%%ItemTitle%%

ImageGear .NET
User Guide

ImageGear® for .NET is the most advanced way to create, control, and deliver more secure, high-quality imaging applications. Using ImageGear, you can easily add powerful imaging capability to your applications. ImageGear supports all of the most commonly used graphics file formats and many more, providing complete compatibility when developing .NET solutions, whether they are Windows Forms applications, WPF applications, ASP.NET Web Forms applications, or ASP.NET Web Service applications across multiple platforms.

ImageGear for .NET features include:

  • Reading and writing 100+ file formats
  • File format conversion
  • Download Manager engine
  • Multi-page images support
  • In-memory access to image pixel data
  • Import pixel data from and export pixel data to the native HDIB
  • Access to image metadata such as XMP, TIFF, EXIF, IPTC and other
  • Metadata update w/o recompressing the image
  • Display and printing
  • Clipboard support
  • Comprehensive image processing
  • Image enhancement
  • Special effects
  • Analysis/correction/manipulation of computer-generated images
  • Color processing: reduction/promotion/dithering
  • ICC color profiles support
  • Thumbnail read and write support
  • Alpha channels support
  • Pantone channels support
  • ROI processing
  • Comprehensive Annotations support: adding/editing/burn-in/deleting
  • Support for Custom Annotation
  • Annotation marks statistics gathered by the area and linear measurements
  • NotateXpress™ annotation format reader
  • Annotation security support
  • TWAIN scanning
  • ISIS scanning
  • Analysis/correction/manipulation of scanned images
  • JPEG 2000 and JPX formats support
  • Dramatic speed enhancement for heavily tiled JPEG 2000 images
  • Native Adobe PDF/PS support
  • Powerful PDF/PS/EPS editing API
  • Native PDF printing
  • PDF XMP metadata support
  • PDF/A-1a and PDF/A-1b verifier support
  • PDF/A-1a and PDF/A-1b support (image only)
  • Native CAD/Vector formats support
  • Microsoft Office Open XML Word support
  • Microsoft Office Open XML Excel support
  • Microsoft Office Open XML PowerPoint support
  • Vector rasterization
  • Vector formats editing API
  • SVG format support
  • 3D image visualization, rendering and isosurface
  • Medical/DICOM format support
  • DICOM image processing
  • DICOM 2011 metadata support
  • DICOM Multi-Planar Reconstruction
  • Comprehensive Digital Camera RAW formats support
  • Headerless RAW format support
  • Optical Character Recognition for Documents (OCR)
  • Asian OCR engine for Simplified Chinese, Standard Chinese, Korean and Japanese languages
  • 2 pre-made voting interfaces - OmniPage and PLUS
  • Direct access to 3 leading OCR engines - MOR, MTX and FireWorX
  • Recognition output to PDF/A
  • Barcode Recognition and Writer technologies
  • Image and Document Clean processing
  • Windows Forms display, annotations and UI support
  • WPF viewer controls with auto-update for display and annotation changes
  • Property binding support in display and annotation API
  • XAML based components that include customizable context menus and configurable toolbar controls with page and annotation mouse tools
  • XAML based thumbnail controls
  • Server-side ASP.NET Web Forms controls
  • Server-side ASP.NET image retrieve and upload RESTful services
  • Client-side ASP.NET controls to display images, annotations and thumbnails in a browser
  • Platform independent client-side ASP.NET controls compatible with jQuery
  • Unlimited product evaluation licensing

The toolkit has native support for all color spaces and bit depths, provides comprehensive handling of color channels, and supports the following bit depths internally: 1, 4, 8-bit gray level, 8i, 9-16-bit gray level, 24, 32, 48, 64. The toolkit can also read all the additional bit depths possible for the file formats ImageGear supports.

With ImageGear for .NET, you are assured of the high quality and performance you expect from Accusoft Corporation, the industry leader in image processing toolkits.

Updated 3/2/2016

©2016. Accusoft Corporation. All Rights Reserved.

Send Feedback


What's New?
User Guide > What's New?

ImageGear .NET v22.0 introduces many usability improvements:

  • The installer has been improved to simplify the Installation process and directory structure.
  • We now provide NuGet Packages to simplify the packaging process. NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework.
  • We've improved our samples:
    • The PDF samples have been revamped, allowing users to quickly find sample code for common real world use cases. These samples also support Microsoft Visual Studio 2015.
    • We've added a new sample images dataset.
    • All of the original samples are also still available.
  • The ImageGear .NET help file...
    • Has been reorganized to help you find content more easily
    • Provides simplified tutorials to help you create a new ImageGear project more quickly, and also new PDF tutorials that guide you through creating an ImageGear project using PDF
    • Provides a new set of File Formats and Compressions tables to help you quickly reference all of the formats supported by ImageGear
    • Provides many new PDF How to... topics to cover common use cases, and re-worked existing PDF content to improve its usability
  • The ImageGear .NET v22.0 release also includes many fixed issues (refer to the Release Notes in the Documentation folder or at Accusoft.com for details).


Getting Started
User Guide > Getting Started

This section provides information about the following:

  • Getting Started
    • System Requirements
    • Installation
    • NuGet Packages
    • Tutorial: Create Your First Project
      • Console Application
      • WinForms Application
      • WPF Application
      • ASP.NET Application
    • Samples
    • Getting Support


System Requirements
User Guide > Getting Started > System Requirements

This section provides information about the system requirements for ImageGear for .NET in the following sub-sections:

  • Operating Systems
  • .NET Frameworks
  • Web Servers and Browsers

Microsoft recommends running Visual Studio with administrator privileges. To properly use the ImageGear Samples, please run Visual Studio with elevated permissions. To run Visual Studio with elevated administrator permissions:

  1. Confirm you are a member of the "Administrators" group on the local machine.
  2. Right-click the Visual Studio shortcut and select the "Run as administrator" option from the context menu.
  3. Click Continue to the UAC prompt.
  4. To ensure you have the latest updates, after running Visual Studio, choose Help > Check for Updates.

Operating Systems

  • Windows Vista 32-bit and 64-bit Editions
  • Windows 7 32-bit and 64-bit Editions
  • Windows 8 32-bit and 64-bit Editions
  • Windows 10 32-bit and 64-bit Editions
  • Windows Server 2003 32-bit, Service Pack 1
  • Windows Server 2003 x64 Edition
  • Windows Server 2008 32-bit and 64-bit Editions
  • Windows Server 2012

.NET Frameworks

Microsoft .NET Framework 2.x, 3.0, 3.5, 4.0.

  • Microsoft .NET Framework 4.0 is required for ASP.NET.
  • Microsoft .NET Framework 3.5 is required for:
    • Vector formats
    • Office formats
    • DICOM format
    • PDF
    • ART
    • Evaluation
    • Presentation
    • Formatted Output feature of the ImageGear Recognition API
    • Windows Forms
    • WPF

Components not mentioned above require Microsoft .NET Framework 2.0 (or higher).

Web Servers and Browsers

ASP.NET functionality is supported on IIS 6.0 and IIS 7.0 with the following browsers:

  • Windows Internet Explorer 9.0, 10.0, and 11.0 (in compatibility mode)
  • Firefox 3.0 - 35.0
  • Chrome 4.0 - 40.0
  • Safari 4.0 - 5.0


Installation
User Guide > Getting Started > Installation

This topic provides information about the following:

  • Installing ImageGear
  • Directory Structure
  • Uninstalling ImageGear

Before installing ImageGear for .NET, make sure that your system complies with the requirements detailed in the System Requirements section.

Installing ImageGear

To install ImageGear, perform the following steps:

  1. Start the installer from the Web:
    1. Click to download. After the download finishes, run the exe.
  2. Click the Next button to continue past the welcome dialog.
  3. Carefully read the information contained in the License Agreement form before making a decision to accept the terms of the agreement. Choose I accept the license agreement to accept the conditions outlined in the License Agreement, and then click the Next button to continue the installation, or click Cancel to exit the installation process.
  4. If you accepted the License Agreement and continued the installation process, the User Information form appears next. Enter your name and the name of your company in the Full Name and Organization text boxes, respectively. Then click Next.
  5. After clicking Next the Destination Directory form is displayed. Choose the destination directory where the ImageGear product should be installed or choose the default installation destination directory. Then click Next.
  6. Once you click the Next button, the product Select Features form is displayed. In this form you can:
    1. Choose the features and namespaces of the selected product to install on your system.
    2. Get information about how much of your hard disk memory is required to install the product features that you have chosen in 6a.
  7. When all these options are chosen, click the Next button to continue the installation process, and then click Finish.

Directory Structure

If you accept the suggested default location, the installation program creates the following directory structure:

For 32-bit:

Directory | Description
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Bin | Assemblies and dependencies. Compiled sample binaries.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Documentation | Documentation.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Licensing\Deployment | Deployment Utility files.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Licensing\LicenseManager | Accusoft License Manager.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Sample Shortcuts | Sample source code, executables, and images.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Resources\Utilities | Utilities.

For 64-bit:

Directory | Description
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Bin | Assemblies and dependencies. Compiled sample binaries.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Documentation | Documentation.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Licensing\Deployment | Deployment Utility files.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Licensing\LicenseManager | Accusoft License Manager.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Sample Shortcuts | Sample source code, executables, and images.
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22 64-bit\Resources\Utilities | Utilities.

Uninstalling ImageGear

To uninstall ImageGear for .NET:

  1. From the Control Panel, open Programs and Features.
  2. Choose Accusoft ImageGear for .NET.
  3. Click Change/Remove.
  4. Select Remove and click Next.


NuGet Packages
User Guide > Getting Started > NuGet Packages

This topic provides information about the following:

  • What are NuGet Packages?
  • Installing NuGet
  • Adding Accusoft NuGet Packages
  • ImageGear for .NET NuGet Packages

What are NuGet Packages?

NuGet is the package manager for the Microsoft development platform that includes .NET. NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework.

To read more about NuGet, please visit nuget.org.

Installing NuGet

Starting with Visual Studio 2012, NuGet is included in every version of Visual Studio (except Team Foundation Server) by default. For Visual Studio 2010, you will need to install the NuGet Extension manually using the Extension Manager.

To check if your copy of Visual Studio already has the NuGet extension, in the Visual Studio Tools menu, look for Library Package Manager (VS2012) or NuGet Package Manager (VS2015).

If your copy of Visual Studio does not already have the Library Package Manager (NuGet) extension, you can install it using the Extension Manager. See https://docs.nuget.org/consume/installing-nuget for details.

Adding Accusoft NuGet Packages

All of our packages can be found at nuget.org, which is the central package repository used by all package authors and consumers. The NuGet Package Manager is configured by default to use nuget.org for packages' sources.

To add NuGet packages into your imaging application:

  1. Open the NuGet Package Manager in Visual Studio using one of the following methods:
    • Tools > Library Package Manager (VS2012) or NuGet Package Manager (VS2015) > Manage NuGet packages for solution
    • Right-click on the project or solution in the Solution Explorer and choose Manage NuGet packages
  2. In the opened window make sure that Package source is set to nuget.org and find the required package from the list of packages. See the ImageGear for .NET NuGet Packages table below to determine which packages to install. If you are unsure which package to use, you can use the ImageGear.All package for evaluation purposes.
  3. After selecting and installing the required package(s), you should see the newly added assemblies in your application's References folder. If your selected package requires native binaries or additional resources, they will be copied to the application's Output directory after building the project.
  4. Add using [namespace]; to any CS/VB file where you want to reference these libraries.

To learn more, we also recommend following the official tutorials available at nuget.org: https://docs.nuget.org/consume/package-manager-dialog

ImageGear for .NET NuGet Packages

Package Dependencies are automatically included; so, for example, if you select the ImageGear.Barcode package, the ImageGear.Core package is also included.

ImageGear .Net NuGet packages are self-sufficient and provide all the necessary functionality for the package they describe. However, if you want to extend the package capabilities with functionality from other packages, you need to install those corresponding packages, too. For example:

  • To use Annotations (ART marks) with Medical (DICOM) files, in addition to installing the ImageGear.Medical.WinForms package, you will also need to install the ImageGear.ART.WinForms package.
  • To work with Recognition (OCR) and PDF files, you will need to install both ImageGear.Recognition and ImageGear.PDF packages.

Package Name

Description

Assemblies

Package Dependencies

ImageGear.All

ImageGear for .NET adds enterprise-class image viewing, compression, image processing and editing functions easily to any application, with support for PDF, more than 100 file formats, and expanded functionality such as optical character recognition (OCR), barcode recognition, and support for medical DICOM images.

All

All

ImageGear.Core

Includes all functionality to work with common files. Also includes Core ImageGear API, Display API, File format manager, general metadata API, and Metadata dictionary API for the file formats.(BMP, ICO, CUR, CLP, PNG, GIF, TIFF and JFIF file formats. CCITT, Deflate, LZW, JPEG compressions. EXIF metadata.)
  • ImageGear22.Core.dll
  • ImageGear22.Evaluation.dll
  • ImageGear22.Formats.Common.dll
  • ImageGear22.Formats.SimplifiedMetadata.dll

Also includes:

  • ig_cmyk_profile.icm
  • ig_rgb_profile.icm
  • igpict1.dll

None

ImageGear.AdvancedProcessing

Advanced Processing including image processing effects and document cleaning API.
  • ImageGear22.Processing.Advanced.dll

ImageGear.Core

ImageGear.ART.WinForms

Includes all functionality to work with WinForms Annotation controls and UI.
  • ImageGear22.Art.dll
  • ImageGear22.Art.Forms.dll

ImageGear.Core

ImageGear.WinForms

ImageGear.ART.WPF

Provides UI controls for use with the Windows Presentation Foundation framework. Also enables HD Photo and XPS file formats, and BitmapSource converters.
  • ImageGear22.Art.dll
  • ImageGear22.Art.Windows.Controls.dll

ImageGear.Core

ImageGear.WPF

ImageGear.Barcode

Provides a set of objects that provides access to barcode recognition technology.
  • ImageGear22.Barcode.dll

ImageGear.Core

ImageGear.CameraRaw

Includes all functionality to work with the following digital camera raw formats: CRW, ORF, PEF, NEF, Adobe DNG, KodakRAW, SonyRaw, LeicaRAW, MOS, MEF, CR2, Imacon Raw, MRW, RAF, Headerless Camera Raw.
  • ImageGear22.Formats.CameraRaw.dll

ImageGear.Core

ImageGear.Formats.Advanced

Includes all functionality to work with the following raster file formats: PSD, PCX, DCX, PCD, PBM, RAS, MSP, Scitex CT, SGI, IFF, WPG, CAL, BTR, IMR, IMT, KFX, LV, NCR, GEM, WBMP, XWD, XBM, XPM, IBM IOCA, IBM MO:DCA, TGA, CUT.
  • ImageGear22.Formats.Advanced.dll

ImageGear.Core

ImageGear.Jpeg2k

Provides support for JPEG 2000 compression and the JPEG 2000 file format.
  • ImageGear22.Formats.Jpeg2k.dll

Also includes:

  • igjpeg2k22nu.dll

ImageGear.Core

ImageGear.Medical.WinForms

Provides functionality to support the end user's interaction and Windows Forms UI for multi-planar reconstruction (MPR).
  • ImageGear22.Dicom.Forms.dll
  • ImageGear22.Formats.Dicom.dll

ImageGear.Core

ImageGear.WinForms

ImageGear.Medical.WPF

Provides functionality to support the end user's interaction and WPF UI for multi-planar reconstruction (MPR).
  • ImageGear22.Formats.Dicom.dll
  • ImageGear22.Windows.Controls.Dicom.dll

ImageGear.Core

ImageGear.WPF

ImageGear.Office

Provides support for Microsoft Office formats.
  • ImageGear22.Formats.Office.dll

Also includes:

  • DocumentFormat.OpenXml.dll

ImageGear.Core

ImageGear.PDF

Includes all functionality to work with Adobe PDF and PostScript file formats, and PDF editing API.
  • ImageGear22.Formats.Pdf.dll
  • ImageGear22.Formats.Vector.dll

Also includes:

  • igpdf22nu.dll
  • APDFL files
  • Resource files

ImageGear.Core

ImageGear.Recognition

Provides a set of objects that provide access to document recognition technology.
  • ImageGear22.Recognition.dll
  • ImageGear22.Recognition.Forms.dll

Also includes:

  • Nuance files

ImageGear.Core

ImageGear.Recognition.Asian

This adds files for Asian OCR feature.

Nuance resource files for Asian support.

ImageGear.Core

ImageGear.Recognition

ImageGear.TWAIN

Provides support for TWAIN scanning API
(32-bit only)
  • ImageGear22.Twain.dll

ImageGear.Core

ImageGear.Vector

Includes all functionality to work with the DWG, DXF, CGM, DGN, DWF, HPGL, SVG, and U3D vector file formats.
  • ImageGear22.Formats.Vector.dll
  • ImageGear22.Presentation.dll

Also includes:

  • igcad21nu.dll
  • igdwf21nu.dll
  • igu3d21nu.dll
  • igvect21nu.dll

ImageGear.Core

ImageGear.Web

Supports easy creation of web-based imaging systems.
  • ImageGear22.Web.dll
  • ImageGear22.Web.ImageDataProcessor.dll
  • ImageGear22.Web.Services.dll

ImageGear.Core

ImageGear.WinForms

Provides a set of objects to simplify development of WinForms based applications.
  • ImageGear22.Windows.Forms.dll

ImageGear.Core

ImageGear.WPF

Provides UI controls for use with the Windows Presentation Foundation framework. Also enables HD Photo and XPS file formats, and BitmapSource converters.
  • ImageGear22.Presentation.dll
  • ImageGear22.Windows.Controls.dll
  • ImageGear22.Wpf.dll

ImageGear.Core


Tutorial: Create Your First Project
User Guide > Getting Started > Tutorial: Create Your First Project

This section provides the following ImageGear .NET tutorials:

  • Tutorial: Create Your First Project
    • Console Application
    • WinForms Application
    • WPF Application
    • ASP.NET Application

We've also provided separate tutorials to help you get started using ImageGear's PDF capabilities:

  • PDF Tutorials


Console Application
User Guide > Getting Started > Tutorial: Create Your First Project > Console Application

In this tutorial, you will configure a C# or VB.NET project for a console application and use ImageGear .NET capabilities. You will also learn how to load an image, then resize and convert it to a new format.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "Console Application" project, using C# or VB.NET and name the project: IG_Tutorial_Console.
  2. If you installed ImageGear .NET 64-bit, using the Configuration Manager, create a new project platform (if you don't have one already) for x64. Make sure your project is set to compile targeting Debug and x64. Make sure you now have $YOURLOCALPROJ\bin\x64\Debug\, and if is not there, create it.
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following package:
      Accusoft.ImageGear.Core.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.Core/)
    • Manually:
      1. Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      2. Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Evaluation.dll
        • ImageGear22.Formats.Common.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\

  4. At this point your project is ready for some code. The following code can be used to load an image, resize it to a 150 x 150 dimension, and convert it to another format specified by the user. In the next step, we will go over some areas of this sample code in more detail.
    • CS
    • VBNET
    C#
    Copy Code
    using System;
using System.IO;

using ImageGear.Core;
using ImageGear.Evaluation;
using ImageGear.Formats;
using ImageGear.Processing;
using ImageGear.Display;

namespace IG_Tutorial_Console
{
   class Program
   {
static void Main(string[] args)
{
// Initialize license for a Deployment(Runtime) license.
//***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
//methods must be called to distribute the runtime.***
//ImGearLicense.SetSolutionName("YourSolutionName");
//ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
//Manually Reported Runtime licenses also require the following method
//call to SetOEMLicenseKey.
//ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

// Initialize evaluation license.
ImGearEvaluationManager.Initialize();

// Initialize common formats.
ImGearCommonFormats.Initialize();

Console.WriteLine("Enter the complete path to the image to be converted:");
string fileName = Console.ReadLine();

Console.WriteLine("Enter the format for the new image among BMP|GIF|JPG|PNG|TIFF:");
string newFormat = Console.ReadLine();

try
   {
    using (FileStream stream = new FileStream(fileName, FileMode.Open, FileAccess.Read, FileShare.Read))
    {
 try
 {

 // Load the image into the page.
 ImGearPage imGearPage = ImGearFileFormats.LoadPage(stream, 0);

 // Resize the image to the width and height specified.
 // ImGearInterpolations.BILINEAR is the value indicating the type of interpolation employed.
 // It may be changed for other values, e.g. ImGearInterpolations.BICUBIC, ImGearInterpolations.NEAREST_NEIGHBOR.
 ImGearProcessing.Resize(imGearPage, 150, 150, ImGearInterpolationOptions.GetDefault(ImGearInterpolations.BILINEAR));

 string outputFileName = fileName.Substring(0,fileName.LastIndexOf('\\') + 1) + "out.";

 // Indicate the format used when saving the image.
 // It may be changed for other values, e.g. ImGearSavingFormats.JPG, ImGearSavingFormats.PNG.
 ImGearSavingFormats savingFormat = ImGearSavingFormats.UNKNOWN;

 // Identify the format selected.
 switch (newFormat)
 {

     case "BMP":
  outputFileName += "bmp";
  savingFormat = ImGearSavingFormats.BMP_UNCOMP;
  break;
     case "GIF":
  outputFileName += "gif";
  savingFormat = ImGearSavingFormats.GIF;
  break;
     case "JPG":
  outputFileName += "jpg";
  savingFormat = ImGearSavingFormats.JPG;
  break;
     case "PNG":
  outputFileName += "png";
  savingFormat = ImGearSavingFormats.PNG;
  break;
     case "TIFF":
  outputFileName += "tiff";
  savingFormat = ImGearSavingFormats.TIF_UNCOMP;
  break;
     default:
  Console.WriteLine("Unsupported format.");
  break;
 }

 if (savingFormat != ImGearSavingFormats.UNKNOWN)
 {
     using (FileStream imGearConverted = new FileStream(outputFileName, FileMode.Create))
     {
  // Save the image to the format selected.
  ImGearFileFormats.SavePage(imGearPage, imGearConverted, 1, ImGearSavingModes.OVERWRITE, savingFormat, new ImGearSaveOptions());
     }

     Console.WriteLine("Conversion successful.");
 }

 }
 catch (ImGearException ex)
 {
 Console.WriteLine("Conversion failed: " + ex.Message);
 }
    }
   }
   catch (Exception)
   {
    Console.WriteLine("Incorrect path to an image file.");
   }
Console.ReadLine();

}

   }
}
    VB.NET
    Copy Code
    Imports System
Imports System.IO

Imports ImageGear.Core
Imports ImageGear.Evaluation
Imports ImageGear.Formats
Imports ImageGear.Processing
Imports ImageGear.Display

Module Module1

   Sub Main()
' Initialize license for a Deployment(Runtime) license.
'***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
'methods must be called to distribute the runtime.***
'ImGearLicense.SetSolutionName("YourSolutionName");
'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
'Manually Reported Runtime licenses also require the following method
'call to SetOEMLicenseKey.
'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

'Initialize evaluation license.
ImGearEvaluationManager.Initialize()

'Initialize common formats.
ImGearCommonFormats.Initialize()

Console.WriteLine("Enter the complete path to the image to be converted:")
Dim fileName As String = Console.ReadLine()

Console.WriteLine("Enter the format for the new image among BMP|GIF|JPG|PNG|TIFF:")
Dim newFormat As String = Console.ReadLine()

Try
Using stream As New FileStream(fileName, FileMode.Open, FileAccess.Read, FileShare.Read)
    Try
 ' Load the image into the page.
 Dim imGearPage As ImGearPage = ImGearFileFormats.LoadPage(stream, 0)

 ' Resize the image to the width and height specified.
 ' ImGearInterpolations.BILINEAR is the value indicating the type of interpolation employed.
 ' It may be changed for other values, e.g. ImGearInterpolations.BICUBIC, ImGearInterpolations.NEAREST_NEIGHBOR.
 ImGearProcessing.Resize(imGearPage, 150, 150, ImGearInterpolationOptions.GetDefault(ImGearInterpolations.BILINEAR))

 Dim outputFileName As String = fileName.Substring(0, fileName.LastIndexOf("\") + 1) + "out."

 ' Indicate the format used when saving the image.
 ' It may be changed for other values, e.g. ImGearSavingFormats.JPG, ImGearSavingFormats.PNG.
 Dim savingFormat As ImGearSavingFormats = ImGearSavingFormats.UNKNOWN

 ' Identify the format selected.
 Select Case newFormat
 Case "BMP"
     outputFileName += "bmp"
     savingFormat = ImGearSavingFormats.BMP_UNCOMP
 Case "GIF"
     outputFileName += "gif"
     savingFormat = ImGearSavingFormats.GIF
 Case "JPG"
     outputFileName += "jpg"
     savingFormat = ImGearSavingFormats.JPG
 Case "PNG"
     outputFileName += "png"
     savingFormat = ImGearSavingFormats.PNG
 Case "TIFF"
     outputFileName += "tiff"
     savingFormat = ImGearSavingFormats.TIF_UNCOMP
 End Select

 If Not savingFormat = ImGearSavingFormats.UNKNOWN Then
 Using imGearConverted As FileStream = New FileStream(outputFileName, FileMode.Create)
     ' Save the image to the format selected.
     ImGearFileFormats.SavePage(imGearPage, imGearConverted, 1, ImGearSavingModes.OVERWRITE, savingFormat, New ImGearSaveOptions())
     Console.WriteLine("Conversion successful.")
 End Using
 Else
 Console.WriteLine("Unsupported format.")
 End If

    Catch ex As Exception
 Console.WriteLine("Conversion failed: " + ex.Message)
    End Try

End Using

Catch ex As Exception
Console.WriteLine("Incorrect path to an image file.")
End Try

Console.ReadLine()

   End Sub

End Module
  5. If you are using a Deployment (Runtime) licensing, add the license initialization code. This is not necessary if you are using an Evaluation or Development (Toolkit) license. Please add the ImGearEvaluationManager.Initialize() call if you are evaluating the product.
    • CS
    • VBNET
    C#
    Copy Code
    // Initialize license for a Deployment(Runtime) license.
//***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
//methods must be called to distribute the runtime.***
//ImGearLicense.SetSolutionName("YourSolutionName");
//ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
//Manually Reported Runtime licenses also require the following method
//call to SetOEMLicenseKey.
//ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

// Initialize evaluation license.
ImGearEvaluationManager.Initialize();

// Initialize common formats.
ImGearCommonFormats.Initialize();
    VB.NET
    Copy Code
    ' Initialize license for a Deployment(Runtime) license.
'***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
'methods must be called to distribute the runtime.***
'ImGearLicense.SetSolutionName("YourSolutionName");
'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
'Manually Reported Runtime licenses also require the following method
'call to SetOEMLicenseKey.
'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

'Initialize evaluation license.
ImGearEvaluationManager.Initialize()

'Initialize common formats.
ImGearCommonFormats.Initialize()
  6. We load the image using:
    • CS
    • VBNET
    C#
    Copy Code
    // Load the image into the page.
ImGearPage imGearPage = ImGearFileFormats.LoadPage(stream, 0);
    VB.NET
    Copy Code
    ' Load the image into the page.
Dim imGearPage As ImGearPage = ImGearFileFormats.LoadPage(stream, 0)
  7. We resize the image by defining the width, the height, and the interpolation approach as follows:
    • CS
    • VBNET
    C#
    Copy Code
    // Resize the image to the width and height specified.
// ImGearInterpolations.BILINEAR is the value indicating the type of interpolation employed.
// It may be changed for other values, e.g. ImGearInterpolations.BICUBIC, ImGearInterpolations.NEAREST_NEIGHBOR.
ImGearProcessing.Resize(imGearPage, 150, 150, ImGearInterpolationOptions.GetDefault(ImGearInterpolations.BILINEAR));
    VB.NET
    Copy Code
    ' Resize the image to the width and height specified.
' ImGearInterpolations.BILINEAR is the value indicating the type of interpolation employed.
' It may be changed for other values, e.g. ImGearInterpolations.BICUBIC, ImGearInterpolations.NEAREST_NEIGHBOR.
ImGearProcessing.Resize(imGearPage, 150, 150, ImGearInterpolationOptions.GetDefault(ImGearInterpolations.BILINEAR))
  8. Finally, we save the image based on the savingFormat specified:
    • CS
    • VBNET
    C#
    Copy Code
    // Save the image to the format selected.
ImGearFileFormats.SavePage(imGearPage, imGearConverted, 1, ImGearSavingModes.OVERWRITE, savingFormat, new ImGearSaveOptions());
    VB.NET
    Copy Code
    ' Save the image to the format selected.
ImGearFileFormats.SavePage(imGearPage, imGearConverted, 1, ImGearSavingModes.OVERWRITE, savingFormat, New ImGearSaveOptions())


WinForms Application
User Guide > Getting Started > Tutorial: Create Your First Project > WinForms Application

In this tutorial, you will configure a C# or VB.NET project for a Windows Forms application and use ImageGear .NET capabilities. You will also learn how to load a document, then view, zoom, and rotate it.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "Windows Forms Application" project, using C# or VB.NET and name the project: IG_Tutorial_WinForms.
  2. If you installed IG NET 64-bit, using the Configuration Manager, create a new project platform (if you don’t have one already) for x64. Make sure your project is set to compile targeting Debug and x64. Make sure you now have $YOURLOCALPROJ\bin\x64\Debug\, and if is not there, create it.
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following packages:
      Accusoft.ImageGear.WinForms.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WinForms/)
    • Manually:
      1. Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      2. Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Evaluation.dll
        • ImageGear22.Formats.Common.dll
        • ImageGear22.Windows.Forms.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\

  4. Next, add the ImageGear Windows Forms tools to use in your GUI:
    1. In your Visual Studio menu, go to Tools > Choose Toolbox Items...
    2. In the .NET Framework Components tab, click the Browse button.
    3. Navigate to $INSTALLDIR\ImageGear for .NET v22\Bin\, select ImageGear22.Windows.Forms.dll, and click Open.
    4. You will see the ImGearMagnifier, ImGearPageView, ImGearPan, and ImGearThumbnailCtl controls added to the list of components. Make sure they are checked and click OK.
  5. Next, you will add some pertinent controls to your form. For this tutorial, keep the default names for the controls:
    1. First, create a menu on the form. From the Windows Forms toolbox, drag a MenuStrip control onto the form:
      1. Create three MenuItems called File, View, and Processing.
      2. Under the File menu, add Load Page
      3. Under the View menu, add Zoom In and Zoom Out.
      4. Under the Processing menu, add Rotate 90.
      5. Double-click each added menu item to create a Click Event Handler.
    2. Second, also from the toolbox, drag the ImGearPageView control onto the form. This control will be used to display the document loaded. Set the Dock (in the Layout group) property of the imGearPageView1 control to Fill. This will cause the control to resize as the form resizes.
  6. At this point your project is ready for some code. The following code can be used to load a document, view it using an ImGearPageView control, zoom in/zoom out on it and rotate it. In the next step, we will go over some areas of this sample code in more detail.
    • CS
    • VBNET
    C#
    Copy Code
    using System;
using System.Windows.Forms;
using System.IO;
using System.Diagnostics;

using ImageGear.Core;
using ImageGear.Display;
using ImageGear.Processing;
using ImageGear.Formats;
using ImageGear.Evaluation;

namespace IG_Tutorial_WinForms
{
   public partial class Form1 : Form
   {

       // Hold the image data.
       private ImGearPage imGearPage = null;
       // Control how the page is displayed.
       private ImGearPageDisplay imGearPageDisplay = null;

       public Form1()
       {
           // Initialize license for a Deployment(Runtime) license.
           //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
           //methods must be called to distribute the runtime.***
           //ImGearLicense.SetSolutionName("YourSolutionName");
           //ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
           //Manually Reported Runtime licenses also require the following method
           //call to SetOEMLicenseKey.
           //ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();

           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           InitializeComponent();
       }

       private void loadPageToolStripMenuItem_Click(object sender, EventArgs e)
       {
           OpenFileDialog openFileDialog1 = new OpenFileDialog();
           openFileDialog1.Filter =
           ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.UNKNOWN);

           if (DialogResult.OK == openFileDialog1.ShowDialog())
           {
               using (FileStream stream =
                   new FileStream(openFileDialog1.FileName, FileMode.Open,
                       FileAccess.Read, FileShare.Read))
               {
                   try
                   {
                       // Load the image into the page.
                       imGearPage = ImGearFileFormats.LoadPage(stream, 0);
                   }
                   catch (ImGearException ex)
                   {
                       Debug.WriteLine(ex.Message);
                   }
               }
               if (null != imGearPage && null != imGearPage.DIB &&
               !imGearPage.DIB.IsEmpty())
               {
                   // Create a new page display.
                   imGearPageDisplay = new ImGearPageDisplay(imGearPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = imGearPageDisplay;
                   // Cause the page view to repaint.
                   imGearPageView1.Invalidate();
               }
           }
       }

       private void zoomInToolStripMenuItem_Click(object sender, EventArgs e)
       {
           if (null != imGearPageDisplay && !imGearPageDisplay.Page.DIB.IsEmpty())
           {
               // Get the current zoom info.
               ImGearZoomInfo igZoomInfo = imGearPageDisplay.GetZoomInfo(imGearPageView1);

               // Increase the zoom.
               igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25;
               igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25;
               igZoomInfo.Horizontal.Fixed = true;
               igZoomInfo.Vertical.Fixed = true;

               // Set the new zoom values and repaint the view.
               imGearPageDisplay.UpdateZoomFrom(igZoomInfo);
               imGearPageView1.Invalidate();
           }
       }

       private void zoomOutToolStripMenuItem_Click(object sender, EventArgs e)
       {
           if (null != imGearPageDisplay && !imGearPageDisplay.Page.DIB.IsEmpty())
           {
               // Get the current zoom info.
               ImGearZoomInfo igZoomInfo = imGearPageDisplay.GetZoomInfo(imGearPageView1);

               igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * (1 / 1.25);
               igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * (1 / 1.25);
               igZoomInfo.Horizontal.Fixed = true;
               igZoomInfo.Vertical.Fixed = true;
               // Set the new zoom values and repaint the view.
               imGearPageDisplay.UpdateZoomFrom(igZoomInfo);
               imGearPageView1.Invalidate();
           }
       }

       private void rotate90ToolStripMenuItem_Click(object sender, EventArgs e)
       {
           if (null != imGearPageDisplay && null != imGearPage && !imGearPageDisplay.Page.DIB.IsEmpty())
           {
               try
               {
                   // Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
                   // ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
                   // It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
                   ImGearProcessing.Rotate(imGearPage, ImGearRotationValues.VALUE_90);
                   imGearPageView1.Invalidate();
               }
               catch (ImGearException ex)
               {
                   Debug.WriteLine(ex.Message);
               }
           }
       }

   }
}
    VB.NET
    Copy Code
    Imports System.IO
Imports System.Diagnostics

Imports ImageGear
Imports ImageGear.Core
Imports ImageGear.Windows.Forms
Imports ImageGear.Display
Imports ImageGear.Processing
Imports ImageGear.Formats
Imports ImageGear.Evaluation

Public Class Form1

   ' Hold the image data.
   Private igPage As ImGearPage
   ' Control how the page is displayed.
   Private igPageDisplay As ImGearPageDisplay

   Public Sub New()

       ' Initialize license for a Deployment(Runtime) license.
       '***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
       'methods must be called to distribute the runtime.***
       'ImGearLicense.SetSolutionName("YourSolutionName");
       'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
       'Manually Reported Runtime licenses also require the following method
       'call to SetOEMLicenseKey.
       'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

       'Initialize evaluation license.
       ImGearEvaluationManager.Initialize()

       'Initialize common formats.
       ImGearCommonFormats.Initialize()

       ' This call is required by the designer.
       InitializeComponent()

   End Sub

   Private Sub LoadPageToolStripMenuItem_Click(sender As System.Object, e As System.EventArgs) Handles LoadPageToolStripMenuItem.Click
       Dim openFileDialog1 As New OpenFileDialog
       openFileDialog1.Filter = "All files (*.*)|*.*"
       openFileDialog1.FilterIndex = 1
       openFileDialog1.RestoreDirectory = True
       If openFileDialog1.ShowDialog = DialogResult.OK Then
           Using stream As New FileStream(openFileDialog1.FileName, FileMode.Open, FileAccess.Read)
               Try
                   ' Load the image into the page.
                   igPage = ImGearFileFormats.LoadPage(stream, 0)
               Catch ex As ImGearException
                   Debug.WriteLine(ex.Message)
               End Try
               If Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing Then
                   ' Create a new page display.
                   igPageDisplay = New ImGearPageDisplay(igPage)
                   ' Associate the page display with the page view.
                   ImGearPageView1.Display = igPageDisplay
                   ' Cause the page view to repaint.
                   ImGearPageView1.Invalidate()
               End If
           End Using
       End If
   End Sub

   Private Sub ZoomInToolStripMenuItem_Click(sender As System.Object, e As System.EventArgs) Handles ZoomInToolStripMenuItem.Click
       If Not igPageDisplay Is Nothing AndAlso Not igPageDisplay.Page.DIB.IsEmpty() Then
           ' Get the current zoom info.
           Dim igZoomInfo As ImGearZoomInfo
           igZoomInfo = igPageDisplay.GetZoomInfo(ImGearPageView1)
           ' Increase the zoom.
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25
           igZoomInfo.Horizontal.Fixed = True
           igZoomInfo.Vertical.Fixed = True
           ' Set the new zoom values and repaint the view.
           igPageDisplay.UpdateZoomFrom(igZoomInfo)
           ImGearPageView1.Invalidate()
       End If
   End Sub

   Private Sub ZoomOutToolStripMenuItem_Click(sender As System.Object, e As System.EventArgs) Handles ZoomOutToolStripMenuItem.Click
       If Not igPageDisplay Is Nothing AndAlso Not igPageDisplay.Page.DIB.IsEmpty() Then
           ' Get the current zoom info.
           Dim igZoomInfo As ImGearZoomInfo
           igZoomInfo = igPageDisplay.GetZoomInfo(ImGearPageView1)
           ' Decrease the zoom.
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value / 1.25
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value / 1.25
           igZoomInfo.Horizontal.Fixed = True
           igZoomInfo.Vertical.Fixed = True
           ' Set the new zoom values and repaint the view.
           igPageDisplay.UpdateZoomFrom(igZoomInfo)
           ImGearPageView1.Invalidate()
       End If
   End Sub

   Private Sub Rotate90ToolStripMenuItem_Click(sender As System.Object, e As System.EventArgs) Handles Rotate90ToolStripMenuItem.Click
       If Not igPage Is Nothing Then
           Try
               ' Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
               ' ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
               ' It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
               ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90)
           Catch ex As Exception
               Console.WriteLine(ex.Message)
           End Try
           ImGearPageView1.Invalidate()
       End If
   End Sub
End Class
  7. If you are using a Deployment (Runtime) licensing, add the license initialization code to the Form1 constructor. This is not necessary if you are using an Evaluation or Development (Toolkit) license. Please add the ImGearEvaluationManager.Initialize() call if you are evaluating the product.
    • CS
    • VBNET
    C#
    Copy Code
           public Form1()
       {
           // Initialize license for a Deployment(Runtime) license.
           //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
           //methods must be called to distribute the runtime.***
           //ImGearLicense.SetSolutionName("YourSolutionName");
           //ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
           //Manually Reported Runtime licenses also require the following method
           //call to SetOEMLicenseKey.
           //ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();

           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           InitializeComponent();
       }
    VB.NET
    Copy Code
       Public Sub New()

       ' Initialize license for a Deployment(Runtime) license.
       '***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
       'methods must be called to distribute the runtime.***
       'ImGearLicense.SetSolutionName("YourSolutionName");
       'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
       'Manually Reported Runtime licenses also require the following method
       'call to SetOEMLicenseKey.
       'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

       'Initialize evaluation license.
       ImGearEvaluationManager.Initialize()

       'Initialize common formats.
       ImGearCommonFormats.Initialize()

       ' This call is required by the designer.
       InitializeComponent()

   End Sub
  8. Load and display a document using:
    • CS
    • VBNET
    C#
    Copy Code
               OpenFileDialog openFileDialog1 = new OpenFileDialog();
           openFileDialog1.Filter =
           ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.UNKNOWN);

           if (DialogResult.OK == openFileDialog1.ShowDialog())
           {
               using (FileStream stream =
                   new FileStream(openFileDialog1.FileName, FileMode.Open,
                       FileAccess.Read, FileShare.Read))
               {
                   try
                   {
                       // Load the image into the page.
                       imGearPage = ImGearFileFormats.LoadPage(stream, 0);
                   }
                   catch (ImGearException ex)
                   {
                       Debug.WriteLine(ex.Message);
                   }
               }
               if (null != imGearPage && null != imGearPage.DIB &&
               !imGearPage.DIB.IsEmpty())
               {
                   // Create a new page display.
                   imGearPageDisplay = new ImGearPageDisplay(imGearPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = imGearPageDisplay;
                   // Cause the page view to repaint.
                   imGearPageView1.Invalidate();
               }
           }
    VB.NET
    Copy Code
           Dim openFileDialog1 As New OpenFileDialog
       openFileDialog1.Filter = "All files (*.*)|*.*"
       openFileDialog1.FilterIndex = 1
       openFileDialog1.RestoreDirectory = True
       If openFileDialog1.ShowDialog = DialogResult.OK Then
           Using stream As New FileStream(openFileDialog1.FileName, FileMode.Open, FileAccess.Read)
               Try
                   ' Load the image into the page.
                   igPage = ImGearFileFormats.LoadPage(stream, 0)
               Catch ex As ImGearException
                   Debug.WriteLine(ex.Message)
               End Try
               If Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing Then
                   ' Create a new page display.
                   igPageDisplay = New ImGearPageDisplay(igPage)
                   ' Associate the page display with the page view.
                   ImGearPageView1.Display = igPageDisplay
                   ' Cause the page view to repaint.
                   ImGearPageView1.Invalidate()
               End If
           End Using
       End If
  9. Execute the Zoom In operation as follows:
    • CS
    • VBNET
    C#
    Copy Code
               if (null != imGearPageDisplay && !imGearPageDisplay.Page.DIB.IsEmpty())
           {
               // Get the current zoom info.
               ImGearZoomInfo igZoomInfo = imGearPageDisplay.GetZoomInfo(imGearPageView1);

               // Increase the zoom.
               igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25;
               igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25;
               igZoomInfo.Horizontal.Fixed = true;
               igZoomInfo.Vertical.Fixed = true;

               // Set the new zoom values and repaint the view.
               imGearPageDisplay.UpdateZoomFrom(igZoomInfo);
               imGearPageView1.Invalidate();
           }
    VB.NET
    Copy Code
           If Not igPageDisplay Is Nothing AndAlso Not igPageDisplay.Page.DIB.IsEmpty() Then
           ' Get the current zoom info.
           Dim igZoomInfo As ImGearZoomInfo
           igZoomInfo = igPageDisplay.GetZoomInfo(ImGearPageView1)
           ' Increase the zoom.
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25
           igZoomInfo.Horizontal.Fixed = True
           igZoomInfo.Vertical.Fixed = True
           ' Set the new zoom values and repaint the view.
           igPageDisplay.UpdateZoomFrom(igZoomInfo)
           ImGearPageView1.Invalidate()
       End If

    Similarly, we can perform Zoom Out by just modifying the multiplier of the Horizontal and Vertical values as (1/1.25). See Zoom Out Click Event Handler.

  10. Finally, rotate the page displayed with:
    • CS
    • VBNET
    C#
    Copy Code
               if (null != imGearPageDisplay && null != imGearPage && !imGearPageDisplay.Page.DIB.IsEmpty())
           {
               try
               {
                   // Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
                   // ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
                   // It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
                   ImGearProcessing.Rotate(imGearPage, ImGearRotationValues.VALUE_90);
                   imGearPageView1.Invalidate();
               }
               catch (ImGearException ex)
               {
                   Debug.WriteLine(ex.Message);
               }
           }
    VB.NET
    Copy Code
           If Not igPage Is Nothing Then
           Try
               ' Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
               ' ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
               ' It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
               ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90)
           Catch ex As Exception
               Console.WriteLine(ex.Message)
           End Try
           ImGearPageView1.Invalidate()
       End If

    Notice that for performing 180 and 270 degree rotations, we simply change the second parameter of the Rotate method to ImGearRotationValues.VALUE_180 and ImGearRotationValues.VALUE_270, respectively.


WPF Application
User Guide > Getting Started > Tutorial: Create Your First Project > WPF Application

In this tutorial, you will configure a C# or VB.NET project for a WPF application and use ImageGear .NET capabilities. You will also learn how to zoom in/out and rotate a file that is loaded.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "WPF Application" project, using C# or VB.NET and name the project: IG_Tutorial_WPF.
  2. If you installed ImageGear .NET 64-bit, using the Configuration Manager, create a new project platform (if you don't have one already) for Any CPU. Make sure your project is set to compile targeting $YOURLOCALPROJ\bin\Debug\ (create this location if you don't have it) and Any CPU.

    If you are using ImageGear .NET 64-bit, we suggest that you set your project to be compiled for Any CPU because there might be some conflicts within the design view when set to x64 due to the custom variables that are created for this sample.

  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following packages:
      Accusoft.ImageGear.WPF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WPF/)
      Accusoft.ImageGear.WinForms.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WinForms/)
    • Manually:
      1. Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      2. Manually add the reference System.Windows.Forms to your project from the .NET Assemblies tab.
      3. Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Art.dll
        • ImageGear22.Evaluation.dll
        • ImageGear22.Formats.Common.dll
        • ImageGear22.Presentation.dll
        • ImageGear22.Windows.Controls.dll
        • ImageGear22.Windows.Forms.dll
        • ImageGear22.Wpf.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\

  4. Open the MainWindow.xaml screen with both the Design and XAML panels for the window visible. You will use the XAML panel to create the graphical user interface. First, in the XAML panel, create a custom alias namespace. So, add some code to the header so it looks like this:
    XAML
    Copy Code

    <Window x:Class="IG_Tutorial_WPF.MainWindow"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:custom="clr-namespace:IG_Tutorial_WPF"
    xmlns:IGWC="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"
    Title="MainWindow" Height="300" Width="300">
    </Window>

  5. For organizational purposes, we will use a Grid. Inside of that Grid we will have a Menu. That Menu will have a File > Open item that will be responsible for opening a file, View > Zoom In | Zoom Out for zoom in/out on the file loaded and Processing > Rotate 90 for rotating the file loaded. To finish the GUI, we also need a PageView control, which will be used to display the file. After adding these controls, the XAML code should result in the following:
    XAML
    Copy Code

    <Window x:Class="IG_Tutorial_WPF.MainWindow"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:custom="clr-namespace:IG_Tutorial_WPF"
    xmlns:IGWC="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"
    Title="MainWindow" Height="300" Width="300">

    <Window.CommandBindings>
    <CommandBinding
    Command="Open"
    Executed="OpenExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.ZoomInCmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ZoomInExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.ZoomOutCmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ZoomOutExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.Rotate90Cmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ExectutedRotate90"/>
    </Window.CommandBindings>

    <Grid>
    <DockPanel Name="DockPanel1">
    <Menu DockPanel.Dock="Top" Height="22" Name="menu1">
    <MenuItem Name="mnuFile" Header="_File">
    <MenuItem Name="mnuFileOpen" Header="_Open" Command="Open"/>
    </MenuItem>
    <MenuItem Name="mnuView" Header="_View">
    <MenuItem Name="mnuViewZoomIn" Header="Zoom _In" Command="{x:Static custom:MainWindow.ZoomInCmd}"/>
    <MenuItem Name="mnuViewZoomOut" Header="Zoom _Out" Command="{x:Static custom:MainWindow.ZoomOutCmd}"/>
    </MenuItem>
    <MenuItem Name="mnuProcessing" Header="_Processing">
    <MenuItem Name="mnuProcessingRot90" Header="Rotate 90" Command="{x:Static custom:MainWindow.Rotate90Cmd}"/>
    </MenuItem>
    </Menu>
    <IGWC:PageView x:Name="imGearPageView1"/>
    </DockPanel>
    </Grid>
    </Window>

  6. Each Command Binding entry will have its own handler for Executed, but all of the them will share a single handler for CanExecute. Right-click over each handler created and navigate to its definition in the .xaml.cs file. In the case of CanExecute, you can navigate to its definition through any of the controls.
  7. Next, add the functionality to the controls in the MainWindow.xaml.cs file:
    1. First, add some using statements and declare the some members required for this project.
    2. Second, declare the static RoutedCommands required for the controls created.
    3. Third, two member variables will need to be added to the class: ImGearPage to hold the image data and ImGearPageDisplay that will control the ways it is shown.
    4. Finally, add the code for the commands that will be executed by each control.

    The body of the MainWindow class should look like this:

    • CS
    • VBNET
    C#
    Copy Code
    using System.Windows;
using System.Windows.Input;
using System.IO;
using System.Windows.Forms;
using System.Diagnostics;

using ImageGear;
using ImageGear.ART;
using ImageGear.Core;
using ImageGear.Display;
using ImageGear.Windows.Forms;
using ImageGear.Windows.Controls;
using ImageGear.Processing;
using ImageGear.Formats;
using ImageGear.WPF;
using ImageGear.WPF.HDP;
using ImageGear.Evaluation;

namespace IG_Tutorial_WPF
{

   public partial class MainWindow : Window
   {
       public static RoutedCommand ZoomInCmd = new RoutedCommand();
       public static RoutedCommand ZoomOutCmd = new RoutedCommand();
       public static RoutedCommand Rotate90Cmd = new RoutedCommand();

       // Hold the image data.
       ImGearPage igPage = null;
       // Control how the page is displayed.
       ImGearPresentationPageDisplay igPageDisplay = null;

       public MainWindow()
       {
           // Initialize license for a Deployment(Runtime) license.
           //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
           //methods must be called to distribute the runtime.***
           //ImGearLicense.SetSolutionName("YourSolutionName");
           //ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
           //Manually Reported Runtime licenses also require the following method
           //call to SetOEMLicenseKey.
           //ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();

           // Insert the HD Photo format held by the IGWPF component.
           ImGearFileFormats.Filters.Insert(0, ImGearHDPhoto.CreateHDPhotoFormat());
           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           InitializeComponent();
       }

       private void OpenExecuted(object sender, ExecutedRoutedEventArgs e)
       {
           ImGearLoadingSelection selection = ImGearWinForms.SelectLocalFileToLoad(null, "Select File");
           if (null != selection)
           {
               using (FileStream fileContent = ((ImGearLocalFile)
                  selection.File).OpenToRead())
               {
                   try
                   {
                       igPage = ImGearFileFormats.LoadPage(fileContent, 0);
                   }
                   catch (ImGearException ex)
                   {
                       Debug.WriteLine(ex.Message);
                   }
               }
               if (null != igPage && null != igPage.DIB &&
                   !igPage.DIB.IsEmpty())
               {
                   // Create a new page display.
                   igPageDisplay = new ImGearPresentationPageDisplay(igPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay;
                   // Cause the page view to update.
                   imGearPageView1.Update();
               }
           }
       }

       private void ZoomInExecuted(object sender, ExecutedRoutedEventArgs e)
       {
           // Get the current zoom info.
           ImGearZoomInfo igZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1);
           // Increase the zoom.
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25;
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25;
           igZoomInfo.Horizontal.Fixed = true;
           igZoomInfo.Vertical.Fixed = true;
           // Set the new zoom values.
           igPageDisplay.UpdateZoomFrom(igZoomInfo);
           // Trigger an update, letting it know only the layout has changed.
           imGearPageView1.Update(true);

       }

       private void ZoomOutExecuted(object sender, ExecutedRoutedEventArgs e)
       {
           // Get the current zoom info.
           ImGearZoomInfo igZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1);
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * (1 / 1.25);
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * (1 / 1.25);
           igZoomInfo.Horizontal.Fixed = true;
           igZoomInfo.Vertical.Fixed = true;
           // Set the new zoom values.
           igPageDisplay.UpdateZoomFrom(igZoomInfo);
           // Trigger an update, letting it know only the layout has changed.
           imGearPageView1.Update(true);
       }

       private void ExectutedRotate90(object sender, ExecutedRoutedEventArgs e)
       {
           try
           {
               // Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
               // ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
               // It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
               ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90);
               imGearPageView1.Update();
           }
           catch (ImGearException ex)
           {
               Debug.WriteLine(ex.Message);
           }

       }

       private void CanExectutePageAvailable(object sender, CanExecuteRoutedEventArgs e)
       {
           e.CanExecute = (null != igPage && null != igPage.DIB
               && !igPage.DIB.IsEmpty() && null != igPageDisplay);
       }

   }
}
    VB.NET
    Copy Code
    Imports System.Windows
Imports System.Windows.Input
Imports System.IO
Imports System.Windows.Forms
Imports System.Diagnostics

Imports ImageGear
Imports ImageGear.ART
Imports ImageGear.Core
Imports ImageGear.Display
Imports ImageGear.Windows.Forms
Imports ImageGear.Windows.Controls
Imports ImageGear.Processing
Imports ImageGear.Formats
Imports ImageGear.WPF
Imports ImageGear.WPF.HDP
Imports ImageGear.Evaluation

Class MainWindow

   Public Shared ZoomInCmd As New RoutedCommand()
   Public Shared ZoomOutCmd As New RoutedCommand()
   Public Shared Rotate90Cmd As New RoutedCommand()

   ' Hold the image data.
   Private igPage As ImGearPage
   ' Control how the page is displayed.
   Private igPageDisplay As ImGearPresentationPageDisplay

   Public Sub New()

       ' Initialize license for a Deployment(Runtime) license.
       '***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
       'methods must be called to distribute the runtime.***
       'ImGearLicense.SetSolutionName("YourSolutionName");
       'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
       'Manually Reported Runtime licenses also require the following method
       'call to SetOEMLicenseKey.
       'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

       'Initialize evaluation license.
       ImGearEvaluationManager.Initialize()

       'Initialize common formats.
       ImGearCommonFormats.Initialize()

       ' This call is required by the designer.
       InitializeComponent()

   End Sub

   Private Sub OpenExecuted(sender As Object, e As ExecutedRoutedEventArgs)
       Dim selection As ImGearLoadingSelection = ImGearWinForms.SelectLocalFileToLoad(Nothing, "Select File")
       If Not selection Is Nothing Then
           Dim localFile As ImGearLocalFile = selection.File
           Using fileContent As FileStream = localFile.OpenToRead()
               Try
                   ' Load the image into the page.
                   igPage = ImGearFileFormats.LoadPage(fileContent, 0)
               Catch ex As ImGearException
                   Debug.WriteLine(ex.Message)
               End Try
               If Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing AndAlso Not igPage.DIB.IsEmpty() Then
                   ' Create a new page display.
                   igPageDisplay = New ImGearPresentationPageDisplay(igPage)
                   ' Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay
                   ' Cause the page view to update.
                   imGearPageView1.Update()
               End If
           End Using
       End If
   End Sub

   Private Sub ZoomInExecuted(sender As Object, e As ExecutedRoutedEventArgs)
       ' Get the current zoom info.
       Dim igZoomInfo As ImGearZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1)
       'Increase the zoom.
       igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25
       igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25
       igZoomInfo.Horizontal.Fixed = True
       igZoomInfo.Vertical.Fixed = True
       ' Set the New zoom values.
       igPageDisplay.UpdateZoomFrom(igZoomInfo)
       ' Trigger an update, letting it know only the layout has changed.
       imGearPageView1.Update(True)
   End Sub

   Private Sub ZoomOutExecuted(sender As Object, e As ExecutedRoutedEventArgs)
       ' Get the current zoom info.
       Dim igZoomInfo As ImGearZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1)
       igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * (1 / 1.25)
       igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * (1 / 1.25)
       igZoomInfo.Horizontal.Fixed = True
       igZoomInfo.Vertical.Fixed = True
       ' Set the New zoom values.
       igPageDisplay.UpdateZoomFrom(igZoomInfo)
       ' Trigger an update, letting it know only the layout has changed.
       imGearPageView1.Update(True)
   End Sub

   Private Sub ExectutedRotate90(sender As Object, e As ExecutedRoutedEventArgs)
       Try
           ' Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
           ' ImGearRotationValues.VALUE_90 Is the constant value for indicating the amount of the rotation.
           ' It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
           ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90)
           imGearPageView1.Update()
       Catch ex As ImGearException
           Debug.WriteLine(ex.Message)
       End Try
   End Sub

   Private Sub CanExectutePageAvailable(sender As Object, e As CanExecuteRoutedEventArgs)
       e.CanExecute = (Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing AndAlso
           Not igPage.DIB.IsEmpty() AndAlso Not igPageDisplay Is Nothing)
   End Sub

End Class

    In what follows, we will go over some areas of this sample code in more detail.

  8. We declare the route commands required for this project in the .xaml.cs file as:
    • CS
    • VBNET
    C#
    Copy Code
    public static RoutedCommand ZoomInCmd = new RoutedCommand();
public static RoutedCommand ZoomOutCmd = new RoutedCommand();
public static RoutedCommand Rotate90Cmd = new RoutedCommand();
    VB.NET
    Copy Code
       Public Shared ZoomInCmd As New RoutedCommand()
   Public Shared ZoomOutCmd As New RoutedCommand()
   Public Shared Rotate90Cmd As New RoutedCommand()
  9. Then, the Command Bindings in the .xaml file for the RoutedCommands created above:
    XAML
    Copy Code

    <Window.CommandBindings>
    <CommandBinding
    Command="Open"
    Executed="OpenExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.ZoomInCmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ZoomInExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.ZoomOutCmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ZoomOutExecuted"/>
    <CommandBinding
    Command="{x:Static custom:MainWindow.Rotate90Cmd}"
    CanExecute="CanExectutePageAvailable"
    Executed="ExectutedRotate90"/>
    </Window.CommandBindings>

  10. If you are using a Deployment (Runtime) licensing, add the license initialization code to the Main Window constructor. This is not necessary if you are using an Evaluation or Development (Toolkit) license. Please add the ImGearEvaluationManager.Initialize() call if you are evaluating the product.
    • CS
    • VBNET
    C#
    Copy Code
                   public MainWindow()
       {
           // Initialize license for a Deployment(Runtime) license.
           //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
           //methods must be called to distribute the runtime.***
           //ImGearLicense.SetSolutionName("YourSolutionName");
           //ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
           //Manually Reported Runtime licenses also require the following method
           //call to SetOEMLicenseKey.
           //ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();

           // Insert the HD Photo format held by the IGWPF component.
           ImGearFileFormats.Filters.Insert(0, ImGearHDPhoto.CreateHDPhotoFormat());
           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           InitializeComponent();
       }
    VB.NET
    Copy Code
       Public Sub New()

       ' Initialize license for a Deployment(Runtime) license.
       '***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
       'methods must be called to distribute the runtime.***
       'ImGearLicense.SetSolutionName("YourSolutionName");
       'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
       'Manually Reported Runtime licenses also require the following method
       'call to SetOEMLicenseKey.
       'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");

       'Initialize evaluation license.
       ImGearEvaluationManager.Initialize()

       'Initialize common formats.
       ImGearCommonFormats.Initialize()

       ' This call is required by the designer.
       InitializeComponent()

   End Sub
  11. Load and display a document using:
    • CS
    • VBNET
    C#
    Copy Code
                      ImGearLoadingSelection selection = ImGearWinForms.SelectLocalFileToLoad(null, "Select File");
           if (null != selection)
           {
               using (FileStream fileContent = ((ImGearLocalFile)
                  selection.File).OpenToRead())
               {
                   try
                   {
                       igPage = ImGearFileFormats.LoadPage(fileContent, 0);
                   }
                   catch (ImGearException ex)
                   {
                       Debug.WriteLine(ex.Message);
                   }
               }
               if (null != igPage && null != igPage.DIB &&
                   !igPage.DIB.IsEmpty())
               {
                   // Create a new page display.
                   igPageDisplay = new ImGearPresentationPageDisplay(igPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay;
                   // Cause the page view to update.
                   imGearPageView1.Update();
               }
           }
    VB.NET
    Copy Code
           Dim selection As ImGearLoadingSelection = ImGearWinForms.SelectLocalFileToLoad(Nothing, "Select File")
       If Not selection Is Nothing Then
           Dim localFile As ImGearLocalFile = selection.File
           Using fileContent As FileStream = localFile.OpenToRead()
               Try
                   ' Load the image into the page.
                   igPage = ImGearFileFormats.LoadPage(fileContent, 0)
               Catch ex As ImGearException
                   Debug.WriteLine(ex.Message)
               End Try
               If Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing AndAlso Not igPage.DIB.IsEmpty() Then
                   ' Create a new page display.
                   igPageDisplay = New ImGearPresentationPageDisplay(igPage)
                   ' Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay
                   ' Cause the page view to update.
                   imGearPageView1.Update()
               End If
           End Using
       End If
  12. Execute the Zoom In operation as follows:
    • CS
    • VBNET
    C#
    Copy Code
               // Get the current zoom info.
           ImGearZoomInfo igZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1);
           // Increase the zoom.
           igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25;
           igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25;
           igZoomInfo.Horizontal.Fixed = true;
           igZoomInfo.Vertical.Fixed = true;
           // Set the new zoom values.
           igPageDisplay.UpdateZoomFrom(igZoomInfo);
           // Trigger an update, letting it know only the layout has changed.
           imGearPageView1.Update(true);
    VB.NET
    Copy Code
           ' Get the current zoom info.
       Dim igZoomInfo As ImGearZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1)
       'Increase the zoom.
       igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25
       igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25
       igZoomInfo.Horizontal.Fixed = True
       igZoomInfo.Vertical.Fixed = True
       ' Set the New zoom values.
       igPageDisplay.UpdateZoomFrom(igZoomInfo)
       ' Trigger an update, letting it know only the layout has changed.
       imGearPageView1.Update(True)

    Similarly, we can perform Zoom Out by just modifying the multiplier of the Horizontal and Vertical values as (1/1.25). See Zoom Out Click Event Handler.

  13. Finally, we can rotate the page displayed with:
    • CS
    • VBNET
    C#
    Copy Code
               try
           {
               // Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
               // ImGearRotationValues.VALUE_90 is the constant value for indicating the amount of the rotation.
               // It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
               ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90);
               imGearPageView1.Update();
           }
           catch (ImGearException ex)
           {
               Debug.WriteLine(ex.Message);
           }
    VB.NET
    Copy Code
           Try
           ' Rotate the given page 90 degrees using ImGearRotationValues.VALUE_90.
           ' ImGearRotationValues.VALUE_90 Is the constant value for indicating the amount of the rotation.
           ' It may be changed for other values, e.g. ImGearRotationValues.VALUE_180, ImGearRotationValues.VALUE_270.
           ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90)
           imGearPageView1.Update()
       Catch ex As ImGearException
           Debug.WriteLine(ex.Message)
       End Try

    Notice that for performing 180 and 270 rotations, we simply change the second parameter of the Rotate method to ImGearRotationValues.VALUE_180 and ImGearRotationValues.VALUE_270, respectively.


ASP.NET Application
User Guide > Getting Started > Tutorial: Create Your First Project > ASP.NET Application

In this tutorial, you will configure a project for a ASP.NET and use ImageGear for .NET capabilities. You will also learn how to load a document, then view, rotate, and zoom it.

  • I. Create the Project
  • II. Create a Page
  • III. Copy Code
  • IV. Deploying Your Application to IIS

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

A sample of this tutorial is provided within the installer of ImageGear for .NET. You can have access to it in the following directory: $INSTALLDIR\ImageGear for .NET v22 64-bit\Samples\ASP.NET\CSharp\ASP.NET Tutorial\. In addition, we include another sample that illustrates the use of ImageGear .NET with jQuery at: $INSTALLDIR\ImageGear for .NET v22 64-bit\Samples\ASP.NET\jQuerySamples\ImGearPluginSample\ImGearPluginSample\. This jQuery sample also provides instructions for running the ASP.NET sample using HTTP or HTTPS.

I. Create the Project

  1. Using the desired version of Visual Studio (2010 or later):
    1. Create a new "Web Site" using C# or VB.NET.
    2. Select the ASP.NET Empty Web Site template.
    3. Set .NET Framework 4.0 as the targeted framework.
    4. Set File System for the location.
    5. Name the project ASP.NET Tutorial" and click OK.
  2. In the Solution Explorer window view, right-click on the bold ASP.NET Tutorial project and choose Add > Add New Item. Choose the Web Form item and click Add. This will add the Default.aspx (and the code behind Default.aspx.cs if the code behind check box is appropriately configured).
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following packages:
      Accusoft.ImageGear.WinForms.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WinForms/)
    • Manually:
      1. Add the ImageGear Windows Forms tools to use in your GUI:
        1. In your Toolbox window, right-click and go to Choose Toolbox Items...
        2. In the .NET Framework Components tab, click the Browse button.
        3. Navigate to "$INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\”, select ImageGear22.Web.dll, and click Open.
        4. Repeat the process to add ImageGear22.Web.ImageDataProcessor.dll.
        5. You will see the PageView, ThumbnailView, ImGearThumbnailList and ImageGearBackEnd controls added to the list of components. Make sure they are checked and click OK. You only need to do this configuration once; in the future, you can skip this step.
      2. Manually add ImageGear22.Web.Services.dll as a reference to your project from $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\.
  4. Drag an ImageGearBackEnd control from the Toolbox and drop it on the page. In Visual Studio's Source View, drop it just below the usage instructions; in Design View, drop it anywhere on the page. Adding ImageGearBackEnd to your form caused Visual Studio to copy the necessary ImageGear DLLs into the bin folder of your web site.

II. Create a Page

At this point you can create a Page in one of the following ways:

  • Using Project Item Template
  • Adding Controls

Using Project Item Template

  1. Right-click on the web site in the Visual Studio Solution Explorer and choose Add > Add New Item to add a new page to your web site, based on the ThumbnailVerticalTemplate template.
  2. Switch to Visual Studio's Design View for ThumbnailSampleVertical.aspx. You most likely will see two occurrences of Error Creating Control because ImageGearBackEnd does not install the ImageGear22.Web.dll into the project.
  3. Normally in design mode, a PageView, ImGearThumbnailList, or ThumbnailView control would be dragged from the Toolbox onto the Web design form by the developer, which would have installed the ImageGear22.Web.dll into the bin directory. The ThumbnailSampleVertical template is unable to perform this process automatically, so the next step is required to resolve the above error for this tutorial.
  4. Select the PageView control from the ToolBox and drop it onto the top left side of the design form. Now, switch to split view in the Visual Studio window, keeping the PageView control highlighted. The following line should be highlighted in the source window somewhere near the top of the ThumbnailVertical.aspx page:
    <imgear:PageView ID="PageView1" runat="server" />
  5. Delete the highlighted line, as this is an extra unnecessary control for this tutorial demo page. The ImageGear22.Web.dll and the ImageGear22.Web.ImageDataProcessor.dll should now have been added to the Bin folder in your solution project. You should still see a PageView control, but sometimes the pre-installed PageView control will not be displayed properly unless the ThumbnailSampleVertical.aspx file is closed and then reopened.
  6. The next step of this tutorial will help you set up web.config. Switch back to Visual Studio's Design View (on the ThumbnailSampleVertical.aspx file page). Configure the web.config file using the PageView control's action list:
    1. First, select the PageView control.
    2. Then open the action list menu by clicking on the arrow on the top-right corner of the control.
    3. Click on the following items to add the necessary configuration settings to web.config:
      • Configure ImageGear Web Settings - This launches a separate web.config editor which sets up the necessary configuration sections in that file. Please refer to the ASP.NET Web.Config Editor Application help section for more details. Typically entering and clicking Next to get to the Save menu and selecting Save is sufficient for a default configuration. However, for this tutorial, try adding two file data providers called FileImageDataProvider1 and FileImageDataProvider2. Have them tie to viewerImages and viewerImages2 storage directories. Or simply copy the web.config file from the installed Accusoft samples folder: $INSTALLDIR\ImageGear for .NET v22 64-bit\Samples\ASP.NET\CSharp\ASP.NET Tutorial\. The folder can be found by clicking on the samples folder that is under the Accusoft folder on the Windows Start menu.
      • Configure ImageGear ASP.NET Services - This creates the required ImageGearService.svc file necessary to run the ImageGear Services to support the website being constructed in this tutorial.
  7. Save your changes, and then run the application by selecting the ThumbnailSampleVertical.aspx in the Visual Studio Solution Window and right-clicking on it and choosing Set As Start Page. Then hit F5 to run the project or start the project from the Debug menu. Please note that if you installed only the 64-bit version of ImageGear, you cannot view your web site using Visual Studio; you will have to deploy it to IIS instead.
  8. Next, proceed to III. Copy Code, below

Use IISExpress from Microsoft for a better debugging experience with web services.

Adding Controls

  1. Open default.aspx in Visual Studio and switch to Design View.
  2. From the AJAX Extensions section of the Visual Studio Toolbox, drag a ScriptManager onto the form. You can drop it anywhere on the form in Design View; the exact location does not matter.
  3. From the HTML section of the Visual Studio Toolbox, drag five Input (Button) controls onto the form. In the Visual Studio Properties Window, change:
    • The first button's Value property to Show Full Image
    • The second button's Value property to Rotate Right
    • The third button's Value property to Draw Ellipse
    • The fourth button's Value property to Data Provider 1
    • The fifth button's Value property to Data Provider 2
  4. Drag a PageView control onto the form.
  5. In the Visual Studio Properties Window, change the PageView control's DocumentIdentifier property to MyImage.tif. You could use your own image, but then you would need to appropriately modify the code.
  6. Create two folders named viewerImages and viewerImages2 in the root of the project. From the Accusoft sample folder $INSTALLDIR\ImageGear for .NET v22 64-bit\Samples\ASP.NET\CSharp\ASP.NET Tutorial\viewerImages\, copy the image MyImage.tif into viewerImages and ccitt.tif into viewerImages2.
  7. The next step of this tutorial will help you set up web.config. Switch back to Visual Studio's Design View (on the Default.aspx file page). Configure the web.config file using the PageView control's action list:
    • First, select the PageView control.
    • Then open the action list menu by clicking on the arrow on the top-right corner of the control.
    • Click on the following items to add the necessary configuration settings to web.config:
      • Configure ImageGear Web Settings - This launches a separate web.config editor, which sets up the necessary configuration sections in that file. Please refer to the ASP.NET Web.Config Editor Application help section for more details. Typically entering and clicking Next to get to the Save menu and selecting Save is sufficient for a default configuration. However, for this tutorial, try adding two file data providers called FileImageDataProvider1 and FileImageDataProvider2. Have them tie to viewerImages and viewerImages2 storage directories. Or simply copy the web.config file from the installed Accusoft samples folder: $INSTALLDIR\ImageGear for .NET v22 64-bit\Samples\ASP.NET\CSharp\ASP.NET Tutorial\. The folder can be found by clicking on the samples folder that is under the Accusoft folder on the Windows Start menu.
      • Configure ImageGear ASP.NET Services - This creates the required ImageGearService.svc file necessary to run the ImageGear Services to support the website being constructed in this tutorial.

III. Copy Code

At this point your project is ready for copying some code. The following code can be used to load a document, view it using an PageView control, and rotate it. Moreover, you can drag a rectangle on the image to zoom in (because the MouseTool property is set to RectangleZoom) and click the button to show the full image.

Default.aspx
Copy Code

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" %>

<%@ Register assembly="ImageGear22.Web.ImageDataProcessor" namespace="ImageGear.Web.UI" tagprefix="imgear" %>
<%@ Register assembly="ImageGear22.Web" namespace="ImageGear.Web.UI" tagprefix="imgear" %>

<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title></title>

<script language="javascript" type="text/javascript">
// <!CDATA[

function Button1_onclick() {
$find('PageView1').fitPage(ImageGear.Web.UI.FitType.FullImage);
}

function Button2_onclick() {
$find('PageView1').rotate(90);
}

function Button3_onclick() {
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Ellipse);

mark.set_rectangle(new ImageGear.Web.UI.Rectangle(Math.random()*800, Math.random()*800, 800, 350));
mark.set_fillColor('#ffc0cb');
mark.set_lineWidth(10);
mark.set_lineColor('#008020');
mark.set_opacity(127);

$find('PageView1').get_artPage().addMark(mark);
}

function Button4_onclick() {
var _ctrlView = $find('PageView1');
if (_ctrlView.get_pageIsOpen() == true) {
_ctrlView.closePage();
}
_ctrlView.openPage({ documentIdentifier: 'FileImageDataProvider1:MyImage.tif', pageNumber: 2, viewFitType: ImageGear.Web.UI.FitType.ActualSize });
}

function Button5_onclick() {

var _ctrlView = $find('PageView1');
if (_ctrlView.get_pageIsOpen() == true) {
_ctrlView.closePage();
}
_ctrlView.openPage({ documentIdentifier: 'FileImageDataProvider2:ccitt.tif', pageNumber: 2, viewFitType: ImageGear.Web.UI.FitType.ActualSize });
}

// ]]>

</script>

</head>
<body>
<form id="form1" runat="server">
<div>

</div>
<imgear:ImageGearBackEnd ID="ImageGearBackEnd1" runat="server">
</imgear:ImageGearBackEnd>
<asp:ScriptManager ID="ScriptManager1" runat="server">
</asp:ScriptManager>

<input id="Button1" type="button" value="Show Full Page" onclick="return Button1_onclick()" />
<input id="Button2" type="button" value="Rotate Right" onclick="return Button2_onclick()" />
<input id="Button3" type="button" value="Draw Ellipse" onclick="return Button3_onclick()" />
<input id="Button4" type="button" value="Data Provider 1" onclick="return Button4_onclick()" />
<input id="Button5" type="button" value="Data Provider 2" onclick="return Button5_onclick()" />

<imgear:PageView ID="PageView1" runat="server" Height="472px" Width="696px" DocumentIdentifier="MyImage.tif" />

</form>
</body>
</html>

Web.config
Copy Code

<?xml version="1.0" encoding="UTF-8"?>
<!--
For more information on how to configure your ASP.NET application, please visit
http://go.microsoft.com/fwlink/?LinkId=169433
-->
<configuration>
<configSections>
<section name="ImageGear.Web.DataProviders.ImageProvider" type="ImageGear.Web.DataProviders.ImageDataProviderConfiguration,ImageGear22.Web.Services" />
</configSections>
<system.web>
<compilation debug="true" targetFramework="4.0" batch="false">
<assemblies>
<add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
</assemblies>
</compilation>
</system.web>
<system.serviceModel>
<services>
<service name="ImageGear.Web.ImGearService" behaviorConfiguration="ImageGearRestfulBehavior">
<endpoint binding="webHttpBinding" contract="ImageGear.Web.IImGearService" />
</service>
</services>
<behaviors>
<serviceBehaviors>
<behavior name="ImageGearRestfulBehavior">
<!-- To avoid disclosing metadata information, set the value below to false and remove the metadata endpoint above before deployment -->
<serviceMetadata httpGetEnabled="true" />
<!-- To receive exception details in faults for debugging purposes, set the value below to true. Set to false before deployment to avoid disclosing exception information -->
<serviceDebug includeExceptionDetailInFaults="true" />
</behavior>
</serviceBehaviors>
</behaviors>
<serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
</system.serviceModel>
<ImageGear.Web.DataProviders.ImageProvider default="FileImageDataProvider1" parseToken=":">
<providers>
<add name="FileImageDataProvider1" type="ImageGear.Web.DataProviders.FileImageDataProvider,ImageGear22.Web.Services" storageRootPath="~/viewerImages/" maxImageSizeToCache="512" cachingTimeLimit="5" cachingEnable="false" />
<add name="FileImageDataProvider2" type="ImageGear.Web.DataProviders.FileImageDataProvider,ImageGear22.Web.Services" storageRootPath="~/viewerImages2/" maxImageSizeToCache="512" cachingTimeLimit="5" cachingEnable="false" />
</providers>
</ImageGear.Web.DataProviders.ImageProvider>
<system.diagnostics>
<switches>
<!--Notes!!!-->
<!--The following sections can permit the Accusoft Pegasus ASP.NET component to record/log Errors and other information.-->
<!--The imageGearSwitch values may have one of the following values: Critical, Error, Warning, Information or Verbose.-->
<!--Obviously, each successive value reults in more messages being generated.-->
<add name="imageGearSwitch" value="Error" />
</switches>
<sources>
<source name="ImageGear.Web" switchName="imageGearSwitch">
<listeners>
<add name="imageGearListener" traceOutputOptions="DateTime" type="System.Diagnostics.TextWriterTraceListener" initializeData="ImageGear.Web.log" />
</listeners>
</source>
</sources>
</system.diagnostics>
<appSettings>
<!--<add key="igSolutionName" value="Accusoft" />-->
<!--<add key="igSolutionKey" value="" />-->
<!--<add key="igLicenseKey" value="" />-->
<!--*** Edit the igPdfResources value path to reflect resources folder for PDF ****-->
<!--<add key="igPdfResources" value=$INSTALLDIR\ImageGear for .NET v22\Bin"/>-->
<!-- *** Possible edits to disable undesired formats to increase performance. -->
<!-- <add key="igDisableFormats" value="jpeg2k, dcrawHeaderless, dcraw, ps, pdfps, dicom, office"/> -->
<add key="igSolutionName" value="Accusoft" />
<add key="igPdfResources" value="" />
<add key="igBinaries" value="" />
<add key="igComponent" value="~/bin/ImageGear22.Web.ImageDataProcessor.dll" />
<add key="maxThreadsPerControl" value="4" />
<add key="igDisableFormats" value="dcrawHeaderless, dcraw, pdfps, NativeCommon" />
</appSettings>
<system.webServer>
<handlers accessPolicy="Read, Write, Script" />
<directoryBrowse enabled="false" />
<defaultDocument>
<files>
<clear />
<add value="Default.aspx" />
</files>
</defaultDocument>
<httpErrors>
<clear />
</httpErrors>
</system.webServer>
</configuration>

Now, we will go over some areas of this sample code in more detail:

  • We fit the image to the PageView control using:
    JavaScript
    Copy Code
    function Button1_onclick() {
$find('PageView1').fitImage(ImageGear.Web.UI.FitType.FullImage);
}
  • The 90 degrees rotation is performed as follows:
    JavaScript
    Copy Code
    function Button2_onclick() {
$find('PageView1').rotate(90);
}
  • We draw an Ellipse by adding the following code:
    JavaScript
    Copy Code
    function Button3_onclick() {
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Ellipse);
mark.set_rectangle(new ImageGear.Web.UI.Rectangle(Math.random()*800, Math.random()*800, 800, 350));
mark.set_fillColor('#ffc0cb');
mark.set_lineWidth(10);
mark.set_lineColor('#008020');
mark.set_opacity(127);

$find('PageView1').get_artPage().addMark(mark);
}
  • We load a document using:
    JavaScript
    Copy Code
    function Button4_onclick() {
var _ctrlView = $find('PageView1');
if (_ctrlView.get_pageIsOpen() == true) {
    _ctrlView.closePage();
}
_ctrlView.openPage({ documentIdentifier: 'FileImageDataProvider1:myImage.tif', pageNumber: 2,
 viewFitType: ImageGear.Web.UI.FitType.ActualSize });
}

IV. Deploying Your Application to IIS

Let's refer to a couple of things that you will need to consider when deploying your application to IIS, given that the tutorial relies on Cassini, the development web server built into Visual Studio:

  • Services - Deployment Considerations
  • Logging
  • Application Pools on 64-bit Operating Systems

Services - Deployment Considerations

  • You will need to properly configure web.config similar to the one used for your application development. If you used the smart tag on the PageView or ThumbnailView control window, you launched a program called WebConfigEditor. You may need to review the changes done on the development web.config for your deployment or run this stand-alone program on the correct web.config file that you are deploying to properly set up services.
  • You will need to set up (or publish) a folder that contains the web.config and ImageGearService.svc files along with your web application (aspx, html, etc.) files.
  • You will need a bin folder containing all the .dlls and PDF resource files either within the top level folder or properly configured in the web.config file for its location.
  • You will need to have the image repository accessible and properly configured in the web.config file as described by the Configuring & Working with Data Providers section in this help file.
  • Services under IIS can only accept one security authentication scheme. Typically the choice would be choosing either windowsAuthentication or anonymousAuthentication.
  • If you are not running under IIS, but in Cassini or IISExpress, take note of the port number, as that must be used for testing the services.
  • If everything has been properly done, the services should be running under IIS automatically. If the deployed application fails, you can launch a browser and type in the web URL for the services and you should see the following image in the web browser (URL may be different except for the last piece: ImageGearService.svc):

  • If any other page is displayed, the services are not running and you will need to perform more IIS troubleshooting to understand the cause of the problem. In this case, turning on the debugging features in the web.config file may help gather more information. Make sure only one security authentication scheme is selected as noted above.

Logging

ImageGear's ASP.NET includes server-side logging to help you identify problems. To turn on this logging, you need to configure web.config. The easiest way to do that is to do the following:

  1. Display an aspx page in Visual Studio's Design View.
  2. Select an ImageGear PageView, ThumbnailList, or ThumbnailView control.
  3. Click the arrow in the top right corner to display the action list.
  4. Select Configure ImageGear Web Settings.
  5. Click the Error Logging button and choose an Error Severity level.

You can adjust the amount of information that ImageGear places into the log file by selecting "Off", "Critical", "Error", "Warning", "Information", or "Verbose". These values are documented in MSDN for the System.Diagnostics.TraceLevel enumeration. The amount of information logged typically increases going from "Critical" towards "Verbose".

Application Pools on 64-bit Operating Systems

By default, IIS runs web sites in a 32-bit process on a 32-bit operating system and in a 64-bit process on a 64-bit operating system. If you wish to run the 32-bit version of ImageGear on a 64-bit machine, you should create a new Application Pool using the IIS Manager. After you create it, you should edit its Advanced Settings to enable 32-bit applications.


Samples
User Guide > Getting Started > Samples

All samples are located within ImageGear.NET v22 64-bit\Source Code\... subfolders.

ImageGear for .NET has the following samples (organized by category):

  • ART Annotations
  • Barcode
  • PDF and PostScript
  • Medical
  • Microsoft Office
  • Scanning
  • Vector
  • Miscellaneous

ART Annotations

Samples Location: ...\[CSharp|VBNET]\Legacy\ART\...

Name | GUI | This Sample Demonstrates... | Languages | IDEs
ART_MFA (Legacy) | WinForms | How to work with and manipulate ART annotations, and import and export them from/to XML. | C#, VB.NET | VS2010
WPF_ART (Legacy) | WPF | WPF PageView control and annotations. | C# | VS2010

Barcode

Samples Location: ...\[CSharp|VBNET]\Legacy\Barcode\...

Name | GUI | This Sample Demonstrates... | Languages | IDEs
Barcode (Legacy) | WinForms | Different methods for creating and recognizing barcodes. | C#, VB.NET | VS2010

PDF and PostScript

Samples Location: ...\[CSharp|VBNET]\[VS2010|VS2015]\PDF\...

For convenience, we added identical sample projects created with different versions of Visual Studio.

Name

GUI

This Sample Demonstrates...

Languages

IDEs

ConvertDOCXtoPDF

WinForms

How to read a DOCX document page and save it as a PDF file.

C#, VB.NET

VS2010
VS2015

SplitPDFUsingMultipleThreads

Console

How to split PDFs using multiple threads.

C#, VB.NET

VS2010
VS2015

ConvertPDFtoSVG

WinForms

How to convert a PDF document to a SVG using Accusoft's API.

C#, VB.NET

VS2010
VS2015

VerifyAndConvertToPDFA

WinForms

How to convert a PDF document into a PDFA standard and how to verify compliance with ISO-standard PDFA-1a.

C#, VB.NET

VS2010
VS2015

PDFMerge

WinForms

How to merge two PDF documents into a one PDF document.

C#, VB.NET

VS2010
VS2015

SavePDFtoImage

WinForms

How to read a PDF document page by page, index, rasterize a page, and store the raster page as JPEG file.

C#, VB.NET

VS2010
VS2015

AddWatermarkToPDFPage

WinForms

Watermarking a PDF document by adding:

  • A translucent PDF FreeText annotation that says "DRAFT" across the top of the page.
  • A PNG image placed in the center of the page.

Images that support alpha channel transparency may be used.

C#, VB.NET

VS2010
VS2015

WPF_SavePDFtoMultiPageTIF

WPF

Converting a PDF into a multi-page TIF using WPF controls.

C#, VB.NET

VS2010
VS2015

PDF Sample (Legacy) WinForms The capabilities of ImageGear for viewing, editing, annotating, and saving PDF documents. C#, VB.NET VS2010

Medical

Samples Location: ...\[CSharp|VBNET]\Legacy\Medical\...

Name

GUI

This Sample Demonstrates...

Languages

IDEs

Medical (Legacy)

WinForms

How to work with DICOM images and medical functionality.

C#, VB.NET

VS2010

WPF_Medical (Legacy)

WPF

How to work with DICOM images and medical functionality using WPF Controls.

C#

VS2010

RadiologyOfficeSample

WebForms

The use of ImageGear web components PageView and ThumbnailView to display and annotate radiology procedure images. This sample uses LINQ to SQL to drill down from patient to procedures lists displayed in ASP.NET GridView components. Selection of a procedure from the list displays images belonging to that procedure in a ThumbnailView list. Thumbnail selection displays image in the PageView web control. This sample also demonstrates using a custom Image Data Provider in a separate assembly. The database included with the sample contains patient and procedure information. The images are stored on the server as files. The database stores image file names. Microsoft SQL Server 2005 Express installation is required for this sample to work.

All ASP.NET samples are located in the ...\Source Code\ASP.NET\... folder.

C#, ASP.NET

VS2010

Microsoft Office

Samples Location: ...\[CSharp|VBNET]\Legacy\Office\...

Name | GUI | This Sample Demonstrates... | Languages | IDEs
Office (Legacy) | WinForms | How to load, display, print, and repaginate Word files. | C#, VB.NET | VS2010
WPF_Office (Legacy) | WPF | How to load, display, print, and repaginate Word files using WPF controls. | C# | VS2010

Scanning

Samples Location: ...\[CSharp|VBNET]\Legacy\TWAIN\...

Name

GUI

This Sample Demonstrates...

Languages

IDEs

TWAIN (only x86)(Legacy)

WinForms

Scanning capabilities using the installed TWAIN drivers.

C#, VB.NET

VS2010

ImGearIsisSample

WebForms

Scanning capabilities using ImageGear web components.

All ASP.NET samples are located in the ...\Source Code\ASP.NET\... folder.

C#, ASP.NET

VS2010

Vector

Samples Location: ...\[CSharp|VBNET]\Legacy\Vector\...

Name | GUI | This Sample Demonstrates... | Languages | IDEs
Vector(Legacy) | WinForms | How to deal with CAD and other vector files, providing a comprehensive GUI for vector and 3D processing. | C#, VB.NET | VS2010

Miscellaneous

Samples Location: ...\[CSharp|VBNET]\Legacy\...

Name

GUI

This Sample Demonstrates...

Languages

IDEs

Core (Legacy)

WinForms

The core product functionality, working with documents and individual pages.

C#, VB.NET

VS2010

Display (Legacy)

WinForms

Display capabilities, which includes anti-aliasing, transparency, and extra channels.

C#, VB.NET

VS2010

Processing (Legacy)

WinForms

Image processing operations (basic, color, filtering, encryption, visual effects, and ImageClean).

C#, VB.NET

VS2010

Recognition (Legacy)

WinForms

ImageGear's character recognition capabilities.

C#, VB.NET

VS2010

Timing (Legacy)

WinForms

The benchmarking methods for input, output, display, and image processing functionality.

C#

VS2010

FreqIP (only x86) (Legacy)

WinForms

The use of ImageGear components for frequency domain image processing (FFT, DCT).

C#

VS2010

XPS (Legacy)

WinForms

Working with XML Paper Specification files.

C#

VS2010

WPF_Thumbnail (Legacy)

WPF

How to enable support for HD Photo images and the XAML based thumbnail and magnifier controls for WPF.

C#

VS2010

WebSqlSample

WebForms

The use of the built-in SqlImageDataProvider. The images are stored as "Blobs" in the database included with the sample. The web page displays images in the PageView web control. There is a simple toolbar at the top that demonstrates the use of some of the ImageGear Client API to manipulate the displayed image. Microsoft SQL Server 2005 Express installation is required for this sample to work.

All ASP.NET samples are located in the ...\Source Code\ASP.NET\... folder.

C#, ASP.NET

VS2010

ImageStreamSample

WebForms

How to pre-fetch images from the image repository and allow the user to scroll forward or backward through these images.

All ASP.NET samples are located in the ...\Source Code\ASP.NET\... folder.

C#, ASP.NET

VS2010

jQuerySamples > ImGearPluginSample

WebForms

The use of ImageGear web components using jQuery. A set of instructions is provided in the Default file in order to help configure this sample for running it using HTTP or HTTPS.

All ASP.NET samples are located in the ...\Source Code\ASP.NET\... folder.

jQuery

VS2010


Getting Support
User Guide > Getting Started > Getting Support

Have a question? Can't find what you are looking for in our Samples? Send us a technical support request from our website: https://www.accusoft.com/support/

The Accusoft Support Team can help with problems or questions you may have about the following:

  • Installation
  • Licensing
  • Sample code
  • Error handling
  • General questions or help on how to use the API

For information about Accusoft Support Plans, see Support Plans or call Accusoft at 813-875-7575.

Also, check out the following additional resources on our website:

  • Online Demos
  • White Papers & Case Studies
  • ImageGear FAQs


Using ImageGear for .NET
User Guide > Using ImageGear for .NET

ImageGear for .NET is implemented as safe and managed code and offers the hierarchy of classes, structures, interfaces, and enumerations. It is structured into several namespaces, providing APIs in the following categories: Core Functionality, Formats, Processing, and Display.


Namespaces
User Guide > How to Work with... > Namespaces

ImageGear functionality is divided into namespaces. This provides flexibility in packaging and licensing ImageGear technology. Each namespace encapsulates a particular functionality of the product. All namespaces are enabled when you evaluate or purchase the product (there is an expiration date for the evaluation version). However, different licensing fees may be associated with different namespaces for deployment of your application. Please contact your Accusoft Corporation sales representative for more information about deployment licensing fees.

You will need to initialize a namespace (except for the Core namespace) before using it. See the Samples for a demonstration of initializing the namespaces. The sample code has been provided so that you can cut and paste the initializing namespace code into your own application.

Starting with v22, ImageGear for .NET provides NuGet Packages to simplify the packaging process. NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework. If you prefer to handle this manually, refer to Assembly Dependencies for information on assemblies and their dependencies.

Please see Licensing and Distributing for information about ImageGear and the namespace licensing process.

This section summarizes the ImageGear for .NET namespaces that are currently available. For more information on these namespaces, refer to the Using ImageGear for .NET and ImageGear.Core Namespace chapters.

The ImageGear for .NET documentation provides information for all platforms and .NET framework versions. However, not all features are available for all ImageGear for .NET versions. The following table describes which ImageGear for .NET Namespaces are available for which versions (Windows 32-bit and Windows 64-bit).

Namespace

Description

Associated Assemblies

ImageGear.Core

The foundation for all other namespaces, ImageGear.Core contains shared classes used in other namespaces such as ImGearPage Class and ImGearDocument Class, and global attributes such as error handling classes and licensing.
  • ImageGear22.Core.dll
  • ImageGear22.Formats.Dicom.dll
  • ImageGear22.Windows.Controls.dll

ImageGear.ART

Lets you annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Mark objects are created by using their constructors, but their actual life starts when they are added into the ImGearARTPage Class. An ART page can be associated with one or more ImGearPage Class objects. The association is done by using ImGearPageDisplay Class properties: Page and ARTPage. ART internally tracks the marks that are associated with the image and ensures that marks are always displayed on the correct part of the image (even as the image is scrolled, rotated, flipped, and zoomed). Your application can save an image with marks into a separate file in legacy .ART file format or .XML file format. Any time the image is reloaded, the ART marks can be reloaded with a simple method call.
  • ImageGear22.Art.dll
  • ImageGear22.Presentation.dll

ImageGear.ART.Forms

Lets you add redlining and annotation capabilities to any application built with ImageGear. It provides ART GUI functionality that can simplify development of ImageGear based applications.

  • ImageGear22.Art.Forms.dll

ImageGear.ART.Windows.Controls

Provides WPF Annotation controls and UI.

  • ImageGear22.Art.Windows.Controls.dll

ImageGear.Barcode

Provides a set of objects that provides access to barcode recognition technology.
  • ImageGear22.Barcode.dll

ImageGear.Dicom.Forms

Provides functionality to support the end user’s interaction and UI for multi-planar reconstruction (MPR).
  • ImageGear22.Dicom.Forms.dll
ImageGear.Display

Provides access to ImageGear display API and contains shared classes and structures used for image drawing.
  • ImageGear22.Core.dll
  • ImageGear22.Presentation.dll

ImageGear.Evaluation

Provides the evaluation manager used for product evaluation either in trial mode (default) or watermarks mode.
  • ImageGear22.Evaluation.dll
ImageGear.Formats

Provides image loading/saving operations for all other ImageGear namespaces.
  • ImageGear22.Core.dll
  • ImageGear22.Formats.Advanced.dll
  • ImageGear22.Formats.CameraRaw.dll
  • ImageGear22.Formats.Common.dll
  • ImageGear22.Formats.SimplifiedMetadata.dll
ImageGear.Formats.CAD

Provides the API to create DWG and DXF vector formats.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.CGM

Provides the API to create the CGM vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.DGN

Provides the API to create DGN vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.DICOM

Provides features that are used with medical and DICOM images. DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images; it is the standard for medical imaging throughout the world.

ImageGear.Formats.DICOM supports the DICOM format, contains a custom API, and includes expanded image processing capabilities beyond those of the baseline ImageGear library.
  • ImageGear22.Formats.Dicom.dll
ImageGear.Formats.DWF Provides the API to create DWF vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.EXIF

Provides the API for operating with EXIF non-image data.
  • ImageGear22.Formats.Common.dll
  • ImageGear22.Formats.SimplifiedMetadata.dll
ImageGear.Formats.HPGL

Provides the API to create HPGL vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.IPTC

Contains classes, structures, and enumerations that provide simplified access to IPTC metadata.
  • ImageGear22.Formats.SimplifiedMetadata.dll
ImageGear.Formats.JPEG2K Allows you to use the diverse functionality of the JPEG 2000 wavelet-based compression technique and provides support for JPEG 2000 and JPX formats.
  • ImageGear22.Formats.Jpeg2k.dll
ImageGear.Formats.JPG

Provides enumeration values for JPEG format filter control parameters.
  • ImageGear22.Core.dll

ImageGear.Formats.Office

 Provides support for Microsoft Office formats.
  • ImageGear22.Formats.Office.dll
ImageGear.Formats.PDF

Allows you to load, save, and process PDF (Portable Document Format) files using ImageGear.Core and other ImageGear namespace functionality. This namespace also allows you to read vector data from PS (PostScript) file formats (the ImageGear.Core namespace allows you to read only raster data from these two formats). In addition, you can extract text from loaded PDF and PS image files.
  • ImageGear22.Formats.Pdf.dll
ImageGear.Formats.SVG Provides the API to create SVG vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.TIF

Provides public API for TIFF format metadata operations and for TIFF filter control parameters.
  • ImageGear22.Core.dll
  • ImageGear22.Formats.Common.dll
  • ImageGear22.Formats.SimplifiedMetadata.dll
ImageGear.Formats.U3D

Provides the API to create U3D vector format.
  • ImageGear22.Formats.Vector.dll
ImageGear.Formats.XMP

Provides the API for XMP formats.
  • ImageGear22.Formats.SimplifiedMetadata.dll
ImageGear.FreqIP
Deprecated
(32-bit only)

Provides public API methods for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc.
  • ImageGear22.Processing.Advanced.dll
ImageGear.Processing

Provides the capability to resize, rotate, adjust brightness and contrast, reduce or promote bit depth, and perform many other image processing operations.
  • ImageGear22.Core.dll
  • ImageGear22.Processing.Advanced.dll
ImageGear.Processing.ImageClean

Contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop.
  • ImageGear22.Processing.Advanced.dll
ImageGear.Processing.Layers

Provides API for creating and editing image layers. It includes ImGearLayeredPage Class, which contains a raster composition image and an array of layers.

  • ImageGear22.Core.dll
ImageGear.Recognition

Offers a set of objects that provide access to document recognition technology, enabling you to build OCR applications.
  • ImageGear22.Recognition.dll
ImageGear.Recognition.Forms

Provides recognition-related user interface functionality. For example, it provides a customizable toolbar for creating recognition zones, as well as interactive, visual creation and editing of recognition zones, which are displayed directly over the image to be recognized.

  • ImageGear22.Recognition.Forms.dll
ImageGear.TWAIN
(32-bit only)

Allows you to support all three TWAIN Transfer Modes: Native Data Transfer Mode (the TWAIN default), Disk File Transfer, and Buffered Memory.
  • ImageGear22.Twain.dll
ImageGear.Vector Provides native support for vector data as used by CAD/vector formats such as DWF, DWG, CGM, DGN, and HPGL. When you load any of these formats, the resulting ImGearPage object is not automatically rasterized at load time. The data is kept in vector form for display and processing. It's possible to display the vector data from different viewpoints and edit individual vector entities. The vector data can also be rasterized, converting it to a bitmap form.
  • ImageGear22.Formats.Vector.dll
ImageGear.Web.DataProviders

Includes ImageDataProvider classes for images that are stored in files or in a SQL database, as well as a provider-based model that you can use to create custom image data providers.

  • ImageGear22.Web.Services.dll
ImageGear.Web.Isis

Provides API for obtaining an ImGearPage or ImGearDocument from an ISIS or TWAIN compliant device in a web-based application running in a browser.
  • ImageGear.Web.Isis Namespace Client API Library
ImageGear.Web.UI

Includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.

  • ImageGear22.Web.dll
  • ImageGear22.Web.ImageDataProcessor.dll
  • ImageGear22.Web.Services.dll
ImageGear.Windows.Controls

Provides WPF PageView, Annotation, UI and other common controls to simplify development of XAML based applications.
  • ImageGear22.Windows.Controls.dll
  • ImageGear22.Windows.Controls.Art.dll
ImageGear.Windows.Forms

Provides common GUI functionality that can simplify development of Windows Forms based applications.
  • ImageGear22.Windows.Forms.dll
ImageGear.Windows.Forms.Thumbnails

Provides the GUI Thumbnail control API.

  • ImageGear22.Windows.Forms.dll
ImageGear.WPF

Provides UI controls for use with the Windows Presentation Foundation framework.

  • ImageGear22.Wpf.dll
ImageGear.WPF.BitmapSourceConversion

Provides BitmapSource conversion API.
  • ImageGear22.Wpf.dll
ImageGear.WPF.HDP

Provides functionality for compatibility with the HD Photo (Windows Media Photo) format.
  • ImageGear22.Wpf.dll
ImageGear.WPF.XPS

Provides full multi-page reading, writing and printing support for XPS documents and pages. You can detect, read, write, append, insert, replace, delete and print specified pages in the XPS document as well as convert raster images to XPS.

  • ImageGear22.Wpf.dll


Images and ImGearPage
User Guide > How to Work with... > Images and ImGearPage

One of the primary entities in the ImageGear for .NET toolkit is page and its implementation as ImGearPage Class.

ImGearPage Class consists of three main parts: image data, metadata, and region of interest.

Image data (or simply, image) is available for manipulations through the DIB property and is a ImGearDIB Class type. Color space, channels, width, and height are major attributes which define image structure.

ImageGear for .NET considers an image as a collection of channels, each of which gives some single piece of information about the pixels in a whole image. Channels are defined as an array of depths for each channel. Depth specifies the quantity of different values for a particular channel. This data is constant for the page until image processing functions are applied. It may be accessed through the ImGearDIB. ChannelDepths Property.

The ImGearColorSpace Structure (returned by the ImGearDIB. ColorSpace Property) defines the semantics of the information stored in all channels (i.e., whether the second channel is the green component of RGB color, magenta of CMYK, or alpha value of a grayscale image). This information may be formed from ImGearColorSpaceIDs Enumeration flags and placed into the constructor of ImGearPage Class.

Pixels in ImGearDIB Class may be accessed as both individual pixels or groups of pixels. GetPixelCopy Method() and UpdateColumnFrom Method() are examples of such members. An important issue is that all of these routines return copies of the data stored in an image as an array of the ImGearPixel Class. None of these members allows direct access to the pixel store.

To gain direct access to an image, GetImage Method() or GetRaster Method() members of ImGearDIB Class should be used. This is an efficient way to implement image processing routines, since all changes made to the structures (returned by these functions) will be reflected in the image. Users of GetImage Method() or GetRaster Method() should completely understand the structure of the internal pixel store to avoid producing ill-formed images.

The following example creates an RGB image and swaps red and blue channel values for diagonal pixels.

C#
Copy Code
const int pageSize = 200;
const int redChannel = 0;
const int greenChannel = 1;
const int blueChannel = 2;
// Creates page with RGB colorspace and 8 bits channels.
ImGearPage igPage = new ImGearRasterPage(pageSize, pageSize,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    new int[] { 8, 8, 8 },
    true);
// Iterates all rows in created page.
for (int row = 0; row < igPage.DIB.Height; ++row)
{
    // Obtains reference to raster store.
    ImGearArrayRef igArrayRef = igPage.DIB.GetRaster(row);
    // Casts content to byte[] since all channels are 8 bit.
    byte[] raster = (byte[])igArrayRef.Content;
    // Offset of diagonal pixel in raster.
    int pixelOffset = igArrayRef.Offset + row * igPage.DIB.ChannelCount;
    // Swaps red & blue.
    byte red = raster[pixelOffset + redChannel];
    raster[pixelOffset + redChannel] = raster[pixelOffset + blueChannel];
    raster[pixelOffset + blueChannel] = red;
}

Metadata is non-image data, often available in some complex formats like TIFF or PNG. It may have complexity and is completely dependent on the nature of the file format. To provide a way of manipulating such data, ImageGear for .NET offers a set of classes composed from ImGearMetadataNode Class, ImGearMetadataNodeList Class and ImGearMetadataTree Class and their descendants. For a particular ImGearPage Class instance, metadata may be accessed through the Metadata Property.

Region of interest (ImGearROI Class) represents a free-shape image area (rectangular, non-rectangluar, or entire space) and specifies a meaningful part of an image. For example, a region of interest may be established to define an area where some image processing functions should be applied.


Loading and Saving Pages and Documents
User Guide > How to Work with... > Loading and Saving Pages and Documents

ImGearFileFormats Class should be used to load/save images. It offers LoadPage Method(), SavePage Method(), LoadDocument Method() and SaveDocument Method() members for these purposes. Each of these members mainly loads (saves) an image from a given .NET Stream object. ImageGear supports loading from streams having the seek ability, as well as from streams that don't have the seek ability, such as network streams.

ImageGear only supports saving to streams that have the seek ability.

The following example demonstrates how to load a single page from a local file:

C#
Copy Code
ImGearPage igPage;
using (FileStream localFile = new FileStream("photo.jpg",FileMode.Open))
{
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
}

The next example demonstrates how to load a page from a remote file:

C#
Copy Code
ImGearPage igPage;
WebRequest request = WebRequest.Create("http://www.google.com/intl/en_ALL/images/logo.gif");
using (WebResponse response = request.GetResponse())
    using (Stream stream = response.GetResponseStream())
        igPage = ImGearFileFormats.LoadPage(stream, 0);

The example below demonstrates how to stream a particular page of document into memory:

C#
Copy Code
ImGearDocument igDocument;
using (FileStream localFile = new FileStream("MULTIPAG.TIF", FileMode.Open))
{
    int pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN);
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount);
}
System.IO.MemoryStream memory = new MemoryStream();
ImGearFileFormats.SavePage(igDocument.Pages[0], memory, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
byte[] array = memory.ToArray();

Also refer to the following sections:

  • Loading and Saving Pages and Documents
    • Load Pages and Documents from Internet
    • Convert Pixel Format during Image Saving
    • Use Filter Control Parameters
    • Save to Raster Formats
    • Layered Images


Load Pages and Documents from Internet
User Guide > How to Work with... > Loading and Saving Pages and Documents > Load Pages and Documents from Internet

ImageGear provides a specialized stream class for loading of images from internet: ImGearWebStream Class. This class is most useful for loading multipage images, because it downloads only the necessary portion of remote file.

ImGearWebStream Class only supports loading images from servers that use HTTP protocol.

The following example demonstrates how to load a page from a remote document using ImGearWebStream Class:

C#
Copy Code
ImGearPage igPage;
using (ImGearWebStream igWebStream = new ImGearWebStream ("http://localhost/MULTIPAG.TIF"))
    igPage = ImGearFileFormats.LoadPage(igWebStream, 2);


Convert Pixel Format during Image Saving
User Guide > How to Work with... > Loading and Saving Pages and Documents > Convert Pixel Format during Image Saving

ImageGear supports a variety of pixel formats (color spaces and channel depths). However, most image file formats support only a limited set of pixel formats. For example, PNG format does not support CMYK color space, and JPEG Lossy format does not support storing 16-bit per channel pixel values. ImageGear provides conversion from a source image's pixel format into one of the pixel formats supported by the destination image file format.

Availability of a specific pixel format for saving depends on the requested compression, saving options, and filter control parameters.

ImageGear uses the following logic to select the pixel format for saving:

  • If the format filter directly supports saving of image's pixel format, ImageGear uses this pixel format;
  • Otherwise, if the format filter supports saving of pixel formats that exceed the image's pixel format (so no image quality degradation occurs), ImageGear uses the one that takes least storage space;
  • Otherwise, ImageGear uses the pixel format that results in least degradation of image quality.

A special case is when the image color space has to be converted, and multiple choices of channel depths are available. In that case, ImageGear selects channel depths that are equal to the image's channel depths, rather than larger channel depths. This results in a slightly worse quality degradation, but avoids an unexpected increase in image size. For example, PNG format does not support CMYK color space, but it supports storing 8- or 16-bits per channel. ImageGear saves a 32-bit CMYK to PNG as 24-bit RGB rather than 48-bit RGB.

ImageGear does not support conversion from multichannel truecolor color spaces (RGB, CMYK, etc.) into an indexed color space during saving.

Use ImGearSaveOptions. ConversionMode Property to specify the acceptability of image quality degradation or bit depth promotion during saving.

Use ImGearSaveOptions. ForceColorspace Property to make ImageGear use a specific color space for saving.


Use Filter Control Parameters
User Guide > How to Work with... > Loading and Saving Pages and Documents > Use Filter Control Parameters

Many format filters in ImageGear have control parameters that affect filter operations, such as image reading and writing. Those parameters may be declared by the format specification, or they may be specific to the format implementation by ImageGear.

There are two ways to specify filter control parameters:

  • Specify parameters globally. This affects all format reading and writing operations, and threads in the process. Use the Filters static property of the ImGearFileFormats Class to set parameters globally.
  • Specify parameters locally. This affects only one reading or writing operation, and thus can be used for setting different parameters in different threads. To specify the local parameters, create an instance of ImGearFileFilters Class, assign it to ImGearLoadOptions. Filters property or ImGearSaveOptions. Filters property, and pass the Load or Save options object to the reading or writing method, correspondingly.

The following example sets a global control parameter:

C#
Copy Code
IImGearFormat JpgFormat = ImGearFileFormats.Filters.Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.Parameters.GetByName("SaveType");
Param.Value = 1; // Lossless
using (FileStream fsWrite = File.Open("Test.jpg", FileMode.Create, FileAccess.ReadWrite, FileShare.None))
 ImGearFileFormats.SavePage(imGearPage, fsWrite, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG, null);

The following example sets a local control parameter:

C#
Copy Code
ImGearFileFilters LocalFilters = new ImGearFileFilters();
IImGearFormat JpgFormat = LocalFilters.Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.Parameters.GetByName("SaveType");
Param.Value = 1; // Lossless
ImGearSaveOptions SaveOptions = new ImGearSaveOptions();
SaveOptions.Filters = LocalFilters;
using (FileStream fsWrite = File.Open("Test.jpg", FileMode.Create, FileAccess.ReadWrite, FileShare.None))
 ImGearFileFormats.SavePage(imGearPage, fsWrite, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG, SaveOptions);


Save to Raster Formats
User Guide > How to Work with... > Loading and Saving Pages and Documents > Save to Raster Formats

ImageGear for .NET provides the ImGearRasterSaveOptions class that defines options for saving vector pages and documents to raster formats. This class is derived from the regular ImGearSaveOptions class and could be used with the regular ImGearFileFormats.SavePage and ImGearFileFormats.SaveDocument methods that take ImGearSaveOptions parameter.

The following sample code demonstrates how to use the ImGearRasterSaveOptions class for saving vector PDF document to TIF:

C# Example
Copy Code
        ImGearDocument doc = null;
        // Load PDF document.
        using (FileStream fileStream = new FileStream(infile, FileMode.Open, FileAccess.Read, FileShare.Read))
        {
            doc = ImGearFileFormats.LoadDocument(fileStream, 0, -1);
        }
        // Specify raster options for saving.
        ImGearRasterSaveOptions rasterOptions = new ImGearRasterSaveOptions();
        rasterOptions.BitDepth = 24;
        rasterOptions.ScaleX = 2.0;
        rasterOptions.ScaleY = 2.0;
        // Save to TIF file.
        using (FileStream fileStream = new FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite))
        {
            ImGearFileFormats.SaveDocument(doc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_DEFLATE, rasterOptions);
        }
VB.NET Example
Copy Code
        Dim doc As ImGearDocument
        ' Load PDF document.
        Using fileStream As FileStream = New FileStream(infile, FileMode.Open, FileAccess.Read, FileShare.Read)
            doc = ImGearFileFormats.LoadDocument(fileStream, 0, -1)
        End Using
        ' Specify raster options for saving.
        Dim rasterOptions As ImGearRasterSaveOptions = New ImGearRasterSaveOptions()
        rasterOptions.BitDepth = 24
        rasterOptions.ScaleX = 2.0
        rasterOptions.ScaleY = 2.0
        ' Save to TIF file.
        Using fileStream As FileStream = New FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite)
            ImGearFileFormats.SaveDocument(doc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_DEFLATE, rasterOptions)
        End Using


Layered Images
User Guide > How to Work with... > Loading and Saving Pages and Documents > Layered Images

ImageGear allows users to load layered image files and retain image layers for editing. Users can also create new layers and delete existing ones, as well as flatten and display the selected layers.

ImageGear currently supports layers for PSD and large PSD (PSB) file formats.

The ImageGear.Processing.Layers Namespace provides a set of API for working with layers.

Layer

Layers are used to specify different elements of an image. There are different types of layers. They represent a part of an image either as image pixels or as adjustment instructions. They are stacked on top of each other producing the resulting appearance of the image. ImageGear supports the image layers described in the next section.

Image Layer

Image Layer is a type of layer containing image pixels which can be applied/blended with other layers. The image from the Image Layer can cover the same area as the resulting image or just a part, specified by its rectangle. The Image Layer is associated with a certain opacity and other properties.

Layered Page

An ImageGear layered page is a raster image page containing the composition of layers. Layers associated with an image page can be blended in the order in which they appear to provide the resulting page. The result of such blending represents the final image view and is stored in the page's DIB.


Image Display
User Guide > How to Work with... > Image Display

ImageGear gives you complete control over how your application displays images. There are many configuration options and attributes that can be used to define how images should be displayed. The following list details some of the settings that can be controlled:

  • Contrast and Brightness adjustments
  • Transparency
  • Gamma correction
  • Image Rotation (Orientation)
  • The display area where the image is to be drawn (this area is called the Device Rectangle)
  • The portion of the image to display (this array of pixels within the DIB bitmap is called the Image Rectangle)
  • The Alignment of the displayed image in the display area
  • The fill pattern and color to use for the background, any area of the Device Rectangle not displaying a portion of the image
  • The Image Layout, Fit to width/height/window
  • Precision scrolling
  • Aspect ratio
  • Anti-aliasing display for 1bit (Black & White) images using preserve black, preserve white and scale to gray modes
  • Color Anti-aliasing for non 1bit (Black & White) images
  • Using LUTs (look-up tables) to cause the colors in an image's color palette to be translated to other colors you select (i.e., you can display an 8-bit grayscale image in any 256 colors you choose).

All of the above display attributes affect the display only. They do not alter either the image bitmap or the color palette in the DIB. In addition, any time your image is being displayed, you can center, zoom or scroll it from within your application.

Once the ImGearPage Class object is obtained (either by itself, or as part of an ImGearDocument Class), the most common thing to do with it is to display it on the computer screen. Usually, an application will only display a given image on the computer screen once. However, there are many situations when an application will need to display the same image more than once (e.g., to allow the end user to apply some alternate display settings, the application needs to show "before" and "after" images at the same time). The various control options used to determine the appearance on the screen are all bundled together in a single object called ImGearPageDisplay Class. Each ImGearPageDisplay Class is associated with one (and only one) ImGearPage Class, but a given ImGearPage Class can have any number (0, 1, or more) of ImGearPageDisplay Class instances associated with it.

All that is necessary is to create an ImGearPageDisplay Class instance attached to the page, set up display style optionally, and call its Draw Method member during paint event handling.

Please use ImGearPresentationPageDisplay Class instead of ImGearPageDisplay Class when working with WPF environment.

This section provides information about the following:

  • Image Display
    • ImGearPageDisplay Class
    • ImGearPageDisplay Properties and Methods
    • ImageRect, ClipRect, and DeviceRect
    • Displaying Medical Images
    • Contrast Settings
    • Color Anti-Aliasing
    • Re-Sampling
    • Display Images in WPF Environment
      • ImGearPresentationPageDisplay Class
      • Device Coordinates
      • Specifying Scale Settings
      • Scaling Modes
      • Printing
        • Printing Images with Native Scaling
        • Printing Images with WPF Scaling
      • Performance Considerations
      • Usage of the Canvas Element


ImGearPageDisplay Class
User Guide > How to Work with... > Image Display > ImGearPageDisplay Class

To work with the ImGearPageDisplay Class, your application must create an ImGearPage Class object first, and load an image into it. The following example shows the use of the ImGearFileFormats. LoadPage Method, but any of the techniques could be used:

C#
Copy Code
// declared somewhere in you application
public ImGearPage m_igPage = null;

....

C#
Copy Code
using (FileStream stream = new FileStream(
    "test1.tif", FileMode.Open,
    FileAccess.Read, FileShare.Read))
{
    m_igPage = ImGearFileFormats.LoadPage(stream, 0);
}

Next, your application must create an ImGearPageDisplay Class object for the ImGearPage Class. This is done by declaring a respective variable and initializing it:

C#
Copy Code
// declared somewhere in you application
public ImGearPageDisplay m_igPageDisplay = null;

....

C#
Copy Code
m_igPageDisplay = new ImGearPageDisplay(m_igPage);

By itself, the ImGearPageDisplay Class object does not cause the image to appear on the computer screen. For that to happen, .NET provides a construct of type Graphics. There are many .NET API functions that can be used to obtain a Graphics for ImGearPageDisplay Class to use. A simple case instance of Graphics is provided as part of the Paint event.

To simplify programming, ImageGear provides a .NET control called ImGearPageView Class that automatically performs image drawing according to settings stored in ImGearPageDisplay Class. The application programmer simply places the ImGearPageView Class onto a dialog or other window, and then adds a line of code to the application to associate the ImGearPageView Class with the ImGearPageDisplay Class object.

ImGearPageDisplay Class offers the following options for rendering the image:

  • Using an ImGearPageView Class, as shown above.
  • Directly into Graphics. The application program must obtain the Graphics for this purpose (e.g., from HDC handle returned by Windows GDI GetDC() call). The image is rendered by calling the ImGearPageDisplay. Draw Method.
  • Directly into a printer Device Context. The application must obtain the printer Graphics for this purpose (e.g., from the Printer Common Dialog). The image is printed by calling the ImGearPageDisplay. Print Method.

When the ImGearPageDisplay Class is created, ImageGear creates the structures needed to render the image. When the ImGearPageDisplay Class is associated with an ImGearPageView Class, and the ImGearPageView. Update Method is called, then the image is rendered into the Graphics defined by the ImGearPageView Class.

There are a host of display setting properties in ImGearPageDisplay Class. They can be altered to change the way that the image is rendered a those properties will be discussed below. After setting any of the ImGearPageDisplay Class properties, or modifying the image in the ImGearPage Class object, the application must call ImGearPageView. Update Method once again to re-render the image:

C#
Copy Code
imGearPageView.Display = m_igPageDisplay;
imGearPageView.Update();

Neither changes to the display settings (e.g., changes to ImGearPageDisplay Class properties), nor changes to the ImGearPage Class object associated with the ImGearPageDisplay Class will cause an automatic redraw of the ImGearPageView Class a the application must call the ImGearPageView. Update Method to have it regenerate the DIB for the image. Continuing our example, assume that the application loads a different image into the ImGearPage Class object:

C#
Copy Code
using (FileStream stream = new FileStream(
    "photo.jpg", FileMode.Open,
    FileAccess.Read, FileShare.Read))
{
    m_igPage = ImGearFileFormats.LoadPage(stream, 0);
}
m_igPageDisplay.Page = m_igPage;

ImGearPage Class is changed, but the image is not yet rendered:

C#
Copy Code
imGearPageView.Update();


ImGearPageDisplay Properties and Methods
User Guide > How to Work with... > Image Display > ImGearPageDisplay Properties and Methods

ImGearPageDisplay Class provides a great deal of display-related properties and methods. All of the methods, and most of these properties, are used by your application program to control the way the image is displayed in the application.

The following ImGearPageDisplay Class properties and methods affect the display of an image only, not the image itself (as contained in the ImGearPage Class object). They do not alter the image bitmap. To alter the image itself, use the Image Manipulation facilities of ImageGear, described below.

A few of these properties are "read-only", and provide information about the rendered image to your application. The ImGearPageDisplay Class properties are grouped into data-value objects as a way to organize them. The data-value objects, and the properties that they contain, are as follows (for complete descriptions of these properties and methods, see the ImageGear.Display Namespace).

IImGearAntiAlias Interface

Properties used to make scanned text more readable, by removing or minimizing the "aliasing" (jagged edges of characters and other thin lines). For example:

Original Image

Image with AntiAliasing

These properties can be referenced directly, using the AntiAliasing Property of ImGearPageDisplay Class:

C#
Copy Code
imGearPageView.Display.AntiAliasing.Method = ImGearAliasModes.NONE;
IImGearBackground Interface

Controls the appearance of the area that is inside ImGearPageView Class, but outside of the displayed image. For example:

Default Background

Your application can set the background to a solid color or disable background drawing. These properties can be referenced directly, using the Background Property of ImGearPageDisplay Class:

C#
Copy Code
imGearPageView.Display.Background.Mode = ImGearBackgroundModes.NONE;
ImGearScrollInfo Structure

Controls the way a portion of a large image is visible within the smaller ImGearPageView Class. Scrolling can either be automatic (ImageGear takes care of it) or manual (your application has to react to mouse events and tell ImGearPageDisplay Class how to position the image). The scroll properties are all interrelated, and so they are "gotten" from ImGearPageDisplay Class as a group, and they are "updated" in ImGearPageDisplay Class as a group. Access them as follows:

C#
Copy Code
ImGearScrollInfo igScrollInfo;
igScrollInfo = imGearPageView.Display.GetScrollInfo(imGearPageView);

Change the properties as follows:

C#
Copy Code
igScrollInfo.Horizontal.Mode = ImGearScrollBarModes.SCROLLBAR_ENABLE;
imGearPageView.Display.UpdateScrollFrom(imGearPageView, igScrollInfo);
ImGearZoomInfo Structure

Controls the way that an image is magnified before being displayed in the ImGearPageView Class. For example:

Actual Size

300% Zoom

The zoom properties are all interrelated, and so they are "gotten" from ImGearPageDisplay Class as a group, and they are "updated" in ImGearPageDisplay Class as a group. Access them as follows:

C#
Copy Code
ImGearZoomInfo igZoomInfo;
igZoomInfo = imGearPageView.Display.GetZoomInfo(imGearPageView);
bool isHorizontalFixed;
// Check if the horizontal zoom mode is fixed.
isHorizontalFixed = igZoomInfo.Horizontal.Fixed;

Change the properties as follows:

C#
Copy Code
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Horizontal.Value = 0.5;
igZoomInfo.Vertical.Fixed = true;
igZoomInfo.Vertical.Value = 0.5;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
ImGearPageDisplay. Layout Property

Controls the geometric appearance (full image or partial image, centered or not, etc.) of the image as displayed in ImGearPageView Class.

Layout settings include three rectangles (ImageRect, ClipRect and DeviceRect) that can be used to control the layout of the image as rendered a see ImageRect, ClipRect, and DeviceRect for a description of these rectangles. Normally your application won't reference these rectangles, as they default to the size of the image and the size of the ImGearPageView Class client area, respectively.

The most commonly used layout properties are Alignment and FitMode:

Alignment.Horizontal: Left
Alignment.Vertical: Top

Fit: To Window Height

These properties can be referenced directly, using the Layout Property of ImGearPageDisplay Class:

C#
Copy Code
imGearPageView.Display.Layout.FitMode = ImGearFitModes.ACTUAL_SIZE;
ImGearFitModes igFitMode;
igFitMode = imGearPageView.Display.Layout.FitMode;

The Orientation Property attribute is accessible directly from the ImGearPageDisplay Class object:

ImGearPageDisplay.Orientation Property

Another control that determines the geometric appearance of the image as displayed in ImGearPageView Class. For example:

BOTTOM_RIGHT

RIGHT_BOTTOM

These properties can be referenced directly:

C#
Copy Code
imGearPageView.Display.Orientation.Value = ImGearOrientationModes.BOTTOM_RIGHT;
ImGearOrientationModes igOrientationMode;
igOrientationMode = imGearPageView.Display.Orientation.Value;

The following ImGearPageDisplay Class methods can be used to change the way the ImGearPage Class image is rendered:

  • ScrollTo Method() - An alternate mechanism for scrolling the image
  • ZoomToRectangle Method() - An alternate mechanism for setting the zoom properties


ImageRect, ClipRect, and DeviceRect
User Guide > How to Work with... > Image Display > ImageRect, ClipRect, and DeviceRect

ImageRect

This rectangle defines the part of the image that is output to the device. It is expressed in image coordinates. By default, this option is set to the empty rectangle (Left:0, Top:0, Right:-1, Bottom:-1, Width:0, Height:0) that is equivalent to the entire image. Use the ImGearPageDisplay.Layout.ImageRect Property to change this attribute.

ClipRect

This rectangle identifies the destination device area effected by the display operations. It is expressed by device coordinates and is initially assigned to the empty rectangle (Left:0, Top:0, Right:-1, Bottom:-1, Width:0, Height:0) that is equivalent to the entire client area of the ImGearPageView Class. Use the ImGearPageDisplay.Layout.ClipRect Property to change this attribute.

DeviceRect

By default, this option is set to the empty rectangle (Left:0, Top:0, Right:-1, Bottom:-1, Width:0, Height:0) that indicates that the device rectangle will be equal to the clip rectangle. The image does not have to necessarily fit exactly into the device rectangle. The position of the image inside the device rectangle may also be determined by other display options such as ImGearPageDisplay.Layout.AspectRatio Property, ImGearPageDisplay.Layout.FitMode Property, and ImGearPageDisplay.Layout.Alignment Property. Use the ImGearPageDisplay.Layout Property.DeviceRect Property to change this attribute.

Displayed Image Rectangle (DisplayedImageRect)

Although this is not a display option you can set, it is an important concept. This rectangular area represents the image size and location on the device and is therefore expressed in device coordinates. It is NOT related to the ClipRect Property, which represents the visible part of the image. The DisplayedImageRect value can be calculated and used, but cannot be set directly.

This figure illustrates the meaning of the rectangles listed above:

Accordingly, if the ImageRect Property remains at its default value (equal to the entire image), and the DeviceRect Property and ClipRect Property remain at their default values (equal to the size of the ImGearPageView Class), and if the FitMode Property is FIT_TO_DEVICE, then the result will be as follows:

If your application makes the DisplayRect 2x wider and 2x taller, but leaves the ClipRect Property set to the size of the ImGearPageView Class (this is the same as setting a 2x zoom), then the following will result:

On the other hand, if your application leaves the DisplayRect set to the size of the ImGearPageView Class, but makes the ClipRect Property half as wide and half as tall, then the following will result:

Note that the settings for ImageRect Property, DeviceRect Property, ClipRect Property, Layout Property.FitMode Property, Layout Property.Alignment Property, ZoomToRectangle Method, ScrollTo Method, and Orientation Property can specify conflicting values. The resolution to this is a hierarchy wherein some of these properties take precedence over others. We will further explain how ImageGear deals with the options when conflicting values are applied.

Consider the general display rendering algorithm: it consists of several steps. Within each step, ImageGear processes some options to introduce modifications to the resulting image. ImageRect Property is oriented according to OrientMode. ClipRect Property and DeviceRect Property are calculated according to their definitions above.

If FitMode Property is set to ACTUAL_SIZE, then DisplayedImageRect.width and DisplayImageRect.height are set to ImageRect Property width and ImageRect Property height, respectively. Otherwise, DisplayedImageRect is computed using DeviceRect Property. According to Horizontal and Vertical zoom modes (fixed or not), Horizontal and Vertical zoom values, DisplayedImageRect.width and DisplayedImageRect.height are modified as follows:

C#
Copy Code
if (zoomHorizontal.Fixed)
    DisplayedImageRect.Width = DisplayedImageRect.Width*zoomHorizontal.Value;

And

C#
Copy Code
if (zoomVertical.Fixed)
    DisplayedImageRect.Height = DisplayedImageRect.Height*zoomVertical.Value;

If AspectRatio.Fixed is set to true, zoomVertical.Value is not used, and the above procedure is changed in the following way:

C#
Copy Code
if (zoomHorizontal.Fixed)
{
    DisplayedImageRect.Width = DisplayedImageRect.Width*zoomHorizontal.Value;
    DisplayedImageRect.Height = DisplayedImageRect.Height*zoomHorizontal.Value;
}

DisplayedImageRect.x and DisplayedImageRect.y are computed so that DisplayedImageRect is aligned as specified by AlignMode. The scrolling range is calculated so that DisplayedImageRect can be viewed within ClipRect Property. Then DisplayedImageRect.x and DisplayedImageRect.y are shifted according to the current scroll position.


Displaying Medical Images
User Guide > How to Work with... > Image Display > Displaying Medical Images

ImageGear provides special display features for medical images, such as Value Of Interest (Window Leveling), Modality transform, and presentation state display support. These features are accumulated in the ImGearDICOMDisplaySettings Class. An instance of ImGearDICOMDisplaySettings Class can be attached to ImGearRasterPage Class as a member:

ImGearRasterPage. DICOMDisplaySettings Property

When ImageGear loads a DICOM image, it initializes the DICOMDisplaySettings Property with settings found in the image. Display code applies these settings during image display. This allows you to load and display DICOM images properly without the need for any DICOM specific application code.

The DICOMDisplaySettings Property member only affects the grayscale images. It is ignored if attached to color images.

Application can attach the DICOMDisplaySettings Property to an image, even if it was not loaded from a DICOM file.

The ImGearDICOMDisplaySettings Class stores display settings in their original form. For example, if linear VOI transform is used, ImageGear stores Window Center and Window Width values, rather than a LUT calculated from these values. In particular, if an automatic VOI transform is used during image loading, the application can obtain Window Width and Window Center values that have been automatically selected.

A special member of this class, DisplaySummaryLUT Property, is a look-up table that concatenates all transforms from the ImGearDICOMDisplaySettings Class. The application has to call UpdateDisplaySummaryLUT Method to update the LUT after any transformations have been changed.

If the application changes any display settings, such as VOI, Modality, etc., and then saves the image, ImageGear writes the changed settings to the file.


Contrast Settings
User Guide > How to Work with... > Image Display > Contrast Settings

Contrast, Brightness, and Gamma properties are included in ImGearPresentationPageDisplay to make it easier to set and get these settings. If ImGearPresentationPageDisplay.LUT is null and the Contrast, Brightness, or Gamma property is set, a new ImGearRGBLUT is created internally and the ImGearPresentationPageDisplay.LUT property will be set to it.


Color Anti-Aliasing
User Guide > How to Work with... > Image Display > Color Anti-Aliasing

Color anti-aliasing is used to enhance the display of non 1-bit-per-pixel color images. Color anti-aliasing is applicable when an image is zoomed out. Color anti-aliasing attributes can be referenced directly using the ColorAntiAliasing Property of ImGearPageDisplay Class:

C#
Copy Code
imGearPageView.Display.ColorAntiAliasing.Method = ImGearColorAliasModes.NONE


Re-Sampling
User Guide > How to Work with... > Image Display > Re-Sampling

Re-sampling is used to enhance image display when it is zoomed in. Re-sampling attributes can be referenced directly using the Resampling Property of ImGearPageDisplay Class.

C#
Copy Code
imGearPageView.Display.Resampling.Method = ImGearResampleModes.BILINEAR


Display Images in WPF Environment
User Guide > How to Work with... > Image Display > Display Images in WPF Environment

This section discusses image display under Windows Presentation Foundation (WPF) environment.

The WPF API outlined in this section is available in the ImageGear22.Presentation.dll assembly. The following is a list of classes available in the ImageGear22.Presentation.dll assembly:

  • public abstract class ImGearDisplayScaleSettings Class
  • public class ImGearNativeDisplayScaleSettings Class : ImageGear.Display Namespace.ImGearDisplayScaleSettings Class
  • public sealed class ImGearPresentationPageDisplay Class : ImageGear.Display Namespace.ImGearPageDisplay Class
  • public class ImGearRenderSettings Class
  • public class ImGearWpfDisplayScaleSettings Class : ImageGear.Display Namespace.ImGearDisplayScaleSettings Class

This section provides information about the following:

  • Display Images in WPF Environment
    • ImGearPresentationPageDisplay Class
    • Device Coordinates
    • Specifying Scale Settings
    • Scaling Modes
    • Printing
      • Printing Images with Native Scaling
      • Printing Images with WPF Scaling
    • Performance Considerations
    • Usage of the Canvas Element


ImGearPresentationPageDisplay Class
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > ImGearPresentationPageDisplay Class

ImGearPresentationPageDisplay Class is an advanced version of ImGearPageDisplay Class that requires Windows Presentation Framework and the ImageGear22.Presentation.dll assembly.

This class implements the IImGearPageDisplay interface and implements a set of display API for rendering an image specified by the Page Property and annotations specified by the ARTPage Property in the WPF environment. The ImGearPresentationPageDisplay class derives from the System.Windows.DependencyObject class, allowing the Page, ARTPage, Channels, DICOMDisplaySettings, LUT, Orientation, Contrast, Brightness, and Gamma properties of this class to serve as the source or target of a binding. Note that since DependencyObject’s have thread affinity, the ImGearPresentationPageDisplay class should only be accessed from the thread on which it is created.

It is recommended that you use ImGearPresentationPageDisplay Class for WPF and FW 3.0 applications.

C#
Copy Code
ImGearPresentationPageDisplay newDisplay = new ImGearPresentationPageDisplay();
ImGearPage page = ImGearFormats.LoadPage(...);
newDisplay.Page = page;
ImGearARTPage artPage = new ImGearARTPage();
newDisplay.ARTPage = artPage;

Win Forms applications should continue using ImGearPageDisplay Class available in the ImageGear22.Core.dll assembly.

C#
Copy Code
ImGearPageDisplay winFormsDisplay = new ImGearPageDisplay();
ImGearPage page = ImGearFormats.LoadPage(...);
winFormsDisplay.Page = page;
ImGearARTPage artPage = new ImGearARTPage();
winFormsDisplay.ARTPage = artPage;


Device Coordinates
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Device Coordinates

One of the major features of WPF is resolution independence. All visual objects are positioned and measured using device independent coordinates. This is different from GDI+ and Silverlight environments, which measure graphic objects in pixels.

WPF defines one device independent unit as 1/96th of an inch. One unit maps to one pixel if the system uses 96 dpi display setting (Windows Small Fonts).

Most of ImageGear display API supports both GDI+ and WPF. However, the ImageGear term "Device Coordinates" has different meaning in GDI+ and WPF. In GDI+, device coordinates are pixels, and in WPF they are WPF device independent units, rounded to an integer.

This affects the following API:

API Name | Usage in GDI+ | Usage in WPF
IImGearLayout Interface.ClipRect Property | Expressed in pixels. | Expressed in WPF device independent units.
IImGearLayout Interface.DeviceRect Property | Expressed in pixels. | Expressed in WPF device independent units.
ImGearFitModes Enumeration.ACTUAL_SIZE | Displayed image size in pixels is equal to image size in pixels. | Displayed image size, in WPF device independent units, is equal to image size in pixels.
ImGearPresentationPageDisplay. ConvertCoordinates Method | Device coordinates are expressed in pixels. | Device coordinates are expressed in WPF device independent units.
ImGearPageDisplay. ZoomToRectangle Method | Device rectangle coordinates are expressed in pixels. | Device rectangle coordinates are expressed in WPF device independent units.
ImGearARTPage. ConvertCoordinates Method | Device coordinates are expressed in pixels. | Device coordinates are expressed in WPF device independent units.

Device Resolutions

ImageGear renders images according to the specified device dimensions. In WPF, device dimensions are specified in device-independent units. If an end user uses the standard Windows display resolution of 96 DPI ("Small Fonts"), one device independent unit maps exactly to one pixel. In other words, if you set the device rectangle to 100x100, then the size of the ImageGear rendered image will be 100x100 pixels, and the image will occupy an area of 100x100 pixels on the screen.

If the display resolution is different from the default 96 DPI, or when printing an image, the device independent units do not map exactly to device units. For example, if you set the device rectangle to 100x100, and print on a 600 DPI printer, the size of the ImageGear rendered image will still be 100x100 pixels, but the WPF engine will stretch it onto a 625x625 pixel area on the printer (100 / 96 * 600 = 625). This may result in a blurry, low-resolution appearance.

ImageGear provides two ways to avoid this scaling issue:

  • Pass the device resolution info to the drawing functions to render the image according to the actual device resolution. For example, if you set the device rectangle to 100x100, print on a 600 DPI printer, and pass the resolution info to the drawing method, the size of the ImageGear rendered image will be 625x625 pixels, and the image will occupy a 625x625 pixel area on the printer. This avoids scaling by the WPF engine.
  • Use the WPF engine to scale images. In this mode, ImageGear does not scale images, only WPF does. For example, if the original image size is 1600x1200, the size of the ImageGear rendered image will also be 1600x1200, and WPF will scale it according to the display or printer resolution. See more details in the "WPF Scale Mode" section of Scaling Modes.


Specifying Scale Settings
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Specifying Scale Settings

The ImGearPresentationPageDisplay Class API allows you to specify scale settings for image and annotation drawing under WPF graphics environment. Scale settings specify the engine that is used for image scaling, and provide information that is specific for a particular scale engine.

Since the PageView Class calls ImGearPresentationPageDisplay Class drawing methods internally, it provides public properties that allow the user to specify scale settings for internal drawing operations. Use the ImageScaleSettings Property to set scale settings for the image. Use the AnnotationScaleSettings Property to set scale settings for the annotations.

See Also
Display Images in WPF Environment


Scaling Modes
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Scaling Modes

ImageGear provides two approaches for image display scaling. The application can use either of these approaches, depending on its requirements.

ImageGear allows using either scaling mode for both the image and the annotations. You can use same mode for both the image and the annotations, or different modes in any combination. By default, ImageGear uses the ImageGear scale mode for the image, and WPF scale mode for the annotations.

ImageGear Scale Mode

In this mode, ImageGear performs all geometric transformations. This is the same approach that ImageGear uses with GDI+. Result image dimensions are calculated according to desired display size, in device-independent units, and display device resolution, specified via ImGearNativeDisplayScaleSettings. Resolution Property. When using a DrawToCanvas Method or DrawToBitmapImage Method that does not accept an ImGearRenderSettings Class parameter, ImageGear assumes the device resolution to be 96 dpi (default display resolution in Windows).

Use this approach is you prefer ImageGear to do the scaling. The benefits are:

  • In most cases, a smaller buffer size for image display. Supports displaying huge images.
  • Availability of advanced display interpolation settings.

WPF Scale Mode

In this mode, ImageGear does not perform any scaling. It outputs the image in its original size, and uses WPF transforms to position and scale the image. Use this approach if you prefer WPF to handle scaling.

In WPF scale mode, ImageGear does not need to redraw the image for zooming, scrolling, or layout updating. It only updates the geometric transform of the image element. To let ImageGear know that only a layout update is necessary, set ImGearWpfDisplayScaleSettings. UpdateLayoutOnly Property to true.

The benefits of this approach are:

  • It is truly resolution independent. You can use the same display and rendering settings to display or print an image, without the need to know the actual resolution of the output device.
  • For small and medium size images, zoom and scrolling work much faster than in ImageGear display mode.

Use ImGearRenderSettings. ImageScaleSettings Property to specify the scaling mode for image rendering.


Printing
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Printing

ImageGear displays or prints an image in an ImGearPageView Class control, or in a System.Windows.Controls.Canvas element. In either case, you have a System.Windows.Media.Visual object that you can send to a printer or write into an XpsDocumentWriter. You can also put it into another Visual object, into a FixedDocument or FlowDocument and then print the parent object.

It is important to understand ImageGear Scaling Modes for displaying and printing images.

  • Printing Images with Native Scaling
  • Printing Images with WPF Scaling


Printing Images with Native Scaling
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Printing > Printing Images with Native Scaling

When using Native scaling, the application should re-render the ImageGear object before printing, using the printer resolution. You can obtain printer resolution, corresponding to user selected printer settings, using the properties of System.Printing.PrintTicket class. The example below demonstrates this approach:

C#
Copy Code
void SetupPrintResolution(System.Printing.PrintTicket printTicket, IImGearResolution resolution)
{
 if (printTicket.PageResolution != null && printTicket.PageResolution.X != null
  && printTicket.PageResolution.Y != null)
 {
  // Explicit resolution info is available
  resolution.XNumerator = (int)printTicket.PageResolution.X.Value;
  resolution.YNumerator = (int)printTicket.PageResolution.Y.Value;
 }
 else
 {
  // Use qualitative resolution
  System.Printing.PageQualitativeResolution qResolution;
  if (printTicket.PageResolution == null)
   qResolution = System.Printing.PageQualitativeResolution.Default;
  else
   qResolution = (System.Printing.PageQualitativeResolution)(
    printTicket.PageResolution.QualitativeResolution ??
    System.Printing.PageQualitativeResolution.Default);
  double defResolution;

  switch (qResolution)
  {
   case System.Printing.PageQualitativeResolution.Draft:
    defResolution = 300;
    break;
   case System.Printing.PageQualitativeResolution.Normal:
    defResolution = 600;
    break;
   case System.Printing.PageQualitativeResolution.High:
    defResolution = 1200;
    break;
   default:
    defResolution = 600;
    break;
  }
  resolution.XNumerator = (int)defResolution;
  resolution.YNumerator = (int)defResolution;
 }
 resolution.Units = ImGearResolutionUnits.INCHES;
}

ImageGear needs to know the bounds for the drawing. If the application uses a DrawToCanvas Method overload that accepts an IImGearScrollableView Interface, ImageGear uses its bounds. If the application uses an overload that does not accept an IImGearScrollableView Interface, which is the usual way for printing, the application shall set canvas Width and Height properties.

When the image has been drawn, the application should call the Measure and Arrange methods of the canvas that it uses for printing. This step is only necessary for printing, and not for display. It is important to call these methods after the DrawToCanvas Method and before sending the canvas to the system printing method, such as System.Windows.Controls.PrintDialog.PrintVisual().

The following example demonstrates the printing steps:

C#
Copy Code
void PrintWholeImageCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
 System.Windows.Controls.PrintDialog pDialog = new System.Windows.Controls.PrintDialog();
 if(pDialog.ShowDialog() == true)
 {
  // Set up scale settings
  ImGearRenderSettings rs = new ImGearRenderSettings();
  // Use native scale settings. Provide specific resolution.
  ImGearNativeDisplayScaleSettings settings =
new ImGearNativeDisplayScaleSettings();
  System.Printing.PrintTicket pt = pDialog.PrintTicket;
  SetupPrintResolution(pt, settings.Resolution);
  rs.ImageScaleSettings = settings;
  Canvas printCanvas = new Canvas();
  // Setup Display settings to print whole image
  ImGearPresentationPageDisplay pageDisplay =
   new ImGearPresentationPageDisplay(imGearPageView.Display.Page,
   imGearPageView.Display.ARTPage);
  pageDisplay.Layout.FitMode = ImGearFitModes.FIT_TO_DEVICE;
  // printCanvas.Width, printCanvas.Height must be set before
  // pageDisplay.DrawToCanvas, when printing without a pageView
  printCanvas.Width = pDialog.PrintableAreaWidth;
  printCanvas.Height = pDialog.PrintableAreaHeight;
  // Draw the image on the printCanvas
  pageDisplay.DrawToCanvas(printCanvas, rs);
  // Measure and arrange canvas
  printCanvas.Measure(new Size(
pDialog.PrintableAreaWidth, pDialog.PrintableAreaHeight));
  printCanvas.Arrange(new Rect(printCanvas.DesiredSize));

  // Print the canvas
  pDialog.PrintVisual(printCanvas, "Print ImageGear image");
 }
}


Printing Images with WPF Scaling
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Printing > Printing Images with WPF Scaling

In WPF scaling mode, ImageGear renders all images in their original size and lets WPF scale them. ImageGear does not need to know the printer resolution, so this mode may be preferable when the printer resolution is unknown, or when printing to an XPS printer driver. Note that since ImageGear renders images in their original size, printing low-resolution images to an XPS printer driver produces smaller output files, and printing large, high-resolution images produces bigger output files compared to output files produced by ImageGear Native scaling mode.

The rest of the printing process is the same as with Native scaling mode. The following example demonstrates this:

C#
Copy Code
void PrintWholeImageCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
 System.Windows.Controls.PrintDialog pDialog = new System.Windows.Controls.PrintDialog();
 if(pDialog.ShowDialog() == true)
 {
  // Set up scale settings
  ImGearRenderSettings rs = new ImGearRenderSettings();
  // Use WPF scale settings - don't need to set resolution.
  // WPF will scale the image.
  ImGearWpfDisplayScaleSettings settings = new ImGearWpfDisplayScaleSettings();
  rs.ImageScaleSettings = settings;
  Canvas printCanvas = new Canvas();
  // Setup Display settings to print whole image
  ImGearPresentationPageDisplay pageDisplay =
   new ImGearPresentationPageDisplay(imGearPageView.Display.Page,        imGearPageView.Display.ARTPage);
  pageDisplay.Layout.FitMode = ImGearFitModes.FIT_TO_DEVICE;
  // printCanvas.Width, printCanvas.Height must be set before
  // pageDisplay.DrawToCanvas, when printing without a pageView
  printCanvas.Width = pDialog.PrintableAreaWidth;
  printCanvas.Height = pDialog.PrintableAreaHeight;
  // Draw the image on the printCanvas
  pageDisplay.DrawToCanvas(printCanvas, rs);
  // Arrange canvas size
  printCanvas.Measure(new Size(
pDialog.PrintableAreaWidth, pDialog.PrintableAreaHeight));
  printCanvas.Arrange(new Rect(printCanvas.DesiredSize));

  // Print the canvas
  pDialog.PrintVisual(printCanvas, "Print ImageGear image");
 }
}

When using WPF scaling, the application can simply print the canvas that it uses for image display, using PrintDialog.PrintVisual, or any other way supported in WPF. This will display the image with the same layout and physical size as seen on the screen. The following example demonstrates this:

C#
Copy Code
void PrintVisibleAreaCmdExecuted(object target,ExecutedRoutedEventArgs e)
{
 System.Windows.Controls.PrintDialog pDialog = new System.Windows.Controls.PrintDialog();
 if(pDialog.ShowDialog() == true)
 {
  Canvas displayCanvas = imGearPageView.Canvas;
  // Arrange parent canvas
  displayCanvas.Measure(new Size(
pDialog.PrintableAreaWidth, pDialog.PrintableAreaHeight));
  displayCanvas.Arrange(new Rect(displayCanvas.DesiredSize));
  // Print the canvas
  pDialog.PrintVisual(displayCanvas, "Print ImageGear image");
 }
}


Performance Considerations
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Performance Considerations

Because different approaches are used for image display, Native and WPF scaling modes differ in their capabilities and performance.

WPF scaling mode works significantly faster for small and medium sized images (where image size is comparable to screen size).

For larger images, WPF scaling mode requires more memory than Native scaling mode. For displaying an image in Native mode, ImageGear allocates approximately

DisplayWidth * DisplayHeight

or

DisplayWidth * DisplayHeight * 3 bytes

depending on image pixel format. Display buffer size does not depend significantly on the image size. In Native mode, ImageGear can display any image that it can load.

For displaying an image in WPF scaling mode, ImageGear allocates approximately

ImageWidth * ImageHeight

or

ImageWidth * ImageHeight * 3 bytes

depending on image pixel format. The larger the image is, the more memory that is required to display it in WPF mode. If the image is large enough, an attempt to display it in WPF scaling mode may result in an OutOfMemory exception.

The difference between scaling modes is especially important for large bitonal images. ImageGear uses Run Length encoding to store the bitonal DIBs, which typically requires less than one bit for storing each pixel. When displaying such an image in Native scaling mode, ImageGear also requires a relatively small buffer for display. On the other hand, in WPF scaling mode ImageGear allocates a full size uncompressed 8-bit per pixel bitmap. As a result, large bitonal images display successfully in Native scaling mode, but can't be precisely displayed in actual size in WPF scaling mode. As a result, huge bitonal images display fast in Native scaling mode, but may cause an exception in WPF scaling mode.

See Also
Scaling Modes


Usage of the Canvas Element
User Guide > How to Work with... > Image Display > Display Images in WPF Environment > Usage of the Canvas Element

The ImGearPresentationPageDisplay. DrawToCanvas Methods accept a Canvas as a parameter. The methods add an image element to that Canvas, and render the ImGearPage Class into this image element.

ImageGear assumes that no other Image elements are attached to the canvas. If an image element already exists in the canvas, ImageGear assumes that this element was created in the previous DrawToCanvas Method operation, and draws the image in it. If you need to use ImageGear in a complex scene or document, containing other UI Elements, create a parent canvas, add non-ImageGear elements to it, and a canvas where you will draw ImageGear image.

If ImGearPresentationPageDisplay Class contains annotations attached to it, ImageGear creates a canvas for annotation objects, and adds it to the user provided canvas.


Clipboard Operations
User Guide > How to Work with... > Clipboard Operations

ImageGear .NET allows you to easily copy, cut and paste all or part of an image to and from the Windows clipboard. The following sections explain how to:

  • Clipboard Operations
    • Copy or Cut to the Clipboard
    • Check the Contents of the Clipboard
    • Paste an Image from the Clipboard


Copy or Cut to the Clipboard
User Guide > How to Work with... > Clipboard Operations > Copy or Cut to the Clipboard

You may copy or cut all or part of an ImGearRasterPage instance to the clipboard:

  • To copy image data, call ImGearRasterPage.CopyToClipboard.
  • To cut image data replacing it with a specified fill color, call ImGearRasterPage.CutToClipboard. Note that a solid RGB fill color is required when calling cut. If the actual color space of the image is not RGB, ImageGear .NET will automatically use the closest possible match.
  • To limit a copy or cut operation to only a portion of an ImGearRasterPage instance, first set the ImGearRasterPage.ROI property (which specifies the active region of interest). Note that a region of interest can be either rectangular (using ImGearROIRectangle) or non-rectangular (using ImGearROIMask).
When using an ImGearROIMask to set the non-rectangular region of interest, ImageGear .NET does not actually apply the mask before copying or cutting to the clipboard. Instead, both the mask and underlying image data are copied to the clipboard using a proprietary format. As long as this clipboard data is retrieved using the static ImGearRasterPage.GetFromClipboard method, the returned ImGearRasterPage instance will contain both the rectangular image data and a matching non-rectangular mask (as an ImGearRasterPage.ROI property). However, if the data from the Windows clipboard is pasted into a third-party application, the mask will not be honored. Instead, the entire rectangular region beneath the bounding box, defined by the mask, will be pasted.


Check the Contents of the Clipboard
User Guide > How to Work with... > Clipboard Operations > Check the Contents of the Clipboard

You can easily check if the clipboard currently contains image data that is usable by ImageGear .NET via the ImGearRasterPage.CanGetFromClipboard property. We recommend you always check that this property returns True before calling ImGearRasterPage.GetFromClipboard.


Paste an Image from the Clipboard
User Guide > How to Work with... > Clipboard Operations > Paste an Image from the Clipboard

To get an image from the clipboard as a new ImGearRasterPage instance, simply call the static ImGearRasterPage.GetFromClipboard method. If the clipboard contains valid image data, a new ImGearRasterPage instance will be returned.

If the clipboard contains data previously copied from an ImGearRasterPage instance, which happened to contain a non-rectangular region of interest, then the new ImGearRasterPage instance returned from the clipboard will contain a matching non-rectangular region of interest (the ImGearRasterPage.ROI property will contain an ImGearROIMask instance that matches the mask originally copied to the clipboard).

ImageGear .NET does not provide a special method for pasting the clipboard image into a pre-existing ImGearRasterPage. However, this can be easily achieved using the ImGearRasterProcessing.Merge method.

The following example includes code to handle mismatched color spaces and channel depths:

C# Example
Copy Code
ImGearRasterPage page = ImGearRasterPage.GetFromClipboard();
if (page != null)
{
    ImGearRasterPage currentPage = this.imGearPage as ImGearRasterPage;
    if (currentPage != null)
    {
        if (!currentPage.DIB.ColorSpace.Equals(page.DIB.ColorSpace))
        {
            // Convert to the destination color space.
            ImGearRasterProcessing.ConvertColorSpace(page, currentPage.DIB.ColorSpace);
        }
        bool changeDepth = false;
        if (currentPage.DIB.ChannelDepths.Length != page.DIB.ChannelDepths.Length)
        {
            changeDepth = true;
        }
        else
        {
            for (int i = 0; i < currentPage.DIB.ChannelDepths.Length; ++i)
            {
                if (currentPage.DIB.ChannelDepths[i] != page.DIB.ChannelDepths[i])
                {
                    changeDepth = true;
                    break;
                }
            }
        }
        if (changeDepth)
        {
            // Convert to the destination bit depth.
            ImGearRasterProcessing.ChangeChannelDepths(page, currentPage.DIB.ChannelDepths);
        }
        if (ImGearRasterProcessing.Verifier.CanApplyMerge(currentPage, page))
        {
            ImGearRasterProcessing.Merge(currentPage, page, 0, 0, ImGearMergeModes.OVER);
        }
        else
        {
            // Incompatible images. Just replace the current page by page from clipboard.
            this.imGearPage = page;
        }
    }
    else
    {
        this.imGearPage = page;
    }
}

VB.NET Example
Copy Code
Dim page As ImGearRasterPage = ImGearRasterPage.GetFromClipboard()
If page IsNot Nothing Then
Dim currentPage As ImGearRasterPage = TryCast(Me.imGearPage, ImGearRasterPage)
    If currentPage IsNot Nothing Then
        If Not currentPage.DIB.ColorSpace.Equals(page.DIB.ColorSpace) Then
' Convert to the destination color space.
            ImGearRasterProcessing.ConvertColorSpace(page, currentPage.DIB.ColorSpace)
        End If
Dim changeDepth As Boolean = False
        If currentPage.DIB.ChannelDepths.Length <> page.DIB.ChannelDepths.Length Then
            changeDepth = True
        Else
            For i As Integer = 0 To currentPage.DIB.ChannelDepths.Length - 1
                If currentPage.DIB.ChannelDepths(i) <> page.DIB.ChannelDepths(i) Then
                    changeDepth = True
                    Exit For
                End If
            Next
        End If
        If changeDepth Then
' Convert to the destination bit depth.
            ImGearRasterProcessing.ChangeChannelDepths(page, currentPage.DIB.ChannelDepths)
        End If
        If ImGearRasterProcessing.Verifier.CanApplyMerge(currentPage, page) Then
            ImGearRasterProcessing.Merge(currentPage, page, 0, 0, ImGearMergeModes.OVER)
        Else
' Incompatible images. Just replace the current page by page from clipboard.
            Me.imGearPage = page
        End If
    Else
        Me.imGearPage = page
    End If
End If


Accusoft Xpress Components
User Guide > How to Work with... > Accusoft Xpress Components

Converting DIB to HDIB

ImageGear for .NET provides a point of integration between the Xpress components and ImageGear, which allows you to copy the raster page DIB to the Xpress components HDIB. This can be done by using the ImGearRasterPage.CopyTo() method that makes a copy of the raster page's image data and gives the new image data to another object, which can be defined in a different Accusoft assembly. When finished, both the raster page and the destination object will contain separate copies of the same image data.

C# Example
Copy Code
using (FileStream fileStream = new FileStream("image.tif", FileMode.Open))
{
    // Load an image page.
    ImGearRasterPage page = ImGearFileFormats.LoadPage(fileStream, 0) as ImGearRasterPage;
    // Copy the page's DIB to the xpressComponent's HDIB.
    page.CopyTo(xpressComponent);
}
Visual Basic Example
Copy Code
Using fileStream As New FileStream("image.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
    ' Load an image page.
    Dim page As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(fileStream, 0), ImGearRasterPage)
    ' Copy the page's DIB to the xpressComponent's HDIB.
    page.CopyTo(xpressComponent)
End Using

Using ImageGear from Xpress Components

ImageGear for .NET implements an internal interface that allows the ImGearRasterPage to act as a target of the CopyTo(), TransferTo() and Analyze() methods of the Xpress components, which makes it easier for the ImageGear for .NET and Xpress code to work together and for you to pass an HDIB to and from the Xpress components.

C# Example
Copy Code
using (FileStream fileStream = new FileStream("image.tif", FileMode.Open))
{
    // Load an image page.
    ImGearRasterPage page = ImGearFileFormats.LoadPage(fileStream, 0) as ImGearRasterPage;
    // Analyze loaded raster page using Xpress component.
    xpressComponent.Analyze(page);
}
Visual Basic Example
Copy Code
Using fileStream As New FileStream("image.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
    ' Load an image page.
    Dim page As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(fileStream, 0), ImGearRasterPage)
    ' Analyze loaded raster page using Xpress component.
    xpressComponent.Analyze(page)
End Using


Metadata
User Guide > How to Work with... > Metadata

Such complex file formats as EXIF, TIFF, JPEG-JFIF, PNG and some others contain a lot of non-image data generally referred to as metadata. ImageGear provides functionality to read the metadata during image loading, to store it with the image in memory, and modify metadata during image saving.

ImageGear for .NET provides two sets of API for working with non-image data:

  • General Metadata API. This set of API provides unified access to metadata of all supported image formats. Non-image data itself can be of any possible complex type and completely depends on the nature of the file format itself. ImageGear processes this complex data through a single interface and provides uniform processing that does not depend on the actual data format and varies from information fields of such simple formats as BMP and PCX, up to the complex EXIF and IPTC metadata support in such filters as TIFF and JPEG.
  • Simplified Metadata API. This set of API provides access to standard tags of specific complex formats, such as TIFF, EXIF, and IPTC. It takes care of the location of particular tags in the metadata tree, decodes and encodes complex metadata values, and provides structures and enumerations for data types according to the metadata standard.

ImageGear for .NET is responsible for translating this format-dependent data into a standard uniform format. As soon as an image is loaded, its metadata is accessible through ImGearPage. Metadata Property and ImGearDocument. Metadata Property objects.

You do not need to load image pixels to obtain the non-image data. Use ImGearFileFormats. LoadPageHeader Method to load DIB info and metadata without loading pixel data.

This section provides information about the following:

  • Use Common Metadata
  • Access Metadata
  • Use the Metadata Dictionary
  • Update File Metadata without Updating Pixel Data
  • Work with XMP Metadata
  • Use Simplified Access to Metadata
See Also
Metadata Structures


Use Common Metadata
User Guide > How to Work with... > Metadata > Use Common Metadata

ImageGear for .NET uses its Metadata API to provide information that is common for all image file formats, such as compression of file page from which the image was loaded.

Use ImGearMetadataHead. Common Property to access common metadata.


Access Metadata
User Guide > How to Work with... > Metadata > Access Metadata

ImageGear for .NET uses different storage for Document level metadata and Page level metadata:

  • Document level metadata is only used with file formats that are capable of storing multiple pages. This metadata includes only values that are common for all pages of the image.
  • Page level metadata is available for all file formats. It includes data that describes an image page.

Different file formats use different metadata structures and tags. When saving an image to a file format that differs from the format of metadata attached to the image, the image's metadata is ignored, and default metadata is created instead.

ImageGear uses a tree structure to store format metadata. All nodes of the metadata use a common parent class: ImGearMetadataNode Class. The two following classes are derived from it:

  • ImGearMetadataLeaf Class can only contain data and no nested nodes;
  • ImGearMetadataTree Class can contain the nested nodes, but cannot contain the data values.

A special node of type ImGearMetadataHead Class is always present in every ImGearPage Class and ImGearDocument Class as a class member. It cannot be attached to any metadata node, and it can only have one child. If the page (document) has metadata, then a metadata tree is attached to this Head node. Otherwise, the Head does not have child nodes.

A node can be un-referenced or referenced from the one parent, but it cannot be referenced from multiple parents. The node cannot reference itself directly or indirectly. ImageGear checks this when the node is attached to another node. A metadata tree cannot be shared between multiple pages or documents.

Every metadata node has Format Field of ImGearMetadataFormats Enumeration type. This allows you to store, for example, EXIF metadata under TIFF metadata. A Format Field value of ImGearMetadataFormats Enumeration.NONE can be used to indicate a custom/unknown format.

The actual data in ImGearMetadataLeaf Class uses System.Object type. The NativeType Field of the ImGearMetadataLeaf Class object specifies the type of data that is used by a file format.

Several leaves can reference the same object. ImageGear does not check or maintain consistency between an image and the metadata attached to it. For example, if an image loaded from a TIF file is resized, ImageGear does not update ImageWidth and ImageHeight tags in the image metadata. However, when you save this image, the correct values will be written to the file.


Use the Metadata Dictionary
User Guide > How to Work with... > Metadata > Use the Metadata Dictionary

ImageGear provides a metadata dictionary that stores necessary information for all known metadata tags of all supported formats.

The application can obtain an information record for any tag that is present in the dictionary, using ImGearMetadataDictionary. LookUp Method.

All tag information records implement IImGearMetadataDictRecord Interface. This interface provides minimal information for a tag a its name. This is sufficient for most ImageGear supported formats. These formats use ImGearCommonMetadataDictRecord Structure for storing tag information. This structure only contains the tag and its name.

Dictionary records for DICOM tags contain additional fields, such as ValueRepresentation and MaxMultiplicity. ImageGear uses ImGearDICOMMetadataDictRecord Class to store DICOM tag information.

ImageGear contains an expansive set of predefined dictionary records. In addition, the dictionary allows adding new records for new or custom tags that are not present in the predefined dictionary. The dictionary also allows overwriting predefined information for a tag with a custom one. Use ImGearMetadataDictionary. AddRecord Method for this.

Use ImGearMetadataDictionary. Reset Method to reset the dictionary to its initial state. This method removes all records that were added by the AddRecord Method, and leaves only predefined records.

Metadata dictionary only affects General Metadata API. It does not affect Simplified Metadata API.


Update File Metadata without Updating Pixel Data
User Guide > How to Work with... > Metadata > Update File Metadata without Updating Pixel Data

There are cases when an application needs to update the metadata of an image file while leaving its pixel data unchanged. For example, if the image is compressed using a Lossy compression scheme, this avoids degradation of image quality.

Use ImGearFileFormats.LoadPageMetadata or ImGearFileFormats.LoadDocumentMetadata methods to load metadata from a document or an individual page.

Use regular Metadata API to edit the values in the loaded metadata tree.

Use ImGearFileFormats.UpdatePageMetadata or ImGearFileFormats.UpdateDocumentMetadata methods to save the new metadata to an image file without changing its pixel data.

ImGearFileFormats.UpdatePageMetadata and ImGearFileFormats.UpdateDocumentMetadata are not supported for some formats. Please refer to the file format reference guide to see if the metadata update is supported for a given format.
ImGearFileFormats.UpdatePageMetadata and ImGearFileFormats.UpdateDocumentMetadata methods are not supported for DICOM vector waveform files.


Work with XMP Metadata
User Guide > How to Work with... > Metadata > Work with XMP Metadata

Extensible Metadata Platform (XMP) is an XML-based standard for storage and interchange of metadata, developed by Adobe Systems, Inc. The standard defines the rules for storage and processing of metadata, and provides a number of schemas for storage of information that is typically associated with images and documents, such as Title, Author, Creation date/time, Rating, etc. Applications can add custom schemas to store additional information.

XMP metadata can be attached to files of various formats, such as TIFF, PNG, GIF, DNG, JPEG, PSD, PDF, PostScript, JP2 and JPX.

ImageGear provides the following ways for working with XMP metadata:

  • Accessing XMP properties via the ImageGear Metadata API. In this mode, ImageGear decodes XMP properties and accumulates them in the metadata structure, which is attached to the ImGearPage object when working with the raster formats or ImGearDocument object when working with PDF or PostScript. Then, the application can access individual properties in one of the two ways:
    • General Metadata API. In this mode, the application works with a tree structure containing XMP properties. This mode supports arbitrary XMP schemas. However, working in this mode requires that the application developer has some knowledge of both the XMP standard and particular schemas. See Access XMP Tags via General Metadata for information.
    • Simplified Metadata API. In this mode, the application works with classes that allow simple access to particular properties, without the need to know details of the XMP standard, and with only a minimal knowledge of XMP schemas. Simplified API only supports schemas that are known to ImageGear. See the description of ImGearXMPMetadataRoot Class for a list of supported schemas. See Access XMP Tags via Simplified Metadata for information.
  • Working with unprocessed XMP metadata. In this mode, ImageGear passes XMP to the application as a single byte array containing XMP tags. The application can parse this array using a third party XML parser. On the writing side, the application prepares an array containing XMP tags, and passes it to ImageGear. Unprocessed XMP metadata can be accessed via the metadata structure of the containing format, such as TIFF or JPEG, using General Metadata API. The metadata tree will contain only the XMP tag, containing a binary array.

By default, ImageGear parses the XMP stream into its metadata structure, and does not provide the Raw XMP stream. If you don't want ImageGear to parse the XMP stream, and prefer to access the unprocessed XMP stream, set ImGearLoadOptions. ParseXMP Property to false.

During saving, if an XMP tag contains a tree, ImageGear serializes the tree into an XMP stream. Alternatively, if XMP tag contains a byte array, ImageGear saves this array verbatim.

This section provides information about the following:

  • Work with XMP Metadata
    • Access XMP Tags via General Metadata
    • Access XMP Tags via Simplified Metadata
    • Use XMP Metadata in PDF and PS


Access XMP Tags via General Metadata
User Guide > How to Work with... > Metadata > Work with XMP Metadata > Access XMP Tags via General Metadata

Since the XMP standard identifies schema properties using string names rather than numbers, ImageGear also uses names to identify XMP properties. However, it uses numeric identifiers to differentiate between the kinds of entities, such as Description (schema), Array, Property, Qualifier, etc. All properties have ID = ImGearXMPTagIDs.Property, but differ by their names.

See XMP Non-Image Data Structure section for description of XMP metadata structure in ImageGear.

Example:

Representation of XMP metadata using the General API:

- XMP

  • http://ns.adobe.com/xap/1.0/
    • About = "uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b"
    • Namespace
      • Prefix = "xmp"
      • URI = "http://ns.adobe.com/xap/1.0/"
    • Namespace
      • Prefix = "xmpidq"
      • URI = "http://ns.adobe.com/xmp/Identifier/qual/1.0/"
    • Properties
      • xap:Rating
        • Value = 4
      • xap:Identifier
        • Value = "1234.0345.34532.234231"
        • Qualifiers
          • xmpidq:Schema
            • Value = "Accusoft doc IDs"
  • http://purl.org/dc/elements/1.1/
    • Namespace
      • Prefix = "dc"
      • URI = http://purl.org/dc/elements/1.1/
    • Properties
      • dc:subject
        • Bag
          • Item
            • Value = "Test subject 1"
          • Item
            • Value = "Test subject 2"
      • dc:title
        • Alt
          • Item
            • Lang = "x-default"
            • Value = "XMP Support Specification"


Access XMP Tags via Simplified Metadata
User Guide > How to Work with... > Metadata > Work with XMP Metadata > Access XMP Tags via Simplified Metadata

Simplified Metadata API allows the application to work with classes that allow simple access to particular properties, without the need to know details of the XMP standard, and with only the minimal knowledge of XMP schemas.

Simplified API only supports schemas that are known to ImageGear. See ImGearXMPMetadataRoot Class for a list of supported schemas.

XMP schemas use arrays and structures extensively. Please read the Use Arrays and Structures topic.


Use XMP Metadata in PDF and PS
User Guide > How to Work with... > Metadata > Work with XMP Metadata > Use XMP Metadata in PDF and PS

ImageGear .NET PDF component reads the XMP metadata attached to a PDF and PS document, and writes it back when the document is saved. Metadata extracted from a PDF or PS/EPS file is attached to the whole ImageGear document as a common ImageGear metadata tree, which can be processed with General or Simplified Metadata API. The XMP metadata tree is not attached to pages, because it is related to the whole document.

When the ImageGear .NET PDF component creates a new PDF document, it creates and attaches a default XMP tree containing the following schemas: Dublin Core, Basic XMP, Adobe PDF and Media Management. This set of schemas is also automatically populated when a PDF document is created with Acrobat.

The ImageGear .NET PDF component also provides the following methods to work with non-XMP PDF metadata:

ImGearPDFDocument.SetInfo and ImGearPDFDocument.GetInfo. That metadata is stored in a PDF Document Information Dictionary, which is separate to the XMP stream. However, for consistency reasons, the SetInfo would update the metadata in both the XMP tree and the Document Information Dictionary storages, and the GetInfo would access the data from the XMP metadata tree.


Use Simplified Access to Metadata
User Guide > How to Work with... > Metadata > Use Simplified Access to Metadata

ImageGear provides simplified API for accessing specific types of metadata. This API provides the ability to read and write metadata items without the need to know the exact location of these items in the metadata tree. ImGearMetadataHead Class contains accessor members that provide access to metadata structures, such as TIFF, EXIF, or IPTC. These accessors represent all standard metadata tags via their properties. Each property uses a specific type, corresponding to the metadata item type, as defined in the specification.

For example:

C#
Copy Code
string ImageDescription = (page.Metadata.TIFF as ImGearTIFFMetadata).ImageDescription;

A file does not have to include all of the metadata items that are defined by the standard. If a particular item is not present in the metadata tree, the corresponding property returns null. In order to allow such behavior for integers and other value types, corresponding properties use Nullable types.

C#
Copy Code
ImGearTIFFOrientation igTIFFOrientation =
    (igPage.Metadata.TIFF as ImGearTIFFMetadata).Orientation.GetValueOrDefault(ImGearTIFFOrientation.TopLeft);
VB .NET
Copy Code
Dim igTIFFOrientation As ImGearTIFFOrientation = DirectCast(igPage.Metadata.TIFF, ImGearTIFFMetadata).Orientation.GetValueOrDefault(ImGearTIFFOrientation.TopLeft)

On the writing side, setting a property to some value replaces the existing value with a new one. Setting a property to null removes the corresponding item from the metadata tree.


Use Metadata Structures
User Guide > How to Work with... > Metadata > Use Simplified Access to Metadata > Use Metadata Structures

Currently, ImageGear provides simplified access for the following types of metadata:

Metadata Type | ImageGear Class | ImGearMetadataHead Property
TIFF | ImGearTIFFMetadata Class | ImGearMetadataHead. TIFF
EXIF | ImGearEXIFMetadata Class | ImGearMetadataHead. EXIF
IPTC | ImGearIPTCMetadata Class | ImGearMetadataHead. IPTC

The following table shows the file formats that contain the metadata structure:

Metadata Type | File Formats
TIFF | TIFF, JFIF JPEG, Camera Raw formats
EXIF | TIFF, JFIF JPEG, Camera Raw formats
IPTC | TIFF, JFIF JPEG, Camera Raw formats

EXIF metadata also has subtrees that are represented by the following classes:

Metadata Type | ImageGear Class | ImGearEXIFMetadata Property
EXIF GPS | ImGearEXIFGPSMetadata Class | ImGearEXIFMetadata. GPS
EXIF Interoperability | ImGearEXIFInteropMetadata Class | ImGearEXIFMetadata. Interoperability

Classes of the simplified API do not store their own copy of the metadata values. Instead, they access values that are stored in the general metadata tree.

If the page does not contain a specific metadata structure, the corresponding accessor returns null. For example, if an ImGearPage Class was loaded from a BMP image, it will not contain EXIF metadata, and page.Metadata.EXIF will return null.

Simplified API only supports metadata items that were known to Accusoft at the time of toolkit development, i.e., standard or well-known items. Use general metadata API to access custom and non-standard metadata items.

The EXIF specification uses a subset of tags defined in the TIFF specification. Due to this, ImGearEXIFMetadata Class contains a subset of TIFF tags (those that are referenced in the EXIF specification). These tags can be accessed through either ImGearEXIFMetadata Class or ImGearTIFFMetadata Class accessors.


Create New Metadata Structures
User Guide > How to Work with... > Metadata > Use Simplified Access to Metadata > Create New Metadata Structures

If a metadata structure does not exist in the image, the application can create it.

For example:

C#
Copy Code
igPage.Metadata.IPTC = new ImGearIPTCMetadata();
VB .NET
Copy Code
igPage.Metadata.IPTC = New ImGearIPTCMetadata()

However, the page's target metadata format should support the metadata tree being created. For example, if a page was loaded from a BMP image, you cannot add IPTC metadata to it. In order to do that, you should set target metadata format to one that supports the metadata structure you are going to add. Use ImGearMetadataHead. SetTargetFormat Method and ImGearMetadataHead. GetTargetFormat Method to control the target metadata format of the page. Note that changing the target metadata format erases all data from the previous format.


Use Arrays and Structures
User Guide > How to Work with... > Metadata > Use Simplified Access to Metadata > Use Arrays and Structures

ImageGear does not use a separate data storage for the Simplified Metadata API. Instead, it uses the General Metadata storage engine. Simplified API classes only provide easy access to the data stored in the General metadata tree. As a result, there are a few points you may consider.

Each time you access an array or a structure in the Simplified Metadata API, ImageGear returns a new instance of array or structure, with all corresponding data copied into it. To maintain optimal performance, it is better to assign the array to a local variable, and then access its values, rather than access the array property from the metadata for retrieving each value:

Example
Copy Code
// Access array property once - good performance
ImGearXMPBag<ImGearXMPString> Subject = (igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject;
if (Subject != null)
{
    for (int i = 0; i < Subject.Count; i++)
        Debug.WriteLine(Subject[i].Value);
}
// Access array property multiple times - array is
// created and copied each time a value is accessed (poor performance)
if ((igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject != null)
{
    for (int i = 0; i < Subject.Count; i++)
        Debug.WriteLine((igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject[i].Value);
}
VB .NET
Copy Code
' Access array property once - good performance
Dim Subject As ImGearXMPBag(Of ImGearXMPString) = DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject
If Subject IsNot Nothing Then
    For i As Integer = 0 To Subject.Count - 1
        Debug.WriteLine(Subject(i).Value)
    Next
End If
' Access array property multiple times - array is
' created and copied each time a value is accessed (poor performance)
If DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject IsNot Nothing Then
    For i As Integer = 0 To Subject.Count - 1
        Debug.WriteLine(DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject(i).Value)
    Next
End If

In order to set an array or structure type property, create a new array (structure), set its values as needed, and then assign this array (structure) to the corresponding property of the Simplified API. Changing values of an array or structure which has already been set will not have any effect.

C#
Copy Code
// Incorrect: The array will remain empty
(igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject = new ImGearXMPBag<ImGearXMPString>();
(igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject.Add(new ImGearXMPString("Subject1"));
(igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject.Add(new ImGearXMPString("Subject2"));
// Correct: The array will contain the 2 strings
ImGearXMPBag<ImGearXMPString> Subject = new ImGearXMPBag<ImGearXMPString>();
Subject.Add(new ImGearXMPString("Subject1"));
Subject.Add(new ImGearXMPString("Subject2"));
(igPage.Metadata.XMP as ImGearXMPMetadataRoot).DublinCore.Subject = Subject;
VB .NET
Copy Code
' Incorrect: The array will remain empty
DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject = New ImGearXMPBag(Of ImGearXMPString)()
DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject.Add(New ImGearXMPString("Subject1"))
DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject.Add(New ImGearXMPString("Subject2"))
' Correct: The array will contain the 2 strings
Dim Subject As New ImGearXMPBag(Of ImGearXMPString)()
Subject.Add(New ImGearXMPString("Subject1"))
Subject.Add(New ImGearXMPString("Subject2"))
DirectCast(igPage.Metadata.XMP, ImGearXMPMetadataRoot).DublinCore.Subject = Subject


Image Processing
User Guide > How to Work with... > Image Processing

Using the ImGearProcessing Class, the ImGearRasterProcessing Class, and the ImGearEffects Class it is possible to manipulate an image in different ways:

  • Resize, crop, rotate and flip may be done with the identical members of the ImGearProcessing Class and ImGearRasterProcessing Class.
  • Change of contrast, brightness and/or gamma correction are available through InvertContrast Method(), AdjustContrast Method() and other members.
  • To convert from one color representation to another (e.g., from RGB to CYMK, or RGBA to Grayscale, or 8-bit color to 32-bit color) ConvertColorSpace Method() and ChangeChannelDepths Method() can be used.
  • A combination of two images into a new one may be created using the Merge Method(), CombineChannels Method() and Blend Method().
  • The alpha channel may be operated though the BlendWithAlpha Method() and ConvertColorSpace Method() members.
  • The System Bitmap instance for particular page may be obtained with the Export Method() routine.
See Also
Use Processing Methods
Using ImageGear.Processing Namespace


Use Processing Methods
User Guide > How to Work with... > Image Processing > Use Processing Methods

The classes ImGearProcessing Class, ImGearRasterProcessing Class, and ImGearEffects Class present a set of methods for modifying an image. You do not need to create an ImGearProcessing Class object to call its methods since all methods are static. Any method takes an image to be processed and some additional parameters necessary for processing the operation. For example, the Rotate Method will be called as follows:

ImGearProcessing.Rotate(Page, ImGearRotationValues.VALUE_90);

Image processing methods are shown below:

Action Group | API Reference
Crop - removes part of the image | ImGearProcessing. Crop Method
Resize - retains the same image, but either increase the number of pixels (interpolating to determine the color values for the new ones), or reduce the number of pixels | ImGearProcessing. Resize Method
Changes the geometry of the image | ImGearProcessing. Flip Method ImGearProcessing. Rotate Method ImGearEffects. Shear Method ImGearEffects. Perspective Method
Changes the contrast, brightness and/or gamma correction in the image - all these methods have two representations: the second type takes two additional parameters Contrast Mode and Channel Range; the first representation of any method calculates these parameters according the image type and color space. | ImGearRasterProcessing. InvertContrast Method ImGearRasterProcessing. AdjustContrast Method ImGearRasterProcessing. StretchContrast Method ImGearRasterProcessing. EqualizeContrast Method
Creating a thumbnail - an image with the new size is created but source image is not changed | ImGearProcessing. CreateThumbnail Method
Checking for grayscale image | ImGearRasterProcessing. ImageIsGray Method
Filter methods - these methods are based on the convolution of the image and the filter matrix. Any filter method (except Convolution) has two representations: with and without channel range. | ImGearRasterProcessing. Convolve Method ImGearRasterProcessing. Sharpen Method ImGearRasterProcessing. Smooth Method ImGearRasterProcessing. FilterWithMedian Method ImGearRasterProcessing. FilterWithUnsharpMask Method
Methods for combining two or more images - these methods have two representation: with and without channel range | ImGearRasterProcessing. Merge Method ImGearRasterProcessing. Blend Method ImGearRasterProcessing. BlendWithAlpha Method
Methods for manipulating with image channels and color spaces | ImGearRasterProcessing. ConvertColorSpace Method ImGearRasterProcessing. ChangeChannelDepths Method ImGearRasterProcessing. CombineChannels Method ImGearRasterProcessing. SeparateChannels Method ImGearRasterProcessing. InsertChannel Method ImGearRasterProcessing. RemoveChannel Method ImGearRasterProcessing. CreateChannelCopy Method ImGearRasterProcessing. UpdateChannelFrom Method ImGearRasterProcessing. SwapChannels Method
Processing binary and grayscale images by applying erosion and dilation | ImGearRasterProcessing. Dilate Method ImGearRasterProcessing. Erode Method ImGearRasterProcessing. Close Method ImGearRasterProcessing. Open Method
Stylization - these methods imitate scanned paper photographs, analog cameras, or special photo equipment | ImGearEffects. Aging Method ImGearEffects. NightVision Method ImGearEffects. ToyCamera Method
Artistic effects - these methods make the image look like a hand painted picture | ImGearEffects. Oilify Method ImGearEffects. Pointillist Method ImGearEffects. Spatter Method
Rendering effects - these methods change image lightness or color using a specific shaper or pattern | ImGearEffects. DirectionalLight Method ImGearEffects. FreeDirectionalLight Method ImGearEffects. FreeRadialLight Method ImGearEffects. LensFlare Method ImGearEffects. RadialLight Method ImGearEffects. Spotlights Method ImGearEffects. SpotlightsPreview Method
Image enhancement - these methods enhance image detail | ImGearRasterProcessing. EnhanceLocal Method
Borders and frames - these methods add borders, frames, or vignettes to the image | ImGearEffects. DropShadow Method ImGearEffects. RoundCorners Method ImGearEffects. Vignette Method
Distortions - these methods rearrange pixels using a specific pattern or texture | ImGearEffects. Fragment Method ImGearEffects. Mosaic Method ImGearEffects. Pinch Method ImGearEffects. RadialWave Method ImGearEffects. WarpCylinder Method ImGearEffects. WarpParabolic Method ImGearEffects. WarpSphere Method
Color effects - these methods give the image a new look by changing its color | ImGearEffects. Duotone Method ImGearEffects. Sepia Method ImGearEffects. Spotlights Method ImGearEffects. SpotlightsPreview Method ImGearEffects. Solarize Method
Removes red eye | ImGearPixelCheckerRedEyeRGB. ImGearPixelCheckerRedEyeRGB Constructor ImGearPixelProcessorRedEyeRGB. ImGearPixelProcessorRedEyeRGB Constructor
Detects image edges | ImGearEffects. EdgeDetection Method
Speckle removal - these methods remove noise from a grayscale or bitonal image | ImGearRasterProcessing. Despeckle Method ImGearRasterProcessing. GeomDespeckle Method

The C# samples given below illustrate how to work with some Image Processing methods (in the samples, assume that igPage is a valid object of type ImGearPage Class):

Rotate

C#
Copy Code
// Rotate the page to 45 degrees and expand according to the new image
// size. The background will be set to black.
// Create background color object
ImGearPixel igPixelBackground = new ImGearPixel(igPage.DIB.ChannelCount,
    igPage.DIB.BitsPerChannel);
// Rotate
ImGearProcessing.Rotate(igPage, 45, ImGearRotationModes.EXPAND, igPixelBackground);

Crop

C#
Copy Code
// Cut a quarter of an image from left, top, right and bottom
int cutWidth = igPage.DIB.Width / 4;
int cutHeight = igPage.DIB.Height / 4;
// Crop
ImGearProcessing.Crop(igPage, cutWidth, cutHeight, 2 * cutWidth, 2 * cutHeight);

AdjustContrast

C#
Copy Code
double contrast = 1.2;
double brightness = 64;
double gamma = 1.5;
ImGearRasterProcessing.AdjustContrast((ImGearRasterPage)igPage, contrast, brightness, gamma);
See Also
Using ImageGear.Processing Namespace


Process Using ROI
User Guide > How to Work with... > Image Processing > Process Using ROI

ImageGear for .NET allows you to specify a Region of Interest (ROI) as follows:

  • Specify rectangular ROI for nearly all image processing methods
  • Specify arbitrary ROI for most image processing methods (i.e., ellipse, polygon, and freehand)
  • Create 1-bit mask image for identifying which pixels to include/exclude from image processing algorithms

See ImGearROI Class, ImGearROIMask Class, and ImGearROIRectangle Class for more information.


Using ImageGear.Processing Namespace
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace

ImageGear for .NET has the following Image Processing functionality, among others:

  • Region of interest (ROI) support for basic rectangles as well as ellipses, polygons and other shapes
  • The most complete color space support, including color space conversions, color separation and combination, support for any color space found in any of the 100 supported formats, and support for color spaces such as CMYK, without conversion to RGB, for perfect fidelity
  • Powerful color reduction for maximum quality and minimum size
  • Encryption and decryption for entire image or any part of image
  • Matrix convolutions of any size with pre-defined or user-supplied matrix values
  • Special effects, automatic image correction, intelligent re-sizing

The ImageGear.Processing Namespace API provides various image processing capabilities, including the following image correction and advanced image processing methods:

  • Background Correction
  • Bi-Linear and Bi-Cubic Interpolation
  • Edge Detection
  • Edge Map
  • Image Enhancement
  • Mathematical Morphology
  • Red-Eye Removal
  • Removing Chromatic Aberration
  • Speckle Removal
  • White Balance Correction

...and the following image effects:

  • Aging Effect
  • Artistic Effects
  • Boost Effect
  • Borders and Shadows Effects
  • Duotone Effect
  • Fragmentation Effect
  • Functional Lights Effects
  • Gaussian Blur Effect
  • Glowing Edges Effect
  • High Density Range Effect
  • Hot Wax Effect
  • Lens Flare Effect
  • Monochrome Film Effect
  • Mosaic Effect
  • Night Vision Effect
  • Perspective Effect
  • Picturize Effect
  • Pinch Effect
  • Ripple Effect
  • RoundCorners Effect
  • Sepia Effect
  • Shear Effect
  • Sketch Effect
  • Solarize Effect
  • Spotlights Effect
  • ToyCamera Effect
  • Vignette Effect
  • Warp Effect


Background Correction
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Background Correction

You can add, remove, or find the tilt for a specified image. These methods can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

Adding Tilt

The AddTilt Method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with the slope of the plane in X direction and the slope of the plane in Y direction, as specified in the arguments.

Removing Tilt

The RemoveTilt Method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output. This is very handy for correcting illumination gradients in a poorly digitized image.

Finding Tilt

The FindTilt Method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.


Bi-Linear and Bi-Cubic Interpolation
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Bi-Linear and Bi-Cubic Interpolation

ImageGear's implementation of bilinear and bicubic interpolation for image resize is designed for high image quality, especially when resizing large images down to small sizes (e.g., for thumbnail generation). There are also the ImGearBilinearInterpolationOptions.Sharpness Property and the ImGearBicubicInterpolationOptions.Sharpness Property that allow you to fine-tune the sharpness of the resulting image.


Edge Detection
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Edge Detection

Edge detection is one of the most important subjects in image processing. It finds wide applications in pattern recognition, scene analysis, and 3-D vision, because the edges correspond in general to the important changes of physical or geometrical properties of objects in the scene, and they are widely used as primitives in pattern recognition, image matching, etc.

The edges coincide, generally speaking, with gray level transition, so they can be detected by maxima of gradient or the zero-crossing of the second derivatives calculated by some differential operators. Because the differential operators are sensitive to noise, a preprocessing such as smoothing is often necessary to eliminate the noise.

There are three types of edge detection:

  • Edge detection using the maxima of gradient, i.e., maxima of the first order derivative.
  • Edge detection using the zero-crossings of second order derivative along the gradient.
  • Edge detection using an optimal difference recursive filter.

Can be applied only to 8bit grayscale images with one channel.

See EdgeDetection Method for more information.


Edge Map
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Edge Map

An edge map is an image that shows where there are changes in contrast to the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This EdgeMap Method performs the edge map operation specified by the Method argument. Processes specified range of channels. Processes color channels only.

This method takes into account the ROI settings of page object, that are accessible via the ImGearRasterPage. ROI Property. By default ROI is set to the entire image.


Image Enhancement
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Image Enhancement

This EnhanceLocal Method enhances an image using the local standard deviation and mean.

It transforms the input image f(x, y) to a new image g(x, y) based on the following formula,

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where,

A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8-bit grayscale images with one channel.


Mathematical Morphology
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mathematical Morphology

The field of mathematical morphology contributes a wide range of operators to image processing, all based around a few simple mathematical concepts from set theory. The operators are particularly useful for the analysis of binary images. Common usages include edge detection, noise removal, image enhancement, and image segmentation.

The two fundamental operations in mathematical morphology are Erosion and Dilation. Both of these operators take two pieces of data as input: an image to be eroded or dilated, and a structuring element (also known as a kernel). The two pieces of input data are each treated as representing sets of coordinates in a way that is slightly different for binary and grayscale images.

For a binary image, white pixels are normally taken to represent foreground regions, while black pixels denote background. (Note that, in some implementations, this convention is reversed. It is very important to set up input images with the correct polarity for the implementation being used.) The set of coordinates corresponding to that image is simply the set of two-dimensional Euclidean coordinates of all the foreground pixels in the image, with an origin normally taken in one of the corners so that all coordinates have positive elements.

For a grayscale image, the intensity value is taken to represent height above a base plane, so that the grayscale image represents a surface in three-dimensional Euclidean space. The set of coordinates associated with this image surface is simply the set of three-dimensional Euclidean coordinates of all the points within this surface, as well as all points below the surface, down to the base plane. Note that even when we are only considering points with integer coordinates, this is a lot of points, so usually algorithms are employed that do not need to consider all the points.

The structuring element is already just a set of point coordinates (although it is often represented as a binary image). It differs from the input image coordinate set in that it is normally much smaller, and its coordinate origin is often not in a corner, so that some coordinate elements will have negative values. Note that in many implementations of morphological operators, the structuring element is assumed to be a particular shape (e.g., a 3A3 square) and so is hardwired into the algorithm.

Binary morphology can be seen as a special case of grayscale morphology in which the input image has only two gray levels at values 0 and 1.

Erosion and dilation work (at least conceptually) by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image.

Virtually all other mathematical morphology operators can be defined in terms of combinations of erosion and dilation together with set operators such as intersection and union. Some of the more important are Opening and Closing.

This section provides information about the following:

  • Mathematical Morphology
    • Erosion
    • Dilation
    • Opening
    • Closing


Erosion
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mathematical Morphology > Erosion

Erosion is one of the fundamental operations in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to erode away the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels shrink in size, and holes within those areas become larger. Applying this to the grayscale image will make bright objects smaller, that is, the image will be darker.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of dilation, the effect is the opposite.

For more information, see ImGearRasterProcessing. Erode Method.


Dilation
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mathematical Morphology > Dilation

Dilation is one of the fundamental operators in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to gradually enlarge the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels grow in size while holes within those regions become smaller. Applying this to the grayscale image will make bright objects larger, that is, the image will be lighter.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of erosion, the effect is the opposite.

For more information, see ImGearRasterProcessing. Dilate Method.


Opening
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mathematical Morphology > Opening

Opening is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. The basic effect of an opening is somewhat like erosion in that it tends to remove some of the foreground (bright) pixels from the edges of regions of foreground pixels. However it is less destructive than erosion in general. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve foreground regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of foreground pixels.

For more information, see ImGearRasterProcessing. Open Method.


Closing
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mathematical Morphology > Closing

Closing is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. Closing is similar in some ways to dilation in that it tends to enlarge the boundaries of foreground (bright) regions in an image (and shrink background color holes in such regions), but it is less destructive of the original boundary shape. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve background regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of background pixels.

For more information, see ImGearRasterProcessing. Close Method.


Red-Eye Removal
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Red-Eye Removal

Red-eye removal removes the "red eye" effect in color images by converting the red color in the eye to the new specified color. ImageGear's Red-Eye Removal works by detecting an area around a specified point where the colors correspond to the point color with the specified threshold. This detected area is saved as a Region of Interest (ROI) of the raster page. Red eye is then removed for every point in the ROI of a raster page. It is designed only for red eye removal, not other colors (as may occur with animal eyes).

Original Image | Image with Red-Eye Removed

The ImGearPixelCheckerRedEyeRGB.CheckPixel Method, (when an instance of the ImGearPixelCheckerRedEyeRGB class is being used with the ImGearEffects.DetectArea Method), detects an area around specified point where the colors correspond to the point color with the specified threshold.

For example, the color of the specified point is:

Red == 212;

Green == 96;

Blue == 128;

And threshold is 10.

The method detects a closed polygon around the specified point in which the color components belong to the range.

Red - 202.. 222;

Green - 86..106

Blue - 118.. 138

The ImGearPixelProcessorRedEyeRGB.ProcessPixel Method, (when an instance of the ImGearPixelProcessorRedEyeRGB class is being used with ImGearEffects.ProcessArea Method), removes red eye for every point in the ROI of a raster page.

The following are some examples of corrected color values:

210,39,71 -> 25,23,26

186,77,82 -> 64,54,53

236,95,101 -> 80,80,78


Removing Chromatic Aberration
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Removing Chromatic Aberration

The RemoveChromaticAberration Method removes chromatic aberration artifacts from an image. Chromatic aberration is caused by differences in refraction of light components by the lens, and is seen as colored "fringes" around the image.

Original Image | Image with Chromatic Aberration Removed


Speckle Removal
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Speckle Removal
  • The Despeckle Method removes the color noise from a 1-bit image. It looks for an average color value inside the square area that you specify near the pixel and replaces the pixel with this value.
  • The GeomDespeckle Method is used to reduce speckle noise from an image by using the Crimmins algorithm. It reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique. The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image. It can be applied only to 8bit grayscale images with one channel.


White Balance Correction
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > White Balance Correction

The AdjustWhiteBalance Method corrects the white balance of an image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use AdjustWhiteBalance method, setting source white balance to Tungsten and destination white balance to Daylight.

This method can also be used to make image colors "cooler" or "warmer". To make the image look warmer, use source white point corresponding to a higher color temperature, and destination white point corresponding to a lower color temperature. To make the image look cooler, use source white point corresponding to a lower color temperature, and destination white point corresponding to a higher color temperature.

There are several overloads of this method.

Original Image | Image with White Balance Corrected


Aging Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Aging Effect

The Aging Method applies an aging effect to make an image look older. The effect can adjust image saturation and contrast, and add noise and random vertical lines to the image.

Original Image | Image with Aging Effect


Artistic Effects
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Artistic Effects

ImageGear artistic effects make the image appear to have been hand-painted.

  • The Oilify Method makes the image appear similar to an oil painting.
  • The Pointillist Method makes the image appear to have been painted in the pointillism style of painting. This effect is also known as Dot Mosaic. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.
  • The Spatter Method applies a spatter effect to an image, making it look to have been painted in the impressionist style of painting. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.

Original Image | Image with Oilify Effect
Image with Pointillist Effect | Image with Spatter Effect


Boost Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Boost Effect

The Boost Method increases saturation, brightness and contrast of the image. Use this method if you need a simple way to make old and faded images look more vivid.

Original Image | Image with Boost Effect


Borders and Shadows Effects
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Borders and Shadows Effects

The DropShadow Method adds a drop shadow to an image. The image is enlarged to contain a background and shadowed area.

Original Image | Image with Drop Shadow Effect


Duotone Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Duotone Effect

The Duotone Method maps image colors to a gradient between the two specified colors.

Original Image | Image with Duotone Effect


Fragmentation Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Fragmentation Effect

The Fragment Method fragments an image into four blended images which move diagonally outward from the original image.

Original Image | Image with Fragmentation Image


Functional Lights Effects
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Functional Lights Effects

Functional Lights methods change the colors of an image according to the pattern of a sine wave, or an application defined pattern. The image will appear to have circles or bars of light and/or shadow overlaid on top of it.

  • The DirectionalLight Method adds bars of light according to a sine wave pattern.
  • The RadialLight Method adds circles of light according to a sine wave pattern.
  • The FreeDirectionalLight Method adds bars of light according to a custom pattern.
  • The FreeRadialLight Method adds circles of light according to a custom pattern.

Original Image | Image with Directional Light Effect
Image with Radial Light Effect | Image with Free Directional Light Effect


Gaussian Blur Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Gaussian Blur Effect

The GaussianBlur Method will smooth the images using Gaussian transform. It makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening, and take more processing time. The width of the area considered for each pixel is approximately 6 * radius.

Original Image | Image with Gaussian Blur Effect


Glowing Edges Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Glowing Edges Effect

The GlowingEdges Method highlights edges on the image with bright colors, and fills flat areas with black.

Original Image | Image with Glowing Edges Effect


High Density Range Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > High Density Range Effect

The HighDensityRangeEffect Method increases contrast separately in shadow, highlight and midtone areas, imitating the human eye's ability to adapt for light conditions at the point of interest.

Original Image | Image with High Density Range Effect


Hot Wax Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Hot Wax Effect

The HotWax Method makes an image look like it has been coated with wax.

Original Image | Image with Hot Wax Effect


Lens Flare Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Lens Flare Effect

The LensFlare Method applies a lens flare effect to the image. The effect simulates a bright light, such as the sun, and some reflections within the lens. It is typically used to add a sense of drama or realism to a photographic image.

Original Image | Image with Lens Flare Effect


Monochrome Film Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Monochrome Film Effect

The MonochromeFilm Method makes an image look like it has been taken with an analog camera, using a monochrome film. The method takes a parameter specifying the settings, which imitate particular films.

Original Image | Image with Monochrome Film Effect


Mosaic Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Mosaic Effect

Mosaic Method - Mosaic API provides the following methods:

  • Simple Mosaic a imposes a mosaic effect on a bitmap by dividing an image into tiles of a specified size and changing the color of all pixels in each tile to the average color of pixels within the tile.
  • Tile Mosaic - creates a mosaic effect on an image by dividing an image into rectangular or arc-shaped cells with irregular boundaries and modifying the color of each cell.
  • Dot Mosaic - converts image colors into randomly placed dots to create a pointillist painting, and uses the background color to fill the area between dots.
  • Roman mosaic - segments the image into rectangular or rounded rectangular tiles and fills them with a color chosen randomly from the colors of the tiles pixels.

The mosaic effect divides a bitmap into tiles of a specified size and changes the color of all pixels in each tile to the average color of pixels within the tile.

Original Image | Image with Mosaic Effect

Also refer to the following API for more information:

  • ImGearMosaicBorderParams Class
  • ImGearMosaicCellParams Class
  • ImGearMosaicFillParams Class
  • ImGearMosaicShadowParams Class


Night Vision Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Night Vision Effect

The NightVision Method applies a "night vision" effect to the image.

Original Image | Image with Night Vision, "Binocular" Mode
Image with Night Vision, "Sniper" Mode | Image with Night Vision, "Television" Mode


Perspective Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Perspective Effect

The Perspective Method effect gives a bitmap a 3D effect, as if it exists on a flat plane and has been skewed into a different shape.

Original Image | Image with Perspective Effect


Picturize Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Picturize Effect

The Picturize Method divides the image into rectangular cells, and replaces each cell with an image from the specified image collection, attempting to select cell images such that they match colors of course image.

Original Image | Image with Picturize Effect


Pinch Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Pinch Effect

Pinch Method transforms the current DIB by making it appear as if it were pinched in the center.

A region of interest (ROI) can be used as a pinch base.

Original Image | Image with Pinch Effect


Ripple Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Ripple Effect

The Ripple Effect can be created using one of the following methods:

  • The RadialWave Method
  • The RippleFreeHand Method
  • The RippleTexture Method
  • The Ripple Method


The RadialWave Method
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Ripple Effect > The RadialWave Method

The RadialWave Method warps the image in concentric rings.

Original Image | Image with RadialWave Effect


The RippleFreeHand Method
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Ripple Effect > The RippleFreeHand Method

The RippleFreeHand Method provides the ripple effect on the image, as if it is looked at through a relief glass. The method uses a custom ripple pattern, defined as two one-dimensional arrays containing light deviations in X and Y directions.


The RippleTexture Method
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Ripple Effect > The RippleTexture Method

The RippleTexture Method provides the ripple effect on the image, as if it is looked at through a relief glass. The method uses an image as a ripple pattern.


The Ripple Method
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Ripple Effect > The Ripple Method

The Ripple Method uses one of the predefined ripple patterns defined in the ImGearRipplePattern Enumeration.

Original Image | Image with Ripple 0: Sea Ripple Effect
Image with Ripple 1: Crosshatch Effect | Image with Ripple 2: Tiles with Convex Border Effect
Image with Ripple 3: Tiles with Concave Center Effect | Image with Ripple 4: Flat Tiles with Bevel Edges Effect
Image with Ripple 4: Diagonal Flat Tiles with Bevel Edges Effect |


RoundCorners Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > RoundCorners Effect

The RoundCorners Method rounds the corners of the image and fills them with a specified color.

Original Image | Image with RoundCorners Effect


Sepia Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Sepia Effect

The Sepia Method makes the image look like an old sepia toned photograph.

Original Image | Image with Sepia Effect


Shear Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Shear Effect

The Shear Method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.

Original Image | Image with Shear Effect


Sketch Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Sketch Effect

The Sketch Method blends the source image with a texture image, making it look like painted by a pencil or charcoal.

Original Image | Image with Sketch Effect


Solarize Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Solarize Effect

The Solarize Method effect mimics the accidental exposure of photographic film to light.

Solarize inverts the colors of pixels whose lightness exceeds a given threshold. If lightness is considered on a 0 to 1.0 scale, the default threshold used by various paint programs is 0.5.

In the following set of images, Solarize was performed with a threshold that caused the color of the sky to be inverted while the rest of the image remained uneffected.

Original Image | Image with Solarize Effect


Spotlights Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Spotlights Effect

The Spotlights Method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight. You can also use ImGearEffects.SpotlightsPreview Method for fast generation of a small preview of the effect.

Original Image | Image with Spotlights Effect


ToyCamera Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > ToyCamera Effect

The ToyCamera Method makes the image look as if it was taken by a toy camera. It imitates the distortions caused by cheap lens and poor shooting conditions. Such distortions, however, sometimes make the image look more attractive and lively.

Original Image | Image with ToyCamera Effect


Vignette Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Vignette Effect

You can use the Vignette Method for two purposes:

  • Draw a vignette over an image.
    Original Image Image with Vignette Effect
  • Turn an image into a semi-transparent vignette. You can then blend this vignette over other images.
    Original Image | Vignette
    Image to be Blended with Vignette | Vignette Blended over Image


Warp Effect
User Guide > How to Work with... > Image Processing > Using ImageGear.Processing Namespace > Warp Effect

The WarpCylinder Method, WarpParabolic Method, and WarpSphere Method effects perform a point-to-point stretch of the image to give a warping effect.

Original Image | Image with Warp Cylinder Effect
Image with Warp Parabola Effect | Image with Warp Sphere Effect


Use ImageClean
User Guide > How to Work with... > Image Processing > Use ImageClean

The ImageGear.Processing.ImageClean Namespace contains classes to enhance bi-level image support.

Use this class... | To...
ImGearIC
  • Check for "noise" of black pixels
  • Invert white text
  • Auto-orient an image
  • Auto invert black text on a white background
  • Auto crop
ImGearICBorderOptions | Clean borders
ImGearICDotLineOptions | Remove dotted lines
ImGearICLineOptions | Remove solid lines
ImGearICPunchHoleOptions | Remove Punch Holes
ImGearICVerifier | Verify applicability of ImageClean methods to an ImGearPage object


Process Images in the Frequency Domain
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain
The ImageGear.FreqIP namespace has been deprecated and will be removed from the public API in a future release.

The ImageGear.FreqIP Namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc. This includes the following areas:

  • Fast Fourier Transform
  • Image Filtering
  • Image Restoration
  • Convolution
  • Discrete Cosine Transform and Discrete Sine Transform
Available on ImageGear for .NET 32-bit only.


Fast Fourier Transform
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Fast Fourier Transform

Fast Fourier Transform (FFT) performs a multidimensional FFT on the input object specified by Input File. FFT is based on the FFTW 3 library (see www.fftw.org).

Before using these methods, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable support for FFTW.

  • ForwardFFT
  • ForwardFFTFromImage
  • InverseFFT
  • InverseFFTToImage


ForwardFFT
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Fast Fourier Transform > ForwardFFT

The ForwardFFT Method performs a forward Fast Fourier Transform.

You must keep track how the transform is centered, as well as the scaling method, in the forward FFT in order to know how to de-center it during the inverse FFT.

This method can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessingVerifier. CanApplyForwardFFT Method can be called to check whether the operation can be performed or not.


ForwardFFTFromImage
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Fast Fourier Transform > ForwardFFTFromImage

This ForwardFFTFromImage Method performs a forward Fast Fourier Transform of the input image. The difference between this method and ForwardFFT is that this method takes an ImGearPage Class as the input object.

You must keep track how the transform is centered, as well as the scaling method, in the forward FFT in order to know how to de-center it during the inverse FFT.

This method can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyForwardFFTFromImage Method can be called to check whether the operation can be performed or not.

See Also
ForwardFFT


InverseFFT
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Fast Fourier Transform > InverseFFT

This InverseFFT Method performs an inverse Fast Fourier Transform.

This method can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessingVerifier. CanApplyInverseFFT Method can be called to check whether the operation can be performed or not.


InverseFFTToImage
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Fast Fourier Transform > InverseFFTToImage

This InverseFFTToImage Method performs an inverse Fast Fourier Transform.

This method can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessingVerifier. CanApplyInverseFFTToImage Method can be called to check whether the operation can be performed or not.


Image Filtering
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Filtering

The following image filtering features are available in the ImageGear.FreqIP Namespace:

  • BandPassFilter
  • BandStopFilter
  • HighPassFilter
  • LowPassFilter


BandPassFilter
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Filtering > BandPassFilter

This BandPassFilter Method filters the image using a band-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Cutoff frequency is normalized between 0 and 1.0 where 0 is DC, and 1.0 is the Nyquist frequency.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyBandPassFilter Method can be called to check whether the operation can be performed or not.


BandStopFilter
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Filtering > BandStopFilter

This BandStopFilter Method filters the image using a band-stop filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Cutoff frequency is normalized between 0 and 1.0 where 0 is DC, and 1.0 is the Nyquist frequency.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyBandStopFilter Method can be called to check whether the operation can be performed or not.


HighPassFilter
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Filtering > HighPassFilter

This HighPassFilter Method filters the image using a high-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyHighPassFilter Method can be called to check whether the operation can be performed or not.


LowPassFilter
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Filtering > LowPassFilter

This LowPassFilter Method filters the image using a low-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyLowPassFilter Method can be called to check whether the operation can be performed or not.


Image Restoration
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Restoration

The image restoration filters include:

  • Image Restoration
    • Inverse Filtering
    • Wiener Filtering


Inverse Filtering
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Restoration > Inverse Filtering

This InverseRestore Method restores an image using inverse filtering in the frequency domain. The idea is to deconvolve PSF from the blurred data to extract the original image.

The deconvolution involves dividing the Fourier transform of the blurred image by the Fourier transform of PSF. If the transform of PSF has very small values, then the division result from those small values could easily dominate the entire result. The approach used to get around this issue is to limit the smallest value of the transform of PSF, thus we require a threshold value, dThreshold, to be passed in as a parameter. Ideally, this value will be just above the noise level in the image. This method places zeros in the output for those data points where the magnitude of PSF transform is below the threshold. In this respect, InverseRestore is actually an implementation of a pseudo-inverse filter.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyInverseRestore Method can be called to check whether the operation can be performed or not.


Wiener Filtering
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Image Restoration > Wiener Filtering

This WienerRestore Method performs image restoration using Wiener filtering in the frequency domain. This filter is also commonly referred to as the minimum mean square error filter or the least square error filter.

Usually Wiener filtering can produce better results than inverse filtering.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8-bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyWienerRestore Method can be called to check whether the operation can be performed or not.


Convolution
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Convolution

This Convolve Method convolves an image with the given kernel matrix. The convolution is implemented using FFT, based on the Convolution Theorem, which provides improved performance for larger kernel matrix.

The result of the convolution is multiplied by a normalizer to scale the data. For kernels that sum to zero, the normalizer is usually set to 1.0.

Before using this method, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier. CanApplyConvolve Method can be called to check whether the operation can be performed or not.


Discrete Cosine Transform and Discrete Sine Transform
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Discrete Cosine Transform and Discrete Sine Transform

Before using these methods, like other frequency processing methods, ImGearFrequencyProcessing. InitializeFFTW Method() must be called first to enable the support for FFTW.

  • Forward Discrete Cosine Transform (DCT)
  • Inverse Discrete Cosine Transform (IDCT)
  • Forward Discrete Sine Transform (DST)
  • Inverse Discrete Sine Transform (IDST)


Forward Discrete Cosine Transform (DCT)
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Discrete Cosine Transform and Discrete Sine Transform > Forward Discrete Cosine Transform (DCT)
  • The ForwardDCT Method computes the forward Discrete Cosine Transform (DCT) of the input data.
  • The ForwardDCTFromImage Method computes the forward Discrete Cosine Transform (DCT) of the input image. The difference between this method and ForwardDCT is that this method takes an ImGearPage Class as the input. Can be applied only to 8, 16, or 32bit grayscale images with one channel.


Inverse Discrete Cosine Transform (IDCT)
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Discrete Cosine Transform and Discrete Sine Transform > Inverse Discrete Cosine Transform (IDCT)
  • The InverseDCT Method computes the inverse Discrete Cosine Transform (IDCT) of the input data.
  • The InverseDCTToImage Method computes the inverse Discrete Cosine Transform (IDCT) of the input image. The difference between this method and InverseDCT is that this method returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.


Forward Discrete Sine Transform (DST)
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Discrete Cosine Transform and Discrete Sine Transform > Forward Discrete Sine Transform (DST)
  • The ForwardDST Method computes the forward Discrete Sine Transform (DST) of the input data.
  • The ForwardDSTFromImage Method computes the forward Discrete Sine Transform (DST) of the input image. The difference between this method and ForwardDST() is that this method takes an ImGearPage Class as the input. Can be applied only to 8, 16, or 32bit grayscale images with one channel.


Inverse Discrete Sine Transform (IDST)
User Guide > How to Work with... > Image Processing > Process Images in the Frequency Domain > Discrete Cosine Transform and Discrete Sine Transform > Inverse Discrete Sine Transform (IDST)
  • The InverseDST Method computes the inverse Discrete Sine Transform (IDST) of the input data.
  • The InverseDSTToImage Method computes the inverse Discrete Sine Transform (IDST) of the input data. The difference between this method and InverseDST is that this method returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.


Warnings and Errors
User Guide > How to Work with... > Warnings and Errors

The common language runtime provides an exception handling model that is based on the representation of exceptions as objects.

ImageGear for .NET natively supports the functionality of the new platform and reports errors by throwing an exception containing specific information about the error. It is important to note that not only ImageGear for .NET exceptions can be thrown from its classes - system or currently executing application exceptions may be thrown as well.

ImageGear defines the ImGearException Class to represent errors during execution of its code. Although this class does not have a public constructor, the ThrowError member may be used to report a problem with an appropriate identifier listed in ImGearErrorCodes Enumeration.

The ImGearException Class is used to report critical errors (i.e., when incorrect parameters are specified or internal errors occur). However, to report minor and non-critical mistakes (i.e., an inconsistency of the metadata or image attributes in ImGearPage Class entered into the SavePage Method of the ImGearFileFormats Class), the toolkit uses yet another class a ImGearAddWarning Delegate. To use this functionality, the developer should register a defined delegate to receive information about errors at this level.


Color
User Guide > How to Work with... > Color

This section provides information about the following:

  • Color
    • Color Profiles
      • Use Native CMYK Support
      • Specify Color Profiles
      • Save Images with Embedded Color Profiles
    • Color Channels
    • Transparent Color


Color Profiles
User Guide > How to Work with... > Color > Color Profiles

ImageGear for .NET supports color profiles while performing color conversion operations as well as when displaying color profiled images. ImageGear can apply the embedded image profile as well as the global color profile for display. See ImGearRasterPage. ColorProfile Property and ImGearColorProfileManager Class.

It is often necessary to use color profiles in order to obtain desirable results when converting image data between color spaces such as CMYK and RGB. Different color spaces have different gamuts, or sets of colors that can be represented. Color profiles contain complex mappings that make it possible to carefully manage the translations of colors between different color spaces and gamuts.

A color profile defines instructions for how to map colors from a particular color space to and from a special intermediate color space known as the PCS a profile connection space. There are different ways to do this mapping, representing different tradeoffs and processes, so it is possible to use a wide variety of color profiles. Color profiles typically exist for different input and output devices, such as scanners, cameras, monitors, and printers. Their mappings take into account the physical device characteristics.

When performing color space conversion using color profiles, it is necessary to define a source color profile whose color space matches the color space of the image being converted, as well as a destination color profile whose color space matches the color space to which the image is to be converted.

In addition to source and destination color profiles, a rendering intent is also specified. The rendering intent allows additional control over the conversion process by indicating how certain tradeoffs should be made. For more information, see the ImGearRenderingIntents Enumeration and the ICC color profile specifications at www.color.org.

Detailed information about color processing based on profiles can be found at www.color.org. The following sections describe how color profiles can be used with ImageGear:

  • Color Profiles
    • Use Native CMYK Support
    • Specify Color Profiles
    • Save Images with Embedded Color Profiles


Use Native CMYK Support
User Guide > How to Work with... > Color > Color Profiles > Use Native CMYK Support

ImageGear for .NET provides native CMYK support for all color spaces and bit depths. This means that:

  • Images stored in CMYK format can be loaded into ImageGear without being converted to RGB, ensuring the original color information is maintained with perfect fidelity
  • Images can be saved to formats that support CMYK color space
  • Images stored in CMYK can be optionally converted to RGB when loaded (default for STD), or converted to RGB at any time after loading
  • Basic image processing, image access, display and other methods work with native CMYK image data
  • CMYK images can be color separated or converted to several other color spaces


Specify Color Profiles
User Guide > How to Work with... > Color > Color Profiles > Specify Color Profiles

ImageGear for .NET offers two ways to specify color profiles to use for color conversion operations.

  • The first way is a global profile storage system that allows implicit use of color profiles throughout ImageGear.
  • The second way involves explicit specification of profiles when calling certain overloads of methods such as ImGearRasterProcessing. ConvertColorSpace Method.

Both ways are easy to use, and you should use whichever one suits your particular application's needs.

To enable implicit or "automatic" usage of color profiles for color conversion operations, use the ImGearColorProfileManager Class object. The ImGearColorProfileManager Class and its methods allow enabling and disabling the automatic use of global color profiles for color space conversion and display operations. You will need to set its EnableProfiles Property to True, and specify global color profiles via its CmykProfile Property and/or RgbProfile Property. Once you have done this, these profiles will be used for the color space conversion. If a profile is associated with a particular image via ImGearRasterPage. ColorProfile Property, that profile will be used instead of a global profile as the source profile in a color space conversion. For example, the following code sets the global profiles and converts an image from CMYK to RGB:

C#
Copy Code
ImGearColorProfileManager.EnableProfiles = true;
using (FileStream fs = File.OpenRead("ig_cmyk_profile.icm"))
    ImGearColorProfileManager.CmykProfile = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead("ig_rgb_profile.icm"))
    ImGearColorProfileManager.RgbProfile = new ImGearColorProfile(fs);
ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage)igPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB));

To use explicit specification of color profiles, call the method ImGearRasterProcessing. ConvertColorSpace Method or overload it. The conversion operation will use the color profiles specified by the parameters, ignoring any settings of the ImGearColorProfileManager Class object. For example, the following code converts an image from CMYK to RGB by explicitly specifying color profiles:

C#
Copy Code
ImGearColorProfile igColorProfileSource, igColorProfileDest;
using (FileStream fs = File.OpenRead("ig_cmyk_profile.icm"))
    igColorProfileSource = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead("ig_rgb_profile.icm"))
    igColorProfileDest = new ImGearColorProfile(fs);
ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage)igPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    igColorProfileSource, igColorProfileDest, ImGearRenderingIntents.PERCEPTUAL);


Save Images with Embedded Color Profiles
User Guide > How to Work with... > Color > Color Profiles > Save Images with Embedded Color Profiles

ImageGear supports saving color profiles when saving image files. Currently, ImageGear embeds color profiles in the following file formats:

  • JPEG
  • PNG
  • TIFF

Use EmbedColorProfile Property of ImGearSaveOptions Class to enable or disable embedding of color profiles in image files. By default this property is set to true.

When this property is set to true (default), ImageGear saves the color profile to the file being saved. If the destination format supports the image color space, ImageGear saves the color profile attached to the image, or global color profile selected in ImageGear for this color space. If the color space selected for saving does not match the image color space, ImageGear converts the image to the destination color space, using the global color profile for the destination color space, and saves global color profile to the file.

When this property is set to false, ImageGear does not save the color profile to the destination file. It converts the image to the global color profile during saving. ImageGear also uses this logic for formats that do not support embedded color profiles.


Color Channels
User Guide > How to Work with... > Color > Color Channels

The following types of color channels are currently supported by ImageGear for reading, writing, and display:

  • Alpha Channel
  • Extra Channel

Alpha Channel

An Alpha channel defines opacity/transparency of an image. Only one Alpha channel per image can exist. Color space with Alpha channel can be pre-multiplied or non-pre-multiplied. This is the common definition of an Alpha channel, used by most file formats, such as TIFF, PNG, SGI, TGA, etc.

Extra Channel

An Extra channel is any channel besides regular color channels or Alpha. There can be any number of Extra channels per image. Extra channels may have some defined semantics, such as Mask or Spot channels, or can be "Unknown", meaning that ImageGear does not know how to display or process them.

  • A Mask channel specifies a mask or selection in the image. There can be any number of mask channels per image. Images are never pre-multiplied by mask channels.
  • A Spot channel uses a specific color. The color can be specified using a standard color space, such as RGB or CMYK, or using a custom color, such as Pantone, TRUMATCH, etc. The custom spot color is defined by its Vendor ID and Color ID. See "Spot Channel Vendor IDs", below.
  • An Unknown channel is an extra channel whose purpose is unknown to ImageGear.

These channels can be mixed in arbitrary order. ImageGear does not use separate bit masks from ImGearColorSpaceIDs Enumeration for Mask and Spot channels. Instead, it uses ImGearColorSpaceIDs Enumeration.Extra bit mask to specify presence of any of these channels in an image.

ImageGear stores an array of ImGearExtraChannelInfo Classes in ImGearDIB Class. The length of this array must always be equal to the number of extra channels in the DIB. DIB constructors, color space and channel manipulation functions must ensure this.

If an entry of the info array is ImGearSpotChannelInfo Class, then the corresponding Extra channel is a Spot channel. ImGearSpotChannelInfo Class contains information that is necessary for displaying the spot channel. ImageGear uses spot color channels for display and color space conversions, and saves them to output files when supported by the format. If the output format does not allow storing additional channels, ImageGear converts Spot channels, together with regular color channels, to the destination color space.

If an entry of the info array is ImGearMaskColorChannelInfo or ImGearMaskSpotChannelInfo then the corresponding Extra channel is a Mask channel. ImageGear uses Mask channels for display and saves them to output files when supported by format. However, it does not use them in color space conversions. If the output format does not allow storing additional channels, ImageGear ignores Mask channels in conversion to the destination color space.

If an entry is ImGearExtraChannelInfo Class, then the corresponding Extra channel is unknown. It is not used in display and color conversions, but preserved and saved to output files when possible.

Spot color, Mask, and Extra channels can be appended after any regular color channels, in any order, including color spaces that contain Alpha or Pre-multiplied Alpha channel.

ImageGear for .NET can load extra channels from TIFF and PSD file formats. The extra channels are internally stored as specified above and saved back as extra channels when the output format is either TIFF or PSD. Spot color support is added to the raster color conversion mechanism, so when saving an image to a format that does not support extra channels, the image spot channels are blended to the base channels. The alpha channels are skipped in this case.

Spot Channel Vendor IDs

  • 3000 (ANPA)
  • 3001 (Focoltone)
  • 3002 (PantoneCoated)
  • 3003 (PantoneProcess)
  • 3004 (PantoneProSlim)
  • 3005 (PantoneUncoated)
  • 3006 (Toyo)
  • 3007 (Trumatch)
  • 3008 (HKSE)
  • 3009 (HKSK)
  • 3010 (HKSN)
  • 3011 (HKSZ)
  • 3012 (DIC)
  • 3013 (PantoneMatte)
  • 3020 (PantonePastelCoated)
  • 3021 (PantonePastelUncoated)
  • 3022 (PantoneMetallic)
  • 3024 (HKSEProcess)
  • 3025 (HKSKProcess)
  • 3026 (HKSNProcess)
  • 3027 (HKSZProcess)
  • 3028 (PantoneProSlimEuro)
  • 3029 (PantoneProcessUncoated)

ImageGear for .NET can load Adobe Color Books and apply the loaded colors for displaying spot channels. Color books API allows specifying a path to the color books, enumerates loaded books and colors within a book, and retrieves info on the specific spot color. Display and processing code uses color books to convert spot colors to regular colors such as CMYK, RGB, etc.


Transparent Color
User Guide > How to Work with... > Color > Transparent Color

Reading and writing of transparent color is supported for GIF, PNG, and XPM file formats.

Transparent color is automatically extracted from the image file and attached to ImGearPage. Transparency Field. This color will be transparent on display.


ART Annotations
User Guide > How to Work with... > ART Annotations

This section provides information about the different ways you can annotate your content using ImageGear:

  • ART Annotations
    • Using ImageGear.ART Namespace
      • Annotation and Redlining
      • Creating, Saving, Loading, Modifying, and Deleting ART Marks
        • Creating a Mark via the ToolBar
        • Creating a Mark via API Calls
        • Saving ART Marks
        • Loading ART Marks
        • Edit Mode, Run Mode, and View Mode
        • Modifying Marks
        • Deleting Marks
        • Undoing & Redoing Edit Operations
      • Operating with ART Marks
        • Clipboard Operations
        • Iterating Through Marks
        • Rotating & Flipping the ART Page & Marks
        • Mark Groups
        • Event Handling
        • Statistics
        • Scaling the ART Page & Marks
      • ART 2.0 and ART 3.0 Marks
        • ART 3.0/ART 2.0 Marks
          • Audio
          • Button
          • Curve
          • Ellipse
          • Encryption
          • Freehand Polyline
          • Hot Spot
          • Image
          • Line
          • Polygon
          • Polyline
          • Polyline Ruler
          • Popup Text
          • Protractor
          • Rectangle
          • Rich Text
          • Ruler
          • Text
        • ART 2.0 Legacy Marks
          • Arrow
          • Attach-a-Note
          • Filled Ellipse
          • Filled Polygon
          • Filled Rectangle
          • Highlighter
          • Hollow Ellipse
          • Hollow Polygon
          • Hollow Rectangle
          • Image Embedded
          • Image Reference
          • Pin Up Text
          • Redaction
          • Text from File
          • Text Stamp
          • Typed Text
      • PDF Marks
      • WANG Annotation Marks
      • WPF Annotations
      • Custom Marks
        • Custom Mark Class
        • User Data Attributes
        • Custom Mark Statistics
        • Custom Mark Registration
      • Custom Mark Controller
        • Custom Mark Controller Registration
      • NotateXpress XML (NXXML Marks)
      • ART Security
    • Using ImageGear.ART.Forms Namespace
      • Custom Mark Creation
      • Resizing Custom Marks
      • Custom Mark Property Window
      • Toolbar
      • Mouse Events
    • Using ImageGear.ART.Windows.Controls Namespace
      • Annotator
      • Toolbar Annotator
      • Annotator Settings


Using ImageGear.ART Namespace
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace

Using the ImageGear.ART Namespace, you can annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Marks objects are created using their constructors, but their actual life starts when they are added into the ImGearARTPage Class. ART page can be associated with one or more ImGearPage Class objects. The association is done by using ImGearPageDisplay Class properties: Page Property and ARTPage Property. ART internally tracks the marks that are associated with the image and insures that marks are always displayed on the correct part of the image (even as the image is scrolled, rotated, flipped and zoomed). Your application can save an image with the marks into a separate file in legacy .ART file format or .XML file format. Any time the image is reloaded, the ART marks can be reloaded with a simple API call.

ImageGear.ART Namespace consists of the marks objects as well as the objects for handling marks.

ImageGear.ART.Forms Namespace consists of the GUI objects for interacting with marks and toolbars and marks property dialogs in a WinForms application.

ImageGear.ART.Windows.Controls Namespace consists of the GUI objects for interacting with marks and toolbars and marks property dialogs in a WPF application. See the Using ImageGear.ART.Windows.Controls Namespace section.

To enable the ImageGear.ART Namespace in your project, specify the following directive:

C#
Copy Code
using ImageGear.ART;

To enable the ImageGear.ART.Forms Namespace in your project, specify the following directive:

C#
Copy Code
using ImageGear.ART.Forms;

To enable the ImageGear.ART.Windows.Controls Namespace in your project, specify the following directive:

C#
Copy Code
using ImageGear.ART.Windows.Controls;

This section provides information about the following:

  • Using ImageGear.ART Namespace
    • Annotation and Redlining
    • Creating, Saving, Loading, Modifying, and Deleting ART Marks
      • Creating a Mark via the ToolBar
      • Creating a Mark via API Calls
      • Saving ART Marks
      • Loading ART Marks
      • Edit Mode, Run Mode, and View Mode
      • Modifying Marks
      • Deleting Marks
      • Undoing & Redoing Edit Operations
    • Operating with ART Marks
      • Clipboard Operations
      • Iterating Through Marks
      • Rotating & Flipping the ART Page & Marks
      • Mark Groups
      • Event Handling
      • Statistics
      • Scaling the ART Page & Marks
    • ART 2.0 and ART 3.0 Marks
      • ART 3.0/ART 2.0 Marks
        • Audio
        • Button
        • Curve
        • Ellipse
        • Encryption
        • Freehand Polyline
        • Hot Spot
        • Image
        • Line
        • Polygon
        • Polyline
        • Polyline Ruler
        • Popup Text
        • Protractor
        • Rectangle
        • Rich Text
        • Ruler
        • Text
      • ART 2.0 Legacy Marks
        • Arrow
        • Attach-a-Note
        • Filled Ellipse
        • Filled Polygon
        • Filled Rectangle
        • Highlighter
        • Hollow Ellipse
        • Hollow Polygon
        • Hollow Rectangle
        • Image Embedded
        • Image Reference
        • Pin Up Text
        • Redaction
        • Text from File
        • Text Stamp
        • Typed Text
    • PDF Marks
    • WANG Annotation Marks
    • WPF Annotations
    • Custom Marks
      • Custom Mark Class
      • User Data Attributes
      • Custom Mark Statistics
      • Custom Mark Registration
    • Custom Mark Controller
      • Custom Mark Controller Registration
    • NotateXpress XML (NXXML Marks)
    • ART Security


Annotation and Redlining
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Annotation and Redlining

ImageGear ART helps developers to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with the ImageGear.ART Namespace enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper.

The fundamental "unit" of annotation is called an "ART Mark", or "mark" for short (the original name of ImageGear ART was the "Annotation and Redlining Toolkit"). When the end-user uses your application to annotate an image, (s)he is creating marks. Each mark is defined by some geometry ((x,y) position on the image, height and width, etc.), and (for some marks) textual information (a text string, a date, etc.). While the rest of ImageGear typically works with raster (pixel-based) images, ImageGear ART marks are vector objects a they can be moved, resized, and deleted.

While the marks are vector objects, they typically are intended to be related to some part of the raster image. For example, one of the marks is a digital version of a "PostIt" note (called an "Attach A Note" mark):

If the user scrolls or zooms the image, it's critical that the mark scrolls or zooms with the image a so that it always appears over the same part of the image. ImageGear ART works in conjunction with ImGearPageDisplay Class to make sure that this happens.

For WinForms applications, ImageGear ART provides ART Forms (GUI) tool that the end-user works with to create and edit the marks. Enabling the ART Forms tool makes adding annotation/redlining capabilities to your application easier. See ImageGear.ART.Forms Namespace.

For WPF applications, ImageGear ART provides the WPF Annotator tool that the end-user works with to create and edit the marks. Enabling the Annotator tool makes adding annotation/redlining capabilities to your application easier. See ImageGear.ART.Windows.Controls Namespace.

Once the end-user has created marks for a given image, they need to be saved. ART marks can be saved in the following ways:

  • Save the annotations in a separate .ART or .XML file.
  • "Burn in" the annotations permanently (making them part of the image file).
  • Save the legacy annotations in the image format that supports storing annotations (for example, TIFF files).
  • You may also combine these methods. You can, for example, leave classified information in an ART file and "burn in" non-classified information into the image.

The various marks that can be created with ImageGear ART are described in the following table. Please refer to the ImageGear.ART Namespace for complete descriptions of the ImageGear ART namespace methods.

ART 3.0/ART 2.0 Mark | Example
Text |
Line |
Freehand Polyline |
Rectangle |
Ellipse |
Polygon |
Polyline |
Polyline Ruler |
Audio (a WAV file on disk is read, and the sound played when the user clicks in the mark) |
Image (your application provided the image used - the one shown here is the one used in the sample program) |
Ruler (when a mark is created or editied using the UI, the label’s numeric value is adjusted according to the image resolution and the chosen measurement unit) |
Protractor |
Encryption (visually looks like a filled rectangle). When user clicks on the rectangle, an event is raised allowing to request a password. If password matches the one in the mark, then application can make the mark transparent, which displays the image) |
Button (when user clicks on the button, an event is raised allowing to take action) |
Hotspot (when end-user clicks in shaded area, an event is raised to which your application can respond) |
Rich Text |
ART 2.0 Mark | Example
Arrow |
Filled Rectangle |
Hollow Rectangle |
Filled Ellipse |
Hollow Ellipse |
Filled Polygon |
Hollow Polygon |
Redaction (looks just like a filled rectangle, but cannot be moved after the marks are written to a file) |
Highlighter Rectangle |
Typed Text |
Text Stamp (automatically set to date and/ore time the mark was created) |
Attach-A-Note |
Text From File (a text file on disk is read, and the text displayed in the mark) |
Pin-Up Text (when user clicks on the pushpin, an event is raised allowing the application to display additional text). |
Embedded Image (your application provides the image used a the one shown here is the one used in the sample program) |
Image Reference (an image file on disk is read, and the image in the file is displayed for the mark a the one shown here is just a sample) |

See Also
ART 2.0 and ART 3.0 Marks


Creating, Saving, Loading, Modifying, and Deleting ART Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks

This section provides information about the following:

  • Creating, Saving, Loading, Modifying, and Deleting ART Marks
    • Creating a Mark via the ToolBar
    • Creating a Mark via API Calls
    • Saving ART Marks
    • Loading ART Marks
    • Edit Mode, Run Mode, and View Mode
    • Modifying Marks
    • Deleting Marks
    • Undoing & Redoing Edit Operations


Creating a Mark via the ToolBar
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Creating a Mark via the ToolBar

End users can create a mark using the ART toolbar, or your application can create them directly by calling ART functions. This section describes how to create marks with user interaction through the ART toolbar.

When a button is selected from the toolbar, ART goes into "edit mode", where the mouse is used to place and size the mark. The sequence of events depends on whether the mark is one of the types that contains text or not:

Mark does not contain text:

  1. User drags a rectangle on the image.
  2. Mark is placed and sized on the image, and is selected.
  3. Control returns to the application.

Mark contains text:

  1. User drags a rectangle on the image.
  2. Mark is placed and sized on the image, and is placed in text-edit mode.
  3. Blinking "I-Beam" insertion point is placed in the mark.
  4. User types text into the mark, as desired.
  5. User clicks the mouse-button. Mark goes from text-edit mode to selected.
  6. Control returns to the application.

During the creation of polymarks, such as Polyline, Polyline Ruler or Polygon, two options can be enabled (both are disabled by default):

  1. Auto-rollback: when the user clicks on the last added point (for Polyline, Polyline Ruler, Curve, Polygon) or drags over it (for Freeline), the latest point is removed. This allows the user to fix mistakes in drawing a mark. See the IsPolyMarkAutoRollbackEnabled property.
  2. Auto-close: when the last point of the mark is quite close to the first one, and the mark has the IsClosed property, it is set to True. Marks that support the IsClosed property are Freeline and Polyline. See the IsPolylineAutoCloseEnabled property.

Note that ART ToolBar event handlers are implemented in the ART Forms open source code and can be modified at any time and in any way, but in order for them to work, your application needs to interact with the following events:

C#
Copy Code
private void imGearPageView_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseDown(sender, e);
}
private void imGearPageView_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseMove(sender, e);
}
private void imGearPageView_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseUp(sender, e);
}


Creating a Mark via API Calls
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Creating a Mark via API Calls

Some applications won't use the ART ToolBar, or will provide the ToolBar and other options, to create marks. In that case, some methods in your application will need to create the marks directly. ART marks are created by using their constructors. For example, a rectangle mark can be created as follows:

C#
Copy Code
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(255, 0, 0);
ImGearRectangle igRectangle = new ImGearRectangle(0, 0, 100, 100);
ImGearARTRectangle igARTRectangle = new ImGearARTRectangle(igRectangle, igRGBQuad);

Once it is created, it should be added to the ART page:

C#
Copy Code
int markID;
markID = igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

Mark properties can be edited at any time:

C#
Copy Code
// Get the mark we just added.
igARTRectangle = (ImGearARTRectangle)igARTPage.MarkGet(markID);
igARTRectangle.Opacity = 128;

The same mark cannot be added to the same or another ART page twice; it must be cloned prior to adding it again, otherwise the ImGearException will be thrown. To control whether the mark already has parent group, please use ImGearARTMark.ParentGroup property. See the sample code below:

C#
Copy Code
if (igARTRectangle.ParentGroup != null)
{
    igARTRectangle = igARTRectangle.Clone();
}
igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);
ImGearARTPage otherPage = new ImGearARTPage();
igARTRectangle = igARTRectangle.Clone();
otherPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);


Saving ART Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Saving ART Marks

Once the end user of your application has created some marks, they may want to save them somewhere. Your application has the following choices of where to save them:

  • Save them to a separate .ART file. This is a legacy ART storage format supported in previous versions of ImageGear ART. Using this method, your application will have to keep track of which .ART file goes with which image file, and load them together. Use ImGearART. SavePage Method with ImGearARTSaveType Enumeration.LEGACY parameter to do this.
  • Save them to a separate .XML file. This is a more flexible and extendable storage format highly recommended for using. Using this method, your application will have to keep track of which .XML file goes with which image file, and load them together. Use ImGearART. SavePage Method with ImGearARTSaveType Enumeration.XML parameter to do this.
  • Save the ART marks as tags or objects inside the image file. This option is only available for the raster file formats that support storing annotations, like TIFF files. Use the ImGearART. SavePage Method that takes ImGearPage Class to do this.
  • Save the ART marks as annotations inside the PDF file. This option is only available for PDF format. Use the ImGearART. SavePage Method that takes ImGearPage Class to do this.
  • "Burn In" the ART marks. This converts the ART marks from their native representation to the format of the raster image file, which usually destroys a lot of their functionality (for instance, once a mark is burned in to a JPEG image, it cannot be moved, resized or hidden). Use ImGearART. BurnIn Method to do this.
.ART files can be read by any other application developed with ImageGear.


Loading ART Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Loading ART Marks

Once ART marks have been saved, they can be reloaded (by the same user or a different user, using the same program or using any other ImageGear-enabled application). The way that the marks were saved will determine how they must be reloaded:

  • .ART / .XML / .NXXML / image file / PDF file: Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods and then loads ART page using the appropriate ImGearART. LoadPage Method.
  • Burned In: Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods. The burned-in remains of the marks are loaded as part of the image.

Load Events

The ImGearART.LoadPage method allows the use of the following events:

  • ImGearARTLoadEvents.CreateSecureObjectData
  • ImGearARTLoadEvents.CreatingMark
  • ImGearARTLoadEvents.CreatingGroup
  • ImGearARTLoadEvents.CreatingPage
  • ImGearARTLoadEvents.DroppedMark
  • ImGearARTLoadEvents.DroppedAttribute
  • ImGearARTLoadEvents.GetNotateXpressLayerPassword

These events occur during the loading of ART or NotateXpress™ marks.

  • CreateSecureObjectData event is fired if the loaded Art object contains SecureObjectData.
  • CreatingGroup event is fired before adding group object to ImGearARTPage.
  • CreatingMark event is fired before adding mark object to ImGearARTPage.
  • CreatingPage even is fired before returning a constructed Art Page object.
  • DroppedMark event is fired for unsupported annotations.
  • DroppedAttribute event is fired for unsupported annotation’s attributes/elements.
  • GetNotateXpressLayerPassword event is fired during the loading of NotateXpress annotation file for all layers that were saved with a password.


Edit Mode, Run Mode, and View Mode
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Edit Mode, Run Mode, and View Mode

ART GUI can interact in one of three modes:

  • Edit mode lets users create or edit marks.
  • Run mode lets users operate on Encryption, Image Embedded, Audio, and Button activities.
  • View-only mode lets users view marks, but not add or modify them.

Your WinForms application can switch the mode from one to another by simply setting ImGearARTForms. Mode Property.

Your WPF application can switch the mode from one to another by simply setting Annotator. Mode Property.

While you are in View mode, your application will not have to deal with any ART-related events: it simply loads the image and ART marks and displays them.

If your WinForms application switches to Run mode, then it will have to start dealing with specific ART-related events. For example, for an Encryption mark, when the image and ART marks are first loaded and displayed, the Encryption mark will obscure some or all of the image. When the user moves the cursor over the mark, the cursor will change to pointing hand cursor. The ART Forms event handler will display a dialog box asking for the password to enable viewing of that portion of the image, and then (if the user gets the password correct), unobscure the image.

If your WPF application switches to Run mode, your application will not have to deal with any ART-related events: it simply loads the image and ART marks and displays and detects them.

If your application switches to Edit mode, then it will have to start dealing with specific ART-related events.


Modifying Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Modifying Marks

As long as you are in Edit mode, marks can be modified. There are two ways to modify marks:

  • The first is to use ART Forms property dialogs or Annotator property dialogs.
  • The second is to use mark objects properties and methods.

Geometric changes (like moving and resizing) are done automatically, as a result of ART Forms implementation, as shown in Creating a Mark via the ToolBar. To make other changes to a mark, your application makes a simple call to the mark's properties and methods.

The technique for modifying marks via method call is used in the ART Forms or Annotator dialogs' code. The marks attributes can be modified by changing their properties and using their methods.


Deleting Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Deleting Marks

Marks are deleted by using ImGearARTPage. MarkRemove Method or RemoveMarks Method.


Undoing & Redoing Edit Operations
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Creating, Saving, Loading, Modifying, and Deleting ART Marks > Undoing & Redoing Edit Operations

All Undo/Redo operations are managed by the ImGearARTHistory class. The ImGearARTPage has a corresponding read-only property to access this class instance: ImGearARTPage.History.

To use the Undo/Redo functionality, it is necessary to enable it first; use ImGearARTHistory.IsEnabled to toggle this functionality. When enabled, the History will record the following ART editing operations:

  • Add Mark
  • Remove Mark
  • Change Mark’s Properties
  • Resizing the Mark
  • Repositioning the Mark – Move, Rotate, Flip
  • Change Mark’s Selection
  • Change Mark’s Z-Order
  • Add Group
  • Remove Group
  • Change Group’s Properties
  • Change Page’s Properties

There are 2 separate properties to toggle the recording of Mark’s selection and z-order change: ImGearARTHistory.IsSelectionRecorded and ImGearARTHistory.IsZOrderRecorded which are set to False by default (to not congest the Undo stack).

Recording of Undo history may be a memory consuming operation, especially in the case of adding/removing the marks/groups. It can easily bring an out-of-memory condition. To limit the number of Undo records, use the ImGearARTHistory.Limit property, which by default is 0 (which means 'no limit').

The ImGearARTHistory class has one more alternative property that allows controlling of memory consumption: ImGearARTHistory.Stream. Assign to this property some external stream, e.g. System.IO.FileStream, and the Undo history will be kept in that stream instead of memory. In this case ImGearARTHistory.Limit will not be taken into account.

If the ImGearARTHistory.Stream is being initialized, and if there are already some recorded into the memory Undo actions, they will be lost. Please initialize this property prior to making any edit operations.

The ImGearARTHistory allows grouping of multiple edit operations into a single Undo/Redo operation. Use ImGearARTHistory.BeginGroupingHistory() to start the recording of edit operations into the single action. Use ImGearARTHistory.EndGroupingHistory() to stop recording of the single Undo/Redo action.

The ImGearARTHistory.UndoCount and ImGearARTHistory.RedoCount tell how many times ImGearARTHistory.Undo() and ImGearARTHistory.Redo() can be called.

If there were grouping of several edit operations, ImGearARTHistory.UndoCount and ImGearARTHistory.RedoCount will consider them as a single operation.

Providing Undo and Redo Functionality for Custom Marks

If you have implemented some Custom Marks, (derived from the ImGearARTCustomMark to provide Undo/Redo functionality for its properties), it is necessary to call ImGearARTMark.OnPropertyChanged.


Operating with ART Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks

This section provides information about the following:

  • Operating with ART Marks
    • Clipboard Operations
    • Iterating Through Marks
    • Rotating & Flipping the ART Page & Marks
    • Mark Groups
    • Event Handling
    • Statistics
    • Scaling the ART Page & Marks


Clipboard Operations
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Clipboard Operations

ART marks can be cut from and copied to the clipboard as well as pasted into an image individually or in groups. The ImGearARTPage Class provides the methods to perform clipboard operations.


Iterating Through Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Iterating Through Marks

Sometimes your application will need to iterate through the marks in an ImGearARTPage Class object. This can be done by using a "foreach" mechanism:

For example, to delete all selected marks, your application would do the following:

C#
Copy Code
// Build a list of selected marks.
ArrayList igARTMarks = new ArrayList();
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igArtPage.MarkIsSelected(igARTMark))
        igARTMarks.Add(igARTMark);
}
// Delete the marks.
igArtPage.RemoveMarks(igARTMarks);
// Redraw the view.
imGearPageView1.Invalidate();


Rotating & Flipping the ART Page & Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Rotating & Flipping the ART Page & Marks

To rotate or flip the entire ART page, please use the following methods:

  • ImGearARTPage.Rotate
  • ImGearARTPage.Flip

These methods perform “deep” rotation/flipping; they are updating the coordinates of all marks within the page accordingly.

To rotate or flip the mark(s) separately, please use the following methods of the Mark:

  • ImGearARTMark.Rotate
  • ImGearARTMark.Flip

The rotation/flipping center point of these methods must be provided in the same coordinate system, as the marks were created and added to the ART page (image or device).

If the ART page should be rotated synchronously with the underlying image (ImGearPage), there are some aspects that should be taken into account. If the marks have image coordinates, their position is calculated relatively to the top-left corner of the image, so in the case of rotation by 90 or 270 degrees along with underlying image, the coordinates of the marks should be corrected (i.e., they should be shifted) to put the ART page in the correct position in regard to ImGearPage. Here is a code example for how to rotate by 90 degrees for both ART and the underlying page:

C# Example
Copy Code
private void menuEditRotate90_Click(object sender, System.EventArgs e)
{
    ImGearPoint center = new ImGearPoint(imGearPageView.Page.DIB.Width / 2, imGearPageView.Page.DIB.Height / 2);
    artGUI.Page.Rotate(center, ImGearRotationValues.VALUE_90);
    ImGearPoint centerAfterRotation = CalculateCenterPointShift(center, ImGearRotationValues.VALUE_90);
    foreach (ImGearARTMark mark in artGUI.Page)
    {
        mark.Move(centerAfterRotation.X - center.X, centerAfterRotation.Y - center.Y);
    }
    ImGearProcessing.Rotate(imGearPageView.Page, ImGearRotationValues.VALUE_90);
    imGearPageView.Update();
}
private ImGearPoint CalculateCenterPointShift(ImGearPoint center, ImGearRotationValues rotationAngle)
{
    switch (rotationAngle)
    {
        case ImGearRotationValues.VALUE_90:
            return new ImGearPoint(imGearPageView.Page.DIB.Height - center.Y, center.X);
        case ImGearRotationValues.VALUE_180:
            return new ImGearPoint(imGearPageView.Page.DIB.Width - center.X, imGearPageView.Page.DIB.Height - center.Y);
        case ImGearRotationValues.VALUE_270:
            return new ImGearPoint(center.Y, imGearPageView.Page.DIB.Width - center.X);
        default:
            return center;
    }
}

VB.NET Example
Copy Code
Private Sub mnuEditRot90_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuEditRot90.Click
    Dim center As ImGearPoint = New ImGearPoint(ImGearPageView1.Page.DIB.Width / 2, ImGearPageView1.Page.DIB.Height / 2)
    artGUI.Page.Rotate(center, ImGearRotationValues.VALUE_90)
    Dim centerAfterRotation As ImGearPoint = CalculateCenterPointShift(center, ImGearRotationValues.VALUE_90)
    For Each mark As ImGearARTMark In artGUI.Page
        mark.Move(centerAfterRotation.X - center.X, centerAfterRotation.Y - center.Y)
    Next
    ImGearProcessing.Rotate(ImGearPageView1.Page, ImGearRotationValues.VALUE_90)
    ImGearPageView1.Update()
End Sub
Private Function CalculateCenterPointShift(ByVal center As ImGearPoint, ByVal rotationAngle As ImGearRotationValues) As ImGearPoint
    Select Case (rotationAngle)
        Case ImGearRotationValues.VALUE_90
            Return New ImGearPoint(ImGearPageView1.Page.DIB.Height - center.Y, center.X)
        Case ImGearRotationValues.VALUE_180
            Return New ImGearPoint(ImGearPageView1.Page.DIB.Width - center.X, ImGearPageView1.Page.DIB.Height - center.Y)
        Case ImGearRotationValues.VALUE_270
            Return New ImGearPoint(center.Y, ImGearPageView1.Page.DIB.Width - center.X)
        Case Else
            Return center
    End Select
End Function


Mark Groups
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Mark Groups

ImGearARTPage Class provides a facility called "mark groups" (or just "groups", for short) that provides a powerful mechanism for implementing application features. Every mark belongs to one and only one group; by default all marks belong to a group with index 0 and named "[Untitled]". Your application can create as many groups as needed - each group is given a unique index. ImGearARTPage Class provides a set of methods that manipulate all of the marks in a group (hide them all, make them all visible, etc.). Your application could use groups to provide annotation layers (each "layer" would simply be a group), so that the user could choose which layer, and thus which set of annotations to view. Alternatively, your application could use groups to provide private annotations (each person would only be able to see "their" annotations).

The various methods that operate on groups are provided by ImGearARTGroup Class and ImGearARTGroupArray Class objects.

The same group cannot be added to the same or another ART page (via ImGearARTPage.Groups property) twice; it must be cloned prior to doing it again, otherwise the ImGearException will be thrown. To control whether the group already has parent page please use ImGearARTGroup.ParentPage property. See sample code below:

C#
Copy Code
ImGearARTPage artPage = new ImGearARTPage();
ImGearARTGroup group = new ImGearARTGroup("Group1", "ART Group");
artPage.Groups.Add(group);

ImGearARTPage otherPage = new ImGearARTPage();
if (group.ParentPage != null)
 {
     group = group.Clone();
 }

otherPage.Groups.Add(group);


Event Handling
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Event Handling

Event handlers are implemented in the ART Forms open source code and can be modified at any time and in any way. To enable ART Forms event handlers, your application needs to interact with the following ImGearARTForms methods:

  • MouseDown
  • MouseMove
  • MouseUp


Statistics
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Statistics

ImGearARTMark Class provides a property called "Statistics" that returns the values, such as Length, Area, Perimeter, and characterizing a mark. These measurements are available in different measurement units, like feet, meters, inches, or in user-defined measurement units. Users can select a needed measurement unit by setting the Statistics.Unit property.

To calculate lengths and areas correctly, Statistics needs to have resolution values of the current image, which can be set in the Statistics.Resolution property.

The various properties that return measurements of the mark are provided by the ImGearARTMarkStatistics Class.

Statistics measurements are also available in the ART GUI, in the mark’s properties dialog («Statistics» tab).


Scaling the ART Page & Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Operating with ART Marks > Scaling the ART Page & Marks

To scale the entire ART page, please use following method: ImGearARTPage.Scale.

This method performs "deep" scaling; it is updating the coordinates and dimensions of all marks within the page accordingly.

To scale the mark(s) separately, please use the following method of the mark: ImGearARTMark.Scale.


ART 2.0 and ART 3.0 Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks

This section describes the marks available in the ImageGear ART namespace:

  • ART 3.0/ART 2.0 Marks
  • ART 2.0 Legacy Marks

ART 3.0 set consists of an enhanced list of more flexible marks. These marks are recommended for new applications. The ART 2.0 (Legacy) set consists of the marks backward compatible with the previous ART versions.

Only ART 2.0 marks can be loaded from the .ART files created with previous ART versions, and only ART 2.0 marks can be saved into the legacy ART storage format.

Both ART 2.0 and ART 3.0 marks can be saved into the XML storage format, please note however that ART 2.0 marks will be converted to the appropriate ART 3.0 super class marks. Only ART 3.0 marks are loaded from the XML storage format.

Some ART marks, such as Attach-a-Note, Text Stamp may require Wang compatibility mode enabled to be saved properly in legacy storage format. On the contrary, the Highlighter mark should be saved in legacy format without Wang compatibility mode on.

ART 2.0 Legacy and some 3.0/2.0 Marks of ImageGear for .NET have slightly different default styling properties compared to the ART 2.0 Legacy Marks of ImageGear Pro. If it is necessary to make the appearance of ImageGear for .NET Marks similar to ImageGear Pro, you can use the control parameter ImGearART.IsLegacyAppearanceModeEnabled.

Setting this parameter to true prior to importing from legacy format .ART file or creating using toolbar or API calls will enable legacy appearance mode.

This parameter has an effect for WinForms implementation only, as far as WPF does not have legacy annotations.
Rich Text annotation is displayed transparent if legacy appearance mode is enabled.
For already loaded/created annotations: the switching of this flag will not have any effect. It means that this flag will not dynamically switch appearance of existing marks.

In the case of exporting to legacy .ART format, this parameter will not have any effect.

In the case of exporting to XML format, the modified properties of annotations that were imported/created with the ImGearART.IsLegacyAppearanceModeEnabled flag enabled, will be saved to the XML, so upon loading of that XML, the imported annotations will have the same look as they had upon saving.

Highlight Effect

Some legacy annotations have Boolean property Highlight. When it is set to true, the Highlight effect is applied. This effect is used to highlight the annotated area. The behavior of Highlight effect depends on the value of ImGearART.IsLegacyMarkAppearanceEnabled parameter:

  • If it is true, the Highlight effect changes background color of the mark’s underlying elements and image – it applies AND operation for each background and foreground pixel of the annotation.
  • If it is false (legacy mark appearance is disabled), the Highlight effect makes the current annotation semi-transparent.

The following table shows the style modifications that will be applied to the marks if ImGearART.IsLegacyAppearanceModeEnabled is set to True:

Mark | Property | Value
Arrow
 | Color | Red
 | HeadType | ImGearARTLineHeadType.SOLID
Hollow Polygon | JoinStyle | ImGearARTJoinStyle.Round
 | BorderColor | Red
Line | CapStyle | ImGearARTCapStyle.Round
 | Color | Red
 | Opacity | 255
 | Width | 2
Attach-a-Note | Padding | Left:2, Top:2, Right:2, Bottom:2
Pin Up Text | Padding | Left: dynamically calculated using icon size, Top:1, Right:1, Bottom:1
 | TextColor | Red
 | FontSize | 6
Polyline | CapStyle | ImGearARTCapStyle.Round
 | JoinStyle | ImGearARTJoinStyle.Round
 | Color | Red
 | Opacity | 255
 | Width | 2
Protractor | CapStyle | ImGearARTCapStyle.Round
 | JoinStyle | ImGearARTJoinStyle.Round
 | Color | Red
 | Arc radius | 50
 | Width | 2
Ruler | CapStyle | ImGearARTCapStyle.Round
 | Color | Red
 | Width | 2
 | FontSize | 6
Text from File | Padding | Left:2, Top:2
 | TextColor | Red
Text Stamp | Padding | Left:2, Top:2, Right:2, Bottom:2
 | TextColor | Red
Typed Text | Padding | Left:3, Top:3
 | TextColor | Red
Rich Text | Border | null
 | Opacity | 255
Filled Ellipse | Highlight | true
Filled Polygon | FillColor | Red
 | Highlight | true
Filled Rectangle | FillColor | Red
 | Highlight | true
Freehand Polyline | Color | Red
 | Width | 2
Hollow Ellipse | BorderColor | Red
Hollow Polygon | BorderColor | Red
Hollow Rectangle | BorderColor | Red
Redaction | FillColor | Black

Ruler and Polyline Ruler Legacy Mode

Additional to visual styles, toggled by ImGearART.IsLegacyAppearanceModeEnabled, the ImGearART.IsLegacyRulerAppearanceModeEnabled flag controls the rendering of start/end elements of ImGearARTRuler and ImGearARTPolyRuler marks. In this mode the start/end line length is not being scaled to device resolution, the start/end elements are being rendered by constant size. By default this mode is turned Off. If you need to enable the ImGearARTRuler/ImGearARTPolyRuler legacy appearance mode, you have to set the ImGearART.IsLegacyRulerAppearanceModeEnabled property to True before creating or importing Ruler or Polyline Ruler annotations.

ImGearART.IsLegacyRulerAppearanceModeEnabled parameter has an effect for WinForms implementation only.
For already loaded/created annotations: the switching of ImGearART.IsLegacyRulerAppearanceModeEnabled flag will not have any effect. It means that this flag will not dynamically switch appearance of existing marks.
In the case of exporting to legacy .ART or .XML format, ImGearART.IsLegacyRulerAppearanceModeEnabled parameter will not have any effect, as far as it controls rendering only, it does not change any property of the mark.


ART 3.0/ART 2.0 Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks

This section provides information about the following marks:

  • Audio
  • Button
  • Curve
  • Ellipse
  • Encryption
  • Freehand Polyline
  • Hot Spot
  • Image
  • Line
  • Polygon
  • Polyline
  • Polyline Ruler
  • Protractor
  • Rectangle
  • Rich Text
  • Ruler
  • Text


Audio
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Audio

The Audio mark enables end users to hear sounds when annotating an image or document. It is useful for drawing attention to a particular area of a text or image file. This mark plays a waveform audio file (.WAV).

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Audio button and then drag the mark to its destination.
  2. To display the dialog box, double-click the loud-speaker. This allows you to specify the name of the .WAV file that plays during Run mode.

Run Mode

When the application is in the Run mode, the cursor changes to a pointing hand when it passes over the loud-speaker bitmap. As the mark is activated (makes a sound), lines representing sound waves appear and disappear from the end of the loud-speaker.


Button
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Button

The Button mark places a programmable button on an image. For example, a button can be programmed to zoom into part of an image.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Button button and then drag the mark to its destination.
  2. You can do the following to customize the Button:
    • Resize the Button by dragging the resize handles.
    • Set your application to respond to a right-click by displaying the properties box and selecting the appropriate property.
    • Set several attributes for a button, including font, foreground color, background color ,and text.

Run Mode

When the application is in Run mode, the cursor changes to a pointing hand when it passes over the Button bitmap.


Curve
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Curve

The Curve mark enables the end user to use spline curve drawings. With this mark, end users create spline curves between the specified points and using the specified tension.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click where you want the curve to start.
  2. Drag to the location of a vertice and click.
  3. Drag and click to create each additional vertice.
  4. Double-click the location where the curve ends.


Ellipse
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Ellipse

The Ellipse mark enables end users to cover areas of an image or document with an ellipse. The Ellipse can be with or without border and filled color. It can have a different opacity level.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Ellipse button and then drag the resulting ellipse over the items to be covered.
  2. Right-click the mark after it is created to activate the popup edit menu.


Encryption
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Encryption

The Encryption mark enables your users to scramble all or part of the image.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Encryption button and then drag the resulting rectangle over the area to be scrambled.
Encryption marks cannot overlap.


Freehand Polyline
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Freehand Polyline

The Freehand Polyline mark enables the end user to use freehand drawing for annotation. With this mark, end users create drawings as though they are using a pen and paper.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Freehand Polyline button, drag the image, and then release the mouse button.
  2. Right-click the mark after it is created to activate the popup edit menu.


Hot Spot
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Hot Spot

The Hot Spot mark enables the end user to define an invisible region in a document or image that can be used to hold hidden messages.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Hot Spot button, drag the image, and then release the mouse button.
  2. When the mouse button is released, the resulting rectangle becomes a hot spot region. It remains visible while the application is in edit mode.
  3. Right-click the mark after it is created to activate the popup edit menu.

Run Mode

When a user passes the cursor over this region, the cursor changes, indicating that there is something special about the contents within the invisible region. If the user clicks while the cursor is in the region, your application sends a message detailing the information about the contents of the region.

The Hot Spot region is visible only when the application is in Edit mode.


Image
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Image

The Image mark enables the end user to embed or file reference a bitmap or a vector image in a document or image.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Image button, drag the image, and then release the mouse button.
  2. When the mouse button is released, the image becomes embedded.
  3. Once the bitmap or the vector image is in place on the annotation window, it can be re-sized using the mouse.
  4. Right-click the mark to activate the popup edit menu.

Run Mode

In Run mode, end users interact with a vector Image mark by clicking over the mark and using the popup 3D toolbar. End users can rotate, scale, and move 3D data, as well as change lights and view settings.

To work with the image, do the following:

  1. Click the image mark and use items from the popup 3D toolbar.
  2. Using the toolbar, end users can rotate, scale, and move 3D data, as well as change light and view settings.

Transparent and Semi-transparent Images

The image annotations support two types of transparency – binary transparency and transparency by alpha channel.

Binary transparency specifies one color in the image to be transparent. The pixels with this color are displayed as fully transparent, other pixels - as fully opaque. Each image can have only one transparent color. The transparent color can be selected by using ImGearARTImage.Page.Transparency property.

In case of Transparency by alpha-channel, the alpha channel represents transparency information of an image on a per-pixel basis. A value of 100% in the alpha channel gives a fully opaque pixel and 0% provides a fully transparent pixel. Image annotations support alpha channel only for pages with the following color spaces - RGBA32 and RGBPA32 with 8 bits per channel.


Line
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Line

The Line mark enables the end user to create straight lines on an image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Line button.
  2. Click the point where the line should begin, and drag the line to the point where the line should end.
  3. Release the mouse button to complete the line.
  4. Right-click the mark after it is created to activate the popup Edit menu.


Polygon
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Polygon

The Polygon mark enables the end user to cover areas of an image or document with a polygon.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Polygon button.
  2. Click the point where the polygon should start.
  3. Drag the mouse and click the location of a vertice.
  4. Drag and click to add the desired number of vertices to the polygon.
  5. Double-click to complete the polygon.
  6. Right-click the mark after it is created to activate the popup Edit menu.


Polyline
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Polyline

The Polyline mark enables the end user to create several connected straight lines by dragging and clicking the mouse.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Polyline button.
  2. Click at the point where the polyline starts.
  3. Drag to the location of a vertice and click to create the vertice.
  4. Drag and click to create each additional vertice.
  5. Double-click the location where the polyline ends.
  6. Right-click the mark after it is created to activate the popup Edit menu.


Polyline Ruler
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Polyline Ruler

The Polyline Ruler mark enables the end user to create a polyline (several connected straight lines) that displays its total length.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Polyline Ruler button.
  2. Click at the point where the polyline ruler starts.
  3. Drag to the location of a vertice and click to create the vertice.
  4. Drag and click to create each additional vertice.
  5. Double-click the location where the polyline ruler ends.
  6. Right-click the mark after it is created to activate the popup Edit menu.

Polyline Ruler Length Measuring Modes

ImageGear provides two different length measuring modes for Ruler and PolyRuler annotations – Absolute and Relative, which can be changed using ImGearARTPage.AspectKind property.

  • Absolute – In this mode, a change to the resolution of the underlying image will not affect the physical measurements of your marks (such as length of the ruler or poly-ruler) on the screen. The physical measurements of your marks on the screen are absolute.

If the physical measurements of your marks need to reflect the changes to the resolution of the underlying image, you should work with pages and marks in Relative mode instead.

  • Relative – In this mode, a change to the resolution of the underlying image will affect the physical measurements of your marks (such as length of the ruler or poly-ruler) on the screen. The physical measurements of your marks on the screen are relative to the resolution of the underlying image.

If the physical measurements of your marks need to remain constant regardless of the resolution of the underlying image, you should work with pages and marks in Absolute mode instead.


Popup Text
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Popup Text

The Popup Text annotation enables the end user to add an icon over the displayed document or image, and show text by clicking on the icon. The text can be created in various fonts, sizes, colors, and opacity. It can be created with or without a border or a fill color. The text can be modified by double-clicking on it.

Edit Mode

In Edit Mode, the end user can create a mark as follows:

  1. Click the Popup Text button.
  2. Click the point where the icon should be placed.
  3. To modify it, double-click the Popup Text mark. The cursor appears at the beginning of the text, and transforms to allow editing.

Run Mode

When the application is in Run mode, the cursor changes to a pointing hand when it passes over the icon of the Popup Text mark and the text is shown by clicking on it.


Protractor
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Protractor

The Protractor mark enables the end user to create an angle that displays the arc and the angle measurement.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Protractor button.
  2. Drag to create the first line of the angle.
  3. Click to end the first line. This click creates the vertex and begins the second line.
  4. Click the left mouse button where you want your second line to end. The measured angle is complete.
  5. Right-click the mark after it is created to activate the popup Edit menu.


Rectangle
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Rectangle

The Rectangle mark enables end users to cover areas of an image or document with a rectangle. The Rectangle can be with or without border and filled color. It can have a different opacity level.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Rectangle button and then drag the resulting rectangle over the items to be covered.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Rich Text
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Rich Text

The Rich Text mark enables end users to edit, load, and display RTF text.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Rich Text button and then drag the resulting rectangle over the area to be annotated.
  2. The RTF Editor Tool allows users to load RTF files and edit the RTF text using the menu and toolbar buttons.


Ruler
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Ruler

The Ruler mark enables the end user to create a line that displays its measurement.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Ruler button.
  2. Click where the line begins and drag it to the end of the line.
  3. Release the mouse button to complete the line.
  4. Right-click the mark after it is created to activate the popup Edit menu.

Ruler Length Measuring Modes

ImageGear provides two different length measuring modes for Ruler and PolyRuler annotations – Absolute and Relative, which can be changed using ImGearARTPage.AspectKind property.

  • Absolute – In this mode, a change to the resolution of the underlying image will not affect the physical measurements of your marks (such as length of the ruler or poly-ruler) on the screen. The physical measurements of your marks on the screen are absolute.

If the physical measurements of your marks need to reflect the changes to the resolution of the underlying image, you should work with pages and marks in Relative mode instead.

  • Relative – In this mode, a change to the resolution of the underlying image will affect the physical measurements of your marks (such as length of the ruler or poly-ruler) on the screen. The physical measurements of your marks on the screen are relative to the resolution of the underlying image.

If the physical measurements of your marks need to remain constant regardless of the resolution of the underlying image, you should work with pages and marks in Absolute mode instead.


Text
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 3.0/ART 2.0 Marks > Text

The Text mark enables the end user to add descriptive text to their annotated image or document. The text can be created in various fonts, sizes, colors and opacity. It can be with or without border, fill color, and pin icon. The text appears over the original image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Text button and then drag the resulting rectangle over the area to be annotated. This rectangle helps to position the Text annotations.
  2. To modify it, double-click the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.


ART 2.0 Legacy Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks

This section provides information about the following marks:

  • Arrow
  • Attach-a-Note
  • Filled Ellipse
  • Filled Polygon
  • Filled Rectangle
  • Highlighter
  • Hollow Ellipse
  • Hollow Polygon
  • Hollow Rectangle
  • Image Embedded
  • Image Reference
  • Pin Up Text
  • Redaction
  • Text from File
  • Text Stamp
  • Typed Text


Arrow
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Arrow

The Arrow mark enables the end user to create an arrow over an image or document. It allows users to point to areas of a document that may be of interest to its reader.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Arrow button, drag the image, and then release. The head of the arrow is drawn at the point where the mouse button is first clicked, and the tail (end) of the arrow is set at the location where the mouse button is released.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Attach-a-Note
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Attach-a-Note

The Attach-A-Note mark enables your end users to add notes to their annotated image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Attach-A-Note button and then drag the resulting rectangle over the area to be annotated.
  2. Right-click the mark after it is created to activate the popup Edit menu, which enables you to change the font or the background colors of the note.
    • The Choose Font option displays a dialog box that allows you to change text properties.
    • The Set Background Color option displays a dialog box that allows you to change the color of the note.
  3. To modify the text, double-click the note. The cursor appears at the beginning of the text to allow editing.


Filled Ellipse
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Filled Ellipse

The Filled Ellipse mark enables end users to cover areas of an image or document with an ellipse.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Filled Ellipse button, drag the image, and then release the mouse button.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Filled Polygon
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Filled Polygon

The Filled Polygon mark enables the end user to cover areas of an image or document with a polygon.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Filled Polygon button.
  2. Click at the point where the polygon starts.
  3. Drag the mouse to the location of a vertex and click.
  4. Drag and click to add the desired number of vertices to the polygon.
  5. Double-click to complete the polygon.
  6. Right-click the mark after it is created to activate the popup Edit menu.


Filled Rectangle
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Filled Rectangle

The Filled Rectangle mark enables end users to cover areas of an image or document with a rectangle.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Filled Rectangle button and then drag the resulting rectangle over the items to be covered.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Highlighter
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Highlighter

The Highlighter mark enables end users to highlight areas of their annotated image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Highlighter button and then drag the resulting rectangle over the items to cover.
  2. The resulting rectangle highlights whatever is underneath it.
  3. Right-click the mark after it is created to activate the popup Edit menu.


Hollow Ellipse
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Hollow Ellipse

The Hollow Ellipse mark enables the end user to create a hollow ellipse to surround important areas.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Hollow Ellipse button, dragging the image, and then releasing the mouse button.
  2. Right-click the mark after it is created to activate the popup Edit menu.

Description | A hollow ellipse whose boundaries are defined by a rectangle. Two points define the rectangle, an upper left point and a bottom right point.
Attr Properties | AttrBounds, AttrForeColor, AttrHighlight, AttrLineSize


Hollow Polygon
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Hollow Polygon

The Hollow Polygon mark enables the end user to surround areas of an image or document with a polygon.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Hollow Polygon button.
  2. Click the point where the polygon starts.
  3. Drag and click to create each vertex you want to add.
  4. Double-click to complete the polygon.
  5. Right-click the mark after it is created to activate the popup Edit menu.


Hollow Rectangle
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Hollow Rectangle

The Hollow Rectangle mark enables users to surround areas of an image or document with a hollow rectangle.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Hollow Rectangle button and then drag the resulting rectangle over the items to be surrounded.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Image Embedded
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Image Embedded

The Image Embedded mark enables the end user to embed a bitmap image in a document or image.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Image Embedded button, drag the image, and then releasing the mouse button. When the mouse button is released, the image becomes embedded.
  2. Once the bitmap is in place on the annotation window, it can be re-sized using the mouse.
  3. Right-click the mark after it is created to activate the popup Edit menu.
Image Embedded marks are intended for use with bitmaps that use no more than the standard 20 Windows colors. Therefore, 1-bit and 4-bit bitmaps are allowed. If you try to display an 8-bit bitmap in the mark, it is displayed using only the standard 20 colors.


Image Reference
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Image Reference

The Image Reference mark enables the end user to include an image by reference in a document or image.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Image Reference button, drag the image, and then release the mouse button. When the left mouse button is released, an image is displayed.
  2. To insert an image, right-click the mark after it is created to activate the popup Edit menu, and choose Properties. Select the image to reference.


Pin Up Text
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Pin Up Text

The Pin Up Text mark enables the user to create a mark that appears to be tacked onto the image with a push pin.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Pin Up Text button and then drag it to the desired location.
  2. Right-click the mark after it is created to activate the popup Edit menu.
This mark can have an optional label. The label indicates which data can be obtained by clicking on the pin in while in Run mode. You can add code to the MouseNotify event to display additional data when the push pin is pressed.


Redaction
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Redaction

The Redaction mark enables end users to hide or black out areas of their annotated image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Redaction button and then drag the resulting rectangle over the items to cover. The rectangle covers whatever is underneath it.
  2. Right-click the mark after it is created to activate the popup Edit menu.


Text from File
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Text from File

The Text From File mark enables the end user to add descriptive text to an annotated image or document. The text can be created in various fonts, sizes, colors, and even angles of presentation. The text appears to lay over the original image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Text From File button and then dragging the rectangle over the area to be annotated. This rectangle helps to position the Text annotations. Text annotations are modified when the application is in Edit mode. To modify the text, double-click the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.
  2. While creating this mark and entering text, right-click the mark after it is created to activate the popup Edit menu, which enables you to change several attributes of the mark.
    • Choose Font option allows users to select the color of the text fonts.
    • Adjust Angle option enables end users to rotate the text mark with a dialog box. The square at the lower left corner of the Adjust Angle dialog box shows the appearance of the text mark with the selected text display angle.
    • Set Background Color option is identical to the one available while creating the Attach-a-Note mark.
    • Set Background Mode option enables end users to change the visibility level of the region within the Text mark. When this option is selected, a dialog box appears.
      • If Transparent is selected, the interior of the text mark is not visible; only the text is visible.
      • If Opaque is selected, end users are not able to see through the interior of the text mark.
      • If Tinted is selected, the text mark resembles a tinted glass. End users are able to see through the mark.
If end users create a text mark without any text with a Transparent background, the resulting mark will exist but will not be visible.


Text Stamp
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Text Stamp

The Text Stamp mark allows the end user to annotate documents and images with text.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Text Stamp button and then drag it to the desired location.
  2. Right-click the mark after it is created to activate the popup Edit menu, which allows you to enter the text of the stamp.


Typed Text
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART 2.0 and ART 3.0 Marks > ART 2.0 Legacy Marks > Typed Text

The Typed Text mark enables the end user to add descriptive text to their annotated image or document. The text can be created in various fonts, sizes, colors. The text appears over the original image or document.

Edit Mode

In Edit mode, end users create this mark as follows:

  1. Click the Typed Text button and then drag the resulting rectangle over the area to be annotated. This rectangle helps to position the Text annotations.
  2. To modify the annotation, double-click the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.

If end users create a text mark without any text with a Transparent background, the resulting mark will exist but will not be visible.


PDF Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > PDF Marks

ImageGear ART can convert ART marks to PDF annotations and PDF annotations to ART marks giving the user an ability to edit PDF annotations using the same ImageGear ART Forms GUI.

The following table lists all the ART marks that can be converted to PDF annotations and describes how the marks are being converted:

ART Marks | PDF Annotations
Text | FreeText
Legacy Typed Text | FreeText
Legacy Text Stamp | FreeText
Legacy Text From File | FreeText
Legacy Attach-A-Note | FreeText
Rich Text (RTF) | FreeText
Rectangle | Square
Legacy Filled Rectangle | Square
Legacy Hollow Rectangle | Square
Legacy Redaction | Square
Legacy Highlighter | Square
Ellipse | Circle
Legacy Filled Ellipse | Circle
Legacy Hollow Ellipse | Circle
Image (vector) | 3D
Line | Line
Legacy Arrow | Line
Polyline and Freehand Polyline | PolyLine
Polygon | Polygon
Legacy Filled Polygon | Polygon
Legacy Hollow Polygon | Polygon

The following PDF annotations can be converted to ART marks:

PDF Annotations | ART Marks
3D | Image (vector)
Free Text (simple style text) | Text
Free Text (RTF style text) | Rich Text
Line | Line
Square | Rectangle
Circle | Ellipse
PolyLine | Polyline
Polygon | Polygon

See Also
ART 2.0 and ART 3.0 Marks


WANG Annotation Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > WANG Annotation Marks

The following WANG compatible annotations are supported by ImageGear ART:

  • Image embedded
  • Image reference
  • Straight line
  • Freehand line
  • Hollow rectangle
  • Filled rectangle
  • Typed text
  • Text from file
  • Text stamp
  • Attach-a-Note
See Also
ART 2.0 and ART 3.0 Marks


WPF Annotations
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > WPF Annotations

While ImageGear for .NET supports the entire list of ART 2.0 and 3.0 annotations for editing and displaying in Win Forms applications using ImageGear.ART.Forms Namespace and System.Drawing API from ImageGear.Display namespaces, only the following subset of ART 3.0 annotations is supported by the WPF annotation renderer and viewer, allowing display, editing, and UI interaction:

  • Ellipse
  • Freehand line (Polyline mark with its own creation tool)
  • Image
  • Line
  • Polygon
  • Polyline
  • Polyline Ruler
  • Protractor
  • Rectangle
  • Ruler
  • Text

WPF annotations can be created, imported, or exported to/from XML, viewed, changed, moved, or resized in ImageGear for .NET.

Additionally, the annotations can be rasterized (using Burn In) and operated via the clipboard API.

WPF annotations can also be viewed with both ImageGear scaling modes: Native and WPF. See more info about scaling modes in Image Display.

See Also
ART 2.0 and ART 3.0 Marks


Custom Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Marks

ImageGear custom mark support allows you to implement a mark with a custom look-and-feel. It is supported in the ART serialization subsystem, ART drawing and ART annotator. To implement a custom mark, you will need to implement the mark and controllers outlined in the following table and register them using ImageGear ART API.

The following table lists the classes required for the custom mark implementation. The Sector mark demonstrated in the ImageGear ART samples used as an example:

Class | Example Name | Derived From | Registration | Purpose
Custom Mark Class | SectorMark | ImGearARTCustomMark | ImGearARTCustomController.RegisterCustomMark | Implements custom mark properties.
Custom Mark Controller | SectorMarkController | ImGearARTCustomDrawingController (WinForms version) ImGearARTCustomPresentationController(WPF version) | ImGearARTCustomDrawingController.RegisterCustomController (WinForms version) ImGearARTCustomPresentationController.RegisterCustomController (WPF version) | Implements mark’s drawing and hit testing.
Custom Mark Annotator Controller | SectorEditController | ImGearARTFormsMarkController, ImGearARTFormsPolyController or ImGearARTFormsRectangleController(WinForms version) ImGearAnnotatorMarkController and ImGearAnnotatorRectangleController (WPF version) | ImGearARTFormsMarkController.RegisterCustomController(WinForms version) ImGearAnnotatorMarkController.RegisterCustomController (WPF version) | Responsible for user interaction: mark creation, move/resize actions, property window creation and integration with toolbar.
Custom Mark Statistics Calculator (Optional) | SectorMarkStatistics | ImGearARTMarkStatistics | No registration is required. The user should create the statistics object in the Custom mark class implementation. | Responsible for calculation of statistics properties, such as Area, Length, Perimeter (if applicable), or statistics values specific for a given custom mark.

The following topics are covered in this section:

  • Custom Mark Class
  • User Data Attributes
  • Custom Mark Statistics
  • Custom Mark Registration


Custom Mark Class
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Marks > Custom Mark Class

This abstract class defines a base interface for any user defined custom annotation mark. The user implements a custom mark class by deriving from this base class. Custom mark class resides in the user application, as well as custom mark controller and custom mark annotator controller.

The ImGearARTCustomMark class has a similar public API to what the existing marks have. The only custom mark’s specific property is UserType read-only property of type string. It is used to distinguish marks of different custom types. This property is used by ART to determine which registered type should be used when ART page is loaded. This property should be overridden in users custom mark class. Its value must be unique for each custom mark class implemented in user application.


User Data Attributes
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Marks > User Data Attributes

Properties specific to a custom mark are stored in the UserDataAttributes property. UserDataAttributes is a dictionary that contains a set of key/value pairs, both of type string. When a custom mark is loaded, ART loads the UserDataAttributes dictionary first, and then passes it to the user’s code. The user’s code reads and converts custom properties from the UserDataAttributes dictionary in a specific custom mark constructor, which takes UserDataAttributes dictionary as a parameter.

This constructor must be implemented in the user’s custom mark class. The user also has to provide a code (overridden SavePropertiesToUserData method) to save the mark state into the UserDataAttributes when the ART component is about to save/serialize the mark. Constructor’s code and SavePropertiesToUserData must be consistent.


Custom Mark Statistics
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Marks > Custom Mark Statistics

The ImageGear ART component provides mark statistics support, implemented for all standard ART marks as an object of type ImGearARTMarkStatistics attached to each Mark object. This object provides a set of read-only properties that get some measured values of the mark, like Area, Perimeter and Length.

Since the structure of any custom mark is unknown to ART, it is impossible to calculate custom mark’s area or size in ART, and you will have to implement a statistics class. To do this, you must:

  1. Create a new class derived from ImGearARTMarkStatistics and override its properties.
  2. Override custom mark’s Statistics properties to create an object of the class mentioned above, instead of the standard ImGearARTMarkStatistics object.

The ImageGear ART samples demonstrate this in the SectorMarkStatistics class and SectorMark.Statistics property.

ImGearARTMarkStatistics has two protected properties, AspectX and AspectY. These properties are used to convert sizes/areas calculated in pixels, into other measurement units, such as inches, meters etc. These values are calculated internally by current image resolution and currently selected measurement unit (see ImGearARTMarkStatistics properties description). Use these properties in the same manner as in the sample SectorMarkStatistics class, i.e., the real area can be obtained as an area in pixels multiplied by AspectX and AspectY, but for linear measures you’ll need to multiply any x-projection and y-projection separately, before calculating the whole distance.


Custom Mark Registration
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Marks > Custom Mark Registration

The custom mark class is registered in ART using the static method ImGearARTCustomController.RegisterCustomMark, with user type name and custom class type information passed as parameters.


Custom Mark Controller
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Mark Controller

Abstract classes ImGearARTCustomDrawingController (WinForms version) / ImGearARTCustomPresentationController (WPF version) define a base interface for any user defined custom mark controller. The user implements a custom mark controller by deriving from one of these base classes. Custom mark controller class resides in the user application.

Custom mark controller draws a custom mark (Draw method) and determines if a given mark is over the mark (HitTest method).

There are two base custom mark controllers defined in ImageGear: the ImGearARTCustomDrawingController and ImGearARTCustomPresentationController, for WinForms-based and WPF-based projects, respectively. They have a similar purpose and API, but slightly differ in parameters, which are specific to rendering engine.

ImageGear ART component provides the ImGearARTDrawingState (WinForms version) / ImGearARTPresentationState (WPF version) helper classes that are used to pass some information significant for mark drawing and hit testing into the user’s code. The user can neither create objects of these classes nor implement classes derived. The only places where valid objects of these classes exist are custom controller’s Draw and custom controller’s HitTest methods.

These objects, generated and passed by ART drawing subsystem, contain:

  • Canvas/Graphics in which the mark must be rendered or hit tested.
  • IsSelected Boolean property – defines if the mark is selected currently (if yes, user may want to draw some selection marks, border or highlight).
  • Some methods to convert points from mark’s coordinate to device and backwards.

The following topic is discussed in this section:

  • Custom Mark Controller Registration


Custom Mark Controller Registration
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > Custom Mark Controller > Custom Mark Controller Registration

The custom mark controller must be registered in ART with static methods:

ImGearARTCustomPresentationController.RegisterCustomController (for WPF version) or ImGearARTCustomDrawingController.RegisterCustomController (for Winforms version).


NotateXpress XML (NXXML Marks)
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > NotateXpress XML (NXXML Marks)

NotateXpress™ XML is an open format for saving and restoring annotations. This format supports single and multiple Page annotations.

ImageGear ART can convert NotateXpress XML annotations to ART Marks using the ImGearART.LoadPage Method. The conversion is performed automatically when you load NotateXpress XML annotations.

The following table lists all the NotateXpress XML annotations that can be converted to ART Marks and describes how the mark’s attributes are being converted.

NotateXpress™ XML Mark | ART Mark
Text 1. TextString 2. PenColor 3. TextColor 4. BackStyle 5. BackColor 6. PenWidth 7. HighlightBack 8. TextOrientation 9. TextJustification 10. AutoSize 11. UserString 12. UserLong 13. Visible | ImGearARTText 1. Text 2. Border.Color 3. TextColor 4. Opacity + TextOpacity 5. FillColor 6. Border.Width 7. Opacity + TextOpacity 8. Orientation 9. AlignmentH 10. AutoSize 11. UserDataAttributes (entry with “UserString” key) 12. UserDataAttributes(entry with “UserLong” key) 13. Visible
Stamp 1. TextString 2. PenColor 3. TextColor 4. BackStyle 5. BackColor 6. PenWidth 7. HighlightBack 8. TextOrientation 9. TextJustification 10. AutoSize 11. UserString 12. UserLong 13. Visible | ImGearARTText 1. Text 2. Border.Color 3. TextColor 4. Opacity + TextOpacity 5. FillColor 6. Border.Width 7. Opacity + TextOpacity 8. Orientation 9. AlignmentH 10. AutoSize 11. UserDataAttributes (entry with “UserString” key) 12. UserDataAttributes(entry with “UserLong” key) 13. Visible
Rectangle 1. PenColor 2. FillColor 3. PenWidth 4. HighlightFill 5. BackStyle 6. UserString 7. UserLong 8. Visible | ImGearARTRectangle 1. Border.Color 2. FillColor 3. Border.Width 4. Opacity + TextOpacity 5. Opacity + TextOpacity 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible
Ellipse 1. PenColor 2. FillColor 3. PenWidth 4. HighlightFill 5. BackStyle 6. UserString 7. UserLong 8. Visible | ImGearARTEllipse 1. Border.Color 2. FillColor 3. Border.Width 4. Opacity + TextOpacity 5. Opacity + TextOpacity 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible
Polygon 1. PenColor 2. FillColor 3. PenWidth 4. HighlightFill 5. BackStyle 6. UserString 7. UserLong 8. Visible | ImGearARTPolygon 1. Border.Color 2. FillColor 3. Border.Width 4. Opacity + TextOpacity 5. Opacity + TextOpacity 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible
Polyline 1. Points 2. PenColor 3. PenWidth 4. PenStyle 5. PenFillStyle (Opaque and Translucent options only) 6. UserString 7. UserLong 8. Visible | ImGearARTPolyline 1. Points 2. Color 3. Width 4. Style 5. Opacity 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible
Line 1. Points 2. PenColor 3. PenWidth 4. PenStyle 5. PenFillStyle (Opaque and Translucent options only) 6. UserString 7. UserLong 8. Visible 9. BeginPointStyle / EndPointStyle | ImGearARTLine 1. StartPoint/EndPoint 2. Color 3. Width 4. Style 5. Opacity 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible 9. BeginHeadAngle / EndHeadAngle / BeginHeadLength / EndHeadLength /BeginHeadType / EndHeadType
Freehand 1. Points 2. PenColor 3. PenWidth 4. PenStyle 5. PenFillStyle (Opaque and Translucent options only) 6. UserString 7. UserLong 8. Visible | ImGearARTPolyline 1. Points 2. Color 3. Width 4. Style 1. Opacity 2. UserDataAttributes (entry with “UserString” key) 3. UserDataAttributes(entry with “UserLong” key) 4. Visible
Image 1. ImageData 2. PenColor 3. PenWidth 4. TransparentColor 5. UserString 6. UserLong 7. Visible | ImGearARTImage 1. Page 2. Border.Color 3. Border.Width 4. Page.Transparency 5. UserDataAttributes (entry with “UserString” key) 6. UserDataAttributes(entry with “UserLong” key) 7. Visible
Ruler 1. Points 2. PenColor 3. PenWidth 4. PenStyle 5. MeasureChoice 6. ShowLength 7. GaugeLength 8. Precision 9. Font 10. UserString 11. UserLong 12. Visible | ImGearARTRuler 1. StartPoint / EndPoint 2. Color 3. Width 4. Style 5. Label 6. IsLabelVisible 7. GaugeLength 8. Precision 9. FontName / FontSize / FontStyleART 10. UserDataAttributes (entry with “UserString” key) 11. UserDataAttributes(entry with “UserLong” key) 12. Visible
BlockHightlight 1. FillColor 2. UserString 3. UserLong 4. Visible | ImGearARTRectangle 1. FillColor 2. UserDataAttributes (entry with “UserString” key) 3. UserDataAttributes(entry with “UserLong” key) 4. Visible
Note 1. TextString 2. Font 3. TextColor 4. BackColor 5. TextJustification 6. UserString 7. UserLong 8. Visible | ImGearARTPopupText 1. Text 2. FontName / FontSize / FontStyleART 3. TextColor 4. FillColor 5. AlignmentH 6. UserDataAttributes (entry with “UserString” key) 7. UserDataAttributes(entry with “UserLong” key) 8. Visible
Protractor 1. Points 2. Font 3. PenColor 4. PenWidth 5. PenStyle 6. PenFillStyle (Opaque and Translucent options only) 7. ShowAngle 8. GaugeLength 9. Precision 10. UserString 11. UserLong 12. Visible | ImGearARTProtractor 1. StartPoint / HeadPoint / EndPoint 2. FontName / FontSize / FontStyleART 3. Color 4. Width 5. Style 6. Opacity 7. IsLabelVisible 8. ArcRadius 9. Precision 10. UserDataAttributes (entry with “UserString” key) 11. UserDataAttributes(entry with “UserLong” key) 12. Visible


ART Security
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART Namespace > ART Security

ImageGear.ART can be used in a variety of architectural solutions and sometimes it is necessary to provide access to the same ART page for different users with different access levels. ImageGear does not provide a complete solution for access control; instead, it provides a basic set of tools required to implement access control.

By default, access control functionality is disabled. In order to enable it, you have to implement your own class inherited from ImGearARTAccessController and initialize the ImGearARTPage.AccessController property.

Access control can be applied to the following ART classes: ImGearARTPage, ImGearARTGroup, and annotation classes derived from the ImGearARTMark class. All these classes have a public property AccessController, but only the ART page allows you to set a value of the AccessController. For ART Groups and Annotations, this property is initialized internally when a corresponding object is added to the page and cannot be changed directly.

The ImGearARTAccessController class defines a few abstract overloaded methods (bool OnIsAccessAllowed), that you have to implement in your own class. These methods will be called each time the page / group / annotations are accessed. If access is not available, the OnIsAccessAllowed method has to return false. If the method returns true, it means that access is allowed and the corresponding operation will be performed in a regular way, but if the method returns false, an ImGearARTAccessDenied exception will be thrown.

If the exception throwing is undesirable, then before accessing the methods/properties of the ART object, you can explicitly call the IsAccessAllowed method of the access controller and ensure that the current user has the necessary rights:

C# Example
Copy Code
if (artPage.AccessController.IsAccessAllowed(ImGearARTAccessRights.View))
{
    string author = artPage.Author;
    //…
}

VB.NET Example
Copy Code
If artPage.AccessController.IsAccessAllowed(ImGearARTAccessRights.View) Then

    Dim author As String = artPage.Author
    '…
End If

Access Rights

ImageGear defines the following access rights:

Right | Description
View | Controls if an object can be viewed
Create | Controls if an object can be created
Delete | Controls if an object can be deleted
Edit | Controls if an object properties can be changed
Resize | Controls if a mark object can be resized
Move | Controls if a mark object can be moved
Export | Controls if a mark object can be exported

Access Token

An access token is an object that describes the current security context of the ART Page. The information that token contains varies on implementation, as a rule it includes identity and privileges of the current user.

ImageGear does not provide implementation of an access token, instead there is a defined, empty abstract class ImGearARTAccessToken. The implementation of an access token should inherit the ImGearARTAccessToken class in order to be able to use it with the ImGearARTAccessController.

The ImGearARTAccessController class contains the abstract property AccessToken which should be used to switch the current user of the ART Page:

C# Example
Copy Code
ImGearARTAccessToken accessToken = _userDataBase.GetAccessToken("User name #1");
if (accessToken != null)
{
    _artPage.AccessController.AccessToken = accessToken;
    // ...
}
VB.NET Example
Copy Code
Dim accessToken As ImGearARTAccessToken = _userDataBase.GetAccessToken("User name #1")
If accessToken IsNot Nothing Then
    _artPage.AccessController.AccessToken = accessToken
    ' ...
End If
There are no specific requirements for the access token implementation. This abstraction was introduced to simplify switching between users and is not used internally by ImageGear.

Secure Object Data

We use the term “secure object” to refer to any object in ImageGear ART in which the access must be limited: ImGearARTPage class, ImGearARTGroup class, and any annotation class derived from ImGearARTMark.

Sometimes it may be necessary to associate some data with a secure object which can be used by the AccessController. For this purpose, ImGearARTPage / ImGearARTGroup / ImGearARTMark classes have the SecureObjectData property of ImGearARTSecureObjectData type.

Examples

Access Controller Implementation Example:

C# Example
Copy Code
class UserAccessToken : ImGearARTAccessToken
{
    private ImGearARTAccessRights _accessRights;
    public UserAccessToken(ImGearARTAccessRights accessRights)
    {
        _accessRights = accessRights;
    }
    public ImGearARTAccessRights UserRights
    {
        get
        {
            return _accessRights;
        }
    }
}
class SimpleAccessController : ImGearARTAccessController
{
    public override ImGearARTAccessToken AccessToken
    {
        get;
        set;
    }
    protected override bool OnIsAccessAllowed(ImGearARTAccessRights accessRights)
    {
        UserAccessToken userAccessToken = this.AccessToken as UserAccessToken;
        if (userAccessToken != null)
        {
            // compare current User Access Rights and required rights
            return (userAccessToken.UserRights & accessRights) == accessRights;
        }
        return false;
    }
    protected override bool OnIsAccessAllowed(
        ImGearARTAccessRights accessRights, ImGearARTGroup group)
    {
        // allow access for any user to default Group, and disable access to other groups
        if (group.Name == "[Untitled]")
            return true;
        return false;
    }
    protected override bool OnIsAccessAllowed(
        ImGearARTAccessRights accessRights, ImGearARTMark mark)
    {
        UserAccessToken userAccessToken = this.AccessToken as UserAccessToken;
        if (userAccessToken != null)
        {
            // compare current User Access Rights and required rights
            return (userAccessToken.UserRights & accessRights) == accessRights;
        }
        return false;
    }
}
VB.NET Example
Copy Code
Class UserAccessToken
    Inherits ImGearARTAccessToken
    Private _accessRights As ImGearARTAccessRights
    Public Sub New(accessRights As ImGearARTAccessRights)
        _accessRights = accessRights
    End Sub
    Public ReadOnly Property UserRights() As ImGearARTAccessRights
        Get
            Return _accessRights
        End Get
    End Property
End Class
Class SimpleAccessController
    Inherits ImGearARTAccessController
    Public Overrides Property AccessToken() As ImGearARTAccessToken
        Get
            Return _accessToken
        End Get
        Set(value As ImGearARTAccessToken)
            _accessToken = value
        End Set
    End Property
    Private _accessToken As ImGearARTAccessToken
    Protected Overrides Function OnIsAccessAllowed(accessRights As ImGearARTAccessRights) As Boolean
        Dim userAccessToken As UserAccessToken = TryCast(Me.AccessToken, UserAccessToken)
        If userAccessToken IsNot Nothing Then
            ' compare current User Access Rights and required rights
            Return (userAccessToken.UserRights And accessRights) = accessRights
        End If
        Return False
    End Function
    Protected Overrides Function OnIsAccessAllowed(accessRights As ImGearARTAccessRights, group As ImGearARTGroup) As Boolean
        ' allow access for any user to default Group, and disable access to other groups
        If group.Name = "[Untitled]" Then
            Return True
        End If
        Return False
    End Function
    Protected Overrides Function OnIsAccessAllowed(accessRights As ImGearARTAccessRights, mark As ImGearARTMark) As Boolean
        Dim userAccessToken As UserAccessToken = TryCast(Me.AccessToken, UserAccessToken)
        If userAccessToken IsNot Nothing Then
            ' compare current User Access Rights and required rights
            Return (userAccessToken.UserRights And accessRights) = accessRights
        End If
        Return False
    End Function
End Class

Access Controller usage Example:

C# Example
Copy Code
void Example()
{
    // View (read-only) access rights
    UserAccessToken user1 = new UserAccessToken(ImGearARTAccessRights.View);

    // View & Edit & Create (Edit right does not include Move & Resize) rights
    UserAccessToken user2 = new UserAccessToken(
        ImGearARTAccessRights.View &
        ImGearARTAccessRights.Edit &
        ImGearARTAccessRights.Create);
    // create art page and access controller
    ImGearARTPage artPage = new ImGearARTPage();
    artPage.AccessController = new SimpleAccessController();
    // switch access controller to user1
    artPage.AccessController.AccessToken = user1;

    try
    {
        // try to add mark
        ImGearARTLine line = new ImGearARTLine(
            new ImGearPoint(),
            new ImGearPoint(),
            new ImGearRGBQuad());
        // Access Denied exception is thrown, because 'user1'
        // does not have 'Create' right
        artPage.AddMark(line, ImGearARTCoordinatesType.DEVICE_COORD);
    }
    catch (ImGearARTAccessDeniedException)
    {
    }
    // switch access controller to user2
    artPage.AccessController.AccessToken = user2;
    ImGearARTLine line2 = new ImGearARTLine(
        new ImGearPoint(), new ImGearPoint(), new ImGearRGBQuad());
    // OK, 'user2' has Create right
    artPage.AddMark(line2, ImGearARTCoordinatesType.DEVICE_COORD);
}
VB.NET Example
Copy Code
Private Sub Example()
    ' View (read-only) access rights
    Dim user1 As New UserAccessToken(ImGearARTAccessRights.View)
    ' View & Edit & Create (Edit right does not include Move & Resize) rights
    Dim user2 As New UserAccessToken(ImGearARTAccessRights.View And ImGearARTAccessRights.Edit And ImGearARTAccessRights.Create)
    ' create art page and access controller
    Dim artPage As New ImGearARTPage()
    artPage.AccessController = New SimpleAccessController()
    ' switch access controller to user1
    artPage.AccessController.AccessToken = user1

    Try
        ' try to add mark
        Dim line As New ImGearARTLine(New ImGearPoint(), New ImGearPoint(), New ImGearRGBQuad())
        ' Access Denied exception is thrown, because 'user1'
        ' does not have 'Create' right
        artPage.AddMark(line, ImGearARTCoordinatesType.DEVICE_COORD)
    Catch generatedExceptionName As ImGearARTAccessDeniedException
    End Try
    ' switch access controller to user2
    artPage.AccessController.AccessToken = user2
    Dim line2 As New ImGearARTLine(New ImGearPoint(), New ImGearPoint(), New ImGearRGBQuad())
    ' OK, 'user2' has Create right
    artPage.AddMark(line2, ImGearARTCoordinatesType.DEVICE_COORD)
End Sub


Using ImageGear.ART.Forms Namespace
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace

ImageGear ART Forms provides 3 classes to support the end user’s interaction and UI for custom marks. You must take one of them as a base class and implement a custom annotator controller in your application, just like you did for the custom class and custom controller. The custom annotator controller is responsible for:

  • Interactive mark creation (with pre-drawing)
  • Mark resizing
  • Representing the custom mark on Annotator’s toolbar
  • Creating mark’s property window when requested by Annotator

Base classes are as follows:

  • ImGearARTFormsMarkController - This class defines an API which must be implemented by the user. This class does not implement any functionality and is recommended only if the custom mark is not similar to a rectangle or a set of points when created/resized.
  • ImGearARTFormsRectangleController - This class implements default resize/creation behavior for rectangular marks. The user will have to override the mark creation code to support the rectangular mark.
  • ImGearARTFormsPolyController - This class implements default resize/creation behavior for marks similar to polyline/polygon. The user will have to override the mark creation code and some members related to resizing to support the mark (please refer to the SectorEditController class in ART sample).

The following topics are covered in this section:

  • Custom Mark Creation
  • Resizing Custom Marks
  • Custom Mark Property Window
  • Toolbar
  • Mouse Events


Custom Mark Creation
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace > Custom Mark Creation

Custom mark creation is processed by two overridden methods: CanCreateMark and CreateMark.

Annotator calls CanCreateMark each time the user releases a mouse button. Annotator passes a set of already entered points as parameters, along with some data that can be used in CanCreateMark method (see ImGearARTFormsCreateMarkData class description). It’s the controller’s responsibility to analyze if already entered points are enough for creating a mark (and/or by some conditions in the creation data). For example, all rectangular annotations can be created by 2 points, so default implementation in ImGearARTFormsRectangleController returns true without any checks (when MouseUp occurs, point list contains exactly two points). As another example, in PolyController default implementation checks if the last mouse click event was a double-click. This behavior is overridden in SectorMark, which needs 3 points for creation, and it is checked in SectorEditController.CanCreateMark.

CreateMark is a public controller’s method. It is called by Annotator if last call of CanCreateMark was successful. This method should be overridden in all custom controllers. It creates a new instance of the custom mark by given set of points.


Resizing Custom Marks
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace > Resizing Custom Marks

To process resizing of marks that are rectangular, the user must override UpdateBounds method. It takes a rectangle containing new bounds for mark, and updates custok mark’s properties with it. It is necessary, because there is no common properties for custom mark, that determines custom mark’s bounds. All other functionality, including cursors handling, is implemented in the ImGearARTFormsRectangleController class.

To process resizing of marks that are not rectangular, the user must override at least Resize method, which takes a point, a point identifier, and updates one of the mark’s points with a given point. It will work for marks that are similar to the Polyline mark, i.e., marks based on a list of points. For more complex marks (for example, if custom mark is similar to Art Callout mark), the user may also want to override ManageCursor method. Here the user is able to:

  • Define custom way to identify points (in this case Resize override must use same way)
  • Test single points using UpdateCursor protected method
  • Customize the cursor management

ManageCursor is called by Annotator every time when mouse hovers the mark which is selected. Default ManageCursor implementation method analyzes if the mouse is over one of mark’s resizing points, and, if yes, sets up the cursor and store a point ID in the data structure passed by annotator. Resize method is called by Annotator if mouse moved while mouse button is pressed, and appropriate resizing cursor and point identifier was set up during previous call of ManageCursor. Overridden Resize must update the internal point with new passed coordinates, using point identifier passed by Annotator (see ImGearARTFormsMarkControllerData in API Reference).


Custom Mark Property Window
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace > Custom Mark Property Window

To implement a custom property window for the custom mark, the user must override the GetPropertiesWindow method in the custom mark edit controller. Annotator calls this method when the “Properties” menu item is selected in the Annotator UI, and passes a mark for which property window is requested, and a current ImGearPageView object. In overridden method the user must create a Form-derived window which will display and modify mark’s properties. Please refer to SectorPropertyWindow class in ART sample.

It is not necessary to implement your property window for custom mark, if you are not going to use it. If edit controller returns null instead of form, the annotator doen not display anything.


Toolbar
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace > Toolbar

When Annotator creates a toolbar, it iterates a list of registered custom mark edit controllers and gets a ToolbarInfo property for each. ToolbarInfo is a read-only edit controller’s property of public type ImGearARTFormsToolbarButtonInfo.

This class has fields that are necessary for creating a toolbar button which will be associated to custom mark/edit controller. In user’s overridden ToolbarInfo property the user must create a new ImGearARTFormsToolbarButtonInfo object and fill its fields with the button’s icon, tooltip string and user type identifier (string, same as was used when the controller is registered).


Mouse Events
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Forms Namespace > Mouse Events

The following events are available for the user to allow the actions that are available for standard marks, like: post-creation and double-click in-place editing or run-mode actions:

  • MouseLeftButtonDown
  • MouseLeftButtonUp
  • MouseRightButtonDown
  • MouseRightButtonUp
  • MouseMoved
  • MarkCreating
  • MarkCreated

For example, you can handle MouseLeftButtonDown in your application. The ImageGear ART Forms will pass a reference to the clicked mark along with system mouse event arguments, and, if the clicked mark is of a needed type (not necessary custom) and Annotator is in needed mode (say, RUN), you can start some action.


Using ImageGear.ART.Windows.Controls Namespace
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Windows.Controls Namespace

The ImageGear.ART.Windows.Controls Namespace provides WPF annotation UI controls that can simplify development of WPF .NET applications interacting with ART annotations. This functionality is implemented in a separate assembly, using the public ImageGear API, with source code provided to enable modifications. This section provides information about the following:

  • Using ImageGear.ART.Windows.Controls Namespace
    • Annotator
    • Toolbar Annotator
    • Annotator Settings


Annotator
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Windows.Controls Namespace > Annotator

The main piece of the WPF annotations UI is implemented in the Annotator Class. Use this class in your application to enable interactions with the annotations loaded by ImageGear. This will allow you to create annotation marks with or without a toolbar; edit, move, resize, or delete annotations; and view and edit their properties. The Annotator is associated with the PageView Class control during the initialization. A reference to the associated PageView Class control is available via the Annotator. PageView Property. The following code demonstrates initialization of the Annotator:

C#
Copy Code
 Annotator m_Annotator;
 m_Annotator = new Annotator(m_igPageView);

The Annotator is applicable to the same image and the annotation page used by the PageView Class. The image page is accessible via the PageView. Display Property.Page Property. The annotation page is accessible via the PageView. Display Property.ARTPage Property.

In order to display an image in your PageView Class control you would load or create an ImGearPage Class object using the ImageGear API and set it to the PageView. Display Property.Page Property. A similar approach can be used for annotations - load or create an ImGearARTPage Class object using the ImageGear.ART Namespace API and set it to the PageView. Display Property.ARTPage Property. The following code demonstrates PageView. Display Property initialization with the new image and annotation pages:

C#
Copy Code
 ImGearPage m_CurrentPage;
 ImGearARTPage m_CurrentArtPage;
 m_CurrentPage = ImGearFileFormats.LoadPage(f, 0);
 m_CurrentArtPage = ImGearART.LoadPage(page);
 if (m_CurrentArtPage == null)
 {
  m_CurrentArtPage = new ImGearARTPage();
 }
 m_igPageView.Display = new ImGearPresentationPageDisplay(m_ CurrentPage, m_CurrentArtPage);

In order to enable the Annotator support, you just need to initialize the Annotator Class as demonstrated in the code example above.

The Annotator Class provides a set of events that allow you to control the process of creating, editing, and deleting marks using the UI. The following code demonstrates initialization and use of the Annotator Class events:

C#
Copy Code
m_Annotator.PreCreateMark += new Annotator.PreCreateMarkEventHandler(Page_PreCreateMark);
m_Annotator.PreDeleteMark += new Annotator.PreDeleteMarkEventHandler(Page_PreDeleteMark);
m_Annotator.ModifyMark += new Annotator.ModifyMarkEventHandler(Page_ModifyMark);
 public void Page_PreCreateMark(object sender, PreCreateMarkEventArgs e)
 {
  // Check the mark.
 }
 public void Page_PreDeleteMark(object sender, PreDeleteMarkEventArgs e)
 {
  // Check the mark.
 }
 public void Page_ModifyMark(object sender, ModifyMarkEventArgs e)
 {
  // Check the modified mark.
 }


Toolbar Annotator
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Windows.Controls Namespace > Toolbar Annotator

While it is not required for the Annotator to use a toolbar (you can force the Annotator to change its Tool property using menu items, radio buttons, etc.), most applications will probably use a toolbar.

The ToolBarAnnotator Class is a version of the Annotator that implements a toolbar based UI control. The purpose of this class is to demonstrate the use of a toolbar, implemented in the ToolBar Class, with the Annotator in WPF .NET applications. This class, as the rest of this namespace, is distributed with the source code and could be adjusted and modified as required. The following code demonstrates initialization of the ToolBarAnnotator Class:

C#
Copy Code
  Annotator m_Annotator;
  m_Annotator = new ToolBarAnnotator(m_igPageView, m_AnnotationMenu.ToolBar);

ToolBarAnnotator Class inherits all the properties of the Annotator Class.


Annotator Settings
User Guide > How to Work with... > ART Annotations > Using ImageGear.ART.Windows.Controls Namespace > Annotator Settings

The Annotator Class provides a set of the adjustable UI parameters accessed via its Settings Property. This allows you to change the Annotator's global settings as well as its behavior in run-time.


Barcodes
User Guide > How to Work with... > Barcodes

The ImageGear.Barcode namespace API offers a set of objects that provides access to barcode recognition technology.

  • Barcode Detection

    You can easily add barcode detection to your Windows applications. The ImageGear for .NET Barcode component detects all barcodes in an image and gives you complete details about each barcode.

    For a list of barcodes that can be read and the editions that support them, see Supported Barcode Types.

  • Barcode Creation

    The barcode engine can create many of the popular 1D barcode formats. The Barcode engine is also capable of writing both PDF417 and DataMatrix 2-D barcodes. The created barcodes can be constrained to a specified image size or can auto-size output image. 1D barcodes can also include the barcode value under the barcode symbol.

    For a list of barcodes that can be written/created and the editions that support them, see Supported Barcode Types.

This section provides information about the following:

  • Barcodes
    • Barcode Checksums
    • Boundary and Point Properties
    • Supported Barcode Types
      • Add 2 and Add 5 Barcode Specifications
      • Australian Post 4-State Barcode
      • Aztec
      • BCD Matrix
      • Codabar
      • Code 32
      • Code 39
      • Code 39 Extended
      • Code 93
      • Code 93 Extended
      • Code 128 and EAN 128
      • DataLogic 2 of 5
      • DataMatrix
      • EAN-8
      • EAN-13 and JAN
      • IATA 2 of 5
      • Industry 2 of 5
      • Intelligent Mail
      • Interleaved 2 of 5
      • Inverted 2 of 5
      • Matrix 2 of 5
      • Patch Code
      • PDF417
      • PostNet
      • QRcode
      • Royal Post 4-State Barcode
      • UPC-A
      • UPC-E
    • Acquire an Image for Barcode Recognition
    • Recognize a Barcode
    • Access Results
    • Create a 1D Barcode
    • Create a 2D Barcode


Barcode Checksums
User Guide > How to Work with... > Barcodes > Barcode Checksums

Checksums are used to verify the correctness of data. Their use is usually in data transmission, or converting data from one form to another. A parity bit is a form of checksum error correction coding. The idea is that the whole unit of data can be identified by a single number, a checksum. If the checksum is not correct or it does not match, errors have occurred.

The simplest checksum is to add up the value of the individual bytes in the data. Given the data of "CAT", the ASCII values of the letters are 67 + 65 + 84 = 216 and the whole package might be given the notation "CAT(216)". So if we received "CAS(216)" we’d know that an error occurred somewhere along the way.

A simple sum of the characters can be fooled by switching the order but not the value of the data, e.g. "TAC" and "CAT" have the same checksum. So more sophisticated checksum methods have been developed which reduce (but never totally eliminate) the chance of incorrect data giving the correct checksum.

Many types of barcodes employ checksums. In several other types, checksums are optional. Clearly, those that incorporate checksums are more robust and reliable.

The UPC and EAN codes always append the checksum character to the barcode results. This is done regardless of the AppendCheckSum property value.

More advanced barcodes use an error correction system. This allows for reliable reading even if the code has been slightly damaged.

  • Barcodes with No Checksum
  • Barcodes Requiring a Checksum
  • Barcodes with Optional Checksum
  • Barcodes with Error Correction

Barcodes with No Checksum

  • Add2
  • Add5
  • Codabar
  • DataLogic 2 of 5
  • Patch Code

Barcodes Requiring a Checksum

  • Code 128
  • Code 93
  • Code 93 Extended
  • IATA 2 of 5
  • EAN-128
  • EAN-13
  • EAN-8
  • Intelligent Mail
  • PostNet
  • Royal Post 4-State Barcode
  • UPC-A
  • UPC-E

Barcodes with Optional Checksum

  • BCD Matrix
  • Code 32
  • Code 39
  • Code 39 Extended
  • Industry 2 of 5
  • Interleaved 2 of 5
  • Inverted 2 of 5
  • Matrix 2 of 5

Barcodes with Error Correction

  • Australian Post 4 State Barcode
  • Aztec
  • DataMatrix
  • PDF417
  • QRcode


Boundary and Point Properties
User Guide > How to Work with... > Barcodes > Boundary and Point Properties

When a barcode on an incoming image is detected, five properties of the ImGearBarcode.Result class detect the outer parameters of the barcode. They mark both the boundary dimensions and the corner points of the barcode. Height, Width and Area properties describe the boundaries of the barcode rectangle. Point properties are used to identify corner points of the barcode on the image. Point properties 1 through 4 locate the corner points of linear 1D Barcodes.

  • When the barcode is in the horizontal orientation, it is read from left to right, assigning values to the Point 1 through 4 properties. The Point1 property is the upper-left corner point of the barcode.
  • The boundary and corner point properties describe a rectangle area for the barcode on the image. The Skew property returns the angle of the barcode.

With any rotation of the barcode on the image, the Point value assigned to the corners rotate with the barcode. No matter what the rotation is, the Point properties always identify the same corner point of the barcode. If the barcode is rotated 180 degrees, the Point value for the corner remains. Point1 is now the bottom-right corner; but its value is still 1.


Supported Barcode Types
User Guide > How to Work with... > Barcodes > Supported Barcode Types

Several barcode types are identified by multiple names. But in Barcode, they are referenced by a single enumeration, ImGearBarcodeType. The table below shows which barcode type and enumeration value must be mapped, and the editions that support that barcode.

Format | Name | 1D | 2D
2D Barcodes |  |  |
Aztec | AztecBarcode |  | R
DataMatrix | DataMatrixBarcode |  | R/W
PDF417 | PDF417Barcode |  | R/W
QR Code | QRCodeBarcode |  | R
1D Barcodes |  |  |
Add-2 | Add2Barcode | R | R
Add-5 | Add5Barcode | R | R
Airline 2 of 5 | IATA2of5Barcode | R | R
Australia Post 4-State Code | AustralianPost4StateBarcode | R | R
BCD Matrix | BCDMatrixBarcode | R | R
Codabar | CodabarBarcode | R/W | R/W
Code 128 (A,B,C) | Code128Barcode | R/W | R/W
Code 2 of 5 | Industry2of5Barcode | R | R
Code 32 | Code32Barcode | R | R
Code 39 | Code39Barcode | R/W | R/W
Code 39 Extended | Code39ExtendedBarcode | R/W | R/W
Code 93 | Code93Barcode | R/W | R/W
Code 93 Extended | Code93ExtendedBarcode | R/W | R/W
DataLogic 2 of 5 | DataLogic2of5Barcode | R | R
EAN 128 (GS1, UCC) | EAN128Barcode | R/W | R/W
EAN-13 | EAN13Barcode | R/W | R/W
EAN-8 | EAN8Barcode | R/W | R/W
Industrial 2 of 5 | Industry2of5Barcode | R/W | R/W
Intelligent Mail (OneCode) | IntelligentMailBarcode | R | R
Interleaved 2 of 5 | Interleaved2of5Barcode | R/W | R/W
Invert 2 of 5 | Invert2of5Barcode | R | R
ITF-14 / SCC-14 | Interleaved2of5Barcode | R | R
Matrix 2 of 5 | Matrix2of5Barcode | R | R
Patch Codes | PatchCodeBarcode | R/W | R/W
PostNet | PostNetBarcode | R | R
Royal Mail (RM4SCC) | RoyalPost4StateBarcode | R | R
UCC 128 | EAN128Barcode | R | R
UPC-A | UPCABarcode | R/W | R/W
UPC-E | UPCEBarcode | R/W | R/W

This section provides information about the following:

  • Supported Barcode Types
    • Add 2 and Add 5 Barcode Specifications
    • Australian Post 4-State Barcode
    • Aztec
    • BCD Matrix
    • Codabar
    • Code 32
    • Code 39
    • Code 39 Extended
    • Code 93
    • Code 93 Extended
    • Code 128 and EAN 128
    • DataLogic 2 of 5
    • DataMatrix
    • EAN-8
    • EAN-13 and JAN
    • IATA 2 of 5
    • Industry 2 of 5
    • Intelligent Mail
    • Interleaved 2 of 5
    • Inverted 2 of 5
    • Matrix 2 of 5
    • Patch Code
    • PDF417
    • PostNet
    • QRcode
    • Royal Post 4-State Barcode
    • UPC-A
    • UPC-E


Add 2 and Add 5 Barcode Specifications
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Add 2 and Add 5 Barcode Specifications

Add 2 and Add 5 Barcode Specifications Retail barcodes (UPC and EAN) are strictly limited in the amount and format of the data that they encode. Add 2 or Add 5 barcodes give the vendors another two or five digits to identify the specific product, model, or issue. It is usually printed just to the right of the product code. For periodicals, an Add2 often indicates the issue, while other publications include a volume number.

Below is an Add 2 barcode example:

Below is an Add 5 barcode example:


Australian Post 4-State Barcode
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Australian Post 4-State Barcode

Below is an example of the Australian 4-State Postal Code:

The Australian Post 4 State barcode is a 4-state barcode. It supports four different formats:

  • Standard
  • Customer Barcode 2
  • Customer Barcode 3
  • Reply Paid Barcode

The Customer Barcodes 2 & 3 include a customer field for encoding data. This barcode also supports the Reed-Solomon error correction scheme.

Format Control Field

The Format Control Field is a 2 digit field identifying the barcode type:

  • 11 - Standard Customer Barcode
  • 59 - Customer Barcode 2
  • 62 - Customer Barcode 3
  • 45 - Reply Paid Barcode

Sorting Code

The Sorting Code is an 8 character sorting code (Delivery Point ID).

Customer Information

There is a free format area available in the Customer Barcodes 2 & 3. This will be decoded using the AustralianPostCustomDecodeType.

  • If the decode mode is "BarStates" then the output will be either bar state "F" full bar, "T" tracker bar, "A" ascending bar or "D" descending bar.
  • If the decode mode is "TableN" then the output will be decoded using the numeric decoding defined in the Australian Post specification.
  • If the decode mode is "TableC" then the output will be decoded using the character decoding defined in the Australian Post specification.
  • If the decode mode is "NoCustomDecode", then the bars in the custom section are not decoded.
  • Use the no custom decode if the decode mode has no custom decode type.
If the FCC code is not valid, the confidence will be decreased by 10%.


Aztec
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Aztec

Aztec Barcode is a 2D barcode which can encode 8 bit data, including all ASCII characters (binary values 0 - 127) and the remaining values (binary values 128 - 255). The barcode also includes error detection and correction to compensate for damaged barcodes. Error correction typically takes up 23% of the code space.

The Aztec barcode has three different code sizes:

  • Full - Full code size.
  • Compact - Compact code size.
  • Rune - A special barcode which can only encode values 000 - 255.

 | Full | Compact | Rune
Image |  |  |
Number of Symbols | 40 | 4 | 256
Size | 19x19 - 151x151 modules | 15x15 - 27x27 modules | 11x11 modules
Text Capacity (characters) | 15 - 3067 | 12 - 89 | 0
Numeric Capacity (digits) | 18 - 3832 | 13 - 110 | 3
Binary Capacity (8-bit values) | 8 - 1914 | 6 - 53 | 0


BCD Matrix
User Guide > How to Work with... > Barcodes > Supported Barcode Types > BCD Matrix

BCD Matrix is a compact version of 2 of 5 barcodes, but its checking for the data patterns is not as robust. It does include a checksum character. It is not widely used.

An example:


Codabar
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Codabar

Codabar

Codabar is used in libraries, blood banks, the overnight package delivery industry, and a variety of other information processing applications. Codabar is also known as USD-4, NW-7 and 2 of 7 code.

The Codabar character set includes the digits 0-9, six symbols including: minus "-", plus "+", period ".", dollar sign "$", slash "/", and colon ":", and the following start/stop characters A, B, C and D. The start/stop characters must be used in matching pairs and may not appear elsewhere in the barcode. If you omit the start/stop characters, the barcode will use A and B respectively. Blood banks use the D stop character to indicate that the next barcode beginning with a D should be concatenated with the current barcode.

By default, the read value of the Codabar barcode does not include the start and stop characters. To include the start and stop characters in the barcode result, the IncludeControlCharacters property must be set to true.

Traditional Codabar defines different element width for each of the characters in an effort to make all of the characters have the same width. Rationalized Codabar uses the same patterns, but assigns only 2 element width for wide and narrow.

The barcode engine implements Rationalized Codabar. an error will be generated if you have characters in your barcode value that are not allowed.

Codabar requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Since Codabar is self-checking, there is no standard checksum.

An example:


Code 32
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 32

Code 32

Code 32 is an Italian pharmacy code. It is a variant version of Code 39: it uses the exact same symbol set, stop and start code and rules but restricts the characters that may be encoded to just digits and capital letters excluding the vowels (‘A’, ‘E’, ‘I’, ‘O’, ‘U’). Otherwise it shares all the other advantages of Code 39.

Since Code 32 is a subset of Code 39, the barcode engine assumes the barcode is a Code 39 type when detecting all 1D types. The barcode type should be set specifically to Code 32 to read this barcode type correctly.

If you plan to detect Code 32 barcodes, you should set the BarcodeTypes property to this type so that the barcode engine specifically looks for Code 32. If you don’t tell the barcode engine to specifically look for Code 32 barcodes, it might confuse a Code 32 barcode with a Code 39 barcode.

An example:


Code 39
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 39

Code 39 is widely used in many industries across the world. It is the standard for many government barcode specifications, including the U.S. Department of Defense. Code 39 is also known as Code 3 of 9.

Code 39 was the first alphanumeric symbology. Its character set includes the digits 0-9, the letters A-Z (uppercase only), and the following symbols: space, minus "-", plus "+", period ".", dollar sign "$", slash "/", and percent "%". ImageGear generates an error if you have characters in your barcode value that are not allowed.

Each data character is made up of 5 bars and 4 spaces for a total of 9 elements. Each character includes 3 wide and 6 narrow elements. Thus, 3 out of the 9 elements are always wide, which is the reason why the code is sometimes called "3 of 9".

The ratio of wide to narrow bar width can be in the range of 1.8 to 3.4. The barcode engine Code 39 uses a 2:1 wide to narrow bar width ratio.

Code 39 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Since Code 39 is a self-checking barcode, it normally does not require a checksum. However, when necessary, an optional modulo 43 checksum may be used.

By default, ImageGear does not write optional checksums. If a checksum is desired for Code 39, set the EnableCheckSum property to 1(TRUE) and the barcode engine calculates and writes the checksum.

If you plan to detect Code 39 barcodes, you should set the BarcodeTypes property to this type so that the barcode engine specifically looks for Code 39. If you don’t tell the barcode engine to specifically look for Code 39 barcodes, it might confuse a Code 39 barcode with a Code 32 barcode.

An example:


Code 39 Extended
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 39 Extended

Code 39 Extended was developed to provide a means of encoding additional characters that are not part of the Code 39 character set (for example, lowercase characters and additional symbols), and is essentially a superset of Code 39. Extended characters are encoded by using a pair of normal Code 39 characters. For example, a lowercase "a" is encoded by the character pair "+A". Code 39 Extended supports the full ASCII character set.

The ratio of wide to narrow bar width can be in the range of 1.8 to 3.4.The barcode engine Code 39 uses a 2:1 wide:narrow bar width ratio.

Code 39 Extended requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Since Code 39 is a self-checking barcode, it normally does not require a checksum. However, when necessary, an optional modulo 43 checksum may be used.

By default, ImageGear will not write optional checksums. If a checksum is desired for Code 39, set the EnableCheckSum property to 1(TRUE) and the barcode engine will calculate and write the checksum.

If you use te barcode engine to detect Code 39 barcodes, you should set the reader BarcodeType property to this type so that the barcode engine specifically looks for Code 39. If you don’t tell the barcode engine to specifically look for Code 39 barcodes, it might confuse a Code 39 barcode with a Code 32 barcode.

An example:


Code 93
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 93

Code 93 is a bar code symbology which encodes 43 data characters (0-9, A-Z, 6 symbols, and Space), four shift characters, and a unique start/stop character. Code 93 derives its name from the fact that every character is constructed from 9 modules arranged into 3 bars with their adjacent spaces.

The Code 93 character set includes the digits 0-9, the letters A-Z (uppercase only), and the following symbols: space, minus "-", plus "+", period ".", dollar sign "$", slash "/", and percent "%". Barcode XpressImageGear will generate an error if you have characters in your barcode value that are not allowed.

Code 93 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Code 93 requires two checksum characters, sometimes referred to as the “C” and “K” characters.

An example:


Code 93 Extended
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 93 Extended

Similar to Code 39 Extended, Code 93 Extended is a superset of Code 93. Extended characters are encoded by using a pair of Code 93 characters. For example, a lowercase "a" is encoded by the character pair "+A". The difference in Code 93 Extended, when compared to Code 39 Extended, is that the shift character used to encode an extended character is a reserved character, and not one of the standard 43 characters in the Code 93 character set. Code 93 Extended supports the full ASCII character set.

Code 93 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Code 93 requires two checksum characters, sometimes referred to as the “C” and “K” characters.

An Example:


Code 128 and EAN 128
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Code 128 and EAN 128

Code 128

Code 128 provides excellent density for all-numeric data and good density for alphanumeric data. The symbol can be as long as necessary to store the encoded data. It is often selected over Code 39 in new applications because of its density and because it offers a much larger selection of characters. Code 128 is designed to encode all 128 ASCII characters.

A Code 128 can actually be divided into three subsets A, B and C. There are three separate start codes to indicate which subset is being used. In addition, each subset includes control characters to switch to another subset in the middle of a barcode.

  • A – Digits, uppercase characters, standard ASCII symbols and control codes.
  • B – Digits, upper and lower case characters, standard ASCII symbols and control codes.
  • C – Numeric only. Compresses two numeric digits into each character, providing excellent density. ImageGear will add a leading "0" if there are an odd number of digits in the code.

When the BarcodeType property is set to write a Code 128 barcode, the barcode engine will automatically switch between the three character sets (A, B and C) to code the data in the shortest form.

An Example:

EAN-128

The UCC/EAN 128 barcode is a special form of Code 128. EAN-128 is based on Code 128 but it has a double start character. It is also called UCC128.

The barcode engine will generate an error, if you have characters in your barcode value that are not allowed.

Each character is 11 times the width of the most narrow bar. Each character consists of 3 bars and 3 spaces. The bars always use an even number of elements and the spaces use an odd number. This provides the basis for a character-by-character consistency check during scanning. In addition, each Code 128 barcode includes a Modulo 103 checksum.

Code 128 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.

An Example:


DataLogic 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > DataLogic 2 of 5

DataLogic 2 of 5 is a variation of the 2 of 5 barcodes using both white and black bars. It does not have a checksum character. It is not widely used.

An example:


DataMatrix
User Guide > How to Work with... > Barcodes > Supported Barcode Types > DataMatrix

DataMatrix is a widely used true 2D barcode. It allows for encoding large amounts of information (over 3000 characters) using a variety of character sets (ASCII, C40, TEXT and BASE256) allowing efficient data packing or binary data storage as needed. DataMatrix employs an error correction system allowing it to read codes that are as much as 40% damaged.

ImGearBarcode supports the ECC 200 standard. It does not support the ECC 100-140 standards. The barcode engine does not support the automatic structured append feature. It returns results of each barcode, but the individual results have to be combined.

Performance Enhancement: The barcode engine is designed to optimize speed for the DataMatrix barcode recognition type as it takes advantage of the SSE2 (Streaming SIMD Extensions) technology provided in some computer processors with the initial release of the Pentium 4 architecture. This SSE2 technology allows for more efficient pixel processing, significantly improving image recognition time. Computer processors not supporting SSE2 will not provide this performance enhancement, and will automatically use the same processing algorithm as all prior releases.
Note the image will be converted internally to an 8 bpp image for performance enhancement which will consume more memory but improve recognition performance.

An example:

The Write 2D edition supports creating PDF417 and DataMatrix barcodes which can then be written using ImGearFileFormats.SavePage or by writing to a Printer Device Context. Your application logic will set the barcode writing parameters and make a call to the Create method. The output image will then be returned in the call.

Included features to use with this functionality are:

  • BarcodeValue - Barcode data returned as an array of bytes.
  • RowsAndColumns - This value is used to set the number of rows and columns.
  • RowsAndColumnsCreated - The number of rows and columns created.
  • RequiredHeight - An output height value is required to create the barcode image.
  • RequiredWidth - An output width value is required to create the barcode image.
Caution: When using trial (unpaid) licensing, the words”Accusoft.com Evaluation" will appear in every DataMatrix and PDF417 barcode created, taking up 24 bytes of space including the leading and trailing spaces. When testing the contents of generated barcodes, be aware of the extra space requirements.
Caution: An anomaly has been identified for DataMatrix 144 x 144 barcodes written by several competitors' components. For this size only, barcodes created using those components do not adhere to the DataMatrix barcode specification. Because Accusoft Corporation does adhere to the DataMatrix specification, those competitors' components will not correctly read 144 x 144 size DataMatrix written by the barcode engine.

When reading 144 x 144 DataMatrix barcodes, the barcode engine will assume that the barcodes adhere to the specification. If reading fails, the component will automatically attempt to apply the recognition algorithm that will work on barcodes written by the competitor’s components, and report the results. The barcode reader will not be notified that the barcode did not adhere to the specification. For these barcodes only, recognition speed will be impacted.


EAN-8
User Guide > How to Work with... > Barcodes > Supported Barcode Types > EAN-8

The EAN (European Article Numbering) code is primarily used in supermarkets. EAN-8 is a shortened version of the EAN-13 code. It is a numeric-only code that includes a 2 or 3 digit country code, 4 or 5 data digits (depending on the length of the country code), and a checksum digit that is automatically added. If there are eight digits specified during a write, the eighth digit will be replaced with the correct checksum.

Unlike the UPC-E symbol, which compresses data that could also be printed as a full-size UPC-A symbol by squeezing out zeros, the data digits in an EAN-8 symbol specifically identify a particular product and manufacturer. Since a limited number of EAN-8 codes are available in each country, they are issued only for products with insufficient space for a normal EAN-13 symbol.

The barcode engine will generate an error if you have characters in your barcode value that are not allowed. You can have 7 or 8 digits in the EAN-8 barcode value. You don’t have to include the 8th digit (checksum) since it is automatically added.

EAN-8 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.

The EAN-8 barcode is also commonly written with 2 different bar heights. Typically, the height of the left and right guard bars are greater than the height of the bars encoding the actual barcode value, essentially creating a notch in the barcode where the text value can be written. The barcode engine provides the user with control over the size of this notch with the TextNotchPercent property.

The TextNotchPercent property can be set to a value of 0 to 50. This number represents the percentage of the tall bar height the short bars will be shortened by. For example, if TextNotchPercent is 10, and the bar height is set to 100 pixels, the tall bars (left and right guard bars) will be 100 pixels tall, and the short bars (bars encoding the value) will be 90 pixels tall.

An example:


EAN-13 and JAN
User Guide > How to Work with... > Barcodes > Supported Barcode Types > EAN-13 and JAN

EAN-13 is used worldwide for marking retail goods. The symbol is numeric-only and encodes 13 digits. The first two or three digits are a country code which identify the country in which the manufacturer is registered (not necessarily where the product is actually made). The country code is followed by 9 or 10 data digits (depending on the length of the country code) and a single checksum digit that is automatically added. If there are 13 digits, the last digit will be replaced with the correct checksum. There is a special form of EAN-13, called EAN-99 which just starts with "99".

The JAN barcode is identical to the EAN-13 except with a country code of 49, designating that it was registered in Japan. The JAN barcode is treated exactly the same as the EAN-13 for reading and writing barcodes.

As of January 1, 2005, all retail scanning systems in the United States must be able to accept the EAN-13 symbol as well as the standard UPC-A symbol. The United States has begun the process of moving to the EAN-13 symbol, which will be known as the UPC-13 symbol in the USA.

ImGearBarcode generates an error if you have characters in your barcode value that are not allowed. You can have 12 or 13 digits in the EAN-13 barcode value. You don’t have to include the 13th digit (checksum) since it is automatically added.

EAN-13 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.

The EAN-13 barcode is also commonly written with 2 different bar heights. Typically, the height of the left, center and right guard bars are greater than the height of the bars encoding the actual barcode value, essentially creating a notch in the barcode where the text value can be written. The barcode engine provides the user with control over the size of this notch with the TextNotchPercent property.

The TextNotchPercent property can be set to a value of 0 to 50. This number represents the percentage of the tall bar height the short bars will be shortened by. For example, if TextNotchPercent is 10, and the bar height is set to 100 pixels, the tall bars (left, center and right guard bars) will be 100 pixels tall, and the short bars (bars encoding the value) will be 90 pixels tall.

An example:


IATA 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > IATA 2 of 5

This is a numeric only code used by the Airline industry, and is a variation of Industry 2 of 5. This barcode is also known as Airline 2 of 5.

Since IATA 2 of 5 requires a checksum, you must set the AppendCheckSum property to true and ImageGear will calculate and write the checksum.

An example:


Industry 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Industry 2 of 5

Industry 2 of 5 barcodes have been in use since the late 1960’s for airline tickets, photo developing envelopes and warehouse sorting systems. The Industry 2 of 5 barcode is also called Code 2 of 5.

Industry 2 of 5 encodes all of the information in the bars. The spaces are fixed width and are used only to separate the bars. Consequently, it is a fairly inefficient code in terms of how much space is required to encode a single digit.

  • Since Industry 2 of 5 is a numeric-only code, the barcode engine generates an error if the barcode value contains characters that are not numeric. Industry 2 of 5 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.
  • Since Industry 2 of 5 is a self-checking barcode, it normally does not require a checksum. However, when necessary, an optional modulo 10 checksum may be used. By default, the control will not write optional checksums. If a checksum is desired for Industry 2 of 5, set the EnableCheckSum property to 1 (TRUE) and the barcode engine will calculate and write the checksum.

An example:


Intelligent Mail
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Intelligent Mail

The Intelligent Mail Barcode is also known as the USPS OneCode Solution or USPS 4-State Customer Barcode (abbreviated 4CB, 4-CB, or USPS4CB). This barcode is adopting a new 4-state 1D barcode that includes more address information than the current code. Further information can be found at the USPS Web site: http://ribbs.usps.gov/onecodesolution/.

An example:

The Intelligent Mail barcode combines information currently found in the PostNet and Planet barcodes. The length of the barcode is fixed at 65 bars. It also contains a CRC-Checksum for verifying the barcode value. There is no error correction. The output of the barcode is a 20, 25, 29 or 31 digit string (0, 5, 9 or 11 digit zip code) containing the following data:

(© USPS-B-3200,Pages 4-5,file:SPUSPS-B3200B001.pdf)

Statistics

The Mailer ID is a field within the Intelligent Mail barcodes that is used to identify Mail Owners and/or Mailing Agents. The IDs are assigned by the USPS to each Mail Owner and/or Mailing Agent that requests them. A Mailer ID can be a 9-digit field or a 6-digit field. The USPS assigns 6-digit or 9-digit Mailer IDs based upon the mail volume of the mailer.

  • The barcode identifier is a 2 digit field assigned by the USPS. The first digit ranges from 0-9 and the second digit ranges from 0-4.
All 6-digit MIDs (Mailer IDs), assigned by USPS will begin with 0 through 8. All 9-digit MIDs will begin with the number 9.
  • Special services include a 3 digit field assigned by the USPS for any special services which range from 000-999.
  • The customer identifier is a 6 digit field assigned by the USPS and is unique for each customer. The range is from 000000000-999999999.
  • The sequence number is a 9 digit field assigned by the mailer for tracking mail pieces which range from 000000000-999999999.
  • The zip code is a 0, 5, 9, or 11 digit zip code which range from none, 00000-99999, 000000000-999999999, 00000000000-99999999999.


Interleaved 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Interleaved 2 of 5

Interleaved 2 of 5 is a numeric-only barcode that is widely used in warehouse and industrial applications. It is also called ITF-14/SCC-14.

The symbol can be as long as necessary to store the encoded data. The code is a high-density code.

The symbol is called "Interleaved" because a digit is encoded in the bars and the next digit is encoded in the spaces. There are five bars, two of which are wide; and five spaces, two of which are wide. Since the characters are interleaved in pairs, the barcode has to contain an even number of digits. If the barcode value contains an odd number of digits, a leading "0" will be added to the value.

Interleaved 2 of 5 requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels. Since Interleaved 2 of 5 is a self-checking barcode, it normally does not require a checksum. However, when necessary, an optional modulo 10 checksum may be used. By default, the control will not write optional checksums. If a checksum is desired for Interleaved 2 of 5, set the EnableCheckSum property to 1 (TRUE) and the control calculates and writes the checksum.

An example:


Inverted 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Inverted 2 of 5

Inverted 2 of 5 is similar to Industry 2 of 5, except the data is encoded in the white bars. It is not widely used.

An example:


Matrix 2 of 5
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Matrix 2 of 5

Matrix 2 of 5 is similar to DataLogic 2 of 5 with a checksum character. It is not widely used.

An example:


Patch Code
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Patch Code

The barcode engine supports the following patch codes:

Patch Code Type | Barcode Value
Patch 1 | 1100
Patch 2 | 1001
Patch 3 | 1010
Patch 4 / Toggle Patch | 0110
Patch 6 | 0011
Patch T / Transfer Patch | 0101

To write a Patch Code, set the writer BarcodeType property to PatchCode, then set the writer BarcodeValue property to a value of 1 through 6.

Patch Codes require a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 5 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 50 pixels. There is no checksum for Patch Code.

The minimum bar width for Patch Codes is 5.

An example:


PDF417
User Guide > How to Work with... > Barcodes > Supported Barcode Types > PDF417

PDF417 is often referred to as a stacked 1D barcode. Like DataMatrix it uses an error correction scheme and allows for encoding binary data.

An example PDF417:

2D writes are supported for PDF417 using an external application. Typically this can be done using ImGearFileFormats.SavePage or by writing to a Printer Device Context. The external application will set the barcode writing parameters and make a call to the Create method. The output image will then be available in the image properties.

Included features to use for this functionality are:

  • BarcodeValue - Barcode value returned as an array of bytes.
  • MinimumBarHeight - PDF417 uses this value as a multiplier of the minimum barcode width to set the row module height.
  • Rows - This value is used to set the number of rows.
  • RowsCreated - The number of rows created.
  • Columns - This value is used to set the number of columns to create.
  • ColumnsCreated - The number of columns created.
  • ErrorCorrectionLevel - This value is used for the amount of error correction to add to a barcode which supports selected error correction level.
  • ErrorCorrectionLevelUsed - The value from the error correction level created.
  • PDF417ErrorCorrectionLevel - The range of possible values to use with ErrorCorrectionLevel property.
  • RequiredHeight - An output height value is required to create the barcode image.
  • RequiredWidth - An output width value is required to create the barcode image.
Caution: When using trial (unpaid) licensing, the words”Accusoft.com Evaluation " will appear in every DataMatrix and PDF417 barcode created, taking up 24 bytes of space including the leading and trailing spaces. When testing the contents of generated barcodes, be aware of the extra space requirements.


PostNet
User Guide > How to Work with... > Barcodes > Supported Barcode Types > PostNet

Specific to the US Postal Service is the PostNet (Postal Numeric Encoding Technique) examples can be found on of mail in the United States. Unique in that it varies the height instead of the width of the bars. Except for the start and end bars they are in groups of five with two long, three short. A PostNet can encode five, nine, or eleven digits, nothing else. It includes a checksum.

An example:


QRcode
User Guide > How to Work with... > Barcodes > Supported Barcode Types > QRcode

QR code is one of very few barcode types that allow encoding of Kanji and Kana.

An example:

Statistics

  • The symbol size of the QRcode is 21 x 21 modules to 177 x 177 modules corresponding to Version 1-40, increasing in steps of 4.
  • The numeric data is maximum capacity 7089 digits.
  • The alphanumeric data maximum capacity is 4296 characters.
  • The byte data maximum capacity is 2953 bytes.
  • The Kanji data maximum capacity is 1817 characters.

Error Correction Level

This barcode type uses a Reed-Solomon error detection and correction scheme. There are four levels of error correction, each with increasing amount of error recover. Note: The higher the error level, the less data that can be stored in the barcode.

  • "L" - 7% error recovery
  • "M" - 15% error recovery
  • "Q" - 25% error recovery
  • "H" - 30% error recovery


Royal Post 4-State Barcode
User Guide > How to Work with... > Barcodes > Supported Barcode Types > Royal Post 4-State Barcode

The United Kingdom has implemented a new 4-state barcode referred to as the Royal Mail 4-State Customer Code (RM4SCC).

An example:

This barcode type is used by the Royal Post. It encodes 5, 6, or 7 character post codes along with a two character Delivery Point Suffix (DPS). A checksum character is included to verify the barcode read.


UPC-A
User Guide > How to Work with... > Barcodes > Supported Barcode Types > UPC-A

The UPC-A code is the standard version of the UPC code and has 12 digits. It is also called UPC-12 and is very similar to the EAN code. The UPC-A code is a numeric code, which is able to display digits from 0 to 9. Each character consists of two lines and two spaces.

UPC-A encodes 12 digits. The first digit of the UPC-A code indicates what the code contains as follows:

0. Regular UPC code

1. Reserved

2. Articles where the price varies by weight: for example meat.

3. National Drug Code (NDC) and National Health Related Items Code (HRI)

4. UPC code which can be used without format restrictions. For use in-store on non-food items

5. Coupons

6. Reserved

7. Regular UPC code

8. Reserved

9. Reserved

The second to sixth digits indicate the producer of the article (UPC ID number). This number is issued by the Uniform Code Council (UUC). The seventh to eleventh digits show the individual article number issued by the producer. The last digit is a Modulo 103 checksum digit, which is calculated by ImageGear.

The height of the UPC-A symbol should be at least half of the length of the symbol.

An error is generated if you have characters in your barcode value that are not allowed. You can have 11 or 12 digits in the UPC-A value. You don’t need to include the 12th digit (checksum) since ImageGear calculates it anyway.

UPC-A requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.

The UPC-A barcode is also commonly written with 2 different bar heights. Typically, the height of the left, center and right guard bars are greater than the height of the bars encoding the actual barcode value, essentially creating a notch in the barcode where the text value can be written. The user has control over the size of this notch with the TextNotchPercent property.

The TextNotchPercent property can be set to a value of 0 to 50. This number represents the percentage of the tall bar height the short bars will be shortened by. For example, if TextNotchPercent is 10, and the bar height is set to 100 pixels, the tall bars (left, center and right guard bars) will be 100 pixels tall, and the short bars (bars encoding the value) will be 90 pixels tall.

If you plan to detect UPC-A barcodes, you should set the BarcodeType property to this barcode type so that the barcode engine specifically looks for UPC-A. If you don’t tell the barcode engine to specifically look for UPC-A barcodes, it might confuse a UPC-A barcode with an EAN-13 barcode.

An example:

The second to sixth digits indicate the producer of the article (UPC ID number). This number is issued by the Uniform Code Council (UUC). The seventh to eleventh digits show the individual article number issued by the producer. The last digit is a Modulo 103 checksum digit, which is calculated by the barcode engine. The 12th digit will be added or replaced by the barcode engine during a write to be the correct value for the checksum.


UPC-E
User Guide > How to Work with... > Barcodes > Supported Barcode Types > UPC-E

UPC-E is a variation of the UPC-A symbol that is used for number system 0. The UPC-E code is a numeric-only code which is able to display digits from 0 to 9. UPC-E has 8 digits, where the last digit is a checksum digit automatically added by the barcode engine. The first digit is always "0" and it is also automatically added by ImageGear.

The UPC-E code is a compressed barcode which is intended for use on small items. Compression works by squeezing extra zeros out of the barcode and then automatically re-inserting them at the scanner. Only barcodes containing zeros are candidates for the UPC-E symbol.

When reading UPC-E, results are returned as uncompressed UPC values.

The barcode engine generates an error if you have characters in your barcode value that are not allowed. You can have 6, 10, 11 or 12 digits in the UPC-E value. If the barcode value has more than 6 digits, the barcode engine automatically compresses the value. There are four rules that determine what UPC codes can be created using the compressed UPC-E format:

  • If the last 3 digits of the manufacturer’s number are 000, 100, or 200, the valid product code numbers are 00000-00999 (1,000 numbers).
  • If the last 3 digits of the manufacturer’s number are 300, 400, 500, 600, 700, 800, or 900, the valid product code numbers are 00000-00099 (100 numbers).
  • If the last 2 digits of the manufacturer’s number are 10, 20, 30, 40, 50, 60, 70, 80 or 90, the valid product code numbers are 00000-00009 (10 numbers).
  • If the manufacturer’s number does not end in zero, the valid product code numbers are 00005-00009 (5 numbers).

UPC-E requires a quiet zone, which should be at least the width of 10 narrow bars. This means that if you set the MinimumBarWidth property to 3 pixels (narrow bar size), you should set the HorizontalWhiteSpace property to 30 pixels.

The UPC-E barcode is also commonly written with 2 different bar heights. Typically, the height of the left and right guard bars are greater than the height of the bars encoding the actual barcode value, essentially creating a notch in the barcode where the text value can be written.

The barcode engine provides the user with control over the size of this notch with the TextNotchPercent property. The TextNotchPercent property can be set to a value of 0 to 50. This number represents the percentage of the tall bar height the short bars will be shortened by.

For example, if TextNotchPercent is 10, and the bar height is set to 100 pixels, the tall bars (left and right guard bars) will be 100 pixels tall, and the short bars (bars encoding the value) will be 90 pixels tall.

An example:


Acquire an Image for Barcode Recognition
User Guide > How to Work with... > Barcodes > Acquire an Image for Barcode Recognition

Image Options

The barcode engine works with 1-bit black and white images, 8-bit grayscale images, and 24-bit color images. To convert other image formats use the ImageGear Reduce method or other methods with the included ImageGear system.

The barcode engine accepts ImGearPages, .NET Bitmaps or an hDIB as an input image. Use ImageGear to load images from numerous file formats and convert into the appropriate format for the barcode engine.

C# Example - Minimum C# code to load an image and recognize for barcodes.
Copy Code
// Load the file into an image page
    ImageGear.Core.ImGearPage page = ImageGear.Formats.ImGearFileFormats.LoadPage(fileContent, 0);
      List<ImGearResult> results = new List<ImGearResult>();
      // Analyze the barcode
      results.AddRange(IGBarcode.Reader.Analyze(page);


Recognize a Barcode
User Guide > How to Work with... > Barcodes > Recognize a Barcode

Once your image has been acquired and pre-image processing has been performed to recognize the barcode on the image, the following properties must first be set:

Checks Before Barcode Recognition

If possible, the following properties should be set before the detection process is started:

Property

Description

InkColor | The default barcode color is black.
Orientation | The default barcode orientation is horizontal/vertical orientations.
BarcodeTypes

The type of barcodes you want to detect. The default is all 1D barcodes. See the BarcodeTypes property for specific identification of barcode types that must be explicitly set to be recognized, and how to speed up barcode detection for known barcode types.

If the barcode image quality is poor (i.e. less than 300 dpi), set the BarcodeTypes property to the specific barcode type in order to obtain accurate results.
MaximumBarcodes

Sets the maximum number of barcodes that will be detected. The default is 100.

If you know how many barcodes you expect to find, set the MaximumBarcodes to that value, and the barcode engine will stop looking once that number is found.

Once these properties are set you are ready to recognize the barcode on the image.

The barcode engine detects all barcodes in an image and gives you complete details about them.

If you know where on the image the barcodes reside, setting the Area values to define a smaller rectangular area on your image will speed up processing. By default these values are set to 0 which tells the barcode engine to search the entire image automatically.

Supported Barcodes for Recognition

Once the BarcodeTypes property has been determined as stated in the How to Acquire an Image topic, use the following methods and properties to recognize the barcode.

Methods

Method | Description
Analyze(ImGearPage) | This method detects barcodes within the given ImGearPage

Properties

Property | Description
AppendCheckSum | This property gets or sets a value which determines if a checksum value is appended to the barcode during recognition.
Area | This property gets or sets the area of the image, in pixels, to analyze for barcode recognition.
AustralianPostCustomDecodeMode | This property gets or sets the AustralianPostCustomDecodeType .
BarcodeTypes | This property gets or sets the type of barcodes to analyze during recognition processing.
IncludeControlCharacters | This property gets or sets the control characters in the barcode value during recognition processing.
InkColor | This property gets or sets the ink color of barcodes to search for during recognition processing.
MaximumBarcodes | This property gets or sets the maximum number of barcodes to recognize.
Orientation | This property gets or sets the orientation of the barcodes to analyze during recognition.
ReturnPossibleBarcodes | This property gets or sets a value to determine if possible barcodes are returned in the result list.


Access Results
User Guide > How to Work with... > Barcodes > Access Results

Get Barcode Results

Result Class

The Analyze method returns an array of Result objects. Each element of the Result collection contains the results of a single recognized barcode (or unsolved barcode. See ReturnPossibleBarcodes).

C# Example - to get the recognition results
Copy Code
// call Analyze to detect barcodes in the image
// all detected barcodes will be returned to the
// Result collection class.
      List<ImGearResult> results = new List<ImGearResult>();
      results.AddRange(IGBarcode.Reader.Analyze(page);

// get some results info, if any
      foreach (ImGearResult found in results)
      {
         MessageBox.Show(found.BarcodeName);
         MessageBox.Show(found.BarcodeValue);
      }

Properties

Property | Description
Area | This property gets the bounding rectangular area of the recognized barcode.
BarcodeDataAsByte | This property gets the recognized barcode data value in bytes.
BarcodeName | This property gets the name of the recognized barcode.
BarcodeType | This property gets the type of the recognized barcode.
BarcodeValue | This property gets the value of the recognized barcode.
Confidence | This property gets the confidence of the recognized barcode.
Length | This property gets the length of the result string.
NumberCheckSumChars | This property gets the number of characters in the recognized checksum.
Point1 | This property gets the top left coordinate of the recognized barcode.
Point2 | This property gets the top right coordinate of the recognized barcode.
Point3 | This property gets the bottom left coordinate of the recognized barcode.
Point4 | This property gets the bottom right coordinate of the recognized barcode.
Skew | This property gets the angle of skew for the recognized barcode analyzed.
IsCheckSumValid | This property gets a valid checksum for a recognized barcode.

Order of Results

Since the barcode engine can return multiple barcode results from a single scan, the detected barcode results (both solved and unsolved) will be sorted using the following criteria. Note that all solved barcodes will be ordered before unsolved barcodes.

  1. First, the confidence factor is used to sort the barcode results from highest confidence to lowest. The Confidence property gets the confidence of the barcode that was recognized.
  2. Next, for any barcodes with the same confidence, they will then be sorted by their location, from top to bottom, and then left to right.


Create a 1D Barcode
User Guide > How to Work with... > Barcodes > Create a 1D Barcode

Basic Steps to Create a 1D Barcode

  1. Set the value you want to create.

Property | Description
BarcodeType | This property gets or sets the type of barcode to create from the BarcodeType enumeration.
BarcodeValue | This property gets or sets the value of the barcode to be created.
BarcodeValueAsByte | This property gets or sets the current barcode value as an array of bytes used only if non-ASCII text values are needed.

  2. Call either the CreatePage method, Create method (to create an hDib) or the CreateBitmap method (to create a System.Drawing.Bitmap) from the Barcode Writer member. These methods will return an image with the desired barcode.

Method | Description
CreatePage | This method is the main method for creating ImGearPage barcodes.

There are many additional properties within the Writer class which may be used as needed in creating barcodes. See the class overview for more information.

Examples

C# Example - Basic steps for barcode writing 1D barcodes
Copy Code
//create the Barcode component
ImageGear.Barcode.ImGearBarcode IGBarcodeWrite = new ImageGear.Barcode.ImGearBarcode();
//set the required writer properties
IGBarcodeWrite.Writer.BarcodeType = ImGearBarcodeType.Code39Barcode;
IGBarcodeWrite.Writer.BarcodeValue = "CODE39";
//call Create and get resulting image
myImGearPage = IGBarcodeWrite.Writer.CreatePage();

VB.NET Example - Basic steps for barcode writing 1D barcodes
Copy Code
'create the Barcode component
Dim IGBarcodeWrite As New ImageGear.Barcode.ImGearBarcode()
'set the required writer properties
IGBarcodeWrite.Writer.BarcodeType = ImGearBarcodeType.Code39Barcode
IGBarcodeWrite.Writer.BarcodeValue = "CODE39"
'call Create and get resulting image
myImGearPage = IGBarcodeWrite.Writer.CreatePage()


Create a 2D Barcode
User Guide > How to Work with... > Barcodes > Create a 2D Barcode

2D Barcodes

Each 2D barcode type supported by ImageGear has its own object type. ImageGear supports the creation of DataMatrix and PDF417 barcodes.

Object | Description
WriterDataMatrix | The class which can write out a DataMatrix barcode.
WriterPDF417 | The class which can write out a PDF417 barcode.

Although the barcode engine supports reading of Aztec and QR Code, writing of these barcodes is not supported.

Basic Steps to Create a 2D Barcode

  1. Instantiate the writer class for the barcode type you want to create.
  2. Set the value you want to create.

Property | Description
BarcodeValue | This property gets or sets the value of the barcode to be created.
BarcodeValueAsByte | This property gets or sets the current barcode value as an array of bytes used only if non-ASCII text values are needed.

  3. Call either the CreatePage method, Create method (to create an hDib) or the CreateBitmap method (to create a System.Drawing.Bitmap) from the instanced writer class. These methods will return an image with the desired barcode.

Method | Description
CreatePage | This method is the main method for creating ImGearPage barcodes.

Examples for PDF417 Barcodes

C# Example - Basic steps for writing PDF417 barcodes
Copy Code
//create the Barcode component
ImageGear.Barcode.ImGearBarcode IGBarcodeWrite = new ImageGear.Barcode.ImGearBarcode();
//Create the writer PDF417 class
ImageGear.Barcode.ImGearWriterPDF417 pdfWriter = new ImageGear.Barcode.ImGearWriterPDF417(IGBarcodeWrite);
// Set the text value
pdfWriter.BarcodeValue = "PDF417 Value";
//call Create and get resulting image
myImGearPage = pdfWriter.CreatePage();
pdfWriter.Dispose();

VB.NET Example - Basic steps for writing PDF417 barcodes
Copy Code
'create the Barcode component
Dim IGBarcodeWrite As New ImageGear.Barcode.ImGearBarcode()
'Create the writer PDF417 class
Dim pdfWriter As New ImageGear.Barcode.ImGearWriterPDF417(IGBarcodeWrite)
' Set the text value
pdfWriter.BarcodeValue = "PDF417 Value"
'call Create and get resulting image
myImGearPage = pdfWriter.CreatePage()
pdfWriter.Dispose()

Examples for DataMatrix Barcodes

C# Example - Basic steps for barcode writing DataMatrix barcodes
Copy Code
//create the Barcode component
ImageGear.Barcode.ImGearBarcode IGBarcodeWrite = new ImageGear.Barcode.ImGearBarcode();
//Create the writer data matrix class
ImageGear.Barcode.ImGearWriterDataMatrix dmWriter = new ImageGear.Barcode.ImGearWriterDataMatrix(IGBarcodeWrite);
// Set the text value
dmWriter.BarcodeValue = "DataMatrix Value";
//call Create and get resulting image
myImGearPage = dmWriter.CreatePage();
dmWriter.Dispose();

VB.NET Example - Basic steps for barcode writing DataMatrix barcodes
Copy Code
'create the Barcode component
Dim IGBarcodeWrite As New ImageGear.Barcode.ImGearBarcode()
'Create the writer data matrix class
Dim dmWriter As New ImageGear.Barcode.ImGearWriterDataMatrix(IGBarcodeWrite)
' Set the text value
dmWriter.BarcodeValue = "DataMatrix Value"
'call Create and get resulting image
myImGearPage = dmWriter.CreatePage()
dmWriter.Dispose()


Digital Camera RAW Formats
User Guide > How to Work with... > Digital Camera RAW Formats

This section provides the following information:

  • ImageGear Digital Camera RAW Filter
  • Reconstructing Camera Raw Images with ImageGear Processing API


ImageGear Digital Camera RAW Filter
User Guide > How to Work with... > Digital Camera RAW Formats > ImageGear Digital Camera RAW Filter

ImageGear supports reading raw images created by many digital cameras. Support for raw images includes reading of image pixel data, color reconstruction of raw images, and reading of metadata stored with the images. This section provides information about the following:

  • Loading Raw Images
  • Loading of Pixel Data from RAW and DNG Images
  • Headerless Digital Camera Raw Images


Loading Raw Images
User Guide > How to Work with... > Digital Camera RAW Formats > ImageGear Digital Camera RAW Filter > Loading Raw Images

Load camera raw images in the same way as you load images of all other formats, using one of the image loading methods, such as ImGearFileFormats. LoadPage Method. Use the control parameters of the corresponding format filter to control loading of raw images.

By default, ImageGear attempts to reconstruct the full color image from raw data. You can also load unprocessed or partially processed image and apply some custom processing to it.


Loading of Pixel Data from RAW and DNG Images
User Guide > How to Work with... > Digital Camera RAW Formats > ImageGear Digital Camera RAW Filter > Loading of Pixel Data from RAW and DNG Images

Digital cameras store raw images in exactly the same format as obtained from the camera sensor. A number of image processing operations must be performed to reconstruct full color image from the raw data. All raw format filters and DNG have the same set of loading options that allows loading unprocessed or partially processed image. Partially processed images can then be processed with the help of ImageGear image processing methods.

Note that camera manufacturers do not publish specifications on their raw formats. ImageGear attempts to reconstruct color images correctly where it is possible. For some cameras not all of the color balance data is available. The application may need to apply additional processing to such images.

Cameras Supported for DC RAW Formats lists the level of support that ImageGear provides for particular cameras.


Headerless Digital Camera Raw Images
User Guide > How to Work with... > Digital Camera RAW Formats > ImageGear Digital Camera RAW Filter > Headerless Digital Camera Raw Images

A special group of camera raw formats is Headerless Camera Raw formats. The Headerless Digital Camera file filter provides support for Digital Camera Raw images that only contain pixel data and no header.

Due to the absence of a header, such files cannot be detected reliably. ImageGear uses low detection priority for these images, and by default, detection of this filter is disabled. Also, since these files do not contain any metadata describing color reconstruction, ImageGear support level for them is limited to "S2" - pixel decoding only.


Reconstructing Camera Raw Images with ImageGear Processing API
User Guide > How to Work with... > Digital Camera RAW Formats > Reconstructing Camera Raw Images with ImageGear Processing API

By default, ImageGear reconstructs Camera Raw images automatically, using the settings found in image metadata. However, one of the main benefits of Raw formats is that they can be custom adjusted during conversion to the working RGB color space.

ImageGear provides an API that allows you to specify white balance and tone settings for Raw image reconstruction.

In order to adjust white balance for the image, set the ApplyColorspaceConversion control parameter to false (see DCRAW format Control Parameters). Use ImGearCameraRawProcessing. CalculateCameraToRGBMatrix Method to calculate a conversion matrix, based on selected white balance and on known conversion matrices obtained from metadata. Use ImGearWhiteBalance Class for preset white balance settings and for converting between color temperature and white point XY values. The ApplyColorspaceConversion control parameter only has effect if the ApplyLowLevelProcessing option is True.

In order to adjust image tone (contrast/brightness curve), set the ApplyToneCorrection filter option to False. This will tell ImageGear to skip the tone correction step. The application can create a Tone correction LUT using ImGearCameraRawProcessing. BuildToneLUT Method, or build its own Tone LUT. In order to convert the image to the standard sRGB color space, an additional sRGB Gamma LUT must be applied. ApplyToneCorrection only has effect if both ApplyLowLevelProcessing and ApplyColorspaceConversion options are True.


Cameras Supported for DC RAW Formats
User Guide > How to Work with... > Digital Camera RAW Formats > Cameras Supported for DC RAW Formats

Camera manufacturers do not publish specifications on their raw formats. ImageGear attempts to reconstruct color images correctly where it is possible. For some cameras, however, not all of the color balance data is available. The application may need to apply additional processing to such images. This table lists the level of support that ImageGear provides for particular cameras.

The table uses the following notation:

  • S2 - ImageGear loads non-demosaiced image, basic metadata, and exif metadata if available. Reconstructed image can have incorrect colors.
  • S3 - Same as S2 plus correct white balance, black level tags. Display can be slightly different from native viewer, due to lack of info on camera color space.
  • S4 - Displays with colors very close to native viewer.
  • S5 - Displays with colors and contrast very close to native viewer.

Manufacturer | Model | Level of Support
Canon | EOS-1D | S2
Canon | EOS-1D Mark II | S5
Canon | EOS-1D Mark II N | S5
Canon | EOS-1D Mark III | S5
Canon | EOS-1D Mark IV | S5
Canon | EOS-1DS | S2
Canon | EOS-1Ds Mark II | S5
Canon | EOS-1Ds Mark III | S5
Canon | EOS 5D | S4
Canon | EOS 5D Mark II | S5
Canon | EOS 7D | S5
Canon | EOS 10D | S5
Canon | EOS 20D | S3
Canon | EOS 30D | S4
Canon | EOS 40D | S5
Canon | EOS 50D | S5
Canon | EOS 300D | S5
Canon | EOS 350D | S5
Canon | EOS 400D | S4
Canon | EOS 450D | S5
Canon | EOS 500D | S5
Canon | EOS 550D | S5
Canon | EOS 1000D | S5
Canon | EOS 1000D | S5
Canon | EOS D30 | S2
Canon | EOS D60 | S5
Canon | EOS D2000C | S3
Canon | EOS Digital Rebel | S5
Canon | EOS Digital Rebel T1i | S5
Canon | EOS Digital Rebel T2i | S5
Canon | EOS Digital Rebel XS | S5
Canon | EOS Digital Rebel XSi | S5
Canon | EOS Digital Rebel XT | S5
Canon | EOS Digital Rebel XTi | S4
Canon | EOS DX | S5
Canon | EOS K215 | S5
Canon | EOS K236 | S5
Canon | EOS Kiss Digital | S5
Canon | EOS Kiss Digital N | S5
Canon | EOS Kiss Digital X | S4
Canon | EOS Kiss Digital X2 | S5
Canon | EOS Kiss Digital X3 | S5
Canon | EOS Kiss Digital X4 | S5
Canon | PowerShot 600 | S4
Canon | PowerShot A5 | S2
Canon | PowerShot A5 Zoom | S5
Canon | PowerShot A50 | S2
Canon | PowerShot A460 ** | S2
Canon | PowerShot A470 | S5
Canon | PowerShot A530 | S4
Canon | PowerShot A610 ** | S2
Canon | PowerShot A620 ** | S2
Canon | PowerShot A630 ** | S2
Canon | PowerShot A640 ** | S2
Canon | PowerShot A650 | S5
Canon | PowerShot A710 ** | S2
Canon | PowerShot A720 ** | S2
Canon | PowerShot G1 | S5
Canon | PowerShot G2 | S5
Canon | PowerShot G3 | S3
Canon | PowerShot G5 | S2
Canon | PowerShot G6 | S2
Canon | PowerShot G7 ** | S2
Canon | PowerShot G9 | S5
Canon | PowerShot G10 | S5
Canon | PowerShot G11 | S5
Canon | PowerShot Pro1 | S5
Canon | PowerShot Pro70 | S2
Canon | PowerShot Pro90 IS | S2
Canon | PowerShot S2 I S** | S2
Canon | PowerShot S3 IS ** | S2
Canon | PowerShot S5 IS ** | S2
Canon | PowerShot S30 | S2
Canon | PowerShot S40 | S5
Canon | PowerShot S45 | S2
Canon | PowerShot S50 | S4
Canon | PowerShot S60 | S2
Canon | PowerShot S70 | S2
Canon | PowerShot S90 | S5
Canon | PowerShot SD300 | S5
Canon | PowerShot SX1 IS | S5
Canon | PowerShot SX110 IS | S5
Casio | Exlim Pro 505 ** | S2
Casio | Exlim Pro 600 ** | S2
Casio | Exlim Pro 700 ** | S2
Casio | EX-S100 ** | S2
Casio | EX-Z50 ** | S2
Casio | EX-Z55 ** | S2
Casio | QV-R51 ** | S2
Fujifilm | FinePix E550 | S5
Fujifilm | FinePix E900 | S5
Fujifilm | FinePix F700 | S2
Fujifilm | FinePix F710 | S2
Fujifilm | FinePix HS10 | S5
Fujifilm | FinePix HS11 | S5
Fujifilm | FinePix S2 Pro | S2
Fujifilm | FinePix S3 Pro | S5
Fujifilm | FinePix S5 Pro | S5
Fujifilm | FinePix S20 Pro | S2
Fujifilm | FinePix S100FS | S5
Fujifilm | FinePix S200EXR | S5
Fujifilm | FinePix S5000 Z | S2
Fujifilm | FinePix S5100 | S5
Fujifilm | FinePix S5200 | S5
Fujifilm | FinePix S5500 | S5
Fujifilm | FinePix S5600 | S5
Fujifilm | FinePix S6000fd | S5
Fujifilm | FinePix S6500fd | S5
Fujifilm | FinePix S7000 Z | S2
Fujifilm | FinePix S9000 | S5
Fujifilm | FinePix S9100 | S5
Fujifilm | FinePix S9500 | S5
Fujifilm | FinePix S9600 | S5
Hasselblad | CFV | S5
Hasselblad | H3D | S5
Hasselblad | H4D | S5
Imacon | Ixpress 16-megapixel | S4
Imacon | Ixpress 22-megapixel | S4
Kodak | DCS 720x | S2
Kodak | DCS 760C | S4
Kodak | DCS 760M (monochrome) | S2
Kodak | DCS PRO 14n (13.5 MegaPixel) | S2
Kodak | DCS PRO 14n (3.2 MegaPixel) | S2
Kodak | DCS PRO 14n (6 MegaPixel) | S2
Kodak | DCS PRO 14n (YUV) | S2
Kodak | DCS PRO 14nx | S2
Kodak | DCS Pro SLR/c | S2
Kodak | DCS Pro SLR/c (YUV) | S2
Kodak | DCS Pro SLR/n (13.5 MegaPixel) | S2
Kodak | DCS Pro SLR/n (3.2 MegaPixel) | S2
Kodak | DCS Pro SLR/n (6 MegaPixel) | S2
Kodak | DCS Pro SLR/n (YUV) | S2
Kodak | EasyShare P850 | S2
Kodak | EasyShare P880 | S2
Konica Minolta | Alpha Sweet | S5
Konica Minolta | DiMAGE 5 | S5
Konica Minolta | DiMAGE 7 | S5
Konica Minolta | DiMAGE 7Hi | S5
Konica Minolta | DiMAGE 7i | S4
Konica Minolta | DiMAGE A1 | S5
Konica Minolta | DiMAGE A2 | S5
Konica Minolta | DYNAX/MAXXUM 5D | S5
Konica Minolta | DYNAX/MAXXUM/ALPHA 7D | S5
Leaf | 3024x1944 | S3
Leaf | AFi 7 | S5
Leaf | Aptus 17 | S5
Leaf | Aptus 22 | S5
Leaf | Aptus 54S | S5
Leaf | Aptus 65 | S5
Leaf | Aptus 75 | S5
Leaf | Aptus 75S | S5
Leaf | Cantare | S3
Leaf | CatchLight | S3
Leaf | CMost | S5
Leaf | DCB2 | S3
Leaf | Valeo 6 | S5
Leaf | Valeo 11 | S5
Leaf | Valeo 17 | S5
Leaf | Valeo 22 | S5
Leaf | Volare | S3
Leica | Digilux 2 | S5
Leica | Digilux 3 | S5
Leica | D-LUX2 | S5
Leica | D-LUX3 | S5
Leica | V-LUX1 | S5
Mamiya | ZD | S4
Nikon | Coolpix 5000 | S2
Nikon | Coolpix 5400 | S5
Nikon | Coolpix 5700 | S5
Nikon | Coolpix 8400 | S5
Nikon | Coolpix 8700 | S5
Nikon | Coolpix 8800 | S5
Nikon | D1 | S5
Nikon | D1H | S5
Nikon | D1X | S5
Nikon | D2H | S5
Nikon | D2Hs | S5
Nikon | D2X | S5
Nikon | D2Xs | S5
Nikon | D3 | S5
Nikon | D3X | S5
Nikon | D40 | S5
Nikon | D40X | S5
Nikon | D50 | S5
Nikon | D60 | S5
Nikon | D70 | S5
Nikon | D70s | S5
Nikon | D80 | S4
Nikon | D90 | S5
Nikon | D100 | S5
Nikon | D200 | S5
Nikon | D300 | S5
Nikon | D300s | S5
Nikon | D700 | S5
Nikon | D3000 | S5
Nikon | D5000 | S5
Olympus | C-70Z | S5
Olympus | C-740UZ | S5
Olympus | C-770UZ | S5
Olympus | C-5050 Zoom | S5
Olympus | C-5060 Zoom | S5
Olympus | C-7070 Zoom | S5
Olympus | C-7000 Zoom | S5
Olympus | C-8080 | S5
Olympus | E-1 | S5
Olympus | E-3 | S5
Olympus | E-10 | S5
Olympus | E-20 | S5
Olympus | E-300 | S5
Olympus | E-330 | S5
Olympus | E-400 | S5
Olympus | E-420 | S5
Olympus | E-410 | S4
Olympus | E-500 | S5
Olympus | E-510 | S4
Olympus | E-520 | S5
Olympus | E-P1 | S5
Olympus | E-PL1 | S5
Olympus | SP350 | S5
Olympus | SP500UZ | S5
Olympus | SP510UZ | S5
Olympus | SP550UZ | S5
Olympus | SP560UZ | S5
Panasonic | DMC-FX150 | S5
Panasonic | DMC-FZ18 | S5
Panasonic | DMC-FZ28 | S5
Panasonic | DMC-FZ30 | S5
Panasonic | DMC-FZ35 | S5
Panasonic | DMC-FZ38 | S5
Panasonic | DMC-FZ50 | S5
Panasonic | DMC-FZ8 | S5
Panasonic | DMC-G1 | S5
Panasonic | DMC-GH1 | S5
Panasonic | DMC-G2 | S5
Panasonic | DMC-L1 | S5
Panasonic | DMC-L10 | S5
Panasonic | DMC-LC1 | S5
Panasonic | DMC-LX1 | S5
Panasonic | DMC-LX2 | S5
Panasonic | DMC-LX3 | S5
Pentax | *ist D | S5
Pentax | *ist DL | S5
Pentax | *ist DL2 | S4
Pentax | *ist DS | S5
Pentax | *ist DS2 | S5
Pentax | K10D | S5
Pentax | K100D | S4
Pentax | K100D Super | S5
Pentax | K110D | S4
Phase One | H 10 | S5
Phase One | H 20 | S5
Phase One | H 25 | S5
Phase One | LightPhase | S5
Phase One | P 20 | S5
Phase One | P 25 | S5
Phase One | P 30 | S5
Phase One | P 40+ | S5
Phase One | P 45+ | S4
Phase One | P 65+ | S4
Samsung | GX-1S | S5
Sony | DSC-F828 | S2
Sony | DSC-R1 | S3
Sony | DSC-V3 | S2
Sony | DSLR-A100 | S5
Sony | DSLR-A200 | S5
Sony | DSLR-A230 | S5
Sony | DSLR-A300 | S5
Sony | DSLR-A330 | S5
Sony | DSLR-A350 | S5
Sony | DSLR-A550 | S5
Sony | DSLR-A700 | S2
Sony | DSLR-A900 | S5
Sony | NEX-3 | S5
Sony | NEX-5 | S5

** See Headerless Camera Raw. Detection is disabled by default.


DICOM Images
User Guide > How to Work with... > DICOM Images

The ImageGear.Formats.DICOM Namespace provides features that are used with medical and DICOM images.

To use the support for DICOM format as well as manipulate, transform, and process DICOM images, add the DICOM format to ImageGear's global formats list, as follows:

C#
Copy Code
ImGearFileFormats.Filters.Insert(0, ImGearDICOM.CreateDICOMFormat());

The format support of the MD component includes loading and saving monochrome, palettized, and true color medical images using the following file formats:

  • DICOM 3.0 Part 10-compliant images
  • DICOM 3.0 Raw Format (non-Part 10-compliant)

The ImageGear.Formats.DICOM namespace provides DICOM Presentation State objects that allow you to display images on various devices and media, to store specific settings for display (contrast transformations, geometric transformations), and to store ART annotations and to display multi-frame images.

In addition, your application will continue to support all ImageGear-supported file formats, allowing you to convert an image of a different format to a medical image format, and vice-versa.

The following sections discuss various aspects of working with these images:

  • DICOM Images
    • Loading and Saving DICOM Images
      • Transfer Syntaxes
      • Saving DICOM Images Using JPEG Compression
        • JPEG Lossy Baseline or Extended
        • JPEG Lossy Baseline Only
        • JPEG Lossless
      • Saving DICOM Images Using RLE Compression
      • Saving Non-DICOM Images to DICOM Format
      • Saving Multiframe Images
    • Overlays
    • DICOM Metadata Support
    • DICOM Multi-Planar Reconstruction
    • Presentation State
      • Consistent Display of Images
      • Grayscale Contrast Transformations
      • Geometric Transformations
      • Annotations
      • Working with Presentation State Objects
    • Waveform Image Support
    • IOD/SOP Class Support
    • Using ImageGear.Dicom.Forms Namespace
See Also
Displaying Medical Images
Use the Metadata Dictionary
DICOM


Loading and Saving DICOM Images
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images

Load DICOM images in the same way as you load images of other formats. Use DICOM format options to set specific features for image loading.

Save DICOM images in the same way as you save images of other formats. However, there are a few items that need to be discussed about saving DICOM images. This section provides information about the following:

  • Loading and Saving DICOM Images
    • Transfer Syntaxes
    • Saving DICOM Images Using JPEG Compression
      • JPEG Lossy Baseline or Extended
      • JPEG Lossy Baseline Only
      • JPEG Lossless
    • Saving DICOM Images Using RLE Compression
    • Saving Non-DICOM Images to DICOM Format
    • Saving Multiframe Images


Transfer Syntaxes
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Transfer Syntaxes

There are two ways to specify transfer syntax (compression) for DICOM image saving: SaveFormat parameter, and TransferSyntax DICOM format option. SaveFormat is an easy-to-use shortcut, while TransferSytnax option provides the full selection of transfer syntaxes for image saving.

ImGearSavingFormats | ImGearCompressions | Transfer Syntax
DICOM | AUTO | Defined by SaveSyntax option
DICOM_UNCOMP | NONE | ImplicitLittleEndian
DICOM_RLE | RLE | RLE
DICOM_JPEG | JPEG | JPEG Lossy
DICOM_JPEG2K | JPEG2K | JPEG2K Lossy


Saving DICOM Images Using JPEG Compression
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving DICOM Images Using JPEG Compression

ImageGear supports the following modes for saving JPEG compressed DICOM images:

  • JPEG Lossy Baseline or Extended
  • JPEG Lossy Baseline Only
  • JPEG Lossless


JPEG Lossy Baseline or Extended
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving DICOM Images Using JPEG Compression > JPEG Lossy Baseline or Extended

This is the default mode for saving DICOM images with JPEG compression in ImageGear. In this mode:

  • ImageGear saves grayscale images as either 8 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax, or as 9..12 bits per pixel, using "JPEG Extended (Process 2 & 4)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.

If the source image colorspace is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See Pixel Format Conversion during Image Saving for more details.

As part of JPEG Lossy compression process, ImageGear converts RGB rasters into YCbCr colorspace (or YCC in DICOM terminology) during saving. This conversion is fully encapsulated into the ImageGear JPEG codec; the application should not convert images to YCbCr before saving them to JPEG or DICOM JPEG.

Use one of these ways to save an image as DICOM JPEG Baseline or Extended:

  • Save the image as ImGearSavingFormats Enumeration.DICOM_JPEG (SaveSyntax parameter is ignored)
  • Save the image as ImGearSavingFormats Enumeration.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSY
  • Save the image as ImGearSavingFormats Enumeration.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_2_4


JPEG Lossy Baseline Only
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving DICOM Images Using JPEG Compression > JPEG Lossy Baseline Only

This mode provides compatibility with viewers that do not support JPEG Extended coding process (12-bit images). In this mode:

  • ImageGear saves grayscale images as 8 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.

If the source image colorspace is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See Pixel Format Conversion during Image Saving for more details.

As part of the JPEG Lossy compression process, ImageGear converts RGB rasters into YCbCr colorspace (or YCC in DICOM terminology) during saving. This conversion is fully encapsulated into the ImageGear JPEG codec; the application should not convert images to YCbCr before saving them to JPEG or DICOM JPEG.

To save an image as DICOM JPEG Baseline, use ImGearSavingFormats Enumeration.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_BASELINE_PR_1.


JPEG Lossless
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving DICOM Images Using JPEG Compression > JPEG Lossless

In this mode:

  • ImageGear saves grayscale images as 8…16 bits per pixel, using "JPEG Lossless, Non-Hierarchical (Process 14)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Lossless, Non-Hierarchical (Process 14)" transfer syntax.
JPEG Lossless compression does not involve internal conversion or RGB rasters into YCbCr colorspace (YCC in DICOM terminology).

To save an image as DICOM JPEG Lossless, use ImGearSavingFormats Enumeration.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS or ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_14.


Saving DICOM Images Using RLE Compression
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving DICOM Images Using RLE Compression

DICOM provides a mechanism for supporting the use of Run Length Encoding (RLE) Compression, which is a byte oriented lossless compression scheme.

  • ImageGear saves grayscale images as 8…16 bits per pixel, using "RLE Lossless" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "RLE Lossless" transfer syntax.

If the source image color space is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See Pixel Format Conversion during Image Saving for more details.

Use one of the following to save an image as DICOM RLE:

  • Save the image as ImGearSavingFormats.DICOM_RLE (SaveSyntax parameter is ignored).
  • Save the image as ImGearSavingFormats.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.RLE.


Saving Non-DICOM Images to DICOM Format
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving Non-DICOM Images to DICOM Format

ImageGear for .NET allows saving of non-DICOM images to DICOM format. A default Secondary Capture DataSet is created for such images.


Saving Multiframe Images
User Guide > How to Work with... > DICOM Images > Loading and Saving DICOM Images > Saving Multiframe Images

The DICOM format is not designed for an easy insertion of pages. The following issues exist:

  • Pages are stored sequentially rather than in arbitrary order. If the image is compressed, replacing a page requires rewriting all subsequent pages.
  • "Number of pages" tag is stored as "Integer string". If, for example, tag is equal to "99", adding a page requires to increase length of this tag, and thus requires rewriting of the whole image.
  • All pages in the file must have the same dimensions and compression.
  • Some DICOM modalities support multiframe images, while others don't.

According to the above issues, DICOM format filter in ImageGear for .NET has the following limitations:

  • Only APPEND and OVERWRITE saving modes are supported.
  • ImageGear for .NET allows appending a page to a DICOM file only if the file already has "Number Of Pages" tag, and this tag has maximum possible length for an Integer String: 12 bytes.
  • Page being saved must have the same dimensions and compression as existing pages in the file.
  • ImageGear does not check if image's modality allows multipage images.

If any of the limitations is encountered, ImageGear throws an exception.

To save a multipage image:

  1. Load an image to ImageGear for .NET.
  2. Save image to a new file (or use OVERWRITE mode).
  3. Load next image to ImageGear for .NET.
  4. Save image to existing file, using APPEND mode.
  5. Repeat steps 3 and 4 for all pages to be written.

Alternatively, create an ImGearDocument Class and save to DICOM using the SaveDocument Method.


Overlays
User Guide > How to Work with... > DICOM Images > Overlays

An Overlay Plane describes graphics or bit-mapped text that is associated with an Image. It may also describe a Region of Interest in an Image. Each Overlay Plane is one bit deep. Sixteen separate Overlay Planes may be associated with an Image. Overlay data is stored in Overlay Data (60xx,3000).

Use ImGearDICOM.LoadOverlay Method() to load graphic overlays from a DICOM DataSet to ART annotations. Use ImGearDICOM.SaveOverlay Method() to save ART annotations into a DICOM DataSet as overlay data.

DICOM overlays are monochrome images (see DICOM specification PS 3.3 - 2008, C.9.2 Overlay plane module) - pixels from overlay data with a zero value (i.e., black) will not be displayed; pixels with a non-zero value will be displayed.

Upon saving of ART annotations, all non-black pixels of annotations will be saved as overlay data. As a result, a text annotation that has a non-null or non-black FillColor Property will be displayed as a square. To save the text only as an overlay, it is necessary to set the FillColor Property to null or black.

See Also
ART 2.0 and ART 3.0 Marks


DICOM Metadata Support
User Guide > How to Work with... > DICOM Images > DICOM Metadata Support

ImageGear for .NET uses its general metadata engine for all file formats, including DICOM. When ImageGear loads a DICOM image, it builds a metadata tree structure and attached it to the new ImGearPage Class object. Use ImageGear for .NET Metadata support classes to access data items in this tree.

A DICOM file includes one header with metadata, and zero, one, or multiple images. Metadata applies to all images in the file. ImageGear loads a copy of DICOM metadata into every loaded page. DICOM Document metadata is empty.

See the DICOM section in the ImageGear Imaging Formats Reference chapter information about the detailed structure of the DICOM Metadata tree.

DICOM tags map to ImageGear metadata tags as follows:

Tag group number, element number | ImGearMetadataNode. Tag Property
Value Representation | ImGearMetadataLeaf. NativeType Field
Value Length | Not stored explicitly. Application can use string and array lengths instead.
Value Multiplicity (Item count) | Not stored explicitly. For values of OB/OW/OF it is always 1. For other Value Representations, if data is singular it is 1, otherwise it is equal to the length of the data array.
Data | ImGearMetadataLeaf. Data Property

"Sequence" (SQ) tags are represented by nested metadata trees. SQ contains one or more Sequence Items, and cannot contain normal DICOM tags. Sequence Item contains a set of DICOM tags.

The following tags are read from the file, but not added to the metadata tree:

  • Group lengths
  • Sequence Delimitation items
  • Item delimitation items

The following table lists the mapping between DICOM Value Representations and .NET system types:

VR | Meaning | System type to which it converts on reading | Allowed system types on writing
AE | Application Entity | String | String
AS | Age String | String | String
AT | Attribute Tag | String | String
CS | Code String | String | String
DA | Date | String | String
DS | Decimal String | double | all numeric types, String
DT | Date Time | String | String
FL | Floating Point Single | float | all numeric types, String
FD | Floating Point Double | double | all numeric types, String
IS | Integer String | long (64-bit) | all integer types, String
LO | Long String | String | String
LT | Long Text | String | String
OB | Other Byte String | byte[] | byte[]
OW | Other Word String | ushort[] | ushort[]
PN | Person Name | String | String
SH | Short String | String | String
SL | Signed Long | int | all integer types, String
SQ | Sequence | - | -
SS | Signed Short | short | all integer types, String
ST | Short Text | String | String
TM | Time | String | String
UI | Unique Identifier | String | String
UL | Unsigned Long | uint | all integer types, String
UN | Unknown | byte[] | byte[]
US | Unsigned Short | ushort | all integer types, String
UT | Unlimited Text | String | String
OF | Other Float String | float[] | float[], double[]

For types other than OB, OW and OF, if the system type is an array, a multivalued data element is saved.

Example of conversion on metadata reading:

VR | Tag value | Metadata leaf data type | Metadata leaf value
US | 0x0001 | ushort | 1
OW | 0x0001 0x0002 0x0003 | ushort[] | {1, 2, 3}
DS | "0.12345\0.6789" | double[] | {0.12345, 0.6789}
CS | "MR" | string | "MR"
CS | "ORIGINAL\PRIMARY" | string[] | {"ORIGINAL", "PRIMARY"}


DICOM Multi-Planar Reconstruction
User Guide > How to Work with... > DICOM Images > DICOM Multi-Planar Reconstruction

The ImageGear.Formats.DICOM namespace contains the ImGearMprProcessor class that provides functionality to perform multi-planar reconstruction (MPR) on the provided stack of images in any of the MPR views.

To perform MPR, the ImGearMprProcessor class instance should be initialized through one of its constructors, providing a collection of initial stack of images and the type of that stack orientation (Axial, Coronal or Sagittal).

Then GetPlane() could be used to obtain the MPR result applied on initial stack of images, providing the start/end positions of the MPR line and the type of the view, from which to perform MPR. The method returns the MPR result as an ImGearRasterPage class instance.

Similarly, GetPlaneSize() method could be used to calculate the expected dimensions of the MPR result page. The ImGearMprProcessor class also contains a static ValidatePages() method that could be used to check whether the MPR could be performed on the provided pages collection. The method will throw a corresponding exception if MPR cannot be performed on the provided pages.

The reconstructed view will have the same color space and bit depth as the original images. But the contrast/brightness could differ.


Presentation State
User Guide > How to Work with... > DICOM Images > Presentation State

Presentation State (PS) objects serve the following purposes:

  • Consistent display of images on various devices and media
  • Storage of specific settings for display (contrast transformations, geometric transformations)
  • Storage of annotations
  • Special display of multiframe images

Presentation State objects do not include actual images, but a reference to one or more images.

Presentation State objects, in addition to LUTs, display parameters, and annotations, contain other tags, such as Patient/Study/Series info, Referenced Image UIDs, etc. ImageGear loads all tags from Presentation State object into a metadata tree, which is available to the application.

This section provides information about the following:

  • Consistent Display of Images
  • Grayscale Contrast Transformations
  • Geometric Transformations
  • Annotations
  • Working with Presentation State Objects


Consistent Display of Images
User Guide > How to Work with... > DICOM Images > Presentation State > Consistent Display of Images

The DICOM standard introduces the Standardized Display System. A Standardized Display System may be a printer, a monitor, or some other display device which has been calibrated according to the Grayscale Standard Display Function. The main feature of such display system is that throughout its display range, equal differences in digital input values correspond to visually equal differences in luminosity. Two Standardized Display Systems will always show the same detail in an image, even if their physical characteristics are different.

The values that can be used as input to a Standardized Display System are called "Presentation Values" ("P-Values"). To map image pixel intensities into P-Values, Presentation Look Up Table ("P-LUT") is used. It is applied after Modality and VOI LUTs.

Presentation LUT is stored in a Presentation State DataSet.

If a display device is not physically calibrated to comply with the Standard Display Function, but its characteristic curve (a table that lists luminosities for each digital input value) is known, it can be calibrated at the software level. In that case, P-Values shall be used as input to a Standard Display LUT, which will map them to the device's input values according to Standard Display Function. Thus, a non-standardized device, together with its Standard Display LUT, can be considered as Standardized Display System.

The ImageGear.Formats.DICOM namespace allows you to build a Standard Display LUT from a device's Characteristic Curve.

ImageGear uses all available LUTs (Modality LUT, VOI LUT, Presentation LUT, and Standard Display LUT), to build the Summary LUT that maps image pixel values into display input values.

Presentation LUT and Standard Display LUT, as well as Modality and VOI LUTs are stored in the ImGearDICOMDisplaySettings Class. It can be attached to any ImGearRasterPage Class.


Grayscale Contrast Transformations
User Guide > How to Work with... > DICOM Images > Presentation State > Grayscale Contrast Transformations

A Presentation State DataSet may include VOI and Modality LUTs. Their usage is the same as in normal DICOM images. When a Presentation State is applied to an image, its LUTs override the LUTs found in the image.


Geometric Transformations
User Guide > How to Work with... > DICOM Images > Presentation State > Geometric Transformations

Presentation State DataSet may include Rectangle of Interest, scale mode (True size, Scale to Fit, Magnify), and orientation (Rotate, Flip).


Annotations
User Guide > How to Work with... > DICOM Images > Presentation State > Annotations

Annotation objects include: Textbox, Point, Polyline, Spline, Circle, Ellipse. Graphical objects can be filled or not filled. Annotations can be grouped into layers.

ImageGear for .NET uses ART marks to represent DICOM annotation objects. When a Presentation State DataSet is applied to an image, ImageGear creates ART marks for each of the annotation objects. These marks can then be edited with the ART API methods.

DICOM Graphic Annotation objects can be grouped into Layers. All objects on the same layer have the same color (recommended grayscale value). ImageGear uses ART mark groups to represent layers.

Use PreparePresStateMetadata Method to prepare presentation state metadata from image's display settings and annotation marks. This metadata can be saved as a presentation state object file.

When preparing presentation state from ImGearPage Class that has ART marks attached to it, ART marks are converted to DICOM Graphic Annotation objects or Text Annotation objects. The table below lists ART marks that can be converted, corresponding DICOM Graphic Annotation objects, and properties that Graphic Annotation objects support. Marks that are not listed in this table are ignored.

ImGearARTMarkType Value | DICOM Graphic Annotation Object | Supported Properties
POINT | POINT | Point coordinates
POLYLINE | POLYLINE | Node coordinates, "Filled" property
POLYGON | POLYLINE | Node coordinates, "Filled" property
FILLED_POLYGON | POLYLINE | Node coordinates, "Filled" property
CURVE | INTERPOLATED | Node coordinates, "Filled" property
ELLIPSE | ELLIPSE | Bounds coordinates, "Filled" property
FILLED_ELLIPSE | ELLIPSE | Bounds coordinates, "Filled" property
HOLLOW_ELLIPSE | ELLIPSE | Bounds coordinates, "Filled" property

The following ART marks are saved as DICOM Text Annotation objects:

TEXT | Text, bounds coordinates, anchor point coordinates, anchor point visibility
TYPED_TEXT | Text, bounds coordinates
CALLOUT | Text, bounds coordinates, anchor point coordinates, anchor point visibility

Graphic Annotation objects do not have a color property. Instead, Graphic Layer has "Recommended Display Grayscale Value" property. ImageGear uses the color of the first mark in the ART group as the color for the entire Graphic Layer. If R, G, and B channels of the color of that first mark are equal, ImageGear converts the color to grayscale and uses this value to initialize the "Recommended Display Grayscale Value" property of the layer.
Otherwise, ImageGear initializes the "Recommended Display RGB Value" property of the layer by that color.

There are some aspects of saving/loading of POLYLINE and POLYGON ART marks that should be considered. As the DICOM specification for Presentation State does not define POLYGON Graphic Annotation object, only POLYLINE (see PS 3.3 2008, C.10.5 Graphic Annotation Module), ImageGear saves a POLYGON ART mark as a POLYLINE DICOM Graphic object in the Presentation State metadata. The DICOM Tag "Graphic Filled" (0070,0024) indicates whether the POLYLINE is filled or not. Additionally, it indicates whether a non-filled POLYLINE is closed or not – if it has a "No" value, then the polyline is closed, otherwise, if that Tag is absent at all, then the polyline is opened (see aforementioned DICOM specification).

The saving logic of POLYGON and POLYLINE ART marks is as follows:

ART Annotation to Save | Saved Graphic Filled Tag Value | Saved DICOM Graphical Object
POLYLINE | If IsClosed Property is true, then ImageGear writes this tag with "No" value; otherwise it does not write this tag at all. | POLYLINE
POLYGON | If FillColor Property is not null, ImageGear writes this tag with "Yes" value; otherwise it writes this tag with "No" value. | POLYLINE

The loading logic of a POLYLINE DICOM Graphical object is as follows:

Loaded DICOM Graphical Object | Loaded Graphic Filled Tag Value | Created ART Annotation
POLYLINE | None - absent in the Presentation State metadata. | POLYLINE mark, IsClosed Property is false.
POLYLINE | No | POLYLINE mark, IsClosed Property is true.
POLYLINE | Yes | POLYGON mark, FillColor Property is not null.

See Also
ART 2.0 and ART 3.0 Marks


Working with Presentation State Objects
User Guide > How to Work with... > DICOM Images > Presentation State > Working with Presentation State Objects

Loading and Applying Presentation State Objects

Use ImGearDICOM. LoadPresState Method to load a Presentation State object and apply it to an image.

Extracting and Saving Presentation State Objects

Use these steps to extract and save a presentation state object:

  1. Use ImGearDICOM. PreparePresStateMetadata Method to extract presentation state settings from image and image's display, and to prepare metadata tree for the Presentation State object.
  2. Edit Presentation State metadata if needed.
  3. Use ImGearDICOM. SavePresState Method to save Presentation State metadata as Presentation State object.


Waveform Image Support
User Guide > How to Work with... > DICOM Images > Waveform Image Support

ImageGear for .NET supports both DICOM raster and vector (waveform) images. ImageGear loads DICOM raster pages as ImGearRasterPage Class, and vector images as ImGearVectPage Class.

ImageGear reads and displays waveform data (graphs), as well as axes and some annotations.

Currently, ImageGear creates the following annotations for waveform images:

  • X axis with second marks, according to SamplingFrequency tag value.
  • X axis for every image, if it is visible and does not intersect with other images
  • Y axis for all images.
  • Minimum and maximum waveform values for each graph.


IOD/SOP Class Support
User Guide > How to Work with... > DICOM Images > IOD/SOP Class Support

The IOD (Information Object Definition) and SOP (Service-Object Pair) Class specifications are defined in DICOM standard section PS3.3.

In general, the SOP Class defines what kind of medical information (not Pixel Data) is being stored in the Data Set (metadata tree). So, it defines the set of mandatory DICOM Tags that must be present in the metadata to claim that the file contains some particular SOP Class. This set of Tags defines the Information Object Definition (IOD).

ImageGear always loads the entire metadata tree of the DICOM file without taking into account what kind of SOP Class is actually defined. Any DICOM image can contain either Image Module (that is Pixel Data), or Waveform Sequence (that is Waveform Data), or it can represent a Structured Report (SR), which does not have any pixel or waveform displayable data – it contains only metadata with patient-specific information. All of these are supported by ImageGear.

For more details, see the Waveform Image Support and DICOM Metadata Support sections.

The Pixel Data's compression is determined by the corresponding Transfer Syntax (TransferSyntaxUID (0002,0010) Tag) and does not depend on the SOP class value. See the ImGearDICOMTransferSyntaxes Enumeration section for more details.

ImageGear is able to open a DICOM file with any SOP class as soon as the file's Transfer Syntax is supported. The corresponding SOP class value of the file can be obtained from metadata by looking up the MediaStorageSOPClassUID (0002,0002) Tag.


Using ImageGear.Dicom.Forms Namespace
User Guide > How to Work with... > DICOM Images > Using ImageGear.Dicom.Forms Namespace

The ImageGear.Dicom.Forms namespace provides functionality to support the end user’s interaction and UI for multi-planar reconstruction (MPR). The term “MPR” defines the ability to reconstruct volumes from a set of 2D image data and display multiple 2D planes of data from within the reconstructed data set.

ImageGear allows the following 2D plane views:

  • Axial View - This is a horizontal cut away slice of the body as seen from the top. Most commonly DICOM images are taken in this view.
  • Coronal View - This view is a vertical cut away slice of the body as seen from the front.
  • Sagittal View - This is a vertical cut away slice of the body as seen from its left side.
  • Oblique View - This Oblique view has not a specific definition. It is just a cut away slice of the body taken at some angle to the X axis of the one of the above described views.

Multi-frame DICOM images contain a collection of slices of the body. For example, considering each axial slice represents (X-Y) plane of the body, then a collection of slices will represents Z axis.

In the simplest case, multi-planar reconstruction (MPR) involves generating perspectives at right angles to a stack of axial slices so that coronal and sagittal images can be generated. The described views can be graphically represented as following:

So if we have multi-frame DICOM image that contains F frames of images with (W x H) dimension, then W would be the X axis, H would be the Y axis and F would be the Z axis.

Coronal view could be considered as oblique view with 0 degree rotation angle about Z axis, while sagittal view could be considered as oblique view with 90 degree rotation angle about Z axis.

It is possible to perform MPR not only from multi-frame DICOM images, but also from a collection of single-frame DICOM images with the same width and height.

As each frame of DICOM image is represented as a page in IG, so multi-frame DICOM is represented as a collection of pages, so each page represents a horizontal slice of the axial view or vertical slice of the coronal/sagittal view of the body.

There are 3 classes within ImageGear.Dicom.Forms namespace providing handling of the described views:

  • ImGearMprAxialController
  • ImGearMprCoronalController
  • ImGearMprSagittalController

After providing the initial stack of images for multi-planar reconstruction, each view could be bound to other views to display MPR results. ImGearMprAxialController has following 3 properties: CoronalViews, SagittalViews and ObliqueViews. After adding a CoronalView to the CoronalViews property, the horizontal “MPR line” will be shown over the ImGearAxialView to allow you to perform coronal reconstruction by moving that line over the view.

Similarly, after adding a SagittalView to the SagittalViews property, the vertical “MPR line” will be shown over the ImGearAxialController’s view to allow you to perform sagittal reconstruction by moving that line over the view. For ObliqueView, the 45 degree diagonal “MPR line” will be shown over the ImGearAxialController view to allow you to perform oblique reconstruction by moving and resizing that line over the view.

The MPR is always performed in left to right direction of the “MPR line”. The start point of the line is considered the one that has smaller X coordinate.

You can bind as many views to each property as you need.

To support full MPR, involving reconstruction of all described views, ImageGear.Dicom.Forms has a user control called ImGearMprVisualizer. This control contains 4 views for each of the MPR view and provides you with the possibility to reconstruct each of them by moving “MPR lines” over the original MPR view. The original MPR view is defined by providing stack of images in corresponding view and initializing the ImGearMprVisualizer object by them.


JPEG 2000 Images
User Guide > How to Work with... > JPEG 2000 Images

The ImageGear.Formats.JPEG2K namespace allows you to use the diverse functionality of the JPEG 2000 wavelet-based compression technique. It provides the following advantages:

  • Excellent image quality at high compression ratios
  • Fast compression and decompression
  • Both lossless (guaranteed pixel identity) and lossy image compression options
  • User-controlled compression ratio
  • Quicklook generation and scaled image reconstruction based on embedded coding techniques
  • Elimination of JPEG-like blocking artifacts

All these features outperform all other image compression techniques. JPEG 2000 image compression is best suited for compression either of sensitive images, because of the lossless feature, or for its excellent image quality at high compression ratios for uses such as transmission in low-bandwidth applications.

The ImageGear.Formats.JPEG2K namespace provides support for JPEG 2000 and JPX formats.

The JPEG 2000 standard provides a set of features that take advantage of new technologies, making them important to many high-end and emerging applications. It addresses areas where current standards fail to produce the best quality or performance and provides capabilities to markets that currently do not use compression. The markets and applications better served by the JPEG 2000 standard are Internet, color facsimile, printing, scanning (consumer and pre-press), digital photography, remote sensing, mobile, medical imagery, digital libraries/archives and eCommerce. Each application area imposes some requirements that the standard should fulfill.

The ImageGear JPEG2K namespace allows you to create an imaging application that supports JPEG 2000 Standard Part I (JP2, J2K, JPC) and JPEG 2000 Part II (JPX) image file formats.

  • JPEG 2000 Standard Part I (JP2, J2K, JPC) provides a set of features that are of importance to many high-end and emerging applications by taking advantage of new technologies. It addresses areas where current standards fail to produce the best quality or performance and provides capabilities to markets that currently do not use compression. The markets and applications better served by the JPEG 2000 standard are Internet, color facsimile, printing, scanning (consumer and pre-press), digital photography, remote sensing, mobile, medical imagery, digital libraries/archives and eCommerce. Each application area imposes some requirements that the standard should fulfill.
  • JPEG 2000 Part II (JPX) is an extension to the JPEG 2000 file format. It is provided for the exchange of compressed image files between application environments. Many applications may choose to use this optional file format to contain JPEG 2000 compressed image data. While the JP2 file format provides a method by which applications can interchange image files in such a way that all conforming readers can properly interpret and display the image, some applications require extensions to the JP2 file format that would prevent the file from being properly interpreted by a conforming reader. For example, an image encoded in a CMYK color space will not be properly interpreted by a conforming JP2 reader. To avoid such confusions JPX format is used in applications that require functionality or data structures beyond those defined in the JP2 file format.

To use the support for JPEG 2000 formats as well as efficiently and dynamically stream portions of a JPEG 2000 compressed image over a network, add JPEG 2000 formats to ImageGear's global formats list, as follows:

C#
Copy Code
ImGearFileFormats.Filters.Insert(0, ImGearJPEG2K.CreateJP2Format());
ImGearFileFormats.Filters.Insert(0, ImGearJPEG2K.CreateJPXFormat());

For saving images, refer to the topic Saving JPEG 2000 and JPX Images in Lossless Mode.

For more information about JP2 and JPX formats, visit: http://jpeg.org/jpeg2000/index.html.

This section provides information about the following:

  • JPEG 2000 Images
    • JPEG 2000 Standard Part I (JP2, J2K, JPC)
      • JP2 File Format
    • JPEG 2000 Part II (JPX)
      • JPX File Format
    • Saving JPEG 2000 and JPX Images in Lossless Mode


JPEG 2000 Standard Part I (JP2, J2K, JPC)
User Guide > How to Work with... > JPEG 2000 Images > JPEG 2000 Standard Part I (JP2, J2K, JPC)

The ImageGear.Formats.JPEG2K Namespace allows you to utilize the wide functionality of the JPEG 2000 standard Part 1 (ISO/IEC 15444-1).

It provides the following advantages:

  • The ability to read/write JPEG 2000 codestream and JP2 format. Also see the FileFormat control parameter.
  • Excellent image quality at high compression rates. A major difference between JPEG 2000 and the well known JPEG (Joint Photographic Experts Group) technique is the use of the analyzing method. While JPEG uses the Discrete Cosine Transform, JPEG 2000 uses a special Discrete Wavelet Transform, which results in improved image quality. The Discrete Wavelet Analysis is performed over the whole image without partitioning it into many different tiles. The reconstructed image does not contain blocking artifacts corresponding to these initial tiles even at high compression rates. Refer to the Discrete Wavelet Transform (DWT), WaveletFilter, and WaveletLevels control parameters.
  • Choice of lossless and lossy image compression. The analyzing wavelet filter operation allows a lossless compression at low compression rates and a lossy compression at higher rates. The lossless compression is the lowest possible compression rate. The JPEG 2000 compression is very efficient, and out-performs comparable lossless image compression techniques like LZW and TIFF.
  • User controlled output lossy compression rate. The image to be stored may be compressed to a pre-determined rate or to achieve a desired quality. If set for a pre-determined compression rate, the size of the resulting JPEG 2000 file will meet the rate exactly. While using other compression techniques, the size of a compressed file depends on the image contents and differs over a wide range. The different progression orders available in a JPEG 2000 compressed file allows for size-dependent compression control. Of course, you may also compress an image with the control set for a desired quality. In addition to compression rate, this component allows you to set a different number of quality layers. Also see the RateBytes control parameter.
  • Support of different image types. The JPEG2K Component supports the following image types and bit depths: palette-based (1-, 4- , 8-bit depths), grayscale (8-, 16-bit depths), truecolor (24-bit depth) and CMYK (32-bit depth).
  • User-controlled opacity and transparency information (alpha channel transparency). The ImageGear JPEG2K component allows you to store and load alpha channel transparency for all color channels. Loading and saving of additional alpha channels can be performed using core ImageGear functionality. Also see AlphaChannels.
  • User controlled reading/writing of JPEG 2000 format metadata (XML and IPR). Non-image information (XML and IPR) does not affect the decoding or visual appearance of the image itself. Also see JPEG 2000 Part I (JP2) Metadata Tags and Non-image Dataset Structure for JPEG2K as well as "XML" and "IPR".
  • Quicklook generation and scaled image reconstruction based on embedded coding techniques. The resolution progression feature of the compressed JPEG 2000 data is best suited to perform a scaled reconstruction. The reconstruction process can be interrupted at any time and the partly processed data contains information of the full-size image. The reconstructed image appears in the appropriate quality corresponding to the processed amount of image data. If the image is reconstructed only for quicklook purposes, the best quality is not necessary because it is displayed at a fraction of the original image size. Using the ImageGear JPEG2K component, the quality and size of the reconstructed image can be scaled. This reconstructed image may be shown clearly because critical image information is located at the beginning of the compressed file, and remaining data follows in the order of detail. Also see the DiscardLevels and Mode control parameters.

These features outperform all other image compression techniques. JPEG 2000 image compression is suited well for sensitive image compressions (because of the lossless feature), or for its excellent image quality at high compression ratios for uses such as transmission in low bandwidth applications.

This section provides information about the following:

  • JPEG 2000 Standard Part I (JP2, J2K, JPC)
    • JP2 File Format


JP2 File Format
User Guide > How to Work with... > JPEG 2000 Images > JPEG 2000 Standard Part I (JP2, J2K, JPC) > JP2 File Format

To enable JP2 file format in your project, add a reference to ImageGear22.Formats.Jpeg2k Assembly. Specify this directive:

C#
Copy Code
using ImageGear.Formats.JPEG2K;

and use this API:

C#
Copy Code
ImGearFileFormats.Filters.Add( ImGearJPEG2K.CreateJP2Format());

See the JPEG 2000 section of the File Formats Reference for a list of bit depths and color spaces supported for reading and writing.


JPEG 2000 Part II (JPX)
User Guide > How to Work with... > JPEG 2000 Images > JPEG 2000 Part II (JPX)

JPEG 2000 Part II (JPX) defines a file architecture rather than a specific, fixed set of data structures that will be found in a file. The ImageGear.Formats.JPEG2K Namespace provides you with the support of the following important JPX features:

  • CMYK support. JPX CMYK image is saved such that any other JPX software is able to read the image as CMYK.
  • Multipage support. ImageGear JPEG2K namespace allows you to read/write multipage JPX documents with many compositing layers. You also may add new pages to the end of already existing pages in the multipage file.
  • Separate codestreams support. Each JPX transparency channel can be separated from the color channels and can be written as single codestream. This feature is very useful, if we have multipage JPX document and want to set one transparency channel for all pages. In this case, it is possible to save this transparency channel as a separate codestream and then add a pointer to this codestream to all pages. This ability allows you to significantly reduce the size of the output multipage JPX document.
  • Chroma-key opacity support. This JPX feature allows you to specify the color value of every transparent pixel.
  • User controlled reading/writing of JPEG 2000 format metadata (XML and IPR). Non-image information (XML and IPR) does not affect the decoding or visual appearance of the image itself. Also see JPEG 2000 Part II (JPX) Metadata Tags and Non-image Dataset Structure for JPX as well as "XML" and "IPR".

This section provides information about the following:

  • JPEG 2000 Part II (JPX)
    • JPX File Format


JPX File Format
User Guide > How to Work with... > JPEG 2000 Images > JPEG 2000 Part II (JPX) > JPX File Format

To enable JPX file format in your project, add a reference to ImageGear22.Formats.Jpeg2k Assembly. Specify this directive:

C#
Copy Code
using ImageGear.Formats.JPEG2K;

and use this API:

C#
Copy Code
ImGearFileFormats.Filters.Add( ImGearJPEG2K.CreateJPXFormat());

See the JPX section of the File Formats Reference for a list of bit depths and color spaces supported for reading and writing.


Saving JPEG 2000 and JPX Images in Lossless Mode
User Guide > How to Work with... > JPEG 2000 Images > Saving JPEG 2000 and JPX Images in Lossless Mode

Lossless compression is used in sensitive applications, such as legal or medical. Lossless compression provides lower compression rates than even the maximum quality lossy compression. However, JPEG 2000 lossless compression outperforms comparable lossless image compression techniques like LZW and TIFF. The format also allows storing several quality levels in an image, and in particular, using lossy compression for the lower quality levels and lossless compression for the highest quality layer.

The following actions are necessary to save a lossless JPEG 2000 or JPX image:

  • Set WaveLetFilter control parameter to ImGearJPEG2KFilters.REVERSIBLE to use the reversible color transform.
  • Specify the maximum compression quality, by one of the following:
    • Set RateBytes control parameter to 0, and QualityLayers control parameter set to default value, or
    • Use the QualityLayers control parameter, and set the last entry in the array passed to it to 0.0. This results in an image where the first several layers are lossy, and the last layer is lossless.
If the maximum compression quality is used, the value of QuantizationStep parameter is ignored, as no quantization takes place.

See JPEG 2000 and JPX file format descriptions for details on the control parameters mentioned above.


Office Formats
User Guide > How to Work with... > Office Formats

Office Open XML (also informally known as OOXML or OpenXML) is a zipped, XML-based file format developed by Microsoft for representing spreadsheets, charts, presentations and word processing documents. The Office Open XML specification was initially standardized by ECMA (as ECMA-376) and later by ISO and IEC (as ISO/IEC 29500).

The new formats improve file and data management, data recovery, and interoperability with line-of-business systems. They extend what is possible with the binary files of earlier versions. Any application that supports XML can access and work with data in the new file format. The application does not need to be part of the Microsoft Office system or even a Microsoft product. Users can also use standard transformations to extract or repurpose the data. In addition, security concerns are drastically reduced because the information is stored in XML, which is essentially plain text. Thus, the data can pass through corporate firewalls without hindrance.

The ImageGear.Formats.Office Namespace allows you to load and display WordprocessingML and SpreadsheetML documents. To enable it in your project, specify the following directive:

C# Example
Copy Code
using ImageGear.Formats.Office;
VB.NET Example
Copy Code
Imports ImageGear.Formats.Office

This section provides information about the following:

  • Office Formats
    • Working with Word Documents
      • WordprocessingML Groups Supported by ImageGear
        • Paragraph
        • Run
        • Tables
        • Numbering
        • Fields and Hyperlinks
        • Sections
        • Styles
        • Drawing
        • Headers and Footers
        • Alternate Content
        • Text Frames
      • Extracting Text from Word Documents
    • Working with Excel Documents
      • Walkthrough: Loading Excel Documents
      • SpreadsheetML Groups Supported by ImageGear
        • Workbook
        • Worksheets
        • Shared String Table
        • Styles
        • Headers and Footers
    • Working with PowerPoint Documents
      • Walkthrough: Loading PowerPoint Documents
      • PresentationML Groups Supported by ImageGear
        • Presentations
        • Slides
        • Styles


Working with Word Documents
User Guide > How to Work with... > Office Formats > Working with Word Documents

Displaying Word Documents

The ImGearWordDocument can be created and processed in any thread with any apartment state: STA or MTA. If it also needs to be displayed, then there are some concepts which should be taken into account:

  • In WPF display scale mode the document must be created in the UI thread, otherwise a System.InvalidOperationException will be thrown, stating that "The calling thread cannot access this object because a different thread owns it”. This is requirement of Windows Presentation Foundation.
  • In Native display scale mode, which is the default for ImageGear, there are no restrictions for displaying Word pages in a multithreaded environment.

Additional Information

The following topics are covered in this section:

  • Working with Word Documents
    • WordprocessingML Groups Supported by ImageGear
      • Paragraph
      • Run
      • Tables
      • Numbering
      • Fields and Hyperlinks
      • Sections
      • Styles
      • Drawing
      • Headers and Footers
      • Alternate Content
      • Text Frames
    • Extracting Text from Word Documents

Below are the groups of the Open XML WordprocessingML, which ImageGear supports (read only):

  • Paragraph
  • Run
  • Tables
  • Numbering
  • Fields and Hyperlinks
  • Sections
  • Styles
  • Drawing

ImageGear renders only accepted revision changes of the document; i.e., if it has "Track Changes" enabled, please make sure to accept all/required changes in the document prior to opening it with ImageGear.


WordprocessingML Groups Supported by ImageGear
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear

ImageGear Office Assembly uses the WPF engine for displaying Open XML WordprocessingML elements. Since WPF has limited support of WordprocessingML groups/elements, ImageGear does not provide full support of ECMA-376, Second Edition specification. Brief descriptions of the features are from the ECMA specification.

Below are the groups of the Open XML WordprocessingML that ImageGear supports (read only):

  • WordprocessingML Groups Supported by ImageGear
    • Paragraph
    • Run
    • Tables
    • Numbering
    • Fields and Hyperlinks
    • Sections
    • Styles
    • Drawing
    • Headers and Footers
    • Alternate Content
    • Text Frames


Paragraph
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Paragraph

Paragraph is the most basic unit of block-level content within a WordprocessingML document. It defines a distinct division of content with a WordprocessingML document which begins on a new line. Below is the table of Paragraph’s features, supported by ImageGear:

Feature

Description

Comment

Borders

This element specifies a set of borders around the paragraph.

ImageGear supports almost all Open XML border styles, except the following:

  • Art borders
  • Borders that require 3 parallel lines or 3D rendering

Indentation

This element specifies a set of indentation properties applied to the current paragraph.

Fully supported.

Horizontal text alignment

This element specifies the paragraph alignment which shall be applied to text in this paragraph.

Supported alignments are:

  • Left
  • Center
  • Right
  • Justify

Vertical text alignment

This element specifies the vertical alignment of all text on each line displayed within a paragraph. If the line
height (before any added spacing) is larger than one or more characters on the line, all characters are aligned to
each other as specified by this element.

Supported alignments are:

  • Top
  • Center
  • Bottom
  • Baseline

Shading

This element specifies the shading applied to the contents of the paragraph.
This shading consists of three components:

  • Background Color
  • (optional) Pattern
  • (optional) Pattern Color

The resulting shading is applied by setting the background color behind the paragraph, then applying the pattern color using the mask supplied by the pattern over that background.

If Pattern of the shading is specified, ImageGear supports only clear and solid types of the Pattern, i.e. no any percentage or style (stripe, cross, diagonal…) in the pattern.

Text flow direction

This element specifies the direction of the text flow for this paragraph.

ImageGear supports only left-to-right and right-to-left directions. But WordprocessingML allows also setting e.g. bottom-to-top flow.
NOTE: for example, rotated text (e.g. vertical one) is not supported.

Spacing between lines and paragraphs

This element specifies the inter-line and inter-paragraph spacing which shall be applied to the contents of this
Paragraph when it is displayed by a consumer.

Fully supported, if explicit spacing before/after paragraph is specified. Otherwise, if that parameter is “Auto”, which according to ECMA specification:

Specifies whether a consumer shall automatically determine the spacing before/after this
paragraph based on its contents.
This automatic spacing shall match the spacing which would be applied to the paragraph
in an HTML document where no explicit spacing before/after is specified.

In such case ImageGear will try to set appropriate spacing between paragraphs, but in some cases displayed text can slightly differ from some other WordprocessingML viewers (e.g. Microsoft Word).


Run
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Run

The next level of the document hierarchy is the Run, which defines a region of text with a common set of
properties. Below is the table of Run’s features, supported by ImageGear:

Feature

Description

Comment

Font Family

This element specifies the fonts which shall be used to display the text contents of this run.

Supported True Type fonts only.

Font Size

This element specifies the font size which shall be applied to all characters in the contents of
this run when displayed.

Fully supported.

Font Style

Supported styles are:

  • Bold
  • Italic
  • Underline
  • Strikethrough
  • Subscript
  • Superscript
  • All Capitals
  • All Small Caps

For Underline ImageGear supports following styles of the underline:

  • Single
  • Thick
  • Dotted
  • Dotted Heavy
  • Dashed
  • Dashed Heavy
  • Dash Long
  • Dash Long Heavy
  • Dot Dash
  • Dot Dash Heavy
  • Dot Dot Dash
  • Dot Dot Dash Heavy

For example, ImageGear does not support Double or Wave style underlines. Any unsupported underline ImageGear will display as a Single one.

Font Highlight

This element specifies a highlighting color which is applied as a background behind the contents of this run.

Fully supported.

Font Color

This element specifies the color which shall be used to display the contents of this run in the document.

Fully supported.

Hidden Text

This element specifies whether the contents of this run shall be hidden from display at display time in a document.

Fully supported.

ImageGear uses Microsoft WPF for rendering fonts. For some particular font families, WPF may fail to load the correct typeface, although the specified font is present on the system - this is a known issue that has not yet been addressed. Due to this, the content displayed by ImageGear (font family/style, text layout, line spacing, etc.) may differ from the content displayed by Microsoft Office.


Tables
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Tables

Another form of block-level content in WordprocessingML, a Table is a set of paragraphs (and other block-level content) arranged in rows and columns. Below is the table of Table’s features, supported by ImageGear:

Feature

Description

Comment

Table Borders

This element specifies the set of borders for the edges of the current table, using the six border types defined by its child elements.

The same as for paragraph borders.

Table Cell Borders

This element specifies the set of borders for the edges of the current table cell, using the eight border types
defined by its child elements.

The same as for Paragraph borders.
Also, diagonal cell borders are not supported.

Table Indentation

This element specifies the indentation which shall be added before the leading edge of the current table in the
document (the left edge in a left-to-right table, and the right edge in a right-to-left table). This indentation should shift the table into the text margin by the specified amount.

Fully supported.

Table Shading

This element specifies the shading applied to the contents of the paragraph.
This shading consists of three components:

  • Background Color
  • (optional) Pattern
  • (optional) Pattern Color

The resulting shading is applied by setting the background color behind the paragraph, then applying the pattern color using the mask supplied by the pattern over that background.

If Pattern of the shading is specified, ImageGear supports only clear and solid types of the Pattern, i.e. no any percentage or style (stripe, cross, diagonal…) in the pattern.

Table Cell Margin

This element specifies the default cell margin settings for all cells in the current table.

Fully supported.

Table Cell Spacing

This element specifies the default table cell spacing (the spacing between adjacent cells and the edges of the table) for all cells in the parent table.

Fully supported.

Table Cell/Row Conditional Formatting

This element specifies the set of conditional table style formatting properties which have been applied to this table row/cell.

Conditional formatting applies referenced Run, Paragraph, Table Cell and Table Row styles/properties to the current cell/row. For more information see ECMA-376, Second Edition specification.

Limited support due to limitations in Run, Paragraph and Table processing.


Numbering
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Numbering

Numbering refers to symbols - Arabic numerals, Roman numerals, symbol characters ("bullets"), text strings, etc. - in WordprocessingML that are used to label individual paragraphs of text. Below is the table of Numbering’s features, supported by ImageGear:

Feature

Description

Comment

Numbering Format

This element specifies the number format which shall be used to display all numbering at this level in the Numbering definition.

Supported numbering symbols are:
Bulleted symbols:

  • Bullet (filled circle)
  • Circle (hollow circle)
  • Box (filled square)
  • Square (hollow square)

Numbered symbols:

  • Decimal
  • Lower Letter
  • Upper Letter
  • Lower Roman
  • Upper Roman

Any unsupported Numbering symbol (such as a picture or non-English letter) ImageGear will display as a Bullet (filled circle).

Justification

This element specifies the type of justification used on a numbering level's text within a given numbering level.
This justification is applied relative to the text margin of the parent numbered paragraph in the document.

Fully supported.

Paragraph Style's Associated Numbering Level

Besides ordinary bulleted or numbered lists, WordprocessingML Numbering specifies also set of properties, used for numbering of the paragraphs – for example, heading paragraphs. Here is an example:

1 Chapter 1

1.1 Subchapter 1

Some text.

2 Chapter 2

2.1 Subchapter 2

Some text.

Support is limited due to numbering symbols limitation of the WPF – see Numbered symbols of the Numbering Format feature.


Fields and Hyperlinks
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Fields and Hyperlinks

A Field is a set of codes that instructs a WordprocessingML consumer to insert text, graphics, page numbers, and other material into a document automatically. Field definitions can be found in the ECMA-376, Second Edition specification, file “ECMA-376, Second Edition, Part 1 - Fundamentals and Markup Language Reference.pdf”, chapter 17.16.5 “Field definitions”. Below is the table of Field definitions, supported by ImageGear:

Field | Description | Comment
HYPERLINK | When selected, causes control to jump to the specified location. That location can be a bookmark or a URL. | ImageGear only renders the hyperlink accordingly. Jump to the link’s location is not supported yet.
DATE | The current date and time. | Supported calendar: Gregorian. Supported culture: English-US (Invariant).
FILESIZE | The size of the WordprocessingML package in bytes, or the empty string if the size of the package cannot be determined when a field update is performed. | Fully supported.
FORMCHECKBOX | Inserts a check box style form field, can be checked and unchecked. | ImageGear only renders the checkbox accordingly with initial check state. Checking/unchecking functionality is not supported yet.
FORMDROPDOWN | Inserts a drop-down list style form field, can be used to select an entry in the list. | ImageGear only renders the drop-down list accordingly with the specified item in list selected. Entry selection functionality is not supported yet.
FORMTEXT | Inserts a text box style form field, can be typed into. | ImageGear only renders the text box accordingly. Typing functionality is not supported yet.
TIME | The current date and time. | Supported calendar: Gregorian. Supported culture: English-US (Invariant).
TOC | Builds a table of contents using the entries specified by TC fields, their heading levels, and specified styles, and inserts that table at this place in the Document. Each table entry is a separate paragraph. | ImageGear only renders the TOC entries accordingly. Jumping to the link's location is not supported yet.


Sections
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Sections

WordprocessingML does not natively store the concept of pages, since it is based on paragraphs and runs (which are laid out on to pages by consumers of this content). However, although there is no concept of storing pages in the WordprocessingML format, it is often necessary to store information about a page or group of pages in a document, in order to store information that is to be used to format the pages on which a set of paragraphs appear. In WordprocessingML, this information is stored via the use of sections.

In WordprocessingML, sections are groupings of paragraphs that have a specific set of properties used to define the pages on which the text appears, as well as other section-level (applying to all paragraphs' appearance) properties.

From paragraph level section properties ImageGear supports:

  • Text flow direction
  • Vertical text alignment

From document level section properties (the last section properties in WordprocessingML package) ImageGear supports:

  • Default tab stop size
ImageGear currently supports left-aligned tab stops only. Center- and right-aligned tab stops will be supported in future releases.
  • Page size


Styles
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Styles

Within a WordprocessingML file, styles are predefined sets of table, numbering, paragraph, and/or character properties which can be applied to text within the document. This allows the formatting properties to be stored and managed independently from the content, allowing the look of document content to be changed in a single location (e.g. the look of all first-level headings is changed by changing the style with style Id Heading1 rather than looking for and changing each paragraph in the document).

ImageGear supports following properties of the Style:

  • Style Inheritance
  • Style Hierarchy
  • Toggle Properties
  • General Style Properties
  • Document Defaults
  • Table Styles
  • Numbering Styles
  • Paragraph Styles
  • Run (Character) Styles


Drawing
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Drawing

The DrawingML Main namespace of the Office Open XML defines all of the base constructs for all kinds of DrawingML objects (charts, diagrams, shapes, pictures, and so on). Within a WordprocessingML document, it is possible to include graphical DrawingML objects:

  • Pictures
  • Locked Canvases
  • Diagrams
  • Charts
VML (Vector Markup Language) is a format deprecated by ECMA OpenXML Specification. However, it is in use for drawing by Microsoft Word and ImageGear supports VML drawing too. VML drawing objects may be located in the VML groups. ImageGear supports such groups with any nested level.

The following objects are supported by ImageGear:

Object

Supported Types

Comment

Picture

Embedded picture

ImageGear supports only embedded into WordprocessingML package images – no any external links.

Line

Following line types are supported:

  • Line
  • Arrow
  • Double Arrow
  • Elbow Connector
  • Elbow Arrow Connector
  • Elbow Double Arrow Connector

Basic Shape

Following basic Shapes are supported:

  • Text Box
  • Rectangle
  • Parallelogram
  • Trapezoid
  • Diamond
  • Rounded Rectangle
  • Octagon
  • Isosceles Triangle
  • Right Triangle
  • Oval
  • Hexagon
  • Cross
  • Regular Pentagon
  • Lightning Bolt

Currently ImageGear doesn't support curves and composite path segments for the drawing - the shape is drawn with cut corner instead of the folded corner.

Block Arrow

Following Block Arrows are supported:

  • Right Arrow
  • Left Arrow
  • Down Arrow
  • Up Arrow
  • Left-Right Arrow
  • Up-Down Arrow
  • Quad Arrow
  • Left-Right-Up Arrow
  • Left-Up Arrow
  • Bent-Up Arrow
  • Notched Right Arrow
  • Pentagon
  • Chevron
  • Right Arrow Callout
  • Down Arrow Callout
  • Left Arrow Callout
  • Up Arrow Callout
  • Left Right Arrow Callout
  • Quad Arrow Callout

The following arrow styles are supported:

  • Begin style: arrow, open arrow, oval arrow.
  • End style: arrow, open arrow, oval arrow.

The diamond arrow style is drawn as oval arrow style.

Flow Chart

Following Flow Charts are supported:

  • Process
  • Decision
  • Data
  • Preparation
  • Manual Input
  • Manual Operation
  • Off-page connector
  • Card
  • Collate
  • Extract
  • Merge

Stars and Banners

Following Stars and Banners are supported:

  • Explosion 1
  • Explosion 2
  • 4-Point Star
  • 5-Point Star
  • 8-Point Star
  • 16-Point Star
  • 24-Point Star
  • 32-Point Star

ImageGear supports Solid, Linear Gradient and Radial Gradient fills for Drawing Shapes. For Gradients, there are a few limitations that should be considered:

  • For Linear Gradients - ImageGear does not support arbitrary angle of the Gradient; it will be rendered either vertically or horizontally.
  • For Radial Gradients - ImageGear does not support adjustment of the Gradient according to the shape’s outline. For example, Microsoft Word adjusts the Radial Gradient to repeat the outline of the shape: e.g. for rectangular shapes it becomes rectangular, for star-like shapes it becomes star-like. ImageGear renders Radial Gradients in the traditional way – circularly for any shape.
The Word ML objects not listed in the table above will not be rendered by ImageGear. Those objects might be added in a future release.

Positioning of Drawing Objects

Within a WordprocessingML document, drawing objects can exist in two states:

  • Inline - The drawing object is in line with the text, and affects the line height and layout of its line (like a character glyph of similar size).
  • Floating - The drawing object is anchored within the text, but can be absolutely positioned in the document relative to the page.

ImageGear supports both states. For inline drawings there are no issues, but for floating objects there are few limitations that should be considered:

Horizontal positioning:

ImageGear supports all "relative to"/"to the right of" objects, except "Inside Margin" and "Outside Margin".

Vertical positioning:

ImageGear supports all "relative to"/"below" objects, except "Inside Margin" and "Outside Margin". Additionally, if the absolute positioning is below Paragraph or below Line, only positive values are supported for position value. Negative values will lead to incorrect layout of the page. In this case, adjust the anchor of the drawing object to avoid a negative value.

Supported Wrapping styles:

  • In line with text
  • Square
  • Top and bottom
  • Behind text
  • In front of text
Tight and Through wrap styles will be treated as a Square.


Headers and Footers
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Headers and Footers

Headers and footers refer to text, graphics or data (such as page number, date, document title, and so on) that can appear at the top or bottom of each page in a WordprocessingML document.

A header appears in the top margin (above the main document content on the page), while a footer appears in the bottom margin of a document page (below the main document content on the page).

Since WordprocessingML is a flow-based format, headers and footers are applied by specifying the headers and footers for all pages in a particular section of a document.

Within each section of a document there can be up to three different types of headers and footers:

  • First page header/footer - specify a unique header or footer which shall appear on the first page of a section.
  • Odd page header/footer - specify a unique header and footer which shall appear on all odd numbered pages for a given section.
  • Even page header/footer - specify a unique header and footer which shall appear on all even numbered pages in a given section.

ImageGear supports any content within Headers/Footers that is supported for regular document body.


Alternate Content
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Alternate Content

Office Open XML defines a mechanism for the storage of content which is not defined by ECMA-376, for example, extensions developed by future software applications which leverage the Office Open XML formats. This mechanism allows for the storage of a series of alternative representations of content, of which the consuming application should use the first alternative whose requirements are met.

Alternate Content has two XML sub-trees: Choice and Fallback. Choice tree usually has some custom, not defined by ECMA-376 content, while Fallback tree contains standard WordprocessingML elements. So, ImageGear considers Fallback sub-tree only.


Text Frames
User Guide > How to Work with... > Office Formats > Working with Word Documents > WordprocessingML Groups Supported by ImageGear > Text Frames

Text frames are paragraphs of text in a document that are positioned in a separate region or frame in the document, and can be positioned with a specific size and position relative to non-frame paragraphs, page, or margins in the current document.

  • Horizontal and Vertical positioning: ImageGear supports all position kinds and "Relative To" objects.
  • Supported wrapping styles: ImageGear supports both wrapping styles – None and Around.


Extracting Text from Word Documents
User Guide > How to Work with... > Office Formats > Working with Word Documents > Extracting Text from Word Documents

ImageGear Office Assembly provides API for plain text extraction from a Word document; ImGearWordDocument.ExtractText allows text extraction from the following Word page areas:

  • Regular body
  • Header
  • Footer

Using ImGearWordTextExtractionOptions, it is possible to specify the area from which the text should be extracted. By default, ImageGear extracts the text from all areas mentioned above. The order of extraction is as follows:

  • Extract body
  • Extract header
  • Extract footer

For a multi-page document, each type of header and footer will be extracted just once - at the end of the file.

The ImGearWordTextExtractionMethod specifies how the text should be extracted. By default, ImageGear uses paragraph break order, i.e., extracts words in the native order they appear in the Word file (does not consider their coordinates on the page). Line break order extracts words according to their coordinates on the page.

The ImGearWordTextExtractionOptions.Encoding property specifies encoding to be used upon extraction. By default, ImageGear uses UTF-8 encoding that is native for OpenXML package.

The ImGearWordLineEndingType specifies what character sequence should be used to insert line breaks in the output stream. By default, ImageGear uses ImGearWordLineEndingType.CRLF sequence.

  • Graphical content (including text boxes and shapes with text) will not be extracted.
  • Non-textual Numbering bullets will be extracted as '*' character, and hollow ellipse bullets will be extracted as 'o' character. The indentation between numbering bullet/character and paragraph text will be replaced by white space in paragraph break order, and by tabulation character '\t' in line-break order.


Working with Excel Documents
User Guide > How to Work with... > Office Formats > Working with Excel Documents

Displaying Excel Documents

The ImGearExcelBookDocument and ImGearExcelSheetDocument objects can be created and processed in any thread with any apartment state: STA or MTA. If they also need to be displayed, then there are some concepts which should be taken into account:

  • In WPF display scale mode the calling thread must use the STA apartment state, which is a requirement of Windows Presentation Foundation. ImageGear will create a WPF Canvas in the context of this calling thread to render the document pages for display.
  • In Native display scale mode, which is the default for ImageGear, there are no restrictions for displaying Excel pages in a multithreaded environment.

Additional Information

The following topics are also covered in this section:

  • Walkthrough: Loading Excel Documents
  • SpreadsheetML Groups supported by the ImageGear Office Assembly

Below are the groups of the Open XML SpreadsheetML, which ImageGear supports (read only):

  • Workbook
  • Worksheets
  • Shared String Table
  • Styles

At a high level, the following SpreadsheetML features are not currently supported.

Excel files containing these features can still be loaded by ImageGear. However, the unsupported content will be ignored.

ImageGear renders only accepted revision changes of the document; i.e., if it has "Track Changes" enabled, please make sure to accept all/required changes in the document prior to opening it with ImageGear.

  • Formulas (The last cached value will be displayed, if available)
  • Table Definitions
  • Pivot Tables
  • Query Tables
  • Chartsheets
  • Dialogsheets
  • External Data Connections
  • Supplementary Data Connections
  • Custom XML Mappings

More information can be found about all of the above SpreadsheetML features in the ECMA-376 Specification.


Walkthrough: Loading Excel Documents
User Guide > How to Work with... > Office Formats > Working with Excel Documents > Walkthrough: Loading Excel Documents

Loading Excel Documents

The process for loading Excel documents with ImageGear is very similar to that of other document formats. The following steps will enable you to view the first page of a worksheet in an Excel document.

Step 1

Add the Excel format to the list of file format filters ImageGear will use to detect formats of loaded content.

C# Example
Copy Code
// Add support for Excel files
ImGearFileFormats.Filters.Add(ImGearOffice.CreateExcelFormat());
VB.NET Example
Copy Code
' Add support for Excel files
ImGearFileFormats.Filters.Add(ImGearOffice.CreateExcelFormat())

Step 2

Once the desired Excel file has been opened into a System.IO.Stream, the document can be loaded with the LoadDocument method. The startPageNumber and count parameters of the LoadDocument method can be used to load a select few or all of the sheets in the Excel document. The example below will load all available sheets.

The GetPageCount method can be used to get the number of sheets in a Stream that contains a valid Excel document.

ImageGear only supports the popular worksheet sheet type currently. For any other sheet type encountered, like chartsheet and dialogsheet, a blank 8.5” x 11” page will be returned.
C# Example
Copy Code
ImGearDocument imGearDocument = ImGearFileFormats.LoadDocument(fileContent, 0, -1);
VB.NET Example
Copy Code
Dim imGearDocument As ImGearDocument = ImGearFileFormats.LoadDocument(fileContent, 0, -1)

Step 3

Once the document is loaded, the top-level ImGearExcelBookDocument will contain pages, with each one representing an entire sheet. Retrieve one of the pages to access a sheet in the Excel document that can be displayed or printed as a single page or paginated further with a different page size. The following example paginates the worksheet into pages whose size is determined by that which is defined in the original Excel document. Alternatively, a custom size can be defined for the new pages simply by setting the width and height parameters of the Repaginate method accordingly.

Use caution when displaying or printing a sheet as a single page. Because of the large sizes that are possible with Excel sheets, it’s possible that the memory necessary to render the page will exceed the resources of the system. In general, sheets with less than 20,000 cells are safe for rendering as a single page on a modern system. Though keep in mind, the larger the sheet the more time that will be needed to render the page. It is recommended that the paginated ImGearExcelSheetPage objects be used for displaying or printing by default unless the size of the worksheets are known.
C# Example
Copy Code
if (imGearDocument is ImGearExcelBookDocument)
{
    if (imGearExcelBookDocument.Pages.Count > 0)
    {
        currSheetNumber = 0;
        ImGearExcelBookPage imGearBookPage = (ImGearExcelBookPage)imGearExcelBookDocument.Pages[currSheetNumber];
        imGearDocument = imGearBookPage.Repaginate(0, 0);
    }
}
VB.NET Example
Copy Code
If (TypeOf imGearDocument Is ImGearExcelBookDocument) Then
    If imGearExcelBookDocument.Pages.Count > 0 Then
        currSheetNumber = 0
        Dim imGearBookPage As ImGearExcelBookPage = DirectCast(imGearExcelBookDocument.Pages(Me.currSheetNumber), ImGearExcelBookPage)
        imGearDocument = imGearBookPage.Repaginate(0, 0)
    End If
End If

Step 4

Displaying the first one of the pages you created for the sheet is easy using ImageGear’s PageView control. Simply create the control and set the Page property to that of the Excel page. Refer to the Displaying Images topic for more information on displaying images with ImageGear.

C# Example
Copy Code
imGearPageView.Page = imGearDocument.Pages[0];
imGearPageView.Update();
VB.NET Example
Copy Code
imGearPageView.Page = imGearDocument.Pages(0)
imGearPageView.Update()


SpreadsheetML Groups Supported by ImageGear
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear

The ImageGear Office Assembly uses the WPF engine for displaying Open XML SpreadsheetML elements. Since WPF has limited support for SpreadsheetML groups and elements, ImageGear does not fully support the ECMA-376, Second Edition specification. Brief descriptions of the features are from the ECMA specification.

Below are the groups of the Open XML SpreadsheetML that ImageGear supports (read only):

  • SpreadsheetML Groups Supported by ImageGear
    • Workbook
    • Worksheets
    • Shared String Table
    • Styles
    • Headers and Footers


Workbook
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear > Workbook

The workbook is the central structure within a SpreadsheetML package. The workbook provides access to the worksheets, which contain the cells that provide the text, numbers, dates and other content. The workbook part and corresponding properties comprise data used to set application and workbook-level operational state.

Many workbook-level properties describe characteristics more suitable for a spreadsheet application that support editing. As a read-only viewer, ImageGear supports a limited subset of the features in the workbook part. These features are described below.

Feature | Description | Comment
Sheets | This element represents the collection of sheets in the workbook. There are different types of sheets you can create in SpreadsheetML. The most common sheet type is a worksheet; also called a spreadsheet. A worksheet is the primary document that you use in SpreadsheetML to store and work with data. A worksheet consists of cells that are organized into columns and rows. | ImageGear only supports the worksheet sheet type. For other types such as chartsheets and dialogsheets, the content is ignored and a blank 8.5” x 11” page will be created in its place.
Date Compatibility | This attribute, which is part of the Workbook Properties element, specifies whether the date base should be treated as a compatibility date base or should support the full ISO 8601 date range. | Both the compatibility date base and IS0 8601 date range are supported.
Date 1904 | This attribute, which is part of the Workbook Properties element, indicates whether to use a 1900 or 1904 date base when converting serial values in the workbook to date. | Both 1900 and 1904 date bases are supported.


Worksheets
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear > Worksheets

Sheets are the fundamental parts within a workbook, and are where the user does most of their spreadsheet work. The most common type of sheet is the worksheet, which is represented as a grid of cells. Worksheet cells can contain text, numbers, dates and formulas. Cells can be formatted as well.

For the other sheet types such as chartsheets and dialogsheets, the content is ignored and a blank 8.5” x 11” page will be created in its place.

Feature

Description

Comment

Row

This element expresses information about an entire row of a worksheet, and contains all cell definitions for a particular row in the worksheet.

The following row attributes are supported:

  • Custom Format
  • Row Height
  • Row Index
  • Style Index

ImageGear does not support the outline feature, which enables the user to collapse and expand one or more rows in the application.

Cell

This element represents a cell in the worksheet. Information about the cell’s location (reference), value, data type, formatting, and formula is expressed here.

The cell element is fully supported by ImageGear. However, certain cell formatting characteristics are not. See the Styles section for more details.

Merged Cells

The element expressed the ranged of a merged cell in the worksheet.

Merged cells are fully supported in most cases. However, there is a specific limitation of merged cells if they break across page boundaries in the paginated worksheet view (ImageGear.Formats.Office.ImGearExcelSheetPage). In this case, all text of the merged cells will be contained on the page where the first section of the merged cell exists.

Cell Value

This element expresses the value contained in a cell. If the cell contains a string, then this value is an index into the shared string table, pointing to the actual string value. Otherwise, the value of the cell is expressed directly in this element. Cells containing formulas express the last calculated result of the formula in this element.

The cell value element is fully supported by ImageGear. However, certain cell formatting characteristics are not. See the Styles section for more details.

Cells containing formulas will be supported if the last calculated value is included here. Otherwise, the cell’s formula is ignored.

Inline Text

This element allows for strings to be expressed directly in the cell definition instead of implementing the shared string table.

Fully supported.

Picture Specifies the existence of an embedded picture. ImageGear supports raster pictures only.
Shape Specifies the existence of a shape.

ImageGear supports a limited set of shapes.

  • Line shapes: Line/Straight Connector, Elbow Connector, Curved Connector, Curve, Freeform, Scribble.
  • Rectangle shapes: Rectangle, Rounded Rectangle, Snip Single Corner Rectangle, Snip Same Side Corner Rectangle, Snip Diagonal Corner Rectangle.
  • Basic shapes: Oval, Isosceles Triangle, Right Triangle, Parallelogram, Trapezoid, Diamond, Regular Pentagon, Hexagon, Heptagon, Octagon, Decagon, Dodecagon, Can, Cube, Folded Corner, Cloud.
  • Block Arrow shapes: Right Arrow, Left Arrow, Down Arrow, Up Arrow, Left-Right Arrow, Up-Down Arrow, Left-Up Arrow, Bent-Up Arrow, Curved Right Arrow, Curved Left Arrow, Curved Up Arrow, Curved Down Arrow, Pentagon, Chevron.
  • Flow Chart shapes: Process, Alternate Process, Decision, Data, Predefined Process, Internal Storage, Document, Multidocument, Terminator, Preparation, Manual Input, Manual Operation, Connector, Off-page Connector, Card, Punched Tape, Magnetic Disk, Direct Access Storage.
  • Callout shapes: Rectangular Callout, Rounded Rectangular Callout, Oval Callout, Cloud Callout, Line Callout 1, Line Callout 3, Line Callout 3, Line Callout 1 (Accent Bar), Line Callout 2 (Accent Bar), Line Callout 3 (Accent Bar), Line Callout 1 (No Border), Line Callout 2 (No Border), Line Callout 3 (No Border), Line Callout 1 (Border and Accent Bar), Line Callout 2 (Border and Accent Bar), Line Callout 3 (Border and Accent Bar).
  • Group shapes (many shapes grouped together).

The shapes not listed above will not be rendered by ImageGear.

Chart Specifies the existence of a chart.

ImageGear supports a limited set of charts:

  • Line
  • Stacked Line
  • 100% Stacked Line
  • Line With Markers
  • Stacked Line With Markers
  • 100% Stacked Line With Markers
  • Scatter with Straight Lines
  • Scatter with Only Markers
  • Scatter with Straight Lines and Markers
  • Clustered Column
  • Stacked Column
  • 100% Stacked Column
  • Clustered Bar
  • Stacked Bar
  • 100% Stacked Bar

ImageGear supports all possible combinations of above mentioned Charts.

Break

This element defines individual row or column breaks.

Both horizontal (row) and vertical (column) page breaks are fully supported.

Column Width & Formatting

This element defines the column width and formatting for one or more columns of the worksheet.

SpreadsheetML defines column formatting attributes to allow rows and columns to be expanded and collapsed from the user interface. This feature called outline is not supported by ImageGear.

Supported column attributes are:

  • Width
  • Hidden

Dimension

This element specifies the used range of the worksheet. It specifies the row and column bounds of used cells in the worksheet. This is optional and is not required.

ImageGear will attempt to use the dimension element to correctly size the worksheet page to encompass the active content. If the dimension element does not exist, the worksheet content will be scanned to determine the range of used cells manually.

Page Margins

This element defines the page margins for a sheet.

Supported margins are:

  • Top
  • Left
  • Right
  • Bottom

Page Setup

This element defines the page setup settings for the worksheet.

The page setup collection describes a variety of settings for printing a worksheet. ImageGear currently only uses the page size attribute to automatically determine a size for pages when a worksheet is paginated. Other page setup attributes are ignored.

The following page sizes are supported for automatic detection:

  • Letter (8.5” x 11”)
  • Letter Small (8.5” x 11”)
  • Tabloid (11” x 17”)
  • Ledger (17” x 11”)
  • Legal (8.5” x 14”)
  • Statement (5.5” x 8.5”)
  • Executive (7.25” x 10.5”)
  • A3 (297 mm x 420 mm)
  • A4 (210 mm x 297 mm)
  • A4 Small (210 mm x 297 mm)
  • A5 (148 mm x 210 mm)
  • B4 (250 mm x 353 mm)
  • B5 (176 mm x 250 mm)

Sheet Format Properties

This element defines several formatting properties for a worksheet.

The following sheet formatting properties are supported:

  • Base Column Width
  • Custom Height
  • Default Column Width
  • Default Row Height
  • Thick Bottom
  • Thick Top
  • Zero Height (Hidden)

Chart Rendering Properties

The DrawingML charts rendered by ImageGear and rendered by MS Office may have visual differences, because OpenXML specification does not contain rendering details for some chart elements. These differences include the relative positions of chart elements such as: title, axes, axes ticks, labels, legend, order of series in a legend, number of major and minor gridlines, and number of labels per axis. Also, combined charts axes maximum and minimum values (chart scaling) may differ from MS Office; as a result, the combined charts (relative positions of chart data series) rendered by ImageGear in the same plot area may visually differ from MS Office rendering. These differences do not have strict definition in OpenXML specification, and their rendering details are left up to the implementers.

Property dialogs of XLSX Charts have various customization settings. For those properties there are a few limitations in ImageGear that should be considered. Please note that only the supported properties/features are listed below; features not listed are not currently supported.

  • Chart Area Properties
  • Plot Area Properties
  • Value Axis Properties
  • Category Axis Properties
  • Chart Axis Title (Horizontal and Vertical) Properties
  • Legend Properties
  • Gridlines Properties
  • Data Series Properties
  • Data Labels Properties

Chart Area Properties

  • Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Border Color
    • No line
    • Solid line
    • Automatic
  • Border Styles
    • Single solid or dashed line
  • Size
  • Position

Plot Area Properties

  • Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Border Color
    • No line
    • Solid line
    • Automatic
  • Border Styles
    • Single solid or dashed line

Value Axis Properties

  • Axis Options
    • Minimum: Auto, Fixed
    • Maximum: Auto, Fixed
    • Major unit: Auto, Fixed
    • Minor unit: Auto, fixed
    • Values in reverse order
    • Logarithmic scale
    • Major tick mark type
    • Minor tick mark type
    • Axis labels
    • Horizontal axis crosses
  • Number
    • General
  • Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Line Color
    • No line
    • Solid line
    • Automatic
  • Line Styles
    • Single solid or dashed line

Category Axis Properties

  • Axis Options
    • Interval between labels
    • Categories in reverse order
    • Label distance from axis
    • Major tick mark type
    • Minor tick mark type
    • Axis labels
    • Vertical axis crosses
    • Position axis (Between tick marks)
  • Number
    • General
  • Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Line Color
    • No line
    • Solid line
    • Automatic
  • Line Styles
    • Single solid or dashed line

Chart Axis Title (Horizontal and Vertical) Properties

  • Fill
    • No fill
    • Solid fill
    • Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Border Color
    • No line
    • Solid line
    • Automatic
  • Border Styles
    • Single solid or dashed line

Legend Properties

  • Legend Position
    • Top
    • Bottom
    • Left
    • Right
    • Top Right
    • Show the legend without overlapping the chart
    • Show the legend at custom position
  • Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Border Color
    • No line
    • Solid line
    • Automatic
  • Border Styles
    • Single solid or dashed line

Gridlines Properties

  • Line Color
    • No line
    • Solid line
    • Automatic
  • Line Styles
    • Single solid or dashed line

Data Series Properties

Line Charts

  • Series Options
    • Plot Series on Primary Axis
  • Marker Options
    • Marker Type
  • Marker Fill
    • No fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Line Color
    • No line
    • Solid line
    • Automatic
  • Line Style
    • Single solid or dashed line
  • Marker Line Color
    • No line
    • Solid line
    • Automatic
  • Marker Line Style
    • Single solid or dashed line

Bar/Column Charts

  • Series Options
    • Series Overlap
    • Gap Width
    • Plot Series on Primary Axis
  • Fill
    • No Fill
    • Solid fill
    • Linear or Radial Gradient fill
    • Picture or texture fill
    • Automatic fill
  • Border Color
    • No line
    • Solid line
    • Automatic
  • Border Styles
    • Single solid or dashed line

Data Labels Properties

Line Charts

  • Label Options

    • Label Contains

      • Value

    • Label Position (Center, Left, Right, Above, Below)

  • Fill

    • No fill

    • Solid fill

    • Linear or Radial Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Bar/Column Charts

  • Label Options

    • Label Contains

      • Value

    • Label Position (Center, Inside End, Inside Base, Outside End)

  • Fill

    • No fill

    • Solid fill

    • Linear or Radial Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line


Shared String Table
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear > Shared String Table

A workbook can contain thousands of cells containing string (non-numeric) data. Furthermore this data is very likely to be repeated across many rows or columns. The goal of implementing a single string table that is shared across the workbook is to improve performance and optimize the storage format.

For cells that contain a string, the cell value will contain an index into the shared string table, pointing to the actual string value. The shared string table is permitted to contain all the necessary information for displaying the string: the text, formatting properties, and phonetic properties (for East Asian languages).

Most strings in a workbook have formatting applied at the cell level, that is, the entire string in the cell has the same formatting applied. In these cases, the formatting for the cell is stored in the styles part, and the string for the cell can be stored in the shared strings table.

Some strings in the workbook can have formatting applied at a level that is more granular than the cell level. For instance, specific characters within the string can be bolded, have coloring, italicizing, etc. In these cases, the formatting is stored along with the text in the string table, and is treated as a unique entry in the table.

The following features of the shared strings table are supported by ImageGear:

Feature

Description

Comment

String Item

This element is the representation of an individual string in the shared strings table.

If the string is just a simple string with formatting applied at the cell level, then the String Item should contain a single text element used to express the string. If the string has more complex formatting, then the String Item consists of multiple rich text runs.

Phonetic properties of string items are not supported by ImageGear.

Rich Text Run

This element represents a run of rich text.

Fully supported.

Run Font

This element is a string representing the name of the font assigned to display this run.

Fully supported.

Run Properties

This element represents a set of properties to apply to the contents of a rich text run

The following run properties are supported:

  • Bold
  • Font Family (Supported true type fonts only)
  • Italic
  • Font
  • Strike Through
  • Font Size
  • Underline

ImageGear does not support the vertical alignment of text, meaning that subscripts and superscripts will appear as normal text.

ImageGear uses Microsoft WPF for rendering fonts. For some particular font families, WPF may fail to load the correct typeface, although the specified font is present on the system - this is a known issue that has not yet been addressed. Due to this, the content displayed by ImageGear (font family/style, text layout, line spacing, etc.) may differ from the content displayed by Microsoft Office.


Styles
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear > Styles

The following style attributes are supported by ImageGear:

Feature

Description

Comment

Alignment

This element describes the text alignment in cells. There are a variety of choices for how text is aligned both horizontal and vertically, as well as indentation settings, rotation, and so on.

ImageGear supports only the following alignment attributes:

  • Horizontal Alignment
    • General
    • Center
    • Justify
    • Left
    • Right
  • Vertical Alignment
    • Top
    • Center
    • Bottom
  • Indent
  • Reading Order
  • Wrap Text

Other alignment properties not mentioned here are not supported and will be ignored.

Background Color

This element describes the background color of the cell fill pattern. Cell fill patterns operate with two colors: a background color and a foreground color. These combine to make a patterned cell fill.

ImageGear only supports the solid fill pattern. In this case, only the foreground color is used to produce the fill effect. This means that the background color is, effectively, ignored.

Borders

The border element expresses a single set of cell border formats (left, right, top, bottom, diagonal). Color is optional. When missing, ‘automatic’ is implied.

ImageGear supports all border sides, including both diagonal directions.

The following border types are supported:

  • Thin
  • Thick
  • Medium
  • Hair
  • MediumDashDot
  • DashDot
  • MediumDashDotDot
  • DashDotDot
  • MediumDashed
  • Dashed
  • Dotted
  • Double

The SlantDashDot is not supported and will be rendered as the regular DashDot border type.

Fills

This element defines the cell, which consists of a background color, foreground color, and pattern to be applied across the cell.

ImageGear only supports the Solid pattern fill. Other fill types, like gradients, are ignored.

Fonts

This element defines the properties for one of the fonts used in a workbook.

The following font attributes are supported:

  • Bold
  • Font Family (Supported True Type fonts only)
  • Italic
  • Font Name
  • Strike Through
  • Font Size
  • Underline

Foreground Color

This element describes the foreground color of the cell fill pattern. Cell fill patterns operate with two colors: a background color and a foreground color. These combine to make a patterned cell fill.

ImageGear supports the following foreground color sources and effects:

  • Automatic
  • Indexed
  • RGB
  • Theme Color
  • Tint

Indexed Colors

This element collection defines the legacy indexing scheme for colors that are still required for some records, and for backwards compatibility with legacy formats.

All indexed colors are fully supported. Specifically, the colors are:

  • "0" 00000000
  • "1" 00FFFFFF
  • "2" 00FF0000
  • "3" 0000FF00
  • "4" 000000FF
  • "5" 00FFFF00
  • "6" 00FF00FF
  • "7" 0000FFFF
  • "8" 00000000
  • "9" 00FFFFFF
  • "10" 00FF0000
  • "11" 0000FF00
  • "12" 000000FF
  • "13" 00FFFF00
  • "14" 00FF00FF
  • "15" 0000FFFF
  • "16" 00800000
  • "17" 00008000
  • "18" 00000080
  • "19" 00808000
  • "20" 00800080
  • "21" 00008080
  • "22" 00C0C0C0
  • "23" 00808080
  • "24" 009999FF
  • "25" 00993366
  • "26" 00FFFFCC
  • "27" 00CCFFFF
  • "28" 00660066
  • "29" 00FF8080
  • "30" 000066CC
  • "31" 00CCCCFF
  • "32" 00000080
  • "33" 00FF00FF
  • "34" 00FFFF00
  • "35" 0000FFFF
  • "36" 00800080
  • "37" 00800000
  • "38" 00008080
  • "39" 000000FF
  • "40" 0000CCFF
  • "41" 00CCFFFF
  • "42" 00CCFFCC
  • "43" 00FFFF99
  • "44" 0099CCFF
  • "45" 00FF99CC
  • "46" 00CC99FF
  • "47" 00FFCC99
  • "48" 003366FF
  • "49" 0033CCCC
  • "50" 0099CC00
  • "51" 00FFCC00
  • "52" 00FF9900
  • "53" 00FF6600
  • "54" 00666699
  • "55" 00969696
  • "56" 00003366
  • "57" 00339966
  • "58" 00003300
  • "59" 00333300
  • "60" 00993300
  • "61" 00993366
  • "62" 00333399
  • "63" 00333333
  • "64" System Foreground
  • "65" System Background

Number Format

This element defines the number formats in a workbook, consisting of a sequence of numFmt records, where each numFmt record defines a particular number format, indicating how to format and render the numeric value of a cell.

The number formatting system of the SpreadsheetML defines an extensive architecture for formatting numbers. ImageGear currently only support a small subset of number formats. These include all of the built-in formats, which are:

  • General
  • 0
  • 0.00
  • #,##0
  • #,##0.00
  • 0%
  • 0.00%
  • 0.00E+00
  • # ?/?
  • # ??/??
  • mm-dd-yy
  • d-mmm-yy
  • d-mmm
  • mmm-yy
  • h:mm AM/PM
  • h:mm:ss AM/PM
  • h:mm
  • h:mm:ss
  • m/d/yy h:mm
  • #,##0 ;(#,##0)
  • #,##0 ;[Red](#,##0)
  • #,##0.00;(#,##0.00)
  • #,##0.00;[Red](#,##0.00)
  • mm:ss
  • [h]:mm:ss
  • mmss.0
  • ##0.0E+0
  • @

In additional to the built-in formats, ImageGear also supports a handful of special case formats, which are:

  • 0.0
  • 0.00
  • 0.000
  • 0.0000
  • 0.00000
  • $#,##0,00
  • m/d/yy
  • [$-F800]dddd, mmmm dd, yyyy
  • [$-F400]h:mm:ss AM/PM


Headers and Footers
User Guide > How to Work with... > Office Formats > Working with Excel Documents > SpreadsheetML Groups Supported by ImageGear > Headers and Footers

Headers and footers refer to text, graphics, or data fields (such as page number, date, sheet tab name, and so on) that can appear at the top or bottom of each page in a SpreadsheetML document. A header appears in the top margin (above the main document content on the page), while a footer appears in the bottom margin of a document page (below the main document content on the page).

Since SpreadsheetML is a flow-based format, headers and footers are applied by specifying the headers and footers for all pages in a particular section of a document. Within each section of a document, there can be up to three different types of headers and footers, and within each header/footer type there are three locations: "left", "center", and "right".

  • First page header/footer

    First page headers and footers specify up to three headers and footers which shall appear on left, center, and right sides of the first page of a section.

  • Odd page header/footer

    Odd page headers and footers specify up to three headers and footers which shall appear on left, center, and right sides of all odd-numbered pages in a given section.

  • Even page header/footer

    Even page headers and footers specify up to three headers and footers which shall appear on left, center, and right sides of all even-numbered pages in a given section.

Supported Header/Footer Attributes

The following header/footer attributes are supported by ImageGear:

Feature | Description | Comment
Different First | This attribute specifies the header and footer are different for the first page. | Fully supported.
Different Odd Even | This attribute specifies the header and footer are different on odd-numbered pages and even-numbered pages. | Fully supported.
Align With Margins | This attribute specifies the header and footer should align with the left and right margins of the chart. | Fully supported.
Scale With Document | This attribute specifies the header and footer should be scaled with document. | Fully supported.

Supported Header/Footer Data Fields

The following data fields are supported in header/footer by ImageGear:

Feature

Description

Comment

Current Page

This header/footer data field specifies the current page number.

ImageGear supports the numbers in decimal format.

Total Pages

This header/footer data field describes the number of pages of the document.

ImageGear supports the numbers in decimal format.

Date

This header/footer data field describes the date.

ImageGear supports the data in Short Date Pattern.

Time

This header/footer data field describes the time.

ImageGear supports the time in Short Time Pattern.

Workbook’s File Path

This header/footer data field describes the workbook’s file path.

ImageGear supports the file path in system-specific format.

Workbook’s File Name

This header/footer data field describes the workbook’s file name.

ImageGear supports the file name without file extension.

Sheet Tab Name

This header/footer data field describes current sheet tab name.

ImageGear supports the sheet tab name, which should be unique.

Picture

This header/footer data field describes a background picture.

ImageGear supports the picture with following parameters (Format Picture dialog in MS Excel):

  • Picture size parameters
  • Picture cropping parameters

All remaining parameters of the Format Picture dialog are not supported yet.

Supported Header/Footer Style Attributes

The following style attributes are supported in header/footer by ImageGear:

Feature

Description

Comment

Fonts

This style attribute defines the properties for one of the fonts used in header/footer.

The following font attributes are supported:

  • Font Family (Supported True Type fonts only)
  • Font Name
  • Font Size
  • Bold
  • Italic
  • Underline
  • Strike Through
  • Superscript
  • Subscript

Font Color

This style attribute describes the font color of the header/footer.

ImageGear supports the font color in RGB and Theme Color formats:

  • RGB Color is specified as RRGGBB
  • Theme Color is specified as TTSNN, where TT is the theme color Id, S is either "+" or "-" of the tint/shade value, and NN is the tint/shade value.


Working with PowerPoint Documents
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents

Displaying PowerPoint Documents

The ImGearPowerPointDocument can be created and processed in any thread with any apartment state: STA or MTA. If they also need to be displayed, then there are some concepts which should be taken into account:

  • In WPF display scale mode the calling thread must use the STA apartment state, which is a requirement of Windows Presentation Foundation. ImageGear will create a WPF Canvas in the context of this calling thread to render the document pages for display.
  • In Native display scale mode, which is the default for ImageGear, there are no restrictions for displaying PowerPoint pages in a multi-threaded environment.

Additional Information

The following topics are also covered in this section:

  • Walkthrough: Loading PowerPoint Documents
  • PresentationML Groups Supported by ImageGear

Below are the groups of the Open XML PresentationML, which ImageGear supports (read-only):

  • Presentations
  • Slides
  • Styles


Walkthrough: Loading PowerPoint Documents
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents > Walkthrough: Loading PowerPoint Documents

Loading PowerPoint Documents

The process for loading PowerPoint documents with ImageGear is very similar to that of other document formats. The following steps will enable you to view the first page of a presentation in a PowerPoint document.

Step 1

Add the PowerPoint format to the list of file format filters ImageGear will use to detect formats of loaded content.

C# Example
Copy Code
// Add support for PowerPoint files
ImGearFileFormats.Filters.Add(ImGearOffice.CreatePowerPointFormat());
VB.NET Example
Copy Code
' Add support for PowerPoint  files
ImGearFileFormats.Filters.Add(ImGearOffice.CreatePowerPointFormat())

Step 2

Once the desired PowerPoint file has been opened into a System.IO.Stream, the document can be loaded with the LoadDocument method. The startPageNumber and count parameters of the LoadDocument method can be used to load a select few or all of the slides in the PowerPoint document. The example below will load all available slides.

The GetPageCount method can be used to get the number of slides in a Stream that contains a valid PowerPoint document.

C# Example
Copy Code
ImGearDocument imGearDocument = ImGearFileFormats.LoadDocument(fileContent, 0, -1);
VB.NET Example
Copy Code
Dim imGearDocument As ImGearDocument = ImGearFileFormats.LoadDocument(fileContent, 0, -1)

Step 3

Once the document is loaded, the ImGearDocument will contain pages, with each one representing an entire slide.

Displaying the first one of the pages you created for the slide is easy using ImageGear’s PageView control. Simply create the control and set the Page property to that of the PowerPoint page. See the Displaying Images topic for more information displaying images with ImageGear.

C# Example
Copy Code
imGearPageView.Page = imGearDocument.Pages[0];
imGearPageView.Update();
VB.NET Example
Copy Code
imGearPageView.Page = imGearDocument.Pages(0)
imGearPageView.Update()


PresentationML Groups Supported by ImageGear
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents > PresentationML Groups Supported by ImageGear

The ImageGear Office Assembly uses the WPF engine for displaying Open XML PresentationML elements. Since WPF has limited support for PresentationML groups and elements, ImageGear does not fully support the ECMA-376, Second Edition specification. Brief descriptions of the features are from the ECMA specification.

Below are the groups of the Open XML PresentationML that ImageGear supports (read only):

  • Presentations
  • Slides
  • Styles


Presentations
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents > PresentationML Groups Supported by ImageGear > Presentations

The presentation is the central structure within a PresentationML package. The presentation provides access to the slides, which contain the shapes that provide the text, numbers, dates and other content. The presentation part and corresponding properties comprise data used to set application and presentation-level operational state.

ImageGear supports a limited subset of the features in the presentation part. These features are described below:

Feature | Description | Comment
DefaultTextStyle | Presentation Default Text Style | The default text styles that are to be used within the presentation.
SlideSize | Presentation Slide Size | The size of the presentation slide surface.


Slides
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents > PresentationML Groups Supported by ImageGear > Slides

Slides are the fundamental parts within a presentation. The best way to think of a slide is a container for all data that is to be on that slide. The specific shapes, images, and relations within a slide will not come into play here.

Feature

Description

Comment

Slide Background

The background appearance information for a slide. The slide background covers the entire slide and is visible where no objects exist and as the background for transparent objects.

ImageGear supports the Solid, Gradient* and Picture fill patterns. Other fill types, like Pattern Fill, are ignored.

* The Path (Shape) and Rectangle gradient types are not supported. For these types, the first stop color will be used as the solid fill color.

Shape

Specifies the existence of a single shape. A shape can either be a preset or a custom geometry, defined using the DrawingML framework. In addition to geometry each shape can have both visual and non-visual properties attached. Text and corresponding styling information can also be attached to a shape.

Fully supported.

Picture

Specifies the existence of a picture object within the document.

ImageGear supports raster pictures only.

Connection Shape

Specifies a connection shape (lines and arrows).

Fully supported.

Group Shape

Specifies a group shape that represents many shapes grouped together.

ImageGear supports Shape and Picture shapes within the Group Shape.

Graphic Frame (Table, Chart)

Specifies the existence of a graphics frame (table, chart).

ImageGear supports Graphic Frames in the form of tables and charts.

ImageGear supports a limited set of charts: Line, Stacked Line, 100% Stacked Line, Line With Markers, Stacked Line With Markers, 100% Stacked Line With Markers, Scatter with Straight Lines, Scatter with Only Markers, Scatter with Straight Lines and Markers, Clustered Column, Stacked Column, 100% Stacked Column, Clustered Bar, Stacked Bar, 100% Stacked Bar.

ImageGear supports all possible combinations of above mentioned Charts.

Shape Properties

Specifies the visual shape properties that can be applied to a shape. These properties include the shape: fill, outline, geometry, effects, and 3D orientation.

ImageGear supports a limited set of geometries: Line/Straight Connector, Elbow Connector, Curved Connector, Curve, Freeform, Scribble, Rectangle, Rounded Rectangle, Snip Single Corner Rectangle, Snip Same Side Corner Rectangle, Snip Diagonal Corner Rectangle, Folded Corner, Oval, Isosceles Triangle, Right Triangle, Parallelogram, Trapezoid, Diamond, Regular Pentagon, Hexagon, Heptagon, Octagon, Decagon, Dodecagon, Can, Cube, Cloud, Flowchart Process, Flowchart Alternate Process, Flowchart Decision, Flowchart Data, Flowchart Predefined Process, Flowchart Internal Storage, Flowchart Document, Flowchart Multidocument, Flowchart Terminator, Flowchart Preparation, Flowchart Manual Input, Flowchart Manual Operation, Flowchart Connector, Flowchart Off-page Connector, Flowchart Card, Flowchart Punched Tape, Flowchart Magnetic Disk, Flowchart Direct Access Storage, Right Arrow, Left Arrow, Down Arrow, Up Arrow, Left-Right Arrow, Up-Down Arrow, Left-Up Arrow, Bent-Up Arrow, Curved Right Arrow, Curved Left Arrow, Curved Down Arrow, Curved Up Arrow, Pentagon, Chevron, Rectangular Callout, Rounded Rectangular Callout, Oval Callout, Cloud Callout, Line Callout 1, Line Callout 3, Line Callout 3, Line Callout 1 (Accent Bar), Line Callout 2 (Accent Bar), Line Callout 3 (Accent Bar), Line Callout 1 (No Border), Line Callout 2 (No Border), Line Callout 3 (No Border), Line Callout 1 (Border and Accent Bar), Line Callout 2 (Border and Accent Bar), Line Callout 3 (Border and Accent Bar).

Shape Text Body

Specifies the existence of text to be contained within the corresponding shape. All visible text and visible text related properties are contained within this element. There can be multiple paragraphs and within paragraphs multiple runs of text.

Fully supported.

Text Paragraphs

Specifies the presence of a paragraph of text within the containing text body. The paragraph is the highest level text separation mechanism within a text body.

Fully supported.

Text Run

Specifies the presence of a run of text within the containing text body. The run element is the lowest level text separation mechanism within a text body.

Fully supported.

Text String

Specifies the actual text for this text run. This is the text that is formatted using all specified body, paragraph and run properties.

Fully supported.

Bullets and Numbering

Specifies bullets and numbering applied to the paragraphs.

Fully supported.

Chart Rendering Properties

The DrawingML charts rendered by ImageGear and rendered by MS Office may have visual differences, because OpenXML specification does not contain rendering details for some chart elements. These differences include the relative positions of chart elements such as: title, axes, axes ticks, labels, legend, order of series in a legend, number of major and minor gridlines, and number of labels per axis. Also, combined charts axes maximum and minimum values (chart scaling) may differ from MS Office; as a result, the combined charts (relative positions of chart data series) rendered by ImageGear in the same plot area may visually differ from MS Office rendering. These differences do not have strict definition in OpenXML specification, and their rendering details are left up to the implementers.

Property dialogs of PPTX Charts have various customization settings. For those properties there are a few limitations in ImageGear that should be considered. Please note that only the supported properties/features are listed below; features not listed are not currently supported.

  • Chart Area Properties
  • Plot Area Properties
  • Value Axis Properties
  • Category Axis Properties
  • Chart Axis Title (Horizontal and Vertical) Properties
  • Legend Properties
  • Gridlines Properties
  • Data Series Properties
  • Data Labels Properties

Chart Area Properties

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

  • Size

  • Position

Plot Area Properties

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Value Axis Properties

  • Axis Options

    • Minimum: Auto, Fixed

    • Maximum: Auto, Fixed

    • Major unit: Auto, Fixed

    • Minor unit: Auto, fixed

    • Values in reverse order

  • Major tick mark type

    • Outside

    • Inside

    • Cross

    • None

  • Minor tick mark type

    • Outside

    • Inside

    • Cross

    • None

  • Axis labels

    • Next to Axis

    • High

    • Low

    • None

  • Horizontal axis crosses

    • Automatic

    • Explicit value

    • Maximum axis value

  • Number

    • General

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Line Color

    • No line

    • Solid line

    • Automatic

  • Line Styles

    • Single solid or dashed line

Category Axis Properties

  • Axis Options

    • Interval between labels

    • Categories in reverse order

  • Major tick mark type

    • Outside

    • Inside

    • Cross

    • None

  • Minor tick mark type

    • Outside

    • Inside

    • Cross

    • None

  • Axis labels

    • Next to Axis

    • High

    • Low

    • None

  • Vertical axis crosses

    • Automatic

    • Explicit value

    • Maximum axis value

  • Position axis

    • Between tick marks

  • Number

    • General

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Line Color

    • No line

    • Solid line

    • Automatic

  • Line Styles

    • Single solid or dashed line

Chart Axis Title (Horizontal and Vertical) Properties

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Legend Properties

  • Legend Position

    • Top

    • Bottom

    • Left

    • Right

    • Top Right

    • Show the legend without overlapping the chart

    • Show the legend at custom position

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Gridlines Properties

  • Line Color

    • No line

    • Solid line

    • Automatic

  • Line Styles

    • Single solid or dashed line

Data Series Properties

Line Charts

  • Plot Series On

    • Primary Axis

  • Marker Type

    • Automatic

    • None

    • Built-in

  • Marker Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Line Color

    • No line

    • Solid line

    • Automatic

  • Line Style

    • Single solid or dashed line

  • Marker Line Color

    • No line

    • Solid line

    • Automatic

  • Marker Line Style

    • Single solid or dashed line

Bar/Column Charts

  • Series Overlap

    • Any from ‘Separated’ to ‘Overlapped’

  • Gap Width

    • Any from ‘No Gap’ to ‘Large Gap’

  • Plot Series On

    • Primary Axis

  • Fill

    • No Fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Data Labels Properties

Line Charts

  • Label Options

    • Label Contains

      • Value

    • Label Position (Center, Left, Right, Above, Below)

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line

Bar/Column Charts

  • Label Options

    • Label Contains

      • Value

    • Label Position (Center, Inside End, Inside Base, Outside End)

  • Fill

    • No fill

    • Solid fill

    • Gradient fill

    • Picture or texture fill

    • Automatic fill

  • Border Color

    • No line

    • Solid line

    • Automatic

  • Border Styles

    • Single solid or dashed line


Styles
User Guide > How to Work with... > Office Formats > Working with PowerPoint Documents > PresentationML Groups Supported by ImageGear > Styles

The following styling attributes are supported by ImageGear:

Feature

Description

Comment

Text Alignment

This element describes the text alignment in shapes. There are a variety of choices for how text is aligned both horizontal and vertically, as well as indentation settings, rotation, and so on.

ImageGear supports the only the following alignment attributes:

  • Horizontal Alignment
    • General
    • Center
    • Justify
    • Left
    • Right
  • Vertical Alignment
    • Top
    • Center
    • Bottom
  • Indent
  • Left, Top, Right, Bottom insets

Other alignment properties not mentioned here are not supported and will be ignored.

Shape Line Styles

This element specifies an outline style that can be applied to shapes. The line allows for the specifying of many different types of outlines including even line dashes and bevels.

ImageGear supports only Solid Fill based outlines. Additionally the following preset dash styles are supported:

  • Dash
  • DashDot
  • Dot
  • LargeDash
  • LargeDashDot
  • LargeDashDotDot
  • SystemDash
  • SystemDashDot
  • SystemDashDotDot
  • SystemDot

Other dash styles are not supported and will be rendered as the regular solid outline.

Foreground Color

This element describes the foreground color of the text.

ImageGear supports the following Solid Fill foreground color sources and effects:

  • RGB
  • HSL
  • Theme Color
  • Tint
  • Shade

Fills

This element defines the shape fill styles.

ImageGear only supports the Solid, Gradient* and Picture pattern fill types. Other fill types, like Pattern Fill, are ignored.

* The Path(Shape) and Rectangle gradient types are not supported. For these types, the first stop color will be used as the solid fill color.

Fonts

This element defines the properties for one of the fonts used in a text paragraph.

The following font attributes are supported:

  • Font Name
  • Font Size
  • Bold
  • Italic
  • Strike Through
  • Underline
  • Subscript
  • Superscript

ImageGear uses Microsoft WPF for rendering fonts. For some particular font families, WPF may fail to load the correct typeface, although the specified font is present on the system - this is a known issue that has not yet been addressed. Due to this, the content displayed by ImageGear (font family/style, text layout, line spacing, etc.) may differ from the content displayed by Microsoft Office.


PDF
User Guide > How to Work with... > PDF

The PDF component in ImageGear for .NET allows you to securely create, display, edit, annotate, format, organize, and search PDF and PostScript (PS) documents. ImageGear is also a complete, high-performance, image processing toolkit; so, it allows applications to seamlessly integrate advanced image processing techniques into PDF documents.

This topic provides information about the following:

  • About PDF, PS, and EPS
  • PDF and PS Support and Compatibility
  • PDF Samples

About PDF, PS, and EPS

  • About PDF
  • About PostScript
  • About Encapsulated PostScript

About PDF

The Adobe Portable Document Format (PDF) is the native file format of the Adobe Acrobat family of products. PDF relies on the same imaging model as the PostScript page description language to describe text and graphics in a device-independent and resolution-independent manner. A document can be converted straightforwardly between PDF and the PostScript language; the two representations produce the same output when printed. To improve performance for interactive viewing, PDF defines a more structured format than that used by most PostScript language programs. PDF also includes objects, such as annotations and hypertext links that are not part of the page itself but are useful for interactive viewing and document interchange. However, PDF lacks the general-purpose programming language framework of the PostScript language.

About PostScript

The PostScript (PS) language is a simple, interpretive programming language with powerful graphics capabilities. Its primary application is to describe the appearance of text, graphical shapes, and sampled images on printed or displayed pages, according to the Adobe imaging model. A program in this language can communicate a description of a document from a composition system to a printing system or control the appearance of text and graphics on a display. The description is high-level and device-independent.

About Encapsulated PostScript

"PostScript" refers to a widely-supported general-purpose computer language that encodes text and graphics files for sharing with the many different hardware devices that support it. The full name for this language is "PostScript Page Description Language" (PDL).

An Encapsulated PostScript file stores (encapsulates) graphical or photographic images from a larger PostScript file. ImageGear currently supports the reading of EPS image of any bit depth as long as the preview image is TIFF, uncompressed. ImageGear currently supports the writing of monochrome (1-bit), grayscale (8-bit gray level), and color RGB (24-bit) EPS images only.

The EPS file format begins with a PostScript language header. The data herein identifies the format as EPS, and gives the image title, creator, creation date, size, and position of the image. Each line begins with a percent sign (%), which is normally interpreted in the PostScript language as the beginning of a comment line. Within the context of the EPS header, it takes on a different meaning.

Following the header is a block of PostScript code, which accomplishes the actual creation of the image.

The format proceeds with the bitmap data, or "graphics screen representation".

The EPI version of the EPS format, the version supported by ImageGear, contains an abridged interpretation of the image that is appended to the end of the file. It is usually smaller, and contains a lower resolution. One of the benefits of a preview image is that an application does not need to be able to interpret PostScript in order to display the image. Preview images are created with one of four file format types: TIFF, WMF, MAC PICT, and EPS.

PDF and PS Support and Compatibility

PDF support is compatible with Adobe PDF v1.7 as defined in the Portable Document Format Reference Manual Version 1.7, distributed by Adobe Systems, Incorporated. It provides reading capability up to the PDF v1.7 and writing of PDF v1.7 documents.

PDF documents that contain XFA information are not supported.

PostScript support is compatible with Adobe PostScript (TM) 3.0 language as defined in the PostScript Format Reference Manual, distributed by Adobe Systems, Incorporated. It provides reading capability up to the PostScript 3.0 Language, Level 3, and writing of the PostScript 3.0 files with Language Levels 1, 2 and 3. This includes writing of Encapsulated PostScript (EPS) files with standard and extended preview as well as without preview at all.

PDF Samples

We have an entire set of samples that illustrate common PDF functionalities and uses cases. See a list of PDF Samples.


Getting Started with ImageGear PDF
User Guide > How to Work with... > PDF > Getting Started with ImageGear PDF

This section provides information about the following:

  • PDF Samples and Tutorials
  • ImageGear.Formats.PDF Namespace
  • PDF Dependencies
  • PDF Object Lifetime
  • Working with PS Files

PDF Samples and Tutorials

Our suite of PDF samples will help you get started using ImageGear's PDF capabilities.

This section also provides step-by-step PDF tutorials, which show you how to create a new ImageGear project using the PDF component:

  • Getting Started with ImageGear PDF
    • Tutorial: Create Your First PDF Project
      • Console Application
      • Windows Forms Application
      • Windows Presentation Foundation (WPF)

ImageGear.Formats.PDF Namespace

The ImageGear.Formats.PDF namespace allows you to load, save, and process native PDF and PostScript documents. It also allows rasterization of PDF and PostScript documents, by converting them to bitmaps, and provides you with the ability to extract text from loaded PDF and PostScript documents.

The ImageGear.Formats.PDF namespace provides full multi-page read and write support for the entire document as well as a specified set of pages. You can detect, read, write, append, insert, replace, swap, and delete a specified page in the PDF document as well as to edit its content.

To enable the ImageGear.Formats.PDF Namespace in your project, specify the following directive:

Copy Code
using ImageGear.Formats.PDF;

PDF Dependencies

You can use our NuGet packages or the Deployment Packaging Wizard to ensure you've met all required dependencies.

NuGet Packages

NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework. See NuGet Packages for more information.

Deployment Packaging Wizard

  1. To ensure that you have all the required library files, please run the Deployment Packaging Wizard located at …\Accusoft\ImageGear.NET v22\Licensing\Deployment \DPW.exe or navigate to Start menu >All Programs > Accusoft > ImageGear for .NET v22 > Deployment Kit > Deployment Packaging Wizard. For more information, see Deployment Packaging Wizard, if needed.
  2. Please ensure that your Visual Studio build environment is set properly. This can be checked or changed by the following:
    1. From the project properties:
      • On the Build tab, check/change the Platform target property to the appropriate x86/x64. At the top, also make sure the Platform property is set to the same.
      • On the Build tab, in the Output section, make sure Output path property is pointing to the same location as your dlls, i.e., bin\RunTime\NET\
      • On the Debug tab, check/change the Platform property to the correct platform.
    2. Select Build from the pull down menus, and click Configuration Manager…
      • Check/change the Active solution platform property to the correct x86/x64 platform.
      • Click Close.
  3. You will also need to have the Microsoft Visual C++ CRT 10.0 (x86) installed. Corresponding links to VS2010/VS2010SP1 C++ Redistributable Packages are:

    http://www.microsoft.com/en-us/download/details.aspx?id=5555
    http://www.microsoft.com/en-us/download/details.aspx?id=14632
    http://www.microsoft.com/en-us/download/details.aspx?id=8328
    http://www.microsoft.com/en-us/download/details.aspx?id=13523

    For more information, see Distributing PDF and PS Fonts and Libraries with an Application.

  4. You can also pass in the direct location of the PDF resource files as a parameter of the CreatePDFFormat method. For a modified code example, please see the following:
    Copy Code
    ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(@"C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Bin"));

ImGearPDF.Initialize(@"C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Bin");
  5. For a WEB application, you can pass the location of PDF binaries and resources directly in the web.config file of the application:
    Copy Code
    <appSettings>
  ......
  <add key="igPdfResources" value="C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Bin" />
  <add key="igBinaries" value="C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Bin" />
</appSettings>

    For more information about working with the web.config file, see Using the ASP.NET Web.Config Editor Application for Configuring Your Web Application.

PDF Object Lifetime

All PDF objects, such as ImGearPDEColorspace, ImGearPDFPage, and ImGearPDEContent, are based on underlying low-level PDF objects, which are not controlled by .NET resource manager and garbage collector. Due to complex dependencies between these objects, it is not possible to wrap these objects with a fully-automated .NET lifecycle management. For example, disposing an ImGearPDFPage object whose content was obtained with the GetContent method and was not released with ReleaseContent can lead to an internal PDF exception.

So, each PDF object that is obtained or created from scratch should be disposed explicitly using its Dispose() method (as an alternative, “using” syntax can be applied).

Failure to dispose of PDF Documents and Pages can cause significant memory issues in the running application and lingering issues, in the form of abandoned temp files, after the application has terminated.

Also, an ImGearPDEContent object obtained from ImGearPDFPage should be released using the ImGearPDFPage.ReleaseContent() method in all cases.

An ImGearPDEContent object obtained from a Container, Group, or Form does not need to be released, so ImGearPDEContainer, ImGearPDEForm, and ImGearPDEGroup do not have such a method.

Here is sample code to illustrate this:

C#
Copy Code
public void IterateElements(ImGearDocument imageDocument)
        {
            ImGearPDFDocument pdfDocument = (ImGearPDFDocument)imageDocument;

            for (int index = 0; index < pdfDocument.Pages.Count; index++)
            {
                try
                {
                    ImGearPage page = pdfDocument.Pages[index];
                 // content should be disposed
                    ImGearPDEContent content = ((ImGearPDFPage)page).GetContent();
                    for (int elementIndex = 0; elementIndex < content.ElementCount; elementIndex++)
                    {
                        ImGearPDEElement element = content.GetElement(elementIndex);
                        if (!TryLoadElement(element))
                        {
                            throw new Exception();
                       }
                        element.Dispose();
                    }

                    // ReleaseContent should be called for a page
                    ((ImGearPDFPage)page).ReleaseContent();
                    // dispose content
                    content.Dispose();
                }
                catch (Exception ex)
                {
                    MessageBox.Show("Error”);
                }
            }
            // ImGearPDFDocument object should be disposed too. We’ve left it to caller.
        }

Working with PS Files

The ImageGear.Formats.PDF namespace loads PostScript files by converting them to PDF first and applying a set of default conversion settings. To adjust the results of that conversion, ImageGear .NET PDF namespace implements JobOptionsFile PostScript filter control parameter that can be pointed to one of the .joboptions files distributed with the product. A .joboptions file contains settings that control the conversion from PostScript or EPS to PDF performed on-the-fly for rendering PostScript and EPS in ImageGear .NET. If you encounter any problems with PostScript or EPS rendering or conversion to PDF, such as color or layout differences, you can use the provided "Bin\Resource\PS\Settings\Standard.joboptions" by setting the value of JobOptionsFile PostScript filter control parameter to the full path of the location of that file.


Tutorial: Create Your First PDF Project
User Guide > How to Work with... > PDF > Getting Started with ImageGear PDF > Tutorial: Create Your First PDF Project

The following tutorials walk you through creating a PDF project with ImageGear:

  • Tutorial: Create Your First PDF Project
    • Console Application
    • Windows Forms Application
    • Windows Presentation Foundation (WPF)


Console Application
User Guide > How to Work with... > PDF > Getting Started with ImageGear PDF > Tutorial: Create Your First PDF Project > Console Application

In this tutorial, you will configure a C# or VB.NET project for a console application and use ImageGear .NET PDF capabilities. You will also learn how to open a PDF or PS file and save it as a new file.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "Console Application" project, using C# or VB.NET, and name the project: my_first_PDF_project
  2. If you installed ImageGear .NET 64-bit, using the Configuration Manager, create a new project platform (if you don't have one already) for x64. Make sure your project is set to compile targeting Debug and x64. Confirm you now have $YOURLOCALPROJ\bin\x64\Debug\, and if it's not there, create it.
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following package:
      Accusoft.ImageGear.PDF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.PDF/ )
    • Manually:
      • Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      • Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Evaluation.dll
        • ImageGear.22.Art.dll
        • ImageGear22.Formats.Common.dll
        • ImageGear22.Formats.Pdf.dll
        • ImageGear22.Formats.Vector.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\ .

  4. At this point all necessary assembly references and resources have been added to the project. The following code snippet can be used to load a PDF and save it as new file. Make sure to replace C:\PATHTOPDF\ with your own PDF file name and path:
    • CS
    • VBNET
    C#
    Copy Code
    using System.IO;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;
using ImageGear.Evaluation;

namespace my_first_PDF_project
{
   class Program
   {
       public void SaveAs(string fileIn, string fileOut)
       {
           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();
           ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           // Add support for PDF and PS files.
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
           ImGearPDF.Initialize();

           using (FileStream inStream = new FileStream(fileIn, FileMode.Open))
           {
               using (FileStream outStream = new FileStream(fileOut, FileMode.Create))
               {
                   // Load PDF document.
                   ImGearDocument igDocument = ImGearFileFormats.LoadDocument(inStream);

                   // Save PDF.
                   ImGearPDFSaveOptions pdfOptions = new ImGearPDFSaveOptions();
                   ImGearFileFormats.SaveDocument(igDocument, outStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, pdfOptions);
               }
           }
           // Dispose of the PDF component.
           ImGearPDF.Terminate();
       }

       static void Main(string[] args)
       {
           Program myProgram = new Program();
           myProgram.SaveAs(@"C:\PATHTOPDF\FILENAME.pdf",@"C:\PATHTOPDF\NEWNAME.pdf");
       }
   }
}
    VB.NET
    Copy Code
    Imports System.IO

Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF
Imports ImageGear.Evaluation

Module Module1
   Public Sub SaveAs(fileIn As String, fileOut As String)
       ' Initialize evaluation license.
       ImGearEvaluationManager.Initialize()
       ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

       ImGearCommonFormats.Initialize()

       ' Add support for PDF and PS files.
       ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
       ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
       ImGearPDF.Initialize()

       Using inStream As New FileStream(fileIn, FileMode.Open)
           Using outStream As New FileStream(fileOut, FileMode.Create)
               ' Load PDF document.
               Dim igDocument As ImGearDocument = ImGearFileFormats.LoadDocument(inStream)

               ' Save PDF.
               Dim pdfOptions As New ImGearPDFSaveOptions()
               ImGearFileFormats.SaveDocument(igDocument, outStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, pdfOptions)
           End Using
       End Using
       ' Dispose of the PDF component.
       ImGearPDF.Terminate()
   End Sub

   Sub Main()
       SaveAs("C:\PATHTOPDF\FILENAME.pdf", "C:\PATHTOPDF\NEWNAME.pdf.pdf")
   End Sub

End Module
  5. Now, let's go over some of the important areas in the sample code with more detail. To initialize and support processing of PDF and PS files we need:
    • CS
    • VBNET
    C#
    Copy Code
    // Initialize evaluation license.
ImGearEvaluationManager.Initialize();
ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

// Initialize common formats.
ImGearCommonFormats.Initialize();

// Add support for PDF and PS files.
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
ImGearPDF.Initialize();
    VB.NET
    Copy Code
    ' Initialize evaluation license.
ImGearEvaluationManager.Initialize()
ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

' Initialize common formats.
ImGearCommonFormats.Initialize()

' Add support for PDF and PS files.
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
ImGearPDF.Initialize()
  6. There is one main data structure that is used in this sample code: The ImGearDocument that holds the entire loaded document.
    • CS
    • VBNET
    C#
    Copy Code
    // Load PDF document.
ImGearDocument igDocument = ImGearFileFormats.LoadDocument(inStream);
    VB.NET
    Copy Code
    ' Load PDF document.
Dim igDocument As ImGearDocument = ImGearFileFormats.LoadDocument(inStream)
  7. You can save the loaded document using:
    • CS
    • VBNET
    C#
    Copy Code
    // Save PDF.
ImGearPDFSaveOptions pdfOptions = new ImGearPDFSaveOptions();
ImGearFileFormats.SaveDocument(igDocument, outStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, pdfOptions);
    VB.NET
    Copy Code
    ' Save PDF.
Dim pdfOptions As New ImGearPDFSaveOptions()
ImGearFileFormats.SaveDocument(igDocument, outStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, pdfOptions)

This sample project was created as a simple introduction to using the PDF functionality in ImageGear. For systems designed for production environments, you need to configure your projects more efficiently by only adding the resources that you need. For more information, refer to Deploying Your Product.


Windows Forms Application
User Guide > How to Work with... > PDF > Getting Started with ImageGear PDF > Tutorial: Create Your First PDF Project > Windows Forms Application

In this tutorial, you will configure a C# or VB.NET project for a Windows Forms application and use ImageGear .NET PDF capabilities. You will also learn how to open a PDF or PS file, display it on the screen, and Save the document as a new file.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "Windows Forms Application" project, using C# or VB.NET, and name the project: my_first_PDF_project
  2. If you installed ImageGear .NET 64-bit, using the Configuration Manager, create a new project platform (if you don’t have one already) for x64. Make sure your project is set to compile targeting Debug and x64. Make sure you now have $YOURLOCALPROJ\bin\x64\Debug\, and if is not there, create it.
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following packages:
      • Accusoft.ImageGear.PDF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.PDF/ )
      • Accusoft.ImageGear.ART.WinForms.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.ART.WinForms/ )
      • Accusoft.ImageGear.WinForms.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WinForms/ )
    • Manually:
      • Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      • Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Evaluation.dll
        • ImageGear.22.Art.dll
        • ImageGear22.Formats.Common.dll
        • ImageGear22.Formats.Pdf.dll
        • ImageGear22.Formats.Vector.dll
        • ImageGear22.Windows.Forms.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\ .

  4. Next, add the ImageGear Windows Forms tools to use in your GUI:
    1. In Visual Studio, go to Tools > Choose Toolbox Items...
    2. In the .NET Framework Components tab, click Browse and navigate to $INSTALLDIR\ImageGear for .NET v22\Bin\, select ImageGear22.Windows.Forms.dll, and click Open.
    3. You will see the ImGearMagnifier, ImGearPageView, ImGearPan, and ImGearThumbnailCtl controls added to the list of components. Make sure they are checked and click OK.

    Next, you will add some pertinent controls to your form. For this tutorial, keep the default names for the controls.

  5. First, create the menu on the form. From the Windows Forms toolbox, drag a MenuStrip control onto the form. Create a menu called File. Under File, add Load, Save, Next Page, and Previous Page.
  6. Second, also from the toolbox, drag the ImGearPageView control onto the form. This control will be used to display the PDF document. Set the Dock (in the Layout group) property of the imGearPageView1 control to Fill. This will cause the control to resize as the form resizes.
  7. For the last control, add a statusStrip control. After it has been added, right-click on the control and insert a StatusLabel into it. This control will be used to keep track of the displayed page number.
  8. Double-click each added menu item to create a handler.
  9. At this point your project is ready for some code. The following code can be used to load a PDF or PS file, view it using an ImGearPageView control, and save it as new file. In the next step, we will go over some important areas of this sample code.
    • CS
    • VBNET
    C#
    Copy Code
    using System;
using System.IO;
using System.Windows.Forms;

using ImageGear.Core;
using ImageGear.Display;
using ImageGear.Formats;
using ImageGear.Formats.PDF;
using ImageGear.Evaluation;

namespace my_first_PDF_project
{
   public partial class Form1 : Form
   {
       // Create empty IG document object.
       private ImGearDocument igDocument = null;
       private int currentPageIndex = 0;

       public Form1()
       {
           // Initialize evaluation license.
           ImGearEvaluationManager.Initialize();
           ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

           // Add support for PDF and PS files.
           ImGearCommonFormats.Initialize();
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
           ImGearPDF.Initialize();

           InitializeComponent();
       }

       private void loadToolStripMenuItem_Click(object sender, EventArgs e)
       {
           OpenFileDialog openFileDialogLoad = new OpenFileDialog();
           // Allow only PDF and PS files.
           openFileDialogLoad.Filter =
           ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" +
           ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS);

           if (DialogResult.OK == openFileDialogLoad.ShowDialog())
           {
               using (FileStream inputStream =
                   new FileStream(openFileDialogLoad.FileName, FileMode.Open, FileAccess.Read, FileShare.Read))
               {
                   try
                   {
                       // Load the entire the document.
                       igDocument = ImGearFileFormats.LoadDocument(inputStream);
                   }
                   catch (ImGearException ex)
                   {
                       // Perform error handling.
                       MessageBox.Show(ex.Message);
                   }
               }
               // Render first page.
               renderPage(0);
           }
       }

       private void saveToolStripMenuItem_Click(object sender, EventArgs e)
       {
           // Check if document exists.
           if (igDocument == null)
               return;

           string filename = "";
           // Open File dialog. For this sample, just allow PDF or PS.
           ImGearSavingFormats savingFormat = ImGearSavingFormats.PDF;

           using (SaveFileDialog fileDialogSave = new SaveFileDialog())
           {
               fileDialogSave.Filter = ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" +
               ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS);
               fileDialogSave.OverwritePrompt = true;
               if (fileDialogSave.ShowDialog(this) != DialogResult.OK)
               {
                   return;
               }
               filename = fileDialogSave.FileName;
           }

           // Save to output file.
           using (FileStream outputStream = new FileStream(filename, FileMode.Create, FileAccess.ReadWrite))
           {
               try
               {
                   // Save the page in the requested format.
                   ImGearFileFormats.SaveDocument(
                       igDocument,
                       outputStream,
                       0,
                       ImGearSavingModes.OVERWRITE,
                       savingFormat,
                       null);
                   MessageBox.Show("Saved {0}", filename);
               }
               // Perform error handling.
               catch (Exception ex)
               {
                   MessageBox.Show(string.Format("Could not save file {0}. {1}", filename, ex.Message));
                   return;
               }
           }
       }

       private void renderPage(int pageNumber)
       {
           // Create page to hold the content.
           ImGearPage igPage = null;
           // Load a single page from the loaded document.
           try
           {
               igPage = igDocument.Pages[pageNumber];
               if (igPage != null)
               {
                   // Create a new page display to prepare the page for being displayed.
                   ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay;
                   // Cause the page view to repaint.
                   imGearPageView1.Invalidate();
                   currentPageIndex = pageNumber;
                   toolStripStatusLabel1.Text = string.Format("{0} of {1}", pageNumber + 1, igDocument.Pages.Count);

               }
           }
           catch (ImGearException ex)
           {
               // Perform error handling.
               MessageBox.Show(ex.Message);
           }
       }

       // Properly dispose of ImGearPDF and other objects.
       protected override void OnFormClosed(FormClosedEventArgs e)
       {
           ImGearPDF.Terminate();
           imGearPageView1.Display = null;
       }

       private void nextPageToolStripMenuItem_Click(object sender, EventArgs e)
       {
           if (igDocument != null)
               if (currentPageIndex < igDocument.Pages.Count-1)
                   renderPage(currentPageIndex + 1);
       }

       private void previousPageToolStripMenuItem_Click(object sender, EventArgs e)
       {
           if (igDocument != null)
               if (currentPageIndex > 0)
                   renderPage(currentPageIndex - 1);
       }

   }
}
    VB.NET
    Copy Code
    Imports System.IO
Imports System.Windows.Forms

Imports ImageGear.Core
Imports ImageGear.Display
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF
Imports ImageGear.Evaluation

Namespace my_first_PDF_project
            Public Partial Class Form1
                        Inherits Form
                        ' Create empty IG document object.
                        Private igDocument As ImGearDocument = Nothing
                        Private currentPageIndex As Integer = 0

                        Public Sub New()
                                    ' Initialize evaluation license.
                                    ImGearEvaluationManager.Initialize()
                                    ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

                                    ' Add support for PDF and PS files.
                                    ImGearCommonFormats.Initialize()
                                    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
                                    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
                                    ImGearPDF.Initialize()

                                    InitializeComponent()
                        End Sub

                        Private Sub loadToolStripMenuItem_Click(sender As Object, e As EventArgs)
                                    Dim openFileDialogLoad As New OpenFileDialog()
                                    ' Allow only PDF and PS files.
                                    openFileDialogLoad.Filter = ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" + ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS)

                                    If DialogResult.OK = openFileDialogLoad.ShowDialog() Then
                                                Using inputStream As New FileStream(openFileDialogLoad.FileName, FileMode.Open, FileAccess.Read, FileShare.Read)
                                                            Try
                                                                        ' Load the entire the document.
                                                                        igDocument = ImGearFileFormats.LoadDocument(inputStream)
                                                            Catch ex As ImGearException
                                                                        ' Perform error handling.
                                                                        MessageBox.Show(ex.Message)
                                                            End Try
                                                End Using
                                                ' Render first page.
                                                renderPage(0)
                                    End If
                        End Sub

                        Private Sub saveToolStripMenuItem_Click(sender As Object, e As EventArgs)
                                    ' Check if document exists.
                                    If igDocument Is Nothing Then
                                                Return
                                    End If

                                    Dim filename As String = ""
                                    ' Open File dialog. For this sample, just allow PDF or PS.
                                    Dim savingFormat As ImGearSavingFormats = ImGearSavingFormats.PDF

                                    Using fileDialogSave As New SaveFileDialog()
                                                fileDialogSave.Filter = ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" + ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS)
                                                fileDialogSave.OverwritePrompt = True
                                                If fileDialogSave.ShowDialog(Me) <> DialogResult.OK Then
                                                            Return
                                                End If
                                                filename = fileDialogSave.FileName
                                    End Using

                                    ' Save to output file.
                                    Using outputStream As New FileStream(filename, FileMode.Create, FileAccess.ReadWrite)
                                                Try
                                                            ' Save the page in the requested format.
                                                            ImGearFileFormats.SaveDocument(igDocument, outputStream, 0, ImGearSavingModes.OVERWRITE, savingFormat, Nothing)
                                                            MessageBox.Show("Saved {0}", filename)
                                                ' Perform error handling.
                                                Catch ex As Exception
                                                            MessageBox.Show(String.Format("Could not save file {0}. {1}", filename, ex.Message))
                                                            Return
                                                End Try
                                    End Using
                        End Sub

                        Private Sub renderPage(pageNumber As Integer)
                                    ' Create page to hold the content.
                                    Dim igPage As ImGearPage = Nothing
                                    ' Load a single page from the loaded document.
                                    Try
                                                igPage = igDocument.Pages(pageNumber)
                                                If igPage IsNot Nothing Then
                                                            ' Create a new page display to prepare the page for being displayed.
                                                            Dim igPageDisplay As New ImGearPageDisplay(igPage)
                                                            ' Associate the page display with the page view.
                                                            imGearPageView1.Display = igPageDisplay
                                                            ' Cause the page view to repaint.
                                                            imGearPageView1.Invalidate()
                                                            currentPageIndex = pageNumber

                                                            toolStripStatusLabel1.Text = String.Format("{0} of {1}", pageNumber + 1, igDocument.Pages.Count)
                                                End If
                                    Catch ex As ImGearException
                                                ' Perform error handling.
                                                MessageBox.Show(ex.Message)
                                    End Try
                        End Sub

                        ' Properly dispose of ImGearPDF and other objects.
                        Protected Overrides Sub OnFormClosed(e As FormClosedEventArgs)
                                    ImGearPDF.Terminate()
                                    imGearPageView1.Display = Nothing
                        End Sub

                        Private Sub nextPageToolStripMenuItem_Click(sender As Object, e As EventArgs)
                                    If igDocument IsNot Nothing Then
                                                If currentPageIndex < igDocument.Pages.Count - 1 Then
                                                            renderPage(currentPageIndex + 1)
                                                End If
                                    End If
                        End Sub

                        Private Sub previousPageToolStripMenuItem_Click(sender As Object, e As EventArgs)
                                    If igDocument IsNot Nothing Then
                                                If currentPageIndex > 0 Then
                                                            renderPage(currentPageIndex - 1)
                                                End If
                                    End If
                        End Sub

            End Class
End Namespace
  10. Now, let's go over some of the important areas in the sample code with more detail. There are 2 main data structures that are used in this sample code:
    • The ImGearDocument that holds the entire loaded document
    • The ImGearPage that holds a single page from that document (one page can only be displayed on the screen at a time).
  11. To initialize and support processing of PDF and PS files we need:
    • CS
    • VBNET
    C#
    Copy Code
    // Initialize evaluation license.
ImGearEvaluationManager.Initialize();
ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

// Add support for PDF and PS files.
ImGearCommonFormats.Initialize();
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
ImGearPDF.Initialize();
    VB.NET
    Copy Code
    ' Initialize evaluation license.
ImGearEvaluationManager.Initialize()
ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

' Add support for PDF and PS files.
ImGearCommonFormats.Initialize()
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
ImGearPDF.Initialize()
  12. We load the document using:
    • CS
    • VBNET
    C#
    Copy Code
    // Load the entire the document.
igDocument = ImGearFileFormats.LoadDocument(inputStream);
    VB.NET
    Copy Code
    ' Load the entire the document.
igDocument = ImGearFileFormats.LoadDocument(inputStream)
  13. Next, we will go over the code to render a page with the ImGearPageView control:
    • CS
    • VBNET
    C#
    Copy Code
    private void renderPage(int pageNumber)
       {
           // Create page to hold the content.
           ImGearPage igPage = null;
           // Load a single page from the loaded document.
           try
           {
               igPage = igDocument.Pages[pageNumber];
               if (igPage != null)
               {
                   // Create a new page display to prepare the page for being displayed.
                   ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
                   // Associate the page display with the page view.
                   imGearPageView1.Display = igPageDisplay;
                   // Cause the page view to repaint.
                   imGearPageView1.Invalidate();
                   currentPageIndex = pageNumber;
                   toolStripStatusLabel1.Text = string.Format("{0} of {1}", pageNumber + 1, igDocument.Pages.Count);
                   Application.DoEvents();
               }
           }
           catch (ImGearException ex)
           {
               // Perform error handling.
               MessageBox.Show(ex.Message);
           }
       }
    VB.NET
    Copy Code
    Private Sub renderPage(pageNumber As Integer)
       ' Create page to hold the content.
       Dim igPage As ImGearPage = Nothing
       ' Load a single page from the loaded document.
       Try
           igPage = igDocument.Pages(pageNumber)
           If igPage IsNot Nothing Then
               ' Create a new page display to prepare the page for being displayed.
               Dim igPageDisplay As New ImGearPageDisplay(igPage)
               ' Associate the page display with the page view.
               ImGearPageView1.Display = igPageDisplay
               ' Cause the page view to repaint.
               ImGearPageView1.Invalidate()
               currentPageIndex = pageNumber

               ToolStripStatusLabel1.Text = String.Format("{0} of {1}", pageNumber + 1, igDocument.Pages.Count)
               Application.DoEvents()
           End If
       Catch ex As ImGearException
           ' Perform error handling.
           MessageBox.Show(ex.Message)
       End Try
End Sub
  14. To render one specific page we first need to create an ImGearPage object:
    • CS
    • VBNET
    C#
    Copy Code
    // Create page to hold the content.
ImGearPage igPage = null;
    VB.NET
    Copy Code
    ' Create empty IG document object.
Private igDocument As ImGearDocument = Nothing
  15. You can access a page from a document using:
    • CS
    • VBNET
    C#
    Copy Code
    igPage = igDocument.Pages[pageNumber];
    VB.NET
    Copy Code
    igPage = igDocument.Pages(pageNumber)
  16. To render a page, we need to first create an ImGearPageDisplay object that can be directly loaded into an ImGearPageView control:
    • CS
    • VBNET
    C#
    Copy Code
    // Create a new page display to prepare the page for being displayed.
ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
    VB.NET
    Copy Code
    ' Create a new page display to prepare the page for being displayed.
Dim igPageDisplay As New ImGearPageDisplay(igPage)
  17. Last, but not least, we need to appropriately dispose of all used objects:
    • CS
    • VBNET
    C#
    Copy Code
    // Properly dispose of ImGearPDF and other objects.
       protected override void OnFormClosed(FormClosedEventArgs e)
       {
           ImGearPDF.Terminate();
           imGearPageView1.Display = null;
       }
    VB.NET
    Copy Code
    ' Properly dispose of ImGearPDF and other objects.
Protected Overrides Sub OnFormClosed(e As FormClosedEventArgs)
   ImGearPDF.Terminate()
   ImGearPageView1.Display = Nothing
End Sub

This sample project was created as a simple introduction to using the PDF functionality in ImageGear. For systems designed for production environments, you need to configure your projects more efficiently by only adding the resources that you need. For more information, refer to Deploying Your Product.


Windows Presentation Foundation (WPF)
User Guide > How to Work with... > PDF > Getting Started with ImageGear PDF > Tutorial: Create Your First PDF Project > Windows Presentation Foundation (WPF)

In this tutorial, you will configure a C# or VB.NET project for a Windows Presentation Foundation (WPF) application and use ImageGear .NET PDF capabilities. You will also learn how to open a PDF or PS file, display it on the screen, and navigate through the different pages of the PDF.

The following tutorial refers specifically to 64-bit installations; for 32-bit installations:

  • Your project should already be set to compile to target Debug and x86, and you should have the directory: $YOURLOCALPROJ\bin\x86\Debug\.
  • Throughout these instructions, replace x64 with x86.
  • The 32-bit ImageGear binaries are found in $INSTALLDIR\ImageGear for .NET v22\Bin\

Using the desired version of Visual Studio (2010 or later):

  1. Create a new "WPF Application" project, using C# or VB.NET, and name the project: my_first_PDF_WPF_project
  2. If you installed ImageGear .NET 64-bit, using the Configuration Manager, create a new project platform (if you don’t have one already) for x64. Make sure your project is set to compile targeting Debug and x64. Make sure you now have $YOURLOCALPROJ\bin\x64\Debug\, and if is not there, create it.
  3. Add references and required resources into your projects in one of the following ways:
    • Recommended: use our NuGet Packages. For this project, you need the following packages:
      • Accusoft.ImageGear.PDF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.PDF/ )
      • Accusoft.ImageGear.ART.WPF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.ART.WPF/ )
      • Accusoft.ImageGear.WPF.nupkg (https://www.nuget.org/packages/Accusoft.ImageGear.WPF/ )
    • Manually:
      • Copy all files (and folders) inside $INSTALLDIR\ImageGear for .NET v22 64-bit\Bin\ to your local output bin directory in your project (i.e., $YOURLOCALPROJ\bin\x64\Debug\ ).
      • Add the following references to your project from $YOURLOCALPROJ\bin\x64\Debug\:
        • ImageGear22.Core.dll
        • ImageGear22.Evaluation.dll
        • ImageGear.22.Art.dll
        • ImageGear22.Formats.Common.dll
        • ImageGear22.Formats.Pdf.dll
        • ImageGear22.Formats.Vector.dll
        • ImageGear22.Presentation.dll
        • ImageGear22.Windows.Controls.dll
        • ImageGear22.Wpf.dll

    Your output target directory should be set to $YOURLOCALPROJ\bin\x64\Debug\

  4. Open the MainWindow.xaml screen with both the Design and XAML panels for the window visible. You will use the XAML panel to create the graphical user interface. First, in the XAML panel, create a custom alias namespace. So, add some code to the header so it looks like this:
    XAML
    Copy Code

    <Window x:Class="my_first_PDF_WPF_project.MainWindow"

    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

    xmlns:IGWC="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"

    Title="MainWindow" Height="714" Width="1035" HorizontalContentAlignment="Stretch" VerticalContentAlignment="Stretch">

    </Window>

  5. For organizational purposes we will use a Grid. Inside of that Grid, add a Menu. That Menu will have a File > Open … item that will be responsible for opening a PDF file. In the Grid, we will also add a StatusBar to offer feedback to the user. The XML code to add the mentioned controls is the following:
    XAML
    Copy Code

    <Window x:Class="my_first_PDF_WPF_project.MainWindow"

    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

    xmlns:IGWC="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"

    Title="MainWindow" Height="714" Width="1035" HorizontalContentAlignment="Stretch" VerticalContentAlignment="Stretch">

    <Grid>

    <Grid.ColumnDefinitions>

    <ColumnDefinition Width="91*" />

    <ColumnDefinition Width="4*" />

    <ColumnDefinition Width="44*" />

    <ColumnDefinition Width="888*" />

    </Grid.ColumnDefinitions>

    <Menu Height="20" HorizontalAlignment="Stretch" Name="menu" VerticalAlignment="Top" Grid.ColumnSpan="4">

    <MenuItem Name="menuItemFile" Header="File" Click="menuItemFile_Click">

    <MenuItem Name="menuItemFileOpen" Header="Open PDF ..." Click="menuItemFileOpen_Click"/>

    </MenuItem>

    </Menu>

    <StatusBar Height="25" HorizontalAlignment="Stretch" VerticalAlignment="Bottom" VerticalContentAlignment="Center" HorizontalContentAlignment="Stretch" Margin="0,0,0,-1" Grid.ColumnSpan="4">

    <StatusBarItem Name="statusLabel" DataContext="{Binding}" BorderBrush="Black" BorderThickness="0" VerticalAlignment="Center" />

    </StatusBar>

    </Grid>

    </Window>

  6. To finish the GUI, we need to add a PageView control, which will be used to display the PDF document, and the ImGearThumbnailList that will be used to navigate through the document. The entire XAML file should now look like this:
    XAML
    Copy Code

    <Window x:Class="my_first_PDF_WPF_project.MainWindow"

    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

    xmlns:IGWC="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"

    Title="MainWindow" Height="714" Width="1035" HorizontalContentAlignment="Stretch" VerticalContentAlignment="Stretch">

    <Grid>

    <Grid.ColumnDefinitions>

    <ColumnDefinition Width="91*" />

    <ColumnDefinition Width="4*" />

    <ColumnDefinition Width="44*" />

    <ColumnDefinition Width="888*" />

    </Grid.ColumnDefinitions>

    <Menu Height="20" HorizontalAlignment="Stretch" Name="menu" VerticalAlignment="Top" Grid.ColumnSpan="4">

    <MenuItem Name="menuItemFile" Header="File" Click="menuItemFile_Click">

    <MenuItem Name="menuItemFileOpen" Header="Open Document ..." Click="menuItemFileOpen_Click"/>

    </MenuItem>

    </Menu>

    <StatusBar Height="25" HorizontalAlignment="Stretch" VerticalAlignment="Bottom" VerticalContentAlignment="Center" HorizontalContentAlignment="Stretch" Margin="0,0,0,-1" Grid.ColumnSpan="4">

    <StatusBarItem Name="statusLabel" DataContext="{Binding}" BorderBrush="Black" BorderThickness="0" VerticalAlignment="Center" />

    </StatusBar>

    <IGWC:ImGearThumbnailList Name="igThumbnailList" Margin="12,26,0,30" HorizontalAlignment="Left" VerticalAlignment="Stretch" Width="90" ItemHeight="80" ItemWidth="60" SelectionChanged="igThumbnailList_SelectionChanged" Grid.ColumnSpan="3" />

    <IGWC:PageView Name="igPageView" Margin="20,26,12,30" HorizontalAlignment="Stretch" VerticalAlignment="Stretch" Background="LightGray" Grid.Column="2" Grid.ColumnSpan="2" />

    </Grid>

    </Window>

  7. Next, let's add the functionality to the controls in the MainWindow.xaml.cs file. First add some using statements and declare the some members required for this project in the .xaml.cs file. Open MainWindow.xaml.cs and add code similar to the following within the body of your MainWindow class:
    • CS
    • VBNET
    C#
    Copy Code
    using System;
using System.IO;
using System.Windows;
using System.Windows.Controls;

using ImageGear.Evaluation;
using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;

namespace my_first_PDF_WPF_project
{
   public partial class MainWindow : Window
   {
       // Current loaded PDF document.
       private ImGearPDFDocument igPdfDocument = null;

       // Directory for PDF file selection dialog.
       private string fileOpenDialogInitialDirectory;
   }
}
    VB.NET
    Copy Code
    Imports System.IO
Imports System.Windows
Imports System.Windows.Controls

Imports ImageGear.Evaluation
Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF

Namespace my_first_PDF_WPF_project
            Public Partial Class MainWindow
                        Inherits Window
                        ' Current loaded PDF document.
                        Private igPdfDocument As ImGearPDFDocument = Nothing

                        ' Directory for PDF file selection dialog.
                        Private fileOpenDialogInitialDirectory As String
            End Class
End Namespace
  8. First, we need to initialize and support processing of PDF and PS files:
    • CS
    • VBNET
    C#
    Copy Code
    public MainWindow()
       {
           InitializeComponent();

           // Initialize evaluation manager.
           ImGearEvaluationManager.Initialize();

           // Use watermark mode for evaluation license.
           ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

           // Initialize common formats.
           ImGearCommonFormats.Initialize();

           // Add PDF file format filter to filter list.
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
           ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());

           // Initialize PDF engine.
           ImGearPDF.Initialize();

           // Create page display one time.
           igPageView.Display = new ImageGear.Display.ImGearPresentationPageDisplay();

           // Prepare common images directory.
           string commonImagesDirectory = Environment.GetFolderPath(Environment.SpecialFolder.CommonDocuments);
           commonImagesDirectory = System.IO.Path.Combine(commonImagesDirectory, @"Accusoft\Common\Images");
           if (!Directory.Exists(commonImagesDirectory))
               Directory.CreateDirectory(commonImagesDirectory);

           // Update initial directory for file dialogs with common images directory.
           fileOpenDialogInitialDirectory = commonImagesDirectory;
       }
    VB.NET
    Copy Code
    Public Sub New()
            InitializeComponent()

            ' Initialize evaluation manager.
            ImGearEvaluationManager.Initialize()

            ' Use watermark mode for evaluation license.
            ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

            ' Initialize common formats.
            ImGearCommonFormats.Initialize()

            ' Add PDF file format filter to filter list.
            ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
            ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())

            ' Initialize PDF engine.
            ImGearPDF.Initialize()

            ' Create page display one time.
            igPageView.Display = New ImageGear.Display.ImGearPresentationPageDisplay()

            ' Prepare common images directory.
            Dim commonImagesDirectory As String = Environment.GetFolderPath(Environment.SpecialFolder.CommonDocuments)
            commonImagesDirectory = System.IO.Path.Combine(commonImagesDirectory, "Accusoft\Common\Images")
            If Not Directory.Exists(commonImagesDirectory) Then
                        Directory.CreateDirectory(commonImagesDirectory)
            End If

            ' Update initial directory for file dialogs with common images directory.
            fileOpenDialogInitialDirectory = commonImagesDirectory
End Sub
  9. Next, add the code for opening a PDF or PS file.
    • CS
    • VBNET
    C#
    Copy Code
    // Calls open file dialog for getting PDF file name and loads the document from this file.
       private void menuItemFileOpen_Click(object sender, RoutedEventArgs e)
       {
           try
           {
               // Initialize open file dialog.
               Microsoft.Win32.OpenFileDialog dialog = new Microsoft.Win32.OpenFileDialog();
               dialog.Filter = ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" +
               ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS);
               dialog.Title = "Open PDF Document";
               dialog.InitialDirectory = fileOpenDialogInitialDirectory;

               // Run open file dialog.
               if (dialog.ShowDialog(this) == true)
               {

                   // Store initial directory for further dialog run.
                   fileOpenDialogInitialDirectory = System.IO.Path.GetDirectoryName(dialog.FileName);

                   // Load PDF document from a file.
                   ImGearDocument igDocument;
                   using (System.IO.Stream stream = new System.IO.FileStream(dialog.FileName, System.IO.FileMode.Open, System.IO.FileAccess.Read))
                       igDocument = ImGearFileFormats.LoadDocument(stream);

                   // Check the document is PDF document.
                   if (!(igDocument is ImGearPDFDocument))
                       throw new ApplicationException("Selected document is valid document but not a PDF document.");

                   // Clear previously loaded document.
                   if (igPdfDocument != null)
                   {
                       igPdfDocument.Dispose();
                       igPdfDocument = null;
                   }

                   // Store current loaded document.
                   igPdfDocument = (ImGearPDFDocument)igDocument;

                   // Refill thumbnail list with new page thumbnails.
                   igThumbnailList.Items.Clear();
                   foreach (ImGearPDFPage page in igPdfDocument.Pages)
                       igThumbnailList.Items.Add(new ImageGear.Windows.Controls.ImGearThumbnailPage(page));

                   // Set first thumbnail in list as a current.
                   igThumbnailList.SelectedIndex = 0;

                   // Output result to the status bar.
                   statusLabel.Content = "PDF document is successfully loaded from \"" + dialog.FileName + "\".";
               }
           }
           catch (Exception exp)
           {
               // Expose the error in status bar and message box.
               statusLabel.Content = exp.Message;
               MessageBox.Show(this, exp.Message);
           }

       }

       private void menuItemFile_Click(object sender, RoutedEventArgs e)
       {

       }
    VB.NET
    Copy Code
    ' Calls open file dialog for getting PDF file name and loads the document from this file.
Private Sub menuItemFileOpen_Click(sender As Object, e As RoutedEventArgs)
            Try
                        ' Initialize open file dialog.
                        Dim dialog As New Microsoft.Win32.OpenFileDialog()
                        dialog.Filter = ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PDF) + "|" + ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.PS)
                        dialog.Title = "Open PDF Document"
                        dialog.InitialDirectory = fileOpenDialogInitialDirectory

                        ' Run open file dialog.
                        If dialog.ShowDialog(Me) = True Then

                                    ' Store initial directory for further dialog run.
                                    fileOpenDialogInitialDirectory = System.IO.Path.GetDirectoryName(dialog.FileName)

                                    ' Load PDF document from a file.
                                    Dim igDocument As ImGearDocument
                                    Using stream As System.IO.Stream = New System.IO.FileStream(dialog.FileName, System.IO.FileMode.Open, System.IO.FileAccess.Read)
                                                igDocument = ImGearFileFormats.LoadDocument(stream)
                                    End Using

                                    ' Check the document is PDF document.
                                    If Not (TypeOf igDocument Is ImGearPDFDocument) Then
                                                Throw New ApplicationException("Selected document is valid document but not a PDF document.")
                                    End If

                                    ' Clear previously loaded document.
                                    If igPdfDocument IsNot Nothing Then
                                                igPdfDocument.Dispose()
                                                igPdfDocument = Nothing
                                    End If

                                    ' Store current loaded document.
                                    igPdfDocument = DirectCast(igDocument, ImGearPDFDocument)

                                    ' Refill thumbnail list with new page thumbnails.
                                    igThumbnailList.Items.Clear()
                                    For Each page As ImGearPDFPage In igPdfDocument.Pages
                                                igThumbnailList.Items.Add(New ImageGear.Windows.Controls.ImGearThumbnailPage(page))
                                    Next

                                    ' Set first thumbnail in list as a current.
                                    igThumbnailList.SelectedIndex = 0

                                    ' Output result to the status bar.
                                    statusLabel.Content = "PDF document is successfully loaded from """ + dialog.FileName + """."
                        End If
            Catch exp As Exception
                        ' Expose the error in status bar and message box.
                        statusLabel.Content = exp.Message
                        MessageBox.Show(Me, exp.Message)
            End Try

End Sub

Private Sub menuItemFile_Click(sender As Object, e As RoutedEventArgs)

End Sub
  10. Also, the code to navigate across the pages in the PDF document using the Thumbnail list:
    • CS
    • VBNET
    C#
    Copy Code
    // Sets current selected in thumbnail list page to main page view.
       private void igThumbnailList_SelectionChanged(object sender, SelectionChangedEventArgs e)
       {
           if (igThumbnailList.SelectedIndex >= 0 && igPdfDocument != null)
           {
               igPageView.Page = igPdfDocument.Pages[igThumbnailList.SelectedIndex];
               igPageView.Update();
           }
       }
    VB.NET
    Copy Code
    ' Sets current selected in thumbnail list page to main page view.
Private Sub igThumbnailList_SelectionChanged(sender As Object, e As SelectionChangedEventArgs)
            If igThumbnailList.SelectedIndex >= 0 AndAlso igPdfDocument IsNot Nothing Then
                        igPageView.Page = igPdfDocument.Pages(igThumbnailList.SelectedIndex)
                        igPageView.Update()
            End If
End Sub
  11. And finally, the code to properly dispose of all the used controls:
    • CS
    • VBNET
    C#
    Copy Code
    // Properly dispose of PDF and other objects.
private void CloseWindow()
{
   ImGearPDF.Terminate();
   igPageView.Display = null;
   this.Close();
}
    VB.NET
    Copy Code
    ' Properly dispose of PDF and other objects.
Private Sub CloseWindow()
            ImGearPDF.Terminate()
            igPageView.Display = Nothing
            Me.Close()
End Sub

This sample project was created as a simple introduction to using the PDF functionality in ImageGear. For systems designed for production environments, you need to configure your projects more efficiently by only adding the resources that you need. For more information, refer to Deploying Your Product.


How to...
User Guide > How to Work with... > PDF > How to...

This section provides information about the following:

  • How to...
    • Load and Save a PDF
    • Convert...
      • PDF to Image
      • PDF to Multi-Page Image
      • PDF to SVG
      • Image to PDF
      • Microsoft Office Documents to PDF
    • Print a PDF
    • Merge Multiple PDFs
    • Split a PDF Document
    • Manage PDF Content
      • PDF Fonts
      • Manage PDF Metadata
      • Edit PDF Content
      • Extract Text from a PDF
      • Watermarks in a PDF
      • Containers, Dictionaries, and Layers
        • PDF Layers
      • 3D Artwork
    • Process PDF Using Multiple Threads
    • Work with PDF Format Compliance
      • About ISO Standards and Compliance
      • Verify PDF Format Compliance
      • Convert to Compliant PDF


Load and Save a PDF
User Guide > How to Work with... > PDF > How to... > Load and Save a PDF

This section provides information about the following:

  • Loading a Password Protected PDF
  • Saving as a PDF
  • Saving a Password Protected PDF
  • Exporting OCR Recognized Data to a PDF Output
  • Saving a PDF as Other Supported Formats

Loading a Password Protected PDF

To load a password protected PDF refer to PDF Security.

Saving as a PDF

ImageGear for .NET PDF component provides the ImGearPDFSaveOptions class that defines options for saving raster pages and documents to specific PDF formats like PDF/A. This class is derived from the regular ImGearSaveOptions class and could be used with the regular ImGearFileFormats.SavePage and ImGearFileFormats.SaveDocument methods that take ImGearSaveOptions parameter.

The following sample code demonstrates how to use the ImGearPDFSaveOptions class for saving raster document to PDF/A:

C# Example
Copy Code
        ImGearDocument doc = null;
        // Load raster document.
        using (FileStream fileStream = new FileStream(infile, FileMode.Open, FileAccess.Read, FileShare.Read))
        {
            doc = ImGearFileFormats.LoadDocument(fileStream, 0, -1);
        }
        // Specify PDF/A options for saving.
        ImGearPDFSaveOptions pdfOptions = new ImGearPDFSaveOptions();
        pdfOptions.PreflightOptions = new ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1);
        pdfOptions.PreflightOptions.OutputIntentColorProfile = ImGearColorProfileManager.RgbProfile;
        // Save to PDF/A file.
        using (FileStream fileStream = new FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite))
        {
            ImGearFileFormats.SaveDocument(doc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF_DEFLATE, pdfOptions);
        }
VB.NET Example
Copy Code
        Dim doc As ImGearDocument
        ' Load raster document.
        Using fileStream As FileStream = New FileStream(infile, FileMode.Open, FileAccess.Read, FileShare.Read)
            doc = ImGearFileFormats.LoadDocument(fileStream, 0, -1)
        End Using
        ' Specify PDF/A options for saving.
        Dim pdfOptions As ImGearPDFSaveOptions = New ImGearPDFSaveOptions()
        pdfOptions.PreflightOptions = New ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1)
        pdfOptions.PreflightOptions.OutputIntentColorProfile = ImGearColorProfileManager.RgbProfile
        ' Save to PDF/A file.
        Using fileStream As FileStream = New FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite)
            ImGearFileFormats.SaveDocument(doc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF_DEFLATE, pdfOptions)
        End Using
You can also use this approach for converting PDF files to PDF/A which would be effectively the same as using ImGearPDFPreflight.Convert for the original PDF document.

Saving a Password Protected PDF

To save a password protected PDF refer to PDF Security.

Exporting OCR Recognized Data to a PDF Output

See Exporting to a PDF Output Document for more information.

Saving a PDF as Other Supported Formats

See Convert... for more information.


Convert...
User Guide > How to Work with... > PDF > How to... > Convert...

This section provides information about how to convert...

  • Convert...
    • PDF to Image
    • PDF to Multi-Page Image
    • PDF to SVG
    • Image to PDF
    • Microsoft Office Documents to PDF


PDF to Image
User Guide > How to Work with... > PDF > How to... > Convert... > PDF to Image

The CreateRasterPageFromPDFPage sample demonstrates this functionality. See Samples.

The following CreateRasterPageFromPDFPage sample illustrates how you can create a raster page from a PDF page:

C#
Copy Code
using System;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;

private ImGearRasterPage CreateRasterPageFromPDFPage(ImGearPDFPage pdfPage)
       {
           // Bit depth for rasterization process. It may be changed.
           const int rasterizationBitDepth = 24;

           #region setResolution
           // Get device independent bitmap from input page.
           ImGearDIB dib = pdfPage.DIB;
           // Get resolution of source page.
           IImGearResolution resolution = dib.ImageResolution;
           // Convert source page resolution if the units are not inches.
           if (resolution.Units != ImGearResolutionUnits.INCHES)
           resolution.ConvertUnits(ImGearResolutionUnits.INCHES);
           // Get maximal size of source page for resolution calculation.
           int maximalPageSize = Math.Max(dib.Width, dib.Height);
           // Calculate X resolution for destination page so the X size of
           // destination page will be 250X250 pixels.
           int xResolution = 250 * resolution.XNumerator / resolution.XDenominator / maximalPageSize;
           // Adjust calculated resolution to 1 because there are conditions when
           // the resolution will be less or equal than 0.
           if (xResolution <= 0) xResolution = 1;
           // Calculate Y resolution for destination page so the X size of
           // destination page will be 250xX250 pixels.
           int yResolution = 250 * resolution.YNumerator / resolution.YDenominator / maximalPageSize;
           #endregion

           //Rasterize page.
           ImGearRasterPage rasterPage = pdfPage.Rasterize(rasterizationBitDepth, xResolution, yResolution);
           return rasterPage;
}
VB.NET
Copy Code
Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF

Private Function CreateRasterPageFromPDFPage(pdfPage As ImGearPDFPage) As ImGearRasterPage
            ' Bit depth for rasterization process. It may be changed.
            Const  rasterizationBitDepth As Integer = 24

            '#Region "setResolution"
            ' Get device independent bitmap from input page.
            Dim dib As ImGearDIB = pdfPage.DIB
            ' Get resolution of source page.
            Dim resolution As IImGearResolution = dib.ImageResolution
            ' Convert source page resolution if the units are not inches.
            If resolution.Units <> ImGearResolutionUnits.INCHES Then
                        resolution.ConvertUnits(ImGearResolutionUnits.INCHES)
            End If
            ' Get maximal size of source page for resolution calculation.
            Dim maximalPageSize As Integer = Math.Max(dib.Width, dib.Height)
            ' Calculate X resolution for destination page so the X size of
            ' destination page will be 250X250 pixels.
            Dim xResolution As Integer = 250 * resolution.XNumerator / resolution.XDenominator / maximalPageSize
            ' Adjust calculated resolution to 1 because there are conditions when
            ' the resolution will be less or equal than 0.
            If xResolution <= 0 Then
                        xResolution = 1
            End If
            ' Calculate Y resolution for destination page so the X size of
            ' destination page will be 250xX250 pixels.
            Dim yResolution As Integer = 250 * resolution.YNumerator / resolution.YDenominator / maximalPageSize
            '#End Region

            'Rasterize page.
            Dim rasterPage As ImGearRasterPage = pdfPage.Rasterize(rasterizationBitDepth, xResolution, yResolution)
            Return rasterPage
End Function

Remarks

Implementation of this method uses only the ImGearPDFPage.Rasterize(int bitDepth, int xResolution, int yResolution) method of ImageGear. Argument bitDepth defines the resulting image bit depth. In the above sample, the value 24 is used, however other values can be used. Arguments xResolution and yResolution define the resolution of the output raster image. For example, in the sample above, the region #region setResolution can be replaced for fixed resolutions as follows:

Copy Code
xResolution = 300;
yResolution = 300;

These resolutions will be used for the new image, i.e., in resultImage.DIB.ImageResolution.


PDF to Multi-Page Image
User Guide > How to Work with... > PDF > How to... > Convert... > PDF to Multi-Page Image

The following savePDFAsMultiplePageTIF sample illustrates how you can create a multi-page TIFF from a multi-page PDF loaded in an igDocument. In the following sample we use ImGearSavingModes to control some raster options like bit depth and scaling (to control resolution):

C#
Copy Code
using System.IO;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;

public void savePDFAsMultiplePageTIF(ImGearDocument igDocument, string outfile)
{
   // Set some raster options.
   ImGearRasterSaveOptions rasterOptions = new ImGearRasterSaveOptions();
   rasterOptions.BitDepth = 24;
   // Set scaling factor for rasterized image. Scale = 1 (default) corresponds to 72 dpi, 2 to 144 dpi, etc.
   rasterOptions.ScaleX = 4;
   rasterOptions.ScaleY = 4;

   // Save to TIF file.
   using (FileStream fileStream = new FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite))
   {
       ImGearFileFormats.SaveDocument(igDocument, fileStream, 0, ImGearSavingModes.OVERWRITE,    ImGearSavingFormats.TIF_DEFLATE, rasterOptions);
   }
}
VB.NET
Copy Code
Public Sub savePDFAsMultiplePageTIF(igDocument As ImGearDocument, outfile As String)
   ' Set some raster options.
   Dim rasterOptions As New ImGearRasterSaveOptions()
   rasterOptions.BitDepth = 24
   ' Set scaling factor for rasterized image. Scale 1 (default) corresponds to 72 dpi, 2 to 144 dpi, etc.
   'rasterOptions.ScaleX = 4;
   'rasterOptions.ScaleY = 4;

   ' Save to TIF file.
   Using fileStream As New FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite)
       ImGearFileFormats.SaveDocument(igDocument, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_DEFLATE, rasterOptions)
   End Using
End Sub

In the following sample we use an alternative approach to the one above that uses global control parameters to control some raster options like bit depth and resolution:

C#
Copy Code
using System.IO;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;

public void savePDFAsMultiplePageTIF(ImGearDocument igDocument, string outfile)
{
   // Change global control parameters for PDF resolution. ImGearSaveOptions in SaveDocument should be set to null.
   IImGearFormat pdfFilter = ImGearFileFormats.Filters.Get(ImGearFormats.PDF);

   ImGearControlParameter bitDepth = pdfFilter.Parameters.GetByName("Depth");
   ImGearControlParameter resolutionX = pdfFilter.Parameters.GetByName("ResolutionX");
   ImGearControlParameter resolutionY = pdfFilter.Parameters.GetByName("ResolutionY");
   bitDepth.Value = 24;
   resolutionX.Value = 300;
   resolutionY.Value = 300;

   // Save to TIF file.
   using (FileStream fileStream = new FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite))
   {
       ImGearFileFormats.SaveDocument(igDocument, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_DEFLATE, null);
   }
}
VB.NET
Copy Code
Public Sub savePDFAsMultiplePageTIF2(igDocument As ImGearDocument, outfile As String)
   ' Change global control parameters for PDF resolution. ImGearSaveOptions in SaveDocument should be set to null.
   Dim pdfFilter As IImGearFormat = ImGearFileFormats.Filters.[Get](ImGearFormats.PDF)

   Dim bitDepth As ImGearControlParameter = pdfFilter.Parameters.GetByName("Depth")
   Dim resolutionX As ImGearControlParameter = pdfFilter.Parameters.GetByName("ResolutionX")
   Dim resolutionY As ImGearControlParameter = pdfFilter.Parameters.GetByName("ResolutionY")
   bitDepth.Value = 24
   resolutionX.Value = 300
   resolutionY.Value = 300

   ' Save to TIF file.
   Using fileStream As New FileStream(outfile, FileMode.OpenOrCreate, FileAccess.ReadWrite)
       ImGearFileFormats.SaveDocument(igDocument, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_DEFLATE, Nothing)
   End Using
End Sub


PDF to SVG
User Guide > How to Work with... > PDF > How to... > Convert... > PDF to SVG

ImageGear for .NET provides the ability to convert and save any page from a PDF document to a Scalable Vector Graphics (SVG) file. This can be done by using one of the following API calls:

  • ImGearFileFormats.SavePage(pdfPage, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.SVG);
  • ImGearFileFormats.SaveDocument(pdfDoc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.SVG, pdfOptions);

Since SVG format is not a multi-page format, the SaveDocument API called with default options will only convert and save the first page of the provided PDF document.

This topic provides information about the following:

  • Text Conversion
  • Color Profiles
  • Password-Protected PDF Documents
  • Anti-Aliasing
  • No Thin Line Enhancement in SVG
  • ConvertPDFtoSVG Sample

Text Conversion

ImageGear for .NET PDF to SVG converter is optimized to provide the best text fidelity results. For that purpose, all PDF text elements are converted to SVG outlining paths, which are not searchable for text.

Color Profiles

ImageGear for .NET PDF to SVG color converter applies the default color space defined in the PDF document. If no default color space is defined, all PDF colors defined in CMYK color space are converted to RGB using the Windows ICM and the color profiles enabled in the ImageGear for .NET color profile manager. The color profile transformation uses the ICC profile specified in ImGearColorProfileManager.CmykProfile. If this is not set, then the default color profile distributed with ImageGear for .NET (ig_cmyk_profile.icm) is used.

Password-Protected PDF Documents

ImageGear for .NET PDF to SVG converter requires “Content Copying” permission to the source PDF document to be granted, which means that if a PDF document is secured, it should be opened with the password that allows access to its internals.

If this permission is not granted, the ImageGear for .NET PDF to SVG converter will turn on the rasterizaton mode for this document, which will rasterize any PDF page from this document prior to converting to SVG. The resolution of the raster image embedded to SVG will be set using the PDF control parameters.

Anti-Aliasing

Most SVG viewers, including Internet Explorer, Chrome, and Firefox browsers, enable edge anti-aliasing, but do not allow turning it off. Although in most cases anti-aliasing makes vector graphics look much better and smoother, there are cases when anti-aliasing leads to unintended SVG rendering effects like the following:

  • Although using a set of thin bars of different shades of a color to emulate a gradient background may look good in PDF, it may not produce the desired effect in SVG. Thin white lines may appear between bars, depending on the viewer’s zoom. It is recommended that the PDF producers use the native PDF gradients instead of emulating them.
  • Small sized text in the converted SVG may look blurry compared to the original PDF, because of the differences between the algorithms specific to PDF text anti-aliasing and anti-aliasing of the graphic paths representing text in SVG.

No Thin Line Enhancement in SVG

While the ImageGear for .NET PDF renderer provides enhanced rendering of thin lines when a PDF page is zoomed out, ensuring that 1 pixel lines are still visible even when the page is zoomed far out, SVG viewers normally don’t support that. So, thin lines converted from PDF will have the correct widths in SVG, but will be scaled proportionally and may disappear if a page is zoomed out too much.

ConvertPDFtoSVG Sample

The following ConvertPdftoSVG sample method illustrates how you can convert a PDF file to SVG file.

C#
Copy Code
      private void ConvertPdftoSVG(string inputFile, string outputFile)
       {
           ImGearPage imGearPDFPage = null;

           // Open file and load PDF page.
           using (var stream = new FileStream(inputFile, FileMode.Open, FileAccess.Read, FileShare.Read))
           {
               try
               {
                   // Load PDF page.
                   imGearPDFPage = ImGearFileFormats.LoadPage(stream, 0);
               }
               catch (ImGearException ex)
               {
                   MessageBox.Show(string.Format("Could not load file { 0}", ex.Message));
               }
           }

           // Open output file and save to SVG.
           using (var fileStream = new FileStream(outputFile, FileMode.Create, FileAccess.ReadWrite))
           {
               ImGearFileFormats.SavePage(imGearPDFPage, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.SVG);
           }
       }
VB.NET
Copy Code
   Private Sub ConvertPdftoSVG(ByVal inputFile As String, ByVal outputFile As String)
       Dim imGearPDFPage As ImGearPage = Nothing

       ' Open file and load PDF page.
       Using stream = New FileStream(inputFile, FileMode.Open, FileAccess.Read, FileShare.Read)
           Try
               ' Load PDF page.
               imGearPDFPage = ImGearFileFormats.LoadPage(stream, 0)
           Catch ex As ImGearException
               MessageBox.Show(String.Format("Could not load file { 0}", ex.Message))
           End Try
       End Using

       ' Open output file and save to SVG.
       Using fileStream = New FileStream(outputFile, FileMode.Create, FileAccess.ReadWrite)
           ImGearFileFormats.SavePage(imGearPDFPage, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.SVG)
       End Using
   End Sub

Also you can specify a background color for the converted SVG file using PDF control parameters.

C#
Copy Code
           // Get SVGBackgroundColor global control parameter.
           IImGearFormat pdfFormat = ImGearFileFormats.Filters.Get(ImGearFormats.PDF);
           ImGearControlParameter xParam = pdfFormat.Parameters.GetByName("SVGBackgroundColor");
           ImGearRGBQuad rgb = (ImGearRGBQuad)xParam.Value;

           // Select new color.
           var colorDialog = new ColorDialog
           {
               Color = System.Drawing.Color.FromArgb(rgb.Red, rgb.Green, rgb.Blue)
           };

           // Set selected color as new backround value.
           if (colorDialog.ShowDialog() == DialogResult.OK)
               xParam.Value = new ImGearRGBQuad(colorDialog.Color.R, colorDialog.Color.G, colorDialog.Color.B);
VB.NET
Copy Code
       ' Get SVGBackgroundColor global control parameter.
       Dim pdfFormat As IImGearFormat = ImGearFileFormats.Filters.[Get](ImGearFormats.PDF)
       Dim xParam As ImGearControlParameter = pdfFormat.Parameters.GetByName("SVGBackgroundColor")
       Dim rgb As ImGearRGBQuad = DirectCast(xParam.Value, ImGearRGBQuad)

       ' Select new color.
       Dim colorDialog = New ColorDialog() With{.Color = System.Drawing.Color.FromArgb(rgb.Red, rgb.Green, rgb.Blue)}

       ' Set selected color as new backround value.
       If ColorDialog.ShowDialog() = DialogResult.OK Then
           xParam.Value = New ImGearRGBQuad(ColorDialog.Color.R, ColorDialog.Color.G, ColorDialog.Color.B)
       End If


Image to PDF
User Guide > How to Work with... > PDF > How to... > Convert... > Image to PDF

The following example illustrates how to load an image file and save it as a single PDF page:

C#
Copy Code
using System;
using System.IO;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;
using ImageGear.Evaluation;

public void SaveImageAsPDF(string inputFilePathName, string outputFilePathName)
       {
           try
           {
               const int FIRST_PAGE = 0;

               // Initialize evaluation license.
               ImGearEvaluationManager.Initialize();
               ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark;

               // Initialize common formats.
               ImageGear.Formats.ImGearCommonFormats.Initialize();

               // Add support for PDF and PS files.
               ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
               ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
               ImGearPDF.Initialize();

               // Load required page from a file.
               ImGearPage page = null;
               using (Stream stream = new FileStream(inputFilePathName, FileMode.Open, FileAccess.Read))
                   page = ImGearFileFormats.LoadPage(stream, FIRST_PAGE);

               // Save page as PDF document to a file.
               using (Stream stream = new FileStream(outputFilePathName, FileMode.Create, FileAccess.Write))
                   ImGearFileFormats.SavePage(page, stream, FIRST_PAGE, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF);
           }
           catch (Exception exp)
           {
               // Write error to Console window.
               Console.WriteLine(exp.Message);
           }
           finally
           {
               // Call PDF engine terminating in any case.
               ImGearPDF.Terminate();
           }
       }
VB.NET
Copy Code
Imports System.IO

Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF
Imports ImageGear.Evaluation

Public Sub SaveImageAsPDF(inputFilePathName As String, outputFilePathName As String)
         Try
                 Const  FIRST_PAGE As Integer = 0

                 ' Initialize evaluation license.
                 ImGearEvaluationManager.Initialize()
                 ImGearEvaluationManager.Mode = ImGearEvaluationMode.Watermark

                 ' Initialize common formats.
                 ImageGear.Formats.ImGearCommonFormats.Initialize()

                 ' Add support for PDF and PS files.
                 ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
                 ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
                 ImGearPDF.Initialize()

                 ' Load required page from a file.
                 Dim page As ImGearPage = Nothing
                 Using stream As Stream = New FileStream(inputFilePathName, FileMode.Open, FileAccess.Read)
                          page = ImGearFileFormats.LoadPage(stream, FIRST_PAGE)
                 End Using

                 ' Save page as PDF document to a file.
                 Using stream As Stream = New FileStream(outputFilePathName, FileMode.Create, FileAccess.Write)
                          ImGearFileFormats.SavePage(page, stream, FIRST_PAGE, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF)
                 End Using
         Catch exp As Exception
                 ' Write error to Console window.
                 Console.WriteLine(exp.Message)
         Finally
                 ' Call PDF engine terminating in any case.
                 ImGearPDF.Terminate()
         End Try
End Sub


Microsoft Office Documents to PDF
User Guide > How to Work with... > PDF > How to... > Convert... > Microsoft Office Documents to PDF

ImageGear for .NET provides the ability to convert any Microsoft Office Open XML document currently supported by the product or any page of a Microsoft Office Open XML document and save the converted content to a PDF file. This can be done by using one of the following API calls:

  • ImGearFileFormats.SavePage(officePage, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF);
  • ImGearFileFormats.SaveDocument(officeDoc, fileStream, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, null);

ImageGear for .NET Office to PDF converter provides the conversion of all currently supported text elements, raster images, and graphic shapes for Microsoft Office Open XML formats described in Using ImageGear.Formats.Office Namespace.

Note the following conversions that take place when converting to PDF:

  • Gradients with Transparency: Microsoft Office Open XML gradients with transparency are converted as non-transparent PDF gradients.
  • Text with Gradients: Microsoft Office Open XML text with gradient fill and stroke is converted to solid PDF text with the color of the first gradient stop.
  • Patterns: Microsoft Office Open XML text with patterns is converted to solid black PDF text.
  • Word (DOCX) to PDF
  • Excel (XLSX) to PDF
  • PowerPoint (PPTX) to PDF

Word (DOCX) to PDF

This sample shows how to input a Word document in the DOCX format and output all pages as a PDF document.

ImageGear does not support MS Word 97 DOC files.

After some initializations, load the necessary ImGear filters to create an instance of Microsoft Word format for input and an instance of PDF format for output using code that looks like:

Copy Code
ImGearFileFormats.Filters.Add(ImGearOffice.CreateWordFormat());
ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat());

Next, the PDF library requires its own initialization:

Copy Code
ImGearPDF.Initialize();

Then, simply read in all pages of the Word document using the ImGearFileFormats.LoadDocument() method:

Copy Code
ImGearDocument igDocument;
using (FileStream fileStream = new FileStream(inputFileName, FileMode.Open,
       FileAccess.Read, FileShare.Read))
{
   igDocument = ImGearFileFormats.LoadDocument(fileStream);
}

Finally, write out the document as PDF using the ImGearFileFormats.SaveDocument() method with the saving format set to ImGearSavingFormats.PDF and no special options:

Copy Code
using (FileStream fileStream = new FileStream(outputFileName, FileMode.Create,
       FileAccess.ReadWrite))
{
   ImGearFileFormats.SaveDocument(igDocument, fileStream, 0,
       ImGearSavingModes.OVERWRITE, ImGearSavingFormats.PDF, null);
}

Excel (XLSX) to PDF

This sample can be easily adjusted to accept Excel Spreadsheet XSLX documents as input.

ImageGear does not support reading Excel 97-2007 XLS documents.

To accept XSLX files as input, create an instance of Microsoft Excel format after initializing ImageGear .NET:

Copy Code
ImGearFileFormats.Filters.Add(ImGearOffice.CreateExcelFormat());

and modify the sample's open file dialog to accept the *.xlsx extension:

Copy Code
ofd.Filter = @"DOCX files (*.docx)|*.docx|XLSX files (*.xlsx)|*.xslx";

PowerPoint (PPTX) to PDF

This sample can be easily adjusted to accept PowerPoint PPTX files as input.

ImageGear does not support reading legacy PowerPoint PPT files.

To accept PPTX files as input, create an instance of Microsoft PowerPoint format after initializing ImageGear .NET:

Copy Code
ImGearFileFormats.Filters.Add(ImGearOffice.CreatePowerPointFormat());

and modify the sample's open file dialog to accept the *.pptx extension:

Copy Code
ofd.Filter = @"DOCX files (*.docx)|*.docx|PPTX files (*.pptx)|*.pptx";


Print a PDF
User Guide > How to Work with... > PDF > How to... > Print a PDF

Native PDF document printing renders the document content directly to the printer, so it is fast and requires less memory.

The following is a sample method that illustrates how to print a PDF from a Windows Form project using the ImGearPDFDocument.Print() method:

C#
Copy Code
using System.Drawing.Printing;
       public void PrintPDF(ImGearDocument igDocument)
       {
           using (ImGearPDFDocument igPDFDocument = (ImGearPDFDocument)igDocument)
           {
               ImGearPDFPrintOptions printOptions = new ImGearPDFPrintOptions();
               PrintDocument printDocument = new PrintDocument();
               // Use default Windows printer.
               printOptions.DeviceName = printDocument.PrinterSettings.PrinterName;
                    // Print all pages.
               printOptions.StartPage = 0;
               printOptions.EndPage = igDocument.Pages.Count;
               igPDFDocument.Print(printOptions);
           }
           return;
       }
VB.NET
Copy Code
Imports System.Drawing.Printing
Public Sub PrintPDF(igDocument As ImGearDocument)
           Using igPDFDocument As ImGearPDFDocument = DirectCast(igDocument, ImGearPDFDocument)
               Dim printOptions As New ImGearPDFPrintOptions()
               Dim printDocument As New PrintDocument()
               ' Use default Windows printer.
               printOptions.DeviceName = printDoc.PrinterSettings.PrinterName
               ' Print all pages.
               printOptions.StartPage = 0
               printOptions.EndPage = igDocument.Pages.Count
               igPDFDocument.Print(printOptions)
           End Using
           Return
       End Sub

The .NET reference System.Drawing.dll is required for this snippet.


Merge Multiple PDFs
User Guide > How to Work with... > PDF > How to... > Merge Multiple PDFs

The following example illustrates how to merge two multi-page PDF documents into one document:

C#
Copy Code
using ImageGear.Formats.PDF;
       // Merges two PDF document into a third PDF document.
       ImGearPDFDocument MergePdfDocuments(ImGearPDFDocument igFirstDocument, ImGearPDFDocument igSecondDocument)
       {
           // ImageGear uses zero-based numeration of pages in document.
           int FIRST_PAGE_INDEX = 0;

           // Create new PDF document for result.
           ImGearPDFDocument igResultDocument = new ImGearPDFDocument();

           // Copy all pages of first document into result document.
           for (int pageIndex = FIRST_PAGE_INDEX; pageIndex < igFirstDocument.Pages.Count; pageIndex++)
               igResultDocument.Pages.Add(igFirstDocument.Pages[pageIndex].Clone());

           // Copy all pages of second document into result document.
           for (int pageIndex = FIRST_PAGE_INDEX; pageIndex < igSecondDocument.Pages.Count; pageIndex++)
               igResultDocument.Pages.Add(igSecondDocument.Pages[pageIndex].Clone());
           return igResultDocument;
       }
VB.NET
Copy Code
Imports ImageGear.Formats.PDF
' Merges two PDF document into third PDF document.
Private Function MergePdfDocuments(igFirstDocument As ImGearPDFDocument, igSecondDocument As ImGearPDFDocument) As ImGearPDFDocument

   ' ImageGear uses zero-based numeration of pages in document.
   Dim FIRST_PAGE_INDEX As Integer
   FIRST_PAGE_INDEX = 0

   ' Create new PDF document for result.
   Dim igResultDocument As New ImGearPDFDocument()

   ' Copy all pages of first document into result document.
    Dim pageIndex As Integer = FIRST_PAGE_INDEX
    While pageIndex < igFirstDocument.Pages.Count
       igResultDocument.Pages.Add(igFirstDocument.Pages(pageIndex).Clone())
       System.Math.Max(System.Threading.Interlocked.Increment(pageIndex), pageIndex - 1)
    End While

    ' Copy all pages of second document into result document.
    pageIndex = FIRST_PAGE_INDEX
    While pageIndex < igSecondDocument.Pages.Count
       igResultDocument.Pages.Add(igSecondDocument.Pages(pageIndex).Clone())
       System.Math.Max(System.Threading.Interlocked.Increment(pageIndex), pageIndex - 1)
    End While

    Return igResultDocument

End Function

This method can be extended for any document type. The main rule that must be observed for copying pages from one document to another is that the type of the documents must be the same.


Split a PDF Document
User Guide > How to Work with... > PDF > How to... > Split a PDF Document

Splitting a PDF document is the process of saving each page into a new, separate PDF document. For example, splitting a three-page PDF document will produce three, single-page PDF documents.

To split a PDF document using ImageGear .NET:

  1. Read the PDF document into a System.IO.Stream object.
  2. Read the stream using ImGearFileFormats.LoadDocument(), casting the ImGearDocument object returned to an ImGearPDFDocument object.
  3. Determine the PDF page count using the ImGearPDFDocument.Pages property.
  4. For each PDF page:
    • Construct a new ImGearPDFDocument object to create an empty PDF document.
    • Add the page to the empty PDF document using the ImGearPDFDocument.InsertPages() method.
    • Save the single-page PDF to disk or memory using the ImGearPDFDocument.Save() method.

The following is a sample method that illustrates how to split a single PDF document into several single-page PDF documents:

C#
Copy Code
using System;
using System.IO;
using System.Text;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Windows.Forms;
using ImageGear.Formats.PDF;

public void SplitPDFDocument(String inputPath, String outputDirectory)
{
   const int FIRST_PAGE = 0;
   const int ONE_PAGE = 1;

   // Ensure output directory exists.
   if ( !System.IO.Directory.Exists(outputDirectory) )
   {
       Directory.CreateDirectory(outputDirectory);
   }

   // Open file for reading.
   using ( FileStream pdfData = new FileStream(inputPath, FileMode.Open,
       FileAccess.Read) )
   {
       // Read PDF document to memory.
       using ( ImGearPDFDocument igSourceDocument = ImGearFileFormats.LoadDocument(
           pdfData, FIRST_PAGE, (int)ImGearPDFPageRange.ALL_PAGES)
           as ImGearPDFDocument )
       {
           // For each page in document.
           for ( int i = 0; i < igSourceDocument.Pages.Count; i++ )
           {
               // Construct the output filepath.
               String outputFileName = String.Format("{0}_{1}.pdf",
                   Path.GetFileNameWithoutExtension(inputPath), i + 1);
               String outputPath = System.IO.Path.Combine(outputDirectory, outputFileName);

               // Create a new empty PDF document.
               using ( ImGearPDFDocument igTargetDocument = new ImGearPDFDocument() )
               {
                   // Insert page into new PDF document.
                   igTargetDocument.InsertPages(
                       (int)ImGearPDFPageNumber.BEFORE_FIRST_PAGE, igSourceDocument,
                       i, ONE_PAGE, ImGearPDFInsertFlags.DEFAULT);

                   // Save new PDF document to file.
                   igTargetDocument.Save(outputPath, ImGearSavingFormats.PDF,
                       FIRST_PAGE, FIRST_PAGE, ONE_PAGE,
                       ImGearSavingModes.OVERWRITE);
               }
           }
       }
   }
}
VB.NET
Copy Code
Imports System
Imports System.IO
Imports System.Text

Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF

Public Sub SplitPDFDocument(ByVal inputPath As String, ByVal outputDirectory As String)

   Const FIRST_PAGE As Integer = 0
   Const ONE_PAGE As Integer = 1

   ' Ensure output directory exists.
   If Not System.IO.Directory.Exists(outputDirectory) Then
       Directory.CreateDirectory(outputDirectory)
   End If

   ' Open file for reading.
   Using pdfData As New FileStream(inputPath, FileMode.Open, FileAccess.Read)

       ' Read PDF document to memory.
       Using igSourceDocument As ImGearPDFDocument =
           TryCast(ImGearFileFormats.LoadDocument(
               pdfData, FIRST_PAGE, DirectCast(ImGearPDFPageRange.ALL_PAGES,
               Integer)), ImGearPDFDocument)

           ' For each page in document
           For i As Integer = 0 To igSourceDocument.Pages.Count

               ' Construct the output filepath
               Dim outputFileName As String = String.Format("{0}_{1}.pdf",
                   Path.GetFileNameWithoutExtension(inputPath), i + 1)
               Dim outputPath As String = System.IO.Path.Combine(outputDirectory,
                   outputFileName)

               ' Create a new empty PDF document.
               Using igTargetDocument As New ImGearPDFDocument()

                   ' Insert page into new PDF document.
                   igTargetDocument.InsertPages(
                       DirectCast(ImGearPDFPageNumber.BEFORE_FIRST_PAGE, Integer),
                       igSourceDocument, i, ONE_PAGE, ImGearPDFInsertFlags.[DEFAULT])

                   ' Save new PDF document to file.
                   igTargetDocument.Save(outputPath, ImGearSavingFormats.PDF,
                       FIRST_PAGE, FIRST_PAGE, ONE_PAGE,
                       ImGearSavingModes.OVERWRITE)

               End Using

           Next

       End Using

   End Using

End Sub

Refer to Samples documentation.


Manage PDF Content
User Guide > How to Work with... > PDF > How to... > Manage PDF Content

This section provides information about the following:

  • Manage PDF Content
    • PDF Fonts
    • Manage PDF Metadata
    • Edit PDF Content
    • Extract Text from a PDF
    • Watermarks in a PDF
    • Containers, Dictionaries, and Layers
      • PDF Layers
    • 3D Artwork


PDF Fonts
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > PDF Fonts

Document font support includes:

  • Listing the fonts available in the host system and finding a system font that matches a PDF font
  • Creating a font from the system font and encoding as well as from the specified attributes
  • Changing a font's information
  • Editing and embedding a font in the document
  • Both single and multiple byte fonts are supported


Manage PDF Metadata
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Manage PDF Metadata

You can get and set PDF document metadata corresponding to a document's Info dictionary.

You can also get and set the XMP metadata associated with a PDF or PostScript document. See the Working with XMP Metadata section for more information about the XMP metadata support in PDF and PostScript.

To manage PDF metadata you can use the GetInfo and SetInfo methods of ImGearPDFDocument. The following example illustrates the usage of these methods:

C#
Copy Code
public void SetMetadata(ImGearPDFDocument igPDFDocument)
{
    // If empty, set the dictionary key "Author" to "Accusoft."
    if (igPDFDocument.GetInfo("Author") == "")
        igPDFDocument.SetInfo("Author", "Accusoft");
    return;
}
VB.NET
Copy Code
Public Sub SetMetadata(igPDFDocument As ImGearPDFDocument)
    ' If empty, set the dictionary key "Author" to "Accusoft."
    If igPDFDocument.GetInfo("Author") = "" Then
        igPDFDocument.SetInfo("Author", "Accusoft")
    End If
    Return
End Sub


Edit PDF Content
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Edit PDF Content

The ImageGear API provides content editing functionality for creating, accessing, and editing PDF page content objects. With this API you can work with a page's content as a list of objects, such as images, text, forms. You can retain, modify, and save their data and properties.


Extract Text from a PDF
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Extract Text from a PDF

ImageGear for .NET support for text extraction includes:

  • Extracting words from a PDF document or specified page
  • Enumerating and sorting the words
  • Getting word layouts, styles, and characters

To extract text from a PDF you can use the ExtractText method. The following example shows how to convert an ImGearDocument into a string using ExtractText:

C#
Copy Code
         // Returns a string corresponding to the text extracted from the PDF.
       public string ExtractTextFromPDF(ImGearDocument igDocument)
       {
           ImGearPDFDocument pdfDocument = igDocument as ImGearPDFDocument;
           using (MemoryStream textFromPDF = new MemoryStream())
           {
               // Extract text from all pages.
               pdfDocument.ExtractText(0, igDocument.Pages.Count, ImGearPDFContextFlags.PDF_ORDER, textFromPDF);
               return System.Text.Encoding.GetEncoding(0).GetString(textFromPDF.ToArray());
           }
       }
VB.NET
Copy Code
' Returns a string corresponding to the text extracted from the PDF.
       Public Function ExtractTextFromPDF(igDoc As ImGearDocument) As String
           Dim pdfDocument As ImGearPDFDocument = DirectCast(igDoc, ImGearPDFDocument)
           Using textFromPDF As New MemoryStream()
               ' Extract text from all pages.
               pdfDocument.ExtractText(0, igDoc.Pages.Count, ImGearPDFContextFlags.PDF_ORDER, textFromPDF)
               Return System.Text.Encoding.GetEncoding(0).GetString(textFromPDF.ToArray())
           End Using
       End Function

The options parameter controls how the text is extracted. For example, given the following text in a PDF:

When options = ImGearPDFContextFlags.XY_ORDER, the call to System.Diagnostics.Debug.WriteLine would produce:

The quick brown

fox jumps over

the lazy dog. The green turtle

watched closely

and entertained.

When options = ImGearPDFContextFlags.PDF_ORDER would produce:

The quick brown fox jumps over the lazy dog. The green turtle watched closely and entertained.


Watermarks in a PDF
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Watermarks in a PDF

A digital watermark is any auxiliary data embedded into a document used for subsequent identification. Watermarks may provide contextual support to an author's content, but are otherwise independent of that content. For example, stamping a page as "DRAFT" or "CONFIDENTIAL" imparts meaning beyond any text or drawings present on that page.

PDF documents may express a digital watermark using any of the following techniques:

  • Annotations: An interactive object associated with a location on the page that displays text or an image. A variety of types may be used including Text, Free text, Rubber stamp. Watermark annotations may be used to print at a fixed position and size on a page regardless of the dimensions of the printed page.
  • Page Graphics: Graphics may include text with specific style information and color, vector line art, sampled images or shading patterns. Content representing a watermark are inserted directly into the page's content stream, possibly indistinguishable from the original content. Graphics specifically intended for watermarks may be indicated using Optional Content Groups.
  • Optional Content Groups (OCG): Collections of graphics in a PDF document can be selectively drawn or hidden by document authors or consumers. An OCG can indicate its graphics are intended as a watermark for printing.
  • Pagination Artifacts. Tagged PDF documents distinguish between original content and artifacts of the layout process, including pagination artifacts such as header, footers, page numbers. Content may be specifically designated to be a watermark.

Each of these techniques can be accomplished using ImageGear, with varying complexity and completeness. See the following subsections:

  • Annotations
  • Page Graphics
  • Optional Content Groups
  • Pagination Artifacts

Annotations

Annotations are added to PDF pages by using the ImageGear.ART namespace, which supports a subset of available PDF annotations. Refer to PDF Marks for the mapping used with PDF annotations.

ImageGear .NET does not export ART Marks to PDF Watermark annotations. Apps that require explicit PDF Watermark annotation support may use the basic object classes to create a PDF Watermark annotation object and appearance streams, as outlined in the PDF Reference under topic "Watermark Annotations".

The following sample code demonstrates creating a Text ART mark and exporting to a PDF page as a FreeText annotation:

C#
Copy Code
using System;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.ART;
using ImageGear.Windows.Forms;

public static void AddFreeTextAnnotationToPageView(ImGearPageView igPageView, String text)
{
   const Int32 BORDER_THICKNESS_IN_PIXELS = 2;
   const Int32 BOX_OPACITY_TRANSLUCENT = 100;
   const Int32 TEXT_OPACITY_TRANSLUCENT = 100;
   const Int32 MAX_HEIGHT_IN_IMAGE_PIXELS = 200;
   Int32 boxWidth = igPageView.Page.DIB.Width;
   Int32 boxHeight = Math.Min(MAX_HEIGHT_IN_IMAGE_PIXELS, igPageView.Page.DIB.Height);

   // Choose a font size that is 85% height of the box height.
   float fontSize = Convert.ToSingle(boxHeight) * 0.85f;

   // Create a text annotation.
   ImGearARTText textAnnotation = new ImGearARTText(new ImGearRectangle(0, 0, boxWidth, boxHeight),
       text, new ImGearRGBQuad(255, 0, 0), ImGearARTTextType.DIRECT_TEXT, TEXT_OPACITY_TRANSLUCENT,
       new ImGearRGBQuad(255, 0, 0), new ImGearARTBorder(new ImGearRGBQuad(0, 0, 255),
       BORDER_THICKNESS_IN_PIXELS), true,
       BOX_OPACITY_TRANSLUCENT, "Arial", fontSize, ImGearARTFontStyles.Bold, null, null);

   // Recover the page view ART page.
   ImGearARTPage igArtPage = (ImGearARTPage)igPageView.Display.ARTPage;

   // Add the text annotation to the page view ART page.
   igArtPage.AddMark(textAnnotation, ImGearARTCoordinatesType.IMAGE_COORD);

   // Export the ART Text mark to the PDF page as a FreeText annotation.
   ImGearART.SavePage(igArtPage, igPageView.Page);

   // Cause the page view to redraw.
   igPageView.Invalidate();
}
VB.NET
Copy Code
   Public Shared Sub AddFreeTextAnnotationToPageView(ByVal igPageView As ImGearPageView, ByVal text As [String])
       Const BORDER_THICKNESS_IN_PIXELS As Int32 = 2
       Const BOX_OPACITY_TRANSLUCENT As Int32 = 100
       Const TEXT_OPACITY_TRANSLUCENT As Int32 = 100
       Const MAX_HEIGHT_IN_IMAGE_PIXELS As Int32 = 200
       Dim boxWidth As Int32 = igPageView.Page.DIB.Width
       Dim boxHeight As Int32 = Math.Min(MAX_HEIGHT_IN_IMAGE_PIXELS, igPageView.Page.DIB.Height)

       ' Choose a font size that is 85% height of the box height.
       Dim fontSize As Single = Convert.ToSingle(boxHeight) * 0.85F

       ' Create a text annotation.
       Dim textAnnotation As New ImGearARTText(New ImGearRectangle(0, 0, boxWidth, boxHeight), text, New ImGearRGBQuad(255, 0, 0), ImGearARTTextType.DIRECT_TEXT, TEXT_OPACITY_TRANSLUCENT, New ImGearRGBQuad(255, 0, 0), _
        New ImGearARTBorder(New ImGearRGBQuad(0, 0, 255), BORDER_THICKNESS_IN_PIXELS), True, BOX_OPACITY_TRANSLUCENT, "Arial", fontSize, ImGearARTFontStyles.Bold, _
        Nothing, Nothing)

       ' Recover the page view ART page.
       Dim igArtPage As ImGearARTPage = DirectCast(igPageView.Display.ARTPage, ImGearARTPage)

       ' Add the text annotation to the page view ART page.
       igArtPage.AddMark(textAnnotation, ImGearARTCoordinatesType.IMAGE_COORD)

       ' Export the ART Text mark to the PDF page as a FreeText annotation.
       ImGearART.SavePage(igArtPage, igPageView.Page)

       ' Cause the page view to redraw.
       igPageView.Invalidate()
   End Sub

Refer to the AddWatermarkToPDFPage sample. See Samples.

See the PDF Reference topic "Annotations" for additional information.

Page Graphics

Watermarks expressed as PDF page graphics are added using the ImageGear.Formats.PDF namespace. This namespace provides classes for content editing modeled after graphics objects and operators described in the PDF Reference.

The following snippet demonstrates placing a 24-bpp RGB bitmap at the bottom left corner of a PDF page:

Adjustments are required to successfully add images utilizing other pixel formats and color spaces in accordance to the image XObject discussion in the PDF reference.

C#
Copy Code
using System;
using System.IO;
using System.Windows.Forms;

using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Formats.PDF;

public static void AddRGB24ImageToPdfPage(ImGearPDFPage igPDFPage, ImGearPage igImage)
{
   const Int32 BITS_PER_BYTE = 8;
   try
   {
       // Acquire the PDF page content.
       using (ImGearPDEContent content = igPDFPage.GetContent())
       {
           // Extract pixel data from RGB24 image.
           Int32 strideInBytes = (igImage.DIB.Width * igImage.DIB.BitDepth + BITS_PER_BYTE - 1)
                                   / BITS_PER_BYTE;
           Byte[] pixelData = new Byte[strideInBytes * igImage.DIB.Height];
           for (int row = 0; row < igImage.DIB.Height; row++)
           {
               ImGearArrayRef raster = igImage.DIB.GetRaster(row);
               Array.Copy((Byte[])raster.Content, raster.Offset, pixelData, row * strideInBytes,
                   strideInBytes);
           }

           // Create a DeviceRGB PDE Colorspace for RGB24 image.
           ImGearPDEColorSpace igPDEColorSpace = new ImGearPDEColorSpace(
               new ImGearPDFAtom("DeviceRGB"));

           // Create a PDE Image attributes for image Form XObject
           ImGearPDEImageAttrs igPDEImageAttrs = new ImGearPDEImageAttrs();
           igPDEImageAttrs.Width = igImage.DIB.Width;
           igPDEImageAttrs.Height = igImage.DIB.Height;
           igPDEImageAttrs.Flags = ImGearPDEImageAttrFlags.EXTERNAL;
           igPDEImageAttrs.BitsPerComponent = 8;

           // Create a transform matrix that places the image at the bottom-left corner
           // of the PDF page.
           ImGearPDFFixedMatrix igPDETransformMatrix = new ImGearPDFFixedMatrix();
           igPDETransformMatrix.A = ImGearPDF.DoubleToFixed(((double)igImage.DIB.Width));
           igPDETransformMatrix.B = (int)ImGearPDFFixedValues.ZERO;
           igPDETransformMatrix.C = (int)ImGearPDFFixedValues.ZERO;
           igPDETransformMatrix.D = ImGearPDF.DoubleToFixed(((double)igImage.DIB.Height));
           igPDETransformMatrix.H = (int)ImGearPDFFixedValues.ZERO;
           igPDETransformMatrix.V = (int)ImGearPDFFixedValues.ZERO;

           // Create a filter to compress RGB24 pixel data using the discrete cosine
           // transform (DCT) technique based on the JPEG standard.
           ImGearPDEFilterArray igPDEFilterArray = new ImGearPDEFilterArray();
           ImGearPDFBasDict igDict = new ImGearPDFBasDict((ImGearPDFDocument)igPDFPage.Document,
                                        false, 3);
           igDict.PutInt(new ImGearPDFAtom("Columns"), false, igImage.DIB.Width);
           igDict.PutInt(new ImGearPDFAtom("Rows"), false, igImage.DIB.Height);
           igDict.PutInt(new ImGearPDFAtom("Colors"), false, 3);
           ImGearPDEFilterSpec igPDEFilterSpec = new ImGearPDEFilterSpec();
           igPDEFilterSpec.Name = new ImGearPDFAtom("DCTDecode");
           igPDEFilterSpec.DecodeParams = igDict;
           igPDEFilterSpec.EncodeParams = igDict;
           igPDEFilterArray.AddSpec(igPDEFilterSpec);

           // Create the PDE image.
           using (ImGearPDEImage igPDEImage = new ImGearPDEImage(igPDEImageAttrs,
                   igPDETransformMatrix, ImGearPDEImageDataFlags.DECODED, igPDEColorSpace, null,
                   igPDEFilterArray, null, pixelData))
           {
               // Add the PDEImage to the PDF page graphics.
               content.AddElement((int)ImGearPDEInsertElement.AFTER_LAST, igPDEImage);
               igPDFPage.SetContent();

               // Force refresh of PDF page content.
               igPDFPage.ResetDisplayCache();
           }
       }
   }
   finally
   {
       // Release the PDF page content.
       igPDFPage.ReleaseContent();
   }
}
VB.NET
Copy Code
Public Shared Sub AddRGB24ImageToPdfPage(ByVal igPDFPage As ImGearPDFPage, ByVal igImage As ImGearPage)
       Const BITS_PER_BYTE As Int32 = 8
       Try
           ' Acquire the PDF page content.
           Using content As ImGearPDEContent = igPDFPage.GetContent()
               ' Extract pixel data from RGB24 image.
               Dim strideInBytes As Int32 = (igImage.DIB.Width * igImage.DIB.BitDepth + BITS_PER_BYTE - 1) / BITS_PER_BYTE
               Dim pixelData As [Byte]() = New [Byte](strideInBytes * igImage.DIB.Height - 1) {}
               For row As Integer = 0 To igImage.DIB.Height - 1
                   Dim raster As ImGearArrayRef = igImage.DIB.GetRaster(row)
                   Array.Copy(DirectCast(raster.Content, [Byte]()), raster.Offset, pixelData, row * strideInBytes, strideInBytes)
               Next

               ' Create a DeviceRGB PDE Colorspace for RGB24 image.
               Dim igPDEColorSpace As New ImGearPDEColorSpace(New ImGearPDFAtom("DeviceRGB"))

               ' Create a PDE Image attributes for image Form XObject
               Dim igPDEImageAttrs As New ImGearPDEImageAttrs()
               igPDEImageAttrs.Width = igImage.DIB.Width
               igPDEImageAttrs.Height = igImage.DIB.Height
               igPDEImageAttrs.Flags = ImGearPDEImageAttrFlags.EXTERNAL
               igPDEImageAttrs.BitsPerComponent = 8

               ' Create a transform matrix that places the image at the bottom-left corner
               ' of the PDF page.
               Dim igPDETransformMatrix As New ImGearPDFFixedMatrix()
               igPDETransformMatrix.A = ImGearPDF.DoubleToFixed(CDbl(igImage.DIB.Width))
               igPDETransformMatrix.B = CInt(ImGearPDFFixedValues.ZERO)
               igPDETransformMatrix.C = CInt(ImGearPDFFixedValues.ZERO)
               igPDETransformMatrix.D = ImGearPDF.DoubleToFixed(CDbl(igImage.DIB.Height))
               igPDETransformMatrix.H = CInt(ImGearPDFFixedValues.ZERO)
               igPDETransformMatrix.V = CInt(ImGearPDFFixedValues.ZERO)

               ' Create a filter to compress RGB24 pixel data using the discrete cosine
               ' transform (DCT) technique based on the JPEG standard.
               Dim igPDEFilterArray As New ImGearPDEFilterArray()
               Dim igDict As New ImGearPDFBasDict(DirectCast(igPDFPage.Document, ImGearPDFDocument), False, 3)
               igDict.PutInt(New ImGearPDFAtom("Columns"), False, igImage.DIB.Width)
               igDict.PutInt(New ImGearPDFAtom("Rows"), False, igImage.DIB.Height)
               igDict.PutInt(New ImGearPDFAtom("Colors"), False, 3)
               Dim igPDEFilterSpec As New ImGearPDEFilterSpec()
               igPDEFilterSpec.Name = New ImGearPDFAtom("DCTDecode")
               igPDEFilterSpec.DecodeParams = igDict
               igPDEFilterSpec.EncodeParams = igDict
               igPDEFilterArray.AddSpec(igPDEFilterSpec)

               ' Create the PDE image.
               Using igPDEImage As New ImGearPDEImage(igPDEImageAttrs, igPDETransformMatrix, ImGearPDEImageDataFlags.DECODED, igPDEColorSpace, Nothing, igPDEFilterArray, _
                Nothing, pixelData)
                   ' Add the PDEImage to the PDF page graphics.
                   content.AddElement(CInt(ImGearPDEInsertElement.AFTER_LAST), igPDEImage)
                   igPDFPage.SetContent()

                   ' Force refresh of PDF page content.
                   igPDFPage.ResetDisplayCache()
               End Using
           End Using
       Finally
           ' Release the PDF page content.
           igPDFPage.ReleaseContent()
       End Try
   End Sub

Refer to the AddWatermarkToPDFPage sample. See Samples.

See the PDF Reference topic "Graphics" for additional information.

Optional Content Groups

Watermark optional content can be added to PDF pages using the ImageGear.Formats.PDF namespace, which provides classes for layer management.

Refer to PDF Layers for guidance on using the ImageGear.Formats.PDF namespace to manage watermarks with Optional Content Groups (OCG).

The PDF demo sample demonstrates creating OCGs. To designate a watermark intended for printing, add an Optional Content Print Usage dictionary with Subtype name "Watermark" to that OCG, represented with an ImGearPDFLayer object:

C#
Copy Code
// Create Print Usage dictionary
ImGearPDFBasDict igPrintUsageDict = new ImGearPDFBasDict( igPDFDocument, false, 2 );
igPrintUsageDict.PutName( new ImGearPDFAtom("Subtype"), false, new ImGearPDFAtom( "Watermark" ));
igPrintUsageDict.PutName( new ImGearPDFAtom("PrintState"), false, new ImGearPDFAtom( "ON" ));

// Add Print Usage dictionary to OCG group named "WatermarkLayer"
ImGearPDFLayer igWatermarkLayer = igPDFDocument.CreateLayer( "WatermarkLayer" );
igWatermarkLayer.SetUsageInfo( new ImGearPDFAtom("Print"), igPrintUsageDict );

See the PDF Reference topic "Making Graphical Content Optional" for additional information.

Pagination Artifacts

Watermarks expressed as Pagination Artifacts can be added using the ImageGear.Formats.PDF namespace, which provides classes to create a marked-content sequence in accordance with the PDF Reference.

This usage is not demonstrated in any sample presently.

See the PDF Reference topic "Real Content and Artifacts" for additional information.


Containers, Dictionaries, and Layers
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Containers, Dictionaries, and Layers

Before creating a container, you need to create one or more layers using the View > Layers menu. Make sure to create some simple elements like text, paths, or images as well.

To create a container:

  1. Right-click on the PDF page and choose Create > Container.
  2. You will be prompted to select all the layers you want to associate with the containers dictionary, which will affect the container's visibility.
  3. You also need to select the visibility policy and check all the elements you want to include into the new container. When a container is created, a new dictionary is automatically created as well.

To show or hide the container's elements use View > Layers to change the layer's state to ON or OFF.

To rearrange the container's elements you can right-click to delete the existing container, which will free its elements and create the new one.

Also refer to PDF Layers.


PDF Layers
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > Containers, Dictionaries, and Layers > PDF Layers

The following objects are related to PDF Layers and are responsible for their visibility:

  • Layers
  • Dictionaries
  • Containers
  • PDF Objects and Layers Diagram
  • Visibility Policy

Layers

Each layer has a name and a visibility state for the containers connected to the layer through a Dictionary. The visibility state can have one of two values - ON or OFF.

Dictionaries

Each dictionary contains the array of layers and a Boolean property, which takes all the layers' states as input and applies the visibility policy to the layers' state values producing the Boolean result whether or not to display all the objects from the dictionary's container. The output can have one of two values - ON or OFF.

Containers

Each container is an arbitrary set of PDF elements or other containers. Each container is associated with a dictionary. The container and all its elements (including the other containers) are displayed when its dictionary's visibility policy Boolean property results with ON.

The following diagram shows the relationship between containers and the other PDF document objects:

PDF Objects and Layers Diagram

The following diagram shows interconnection between PDF objects and layers:

Visibility Policy

A Dictionary Boolean property defines the visibility policy. It can be one of the following:

  • AllOn - equivalent to "AND" for all input parameters
  • AnyOn - equivalent to "OR" for all input parameters
  • AnyOff - equivalent to "NOT-OR" for all input parameters
  • AllOff - equivalent to "NOT-AND" for all input parameters

In other words:

AllOn | All the containers from the dictionary will be displayed when all the input layers' states are 'ON'
AnyOn | All the containers from the dictionary will be displayed when at least one of the input layers state is 'ON'
AnyOff | All the containers from the dictionary will be displayed when at least one of the input layers state is 'OFF'
AllOff | All the containers from the dictionary will be displayed when all the input layers' states are 'OFF'

For more information, see the following API sections: ImGearPDFDictionary Class, ImGearPDFDocument Class, and ImGearPDFLayer Class.


3D Artwork
User Guide > How to Work with... > PDF > How to... > Manage PDF Content > 3D Artwork

Starting with version 1.7, PDF introduces the capability for collections of 3D objects, such as those used by CAD formats, to be embedded in PDF files. Such collections are called 3D models, and PDF refers to them as 3D Artwork. In PDF documents, 3D Artwork is represented by 3D annotations stored in Universal 3D (U3D) format.

The ImageGear.Formats.PDF namespace allows the following 3D features:

  • 3D content can be rendered within a page.
  • Multiple instances of 3D data can appear within a page or document.
  • Specific views of 3D artwork can be available, including a default view that is displayed initially and other views that can be selected.
  • Users can rotate and move 3D data, enabling them to examine complex objects from any angle or orientation.

This section provides information about the following:

  • Working Process
  • U3D XML Import and Export

Working Process

ImageGear 3D Artwork processing integrates the following namespaces:

  • ImageGear.Formats.PDF Namespace a PDF content reader and writer.
  • ImageGear.Formats.U3D Namespace a U3D format decoder and encoder.
  • ImageGear.ART Namespace an Image annotation mark used to represent 3D Artwork.
  • ImageGear.ART.Forms Namespace an Interactive GUI forms and toolbar.
  • ImageGear.Vector Namespace a Vector data storage and API for interaction.

3D PDF Artwork is converted into the ART Image mark referencing a vector ImGearPage Class, so it can be edited, interacted with, and/or saved back to PDF.

3D Interaction is possible in the ART RUN Mode, by clicking over the mark and using the popup 3D toolbar. Users can rotate, scale, and move 3D data, as well as change light and view settings.

U3D XML Import and Export

The vector Image mark representing 3D data can be exported to XML in the U3D format. While saving to XML, vector ImGearPage associated with the Image mark will be converted to U3D stream and saved to XML Data tag. While loading from XML, U3D stream will be loaded as a vector ImGearPage and will be attached to the Image mark.


Process PDF Using Multiple Threads
User Guide > How to Work with... > PDF > How to... > Process PDF Using Multiple Threads

While the ImageGear.Formats.PDF Namespace is thread safe and can be used from the multiple threads, it has some limitations. The ImageGear .NET PDF component must be initialized and terminated on each thread that it is used using ImGearPDF.Initialize() and ImGearPDF.Terminate() methods, respectively. Applications can use ImageGear .NET PDF to process PDF documents with multiple threads, provided that each PDF document is only operated on by the thread that created/opened it. ImageGear .NET PDF objects may only be used by the thread that created it.

Refer to the sample SplitPDFUsingMultipleThreads for an example of an ImageGear .NET PDF multi-threaded operation (see PDF Samples).


Work with PDF Format Compliance
User Guide > How to Work with... > PDF > How to... > Work with PDF Format Compliance

This section provides information about the following:

  • Work with PDF Format Compliance
    • About ISO Standards and Compliance
    • Verify PDF Format Compliance
    • Convert to Compliant PDF


About ISO Standards and Compliance
User Guide > How to Work with... > PDF > How to... > Work with PDF Format Compliance > About ISO Standards and Compliance

PDF/A and PDF/X standards are defined by the International Organization for Standardization (ISO).

  • PDF/A standards apply to long-term archiving of electronic documents. The most widely used standards for PDF archiving are PDF/A-1a and PDF/A-1b (for less stringent requirements).
  • PDF/X standards apply to graphic content exchange. The most widely used standards for a print publishing workflow are several PDF/X formats: PDF/X-1a, PDF/X-3, and PDF/X-4.

For more information on PDF/X and PDF/A, see the ISO website.

This section provides information about the following:

  • PDF/A
  • PDF/X

PDF/A

Level A conforming files shall adhere to all of the requirements of the ISO 19005-1:2005 specification.

PDF/A

PDF/A is a file format based on PDF. It provides a mechanism for representing electronic documents in a manner that preserves their visual appearance over time, independent of the tools and systems used for creating, storing, or rendering the files.

PDF/A-1a

A file meeting this conformance level is said to be a "conforming PDF/A -1a file."

PDF/A-1b

In recognition of the varying preservation needs of the diverse user communities making use of PDF files, the ISO 19005-1:2005 specification defines a Level B conformance level. Level B conforming files shall adhere to all of the requirements of the specification except those applicable to Level A only.

A file meeting this conformance level is said to be a "conforming PDF/A-1b file."

The Level B conformance requirements are intended to be those minimally necessary to ensure that the rendered visual appearance of a conforming file is preservable over the long term. However, Level B conforming files might not have sufficiently rich internal information to allow for the preservation of the document's logical structure and content text stream in natural reading order, which is provided by Level A conformance. The requirements for Level A conformance place greater responsibilities on writers of conforming files and those preparing such files, but these requirements allow for a higher level of document preservation service and confidence.

PDF/X

PDF/X is a PDF based format for the exchange of object-based data where individual objects may be in either vector or raster data structures. PDF/X defines a data format and its usage to permit the predictable dissemination of a compound entity to one or more locations, as color-managed, CMYK, gray, RGB, and/or spot color data, in a form ready for final print reproduction, by transfer of a single file. This file contains all the content information necessary to process and render the document, as intended by the sender, coded inside a single PDF file. No other parts, either external files nor internally embedded files, are required or permitted. This exchange requires no prior knowledge of the sending and receiving environments and is sometimes referred to as "blindi" exchange. It is platform- and transport-independent.

PDF/X-3:2003 conforming files shall adhere to all of the requirements of the ISO 15930-6:2003 specification defining "Prepress digital data exchange using PDF -- Part 6: Complete exchange of printing data suitable for colour-managed workflows using PDF 1.4 (PDF/X-3)."

A file meeting this conformance level is said to be a "conforming PDF/X-3 file."


Verify PDF Format Compliance
User Guide > How to Work with... > PDF > How to... > Work with PDF Format Compliance > Verify PDF Format Compliance

ImageGear for .NET provides the ImGearPDFPreflight.VerifyCompliance method to validate if a PDF document was created in compliance with PDF/A or PDF/X standards.

This method does not change the original PDF document; it just analyzes the content of a PDF document and reports detected incompliance. The verifier report is returned as a tree, grouped by the common document part and the pages. Each node in the report tree represented by ImGearPDFPreflightReport class corresponds to an incompliance with PDF/A or PDF/X standards.

The status code of each reported incompliance node can have one of the following ImGearPDFPreflightStatusCode values:

  • Fixable – reports incompliance that can be fixed by the automated PDF Converter.
  • Unfixable – reports incompliance that cannot be fixed by the automated PDF Converter. Such incompliance should be fixed using the ImageGear PDF editing API.

PDF annotations can only be verified while they reside in a PDF document. Loading PDF annotation to ART will detach them from the PDF document and make them unavailable for PDF/A or PDF/X compliance validation.

The following example illustrates how a PDF document can be verified for compliance with one of the PDF standards.

  • CS
  • VBNET
C#
Copy Code
using ImageGear.Formats.PDF;

// Verification for compliance with PDF standards results.
enum CompliantResult
{
   // Document is not compliant and cannot be converted to given profile.
   CR_CANNOT_CONVERT,
   // Document is not compliant and can be converted to given profile.
   CR_CAN_BE_CONVERTED,
   // Document is compliant with given profile.
   CR_COMPLIANT
}

// Checks the document for compliance with standard.
CompliantResult IsPDFDocumentCompliantToProfile(ImGearPDFDocument igDocument, ImGearPDFPreflightProfile profile)
{
   ImGearPDFPreflightReport report;
   using(ImGearPDFPreflight preflight = new ImGearPDFPreflight((ImGearPDFDocument)igDocument))
   report = preflight.VerifyCompliance(profile, 0, -1);
   CompliantResult result;
   if (report.Code == ImGearPDFPreflightReportCodes.SUCCESS)
       result = CompliantResult.CR_COMPLIANT;
   else if (report.Status == ImGearPDFPreflightStatusCode.Fixable)
       result = CompliantResult.CR_CAN_BE_CONVERTED;
   else
       result = CompliantResult.CR_CANNOT_CONVERT;
   return result;
}
VB.NET
Copy Code
Imports ImageGear.Formats.PDF

' Verification for compliance with PDF standards results.
Enum CompliantResult
            ' Document is not compliant and cannot be converted to given profile.
            CR_CANNOT_CONVERT
            ' Document is not compliant and can be converted to given profile.
            CR_CAN_BE_CONVERTED
            ' Document is compliant with given profile.
            CR_COMPLIANT
End Enum

' Checks the document for compliance with standard.
Private Function IsPDFDocumentCompliantToProfile(igDocument As ImGearPDFDocument, profile As ImGearPDFPreflightProfile) As CompliantResult
            Dim report As ImGearPDFPreflightReport
            Using preflight As New ImGearPDFPreflight(DirectCast(igDocument, ImGearPDFDocument))
                        report = preflight.VerifyCompliance(profile, 0, -1)
            End Using
            Dim result As CompliantResult
            If report.Code = ImGearPDFPreflightReportCodes.SUCCESS Then
                        result = CompliantResult.CR_COMPLIANT
            ElseIf report.Status = ImGearPDFPreflightStatusCode.Fixable Then
                        result = CompliantResult.CR_CAN_BE_CONVERTED
            Else
                        result = CompliantResult.CR_CANNOT_CONVERT
            End If
            Return result
End Function


Convert to Compliant PDF
User Guide > How to Work with... > PDF > How to... > Work with PDF Format Compliance > Convert to Compliant PDF

ImageGear for .NET provides the ImGearPDFPreflight.Convert method to run an automatic PDF to PDF/A conversion, with or without preceding verification.

This method changes the original PDF document (in memory) by fixing all Fixable incompliance nodes. If all incompliance nodes in a PDF document are fixable, that PDF document will be converted into a PDF/A compliant document. The converter report is returned as a tree, grouped by the common document part and the pages. Each node in the report tree represented by ImGearPDFPreflightReport class corresponds to incompliance with PDF/A standard. All fixed incompliance nodes in the report provide details of the corresponding fix.

Raster to PDF/A

This version of the ImageGear for .NET PDF component allows PDF to PDF/A conversion for all PDF files produced directly from raster files by saving them to PDF with ImageGear for .NET. The following automatic fixes are done during this conversion:

Problem Area | Fix Description
OutputIntent | All uncalibrated color spaces are replaced with a provided color profile (must be RGB or CMYK). Note that images may be converted to a new color space, which could change the file size. Particularly, the bit depth and compression of the 1-bit images will be changed to either 24- or 32-bits per pixel.
LZW and JPEG 2000 Compression | Since LZW and JPEG 2000 compressions are prohibited in PDF/A compliant files, all LZW and JPEG 2000 streams in PDF document are recompressed, which would change the file size.
Header and Metadata | ImageGear for .NET automatically fills in all values in PDF document headers to ensure PDF/A compliance.

Saving PDF/A Documents

There are two ways to save converted PDF/A documents. Choose one of the following methods described below that best fits into your current workflow:

ImGearFileFormats.SaveDocument Method

If you need to convert a PDF document to PDF/A quickly, without displaying it or otherwise working with it, then saving the PDF document with the ImGearFileFormats.SaveDocument method is the best choice. See the Load and Save a PDF topic for an example on how to convert a document to PDF/A using this method.

The saveOptions parameter of the ImGearFileFormats.SaveDocument method must not be null, and the ImGearPDFSaveOptions.PreflightOptions property must be set for the saved PDF to be PDF/A compliant. This is true even if the ImGearPDFPreflight.Convert method was called manually on the PDF document prior to saving it. If no PreflightOptions are specified, then the saved PDF will not be PDF/A compliant.

ImGearDocument.Save Method

Alternatively, the ImGearPDFDocument.Save method can be used if your application uses a manual process for converting PDF documents to PDF/A or performs other actions on the PDF opened in memory. In this case, the ImGearPDFPreflight.Convert method must be called on the document before it is saved. When you are ready, call the ImGearPDFDocument.Save method to save the changes in the PDF/A document to a file or memory stream.

This process is convenient when using ImageGear.Recognition to create searchable image PDFs that are PDF/A compliant. See the Exporting to a PDF Output Document topic for an example of how to do this.

The following example illustrates how a PDF document can be converted to a PDF document compliant with the PDFA-1a standard.

  • CS
  • VBNET
C#
Copy Code
// ImGearPDFPreflightProfile.PDFA_1A_2005 is the constant value for checking for PDFA-a1 standard. It may be changed for checking for other standards,
       // e.g. PDFA_1A_2005, PDFA_1B_2005, PDFX_3_2003.
       ImGearPDFPreflightConvertOptions conversionOptions = new ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1);

       // Convert PDF document to PDFA
       void ConvertPdfToCompliantWithPDFA(ImGearPDFDocument pdfDocument)
       {
           ImGearPDFPreflightReport report;
           // Perform conversion of PDF document to PDFA-1a standard.
           using (ImGearPDFPreflight preflight = new ImGearPDFPreflight((ImGearPDFDocument)pdfDocument))
               report = preflight.Convert(conversionOptions);
           // Create error message if document was not converted.
           if (report.Status != ImGearPDFPreflightStatusCode.Fixed)
               throw new ApplicationException("Given PDF document cannot be converted to PDFA-1a standard.");
       }
VB.NET
Copy Code
' ImGearPDFPreflightProfile.PDFA_1A_2005 is the constant value for checking for PDFA-a1 standard. It may be changed for checking for other standards,
' e.g. PDFA_1A_2005, PDFA_1B_2005, PDFX_3_2003.
Private conversionOptions As New ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1)

' Convert PDF document to PDFA
Private Sub ConvertPdfToCompliantWithPDFA(pdfDocument As ImGearPDFDocument)
            Dim report As ImGearPDFPreflightReport
            ' Perform conversion of PDF document to PDFA-1a standard.
            Using preflight As New ImGearPDFPreflight(DirectCast(pdfDocument, ImGearPDFDocument))
                        report = preflight.Convert(conversionOptions)
            End Using
            ' Create error message if document was not converted.
            If report.Status <> ImGearPDFPreflightStatusCode.Fixed Then
                        Throw New ApplicationException("Given PDF document cannot be converted to PDFA-1a standard.")
            End If
End Sub


Vector Formats
User Guide > How to Work with... > Vector Formats

The ImageGear.Vector Namespace provides native support for vector data as used by the following CAD/vector formats:

  • CGM
  • DGN
  • DWF
  • DWG
  • DXF
  • HPGL (HPGL/2)
  • U3D
  • SVG

To work with these formats, add them to ImageGear's global formats list, as follows:

C#
Copy Code
ImGearFileFormats.Filters.Insert(0, ImGearCGM.CreateCGMFormat());
ImGearFileFormats.Filters.Insert(0, ImGearDGN.CreateDGNFormat());
ImGearFileFormats.Filters.Insert(0, ImGearDWF.CreateDWFFormat());
ImGearFileFormats.Filters.Insert(0, ImGearCAD.CreateCADFormat());
ImGearFileFormats.Filters.Insert(0, ImGearHPGL.CreateHPGLFormat());
ImGearFileFormats.Filters.Insert(0, ImGearU3D.CreateU3DFormat());
ImGearFileFormats.Filters.Insert(0, ImGearSVG.CreateSvgFormat());

Use ImageGear.Vector Namespace to manipulate and process CAD/Vector images.

When you load any of these formats, the resulting ImGearPage Class object is not automatically rasterized at load time. The data is kept in vector form for display and processing. It's possible to display the vector data from different viewpoints and edit individual vector entities. The vector data can also be rasterized, converting it to a bitmap form.

This section provides information about the following:

  • Working with Vector Data
  • Loading a Vector Drawing
  • Rasterizing a Vector Drawing
  • Displaying and Manipulating Vector Data
  • Disposal of Vector Data
  • 3D Visualization API


Working with Vector Data
User Guide > How to Work with... > Vector Formats > Working with Vector Data

ImageGear for .NET provides native support for vector formats. Examples of such formats include PDF and and CAD/vector file formats such as DXF, DWG, CGM, DGN, HPGL, and U3D. When you load any of these vector formats, the resulting page object is of type ImGearVectorPage, which is derived from ImGearPage Class. The page is not automatically rasterized at load time. Instead, its data is kept in vector form for display and processing.

You can work with a vector page as either a general ImGearPage Class object or a more specific ImGearVectorPage object. ImGearVectorPage provides a Rasterize Method that you can use to create a rasterized copy of the vector page.

An even more specific type of page is ImGearVectPage Class, which is derived from ImGearVectorPage. Pages loaded from CAD/vector file formats are available as ImGearVectPage Class. This object is part of the ImageGear.Vector Namespace. It provides properties and methods for controlling display and manipulation of vector data.

ImageGear vector renderer takes advantage of standard system rendering APIs which may be hardware accelerated. Due to differences in graphics chipsets, settings, drivers, and operating systems, performance and appearance (in particular, lighting effects) may vary. It is recommended that you tune and test your application for the environments on which you will be deploying.


Loading a Vector Drawing
User Guide > How to Work with... > Vector Formats > Loading a Vector Drawing

Loading a vector drawing is done using the same methods used to load other types of images. However, before loading the drawing, you must first enable support for the vector formats you want to use. For example:

C#
Copy Code
//Placed at start of source file.
using ImageGear.Vector;
using ImageGear.Formats;
using ImageGear.Formats.CAD;
using ImageGear.Formats.HPGL;
using ImageGear.Formats.DGN;
using ImageGear.Formats.CGM;
C#
Copy Code
//Placed during application load.
ImGearFileFormats.Filters.Add(ImGearCAD.CreateDWGFormat());
ImGearFileFormats.Filters.Add(ImGearCAD.CreateDXFFormat());
ImGearFileFormats.Filters.Add(ImGearHPGL.CreateHPGLFormat());
ImGearFileFormats.Filters.Add(ImGearDGN.CreateDGNFormat());
ImGearFileFormats.Filters.Add(ImGearCGM.CreateCGMFormat());


Rasterizing a Vector Drawing
User Guide > How to Work with... > Vector Formats > Rasterizing a Vector Drawing

To rasterize a vector drawing, use the Rasterize Method of ImGearVectPage Class. This creates a copy of the drawing in bitmap form. For example:

C#
Copy Code
if (igPage is ImGearVectorPage)
    igPage = ((ImGearVectorPage)igPage).Rasterize();

To control the size of the rasterized bitmap, you can do one of following:

  • Before loading the vector drawing, set the Width filter control parameter of the format filter used to load the drawing to the desired width of the rasterized image in pixels. (The height will be calculated automatically based on the aspect ratio of the drawing.)
  • Call the Resize Method of ImGearProcessing Class before calling the Rasterize Method. This will allow you to specify the rasterized dimensions in pixels.
See Also
Use Filter Control Parameters


Displaying and Manipulating Vector Data
User Guide > How to Work with... > Vector Formats > Displaying and Manipulating Vector Data

Vector drawings are displayed using the normal ImageGear display methods. However, there is a specific API for controlling display and manipulation of the vector data. ImGearVectPage Class provides a property called VectorData Property, which returns an ImGearVectorData Class object that can be used to access a drawing's vector data. This object provides methods and properties for working with individual vector entities as well as controlling how the vector data is displayed.

Also see the C# Vector sample for a demonstration of the use of ImGearVectorData Class.

This section provides information about the following:

  • Displaying and Manipulating Vector Data
    • Working with Gradient Filling


Working with Gradient Filling
User Guide > How to Work with... > Vector Formats > Displaying and Manipulating Vector Data > Working with Gradient Filling

Gradient filling properties are encapsulated in ImGearVectorGradient Class. Objects of this class are attached to ImGearVectorFilltype Class objects.

There are two types of gradient fillings: linear and radial. They are represented by ImGearVectorGradientLinear Class and ImGearVectorGradientRadial Class, respectively.

A linear gradient is defined by its start and end points. A radial gradient is defined by a start point and an outer circle. The start point should be located inside the outer circle, but not necessarily in its center. Coordinates of the gradient can be absolute or relative (to the bounding rectangle of the entity that uses the gradient).

The color of the gradient is defined by an array of stops. A stop comprises a pair of offset and color. Stop offsets are relative to gradient coordinates. 0.0 corresponds to the start point, 1.0 corresponds to the end points, in the case of a linear gradient, or to a point at the outer circle, in the case of radial gradient. If the first stop offset is greater than 0.0, or the last stop offset is less than 1.0, the gradient is expanded according to its SpreadMethod. Gradient color is linearly interpolated between the stops.

A gradient filling can be transformed with an affine matrix.


Disposal of Vector Data
User Guide > How to Work with... > Vector Formats > Disposal of Vector Data

ImGearVectorData class provides a standard .NET Dispose method. It's recommended that you call this method whenever vector data is no longer needed, such as when a vector drawing is being unloaded or replaced. If the Dispose method is not called, the vector data will consume memory until .NET garbage collection occurs.


3D Visualization API
User Guide > How to Work with... > Vector Formats > 3D Visualization API

The classes ImGear3DVisualization Class, ImGear3DVisualizationVerifier Class and ImGearIsosurfaceOptions Class present a set of properties and methods for generating an isosurface for 3D objects.

The 3D algorithm works on the set of images that should comprise a 3D object, and generate an isosurface for 3D visualization. It allows the options of adding "cover-up" slices at both ends, and also limiting the surface depth to reduce the number of triangles in the isosurface. Both of these two options, along with a few others, can be passed to the algorithm through an object of type ImGearIsosurfaceOptions Class.

Usually, you need to create an object of ImGearIsosurfaceOptions Class to store the values of options to be passed to the isosurface algorithm. There is no need to explicitly instantiate any object for class ImGear3DVisualization Class, since the only public method in the ImGear3DVisualization Class, GenerateIsosurface Method, is a static method . ImGear3DVisualization Class also has a static member Verifier Property of type ImGear3DVisualizationVerifier Class that can be used to check whether an ImGearDocument Class can be used to calculate an isosurface. The user should use this Verifier Property instead of instantiating such an object.

The algorithm itself takes an ImGearDocument Class object as the data source, so there is no limitation as far as the image format is concerned. It is the user's responsibility to somehow read data from the images and store them in an ImGearDocument Class object. It is important to make sure that the slices of images in the ImGearDocument Class are in the desired order, as the order will be the same in the 3D object.

This algorithm generates an ImGearVectPage Class as a result, in which the vertices of triangles together with the normals at those vertices are included. This ImGearVectPage Class must be associated with an ImGearVectorView Class object in order to visualize it.

C#
Copy Code
// Declare an ImGearDocument object and load it with data.
ImGearDocument igDocument = new ImGearDocument();
// ......
// Load images into igDocument
// ......
// Call function CanApplyGenerateIsosurface() on igDocument to
// check whether it is suitable for the algorithm
if (!ImGear3DVisualization.Verifier.CanApplyGenerateIsosurface(igDocument))
{
    // Show some error message regarding this fact that igDocument
    // is not suitable
    return;
}
// Instantiate an object of type ImGearIsosurfaceOptions for the
// options to be passed to the algorithm
ImGearIsosurfaceOptions isoOptions = new ImGearIsosurfaceOptions();
// Set the values for the members of isoOptions, usually, a
// dialog should be presented for the end user to set/modify these
// options
isoOptions.IsoValue = 120.0; // the intensity of pixels on the surface,
// this needs to be determined BEFOREHAND.
isoOptions.IsDoNorms = true;
/// .....
// Call function GenerateIsosurface to generate the isosurface
ImGearVectPage igVectPage = ImGear3DVisualization.GenerateIsosurface(igDocument, isoOptions);

For a complete sample program, please see the "Medical" sample.


SVG Images
User Guide > How to Work with... > Vector Formats > SVG Images

The ImageGear.Formats.SVG Namespace provides the API to create SVG vector format, and belongs to the ImageGear22.Formats.Vector.dll assembly. This namespace provides read and write support for the SVG format.

To enable it in your project, specify the following directive:

C# Example
Copy Code
using ImageGear.Formats.SVG;
VB.NET Example
Copy Code
Imports ImageGear.Formats.SVG

Displaying SVG Images

ImageGear SVG vector renderer uses WPF (Windows Presentation Framework) functionality. If loaded, the SVG page is supposed to be displayed or rasterized using the ImGearVectorPage.Rasterize(), then the ImageGear22.Presentation.dll assembly should be initialized, otherwise an ImGearException will be thrown, indicating that the Presentation assembly is not initialized. In order to initialize the Presentation assembly please do following:

  • Add a reference from your project’s settings to the ImageGear22.Presentation.dll
  • Add the following call prior to using any SVG functionality (e.g., before or after file formats initializations):
C# Example
Copy Code
ImageGear.Display.ImGearPresentation.Initialize();
VB.NET Example
Copy Code
ImageGear.Display.ImGearPresentation.Initialize()
If you are going to load/save SVG files, then Presentation initialization is not required.


U3D Format
User Guide > How to Work with... > Vector Formats > U3D Format

The ImageGear.Formats.U3D Namespace provides the API to create the U3D vector format, and belongs to the ImageGear22.Formats.Vector.dll assembly. This namespace provides read and write support for the following features of the Universal 3D format:

  • CLOD Progressive Mesh
  • Normals
  • Colors (diffuse and specular)
  • Views
  • Lights
  • Textures
  • Transparency
  • Linesets
  • Pointsets

For information about using the CAD/Vector components, see Vector Formats.


Recognition
User Guide > How to Work with... > Recognition

ImageGear offers a comprehensive full-page OCR solution.

  • Output to:
    • Image over text PDF
    • Plain text PDF
    • Microsoft Office 2007, Office 97: Word and Excel
    • RTF
    • HTML
    • XML
  • Zone-based recognition
  • Dictionary support
  • Image Preprocesssing
    • Deskew
    • Despeckle
    • Inversion
    • Orientation
    • Bitonal Reduction
    • Resolution Enhancement
  • Image Cleanup
    • Deskew
    • Despeckle
    • Auto Orient

See ImageGear.Recognition Namespace and ImageGear.Recognition.Forms Namespace for more information.

The ImageGear.Recognition namespace API offers a set of objects that provide access to document recognition technology. It enables you to build OCR applications for the Windows .NET development environment.

Portions of this document are excerpted from OmniPage Capture SDK 18.6 reference materials. Copyright © 2011 Nuance Communications, Inc. All Rights Reserved. Nuance and the Nuance logo are trademarks or registered trademarks of Nuance Communications, Inc. or its affiliates in the United States and/or other countries.

This core software module, referred to hereafter as the recognition engine, provides unsurpassed recognition accuracy for almost any document, including those produced on typewriters, dot-matrix printers, ink-jet printers, laser printers, and phototypesetters, as well as photocopied and faxed versions of any documents.

The figure below illustrates a simple application that takes a page image as input and produces recognized text in a variety of output formats.

This section provides information about the following:

  • Recognition
    • About the ImageGear Recognition API
    • Work with the Recognition API
      • Error Handling
      • Object Structure of the Recognition API
      • Top-Level Object Lifetime and Disposal
      • Importing Images into the Recognition API
    • Recognition API and Multi-Threading
      • Walkthrough: Multi-Threaded Recognition
    • Prepare the Image for Recognition
      • Pre-Process the Image
        • INVERSION
        • DESKEWING
        • ROTATION and MIRRORING
        • DESPECKLING
        • RESOLUTION ENHANCEMENT
        • BLANK PAGE DETECTION
      • Work with Zones
        • Add Zones
          • Auto-Zone
          • Add Zones Manually
          • Add Zones from a Zone File
        • Detect Tables without Visible Cell Separators
          • Example: Define a Zone Manually
          • Example: Update a Zone
    • Recognition
      • Recognition Modules
      • The Recognition Process
        • Recognize a Multi-Page Document
        • Recognize a Single-Page Document
      • Structured Data Output
      • OCR Performance Considerations
      • Define the Character Set
        • Recognition of a Bi-Lingual Document
        • Character Set with No Language Selection
        • Language Selection, LanguagesPlus Characters, and Local Filter
        • Multiple Languages, Global and Local Filters, FilterPlus Characters
      • Recognized Data Kept in Memory
    • Recognition.Forms
    • Checking
      • Improving Accuracy with the Checking Subsystem
        • Spell Checking
        • UD-Checking
        • User-Written Checking
      • Applying Checking
        • Spell Checking Languages
        • Spell Checking with Automatic Spell Language Selection
        • UD-Checking Prerequisites
      • Preparing and Maintaining the User Dictionary
    • Recognition Output
      • Code Pages
      • Exporting Recognized Data Directly to Text Formats
      • Exporting to a PDF Output Document
      • Exporting to a Formatted Output Document
      • Format Retention in Final Output Documents
      • Embedded Images in Final Output Documents
      • Confidence Reporting
      • Progress Indication
      • Processing Statistics
    • Recognition Namespace Specifications
      • Characters and Code Pages
      • Code Page List
        • Customized Code Pages
        • Code Page Ignored during Converting to the Output
      • Output Text Format List
      • Language Dictionary List
      • Vertical Dictionary List
      • Specifications for the Recognition Modules
        • Filling Method - Recognition Module Combinations
        • Recognition Modules and the Widest Available Character Set
        • Recognition Modules and Filters
        • Recognition Modules and Trade-off Settings
        • Recognition Modules and the Checking Subsystem
        • DOT 9-Pin Draft Dot-Matrix Recognition Module
        • FRX Multi-Lingual Omnifont Recognition Module
        • MOR Multi-Lingual Omnifont Recognition Module
        • MTX Omnifont Recognition Module
        • PLUS2W and PLUS3W Omnifont Recognition Modules
        • Asian Recognition Module
    • Migrating from ImageGear v16 Recognition
      • API Elements Removed from ImageGear v17.3
      • API Elements Added in ImageGear v17.3
      • API Elements Modified in ImageGear v17.3
      • Classes Declared as Sealed in ImageGear 17.3


About the ImageGear Recognition API
User Guide > How to Work with... > Recognition > About the ImageGear Recognition API

The ImageGear.Recognition Namespace API enables you to build OCR applications for the Windows .NET development environment. An application using the Recognition API can do the following:

  • Accept as input any image file format supported by ImageGear. This image data can be binary, gray, or color.
  • Recognize a document image and export text in any format defined by the recognition engine. These formats include 8-bit text, HTML, XML and Word processor formats such as MS Word or WordPerfect.
  • Select the language or languages of documents to be recognized. The list includes English, Eastern and Western European languages, Asian languages, Cyrillic based languages (Russian), the Baltic languages, Turkish, and Greek. Documents with multiple languages can be recognized with accuracy because the API allows the application to specify the set of languages for recognition.
  • Enable end users to verify text during the recognition process.
  • Increase recognition accuracy with built-in and user-defined dictionaries.
  • Output confidence values for post-recognition processing.
  • Automatically segment the page to correctly recognize text on pages with complex or irregular layouts, including tables, reverse video, and line art as well.
  • Allow the user to manage delineate zones of a document page and then specify treatment for those zones. This includes the ability to correct the OCR engine's automatic segmentation between the segmentation phase and the recognition phase.
  • Process both text and graphics. The recognition software's ability to distinguish graphics from text can provide the basis of a compound document processing system.
  • Automatically detect fax, dot matrix, and other degraded documents and compensate accordingly.
  • Use a scalable voting architecture that provides developers with 2 pre-made voting interfaces (OmniPage and PLUS) and direct access to 3 leading OCR engines (MOR, MTX, and FireWorX).
  • Recognize handwritten text using a numbers only module or alphanumeric module.


Work with the Recognition API
User Guide > How to Work with... > Recognition > Work with the Recognition API

This code demonstrates loading and recognizing the TEST1.TIF image file. The image contains English, machine-printed text. The result will be saved in the TEST1.TXT text file.

C#
Copy Code
//Placed at top of file
using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Recognition;
C#
Copy Code
   ImGearRecognition igRecognition = new ImGearRecognition();
   ImGearPage igPage;
   using (FileStream localFile = new FileStream("TEST1.TIF", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
   ImGearRecPage igRecPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
   igRecognition.OutputManager.CodePage = "Windows ANSI";
   igRecognition.OutputManager.Level = ImGearRecOutputLevel.NOFORMAT;
   igRecognition.OutputManager.Format = "Converters.Text.Text";
            igRecPage.Recognize();
            ImGearRecDocument document = ImGearRecDocument.Create(null);
            document.InsertPage(igRecPage, -1);
   igRecognition.OutputManager.WriteDocument(document, "TEST1.TXT");
            document.Dispose();
            igRecognition.Dispose();
VB .NET
Copy Code
Dim igRecognition As New ImGearRecognition()
Dim igPage As ImGearPage
Using localFile As New FileStream("TEST1.TIF", FileMode.Open)
      igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
Dim igRecPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))

igRecognition.OutputManager.CodePage = "Windows ANSI"
igRecognition.OutputManager.Level = ImGearRecOutputLevel.NOFORMAT
igRecognition.OutputManager.Format = "Converters.Text.Text"

igRecPage.Recognize()

Dim document As ImGearRecDocument = ImGearRecDocument.Create(Nothing)
document.InsertPage(igRecPage, -1)
igRecognition.OutputManager.WriteDocument(document, "TEST1.TXT")
document.Dispose()
igRecognition.Dispose()

This section provides information about the following:

  • Work with the Recognition API
    • Error Handling
    • Object Structure of the Recognition API
    • Top-Level Object Lifetime and Disposal
    • Importing Images into the Recognition API


Error Handling
User Guide > How to Work with... > Recognition > Work with the Recognition API > Error Handling

The ImageGear Recognition API reports errors in the same way as other ImageGear APIs. When an error occurs in the underlying Nuance modules, ImageGear throws an ImGearException with ErrorCode of REC_ENGINE_FAILURE. You can use the Value1 property of ImGearException to obtain the original error code from the recognition engine. This error code is a member of the ImGearRecErrorCodes enumeration.


Object Structure of the Recognition API
User Guide > How to Work with... > Recognition > Work with the Recognition API > Object Structure of the Recognition API

The Recognition API uses a simple object structure with two top-level objects: ImGearRecognition, which represents the recognition engine, and ImGearRecPage, which represents a page with an associated image and recognition data. Visually, the hierarchy looks like the following:

ImGearRecognition
+ - Modules (ImGearRecModuleCollection)
| + - [] (indexer) (ImGearRecModule)
| + - MOR (ImGearRecMORSettings)
+ - Preprocessing (ImGearRecPreprocessingSettings)
+ - Recognition (ImGearRecRecognitionSettings)
| + - UserDictionary (ImGearRecUserDictionary)
+ - OutputManager (ImGearRecOutputManager)
+ - Formats (ImGearRecOutputFormatCollection)
+ - [] (indexer) (ImGearRecOutputFormat)

ImGearRecPage
+ - Image (ImGearRecImage)
+ - Statistics (ImGearRecStatistics)
+ - Zones (ImGearRecZoneCollection)
+ - [] (indexer) (ImGearRecZone)


Top-Level Object Lifetime and Disposal
User Guide > How to Work with... > Recognition > Work with the Recognition API > Top-Level Object Lifetime and Disposal

The ImGearRecognition Object

The ImGearRecognition object represents the recognition engine. When this object is instantiated, the native recognition engine is initialized. For any additional ImGearRecognition objects that are instantiated in the same process, they will not re-initialize the recognition engine, only obtain a reference to it. The recognition engine will remain initialized until:

  • All references to each ImGearRecognition object instance and any associated objects cease to exist and garbage collection occurs, or
  • The application calls the Dispose Method for each ImGearRecognition instance.

The Dispose Method lets the application shut down the recognition engine immediately, freeing its resources. The application is responsible for not attempting to use the recognition engine after having called the Dispose Method. It is acceptable to instantiate a new ImGearRecognition object afterwards and use that object.

The ImGearRecPage Object

The ImGearRecPage object represents a page with associated image and recognition data. This object can only be instantiated by the ImportPage Method of ImGearRecognition. Resources associated with an ImGearRecPage object will continue to be in use until:

  • All references to the ImGearRecPage object and any associated child objects (i.e., not ImGearRecognition) cease to exist and garbage collection occurs, or
  • The application calls the Dispose Method.

The Dispose Method lets the application free resources associated with the ImGearRecPage object. In order to minimize resource usage, it's recommended to explicitly call this Dispose Method whenever an ImGearRecPage object is no longer needed by the application. The application is responsible for not attempting to use an ImGearRecPage object or its associated child objects after having called its Dispose Method.

Common Reasons to Call the Dispose Method

Note that, under normal circumstances, the application is not required to call a Dispose Method. The most common reasons to call this method are:

  • To minimize memory usage by disposing of ImGearRecPage objects that are no longer needed,
  • To be able to shut down and re-initialize the recognition engine.

When the application adds an ImGearRecPage object to an ImGearRecDocument object, the latter takes ownership of the internal data of ImGearRecPage object, which then becomes invalid. If the application needs to re-recognize the image that has been added to a document, it should re-import it from ImGearPage. There’s no need to dispose a page explicitly after it has been added to a document.


Importing Images into the Recognition API
User Guide > How to Work with... > Recognition > Work with the Recognition API > Importing Images into the Recognition API

The Recognition engine uses its own internal image storage. To supply recognition engine with input data, you should first load an image to ImageGear storage (ImGearPage). You can load images from any ImageGear supported image location, such as file, URL, or memory, or retrieve images from a scanner. Then you can import the image into Recognition image storage (ImGearRecPage Class). Use the ImGearRecognition. ImportPage Method for this.

If the source ImGearPage contains a grayscale image, the import method can convert the imported image to a bitonal one. If the source ImGearPage contains a color image, the import method can convert the imported image to grayscale or bitonal. The way this method will handle the different image types (such as bitonal, grayscale, or color images) is called the primary color reduction mode. The reduction mode applied during the execution of this method is specified by the ImGearRecPreprocessingSettings.PrimaryReductionMode Property.

Use the ImGearRecImage.Export Method to export the pixel data from ImGearRecPage Class to ImGearPage.

Note that pixel data is copied into ImGearRecPage Class object rather than shared between ImGearPage and ImGearRecPage Class. If you perform some preprocessing operation on the recognition page, and would like to access the modified image, for example, in order to display it, you'll need to export the image to an ImGearPage.


Recognition API and Multi-Threading
User Guide > How to Work with... > Recognition > Recognition API and Multi-Threading

The Recognition API can be used in a multi-threaded application. However, it is generally the application's responsibility to ensure that the different recognition activities (e.g., pre-processing, decomposition, recognition, etc.) occur sequentially for any given image or page.

Multiple instances of the ImGearRecognition object are now supported in a single process. While all instances of this object will access the same underlying native Recognition engine, each instance operates on its own set of pages and documents. Each instance can use the shared global collection of Recognition settings if instantiated with the default constructor. This means that changing settings (e.g., ImGearRecOutputManager.Format) in one instance will affect all other instances using the global settings. To isolate the Recognition settings for each instance, use the overloaded constructor, ImGearRecognition(bool). This will force each instance to use its own collection of unique settings.

Using multiple instances of the ImGearRecognition object in separate threads enables the application to perform recognition activities on different images and pages in parallel. However, it is important to remember that for each page, the recognition process must occur sequentially, meaning that a page must first be imported and pre-processed before it can be recognized and exported. Also, access to the underlying formatted output module is synchronized, so only one instance can export to a formatted output document at a time.

No re-entrance is allowed within the same thread. This can occur when the API is firing an event. When the focus of control is in the application-defined event handler, no methods of the Recognition API can be called.

This section provides information about the following:

  • Recognition API and Multi-Threading
    • Walkthrough: Multi-Threaded Recognition

Memory Usage Best Practices

With the ability to open and recognize multiple images at once, it becomes the responsibility of the developer to ensure that the amount of memory being consumed by this process does not exceed the limitations of the system. The following points should always be considered when using the Recognition API, but especially when calling it within multiple threads or when large images are to be recognized:

  • The ImGearRecognition.ImportPage method will create a copy of the imported ImGearRasterPage which will be used exclusively by the recognition engine. Care should be taken to account for this memory overhead in your application.
  • The Recognition API uses native binaries and therefore inherits from the IDisposable interface. The Dispose methods of the recognition objects should be called as soon as the objects are no longer needed in the application.
  • ImageGear will not monitor memory usage for you. Failure to do so can result in Out Of Memory Exceptions in high-stress applications using multiple threads and/or large images.


Walkthrough: Multi-Threaded Recognition
User Guide > How to Work with... > Recognition > Recognition API and Multi-Threading > Walkthrough: Multi-Threaded Recognition

The ImageGear Recognition assembly provides you with the ability to perform recognition activities on multiple images in parallel. However, you will want to ensure that the amount of memory being consumed by this process does not exceed the limitations of the system. This can occur if, for example, all pages of a large PDF are opened at once and then sent to the Recognition assembly for processing.

An alternative to the “all-at-once” processing style mentioned above is a processing technique where smaller chunks of images are opened, processed, exported and closed in an assembly line style. This technique ensures that only a specified number of images are opened and being processed at one time, keeping a consistent and manageable memory footprint throughout the process.

This walkthrough describes this technique using the System.Threading.Tasks.Parallel class included in the .NET 4.0 Framework. In this walkthrough, you will create a .NET 4 windows application that processes all pages of a PDF file while ensuring a controlled memory footprint throughout the task.

Creating the Project

This section describes how to create the project for this sample:

  1. Start Visual Studio and create a new Windows Forms Application project in C# named ParallelSample.
  2. In Visual Studio, add the following ImageGear references to your project (note: assembly versions may differ):
  • ImageGear22.Core
  • ImageGear22.Evaluation
  • ImageGear22.Formats.Advanced
  • ImageGear22.Formats.Common
  • ImageGear22.Formats.Pdf
  • ImageGear22.Recognition
  • ImageGear22.Windows.Forms

Creating the Page Processor Class

This section describes how to create the class that will perform the parsing and recognition of the PDF file using multiple threads:

  1. In Visual Studio, add a new class to the ParallelSample project called PageProcessorTest.
  2. Add the following using statements to the top of the class file. This code imports the proper types for use in the class.
C# Example
Copy Code
using System;
using System.IO;
using System.Threading.Tasks;
using ImageGear.Core;
using ImageGear.Evaluation;
using ImageGear.Formats;
using ImageGear.Formats.PDF;
using ImageGear.Recognition;

VB.NET Example
Copy Code
Imports System
Imports System.IO
Imports System.Threading.Tasks
Imports ImageGear.Core
Imports ImageGear.Evaluation
Imports ImageGear.Formats
Imports ImageGear.Formats.PDF
Imports ImageGear.Recognition
  3. Add the following code to initialize a new instance of the class. This code sets up licensing, initializes the ImageGear Formats assembly and adds the required format filters. In this sample, we are only supporting the PDF and PostScript formats:
C# Example
Copy Code
public PageProcessorTest()
{
    // Initialize evaluation manager.
    ImGearEvaluationManager.Initialize();
    //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
    //methods must be called to distribute the runtime.***
    //ImGearLicense.SetSolutionName("YourSolutionName");
    //ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
    //Manually Reported Runtime licenses also require the following method
    //call to SetOEMLicenseKey.
    //ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing...");
    ImGearCommonFormats.Initialize();
    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());
    ImGearPDF.Initialize();
}

VB.NET Example
Copy Code
Public Sub Initialize()
 ' Initialize evaluation manager.
 ImGearEvaluationManager.Initialize()

 '***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey
 'methods must be called to distribute the runtime.***
 'ImGearLicense.SetSolutionName("YourSolutionName")
 'ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345)
 'Manually Reported Runtime licenses also require the following method
 'call to SetOEMLicenseKey.
 'ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensing..."); ImGearCommonFormats.Initialize ()
 ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
 ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat())
 ImGearPDF.Initialize()
End Sub
  4. Add the following code to create a private method that processes a chunk of pages. This code works on an array of ImGearRecPage objects to pre-process and recognize them in parallel. After each page has been processed, the results are added to the output document and the pages used for recognition are disposed to free up memory for the next chunk.
C# Example
Copy Code
private void ProcessPageChunk(ImGearRecPage[] recPagesChunk, ImGearRecDocument document)
{
    Parallel.ForEach(recPagesChunk, pg =>
    {
        if (pg != null)
        {
            pg.Image.Preprocess();
            pg.Recognize();
        }
    });
    for (int i = 0; i < recPagesChunk.Length; i++)
    {
        if (recPagesChunk[i] != null)
        {
            document.InsertPage(recPagesChunk[i], -1);
            // Dispose of the rec page from this last chunk. It has
            // already been added to an output document at this point
            // so the recognized page data will be included in the
            // output document.
            // Processing the document in "chunks" also allows the
            // application to maintain a predictable memory footprint.
            recPagesChunk[i].Dispose();
            recPagesChunk[i] = null;
        }
    }
}
VB.NET Example
Copy Code
Private Sub ProcessPageChunk(ByRef recPagesChunk As ImGearRecPage(), ByRef document As ImGearRecDocument)
 Parallel.ForEach(recPagesChunk, Sub(pg)
          If pg IsNot Nothing Then
           Dim recPage As ImGearRecPage = DirectCast(pg, ImGearRecPage)
           If recPage IsNot Nothing Then
            recPage.Image.Preprocess()
            recPage.Recognize()
           End If
          End If
         End Sub)
 For i As Integer = 0 To recPagesChunk.Length - 1
  If recPagesChunk(i) IsNot Nothing Then
   document.InsertPage(recPagesChunk(i), -1)
   ' Dispose of the rec page from this last chunk. It has
   ' already been added to an output document at this point
   ' so the recognized page data will be included in the
   ' output document.
   ' Processing the document in "chunks" also allows the
   ' application to maintain a predictable memory footprint.
   recPagesChunk(i).Dispose()
   recPagesChunk(i) = Nothing
  End If
 Next
End Sub

  5. Add the following code to create a public method called Process. This code initializes the ImageGear Recognition assembly, creates the output document and calls the ProcessPageChunk method created in Step 3 (above) for each chunk until all pages are processed. In this example, a maximum of 4 pages will be processed in parallel. This value can change in your situation depending upon the number of cores and threads your CPU supports.
C# Example
Copy Code
public void Process(FileInfo file)
{
    string xmlFile = "output.xml";
    int numberOfCores = 4;
    // Create an ImGearRecognition object to initialize the Recognition engine. To isolate its
    // setting collection from all other ImGearRecognition objects, construct with the parameter
    // createUnique set to true.
    using (var igRecognition = new ImGearRecognition(true))
    {
        using (var document = igRecognition.OutputManager.CreateDocument(null))
        {
            using (var content = new FileStream(file.FullName, FileMode.Open, FileAccess.Read))
            {
                int numberOfPages = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN);
                var recPagesChunk = new ImGearRecPage[numberOfCores];
                for (int i = 0; i < numberOfPages; i++)
                {
                    // Index to track the current index within the smaller
                    // chunk of pages
                    int chunkIndex = i % numberOfCores;
                    ImGearPage igPage = ImGearFileFormats.LoadPage(content, i);
                    // Rasterize the page if it's a vector page
                    if (igPage is ImGearVectorPage)
                    {
                        ImGearPage tempPage = ((ImGearVectorPage)igPage).Rasterize();
                        if (igPage is IDisposable)
                        {
                            (igPage as IDisposable).Dispose();
                        }
                        igPage = tempPage;
                    }
                    recPagesChunk[chunkIndex] = igRecognition.ImportPage((ImGearRasterPage)igPage);
                    if (((i != 0) && (chunkIndex == numberOfCores - 1)) ||
                        (i == numberOfPages - 1))
                    {
                        ProcessPageChunk(recPagesChunk, document);
                    }
                }
            }
            igRecognition.OutputManager.CodePage = "UTF-8";
            igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO;
            igRecognition.OutputManager.Format = "Converters.Text.XML";
            igRecognition.OutputManager.WriteDocument(document, xmlFile);
        }
    }
}

VB.NET Example
Copy Code
Public Sub Process(ByVal file As FileInfo)
 Dim xmlFile As String = "output.xml"
 Dim numberOfCores As Integer = 4

 ' Create an ImGearRecognition object to initialize the Recognition engine. To isolate its  ' setting collection from all other ImGearRecognition objects, construct with the parameter  ' createUnique set to true.  Using igRecognition As New ImGearRecognition(true)
  Using document As ImGearRecDocument = igRecognition.OutputManager.CreateDocument(Nothing)
   Using content As New FileStream(file.FullName, FileMode.Open, FileAccess.Read)
    Dim numberOfPages As Int32 = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN)
    Dim recPagesChunk(numberOfCores) As ImGearRecPage
    For i As Int32 = 0 To numberOfPages - 1
     ' Index to track the current index within the smaller
     ' chunk of pages
     Dim chunkIndex As Int32 = i Mod numberOfCores
     Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, i)
     ' Rasterize the page if it's a vector page
     If TypeOf igPage Is ImGearVectorPage Then
      Dim tempPage As ImGearPage = DirectCast(igPage, ImGearVectorPage).Rasterize()
      If TypeOf igPage Is IDisposable Then
       DirectCast(igPage, IDisposable).Dispose()
      End If
      igPage = tempPage
     End If
     recPagesChunk(chunkIndex) = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
     If ((i <> 0 AndAlso chunkIndex = numberOfCores - 1) Or i = numberOfPages - 1) Then
      ProcessPageChunk(recPagesChunk, document)
     End If
    Next
   End Using
   igRecognition.OutputManager.CodePage = "UTF-8"
   igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO
   igRecognition.OutputManager.Format = "Converters.Text.XML"
   igRecognition.OutputManager.WriteDocument(document, xmlFile)
  End Using
 End Using
End Sub

Calling the Page Processor Class

This section describes how to call the PageProcessorTest class that you created above:

  1. Create your own User Interface to enable the user to select a PDF file to process. This example assumes that a file has been selected and valid filename is available.
  2. Add the following code to call the PageProcessorTest class you created.
C# Example
Copy Code
PageProcessorTest processor = new PageProcessorTest();
processor.Process(new System.IO.FileInfo(filename));

VB.NET Example
Copy Code
Dim processor As New PageProcessorTest()
processor.Initialize()
processor.Process(New System.IO.FileInfo(filename))


Prepare the Image for Recognition
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition

This section consists of the following subsections:

  • Prepare the Image for Recognition
    • Pre-Process the Image
      • INVERSION
      • DESKEWING
      • ROTATION and MIRRORING
      • DESPECKLING
      • RESOLUTION ENHANCEMENT
      • BLANK PAGE DETECTION
    • Work with Zones
      • Add Zones
        • Auto-Zone
        • Add Zones Manually
        • Add Zones from a Zone File
      • Detect Tables without Visible Cell Separators
        • Example: Define a Zone Manually
        • Example: Update a Zone


Pre-Process the Image
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image

Before recognizing an image, API methods can be used to apply some image pre-processing procedures to enhance the quality of an image resulting in more accurate auto-zoning and recognition. This is typically done with the ImGearRecImage.Preprocess Method, which can include any or all of the following steps:

  • Inversion: automatic, programmed or none
  • Rotation: automatic, programmed or none
  • Deskewing: automatic, automatic 3D perspective, programmed or none

The following properties of ImGearRecPreprocessingSettings Class let you define the behavior of these image enhancement steps:

  • InversionMode Property
  • OrientationMode Property
  • DeskewMode Property
  • SkewAmount Property

In addition to these, sometimes image despeckling and resolution enhancement are also performed internally to improve the success of the above transformations.

The Asian Recognition module offers additional settings for automatic deskewing and orientation. See the Asian Recognition Module topic for more details.

Example

Pre-processing an image to deskew it by a set value with the ImGearRecImage.Preprocess Method:

C#
Copy Code
igRecognition.Preprocessing.DeskewMode = ImGearRecDeskewMode.SET;
igRecognition.Preprocessing.SkewAmount = 82;
igRecPage.Image.Preprocess();
VB .NET
Copy Code
igRecognition.Preprocessing.DeskewMode = ImGearRecDeskewMode.[SET]
igRecognition.Preprocessing.SkewAmount = 82
igRecPage.Image.Preprocess()

The image pre-processing methods can also be called one by one. In your code you can use pre-processing methods of ImGearRecImage such as Invert Method, Orient Method, Deskew Method, and Deskew3D Method. When the application calls any of these methods, the appropriate image enhancement step is immediately performed on the image, and the result is available to both the recognition engine and the application. These methods do not have progress monitoring facilities.

These sections provide a summary of information on each image modification step:

  • Pre-Process the Image
    • INVERSION
    • DESKEWING
    • ROTATION and MIRRORING
    • DESPECKLING
    • RESOLUTION ENHANCEMENT
    • BLANK PAGE DETECTION


INVERSION
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > INVERSION

Image inversion can be done on any image (bitonal, grayscale, or color) within the recognition engine's memory space. Recognition needs black or dark characters on a white or pale background.

The Invert Method immediately inverts a whole single image - or a specified rectangle within it. This method ignores the image inversion mode setting. The inverted image replaces the original image and is available to the recognition engine and the application.

An image inversion mode setting is made with the ImGearRecPreprocessingSettings.InversionMode Property, taking values from ImGearRecInvertMode Enumeration. These are:

  • AUTO : recognition engine examines image and inverts it if necessary (default)
  • NO : No images are inverted
  • YES : All images are inverted

This mode-induced inversion is performed when ImGearRecImage. Preprocess Method is called and always acts on the whole image. The inverted image replaces the original one, it keeps its original type (bitonal, grayscale, or color) and format, and is available to the recognition engine and the application.

If auto-inversion is set (AUTO), grayscale or color images undergo an implicit secondary conversion to create a clean bitonal image. If auto-inversion is set and despeckle mode is ON for a bitonal image with over 280 dpi, a despeckled bitonal image is created. Detecting whether inversion is needed or not is done on the bitonal image - the despeckled image, if available. These bitonal images are not available to the application. If the recognition engine decides inversion is needed, the whole original image is inverted.


DESKEWING
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > DESKEWING

Image deskewing can be done on any image type (bitonal, grayscale, or color), either automatically or with a programmed value. A deskewed image should increase auto-zoning and recognition accuracy.

The Deskew Method immediately deskews a whole single image in the recognition engine's memory space by an amount defined in the method itself - up to 30 degrees. The DetectSkew Method can be used to detect the amount of skew in an image.

The Deskew Method ignores the DeskewMode Property and SkewAmount Property set in ImGearRecPreprocessingSettings Class. The deskewed image replaces the original image, retaining its type and format, and is available to the recognition engine and the application.

A deskewing mode setting is made with DeskewMode Property, taking values from ImGearRecDeskewMode Enumeration. These are:

  • SET : All images are deskewed by a given value, up to 30º
  • NO : No images are deskewed
  • AUTO : Skew up to 15º is auto-detected and removed (default)
  • AUTO 3D : Skew and perspective distortion are removed from images taken by a digital camera. See 3D Deskew section below.

The skew value to be applied for SET is defined with SkewAmount Property. The value needed here can be obtained by ImGearRecImage. DetectSkew Method.

This mode-induced deskewing is performed when ImGearRecImage. Preprocess Method is called. The deskewed image replaces the original one; it keeps its original type and format and is available to the recognition engine and the application.

When AUTO is set, grayscale or color images undergo an implicit secondary conversion to create a clean but hidden bitonal image. If AUTO is set and despeckle mode is ON for a bitonal image with over 280 dpi, a hidden, despeckled bitonal image is created. Skew detection is done on the bitonal image - the despeckled image, if available. These hidden bitonal images are not available to the application. The detected deskew value is applied to the original image.

3D Deskew

The 3D deskew feature performs a 3-dimensional deskew on a page. This is useful for correcting skew and perspective distortion common in images taken by a digital camera. In these distorted images, parallel text lines are transformed to be horizontal and column edges are transformed to be vertical. The 3D Deskew algorithm does NOT detect that a page is upside down, so an image with this orientation may remain that way after 3D deskew has been performed.

Similar to the standard 2-dimensional deskew, 3D deskew can be applied in two different ways; either indirectly as part of the ImGearRecImage.Preprocess Method, or directly by the Deskew3D Method. A value has been added to the ImGearRecDeskewMode Enumeration to enable 3D deskew during preprocessing. For immediate correction, the new ImGearRecImage.Deskew3D Method can be used.

The 3D deskew algorithm does require a minimum number of characters, text lines and column edges to be successful. A column edge is defined as the beginning and/or end of consecutive text lines that have identical vertical positions (i.e. the left edge of a column aligned left or both edges of a justified column). The minimal quantities are approximately 10 text lines and the edges of two columns or both edges of a single, justified column.

3D deskew is not supported for images with Asian languages. If any Asian language is set for recognition before pre-processing, 3D deskew will not be available.


ROTATION and MIRRORING
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > ROTATION and MIRRORING

Image rotation in multiples of 90º can be done on any image type (bitonal, grayscale or color).

The method ImGearRecImage. Orient Method immediately rotates and/or mirrors a whole single image in the recognition engine's memory space. Seven combinations of rotation and mirroring are available. This method ignores the image rotation mode setting of the recognition engine. The transformed image replaces the original image, keeping its type and format. It remains in the recognition engine's memory space, but is available to the application.

A rotation mode setting is made with OrientationMode, taking values from ImGearRecOrientationMode. These are:

  • AUTO : Automatic image orientation
  • NO : Do not orient the image
  • RIGHT : Rotate image to the right (90 degrees clockwise)
  • DOWN : Rotate image down (rotate twice)
  • LEFT : Rotate image to the left (90 degrees counter-clockwise)
  • FLIPPED : Flip around the Y axis
  • RIGHT_FLIPPED : Flip around the Y axis, then rotate to the right
  • DOWN_FLIPPED : Flip around X-axis
  • LEFT_FLIPPED : Flip around the Y axis, then rotate to the left

This mode-induced rotation is performed whenever ImGearRecImage. Preprocess Method is called. When a fixed value is given (e.g., LEFT), the original image is rotated.

When AUTO is set, grayscale or color images undergo an implicit secondary conversion to create a clean bitonal image. If AUTO is set and despeckle mode is ON for a bitonal image with over 280 dpi, a despeckled bitonal image is created. Orientation detection is done on the bitonal image - the despeckled image, if available. This bitonal image is not available to the application. The required rotation is performed on the original image. In both cases, the original rotated image remains in the recognition engine's memory space and is available to the application.


DESPECKLING
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > DESPECKLING

Image despeckling relates to bitonal images. These may be imported as bitonal or may be generated, explicitly or implicitly, from grayscale or color images. Image despeckling can improve the quality of auto-zoning, recognition, and the automatic pre-processing transformations: the detection of inverted characters, skew, and orientation is more reliable when run on a despeckled bitonal image.

The method ImGearRecImage. Despeckle Method immediately despeckles a single bitonal image in the recognition engine's memory space. This functions independently of the despeckle mode setting and the resolution of the original image. The transformed image replaces the original image, keeping its format, and is available to the application.

An image despeckling mode setting is given by DespeckleMode Property, with Boolean values true and false (default: true). This mode setting influences bitonal images with a resolution of 280 dpi or greater. This mode setting is applied whenever any of the following methods are called:

  • ImGearRecZoneCollection. Locate Method
  • ImGearRecPage. Recognize Method
  • ImGearRecImage. Preprocess Method with DeskewMode Property, OrientationMode Property, or InversionMode Property set to AUTO.

When a grayscale or color image is converted to bitonal, it usually results in a cleaned image. This can be influenced by the values in SecondaryReductionMode Property and ReductionThreshold Property.

With these mode-induced transformations, the cleaned or despeckled bitonal image exists in parallel with the original one and is not available to the application.


RESOLUTION ENHANCEMENT
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > RESOLUTION ENHANCEMENT

Resolution enhancement may be performed internally during image conversions. It involves a doubling of the resolution of a bitonal image resulting from an implicit secondary image conversion from grayscale or color. The doubling is performed on the basis of information available from the greater pixel depth in grayscale and color images. The resulting bitonal image exists in parallel with the original image, and is not available to the application.

The application has no control over when resolution doubling is done, only on whether and how it is done. The ResEnhancementMode Property accepts one of three settings from ImGearRecResEnhancementMode Enumeration:

  • YES : Forces resolution doubling in all cases
  • NO : Prohibits enhancement
  • AUTO : Enhances all images with 150 dpi or less (default)


BLANK PAGE DETECTION
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Pre-Process the Image > BLANK PAGE DETECTION

Blank page detection can be performed on any image (bitonal, grayscale, or color) within the recognition engine's memory space. The DetectBlankPage Method will consider an image blank if there is a small percentage of noise, especially noise around the edge of the image usually created as a result of scanning.

The DetectBlankPage Method will return TRUE if the image is blank, or FALSE if any text of graphics are found on the page. The image will not be modified from this process.


Work with Zones
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones

A zone is a rectangular area in the image, up to full size, containing a feature of interest to the user. The image data covered by each zone is handled and processed (and typically recognized) separately, according to zone-specific parameters. The zones of an ImGearRecPage Class image form a list, the zone list, which is attached to the image. The zone list can be examined at any time with the Zones Property of ImGearRecPage Class.

The characterizing attributes of a zone are the following:

  • Size and position
  • Identifier of the zone (identifies the zone in the zone list)
  • Type (determines the role of the zone in the image layout, i.e., Flowed text, Table, or Graphic)
  • Filling method (specifies the nature of the zone content, i.e., how the zone's area was supposed to be filled originally)
  • Recognition method (the recognition module to be applied for the zone)
  • A Character Set filter
  • What kind of checking is enabled for the zone content
  • User dictionary section assigned to the zone (for UD-checking)
  • Checking event assigned to the zone for user-written checking

The zone's filling method (fm) can take one of the following ImGerRecFillingMethod Enumeration values:

  • OMNIFONT : denotes machine printed text with any typeface that is not too stylized
  • DRAFTDOT9 : denotes a 9-pin draft dot-matrix printout
  • DRAFTDOT24 : denotes a 24-pin draft dot-matrix printout
  • OCRA : denotes OCR-A zone filling
  • OCRB : denotes OCR-B zone filling

There are two special filling methods worth mentioning separately:

  • NO_OCR : denotes that no recognition should be attempted
  • DEFAULT : allows a number of zones on the image to be handled together. For zones having this filling method, the recognition engine will apply a common value according to the setting previously given by the DefaultFillingMethod property of ImGearRecRecognitionSettings Class.

This section provides information about the following:

  • Work with Zones
    • Add Zones
      • Auto-Zone
      • Add Zones Manually
      • Add Zones from a Zone File
    • Detect Tables without Visible Cell Separators
      • Example: Define a Zone Manually
      • Example: Update a Zone


Add Zones
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Add Zones

Zones can be added to a given image (to the zone list of the image, to be precise) in three different ways:

  • Automatically (auto-zoning)
  • Manually (by specifying the zone coordinates and zone attributes)
  • From a storage file, called a zone file

This section provides information about the following:

  • Add Zones
    • Auto-Zone
    • Add Zones Manually
    • Add Zones from a Zone File


Auto-Zone
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Add Zones > Auto-Zone

The automatic page-layout decomposition process (auto-zoning) can be activated directly by calling the ImGearRecZoneCollection. Locate Method for finding text blocks on the image. It creates an entire zone list for the given image.

The Locate Method has an overload that takes an ImGearRectangle as a parameter. This rectangle serves to limit the area of the image inside which zones will be searched and defined.

The recognition engine offers three different algorithms to be applied during auto-zoning: use the ImGearRecRecognitionSettings. DecompMethod Property to specify which Page parser algorithm setting should be applied during auto-zoning from among the following:

  • STANDARD : The page parser algorithm introduced in the previous version of the toolkit
  • LEGACY : The one incorporated in the earlier versions of the toolkit
  • FAST : The quickest, but not able to handle complex cases (including tables)

In addition, the integrating application can set the zoning method to AUTO. With this setting, the recognition engine determines the method to use. See ImGearRecDecompositionMethod Enumeration for details.

Applying the new STANDARD algorithm results in the best throughput in overall accuracy, though in some cases it might require significantly more time to complete.

When auto-zoning is used, each resulting zone is initialized with the following:

  • A unique auto-assigned zone identifier
  • The zone's detected coordinates
  • The zone type determined (FLOW, TABLE, or GRAPHIC)

All zones created by this method will have the following:

  • The default filling method, DEFAULT
  • The automatic recognition module selection AUTO setting
  • The DEFAULT Character Set filter to specify the use of global filtering, if any
  • None of the checking prohibit flags (e.g., LANGDICT_PROHIBIT) set

Any zone can be locally overridden with the Zones Property of ImGearRecPage, which allows you to access the zone list and change the attributes of a zone.


Add Zones Manually
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Add Zones > Add Zones Manually

In addition to, or instead of the automatic zone search, you can program your own zones. For adding zones to the zone list manually, the application calls the Add Method of ImGearRecZoneCollection Class. Related methods are: Insert Method, Remove Method, RemoveAt Method, and Clear Method.


Add Zones from a Zone File
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Add Zones > Add Zones from a Zone File

The third way of creating zones is by reading zones from a file (called a zone file) that contains the attributes of previously saved zones. An application can save the current zone definitions to a zone file any time with the ImGearRecZoneCollection. SaveToFile Method. The application can load them from a zone file with the LoadFromFile Method.

When a zone file is loaded, any previous zones on the image are removed.

If the application calls the ImGearRecPage. Recognize Method on an image with an empty zone list, the page-layout decomposition method is called automatically.


Detect Tables without Visible Cell Separators
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Detect Tables without Visible Cell Separators

Tables with visible grid lines (gridded tables) in an original page can usually be detected successfully by the auto-zoning method. However, tables without visible cell separators in the original are harder to identify as tables, because they could alternately be word lists or data arranged in columns. The recognition engine offers an algorithm for detecting such non-gridded tables more confidently. This feature can only be used in conjunction with an auto-zoning step. The algorithm to detect non-gridded tables is based on the result of character recognition. This algorithm will run only if all the following conditions are met:

  • The zone list was created through auto-zoning
  • There were no changes in the zone list (no zones were inserted or deleted)
  • None of the zones in zone list were updated by modifying the zone coordinates
  • The feature is enabled through the ImGearRecRecognitionSettings. DecompDetectNongriddedTablesEnabled Property

This section provides information about the following:

  • Detect Tables without Visible Cell Separators
    • Example: Define a Zone Manually
    • Example: Update a Zone


Example: Define a Zone Manually
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Detect Tables without Visible Cell Separators > Example: Define a Zone Manually

The following example contains uppercase letters only for multi-lingual omnifont recognition.

C#
Copy Code
ImGearRecZone igRecZone = new ImGearRecZone();
igRecZone.Rect.Left = 739;
igRecZone.Rect.Top = 63;
igRecZone.Rect.Right = 1729;
igRecZone.Rect.Bottom = 114;
// textual zone: it contains flowed text
igRecZone.Type = ImGearRecZoneType.FLOW;
// Omnifont filling method was used to fill the zone's area
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
// MOR recognition module will be applied for the zone's area
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR;
// Character Set: only uppercase letters
igRecZone.Filter = ImGearRecFilter.UPPERCASE;
// Add the zone to the zone list
igRecPage.Zones.Add(igRecZone);
igRecPage.Zones.SaveToFile("SAMPLE.ZON");
MessageBox.Show("Number of Zones: " + igRecPage.Zones.Count);
VB .NET
Copy Code
Dim igRecZone As New ImGearRecZone()
igRecZone.Rect.Left = 739
igRecZone.Rect.Top = 63
igRecZone.Rect.Right = 1729
igRecZone.Rect.Bottom = 114
' textual zone: it contains flowed text
igRecZone.Type = ImGearRecZoneType.FLOW
' Omnifont filling method was used to fill the zone's area
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
' MOR recognition module will be applied for the zone's area
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR
' Character Set: only uppercase letters
igRecZone.Filter = ImGearRecFilter.UPPERCASE
' Add the zone to the zone list
igRecPage.Zones.Add(igRecZone)
igRecPage.Zones.SaveToFile("SAMPLE.ZON")
MessageBox.Show("Number of Zones: " + igRecPage.Zones.Count.ToString())

To get information about any particular zone of the zone list of the image, the application can access the zone list via the Zones Property of ImGearRecPage Class. This can be useful in finding out more about the zones created by the auto-zoning method.


Example: Update a Zone
User Guide > How to Work with... > Recognition > Prepare the Image for Recognition > Work with Zones > Detect Tables without Visible Cell Separators > Example: Update a Zone
C#
Copy Code
igRecPage.Zones.LoadFromFile("SAMPLE.ZON");
int nZones = igRecPage.Zones.Count;
// Get the first zone in the zone list
ImGearRecZone igRecZone = igRecPage.Zones[0];
// . . .
// Adjust the left border of the zone by 50 pixels
igRecZone.Rect.Left -= 50;
// Zone content will be handled as a flow text
igRecZone.Type = ImGearRecZoneType.FLOW;
igRecPage.Zones.SaveToFile("SAMPLE.ZON");
VB .NET
Copy Code
igRecPage.Zones.LoadFromFile("SAMPLE.ZON")
Dim nZones As Integer = igRecPage.Zones.Count
' Get the first zone in the zone list
Dim igRecZone As ImGearRecZone = igRecPage.Zones(0)
' . . .
' Adjust the left border of the zone by 50 pixels
igRecZone.Rect.Left -= 50
' Zone content will be handled as a flow text
igRecZone.Type = ImGearRecZoneType.FLOW
igRecPage.Zones.SaveToFile("SAMPLE.ZON")
When updating a table-type zone by accessing the zone list via the Zones Property, the "cell-detection" algorithm won't be activated, which will result in improper table detection within the zone.

The program can detect cells within a table-zone if automatic page decomposition is used.


Recognition
User Guide > How to Work with... > Recognition > Recognition

This section consists of the following subsections:

  • Recognition Modules
  • The Recognition Process
  • Structured Data Output
  • OCR Performance Considerations
  • Define the Character Set
  • Recognized Data Kept in Memory


Recognition Modules
User Guide > How to Work with... > Recognition > Recognition > Recognition Modules

The ImageGear Recognition API can load a number of recognition modules: which ones are present depends on its configuration. You can program which one should run in a given zone with the zone's ImGearRecZone.RecognitionModule Property. This allows your application to perform "multi-module" recognition on any image.

The ImGearRecRecognitionModule Enumeration lists the possible recognition modules:

  • PLUS3W omnifont module for machine-printed text (default)
  • PLUS2W omnifont module for machine-printed text
  • MTX omnifont module for machine-printed text
  • MOR multi-lingual omnifont module for machine-printed text
  • FRX multi-lingual omnifont module for machine-printed text
  • DOT module for 9-pin draft dot-matrix printouts
  • ASIAN module for Asian language text

Corresponding to the above list, the RecognitionModule Property of any zone should contain one of the following recognition module IDs: OMNIFONT_PLUS3W, OMNIFONT_PLUS2W, OMNIFONT_MTX, OMNIFONT_MOR, OMNIFONT_FRX, DOT, or one of the two special ones: NO_OCR and AUTO. The NO_OCR value means that no recognition will be done in the zone concerned.

AUTO means that the recognition engine will choose the module most likely to be appropriate. It does this first of all by consulting the filling method set for the zone.

The filling method describes the type of data expected in the zone, e.g., dot matrix printed text or machine generated text. A degree of auto-detection is available for the filling method, with the ImGearRecPage.DetectFillingMethod Method, which is useful when the precise filling method used on incoming documents may not be known in advance. It is the programmer's responsibility to specify a valid recognition module-filling method pair. Any incorrectly set zone will have no recognition result. Some filling methods can be linked successfully with one and only one recognition module. However, some recognition modules support more than one filling method, and some filling methods are accepted by more than one recognition module. For example, with mid-quality 9-pin dot-matrix text, either DOT or one of the omnifont modules could give better results. With mid-quality 24-pin dot-matrix text, try RM OMNIFONT_MOR with FM DOTMATRIX24 and OMNIFONT.

You can find detailed information on this and the different recognition modules in the Specifications for the Recognition Modules.

RM AUTO reads the filling method; if only one recognition module is suitable, it is used. When there is a choice, RM AUTO uses various checks (character set, image size, etc.) to select the best one. Thus, it protects against an invalid FM-RM pair.

If the recognition module is not present when it is needed, the Recognize Method throws an ImGearException with error code and value ImGearRecErrorCodes.REC_ENGINE_FAILURE / API_MODULEMISSING_ERR, and there will be no recognized data for the zone concerned. To avoid this risk, we recommend checking the presence and correct installation of the necessary recognition modules by examining the modules collection using the ImGearRecognition.Modules Property just after the Recognition API's initialization.


The Recognition Process
User Guide > How to Work with... > Recognition > Recognition > The Recognition Process

The recognition process is initiated by the ImGearRecPage. Recognize Method.

The Recognize Method processes the single image associated with the ImGearRecPage Class. The method takes the zone list of the image or if it is empty, automatically calls the page-layout decomposition process (auto-zoning).

Internally this method operates on a bitonal image. If the image is not bitonal or the image despeckle mode setting is enabled, an implicit secondary image conversion step is performed automatically to create a secondary image. This implicit image conversion can be influenced with previous settings of the ImGearRecPreprocessingSettings. SecondaryReductionMode Property and DespeckleMode Property.

The Recognize Method enumerates the zones in the zone list and activates the appropriate recognition modules for them. The recognition modules are given the calculated Character Set information zone by zone.

This section provides information about the following:

  • The Recognition Process
    • Recognize a Multi-Page Document
    • Recognize a Single-Page Document


Recognize a Multi-Page Document
User Guide > How to Work with... > Recognition > Recognition > The Recognition Process > Recognize a Multi-Page Document

In this example, the application specifies the output format (Converters.Text.Word2000) for the final output document (MULTIPAG.DOC) with the Format property. Then the multi-page result of the recognition stored in the recognition data file is converted into the requested format with the ImGearRecOutputManager. WriteDocument Method call.

C#
Copy Code
ImGearRecDocument document = ImGearRecDocument.Create(null);
using (FileStream content = new FileStream("MULTIPAG.TIF", FileMode.Open))
{
     int numPages = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN);
     for (int i = 0; i < numPages; i++)
     {
          ImGearPage igPage = ImGearFileFormats.LoadPage(content, i);
          ImGearRecPage igRecPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
          igRecPage.Image.Preprocess();
          igRecPage.Recognize();
          document.InsertPage(igRecPage, -1);
     }
}
igRecognition.OutputManager.CodePage = "Windows ANSI";
igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO;
igRecognition.OutputManager.Format = "Converters.Text.Word2000";
igRecognition.OutputManager.WriteDocument(document, "MULTIPAG.DOC");
document.Dispose();
VB .NET
Copy Code
Dim document As ImGearRecDocument = ImGearRecDocument.Create(Nothing)
Using content As New FileStream("MULTIPAG.TIF", FileMode.Open)
      Dim numPages As Integer = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN)
      Dim i As Integer = 0
      While i < numPages
           Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, i)
           Dim igRecPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
           igRecPage.Image.Preprocess()
           igRecPage.Recognize()
           document.InsertPage(igRecPage, -1)
           System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
      End While
End Using
igRecognition.OutputManager.CodePage = "Windows ANSI"
igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO
igRecognition.OutputManager.Format = "Converters.Text.Word2000"
igRecognition.OutputManager.WriteDocument(document, "MULTIPAG.DOC")
document.Dispose()


Recognize a Single-Page Document
User Guide > How to Work with... > Recognition > Recognition > The Recognition Process > Recognize a Single-Page Document
C#
Copy Code
ImGearPage igPage;
using (FileStream localFile = new FileStream("test1.tif",FileMode.Open))
     igPage = ImGearFileFormats.LoadPage(localFile, 0);
ImGearRecPage igRecPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
imGearPageView1.Page = igPage;
igRecPage.Image.Preprocess();
igRecPage.Recognize();
igRecognition.OutputManager.CodePage = "Windows ANSI";
igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO;
igRecognition.OutputManager.Format = "Converters.Text.Word2000";
ImGearRecDocument document = ImGearRecDocument.Create(null);
document.InsertPage(igRecPage, -1);
igRecognition.OutputManager.WriteDocument(document, "singlePage.doc");
document.Dispose();
VB .NET
Copy Code
Dim igPage As ImGearPage
Using localFile As New FileStream("test1.tif", FileMode.Open)
      igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
Dim igRecPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
imGearPageView1.Page = igPage
igRecPage.Image.Preprocess()
igRecPage.Recognize()
igRecognition.OutputManager.CodePage = "Windows ANSI"
igRecognition.OutputManager.Level = ImGearRecOutputLevel.AUTO
igRecognition.OutputManager.Format = "Converters.Text.Word2000"
Dim document As ImGearRecDocument = ImGearRecDocument.Create(Nothing)
document.InsertPage(igRecPage, -1)
igRecognition.OutputManager.WriteDocument(document, "singlePage.doc")
document.Dispose()


Structured Data Output
User Guide > How to Work with... > Recognition > Recognition > Structured Data Output

After recognition, the application can also access the recognition data as a structured data output with a call to the ImGearRecPage. GetLetters Method, which returns an array of ImGearRecLetter Class objects.

Any of these above also provides confidence information for the recognition as follows:

  • Confidence of the character recognition
  • Confidence of the space estimation (of the decision whether there is a space in front of the recognized character)
See Also
Recognized Data Kept in Memory
Confidence Reporting


OCR Performance Considerations
User Guide > How to Work with... > Recognition > Recognition > OCR Performance Considerations

There are different considerations to be taken into account when you want to improve recognition accuracy. Typically, they also have consequences for the processing speed.

  • Image Quality
  • Auto-Zoning Algorithm to Apply
  • Correct RM-FM Choice
  • Trade-off Settings
  • Module Specific Settings
  • Character Set
  • The Checking Subsystem

Image Quality

This is one of the most important factors that influences accuracy.

  • A resolution of 300 dpi or 400 dpi is best for recognition.
  • Use image preprocessing to enhance the quality of the given image to get more accurate auto-zoning and recognition.
  • Load grayscale or color images into the recognition engine without any conversion (ImGearRecReductionMode Enumeration.NO) and combine this with image preprocessing in order to get more accurate output.
  • When the Asian Recognition module is in use, the ideal font size for Asian language text is 12 points, scanned at 300 dpi, resulting in characters with around 48 x 48 pixels. The minimum pixel count is about 30 x 30, that is 10.5 points at 300 dpi. For characters smaller than this, 400 dpi should be used.

Auto-Zoning Algorithm to Apply

If auto-zoning is needed, use ImGearRecDecompositionMethod Enumeration.STANDARD, the most accurate page parser available in the recognition engine. Applying the STANDARD algorithm results in better throughput in overall accuracy, though in some complex cases it might require significantly more time to complete.

If processing speed is also important, consider using the LEGACY algorithm.

Finally, use FAST when the processing speed has a higher priority than accuracy, and the image content of the originals is simple enough (e.g., good quality letters without graphics or tables). In this case, it is recommended that the Non-gridded table detection algorithm be disabled (see DecompDetectNongriddedTablesEnabled Property).

Correct RM-FM Choice

The most suitable filling method and recognition module should be specified, as described in Recognition Modules.

If more than one recognition module supports a given filling method, consider whether for your application it is better to specify the recognition module in your program rather than accept the setting selected by the recognition engine through the ImGearRecRecognitionModule Enumeration.AUTO option.

By choosing different combinations of the auto-zoning algorithm and specific recognition modules, 2-3 times faster recognition speed at the cost of increased error rate (1.5-2 times more errors) can be achieved.

For example, when speed is an issue, consider using OMNIFONT_MTX, OMNIFONT_FRX, OMNIFONT_MOR, or OMNIFONT_PLUS2W, instead of the default omnifont module OMNIFONT_PLUS3W.

Trade-off Settings

These are set at engine level, and determine how thorough the recognition should be, i.e., whether more time should be taken to try for higher accuracy. There are three possible values: ACCURATE, BALANCED, FAST, set using the ImGearRecRecognitionSettings. Tradeoff Property. For more details, see Specifications for the recognition modules.

Module Specific Settings

The behavior, and hence accuracy, of some recognition modules can be influenced by separate module-specific settings. These settings are accessed via the Modules Property of ImGearRecognition Class. The Modules Property provides access to ImGearRecModuleCollection Class, which provides the following properties to access module-specific settings:

  • MOR, PLUS2W and PLUS3W modules: ImGearRecognition. Modules Property.MOR
    For poor-quality fax output, the fax compensation ImGearRecMORSettings. IsFaxed Property can be used.
  • Asian Recognition module: ImGearRecognition.Modules Property.Asian
    • To allow wide characters to be used for Latin embedded text detected with Asian language text, the ImGearRecAsianSettings.AllowFullWidthLatinCharacters property can be used.
    • To allow vertical punctuation in Asian text recognition results, use the ImGearRecAsianSettings.AllowVerticalPunctuation property.
    • To instruct the auto deskew pre-processing to ignore images with Asian text, use the ImGearRecAsianSettings.IgnoreAsianTextForDeskew property.
    • To instruct the auto orientation pre-processing to ignore images with Asian text, use the ImGearRecAsianSettings.IgnoreAsianTextForRotation property.
    • To use a greater recognizable character set with the Asian recognition module, use the ImGearRecAsianSettings.UseFullCharacterSet property. This property has no effect when the Korean language is set.

In the Recognition module specifications each module has its own section, Accuracy Issues.

Character Set

This determines, at zone level, which set of characters should be considered as valid. By eliminating characters that are known not to appear in the zone, accuracy can be improved. If non-validated character shapes are encountered in a zone, they are either replaced by the rejection symbol or forced to a similar-shaped validated character. A major component of the Character Set is the language choice. Setting the wrong language(s) and/or language dictionary (or leaving unneeded ones enabled) is likely to slow down recognition and reduce accuracy considerably. The steps for defining the Character Set are given (with examples) in a following section, Define the Character Set.

The Checking Subsystem

This consists of any combination of the following checking tools:

  • Spell checking (language-based checking)
  • User dictionary based checking (with words, strings or character patterns)
  • User-written checking routines

The Checking subsystem will find characters, words, or zone contents that do not match program-specified rules for that zone. It can be instructed either to only mark these occurrences, or be given permission to change them when it finds a sufficiently similar acceptable solution. See the section (Improving Accuracy with the Checking Subsystem) for examples.

Character Set limitation and the Checking subsystem (CSS) both influence accuracy, but in different ways. Both, either or none of them can be used; the integrator should decide which balance is best. Their effects, when used separately, can be summarized as follows:

  • Limiting the Character Set: Recognition results outside the Character Set will not be used.
  • CSS with changes: Recognition results outside the CSS rules are less likely; both non-CSS solutions and changed items will be flagged.
  • CSS used without changing: Text appears as recognized, but non-CSS solutions will be flagged.

Limiting the Character Set gives the program the greatest decision power, using the checking subsystem to only flag errors is safest, but requires more post-processing outside the recognition engine to check all non-conforming cases.

A typical balance would be to impose broad restrictions by limiting the Character Set, e.g., specifying the permissible languages, but using the checking subsystem for detailed control over parts of the recognized text where it's important that the original data be recognized and passed for checking precisely as it was written (e.g., for an ID Code incorporating a check-digit method). This later checking should make it possible to determine whether any error is due to optical recognition errors or was originally invalid.


Define the Character Set
User Guide > How to Work with... > Recognition > Recognition > Define the Character Set

You can improve text recognition accuracy by narrowing the range of characters valid for recognition. This way the recognition engine doesn't always have to choose its solutions from all 500 characters in the recognition engine's Total Character Set. The multi-lingual omnifont MOR recognition module supports all of these characters; other recognition modules recognize fewer of them. Broadly, the Set is compiled as follows:

  • Language environment

    This involves selecting one or more of the 114 available languages with the LanguageEnabled Property and optionally additional characters validated individually with the LanguagesPlus Property. Selecting only needed language(s) has a major impact. For example, selecting German only immediately INVALIDATES the Cyrillic and Greek alphabets and over 150 other unneeded accented letters. For a list of languages with their validated accented letters, see Languages and characters. For a list of accented letters and the languages which use them, see Characters, languages, modules. For an overview of the topic, see Introduction to language-related topics.

    If the LanguageEnabled Property is not used to enable or disable any languages, the default is to enable the English alphabet.
  • Recognition module capabilities

    Defining a recognition module for processing a zone may also restrict the available languages or characters within the Language environment.

  • Filtering

    The SDK provides filters (ImGearRecFilter Enumeration) to further narrow down the Character Set, by enabling only certain character classes, e.g., digits, uppercase letters, etc. The value ALL means no filtering.

  • Re-Expanding

    An application may require exceptions to the filter rule. The most flexible way to re-expand the Character Set with individual characters after filtering is to specify them with the FilterPlus Property and validate them with the PLUS flag in the required zones.

  • Zone-level modification

    In addition to the global, page-level definition of the Character Set, the choice of Recognition module, filling method, filtering and use of the expansion string can be fine-tuned on a local, zone level. Auto-located zones will be set to take the global filter settings. Manually created or modified zones may contain zone-level settings. Local filtering and expansion (with PLUS) can be set in the zone's Filter Property. The possible local filter values are the same as the global ones, with an extra one: DEFAULT. If this is the only one set, the zone inherits the global filter setting.

This section provides the following examples to illustrate various techniques for limiting the Character Set:

  • Recognition of a Bi-Lingual Document
  • Character Set with No Language Selection
  • Language Selection, LanguagesPlus Characters, and Local Filter
  • Multiple Languages, Global and Local Filters, FilterPlus Characters

To summarize, the Character Set for each zone was:

  • Zones 1-4: Globally defined: All unaccented letters plus all accented letters needed for the three specified languages, plus all digits and punctuation.
  • Zone 5: Locally defined: All uppercase unaccented letters plus three accented ones, plus the period, comma, and question mark. (The letters BDEFLMRU were doubly validated; that doesn't matter).
  • Zone 6: Locally defined: The digits, the letters BDEFLMRU, the comma and (superfluously) the period and question mark.

The IsCharEnabled Method can be used to inquire whether a given character is validated for the current page by its Language environment and FilterPlus.


Recognition of a Bi-Lingual Document
User Guide > How to Work with... > Recognition > Recognition > Define the Character Set > Recognition of a Bi-Lingual Document

In the following example, the default recognition module (omnifont, unless specifically changed) will be assigned to all zones, as will the filter value DEFAULT, i.e., there is no local modification of the Character Set.

The Asian Recognition module has some unique restrictions in regards to setting multiple languages at one time. See the Asian Recognition Module topic for more details.
C#
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll();
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.GER] = true;
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.ENG] = true;
VB .NET
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll()
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.GER) = True
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.ENG) = True


Character Set with No Language Selection
User Guide > How to Work with... > Recognition > Recognition > Define the Character Set > Character Set with No Language Selection

You can specify a character set with no language selection: "a, A, b, B, c, C, d, D, e, E" as the only validated characters. This example illustrates a rare case, such as you have a page containing zones with a very restricted number of characters to be recognized, e.g., in recognizing forms or multiple-choice test papers. In this case the application doesn't enable any language, but instead defines the few characters necessary as LanguagesPlus characters. This means there is no language selection and the Language environment consists solely of the individually defined LanguagesPlus characters. Also note that there is no filtering and no locally (zone) validated FilterPlus characters, in this case, the Language environment fully defines the Character Set and it will be valid for the defined zone, and for others inserted with an identical zone structure.

C#
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll();
igRecognition.Recognition.FilterPlus = "aAbBcCdDeE";
ImGearRecZone igRecZone = new ImGearRecZone();
igRecZone.Rect.CopyFrom(new ImGearRectangle(igRecPage.Image.Width, igRecPage.Image.Height));
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
igRecZone.RecognitionModule = ImGearRecRecognitionModule.AUTO;
igRecZone.Filter = ImGearRecFilter.ALL | ImGearRecFilter.PLUS;
igRecZone.Type = ImGearRecZoneType.FLOW;
igRecPage.Zones.Add(igRecZone);
VB .NET
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll()
igRecognition.Recognition.FilterPlus = "aAbBcCdDeE"
Dim igRecZone As New ImGearRecZone()
igRecZone.Rect.CopyFrom(New ImGearRectangle(igRecPage.Image.Width, igRecPage.Image.Height))
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
igRecZone.RecognitionModule = ImGearRecRecognitionModule.AUTO
igRecZone.Filter = ImGearRecFilter.ALL Or ImGearRecFilter.PLUS
igRecZone.Type = ImGearRecZoneType.FLOW
igRecPage.Zones.Add(igRecZone)

In the above case the zone list is not empty, so the Recognize Method will not perform auto-decomposition (auto-zoning), but will act on the inserted zone(s).


Language Selection, LanguagesPlus Characters, and Local Filter
User Guide > How to Work with... > Recognition > Recognition > Define the Character Set > Language Selection, LanguagesPlus Characters, and Local Filter

This example demonstrates reading a printed page in Hungarian, in which a Croatian town name appears repeatedly, containing the character "z-hacek" in lower and uppercase. The Windows Eastern Europe Code Page (1250), is needed as the current Code Page (and for export). The page includes a table containing numbers, which should be zoned separately for digits-only recognition.

In this example the Language environment is formed from the language selection (Hungarian) plus the two additional LanguagesPlus characters "z-hacek" and "Z-hacek". There is no global filter, but there is a local one, DIGIT, defined for one zone.

C#
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll();
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.HUN] = true;
igRecognition.OutputManager.CodePage = "Windows Eastern";  // Code Page 1250
string s = "";
s += igRecognition.OutputManager.ConvertCodePageToUnicode(0x9E); // z-hacek in CP1250
s += igRecognition.OutputManager.ConvertCodePageToUnicode(0x8E); // Z-hacek in CP1250
igRecognition.Recognition.LanguagesPlus = s;
// . . .
// 1st zone contains a table with digits
ImGearRecZone igRecZone = new ImGearRecZone();
igRecZone.Rect.Left = 970;
igRecZone.Rect.Right = 2260;
igRecZone.Rect.Top = 1355;
igRecZone.Rect.Bottom = 1729;
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR;
igRecZone.Filter = ImGearRecFilter.DIGIT;
igRecZone.Type = ImGearRecZoneType.TABLE;
igRecPage.Zones.Add(igRecZone);
// 2nd zone contains flowed text without filtering
igRecZone = new ImGearRecZone();
igRecZone.Rect.Left = 342;
igRecZone.Rect.Right = 867;
igRecZone.Rect.Top = 665;
igRecZone.Rect.Bottom = 1644;
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR;
igRecZone.Filter = ImGearRecFilter.ALL;
igRecZone.Type = ImGearRecZoneType.FLOW;
igRecPage.Zones.Add(igRecZone);
VB .NET
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll()
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.HUN) = True
igRecognition.OutputManager.CodePage = "Windows Eastern"
' Code Page 1250
Dim s As String = ""
s += igRecognition.OutputManager.ConvertCodePageToUnicode(&H9E)
' z-hacek in CP1250
s += igRecognition.OutputManager.ConvertCodePageToUnicode(&H8E)
' Z-hacek in CP1250
igRecognition.Recognition.LanguagesPlus = s
' . . .
' 1st zone contains a table with digits
Dim igRecZone As New ImGearRecZone()
igRecZone.Rect.Left = 970
igRecZone.Rect.Right = 2260
igRecZone.Rect.Top = 1355
igRecZone.Rect.Bottom = 1729
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR
igRecZone.Filter = ImGearRecFilter.DIGIT
igRecZone.Type = ImGearRecZoneType.TABLE
igRecPage.Zones.Add(igRecZone)
' 2nd zone contains flowed text without filtering
igRecZone = New ImGearRecZone()
igRecZone.Rect.Left = 342
igRecZone.Rect.Right = 867
igRecZone.Rect.Top = 665
igRecZone.Rect.Bottom = 1644
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR
igRecZone.Filter = ImGearRecFilter.ALL
igRecZone.Type = ImGearRecZoneType.FLOW
igRecPage.Zones.Add(igRecZone)


Multiple Languages, Global and Local Filters, FilterPlus Characters
User Guide > How to Work with... > Recognition > Recognition > Define the Character Set > Multiple Languages, Global and Local Filters, FilterPlus Characters

To read a page from a Luxembourgian newspaper, in which articles on a single page appear in French, German, and Luxembourgian. The page contains six zones. The text contains no miscellaneous characters (mathematical symbols, etc.). Zone 5 contains uppercase letters only, with no digits, and only three punctuation characters: the comma, the period (full-stop), and a question mark. Zone 6 presents a currency conversion table containing the digits, the comma, and the currency codes of Luxembourg and its neighbors: LUF, FRF, DEM, BEF, and EUR.

The language selection is set to French, German, and Luxembourgian. The DefaultFilter property is used to specify the global filter, to filter out only the 30 miscellaneous characters:

ALPHA | PUNCTUATION | DIGIT.

A local filter is defined for zone 5:

UPPERCASE | PLUS.

A different local filter is defined for zone 6:

DIGIT | PLUS, or simply NUMBERS.

These have the same effect.

The FilterPlus property is set to validate the FilterPlus characters needed in zone 5 and zone 6:

The comma, the period, the question mark, and the currency letters, B D E F L M R U.

C#
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll();
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.FRE] = true;
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.GER] = true;
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.LUX] = true;
igRecognition.OutputManager.CodePage = "Windows ANSI";  // Code Page 1252
igRecognition.Recognition.DefaultFilter = ImGearRecFilter.ALPHA |
     ImGearRecFilter.PUNCTUATION | ImGearRecFilter.DIGIT;
// . . .
// 1-4 zones
// . . .
// 5th zone
ImGearRecZone igRecZone = new ImGearRecZone();
igRecZone.Rect.Left = 10;
igRecZone.Rect.Right = 330;
igRecZone.Rect.Top = 420;
igRecZone.Rect.Bottom = 450;
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR;
igRecZone.Filter = ImGearRecFilter.UPPERCASE | ImGearRecFilter.PLUS;
igRecZone.Type = ImGearRecZoneType.FLOW;
igRecPage.Zones.Add(igRecZone);
// 6th zone
igRecZone.Rect.Left = 10;
igRecZone.Rect.Right = 330;
igRecZone.Rect.Top = 80;
igRecZone.Rect.Bottom = 120;
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT;
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR;
igRecZone.Filter = ImGearRecFilter.DIGIT | ImGearRecFilter.PLUS;
igRecZone.Type = ImGearRecZoneType.FLOW;
igRecPage.Zones.Add(igRecZone);
// . . .
igRecognition.Recognition.FilterPlus = "BDEFLMRU.,?";
VB .NET
Copy Code
igRecognition.Recognition.LanguageEnabled.DisableAll()
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.FRE) = True
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.GER) = True
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.LUX) = True
igRecognition.OutputManager.CodePage = "Windows ANSI"
' Code Page 1252
igRecognition.Recognition.DefaultFilter = ImGearRecFilter.ALPHA Or ImGearRecFilter.PUNCTUATION Or ImGearRecFilter.DIGIT
' . . .
' 1-4 zones
' . . .
' 5th zone
Dim igRecZone As New ImGearRecZone()
igRecZone.Rect.Left = 10
igRecZone.Rect.Right = 330
igRecZone.Rect.Top = 420
igRecZone.Rect.Bottom = 450
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR
igRecZone.Filter = ImGearRecFilter.UPPERCASE Or ImGearRecFilter.PLUS
igRecZone.Type = ImGearRecZoneType.FLOW
igRecPage.Zones.Add(igRecZone)
' 6th zone
igRecZone.Rect.Left = 10
igRecZone.Rect.Right = 330
igRecZone.Rect.Top = 80
igRecZone.Rect.Bottom = 120
igRecZone.FillingMethod = ImGearRecFillingMethod.OMNIFONT
igRecZone.RecognitionModule = ImGearRecRecognitionModule.OMNIFONT_MOR
igRecZone.Filter = ImGearRecFilter.DIGIT Or ImGearRecFilter.PLUS
igRecZone.Type = ImGearRecZoneType.FLOW
igRecPage.Zones.Add(igRecZone)
' . . .
igRecognition.Recognition.FilterPlus = "BDEFLMRU.,?"


Recognized Data Kept in Memory
User Guide > How to Work with... > Recognition > Recognition > Recognized Data Kept in Memory

The recognized data is available as an array of ImGearRecLetter Class objects providing significantly more information than the character code itself. This occupies 36 bytes for each recognized character, and this type of output offers the most detailed information on the recognition.

The application can slightly change the recognized data before converting it to a recognition data file. The SetLetters Method can be used to update the recognized data belonging to the ImGearRecPage Class. Be careful to modify only those fields whose change is necessary.


Recognition.Forms
User Guide > How to Work with... > Recognition > Recognition.Forms

The ImageGear.Recognition.Forms Namespace contains classes that offer recognition-related user interface functionality. For example, it provides a customizable toolbar for creating recognition zones, as well as interactive, visual creation and editing of recognition zones, which are displayed directly over the image to be recognized.

This namespace contains classes and enumerations that offer recognition-related user interface functionality.

Classes

Class | Description
ImGearRecZoneGUI | This is the main recognition zone editor GUI class that allows you to control visibility and customize the zone editor toolbar, showing zone property pages, processing mouse events, and so on.
ImGearRecZoneGUICustomBtnParam | Represents custom button parameters.
ImGearRecZoneGUICustomBtnParams | Represents custom button parameters collection.
ImGearRecZoneGUICustomToolBar | Provides access to a custom tool bar.

Enumerations

Enumeration | Description
ImGearRecZoneGUIEditMode | Specifies the edit mode used for zone editing GUI.
ImGearRecZoneGUIMatchingFlags | Specifies flags used to describe which types of zones should match a custom zone editor toolbar button.
ImGearRecZoneGUIType | Zone type used for zone editor toolbar buttons.


Checking
User Guide > How to Work with... > Recognition > Checking

This section consists of the following subsections:

  • Improving Accuracy with the Checking Subsystem
  • Applying Checking
  • Preparing and Maintaining the User Dictionary


Improving Accuracy with the Checking Subsystem
User Guide > How to Work with... > Recognition > Checking > Improving Accuracy with the Checking Subsystem

The checking subsystem is mainly used to achieve better accuracy in the recognized output text and/or to make proofing more effective. Its services are closely integrated into the recognition process; they are activated internally either during the recognition (by some recognition modules) or immediately after the recognition process. That is why all the checking related settings have to be set BEFORE calling the Recognize Method.

This section provides information about the checking subsystem, which consists of the following three independent parts:

  • Spell Checking: using language-specific dictionary elements
  • UD-Checking: checking against the User dictionary (with words, strings or patterns)
  • User-Written Checking: using user-written API

Asian Recognition Module: The checking subsystem is not available. This means spell checking, UD-Checking and User-Written Checking cannot be used when the Asian Recognition Module is active. See the Asian Recognition Module topic for more details.

Any combination of these parts is possible during the recognition process as steps in determining the acceptability of words. Note that the use of these checking types can still be enabled or disabled separately at zone level.


Spell Checking
User Guide > How to Work with... > Recognition > Checking > Improving Accuracy with the Checking Subsystem > Spell Checking

Spell checking uses third-party language-specific spell checkers. There are two kinds of spell checkers:

  • Language dictionaries ("language checking")
  • Vertical dictionaries ("vertical language checking")

The recognition engine is delivered with seventeen different Language dictionaries (English, German, Dutch, Polish, Russian, etc.). These are generic language dictionaries, which contain between 100,000 and 200,000 entries.

Vertical dictionaries apply to special professions and in the toolkit. They can be treated as extensions to the Language dictionaries, though they can even be used when no Language dictionary is specified. The recognition engine is delivered with 8 different Vertical dictionaries for two professions (medical and legal) in four languages (English, German, French, and Dutch).

Specifying the Spelling language (Language dictionary) and/or a Vertical dictionary is page-level setting. Once a Language dictionary has been specified, the language checking will be applied to all zones on the page, unless their LANGDICT_PROHIBIT flag is set.

Similarly, once a Vertical dictionary has been specified, the vertical language checking will be applied to all zones on the page, unless their VERTDICT_PROHIBIT flag is set.

Asian Recognition Module: The checking subsystem is not available. This means spell checking, UD-Checking and User-Written Checking cannot be used when the Asian Recognition Module is active. See the Asian Recognition Module topic for more details.

Example: Recognizing Dutch Legal Texts

C#
Copy Code
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.DUT] = true;
igRecognition.Recognition.SpellingLanguage = ImGearRecLanguage.DUT;
igRecognition.Recognition.VerticalDictionary = "Dutch Legal Dictionary";
VB .NET
Copy Code
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.DUT) = True
igRecognition.Recognition.SpellingLanguage = ImGearRecLanguage.DUT
igRecognition.Recognition.VerticalDictionary = "Dutch Legal Dictionary"


UD-Checking
User Guide > How to Work with... > Recognition > Checking > Improving Accuracy with the Checking Subsystem > UD-Checking

The checking subsystem also makes use of a User dictionary. A User dictionary is a collection of user-specific elements, the so-called UDitems. UDitems can be of two types: literal strings (usually words, as in the case of any word processor's user dictionary) or regular expressions. A string being checked will be accepted if it conforms to at least one item in the specified section of the User dictionary. A regular expression defines a pattern, range, or class of characters, either singly or as a group. When an item is a regular expression, it means that during the UD-checking, strings passed for checking by a recognition module will be checked to see whether they conform to the pattern defined by the regular expression.

In the following example, regular expressions will be applied to check whether the recognized strings comply with post or zip code formats used mostly in Europe or in the US.

Asian Recognition Module: The checking subsystem is not available. This means spell checking, UD-Checking and User-Written Checking cannot be used when the Asian Recognition Module is active. See the Asian Recognition Module topic for more details.

Example: Adding Literal and Regular Expression UDitems to the User Dictionary

C#
Copy Code
string sect1 = "ZIP_Section";
string item_literal = "Accusoft";
// US postal zip code: 12345 or 12345-67890
string US_postal_zip = "\\d{5}(-\\d{5})?";
// European postal code: D-12345 or H-1234
string European_postal_zip = "[A-Z]-\\d{4,5}";
// This assumes the UD is already open for maintenance
igRecognition.Recognition.UserDictionary.Create();
ImGearRecUserDictionary igRecUserDictionary = igRecognition.Recognition.UserDictionary;
igRecUserDictionary.AddItem(new ImGearRecUDItem(sect1, item_literal));
igRecUserDictionary.AddItem(new ImGearRecUDItem(sect1, US_postal_zip, true));
igRecUserDictionary.AddItem(new ImGearRecUDItem(sect1, European_postal_zip, true));
VB .NET
Copy Code
Dim sect1 As String = "ZIP_Section"
Dim item_literal As String = "AccuSoft"
' US postal zip code: 12345 or 12345-67890
Dim US_postal_zip As String = "\d{5}(-\d{5})?"
' European postal code: D-12345 or H-1234
Dim European_postal_zip As String = "[A-Z]-\d{4,5}"
' This assumes the UD is already open for maintenance
igRecognition.Recognition.UserDictionary.Create()
Dim igRecUserDictionary As ImGearRecUserDictionary = igRecognition.Recognition.UserDictionary
igRecUserDictionary.AddItem(New ImGearRecUDItem(sect1, item_literal))
igRecUserDictionary.AddItem(New ImGearRecUDItem(sect1, US_postal_zip, True))
igRecUserDictionary.AddItem(New ImGearRecUDItem(sect1, European_postal_zip, True))

Within the User dictionary, the UDitems can be organized under different sections. Zones are always associated with a section of the User dictionary when they are created.

There can be different situations when it is worth doing an UD-checking.

If the application uses spell checking, and it consistently encounters words marked as uncertain that are spelled correctly, or it is known that the document contains many proper nouns, the application can reduce unwanted marking and improve recognition accuracy by performing UD-checking, to supplement the spell checking (assuming that the User dictionary has been prepared previously by adding the required words to it). In this case the UD-checking is complementary to the spell checking.

UD-checking without spell checking enabled is typically used in form-like applications (e.g., questionnaires), i.e., where the data to be recognized is highly structured and follows predictable patterns.

Specifying the User dictionary file itself is a page-level setting. Once it is specified, it will be applied to all zones on the page. However, since the User dictionary may have several sections, each to be assigned to the different zones, different sets of dictionary items can be used for the different zones. For particular zones the UD-checking can be disabled with the USERDICT_PROHIBIT flag.


User-Written Checking
User Guide > How to Work with... > Recognition > Checking > Improving Accuracy with the Checking Subsystem > User-Written Checking

User-written checking is performed through the ImGearRecZone. CheckWord Event by the integrating application. When creating or updating a zone, the ImGearRecCheckWordEventArgs. CheckWord Property of the zone may be used to register an event listener for the CheckWord Event. During recognition, the CheckWord Event is fired, and the user-written event handler is passed the string to be checked and the index of the zone (from which the string to be checked is derived). The user-written event handler should evaluate the string, knowing the pattern of permissible zone content. Its opinion on the recognized string's acceptability should be expressed with one of the five values from the ImGearRecCheckWordOpinion Enumeration.

Asian Recognition Module: The checking subsystem is not available. This means spell checking, UD-Checking and User-Written Checking cannot be used when the Asian Recognition Module is active. See the Asian Recognition Module topic for more details.

See the C# Recognition sample for a demonstration of how to handle the CheckWord Event.


Applying Checking
User Guide > How to Work with... > Recognition > Checking > Applying Checking

The most important property in controlling the checking subsystem is the ImGearRecRecognitionSettings. SpellingEnabled Property. This property is used to enable or disable the running of the checking subsystem.

If it is enabled (default), the correction of non-compliant words can be enabled or disabled. For this, the CorrectionEnabled Property and SpellingLanguage Property are used. If correction is disabled, non-compliant and suspicious words are flagged, but no auto-correction is done. When enabled, all these unchanged words are flagged, while some characters may be changed and are marked as changed. Correction is the default, so the application needs to call this property only when it wants to explicitly disable the word correction feature.

The remaining checking-related properties are specific to the particular checking system.

This section provides information about the following:

  • Applying Checking
    • Spell Checking Languages
    • Spell Checking with Automatic Spell Language Selection
    • UD-Checking Prerequisites


Spell Checking Languages
User Guide > How to Work with... > Recognition > Checking > Applying Checking > Spell Checking Languages

The spelling languages available in the current recognition engine configuration can be accessed via the ImGearRecRecognitionSettings. SpellingLanguages Property. The application can specify a language setting as the spelling language, valid for the next page or pages with the SpellingLanguage Property.

Additionally, vertical language checking can also be activated when one of the Vertical dictionaries (e.g., LEGAL_GER.DMD) has been set through the VerticalDictionary Property.

Configuring the Checking Subsystem to Use English Spell Checking

C#
Copy Code
igRecognition.Recognition.SpellingEnabled = true;
igRecognition.Recognition.CorrectionEnabled = true;
igRecognition.Recognition.SpellingLanguage = ImGearRecLanguage.ENG;
VB .NET
Copy Code
igRecognition.Recognition.SpellingEnabled = True
igRecognition.Recognition.CorrectionEnabled = True
igRecognition.Recognition.SpellingLanguage = ImGearRecLanguage.ENG

When the spelling language is set to NO, or when it specifies a language for which there is no language dictionary, the language checking will not be activated for the zones of the page.


Spell Checking with Automatic Spell Language Selection
User Guide > How to Work with... > Recognition > Checking > Applying Checking > Spell Checking with Automatic Spell Language Selection

In the special (default) case, when the specified spelling language is set to AUTO, the language checking will be performed based on the recognition language selection (LanguageEnabled Property) as follows:

  • If the recognition language selection is empty, there won't be language checking
  • If one recognition language has been set, that language will be automatically selected for language checking, assuming that the appropriate Language dictionary is available
  • If two or more languages are selected for recognition, language checking will be done for all selected languages for which a Language dictionary is available


UD-Checking Prerequisites
User Guide > How to Work with... > Recognition > Checking > Applying Checking > UD-Checking Prerequisites

The prerequisites for checking with a User dictionary are:

  • A properly prepared User dictionary file
  • A call to ImGearRecUserDictionary. Load Method
  • Zones referring to sections in the User dictionary (if not, the default section of the User dictionary is required)

The checking subsystem can handle two kinds of User dictionaries: native dictionary files (created or updated by a previous ImGearRecUserDictionary. Save Method call), and word-list file. The way of preparing a native User dictionary file is given in the next topic. A word-list file is a text file; it contains words, one in each line.

Before recognition, the ImGearRecUserDictionary. Load Method must be called with the name of the User dictionary file and also with a section name. This section name defines the default section in the User dictionary. The items under this section will be "used" by any zone in the zone list whose UserDictionarySection Property contains an empty string. (Note that the auto-zoning feature always creates zones with an empty string in this property.) Other sections in the User dictionary can be referred to by name. In this case, for those zones where it is needed, the UserDictionarySection Property must contain the section name. This way different zones on a page can be UD-checked with different sections. A zone will be subject to UD-checking only if the USERDICT_PROHIBIT flag of its Checking Property is off.

Configuring the Checking Subsystem to Enable UD-Checking

C#
Copy Code
igRecognition.Recognition.SpellingEnabled = true;
igRecognition.Recognition.CorrectionEnabled = true;
igRecognition.Recognition.UserDictionary.Load("MYWORDS.DCT", "DEFSECT");
VB .NET
Copy Code
igRecognition.Recognition.SpellingEnabled = True
igRecognition.Recognition.CorrectionEnabled = True
igRecognition.Recognition.UserDictionary.Load("MYWORDS.DCT", "DEFSECT")

After recognition, the Checking Property of the zones might be updated by one of the flags: LANGDICT_USED, USERDICT_USED, CHECKCBF_USED, or VERTDICT_USED.

See Also
Preparing and Maintaining the User Dictionary


Preparing and Maintaining the User Dictionary
User Guide > How to Work with... > Recognition > Checking > Preparing and Maintaining the User Dictionary

Compiling and changing a User dictionary requires that the application specify a User dictionary file with the ImGearRecUserDictionary. Load Method or create a new dictionary using the Create Method. At this point the content of the User dictionary can be listed, and items can be added or removed on request. Accessing the contents of the User dictionary or performing editing operations will open it for maintenance. If the User dictionary has been opened for maintenance, the user must call the Close Method before performing recognition.

The Modified Property can be used to learn whether there has been any change since the User dictionary was last opened for maintenance.

Changes can be made permanent by calling the Save Method.

A new User dictionary can be created by calling the Create Method followed by the Save Method as follows:

Creating a New User Dictionary and Adding UDitems to It

C#
Copy Code
string userdict = "NEW_USER.DCT";
string sectA = "Section_A";
string item1 = "Peabody";
string item2 = "Budapest";
ImGearRecUserDictionary igRecUserDictionary = igRecognition.Recognition.UserDictionary;
igRecUserDictionary.Create();
igRecUserDictionary.AddItem(new ImGearRecUDItem(sectA, item1));
igRecUserDictionary.AddItem(new ImGearRecUDItem(sectA, item2));
igRecUserDictionary.Save(userdict);
igRecUserDictionary.Close();
VB .NET
Copy Code
Dim userdict As String = "NEW_USER.DCT"
Dim sectA As String = "Section_A"
Dim item1 As String = "Peabody"
Dim item2 As String = "Budapest"
Dim igRecUserDictionary As ImGearRecUserDictionary = igRecognition.Recognition.UserDictionary
igRecUserDictionary.Create()
igRecUserDictionary.AddItem(New ImGearRecUDItem(sectA, item1))
igRecUserDictionary.AddItem(New ImGearRecUDItem(sectA, item2))
igRecUserDictionary.Save(userdict)
igRecUserDictionary.Close()

A list of sections in the currently opened User dictionary can be retrieved with the GetSections Method.

A list of UDitems (the elements or entries) of the currently opened User dictionary can be retrieved with the GetItems Method. This method returns a list of the UDitems belonging to the specified section of the User dictionary with their attribute(s). The ImGearRecUDItem. IsRegExp Property denotes whether or not the item is a regular expression.

Elements can be added to the User dictionary with the AddItem Method. When adding a new UDitem with a non-existing section specified, the section will be automatically created. Existing UDitems can be deleted from the User dictionary with the DeleteItem Method. Sections are automatically removed as soon as their last UD item is deleted.

Maintaining an Existing User Dictionary

C#
Copy Code
string userdict = "NEW_USER.DCT";
string sectA = "Section_A";
string sectB = "Section_B";
string item1 = "Peabody";
string item2 = "Peabody";
string item3 = "Budapest";
ImGearRecUserDictionary igRecUserDictionary = igRecognition.Recognition.UserDictionary;
igRecUserDictionary.Load(userdict, sectB);
igRecUserDictionary.AddItem(new ImGearRecUDItem(sectB, item1));
igRecUserDictionary.AddItem(new ImGearRecUDItem(sectB, item3));
igRecUserDictionary.DeleteItem(new ImGearRecUDItem(sectA, item2));
if (igRecUserDictionary.Modified)
      igRecUserDictionary.Save(userdict);
igRecUserDictionary.Close();
VB .NET
Copy Code
Dim userdict As String = "NEW_USER.DCT"
Dim sectA As String = "Section_A"
Dim sectB As String = "Section_B"
Dim item1 As String = "Peabody"
Dim item2 As String = "Peabody"
Dim item3 As String = "Budapest"
Dim igRecUserDictionary As ImGearRecUserDictionary = igRecognition.Recognition.UserDictionary
igRecUserDictionary.Load(userdict, sectB)
igRecUserDictionary.AddItem(New ImGearRecUDItem(sectB, item1))
igRecUserDictionary.AddItem(New ImGearRecUDItem(sectB, item3))
igRecUserDictionary.DeleteItem(New ImGearRecUDItem(sectA, item2))
If igRecUserDictionary.Modified Then
      igRecUserDictionary.Save(userdict)
End If
igRecUserDictionary.Close()
A User Dictionary that has been opened with Load Method or created with Create Method must be closed with Close Method before calling any method that performs recognition (e.g., Recognize Method).


Recognition Output
User Guide > How to Work with... > Recognition > Recognition Output

This section consists of the following subsections:

  • Recognition Output
    • Code Pages
    • Exporting Recognized Data Directly to Text Formats
    • Exporting to a PDF Output Document
    • Exporting to a Formatted Output Document
    • Format Retention in Final Output Documents
    • Embedded Images in Final Output Documents
    • Confidence Reporting
    • Progress Indication
    • Processing Statistics


Code Pages
User Guide > How to Work with... > Recognition > Recognition Output > Code Pages

One of the recognition engine's settings is its Code Page setting, which can be set using the ImGearRecOutputManager. CodePage Property.

Recognized characters are stored internally in the recognition engine in their UNICODE representation. The current Code Page is taken into account either when converting a character to/from this UNICODE representation, or when converting the recognition data to the final output document. The utility methods ConvertCodePageToUnicode Method and ConvertUnicodeToCodePage Method are provided in case it is necessary for the application to perform such conversions, i.e., when configuring the language environment.

The ConvertCodePageToUnicode Method is useful when an API requires a UNICODE character or character string parameter, and you know only the character code in your target Code Page.

The output conversion process performs character code conversions from UNICODE into the current code page while producing the final output document.

In most cases, the Code Page setting of the recognition engine must be specified together with the Output Text Format for the final output document. While some output converters ignore the Code Page setting, others, typically the text converters, apply it during their running.

The current Code Page setting should be able to express all characters validated for recognition (i.e., the Character Set). You can use the OutOfCodePageCharacters Property to decide whether the current Code Page fulfills this requirement.

The CodePages Property can be used to access the list of available Code Pages.

Enumerating the List of Available Code Pages

C#
Copy Code
string codePageList = "";
for (int i = 0; i < igRecognition.OutputManager.CodePages.Count; i++)
     codePageList += igRecognition.OutputManager.CodePages[i].Name + Environment.NewLine;
System.Console.WriteLine(codePageList);
VB .NET
Copy Code
Dim codePageList As String = ""
Dim i As Integer = 0
While i < igRecognition.OutputManager.CodePages.Count
      codePageList += igRecognition.OutputManager.CodePages(i).Name + Environment.NewLine
      System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
End While
System.Console.WriteLine(codePageList)

There can be conflicts between the set of characters validated for recognition (i.e., the Character Set) and the Code Page selection; a selected Code Page may not support some characters. For example, if you select the Hungarian language and the current Code Page is Windows ANSI (Code Page 1252), the final output document will not contain some accented characters for that language. Use the OutOfCodePageCharacters Property to check whether the current Code Page setting contains all the characters of the current Language environment (language selection, the LanguagesPlus characters), and any characters listed as FilterPlus characters. The OutOfCodePageCharacters Property returns a string of characters not supported by the current Code Page (non-supported characters).

If the language and Code Page settings are such that there are non-supported characters when output conversion is performed, the recognition engine tries to replace non-supported characters with somewhat similar shaped ones in the final output document. This substitution does not work in all cases; mainly it is good for replacing non-supported accented characters with un-accented ones. The final output document will contain a missing symbol in the place of characters, which were recognized correctly but could not be either exported or substituted.

The application can use the MissingSymbol Property to define which character from the current Code Page should be used to indicate a missing symbol.


Exporting Recognized Data Directly to Text Formats
User Guide > How to Work with... > Recognition > Recognition Output > Exporting Recognized Data Directly to Text Formats

ImageGear Recognition API allows saving recognized data to a number of simple text and XML formats. Use ImGearRecOutputManager.WriteDirectText methods to write recognized data of an ImGearRecPage object, or an array of ImGearRecPage objects, to a file or a stream as text. Use ImGearRecOutputManager.DirectTextFormat property to get or set the format for saving. The following formats are available:

  • Simple Text.
  • Comma Separated Text, which can be used to represent tables.
  • Formatted Text, which delivers plain text, but attempts to keep layout (columns and boxes) as detected in the original image using tabulators.
  • Simple XML with letter coordinates, which is typically used for further processing recognized data. You can easily parse (e.g., MSXML) or transform (XSLT) the output xml file. The format of the xml output is specified by the same scheme as the Layout Retention Xml Output. Refer to Nuance XML schema, ssdoc-schema3.xsd, distributed in the ImageGear for .NET installation's Bin directory.

Writing Results to a File

The following example loads an image file, recognizes it, and outputs it to a file as formatted text.

C#
Copy Code
using (FileStream content = new FileStream("test1.tif", FileMode.Open))
{
      ImGearPage igPage = ImGearFileFormats.LoadPage(content, 0);
      ImGearRecPage recPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
      recPage.Image.Preprocess();
      recPage.Recognize();
      igRecognition.OutputManager.CodePage = "Windows ANSI";
     igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText;
      if (File.Exists("singlePage.TXT"))
      {
           File.Delete("singlePage.TXT");
      }
      igRecognition.OutputManager.WriteDirectText(recPage, "singlePage.TXT");
      recPage.Dispose();
}
VB .NET
Copy Code
Using content As New FileStream("test1.tif", FileMode.Open)
      Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, 0)
      Dim recPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
      recPage.Image.Preprocess()
      recPage.Recognize()
      igRecognition.OutputManager.CodePage = "Windows ANSI"
      igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText
      If File.Exists("singlePage.TXT") Then
           File.Delete("singlePage.TXT")
      End If
      igRecognition.OutputManager.WriteDirectText(recPage, "singlePage.TXT")
      recPage.Dispose()
End Using

Writing Results to a Stream

The following example loads an image file, recognizes it, and outputs it to a stream as formatted text.

C# Example
Copy Code
string resultText = "";
using (MemoryStream stream = new MemoryStream())
{
    ImGearPage igPage = ImGearFileFormats.LoadPage(content, 0);
    ImGearRecPage recPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
    recPage.Image.Preprocess();
    recPage.Recognize();
    igRecognition.OutputManager.CodePage = "Windows ANSI";
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText;
    igRecognition.OutputManager.WriteDirectText(recPage, stream);
    using (StreamReader reader = new StreamReader(stream))
    {
        stream.Seek(0, SeekOrigin.Begin);
        resultText = reader.ReadToEnd();
    }
    recPage.Dispose();
}
VB.NET Example
Copy Code
Dim resultText As String
Using stream As New MemoryStream()
    Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, 0)
    Dim recPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
    recPage.Image.Preprocess()
    recPage.Recognize()
    igRecognition.OutputManager.CodePage = "Windows ANSI"
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText
    igRecognition.OutputManager.WriteDirectText(recPage, stream)
    Using reader As New StreamReader(stream)
        stream.Seek(0, SeekOrigin.Begin)
        resultText = reader.ReadToEnd()
    End Using
    recPage.Dispose()
End Using

A more advanced approach to outputting recognized data is to use Formatted Output. However, this requires ImGearRecLicenseFeature.FormattedOutput to be enabled. For more details, see Exporting to a Formatted Output Document.


Exporting to a PDF Output Document
User Guide > How to Work with... > Recognition > Recognition Output > Exporting to a PDF Output Document

The ImageGear Recognition API allows saving recognized data to PDF documents. Unlike exporting to other output formats that use the ImGearRecOutputManager class, exporting recognition results to a PDF is accomplished by using methods of the ImGearRecPage object directly.

This PDF export feature requires a license the enables the PDF format.

The ImGearRecPage.CreatePDFPage method will create a new PDF page and add the recognized text, and optionally the original input image, to it. The new page is then appended to the new or existing PDF document specified in the first parameter.

Alternatively, if a PDF page already exists, the ImGearRecPage.PopulatePDFPage method can populate the page with the recognized data and/or original input image. Any existing content of the PDF page is preserved.

Once the recognized data has been added to the PDF document by either of the above methods, the ImGearPDFDocument.Save method can be called to write the PDF document to a file.

Both the CreatePDFPage and PopulatePDFPage methods provide an ImGearRecPDFOutputOptions class object parameter to adjust settings of the output PDF document. These settings allow the caller to show or hide the added text and/or image, indicate a compression to use for images (subject to PDF requirements), specify the PDF fonts to use for various types of text, and select whether to add text to the PDF using Windows ANSI or Unicode encoding.

If JPEG compression is used for compressing images, the compression quality can be adjusted using the global ImageGear filter parameters. The Quality and DecimationType values will be used for JPEG compression of images in the recognition PDF output. All other JPEG filter parameters are ignored. See the JPEG format topic for more information about these parameters. See the Using Filter Control Parameters topic for information on how to set the global filter parameters.
C# Example
Copy Code
using (FileStream content = new FileStream("test1.tif", FileMode.Open))
{
    ImGearPage igPage = ImGearFileFormats.LoadPage(content, 0);
    // Import image into Recognition engine
    ImGearRecPage recPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
    recPage.Image.Preprocess();
    recPage.Recognize();
    // Create and set PDF Output options; Text-only PDF
    ImGearRecPDFOutputOptions options = new ImGearRecPDFOutputOptions();
    options.VisibleImage = false;
    options.VisibleText = true;
    // Initialize PDF Assembly for export
    ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat());
    ImGearPDF.Initialize();
    // Export page to PDF
    using (ImGearPDFDocument pdfDocument = new ImGearPDFDocument())
    {
        recPage.CreatePDFPage(pdfDocument, options);
        pdfDocument.Save("test1.pdf", ImGearSavingFormats.PDF_UNCOMP,
            0, 0, (int)ImGearPDFPageRange.ALL_PAGES, ImGearSavingModes.OVERWRITE);
    }
    recPage.Dispose();
}

VB.NET Example
Copy Code
Using content As New FileStream("test.tif", FileMode.Open, FileAccess.Read)
    Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, 0)
    ' Import the page into the recognition engine
    Dim recPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
    recPage.Image.Preprocess()
    recPage.Recognize()
    ' Create and set PDF Output options; Text-only PDF
    Dim options As New ImGearRecPDFOutputOptions()
    Options.VisibleImage = False
    Options.VisibleText = True
    ' Initialize PDF Assembly for export
    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
    ImGearPDF.Initialize()
    ' Export page to PDF
    Using pdfDocument As ImGearPDFDocument = New ImGearPDFDocument()
        recPage.CreatePDFPage(pdfDocument, options)
        pdfDocument.Save("test1.pdf", ImGearSavingFormats.PDF_UNCOMP,
            0, 0, CInt(ImGearPDFPageRange.ALL_PAGES), ImGearSavingModes.OVERWRITE)
    End Using
End Using

PDF/A Support

If your PDF documents require conformance to the PDF/A-1a standard, the ImGearRecPDFOutputOptions class provides a setting to make it easy to produce PDF output that can be easily and automatically converted to PDF/A later with the PDF Converter. When the ImGearRecPDFOutputOptions.OptimizeForPdfa property is set to True, Recognition will automatically produce the necessary information in the output PDF to satisfy much of the PDF/A-1a requirements. The following is an overview on what exactly will be done:

  • Logical Structure and Tagging: This is one of the most difficult requirements to satisfy automatically for achieving PDF/A-1a compliance. The logical structure, combined with tagging, describes the content (e.g. text and images) of the document and how it is logically arranged. More information about this topic can be found in the PDF Reference, Section 10.6 Logical Structure.

Because of the page decomposition that occurred during the Recognition process, much information about the logical structure of a page is already understood. This information allows Recognition to automatically create the logical structure and tags for the PDF content that is produced by it.
The following hierarchy is followed by Recognition to create the logical structure. Recognition will also safely handle the case where PDF content is appended to an existing PDF document that already contains a logical structure.

\Document
\OCR_Page (Part) – References the PDF page where OCR was performed.
\OCR_Zone (Div) – References all recognized text in a single OCR zone.
\OCR_Image (Figure) – References the original image used to perform OCR.

  • Fonts: The PDF/A-1 standards require that all fonts used by visible text in a PDF document be fully embedded. Furthermore, any text in the document, hidden or visible, must be able to be mapped to Unicode values. Recognition will satisfy both of these requirements by embedding fonts that are used by visible text and creating a ToUnicode table for all fonts that are used in the document.

When creating Searchable Text PDFs consisting of hidden text aligned under the original image, any fonts used in this case will not be embedded because the text is not visible.

It is important to note that the PDF exported from ImageGear Recognition will not be fully PDF/A compliant. Use the ImageGear PDF Converter to automatically create a fully compliant PDF/A document. This process is demonstrated in the example below.

Example: Exporting to a Text-only PDF/A Document

C# Example
Copy Code
using (FileStream content = new FileStream("test1.tif", FileMode.Open))
{
    ImGearPage igPage = ImGearFileFormats.LoadPage(content, 0);
    // Import image into Recognition engine
    ImGearRecPage recPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
    recPage.Image.Preprocess();
    recPage.Recognize();
    // Create and set PDF Output options; Text-only PDF
    ImGearRecPDFOutputOptions options = new ImGearRecPDFOutputOptions();
    options.VisibleImage = false;
    options.VisibleText = true;
    options.OptimizeForPdfa = true;
    // Initialize PDF Assembly for export
    ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat());
    ImGearPDF.Initialize();
    // Export page to PDF
    using (ImGearPDFDocument pdfDocument = new ImGearPDFDocument())
    {
        recPage.CreatePDFPage(pdfDocument, options);
        // Convert PDF to full PDF/A-1a compliance
        ImGearPDFPreflightConvertOptions options = new ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1);
        ImGearPDFPreflight preflight = new ImGearPDFPreflight(pdfDocument);
        preflight.Convert(options);
        pdfDocument.Save("test1.pdf", ImGearSavingFormats.PDF_UNCOMP,
            0, 0, (int)ImGearPDFPageRange.ALL_PAGES, ImGearSavingModes.OVERWRITE);
    }
    recPage.Dispose();
}
VB.NET Example
Copy Code
Using content As New FileStream("test.tif", FileMode.Open, FileAccess.Read)
    Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, 0)
    ' Import the page into the recognition engine
    Dim recPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
    recPage.Image.Preprocess()
    recPage.Recognize()
    ' Create and set PDF Output options; Text-only PDF
    Dim options As New ImGearRecPDFOutputOptions()
    Options.VisibleImage = False
    Options.VisibleText = True
    Options.OptimizeForPdfa = True
    ' Initialize PDF Assembly for export
    ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat())
    ImGearPDF.Initialize()
    ' Export page to PDF
    Using pdfDocument As ImGearPDFDocument = New ImGearPDFDocument()
        recPage.CreatePDFPage(pdfDocument, options)
        ' Convert PDF to full PDF/A-1a compliance
         Dim convertOptions As New ImGearPDFPreflightConvertOptions(ImGearPDFPreflightProfile.PDFA_1A_2005, 0, -1)
         Dim preflight As New ImGearPDFPreflight(pdfDocument)
         preflight.Convert(convertOptions)
        pdfDocument.Save("test1.pdf", ImGearSavingFormats.PDF_UNCOMP,
            0, 0, CInt(ImGearPDFPageRange.ALL_PAGES), ImGearSavingModes.OVERWRITE)
    End Using
End Using


Exporting to a Formatted Output Document
User Guide > How to Work with... > Recognition > Recognition Output > Exporting to a Formatted Output Document

The ImageGear Recognition API allows saving recognized data to a number of document formats, such as RTF, Microsoft Office Word, or Excel.

This API group requires ImGearRecLicenseFeature.FormattedOutput to be enabled.

After having successfully recognized the image (or a series of images), create an ImGearRecDocument Class object for accumulating recognized pages and writing them to the final output document. Use ImGearRecDocument. Create static method to create an empty ImGearRecDocument object. Then, use ImGearRecDocument.InsertPage to insert recognized pages to the document. ImGearRecDocument class also allows you to remove, update, or reorder pages. You can also save ImGearRecDocument object into an intermediate file, preserving all of the recognized data, and reopen it later. Use ImGearRecDocument.Save Method and ImGearRecDocument.Open static method, correspondingly.

When a page has been added to the document, the document gets ownership of the recognized data, and the page object becomes invalid. Use ImGearRecPage.IsValid property to check if the page is valid. If you need to re-recognize the image that has been added to a document, reimport it from ImGearPage. You can then recognize it and update the corresponding page in the document, using ImGearRecDocument.UpdatePage.

When all document pages have been recognized, you can output the final document using ImGearRecOutputManager.WriteDocument. The Code Page, format of the final output document, and the level of format retention should be specified beforehand, using the CodePage Property, Format Property, and Level Property. The full list of supported output formats is given in the topic Output Text Format List.

To check whether a requested output format is available in the current Recognition API's configuration, use the Formats Property to examine the list of available output formats.

Enumerating the Available Output Text File Formats

C#
Copy Code
string formatList = "";
for (int i = 0; i < igRecognition.OutputManager.Formats.Count; i++)
{
     ImGearRecOutputFormat igRecOutputFormat = igRecognition.OutputManager.Formats[i];
     formatList += "Text Format: " + igRecOutputFormat.Name + Environment.NewLine;
     formatList += "Extension: " + igRecOutputFormat.DefaultFileExtension + Environment.NewLine;
}
System.Console.WriteLine(formatList);
VB .NET
Copy Code
Dim formatList As String = ""
Dim i As Integer = 0
While i < igRecognition.OutputManager.Formats.Count
      Dim igRecOutputFormat As ImGearRecOutputFormat = igRecognition.OutputManager.Formats(i)
      formatList += "Text Format: " + igRecOutputFormat.Name + Environment.NewLine
      formatList += "Extension: " + igRecOutputFormat.DefaultFileExtension + Environment.NewLine
      System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
End While
System.Console.WriteLine(formatList)

In some cases the application may need to access the recognized information on a per-character basis. For this structured data output, you can use the GetLetters Method, which provides access to the recognized output of the Recognize Method.

The GetLetters Method can only be called immediately after recognition, so the Recognize Method must be used with one page being processed at a time.


Format Retention in Final Output Documents
User Guide > How to Work with... > Recognition > Recognition Output > Format Retention in Final Output Documents

If you select an advanced word processor as the output text format for the final output document (e.g., Microsoft Word), you may want the recognition engine to pass as much formatting information as it can collect from a document to make the layout result similar to the original one. Use ImGearRecOutputManager.Level Property to control the formatting level of the output document.

In the final output document, not all possible formatting features can be used, since either they are not applicable or they were not implemented for that particular converter. For example, specifying the page margins in conjunction with a text output converter won't have any effect. The converters implement the various output formatting features as described in the Output converter formatting properties topic.


Embedded Images in Final Output Documents
User Guide > How to Work with... > Recognition > Recognition Output > Embedded Images in Final Output Documents

The ImageGear Recognition API is able to export images to the final output document for graphics zones. Images obtained from graphic zones are stored internally, and inserted to the final output document if the output format and level allow this.


Confidence Reporting
User Guide > How to Work with... > Recognition > Recognition Output > Confidence Reporting

For some applications, it may be important to know the reliability of the recognized text. These applications may require having additional confidence information for the recognized characters and/or words.

Confidence information can be retrieved directly into application memory by a call to the GetLetters Method, just after issuing the Recognize Method call. The GetLetters Method provides the most detailed information about the recognized data: it results in a ImGearRecLetter Class for each recognized character.

The ImGearRecLetter Class provides character recognition confidence information via its ConfidenceInfo Property. The ConfidenceInfo Property is a combined value. Its most significant bit is used to express the certainty/uncertainty of the word (the word is uncertain if this bit is set to 1). The remaining bits express the certainty of the recognition of the character, which ranges between 0 and 100. A value of zero (0) means that the recognition engine recognized the character with high confidence. In some cases a word may have some or all characters that are individually suspicious but the characters are not be marked suspicious in the word bit. This is usually a result of language or user dictionary checking. It means the word was validated by the checking subsystem.

Applications that examine the character confidence information can use a threshold value, above which the character value is treated as a suspicious result. A value of 64 is recommended for this purpose. A value less than 64 will indicate that the character was recognized with high confidence. A value of 64 or greater marks that code is suspicious. This value (64) is also used internally in the same manner when the output-marking feature for suspicious characters in the output text is enabled.

There are also two properties in ImGearRecLetter Class called Confidence Property and WordUncertain Property. These are provided for convenience. They decode the contents of the ConfidenceInfo Property. The Confidence Property ranges between 0 and 100, and indicates confidence rather than error: 0 indicates low confidence, and 100 indicates high confidence. If the WordUncertain Property is true, the word containing the letter is uncertain.

The confidence reporting system works best when all three recognition modules are used in the voting scheme (OMNIFONT_PLUS3W). If other machine print recognition modules are used (OMNIFONT_PLUS2W, OMNIFONT_MTX, etc.) then confidence information is still available, but the ability of the system to properly report confidence will be reduced. This will result in a higher level of false negative and false positive reporting of suspicious recognition results. See ImGearRecRecognitionModule enumeration for information on recognition modules.

Alternatives

The ImGearRecLetter Class provides two other properties, AlternativeCharacters and WordSuggestsions, which report possible alternative values for a character or word. These values, used in conjunction with the confidence values, may be helpful in a user-checking scenario when low confidence results are detected.

Alternative character values, found in the AlternativeCharacters Property, are a list of additional character options for the current letter result. Alternative character values are commonly available for characters that are frequently misrecognized during the OCR process. For example, ‘i’ and ‘l’ are common alternatives for each other. Characters recognized with high confidence will typically not have any alternative character values listed.

Alternative word suggestions, found in the WordSuggestions Property, are a list of additional word options for the current word result. Word suggestions will only be available from the first letter of a word. Consecutive words can have the same suggestions, which is the case when the suggestion combines two or more space-separated words into a single one without spaces. For example, the consecutive words “Image” and “Gear” might both have word suggestions of “ImageGear” and “Image Gear” if the space between the words is not sufficient enough to confidently determine the word breaks. Words recognized with high confidence will typically not have any word suggestion values listed.


Progress Indication
User Guide > How to Work with... > Recognition > Recognition Output > Progress Indication

Typically the most time-consuming processes invoked by the Recognition engine are the recognition processes (RECOGNITION1, RECOGNITION2, and RECOGNITION3), and the final output document generation (WRITEFOUTDOC). In some particular cases, other processes like image loading (IMGINPUT) or image preprocessing (IMGPREPROCESS) might also take considerable time.

Sometimes it is advisable to provide the application user with feedback about these processes. The application can register an event handler for progress monitoring using the Progress Event of ImGearRecognition Class. The Recognition engine will fire the Progress Event during processing with a ImGearRecProgressEventArgs Class object containing information about the current process. The application can provide progress indication by handling this event. If the event handler sets the Abort Property of ImGearRecProgressEventArgs Class to true, it signals an interruption of the current process. This can be used to provide the application user with a cancel button.

The Process Property of the ImGearRecProgressEventArgs Class object identifies the current process (e.g., DECOMPOSITION, WRITEFOUTDOC, etc.). The Percent Property provides the progress information for the process.

If the current session includes one of the two recognition processes, the ImGearRecStatistics. CharCount Property and RejectedCharCount Property provide the number of recognized and rejected characters up to that point on the page being processed. This feature can be used to alert the user, or even some automatic monitoring code, that recognition accuracy has fallen below some predefined level.

Sample Event Registration and Event Handler for Progress Monitoring

C#
Copy Code
public delegate void UpdateProgressBarDelegate(ImGearRecProgressEventArgs e);
UpdateProgressBarDelegate progressDelegate = null;
void UpdateProgressBar(ImGearRecProgressEventArgs e)
{
     if (e.Percent < 100)
         toolStripStatusProgress.Text = e.Process + " - " + e.Percent + "%";
     else
         toolStripStatusProgress.Text = "Ready";
     this.Update();
}
private void recProgress(object sender, ImGearRecProgressEventArgs e)
{
     if(this.InvokeRequired)
     {
         object[] arg = new object[1];
         arg[0] = e;
         this.Invoke(progressDelegate, arg);
     }
     else
     {
         UpdateProgressBar(e);
     }
}
VB .NET
Copy Code
Public Delegate Sub UpdateProgressBarDelegate(ByVal e As ImGearRecProgressEventArgs)
Public progressDelegate As UpdateProgressBarDelegate
Sub UpdateProgressBar(ByVal e As ImGearRecProgressEventArgs)
     If e.Percent < 100 Then
         toolStripStatusProgress.Text = e.Process.ToString() + " - " + e.Percent.ToString() + "%"
     Else
         toolStripStatusProgress.Text = "Ready"
     End If
     Me.Update()
End Sub
Private Sub recProgress(ByVal sender As Object, ByVal e As ImGearRecProgressEventArgs)
     If Me.InvokeRequired Then
         Dim arg As Object() = New Object(0) {}
         arg(0) = e
         Me.Invoke(progressDelegate, arg)
     Else
         UpdateProgressBar(e)
     End If
End Sub


Processing Statistics
User Guide > How to Work with... > Recognition > Recognition Output > Processing Statistics

The integrating application can retrieve timing and other statistical information about the last accessed image. This includes the following:

  • Time used to load the image in the recognition engine's memory space
  • Time used for pre-processing the image, if any
  • Time used for auto-zoning of the image, if any
  • Recognition time measured until producing the recognition result
  • Number of recognized characters on the image
  • Number of recognized words on the image
  • Number of rejected characters on the image

The application accesses the ImGearRecPage. Statistics Property for this purpose. The properties of the ImGearRecStatistics Class object will return the relevant information.

The statistics properties can be called during any phase of the processing. The time for any processes (from ImGearRecProcess Enumeration) that have not run will contain zero (0). Similarly, if no recognition has been performed when the statistics properties are accessed, these properties will return zero (0).

All timing data is measured in milliseconds.

Processing Statistics of an Image

C#
Copy Code
int nChar, nWord, nRej;
int nSTime, nPTime, nLTime, nRTime;
ImGearRecStatistics igRecStatistics = igRecPage.Statistics;
nChar = igRecStatistics.CharCount;// Number of recognized characters
nWord = igRecStatistics.WordCount;// Number of recognized words
nRej = igRecStatistics.RejectedCharCount; // Number of rejected characters
nSTime = igRecStatistics.ReadTime;// Image reading time
nPTime = igRecStatistics.PreProcTime;  // Image pre-processing time
nLTime = igRecStatistics.DecompTime;  // Decomposition/auto-zoning time
nRTime = igRecStatistics.RecognitionTime; // Recognition time
// . . .
VB .NET
Copy Code
Dim nChar As Integer, nWord As Integer, nRej As Integer
Dim nSTime As Integer, nPTime As Integer, nLTime As Integer, nRTime As Integer
Dim igRecStatistics As ImGearRecStatistics = igRecPage.Statistics
nChar = igRecStatistics.CharCount
' Number of recognized characters
nWord = igRecStatistics.WordCount
' Number of recognized words
nRej = igRecStatistics.RejectedCharCount
' Number of rejected characters
nSTime = igRecStatistics.ReadTime
' Image reading time
nPTime = igRecStatistics.PreProcTime
' Image pre-processing time
nLTime = igRecStatistics.DecompTime
' Decomposition/auto-zoning time
nRTime = igRecStatistics.RecognitionTime
' Recognition time
' . . .


Recognition Namespace Specifications
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications

This Appendix provides detailed specifications of ImageGear Recognition namespace characters, codepages, language lists, modules, etc.

Portions of this document are excerpted from OmniPage Capture SDK 18.6 reference materials. Copyright © 2011 Nuance Communications, Inc. All Rights Reserved. Nuance and the Nuance logo are trademarks or registered trademarks of Nuance Communications, Inc. or its affiliates in the United States and/or other countries.

This section provides information about the following:

  • Recognition Namespace Specifications
    • Characters and Code Pages
    • Code Page List
      • Customized Code Pages
      • Code Page Ignored during Converting to the Output
    • Output Text Format List
    • Language Dictionary List
    • Vertical Dictionary List
    • Specifications for the Recognition Modules
      • Filling Method - Recognition Module Combinations
      • Recognition Modules and the Widest Available Character Set
      • Recognition Modules and Filters
      • Recognition Modules and Trade-off Settings
      • Recognition Modules and the Checking Subsystem
      • DOT 9-Pin Draft Dot-Matrix Recognition Module
      • FRX Multi-Lingual Omnifont Recognition Module
      • MOR Multi-Lingual Omnifont Recognition Module
      • MTX Omnifont Recognition Module
      • PLUS2W and PLUS3W Omnifont Recognition Modules
      • Asian Recognition Module


Characters and Code Pages
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Characters and Code Pages

The following tables list all the characters handled by the Engine, arranged in filter categories. The letters are in alphabetical order. You cannot extend the Engine’s capability beyond these characters (approx. 500 in total).

The first columns present the character names and their UNICODE value. The next columns show the character in ASCII (437), Roman-8, ANSI (1252), Greek-Elot, Greek-Memotek and WordPerfect code pages.

Some API functions need character strings stated in UNICODE values.

"MIS" in the tables means that the character is missing from the Code Page.

Where a character is unique to one or two Latin-alphabet languages, this is stated in the uppercase listing. In the Cyrillic character listing, the characters validated for Russian are indicated. Additionally validated characters for the other Cyrillic languages are listed in Languages and characters.

For full information on each character: which languages use it and which modules support it, see Characters, languages, modules.

Numbers (Digits)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Digit Zero | 0x0030 | 0 | 0 | 0 | 0 | 0 | 0x0030
Digit One | 0x0031 | 1 | 1 | 1 | 1 | 1 | 0x0031
Digit Two | 0x0032 | 2 | 2 | 2 | 2 | 2 | 0x0032
Digit Three | 0x0033 | 3 | 3 | 3 | 3 | 3 | 0x0033
Digit Four | 0x0034 | 4 | 4 | 4 | 4 | 4 | 0x0034
Digit Five | 0x0035 | 5 | 5 | 5 | 5 | 5 | 0x0035
Digit Six | 0x0036 | 6 | 6 | 6 | 6 | 6 | 0x0036
Digit Seven | 0x0037 | 7 | 7 | 7 | 7 | 7 | 0x0037
Digit Eight | 0x0038 | 8 | 8 | 8 | 8 | 8 | 0x0038
Digit Nine | 0x0039 | 9 | 9 | 9 | 9 | 9 | 0x0039

Latin Characters (Upper case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Cap. A Diaeresis | 0x00c4 | 142 | 216 | 196 | MIS | MIS | 0x011e
Cap. A Acute | 0x00c1 | MIS | 224 | 193 | MIS | MIS | 0x011a
Cap. A Ring | 0x00c5 | 143 | 208 | 197 | MIS | MIS | 0x0122
Cap. A Circumflex | 0x00c2 | MIS | 162 | 194 | MIS | MIS | 0x011c
Cap. A Grave | 0x00c0 | MIS | 161 | 192 | MIS | MIS | 0x0120
Cap. A Tilde (Portuguese) | 0x00c3 | MIS | 225 | 195 | MIS | MIS | 0x014c
Cap. A Breve (Romanian) | 0x0102 | MIS | MIS | MIS | MIS | MIS | MIS
Cap. A Ogonok (Polish, Lith...) | 0x0104 | MIS | MIS | MIS | MIS | MIS | 0x015e
Cap. A Macron (Latvian) | 0x0100 | MIS | MIS | MIS | MIS | MIS | 0x015c
Cap. AE | 0x00c6 | 146 | 211 | 198 | MIS | MIS | 0x0124
Cap. A | 0x0041 | A | A | A | A | A | 0x0041
Cap. B | 0x0042 | B | B | B | B | B | 0x0042
Cap. C Acute | 0x0106 | MIS | MIS | MIS | MIS | MIS | 0x0160
Cap. C Circumflex (Esperanto) | 0x0108 | MIS | MIS | MIS | MIS | MIS | 0x0164
Cap. C Hacek | 0x010c | MIS | MIS | MIS | MIS | MIS | 0x0162
Cap. C Dot (Maltese) | 0x010a | MIS | MIS | MIS | MIS | MIS | 0x0166
Cap. C Cedilla | 0x00c7 | 128 | 180 | 199 | MIS | MIS | 0x0126
Cap. C | 0x0043 | C | C | C | C | C | 0x0043
Cap. D Hacek (Czech, Slovak) | 0x010e | MIS | MIS | MIS | MIS | MIS | 0x0168
Cap. D Stroke (Croatian) | 0x0110 | MIS | MIS | MIS | MIS | MIS | 0X014e
Cap. D | 0x0044 | D | D | D | D | D | 0x0044
Cap. ETH (Icelandic, Faroese) | 0x00d0 | MIS | 227 | 208 | MIS | MIS | 0x0156
Cap. E Acute | 0x00c9 | 144 | 220 | 201 | MIS | MIS | 0x0128
Cap. E Diaeresis | 0x00cb | MIS | 165 | 203 | MIS | MIS | 0x012c
Cap. E Circumflex | 0x00ca | MIS | 164 | 202 | MIS | MIS | 0x012a
Cap. E Grave | 0x00c8 | MIS | 163 | 200 | MIS | MIS | 0x012e
Cap. E Hacek | 0x011a | MIS | MIS | MIS | MIS | MIS | 0x016a
Cap. E Dot (Lithuanian) | 0x0116 | MIS | MIS | MIS | MIS | MIS | 0x016c
Cap. E Ogonok (Polish, Lith…) | 0x0118 | MIS | MIS | MIS | MIS | MIS | 0x0170
Cap. E Macron (Latvian) | 0x0112 | MIS | MIS | MIS | MIS | MIS | 0x016e
Cap. E | 0x0045 | E | E | E | E | E | 0x0045
Cap. F | 0x0046 | F | F | F | F | F | 0x0046
Cap. G Circumflex (Esperanto) | 0x011c | MIS | MIS | MIS | MIS | MIS | 0x017a
Cap. G Breve (Turkish) | 0x011e | MIS | MIS | MIS | MIS | MIS | 0x0176
Cap. G Dot (Maltese) | 0x0120 | MIS | MIS | MIS | MIS | MIS | 0x017c
Cap. G Cedilla (Latv. + Sami) | 0x0122 | MIS | MIS | MIS | MIS | MIS | 0x0178
Cap. G | 0x0047 | G | G | G | G | G | 0x0047
Cap. H Circumflex (Esperanto) | 0x0124 | MIS | MIS | MIS | MIS | MIS | 0x017e
Cap. H Bar (Maltese) | 0x0126 | MIS | MIS | MIS | MIS | MIS | 0x0180
Cap. H | 0x0048 | H | H | H | H | H | 0x0048
Cap. I Diaeresis | 0x00cf | MIS | 167 | 207 | MIS | MIS | 0x0134
Cap. I Grave | 0x00cc | MIS | 230 | 204 | MIS | MIS | 0x0136
Cap. I Circumflex | 0x00ce | MIS | 166 | 206 | MIS | MIS | 0x0132
Cap. I Acute | 0x00cd | MIS | 229 | 205 | MIS | MIS | 0x0130
Cap. I Tilde (Inuit, Kikuyu) | 0x0128 | MIS | MIS | MIS | MIS | MIS | 0x0188
Cap. I Dot (Turkish) | 0x0130 | MIS | MIS | MIS | MIS | MIS | 0x0182
Cap. I Ogonok (Lithuanian) | 0x012e | MIS | MIS | MIS | MIS | MIS | 0x0186
Cap. I Macron (Latvian…) | 0x012a | MIS | MIS | MIS | MIS | MIS | 0x0184
Cap. I Hacek | 0x012c | MIS | MIS | MIS | MIS | MIS | MIS
Cap. I | 0x0049 | I | I | I | I | I | 0x0049
Cap. J Circumflex (Esperanto) | 0x0134 | MIS | MIS | MIS | MIS | MIS | 0x018c
Cap. J | 0x004a | J | J | J | J | J | 0x004a
Cap. K Cedilla (Latvian) | 0x0136 | MIS | MIS | MIS | MIS | MIS | 0x018e
Cap. K | 0x004b | K | K | K | K | K | 0x004b
Cap. L Acute (Slovak) | 0x0139 | MIS | MIS | MIS | MIS | MIS | 0x0190
Cap. L Hacek (Slovak) | 0x013d | MIS | MIS | MIS | MIS | MIS | 0x0192
Cap. L Slash (Polish…) | 0x0141 | MIS | MIS | MIS | MIS | MIS | 0x0198
Cap. L Cedilla (Latvian) | 0x013b | MIS | MIS | MIS | MIS | MIS | 0x0194
Cap. L | 0x004c | L | L | L | L | L | 0x004c
Cap. M | 0x004d | M | M | M | M | M | 0x004d
Cap. N Tilde | 0x00d1 | 165 | 182 | 209 | MIS | MIS | 0x0138
Cap. N Acute (Polish…) | 0x0143 | MIS | MIS | MIS | MIS | MIS | 0x019a
Cap. N Hacek (Czech, Slovak) | 0x0147 | MIS | MIS | MIS | MIS | MIS | 0x019e
Cap. N Cedilla (Latvian) | 0x0145 | MIS | MIS | MIS | MIS | MIS | 0x01a0
Cap. ENG (Sami) | 0x014a | MIS | MIS | MIS | MIS | MIS | 0x01d2
Cap. N | 0x004e | N | N | N | N | N | 0x004e
Cap. O Diaeresis | 0x00d6 | 153 | 218 | 214 | MIS | MIS | 0x013e
Cap. O Acute | 0x00d3 | MIS | 231 | 211 | MIS | MIS | 0x013a
Cap. O Circumflex | 0x00d4 | MIS | 223 | 212 | MIS | MIS | 0x013c
Cap. O Grave | 0x00d2 | MIS | 232 | 210 | MIS | MIS | 0x0140
Cap. O Tilde (Estonian, Port.) | 0x00d5 | MIS | 233 | 213 | MIS | MIS | 0x0152
Cap. O Double Acute (Hungarian) | 0x0150 | MIS | MIS | MIS | MIS | MIS | 0x01a2
Cap. O Macron (Latvian) | 0x014c | MIS | MIS | MIS | MIS | MIS | 0x01a4
Cap. O Breve (Latin) | 0x014e | MIS | MIS | MIS | MIS | MIS | MIS
Cap. O Slash (Danish, Nor. …) | 0x00d8 | MIS | 210 | 216 | MIS | MIS | 0x0150
Cap. O E (French) | 0x0152 | MIS | MIS | 140 | MIS | MIS | 0x01a6
Cap. O | 0x004f | O | O | O | O | O | 0x004f
Cap. P | 0x0050 | P | P | P | P | P | 0x0050
Cap. Q | 0x0051 | Q | Q | Q | Q | Q | 0x0051
Cap. R Acute (Slovak, Basque…) | 0x0154 | MIS | MIS | MIS | MIS | MIS | 0x01a8
Cap. R Hacek (Czech…) | 0x0158 | MIS | MIS | MIS | MIS | MIS | 0x01aa
Cap. R Cedilla (Latvian) | 0x0156 | MIS | MIS | MIS | MIS | MIS | 0x01ac
Cap. R | 0x0052 | R | R | R | R | R | 0x0052
Cap. S Hacek | 0x0160 | MIS | 235 | 138 | MIS | MIS | 0x01b0
Cap. S Acute (Polish…) | 0x015a | MIS | MIS | MIS | MIS | MIS | 0x01ae
Cap. S Circumflex (Esperanto) | 0x015c | MIS | MIS | MIS | MIS | MIS | 0x01b4
Cap. S Cedilla (Turkish, Rom. …) | 0x015e | MIS | MIS | MIS | MIS | MIS | 0x01b2
Cap. S | 0x0053 | S | S | S | S | S | 0x0053
Cap. T Hacek (Czech, Slovak) | 0x0164 | MIS | MIS | MIS | MIS | MIS | 0x01b6
Cap. T Cedilla (Romanian) | 0x0162 | MIS | MIS | MIS | MIS | MIS | 0x01b8
Cap. T THORN (Icelandic) | 0x00de | MIS | 240 | 222 | MIS | MIS | MIS
Cap. T Bar (Sami) | 0x0166 | MIS | MIS | MIS | MIS | MIS | 0x01ba
Cap. T | 0x0054 | T | T | T | T | T | 0x0054
Cap. U Diaeresis | 0x00dc | 154 | 219 | 220 | MIS | MIS | 0x0146
Cap. U Acute | 0x00da | MIS | 237 | 218 | MIS | MIS | 0x0142
Cap. U Circumflex | 0x00db | MIS | 174 | 219 | MIS | MIS | 0x0144
Cap. U Grave | 0x00d9 | MIS | 173 | 217 | MIS | MIS | 0x0148
Cap. U Tilde | 0x0168 | MIS | MIS | MIS | MIS | MIS | 0x01c6
Cap. U Double Acute(Hungarian) | 0x0170 | MIS | MIS | MIS | MIS | MIS | 0x01be
Cap. U Breve (Latin, Esperanto) | 0x016c | MIS | MIS | MIS | MIS | MIS | 0x01bc
Cap. U Ring (Czech) | 0x016e | MIS | MIS | MIS | MIS | MIS | 0x01c4
Cap. U Macron (Lith.+Latv. …) | 0x016a | MIS | MIS | MIS | MIS | MIS | 0x01c0
Cap. U Ogonok (Lithuanian) | 0x0172 | MIS | MIS | MIS | MIS | MIS | 0x01c2
Cap. U | 0x0055 | U | U | U | U | U | 0x0055
Cap. V | 0x0056 | V | V | V | V | V | 0x0056
Cap. W Circumflex (Welsh) | 0x0174 | MIS | MIS | MIS | MIS | MIS | 0x01c8
Cap. W | 0x0057 | W | W | W | W | W | 0x0057
Cap. X | 0x0058 | X | X | X | X | X | 0x0058
Cap. Y Acute | 0x00dd | MIS | 177 | 221 | MIS | MIS | 0x0154
Cap. Y Diaeresis (French) | 0x0178 | MIS | 238 | 159 | MIS | MIS | 0x014a
Cap. Y Circumflex (Welsh) | 0x0176 | MIS | MIS | MIS | MIS | MIS | 0x01ca
Cap. Y | 0x0059 | Y | Y | Y | Y | Y | 0x0059
Cap. Z Acute (Sorbian) | 0x0179 | MIS | MIS | MIS | MIS | MIS | 0x01cc
Cap. Z Hacek | 0x017d | MIS | MIS | MIS | MIS | MIS | 0x01ce
Cap. Z Dot (Polish, Maltese) | 0x017b | MIS | MIS | MIS | MIS | MIS | 0x01d0
Cap. Z | 0x005a | Z | Z | Z | Z | Z | 0x005a

Latin Characters (Lower case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Sml. A Diaeresis | 0x00e4 | 132 | 204 | 228 | MIS | MIS | 0x011f
Sml. A Acute | 0x00e1 | 160 | 196 | 225 | MIS | MIS | 0x011b
Sml. A Ring | 0x00e5 | 134 | 212 | 229 | MIS | MIS | 0x0123
Sml. A Circumflex | 0x00e2 | 131 | 192 | 226 | MIS | MIS | 0x011d
Sml. A Grave | 0x00e0 | 133 | 200 | 224 | MIS | MIS | 0x0121
Sml. A Tilde | 0x00e3 | MIS | 226 | 227 | MIS | MIS | 0x014d
Sml. A Feminine Ord. Ind. (Sp…) | 0x00aa | 166 | 249 | 170 | MIS | MIS | 0x040f
Sml. A Breve | 0x0103 | MIS | MIS | MIS | MIS | MIS | 0x015b
Sml. A Ogonok | 0x0105 | MIS | MIS | MIS | MIS | MIS | 0x015f
Sml. A Macron | 0x0101 | MIS | MIS | MIS | MIS | MIS | 0x015d
Sml. AE | 0x00e6 | 145 | 215 | 230 | MIS | MIS | 0x0125
Sml. A | 0x0061 | a | a | a | a | a | 0x0061
Sml. B | 0x0062 | b | b | b | b | b | 0x0062
Sml. C Acute | 0x0107 | MIS | MIS | MIS | MIS | MIS | 0x0161
Sml. C Circumflex | 0x0109 | MIS | MIS | MIS | MIS | MIS | 0x0165
Sml. C Hacek | 0x010d | MIS | MIS | MIS | MIS | MIS | 0x0163
Sml. C Dot | 0x010b | MIS | MIS | MIS | MIS | MIS | 0x0167
Sml. C Cedilla | 0x00e7 | 135 | 181 | 231 | MIS | MIS | 0x0127
Sml. C | 0x0063 | c | c | c | c | c | 0x0063
Sml. D Hacek | 0x010f | MIS | MIS | MIS | MIS | MIS | 0x0169
Sml. D Stroke | 0x0111 | MIS | MIS | MIS | MIS | MIS | 0X0145
Sml. D | 0x0064 | d | d | d | d | d | 0x0064
Sml. ETH | 0x00f0 | MIS | 228 | 240 | MIS | MIS | 0x0157
Sml. E Acute | 0x00e9 | 130 | 197 | 233 | MIS | MIS | 0x0129
Sml. E Diaeresis | 0x00eb | 137 | 205 | 235 | MIS | MIS | 0x012d
Sml. E Circumflex | 0x00ea | 136 | 193 | 234 | MIS | MIS | 0x012b
Sml. E Grave | 0x00e8 | 138 | 201 | 232 | MIS | MIS | 0x012f
Sml. E Hacek | 0x011b | MIS | MIS | MIS | MIS | MIS | 0x016b
Sml. E Dot | 0x0117 | MIS | MIS | MIS | MIS | MIS | 0x016d
Sml. E Ogonok | 0x0119 | MIS | MIS | MIS | MIS | MIS | 0x0171
Sml. E Macron | 0x0113 | MIS | MIS | MIS | MIS | MIS | 0x016f
Sml. E | 0x0065 | e | e | e | e | e | 0x0065
Sml. F | 0x0066 | f | f | f | f | f | 0x0066
Sml. G Circumflex | 0x011d | MIS | MIS | MIS | MIS | MIS | 0x017b
Sml. G Breve | 0x011f | MIS | MIS | MIS | MIS | MIS | 0x0177
Sml. G Dot | 0x0121 | MIS | MIS | MIS | MIS | MIS | 0x017d
Sml. G Cedilla | 0x0123 | MIS | MIS | MIS | MIS | MIS | 0x0179
Sml. G | 0x0067 | g | g | g | g | g | 0x0067
Sml. H Circumflex | 0x0125 | MIS | MIS | MIS | MIS | MIS | 0x017f
Sml. H Bar | 0x0127 | MIS | MIS | MIS | MIS | MIS | 0x0181
Sml. H | 0x0068 | h | h | h | h | h | 0x0068
Sml. I Diaeresis | 0x00ef | 139 | 221 | 239 | MIS | MIS | 0x0135
Sml. I Grave | 0x00ec | 141 | 217 | 236 | MIS | MIS | 0x0137
Sml. I Circumflex | 0x00ee | 140 | 209 | 238 | MIS | MIS | 0x0133
Sml. I Acute | 0x00ed | 161 | 213 | 237 | MIS | MIS | 0x0131
Sml. I Tilde | 0x0129 | MIS | MIS | MIS | MIS | MIS | 0x0189
Sml. I Ogonok | 0x012f | MIS | MIS | MIS | MIS | MIS | 0x0187
Sml. I Macron | 0x012b | MIS | MIS | MIS | MIS | MIS | 0x0185
Sml. I Hacek | 0x012d | MIS | MIS | MIS | MIS | MIS | MIS
Sml. Dotless I | 0x0131 | MIS | MIS | MIS | MIS | MIS | 0x0118
Sml. I | 0x0069 | i | i | i | i | i | 0x0069
Sml. J | 0x006a | j | j | j | j | j | 0x006a
Sml. J Circumflex | 0x0135 | MIS | MIS | MIS | MIS | MIS | 0x018d
Sml. K Cedilla | 0x0137 | MIS | MIS | MIS | MIS | MIS | 0x018f
Sml. K | 0x006b | k | k | k | k | k | 0x006b
Sml. L Acute | 0x013a | MIS | MIS | MIS | MIS | MIS | 0x0191
Sml. L Hacek | 0x013e | MIS | MIS | MIS | MIS | MIS | 0x0193
Sml. L Slash | 0x0142 | MIS | MIS | MIS | MIS | MIS | 0x0199
Sml. L Cedilla | 0x013c | MIS | MIS | MIS | MIS | MIS | 0x0195
Sml. L | 0x006c | l | l | l | l | l | 0x006c
Sml. M | 0x006d | m | m | m | m | m | 0x006d
Sml. N Tilde | 0x00f1 | 164 | 183 | 241 | MIS | MIS | 0x0139
Sml. N Acute | 0x0144 | MIS | MIS | MIS | MIS | MIS | 0x019b
Sml. N Hacek | 0x0148 | MIS | MIS | MIS | MIS | MIS | 0x019f
Sml. N Cedilla | 0x0146 | MIS | MIS | MIS | MIS | MIS | 0x019d
Sml. ENG | 0x014b | MIS | MIS | MIS | MIS | MIS | 0x01d3
Sml. N | 0x006e | n | n | n | n | n | 0x006e
Sml. O Diaeresis | 0x00f6 | 148 | 206 | 246 | MIS | MIS | 0x013f
Sml. O Acute | 0x00f3 | 162 | 198 | 243 | MIS | MIS | 0x013b
Sml. O Circumflex | 0x00f4 | 147 | 194 | 244 | MIS | MIS | 0x013d
Sml. O Grave | 0x00f2 | 149 | 202 | 242 | MIS | MIS | 0x0141
Sml. O Tilde | 0x00f5 | MIS | 234 | 245 | MIS | MIS | 0x0153
Sml. O Masculine Ord. Ind. (Sp…) | 0x00ba | 167 | 250 | 186 | MIS | MIS | 0x0410
Sml. O Double Acute | 0x0151 | MIS | MIS | MIS | MIS | MIS | 0x01a3
Sml. O Macron | 0x014d | MIS | MIS | MIS | MIS | MIS | 0x01a5
Sml. O Breve | 0x014f | MIS | MIS | MIS | MIS | MIS | MIS
Sml. O Slash | 0x00f8 | MIS | 214 | 248 | MIS | MIS | 0x0151
Sml. O E | 0x0153 | MIS | MIS | 156 | MIS | MIS | 0x01a7
Sml. O | 0x006f | o | o | o | o | o | 0x006f
Sml. P | 0x0070 | p | p | p | p | p | 0x0070
Sml. Q | 0x0071 | q | q | q | q | q | 0x0071
Sml. R Acute | 0x0155 | MIS | MIS | MIS | MIS | MIS | 0x01a9
Sml. R Hacek | 0x0159 | MIS | MIS | MIS | MIS | MIS | 0x01ab
Sml. R Cedilla | 0x0157 | MIS | MIS | MIS | MIS | MIS | 0x01ad
Sml. R | 0x0072 | r | r | r | r | r | 0x0072
Sml. S Hacek | 0x0161 | MIS | 236 | 154 | MIS | MIS | 0x01b1
Sml. S Acute | 0x015b | MIS | MIS | MIS | MIS | MIS | 0x01af
Sml. S Circumflex | 0x015d | MIS | MIS | MIS | MIS | MIS | 0x01b5
Sml. S Cedilla | 0x015f | MIS | MIS | MIS | MIS | MIS | 0x01b3
Sharp SS (German) | 0x00df | 225 | 222 | 223 | 169 | 153 | 0x0117
Sml. S | 0x0073 | s | s | s | s | s | 0x0073
Sml. T Hacek | 0x0165 | MIS | MIS | MIS | MIS | MIS | 0x01b7
Sml. T Cedilla | 0x0163 | MIS | MIS | MIS | MIS | MIS | 0x01b9
Sml. T THORN | 0x00fe | MIS | 241 | 254 | MIS | MIS | MIS
Sml. T Bar | 0x0167 | MIS | MIS | MIS | MIS | MIS | 0x01bb
Sml. T | 0x0074 | t | t | t | t | t | 0x0074
Sml. U Diaeresis | 0x00fc | 129 | 207 | 252 | MIS | MIS | 0x0147
Sml. U Acute | 0x00fa | 163 | 199 | 250 | MIS | MIS | 0x0143
Sml. U Circumflex | 0x00fb | 150 | 195 | 251 | MIS | MIS | 0x0145
Sml. U Grave | 0x00f9 | 151 | 203 | 249 | MIS | MIS | 0x014b
Sml. U Tilde | 0x0169 | MIS | MIS | MIS | MIS | MIS | 0x01c7
Sml. U Double Acute | 0x0171 | MIS | MIS | MIS | MIS | MIS | 0x01bf
Sml. U Breve | 0x016d | MIS | MIS | MIS | MIS | MIS | 0x01bd
Sml. U Ring | 0x016f | MIS | MIS | MIS | MIS | MIS | 0x01bb
Sml. U Macron | 0x016b | MIS | MIS | MIS | MIS | MIS | 0x01c1
Sml. U Ogonok | 0x0173 | MIS | MIS | MIS | MIS | MIS | 0x01c3
Sml. U | 0x0075 | u | u | u | u | u | 0x0075
Sml. V | 0x0076 | v | v | v | v | v | 0x0076
Sml. W Circumflex | 0x0175 | MIS | MIS | MIS | MIS | MIS | 0x01c9
Sml. W | 0x0077 | w | w | w | w | w | 0x0077
Sml. X | 0x0078 | x | x | x | x | x | 0x0078
Sml. Y Acute | 0x00fd | MIS | 178 | 253 | MIS | MIS | 0x0155
Sml. Y Diaeresis | 0x00ff | 152 | 239 | 255 | MIS | MIS | 0x014b
Sml. Y Circumflex | 0x0177 | MIS | MIS | MIS | MIS | MIS | 0x01cb
Sml. Y | 0x0079 | y | y | y | y | y | 0x0079
Sml. Z Acute | 0x017a | MIS | MIS | MIS | MIS | MIS | 0x01cd
Sml. Z Hacek | 0x017e | MIS | MIS | MIS | MIS | MIS | 0x01cf
Sml. Z Dot | 0x017c | MIS | MIS | MIS | MIS | MIS | 0x01d1
Sml. Z | 0x007a | z | z | z | z | z | 0x007a

Cyrillic Characters (Upper case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Cyr. Cap. A (Russian) | 0x0410 | MIS | MIS | MIS | MIS | MIS | 0x0a00
Cyr. Cap. YA (Russian) | 0x042f | MIS | MIS | MIS | MIS | MIS | 0x0a40
Cyr. Cap. BE (Russian) | 0x0411 | MIS | MIS | MIS | MIS | MIS | 0x0a02
Cyr. Cap. VE (Russian) | 0x0412 | MIS | MIS | MIS | MIS | MIS | 0x0a04
Cyr. Cap. GHE (Russian) | 0x0413 | MIS | MIS | MIS | MIS | MIS | 0x0a06
Cyr. Cap. GJE | 0x0403 | MIS | MIS | MIS | MIS | MIS | 0x0a46
Cyr. Cap.GHEWITHUPTURN | 0x0490 | MIS | MIS | MIS | MIS | MIS | 0x0a42
Cyr. Cap. DE (Russian) | 0x0414 | MIS | MIS | MIS | MIS | MIS | 0x0a08
Cyr. Cap. DJE | 0x0402 | MIS | MIS | MIS | MIS | MIS | 0x0a44
Cyr. Cap. IE (Russian) | 0x0415 | MIS | MIS | MIS | MIS | MIS | 0x0a0a
Cyr. Cap. IO (Russian) | 0x0401 | MIS | MIS | MIS | MIS | MIS | 0x0a0c
Cyr. Cap. UKRAINIANIE | 0x0404 | MIS | MIS | MIS | MIS | MIS | 0x0a48
Cyr. Cap. ZHE (Russian) | 0x0416 | MIS | MIS | MIS | MIS | MIS | 0x0a0e
Cyr. Cap. ZE (Russian) | 0x0417 | MIS | MIS | MIS | MIS | MIS | 0x0a10
Cyr. Cap. I (Russian) | 0x0418 | MIS | MIS | MIS | MIS | MIS | 0x0a12
Cyr. Cap. SHORTI (Russian) | 0x0419 | MIS | MIS | MIS | MIS | MIS | 0x0a14
Cyr. Cap.BYELORUSSIANUKRI | 0x0406 | MIS | MIS | MIS | MIS | MIS | 0x0a4c
Cyr. Cap. YI | 0x0407 | MIS | MIS | MIS | MIS | MIS | 0x0a4e
Cyr. Cap. YERU (Russian) | 0x042b | MIS | MIS | MIS | MIS | MIS | 0x0a38
Cyr. Cap. KA (Russian) | 0x041a | MIS | MIS | MIS | MIS | MIS | 0x0a16
Cyr. Cap. KJE | 0x040c | MIS | MIS | MIS | MIS | MIS | 0x0a58
Cyr. Cap. EL (Russian) | 0x041b | MIS | MIS | MIS | MIS | MIS | 0x0a18
Cyr. Cap. LJE | 0x0409 | MIS | MIS | MIS | MIS | MIS | 0x0a52
Cyr. Cap. EM (Russian) | 0x041c | MIS | MIS | MIS | MIS | MIS | 0x0a1a
Cyr. Cap. EN (Russian) | 0x041d | MIS | MIS | MIS | MIS | MIS | 0x0a1c
Cyr. Cap. NJE | 0x040a | MIS | MIS | MIS | MIS | MIS | 0x0a54
Cyr. Cap. O (Russian) | 0x041e | MIS | MIS | MIS | MIS | MIS | 0x0a1e
Cyr. Cap. PE (Russian) | 0x041f | MIS | MIS | MIS | MIS | MIS | 0x0a20
Cyr. Cap. ER (Russian) | 0x0420 | MIS | MIS | MIS | MIS | MIS | 0x0a22
Cyr. Cap. ES (Russian) | 0x0421 | MIS | MIS | MIS | MIS | MIS | 0x0a24
Cyr. Cap. TE (Russian) | 0x0422 | MIS | MIS | MIS | MIS | MIS | 0x0a26
Cyr. Cap. TSHE | 0x040b | MIS | MIS | MIS | MIS | MIS | 0x0a56
Cyr. Cap. U (Russian) | 0x0423 | MIS | MIS | MIS | MIS | MIS | 0x0a28
Cyr. Cap. YU (Russian) | 0x042e | MIS | MIS | MIS | MIS | MIS | 0x0a3e
Cyr. Cap. SHORTU | 0x040e | MIS | MIS | MIS | MIS | MIS | 0x0a5a
Cyr. Cap. EF (Russian) | 0x0424 | MIS | MIS | MIS | MIS | MIS | 0x0a2a
Cyr. Cap. HA (Russian) | 0x0425 | MIS | MIS | MIS | MIS | MIS | 0x0a2c
Cyr. Cap. TSE (Russian) | 0x0426 | MIS | MIS | MIS | MIS | MIS | 0x0a2e
Cyr. Cap. DZHE | 0x040f | MIS | MIS | MIS | MIS | MIS | 0x0a5c
Cyr. Cap. CHE (Russian) | 0x0427 | MIS | MIS | MIS | MIS | MIS | 0x0a30
Cyr. Cap. SHA (Russian) | 0x0428 | MIS | MIS | MIS | MIS | MIS | 0x0a32
Cyr. Cap. SHCHA (Russian) | 0x0429 | MIS | MIS | MIS | MIS | MIS | 0x0a34
Cyr. Cap. DZE | 0x0405 | MIS | MIS | MIS | MIS | MIS | 0x0a4a
Cyr. Cap. HARDSIGN (Russian) | 0x042a | MIS | MIS | MIS | MIS | MIS | 0x0a36
Cyr. Cap. JE | 0x0408 | MIS | MIS | MIS | MIS | MIS | 0x0a50
Cyr. Cap. SOFTSIGN (Russian) | 0x042c | MIS | MIS | MIS | MIS | MIS | 0x0a3a
Cyr. Cap. E (Russian) | 0x042d | MIS | MIS | MIS | MIS | MIS | 0x0a3c

Cyrillic Characters (Lower case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Cyr. Sml. A | 0x0430 | MIS | MIS | MIS | MIS | MIS | 0x0a01
Cyr. Sml. YA | 0x044f | MIS | MIS | MIS | MIS | MIS | 0x0a41
Cyr. Sml. BE | 0x0431 | MIS | MIS | MIS | MIS | MIS | 0x0a03
Cyr. Sml. VE | 0x0432 | MIS | MIS | MIS | MIS | MIS | 0x0a05
Cyr. Sml. GHE | 0x0433 | MIS | MIS | MIS | MIS | MIS | 0x0a07
Cyr. Sml. GHEWITHUPTURN | 0x0491 | MIS | MIS | MIS | MIS | MIS | 0x0a43
Cyr. Sml. GJE | 0x0453 | MIS | MIS | MIS | MIS | MIS | 0x0a47
Cyr. Sml. DE | 0x0434 | MIS | MIS | MIS | MIS | MIS | 0x0a09
Cyr. Sml. DJE | 0x0452 | MIS | MIS | MIS | MIS | MIS | 0x0a45
Cyr. Sml. IE | 0x0435 | MIS | MIS | MIS | MIS | MIS | 0x0a0b
Cyr. Sml. IO | 0x0451 | MIS | MIS | MIS | MIS | MIS | 0x0a0d
Cyr. Sml. UKRAINIANIE | 0x0454 | MIS | MIS | MIS | MIS | MIS | 0x0a49
Cyr. Sml. ZHE | 0x0436 | MIS | MIS | MIS | MIS | MIS | 0x0a0f
Cyr. Sml. ZE | 0x0437 | MIS | MIS | MIS | MIS | MIS | 0x0a11
Cyr. Sml. I | 0x0438 | MIS | MIS | MIS | MIS | MIS | 0x0a13
Cyr. Sml. SHORTI | 0x0439 | MIS | MIS | MIS | MIS | MIS | 0x0a15
Cyr. Sml. YI | 0x0457 | MIS | MIS | MIS | MIS | MIS | 0x0a4f
Cyr. Sml. BYELORUSSIANUKRI | 0x0456 | MIS | MIS | MIS | MIS | MIS | 0x0a4d
Cyr. Sml. YERU | 0x044b | MIS | MIS | MIS | MIS | MIS | 0x0a39
Cyr. Sml. KA | 0x043a | MIS | MIS | MIS | MIS | MIS | 0x0a17
Cyr. Sml. KJE | 0x045c | MIS | MIS | MIS | MIS | MIS | 0x0a59
Cyr. Sml. EL | 0x043b | MIS | MIS | MIS | MIS | MIS | 0x0a19
Cyr. Sml. LJE | 0x0459 | MIS | MIS | MIS | MIS | MIS | 0x0a53
Cyr. Sml. EM | 0x043c | MIS | MIS | MIS | MIS | MIS | 0x0a1b
Cyr. Sml. EN | 0x043d | MIS | MIS | MIS | MIS | MIS | 0x0a1d
Cyr. Sml. NJE | 0x045a | MIS | MIS | MIS | MIS | MIS | 0x0a55
Cyr. Sml. O | 0x043e | MIS | MIS | MIS | MIS | MIS | 0x0a1f
Cyr. Sml. PE | 0x043f | MIS | MIS | MIS | MIS | MIS | 0x0a21
Cyr. Sml. ER | 0x0440 | MIS | MIS | MIS | MIS | MIS | 0x0a23
Cyr. Sml. ES | 0x0441 | MIS | MIS | MIS | MIS | MIS | 0x0a25
Cyr. Sml. TE | 0x0442 | MIS | MIS | MIS | MIS | MIS | 0x0a27
Cyr. Sml. TSHE | 0x045b | MIS | MIS | MIS | MIS | MIS | 0x0a57
Cyr. Sml. U | 0x0443 | MIS | MIS | MIS | MIS | MIS | 0x0a29
Cyr. Sml. SHORTU | 0x045e | MIS | MIS | MIS | MIS | MIS | 0x0a5b
Cyr. Sml. YU | 0x044e | MIS | MIS | MIS | MIS | MIS | 0x0a3f
Cyr. Sml. EF | 0x0444 | MIS | MIS | MIS | MIS | MIS | 0x0a2b
Cyr. Sml. HA | 0x0445 | MIS | MIS | MIS | MIS | MIS | 0x0a2d
Cyr. Sml. TSE | 0x0446 | MIS | MIS | MIS | MIS | MIS | 0x0a2f
Cyr. Sml. DZHE | 0x045f | MIS | MIS | MIS | MIS | MIS | 0x0a5d
Cyr. Sml. CHE | 0x0447 | MIS | MIS | MIS | MIS | MIS | 0x0a31
Cyr. Sml. SHA | 0x0448 | MIS | MIS | MIS | MIS | MIS | 0x0a33
Cyr. Sml. SHCHA | 0x0449 | MIS | MIS | MIS | MIS | MIS | 0x0a35
Cyr. Sml. DZE | 0x0455 | MIS | MIS | MIS | MIS | MIS | 0x0a4b
Cyr. Sml. HARDSIGN | 0x044a | MIS | MIS | MIS | MIS | MIS | 0x0a37
Cyr. Sml. JE | 0x0458 | MIS | MIS | MIS | MIS | MIS | 0x0a51
Cyr. Sml. SOFTSIGN | 0x044c | MIS | MIS | MIS | MIS | MIS | 0x0a3b
Cyr. Sml. E | 0x044d | MIS | MIS | MIS | MIS | MIS | 0x0a3d

Greek Characters (Upper case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Cap. ALPHA TONOS (A) | 0x0386 | MIS | 224 | 193 | MIS | 234 | 0x08c8
Cap. ALPHA | 0x0391 | A | A | A | 144 | 128 | 0x0800
Cap. BETA | 0x0392 | B | B | B | 145 | 129 | 0x0802
Cap. GAMMA | 0x0393 | 226 | MIS | MIS | 146 | 130 | 0x0806
Cap. DELTA | 0x0394 | MIS | MIS | MIS | 147 | 131 | 0x0808
Cap. EPSILON TONOS (E) | 0x0388 | 144 | 220 | 201 | MIS | 235 | 0x08c9
Cap. EPSILON | 0x0395 | E | E | E | 148 | 132 | 0x080a
Cap. ZETA | 0x0396 | Z | Z | Z | 149 | 133 | 0x080c
Cap. ETA TONOS(H) | 0x0389 | MIS | MIS | MIS | MIS | 236 | 0x08ca
Cap. ETA | 0x0397 | H | H | H | 150 | 134 | 0x080e
Cap. THETA | 0x0398 | 233 | MIS | MIS | 151 | 135 | 0x0810
Cap. IOTA TONOS (I) | 0x038a | MIS | 229 | 205 | MIS | 237 | 0x08cb
Cap. IOTA DIAERESIS | 0x03AA | MIS | MIS | MIS | MIS | MIS | MIS
Cap. IOTA | 0x0399 | I | I | I | 152 | 136 | 0x0812
Cap. KAPPA | 0x039a | K | K | K | 153 | 137 | 0x0814
Cap. LAMBDA | 0x039b | MIS | MIS | MIS | 154 | 138 | 0x0816
Cap. MU | 0x039c | M | M | M | 155 | 139 | 0x0818
Cap. NU | 0x039d | N | N | N | 156 | 140 | 0x081a
Cap. XI | 0x039e | MIS | MIS | MIS | 157 | 141 | 0x081c
Cap. OMICRON TONOS (O) | 0x038c | MIS | 231 | 211 | MIS | 238 | 0x08cc
Cap. OMICRON | 0x039f | O | O | O | 158 | 142 | 0x081e
Cap. PI | 0x03a0 | MIS | MIS | 182 | 159 | 143 | 0x0820
Cap. RHO | 0x03a1 | P | P | P | 160 | 144 | 0x0822
Cap. SIGMA | 0x03a3 | 228 | MIS | MIS | 161 | 145 | 0x0824
Cap. TAU | 0x03a4 | T | T | T | 162 | 146 | 0x0828
Cap. UPSILON TONOS (Y) | 0x038e | MIS | 177 | 221 | MIS | 239 | 0x08cd
Cap. UPSILON DIAERESIS | 0x03ab | MIS | MIS | MIS | MIS | MIS | MIS
Cap. UPSILON | 0x03a5 | Y | Y | Y | 163 | 147 | 0x082a
Cap. PHI | 0x03a6 | 232 | MIS | MIS | 164 | 148 | 0x082c
Cap. CHI | 0x03a7 | X | X | X | 165 | 149 | 0x082e
Cap. PSI | 0x03a8 | MIS | MIS | MIS | 166 | 150 | 0x0830
Cap. OMEGA TONOS (ê) | 0x038f | MIS | MIS | MIS | MIS | 240 | 0x01ce
Cap. OMEGA | 0x03a9 | 234 | MIS | MIS | 167 | 151 | 0x0832

Greek Characters (Lower case)

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Sml. ALPHA TONOS | 0x03ac | MIS | MIS | MIS | 193 | 225 | 0x0866
Sml. ALPHA | 0x03b1 | 224 | MIS | MIS | 168 | 152 | 0x0801
Sml. BETA | 0x03b2 | MIS | MIS | MIS | 169 | 153 | 0x0803
Sml. GAMMA | 0x03b3 | MIS | MIS | MIS | 170 | 154 | 0x0807
Sml. DELTA | 0x03b4 | 235 | MIS | MIS | 171 | 155 | 0x0809
Sml. EPSILON TONOS | 0x03ad | MIS | MIS | MIS | 194 | 226 | 0x0878
Sml. EPSILON | 0x03b5 | MIS | MIS | MIS | 172 | 156 | 0x080b
Sml. ZETA | 0x03b6 | MIS | MIS | MIS | 173 | 157 | 0x080d
Sml. ETA TONOS | 0x03ae | MIS | MIS | MIS | 196 | 227 | 0x0881
Sml. ETA | 0x03b7 | MIS | MIS | MIS | 174 | 158 | 0x080f
Sml. THETA | 0x03b8 | MIS | MIS | MIS | 175 | 159 | 0x0811
Sml. IOTA TONOS | 0x03af | MIS | MIS | MIS | 195 | 229 | 0x0893
Sml. IOTA Diaeresis | 0x03ca | MIS | MIS | MIS | 209 | 228 | 0x0899
Sml. IOTA Diaeresis TONOS | 0x0390 | MIS | MIS | MIS | MIS | MIS | 0x0891
Sml. IOTA | 0x03b9 | MIS | MIS | MIS | 176 | 160 | 0x0813
Sml. KAPPA | 0x03ba | MIS | MIS | MIS | 177 | 161 | 0x0815
Sml. LAMBDA | 0x03bb | MIS | MIS | MIS | 178 | 162 | 0x0817
Sml. MU | 0x03bc | 230 | 243 | 181 | 179 | 163 | 0x0819
Sml. NU | 0x03bd | MIS | MIS | MIS | 180 | 164 | 0x081b
Sml. XI | 0x03be | MIS | MIS | MIS | 181 | 165 | 0x081d
Sml. OMIK TONOS | 0x03cc | 162 | 198 | 243 | 197 | 230 | 0x089f
Sml. OMICRON | 0x03bf | o | o | o | 182 | 166 | 0x081f
Sml. PI | 0x03c0 | 227 | MIS | MIS | 183 | 167 | 0x0821
Sml. RHO | 0x03c1 | MIS | MIS | MIS | 184 | 168 | 0x0823
Sml. SIGMA | 0x03c3 | 229 | MIS | MIS | 185 | 169 | 0x0825
Sml. TAU | 0x03c4 | 231 | MIS | MIS | 186 | 171 | 0x0829
Sml. UPSILON TONOS | 0x03cd | 163 | 199 | 250 | 198 | 231 | 0x08a0
Sml. UPSILON Diaeresis | 0x03cb | 129 | 207 | 252 | 212 | 232 | 0x08a8
Sml. UPSILON Diar.TONOS | 0x03b0 | MIS | MIS | MIS | MIS | MIS | 0x08a4
Sml. UPSILON | 0x03c5 | u | u | u | 187 | 172 | 0x082b
Sml. PHI | 0x03c6 | MIS | MIS | MIS | 188 | 173 | 0x082d
Sml. CHI | 0x03c7 | MIS | MIS | MIS | 189 | 174 | 0x082f
Sml. PSI | 0x03c8 | MIS | MIS | MIS | 190 | 175 | 0x0831
Sml. OMEGA TONOS | 0x03ce | MIS | MIS | MIS | 199 | 233 | 0x08b4
Sml. OMEGA | 0x03c9 | MIS | MIS | MIS | 191 | 224 | 0x0833
Sml. EVANGEL | 0x03c2 | MIS | MIS | MIS | 192 | 170 | 0x0827

Punctuation Characters

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Apostrophe-Quote | 0x0027 | ' | ' | ' | ‘ | ‘ | 0x0027
Closing Curly Bracket | 0x007d | } | } | } | } | } | 0x007d
Closing Parenthesis | 0x0029 | ) | ) | ) | ) | ) | 0x0029
Closing Square Bracket | 0x005d | ] | ] | ] | ] | ] | 0x005d
Colon | 0x003a | : | : | : | : | : | 0x003a
Comma | 0x002c | , | , | , | , | , | 0x002c
Em Dash | 0x2014 |  |  | — |  |  | 0x0422
En Dash | 0x2013 |  |  | – | MIS | MIS | 0x0421
Exclamation Mark | 0x0021 | ! | ! | ! | ! | ! | 0x0021
Hyphen-Minus | 0x002d | - | - | - | - | - | 0x002d
Inverted Exclamation Mark (Sp.) | 0x00a1 | ¡ | ¡ | ¡ | MIS | MIS | 0x0407
Inverted Question Mark (Sp.) | 0x00bf | ¿ | ¿ | ¿ | MIS | MIS | 0x0408
Low Dbl. Comma Quot. Mark | 0x201e | " | " | " | " | " | 0x043f
Low Single Comma Quot. Mark | 0x201a | ‚ | ‚ | ‚ | MIS | MIS | 0x010c
Opening Curly Bracket | 0x007b | { | { | { | { | { | 0x007b
Opening Parenthesis | 0x0028 | ( | ( | ( | ( | ( | 0x0028
Opening Square Bracket | 0x005b | [ | [ | [ | [ | [ | 0x005b
Period (full stop) | 0x002e | . | . | . | . | . | 0x002e
Question Mark | 0x003f | ? | ? | ? | ? | ? | 0x003f
Quotation Mark | 0x0022 | " | " | " | " | " | 0x0022
Semicolon | 0x003b | ; | ; | ; | ; | ; | 0x003b
Left Pointing Single Guillemet | 0x2039 | ‹ | ‹ | ‹ | ‹ | ‹ | 0x0441
Right Pointing Single Guillemet | 0x203a | › | › | › | › | › | 0x0441
Soft Hyphen | 0x20ad |  |  |  |  |  | 0x002d
Spacing Grave | 0x0060 | ` | ` | ` | ` | ` | 0x0060

Miscellaneous Characters

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
Acute | 0x00b4 | MIS | ´ | ´ | MIS | MIS | 0x0106
Ampersand | 0x0026 | & | & | & | & | & | 0x0026
Asterisk | 0x002a | * | * | * | * | * | 0x002a
Backslash | 0x005c | \ | \ | \ | \ | \ | 0x005c
Bullet | 0x2022 | • | • | • | MIS | • | 0x0400
Broken Bar | 0x00a6 | ¦ | ¦ | ¦ | MIS | MIS | 0x007c
Cedilla | 0x00b8 | MIS | MIS | ¸ | MIS | MIS | 0x0111
Cent Sign | 0x00a2 | ¢ | ¢ | ¢ | MIS | MIS | 0x0413
Circumflex | 0x02c6 | MIS | ˆ | ˆ | MIS | MIs | 0x0103
Commercial At | 0x0040 | @ | @ | @ | @ | @ | 0x0040
Copyright Sign | 0x00a9 | MIS | MIS | © | MIS | MIS | 0x0417
Currency Sign | 0x00a4 | MIS | ¤ | ¤ | MIS | MIS | 0x0418
Dagger | 0x2020 | MIS | MIS | † | MIS | MIS | 0x0431
Degree Sign | 0x00b0 | ° | ° | ° | MIS | MIS | 0x0410
Diaresis | 0x00a8 | MIS | ¨ | ¨ | MIS | MIS | 0x0107
Dollar Sign | 0x0024 | $ | $ | $ | $ | $ | 0x0024
Double Dagger | 0x2021 | MIS | MIS | ‡ | MIS | MIS | 0x0432
Equals Sign | 0x003d | = | = | = | = | = | 0x003d
Euro Sign | 0x20ac | MIS | MIS | € | MIS | MIS | 0x209c
Greater-Than Sign | 0x003e | > | > | > | > | > | 0x003e
Horizontal Ellipsis | 0x2026 | MIS | MIS | … | MIS | MIS | 0x0438
Left Pointing Guillemet | 0x00ab | « | « | « | MIS | MIS | 0x0409
Less-Than Sign | 0x003c | < | < | < | < | < | 0x003c
Macron | 0x00af | MIS | ¯ | ¯ | MIS | MIS | 0x0108
Math Division Sign | 0x00f7 | ÷ | MIS | ÷ | MIS | MIS | 0x0608
Math Multipication Sign | 0x00d7 | MIS | MIS | × | MIS | MIS | 0x0627
Micron | 0x00b5 | µ | µ | µ | MIS | MIS | 0x0625
Midddle Dot | 0x00b7 | · | · | · | MIS | MIS | 0x010e
Not Sign | 0x00ac | ¬ | MIS | ¬ | MIS | MIs | 0x0614
Number Sign | 0x0023 | # | # | # | # | # | 0x0023
Per Mille Sign | 0x2030 | MIS | MIS | ‰ | MIS | MIS | 0x044b
Percent Sign | 0x0025 | % | % | % | % | % | 0x0025
Pilcrow Sign | 0x00b6 | ¶ | ¶ | ¶ | MIS | MIS | 0x0405
Plus Sign | 0x002b | + | + | + | + | + | 0x002b
Plus-OR-Minus Sign | 0x00b1 | ± | ± | ± | ± | ± | 0x0601
Pound Sign | 0x00a3 | £ | £ | £ | MIS | MIS | 0x040b
Registered Trade Mark Sign | 0x00ae | MIS | MIS | ® | MIS | MIS | 0x0416
Right Pointing Guillemet | 0x00bb | » | » | » | MIS | MIS | 0x040a
Section Sign | 0x00a7 | § | § | § | MIS | MIS | 0x0406
Slash | 0x002f | / | / | / | / | / | 0x002f
Sml. Script F | 0x0192 | ƒ | ƒ | ƒ | MIS | MIS | 0x040e
Sml. Tilde | 0x02dc | MIS | ˜ | ˜ | MIS | MIS | 0x0102
Space | 0x0020 |  |  |  |  |  | 0x0020
Spacing Circumflex | 0x005e | ^ | ^ | ^ | ^ | ^ | 0x005e
Spacing Underscore | 0x005f | _ | _ | _ | _ | _ | 0x005f
Superscript One | 0x00b9 | MIS | MIS | ¹ | MIS | MIS | 0x044e
Superscript Three | 0x00b3 | MIS | MIS | ³ | MIS | MIS | 0x041a
Superscript Two | 0x00b2 | ² | MIS | ² | MIS | MIS | 0x0414
Tilde | 0x007e | ~ | ~ | ~ | ~ | ~ | 0x007e
Trade Mark Sign | 0x2122 | MIS | MIS | ™ | MIS | MIS | 0x0429
Vertical Bar | 0x007c | | | | | | | | | | | 0x007c
Vulgar Fraction Three Quarter | 0x00be | MIS | ¾ | ¾ | MIS | MIS | 0x0419
Vulgar Fraction One Half | 0x00bd | ½ | ½ | ½ | MIS | MIS | 0x0411
Vulgar Fraction One Quarter | 0x00bc | ¼ | ¼ | ¼ | MIS | MIS | 0x0412
Yen Sign | 0x00a5 | ¥ | ¥ | ¥ | MIS | MIS | 0x040c

OCR Special Characters

Name of the Character | UNICODE | ASCII | Roman | ANSI | Elot | Memotek | WP
OCR Amount Of Check | 0x2447 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Belt Buckle | 0x2444 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Bow Tie | 0x2445 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Branch Bank | 0x2446 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Chair | 0x2441 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Customer Account Number | 0x2449 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Dash | 0x2448 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Double Backslash | 0x244a | MIS | MIS | MIS | MIS | MIS | MIS
OCR Fork | 0x2442 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Hook | 0x2440 | MIS | MIS | MIS | MIS | MIS | MIS
OCR Inverted Fork | 0x2443 | MIS | MIS | MIS | MIS | MIS | MIS


Code Page List
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Code Page List

The following table summarizes all the Code Pages supported by the Engine. One of these must be specified as the Code Page of the final output document.

CODE PAGE NAME | WIDTH | DESCRIPTION | IMPLEMENTATION
Windows ANSI | 8-bit | Code Page 1252 | Hard-coded (Default)
Windows Greek | 8-bit | Code Page 1253 | Hard-coded
Windows Eastern | 8-bit | Code Page 1250 | Hard-coded
Windows Turkish | 8-bit | Code Page 1254 | Hard-coded
Windows Baltic | 8-bit | Code Page 1257 | Hard-coded
Windows Cyrillic | 8-bit | Code Page 1251 | Hard-coded
Windows Esperant | 8-bit | Non Standard Win | Derived from CP 1252
Code Page 437 | 8-bit | DOS Latin US | Hard-coded
Greek-ELOT | 8-bit | DOS Greek | Hard-coded
Greek-MEMOTEK | 8-bit | DOS Greek | Hard-coded
Code Page 850 | 8-bit | DOS Latin 1 | Derived from CP 437
Code Page 852 | 8-bit | DOS Latin 2 | Derived from CP 437
Code Page 860 | 8-bit | DOS Portuguese | Derived from CP 437
Code Page 863 | 8-bit | DOS French-Canadian | Derived from CP 437
Code Page 865 | 8-bit | DOS Nordic | Derived from CP 437
Code Page 866 | 8-bit | DOS Cyrillic CIS | Derived from CP 437
CWI Magyar | 8-bit | DOS Hungarian | Derived from CP 437
Magyar Ventura | 8-bit | DOS Hungarian | Derived from CP 437
IVKAM C-S | 8-bit | Czech & Slovak | Derived from CP 437
Mazowia Polish | 8-bit | DOS Polish | Derived from CP 437
Sloven & Croat | 8-bit | 7 bits used | Derived from CP 437
Turkish | 8-bit | DOS Turkish | Derived from CP 437
Icelandic | 8-bit | DOS Icelandic | Derived from CP 437
Macintosh | 8-bit | Mac Western | Hard-coded
Mac INSO Latin 2 | 8-bit | MAC CE | Hard-coded
Mac Central EU | 8-bit | PT 202 | Hard-coded
Mac Primus CE u | 8-bit | MAC CE | Hard-coded
Maltese | 8-bit | Malta; 7 bits used | Derived from CP 437
OCR | 8-bit | Non Standard Win | Derived from CP 437
Unicode | 16-bit | multilingual | Hard-coded
WordPerfect | 16-bit | multilingual | Hard-coded
WordPerfect Old | 16-bit | multilingual | Hard-coded
Roman 8 | 8-bit | For HP printers | Hard-coded
UTF-8 | 16-bit | multilingual | Hard-coded

For programming, the current Code Page setting of the Engine can be set or inquired by ImGearRecOutputManager. CodePage Property value. The exact list of available Code Pages can be inquired by ImGearRecOutputManager. CodePages Property value.

The Windows ANSI name here is not connected with the real ANSI character set (ISO 8859-1). In fact, this is the code page 1252 (Windows CP 1252).

Details of the WordPerfect code pages:

  • WordPerfect: variable length character codes stored on 1 or 4 bytes. It is used from WordPerfect 6.0.
  • WordPerfect Old: similar to WordPerfect, but it is used before WordPerfect 6.0.

This section provides information about the following:

  • Code Page List
    • Customized Code Pages
    • Code Page Ignored during Converting to the Output


Customized Code Pages
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Code Page List > Customized Code Pages

If no offered Code Page fulfills your needs, you can develop your own derivative 8-bit Code Page by adding a new Code Page Definition file to the Engine Binary directory. This new file should have a .SET file extension and it should contain a separate section for your custom Code Page. Five Code Pages are available as the basis for customized Code Pages:

  • Windows CP 1252
  • DOS CP 437
  • Greek-Elot
  • Greek Memotek
  • Roman 8

The characters belonging to the custom Code Page should be given in UNICODE and follow the other layout conventions found in the RECOGN.SET basic Code Page Definition file.


Code Page Ignored during Converting to the Output
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Code Page List > Code Page Ignored during Converting to the Output

In some cases, the Code Page setting of the Engine must be specified together with the Output Text Format for the final output document. With other output formats, specifying the Code Page is superfluous, since these output converters ignore the Code Page setting (e.g., MS Word).


Output Text Format List
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Output Text Format List

The following list contains all the selectable output formats of the converters:

  • Text - This converter writes the recognized text into a simple text file that can be read by most text editors and word processors.
  • Comma Separated Text - This converter writes the recognized text into a tabled text file (Comma delimited text file) that can be read by Excel. “List Separator” separates the cells and NL (new line character) separates the lines of the table.
  • Formatted Text - This converter writes the recognized text into a text file, but tries to retain the layout of the page by inserting extra spaces.
  • Text with linebreaks - The same as Text converter, but this converter inserts line breaks at the end of lines instead of only inserting them at the end of the paragraphs.
  • Unicode Text - Same as Text, but using two-byte Unicode characters.
  • Unicode Formatted Text - Same as Formatted Text, but using two-byte Unicode characters.
  • Unicode Text with linebreaks - Same as Text with linebreaks, but using two-byte Unicode characters.
  • HTML 3.2 - The HTML 3.2 format is a clear, small but useable HTML format, this format is supported by ‘all’ HTML interpreters (contrary to HTML 4.0.).
  • HTML 4.0 - The HTML 4.0 format is not so clear as HTML 3.2, but Cascading Style Sheet (CSS) technology can be used for box-like absolute positioned objects, styles and manipulating all paragraph and character attributes.
  • eBook - Open Ebook Specification 1.0 XML converter.
    Formatted output in eBook format is not supported by the 64-bit SDK.
  • XML - An XML file format conforming to the Nuance XML schema, ssdoc-schema3.xsd, distributed in the ImageGear for .NET installation's Bin directory. It contains almost all layout related information and paragraph and character attributes. The page XML output format contains a general description of this format.
  • WordPerfect 10 – WordPerfect binary file format for WordPerfect 9 and up.
  • Microsoft Reader - Converter for Microsoft Reader ebook format (.lit files).
  • Microsoft Infopath - A Microsoft Infopath converter. It supports the saving of various recognized form elements like checkboxes and input lines.
  • WordPad - An RTF-based converter that generates a plain and simple RTF file, which can be interpreted by Microsoft Wordpad (and other simple RTF readers).
  • RTF Word 6.0/95 - Rich Text Format converter based on the version 1.3 of the RTF Specification. The generated files could be interpreted by almost all RTF readers. The downside is that the size of the output files could be considerably larger than those generated by later RTF converters.
  • RTF Word 97 - This RTF converter uses some new features that can only be interpreted by Microsoft Word 97 and up (or by readers with compatible capabilities).
  • Microsoft Powerpoint 97 - An RTF-based converter that generates a plain and simple RTF file, which can be interpreted by Microsoft Powerpoint.
  • Microsoft Excel 97 - Generates Microsoft Excel 97 binary files (.xls).
  • Microsoft Word 97 - The same as RTF Word 97.
  • Microsoft Publisher 98 - An RTF-based converter that generates a plain and simple RTF file, which can be interpreted by Microsoft Publisher.
  • RTF Word 2000 - Similar to RTF Word 97 converter, but using new features only available in Microsoft Word 2000 and up.
  • RTF 2000 Exact Word - This converter is based on RTF Word 2000. It loads the resulting file into Microsoft Word, and tries to correct the pagination errors by slight modifications to spacing values.
  • Microsoft Word 2000, XP - The same as RTF Word 2000.
  • Microsoft Word WordML - A converter for the XML-based file format of Microsoft Word 2003. Its features, capabilities and layout retention quality are practically the same as in the RTF Word 2000 converter.
  • Microsoft Excel 2003, XP - This converter is currently the same as Microsoft Excel 97.

Office 2007 Support

ImageGear Recognition can generate output for the new Office 2007 file types DOCX, XLSX and PPTX. These files can be opened only by programs in Office 2007, or by Office 2003 with an add-in supplied by Microsoft.

The DOCX philosophy is using a set of separate XML, picture and font files, all compressed into one ZIP-like package file. The real document content is housed in a set of XML files, but there are other XML files that define the connections between the content files and the other files. This allows DOCX file sizes to be typically much smaller than a corresponding DOC file.

This DOCX file type specification can download from: http://www.ecma-international.org/news/TC45_current_work/TC45_available_docs.htm

The DOCX/XPSX/PPTX file types conform with a new Microsoft standard called “Open Packaging Conventions (OPC)” whose specification is available for download at http://go.microsoft.com/fwlink/?linkID=71255


Language Dictionary List
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Language Dictionary List

The following table lists the languages available in the Engine’s checking module for spell checking (language checking). One of these can be specified as the spelling language, if desired.

  • Brazilian
  • Catalan
  • Czech
  • Danish
  • Dutch
  • English
  • Esperanto
  • Finnish
  • French
  • German
  • Greek
  • Hungarian
  • Italian
  • Norwegian
  • Polish
  • Portuguese
  • Russian
  • Slovenian
  • Spanish
  • Swedish
  • Turkish


Vertical Dictionary List
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Vertical Dictionary List

The following table lists all the Vertical dictionaries available in the ImageGear Recognition.

PROFESSION | LANGUAGE | DESCRIPTION OF DICTIONARY
Financial | English | English Financial Dictionary
Medical | Dutch | Dutch Medical Dictionary
Medical | English | English Medical Dictionary
Medical | French | French Medical Dictionary
Medical | German | German Medical Dictionary
Legal | Dutch | Dutch Legal Dictionary
Legal | English | English Legal Dictionary
Legal | French | French Legal Dictionary
Legal | German | German Legal Dictionary


Specifications for the Recognition Modules
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules

This section provides information about the following:

  • Filling Method - Recognition Module Combinations
  • Recognition Modules and the Widest Available Character Set
  • Recognition Modules and Filters
  • Recognition Modules and Trade-off Settings
  • Recognition Modules and the Checking Subsystem
  • DOT 9-Pin Draft Dot-Matrix Recognition Module
  • FRX Multi-Lingual Omnifont Recognition Module
  • MOR Multi-Lingual Omnifont Recognition Module
  • MTX Omnifont Recognition Module
  • PLUS2W and PLUS3W Omnifont Recognition Modules
  • Asian Recognition Module


Filling Method - Recognition Module Combinations
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Filling Method - Recognition Module Combinations

When a zone recognition module setting is ImGearRecRecognitionModule Enumeration.AUTO, set either by default or explicitly, the Engine takes care of recognition module selection for any filling method. When setting specific values for filling methods and recognition modules, it is the programmer’s responsibility to specify a valid recognition module-filling method pair. Any incorrectly set zone will have no recognition result. The following table shows which modules are considered by the automatic recognition module selection, called up by the ImGearRecRecognitionModule Enumeration.AUTO value. The order of the recognition modules in the second column shows the priority order for the automatic recognition module selection.

Filling Method | Permissible Recognition Module
OMNIFONT | OMNIFONT_PLUS2W, OMNIFONT_PLUS3W, OMNIFONT_MOR, OMNIFONT_FRX, OMNIFONT_MTX
DRAFTDOT9 | DOT, OMNIFONT_MTX
DRAFTDOT24 | OMNIFONT_MOR, OMNIFONT_MTX
OCRA | OMNIFONT_MOR, OMNIFONT_MTX
OCRB | OMNIFONT_MOR, OMNIFONT_MTX
FM_NO_OCR | -


Recognition Modules and the Widest Available Character Set
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Recognition Modules and the Widest Available Character Set

The correct assignment of a recognition module and a filling method to a zone should mean that the recognition module is able to satisfactorily process the contents of that zone. But it does not guarantee that the recognition module will be able to process every possible character. The characters supported by the Engine are listed in Characters and Code Pages. Most recognition modules recognize only a subset of these. Even if we restrict the character set to a limited Language Environment, e.g., selecting the German language, the recognition module may not be able to process all the enabled characters. Automatic recognition module selection takes Character Set support of modules into consideration. Selecting a recognition module directly, it is the programmer’s responsibility to select a recognition module capable of supporting the widest character set enabled in the zone. Otherwise this zone may have an incomplete recognition result. The precise character and language support for each module is given in the appropriate recognition module specifications.


Recognition Modules and Filters
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Recognition Modules and Filters

Narrowing the Character Set has two effects:

  • It influences the automatic recognition module selection
  • It may increase accuracy

The filtering system allows the Language environment to be narrowed, by enabling only certain character classes, and also by enabling individual characters. A filter is built up from filter elements, as detailed under ImGearRecFilter.

Each filter element name tells which character class is enabled, e.g., ALL means no filtering. Not all recognition modules interpret all filter elements. Precise information appears in the sub-heading for each module.

Applying a filter may not always enable the same number of characters. E.g., MISCELLANEOUS can enable only those miscellaneous characters supported by the recognition module assigned to the zone.


Recognition Modules and Trade-off Settings
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Recognition Modules and Trade-off Settings

Three accuracy/speed trade-off settings can be specified at page or document level: ACCURATE, BALANCED, and FAST. Five recognition modules can interpret these. Precise information appears in the sub-heading for each module.


Recognition Modules and the Checking Subsystem
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Recognition Modules and the Checking Subsystem

The checking module has two basic services. It can flag unacceptable recognition results without changing them or it can be permitted to modify recognition results using checking module feedback. The available acceptance rules can come from the following:

  • Language and/or Vertical dictionaries
  • User dictionaries containing precise entries and/or required patterns
  • User-written checking functions

These three sources may be combined freely. The checking module and each of its three parts can be enabled or disabled on a per-zone basis. The integrator should try to match the particular parts of the checking module to the contents and recognition modules of individual zones.


DOT 9-Pin Draft Dot-Matrix Recognition Module
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > DOT 9-Pin Draft Dot-Matrix Recognition Module
Module name: | DOT
Module identifier: | DOT
Filling methods supported: | DRAFTDOT9
Filters supported: | all filter elements
Trade-off supported: | none
Knowledge base file: | TUDAS.FA

Application Areas

This module is designed for ONLY draft-quality 9-pin dot-matrix texts. For NLQ or LQ texts, the OMNIFONT_PLUS2W, OMNIFONT_PLUS3W, OMNIFONT_MTX, OMNIFONT_FRX or OMNIFONT_MOR modules are likely to give better results.

Range of Characters

This module supports 76 languages, of which 14 have dictionary support: Catalan, Danish, Dutch, English, Finnish, French, German, Greek, Hungarian, Italian, Norwegian, Portuguese, Spanish and Swedish. It can read multiple languages. It can read 18 of the 29 punctuation characters. (The Low Double Comma Quotation Mark is missing). It supports 24 of the 55 miscellaneous characters. (Some missing ones are: the Euro Sign, the Small Script F, the Copyright Sign, Registered Trade Mark Sign and the Degree Sign.)

The following table lists all accented letters this module can recognize. The range of uppercase ones supported by this module is limited, since in 9-pin dot-matrix text, there is difficulty in printing these letters. Those with lowercase support only are listed separately:

Upper & Lowercase | Lowercase Only
Cap.&Small A Acute (A’) | Small A Circumflex (a^)
Cap.&Small AE (Ae) | Small A Macron (a-)
Cap.&Small A Ring (Ao) | Small A Grave (a`)
Cap.&Small A Umlaut (A:) | Small E Umlaut (e:)
Cap.&Small A Tilde (A~) | Small E Circumflex (e^)
Cap.&Small C Cedilla (C,) | Small E Grave (e`)
Cap.&Small E Acute (E’) | Small I Umlaut (I:)
Cap.&Small I Acute (I’) | Small I Circumflex (I^)
Cap.&Small N Tilde (N~) | Small I Grave (I`)
Cap.&Small O Double Acute (O") | Small O Circumflex (O^)
Cap.&Small O Acute (O’) | Small O Macron (O-)
Cap.&Small O Umlaut (O:) | Small O Grave (O`)
Cap.&Small O Tilde (O~) | Small S Hacek (Sv)
Cap.&Small O Slash (O/) | Small U Circumflex (U^)
Cap.&Small AE(OE) | Small U Grave (U`)
Cap.&Small U Double Acute (U") |
Cap.&Small U Acute (U’) |
Cap.&Small U Umlaut (U:) |

Accuracy Issues

This module does not interpret the recognition trade-off setting.

Character Attributes

Since this module recognizes draft dot-matrix texts, character attributes are not applicable. Expanded characters are not recognized, condensed printout can be, but the accuracy is liable to be low.

Conditions

This module is used if it is directly specified in a zone structure.

If DRAFTDOT9 filling method is set together with AUTO, OMNIFONT_MTX is used, provided that all characters (or languages or filters) validated for the zone are supported by it. If any are not supported, this module is used.

It can generate confidence data on recognized characters and can interpret all filter values.


FRX Multi-Lingual Omnifont Recognition Module
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > FRX Multi-Lingual Omnifont Recognition Module
Module name: | FRX
Module identifier: | FRX
Filling methods supported: | OMNIFONT
Filters supported: | all filter elements
Trade-off supported: | none
Knowledge base files: | none

The OMNIFONT_PLUS2W, and OMNIFONT_PLUS3W recognition modules require the presence of this module.

Its associated files are:

baltic.shp | Frx shape pack (code page) file.
cyrillic.shp | Frx shape pack (code page) file.
greek.shp | Frx shape pack (code page) file.
latin1.shp | Frx shape pack (code page) file.
latin2.shp | Frx shape pack (code page) file.
turkish.shp | Frx shape pack (code page) file.
charsettable.chr |
asciieng.lng | Frx language dictionary. Used in case of multi-language selection.
czech.lng | Frx language dictionary data file.
danish.lng | Frx language dictionary data file.
dutch.lng | Frx language dictionary data file.
english.lng | Frx language dictionary data file.
finnish.lng | Frx language dictionary data file.
french.lng | Frx language dictionary data file.
german.lng | Frx language dictionary data file.
greek.lng | Frx language dictionary data file.
hungar.lng | Frx language dictionary data file.
italian.lng | Frx language dictionary data file.
norsk.lng | Frx language dictionary data file.
polish.lng | Frx language dictionary data file.
port.lng | Frx language dictionary data file.
russian.lng | Frx language dictionary data file.
spanish.lng | Frx language dictionary data file.
swedish.lng | Frx language dictionary data file.
turkish.lng | Frx language dictionary data file.

Application Areas

This module recognizes machine printed text; i.e. from printed publications, laser or ink-jet printers and electric typewriters. Output from mechanical typewriters in good condition may also be acceptable. It should also be used for letter or near letter quality (NLQ, LQ) output from dot-matrix printers.

Range of Characters

This module supports the recognition of Latin, Greek and Cyrillic alphabets with enough accented letters to recognize the 54 languages.

The characters are listed in category and alphanumeric order, together with their Code Page values, in Characters and Code Pages.

Multi-Lingual Language Support

The language support of this module is based on the module's internal code pages, which contain characters from a related group of languages. The internal code pages of this module are American/European (Latin 1, 1252), Baltic (1257), Central-European (Latin 2, 1250), Cyrillic (1251), Greek (1253) and Turkish (1254).

The module supports multi-language selection for recognition, though it may not recognize languages from different language groups properly. It supports only language combinations within the same Code Page. For example, it properly processes the English, German and Italian language combination, since all these languages belong to the Latin 1 (1252) code page. However, when specifying e.g. both the French and Czech languages, OMNIFONT_FRX may fail to properly recognize some accented characters in the Czech alphabet, since these languages are not in the same code page. The following table contains the languages by code pages supported by FRX.

Latin 2 (1250) | Polish, Czech, Hungarian, Romanian, Albanian, Croatian, Wend (Sorbian), Slovak, Slovenian
Cyrillic (1251) | Russian, Ukrainian, Byelorussian, Bulgarian, Macedonian, Serbian
Latin 1 (1252) | English, German, French, Spanish, Italian, Dutch, Swedish, Norwegian, Finnish, Danish, Portuguese, Portuguese (Brazilian), Catalan, Afrikaans, Aymara, Basque, Breton, Faroese, Friulian, Gaelic, Galician, Eskimo, Icelandic, Indonesian, Latin, Malaysian, Pidgin English, Swahili, Tahitian, Welsh, Frisian, Zulu
Greek (1253) | Greek
Turkish (1254) | Turkish, Kurdish (written in Latin alphabet)
Baltic (1257) | Estonian, Hawaiian, Latvian, Lithuanian

Character Attributes

The omnifont recognition module can detect and transmit character attributes: bold, italic or underlined text (or any combination of them). It can also detect and transmit character size, and can classify font types into three broad categories: serif, sans serif and monospaced.


MOR Multi-Lingual Omnifont Recognition Module
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > MOR Multi-Lingual Omnifont Recognition Module
Module name: | MOR
Module identifier: | OMNIFONT_MOR
Filling methods supported: | OMNIFONT, DRAFTDOT24, OCRA, OCRB
Filters supported: | all filter elements
Trade-off supported: | FAST, BALANCED, ACCURATE
Knowledge base files: | RECOGN.BCT and RECOGN24.BCT

The PLUS2W and PLUS3W recognition modules also require the presence of this module.

Application Areas

This module recognizes machine printed text; i.e., from printed publications, laser or ink-jet printers and electric typewriters. Output from mechanical typewriters in good condition may also be acceptable. It could also be used for letter or near letter quality (NLQ, LQ) output from dot-matrix printers. For Draft quality 24-pin dot-matrix documents use the DRAFTDOT24 filling method. NLQ or LQ quality output can usually be better recognized without using DRAFTDOT24.

The max. number of zones defined on an image that this module can handle is 500.

Range of Characters

This module can recognize about 500 characters, termed Engine’s Total Character Set. It includes the letters of the Latin, Greek and Cyrillic alphabets with enough accented letters to recognize the 119 Languages supported by the Engine

The set is classified as follows:

 | Non-accented | Accented
Latin alphabet upper case letters | 26 | 89
Latin alphabet lower case letters | 26 | 91
Digits | 10 |
Punctuation | 29 |
Miscellaneous (math symbols, etc.) | 55 |
Cyrillic upper case letters | 33 | 14
Cyrillic lower case letters | 33 | 14
Greek upper case letters | 24 | 9
Greek lower case letters | 25 | 11
OCR (OCR-A) characters | 3 |

The characters are listed in category and alphanumeric order, together with their Code Page values, in Characters and Code Pages. These are the character categories used by the filter elements.

Character Attributes

The omnifont recognition module can detect and transmit character attributes: bold, italic or underlined text (or any combination of them). It can also detect and transmit character size, and can classify font types into three broad categories: serif, sans serif and monospaced.

Speed/Accuracy Choices

The multi-lingual omnifont recognition module basically uses contour analysis, but can supplement this with an innovative form of pattern matching not requiring enormous pre-stored shape libraries.

This module interprets all three page-level recognition trade-off settings: ACCURATE, BALANCED and FAST.

The module is tightly integrated with the checking module, giving a total of five speed/accuracy choices.

  • Level 1: FAST without checking.
    Fastest. The module reads text once and uses feature extraction only. Even this setting can give excellent accuracy on high-quality documents. Recommended also when accuracy is not a big issue (e.g. when OCR is only to allow fuzzy keyword searching in a document retrieval system) or for high-volume work when processing speed is most important.
  • Level 2: FAST with checking.
    The recognition module reads text only once, with feature extraction, but sends words containing suspect or reject characters to a checker, together with its first and second guesses for unsure characters. The checker tries to find solutions based only on those characters. It also tries to repair other typical OCR faults (e.g. di9its embedded in words) and will flag all non-dictionary words it was unable to solve. Recommended e.g. when a Language dictionary is available and the texts are mono-lingual and liable to contain normal language (if not, a User dictionary could be employed).
  • Level 3: BALANCED without checking.
    Two-pass recognition. During the first pass with feature extraction, the program builds up a library of sample characters and ligatured character pairs from the page, whose recognition was very sure. During the second reading pass it stops on all reject and unsure characters, consults its library and uses pattern matching to try and find solutions. That’s why the second pass is not very useful for pages with very little text – the library is too small. Recommended for multi-lingual documents or when a checker is not available.
  • Level 4: BALANCED with checking.
    Two-pass recognition. Reading is a combination of the two processes used in levels 2 and 3. More accurate but processing will take more time.
  • Level 5: ACCURATE with checking compulsory.
    Most accurate but slowest. Designed for use on very degraded mono-lingual documents or when maximum accuracy is very important. It involves two-pass recognition with Adaptive Cell Analysis. This is used to get a bigger library for the pattern matching: uniformly highly degraded documents typically can’t yield enough surely recognized characters to form a useful library. With ACA recognition, characters with somewhat lower certainty are accepted, provided they fall within words accepted by the checking module. This allows the pattern matching to work more successfully.


MTX Omnifont Recognition Module
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > MTX Omnifont Recognition Module
Module name: | MTX
Module identifier: | OMNIFONT_MTX
Filling methods supported: | OMNIFONT, DRAFTDOT9, DRAFTDOT24, OCRA, OCRB
Filters supported: | ALL, DIGIT and ALPHA
Trade-off supported: | FAST, ACCURATE (BALANCED is equal to this)
Knowledge base file: | N / A

The PLUS2W and PLUS3W recognition modules also require the presence of this module.

Recognition module language binaries are xi*.bin, as follows:

  • For recognizing an English document, the filenames include the identifier ENG:
    • xiengb.bin
    • xiengc.bin
    • xiengd.bin
    • xienge.bin
    • xiengf.bin (used unaltered for all languages)
    • xiengl.bin (used unaltered for all languages)
    • xiengp.bin
    • xiengs.bin
    • xiengz.bin

The files xiengf.bin and xiengl.bin are required, unaltered, for all languages. All other languages have language-specific equivalents of the remaining seven files. The identifier eng is changed as follows:

  • French: frn
  • Italian: itl
  • German: grm
  • Dutch: dut
  • Spanish: spn
  • Portuguese: prt
  • Swedish: swd
  • Norwegian: nrw
  • Danish: dan
  • Finnish: fin
  • Portuguese (Brazilian): brz

Application Areas

This recognition module recognizes machine printed text; i.e. from printed publications, laser or ink-jet printers and electric typewriters. Output from mechanical typewriters in good condition may also be acceptable. It should also be used for Letter or Near Letter Quality output from dot-matrix printers, and can also be used for Draft Quality.

Range of Characters

This module supports the characters of the following languages:

Language

English

French

Spanish

Italian

German

Norwegian

Portuguese

Danish

Dutch

Finnish

Swedish

Brazilian

Any of these languages can be combined.

Accuracy Issues

This module is influenced by the page-level trade-off setting, but reduces the three settings to two: FAST is respected, while BALANCED and ACCURATE are merged to one value.

Character Attributes

The omnifont recognition module can detect and transmit character attributes: bold, italic or underlined text (or any combination of them). It can also detect and transmit character size, and can classify font types into three broad categories: serif, sans serif and monospaced.


PLUS2W and PLUS3W Omnifont Recognition Modules
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > PLUS2W and PLUS3W Omnifont Recognition Modules
Module name: | PLUS2W and PLUS3W
Module identifier: | OMNIFONT_PLUS2W and OMNIFONT_PLUS3W
Filling methods supported: | OMNIFONT
Filters supported: | ALL, DIGIT and ALPHA
Trade-off supported: | FAST, BALANCED, ACCURATE
Knowledge base file: | RECOGN.BCT, RECOGN24.BCT

Both PLUS2W and PLUS3W require the presence of FRX, MTX and MOR recognition modules.

Application Areas

This recognition module recognizes machine printed text; i.e. from printed publications, laser or ink-jet printers and electric typewriters. Output from mechanical typewriters in good condition may also be acceptable.

Range of Characters

This module supports the same set of characters as the OMNIFONT_MOR module.

Accuracy Issues

The PLUS2W and PLUS3W modules use voting technology to provide improved recognition results. The PLUS2W and PLUS3W modules use the results from one or more of FRX, MOR and MTX modules according to the trade-off. With either of these two voting modules, the accuracy is considerably better, but the recognition may need significantly more time than any single module.

Suspicious Marking

With these modules, the suspicious character and word marking feature is different from that used in MOR, MTX or FRX. These modules do not mark characters as suspicious if all the voting modules provided the same recognition result, even if they were suspiciously recognized in any of them. Consequently, there are likely to be fewer words marked as non-dictionary.

Character Attributes

The omnifont recognition module can detect and transmit character attributes: bold, italic or underlined text (or any combination of them). It can also detect and transmit character size, and can classify font types into three broad categories: serif, sans serif and monospaced.


Asian Recognition Module
User Guide > How to Work with... > Recognition > Recognition Namespace Specifications > Specifications for the Recognition Modules > Asian Recognition Module

Module name: | ASN
Module identifier: | ASIAN
Filling methods supported: | ASIAN
Filters supported: | Not used
Trade-off supported: | Not used

The Asian Recognition Module requires the ImGearRecLicenseFeature.AsianOcr license feature to be enabled.

Application Areas

This module provides recognition services for four Asian languages with horizontal or vertical text direction; these languages are Japanese, Korean and Chinese – Traditional and Simplified. It can also recognize short lengths of embedded English text, without explicitly enabling English in the Languages collection.

The Asian language module differs somewhat from those of Western languages. Below is a list of differences that should be taken into account when performing recognition of Asian text:

  • The checking subsystem is not available. This means spell checking, UD-Checking and User-Written Checking cannot be used when the Asian Recognition Module is active.
  • Only one Asian language should be set for recognition at a time.
  • Western languages should not be set alongside an Asian language.
    Note: the Asian Recognition module can recognize short lengths of embedded English text, without English needing to be set. If text from other Latin character sets are embedded, these langauges similarly do not need to be set; however, accented characters may not always be handled correctly.
  • Character attributes, such as bold and italic styling, cannot be retrieved for Asian text, or for embedded English text.
  • The Deskew3D Method does not support images with text from Asian languages.
For the Asian Recognition Module to work correctly, the selected Asian language should be set before performing preprocessing.

Asian text can be horizontal and left-to-right (FLOW) or vertical - character flow top-to-bottom with line flow from right-to-left (VERTTEXT).

Non-Asian texts embedded in vertical texts can have three orientations: vertical (neon), right-rotated and side-by-side. The latter is usually limited to three characters, and is most often used for Arabic numerals. All embedded texts will be converted to right rotation when exported to a formatted output document.

The orientation of Asian text is auto-detected on pages where user zones have not been inserted or on AUTO user zones. Auto-detection runs zone-by-zone, so pages with both horizontal and vertical text blocks (such as for picture captions) can be handled.

Digital camera input can be used for Asian-language input, but the automatic 3D deskewing is not useful is these cases.

Table zones can be inserted into Asian pages, but if the OCR engine cannot detect a table within such a zone, the zone is likely to produce zero recognition results.

Conditions

The ideal font point size for Asian language body text is 12 points, scanned at 300 dpi, resulting in characters with around 48 x 48 pixels. The minimum pixel count is about 30 x 30, that is 10.5 points at 300 dpi. For characters smaller than this, 400 dpi should be used.

When zones are defined by the user, it is recommended to create homogeneous user zones as much as possible, because they may give better results. It is especially important in the case of Asian languages. Zones that are automatically located can be inhomogeneous.

Automatic Deskew and Orientation

Support for images with text in Asian languages by the automatic deskew and orientation process can be turned on or off. By setting the ImGearRecAsianSettings.IgnoreAsianTextForDeskew and ImGearRecAsianSettings.IgnoreAsianTextForRotation properties to true, when the ImGearRecImage.PreProcess Method is called with DeskewMode and OrientationMode set to AUTO, the image will not be deskewed or rotated if the Asian Recognition module is enabled.

Character Attributes

The character attributes, such as bold and italic styling, cannot be retrieved for Asian text, or for embedded English text.

Confidence Data and Choices

Recognition results can be saved to memory as a LETTER array, making the confidence data and alternate character choices available for Asian languages.


Migrating from ImageGear v16 Recognition
User Guide > How to Work with... > Recognition > Migrating from ImageGear v16 Recognition

ImageGear for .NET v17.3 re-introduced the ImageGear.Recognition Namespace API, which offers a set of objects that provide access to document recognition technology. It enables you to build OCR applications for the Windows .NET development environment. In addition, the ImageGear.Recognition.Forms Namespace API contains classes that offer recognition-related user interface functionality.

If you want to port applications that used the ImageGear for .NET v16 (and earlier) Recognition API to the new ImageGear Recognition API, you should review this section carefully. While the new API is similar in many respects, there are many important changes to consider.

The addition of these namespaces and corresponding functionality will only make the OCR functionality available again. If you need recognition functionality other than OCR, please refer the proper replacement product for the functionality area:

  • Barcode – The Barcode Xpress product provides Barcode read and writing capabilities for many 1D and 2D barcode symbologies.
  • ICR – SmartZone ICR/OCR provides a zonal based recognition system for hand and machine printed character recognition.
  • OMR – The FormFix product is a full featured recognition tool with integrated mark detection technology for identifying and process form images
  • MICR – MICR Xpress is a complete MICR process solution allowing for accurate character recognition and image cleanup for higher accuracy

Visit www.accusoft.com for information about all Accusoft Corporation Imaging products and services.

This section provides information about the following:

  • Migrating from ImageGear v16 Recognition
    • API Elements Removed from ImageGear v17.3
    • API Elements Added in ImageGear v17.3
    • API Elements Modified in ImageGear v17.3
    • Classes Declared as Sealed in ImageGear 17.3


API Elements Removed from ImageGear v17.3
User Guide > How to Work with... > Recognition > Migrating from ImageGear v16 Recognition > API Elements Removed from ImageGear v17.3

The following API elements have been removed from ImageGear v17.3:

Enumerations

  • ImGearRecBarcodeType
  • ImGearRecFrameDetectionMode
  • ImGearRecHandprintStyle
  • ImGearRecMarkSensitivity
  • ImGearRecModuleIDs
  • ImGearRecOutputAlignment
  • ImGearRecOutputFormatType
  • ImGearRecOutputGraphics
  • ImGearRecOutputLanguage
  • ImGearRecOutputLineSpace
  • ImGearRecOutputMode
  • ImGearRecOutputPaperOrientation
  • ImGearRecOutputPaperSize
  • ImGearRecOutputTableMethod

Classes

  • ImGearRecBarcodeTypeEnabled
  • ImGearRecBARSettings
  • ImGearRecHNRSettings
  • ImGearRecOMRSettings

Structures

  • ImGearRecMarkingColor
  • ImGearRecOutputCharacterSettings
  • ImGearRecOutputDocumentSettings
  • ImGearRecOutputMarkingSettings
  • ImGearRecOutputParagraphSettings
  • ImGearRecOutputParams


API Elements Added in ImageGear v17.3
User Guide > How to Work with... > Recognition > Migrating from ImageGear v16 Recognition > API Elements Added in ImageGear v17.3

The following API elements are new in ImageGear for .NET v17.3:

Enumerations

  • ImGearRecDirectTextFormat
  • ImGearRecSpaceType

Classes

  • ImGearRecDocument


API Elements Modified in ImageGear v17.3
User Guide > How to Work with... > Recognition > Migrating from ImageGear v16 Recognition > API Elements Modified in ImageGear v17.3

The following API elements have been modified in ImageGear for .NET v17.3:

ImGearRecFillingMethod Enumeration

ImageGear 16.2 | ImageGear 17.3
BARCODE OMR HANDPRINT BRAILLE MICR BARCODE2D DOTDIGIT DASHDIGIT ASIAN | Removed Removed Removed Removed Removed Removed Removed Removed Removed

ImGearRecLicenseFeature Enumeration

ImageGear 16.2 | ImageGear 17.3
OCR ICR OMR BARCODE_BASIC BARCODE_ADVANCED | Renamed to Ocr Removed Removed Removed Removed
 | New value: FormattedOutput

ImGearRecMakeupInfo Enumeration

ImageGear 16.2 | ImageGear 17.3
RESERVED0 RESERVED1 | Removed Removed
 | New values: ENDOFROW INTABLE TEXT_DIR_MASK NORMTEXT VERTTEXT LEFTTEXT RIGHTTEXT

ImGearRecModule Enumeration

ImageGear 16.2 | ImageGear 17.3
BAR OMR HNR RER BRA MAT BAR2D ASN | Removed Removed Removed Removed Removed Removed Removed Removed
 | New value: XOCR

ImGearRecOutputLevel Enumeration

This enumeration has been completely replaced with new values. See the ImageGear for .NET v17.3 documentation for new descriptions.

ImageGear 16.2 | ImageGear 17.3
FULLFORMAT PARTFORMAT DROPFORMAT RFC | Removed Removed Removed Removed
 | New values: AUTO NOFORMAT RFP TRUEPAGE FLOWINGPAGE SPREADSHEET

ImGearRecRecognitionModule Enumeration

ImageGear 16.2 | ImageGear 17.3
BAR OMR HNR RER BRA MAT BAR2D ASIAN | Removed Removed Removed Removed Removed Removed Removed Removed

ImGearRecZoneType Enumeration

ImageGear 16.2 | ImageGear 17.3
OTHER FOOTER SGRAPHIC HEADER CAPTION COLUMN | Removed Removed Removed Removed Removed Removed
 | New values: IGNORE LEFTTEXT RIGHTTEXT

ImGearRecErrorCodes Enumeration

ImageGear 16.2

ImageGear 17.3

API_KEYCODE_ERR

BAR2D_INIT_ERR

BAR_INVALID_CODE_ERR

BAR_NOT_DEFINIT_ERR

BAR_NOT_ENOUGH_MEMORY_ERR

BAR_NO_CODE_ERR

FILE_SHARE

HNR_SYNTAX_WARN

HNR_TBSCORRUPTED_ERR

MAT_INIT_ERR

OMR_ERR

RER_INTERNAL_ERR

RER_NOCHARSET_SET_ERR

RER_NOKNOWLEDGEFILE_ERR

RER_NOTSUPPORTED_CHARSET_ERR

RER_SPECFILE_NOTFOUND_ERR

TMP_BADICF_ERR

TMP_BADPARAMETER_ERR

TMP_CLOSE_ERR

TMP_CREATEFILE_ERR

TMP_DLLLOAD_ERR

TMP_ENDOFFILE_ERR

TMP_FILENOTFOUND_ERR

TMP_INFOFULL_ERR

TMP_MEMNOTFOUND_ERR

TMP_MEM_ERR

TMP_MUSTINIT_ERR

TMP_NOCONVERTER_ERR

TMP_NOIMAGEFILE_WARN

TMP_NOMORE_WARN

TMP_READ_ERR

TMP_SEEKFILE_ERR

TMP_WRITE_ERR

TXT_W4WBADOPTION_ERR

TXT_W4WCANCELED_ERR

TXT_W4WCREATEFILE_ERR

TXT_W4WENCRYPTEDSRC_ERR

TXT_W4WEXCWRITE_ERR

TXT_W4WFATALINTERNAL_ERR

TXT_W4WFILENOTFOUND1_ERR

TXT_W4WFILENOTFOUND2_ERR

TXT_W4WINVDATA_ERR

TXT_W4WINVDOC_ERR

TXT_W4WMEMNOTFOUND_ERR

TXT_W4WREAD_ERR

TXT_W4WSEEKFILE_ERR

TXT_W4WTOOLARGE_ERR

TXT_W4WWARNING_ERR

TXT_W4WWRITE1_ERR

TXT_W4WWRITE2_ERR

ZONE_NOMORE_WARN

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

Removed

New values:

FILE_SHARE_ERR

FILE_ALREADYEXIST_ERR

FILE_INVALIDFLAG_ERR

FILE_INVALIDPARAMETER_ERR

FILE_LOCKVIOLATION_ERR

FILE_DIRNOTEMPTY_ERR

FILE_INVALIDHANDLE_ERR

FILE_MUTEX_NOTAVAILABLE_ERR

FILE_CANTCREATE_MUTEX_ERR

FILE_CANTRELEASE_MUTEX_ERR

FILE_QUIT_ERR

FILE_NOT_IMPLEMENTED_ERR

FILE_INVALIDPOINTER_ERR

FILE_INVALIDFUNCTION_ERR

CHR_MULTIPLELANG_FOUND_WARN

CHR_LANG_NOTFOUND_ERR

API_LICENSE_ERR

API_FILEFORMAT_ERR

API_INVALIDSESSION_ERR

API_DOTNET30_OR_LATER_MISSING_ERR

API_CRYPT_MISS_WARN

API_HARDTIMEOUT_ERR

IMF_READ_ERR

IMF_WRITE_ERR

IMF_INIT_ERR

IMF_OPEN_ERR

IMF_CLOSE_ERR

IMF_CREATE_ERR

IMF_MEMORY_ERR

IMF_NOTSUP_ERR

IMF_TAGMISSING_ERR

IMF_COMP_ERR

IMF_IMGFORM_ERR

IMF_PAGENUM_ERR

IMF_FILEFORMAT_ERR

IMF_COLOR_ERR

IMF_TMPFILE_ERR

IMF_APPEND_ERR

IMF_FILENOTEMPTY_ERR

IMF_FAXVIEWMISS_ERR

IMF_PASSWORD_WARN

IMF_EMPTYHANDLE_WARN

IMF_READ_WARN

IMF_COMP_WARN

IMG_INVALIDOP_ERR

IMG_ZONE_ERR

IMG_DPI_WARN

IMG_ANCHOR_WARN

IMG_ANCHORNOTFOUND_ERR

PAGE_NOTFOUND_ERR

PAGE_HANDLE_ERR

ZONE_NOTFOUND_WARN

ZONE_SHAPE_ERR

ZONE_IMAGE_DOWNSAMPLED_WARN

ZONE_SIZE_WARN

ZONE_NO_FIELDNAME_WARN

EXTRACTED_TXT_WARN

SPL_EXISTSECT_WARN

APIP_INIT_ERR

APIP_PARAM_ERR

APIP_NOMORE_WARN

APIP_INTERNAL_ERR

L_WARNINGS

L_WARNING_NOTFOUND

L_WARNING_NOTOPENED

L_WARNING_MISSING

L_WARNING_SUBSTITUTED

L_ERRORS

L_ERROR_NOID

L_ERROR_OBJID

L_ERROR_OBJTYPE

L_ERROR_FILE

L_ERROR_FILE_OPEN

L_ERROR_FILE_CLOSE

L_ERROR_FILE_SEEK

L_ERROR_FILE_READ

L_ERROR_FILE_WRITE

L_ERROR_FILE_FORMAT

L_ERROR_PARAMETER

L_ERROR_RANGE

L_ERROR_CALL

L_ERROR_CONVERTER

L_ERROR_BADVERSION

L_ERROR_IMAGE

L_ERROR_DTK

L_ERROR_READONLY

L_ERROR_OUTPUT_MODE

L_ERROR_APPSET

L_ERROR_PRERENDERING

L_ERROR_NOACCESS

L_ERROR_NOTIMPLEMENTED

L_ERROR_MASTERSOFT

L_ERROR_ABORTED

L_ERROR_CONV_NODOCUMENT

L_ERROR_CONV_LECSO

L_ERROR_TOO_MANY_SHEETS

L_ERROR_DOCFORMATTER

L_ERROR_STOP

L_FATALERRORS

L_FERROR_MEMORY

L_FERROR_INTERNAL

L_FERROR_FILEFORMAT

L_FERROR_INDEX

L_FERROR_RECAPI

L_FERROR_NOSET

L_FERROR_PERMISSION

L_FERROR_MISSING

FRX_INIT_ERR

ASN_INIT_ERR

MNG_INIT_ERR

STSMN_HANDLE_ERR

STSMN_NOSETTING_ERR

STSMN_BADTYPE_ERR

STSMN_OPNOTALLOWED_ERR

STSMN_PARAMETER_ERR

STSMN_INVALIDFILE_ERR

STSMN_NOTFOUND_ERR

STSMN_FULLSAVEDTREE_WARN

STSMN_BADORMISSINGREF_ERR

ImGearRecCodePage Structure

Public fields have been replaced with properties.

ImageGear 16.2 | ImageGear 17.3
Fields: System.String Name System.String Description ImGearRecOutputCodePageType Type | Properties: System.String Name {get;} System.String Description {get;} ImGearRecOutputCodePageType Type {get;}

ImGearRecLetter Class

Public fields have been replaced with properties.

ImageGear 16.2 | ImageGear 17.3
Fields: ImGearRectangle Rect Int16 Baseline Byte Space Char Code Byte Err ImGearRecFontFlags Font Byte FontSize ImGearRecLanguage Lang ImGearRecLanguage Lang2 public UInt16 Zone | Properties: IImGearRectangle Rect {get; } UInt16 Baseline { get; set; } Replaced with UInt16 SpacesCount {get; set;} Replaced with Char Code {get; set;} Replaced with Byte ConfidenceInfo {get; set;} Replaced with FontAttribute {get; set;} Replaced with UInt16 CapitalLetterHeight {get; set;}. See documentation for details. Replaced with Language {get; set;} Replaced with AlternativeLanguage {get; set;} public UInt16 ZoneIndex {get; set;}
Byte SpaceErr Char Code2 Char Code3 UInt16 CellNum | Removed Removed Removed Removed
 | New properties: Byte UnderlineDotWidth {get; set;} Byte UnderlineGapWidth {get; set;} ImGearRecSpaceType SpaceType {get; set;} UInt16 SpacesCount {get; set;}

ImGearRecModuleCollection Class

ImageGear 16.2 | ImageGear 17.3
Properties: ImGearRecBARSettings BAR ImGearRecHNRSettings HNR ImGearRecOMRSettings OMR | Removed Removed Removed

ImGearRecModuleSettings Class

ImageGear 16.2 | ImageGear 17.3
Boolean Resident System.String SpecParams | Removed Removed

ImGearRecOutputFormat Structure

Public fields have been replaced with properties.

ImageGear 16.2 | ImageGear 17.3
Fields: System.String Name System.String DefaultFileExtension ImGearRecOutputCodePageType CodePageType System.String DLLFileName ImGearRecOutputFormatType OutputType | Properties: System.String Name {get;} System.String DefaultFileExtension {get;} Removed Removed Removed

ImGearRecOutputManager Class

ImageGear 16.2 | ImageGear 17.3
Void WriteDocument(System.String) Void WriteDocument(System.String, System.String) | Void WriteDocument(ImGearRecDocument, System.String) – for formatted output Void WriteDirectText(ImGearRecPage, System.String) and Void WriteDirectText(ImGearRecPage[], System.String) – for direct text output.
System.String Format | Now only affects the formatted output. For direct text output, use the property ImGearRecDirectTextFormat DirectTextFormat
Void WriteDocumentToMemory() Void WriteDocumentToMemory(System.String) ImGearRecOutputParams GetParamsCopy() Void UpdateParamsFrom( ImGearRecOutputParams) System.String OutputText | Removed Removed Removed Removed Removed

ImGearRecPage Class

ImageGear 16.2 | ImageGear 17.3
Methods: Void RecognizeToMemory() Void Recognize(System.String) Void WriteRecognitionData(System.String) | Removed Removed Removed
 | New property: Boolean IsValid { get; }

ImGearRecProgressEventArgs Class

ImageGear 16.2 | ImageGear 17.3
Properties: Int32 CharCount Int32 RejectedCharCount | Removed Removed

ImGearRecRecognitionSettings Class

ImageGear 16.2 | ImageGear 17.3
Methods: Boolean IsCharEnabled(Char) Properties: Boolean KeepGraphics ImGearRecLanguage[] SpellingLanguages | Removed Removed Replaced with ReadOnlyCollection< ImGearRecLanguage> SpellingLanguages

ImGearRecUDItem Class

Public fields have been replaced with properties.

ImageGear 16.2 | ImageGear 17.3
Fields: System.String ItemText System.String SectionName Boolean IsRegExp | Properties: System.String ItemText {get; set;} System.String SectionName {get; set;} Boolean IsRegExp {get; set;}

ImGearRecZone Class

Public fields have been replaced with properties.

ImageGear 16.2 | ImageGear 17.3
Fields: ImGearRectangle Rect ImGearRecFillingMethod FillingMethod ImGearRecRecognitionModule RecognitionModule ImGearRecFilter Filter ImGearRecZoneType Type ImGearRecZoneCheckingFlags Checking System.String UDSectionName System.Object UserData | Properties: IImGearRectangle Rect {get; } ImGearRecFillingMethod FillingMethod {get; set;} ImGearRecRecognitionModule RecognitionModule {get; set;} ImGearRecFilter Filter {get; set;} ImGearRecZoneType Type {get; set;} ImGearRecZoneCheckingFlags Checking {get; set;} System.String UserDictionarySection {get; set;} System.Object UserData {get; set;}
Int32 ID | Removed


Classes Declared as Sealed in ImageGear 17.3
User Guide > How to Work with... > Recognition > Migrating from ImageGear v16 Recognition > Classes Declared as Sealed in ImageGear 17.3

The following classes have been declared as sealed in ImageGear v17.3:

  • ImGearRecCheckWordEventArgs Class
  • ImGearRecLetter Class
  • ImGearRecognition Class
  • ImGearRecPDFOutputOptions Class
  • ImGearRecProgressEventArgs Class
  • ImGearRecUDItem Class
  • ImGearRecZone Class


Scanning
User Guide > How to Work with... > Scanning

This section provides information about the following:

  • Scanning
    • TWAIN Scanning
      • Acquiring Images from TWAIN Devices
    • Using ImageGear.Web.Isis Namespace
      • Captiva Cloud Runtime Redistribution
      • Scanner Service & Session
      • Scanner Selection
      • Scanner Settings
      • ISIS Tags
      • Scan Job


TWAIN Scanning
User Guide > How to Work with... > Scanning > TWAIN Scanning

Another technique for loading an ImGearPage Class object involves obtaining the image from a device, like a scanner or a camera. ImageGear supports the acquisition of images from TWAIN-compliant devices.

ImageGear supports TWAIN 1.6, 1.7, 1.8, and 1.9, working with a wide variety of scanner devices, digital cameras, and video capture boards. No TWAIN toolkit is easier or more comprehensive.

ImageGear includes a wide array of methods, providing the developer with detailed control of the scanning process, including control of the following:

  • TWAIN transfer mode
  • Available TWAIN device listing
  • Scanning area
  • Brightness and contrast
  • Dots-per-inch (resolution)
  • Display of the TWAIN UI
  • Setting an event to gain control during scanning
  • ADF (Automatic Document Feeder) for multi-page scanning
  • Scanner capabilities

For a complete description of how to use ImageGear TWAIN namespace, see the ImageGear.TWAIN Namespace API Reference.

The ImageGear.TWAIN Namespace is available in ImageGear for .NET 32-bit only.

This section provides information about the following:

  • TWAIN Scanning
    • Acquiring Images from TWAIN Devices


Acquiring Images from TWAIN Devices
User Guide > How to Work with... > Scanning > TWAIN Scanning > Acquiring Images from TWAIN Devices

TWAIN was developed by a consortium of software and hardware manufacturers to standardize the communications between application programs and image acquisition devices. The interface is optimized for the acquisition of graphics images. The TWAIN standard is widely supported by scanner manufacturers. The most widely used version of TWAIN is v1.9 (as of this writing). In addition to scanners, TWAIN is being used with digital cameras and video capture boards. ImageGear supports all three TWAIN Transfer Modes: Native Data Transfer Mode (which is the TWAIN default), Disk File Transfer, and Buffered Memory.

A TWAIN-compliant image acquisition device is one whose device driver complies with the TWAIN specification. The device driver understands the TWAIN protocol, thus allowing interaction with the Data Source Manager, the main interface module of the TWAIN software. The Data Source Manager "manages the session" between the application program and the raster-generating data source. Three software elements work together in TWAIN: the application, the Data Source (DS), and the Data Source Manager (DSM) as shown in the illustration below:

The following terminology is used to discuss ImageGear scanning:

  • Data Source: Software provided by the manufacturer of the device. Windows refers to this as a "Device Driver". It must be installed in the system where your application program will run.
  • Data Source Manager: The TWAIN manager for the device drivers. This is software developed by the TWAIN consortium to provide a common mechanism for managing and using the Data Sources from all the different device manufacturers. It must be installed in the system where your application will run.
  • Device: Any device from which images can be acquired using the TWAIN protocol, including scanners and cameras.

The TWAIN Data Source for your device and the TWAIN Data Source Manager should be included as part of your scanner software. They are not part of the ImageGear software.

The process of acquiring an image (or set of images) from a device is as follows:

  1. Open the Data Source. This can be done automatically by the application (it chooses the Data Source for the end-user). Alternatively, the application can obtain a list of Data Sources from the Data Source Manager and let the end-user choose, or the application can have ImGearTWAIN Class display the list via its standard dialog box.
  2. Set the the image acquisition parameters (single-page, multi-page, image size, etc.). This can be done automatically by the application, or the application can obtain the various Data Source capabilities (called "ScanCaps"), display them to the end-user in a dialog, and let the end-user choose the values. Alternatively, the application can let ImGearTWAIN Class obtain the settings from the end-user via its standard ScanCaps dialog.
  3. Acquire the image(s). Each image is loaded into an ImGearPage Class object. For a multi-page acquisition, the ImGearPages are loaded into an ImGearDocument Class.
  4. Close the Data Source.

Thus, an example of the code needed to acquire an image from a TWAIN Data Source is as follows:

C#
Copy Code
ImGearTWAIN igTWAIN = new ImGearTWAIN();
igTWAIN.WindowHandle = this.Handle;
igTWAIN.UseUI = true;
// Open a data source
igTWAIN.OpenSource("");
// Set simplex mode
ImGearCapOneValue igCapOneValue = new ImGearCapOneValue(ImGearCapabilities.CAP_DUPLEXENABLED);
igCapOneValue.Value = false;
igTWAIN.SetCapability(igCapOneValue, ImGearMessages.SET);
// Acquire image
ImGearPage igPage = igTWAIN.AcquireToPage();
// Close the data source
igTWAIN.CloseSource();


Using ImageGear.Web.Isis Namespace
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace

The ImageGear.Web.Isis API provides functionality for obtaining an ImGearPage or ImGearDocument from an ISIS or TWAIN compliant device in a web-based application running in a browser. TWAIN compliant devices can be accessed through the ISIS PixTwain driver that is included with the Captiva Cloud Runtime.

To access the ImageGear .NET ISIS API, you must reference the ImageGear.Web.UI.Isis.js file in the ImageGear.Web assembly as demonstrated below:

HTMLExample
Copy Code
<body>
    <form id="form1" runat="server">
    <asp:ScriptManager ID="ScriptManager1" runat="server">
        <Scripts>
            <asp:ScriptReference Assembly="ImageGear22.Web" Name="ImageGear.Web.UI.Isis.js" />
        </Scripts>
    </asp:ScriptManager>
…

Class Architecture

The class architecture for the ImageGear ISIS functionality is shown in the diagram below:

The following topics are discussed in this section:

  • Using ImageGear.Web.Isis Namespace
    • Captiva Cloud Runtime Redistribution
    • Scanner Service & Session
    • Scanner Selection
    • Scanner Settings
    • ISIS Tags
    • Scan Job


Captiva Cloud Runtime Redistribution
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > Captiva Cloud Runtime Redistribution

Captiva Cloud Runtime

The Captiva Cloud Service acts as a local web capture server to process ImageGear ISIS API calls to perform tasks such as scanning and manipulating images. The service is part of the Captiva Cloud Runtime Components which must be installed on each client computer that will access your application. The Captiva Cloud Runtime installer is installed when you install ImageGear for .NET, and the Captiva Cloud Runtime Components can optionally be installed, which is necessary to use the ImageGear ISIS functionality.

By default, the Captiva Cloud Service is configured to start automatically when the computer starts. When the service starts, it scans for available TCP network ports that your application can use to communicate with the local web capture server. The server listens on port 49732, 49733, or 49734 for HTTP and on port 49735, 49736, or 49737 for HTTPS. If none of the ports are available, then an error is logged in the Windows System event log.

Redistribution

For an application to use the ImageGear ISIS features, the Captiva Cloud Runtime components must be installed on the application user’s system. The runtime components might be installed as a standalone package, or with another piece of software such as a scanning application. Users running your application must also have Microsoft .NET Framework 3.5 SP1 installed. You can download a redistributable package from the Microsoft website and include it in your distribution. The Captiva Cloud Runtime installer files are installed by default to the location below:

C:\Users\Public\Documents\Accusoft\ImageGear for .NET v22\Redistributable

If a browser is installed after the toolkit runtime is installed, then the Captiva Cloud Service must be restarted before the browser will have access to the local security certificate that enables secure communications over HTTPS. If a browser is open during installation of the toolkit runtime, then the browser might have to be restarted. If the service or the browser is not restarted, the operator might be presented with security warnings when using your application.

The following redistribution options are available. You need to use only one of these.

Merge Module

A merge module lets you include toolkit components in an installer application. Use this option when you want to install the runtime alongside additional software. You can add a merge module file to your installation project following the instructions provided with Visual Studio.

The following merge modules are available:

  • EMC.CaptivaCloud.msm: Contains all of the files needed for ImageGear ISIS applications to use scanners via the ISIS driver interface.
  • pixtwain.msm: Contains PixTWAIN, which is an application that enables ISIS commands to work with TWAIN drivers. ISIS is often preferred, but not all scanners have ISIS drivers. Include this package if you might need to support TWAIN drivers.

This version of PixTWAIN can be used only by applications using the Captiva Cloud Runtime.

Installer

The installer is an executable file (plus supporting files) that can be used to distribute only the toolkit components. The installer can be run from a number of different contexts. A silent installation option is available, but by default the installer is interactive. You can distribute the installer if you want to allow users to decide where to install the files.

You can redistribute the runtime installer in many ways, such as on an intranet site, via an automatic deployment tool such as Microsoft Systems Management Server (SMS), or simply by making it available on a network share. Your distribution package must include all of the files in the Redistributable folder. The runtime can be installed by running setup.exe.

To perform a silent installation, run the installer using the following command:

setup.exe /S /v/qn

Additional command line arguments are available. Run the following command to display a list of arguments that you can specify:

setup.exe /?

The Windows Installer program itself (MsiExec.exe) accepts a number of additional arguments that can be passed with the /v argument. Run MsiExec.exe /help for more information about these arguments.

Configuring the Service to Restart Automatically

To help ensure continuous availability of toolkit functionality, you can configure the Captiva Cloud Service to restart automatically on failure when you install it. Windows services are configurable from a command line that you can call from your installer. Refer to the operating system documentation or the Microsoft web site for information about configuring the behavior for a service that fails. The service name is Emc.Captiva.WebCaptureService.


Scanner Service & Session
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > Scanner Service & Session

The ImGearIsisScannerService class can be used to create an ImGearIsisScannerSession by calling the createSession method, and only one ImGearIsisScannerSession can be used at a time. An ImGearIsisScannerSession has a read-only scanner property and can be used to create an ImGearIsisScanJob to begin scanning, and these are described in more detail in the Scanner Selection, Scanner Settings and Scan Job topics.

When any asynchronous method is called, a callback parameter is used so the customer can be notified when the task completes. Also, an ImGearIsisStatus object is returned so the customer can check the status of the task.

The code below demonstrates creating an ImGearIsisScannerService, calling the createSession method, and accessing the session in the callback:

JavaScript Example
Copy Code
            var scannerSession;
…
            function createSessionCallback(theScannerSession, status) {
                if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                    alert(status.get_statusMessage());
                }
                // Store the scanner session.
                scannerSession = theScannerSession;
            }
            var scannerService = new ImageGear.Web.Isis.ImGearIsisScannerService();
            scannerService.createSession({ applicationName: ‘ImageGear ISIS Application’, destroyExistingSession: true, locale: ‘en-us’, idleTimeoutMinutes: 0, callback: createSessionCallback });

The ImGearIsisScannerSession.destroy method can be used to destroy a scanner session. To ensure that the runtime is available to other applications when your application exits, you must explicitly end the session. You can end the session automatically when the web page is closed by assigning an event handler to the onunload property of the HTML body element. This is demonstrated in the ASP.NET Isis sample and shown below:

JavaScript Example
Copy Code
<body>
…
  <script type="text/javascript">
    window.onunload = onPageUnload;
    function onPageUnload() {
      if (scannerSession) {
        scannerSession.destroy();
      }
    }
  </script>
</body>


Scanner Selection
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > Scanner Selection

A scanner must first be selected by calling the ImGearIsisScannerSession setScanner method in order for the ImGearIsisScannerSession scan method to work or any of the ImGearIsisScanner methods to work. When a scanner is selected, the ImGearIsisScanner selected property returns true. A scanner can be unloaded by calling the unload method.

The setScanner method has two overloads. You can specify a load option for a scanner selection dialog or to specify that the currently selected scanner should be used. This is demonstrated below:

JavaScript Example
Copy Code
            function onScannerLoaded(status) {
                if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                    alert(status.get_statusMessage());
                }
                // The scanner can now be accessed through the ImGearIsisScannerSession scanner property.
                var scanner = scannerSession.get_scanner();
                // You could use the getTag method or getAllTags method here
                // to get the current scanner settings.
            }
            // Show the scanner selection dialog with a list of connected drivers.
            scannerSession.setScannerWithDialog(
                ImageGear.Web.Isis.ImGearIsisLoadScannerOption.ShowConnectedDriverList, onScannerLoaded);

Another option is to pass an ImGearIsisScanner object to change to the specified scanner without showing a dialog. You can get a collection of connected scanners and a collection of undetected scanners by calling the ImGearIsisScannerSession getScanners method. This is demonstrated below, where “scannerSelect” is an HTML DOM <select> object:

JavaScript Example
Copy Code
       var scanners;
...
       function ButtonGetScanners_onclick() {
           function getScannersCallback(connectedDevices, undetectedDevices, status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
               var select = document.getElementById('scannerSelect');
               // Store the scanners so one of them can be set later.
               scanners = connectedDevices;

               for (var i = 0; i < connectedDevices.get_length(); i++) {
                   var scanner = connectedDevices.getScanner(i);

                   var option = document.createElement(‘option’);
                   var scannerName = scanner.get_name();
                   option.text = scannerName;
                   select.add(option, null);
               }
            }
            // Get a list of connected scanners and add each to a list box.
            var operationStatus = scannerSession.getScanners(getScannersCallback);
       }
       function ButtonSetConnectedScanner_onclick() {
           function onScannerLoaded(status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
                // The scanner can now be accessed through the ImGearIsisScannerSession scanner property.
                var scanner = scannerSession.get_scanner();
                // You could use the getTag method or getAllTags method here
                // to get the current scanner settings.
           }
           var select = document.getElementById('scannerSelect');
           var selectedScanner = scanners.getScanner(select.selectedIndex);
           // Set the scanner that is selected in the connected list.
           scannerSession.setScanner(selectedScanner, onScannerLoaded);
       }


Scanner Settings
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > Scanner Settings

The ImGearIsisScanner showUI method can be used to show a configuration dialog for the scanner, as demonstrated below:

JavaScript Example
Copy Code
           function showUICallback(status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
           }
           scannerSession.get_scanner().showUI(showUICallback);

The getTag method can be used to get the value of an ISIS tag and the setTagInteger, setTagRational and setTagString methods can be used to set the value of an ISIS tag. The first example below demonstrates getting the string values for the page size tag and adding each to an HTML DOM <select> object named “pageSizeSelect”. The second example demonstrates setting the page size tag to the selected item.

JavaScript Example #1
Copy Code
           function getTagCallback(tagID, tagType, choices, tagValue, status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
               var pageSizeSelect = document.getElementById(‘pageSizeSelect’);
               // The page sizes are provided as strings. The choices argument contains properties for getting the list of strings, integers, or numerators and denominators or the minimum, maximum, and step values for a range of integers or numerators and denominators. The tagValue argument contains properties for getting the current string value, integer value, or numerator and denominator values. You can check the tagType argument to determine if the tag values are string, integer, or rational. You can check the choiceKind property of the choices argument to determine if the tag values are provided as a range or in a list. See the ASP .NET ISIS sample for more code that demonstrates accessing the getTag callback arguments for different tags.
               var stringList = choices.get_stringList();
               for (var i = 0; i < stringList.get_length(); i++) {
                   var tagString = stringList.getTagString(i);
                   var option = document.createElement(‘option’);
                   option.text = tagString;
                   pageSizeSelect.add(option, null);
               }
           }
           scannerSession.get_scanner().getTag(ImageGear.Web.Isis.ImGearIsisTag.PageSize, 0, getTagCallback);

JavaScript Example #2
Copy Code
           function setTagCallback(status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
           }
           var pageSizeSelect = document.getElementById(‘pageSizeSelect’);
           scannerSession.get_scanner().setTagString(ImageGear.Web.Isis.ImGearIsisTag.PageSize, pageSizeSelect[pageSizeSelect.selectedIndex].value, setTagCallback);

To get or set all of the ISIS tag settings you can use the getAllTags and setAllTags methods, as demonstrated below:

JavaScript Example #1
Copy Code
           var scannerSettings = ‘’;
…
           function getAllTagsCallback(settingString, status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }

               scannerSettings = settingString;
           }
           scannerSession.get_scanner().getAllTags(getAllTagsCallback);

JavaScript Example #2
Copy Code
           function setAllTagsCallback(status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
           }
           scannerSession.get_scanner().setAllTags(scannerSettings, setAllTagsCallback);


ISIS Tags
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > ISIS Tags

ISIS Tags

ISIS tags can be used to configure scanner settings.

Tag Number

Hexadecimal (Decimal)

Tag Name

(Not Used Directly in Captiva Cloud Toolkit)

Data Type

Description

0x0000 (0)

—

Integer

A list of all the tags that the driver supports, as numeric values.

0x06A5 (1701)

TAG_ADFTIMEOUT

Integer

The time (in seconds) that the scanner spends attempting to read the next page before reporting that no page was found.

0x1318 (4888)

TAG_ALLFILESFLAG

Integer

Enables or disables the filter that shows all files (*.*) in a common file open selection list. Set this tag as desired before getting the value of TAG_AVAILFMTS to control whether the available formats include the filter.

Possible Values for: TAG_ALLFILESFLAG

Value | Description
0 | Disable the filter.
1 | Enable the filter.

0x1322 (4892)

TAG_ALLOWEDFORMATS

Integer

Limits the available formats reported by TAG_AVAILFMTS, enabling your application to list only a subset of the formats supported by the installed group of file filters in a file open or file save selection list.

The number of times this tag can be set depends on the value of TAG_NUMALLOWEDFORMATS.

For the list of possible tag values, refer to ImGearIsisFileType.

0x1330 (4900)

TAG_AVAILBITSPERSAMPLE

Integer

Enables you to retrieve the valid choices for the number of bits per sample.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1324 (4894)

TAG_AVAILCOLORFMTS

Integer

Enables you to retrieve the valid color format choices for the file types in TAG_AVAILFORMAT_FILETYPES.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1325 (4895)

TAG_AVAILCOLORFMTSNAME

String

Enables you to retrieve the valid color format name choices for the color format choices in TAG_AVAILCOLORFMTS.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1326 (4896)

TAG_AVAILCOMPRESSION

Integer

Enables you to retrieve the valid compression choices for the color format choices in TAG_AVAILCOLORFMTS.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1327 (4897)

TAG_AVAILCOMPRESSIONNAME

String

Enables you to retrieve the valid compression name choices for the color format choices in TAG_AVAILCOLORFMTS.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1316 (4886)

TAG_AVAILFMTS

String

A string in the format required by a file type list in a Windows common file open window.

The list depends on the values of TAG_NUMALLOWEDFORMATS and TAG_ALLOWEDFORMATS.

0x1321 (4891)

TAG_AVAILFORMAT_EXTS

String

Enables you to retrieve the filename extensions for the valid file types.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1319 (4889)

TAG_AVAILFORMAT_FILETYPES

Integer

Enables you to retrieve the file types. For the list of possible values that might be available as choices, refer to ImGearIsisFileType.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1320 (4890)

TAG_AVAILFORMAT_NAMES

String

Enables you to retrieve the file type names.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1329 (4899)

TAG_AVAILPHOTOMETRIC

Integer

Enables you to retrieve the valid photometric interpretation choices for the current bits per sample choices.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1328 (4898)

TAG_AVAILSAMPLESPERPIXEL

Integer

Enables you to retrieve the valid samples per pixel choices for the current file type choices.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x06C1 (1729)

TAG_BAR_AUTOREADBACK

Integer

Enables or disables automatic barcode detection on the back side of a duplex scan, using the current barcode search parameters.

Note: If the driver supports barcode detection but does not support this tag specifically, then automatic search is always enabled.

Possible values for: TAG_AUTOREADBACK

Value | Description
0 | Disable automatic barcode check.
1 | Enable automatic barcode check.

0x06C0 (1728)

TAG_BAR_AUTOREADFRONT

Integer

Enables or disables automatic barcode detection on the front side of a duplex scan, using the current barcode search parameters.

Note: If the driver supports barcode detection but does not support this tag specifically, then automatic search is always enabled.

Possible values for: TAG_AUTOREADFRONT

Value | Description
0 | Disable automatic barcode check.
1 | Enable automatic barcode check.

0x069C (1692)

TAG_BAR_TYPE

Integer

The type or types of barcodes to search for.

This tag contains a list of one or more values, accessible through an index. Set the number of barcode types with TAG_BAR_TYPECOUNT.

For the list of possible barcode type values, refer to ImGearIsisBarcodeType.

0x069D (1693)

TAG_BAR_TYPECOUNT

Integer

The number of barcode types to search for.

0x069B (1691)

TAG_BARCODE

Integer

Enables or disables barcode detection.

Possible values for: TAG_BARCODE

Value | Description
0 | Disable barcode detection.
1 | Enable barcode detection. This choice is not available if the driver does not support this feature.

0x06C7 (1735)

TAG_BARDATA_TEXT

String

The text of the barcode from the most recent barcode detection.

If no barcode was found, then this value has no meaning and should be ignored. Check the value TAG_BARDATA_TYPE to determine if a barcode was found.

0x06C2 (1730)

TAG_BARDATA_TYPE

Integer

The type of the barcode from the most recent barcode detection.

For the list of possible values, refer to ImGearIsisBarcodeType.

0x06C3 (1731)

TAG_BARDATA_XPOSITION

Integer

The horizontal position of the barcode from the most recent barcode detection, measured in units of the current resolution. This is the horizontal distance from the left edge of the page to the left edge of the barcode.

0x06C4 (1732)

TAG_BARDATA_YPOSITION

Integer

The vertical position of the barcode from the most recent barcode detection, measured in units of the current resolution. This is the vertical distance from the top edge of the page to the top edge of the barcode.

0x0508 (1288)

TAG_BELL

Integer

Indicates if the scanner has an audible alert device.

Possible values for: TAG_BELL

Value | Description
0 | The scanner has an audible alert device.
1 | The scanner does not have an audible alert device.

0x0102 (258)

TAG_BITSPERSAMPLE

Integer

The number of bits per sample to use in stored images.

Note: Because some drivers have restrictions on how pages can be fed or rotated, setting this tag could affect the values of TAG_DATAORIENTATION and TAG_SCANORIENTATION.

0x1726 (5926)

TAG_BLANKPAGE_IMPRINTER_BEHAVIOR

Integer

Detects whether the scanner’s imprinter prints on deleted blank pages. You can use this value to keep track of the imprinter counter when a blank page is deleted.

Possible values for: TAG_BLANKPAGE_IMPRINTER_BEHAVIOR

Value | Description
0 | Blank pages are imprinted.
1 | Blank pages are not imprinted.

0x1334 (4904)

TAG_BPS_LBS

String

Enables you to retrieve the valid choices for the number of bits per sample for a list box control. It should be used in conjunction with TAG_SPP_LBS and TAG_PHOTO_LBS to give the user total control over color format. If separate control is not desired, you should use TAG_COLORFMTS_LBS instead.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x0502 (1282)

TAG_BRIGHTNESS

Integer

The brightness applied to an image.

The table that follows lists the possible nonpositive special values. You must get the list of valid choices to be aware of the number of possible positive values.

Possible values for: TAG_BRIGHTNESS

Value | Description
-3 | Brightness set automatically based on real-time sampling during scanning.
-2 | “Dark”. This is a particular value based on tests conducted by the designer of the scanner driver.
-1 | “Normal” brightness. This is a particular value based on tests conducted when the scanner driver was designed. Each model of scanner may have a different value. The normal value will be the initial value of this tag, so to determine what it is, get the value this tag before you set it.
0 | “Light”. This is a particular value based on tests conducted by the designer of the scanner driver.
Any positive integer. | An explicit relative brightness. Higher numbers produce brighter pages.

0x0507 (1287)

TAG_BUFSIZE

Integer

The size of the driver’s preferred image buffer, in bytes.

0x1332 (4902)

TAG_COLORFMTS_LBS

String

Enables you to retrieve the valid color format choices for a list box control.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x1734 (5940)

TAG_COLORFORMAT

 Integer

The color format to use in stored images.

Possible values for: TAG_COLORFORMAT

Value | Description
0 | Unknown color format
1 | 2-color (black & white)
2 | 4-bit grayscale
3 | 8-bit grayscale
4 | Full color using the RGB color space

0x0140 (320)

TAG_COLORMAP

Integer

The palette values for a palette image.

This tag is set automatically by file drivers when they are handling a palette image, so in most cases you do not need to be concerned with this tag.

0x0103 (259)

TAG_COMPRESSION

Integer

The compression type to use in stored images. For the list of possible values, refer to ImGearIsisImageCompression.

The valid compression types depend on the color format, so you should set this tag only after setting the desired color format. For information about the supported formats, refer to ImGearIsisFileType.

0x1333 (4903)

TAG_COMPRESSION_LBS

String

Enables you to retrieve the valid compression type choices for a list box control.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x0600 (1536)

TAG_CONFIGURATIONS

String

Enables you to retrieve the names of the custom default scanner configurations that are defined in the driver. The configurations themselves are stored in the TAG_CONFIG_n tags.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x0601 (1537)

TAG_CONFIG_1

String

A custom default scanner configuration that is defined in the driver.

0x0602 (1538)

TAG_CONFIG_2

String

A custom default scanner configuration that is defined in the driver.

0x0603 (1539)

TAG_CONFIG_3

String

A custom default scanner configuration that is defined in the driver.

0x0604 (1540)

TAG_CONFIG_4

String

A custom default scanner configuration that is defined in the driver.

0x0501 (1281)

TAG_CONTRAST

Integer

The contrast applied to an image.

Possible values for: TAG_CONTRAST

Value | Description
0 | Contrast set automatically. This value could also mean that no contrast control is available.
Any positive integer. | An explicit relative contrast. A higher numbers means higher contrast.

0x0114 (276)

TAG_DATAORIENTATION

Integer

The orientation to which the scanner has rotated the image.

For the list of possible values, refer to ImGearIsisOrientation.

Note:

This tag must be set before TAG_SCANORIENTATION. Setting either of these tags will affect the values of TAG_IMAGELENGTH, TAG_IMAGEWIDTH, TAG_XPOSITION, and TAG_YPOSITION. Also, because some drivers have restrictions on how pages can be fed or rotated, setting any of the following tags could affect the values of TAG_DATAORIENTATION and TAG_SCANORIENTATION:

  • TAG_BITSPERSAMPLE

  • TAG_PAGESIZE

  • TAG_SAMPLESPERPIXEL

  • TAG_SCANTYPE

  • TAG_XRESOLUTION

  • TAG_YRESOLUTION

0x1341 (4929)

TAG_DETECTBLANKIMAGE

Integer

Enables or disables blank page detection and deletion during scanning.

This is useful if you are keeping track of page sides in a duplex scan. Unless you can detect deleted pages, you will be unable to determine whether an image is from the front side or the back side of a sheet of paper.

You can also use this, along with TAG_BLANKPAGE_IMPRINTER_BEHAVIOR, to keep track of imprinter counts.

Possible values for: TAG_DETECTBLANKIMAGE

Value | Description
0 | Disable blank page detection.
1 | Enable blank page detection.

0x133B (4923)

TAG_DETECTBLANKIMAGE_BINARY

Integer

Enables or disables blank page detection and deletion for the binary stream during multistream scanning.

Possible values for: TAG_DETECTBLANKIMAGE_BINARY

Value | Description
0 | Disable blank page detection.
1 | Enable blank page detection.

0x133D (4925)

TAG_DETECTBLANKIMAGE_COLOR

Integer

Enables or disables blank page detection and deletion for the color stream during multistream scanning.

Possible values for: TAG_DETECTBLANKIMAGE_COLOR

Value | Description
0 | Disable blank page detection.
1 | Enable blank page detection.

0x133C (4924)

TAG_DETECTBLANKIMAGE_GRAY

Integer

Enables or disables blank page detection and deletion for the grayscale stream during multistream scanning.

Possible values for: TAG_DETECTBLANKIMAGE_GRAY

Value | Description
0 | Disable blank page detection.
1 | Enable blank page detection.

0x05A7 (1447)

TAG_DETECTJOBSEP

Integer

The mode for detecting job separator sheets.

Possible values for: TAG_DETECTJOBSEP

Value

Description

0

Disable job separator detection.

1

Detect job separator, and:

  • Include the separator as a scanned page.

  • Continue with ScanAhead.

2

Detect job separator, and:

  • Skip the separator.

  • Continue with ScanAhead.

Note: This value has the same meaning as value 5. Different scanners support different values. You should get the list of valid choices to determine which one to use.

3

Detect job separator, and:

  • Include the separator as a scanned page.

  • Stop ScanAhead. (You can change scanner settings before the next batch of pages is scanned.)

4

Detect job separator, and:

  • Skip the separator.

  • Stop ScanAhead. (You can change scanner settings before the next batch of pages is scanned.)

Note: This value has the same meaning as value 6. Different scanners support different values. You should get the list of valid choices to determine which one to use.

5

Detect job separator, and:

  • Skip the separator.

  • Continue with ScanAhead.

Note: This value has the same meaning as value 2. Different scanners support different values. You should get the list of valid choices to determine which one to use.

6

Detect job separator, and:

  • Skip the separator.

  • Stop ScanAhead. (You can change scanner settings before the next batch of pages is scanned.)

Note: This value has the same meaning as value 4. Different scanners support different values. You should get the list of valid choices to determine which one to use.

0x0500 (1280)

TAG_DITHER

String

The dithering mode.

Dither patterns are unique to each scanner, so there is no predefined set of tag choices. You should get the valid choices before attempting to set this tag. The first choice represents no dithering and is usually called None.

Note:

Some scanners have different dithering options depending on the color format of the image. Many scanners support dithering of only binary images. Therefore, the values of the following tags might affect the dithering choices that are available:

  • TAG_BITSPERSAMPLE

  • TAG_PHOTOMETRICINTERPRETATION

  • TAG_SAMPLESPERPIXEL

0x0518 (1304)

TAG_DITHER_LENGTH1

Integer

The length of TAG_DITHER_PATTERN1.

0x0519 (1305)

TAG_DITHER_LENGTH2

Integer

The length of TAG_DITHER_PATTERN2.

0x0548 (1352)

TAG_DITHER_PATTERN1

Integer

A downloadable dither pattern defined on the scanner.

A dither pattern is a 2-dimensional array of values. To create one, establish the pattern width and length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable dither patterns.

0x0549 (1353)

TAG_DITHER_PATTERN2

Integer

A downloadable dither pattern defined on the scanner.

A dither pattern is a 2-dimensional array of values. To create one, establish the pattern width and length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable dither patterns.

0x0538 (1336)

TAG_DITHER_WIDTH1

Integer

The width of TAG_DITHER_PATTERN1.

0x0539 (1337)

TAG_DITHER_WIDTH2

Integer

The width of TAG_DITHER_PATTERN2.

0x0510 (1296)

TAG_EMPHASIS

Integer

The scanner’s emphasis setting. Consult the scanner documentation for information on how to use emphasis.

Possible values for: TAG_EMPHASIS

Value | Description
0 | No emphasis.
1 | Low emphasis.
2 | Medium emphasis.
3 | High emphasis.
4 | Smooth emphasis.

0x16F2 (5874)

TAG_ENDORSER_COUNTER_INDEX

Integer

Specifies which endorser or imprinter counter to increment. For imprinters that support multiple counters, this tag is the 0-based index for accessing the counter tags for each counter. This tag only controls multiple counters within the same imprinter. Counters on different imprinters are indexed by TAG_ENDORSER_INDEX.

The currently-selected imprinter should be enabled before setting this tag. The imprinter should be configured to print the incrementing counter by using the proper token in TAG_ENDORSER_STRING.

As an index tag, this tag can change the current value for any other counter-specific tag, including TAG_ENDORSER_COUNTERDIGITS, TAG_ENDORSER_INCSTART, and TAG_ENDORSER_INCSTEP.

0x152C (5420)

TAG_ENDORSER_COUNTERDIGITS

Integer

The number of digits of the incrementing counter to print. The high-order digits are truncated if necessary.

If the counter has fewer digits than specified, then the behavior depends on the selected counter format. For example, some formats will pad with 0’s or spaces.

The currently-selected imprinter should be enabled before setting this tag. The imprinter should be configured to print the incrementing counter by using the proper token in TAG_ENDORSER_STRING.

This tag is indexed from TAG_ENDORSER_COUNTER_INDEX.

0x16FB (5883)

TAG_ENDORSER_DATE_SEPARATOR

String

The separator to be used when printing the special date codes. Some scanners support changing the separator value, while others do not.

The currently-selected imprinter should be enabled before setting this tag. Enable one of the special date codes in TAG_ENDORSER_STRING.

0x1068 (4200)

TAG_ENDORSER_FONT

String

The text font used by the imprinter.

The possible values of this tag vary based on the scanner. It might use formal font names or user-friendly names.

The currently-selected imprinter should be enabled before setting this tag.

0x0584 (1412)

TAG_ENDORSER_INCSTART

Integer

The starting value for the imprinter incrementing counter.

This tag is automatically updated at the end of the batch with the next number to be printed.

The currently-selected imprinter should be enabled before setting this tag. The imprinter should be configured to print the incrementing counter by using the proper token in TAG_ENDORSER_STRING.

This tag is indexed from TAG_ENDORSER_COUNTER_INDEX.

0x1066 (4198)

TAG_ENDORSER_INCSTEP

Integer

The increment value for the imprinter incrementing counter. For each page the counter will be increased by this value.

The currently-selected imprinter should be enabled before setting this tag. The imprinter should be configured to print the incrementing counter by using the proper token in TAG_ENDORSER_STRING.

This tag is indexed from TAG_ENDORSER_COUNTER_INDEX.

0x16F1 (5873)

TAG_ENDORSER_INDEX

Integer

The 0-based index value of the imprinter to configure. The values of the other imprinter tags depend on which imprinter is selected.

Imprinters are not indexed in any particular order, so your application should look at the values of other tags to determine which imprinter is selected.

0x1067 (4199)

TAG_ENDORSER_ORIENTATION

Integer

The orientation of the printed text relative to the leading edge of the page.

For the list of possible values, refer to ImGearIsisOrientation.

The currently-selected imprinter should be enabled before setting this tag.

0x106C (4204)

TAG_ENDORSER_PRINTTYPE

Integer

Enables or disables the currently selected imprinter.

Possible values for: TAG_EMPHASIS

Value | Description
0 | Disable the imprinter.
1 | Enable the imprinter.

0x0477 (1143)

TAG_ENDORSER_SIDE

Integer

Specifies which side of a duplex page on which to print the endorser string.

For the list of possible values, refer to ImGearIsisPageSide.

0x0583 (1411)

TAG_ENDORSER_STRING

String

The imprinter string.

Special token codes can be used to describe dynamic data such as the date, the time, or an incrementing counter.

Note: The symbol # is treated as an incrementing counter for backward compatibility, but you should use the primary counter token codes instead.

Imprinter String Token Codes:

Token Code | Description | Examples
%C2% | Counter - without leading zeroes: (#) | 12345 222
%C3% | Counter - with leading zeroes: (000#) | 0012345 00222
%C4% | Counter - with blanks: ( #) | 12345 222
%D2% | Date - Numerical with separator: (MM-DD-YY) | 01-05-95 10-30-92
%D3% | Date - Long text: (Month DD, YYYY) | January 05, 1995 October 30, 1992
%D4% | Date - Abbreviated with separator: (DD-Mon-YY) | 05-Jan-95 30-Oct-92
%D5% | Date - Numerical with separator: (YYYY-MM-DD) | 1995-01-05 1992-10-30
%D6% | Date - Abbreviated with separator: (YYYY-Mon-DD) | 1995-Jan-05 1992-Oct-30
%D7% | Date - Abbreviated without separator: (DD Mon YYYY) | 05 Jan 199530 Oct 1992
%D8% | Date - Numerical with separator: (MM-DD-YYYY) | 01-05-1995 10-30-1992
%D9% | Date - Numerical with separator: (M-D-YY) One-digit month/day if possible. | 1-5-95 10-30-92
%T2% | Time - (H:MM:SS) One-digit hour, if possible. | 1:08:32 12:12:12
%T3% | Time - (H:MM) One-digit hour, if possible. | 1:08 12:12
%T4% | Time - (H:MM:SS PM) One-digit hour, if possible. AM/PM indicator. | 1:08:32 AM 12:12:12 PM
%T5% | Time - (H:MM PM) One-digit hour, if possible. AM/PM indicator. | 1:08 AM 12:12 PM
%T6% | Time - with 24 hours (H:MM:SS) One-digit hour, if possible. 24-hour format. | 1:08:32 12:12:12
%T7% | Time - with 24 hours (H:MM) One-digit hour, if possible. 24-hour format. | 1:08 12:12
%T8% | Time - with leading zeroes (HH:MM:SS) | 01:08:32 12:12:12
%T9% | Time - with leading zeroes (HH:MM) | 01:08 12:12
%T10% | Time - with leading zeroes (HH:MM:SS PM) AM/PM indicator. | 01:08:32 AM 12:12:12 PM
%T11% | Time - with leading zeroes (HH:MM PM) AM/PM indicator. | 01:08 AM 12:12 PM
%T12% | Time - with 24 hours with leading zeroes (HH:MM:SS) 24-hour format. | 01:08:32 12:12:12 23:30:00
%T13% | Time - with 24 hours with leading zeroes (HH:MM) 24-hour format. | 01:08 12:12 23:30

The values acceptable to an endorser are specific to the scanner. Various scanners support different characters and string lengths, and might support other tags that control endorsement position, orientation, size, and so forth.

For legacy support, setting this tag to an empty string turns off the imprinter, and setting this tag to a non-empty string turns on the imprinter. However, you should not rely on this behavior. Always enable or disable the imprinter with TAG_ENDORSER_PRINTTYPE.

0x16F3 (5875)

TAG_ENDORSER_STRING_EXAMPLE

String

The actual imprinter string that would be printed on the page using the current date, time, and counter value.

0x16FA (5882)

TAG_ENDORSER_TIME_SEPARATOR

String

The separator to be used when printing the special time codes. Some scanners support changing the separator value, while others do not.

0x16F4 (5876)

TAG_ENDORSER_TOKEN_FULL

String

The list of all available imprinter string characters and token codes as a single string. This tag requires some minor parsing, so you might want to use TAG_ENDORSER_TOKEN_NEXT_CODE instead.

The format of a token is the token code, followed by the symbol |, followed by a description. An example is:

%C2%|Counter - without leading zeroes: (#)

Note: Different drivers might use different descriptions for the same token code.

The currently-selected imprinter should be enabled before setting this tag.

0x16F9 (5881)

TAG_ENDORSER_TOKEN_MASK

Integer

Applies a mask to the imprinter string.

The value is a bitmask, with each bit specifying a different component to mask. The default value is 0x00000001.

Bit values for: TAG_ENDORSER_TOKEN_MASK

Value | Description
0x0 | No mask.
0x1 | Remove regular characters.
0x2 | Remove time codes.
0x4 | Remove date codes.
0x8 | Remove counter codes.

The currently-selected imprinter should be enabled before setting this tag.

0x16F6 (5878)

TAG_ENDORSER_TOKEN_NEXT_CODE

String

The next available token code in the scanner’s list.

Setting this tag modifies the other next token tags to match the selected token.

The currently-selected imprinter should be enabled before setting this tag.

0x16F5 (5877)

TAG_ENDORSER_TOKEN_NEXT_DESC

String

The next available token code description in the scanner’s list.

Setting this tag modifies the other next token tags to match the selected token.

The currently-selected imprinter should be enabled before setting this tag.

0x16F7 (5879)

TAG_ENDORSER_TOKEN_NEXT_EXAMPLE

String

The example string for the next available token code.

Setting this tag modifies the other next token tags to match the selected token.

The currently-selected imprinter should be enabled before setting this tag.

0x16F8 (5880)

TAG_ENDORSER_TOKEN_NEXT_FULL

String

The next full token in the scanner’s list, including the token code and the description.

Setting this tag modifies the other next token tags to match the selected token.

The currently-selected imprinter should be enabled before setting this tag.

0x0476 (1142)

TAG_ENDORSER_TYPE

Integer

Specifies if the imprinter string is printed before or after an image is scanned.

Bit values for: TAG_ENDORSER_TOKEN_MASK

Value | Description
0 | The imprinter prints before the page is scanned. In this case, the scanned image will include the imprinter printing on the image.
1 | The imprinter prints after the page is scanned. The scanned image will not include the imprinter printing on the image.

0x16F0 (5872)

TAG_ENDORSER_VERSION

Integer

The version number of the imprinter.

0x0585 (1413)

TAG_ENDORSER_YOFFSET

Integer

The distance (in mm) to the printed imprinter string from a scanner-defined location (often the edge of the page).

The choices for this tag are limited by where the scanner allows the imprinter string to be placed.

0x0503 (1283)

TAG_FEEDER

Integer

The feeder capabilities of the scanner.

The value is a bitmask, with each bit specifying a different component to mask.

Bit values for: TAG_FEEDER

Value | Description
0x00000001 | The scanner has a sheet feeder.
0x00000002 | The scanner has flatbed scanning surface.
0x00020000 | The scanner can detect whether or not a page is on the flatbed scanning surface.
0x00010000 | The scanner can detect whether or not a page is in the sheet feeder.
0x00040000 | The scanner can detect whether a page is loaded in the feeder only by committing a page. Whenever a page is committed, it should also be scanned.
0x00080000 | The scanner can center a page in the feeder.
0x00100000 | The scanner can detect whether or not a page is centered on the flatbed.
0x00200000 | The scanner can safely stop a ScanAhead batch in the middle and recover all of the pages left in the buffer.

0x0907 (2311)

TAG_FILETYPE

Integer

The file type to store.

For the list of possible values, refer to ImGearIsisFileType.

0x1331 (4901)

TAG_FILETYPE_LBS

String

Enables you to retrieve the valid file type choices for a list box control.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x010A (266)

TAG_FILLORDER

Integer

The order in which bits are stored in a byte.

This tag applies only to binary images. The default value is 1.

The value is a bitmask, with each bit specifying a different component to mask.

Possible values for: TAG_FILLORDER

Value | Description
1 | Pixels are arranged within a byte such that pixels with lower column values are stored in the higher-order bits of the byte. The first bit of the first byte corresponds to the first pixel in an uncompressed image.
2 | Pixels are arranged within a byte such that pixels with lower column values are stored in the lower order bits of the byte. The last bit of the first byte corresponds to the first pixel in an uncompressed image.

0x050F (1295)

TAG_GAMMA

Integer

The scanner’s gamma correction setting.

Possible values for: TAG_GAMMA

Value | Description
0x00 | Automatic.
0x80 | The 1st downloaded correction table.
0x81 | The 2nd downloaded correction table.
0x82 | The 3rd downloaded correction table.
0x83 | The 4th downloaded correction table.
0x84 | The 5th downloaded correction table.
0x85 | The 6th downloaded correction table.
Custom value | Specific scanners might support other values.

0x0558 (1368)

TAG_GAMMA_LENGTH1

Integer

The length of TAG_GAMMA_TABLE1.

0x0559 (1369)

TAG_GAMMA_LENGTH2

Integer

The length of TAG_GAMMA_TABLE2.

0x055A (1370)

TAG_GAMMA_LENGTH3

Integer

The length of TAG_GAMMA_TABLE3.

0x055B (1371)

TAG_GAMMA_LENGTH4

Integer

The length of TAG_GAMMA_TABLE4.

0x055C (1372)

TAG_GAMMA_LENGTH5

Integer

The length of TAG_GAMMA_TABLE5.

0x055D (1373)

TAG_GAMMA_LENGTH6

Integer

The length of TAG_GAMMA_TABLE6.

0x0568 (1384)

TAG_GAMMA_TABLE1

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x0569 (1385)

TAG_GAMMA_TABLE2

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x056A (1386)

TAG_GAMMA_TABLE3

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x056B (1387)

TAG_GAMMA_TABLE4

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x056C (1388)

TAG_GAMMA_TABLE5

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x056D (1389)

TAG_GAMMA_TABLE6

Integer

A downloadable gamma table defined on the scanner.

To create a gamma table, establish the table length, then fill in the values for each element. For more information, consult the documentation supplied with scanners that support downloadable gamma tables.

0x090B (2315)

TAG_GIFVERSION

Integer

The version number of the GIF file format being used.

Possible values for: TAG_GIFVERSION

Value | Description
0x870A | 8.7A
0x890A | 8.9A

0x0124 (292)

TAG_GROUP3OPTIONS

Integer

Options for ITU Group 3 compression.

Note: This is now known as T4Options in the TIFF specification.

The value is a bitmask, so multiple values can be specified with the different bits. All unused bits must be set to 0. The default value is 0x0.

Bit values for: TAG_GROUP3OPTIONS

Value | Description
0x0 | 1-dimensional coding.
0x1 | 2-dimensional coding. If more than one strip is specified, each strip must begin with a 1D coded line. That is, RowsPerStrip should be a multiple of TAG_KFACTOR.
0x2 | Uncompressed.
0x4 | Standard Group 3 coding. Each line has been padded with fill bits to a byte boundary, ensuring an EOL sequence of one byte preceded by a zero nibble: xxxx-0000 0000-0001.

0x0698 (1688)

TAG_HAVELENGTH

Integer

Specifies whether the end of an autopipe delivers the length of the image, required by file writing drivers.

Possible values for: TAG_HAVELENGTH

Value | Description
0 | The autopipe does not deliver the image length.
1 | The autopipe delivers the image length.

0x1725 (5925)

TAG_IMAGEDELETED

Integer

Indicates that a blank page was deleted.

The image was deleted if the tag is defined. The only possible value for the tag is 1.

0x0101 (257)

TAG_IMAGELENGTH

Integer

The height of an image, in pixels.

In some applications, you can set this tag to crop or overscan the image.

Note: The value of this tag will be affected by setting the value of either TAG_DATAORIENTATION or TAG_SCANORIENTATION.

0x0100 (256)

TAG_IMAGEWIDTH

Integer

The width of an image, in pixels.

In some applications, you can set this tag to crop or overscan the image.

Note: The value of this tag will be affected by setting the value of either TAG_DATAORIENTATION or TAG_SCANORIENTATION.

0x16E1 (5857)

TAG_INPUTAUTHOR

String

The author of a document.

0x16E3 (5859)

TAG_INPUTCREATOR

String

The creator of a document.

0x16E4 (5860)

TAG_INPUTKEYWORDS

String

The keywords defined in a document.

0x1008 (4104)

TAG_INPUTNAME

String

The name of the file from which an image is read.

0x16E5 (5861)

TAG_INPUTPRODUCER

String

The producer of a document.

0x16E2 (5858)

TAG_INPUTSUBJECT

String

The subject of a document.

0x16E0 (5856)

TAG_INPUTTITLE

String

The title of a document.

0x1311 (4881)

TAG_INSERTMODE

Integer

Specifies how data is inserted into a file.

Possible values for: TAG_INSERTMODE

Value

Description

0

Create a new file. Overwrite if a file with the specified filename exists.

1

Append the page to the end of a multipage file. This value should be used only with files that support multiple pages.

2

Insert the page at the position specified by TAG_PAGENUMBER; increment each of the subsequent page numbers by 1.

Use with TIFF files only. The new page is physically added to the end of the file, but the pointers in the file are changed to reflect the correct order.

3

Overwrite the page at the position specified by TAG_PAGENUMBER. Use with TIFF files only. The new page is physically added to the end of the file. The overwritten page is not physically removed from the file. Pointers in the file are changed to bypass the overwritten page and substitute the new page.

0x05E3 (1507)

TAG_INVERT

Integer

Specifies whether an image is color inverted.

Possible values for: TAG_INVERT

Value | Description
0 | Colors are normal (not inverted).
1 | Colors are inverted.

0x87BE (34750)

TAG_JBIGOPTIONS

Integer

Options for JBIG image data.

This valule consists of 20 bytes that comprise the JBIG header, and have the following values:

Byte values for: TAG_JBIGOPTIONS

Bytes | Value | Meaning
0 | 0 | Reserved. (Used for progressive JBIG only.)
1 | 0 | Reserved. (Used for progressive JBIG only.)
2 | 1 | Number of planes.
3 | 0 | Always 0.
4–7 | Pixels | (Motorola format.)
8–11 | Linies | (Motorola format.)
12–15 | LinesPerStrip | (Motorola format.)
16 | Typically 8 | Maximum Adaptive Template pixel horizontal movement.
17 | Typically 0 | Maximum Adaptive Template pixel vertical movement.
18 | 0 | Progressive mode ordering. (Not used.)
19 | Bit 7 = 0 | Always 0.
19 | Bit 6 | 1 = Two-line template; 0 = Three-line template.
19 | Bit 5 = 0 | (Used in progressive JBIG.)
19 | Bit 4 = 0 | (Used in progressive JBIG.)
19 | Bit 3 | 1 = Typical prediction on; 0 = Typical prediction off.
19 | Bit 2 = 0 | (Used in progressive JBIG.)
19 | Bit 1 = 0 | (Used in progressive JBIG.)
19 | Bit 0 = 0 | (Used in progressive JBIG.)

0x05A8 (1448)

TAG_JOBSEPDETECTED

Integer

Indicates that a job separator page was detected.

Values for: TAG_JOBSEPDETECTED

Value | Description
0 | No job separator sheet detected.
Any non-0 value | Job separator sheet detected.

0x138F (5007)

TAG_JP2_LOSSLESS

Integer

Specifies whether the compression is lossless.

Values for: TAG_JP2_LOSSLESS

Value | Description
0 | Lossy compression is allowed. Image data might be discarded during compression.
Any non-0 value | Only lossless compression is used.

0x138D (5005)

TAG_JP2_MAXRATE

Rational

The maximum number of quality layers in a JPEG 2000 compressed image.

0x138C (5004)

TAG_JP2_MINRATE

Rational

The minimum number of quality layers in a JPEG 2000 compressed image.

0x138E (5006)

TAG_JP2_NUMRATES

Integer

The number of quality layers to spread between TAG_JP2_MINRATE and TAG_JP2_MAXRATE.

Values for: TAG_JP2_NUMRATES

Value | Description
0 | Disabled.
An integer between 2 and 16384, inclusive | The number of quality layers used to compress the image. This applies only for lossy compression.

0x137F (4991)

TAG_JP2_PROGRESSION_ORDER

Integer

The progression order to use when saving JPEG 2000 compressed files.

The default value is 0.

Values for: TAG_JP2_PROGRESSION_ORDER

Value | Description
0 | Layer-Resolution-Component-Position progressive.
1 | Resolution-Layer-Component-Position progressive.
2 | Resolution-Position-Component-Layer progressive.
3 | Position-Component-Resolution-Layer progressive.
4 | Component-Position-Resolution-Layer progressive.

0x138B (5003)

TAG_JP2_RATE

Rational

The compression ratio to use when saving JPEG 2000 compressed files, expressed as a ratio between the total number of compressed bits (including headers) and the product of the longest horizontal and vertical image component dimensions. The compression factor affects the degree of compression and the image quality of the saved file.

The default value is 1/1.

For lossless compression, the final quality layer includes all pixels in the original image (compressed).

This value is ignored if TAG_JP2_USEDEFAULTRATE is set to 1.

0x1289 (5001)

TAG_JP2_USEDEFAULTRATE

Integer

Specifies whether a default compression ratio is used.

The default value is 1.

Values for: TAG_JP2_USEDEFAULTRATE

Value | Description
0 | Use the values specified in TAG_JP2_MINRATE, TAG_JP2_MAXRATE, and TAG_JP2_NUMRATES to determine the compression.
1 | Use the default compression rate of 0.75.

0x1380 (4992)

TAG_JPEGCOMPRESSIONFACTOR

Integer

The compression factor to use when saving JPEG compressed files. The compression factor affects the degree of compression and the image quality of the saved file.

The possible values are integers from -10 to 10, inclusive. Lower numbers provide less compression with better image quality, while higher numbers provide greater compression at the expense of image quality.

0x050C (1292)

TAG_KFACTOR

Integer

The “Parameter K” value as defined in the ITU Specification for Group 3 two-dimensional compression. It is generated in compressed images from ISIS drivers that support Group 3 2D compression.

0x1317 (4887)

TAG_KNOWNFMTSFLAG

Integer

Specifies whether the “Known Formats” entry in a common file open window is enabled.

Values for: TAG_KNOWNFMTSFLAG

Value | Description
0 | The known formats entry is disabled.
1 | The known formats entry is enabled.

0x13DE (5086)

TAG_LASTPAGE_ENDORSER

String

The actual imprinter text that was printed on the page.

0x06FF (1791)

TAG_LASTPAGE_SIDE

Integer

The side of a sheet of paper that was scanned.

For the list of possible values, refer to ImGearIsisPageSide.

0x0912 (2322)

TAG_MAXDCXIFDSIZE

Integer

The maximum number of bytes allocated to the DCX offsets list.

0x0504 (1284)

TAG_MAXPAGES

Integer

The maximum number of pages that can be loaded at one time in the scanner’s automatic document feeder.

0x0505 (1285)

TAG_MAXTIME

Integer

The maximum amount of time required for scanner to scan a page, expressed in tenths of a second.

0x0511 (1297)

TAG_MIXEDSCAN

Integer

Specifies if mixed text and image scanning is enabled.

Values for: TAG_MIXEDSCAN

Value | Description
0 | Mixed scanning is disabled.
1 | Mixed scanning is enabled.

0x0512 (1298)

TAG_MORE_SETTINGS

Integer

Indicates if the scanner driver has extended settings available in a secondary configuration window.

Values for: TAG_MORE_SETTINGS

Value | Description
0 | Extended settings are not available.
1 | Extended settings are available.

0x1323 (4893)

TAG_NUMALLOWEDFORMATS

Integer

The number of allowed file formats.

Use this tag with TAG_ALLOWEDFORMATS to design an application that handles a particular subset of the available file formats.

0x090A (2314)

TAG_OPENATTRIBUTE

Integer

File open modes.

The value is a bitmask, so multiple values can be specified with the different bits.

Bit Values for: TAG_OPENATTRIBUTE

Value | File Open/Create Behavior | File Create Attributes | Access Mode | Sharing Mode
0x00000000 | Open the file if it exists; otherwise fail. | No attributes set. | For reading. | Allow the file to be accessed by other applications while it is open.
0x00000001 | — | Read-only. | For writing. | —
0x00000002 | — | Hidden. | For reading and writing. | —
0x00000004 | — | System. | — | —
0X00000010 |  |  |  | Deny read/write access to other applications. This works only if the file is not already open in a different mode.
0x00000020 |  |  |  | Deny write access to other applications. This works only if the file is not already open in a different mode.
0x00010000 | Create a new file. Overwrite if a file with the specified filename exists. This tag overrides TAG_APPEND. | — | — | —
0x00020000 | Overwrite the file if it exists; otherwise fail. | — | — | —
0x0003000 | Do not open the file if it exists; otherwise create the file. (Logical OR of 0x00010000 and 0x00020000. | — | — | —
0x00008000 | Create the file only if it does not exist; otherwise fail. | — | — | —
0x00000030 |  |  |  | Deny read access to other applications. This works only if the file is not already open in a different mode.
0x00000040 |  |  |  | Do not deny access. This is the same as allowing access (0x00000000), but it prevents other processes from opening the file for sharing. This works only if the file is not already open in a different mode.

0x0112 (274)

TAG_ORIENTATION

Integer

The orientation of the image.

For the list of possible values, refer to ImGearIsisOrientation.

0x05A6 (1446)

TAG_OUTLINE

Integer

Specifies if outline scanning is enabled.

Values for: TAG_OUTLINE

Value | Description
0 | Outline scanning is disabled.
1 | Outline scanning is enabled.

0x1337 (4907)

TAG_OUTPUT_TAGS

Integer

A pointer to a structure that contains all of the settings specified by the user.

0x16E7 (5863)

TAG_OUTPUTAUTHOR

String

The author of the output document.

0X16E9 (5865)

TAG_OUTPUTCREATOR

String

The creator of the output document.

0x16EA (5866)

TAG_OUTPUTKEYWORDS

String

The keywords for the output document.

0x0680 (1664)

TAG_OUTPUTNAME

String

The name of the file to write.

0x16E8 (5864)

TAG_OUTPUTSUBJECT

String

The subject of the output document.

0x16E6 (5862)

TAG_OUTPUTTITLE

String

The title of the output document.

0x0696 (1686)

TAG_PAD16

Integer

Specifies whether an image is padded to a 16-bit word boundary when required for the file type.

Values for: TAG_PAD16

Value | Description
0 | The image is not padded.
1 | The image is padded.

0x1007 (4103)

TAG_PAGENUMBER

Integer

The page number in the file at which to insert or overwrite pages when writing to the file.

0x050E (1294)

TAG_PAGESIZE

String

The page size, as a descriptive string. The available choices depend on the scanner.

This tag affects the values of several other tags and so should be set before all of these other tags:

  • TAG_IMAGELENGTH

  • TAG_IMAGEWIDTH

  • TAG_XPOSITION

  • TAG_XRESOLUTION

  • TAG_YPOSITION

  • TAG_YRESOLUTION

0x1336 (4906)

TAG_PHOTO_LBS

String

Enables you to retrieve the valid choices for the photometric interpretation for a list box control. It should be used in conjunction with TAG_BPS_LBS and TAG_SPP_LBS to give the user total control over color format. If separate control is not desired, you should use TAG_COLORFMTS_LBS instead.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x0106 (262)

TAG_PHOTOMETRICINTERPRETATION

Integer

The photometric interpretation to use in the image.

For the list of possible values, refer to ImGearIsisPhotometric.

Note: Because some drivers have restrictions on how pages can be fed or rotated, setting this tag could affect the values of TAG_DATAORIENTATION and TAG_SCANORIENTATION.

0x1300 (4864)

TAG_PIXFPACK_CALLBACK

Integer

Used to create custom tags to be written into the image file.

0x1301 (4865)

TAG_PIXFPACK_CALLBACK_DATA

Integer

Contains the value to which to set the custom tag created by using TAG_PIXFPACK_CALLBACK.

0x1302 (4866)

TAG_PIXFPACK_IOFNS

Integer

A pointer to a structure containing replacement I/O functions for writing data.

0x1303 (4867)

TAG_PIXIF_IOFNS

Integer

A pointer to a structure containing replacement I/O functions for reading data.

0x057E (1406)

TAG_PIXMPAGE

Integer

A pointer to the next page to use.

0x011C (284)

TAG_PLANARCONFIGURATION

Integer

Describes how data in a color RGB image is arranged.

Values for: TAG_PLANARCONFIGURATION

Value | Description
1 | Line pack. Color data for each pixel is stored in order by line: RGBRGBRGBRGBRGBRGB... RGB Each RGB set represents one pixel of a line. Each line is padded to an even byte boundary. This is probably the easiest format to handle because the data for each pixel is in one place. Supported in TIFF.
2 | Page. Color data for the entire page is stored by color plane: RRRRRRRRRRRRRRRRRR... RRR RRRRRRRRRRRRRRRRRR... RRR RRRRRRRRRRRRRRRRRR... RRR . GGGGGGGGGGGGGGGGGG... GGG GGGGGGGGGGGGGGGGGG... GGG GGGGGGGGGGGGGGGGGG... GGG . BBBBBBBBBBBBBBBBBB... BBB BBBBBBBBBBBBBBBBBB... BBB BBBBBBBBBBBBBBBBBB... BBB Each RRR... represents red for the entire page. Each line is padded to an even byte boundary. This is common for 3-pass scanners. Supported in TIFF.
5000 | Line Unpack. Color data for each line is stored by color plane: RRRRRRRRRRRRRRRRRR... RRR GGGGGGGGGGGGGGGGGG... GGG BBBBBBBBBBBBBBBBBB... BBB RRRRRRRRRRRRRRRRRR... RRR GGGGGGGGGGGGGGGGGG... GGG Each RRR... set represents red for an entire line. Each line is padded to an even byte boundary. Many color scanners return data in this format.

0x050B (1291)

TAG_PLATENLENGTH

Integer

The maximum number of pixels that can be scanned from the scanner’s platen (flatbed) at the current resolution.

0x0516 (1302)

TAG_RESPONSECURVE

Integer

A mapping of image values.

Values for: TAG_RESPONSECURVE

Value | Description
0 | Image is scanned with contrast and brightness.
1 | A mapping of 8-bit input values to 8-bit output values is used, as defined in TAG_TRCMAP8.

0x0128 (296)

TAG_RESUNIT

Integer

The unit of measurement for image resolution.

The default value is 2.

Values for: TAG_RESUNIT

Value

Description

1

No absolute unit of measurement. Used for images that may have a non-square aspect ratio, but no meaningful absolute dimensions.

The drawback to this value is that different applications will import the image at different sizes. Even if the decision is arbitrary, it might be a good idea to use a specific measurement, and to pick horizontal and vertical resolution values so that the aspect ratio is correct and the maximum size of the image is not too large.

2

Dots per inch (dpi).

3

Dots per centimeter.

0x0116 (278)

TAG_ROWSPERSTRIP

Integer

The number of rows per strip in an image.

The default value is the maximum of 2^(32-1). That is, the entire image is one strip.

0x0695 (1685)

TAG_RUNSAFE

Integer

Specifies if ITU Group 4 compressed images are converted to raster images before converting them back into Group 3 compressed images. This is necessary because the intermediate run list used by Group 4 is not compatible with the run list required by Group 3.

Values for: TAG_RUNSAFE

Value | Description
0 | Does not automatically convert Group 4 images to raster images.
1 | Automatically converts Group 4 images to raster images.

0x0115 (277)

TAG_SAMPLESPERPIXEL

Integer

The number of samples per pixel to use in stored images.

The default value is 1.

Note: Because some drivers have restrictions on how pages can be fed or rotated, setting this tag could affect the values of TAG_DATAORIENTATION and TAG_SCANORIENTATION.

0x050D (1293)

TAG_SCANAHEAD

Integer

Specifies if the ScanAhead feature of the scanner is enabled.

Values for: TAG_SCANAHEAD

Value | Description
0 | ScanAhead is disabled. Some high-speed scanners allow buffered pages to be retrieved if you stop the batch by turning off ScanAhead.
1 | ScanAhead is enabled.

0x057C (1404)

TAG_SCANAHEAD_MAXPAGES

Integer

The maximum number of pages to scan ahead.

A value of 0 means to scan until the feeder is empty. Some scanners only support a value of 0 because there is no way to tell the scanner how many pages to scan.

0x0515 (1301)

TAG_SCANAHEAD_PAGES

Integer

The number of pages that have been scanned ahead.

You can use this information to determine if all of the scanned pages have been successfully read (to be sure, for example, that no misfeed or paper jam occurred).

0x050A (1290)

TAG_SCANNERID

String

The unique scanner ID.

0x0113 (275)

TAG_SCANORIENTATION

Integer

The orientation of a page in the scanner’s feeder.

For the list of possible values, refer to ImGearIsisOrientation.

Note:

TAG_DATAORIENTATION must be set first. Setting either of these tags will affect the values of TAG_IMAGELENGTH, TAG_IMAGEWIDTH, TAG_XPOSITION, and TAG_YPOSITION. Also, because some drivers have restrictions on how pages can be fed or rotated, setting any of the following tags could affect the values of TAG_DATAORIENTATION and TAG_SCANORIENTATION:

  • TAG_BITSPERSAMPLE

  • TAG_PAGESIZE

  • TAG_SAMPLESPERPIXEL

  • TAG_SCANTYPE

  • TAG_XRESOLUTION

  • TAG_YRESOLUTION

0x0514 (1300)

TAG_SCANTYPE

Integer

The scanning source.

Values for: TAG_SCANAHEAD

Value | Description
0 | Scan from the automatic document feeder (ADF) if pages are detected; otherwise, scan from the flatbed.
1 | Scan from the transparency unit.
2 | Scan from the flatbed.
3 | Scan only the front side of the page (duplex scanner).
4 | Scan in duplex mode (duplex scanner), from the feeder.
5 | Scan in duplex mode, but return the back side of the page first (duplex scanner), from the feeder.
6 | Scan only the back side of the page (duplex scanner), from the feeder.

0x1335 (4905)

TAG_SPP_LBS

String

Enables you to retrieve the valid choices for the number of samples per pixel for a list box control. It should be used in conjunction with TAG_BPS_LBS and TAG_PHOTO_LBS to give the user total control over color format. If separate control is not desired, you should use TAG_COLORFMTS_LBS instead.

The value of this tag has no specific meaning. You simply get the value in order to retrieve the list of available choices.

0x0117 (279)

TAG_STRIPBYTECOUNTS

Integer

The number of bytes in a particular strip of a stripped image after compression (if any). This is a read-only tag.

The value is an array of integers, each representing the number of bytes in a particular strip. An image with PlanarConfiguration = 1 has one value for each strip. An image with PlanarConfiguration <> 1 has (SamplesPerPixel * StripsPerImage) values.

0x0111 (273)

TAG_STRIPOFFSETS

Integer

The byte offset of each strip of a stripped image.

The value is array of integers, each representing the byte offset from the beginning of the file. Note that this implies that each strip has a location independent of the location of other strips. An image with PlanarConfiguration = 1 has one value for each strip. An image with PlanarConfiguration <> 1 has (SamplesPerPixel * StripsPerImage) values.

This TIFF-required field is the only way for a reader to find the image data (unless the TIFF-specific tag TAG_TILEOFFSETS is used).

0x0517 (1303)

TAG_TRCMAP8

Integer

A mapping of 8-bit input levels to 8-bit output levels.

0x0700 (1792)

TAG_USERn

(where n is a number between 0 and 99, inclusive)

Driver-Defined

Custom tags specific to the driver.

0x011E (286)

TAG_XPOSITION

Rational

The distance in pixels from the left edge of the page to the start of the image.

Note: The value of this tag will be affected by setting the value of either TAG_DATAORIENTATION or TAG_SCANORIENTATION.

0x011A (282)

TAG_XRESOLUTION

Rational

The number of pixels in each unit specified by TAG_RESUNIT when measured horizontally.

0x0513 (1299)

TAG_YIELDPROC

Integer

A pointer to a procedure to be called during printing.

0x011F (287)

TAG_YPOSITION

Rational

The distance in pixels from the top edge of the page to the start of the image.

Note: The value of this tag will be affected by setting the value of either TAG_DATAORIENTATION or TAG_SCANORIENTATION.

0x011B (283)

TAG_YRESOLUTION

Rational

The number of pixels in each unit specified by TAG_RESUNIT when measured vertically.


Scan Job
User Guide > How to Work with... > Scanning > Using ImageGear.Web.Isis Namespace > Scan Job

The ImGearIsisScannerSession scan method can be used to begin scanning, and you can specify the type of data (None, Base64Page, or Base64Document) that is available in the callback arguments using the scanDataType enum parameter. The enum values are 0, 4, and 8, and multiple data types can be specified. You can also specify a page retrieved callback (which is fired after each page is scanned) and a document retrieved callback (which is fired after all pages are scanned). If you do not specify a data type, then the corresponding property in the callback’s page/document arguments (ImGearIsisPageRetrievedResult/ImGearIsisDocumentRetrievedResult) will be null. The ImGearIsisPageRetrievedResult imageInfo and metadata properties provide information about the scanned image. The page/document retrieved callback also has an ImGearIsisStatus argument which can be used to check the status of the operation.

The code below demonstrates calling the scan method to scan all pages in the feeder as G4 compressed TIFF to retrieve a base 64 data string for each scanned page in the page scanned callback and to retrieve a base 64 data string containing all scanned pages in the scanned document.

JavaScript Example
Copy Code
           function pageRetrievedCallback(result, status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                    alert(status.get_statusMessage());
               }
               // Get the base 64 data string for the page. The ASP .NET ISIS sample demonstrates how to upload this string and display the image in a PageView control.
               var base64page = result.get_base64Page();

               // Get the image info for the page. This object contains properties for getting the color format, compression, file type, width, height, and resolution.
               var imageInfo = result.get_imageInfo();
…
               // You can also get the image metadata and the scanned page number.
           }
           function documentRetrievedCallback(result, status) {
               if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
                   alert(status.get_statusMessage());
               }
               // Get the base 64 data string for the scanned document.
               var base64document = result.get_base64Document();
…
           }
           var scanJob = scannerSession.scan({pages: 0, scanDataType: ImageGear.Web.Isis.ImGearIsisScanDataType.Base64Page | ImageGear.Web.Isis.ImGearIsisScanDataType.Base64Document, fileType: ImageGear.Web.Isis.ImGearIsisFileType.Tif, compression: ImageGear.Web.Isis.ImGearIsisImageCompression.G4, pageRetrievedCallback: pageRetrievedCallback, documentRetrievedCallback: documentRetrievedCallback});

The ImGearIsisScanJob cancel method can be used to cancel scanning. The destroy method can be used to destroy the scan job, which deletes all scanned images that were stored internally by the service.


Image Data Providers
User Guide > How to Work with... > Image Data Providers

The Image Data Provider is an extensible and decoupled module used by the PageView and the ThumbnailView components for the delivery of image and annotations data for viewing. It also handles updating/saving annotations data. The architecture is based on the ASP.NET Provider model.

The PageView and ThumbnailView components use two built-in providers in the ImageGear22.Web assembly:

  • SqlImageDataProvider
  • FileImageDataProvider

The image data provider model is based on a well known design pattern called the "Strategy" pattern. The most notable part of the strategy pattern is that it provides a way for an object or a subsystem to expose its internals so that users/clients can unplug the default implementation of a given feature/functionality and plug their own in. Since the ImageGear Image Data Provider is based on this provider model, it allows customers the ability to unplug the built-in default Image Data Providers, namely the "FileImageDataProvider" and the "SqlImageDataProvider" and plug in their own custom Image Data Provider derived from the ImageGear.Web.DataProviders.ImageDataProvider Class.

The diagram below shows the high-level object design of the ImageProvider module. It illustrates the object model for the built-in providers. The built-in providers are derived from the ImageDataProvider class (light orange color boxes). Custom providers (bottom box in light green) can also be built, derived from this ImageDataProvider class.

This section provides information about the following:

  • Image Data Providers
    • Configuring ImageDataProviders in Web.Config
    • File Image Data Providers
    • SQL Image Data Providers
      • Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies
    • Implementing Annotations in an Image Data Provider
      • Annotation Using Built-In Providers
      • Enabling Annotation within a Custom Image Data Provider
        • Background Information on Transactions
          • Using a Transactional Resource
          • Using a Non-Transactional Resource
        • Helper Abstract Classes in ImageGear22.Web.Services Assembly


Configuring ImageDataProviders in Web.Config
User Guide > How to Work with... > Image Data Providers > Configuring ImageDataProviders in Web.Config

See the Image Data Provider Configuration section for details on how to modify web.config settings to enable your ImageDataProviders.


File Image Data Providers
User Guide > How to Work with... > Image Data Providers > File Image Data Providers

In order to retrieve image and annotations data stored in files, you must configure a file image data provider. ImageGear provides a built-in FileImageDataProvider that enables the application to read images and annotations from files. This provider also allows writing annotations to the files so they can be retrieved for display. The default root folder configured for retrieving images is "ViewerImages" relative to the application path.

A custom image data provider can be written to replace the built-in FileImageDataProvider. If you write a custom provider, then you must be mindful of handling transactions when writing annotations data. See Implementing Annotations in an Image Data Provider.


SQL Image Data Providers
User Guide > How to Work with... > Image Data Providers > SQL Image Data Providers

To retrieve from and store data to a SQL database, you must define a SQL image data provider.

The ImageGear built-in SQLImageDataProvider is an ADO.NET based ImageProvider, which by default uses Microsoft SQL Server Data provider. However, this provider can be configured to use any database.

The built-in SQLImageDataProvider requires that image data be stored in the database in one of these forms:

  • A column/data field containing image data stored as blobs. The image column data type must be binary.
    In Microsoft SQL Server, the image column data type is "Image" or "varbinary(MAX)". We recommend the use of latter, since the former has been deprecated in SQL Server 2008.
  • A column/data field containing a file path and name of an image file.

The built-in SQLImageDataProvider requires that annotation data be stored in the database as follows:

  • A column/data field containing annotation data stored as a "CLOB" (Character Large Object).

The built-in SqlImageDataProvider uses the database schema defined in the following files, which are provided in the install folder.

The install folder default path is:
C:\Users\Public\Documents\Accusoft\ImageGear.NET v22\Samples\ASP.NET\SQL
  1. scriptSQLExpress2005ImageStorageTableSchema.sql
  2. scriptSQLExpress2008ImageStorageTableSchema.sql
  3. ImageStorageDBSchemaAndData.sql - Creates database with image data. This is suitable for the sample application.

A custom Sql Image data provider can be written to replace the built-in SqlImageDataProvider. Most databases are transactions-aware but if you choose to use non-transactional database, then you must be mindful of transactions in your custom provider when writing annotations data. The "RadiologyOfficeSample" sample application demonstrates how to write a custom Sql image data provider.

This section provides information about the following:

  • SQL Image Data Providers
    • Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies


Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies
User Guide > How to Work with... > Image Data Providers > SQL Image Data Providers > Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies

SQL Server 2005 and SQL Server 2008 have their notification infrastructure built into the database with a messaging system called the "Service Broker". The Service Broker manages queues. These queues are database objects at the same level as the stored procedures, tables and views.

The steps provided in this section for Visual Studio 2010 are also applicable for Visual Studio 2012.

Enabling the Service Broker in SQL Server Express

SQL Server 2005 and SQL Server 2008 are usually locked down for security reasons. The SQL Server broker must be enabled for each specific database that you want to use for cache dependencies. In order to enable the service broker, you must first launch the Visual Studio 2010 command prompt window.

The following are the steps to do that: (The example uses SQL Express:2005 and the default database table "ImageStorage").

  1. Close all instances of Visual Studio 2010.
  2. Click Start Button and choose All Programs.
  3. Select Visual Studio Tools.
  4. Select Visual Studio 2010 Command Prompt.
  5. Run the SqlCmd.exe command line utility specifying the command line parameter -S in the command window:

    SQL
    Copy Code
    SqlCmd -S  .\SQLEXPRESS
  6. The above connects SqlExpress on the local machine.
  7. The SqlCmd provides a command prompt. Enter the following SQL statements:

    SQL
    Copy Code
    USE ImageStorage
ALTER DATABASE ImageStorage SET ENABLE_BROKER;
GO
  8. QUIT or EXIT.
If you have any Visual Studio instance with Database View window open then the command Set Enable_Broker will appear not to execute. It will appear to be hung/frozen.

SqlDependency Rules

There are a number of rules that must be followed for SqlDependency to work correctly. These rules are documented in Microsoft msdn library article titled "Using SqlDependency in an ASP.NET Application" (http://msdn.microsoft.com/en-us/library/9dz445ks(VS.80).aspx). Here is a list of some to bear in mind:

  • You must not use SELECT * in your query. Use individual column names.
  • You must use fully qualified name of the table, example: dbo.ImageStore
  • All tables referenced in the statement must be in the same database.
  • The statement may not use unnamed columns or duplicate column names.
  • The statement must not reference tables with computed columns.
  • The projected columns in the SELECT statement may not contain aggregate expressions unless the statement uses a GROUP BY expression. When a GROUP BY expression is provided, the select list may contain the aggregate functions COUNT_BIG() or SUM(). However, SUM() may not be specified for a nullable column. The statement may not specify HAVING, CUBE, or ROLLUP.

The procedure that sends notifications is a .NET procedure. Make sure your Sql server has CLR support enabled.

Here is how it can be done in SQLEXPRESS:

  1. Run the SqlCmd.exe command line utility.
    SQL
    Copy Code
    SqlCmd -S .\SQLEXPRESS
  2. Enter the following SQL statements:
    SQL
    Copy Code
    EXEC sp_configure 'show advanced options', '1'
GO
RECONFIGURE
GO
EXEC sp_configure 'clr enabled', 1
GO
RECONFIGURE
GO
  3. Enter QUIT or EXIT.

For more detailed explanation and usage of the SQL cache dependency refer to the article on the ASP.NET website: http://www.asp.net/learn/data-access/tutorial-61-vb.aspx


Implementing Annotations in an Image Data Provider
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider

Annotations on a document could potentially be modified and sent to the server by multiple users at any given time. When saving annotations, ImageGear will first call the provider to read the current annotations, merge in the changes, and then call the provider to save the annotations. To protect the integrity of annotation data during this operation, ImageGear uses a .NET framework object, System.Transactions.TransactionScope.

This section provides information about the following:

  • Implementing Annotations in an Image Data Provider
    • Annotation Using Built-In Providers
    • Enabling Annotation within a Custom Image Data Provider
      • Background Information on Transactions
        • Using a Transactional Resource
        • Using a Non-Transactional Resource
      • Helper Abstract Classes in ImageGear22.Web.Services Assembly


Annotation Using Built-In Providers
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Annotation Using Built-In Providers

Most modern database engines are transactional and obey the semantics of the System.Transactions.TransactionScope object. The built-in provider, SQLImageDataProvider, assumes usage of a transactional database engine.

Other repositories, such as the file system, are not transactional, and require code to handle and manage transactional resources. The built in provider, FileImageDataProvider handles and manages the transactional resources.


Enabling Annotation within a Custom Image Data Provider
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Enabling Annotation within a Custom Image Data Provider

Implementing a Custom Image Data Provider that supports annotation requires an understanding of Transactional Programming (see Background Information on Transactions).

Most modern database engines are transactional and obey the semantics of the System.Transactions.TransactionScope object. Creating a custom data provider for a transactional system is fairly straightforward (see Using a Transactional Resource).

Creation of a custom image data provider for a non-transactional system (such as the file system) is also supported by ImageGear, but requires some additional steps to handle and manage the transactional resources (see Using a Non-Transactional Resource).

To assist the programmer in creating custom image data providers that support annotations, two abstract helper classes are provided within the ImageGear22.Web.Services assembly (see Helper Abstract Classes in ImageGear22.Web.Services Assembly).

This section provides information about the following:

  • Enabling Annotation within a Custom Image Data Provider
    • Background Information on Transactions
      • Using a Transactional Resource
      • Using a Non-Transactional Resource
    • Helper Abstract Classes in ImageGear22.Web.Services Assembly


Background Information on Transactions
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Enabling Annotation within a Custom Image Data Provider > Background Information on Transactions

Transactional programming requires working with resources such as databases that are capable of participating in a transaction, and being able to commit or roll back the changes made during the transaction. Typically, you inform a resource that you want to perform transactional work against it. This is called enlisting the resource in the transaction. You then perform work against the resource, and if no error occurs, you ask the resource to commit the changes made to its state. If you encounter any error, you ask it to roll back the changes. During a transaction, it is vital that you do not access any non-transactional resources, because changes made to those resources will not roll back if the transaction is aborted. The .NET Framework 2.0 automates the act of enlisting and managing a transaction against transactional resources. The System.Transactions Namespace offers a common infrastructure for transaction classes, common behaviors, and helper classes. For more information on transactions, refer to the MSDN library documentation under .NET Framework Programming in Visual Studio -> Accessing Data -> Transaction Processing:

http://msdn.microsoft.com/en-us/library/w97s6fw4.aspx

The .NET Framework defines a resource manager as a resource that can automatically enlist in a transaction managed by System.Transactions. The resource has to detect that it is being accessed by a transaction and enlist in that transaction. The System.Transactions Namespace supports a concept called an ambient transaction. When the provider is asked to save annotations data, your provider code will be executing in this ambient transaction within the ImageGear22.Web.Services API method's scope of TransactionScope.

This section provides information about the following:

  • Background Information on Transactions
    • Using a Transactional Resource
    • Using a Non-Transactional Resource


Using a Transactional Resource
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Enabling Annotation within a Custom Image Data Provider > Background Information on Transactions > Using a Transactional Resource

If your custom provider is based on a non-transactional system then your code has to detect this ambient TransactionScope and handle the read and write requests from within this TransactionScope. For an Image Data Provider, the transactional resources could be a file being accessed for this purpose or a SQL database. If you use transactional databases, a lot of work like commits and rollbacks are handled for you by the transactional database. Not all databases behave in a consistent way. You should read the documentation on the database that you are using before designing your provider. In particular, pay attention to the database vendor’s support for System.Transactions.


Using a Non-Transactional Resource
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Enabling Annotation within a Custom Image Data Provider > Background Information on Transactions > Using a Non-Transactional Resource

If your custom provider is based on a non-transactional system, then your code has to detect the ambient TransactionScope and handle the read and write requests from within the TransactionScope.

Microsoft introduced Transactional NTFS (abbreviated TxF) in Vista (For details refer to: http://msdn.microsoft.com/en-us/library/bb968806(VS.85).aspx). The Transactional NTFS brings the concept of atomic transactions to the NTFS file system, and can be used to support the handling of read and write requests from within the TransactionScope.

Prior Operating Systems, like Windows Server 2003, do not have support for TxF and it is not included in the .NET Framework (through version 4.0). This means that when using older operating systems, custom image data providers that store annotations in files must either manage the file resources without the assistance of TxF or access the TxF unmanaged API via InteropServices.


Helper Abstract Classes in ImageGear22.Web.Services Assembly
User Guide > How to Work with... > Image Data Providers > Implementing Annotations in an Image Data Provider > Enabling Annotation within a Custom Image Data Provider > Helper Abstract Classes in ImageGear22.Web.Services Assembly

To assist in handling annotation transactions, the ImageGear22.Web.Services assembly provides two abstract classes that must be implemented in your custom image data provider. Your custom image data provider must include derived classes from these two abstract classes regardless of whether your storage implementation is transactional or non-transactional.

  • ImageGear.Web.DataProviders.ArtDataConnection Abstract Class: An abstract base class that represents a connection to the annotation data stream. Your custom provider must derive a class from this abstract class, and may use it to read and write any number of streams.
    If your custom provider is based on a non-transactional system then you should implement the System.Transactions.IEnlistmentNotification interface in your derived class. The Commit method is called when the annotation data needs to be committed to your chosen storage system. The Rollback method is called when there is some kind of failure indicating the final write operation of the annotation data to the storage system must not occur.
  • ImageGear.Web.DataProviders.ArtDocumentDataConnection Abstract Class: An abstract base class that represents a connection to the pages of annotations associated with one specific document. Your custom provider must derive a class from this abstract class and customize it as needed.

The example below shows a code sample high-level view and the relationships between the provider code, TransactionScope, and the server API code during an annotations data save operation in the ImageGear22.Web assembly API. (For additional example code, refer to the "RadiologyOfficeSample" sample, which uses a custom SQL image data provider.)

C#
Copy Code
//The ImageGearAPI calls OpenArtDocument of ImageDataProvider to get an
//ArtDataConnection derived object.For SQL based provider,
//it is recommended that you open a database connection in the
//constructer of the ArtDataConnection derived class.
ImageGear.Web.DataProviders.ArtDataConnection artconnect =
           ImageGear.Web.DataProviders.ImageDataProvider.OpenArtData();

//The ImageGearAPI calls the ImageDataProvider ArtDataConnection.Open to open
//the required document
using (ImageGear.Web.DataProviders.ArtDocumentDataConnection document =  artconnect.OpenDocument(documentIdentifier))
{
    //Since the ImageGearAPI needs to save the annotations data, it needs
    //to get a current copy from the repository to do the merge with what
    // has just been updated. After that it needs to update the repository.
    // This operation requires use of a TransactionScope to make sure this
    // data is not updated by another user when this process is taking place.
    using (TransactionScope Scope = new TransactionScope())
    {
           //The ImageGear API reads the document first by calling the
           // provider ArtDocumentDataConnection.Read()
           System.IO.Stream stream =  document.Read();

           // The ImageGear API does the merge operations
           // System.IO.Stream artStream = ....;

           //The data is merged and now the data is written to the
           //repository by calling the provider
           //artDocumentdataConnection.Write
           document.Write(artStream);
           //This call will cause the data to be finally committed.
           //If you are using non-transactional system for data storage
           //then you must implement the IEnlistmentNotification interface.
           //The system will call Commit member of this interface to store
           //the data. If there is a processing error before this point then
           //this interface’Rollback method will be called in which case
           //annotation data can not be saved. It is not necessary to
           //implement this interface when using transactional repository
           //systems like the transactional databases.
           Scope.Complete();
    }
}
    // The Server API disposes the ArtDocumentDataConnection derived and
    // ArtDataConnection derived Objects. The SQL connections should be
    // disconnected at this point.
    artconnect.Dispose();


ASP.NET
User Guide > How to Work with... > ASP.NET

This section provides information about the following:

  • ASP.NET
    • Displaying Images using ASP.NET
      • Document Identifiers
      • Client-Side API
      • Context Menu Customization
        • Removing a Context Menu Item from Top Level of Context Menu
        • Removing a Context Menu Item from Any Level of Context Menu
        • Adding a Context Menu Item to the Top Level of Context Menu
        • Adding a Context Menu Item to Any Level of Context Menu
        • Reordering Context Menu Items in Context Menu
        • Changing the Text of Context Menu Items
        • Creating Context Menu Items
        • Working with Check and Radio Handlers
        • Using the Context Menu Customization API for Multiple Controls
      • Server-Side API
      • ImageGearBackEnd Web Control
      • Data Binding to the Server Side ImGearThumbnailList Control
      • Web.config Settings for PageView and ThumbnailView Controls
        • PageView and ThumbnailView Control Action List Items (Smart Tags)
        • Description of Configuration Settings
          • Web Services Registration
          • Image Data Provider Configuration
            • Built-In SqlImageDataProvider
              • SqlImageDataProvider Attributes
              • Annotation Related Parameters for the SQLImageDataProvider
            • Built-In FileImageDataProvider
              • FileImageDataProvider Attributes
              • Annotation Related Parameters for the FileImageDataProvider
          • Image Data Processor Configuration
          • Cache Configuration Settings
          • Error Logging Configuration Settings
      • Using ImageGear jQuery Plugins
      • Data Provider Selection
    • ASP.NET Web.Config Editor Application
      • Run the ASP.NET Web.Config Editor
      • Use the Web Configuration Categories Screen
        • Configuring Error Logging
        • Licensing ASP.NET Components
        • Defining Service Settings
        • Configuring & Working with Data Providers
          • Creating New Data Providers
            • Creating New File Providers
          • Creating New SQL Providers
            • Managing SQL Connection Strings
            • Creating or Editing an SQL Connection String
          • Creating & Editing New Custom Providers
        • Saving Your Web.Config Settings


Displaying Images using ASP.NET
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET

ImageGear includes an ASP.NET-based solution for displaying images in a web browser:

  • PageView and ThumbnailView controls
  • Annotation support
  • Rotation and mirroring
  • Anti-alias display
  • Robust mouse tools, such as a magnifying glass, hand pan, and zoom-on-selection
  • Flexible client-side API for true AJAX applications
  • Handles non-square aspect ratios
  • Very flexible support for image storage, including file and SQL databases
  • Designed to minimize demand on a server

The ImageGear.Web.UI Namespace provides objects that support image viewing and annotations in a web browser.

The core part of the namespace is the PageView Class ASP.NET control, which provides the API for viewing pages/images and a supporting control, the ThumbnailView Class control, which allows you to create thumbnails on your page and the ImGearThumbnailList Class control that lets you display a list of thumbnails of pages from one or more single or multipage documents. This list of thumbnails can either be vertical or horizontal scrolling in a grid or horizontal formats respectively.

All three controls support the ASP.NET 4.0 client-side control facility and provide robust client-side APIs. To provide the best possible experience to your users, use the Client-Side API as much as possible, since it avoids round-trips to the server.

The controls are true AJAX controls. While they will function properly inside an UpdatePanel, there is no need to place them inside one to get AJAX functionality.

This section provides information about the following:

  • Displaying Images using ASP.NET
    • Document Identifiers
    • Client-Side API
    • Context Menu Customization
      • Removing a Context Menu Item from Top Level of Context Menu
      • Removing a Context Menu Item from Any Level of Context Menu
      • Adding a Context Menu Item to the Top Level of Context Menu
      • Adding a Context Menu Item to Any Level of Context Menu
      • Reordering Context Menu Items in Context Menu
      • Changing the Text of Context Menu Items
      • Creating Context Menu Items
      • Working with Check and Radio Handlers
      • Using the Context Menu Customization API for Multiple Controls
    • Server-Side API
    • ImageGearBackEnd Web Control
    • Data Binding to the Server Side ImGearThumbnailList Control
    • Web.config Settings for PageView and ThumbnailView Controls
      • PageView and ThumbnailView Control Action List Items (Smart Tags)
      • Description of Configuration Settings
        • Web Services Registration
        • Image Data Provider Configuration
          • Built-In SqlImageDataProvider
            • SqlImageDataProvider Attributes
            • Annotation Related Parameters for the SQLImageDataProvider
          • Built-In FileImageDataProvider
            • FileImageDataProvider Attributes
            • Annotation Related Parameters for the FileImageDataProvider
        • Image Data Processor Configuration
        • Cache Configuration Settings
        • Error Logging Configuration Settings
    • Using ImageGear jQuery Plugins
    • Data Provider Selection

See Also
Client-Side API
File Formats Reference


Document Identifiers
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Document Identifiers

Because of the distributed nature of web applications, it is not practical to rely on a reference to a single document object for the lifetime of a viewer. Instead, the PageView Class and ThumbnailView Class controls introduce the concept of a document identifier.

The ImGearThumbnailList control does not have a property called DocumentIdentifier but it uses the same concept of DocumentIdentifier for data binding.

Using document identifiers instead of .NET objects to represent a document allows ImageGear to be used in a web form environment and allows an ImageGear client to continue functioning if the server that created it is rebooted.

A document identifier is a string that uniquely identifies the document, via relative path to a file, or via a database key.

To specify a document to view, set the PageView.DocumentIdentifier Property and ThumbnailView.DocumentIdentifier Property. (The PageView.PageNumber Property and ThumbnailView.PageNumber Property indicate the page to view in a multipage document.) To get the encoded value of the document identifier, use the PageView.EncodedDocumentIdentifier Property and ThumbnailView.EncodedDocumentIdentifier Property.

The ImGearThumbnailList class control does not contain DocumentIdentifier property but the documentidentifier is used for data binding. The client side ImageGear.Web.UI.ImGearDocument contains a DocumentIdentifier property. Therefore, internally, the server control uses the bound DocumentIdentifier to create a Client side ImGearDocument object.


Client-Side API
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Client-Side API
This topic provides information about the following:
  • Using the Client-Side API for Viewing
  • Using the Client-Side API for Annotating
  • Using the Client-Side API for Context Menu Customization
  • Debugging the Client-Side

Using the Client-Side API for Viewing

The client-side API resides in three ASP.NET client-side controls: PageView Class, ThumbnailView Class, and ImGearThumbnailList Class. These controls rely on the framework that Microsoft introduced in ASP.NET 2.0.

The ImGearThumbnailList Class properties will acquire the current state of the associated server-side property SelectedPages.

If you are binding documents to the ImGearThumbnailList control from the server side and setting specific properties on the server side then you should do this every time you load the pages containing the ImGearThumbnailList control.

These controls are supported by a few enumerations and other classes and expose an easy, but powerful viewing API. Normally, you will want to develop as much of your viewer functionality as possible in JavaScript to avoid round-trips to the server. The client portion of ImageGear will automatically interact with the server portion using AJAX calls to support whatever viewing operations you have requested via the client API.

Using the Client-Side API for Annotating

In addition to the viewing functionality, these controls expose a rich API for adding, editing, or deleting marks or annotations to your images. Marks can also be interactively added, edited, and deleted via a set of mouse tools and context menus.

If your application is based on ASP.NET postbacks, then the server-side PageView and ThumbnailView controls will automatically save your annotations. The ImGearThumbnailList control does not use postbacks for saving annotations; it uses services.

If your application does not utilize postbacks, and you wish to save your annotations when using either the PageView or ThumbnailView controls, use the saveArtPage methods to save the annotations. In the ImGearThumbnailList client control, use the saveArtData method. The ImGearThumbnailList.saveArtData method will save only pages where annotation changes are made including creation of new annotation objects.

Using the Client-Side API for Context Menu Customization

The ImageGear ASP.NET PageView control provides the ability to customize the behavior of its context menu.

Using the public API available in the PageView control, you can show and hide the context menu (see showContextMenu and hideContextMenu for details). You can also catch and process an event when the user activates the context menu (see contextMenu event for details).

If your application requires customization of the existing context menu such as adding new menu items with the corresponding events, deleting existing items, changing the context menu item text, or changing the behavior of the context menu item, this can be achieved with the use of the context menu API provided by the JavaScript PageView control. This API includes setContextMenu, setContextMenuForTool, getDefaultContextMenu, and getContextMenu methods that could be used to customize the context menu of the PageView control.

See Context Menu Customization for more information.

Debugging the Client-Side

For client-side errors, ImageGear uses the ASP.NET client-side trace facility (Sys.Debug.trace), as well as a global function, onImageGearItemLogged(), that you can create to receive notification of logged items. Refer to the PageView .debug Property for more information.

For more information about the client-side API, refer to the ImageGear.Web.UI Namespace Client API Library Reference.

A web application can track failures occurring during the opening of images. This can be done using the pageOpenFailed event. This event is fired whenever an image fails to open with an openImage call in the PageView or ThumbnailView client controls. The ImGearThumbnailList client control fires the pageAddFailed event when a page fails to load in the control.

The event argument ImageGear.Web.UI.ImGearPageOpenFailedEventArgs contains an error object of one of the following types:

  • ImageGear.Web.UI.ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException

The ImGearHttpException gives some information about an error occurring on the server when trying to open an image. In particular, if you are using a custom data provider, then you can use the ImGearHttpException object to pass information about an error occurring on the server in the parameter “customErrorCode”.

The “statuscode” parameter for this object must be one of the standard HTTP error codes. Also, when you are using a custom provider, make sure that you never pass a statuscode of 200 when there is an error. The statuscode value of 200 means there was no error.

All other error exceptions objects reflect errors occurring in the client side code.


Context Menu Customization
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization

User interaction with the client-side PageView control is mostly performed using the context menu. The PageView control supports 14 modes listed in the MouseTool enumeration. Each mode allows the user to activate a context menu for a specific ART mark type listed in MarkType, or an image loaded into the control. The context menu customization API allows enabling an individual context menu for every combination of the MouseTool and ART mark type.

A context menu is an indexed array of items that are displayed on the screen when the user interacts with it. Any context menu item can be one of the following:

  • Separator
  • Popup
  • Standard
  • User

The Separator menu item is displayed on the screen as a horizontal line between the other context menu items. It is used for logical grouping of the items in the context menu.

The Popup menu item has text associated with the menu as well as a list of child items representing sub items and displayed when the user activates the popup in the context menu.

The context menu is designed as a tree of context menu items with ContextMenu as a non-leaf node and the leaf nodes performing the action. Any leaf node of the context menu can either represent a standard item or a user specific item. All context menus of the PageView control contain only standard items by default, but you can add any number of user items to any context menu using the customization API. Please refer to ContextMenuItemType and ContextMenuItem for details about the currently supported standard context menu items as well as the data structure of the context menu item.

The context menu can be hidden and shown using hideContextMenu and showContextMenu methods.

Context menu customization API provides the following API:

  • ContextMenuItemType Enumeration
  • ContextMenu Class
  • ContextMenuItem Class
  • getContextMenu Method
  • getDefaultContextMenu Method
  • setContextMenu Method
  • setContextMenuForTool Method

This API can be used to change, rename, or entirely reorganize the context menus.

This section provides information about the following:

  • Context Menu Customization
    • Removing a Context Menu Item from Top Level of Context Menu
    • Removing a Context Menu Item from Any Level of Context Menu
    • Adding a Context Menu Item to the Top Level of Context Menu
    • Adding a Context Menu Item to Any Level of Context Menu
    • Reordering Context Menu Items in Context Menu
    • Changing the Text of Context Menu Items
    • Creating Context Menu Items
    • Working with Check and Radio Handlers
    • Using the Context Menu Customization API for Multiple Controls


Removing a Context Menu Item from Top Level of Context Menu
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Removing a Context Menu Item from Top Level of Context Menu

You can remove context menu items from a menu. The following example shows how to remove context menu items from the top level of a context menu.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
//var pageView = $.find("pluginPageView");
// get default context menu for image
var contextMenu = pageView.getDefaultContextMenu(null);
// remove two items from the top level
contextMenu.remove(0);
contextMenu.remove(0);
// set the renew context menu for RectangleZoom mouse tool
pageView.setContextMenuForTool(contextMenu, null, ImageGear.Web.UI.MouseTool.RectangleZoom);


Removing a Context Menu Item from Any Level of Context Menu
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Removing a Context Menu Item from Any Level of Context Menu

Context menu items can be removed from any context menu level. The same ContextMenu class is used for menu organization. The following example demonstrates the removal of context menu items from the second level of a context menu.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
//var pageView = $.find("pluginPageView");
// get context menu for image and HandPan mouse tool
var topLevelContextMenu = pageView.getContextMenu(null, ImageGear.Web.UI.MouseTool.HandPan);
// get mouse tool menu
var secondLevelContextMenu = topLevelContextMenu.get(4).contextMenu;
// remove items creating the marks
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
secondLevelContextMenu.remove(5);
// set the renew context menu for RectangleZoom mouse tool
pageView.setContextMenuForTool(topLevelContextMenu, null, ImageGear.Web.UI.MouseTool.HandPan);


Adding a Context Menu Item to the Top Level of Context Menu
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Adding a Context Menu Item to the Top Level of Context Menu

The following example demonstrates how to add context menu items to the top level of the context menu.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
//var pageView = $.find("pluginPageView");
// get context menu for image and HandPan mouse tool
var contextMenu = pageView.getContextMenu(null, ImageGear.Web.UI.MouseTool.HandPan);
// add separator to the end of list
contextMenu.insert(contextMenu.get_size(), new ImageGear.Web.UI.ContextMenuItem(ImageGear.Web.UI.ContextMenuItemType.Separator));
// create new context menu item
var alertMenu = new ImageGear.Web.UI.ContextMenuItem
    (ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
    'Throw Alert', undefined,
    function (pageView, mark) { alert('My alert works!'); }
);
// add alert context menu item after the separator
contextMenu.insert(contextMenu.get_size(), alertMenu);
// set the renew context menu for HandPan mouse tool
pageView.setContextMenuForTool(contextMenu, null, ImageGear.Web.UI.MouseTool.HandPan);


Adding a Context Menu Item to Any Level of Context Menu
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Adding a Context Menu Item to Any Level of Context Menu

Context menu items can also be added to any level of a context menu. The following example shows how to add items to the second level of a context menu.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
    // get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
    var pageView = $("#pluginPageView").ImGearPageViewPlugin();
    // get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
    //var pageView = $.find("pluginPageView");
    // get context menu for image and HandPan mouse tool
    var contextMenu = pageView.getContextMenu(null, ImageGear.Web.UI.MouseTool.HandPan);
    // get second level menu
    var popupMenu = contextMenu.get(4).contextMenu;
    // add separator to the end of list
    popupMenu.insert(popupMenu.get_size(), new ImageGear.Web.UI.ContextMenuItem(ImageGear.Web.UI.ContextMenuItemType.Separator));
    // create the handler of menu item for all mark types
    var commonClickHandler = function (pageView, mark) {
        if (mark) {
            var markType = mark.get_type();
            switch (markType) {
                case ImageGear.Web.UI.MarkType.Line:
                    alert('Line mark is clicked');
                    break;
                case ImageGear.Web.UI.MarkType.Polyline:
                    alert('Polyline mark is clicked');
                    break;
                case ImageGear.Web.UI.MarkType.Rectangle:
                    alert('Rectangle mark is clicked');
                    break;
                case ImageGear.Web.UI.MarkType.Ellipse:
                    alert('Ellipse mark is clicked');
                    break;
                case ImageGear.Web.UI.MarkType.Polygon:
                    alert('Polygon mark is clicked');
                    break;
                case ImageGear.Web.UI.MarkType.Text:
                    alert('Text mark is clicked');
                    break;
            }
        }
        else {
            alert('No mark is clicked.');
        }
    };
    // create new context menu item
    var alertMenu = new ImageGear.Web.UI.ContextMenuItem
        (ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
        'Mark Checker', undefined,
        commonClickHandler
    );
    // add alert context menu item after the separator
    popupMenu.insert(popupMenu.get_size(), alertMenu);

    // set the renew context menu for HandPan mouse tool
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Line, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Polyline, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Rectangle, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Ellipse, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Polygon, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, ImageGear.Web.UI.MarkType.Text, ImageGear.Web.UI.MouseTool.HandPan);
    pageView.setContextMenuForTool
        (contextMenu, null, ImageGear.Web.UI.MouseTool.HandPan);


Reordering Context Menu Items in Context Menu
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Reordering Context Menu Items in Context Menu

The following example demonstrates the ability to change the context menu of a MouseTool and MarkType pair and assign it to all available pairs.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
//var pageView = $.find("pluginPageView");

// get context menu for None mouse tool and no mark clicked conditions
var contextMenu = pageView.getDefaultContextMenu(null);
// get internal array for reodering
var itemArray = contextMenu.get_innerData();

// change the order of menu items in menu to opposite
var storeItem = itemArray[0];
itemArray[0] = itemArray[4];
itemArray[4] = storeItem;
storeItem = itemArray[1];
itemArray[1] = itemArray[3];
itemArray[3] = storeItem;

// set reorganized menu to control for all mouse tool and mark pairs
pageView.setContextMenu(contextMenu, null);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Line);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Polyline);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Rectangle);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Ellipse);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Polygon);
pageView.setContextMenu(contextMenu, ImageGear.Web.UI.MarkType.Text);


Changing the Text of Context Menu Items
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Changing the Text of Context Menu Items

Every context menu item other than a separator has text. The following example demonstrates renaming or localizing the text within the context menu associated with the hand pan mouse tool and image click.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
// var pageView = $.find("pluginPageView");

// get context menu for None mouse tool and no mark clicked conditions
var contextMenu = pageView.getContextMenu(null, ImageGear.Web.UI.MouseTool.HandPan);

// change "Zoom In 25%" to "Decrease Size"
contextMenu.get(0).text = 'Increase Size';
// change "Zoom Out 25%" to "Decrease Size"
contextMenu.get(1).text = 'Decrease Size';
// change "Zoom To Fit" to "Align Size"
contextMenu.get(2).text = 'Align Size';
// change "Mouse Tools" to "Mouse Modes"
contextMenu.get(4).text = 'Mouse Modes';

// set reorganized menu to back
pageView.setContextMenuForTool(contextMenu, null, ImageGear.Web.UI.MouseTool.HandPan);


Creating Context Menu Items
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Creating Context Menu Items

You can also add your own menu items. Additionally, the user specific menu items can be set to use checkboxes and radio buttons.

There are two ways to create a ContextMenuItem. You can do it explicitly or implicitly.

The explicit way assumes the use of the constructor and is a more formal way, requiring all members to be specified explicitly:

Example
Copy Code
var contextMenuItem = new ImageGear.Web.UI.ContextMenuItem
    (ImageGear.Web.UI.ContextMenuItemType.Popup, 'Some group of items',
    precreatedContextMenu, null, null, null);

The implicit way is less strict and is based on the Javascript object notation (JSON):

Example
Copy Code
 var contextMenuItem = {
     type: ImageGear.Web.UI.ContextMenuItemType.Popup,
     text: 'Some group of items',
     items: precreatedContextMenu
  };


Working with Check and Radio Handlers
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Working with Check and Radio Handlers

The following example shows how to create new context menu items and popup groups with checkHandler and radioHandler callbacks. The context menu items are intentionally created explicitly and implicitly for the purpose of demonstration.

For Ajax server users, please comment out the first portion of the code below and uncomment the second.

Example
Copy Code
// get PageView control with "pluginPageView" identifier from the HTML page in jQuery plugin
var pageView = $("#pluginPageView").ImGearPageViewPlugin();
// get PageView control with "pluginPageView" identifier from the HTML page for Ajax server
//var pageView = $.find("pluginPageView");

// define scroll bars popup menu item
var scrollBarsPopup = new ImageGear.Web.UI.ContextMenuItem(
    ImageGear.Web.UI.ContextMenuItemType.Popup,
    'Scroll Bars Mode',
    [
        {
            type: ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
            text: 'Auto',
            clickHandler: function (pageView, mark) { pageView.set_scrollBars(ImageGear.Web.UI.ScrollBars.Auto); },
            radioHandler: function (pageView, mark) { return pageView.get_scrollBars() == ImageGear.Web.UI.ScrollBars.Auto; }
        },
        {
            type: ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
            text: 'Both',
            clickHandler: function (pageView, mark) { pageView.set_scrollBars(ImageGear.Web.UI.ScrollBars.Both); },
            radioHandler: function (pageView, mark) { return pageView.get_scrollBars() == ImageGear.Web.UI.ScrollBars.Both; }
        },
        {
            type: ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
            text: 'None',
            clickHandler: function (pageView, mark) { pageView.set_scrollBars(ImageGear.Web.UI.ScrollBars.None); },
            radioHandler: function (pageView, mark) { return pageView.get_scrollBars() == ImageGear.Web.UI.ScrollBars.None; }
        }
    ],
    null, null, null
);

// define vectorFormatsRendering as a boolean checkbox item
var vectorFormatsRendering = {
    type: ImageGear.Web.UI.ContextMenuItemType.UserMenuItem,
    text: 'Vector Formats as Raster',
    clickHandler: function (pageView, mark) {
        if (pageView.get_vectorFormatsRendering() == ImageGear.Web.UI.VectorFormatsRendering.Raster)
            pageView.set_vectorFormatsRendering(ImageGear.Web.UI.VectorFormatsRendering.SVG);
        else
            pageView.set_vectorFormatsRendering(ImageGear.Web.UI.VectorFormatsRendering.Raster);
    },
    checkHandler: function (pageView, mark) { return pageView.get_vectorFormatsRendering() == ImageGear.Web.UI.VectorFormatsRendering.Raster; }
};

// get context menu for None mouse tool and no mark clicked conditions
var contextMenu = pageView.getContextMenu(null, ImageGear.Web.UI.MouseTool.RectangleZoom);

// append separator
contextMenu.insert(5,
{ type: ImageGear.Web.UI.ContextMenuItemType.Separator }
);
contextMenu.insert(6, vectorFormatsRendering);
contextMenu.insert(7, scrollBarsPopup);

// set reorganized menu back
pageView.setContextMenuForTool(contextMenu, null, ImageGear.Web.UI.MouseTool.RectangleZoom);


Using the Context Menu Customization API for Multiple Controls
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Context Menu Customization > Using the Context Menu Customization API for Multiple Controls

If you are using more than one PageView control and you want to use the same customized menu for all of them, you can get and customize the context menu for one control and then set that menu to all controls. The following example shows how to change context menu items from 'Zoom_In_25%' and 'Zoom_Out_25%' to 'Zoom_In_50%' and 'Zoom_Out_50%' accordingly for ten PageView controls on the page.

Example
Copy Code
// get the list of PageView controls with "pluginPageView_X" identifier
// from the HTML page in jQuery plugin
var pageViewControls = [];
for (var i = 1; i <= 10; i++) {
    pageViewControls.push($("#pluginPageView_" + i).ImGearPageViewPlugin());
}
// get the list of PageView controls with "pluginPageView_X" identifier
// from the HTML page in Ajax server
//var pageViewControls = [];
//for (var i = 1; i <= 10; i++) {
//    pageViewControls.push($.find("pluginPageView_" + i));
//}

// get context menu of the first control
var contextMenu = pageViewControls[0].getDefaultContextMenu(null);

// change context menu
var item = contextMenu.get(0);
item.text = 'Zoom In 50%';
item.type = ImageGear.Web.UI.ContextMenuItemType.UserMenuItem;
item.clickHandler = function (pageView, mark) { pageView.zoomIn(1.5); }
var item = contextMenu.get(1);
item.text = 'Zoom Out 50%';
item.type = ImageGear.Web.UI.ContextMenuItemType.UserMenuItem;
item.clickHandler = function (pageView, mark) { pageView.zoomOut(1.5); }

// set reorganized menu to all controls
for (var i = 0; i < pageViewControls.length; i++) {
    pageViewControls[i].setContextMenuForTool(contextMenu, null, ImageGear.Web.UI.MouseTool.None);
}


Server-Side API
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Server-Side API

Using the Server-Side API for Viewing

Three server-side web controls support viewing: PageView Class web control, ThumbnailView Class web control, and the ImGearThumbnailList web control. The PageView and the ThumbnailView web controls primarily encapsulate the current state of a client-side image viewer or thumbnail. The ImGearThumbnailList web control maintains only the selected state of the thumbnails when the ImGearThumbnailList control property DataBindingType is set to ImageGear.Web.UI.ImGearDataBindingType.Page.

During an initial page lifecycle (i.e., not a postback), set the properties of the PageView Class, ThumbnailView Class and ImGearThumbnailList web controls to the desired state, and they will create instances of client-side control with matching properties.

During a postback, the PageView Class properties will acquire the current state of the associated client-side properties listed below. (All other PageView Class properties revert to default values.)

  • DocumentIdentifier
  • PageNumber
  • ImageFitType
  • ViewRectangle
  • ViewRotationDegreesClockwise
  • ViewMirror

The ThumbnailView Class properties will acquire the current state of the associated client-side properties listed below. (All other ThumbnailView Class properties revert to default values.)

  • DocumentIdentifier
  • PageNumber
  • Selected

Server-Side Annotation Support

The ASP.NET services support six of the ImageGear annotation types:

  • Line
  • Polyline
  • Rectangle
  • Ellipse
  • Polygon
  • Text

The annotations are read from either a NotateExpress or ImageGear XML file but can only be saved to the ImageGear XML format. Refer to ImageGear.Web.UI Namespace Client API Library : ImageGear.Web.UI Namespace.

Enabling Annotation Support with the Server-Side API

The server-side API allows the programmer to specify the level of annotation support that should be enabled by setting the PageView.ArtEnableMode and the ThumbnailView.ArtEnableMode properties. The ImGearThumbnailList control uses services for annotations. The service option can be selected using the property ImGearThumbnailList.ArtDataServiceOption of the type ImGearArtDataServices enumeration.

When annotations are enabled via the ArtEnableMode properties and a document page is loaded, ImageGear ASP.NET will check for a corresponding artwork document identifier source (containing the annotations) such as a same document name file ending in an ".xml" extension. The default action for every post back is to save the current art work annotations and then load the requested document page and its associated artwork for the page.

If the user's application needs to read and save the annotation artwork to a different document identifier or wishes to draw and save art without all the overhead of a post back, then the ImageGear.Web.UI.ArtConnection Class public API may be used to read and write XML source files.

Debugging the Server-Side

ImageGear ASP.NET components make use of the ImageGear RESTful services to respond to viewing and annotations requests made by the client web controls. These services and other server side modules include extensive logging to help you track down any problems that may occur. ImageGear uses the System.Diagnostics.TraceListener facility built into ASP.NET and the .NET framework. You can control the amount of logging ImageGear does by editing web.config. See Error Logging Configuration Settings.


ImageGearBackEnd Web Control
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > ImageGearBackEnd Web Control

ImageGear provides a simple ImageGearBackEnd Class control that when dragged to your web page will place all required ImageGear .NET libraries in your application's Bin folder. This control does not have any properties or methods except the standard inherited ones. This control only performs its function it is designed to if it is dragged from the Visual Studio Toolbox onto your page. It has no affect if you choose to manually add it on your web page using the Visual Studio Code Editor or any other text editor.


Data Binding to the Server Side ImGearThumbnailList Control
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Data Binding to the Server Side ImGearThumbnailList Control

The server side ImGearThumbnailList control allows you to bind a list of documents or pages created using any of the data sources supported by .NET. The data sources can either be an XML file, a database query result or local variables. There are two forms of data binding. You can choose any one, but you cannot mix the two in the same control.

The options are:

  • Document -or-
  • Page

These options are defined in the Enumeration “ImageGear.Web.UI.ImGearDataBindingType”. The ImGearThumbnailList property “DataBindingType” instructs the control about your choice of the data binding type. You also must inform the control about fields to bind to using the following properties of the ImageGear.Web.UI.ImGearThumbnailList control:

  • DocumentIdentifierField
  • DocumentCaptionField
  • PageCaptionField
  • PageNumberField

The field “DocumentIdentifierField” is required for both types of data binding. The caption fields are optional. The “PageNumberField” is required for specifying specific page numbers when using the Document binding type is also required when using “Page” binding type.

If the property IncludeAllPages is set to “true” when using “Document” binding type, all the data binding information about page numbers will be ignored. However, when using “Page” binding type and if the “IncludeAllpages”property is set to true and “DataBindingType” property is set to “Page”, the “IncludeAllPages” property value will be ignored and the data binding will occur using “Page” type binding. When there is a “Page” type binding, each page is wrapped in a separate document instance even when exactly the same DocumentIdentifier is specified.

Data Binding Examples

The following examples illustrate data binding to the ImGearThumbnailList control:

Example 1, using a XML file as a data source
XML File: ThumbnailListTest.xml

Example 1
Copy Code
<?xml version="1.0" encoding="utf-8"? >
<pages>
<page documentIdentifier="MyImage.tif" pageNumber="2" documentCaption="MyImage" pageCaption="Page"/>
<page documentIdentifier="ccitt.tif" pageNumber="4" documentCaption="ccitt" pageCaption="Page" />
<page documentIdentifier= "MyImage2.tif" pageNumber="6" documentCaption="MyImage2" pageCaption="Page" />
</pages>

The following properties are set in your application to enable binding to the ImGearThumbnailList web server side control:

  • ImGearThumbnailList1.IncludeAllPages = false;
  • ImGearThumbnailList1.DataBindingType = ImGearDataBindingType.Page;
  • ImGearThumbnailList1.PageNumberField = "PageNumber";
  • ImGearThumbnailList1.PageCaptionField = "PageCaption";
  • ImGearThumbnailList1.DocumentCaptionField = "DocumentCaption";
  • ImGearThumbnailList1.DocumentIdentifierField = "DocumentIdentifier";

Data Binding Method A

The following example illustrates data binding from the above XML file using Linq. In your Page_Load method of your web application, create a list from the above XML file using the following code:

Example 2
Copy Code
string fullPath = HttpContext.Current.Request.MapPath(@"~/ThumbnailListTest.xml");

var documentsXml = XDocument.Load(fullPath);

//create a list of pages using Linq. Select values based on the values set for properties, //PageNumberField, PageCaptionField, DocumentCaptionField and DocumentIdentifierField.

var pages = from page in documentsXml.Descendants("page")

select new
{
PageNumber = page.Attribute("pageNumber").Value,
PageCaption = page.Attribute("pageCaption").Value,
DocumentCaption = page.Attribute("documentCaption").Value,
DocumentIdentifier = page.Attribute("documentIdentifier").Value
};

Data Binding Method B

The following example illustrates data binding by populating a list with data objects and data obtained from the ThumbnailListTest.xml file:

Example 3
Copy Code
// This requires declaration of a data object class

class MyBindingObject
{
public string DocumentIdentifier;

public string PageNumber;
public string DocumentCaption;
public string PageCaption;

}

List< MyBindingObject> pages = new List <MyBindingObject>();

// We create list with data from the same xml file
foreach (var p in documentsXml1.Descendants("page"))
{
pages.Add(new MyBindingObject() { DocumentIdentifier = p.Attribute("documentIdentifier").Value,
PageCaption = p.Attribute("pageCaption").Value,
PageNumber = p.Attribute("pageNumber").Value,
DocumentCaption = p.Attribute("documentCaption").Value});
}

// specify the data source and bind the data (The following is common code for the examples A and B).

ImGearThumbnailList1.DataSource = pages;
ImGearThumbnailList1.DataBind();

Data Binding Method C

XML File: ThumbnailListDocs.xml

Example 4
Copy Code
<?xml version="1.0" encoding="utf-8"? >
<documents>
<document documentIdentifier="MyImage.tif"DocumentCaption="MyImage" pageCaption="Page"/>
<document documentIdentifier="ccitt.tif" documentCaption="ccitt" pageCaption="Page" />
<document documentIdentifier= "MyImage2.tif" documentCaption="MyImage2" pageCaption="Page" />
</documents>

The following example illustrates “Document” type data binding. It creates a list of documents from the above XML file using Linq. In your Page_Load method of your web application, create a list from the above XML file using the following code:

Example 5
Copy Code
string fullPath = HttpContext.Current.Request.MapPath(@"~/: ThumbnailListDocs.xml ");

var documentsXml = XDocument.Load(fullPath);

//create a list of documents using Linq. Select values based on the values set for properties,
//PageCaptionField, DocumentCaptionField and DocumentIdentifierField.

ImGearThumbnailList1.IncludeAllPages = true;
ImGearThumbnailList1.DataBindingType = ImGearDataBindingType.Document;
ImGearThumbnailList1.PageCaptionField = "PageCaption";
ImGearThumbnailList1.DocumentCaptionField = "DocumentCaption";
ImGearThumbnailList1.DocumentIdentifierField = "DocumentIdentifier";
var docs = from documents in documentsXml.Descendants("document")

select new
{
PageCaption = page.Attribute("pageCaption").Value,
DocumentCaption = page.Attribute("documentCaption").Value,
DocumentIdentifier = page.Attribute("documentIdentifier").Value
};
// specify the data source and bind the data .

ImGearThumbnailList1.DataSource = docs;
ImGearThumbnailList1.DataBind();


Web.config Settings for PageView and ThumbnailView Controls
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls

PageView, ThumbnailView, and ImGearThumbnailList controls require configuring your web application so that these controls can function properly and be able to display images in your web pages. The configuration settings apply to your application's web.config file. All PageView and ThumbnailView controls in your entire web application will share these settings. Therefore, you cannot have separate settings for individual controls. In other words, these settings are web application specific.

The following is the list of configurations:

  • Web Services Registration (Required)
  • Image Data Provider Configuration (Required)
  • Image Data Processor Configuration (Required)
  • Server-side PageView and ThumbnailView control Error Logging Configuration Settings (Optional)

There are two methods by which these settings can be configured:

  • Utilize "Smart Tags" or "Action Lists" visible in the design view in Visual Studio 2008, 2010, and 2012. These Action Lists will invoke a configuration dialog that will assist you in configuring the various settings required for your application.
  • Edit the configuration settings within web.config. See the Description of Configuration Settings section for a description of required and optional settings to display images.

This section provides information about the following:

  • Web.config Settings for PageView and ThumbnailView Controls
    • PageView and ThumbnailView Control Action List Items (Smart Tags)
    • Description of Configuration Settings
      • Web Services Registration
      • Image Data Provider Configuration
        • Built-In SqlImageDataProvider
          • SqlImageDataProvider Attributes
          • Annotation Related Parameters for the SQLImageDataProvider
        • Built-In FileImageDataProvider
          • FileImageDataProvider Attributes
          • Annotation Related Parameters for the FileImageDataProvider
      • Image Data Processor Configuration
      • Cache Configuration Settings
      • Error Logging Configuration Settings


PageView and ThumbnailView Control Action List Items (Smart Tags)
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > PageView and ThumbnailView Control Action List Items (Smart Tags)

All three controls, PageView, ThumbnailView, and ImGearThumbnailList have "Smart Tags" or "Action Lists" visible in the design view in Visual Studio 2010. These Action Lists provide the ability to configure the various settings. This SmartTag launches a configuration application that guides you through the various settings required in your application configuration file.

The screen capture below shows the PageView control that has an arrow pointing right on the top-right hand corner, also referred to as the "Smart Tag Anchor". When this arrow is clicked, an Action List menu is displayed. This is also referred to as the "Smart Tag Panel". This is the "Action List" in the collapsed form.

When the smart tags are expanded, there are two choices:

  • The first choice, Configure ImageGear Web Settings, is to configure the web.config file and
  • The second choice, Configure ImageGear ASP.NET Services, is to create the necessary ImageGearService.svc file.

The web.config configuration is covered in the WebConfigEditor section of this help file. Both steps are necessary to implement the services to support the web application running with ImageGear services. Both files, web.config and ImageGearService.svc, must reside in the application directory when deployed.


Description of Configuration Settings
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings

This section provides information about the following configuration settings:

  • Web Services Registration (Required)
  • Image Data Provider Configuration (Required)
  • Image Data Processor Configuration (Required)
  • Cache Configuration Settings (Optional)
  • Error Logging Configuration Settings (Optional)


Web Services Registration
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Web Services Registration

Previous versions of ImageGear for .NET (prior to version 19.2) used an ImageHandler scheme for providing images from the server to the client. With the introduction of ImageGear for .NET, version 19.2, the server-side ASP.NET solution has migrated to Microsoft Communication Foundation (WCF) to provide image and ART annotation delivery to the client.

Because of this enhancement, the web.config file configuration settings are different from previous releases and must be revised in order to use ImageGear for .NET version 19.2 ASP.NET. The best way to make changes to this file is to use the new Webconfig utility shipped with the ImageGear product. However, you can edit the configuration file manually as outlined below.

The following element tags are required:

Required Element Tags
Copy Code
<configuration>
.
.
.
  <system.serviceModel>
    <services>
      <service name="ImGearService">
        <endpoint binding="webHttpBinding" contract="ImageGear.Web.IImGearService" />
      </service>
    </services>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="true"/>
  </system.serviceModel>
.
.
.
<configuration>

In the application directory where the web.config file resides, another file must be present: ImageGearService.svc. The file must contain the following line:

Required Code
Copy Code
<%@ ServiceHost Language="C#" Debug="true" Service="ImageGear.Web.ImGearService" CodeBehind="ImageGearService.svc.cs" Factory="System.ServiceModel.Activation.WebServiceHostFactory" %>


Image Data Provider Configuration
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration

The Image Data Provider is an extensible and decoupled module used by PageView and the ThumbnailView components for the delivery of images for viewing. The architecture is based on the ASP.NET Provider model. See Image Data Providers.

There are two methods by which these settings can be configured:

  • Utilize "Smart Tags" or "Action Lists" visible in the design view in Visual Studio 2008, 2010, and 2012. These Action Lists provide the ability to automatically configure default settings.
  • Edit the configuration settings within web.config.

The following example illustrates the settings that must be specified for all image data providers (built-in and custom).

Web.config
Copy Code
<configuration>
 <configSections>
.....
.....
<section name="ImageGear.Web.DataProviders.ImageProvider" type="ImageGear.Web.DataProviders.ImageDataProviderConfiguration,ImageGear22.Web.Services" />
....
....
</configSections>
.....
......
< ImageGear.Web.DataProviders.ImageProvider default = "SqlImageDataProvider"
  parseToken = "!">
<providers>
<add name="SqlImageDataProvider" type="ImageGear.Web.DataProviders.SqlImageDataProvider,ImageGear22.Web.Services" connectionStringName="SqlImageProviderConnection" sqlCommand="SELECT ImageData FROM dbo.ImageStore WHERE [Image_key] = @Image_key" sqlCommandType="Text" sqlImageDataField="ImageData" sqlParameter="@Image_key" paramKeySqlDbType="UniqueIdentifier" paramKeyLength="36"
cachingEnable="false" sqlCacheDependencyNeeded="false" initSqlCacheDependency="false" maxImageSizeToCache="512" cachingTimeLimit="5" />
sqlInsertCommand="INSERT INTO dbo.ImageStore (Image_key, ImageData) VALUES (@Image_key, @ImageData)"
sqlImageDataParameter="@ImageData”
sqlInsertCommandType="Text"
sqlArtReadCommandType="Text"
sqlArtUpdateCommand="UPDATE dbo.ImageStore SET ArtDocument = @myArtData WHERE [Image_key] = @Image_key"
sqlArtUpdateCommandType="Text"
sqlArtDataField="ArtDocument" sqlImageDataFieldBlob="false" />
<add name="FileImageDataProvider" type="ImageGear.Web.DataProviders.FileImageDataProvider,ImageGear22.Web.Services" storageRootPath="~/viewerImages/" maxImageSizeToCache="512" cachingTimeLimit="5" cachingEnable="false" />
</providers>
</ImageGear.Web.DataProviders.ImageProvider>
....
</configuration>

The section details in the following node must remain the same, even if you write your own custom provider:

Web.config
Copy Code
<section name="ImageGear.Web.DataProviders.ImageProvider" type="ImageGear.Web.DataProviders.ImageDataProviderConfiguration,ImageGear22.Web.Services" />

The section details in the following node define the provider that is used:

Web.config
Copy Code
<ImageGear.Web.DataProviders.ImageProvider default =  "SqlImageDataProvider" >

If the default value is left out, then the first in the list under provider is used as a default. If you are using your custom provider, then replace the default SqlImageDataProvider with your custom provider name.

Each of the providers has its details in the <providers> subsection of <ImageGear.Web.DataProviders.ImageProvider > details section. The custom provider has to be listed in this list with the accompanying assembly name.

This section provides information about the following:

  • Image Data Provider Configuration
    • Built-In SqlImageDataProvider
      • SqlImageDataProvider Attributes
      • Annotation Related Parameters for the SQLImageDataProvider
    • Built-In FileImageDataProvider
      • FileImageDataProvider Attributes
      • Annotation Related Parameters for the FileImageDataProvider


Built-In SqlImageDataProvider
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In SqlImageDataProvider

Any database may be specified for the SqlImageDataProvider, provided there is an ADO.NET data provider for that database.

The image data can be stored in the database as blobs or in files. When the image data is stored in the database as "Blobs", the column data type is expected to be of binary type. For example, in SQL 2005, use "image" data type or use varbinary(max) data type. It is recommended to use the varbinary(max) data type since the "image" data type has been deprecated in SQL 2008. This built-in SqlImageDataProvider also supports the newly introduced FILESTREAM feature in SQL Server 2008.

When storing image data in files, create a column in your database that contains the file name, with Sql data type as Text.

Regardless of the Image storage methods, the annotations data are always stored as "CLOB" (Character Large Object). The Sql data type is Varchar(MAX) in the Sql Server.

Web.config
Copy Code
<configuration>
 <configSections>
.....
.....
<section name="ImageGear.Web.DataProviders.ImageProvider" type="ImageGear.Web.DataProviders.ImageDataProviderConfiguration,ImageGear22.Web.Services" />
....
....
</configSections>
.....
......
<ImageGear.Web.DataProviders.ImageProvider default="SqlImageDataProvider">
<providers>
   <add name="SqlImageDataProvider" type="ImageGear.Web.DataProviders.SqlImageDataProvider,ImageGear22.Web.Services" connectionStringName="SqlImageProviderConnection"
sqlCommand="SELECT ImageData FROM dbo.ImageStore WHERE [Image_key] = @Image_key"
sqlCommandType="Text"
sqlImageDataField="ImageData"
sqlParameter="@Image_key"
paramKeySqlDbType="UniqueIdentifier"
paramKeyLength="36"
cachingEnable="false"
sqlCacheDependencyNeeded="false"
initSqlCacheDependency="false"
maxImageSizeToCache="512"
cachingTimeLimit="5"
sqlArtReadCommand="SELECT ArtDocument FROM dbo.ImageStore WHERE [Image_key] = @Image_key"
sqlArtReadCommandType="Text"
sqlArtUpdateCommand="UPDATE dbo.ImageStore SET ArtDocument = @myArtData WHERE [Image_key] = @Image_key"
sqlArtUpdateCommandType="Text"
sqlArtDataField="ArtDocument"/>
</providers>
</ImageGear.Web.DataProviders.ImageProvider>
....
</configuration>

This section provides information about the following:

  • Built-In SqlImageDataProvider
    • SqlImageDataProvider Attributes
    • Annotation Related Parameters for the SQLImageDataProvider


SqlImageDataProvider Attributes
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In SqlImageDataProvider > SqlImageDataProvider Attributes

The following attributes may be set within the web.config to specify your built-in SqlImageDataProvider:

Familiarity and experience working with databases is expected for the use and implementation of database based Image Data Providers. If you have any general database related questions or any other questions related to database engine and its behavior used at your site, then please consult your Database Administrator.
  • name - (Required) Specifies the name of the image data provider.
    For the built-in SQL image data provider, the name must be specified as "SqlImageDataProvider". If you use the built in provider, and do not provide this name, your images will not display. The name coincides with the name of the class. When you write your own custom data providers, this name can be any string that you give in your code. Refer to the "RadiologyOfficeSample" sample for an example of how to write a custom image data provider.
  • type - (Required) Specifies the Image Data Provider class and the assembly to which it belongs. (For the built-in provider, the assembly is ImageGear22.Web.Services).

    If your provider is a class in your application (in App Code), then the assembly name is not required.

  • connectionStringName - (Required) Specifies the connection name for the database. Dependent on your database and the database server. (This will require a change depending on your environment.)
    For details of database provider specific connection strings see: http://www.connectionstrings.com/
  • sqlCommand - (Required) A Sql query command or a stored procedure that when executed returns a DocumentIdentifier. This attribute value can be edited to suit your database.
    If you edit the query, using either the Visual Studio or the Sql Server Management Studio, make sure that it executes correctly and returns the expected results.
  • sqlParameter - (Required) Represents the column / data field being searched in the query.
    For the built-in SqlImageDataProvider, we recommend that this column / data field contain unique values. (For example, in the WebSqlSample, the "Image_key" and "id" columns/fields contain unique values. Either of these could be used.) The sqlParameter does not have to be a primary key or foreign key. You may choose any column for the query in your command. However, if your query results in multiple row fetches, only the first row will be processed. Other rows will be ignored.
  • sqlCommandType - (Required) Specifies a Text (syntax "Text") command or a stored procedure (syntax "StoredProcedure").
  • sqlInsetCommand – (new in v20 for upload) A Sql Insert command or a stored procedure that when executed inserts an image document or document name into the data base.
  • sqlInsertCommandType – (new in v20 for upload) Specifies a Text (syntax "Text") command or a stored procedure (syntax "StoredProcedure").
  • sqlImageDataParameter – (new in v20 for upload) Represents the value parameter identifier used in the insert command for the image data field or column.
  • sqlImageDataFieldBlob - (Required) Indicates whether the image data stored in the database (see attribute 'sqlImageDataField') is in a BLOB format. This attribute takes the value "true or "false" (note case sensitivity). The default value is "true", meaning the image data is stored in the database in a "BLOB" format in the data field specified by the attribute 'sqlImageDataField'. A value of 'false' expects image file name stored in the field specified in the 'sqlImageDataField' attribute.
  • sqlImageDataField - (Required) Specifies the name of the column that contains the actual image data when the images are stored in a 'BLOB' format, or contains the file path name in the scenarios where the image data is stored in files.
    For the built in provider, the 'BLOB" format image data storage requires Sql data type data to be a varbinary(max) or 'image' Sql data type column SQL Server 2005). We recommend that you use varbinary(max) since Microsoft will eventually deprecate 'image' Sql data type. If you use other databases, then this column data type must be a binary Blob equivalent. For image scenarios where image data is stored in files, the Sql data type column can be Text.
  • paramKeyLength - Specifies the length of the Key (sqlParameter) used to query the database for image retrieval. This parameter is useful to prevent SQL injection if you are using a stored procedure in your query. For a detailed description of SQL Injection, refer to the article on MSDN:
    • patterns & practices Security How Tos Index
      and then,
    • How To: Protect From SQL Injection in ASP.NET - Step 2
  • paramKeySqlDbType - Specifies the SQL Database type of the query parameter (sqlParameter). This attribute is used in conjunction with the above attribute (paramKeyLength) to prevent SQL injection attacks.
    Some database engines like SQL Server Express ignore this feature. Please consult your DBA for advice.
  • cachingEnable - (Required) Indicates whether caching is enabled. This attribute is a boolean and takes a value of "true" or "false" (note the case sensitivity).
    • A value of "false" will disable all caching. (Default value)
    • If cachingEnable is set to "true" and the attribute "sqlCacheDependencyNeeded" (described below) is set to "false", then only ordinary data caching will be performed (no Sql dependency caching will occur).
    • If cachingEnable is set to "true" and the attribute "sqlCacheDependencyNeeded" is set to "true", then both ordinary data caching and Sql dependency caching will occur.
      The ordinary cache will never cache annotations data.
  • sqlCacheDependencyNeeded - Indicates whether SQL dependency will be used for caching. This attribute has a boolean value of "true" or "false" (note the case sensitivity).
    • A value of "false" indicates that SQL dependency will not be used for caching. (Default value)
    • A value of "true" indicates that SQL dependency will be used for caching.
    The default SQL provider supports two types of caching: ordinary data caching and SQL dependency caching. SQL dependency caching is recommended only if your image database is static. If your image database is being constantly updated, then you want to make sure that you are not retrieving outdated images, and therefore SQL dependency caching is not recommended.
    Your database must be configured for Sql dependency prior to use by performing a one-time setup procedure.

    See Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies.

  • initSqlCacheDependency - Indicates whether SqlCacheDependency should be initialized by the image data provider. This attribute has a boolean value of "true" or "false".
    • A value of "false" indicates that SqlCacheDependency should not be initialized by the image data provider. (Default value).
    • A value of "true" indicates that SqlCacheDependency should be initialized by the image data provider. A value of "true" has meaning only if cachingEnable and sqlCacheDependencyNeeded are both also set to "true".
    SQL dependency requires one time initialization. If this initialization has already occurred in your application, then the initSqlCacheDependency attribute should be set to false. See the example below for information on how to perform the initialization in your application.

    Set initSqlCacheDependency attribute to "false" and call the method below before you access any data from the database:

    C#
    Copy Code
    System.Data.SqlClient.SqlDependency.Start().

    The method must be called before the first query is executed. Some prefer to put it in the global.asax file.

    C#
    Copy Code
    void Application_Start(object sender, EventArgs e)
{
System.Data.SqlClient.SqlDependency.Start(ConfigurationManager.ConnectionStrings["conn"].ConnectionString);
}
  • maxImageSizeToCache -Allows you to put an upper limit on the size of the image that can be cached using ordinary cache (not Sql-dependency cache). When deciding on the value, bear in mind the amount of memory your system has. A larger value on infrequently used images will unnecessarily use up the memory for cache. This value is in kilobytes. The default value is 512K.
  • cachingTimeLimit - Represents the amount of time in minutes that the image is to remain in the ordinary cache (not Sql-dependency cache). Upon remaining in the cache for the amount of time specified, the system flushes the cached image. The default value is 5 minutes.
  • storageRootPath - (Required when image data is stored in files) Specifies the root folder path where the image files are stored. This can be changed to suit your image storage system. To indicate that the folder is relative to the web application folder, prepend the path with the '~' character (example: "~/viewerImages/").


Annotation Related Parameters for the SQLImageDataProvider
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In SqlImageDataProvider > Annotation Related Parameters for the SQLImageDataProvider

The following parameter settings are used to enable annotation:

  • artConnectionStringName - (Optional) If this attribute is not provided then the default value is the one provided with "connectionStringName" attribute. Specifying artConnectionStringName is useful if the annotations data is stored on a separate database server.
  • sqLArtParameter -(Required) Represents the column / data field being searched in the query.
For the built-in SqlImageDataProvider, we recommend that this column / data field contain unique values. The sqlArtParameter does not have to be a primary key or foreign key. You may choose any column for the query in your command. However, if your query results in multiple row fetches, only the first row will be processed. Other rows will be ignored.
  • sqlArtReadCommand - (Required) SQL query to retrieve annotations data. It can be edited to suit your database. This query should retrieve annotations data associated with the DocumentIdentifer of the image document being retrieved.
  • sqlArtReadCommandType - (Required) A SQL command can either be in a command format or a stored procedure call. This attribute specifies if it is a Text (syntax "Text") command or a stored procedure (syntax "StoredProcedure").
  • sqlArtUpdateCommand - (Required) A SQL query that is run to update the annotations data.
  • sqlArtUpdateCommandType - (Required) Specifies if the sqlArtUpdateCommand is in a Text format (syntax "Text") or a stored procedure call (syntax "StoredProcedure").
  • sqlArtDataField - (Required) Represents the database table field/column that holds the annotation data. If using the built-in SqlImageDataProvider, even when images are stored as files, the annotations data are expected to be stored as CLOBs (character large objects or VARCHAR(MAX) Sql data type.
  • artFieldParameterLength - (Optional) This specifies the length of the art data Field (sqlArtDataField). This parameter is useful for preventing SQL injection if you are using a stored procedure in your query. For a detailed description of SQL Injection, refer to the article on MSDN:
    • patterns & practices Security How Tos Index
      and then,
    • How To: Protect From SQL Injection in ASP.NET - Step 2
  • artFieldParameterDbType - (Optional) Specifies the Sql Database type of the sqlArtDatafield parameter. This attribute is used in conjunction with the above attribute (artFieldParameterLength) to prevent SQL injection attacks.


Built-In FileImageDataProvider
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In FileImageDataProvider

This provider allows the retrieval of image files for display. It also allows retrieval and updating annotations data from the files.

Web.config
Copy Code
<ImageGear.Web.DataProviders.ImageProvider default="FileImageDataProvider">
    <providers>
  <add name="FileImageDataProvider" type="ImageGear.Web.DataProviders.FileImageDataProvider,ImageGear22.Web.Services" storageRootPath="~/viewerImages/" maxImageSizeToCache="512" cachingTimeLimit="5" cachingEnable="false" />
maxImageSizeToCache="512"
cachingTimeLimit="5"
cachingEnable="false"
artDataFileNameFormat="{0}.xml" />

  </providers>
  </ImageGear.Web.DataProviders.ImageProvider>

This section provides information about the following:

  • Built-In FileImageDataProvider
    • FileImageDataProvider Attributes
    • Annotation Related Parameters for the FileImageDataProvider


FileImageDataProvider Attributes
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In FileImageDataProvider > FileImageDataProvider Attributes

The following attributes may be set within the web.config to specify your built-in FileImageDataProvider:

  • name - (Required) Specifies the name of the image data provider.
    When using the build-in provider, the name must be specified as "FileImageDataProvider". If you use the built in provider, and do not provide this name in the name attribute value, your images will not display. The name coincides with the name of the class. When you write your own custom data providers, this name can be any string that you give in your code. Refer to the Radiology Office sample for an example of a custom image data provider.
  • type - (Required) Specifies the provider class and the assembly in which it resides. (For the built-in provider, the assembly is ImageGear22.Web.Services).
    If your provider is a class in your application, then the assembly name is not required.
  • storageRootPath - (Required) Specifies the root folder path where the image files are stored. This can be changed to suit your image storage system. The '~' character specifies that it is relative to the web application path.

    Absolute and UNC Paths are also accepted. Make sure that when you deploy your web site that the IIS user (usually Network service user) has access to this folder. Without the necessary folder read/write access permissions to the IIS user, the images won't display.

  • maxImageSizeToCache - Allows you to put an upper limit on the size of the image that can be cached. When deciding on the value, bear in mind the amount of memory your system has. A larger value on infrequently used images will unnecessarily use up the memory for cache. This value is in kilobytes. The default value is 512K.
  • cachingTimeLimit - Represents the amount of time in minutes that the image is to remain in the cache. Upon remaining in the cache for the amount of time specified, the system flushes the cache of the stored image. The default value is five minutes (cachingTimeLimit==5).
  • cachingEnable - (Required) Indicates whether caching is enabled. This attribute has a boolean value ("true" or "false").
    • A value of "false" will disable all caching. (Default value)
    • A value of "true" will enable caching.
      The annotations data is never cached.


Annotation Related Parameters for the FileImageDataProvider
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Provider Configuration > Built-In FileImageDataProvider > Annotation Related Parameters for the FileImageDataProvider

The following parameter settings are used to enable annotation:

  • artStorageRootPath - (Optional) The storage root folder path where annotations data files are stored. If this attribute is missing then the "storageRootPath" folder will be used.
  • artDataFileNameFormat - (Optional) Specifies the annotation data file name format. It defaults to the format string "{0}.xml". The {0} in this format is replaced with the value of DocumentIdentifier. For example if your image file is Myimage.tif, then the annotations file will be Myimage.tif.xml.


Image Data Processor Configuration
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Image Data Processor Configuration

The image data processor is configured in the <appsettings> section of the configuration file.

Explanations of the entries added by the designer to your web.config:

  • igComponent - Names the plug-in component dll which will be used at run time. The path portion is typically relative to the ASP.NET solution thus the notation "~/bin/" which specifies that the ImageGear component wrapper dll, ImageGear22.Web.ImageDataProcessor.dll, is located in the bin directory below the application aspx pages.
  • maxThreadsPerControl - The ImageGear ASP.NET server is capable of running concurrent ImageGear components in different threads. The value of this attribute indicates the maximum number of threads that can be launched housing the component. It is recommended that this value should be set to no greater than twice the number of processors available on the ASP.NET host server machine.
    The following lines need to be edited appropriately, especially when deploying the ASP.NET solution with the appropriate ImageGear License Information. Be sure to remove the comment elements "<!--" and "-->".
    C#
    Copy Code
    <appSettings>
    <!--<add key="igSolutionName" value="My ASP.NET Deployment" />-->
    <!--<add key="igSolutionKey" value="12345, -12345, 12345, -12345" />-->
    <!--<add key="igLicenseKey" value="1.0qwertyui..." />-->
  • igSolutionName - This attribute value should be set with the solution name parameter if one has been obtained for the ImageGear product from Accusoft Corporation. It will depend on the type of license obtained.
  • igSolutionKey - The attribute value of this entry should be set with the solution key license if one has been obtained for the ImageGear product. It will depend on the type of license obtained.
    The igSolutionKey may be entered as decimal or hexadecimal values.
  • igLicenseKey - The attribute value of this entry should be set with the OEM license key if one has been obtained for the ImageGear product. It will depend on the type of license obtained.

    The following lines are required if for some reason you have not installed ImageGear on the target system. The information for these is normally extracted from registry. If for some reason, this information is not available in the registry these attributes must be added in the web.config to reflect the path on the machine hosting the ASP.NET binary folders. If the OS host machine is 64 bit and the ImageGear kit is 32 bit, then the paths are most likely incorrect, as the toolkit is typically installed in the (x86) folder of Program Files.
    C#
    Copy Code
    <add key="igPdfResources" value="C:\Users\Public\Documents\AccuSoft\ImageGear.NET v22\Bin" />
<add key="igBinaries" value="C:\Users\Public\Documents\AccuSoft\ImageGear.NET v22\Bin" />
<!--add key="igDisableFormats" value="dicom, jpeg2k, office, ps, pdfps, dcraw, dcrawHeaderless" /> -->

</appSettings>
  • igPdfResources - For decoding PDF file formats correctly, the ASP.NET control needs the location of where the PDF resource files are stored. The PDF resources can be found by either setting this attribute value to the PDF resource directory or setting the registry key "SOFTWARE/Accusoft/ImageGear/dotNet22" in HKEY_LOCAL_MACHINE with the following value.
    • "PDFResourceDirRoot" set to the path containing the "Resource" directory where the PDF resources are stored.
  • igBinaries - Several formats such as PDF have other dynamic libraries pieces which must be located at run time. This attribute value contains the binary folders path to the installed ImageGear toolkit dynamic libraries if not set in the registry. Otherwise, the registry key "SOFTWARE/Accusoft/ImageGear/dotNet22" (or SOFTWARE/Wow6432Node/Accusoft/ImageGear/dotNet22) in HKEY_LOCAL_MACHINE can contain the following value as well.
    • "RootDir" set to the path containing the "Bin" directory where the dynamic dlls are located.
  • igDisableFormats – Having the product detecting formats that are not going to be used affects performance and those formats should be disabled (particularly the more complicated format structures). This key will disable the more exotic, complex formats as noted below. Combining comma separated strings disables the formats specified:
    • Dicom - disables the medical Dicom format.
    • Jpeg2k – disables Jpeg 2000 format.
    • Office – disables word, powerpoint and excel formats.
    • Ps – disables the post script pdf format.
    • Pdfps – disables all of pdf including post script pdf.
    • Dcraw – disables Camera raw except for headerless camera raw formats.
    • DcrawHeaderless – disables the headerless camera raw formats.
  • igVerifyDocuments - This setting corresponds to the "Document Verification" checkbox from the Service Settings UI. When enabled, this setting forces ImageGear for .NET to validate the format of a document uploaded by the ImageGear.Web.Isis namespace API and reject that document if its format cannot be detected by ImageGear.

  • useSvgGzipCompression - When SVG data is used for vector or Office format document transmission, GZIP compression can be used. To enable this functionality, the following line should be added to the appSettings section of the Web configuration file:

    C#
    Copy Code
    <add key="useSvgGzipCompression" value="true" />

    In this case, for Web browsers supporting GZIP content compression SVG data will be compressed with GZIP compression. This option allows you to keep the network traffic.


Cache Configuration Settings
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Cache Configuration Settings

The ImageGear ASP.NET web.config parameter cachingTimeLimit specifies the number of minutes that a document will remain stored in the ASP.NET cache storage from the last time it was accessed. If the document is not accessed within the allotted time, it will be removed from the cache. The entire document must meet the constraints specified by the maxImageSizeToCache parameter (specified in kilobytes) in order to be cached. Otherwise, the document will not be placed into the cache. Of course, the parameter cachingEnable needs to be set to "true" to enable the ASP.NET caching mechanism.

The cached document will be accessed more quickly than one stored in a storage media device and is used even for tile formation of raster images. Raster tiles give better image fidelity than a scaled full-size image page. Depending on the original document size and requested zoom-in image, 2 or more tiles may be needed to pan around the document page by the browser application viewing the document page. So enabling the cache helps for a faster viewing experience. Of course, tiles are not required for documents that can be converted to SVG format by the ImageGear ASP.NET product. The SVG format is scalable by the web browser client viewer.

The only other aspect of caching with the ImageGear ASP.NET product is the user agent or browser caching. The ImageGear ASP.NET product requests a short time frame of approximately 20 seconds to the browser to hold onto the viewed document. Subsequent requests by the browser will most likely participate on a round-trip request for the page if the same page is refreshed. The short duration prevents possible quick redundant requests from downloading the document page unnecessarily.

See Image Data Provider Configuration section on setting these cache parameters in the web.config file.


Error Logging Configuration Settings
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Web.config Settings for PageView and ThumbnailView Controls > Description of Configuration Settings > Error Logging Configuration Settings

The PageView and ThumbnailView server-side controls have the ability to trace errors. In order for the server-side code for these controls to trace errors or just log information, web.config requires certain specific configuration settings.

Error logging configuration is optional. If this section is absent, then server-side error logging will not occur.

Below is a relevant snapshot of the web.config file.

Error logging will also not occur, even with these configuration settings, if your application is deployed in IIS and the IIS user (NetworkService) does not have write access to the folder where the log file is being output.

C#
Copy Code
<system.diagnostics>
      <!--Notes!!!-->
      <!--The following sections can permit the Accusoft Corporation ASP.NET component to record/log Errors and other information.-->
      <!--The imageGearSwitch values may have one of the following values: Off, Critical, Error, Warning, Information or Verbose.-->
      <!--Obviously, each successive value reults in more messages being generated.-->
    <switches>
      <add name="imageGearSwitch" value="Error" />
    </switches>
    <sources>
      <source name="ImageGear.Web" switchName="imageGearSwitch">
        <listeners>
          <add name="imageGearListener" traceOutputOptions="DateTime" type="System.Diagnostics.TextWriterTraceListener" initializeData="ImageGear.Web.log" />
        </listeners>
      </source>
    </sources>
  </system.diagnostics>

These settings are shared both by PageView and ThumbnailView controls.

All the element pairs and attributes above are standard Web.Config elements and attributes and many different arrangements can be deployed. The above sample illustrates the minimum arrangement for logging events.

The name attributes demonstrated above are suggested name strings and all could be changed, save one. The source name = "ImageGear.Web" must be used or error logging from the ImageGear.Web server-side code will not function correctly. Everything else may have a custom name. Of course, names must be consistent, like between the switchName and the name attribute between the switches elements.

The switches element pair has one necessary attribute that adds the switch name to be used and what level of logging is desired. It is recommended that you use the control's Action List item "Default Error Logging Configuration" for initial configuration. However, you may want to replace the value error on your production server with one of the values stated in the commented out section (Off, Critical, Error, Warning, Information or Verbose). Going in the above order, Off will give no logging to Verbose giving the most logging from the Asp.Net server product. Most of the logging information is primarily intended to aid the Accusoft Corporation support team, if a problem should arise (the email address for support is support@accusoft.com).


Using ImageGear jQuery Plugins
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Using ImageGear jQuery Plugins

JQuery plugins are provided for the following ImageGear ASP.NET web client controls:

  • PageView
  • ThumbnailView
  • ImGearThumbnailList

These plugins are designed for use with the jQuery JavaScript library/framework. It is recommended that you use jQuery library versions that have support for the plugins. The ImageGear ASP.NET plugins will work in the absence of the Microsoft Ajax client library.

The table below shows the names of the plugins:

Control Name | jQuery Plugin name
PageView | ImGearPageViewPlugin
ThumbnailView | ImGearThumbnailViewPlugin
ImGearThumbnailList | ImGearThumbnailListPlugin
The plugins do not send Postbacks. The mark-up is not required to be enclosed in an HTML form tag. This makes them ideal for use in MVC web applications. The HTML elements to attach these plugins to must be DIV elements with given, unique ID's. A typical usage pattern is shown below:

Example
Copy Code
$(document).ready(function() {
 . $('#PageView1').ImGearPageViewPlugin(options).openPage(openPageParams);
});

Step-by-step instructions for using ImageGear Plugins

  1. Set up a simple HTML page containing the following markup:
HTML Example
Copy Code
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title></title>
</head>
<body>
<div style="float:right">
<div id="pluginPageView" style="height:800px; width:800px">
</div>
</div>
</body>
</html>
  2. Create two folders under your application:
    1. Scripts
    2. Images
  3. Copy the following JavaScript files from the <Install>/samples/ASP.NET/WebResources/JS folder to the Scripts folder that you just created in Step 2 above:
  • ImGearPlugins22.0.js
  • ImGearCore22.0.js
  • ImGearClientViewer22.0.js
  • ImgearClientArt22.0.js
  4. Add the following in the Head section of the page to include the JavaScript files:
The jQuery file should be included bfore the plugins or any other script files. Also note the order in which to include the files.
Example
Copy Code
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"> </script>
     <script type="text/javascript" src="Scripts/ImGearPlugins22.0.js"> </script>
     <script type="text/javascript" src="Scripts/ImGearCore22.0.js"> </script>
     <script type="text/javascript" src="Scripts/ImGearClientViewer22.0.js"> </script>
     <script type="text/javascript" src="Scripts/ImGearClientArt22.0.js"> </script>
  5. Copy the following .png image files from the <Install>/samples/ASP.NET/WebResources/Images folder to the Images folder that you just created in Step 2 above:
  • ArtMarkHandles.png
  • ArtMarkHandles40.png
  • MenuIcons.png
  6. Add the following JavaScript code to the Head section of the HTML page:
JavaScript Example
Copy Code
<script type="text/javascript">
 //Note: The URL for service path (in blue) if necessary, should be changed to reflect your Domain in the service path.
$(document).ready(function() {
$("#pluginPageView").ImGearPageViewPlugin({ imageHandlerUrl: "ImageGearService.svc" , resourcePath
: “Images”, artServiceOption: ImageGear.Web.UI.ImGearArtDataServices.ArtDataService
}).openPage({ documentIdentifier: "ccitt.tif", pageNumber: 3});
});
</script>
  7. Add the ImageGearService.svc file to your application folder.
  8. Run the ASP.NET Web.Config Editor Application and point to the web.config of your application. If you do not configure your web.config file correctly, your application will fail.
  9. If you are running this application in IIS, make sure that the IIS user has the necessary write access to your application folder for logging.
  10. Make sure the viewImage folder has the image that you are trying to open in the PageView.
  11. Run your application to display the page just created. The page should display images in the PageView.


Data Provider Selection
User Guide > How to Work with... > ASP.NET > Displaying Images using ASP.NET > Data Provider Selection

Because of the distributed nature of the web, data content can be stored in different data repositories such as files and data bases. The ImageGear ASP.NET services support the data provider model where any provider can be used to acquire or store data from a specific data store entity. The Image Data Provider Configuration can have more than one image data provider model defined with a default attribute selecting the implicit data provider to use when no provider is explicitly named. Each provider denoted in ImageGear.Web.DataProviders.ImageProvider section of the web.config file is named and it is that name which can be used by the web client application to pick a different image data provider rather than using the default provider.

To select a data provider, the provider name is combined with the document identifier name separated by a special character or string sequence and used wherever a document identifier is requested. For controls like PageView, there is a DocumentIdentifier property and for JavaScript code, there is the PageViewState class which has a documentIdentifier field. The default value separator is an “!” but can be changed to another string value but both the C# and JavaScript code pieces must be consistent in using the same token separator.

Developers writing their own custom provider should note that a new method, OpenImageData, has been added which should be used instead of the GetImage method. The GetImage method is not supported for multiple provider selection and is being deprecated.
The parseToken attribute value in the ImageProvider configuration section of the web.config file sets the separator value which will be used by the web application. The ImageGear ASP.NET services will use that token to separate out the data provider name from the document identifier and call the requested data provider passing along the document identifier parameter being requested. For an example, see the Tutorial sample which sets attribute parseToken=”:” in the web.config file and has two input buttons defined on the Default.aspx page which switches between two file providers.
See Also
ImageDataProvider Class
ImageGear.Web.DataProviders Namespace
Configuring ImageDataProviders in Web.Config


ASP.NET Web.Config Editor Application
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application

The Accusoft ASP.NET Web.Config Editor is provided to assist you in making the necessary changes to the sections of your ASP.NET solutions web.config, which pertain to ImageGear’s ASP.NET functionality. You may continue to edit the web.config file directly if desired. This tool will assist you in defining values for settings, while also ensuring that the formatting of the ImageGear ASP.NET related sections is done properly.

The Accusoft ASP.NET Web.Config Editor can be used to update the web.config settings used by versions of ImageGear for .NET prior to v19.2.

The following sections provide more detail on how to use the ASP.NET Web.Config Editor application:

  • ASP.NET Web.Config Editor Application
    • Run the ASP.NET Web.Config Editor
    • Use the Web Configuration Categories Screen
      • Configuring Error Logging
      • Licensing ASP.NET Components
      • Defining Service Settings
      • Configuring & Working with Data Providers
        • Creating New Data Providers
          • Creating New File Providers
        • Creating New SQL Providers
          • Managing SQL Connection Strings
          • Creating or Editing an SQL Connection String
        • Creating & Editing New Custom Providers
      • Saving Your Web.Config Settings


Run the ASP.NET Web.Config Editor
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Run the ASP.NET Web.Config Editor

The Accusoft ASP.NET Web.Config Editor is installed with the ImageGear toolkit. The Accusoft ASP.NET Web.Config Editor can be launched from the executable or from within Visual Studio:

  • Use the Executable
  • Use Visual Studio

Use the Executable

You can launch the executable, which is located as follows:

  • 32-bit: $INSTALLDIR\ImageGear.NET v22\Resources\Utilities\ASP.NET Web.Config Editor
  • 64-bit: $INSTALLDIR\ImageGear.NET v22 64-bit\Resources\Utilities\ASP.NET Web.Config Editor

When running the Accusoft ImageGear for ASP.NET Web.Config Editor from the executable, the application will load to the Open File dialog. To specify the web.config file that you want to load and work with, click Open:

The Recent Web Configurations section of the dialog will list any web.config files that were previously loaded. If you are running the application for the first time, the list will be empty. You can load one of these Recent Web Configurations by clicking on the orange triangle button to the left of the listing:

Use Visual Studio

To launch the ASP.NET Web.Config Editor application from within Visual Studio, choose the Configure ImageGear Web Settings option from the PageView Control's Smart Tag Panel:

The Smart Tag Panel can be accessed by clicking on the Smart Tag Anchor, the box in the upper-right-hand corner of the control with a ">" (this can be seen in Design View of the page where the PageView control is located). The following example shows how this looks within Visual Studio 2010:

The Accusoft ASP.NET Web.Config Editor will load the web.config file associated with your solution when launched from within Visual Studio. To load a specific web.config file, follow the instructions in the section "Use the Executable" above.


Use the Web Configuration Categories Screen
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen

The Web Configuration Categories dialog box is the main navigation screen for the Accusoft ASP.NET Web.Config Editor. The dialog box displays the four main operations of the application with text located next to each button to provide you with a quick view of the defined settings for that category:

Category Name | Description
Error Logging | Set the logging level and location of the log files for the ASP.NET components.
Licensing | Specify the type of licensing to use: Evaluation, Development or Deployment.
Service Settings | Define the different environment settings for the ASP.NET application.
Data Providers | Customize from what sources the ASP.NET services will load images and annotations.

All changes made within the application are stored in memory until they are saved to a file.

This section provides information about the following:

  • Use the Web Configuration Categories Screen
    • Configuring Error Logging
    • Licensing ASP.NET Components
    • Defining Service Settings
    • Configuring & Working with Data Providers
      • Creating New Data Providers
        • Creating New File Providers
      • Creating New SQL Providers
        • Managing SQL Connection Strings
        • Creating or Editing an SQL Connection String
      • Creating & Editing New Custom Providers
    • Saving Your Web.Config Settings


Configuring Error Logging
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring Error Logging

The Error Logging dialog allows you to define three error logging settings for the ImageGear for .NET ASP.NET components. These settings are used by the PageView and the ThumbnailView controls:

Error Severity Level: Defines what messages will be output to the defined log file. These options follow the settings defined by the System.Diagnostics.TraceLevel Enumeration in MSDN. The table below outlines the Error Severity Level settings and their meaning:

Name | Description
Off | Output no tracing or debugging messages.
Critical | Output Critical Error-handling messages.
Error | Output all Error-handling messages.
Warning | Output warning and all error-handling messages.
Information | Output information messages, warnings and all error-handling messages.
Verbose | Output all debugging and tracing messages.

Error Log Filename: Defines the complete path and filename where the log messaging will be written. This field is parsed by the application to extract any path information. Any defined path will be used to define the Error Log Directory.

Error Log Directory: Specifies the path in which the messaging file will be created. The value of this field will be used to update the path information for the Error Log Filename field. The path to the file will be displayed in both fields. The Error Log Directory is provided as a simple method for editing the path. If a hard path, i.e. “C:\inetpub\Logs\”, is not defined, the location of the log file will be relative to the web.config file.


Licensing ASP.NET Components
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Licensing ASP.NET Components

The Licensing dialog allows you to set your ASP.NET applications licensing method for ImageGear for .NET, which includes setting the licensing type and defining deployment licensing codes:

Licensing Type: Defines the type of licensing, Distribution or Evaluation/Development, that will be used to license the ImageGear for .NET ASP.NET functionality. Depending on which option is selected from the drop-down list, the other fields within the dialog will be enabled or disabled.

License Type | Description
EvaluationOrDevelopment | This option will instruct the Services to use the licensing obtained by the License Manager utility. The licensing for this option assumes that the ImageGear for .NET product was installed and licensed. Selecting this option will disable the Solution Name, Solution Keys, and License Key fields.
Distribution | Selecting this option will set your application to use purchased deployment licensing. The Solution Name, Solution Keys, and License Key fields will be enabled and will need to be populated with the information provided in the licensing e-mail correspondence.

Solution Name: In this field you will need to enter the Solution Name provided to you when you purchased distribution licensing for your application. If you do not have this value please contact sales@accusoft.com. This field is required when using the Distribution Licensing.

Solution Keys: The Solution Keys consist of four values. This field is required when using the Distribution Licensing.

OEM License Key: If you purchased OEM licensing, you will have been provided an OEM License Key. OEM license keys will unlock the ImageGear for .NET ASP.NET functionality to run in any environment. The License Key is optional; if it is not provided, ImageGear for .NET will expect a license to have been obtained using the Manually Reported Runtime (Non-Node-Locked) Licensing process. The Manually Reported Runtime (Non-Node-Locked) Licensing Process will place a license key into the system's registry.

For more information about using the ASP.NET Web.Config Editor application, refer to Using the ASP.NET Web.Config Editor Application for Configuring Your Web Application.


Defining Service Settings
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Defining Service Settings

The Service Settings dialog allows you to define configuration options for the ASP.NET application. These settings define parameters that control how the ASP.NET components are initialized:

  • Bin Directory: Defines the location of the ImageGear for .NET Assemblies. This path can be defined as a relative path, based on the location of the web.config file, by using a tilde, "~".
  • PDF Directory: Defines the location of the ImageGear for .NET PDF binaries. More information on distributing the PDF Libraries can be found in the Distributing PDF and PS Fonts and Libraries section of the documentation. This path can be defined as a relative path, based on the location of the web.config file, by using a tilde, "~".
  • Max Threads Per Control: Specifies the maximum number of threads that should be created to process ASP.NET requests.
  • Document Verification: Forces ImageGear for .NET to validate the format of a document uploaded by the ImageGear.Web.Isis namespace API and reject that document if its format cannot be detected by ImageGear.
  • Max Upload Byte Size: Defines the maximum number of bytes that can be transmitted by the service per one request. If the size of data is greater than the defined value, an HTTP error 404 will be returned from the service. The maximum possible value for this parameter is 1844674407370955.
  • SVG Content Compression: Defines GZIP compression for SVG content. When the SVG format is being used for vector or Office document data transmission, the GZIP compression will be applied to the HTTP message content if the client browser allows this compression.
  • Enable Optional Formats: Enables optional formats:
    • Camera Raw – enables Camera raw except for headerless camera raw formats.
    • Headerless Camera Raw – enables the headerless camera raw formats.
    • DICOM- enables the medical DICOM format.
    • JPEG 2000 – enables JPEG 2000 format.
    • MS Office – enables Word, PowerPoint and Excel formats.
    • PDF – enables all of PDF, including PostScript PDF.
    • PostScript (Requires PDF) – enables the PostScript PDF format.
    • NativeCommon – enables the native common formats implementation.


Configuring & Working with Data Providers
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers

This section provides information about the following:

  • Configuring & Working with Data Providers
    • Creating New Data Providers
      • Creating New File Providers
    • Creating New SQL Providers
      • Managing SQL Connection Strings
      • Creating or Editing an SQL Connection String
    • Creating & Editing New Custom Providers

Configuring Data Providers

The Data Providers dialog allows you to define the location where files and annotations will be stored. Create new data providers, edit, duplicate or delete existing data providers, or activate a data provider.

For more detailed information on Data Providers, refer to the Using ImageGear.Web.DataProviders Namespace section of the documentation.

If you are running the Accusoft for ASP.NET Web.Config Editor for the first time, the application will create and activate a default FileImageDataProvider. This data provider is set to load images from the ViewerImages folder. This folder should be located in the same folder as the web.config file. This default Data Provider can be edited or deleted.

Working with Data Providers

There are three options associated with each Data Provider listed in the Data Providers dialog. These options allow you to perform some quick management on the Data Providers:

Activate: This option will mark the associated Data Provider as the Data Provider to use. The ASP.NET functionality can only use one Data Provider. The "Active" Data Provider will be used to process requests while the other Data Providers will be ignored.

Duplicate: This option allows you to create a copy of an existing Data Provider. The name of the associated Data Provider, with a numerical increment, will be used to create the name for the new Data Provider. For example, if the original Data Provider being duplicated is named "SqlImageProvider", the duplicate would be named "SqlImageProvider (2)".

Delete: This option will remove a Data Provider from the web.config file. This will not remove any Connection Strings associated with an SQL Data Provider.


Creating New Data Providers
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating New Data Providers

To create a new Data Provider, select Create New Provider from the Data Providers dialog:

The Create New Data Provider dialog displays:

The menu displays three different types of Data Providers that you can create. Each type of Data Provider has settings to control how image files and annotation data will be processed.

The text area to the right of each button defines the default configuration for each type of Data Provider. To create a Data Provider with the displayed default settings, click on the Add Default button below the Data Provider. This will create the references for the Data Provider and return you to the previous screen, with a listing of all your defined Data Providers.

DataProvider Type | Description
File Provider | Specifies the location on the file system where image and annotation data is located.
SQL Provider | Defines the SQL Query and Connection Strings to use in order to obtain image and annotation data from an SQL compliant database.
Custom Provider | Specifies the Assembly and Class information for a custom built DataProvider.

This section provides information about the following:

  • Creating New Data Providers
    • Creating New File Providers


Creating New File Providers
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating New Data Providers > Creating New File Providers

To create a new file provider, select New File Provider to launch a set of two dialog boxes that guide you through customizing a File Data Provider:

The File Data Provider (Page 1 of 2) dialog is displayed. This dialog allows you to define the location of the image data and how it should be handled:

File Data Provider Option | Description
Name | Specifies the name used to reference the Data Provider; this value will be used to reference this data provider.
Storage Root Path | The base location where files will be located. This path can be defined as a hard path or a relative path based on the location of the web.config file (by using a tilde).
Maximum Image Size to Cache | This value is in kilobytes. It allows you to put an upper limit on the size of the image that can be cached. When deciding on the value, bear in mind the amount of memory your system has. A larger value on infrequently used images will unnecessarily use up the memory for cache. The default value is 512K.
Cache Time Limit | Represents the amount of time in minutes that the image is to remain in the cache. Upon remaining in the cache for the amount of time specified, the system will flush the cache of the stored image.
Caching | Indicates whether caching is enabled.

To continue configuring the file data provider, click Next. The File Data Provider (Page 2 of 2) dialog is displayed. This dialog allows you to define the annotation related parameters:

Annotation Related Parameters | Description
ART Storage Root Path | The storage root folder path where the annotation data files are stored. The application defaults the path to the previously defined "Storage Root Path".
ART Data File Name Format | Specifies the replacement scheme used to determine the name of the annotation data file. The application sets this value to "{0}.xml". The {0} in this format is replaced with the value of Document Identifier. For example, if your image file is Myimage.tif, then the annotations file will be Myimage.tif.xml.

After you have defined the Data Provider with your settings, click the OK button to add the Data Provider to the Data Provider list. The Data Provider has been added to the web.config stored in memory, but it has not been written to disk at this point. To save your Web.Config settings, refer to the Saving Your Web.Config Settings topic.


Creating New SQL Providers
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating New SQL Providers

To create a new SQL provider, select New SQL Provider to launch a set of three dialog boxes that guide you through customizing an SQL Provider:

The dialog boxes will guide you through defining how to retrieve images and annotations files from your Database Schema.

The SQL Data Provider (Page 1 of 3) is displayed. This dialog allows you to define the caching aspects of the SQL Data Provider:

SQL Data Provider Settings (Page 1) | Description
Name | Specifies the name used to reference the Data Provider; this value will be used to reference this data provider.
Maximum Image Size to Cache | This value is in kilobytes. It allows you to put an upper limit on the size of the image that can be cached. When deciding on the value, bear in mind the amount of memory your system has. A larger value on infrequently used images will unnecessarily use up the memory for cache. The default value is 512K.
Cache Time Limit | Represents the amount of time in minutes that the image is to remain in the cache. Upon remaining in the cache for the amount of time specified, the system will flush the cache of the stored image.
Caching | Indicates whether caching is enabled.
SQL Cache Dependency | Indicates whether SQL dependency will be used for caching. For more information, refer to Setting Up SQL Server 2005 and SQL Server 2008 Cache Dependencies.
SQL Cache Dependency Initialization | Indicates whether SqlCacheDependency should be initialized by the image data provider. SQL dependency requires one time initialization. If this initialization has already occurred in your application, then the initSqlCacheDependency attribute should be set to false. See the example below for information on how to perform the initialization in your application.

Once you have defined the Cache Settings, click the Next button. The SQL Data Provider (Page 2 of 3) dialog is displayed and allows you to define how the Data Provider will connect to your database and the SQL to be used to retrieve the image data:

SQL Data Provider Settings (Page 2) | Description
Connection String Name | The drop-down list displays all Connection Strings that are defined within the web.config. The Connection String Name field defines how the Data Provider should connect to your database in order to issue SQL commands. For more information on defining a connection string, refer to the Managing SQL Connection Strings topic.
SQL Command | Defines the SQL query command or a stored procedure that will be executed to retrieve a DocumentIdentifier from your database schema.
SQL Parameter | Represents the column / data field being searched in the query.
SQL Command Type | Specifies a Text (syntax "Text") command or a stored procedure (syntax "StoredProcedure").
SQL Image Data Field Blob | Indicates whether the image data stored in the databases is in a BLOB format. The default value is "enabled", meaning the image data is stored in the database in a "BLOB" format. If this field is not "enabled", the Data Provider will expect the Image File name to be stored in the database field.
SQL Image Data Field | Specifies the name of the column that contains the request data. If the "SQL Image Data Field Blob" setting is enabled, this field will contain 'BLOB' image data. If the "SQL Image Data Field Blob" is not enabled, this field will be the file path where the image data is stored.
Param Key Length

Specifies the length of the Key (sqlParameter) used to query the database for image retrieval. This parameter is useful to prevent SQL injection if you are using a stored procedure in your query. For a detailed description of SQL Injection, refer to the articles on MSDN:

  • Patterns & Practices: Security How To's Index
  • How To: Protect from SQL Injection in ASP.NET - Step 2
Param Key SQL Database Type | Specifies the SQL Database type of the query parameter (SQL Parameter). This attribute is used in conjunction with the above attribute (paramKeyLength) to prevent SQL injection attacks. (Some database engines, like SQL Server Express ignore this feature. Please consult your DBA for advice.)
After you have defined the SQL connection for the Image data, click Next to define the SQL configuration to be used for annotation retrieval. The SQL Data Provider (Page 3 of 3) dialog is displayed and allows you to define the SQL used to retrieve and update annotation data (ART):

SQL Data Provider Settings (Page 3) | Description
ART Connection String Name | The drop-down list displays all Connection Strings that are defined within the web.config. The ART Connection String Name field defines how the Data Provider should connect to your database in order to issue SQL commands. For more information on defining a connection string, refer to the Managing SQL Connection Strings topic.
SQL ART Read Command | SQL query to retrieve annotations data. This query should retrieve annotations data associated with the Document Identifier of the image document being retrieved.
SQL ART Read Command Type | A SQL command can either be in a command format or a stored procedure call. This attribute specifies if it is a Text (syntax "Text") command or a stored procedure (syntax "StoredProcedure").
SQL ART Update Command | A SQL query that is run to update the annotations data.
SQL ART Update Parameter | Represents the column / data field being searched in the query.
SQL ART Update Command Type | Specifies if the SQL Art Update Command is in a Text format (syntax "Text") or a stored procedure call (syntax "StoredProcedure").
SQL ART Data Field | Represents the database table field/column that holds the annotation data. If using the built-in SqlImageDataProvider, even when images are stored as files, the annotations data is expected to be stored as CLOBs (character large objects or VARCHAR(MAX) SQL data type).
ART Field Parameter Length

This specifies the length of the ART Data Field (SQL ART Data Field). This parameter is useful for preventing SQL injection if you are using a stored procedure in your query. For a detailed description of SQL Injection, refer to the articles on MSDN:

  • Patterns & Practices: Security How To's Index
  • How To: Protect From SQL Injection in ASP.NET - Step 2
ART Field Parameter Database Type

Specifies the SQL Database type of the SQL ART Data field parameter. This attribute is used in conjunction with the above attribute (ART Field Parameter Length) to prevent SQL injection attacks.

This section provides information about the following:

  • Creating New SQL Providers
    • Managing SQL Connection Strings
    • Creating or Editing an SQL Connection String


Managing SQL Connection Strings
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating New SQL Providers > Managing SQL Connection Strings

The Connection String is the name or network address of the instance of SQL Server in which to connect. To create a new SQL Connection, click the Manage Connections button on the SQL Data Provider (Page 2 and 3) dialog:

The Connection Strings dialog is displayed where you can view and manage all the SQL connections currently defined within the web.config file. The value of a Connection String is displayed in the text area to the right of the controls for each Connection String. A Connection String that is being used by an SQL Data Provider is surrounded in yellow and marked "In Use". These Connection Strings cannot be deleted, but they can be edited or duplicated:

The name of each Connection String will be listed on a button in this dialog. Selecting the button launches a dialog to configure/edit the Connection String. There are two additional buttons, Duplicate and Delete, that perform a specific operation on the associated Connection String:

Duplicate: This option creates a copy of the associated Connection String. The name of the associated Connection String, along with a number increment, is used to create the name for the new Connection String. For example, if the original Connection String being duplicated is named "SqlImageProviderConnection", the duplicate would be named "SqlImageProviderConnection (2)".

Delete: Allows you to remove a Connection String, which is not in use by a Data Provider, from the web.config file.


Creating or Editing an SQL Connection String
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating New SQL Providers > Creating or Editing an SQL Connection String

From the Connection Strings dialog, you can create a new connection or edit an existing connection:

  • To create a new Connection String, click the Create New Connection button in the top right corner of the Connection Strings dialog.
  • To edit an existing Connection String, click on the button labeled with the name of the Connection String you wish to edit:

The data that populates the template will be filled in with either:

  • The default values for a new Connection String, or
  • The values for the Connection String being edited:

To finalize your selections, click OK.

Connection String Parameter | Description
Name | Defines the value that will be listed in the Connection String drop-down list, when defining a Connection String for handling Images or ART data in the SQL Data Provider.
Value | A text string that defines the connection string. For details on database provider-specific connection strings, refer to: http://www.connectionstrings.com/.
In Use | If checked, this Connection String is set as an active Connection String for an SQL Data Provider.


Creating & Editing New Custom Providers
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Configuring & Working with Data Providers > Creating & Editing New Custom Providers

There are two way to access the Custom Data Provider dialog:

  1. To create a new Custom Data Provider, select New Custom Provider from the Create New Data Provider dialog:

The Custom Data Provider dialog is displayed and the fields are populated with default values.

  2. To edit an existing Custom Data Provider, select Custom Data Provider from the Data Provider dialog. The Custom Data Provider dialog is displayed and the fields are populated with the values for the selected Data Provider.

Now you can define your Custom Data Provider:

Custom Data Provider Setting | Description
Name | A string value by which the Data Provider will be referenced.
Assembly | The Assembly which defines the Custom Data Provider.
Class | The Class within the Assembly that the Data Provider will interact with to retrieve images and annotation data.


Saving Your Web.Config Settings
User Guide > How to Work with... > ASP.NET > ASP.NET Web.Config Editor Application > Use the Web Configuration Categories Screen > Saving Your Web.Config Settings

On the Web Configuration Categories dialog there is an option, on the bottom right corner, to Export:

To export or save your web.config settings, click Export. The Export Web Configuration dialog is displayed. There are four options on this dialog that allow you to output the web.config data in different ways to suit your needs:

Export Option | Description
Save | Will save the changes to the loaded web.config file. If the application was launched from the Smart tags, the data will be written to the web.config file associated with the Visual Studio Solution. If a specific web.config file was loaded, then the data will be saved into that file.
Save As | This will output all of the web.config data in memory to a specified file.
Export | The option will only output the settings related to the ImageGear for .NET ASP.NET functionality. Other settings with the loaded web.config file will be dropped.
Copy to Clipboard | This will output all of the web.config data in memory to the clipboard for manual integration.

Once you have saved your data, you can safely exit the application by clicking Exit at the bottom right corner of the dialog.


Windows Forms
User Guide > How to Work with... > Windows Forms

The ImageGear.Windows.Forms Namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly (ImageGear22.Windows.Forms Assembly), using only public ImageGear API, with source code provided to enable modifications.

This section provides information about the following:

  • Windows Forms
    • The GUI Magnifier Window
    • The GUI Pan Window
    • Using ImageGear.Windows.Forms.Thumbnails Namespace
      • The GUI Thumbnail Window
        • Loading
        • Sorting
        • Selecting
        • Dragging

See Also
Using ImageGear.Windows.Forms.Thumbnails Namespace


The GUI Magnifier Window
User Guide > How to Work with... > Windows Forms > The GUI Magnifier Window

The ImGearMagnifier Class control provides a magnified view of a portion of the image in ImGearPageView Class control. It appears either in a separate, stationary window, or as a popup area within the ImGearPageView Class window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView Class control, the magnified display of the image tracks the location of the mouse. If the popup view is used, the magnified display of the image tracks the mouse within the ImGearPageView Class control. The programmer can set the magnification factor, and can optionally expose that capability to the end user. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView Class control. A scroll bar is provided in the magnify window. When the user drags this magnify window scroll bar, ImageGear automatically changes the magnification factor.


The GUI Pan Window
User Guide > How to Work with... > Windows Forms > The GUI Pan Window

The GUI Pan Control allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image. Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImGearPageView Class control is repositioned. The portion of the image that is visible in the ImGearPageView Class control is displayed within the floating window in reverse video. Refer to the ImGearPan Class.


Using ImageGear.Windows.Forms.Thumbnails Namespace
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace

The ImageGear.Windows.Forms.Thumbnail Namespace provides The GUI Thumbnail Window.

See Also
The GUI Thumbnail Window
Windows Forms


The GUI Thumbnail Window
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace > The GUI Thumbnail Window

The GUI Thumbnail Control provides the ability to work with thumbnail images displayed on a thumbnail browser window. Each thumbnail is associated with an ImGearThumbnailItem Class object, which contains full information about the image. The collection of ImGearThumbnailItem Class objects is implemented within the ImGearThumbnailCtl Class.

When the application program runs, the thumbnail browser appears as a series of image buttons on the window.

This section provides information about how an application interacts with the GUI Thumbnail control in the following ways:

  • Loading: when thumbnail items are being loaded
  • Sorting: when the thumbnail items are being re-sequenced on the display
  • Selecting: when the user clicks on a thumbnail item
  • Dragging: when the user drags a thumbnail item to a new position in the display


Loading
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace > The GUI Thumbnail Window > Loading

The thumbnail items are created in response to calls to DirectoryAppend Method, FileAppend Method, PageAppend Method, or DocumentAppend Method. The thumbnail items can also be created in response to the user dragging and dropping a file-icon from Windows Explorer onto the ImGearThumbnailCtl Class control. This will cause the BeforeLoad and AfterLoad event handlers to be called exactly as if the FileAppend Method had been called.


Sorting
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace > The GUI Thumbnail Window > Sorting

The thumbnail items are displayed unsorted by default. The application can re-sequence them by calling Sort. The call to Sort can specify that the items should be sorted by title (ascending or descending), or that a custom sort sequence can be provided. A custom sort sequence is implemented via a SortComparer interface.


Selecting
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace > The GUI Thumbnail Window > Selecting

When the user clicks on a thumbnail item in the display, any of several things will happen (depending on the way that ImGearThumbnailCtl Class properties are set, and how the mouse button is used):

Left-click to select an item under the cursor. If the MultiSelect Property value is set to false, then all other items are deselected. Double-clicking fires an event with the Index parameter set to the item being clicked. If this parameter is equal to -1 then the cursor is outside any thumbnail image. Typically, this event causes the application to load the corresponding image into the main program window.

Right-click to show the thumbnail magnifier if the ShowMagnify Property has been set to true. Releasing the right mouse button will hide the magnifier.

ImGearThumbnailCtl Class will automatically change the appearance of the selected thumbnail item, as per the SelectionBackColor Property and SelectionForeColor Property.

The application can also apply a different appearance to selected thumbnail items, called "Highlighting" them. Each thumbnail item has a Highlighted Property that can be set by the application. When the Highlighted Property is set, the thumbnail item's appearance is determined by the HighlightBackColor Property and HighlightForeColor Property.

ImGearThumbnailCtl Class supports MultiSelect. If the MultiSelect Property is set to true, then the user can select multiple thumbnail items at a time (using Ctrl-click and Shift-click).


Dragging
User Guide > How to Work with... > Windows Forms > Using ImageGear.Windows.Forms.Thumbnails Namespace > The GUI Thumbnail Window > Dragging

ImGearThumbnailCtl Class control supports internally implemented Drag-and-Drop operations that can be enabled or disabled via the DragDropOptions Property. If the ImGearDragDropOptions Enumeration.Drag flag is set, then the thumbnail browser will operate as a source of file Drag operation. If the ImGearDragDropOptions Enumeration.Drop flag is set, then the thumbnail browser will be able to receive the image files via a Drop operation.


Windows Presentation Foundation (WPF)
User Guide > How to Work with... > Windows Presentation Foundation (WPF)

ImageGear.WPF Namespace provides UI controls for use with the Windows Presentation Foundation framework.

ImageGear WPF Samples require Visual Studio 2008 or later or Visual Studio 2005 extensions for .NET Framework 3.0 or later to be installed. It can be downloaded from the Microsoft web site and installed as an extension plug-in to Visual Studio.

This section provides information about the following major parts of the ImageGear.WPF namespace:

  • BitmapSource Interface
  • HD Photo Format
  • XAML GUI Controls and Templates


BitmapSource Interface
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > BitmapSource Interface

BitmapSource is the basic building block of the WPF imaging pipeline, conceptually representing a single, constant set of pixels at a certain size and resolution. A BitmapSource could be a single frame in an image file that a decoder provides, or it could be the result of a transform that operates on a BitmapSource of its own. BitmapSource is not used to represent a multi-frame image or an animation.

ImageGear.WPF Namespace provides an interface to convert between WPF BitmapSource and ImGearPage Class objects.


HD Photo Format
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > HD Photo Format

The ImageGear.WPF.HDP Namespace provides a read/write support HD Photo file format. See the ImageGear Imaging Formats Reference chapter for information.


XAML GUI Controls and Templates
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates

ImageGear.WPF Namespace implements the following XAML configurable template based GUI controls, as documented in the following sections:

  • Thumbnail
  • Magnifier
  • Pan


Thumbnail
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Thumbnail

WPF Thumbnail control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates, as described in the following sections:

  • ImGearThumbnailCtl
  • ThumbnailListBoxStyle
  • ThumbnailListBoxItemStyle
  • ImGearThumbnailItem


ImGearThumbnailCtl
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Thumbnail > ImGearThumbnailCtl

The following template defines ImGearThumbnailCtl Class style and consists of ScrollViewer with binding, ScrollBarVisibility dependency property, and ListBox control with another binded property (SelectionMode), items source (ItemsSource="{Binding Path = Thumbnails}") and overridden styles, called ThumbnailListBoxItemStyle for generic items and ThumbnailListBoxStyle for ListBox itself.

XAML
Copy Code
  <Style TargetType="{x:Type local:ImGearThumbnailCtl}
    <Setter Property="HorizontalAlignment" Value="Stretch"/>
    <Setter Property="VerticalAlignment" Value="Stretch"/>
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type local:ImGearThumbnailCtl}
          <ScrollViewer
            VerticalScrollBarVisibility="{Binding ScrollBarVisibility}"
            HorizontalScrollBarVisibility="Disabled"
            Background ="{Binding Background}
            <ListBox
                IsSynchronizedWithCurrentItem="True"
                Name="ThumbnailListBox"
                SelectedIndex="0"
                SelectionMode="{Binding SelectionMode}"
                Style ="{StaticResource ThumbnailListBoxStyle}"
                ItemsSource="{Binding Path = Thumbnails}"
                ItemContainerStyle =
"{StaticResource ThumbnailListBoxItemStyle}"
                >
            </ListBox>
          </ScrollViewer>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>


ThumbnailListBoxStyle
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Thumbnail > ThumbnailListBoxStyle

The following template defines a style that determines what type of panel is used in the Thumbnail control. It is a WrapPanel by default. User can overwrite this style in his application to use StackPanel, Panel etc, using given properties (like Margin, Background in current implementation). In this case it is necessary to overwrite main style for thumbnail control to set ListBox Style property to newly created style.

XAML
Copy Code
<Style TargetType="{x:Type ListBox}" x:Key="ThumbnailListBoxStyle
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type ListBox}
          <WrapPanel IsItemsHost="True" Orientation="Horizontal"
                     Background="{Binding Background}"
                     Margin="{Binding Margin}"
                     ItemWidth="{Binding CellSize.Width}"
                     ItemHeight="{Binding CellSize.Height}
          </WrapPanel>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>


ThumbnailListBoxItemStyle
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Thumbnail > ThumbnailListBoxItemStyle

The following template is used to cancel default selection drawing, because there is a special selection/highlighting logic in the Thumbnail control.

XAML
Copy Code
 <Style TargetType="{x:Type ListBoxItem}" x:Key="ThumbnailListBoxItemStyle
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type ListBoxItem}" >
          <ContentPresenter
            VerticalAlignment="Top"
            HorizontalAlignment="Left"/>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>


ImGearThumbnailItem
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Thumbnail > ImGearThumbnailItem

The following template is used by framework to show ImGearThumbnailItem Class in any Panel control. This data template is only related to ImGearThumbnailItem Class data type and does not depend on the container type. ImGearThumbnailItem Class data template consists of shadow, border, image and label.

XAML
Copy Code
  <!-- Thumbnail Template -->
  <DataTemplate DataType="{x:Type local:ImGearThumbnailItem}
    <Grid
      VerticalAlignment="Top"
      HorizontalAlignment="Left"
      Margin="0"
      >
      <!-- Drop Shadow -->
      <Border
        VerticalAlignment="Top"
        HorizontalAlignment="Left"
        Width="{Binding ParentCtl.ItemWidth}"
        Height="{Binding ParentCtl.ItemHeight}"
        CornerRadius="{Binding ParentCtl.BorderWidth}"
        Background="#55000000"
        Visibility="{Binding ParentCtl.ShadowsVisibility}"
        >
      <!-- Drop Shadow shift and blur effect-->
        <Border.RenderTransform>
          <TranslateTransform X="{Binding ParentCtl.ShadowWidth}" Y="{Binding ParentCtl.ShadowWidth}" />
        </Border.RenderTransform>
        <Border.BitmapEffect>
          <BlurBitmapEffect Radius="{Binding Path=ParentCtl.ShadowWidth}" />
        </Border.BitmapEffect>
      </Border>

      <!aBorder (select and highlight)-->
      <Border
        x:Name="IGThumbnailSelectionBorder"
        VerticalAlignment="Top"
        HorizontalAlignment="Left"
        BorderThickness="{Binding ParentCtl.BorderWidth}"
        BorderBrush="{Binding CurrentBackground}"
        CornerRadius="{Binding ParentCtl.BorderWidth}"
        Background="White"
        Width="{Binding ParentCtl.ItemWidth}"
        Height="{Binding ParentCtl.ItemHeight}
          <StackPanel Orientation="Vertical" Margin=
"{Binding ParentCtl.Interior}
        <!aThumbnail image-->
            <Image Width="{Binding ParentCtl.ImageSize.Width}"
                   Height="{Binding ParentCtl.ImageSize.Height}"
                   VerticalAlignment="Center"
                   HorizontalAlignment="Center"
                   Source ="{Binding Image}"/>
  <!a-Title-->
            <Label Content="{Binding Title}"
                   HorizontalAlignment="Center"
                   VerticalAlignment="Center"
                   Foreground ="{Binding CurrentForeground}"
                   Visibility ="{Binding ParentCtl.TitlesVisibility}"
                   >
            </Label>
          </StackPanel>
       </Border>
    </Grid>
</DataTemplate>


Magnifier
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Magnifier

WPF magnifier control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates, as described in the following sections:

  • ImGearMagnifierCtl
  • ImGearMagnifierPopUpCtl


ImGearMagnifierCtl
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Magnifier > ImGearMagnifierCtl

The following template defines ImGearThumbnailMagnifierCtl Class control. Since ImGearMagnifierCtl Class is an invisible control, its template consists of placeholder and resource section that contains a visual template for ellipse magnifier. Note that this style is turning on in code-behind, so it must be in resource section to find it there.

XAML
Copy Code
<Style TargetType="{x:Type local:ImGearMagnifierCtl}
    <Setter Property="HorizontalAlignment" Value="Left"/>
    <Setter Property="VerticalAlignment" Value="Top"/>
    <Setter Property="Visibility" Value="Collapsed"/>
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type local:ImGearMagnifierCtl}
  <!a-Resources-->
          <ControlTemplate.Resources>
  <!a-Style for ellipse popup magnifier-->
            <Style TargetType="{x:Type local:ImGearMagnifierPopUpCtl}"
x:Key="EllipseMagnifier
              <Setter Property="HorizontalAlignment" Value="Left"/>
              <Setter Property="VerticalAlignment" Value="Top"/>
              <Setter Property="Template
                <Setter.Value>
                  <ControlTemplate
TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
                    <Grid>
                      <Path x:Name="Path"
Width="{Binding ParentCtl.PopupWidth}"
Height="{Binding ParentCtl.PopupHeight}"
Stretch="Fill" StrokeLineJoin="Round"
Stroke="#55000000" Fill="#55000000" >
                        <Path.Data>
                          <EllipseGeometry x:Name="EllipseGeom"
     Center="100,100"
RadiusX="{Binding ParentCtl.PopupWidth}" RadiusY="{Binding ParentCtl.PopupHeight}"/>
                        </Path.Data>
                      </Path>
                      <StackPanel ClipToBounds="True
                        <Image HorizontalAlignment="Center"
Source="{Binding ParentCtl.MagnifiedImage}
                          <Image.Clip>
                            <EllipseGeometry
Center="{Binding Center}"
RadiusX="{Binding ImageRadius.Width}" RadiusY="{Binding ImageRadius.Height}"/>
                          </Image.Clip>
                        </Image>
                      </StackPanel>
                    </Grid>
                  </ControlTemplate>
                </Setter.Value>
              </Setter>
            </Style>
          </ControlTemplate.Resources>
<!--Placeholder-->
          <Border Background="Indigo" CornerRadius="3
            <Label>ImGearMagnifierCtl Control</Label>
          </Border>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>


ImGearMagnifierPopUpCtl
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Magnifier > ImGearMagnifierPopUpCtl

The following template defines style for popup rectangle magnifier window. Consists of border and image that is bound to MagnifiedImage Property of ImGearMagnifierCtl Class.

XAML
Copy Code
<Style TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
    <Setter Property="HorizontalAlignment" Value="Left"/>
    <Setter Property="VerticalAlignment" Value="Top"/>
        <Setter Property="Template
          <Setter.Value>
            <ControlTemplate TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
              <Border
                BorderBrush="#55000000"
                CornerRadius="3"
                BorderThickness="3"
                Background="#55000000"
                Width ="{Binding ParentCtl.PopupWidth}"
                Height="{Binding ParentCtl.PopupHeight}
                <Image Source="{Binding ParentCtl.MagnifiedImage}"/>
              </Border>
            </ControlTemplate>
          </Setter.Value>
        </Setter>
  </Style>


Pan
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Pan

WPF Pan control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates:

  • ImGearPanCtl


ImGearPanCtl
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > XAML GUI Controls and Templates > Pan > ImGearPanCtl

The following template defines ImGearPanCtl Class control.

XAML
Copy Code
<Style TargetType="{x:Type local:ImGearPanCtl}">
 <Setter Property="HorizontalAlignment" Value="Left"/>
 <Setter Property="VerticalAlignment" Value="Top"/>
 <Setter Property="Visibility" Value="Collapsed"/>
 <Setter Property="Template">
  <Setter.Value>
   <ControlTemplate TargetType="{x:Type local:ImGearPanCtl}">
    <ControlTemplate.Resources>
    </ControlTemplate.Resources>
    <Border Background="Indigo" CornerRadius="3">
     <Label>ImGearPanCtl Control</Label>
    </Border>
   </ControlTemplate>
  </Setter.Value>
 </Setter>
</Style>


Using ImageGear.Windows.Controls Namespace
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace

The ImageGear.Windows.Controls Namespace provides WPF PageView, Annotation, UI and other common controls to simplify development of XAML based applications.

This section provides information about the following:

  • Using ImageGear.Windows.Controls Namespace
    • Auto Update
    • Context Menu
    • Toolbar
      • Annotation Mouse Tools
      • Image Mouse Tools
    • Annotations
      • Custom Annotations
        • ImGearAnnotatorMarkController
        • ImGearAnnotatorRectangleController
        • ImGearAnnotatorPolyController
        • Custom Mark Properties Window
    • Thumbnail Control
      • Loading Thumbnails
        • Loading Thumbnails in XAML
        • Loading Thumbnails in Code-Behind
        • Loading All Pages of Multi-Page Files
      • Thumbnail Items
      • ART Marks in Thumbnails
      • Thumbnail Scrolling
      • Thumbnail Selection
    • DICOM Multi-Planar Reconstruction


Auto Update
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Auto Update

The PageView control contains the UpdateMode property, which is set to Manual by default and can be set to True to enable the auto-update functionality. If the UpdateMode property is set to Automatic, you do not need to call the Update method in your code when changing display settings or annotations. The PageView control will automatically display any changes that are made to display settings or annotations. It is still necessary to call Update manually when modifying or processing the PageView.Display.Page because changes in ImGearPage do not currently cause an automatic update.


Context Menu
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Context Menu

A context menu is shown by default when right-clicking on the PageView control. When right-clicking on the image, a context menu is displayed with image settings such as zoom settings, antialiasing, and resampling. The PageView context menu can be disabled by setting the ContextMenu property to null. You could also override the ContextMenuOpening event to handle this event however you want.

If you reference the ImageGear.Windows.Controls.Art.dll in your project, then a context menu that corresponds to the specific type of annotation mark will be displayed when clicking on an annotation mark. This context menu contains menu items such as the width and style of a line, for example, if you right-click on a line annotation mark. This context menu also contains the common mark menu items that are available in the Annotator context menu (such as Delete, Copy, and Properties) as well as a Page sub-menu with the default image context menu items. If ImageGear.Windows.Controls.Art.dll is not referenced or located by your application, then the image context menu will be displayed when clicking on an annotation mark.

ImageGear.Windows.Controls.Art.dll replaces the ImageGear.Art.Windows.Controls namespace/assembly (which includes the Annotator/ToolBarAnnotator controls), so that the annotation user interface can now be accessed through PageView instead of a separate Annotator/ToolBarAnnotator control. If you are still using Annotator or ToolBarAnnotator, the behavior will be the same as in previous versions of ImageGear (i.e., the PageView context menu will not be displayed; the context menu that Annotator displays will still be displayed when right-clicking on an annotation).

Customizing the Context Menu

XAML for the default context menu is provided in the WPF Office sample. This XAML can be copied to your project’s XAML and modified to customize the PageView context menu. Numerous commands are available in PageView so the action that occurs when selecting a context menu item can be easily specified. The PageView context menu supports objects of type MenuItem and Separator.

The context menu functionality is included in the ImGearPageViewContextMenu class, which derives from the ContextMenu class. The PageView.ContextMenu property can be set to an instance of the ImGearPageViewContextMenu class (which is done internally by default to create the default context menu) but also still supports simply being set to a new instance of the ContextMenu class.

The ImGearPageViewContextMenu class can be used to specify which context menu items appear when right-clicking on the PageView image or when right clicking on a specific type of annotation mark. The ImGearPageViewContextMenu.PageItems property contains the collection of menu items that are displayed when right-clicking on the PageView image. ImGearPageViewContextMenu.AnnotationItems contains a collection property for each annotation mark type (ImGearPageViewContextMenu.AnnotationItems.Curve, ImGearPageViewContextMenu.AnnotationItems.Ellipse, etc.), which can be used to specify the menu items that are displayed when right-clicking on an annotation mark of that type.

ImGearPageViewContextMenu.AnnotationItems also contains a Common property, which can be used to specify context menu items that are shown when clicking on any annotation mark type. These are shown under the specific annotation mark context menu items. If menu items are added to ImGearPageViewContextMenu.Items, these are displayed at the bottom of the context menu.

The ImGearPageViewContextMenu.Custom property can be used to specify the context menu items that are displayed when right clicking on a custom mark, as demonstrated in the WPF ART sample. This property can be set to a dictionary of object collections, where each object is either a MenuItem or a Separator. The name of a custom mark class that you have registered should be used for the key of an object collection in the dictionary.

To display a mark properties window for your custom mark (when the Properties context menu item is selected, or when the PageView.ShowMarkPropertiesWindow method is called for a custom mark), you can override the GetPropertiesWindow method of your custom mark class that derives from ImGearAnnotatorMarkController, ImGearAnnotatorRectangleController or ImGearAnnotatorPolyController. This method will need to return an instance of a class that implements IImGearMarkEditorWindow.


Toolbar
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Toolbar

The PageView MouseTool property can be set to specify the current mouse tool. The mouse tool settings can be accessed through the MouseToolSettings property.

The following topics are discussed in this section:

  • Annotation Mouse Tools
  • Image Mouse Tools

Default Toolbar

The ImGearPageViewToolbar control is a PageView toolbar containing the default tools. It can be bound to a PageView control using the following XAML:

XAML Example
Copy Code
<igwc:ImGearPageViewToolbar x:Name="igToolBar" MouseTool="{Binding ElementName=imGearPageView, Path=MouseTool, Mode=TwoWay}" />

The toolbar contains the following default tools:

  • None
  • Hand Pan
  • Select
  • Rectangle Zoom
  • Zoom In
  • Zoom Out
  • Magnifier
  • Select Mark
  • Create Rectangle Mark
  • Create Ellipse Mark
  • Create Line Mark
  • Create Polyline Mark
  • Create Freehand Mark
  • Create Polygon Mark
  • Create Text Mark
  • Create Ruler Mark
  • Create Poly Ruler Mark
  • Create Point Mark
  • Create Curve Mark
  • Create Image Mark
  • Create Protractor Mark

Customizing the Toolbar

You can customize the toolbar and specify the tools it contains, the order of the tools, the images, the tool tips, etc., by setting its ItemsSource to a collection of ImGearPageViewTools, as shown in the code below. This is also demonstrated in the ART sample which has an additional toolbar item for creating a custom mark.

The toolbar in the example code below contains four items: Select Mark, Create Rectangle Mark, Create Sector Mark, and Hand Pan. The MouseTool property of each ImGearPageViewTool is set to the PageView MouseTool enum member that the bound PageView MouseTool should be set to when the toolbar item is selected. You can specify Custom if you want the selection of an item to have no effect on the bound PageView MouseTool (for example, if you are using the SelectionChanged event to handle the selection of a toolbar item).

The Image property in the code below uses the ImGearImageConverter class to load the image for a toolbar item from a FrameworkElement. These elements are specified in App.xaml, shown further below. The Hand Pan toolbar item in the XAML below provides an example of setting the Image to an image file resource (hand.png) in the project (instead of using an image converter).

The Create Sector Mark toolbar item specified in the XAML below uses custom mark functionality, which is demonstrated in the ART sample. The CustomMarkController property of ImGearPageViewTool must be set to the string that is passed to the ImGearAnnotatorMarkController RegisterCustomController method used to register the custom mark. In the XAML below, the SelectedCustomMarkController property of an ImGearPageViewToolbar control is bound to the CustomMarkController property of a PageView control so that the PageView’s custom mark controller is set to the sector mark controller when the Create Sector Mark toolbar item is selected.

XAML Example
Copy Code

<Window.Resources>
<igwc:ImGearImageConverter x:Key="imageConverter" />
</Window.Resources>

…

<igwc:ImGearPageViewToolbar x:Name="igToolBar" MouseTool="{Binding ElementName=imGearPageView, Path=MouseTool, Mode=TwoWay}" SelectedCustomMarkController="{Binding ElementName=imGearPageView, Path=CustomMarkController, Mode=TwoWay}" >
<igwc:ImGearPageViewToolbar.ItemsSource>
<igwc:ImGearPageViewToolCollection>
<igwc:ImGearPageViewTool MouseTool="SelectMark" ToolTip="Select Mark" Image="{Binding RelativeSource={RelativeSource Self}, Path=MouseTool, Converter={StaticResource imageConverter}, ConverterParameter={StaticResource ResourceKey=SelectMark}}" />
<igwc:ImGearPageViewTool MouseTool="CreateRectangleMark" ToolTip="Create Rectangle Mark" Image="{Binding RelativeSource={RelativeSource Self}, Path=MouseTool, Converter={StaticResource imageConverter}, ConverterParameter={StaticResource ResourceKey=CreateRectangleMark}}" />
<igwc:ImGearPageViewTool MouseTool="CreateCustomMark" ToolTip="Create Sector Mark" Image="{Binding RelativeSource={RelativeSource Self}, Path=MouseTool, Converter={StaticResource imageConverter}, ConverterParameter={StaticResource ResourceKey=CreateSectorMark}}" CustomMarkController="SectorMark" />
<igwc:ImGearPageViewTool MouseTool="HandPan" ToolTip="Hand Pan" Image="hand.png" />
</igwc:ImGearPageViewToolCollection>
</igwc:ImGearPageViewToolbar.ItemsSource>
</igwc:ImGearPageViewToolbar>

The following application resources are specified in App.xaml, as demonstrated in the ART sample:

XAML Example
Copy Code

<Application.Resources>
<Canvas x:Key="SelectMark" Width="30" Height="30">
<Rectangle Margin="13,16,5,6" Width="11" Height="7" StrokeThickness="1.5" Fill="Red" Stroke="Black" Opacity="0.7">
</Rectangle>
<Ellipse Margin="7,7,4,6" Width="12" Height="8" StrokeThickness="1.5" Fill="Yellow" Stroke="Black" Opacity="0.7">
</Ellipse>
<Rectangle Margin="4" Width="22" Height="22" StrokeThickness="1.5" StrokeDashArray="2,2" Stroke="DarkGray" >
</Rectangle>
</Canvas>
<Canvas x:Key="CreateTextMark" Width="30" Height="30">
<Rectangle Margin="4" Width="22" Height="22" StrokeThickness="0" Fill="Yellow">
</Rectangle>
<TextBlock Margin="6, 6" FontSize="14">ab</TextBlock>
<Rectangle Margin="24,6,0,0" Width="2" Height="20" Fill="Black"/>
</Canvas>
<Canvas x:Key="CreateLineMark" Width="30" Height="30">
<Line X1="4" Y1="5" X2="26" Y2="27" Stroke="DarkMagenta"></Line>
<Line X1="4" Y1="4" X2="26" Y2="26" Stroke="Magenta"></Line>
</Canvas>
<Canvas x:Key="CreateFreehandMark" Width="30" Height="30">
<Path Stroke="SeaGreen" StrokeThickness="1.5">
<Path.Data>
<PathGeometry>
<PathGeometry.Figures>
<PathFigureCollection>
<!-- The StartPoint specifies the starting point of the first curve. -->
<PathFigure StartPoint="4,4">
<PathFigure.Segments>
<PathSegmentCollection>
<PolyBezierSegment Points="29,4 -5,27 26,26" />
</PathSegmentCollection>
</PathFigure.Segments>
</PathFigure>
</PathFigureCollection>
</PathGeometry.Figures>
</PathGeometry>
</Path.Data>
</Path>
</Canvas>
<Canvas x:Key="CreatePointMark" Width="30" Height="30">
<Ellipse Margin="12,13,4,6" Width="5" Height="5" StrokeThickness="1.5" Fill="#FF800000" Stroke="#FF800000" Opacity="0.7">
</Ellipse>
</Canvas>
<Canvas x:Key="CreateCurveMark" Width="30" Height="30">
<Path Stroke="#FF00FFFF" StrokeThickness="1.5">
<Path.Data>
<PathGeometry>
<PathGeometry.Figures>
<PathFigureCollection>
<PathFigure StartPoint="4,26">
<PathFigure.Segments>
<PathSegmentCollection>
<PolyBezierSegment Points="8,8 22,22 26,4" />
</PathSegmentCollection>
</PathFigure.Segments>
</PathFigure>
</PathFigureCollection>
</PathGeometry.Figures>
</PathGeometry>
</Path.Data>
</Path>
</Canvas>
<Canvas x:Key="CreateRectangleMark" Width="30" Height="30">
<Rectangle Margin="4,6,4,6" Width="22" Height="18" StrokeThickness="1.5" Fill="Red" Stroke="Black" Opacity="0.7">
</Rectangle>
</Canvas>
<Canvas x:Key="CreateEllipseMark" Width="30" Height="30">
<Ellipse Margin="4,6,4,6" Width="22" Height="18" StrokeThickness="1.5" Fill="Yellow" Stroke="Black" Opacity="0.7">
</Ellipse>
</Canvas>
<Canvas x:Key="CreatePolygonMark" Width="30" Height="30">
<Polygon StrokeThickness="1.5" Fill="Blue" Stroke="Black" Opacity="0.7" Points="8,9 20,6 26,20 6,24" >
</Polygon>
</Canvas>
<Canvas x:Key="CreatePolylineMark" Width="30" Height="30">
<Polyline StrokeThickness="1.5" Stroke="Green" Opacity="1" Points="10,4 5,23 25,20 12,15" >
</Polyline>
</Canvas>
<Canvas x:Key="CreateImageMark" Width="30" Height="30">
<Image Source="image.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="CreateRulerMark" Width="30" Height="30">
<Rectangle Margin="2, 10" Width="26" Height="12" StrokeThickness="1" Fill="LightGoldenrodYellow" Stroke="Black"/>
<Line X1="5.5" Y1="21" X2="5.5" Y2="18" Stroke="Black"></Line>
<Line X1="8.5" Y1="21" X2="8.5" Y2="18" Stroke="Black"></Line>
<Line X1="11.5" Y1="21" X2="11.5" Y2="16" Stroke="Black"></Line>
<Line X1="14.5" Y1="21" X2="14.5" Y2="18" Stroke="Black"></Line>
<Line X1="17.5" Y1="21" X2="17.5" Y2="18" Stroke="Black"></Line>
<Line X1="20.5" Y1="21" X2="20.5" Y2="18" Stroke="Black"></Line>
<Line X1="23.5" Y1="21" X2="23.5" Y2="16" Stroke="Black"></Line>
<Line X1="26.5" Y1="21" X2="26.5" Y2="18" Stroke="Black"></Line>
</Canvas>
<Canvas x:Key="CreatePolyRulerMark" Width="30" Height="30">
<Rectangle Margin="6.5, 7.5" StrokeThickness="0.5" Fill="LightGoldenrodYellow" Stroke="Black" Width="22" Height="7"/>
<Rectangle StrokeThickness="0.5" Fill="LightGoldenrodYellow" Stroke="Black" Margin="10.5, 6.5" Width="22" Height="7">
<Rectangle.RenderTransform>
<RotateTransform CenterX="0" CenterY="0" Angle="45" />
</Rectangle.RenderTransform>
</Rectangle>
<Rectangle StrokeThickness="0.5" Fill="LightGoldenrodYellow" Stroke="Black" Margin="2.5, 18.5" Width="22" Height="7"/>
<Ellipse Stroke="DarkGray" Width="2" Height="2" Margin="9.5, 10.5"></Ellipse>
<Ellipse Stroke="DarkGray" Width="2" Height="2" Margin="20.5, 21.5"></Ellipse>
</Canvas>
<Canvas x:Key="CreateProtractorMark" Width="30" Height="30">
<Canvas.Clip>
<RectangleGeometry Rect="6,0,30,25"></RectangleGeometry>
</Canvas.Clip>
<Line X1="7" Y1="24" X2="7" Y2="6" Stroke="DarkRed" StrokeThickness="2"></Line>
<Line X1="7" Y1="24" X2="25" Y2="24" Stroke="DarkRed" StrokeThickness="2"></Line>
<Ellipse Width="18" Height="18" Stroke="DarkRed" Canvas.Left="-1" Canvas.Top="13"></Ellipse>
</Canvas>
<Canvas x:Key="CreateSectorMark" Width="30" Height="30">
<Path Stroke="Black" StrokeThickness="1.5" Fill="Orange">
<Path.Data>
<PathGeometry>
<PathFigure StartPoint="15 15" IsClosed="True">
<LineSegment Point="25 15"/>
<ArcSegment Size="10 10" Point="15 5" SweepDirection="ClockWise" IsLargeArc="True" />
</PathFigure>
</PathGeometry>
</Path.Data>
</Path>
</Canvas>
<Canvas x:Key="Select" Width="30" Height="30">
<Rectangle Margin="4" Width="22" Height="22" StrokeThickness="1.5" StrokeDashArray="2,2" Stroke="DarkGray" >
</Rectangle>
</Canvas>
<Canvas x:Key="Magnifier" Width="30" Height="30">
<Image Source="magnify.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="RectangleZoom" Width="30" Height="30">
<Rectangle Margin="4" Width="22" Height="22" StrokeThickness="1.5" StrokeDashArray="2,2" Stroke="DarkGray" >
</Rectangle>
<Image Source="zoom.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="HandPan" Width="30" Height="30">
<Image Source="hand.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="None" Width="30" Height="30">
<Image Source="arrow.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="ZoomIn" Width="30" Height="30">
<Image Source="zoomin.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
<Canvas x:Key="ZoomOut" Width="30" Height="30">
<Image Source="zoomout.png" Margin="4,6,4,6" Width="22"/>
</Canvas>
</Application.Resources>


Annotation Mouse Tools
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Toolbar > Annotation Mouse Tools

To access the annotation toolbar functionality in the PageView control:

  1. Add a reference to ImageGear.Windows.Controls.Art.dll in your project (and distribute this assembly with your application).
  2. Do one of the following:
    • Use the toolbar as described in the Toolbar section (which will change the PageView.MouseTool property when a toolbar button is clicked).

    • Set the PageView mouse tool programmatically by setting the PageView.MouseTool property to an annotation mouse tool setting.

      For example, if you set the MouseTool property to CreateRectangleMark, the user can then use the mouse to create a rectangle mark. You can set the PageView.MouseTool property to SelectMark so that the user can edit marks, such as moving them or resizing them.

For more information on the ImageGear.Windows.Controls.Art assembly and annotation creation, editing, and settings, see the Annotations section.


Image Mouse Tools
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Toolbar > Image Mouse Tools

The PageView MouseTool can be set to the image mouse tools described below. The settings for each of these mouse tools can be accessed through the corresponding property of the PageView MouseToolSettings property.

Hand Pan

When the MouseTool property is set to HandPan, the mouse can be used to scroll the image by clicking on the image and dragging the mouse.

Magnifier

A magnified view of a portion of the image is displayed in a popup window under the mouse pointer when this mouse tool is selected and the mouse is clicked on the image.

ZoomIn

When the PageView MouseTool property is set to ZoomIn, the image is zoomed in when it is clicked on.

ZoomOut

When the PageView MouseTool property is set to ZoomOut, the image is zoomed out when it is clicked on.

RectangleZoom

When the PageView MouseTool property is set to RectangleZoom, a rectangular region of the image can be selected by clicking on the image and dragging the mouse. When the mouse button is released, the image is zoomed to the selected region.

The PageView.MouseToolSettings.RectangleZoom.SelectionStyle property can be used to set a Style for the selection rectangle and to specify its look.

Select

When the PageView MouseTool property is set to Select, a rectangular region of the image can be selected by clicking on the image and dragging the mouse. When the mouse button is released, the selected region continues to be displayed until the next time the mouse is clicked. The PageView.MouseToolSettings.Select.SelectionRectangle property returns an ImGearRectangle (in image coordinates) for the selected region. The coordinates of this ImGearRectangle can be used, for example, to set an ImGearRasterPage’s ROI property to specify a region of interest for processing functions.

The PageView.MouseToolSettings.Select.SelectionStyle property can be used to set a Style for the selection rectangle and to specify its look.


Annotations
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations

All annotation user interface functionality can be accessed through the PageView control by adding a reference in your project to ImageGear.Windows.Controls.Art.dll. This includes functionality for setting the PageView.MouseTool property so that the user can use the mouse to create and edit annotation marks. For information on using a toolbar to select the PageView mouse tool, see the Toolbar section.

The ImageGear.Windows.Controls.Art assembly also provides functionality for accessing the annotation context menu items in the PageView context menu, which is described in the Context Menu section.

This section provides information about the following:

  • Annotations
    • Custom Annotations
      • ImGearAnnotatorMarkController
      • ImGearAnnotatorRectangleController
      • ImGearAnnotatorPolyController
      • Custom Mark Properties Window

Mouse Tool and Mode

You can do either of the following:

  • Use the toolbar as described in the Toolbar section to set the PageView.MouseTool property when an annotation toolbar button is clicked.
  • Set the PageView mouse tool programmatically by setting the PageView.MouseTool property to an annotation mouse tool setting. For example:
    • If you set the MouseTool property to CreateRectangleMark, the user can then use the mouse to create a rectangle mark.
    • If you set the PageView.MouseTool property to SelectMark, the user can edit marks, such as moving them or resizing them, if the PageView.AnnotationMode property is set to Edit. If the PageView.AnnotationMode property is set to View, then editing annotations using the mouse is disabled.

If you do not reference ImageGear.Windows.Controls.Art.dll in your project, then the PageView.AnnotationMode property will have no effect, and if the PageView.MouseTool property is set to an annotation mouse tool, the behavior will be the same as setting the MouseTool property to None. The PageView.AnnotationsAreAvailable method will return true if your application is referencing ImageGear.Windows.Controls.Art.dll and is able to locate it.

Mouse Tool Settings

You can use the PageView.MouseToolSettings.Annotation property to access the mouse tool settings for annotation marks.

The PageView.MouseToolSettings.Annotation.Templates property provides a property for each mark type, which can be set to specify the properties of the mark when it is added using the mouse. These template properties only affect mark creation if PageView.MouseToolSettings.Annotation.DrawPreview is set to false.

The SelectionStyle property can be used to set a Style for the annotation selection rectangle to specify its look. For example, the code below demonstrates how to create a SolidColorBrush with an opacity and color, create a Style, and add a Setter for the Brush Stroke property.

C# Example
Copy Code
System.Windows.Media.Color annColor = System.Windows.Media.Color.FromArgb(myOpacity, myColor.R, myColor.G, myColor.B);
System.Windows.Media.Brush annBrush = new System.Windows.Media.SolidColorBrush(annColor);
Style selectStyle = new Style(typeof(System.Windows.Shapes.Rectangle));
Setter setterStroke = new Setter(System.Windows.Shapes.Rectangle.StrokeProperty, annBrush);
selectStyle.Setters.Add(setterStroke);
pageView.MouseToolSettings.Annotation.SelectionStyle = selectStyle;

PageView.MouseToolSettings.Annotation also provides properties for:

  • Specifying the size of the mark handles that appear when a mark is selected
  • Specifying the double-click threshold
  • Enabling polymark auto-rollback and polyline auto-close
  • Resetting the mouse tool to SelectMark after a mark is created
  • Specifying the interaction area for editing annotations
  • Enabling the text clipboard

There are also preview mark settings, which are described in the next section.

In-Progress Mark and Preview Mark

When using the mouse to create an annotation mark, by default an "in-progress mark" is drawn as the mark will appear when it is added. This in-progress mark can be accessed through the PageView.InProgressMark property.

To instead draw a preview mark during mark creation, set the PageView.MouseToolSettings.Annotation.DrawPreview property to true. The preview mark is drawn using the PageView.MouseToolSettings.Annotation.CreatorColor and PageView.MouseToolSettings.Annotation.CreatorOpacity settings.

Annotation Events

PageView contains MarkCreating, MarkRemoved, and MarkChanged events as well as mouse events that can be used to programmatically handle when a mark is edited, clicked, etc. You can access the ImGearARTMark at the current mouse position by using the PageView.Display.HitTestCanvas method as shown in the following code.

C# Example
Copy Code
Point mousePoint = e.GetPosition(pageView);

if (pageView.Display != null)
{
    int markID = -1;
    if (pageView.Display.ARTPage != null)
    {
        ImGearARTPage art = (ImGearARTPage)pageView.Display.ARTPage;
        ImGearDoublePoint[] pnts = new ImGearDoublePoint[]
            {
            new ImGearDoublePoint(mousePoint.X, mousePoint.Y),
            new ImGearDoublePoint(mousePoint.X - 1, mousePoint.Y),
            new ImGearDoublePoint(mousePoint.X + 1, mousePoint.Y),
            new ImGearDoublePoint(mousePoint.X - 2, mousePoint.Y),
            new ImGearDoublePoint(mousePoint.X + 2, mousePoint.Y),
            new ImGearDoublePoint(mousePoint.X, mousePoint.Y - 1),
            new ImGearDoublePoint(mousePoint.X, mousePoint.Y + 1),
            new ImGearDoublePoint(mousePoint.X, mousePoint.Y - 2),
            new ImGearDoublePoint(mousePoint.X, mousePoint.Y + 2)
            };

        for (int i = 0; i < pnts.Length; i++)
        {
            markID = pageView.Display.HitTestCanvas(
                pnts[i], pageView, pageView.Canvas, 0, 0);
            if (markID >= 0) break;
        }

Using Keyboard Input for Different Annotation Resize Behavior

The Shift and Ctrl keys can be used to affect how a mark is resized.

  • If you hold the Ctrl key while resizing a mark, then the center point of the mark will be fixed.
  • If you hold the Shift key while resizing a mark, then the aspect ratio of the mark will be fixed.
  • If you hold both the Ctrl and Shift keys, then the center point and aspect ratio of the mark will be fixed.


Custom Annotations
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations > Custom Annotations

Custom annotations or custom marks (i.e., classes derived from ImGearARTCustomMark) can be modified with the mouse by using the ImGearAnnotatorMarkController.RegisterCustomController(string customTypeName, ImGearAnnotatorMarkController controller) method to register a class that derives from ImGearAnnotatorMarkController, ImGearAnnotatorRectangleController, or ImGearAnnotatorPolyController. The GetCustomController(string customTypeName) method can be used to get a registered custom mark annotator controller. A custom sector mark is demonstrated in the ART sample.

You could include a toolbar item for your custom mark as demonstrated in the ART sample. To set the mouse tool to create the custom mark, you need to set the PageView.MouseTool property to CreateCustomMark and set the PageView.CustomMarkController property to the key for the custom mark annotator controller, which is the string you passed to the ImGearARTCustomController.RegisterCustomMark method when registering your custom mark annotator controller.

See the ImGearAnnotatorMarkController, ImGearAnnotatorRectangleController, and ImGearAnnotatorPolyController sections for information regarding overriding the annotator controller methods, such as mark creation methods.

The following topics are discussed in this section:

  • ImGearAnnotatorMarkController
  • ImGearAnnotatorRectangleController
  • ImGearAnnotatorPolyController
  • Custom Mark Property Window


ImGearAnnotatorMarkController
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations > Custom Annotations > ImGearAnnotatorMarkController

The abstract ImGearAnnotatorMarkController class provides methods that can be overridden to specify the behavior of a custom mark. You can instead derive from the ImGearAnnotatorRectangleController or ImGearAnnotatorPolyController class to inherit rectangular or point-based mark functionality.

You must override the virtual CreateInProgressMark(ImGearAnnotatorCreateMarkData createMarkData) method to create a mark that is initially set as the PageView in-progress mark. The in-progress mark is the mark that is shown while creating the mark using the mouse, before the mark is added to the ART page. The createMarkData parameter contains data associated with the creation process, such as whether or not the user double-clicked the mouse or any custom data you need to keep track of the state of the creation process.

You can override the virtual DrawInProgressMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method to modify the in-progress mark while the user is moving or clicking the mouse during the mark creation process. The points parameter contains points indicating the locations in which the user has clicked the mouse.

You must override the virtual CanCreateMark(IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method to specify when the in-progress mark should be added to the ART page. For example, if you want to add your mark when the user double clicks, you can return the value of the createMarkData.IsDoubleClick property.

By default the virtual CreateMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method returns the in-progress mark, which is then added to the ART page.

The virtual ManageCursor(ImGearPoint point, ImGearDoublePoint mousePoint, ImGearAnnotatorMarkControllerData markControllerData) method can be overridden to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point. The properties of the ImGearAnnotatorMarkControllerData parameter, which include Cursor, PointID, and ResizeType, can be set to update the cursor, etc. The static ImGearAnnotatorMarkController.UpdateCursor method can be used to set the ImGearAnnotatorMarkControllerData.Cursor property to the Hand cursor if the mouse is over the specified point. The virtual Resize(ImGearARTMark mark, ImGearPoint point, ImGearAnnotatorMarkControllerData markControllerData) method can be used to resize the mark.

The ImGearAnnotatorMarkController class also has a virtual GetPropertiesWindow method that can be overridden to return a properties window for a custom mark. By default the PageView ShowMarkPropertiesWindow method and ShowMarkPropertiesWindow command will have no effect for a custom mark because the ImGearAnnotatorMarkController ShowPropertiesWindow method returns null. To show a properties window for a custom mark, you will need to override the ShowPropertiesWindow method to return an instance of a class that is derived from IImGearMarkEditorWindow. Information on the custom mark Properties context menu item and other custom mark context menu items can be found in the Context Menu section.


ImGearAnnotatorRectangleController
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations > Custom Annotations > ImGearAnnotatorRectangleController

The abstract ImGearAnnotatorRectangleController class derives from ImGearAnnotatorMarkController and can be used as a base class for rectangular marks.

You must override the virtual CreateInProgressMark(ImGearAnnotatorCreateMarkData createMarkData) method to create a mark that is initially set as the PageView in-progress mark. The in-progress mark is the mark that is shown while creating the mark using the mouse, before the mark is added to the ART page. The createMarkData parameter contains data associated with the creation process, such as whether or not the user double-clicked the mouse or any custom data you need to keep track of the state of the creation process.

You can override the virtual DrawInProgressMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method to modify the in-progress mark while the user is moving or clicking the mouse during the mark creation process. The points parameter contains points indicating the locations in which the user has clicked the mouse.

This class overrides the CanCreateMark(IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method so that it returns true if 2 points have been specified. You can override this method to specify when the in-progress mark should be added to the ART page.

By default the virtual CreateMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method returns the in-progress mark, which is then added to the ART page.

This class overrides the ManageCursor method so that the cursor is changed to the Hand cursor if the mouse is over one of the eight selection handle points in the specified bounds. This class overrides the Resize method to resize the rectangular mark based on the position specified in the point parameter and the ImGearAnnotatorMarkControllerData parameter. This class contains a virtual UpdateBounds(ImGearARTMark mark, IImGearRectangle rect) method which can be used to update the location and size properties of your custom mark by getting those values from the rect parameter. You must override the UpdateBounds method to enable resizing your custom mark.

By default the PageView ShowMarkPropertiesWindow method and ShowMarkPropertiesWindow command will have no effect for a custom mark because the ImGearAnnotatorMarkController ShowPropertiesWindow method returns null. To show a properties window for a custom mark, you will need to override the ShowPropertiesWindow method to return an instance of a class that is derived from IImGearMarkEditorWindow. Information on the custom mark Properties context menu item and other custom mark context menu items can be found in the Context Menu section.


ImGearAnnotatorPolyController
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations > Custom Annotations > ImGearAnnotatorPolyController

The abstract ImGearAnnotatorPolyController class derives from ImGearAnnotatorMarkController and can be used as a base class for point-based marks.

You must override the virtual CreateInProgressMark(ImGearAnnotatorCreateMarkData createMarkData) method to create a mark that is initially set as the PageView in-progress mark. The in-progress mark is the mark that is shown while creating the mark using the mouse, before the mark is added to the ART page. The createMarkData parameter contains data associated with the creation process, such as whether or not the user double-clicked the mouse or any custom data you need to keep track of the state of the creation process.

You can override the virtual DrawInProgressMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method to modify the in-progress mark while the user is moving or clicking the mouse during the mark creation process. The points parameter contains points indicating the locations in which the user has clicked the mouse.

This class overrides the CanCreateMark(IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method so that it returns true if 2 or more points have been specified and the mouse was double-clicked. You can override this method to specify when the in-progress mark should be added to the ART page.

By default the virtual CreateMark(ImGearARTMark mark, IEnumerable<ImGearPoint> points, ImGearAnnotatorCreateMarkData createMarkData) method returns the in-progress mark, which is then added to the ART page.

This class overrides the ManageCursor method to manage the cursor for point-based marks. You must override the Resize method to enable resizing your custom mark.

By default the PageView ShowMarkPropertiesWindow method and ShowMarkPropertiesWindow command will have no effect for a custom mark because the ImGearAnnotatorMarkController ShowPropertiesWindow method returns null. To show a properties window for a custom mark, you will need to override the ShowPropertiesWindow method to return an instance of a class that is derived from IImGearMarkEditorWindow. Information on the custom mark Properties context menu item and other custom mark context menu items can be found in the Context Menu section.


Custom Mark Properties Window
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Annotations > Custom Annotations > Custom Mark Properties Window

To display a mark properties window for your custom mark (when the Properties context menu item is selected, or when the PageView.ShowMarkPropertiesWindow method is called for a custom mark), you can override the GetPropertiesWindow method of your custom mark class that derives from ImGearAnnotatorMarkController or ImGearAnnotatorRectangleController. This method will need to return an instance of a class that implements IImGearMarkEditorWindow. Information on the custom mark Properties context menu item and other custom mark context menu items can be found in the Context Menu section.


Thumbnail Control
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control

The ImGearThumbnailList class can be used to manage thumbnail generation and viewing.

This section contains details on how to work with thumbnails:

  • Loading Thumbnails
  • Thumbnail Items
  • ART Marks in Thumbnails
  • Thumbnail Scrolling
  • Thumbnail Selection


Loading Thumbnails
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Loading Thumbnails

You can load thumbnails by setting the ItemsSource property of the ImGearThumbnailList control to a collection of ImGearThumbnailPages, filename strings, Streams, ImGearDocuments, or ImGearPages in XAML or in code. The ImGearThumbnailPage class can be used to specify a Caption, PageNumber, and Source (filename string, Stream, ImGearDocument, or ImGearPage).

This section contains details on additional ways to load thumbnails and all pages of multi-page files:

  • Loading Thumbnails in XAML
  • Loading Thumbnails in Code-Behind
  • Loading All Pages of Multi-Page Files


Loading Thumbnails in XAML
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Loading Thumbnails > Loading Thumbnails in XAML

The code below demonstrates how to set the ItemsSource to a collection of ImGearThumbnailPages. The ImGearThumbnailPageExtension class must be used to specify an ImGearThumbnailPage in XAML. The ImGearThumbnailPageCollection class in the XAML below must be specified in the code-behind as follows:

C# Example
Copy Code
public class ThumbnailPageCollection : ObservableCollection<object> { }
XAML Example
Copy Code
…
    <Window.Resources>
        <custom:ThumbnailPageCollection x:Key="thumbnails">
            <igwc:ImGearThumbnailPageExtension Caption="benefits" Source="c:\images\benefits.tif"/>
            <igwc:ImGearThumbnailPageExtension Caption="multi.tif Page 3" Source="c:\images\multi.tif" PageNumber="2"/>
            <igwc:ImGearThumbnailPageExtension Caption="bird" Source="c:\images\bird.jpg"/>
            <igwc:ImGearThumbnailPageExtension Caption="multi.tif Page 5" Source="c:\images\multi.tif" PageNumber="4"/>
        </custom:ThumbnailPageCollection>
    </Window.Resources>
…
<igwc:ImGearThumbnailList ItemsSource="{StaticResource thumbnails}" Name="thumbnailList"/>


Loading Thumbnails in Code-Behind
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Loading Thumbnails > Loading Thumbnails in Code-Behind

The code below demonstrates how to show an open file dialog and set the ItemsSource to a collection containing a filename string for each selected file:

C# Example
Copy Code
        OpenFileDialog ofd = new OpenFileDialog();
        ofd.Multiselect = true;
        ofd.ShowDialog();

        ObservableCollection<string> thumbnailFiles = new ObservableCollection<string>();
        foreach (string fileInfo in ofd.FileNames)
        {
            thumbnailFiles.Add(fileInfo);
        }
        thumbnailList.ItemsSource = thumbnailFiles;


Loading All Pages of Multi-Page Files
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Loading Thumbnails > Loading All Pages of Multi-Page Files

The ImGearThumbnailPage class can be used to specify specific pages of a multi-page file. To convert all pages of a multi-page file to ImGearThumbnailPages, you can use the ImGearThumbnailMultiPageAdapter class. This class can convert a collection of filename strings, Streams, or ImGearDocuments to a collection of ImGearThumbnailPages. The code below demonstrates how to use the ImGearThumbnailMultiPageAdapter to convert a collection of filename strings to a collection of ImGearThumbnailPages:

XAML Example
Copy Code
    <Window.Resources>
        <!--A list of filename strings can be specified as follows.-->
        <custom:FileNames x:Key="fileNames">
            <sys:String>c:\images\bird.jpg</sys:String>
            <sys:String>c:\images\benefits.tif</sys:String>
            <sys:String>c:\images\multi.tif</sys:String>
            <sys:String>c:\images\window.jpg</sys:String>
        </custom:FileNames>
        <!--The multipage adapter can be used to convert source multipage documents to separate ImGearThumbnailPages.-->
        <igwc:ImGearThumbnailMultiPageAdapter x:Key="adapter" ItemsSource="{StaticResource fileNames}"/>

    </Window.Resources>
…
    <!--Use the multipage adapter specified in the resources above to load all pages of multipage files.-->
    <igwc:ImGearThumbnailList ItemsSource="{StaticResource adapter}" Name="thumbnailList" />
…

C# Example
Copy Code
// The FileNames class derives from a List of strings and is specified in the code-behind as shown below.
public class FileNames : List<string> { }


Thumbnail Items
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Thumbnail Items

The container for each thumbnail item is an ImGearThumbnailListItem. The ImGearThumbnailList control uses an ImGearVirtualizingWrapPanel so that items are only generated when visible. The CacheItemContainers property is true by default so that once an item container is generated, it remains in memory so that the item appears immediately when scrolled back into view. The CacheItemContainers property can be set to false to only cache the thumbnail images and destroy the item containers when items are scrolled out of view; this option uses less memory but there is a small delay when displaying cached thumbnails that are scrolled back into view. During generation the thumbnail image is created internally by resizing the source image to fit within the width and height of the thumbnail item.

The ImGearThumbnailList ReloadItem(int index) method can be used to regenerate a thumbnail image from its source. The ImGearThumbnailList ReloadItems method can be used to regenerate the thumbnail images for the thumbnail items that are currently displayed. If the width or height of the thumbnail items is changed, the thumbnail images will stretch to fit the new size. The ReloadItems method will regenerate the thumbnail images to best fit the new size.

The Caption, PageNumber, PageCount, PageDisplay, and Source properties of an ImGearThumbnailListItem are set when the item is generated, and some of these properties are bound to the properties of elements in the ItemTemplate of the ImGearThumbnailList Style as shown in the default style XAML below.

The ImGearThumbnailList control contains the following properties that apply to all thumbnail items: ItemWidth, ItemHeight, ItemBackground, ItemBorderBrush, ItemBorderThickness, ItemCaptionBackground, and ItemCaptionForeground. These properties are also bound to the properties of elements in the XAML below. The ImGearThumbnailList XSpacing and YSpacing properties specify the amount of space between thumbnail items. The ImGearThumbnailList ItemsMargin property specifies the region within the ImGearThumbnailList control where thumbnail items are displayed.

You can specify your own ImGearThumbnailList Style ItemTemplate to change the appearance of thumbnail items. For example, if you want to show the PageNumber and PageCount in addition to the Caption, you could copy the XAML below and add TextBlocks that bind to the PageNumber and PageCount properties. You can also specify Triggers, for example to change the appearance when an item is selected or when the mouse is over it.

XAML Example
Copy Code
    <Style TargetType="local:ImGearThumbnailList">
        <Setter Property="ItemTemplate">
            <Setter.Value>
                <DataTemplate>
                    <Border BorderThickness="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemBorderThickness}"
                            BorderBrush="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemBorderBrush}"
                            Width="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemWidth}"
                            Height="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemHeight}"
                            CornerRadius="10" Name="itemBorder">
                        <Grid>
                            <Border Name="mask" Background="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemBackground}" CornerRadius="8" />
                            <Grid x:Name="itemGrid" Background="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemBackground}">
                                <Grid.RowDefinitions>
                                    <RowDefinition Height="*" />
                                    <RowDefinition Height="Auto" />
                                </Grid.RowDefinitions>
                                <Grid.OpacityMask>
                                    <VisualBrush Visual="{Binding ElementName=mask}"/>
                                </Grid.OpacityMask>
                                <local:PageView UpdateMode="Automatic" Grid.Row="0" Margin="5,5,5,0"
                                            Display="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailListItem}}, Path=PageDisplay, Mode=OneWay}"
                                            MouseToolSettings="{x:Null}" ContextMenu="{x:Null}" />
                                <TextBlock TextWrapping="NoWrap" Grid.Row="1" HorizontalAlignment="Center"
                                            Text="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailListItem}}, Path=Caption}"
                                            Background="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemCaptionBackground}"
                                            Foreground="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=ItemCaptionForeground}"
                                            FontSize="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=FontSize}"
                                            FontFamily="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=FontFamily}"
                                            FontStretch="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=FontStretch}"
                                            FontStyle="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=FontStyle}"
                                            FontWeight="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailList}}, Path=FontWeight}"
                                            >
                                    <TextBlock.Style>
                                        <Style TargetType="TextBlock">
                                            <Style.Triggers>
                                                <Trigger Property="Text" Value="">
                                                    <Setter Property="Visibility" Value="Collapsed"/>
                                                </Trigger>
                                            </Style.Triggers>
                                        </Style>
                                    </TextBlock.Style>
                                </TextBlock>
                            </Grid>
                        </Grid>
                    </Border>
                    <DataTemplate.Triggers>
                        <DataTrigger Binding="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailListItem}}, Path=IsSelected}" Value="True">
                            <Setter TargetName="itemGrid" Property="Background" Value="{StaticResource ThumbnailSelectedBrush}"/>
                        </DataTrigger>
                        <MultiDataTrigger>
                            <MultiDataTrigger.Conditions>
                                <Condition Binding="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailListItem}}, Path=IsMouseOver}" Value="True"/>
                                <Condition Binding="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearThumbnailListItem}}, Path=IsSelected}" Value="False"/>
                            </MultiDataTrigger.Conditions>
                            <Setter TargetName="itemBorder" Property="BorderBrush" Value="{StaticResource ThumbnailSelectedBrush}" />
                        </MultiDataTrigger>
                    </DataTemplate.Triggers>
                </DataTemplate>
            </Setter.Value>
        </Setter>
    </Style>
...
<SolidColorBrush x:Key="ThumbnailSelectedBrush" Color="#FFBB00" />


ART Marks in Thumbnails
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > ART Marks in Thumbnails

When a thumbnail item is first generated, a new ImGearARTPage is created for the thumbnail item and added to the ART page cache. The MarksLoading event fires for each generated thumbnail item and can be used to specify the ImGearARTPage that is associated with the thumbnail item. For example, the code below loads in each generated thumbnail item a text mark with the thumbnail caption as the text. The ImGearThumbnailList LoadAllARTPages method can be used to fire the MarksLoading event for all thumbnail items that do not have an associated ImGearARTPage. The ImGearThumbnailList DisplayMarks property can be set to false to not display ART marks in thumbnails.

C# Example
Copy Code
        private void thumbnailList_MarksLoading(object sender, ImGearMarksLoadingEventArgs e)
        {
            // Load a text mark with the caption of the thumbnail item.
            ImGearARTText text = new ImGearARTText(new ImGearRectangle(80, 90, 140, 120), e.Item.Caption, new ImGearRGBQuad(255, 255, 255));
            text.FontSize = 40;
            text.FillColor = new ImGearRGBQuad(0, 0, 255);
            artPage.AddMark(text, ImGearARTCoordinatesType.IMAGE_COORD);
            e.ARTPage = artPage;
        }

If the ImGearThumbnailList SelectedPageDisplay property is bound to a PageView Display and the marks are modified in the PageView Display, the modified ImGearARTPage for the selected thumbnail item will be updated in the ART page cache. The ImGearThumbnailList ARTPageCache property can be used to access the ImGearARTPages associated with thumbnail items. For example, when your application is closing, you can iterate through the ImGearARTPages and check the ImGearARTPage MarksChanged property to determine if an ImGearARTPage should be saved.


Thumbnail Scrolling
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Thumbnail Scrolling

The scrollbar can be scrolled manually with the mouse or by using the Page Up and Page Down keys to scroll up or down a page of thumbnail items. You can use the following ImGearThumbnailList methods to programmatically scroll the thumbnails items: ScrollToFirstItem, ScrollToLastItem, ScrollToNextPage, ScrollToPreviousPage, ScrollToNextBand, and ScrollToPreviousBand. The control also contains commands for these which can be used in XAML. You can use the ImGearThumbnailList ScrollDirection method to specify whether thumbnail items are oriented and scrolled horizontally or vertically.

Note that because of a bug in the MS ListBox, the ScrollIntoView(object item) method inherited from ListBox does not work with a virtualizing panel, and the ScrollIntoView(int index) method should be used instead.


Thumbnail Selection
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > Thumbnail Control > Thumbnail Selection

You can use the following ImGearThumbnailList methods to programmatically change which thumbnail item is selected: SelectFirstItem, SelectLastItem, SelectNextBandItem, SelectPreviousBandItem, SelectNextItem, and SelectPreviousItem. The control also contains commands for these which can be used in XAML. If a thumbnail item is currently selected, the arrow keys can also be used to change the currently selected item to an adjacent thumbnail item. The SelectionMode property can be used to specify Single, Multiple, or Extended selection.

The full resolution source image of the currently selected thumbnail item can be displayed in a PageView control by binding the PageView Display property to the ImGearThumbnailList SelectedPageDisplay property. When this is done, a thumbnail’s source image is automatically displayed in the PageView control when the thumbnail item is selected. Any mark modifications in the PageView control are also shown in the thumbnail image if the DisplayMarks property is set to true.


DICOM Multi-Planar Reconstruction
User Guide > How to Work with... > Windows Presentation Foundation (WPF) > Using ImageGear.Windows.Controls Namespace > DICOM Multi-Planar Reconstruction

The ImageGear.Windows.Controls namespace provides functionality (in the ImageGear.Windows.Controls.Dicom assembly) to support the end user’s interaction and UI for multi-planar reconstruction (MPR). The term “MPR” defines the ability to reconstruct volumes from a set of 2D image data and display multiple 2D planes of data from within the reconstructed data set.

ImageGear allows the following 2D plane views:

  • Axial View - This is a horizontal cut away slice of the body as seen from the top. Most commonly DICOM images are taken in this view.
  • Coronal View - This view is a vertical cut away slice of the body as seen from the front.
  • Sagittal View - This is a vertical cut away slice of the body as seen from its left side.
  • Oblique View - This Oblique view has not a specific definition. It is just a cut away slice of the body taken at some angle to the X axis of one of the above described views.

Multi-frame DICOM images contain a collection of slices of the body. For example, considering each axial slice represents an (X-Y) plane of the body, then a collection of slices will represents Z axis.

In the simplest case, multi-planar reconstruction (MPR) involves generating perspectives at right angles to a stack of axial slices so that coronal and sagittal images can be generated. The described views can be graphically represented as the following:

So if we have a multi-frame DICOM image that contains F frames of images with (W x H) dimension, then W would be the X axis, H would be the Y axis and F would be the Z axis.

The coronal view could be considered as the oblique view with 0 degree rotation angle about Z axis, while the sagittal view could be considered as the oblique view with 90 degree rotation angle about Z axis.

It is possible to perform MPR not only from multi-frame DICOM images, but also from a collection of single-frame DICOM images with the same width and height.

As each frame of a DICOM image is represented as a page in IG, so multi-frame DICOM is represented as a collection of pages, so each page represents a horizontal slice of the axial view or vertical slice of the coronal/sagittal view of the body.

There are 3 classes within the ImageGear.Windows.Controls namespace that provide handling of the described views:

  • ImGearMprAxialController
  • ImGearMprCoronalController
  • ImGearMprSagittalController

After providing the initial stack of images for multi-planar reconstruction, each view could be bound to other views to display MPR results. For example, ImGearMprAxialController has the following 3 properties: CoronalDisplay, SagittalDisplay and ObliqueDisplay. The horizontal “MPR line” is shown over the ImGearAxialController’s view to allow the user to perform coronal reconstruction by moving that line over the view and the result of the coronal reconstruction is available through the ImGearMprAxialController.CoronalDisplay property. The Display property of a PageView control can be bound to the CoronalDisplay property to display the coronal view. Similarly, the vertical “MPR line” is shown over the ImGearAxialController’s view to allow the user to perform sagittal reconstruction by moving that line over the view and the result of the sagittal reconstruction is available through the ImGearMprAxialController.SagittalDisplay property, which a PageView control can bind to. For ObliqueDisplay, the 45 degree diagonal “MPR line” is shown over the ImGearAxialController’s view to allow the user to perform oblique reconstruction by moving and resizing that line over the view.

The MPR is always performed in left to right direction of the “MPR line”. The start point of the line is considered the one that has a smaller X coordinate.

You can bind as many views to each property as you need.

To support full MPR, involving reconstruction of all described views, ImageGear.Windows.Controls has a user control called ImGearMprVisualizer. This control contains 4 views for each of the MPR views and provides the user the possibility to reconstruct each of them by moving “MPR lines” over the original MPR view. The original MPR view is defined by providing a stack of images in the corresponding view and initializing the ImGearMprVisualizer object with them.

The look of the MPR visualizer and MPR controllers can be customized using a template. The default template XAML is provided below. To support the axial view, an ImGearMprAxialController must be specified with the name “AxialController”. Similarly, to support the coronal view, an ImGearMprCoronalController named “CoronalController” must be specified, and to support the sagittal view, an ImGearMprSagittalController named “SagittalController” must be specified.

XAML Example
Copy Code
<Window x:Class="WPF_Example.MprVisualizerWindow"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:igwc="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls"
        xmlns:igdicom="clr-namespace:ImageGear.Windows.Controls;assembly=ImageGear22.Windows.Controls.Dicom"
        Title="MPR Visualizer" Height="500" Width="600">

    <Grid>
        <igdicom:ImGearMprVisualizer x:Name="mprVisualizer">
            <igdicom:ImGearMprVisualizer.Template>
                <ControlTemplate>
                    <Grid Background="Black">
                        <Grid.RowDefinitions>
                            <RowDefinition Height="*"/>
                            <RowDefinition Height="*"/>
                            <RowDefinition Height="Auto"/>
                        </Grid.RowDefinitions>
                        <Grid.ColumnDefinitions>
                            <ColumnDefinition Width="*"/>
                            <ColumnDefinition Width="*"/>
                        </Grid.ColumnDefinitions>
                        <Border BorderThickness="1" BorderBrush="White">
                            <igdicom:ImGearMprAxialController x:Name="AxialController">
                                <igdicom:ImGearMprAxialController.Template>
                                    <ControlTemplate>
                                        <Grid>
                                            <Grid.RowDefinitions>
                                                <RowDefinition Height="Auto"/>
                                                <RowDefinition Height="*"/>
                                            </Grid.RowDefinitions>
                                            <TextBlock Text="Axial" Foreground="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=Settings.AxialLineBrush, Mode=OneWay}"/>
                                            <igwc:PageView MouseTool="SelectMark" UpdateMode="Automatic" Grid.Row="1" ContextMenu="{x:Null}" Display="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprAxialController}}, Path=PageDisplay, Mode=OneWay}"/>
                                        </Grid>
                                    </ControlTemplate>
                                </igdicom:ImGearMprAxialController.Template>
                            </igdicom:ImGearMprAxialController>
                        </Border>
                        <Border BorderThickness="1" BorderBrush="White" Grid.Row="0" Grid.Column="1">
                            <igdicom:ImGearMprCoronalController x:Name="CoronalController">
                                <igdicom:ImGearMprCoronalController.Template>
                                    <ControlTemplate>
                                        <Grid>
                                            <Grid.RowDefinitions>
                                                <RowDefinition Height="Auto"/>
                                                <RowDefinition Height="*"/>
                                            </Grid.RowDefinitions>
                                            <TextBlock Text="Coronal" Foreground="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=Settings.CoronalLineBrush, Mode=OneWay}"/>
                                            <igwc:PageView MouseTool="SelectMark" UpdateMode="Automatic" Grid.Row="1" ContextMenu="{x:Null}" Display="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprCoronalController}}, Path=PageDisplay, Mode=OneWay}"/>
                                        </Grid>
                                    </ControlTemplate>
                                </igdicom:ImGearMprCoronalController.Template>
                            </igdicom:ImGearMprCoronalController>
                        </Border>
                        <Border BorderThickness="1" BorderBrush="White" Grid.Row="1" Grid.Column="0">
                            <igdicom:ImGearMprSagittalController x:Name="SagittalController">
                                <igdicom:ImGearMprSagittalController.Template>
                                    <ControlTemplate>
                                        <Grid>
                                            <Grid.RowDefinitions>
                                                <RowDefinition Height="Auto"/>
                                                <RowDefinition Height="*"/>
                                            </Grid.RowDefinitions>
                                            <TextBlock Text="Sagittal" Foreground="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=Settings.SagittalLineBrush, Mode=OneWay}"/>
                                            <igwc:PageView MouseTool="SelectMark" UpdateMode="Automatic" Grid.Row="1" ContextMenu="{x:Null}" Display="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprSagittalController}}, Path=PageDisplay, Mode=OneWay}"/>
                                        </Grid>
                                    </ControlTemplate>
                                </igdicom:ImGearMprSagittalController.Template>
                            </igdicom:ImGearMprSagittalController>
                        </Border>
                        <Border BorderThickness="1" BorderBrush="White" Grid.Row="1" Grid.Column="1">
                            <Grid>
                                <Grid.RowDefinitions>
                                    <RowDefinition Height="Auto"/>
                                    <RowDefinition Height="*"/>
                                </Grid.RowDefinitions>
                                <TextBlock Text="Oblique" Foreground="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=Settings.ObliqueLineBrush, Mode=OneWay}"/>
                                <igwc:PageView Name="mprViewOblique" MouseTool="SelectMark" UpdateMode="Automatic" Grid.Row="1" Display="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=ObliqueDisplay, Mode=OneWay}" ContextMenu="{x:Null}"/>
                            </Grid>
                        </Border>
                        <Border BorderThickness="1" BorderBrush="White" Grid.Row="2" Grid.ColumnSpan="2">
                            <Slider HorizontalAlignment="Stretch" Value="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearMprVisualizer}}, Path=ActiveController.PageNumber, Mode=TwoWay}" Maximum="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearMprVisualizer}}, Path=ActiveController.MaximumPageNumber, Mode=OneWay}" Minimum="{Binding RelativeSource={RelativeSource AncestorType={x:Type local:ImGearMprVisualizer}}, Path=ActiveController.MinimumPageNumber, Mode=OneWay}">
                                <Slider.Style>
                                    <Style>
                                        <Style.Triggers>
                                            <DataTrigger Binding="{Binding RelativeSource={RelativeSource AncestorType={x:Type igdicom:ImGearMprVisualizer}}, Path=ActiveController, Mode=TwoWay}" Value="{x:Null}">
                                                <Setter Property="Slider.Visibility" Value="Collapsed"/>
                                            </DataTrigger>
                                        </Style.Triggers>
                                    </Style>
                                </Slider.Style>
                                <ToolTipService.ToolTip>
                                    <ToolTip Content="Move the bar to navigate through image pages"/>
                                </ToolTipService.ToolTip>
                            </Slider>
                        </Border>
                    </Grid>
                </ControlTemplate>
            </igdicom:ImGearMprVisualizer.Template>
        </igdicom:ImGearMprVisualizer>
    </Grid>
</Window>


File Formats and Compressions
User Guide > File Formats and Compressions

This section provides detailed information about the image formats and compressions that ImageGear supports.

  • File Formats provides background information about different types of file formats, and contains additional topics that provide information on the following:
    • What's the Best Format for...? lists which formats best support various types of images (for example, which formats support an alpha channel). This section provides you with a starting point for deciding which file formats to use in your application.
    • Format Bit Depths is a table that lists the bit depths and the read/write capabilities of the supported formats. Using this table, you can easily find out whether an image can be converted to a particular format.
    • File Formats Reference provides information about every ImageGear supported format, its ID, supported versions, encoding type, multi-page and alpha channel support, supported compressions, color spaces and bit depths for read and write, as well as information about ImageGear supported features and filter control parameters.
    • Metadata Structures provides detailed information about ImageGear supported metadata.
  • Compressions provides information about every ImageGear supported imaging compression.

This topic provides information about the following:

  • Supported Formats and Compressions
  • Encoding vs. Compressing

Supported Formats and Compressions

ImageGear supports the following formats and compressions in the following categories:

  • Raster Color and Grayscale
  • Raster Bitonal (1-Bit)
  • Vector
  • Office
  • Barcode
  • Compressions

ImageGear for .NET also provides support for 100+ Digital Cameras.

Raster Color and Grayscale

Format | Full Name | Support
BMP | Microsoft Windows Bitmap | RW
CLP | Windows Clipboard | RW
CR2 | Canon CR2 Camera Raw Format | R
CRW | Canon CRW Camera Raw Format | R
CUR | Windows cursor | RW
CUT | Dr. Halo | RW
DCRAW | Digital camera RAW format | R
DCX | Paintbrush (Intel multi-page FAX format) | RW
DIB | DIB (Microsoft Windows Device Independent Bitmap) | RW
DICOM | DICOM (Digital Imaging & Communication in Medicine) | RW
DNG | Digital Negative file format | R
GEM | GEM Raster | R
GIF | CompuServe Graphics Interchange Format (GIF) | RW
Hasselblad Raw | Hasselblad Camera Raw Format | R
HD Photo | HD Photo (Windows Media Photo) | RW
Headerless Camera Raw | Headerless Camera Raw Format | R
ICO | ICO (Windows icon) | RW
IFF | Interchange File Format | RW
Imacon Raw | Imacon Camera Raw Format | R
IMG | Xerox 9700 graphic image (IMG) | R
IOCA | IBM IOCA (Image Object Content Architecture) | RW
JPEG | JPEG File Interchange Format | RW
JPEG 2000 | JPEG 2000 | RW
JPX | JPEG 2000 Extensions | RW
KodakRAW | Kodak Camera Raw Format | R
LeicaRAW | Leica/Panasonic Camera Raw Format | R
MEF | Mamiya Camera Raw Format | R
MODCA | IBM MO:DCA (Mixed Object Document Content Architecture) | RW
MOS | Leaf Camera Raw Format | R
MRW | Konica Minolta Camera Raw Format | R
NCR | NCR | RW
NEF | Nikon Camera Raw Format | R
ORF | Olympus Camera Raw Format | R
PBM | Portable Bitmap File Format | RW
PCD | Kodak Photo CD | R
PCX | PC Paintbrush File Format | RW
PDF | Adobe Portable Document Format | RW
PEF | Pentax/Samsung Camera Raw Format | R
PGM | Portable Graymap File Format | RW
PhaseOne Raw | Phase One Camera Raw Format | R
PNG | Portable Network Graphics | RW
PNM | Portable Any-Map File Format | RW
PPM | Portable Pixmap File Format | RW
PS | Adobe PostScript | RW
PSB | Adobe Photoshop Big | RW
PSD | Adobe Photoshop | RW
PTOCA | Presentation Text Object Content Architecture | R
RAF | Fujifilm Camera Raw Format | R
RAS | Sun Raster Data Format | RW
Scitex CT | Scitex CT | RW
SGI | Silicon Graphics Image | RW
SonyRaw | Sony Camera Raw Format | R
TGA | Truevision Targa | RW
TIFF | Tagged Image File Format | RW
WPG | WordPerfect Graphics Metafile | R
XPM | X PixMap | RW
XPS | XML Paper Specification | RW
XWD | X Window Dump | RW

Raster Bitonal (1-Bit)

Format | Full Name | Support
BTR | Brooktrout | RW
CAL | CALS Raster | RW
IMR | IMRS-Raster image | R
IMT | IMNET (Medical Image Format) | RW
KFX | Kofax Group4 image | R
LV | Lazer View format | R
MSP | MS Paint | R
WBMP | Wireless Bit-Map | RW
XBM | X BitMap | RW

Vector

Format | Full Name | Support
CGM | Computer Graphics Metafile | RW
DGN | MicroStation Drawing | RW
DWF | Design Web Format | RW
DWG | AutoDesk AutoCAD | RW
DXF | AutoDesk AutoCAD | RW
HPGL | Hewlett Packard Graphics Language | RW
PDF | Adobe Portable Document Format | RW
SVG | Scalable Vector Graphics | RW
U3D | Universal 3D | RW

Office

Format | Full Name | Support
DOCX | Office Open XML Word Format | R
PPTX | Office Open XML PowerPoint Format | R
XLSX | Office Open XML Excel Format | R

Barcode

Detailed information about using Barcodes is in the Barcodes section.

Format | Full Name | 1D | 2D
2D Barcodes |  |  |
Aztec | AztecBarcode |  | R
DataMatrix | DataMatrixBarcode |  | RW
PDF417 | PDF417Barcode |  | RW
QRcode | QRCodeBarcode |  | R
1D Barcodes |  |  |
Add-2 | Add2Barcode | R | R
Add-5 | Add5Barcode | R | R
Airline 2 of 5 | IATA2of5Barcode | R | R
Australian Post 4-State Barcode | AustralianPost4StateBarcode | R | R
BCD Matrix | BCDMatrixBarcode | R | R
Codabar | CodabarBarcode | RW | RW
Code 128 (A,B,C) | Code128Barcode | RW | RW
Code 2 of 5 | Industry2of5Barcode | R | R
Code 32 | Code32Barcode | R | R
Code 39 | Code39Barcode | RW | RW
Code 39 Extended | Code39ExtendedBarcode | RW | RW
Code 93 | Code93Barcode | RW | RW
Code 93 Extended | Code93ExtendedBarcode | RW | RW
DataLogic 2 of 5 | DataLogic2of5Barcode | R | R
EAN 128 (GS1, UCC) | EAN128Barcode | RW | RW
EAN-13 | EAN13Barcode | RW | RW
EAN-8 | EAN8Barcode | RW | RW
Industrial 2 of 5 | Industry2of5Barcode | RW | RW
Intelligent Mail (OneCode) | IntelligentMailBarcode | R | R
Interleaved 2 of 5 | Interleaved2of5Barcode | RW | RW
Invert 2 of 5 | Invert2of5Barcode | R | R
ITF-14 / SCC-14 | Interleaved2of5Barcode | R | R
Matrix 2 of 5 | Matrix2of5Barcode | R | R
Patch Codes | PatchCodeBarcode | RW | RW
PostNet | PostNetBarcode | R | R
Royal Mail (RM4SCC) | RoyalPost4StateBarcode | R | R
UCC 128 | EAN128Barcode | R | R
UPC-A | UPCABarcode | RW | RW
UPC-E | UPCEBarcode | RW | RW

Compressions

Format | Full Name | Formats Supported
ASCII Compression | American Standard Code for Information Interchange | PBM, PGM, PNM, PPM
CCITT Group 3 Compression | CCITT Group 3 | BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, PDF, PS, TIFF
CCITT Group 3 2D Compression | CCITT Group 3 2D | BTR, IBM IOCA, IBM MO:DCA, Adobe PDF, PS, TIFF
CCITT Group 4 Compression | CCITT Group 4 | CAL, IMR, KFX, BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, Adobe PDF, PS, TIFF
Deflate Compression | Deflate Compression | PDF, PS, TIFF, PNG
HD Photo Compression | Microsoft HD Photo | HD Photo
Huffman Compression | Huffman Encoding | NCR, PCD, TIFF, KodakRAW, NEF, PEF
IBM MMR Compression | IBM Modified Modified Read | IBM IOCA, IBM MO:DCA

JPEG Compressions

  • "Lossy" JPEG Compression
  • Lossless JPEG Compression
  • Progressive JPEG Compression

JPEG Compression
  • Lossy: JPEG, DICOM, DNG, Adobe PDF, PS, TIFF
  • Lossless: JPEG, DICOM, TIFF
  • Progressive: JPEG
JPEG 2000 Compression | JPEG 2000 Wavelet Compression | JPEG 2000, JPX, DICOM, PDF, PS
LZW (Lempel-Ziv-Welch) Compression | Lempel-Zif-Welch (LZW) Compression | GIF, PDF, PS, TIFF
Packbits Compression | Packed Bits Compression | PSD, TIFF
RAW Compression | RAW compression (Uncompressed Binary Compression) | PBM, PGM, PNM, PPM
RLE Compression | Run Length Encoding Compression | BMP, CLP, CUT, DCX, DICOM, GEM, IFF, MSP, PCX, PDF, PS, RAS, SGI, TGA, WPG

Encoding vs. Compressing

These two words are often used interchangeably in discussions of graphics file formats. Encoding is actually a broad term under which compression falls. For the sake of clarity, use these terms separately with the following intended meanings:

  • Encoding - The manner that data is stored when uncompressed (binary, ASCII, etc.), how it is packed (e.g., 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.
  • Compressing - A "physical" rewriting of the graphics data so that it is represented by a smaller set of data.


File Formats
User Guide > File Formats and Compressions > File Formats

This sections contains detailed information on the following:

  • What's the Best Format for...? lists which formats best support various types of images (for example, which formats support an alpha channel). This section provides you with a starting point for deciding which file formats to use in your application.
  • Format Bit Depths is a table that lists the bit depths and the read/write capabilities of the supported formats. Using this table, you can easily find out whether an image can be converted to a particular format.
  • File Formats Reference provides information about every ImageGear supported format, its ID, supported versions, encoding type, multi-page and alpha channel support, supported compressions, color spaces and bit depths for read and write, as well as information about ImageGear supported features and filter control parameters.
  • Metadata Structures provides detailed information about ImageGear supported metadata.

About File Formats

Every application that deals with images has specific kinds of data to store and interchange, from icons to photographs. The various hardware devices used to record and store the graphics data, and the hardware intended to display or print the data also affect the design of the format. This leads to a diversity of file formats. To add to this diversity, different groups of people have different ideas about how to structure and access an image, and what kind of additional information should be stored with an image. Even formats designed to store the same kind of data can differ. Other factors that affect the outcome of the design include memory considerations, storage size, accuracy, and portability.

National and international standardization organizations, such as the American National Standards Institute (ANSI) and the International Standards Organization (ISO), seek to create standards of storage for graphics data. One example is the Joint Photographic Experts Group's (JPEG) creation of the JPEG file format. Some of its intended goals were good image quality, user-chosen compression ratio, and cross-platform flexibility. When an image is called a JPEG, it is assumed to precisely follow the standardized JPEG format.

Formats known as "de facto standards" are those that begin as proprietary formats, but by the forces of the market and sometimes by good quality, become widely supported. Some examples of de facto standards are BMP, GIF, and PCD.

A third group of file formats falls somewhere between officially recognized standards and the strictly proprietary formats. These formats are created by groups of individuals with a common interest who come together to form a more unofficial standards organization. These formats are usually intended to provide an end-all industry standard so that data with the same or similar origins can be shared across different applications or platforms. One example is the TIFF format. TIFF was designed by eight computer technology companies (headed by Aldus Corporation) with the common goal of providing a standard format for storing scanned images.

ImageGear supports graphics file formats from all of these genres, providing you with a complete range of imaging capabilities, including the capture and processing of scanned images.

In addition, ImageGear functionality enables you to exchange data easily from one format to another, and to make improvements in images using powerful image-processing API.

ImageGear supports all of the popular formats, including recognized standards that best utilize the latest imaging technologies.

See Also
Compressions
File Formats Reference


What's the Best Format for...?
User Guide > File Formats and Compressions > File Formats > What's the Best Format for...?

The following table contains the formats that Accusoft Corporation considers most practical for the listed type of data, and can be used as a starting point. You can use a format with the appropriate bit depth and one that provides either the most efficient use of space, or the fastest loading and saving capabilities.

Bear in mind that the following table represents recommendations only. To make an informed choice, read about each format in more detail in the section File Formats Reference.

Image Type | Recommended
Colors | JPEG, JPEG 2000, TIFF, PNG
Grayscale/many shades | TGA, TIFF, JPEG, DICOM
Monochrome / high resolution | TIFF (CCITT Group 3 Compression and CCITT Group 4 Compression)
Banking data | IBM IOCA
Noisy | Color: PNG, TIFF, JPEG
Lossless | GIF, TIFF, PNG, JPEG (Lossless JPEG Compression)
Lossy | TIFF (JPEG Compression), JPEG
Extra data to store | TIFF
Iconic images | ICO
Multimedia | PNG, GIF, JPEG
Multi-page
  • PDF
  • PS
  • BMP (OS/2 BMP only)
  • CGM
  • CUR
  • DCX
  • DICOM
  • DWF
  • GIF
  • HPGL
  • IBM IOCA
  • IBM MO:DCA
  • ICO
  • IFF
  • PCD
  • PTOCA
  • TIFF
  • XPS
Photographic images | PSB, PSD, PCD, JPEG
Internet images | GIF, JPEG, PNG, JPEG 2000, WBMP
PC paint programs and/or graphics arts | PCX, GEM, TIFF, BMP
X Windows | XBM, XPM, XWD
Medical data | DICOM
CAD/Vector | DWG, DWF, DXF, CGM, DGN, HPGL, SVG, U3D
Camera Raw
  • CR2
  • CRW
  • Hasselblad Raw
  • Headerless Camera Raw
  • Imacon Raw
  • KodakRAW
  • LeicaRAW
  • MEF
  • MOS
  • MRW
  • NEF
  • ORF
  • PEF
  • PhaseOneRaw
  • RAF
  • SonyRaw
Document processing | TIFF, PDF, PS, PTOCA, XPS
Alpha Channel
Format Read Only Support Read/Write Support
CUR

Single 1-bit alpha channel

Single 8-bit alpha channel

ICO

Single 1-bit alpha channel

Single 8-bit alpha channel

JPEG

Single alpha channel

JPEG 2000

Single alpha channel, for grayscale and RGB images

JPX
  • Single alpha channel, for grayscale and RGB images
  • Additional alpha channels as ImageGear Extra channels
PNG

Single alpha channel

PSB
  • Single alpha channel
  • Additional alpha channels as ImageGear Extra channels
PSD
  • Single alpha channel
  • Additional alpha channels as ImageGear Extra channels
SGI

Single alpha channel

TGA

Single alpha channel

TIFF
  • Single alpha channel
  • Additional alpha channels as ImageGear Extra channels
  • The following compressions are supported with alpha channel:
    • Uncompressed
    • Packed Bits
    • LZW
    • Deflate


Format Bit Depths
User Guide > File Formats and Compressions > File Formats > Format Bit Depths

You may want to convert a file from one format to another. You can do this by saving the original file to its desired format by setting the nFormatType parameter to the appropriate value in the saving method. For more information on converting issues, see the section Loading and Saving Pages and Documents.

When saving a file to another format, remember to ensure that the desired file format is supported for that image. For example, you cannot convert an 8-bit DCX file to an 8-bit CAL file, because the CAL format does not support 8-bit files.

In the following table, the columns underneath the numbers indicated size in bits that can actually be saved (written). In each cell, a value of "R" indicates read-only support, and a value of "RW" indicates that the ImageGear reads and writes the corresponding file format.

Format | 1 | 4 | 8 | 9-16 | 24 | 32 | 36 | 48 | 64 | Notes
BMP | RW | RW | RW | RW | RW | R |  |  |  |
BTR | RW |  |  |  |  |  |  |  |  |
CAL | RW |  |  |  |  |  |  |  |  |
CGM |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
CLP | RW | RW | RW |  | RW |  |  |  |  |
CR2 |  |  |  | R |  |  |  | R |  |
CRW |  |  |  | R |  |  |  | R |  |
CUR | RW | RW | RW |  |  | RW |  |  |  | Supports Extra ((1, 3, 4, 8)*2)-bit images also
CUT |  |  | RW |  |  |  |  |  |  |
DCRAW |  |  |  | R |  |  |  | R |  |
DCX | RW | RW | RW |  | RW |  |  |  |  |
DGN |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
DIB | RW | RW | RW | R | RW | R |  |  |  |
DICOM | RW |  | RW | RW | RW | RW |  | RW |  |
DNG |  |  |  | R |  |  |  | R |  |
DOCX |  |  |  |  |  |  |  |  |  | Read-only support. Office formats do not support specific bit-depths.
DWF |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
DWG |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
DXF |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
GEM | R | R | R |  |  |  |  |  |  |
GIF | RW | RW | RW |  |  |  |  |  |  |
Hasselblad Raw |  |  |  | R |  |  |  | R |  |
HD Photo | RW |  | RW | RW | RW | RW |  | RW | RW |
Headerless Camera Raw |  |  |  | R |  |  |  | R |  |
HPGL |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
ICO | RW | RW | RW |  |  | RW |  |  |  |
IFF | RW | RW | RW |  | RW |  |  |  |  |
Imacon Raw |  |  |  | R |  |  |  | R |  |
IMG | R |  | R |  |  |  |  |  |  |
IMR | R |  |  |  |  |  |  |  |  |
IMT | RW |  |  |  |  |  |  |  |  |
IOCA | RW | R | R |  | R |  |  |  |  |
JPEG |  |  | RW | RW | RW | RW | RW | RW |  | 8-bit grayscale.
JPEG 2000 | RW | RW | RW | RW | RW | RW |  | RW |  |
JPX | RW | RW | RW | RW | RW | RW |  | RW |  |
KFX | R |  |  |  |  |  |  |  |  |
KodakRAW |  |  |  | R |  |  |  | R |  |
LeicaRAW |  |  |  | R |  |  |  | R |  |
LV | R |  |  |  |  |  |  |  |  |
MEF |  |  |  | R |  |  |  | R |  |
MODCA | RW | R | R |  | R |  |  |  |  |
MOS |  |  |  | R |  |  |  | R |  |
MRW |  |  |  | R |  |  |  | R |  |
MSP | R |  |  |  |  |  |  |  |  |
NCR | RW | R |  |  |  |  |  |  |  |
NEF |  |  |  | R |  |  |  | R |  |
ORF |  |  |  | R |  |  |  | R |  |
PBM | RW |  | RW | RW | RW |  |  | RW |  |
PCD |  |  |  |  | R |  |  |  |  |
PCX | RW | RW | RW |  | RW |  |  |  |  |
PDF | RW | RW | RW |  | RW | RW |  |  |  |
PEF |  |  |  | R |  |  |  | R |  |
PGM |  |  | RW | RW |  |  |  |  |  | Supports 16-bit grayscale images also.
PhaseOne Raw |  |  |  | R |  |  | R |  |  |
PNG | RW | RW | RW | RW | RW | RW |  | RW | RW | Supports 48(RGB)- and 64(RGB+alpha)-bit images.
PNM | RW |  | RW | RW | RW |  |  | RW |  | Supports 16-bit grayscale and 48-bit color images also
PPM |  |  |  |  | RW |  |  | RW |  |
PPTX |  |  |  |  |  |  |  |  |  | Read-only support. Office formats do not support specific bit-depths.
PS | RW | RW | RW |  | RW | RW |  |  |  |
PSB | RW | RW | RW | RW | RW | RW |  | R | R |
PSD | RW | RW | RW | RW | RW | RW |  | R | R |
PTOCA |  |  | R |  |  |  |  |  |  |
RAF |  |  |  | R |  |  |  | R |  |
RAS | RW | R | RW |  | RW |  |  |  |  |
Scitex CT |  |  |  |  |  | RW |  |  |  | The native format is CMYK. With full CMYK support enabled, you can use 32-bit images.
SGI |  |  | RW | RW | RW | RW |  |  |  |
SonyRaw |  |  |  | R |  |  |  | R |  |
SVG |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
TGA | RW |  | RW | RW | RW | RW |  |  |  |
TIFF | RW | RW | RW | RW | RW | RW | RW | RW | RW | Read only supports also 3- and 6 bpp for RGB and LAB color spaces for Deflate Compression, LZW (Lempel-Ziv-Welch) Compression, Packbits Compression and uncompressed.
U3D |  |  |  |  |  |  |  |  |  | Read-write support. Vector formats do not support specific bit-depths.
WBMP | RW |  |  |  |  |  |  |  |  |
WPG | R | R | R |  |  |  |  |  |  |
XBM | RW |  |  |  |  |  |  |  |  |
XLSX |  |  |  |  |  |  |  |  |  | Read-only support. Office formats do not support specific bit-depths.
XPM | RW | RW | RW |  | R |  |  |  |  |
XPS | RW |  | RW | RW | RW | RW |  | RW | RW |
XWD | RW | RW | RW |  | RW |  |  |  |  |


File Formats Reference
User Guide > File Formats and Compressions > File Formats > File Formats Reference

This section provides a reference for every imaging file format supported by ImageGear. Each file format page provides the following information:

  • Full Name - Full name of the file format.
  • Format ID - ImageGear constant that determines the file format ID used for loading this file in ImageGear-based application.
  • File Extension(s) - The extensions used for the file format.
  • Data Type - The type of the file format (raster, vector, metafile).
  • Data Encoding - The type of data encoding. Please see the section Encoding vs. Compressing.
  • ImageGear Multi-Page Support - Shows whether ImageGear supports the file format as multi-page or single page.
  • ImageGear Alpha Channel Support - Shows whether or not ImageGear supports the alpha channel for the file format.
  • ImageGear Platforms Support - Shows ImageGear platform versions that support the file format.
  • ImageGear Supported Versions - Shows the versions of the file format supported by ImageGear.
  • ImageGear Supported Features - Shows the ImageGear format filter features supported by ImageGear for this format.
  • ImageGear Read Support - Provides all compressions, color spaces, channels, and bit depths supported by ImageGear for the file format reading.
  • ImageGear Write Support - Provides all compressions, color spaces, channels, and bit depths supported by ImageGear for the file format writing.
  • ImageGear Filter Control Parameters - Provides all filter control parameters supported by ImageGear for this format filter.
  • Comments - Some general information about format encoding and compression structure.
  • References Used - References to the information sources for the file format.
The following formats are not currently supported in ImageGear ASP.NET Services: CGM, DGN, DWF, DWG, DXF, HPGL, and U3D.

Currently ImageGear supports the following file formats:

Format | Read/Write | Description
BMP | Read/Write | Standard Windows format including OS/2 bitmap format
BTR | Read/Write | Brooktrout FAX format, Group III or Group III 2D or 301
CAL | Read/Write | CALS raster, Type I
CGM | Read/Write | Computer Graphics Metafile. Requires ImageGear.Formats.CGM Namespace. (Not supported in ImageGear ASP.NET Services.)
CLP | Read/Write | Windows Clipboard format for raster images
CR2 | Read | Canon CR2 Camera Raw Format
CRW | Read | Canon CRW Camera Raw Format
CUR | Read/Write | For reading Windows 3.x and Windows95 mouse cursor display
CUT | Read/Write | Dr. Halo CUT format
DCRAW | Read | Digital Camera RAW format
DCX | Read/Write | Intel multi-page FAX format
DGN | Read | MicroStation Drawing (Drawing format used by MicroStation construction design software). Requires ImageGear.Formats.DGN Namespace. (Not supported in ImageGear ASP.NET Services.)
DIB | Read/Write | DIB (Microsoft Windows Device Independent Bitmap)
DICOM | Read/Write | DICOM is a public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images. Requires ImageGear.Formats.DICOM Namespace.
DNG | Read | Digital Negative file format
DOCX | Read | Office Open XML Word format.
DWF | Read | Used for publishing 2D and 3D CAD drawings so they can be easily viewed without requiring the use of CAD software. Requires ImageGear.Formats.DWF namespace and ImageGear.Vector Namespace. (Not supported in ImageGear ASP.NET Services.)
DWG | Read/Write | DWG (AutoDesk AutoCAD) format. Requires ImageGear.Formats.CAD Namespace. (Not supported in ImageGear ASP.NET Services.)
DXF | Read/Write | DXF (AutoDesk AutoCAD) format. Requires ImageGear.Formats.CAD Namespace. (Not supported in ImageGear ASP.NET Services.)
GEM | Read | GEM Paint Raster format
GIF | Read/Write | Graphic Image Format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm.
Hasselblad RAW | Read | Hasselblad Camera Raw Format
HD Photo | Read/Write | HD Photo (Windows Media Photo)
Headerless Camera Raw | Read | Headerless Camera Raw Format
HPGL | Read | Hewlett-Packard Graphics Language format. Requires ImageGear.Formats.HPGL Namespace. (Not supported in ImageGear ASP.NET Services.)
ICO | Read/Write | Windows ICON format
IFF | Read/Write | Electronic Arts format
Imacon Raw | Read | Imacon Camera Raw Format
IMG | Read | Xerox raster format, Group IV
IMR | Read | IMRS-Raster image format
IMT | Read | IMNET format, Groups III and IV
IOCA | Read/Write | IBM Image Object Content Architecture, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
JPEG | Read/Write | ANSI-standard, full-color image format; IG supports all aspects of this format including lossless and progressive; JFIF - industry standard header for JPEG compressed images.
JPEG 2000 | Read/Write | New JPEG 2000 standard, based on the EBCOT (Embedded Block Coding with Optimized Truncation of the embedded bitstreams) algorithm. Requires ImageGear.Formats.JPEG2K Namespace.
JPX | Read/Write | JPX file format is an extension to JPEG 2000 file format. Requires ImageGear.Formats.JPEG2K Namespace.
KFX | Read | Kofax format, Group IV
KodakRAW | Read | Kodak Camera Raw Format
LeicaRAW | Read | Leica/Panasonic Camera Raw Format
LV | Read | LaserView, LaserData, Group IV
MEF | Read | Mamiya Camera Raw Format
MODCA | Read/Write | IBM Mixed Object Document Content Architecture format, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
MOS | Read | Leaf Camera Raw Format
MRW | Read | Konica Minolta Camera Raw Format
MSP | Read | Microsoft Paint format
NCR | Read/Write | NCR Group IV format
NEF | Read | Nikon Camera Raw Format
ORF | Read | Olympus Camera Raw Format
PBM | Read/Write | Portable BitMap (UNIX graphic file format)
PCD | Read | Kodak format for high resolution photographs
PCX | Read/Write | PC Paintbrush format
PDF | Read/Write | Adobe PDF file format. Requires ImageGear.Formats.PDF Namespace.
PEF | Read | Pentax/Samsung Camera Raw Format
PGM | Read/Write | Portable BitMap (UNIX graphic file format)
PhaseOneRaw | Read | Phase One Camera Raw Format
PNG | Read/Write | Portable Network Graphics, intended as successor to GIF
PNM | Read/Write | Portable BitMap (UNIX graphic file format)
PPM | Read/Write | Portable BitMap (UNIX graphic file format)
PPTX | Read | Office Open XML Power Point format
PS | Read/Write | Adobe PostScript file format. Requires ImageGear.Formats.PDF Namespace.
PSB | Read/Write | Adobe Photoshop Big
PSD | Read/Write | Adobe Photoshop
PTOCA | Read | Presentation Text Object Content Architecture support for IBM's AFP printer architecture.
RAF | Read | Fujifilm Camera Raw Format
RAS | Read/Write | SUN raster format
RAW | Read | Header-less image
Scitex CT | Read/Write | For electronic pre-press and visual communications systems, part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols.
SGI | Read/Write | Silicon Graphics raster format
SonyRaw | Read | Sony Camera Raw Format
SVG | Read/Write | Scalable Vector Graphics
TGA | Read/Write | Targa file format. ImageGear supports many aspects of this format including alpha channel.
TIFF | Read/Write | Tagged Image File Format; ImageGear supports every aspect of this format.
U3D | Read/Write | Universal 3D format. Requires ImageGear.Formats.U3D Namespace. (Not supported in ImageGear ASP.NET Services.)
WBMP | Read/Write | Optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).
WPG | Read | Wordperfect Graphic Format. ImageGear reads bitmaps stored in this format.
XBM | Read/Write | X Windows Bitmap format
XLSX | Read | Office Open XML Excel format
XPM | Read/Write | X Windows Pixmap format
XPS | Read/Write | Vector image (XML Paper Specification)
XWD | Read/Write | X Windows Dump format

For information about Barcode formats supported, see Barcodes.

See Also
Cameras Supported for DC RAW Formats


BMP
User Guide > File Formats and Compressions > File Formats > File Formats Reference > BMP
Full Name | Microsoft Windows Bitmap
Format ID | ImGearFormats.BMP
File Extension(s) | *.bmp, *dib
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Only for OS/2 BMP
Alpha Channel Support | No
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Java

ImageGear Supported Versions

  • Windows Bitmap version 5 (created for Windows 98, Windows 2000)
  • Windows Bitmap version 4 (created for Windows 95, Windows NT 4.0)
  • Windows Bitmap version 3 (created for Windows 3.x)
  • Windows Bitmap version 2 (created for Windows 2.x)
  • OS/2 Bitmap version 2
  • OS/2 Bitmap version 1

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
UpsideDown | bool | false | false, true | If true then the images will be saved upside-down
Type | int | 1 (BMI, MS Windows format) | 0 (BMC, OS/2 1.x format), 1 (BMI, MS Windows format), 2 (BMI2, OS/2 2.x format). | BMP type to use for saving.
Scanner16GrayEnabbled | bool | false | false, true | Vidar 12-bit scanner options
Scanner16GrayType | int | 0 | 0, 1 | Vidar 12-bit scanner options: 0 a no particular scanner is specified. 1 a old VXR 12 scanner.

Comments

The BMP format for versions 2.x - 4.x contains two headers. All Windows bitmap files begin with the same first header. They proceed with a data structure containing image information (the Bitmap Information Header), and end with the actual image data. If there is a palette (1, 4, 8-bit images), it is located between the bitmap information and the bitmap image data.

The first header identifies the format as BMP, and stores the file size and the address of the image. Two additional fields, Reserved1 and Reserved2, are not used and are set to 0.

The second header, known as the "bitmap information header", varies across the versions of Windows bitmaps. The second header for all bitmaps from version 2.x to 5.x have in common the following basic set of information: size of the secondary header in bytes, height and width of the image in pixels, the number of bit planes, the number of bits per pixel, compression scheme (0 = uncompressed, 1 = 4-bit RLE compression, 2 = 8-bit RLE compression, 3 = bitfields encoding was used), size of image in bytes, horizontal and vertical resolution in pixels per meter, the number of colors in the image, and the minimum number of important colors.

If the image is 16 or 32-bits per pixel in resolution, the compression field equals 3, and following the header are values for RedMask, GreenMask and BlueMask, rather than a palette. If the file is 4.x, there are values for an alpha component, color space type, x and y coordinates of red, green or blue endpoints, and gamma values for red, green, and blue coordinate scale values. The "ColorsImportant" field accommodates hardware that supports fewer colors than are contained by the image palette. The most significant colors are determined by counting their frequency of appearance. A value of zero means that all the colors in the image are significant.

The palette, or color table, varies in size depending on the number of colors in the image. This value is stored in the "ColorsUsed" field of the Bitmap Information Header. In the BMP format v. 3, the palette's structure is in "RGBQUAD" format. See the section entitled "Palettes" in for more information. 24-bit images do not use a palette, but rather store the color information directly in the image data.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


BTR
User Guide > File Formats and Compressions > File Formats > File Formats Reference > BTR
Full Name | Brooktrout
Format ID | ImGearFormats.BRK
File Extension(s) | *.brk, *.301,
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

Version 1

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetect
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp
When saving an image, the image must have horizontal resolution of 200 DPI and vertical resolution of 100 or 200 DPI.

ImageGear Filter Control Parameters

None

Comments

A Brooktrout file consists of a CCITT Group 3 (G3) compressed file with a 128-byte header designed by Brooktrout Technology. The header fields include a constant that identifies the file as Brooktrout, a version number, the horizontal and vertical resolutions of the image in dots/mm, the number of bits per pixel, and the number of pixels per line.


CAL
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CAL
Full Name | CALS Raster
Format ID | ImGearFormats.CAL
File Extension(s) | *.cal, *.ras, *.cals
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Java

ImageGear Supported Versions

  • Type II (Tiles made possible)
  • Type I

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Write Support

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Filter Control Parameters

None

Comments

The CALS file format was created as a graphics format specification by The Department of Defense to standardize the data exchange of logistics support operations across the military branches and military contractors. It is mandatory for most military document-handling applications. It is no longer used solely by the military and its contractors; other government agencies and commercial businesses have also adopted this format, including the aerospace, commercial computer, and medical industries.

There are two types of CALS files: Type I, and a newer, significantly more complicated Type II. Type II supports the use of tiles. Sometimes it acts a repository for a group of Type I files. Whether or not a Type II contains Type I images determines what kind of compression scheme is used. Type I is supported by ImageGear.

Type I and Type II files begin with a header that has the same format and size. It includes information about the source and destination documents, as well as image characteristics data. The data storage units under the header are each 128 bytes in length, and are referred to as records. These are written with 7-bit ASCII characters, making it more "human-readable" than most file format headers.

The image data follows the header. In a Type II file, if the data is a series of Type I images, the images are encoded with CCITT Group 4 compression. If they are Type II files, the data may either be uncompressed or encoded with CCITT Group 4. In addition, Type II data may be stored in tiles, wherein some, all, or none of the tiles may be compressed.

The Type II file contains several more substructures than Type I. Between the header and the image data are three groups of document formatting data. Other data preceding each image (or images), are "layout information" and a "Tile Index", that contains the address of each tile stored for the image.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


CGM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CGM
Full Name | Computer Graphics Metafile
Format ID | ImGearFormats.CGM
File Extension(s) | *.cgm
Data Type | Metafile Vector Image
Data Encoding | Character-based, Binary, Clear-text encoded
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, Win64, .NET, .NET64
CGM format requires ImageGear.Formats.CGM Namespace.

Supported Versions

  • Version 1 (1987 standard)
  • Version 2
  • Version 3 (1992 standard)

Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single page file writing
  • IGFilterFormatFlags.IG_FLTR_MPAGEREADSUPPORT - multi-page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

  • ImGearCompressions.NONE - Vector/CAD data

Please see Supported Features, below, for more information.

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

This is standardized, platform-independent format used for the interchange of bitmap and vector data.

CGM is a very feature-rich format which attempts to support the graphic needs of many general fields (graphic arts, technical illustration, cartography, visualization, electronic publishing, and so on). While the CGM format is rich in features (many graphical primitives and attributes), it is less complex than PostScript, produces much smaller (more compact) files, and allows the interchange of very sophisticated and artistic images.

Computer Graphics Metafile was developed by experts working on committees under the auspices of the International Standards Organization (ISO) and the American Standards National Institute (ANSI). It was specifically designed as a common format for the platform-independent interchange of bitmap and vector data, and for use in conjunction with a variety of input and output devices. Although CGM incorporates extensions designed to support bitmap (called raster in the CGM specification) data storage, files in CGM format are used primarily to store vector information. CGM files typically contain either bitmap or vector data, but rarely both.

CGM Features Supported for Reading

CGM Element

Supported Attributes

Imported into ImageGear as:

Font names

Font name

ImGearVectorFont objects.

Color Model

Color model

Processed internally.

Affects the interpretation of the colors when reading file content.

Color selection mode

Mode: True color or indexed

Processed internally.

Affects the interpretation of colors.

Background color

RGB color value

Background color of the view.

VDC extent

Left

Top

Right

Bottom

Processed internally.

Affects the interpretation of different ranges. Also, used as a range of the view.

Begin Picture Body

Processed internally.

End Picture body

Processed internally.

Line and Edge type definition

Type

Pattern

Pattern Length

ImGearVectorLinetype object.

Edge width specification mode

Mode: absolute, scaled, fraction, mm.

Processed internally.

Affects the interpretation of edge width of ImGearVectorLinetype object.

Line width specification mode

Mode: absolute, scaled, fraction, mm.

Processed internally.

Affects the interpretation of line width of ImGearVectorLinetype object.

Marker size specification mode

Mode: absolute, scaled, fraction, mm.

Processed internally.

Affects the interpretation of size of Poly Marker objects.

Line representation

Line type

Line width

Line color

Affects the interpretation of Line and Polyline objects.

Marker

representation

Marker type

Marker size

Marker color

Affects the interpretation of Poly Marker objects.

See Poly Marker section.

Text representation

Font index

Precision

Spacing

Expansion

Color

Affects the interpretation of Text objects.

Fill representation

Font index

Precision

Spacing

Expansion

Color

Used for creating ImGearVectorFilltype object when creating the filling entity.

Edge representation

Edge type

Edge width

Edge color

Affects the interpretation of edges when creating such entity as ImGearVectEntities.FIGURE (see below).

Real Precision

Fixed or floating indicator

Whole part

Fractional part

Processed internally.

Affects the interpretation of many floating-point parameters.

Color index precision

Precision

Processed internally.

Affects the interpretation of color indices.

Index precision

Precision

Processed internally.

Affects the interpretation of indices for different tables.

VDC Integer precision

Precision

Processed internally.

Affects the interpretation of many integer parameters.

VDC real precision

Precision

Processed internally.

Affects the interpretation of many floating-point parameters.

Transparent cell colors

On/Off flag

Color

Processed internally. Turns on/off the transparent color for cell array being represented by ImGearVectEntities.RASTER (see below).

Color precision

Precision

Processed internally.

Affects the interpretation of true colors.

Maximum color index

Maximum index

Processed internally.

Defines a size of the internal palette.

VDC type

Type

Processed internally.

Defines a type of parameters – either integer or float.

Integer precision

Precision

Processed internally.

Affects the interpretation of many integer parameters.

Color model

Color model

The only RGB is supported by the ImageGear CGM filter.

Metafile default replacement

Default replacement flag

Processed internally. Turns on the default setting mode.

Begin picture

Defines begin of ImGearVectPage page.

Begin figure

Starts ImGearVectEntities.FIGURE entity. All objects being read inside Begin figure/End figure block will be added to the figure entity container.

End figure

Finishes ImGearVectEntities.FIGURE entity. See above.

Color table

RGB color values

Processed internally. Creates the internal palette.

Aspect source flags

Type

Value

Processed internally.

Affects the interpretation of different objects and parameters.

Line Width

Width

Specifies a width for ImGearVectorLinetype object.

Line bundle index

Index

Specifies a set of predefined parameters for line objects.

Line type

Type

Specifies a pattern for ImGearVectorLinetype object.

Line color

Color

Specifies ImGearVectAttrib.DRAWCOLOR attribute for entities.

Polyline

Vertices

ImGearVectEntities.POLYLINE entity.

Disjoined polyline

Vertices

ImGearVectEntities.POLYLINE entity.

Connection edge

ImGearVectEntities.CONNECTION entity.

Clip rectangle

First corner

Second corner

ImGearVectEntities.VIEWPORT entity.

New region

New region for ImGearVectEntities.FIGURE entity.

Text bundle index

Index

Specifies a set of predefined parameters for text objects.

Text color

Color

Specifies a color for ImGearVectorTextObject object.

Character height

Height

Specifies text height for ImGearVectorTextObject object.

Text font index

Index

ImGearVectorFont objects.

Character spacing

Spacing

Specifies character spacing for ImGearVectorTextObject object.

Character expansion factor

Expansion

Used for calculating the character width for ImGearVectorTextObject object.

Restricted text type

Type

Specifies restriction type for ImGearVectEntities.TEXT entity.

Text alignment

Horizontal alignment

Vertical alignment

Specifies an alignment for ImGearVectEntities.TEXT entity.

Text path

Path

Specifies an orientation of ImGearVectEntities.TEXT entity.

Character orientation

XUp

YUp

XBase

YBase

Specifies an orientation of characters for ImGearVectorTextObject object.

Restricted text

Delta width

Delta height

Text position

Final/not final flag

Text string

ImGearVectEntities.TEXT entity.

Append text

Final/not final flag

Text string

ImGearVectEntities.TEXT entity.

Text

Text position

Final/not final flag

Text string

ImGearVectEntities.TEXT entity.

Edge visibility

Visibility

Affects the creation of ImGearVectAttrib.DRAWCOLOR and ImGearVectAttrib.LINETYPE attributes for entities.

Edge width

Width

Specifies ImGearVectAttrib.THICKNESS attribute for entities.

Edge bulge index

Index

Specifies a set of predefined parameters for polygon edges.

Edge type

Type

Specifies a pattern for ImGearVectorLinetype object. Applicable mostly to polylines.

Edge color

Color

Specifies ImGearVectAttrib.DRAWCOLOR attribute for entities.

Fill bundle index

Index

Specifies a set of predefined parameters for ImGearVectorFilltype object.

Interior style

Style

Specifies a pattern for ImGearVectorFilltype object.

Fill color

Color

Specifies ImGearVectAttrib.FILLCOLOR attribute for entities.

Hatch index

Index

Specifies a pattern for ImGearVectorFilltype object if interior style is a hatch.

Polygon

Vertices

ImGearVectEntities.POLYLINEEX entity.

Polygon set

Vertices

Edge out flags

ImGearVectEntities.POLYLINEEX entity.

Rectangle

First corner

Second corner

ImGearVectEntities.POLYLINE entity.

Circle

Center

Radius

ImGearVectEntities.ELLIPSE entity.

Circular arc 3 point

Starting point

Intermediate point

Ending point

ImGearVectEntities.ARC entity.

Circular arc 3 point close

Starting point

Intermediate point

Ending point

Type of arc closure

ImGearVectEntities.ARC entity.

Circular arc center

Center

Delta x for start vector

Delta y for start vector

Delta x for end vector

Delta y for end vector

ImGearVectEntities.ARC entity.

Circular arc center close

Center

Delta x for start vector

Delta y for start vector

Delta x for end vector

Delta y for end vector

Type of arc closure

ImGearVectEntities.ARC entity.

Ellipse

Center

Endpoint of first conjugate diameter

Endpoint of second conjugate diameter

ImGearVectEntities.ELLIPSE entity.

Elliptical arc

Center

Endpoint of first conjugate diameter

Endpoint of second conjugate diameter

Delta x for start vector

Delta y for start vector

Delta x for end vector

Delta y for end vector

ImGearVectEntities.ARC entity.

Elliptical arc close

Center

Endpoint of first conjugate diameter

Endpoint of second conjugate diameter

Delta x for start vector

Delta y for start vector

Delta x for end vector

Delta y for end vector

Type of arc closure

ImGearVectEntities.ARC entity.

Marker bundle index

Index

Specifies a set of predefined parameters for markers. See Poly Marker section.

Marker type

Type

Specifies predefined type of marker. See Poly Marker section.

Marker size

Size

Specifies size of marker. See Poly Marker section.

Marker color

Color

Specifies color of marker. See Poly Marker section.

Poly Marker

Marker positions

ImGearVectEntities.BLOCK entity with several entities in its entity container.

Cell array

Corner point P

Corner point Q

Corner point R

Nx

Ny

Local color precision

Array of cell color values

ImGearVectEntities.RASTER entity.

Begin tile array

Position

Path direction

Line progression direction

Number of tiles in path direction

Number of tiles in line direction

Number of cells/tile in path direction

Number of cells/tile in line direction

Cell size in path direction

Cell size in line direction

Image offset in path direction

Image offset in line direction

Image number of cells in path direction

Image number of cells in line direction

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

Tile

Compression type

  • Supported types: Group4, 1D Group3, 2D Group3, JPEG
  • Not implemented: Null background, null foreground, bitmap, run length, LZW, PNG

Row padding indicator

Cell color precision

Compression-specific parameters

Bit stream

ImGearVectEntities.RASTER entity.

End tile array

Closes “Begin tile array”.

Begin segment

Segment identifier

ImGearVectEntities.BLOCK entity.

Segment display priority

Segment identifier

Priority

Used internally to sort segment blocks in the drawing.

Copy segment

Segment identifier

Transformation matrix

ImGearVectEntities.INSERTION entity that references the block specified by segment identifier.

Polybezier

Continuity indicator

Control points

ImGearVectEntities.BEZIER_CURVE entity.

Non-uniform B-spline

Spline order

Number of control points

Control points

List of knots

ImGearVectEntities.NURBS_CURVE entity.

Non-uniform rational B-spline

Spline order

Number of control points

Control points

List of knots

List of weights

ImGearVectEntities.NURBS_CURVE entity.

End Picture

Finishes reading the page.

End segment

Closes "Begin segment" element.

End metafile

Finishes reading the file.

ImageGear Vector Entities Supported for Writing to CGM Format

Only the content of active view is saved in CGM format. View content is transformed using view transformation when saving.

ImageGear Entity or Object | Saved as CGM Element
ImGearVectorView | VDC extent. Begin picture body. End picture body.
ImGearVectEntities.BLOCK | Sequence of CGM elements for every entity.
ImGearVectEntities.EASYLINE | Polyline.
ImGearVectEntities.TEXT | Text, Restricted text, Append text, depending on the entity settings.
ImGearVectEntities.POLYLINE | Polyline or polygon, depending on the entity settings.
ImGearVectEntities.INSERTION | Sequence of CGM elements for every entity in the referenced block.
ImGearVectEntities.RASTER | Cell array.
ImGearVectEntities.ARC | Circular arc 3 point, Circular arc 3 point close, Elliptical arc, Elliptical arc close, depending on the entity settings.
ImGearVectEntities.ELLIPSE | Circle or Ellipse, depending on the entity settings.
ImGearVectEntities.NURBS_CURVE | Non-uniform B-spline or Non-uniform rational B-spline, depending on the entity settings.
ImGearVectEntities.BEZIER_CURVE | Polybezier.
ImGearVectEntities.NURBS_SURFACE | The surface is saved as a set of Polyline objects, without interpolation and without taking into account knots and weights.
ImGearVectEntities.VIEWPORT | Clip rectangle.
ImGearVectEntities.FIGURE | “Begin Figure”, several “New Region” and “End Figure” objects.
ImGearVectEntities.CONNECTION | Connecting Edge.
ImGearVectEntities.POLYLINEEX | Polygon set.
ImGearVectEntities.EASY_SURFACE | The surface is saved as a set of Polyline objects.
ImGearVectEntities.SHELL | A set of Polyline or Polygon objects, depending on the entity settings.
ImGearVectEntities.SOLID | Polyline or Polygon object, depending on the entity settings.


CLP
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CLP
Full Name | Windows Clipboard
Format ID | ImGearFormats.CLP
File Extension(s) | *.clp
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters

None

Comments

The CLP file format represents a subset of a file format called Pictor PC Paint. The use for PC Paint format is to display images created by the PC Paint application to IBM display hardware (CGA, EGA, VGA, etc.).

The header of a CLP file is fairly short and simple, containing the file size (in bytes), and the height, width, and address of the image. The image data may be compressed or uncompressed. If it is compressed, the header contains two additional fields to give the number of bits per pixel of the packed data, and the address of the beginning of the packed run.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


CR2
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CR2
Full Name | Canon CR2 Camera Raw Format
Format ID | ImGearFormats.CR2
File Extension(s) | *.cr2, *.tif
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.JPEG:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

This is one of the two main formats that Canon digital cameras use to store Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Canon CR2 format uses EXIF file structure as the base. CR2 images contain a preview in the root IFD. This allows applications that do not support CR2 format, load the preview as a valid TIFF-EXIF image. Actual raw data is stored in the EXIF makernote tag. Raw data is encoded using JPEG lossless compression.


CRW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CRW
Full Name | Canon CRW Camera Raw Format
Format ID | ImGearFormats.CRW
File Extension(s) | *.crw
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • Proprietary Canon compression:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

This is one of the two main formats that Canon digital cameras use to store Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Canon CRW format uses CIFF file structure as the base. CIFF file format is similar to TIFF in many aspects, but is not compatible with it. Raw data is encoded using Canon proprietary compression.


CUR
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CUR
Full Name | Windows cursor
Format ID | ImGearFormats.CUR
File Extension(s) | *.cur
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | Single alpha channel for read/write (see Comments).
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

Windows 3.x

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

None

Comments

Cursor files consist of a file header (that is repeated several times), info headers, and cursor data. Cursor data contains an XOR mask bitmap and a monochrome AND mask bitmap. Whenever Windows draws a cursor, the AND bitmap is applied to whatever is on the screen. After that, the XOR bitmap is applied.

Files must be 255x255 pixels or less.

References Used

A Jorn Daub EDV-Beratung - Glashutter Weg 105 - D-22889 Tangstedt

fileformats@daubnet.com


CUT
User Guide > File Formats and Compressions > File Formats > File Formats Reference > CUT
Full Name | Dr. Halo
Format ID | ImGearFormats.CUT
File Extension(s) | *.cut, *.pal (for the separately stored palette)
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64, Unix, Unix64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Write Support

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Filter Control Parameters

None

Comments

The Dr. Halo file format is associated with the HALO Image File Format Library, the Dr. Halo III paint program, and other applications created by Media Cybernetics.

This format consists of two separate files, one with an extension of .CUT and the other with an extension of .PAL. The .CUT file contains the image data and the .PAL file contains the color palette.

The .CUT file begins with a simple header of just three data fields: width and height of the image data (pixels by scan lines), and a reserved field intended for use with any future expansions of the header. The image data is always RLE-encoded and follows the header.

The palette file (.PAL) contains a header, with information about the type of palette used, and the size and maximum values of the Red, Green, and Blue components. The palette can be hardware-specific, in which case it contains additional data.

When a CUT image is loaded into ImageGear, the palette is initialized to a grayscale ramp. In order to achieve the original colors of the palette (PAL file), it must be loaded separately into the HIGEAR image.

When saving an image into the Dr. Halo format, ImageGear creates a .CUT file. In order to save the palette (PAL file), it must be saved separately.

See the RLE Compression for more information.

Auto-detection of CUT format (Dr. Halo CUT) is disabled by default. The format is not popular and has unreliable detection. An application can enable auto-detection of the format if needed, using IImGearFormat Interface.DetectionEnabled Property.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


DCRAW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DCRAW
Full Name | Digital camera RAW format
Format ID | ImGearFormats.DCRAW
File Extension(s) | *.*
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64, Unix, Unix64, MAC

ImageGear Supported Versions

Please see Digital Camera RAW Formats.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Gray level: 10..16 bpp;
    • RGB: 48 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ApplyColorSpaceConversion | bool | true | false, true | Set to true to convert raw image to linear sRGB colorspace during loading. Has effect only if ApplyLowLevelProcessing is true.
ApplyLowLevelProcessing | bool | true | false, true | If true, ImageGear applies initial processing stages on the Raw image. If false, ImageGear loads Raw image without any post-processing. See also ApplyColorspaceConversion and ApplyToneCorrection parameters.
ApplyToneCorrection | bool | true | false, true | Set to true to automatically adjust image tone and apply sRGB gamma correction during loading. Has effect only if both ApplyLowLevelProcessing and ApplyColorspaceConversion are true.


DCX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DCX
Full Name | Paintbrush (Intel multi-page FAX format)
Format ID | ImGearFormats.DCX
File Extension(s) | *.dcx
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

This file format was designed to allow multiple PCX files to be stored in one file. This is especially desirable for multi-page faxes (for which the PCX format is often used). Up to 1024 PCX images can be stored in one DCX file.

The DCX construct begins with a simple header, then the PCX files are simply stored end-to-end, complete with their individual headers and palettes. An array in the header called "Pagetable" contains offsets to each PCX. The one piece of vital information not stored with the PCX files under a DCX is their original filenames. See the PCX section of this manual for more about PCX files.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


DGN
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DGN
Full Name | MicroStation Drawing (Drawing format used by MicroStation construction design software)
Format ID | ImGearFormats.DGN
File Extension(s) | *.dgn
Data Type | Vector image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, Win64, .NET, .NET64
DGN format requires ImageGear.Formats.DGN Namespace.

ImageGear Supported Versions

  • DGN_VERSION_UNKNOWN
  • DGN_VERSION_DGN2
  • DGN_VERSION_DGN1_2D
  • DGN_VERSION_DGN1_3D
  • DGN_VERSION_CEL1_2D
  • DGN_VERSION_CEL1_3D

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Backcolor | Long | 0 | Any positive value | This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

DGN is a CAD file format used by Intergraph IGDS CAD software. It is not as commonly used as some other CAD file formats, but it has an open specification.

DGN Elements Supported for Reading

DGN Element | Supported Attributes | Imported into ImageGear as:
Shared cell definition | Cell name | ImGearVectEntities.BLOCK entity.
Shared cell instance | Cell name Transformation matrix | ImGearVectEntities.BLOCK entity that appends the shared cell definition to its container and is made current.
Shape | Points Color Line type | ImGearVectEntities.POLYLINE entity.
Cell header | Cell name | ImGearVectEntities.BLOCK entity.
Line string | Points Color Line type | ImGearVectEntities.POLYLINE entity.
Curve | Points Color Line type | ImGearVectEntities.POLYLINE entity.
B-spline surface | Order Rational flag Poles Knots Rule lines Color Line type | ImGearVectEntities.NURBS_SURFACE entity.
Text | Font Alignment Width Height Rotation Text string Color | ImGearVectEntities.TEXT entity.
Arc | Start angle End angle X Radius Y Radius Rotation Center Color Line type | ImGearVectEntities.ARC entity.
Ellipse | X Radius Y Radius Rotation Center Color Line type | ImGearVectEntities.ELLIPSE entity.
Line | Start point End point Color Line type | ImGearVectEntities.EASYLINE entity.
Group data: Named View level | Origin Matrix | Several ImGearVectorView objects.
Group data: Color table level | 256 color values | Used as a palette internally.
Level symbology |  | ImGearVectorLayer object.


DIB
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DIB
Full Name | DIB (Microsoft Windows Device Independent Bitmap)
Format ID | ImGearFormats.BMP
File Extension(s) | *.dib
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
IG Metadata Update Support | No
IG Platforms Support | WIN32, WIN64, .NET, .NET64

ImageGear Supported Versions

See BMP format description.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
UpsideDown | bool | false | false, true | If true then the images will be saved upside-down
Type | int | 1 (BMI, MS Windows format) | 0 (BMC, OS/2 1.x format), 1 (BMI, MS Windows format), 2 (BMI2, OS/2 2.x format). | BMP type to use for saving.
Scanner16GrayEnabled | bool | false | false, true | Vidar 12-bit scanner options
Scanner16GrayType | int | 0 | 0, 1 | Vidar 12-bit scanner options: 0 a no particular scanner is specified. 1 a old VXR 12 scanner.

Comments

DIB is a synonym for the BMP format.


DICOM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DICOM
Full Name | DICOM (Digital Imaging & Communication in Medicine)
Format ID | ImGearFormats.DICOM
File Extension(s) | *.dicm, *.dcm
Data Type | Raster or vector image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | Page, Document
ImageGear Platforms Support | WIN32, WIN64, Unix (Linux), .NET, .NET64

To support DICOM format, attach the ImageGear.Formats.DICOM Namespace to Core ImageGear.

ImageGear Supported Versions

  • DICOM 3.0, 1991 - 2006

ImageGear Supported Features

  • IG_FLTR_DETECTSUPPORT - autodetection
  • IG_FLTR_PAGEREADSUPPORT - single page file reading
  • IG_FLTR_PAGEINSERTSUPPORT - single-page file writing
  • IG_FLTR_PAGEDELETESUPPORT - page deleting from multi-page file (only deletion of the last page is supported)
  • IG_FLTR_MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1, 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp
    • Vector/waveform data
  • ImGearCompressions.JPEG (lossy):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG2K:
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp
ImageGear also supports reading of Adobe PDF documents, encapsulated in DICOM files. See the PDF description for information on supported Adobe PDF features.

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Grayscale: 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossy - baseline / process 1):
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossy - extended / process 2&4):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG2K:
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp
  • To use the JPEG 2000 Compression scheme, attach the ImageGear.Formats.JPEG2K Namespace.

    To be able to load and encapsulate an PDF document, attach the ImageGear.Formats.PDF Namespace.

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
DetectContinuousRLE | bool | true | false, true | Set to true for ImageGear to detect and load images where RLE runs across row boundaries. This parameter specifies what to do with RLE compressed images where RLE runs across row boundaries. If it is set to true , ImageGear tries to detect and load images where RLE runs across row boundaries. Otherwise, ImageGear truncates any row overruns and decodes each row separately. This parameter does not effect the loading of properly encoded images, where each row is encoded separately.
LoadConcatenateRepeatedDE | bool | false | false, true | Set to true to concatenate repeated data elements into one data element during loading. **
LoadDetectSkipDIMSE | bool | false | false, true | Set to false if files may contain DIMSE commands - that could throw off the format detection
LoadSavePixdataTag | bool | false | false, true | Set to true to allow loading and saving pixel data to/from the metadata tree rather than to/from ImageGear DIB.***
LoadSyntax | ImGearDICOMTransferSyntaxes Enumeration | AUTODETECT | ImGearDICOMTransferSyntaxes Enumeration | Transfer Syntax to load DCM image with.
LoadWithoutDetection | bool | false | true, false | Set to true to skip detection phase before loading a DICOM image.*
SaveAsPart10 | bool | true | true, false | true will cause the Header to be saved
SaveGroupLengths | bool | true | true, false | true =include false =exclude
SavePlanarConfig | ImGearDICOMPlanarConfigurations Enumeration | PIXEL_BY_PIXEL | ImGearDICOMTransferSyntaxes Enumeration | Planar configuration for image saving.
SaveSyntax | ImGearDICOMTransferSyntaxes Enumeration | DEFAULT | All supported values of ImGearDICOMTransferSyntaxes Enumeration. **** | Transfer Syntax to save DCM image with.

*) LoadWithoutDetection parameter affects loading of DICOM images that do not have File Meta Info (Part10) header. If false (default), the DICOM filter checks that the first several Data Elements are well formed, and if they are not, stops the reading. If true, the filter skips checking the first tags, and attempts to read the image, using the Transfer Syntax specified in the LoadSyntax parameter. LoadSyntax parameter should be set to a specific syntax, rather than AUTODETECT, PART10 or UNKNOWN. When loading the file, set loadOptions.Format to ImGearFormats.DICOM. Use this mode if you know for sure the file is a DICOM, and you know its transfer syntax.

**) Parameter LoadConcatenateRepeatedDE allows you to load incompliant DICOM images where some data elements are cut into several repeated data elements. Instead of one data element containing an array of values, the data set contains several data elements, with the same group/element numbers pair, containing portions of the array. Specifically, there are images with look up tables and palettes stored in this way. Set LoadConcatenateRepeatedDE parameter to TRUE to concatenate repeated data elements into one data element during loading. Otherwise (default), ImageGear loads all of the repeated elements in the same way as they are located in the file. Note that ImageGear does not allow saving of repeated data elements. If a data set contains repeated data elements, ImageGear will only write the first repeated element to the file.

***) When LoadSavePixdataTag is true during image loading, ImageGear does not read pixel data into a DIB, but instead creates an empty DIB and loads pixel data into Metadata Tree, so the image will not be displayed. ImageGear represents the PixelData tag in the metadata tree as either byte array or ushort array, according to Value Representation of PixelData Tag (OB or OW).

In uncompressed images this array contains uncompressed pixel data. If the image has multiple pages (frames), pixel data of all frames is concatenated in this array.

In compressed images pixel data always has value representation of OB, so ImageGear represents it as a byte array. Content of this array has rich internal structure, similar to DICOM Sequence of Items. The first item is the Basic Offset Table, which is either empty, or contains offsets to image frames within the array. The rest of items contain compressed frames. At the end of the pixel data there is the sequence delimitation item. ImageGear does not expose this structure to the application. If the application needs to access individual frames, it shall parse this byte array. See DICOM PS 3.5 - 2008, Annex A.4 "TRANSFER SYNTAXES FOR ENCAPSULATION OF ENCODED PIXEL DATA" for additional details.

If LoadSavePixdataTag parameter is true during image saving, ImageGear uses pixel data from the PixelData tag of the DICOM metadata tree, instead of the ImGearPage DIB. When saving an image in this mode, make sure that saving Transfer Syntax exactly matches the Transfer Syntax of PixelData element. If it is not so, saved image will be incompatible with the standard and most probably unreadable, because transfer syntax of the pixel data will not match transfer syntax specified in file header.

****) Currently, the following values of ImGearDICOMTransferSyntaxes Enumeration are supported:

ImGearDICOMTransferSyntaxes.DEFAULT

ImGearDICOMTransferSyntaxes.IMPLICIT_VR_LE

ImGearDICOMTransferSyntaxes.EXPLICIT_VR_LE

ImGearDICOMTransferSyntaxes.EXPLICIT_VR_BE

ImGearDICOMTransferSyntaxes.JPEG_BASELINE_PR_1

ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_2_4

ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_3_5

ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_NONH_PR_6_8

ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_NONH_PR_7_9

ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_NONH_PR_10_12

ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_NONH_PR_11_13

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_14

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_15

ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_HIER_PR_16_18

ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_HIER_PR_17_19

ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_HIER_PR_20_22

ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_HIER_PR_21_23

ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_HIER_PR_24_26

ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_HIER_PR_25_27

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_HIER_PR_28

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_HIER_PR_29

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_FIRSTORDER_PR_14

ImGearDICOMTransferSyntaxes.JPEG_LOSSY

ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS

ImGearDICOMTransferSyntaxes.JPEG_2K_LOSSLESS_ONLY

ImGearDICOMTransferSyntaxes.JPEG_2K

ImGearDICOMTransferSyntaxes.RLE

Comments

DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images. Today DICOM is the standard for medical imaging throughout the world.

DICOM image (alternately called Data Set) contains an ordered collection of attributes referred to as "Data Elements" that are related to one or more images. Each Data Element (DE) describes a single attribute of the image, patient, or study. The images themselves are also stored in DEs.

Each DICOM Data Set is transported through the Network, and consequently, stored in a file, using one of the defined Transfer Syntaxes. The Transfer Syntax of the DICOM file indicates whether the file uses Big Endian or Little Endian byte order, whether the image data is compressed or uncompressed, and if the DICOM Data Set uses Explicit or Implicit Value Representation (VR).

The Data Element (DE) is made up of the following parts:

  • Tag
  • Value Representation (optional)
  • Value Lenth
  • Value

Tag field identifies the type of information that is contained in the Value field (where the actual data is stored). The DICOM Data Dictionary (Part 6 of the specification) defines all possible public Data Element Tags that may be used. DICOM also allows applications to define and use private Tags and thus define their own Data Elements. Value Representation (VR) specifies the format of the Data Element Value, such as UL (unsigned long), ST (Short Text) or PN (Person Name). If Implicit Transfer Syntax is used, the VR field is omitted. It can be obtained from the standard or private Data Dictionary. Value Lenth is the lenth (in bytes) of the Data field.

DICOM also allows embedding (nesting) Data Sets within Data Sets. Nested Data Sets are implemented using a "Sequence of Items" (SQ), which is a special type of Data Element.

A special group of tags at the beginning of the file allows application to recognize the file as a DICOM image file, and includes information needed to decode the file (Transfer Syntax), and serial numbers to help locate and keep track of each field. This header is referred to as "File Meta Information Header", or "Part 10 Header" (since it is defined in Part 10 of the DICOM standard). While the standard clearly states that all DICOM image files must include a Part 10 Header, in reality one finds that many do not. Instead, the average DICOM image file is a simple data stream capture of the data into a file. This is called a "Raw Data" DICOM image file. In order to read a Raw DICOM the Transfer Syntax must be guessed at using a Transfer Syntax detection algorithm.

The actual pixel data for a DICOM image is stored in a Data Element, just like any other DICOM information. Image parameters, such as dimensions, bit depth, photometric interpretation etc., are also stored in Data Elements. The Tag for Pixel Data is called "Pixel Data" and has the Tag Number 7FE0, 0010. The Data Field in this Data Element contains all pixels for the image. Depending on the image's Transfer Syntax, the Pixel Data can be compressed or uncompressed.

See also DICOM Images.

References Used

Digital Imaging and Communication in Medicine (DICOM). Published by: National Electrical Manufacturers Association: http://medical.nema.org/dicom.html .


DNG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DNG

Full Name | Digital Negative file format
Format ID | ImGearFormats.DNG
File Extension(s) | *.dng
Data Type | Bitmap (2D raster)
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

  • Version 1.0.0.0
  • Version 1.1.0.0 a fixed incompatibility in JPEG Lossless compression, added new tags

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE
    • Without color reconstruction: Grayscale - 16 bpp;
    • With color reconstruction: RGB - 24, 48 bpp*
  • ImGearCompressions.JPEG
    • Without color reconstruction: Grayscale - 16 bpp;
    • With color reconstruction: RGB - 24, 48 bpp*

* 8bpc DNG loading has been enabled via promoting the image to 16bpc before loading.

ImageGear Write Support

None.

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ApplyColorSpaceConversion | bool | true | false, true | Set to true to convert raw image to linear sRGB colorspace during loading. Has effect only if ApplyLowLevelProcessing is true.
ApplyLowLevelProcessing | bool | true | false, true | If true, ImageGear applies initial processing stages on the Raw image. If false, ImageGear loads Raw image without any post-processing. See also ApplyColorspaceConversion and ApplyToneCorrection parameters.
ApplyToneCorrection | bool | true | false, true | Set to true to automatically adjust image tone and apply sRGB gamma correction during loading. Has effect only if both ApplyLowLevelProcessing and ApplyColorspaceConversion are true.
UseCameraWhiteBalance | bool | true | false, true | If true, ImageGear uses white balance settings from the file. Otherwise, white ballance is calculated using ImageGear's algorithm.

Comments

This file format was developed by Adobe as a non-proprietory format for unified storage of "raw" images from digital cameras. DNG image stores unprocessed pixel data obtained from camera's sensor, and keeps information about color, contrast and brightness adjustments, sharpening, as well as many other parameters, in its tags. This provides greater possibilities for image correction and enhancement, compared to commonly used formats such as JPEG, EXIF or TIFF.

The fact that the format is non-proprietary allows software vendors to provide support for DNG in their applications, with complete control over the image reconstruction process.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

DNG extends TIFF/EP format. It adds a set of new tags for parameters that control reconstruction of full color image from the raw data.

References Used

ADOBE SYSTEMS INCORPORATED. Digital Negative (DNG) specification.


DOCX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DOCX
Full Name | Office Open XML Word Format
Format ID | ImGearFormats.DOCX
File Extension(s) | *.docx
Data Type | Vector Image
Data Encoding | Zipped XML Package
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | .NET, .NET64
DOCX format requires ImageGear.Formats.Office Namespace.

ImageGear Supported Versions

  • ECMA-376, Second Edition

ImageGear Supported Features

  • Autodetection
  • Single page file reading
  • Multiple page file reading

ImageGear Read Support

  • DOCX files conformed to ECMA-376, Second Edition Specification.

Please use ImGearFileFormats.LoadDocument to load Word files. The ImGearFileFormats.LoadPage is not supported for Word documents.

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

Please see Using ImageGear.Formats.Office Namespace.

Please see the ImageGear.Formats.Office Namespace.


DWF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DWF
Full Name | DWF (Design Web Format)
Format ID | ImGearFormats.DWF
File Extension(s) | *.dwf, *.w2d, *.w3d
Data Type | Vector/CAD image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, .NET
DWF format requires ImageGear.Formats.DWF Namespace.

ImageGear Supported Versions

  • Up to version 6.20

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

DWF is an open format developed by AutoDesk (Design Web Format). Unlike DWG and DXF, DWF is focused on viewing only. It is intended to be used for publishing 2D and 3D CAD drawings so they can be easily viewed without requiring the use of CAD software.

DWF Features Supported for Reading

ImageGear uses DWFToolkit for reading DWF file contents. The following tables use DWFToolkit terms to list DWF features supported by ImageGear:

  • 2D Features
  • 3D Features

2D Features

DWF Toolkit Object | Supported Attributes | Imported into ImageGear as:
WT_Polygon | Vertices | ImGearVectEntities.POLYLINE entity.
WT_Polyline | Vertices | ImGearVectEntities.POLYLINE entity.
WT_Color | RGBA color | Current color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object.
WT_Background | RGBA color | Background color for ImGearVectorView object.
WT_Text | Text string Bounds Position | ImGearVectEntities.TEXT entity.
WT_Text_HAlign | Horizontal alignment | Horizontal alignment for ImGearVectEntities.TEXT entity.
WT_Text_VAlign | Vertical alignment | Vertical alignment for ImGearVectEntities.TEXT entity.
WT_Font | Font name Font height Font rotation Font spacing Font width scale Font is bold flag Font is italic flag Font is underlined flag | Used for creating ImGearVectorFont object.
WT_Line_Weight | Weight | Used as a thickness when creating ImGearVectAttrib.THICKNESS attribute.
WT_Fill | Fill mode | Used internally to turn filling mode on/off.
WT_Filled_Ellipse | Start angle End angle Rotation Major axe Minor axe Center X position Center Y position | Either ImGearVectEntities.ELLIPSE or ImGearVectEntities.ARC entity.
WT_Outline_Ellipse | Start angle End angle Rotation Major axe Minor axe Center X position Center Y position | Either ImGearVectEntities.ELLIPSE or ImGearVectEntities.ARC entity.
WT_Polytriangle | Vertices | ImGearVectEntities.GEOMETRY entity.
WT_Visibility | Visibility | Affects the visibility of entities.

3D Features

DWF Toolkit Object | Supported Attributes | Imported into ImageGear as:
Color | Diffuse color | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object.
Color_RGB | RGB value | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object.
Color_By_Value | Value | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object. Color value is converted into RGB.
Color_By_Index | Index | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object. Color value is converted into RGB.
Color_By_Index_16 | Index | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object. Color value is converted into RGB.
Color_By_FIndex | Index | Color for creating ImGearVectAttrib.DRAWCOLOR, ImGearVectAttrib.FILLCOLOR attributes and a color of ImGearVectorTextObject object. Color value is converted into RGB.
Color_Map | Color values | Used to get an actual color value by index.
View | Target Position Up vector | Transformation matrix of ImGearVectorView object.
Modelling_Matrix | 4x4 matrix | Transformation for entities.
Open_Segment | Segment name | ImGearVectEntities.BLOCK and ImGearVectEntities.INSERT entities. ImGearVectEntities.INSERT references ImGearVectEntities.BLOCK. The block is set as current.
Close_Segment |  | Restores previous current block.
Include_Segment | Segment name | ImGearVectEntities.INSERT entity that references the existing block.
Visibility | Visibility | Affects the visibility of entities.
Text_Alignment | Alignment | Specifies an alignment for ImGearVectEntities.TEXT entity.
Text_Font | Mask Name Size Width factor Width scale Extra space Rotation | Used for creating ImGearVectorFont object and for some settings of ImGearVectEntities.TEXT entity.
Circle | Start point Middle point End point Center | ImGearVectEntities.ELLIPSE entity.
Circular_Arc | Start point Middle point End point Center | ImGearVectEntities.ELLIPSE or ImGearVectEntities.ARC entity.
Circular_Hord | Start point Middle point End point Center | ImGearVectEntities.ELLIPSE or ImGearVectEntities.ARC entity.
Circular_Wedge | Start point Middle point End point Center | ImGearVectEntities.ELLIPSE or ImGearVectEntities.ARC entity.
Ellipse | Major Minor Center | ImGearVectEntities.ELLIPSE entity.
Elliptical_Arc | Major Minor Center Limits (Angles) | ImGearVectEntities.ARC entity.
Line | Points | ImGearVectEntities.EASYLINE entity.
Polygon | Points | ImGearVectEntities.POLYLINE entity.
Polyline | Points | ImGearVectEntities.POLYLINE entity.

ImageGear Vector Entities Supported for Writing to DWF Format

All vector data is saved as 2D stream. 3D coordinates are projected to 2D surface during saving, according to the active view transformation.

ImageGear Entity or Object | Saved as DWF Element
ImGearVectEntities.EASYLINE ImGearVectEntities.POLYLINE ImGearVectEntities.POLYLINEEX ImGearVectEntities.ARC ImGearVectEntities.ELLIPSE ImGearVectEntities.NURBS_CURVE ImGearVectEntities.BEZIER_CURVE | Vector Cache data is written as either WT_Polygon or WT_Polyline, depending on draw and fill attributes.
ImGearVectEntities.NURBS_SURFACE | Mesh object of the NURBS surface is saved as several WT_Polyline objects.
ImGearVectEntities.BEZIER_SURFACE | Mesh object of the Bezier surface is saved as several WT_Polyline objects.
ImGearVectEntities.BLOCK | All entities in the block container are saved taking into account the block transformation.
ImGearVectEntities.TEXT | WT_Text objects. WT_Font objects are created if necessary.
ImGearVectEntities.INSERTION | All entities in the reverenced block container are saved taking into account the insertion and block transformation.
ImGearVectEntities.VIEWPORT | Viewport content is saved taking into account the viewport scaling and transformation.
ImGearVectEntities.FIGURE | Vector Cache data is written as WT_Polygon. Every internal entity of the figure is also saved as WT_Polyline.
ImGearVectEntities.EASY_SURFACE | Mesh object of the surface is saved as several WT_Polyline objects.
ImGearVectEntities.SHELL | Faces of the shell are saved as WT_Polyline objects.
ImGearVectEntities.SOLID | Either WT_Polygon or WT_Polyline, depending on draw and fill attributes.
ImGearVectEntities.GEOMETRY | WT_Polytriangle object.


DWG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DWG
Full Name | DWG (AutoDesk AutoCAD)
Format ID | ImGearFormats.DWG
File Extension(s) | *.dwg
Data Type | Vector/CAD image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, Win64, .NET, .NET64
DWG format requires ImageGear.Vector Namespace.

ImageGear Supported Versions

  • Read: AC1002, AC1003 AC1004, AC1006, AC1009, AC1012, AC1013, AC1014, AC1015, AC1018, AC1021, AC1024, AC1027
  • Write: AC1012, AC1013, AC1014, AC1015, AC1018, AC1021, AC1024, AC1027

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BackColor | Long | 0 | Any positive value | This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.
FontPath String "" Any string up to 262 characters Defines a path to the vector font files. Format - <Path1>;< Path2>;... .
Password String "" Any string up to 262 characters Used to set password for encrypted files before reading.
Version String ACAD2004
  • ACAD12
  • ACAD13
  • ACAD14
  • ACAD2000
  • ACAD2004
  • ACAD2007
  • ACAD2010
  • ACAD2013
Used to specify version to save the file as.
ShowHidden | Boolean | False | True, False | If true, hidden layers are shown by default.

Comments

DWG, short for "DraWinG", is a CAD file format which serves as the native file format for drawings created in AutoCAD.

DWG/DXF Elements Supported for Reading

CAD Element | Supported Attributes | Imported into ImageGear as:
VIEWPORT | Center point Width Height View target View direction Frozen layers Non-rectangle clipping | ImGearVectEntities.VIEWPORT entity.
LINE | Start point End point Draw color Line type Line weight | ImGearVectEntities.EASYLINE entity.
2D Simple polyline | Vertices Draw color Line type Start width | ImGearVectEntities.POLYLINE entity.
2D Quadratic spline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=2.
2D Cubic spline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=3.
2D Fit polyline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as cubic B-spline.
3D Simple polyline | Vertices Draw color Line type Line weight | ImGearVectEntities.POLYLINE entity.
3D Quadratic spline | Vertices Draw color Line type Line weight | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=2.
3D Cubic spline | Vertices Draw color Line type Line weight | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=3.
Polyface mesh (if contains faces) | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
Polyface mesh (if does not contain faces) | Draw color Line type Line weight Hidden vertices | ImGearVectEntities.POLYLINE entity.
Block reference | Scale Position Orientation Draw color Fill color Line type Fill type | ImGearVectEntities.INSERTION entity.
Spline | Knots Vertices (weights are supported) Draw color Line type | ImGearVectEntities.NURBS_CURVE entity.
Ellipse | Orientation Major axe Ratio Start angle End angle Center Draw color Line type Line weight | ImGearVectEntities.ARC entity.
Solid | Points [0…3] Draw color Line type Fill color Fill type Thickness | ImGearVectEntities.SOLID entity.
Trace | Points [0…3] Draw color Line type Fill color Fill type Thickness | ImGearVectEntities.SOLID entity.
3D solid | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
Polyline (don’t confuse with 2D polyline and 3D polyline) | Vertices (Bulge attribute is supported) Draw color Line type Constant width | ImGearVectEntities.POLYLINE entity.
Hatch | Draw color Line type Fill color Fill type Gradient filling Hatch lines | ImGearVectEntities.FIGURE entity.
Circle | Orientation Center Radius Draw color Line type Line weight | ImGearVectEntities.ELLIPSE entity.
Region | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
MText | Orientation Text color Location Font Font height Font width factor Underlined flag | ImGearVectEntities.BLOCK entity with several ImGearVectEntities.TEXT entities and ImGearVectEntities.INSERT that references this block.
Text | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Attribute | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Attribute definition | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Raster image | Units File name Image size Image scale Clip boundary | ImGearVectEntities.RASTER entity.
Face | Vertices Draw color Line type | ImGearVectEntities.POLYLINE entity.
Arc | Orientation Center Start angle End angle Radius Draw color Line type Thickness | ImGearVectEntities.ARC entity.
Dimension | Block position Draw color Line type Fill color Fill type | ImGearVectEntities.INSERTION entity that references the existing block.
Leader | Arrow head Vertices Scale Arrow head size Reference box Fill color Fill type Draw color Line type | ImGearVectEntities.INSERTION and ImGearVectEntities.BLOCK with ImGearVectEntities.POLYLINE and ImGearVectEntities.SOLID entities inside it.
Tolerance | Location Text Size of the text Draw color Line type Fill color Different shape attributes of included entities | ImGearVectEntities.INSERTION and ImGearVectEntities.BLOCK with several entities inside it, such as ImGearVectEntities.TEXT, ImGearVectEntities.ELLIPSE, and so on.
Block table record | Draw color Line type Fill color Fill type | ImGearVectEntities.BLOCK entity.
Viewport table record (don’t confuse with VIEWPORT entity) | View name View content as a block Direction Target point Twist (angle) Clip distance Background color | ImGearVectorView object.

ImageGear Vector Entities Supported for Writing to DWG and DXF Formats

ImageGear Entity or Object

Saved as DWG/DXF Element

ImGearVectEntities.BLOCK

Block table record.

ImGearVectEntities.INSERTION

Block reference.

ImGearVectEntities.EASYLINE

Line.

ImGearVectEntities.POLYLINE

Depending on fill type and vertex count:

  • Polyline
  • Face
  • 3D Polyline
  • Hatch

    Hatch is created if non-zero fill type object is attached to the polyline and its type is one of the following:

    • ImGearVectFillPattern.SOLID
    • ImGearVectFillPattern.HATCH_BDIAGONAL
    • ImGearVectFillPattern.HATCH_CROSS
    • ImGearVectFillPattern.HATCH_DIAGCROSS
    • ImGearVectFillPattern.HATCH_FDIAGONAL
    • ImGearVectFillPattern.HATCH_HORIZONTAL
    • ImGearVectFillPattern.HATCH_VERTICAL
    • ImGearVectFillPattern.GRADIENT

ImGearVectEntities.POLYLINEEX

3D polyline for every contour. If non-zero fill type object is attached to the polyline, then a Hatch is created as well.

ImGearVectEntities.ELLIPSE
  • If the entity contains a draw color attribute, then Ellipse object is created.
  • If the entity references a fill type, then Hatch object is created.

ImGearVectEntities.ARC
  • If draw color is attached to the entity, then Ellipse object is created.
  • If non-zero fill type object is attached to the entity, then Hatch object is created.

ImGearVectEntities.TEXT

Several Text objects.

ImGearVectEntities.BEZIER_CURVE
  • If curve flag is set to ImGearVectNURBSFlags.MFIT, then 2D Fit polyline;
  • If Bezier degree is 2, then 3D Quadratic spline;
  • If Bezier degree is 3, then 3D Cubic spline.

ImGearVectEntities.NURBS_CURVE

Spline.

ImGearVectEntities.EASY_SURFACE

Polygon mesh.

ImGearVectEntities.FIGURE
  • If the entity references a fill type, then hatch object is created.
  • If the entity references a line type, then internal entities are saved as Polyline objects using entity data cache.

ImGearVectEntities.RASTER

Raster image (saved to a separate raster file and referenced from the DWG/DXF file). Filename must be specified for the raster entity.

ImGearVectEntities.VIEWPORT

Viewport (don’t confuse with Viewport table record).

ImGearVectEntities.SHELL

If the entity contains only triangles and quadrilaterals then it is saved as polyface mesh. Otherwise, the entity is saved as line segments or region.

ImGearVectEntities.SOLID

Solid.

ImGearVectEntities.GEOMETRY

If Fill type exists, then region; otherwise line segments.

ImGearVectorView

Viewport table record.


DXF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > DXF
Full Name | DXF (AutoDesk AutoCAD)
Format ID | ImGearFormats.DXF
File Extension(s) | *.dxf
Data Type | Vector/CAD image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, Win64, .NET, .NET64
DXF format requires ImageGear.Vector Namespace.

ImageGear Supported Versions

  • Read: AC1002, AC1003 AC1004, AC1006, AC1009, AC1012, AC1013, AC1014, AC1015, AC1018, AC1021, AC1024, AC1027
  • Write: AC1012, AC1013, AC1014, AC1015, AC1018, AC1021, AC1024, AC1027

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BackColor | Long | 0 | Any positive value | This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.
FontPath String "" Any string up to 262 characters Defines a path to the vector font files. Format - <Path1>;< Path2>;... .
Password String "" Any string up to 262 characters Used to set password for encrypted files before reading.
Version String ACAD2004
  • ACAD12
  • ACAD13
  • ACAD14
  • ACAD2000
  • ACAD2004
  • ACAD2007
  • ACAD2010
  • ACAD2013
Used to specify version to save the file as.
ShowHidden | Boolean | False | True, False | If true, hidden layers are shown by default.

Comments

DXF is an AutoDesk graphics format (Drawing eXchange Format). Most CAD programs (PC-based) support this format. Compared to DWG, it is simpler and more broadly supported among different software.

DWG/DXF Elements Supported for Reading

CAD Element | Supported Attributes | Imported into ImageGear as:
VIEWPORT | Center point Width Height View target View direction Frozen layers Non-rectangle clipping | ImGearVectEntities.VIEWPORT entity.
LINE | Start point End point Draw color Line type Line weight | ImGearVectEntities.EASYLINE entity.
2D Simple polyline | Vertices Draw color Line type Start width | ImGearVectEntities.POLYLINE entity.
2D Quadratic spline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=2.
2D Cubic spline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=3.
2D Fit polyline | Vertices Draw color Line type Start width | ImGearVectEntities.BEZIER_CURVE entity, interpolated as cubic B-spline.
3D Simple polyline | Vertices Draw color Line type Line weight | ImGearVectEntities.POLYLINE entity.
3D Quadratic spline | Vertices Draw color Line type Line weight | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=2.
3D Cubic spline | Vertices Draw color Line type Line weight | ImGearVectEntities.BEZIER_CURVE entity, interpolated as Bezier with degree=3.
Polyface mesh (if contains faces) | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
Polyface mesh (if does not contain faces) | Draw color Line type Line weight Hidden vertices | ImGearVectEntities.POLYLINE entity.
Block reference | Scale Position Orientation Draw color Fill color Line type Fill type | ImGearVectEntities.INSERTION entity.
Spline | Knots Vertices (weights are supported) Draw color Line type | ImGearVectEntities.NURBS_CURVE entity.
Ellipse | Orientation Major axe Ratio Start angle End angle Center Draw color Line type Line weight | ImGearVectEntities.ARC entity.
Solid | Points [0…3] Draw color Line type Fill color Fill type Thickness | ImGearVectEntities.SOLID entity.
Trace | Points [0…3] Draw color Line type Fill color Fill type Thickness | ImGearVectEntities.SOLID entity.
3D solid | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
Polyline (don’t confuse with 2D polyline and 3D polyline) | Vertices (Bulge attribute is supported) Draw color Line type Constant width | ImGearVectEntities.POLYLINE entity.
Hatch | Draw color Line type Fill color Fill type Gradient filling Hatch lines | ImGearVectEntities.FIGURE entity.
Circle | Orientation Center Radius Draw color Line type Line weight | ImGearVectEntities.ELLIPSE entity.
Region | Draw color Line type Fill color Fill type | ImGearVectEntities.SHELL entity. The entity contains the result of breaking the polyface into simple objects such as vertices, edges, faces, etc.
MText | Orientation Text color Location Font Font height Font width factor Underlined flag | ImGearVectEntities.BLOCK entity with several ImGearVectEntities.TEXT entities and ImGearVectEntities.INSERT that references this block.
Text | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Attribute | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Attribute definition | Orientation Font Italic Weight Font height Font width factor Text color Underlined flag Alignment Position Alignment point | ImGearVectEntities.TEXT entity.
Raster image | Units File name Image size Image scale Clip boundary | ImGearVectEntities.RASTER entity.
Face | Vertices Draw color Line type | ImGearVectEntities.POLYLINE entity.
Arc | Orientation Center Start angle End angle Radius Draw color Line type Thickness | ImGearVectEntities.ARC entity.
Dimension | Block position Draw color Line type Fill color Fill type | ImGearVectEntities.INSERTION entity that references the existing block.
Leader | Arrow head Vertices Scale Arrow head size Reference box Fill color Fill type Draw color Line type | ImGearVectEntities.INSERTION and ImGearVectEntities.BLOCK with ImGearVectEntities.POLYLINE and ImGearVectEntities.SOLID entities inside it.
Tolerance | Location Text Size of the text Draw color Line type Fill color Different shape attributes of included entities | ImGearVectEntities.INSERTION and ImGearVectEntities.BLOCK with several entities inside it, such as ImGearVectEntities.TEXT, ImGearVectEntities.ELLIPSE, and so on.
Block table record | Draw color Line type Fill color Fill type | ImGearVectEntities.BLOCK entity.
Viewport table record (don’t confuse with VIEWPORT entity) | View name View content as a block Direction Target point Twist (angle) Clip distance Background color | ImGearVectorView object.

ImageGear Vector Entities Supported for Writing to DWG and DXF Formats

ImageGear Entity or Object

Saved as DWG/DXF Element

ImGearVectEntities.BLOCK

Block table record.

ImGearVectEntities.INSERTION

Block reference.

ImGearVectEntities.EASYLINE

Line.

ImGearVectEntities.POLYLINE

Depending on fill type and vertex count:

  • Polyline
  • Face
  • 3D Polyline
  • Hatch

    Hatch is created if non-zero fill type object is attached to the polyline and its type is one of the following:

    • ImGearVectFillPattern.SOLID
    • ImGearVectFillPattern.HATCH_BDIAGONAL
    • ImGearVectFillPattern.HATCH_CROSS
    • ImGearVectFillPattern.HATCH_DIAGCROSS
    • ImGearVectFillPattern.HATCH_FDIAGONAL
    • ImGearVectFillPattern.HATCH_HORIZONTAL
    • ImGearVectFillPattern.HATCH_VERTICAL
    • ImGearVectFillPattern.GRADIENT

ImGearVectEntities.POLYLINEEX

3D polyline for every contour. If non-zero fill type object is attached to the polyline, then a Hatch is created as well.

ImGearVectEntities.ELLIPSE
  • If the entity contains a draw color attribute, then Ellipse object is created.
  • If the entity references a fill type, then Hatch object is created.

ImGearVectEntities.ARC
  • If draw color is attached to the entity, then Ellipse object is created.
  • If non-zero fill type object is attached to the entity, then Hatch object is created.

ImGearVectEntities.TEXT

Several Text objects.

ImGearVectEntities.BEZIER_CURVE
  • If curve flag is set to ImGearVectNURBSFlags.MFIT, then 2D Fit polyline;
  • If Bezier degree is 2, then 3D Quadratic spline;
  • If Bezier degree is 3, then 3D Cubic spline.

ImGearVectEntities.NURBS_CURVE

Spline.

ImGearVectEntities.EASY_SURFACE

Polygon mesh.

ImGearVectEntities.FIGURE
  • If the entity references a fill type, then hatch object is created.
  • If the entity references a line type, then internal entities are saved as Polyline objects using entity data cache.

ImGearVectEntities.RASTER

Raster image (saved to a separate raster file and referenced from the DWG/DXF file). Filename must be specified for the raster entity.

ImGearVectEntities.VIEWPORT

Viewport (don’t confuse with Viewport table record).

ImGearVectEntities.SHELL

If the entity contains only triangles and quadrilaterals then it is saved as polyface mesh. Otherwise, the entity is saved as line segments or region.

ImGearVectEntities.SOLID

Solid.

ImGearVectEntities.GEOMETRY

If Fill type exists, then region; otherwise line segments.

ImGearVectorView

Viewport table record.


GEM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > GEM
Full Name | GEM Raster
Format ID | ImGearFormats.GEM
File Extension(s) | *.gem
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

ImGearCompressions.RLE - 1, 4, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

A deal with the creators of Ventura Publisher made this a significant format in the desktop publishing arena. It was also distributed by PC systems manufacturers and was the native bitmap format of the Atari ST system.

The structure of a GEM Raster image file begins with a fixed-length header and is followed by the bitmap data.

The data fields of the header include the version number (always 1), image width (in pixels), and image height (in scan lines). A field named "Headerlength" contains a value of either 8 or 9, where 9 indicates that an optional field appears at the end, called "BitImageFlag". This field is directly tied with a "NumberOfPlanes" field. If "NumberOfPlanes" is greater than 1, the BitImageFlag indicates whether the image is color or grayscale. (BitImageFlag = 0 = color, BitImageFlag = 1 = grayscale).

Two fields in the header that are a little unusual among bitmap formats are the width and height of the pixels (in microns), and a field called "PatternLength". PatternLength is the length of any pattern that will be decoded. It is used by the RLE compression scheme, which assigns one of four different kind of codes to store each of the four different types of repeat data in the image. The "pattern code" indicates that a pattern is available. The pattern and repeat count are decoded while reading the file.

See RLE Compression.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


GIF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > GIF
Full Name | CompuServe Graphics Interchange Format (GIF)
Format ID | ImGearFormats.GIF
File Extension(s) | *.gif
Data Type | Raster image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 89a, 1989: added ability to store both text and graphics in same file.
  • Version 87a, 1987: first version; still read by major applications supporting GIF.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

ImGearCompressions.LZW - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support

ImGearCompressions.LZW - Indexed RGB: 1, 2, 3, 4, 5, 6, 7, 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Version | int | 89 | 87; 89 | Sets version of GIF file to be saved.
Interlace | bool | false | true, false | Sets GIF interlace mode to be used on saving.

Comments

This is a very popular format for storing graphics images on Web pages. It is also supported by most applications that handle graphical image data.

Unisys, the owner of the LZW compression used on all GIF files, declared at the end of 1995 that it will charge a royalty fee to all developers wishing to use this compression scheme. (This drove many developers to search for a replacement file format. A new file format called PNG ("Ping") was created. The PNG format is supported by ImageGear; see the See PNG. section of this chapter for more information.) However, worldwide GIF-related patents expired in 2004 and the format is once again free to use without the need to pay royalties to Unisys.

While the GIF format is designed to store multiple images, few GIF format viewers support this. For this reason, it is not advisable to store more than one image in a GIF file.

The GIF layout is fairly complex; it can include several categories of "blocks" under which subcategories of blocks may occur. For both the 89a and 87a versions, the first three blocks are the header, the Logical Source Descriptor, and the Global Color Table. The header simply identifies the file as a GIF and gives the version number. The Logical Source Descriptor is very similar to a header, and is sometimes stored within the header. It contains information about the display screen and color table.

GIFs contain two kinds of color tables: a "Global Color Table" and "Local Color Table." The Global Color Table is used as a table for the pixel values of all images contained within the GIF file. Optionally, the Local Color Table block that is provided for each image can contain data specific to an individual image.

In addition to a local color table, each image is associated with another block of data, the Local Image Descriptor, provides the size and location of the image, and data about its color table.

GIF89a is equipped with four new types of blocks called "Control Extensions". The most significant group of these are the "Graphics Control Extension Blocks" that enable the simultaneous storing and displaying of textual and graphical data, including multiple images, resulting in a "multimedia presentation". The functions provided by these blocks include setting the transparency or opacity of the images, restoring or deleting images, and overlaying captions (that are not part of the actual bitmap) on images.

GIF image data is always stored in LZW-compressed form. The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.

See Also
GIF Metadata Structure


Hasselblad RAW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > Hasselblad RAW
Full Name | Hasselblad Camera Raw Format
Format ID | ImGearFormats.HasselbladRaw
File Extension(s) | *.3fr,*.fff
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Hasselblad digital cameras use this format for storing Raw images. By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Hasselblad Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Hasselblad files store a small color preview in the root IFD. An application that does not support Hasselblad can read the root IFD as a regular TIFF image. Raw image is stored in the own binary tag uncompressed or Huffman compressed.


HD Photo
User Guide > File Formats and Compressions > File Formats > File Formats Reference > HD Photo
Full Name | HD Photo (Windows Media Photo)
Format ID | ImGearFormats.HDPHOTO
File Extension(s) | *.wdp
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Yes
Metadata Update Support | No
ImageGear Platforms Support | Win32 (DLL only), Win64, .NET, .NET64

ImageGear Supported Versions

  • Version 1.0 - First public release.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.AUTO:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1, 8, 16 bpp;
    • RGB: 24, 48 bpp
    • RGBA: 32, 64 bpp
    • RGBPA: 32, 64 bpp;
    • CMYK: 32, 64 bpp;
    • CMYKEx: 40, 80 bpp

ImageGear Write Support

  • ImGearCompressions.AUTO:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1, 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGBA: 32, 64 bpp;
    • RGBPA: 32, 64 bpp;
    • CMYK: 32 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Lossless | Boolean | False | False, True | Set to True to use lossless compression during save.
ImageQuality | Single | 0.9 | 0 to 1.0 | Image quality level. 1.0 represents lossless compression.
UseAdvancedParameters | Boolean | False | False, True | When true, QualityLevel, OverlapLevel, and SubsamplingLevel are used in place of the ImageQualityLevel. When false, QualityLevel, OverlapLevel, and SubsamplingLevel are set based on ImageQualityLevel
Advanced.Quality | Byte | 1 | 0..255 | Controls quantization of the main image. A value of 1 sets lossless mode (no quantization). Increasing values result in greater quantization and thus greater compression ratios and lower image quality. This parameter is tightly related with Advanced.Subsampling and Advanced.Overlap parameters, and its behavior may differ depending on source image content. If the application needs a single parameter to control image quality, the use of the basic ImageQuality parameter is recommended.
Advanced.Overlap | Byte | 1 | 0,1,2 | 0 - No overlap processing is enabled; 1 - One level of overlap processing is enabled. Encoded values of 4x4 blocks are modified based on the values of neighboring blocks; 2 - Two levels of overlap processing are enabled. In addition to the first level of processing, encoded values of 16x16 macro blocks are modified based on the values of neighboring macro blocks.
Advanced.Subsampling | Byte | 3 | 0, 1, 2, 3 | 0 - 4:0:0 encoding. Chroma content is discarded, luminance is preserved. 1 - 4:2:0 encoding. Chroma resolution is reduced by 1/4 of luminance resolution. 2 - 4:2:2 encoding. Chroma resolution is reduced to 1/2 of luminance resolution. 3 - 4:4:4 encoding. Chroma resolution is preserved.
Advanced.HorizontalTileSlices | Short | 0 | 0..4095 | The number of horizontal divisions to use during compression encoding.
Advanced.VerticalTileSlices | Short | 0 | 0..4095 | The number of vertical divisions to use during compression encoding.
Advanced.FrequencyOrder | Boolean | True | False, True | True to encode the image in frequency order; False to encode the image by its spatial orientation.
Advanced.InterleavedAlpha | Boolean | False | False, True | True if the image is to be encoded with an additional interleaved alpha channel; False if planar alpha channel is to be used.
Advanced.AlphaQuality | Byte | 1 | 0..255 | The compression quality for a planar alpha channel image. A value of 1 is considered lossless.
Advanced.CompressedDomainTranscode | Boolean | True | False, True | True if compressed domain operations can be used.
Advanced.ImageDataDiscard | Byte | 1 | 0, 1, 2, 3 | 0 - No image frequency data is discarded. 1 - FlexBits are discarded. The image quality of the image is reduced without changing the effective resolution of the image. 2 - HighPass frequency data band is discarded. The image's effective resolution is reduced by a factor of 4 in both dimensions. 3 - HighPass and LowPass frequency data bands are discarded. The image's effective resolution is reduced by a factor of 16 in both dimensions
Advanced.AlphaDataDiscard | Byte | 1 | 0..4 | 0 - No image frequency data is discarded. 1 - FlexBits are discarded. The image quality of the image is reduced without changing the effective resolution of the image. 2 - HighPass frequency data band is discarded. The image's effective resolution is reduced by a factor of 4 in both dimensions. 3 - HighPass and LowPass frequency data bands are discarded. The image's effective resolution is reduced by a factor of 16 in both dimensions. 4 - The alpha channel is completely discarded. The pixel format is changed to reflect the removal of the alpha channel.
Advanced.IgnoreOverlap | Boolean | False | False, True | True if overlap is ignored. This value is only valid when CompressedDomainTranscode is true and a sub-region encode is requested.

Non-Image Data Structure

HD Photo file format has different non-image data that can be stored before and after an image data. The HD Photo metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag Name | ID | Description
ApplicationName | ImGearHDPhotoTagIDs.APPLICATION_NAME | Gets or sets a value that identifies the name of the application that was used to construct or alter an image file.
Author (collection of strings) | ImGearHDPhotoTagIDs.AUTHORS Single author is ImGearHDPhotoTagIDs.AUTHOR | Gets or sets a value that represents the author of an image.
CameraManufacturer | ImGearHDPhotoTagIDs.CAMERA_MANUFACTURER | Gets or sets a value that identifies the camera manufacturer that is associated with an image.
CameraModel | ImGearHDPhotoTagIDs.CAMERA_MODEL | Gets or sets a value that identifies the camera model that was used to capture the image.
Comment | ImGearHDPhotoTagIDs.COMMENT | Gets or sets a value that represents a comment that is associated with the image file.
Copyright | ImGearHDPhotoTagIDs.COPYRIGHT | Gets or sets a value that indicates copyright information that is associated with the image file.
DateTaken | ImGearHDPhotoTagIDs.DATE_TAKEN | Gets or sets a value that indicates the date that the image was taken.
Keywords (collection of strings ) | ImGearHDPhotoTagIDs.KEYWORDS Single keyword is ImGearHDPhotoTagIDs.KEYWORD | Gets or sets a collection of keywords that describe the bitmap image.
Rating (integer 0 to 5) | ImGearHDPhotoTagIDs.RATING | Gets or sets a value that identifies the image rating.
Subject | ImGearHDPhotoTagIDs.SUBJECT | Gets or sets a value that indicates the subject matter of the bitmap image.
Title | ImGearHDPhotoTagIDs.TITLE | Gets or sets a value that identifies the title of an image file.

Comments

HD Photo, also known as Windows Media Photo (WMPhoto), is a new file format for continuous-tone still images, developed by Microsoft as a part of the Windows Media family that surpasses the limitations of existing image formats. HD Photo supports a wide range of features, including:

  • Multiple color formats for display or print.
  • Fixed or floating point high dynamic range, wide gamut image encoding.
  • Lossless or high-quality lossy compression.
  • Extremely efficient decoding for multiple resolutions and sub-regions.
  • Minimal overhead for format conversion or transformations during decode.

HD Photo delivers a lightweight, high performance algorithm with a small memory footprint that enables practical, in-device encoding and decoding. HD Photo delivers image quality that is comparable to JPEG-2000 and more than twice the quality of JPEG.


Headerless Camera Raw
User Guide > File Formats and Compressions > File Formats > File Formats Reference > Headerless Camera Raw
Full Name | Headerless Camera Raw Format
Format ID | ImGearFormats.HeaderlessRaw
File Extension(s) | *.*
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Headerless Digital Camera file filter provides support for Digital Camera Raw images that only contain pixel data and no header. This filter supports raw images from cameras of various manufacturers. Camera model and manufacturer of particular image can be obtained from Common section of the Camera Raw metadata.

Because of the absence of a header, such files cannot be detected reliably. By default, detection of this filter is disabled. If you enable detection of this filter, make sure it is last in the detection list, by removing it and adding it back at the end of the list.

Since these files do not contain any metadata describing color reconstruction, ImageGear support level for them is limited to "S2" - pixel decoding only.


HPGL
User Guide > File Formats and Compressions > File Formats > File Formats Reference > HPGL
Full Name | Hewlett Packard Graphics Language
Format ID | ImGearFormats.HPGL
File Extension(s) | *.hpgl
Data Type | Vector image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | Win32, Win64, .NET, .NET64
HPGL format requires ImageGear.Formats.HPGL Namespace.

ImageGear Supported Versions

HPGL, HPGL/2

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support

ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BackColor | Long | 0 | Any positive value | This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width | Long | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

HPGL ("Hewlett Packard Graphics Language") is a vector graphics language used to output vector/CAD drawings to plotters. Due to widespread support among CAD software, it is sometimes used as a vector/CAD interchange format.

HPGL Features Supported for Reading

HPGL Instruction | Supported Attributes | Imported into ImageGear as:
BR (Bezier relative) | Relative points | ImGearVectEntities.NURBS_CURVE entity.
BZ (Bezier absolute) | Absolute points | ImGearVectEntities.BEZIER_CURVE entity.
DF (Default) |  | Used internally. Resets the settings to their default values.
DI (Absolute direction) | X coordinate of arc tangent Y coordinate of arc tangent | Defines a direction for ImGearVectEntities.TEXT entity.
DR (Relative direction) | X coordinate of arc tangent Y coordinate of arc tangent | Defines a direction for ImGearVectEntities.TEXT entity.
DT (Define terminator) | Terminator | Used internally. Defines a terminator for text.
EA (Rectangle absolute) | Second corner of the rectangle | ImGearVectEntities.POLYLINE entity.
EP (Edge polygon) |  | Appends ImGearVectAttrib.LINETYPEINDEX, ImGearVectAttrib.DRAWCOLOR, and ImGearVectAttrib.THICKNESS attributes to the extended polyline being previously created from PM instruction.
ER (Rectangle relative) | Second corner of the rectangle | ImGearVectEntities.POLYLINE entity.
FT (fill type) | Fill pattern Fill spacing Fill angle | Used for creating ImGearVectorFilltype object.
FP (Fill type polygon) |  | Appends ImGearVectAttrib.FILLTYPEINDEX and ImGearVectAttrib.FILLCOLOR attributes to the extended polyline being previously created from PM instruction.
IN (Initialize) |  | Used internally. Initializes the drawing parameters.
IP (Input P1 and P2) | Minimum point Maximum point | Used internally for specifying layout, scale factors, and so on.
SC (Scale) | Minimum scale point Maximum scale point Scale mode | Used internally for specifying layout, scale factors, and so on.
SI (Absolute character size) | Width Height | Defines font width and height for ImGearVectEntities.TEXT entities.
SR (Relative character size) | Relative width Relative height | Defines font width and height for ImGearVectEntities.TEXT entities.
SL (Character slant) | Slant | Defines character slant for ImGearVectEntities.TEXT entities.
LB (Label) | Text string | ImGearVectEntities.TEXT entity.
\x1b. (Esc sequence) |  | Used internally.
PA (Plot absolute) | Absolute position | Defines a position of entities. If pen is down, then either new ImGearVectEntities.POLYLINE entity or new region for ImGearVectEntities.POLYLINEEX is created.
PC (Palette entry) | Entry number Red, Green, Blue color values | Used internally for specifying colors.
PR (Plot relative) | Relative position | Defines a position of entities. If pen is down, then either new ImGearVectEntities.POLYLINE entity or new region for ImGearVectEntities.POLYLINEEX is created.
RA (Shade rectangle absolute) | Second corner | ImGearVectEntities.POLYLINE entity.
RR (Fill rectangle absolute) | Second corner | ImGearVectEntities.POLYLINE entity.
AA (Arc absolute) | Center Angle (Starting from the current position) | Vertexes with bulge attribute being set if the arc is added to the polygon, otherwise - ImGearVectEntities.ARC entity.
PG (New page) |  | Used for navigation through the pages.
AF (New plot) |  | Used for navigation through the pages.
AR (Arc relative) | Offset of the center Angle | ImGearVectEntities.ARC entity.
AT (Arc absolute three points) | Second point Third point | ImGearVectEntities.ARC entity.
CI (Circle) | Radius | ImGearVectEntities.ELLIPSE entity.
CP (Character plot) | Spaces Lines | Used for updating current position for ImGearVectEntities.TEXT entity.
EW (Edge wedge) | Radius Start angle Sweep angle | ImGearVectEntities.ARC entity.
LT (Line type) | Line style Line pattern length | Used for creating ImGearVectorLinetype objects.
PD (Pen down) | X position Y position | Either ImGearVectEntities.POLYLINE entity or new region for the existing ImGearVectEntities.POLYLINEEX entity.
PE (Polyline encoding) | Binary sequence | ImGearVectEntities.POLYLINE entity.
PM (Polygon mode) | Mode (new polygon or close) | ImGearVectEntities.POLYLINEEX entity.
PU (Pen up) | X position Y position | Changes current position. For polygons, appends hidden vertices to the vertex container.
PW (Pen width) | Thickness | Defines line thickness when creating ImGearVectAttrib.THICKNESS attribute.
RO (rotate coordinate system) | Angle | Creates new ImGearVectEntities.BLOCK entity with the corresponding rotation.
SP (Select pen) | Pen number | Selects drawing color. Used as ImGearVectAttrib.DRAWCOLOR attribute.
TL (tick length) | Length positive Length negative | Used for creating coordinate axes – see below.
WG (Shade wedge) | Radius Start angle Sweep angle | ImGearVectEntities.ARC entity.
WU (Pen width units) | Unit type (Plot units or mm) | Used for creating ImGearVectAttrib.THICKNESS attribute.
XT (X Tick, that is, X axe) |  | ImGearVectEntities.EASYLINE entity.
YT (Y Tick, that is, Y axe) |  | ImGearVectEntities.EASYLINE entity.


ICO
User Guide > File Formats and Compressions > File Formats > File Formats Reference > ICO
Full Name | ICO (Windows icon)
Format ID | ImGearFormats.ICO
File Extension(s) | *.ico
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | Single alpha channel for read/write (see Comments).
IG Metadata Update Support | Page
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Windows 3.1
  • Windows NT/95

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ReadAsRGBA | bool | false | true, false | If true, ImageGear reads ICO format as RGBA (RGB with alpha channel).

Comments

More than one representation of the icon bitmap is stored in order to offer a choice of icons; the version most compatible to the output device is used. Support for read-write transparency masks has been added to the ICO filter. Transparency masks are placed into an alpha channel when the image is created. These masks can subsequently be set and applied to the main image.

The structure of an ICO file consists of four data sections: the header, the Resource Descriptor, and two representations of the image data per each icon (the color bitmap and the 1-bit masking bitmap).

The header identifies the file as an ICO and stores the number of icon images that are stored in the file.

The Resource Descriptor stores the image width and height, the number of colors used, and the offset from the beginning of the file to the image data.

The 1-bit masking bitmap defines the transparent portion of the bitmap.

ReadAsRGBA control parameter determines how ImageGear reads the 1-bit AND masks. If ReadAsRGBA is False, ImageGear reads AND mask into "Extra" channel. This mode preserves unchanged pixel values from the file. However, in this mode ImageGear displays only the XOR mask and ignores AND mask (Extra channel) during display, i.e., display is not transparent. If ReadAsRGBA is TRUE, ImageGear reads ICO files as 32 bpp RGB + Alpha. This allows transparent display.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.


IFF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > IFF
Full Name | Interchange File Format
Format ID | ImGearFormats.IFF
File Extension(s) | *.iff
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 1, 1985

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp
  • ImGearCompressions.RLE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp
  • ImGearCompressions.RLE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

This type of file format is referred to as a "wrapper" because it can include any type of data that is encoded in any manner.

The basic organization of the IFF file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (that identifies the chunk size and type). This makes it easy for an IFF viewer to identify chunks and to skip over the ones that are not necessary.

The Header Chunk contains 17 fields, including the size of the header chunk, the identification of the chunk as a header, the size and origin of the image, data encoding (yes or no), and aspect ratio.

A "CMG Chunk" may follow, containing data specific to Amiga display hardware.

A "CMAP Chunk" contains the RGB palette for the image.

The "Body Chunk" (also called the ILBM or "interleaved bitmap"), is the image data itself. It is stored in an "interleaved" format, by bit plane. Interleaving allows for data with different resolutions to be neatly stored together. The data may be uncompressed or compressed using an RLE scheme. See See RLE Compression. section at the beginning of this chapter for more information.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


Imacon Raw
User Guide > File Formats and Compressions > File Formats > File Formats Reference > Imacon Raw
Full Name | Imacon Camera Raw Format
Format ID | ImGearFormats.Imacon
File Extension(s) | *.fff
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Imacon digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Imacon Raw format uses TIFF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, as a binary TIFF tag.


IMG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > IMG
Full Name | Xerox 9700 graphic image (IMG)
Format ID | ImGearFormats.IMG
File Extension(s) | *.img
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 1.0
  • Version 2.0

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 1, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

The IMG header contains the width, height and resolution of the image. Following the header is compressed data. The sample values of a binary image are compressed and then encoded into a sequence of bits. Compression is achieved by predicting a pixel value based on pixel values that have already been computed. For example, the predicted value of a pixel may be that of the corresponding pixel on the previous scan line. Up to fifteen different compression techniques are used, each designed to remove redundancy from a certain kind of image - text characters, line art, and halftones of various screen frequencies. The algorithm adapts to the properties of the image by selecting the technique that will perform the best.

References Used

Xerox System Integration Standard. Raster Encoding Standard. Xerox, XNSS 178506, June 1990.


IMR
User Guide > File Formats and Compressions > File Formats > File Formats Reference > IMR
Full Name | IMRS-Raster image
Format ID | ImGearFormats.IMR
File Extension(s) | *.ima
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


IMT
User Guide > File Formats and Compressions > File Formats > File Formats Reference > IMT
Full Name | IMNET (Medical Image Format)
Format ID | ImGearFormats.IMT
File Extension(s) | *.imt
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None


IOCA
User Guide > File Formats and Compressions > File Formats > File Formats Reference > IOCA
Full Name | IBM IOCA (Image Object Content Architecture)
Format ID | ImGearFormats.ICA
File Extension(s) | *.ica, *.mod
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

IOCA files are most often used for document storage. They are not so unusual from most file formats, except for their naming conventions, which tend to be IBM-specific.

The general structure of an IOCA image file includes a "beginning segment", an "end segment", a header component called "Image Data Parameters", a palette, and the actual image data. Most IOCA images (less than 24-bit) contain a palette. The elements of the bitmap image are referred to as Image Data Elements (IDEs), that are called pixels by most other formats. The "Object Content" refers to the combination of the header and the image data.

IBM uses fields in the header called "self-defining fields". They each contain a type code, the length of the parameter, and then the actual parameter data. They include information as resolution, size, encoding scheme, and bit depth.

There are many optional parameters. Subsets of IOCA parameters define different flavors of the IOCA, one being the MODCA, also supported by ImageGear. Examples of optional parameters include a tiling parameter, if the image is tiled, and a Band Image parameter, which signifies that the image is saved in "bands" ("bit planes" in other formats).

References Used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


JPEG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > JPEG
Full Name | JPEG File Interchange Format
Format ID | ImGearFormats.JPG
File Extension(s) | *.ipg, *jpeg
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Read/write
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Java

ImageGear Supported Versions

  • Version 1.01 - 1991
  • Version 1.02 - Added ability for thumbnails to be color-mapped and JPEG compressed.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support ("Native" Filter)

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Progressive JPEG):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support ("Native" Filter)

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • RGB + Alpha: 32 bpp
    • CMYK: 32 bpp
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (Progressive):
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24 bpp

ImageGear Read Support ("Managed" Filter)

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Progressive JPEG):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support ("Managed" Filter)

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • RGB + Alpha: 32 bpp (RGBA saving is disabled by default. Set AllowRGBASaving control parameter to true to enable it.)
    • CMYK: 32 bpp2 (CMYK saving is enabled by default. You can disable it by setting AllowCMYKSaving control parameter to false.)
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

ImageGear for .NET provides two versions of JPEG filters. One is 100% "managed", and the other relies on native codecs and is optimized for the best compression and decompression performance. Each filter has its own set of control parameters listed below:

  • ImageGear "Native" Filter Control Parameters
  • ImageGear "Managed" Filter Control Parameters

ImageGear "Native" Filter Control Parameters

Filter Control Parameter

Type

Default Value

Available Values

Description

SaveCosited

bool

false

true, false

Indicates whether the image should be compressed with cosited subsampling on saving.

Known Issue: This control parameter does not affect CMYK images.

Chrominance

int

10

Possible value in range [0,255]

A value of zero means no compression (maximum color quality); 255 means maximum image color compression (minimal image color quality). JPEG images are stored in a compressed format. Compression is "lossy", which means when saving JPEG files, there is always data loss. Data loss is the result of JPEG ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff. The image compression ratio can be adjusted by setting the Luminance and Chrominance properties.

The Luminance property adjusts the luminance or grayscale quality, and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression. For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Chrominance should always have a value equal or higher than Luminance.

Luminance

int

10

Possible value in range [0,255]

See description for Chrominance.

SubSampling

 ImGearDecimationTypes Enumeration

Decim_2x2_1x1_1x1

Decim_1x1_1x1_1x1, Decim_2x1_1x1_1x1, Decim_1x2_1x1_1x1,

Decim_2x2_1x1_1x1

This parameter is used in conjunction with the Chrominance and Luminance properties to control the compression ratio and the compressed image quality. For higher quality and lower compression, set Luminance and Chrominance in the low teens, and set SubSampling to "Decim_1x1_1x1_1x1" compression. For higher compression and lower quality, set Luminance and Chrominance in the low 20's and set SubSampling to "Decim_2x2_1x1_1x1" compression.

UseOptimizedHuffmanCodes

bool

true

true, false

Indicates whether to use optimized Huffman codes during encoding instead of using default Huffman codes.

LoadCosited

bool

false

true, false

Indicates whether the image was compressed with cosited subsampling.

There is no flag in JPEG files to indicate compression with cosited (2-1-1) subsampling. Therefore, this fact must be determined independently by the application performing the file load method.

QuadComponentColorSpace

 ImGearQuadComponentColorSpace Enumeration

Auto

Auto, Rgba, Cmyk

This parameter allows you to explicitly specify the color space of the quad component JPEG image on load. Value of 'Auto' always sets color space to Cmyk.

JpegSaveType

ImGearJpegSaveType Enumeration

Lossy

Lossy, Lossless, Progressive

Type for output JPEG format. See Loading and Saving JPEG-Compressed Images section for details.

The following metadata nodes are not supported by this filter, so they will not be available upon image load:

  • EXIF-GPS
  • SOF0 - SOF15
  • DQT
  • DHT
  • DRI
  • SOS

ImageGear "Managed" Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
AllowLossy12bpcSaving | bool | true | true, false | Controls the saving to Lossy JPEG format. If True, saving of 12 bits per channel Lossy JPEG is allowed. This is the maximum channel depth supported by Lossy JPEG format. If source image's depth is more than 8 bits per channel, it will be saved to a 12 bpc JPEG. For example, 48-bit RGB image will be saved to 36-bit JPEG. Note that many viewers do not support 12 bpc JPEG. If False, all images are saved to 8 bpc JPEG, regardless of their channel depth.
AllowRGBASaving | bool | true | true, false | Set this parameter to true to enable RGBA JPEG saving. Note, that there is no official standard for RGBA JPEG. This format is recognized as CMYK rather than RGBA by most third-party software.
Quality | int | 70 | Possible value in range [1,100] | Gets/Sets quality value for Lossy and Progressive JPEG compression. See JPEG Quality. Section for details.
DecimationType | ImGearDecimationTypes Enumeration | Decim_2x2_1x1_1x1 | ImGearDecimationTypes Enumeration | Get/Set decimation value. For all available values see ImGearDecimationTypes Enumeration.
Predictor | int | 1 |  | Gets/Sets predictor for lossless JPEG. See Lossless JPEG Predictor Settings. Section for details.
SaveType | int | 0 (Lossy compression) | 0 (Lossy compression), 1 (Lossless compression) | Get/Set type for output JPEG format. See Loading and Saving JPEG-Compressed Images. Section for details.
AllowCMYKSaving | bool | true | true, false | Set to true (default) to allow saving JPEG CMYK images. Set to false to save CMYK images to JPEG as RGB.
SaveEXIFMetadata | bool | false | true, false | If true. EXIF metadata is saved.
SaveExistingEXIFMetadata | bool | true | true, false | This parameter controls the saving of existing EXIF metadata. By default (SaveEXIFMetadata = False, SaveExistingEXIFMetadata = True), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.
QuadComponentColorSpace | ImGearQuadComponentColorSpace Enumeration | Auto | Auto, Rgba, Cmyk, Ycck | This parameter allows you to explicitly specify the color space of the quad component JPEG image on load. Set this parameter to “Auto” to let ImageGear detect the best suitable color space, or set it to any other enumeration value to explicitly specify the color space. Please see ImGearQuadComponentColorSpace Enumeration for more details.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata | SaveExistingEXIFMetadata | Source Page has EXIF Metadata | ImageGear Action
False | False | No | Does not save EXIF metadata
False | False | Yes | Does not save EXIF metadata
False | True | No | Does not save EXIF metadata
False | True | Yes | Saves existing EXIF metadata
True | False | No | Saves default EXIF metadata
True | False | Yes | Ignores existing and saves default EXIF metadata
True | True | No | Saves default EXIF metadata
True | True | Yes | Saves existing EXIF metadata

Comments

JPEG is normally associated with the JPEG compression scheme, but it is also implemented into the JFIF file format. This format was developed to store JPEG-encoded data, and to exchange it between applications or operating systems that are normally incompatible.

The JPEG compression scheme was developed by the Joint Photographic Experts Group (created by the joining of a subgroup of the International Standards Organizations, called PEG (Photographic Experts Group) and a subgroup of the CCITT). Their common goal was to produce a standard for the transmission of graphics image data over networks and through color facsimile systems.

The header of the JFIF contains the version number, the image dots per inch (DPI), or dots per centimeter, and an optional thumbnail (miniature) RGB representation of the main image. Version 1.02 handles thumbnails differently by storing them separately, rather than in the identification marker of the header.

The raw JPEG data is surrounded by two markers, an "SOI" (start of image) marker, and an "EOI" (end of image) marker. See Lossy JPEG Compression for more about JPEG compression.

JFIF is considered a non-proprietary file format. Many proprietary file formats contain JPEG data, incorporating their own application-specific data structures. Another non-proprietary format that uses JPEG-encoded data is TIFF file format, version 6.0.

Loading and Saving JPEG-Compressed Images

ImageGear supports the reading and writing of three types of JPEG compression: baseline JPEG (Lossy), Progressive JPEG, and Lossless JPEG. When you load a JPEG-compressed file, ImageGear detects the type of JPEG compression and decompresses the image automatically. However, if you want to save an image with a JPEG compression scheme other than baseline JPEG, you must use "SaveType" parameter (for "Managed" filter) or "JpegSaveType" parameter (for "Native" filter) to specify the type of JPEG compression.

JPEG Thumbnails

The JPEG format can store thumbnails, which are small representations of the original image. These images are stored in uncompressed form and can significantly decrease your overall compression ratio. (Uncompressed thumbnails sometimes occupy more space than the original JPEG image when compressed). Use this option carefully.

The JPEG format does not allow the storage of "large" thumbnails. This is due to the marker segment length, which cannot be greater than 65,536 bytes. The maximum size of a color thumbnail is about 100x200 or 200x100 pixels, and the maximum size of a grayscale thumbnail is about 300x200 or 200x300 pixels.

Lossless JPEG Predictor Settings

The Lossless JPEG scheme is "predictive" in nature; it uses the values of surrounding pixels in addition to the value of the original pixel to calculate a predictor value, which it then subtracts from the value of the original pixel. The resulting pixel value will be reduced such that it can be compressed more than the original value. The higher the number of neighboring pixels used, the higher the compression will be.

Regardless of the predictor value setting, the quality of the image will remain the same. The difference is that if you choose to optimize for space by setting a high predictor value, you will have to give up some speed, as the decompression will take longer to perform.

ImageGear lets you set the predictor value using "Predictor" control parameter. The ImageGear default for this setting is 1. The allowed range is 1-7. Values outside of the allowed range of 1-7 will be mapped to a value of 5. The graphic below shows a predictor (x) and three reconstructed samples (a,b,c) immediately to the left, immediately above, and diagonally to the left of the current sample

Lossless JPEG does not apply DCT for an image as per the Lossy JPEG compression. Instead, it uses a DPCM difference coding, which can be carried out with any one of seven different prediction modes. Correspondingly, the "Predictor" control parameter can be set to a value between 1 and 7. In the table below, you will see what algorithm your setting of 1-7 will use, where Px is the predictor, and Ra, Rb, and Rc are the reconstructed samples:

Value | JPEG DIS Prediction
1 | Px = Ra
2 | Px = Rb
3 | Px = Rc
4 | Px = Ra + Rb - Rc
5 | Px = Ra + ((Rb-Rc)/2)
6 | Px = Rb + ((Ra-Rc)/2)
7 | Px = (Ra + Rb)/2

JPEG Quality

The baseline JPEG specification calls for a quality setting. The lower the setting, the greater the number of original pixels lost, and therefore the smaller the resulting compressed file will be. ImageGear lets you set the quality of compression with values of type INT between 1-100, where 100 provides the highest retention of original pixel values. A setting of 100 does not mean that the image includes 100% of all original pixel values. With Lossy JPEG, there is no such thing as "no loss". Control parameter for setting Lossy JPEG quality is "Quality" (for "Managed" filter). Please see description of "Chrominance" and "Luminance" control parameters to apply JPEG quality settings for the "Native" filter.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


JPEG 2000
User Guide > File Formats and Compressions > File Formats > File Formats Reference > JPEG 2000
Full Name | JPEG 2000
Format ID | ImGearFormats.JPEG2K
File Extension(s) | *.jp2, *.jpc, *.j2k, *.j2c
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Read/write
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64
JPEG 2000 format requires ImageGear.Formats.JPEG2K Namespace.

ImageGear Supported Versions

ISO/IEC 15444-1:2000

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

For Raw Code-stream JPEG 2000 files:

  • ImGearCompressions.JPEG2K:
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

For JP2-compatible JPEG 2000 files:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • Grayscale + Pre-multiplied Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc
    • RGB + Pre-multiplied Alpha: 1..16 bpc
    • Grayscale + Extra: 1..16 bpc
    • RGB + Extra: 1..16 bpc
    • RGB + Alpha + Extra: 1..16 bpc
    • RGB + Pre-multiplied Alpha + Extra: 1..16 bpc

ImageGear Write Support

For Raw Codestream JPEG 2000 files:

  • ImGearCompressions.JPEG2K:
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

For JP2-compatible JPEG 2000 files:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • Grayscale + Pre-multiplied Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc
    • RGB + Pre-multiplied Alpha: 1..16 bpc
    • Grayscale + Extra: 1..16 bpc
    • RGB + Extra: 1..16 bpc
    • RGB + Alpha + Extra: 1..16 bpc
    • RGB + Pre-multiplied Alpha + Extra: 1..16 bpc

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
CodeBlockSize Int 64 4, 8, 16, 32, 64

Affects image saving.

Nominal code-block dimension. Actual dimension is the subject to precinct, tile and image dimensions.

CodeBlockStyle ImGearJPEG2KCodeBlockStyles Enumeration ImGearJPEG2KCodeBlockStyles Enumeration.ALL_OFF Any combination of values from ImGearJPEG2KCodeBlockStyles Enumeration values.

Affects image saving.

Block coder mode switches. Any combination of values from ImGearJPEG2KCodeBlockStyles Enumeration is legal.

CpuOptimizationMode | ImGearJPEG2KCpuOptimizationMode Enumeration | ImGearJPEG2KCpuOptimizationMode Enumeration.EnableAll | Any ImGearJPEG2KCpuOptimizationMode value. | Allows disabling CPU optimization features if those are not supported by the OS.
DiscardLevels Int 0 Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. This parameter indicates the number of highest resolution DWT levels which will be skipped during the reading. Dimensions of the image loaded with DiscardLevels = N will be 2^N times smaller than the actual image dimensions. If the specified number exceeds the number of DWT levels in the image, the lowest resolution level will be loaded. For this parameter to take effect, the image must have more than one DWT level. Use the WaveletLevels parameter to specify the number of DWT levels for JPEG 2000 image saving.

EbcotBitplaneShift Int 0 0, 3

This control parameter should be used in combination with the CodeBlockStyle control parameter. Setting EbcotBitplaneShift to 3 and CodeBlockStyle to ImGearJPEG2KCodeBlockStyles.BYPASS enables a notable encoder speed-up between 10% and 20% over regular coding bypass mode, and a speed-up of up to 40% over regular coding mode. A similar speed-up can be expected in decoding images that have been encoded in this mode.

Images saved in this mode are slightly larger in size but load faster. A value of 0 disables the feature; a value of 3 enables it. The rest of the values are reserved and result in an error upon attempting to set. The feature is disabled by default.

FileFormat ImGearJPEG2KType Enumeration ImGearJPEG2KType Enumeration.FILE_FORMAT Any ImGearJPEG2KType Enumeration value

Affects image saving.

Specifies whether to save the file as a JP2-compatible file or as a raw JPEG 2000 code-stream. JP2 compatible files contain various metadata, such as resolution, color space, palette, XML, etc. Raw code-streams do not store any metadata.

Mode ImGearJPEG2KModes Enumeration ImGearJPEG2KModes Enumeration.FAST Any ImGearJPEG2KModes Enumeration value.

This parameter has been deprecated.
ProgressionOrder ImGearJPEG2KProgressionOrders Enumeration ImGearJPEG2KProgressionOrders Enumeration.LRCP Any ImGearJPEG2KProgressionOrders Enumeration value.

Affects image saving.

This parameter specifies the progression order to be used by the result file. See ImGearJPEG2KProgressionOrders Enumeration for available progression orders.

QualityLayers Double[] new Double[0] Array of one or more double values.

Affects image saving.

This parameter represents a more powerful version of the RateBytes control parameter. Its value is an array of one or more bit-rates, expressed in terms of the ratio between the total number of compressed bits in the code stream (including code stream header, but not including JP2 header) and the number of pixels in the image (image width * height). The number of elements in the array represents the number of quality layers. Each value in the array represents the overall bit-rate of this layer, rather than the difference between this layer and the previous layer.

In order to use the maximum quality for the last layer, set the last element of the array to 0.0.

Setting the last element in the array to 0.0 does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.

Example:

Set QualityLayers to {0.01, 0.1, 0.5}

If the source image dimensions are 800 x 600 = 480000 pixels, the array used in the example will result in the following layer sizes:

  • 1st layer: 480000 * 0.01 / 8 = 600 bytes
  • 1st and 2nd layers: 480000 * 0.1 / 8 = 6000 bytes
  • 1st, 2nd, and 3rd layers (whole codestream): 480000 * 0.5 / 8 = 30000 bytes
QuantizationStep Double -1.0 Any negative value; 0.0…2.0

Affects image saving.

This control parameter is the base step size to be used in deriving irreversible quantization step sizes for every sub-band.

Any negative value results in automatic selection of the quantization step size. This is the recommended mode.

RateBytes Int 0 Any non-negative integer value.

Affects image saving.

This control parameter specifies the maximal size of the saved code stream in bytes. A zero value instructs the filter to use the highest compression quality.

Using the same non-zero value for different images causes the filter to write files with a different compression rate. In order to provide a consistent compression rate across images of different sizes, calculate this parameter for each image, based on the product of the image width and height, or on the uncompressed DIB size.

Alternatively, use QualityLayers control parameter, which uses relative coefficients.

Setting RateBytes to 0 does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.
StitchTiles bool true true, false

Affects image loading.

This parameter specifies how tiled images should be loaded. If true then ImageGear loads and stitches (composes together) all tiles automatically into the resulting image. If false then ImageGear loads a single tile.

TileHeight Int 0 Any non-negative integer value.

Affects image loading.

Specifies the height of one tile in the reference grid. A zero value indicates the image's height.

TileWidth Int 0 Any non-negative integer value.

Affects image loading.

Specifies the width of one tile in reference grid. A zero value indicates the image's width.

ViewHeight Int 0 Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. If the value is nonzero, or is greater than the image height, ImageGear only loads DWT levels whose height is not greater than the parameter value. Dimensions of each decomposition level are twice greater than that of the previous level. A zero value indicates the initial image's height. This parameter is similar to DiscardLevels in that it allows you to select the highest resolution level for image loading.

ViewWidth Int 0 Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. If the value is nonzero, or is greater than the image width, ImageGear only loads DWT levels whose width is not greater than the parameter value. Dimensions of each decomposition level are twice greater than that of the previous level. A zero value indicates the initial image's height. This parameter is similar to DiscardLevels in that it allows you to select the highest resolution level for image loading.

WaveletFilter ImGearJPEG2KFilters Enumeration ImGearJPEG2KFilters Enumeration.AUTO Any ImGearJPEG2KFilters Enumeration value.

Affects image saving.

Specifies the type of Wavelet filter (Auto, Reversible, or Irreversible) to be used for Discrete Wavelet Transform.

Selecting the ImGearJPEG2KFilters.REVERSIBLE filter does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.

Applying irreversible transform to indexed (paletted) images may result in significant degradation of image quality, because small changes in pixel values may result in significant visual difference after application of a palette. Consider using reversible transform for paletted images, or promoting images to true color and then using the reversible transform.

WaveletLevels Int -1 -1 … 16

Affects image saving.

Specifies the quantity of decomposition levels (stages) for the image being saved. The main purpose of each level is to provide the ability for the reader to faster decompress the reduced size version of the original image.

Dimensions of the Nth level are 2^N times smaller than the actual image dimensions.

Setting this parameter to -1 tells ImageGear to select the value automatically. Currently, ImageGear uses 5 levels for all types of images in this mode.

Comments

JPEG 2000 standard defines a compression scheme and a file format for interchange of JPEG 2000 compressed data.

The compression scheme is based on a discrete wavelet transform, and supports both lossy and lossless modes. JPEG 2000 compression is similar to JPEG in that it supports lossy compression. However, JPEG 2000 allows achieving much higher compression ratios while preserving good image quality.

JPEG 2000 file format defines a basic set of features that allow interchange of JPEG 2000 compressed images.

See also JPEG 2000 Non-Image Data Structure.

Metadata Update

You can use the Metadata Update API to update XML, IPR, Comment, and Resolution metadata in JPEG 2000 files. You can also use the Metadata Update API to update Comment metadata in JPEG 2000 code stream files. Metadata Update API can only change a single occurrence of the Comment metadata.

Capture and Display Resolutions are represented by their X and Y values that can only be updated together. An attempt to update only X or Y value leaving the other value to 0 will result in no change at all.


JPX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > JPX
Full Name | JPEG 2000 Extensions
Format ID | ImGearFormats.JPX
File Extension(s) | *.jpx
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Yes
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64
JPX format requires ImageGear.Formats.JPEG2K Namespace.

ImageGear Supported Versions

ISO/IEC 15444-2:2000

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEREADPSUPPORT – multi-page file writing

ImageGear Read Support

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpc
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • YCbCr: 1..16 bpc
    • Lab: 1..16 bpc
    • CMY: 1..16 bpc
    • CMYK: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • Grayscale + Pre-multiplied Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc
    • RGB + Pre-multiplied Alpha: 1..16 bpc
    • Indexed RGB + Extra: 1..16 bpc
    • Grayscale + Extra: 1..16 bpc
    • RGB +Extra: 1..16 bpc
    • YCbCr +Extra: 1..16 bpc
    • Lab +Extra: 1..16 bpc
    • CMY +Extra: 1..16 bpc
    • CMYK +Extra: 1..16 bpc
    • Grayscale + Alpha + Extra: 1..16 bpc
    • Grayscale + Pre-multiplied Alpha + Extra: 1..16 bpc
    • RGB + Alpha + Extra: 1..16 bpc
    • RGB + Pre-multiplied Alpha + Extra: 1..16 bpc

ImageGear Write Support

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpc
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • YCbCr: 1..16 bpc
    • Lab: 1..16 bpc
    • CMY: 1..16 bpc
    • CMYK: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • Grayscale + Pre-multiplied Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc
    • RGB + Pre-multiplied Alpha: 1..16 bpc
    • Grayscale + Extra: 1..16 bpc
    • RGB +Extra: 1..16 bpc
    • YCbCr +Extra: 1..16 bpc
    • CMY +Extra: 1..16 bpc
    • CMYK +Extra: 1..16 bpc

ImageGear Filter Control Parameters

Filter Control Parameter

Type

Default Value

Available Values

Description

CodeBlockSize

Int

64

4, 8, 16, 32, 64

Affects image saving.

Nominal code-block dimension. Actual dimension is subject to precinct, tile, and image dimensions.

CodeBlockStyle

ImGearJPEG2KCodeBlockStyles Enumeration

ImGearJPEG2KCodeBlockStyles Enumeration.ALL_OFF

Any combination of ImGearJPEG2KCodeBlockStyles Enumeration values.

Affects image saving.

Block coder mode switches. Any combination of values from ImGearJPEG2KCodeBlockStyles Enumeration is legal.

DiscardLevels

Int

0

Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. This parameter indicates the number of highest resolution DWT levels which will be skipped during the reading. Dimensions of the image loaded with DiscardLevels = N will be 2^N times smaller than the actual image dimensions. If the specified number exceeds the number of DWT levels in the image, the lowest resolution level will be loaded. For this parameter to take effect, the image must have more than one DWT level. Use the WaveletLevels parameter to specify the number of DWT levels for JPEG 2000 image saving.

EbcotBitplaneShift

Int

0

0, 3

This control parameter should be used in combination with the CodeBlockStyle control parameter. Setting EbcotBitplaneShift to 3 and CodeBlockStyle to ImGearJPEG2KCodeBlockStyles.BYPASS enables a notable encoder speed-up between 10% and 20% over regular coding bypass mode, and a speed-up of up to 40% over regular coding mode. A similar speed-up can be expected in decoding images that have been encoded in this mode.

Images saved in this mode are slightly larger in size but load faster. A value of 0 disables the feature; a value of 3 enables it. The rest of the values are reserved and result in an error upon attempting to set. The feature is disabled by default.

FileFormat

ImGearJPEG2KType Enumeration

ImGearJPEG2KType Enumeration.FILE_FORMAT

Any ImGearJPEG2KType Enumeration value

Affects image saving.

Specifies whether to save the file as a JP2-compatible file or as a raw JPEG 2000 code-stream. JP2 compatible files contain various metadata, such as resolution, color space, palette, XML, etc. Raw code-streams do not store any metadata.

LoadComposition

bool

false

false

This parameter is reserved for future use. Set to false.

Mode

ImGearJPEG2KModes Enumeration

ImGearJPEG2KModes Enumeration.FAST

Any ImGearJPEG2KModes Enumeration value.

This parameter has been deprecated.

ProgressionOrder

ImGearJPEG2KProgressionOrders Enumeration

ImGearJPEG2KProgressionOrders Enumeration.LRCP

Any ImGearJPEG2KProgressionOrders Enumeration value

Affects image saving.

This parameter specifies the progression order to be used by the result file. See ImGearJPEG2KProgressionOrders Enumeration for available progression orders.

QualityLayers

double[]

new double[0]

Array of one or more double values, or null.

Affects image saving.

This parameter represents a more powerful version of the RateBytes control parameter. Its value is an array of one or more bit-rates, expressed in terms of the ratio between the total number of compressed bits in the code stream (including code stream header, but not including JP2 header) and the number of pixels in the image (image width * height). The number of elements in the array represents the number of quality layers. Each value in the array represents the overall bit-rate of this layer, rather than the difference between this layer and the previous layer.

In order to use the maximum quality for the last layer, set the last element of the array to 0.0.

Setting the last element in the array to 0.0 does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.

Example:

Set QualityLayers to {0.01, 0.1, 0.5}

If the source image dimensions are 800 x 600 = 480000 pixels, the array used in the example will result in the following layer sizes:

  • 1st layer: 480000 * 0.01 / 8 = 600 bytes
  • 1st and 2nd layers: 480000 * 0.1 / 8 = 6000 bytes
  • 1st, 2nd, and 3rd layers (whole codestream): 480000 * 0.5 / 8 = 30000 bytes

QuantizationStep

double

-1.0

Any negative value; 0.0…2.0

Affects image saving.

This control parameter is the base step size to be used in deriving irreversible quantization step sizes for every sub-band.

Any negative value results in automatic selection of the quantization step size. This is the recommended mode.

RateBytes

Int

0

Any non-negative integer value.

Affects image saving.

This control parameter specifies the maximal size of the saved code stream in bytes. A zero value instructs the filter to use the highest compression quality.

Using the same non-zero value for different images causes the filter to write files with a different compression rate. In order to provide a consistent compression rate across images of different sizes, calculate this parameter for each image, based on the product of the image width and height, or on the uncompressed DIB size.

Alternatively, use QualityLayers control parameter, which uses relative coefficients.

Setting RateBytes to 0 does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.

StitchTiles

bool

true

true, false

Affects image loading.

This parameter specifies how tiled images should be loaded. If true then ImageGear loads and stitches (composes together) all tiles automatically into the resulting image. If false then ImageGear loads a single tile.

TileHeight

Int

0

Any non-negative integer value.

Affects image loading.

Specifies the height of one tile in the reference grid. A zero value indicates the image's height.

TileWidth

Int

0

Any non-negative integer value.

Affects image loading.

Specifies the width of one tile in reference grid. A zero value indicates the image's width.

ViewHeight

Int

0

Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. If the value is nonzero, or is greater than the image height, ImageGear only loads DWT levels whose height is not greater than the parameter value. Dimensions of each decomposition level are twice greater than that of the previous level. A zero value indicates the initial image's height. This parameter is similar to DiscardLevels in that it allows you to select the highest resolution level for image loading.

ViewWidth

Int

0

Any non-negative integer value.

Affects image loading.

Allows loading a smaller version of the image, which takes less time and memory than loading the whole image. If the value is nonzero, or is greater than the image width, ImageGear only loads DWT levels whose width is not greater than the parameter value. Dimensions of each decomposition level are twice greater than that of the previous level. A zero value indicates the initial image's height. This parameter is similar to DiscardLevels in that it allows you to select the highest resolution level for image loading.

WaveletFilter

ImGearJPEG2KFilters Enumeration

ImGearJPEG2KFilters Enumeration.AUTO

Any ImGearJPEG2KFilters Enumeration value.

Affects image saving.

Specifies the type of Wavelet filter (Auto, Reversible, or Irreversible) to be used for Discrete Wavelet Transform.

Selecting the ImGearJPEG2KFilters.REVERSIBLE filter does not guarantee that the image will be saved without a loss of quality. See Saving JPEG 2000 and JPX Images in Lossless Mode for more details.

Applying irreversible transform to indexed (paletted) images may result in significant degradation of image quality, because small changes in pixel values may result in significant visual difference after application of a palette. Consider using reversible transform for paletted images, or promoting images to true color and then using the reversible transform.

WaveletLevels

Int

-1

-1 … 16

Affects image saving.

Specifies the quantity of decomposition levels (stages) for the image being saved. The main purpose of each level is to provide the ability for the reader to faster decompress the reduced size version of the original image.

Dimensions of the Nth level are 2^N times smaller than the actual image dimensions.

Setting this parameter to -1 tells ImageGear to select the value automatically. Currently, ImageGear uses 5 levels for all types of images in this mode.

Comments

JPX file format is an extension to JPEG 2000 file format. It normally uses JPEG 2000 compression, but allows other compressions as well, such as JBIG, CCITT Group3, CCITT Group4, etc. ImageGear only supports JPEG 2000 compression for JPX format. The format also provides advanced features such as multiple layers for an image, various color spaces, opacity (alpha channel), and fragmented code streams.

See also JPX Non-Image Data Structure.

Metadata Update

You can use the Metadata Update API to update XML, IPR, Comment, and Resolution metadata in JPEG 2000 Part 2 files. Metadata Update API can only change a single occurrence of the Comment metadata.

Capture and Display Resolutions are represented by their X and Y values that can only be updated together. An attempt to update only X or Y value leaving the other value to 0 will result in no change at all.


KFX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > KFX
Full Name | KFX (Kofax Group4 image)
Format ID | ImGearFormats.KFX
File Extension(s) | *.kfx
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 3

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


KodakRAW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > KodakRAW
Full Name | Kodak Camera Raw Format
Format ID | ImGearFormats.KDC
File Extension(s) | *.dcr, *.kdc
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • Proprietary Kodak compression:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Kodak digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Kodak Raw format uses TIFF/EXIF file structure as the base, but is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored using proprietary compression. Raw data in some cameras is stored in 3-channel YUV format than in mosaic grayscale.


LeicaRAW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > LeicaRAW
Full Name | Leica/Panasonic Camera Raw Format
Format ID | ImGearFormats.LeicaRaw
File Extension(s) | *.raw
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Leica and Panasonic digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Leica/Panasonic Raw format uses TIFF/EXIF file structure as the base, but is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD as uncompressed grayscale image.


LV
User Guide > File Formats and Compressions > File Formats > File Formats Reference > LV
Full Name | LV (Lazer View format)
Format ID | ImGearFormats.LV
File Extension(s) | *.lv
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - 1bpp
  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


MEF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > MEF
Full Name | Mamiya Camera Raw Format
Format ID | ImGearFormats.MEF
File Extension(s) | *.mef
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Mamiya digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Mamiya Raw format uses TIFF/EXIF file structure. Raw image is stored uncompressed.


MODCA
User Guide > File Formats and Compressions > File Formats > File Formats Reference > MODCA
Full Name | IBM MO:DCA (Mixed Object Document Content Architecture)
Format ID | ImGearFormats.MOD
File Extension(s) | *.mod, *.ica
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The MO:DCA header allows the storage of multiple IOCA images in one file. The MO:DCA format is an IOCA "wrapper". It is considered by IBM to be a "data stream controlling environment" for a group of IOCA images.

There are many optional parameters. Subsets of IOCA parameters define different flavors of the IOCA, for example, the MO:DCA. The MO:DCA incorporates sets "10" and "11".

Please see the description of See IBM IOCA. in this chapter for further description.

References Used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


MOS
User Guide > File Formats and Compressions > File Formats > File Formats Reference > MOS
Full Name | Leaf Camera Raw Format
Format ID | ImGearFormats.MOS
File Extension(s) | *.mos
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Leaf digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

MOS Raw format uses TIFF/EXIF file structure as a base, but is not fully compliant with TIFF. Raw image is stored in the own Leaf tag as uncompressed or JPEG Lossless compressed grayscale image. Some of MOS images contain a small color preview in the same Leaf tag as JPEG Lossy compressed image.


MRW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > MRW
Full Name | Konica Minolta Camera Raw Format
Format ID | ImGearFormats.MRW
File Extension(s) | *.mrw
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Konica Minolta digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Konica Minolta Raw files use a proprietary format, that contains a hierarchy of segments. One of the segments contains EXIF metadata tree. Raw data is stored uncompressed.


MSP
User Guide > File Formats and Compressions > File Formats > File Formats Reference > MSP
Full Name | MSP (MS Paint)
Format ID | ImGearFormats.MSP
File Extension(s) | *.msp
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 2.0
  • Version 1.0

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE: Indexed RGB: 1 bpp
  • ImGearCompressions.RLE: Indexed RGB: 1 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

This was a popular format for storing line drawing and clip art images created with Windows applications, but has recently begun to be replaced by the Windows bitmap format (also supported by ImageGear BMP).

For versions earlier than 2.0, the format begins with a 32-byte header and immediately proceeds with the bitmap data. The header information includes: the version of the file, the size and aspect ratio of the bitmap, and the width and height and aspect ratio (in pixels) of the output device used to render the bitmapped image. The bitmap data is uncompressed.

Files made with Version 2.0 and later always use RLE compression. In these files a "scan-line map" follows the header and precedes the data. It gives offsets to each scan line for instances when a particular scan line needs to be examined. All previous lines can remain compressed, while the needed line is located.

See RLE Compression for more information.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


NCR
User Guide > File Formats and Compressions > File Formats > File Formats Reference > NCR
Full Name | NCR
Format ID | ImGearFormats.NCR
File Extension(s) | *.ncr
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp
  • ImGearCompressions.NONE - Indexed RGB: 1, 4 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

NCR is the black and white image compression format.


NEF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > NEF
Full Name | Nikon Camera Raw Format
Format ID | ImGearFormats.NEF
File Extension(s) | *.nef
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.
  • ImGearCompressions.HUFFMAN:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Nikon digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Nikon Raw files are compliant with TIFF/EP standard, and include EXIF metadata. They store a small color preview in the root IFD. An application that does not support NEF can read the root IFD as a regular TIFF image. Raw data is stored in a SubIFD, uncompressed or using huffman compression.


ORF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > ORF
Full Name | Olympus Camera Raw Format
Format ID | ImGearFormats.ORF
File Extension(s) | *.orf
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Olympus digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Olympus Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD as uncompressed grayscale image.


PBM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PBM
Full Name | PBM (Portable Bitmap File Format)
Format ID | ImGearFormats.PBM
File Extension(s) | *.pbm
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

This is useful for quick and easy transfer of monochrome bitmap images, although the encoding scheme is not efficient in terms of storage space. This format, as well as the PGM, PNM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. Among other things, these formats serve as intermediary storage methods for the conversion of other file formats.

The Portable Bitmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of bits is equal to the width * height. A pixel value of 0 indicates white, and a value of 1 indicates black.

The magic number of the header can have one of two values: either P1 or P4. P1 indicates that the bitmap data are to be read as ASCII decimal values. P4 indicates that the bitmap data are stored as plain bytes. Because 8 pixel values (1 bit each) are stored in one byte, the file is 8 times smaller than in the ASCII decimal format. White spaces are permitted in the P1 format but not permitted in the P4 format.

ImageGear uses PBM filter to handle the whole family of formats: PBM (1-bit), PGM (grayscale), PPM (truecolor) and PNM (collective name for all of above). When saving image as ImGearFormats.PBM format, ImageGear chooses particular format (PBM, PGM, PNM or PPM) depending on image bit depth.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM Specification by Jef Poskanzer, copyright A 1989, 1991.

See Also
PGM
PNM
PPM


PCD
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PCD
Full Name | PCD (Kodak Photo CD)
Format ID | ImGearFormats.PCD
File Extension(s) | *.pcd
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

All valid PCD files in 5 different resolutions:

  • Resolution 1: 768x512
  • Resolution 2: 384x256
  • Resolution 3: 192x128
  • Resolution 4: 1536x1024
  • Resolution 5: 3072x2048

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - RGB: 24 bpp
  • ImGearCompressions.HUFFMAN - RGB: 24 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter Type Default Value Available Values Description
Resolution int 0 0..4 Resolution level to load:

  • 0 = load last (largest) resolution (Resolution 5: 3072x2048)
  • 1 = load second to last resolution (Resolution 4: 1536x1024)
  • 2 = load middle resolution (Resolution 3: 192x128)
  • 3 = load second resolution (Resolution 2: 384x256)
  • 4 or higher = load first (smallest) resolution (Resolution 1: 768x512)

Comments

"Photo CD" is the informally adopted name for files created using the Photo CD-ROM-based storage and retrieval system created by Kodak. The images are digitized versions of photographic images. Using a Photo CD player, images can be viewed on television. Although intended for photographic images, the data source does not necessarily have to be film. Due to the large storage capacity of the CD medium, this format supports very large and/or intricate images.

Images and their associated information are stored in groups called "sessions". Originally, they were stored at the rate of one session per CD, but later versions allowed multiple sessions per disc.

For each stored image, there are up to 5 bitmaps, each representing the image at a different resolution. The bitmaps at the lowest resolution are intended for such purposes as displaying thumbnails and previewing an image.

To find out the number of resolutions in a PCD image, load image header using ImGearFileFormats. LoadPageHeader Method, and then check ImGearPage. Metadata.Common.ResolutionLayersCount property.

Note that resolutions in a PCD image are not ordered by size. See the list of resolutions and their sizes in the format description above.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


PCX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PCX
Full Name | PCX (PC Paintbrush File Format)
Format ID | ImGearFormats.PCX
File Extension(s) | *.pcx
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 5.0 1991, Supports 24-bit RGB
  • Version 3.0
  • Version 2.8 Included color palette
  • Version 2.5

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None.

Comments

PCX is one of the oldest PC-based bitmap formats. It became well-known when Microsoft used it for their Paintbrush for Windows application and distributed it with every copy of Windows. This format is popular for fax documents because it allows them to be viewed within many popular paint and image display programs. If multiple images are desired in a PCX format, the format known as DCX, designed for this purpose, (and supported by ImageGear), may be used. Please see See DCX. file format for more information.

The main components of the PCX file format are the fixed length header, the image data, and if it is written for VGA display technology, the palette for the image (this appears as the last structure in the file). The header includes fields including the PCX version, the image size, resolution and position, and an encoding field that always has a value of 1; PCX data is always RLE. (For complex images, this may actually cause the bitmap data to increase in size).

The size and location of the palette associated with the image depends on the version of the PCX. When it was first developed, the limitations of the EGA card led to a palette that contained just 16 colors. PCX also supported CGA, so that the palette contained only 4 colors. Both of these palettes were stored in the palette array structure of the header. When the PCX was modified to display VGA, there was not enough room to store the palette in the header; subsequently, it was located at the end of the file.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


PDF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PDF

Full Name | Adobe PDF (Adobe Portable Document Format)
Format ID | ImGearFormats.PDF
File Extension(s) | *.pdf
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | Document
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

PDF format requires ImageGear.Formats.PDF. See Assembly Initialization for more information.

ImageGear Supported Versions

  • Adobe® PDF version 1.7
  • Adobe® PDF version 1.6
  • Adobe® PDF version 1.5

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swapping in multi-page files

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
DefaultCompression | ImGearCompressions Enumeration | ImGearCompressions Enumeration.NONE | Any ImGearCompressions Enumeration value | This parameter specifies a compression used for encoding a raster page added/inserted into the PDF document by using ImGearDocument. Pages method.
Depth | Int32 | 24 | 1, 8, 24 | This parameter specifies bit depth in bits-per-pixel during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory required for rasterization. The DIB of the output raster image has this value as a bit count.
DrawMode | ImGearPDFPageDrawMode Enumeration | ImGearPDFPageDrawMode Enumeration.ENTIRE_PAGE | One of the ImGearPDFPageDrawMode Enumeration values | This parameter specifies default PDF rendering method used by the ImageGear PDF component to draw PDF page content.
IndependentPagesize | Bool | false | true, false | If this parameter is false, when saving a raster image into the PDF document, the width and height of the newly created page is set to the width and height of the previous page from the PDF document. If the previous page does not exist, the width and height are calculated from the image resolution and size as follows: Width = <width of the raster image> * 72 / <X DPI of the raster image> Height = < height of the raster image> * 72 / <Y DPI of the raster image> If the image resolution is not defined, the width and height are set to the width and height of the Letter page, which is 612 x 792. If this parameter is true, the following parameters are used to set the page size: PageHeight PageWidth
IncRend | Bool | False | True, False | This parameter specifies the way of drawing rendering. The true value sets incremental (stripe by stripe) rendering mode, the false value sets rendering as a single bitmap.
PageHeight | Int32 | 0 | Any non-negative value | This parameter sets the height of the page (in 1/72 inches). If this option is 0, the height is calculated from the image resolution and size as follows: Height = < height of the raster image> * 72 / <Y DPI of the raster image> If the image resolution is not defined, the height is set to the height of the Letter page, which is 792. This parameter is not used if IndependentPagesize is false.
PageWidth | Int32 | 0 | Any non-negative value | This parameter sets the width of the page (in 1/72 inches). If this option is 0, the width is calculated from the image resolution and size as follows: Width = <width of the raster image> * 72 / <X DPI of the raster image> If the image resolution is not defined, the width is set to the width of the Letter page, which is 612. This parameter is not used if IndependentPagesize is false.
Password | String | "" | Any string | This parameter specifies password string for password protected PDF documents.
PrintDepth | Int32 | 8 | 1, 8, 24 | This parameter specifies bit depth in bits-per-pixel during the PDF document printing. The greater this value, the higher the quality of the raster image you get and the more memory required for printing.
PrintResolutionX | Int32 | 300 | Any | This parameter specifies the horizontal resolution in dots-per-inch during PDF document printing. The greater this value, the higher the quality of the printed image.
PrintResolutionY | Int32 | 300 | Any | This parameter specifies the vertical resolution in dots per inch during the PDF document printing. The more this value the more quality image is printed.
Resolution3D | UInt | 72 | Any, except zero | This parameter specifies the resolution in dots per inch used for generating a pre-rendered bitmap of the default view of the 3D artwork. Producers should provide bitmaps of appropriate resolution for all intended uses of the document; i.e., a high-resolution bitmap for high-quality printing, and a default screen-resolution bitmap for on-screen viewing.
ResolutionX | Int32 | 72 | Any | This parameter specifies the horizontal resolution in dots-per-inch during the PDF document conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY | Int32 | 72 | Any | This parameter specifies the vertical resolution in dots-per-inch during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
SaveFlags | ImGearPDFSaveFlags Enumeration | ImGearPDFSaveFlags Enumeration.FULL | ImGearPDFSaveFlags Enumeration.COLLECT_GARBAGE | A bit composition of an OR of ImGearPDFSaveFlags Enumeration values | This parameter specifies an option for saving a PDF file, which allows you to remove unreferenced objects, often reducing file size as well as to write a linearized file for page-served remote (network) access, and to control compression of content streams inside a PDF file.
SaveMajor | Int32 | 0 | 1 | Specifies major PDF version number of the document for saving. If major equals 0, both major and minor are ignored and the document is saved to the library's default version. Make sure that the document conforms to the version number you are setting.
SaveMinor | Int32 | 0 | 6, 5, 4, etc. | Specifies minor PDF version number of the document for saving. Make sure that the document conforms to the version number you are setting.
SmoothFlags | ImGearPDFSmoothFlags Enumeration | 13 ImGearPDFSmoothFlags Enumeration.SMOOTH_IMAGE | ImGearPDFSmoothFlags Enumeration.SMOOTH_TEXT | ImGearPDFSmoothFlags Enumeration.ENHANCE_THIN_LINES | A bit composition of an OR of ImGearPDFSmoothFlags Enumeration values | This parameter specifies smooth settings for PDF rasterization.
TextEncoding | ImGearPDFTextEncoding Enumeration | ImGearPDFTextEncoding Enumeration.ASCII_85 | Any ImGearPDFTextEncoding Enumeration value | This parameter specifies which encoding scheme should be used to convert binary image data to the text format when saving raster image into the PDF document.

Comments

Please see the ImageGear.Formats.PDF Namespace and How to Work with PDF.

PDF documents that contain XFA information are not supported.


PEF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PEF
Full Name | Pentax/Samsung Camera Raw Format
Format ID | ImGearFormats.PEF
File Extension(s) | *.pef
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.
  • ImGearCompressions.HUFFMAN:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Pentax and Samsung digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Pentax/Samsung Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, or using Huffman compression.


PGM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PGM
Full Name | PGM (Portable Graymap File Format)
Format ID | ImGearFormats.PBM (see the Note below)
File Extension(s) | *.pgm
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC
ImageGear supports PGM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PGM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Write Support

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Filter Control Parameters

None

Comments

This format quickly and easily transfers grayscale bitmap images. This format, as well as PBM, PNM, and PPM, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as an intermediary storage methods for the conversion of other file formats.

The Portable Graymap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum gray value", and perhaps a comment line identifying the filename. The bitmap data follows white space (usually a carriage return). The number of pixels is equal to width * height. A pixel value of 0 indicates black, and a "maximum gray value" is equivalent to white.

The magic number of the header can have one of two values: either P2 or P5. P2 indicates that the bitmap data is read as ASCII decimal values. P5 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value does not exceed 255 (28 = 256 gray values from 0 to 255), each pixel is represented by a 8-bit sample. ImageGear loads such images as 8-bit grayscale. Otherwise, each pixel is represented by a 16-bit sample. ImageGear loads these images as 16-bit grayscale.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PGM Specification by Jef Poskanzer, copyright A 1989, 1991.

See Also
PPM
PBM
PNM


PhaseOneRaw
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PhaseOneRaw
Full Name | Phase One Camera Raw Format
Format ID | ImGearFormats.PhaseOneRaw
File Extension(s) | *.*
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Phase One digital cameras use this format for storing Raw images. By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Phase One Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Phase One files store a small color preview in the root IFD. An application that does not support Phase One can read the root IFD as a regular TIFF image. Raw image is stored in the own binary tag using original own compression method.


PNG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PNG
Full Name | PNG (Portable Network Graphics)
Format ID | ImGearFormats.PNG
File Extension(s) | *.png
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Supports single alpha channel for read/write.
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • 10th draft (future drafts will be backward-compatible)
  • PNG v2

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 2, 4, 8 bpp;
    • Grayscale: 1, 2, 4, 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Write Support

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 4, 8 bpp;
    • Grayscale: 1, 4, 8, 16 bpp;
    • Grayscale + Alpha: 16, 32 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Filter Control Parameters

ImageGear for .NET provides two versions of PNG filters. One is 100% "managed", and the other relies on the native codecs and is optimized for best compression and decompression performance. Each filter has its own set of control parameters listed below:

  • ImageGear "Native" Filter Control Parameters
  • ImageGear "Managed" Filter Control Parameters

ImageGear "Native" Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Filter ImGearPngImprovingFilter Enumeration None ImGearPngImprovingFilter Enumeration values

Each raster can be passed through a filter for improving the compression of raster. Possible values for this parameter are "None", "Sub", "Up", "Average", "Paeth", and "Optimal".

  • The value "None" means that the filter is not used.
  • The values "Sub”, "Up", "Average", and "Paeth" represent four different filters.
  • The value "Optimal" enables an algorithm that selects the best result. The algorithm passes the raster through each of the four filters, and the best result is used.
Interlaced | bool | true | true, false | Determines whether the image is saved in an interlaced or non-interlaced format.
KeepAlpha bool true true, false

When loading: if this parameter is true, then alpha channel is loaded into Alpha DIB. Otherwise, the image is transformed into RGB, by compositing over the background supplied in the bKGD chunk, if it is present, or over the default background.

When saving: if this parameter is true, and alpha DIB is present, it will be written to the file. Otherwise, alpha channel will be truncated.

  • Saving to PNG format with this filter produces images with resolution set to PPM (pixels per meter).
  • This filter uses more strict approach with processing corrupted PNG files, so images having any kind of corruption (like checksums mismatch or partial rater data) may not load.

ImageGear "Managed" Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
StripConfig | int | 0 (fixed count) | 0 (fixed count), 1 (fixed buffer) | Format of PNG strip, see ImGearPNGStrip constants.
BufferSize | int | 0 | Any int value | Size of the buffer for strip if StripConfig is 1 ( fixed buffer).
StripCount | int | 0 | Any int value | Number of lines in one strip if StripConfig is 0 ( fixed count).
CompLevel | int | 6 (default compression) | Any integer in range 0..9 | Compression level. It must be between 0 (No compression) and 9 (max compression). Better compression takes more time for compression. See ImGearPNGCompLevel.
KeepAlpha | bool | true | true, false | When loading: if this parameter is true, then alpha channel is loaded into Alpha DIB. Otherwise, the image is transformed into RGB, by compositing over the background supplied in the bKGD chunk, if it is present, or over the default background. When saving: if this parameter is true, and alpha DIB is present, it will be written to the file.

Comments

The PNG (pronounced "Ping") format was created out of reaction to Unisys's announcement that it would begin requiring royalty fees for use of its LZW compression scheme. This was the compression scheme for the widely-used GIF format (found in Web pages and online library images).

Thomas Boutell and a host of other programmers began working to devise a new file format to eliminate the need for payment of royalty fees. The result was a file format that offers better compression than GIF, and adds features GIF doesn't offer, including truecolor, and full alpha channel and gamma correction.

The basic organization of the PNG file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (identifying the chunk size and type). This makes it easy for a PNG viewer to identify chunks and to skip over the ones that are not necessary.

The first entry in a PNG file is the "PNG signature" that identifies the format as PNG. The file then proceeds with a series of chunks.

The IHDR Image Header, or IHDR Chunk, contains a number of fields including the height, width, depth, color type, and compression type of the image. The only valid compression value is 0, which indicates the PNG's custom compression scheme, a deflate/inflate compression with a 32k sliding window. This is a derivative of ZZ77, the precursor to LZW. ZZ77 is the compression scheme used by pkzip software.

The "PLTE Palette Chunk" contains 1 to 256 palette entries. This is present if the type field of the header chunk is set to 3. The number of colors cannot exceed the range provided by the bit depth.

The image data is stored in "IDAT Image Data Chunks". These are subdivided into chunks whose size is usually determined by the size of the encoder's buffer. The data may be stored in "interlaced order" allowing the image to be "faded in". The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

"Ancillary Chunks" are optional. They must appear before the first IDAT and after the PLTE. One chunk is the "bKGD chunk" that sets the default background color for the image. Two of the other ancillary chunks are the "hHist Chunk" or histogram chunk, and the "tEXt" chunk. The histogram chunk appears if there is a palette. It stores the frequency of each color of the palette as it occurs in the image data. If the application doesn't support all of the colors in the palette, the histogram can be used to choose a subset of colors. There may be any number of text chunks. They can vary in length from 0 to the maximum chunk size. They include the image author, copyright information, and any desired comments.

Questions about PNG can be e-mailed to: png-info@uunet.uu.net

References Used

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

PNG (Portable Network Graphics), tenth draft. Page 5, copyright Thomas Boutell, May 1995.

Wegner, Tim. "Coding for PNG Graphics", "PC Techniques", Feb/Mar 1996, pp 32-38.


PNM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PNM
Full Name | PNM (Portable Any-Map File Format)
Format ID | ImGearFormats.PBM (See the Note below)
File Extension(s) | *.pnm
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC
ImageGear supports PNM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PNM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

The PNM format is useful for quick and easy transfer of uncomplicated monochrome, grayscale, or color bitmap images. This format, as well as the PBM, PGM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a method called gifftoppm translates a GIF file to a PPM, from where it can be then translated to a TIFF using the pnmtotiff.

The Portable Anymap File Format structure is very simple. The "Anymap" portion of its name refers to the fact that it can be one of three types of UNIX bitmap file formats: the Portable Bitmap File Format (PBM), the Portable Graymap File Format (PGM), or the Portable Pixelmap File Format (PPM). A PNM begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value" if it is a PPM, a "maximum gray value" if it is a PGM, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. For PGM and PPM files, the number of pixels is equal to width * height (whereas, in a PBM file, this calculation gives you the number of bits).

The magic number of the header can have one of six values depending on whether the bitmap is in PBM, PGM, or PPM format. Each format can have one of two magic numbers depending on whether the pixel data is stored in ASCII decimal or plain bytes. See the descriptions for the individual formats (these are all supported by ImageGear) for more details.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM, PGM, PPM, PNM Specifications by Jef Poskanzer, copyright A 1989, 1991.


PPM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PPM
Full Name | PPM (Portable Pixmap File Format)
Format ID | ImGearFormats.PBM (See the Note below)
File Extension(s) | *.ppm
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC
ImageGear supports PPM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PPM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

The PPM format is useful for quick and easy transfer of color bitmap images. This format, as well as the PBM, PGM, and PNM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a method called gifftoppm translates a GIF file to a PPM, where it can translate to a TIFF using the pnmtotiff.

The Portable Pixmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value", and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of pixels is equal to width * height, with each pixel being represented by three bytes: one each for Red, Green, and Blue color components, respectively.

The magic number of the header can have one of two values: either P3 or P6. P3 indicates that the bitmap data is read as ASCII decimal values. P6 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value exceeds 255 (28 = 256 gray values from 0 to 255), each pixel is represented by three 16-bit RGB samples, making a total of 48 bits per pixel. ImageGear loads such images to 24-bit RGB.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PPM Specification by Jef Poskanzer, copyright A 1989, 1991.

See Also
PGM
PBM
PNM


PPTX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PPTX
Full Name | Office Open XML PowerPoint Format
Format ID | ImGearFormats.PPTX
File Extension(s) | *.pptx
Data Type | Vector Image
Data Encoding | Zipped XML Package
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | .NET, .NET64
PPTX format requires ImageGear.Formats.Office Namespace.

ImageGear Supported Versions

  • ECMA-376, Second Edition

ImageGear Supported Features

  • Autodetection
  • Single page file reading
  • Multiple page file reading

ImageGear Read Support

  • PPTX files conformed to ECMA-376, Second Edition Specification.

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

Please see Using ImageGear.Formats.Office Namespace.

Please see the ImageGear.Formats.Office Namespace.


PS
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PS

Full Name | Adobe PS (Adobe PostScript)
Format ID | ImGearFormats.PS
File Extension(s) | *.ps, *.eps
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | Document
ImageGear Platforms Support | WIN32, WIN64, Unix, .NET, .NET64, MAC

PS format requires ImageGear.Formats.PDF. See Assembly Initialization for more information.

ImageGear Supported Versions

  • Adobe® PS v3

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swapping in multi-page files

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.LZW:
  • Indexed RGB: 1,4,8 bpp;
  • Grayscale - 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
AutoPosition | Bool | true | true, false | This parameter enables/disables AutoPositionEPSFiles option for reading PS/EPS file format.
Depth | Int32 | 24 | 1, 8, 24 | This parameter specifies bit depth in bits-per-pixel during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory is required for rasterization. The DIB of the output raster image has this value as a bit count.
Height | Int32 | 0 | Any non-negative value. | This parameter sets the height of the page (in 1/72 inches). This parameter is used on loading a PostScript page. When this parameter is set to 0, the height is read from PostScript bounding box. If bounding box is not defined in PostScript, the height is set to 792.
IndependentPagesize | Bool | false | true, false | If this parameter is false, when saving raster image into the PDF document, the width and height of the newly created page is set to the width and height of the previous page from the PDF document. If the previous page does not exist, the width and height are calculated from the image resolution and size as follows: Width = <width of the raster image> * 72 / <X DPI of the raster image> Height = < height of the raster image> * 72 / <Y DPI of the raster image> If the image resolution is not defined, the width and height are set to the width and height of the Letter page, which is 612x792. If this parameter is true the following parameters are used to set the page size: PageHeight PageWidth
JobOptionsFile | String | "" | Any | This parameter specifies a path to Adobe job options file name.
Level | ImGearPSLevel Enumeration | ImGearPSLevel Enumeration.LEVEL_3 | Any ImGearPSLevel Enumeration value | This parameter specifies a language level of the output PostScript 3.0 document when saving to PostScript.
PageHeight | Int32 | 0 | Any non-negative value | This parameter sets the height of the page (in 1/72 inches). If this option is 0, the height is calculated from the image resolution and size as follows: Height = < height of the raster image> * 72 / <Y DPI of the raster image> If the image resolution is not defined, the height is set to the height of the Letter page, which is 792. This parameter is not used if IndependentPagesize is false. This parameter is also used when saving a raster image to PDF and IndependentPagesize is set to True.
PageWidth | Int32 | 0 | Any non-negative value | This parameter sets the width of the page (in 1/72 inches). If this option is 0, the width is calculated from the image resolution and size as follows: Width = <width of the raster image> * 72 / <X DPI of the raster image> If the image resolution is not defined, the width is set to the width of the Letter page, which is 612. This parameter is not used if IndependentPagesize is false. This parameter is also used when saving a raster image to PDF and IndependentPagesize is set to True.
ResolutionX | Int32 | 72 | Any | This parameter specifies the horizontal resolution in dots-per-nch during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY | Int32 | 72 | Any | This parameter specifies the vertical resolution in dots-per-inch during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
SmoothFlags | ImGearPDFSmoothFlags Enumeration | ImGearPDFSmoothFlags Enumeration.NONE | A bit composition of an OR of ImGearPDFSmoothFlags Enumeration values | This parameter specifies smooth settings for PostScript rasterization.
TextEncoding | ImGearPDFTextEncoding Enumeration | ImGearPDFTextEncoding Enumeration.ASCII_85 | Any ImGearPDFTextEncoding Enumeration value | This parameter specifies which encoding scheme should be used to convert binary image data to the text format when saving raster image into the PostScript document.
Type | ImGearPSType Enumeration | ImGearPSType Enumeration.POSTSCRIPT | Any ImGearPSType Enumeration value | This parameter specifies a type of the output PostScript document when saving to PostScript.
Width | Int32 | 0 | Any non-negative value | This parameter sets the width of the page (in 1/72 inches). This parameter is used on loading a PostScript page. When this parameter is set to 0, the width is read from PostScript bounding box. If bounding box is not defined in PostScript, the width is set to 612.

Comments

Please see the ImageGear.Formats.PDF Namespace and How to Work with PDF.


PSB
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PSB

Full Name | PSB (Adobe Photoshop Big)
Format ID | ImGearFormats.PSB
File Extension(s) | *.psb
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Supports pre-multiplied Alpha and additional Alpha mask channels as ImageGear Extra channels.
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, .NET, .NET64, .NET Compact Framework

ImageGear Supported Versions

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
LoadFirstExtraChannelAsAlpha | bool | false | false, true | This parameter specifies how ImageGear should load the first extra channel of a PSB image. If false , ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel. If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.
ReadLayerIndex | int | -1 | Any integer, but no more than number of layers | When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure

Adobe PSB/PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSB/PSD metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag name | Tag ID | Description
Signature | ImGearPSBTagIDs.SIGNATURE | Adobe Photoshop Signature: always equal to '8BPS'.
Version | ImGearPSBTagIDs.VERSION | Version: always equal to 1.
Rows | ImGearPSBTagIDs.ROWS | The height of the image in pixels. Supported range is 1 to 30,000.
Cols | ImGearPSBTagIDs.COLS | The width of the image in pixels. Supported range is 1 to 30,000.
Depth | ImGearPSBTagIDs.DEPTH | Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode | ImGearPSBTagIDs.MODE | The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength | ImGearPSBTagIDs.MODE_LEN | The length of the following color data provided by tag ColorData.
ColorData | ImGearPSBTagIDs.COLOR_DATA | The color data.
PhotoshopResources | ImGearPSBTagIDs.PHOTOSHOP_RESOURCES | Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers | ImGearPSBTagIDs.LAYERS | Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount | ImGearPSBTagIDs.LAYER_COUNT | Number of layers in the Photoshop Image.
Header | ImGearPSBTagIDs.HEADER | This section contains the basic properties of the image.
RESERVED_HDR | ImGearPSBTagIDs.RESERVED_HDR | Reserved: must be zero.
Channels | ImGearPSBTagIDs.CHANNELS | The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA | ImGearPSBTagIDs.IPTC_NAA | File information (IPTC-NAA record 2).

Comments

The PSB (Photoshop Big), or Large Document format, is a newer version of PSD designed for files over 2 gigabytes, supporting up to 300,000 pixels in any dimension. The PSB format is identical to the Photoshop native format (PSD) in many ways.

The PSB/PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSB/PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSB/PSD file.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: OaReilly & Associates, Inc., 1996.


PSD
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PSD

Full Name | PSD (Adobe Photoshop)
Format ID | ImGearFormats.PSD
File Extension(s) | *.psd
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Supports pre-multiplied Alpha and additional Alpha mask channels as ImageGear Extra channels.
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, .NET, .NET64, .NET Compact Framework

ImageGear Supported Versions

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
LoadFirstExtraChannelAsAlpha | bool | false | false, true | This parameter specifies how ImageGear should load the first extra channel of a PSD image. If false , ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel. If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.
ReadLayerIndex | int | -1 | Any integer, but no more than number of layers | When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure

Adobe PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSD metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag Name | Tag ID | Description
Signature | ImGearPSDTagIDs.SIGNATURE | Adobe Photoshop Signature: always equal to '8BPS'.
Version | ImGearPSDTagIDs.VERSION | Version: always equal to 1.
Rows | ImGearPSDTagIDs.ROWS | The height of the image in pixels. Supported range is 1 to 30,000.
Cols | ImGearPSDTagIDs.COLS | The width of the image in pixels. Supported range is 1 to 30,000.
Depth | ImGearPSDTagIDs.DEPTH | Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode | ImGearPSDTagIDs.MODE | The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength | ImGearPSDTagIDs.MODE_LEN | The length of the following color data provided by tag ColorData.
ColorData | ImGearPSDTagIDs.COLOR_DATA | The color data.
PhotoshopResources | ImGearPSDTagIDs.PHOTOSHOP_RESOURCES | Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers | ImGearPSDTagIDs.LAYERS | Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount | ImGearPSDTagIDs.LAYER_COUNT | Number of layers in the Photoshop Image.
Header | ImGearPSDTagIDs.HEADER | This section contains the basic properties of the image.
RESERVED_HDR | ImGearPSDTagIDs.RESERVED_HDR | Reserved: must be zero.
Channels | ImGearPSDTagIDs.CHANNELS | The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA | ImGearPSDTagIDs.IPTC_NAA | File information (IPTC-NAA record 2).

Comments

The PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSD file.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: OaReilly & Associates, Inc., 1996.


PTOCA
User Guide > File Formats and Compressions > File Formats > File Formats Reference > PTOCA
Full Name | PTOCA (Presentation Text Object Content Architecture)
Format ID | ImGearFormats.PTOCA
File Extension(s) | *.pto, *.mod
Data Type | Metafile
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64

ImageGear Supported Versions

  • Format 2

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Factor | DOUBLE | 1.0 |  | Linear DIB size Factor.

Comments

ImageGear can read PTOCA files as content of multi- and single-page MOD:CA files, ensuring better compatibility with IBM's AFP (Advanced Function Presentation) printer architecture.

The PT object structure starts with the "Begin Presentation Text" structure field and finishes with the "End Presentation Text" structure field. Text data is placed between these fields and consists of graphic characters and control sequences that describe how the text will be shown on the presentation surface. The PT object can include some other optional structured fields that define initial presentation text values. If PTOCA is included in the MOD:CA content, some presentation text parameters (like code page, font, an initial values) can be defined on the MOD:CA level.

References Used

IBM BookManager BookServer, Copyright 1989, 1999, IBM Corporation.


RAF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > RAF
Full Name | Fujifilm Camera Raw Format
Format ID | ImGearFormats.RAF
File Extension(s) | *.raf
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Fujifilm digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Fujifilm Raw format uses a proprietary prefix followed by TIFF/EXIF file structure. Raw image is stored uncompressed. CCD sensor in many Fujifilm cameras is rotated by 45 degrees, to improve quality of vertically and horizontally oriented objects in the picture. ImageGear automatically rotates these images during the "Low level processing" step of Camera Raw color reconstruction.


RAS
User Guide > File Formats and Compressions > File Formats > File Formats Reference > RAS
Full Name | RAS (Sun Raster Data Format)
Format ID | ImGearFormats.RAS
File Extension(s) | *.ras
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

Bitmap images used under the SunOS system and UNIX imaging applications are usually stored in Sun Raster form.

The Sun Raster header contains image data (size and type), and the type and size of the colormap, if present. It also contains a Sun Raster identifying tag called "MagicNumber," which always contains the same value. A type field identifies the version of Sun Raster, the most common are called "Old" and "Standard". These are actually the same format and indicate that the image is not compressed. Other possible versions of Sun Raster files include TIFF and IFF, meaning that the image data was converted from one of these formats.

Following the header is a colormap, if applicable. Most 24 or 32-bit raster images do not use a colormap, but rather store the color values directly with the image data. This is known as "truecolor".

The last element of the Sun Raster file is the image data itself. It is usually in 2D raster format.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


RAW
User Guide > File Formats and Compressions > File Formats > File Formats Reference > RAW
Full Name | RAW (Header-less image)
Format ID | ImGearFormats.RAW
File Extension(s) | *.*
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Supports single alpha channel for read.
ImageGear Platforms Support | .NET, .NET64

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1, 4, 8, 12, 16 bpp;
    • RGB: 24,48 bpp;
    • RGB + Alpha: 32,64 bpp
    • CMYK: 32, 64 bpp
  • ImGearCompressions.LZW:
    • Grayscale: 1, 4, 8, 12, 16 bpp;
    • RGB: 24,48 bpp;
    • RGB + Alpha: 32, 64 bpp
    • CMYK: 32, 64 bpp
  • ImGearCompressions.CCITT_G3:
    • Grayscale: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Grayscale: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Grayscale: 1 bpp

ImageGear Write Support

RAW images writing is not supported.

Comments

A raw image file contains no header or identifying information. ImageGear can load images of proprietary or unsupported formats as raw data. Since ImageGear cannot obtain parameters, such as width, height or bits per pixel from the file, the application should specify them. This can be done by using the ImGearRawLoadOptions class derived from the ImGearLoadOptions, to specify loading options for header-less RAW formats and passing them to the LoadPage method.


Scitex CT
User Guide > File Formats and Compressions > File Formats > File Formats Reference > Scitex CT
Full Name | SciTex (Scitex CT)
Format ID | ImGearFormats.SCI
File Extension(s) | *.sct
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Write Support

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Filter Control Parameters

None

Comments

ImageGear has read and write support for Scitex HandShake Continuous Tone Picture files. This is the native format used by Scitex scanners and printers for high-end image processing and color separation.

Scitex CT files store uncompressed, CMYK true-color raster data. They contain a Control Block, a Parameters Block, and the image data. Scitex CT images are typically four-color separation, CMYK, line-interleaved raster data. The separations are always stored by scan line and in the order C-M-Y-K (cyan-magenta-yellow-black). A color pixel value have up to 16 separations (128 bits) in size. Separations 1 through 4 are defined in order (C-M-Y-K). Separations 5 through 16 are reserved for future expansion of the format, as shown below.

Each row or Scitex CT image data is stored in separated color. The first separation's row data is followed by the second, and so forth, up to the number of separations specified by NumColorSeparations. Only the data for the separations defined by the SeparationsBitMask field is actually stored in the CT file. Each pixel can contain up to 16 separation components and each component is one byte in size. A CMYK pixel contains four components and is of a 32-bit size. Remember that the data is not stored by pixel, but by separation. If rows contain odd numbers of bytes, the zero padding byte will be added to the end of each separation to preserve word alignment.

You can set ImageGear CMYK Support level to IG_CONVERT_TO_RGB to convert CMYK images to 24-bit RGB during loading. However, use of this mode is deprecated. We recommend to load the image in its native format, and then convert to desired color space if needed.

References Used

CopyrightA 1994, 1996, O'Reilly & Associates, Inc.


SGI
User Guide > File Formats and Compressions > File Formats > File Formats Reference > SGI
Full Name | SGI (Silicon Graphics Image)
Format ID | ImGearFormats.SGI
File Extension(s) | *.sgi, *.bw, *.rgb, *.rgba
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Supports single alpha channel for read and write.
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

None

Comments

This format was developed for use with the SGI image library included on most Silicon Graphics computers. Most SGI images are black and white.

The major components of an SGI file are the 512-byte header, a "scan-line offset table", and the bitmap header. SGI is one of the few formats to use a scan-line offset table.

The fields of the header structure include a compression flag (1 = compressed), the height and width (in pixels) of the image, the number of bit planes, the highest pixel value and the lowest pixel value, the name of the image, and pixel format. Pixel format can indicate the number of color channels, whether the image is dithered to a single channel, and whether the bitmap image is actually a color map for other images.

The bitmap data is stored up-side-down--the first scan line is at the bottom of the bitmap. If the data is RLE, a scan-line offset table is present, following the header and preceding the bitmap. This increases compression further by allowing repeated offsets to the same scan line, if several scan lines have the same value. A grayscale image may even refer to the same scan line from three different bit fields. For this reason, and because SGI data that is compressed can be stored in any scan-line order, the offset table must not be ignored.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


SonyRaw
User Guide > File Formats and Compressions > File Formats > File Formats Reference > SonyRaw
Full Name | Sony Camera Raw Format
Format ID | ImGearFormats.SonyRaw
File Extension(s) | *.srf
Data Type | Bitmap
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support

No

ImageGear Filter Control Parameters

See DCRAW Filter Control Parameters.

Comments

Sony digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Sony Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, some cameras use predictor.


SVG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > SVG
Full Name | SVG (Scalable Vector Graphics)
Format ID | ImGearFormats.SVG
File Extension(s) | *.svg
Data Type | Vector Image
Data Encoding | XML
Multi-Page Support | No
Alpha Channel Support | No
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64
SVG Format requires the ImageGear.Formats.SVG Namespace.

ImageGear Supported Versions

  • SVG v1.1

ImageGear Supported Features

  • Autodetection
  • Single page file reading
  • Single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - XML data

ImageGear Write Support

  • ImGearCompressions.NONE - XML data

Comments

SVG is a markup language for describing two-dimensional graphics applications and images, and a set of related graphics script interfaces. SVG 1.1 is a W3C Recommendation and is the most recent version of the full specification. The second edition - SVG 1.1 - includes clarifications and minor improvements based on developer feedback. Most of commonly used browsers support SVG format by some level. The specification for this format is available on W3C web site:

http://www.w3.org/TR/SVG11/

SVG Elements Supported for Reading

SVG Element*

Supported Attributes

Supported Properties

Imported into ImageGear as:

circle

class

id

style

transform

cx

cy

r

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-width

visibility

ImGearVectEntities.ELLIPSE entity.

clipPath

id

-

Clipping region for the specified entity. Use Vector Entity functions to access clipping regions.

defs

class

id

style

transform

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK entity.

ellipse

class

id

style

transform

cx

cy

rx

ry

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-width

visibility

ImGearVectEntities.ELLIPSE entity.

font

style

Attributes listed below are only stored and saved back to SVG, but are not used for display:

horiz-origin-x

horiz-origin-y

horiz-adv-x

vert-origin-x

vert-origin-y

vert-adv-y

font-face

See "font-face" element, below.

glyph

See "glyph" element, below.

missing-glyph

See "glyph" element, below.

ImGearVectorFont object.

If ImGearVectorFont object is created from <font> Svg element, it will be saved as <font> svg tag when writing the image in SVG format. In any other cases ImGearVectorFont object will be written as attributes and properties of <text> or <tspan> elements.
font-face

font-family

font-size

font-style

font-weight

units-per-em

Attributes listed below are only stored and saved back to SVG, but are not used for display:

font-stretch

font-variant

 Stored as part of a ImGearVectorFont object.

G

class

id

style

transform

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

glyph

unicode

d

Attributes listed below are only stored and saved back to SVG, but are not used for display:

horiz-adv-x

vert-adv-y

Stored as part of a ImGearVectorFont object.

Glyphs that correspond to a sequence of two or more Unicode characters are not supported.

image

class

id

style

transform

xlink:href

x

y

width

height

clip-path

display

visibility

ImGearVectEntities.RASTER entity.

line

class

id

style

transform

x1

y1

x2

y2

clip-path

color

dash-repeat

display

marker-end

marker-start

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-width

visibility

ImGearVectEntities.EASYLINE entity.

linearGradient

class

id

style

x1

x2

y1

y2

spreadMethod

gradientTransform

gradientUnits

xlink:href

See ‘stop’ element

ImGearVectorGradient and ImGearVectorFilltype objects.

ImGearVectorFilltype references ImGearVectorGradient.

marker

class

id

style

transform

markerUnits

refX

refY

markerWidth

markerHeight

orient

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

path

class

id

style

transform

d

clip-path

color

dash-repeat

display

fill

fill-opacity

fill-rule

marker-end

marker-start

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

visibility

ImGearVectEntities.FIGURE entity.

polygon

class

id

style

transform

points

clip-path

color

dash-repeat

display

fill

fill-opacity

fill-rule

marker-end

marker-start

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

visibility

ImGearVectEntities.POLYLINE entity.

polyline

class

id

style

transform

points

clip-path

color

dash-repeat

display

fill

fill-opacity

fill-rule

marker-end

marker-start

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

visibility stroke-width

visibility

ImGearVectEntities.POLYLINE entity.

radialGradient

class

id

style

cx

cy

r

fx

fy

spreadMethod

gradientTransform

gradientUnits

xlink:href

See ‘stop’ element

ImGearVectorGradient and ImGearVectorFilltype objects.

ImGearVectorFilltype references ImGearVectorGradient.

rect

class

id

style

transform

x

y

width

height

rx

ry

clip-path

color

dash-repeat

display

fill

fill-opacity

fill-rule

marker-end

marker-start

opacity

stroke

stroke-dasharray

stroke-width

visibility

ImGearVectEntities.POLYLINE entity.

stop

class

style

offset

stop-color

stop-opacity

Stops within ImGearVectEntities.GRADIENT. Use Vector Gradient functions to access the stops.

Svg

class

id

style

transform

x

y

width

height

viewbox

clip-path

color

dash-repeat

display

fill

fill-opacity

fill-rule

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

First-level occurrences are interpreted as ImGearVectorView object.

Nested occurrences are interpreted as ImGearVectEntities.BLOCK entity.

switch

class

id

style

transform

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

symbol

class

id

style

transform

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

text

class

id

style

transform

x

y

dx

dy

rotate

textLength

lengthAdjust

clip-path

display

fill

fill-opacity

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.TEXT entity with one or more ImGearVectorTextObject objects.

tspan

class

id

style

transform

x

y

dx

dy

rotate

textLength

lengthAdjust

clip-path

display

fill

fill-opacity

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.TEXT entity with one or more ImGearVectorTextObject objects.

use

class

id

style

transform

clip-path

color

dash-repeat

display

fill

fill-opacity

opacity

stroke

stroke-dasharray

stroke-linecap

stroke-linejoin

stroke-width

text-anchor

visibility

font-family

font-style

font-variant

font-size

font-weight

font-stretch

font-size-adjust

ImGearVectEntities.BLOCK and ImGearVectEntities.INSERTION entities.

ImGearVectEntities.INSERTION references ImGearVectEntities.BLOCK.

* See SVG format specification for details on SVG elements, attributes, and properties: http://www.w3.org/TR/SVG11/

ImageGear Vector Entities and Objects Supported for Writing to SVG Format

ImageGear Entity or Object

Saved as SVG Element /Property

ImGearVectorFont object

<font>
<font-face>
<glyph>
<missing-glyph>

ImGearVectorFont object is saved as <font> SVG tag only if it has been created from <font> svg element when loading Svg image. In all other cases ImGearVectorFont object is saved as attributes and properties of <text> or <tspan> elements.

ImGearVectEntities.EASYLINE

<line>

ImGearVectEntities.BLOCK

<g>

ImGearVectEntities.INSERTION

<use>

ImGearVectEntities.POLYLINE

<path> or <polyline> depending on whether the entity contains hidden vertices

ImGearVectEntities.POLYLINEEX

<path>

ImGearVectEntities.ELLIPSE

<ellipse>

ImGearVectEntities.ARC

<path>

ImGearVectEntities.RASTER

<image>

ImGearVectEntities.BEZIER_CURVE

<path>

ImGearVectEntities.NURBS_SURFACE

<path>

ImGearVectEntities.SOLID

<polyline>

ImGearVectEntities.NURBS_CURVE

<polyline>

ImGearVectEntities.FIGURE

<path>

ImGearVectEntities.TEXT

<text> with <tspan>

Notes:

  • All non-block and non-insertion entities from the drawing are saved in section.
  • All entities belonging to the active view are inserted to SVG as elements that reference corresponding existing definition from the section.
  • Layers are saved as <style> attributes in CDATA section.
  • Gradient fill types are saved as <linearGradient> and <radialGradient> elements in <defs> section.
  • During the saving, 3D entities are projected to 2D surface, according to the active view settings.
  • ImGearVectorFont object is saved as <font> SVG tag only if it has been created from <font> svg element when loading Svg image. In all other cases ImGearVectorFont object is saved as attributes and properties of <text> or <tspan> elements.


TGA
User Guide > File Formats and Compressions > File Formats > File Formats Reference > TGA
Full Name | TGA (Truevision Targa)
Format ID | ImGearFormats.TGA
File Extension(s) | *.tga, *.tpic
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | Single alpha channel for read/write
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 2.0, 1991
  • Version 1.0, 1984

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;
  • ImGearCompressions.RLE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ImageID | byte[] | Empty array |  | Image ID

Comments

This file format was originally developed by AT&T for use with its image capture boards. The format was taken over by Truevision when it acquired the product line from AT&T. It is now commonly used for digitized images and also for high-quality images produced by ray tracers and other graphics applications.

It became a popular file format mainly because it was the first 24-bit truecolor format to come to the PC market. There are several varieties of Targa files; the most commonly used are the Targa 16, Targa 24, and Targa 32. The names are derived from the type of hardware used to create them.

The fixed-sized header information of the Targa format includes: the existence (or not) and colormap, location, size, pixel depth, image location, colormap (if it exists), and finally the image data itself.

Version 2.0 introduced a file footer that identifies it as the newest version and contains pointers to additional fields in two main structures: the "extension area" and the "developer directory". The extension area contains the addresses of many optional fields, one of the most popular being the "postage stamp image" (miniature of the main image).

The developer directory can be used to store proprietary information. Developers can register their own private fields with Truevision. A null-terminated ASCII string containing "TRUEVISION-XFILE.", and positioned at the end of the file, indicates that the footer is valid.

Targa defines 3 color methods: pseudo color, direct color, and truecolor. Pseudo color uses an index to a color palette. Direct color is like pseudo color except that the RGB components are looked up separately. In truecolor files, the color information is stored directly in the image data. The palettes used by Targa files are variable in size; they do not necessarily correlate to the bit depth of the image. The presence of a palette does not always mean that it is used to display the image.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


TIFF
User Guide > File Formats and Compressions > File Formats > File Formats Reference > TIFF
Full Name | TIFF (Tagged Image File Format)
Format ID | ImGearFormats.TIF
File Extension(s) | *.tif, *.tiff
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | Yes
Metadata Update Support | Page
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 6.0 - Added support for CMYK and YCbCr color images, and JPEG compression. Ability to store pixels in "tiles"
  • Version 5.0 - Added ability to store palette color images and support for LZW compression. This version featured TIFF "classes."
  • Version 4.0 - Added support for uncompressed RGB color images.
  • Version 3.0 - First public release.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swaping in multi-page files
  • IGFilterFormatFlags.MPDATASUPPORT - faster multi-page access by storing private format data (used only with IG_mpi_... and IG_mpf_... API)

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.LZW:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.

To use LZW (Lempel-Ziv-Welch) Compression compression scheme ImageGear.Formats Namespace should be attached.

ImageGear Write Support

TIFF writer requires read/write access to the output stream.

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp;
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BigEndian | bool | false | false, true | If true , big endian order is used for write operation ("MM"), in other case little endian is used("II").
BitonalPaletteMode | ImGearTIFFBitonalPaletteMode Enumeration | LEGACY | An ImGearTIFFBitonalPaletteMode Enumeration value | Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
FillOrder | ImGearFillOrder Enumeration | MSB | An ImGearFillOrder Enumeration value | Specifies fill order (most significant bit first, less significant bit first) to use for writing the TIFF file.
ImageBeforeIFD | bool | false | false, true | This flag specifies physical location of raster data inside TIFF file relatively to IFD record. If this value is true then image data is to be written before IFD record.
IncludePageNumber | bool | true | false, true | If this parameter is true then include tag 297 into TIFF image with real value of page number.
LoadFirstUnknownChannelAsPAlpha | bool | true | true, false | This parameter specifies how to load first extra channel if ExtraSamples tag is missing. If LoadFirstUnknownChannelAsPAlpha is True, IG loads first extra channel as Premultiplied Alpha channel. This mode provides support for RGBPA TIFF images written by earlier versions of ImageGear. If LoadFirstUnknownChannelAsPAlpha is False, IG loads all extra channels as extra channels.
MissingCompression | ImGearCompressions Enumeration | AUTO | An ImGearCompressions Enumeration value | Compression to use for image loading, if compression tag is missing in the image.
Save70 | bool | true | false, true | If this value is true then output TIFF-JPEG image will be produced in TIFF 7.0 compatible format but in other case it will be compatible with TIFF 6.0.
SaveClassF | bool | false | false, true | If this value is true then image to be written in TIFF format compatible with class F requirements.
SaveEXIFMetadata | bool | false | true, false | If this parameter is true EXIF metadata is saved with TIFF file.
SaveExistingEXIFMetadata | bool | true | true, false | This parameter controls the saving of existing EXIF metadata. By default (SaveEXIFMetadata = False, SaveExistingEXIFMetadata = True), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.
SavePlanar | bool | false | false, true | Specifies tag value 284 for output image.
SaveUsingDiffPredictor | bool | false | false, true | If this parameter is true, then output TIFF-LZW image will be produced using the horizontal differencing predictor.
StripBufferSize | int | 32768 | Any positive value | If StripMode equals ImGearStripModes Enumeration.FIXED_BUFFER, specifies the buffer size to be used for writing of each strip.
StripCount | int | 1 | Any positive int value, not greater than image height | If StripMode equals ImGearStripModes Enumeration.FIXED_COUNT, specifies the number of strips for saving the TIFF image.
StripMode | ImGearStripModes Enumeration | FIXED_COUNT | An ImGearStripModes Enumeration value | Specifies strip or tile saving mode for the TIFF image. By default, ImageGear saves TIFF files with one strip.
SubIFDPath | string | Empty string | Any string value | Path of the SubIFD to load the image from. If set to empty string (default), load image from root IFD. See "Camera Raw Image support" section for more detail.
TileHCount | int | 10 | Any positive int value, not greater than image width | If StripMode equals ImGearStripModes Enumeration.TILED_FIXED_COUNT, specifies the number of tiles in horizontal dimension.
TileHeight | int | 64 | Any positive int value, not greater than image height | If StripMode equals ImGearStripModes Enumeration.TILED_FIXED_SIZE, specifies the height of each tile.
TileVCount | int | 10 | Any positive int value, not greater than image height | If StripMode equals ImGearStripModes Enumeration.TILED_FIXED_COUNT, specifies the number of tiles in vertical dimension.
TileWidth | int | 64 | Any positive int value, not greater than image width | If StripMode equals ImGearStripModes Enumeration.TILED_FIXED_SIZE, specifies the width of each tile.
TreatThumbnailsAsPages | bool | false | false, true | If this parameter is true, ImageGear considers the pages marked with 'NewSubfileType tag is 1' as regular pages. Otherwise, pages with 'NewSubfileType is 1' are considered thumbnails and are not loaded and not taken into account in page count calculation.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata | SaveExistingEXIFMetadata | Source Page has EXIF metadata | ImageGear Action
False | False | No | Does not save EXIF metadata
False | False | Yes | Does not save EXIF metadata
False | True | No | Does not save EXIF metadata
False | True | Yes | Saves existing EXIF metadata
True | False | No | Saves default EXIF metadata
True | False | Yes | Ignores existing and saves default EXIF metadata
True | True | No | Saves default EXIF metadata
True | True | Yes | Saves existing EXIF metadata

Comments

TIFF was developed for use in storing black-and-white images from scanners and desktop publishing applications. Now, in its fourth release (version 6.0), it is one of the most detailed and versatile bitmap formats in use. It is supported by most art, imaging, and word-processing applications. It supports several compression schemes. Aside from saving image data in bitmap form, it can also contain vector or text-based images.

Containing just three fields, the TIFF header is simple and one of the shortest of all the graphics file format headers. But, the structure of a TIFF is complicated, with variable length fields, variable number of fields, and the ability to store information (other than the header) in any order desired.

The other two major components of the TIFF format are "Image File Directories" (IFDs) and the image or images themselves. There is one IFD per image stored. The combination of an IFD and an image is referred to as a "subfile". The header contains an offset pointer to the first IFD. If there are multiple IFDs, each contains an offset to the next. The last IFD contains a value that signifies the end of the file.

IFDs closely resemble a header structure, and the information stored in them is often referred to as "TIFF Header Information". Unlike a header, however, they contain a variable number of "tags" (pointers or fields). In addition, each tag can point to data with a variable length. TIFFs are notorious for the number of tags that they can contain, up to a maximum of 65,535 tags of nearly 100 different types (version 6.0). Tags are listed in order by code number so that a TIFF reader can easily determine what fields are present. While ImageGear reads and stores all TIFF tags, it utilizes a subset of all of the possible tags. See note on previous page.

In version 5.0, the presence of certain subgroups of tags determined what "class" the TIFF belonged to. The classes are: TIFF-B-monochrome, TIFF-F-fascimile, TIFF-G-grayscale, TIFF-P-palette based, TIFF-R-RGB color, TIFF-X-any class, TIFF-Y-can use JPEG compression. Version 6.0 uses tags to divide the TIFF type into different file configurations, leaving behind the class concept. Version 6.0 configurations are: Bilevel, palette color, RGB, grayscale, YCbCr, and Class F (facsimile).

TIFF bitmap data can be stored in one of two configurations: strips or tiles. Strips are groups of adjoining rows of bitmap data, and can be found in version 5.0 and 6.0 files. Tiles were new to TIFF version 6.0. They are rectangular or square sections of bitmap data. The method of storage is determined in part by what kind of compression (if any) is used. JPEG compression can handle tiled images. Due to the need for padding with tile storage, tiling is not usually efficient for small images.

ImageGear supports the following compression schemes for TIFF:

  • Uncompressed
  • CCITT Group 3 Compression
  • CCITT Group 3 2D Compression
  • CCITT Group 4 Compression
  • Huffman Compression
  • JPEG Compression
  • Lossless JPEG Compression
  • LZW (Lempel-Ziv-Welch) Compression
  • Packbits Compression
  • Progressive JPEG Compression
  • Deflate Compression (both the 'normal' deflate compression and the Planar/Adobe-style deflate compression are supported)

See the ImageGear Supported Compressions Reference for descriptions of these compression types. The compression tag of the IFD tells whether the image is compressed, and by what method. (Not all TIFF files can use JPEG compression. It is supported by version 6.0, but in version 5.0, only a "Y" class TIFF can use JPEG).

TIFF/EP

TIFF/EP format was designed to provide a means for storing "raw" (unprocessed) image from digital camera's sensor.

TIFF/EP allows you to store several versions of the same image in one file. Typically, TIFF/EP image includes a small preview and a raw image. It can also include a larger or full-size preview, or some other variations of the image.

TIFF/EP uses IFD trees for storing different versions of image. This is different from IFD chains that are used in baseline TIFF to store multiple pages.

ImageGear does not detect TIFF/EP as a separate file format. If Raw detection is enabled, and ImageGear can recognize TIFF/EP file as a known Raw format, it detects and loads the file as DCRAW. Otherwise it detects TIFF/EP as TIFF. One of well known extensions to TIFF/EP is Adobe DNG format. ImageGear detects it as a separate file format.

Most of digital cameras store pixels in "mosaic" format. At a given pixel location either a Red, Green, Blue, Cyan, or some other color sample value is recorded. Such images are referred to as "Color Filter Array" type. TIFF/EP format uses a two-dimensional matrix called "Color Filter Array pattern" to describe positions of pixels of particular color in the mosaic image. In order to recreate the full color values in each pixel, it is necessary to interpolate intensities of neighboring pixels.

To enable loading images from TIFF SubIFDs, a new control parameter is added to TIFF filter: "SUBIFD_PATH". This parameter has the type of String, and its default value is "" (empty string). By default, ImageGear loads the image in the root IFD (thumbnail). If "SUBIFD_PATH" string begins with a number, then ImageGear loads the image from the corresponding SubIFD of the root IFD. For example, if SUBIFD_PATH is set to "3", ImageGear will load the image from the 3rd SubIFD.

SUBIFD_PATH parameter also affects metadata reading. Metadata is loaded starting from the IFD specified by SUBIFD_PATH.

ImageGear does not support color reconstruction of TIFF/EP images, unless they are detected to be a DNG or a DCRAW image supported by ImageGear.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


U3D
User Guide > File Formats and Compressions > File Formats > File Formats Reference > U3D
Full Name | U3D (Universal 3D)
Format ID | ImGearFormats.U3D
File Extension(s) | *.u3d
Data Type | Vector Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, .NET, .NET64
U3D Format requires the ImageGear.Formats.U3D Namespace.

Supported Versions

  • U3D v. 1.0

Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

Read Support

  • ImGearCompressions.NONE - Universal 3D vector data

Write Support

  • ImGearCompressions.NONE - Universal 3D vector data

Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BackColor | Int 32 | 0 | Any positive value | This parameter is used to set background color. If BackColor = 0, then the black background color is set, otherwise the white background color is set.
Width | Int 32 | 512 | Any positive value | Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

U3D file format, short for "Universal 3D", is a universal vector standard for storing three-dimensional data of all kinds to facilitate data exchange. The specification for this format is the document ECMA-363: Universal 3D File Format. The latest edition of this specification is available at the ECMA web site:

www.ecma-international.org/

The U3D format is natively supported by the PDF. 3D objects in U3D format can be inserted into PDF document files and interactively visualized by PDF viewers.

U3D Elements Supported for Reading

U3D Element | Supported Attributes | Imported into ImageGear as:
Croup Node | Id | ImGearVectEntities.BLOCK entity.
Model Node | Id Vertices Normals Material ambient color Material diffuse colors Material specular colors Material emissive colors Reflectivity Opacity Faces Lines Points Texture coordinates Bounding box | ImGearVectEntities.SHELLEX entity.
View Node | Name Near clip plane Far clip plane Rectangle Focus | ImGearVectorView object.
Light Node | Position Direction Specular color Ambient color Diffuse color Intensity Attenuations | ImGearVectorLightSource object.

ImageGear Vector Entities Supported for Writing to U3D Format

ImageGear Entity or Object | Saved as U3D Element
ImGearVectEntities.BLOCK | Group Node
ImGearVectEntities.INSERTION | Group Node
ImGearVectEntities.SHELL | Meshes
ImGearVectEntities.SHELLEX | Textures Materials Meshes Line set Point set
ImGearVectorView | View Node
ImGearVectorLightSource | Light Node


WBMP
User Guide > File Formats and Compressions > File Formats > File Formats Reference > WBMP
Full Name | WBMP (Wireless Bit-Map)
Format ID | ImGearFormats.WBMP
File Extension(s) | *.wbmp,
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 1.1

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The WBMP (Wireless Bit-Map) read/write format is optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).

File contains small header with image parameters and array or pixels in uncompressed form.

References Used

WAP WAE Specification Version, 24 May 1999.


WPG
User Guide > File Formats and Compressions > File Formats > File Formats Reference > WPG
Full Name | WPG (WordPerfect Graphics Metafile)
Format ID | ImGearFormats.WPG
File Extension(s) | *.wpg
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • WPG for WP 5.1 and up can store bitmap and vector graphics in the same file.
  • WPG for WP 5.0 and prior can store only bitmap or vector graphic, but not both in same file.

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.RLE - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

Metafiles contain vector (or geometric) specifications and bitmap pixel data. Vector data is ignored; only the bitmap data is read and/or written.

This format was created specifically for use with WordPerfect software products. WPG files for WordPerfect versions 5.1 and up can store both bitmap and vector image data in the same file.

The WordPerfect Graphics Metafile contains a short header or "prefix" (as WordPerfect Corporation referred to it). The header is followed by a record area, that is a sequence of objects and their attributes. The first record is called the "Start WPG Data" record and contains information on the size of the images and the version number of the .WPG file. The next record is usually a color map, unless the image is black and white. The next record is a bitmap record. If there are multiple images, there is a bitmap record for each image. The last record in a .WPG file contains a NULL body to signify the end of the file. These files may also contain Encapsulated PostScript (EPS) data.

References Used

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XBM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > XBM
Full Name | XBM (X BitMap)
Format ID | ImGearFormats.XBM
File Extension(s) | *.xbm
Data Type | Raster Image
Data Encoding | ASCII
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 11, data stored as 1-byte character, 1986
  • Version 10, data stored as 2-byte "short" integers

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The XBM format is intended as a convenient storage method for small monochrome images, for example, cursor and icon bitmaps. It can, however, support images of any size, but since it supports no native compression scheme, an exterior compression program is used when compacting is desired. The bitmap data is stored as ASCII data with C language syntax, making the file easy to insert into C program code. XBM data can be stored as a standalone graphics file, or within a C program header file. See also XPM, XWD.

XBM files begin with two to four #define statements in substitution of a header. These identify the image width and height, and optionally, the coordinates of a Hotspot, if one exists.

The image data follows and is more free-form than the other bitmap data formats described in this chapter. It consists of one variable-length static array of pixel values. Each value (in version 11) consists of one byte of data, and therefore represents 8 1-bit pixels. The first pixel (0,0) is represented by the high bit of the first byte in the array. Due to this one-array format, there is nothing in the data that explicitly marks the rows of the bitmap.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XLSX
User Guide > File Formats and Compressions > File Formats > File Formats Reference > XLSX
Full Name | Office Open XML Excel Format
Format ID | ImGearFormats.XLSX
File Extension(s) | *.xlsx
Data Type | Vector Image
Data Encoding | Zipped XML Package
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | .NET, .NET64
XLSX format requires ImageGear.Formats.Office Namespace.

ImageGear Supported Versions

  • ECMA-376, Second Edition

ImageGear Supported Features

  • Autodetection
  • Single page file reading
  • Multiple page file reading

ImageGear Read Support

  • XLSX files conformed to ECMA-376, Second Edition Specification.

Please use ImGearFileFormats.LoadDocument to load Excel files. The ImGearFileFormats.LoadPage is not supported for Excel documents.

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

Please see Using ImageGear.Formats.Office Namespace.

Please see the ImageGear.Formats.Office Namespace.


XPM
User Guide > File Formats and Compressions > File Formats > File Formats Reference > XPM
Full Name | XPM (X PixMap)
Format ID | ImGearFormats.XPM
File Extension(s) | *.xpm
Data Type | Raster Image
Data Encoding | ASCII (in C language syntax)
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 3.2g, April 1993

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp

ImageGear Filter Control Parameters

None

Comments

The XPM format was created as an extended version of the XBM file format. It is the informal standard for storing X Window pixmap data, including Hotspot information for cursor bitmaps. The image data is stored in ASCII text characters that are formatted as a standard C array of character strings. It is intended to be human-readable, is readily inserted into C/C++ program code, and can contain any number of comment lines. It therefore does not support a native compression scheme. If compacting is desired, an external compression program may be used. See also XBM, XWD.

All XPM files begin with a C language comment line containing "XPM". Following this are three sections of data: values, colors, and pixels, and an optional fourth section: extensions. The "values" section is the equivalent of the header structure typically found in a graphics file. It gives the size of the pixmap, as well as its number of colors, characters per pixel, the location of the Hotspot (if any), and an indicator of whether the file contains an extension section. Each section is set off with a comment-line title.

The colors section contains codes for the pixmap data characters. All pixels that make up the pixmap are assigned to one or more ASCII characters and one or more colors. (e.g. the character "X" may be assigned to the color red). There are several different conventions for identifying a color. If the string "None" appears as the color to be applied to a specific character, the character(s) symbolizes a transparent pixel.

The "pixels" section contains the bitmap data that appear as an array of character strings, where one row of bitmap data is represented by one array element. Each row is a group of characters set off by quotation marks. Each character is defined in the previous "colors" section.

If indicated by the values section, an extension section appears. It can contain one or more subsections that conform to one of two syntactical formats. An "XPMENDEXT" marker is always used to mark the end of the extension section.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XPS
User Guide > File Formats and Compressions > File Formats > File Formats Reference > XPS
Full Name | XPS (XML Paper Specification)
Format ID | ImGearFormats.XPS
File Extension(s) | *.xps
Data Type | Vector Image
Data Encoding | Binary
Multi-Page Support | Yes
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | .NET, .NET64

ImageGear Supported Versions

  • XPS v. 1.0

ImageGear Supported Features

  • Autodetection
  • Single/multiple page file reading
  • Single/multiple page file writing

ImageGear Read Support

  • XPS files conformed to XML Paper Specification v. 1.0

ImageGear Write Support

  • Raster:
    • Grayscale: 1, 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGBA: 32, 64 bpp;
    • RGBPA: 32, 64 bpp;
    • CMYK: 32 bpp;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ResolutionX | int | 96 | Any integer | This parameter specifies the horizontal resolution, in dots-per-inch, during the XPS document conversion into a raster image. The greater this value, the higher the quality of the raster image after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY | int | 96 | Any integer | This parameter specifies the vertical resolution, in dots-per-inch, during the XPS document conversion into a raster image. The greater this value, the higher the quality of the raster image after rasterization. The DIB of the output raster image has this value as an Y resolution.

Non-Image Data Structure

The XML Paper Specification file format has different nonimage data that can be stored in a package as XML or as resources. The XML Paper Specification metadata design allows reading and writing the following nonimage data (the same as in System.IO.Packaging.PackageProperties ; all are strings):

Tag Name | Tag ID | Description
Category | ImGearXPSTagIDs.CATEGORY | The category of the content that is contained in the file.
ContentStatus | ImGearXPSTagIDs.CONTENT_STATUS | Example ContentStatus values include "Draft", "Reviewed", and "Final".
ContentType | ImGearXPSTagIDs.CONTENT_TYPE | Example ContentType values include "Whitepaper", "Security Bulletin", and "Exam".
Created | ImGearXPSTagIDs.CREATED | The date and time the file was initially created.
Creator | ImGearXPSTagIDs.CREATOR | The individual or entity that created the file and its content.
Description | ImGearXPSTagIDs.DESCRIPTION | The Description may include, but is not limited to: an abstract, table of contents, reference to a graphical representation of content, or a free-text account of the content.
Identifier | ImGearXPSTagIDs.IDENTIFIER | A value that unambiguously identifies the file and its content.
Keywords | ImGearXPSTagIDs.KEYWORDS | A delimited set of keywords to support searching and indexing the Package and content.The Keywords property typically contains a list of terms that are not available elsewhere in file metadata.
Language | ImGearXPSTagIDs.LANGUAGE | A value that identifies the file content language.
LastModifiedBy | ImGearXPSTagIDs.LAST_MODIFIED_BY | The user who last modified the file content.
LastPrinted | ImGearXPSTagIDs.LAST_PRINTED | The date and time the file content was last printed.
Modified | ImGearXPSTagIDs.MODIFIED | The date and time the file was last changed.
Revision | ImGearXPSTagIDs.REVISION | The revision number of the file. The Revision property indicates the number of changed saves or revisions. The application is responsible for updating the Revision property value after each revision.
Subject | ImGearXPSTagIDs.SUBJECT | The topic of the file content.
Title | ImGearXPSTagIDs.TITLE | The name given to the file and its content.
Version | ImGearXPSTagIDs.VERSION | The version number of the file.

Comments

The XPS Document format represents a set of related pages with a fixed layout, which are organized as one or more documents, in the traditional meaning of the word. A file that implements this format includes everything necessary to fully render those documents on a display device or physical medium (for example, paper). This includes all resources, such as fonts and images, that might be required to render individual page markings.

In addition, the format includes optional components that build on the minimal set of components required to render a set of pages. This includes the ability to specify print job control instructions, to organize the minimal page markings into larger semantic blocks, such as paragraphs, and to physically rearrange the contents of the format for easy consumption in a streaming manner, among others.

The XPS format supports See HD Photo. images natively for raster images.

The XPS format concept is similar to Adobe PDF. It is a fixed-layout document format designed to preserve document fidelity, so that documents look the same and as they are intended on any device. While Adobe PDF is based on PostScript the XPS format is based on XML. Adobe PDF, however, includes some dynamic capabilities not supported by the XPS format, and cannot be fully replaced by XPS.

Finally, the XPS Document format implements the common package features, specified by the Open Packaging Conventions specification, that support digital signatures and core properties. An XPS file is a ZIP archive conforming to the Open Packaging Convention.

The XPS format is intended as the replacement for the EMF print spooler format. The format serves as the page description language for printers. For printers supporting XPS, this eliminates an intermediate conversion to a printer-specific language, increasing the reliability and fidelity of the printed output.


XWD
User Guide > File Formats and Compressions > File Formats > File Formats Reference > XWD
Full Name | XWD (X Window Dump)
Format ID | ImGearFormats.XWD
File Extension(s) | *.xwd, *.wd (for Unix)
Data Type | Raster Image
Data Encoding | Binary
Multi-Page Support | No
Alpha Channel Support | No
Metadata Update Support | No
ImageGear Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

ImageGear Supported Versions

  • Version 7 for X11, June 1987 (X10 grayscale and palette only)

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

An XWD file can contain a representation of the window, the background, or the entire screen display. It has been designed to be a very versatile, device-independent format. See also XBM, XPM.

The general structure of the XWD graphics format begins with a long header, that is sometimes followed by a palette and contains the bitmap data. The header contains integer data and stores the header size, the XWD version, the size and location of the bitmap, the window size, location, and border width. A ByteOrder field indicates whether the bytes are stored in big-endian or little-endian order.

In the interest of making this format device-independent, the XWD supports six "visual classes" and three image formats. The visual class code is stored in the visual_class field of the header, and represents the following categories:

  • Static Gray, for most monochrome screens and using a fixed device-dependent color map;
  • GrayScale, for monochrome screens and using a software-supplied palette;
  • StaticColor, which uses a fixed device-dependent palette;
  • Pseudocolor, which uses a software-supplied palette and is intended for VGA screens;
  • TrueColor, with fixed device-dependent mapping of RGB values to screen colors;
  • DirectColor, with software-supplied mapping of RGB values to screen values.

The image-format categories, whose codes are stored in the pixmap_format field of the header, are called XYBitmap (1-bit), XYPixmap (single plane), and ZPixmap (two or more planes).

Where the value of pixmap_format indicates GrayScale, PseudoColor or DirectColor, a palette follows the header.

The image data is the last structure in the file. The bytes are stored in rows with groupings called "units", whose lengths are determined by the bitmap_unit field of the header.

If the pixmap_format field is 1, indicating an XYPixmap, there are multiple representations of the bitmap data, one for each color plane, where the first bitmap represents the highest bit of the data; the second bitmap represents the second-highest bit, and so on. An image with a bit depth of 4 yields a file with four bitmaps.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


Metadata Structures
User Guide > File Formats and Compressions > File Formats > Metadata Structures

This section provides you with the detailed information about the following structures of supported by ImageGear for .NET metadata:

  • Metadata Structures
    • Camera RAW Metadata Structure
    • CIFF Metadata Structure
    • DICOM Metadata Structure
    • EXIF Metadata Structure
    • GIF Metadata Structure
    • IPTC Metadata Structure
    • JPEG Metadata Structure
    • JPEG 2000 Metadata Structure
    • JPX Metadata Structure
    • Photoshop Image Resource Metadata Structure
    • PNG Metadata Structure
    • TIFF Metadata Structure
    • XMP Metadata Structure


Camera RAW Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > Camera RAW Metadata Structure

Camera Raw image metadata structure consists of three sections, which are represented by sub-trees:
  • Common Section
  • Format-Specific Level
  • Statistics

Common Section

The Common sub-tree contains values that are common or useful for all raw files.

All values in the Common sub-tree have Type = VALUE_ITEM and are Read Only.

Name | Id | Native Type | Value count | Description
ImageWidth | ImGearDCRAWTagIDs.IMAGEWIDTH | UINT32 | 1 | Image width after that masked pixels were trimmed out
ImageHeight | ImGearDCRAWTagIDs.IMAGEHEIGHT | UINT32 | 1 | Image height after that masked pixels were trimmed out
BitsPerSample | ImGearDCRAWTagIDs.BITSPERSAMPLE | UINT32 | 1..3 | Bits per sample in the original raw image (before reconstruction)
PhotometricInterpretation | ImGearDCRAWTagIDs.PHOTOMETRICINTERPRETATION | UINT32 | 1 | Photometric interpretation of the original raw image
RawLeft | ImGearDCRAWTagIDs.RAWLEFT | UINT32 | 1 | X coordinate of first column of non-masked pixels
RawTop | ImGearDCRAWTagIDs.RAWTOP | UINT32 | 1 | Y coordinate of first row of non-masked pixels
RawWidth | ImGearDCRAWTagIDs.RAWWIDTH | UINT32 | 1 | Raw Image Width, including masked pixels
RawHeight | ImGearDCRAWTagIDs.RAWHEIGHT | UINT32 | 1 | Raw Image Height, including masked pixels
ColorPlanes | ImGearDCRAWTagIDs.COLORPLANES | UINT32 | 1 | Number of colors in the CFA pattern
SamplesPerPixel | ImGearDCRAWTagIDs.SAMPLESPERPIXEL | UINT32 | 1 | Number of samples per pixel in the original image, before reconstruction
Make | ImGearDCRAWTagIDs.MAKE | STRING | 1 | Name of the camera manufacturer
Model | ImGearDCRAWTagIDs.MODEL | STRING | 1 | Name of the camera model
UniqueCameraModel | ImGearDCRAWTagIDs.UNIQUECAMERAMODEL | STRING | 1 | Unique, non-localized name for the camera model that created the image in the raw file.
TimeStamp | ImGearDCRAWTagIDs.TIMESTAMP | STRING | 1 | Time stamp
CFARepeatPatternDim | ImGearDCRAWTagIDs.CFAREPEATPATTERNDIM | UINT16 | 2 | This tag encodes the number of pixels horizontally and vertically that are needed to uniquely define the repeat pattern of the color filter array.
CFAPattern | ImGearDCRAWTagIDs.CFAPATTERN | INT8 | CFARepeatPatternDim[0] * CFARepeatPatternDim[1] | This tag encodes the actual color filter array geometric pattern of the image sensor used to capture the single sensor color image.
AsShotNeutral | ImGearDCRAWTagIDs.ASSHOTNEUTRAL | RATIONAL_INT32 | ColorPlanes | Specifies the selected white balance at time of capture, encoded as the coordinates of a perfectly neutral color in linear reference space values.
WhiteLevel | ImGearDCRAWTagIDs.WHITELEVEL | RATIONAL_INT32 | 1 | Image pixel value that corresponds to fully saturated encoding level.
CalibrationIlluminant1 | ImGearDCRAWTagIDs.CALIBRATIONILLUMINANT1 | UINT16 | 1 | The illuminant used for ColorMatrix1 color conversion matrix. Allowed values are the same as allowed values for LightSource EXIF tag (see Exif specification).
CalibrationIlluminant2 | ImGearDCRAWTagIDs.CALIBRATIONILLUMINANT1 | UINT16 | 1 | The illuminant used for ColorMatrix2 color conversion matrix. Allowed values are the same as allowed values for LightSource EXIF tag (see Exif specification).
ColorMatrix1 | ImGearDCRAWTagIDs.COLORMATRIX1 | RATIONAL_INT32 | ColorPlanes * 3 | Conversion matrix from XYZ to camera color space, for illuminant specified by CalibrationIlluminant1 tag. Matrix is stored in row scan order.
ColorMatrix2 | ImGearDCRAWTagIDs.COLORMATRIX2 | RATIONAL_INT32 | ColorPlanes * 3 | Conversion matrix from XYZ to camera color space, for illuminant specified by CalibrationIlluminant2 tag. Matrix is stored in row scan order.
BaselineExposure | ImGearDCRAWTagIDs.BASELINEEXPOSURE | RATIONAL_INT32 | 1 | Specifies baseline exposure of the camera, in EV units. Application may use this value to adjust exposure compensation for particular camera model.

Format-Specific Level

This level includes format-specific metadata that is found in the image (CIFF, EXIF, or TIFF). See corresponding sections for structure of metadata for these formats:

  • CIFF Non-Image Data Structure
  • EXIF Non-Image Data Structure
  • TIFF Non-Image Data Structure

Statistics

This section contains data that is collected during image loading, rather than obtained from image's header or metadata. ImGearFileFormats.LoadPage creates this section, but ImGearFileFormats.LoadPageHeader does not, because it does not load pixel data.

Currently, the Statistics section contains image Black Level information.

Black Level specifies pixel intensity, caused by heat rather than by light. Even in absolute darkness, camera sensors report non-zero pixel intensities. Black Level should be subtracted from raw image pixel intensities in the beginning of the processing cycle. If this is not done, the image may look pale or have an unwanted tint.

In order to collect Black Level information, many digital cameras expose only the central part of the sensor to the light, and leave edges of the sensor obscured. Intensities obtained from this obscured area can be averaged to calculate Black Level.

BlackLevel information is represented as a two dimensional array, containing averaged black level values for each element of a color filter array cell.

The following tags can be present in the Statistics section:

Name | ID | Native Type | Value Count | Description
BlackLevelRepeatDim | ImGearDCRAWTagIDs.BLACKLEVELREPEATDIM | UINT16 | 2 | This tag specifies repeat pattern size for the "BlackLevel" tag.
BlackLevel | ImGearDCRAWTagIDs.BLACKLEVEL | UINT32 | BlackLevelRepeatDim[0] * BlackLevelRepeatDim[1] | This tag specifies the image Black Level.


CIFF Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > CIFF Metadata Structure

CIFF metadata uses multiple nested IFDs, structured as a tree.

Brief information on CIFF metadata levels is provided in the set of tables below:
  • CIFF Level
  • ImageProps Level
  • ImageInfo Level
  • ImageDescription Level
  • CameraObject Level
  • ShootingRecord Level
  • MeasuredInfo Level
  • ExifInformation Level
  • CameraSpecification Level
  • FocalLength Level
  • CanonShotInfo Level
  • CanonCameraSettings Level
  • SensorInfo Level
  • CanonCustomFunctions Level
  • CanonPictureInfo Level

CIFF Level

Name | Id | Type
ImageProps level | ImGearCIFFTagIDs.IMAGE_PROPS | Tree
CIFF root tags | <Tag ID> | Leaf

ImageProps Level

Name | Id | Type
ImageInfo level | ImGearCIFFTagIDs.IMAGE_INFO | Tree
ImageDescription level | ImGearCIFFTagIDs.IMAGE_DESCRIPTION | Tree
CameraObject level | ImGearCIFFTagIDs.CAMERA_OBJECT | Tree
ShootingRecord level | ImGearCIFFTagIDs.SHOOTING_RECORD | Tree
MeasuredInfo level | ImGearCIFFTagIDs.MEASURED_INFO | Tree
ExifInformation level | ImGearCIFFTagIDs.EXIF_INFORMATION | Tree
ImageProps tags | <Tag ID> | Leaf

ImageInfo Level

Name | Id | Type
ImageInfo tags | <Tag ID> | Leaf

ImageDescription Level

Name | Id | Type
ImageDescription tags | <Tag ID> | Leaf

CameraObject Level

Name | Id | Type
CameraSpecification level | ImGearCIFFTagIDs.CAMERA_SPECIFICATION | Tree
CameraObject tags | <Tag ID> | Leaf

ShootingRecord Level

Name | Id | Type
ShootingRecord tags | <Tag ID> | Leaf

MeasuredInfo Level

Name | Id | Type
MeasuredInfo tags | <Tag ID> | Leaf

ExifInformation Level

Name | Id | Type
FocalLength level | ImGearCIFFTagIDs.FOCAL_LENGTH | Tree
CanonShotInfo level | ImGearCIFFTagIDs.CANON_SHOT_INFO | Tree
CanonCameraSettings level | ImGearCIFFTagIDs.CANON_CAMERA_SETTINGS | Tree
SensorInfo level | ImGearCIFFTagIDs.SENSOR_INFO | Tree
CanonCustomFunctions level | ImGearCIFFTagIDs.CANON_CUSTOM_FUNCTIONS | Tree
CanonPictureInfo level | ImGearCIFFTagIDs.CANON_PICTURE_INFO | Tree
ExifInformation tags | <Tag ID> | Leaf

CameraSpecification Level

Name | Id | Type
CameraSpecification tags | <Tag ID> | Leaf

FocalLength Level

Name | Id | Type
FocalLength tags | <Tag ID> | Leaf

CanonShotInfo Level

Name | Id | Type
CanonShotInfo tags | <Tag ID> | Leaf

CanonCameraSettings Level

Name | Id | Type
CanonCameraSettings tags | <Tag ID> | Leaf

SensorInfo Level

Name | Id | Type
SensorInfo tags | <Tag ID> | Leaf

CanonCustomFunctions Level

Name | Id | Type
CanonCustomFunctions tags | <Tag ID> | Leaf

CanonPictureInfo Level

Name | Id | Type
CanonPictureInfo tags | <Tag ID> | Leaf


DICOM Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > DICOM Metadata Structure

DICOM files contain one header and zero, one, or several image pages. Image header applies to all pages in the image. ImageGear.Net loads the same metadata tree for each page in the image, and attaches this tree to the corresponding page. ImageGear for .NET does not put any tags to document level metadata for DICOM images.

This section provides information about the following:
  • DICOM Metadata Root Level
  • MetaInfoHeader Level
  • DataSet Level
  • Sequence Level
  • Item Level

DICOM Metadata Root Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
Preamble | Preamble | Leaf | Byte[] |  | 128 | No
MetaInfoHeader | MetaInfoHeader | Tree |  |  |  |
DataSet | DataSet | Tree |  |  |  |

MetaInfoHeader Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |

DataSet may contain subtrees, corresponding to DICOM tags that have "Sequence" (SQ) type. Sequences can non contain normal tags (leafs). Instead, each Sequence contains one or more "Items". Items can contain normal tags including Sequences. All items within one Sequence must have the same set of tags, but tag values can be different.

DataSet Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |
... |  |  |  |  |  |
<SQ tag name> | <SQ tag id> | Tree |  |  |  |
... |  |  |  |  |  |

Sequence Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
Item | Item | Tree |  |  |  |
... |  |  |  |  |  |

Item Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |
... |  |  |  |  |  |
<SQ tag name> | <SQ tag id> | Tree |  |  |  |
... |  |  |  |  |  |

When ImageGear saves images, it overwrites the following tags:

Id | Location | Type
FileMetaInformationVersion | MetaInfoHeader | Leaf
TransferSyntaxUID | MetaInfoHeader | Leaf
SamplesPerPixel | DataSet | Leaf
PhotometricInterpretation | DataSet | Leaf
Rows | DataSet | Leaf
Columns | DataSet | Leaf
BitsAllocated | DataSet | Leaf
BitsStored | DataSet | Leaf
HighBit | DataSet | Leaf
PixelRepresentation | DataSet | Leaf
PlanarConfiguration | DataSet | Leaf
Red Palette Color Look Up Table Descriptor | DataSet | Leaf
Green Palette Color Look Up Table Descriptor | DataSet | Leaf
Blue Palette Color Look Up Table Descriptor | DataSet | Leaf
Red Palette Color Look Up Table Data | DataSet | Leaf
Green Palette Color Look Up Table Data | DataSet | Leaf
Blue Palette Color Look Up Table Data | DataSet | Leaf
PixelData | DataSet | Leaf


EXIF Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > EXIF Metadata Structure

ImageGear for .NET processes EXIF as a metadata format, rather than as a separate image file format.

This section provides information about the following:
  • EXIF Level Metadata
  • EXIF GPS Level Metadata
  • EXIF Interoperability Level Metadata
  • Description of Tags Used in EXIF

EXIF Level Metadata

EXIF level metadata uses the following structure.

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF subIFD tags> | <EXIF subIFD tag ids> |  |  |  |  |
"Interoperability" | ImGearMetadataFormats.INTEROPERABILITYIFD | Tree |  |  |  |
"GPS" | ImGearMetadataFormats.INTEROPERABILITYIFD | Tree |  |  |  |

Interoperability and GPS IFDs are optional.

See Exif subIFD tags below for the list of Exif subIFD tag names and Ids.

EXIF GPS Level Metadata

EXIF GPS level metadata uses the following structure:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF GPS tags> | <EXIF GPS tag ids> |  |  |  |  |

See GPS subIFD tags below for the list of EXIF GPS tag names and Ids.

EXIF Interoperability Level Metadata

EXIF Interoperability level metadata uses the following structure:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF Interoperability tags> | <EXIF Interoperability tag ids> |  |  |  |  |

See Interoperability subIFD tags below for the list of EXIF Interoperability tag names and Ids.

Description of Tags Used in EXIF

The following types of EXIF tags are described below:
  • Exif subIFD Tags
  • GPS subIFD Tags
  • Interoperability subIFD Tags

Exif subIFD Tags

Item Name | Item Id | Ignored on save
"ExposureTime" | 33434 | FALSE
"Fnumber" | 33437 | FALSE
"ExposureProgram" | 34850 | FALSE
"SpectralSensitivity" | 34852 | FALSE
"ISOSpeedRatings" | 34855 | FALSE
"OECF" | 34856 | FALSE
"ExifVersion" | 36864 | FALSE
"DateTimeOriginal" | 36867 | FALSE
"DateTimeDigitized" | 36868 | FALSE
"ComponentsConfiguration" | 37121 | FALSE
"CompressedBitsPerPixel" | 37122 | FALSE
"ShutterSpeedValue" | 37377 | FALSE
"ApertureValue" | 37378 | FALSE
"BrightnessValue" | 37379 | FALSE
"ExposureBiasValue" | 37380 | FALSE
"MaxApertureValue" | 37381 | FALSE
"SubjectDistance" | 37382 | FALSE
"MeteringMode" | 37383 | FALSE
"LightSource" | 37384 | FALSE
"Flash" | 37385 | FALSE
"FocalLength" | 37386 | FALSE
"SubjectArea" | 37396 | FALSE
"MakerNote" | 37500 | FALSE
"UserComment" | 37510 | FALSE
"SubSecTime" | 37520 | FALSE
"SubSecTimeOriginal" | 37521 | FALSE
"SubSecTimeDigitized" | 37522 | FALSE
"FlashPixVersion" | 40960 | FALSE
"ColorSpace" | 40961 | FALSE
"PixelXDimension" | 40962 | TRUE
"PixelYDimension" | 40963 | TRUE
"RelatedSoundFile" | 40964 | FALSE
"InteroperabilityIFDPointer" | 40965 | TRUE
"FlashEnergy" | 41483 | FALSE
"SpatialFrequencyResponse" | 41484 | FALSE
"FocalPlaneXResolution" | 41486 | FALSE
"FocalPlaneYResolution" | 41487 | FALSE
"FocalPlaneResolutionUnit" | 41488 | FALSE
"SubjectLocation" | 41492 | FALSE
"ExposureIndex" | 41493 | FALSE
"SensingMethod" | 41495 | FALSE
"FileSource" | 41728 | FALSE
"SceneType" | 41729 | FALSE
"CFAPattern" | 41730 | FALSE
"CustomRendered" | 41985 | FALSE
"ExposureMode" | 41986 | FALSE
"WhiteBalance" | 41987 | FALSE
"DigitalZoomRatio" | 41988 | FALSE
"FocalLengthIn35mmFilm" | 41989 | FALSE
"SceneCaptureType" | 41990 | FALSE
"GainControl" | 41991 | FALSE
"Contrast" | 41992 | FALSE
"Saturation" | 41993 | FALSE
"Sharpness" | 41994 | FALSE
"DeviceSettingDescription" | 41995 | FALSE
"SubjectDistanceRange" | 41996 | FALSE
"ImageUniqueID" | 42016 | FALSE

GPS subIFD Tags

Item Name | Item Id | Ignored on save
"GPSVersionID" | 0 | FALSE
"GPSLatitudeRef" | 1 | FALSE
"GPSLatitude" | 2 | FALSE
"GPSLongitudeRef" | 3 | FALSE
"GPSLongitude" | 4 | FALSE
"GPSAltitudeRef" | 5 | FALSE
"GPSAltitude" | 6 | FALSE
"GPSTimeStamp" | 7 | FALSE
"GPSSatellites" | 8 | FALSE
"GPSStatus" | 9 | FALSE
"GPSMeasureMode" | 10 | FALSE
"GPSDOP" | 11 | FALSE
"GPSSpeedRef" | 12 | FALSE
"GPSSpeed" | 13 | FALSE
"GPSTrackRef" | 14 | FALSE
"GPSTrack" | 15 | FALSE
"GPSImgDirectionRef" | 16 | FALSE
"GPSImgDirection" | 17 | FALSE
"GPSMapDatum" | 18 | FALSE
"GPSDestLatitudeRef" | 19 | FALSE
"GPSDestLatitude" | 20 | FALSE
"GPSDestLongitudeRef" | 21 | FALSE
"GPSDestLongitude" | 22 | FALSE
"GPSDestBearingRef" | 23 | FALSE
"GPSDestBearing" | 24 | FALSE
"GPSDestDistanceRef" | 25 | FALSE
"GPSDestDistance" | 26 | FALSE
"GPSProcessingMethod" | 27 | FALSE
"GPSAreaInformation" | 28 | FALSE
"GPSDateStamp" | 29 | FALSE
"GPSDifferential" | 30 | FALSE

Interoperability subIFD Tags

Item Name | Item Id | Read Only
"InteroperabilityIndex " | 1 | FALSE
"InteroperabilityVersion " | 2 | FALSE
"RelatedImageFileFormat" | 4096 | FALSE
"RelatedImageWidth " | 4097 | FALSE
"RelatedImageLength" | 4098 | FALSE


GIF Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > GIF Metadata Structure

GIF file format is complex and has different non-image data that can be stored before and after an image data. The GIF metadata design allows you to read/write any GIF non-image data and prevents from misunderstanding with GIF extensions storing order.

The following metadata are always saved before an image data:

  • GIF Logical Screen Descriptor metadata level
  • GIF Image Descriptor metadata level
  • GIF Global Color Table metadata level
  • GIF Local Color Table metadata level

All other GIF Extensions Metadata are saved before an image data.

ImageGear represents simpler GIF metadata by single metadata items, and more complex metadata by subtrees. Thus, there are two main GIF metadata levels in ImageGear:

  • GIF Metadata Level
  • GIF Extensions Metadata

This section provides information about the following:
  • GIF Metadata Level
  • GIF Header Metadata GIF Metadata Level
  • GIF Header Level
  • GIF Logical Screen Descriptor Metadata GIF Metadata Level
  • GIF Logical Screen Descriptor Level
  • GIF Global Color Table Metadata
  • GIF Image Descriptor Metadata GIF Metadata Level
  • GIF Image Descriptor Level
  • GIF Image Descriptor Fields Level
  • GIF Local Color Table Metadata
  • GIF Extensions Metadata GIF Graphic Control Extension Metadata
  • GIF Metadata Level
  • GIF Graphic Control Extension Level
  • GIF Comment Extension Metadata
  • GIF Application Extension Metadata GIF Metadata Level
  • GIF Application Extension Level
  • GIF Plain Text Extension Metadata GIF Metadata Level
  • GIF Plain Text Extension Level
  • GIF Extensions After Image Metadata GIF Metadata Level
  • GIF Extensions After Image Level

GIF Metadata Level

Name Id Type Value Type Value Value Length Read Only
GIF header level
GIF Logical Screen Descriptor level
GIF Image Descriptor level
optional Global and/or Local Color Tables and

optional GIF Extensions levels (extensions before image)

GIF Header Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GIFHeader" | 0x10 | Tree | 0 | NULL | 0 | TRUE

GIF Header Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"Signature" | 0x101 | Leaf | STRING | "GIF" | 3 | TRUE
"Version" | 0x102 | Leaf | STRING |  | 3 | TRUE

GIF Logical Screen Descriptor Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LogicalScreenDescriptor" | 0x20 | Tree |  |  |  |

GIF Logical Screen Descriptor Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LogicalScreenWidth" | 0x201 | Leaf | UINT16 |  | 1 | FALSE
"LogicalScreenHeight" | 0x202 | Leaf | UINT16 |  | 1 | FALSE
"Fields" | 0x205 | Tree |  |  |  |
"GlobalColorTableFlag" | 0x206 | Leaf | BOOL |  | 1 | FALSE
"ColorResolution" | 0x207 | Leaf | UINT8 |  | 1 | FALSE
"SortFlag" | 0x208 | Leaf | BOOL |  | 1 | FALSE
"GlobalColorTableSize" | 0x209 | Leaf | UINT8 |  | 1 | FALSE
"Fields" | 0x205 | Tree |  |  |  |
"BackgroundColorIndex" | 0x203 | Leaf | UINT8 |  |  | FALSE
"PixelAspectRatio" | 0x204 | Leaf | UINT8 |  |  | FALSE

GIF Global Color Table Metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GlobalColorTable" | 0x30 | Leaf | RAW_DATA |  | Variable | TRUE

GIF Image Descriptor Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ImageDescriptor" | 0x2C | Tree |  |  |  |

GIF Image Descriptor Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ImageLeftPosition" | 0x2C1 | Leaf | UINT16 |  | 1 | FALSE
"ImageTopPosition" | 0x2C2 | Leaf | UINT16 |  | 1 | FALSE
"ImageWidth" | 0x2C3 | Leaf |  |  | 1 | FALSE
"ImageHeight" | 0x2C4 | Leaf |  |  | 1 | FALSE
"Fields" | 0x2C5 | Tree |  |  |  |

GIF Image Descriptor Fields Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LocalColorTableFlag" | 0x2C6 | Leaf | BOOL |  | 1 | FALSE
"InterlaceFlag" | 0x2C7 | Leaf | BOOL |  | 1 | FALSE
"SortFlag" | 0x2C8 | Leaf | BOOL |  | 1 | FALSE
"LocalColorTableSize" | 0x2C9 | Leaf | UINT8 |  | 1 | FALSE

GIF Local Color Table Metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LocalColorTable" | 0x40 | Leaf | RAW_DATA |  | Variable | TRUE

GIF Extensions Metadata GIF Graphic Control Extension Metadata

GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GraphicControlExtension" | 0xF9 | Tree |  |  |  |

GIF Graphic Control Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"Fields" | 0xF91 | Tree |  |  |  |
"DisposalMethod" | 0xF92 | Leaf | UINT8 |  | 1 | FALSE
"UserInputFlag" | 0xF93 | Leaf | BOOL |  | 1 | FALSE
"TransparentColorFlag" | 0xF94 | Leaf | BOOL |  | 1 | FALSE
"Fields" | 0xF91 | Tree |  |  |  |
"DelayTime" | 0xF95 | Leaf | UINT16 |  | 1 | FALSE
"TransparentColorIndex" | 0xF96 | Leaf | UINT8 |  | 1 | FALSE

GIF Comment Extension Metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"CommentExtension" | 0xFE | Leaf | STRING |  | Variable | TRUE

GIF Application Extension Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ApplicationExtension" | 0xFF | Tree |  |  |  |

GIF Application Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ApplicationIdentifier" | 0xFF1 | Leaf | STRING |  | 8 | FALSE
"Appl.AuthenticationCode" | 0xFF2 | Leaf | UINT8 |  | 4 | FALSE
"ApplicationData" | 0xFF3 | Leaf | RAW_DATA |  | Variable | FALSE

GIF Plain Text Extension Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"PlainTextExtension" | 0x01 | Tree | 0 | NULL | 0 | TRUE

GIF Plain Text Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"TextGridLeftPosition" | 0x11 | Leaf | UINT16 |  | 1 | FALSE
"TextGridTopPosition" | 0x12 | Leaf | UINT16 |  | 1 | FALSE
"TextGridWidth" | 0x13 | Leaf | UINT16 |  | 1 | FALSE
"TextGridHeight" | 0x14 | Leaf | UINT16 |  | 1 | FALSE
"CharacterCellWidth" | 0x15 | Leaf | UINT8 |  | 1 | FALSE
"CharacterCellHeight" | 0x16 | Leaf | UINT8 |  | 1 | FALSE
"TextForegroundColorIndex" | 0x17 | Leaf | UINT8 |  | 1 | FALSE
"TextBackgroundColorIndex" | 0x18 | Leaf | UINT8 |  | 1 | FALSE
"PlainTextData" | 0x19 | Leaf | STRING |  | Variable | FALSE

GIF Extensions After Image Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"AfterImageExtensions" | 0xFFF | Tree |  |  |  |

GIF Extensions After Image Level

Name Id Type Value Type Value Value Length Read Only
One or more GIF extension levels


IPTC Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > IPTC Metadata Structure

International Press and Telecommunications Council Standards (IPTC) have been created for exchanging different type of information.

IPTC is a metadata format rather than a image file format. It can be stored within JPEG and TIFF image files as Adobe Photoshop Image Resource (see Photoshop Image Resource Metadata Structure). In TIFF files the IPTC data is stored in TIFF tag with Id = 34377 (see TIFF Non-Image Data Structure for metadata structure of the tag). In JPEG files, the IPTC data is stored in Photoshop Image Resource APP13 marker segment (see JPEG Non-Image Data Structure).

ImageGear IPTC metadata structure is framed in two levels:

  • IPTC level containing all IPTC data
  • Record level containing value items of a record

IPTC Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
Record level 1 | <Record#> | Tree |  |  |  |
Record level n | <Record#> | Tree |  |  |  |

The <Record#> tag is the primary identifier of IPTC record. Its value is the number of appropriate IPTC record described in IPTC - NAA IIM4 specification. Record levels must follow in numerical order within IPTC level.

Record Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
Dataset value item | <DataSet ID> | Leaf | <Value Type> | <Data> | <Item Count> | FALSE
Dataset value item | <DataSet ID> | Leaf | <Value Type> | <Data> | <Item Count> | FALSE

The available <Dataset name>, <Dataset Id>, <Item Count>, and <Value Type> values are described below for each IPTC record according to IPTC-NAA IIM4 specification. Dataset value item can follow in any order within appropriate record level.

In the tables below, the last column lists the maximum item count for non-string types, and string length for string types. Item count for string types in IPTC metadata is always 1.

  • Dataset Value Items Description for IPTC Envelope Record (Record #1)
  • Dataset Value Items Description for IPTC Application Record (Record #2)
  • Dataset Value Items Description for IPTC Digital News Photo Parameter Record (Record #3)
  • Dataset Value Items Description for IPTC Pre-Object Descriptor Record (Record #7)
  • Dataset Value Items Description for IPTC Object Record (Record #8)
  • Dataset Value Items Description for IPTC Post-Object Descriptor Record (Record #9)

Dataset Value Items Description for IPTC Envelope Record (Record #1)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "ModelVersion" | UINT16 | 1
5 | "Destination" | STRING | 1024
20 | "FileFormat" | UINT16 | 1
22 | "FileFormatVersion" | UINT16 | 1
30 | "ServiceIdentifier" | STRING | 10
40 | "EnvelopeNumber" | STRING | 8
50 | "ProductID" | STRING | 32
60 | "EnvelopePriority" | STRING | 1
70 | "DateSent" | STRING | 8
80 | "TimeSent" | STRING | 11
90 | "CodedCharacterSet" | STRING | 32
100 | "UNO" | STRING | 80
120 | "ARMIdentifier" | UINT16 | 1
122 | "ARMVersion" | UINT16 | 1

Dataset Value Items Description for IPTC Application Record (Record #2)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "RecordVersion" | UINT16 | 1
3 | "ObjectTypeReference" | STRING | 67
4 | "ObjectAttributeReference" | STRING | 68
5 | "ObjectName" | STRING | 64
7 | "EditStatus" | STRING | 64
8 | "EditorialUpdate" | STRING | 2
10 | "Urgency" | STRING | 1
12 | "SubjectReference" | STRING | 236
15 | "Category" | STRING | 3
20 | "SupplementalCategory" | STRING | 32
22 | "FixtureIdentifier" | STRING | 32
25 | "Keywords" | STRING | 64
26 | "ContentLocationCode" | STRING | 3
27 | "ContentLocationName" | STRING | 64
30 | "ReleaseDate" | STRING | 8
35 | "ReleaseTime" | STRING | 11
37 | "ExpirationDate" | STRING | 8
38 | "ExpirationTime" | STRING | 11
40 | "SpecialInstructions" | STRING | 256
42 | "ActionAdvised" | STRING | 2
45 | "ReferenceService" | STRING | 10
47 | "ReferenceDate" | STRING | 8
50 | "ReferenceNumber" | STRING | 8
55 | "DateCreated" | STRING | 8
60 | "TimeCreated" | STRING | 11
62 | "DigitalCreationDate" | STRING | 8
63 | "DigitalCreationTime" | STRING | 11
65 | "OriginatingProgram" | STRING | 32
70 | "ProgramVersion" | STRING | 10
75 | "ObjectCycle" | STRING | 1
80 | "By-line" | STRING | 32
85 | "By-lineTitle" | STRING | 32
90 | "City" | STRING | 32
92 | "Sublocation" | STRING | 32
95 | "Province/State" | STRING | 32
100 | "Country/ PrimaryLocationCode" | STRING | 3
101 | "Country/ PrimaryLocationName" | STRING | 64
103 | "OriginalTransmission Reference" | STRING | 32
105 | "Headline" | STRING | 256
110 | "Credit" | STRING | 32
115 | "Source" | STRING | 32
116 | "CopyrightNotice" | STRING | 128
118 | "Contact" | STRING | 128
120 | "Caption/Abstract" | STRING | 2000
122 | "Writer/Editor" | STRING | 32
125 | "RasterizedCaption" | UINT8 | 7360
130 | "ImageType" | STRING | 2
131 | "ImageOrientation" | STRING | 1
135 | "LanguageIdentifier" | STRING | 3
150 | "AudioType" | STRING | 2
151 | "AudioSamplingRate" | STRING | 6
152 | "AudioSamplingResolution" | STRING | 2
153 | "AudioDuration" | STRING | 6
154 | "AudioOutcue" | STRING | 64
200 | "ObjectDataPreview FileFormat" | UINT16 | 1
201 | "ObjectDataPreview FileFormatVersion" | UINT16 | 1
202 | "ObjectDataPreviewData" | UINT8 | Undefined

Dataset Value Items Description for IPTC Digital News Photo Parameter Record (Record #3)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "RecordVersion" | UINT16 | 1
10 | "PictureNumber" | RAW_DATA | 16
20 | "PixelsPerLine" | UINT16 | 1
30 | "NumberOfLine" | UINT16 | 1
40 | "PixelSizeInScanningDirection" | UINT16 | 1
50 | "PixelSizePerpendicularTo ScanningDirection" | UINT16 | 1
55 | "SupplementType" | UINT8 | 1
60 | "ColourRepresentation" | UINT8 | 2
64 | "InterchangeColourSpace" | UINT8 | 1
65 | "ColourSequence" | UINT8 | 4
66 | "ICCInputColourProfile" | RAW_DATA | Undefined
70 | "ColourCalibrationMatrixTable" | RAW_DATA | Undefined
80 | "LookupTable" | RAW_DATA | 131072
84 | "NumberOfIndexEntries" | UINT16 | 1
85 | "ColourPalette" | RAW_DATA | Undefined
86 | "NumberOfBitsPerSample" | UINT8 | 1
90 | "SamplingStructure" | UINT8 | 1
100 | "ScanningDirection" | UINT8 | 1
102 | "ImageRotation" | UINT8 | 1
110 | "DataCompressionMethod" | RAW_DATA | 4
120 | "QuantisationMethod" | UINT8 | 1
125 | "EndPoints" | UINT8 | Undefined
130 | "ExcursionTolerance" | UINT8 | 1
135 | "BitsPerComponent" | UINT8 | Undefined
140 | "MaximumDensityRange" | UINT16 | 1
145 | "GammaCompensatedValue" | UINT16 | 1

Dataset Value Items Description for IPTC Pre-Object Descriptor Record (Record #7)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "SizeMode" | UINT8 | 1
20 | "MaxSubfileSize" | UINT8 or UINT16 or UINT32 | 1
90 | "ObjectDataSizeAnnounced" | UINT8 or UINT16 or UINT32 | 1
95 | "MaximumObjectDataSize" | UINT8 or UINT16 or UINT32 | 1

Dataset Value Items Description for IPTC Object Record (Record #8)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "Subfile" | RAW_DATA | Undefined

Dataset Value Items Description for IPTC Post-Object Descriptor Record (Record #9)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "ConfirmedObjectDataSize" | UINT8 or UINT16 or UINT32 | 1


JPEG Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > JPEG Metadata Structure

JPEG metadata structure is framed in several levels:

  • JPEG Level - contains all JPEG metadata
  • JPEG Marker Segment Levels - contains metadata of each particular JPEG marker segment

JPEG Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"JPEG-JFIF" | ImGearFormats.JPG | Tree |  |  |  |
JPEG marker segment levels

JPEG Marker Segment Levels

The following JPEG marker segments metadata are supported:

  • Frame marker segment level - SOF0, SOF1, SOF2 and SOF3 (read only)
  • Frame component level
  • Scan marker segment level - SOS (read only)
  • Scan component level
  • Define-quantization-table marker segment level - DQT (read only)
  • Define-quantization-table level
  • Define-Huffman-tables marker segment level - DHT (read only)
  • Define-Huffman-table level
  • Comment marker segment level - COM (read/write)
  • Application marker segment level - APP0-APP15 (read/write)
Segment level markers are described in the tables:
  • Frame Marker Segment Level
  • Frame Component Level
  • Scan Marker Segment Level
  • Scan Component Level
  • Define-Quantization-Table Marker Segment Level
  • Define-Quantization-Table Table Level
  • Define-Huffman-Tables Marker Segment Level
  • Define-Huffman-Table Table Level
  • Comment Marker Segment Level
  • Application Marker Segment Level

Frame Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Precision" | ImGearJPEGTagIDs. FRAME_PRECISION | Leaf | UINT8 |  | 1 | TRUE
"Lines" | ImGearJPEGTagIDs. FRAME_LINES | Leaf | UINT16 |  | 1 | TRUE
"SamplesPerLine" | ImGearJPEGTagIDs. FRAME_SAMPLES_PER_LINE | Leaf | UINT16 |  | 1 | TRUE
"NumberOfComponents" | ImGearJPEGTagIDs. FRAME_NUMBER_OF_COMPONENTS | Leaf | UINT8 | <n> | 1 | TRUE
Frame component level 1 | ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC | Tree |  |  |  |
...
Frame component level <n> | ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC | Tree |  |  |  |

Frame Component Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Identifier" | ImGearJPEGTagIDs. FRAME_COMPONENT_ID | Leaf | UINT | <Component No.> | 1 | TRUE
HVSamplingFactors | ImGearJPEGTagIDs. FRAME_COMPONENT_HV_SAMPLING | Leaf | UINT |  | 1 | TRUE
"QuantizationNumber" | ImGearJPEGTagIDs. FRAME_COMPONENT_QUANT_SELECTOR | Leaf | UINT |  | 1 | TRUE
<Component No.> is frame component identifier of appropriate component.

Scan Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"ComponentNumber" | ImGearJPEGTagIDs. SCAN_COMPONENT_NUMBER | Leaf | UINT8 | <n> | 1 | TRUE
Scan component level 1 | ImGearJPEGTagIDs.SCAN_COMPONENT | Tree |  |  |  |
Scan component level <n> | ImGearJPEGTagIDs.SCAN_COMPONENT | Tree |  |  |  |
"SpectralStart" | ImGearJPEGTagIDs.SCAN_SP_START | Leaf | UINT8 |  | 1 | TRUE
"SpectralEnd" | ImGearJPEGTagIDs.SCAN_SP_END | Leaf | UINT8 |  |  | TRUE
"AH_AL" | ImGearJPEGTagIDs.SCAN_AH_AL | Leaf | UINT8 |  |  | TRUE

Scan Component Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Selector" | ImGearJPEGTagIDs. SCAN_SELECTOR | Leaf | UINT8 |  | 1 | TRUE
"DC_AC" | ImGearJPEGTagIDs. SCAN_DC_AC | Leaf | UINT8 |  | 1 | TRUE

Define-Quantization-Table Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"QuantizationTable" | ImGearJPEGTagIDs.QUANT_TABLE | Tree |  |  |  |
"QuantizationTable" | ImGearJPEGTagIDs.QUANT_TABLE | Tree |  |  |  |

Define-Quantization-Table Table Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Descriptor" | ImGearJPEGTagIDs. QUANT_TABLE_DESCRIPTOR | Leaf | UINT8 |  |  | TRUE
"Elements" | ImGearJPEGTagIDs. QUANT_TABLE_ELEMENTS | Leaf | UINT8 or UINT16 |  |  | TRUE

Define-Huffman-Tables Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"HuffmanTable" | ImGearJPEGTagIDs.HUFFMAN_TABLE | Tree |  |  |  |
"HuffmanTable" | ImGearJPEGTagIDs.HUFFMAN_TABLE | Tree |  |  |  |

Define-Huffman-Table Table Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Descriptor" | ImGearJPEGTagIDs. HUFFMAN_TABLE_DESCRIPTOR | Leaf | UINT8 |  |  | TRUE
"Lengths" | ImGearJPEGTagIDs. HUFFMAN_TABLE_LENGTH | Leaf | UINT8 |  |  | TRUE
"Values" | ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES | Leaf | UINT8 |  |  | TRUE
"Values" | ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES | Leaf | UINT8 |  |  | TRUE

Comment Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Comment" | ImGearJPEGTagIDs. COMMENT | Leaf | STRING |  | <ValueSize> | FALSE

Application Marker Segment Level

There are several application marker segments whose data structure is well known. These segments are parsed and their data are passed in special format.

These marker segments are:

  • JFIF APP0 segment
  • JFIF extension (JFXX) APP0 segment (read only)
  • EXIF APP1 segment
  • Photoshop Image Resource APP13 marker segment - includes some IPTC data and another Photoshop Image Resource metadata structure
  • Other application marker segment levels

JFIF APP0 Segment

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"JFIF_HEADER" | ImGearJPEGTagIDs. JFIF_ID | Leaf | STRING | JFIF | 5 | TRUE
"Version" | ImGearJPEGTagIDs. JFIF_VERSION | Leaf | UINT16 |  | 1 | FALSE
"ResolutionUnits" | ImGearJPEGTagIDs. JFIF_UNITS | Leaf | UINT8 |  | 1 | FALSE
"ResolutionX" | ImGearJPEGTagIDs. JFIF_X_RES | Leaf | UINT16 |  | 1 | FALSE
"ResolutionY" | ImGearJPEGTagIDs. JFIF_Y_RES | Leaf | UINT16 |  | 1 | FALSE
"ThumbnailWidth"18 | ImGearJPEGTagIDs. JFIF_THUMB_WIDTH | Leaf | UINT8 |  | 1 | TRUE
"ThumbnailHeight"19 | ImGearJPEGTagIDs. JFIF_THUMB_HEIGHT | Leaf | UINT8 |  | 1 | TRUE

Photoshop Image Resource APP13 Marker Segment

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"PHOTOSHOP_HEADER" | ImGearJPEGTagIDs. PHOTOSHOP_HEADER | Leaf | STRING | "Photoshop 3.0" | 14 | FALSE
Photoshop Image Resource level 1
...
Photoshop Image Resource level n
For "Photoshop Image Resource" metadata structure see Photoshop Image Resource Metadata Structure Tables.

Other Application Marker Segment Levels

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"DATA" | ImGearJPEGTagIDs. BINARY_DATA | Leaf | RAW_DATA |  | <ValueSize> | FALSE


JPEG 2000 Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > JPEG 2000 Metadata Structure

ImageGear JPEG 2000 format filter allows you to work with non-image data stored in supported file formats. It provides metadata tags that make possible manipulating with such kinds of non-image information:

  • XML & IPR information
  • Alpha channels mapping
  • Format type information
  • Type of compression (lossy or lossless)
The following metadata tags are available to work with JPEG 2000 files:
  • "AlphaMapping"
  • "Alpha1", "Alpha2", "Alpha3", "Alpha4"
  • "XML"
  • "IPR"
  • "Format"
  • "Compression"
  • "Resolution"

"AlphaMapping"

This tag establishes the relationship, if any, between color channels and alpha (and/or pre-multiplied) alpha channels. Each element of array specifies number of alpha channel associated with regular (color) channel. Zero or negative value means absence of alpha mapping for particular color channel. For example:

"AlphaMapping" with {1, 1, 1, -1} as value means that all red, green and blue channels of image are mapped to single (first) alpha channel, which available under 0-index for current image through ImageGear API. {-1, 2, 1, -1} value means availability of two different alpha channels for green and blue channels and absence of alpha channel for red channel.

Additional information about available alpha channels can be accessed through "Alpha1", "Alpha2", "Alpha3" and "Alpha4" tags.

"Alpha1", "Alpha2", "Alpha3", "Alpha4"

Each of these tags represents information about alpha channels. Valid value for each tag is array with three integer elements. First element represents index of codestream (-1 or non-negative value), in which alpha channel is (or "should be" in case of write) resided. Second - index of component in which alpha is stored (-1 or non-negative value). Last element specifies whether alpha is regular (0) or pre-multiplied (1). For example:

"Alpha1" with {0, 3, 0} as value means that first alpha channel is regular and located in fourth component of the first codestream. {1, 0, 1} value represents pre-multiplied alpha in first component of second codestream in JPX layer.

"XML"

This tag serves for getting and setting some specific information written in XML language.

JPEG 2000 format is only able to store XML data. It must be set as a text string.

"IPR"

This tag serves for getting and setting IPR (Intellectual Property Rights) information. The IPR metadata defines metadata to either protect the rights of the owner of the image or provide further information to request permission to use it. It is important for developers and users to properly protect the rights of the owner of the image data.

JPEG 2000 format is only able to store IPR data. It must be set as a text string.

"Format"

This tag serves for getting the format of the JPEG 2000 file. Its possible values are:

  • ImGearJPEG2KType.CODESTREAM = 0
  • ImGearJPEG2KType.FILE_FORMAT = 1

"Compression"

This tag serves for getting a compression type of the JPEG 2000 image. Its possible values are:

  • ImGearJPEG2KCompressions.LOSSY = 0
  • ImGearJPEG2KCompressions.LOSSLESS = 1

JPEG2K sets one of these values depending on the type of the image. This tag is not used in JPEG2K writing.

"Resolution"

This tag serves for getting the resolution information of JPEG 2000 image. It contains four fields of type double that specify resolution values, in pixels per meter:

  • Capture Resolution X
  • Capture Resolution Y
  • Display Resolution X
  • Display Resolution Y

If neither Capture nor Display resolution is present in the image the corresponding fields are set to 0.0


JPX Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > JPX Metadata Structure

ImageGear JPX format filter allows you to work with non-image data stored in supported file formats. It provides metadata tags that make possible manipulating with such kinds of non-image information:

  • XML & IPR information
  • Alpha channels mapping
  • Chroma keys
  • Composition layers
The following metadata tags are available to work with JPX files:
  • "AlphaMapping"
  • "Alpha1", "Alpha2", "Alpha3", "Alpha4"
  • "Chroma"
  • "ComposedLayersQty"
  • "XML"
  • "IPR"
  • "Resolution"

"AlphaMapping"

This tag establishes the relationship, if any, between color channels and alpha (and/or pre-multiplied) alpha channels. Each element of array specifies number of alpha channel associated with regular (color) channel. Zero or negative value means absence of alpha mapping for particular color channel. For example:

"AlphaMapping" with {1, 1, 1, -1} as value means that all red, green and blue channels of image are mapped to single (first) alpha channel, which available under 0-index for current image through ImageGear API. {-1, 2, 1, -1} value means availability of two different alpha channels for green and blue channels and absence of alpha channel for red channel.

Additional information about available alpha channels can be accessed through "Alpha1", "Alpha2", "Alpha3" and "Alpha4" tags.

"Alpha1", "Alpha2", "Alpha3", "Alpha4"

Each of these tags represents information about alpha channels. Valid value for each tag is array with three integer elements. First element represents index of codestream (-1 or non-negative value), in which alpha channel is (or "should be" in case of write) resided. Second - index of component in which alpha is stored (-1 or non-negative value). Last element specifies whether alpha is regular (0) or pre-multiplied (1). For example:

"Alpha1" with {0, 3, 0} as value means that first alpha channel is regular and located in fourth component of the first codestream. {1, 0, 1} value represents pre-multiplied alpha in first component of second codestream in JPX layer.

For JP2 file format value of the first element (code-stream index) is restricted to {-1, 0} set. Only for JPX files it's allowed to store alpha channels in separate code-stream.

"Chroma"

This tag contains an array of values each of which is treated as fully-transparent for a particular channel. Negative value of any element means absence of chroma-key.

"ComposedLayersQty"

This tag specifies the number of composed layers involved into loaded composition. It appears only for images loaded by JPX filter with value of LoadComposition control parameter set to True.

"XML"

This tag serves for getting and setting some specific information written in XML language.

Please note that only JPEG 2000 format is able to store XML data. It must be set as a text string.

"IPR"

This tag serves for getting and setting IPR (Intellectual Property Rights) information. The IPR metadata defines metadata to either protect the rights of the owner of the image or provide further information to request permission to use it. It is important for developers and users to properly protect the rights of the owner of the image data.

Please note that only JPEG 2000 format is able to store IPR data. It must be set as a text string.

"Resolution"

This tag serves for getting the resolution information of JPEG 2000 image. It contains four fields of type double that specify resolution values, in pixels per meter:

  • Capture Resolution X
  • Capture Resolution Y
  • Display Resolution X
  • Display Resolution Y

If neither Capture nor Display resolution is present in the image the corresponding fields are set to 0.0.


Photoshop Image Resource Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > Photoshop Image Resource Metadata Structure

Adobe Photoshop files can contain data which is placed in additional resources blocks. These resources are used to store non-pixel data associated with images. ImageGear reads this data into the metadata blocks which is attached to ImGearDocument and ImGearPage.

Adobe Photoshop metadata structure is framed in several levels:
  • PhotoshopResources Level
  • PhotoShopImageResource Level

PhotoshopResources Level

This level can contain arbitrary number of PhotoshopImageResource subtrees:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
PhotoshopImageResource | <Res. Id> | Tree | N/A | N/A | N/A | N/A
Or in case the data is parsed
ResolutionInfo | ImGearPHOTOSHOPTagIDs.ResolutionInfo | Tree | N/A | N/A | N/A | N/A
AlphaNames | ImGearPHOTOSHOPTagIDs.AlphaNames | Tree | N/A | N/A | N/A | N/A
DisplayInfo | ImGearPHOTOSHOPTagIDs.DisplayInfo | Tree | N/A | N/A | N/A | N/A
Caption | ImGearPHOTOSHOPTagIDs.Caption | Tree | N/A | N/A | N/A | N/A
IPTC | ImGearPHOTOSHOPTagIDs.IPTC | Tree | N/A | N/A | N/A | N/A
Thumbnail | ImGearPHOTOSHOPTagIDs.Thumbnail | Tree | N/A | N/A | N/A | N/A
ICCProfile | ImGearPHOTOSHOPTagIDs.ICCProfile | Tree | N/A | N/A | N/A | N/A
UnicodeAlphaNames | ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames | Tree | N/A | N/A | N/A | N/A
TransparencyIndex | ImGearPHOTOSHOPTagIDs.TransparencyIndex | Tree | N/A | N/A | N/A | N/A
AlphaIdentifiers | ImGearPHOTOSHOPTagIDs.AlphaIdentifiers | Tree | N/A | N/A | N/A | N/A
VersionInfo | ImGearPHOTOSHOPTagIDs.VersionInfo | Tree | N/A | N/A | N/A | N/A

PhotoShopImageResource Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"PhotoshopImageResourceSize" | <Res. Id> | Leaf | UINT16 |  | 1 | True
Resource data
"Data" | ImGearPHOTOSHOPTagID s.SEGMENTDATA | Leaf | RAW_DATA |  |  | False
Or in case the data are parsed (currently it happens only for IPTC data)
"ResolutionInfo" | ImGearPHOTOSHOPTagIDs.ResolutionInfo | Tree | N/A | N/A | N/A | False
"AlphaNames" | ImGearPHOTOSHOPTagIDs.AlphaNames | Tree | N/A | N/A | N/A | False
DisplayInfo" | ImGearPHOTOSHOPTagIDs.DisplayInfo | Tree | N/A | N/A | N/A | False
"Caption" | ImGearPHOTOSHOPTagIDs.Caption | Tree | N/A | N/A | N/A | False
"IPTC" | ImGearPHOTOSHOPTagIDs.IPTC | Tree | N/A | N/A | N/A | False
"Thumbnail" | ImGearPHOTOSHOPTagIDs.Thumbnail | Tree | N/A | N/A | N/A | False
"ICCProfile" | ImGearPHOTOSHOPTagIDs.ICCProfile | Tree | N/A | N/A | N/A | False
"UnicodeAlphaNames" | ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames | Tree | N/A | N/A | N/A | False
"TransparencyIndex" | ImGearPHOTOSHOPTagIDs.TransparencyIndex | Tree | N/A | N/A | N/A | False
"AlphaIdentifiers" | ImGearPHOTOSHOPTagIDs.AlphaIdentifiers | Tree | N/A | N/A | N/A | False
"VersionInfo" | ImGearPHOTOSHOPTagIDs.VersionInfo | Tree | N/A | N/A | N/A | False


PNG Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > PNG Metadata Structure

PNG format groups non-image data in "Chunks". ImageGear represents simpler chunks by single metadata items, and more complex chunks by subtrees.

There are two main PNG metadata levels in ImageGear:
  • PNG Metadata Level
  • PNG Chunks Metadata Level

PNG Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<PNG chunk names> | <PNG chunk ids> | <PNG chunk type> |  |  |  |

For <PNG chunk names >, <PNG chunk ids> and <PNG Chunk types> see See PNG chunks metadata level. section.

PNG Chunks Metadata Level

The following PNG non-image chunk levels are supported by ImageGear:
  • PNG Header Chunk Metadata PNG Level
  • Header Chunk Level
  • Physical Dimension Chunk Metadata PNG Level
  • Physical Dimension Chunk Level
  • Transparency Chunk Metadata PNG Level
  • Gamma Chunk Metadata PNG Level
  • Primary Chromaticities Chunk Metadata PNG Level
  • Primary Chromaticities Chunk Level
  • sRGB Chunk Metadata PNG Level
  • ICC Profile Chunk Metadata PNG Level
  • ICC Profile Chunk Level
  • Background Chunk Metadata PNG Level
  • Significant Bits Chunk Metadata PNG Level
  • Suggested Palette Chunk Metadata PNG Level
  • Suggested Palette Chunk Level
  • Palette Entry Level
  • Palette Histogram Chunk Metadata PNG Level
  • Modified Time Chunk Metadata PNG Level
  • Modified Time Chunk Level
  • Text Chunk Metadata PNG Level
  • Text Chunk Level
  • Compressed Textual Data Chunk Metadata PNG Level
  • Compressed Textual Data Chunk Level
  • International Textual Data Chunk Metadata PNG Level
  • International Textual Data Chunk Level
  • Calibration of Pixel Values Chunk Metadata PNG Level
  • Calibration of Pixel Values Chunk Level
  • Physical Scale Chunk Metadata PNG Level
  • Physical Scale Chunk Level
  • GIF Application Extension Chunk Metadata PNG Level
  • GIF Application Extension Chunk Level
  • GIF Graphic Control Extension Chunk Metadata PNG Level
  • GIF Graphic Control Extension Chunk Level
  • Image Offset Chunk Metadata PNG Level
  • Image Offset Chunk Level
  • The Rest Chunk Metadata
  • PNG Level

PNG Header Chunk Metadata PNG Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"IHDR" | 0x49484452 | Tree |  |  |  |

Header Chunk Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Width" | 0x49484452 | Leaf | UINT32 |  | 1 | TRUE
"Height" | 0x49484452 | Leaf | UINT32 |  | 1 | TRUE
"BitDepth" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"ColorType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"CompressionType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"FilterType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"InterlaceType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE

Physical Dimension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"pHYs" | 0x70485973 | Tree |  |  |  |

Physical Dimension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"XAxis" | 0x70485973 | Leaf | UINT32 |  | 1 | FALSE
"YAxis" | 0x70485973 | Leaf | UINT32 |  | 1 | FALSE
"UnitSpecifier" | 0x70485973 | Leaf | UINT8 |  | 1 | FALSE

Transparency Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tRNS" | 0x74524e53 | Leaf | UINT8 or UINT16 |  | Variable | FALSE

Gamma Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gAMA" | 0x67414d41 | Leaf | UINT32 |  | 1 | FALSE

Primary Chromaticities Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"cHRM" | 0x6348524d | Tree |  |  |  |

Primary Chromaticities Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"WhitePoint" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Red" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Green" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Blue" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE

sRGB Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sRGB" | 0x73524742 | Leaf | UINT32 |  | 1 | FALSE

ICC Profile Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"iCCP" | 0x70485973 | Tree |  |  |  |

ICC Profile Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"ProfileName" | 0x70485973 | Leaf | STRING |  | Variable | FALSE
"ProfileData" | 0x70485973 | Leaf | RAW_DATA |  | Variable | FALSE

Background Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"bKGD" | 0x624b4744 | Leaf | UINT8 or UINT16 |  | Variable | FALSE

Significant Bits Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sBIT" | 0x73424954 | Leaf | UINT8 |  | Variable | FALSE

Suggested Palette Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sPLT" | 0x73504c54 | Tree |  |  |  |

Suggested Palette Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"PaletteName" | 0x73504c54 | Leaf | STRING |  | Variable | TRUE
"SampleDepth" | 0x73504c54 | Leaf | UINT8 |  | 1 | FALSE
"PaletteEntryCount" | 0x73504c54 | Leaf | UINT16 | <N> | 1 | FALSE
Palette entry level 0 | <Entry No.> | Tree |  |  |  |
...
Palette entry level n | <Entry No.> | Tree |  |  |  |

Palette Entry Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Red" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Green" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Blue" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Alpha" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Frequency" | <Entry No.> | Leaf | UINT16 |  | 1 | FALSE

Palette Histogram Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"hIST" | 0x68495354 | Leaf | UINT16 |  | Variable | FALSE

Modified Time Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tIME" | 0x74494d45 | Tree |  |  |  |

Modified Time Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Year" | 0x74494d45 | Leaf | UINT16 |  | 1 | FALSE
"Month" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Day" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Hour" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Minute" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Second" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE

Text Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tEXt" | 0x74455874 | Tree |  |  |  |

Text Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x74455874 | Leaf | STRING |  | Variable | FALSE
"Text" | 0x74455874 | Leaf | STRING |  | Variable | FALSE

Compressed Textual Data Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"zTXt" | 0x7a545874 | Tree |  |  |  |

Compressed Textual Data Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x7a545874 | Leaf | STRING |  | Variable | FALSE
"CompressionMethod" | 0x7a545874 | Leaf | UINT8 |  | 1 | FALSE
"Text" | 0x7a545874 | Leaf | STRING |  | Variable | FALSE

International Textual Data Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"zTXt" | 0x69545874 | Tree |  |  |  |

International Textual Data Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x69545874 | Leaf | STRING |  | Variable | FALSE
"CompressionFlag" | 0x69545874 | Leaf | BOOL |  |  |
"CompressionMethod" | 0x69545874 | Leaf | UINT8 |  | 1 | FALSE
"LanguageTag" | 0x69545874 | Leaf | STRING |  |  |
"TranslatedKeyword" | 0x69545874 | Leaf | RAW_DATA |  |  |
"Text" | 0x69545874 | Leaf | RAW_DATA |  | Variable | FALSE

Calibration of Pixel Values Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"pCAL" | 0x7043414c | Tree |  |  |  |

Calibration of Pixel Values Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"CalibrationName" | 0x7043414c | Leaf | STRING |  | Variable | FALSE
"OriginalZero(x0)" | 0x7043414c | Leaf | INT32 |  | 1 | FALSE
"OriginalMax(x1)" | 0x7043414c | Leaf | INT32 |  | 1 | FALSE
"EquationType" | 0x7043414c | Leaf | UINT8 |  | 1 | FALSE
"NumberOfParameters" | 0x7043414c | Leaf | UINT8 | <N> | Variable | FALSE
"UnitName" | 0x7043414c | Leaf | STRING |  | Variable | FALSE
"CalibrationParameter" | 0 | Leaf | STRING |  | Variable | FALSE
...
"CalibrationParameter" | <N> - 1 | Leaf | STRING |  | Variable | FALSE

Physical Scale Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sCAL" | 0x7343414c | Tree |  |  |  |

Physical Scale Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"UnitSpecifier" | 0x7343414c | Leaf | UINT8 |  | 1 | FALSE
"PixelWidth" | 0x7343414c | Leaf | STRING |  | Variable | FALSE
"PixelHeigt" | 0x7343414c | Leaf | STRING |  | Variable | FALSE

GIF Application Extension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gIFx" | 0x67494678 | Tree |  |  |  |

GIF Application Extension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"ApplicationIdentifier" | 0x67494678 | Leaf | STRING |  | Variable | FALSE
"AuthenticationCode" | 0x67494678 | Leaf | UINT8 |  | 1 | FALSE
"ApplicationData" | 0x67494678 | Leaf | RAW_DATA |  | Variable | FALSE

GIF Graphic Control Extension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gIFg" | 0x67494674 | Tree |  |  |  |

GIF Graphic Control Extension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"DisposalMethod" | 0x67494674 | Leaf | UINT8 |  | 1 | FALSE
"UserInputFlag" | 0x67494674 | Leaf | UINT8 |  | 1 | FALSE
"DelayTime" | 0x67494674 | Leaf | UINT16 |  | 1 | FALSE

Image Offset Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"oFFs" | 0x6f464673 | Tree |  |  |  |

Image Offset Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"XPosition" | 0x6f464673 | Leaf | UINT32 |  | 1 | FALSE
"YPosition" | 0x6f464673 | Leaf | UINT32 |  | 1 | FALSE
"UnitSpecifier" | 0x6f464673 | Leaf | UINT8 |  | 1 | FALSE

The Rest Chunk Metadata

The rest chunk data are passed as raw data.

PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
<Chunk Name> | <Chunk ID> | Leaf | RAW_DATA |  | Variable | FALSE

<Chunk Name> is a string representation of the chunk type value.

<Chunk ID> is a binary representation of the chunk type value.


TIFF Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > TIFF Metadata Structure

As with all multipage image formats, ImageGear for .NET uses separate metadata trees for TIFF document-level metadata and TIFF page-level metadata:

  • Document level metadata:
    Name | Id | Type | Value Type | Value | Value Length | Ignored on save
    ByteOrder 59936 Leaf UINT16 0x4949 or

    0x4D4D     		1 TRUE
    Identifier | 59937 | Leaf | UINT16 | 42 | 1 | TRUE
  • Page level metadata:

TIFF page level metadata corresponds to a TIFF IFD.

This section provides information about the following:
  • Tags
  • Description of TIFF tags (ImGearTIFTagIDs)
  • TIFF Complex Data Tags
  • EXIF Metadata
  • SubIFDs

Tags

Most of TIFF tags are passed through metadata callback as:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<TagName> | <TagId> | VALUE_ITEM | <ValueType> | <TagValue> | <TagCount> | <R.o.>

The valid values of <TagName>, <TagId> and "Read Only" attributes are available in See Description of TIFF tags (ImGearTIFTagIDs). Table.

It is possible to use tag identifier and value of nonstandard tag (user defined tag).

The <TagCount> is real tag count value that is read/written in file.

The <ValueType> value is the metadata type constant that matches TIFF tag type as described in the table below:

TIFF tag type | Metadata type (ImGearNativeDataTypes)
BYTE | UINT8
SBYTE | INT8
SHORT | UINT16
SSHORT | INT16
LONG | UINT32
SLONG | INT32
RATIONAL | RATIONAL_UINT32
SRATIONAL | RATIONAL_INT32
FLOAT | FLOAT
DOUBLE | DOUBLE
ASCII | STRING
UNDEFINED | AM_TID_RAW_DATA

Description of TIFF tags (ImGearTIFTagIDs)

Item Name | Item Id | Ignored on save
"NewSubfileType" | 254 | TRUE
"SubfileType" | 255 | TRUE
"ImageWidth" | 256 | TRUE
"ImageLength" | 257 | TRUE
"BitsPerSample" | 258 | TRUE
"Compression" | 259 | TRUE
"PhotometricInterpretation" | 262 | TRUE
"Threshholding" | 263 | FALSE
"CellWidth" | 264 | TRUE
"CellLength" | 265 | TRUE
"FillOrder" | 266 | FALSE
"DocumentName" | 269 | FALSE
"ImageDescription" | 270 | FALSE
"Make" | 271 | FALSE
"Model" | 272 | FALSE
"StripOffsets" | 273 | TRUE
"Orientation" | 274 | FALSE
"SamplesPerPixel" | 277 | TRUE
"RowsPerStrip" | 278 | TRUE
"StripByteCounts" | 279 | TRUE
"MinSampleValue" | 280 | FALSE
"MaxSampleValue" | 281 | FALSE
"XResolution" | 282 | FALSE
"YResolution" | 283 | FALSE
"PlanarConfiguration" | 284 | TRUE
"PageName" | 285 | FALSE
"XPosition" | 286 | FALSE
"YPosition" | 287 | FALSE
"FreeOffsets" | 288 | TRUE
"FreeByteCounts" | 289 | TRUE
"GrayResponseUnit" | 290 | FALSE
"GrayResponseCurve" | 291 | FALSE
"T4Options" | 292 | TRUE
"T6Options" | 293 | TRUE
"ResolutionUnit" | 296 | FALSE
"PageNumber" | 297 | TRUE
"TransferFunction" | 301 | FALSE
"Software" | 305 | FALSE
"DateTime" | 306 | FALSE
"Artist" | 315 | FALSE
"HostComputer" | 316 | FALSE
"Predictor" | 317 | TRUE
"WhitePoint" | 318 | FALSE
"PrimaryChromaticities" | 319 | FALSE
"ColorMap" | 320 | TRUE
"HalftoneHints" | 321 | FALSE
"TileWidth" | 322 | TRUE
"TileLength" | 323 | TRUE
"TileOffsets" | 324 | TRUE
"TileByteCounts" | 325 | TRUE
"InkSet" | 332 | FALSE
"InkNames" | 333 | FALSE
"NumberOfInks" | 334 | FALSE
"DotRange" | 336 | FALSE
"TargetPrinter" | 337 | FALSE
"ExtraSamples" | 338 | TRUE
"SampleFormat" | 339 | FALSE
"SMinSampleValue" | 340 | FALSE
"SMaxSampleValue" | 341 | FALSE
"TransferRange" | 342 | FALSE
"JPEGTables" | 347 | TRUE
"JPEGProc" | 512 | TRUE
"JPEGInterchangeFormat" | 513 | TRUE
"JPEGInterchangeFormatLngth" | 514 | TRUE
"JPEGRestartInterval" | 515 | TRUE
"JPEGLosslessPredictors" | 517 | TRUE
"JPEGPointTransforms" | 518 | TRUE
"JPEGQTables" | 519 | TRUE
"JPEGDCTables" | 520 | TRUE
"JPEGACTables" | 521 | TRUE
"YCbCrCoefficients" | 529 | FALSE
"YCbCrSubSampling" | 530 | TRUE
"YCbCrPositioning" | 531 | FALSE
"ReferenceBlackWhite" | 532 | FALSE
"Copyright" | 33432 | FALSE
"PhotoshopResources" | 34377 | FALSE
"ExifIFDPointer" | 34665 | TRUE
"GPSInfoIFDPointer" | 34675 | TRUE
Please see file ImGearTIFTagIDs enum for the full list of TIFF Metadata Item Id constants.

TIFF Complex Data Tags

Some tags, whose value is a complex data, can be passed in parsed form as a tree. In this case, a single metadata item is replaced with a tree that uses one of the specialized metadata formats, such as Photoshop (PhotoshopImageResources) or IPTC.

EXIF Metadata

ExifIFDPointer tag in a TIFF file points to an IFD which contains tags defined in the EXIF image file format specification. ImageGear replaces this tag with EXIF metadata tree.

EXIF metadata usually contains nested IFDs as well.

SubIFDs

TIFF images can contain "SubIFDs" - nested sets of tags. A SubIFD usually contains a special version of image, such as a thumbnail, or a Raw image taken from a digital camera sensor.

ImageGear represents SubIFDs as subtrees of the root TIFF IFD.


XMP Metadata Structure
User Guide > File Formats and Compressions > File Formats > Metadata Structures > XMP Metadata Structure

XMP metadata is the standardized metadata format created by Adobe Systems, Inc. XMP defines a hierarchic metadata model that can be used for storing non-pixel data associated with images.

A short description of the elements supported in XMP metadata is described below.
  • XMP Root Level
  • XMP Schema Level
  • XMP Namespace Level
  • XMP Property Collection Level
  • XMP Simple Property Level
  • XMP Array Level
  • XMP Array Items Level
  • XMP Language Alternative Property Level
  • XMP Structure Level
  • XMP Structure Items Level
  • XMP Qualifiers Level
  • XMP Qualifier Level

XMP Root Level

Name | Id | Type | Level Type | Value Type
<Schema namespace URI 1> | ImGearXMPTagIDs.Description | Tree | XMP Schema | N/A
<Schema namespace URI 1> | ImGearXMPTagIDs.Description | Tree | XMP Schema | N/A
... |  |  |  |

XMP Schema Level

Name | Id | Type | Level Type | Value Type
About | ImGearXMPTagIDs.About | Leaf | N/A | String
Namespace | ImGearXMPCommonTagIDs. Namespace | Tree | XMP Namespace | N/A
Namespace URI | ImGearXMPCommonTagIDs.NamespaceURI | Leaf | N/A | String
Properties | ImGearXMPCommonTagIDs.Properties | Tree | XMP Property Collection | N/A

XMP Namespace Level

Name | Id | Type | Level Type | Value Type
Prefix | ImGearXMPTagIDs.Prefix | Leaf | N/A | String
URI | ImGearXMPTagIDs.URI | Leaf | N/A | String

XMP Property Collection Level

Name | Id | Type | Level Type | Value Type
<Property 1 name> | ImGearXMPTagIDs.Property | Tree | XMP Simple Property / XMP Array / XMP Structure | N/A
<Property 2 name> | ImGearXMPTagIDs.Property | Tree | XMP Simple Property, XMP Array/Structure property | N/A
... |  |  |  |

XMP Simple Property Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPropertyTagIDs.Value | Leaf | N/A | <Value type>
Qualifiers | ImGearXMPropertyTagIDs.Qualifiers | Tree | XMP Qualifiers collection | N/A

XMP Array Level

Name | Id | Type | Level Type | Value Type
Bag / Seq / Alt | ImGearXMPropertyTagIDs.Bag / ImGearXMPropertyTagIDs.Seq / ImGearXMPropertyTagIDs.Alt | Tree | XMP Array items level | N/A

XMP Array Items Level

Name | Id | Type | Level Type | Value Type
Item | ImGearXMPropertyTagIDs.Item | Tree | XMP Simple Property / XMP Language Alternative Property / XMP Structure | <N/A>
Item | ImGearXMPropertyTagIDs.Item | Tree | XMP Simple Property / XMP Language Alternative Property / XMP Structure | <N/A>
... |  |  |  |

XMP Language Alternative Property Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPropertyTagIDs.Value | Leaf | N/A | <Value type>
Lang | ImGearXMPropertyTagIDs.Lang | Leaf | N/A | String

XMP Structure Level

Name | Id | Type | Level Type | Value Type
Struct | ImGearXMPropertyTagIDs.Struct | Tree | XMP Structure items level | N/A

XMP Structure Items Level

Name | Id | Type | Level Type | Value Type
<Field 1 name 1> | ImGearXMPropertyTagIDs.Property | Tree | XMP Simple Property | <N/A>
<Field 2 name> | ImGearXMPropertyTagIDs. Property | Tree | XMP Simple Property | <N/A>
... |  |  |  |

XMP Qualifiers Level

Name | Id | Type | Level Type | Value Type
<Qualifier 1 name> | ImGearXMPropertyTagIDs. Qualifier | Tree | XMP Qualifier | <N/A>
<Qualifier 2 name> | ImGearXMPropertyTagIDs. Qualifier | Tree | XMP Qualifier | <N/A>
... |  |  |  |

XMP Qualifier Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPCommonTagIDs. Value | Leaf | N/A | <Value type>


Compressions
User Guide > File Formats and Compressions > Compressions

All imaging file compressions can be divided into three basic types:

  • 1D compression is compression in which the raster data is treated as one continuous data stream. Each byte read is compared to the previous byte. This compression method is not concerned with delineating lines of data.
  • 2D compression can be thought of as "Differencing Compression", where the data stored is a representation of the differences in data values from previous data values. In 2D compression, the encoding of one line is determined by the contents of the previous line. This method of compression is best used for black-and-white images where the black pixels tend to fall into groups.
  • 3D compression is data compression aimed at the 3D models and other geometric datasets used in computer graphics, virtual reality, video games, CAD/CAM, and many scientific, engineering, and medical applications. Existing 3D compression algorithms use both techniques adapted from the 1D and 2D cases (like wavelets, entropy coding, and predictive coding), and completely different approaches that take advantage of the properties of 3D surfaces (like Edgebreaker, Subdivision Surfaces, and triangle strips).

ImageGear supports the following compressions:

  • Compressions
    • ASCII Compression
    • CCITT Group 3 Compression
    • CCITT Group 3 2D Compression
    • CCITT Group 4 Compression
    • Deflate Compression
    • HD Photo Compression
    • Huffman Compression
    • IBM MMR Compression
    • JPEG Compressions
      • Lossy JPEG Compression
      • Lossless JPEG Compression
      • Progressive JPEG Compression
    • JPEG 2000 Compression
    • LZW (Lempel-Ziv-Welch) Compression
    • Packbits Compression
    • RAW Compression
    • RLE Compression


ASCII Compression
User Guide > File Formats and Compressions > Compressions > ASCII Compression

Full Name | American Standard Code for Information Interchange (ASCII)
Compression ID | ImGearCompressions.ASCII = 23
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
File Formats | PBM, PGM, PNM, PPM
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Acronym for the American Standard Code for Information Interchange. ASCII is a code for representing English characters as numbers, with each letter assigned a number from 0 to 127. For example, the ASCII code for uppercase M is 77. Most computers use ASCII codes to represent text, which makes it possible to transfer data from one computer to another.

Text files stored in ASCII format are sometimes called ASCII files. Text editors and word processors are usually capable of storing data in ASCII format, although ASCII format is not always the default storage format. Most data files, particularly if they contain numeric data, are not stored in ASCII format. Executable programs are never stored in ASCII format.


CCITT Group 3 Compression
User Guide > File Formats and Compressions > Compressions > CCITT Group 3 Compression

Full Name | CCITT Group 3
Compression ID | ImGearCompressions.CCITT_G3 = 3
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1
File Formats | BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, PDF, PS, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

This is a 1-D version of the CCITT Group 3 compression scheme. It uses a static table of values to assign codes to run lengths. Frequently occurring run lengths are given smaller codes. (The most frequent are usually black runs of 2 or 4 pixels).


CCITT Group 3 2D Compression
User Guide > File Formats and Compressions > Compressions > CCITT Group 3 2D Compression

Full Name | CCITT Group 3 2D
Compression ID | ImGearCompressions.CCITT_G32D = 5
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1
File Formats | BTR, IBM IOCA, IBM MO:DCA, Adobe PDF, PS, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

This is a 2-D version of the CCITT Group 3 compression scheme. It includes an error recovery algorithm for error transmissions; an error in one line does not translate to garbage output for the rest of the file. All modern fax machines support this format.


CCITT Group 4 Compression
User Guide > File Formats and Compressions > Compressions > CCITT Group 4 Compression

Full Name | CCITT Group 4
Compression ID | ImGearCompressions.CCITT_G4 = 4
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1
File Formats | CAL, IMR, KFX, BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, Adobe PDF, PS, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

The G4 compression is two-dimensional by default. It is very similar to the G3 2D compression, but it can produce compressed images that are half the size of a G3-compressed file.

It is slower, however, and does not have the same error recovery built in that the G3 format has. The decrease in speed occurs because G4 was designed specifically for encoding disk data. For this reason, it may be advisable to use the G3-Fax compression scheme if final compression size is not crucial, but speed is.


Deflate Compression
User Guide > File Formats and Compressions > Compressions > Deflate Compression

Full Name | Deflate compression
Compression ID | ImGearCompressions.DEFLATE = 14
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1, 2, 4, 8, 16 bpc
File Formats | PDF, PS, TIFF, PNG
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

"Zip-in-TIFF" compression. Deflate compression, sometime known as "zip" compression, uses another variant of the LZW compression method and so gives similar results, but is not restricted by any licenses.


HD Photo Compression
User Guide > File Formats and Compressions > Compressions > HD Photo Compression
Full Name | Microsoft HD Photo
Compression ID | ImGearCompressions.HDPhoto = 20
ImageGear Assembly | ImageGear22.Wpf Assembly
Bit Depth | Grayscale: 1, 8, 16 bpp; RGB: 24, 48 bpp; RGBA: 32, 64 bpp; RGBPA: 32, 64 bpp; CMYK: 32, 64 bpp; CMYKEx: 40, 80 bpp; Extra: 3...9 channels x 8, 16 bpp
File Formats | HD Photo
IG Platforms Support | WIN32, .NET

Comments

Compression scheme used in the HD Photo (also known as WM Photo) image file format. HD Photo delivers a lightweight, high performance algorithm with a small memory footprint that enables practical, in-device encoding and decoding. It delivers compression quality comparable with JPEG-2000 and more than twice the quality of JPEG.

You need ImageGear.WPF Namespace to use this compression.


Huffman Compression
User Guide > File Formats and Compressions > Compressions > Huffman Compression

Full Name | Huffman encoding
Compression ID | ImGearCompressions.HUFFMAN = 2
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Any
File Formats | NCR, PCD, TIFF, KodakRAW, NEF, PEF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Developed in 1952 by David Huffman, this is one of the older compression methods. The encoding and decoding processes are complex relative to todayas standards, but the compression ratio can be high if the image contains many repeat data values. It is best used for images with little or no pixel noise, e.g., cartoons or drawings with large areas of the same color and intensity (like a monotone sky). This compression scheme is often used by other compression algorithms for extra compression.

The Huffman method uses a conversion table to assign codes for each value, based on frequency of occurrence. The file is scanned for all of its values, with the values and their frequency of occurrence tallied. Using a binary tree, values are paired off by frequency of occurrence, beginning with the least frequent values. As the tree progresses upward, the least occurring values at the bottom of the tree continue to be incremented a bit at a time, with one bit added for each new branch added to the tree. In the end, the values that occur the most (at the top of the tree) have the shortest codes.

A potential problem with this compression method is decoding; the file as variable-length codes can cause the dropping or adding of a bit to the end of a line, thereby throwing off subsequent lines of data.


IBM MMR Compression
User Guide > File Formats and Compressions > Compressions > IBM MMR Compression

Full Name | IBM Modified Modified Read
Compression ID | ImGearCompressions.IBM_MMR = 15
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1
File Formats | IBM IOCA, IBM MO:DCA
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Compression for black and white documents, similar to CCITT Group 4.


JPEG Compressions
User Guide > File Formats and Compressions > Compressions > JPEG Compressions
  • JPEG Compressions
    • Lossy JPEG Compression
    • Lossless JPEG Compression
    • Progressive JPEG Compression


Lossy JPEG Compression
User Guide > File Formats and Compressions > Compressions > JPEG Compressions > Lossy JPEG Compression

Full Name | JPEG Compression
Compression ID | ImGearCompressions.JPEG = 6
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
File Formats | JPEG, DICOM, DNG, PDF, PS, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

This file compression method obtains a high compression ratio when used with detailed photographic images (its intended use). It is not a good compression choice for images with a small number of colors and high contrast edges, or for color-mapped data. Part of JPEGs success in high compression is due to the fact that it is a "lossy" compression method, meaning that the compression results in the loss of some data that is determined to be unimportant or unnecessary. This does not necessarily result in a visible reduction of image quality.

JPEG is highly flexible - it allows you to make a "quality" setting that determines the amount of loss that occurs and affects the size of the resulting compressed file.

The JPEG algorithm takes into account that the human eye is more sensitive to changes in brightness than to number of colors. Rather than saving the color data from each pixel in an image, it saves information on the rate of change of color, or "frequency information." More loss is allowed in the color data than in the brightness data. Some of the compression of the color is achieved by converting the RGB values to YCbCr color scheme. ImageGear supports two other JPEG compression modes, as described in the following sub-sections:

  • Lossy JPEG Compression


Lossless JPEG Compression
User Guide > File Formats and Compressions > Compressions > JPEG Compressions > Lossless JPEG Compression

Full Name | Lossless JPEG compression
Compression ID | ImGearCompressions.JPEG = 6
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 48 bpp
File Formats | JPEG, DICOM, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Lossless JPEG is an extension to the normal JPEG standard. One of the main algorithmic differences between the two is that the lossless JPEG does not apply a Discrete Cosine Transform. Rather, it uses a Predictive scheme. For each pixel, the values of one or several neighboring pixels are added to the value of the original pixel and then subtracted from the value of the original pixel. This method yields smaller values that require fewer bits per pixel to store.

ImageGear allows you to set the number of neighboring pixels to use in calculating the "predictor value".


Progressive JPEG Compression
User Guide > File Formats and Compressions > Compressions > JPEG Compressions > Progressive JPEG Compression

Full Name | Progressive JPEG Compression
Compression ID | ImGearCompressions.JPEG = 6
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
File Formats | JPEG
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Progressive JPEG is considered an extension to the JPEG standard. It produces the same kind of lossy compression as normal JPEG compression (see above), except that it saves multiple copies of the same image using different levels of quality. There is no hard limit on the number of "scans" that may be stored.

When a Progressive JPEG-compressed image is decompressed, the filter decompresses the lowest quality image first. This can be helpful for quickly displaying a version of the image that you are loading. The benefit of this compression is the fast display of an image that is recognizable. The downside is that a JPEG decompression is performed more than once.


JPEG 2000 Compression
User Guide > File Formats and Compressions > Compressions > JPEG 2000 Compression

Full Name | JPEG 2000 wavelet compression
Compression ID | ImGearCompressions.JPEG2K = 25
ImageGear Assembly | ImageGear22.Formats.Jpeg2k Assembly
Bit Depth | 1..16 bpc, various color spaces (depends on file format)
File Formats | JPEG 2000, JPX, DICOM, PDF, PS
IG Platforms Support | WIN32, WIN64, .NET, .NET64

Comments

The JPEG 2000 compression technique is based on two main processes: Tiling and Discrete Wavelet Transform (DWT).

Tiling

The term tiling refers to the partition of the original (source) image into rectangular non-overlapping blocks (tiles), which are compressed independently as though they were entirely distinct images. All operations, including component mixing, wavelet transform, quantization and entropy coding are performed independently on the image tiles. Tiling reduces memory requirements, and since they are also reconstructed independently, they can be used for decoding specific parts of the image rather than the entire image.

All tiles have exactly the same dimensions, except for those at the right and lower boundary of the image. Arbitrary tile sizes are allowed, up to and including the entire image (i.e., the whole image is regarded as one tile). Components with different sub-sampling factors are tiled with respect to a high-resolution grid, which ensures spatial consistency on the resulting tile components. Smaller tiles create more tiling artifacts compared to larger tiles.

Discrete Wavelet Transform (DWT)

The Discrete Wavelet Transform (DWT) is very similar to the Discrete Fourier Transform (DFT), but does not use the sine and cosine functions for analyzing the image data. The basic functions are called scaling functions and wavelets. These functions combine the fundamental feature of orthogonality (allowing the transformation and the identical reconstruction) and compact representation. This allows the analysis of image data without the windowing effects, which result from the need to handle the infinite sine method on finite image data using the DFT.

Images can be seen as two dimensional signals. They can be transformed using a two dimensional transformation. Two dimensional transformations can be achieved by separately applying one dimensional transformations to the lines and columns of an image. The DWT method splits the image into four new images in the wavelet domain; one image contains the low-pass information and the others contain high-pass information of horizontal, vertical and diagonal orientation. The transformation then applies itself recursively to the low-pass image. This can be continued until the last low-pass image contains only a single pixel.

The tile components of JPEG 2000 images are decomposed into different decomposition levels using Discrete Wavelet Transform. These decomposition levels contain a number of subbands, which consist of coefficients that describe the horizontal and vertical spatial frequency characteristics of the original tile component. Power of two decompositions are allowed in the form of dyadic decomposition (in Part I).

To perform the forward DWT, the standard uses a one dimensional subband decomposition of a one dimensional set of samples into low-pass samples and high-pass samples. Low-pass samples represent a downsampled low-resolution version of the original set. High-pass samples represent a downsampled residual version of the original set, needed for the perfect reconstruction of the original set from the low-pass set.

The DWT can be irreversible or reversible. The default irreversible transform is implemented by means of the Daubechies 9-tap/7-tap filter. The default reversible transformation is implemented by means of the 5-tap/3-tap filter.

The standard supports two filtering modes: a convolution-based mode and a lifting-based mode. For both modes to be implemented, the signal should first be extended periodically. This periodic symmetric extension is used to ensure that for the filtering operations that take place at both boundaries of the signal, one signal sample exists and spatially corresponds to each coefficient of the filter mask. The number of additional samples required at the boundaries of the signal is, therefore, filter-length dependent.

Convolution-based filtering performs a series of dot products between the two filter masks and the extended one dimensional signal. Lifting-based filtering consists of a sequence of very simple filtering operations for which alternately odd sample values of the signal are updated with a weighted sum of even sample values. Even sample values are updated with a weighted sum of odd sample values. For the reverse (lossless) case, the results are rounded to integer values.

The 5/3 filter allows repetitive encoding and decoding of an image without any additional loss. This is true when the decompressed image values are not clipped when they fall outside the full dynamic range (i.e., 0-255 for an 8-bpp image).


LZW (Lempel-Ziv-Welch) Compression
User Guide > File Formats and Compressions > Compressions > LZW (Lempel-Ziv-Welch) Compression

Full Name | Lempel-Zif-Welch (LZW) compression
Compression ID | ImGearCompressions.LZW = 8
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1, 4, 8, 16 bpc
File Formats | GIF, PDF, PS, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

LZW compression works by finding patterns of data and assigning codes. It works best on highly-patterned images. Images with irregular patterning, or "noise," are not good candidates for this type of compression.

This compression scheme is "dictionary-based". This refers to the array of codes that identify each data pattern found in the image. The "dictionary" begins with a table that contains a code for each possible value in the image. If LZW compression is used on 8-bit images, a LZW "dictionary" is initialized with codes for 256 (28) values. As the file data is read, new values are added to the table for each unique pattern of data found. In the interest of saving space, the dictionary is not saved with the compressed file. The same dictionary is actually rebuilt when the data is decoded.


Packbits Compression
User Guide > File Formats and Compressions > Compressions > Packbits Compression

Full Name | Packed bits compression
Compression ID | ImGearCompressions.PACKED_BITS = 1
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1, 4, 8, 16 bpc
File Formats | PSD, TIFF
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Packbits compression seeks repeated data values. Packbits is considered an RLE (run-length encoding) compression scheme because it looks for "runs" or repeated values, and tallies their number, or "length". While its name implies that runs of bits are "packed" together, it is actually runs of bytes. It is very similar to the Macintosh Packbits compression used by Macpaint, except that the Packbits compression used for a TIFF allows the dimensions of the image to vary.

Packbits works by reducing repeated strings of the same characters into two components: the "run count" and the "run value". The count and value are stored in one byte each. Each two-byte grouping is referred to as an RLE packet. It is not a good compression scheme for images with large color ranges, as these do not tend to have many runs of the same color.


RAW Compression
User Guide > File Formats and Compressions > Compressions > RAW Compression

Full Name | RAW compression (Uncompressed binary compression)
Compression ID | ImGearCompressions.RAW = 2
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
File Formats | PBM, PGM, PNM, PPM
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

Uncompressed binary compression. PBM, PGM, PNM, PPM formats use the term "RAW" for uncompressed binary compression, as opposed to ASCII compression.


RLE Compression
User Guide > File Formats and Compressions > Compressions > RLE Compression

Full Name | Run length encoding compression
Compression ID | ImGearCompressions.RLE = 7
ImageGear Assembly | ImageGear22.Core Assembly
Bit Depth | 1, 4, 8, 16 bpc
File Formats | BMP, CLP, CUT, DCX, DICOM, GEM, IFF, MSP, PCX, Adobe PDF, PS, RAS, SGI, TGA, WPG
IG Platforms Support | WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC

Comments

RLE (Run Length Encoding) is normally a 1-dimensional compression scheme. Working sequentially from left to right and top to bottom, it compares the value of each byte with the value of the previous byte. Each data value is recorded into a "packet" of two bytes where the first byte contains the number of times the value is repeated, and the second packet contains the actual value. The bytes in the pocket are called the "run count" and the "run value". When an image contains many repeat values, the compression ratio is very high (for example, if every byte in a 100 byte image were the same, its size could be reduced to 2 bytes giving a 50:1 ratio). A very noisy image, or a plain ASCII text file typically does not compress well, and in fact could become larger for example, if all bytes in image are different from the ones next to them, the image doubles, because 2 bytes are used to store each byte in the image.


Concepts
User Guide > Concepts

This section provides information about the following:

  • Concepts
    • Architecture
    • Reference Glossary
    • Upgrading from v16 or Earlier
      • Initialize Assemblies
      • Resolve Assembly Cross-Dependencies
        • IImGearDICOMDisplaySettings Interface
        • ImGearAnnotationPage Class
        • ImGearFormatMetadata Class
      • Migrate from Previous Versions


Architecture
User Guide > Concepts > Architecture

The ImageGear for .NET library is logically divided into five major parts, encapsulated into following namespaces a Core, Processing, Formats, Display and extensions. An example of their relationship is shown in the following diagram:

ImageGear.Core Namespace is the basis of ImageGear for .NET toolkit. This namespace contains classes to operate with graphics primitives, to license product, and most importantly, primary ImageGear entities like page and document. Page is implemented in the ImGearPage Class and represents an image in memory. It contains image attributes, pixels, and offers functions for basic operating like access to stored pixels or metadata assignment.

Since the most persistent form of storage for images is files, ImageGear offers the ImGearFileFormats Class, located in ImageGear.Formats Namespace, to handle them. Using this class, it is possible to load and store single pages from local and network files, obtain properties like width and height without loading an entire image, and operate with multi-image documents (ImGearDocument Class) like TIFF. The toolkit also contains classes like ImGearLoadOptions Class and interfaces like the ImGearControlParameter Class to control image loading and saving processes (including saving the format and its characteristics).

A file is not the only source from which an image may be obtained. To acquire a page or document from a scanner device, the ImGearTWAIN Class should be used. It helps to properly set up device parameters and obtain scanned images as single page or multi-page documents.

Once an image (in its representation as ImGearPage Class) is created or obtained from a file or scanner, it is possible to process it using the ImGearProcessing Class. It defines a series of members that can be applied to any ImGearPage Class instance. Adjusting brightness/contrast, flipping, inverting, rotating and other operations are available for developers. Additionally, an export to managed GDI + Bitmap class is also available through ImGearProcessing Class.

The ImGearPageDisplay Class serves to represent an image on the computer's screen. It is a member of the ImageGear.Display Namespace and allows drawing the attached ImGearPage Class onto a Windows Form with an impressive variety of options. WPF applications should use ImGearPresentationPageDisplay Class, available in the ImageGear22.Presentation.dll assembly.

The PageView Class and ThumbnailView Class are ASP.NET Web Form controls that let you view images in a web browser. Those controls manage all the interaction with the rest of ImageGear that they need to support the viewing operations. If your application requires additional ImageGear functionality, you can simply interact directly with ImageGear.


Reference Glossary
User Guide > Concepts > Reference Glossary

This glossary contains a mixture of terminology used by Accusoft Corporation in both its software products and its documentation. Since these terms come from many different disciplines and because many of the terms have different meanings in each discipline, each glossary entry is followed by the name of the field from which the definition is taken.

  • 1
  • 2
  • 4
  • 8
  • A
  • B
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • J
  • K
  • L
  • M
  • N
  • O
  • P
  • R
  • S
  • T
  • V
  • W
  • X
  • Y
  • Z

1

1-bit image

An image comprised of pixels that contain only a single bit of information. Each pixel is either on or off. Normally, "on" is white and "off" is black.

2

24-bit image

A 24-bit image contains pixels made from RGB triplets.

4

4-bit image

An image file format that allows 4-bits per pixel. This image can contain up to 16 (24) different colors or levels of gray.

8

8-bit image

An image where each pixel has 8-bits of information. An 8-bit pixel contains one of 256 possible values. There are two common types of 8-bit images: grayscale and indexed color.

In a grayscale image, each pixel takes one of 256 shades of gray and the shades are linearly distributed from 0 (black) to 256 (white). An 8-bit grayscale image does not require a palette but may have one.

An indexed color image is always a palette image. Each pixel is used as an index to the palette. These images can have up to 256 different colors. This includes hues as well as shades. Indexed 8-bit images are good for low color resolution images that do not need processing. They are 3 times smaller than full-color RGB images, but because the pixel values are not linear, many image-processing algorithms cannot work with them. They must be promoted to 24-bit for image processing.

8-bit gray level

This indicates 8-bit grayscale. 8-bit gray level is used to distinguish between 8-bit indexed color (8i) and 8 bit grayscale. An 8-bit gray level DIB image is one where each pixel in the bitmap is unchanged by its palette when displayed. Each palette entry is the same as its index.

8-bit indexed

This indicates 8-bit indexed color. 8i is used throughout this manual to distinguish between 8-bit grayscale (8-bit gray level) and 8-bit indexed color. An 8-bit indexed color DIB is one where each 8-bit pixel value in the bitmap is used as an index to the palette.

The palette dictates which RGB color the pixel displays. These images are compact ways of storing color images. However they are difficult to process because the bytes that make up the pixel can no longer be ordered with any certainty.

A

absolute coordinates

Absolute coordinates refer to a common origin, for example, the upper left corner of a display screen. This is the opposite of relative coordinates.

ACCUAPI

Accusoft Application Program Interface.

additive primary colors

Red, Green, Blue - the 3 colors used to create all other colors when direct, or transmitted light is used (as in a video monitor). They are called additive primaries, because when these three colors are superimposed they produce white.

anti-aliasing

A method of filling in data that is missing due to under-sampling. In imaging, this usually involves the process of removing jagged edges by interpolating values in-between pixels of contrast. These methods are most often used to remove or reduce the stair-stepping artifact found in digital high contrast images.

AOI

Area Of Interest. An area of interest is a rectangle within an image defined as two points within the image. An AOI can be written as (x1,y1)-(x2,y2). All AOIs are parallel with the image's axes.

API

Application Programmer's Interface. The set of routines that make up a library or toolkit. Some times called a binding.

aspect ratio

The proportion of an image's size given in terms of the horizontal length verses the vertical height. An aspect ratio of 4:3 indicates that the image is 4/3 times as wide as it is high.

B

Bezier curve

A curve created from endpoints and two or more control points that serve as positions for the shape of the curve. Originated by P. Bezier (~1962) for the use in car body descriptions.

bit block transfer

A raster operation that moves a block of bits representing a portion of an image or scene from one location in the frame buffer to another. Usually written as "bit blt".

bitmap

An image is a bitmap if it contains a value for each of its pixels. This is the opposite of vector images where a small set of values generate an object.

bit plane

A hypothetical 2-D plane containing a single bit of memory for each pixel in a image. If each 8-bit pixel is thought of as a stack of 8 coins, and an image as many rows and columns of these stacked coins then the 3rd bit plane would be the plane consisting of the 3rd coin from each stack.

bounding rectangle

The smallest rectangle that fits around a given object. In imaging, the rectangle is usually rotationally restricted to be parallel to both image axes.

C

Cartesian coordinates

A 2-dimensional equally spaced grid iron that uniquely assigns every point in the plane, (one and only one), co-ordinate pair; (x, y). In imaging, each point is usually referred to as a pixel and the x and y values take on integer values. Most images use the top-left as the (0,0), or origin.

Chroma-key

An image blending method that replaces pixels of a specified hue range with pixels from a second image. This is often referred to the weatherman effect because most weather forecasters use a solid blue or green background to make it look as if they are standing in front of a huge weather map. It is important to remember that it is the hue that is used in the blending method and not the intensity or saturation.

C.I.E

Commission Internationale de l'Eclairage. (International Commission of Illumination). A standards organization which provides specifications for the description of device independent color.

clipboard

The clipboard is a windows data structure used to exchanged data between applications. It is a common area where applications place data and others can access it. These operations are usually referred to as Cut (place data in) and Paste (take data out).

CMY & CMYK

Cyan, Magenta, Yellow, blacK. Computer monitors are additive, but color printers are subtractive. Instead of combining light from monitor phosphors, printers coat paper with colored pigment that removes specific colors from the illumination light.

CMY is the subtractive color model that corresponds to the additive RGB model. Cyan, magenta, and yellow are the color complements of red, green, and blue. Due to the difficulties of manufacturing pigments that produce black when mixed together, a separate black ink is often used and is referred to as K (`B' is already used for blue).

color space

A mathematical coordinate system (space) for assigning numerical values to colors. There are many ways to define such spaces, each with its own benefits and problems.

compression

An image processing method for saving valuable disk and memory space by reducing the amount of space required to save a digital image. The graphics data is rewritten allowing it to be represented by a smaller set of data. Do not confuse this with encoding.

compression ratio

The ratio of a file's uncompressed size over its compressed size.

concave

A 2-dimensional blob, for example, a region of interest (ROI), where at least one tangent is drawn that touches the blob at two different locations, and there is a point on the tangent between the two contacts that does not touch the blob.

In simpler words, if a rubber band could be snugly wrapped around a concave blob there would be places where the rubber band lifts off and does not touch the blob. Concave is the opposite of convex.

convex

A 2-dimensional blob, for example, a region of interest (ROI), where every tangent that can be drawn touches the blob at a continuous stretch of the blob's surface with no gaps.

In simpler words, if a rubber band could be snugly wrapped around a convex blob there would be no places where the rubber band lifts off and is not touching the blob. Convex is the opposite of concave.

convolution

An image processing operation that is used to spatially filter an image. A convolution is defined by a kernel that is a small matrix of fixed numbers. The size of the kernel, the numbers within it, and a single normalizer value define the operation that is applied to the image. The kernel is applied to the image by placing the kernel over the image to be convolved and sliding it around to center it over every pixel in the original image.

At each placement the numbers (pixel values) from the original image are multiplied by the kernel number that is currently aligned above it. The sum of all these products is tabulated and divided by the kernel's normalizer. This result is placed into the new image at the position of the kernel's center. The kernel is translated to the next pixel position and the process repeats until all image pixels have been processed.

As an example, a 3x3 kernel holding all `1's with a normalizer of 9 performs a neighborhood averaging operation. Each pixel in the new image is the average of its 9 neighbors from the original.

coordinates

A pair of numbers that represent a specific location in a two-dimensional plane, for example, an image or on a map.

crop

An image processing method for removing the region near the edge of the image, but keeping the central area.

D

DDB

Device Dependent Bitmap. A Window image specification that depends on the capabilities of a specific graphics display controller. Since a DDB is matched to the current graphics controller, it is fast and easy to display since large blocks of memory need only be copied to the controller.

decompression

When an image or other digital data set is compressed and stored, it is not usable until it is decompressed into it original form.

device coordinates

The co-ordinates of the coordinate system that describe the physical units that defines the computer screen.

device dependent

Software written to work on a specific set of hardware platforms. Since these routines make use of physical device attributes, they may behave differently on other devices, although they will most often not work on other devices.

device driver

A set of low-level software routines that work with and control a specific hardware device. The names and functions are often standardized across many similar devices. This allows higher level software to use the hardware as a generic device. This frees the higher-level software from dealing with the particulars of specific devices and allows devices to be interchanged.

device independent

Software or data structures that are designed to work with or on a wide set of hardware platforms.

DIB

Device Independent Bitmap is a Windows-defined image format specification. It is called device-independent because of its straightforward, common-denominator, format. It has all the information that a basic digital image needs and is laid out in a simple specification. Its simplicity makes it an ideal format for holding images that need to be shared by several programs.

dithering

The method of using neighborhoods of display pixels to represent one image intensity or color. This method allows low-intensity resolution display devices to simulate higher resolution images. For example, a binary laser printer can use block patterns to display grayscale images.

DLL

Dynamic Linked Library. A compiled and linked collection of computer functions that are not directly bound to an executable. These libraries are linked at run-time by Windows. Since Windows is in charge of managing (loading, linking, and removing) the DLLs, they are available to all executables currently running. Each executable links to a shared DLL saving memory by avoiding redundant functions from co-existing. DLLs allow a new level of modularity by providing a means to modify and update executables without re-linking. Just copy a new version of the DLL to the correct disk directory.

DPI

Dots Per Inch. The number of printer dots that can be printed in one inch. The printer's resolution is defined by the number of dots per inch: lower resolution = less dots per inch, higher resolution = more dots per inch.

E

edge

In an image, an edge is a region of contrast or color change. Edges are useful in machine vision since optical edges often mark the boundary of physical objects.

edge detection

A method that isolates and locates an optical edge in a digital image.

edge map

An edge map is the output of an image-processing filter that transforms an image into an image where intensity represents a change in the contrast (optical edge) of the original image.

Encoding

The format for storing uncompressed data (binary, ASCII, etc.), how it is packed (e.g. 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.

equalize

An image-processing algorithm that redistributes the frequency of image pixel values allowing equal representation for any given continuous range of values. In an ideal world, an equalized image has the same number of pixels in the range from 10-20 as it does from 200-210. However, since digital images have quantized intensity values, the range totals are rarely identical but usually close.

F

file format

A specification for holding computer data in a disk file. The format dictates what information is present in the file and how it is organized.

filter

An image-processing filter is a transform that removes a specified quantity from an image. For instance a spatial filter removes high, medium or low spatial frequencies from an image.

frame

A single picture, usually taken from a collection of images for example, a movie or video stream.

frame buffer

A computer peripheral that stores and sometimes manipulating digital images.

frame processes

Image-processing algorithms that operate on a single image.

G

gain & level

Gain and level are image-processing terms that correspond to the brightness and contrast control on a television. The gain is the "contrast", and the level is the "brightness." By changing the level, the entire range of pixel values are linearly shifted brighter or darker. Gain on the other hand linearly stretches or shrinks the intensity range, altering the contrast.

gamma correction

A non-linear method that is used to correct the inherent non-linearities of cameras and monitors. The intensity of the luminescent phosphor on the raster display is non-linear. Gamma correction is an adjustment to the pixel intensity values that make up for this inherent non-linearity.

geometric transform

A class of image processing transforms that alter the location of pixels. This class includes rotates and warps.

GUI

Graphical User Interface. A computer-user interface that uses graphical objects and a mouse for user interaction, for example Microsoft Windows.

graphics library

A collection of software routines that work on digital images. These collections usually contain routines for drawing various graphical objects, for example, lines, circles, and rectangles.

gray level

A shade of gray assigned to a pixel. The shades are usually positive integer values taken from the grayscale. In an 8-bit image a gray level can have a value from 0 to 255.

grayscale

A range of gray levels. Zero is usually black and higher numbers indicate brighter pixels.

group III Fax

A CCITT standard for transmission of facsimile data. It compresses black and white images using a combination of differential, run length and Huffman coding.

H

halftone

The reproduction of a continuous-tone image on a device that does not directly support continuous output. This is done by displaying or printing a pattern of small dots that simulate the desired output color or intensity. These methods are used extensively in magazines and newspapers.

handle

A handle references a data object. A handle is a type of pointer but it usually contains, internally, more information about the referenced object.

histogram

A tabulation of pixel value populations displayed as a bar chart where the x-axis represents all the possible pixel values and the y-axis is the total image count of each given pixel value. A histogram counts how many pixels in the image have a given intensity value or range of values.

Each histogram intensity value or range of values is called a bin. Each bin contains a positive number that represents the number of pixels in the image that fall within the bin's range. A typical 8-bit grayscale histogram contains 256 bins. Each bin has a range of a single intensity value. Bin 0 contains the number of pixels in the image that have a grayscale value of 0 or black; bin 255 contains the number of white (255) pixels. When the collection of bins are sorted (0-255) and charted, the graph displays the intensity distributions of all the images pixels.

HLS

Hue Saturation, and Lightness. A method that describes any color as a triplet of real values. The hue represents the color or wavelength of the color. It is sometimes called tone and is commonly known as color. The hue is taken from the standard color wheel and is calibrated in degrees.

Saturation is the depth of the color. It states how gray the color is. It is a real valued parameter from 0.0 to 1.0 with 0.0 indicating full gray and 1.0 representing pure hue.

Lightness determines how black or white a color is. It ranges from 0.0 to 1.0 but with 0.0 representing black and 1.0 white. A lightness of 0.5 is a pure hue.

HSV

Hue, Saturation, and Value.

Huffman coding

A method of encoding symbols that varies the length of the code in proportion to its information content. Groups of pixels that appear frequently in a image are coded with fewer bits than those of lower occurrence.

I

image format

There are many digital image formats. Some of these are: TIFF, DIB, GIF, and JPEG. The image format specification dictates which image information is present and how it is organized in memory. Many formats support various sub-formats or `flavors'.

image processing

The general term "image processing" refers to a computer discipline wherein digital images are the main data object. This type of processing can be broken down into several sub-categories: compression, image enhancement, image filtering, image distortion, image display and coloring, and image editing.

indexed color image

An image where each pixel value is used as an index to a palette for interpretation before the pixel is displayed. These images contain a palette that is initialized specifically for a given image. The pixel values are usually 8-bit and the palette 24-bit (8-red, 8-green, and 8-blue).

invert intensity

An image processing operation where each pixel is subtracted from the maximum pixel value allowed. This produces a photographic negative of the original. For an 8-bit image the inverse function is:

invert(pix) = 255-pix;

For an 8-bit RGB image the function is:

invert(Rpix) = 255-Rpix;

invert(Gpix) = 255-Gpix;

invert(Bpix) = 255-Bpix;

J

jaggies

A term used to describe the visual appearance of lines and shapes in raster pictures that results from a grid of insufficient spatial resolution.

JPEG JFIF

Joint Photographic Experts Group. A collaborative specification of the CCITT and the ISO for image compression. The standard JPEG compression algorithm, which is used by ImageGear, is a lossy compression scheme - it loses data.

K

kernel

A small matrix of pixels, usually no bigger that 9x9, that is used as an operator during image convolution. The kernel is set prior to the convolution in a fashion that emphasizes a particular feature of the image. Kernels are often used as spatial filters, each one tuned to a specific spatial frequency that the convolution is intended to highlight.

L

Lempel Ziff Welch

A dictionary-based image compression method with lossless performance that results in fair compression ratios. Most files are compressed at 2:1.

library

A collection of software functions that can be called upon by a higher level program. Most libraries are collections of similar routines, for example, those used for graphical or image processing.

Look-Up-Table

A look-up-table or LUT is a continuous block of computer memory that computes the values of a function for one variable. The LUT is set up for the function's variable to be used as an address or offset into the memory block. The value that resides at this memory location becomes the function's output. Because the LUT values need only be initialized once, LUTs are very useful for image processing due to their inherent high speed.

LUT[pixel_value] = f(pixel_value)

LUTs come in various widths, usually in units of bits. An nxm bit LUT has 2n addresses or 256 stored values. Each value is 2m bits wide.

If the second dimension is left off it can be assumed to be equal to the first. In grayscale image processing, LUTs are commonly 8x8, and the bit widths are usually assumed.

A linear LUT, sometimes called a NOP LUT or pass through, is a LUT that is initialized to output the same values as the input. NOP_LUT[pixel_value] = pixel_value.

lossless

A method of image compression where there is no loss in quality when the image is uncompressed. The uncompressed image is mathematically identical to its original. Lossless compression is usually lower in compression ratio than lossy compression.

lossy

A method of image compression where some image quality is sacrificed in exchange for higher compression ratios. The amount of quality degradation depends on the compression algorithm used and by a user-selected quality variable.

LUT

Look-Up-Table.

LUT transform

A LUT transform is an image processing method that takes an image and passes each pixel, one at a time, through a pre-set LUT. Each new pixel is a function of one and only one pixel from the original image and is arranged in the same location.

Any image-processing algorithm that transforms a single pixel into another single pixel, both from the same location, can be performed quickly using a LUT.

Square_root_LUT[pixel_value] = sqrt(pixel_value)

M

machine vision

A sub-discipline of artificial intelligence that uses video cameras or scanners to obtain information about a given environment. Machine vision processes extract information from digital images about objects in the image. This is the opposite of computer graphics that takes various data describing objects in and produces an output image. Machine vision takes an image in and outputs some level of description about the objects in it, (i.e. color, size, brightness).

median filter

An image spatial filtering operation based on an input pixel and its 8 neighbors. The resulting value is the median (5th from the sorted values). A median filter is often used to reduce spike or speckling noise from a grayscale image. It has the advantage over convolution smoothing - it better preserves edges.

morphing

An imaging process where one image is gradually transformed into a second image, where both images previously existed. The result is a sequence of in-between images when played sequentially, as in a film loop show, give the appearance of the starting image being transformed to the second image.

Morphing is made up of a collection of image processing algorithms. The two major groups are: warps and blends. Do not confuse this with morphology.

morphology

A neighborhood image-processing algorithm similar to image convolution except that Boolean logic is applied instead of arithmetic. There are two types of morphology, binary and grayscale. Both have similar operation but are carried out differently because of the data width. The four major operations are:

  • Erode - a filter that makes bright objects smaller.
  • Dilation - a filter that makes bright objects larger.
  • Opening - erosion followed by dilation.
  • Closing - dilation followed by erosion.

Do not confuse with morphing.

MPEG

Motion Pictures Experts Group. An ISO specification for the compression of digital-broadcast quality full-motion video and sound.

N

neighborhood process

A class of image-processing routines that works on neighborhoods of pixels. Each pixel in the new image is computed as a function of the neighborhood of the pixel from the original pixel. The neighborhood ID is defined by a kernel that is set once for each image to be processed.

NotateXpress

NotateXpress is an invisible-at-runtime (windowless) control that adds powerful annotation functionality to the Accusoft ImagXpress component. NotateXpress enables annotation capability both programmatically and through application end-user interaction.

O

overlay

An image or sub-image that can be placed over a given image. The pixels from the original image are not altered but the overlay can be viewed as if they had been. Usually used to place temporary text and annotation marks, for example, arrows on a image.

P

packed bits

A binary image is usually stored in computer memory (8 pixels per byte). In this case each byte is referred to as being filled with packed bits. This saves space but makes reading and writing any individual pixel harder since most computers cannot directly access memory in chunks smaller than a byte.

palette

A digital image palette is a collection of 3 look-up-tables or "LUTs" that are used to define a given pixel's display color. One LUT is for red, one for green and one for blue. The number of entries in the LUTs depend on the width (in bits) of the image's pixels. A palette image requires its palette in order to be displayed in a fashion that makes sense to the viewer. This is often the case for color 8-bit images. Without a palette describing what color each pixel needs for display, this type of image would most likely be displayed as randomly selected noise. A grayscale palette is one where each of the 3 LUTs are linear. The output is whatever is input to them. Since each color component (R, G, B) is an equal value, any pixels input to them are displayed in a varying shade of gray.

pattern recognition

A sub-discipline of machine vision where images are searched for specific patterns. Optical character recognition or "OCR" is one type of pattern recognition, where images are searched for the letters of the alphabet.

pixel

An abbreviated version of the term PIcture (X) ELement. This is the most fundamental element of a digital image. A digital image is made up of rows and columns of points of light. Each indivisible point of light is a pixel. Each pixel in an image is addressed by its column (x) and its row (y) usually written as the coordinate pair (x, y). An 8-bit pixel can take on one of 256 values. A 24-bit pixel has 3, 8-bit components for each of the primary colors, red, green, and blue.

point process

A class of image processing transforms where every pixel is taken, one at a time from an image, and mathematically transformed into a new value with no input from any other pixel in the image. A point process is a degenerative neighborhood process where the kernel is a matrix of pixels that is 1x1 or in other words a single pixel.

polar coordinates

An alternative to the usual Cartesian method of addressing image pixels. Polar coordinates use the coordinate pair, angle and radius from an origin instead of column and row.

posterize

A special effect that decreases the number of colors or grayscales in an image. The default image pixel contains 256 levels of gray or 256 levels of red, green, and blue. Using this effect reduces these numbers.

pseudocolor

A method of assigning color to ranges of a grayscale image's pixel values. Most often used to highlight subtle contrast gradients or for visually quantifying pixel values. The applied color usually has no correspondence to the original scene. The colors are used only as a guide or highlight.

R

raster

A term that describes a single row of a digital image. A raster image is made up of rows of pixels. This is opposed to vector images, where an image is made up of a list of polygon nodes. A raster is sometimes called a scan-line.

relative coordinates

Relative coordinates refer to position, as identified as the distance from a local origin.

render

The process of displaying an image. The final and actual displayed image is said to be rendered.

resolution

There are two types of resolution in digital images; spatial and intensity. Spatial resolution is the number of pixels per unit of length along the x and y axis. Intensity resolution is the number of quantized levels that a pixel can have.

RGB

Red, Green, Blue. A triplet of numeric values that describe a color.

RGBQUAD

Red, Green, Blue, Quad. A set of four numbers used to describe a color. The forth number is always set to zero. This creates an efficient color LUT or palette. It is more efficient because most computers find multiplying by 4 easier then by 3, as is the case in an RGB triplet.

ROI

Region Of Interest. A region of interest or ROI is a specification and date structure that allows for the definition of arbitrarily shaped regions within a given image, often called sub-images. A ROI can be thought of as a place holder which remembers a location within an image. ROIs are of several types, each defined in a manor that makes sense for its type.

ROIs are either a rectangle (also called an AOI), square, circle, or a segment list. A rectangle is defined by any two points in the image. From these two points one and only one rectangle can be drawn. A square is defined by a single point and a single length. A circle is defined by its center and radius. A segment list is an arbitrary list of triplets (x, y, xlen); a single point and a length to the right.

Every point in an image is either inside or outside of a given ROI.

Most image processing functions in this package work only within a given ROI. The ROI can encompass the entire image.

S

screen coordinates

Screen coordinates are those of the actual graphics display controller. The origin is almost always at the upper left-hand corner of the display.

segment

A contiguous section of a raster line. It is defined in physical coordinates by the triplet of its left most point and length (x, y, length).

skew

A skew is image distortion that often occurs when a scanner is sampling an image and the image slides to either side before the scan is complete. This has the effect of transforming squares into rhombuses.

special effects

Any image processing transform that is applied mostly for its artistic value. Special effects include, wipes, transitions, barn doors, etc.

stretch intensity

An image processing method that takes a given image and assures that the intensity distribution fills the entire range of possible values. An 8-bit image that is stretched always has at least one pixel with a value of zero and one of 255. The term comes from the before and after histogram of the given image. A stretch operation linearly stretches a histogram so that is ranges from the minimum pixel value to the maximum pixel value.

T

thumbnail

A small copy of an image. Thumbnails are used to display many images on the screen at once.

transform

An algorithm that takes an image, alters it, and outputs a new image. Sometimes written as `xform'.

triplet

Three numbers used together to represent a single quantity or location, for example, RGB or (x, y, z).

V

video stream

A sequence of still images that are transmitted and displayed in synchronous order that give the appearance of live motion.

W

warp

A geometric image processing routine that distorts an image by spatially compressing and stretching regions.

world coordinates

The real valued coordinates that make sense for the object, treating it as if it really exists. The world coordinates of a house on a map would be in miles or longitude and latitude. This is the opposite of screen, device or model coordinates.

X

x, y

A mathematical method for referring to a pixel from a digital image. Since most digital images are maintained as a Cartesian matrix of pixels, each pixel has a unique address that can be described as an x or horizontal displacement from the origin and a y or vertical displacement from the origin.

xform

Shorthand for transform.

Y

YIQ

(Y) luminance, (I), (Q). YIQ is the color model used for U.S. commercial television. It was designed to be backwards compatible with the old black and white television sets. "Y" or luminance is a weighted average of the red, green, and blue that gives more weight to red and green than to blue. The I and Q contain the color components. Together they are called chromoticity.

Z

Z

A mathematical method that refers to a pixel's intensity from a digital image. An image can be written as: I(x,y)=z


Upgrading from v16 or Earlier
User Guide > Concepts > Upgrading from v16 or Earlier

ImageGear for .NET version 17 introduced multiple assemblies. The application can use a subset of assemblies, according to its needs. ImageGear for .NET Assemblies provides a complete list of assemblies, their corresponding namespaces, and their dependencies.

Important aspects related to the usage of multiple assemblies are discussed in the following sections:

  • Assembly Initialization
  • Resolving Assembly Cross-Dependencies
  • Migrating from Previous Versions


Initialize Assemblies
User Guide > Concepts > Upgrading from v16 or Earlier > Initialize Assemblies

The following ImageGear assemblies require explicit initialization at application startup:

Assembly | Initialization Method
ImageGear22.Formats.Advanced.dll | ImGearAdvancedFormats. Initialize Method
ImageGear22.Formats.CameraRaw.dll | ImGearCameraRawFormats. Initialize Method
ImageGear22.Formats.Common.dll | ImGearCommonFormats. Initialize Method
ImageGear22.Formats.SimplifiedMetadata.dll | ImGearSimplifiedMetadata. Initialize Method

The following ImageGear assemblies require both initialization and termination:

Assembly | Initialization and Termination Methods
ImageGear22.Formats.Pdf.dll | ImGearPDF. Initialize Method ImGearPDF. Terminate Method

The order in which format filter assemblies are initialized is important, because it defines format detection priority.

CameraRaw formats should be initialized before Common formats, because many camera raw formats use custom versions of TIFF. If the application initializes Common formats before Camera Raw formats, ImageGear can incorrectly detect camera raw files as TIFF. Advanced formats will usually be initialized last, to allow for faster detection of Camera Raw and Common formats.

The following initialization order is recommended:

C#
Copy Code
ImGearCameraRawFormats.Initialize();
ImGearCommonFormats.Initialize();
ImGearAdvancedFormats.Initialize();

CUT format (supported in ImageGear22.Formats.Advanced assembly) doesn't have a specific signature in the file's header, which makes its detection less reliable. Detection of this format in ImageGear is disabled by default.

Headerless Camera Raw format (supported in ImageGear22.Formats.CameraRaw assembly) doesn't have a file header, which makes its detection less reliable. Detection of this format in ImageGear is disabled by default.

If you enable detection of these formats, it is recommended that you move them to the end of the global formats list, as follows:

C#
Copy Code
IImGearFormat headerlessRawFormat = ImGearFileFormats.Filters.Get(ImGearFormats.HeaderlessRaw);
ImGearFileFormats.Filters.Remove(ImGearFormats.HeaderlessRaw);
ImGearFileFormats.Filters.Add(headerlessRawFormat);

The PDF initialize method does not add PDF and PostScript formats to the global format filter list, so the order in which ImageGear22.Formats.Pdf assembly is initialized, in relation to other assemblies, is not important. PDF and PostScript formats should be added explicitly by calling:

C#
Copy Code
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePDFFormat());
ImGearFileFormats.Filters.Insert(0, ImGearPDF.CreatePSFormat());

The order in which ImageGear22.Formats.SimplifiedMetadata assembly is initialized in relation to other assemblies is not important.

Office formats (supported in ImageGear22.Formats.Office assembly) and XPS format (supported in ImageGear22.Wpf assembly) have similar signatures in the file's header. To ensure proper detection, Office formats should be initialized before XPS.

C#
Copy Code
ImGearFileFormats.Filters.Add(ImGearOffice.CreateWordFormat());
ImGearFileFormats.Filters.Add(ImGearXPS.CreateXPSFormat());


Resolve Assembly Cross-Dependencies
User Guide > Concepts > Upgrading from v16 or Earlier > Resolve Assembly Cross-Dependencies

ImageGear provides the following interfaces and abstract classes to help avoid cross-dependencies between components.

  • IImGearDICOMDisplaySettings Interface
  • ImGearAnnotationPage Class
  • ImGearFormatMetadata Class


IImGearDICOMDisplaySettings Interface
User Guide > Concepts > Upgrading from v16 or Earlier > Resolve Assembly Cross-Dependencies > IImGearDICOMDisplaySettings Interface

The DICOMDisplaySettings Property of ImGearRasterPage Class, as well as DICOMDisplaySettings Property of ImGearPageDisplay Class, use IImGearDICOMDisplaySettings Interface type. IImGearDICOMDisplaySettings Interface has a small set of public members that are used for displaying a DICOM image. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings Interface to the actual class ImGearDICOMDisplaySettings Class, which is defined in the ImageGear22.Formats.Dicom assembly. The following two examples demonstrate this:

ImageGear v16 Example
Copy Code
ImGearRasterPage rasterPage;
// Load an image into rasterPage
// a
// If the image does not have a DICOMDisplaySettings object attached, create and add one.
if (rasterPage.DICOMDisplaySettings == null)
 rasterPage.DICOMDisplaySettings = new ImGearDICOMDisplaySettings();
ImGearDICOMDisplaySettings displaySettings = rasterPage.DICOMDisplaySettings;
// Set Display VOI Transform to automatically calculated values
if (displaySettings != null)
 displaySettings.SetAutoVOITransform(rasterPage);
ImageGear v17 Example
Copy Code
ImGearRasterPage rasterPage;
// Load an image into rasterPage
// a
// If the image does not have a DICOMDisplaySettings object attached, create and add one.
if (rasterPage.DICOMDisplaySettings == null)
 rasterPage.DICOMDisplaySettings = new ImGearDICOMDisplaySettings();
ImGearDICOMDisplaySettings displaySettings = rasterPage.DICOMDisplaySettings as ImGearDICOMDisplaySettings;
// Set Display VOI Transform to automatically calculated values
if (displaySettings != null)
 displaySettings.SetAutoVOITransform(rasterPage);


ImGearAnnotationPage Class
User Guide > Concepts > Upgrading from v16 or Earlier > Resolve Assembly Cross-Dependencies > ImGearAnnotationPage Class

The ARTPage Property of ImGearPageDisplay Class uses ImGearAnnotationPage Class type. ImGearAnnotationPage Class is an abstract class that does not have any public members. If the application works with annotations, it shall cast ImGearPageDisplay. ARTPage Property to the actual class ImGearARTPage Class, defined in the ImageGear22.Art assembly. The following two examples demonstrate this:

ImageGear v16 Example
Copy Code
ImGearPage page;
ImGearPageView pageView = new ImGearPageView();
// Load an image into ImGearPage, create ImGearPageDisplay for it, and load annotations
// a
// Now remove annotations
ImGearARTPage artPage = pageView.Display.ARTPage;
if (artPage != null)
 artPage.RemoveMarks();
ImageGear v17 Example
Copy Code
ImGearPage page;
ImGearPageView pageView = new ImGearPageView();
// Load an image into ImGearPage, create ImGearPageDisplay for it, and load annotations
// a
// Now remove annotations
ImGearARTPage artPage = pageView.Display.ARTPage as ImGearARTPage;
if (artPage != null)
 artPage.RemoveMarks();


ImGearFormatMetadata Class
User Guide > Concepts > Upgrading from v16 or Earlier > Resolve Assembly Cross-Dependencies > ImGearFormatMetadata Class

The TIFF Property, EXIF Property, IPTC Property and XMP Property of ImGearMetadataHead Class, defined in the ImageGear22.Core assembly, use ImGearFormatMetadata Class type. ImGearFormatMetadata Class does not have any public members. If the application uses Simplified Metadata API, it shall cast TIFF, EXIF, IPTC and XMP properties to actual classes ImGearTIFFMetadata Class, ImGearEXIFMetadata Class, ImGearIPTCMetadata Class and ImGearXMPMetadataRoot Class, respectively. These classes are defined in the ImageGear22.Formats.SimplifiedMetadata assembly. The following two examples demonstrate this:

C#
Copy Code
using ImageGear.Formats.XMP;
ImGearPage page;
// Load an image into ImGearPage
// a
String description = "<Empty>";
if (imGearPage.Metadata.XMP != null)
{
 ImGearXMPMetadataRoot xmp = imGearPage.Metadata.XMP as ImGearXMPMetadataRoot;
 if ((xmp.DublinCore != null) &&
  (xmp.DublinCore.Description != null) &&
  (xmp.DublinCore.Description.Default != null))
   description = xmp.DublinCore.Description.Default;
}
VB.NET
Copy Code
Imports ImageGear.Formats.XMP
Dim imGearPage As ImGearPage
' Load an image into ImGearPage
' ...
imGearPage = igPage
Dim description As String = "<Empty>"
If imGearPage.Metadata.XMP IsNot Nothing Then
   Dim xmp As ImGearXMPMetadataRoot = imGearPage.Metadata.XMP
   If ((xmp.DublinCore IsNot Nothing) And (xmp.DublinCore.Description IsNot Nothing) And (xmp.DublinCore.Description.Default IsNot Nothing)) Then description = xmp.DublinCore.Description.Default
   End If
End If


Migrate from Previous Versions
User Guide > Concepts > Upgrading from v16 or Earlier > Migrate from Previous Versions

ImageGear for .NET, up to version 16.x, used a single assembly for all its features. Starting with version 17, all ImageGear for .NET functionality is split into smaller assemblies. The application can use a subset of assemblies, according to its needs.

Perform the following steps to port an application from a single-assembly to a multi-assembly version of ImageGear:

  1. Replace the reference to the old ImageGear assembly with references to ImageGear assemblies that the application needs to use.
  2. Add initialization for components that require it. See Assembly Initialization for the list of components that require initialization.

If the application uses file formats metadata API, DICOM Display Settings, or annotations, add casting to classes that expose actual functionality. See Resolving Assembly Cross-Dependencies for details.

A number of methods that belonged to ImGearRasterProcessing Class have been moved to the new ImGearEffects Class. Corresponding methods from ImGearRasterProcessingVerifier Class have been moved to the new ImGearEffectsVerifier Class. See the new ImGearEffects Class for the methods that have been moved to this class.

The following table lists the mapping between ImageGear v16 and current assemblies. Note, however, that you do not have to use all of the assemblies. You only need to use assemblies that provide the desired functionality, and the assemblies upon which they depend. ImageGear for .NET Assemblies provides assembly dependency information. Assembly Dependencies provides assembly dependency information.

ImageGear v16 Assemblies | ImageGear Current Assemblies
ImageGearV16n.dll | ImageGear22.Art.dll ImageGear22.Core.dll ImageGear22.Formats.Advanced.dll ImageGear22.Formats.CameraRaw.dll ImageGear22.Formats.Common.dll ImageGear22.Formats.Dicom.dll ImageGear22.Formats.Jpeg2k.dll ImageGear22.Formats.Pdf.dll ImageGear22.Formats.SimplifiedMetadata.dll ImageGear22.Formats.Vector.dll ImageGear22.Presentation.dll (FW 3.0) ImageGear22.Processing.Advanced.dll ImageGear22.Twain.dll
IGWinFormsV16n.dll | ImageGear22.Art.Forms.dll ImageGear22.Windows.Forms.dll
IGWpfV16n.dll | ImageGear22.Wpf.dll
IGWebFormsV16n.dll | ImageGear22.Web.dll


Licensing and Distributing
User Guide > Licensing and Distributing

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups or watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime (Non-Node-Locked) Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime (Node-Locked) Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime (Node-Locked) Licensing using the Licensing Development Kit (LDK): In this model, you embed calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.


Evaluation Licensing
User Guide > Licensing and Distributing > Evaluation Licensing

During evaluation of Accusoft products, Evaluation licenses can be used to try out products. This license permits an Accusoft product or toolkit to be used on a system, whether it is a development machine or any other type of system. This type of license is best noted by an Evaluation dialog displaying occasionally while the product is in use. Once the Evaluation dialog is dismissed, the product will continue to operate. Other forms of Evaluation or trial behavior include the watermarking of images when displayed or saved. When an Accusoft product is first installed onto a system, if no other license currently exists on the machine (and no other license is provided by the user during the installation), an Evaluation license will be placed on the system by default.

No licensing calls are necessary to run the product in Evaluation mode. To switch between Watermark and Dialog mode of Evaluation Licensing, use the ImGearEvaluationManager Class.

ImGearLicense.SetSolutionName method should no longer be used to initialize Evaluation licensing.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

When ImageGear is being evaluated for use on a web server, product behavior is limited by watermarks rather than dialog pop-ups.

When you determine the product is a good fit, you can purchase a Toolkit License to eliminate trial dialog pop-ups or watermarks.


Toolkit Licensing
User Guide > Licensing and Distributing > Toolkit Licensing

A Development, or Toolkit license is intended to allow users to develop application projects using Accusoft software development toolkits and remove the evaluation/trial behavior. The development license is not intended for deployment or production scenarios.

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer. This section provides information about the following:

  • Toolkit Licensing
    • Assigned Toolkit License
    • License Manager
    • Product Editions
    • Registration
    • Developing Code


Assigned Toolkit License
User Guide > Licensing and Distributing > Toolkit Licensing > Assigned Toolkit License

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft's website prior to the assignment of licenses. The organization's designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager
User Guide > Licensing and Distributing > Toolkit Licensing > License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit Licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


Product Editions
User Guide > Licensing and Distributing > Toolkit Licensing > Product Editions

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple Evaluation licenses, one Evaluation license per edition.

Selecting an Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an Evaluation Toolkit, the Evaluation license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Evaluation license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition Evaluation license and then switch back to their paid, lower-featured Toolkit edition license at any time.


Registration
User Guide > Licensing and Distributing > Toolkit Licensing > Registration

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without pop-ups or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Registering When Connected to the Internet

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password. The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.

Registering When Disconnected from the Internet

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.

    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code
User Guide > Licensing and Distributing > Toolkit Licensing > Developing Code

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.

Starting with ImageGear for .NET v22.0, ImGearLicense.SetSolutionName method should no longer be used to initialize Toolkit licensing.


Runtime Licensing
User Guide > Licensing and Distributing > Runtime Licensing

Runtime licenses are intended for when a development project has been completed and is ready to deploy to an end-user system. It enables the full functionality of the product with respect to the edition under which the license was purchased.

These types of licenses should only be used for client deployments. Deployment or Runtime licenses should not be used on development machines, as this can deplete the amount of available licenses from your license pool (with respect to node-locked licenses).

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported Runtime (Node-Locked). Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported Runtime (Non-Node-Locked). Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Runtime Licensing
    • Automatically Reported Runtime (Node-Locked)
      • Licensing API
      • License Pools
      • License Configuration Files
      • LDK vs. SLU
        • Server Licensing Utility (SLU)
        • Licensing Development Kit (LDK)
      • Deployment Proxy Service (DPS)
    • Manually Reported Runtime (Non-Node-Locked)


Automatically Reported Runtime (Node-Locked)
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit (LDK) component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility (SLU).

The Licensing Development Kit (LDK) requires integration with the application or installation utility to perform license activation.

The Server Licensing Utility (SLU) is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This section provides information about the following:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)


Licensing API
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

The Licensing API is used in the developer's code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is:

  • The name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the ImGearLicense.SetSolutionName method.

For example:

Copy Code
ImGearLicense.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is:

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • The identity of the organization that purchased the runtime licenses.
  • Set via the ImGearLicense.SetSolutionKey method.

For example:

Copy Code
ImGearLicense.SetSolutionName("ACMEImaging");
ImGearLicense.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImageGear, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility (SLU) or Licensing Development Kit (LDK) to activate licenses when the customer's application is installed on their users' systems.


LDK vs. SLU
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Both the Licensing Development Kit (LDK) and the Server Licensing Utility (SLU) perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility (SLU) may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility (SLU) to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Development Kit (LDK), which allows you to integrate the registration process into your application. The Licensing Development Kit (LDK) also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

When running the SLU.exe (C:\Users\Public\Documents\Accusoft\ImageGear.NET\Licensing\Deployment\SLU.exe), right-click and choose Run as administrator. This will ensure that the licensing information is successfully added to the system’s registry.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.

  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet.

    • Auto Register Toolkit (Connected to Internet)

      Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system's hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

      When running in Automatic mode, the Server License Utility will attempt to contact the Accusoft license server to obtain a license from your deployment pool. If this communication attempt fails, the SLU will place a temporary license on the machine that will last for 14 days. This action is also displayed in a message box to the user. If you encounter this, you can run the SLU and perform the manual steps to obtain a license for the machine.

    • Manually Register Toolkit (Disconnected from Internet)

      Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

    1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
    2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
    3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
    4. Return to the offline system with the removable media device onto which you have saved the license file.
    5. Click Open License File and navigate to the license file. Click OK in the file selection dialog. Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
    6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility (SLU). (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains the following sections:
  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility (SLU). It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

The files for the SLU and LDK (slu.exe and AccuLicClient.dll) are stored on the development machine by the product installer. You can find them at C:\Users\Public\Documents\Accusoft\ImageGear.NET\Licensing\Deployment\...

Assigned Access Keys

Unlike the Server Licensing Utility (SLU), the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility (SLU) section. The process is shown in the C# sample code below:

C#
Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day
    // expiration.

    if (ldk.ResultCode ==
enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection - Optionally do manual
        // registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility (SLU) section. The process is shown in the C# code below:

C#
Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

C#
Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey =
ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

C#
Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
[propget, id(1)] HRESULT LicKey ( [out, retval] BSTR* pVal );
[propput, id(1)] HRESULT LicKey ( [in] BSTR newVal );
[propget, id(2)] HRESULT srvURL ( [out, retval] BSTR* pVal );
[propput, id(2)] HRESULT srvURL ( [in] BSTR newVal );
[propget, id(3)] HRESULT ConfigPath ( [out, retval] BSTR* pVal );
[propput, id(3)] HRESULT ConfigPath ( [in] BSTR newVal );
[propget, id(4)] HRESULT ResultString ( [out, retval] BSTR* pVal );
[propget, id(5)] HRESULT ResultCode ( [out, retval] enumLdkErrorCodes* pVal );
[id(6)] HRESULT GetLicKeyAuto ( [in] BSTR accKey );
[id(7)] HRESULT GetHdwKey ( [in] BSTR accKey
, [out,retval] BSTR* hdwKey );
[id(8)] HRESULT StartEvalPeriod ( void );
[propget] HRESULT LicenseInfo ( [out, retval] BSTR* pVal );
[propput] HRESULT LicenseInfo ( [in] BSTR newVal );
[id(10)] HRESULT GetEvalPeriod ( [out, retval] long* pVal );
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft's Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., "c:\config.txt;c:\config2.txt".
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user's system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user's system for a limited time - the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)
User Guide > Licensing and Distributing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime (Node-Locked) Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)
User Guide > Licensing and Distributing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:
  • Solution Name
  • Solution Key
  • OEM License Key

Solution Name

The solution name is:

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the ImGearLicense.SetSolutionName method.

For example:

Copy Code
ImGearLicense.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is:

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the ImGearLicense.SetSolutionKey method.

For example:

Copy Code
ImGearLicense.SetSolutionName("ACMEImaging");
ImGearLicense.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.

OEM License Key

The OEMLicense Key is:

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the ImGearLicense.SetOEMLicenseKey method, the component is completely licensed and can be distributed without any further licensing operations.

C#
Copy Code
ImGearLicense.SetSolutionName("ACMEImaging");
ImGearLicense.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
ImGearLicense.SetOEMLicenseKey("2.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This method is not required for Automatically Reported Runtime licensing.


Deploying Your Product
User Guide > Licensing and Distributing > Deploying Your Product

The first step in deploying your application is to package the required ImageGear run-time components. To do this, you run the Deployment Packaging Wizard to identify and generate the ImageGear run-time components required by your application. The Deployment Packaging Wizard packages the required components and stores them into a specified output folder, creating sub-folders for the run-time and licensing components.


Running the Deployment Packaging Wizard
User Guide > Licensing and Distributing > Deploying Your Product > Running the Deployment Packaging Wizard

To package the required ImageGear Runtime components, do the following:

  1. From the Start menu, choose the "...\Programs\Accusoft\ImageGear for .NET v22\Licensing\Deployment" folder and run the Deployment Packaging Wizard program.
  2. Enter the path where you want to place the components and click the Next button to continue.

  3. In the ImageGear Run-Time Components form, select the type of ImageGear runtime components you would like to generate, then select the components you would like to include into the installation package for your application. Click Next to continue.

  4. In the ImageGear Licensing Components form, check whether you want to generate the ImageGear licensing components, add the Server Licensing Utility (SLU), or to have no licensing (default for User). Click the Next button to continue.

  5. Finally, you can see a list of all the selected components that will be generated for your deployment. If this looks correct, click the Finish button to complete the Deployment Packaging process.

Once the Deployment Packaging process is finished, the Deployment Packaging Wizard reports its successful completion.

Now you can take the files that the Deployment Packaging Wizard created for you and include them into the installation package along with your application.


Licensing ASP.NET Components
User Guide > Licensing and Distributing > Licensing ASP.NET Components

Please refer to Licensing ASP.NET Components in the ASP.NET Web.Config Editor Application for information.


Distributing an ImageGear Application
User Guide > Licensing and Distributing > Distributing an ImageGear Application
  • A managed code application using the 32-bit version of ImageGear for .NET must target the x86 platform. The toolkit will be running as a 32-bit process on a 32-bit machine or as a 32-bit process on a 64-bit machine.
  • A managed code application using the 64-bit version of ImageGear for .NET must target the x64 platform. The toolkit will be running as a 64-bit process on a 64-bit machine.

Starting with v22, ImageGear for .NET provides NuGet Packages to simplify the packaging process. NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework.

If, however, you prefer to handle this manually, this topic provides information about the assemblies and their dependencies.

  1. You must always distribute your application along with the assemblies that enable the capabilities you're using and their dependencies. See Assembly Dependencies.
  2. In addition, you must include the following:
    If Your Application Uses... | Include...
    ImageGear.Formats.JPEG2K | igjpeg2k22nu.dll
    ImageGear.Vector
    and/or
    ImageGear.Formats.[CAD/CGM/DGN/DWF/HPGL]     		igvect22nu.dll
    ImageGear.Formats.CAD

    igvect22nu.dll
    igcad22nu.dll

    ImageGear.Formats.DWF

    igvect22nu.dll
    igdwf22nu.dll

    ImageGear.Formats.PDF | See Distributing PDF and PS Fonts and Libraries with an Application
    ImageGear.Recognition | See Distributing Recognition Engine Files with an Application
    ImageGear.Web.DataProviders
    and/or
    ImageGear.Web.UI     		See Distributing an ImageGear for an ASP.NET Application


Assembly Dependencies
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Assembly Dependencies

Starting with v22, ImageGear for .NET provides NuGet Packages to simplify the packaging process. NuGet packages make it easy to add, remove, and update libraries and tools in Visual Studio projects that use the .NET Framework. If, however, you prefer to handle this manually, the following table provides information about the assemblies and their dependencies.

The following table lists the ImageGear for .NET assemblies, corresponding namespaces, and dependencies. Please also see Using Multiple Assemblies for more information.

Assembly Name | Namespaces | Dependencies | Description

ImageGear22.Core.dll

ImageGear.Core Namespace

ImageGear.Display Namespace

ImageGear.Formats Namespace

ImageGear.Formats.JPG Namespace

ImageGear.Formats.TIF Namespace

ImageGear.Processing Namespace

ImageGear.Processing.Layers Namespace

<none>

Core ImageGear API and enumerations.

Display API.

File format manager, general metadata API.

Metadata dictionary API for the file formats.

Image processing API available in ImGearProcessing Class.

See ImGearRasterProcessing Class.

ImageGear22.Art.dll

ImageGear.ART Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Vector.dll

Annotation API.

ImageGear22.Art.Forms.dll

ImageGear.ART.Forms Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Vector.dll

ImageGear22.Windows.Forms.dll

WinForms Annotation controls and UI.

ImageGear22.Art.Windows.Controls.dll

ImageGear.ART.Windows.Controls Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Presentation.dll

ImageGear22.Windows.Controls.dll

WPF Annotation controls and UI.

ImageGear22.Barcode.dll | ImageGear.Barcode Namespace | ImageGear22.Core.dll | Provides a set of objects that provide access to barcode recognition technology.
ImageGear22.Dicom.Forms.dll ImageGear.Dicom.Forms

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Art.Forms.dll

ImageGear22.Formats.Dicom.dll

ImageGear22.Windows.Forms.dll

 Provides functionality to support the end user’s interaction and Windows Forms UI for multi-planar reconstruction (MPR).
ImageGear22.Evaluation.dll ImageGear.Evaluation Namespace

ImageGear22.Core.dll

ImageGear22.Presentation.dll

 Provides the evaluation manager used for product evaluation either in trial dialog mode (default) or watermarks mode.

ImageGear22.Formats.Advanced.dll

ImageGear.Formats Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

The following raster file formats: PSD, PCX, DCX, PCD, PBM, RAS, MSP, Scitex CT, SGI, IFF, WPG, CAL, BTR, IMR, IMT, KFX, LV, NCR, GEM, WBMP, XWD, XBM, XPM, IBM IOCA, IBM MO:DCA, TGA, CUT.

ImageGear22.Formats.CameraRaw.dll

ImageGear.Formats Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

The following digital camera raw formats: CRW, ORF, PEF, NEF, DNG, KodakRAW, SonyRaw, LeicaRAW, MOS, MEF, CR2, Imacon Raw, MRW, RAF, Headerless Camera Raw.

ImageGear22.Formats.Common.dll

ImageGear.Formats Namespace

ImageGear.Formats.EXIF Namespace

ImageGear.Formats.TIF Namespace

ImageGear22.Core.dll

BMP, ICO, CUR, CLP, PNG, GIF, TIFF and JFIF file formats. CCITT, Deflate, LZW, JPEG compressions. EXIF metadata.

ImageGear22.Formats.Dicom.dll

ImageGear.Core Namespace

ImageGear.Formats.DICOM Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Common.dll

ImageGear22.Formats.Jpeg2k.dll

ImageGear22.Formats.Vector.dll

DICOM file format.

ImageGear22.Formats.Jpeg2k.dll

ImageGear.Formats.JPEG2K Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

JPEG 2000 compression and the JPEG 2000 file format.

ImageGear22.Formats.Office.dll ImageGear.Formats.Office Namespace

ImageGear22.Core.dll

ImageGear22.Presentation.dll

ImageGear22.Formats.Vector.dll

 Provides support for Microsoft Office formats.

ImageGear22.Formats.Pdf.dll

ImageGear.Formats.PDF Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Common.dll

ImageGear22.Formats.Vector.dll

PDF and PostScript file formats, PDF editing API.

ImageGear22.Formats.SimplifiedMetadata.dll

ImageGear.Formats Namespace

ImageGear.Formats.EXIF Namespace

ImageGear.Formats.IPTC Namespace

ImageGear.Formats.TIF Namespace

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

Simplified EXIF, IPTC and XMP Metadata API.

ImageGear22.Formats.Vector.dll

ImageGear.Formats.CAD Namespace

ImageGear.Formats.CGM Namespace

ImageGear.Formats.DGN Namespace

ImageGear.Formats.DWF Namespace

ImageGear.Formats.HPGL Namespace

ImageGear.Formats.SVG Namespace

ImageGear.Formats.U3D Namespace

ImageGear.Vector Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

Vector drawings API.

DWG, DXF, CGM, DGN, DWF, HPGL, SVG, and U3D vector file formats.

ImageGear22.Presentation.dll (FW 3.0)

ImageGear.ART Namespace

ImageGear.Display Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

WPF Display API and annotation renderer.

ImageGear22.Processing.Advanced.dll

ImageGear.FreqIP Namespace

ImageGear.Processing Namespace

ImageGear.Processing.ImageClean Namespace

ImageGear22.Core.dll

Image processing API in frequency domain (ImageGear for .NET 32-bit only).

Image processing effects available in ImGearEffects Class.

Document cleaning API available in ImGearIC Class.

ImageGear22.Recognition.dll

ImageGear.Recognition Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Pdf

Provides a set of objects that provide access to document recognition technology.

ImageGear22.Recognition.Forms.dll

ImageGear.Recognition.Forms Namespace

ImageGear22.Core.dll

ImageGear22.Art

ImageGear22.Art.Forms

ImageGear22.Recognition

ImageGear22.Windows.Forms

Provides recognition-related user interface functionality.

ImageGear22.Twain.dll

ImageGear.TWAIN Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

TWAIN scanning API.

Available on ImageGear for .NET 32-bit only.

ImageGear22.Web.dll

ImageGear.Web.UI Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Web.Services.dll

The PageView, ThumbnailList and ThumbnailView web controls in ImageGear.Web.UI Namespace support easy creation of web-based imaging systems.

ImageGear22.Web.ImageDataProcessor.dll

ImageGear.Web.UI Namespace

ImageGear22.Core.dll

ImageGear22.Formats.Common.dll

ImageGear22.Formats.Advanced.dll

ImageGear22.Formats.CameraRaw.dll

ImageGear22.Formats.Dicom.dll

ImageGear22.Formats.Jpeg2k.dll

ImageGear22.Formats.Office.dll

ImageGear22.Formats.Pdf.dll

ImageGear22.Formats.Vector.dll

The Image Data Processor decodes and processes images on the server and delivers them for viewing to the client PageView and the ThumbnailView controls.

ImageGear22.Web.Services.dll

ImageGear.Web.DataProviders Namespace

ImageGear.Web.UI Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Common.dll

ImageGear22.Formats.CameraRaw.dll

ImageGear22.Formats.Jpeg2k.dll

ImageGear22.Formats.Pdf.dll

ImageGear22.Web.ImageDataProcessor.dll

 ImageGear.Web.DataProviders Namespace is an extensible and decoupled module used by the PageView, ThumbnailList and the ThumbnailView components for the delivery of Images for viewing. The architecture is based on the ASP.NET provider model.

ImageGear22.Windows.Controls.dll

ImageGear.Core Namespace

ImageGear.Windows.Controls Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Pdf.dll

ImageGear22.Presentation.dll

ImageGear22.Windows.Controls.Art.dll

WPF Page View and other common controls to simplify development of XAML based applications.

ImageGear22.Windows.Controls.Art.dll ImageGear.Windows.Controls Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Presentation.dll

 Provides WPF Annotation controls and UI.
ImageGear22.Windows.Controls.Dicom.dll ImageGear.Windows.Controls Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Dicom.dll

ImageGear22.Presentation.dll

 Provides functionality to support the end user’s interaction and WPF UI for multi-planar reconstruction (MPR).

ImageGear22.Windows.Forms.dll

ImageGear.Windows.Forms Namespace

ImageGear.Windows.Forms.Thumbnails Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Formats.Dicom.dll

ImageGear22.Formats.Pdf.dll

ImageGear22.Formats.Vector.dll

Win Forms ImGearPageView Class and other common controls to simplify development of the Win Forms based applications.

ImageGear22.Wpf.dll

ImageGear.WPF Namespace

ImageGear.WPF.BitmapSourceConversion Namespace

ImageGear.WPF.XPS Namespace

ImageGear.WPF.HDP Namespace

ImageGear22.Core.dll

ImageGear22.Art.dll

ImageGear22.Windows.Forms.dll

WPF component enables HD Photo and XPS file formats, BitmapSource converters and UI controls.


Distributing PDF and PS Fonts and Libraries with an Application
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing PDF and PS Fonts and Libraries with an Application

The Deployment Packaging Wizard (DPW) helps to package all the libraries, resources, and dependencies listed below (except for Microsoft runtime).

To distribute an application that uses ImageGear.Formats.PDF namespace you must include into the distribution package the native ImageGear PDF library - igpdfXXnu.dll (where "XX" is the version) along with the ImageGear for .NET assembly and the following PDF resources:

Adobe PDF libraries:

  • DL100ACE.dll
  • DL100AdobeXMP.dll
  • DL100AGM.dll
  • DL100ARE.dll
  • DL100AXE8SharedExpat.dll
  • DL100BIB.dll
  • DL100BIBUtils.dll
  • DL100CoolType.dll
  • DL100JP2KLib.dll
  • DL100PDFL.dll
  • DL100PDFlattener.ppi
  • DL100PDFPort.dll
  • DL100pdfsettings.dll
  • Icucnv40.dll
  • Icudt40.dll

Adobe PostScript libraries:

  • DL100nserver.dll
  • All Adobe PDF libraries listed above

The PDF component needs the following Microsoft component to be installed:

  • Visual C++ CRT 10.0

This can be installed with one of the following merge modules:

  • Microsoft_VC100_CRT_x86.msm (Windows 32-bit version)
  • Microsoft_VC100_CRT_x64.msm (Windows 64-bit version)

Distributing PDF and PS Fonts with an Application

The ImageGear toolkit comes with multiple PDF and PS fonts that can be used for developing an application based on ImageGear. However only four fonts are pre-licensed for distribution:

  • The two MultiMaster PDF fonts, AdobeSansMM (zx______.mmm) and AdobeSerifMM (zy______.mmm).
  • The two PostScript fonts, Courier and NotDefFont.

These fonts are the property of Adobe® Systems and are fully licensed for distribution with your application.

If you need to distribute the additional fonts, you need to get a license for the redistribution of those fonts. You are however not limited to the fonts supplied with ImageGear; it's possible to add other fonts to be used with ImageGear PDF/PostScript support. To do this, place your fonts to the PDF Resource directory as follows:

  • CID fonts (if any) to ...\Resource\PDF\CIDFont
  • CMaps fonts to ...\Resource\PDF\CMap
  • PDF fonts to ...\Resource\PDF\Font
  • PostScript fonts to ...\Resource\PS\Fonts

Please also note that the fonts that are pre-licensed for distribution (i.e., AdobeSansMM, AdobeSerifMM, "Courier" and "NotDefFont") provide the substitution capabilities for the other fonts, so they are likely to be enough for many cases. The below paragraph provides more technical details regarding fonts substitution.

The multiple master font format is an extension of the Type 1 font format that allows the generation of a wide variety of typeface styles from a single font program. This is accomplished through the presence of various design dimensions in the font. Examples of design dimensions are weight (light to extra-bold) and width (condensed to expanded). Coordinates along these design dimensions (such as the degree of boldness) are specified by numbers. A particular choice of numbers selects an instance of the multiple master font. Adobe® Technical Note #5015, Type 1 Font Format Supplement, describes multiple master fonts in detail.


Distributing Recognition Engine Files with an Application
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing Recognition Engine Files with an Application

To distribute an application that uses ImageGear.Recognition Namespace, you must include into the distribution package the Recognition engine files and their dependencies. The set of files needed depends on the type(s) of recognition performed by the application.

Deploying an application that uses the ImageGear Recognition Component requires the following merge modules to be installed:

32-Bit:

  • Microsoft_VC100_CRT_x86.msm (http://www.microsoft.com/en-us/download/details.aspx?id=5555)
  • Microsoft_VC100_MFC_x86.msm

64-Bit:

  • Microsoft_VC100_CRT_x64.msm (http://www.microsoft.com/en-us/download/details.aspx?id=14632)
  • Microsoft_VC100_MFC_x64.msm

and redistributing the following dependencies:

32-Bit:

  • .NET FW 4.0 (x86) (http://www.microsoft.com/en-us/download/details.aspx?id=17851)
  • MSXML 4.0 (x86) (http://www.microsoft.com/en-us/download/details.aspx?id=15697)

64-Bit:

  • .NET FW 4.0 (x64) (http://www.microsoft.com/en-us/download/details.aspx?id=17851)
  • MSXML 6.0 (x64) (http://www.microsoft.com/en-us/download/details.aspx?id=3988)

Refer to the following sections for more information:

  • Distributing Core Recognition Files
  • Distributing Recognition Engine Files for the Western OCR Feature
  • Distributing Recognition Engine Files for the Asian OCR Feature
  • Distributing Recognition Engine Files for the Formatted Output Feature
See Also
Distributing an ImageGear Application


Distributing Core Recognition Files
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing Recognition Engine Files with an Application > Distributing Core Recognition Files

Core files needed by the Recognition engine:

asciieng.lng | Bnt.dll | Bold300.knb
CharSetTable.chr | CRX.dll | Dot.dll
english.lng | Firewrx.dll | FireWrx2.dll
FireWrx3.dll | FireWrx4.dll | ICDLLW32.dll
kdu_V43R.DLL | KernelAPI.dll | LATIN1.shp
LATIN2.shp | LogMan.dll | lpdata.bin
Mor.dll | Mor2.dll | Mor3.dll
Mor4.dll | NLSCH_1_0.dll | NLSCH_1_1.dll
NLUtils.dll | NuanceLS.exe | NuanceLS.exe.config
pccext.dll | pccext2.dll | pccext3.dll
pccext4.dll | R_ENG.DAT | RecDiag.dll
Recogn.bct | recogn.set | Recogn24.bct
rndsdawg.dll | rndsinso.dll | sami.set
SPDFLib.dll | ssdoc-schema3.xsd | tudas.fa
vtdata.bin | XIBRTB.BIN | XIBRTC.BIN
XIBRTD.BIN | XIBRTE.BIN | XIBRTP.BIN
XIBRTS.BIN | XIBRTZ.BIN | XIBRZB.BIN
XIBRZC.BIN | XIBRZD.BIN | XIBRZE.BIN
XIBRZP.BIN | XIBRZS.BIN | XIBRZZ.BIN
XIDANB.BIN | XIDANC.BIN | XIDAND.BIN
XIDANE.BIN | XIDANP.BIN | XIDANS.BIN
XIDANZ.BIN | XIDUTB.BIN | XIDUTC.BIN
XIDUTD.BIN | XIDUTE.BIN | XIDUTP.BIN
XIDUTS.BIN | XIDUTZ.BIN | Xiengb.bin
Xiengc.bin | Xiengd.bin | xiengd.dmd
Xienge.bin | Xiengf.bin | xiengl.bin
Xiengp.bin | Xiengs.bin | Xiengz.bin
XIFINB.BIN | XIFINC.BIN | XIFIND.BIN
XIFINE.BIN | XIFINP.BIN | XIFINS.BIN
XIFINZ.BIN | XIFRNB.BIN | XIFRNC.BIN
XIFRND.BIN | XIFRNE.BIN | XIFRNP.BIN
XIFRNS.BIN | XIFRNZ.BIN | XIGRMB.BIN
XIGRMC.BIN | XIGRMD.BIN | XIGRME.BIN
XIGRMP.BIN | XIGRMS.BIN | XIGRMZ.BIN
xiintd.dmd | XIITLB.BIN | XIITLC.BIN
XIITLD.BIN | XIITLE.BIN | XIITLP.BIN
XIITLS.BIN | XIITLZ.BIN | XINRWB.BIN
XINRWC.BIN | XINRWD.BIN | XINRWE.BIN
XINRWP.BIN | XINRWS.BIN | XINRWZ.BIN
XIPRTB.BIN | XIPRTC.BIN | XIPRTD.BIN
XIPRTE.BIN | XIPRTP.BIN | XIPRTS.BIN
XIPRTZ.BIN | XISPNB.BIN | XISPNC.BIN
XISPND.BIN | XISPNE.BIN | XISPNP.BIN
XISPNS.BIN | XISPNZ.BIN | XISWDB.BIN
XISWDC.BIN | XISWDD.BIN | XISWDE.BIN
XISWDP.BIN | XISWDS.BIN | XISWDZ.BIN
xocr.dll | xocr2.dll | xocr3.dll
xocr32b.exe | xocr4.dll |


Distributing Recognition Engine Files for the Western OCR Feature
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing Recognition Engine Files with an Application > Distributing Recognition Engine Files for the Western OCR Feature

Files needed for performing recognition of Western languages:

CYRILLIC.shp | czech.lng | danish.lng
dutch.lng | BALTIC.shp | finnish.lng
french.lng | german.lng | greek.lng
GREEK.shp | hungar.lng | ICHUNW32.dll
italian.lng | lpdata_russian.bin | norsk.lng
polish.lng | port.lng | russian.lng
R_CAT.DAT | R_CZH.DAT | R_DAN.DAT
R_DUT.DAT | R_SPA.DAT | R_FIN.DAT
R_FRE.DAT | R_GER.DAT | R_GRE.DAT
R_HUN.DAT | R_ITA.DAT | R_NOR.DAT
R_POL.DAT | R_POR.DAT | R_RUS.DAT
R_SLN.DMD | xiturd.dmd | R_SWE.DAT
spanish.lng | swedish.lng | turkish.lng
TURKISH.shp | xibrzd.dmd | xiczhd.dmd
xidand.dmd | xidutd.dmd | xifind.dmd
xifrnd.dmd | xigred.dmd | xigrmd.dmd
xihund.dmd | xiitld.dmd | xinrwd.dmd
xipold.dmd | xiprtd.dmd | xispnd.dmd
xiswdd.dmd |  |

Vertical dictionary support files for Western Languages:

dut_legal.dmd | dut_medical.dmd | eng_financial.dmd
eng_legal.dmd | eng_medical.dmd | fre_legal.dmd
fre_med.dmd | ger_legal.dmd | ger_medical.dmd


Distributing Recognition Engine Files for the Asian OCR Feature
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing Recognition Engine Files with an Application > Distributing Recognition Engine Files for the Asian OCR Feature

Files needed for performing recognition of Asian languages:

Asian.dll | big5.cjkset | BIG5_GlyphMap_MingLiu.dat
bigramh.dat | bigramz.dat | cbigram.dat
chs.mb | cht.mb | cylm.elm
datasim.dat | engdic.dat | engidx.dat
errstore.dat | EUC-CN.cjkset | EUC-JP.cjkset
EUC-TW.cjkset | GB18030.cjkset | GB2312_GlyphMap_song.dat
gbk.cjkset | hangullb.dat | HKscs-2004.cjkset
japan.mb | jpcode.uni | jpprint.dat
jpprint2.dat | jpserht.dat | jptree.dat
korean.mb | KOREAN_GlyphMap_GungsuhChe.dat | krcode.uni
krdist.dat | krprint.dat | krserht.dat
krtree.dat | kszp.dat | LMQuery.dll
lookup.dat | mojilist.dat | ocrhc.dat
ocrvc.dat | quantifi.dat | sccode.uni
scprint.dat | scprint2.dat | scserht.dat
sctree.dat | shift_jis.cjkset | sizes.dat
SJIS_GlyphMap_MSMinCho.dat | tccode.uni | tcprint.dat
tcprint2.dat | tcserht.dat | tctree.dat
THOCRAPI.DLL | tw_bu.dat | tw_gu.dat
tw_ku.dat | tw_su.dat | tw_ub.dat
tw_ug.dat | tw_uk.dat | tw_us.dat
TWBIG532.dll | twcutchr.dll | twcutckr.dll
twcutle.dll | twcutlin.dll | twcutlkr.dll
TWForm.dll | TWGB32.dll | twksc32.dll
TWLAY32.dll | TWLAYKR.dll | tworient.dll
twpost32.dll | twpostk.dll | twrecc.dll
twrece.dll | twrecj.dll | twreck.dll
twrecs.dll | TWReverse.dll | TWSJIS32.dll
twstruct.dll | uhc.cjkset | unoun.dat
uzu_n.dat | zbigramk.dat |


Distributing Recognition Engine Files for the Formatted Output Feature
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing Recognition Engine Files with an Application > Distributing Recognition Engine Files for the Formatted Output Feature

Outputting recognized data to formatted documents requires ImGearRecLicenseFeature.FormattedOutput license feature to be enabled. If this feature is enabled, the files listed below must be present on the system in addition to files required for the OCR feature.

AppDomainLoader.dll

AppHelper.dll

AppProductConfig.dll

AppUtils.dll

atm2lll.dll

ConvSettings.sts

Defaults.dll

DocXConv.dlc

DocXManagedWrapper.dll

eBookConv.dlc

Formatted output in eBook format is not supported by the 64-bit SDK.

ExcelCnv.dlc

ExcelXCnv.dlc

ExcelXManagedWrapper.dll

Formatter.dll

HTMLCnv.dlc

IF_PNG.dll

InfoPathConv.dlc

IPP_OmniPage.dlm

LecsoMgr.dll

LecsoX.OXML.Converters.PresentationML.dll

LecsoX.OXML.Converters.SpreadSheetML.dll

LecsoX.OXML.Converters.WordProcessingML.dll

LEditor.dll

litgen.dll

Formatted output in eBook format is not supported by the 64-bit SDK.

ME_ConverterMgr.dlm

ME_D2D.dlm

ME_DocMgr.dlm

ME_WFAssist.dlm

ME_WFMgr.dlm

ME_WFView.dlm

MiddleEarth.dll

MorIF.dll

PPTXConv.dlc

PPTXManagedWrapper.dll

PreRendering.dll

RecAPIPlus.dll

Recogn.bct

Recogn24.bct

Rendering.dll

Rendering2.dll

RtfConv.dlc

SkinnedClasses.dll

SkinnedWindows.dll

ssdoc-schema2.xml

TxtConv.dlc

WM_OPActions.dlm

WM_OPSteps.dlm

WM_OPUIActions.dlm

WordMLConv.dlc

WPCnv.dlc

XMLConv.dlc


Distributing an ImageGear for ASP.NET Application
User Guide > Licensing and Distributing > Distributing an ImageGear Application > Distributing an ImageGear for ASP.NET Application

To use the PageView Class and ThumbnailView Class control, add the DLL's listed below to your web site's bin folder. If you drag an PageView Class and ImageGearBackEnd Class control from the Visual Studio toolbox to a page in your web site, Visual Studio will automatically copy all these files into the correct location:

  • ImageGear22.Core.dll
  • ImageGear22.Formats.Common.dll
  • ImageGear22.Formats.Advanced.dll
  • ImageGear22.Formats.CameraRaw.dll
  • ImageGear22.Formats.Dicom.dll
  • ImageGear22.Formats.Jpeg2k.dll
  • ImageGear22.Formats.Pdf.dll
  • ImageGear22.Formats.Office.dll
  • ImageGear22.Formats.Vector.dll
  • ImageGear22.Web.dll
  • ImageGear22.Web.ImageDataProcessor.dll
  • ImageGear22.Web.Services.dll

You must also add the native ImageGear JPEG2K library - igjpeg2k20nu.dll and the PDF and PS fonts and libraries (as specified in the section above). You can distribute those resources by installing ImageGear on your server (in this case, ImageGear will automatically find them) or placing them in your web site's bin folder (in Web.config Settings for PageView and ThumbnailView Controls, refer to Image Data Processor Configuration for the igPdfResources and igBinaries sections, which provide details on directing ImageGear where to find those resources.)


Licensing Error Codes
User Guide > Licensing and Distributing > Licensing Error Codes

This section provides information about the following:

  • Licensing Component Error Codes and Messages
  • ImageGear Licensing Error Codes


Licensing Component Error Codes and Messages
User Guide > Licensing and Distributing > Licensing Error Codes > Licensing Component Error Codes and Messages

The following are the Licensing Component error codes:

Error Constant | Error Description
LDK_SUCCESS | No error.
LDK_ERR_GENERAL | General error.
LDK_ERR_INET_CONN_BROKEN | No Internet connection.
LDK_ERR_REGISTRY_ACCESS | Can't write license key to the registry. This can happen if a user doesn't have administrative privileges.
LDK_ERR_LOCKOUT | Auto mode only, it should happen when we receive several requests from the same IP address within a short period of time with the wrong access keys.
LDK_ERR_HDW_INCOMPATIBLE | Manual mode only, it means that the utility had to verify the hardware ID and didn't match the one stored in the license.
LDK_ERR_HDW_ID_QUERY | Can't get the hardware ID of the client system. This should not happen unless something goes really wrong with the system.
LDK_ERR_HDW_ID_RELEASE | Auto mode only, this happens when someone is trying to change hardware ID within 45 days after a previous hardware ID has been associated with the license.
LDK_ERR_NO_LICENSE_KEY | No license key passed as a parameter.
LDK_ERR_INVALID_LICENSE_KEY | License key passed as a parameter is invalid.
LDK_ERR_NO_ACCESS_KEY | No access key passed as a parameter.
LDK_ERR_INVALID_ACCESS_KEY | Access key passed as a parameter is invalid.
LDK_ERR_INVALID_SOLUTION_NAME | Invalid solution name.
LDK_ERR_NO_CONFIG_FILE | Cannot find the configuration file.
LDK_ERR_INVALID_CONFIG_FILE | Invalid configuration file.
LDK_ERR_NOT_INITIALIZED | Licensing Component is not initialized.
LDK_ERR_NO_LICENSE_INFO | No license info passed as a parameter.
LDK_ERR_INVALID_LICENSE_INFO | License info is invalid.
LDK_ERR_INCOMPATIBLE_LICENSE | This license is not compatible with your deployment configuration.
LDK_ERR_OBTAINIG_LICENSE | Can't obtain license from the system.

The following are the default Licensing Component Wrapper error messages:

Error Constant | Error Description
MSG_LDK_SUCCESS | "The product has been successfully licensed!"
MSG_LDK_ERR_GENERAL | "An unknown error has occurred during licensing. Please contact your vendor."
MSG_LDK_ERR_INET_CONN_BROKEN | "No Internet connection is available. Please check your connection and retry."
MSG_LDK_ERR_REGISTRY_ACCESS | "Unable to write the License Key to the registry. Please verify that you have administrative privileges."
MSG_LDK_ERR_LOCKOUT | "Licensing has been locked out after multiple requests. Verify that you have a valid Access Key, then contact your vendor."
MSG_LDK_ERR_HDW_INCOMPATIBLE | "This license is not compatible with your system hardware, please contact your vendor."
MSG_LDK_ERR_HDW_ID_QUERY | "Unable to obtain the Hardware ID of your system. Please contact your vendor."
MSG_LDK_ERR_HDW_ID_RELEASE | "Your Hardware ID has changed. Please contact your vendor."
MSG_LDK_ERR_NO_ACCESS_KEY | "No Access Key was received. Please retry and enter an Access Key."
MSG_LDK_ERR_INVALID_ACCESS_KEY | "The Access Key entered appears invalid. Please retry, then contact your vendor."
MSG_LDK_ERR_NO_LICENSE_KEY | "No License Key was received during licensing. Please retry, then contact your vendor."
MSG_LDK_ERR_INVALID_LICENSE_KEY | "The License Key received appears invalid. Please retry, then contact your vendor."
MSG_LDK_ERR_INVALID_SOLUTION_NAME | "The Solution Name is invalid. Please contact your vendor."
MSG_LDK_ERR_NO_CONFIG_FILE | "Can't find configuration file. Please contact your vendor."
MSG_LDK_ERR_INVALID_CONFIG_FILE | "An invalid configuration file was received. Please contact your vendor."
MSG_LDK_ERR_NOT_INITIALIZED | "Licensing Component is not initialized. Please contact your vendor."


ImageGear Licensing Error Codes
User Guide > Licensing and Distributing > Licensing Error Codes > ImageGear Licensing Error Codes

The following table describes general ImageGear licensing errors that can occur at runtime if the product is not licensed properly:

The following error descriptions are constant across all licensing errors.

Error Description | Comment
Failure to open registry value. | This error occurs if the license key cannot be obtained from the registry. Server licensing model only.
Invalid license key. | This error occurs if the license key passed to the ImageGear is invalid. All licensing models.
Version is not licensed. | This error occurs if the license key is valid, but does not license the current version of the product. All licensing models.
Your evaluation license has expired. Please run Accusoft License Manager if you would like to get a new license. | This error occurs if the evaluation license key has expired. Evaluation licensing only.
The product is not licensed for this machine. | This error occurs if the evaluation license key is not compatible with a hardware key for the current machine. Evaluation licensing only.
The hardware ID of this machine doesn't match license information. Please run Accusoft License Manager on this machine to add its hardware ID to your license. | This error occurs if the development license key is not compatible with a hardware key for the current machine. Development licensing only.
Solution name is required. | This error occurs if an empty solution name is passed as a parameter. All licensing models.
Invalid solution name. | This error occurs if the solution name from the license doesn't match the solution name passed as a parameter. All licensing models.
Invalid solution key. | This error occurs if the solution key from the license doesn't match the solution key passed as a parameter. All licensing models.
Invalid executable name. | This error occurs if the executable name from the license doesn't match the name of the application executable. Deployment licensing models locked to the executable only.
Please use OEM licensing API with this license. | This error occurs if the User/OEM license is being initialized via the registry. The User/OEM license has to be initialized by using the OEM API. User licensing model only.
Please do not use OEM licensing API with this license. | This error occurs if a non-User/OEM license is being initialized via the OEM API. Only the User/OEM license has to be initialized by using the OEM API. Server licensing model only.


Troubleshooting Licensing
User Guide > Licensing and Distributing > Troubleshooting Licensing

This section reviews potential issues you may experience during the licensing process.

Some general notes about licensing you should be aware of:

  • This was designed as an Internet-based licensing process. It is best if your end users have an Internet connection to get a License Key. The only exceptions are if you are a User License Licensee, or if you are distributing licenses manually on a very limited basis.
  • Once an application is licensed, no further Internet connection or interaction is required until you re-install the system or restore a previously backed-up system onto new hardware.
  • End Users are blocked from using the same Access Key to install the same application on different hardware. This is to prevent piracy.
  • A lightweight Licensing Component will grant a grace period to your end user whenever there is a licensing issue for any reason. You can modify the end user instructions to solve the problem.

End User has no Internet connection

User License level licensing or manual licensing is required if applications are going to be deployed to end users who will never have an Internet connection. Please be advised that manual licensing requires interaction on your part when installing the application on the end-user system.

Internet connection is temporarily broken during installation

In this case, the auto-licensing method will return an error, and the grace period will be activated. The grace period will allow your application to function normally during a limited period of time, and you will need to repeat the licensing process (either manual, or automatic after connection is restored).

Transferring ImageGear license into new hardware system

An error can occur during installation of your application into a new machine or as the result of restoring a backup into different system hardware.

When you need to transfer an ImageGear license onto new system hardware, you have to use the same Access Key that was used to license ImageGear on the old system.

If you are not distributing access keys to the end users you will need to provide a mechanism for transferring an access key into a new machine using the Licensing Component LicenseInfo API as described below.

The Deployment Licensing Service will issue a new license key if a certain number of days (default = 45) have already lapsed since the previous license key has been generated for the same access key with different hardware parameters. Otherwise end users would need to contact you, and you would need to call Accusoft Corporation to authorize a license transfer.

Reinstallation of ImageGear-based application into the same hardware system

In this case, the license will be either found in the registry, or obtained from Deployment Licensing Service, regardless of when it was last requested.

The End user's Windows registry changed (licensing info lost)

In general, if the registry is corrupted it might make sense to reinstall the application or even the entire system. But if the licensing info is the only data deleted from the registry, the licensing process that is executed as a part of the installation/registration can be repeated to retrieve a License Key from the Deployment Licensing Service.


Licensing Glossary
User Guide > Licensing and Distributing > Licensing Glossary
The following sections each describe a licensing term:
  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered Toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for a Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a Runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An Evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, Evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups or timeouts.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime (Node-Locked) license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server Licensing Utility (SLU), and Licensing Development Kit (LDK)) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime (Node-Locked); the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime (Non-Node-Locked), you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime (Node-Locked).

Non-Node-Locked Licensing

Another name for Manually Reported Runtime (Non-Node-Locked).

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups or timeouts. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups or timeouts.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user's installation. You must purchase Runtime licenses, which are consumed as licenses are registered. There are two Runtime Licensing models: Automatically Reported Runtime (Node-Locked); and Manually Reported Runtime (Non-Node-Locked).

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime (Node-Locked); the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the Toolkit license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system.

Web Services

When a license is registered, information that uniquely identifies the customer's or user's hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement
User Guide > Licensing and Distributing > Software License Agreement

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, YOU AGREE TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF LICENSE

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the individual or organization contracting under this agreement ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage or device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED." See Section 20. THIRD PARTY NOTICES for additional requirements.

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, by e-mail at: sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of any kind including, but not limited to, use or distribution of ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN-USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 1. Grant of License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

20. THIRD PARTY NOTICES

a) ADOBE PDF TECHNOLOGY

Portions of the PDF functionality in the TOOLKIT include Adobe Technology ("Adobe") licensed to ACCUSOFT. The term "TOOLKIT" as defined in the Agreement includes technology from Adobe and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

FONT LICENSE: If the TOOLKIT includes font software, LICENSEE may embed the font software, or outlines of the font software, into its Application to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. LICENSEE may fully embed any font owned by Adobe.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT’S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ADOBE AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY.

The Adobe technology is the intellectual property of Adobe and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

b) CAPTIVA ISIS TECHNOLOGY

ISIS functionality in the TOOLKIT is licensed to ACCUSOFT from Captiva Software, a division of EMC, Inc. The term "TOOLKIT" as defined in the Agreement includes technology from Captiva and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT'S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, CAPTIVA AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL CAPTIVA OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF A CAPTIVA REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY.

All ISIS technology is the intellectual property of Captiva and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

Rev. 20160223


Copyrights & Trademarks
User Guide > Copyrights & Trademarks

©1996-2016 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Accusoft® Barcode Scanner™
  • Accusoft® Cloud Services
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • Barcode Xpress Mobile™
  • CapturePro™
  • Cram™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • FormSuite™ for Invoices
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® for Java
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • Image Detergent™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Content Connect™
  • Prizm® Content Connect™ for SharePoint
  • Prizm® Content Connect™ for Documentum
  • Prizm® Document Converter™
  • Prizm® Viewer™
  • Prizm® ActiveX Viewer™
  • Prizm® Cloud™
  • Prizm® Share™
  • Prizm® Image™
  • Prizm® Capture™
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThinPic™
  • ThumbnailXpress™
  • TwainPRO™
  • USB Scanner™
  • USB Scanner SDK™

Accusoft Corporation and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

Accusoft Patents

ImageGear utilizes technology owned by Accusoft Corporation that is protected by U.S. Patents 7,003,170; 7,209,594; 7,352,903; 7,409,100; 7,454,080 8,351,723; 8,437,565; 8,634,651 and U.S. Patents Pending.


API Reference

This API Reference Guide provides information about all ImageGear for .NET public API.


ImageGear22.Art Assembly
Namespaces
Namespace | Description
ImageGear.ART | The ImageGear ART namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear ART namespace enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper. This chapter provides the ART namespace API reference.


ImageGear.ART Namespace (ImageGear22.Art)
Inheritance Hierarchy
ImageGear22.Art Assembly : ImageGear.ART Namespace
The ImageGear ART namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear ART namespace enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper. This chapter provides the ART namespace API reference.
Classes
 | Class | Description
Class | ImGearART | Provides general ART functionality and access to the global properties and methods.
Class | ImGearARTAccessController | Access controller interface.
Class | ImGearARTAccessDeniedException | The Access Denied exception.
Class | ImGearARTAccessRights | Defines access rights for the ART objects.
Class | ImGearARTAccessToken | The base class of access token.
Class | ImGearARTArrow | Represents legacy ART Arrow mark.
Class | ImGearARTAudio | Represents ART Audio mark.
Class | ImGearARTBorder | Provides mark's border attributes.
Class | ImGearARTButton | Represents ART Button mark.
Class | ImGearARTCallout | Provides text mark's callout attributes.
Class | ImGearARTCreateSecureObjectDataEventArgs | The ImGearARTCreateSecureObjectData event arguments.
Class | ImGearARTCreatingGroupEventArgs | CreatingGroupEvent arguments.
Class | ImGearARTCreatingMarkEventArgs | CreatingMarkEvent arguments.
Class | ImGearARTCreatingPageEventArgs | CreatingPageEvent arguments.
Class | ImGearARTCurve | Represents ART Curve mark.
Class | ImGearARTCustomController | Provides a set of abstract members for user-defined custom mark controller.
Class | ImGearARTCustomDrawingController | Provides a set of abstract members for user-defined custom mark controller, using with WinForms drawing engine.
Class | ImGearARTCustomMark | Represents ART Custom mark.
Class | ImGearARTDrawingState | Provides a set of parameters for custom mark's drawing.
Class | ImGearARTDroppedAttributeEventArgs | Provides data for the DroppedAttribute event.
Class | ImGearARTDroppedMarkEventArgs | Provides data for the DroppedMark event.
Class | ImGearARTEllipse | Represents ART Ellipse mark.
Class | ImGearARTEncryption | Represents ART Encryption mark.
Class | ImGearARTFilledEllipse | Represents legacy ART Filled Ellipse mark.
Class | ImGearARTFilledPolygon | Represents legacy ART Filled Polygon mark.
Class | ImGearARTFilledRectangle | Represents legacy ART Filled Rectangle mark.
Class | ImGearARTFreeLine | Represents legacy ART Freehand line mark.
Class | ImGearARTGetNotateXpressLayerPasswordEventArgs | The GetNotateXpressLayerPassword event arguments.
Class | ImGearARTGroup | Represents a collection of annotation marks united into a single group.
Class | ImGearARTGroupArray | Represents an array of annotation groups.
Class | ImGearARTGroupEnumerator | Provides marks iteration capabilities over the annotation group.
Class | ImGearARTHighlighter | Represents legacy ART Highlighter mark.
Class | ImGearARTHistory | Represents an Undo/Redo history of the ART page.
Class | ImGearARTHistoryEventArgs | Provides data for the history events.
Class | ImGearARTHollowEllipse | Represents legacy ART Hollow Ellipse mark.
Class | ImGearARTHollowPolygon | Represents legacy ART Hollow Polygon mark.
Class | ImGearARTHollowRectangle | Represents legacy ART Hollow Rectangle mark.
Class | ImGearARTHotSpot | Represents ART Hot Spot mark.
Class | ImGearARTImage | Represents ART Image mark.
Class | ImGearARTImageEmb | Represents legacy ART Embedded Image mark.
Class | ImGearARTImageRef | Represents legacy ART Image Reference mark.
Class | ImGearARTLine | Represents ART Line mark.
Class | ImGearARTLineMarkStat | Represents statistics information about the linear annotation marks.
Class | ImGearARTMark | Provides the abstract base class for all annotation marks.
Class | ImGearARTMarkEventArgs | Provides data for the mark events.
Class | ImGearARTMarkFlipEventArgs | Provides data for the mark flip events.
Class | ImGearARTMarkMoveEventArgs | Provides data for the mark move events.
Class | ImGearARTMarkPointEventArgs | Provides data for the mark point events.
Class | ImGearARTMarkRotateEventArgs | Provides data for the mark rotate events.
Class | ImGearARTMarkScaleEventArgs | Provides data for the mark scale events.
Class | ImGearARTMarkStat | This class has been deprecated. Provides the abstract base class for a set of classes intended to represent specific statistics information about ART marks.
Class | ImGearARTMarkStatistics | Represent specific statistics information about ART marks.
Class | ImGearARTNote | Represents legacy ART Attach-A-Note mark.
Class | ImGearARTPage | Represents a collection of annotation groups.
Class | ImGearARTPageEnumerator | Provides marks iteration capabilities over the annotation page.
Class | ImGearARTPin | Provides text mark's pin attirbutes.
Class | ImGearARTPinUpText | Represents legacy ART Pin-Up-Text mark.
Class | ImGearARTPoint | Represents ART Point mark.
Class | ImGearARTPointMarkStat | Represents statistics information about the point annotation marks.
Class | ImGearARTPolygon | Represents ART Polygon mark.
Class | ImGearARTPolyline | Represents ART Polyline mark.
Class | ImGearARTPolyRuler | Represents ART Polyline Ruler mark.
Class | ImGearARTPopupText | Represents ART Text mark.
Class | ImGearARTPropertyChangedEventArgs | Provides data for the ARTPropertyChanged events.
Class | ImGearARTProtractor | Represents ART Protractor mark.
Class | ImGearARTRectangle | Represents ART Rectangle mark.
Class | ImGearARTRedaction | Represents legacy ART Redaction mark.
Class | ImGearARTRichText | Represents ART Rich Text mark.
Class | ImGearARTRichTextControl | This class has been deprecated. Represents a control suitable for ART Rich Text processing and drawing.
Class | ImGearARTRuler | Represents ART Ruler mark.
Class | ImGearARTSecureObjectData | The base class for secure object data.
Class | ImGearARTSelection | Provides the abstract class that defines mark selection interface.
Class | ImGearARTShapeMarkStat | Represents statistics information about the shaped annotation marks.
Class | ImGearARTText | Represents ART Text mark.
Class | ImGearARTTextCallout | Represents legacy ART Callout Text mark.
Class | ImGearARTTextFromFile | Represents legacy ART Text From File mark.
Class | ImGearARTTextStamp | Represents legacy ART Text Stamp mark.
Class | ImGearARTTypedText | Represents legacy ART Typed Text mark.
Interfaces
 | Interface | Description
Interface | IImGearARTCurve | Defines ART Curve mark interface.
Interface | IImGearARTEllipse | Defines ART Ellipse mark interface.
Interface | IImGearARTLine | Defines ART Line mark interface.
Interface | IImGearARTMarkIDEnumerable | Exposes the enumerator, which supports a simple iteration over a collection of annotation marks.
Interface | IImGearARTMarkIDEnumerator | Supports a simple iteration over a collection of annotation marks.
Interface | IImGearARTPoint | Defines ART Point mark interface.
Interface | IImGearARTPolygon | Defines ART Polygon mark interface.
Interface | IImGearARTPolyline | Defines ART Polyline mark interface.
Interface | IImGearARTPolyRuler | Defines ART Polyline Ruler mark interface.
Interface | IImGearARTPopupText | Defines ART Text mark interface.
Interface | IImGearARTProtractor | Defines ART Protractor mark interface.
Interface | IImGearARTRectangle | Defines ART Rectangle mark interface.
Interface | IImGearARTRuler | Defines ART Ruler mark interface.
Interface | IImGearARTText | Defines ART Text mark interface.
Structures
 | Structure | Description
Structure | ImGearARTLoadEvents | Contains fields that can be used to pass event delegates to LoadPage method of the ImGearART.
Structure | ImGearARTMeasurementUnit | Represents a measurement unit, such as Meter, Inch etc.
Structure | ImGearARTThickness | Specifies the thickness of a rectangular frame.
Delegates
 | Delegate | Description
Delegate | ARTPropertyChangedEventHandler | Used for declaring ARTPropertyChanged events.
Delegate | ImGearARTHistoryEventHandler | Used for declaring ImGearARTHistory.HistoryChanged event.
Delegate | ImGearARTMarkEventHandler | Used for declaring ImGearARTPage.MarkChanged, ImGearARTPage.MarkAdded, ImGearARTPage.MarkRemoved, ImGearARTPage.MarkZOrderChanged and ImGearARTPage.MarkSelectionChanged events.
Delegate | ImGearARTMarkFlipEventHandler | Used for declaring MarkFlipped event.
Delegate | ImGearARTMarkMoveEventHandler | Used for declaring MarkMoved event.
Delegate | ImGearARTMarkPointEventHandler | Used for declaring PointChanged and PointAdded events.
Delegate | ImGearARTMarkRotateEventHandler | Used for declaring MarkRotated event.
Delegate | ImGearARTMarkScaleEventHandler | Used for declaring MarkScaled event.
Enumerations
 | Enumeration | Description
Enumeration | ImGearARTAccess | Specifies annotations group access level.
Enumeration | ImGearARTAspectKind | Specifies the kinds of aspects for the ruler annotation.
Enumeration | ImGearARTBurnInOptions | Specifies options to burn in annotations.
Enumeration | ImGearARTButtonState | Specifies button mark's state options.
Enumeration | ImGearARTCalloutType | Specifies callout types.
Enumeration | ImGearARTCapStyle | Specifies the available cap styles of a line end.
Enumeration | ImGearARTCoordinatesType | Specifies mark's coordinate types.
Enumeration | ImGearARTFillRule | Specifies how the intersecting areas of the shape are combined to form the filling area of the mark.
Enumeration | ImGearARTFontStyles | Specifies text font style information.
Enumeration | ImGearARTJoinStyle | Specifies the available styles of the shape that joins two lines of the mark.
Enumeration | ImGearARTLineHeadType | Specifies line mark's head types.
Enumeration | ImGearARTMarkHitTest | Specifies the hit test results.
Enumeration | ImGearARTMarkType | Specifies types of annotations.
Enumeration | ImGearARTPenStyle | Specifies pen styles.
Enumeration | ImGearARTPinAlignment | Specifies an alignment of the pin icon.
Enumeration | ImGearARTSaveType | Specifies annotations save formats.
Enumeration | ImGearARTTextAutoFitMode | Specifies auto fit mode for text annotations.
Enumeration | ImGearARTTextTrimming | Describes how text is trimmed when it overflows the bounds of annotation.
Enumeration | ImGearARTTextType | Specifies a type of string in the text mark's "Text" property.
See Also

Reference

ImageGear22.Art Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.ART Namespace (ImageGear22.Art) Inheritance Hierarchy
ImageGear22.Art Assembly : ImageGear.ART Namespace
Inheritance Hierarchy
System.Object
ImageGear.ART.ImGearART
ImageGear.ART.ImGearARTAccessController
ImageGear.ART.ImGearARTAccessRights
ImageGear.ART.ImGearARTAccessToken
ImageGear.ART.ImGearARTBorder
ImageGear.ART.ImGearARTCallout
ImageGear.ART.ImGearARTCustomController
ImageGear.ART.ImGearARTCustomDrawingController
ImageGear.ART.ImGearARTDrawingState
ImageGear.ART.ImGearARTGroup
ImageGear.ART.ImGearARTGroupArray
ImageGear.ART.ImGearARTGroupEnumerator
ImageGear.ART.ImGearARTHistory
ImageGear.ART.ImGearARTMarkStat
ImageGear.ART.ImGearARTLineMarkStat
ImageGear.ART.ImGearARTPointMarkStat
ImageGear.ART.ImGearARTShapeMarkStat
ImageGear.ART.ImGearARTMarkStatistics
ImageGear.ART.ImGearARTPageEnumerator
ImageGear.ART.ImGearARTPin
ImageGear.ART.ImGearARTSecureObjectData
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTArrow
ImageGear.ART.ImGearARTAudio
ImageGear.ART.ImGearARTButton
ImageGear.ART.ImGearARTCurve
ImageGear.ART.ImGearARTCustomMark
ImageGear.ART.ImGearARTEllipse
ImageGear.ART.ImGearARTEncryption
ImageGear.ART.ImGearARTFilledEllipse
ImageGear.ART.ImGearARTFilledPolygon
ImageGear.ART.ImGearARTFilledRectangle
ImageGear.ART.ImGearARTFreeLine
ImageGear.ART.ImGearARTHighlighter
ImageGear.ART.ImGearARTHollowEllipse
ImageGear.ART.ImGearARTHollowPolygon
ImageGear.ART.ImGearARTHollowRectangle
ImageGear.ART.ImGearARTHotSpot
ImageGear.ART.ImGearARTImage
ImageGear.ART.ImGearARTImageEmb
ImageGear.ART.ImGearARTImageRef
ImageGear.ART.ImGearARTLine
ImageGear.ART.ImGearARTNote
ImageGear.ART.ImGearARTPinUpText
ImageGear.ART.ImGearARTPoint
ImageGear.ART.ImGearARTPolygon
ImageGear.ART.ImGearARTPolyline
ImageGear.ART.ImGearARTPolyRuler
ImageGear.ART.ImGearARTPopupText
ImageGear.ART.ImGearARTProtractor
ImageGear.ART.ImGearARTRectangle
ImageGear.ART.ImGearARTRedaction
ImageGear.ART.ImGearARTRichText
ImageGear.ART.ImGearARTRuler
ImageGear.ART.ImGearARTText
ImageGear.ART.ImGearARTTextCallout
ImageGear.ART.ImGearARTTextFromFile
ImageGear.ART.ImGearARTTextStamp
ImageGear.ART.ImGearARTTypedText
ImageGear.Display.ImGearAnnotationPage
ImageGear.ART.ImGearARTPage
System.EventArgs
ImageGear.ART.ImGearARTCreateSecureObjectDataEventArgs
ImageGear.ART.ImGearARTCreatingGroupEventArgs
ImageGear.ART.ImGearARTCreatingMarkEventArgs
ImageGear.ART.ImGearARTCreatingPageEventArgs
ImageGear.ART.ImGearARTDroppedAttributeEventArgs
ImageGear.ART.ImGearARTDroppedMarkEventArgs
ImageGear.ART.ImGearARTGetNotateXpressLayerPasswordEventArgs
ImageGear.ART.ImGearARTHistoryEventArgs
ImageGear.ART.ImGearARTMarkEventArgs
ImageGear.ART.ImGearARTMarkPointEventArgs
ImageGear.ART.ImGearARTMarkFlipEventArgs
ImageGear.ART.ImGearARTMarkMoveEventArgs
ImageGear.ART.ImGearARTMarkRotateEventArgs
ImageGear.ART.ImGearARTMarkScaleEventArgs
System.ComponentModel.PropertyChangedEventArgs
ImageGear.ART.ImGearARTPropertyChangedEventArgs
System.Exception
ImageGear.Core.ImGearException
ImageGear.ART.ImGearARTAccessDeniedException
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.RichTextBox
ImageGear.ART.ImGearARTRichTextControl
System.ValueType
ImageGear.ART.ImGearARTLoadEvents
ImageGear.ART.ImGearARTMeasurementUnit
ImageGear.ART.ImGearARTThickness
See Also

Reference

ImageGear22.Art Assembly


%%PageItemTitle%%

ImGearART Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearART Class
Provides general ART functionality and access to the global properties and methods.
Object Model
ImGearART ClassImGearPage ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearART
'Usage

Dim instance As ImGearART
public class ImGearART
public __gc class ImGearART
public ref class ImGearART
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearART

See Also

Reference

ImGearART Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearART Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearART Class

The following tables list the members exposed by ImGearART.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DisablePPM | Gets or sets a value indicating whether the PPM control option is disabled in font size calculations.
static (Shared in Visual Basic) | IsLegacyAppearanceModeEnabled | Gets or sets a value indicating whether the legacy appearance of the legacy marks is enabled.
static (Shared in Visual Basic) | IsLegacyFontScalingEnabled | Gets or sets a value indicating whether the legacy mode is Enabled.
static (Shared in Visual Basic) | IsLegacyRulerAppearanceModeEnabled | Gets or sets a value indicating whether the legacy appearance of ImGearARTRuler and ImGearARTPolyRuler marks is enabled.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | BurnIn | Merges marks permanently into ImageGear.Core.ImGearPage class.
static (Shared in Visual Basic) | LoadPage | Overloaded. Loads ART marks.
static (Shared in Visual Basic) | SavePage | Overloaded. Saves ART marks.
Top
See Also

Reference

ImGearART Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearART Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearART Class

For a list of all members of this type, see ImGearART members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BurnIn | Merges marks permanently into ImageGear.Core.ImGearPage class.
static (Shared in Visual Basic) | LoadPage | Overloaded. Loads ART marks.
static (Shared in Visual Basic) | SavePage | Overloaded. Saves ART marks.
Top
See Also

Reference

ImGearART Class
ImageGear.ART Namespace


BurnIn Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : BurnIn Method
ImageGear.Core.ImGearPage class to burn marks in.
ART page to get marks from.
BurnIn options.
List of group indexes to apply burn in to, null - all groups.
Merges marks permanently into ImageGear.Core.ImGearPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function BurnIn( _
   ByVal page As ImGearPage, _
   ByVal artPage As ImGearARTPage, _
   ByVal burnOptions As ImGearARTBurnInOptions, _
   ByVal groupIndexes() As Integer _
) As ImGearPage
'Usage

Dim page As ImGearPage
Dim artPage As ImGearARTPage
Dim burnOptions As ImGearARTBurnInOptions
Dim groupIndexes() As Integer
Dim value As ImGearPage

value = ImGearART.BurnIn(page, artPage, burnOptions, groupIndexes)
public static ImGearPage BurnIn(
   ImGearPage page,
   ImGearARTPage artPage,
   ImGearARTBurnInOptions burnOptions,
   int[] groupIndexes
)
public: static ImGearPage* BurnIn(
   ImGearPage* page,
   ImGearARTPage* artPage,
   ImGearARTBurnInOptions burnOptions,
   int[]* groupIndexes
)
public:
static ImGearPage^ BurnIn(
   ImGearPage^ page,
   ImGearARTPage^ artPage,
   ImGearARTBurnInOptions burnOptions,
   array<int>^ groupIndexes
)

Parameters

page
ImageGear.Core.ImGearPage class to burn marks in.
artPage
ART page to get marks from.
burnOptions
BurnIn options.
groupIndexes
List of group indexes to apply burn in to, null - all groups.

Return Value

ImageGear.Core.ImGearPage class object.
Remarks
The marks are converted from vector-format constructs into raster-format. The image may be temporarily promoted to a higher bit-depth for the purpose of the merge (see ImGearARTBurnInOptions enumeration).
Example
  • C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}
  • Visual Basic
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next
See Also

Reference

ImGearART Class
ImGearART Members
ImGearPage Class
ImGearARTPage Class
ImGearARTBurnInOptions Enumeration


LoadPage Method (ImGearART)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : LoadPage Method
Loads ART marks.
Overload List
Overload | Description
LoadPage(Stream,Int32) | Loads ART marks from a stream.
LoadPage(Stream,Int32,ImGearARTLoadEvents) | Loads ART marks from a stream and allows the use of events that occur during loading.
LoadPage(ImGearPage) | Loads ART marks from ImageGear.Core.ImGearPage class.
See Also

Reference

ImGearART Class
ImGearART Members


LoadPage(Stream,Int32) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class > LoadPage Method : LoadPage(Stream,Int32) Method
Stream from which to load marks. The LoadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
Zero-based page number. First page is 0.
Loads ART marks from a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPage( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImGearARTPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImGearARTPage

value = ImGearART.LoadPage(stream, pageNumber)
public static ImGearARTPage LoadPage(
   Stream stream,
   int pageNumber
)
public: static ImGearARTPage* LoadPage(
   Stream* stream,
   int pageNumber
)
public:
static ImGearARTPage^ LoadPage(
   Stream^ stream,
   int pageNumber
)

Parameters

stream
Stream from which to load marks. The LoadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.

Return Value

ImGearARTPage class.
Remarks
This method loads annotation marks from an XML stream.

This method can also be used to load ART 2.0 marks from the binary ART format.

Example
  • C#
// Load first page of ART data from an ART file.
ImGearARTPage igARTPageNew;
using (FileStream localFile = new FileStream("test.xml", FileMode.Open))
    igARTPageNew = ImGearART.LoadPage(localFile, 0);
// Update display with new page.
igPageView.Display.ARTPage = igARTPageNew;
  • Visual Basic
' Load first page of ART data from an ART file.
Dim igARTPageNew As ImGearARTPage
Using localFile As New FileStream("test.xml", FileMode.Open)
    igARTPageNew = ImGearART.LoadPage(localFile, 0)
End Using
' Update display with new page.
igPageView.Display.ARTPage = igARTPageNew
See Also

Reference

ImGearART Class
ImGearART Members
Overload List
ImGearARTPage Class


LoadPage(Stream,Int32,ImGearARTLoadEvents) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class > LoadPage Method : LoadPage(Stream,Int32,ImGearARTLoadEvents) Method
Stream from which to load marks. The LoadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
Zero-based page number. First page is 0.
An instance of the ImGearARTLoadEvents class.
Loads ART marks from a stream and allows the use of events that occur during loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPage( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal events As ImGearARTLoadEvents _
) As ImGearARTPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim events As ImGearARTLoadEvents
Dim value As ImGearARTPage

value = ImGearART.LoadPage(stream, pageNumber, events)
public static ImGearARTPage LoadPage(
   Stream stream,
   int pageNumber,
   ImGearARTLoadEvents events
)
public: static ImGearARTPage* LoadPage(
   Stream* stream,
   int pageNumber,
   ImGearARTLoadEvents events
)
public:
static ImGearARTPage^ LoadPage(
   Stream^ stream,
   int pageNumber,
   ImGearARTLoadEvents events
)

Parameters

stream
Stream from which to load marks. The LoadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.
events
An instance of the ImGearARTLoadEvents class.

Return Value

ImGearARTPage class.
See Also

Reference

ImGearART Class
ImGearART Members
Overload List
ImGearARTPage Class


LoadPage(ImGearPage) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class > LoadPage Method : LoadPage(ImGearPage) Method
Page to load marks from.
Loads ART marks from ImageGear.Core.ImGearPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPage( _
   ByVal page As ImGearPage _
) As ImGearARTPage
'Usage

Dim page As ImGearPage
Dim value As ImGearARTPage

value = ImGearART.LoadPage(page)
public static ImGearARTPage LoadPage(
   ImGearPage page
)
public: static ImGearARTPage* LoadPage(
   ImGearPage* page
)
public:
static ImGearARTPage^ LoadPage(
   ImGearPage^ page
)

Parameters

page
Page to load marks from.

Return Value

ImGearARTPage class.
Remarks
This method can be used to load ART marks from TIF or PDF page.
Example
  • C#
ImGearPage igPage;
// Load an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test1_art.tif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Load the ImGearARTPage from the metadata in the ImGearPage.
ImGearARTPage igARTPage = ImGearART.LoadPage(igPage);
// Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.ALL, null);
imGearPageView1.Page = igPage;
// Clear the annotations from the art page.
igARTPage.RemoveMarks();
// Update the Display with the new ARTPage.
if (igARTPage != null)
    imGearPageView1.Display.ARTPage = igARTPage;
  • Visual Basic
Dim igPage As ImGearPage
' Load an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test1_art.tif", FileMode.Open)
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Load the ImGearARTPage from the metadata in the ImGearPage.
Dim igARTPage As ImGearARTPage = ImGearART.LoadPage(igPage)
' Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.ALL, Nothing)
ImGearPageView1.Page = igPage
' Clear the annotations from the art page.
igARTPage.RemoveMarks()
' Update the Display with the new ARTPage.
If igARTPage IsNot Nothing Then
    ImGearPageView1.Display.ARTPage = igARTPage
End If
See Also

Reference

ImGearART Class
ImGearART Members
Overload List
ImGearARTPage Class
ImGearPage Class


SavePage Method (ImGearART)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : SavePage Method
Saves ART marks.
Overload List
Overload | Description
SavePage(ImGearARTPage,Stream,Int32,ImGearSavingModes,ImGearARTSaveType) | Saves ART marks to a stream.
SavePage(ImGearARTPage,ImGearPage) | Saves ART marks into ImageGear.Core.ImGearPage class.
See Also

Reference

ImGearART Class
ImGearART Members


SavePage(ImGearARTPage,Stream,Int32,ImGearSavingModes,ImGearARTSaveType) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class > SavePage Method : SavePage(ImGearARTPage,Stream,Int32,ImGearSavingModes,ImGearARTSaveType) Method
ART page with marks to save.
Stream to which to save annotation marks. The SavePage method works from the current stream position, so if you are intending to re-write the stream, you need to reset the stream position to the beginning.
Page number to save. First page is 1.
Saving mode.
Saving type.
Saves ART marks to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SavePage( _
   ByVal artPage As ImGearARTPage, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal saveMode As ImGearSavingModes, _
   ByVal type As ImGearARTSaveType _
)
'Usage

Dim artPage As ImGearARTPage
Dim stream As Stream
Dim pageNumber As Integer
Dim saveMode As ImGearSavingModes
Dim type As ImGearARTSaveType

ImGearART.SavePage(artPage, stream, pageNumber, saveMode, type)
public static void SavePage(
   ImGearARTPage artPage,
   Stream stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearARTSaveType type
)
public: static void SavePage(
   ImGearARTPage* artPage,
   Stream* stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearARTSaveType type
)
public:
static void SavePage(
   ImGearARTPage^ artPage,
   Stream^ stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearARTSaveType type
)

Parameters

artPage
ART page with marks to save.
stream
Stream to which to save annotation marks. The SavePage method works from the current stream position, so if you are intending to re-write the stream, you need to reset the stream position to the beginning.
pageNumber
Page number to save. First page is 1.
saveMode
Saving mode.
type
Saving type.
Remarks
This method saves annotation marks to XML stream.

This method can also be used to export ART 2.0 marks to the binary ART format.

Saving a multipage ART XML file with ImageGear.Formats.ImGearSavingModes.APPEND for the 4th parameter is a special case that requires seeking to the start of the stream before the SavePage call. Otherwise an attempt to save several ART pages to one XML file could result in an improperly formatted file from which only the annotations for the 1st page will be loaded, being saved. See the Sample Code below.

Example
  • C#
private static void SaveMultipageArt(ImGearARTPage[] igARTPages, string XmlFilePath)
{
    using (FileStream fileContent = new FileStream(XmlFilePath, FileMode.OpenOrCreate, FileAccess.ReadWrite))
    {
        for (int i = 0; i < igARTPages.Length; i++)
        {
            if (igARTPages[i] != null)
            {
                //Must seek to the start of the stream before saving each ImGearARTPage
                // to a multipage XML ART file using ImGearSavingModes.APPEND
                fileContent.Position = 0;
                ImGearART.SavePage(igARTPages[i], fileContent, i, ImGearSavingModes.APPEND, ImGearARTSaveType.XML);
            }
        }
    }
}
  • Visual Basic
Sub SaveMultipageArt(ByVal igARTPages() As ImGearARTPage, ByVal XmlFilePath As String)
    Dim fileContent As FileStream
    fileContent = Nothing
    Try
        fileContent = New FileStream(XmlFilePath, FileMode.OpenOrCreate, FileAccess.ReadWrite)
        For i As Integer = 0 To igARTPages.Length - 1
            If (Not (igARTPages(i) Is Nothing)) Then
                'Must seek to the start of the stream before saving each ImGearARTPage
                ' to a multipage XML ART file using ImGearSavingModes.APPEND
                fileContent.Position = 0
                ImGearART.SavePage(igARTPages(i), fileContent, i, ImGearSavingModes.APPEND, ImGearARTSaveType.XML)
            End If
        Next
    Finally
        If Not fileContent Is Nothing Then
            fileContent.Close()
        End If
    End Try
End Sub
See Also

Reference

ImGearART Class
ImGearART Members
Overload List
ImGearARTPage Class
ImGearARTSaveType Enumeration


SavePage(ImGearARTPage,ImGearPage) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class > SavePage Method : SavePage(ImGearARTPage,ImGearPage) Method
ART page with marks to save.
ImageGear.Core.ImGearPage class to save to.
Saves ART marks into ImageGear.Core.ImGearPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SavePage( _
   ByVal artPage As ImGearARTPage, _
   ByVal page As ImGearPage _
)
'Usage

Dim artPage As ImGearARTPage
Dim page As ImGearPage

ImGearART.SavePage(artPage, page)
public static void SavePage(
   ImGearARTPage artPage,
   ImGearPage page
)
public: static void SavePage(
   ImGearARTPage* artPage,
   ImGearPage* page
)
public:
static void SavePage(
   ImGearARTPage^ artPage,
   ImGearPage^ page
)

Parameters

artPage
ART page with marks to save.
page
ImageGear.Core.ImGearPage class to save to.
Remarks
Saves ART 2.0 & 3.0 marks into igPage. This method can be used to export ART 2.0 marks to TIF page and ART 3.0 marks to PDF page.
Example
  • C#
// Save reference to the original metadata.
ImGearMetadataTree igMetadataTreeOriginal =
    (ImGearMetadataTree)igPage.Metadata.Child;
// Prepare a TIF metadata tree.
ImGearMetadataTree igMetaDataTreeTIF =
    (igPage.Metadata.Child.Format == ImGearMetadataFormats.TIF) ?
    (ImGearMetadataTree)igPage.Metadata.Child.Clone() :
    new ImGearMetadataTree(ImGearMetadataFormats.TIF, (Int32)ImGearTIFTagIDs.FORMAT);
// Replace page metadata with igMetaDataTreeTIF.
igPage.Metadata.Child = igMetaDataTreeTIF;
// Save the art data into the metadata of the image.
ImGearART.SavePage(igARTPage, igPage);
// Save an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test_art_save.tif", FileMode.Create))
    ImGearFileFormats.SavePage(igPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_UNCOMP, null);
// Restore original meta data.
igPage.Metadata.Child = igMetadataTreeOriginal;
  • Visual Basic
' Save reference to the original metadata.
Dim igMetadataTreeOriginal As ImGearMetadataTree = DirectCast(igPage.Metadata.Child, ImGearMetadataTree)
' Prepare a TIF metadata tree.
Dim igMetaDataTreeTIF As ImGearMetadataTree
If (igPage.Metadata.Child.Format = ImGearMetadataFormats.TIF) Then
    igMetaDataTreeTIF = DirectCast(igPage.Metadata.Child.Clone(), ImGearMetadataTree)
Else
    igMetaDataTreeTIF = New ImGearMetadataTree(ImGearMetadataFormats.TIF, DirectCast(ImGearTIFTagIDs.FORMAT, Int32))
End If
' Replace page metadata with igMetaDataTreeTIF.
igPage.Metadata.Child = igMetaDataTreeTIF
' Save the art data into the metadata of the image.
ImGearART.SavePage(igARTPage, igPage)
' Save an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test_art_save.tif", FileMode.Create)
    ImGearFileFormats.SavePage(igPage, localFile, 0, _
     ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_UNCOMP, Nothing)
End Using
' Restore original meta data.
igPage.Metadata.Child = igMetadataTreeOriginal
See Also

Reference

ImGearART Class
ImGearART Members
Overload List
ImGearARTPage Class
ImGearPage Class


%%PageItemTitle%% $$Properties$$

ImGearART Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearART Class

For a list of all members of this type, see ImGearART members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DisablePPM | Gets or sets a value indicating whether the PPM control option is disabled in font size calculations.
static (Shared in Visual Basic) | IsLegacyAppearanceModeEnabled | Gets or sets a value indicating whether the legacy appearance of the legacy marks is enabled.
static (Shared in Visual Basic) | IsLegacyFontScalingEnabled | Gets or sets a value indicating whether the legacy mode is Enabled.
static (Shared in Visual Basic) | IsLegacyRulerAppearanceModeEnabled | Gets or sets a value indicating whether the legacy appearance of ImGearARTRuler and ImGearARTPolyRuler marks is enabled.
Top
See Also

Reference

ImGearART Class
ImageGear.ART Namespace


DisablePPM Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : DisablePPM Property
Gets or sets a value indicating whether the PPM control option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property DisablePPM As Boolean
'Usage

Dim value As Boolean

ImGearART.DisablePPM = value

value = ImGearART.DisablePPM
public static bool DisablePPM {get; set;}
public: __property static bool get_DisablePPM();
public: __property static void set_DisablePPM(
   bool value
);
public:
static property bool DisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This ART control option allows to disable use of image resolution for adjusting text fonts.

True if the PPM control option is disabled in font size calculations for all text marks displayed; otherwise, false.

The default value is false.
See Also

Reference

ImGearART Class
ImGearART Members


IsLegacyAppearanceModeEnabled Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : IsLegacyAppearanceModeEnabled Property
Gets or sets a value indicating whether the legacy appearance of the legacy marks is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property IsLegacyAppearanceModeEnabled As Boolean
'Usage

Dim value As Boolean

ImGearART.IsLegacyAppearanceModeEnabled = value

value = ImGearART.IsLegacyAppearanceModeEnabled
public static bool IsLegacyAppearanceModeEnabled {get; set;}
public: __property static bool get_IsLegacyAppearanceModeEnabled();
public: __property static void set_IsLegacyAppearanceModeEnabled(
   bool value
);
public:
static property bool IsLegacyAppearanceModeEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

True - enables legacy appearance of the marks, False - disables legacy appearance of the marks.

The default value is false.

Legacy mode emulates appearance of the legacy annotations by adjusting color schemes, arrow and line styles upon creating or importing from legacy format file.

This property does not change the appearance of existing (i.e. already created or imported) annotations dynamically. If you need to enable the legacy appearance mode, you have to set this property to true before creating or importing legacy annotations.

Note: this flag is supported for WinForms display mode only.

>
See Also

Reference

ImGearART Class
ImGearART Members


IsLegacyFontScalingEnabled Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : IsLegacyFontScalingEnabled Property
Gets or sets a value indicating whether the legacy mode is Enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property IsLegacyFontScalingEnabled As Boolean
'Usage

Dim value As Boolean

ImGearART.IsLegacyFontScalingEnabled = value

value = ImGearART.IsLegacyFontScalingEnabled
public static bool IsLegacyFontScalingEnabled {get; set;}
public: __property static bool get_IsLegacyFontScalingEnabled();
public: __property static void set_IsLegacyFontScalingEnabled(
   bool value
);
public:
static property bool IsLegacyFontScalingEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This ART control option sets the way ImageGear scales the text fonts for ART annotations.

True if the legacy scale mode for compatibility with previous ImageGear .NET versions is enabled; otherwise, false.

The default value is false.
See Also

Reference

ImGearART Class
ImGearART Members


IsLegacyRulerAppearanceModeEnabled Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearART Class : IsLegacyRulerAppearanceModeEnabled Property
Gets or sets a value indicating whether the legacy appearance of ImGearARTRuler and ImGearARTPolyRuler marks is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property IsLegacyRulerAppearanceModeEnabled As Boolean
'Usage

Dim value As Boolean

ImGearART.IsLegacyRulerAppearanceModeEnabled = value

value = ImGearART.IsLegacyRulerAppearanceModeEnabled
public static bool IsLegacyRulerAppearanceModeEnabled {get; set;}
public: __property static bool get_IsLegacyRulerAppearanceModeEnabled();
public: __property static void set_IsLegacyRulerAppearanceModeEnabled(
   bool value
);
public:
static property bool IsLegacyRulerAppearanceModeEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

True - enables legacy appearance of the ImGearARTRuler and ImGearARTPolyRuler, False - disables legacy appearance of the marks.

The default value is false.

Legacy mode emulates legacy appearance of the ImGearARTRuler and ImGearARTPolyRuler marks. In this mode the start/end line length is not being scaled to device resolution, the start/end elements are being rendered by constant size.

This property does not change the appearance of existing (i.e. already created or imported) annotations dynamically. If you need to enable the legacy appearance mode, you have to set this property to true before creating or importing Ruler or Polyline Ruler annotations.

Note: this flag is supported for WinForms display mode only.

>
See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

ImGearARTAccessController Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessController Class
Access controller interface.
Object Model
ImGearARTAccessController ClassImGearARTAccessToken ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTAccessController
'Usage

Dim instance As ImGearARTAccessController
public abstract class ImGearARTAccessController
public __gc abstract class ImGearARTAccessController
public ref class ImGearARTAccessController abstract
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTAccessController

See Also

Reference

ImGearARTAccessController Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTAccessController Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessController Class

The following tables list the members exposed by ImGearARTAccessController.

Public Properties
 | Name | Description
Public Property | AccessToken | Gets or sets an access Token.
Public Property | Page | Gets or sets the page associated with the controller.
Top
Public Methods
 | Name | Description
Public Method | IsAccessAllowed | Overloaded. Determines if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Top
Protected Methods
 | Name | Description
Protected Method | OnIsAccessAllowed | Overloaded. Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Top
See Also

Reference

ImGearARTAccessController Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTAccessController Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessController Class

For a list of all members of this type, see ImGearARTAccessController members.

Public Methods
 | Name | Description
Public Method | IsAccessAllowed | Overloaded. Determines if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Top
Protected Methods
 | Name | Description
Protected Method | OnIsAccessAllowed | Overloaded. Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Top
See Also

Reference

ImGearARTAccessController Class
ImageGear.ART Namespace


IsAccessAllowed Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class : IsAccessAllowed Method
Determines if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Overload List
Overload | Description
IsAccessAllowed(ImGearARTAccessRights) | Determines if the caller identified by Access Token has Access Rights to the ImGearARTPage.
IsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) | Determines if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
IsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) | Determines if the caller identified by Access Token has Access Rights to the ImGearARTMark.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members


IsAccessAllowed(ImGearARTAccessRights) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > IsAccessAllowed Method : IsAccessAllowed(ImGearARTAccessRights) Method
Access Rights required for the operation.
Determines if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim value As Boolean

value = instance.IsAccessAllowed(accessRights)
public bool IsAccessAllowed(
   ImGearARTAccessRights accessRights
)
public: bool IsAccessAllowed(
   ImGearARTAccessRights* accessRights
)
public:
bool IsAccessAllowed(
   ImGearARTAccessRights^ accessRights
)

Parameters

accessRights
Access Rights required for the operation.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


IsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > IsAccessAllowed Method : IsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) Method
Access Rights required for the operation.
Art group to which access should be checked.
Determines if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights, _
   ByVal group As ImGearARTGroup _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim group As ImGearARTGroup
Dim value As Boolean

value = instance.IsAccessAllowed(accessRights, group)
public bool IsAccessAllowed(
   ImGearARTAccessRights accessRights,
   ImGearARTGroup group
)
public: bool IsAccessAllowed(
   ImGearARTAccessRights* accessRights,
   ImGearARTGroup* group
)
public:
bool IsAccessAllowed(
   ImGearARTAccessRights^ accessRights,
   ImGearARTGroup^ group
)

Parameters

accessRights
Access Rights required for the operation.
group
Art group to which access should be checked.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


IsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > IsAccessAllowed Method : IsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) Method
Access Rights required for the operation.
Art mark to which access should be checked.
Determines if the caller identified by Access Token has Access Rights to the ImGearARTMark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights, _
   ByVal mark As ImGearARTMark _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim mark As ImGearARTMark
Dim value As Boolean

value = instance.IsAccessAllowed(accessRights, mark)
public bool IsAccessAllowed(
   ImGearARTAccessRights accessRights,
   ImGearARTMark mark
)
public: bool IsAccessAllowed(
   ImGearARTAccessRights* accessRights,
   ImGearARTMark* mark
)
public:
bool IsAccessAllowed(
   ImGearARTAccessRights^ accessRights,
   ImGearARTMark^ mark
)

Parameters

accessRights
Access Rights required for the operation.
mark
Art mark to which access should be checked.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


OnIsAccessAllowed Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class : OnIsAccessAllowed Method
Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Overload List
Overload | Description
OnIsAccessAllowed(ImGearARTAccessRights) | Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTPage.
OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) | Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) | Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members


OnIsAccessAllowed(ImGearARTAccessRights) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > OnIsAccessAllowed Method : OnIsAccessAllowed(ImGearARTAccessRights) Method
Access Rights required for the operation.
Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function OnIsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim value As Boolean

value = instance.OnIsAccessAllowed(accessRights)
protected abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights accessRights
)
protected: abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights* accessRights
)
protected:
abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights^ accessRights
)

Parameters

accessRights
Access Rights required for the operation.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > OnIsAccessAllowed Method : OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTGroup) Method
Access Rights required for the operation.
Art group to which access should be checked.
Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function OnIsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights, _
   ByVal group As ImGearARTGroup _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim group As ImGearARTGroup
Dim value As Boolean

value = instance.OnIsAccessAllowed(accessRights, group)
protected abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights accessRights,
   ImGearARTGroup group
)
protected: abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights* accessRights,
   ImGearARTGroup* group
)
protected:
abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights^ accessRights,
   ImGearARTGroup^ group
)

Parameters

accessRights
Access Rights required for the operation.
group
Art group to which access should be checked.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class > OnIsAccessAllowed Method : OnIsAccessAllowed(ImGearARTAccessRights,ImGearARTMark) Method
Access Rights required for the operation.
Art mark to which access should be checked.
Implement this abstract method to determine if the caller identified by Access Token has Access Rights to the ImGearARTGroup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function OnIsAccessAllowed( _
   ByVal accessRights As ImGearARTAccessRights, _
   ByVal mark As ImGearARTMark _
) As Boolean
'Usage

Dim instance As ImGearARTAccessController
Dim accessRights As ImGearARTAccessRights
Dim mark As ImGearARTMark
Dim value As Boolean

value = instance.OnIsAccessAllowed(accessRights, mark)
protected abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights accessRights,
   ImGearARTMark mark
)
protected: abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights* accessRights,
   ImGearARTMark* mark
)
protected:
abstract bool OnIsAccessAllowed(
   ImGearARTAccessRights^ accessRights,
   ImGearARTMark^ mark
)

Parameters

accessRights
Access Rights required for the operation.
mark
Art mark to which access should be checked.

Return Value

Returns true if access is allowed, otherwise returns false.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearARTAccessController Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessController Class

For a list of all members of this type, see ImGearARTAccessController members.

Public Properties
 | Name | Description
Public Property | AccessToken | Gets or sets an access Token.
Public Property | Page | Gets or sets the page associated with the controller.
Top
See Also

Reference

ImGearARTAccessController Class
ImageGear.ART Namespace


AccessToken Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class : AccessToken Property
Gets or sets an access Token.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property AccessToken As ImGearARTAccessToken
'Usage

Dim instance As ImGearARTAccessController
Dim value As ImGearARTAccessToken

instance.AccessToken = value

value = instance.AccessToken
public abstract ImGearARTAccessToken AccessToken {get; set;}
public: __property abstract ImGearARTAccessToken* get_AccessToken();
public: __property abstract void set_AccessToken(
   ImGearARTAccessToken* value
);
public:
abstract property ImGearARTAccessToken^ AccessToken {
   ImGearARTAccessToken^ get();
   void set (    ImGearARTAccessToken^ value);
}

Property Value

ImGearARTAccessToken value.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members


Page Property (ImGearARTAccessController)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessController Class : Page Property
Gets or sets the page associated with the controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTAccessController
Dim value As ImGearARTPage

instance.Page = value

value = instance.Page
public ImGearARTPage Page {get; set;}
public: __property ImGearARTPage* get_Page();
public: __property void set_Page(
   ImGearARTPage* value
);
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImGearARTPage class instance.
See Also

Reference

ImGearARTAccessController Class
ImGearARTAccessController Members


%%PageItemTitle%%

ImGearARTAccessDeniedException Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessDeniedException Class
The Access Denied exception.
Object Model
ImGearARTAccessDeniedException ClassImGearARTPage ClassImGearARTAccessRights Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTAccessDeniedException
   Inherits ImageGear.Core.ImGearException
'Usage

Dim instance As ImGearARTAccessDeniedException
public class ImGearARTAccessDeniedException : ImageGear.Core.ImGearException
public __gc class ImGearARTAccessDeniedException : public ImageGear.Core.ImGearException
public ref class ImGearARTAccessDeniedException : public ImageGear.Core.ImGearException
Remarks
The exception is thrown in case if the access to the object was limited.
Inheritance Hierarchy

System.Object
System.Exception
ImageGear.Core.ImGearException
ImageGear.ART.ImGearARTAccessDeniedException

See Also

Reference

ImGearARTAccessDeniedException Members
ImageGear.ART Namespace
ImGearARTAccessController Class
ImGearARTAccessRights Class
AccessController Property


%%PageItemTitle%% $$Members$$

ImGearARTAccessDeniedException Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessDeniedException Class

The following tables list the members exposed by ImGearARTAccessDeniedException.

Public Properties
 | Name | Description
Public Property | ArtPage | Gets a parent Art Page.
Public Property | RequiredAccessRights | Gets a required access rights.
Public Property | SecureObject | Gets a secure object to which the access was limited.
Top
See Also

Reference

ImGearARTAccessDeniedException Class
ImageGear.ART Namespace
ImGearARTAccessController Class
ImGearARTAccessRights Class
AccessController Property


%%PageItemTitle%% $$Properties$$

ImGearARTAccessDeniedException Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessDeniedException Class

For a list of all members of this type, see ImGearARTAccessDeniedException members.

Public Properties
 | Name | Description
Public Property | ArtPage | Gets a parent Art Page.
Public Property | RequiredAccessRights | Gets a required access rights.
Public Property | SecureObject | Gets a secure object to which the access was limited.
Top
See Also

Reference

ImGearARTAccessDeniedException Class
ImageGear.ART Namespace
ImGearARTAccessController Class
ImGearARTAccessRights Class
AccessController Property


%%PageItemTitle%% $$Methods$$

ImGearARTAccessDeniedException Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessDeniedException Class

For a list of all members of this type, see ImGearARTAccessDeniedException members.

See Also

Reference

ImGearARTAccessDeniedException Class
ImageGear.ART Namespace
ImGearARTAccessController Class
ImGearARTAccessRights Class
AccessController Property


%%PageItemTitle%% $$Events$$

ImGearARTAccessDeniedException Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessDeniedException Class

For a list of all members of this type, see ImGearARTAccessDeniedException members.

See Also

Reference

ImGearARTAccessDeniedException Class
ImageGear.ART Namespace
ImGearARTAccessController Class
ImGearARTAccessRights Class
AccessController Property


ArtPage Property (ImGearARTAccessDeniedException)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessDeniedException Class : ArtPage Property
Gets a parent Art Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ArtPage As ImGearARTPage
'Usage

Dim instance As ImGearARTAccessDeniedException
Dim value As ImGearARTPage

value = instance.ArtPage
public ImGearARTPage ArtPage {get;}
public: __property ImGearARTPage* get_ArtPage();
public:
property ImGearARTPage^ ArtPage {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class instance.
See Also

Reference

ImGearARTAccessDeniedException Class
ImGearARTAccessDeniedException Members


RequiredAccessRights Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessDeniedException Class : RequiredAccessRights Property
Gets a required access rights.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RequiredAccessRights As ImGearARTAccessRights
'Usage

Dim instance As ImGearARTAccessDeniedException
Dim value As ImGearARTAccessRights

value = instance.RequiredAccessRights
public ImGearARTAccessRights RequiredAccessRights {get;}
public: __property ImGearARTAccessRights* get_RequiredAccessRights();
public:
property ImGearARTAccessRights^ RequiredAccessRights {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights enumeration value.
See Also

Reference

ImGearARTAccessDeniedException Class
ImGearARTAccessDeniedException Members


SecureObject Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessDeniedException Class : SecureObject Property
Gets a secure object to which the access was limited.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SecureObject As Object
'Usage

Dim instance As ImGearARTAccessDeniedException
Dim value As Object

value = instance.SecureObject
public object SecureObject {get;}
public: __property Object* get_SecureObject();
public:
property Object^ SecureObject {
   Object^ get();
}

Property Value

The possible values: ImGearARTPage, ImGearARTGroup, ImGearARTMark.
See Also

Reference

ImGearARTAccessDeniedException Class
ImGearARTAccessDeniedException Members


%%PageItemTitle%%

ImGearARTAccessRights Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessRights Class
Defines access rights for the ART objects.
Object Model
ImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights ClassImGearARTAccessRights Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTAccessRights
'Usage

Dim instance As ImGearARTAccessRights
public class ImGearARTAccessRights
public __gc class ImGearARTAccessRights
public ref class ImGearARTAccessRights
Remarks
The access rights are stored as bits of 64bit value and the maximum number of different rights cannot exceed 64. ImageGear predefines some list of access rights that can be extended. If you need to extend the list of access rights, you have to create a new class and inherit it from ImGearARTAccessRights, where you can define your own rights. The bits from 0 to 31 are reserved by ImageGear and must not be used to define the custom rights. For the custom defined rights, use bits from 32 to 63.
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTAccessRights

See Also

Reference

ImGearARTAccessRights Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTAccessRights Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessRights Class

The following tables list the members exposed by ImGearARTAccessRights.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTAccessRights Constructor | Overloaded.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Create | Gets predefined Create access right.
static (Shared in Visual Basic) | Delete | Gets predefined Delete access right.
static (Shared in Visual Basic) | Edit | Gets predefined Edit access right.
static (Shared in Visual Basic) | Export | Gets predefined Export access right.
static (Shared in Visual Basic) | Move | Gets predefined Move access right.
static (Shared in Visual Basic) | Resize | Gets predefined Resize access right.
Public Property | Value | Gets the stored access rights.
static (Shared in Visual Basic) | View | Gets predefined View access right.
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to the current System.Object.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
Public Operators
public Operator And | AND operator for the ImGearARTAccessRights class.
public Operator Or | OR operator for the ImGearARTAccessRights class.
public Operator Equality | Equal operator for the ImGearARTAccessRights class.
public Operator Exclusive Or | XOR operator for the ImGearARTAccessRights class.
public Operator Inequality | Not Equal operator for the ImGearARTAccessRights class.
Top
See Also

Reference

ImGearARTAccessRights Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTAccessRights Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : ImGearARTAccessRights Constructor
Overload List
Overload | Description
ImGearARTAccessRights Constructor() | Initializes a new instance of the ImGearARTAccessRights class.
ImGearARTAccessRights Constructor(Int64) | Initializes a new instance of the ImGearARTAccessRights class.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


%%PageItemTitle%%

ImGearARTAccessRights Constructor()

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class > ImGearARTAccessRights Constructor : ImGearARTAccessRights Constructor()
Initializes a new instance of the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTAccessRights()
public ImGearARTAccessRights()
public: ImGearARTAccessRights();
public:
ImGearARTAccessRights();
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members
Overload List


%%PageItemTitle%%

ImGearARTAccessRights Constructor(Int64)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class > ImGearARTAccessRights Constructor : ImGearARTAccessRights Constructor(Int64)
The access rights value.
Initializes a new instance of the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rights As Long _
)
'Usage

Dim rights As Long

Dim instance As New ImGearARTAccessRights(rights)
public ImGearARTAccessRights(
   long rights
)
public: ImGearARTAccessRights(
   long rights
)
public:
ImGearARTAccessRights(
   int64 rights
)

Parameters

rights
The access rights value.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearARTAccessRights Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessRights Class

For a list of all members of this type, see ImGearARTAccessRights members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to the current System.Object.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
See Also

Reference

ImGearARTAccessRights Class
ImageGear.ART Namespace


Equals Method (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Equals Method
The System.Object to compare with the current System.Object.
Determines whether the specified System.Object is equal to the current System.Object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As ImGearARTAccessRights
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

Boolean value.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


GetHashCode Method (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As ImGearARTAccessRights
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

A hash code for the current System.Object.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


%%PageItemTitle%% $$Properties$$

ImGearARTAccessRights Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessRights Class

For a list of all members of this type, see ImGearARTAccessRights members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Create | Gets predefined Create access right.
static (Shared in Visual Basic) | Delete | Gets predefined Delete access right.
static (Shared in Visual Basic) | Edit | Gets predefined Edit access right.
static (Shared in Visual Basic) | Export | Gets predefined Export access right.
static (Shared in Visual Basic) | Move | Gets predefined Move access right.
static (Shared in Visual Basic) | Resize | Gets predefined Resize access right.
Public Property | Value | Gets the stored access rights.
static (Shared in Visual Basic) | View | Gets predefined View access right.
Top
See Also

Reference

ImGearARTAccessRights Class
ImageGear.ART Namespace


Create Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Create Property
Gets predefined Create access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Create As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Create
public static ImGearARTAccessRights Create {get;}
public: __property static ImGearARTAccessRights* get_Create();
public:
static property ImGearARTAccessRights^ Create {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be created.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Delete Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Delete Property
Gets predefined Delete access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Delete As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Delete
public static ImGearARTAccessRights Delete {get;}
public: __property static ImGearARTAccessRights* get_Delete();
public:
static property ImGearARTAccessRights^ Delete {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be deleted.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Edit Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Edit Property
Gets predefined Edit access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Edit As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Edit
public static ImGearARTAccessRights Edit {get;}
public: __property static ImGearARTAccessRights* get_Edit();
public:
static property ImGearARTAccessRights^ Edit {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be edited.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Export Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Export Property
Gets predefined Export access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Export As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Export
public static ImGearARTAccessRights Export {get;}
public: __property static ImGearARTAccessRights* get_Export();
public:
static property ImGearARTAccessRights^ Export {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be exported.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Move Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Move Property
Gets predefined Move access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Move As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Move
public static ImGearARTAccessRights Move {get;}
public: __property static ImGearARTAccessRights* get_Move();
public:
static property ImGearARTAccessRights^ Move {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be moved.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Resize Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Resize Property
Gets predefined Resize access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Resize As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.Resize
public static ImGearARTAccessRights Resize {get;}
public: __property static ImGearARTAccessRights* get_Resize();
public:
static property ImGearARTAccessRights^ Resize {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be resized.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Value Property (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Value Property
Gets the stored access rights.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Long
'Usage

Dim instance As ImGearARTAccessRights
Dim value As Long

value = instance.Value
public long Value {get;}
public: __property long get_Value();
public:
property int64 Value {
   int64 get();
}

Property Value

Int64 value.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


View Property (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : View Property
Gets predefined View access right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property View As ImGearARTAccessRights
'Usage

Dim value As ImGearARTAccessRights

value = ImGearARTAccessRights.View
public static ImGearARTAccessRights View {get;}
public: __property static ImGearARTAccessRights* get_View();
public:
static property ImGearARTAccessRights^ View {
   ImGearARTAccessRights^ get();
}

Property Value

ImGearARTAccessRights class instance.
Remarks
Controls if an object can be displayed.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


And Operator

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : And Operator
Left operand.
Right operand.
AND operator for the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator And( _
   ByVal left As ImGearARTAccessRights, _
   ByVal right As ImGearARTAccessRights _
) As ImGearARTAccessRights
'Usage

public ImGearARTAccessRights operator &(
   ImGearARTAccessRights left,
   ImGearARTAccessRights right
)
public: ImGearARTAccessRights* op_BitwiseAnd(
   ImGearARTAccessRights* left,
   ImGearARTAccessRights* right
)
public:
ImGearARTAccessRights^ operator &(
   ImGearARTAccessRights^ left,
   ImGearARTAccessRights^ right
)

Parameters

left
Left operand.
right
Right operand.

Return Value

Returns new instance of the ImGearARTAccessRights class.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Or Operator

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Or Operator
Left operand.
Right operand.
OR operator for the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator Or( _
   ByVal left As ImGearARTAccessRights, _
   ByVal right As ImGearARTAccessRights _
) As ImGearARTAccessRights
'Usage

public ImGearARTAccessRights operator |(
   ImGearARTAccessRights left,
   ImGearARTAccessRights right
)
public: ImGearARTAccessRights* op_BitwiseOr(
   ImGearARTAccessRights* left,
   ImGearARTAccessRights* right
)
public:
ImGearARTAccessRights^ operator |(
   ImGearARTAccessRights^ left,
   ImGearARTAccessRights^ right
)

Parameters

left
Left operand.
right
Right operand.

Return Value

Returns new instance of the ImGearARTAccessRights class.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Equality Operator (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Equality Operator
Left operand.
Right operand.
Equal operator for the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator =( _
   ByVal left As ImGearARTAccessRights, _
   ByVal right As ImGearARTAccessRights _
) As Boolean
'Usage

public bool operator ==(
   ImGearARTAccessRights left,
   ImGearARTAccessRights right
)
public: bool op_Equality(
   ImGearARTAccessRights* left,
   ImGearARTAccessRights* right
)
public:
bool operator ==(
   ImGearARTAccessRights^ left,
   ImGearARTAccessRights^ right
)

Parameters

left
Left operand.
right
Right operand.

Return Value

Returns Boolean value.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Exclusive Or Operator

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Exclusive Or Operator
Left operand.
Right operand.
XOR operator for the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator Xor( _
   ByVal left As ImGearARTAccessRights, _
   ByVal right As ImGearARTAccessRights _
) As ImGearARTAccessRights
'Usage

public ImGearARTAccessRights operator ^(
   ImGearARTAccessRights left,
   ImGearARTAccessRights right
)
public: ImGearARTAccessRights* op_ExclusiveOr(
   ImGearARTAccessRights* left,
   ImGearARTAccessRights* right
)
public:
ImGearARTAccessRights^ operator ^(
   ImGearARTAccessRights^ left,
   ImGearARTAccessRights^ right
)

Parameters

left
Left operand.
right
Right operand.

Return Value

Returns new instance of the ImGearARTAccessRights class.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


Inequality Operator (ImGearARTAccessRights)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAccessRights Class : Inequality Operator
Left operand.
Right operand.
Not Equal operator for the ImGearARTAccessRights class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator <>( _
   ByVal left As ImGearARTAccessRights, _
   ByVal right As ImGearARTAccessRights _
) As Boolean
'Usage

public bool operator !=(
   ImGearARTAccessRights left,
   ImGearARTAccessRights right
)
public: bool op_Inequality(
   ImGearARTAccessRights* left,
   ImGearARTAccessRights* right
)
public:
bool operator !=(
   ImGearARTAccessRights^ left,
   ImGearARTAccessRights^ right
)

Parameters

left
Left operand.
right
Right operand.

Return Value

Returns Boolean value.
See Also

Reference

ImGearARTAccessRights Class
ImGearARTAccessRights Members


%%PageItemTitle%%

ImGearARTAccessToken Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessToken Class
The base class of access token.
Object Model
ImGearARTAccessToken Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTAccessToken
'Usage

Dim instance As ImGearARTAccessToken
public abstract class ImGearARTAccessToken
public __gc abstract class ImGearARTAccessToken
public ref class ImGearARTAccessToken abstract
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTAccessToken

See Also

Reference

ImGearARTAccessToken Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTAccessToken Class Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccessToken Class

The following tables list the members exposed by ImGearARTAccessToken.

See Also

Reference

ImGearARTAccessToken Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTArrow Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTArrow Class
Represents legacy ART Arrow mark.
Object Model
ImGearARTArrow ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTArrow
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTArrow
public class ImGearARTArrow : ImGearARTMark
public __gc class ImGearARTArrow : public ImGearARTMark
public ref class ImGearARTArrow : public ImGearARTMark
Example
  • C#
// Setup start and endpoint for the arrow.
ImGearPoint igPointStart = new ImGearPoint(0, 0);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the Arrow annotation with a width of 4, no highlight,
//  regular pointer head type, a 30 degree angle for the head, and a length of 20 for the head.
ImGearARTArrow igARTArrow = new ImGearARTArrow(
    igPointStart, igPointEnd, igRGBQuad, 4, false,
    ImGearARTLineHeadType.POINTER, 30, 20
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTArrow, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the arrow.
Dim igPointStart As New ImGearPoint(0, 0)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for annotation.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the Arrow annotation with a width of 4, no highlight,
'  regular pointer head type, a 30 degree angle for the head, and a length of 20 for the head.
Dim igARTArrow As New ImGearARTArrow( _
 igPointStart, igPointEnd, igRGBQuad, _
 4, False, ImGearARTLineHeadType.POINTER, 30, 20)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTArrow, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTArrow

See Also

Reference

ImGearARTArrow Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTArrow Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTArrow Class

The following tables list the members exposed by ImGearARTArrow.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTArrow Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the arrow color.
Public Property | EndPoint | Gets or sets the end point of the arrow.
Public Property | HeadAngle | Gets or sets the angle of the arrow head.
Public Property | HeadLength | Gets or sets the length of the arrow head.
Public Property | HeadType | Gets or sets the type of the arrow head.
Public Property | Highlight | Gets or sets a value indicating whether the arrow is highlighted.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartPoint | Gets or sets the start point of the arrow.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the arrow line.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTArrow Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTArrow Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : ImGearARTArrow Constructor
Overload List
Overload | Description
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTArrow class object.
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean) | Initializes a new instance of the ImGearARTArrow class object.
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean,ImGearARTLineHeadType,Int32,Int32) | Initializes a new instance of the ImGearARTArrow class object.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
Start point of the arrow.
End point of the arrow.
Arrow color.
Initializes a new instance of the ImGearARTArrow class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTArrow(startPoint, endPoint, color)
public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)
public: ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color
)
public:
ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Arrow color.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean)
Start point of the arrow.
End point of the arrow.
Color of the arrow.
Width of the arrow.
Specifies whether the arrow is highlighted or not.
Initializes a new instance of the ImGearARTArrow class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim width As Integer
Dim isHighlighted As Boolean

Dim instance As New ImGearARTArrow(startPoint, endPoint, color, width, isHighlighted)
public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   int width,
   bool isHighlighted
)
public: ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   int width,
   bool isHighlighted
)
public:
ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   int width,
   bool isHighlighted
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTArrow Class


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean,ImGearARTLineHeadType,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,Int32,Boolean,ImGearARTLineHeadType,Int32,Int32)
Start point of the arrow.
End point of the arrow.
Color of the arrow.
Width of the arrow.
Specifies whether the arrow is highlighted or not.
Type of the arrow head.
Angle of the arrow head.
Length of the arrow head.
Initializes a new instance of the ImGearARTArrow class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer, _
   ByVal isHighlighted As Boolean, _
   ByVal headType As ImGearARTLineHeadType, _
   ByVal headAngle As Integer, _
   ByVal headLength As Integer _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim width As Integer
Dim isHighlighted As Boolean
Dim headType As ImGearARTLineHeadType
Dim headAngle As Integer
Dim headLength As Integer

Dim instance As New ImGearARTArrow(startPoint, endPoint, color, width, isHighlighted, headType, headAngle, headLength)
public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   int width,
   bool isHighlighted,
   ImGearARTLineHeadType headType,
   int headAngle,
   int headLength
)
public: ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   int width,
   bool isHighlighted,
   ImGearARTLineHeadType headType,
   int headAngle,
   int headLength
)
public:
ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   int width,
   bool isHighlighted,
   ImGearARTLineHeadType headType,
   int headAngle,
   int headLength
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not.
headType
Type of the arrow head.
headAngle
Angle of the arrow head.
headLength
Length of the arrow head.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTLineHeadType Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTArrow Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTArrow Class

For a list of all members of this type, see ImGearARTArrow members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTArrow Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTArrow Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTArrow Class

For a list of all members of this type, see ImGearARTArrow members.

See Also

Reference

ImGearARTArrow Class
ImageGear.ART Namespace


Flip Method (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTArrow
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Flip Method


GetRenderBounds Method (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTArrow
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


Move Method (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTArrow
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


Rotate Method (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTArrow
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Rotate Method


Scale Method (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTArrow
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTArrow Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTArrow Class

For a list of all members of this type, see ImGearARTArrow members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the arrow color.
Public Property | EndPoint | Gets or sets the end point of the arrow.
Public Property | HeadAngle | Gets or sets the angle of the arrow head.
Public Property | HeadLength | Gets or sets the length of the arrow head.
Public Property | HeadType | Gets or sets the type of the arrow head.
Public Property | Highlight | Gets or sets a value indicating whether the arrow is highlighted.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartPoint | Gets or sets the start point of the arrow.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the arrow line.
Top
See Also

Reference

ImGearARTArrow Class
ImageGear.ART Namespace


Bounds Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearRectangle Structure


Color Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Color Property
Gets or sets the arrow color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTArrow
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

IImGearRGBQuad value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearRGBQuad Structure


EndPoint Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : EndPoint Property
Gets or sets the end point of the arrow.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoint As ImGearPoint
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
public ImGearPoint EndPoint {get; set;}
public: __property ImGearPoint get_EndPoint();
public: __property void set_EndPoint(
   ImGearPoint value
);
public:
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearPoint Structure


HeadAngle Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : HeadAngle Property
Gets or sets the angle of the arrow head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadAngle As Integer
'Usage

Dim instance As ImGearARTArrow
Dim value As Integer

instance.HeadAngle = value

value = instance.HeadAngle
public int HeadAngle {get; set;}
public: __property int get_HeadAngle();
public: __property void set_HeadAngle(
   int value
);
public:
property int HeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


HeadLength Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : HeadLength Property
Gets or sets the length of the arrow head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadLength As Integer
'Usage

Dim instance As ImGearARTArrow
Dim value As Integer

instance.HeadLength = value

value = instance.HeadLength
public int HeadLength {get; set;}
public: __property int get_HeadLength();
public: __property void set_HeadLength(
   int value
);
public:
property int HeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


HeadType Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : HeadType Property
Gets or sets the type of the arrow head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadType As ImGearARTLineHeadType
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearARTLineHeadType

instance.HeadType = value

value = instance.HeadType
public ImGearARTLineHeadType HeadType {get; set;}
public: __property ImGearARTLineHeadType get_HeadType();
public: __property void set_HeadType(
   ImGearARTLineHeadType value
);
public:
property ImGearARTLineHeadType HeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearARTLineHeadType Enumeration


Highlight Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Highlight Property
Gets or sets a value indicating whether the arrow is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTArrow
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


SelectionPoints Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTArrow
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


SelectionType Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


StartPoint Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : StartPoint Property
Gets or sets the start point of the arrow.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPoint As ImGearPoint
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
public ImGearPoint StartPoint {get; set;}
public: __property ImGearPoint get_StartPoint();
public: __property void set_StartPoint(
   ImGearPoint value
);
public:
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearPoint Structure


Type Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTArrow
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType.ARROW enumeration value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTArrow)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTArrow
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


Visible Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTArrow
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


Width Property (ImGearARTArrow)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTArrow Class : Width Property
Gets or sets the width of the arrow line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTArrow
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

ImGearARTAudio Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAudio Class
Represents ART Audio mark.
Object Model
ImGearARTAudio ClassImGearRectangle StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTAudio
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTAudio
public class ImGearARTAudio : ImGearARTMark
public __gc class ImGearARTAudio : public ImGearARTMark
public ref class ImGearARTAudio : public ImGearARTMark
Example
  • C#
// Setup rectangle for the audio mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10,10,100,20);
// Create the audio mark annotation pointing to test.wav
ImGearARTAudio igARTAudio = new ImGearARTAudio(
    igRectangle, "test.wav"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTAudio, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the audio mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 20)
' Create the audio mark annotation pointing to test.wav
Dim igARTAudio As New ImGearARTAudio(igRectangle, "test.wav")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTAudio, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTAudio

See Also

Reference

ImGearARTAudio Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTAudio Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAudio Class

The following tables list the members exposed by ImGearARTAudio.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTAudio Constructor | Initializes a new instance of the ImGearARTAudio class object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the sound file name.
Public Property | Height | Gets or sets the height of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTAudio Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTAudio Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : ImGearARTAudio Constructor
The mark rectangle.
The filename of the mark.
Initializes a new instance of the ImGearARTAudio class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fileName As String _
)
'Usage

Dim rect As IImGearRectangle
Dim fileName As String

Dim instance As New ImGearARTAudio(rect, fileName)
public ImGearARTAudio(
   IImGearRectangle rect,
   string fileName
)
public: ImGearARTAudio(
   IImGearRectangle* rect,
   string* fileName
)
public:
ImGearARTAudio(
   IImGearRectangle^ rect,
   String^ fileName
)

Parameters

rect
The mark rectangle.
fileName
The filename of the mark.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTAudio Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAudio Class

For a list of all members of this type, see ImGearARTAudio members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTAudio Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTAudio Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAudio Class

For a list of all members of this type, see ImGearARTAudio members.

See Also

Reference

ImGearARTAudio Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTAudio Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : ImGearARTAudio Constructor
Overload List
Overload | Description
ImGearARTAudio Constructor | Initializes a new instance of the ImGearARTAudio class object.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Flip Method (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTAudio
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
Flip Method


GetRenderBounds Method (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTAudio
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Move Method (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTAudio
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Rotate Method (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTAudio
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
Rotate Method


Scale Method (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTAudio
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTAudio Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAudio Class

For a list of all members of this type, see ImGearARTAudio members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the sound file name.
Public Property | Height | Gets or sets the height of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
See Also

Reference

ImGearARTAudio Class
ImageGear.ART Namespace


Bounds Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTAudio
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
ImGearRectangle Structure


FileName Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : FileName Property
Gets or sets the sound file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As ImGearARTAudio
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Height Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTAudio
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


SelectionType Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTAudio
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Type Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTAudio
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType.AUDIO enumeration value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTAudio
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Width Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTAudio
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


X Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : X Property
Gets or sets the X coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTAudio
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


Y Property (ImGearARTAudio)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTAudio Class : Y Property
Gets or sets the Y coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTAudio
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

ImGearARTBorder Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBorder Class
Provides mark's border attributes.
Object Model
ImGearARTBorder ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTBorder
'Usage

Dim instance As ImGearARTBorder
public class ImGearARTBorder
public __gc class ImGearARTBorder
public ref class ImGearARTBorder
Example
  • C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTBorder

See Also

Reference

ImGearARTBorder Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTBorder Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBorder Class

The following tables list the members exposed by ImGearARTBorder.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTBorder Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the border color.
Public Property | Style | Gets or sets the border style.
Public Property | Width | Gets or sets the width of the border line.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTBorder Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTBorder Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : ImGearARTBorder Constructor
Overload List
Overload | Description
ImGearARTBorder Constructor(IImGearRGBQuad,Int32) | Initializes a new instance of the ImGearARTBorder class object.
ImGearARTBorder Constructor(IImGearRGBQuad,Int32,ImGearARTPenStyle) | Initializes a new instance of the ImGearARTBorder class object.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

ImGearARTBorder Constructor(IImGearRGBQuad,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class > ImGearARTBorder Constructor : ImGearARTBorder Constructor(IImGearRGBQuad,Int32)
The border color.
The border width.
Initializes a new instance of the ImGearARTBorder class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer _
)
'Usage

Dim color As IImGearRGBQuad
Dim width As Integer

Dim instance As New ImGearARTBorder(color, width)
public ImGearARTBorder(
   IImGearRGBQuad color,
   int width
)
public: ImGearARTBorder(
   IImGearRGBQuad* color,
   int width
)
public:
ImGearARTBorder(
   IImGearRGBQuad^ color,
   int width
)

Parameters

color
The border color.
width
The border width.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTBorder Constructor(IImGearRGBQuad,Int32,ImGearARTPenStyle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class > ImGearARTBorder Constructor : ImGearARTBorder Constructor(IImGearRGBQuad,Int32,ImGearARTPenStyle)
The border color.
The border width.
The border style.
Initializes a new instance of the ImGearARTBorder class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer, _
   ByVal style As ImGearARTPenStyle _
)
'Usage

Dim color As IImGearRGBQuad
Dim width As Integer
Dim style As ImGearARTPenStyle

Dim instance As New ImGearARTBorder(color, width, style)
public ImGearARTBorder(
   IImGearRGBQuad color,
   int width,
   ImGearARTPenStyle style
)
public: ImGearARTBorder(
   IImGearRGBQuad* color,
   int width,
   ImGearARTPenStyle style
)
public:
ImGearARTBorder(
   IImGearRGBQuad^ color,
   int width,
   ImGearARTPenStyle style
)

Parameters

color
The border color.
width
The border width.
style
The border style.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTBorder Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBorder Class

For a list of all members of this type, see ImGearARTBorder members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
See Also

Reference

ImGearARTBorder Class
ImageGear.ART Namespace


OnPropertyChanged Method (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : OnPropertyChanged Method
Occurs when a property value changes.
Overload List
Overload | Description
OnPropertyChanged(String) | Occurs when a property value changes.
OnPropertyChanged(String,Object,Object) | Occurs when a ART property value changes.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


OnPropertyChanged(String) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class > OnPropertyChanged Method : OnPropertyChanged(String) Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearARTBorder
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List


OnPropertyChanged(String,Object,Object) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class > OnPropertyChanged Method : OnPropertyChanged(String,Object,Object) Method
The name of the property that changed.
The old value of the property before changing.
The new value of the property after changing.
Occurs when a ART property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As ImGearARTBorder
Dim name As String
Dim oldValue As Object
Dim newValue As Object

instance.OnPropertyChanged(name, oldValue, newValue)
protected void OnPropertyChanged(
   string name,
   object oldValue,
   object newValue
)
protected: void OnPropertyChanged(
   string* name,
   Object* oldValue,
   Object* newValue
)
protected:
void OnPropertyChanged(
   String^ name,
   Object^ oldValue,
   Object^ newValue
)

Parameters

name
The name of the property that changed.
oldValue
The old value of the property before changing.
newValue
The new value of the property after changing.
Remarks
Note: this method does not call itself the OnPropertyChanged(String), which is responsible for firing of PropertyChanged event. To provide System.ComponentModel.INotifyPropertyChanged functionality, please call OnPropertyChanged(String) explicitly.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearARTBorder Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBorder Class

For a list of all members of this type, see ImGearARTBorder members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the border color.
Public Property | Style | Gets or sets the border style.
Public Property | Width | Gets or sets the width of the border line.
Top
See Also

Reference

ImGearARTBorder Class
ImageGear.ART Namespace


Color Property (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : Color Property
Gets or sets the border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTBorder
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
ImGearRGBQuad Structure


Style Property (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : Style Property
Gets or sets the border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTBorder
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
ImGearARTPenStyle Enumeration


Width Property (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : Width Property
Gets or sets the width of the border line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTBorder
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%% $$Events$$

ImGearARTBorder Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBorder Class

For a list of all members of this type, see ImGearARTBorder members.

Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTBorder Class
ImageGear.ART Namespace


ARTPropertyChanged Event (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : ARTPropertyChanged Event
Occurs when a property value changes and presents old and new values of the property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ARTPropertyChanged As ARTPropertyChangedEventHandler
'Usage

Dim instance As ImGearARTBorder
Dim handler As ARTPropertyChangedEventHandler

AddHandler instance.ARTPropertyChanged, handler
public event ARTPropertyChangedEventHandler ARTPropertyChanged
public: __event ARTPropertyChangedEventHandler* ARTPropertyChanged
public:
event ARTPropertyChangedEventHandler^ ARTPropertyChanged
Event Data

The event handler receives an argument of type ImGearARTPropertyChangedEventArgs containing data related to this event. The following ImGearARTPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewPropertyValue | Gets new value of changed property.
OldPropertyValue | Gets old value of changed property.
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


PropertyChanged Event (ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTBorder Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearARTBorder
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

ImGearARTButton Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class
Represents ART Button mark.
Object Model
ImGearARTButton ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTButton
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTButton
public class ImGearARTButton : ImGearARTMark
public __gc class ImGearARTButton : public ImGearARTMark
public ref class ImGearARTButton : public ImGearARTMark
Example
  • C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(40, 40, 200);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the button annotation.
ImGearARTButton igARTButton = new ImGearARTButton(
    igRectangle, "ImGearARTButton annotation", igRGBQuadText,
    igRGBQuadFill, 255, "Arial", (float)14.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTButton, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(40, 40, 200)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the button annotation.
Dim igARTButton As New ImGearARTButton( _
 igRectangle, "ImGearARTButton annotation", igRGBQuadText, _
 igRGBQuadFill, 255, "Arial", CSng(14), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTButton, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTButton

See Also

Reference

ImGearARTButton Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTButton Class Members
Fields Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class

The following tables list the members exposed by ImGearARTButton.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTButton Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | State | The state of the button.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the button.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the button's text.
Public Property | FontSize | Gets or sets the size of the font in points.
Public Property | FontStyleART | Gets or sets the font style of the button's text.
Public Property | Height | Gets or sets the height of the button.
Public Property | Opacity | Gets or sets the opacity of the button.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the button text.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the button.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTButton Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTButton Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : ImGearARTButton Constructor
Overload List
Overload | Description
ImGearARTButton Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTButton class object.
ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,Int32,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTButton class object.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

ImGearARTButton Constructor(IImGearRectangle,String)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class > ImGearARTButton Constructor : ImGearARTButton Constructor(IImGearRectangle,String)
The mark rectangle.
Button text.
Initializes a new instance of the ImGearARTButton class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String

Dim instance As New ImGearARTButton(rect, text)
public ImGearARTButton(
   IImGearRectangle rect,
   string text
)
public: ImGearARTButton(
   IImGearRectangle* rect,
   string* text
)
public:
ImGearARTButton(
   IImGearRectangle^ rect,
   String^ text
)

Parameters

rect
The mark rectangle.
text
Button text.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,Int32,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class > ImGearARTButton Constructor : ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,Int32,String,Single,ImGearARTFontStyles)
The mark rectangle.
Button text.
Button text color.
The fill color of the button.
Button opacity.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTButton class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal opacity As Integer, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fillColor As IImGearRGBQuad
Dim opacity As Integer
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTButton(rect, text, textColor, fillColor, opacity, fontName, fontSize, fontStyle)
public ImGearARTButton(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor,
   int opacity,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTButton(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   IImGearRGBQuad* fillColor,
   int opacity,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTButton(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   IImGearRGBQuad^ fillColor,
   int opacity,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

rect
The mark rectangle.
text
Button text.
textColor
Button text color.
fillColor
The fill color of the button.
opacity
Button opacity.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTButton Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class

For a list of all members of this type, see ImGearARTButton members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTButton Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTButton Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class

For a list of all members of this type, see ImGearARTButton members.

See Also

Reference

ImGearARTButton Class
ImageGear.ART Namespace


Flip Method (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTButton
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Flip Method


GetRenderBounds Method (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTButton
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Move Method (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTButton
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Rotate Method (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTButton
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Rotate Method


Scale Method (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTButton
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTButton Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class

For a list of all members of this type, see ImGearARTButton members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the button.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the button's text.
Public Property | FontSize | Gets or sets the size of the font in points.
Public Property | FontStyleART | Gets or sets the font style of the button's text.
Public Property | Height | Gets or sets the height of the button.
Public Property | Opacity | Gets or sets the opacity of the button.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the button text.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the button.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
See Also

Reference

ImGearARTButton Class
ImageGear.ART Namespace


Bounds Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTButton
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
ImGearRectangle Structure


FillColor Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : FillColor Property
Gets or sets the fill color of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTButton
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
ImGearRGBQuad Structure


FontDisablePPM Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTButton
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

System.Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


FontName Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : FontName Property
Gets or sets the font name of the button's text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTButton
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

Name string.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


FontSize Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : FontSize Property
Gets or sets the size of the font in points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTButton
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any float positive value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


FontStyleART Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : FontStyleART Property
Gets or sets the font style of the button's text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTButton
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Height Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Height Property
Gets or sets the height of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTButton
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Opacity Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Opacity Property
Gets or sets the opacity of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTButton
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


SelectionType Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTButton
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Text Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Text Property
Gets or sets the button text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTButton
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

Text string.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


TextColor Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTButton
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
ImGearRGBQuad Structure


Type Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTButton
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTButton
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Width Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Width Property
Gets or sets the width of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTButton
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


X Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : X Property
Gets or sets the X coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTButton
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


Y Property (ImGearARTButton)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : Y Property
Gets or sets the Y coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTButton
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%% $$Fields$$

ImGearARTButton Class Fields

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButton Class

For a list of all members of this type, see ImGearARTButton members.

Public Fields
 | Name | Description
Public Field | State | The state of the button.
Top
See Also

Reference

ImGearARTButton Class
ImageGear.ART Namespace


State Field

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTButton Class : State Field
The state of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public State As ImGearARTButtonState
'Usage

Dim instance As ImGearARTButton
Dim value As ImGearARTButtonState

value = instance.State

instance.State = value
public ImGearARTButtonState State
public: ImGearARTButtonState State
public:
ImGearARTButtonState State

Field Value

ImGearARTButtonState enumeration value.
See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
ImGearARTButtonState Enumeration


%%PageItemTitle%%

ImGearARTCallout Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCallout Class
Provides text mark's callout attributes.
Object Model
ImGearARTCallout ClassImGearARTBorder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCallout
'Usage

Dim instance As ImGearARTCallout
public class ImGearARTCallout
public __gc class ImGearARTCallout
public ref class ImGearARTCallout
Remarks

Callout is the shape object that points to the object it tells about.

Example
  • C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTCallout

See Also

Reference

ImGearARTCallout Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCallout Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCallout Class

The following tables list the members exposed by ImGearARTCallout.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTCallout Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Line | Gets or sets the callout line attributes.
Public Property | Type | Gets or sets the callout type.
Public Property | X | Gets or sets the callout pointer X location.
Public Property | Y | Gets or sets the callout pointer Y location.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTCallout Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTCallout Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : ImGearARTCallout Constructor
Overload List
Overload | Description
ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32) | Initializes a new instance of the ImGearARTCallout class object.
ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32,ImGearARTBorder) | Initializes a new instance of the ImGearARTCallout class object.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class > ImGearARTCallout Constructor : ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32)
The callout type.
Callout pointer X location.
Callout pointer Y location.
Initializes a new instance of the ImGearARTCallout class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As ImGearARTCalloutType, _
   ByVal pointX As Integer, _
   ByVal pointY As Integer _
)
'Usage

Dim type As ImGearARTCalloutType
Dim pointX As Integer
Dim pointY As Integer

Dim instance As New ImGearARTCallout(type, pointX, pointY)
public ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY
)
public: ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY
)
public:
ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY
)

Parameters

type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List


%%PageItemTitle%%

ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32,ImGearARTBorder)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class > ImGearARTCallout Constructor : ImGearARTCallout Constructor(ImGearARTCalloutType,Int32,Int32,ImGearARTBorder)
The callout type.
Callout pointer X location.
Callout pointer Y location.
Callout line attributes.
Initializes a new instance of the ImGearARTCallout class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As ImGearARTCalloutType, _
   ByVal pointX As Integer, _
   ByVal pointY As Integer, _
   ByVal line As ImGearARTBorder _
)
'Usage

Dim type As ImGearARTCalloutType
Dim pointX As Integer
Dim pointY As Integer
Dim line As ImGearARTBorder

Dim instance As New ImGearARTCallout(type, pointX, pointY, line)
public ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY,
   ImGearARTBorder line
)
public: ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY,
   ImGearARTBorder* line
)
public:
ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY,
   ImGearARTBorder^ line
)

Parameters

type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.
line
Callout line attributes.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List
ImGearARTCalloutType Enumeration
ImGearARTBorder Class


%%PageItemTitle%% $$Methods$$

ImGearARTCallout Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCallout Class

For a list of all members of this type, see ImGearARTCallout members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
See Also

Reference

ImGearARTCallout Class
ImageGear.ART Namespace


OnPropertyChanged Method (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : OnPropertyChanged Method
Occurs when a property value changes.
Overload List
Overload | Description
OnPropertyChanged(String) | Occurs when a property value changes.
OnPropertyChanged(String,Object,Object) | Occurs when a ART property value changes.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


OnPropertyChanged(String) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class > OnPropertyChanged Method : OnPropertyChanged(String) Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearARTCallout
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List


OnPropertyChanged(String,Object,Object) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class > OnPropertyChanged Method : OnPropertyChanged(String,Object,Object) Method
The name of the property that changed.
The old value of the property before changing.
The new value of the property after changing.
Occurs when a ART property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As ImGearARTCallout
Dim name As String
Dim oldValue As Object
Dim newValue As Object

instance.OnPropertyChanged(name, oldValue, newValue)
protected void OnPropertyChanged(
   string name,
   object oldValue,
   object newValue
)
protected: void OnPropertyChanged(
   string* name,
   Object* oldValue,
   Object* newValue
)
protected:
void OnPropertyChanged(
   String^ name,
   Object^ oldValue,
   Object^ newValue
)

Parameters

name
The name of the property that changed.
oldValue
The old value of the property before changing.
newValue
The new value of the property after changing.
Remarks
Note: this method does not call itself the OnPropertyChanged(String), which is responsible for firing of PropertyChanged event. To provide System.ComponentModel.INotifyPropertyChanged functionality, please call OnPropertyChanged(String) explicitly.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearARTCallout Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCallout Class

For a list of all members of this type, see ImGearARTCallout members.

Public Properties
 | Name | Description
Public Property | Line | Gets or sets the callout line attributes.
Public Property | Type | Gets or sets the callout type.
Public Property | X | Gets or sets the callout pointer X location.
Public Property | Y | Gets or sets the callout pointer Y location.
Top
See Also

Reference

ImGearARTCallout Class
ImageGear.ART Namespace


Line Property (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : Line Property
Gets or sets the callout line attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Line As ImGearARTBorder
'Usage

Dim instance As ImGearARTCallout
Dim value As ImGearARTBorder

instance.Line = value

value = instance.Line
public ImGearARTBorder Line {get; set;}
public: __property ImGearARTBorder* get_Line();
public: __property void set_Line(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Line {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
ImGearARTBorder Class


Type Property (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : Type Property
Gets or sets the callout type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearARTCalloutType
'Usage

Dim instance As ImGearARTCallout
Dim value As ImGearARTCalloutType

instance.Type = value

value = instance.Type
public ImGearARTCalloutType Type {get; set;}
public: __property ImGearARTCalloutType get_Type();
public: __property void set_Type(
   ImGearARTCalloutType value
);
public:
property ImGearARTCalloutType Type {
   ImGearARTCalloutType get();
   void set (    ImGearARTCalloutType value);
}

Property Value

ImGearARTCalloutType enumeration value.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
ImGearARTCalloutType Enumeration


X Property (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : X Property
Gets or sets the callout pointer X location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTCallout
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the left edge of the text mark.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


Y Property (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : Y Property
Gets or sets the callout pointer Y location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTCallout
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the top edge of the text mark.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%% $$Events$$

ImGearARTCallout Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCallout Class

For a list of all members of this type, see ImGearARTCallout members.

Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTCallout Class
ImageGear.ART Namespace


ARTPropertyChanged Event (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : ARTPropertyChanged Event
Occurs when a property value changes and presents old and new values of the property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ARTPropertyChanged As ARTPropertyChangedEventHandler
'Usage

Dim instance As ImGearARTCallout
Dim handler As ARTPropertyChangedEventHandler

AddHandler instance.ARTPropertyChanged, handler
public event ARTPropertyChangedEventHandler ARTPropertyChanged
public: __event ARTPropertyChangedEventHandler* ARTPropertyChanged
public:
event ARTPropertyChangedEventHandler^ ARTPropertyChanged
Event Data

The event handler receives an argument of type ImGearARTPropertyChangedEventArgs containing data related to this event. The following ImGearARTPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewPropertyValue | Gets new value of changed property.
OldPropertyValue | Gets old value of changed property.
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


PropertyChanged Event (ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCallout Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearARTCallout
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

ImGearARTCreateSecureObjectDataEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreateSecureObjectDataEventArgs Class
The ImGearARTCreateSecureObjectData event arguments.
Object Model
ImGearARTCreateSecureObjectDataEventArgs ClassImGearARTGroup ClassImGearARTMark ClassImGearARTMark ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCreateSecureObjectDataEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTCreateSecureObjectDataEventArgs
public class ImGearARTCreateSecureObjectDataEventArgs : System.EventArgs
public __gc class ImGearARTCreateSecureObjectDataEventArgs : public System.EventArgs
public ref class ImGearARTCreateSecureObjectDataEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTCreateSecureObjectDataEventArgs

See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCreateSecureObjectDataEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreateSecureObjectDataEventArgs Class

The following tables list the members exposed by ImGearARTCreateSecureObjectDataEventArgs.

Public Properties
 | Name | Description
Public Property | Group | Gets the group.
Public Property | Mark | Gets the mark.
Public Property | Page | Gets the page.
Public Property | SecureObjectData | Gets the secure object data associated with the art object.
Top
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTCreateSecureObjectDataEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreateSecureObjectDataEventArgs Class

For a list of all members of this type, see ImGearARTCreateSecureObjectDataEventArgs members.

Public Properties
 | Name | Description
Public Property | Group | Gets the group.
Public Property | Mark | Gets the mark.
Public Property | Page | Gets the page.
Public Property | SecureObjectData | Gets the secure object data associated with the art object.
Top
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImageGear.ART Namespace


Group Property (ImGearARTCreateSecureObjectDataEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreateSecureObjectDataEventArgs Class : Group Property
Gets the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Group As ImGearARTGroup
'Usage

Dim instance As ImGearARTCreateSecureObjectDataEventArgs
Dim value As ImGearARTGroup

value = instance.Group
public ImGearARTGroup Group {get;}
public: __property ImGearARTGroup* get_Group();
public:
property ImGearARTGroup^ Group {
   ImGearARTGroup^ get();
}

Property Value

ImGearARTGroup class instance.
Remarks
Returns not null value if SecureObjectData is associated with the group, otherwise returns null.
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImGearARTCreateSecureObjectDataEventArgs Members


Mark Property (ImGearARTCreateSecureObjectDataEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreateSecureObjectDataEventArgs Class : Mark Property
Gets the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTCreateSecureObjectDataEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class instance.
Remarks
Returns not null value if SecureObjectData is associated with the mark, otherwise returns null.
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImGearARTCreateSecureObjectDataEventArgs Members


Page Property (ImGearARTCreateSecureObjectDataEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreateSecureObjectDataEventArgs Class : Page Property
Gets the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTCreateSecureObjectDataEventArgs
Dim value As ImGearARTPage

value = instance.Page
public ImGearARTPage Page {get;}
public: __property ImGearARTPage* get_Page();
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class instance.
Remarks
Returns not null value if SecureObjectData is associated with the page, otherwise returns null.
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImGearARTCreateSecureObjectDataEventArgs Members


SecureObjectData Property (ImGearARTCreateSecureObjectDataEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreateSecureObjectDataEventArgs Class : SecureObjectData Property
Gets the secure object data associated with the art object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SecureObjectData As String
'Usage

Dim instance As ImGearARTCreateSecureObjectDataEventArgs
Dim value As String

value = instance.SecureObjectData
public string SecureObjectData {get;}
public: __property string* get_SecureObjectData();
public:
property String^ SecureObjectData {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTCreateSecureObjectDataEventArgs Class
ImGearARTCreateSecureObjectDataEventArgs Members


%%PageItemTitle%%

ImGearARTCreatingGroupEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingGroupEventArgs Class
CreatingGroupEvent arguments.
Object Model
ImGearARTCreatingGroupEventArgs ClassImGearARTGroup ClassImGearARTMark ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCreatingGroupEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTCreatingGroupEventArgs
public class ImGearARTCreatingGroupEventArgs : System.EventArgs
public __gc class ImGearARTCreatingGroupEventArgs : public System.EventArgs
public ref class ImGearARTCreatingGroupEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTCreatingGroupEventArgs

See Also

Reference

ImGearARTCreatingGroupEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCreatingGroupEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingGroupEventArgs Class

The following tables list the members exposed by ImGearARTCreatingGroupEventArgs.

Public Properties
 | Name | Description
Public Property | Group | Gets the group.
Public Property | IgnoreGroup | Gets or sets a value indicating whether the group should not be loaded into the page.
Public Property | Page | Gets the group's parent page.
Top
See Also

Reference

ImGearARTCreatingGroupEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTCreatingGroupEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingGroupEventArgs Class

For a list of all members of this type, see ImGearARTCreatingGroupEventArgs members.

Public Properties
 | Name | Description
Public Property | Group | Gets the group.
Public Property | IgnoreGroup | Gets or sets a value indicating whether the group should not be loaded into the page.
Public Property | Page | Gets the group's parent page.
Top
See Also

Reference

ImGearARTCreatingGroupEventArgs Class
ImageGear.ART Namespace


Group Property (ImGearARTCreatingGroupEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingGroupEventArgs Class : Group Property
Gets the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Group As ImGearARTGroup
'Usage

Dim instance As ImGearARTCreatingGroupEventArgs
Dim value As ImGearARTGroup

value = instance.Group
public ImGearARTGroup Group {get;}
public: __property ImGearARTGroup* get_Group();
public:
property ImGearARTGroup^ Group {
   ImGearARTGroup^ get();
}

Property Value

ImGearARTGroup class object.
See Also

Reference

ImGearARTCreatingGroupEventArgs Class
ImGearARTCreatingGroupEventArgs Members


IgnoreGroup Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingGroupEventArgs Class : IgnoreGroup Property
Gets or sets a value indicating whether the group should not be loaded into the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreGroup As Boolean
'Usage

Dim instance As ImGearARTCreatingGroupEventArgs
Dim value As Boolean

instance.IgnoreGroup = value

value = instance.IgnoreGroup
public bool IgnoreGroup {get; set;}
public: __property bool get_IgnoreGroup();
public: __property void set_IgnoreGroup(
   bool value
);
public:
property bool IgnoreGroup {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearARTCreatingGroupEventArgs Class
ImGearARTCreatingGroupEventArgs Members


Page Property (ImGearARTCreatingGroupEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingGroupEventArgs Class : Page Property
Gets the group's parent page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTCreatingGroupEventArgs
Dim value As ImGearARTPage

value = instance.Page
public ImGearARTPage Page {get;}
public: __property ImGearARTPage* get_Page();
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class object.
See Also

Reference

ImGearARTCreatingGroupEventArgs Class
ImGearARTCreatingGroupEventArgs Members


%%PageItemTitle%%

ImGearARTCreatingMarkEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingMarkEventArgs Class
CreatingMarkEvent arguments.
Object Model
ImGearARTCreatingMarkEventArgs ClassImGearARTGroup ClassImGearARTMark ClassImGearARTMark ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCreatingMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTCreatingMarkEventArgs
public class ImGearARTCreatingMarkEventArgs : System.EventArgs
public __gc class ImGearARTCreatingMarkEventArgs : public System.EventArgs
public ref class ImGearARTCreatingMarkEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTCreatingMarkEventArgs

See Also

Reference

ImGearARTCreatingMarkEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCreatingMarkEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingMarkEventArgs Class

The following tables list the members exposed by ImGearARTCreatingMarkEventArgs.

Public Properties
 | Name | Description
Public Property | Group | Gets the mark's parent group.
Public Property | IgnoreMark | Gets or sets a value indicating whether the mark should not be loaded into the page.
Public Property | Mark | Gets the mark.
Public Property | Page | Gets the mark's parent page.
Top
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTCreatingMarkEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingMarkEventArgs Class

For a list of all members of this type, see ImGearARTCreatingMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Group | Gets the mark's parent group.
Public Property | IgnoreMark | Gets or sets a value indicating whether the mark should not be loaded into the page.
Public Property | Mark | Gets the mark.
Public Property | Page | Gets the mark's parent page.
Top
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImageGear.ART Namespace


Group Property (ImGearARTCreatingMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingMarkEventArgs Class : Group Property
Gets the mark's parent group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Group As ImGearARTGroup
'Usage

Dim instance As ImGearARTCreatingMarkEventArgs
Dim value As ImGearARTGroup

value = instance.Group
public ImGearARTGroup Group {get;}
public: __property ImGearARTGroup* get_Group();
public:
property ImGearARTGroup^ Group {
   ImGearARTGroup^ get();
}

Property Value

ImGearARTGroup class object.
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImGearARTCreatingMarkEventArgs Members


IgnoreMark Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingMarkEventArgs Class : IgnoreMark Property
Gets or sets a value indicating whether the mark should not be loaded into the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreMark As Boolean
'Usage

Dim instance As ImGearARTCreatingMarkEventArgs
Dim value As Boolean

instance.IgnoreMark = value

value = instance.IgnoreMark
public bool IgnoreMark {get; set;}
public: __property bool get_IgnoreMark();
public: __property void set_IgnoreMark(
   bool value
);
public:
property bool IgnoreMark {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImGearARTCreatingMarkEventArgs Members


Mark Property (ImGearARTCreatingMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingMarkEventArgs Class : Mark Property
Gets the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTCreatingMarkEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImGearARTCreatingMarkEventArgs Members


Page Property (ImGearARTCreatingMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingMarkEventArgs Class : Page Property
Gets the mark's parent page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTCreatingMarkEventArgs
Dim value As ImGearARTPage

value = instance.Page
public ImGearARTPage Page {get;}
public: __property ImGearARTPage* get_Page();
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class object.
See Also

Reference

ImGearARTCreatingMarkEventArgs Class
ImGearARTCreatingMarkEventArgs Members


%%PageItemTitle%%

ImGearARTCreatingPageEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingPageEventArgs Class
CreatingPageEvent arguments.
Object Model
ImGearARTCreatingPageEventArgs ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCreatingPageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTCreatingPageEventArgs
public class ImGearARTCreatingPageEventArgs : System.EventArgs
public __gc class ImGearARTCreatingPageEventArgs : public System.EventArgs
public ref class ImGearARTCreatingPageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTCreatingPageEventArgs

See Also

Reference

ImGearARTCreatingPageEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCreatingPageEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingPageEventArgs Class

The following tables list the members exposed by ImGearARTCreatingPageEventArgs.

Public Properties
 | Name | Description
Public Property | IgnorePage | Gets or sets a value indicating whether the page should be created.
Public Property | Page | Gets the page.
Top
See Also

Reference

ImGearARTCreatingPageEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTCreatingPageEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCreatingPageEventArgs Class

For a list of all members of this type, see ImGearARTCreatingPageEventArgs members.

Public Properties
 | Name | Description
Public Property | IgnorePage | Gets or sets a value indicating whether the page should be created.
Public Property | Page | Gets the page.
Top
See Also

Reference

ImGearARTCreatingPageEventArgs Class
ImageGear.ART Namespace


IgnorePage Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingPageEventArgs Class : IgnorePage Property
Gets or sets a value indicating whether the page should be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnorePage As Boolean
'Usage

Dim instance As ImGearARTCreatingPageEventArgs
Dim value As Boolean

instance.IgnorePage = value

value = instance.IgnorePage
public bool IgnorePage {get; set;}
public: __property bool get_IgnorePage();
public: __property void set_IgnorePage(
   bool value
);
public:
property bool IgnorePage {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearARTCreatingPageEventArgs Class
ImGearARTCreatingPageEventArgs Members


Page Property (ImGearARTCreatingPageEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCreatingPageEventArgs Class : Page Property
Gets the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTCreatingPageEventArgs
Dim value As ImGearARTPage

value = instance.Page
public ImGearARTPage Page {get;}
public: __property ImGearARTPage* get_Page();
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class object.
See Also

Reference

ImGearARTCreatingPageEventArgs Class
ImGearARTCreatingPageEventArgs Members


%%PageItemTitle%%

ImGearARTCurve Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCurve Class
Represents ART Curve mark.
Object Model
ImGearARTCurve ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTCurve
   Inherits ImGearARTMark
   Implements IImGearARTCurve
'Usage

Dim instance As ImGearARTCurve
public class ImGearARTCurve : ImGearARTMark, IImGearARTCurve
public __gc class ImGearARTCurve : public ImGearARTMark, IImGearARTCurve
public ref class ImGearARTCurve : public ImGearARTMark, IImGearARTCurve
Example
  • C#
// Create an array of 5 points for the curve.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the curve.
ImGearRGBQuad igRGBQuadCurve = new ImGearRGBQuad(40, 40, 200);
// Create curve with a dashed pattern, width of 4, tension of 0.75 and opacity of 127 (50%)
ImGearARTCurve igARTCurve = new ImGearARTCurve(
    igPoints, igRGBQuadCurve, ImGearARTPenStyle.DASH, 4, (float)0.75, 127
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTCurve, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the curve.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the curve.
Dim igRGBQuadCurve As New ImGearRGBQuad(40, 40, 200)
' Create curve with a dashed pattern, width of 4, tension of 0.75 and opacity of 127 (50%)
Dim igARTCurve As New ImGearARTCurve( _
 igPoints, igRGBQuadCurve, ImGearARTPenStyle.DASH, 4, CSng(0.75), 127)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTCurve, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTCurve

See Also

Reference

ImGearARTCurve Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCurve Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCurve Class

The following tables list the members exposed by ImGearARTCurve.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTCurve Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | NumberOfPoints | Gets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Style | Gets or sets the style of the mark.
Public Property | Tension | Gets or sets the tension of the curve.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets the point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets the point with the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTCurve Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTCurve Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : ImGearARTCurve Constructor
Overload List
Overload | Description
ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTCurve class object.
ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Single,Int32) | Initializes a new instance of the ImGearARTCurve class object.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class > ImGearARTCurve Constructor : ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad)
Raw points array.
Color of the mark.
Initializes a new instance of the ImGearARTCurve class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTCurve(points, color)
public ImGearARTCurve(
   ImGearPoint[] points,
   IImGearRGBQuad color
)
public: ImGearARTCurve(
   ImGearPoint[]* points,
   IImGearRGBQuad* color
)
public:
ImGearARTCurve(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color
)

Parameters

points
Raw points array.
color
Color of the mark.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Overload List
ImGearRGBQuad Structure
ImGearPoint Structure


%%PageItemTitle%%

ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Single,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class > ImGearARTCurve Constructor : ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Single,Int32)
Raw points array.
Color of the mark.
Style of the mark.
Width of the mark.
Tension of the curve.
Opacity of the mark.
Initializes a new instance of the ImGearARTCurve class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal tension As Single, _
   ByVal opacity As Integer _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim tension As Single
Dim opacity As Integer

Dim instance As New ImGearARTCurve(points, color, style, width, tension, opacity)
public ImGearARTCurve(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   float tension,
   int opacity
)
public: ImGearARTCurve(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   float tension,
   int opacity
)
public:
ImGearARTCurve(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   float tension,
   int opacity
)

Parameters

points
Raw points array.
color
Color of the mark.
style
Style of the mark.
width
Width of the mark.
tension
Tension of the curve.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Overload List
ImGearRGBQuad Structure
ImGearPoint Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTCurve Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCurve Class

For a list of all members of this type, see ImGearARTCurve members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets the point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets the point with the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTCurve Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTCurve
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearPoint Structure


Flip Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTCurve
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Flip Method


GetPoint Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : GetPoint Method
Index of the point.
Gets the point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTCurve
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTCurve
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Move Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTCurve
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


OnPointAdded Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTCurve
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


OnPointChanged Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTCurve
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


OnPointsRemoved Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTCurve
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


RemovePoints Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTCurve
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Rotate Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTCurve
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Rotate Method


Scale Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTCurve
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Scale Method


SetPoint Method (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : SetPoint Method
Index of the point.
The point to set.
Sets the point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTCurve
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTCurve Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCurve Class

For a list of all members of this type, see ImGearARTCurve members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | NumberOfPoints | Gets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Style | Gets or sets the style of the mark.
Public Property | Tension | Gets or sets the tension of the curve.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Top
See Also

Reference

ImGearARTCurve Class
ImageGear.ART Namespace


Bounds Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTCurve
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearRectangle Structure


CapStyle Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTCurve
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTCurve
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearRGBQuad Structure


NumberOfPoints Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : NumberOfPoints Property
Gets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")>
Public ReadOnly Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTCurve
Dim value As Integer

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Opacity Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTCurve
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 127.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Points Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTCurve
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTCurve
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


SelectionType Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTCurve
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Style Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Style Property
Gets or sets the style of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTCurve
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearARTPenStyle Enumeration


Tension Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Tension Property
Gets or sets the tension of the curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tension As Single
'Usage

Dim instance As ImGearARTCurve
Dim value As Single

instance.Tension = value

value = instance.Tension
public float Tension {get; set;}
public: __property float get_Tension();
public: __property void set_Tension(
   float value
);
public:
property float Tension {
   float get();
   void set (    float value);
}

Property Value

Float value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Type Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTCurve
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTCurve
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


Width Property (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTCurve
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%% $$Events$$

ImGearARTCurve Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCurve Class

For a list of all members of this type, see ImGearARTCurve members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTCurve Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTCurve
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


PointChanged Event (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTCurve
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


PointsRemoved Event (ImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCurve Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTCurve
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

ImGearARTCustomController Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomController Class
Provides a set of abstract members for user-defined custom mark controller.
Object Model
ImGearARTCustomController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTCustomController
'Usage

Dim instance As ImGearARTCustomController
public abstract class ImGearARTCustomController
public __gc abstract class ImGearARTCustomController
public ref class ImGearARTCustomController abstract
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTCustomController
ImageGear.ART.ImGearARTCustomDrawingController
ImageGear.ART.ImGearARTCustomPresentationController

See Also

Reference

ImGearARTCustomController Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCustomController Class Members
Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomController Class

The following tables list the members exposed by ImGearARTCustomController.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetCustomMark | Gets a registered custom mark type by its name.
static (Shared in Visual Basic) | RegisterCustomMark | Registers a custom mark class defined by user.
Top
See Also

Reference

ImGearARTCustomController Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTCustomController Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomController Class

For a list of all members of this type, see ImGearARTCustomController members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetCustomMark | Gets a registered custom mark type by its name.
static (Shared in Visual Basic) | RegisterCustomMark | Registers a custom mark class defined by user.
Top
See Also

Reference

ImGearARTCustomController Class
ImageGear.ART Namespace


GetCustomMark Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomController Class : GetCustomMark Method
User type name.
Gets a registered custom mark type by its name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetCustomMark( _
   ByVal userType As String _
) As Type
'Usage

Dim userType As String
Dim value As Type

value = ImGearARTCustomController.GetCustomMark(userType)
public static Type GetCustomMark(
   string userType
)
public: static Type* GetCustomMark(
   string* userType
)
public:
static Type^ GetCustomMark(
   String^ userType
)

Parameters

userType
User type name.

Return Value

Custom mark class type info.
See Also

Reference

ImGearARTCustomController Class
ImGearARTCustomController Members


RegisterCustomMark Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomController Class : RegisterCustomMark Method
Name of custom mark type.
Type of custom mark.
Registers a custom mark class defined by user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterCustomMark( _
   ByVal userType As String, _
   ByVal customMarkType As Type _
)
'Usage

Dim userType As String
Dim customMarkType As Type

ImGearARTCustomController.RegisterCustomMark(userType, customMarkType)
public static void RegisterCustomMark(
   string userType,
   Type customMarkType
)
public: static void RegisterCustomMark(
   string* userType,
   Type* customMarkType
)
public:
static void RegisterCustomMark(
   String^ userType,
   Type^ customMarkType
)

Parameters

userType
Name of custom mark type.
customMarkType
Type of custom mark.
See Also

Reference

ImGearARTCustomController Class
ImGearARTCustomController Members


%%PageItemTitle%%

ImGearARTCustomDrawingController Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomDrawingController Class
Provides a set of abstract members for user-defined custom mark controller, using with WinForms drawing engine.
Object Model
ImGearARTCustomDrawingController ClassImGearARTCustomDrawingController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTCustomDrawingController
   Inherits ImGearARTCustomController
'Usage

Dim instance As ImGearARTCustomDrawingController
public abstract class ImGearARTCustomDrawingController : ImGearARTCustomController
public __gc abstract class ImGearARTCustomDrawingController : public ImGearARTCustomController
public ref class ImGearARTCustomDrawingController abstract : public ImGearARTCustomController
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTCustomController
ImageGear.ART.ImGearARTCustomDrawingController

See Also

Reference

ImGearARTCustomDrawingController Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCustomDrawingController Class Members
Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomDrawingController Class

The following tables list the members exposed by ImGearARTCustomDrawingController.

Public Methods
 | Name | Description
Public Method | Draw | Draws a mark.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark controller.
Public Method | HitTest | Checks if mouse is over the mark.
static (Shared in Visual Basic) | RegisterCustomController | Registers a drawing controller for a custom mark type.
Top
See Also

Reference

ImGearARTCustomDrawingController Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTCustomDrawingController Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomDrawingController Class

For a list of all members of this type, see ImGearARTCustomDrawingController members.

Public Methods
 | Name | Description
Public Method | Draw | Draws a mark.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark controller.
Public Method | HitTest | Checks if mouse is over the mark.
static (Shared in Visual Basic) | RegisterCustomController | Registers a drawing controller for a custom mark type.
Top
See Also

Reference

ImGearARTCustomDrawingController Class
ImageGear.ART Namespace


Draw Method (ImGearARTCustomDrawingController)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : Draw Method
Draws a mark.
Overload List
Overload | Description
Draw | Draws a mark.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


Draw(ImGearARTCustomMark,ImGearARTDrawingState) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : Draw(ImGearARTCustomMark,ImGearARTDrawingState) Method
The mark to draw.
A set of parameters for custom mark's drawing.
Draws a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Draw( _
   ByVal mark As ImGearARTCustomMark, _
   ByVal state As ImGearARTDrawingState _
)
'Usage

Dim instance As ImGearARTCustomDrawingController
Dim mark As ImGearARTCustomMark
Dim state As ImGearARTDrawingState

instance.Draw(mark, state)
public abstract void Draw(
   ImGearARTCustomMark mark,
   ImGearARTDrawingState state
)
public: abstract void Draw(
   ImGearARTCustomMark* mark,
   ImGearARTDrawingState* state
)
public:
abstract void Draw(
   ImGearARTCustomMark^ mark,
   ImGearARTDrawingState^ state
)

Parameters

mark
The mark to draw.
state
A set of parameters for custom mark's drawing.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


GetCustomController Method (ImGearARTCustomDrawingController)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : GetCustomController Method
Name of the custom mark type.
Returns a registered custom mark controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetCustomController( _
   ByVal userType As String _
) As ImGearARTCustomDrawingController
'Usage

Dim userType As String
Dim value As ImGearARTCustomDrawingController

value = ImGearARTCustomDrawingController.GetCustomController(userType)
public static ImGearARTCustomDrawingController GetCustomController(
   string userType
)
public: static ImGearARTCustomDrawingController* GetCustomController(
   string* userType
)
public:
static ImGearARTCustomDrawingController^ GetCustomController(
   String^ userType
)

Parameters

userType
Name of the custom mark type.

Return Value

Registered custom controller.
Remarks
userType is an unique name that identifies the type of custom mark. It is stored in ART page and should be the same for all applications that supports a given type of custom mark.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


HitTest Method (ImGearARTCustomDrawingController)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : HitTest Method
Checks if mouse is over the mark.
Overload List
Overload | Description
HitTest | Checks if mouse is over the mark.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


HitTest(ImGearARTCustomMark,ImGearARTDrawingState,ImGearPoint) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : HitTest(ImGearARTCustomMark,ImGearARTDrawingState,ImGearPoint) Method
The mark to check.
A set of parameters for custom mark's hittesting.
Mouse position in device coordinates.
Checks if mouse is over the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function HitTest( _
   ByVal mark As ImGearARTCustomMark, _
   ByVal state As ImGearARTDrawingState, _
   ByVal devicePoint As ImGearPoint _
) As ImGearARTMarkHitTest
'Usage

Dim instance As ImGearARTCustomDrawingController
Dim mark As ImGearARTCustomMark
Dim state As ImGearARTDrawingState
Dim devicePoint As ImGearPoint
Dim value As ImGearARTMarkHitTest

value = instance.HitTest(mark, state, devicePoint)
public abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark mark,
   ImGearARTDrawingState state,
   ImGearPoint devicePoint
)
public: abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark* mark,
   ImGearARTDrawingState* state,
   ImGearPoint devicePoint
)
public:
abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark^ mark,
   ImGearARTDrawingState^ state,
   ImGearPoint devicePoint
)

Parameters

mark
The mark to check.
state
A set of parameters for custom mark's hittesting.
devicePoint
Mouse position in device coordinates.

Return Value

Hit test result.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


RegisterCustomController Method (ImGearARTCustomDrawingController)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomDrawingController Class : RegisterCustomController Method
Name of custom mark type.
Controller object.
Registers a drawing controller for a custom mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterCustomController( _
   ByVal userType As String, _
   ByVal controller As ImGearARTCustomDrawingController _
)
'Usage

Dim userType As String
Dim controller As ImGearARTCustomDrawingController

ImGearARTCustomDrawingController.RegisterCustomController(userType, controller)
public static void RegisterCustomController(
   string userType,
   ImGearARTCustomDrawingController controller
)
public: static void RegisterCustomController(
   string* userType,
   ImGearARTCustomDrawingController* controller
)
public:
static void RegisterCustomController(
   String^ userType,
   ImGearARTCustomDrawingController^ controller
)

Parameters

userType
Name of custom mark type.
controller
Controller object.
Remarks
userType is an unique name that identifies the type of custom mark. It is stored in ART page and should be the same for all applications that supports a given type of custom mark.
See Also

Reference

ImGearARTCustomDrawingController Class
ImGearARTCustomDrawingController Members


%%PageItemTitle%%

ImGearARTCustomMark Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomMark Class
Represents ART Custom mark.
Object Model
ImGearARTCustomMark ClassImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTCustomMark
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTCustomMark
public abstract class ImGearARTCustomMark : ImGearARTMark
public __gc abstract class ImGearARTCustomMark : public ImGearARTMark
public ref class ImGearARTCustomMark abstract : public ImGearARTMark
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTCustomMark

See Also

Reference

ImGearARTCustomMark Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCustomMark Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomMark Class

The following tables list the members exposed by ImGearARTCustomMark.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserType | Gets custom mark's type name.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
Public Methods
 | Name | Description
Public Method | Move | Overridden. Moves the mark by specified offset.
Top
Protected Methods
 | Name | Description
Protected Method | SavePropertiesToUserData | Saves custom mark's properties to User data dictionary.
Top
See Also

Reference

ImGearARTCustomMark Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTCustomMark Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomMark Class

For a list of all members of this type, see ImGearARTCustomMark members.

Public Methods
 | Name | Description
Public Method | Move | Overridden. Moves the mark by specified offset.
Top
Protected Methods
 | Name | Description
Protected Method | SavePropertiesToUserData | Saves custom mark's properties to User data dictionary.
Top
See Also

Reference

ImGearARTCustomMark Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTCustomMark Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomMark Class

For a list of all members of this type, see ImGearARTCustomMark members.

See Also

Reference

ImGearARTCustomMark Class
ImageGear.ART Namespace


Move Method (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTCustomMark
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members


SavePropertiesToUserData Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : SavePropertiesToUserData Method
Saves custom mark's properties to User data dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub SavePropertiesToUserData()
'Usage

Dim instance As ImGearARTCustomMark

instance.SavePropertiesToUserData()
protected abstract void SavePropertiesToUserData()
protected: abstract void SavePropertiesToUserData();
protected:
abstract void SavePropertiesToUserData();
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members


%%PageItemTitle%% $$Properties$$

ImGearARTCustomMark Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCustomMark Class

For a list of all members of this type, see ImGearARTCustomMark members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserType | Gets custom mark's type name.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
See Also

Reference

ImGearARTCustomMark Class
ImageGear.ART Namespace


Bounds Property (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides MustOverride ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTCustomMark
Dim value As ImGearRectangle

value = instance.Bounds
public override abstract ImGearRectangle Bounds {get;}
public: __property abstract ImGearRectangle get_Bounds() override;
public:
abstract property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members
ImGearRectangle Structure


SelectionType Property (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTCustomMark
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members


Type Property (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTCustomMark
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType.CUSTOM enumeration value.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members
ImGearARTMarkType Enumeration


UserType Property (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : UserType Property
Gets custom mark's type name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property UserType As String
'Usage

Dim instance As ImGearARTCustomMark
Dim value As String

value = instance.UserType
public abstract string UserType {get;}
public: __property abstract string* get_UserType();
public:
abstract property String^ UserType {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members


Visible Property (ImGearARTCustomMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTCustomMark Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTCustomMark
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTCustomMark Class
ImGearARTCustomMark Members


%%PageItemTitle%%

ImGearARTDrawingState Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDrawingState Class
Provides a set of parameters for custom mark's drawing.
Object Model
ImGearARTDrawingState ClassImGearPoint StructureImGearRectangle StructureImGearPoint StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTDrawingState
'Usage

Dim instance As ImGearARTDrawingState
public class ImGearARTDrawingState
public __gc class ImGearARTDrawingState
public ref class ImGearARTDrawingState
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTDrawingState

See Also

Reference

ImGearARTDrawingState Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTDrawingState Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDrawingState Class

The following tables list the members exposed by ImGearARTDrawingState.

Public Properties
 | Name | Description
Public Property | Graphics | Gets or sets graphics object that is used to draw a mark.
Public Property | IsSelected | Gets or sets a value indicating whether the current mark is selected.
Top
Public Methods
 | Name | Description
Public Method | ConvertDeviceToMarkPoint | Converts a point specified in device coordinates to mark coodinates.
Public Method | ConvertDeviceToMarkRectangle | Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Public Method | ConvertMarkToDevicePoint | Converts a point specified in mark coordinates to device coodinates.
Public Method | ConvertMarkToDeviceRectangle | Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Top
See Also

Reference

ImGearARTDrawingState Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTDrawingState Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDrawingState Class

For a list of all members of this type, see ImGearARTDrawingState members.

Public Methods
 | Name | Description
Public Method | ConvertDeviceToMarkPoint | Converts a point specified in device coordinates to mark coodinates.
Public Method | ConvertDeviceToMarkRectangle | Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Public Method | ConvertMarkToDevicePoint | Converts a point specified in mark coordinates to device coodinates.
Public Method | ConvertMarkToDeviceRectangle | Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Top
See Also

Reference

ImGearARTDrawingState Class
ImageGear.ART Namespace


ConvertDeviceToMarkPoint Method (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : ConvertDeviceToMarkPoint Method
Point in mark coordinates to convert.
Converts a point specified in device coordinates to mark coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertDeviceToMarkPoint( _
   ByVal point As ImGearPoint _
) As ImGearPoint
'Usage

Dim instance As ImGearARTDrawingState
Dim point As ImGearPoint
Dim value As ImGearPoint

value = instance.ConvertDeviceToMarkPoint(point)
public ImGearPoint ConvertDeviceToMarkPoint(
   ImGearPoint point
)
public: ImGearPoint ConvertDeviceToMarkPoint(
   ImGearPoint point
)
public:
ImGearPoint ConvertDeviceToMarkPoint(
   ImGearPoint point
)

Parameters

point
Point in mark coordinates to convert.

Return Value

Point in device coordinates.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members
ImGearPoint Structure


ConvertDeviceToMarkRectangle Method (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : ConvertDeviceToMarkRectangle Method
Rectangle in device coordinates to convert.
Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertDeviceToMarkRectangle( _
   ByVal rectangle As ImGearRectangle _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTDrawingState
Dim rectangle As ImGearRectangle
Dim value As ImGearRectangle

value = instance.ConvertDeviceToMarkRectangle(rectangle)
public ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)
public: ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)
public:
ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)

Parameters

rectangle
Rectangle in device coordinates to convert.

Return Value

Rectangle in mark coordinates.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members
ImGearRectangle Structure


ConvertMarkToDevicePoint Method (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : ConvertMarkToDevicePoint Method
Point in mark coordinates to convert.
Converts a point specified in mark coordinates to device coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertMarkToDevicePoint( _
   ByVal point As ImGearPoint _
) As ImGearPoint
'Usage

Dim instance As ImGearARTDrawingState
Dim point As ImGearPoint
Dim value As ImGearPoint

value = instance.ConvertMarkToDevicePoint(point)
public ImGearPoint ConvertMarkToDevicePoint(
   ImGearPoint point
)
public: ImGearPoint ConvertMarkToDevicePoint(
   ImGearPoint point
)
public:
ImGearPoint ConvertMarkToDevicePoint(
   ImGearPoint point
)

Parameters

point
Point in mark coordinates to convert.

Return Value

Point in device coordinates.
Remarks
Mark coordinates can be either image coordinates or device coordinates. In both cases the result will be in device coordinates.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members
ImGearPoint Structure


ConvertMarkToDeviceRectangle Method (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : ConvertMarkToDeviceRectangle Method
Rectangle in mark coordinates to convert.
Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertMarkToDeviceRectangle( _
   ByVal rectangle As ImGearRectangle _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTDrawingState
Dim rectangle As ImGearRectangle
Dim value As ImGearRectangle

value = instance.ConvertMarkToDeviceRectangle(rectangle)
public ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)
public: ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)
public:
ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)

Parameters

rectangle
Rectangle in mark coordinates to convert.

Return Value

Rectangle in device coordinates.
Remarks
Mark coordinates can be either image coordinates or device coordinates. In both cases the result will be in device coordinates.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

ImGearARTDrawingState Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDrawingState Class

For a list of all members of this type, see ImGearARTDrawingState members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets or sets graphics object that is used to draw a mark.
Public Property | IsSelected | Gets or sets a value indicating whether the current mark is selected.
Top
See Also

Reference

ImGearARTDrawingState Class
ImageGear.ART Namespace


Graphics Property (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : Graphics Property
Gets or sets graphics object that is used to draw a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Graphics As Graphics
'Usage

Dim instance As ImGearARTDrawingState
Dim value As Graphics

instance.Graphics = value

value = instance.Graphics
public Graphics Graphics {get; set;}
public: __property Graphics* get_Graphics();
public: __property void set_Graphics(
   Graphics* value
);
public:
property Graphics^ Graphics {
   Graphics^ get();
   void set (    Graphics^ value);
}

Property Value

System.Drawing.Graphics value.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members


IsSelected Property (ImGearARTDrawingState)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDrawingState Class : IsSelected Property
Gets or sets a value indicating whether the current mark is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelected As Boolean
'Usage

Dim instance As ImGearARTDrawingState
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
public bool IsSelected {get; set;}
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
public:
property bool IsSelected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTDrawingState Class
ImGearARTDrawingState Members


%%PageItemTitle%%

ImGearARTDroppedAttributeEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedAttributeEventArgs Class
Provides data for the DroppedAttribute event.
Object Model
ImGearARTDroppedAttributeEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTDroppedAttributeEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTDroppedAttributeEventArgs
public class ImGearARTDroppedAttributeEventArgs : System.EventArgs
public __gc class ImGearARTDroppedAttributeEventArgs : public System.EventArgs
public ref class ImGearARTDroppedAttributeEventArgs : public System.EventArgs
Remarks
The DroppedAttribute event occurs only when you call the LoadPage method and the unsupported annotation mark attribute is being dropped.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTDroppedAttributeEventArgs

See Also

Reference

ImGearARTDroppedAttributeEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTDroppedAttributeEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedAttributeEventArgs Class

The following tables list the members exposed by ImGearARTDroppedAttributeEventArgs.

Public Properties
 | Name | Description
Public Property | AttributeData | Gets the XML formatted string representing the attribute data that was dropped.
Public Property | Mark | Gets the annotation mark object whose attribute was dropped.
Top
See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTDroppedAttributeEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedAttributeEventArgs Class

For a list of all members of this type, see ImGearARTDroppedAttributeEventArgs members.

Public Properties
 | Name | Description
Public Property | AttributeData | Gets the XML formatted string representing the attribute data that was dropped.
Public Property | Mark | Gets the annotation mark object whose attribute was dropped.
Top
See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImageGear.ART Namespace


AttributeData Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDroppedAttributeEventArgs Class : AttributeData Property
Gets the XML formatted string representing the attribute data that was dropped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AttributeData As String
'Usage

Dim instance As ImGearARTDroppedAttributeEventArgs
Dim value As String

value = instance.AttributeData
public string AttributeData {get;}
public: __property string* get_AttributeData();
public:
property String^ AttributeData {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImGearARTDroppedAttributeEventArgs Members


Mark Property (ImGearARTDroppedAttributeEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDroppedAttributeEventArgs Class : Mark Property
Gets the annotation mark object whose attribute was dropped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTDroppedAttributeEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImGearARTDroppedAttributeEventArgs Members


%%PageItemTitle%%

ImGearARTDroppedMarkEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedMarkEventArgs Class
Provides data for the DroppedMark event.
Object Model
ImGearARTDroppedMarkEventArgs ClassImGearARTGroup ClassImGearARTMark ClassImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTDroppedMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTDroppedMarkEventArgs
public class ImGearARTDroppedMarkEventArgs : System.EventArgs
public __gc class ImGearARTDroppedMarkEventArgs : public System.EventArgs
public ref class ImGearARTDroppedMarkEventArgs : public System.EventArgs
Remarks
The DroppedMark event occurs only when you call the LoadPage method and the unsupported annotation mark is being dropped.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTDroppedMarkEventArgs

See Also

Reference

ImGearARTDroppedMarkEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTDroppedMarkEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedMarkEventArgs Class

The following tables list the members exposed by ImGearARTDroppedMarkEventArgs.

Public Properties
 | Name | Description
Public Property | Group | Gets the parent group of the mark that was dropped.
Public Property | MarkData | Gets the XML formatted string representing the mark data that was dropped.
Public Property | Page | Gets the parent page of the mark that was dropped.
Top
See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTDroppedMarkEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTDroppedMarkEventArgs Class

For a list of all members of this type, see ImGearARTDroppedMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Group | Gets the parent group of the mark that was dropped.
Public Property | MarkData | Gets the XML formatted string representing the mark data that was dropped.
Public Property | Page | Gets the parent page of the mark that was dropped.
Top
See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImageGear.ART Namespace


Group Property (ImGearARTDroppedMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDroppedMarkEventArgs Class : Group Property
Gets the parent group of the mark that was dropped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Group As ImGearARTGroup
'Usage

Dim instance As ImGearARTDroppedMarkEventArgs
Dim value As ImGearARTGroup

value = instance.Group
public ImGearARTGroup Group {get;}
public: __property ImGearARTGroup* get_Group();
public:
property ImGearARTGroup^ Group {
   ImGearARTGroup^ get();
}

Property Value

ImGearARTGroup class object.
See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


MarkData Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDroppedMarkEventArgs Class : MarkData Property
Gets the XML formatted string representing the mark data that was dropped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkData As String
'Usage

Dim instance As ImGearARTDroppedMarkEventArgs
Dim value As String

value = instance.MarkData
public string MarkData {get;}
public: __property string* get_MarkData();
public:
property String^ MarkData {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


Page Property (ImGearARTDroppedMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTDroppedMarkEventArgs Class : Page Property
Gets the parent page of the mark that was dropped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTDroppedMarkEventArgs
Dim value As ImGearARTPage

value = instance.Page
public ImGearARTPage Page {get;}
public: __property ImGearARTPage* get_Page();
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage class object.
See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


%%PageItemTitle%%

ImGearARTEllipse Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEllipse Class
Represents ART Ellipse mark.
Object Model
ImGearARTEllipse ClassImGearARTBorder ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTEllipse
   Inherits ImGearARTMark
   Implements IImGearARTEllipse
'Usage

Dim instance As ImGearARTEllipse
public class ImGearARTEllipse : ImGearARTMark, IImGearARTEllipse
public __gc class ImGearARTEllipse : public ImGearARTMark, IImGearARTEllipse
public ref class ImGearARTEllipse : public ImGearARTMark, IImGearARTEllipse
Example
  • C#
// Setup rectangle for the ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the ellipse.
ImGearRGBQuad igRGBQuadEllipse = new ImGearRGBQuad(40, 40, 200);
// Setup color for the ellipse border.
ImGearRGBQuad igRGBQuadEllipseBorder = new ImGearRGBQuad(60, 60, 255);
// Create ellipse with a solid 4 pixel border and opacity of 127 (50%)
ImGearARTEllipse igARTEllipse = new ImGearARTEllipse(
    igRectangle, igRGBQuadEllipse, igRGBQuadEllipseBorder, ImGearARTPenStyle.SOLID, 4, 127
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEllipse, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the ellipse.
Dim igRGBQuadEllipse As New ImGearRGBQuad(40, 40, 200)
' Setup color for the ellipse border.
Dim igRGBQuadEllipseBorder As New ImGearRGBQuad(60, 60, 255)
' Create ellipse with a solid 4 pixel border and opacity of 127 (50%)
Dim igARTEllipse As New ImGearARTEllipse( _
 igRectangle, igRGBQuadEllipse, igRGBQuadEllipseBorder, ImGearARTPenStyle.SOLID, 4, 127)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEllipse, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTEllipse

See Also

Reference

ImGearARTEllipse Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTEllipse Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEllipse Class

The following tables list the members exposed by ImGearARTEllipse.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTEllipse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTEllipse Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : ImGearARTEllipse Constructor
Overload List
Overload | Description
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTEllipse class object.
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32) | Initializes a new instance of the ImGearARTEllipse class object.
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32) | Initializes a new instance of the ImGearARTEllipse class object.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
The mark rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTEllipse(rect, fillColor)
public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
The mark rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List
ImGearRGBQuad Structure
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32)
The mark rectangle.
Border color of the mark.
Border style of the mark.
Width of the border line.
Initializes a new instance of the ImGearARTEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer

Dim instance As New ImGearARTEllipse(rect, borderColor, borderStyle, borderWidth)
public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public: ImGearARTEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public:
ImGearARTEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

rect
The mark rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Width of the border line.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List
ImGearRGBQuad Structure
ImGearRectangle Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)
The mark rectangle.
Fill color of the mark.
Border color of the mark.
Border style of the mark.
Border width of the mark.
Opacity of the mark.
Initializes a new instance of the ImGearARTEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer, _
   ByVal opacity As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer
Dim opacity As Integer

Dim instance As New ImGearARTEllipse(rect, fillColor, borderColor, borderStyle, borderWidth, opacity)
public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public: ImGearARTEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public:
ImGearARTEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

rect
The mark rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List
ImGearRGBQuad Structure
ImGearRectangle Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTEllipse Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEllipse Class

For a list of all members of this type, see ImGearARTEllipse members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTEllipse Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEllipse Class

For a list of all members of this type, see ImGearARTEllipse members.

See Also

Reference

ImGearARTEllipse Class
ImageGear.ART Namespace


Flip Method (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTEllipse
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Flip Method


GetRenderBounds Method (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTEllipse
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Move Method (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTEllipse
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Rotate Method (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTEllipse
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Rotate Method


Scale Method (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTEllipse
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTEllipse Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEllipse Class

For a list of all members of this type, see ImGearARTEllipse members.

Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the left-top point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the left-top point of the mark.
Top
See Also

Reference

ImGearARTEllipse Class
ImageGear.ART Namespace


Border Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTEllipse
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
ImGearARTBorder Class


Bounds Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTEllipse
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
ImGearRectangle Structure


FillColor Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTEllipse
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
ImGearRGBQuad Structure


Height Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTEllipse
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


IsHighlighter Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHighlighter As Boolean
'Usage

Dim instance As ImGearARTEllipse
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
public bool IsHighlighter {get; set;}
public: __property bool get_IsHighlighter();
public: __property void set_IsHighlighter(
   bool value
);
public:
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Opacity Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTEllipse
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 255.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


SelectionType Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTEllipse
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Type Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTEllipse
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTEllipse
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Width Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTEllipse
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


X Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : X Property
Gets or sets the X coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTEllipse
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


Y Property (ImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEllipse Class : Y Property
Gets or sets the Y coordinate of the left-top point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTEllipse
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

ImGearARTEncryption Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEncryption Class
Represents ART Encryption mark.
Object Model
ImGearARTEncryption ClassImGearRectangle StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTEncryption
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTEncryption
public class ImGearARTEncryption : ImGearARTMark
public __gc class ImGearARTEncryption : public ImGearARTMark
public ref class ImGearARTEncryption : public ImGearARTMark
Example
  • C#
// Setup rectangle for the encryption mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 300);
// Create the encryption mark.
ImGearARTEncryption igARTEncryption = new ImGearARTEncryption(
    igRectangle, "abcdefg"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEncryption, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the encryption mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 300)
' Create the encryption mark.
Dim igARTEncryption As New ImGearARTEncryption( _
 igRectangle, "abcdefg")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEncryption, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTEncryption

See Also

Reference

ImGearARTEncryption Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTEncryption Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEncryption Class

The following tables list the members exposed by ImGearARTEncryption.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTEncryption Constructor | Initializes a new instance of the ImGearARTEncryption class object.
Top
Public Properties
 | Name | Description
Public Property | Applied | Gets a value indicating whether the encryption is applied or not.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the encryption.
Public Property | Password | Gets or sets the encryption password.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the encryption.
Public Property | X | Gets or sets the X coordinate of the top-left point of the encryption mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the encryption mark.
Top
Public Methods
 | Name | Description
Public Method | Decrypt | This method decrypts the raster page that was encrypted previously.
Public Method | Encrypt | This method encrypts specified raster page in the document.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTEncryption Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTEncryption Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : ImGearARTEncryption Constructor
The mark rectangle.
Encryption password.
Initializes a new instance of the ImGearARTEncryption class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal password As String _
)
'Usage

Dim rect As IImGearRectangle
Dim password As String

Dim instance As New ImGearARTEncryption(rect, password)
public ImGearARTEncryption(
   IImGearRectangle rect,
   string password
)
public: ImGearARTEncryption(
   IImGearRectangle* rect,
   string* password
)
public:
ImGearARTEncryption(
   IImGearRectangle^ rect,
   String^ password
)

Parameters

rect
The mark rectangle.
password
Encryption password.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTEncryption Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEncryption Class

For a list of all members of this type, see ImGearARTEncryption members.

Public Methods
 | Name | Description
Public Method | Decrypt | This method decrypts the raster page that was encrypted previously.
Public Method | Encrypt | This method encrypts specified raster page in the document.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTEncryption Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTEncryption Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEncryption Class

For a list of all members of this type, see ImGearARTEncryption members.

See Also

Reference

ImGearARTEncryption Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTEncryption Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : ImGearARTEncryption Constructor
Overload List
Overload | Description
ImGearARTEncryption Constructor | Initializes a new instance of the ImGearARTEncryption class object.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Decrypt Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Decrypt Method
This method decrypts the raster page that was encrypted previously.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Decrypt()
'Usage

Dim instance As ImGearARTEncryption

instance.Decrypt()
public void Decrypt()
public: void Decrypt();
public:
void Decrypt();
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
Encrypt Method


Encrypt Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Encrypt Method
Page to encrypt.
This method encrypts specified raster page in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Encrypt( _
   ByVal page As ImGearPage _
)
'Usage

Dim instance As ImGearARTEncryption
Dim page As ImGearPage

instance.Encrypt(page)
public void Encrypt(
   ImGearPage page
)
public: void Encrypt(
   ImGearPage* page
)
public:
void Encrypt(
   ImGearPage^ page
)

Parameters

page
Page to encrypt.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
Decrypt Method


Flip Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTEncryption
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
Flip Method


GetRenderBounds Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTEncryption
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Move Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTEncryption
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Rotate Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTEncryption
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
Rotate Method


Scale Method (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTEncryption
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTEncryption Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTEncryption Class

For a list of all members of this type, see ImGearARTEncryption members.

Public Properties
 | Name | Description
Public Property | Applied | Gets a value indicating whether the encryption is applied or not.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the encryption.
Public Property | Password | Gets or sets the encryption password.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the encryption.
Public Property | X | Gets or sets the X coordinate of the top-left point of the encryption mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the encryption mark.
Top
See Also

Reference

ImGearARTEncryption Class
ImageGear.ART Namespace


Applied Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Applied Property
Gets a value indicating whether the encryption is applied or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Applied As Boolean
'Usage

Dim instance As ImGearARTEncryption
Dim value As Boolean

value = instance.Applied
public bool Applied {get;}
public: __property bool get_Applied();
public:
property bool Applied {
   bool get();
}

Property Value

Boolean value.
Remarks
If true, encryption is applied, false - otherwise. The default value is true.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Bounds Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTEncryption
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
ImGearRectangle Structure


Height Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Height Property
Gets or sets the height of the encryption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTEncryption
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Password Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Password Property
Gets or sets the encryption password.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As String
'Usage

Dim instance As ImGearARTEncryption
Dim value As String

instance.Password = value

value = instance.Password
public string Password {get; set;}
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


SelectionType Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTEncryption
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Type Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTEncryption
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTEncryption
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Width Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Width Property
Gets or sets the width of the encryption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTEncryption
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


X Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : X Property
Gets or sets the X coordinate of the top-left point of the encryption mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTEncryption
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


Y Property (ImGearARTEncryption)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTEncryption Class : Y Property
Gets or sets the Y coordinate of the top-left point of the encryption mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTEncryption
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

ImGearARTFilledEllipse Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledEllipse Class
Represents legacy ART Filled Ellipse mark.
Object Model
ImGearARTFilledEllipse ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFilledEllipse
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTFilledEllipse
public class ImGearARTFilledEllipse : ImGearARTMark
public __gc class ImGearARTFilledEllipse : public ImGearARTMark
public ref class ImGearARTFilledEllipse : public ImGearARTMark
Example
  • C#
// Setup rectangle for the ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the ellipse.
ImGearRGBQuad igRGBQuadEllipse = new ImGearRGBQuad(40, 40, 200);
// Create ellipse with highlight on.
ImGearARTFilledEllipse igARTFilledEllipse = new ImGearARTFilledEllipse(
    igRectangle, igRGBQuadEllipse, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledEllipse, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the ellipse.
Dim igRGBQuadEllipse As New ImGearRGBQuad(40, 40, 200)
' Create ellipse with highlight on.
Dim igARTFilledEllipse As New ImGearARTFilledEllipse( _
 igRectangle, igRGBQuadEllipse, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledEllipse, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTFilledEllipse

See Also

Reference

ImGearARTFilledEllipse Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFilledEllipse Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledEllipse Class

The following tables list the members exposed by ImGearARTFilledEllipse.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFilledEllipse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTFilledEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : ImGearARTFilledEllipse Constructor
Overload List
Overload | Description
ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledEllipse class object.
ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Boolean) | Initializes a new instance of the ImGearARTFilledEllipse class object.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class > ImGearARTFilledEllipse Constructor : ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
The mark's rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTFilledEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTFilledEllipse(rect, fillColor)
public ImGearARTFilledEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTFilledEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTFilledEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class > ImGearARTFilledEllipse Constructor : ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Boolean)
The mark's rectangle.
Fill color of the mark.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTFilledEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad
Dim isHighlighted As Boolean

Dim instance As New ImGearARTFilledEllipse(rect, fillColor, isHighlighted)
public ImGearARTFilledEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   bool isHighlighted
)
public: ImGearARTFilledEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor,
   bool isHighlighted
)
public:
ImGearARTFilledEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor,
   bool isHighlighted
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTFilledEllipse Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledEllipse Class

For a list of all members of this type, see ImGearARTFilledEllipse members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTFilledEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTFilledEllipse Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledEllipse Class

For a list of all members of this type, see ImGearARTFilledEllipse members.

See Also

Reference

ImGearARTFilledEllipse Class
ImageGear.ART Namespace


Flip Method (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTFilledEllipse
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Flip Method


GetRenderBounds Method (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledEllipse
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Move Method (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTFilledEllipse
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Rotate Method (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTFilledEllipse
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Rotate Method


Scale Method (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTFilledEllipse
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTFilledEllipse Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledEllipse Class

For a list of all members of this type, see ImGearARTFilledEllipse members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark.
Top
See Also

Reference

ImGearARTFilledEllipse Class
ImageGear.ART Namespace


Bounds Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
ImGearRectangle Structure


FillColor Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
ImGearRGBQuad Structure


Height Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Highlight Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


SelectionType Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Type Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTFilledEllipse)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Visible Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Width Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


X Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : X Property
Gets or sets the X coordinate of the top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


Y Property (ImGearARTFilledEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledEllipse Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTFilledEllipse
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

ImGearARTFilledPolygon Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledPolygon Class
Represents legacy ART Filled Polygon mark.
Object Model
ImGearARTFilledPolygon ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFilledPolygon
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTFilledPolygon
public class ImGearARTFilledPolygon : ImGearARTMark
public __gc class ImGearARTFilledPolygon : public ImGearARTMark
public ref class ImGearARTFilledPolygon : public ImGearARTMark
Example
  • C#
// Create an array of 5 points for the polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the polygon.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create polygon with highlight on.
ImGearARTFilledPolygon igARTFilledPolygon = new ImGearARTFilledPolygon(
    igPoints, igRGBQuad, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledPolygon, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the polygon.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create polygon with highlight on.
Dim igARTFilledPolygon As New ImGearARTFilledPolygon( _
 igPoints, igRGBQuad, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledPolygon, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTFilledPolygon

See Also

Reference

ImGearARTFilledPolygon Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFilledPolygon Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledPolygon Class

The following tables list the members exposed by ImGearARTFilledPolygon.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFilledPolygon Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | NumberOfPoints | Gets or sets the actual number of points.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFilledPolygon Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : ImGearARTFilledPolygon Constructor
Overload List
Overload | Description
ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledPolygon class object.
ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,Boolean) | Initializes a new instance of the ImGearARTFilledPolygon class object.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class > ImGearARTFilledPolygon Constructor : ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
Raw points array to create a polygon from.
Fill color of the mark.
Initializes a new instance of the ImGearARTFilledPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTFilledPolygon(points, fillColor)
public ImGearARTFilledPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor
)
public: ImGearARTFilledPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTFilledPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ fillColor
)

Parameters

points
Raw points array to create a polygon from.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class > ImGearARTFilledPolygon Constructor : ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,Boolean)
Raw points array to create a polygon from.
Fill color of the mark.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTFilledPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim points() As ImGearPoint
Dim fillColor As IImGearRGBQuad
Dim isHighlighted As Boolean

Dim instance As New ImGearARTFilledPolygon(points, fillColor, isHighlighted)
public ImGearARTFilledPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor,
   bool isHighlighted
)
public: ImGearARTFilledPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* fillColor,
   bool isHighlighted
)
public:
ImGearARTFilledPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ fillColor,
   bool isHighlighted
)

Parameters

points
Raw points array to create a polygon from.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTFilledPolygon Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledPolygon Class

For a list of all members of this type, see ImGearARTFilledPolygon members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFilledPolygon Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearPoint Structure


Flip Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Flip Method


GetPoint Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : GetPoint Method
Actual index of the point to get.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTFilledPolygon
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Actual index of the point to get.

Return Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledPolygon
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


Move Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


OnPointAdded Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


OnPointChanged Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


OnPointsRemoved Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


RemovePoints Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


Rotate Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Rotate Method


Scale Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Scale Method


SetPoint Method (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : SetPoint Method
Index to set at.
Point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index to set at.
point
Point to set.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTFilledPolygon Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledPolygon Class

For a list of all members of this type, see ImGearARTFilledPolygon members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | NumberOfPoints | Gets or sets the actual number of points.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
See Also

Reference

ImGearARTFilledPolygon Class
ImageGear.ART Namespace


Bounds Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearRectangle Structure


FillColor Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearRGBQuad Structure


Highlight Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


NumberOfPoints Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : NumberOfPoints Property
Gets or sets the actual number of points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer number.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


Points Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFilledPolygon.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


SelectionType Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


Type Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTFilledPolygon)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


Visible Property (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTFilledPolygon
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%% $$Events$$

ImGearARTFilledPolygon Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledPolygon Class

For a list of all members of this type, see ImGearARTFilledPolygon members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFilledPolygon Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTFilledPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


PointChanged Event (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTFilledPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


PointsRemoved Event (ImGearARTFilledPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledPolygon Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTFilledPolygon
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

ImGearARTFilledRectangle Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledRectangle Class
Represents legacy ART Filled Rectangle mark.
Object Model
ImGearARTFilledRectangle ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFilledRectangle
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTFilledRectangle
public class ImGearARTFilledRectangle : ImGearARTMark
public __gc class ImGearARTFilledRectangle : public ImGearARTMark
public ref class ImGearARTFilledRectangle : public ImGearARTMark
Example
  • C#
// Setup rectangle for the rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the rectangle.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create rectangle with highlight on.
ImGearARTFilledRectangle igARTFilledRectangle = new ImGearARTFilledRectangle(
    igRectangle, igRGBQuad, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledRectangle, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the rectangle.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create rectangle with highlight on.
Dim igARTFilledRectangle As New ImGearARTFilledRectangle( _
 igRectangle, igRGBQuad, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledRectangle, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTFilledRectangle

See Also

Reference

ImGearARTFilledRectangle Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFilledRectangle Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledRectangle Class

The following tables list the members exposed by ImGearARTFilledRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFilledRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTFilledRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : ImGearARTFilledRectangle Constructor
Overload List
Overload | Description
ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledRectangle class object.
ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,Boolean) | Initializes a new instance of the ImGearARTFilledRectangle class object.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class > ImGearARTFilledRectangle Constructor : ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
The mark's rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTFilledRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTFilledRectangle(rect, fillColor)
public ImGearARTFilledRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTFilledRectangle(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTFilledRectangle(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class > ImGearARTFilledRectangle Constructor : ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,Boolean)
The mark's rectangle.
Fill color of the mark.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTFilledRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad
Dim isHighlighted As Boolean

Dim instance As New ImGearARTFilledRectangle(rect, fillColor, isHighlighted)
public ImGearARTFilledRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   bool isHighlighted
)
public: ImGearARTFilledRectangle(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor,
   bool isHighlighted
)
public:
ImGearARTFilledRectangle(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor,
   bool isHighlighted
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTFilledRectangle Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledRectangle Class

For a list of all members of this type, see ImGearARTFilledRectangle members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTFilledRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTFilledRectangle Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledRectangle Class

For a list of all members of this type, see ImGearARTFilledRectangle members.

See Also

Reference

ImGearARTFilledRectangle Class
ImageGear.ART Namespace


Flip Method (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTFilledRectangle
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Flip Method


GetRenderBounds Method (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledRectangle
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Move Method (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTFilledRectangle
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Rotate Method (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTFilledRectangle
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Rotate Method


Scale Method (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTFilledRectangle
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTFilledRectangle Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFilledRectangle Class

For a list of all members of this type, see ImGearARTFilledRectangle members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark.
Top
See Also

Reference

ImGearARTFilledRectangle Class
ImageGear.ART Namespace


Bounds Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
ImGearRectangle Structure


FillColor Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
ImGearRGBQuad Structure


Height Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Highlight Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


SelectionType Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Type Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTFilledRectangle)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Visible Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Width Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


X Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : X Property
Gets or sets the X coordinate of the top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


Y Property (ImGearARTFilledRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFilledRectangle Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTFilledRectangle
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

ImGearARTFreeLine Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFreeLine Class
Represents legacy ART Freehand line mark.
Object Model
ImGearARTFreeLine ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFreeLine
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTFreeLine
public class ImGearARTFreeLine : ImGearARTMark
public __gc class ImGearARTFreeLine : public ImGearARTMark
public ref class ImGearARTFreeLine : public ImGearARTMark
Example
  • C#
// Create an array of 5 points for the line.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create line with a width of 4, highlight off, and not closed.
ImGearARTFreeLine igARTFreeLine = new ImGearARTFreeLine(
    igPoints, igRGBQuad, 4, false, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFreeLine, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the line.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create line with a width of 4, highlight off, and not closed.
Dim igARTFreeLine As New ImGearARTFreeLine( _
 igPoints, igRGBQuad, 4, False, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFreeLine, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTFreeLine

See Also

Reference

ImGearARTFreeLine Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFreeLine Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFreeLine Class

The following tables list the members exposed by ImGearARTFreeLine.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFreeLine Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the color of the line.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | IsClosed | Gets or sets a value indicating whether the line is closed.
Public Property | NumberOfPoints | Gets or sets the actual number of points on the line mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the line.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFreeLine Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFreeLine Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : ImGearARTFreeLine Constructor
Overload List
Overload | Description
ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTFreeLine class object.
ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,Int32,Boolean,Boolean) | Initializes a new instance of the ImGearARTFreeLine class object.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class > ImGearARTFreeLine Constructor : ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad)
The mark's points.
Color of the mark.
Initializes a new instance of the ImGearARTFreeLine class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTFreeLine(points, color)
public ImGearARTFreeLine(
   ImGearPoint[] points,
   IImGearRGBQuad color
)
public: ImGearARTFreeLine(
   ImGearPoint[]* points,
   IImGearRGBQuad* color
)
public:
ImGearARTFreeLine(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color
)

Parameters

points
The mark's points.
color
Color of the mark.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,Int32,Boolean,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class > ImGearARTFreeLine Constructor : ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,Int32,Boolean,Boolean)
The mark's points.
Color of the mark.
Width of the line.
Specifies whether the mark is highlighted or not.
Specifies whether the mark is closed or not.
Initializes a new instance of the ImGearARTFreeLine class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer, _
   ByVal isHighlighted As Boolean, _
   ByVal isClosed As Boolean _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim width As Integer
Dim isHighlighted As Boolean
Dim isClosed As Boolean

Dim instance As New ImGearARTFreeLine(points, color, width, isHighlighted, isClosed)
public ImGearARTFreeLine(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   int width,
   bool isHighlighted,
   bool isClosed
)
public: ImGearARTFreeLine(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   int width,
   bool isHighlighted,
   bool isClosed
)
public:
ImGearARTFreeLine(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   int width,
   bool isHighlighted,
   bool isClosed
)

Parameters

points
The mark's points.
color
Color of the mark.
width
Width of the line.
isHighlighted
Specifies whether the mark is highlighted or not.
isClosed
Specifies whether the mark is closed or not.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTFreeLine Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFreeLine Class

For a list of all members of this type, see ImGearARTFreeLine members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFreeLine Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearPoint Structure


Flip Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Flip Method


GetPoint Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : GetPoint Method
Index of the point.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTFreeLine
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTFreeLine
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Move Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


OnPointAdded Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


OnPointChanged Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


OnPointsRemoved Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


RemovePoints Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Rotate Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Rotate Method


Scale Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Scale Method


SetPoint Method (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : SetPoint Method
Index to set the point at.
Point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTFreeLine
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index to set the point at.
point
Point to set.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTFreeLine Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFreeLine Class

For a list of all members of this type, see ImGearARTFreeLine members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the color of the line.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | IsClosed | Gets or sets a value indicating whether the line is closed.
Public Property | NumberOfPoints | Gets or sets the actual number of points on the line mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the line.
Top
See Also

Reference

ImGearARTFreeLine Class
ImageGear.ART Namespace


Bounds Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTFreeLine
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearRectangle Structure


Color Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Color Property
Gets or sets the color of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTFreeLine
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearRGBQuad Structure


Highlight Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


IsClosed Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : IsClosed Property
Gets or sets a value indicating whether the line is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsClosed As Boolean
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Boolean

instance.IsClosed = value

value = instance.IsClosed
public bool IsClosed {get; set;}
public: __property bool get_IsClosed();
public: __property void set_IsClosed(
   bool value
);
public:
property bool IsClosed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


NumberOfPoints Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : NumberOfPoints Property
Gets or sets the actual number of points on the line mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Points Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTFreeLine
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTFreeLine.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTFreeLine
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


SelectionType Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTFreeLine
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Type Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTFreeLine
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTFreeLine)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Visible Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


Width Property (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : Width Property
Gets or sets the width of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTFreeLine
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%% $$Events$$

ImGearARTFreeLine Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFreeLine Class

For a list of all members of this type, see ImGearARTFreeLine members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTFreeLine Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTFreeLine
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


PointChanged Event (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTFreeLine
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


PointsRemoved Event (ImGearARTFreeLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTFreeLine Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTFreeLine
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

ImGearARTGetNotateXpressLayerPasswordEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGetNotateXpressLayerPasswordEventArgs Class
The GetNotateXpressLayerPassword event arguments.
Object Model
ImGearARTGetNotateXpressLayerPasswordEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTGetNotateXpressLayerPasswordEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTGetNotateXpressLayerPasswordEventArgs
public class ImGearARTGetNotateXpressLayerPasswordEventArgs : System.EventArgs
public __gc class ImGearARTGetNotateXpressLayerPasswordEventArgs : public System.EventArgs
public ref class ImGearARTGetNotateXpressLayerPasswordEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTGetNotateXpressLayerPasswordEventArgs

See Also

Reference

ImGearARTGetNotateXpressLayerPasswordEventArgs Members
ImageGear.ART Namespace
GetNotateXpressLayerPassword Property


%%PageItemTitle%% $$Members$$

ImGearARTGetNotateXpressLayerPasswordEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGetNotateXpressLayerPasswordEventArgs Class

The following tables list the members exposed by ImGearARTGetNotateXpressLayerPasswordEventArgs.

Public Properties
 | Name | Description
Public Property | LayerName | Gets a layer name of the layer that needs a password.
Public Property | LayerPassword | Gets or sets the password for the current layer.
Top
See Also

Reference

ImGearARTGetNotateXpressLayerPasswordEventArgs Class
ImageGear.ART Namespace
GetNotateXpressLayerPassword Property


%%PageItemTitle%% $$Properties$$

ImGearARTGetNotateXpressLayerPasswordEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGetNotateXpressLayerPasswordEventArgs Class

For a list of all members of this type, see ImGearARTGetNotateXpressLayerPasswordEventArgs members.

Public Properties
 | Name | Description
Public Property | LayerName | Gets a layer name of the layer that needs a password.
Public Property | LayerPassword | Gets or sets the password for the current layer.
Top
See Also

Reference

ImGearARTGetNotateXpressLayerPasswordEventArgs Class
ImageGear.ART Namespace
GetNotateXpressLayerPassword Property


LayerName Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGetNotateXpressLayerPasswordEventArgs Class : LayerName Property
Gets a layer name of the layer that needs a password.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerName As String
'Usage

Dim instance As ImGearARTGetNotateXpressLayerPasswordEventArgs
Dim value As String

value = instance.LayerName
public string LayerName {get;}
public: __property string* get_LayerName();
public:
property String^ LayerName {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTGetNotateXpressLayerPasswordEventArgs Class
ImGearARTGetNotateXpressLayerPasswordEventArgs Members


LayerPassword Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGetNotateXpressLayerPasswordEventArgs Class : LayerPassword Property
Gets or sets the password for the current layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LayerPassword As String
'Usage

Dim instance As ImGearARTGetNotateXpressLayerPasswordEventArgs
Dim value As String

instance.LayerPassword = value

value = instance.LayerPassword
public string LayerPassword {get; set;}
public: __property string* get_LayerPassword();
public: __property void set_LayerPassword(
   string* value
);
public:
property String^ LayerPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTGetNotateXpressLayerPasswordEventArgs Class
ImGearARTGetNotateXpressLayerPasswordEventArgs Members


%%PageItemTitle%%

ImGearARTGroup Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroup Class
Represents a collection of annotation marks united into a single group.
Object Model
ImGearARTGroup ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearARTGroup
   Implements IImGearARTMarkIDEnumerable
'Usage

Dim instance As ImGearARTGroup
[DefaultMember("Item")]
public class ImGearARTGroup : IImGearARTMarkIDEnumerable
[DefaultMember("Item")]
public __gc class ImGearARTGroup : public IImGearARTMarkIDEnumerable
[DefaultMember("Item")]
public ref class ImGearARTGroup : public IImGearARTMarkIDEnumerable
Remarks
This class provides methods and properties generic for the annotation group.
Example
  • C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();
  • Visual Basic
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTGroup

See Also

Reference

ImGearARTGroup Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTGroup Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroup Class

The following tables list the members exposed by ImGearARTGroup.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTGroup Constructor | Initializes a new instance of the ImGearARTGroup class object.
Top
Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access to the group.
Public Property | AccessController | Gets access controller for the group.
Public Property | Count | Gets the marks count in the group.
Public Property | Description | Gets or sets the group description.
Public Property | Item | Gets or sets a mark by index.
Public Property | Name | Gets or sets the group name.
Public Property | ParentPage | Gets the reference to the parent page.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the group.
Public Property | Visible | Gets or sets a value indicating whether the group is visible.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Moves the group of marks to the top of Z-Order.
Public Method | Clone | Creates a deep copy of the annotation group.
Public Method | Copy | Copies the group of marks to the Windows clipboard.
Public Method | Cut | Cuts the group of marks to the Windows clipboard.
Public Method | GetEnumerator | Gets the group enumerator class.
Public Method | RemoveAll | Removes all marks from the group.
Public Method | RemoveAt | Removes a mark specified by index from the group.
Public Method | Select | Selects or deselects all marks in the group.
Public Method | SendToBack | Moves the group of marks to the bottom of Z-Order.
Top
See Also

Reference

ImGearARTGroup Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTGroup Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : ImGearARTGroup Constructor
Group name.
Group description.
Initializes a new instance of the ImGearARTGroup class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal description As String _
)
'Usage

Dim name As String
Dim description As String

Dim instance As New ImGearARTGroup(name, description)
public ImGearARTGroup(
   string name,
   string description
)
public: ImGearARTGroup(
   string* name,
   string* description
)
public:
ImGearARTGroup(
   String^ name,
   String^ description
)

Parameters

name
Group name.
description
Group description.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%% $$Methods$$

ImGearARTGroup Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroup Class

For a list of all members of this type, see ImGearARTGroup members.

Public Methods
 | Name | Description
Public Method | BringToFront | Moves the group of marks to the top of Z-Order.
Public Method | Clone | Creates a deep copy of the annotation group.
Public Method | Copy | Copies the group of marks to the Windows clipboard.
Public Method | Cut | Cuts the group of marks to the Windows clipboard.
Public Method | GetEnumerator | Gets the group enumerator class.
Public Method | RemoveAll | Removes all marks from the group.
Public Method | RemoveAt | Removes a mark specified by index from the group.
Public Method | Select | Selects or deselects all marks in the group.
Public Method | SendToBack | Moves the group of marks to the bottom of Z-Order.
Top
See Also

Reference

ImGearARTGroup Class
ImageGear.ART Namespace


BringToFront Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : BringToFront Method
Moves the group of marks to the top of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BringToFront()
'Usage

Dim instance As ImGearARTGroup

instance.BringToFront()
public void BringToFront()
public: void BringToFront();
public:
void BringToFront();
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Clone Method (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Clone Method
Creates a deep copy of the annotation group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearARTGroup
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTGroup

value = instance.Clone()
public ImGearARTGroup Clone()
public: ImGearARTGroup* Clone();
public:
ImGearARTGroup^ Clone();

Return Value

Copy of the ImGearARTGroup object.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Copy Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Copy Method
Copies the group of marks to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Copy()
'Usage

Dim instance As ImGearARTGroup

instance.Copy()
public void Copy()
public: void Copy();
public:
void Copy();
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Cut Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Cut Method
Cuts the group of marks to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Cut()
'Usage

Dim instance As ImGearARTGroup

instance.Cut()
public void Cut()
public: void Cut();
public:
void Cut();
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


GetEnumerator Method (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : GetEnumerator Method
Gets the group enumerator class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As ImGearARTGroupEnumerator
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTGroupEnumerator

value = instance.GetEnumerator()
public ImGearARTGroupEnumerator GetEnumerator()
public: ImGearARTGroupEnumerator* GetEnumerator();
public:
ImGearARTGroupEnumerator^ GetEnumerator();

Return Value

ImGearARTGroupEnumerator class object.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members
ImGearARTGroupEnumerator Class


RemoveAll Method (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : RemoveAll Method
Removes all marks from the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAll()
'Usage

Dim instance As ImGearARTGroup

instance.RemoveAll()
public void RemoveAll()
public: void RemoveAll();
public:
void RemoveAll();
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


RemoveAt Method (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : RemoveAt Method
Index of a mark in the group to remove.
Removes a mark specified by index from the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearARTGroup
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
Index of a mark in the group to remove.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Select Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Select Method
Pass true to select all marks in the group, false to deselect.
Selects or deselects all marks in the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Select( _
   ByVal state As Boolean _
)
'Usage

Dim instance As ImGearARTGroup
Dim state As Boolean

instance.Select(state)
public void Select(
   bool state
)
public: void Select(
   bool state
)
public:
void Select(
   bool state
)

Parameters

state
Pass true to select all marks in the group, false to deselect.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


SendToBack Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : SendToBack Method
Moves the group of marks to the bottom of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendToBack()
'Usage

Dim instance As ImGearARTGroup

instance.SendToBack()
public void SendToBack()
public: void SendToBack();
public:
void SendToBack();
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%% $$Properties$$

ImGearARTGroup Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroup Class

For a list of all members of this type, see ImGearARTGroup members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access to the group.
Public Property | AccessController | Gets access controller for the group.
Public Property | Count | Gets the marks count in the group.
Public Property | Description | Gets or sets the group description.
Public Property | Item | Gets or sets a mark by index.
Public Property | Name | Gets or sets the group name.
Public Property | ParentPage | Gets the reference to the parent page.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the group.
Public Property | Visible | Gets or sets a value indicating whether the group is visible.
Top
See Also

Reference

ImGearARTGroup Class
ImageGear.ART Namespace


Access Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Access Property
Gets or sets the access to the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Access As ImGearARTAccess
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTAccess

instance.Access = value

value = instance.Access
public ImGearARTAccess Access {get; set;}
public: __property ImGearARTAccess get_Access();
public: __property void set_Access(
   ImGearARTAccess value
);
public:
property ImGearARTAccess Access {
   ImGearARTAccess get();
   void set (    ImGearARTAccess value);
}

Property Value

ImGearARTAccess enumeration value.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members
ImGearARTAccess Enumeration


AccessController Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : AccessController Property
Gets access controller for the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AccessController As ImGearARTAccessController
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTAccessController

value = instance.AccessController
public ImGearARTAccessController AccessController {get;}
public: __property ImGearARTAccessController* get_AccessController();
public:
property ImGearARTAccessController^ AccessController {
   ImGearARTAccessController^ get();
}

Property Value

ImGearARTAccessController class instance.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Count Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Count Property
Gets the marks count in the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearARTGroup
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Description Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Description Property
Gets or sets the group description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As ImGearARTGroup
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Item Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Item Property
Index of a mark.
Gets or sets a mark by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImGearARTMark
'Usage

Dim instance As ImGearARTGroup
Dim index As Integer
Dim value As ImGearARTMark

instance.Item(index) = value

value = instance.Item(index)
public ImGearARTMark this[
   int index
]; {get; set;}
public: __property ImGearARTMark* get_Item   int index
;
public: __property void set_Item   int index,
   ImGearARTMark* value
;
public:
property ImGearARTMark^ default [int] {
   ImGearARTMark^ get(int index);
   void set (int index, ImGearARTMark^ value);
}

Parameters

index
Index of a mark.

Property Value

ImGearARTMark class object.
Remarks
Indexed property for accessing individual marks from the group.

When setting a new mark at the specified index, please make sure it does not have parent group (i.e. ImGearARTMark.ParentGroup is null), otherwise ImageGear.Core.ImGearException will be thrown. If the mark to be added already has parent group, please clone it prior to setting at the specified index.

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members
ImGearARTMark Class


Name Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Name Property
Gets or sets the group name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearARTGroup
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


ParentPage Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : ParentPage Property
Gets the reference to the parent page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ParentPage As ImGearARTPage
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTPage

value = instance.ParentPage
public ImGearARTPage ParentPage {get;}
public: __property ImGearARTPage* get_ParentPage();
public:
property ImGearARTPage^ ParentPage {
   ImGearARTPage^ get();
}

Property Value

ImGearARTPage value.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


SecureObjectData Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : SecureObjectData Property
Gets or sets data object for the AccessController property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SecureObjectData As ImGearARTSecureObjectData
'Usage

Dim instance As ImGearARTGroup
Dim value As ImGearARTSecureObjectData

instance.SecureObjectData = value

value = instance.SecureObjectData
public ImGearARTSecureObjectData SecureObjectData {get; set;}
public: __property ImGearARTSecureObjectData* get_SecureObjectData();
public: __property void set_SecureObjectData(
   ImGearARTSecureObjectData* value
);
public:
property ImGearARTSecureObjectData^ SecureObjectData {
   ImGearARTSecureObjectData^ get();
   void set (    ImGearARTSecureObjectData^ value);
}

Property Value

ImGearARTSecureObjectData class instance.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


UserDataAttributes Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : UserDataAttributes Property
Gets the user data dictionary specified for the group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UserDataAttributes As IDictionary(Of String,String)
'Usage

Dim instance As ImGearARTGroup
Dim value As IDictionary(Of String,String)

value = instance.UserDataAttributes
public IDictionary<string,string> UserDataAttributes {get;}
public: __property IDictionary<string*,string*>* get_UserDataAttributes();
public:
property IDictionary<String^,String^>^ UserDataAttributes {
   IDictionary<String^,String^>^ get();
}

Property Value

IDictionary interface.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


Visible Property (ImGearARTGroup)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroup Class : Visible Property
Gets or sets a value indicating whether the group is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As ImGearARTGroup
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

ImGearARTGroupArray Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupArray Class
Represents an array of annotation groups.
Object Model
ImGearARTGroupArray ClassImGearARTGroup Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearARTGroupArray
'Usage

Dim instance As ImGearARTGroupArray
[DefaultMember("Item")]
public class ImGearARTGroupArray
[DefaultMember("Item")]
public __gc class ImGearARTGroupArray
[DefaultMember("Item")]
public ref class ImGearARTGroupArray
Example
  • C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();
  • Visual Basic
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTGroupArray

See Also

Reference

ImGearARTGroupArray Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTGroupArray Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupArray Class

The following tables list the members exposed by ImGearARTGroupArray.

Public Properties
 | Name | Description
Public Property | AccessController | Gets access controller for the page.
Public Property | Count | Gets number of ART groups in the array.
Public Property | Item | Overloaded. Gets or sets a group by index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an annotation group to the array.
Public Method | Find | Finds a group specified by the name in the array.
Public Method | GetEnumerator | Returns the IEnumerator interface for the array of groups.
Public Method | GetGroup | Gets a group specified by the name.
Public Method | Remove | Overloaded. Removes the specified group from the array.
Public Method | RemoveAll | Removes all groups from the array.
Public Method | RemoveAt | Removes a group specified by index from the array.
Top
See Also

Reference

ImGearARTGroupArray Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTGroupArray Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupArray Class

For a list of all members of this type, see ImGearARTGroupArray members.

Public Methods
 | Name | Description
Public Method | Add | Adds an annotation group to the array.
Public Method | Find | Finds a group specified by the name in the array.
Public Method | GetEnumerator | Returns the IEnumerator interface for the array of groups.
Public Method | GetGroup | Gets a group specified by the name.
Public Method | Remove | Overloaded. Removes the specified group from the array.
Public Method | RemoveAll | Removes all groups from the array.
Public Method | RemoveAt | Removes a group specified by index from the array.
Top
See Also

Reference

ImGearARTGroupArray Class
ImageGear.ART Namespace


Add Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : Add Method
Group to add.
Adds an annotation group to the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal group As ImGearARTGroup _
) As Integer
'Usage

Dim instance As ImGearARTGroupArray
Dim group As ImGearARTGroup
Dim value As Integer

value = instance.Add(group)
public int Add(
   ImGearARTGroup group
)
public: int Add(
   ImGearARTGroup* group
)
public:
int Add(
   ImGearARTGroup^ group
)

Parameters

group
Group to add.

Return Value

Integer value.
Remarks
Please make sure the group does not have parent page (i.e. ImGearARTGroup.ParentPage is null), otherwise ImageGear.Core.ImGearException will be thrown. If the group to be added already has parent page, please clone it prior to adding to the array.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
ImGearARTGroup Class


Find Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : Find Method
Name of the group to find.
Finds a group specified by the name in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Find( _
   ByVal name As String _
) As ImGearARTGroup
'Usage

Dim instance As ImGearARTGroupArray
Dim name As String
Dim value As ImGearARTGroup

value = instance.Find(name)
public ImGearARTGroup Find(
   string name
)
public: ImGearARTGroup* Find(
   string* name
)
public:
ImGearARTGroup^ Find(
   String^ name
)

Parameters

name
Name of the group to find.

Return Value

ImGearARTGroup class object.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
ImGearARTGroup Class


GetEnumerator Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : GetEnumerator Method
Returns the IEnumerator interface for the array of groups.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearARTGroupArray
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


GetGroup Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : GetGroup Method
Name of the group to get.
Gets a group specified by the name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGroup( _
   ByVal name As String _
) As ImGearARTGroup
'Usage

Dim instance As ImGearARTGroupArray
Dim name As String
Dim value As ImGearARTGroup

value = instance.GetGroup(name)
public ImGearARTGroup GetGroup(
   string name
)
public: ImGearARTGroup* GetGroup(
   string* name
)
public:
ImGearARTGroup^ GetGroup(
   String^ name
)

Parameters

name
Name of the group to get.

Return Value

ImGearARTGroup class object.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTGroup Class


Remove Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : Remove Method
Removes the specified group from the array.
Overload List
Overload | Description
Remove(ImGearARTGroup) | Removes the specified group from the array.
Remove(String) | Removes a group with the specified name from the array.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


Remove(ImGearARTGroup) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class > Remove Method : Remove(ImGearARTGroup) Method
The group to remove.
Removes the specified group from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal group As ImGearARTGroup _
)
'Usage

Dim instance As ImGearARTGroupArray
Dim group As ImGearARTGroup

instance.Remove(group)
public void Remove(
   ImGearARTGroup group
)
public: void Remove(
   ImGearARTGroup* group
)
public:
void Remove(
   ImGearARTGroup^ group
)

Parameters

group
The group to remove.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List
ImGearARTGroup Class


Remove(String) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class > Remove Method : Remove(String) Method
Name of the group to remove.
Removes a group with the specified name from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearARTGroupArray
Dim name As String

instance.Remove(name)
public void Remove(
   string name
)
public: void Remove(
   string* name
)
public:
void Remove(
   String^ name
)

Parameters

name
Name of the group to remove.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List


RemoveAll Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : RemoveAll Method
Removes all groups from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAll()
'Usage

Dim instance As ImGearARTGroupArray

instance.RemoveAll()
public void RemoveAll()
public: void RemoveAll();
public:
void RemoveAll();
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


RemoveAt Method (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : RemoveAt Method
Index of a group in array to remove.
Removes a group specified by index from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearARTGroupArray
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
Index of a group in array to remove.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%% $$Properties$$

ImGearARTGroupArray Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupArray Class

For a list of all members of this type, see ImGearARTGroupArray members.

Public Properties
 | Name | Description
Public Property | AccessController | Gets access controller for the page.
Public Property | Count | Gets number of ART groups in the array.
Public Property | Item | Overloaded. Gets or sets a group by index.
Top
See Also

Reference

ImGearARTGroupArray Class
ImageGear.ART Namespace


AccessController Property (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : AccessController Property
Gets access controller for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AccessController As ImGearARTAccessController
'Usage

Dim instance As ImGearARTGroupArray
Dim value As ImGearARTAccessController

value = instance.AccessController
public ImGearARTAccessController AccessController {get;}
public: __property ImGearARTAccessController* get_AccessController();
public:
property ImGearARTAccessController^ AccessController {
   ImGearARTAccessController^ get();
}

Property Value

ImGearARTAccessController class instance.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


Count Property (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : Count Property
Gets number of ART groups in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearARTGroupArray
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer number.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


Item Property (ImGearARTGroupArray)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class : Item Property
Gets or sets a group by index.
Gets or sets a group.
Overload List
Overload | Description
Item(Int32) | Gets or sets a group by index.
Item(String) | Gets a group by name.
Remarks
Indexed property for accessing individual groups by index.

When setting a new group at the specified index, please make sure it does not have parent page (i.e. ImGearARTGroup.ParentPage is null), otherwise ImageGear.Core.ImGearException will be thrown. If the group to be added already has parent page, please clone it prior to setting at the specified index.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
ImGearARTGroup Class


Item(Int32) Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class > Item Property : Item(Int32) Property
Index of a group.
Gets or sets a group by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Property Item( _
   ByVal index As Integer _
) As ImGearARTGroup
'Usage

Dim instance As ImGearARTGroupArray
Dim index As Integer
Dim value As ImGearARTGroup

instance.Item(index) = value

value = instance.Item(index)
public ImGearARTGroup Item(
   int index
) {get; set;}
public: __property ImGearARTGroup* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ImGearARTGroup* value
);
public:
property ImGearARTGroup^ Item {
   ImGearARTGroup^ get(int index);
   void set (int index, ImGearARTGroup^ value);
}

Parameters

index
Index of a group.

Property Value

ImGearARTGroup class object.
Remarks
Indexed property for accessing individual groups by index.

When setting a new group at the specified index, please make sure it does not have parent page (i.e. ImGearARTGroup.ParentPage is null), otherwise ImageGear.Core.ImGearException will be thrown. If the group to be added already has parent page, please clone it prior to setting at the specified index.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List
ImGearARTGroup Class


Item(String) Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupArray Class > Item Property : Item(String) Property
Name of a group.
Gets a group by name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ImGearARTGroup
'Usage

Dim instance As ImGearARTGroupArray
Dim name As String
Dim value As ImGearARTGroup

value = instance.Item(name)
public ImGearARTGroup Item(
   string name
) {get;}
public: __property ImGearARTGroup* get_Item(
   string* name
);
public:
property ImGearARTGroup^ Item {
   ImGearARTGroup^ get(String^ name);
}

Parameters

name
Name of a group.

Property Value

ImGearARTGroup class object.
Remarks
Indexed property for accessing individual groups by name.
See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List
ImGearARTGroup Class


%%PageItemTitle%%

ImGearARTGroupEnumerator Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupEnumerator Class
Provides marks iteration capabilities over the annotation group.
Object Model
ImGearARTGroupEnumerator ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTGroupEnumerator
'Usage

Dim instance As ImGearARTGroupEnumerator
public class ImGearARTGroupEnumerator
public __gc class ImGearARTGroupEnumerator
public ref class ImGearARTGroupEnumerator
Remarks
Group enumerator is used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTGroupEnumerator

See Also

Reference

ImGearARTGroupEnumerator Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTGroupEnumerator Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupEnumerator Class

The following tables list the members exposed by ImGearARTGroupEnumerator.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTGroupEnumerator Constructor | Initializes a new instance of the ImGearARTGroupEnumerator class object.
Top
Public Properties
 | Name | Description
Public Property | Current | Gets the current element in the collection.
Top
Public Methods
 | Name | Description
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

ImGearARTGroupEnumerator Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTGroupEnumerator Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupEnumerator Class : ImGearARTGroupEnumerator Constructor
ART group to enumerate the marks from.
Initializes a new instance of the ImGearARTGroupEnumerator class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal artGroup As ImGearARTGroup _
)
'Usage

Dim artGroup As ImGearARTGroup

Dim instance As New ImGearARTGroupEnumerator(artGroup)
public ImGearARTGroupEnumerator(
   ImGearARTGroup artGroup
)
public: ImGearARTGroupEnumerator(
   ImGearARTGroup* artGroup
)
public:
ImGearARTGroupEnumerator(
   ImGearARTGroup^ artGroup
)

Parameters

artGroup
ART group to enumerate the marks from.
See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members
ImGearARTGroup Class
ImGearARTGroupEnumerator Class


%%PageItemTitle%% $$Methods$$

ImGearARTGroupEnumerator Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupEnumerator Class

For a list of all members of this type, see ImGearARTGroupEnumerator members.

Public Methods
 | Name | Description
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

ImGearARTGroupEnumerator Class
ImageGear.ART Namespace


MoveNext Method (ImGearARTGroupEnumerator)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupEnumerator Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As ImGearARTGroupEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

Boolean value.
Remarks

True if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members


%%PageItemTitle%% $$Properties$$

ImGearARTGroupEnumerator Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTGroupEnumerator Class

For a list of all members of this type, see ImGearARTGroupEnumerator members.

Public Properties
 | Name | Description
Public Property | Current | Gets the current element in the collection.
Top
See Also

Reference

ImGearARTGroupEnumerator Class
ImageGear.ART Namespace


Current Property (ImGearARTGroupEnumerator)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTGroupEnumerator Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As ImGearARTMark
'Usage

Dim instance As ImGearARTGroupEnumerator
Dim value As ImGearARTMark

value = instance.Current
public ImGearARTMark Current {get;}
public: __property ImGearARTMark* get_Current();
public:
property ImGearARTMark^ Current {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTHighlighter Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHighlighter Class
Represents legacy ART Highlighter mark.
Object Model
ImGearARTHighlighter ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHighlighter
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTHighlighter
public class ImGearARTHighlighter : ImGearARTMark
public __gc class ImGearARTHighlighter : public ImGearARTMark
public ref class ImGearARTHighlighter : public ImGearARTMark
Example
  • C#
// Setup rectangle for the highlighter mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the highlighter.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create highlighter.
ImGearARTHighlighter igARTHighlighter = new ImGearARTHighlighter(
    igRectangle, igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHighlighter, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the highlighter mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the highlighter.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create highlighter.
Dim igARTHighlighter As New ImGearARTHighlighter( _
 igRectangle, igRGBQuad)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHighlighter, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTHighlighter

See Also

Reference

ImGearARTHighlighter Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHighlighter Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHighlighter Class

The following tables list the members exposed by ImGearARTHighlighter.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHighlighter Constructor | Initializes a new instance of the ImGearARTHighlighter class object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the Highlighter mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the Highlighter mark rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of top-left point of mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHighlighter Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHighlighter Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : ImGearARTHighlighter Constructor
Mark's rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTHighlighter class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTHighlighter(rect, fillColor)
public ImGearARTHighlighter(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTHighlighter(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTHighlighter(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
ImGearRGBQuad Structure
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTHighlighter Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHighlighter Class

For a list of all members of this type, see ImGearARTHighlighter members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHighlighter Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTHighlighter Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHighlighter Class

For a list of all members of this type, see ImGearARTHighlighter members.

See Also

Reference

ImGearARTHighlighter Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHighlighter Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : ImGearARTHighlighter Constructor
Overload List
Overload | Description
ImGearARTHighlighter Constructor | Initializes a new instance of the ImGearARTHighlighter class object.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Flip Method (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTHighlighter
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
Flip Method


GetRenderBounds Method (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTHighlighter
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Move Method (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTHighlighter
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Rotate Method (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTHighlighter
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
Rotate Method


Scale Method (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTHighlighter
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTHighlighter Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHighlighter Class

For a list of all members of this type, see ImGearARTHighlighter members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the Highlighter mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the Highlighter mark rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of top-left point of mark's rectangle.
Top
See Also

Reference

ImGearARTHighlighter Class
ImageGear.ART Namespace


Bounds Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTHighlighter
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
ImGearRectangle Structure


FillColor Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTHighlighter
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
ImGearRGBQuad Structure


Height Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Height Property
Gets or sets the height of the Highlighter mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


SelectionType Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTHighlighter
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Type Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTHighlighter
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTHighlighter)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Visible Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Width Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Width Property
Gets or sets the width of the Highlighter mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


X Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : X Property
Gets or sets the X coordinate of top-left point of mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


Y Property (ImGearARTHighlighter)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHighlighter Class : Y Property
Gets or sets the Y coordinate of top-left point of mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTHighlighter
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

ImGearARTHistory Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistory Class
Represents an Undo/Redo history of the ART page.
Object Model
ImGearARTHistory Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHistory
'Usage

Dim instance As ImGearARTHistory
public class ImGearARTHistory
public __gc class ImGearARTHistory
public ref class ImGearARTHistory
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTHistory

See Also

Reference

ImGearARTHistory Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHistory Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistory Class

The following tables list the members exposed by ImGearARTHistory.

Public Properties
 | Name | Description
Public Property | IsEnabled | Gets or sets a value indicating whether the history functionality is enabled.
Public Property | IsGroupingHistoryOn | Gets a value indicating whether the grouping of history actions is active.
Public Property | IsSelectionRecorded | Gets or sets a value indicating whether the selection history recording is enabled.
Public Property | IsZOrderRecorded | Gets or sets a value indicating whether the z-order history recording is enabled.
Public Property | Limit | Gets or sets a value of the maximum count of Undo/Redo actions.
Public Property | RedoCount | Gets the count of available redo actions.
Public Property | Stream | Gets or sets a value indicating the Stream for action storing. If Stream == NULL the action will be stored in the memory.
Public Property | UndoCount | Gets the count of available undo actions.
Top
Public Methods
 | Name | Description
Public Method | BeginGroupingHistory | Begins group record of history actions. It allows to group multiple actions into a single undo/redo action.
Public Method | Clear | Clears the undo/redo history.
Public Method | EndGroupingHistory | Ends group record of history actions.
Public Method | Redo | Makes redo the stored action.
Public Method | Undo | Makes undo the stored action.
Top
Public Events
 | Name | Description
Public Event | HistoryChanged | Occurs when the history is changed.
Top
See Also

Reference

ImGearARTHistory Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTHistory Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistory Class

For a list of all members of this type, see ImGearARTHistory members.

Public Methods
 | Name | Description
Public Method | BeginGroupingHistory | Begins group record of history actions. It allows to group multiple actions into a single undo/redo action.
Public Method | Clear | Clears the undo/redo history.
Public Method | EndGroupingHistory | Ends group record of history actions.
Public Method | Redo | Makes redo the stored action.
Public Method | Undo | Makes undo the stored action.
Top
See Also

Reference

ImGearARTHistory Class
ImageGear.ART Namespace


BeginGroupingHistory Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : BeginGroupingHistory Method
Begins group record of history actions. It allows to group multiple actions into a single undo/redo action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BeginGroupingHistory()
'Usage

Dim instance As ImGearARTHistory

instance.BeginGroupingHistory()
public void BeginGroupingHistory()
public: void BeginGroupingHistory();
public:
void BeginGroupingHistory();
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


Clear Method (ImGearARTHistory)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : Clear Method
Clears the undo/redo history.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearARTHistory

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


EndGroupingHistory Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : EndGroupingHistory Method
Ends group record of history actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndGroupingHistory()
'Usage

Dim instance As ImGearARTHistory

instance.EndGroupingHistory()
public void EndGroupingHistory()
public: void EndGroupingHistory();
public:
void EndGroupingHistory();
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


Redo Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : Redo Method
Makes redo the stored action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Redo()
'Usage

Dim instance As ImGearARTHistory

instance.Redo()
public void Redo()
public: void Redo();
public:
void Redo();
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


Undo Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : Undo Method
Makes undo the stored action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Undo()
'Usage

Dim instance As ImGearARTHistory

instance.Undo()
public void Undo()
public: void Undo();
public:
void Undo();
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


%%PageItemTitle%% $$Properties$$

ImGearARTHistory Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistory Class

For a list of all members of this type, see ImGearARTHistory members.

Public Properties
 | Name | Description
Public Property | IsEnabled | Gets or sets a value indicating whether the history functionality is enabled.
Public Property | IsGroupingHistoryOn | Gets a value indicating whether the grouping of history actions is active.
Public Property | IsSelectionRecorded | Gets or sets a value indicating whether the selection history recording is enabled.
Public Property | IsZOrderRecorded | Gets or sets a value indicating whether the z-order history recording is enabled.
Public Property | Limit | Gets or sets a value of the maximum count of Undo/Redo actions.
Public Property | RedoCount | Gets the count of available redo actions.
Public Property | Stream | Gets or sets a value indicating the Stream for action storing. If Stream == NULL the action will be stored in the memory.
Public Property | UndoCount | Gets the count of available undo actions.
Top
See Also

Reference

ImGearARTHistory Class
ImageGear.ART Namespace


IsEnabled Property (ImGearARTHistory)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : IsEnabled Property
Gets or sets a value indicating whether the history functionality is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsEnabled As Boolean
'Usage

Dim instance As ImGearARTHistory
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
public bool IsEnabled {get; set;}
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
public:
property bool IsEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


IsGroupingHistoryOn Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : IsGroupingHistoryOn Property
Gets a value indicating whether the grouping of history actions is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsGroupingHistoryOn As Boolean
'Usage

Dim instance As ImGearARTHistory
Dim value As Boolean

value = instance.IsGroupingHistoryOn
public bool IsGroupingHistoryOn {get;}
public: __property bool get_IsGroupingHistoryOn();
public:
property bool IsGroupingHistoryOn {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


IsSelectionRecorded Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : IsSelectionRecorded Property
Gets or sets a value indicating whether the selection history recording is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelectionRecorded As Boolean
'Usage

Dim instance As ImGearARTHistory
Dim value As Boolean

instance.IsSelectionRecorded = value

value = instance.IsSelectionRecorded
public bool IsSelectionRecorded {get; set;}
public: __property bool get_IsSelectionRecorded();
public: __property void set_IsSelectionRecorded(
   bool value
);
public:
property bool IsSelectionRecorded {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


IsZOrderRecorded Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : IsZOrderRecorded Property
Gets or sets a value indicating whether the z-order history recording is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsZOrderRecorded As Boolean
'Usage

Dim instance As ImGearARTHistory
Dim value As Boolean

instance.IsZOrderRecorded = value

value = instance.IsZOrderRecorded
public bool IsZOrderRecorded {get; set;}
public: __property bool get_IsZOrderRecorded();
public: __property void set_IsZOrderRecorded(
   bool value
);
public:
property bool IsZOrderRecorded {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


Limit Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : Limit Property
Gets or sets a value of the maximum count of Undo/Redo actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Limit As UInteger
'Usage

Dim instance As ImGearARTHistory
Dim value As UInteger

instance.Limit = value

value = instance.Limit
public uint Limit {get; set;}
public: __property uint get_Limit();
public: __property void set_Limit(
   uint value
);
public:
property uint Limit {
   uint get();
   void set (    uint value);
}

Property Value

Unsigned integer value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


RedoCount Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : RedoCount Property
Gets the count of available redo actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RedoCount As UInteger
'Usage

Dim instance As ImGearARTHistory
Dim value As UInteger

value = instance.RedoCount
public uint RedoCount {get;}
public: __property uint get_RedoCount();
public:
property uint RedoCount {
   uint get();
}

Property Value

Unsigned integer value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


Stream Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : Stream Property
Gets or sets a value indicating the Stream for action storing. If Stream == NULL the action will be stored in the memory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stream As Stream
'Usage

Dim instance As ImGearARTHistory
Dim value As Stream

instance.Stream = value

value = instance.Stream
public Stream Stream {get; set;}
public: __property Stream* get_Stream();
public: __property void set_Stream(
   Stream* value
);
public:
property Stream^ Stream {
   Stream^ get();
   void set (    Stream^ value);
}

Property Value

Stream value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


UndoCount Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : UndoCount Property
Gets the count of available undo actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UndoCount As UInteger
'Usage

Dim instance As ImGearARTHistory
Dim value As UInteger

value = instance.UndoCount
public uint UndoCount {get;}
public: __property uint get_UndoCount();
public:
property uint UndoCount {
   uint get();
}

Property Value

Unsigned integer value.
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


%%PageItemTitle%% $$Events$$

ImGearARTHistory Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistory Class

For a list of all members of this type, see ImGearARTHistory members.

Public Events
 | Name | Description
Public Event | HistoryChanged | Occurs when the history is changed.
Top
See Also

Reference

ImGearARTHistory Class
ImageGear.ART Namespace


HistoryChanged Event

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistory Class : HistoryChanged Event
Occurs when the history is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event HistoryChanged As ImGearARTHistoryEventHandler
'Usage

Dim instance As ImGearARTHistory
Dim handler As ImGearARTHistoryEventHandler

AddHandler instance.HistoryChanged, handler
public event ImGearARTHistoryEventHandler HistoryChanged
public: __event ImGearARTHistoryEventHandler* HistoryChanged
public:
event ImGearARTHistoryEventHandler^ HistoryChanged
See Also

Reference

ImGearARTHistory Class
ImGearARTHistory Members


%%PageItemTitle%%

ImGearARTHistoryEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistoryEventArgs Class
Provides data for the history events.
Object Model
ImGearARTHistoryEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHistoryEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTHistoryEventArgs
public class ImGearARTHistoryEventArgs : System.EventArgs
public __gc class ImGearARTHistoryEventArgs : public System.EventArgs
public ref class ImGearARTHistoryEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTHistoryEventArgs

See Also

Reference

ImGearARTHistoryEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHistoryEventArgs Class Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistoryEventArgs Class

The following tables list the members exposed by ImGearARTHistoryEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHistoryEventArgs Constructor |
Top
See Also

Reference

ImGearARTHistoryEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHistoryEventArgs Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHistoryEventArgs Class : ImGearARTHistoryEventArgs Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTHistoryEventArgs()
public ImGearARTHistoryEventArgs()
public: ImGearARTHistoryEventArgs();
public:
ImGearARTHistoryEventArgs();
See Also

Reference

ImGearARTHistoryEventArgs Class
ImGearARTHistoryEventArgs Members


%%PageItemTitle%%

ImGearARTHollowEllipse Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowEllipse Class
Represents legacy ART Hollow Ellipse mark.
Object Model
ImGearARTHollowEllipse ClassIImGearRGBQuad InterfaceImGearRectangle StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHollowEllipse
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTHollowEllipse
public class ImGearARTHollowEllipse : ImGearARTMark
public __gc class ImGearARTHollowEllipse : public ImGearARTMark
public ref class ImGearARTHollowEllipse : public ImGearARTMark
Example
  • C#
// Setup rectangle for the hollow ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hollow ellipse.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow ellipse with a border of 10 and highlight off.
ImGearARTHollowEllipse igARTHollowEllipse = new ImGearARTHollowEllipse(
    igRectangle, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowEllipse, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the hollow ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hollow ellipse.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow ellipse with a border of 10 and highlight off.
Dim igARTHollowEllipse As New ImGearARTHollowEllipse( _
 igRectangle, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowEllipse, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTHollowEllipse

See Also

Reference

ImGearARTHollowEllipse Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHollowEllipse Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowEllipse Class

The following tables list the members exposed by ImGearARTHollowEllipse.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHollowEllipse Constructor | Overloaded. Initializes a new instance of the ImGearARTHollowEllipse class.
Top
Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHollowEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : ImGearARTHollowEllipse Constructor
Initializes a new instance of the ImGearARTHollowEllipse class.
Overload List
Overload | Description
ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowEllipse class object.
ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Int32,Boolean) | Initializes a new instance of the ImGearARTHollowEllipse class object.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class > ImGearARTHollowEllipse Constructor : ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
Mark's rectangle.
Border color of the mark.
Initializes a new instance of the ImGearARTHollowEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As IImGearRGBQuad

Dim instance As New ImGearARTHollowEllipse(rect, borderColor)
public ImGearARTHollowEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor
)
public: ImGearARTHollowEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* borderColor
)
public:
ImGearARTHollowEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ borderColor
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Int32,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class > ImGearARTHollowEllipse Constructor : ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,Int32,Boolean)
Mark's rectangle.
Border color of the mark.
Width of the mark's border.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTHollowEllipse class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderWidth As Integer, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As IImGearRGBQuad
Dim borderWidth As Integer
Dim isHighlighted As Boolean

Dim instance As New ImGearARTHollowEllipse(rect, borderColor, borderWidth, isHighlighted)
public ImGearARTHollowEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)
public: ImGearARTHollowEllipse(
   IImGearRectangle* rect,
   IImGearRGBQuad* borderColor,
   int borderWidth,
   bool isHighlighted
)
public:
ImGearARTHollowEllipse(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ borderColor,
   int borderWidth,
   bool isHighlighted
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTHollowEllipse Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowEllipse Class

For a list of all members of this type, see ImGearARTHollowEllipse members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHollowEllipse Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTHollowEllipse Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowEllipse Class

For a list of all members of this type, see ImGearARTHollowEllipse members.

See Also

Reference

ImGearARTHollowEllipse Class
ImageGear.ART Namespace


Flip Method (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTHollowEllipse
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Flip Method


GetRenderBounds Method (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowEllipse
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Move Method (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTHollowEllipse
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Rotate Method (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTHollowEllipse
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Rotate Method


Scale Method (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTHollowEllipse
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTHollowEllipse Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowEllipse Class

For a list of all members of this type, see ImGearARTHollowEllipse members.

Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
See Also

Reference

ImGearARTHollowEllipse Class
ImageGear.ART Namespace


BorderColor Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : BorderColor Property
Gets or sets the border color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As IImGearRGBQuad

instance.BorderColor = value

value = instance.BorderColor
public IImGearRGBQuad BorderColor {get; set;}
public: __property IImGearRGBQuad* get_BorderColor();
public: __property void set_BorderColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ BorderColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
ImGearRGBQuad Structure


BorderWidth Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : BorderWidth Property
Gets or sets the border width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Integer
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
public int BorderWidth {get; set;}
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
public:
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Bounds Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
ImGearRectangle Structure


Height Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Highlight Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


SelectionType Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Type Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTHollowEllipse)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Visible Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Width Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


X Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : X Property
Gets or sets the X coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


Y Property (ImGearARTHollowEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowEllipse Class : Y Property
Gets or sets the Y coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTHollowEllipse
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

ImGearARTHollowPolygon Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowPolygon Class
Represents legacy ART Hollow Polygon mark.
Object Model
ImGearARTHollowPolygon ClassIImGearRGBQuad InterfaceImGearRectangle StructureImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHollowPolygon
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTHollowPolygon
public class ImGearARTHollowPolygon : ImGearARTMark
public __gc class ImGearARTHollowPolygon : public ImGearARTMark
public ref class ImGearARTHollowPolygon : public ImGearARTMark
Example
  • C#
// Create an array of 5 points for the hollow polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the hollow polygon.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow polygon with a width of 10 and highlight off.
ImGearARTHollowPolygon igARTHollowPolygon = new ImGearARTHollowPolygon(
    igPoints, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowPolygon, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the hollow polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the hollow polygon.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow polygon with a width of 10 and highlight off.
Dim igARTHollowPolygon As New ImGearARTHollowPolygon( _
 igPoints, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowPolygon, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTHollowPolygon

See Also

Reference

ImGearARTHollowPolygon Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHollowPolygon Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowPolygon Class

The following tables list the members exposed by ImGearARTHollowPolygon.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHollowPolygon Constructor | Overloaded. Initializes a new instance of the ImGearARTHollowPolygon class.
Top
Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | NumberOfPoints | Gets or sets the number of points of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTHollowPolygon Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : ImGearARTHollowPolygon Constructor
Initializes a new instance of the ImGearARTHollowPolygon class.
Overload List
Overload | Description
ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowPolygon class object.
ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,Int32,Boolean) | Initializes a new instance of the ImGearARTHollowPolygon class object.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class > ImGearARTHollowPolygon Constructor : ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
Mark's points.
Border color of the mark.
Initializes a new instance of the ImGearARTHollowPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal borderColor As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim borderColor As IImGearRGBQuad

Dim instance As New ImGearARTHollowPolygon(points, borderColor)
public ImGearARTHollowPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad borderColor
)
public: ImGearARTHollowPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* borderColor
)
public:
ImGearARTHollowPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ borderColor
)

Parameters

points
Mark's points.
borderColor
Border color of the mark.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,Int32,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class > ImGearARTHollowPolygon Constructor : ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,Int32,Boolean)
Mark's rectangle.
Border color of the mark.
Width of the mark's border.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTHollowPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal borderColor As ImGearRGBQuad, _
   ByVal borderWidth As Integer, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim points() As ImGearPoint
Dim borderColor As ImGearRGBQuad
Dim borderWidth As Integer
Dim isHighlighted As Boolean

Dim instance As New ImGearARTHollowPolygon(points, borderColor, borderWidth, isHighlighted)
public ImGearARTHollowPolygon(
   ImGearPoint[] points,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)
public: ImGearARTHollowPolygon(
   ImGearPoint[]* points,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)
public:
ImGearARTHollowPolygon(
   array<ImGearPoint>^ points,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)

Parameters

points
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTHollowPolygon Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowPolygon Class

For a list of all members of this type, see ImGearARTHollowPolygon members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTHollowPolygon Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearPoint Structure


Flip Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Flip Method


GetPoint Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : GetPoint Method
Index of the point in the mark points array.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTHollowPolygon
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point in the mark points array.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowPolygon
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Move Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


OnPointAdded Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


OnPointChanged Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


OnPointsRemoved Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


RemovePoints Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Rotate Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Rotate Method


Scale Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Scale Method


SetPoint Method (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : SetPoint Method
Index of the point in the mark points array.
The point to be set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point in the mark points array.
point
The point to be set.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTHollowPolygon Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowPolygon Class

For a list of all members of this type, see ImGearARTHollowPolygon members.

Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | NumberOfPoints | Gets or sets the number of points of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
See Also

Reference

ImGearARTHollowPolygon Class
ImageGear.ART Namespace


BorderColor Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : BorderColor Property
Gets or sets the border color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As IImGearRGBQuad

instance.BorderColor = value

value = instance.BorderColor
public IImGearRGBQuad BorderColor {get; set;}
public: __property IImGearRGBQuad* get_BorderColor();
public: __property void set_BorderColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ BorderColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearRGBQuad Structure


BorderWidth Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : BorderWidth Property
Gets or sets the border width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Integer
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
public int BorderWidth {get; set;}
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
public:
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Bounds Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearRectangle Structure


Highlight Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


NumberOfPoints Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : NumberOfPoints Property
Gets or sets the number of points of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Points Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTHollowPolygon.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


SelectionType Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Type Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTHollowPolygon)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


Visible Property (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTHollowPolygon
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%% $$Events$$

ImGearARTHollowPolygon Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowPolygon Class

For a list of all members of this type, see ImGearARTHollowPolygon members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTHollowPolygon Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTHollowPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


PointChanged Event (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTHollowPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


PointsRemoved Event (ImGearARTHollowPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowPolygon Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTHollowPolygon
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

ImGearARTHollowRectangle Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowRectangle Class
Represents legacy ART Hollow Rectangle mark.
Object Model
ImGearARTHollowRectangle ClassIImGearRGBQuad InterfaceImGearRectangle StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHollowRectangle
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTHollowRectangle
public class ImGearARTHollowRectangle : ImGearARTMark
public __gc class ImGearARTHollowRectangle : public ImGearARTMark
public ref class ImGearARTHollowRectangle : public ImGearARTMark
Example
  • C#
// Setup rectangle for the hollow rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hollow rectangle.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow rectangle with a border of 10 and highlight off.
ImGearARTHollowRectangle igARTHollowRectangle = new ImGearARTHollowRectangle(
    igRectangle, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowRectangle, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the hollow rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hollow rectangle.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow rectangle with a border of 10 and highlight off.
Dim igARTHollowRectangle As New ImGearARTHollowRectangle( _
 igRectangle, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowRectangle, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTHollowRectangle

See Also

Reference

ImGearARTHollowRectangle Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHollowRectangle Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowRectangle Class

The following tables list the members exposed by ImGearARTHollowRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHollowRectangle Constructor | Overloaded. Initializes a new instance of the ImGearARTHollowRectangle class.
Top
Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHollowRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : ImGearARTHollowRectangle Constructor
Initializes a new instance of the ImGearARTHollowRectangle class.
Overload List
Overload | Description
ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowRectangle class object.
ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,Int32,Boolean) | Initializes a new instance of the ImGearARTHollowRectangle class object.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class > ImGearARTHollowRectangle Constructor : ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad)
Mark's rectangle.
Border color of the mark.
Initializes a new instance of the ImGearARTHollowRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As ImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As ImGearRGBQuad

Dim instance As New ImGearARTHollowRectangle(rect, borderColor)
public ImGearARTHollowRectangle(
   IImGearRectangle rect,
   ImGearRGBQuad borderColor
)
public: ImGearARTHollowRectangle(
   IImGearRectangle* rect,
   ImGearRGBQuad borderColor
)
public:
ImGearARTHollowRectangle(
   IImGearRectangle^ rect,
   ImGearRGBQuad borderColor
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,Int32,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class > ImGearARTHollowRectangle Constructor : ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,Int32,Boolean)
Mark's rectangle.
Border color of the mark.
Width of the mark's border.
Specifies whether the mark is highlighted or not.
Initializes a new instance of the ImGearARTHollowRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As ImGearRGBQuad, _
   ByVal borderWidth As Integer, _
   ByVal isHighlighted As Boolean _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As ImGearRGBQuad
Dim borderWidth As Integer
Dim isHighlighted As Boolean

Dim instance As New ImGearARTHollowRectangle(rect, borderColor, borderWidth, isHighlighted)
public ImGearARTHollowRectangle(
   IImGearRectangle rect,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)
public: ImGearARTHollowRectangle(
   IImGearRectangle* rect,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)
public:
ImGearARTHollowRectangle(
   IImGearRectangle^ rect,
   ImGearRGBQuad borderColor,
   int borderWidth,
   bool isHighlighted
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not.

Return Value

The new instance of ImGearARTHollowRectangle class object.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTHollowRectangle Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowRectangle Class

For a list of all members of this type, see ImGearARTHollowRectangle members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHollowRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTHollowRectangle Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowRectangle Class

For a list of all members of this type, see ImGearARTHollowRectangle members.

See Also

Reference

ImGearARTHollowRectangle Class
ImageGear.ART Namespace


Flip Method (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTHollowRectangle
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Flip Method


GetRenderBounds Method (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowRectangle
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Move Method (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTHollowRectangle
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Rotate Method (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTHollowRectangle
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Rotate Method


Scale Method (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTHollowRectangle
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTHollowRectangle Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHollowRectangle Class

For a list of all members of this type, see ImGearARTHollowRectangle members.

Public Properties
 | Name | Description
Public Property | BorderColor | Gets or sets the border color of the mark.
Public Property | BorderWidth | Gets or sets the border width of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Height | Gets or sets the height of the mark.
Public Property | Highlight | Gets or sets a value indicating whether the mark is highlighted.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
See Also

Reference

ImGearARTHollowRectangle Class
ImageGear.ART Namespace


BorderColor Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : BorderColor Property
Gets or sets the border color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As IImGearRGBQuad

instance.BorderColor = value

value = instance.BorderColor
public IImGearRGBQuad BorderColor {get; set;}
public: __property IImGearRGBQuad* get_BorderColor();
public: __property void set_BorderColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ BorderColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
ImGearRGBQuad Structure


BorderWidth Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : BorderWidth Property
Gets or sets the border width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Integer
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
public int BorderWidth {get; set;}
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
public:
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Bounds Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
ImGearRectangle Structure


Height Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Height Property
Gets or sets the height of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Highlight Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Highlight Property
Gets or sets a value indicating whether the mark is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As Boolean
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Boolean

instance.Highlight = value

value = instance.Highlight
public bool Highlight {get; set;}
public: __property bool get_Highlight();
public: __property void set_Highlight(
   bool value
);
public:
property bool Highlight {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


SelectionType Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Type Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTHollowRectangle)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Visible Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Width Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


X Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : X Property
Gets or sets the X coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


Y Property (ImGearARTHollowRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHollowRectangle Class : Y Property
Gets or sets the Y coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTHollowRectangle
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

ImGearARTHotSpot Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHotSpot Class
Represents ART Hot Spot mark.
Object Model
ImGearARTHotSpot ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTHotSpot
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTHotSpot
public class ImGearARTHotSpot : ImGearARTMark
public __gc class ImGearARTHotSpot : public ImGearARTMark
public ref class ImGearARTHotSpot : public ImGearARTMark
Example
  • C#
// Setup rectangle for the hotspot mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hotspot.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hotspot with an opacity of 75%.
ImGearARTHotSpot igARTHotSpot = new ImGearARTHotSpot(
    igRectangle, igRGBQuad, (int)(0.75 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHotSpot, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the hotspot mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hotspot.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hotspot with an opacity of 75%.
Dim igARTHotSpot As New ImGearARTHotSpot( _
 igRectangle, igRGBQuad, CInt(0.75 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHotSpot, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTHotSpot

See Also

Reference

ImGearARTHotSpot Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTHotSpot Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHotSpot Class

The following tables list the members exposed by ImGearARTHotSpot.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTHotSpot Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHotSpot Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHotSpot Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : ImGearARTHotSpot Constructor
Overload List
Overload | Description
ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTHotSpot class object.
ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,Int32) | Initializes a new instance of the ImGearARTHotSpot class object.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class > ImGearARTHotSpot Constructor : ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad)
Rectangle of the mark.
Fill color of the mark.
Initializes a new instance of the ImGearARTHotSpot class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTHotSpot(rect, fillColor)
public ImGearARTHotSpot(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTHotSpot(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTHotSpot(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
Rectangle of the mark.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class > ImGearARTHotSpot Constructor : ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,Int32)
Rectangle of the mark.
Fill color of the mark.
Opacity of the mark.
Initializes a new instance of the ImGearARTHotSpot class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal opacity As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad
Dim opacity As Integer

Dim instance As New ImGearARTHotSpot(rect, fillColor, opacity)
public ImGearARTHotSpot(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   int opacity
)
public: ImGearARTHotSpot(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor,
   int opacity
)
public:
ImGearARTHotSpot(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor,
   int opacity
)

Parameters

rect
Rectangle of the mark.
fillColor
Fill color of the mark.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTHotSpot Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHotSpot Class

For a list of all members of this type, see ImGearARTHotSpot members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTHotSpot Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTHotSpot Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHotSpot Class

For a list of all members of this type, see ImGearARTHotSpot members.

See Also

Reference

ImGearARTHotSpot Class
ImageGear.ART Namespace


Flip Method (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTHotSpot
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Flip Method


GetRenderBounds Method (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTHotSpot
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Move Method (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTHotSpot
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Rotate Method (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTHotSpot
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Rotate Method


Scale Method (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTHotSpot
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTHotSpot Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHotSpot Class

For a list of all members of this type, see ImGearARTHotSpot members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTHotSpot Class
ImageGear.ART Namespace


Bounds Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTHotSpot
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
ImGearRectangle Structure


FillColor Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTHotSpot
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
ImGearRGBQuad Structure


Height Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Opacity Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 255.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


SelectionType Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTHotSpot
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Type Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTHotSpot
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Width Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


X Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


Y Property (ImGearARTHotSpot)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTHotSpot Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTHotSpot
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

ImGearARTImage Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImage Class
Represents ART Image mark.
Object Model
ImGearARTImage ClassImGearARTBorder ClassImGearRectangle StructureImGearRectangle StructureImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTImage
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTImage
public class ImGearARTImage : ImGearARTMark
public __gc class ImGearARTImage : public ImGearARTMark
public ref class ImGearARTImage : public ImGearARTMark
Example
  • C#
// Setup rectangle for the image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Create image mark using a file "PNGTEST.png".
ImGearARTImage igARTImage = new ImGearARTImage(
    igRectangle, "PNGTEST.png"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImage, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Create image mark using a file "PNGTEST.png".
Dim igARTImage As New ImGearARTImage( _
 igRectangle, "PNGTEST.png")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImage, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTImage

See Also

Reference

ImGearARTImage Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTImage Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImage Class

The following tables list the members exposed by ImGearARTImage.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTImage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of the image.
Public Property | AspectRatio | Gets or sets the aspect ratio of the image.
Public Property | Border | Gets or sets the mark border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the file name of the image reference.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the rectangle.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | Page | Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. This method clones ImGearARTImage class object.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | GetViewBkColor | The method gets the current background color of the view.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImage Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTImage Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : ImGearARTImage Constructor
Overload List
Overload | Description
ImGearARTImage Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImage class object.
ImGearARTImage Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTImage class object.
ImGearARTImage Constructor(IImGearRectangle,ImGearPage) | Initializes a new instance of the ImGearARTImage class object.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle)
Image rectangle.
Initializes a new instance of the ImGearARTImage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim rect As IImGearRectangle

Dim instance As New ImGearARTImage(rect)
public ImGearARTImage(
   IImGearRectangle rect
)
public: ImGearARTImage(
   IImGearRectangle* rect
)
public:
ImGearARTImage(
   IImGearRectangle^ rect
)

Parameters

rect
Image rectangle.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle,String)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle,String)
Image rectangle.
File name of the image.
Initializes a new instance of the ImGearARTImage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fileName As String _
)
'Usage

Dim rect As IImGearRectangle
Dim fileName As String

Dim instance As New ImGearARTImage(rect, fileName)
public ImGearARTImage(
   IImGearRectangle rect,
   string fileName
)
public: ImGearARTImage(
   IImGearRectangle* rect,
   string* fileName
)
public:
ImGearARTImage(
   IImGearRectangle^ rect,
   String^ fileName
)

Parameters

rect
Image rectangle.
fileName
File name of the image.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle,ImGearPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle,ImGearPage)
The image rectangle.
The page to create a mark from.
Initializes a new instance of the ImGearARTImage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal page As ImGearPage _
)
'Usage

Dim rect As IImGearRectangle
Dim page As ImGearPage

Dim instance As New ImGearARTImage(rect, page)
public ImGearARTImage(
   IImGearRectangle rect,
   ImGearPage page
)
public: ImGearARTImage(
   IImGearRectangle* rect,
   ImGearPage* page
)
public:
ImGearARTImage(
   IImGearRectangle^ rect,
   ImGearPage^ page
)

Parameters

rect
The image rectangle.
page
The page to create a mark from.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List
ImGearPage Class
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTImage Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImage Class

For a list of all members of this type, see ImGearARTImage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. This method clones ImGearARTImage class object.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | GetViewBkColor | The method gets the current background color of the view.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImage Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTImage Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImage Class

For a list of all members of this type, see ImGearARTImage members.

See Also

Reference

ImGearARTImage Class
ImageGear.ART Namespace


Clone Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Clone Method
This method clones ImGearARTImage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As ImGearARTImage
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

The new instance of ImGearARTImage class.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Flip Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTImage
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Flip Method


GetRenderBounds Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTImage
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


GetViewBkColor Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : GetViewBkColor Method
The method gets the current background color of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetViewBkColor() As Integer
'Usage

Dim instance As ImGearARTImage
Dim value As Integer

value = instance.GetViewBkColor()
public int GetViewBkColor()
public: int GetViewBkColor();
public:
int GetViewBkColor();

Return Value

Integer value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Move Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTImage
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Rotate Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTImage
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Rotate Method


Scale Method (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTImage
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTImage Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImage Class

For a list of all members of this type, see ImGearARTImage members.

Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of the image.
Public Property | AspectRatio | Gets or sets the aspect ratio of the image.
Public Property | Border | Gets or sets the mark border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the file name of the image reference.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the rectangle.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | Page | Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
See Also

Reference

ImGearARTImage Class
ImageGear.ART Namespace


AlignmentH Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : AlignmentH Property
Gets or sets the horizontal alignment of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
public ImGearAlignmentHModes AlignmentH {get; set;}
public: __property ImGearAlignmentHModes get_AlignmentH();
public: __property void set_AlignmentH(
   ImGearAlignmentHModes value
);
public:
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
Remarks
The default value is ImGearAlignmentHModes.LEFT.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : AlignmentV Property
Gets or sets the vertical alignment of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
public ImGearAlignmentVModes AlignmentV {get; set;}
public: __property ImGearAlignmentVModes get_AlignmentV();
public: __property void set_AlignmentV(
   ImGearAlignmentVModes value
);
public:
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
Remarks
The default value is ImGearAlignmentVModes.TOP.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearAlignmentVModes Enumeration


AspectRatio Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : AspectRatio Property
Gets or sets the aspect ratio of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectRatio As Double
'Usage

Dim instance As ImGearARTImage
Dim value As Double

instance.AspectRatio = value

value = instance.AspectRatio
public double AspectRatio {get; set;}
public: __property double get_AspectRatio();
public: __property void set_AspectRatio(
   double value
);
public:
property double AspectRatio {
   double get();
   void set (    double value);
}

Property Value

Any positive double number.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Border Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Border Property
Gets or sets the mark border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearARTBorder Class


Bounds Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearRectangle Structure


FileName Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : FileName Property
Gets or sets the file name of the image reference.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As ImGearARTImage
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


FitMode Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : FitMode Property
Gets or sets the fitting mode of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FitMode As ImGearFitModes
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearFitModes

instance.FitMode = value

value = instance.FitMode
public ImGearFitModes FitMode {get; set;}
public: __property ImGearFitModes get_FitMode();
public: __property void set_FitMode(
   ImGearFitModes value
);
public:
property ImGearFitModes FitMode {
   ImGearFitModes get();
   void set (    ImGearFitModes value);
}

Property Value

ImageGear.Display.ImGearFitModes enumeration value.
Remarks
The default value is ImGearFitModes.FIT_TO_DEVICE.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearFitModes Enumeration


Height Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Height Property
Gets or sets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTImage
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Orientation Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Orientation Property
Gets or sets the image orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearOrientationModes Enumeration


Page Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Page Property
Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearPage
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearPage

instance.Page = value

value = instance.Page
public ImGearPage Page {get; set;}
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearPage Class


SelectionType Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Type Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTImage
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTImage
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Width Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Width Property
Gets or sets the width of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTImage
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


X Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : X Property
Gets or sets the X coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTImage
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


Y Property (ImGearARTImage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImage Class : Y Property
Gets or sets the Y coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTImage
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

ImGearARTImageEmb Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageEmb Class
Represents legacy ART Embedded Image mark.
Object Model
ImGearARTImageEmb ClassImGearRectangle StructureImGearRectangle StructureImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTImageEmb
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTImageEmb
public class ImGearARTImageEmb : ImGearARTMark
public __gc class ImGearARTImageEmb : public ImGearARTMark
public ref class ImGearARTImageEmb : public ImGearARTMark
Example
  • C#
// Setup rectangle for the embedded image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Load an image to embed
ImGearPage igPageEmbedded;
using (FileStream localFile = new FileStream("photo.jpg", FileMode.Open))
{
    igPageEmbedded = ImGearFileFormats.LoadPage(localFile, 0);
}
// Create embedded image mark using igPageEmbedded.
ImGearARTImageEmb igARTImageEmb = new ImGearARTImageEmb(
    igRectangle, igPageEmbedded
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageEmb, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the embedded image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Load an image to embed
Dim igPageEmbedded As ImGearPage
Using localFile As New FileStream("photo.jpg", FileMode.Open)
    igPageEmbedded = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Create embedded image mark using igPageEmbedded.
Dim igARTImageEmb As New ImGearARTImageEmb( _
 igRectangle, igPageEmbedded)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageEmb, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTImageEmb

See Also

Reference

ImGearARTImageEmb Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTImageEmb Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageEmb Class

The following tables list the members exposed by ImGearARTImageEmb.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTImageEmb Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of image.
Public Property | AspectRatio | Gets or sets the aspect ratio.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the image.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | Page | Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImageEmb Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTImageEmb Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : ImGearARTImageEmb Constructor
Overload List
Overload | Description
ImGearARTImageEmb Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImageEmb class object.
ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage) | Initializes a new instance of the ImGearARTImageEmb class object.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

ImGearARTImageEmb Constructor(IImGearRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class > ImGearARTImageEmb Constructor : ImGearARTImageEmb Constructor(IImGearRectangle)
The image rectangle.
Initializes a new instance of the ImGearARTImageEmb class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim rect As IImGearRectangle

Dim instance As New ImGearARTImageEmb(rect)
public ImGearARTImageEmb(
   IImGearRectangle rect
)
public: ImGearARTImageEmb(
   IImGearRectangle* rect
)
public:
ImGearARTImageEmb(
   IImGearRectangle^ rect
)

Parameters

rect
The image rectangle.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class > ImGearARTImageEmb Constructor : ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage)
The image rectangle.
The page to create a mark from.
Initializes a new instance of the ImGearARTImageEmb class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal page As ImGearPage _
)
'Usage

Dim rect As IImGearRectangle
Dim page As ImGearPage

Dim instance As New ImGearARTImageEmb(rect, page)
public ImGearARTImageEmb(
   IImGearRectangle rect,
   ImGearPage page
)
public: ImGearARTImageEmb(
   IImGearRectangle* rect,
   ImGearPage* page
)
public:
ImGearARTImageEmb(
   IImGearRectangle^ rect,
   ImGearPage^ page
)

Parameters

rect
The image rectangle.
page
The page to create a mark from.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Overload List
ImGearPage Class
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTImageEmb Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageEmb Class

For a list of all members of this type, see ImGearARTImageEmb members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImageEmb Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTImageEmb Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageEmb Class

For a list of all members of this type, see ImGearARTImageEmb members.

See Also

Reference

ImGearARTImageEmb Class
ImageGear.ART Namespace


Flip Method (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTImageEmb
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Flip Method


GetRenderBounds Method (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTImageEmb
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Move Method (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTImageEmb
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Rotate Method (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTImageEmb
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Rotate Method


Scale Method (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTImageEmb
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTImageEmb Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageEmb Class

For a list of all members of this type, see ImGearARTImageEmb members.

Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of image.
Public Property | AspectRatio | Gets or sets the aspect ratio.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the image.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | Page | Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
See Also

Reference

ImGearARTImageEmb Class
ImageGear.ART Namespace


AlignmentH Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : AlignmentH Property
Gets or sets the horizontal alignment of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
public ImGearAlignmentHModes AlignmentH {get; set;}
public: __property ImGearAlignmentHModes get_AlignmentH();
public: __property void set_AlignmentH(
   ImGearAlignmentHModes value
);
public:
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : AlignmentV Property
Gets or sets the vertical alignment of image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
public ImGearAlignmentVModes AlignmentV {get; set;}
public: __property ImGearAlignmentVModes get_AlignmentV();
public: __property void set_AlignmentV(
   ImGearAlignmentVModes value
);
public:
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearAlignmentVModes Enumeration


AspectRatio Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : AspectRatio Property
Gets or sets the aspect ratio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectRatio As Double
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Double

instance.AspectRatio = value

value = instance.AspectRatio
public double AspectRatio {get; set;}
public: __property double get_AspectRatio();
public: __property void set_AspectRatio(
   double value
);
public:
property double AspectRatio {
   double get();
   void set (    double value);
}

Property Value

Any positive double value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Bounds Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearRectangle Structure


FitMode Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : FitMode Property
Gets or sets the fitting mode of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FitMode As ImGearFitModes
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearFitModes

instance.FitMode = value

value = instance.FitMode
public ImGearFitModes FitMode {get; set;}
public: __property ImGearFitModes get_FitMode();
public: __property void set_FitMode(
   ImGearFitModes value
);
public:
property ImGearFitModes FitMode {
   ImGearFitModes get();
   void set (    ImGearFitModes value);
}

Property Value

ImageGear.Display.ImGearFitModes enumeration value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearFitModes Enumeration


Height Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Height Property
Gets or sets the height of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Orientation Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Orientation Property
Gets or sets the image orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearOrientationModes Enumeration


Page Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Page Property
Gets or sets the ImageGear.Core.ImGearPage class object that contains the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearPage
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearPage

instance.Page = value

value = instance.Page
public ImGearPage Page {get; set;}
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearPage Class


SelectionType Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Type Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTImageEmb
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTImageEmb)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Visible Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Width Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Width Property
Gets or sets the width of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


X Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : X Property
Gets or sets the X coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


Y Property (ImGearARTImageEmb)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageEmb Class : Y Property
Gets or sets the Y coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTImageEmb
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

ImGearARTImageRef Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageRef Class
Represents legacy ART Image Reference mark.
Object Model
ImGearARTImageRef ClassImGearRectangle StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTImageRef
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTImageRef
public class ImGearARTImageRef : ImGearARTMark
public __gc class ImGearARTImageRef : public ImGearARTMark
public ref class ImGearARTImageRef : public ImGearARTMark
Example
  • C#
// Setup rectangle for the reference image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Create reference image mark using a file "PNGTEST.png".
ImGearARTImageRef igARTImageRef = new ImGearARTImageRef(
    igRectangle, "PNGTEST.png"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageRef, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the reference image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Create reference image mark using a file "PNGTEST.png".
Dim igARTImageRef As New ImGearARTImageRef( _
 igRectangle, "PNGTEST.png")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageRef, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTImageRef

See Also

Reference

ImGearARTImageRef Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTImageRef Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageRef Class

The following tables list the members exposed by ImGearARTImageRef.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTImageRef Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of the image.
Public Property | AspectRatio | Gets or sets the aspect ratio of the image.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the file name of the image reference.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the image.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImageRef Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTImageRef Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : ImGearARTImageRef Constructor
Overload List
Overload | Description
ImGearARTImageRef Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImageRef class object.
ImGearARTImageRef Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTImageRef class object.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

ImGearARTImageRef Constructor(IImGearRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class > ImGearARTImageRef Constructor : ImGearARTImageRef Constructor(IImGearRectangle)
Image rectangle.
Initializes a new instance of the ImGearARTImageRef class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim rect As IImGearRectangle

Dim instance As New ImGearARTImageRef(rect)
public ImGearARTImageRef(
   IImGearRectangle rect
)
public: ImGearARTImageRef(
   IImGearRectangle* rect
)
public:
ImGearARTImageRef(
   IImGearRectangle^ rect
)

Parameters

rect
Image rectangle.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTImageRef Constructor(IImGearRectangle,String)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class > ImGearARTImageRef Constructor : ImGearARTImageRef Constructor(IImGearRectangle,String)
The image rectangle.
The file name of the image reference.
Initializes a new instance of the ImGearARTImageRef class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fileName As String _
)
'Usage

Dim rect As IImGearRectangle
Dim fileName As String

Dim instance As New ImGearARTImageRef(rect, fileName)
public ImGearARTImageRef(
   IImGearRectangle rect,
   string fileName
)
public: ImGearARTImageRef(
   IImGearRectangle* rect,
   string* fileName
)
public:
ImGearARTImageRef(
   IImGearRectangle^ rect,
   String^ fileName
)

Parameters

rect
The image rectangle.
fileName
The file name of the image reference.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%% $$Methods$$

ImGearARTImageRef Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageRef Class

For a list of all members of this type, see ImGearARTImageRef members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTImageRef Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTImageRef Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageRef Class

For a list of all members of this type, see ImGearARTImageRef members.

See Also

Reference

ImGearARTImageRef Class
ImageGear.ART Namespace


Flip Method (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTImageRef
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Flip Method


GetRenderBounds Method (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTImageRef
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Move Method (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTImageRef
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Rotate Method (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTImageRef
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Rotate Method


Scale Method (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTImageRef
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTImageRef Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTImageRef Class

For a list of all members of this type, see ImGearARTImageRef members.

Public Properties
 | Name | Description
Public Property | AlignmentH | Gets or sets the horizontal alignment of the image.
Public Property | AlignmentV | Gets or sets the vertical alignment of the image.
Public Property | AspectRatio | Gets or sets the aspect ratio of the image.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FileName | Gets or sets the file name of the image reference.
Public Property | FitMode | Gets or sets the fitting mode of the image.
Public Property | Height | Gets or sets the height of the image.
Public Property | Orientation | Gets or sets the image orientation.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the image.
Public Property | X | Gets or sets the X coordinate of the top-left point of the image.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the image.
Top
See Also

Reference

ImGearARTImageRef Class
ImageGear.ART Namespace


AlignmentH Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : AlignmentH Property
Gets or sets the horizontal alignment of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
public ImGearAlignmentHModes AlignmentH {get; set;}
public: __property ImGearAlignmentHModes get_AlignmentH();
public: __property void set_AlignmentH(
   ImGearAlignmentHModes value
);
public:
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : AlignmentV Property
Gets or sets the vertical alignment of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
public ImGearAlignmentVModes AlignmentV {get; set;}
public: __property ImGearAlignmentVModes get_AlignmentV();
public: __property void set_AlignmentV(
   ImGearAlignmentVModes value
);
public:
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearAlignmentVModes Enumeration


AspectRatio Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : AspectRatio Property
Gets or sets the aspect ratio of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectRatio As Double
'Usage

Dim instance As ImGearARTImageRef
Dim value As Double

instance.AspectRatio = value

value = instance.AspectRatio
public double AspectRatio {get; set;}
public: __property double get_AspectRatio();
public: __property void set_AspectRatio(
   double value
);
public:
property double AspectRatio {
   double get();
   void set (    double value);
}

Property Value

Any positive integer value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Bounds Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearRectangle Structure


FileName Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : FileName Property
Gets or sets the file name of the image reference.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As ImGearARTImageRef
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


FitMode Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : FitMode Property
Gets or sets the fitting mode of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FitMode As ImGearFitModes
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearFitModes

instance.FitMode = value

value = instance.FitMode
public ImGearFitModes FitMode {get; set;}
public: __property ImGearFitModes get_FitMode();
public: __property void set_FitMode(
   ImGearFitModes value
);
public:
property ImGearFitModes FitMode {
   ImGearFitModes get();
   void set (    ImGearFitModes value);
}

Property Value

ImageGear.Display.ImGearFitModes enumeration value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearFitModes Enumeration


Height Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Height Property
Gets or sets the height of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTImageRef
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Orientation Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Orientation Property
Gets or sets the image orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearOrientationModes Enumeration


SelectionType Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Type Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTImageRef
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTImageRef)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTImageRef
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Visible Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTImageRef
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Width Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Width Property
Gets or sets the width of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTImageRef
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


X Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : X Property
Gets or sets the X coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTImageRef
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


Y Property (ImGearARTImageRef)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTImageRef Class : Y Property
Gets or sets the Y coordinate of the top-left point of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTImageRef
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

ImGearARTLine Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLine Class
Represents ART Line mark.
Object Model
ImGearARTLine ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTLine
   Inherits ImGearARTMark
   Implements IImGearARTLine
'Usage

Dim instance As ImGearARTLine
public class ImGearARTLine : ImGearARTMark, IImGearARTLine
public __gc class ImGearARTLine : public ImGearARTMark, IImGearARTLine
public ref class ImGearARTLine : public ImGearARTMark, IImGearARTLine
Example
  • C#
// Setup start and endpoint for the line.
ImGearPoint igPointStart = new ImGearPoint(0, 0);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for the line.
ImGearRGBQuad igRGBQuadLine = new ImGearRGBQuad(0, 255, 0);
// Setup color for the heads.
ImGearRGBQuad igRGBQuadHead = new ImGearRGBQuad(0, 0, 200);
// Create the line annotation with solid pen style, a width of 4, 25% opacity,
//  open head type at the start point with a 30 degree angle and length of 20,
//  solid head type at the end point with a 30 degree angle and length of 20.
ImGearARTLine igARTLine = new ImGearARTLine(
    igPointStart, igPointEnd, igRGBQuadLine, ImGearARTPenStyle.SOLID, 4,
    (int)(0.25 * 255), igRGBQuadHead, ImGearARTLineHeadType.OPEN, 30, 20,
    ImGearARTLineHeadType.POINTER_SOLID, 30, 20
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the line.
Dim igPointStart As New ImGearPoint(0, 0)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for the line.
Dim igRGBQuadLine As New ImGearRGBQuad(0, 255, 0)
' Setup color for the heads.
Dim igRGBQuadHead As New ImGearRGBQuad(0, 0, 200)
' Create the line annotation with solid pen style, a width of 4, 25% opacity,
'  open head type at the start point with a 30 degree angle and length of 20,
'  solid head type at the end point with a 30 degree angle and length of 20.
Dim igARTLine As New ImGearARTLine( _
 igPointStart, igPointEnd, igRGBQuadLine, ImGearARTPenStyle.SOLID, 4, _
 CInt(0.25 * 255), igRGBQuadHead, ImGearARTLineHeadType.OPEN, 30, 20, _
 ImGearARTLineHeadType.POINTER_SOLID, 30, 20)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTLine

See Also

Reference

ImGearARTLine Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTLine Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLine Class

The following tables list the members exposed by ImGearARTLine.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTLine Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the line color.
Public Property | EndHeadAngle | Gets or sets the angle of the line's end head.
Public Property | EndHeadLength | Gets or sets the length of the line's end head.
Public Property | EndHeadType | Gets or sets the type of the line's end head.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | HeadFillColor | Gets or sets the fill color of the line's head.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlihgter.
Public Property | Opacity | Gets or sets the line opacity.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartHeadAngle | Gets or sets the angle of the line's start head.
Public Property | StartHeadLength | Gets or sets the length of the line's start head.
Public Property | StartHeadType | Gets or sets the type of the line's start head.
Public Property | StartPoint | Gets or sets the start point of the line.
Public Property | Style | Gets or sets the style of the line.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the line width.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTLine Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTLine Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : ImGearARTLine Constructor
Overload List
Overload | Description
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTLine class object.
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32) | Initializes a new instance of the ImGearARTLine class object.
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32) | Initializes a new instance of the ImGearARTLine class object.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
The start point of the line.
The end point of the line.
The color of the line.
Initializes a new instance of the ImGearARTLine class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTLine(startPoint, endPoint, color)
public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)
public: ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color
)
public:
ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)
The start point of the line.
The end point of the line.
The color of the line.
The line style.
The width of the line.
Opacity of the line.
Initializes a new instance of the ImGearARTLine class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer

Dim instance As New ImGearARTLine(startPoint, endPoint, color, style, width, opacity)
public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity
)
public: ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity
)
public:
ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32)
The start point of the line.
The end point of the line.
The color of the line.
The line style.
The width of the line.
Opacity of the line.
Fill color of the line's head.
The type of the line's start head.
The angle of the line's start head.
The length of the line's start head.
The type of the line's end head.
The angle of the line's end head.
The length of the line's end head.
Initializes a new instance of the ImGearARTLine class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal headFillColor As IImGearRGBQuad, _
   ByVal startHeadType As ImGearARTLineHeadType, _
   ByVal startHeadAngle As Integer, _
   ByVal startHeadLength As Integer, _
   ByVal endHeadType As ImGearARTLineHeadType, _
   ByVal endHeadAngle As Integer, _
   ByVal endHeadLength As Integer _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim headFillColor As IImGearRGBQuad
Dim startHeadType As ImGearARTLineHeadType
Dim startHeadAngle As Integer
Dim startHeadLength As Integer
Dim endHeadType As ImGearARTLineHeadType
Dim endHeadAngle As Integer
Dim endHeadLength As Integer

Dim instance As New ImGearARTLine(startPoint, endPoint, color, style, width, opacity, headFillColor, startHeadType, startHeadAngle, startHeadLength, endHeadType, endHeadAngle, endHeadLength)
public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   IImGearRGBQuad headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)
public: ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   IImGearRGBQuad* headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)
public:
ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   IImGearRGBQuad^ headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line.
headFillColor
Fill color of the line's head.
startHeadType
The type of the line's start head.
startHeadAngle
The angle of the line's start head.
startHeadLength
The length of the line's start head.
endHeadType
The type of the line's end head.
endHeadAngle
The angle of the line's end head.
endHeadLength
The length of the line's end head.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration
ImGearARTLineHeadType Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTLine Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLine Class

For a list of all members of this type, see ImGearARTLine members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTLine Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTLine Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLine Class

For a list of all members of this type, see ImGearARTLine members.

See Also

Reference

ImGearARTLine Class
ImageGear.ART Namespace


Flip Method (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTLine
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Flip Method


GetRenderBounds Method (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTLine
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


Move Method (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTLine
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


Rotate Method (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTLine
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Rotate Method


Scale Method (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTLine
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTLine Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLine Class

For a list of all members of this type, see ImGearARTLine members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the line color.
Public Property | EndHeadAngle | Gets or sets the angle of the line's end head.
Public Property | EndHeadLength | Gets or sets the length of the line's end head.
Public Property | EndHeadType | Gets or sets the type of the line's end head.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | HeadFillColor | Gets or sets the fill color of the line's head.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlihgter.
Public Property | Opacity | Gets or sets the line opacity.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartHeadAngle | Gets or sets the angle of the line's start head.
Public Property | StartHeadLength | Gets or sets the length of the line's start head.
Public Property | StartHeadType | Gets or sets the type of the line's start head.
Public Property | StartPoint | Gets or sets the start point of the line.
Public Property | Style | Gets or sets the style of the line.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the line width.
Top
See Also

Reference

ImGearARTLine Class
ImageGear.ART Namespace


Bounds Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearRectangle Structure


CapStyle Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Color Property
Gets or sets the line color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTLine
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearRGBQuad Structure


EndHeadAngle Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : EndHeadAngle Property
Gets or sets the angle of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadAngle As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.EndHeadAngle = value

value = instance.EndHeadAngle
public int EndHeadAngle {get; set;}
public: __property int get_EndHeadAngle();
public: __property void set_EndHeadAngle(
   int value
);
public:
property int EndHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


EndHeadLength Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : EndHeadLength Property
Gets or sets the length of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadLength As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.EndHeadLength = value

value = instance.EndHeadLength
public int EndHeadLength {get; set;}
public: __property int get_EndHeadLength();
public: __property void set_EndHeadLength(
   int value
);
public:
property int EndHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


EndHeadType Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : EndHeadType Property
Gets or sets the type of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadType As ImGearARTLineHeadType
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTLineHeadType

instance.EndHeadType = value

value = instance.EndHeadType
public ImGearARTLineHeadType EndHeadType {get; set;}
public: __property ImGearARTLineHeadType get_EndHeadType();
public: __property void set_EndHeadType(
   ImGearARTLineHeadType value
);
public:
property ImGearARTLineHeadType EndHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearARTLineHeadType Enumeration


EndPoint Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : EndPoint Property
Gets or sets the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoint As ImGearPoint
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
public ImGearPoint EndPoint {get; set;}
public: __property ImGearPoint get_EndPoint();
public: __property void set_EndPoint(
   ImGearPoint value
);
public:
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearPoint Structure


HeadFillColor Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : HeadFillColor Property
Gets or sets the fill color of the line's head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadFillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTLine
Dim value As IImGearRGBQuad

instance.HeadFillColor = value

value = instance.HeadFillColor
public IImGearRGBQuad HeadFillColor {get; set;}
public: __property IImGearRGBQuad* get_HeadFillColor();
public: __property void set_HeadFillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ HeadFillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearRGBQuad Structure


IsHighlighter Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlihgter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHighlighter As Boolean
'Usage

Dim instance As ImGearARTLine
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
public bool IsHighlighter {get; set;}
public: __property bool get_IsHighlighter();
public: __property void set_IsHighlighter(
   bool value
);
public:
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


Opacity Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Opacity Property
Gets or sets the line opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 255.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


SelectionPoints Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTLine
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


SelectionType Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


StartHeadAngle Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : StartHeadAngle Property
Gets or sets the angle of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadAngle As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.StartHeadAngle = value

value = instance.StartHeadAngle
public int StartHeadAngle {get; set;}
public: __property int get_StartHeadAngle();
public: __property void set_StartHeadAngle(
   int value
);
public:
property int StartHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


StartHeadLength Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : StartHeadLength Property
Gets or sets the length of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadLength As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.StartHeadLength = value

value = instance.StartHeadLength
public int StartHeadLength {get; set;}
public: __property int get_StartHeadLength();
public: __property void set_StartHeadLength(
   int value
);
public:
property int StartHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


StartHeadType Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : StartHeadType Property
Gets or sets the type of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadType As ImGearARTLineHeadType
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTLineHeadType

instance.StartHeadType = value

value = instance.StartHeadType
public ImGearARTLineHeadType StartHeadType {get; set;}
public: __property ImGearARTLineHeadType get_StartHeadType();
public: __property void set_StartHeadType(
   ImGearARTLineHeadType value
);
public:
property ImGearARTLineHeadType StartHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearARTLineHeadType Enumeration


StartPoint Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : StartPoint Property
Gets or sets the start point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPoint As ImGearPoint
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
public ImGearPoint StartPoint {get; set;}
public: __property ImGearPoint get_StartPoint();
public: __property void set_StartPoint(
   ImGearPoint value
);
public:
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearPoint Structure


Style Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Style Property
Gets or sets the style of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearARTPenStyle Enumeration


Type Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTLine
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTLine
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


Width Property (ImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLine Class : Width Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTLine
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

ImGearARTLineMarkStat Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLineMarkStat Class
Represents statistics information about the linear annotation marks.
Object Model
ImGearARTLineMarkStat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTLineMarkStat
   Inherits ImGearARTMarkStat
'Usage

Dim instance As ImGearARTLineMarkStat
public class ImGearARTLineMarkStat : ImGearARTMarkStat
public __gc class ImGearARTLineMarkStat : public ImGearARTMarkStat
public ref class ImGearARTLineMarkStat : public ImGearARTMarkStat
Remarks
The information is: length of the ART mark.

An instance of the ImGearARTLineMarkStat class is always created for the specified mark object and should not be used after destroying that mark object.

Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTMarkStat
ImageGear.ART.ImGearARTLineMarkStat

See Also

Reference

ImGearARTLineMarkStat Members
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Members$$

ImGearARTLineMarkStat Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLineMarkStat Class

The following tables list the members exposed by ImGearARTLineMarkStat.

Public Properties
 | Name | Description
Public Property | Length | Gets the total length of the line mark.
Top
See Also

Reference

ImGearARTLineMarkStat Class
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Properties$$

ImGearARTLineMarkStat Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLineMarkStat Class

For a list of all members of this type, see ImGearARTLineMarkStat members.

Public Properties
 | Name | Description
Public Property | Length | Gets the total length of the line mark.
Top
See Also

Reference

ImGearARTLineMarkStat Class
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTPointMarkStat Class


Length Property (ImGearARTLineMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLineMarkStat Class : Length Property
Gets the total length of the line mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Double
'Usage

Dim instance As ImGearARTLineMarkStat
Dim value As Double

value = instance.Length
public double Length {get;}
public: __property double get_Length();
public:
property double Length {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTLineMarkStat Class
ImGearARTLineMarkStat Members


%%PageItemTitle%%

ImGearARTMark Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMark Class
Provides the abstract base class for all annotation marks.
Object Model
ImGearARTMark ClassImGearARTAccessController ClassImGearRectangle StructureImGearARTMark ClassImGearRectangle StructureImGearRectangle StructureImGearARTGroup ClassImGearARTMark ClassImGearARTSecureObjectData ClassImGearARTMarkStatistics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTMark
   Inherits ImGearARTSelection
'Usage

Dim instance As ImGearARTMark
public abstract class ImGearARTMark : ImGearARTSelection
public __gc abstract class ImGearARTMark : public ImGearARTSelection
public ref class ImGearARTMark abstract : public ImGearARTSelection
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTArrow
ImageGear.ART.ImGearARTAudio
ImageGear.ART.ImGearARTButton
ImageGear.ART.ImGearARTCurve
ImageGear.ART.ImGearARTCustomMark
ImageGear.ART.ImGearARTEllipse
ImageGear.ART.ImGearARTEncryption
ImageGear.ART.ImGearARTFilledEllipse
ImageGear.ART.ImGearARTFilledPolygon
ImageGear.ART.ImGearARTFilledRectangle
ImageGear.ART.ImGearARTFreeLine
ImageGear.ART.ImGearARTHighlighter
ImageGear.ART.ImGearARTHollowEllipse
ImageGear.ART.ImGearARTHollowPolygon
ImageGear.ART.ImGearARTHollowRectangle
ImageGear.ART.ImGearARTHotSpot
ImageGear.ART.ImGearARTImage
ImageGear.ART.ImGearARTImageEmb
ImageGear.ART.ImGearARTImageRef
ImageGear.ART.ImGearARTLine
ImageGear.ART.ImGearARTNote
ImageGear.ART.ImGearARTPinUpText
ImageGear.ART.ImGearARTPoint
ImageGear.ART.ImGearARTPolygon
ImageGear.ART.ImGearARTPolyline
ImageGear.ART.ImGearARTPolyRuler
ImageGear.ART.ImGearARTPopupText
ImageGear.ART.ImGearARTProtractor
ImageGear.ART.ImGearARTRectangle
ImageGear.ART.ImGearARTRedaction
ImageGear.ART.ImGearARTRichText
ImageGear.ART.ImGearARTRuler
ImageGear.ART.ImGearARTText
ImageGear.ART.ImGearARTTextCallout
ImageGear.ART.ImGearARTTextFromFile
ImageGear.ART.ImGearARTTextStamp
ImageGear.ART.ImGearARTTypedText

See Also

Reference

ImGearARTMark Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMark Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMark Class

The following tables list the members exposed by ImGearARTMark.

Public Properties
 | Name | Description
Public Property | AccessController | Gets access controller for the mark.
Public Property | Bounds | Gets the mark's bounding rectangle in abstract coordinates.
Public Property | HitTestBounds | Gets the mark's boundling rectangle used for hit test.
Public Property | Id | Gets the mark's id.
Public Property | ParentGroup | Gets the reference to the parent group.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | Statistics | Gets an object representing specific statistics information about the mark.
Public Property | Type | Gets the mark's type.
Public Property | UserData | Gets or sets the user data specified for the mark.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the mark.
Public Property | Visible | Gets or sets a value indicating whether the mark's visibility state.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates new object that is an exact copy of the current mark.
Public Method | Flip | Flips the mark around the center in vertical or horizontal direction.
static (Shared in Visual Basic) | FromLegacyMark | Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
Public Method | GetRenderBounds | Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Moves the mark by specified offset.
Public Method | Rotate | Rotates the mark around the center.
Public Method | Scale | Scales the mark in horizontal and vertical directions.
Top
Protected Methods
 | Name | Description
Protected Method | OnMarkFlipped | Occurs when the mark is flipped.
Protected Method | OnMarkMoved | Occurs when the mark is moved.
Protected Method | OnMarkRotated | Occurs when the mark is rotated.
Protected Method | OnMarkScaled | Occurs when the mark is scaled.
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | MarkFlipped | Occurs when the mark is flipped.
Public Event | MarkMoved | Occurs when the mark is moved.
Public Event | MarkRotated | Occurs when the mark is rotated.
Public Event | MarkScaled | Occurs when the mark is scaled.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTMark Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTMark Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMark Class

For a list of all members of this type, see ImGearARTMark members.

Public Methods
 | Name | Description
Public Method | Clone | Creates new object that is an exact copy of the current mark.
Public Method | Flip | Flips the mark around the center in vertical or horizontal direction.
static (Shared in Visual Basic) | FromLegacyMark | Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
Public Method | GetRenderBounds | Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Moves the mark by specified offset.
Public Method | Rotate | Rotates the mark around the center.
Public Method | Scale | Scales the mark in horizontal and vertical directions.
Top
Protected Methods
 | Name | Description
Protected Method | OnMarkFlipped | Occurs when the mark is flipped.
Protected Method | OnMarkMoved | Occurs when the mark is moved.
Protected Method | OnMarkRotated | Occurs when the mark is rotated.
Protected Method | OnMarkScaled | Occurs when the mark is scaled.
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
See Also

Reference

ImGearARTMark Class
ImageGear.ART Namespace


Clone Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Clone Method
Creates new object that is an exact copy of the current mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As ImGearARTMark
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public: virtual Object* Clone();
public:
virtual Object^ Clone();

Return Value

The copy of the current mark.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Flip Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTMark
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public virtual void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: virtual void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public:
virtual void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
Flip Method


FromLegacyMark Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : FromLegacyMark Method
Legacy ART 2.0 mark to convert.
Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromLegacyMark( _
   ByVal legacyMark As ImGearARTMark _
) As ImGearARTMark
'Usage

Dim legacyMark As ImGearARTMark
Dim value As ImGearARTMark

value = ImGearARTMark.FromLegacyMark(legacyMark)
public static ImGearARTMark FromLegacyMark(
   ImGearARTMark legacyMark
)
public: static ImGearARTMark* FromLegacyMark(
   ImGearARTMark* legacyMark
)
public:
static ImGearARTMark^ FromLegacyMark(
   ImGearARTMark^ legacyMark
)

Parameters

legacyMark
Legacy ART 2.0 mark to convert.

Return Value

Resulted ART 3.0 mark.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


GetRenderBounds Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTMark
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public virtual ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: virtual ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
)
public:
virtual ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Move Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTMark
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public abstract void Move(
   int offsetX,
   int offsetY
)
public: abstract void Move(
   int offsetX,
   int offsetY
)
public:
abstract void Move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnMarkFlipped Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : OnMarkFlipped Method
The center point, around which the mark flipped.
Flip direction.
Occurs when the mark is flipped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkFlipped( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTMark
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.OnMarkFlipped(center, flipMode)
protected void OnMarkFlipped(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
protected: void OnMarkFlipped(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
protected:
void OnMarkFlipped(
   ImGearPoint center,
   ImGearFlipModes flipMode
)

Parameters

center
The center point, around which the mark flipped.
flipMode
Flip direction.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnMarkMoved Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : OnMarkMoved Method
Horizontal offset.
Vertical offset.
Occurs when the mark is moved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkMoved( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTMark
Dim offsetX As Integer
Dim offsetY As Integer

instance.OnMarkMoved(offsetX, offsetY)
protected void OnMarkMoved(
   int offsetX,
   int offsetY
)
protected: void OnMarkMoved(
   int offsetX,
   int offsetY
)
protected:
void OnMarkMoved(
   int offsetX,
   int offsetY
)

Parameters

offsetX
Horizontal offset.
offsetY
Vertical offset.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnMarkRotated Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : OnMarkRotated Method
The center point, around which the mark rotated.
Rotation angle.
Occurs when the mark is rotated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkRotated( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTMark
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.OnMarkRotated(center, rotationAngle)
protected void OnMarkRotated(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
protected: void OnMarkRotated(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
protected:
void OnMarkRotated(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)

Parameters

center
The center point, around which the mark rotated.
rotationAngle
Rotation angle.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnMarkScaled Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : OnMarkScaled Method
The horizontal scaling factor.
The vertical scaling factor.
Occurs when the mark is scaled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkScaled( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTMark
Dim scaleX As Double
Dim scaleY As Double

instance.OnMarkScaled(scaleX, scaleY)
protected void OnMarkScaled(
   double scaleX,
   double scaleY
)
protected: void OnMarkScaled(
   double scaleX,
   double scaleY
)
protected:
void OnMarkScaled(
   double scaleX,
   double scaleY
)

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnPropertyChanged Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : OnPropertyChanged Method
Occurs when a property value changes.
Overload List
Overload | Description
OnPropertyChanged(String) | Occurs when a property value changes.
OnPropertyChanged(String,Object,Object) | Occurs when a property value changes.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


OnPropertyChanged(String) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class > OnPropertyChanged Method : OnPropertyChanged(String) Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearARTMark
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
Overload List


OnPropertyChanged(String,Object,Object) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class > OnPropertyChanged Method : OnPropertyChanged(String,Object,Object) Method
The name of the property that changed.
The old value of the property before changing.
The new value of the property after changing.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As ImGearARTMark
Dim name As String
Dim oldValue As Object
Dim newValue As Object

instance.OnPropertyChanged(name, oldValue, newValue)
protected void OnPropertyChanged(
   string name,
   object oldValue,
   object newValue
)
protected: void OnPropertyChanged(
   string* name,
   Object* oldValue,
   Object* newValue
)
protected:
void OnPropertyChanged(
   String^ name,
   Object^ oldValue,
   Object^ newValue
)

Parameters

name
The name of the property that changed.
oldValue
The old value of the property before changing.
newValue
The new value of the property after changing.
Remarks
Note: this method calls OnPropertyChanged(String) too, which is responsible for firing of PropertyChanged event.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
Overload List


Rotate Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTMark
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public virtual void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: virtual void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public:
virtual void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
Rotate Method


Scale Method (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTMark
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public virtual void Scale(
   double scaleX,
   double scaleY
)
public: virtual void Scale(
   double scaleX,
   double scaleY
)
public:
virtual void Scale(
   double scaleX,
   double scaleY
)

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTMark Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMark Class

For a list of all members of this type, see ImGearARTMark members.

Public Properties
 | Name | Description
Public Property | AccessController | Gets access controller for the mark.
Public Property | Bounds | Gets the mark's bounding rectangle in abstract coordinates.
Public Property | HitTestBounds | Gets the mark's boundling rectangle used for hit test.
Public Property | Id | Gets the mark's id.
Public Property | ParentGroup | Gets the reference to the parent group.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | Statistics | Gets an object representing specific statistics information about the mark.
Public Property | Type | Gets the mark's type.
Public Property | UserData | Gets or sets the user data specified for the mark.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the mark.
Public Property | Visible | Gets or sets a value indicating whether the mark's visibility state.
Top
See Also

Reference

ImGearARTMark Class
ImageGear.ART Namespace


AccessController Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : AccessController Property
Gets access controller for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AccessController As ImGearARTAccessController
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearARTAccessController

value = instance.AccessController
public ImGearARTAccessController AccessController {get;}
public: __property ImGearARTAccessController* get_AccessController();
public:
property ImGearARTAccessController^ AccessController {
   ImGearARTAccessController^ get();
}

Property Value

ImGearARTAccessController class instance.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Bounds Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Bounds Property
Gets the mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearRectangle

value = instance.Bounds
public abstract ImGearRectangle Bounds {get;}
public: __property abstract ImGearRectangle get_Bounds();
public:
abstract property ImGearRectangle Bounds {
   ImGearRectangle get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
ImGearRectangle Structure


HitTestBounds Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : HitTestBounds Property
Gets the mark's boundling rectangle used for hit test.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property HitTestBounds As ImGearRectangle
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearRectangle

value = instance.HitTestBounds
public virtual ImGearRectangle HitTestBounds {get;}
public: __property virtual ImGearRectangle get_HitTestBounds();
public:
virtual property ImGearRectangle HitTestBounds {
   ImGearRectangle get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
ImGearRectangle Structure


Id Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Id Property
Gets the mark's id.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Id As Integer
'Usage

Dim instance As ImGearARTMark
Dim value As Integer

value = instance.Id
public int Id {get;}
public: __property int get_Id();
public:
property int Id {
   int get();
}

Property Value

Integer value.
Remarks
The Id is assigned to the mark when it's added to the ART Page. If the mark is not added to the ART Page the value of Id is -1.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


ParentGroup Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : ParentGroup Property
Gets the reference to the parent group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ParentGroup As ImGearARTGroup
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearARTGroup

value = instance.ParentGroup
public ImGearARTGroup ParentGroup {get;}
public: __property ImGearARTGroup* get_ParentGroup();
public:
property ImGearARTGroup^ ParentGroup {
   ImGearARTGroup^ get();
}

Property Value

ImGearARTGroup value.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


SecureObjectData Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : SecureObjectData Property
Gets or sets data object for the AccessController property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SecureObjectData As ImGearARTSecureObjectData
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearARTSecureObjectData

instance.SecureObjectData = value

value = instance.SecureObjectData
public ImGearARTSecureObjectData SecureObjectData {get; set;}
public: __property ImGearARTSecureObjectData* get_SecureObjectData();
public: __property void set_SecureObjectData(
   ImGearARTSecureObjectData* value
);
public:
property ImGearARTSecureObjectData^ SecureObjectData {
   ImGearARTSecureObjectData^ get();
   void set (    ImGearARTSecureObjectData^ value);
}

Property Value

ImGearARTSecureObjectData class instance.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


SelectionPoints Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTMark
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
Remarks
This property is used internally to draw selection handles for point-based marks. This property is null for rectangular marks which use the Bounds property to draw selection graphics.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Statistics Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Statistics Property
Gets an object representing specific statistics information about the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Statistics As ImGearARTMarkStatistics
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearARTMarkStatistics

value = instance.Statistics
public virtual ImGearARTMarkStatistics Statistics {get;}
public: __property virtual ImGearARTMarkStatistics* get_Statistics();
public:
virtual property ImGearARTMarkStatistics^ Statistics {
   ImGearARTMarkStatistics^ get();
}

Property Value

ImGearARTMarkStatistics class object.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Type Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Type Property
Gets the mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTMark
Dim value As ImGearARTMarkType

value = instance.Type
public abstract ImGearARTMarkType Type {get;}
public: __property abstract ImGearARTMarkType get_Type();
public:
abstract property ImGearARTMarkType Type {
   ImGearARTMarkType get();
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTMark)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property UserData As Object
'Usage

Dim instance As ImGearARTMark
Dim value As Object

instance.UserData = value

value = instance.UserData
public virtual object UserData {get; set;}
public: __property virtual Object* get_UserData();
public: __property virtual void set_UserData(
   Object* value
);
public:
virtual property Object^ UserData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


UserDataAttributes Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : UserDataAttributes Property
Gets the user data dictionary specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UserDataAttributes As IDictionary(Of String,String)
'Usage

Dim instance As ImGearARTMark
Dim value As IDictionary(Of String,String)

value = instance.UserDataAttributes
public IDictionary<string,string> UserDataAttributes {get;}
public: __property IDictionary<string*,string*>* get_UserDataAttributes();
public:
property IDictionary<String^,String^>^ UserDataAttributes {
   IDictionary<String^,String^>^ get();
}

Property Value

IDictionary interface.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


Visible Property (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : Visible Property
Gets or sets a value indicating whether the mark's visibility state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property Visible As Boolean
'Usage

Dim instance As ImGearARTMark
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public abstract bool Visible {get; set;}
public: __property abstract bool get_Visible();
public: __property abstract void set_Visible(
   bool value
);
public:
abstract property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%% $$Events$$

ImGearARTMark Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMark Class

For a list of all members of this type, see ImGearARTMark members.

Public Events
 | Name | Description
Public Event | MarkFlipped | Occurs when the mark is flipped.
Public Event | MarkMoved | Occurs when the mark is moved.
Public Event | MarkRotated | Occurs when the mark is rotated.
Public Event | MarkScaled | Occurs when the mark is scaled.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTMark Class
ImageGear.ART Namespace


MarkFlipped Event

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : MarkFlipped Event
Occurs when the mark is flipped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkFlipped As ImGearARTMarkFlipEventHandler
'Usage

Dim instance As ImGearARTMark
Dim handler As ImGearARTMarkFlipEventHandler

AddHandler instance.MarkFlipped, handler
public event ImGearARTMarkFlipEventHandler MarkFlipped
public: __event ImGearARTMarkFlipEventHandler* MarkFlipped
public:
event ImGearARTMarkFlipEventHandler^ MarkFlipped
Event Data

The event handler receives an argument of type ImGearARTMarkFlipEventArgs containing data related to this event. The following ImGearARTMarkFlipEventArgs properties provide information specific to this event.

Property | Description
Center | Gets the center point, around which to rotate the mark.
FlipMode | Gets the rotation angle.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


MarkMoved Event

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : MarkMoved Event
Occurs when the mark is moved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkMoved As ImGearARTMarkMoveEventHandler
'Usage

Dim instance As ImGearARTMark
Dim handler As ImGearARTMarkMoveEventHandler

AddHandler instance.MarkMoved, handler
public event ImGearARTMarkMoveEventHandler MarkMoved
public: __event ImGearARTMarkMoveEventHandler* MarkMoved
public:
event ImGearARTMarkMoveEventHandler^ MarkMoved
Event Data

The event handler receives an argument of type ImGearARTMarkMoveEventArgs containing data related to this event. The following ImGearARTMarkMoveEventArgs properties provide information specific to this event.

Property | Description
OffsetX | Gets the X move offset.
OffsetY | Gets the Y move offset.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


MarkRotated Event

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : MarkRotated Event
Occurs when the mark is rotated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkRotated As ImGearARTMarkRotateEventHandler
'Usage

Dim instance As ImGearARTMark
Dim handler As ImGearARTMarkRotateEventHandler

AddHandler instance.MarkRotated, handler
public event ImGearARTMarkRotateEventHandler MarkRotated
public: __event ImGearARTMarkRotateEventHandler* MarkRotated
public:
event ImGearARTMarkRotateEventHandler^ MarkRotated
Event Data

The event handler receives an argument of type ImGearARTMarkRotateEventArgs containing data related to this event. The following ImGearARTMarkRotateEventArgs properties provide information specific to this event.

Property | Description
Center | Gets the center point, around which to rotate the mark.
RotationAngle | Gets the rotation angle.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


MarkScaled Event

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : MarkScaled Event
Occurs when the mark is scaled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkScaled As ImGearARTMarkScaleEventHandler
'Usage

Dim instance As ImGearARTMark
Dim handler As ImGearARTMarkScaleEventHandler

AddHandler instance.MarkScaled, handler
public event ImGearARTMarkScaleEventHandler MarkScaled
public: __event ImGearARTMarkScaleEventHandler* MarkScaled
public:
event ImGearARTMarkScaleEventHandler^ MarkScaled
Event Data

The event handler receives an argument of type ImGearARTMarkScaleEventArgs containing data related to this event. The following ImGearARTMarkScaleEventArgs properties provide information specific to this event.

Property | Description
ScaleX | Gets the horizontal scaling factor.
ScaleY | Gets the vertical scaling factor.
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


PropertyChanged Event (ImGearARTMark)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMark Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearARTMark
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

ImGearARTMarkEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkEventArgs Class
Provides data for the mark events.
Object Model
ImGearARTMarkEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTMarkEventArgs
public class ImGearARTMarkEventArgs : System.EventArgs
public __gc class ImGearARTMarkEventArgs : public System.EventArgs
public ref class ImGearARTMarkEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkEventArgs
ImageGear.ART.ImGearARTMarkPointEventArgs

See Also

Reference

ImGearARTMarkEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkEventArgs Class

The following tables list the members exposed by ImGearARTMarkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTMarkEventArgs Constructor | Initializes a new instance of the ImGearARTMarkEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Mark | Gets the mark in which the event fired.
Top
See Also

Reference

ImGearARTMarkEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkEventArgs Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkEventArgs Class : ImGearARTMarkEventArgs Constructor
The mark in which the event fired.
Initializes a new instance of the ImGearARTMarkEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New ImGearARTMarkEventArgs(mark)
public ImGearARTMarkEventArgs(
   ImGearARTMark mark
)
public: ImGearARTMarkEventArgs(
   ImGearARTMark* mark
)
public:
ImGearARTMarkEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
The mark in which the event fired.
See Also

Reference

ImGearARTMarkEventArgs Class
ImGearARTMarkEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearARTMarkEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkEventArgs Class

For a list of all members of this type, see ImGearARTMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Mark | Gets the mark in which the event fired.
Top
See Also

Reference

ImGearARTMarkEventArgs Class
ImageGear.ART Namespace


Mark Property (ImGearARTMarkEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkEventArgs Class : Mark Property
Gets the mark in which the event fired.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTMarkEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark value.
Remarks
A copy of the mark that was removed is returned if the MarkRemoved event fired.
See Also

Reference

ImGearARTMarkEventArgs Class
ImGearARTMarkEventArgs Members


%%PageItemTitle%%

ImGearARTMarkFlipEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkFlipEventArgs Class
Provides data for the mark flip events.
Object Model
ImGearARTMarkFlipEventArgs ClassImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkFlipEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTMarkFlipEventArgs
public class ImGearARTMarkFlipEventArgs : System.EventArgs
public __gc class ImGearARTMarkFlipEventArgs : public System.EventArgs
public ref class ImGearARTMarkFlipEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkFlipEventArgs

See Also

Reference

ImGearARTMarkFlipEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkFlipEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkFlipEventArgs Class

The following tables list the members exposed by ImGearARTMarkFlipEventArgs.

Public Properties
 | Name | Description
Public Property | Center | Gets the center point, around which to rotate the mark.
Public Property | FlipMode | Gets the rotation angle.
Top
See Also

Reference

ImGearARTMarkFlipEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTMarkFlipEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkFlipEventArgs Class

For a list of all members of this type, see ImGearARTMarkFlipEventArgs members.

Public Properties
 | Name | Description
Public Property | Center | Gets the center point, around which to rotate the mark.
Public Property | FlipMode | Gets the rotation angle.
Top
See Also

Reference

ImGearARTMarkFlipEventArgs Class
ImageGear.ART Namespace


Center Property (ImGearARTMarkFlipEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkFlipEventArgs Class : Center Property
Gets the center point, around which to rotate the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Center As ImGearPoint
'Usage

Dim instance As ImGearARTMarkFlipEventArgs
Dim value As ImGearPoint

value = instance.Center
public ImGearPoint Center {get;}
public: __property ImGearPoint get_Center();
public:
property ImGearPoint Center {
   ImGearPoint get();
}

Property Value

ImageGear.Core.ImGearPoint value.
See Also

Reference

ImGearARTMarkFlipEventArgs Class
ImGearARTMarkFlipEventArgs Members


FlipMode Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkFlipEventArgs Class : FlipMode Property
Gets the rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FlipMode As ImGearFlipModes
'Usage

Dim instance As ImGearARTMarkFlipEventArgs
Dim value As ImGearFlipModes

value = instance.FlipMode
public ImGearFlipModes FlipMode {get;}
public: __property ImGearFlipModes get_FlipMode();
public:
property ImGearFlipModes FlipMode {
   ImGearFlipModes get();
}

Property Value

ImageGear.Core.ImGearFlipModes value.
See Also

Reference

ImGearARTMarkFlipEventArgs Class
ImGearARTMarkFlipEventArgs Members


%%PageItemTitle%%

ImGearARTMarkMoveEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkMoveEventArgs Class
Provides data for the mark move events.
Object Model
ImGearARTMarkMoveEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkMoveEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTMarkMoveEventArgs
public class ImGearARTMarkMoveEventArgs : System.EventArgs
public __gc class ImGearARTMarkMoveEventArgs : public System.EventArgs
public ref class ImGearARTMarkMoveEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkMoveEventArgs

See Also

Reference

ImGearARTMarkMoveEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkMoveEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkMoveEventArgs Class

The following tables list the members exposed by ImGearARTMarkMoveEventArgs.

Public Properties
 | Name | Description
Public Property | OffsetX | Gets the X move offset.
Public Property | OffsetY | Gets the Y move offset.
Top
See Also

Reference

ImGearARTMarkMoveEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTMarkMoveEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkMoveEventArgs Class

For a list of all members of this type, see ImGearARTMarkMoveEventArgs members.

Public Properties
 | Name | Description
Public Property | OffsetX | Gets the X move offset.
Public Property | OffsetY | Gets the Y move offset.
Top
See Also

Reference

ImGearARTMarkMoveEventArgs Class
ImageGear.ART Namespace


OffsetX Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkMoveEventArgs Class : OffsetX Property
Gets the X move offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OffsetX As Integer
'Usage

Dim instance As ImGearARTMarkMoveEventArgs
Dim value As Integer

value = instance.OffsetX
public int OffsetX {get;}
public: __property int get_OffsetX();
public:
property int OffsetX {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearARTMarkMoveEventArgs Class
ImGearARTMarkMoveEventArgs Members


OffsetY Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkMoveEventArgs Class : OffsetY Property
Gets the Y move offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OffsetY As Integer
'Usage

Dim instance As ImGearARTMarkMoveEventArgs
Dim value As Integer

value = instance.OffsetY
public int OffsetY {get;}
public: __property int get_OffsetY();
public:
property int OffsetY {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearARTMarkMoveEventArgs Class
ImGearARTMarkMoveEventArgs Members


%%PageItemTitle%%

ImGearARTMarkPointEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkPointEventArgs Class
Provides data for the mark point events.
Object Model
ImGearARTMarkPointEventArgs ClassImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkPointEventArgs
   Inherits ImGearARTMarkEventArgs
'Usage

Dim instance As ImGearARTMarkPointEventArgs
public class ImGearARTMarkPointEventArgs : ImGearARTMarkEventArgs
public __gc class ImGearARTMarkPointEventArgs : public ImGearARTMarkEventArgs
public ref class ImGearARTMarkPointEventArgs : public ImGearARTMarkEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkEventArgs
ImageGear.ART.ImGearARTMarkPointEventArgs

See Also

Reference

ImGearARTMarkPointEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkPointEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkPointEventArgs Class

The following tables list the members exposed by ImGearARTMarkPointEventArgs.

Public Properties
 | Name | Description
Public Property | Point | Gets the point that was added or changed.
Top
See Also

Reference

ImGearARTMarkPointEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTMarkPointEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkPointEventArgs Class

For a list of all members of this type, see ImGearARTMarkPointEventArgs members.

Public Properties
 | Name | Description
Public Property | Point | Gets the point that was added or changed.
Top
See Also

Reference

ImGearARTMarkPointEventArgs Class
ImageGear.ART Namespace


Point Property (ImGearARTMarkPointEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkPointEventArgs Class : Point Property
Gets the point that was added or changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Point As ImGearPoint
'Usage

Dim instance As ImGearARTMarkPointEventArgs
Dim value As ImGearPoint

value = instance.Point
public ImGearPoint Point {get;}
public: __property ImGearPoint get_Point();
public:
property ImGearPoint Point {
   ImGearPoint get();
}

Property Value

ImGearPoint value.
See Also

Reference

ImGearARTMarkPointEventArgs Class
ImGearARTMarkPointEventArgs Members


%%PageItemTitle%%

ImGearARTMarkRotateEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkRotateEventArgs Class
Provides data for the mark rotate events.
Object Model
ImGearARTMarkRotateEventArgs ClassImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkRotateEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTMarkRotateEventArgs
public class ImGearARTMarkRotateEventArgs : System.EventArgs
public __gc class ImGearARTMarkRotateEventArgs : public System.EventArgs
public ref class ImGearARTMarkRotateEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkRotateEventArgs

See Also

Reference

ImGearARTMarkRotateEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkRotateEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkRotateEventArgs Class

The following tables list the members exposed by ImGearARTMarkRotateEventArgs.

Public Properties
 | Name | Description
Public Property | Center | Gets the center point, around which to rotate the mark.
Public Property | RotationAngle | Gets the rotation angle.
Top
See Also

Reference

ImGearARTMarkRotateEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTMarkRotateEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkRotateEventArgs Class

For a list of all members of this type, see ImGearARTMarkRotateEventArgs members.

Public Properties
 | Name | Description
Public Property | Center | Gets the center point, around which to rotate the mark.
Public Property | RotationAngle | Gets the rotation angle.
Top
See Also

Reference

ImGearARTMarkRotateEventArgs Class
ImageGear.ART Namespace


Center Property (ImGearARTMarkRotateEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkRotateEventArgs Class : Center Property
Gets the center point, around which to rotate the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Center As ImGearPoint
'Usage

Dim instance As ImGearARTMarkRotateEventArgs
Dim value As ImGearPoint

value = instance.Center
public ImGearPoint Center {get;}
public: __property ImGearPoint get_Center();
public:
property ImGearPoint Center {
   ImGearPoint get();
}

Property Value

ImageGear.Core.ImGearPoint value.
See Also

Reference

ImGearARTMarkRotateEventArgs Class
ImGearARTMarkRotateEventArgs Members


RotationAngle Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkRotateEventArgs Class : RotationAngle Property
Gets the rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RotationAngle As ImGearRotationValues
'Usage

Dim instance As ImGearARTMarkRotateEventArgs
Dim value As ImGearRotationValues

value = instance.RotationAngle
public ImGearRotationValues RotationAngle {get;}
public: __property ImGearRotationValues get_RotationAngle();
public:
property ImGearRotationValues RotationAngle {
   ImGearRotationValues get();
}

Property Value

ImageGear.Core.ImGearRotationValues value.
See Also

Reference

ImGearARTMarkRotateEventArgs Class
ImGearARTMarkRotateEventArgs Members


%%PageItemTitle%%

ImGearARTMarkScaleEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkScaleEventArgs Class
Provides data for the mark scale events.
Object Model
ImGearARTMarkScaleEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkScaleEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTMarkScaleEventArgs
public class ImGearARTMarkScaleEventArgs : System.EventArgs
public __gc class ImGearARTMarkScaleEventArgs : public System.EventArgs
public ref class ImGearARTMarkScaleEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.ImGearARTMarkScaleEventArgs

See Also

Reference

ImGearARTMarkScaleEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkScaleEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkScaleEventArgs Class

The following tables list the members exposed by ImGearARTMarkScaleEventArgs.

Public Properties
 | Name | Description
Public Property | ScaleX | Gets the horizontal scaling factor.
Public Property | ScaleY | Gets the vertical scaling factor.
Top
See Also

Reference

ImGearARTMarkScaleEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTMarkScaleEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkScaleEventArgs Class

For a list of all members of this type, see ImGearARTMarkScaleEventArgs members.

Public Properties
 | Name | Description
Public Property | ScaleX | Gets the horizontal scaling factor.
Public Property | ScaleY | Gets the vertical scaling factor.
Top
See Also

Reference

ImGearARTMarkScaleEventArgs Class
ImageGear.ART Namespace


ScaleX Property (ImGearARTMarkScaleEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkScaleEventArgs Class : ScaleX Property
Gets the horizontal scaling factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScaleX As Double
'Usage

Dim instance As ImGearARTMarkScaleEventArgs
Dim value As Double

value = instance.ScaleX
public double ScaleX {get;}
public: __property double get_ScaleX();
public:
property double ScaleX {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkScaleEventArgs Class
ImGearARTMarkScaleEventArgs Members


ScaleY Property (ImGearARTMarkScaleEventArgs)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkScaleEventArgs Class : ScaleY Property
Gets the vertical scaling factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScaleY As Double
'Usage

Dim instance As ImGearARTMarkScaleEventArgs
Dim value As Double

value = instance.ScaleY
public double ScaleY {get;}
public: __property double get_ScaleY();
public:
property double ScaleY {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkScaleEventArgs Class
ImGearARTMarkScaleEventArgs Members


%%PageItemTitle%%

ImGearARTMarkStat Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStat Class
This class has been deprecated. Provides the abstract base class for a set of classes intended to represent specific statistics information about ART marks.
Object Model
ImGearARTMarkStat ClassImGearARTMarkStat ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. Please use the ImGearARTMarkStatistics class instead.")>
Public MustInherit Class ImGearARTMarkStat
'Usage

Dim instance As ImGearARTMarkStat
[Obsolete("This class will be removed from the public API in a future release. Please use the ImGearARTMarkStatistics class instead.")]
public abstract class ImGearARTMarkStat
[Obsolete("This class will be removed from the public API in a future release. Please use the ImGearARTMarkStatistics class instead.")]
public __gc abstract class ImGearARTMarkStat
[Obsolete("This class will be removed from the public API in a future release. Please use the ImGearARTMarkStatistics class instead.")]
public ref class ImGearARTMarkStat abstract
Remarks
Such information could be: area and perimeter for the shape marks (rectangle, ellipse, etc.), length for the line marks (line, polyline, arrow, etc.), and so on.
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTMarkStat
ImageGear.ART.ImGearARTLineMarkStat
ImageGear.ART.ImGearARTPointMarkStat
ImageGear.ART.ImGearARTShapeMarkStat

See Also

Reference

ImGearARTMarkStat Members
ImageGear.ART Namespace
ImGearARTShapeMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Members$$

ImGearARTMarkStat Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStat Class

The following tables list the members exposed by ImGearARTMarkStat.

Public Properties
 | Name | Description
Public Property | BoundsArea | Gets the area of the marks' bounds rectangle.
Public Property | BoundsPerimeter | Gets the perimeter of the marks' bounds rectangle.
Public Property | Mark | Gets the reference to the original ART mark.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates and initializes an instance of the ImGearARTMarkStat class for an ART mark.
Top
See Also

Reference

ImGearARTMarkStat Class
ImageGear.ART Namespace
ImGearARTShapeMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Methods$$

ImGearARTMarkStat Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStat Class

For a list of all members of this type, see ImGearARTMarkStat members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates and initializes an instance of the ImGearARTMarkStat class for an ART mark.
Top
See Also

Reference

ImGearARTMarkStat Class
ImageGear.ART Namespace
ImGearARTShapeMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


Create Method (ImGearARTMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStat Class : Create Method
The original ART mark.
Creates and initializes an instance of the ImGearARTMarkStat class for an ART mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Create( _
   ByVal mark As ImGearARTMark _
) As ImGearARTMarkStat
'Usage

Dim mark As ImGearARTMark
Dim value As ImGearARTMarkStat

value = ImGearARTMarkStat.Create(mark)
public static ImGearARTMarkStat Create(
   ImGearARTMark mark
)
public: static ImGearARTMarkStat* Create(
   ImGearARTMark* mark
)
public:
static ImGearARTMarkStat^ Create(
   ImGearARTMark^ mark
)

Parameters

mark
The original ART mark.

Return Value

New instance of the ImGearARTMarkStat class.
See Also

Reference

ImGearARTMarkStat Class
ImGearARTMarkStat Members


%%PageItemTitle%% $$Properties$$

ImGearARTMarkStat Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStat Class

For a list of all members of this type, see ImGearARTMarkStat members.

Public Properties
 | Name | Description
Public Property | BoundsArea | Gets the area of the marks' bounds rectangle.
Public Property | BoundsPerimeter | Gets the perimeter of the marks' bounds rectangle.
Public Property | Mark | Gets the reference to the original ART mark.
Top
See Also

Reference

ImGearARTMarkStat Class
ImageGear.ART Namespace
ImGearARTShapeMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


BoundsArea Property (ImGearARTMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStat Class : BoundsArea Property
Gets the area of the marks' bounds rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BoundsArea As Double
'Usage

Dim instance As ImGearARTMarkStat
Dim value As Double

value = instance.BoundsArea
public double BoundsArea {get;}
public: __property double get_BoundsArea();
public:
property double BoundsArea {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStat Class
ImGearARTMarkStat Members


BoundsPerimeter Property (ImGearARTMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStat Class : BoundsPerimeter Property
Gets the perimeter of the marks' bounds rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BoundsPerimeter As Double
'Usage

Dim instance As ImGearARTMarkStat
Dim value As Double

value = instance.BoundsPerimeter
public double BoundsPerimeter {get;}
public: __property double get_BoundsPerimeter();
public:
property double BoundsPerimeter {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStat Class
ImGearARTMarkStat Members


Mark Property (ImGearARTMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStat Class : Mark Property
Gets the reference to the original ART mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTMarkStat
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTMarkStat Class
ImGearARTMarkStat Members


%%PageItemTitle%%

ImGearARTMarkStatistics Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStatistics Class
Represent specific statistics information about ART marks.
Object Model
ImGearARTMarkStatistics ClassImGearARTMark ClassIImGearResolution InterfaceImGearARTMeasurementUnit Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkStatistics
'Usage

Dim instance As ImGearARTMarkStatistics
public class ImGearARTMarkStatistics
public __gc class ImGearARTMarkStatistics
public ref class ImGearARTMarkStatistics
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTMarkStatistics

See Also

Reference

ImGearARTMarkStatistics Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkStatistics Class Members
Properties Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStatistics Class

The following tables list the members exposed by ImGearARTMarkStatistics.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTMarkStatistics Constructor | Initializes a new instance of the ImGearARTMarkStatistics class.
Top
Public Properties
 | Name | Description
Public Property | Area | Gets the area of the mark.
Public Property | BoundsArea | Gets the area of the marks' bounds rectangle. Gets the area of the marks' bounds rectangle.
Public Property | BoundsPerimeter | Gets the perimeter of the marks' bounds rectangle.
Public Property | Length | Gets the total length of the line mark.
Public Property | Perimeter | Gets the perimeter of the mark.
Public Property | Resolution | Gets or sets an image resolution.
Public Property | Unit | Gets or sets a measurement unit that is used to calculate statistics information.
Top
Protected Properties
 | Name | Description
Protected Property | AspectX | Gets an X aspect value that is used to convert the length in pixels to the actual length.
Protected Property | AspectY | Gets an Y aspect value that is used to convert the length in pixels to the actual length.
Protected Property | Mark | Gets a mark which statistics values are calculated.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTMarkStatistics Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkStatistics Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : ImGearARTMarkStatistics Constructor
A mark for which statistics object is created.
Initializes a new instance of the ImGearARTMarkStatistics class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New ImGearARTMarkStatistics(mark)
public ImGearARTMarkStatistics(
   ImGearARTMark mark
)
public: ImGearARTMarkStatistics(
   ImGearARTMark* mark
)
public:
ImGearARTMarkStatistics(
   ImGearARTMark^ mark
)

Parameters

mark
A mark for which statistics object is created.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%% $$Properties$$

ImGearARTMarkStatistics Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStatistics Class

For a list of all members of this type, see ImGearARTMarkStatistics members.

Public Properties
 | Name | Description
Public Property | Area | Gets the area of the mark.
Public Property | BoundsArea | Gets the area of the marks' bounds rectangle. Gets the area of the marks' bounds rectangle.
Public Property | BoundsPerimeter | Gets the perimeter of the marks' bounds rectangle.
Public Property | Length | Gets the total length of the line mark.
Public Property | Perimeter | Gets the perimeter of the mark.
Public Property | Resolution | Gets or sets an image resolution.
Public Property | Unit | Gets or sets a measurement unit that is used to calculate statistics information.
Top
Protected Properties
 | Name | Description
Protected Property | AspectX | Gets an X aspect value that is used to convert the length in pixels to the actual length.
Protected Property | AspectY | Gets an Y aspect value that is used to convert the length in pixels to the actual length.
Protected Property | Mark | Gets a mark which statistics values are calculated.
Top
See Also

Reference

ImGearARTMarkStatistics Class
ImageGear.ART Namespace


Area Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Area Property
Gets the area of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Area As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.Area
public virtual double Area {get;}
public: __property virtual double get_Area();
public:
virtual property double Area {
   double get();
}

Property Value

Double value.
Remarks
If the mark does not have an area (for example, Line or Protractor mark), this property will retun 0.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


AspectX Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : AspectX Property
Gets an X aspect value that is used to convert the length in pixels to the actual length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected ReadOnly Property AspectX As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.AspectX
protected double AspectX {get;}
protected: __property double get_AspectX();
protected:
property double AspectX {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


AspectY Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : AspectY Property
Gets an Y aspect value that is used to convert the length in pixels to the actual length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected ReadOnly Property AspectY As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.AspectY
protected double AspectY {get;}
protected: __property double get_AspectY();
protected:
property double AspectY {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


BoundsArea Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : BoundsArea Property
Gets the area of the marks' bounds rectangle. Gets the area of the marks' bounds rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property BoundsArea As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.BoundsArea
public virtual double BoundsArea {get;}
public: __property virtual double get_BoundsArea();
public:
virtual property double BoundsArea {
   double get();
}

Property Value

Double value.Double value.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


BoundsPerimeter Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : BoundsPerimeter Property
Gets the perimeter of the marks' bounds rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property BoundsPerimeter As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.BoundsPerimeter
public virtual double BoundsPerimeter {get;}
public: __property virtual double get_BoundsPerimeter();
public:
virtual property double BoundsPerimeter {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


Length Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Length Property
Gets the total length of the line mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Length As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.Length
public virtual double Length {get;}
public: __property virtual double get_Length();
public:
virtual property double Length {
   double get();
}

Property Value

Double value.
Remarks
If the mark does not have a Length (for example, Ellipse mark), this property will retun 0.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


Mark Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Mark Property
Gets a mark which statistics values are calculated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As ImGearARTMark

instance.Mark = value

value = instance.Mark
protected ImGearARTMark Mark {get; set;}
protected: __property ImGearARTMark* get_Mark();
protected: __property void set_Mark(
   ImGearARTMark* value
);
protected:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
   void set (    ImGearARTMark^ value);
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


Perimeter Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Perimeter Property
Gets the perimeter of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Perimeter As Double
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As Double

value = instance.Perimeter
public virtual double Perimeter {get;}
public: __property virtual double get_Perimeter();
public:
virtual property double Perimeter {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


Resolution Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Resolution Property
Gets or sets an image resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Resolution As IImGearResolution
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As IImGearResolution

instance.Resolution = value

value = instance.Resolution
public IImGearResolution Resolution {get; set;}
public: __property IImGearResolution* get_Resolution();
public: __property void set_Resolution(
   IImGearResolution* value
);
public:
property IImGearResolution^ Resolution {
   IImGearResolution^ get();
   void set (    IImGearResolution^ value);
}

Property Value

ImageGear.Core.ImGearResolution structure object.
Remarks
An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


Unit Property (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : Unit Property
Gets or sets a measurement unit that is used to calculate statistics information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Unit As ImGearARTMeasurementUnit
'Usage

Dim instance As ImGearARTMarkStatistics
Dim value As ImGearARTMeasurementUnit

instance.Unit = value

value = instance.Unit
public ImGearARTMeasurementUnit Unit {get; set;}
public: __property ImGearARTMeasurementUnit get_Unit();
public: __property void set_Unit(
   ImGearARTMeasurementUnit value
);
public:
property ImGearARTMeasurementUnit Unit {
   ImGearARTMeasurementUnit get();
   void set (    ImGearARTMeasurementUnit value);
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%% $$Events$$

ImGearARTMarkStatistics Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkStatistics Class

For a list of all members of this type, see ImGearARTMarkStatistics members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTMarkStatistics Class
ImageGear.ART Namespace


PropertyChanged Event (ImGearARTMarkStatistics)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMarkStatistics Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearARTMarkStatistics
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Remarks
The PropertyChanged event can indicate all properties on the object have changed by using String.Empty as the property name.
See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

ImGearARTNote Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTNote Class
Represents legacy ART Attach-A-Note mark.
Object Model
ImGearARTNote ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearSize StructureImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTNote
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTNote
public class ImGearARTNote : ImGearARTMark
public __gc class ImGearARTNote : public ImGearARTMark
public ref class ImGearARTNote : public ImGearARTMark
Example
  • C#
// Setup rectangle for the note mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the note text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 0);
// Setup color for the note fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Create note mark using size 16 italic Arial font
ImGearARTNote igARTNote = new ImGearARTNote(
    igRectangle, "ImGearARTNote test", igRGBQuadText, igRGBQuadFill,
    "Arial", (float)16.0, ImGearARTFontStyles.Italic
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTNote, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the note mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the note text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 0)
' Setup color for the note fill.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Create note mark using size 16 italic Arial font
Dim igARTNote As New ImGearARTNote( _
 igRectangle, "ImGearARTNote test", igRGBQuadText, igRGBQuadFill, _
"Arial", CSng(16), ImGearARTFontStyles.Italic)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTNote, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTNote

See Also

Reference

ImGearARTNote Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTNote Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTNote Class

The following tables list the members exposed by ImGearARTNote.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTNote Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text of the mark.
Public Property | FontSize | Gets or sets the font size of the text of the mark.
Public Property | FontStyleART | Gets or sets the font style of the text of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the note mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTNote Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTNote Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : ImGearARTNote Constructor
Overload List
Overload | Description
ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad) | Initializes a new instance of the ImGearARTNote class object.
ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTNote class object.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class > ImGearARTNote Constructor : ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad)
The mark rectangle.
The text of the mark.
The color of the text.
The fill color of the mark.
Initializes a new instance of the ImGearARTNote class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTNote(rect, text, textColor, fillColor)
public ImGearARTNote(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor
)
public: ImGearARTNote(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTNote(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class > ImGearARTNote Constructor : ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,Single,ImGearARTFontStyles)
The mark rectangle.
The text of the mark.
The color of the text.
The fill color of the mark.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTNote class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fillColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTNote(rect, text, textColor, fillColor, fontName, fontSize, fontStyle)
public ImGearARTNote(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTNote(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   IImGearRGBQuad* fillColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTNote(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   IImGearRGBQuad^ fillColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTNote Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTNote Class

For a list of all members of this type, see ImGearARTNote members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTNote Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTNote Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTNote Class

For a list of all members of this type, see ImGearARTNote members.

See Also

Reference

ImGearARTNote Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTNote
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
IImGearScrollableView Interface
ImGearPageDisplay Class


EndEdit Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTNote
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
IImGearScrollableView Interface


Flip Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTNote
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Flip Method


GetAutoFitSize Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : GetAutoFitSize Method
The page view control that contains text mark.
The page display of the page view control.
The auto fit mode.
Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAutoFitSize( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal autoFitMode As ImGearARTTextAutoFitMode _
) As ImGearSize
'Usage

Dim instance As ImGearARTNote
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim autoFitMode As ImGearARTTextAutoFitMode
Dim value As ImGearSize

value = instance.GetAutoFitSize(pageView, pageDisplay, autoFitMode)
public ImGearSize GetAutoFitSize(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public: ImGearSize GetAutoFitSize(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public:
ImGearSize GetAutoFitSize(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.
autoFitMode
The auto fit mode.

Return Value

ImageGear.Core.ImGearSize value with necessary dimensions of the mark's bounds.
Remarks
Calculated bounding box size depends on the autoFitMode. Possible values are:
  • ImGearARTTextAutoFitMode.AdjustHeight - in this mode the width remains unchanged, the height is adjusted to fit entire text without clipping.
  • ImGearARTTextAutoFitMode.AdjustWidth - in this mode the height remains unchanged, the width is adjusted to fit the widest text line without clipping from the right.
  • ImGearARTTextAutoFitMode.AdjustHeight | ImGearARTTextAutoFitMode.AdjustWidth - in this mode both height and width are adjusted to fit entire text without clipping.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


GetOverflowedTextLength Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : GetOverflowedTextLength Method
The page view control that contains text mark.
The page display of the page view control.
Calculates the number of characters that do not completely fit into displayable area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOverflowedTextLength( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay _
) As Integer
'Usage

Dim instance As ImGearARTNote
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim value As Integer

value = instance.GetOverflowedTextLength(pageView, pageDisplay)
public int GetOverflowedTextLength(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay
)
public: int GetOverflowedTextLength(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay
)
public:
int GetOverflowedTextLength(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.

Return Value

The number of not fully displayable characters, 0 otherwise.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


GetRenderBounds Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTNote
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Move Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTNote
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Rotate Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTNote
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Rotate Method


Scale Method (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTNote
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTNote Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTNote Class

For a list of all members of this type, see ImGearARTNote members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text of the mark.
Public Property | FontSize | Gets or sets the font size of the text of the mark.
Public Property | FontStyleART | Gets or sets the font style of the text of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the note mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTNote Class
ImageGear.ART Namespace


Bounds Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTNote
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
ImGearRectangle Structure


FillColor Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTNote
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
ImGearRGBQuad Structure


FontDisablePPM Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTNote
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


FontName Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : FontName Property
Gets or sets the font name of the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTNote
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


FontSize Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : FontSize Property
Gets or sets the font size of the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTNote
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


FontStyleART Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : FontStyleART Property
Gets or sets the font style of the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTNote
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Height Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTNote
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


SelectionType Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTNote
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Text Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Text Property
Gets or sets the text of the note mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTNote
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


TextColor Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTNote
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
ImGearRGBQuad Structure


Type Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTNote
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTNote)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTNote
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Visible Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTNote
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Width Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTNote
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


X Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTNote
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


Y Property (ImGearARTNote)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTNote Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTNote
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

ImGearARTPage Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPage Class
Represents a collection of annotation groups.
Object Model
ImGearARTPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPage
   Inherits ImageGear.Display.ImGearAnnotationPage
   Implements IImGearARTMarkIDEnumerable
'Usage

Dim instance As ImGearARTPage
public class ImGearARTPage : ImageGear.Display.ImGearAnnotationPage, IImGearARTMarkIDEnumerable
public __gc class ImGearARTPage : public ImageGear.Display.ImGearAnnotationPage, IImGearARTMarkIDEnumerable
public ref class ImGearARTPage : public ImageGear.Display.ImGearAnnotationPage, IImGearARTMarkIDEnumerable
Remarks
This class provides methods and properties for accessing to annotation groups and individual marks on the page.

ImGearARTPage is completely independent from ImageGear.Core.ImGearPage class and can be associated with one or more ImageGear.Core.ImGearPage class objects.

Example
  • C#
// Build a list of selected marks.
ArrayList igARTMarks = new ArrayList();
ImGearARTPage igARTPage = (pageView.Display.ARTPage as ImGearARTPage);
foreach (ImGearARTMark igARTMark in igARTPage)
{

    if (igARTPage.MarkIsSelected(igARTMark))
        igARTMarks.Add(igARTMark);
}
// Delete the marks.
igARTPage.RemoveMarks(igARTMarks);
// Redraw the view.
pageView.Update();
  • Visual Basic
' Build a list of selected marks.
Dim igARTMarks As New ArrayList()
Dim igARTPage As ImGearARTPage = TryCast(pageView.Display.ARTPage, ImGearARTPage)
For Each igARTMark As ImGearARTMark In igARTPage

    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTMarks.Add(igARTMark)
    End If
Next
' Delete the marks.
igARTPage.RemoveMarks(igARTMarks)
' Redraw the view.
pageView.Update()
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearAnnotationPage
ImageGear.ART.ImGearARTPage

See Also

Reference

ImGearARTPage Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPage Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPage Class

The following tables list the members exposed by ImGearARTPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPage Constructor | Initializes a new instance of the ImGearARTPage class object.
Top
Public Properties
 | Name | Description
Public Property | AccessController | Gets or sets access controller for this page.
Public Property | AspectKind | Gets or sets a value indicating the aspect kind.
Public Property | Author | Gets or sets the author for the page.
Public Property | Bounds | Gets or sets the bounding rectangle of the annotation page.
Public Property | Comments | Gets or sets the comments for the page.
Public Property | Groups | Gets an array of annotation groups in the page.
Public Property | History | Gets the history object.
Public Property | MarkCount | Gets the marks count in the page.
Public Property | MarksChanged | Gets or sets a value indicating whether the marks changed since they were last saved or loaded.
Public Property | Orientation | Gets or sets the orientation of the annotation page layout.
Public Property | PasteCount | Gets the number of marks currently in the Windows clipboard.
Public Property | PopupTextIcon | Gets or sets the icon associated with the ImGearARTPopupText annotation.
Public Property | Resolution | Gets or sets the resolution, used by ImGearARTRuler and ImGearARTPolyRuler annotations for measurement purposes.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | StartIndex | Gets or sets the start index of the marks enumeration on the page.
Public Property | Subject | Gets or sets the subject for the page.
Public Property | Title | Gets or sets the title for the page.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the page.
Top
Public Methods
 | Name | Description
Public Method | AddMark | Overloaded. Adds the specified mark into an annotation page group.
Public Method | ApplyToImage | Applies the encryption marks from the annotation page to the image.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
Public Method | CopyMarks | Overloaded. Copies specified marks to the Windows clipboard.
Public Method | CutMarks | Overloaded. Cuts specified marks from the annotation page to the Windows clipboard.
Public Method | Flip | Flips entire ART page around the center in vertical or horizontal direction.
Public Method | GetEnumerator | Gets the page enumerator class.
Public Method | HitTest | Returns the index of topmost annotation mark of a hit test.
Public Method | MarkBringToFront | Overloaded. Moves the specified mark to the top of Z-Order.
Public Method | MarkCopy | Overloaded. Copies the specified mark to the Windows clipboard.
Public Method | MarkCut | Overloaded. Cuts the mark from the annotation page to the Windows clipboard.
Public Method | MarkGet | Gets a mark by its ID.
Public Method | MarkIsSelected | Overloaded. Checks if the specified mark is selected.
Public Method | MarkIsValid | Overloaded. Checks if the mark is valid.
Public Method | MarkRemove | Overloaded. Deletes the mark.
Public Method | MarkSelect | Overloaded. Selects or deselects the specified mark.
Public Method | MarkSendToBack | Overloaded. Moves the specified mark to the bottom of Z-Order.
Public Method | MarkSetCoordType | Overloaded. Sets new type of the coordinates system for the specified mark.
Public Method | PasteMarks | Pastes all marks from the Windows clipboard to the annotation page.
Public Method | RemoveMarks | Overloaded. Deletes marks from the annotation page.
Public Method | Rotate | Rotates entire ART page around the center.
Public Method | Scale | Scales the entire ART page in horizontal and vertical directions.
Public Method | SelectMarks | Selects or deselects all marks in the annotation page.
Public Method | SetCoordType | Sets new type of the coordinates system for the entire mark collection.
Top
Protected Methods
 | Name | Description
Protected Method | OnMarkAdded | Occurs when a mark is added.
Protected Method | OnMarkChanged | Occurs when a mark is changed.
Protected Method | OnMarkRemoved | Occurs when a mark is removed.
Protected Method | OnMarkSelectionChanged | Occurs when a mark's selection is changed.
Protected Method | OnMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top
Public Events
 | Name | Description
Public Event | MarkAdded | Occurs when a mark is added.
Public Event | MarkChanged | Occurs when a mark is changed.
Public Event | MarkRemoved | Occurs when a mark is removed.
Public Event | MarkSelectionChanged | Occurs when a mark's selection is changed.
Public Event | MarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top
See Also

Reference

ImGearARTPage Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPage Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : ImGearARTPage Constructor
Initializes a new instance of the ImGearARTPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTPage()
public ImGearARTPage()
public: ImGearARTPage();
public:
ImGearARTPage();
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%% $$Methods$$

ImGearARTPage Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPage Class

For a list of all members of this type, see ImGearARTPage members.

Public Methods
 | Name | Description
Public Method | AddMark | Overloaded. Adds the specified mark into an annotation page group.
Public Method | ApplyToImage | Applies the encryption marks from the annotation page to the image.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
Public Method | CopyMarks | Overloaded. Copies specified marks to the Windows clipboard.
Public Method | CutMarks | Overloaded. Cuts specified marks from the annotation page to the Windows clipboard.
Public Method | Flip | Flips entire ART page around the center in vertical or horizontal direction.
Public Method | GetEnumerator | Gets the page enumerator class.
Public Method | HitTest | Returns the index of topmost annotation mark of a hit test.
Public Method | MarkBringToFront | Overloaded. Moves the specified mark to the top of Z-Order.
Public Method | MarkCopy | Overloaded. Copies the specified mark to the Windows clipboard.
Public Method | MarkCut | Overloaded. Cuts the mark from the annotation page to the Windows clipboard.
Public Method | MarkGet | Gets a mark by its ID.
Public Method | MarkIsSelected | Overloaded. Checks if the specified mark is selected.
Public Method | MarkIsValid | Overloaded. Checks if the mark is valid.
Public Method | MarkRemove | Overloaded. Deletes the mark.
Public Method | MarkSelect | Overloaded. Selects or deselects the specified mark.
Public Method | MarkSendToBack | Overloaded. Moves the specified mark to the bottom of Z-Order.
Public Method | MarkSetCoordType | Overloaded. Sets new type of the coordinates system for the specified mark.
Public Method | PasteMarks | Pastes all marks from the Windows clipboard to the annotation page.
Public Method | RemoveMarks | Overloaded. Deletes marks from the annotation page.
Public Method | Rotate | Rotates entire ART page around the center.
Public Method | Scale | Scales the entire ART page in horizontal and vertical directions.
Public Method | SelectMarks | Selects or deselects all marks in the annotation page.
Public Method | SetCoordType | Sets new type of the coordinates system for the entire mark collection.
Top
Protected Methods
 | Name | Description
Protected Method | OnMarkAdded | Occurs when a mark is added.
Protected Method | OnMarkChanged | Occurs when a mark is changed.
Protected Method | OnMarkRemoved | Occurs when a mark is removed.
Protected Method | OnMarkSelectionChanged | Occurs when a mark's selection is changed.
Protected Method | OnMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top
See Also

Reference

ImGearARTPage Class
ImageGear.ART Namespace


AddMark Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : AddMark Method
Adds the specified mark into an annotation page group.
Overload List
Overload | Description
AddMark(ImGearARTMark,ImGearARTCoordinatesType,String) | Adds the specified mark into the annotation page group specified by name.
AddMark(ImGearARTMark,ImGearARTCoordinatesType,Int32) | Adds the specified mark into the annotation page group specified by index.
AddMark(ImGearARTMark,ImGearARTCoordinatesType) | Adds the specified mark into default annotation page group.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


AddMark(ImGearARTMark,ImGearARTCoordinatesType,String) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > AddMark Method : AddMark(ImGearARTMark,ImGearARTCoordinatesType,String) Method
Reference to the mark to add.
Type of the coordinate system the mark coordinates are specified in.
Name of the group to add the mark to.
Adds the specified mark into the annotation page group specified by name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddMark( _
   ByVal mark As ImGearARTMark, _
   ByVal type As ImGearARTCoordinatesType, _
   ByVal groupName As String _
) As Integer
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim type As ImGearARTCoordinatesType
Dim groupName As String
Dim value As Integer

value = instance.AddMark(mark, type, groupName)
public int AddMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type,
   string groupName
)
public: int AddMark(
   ImGearARTMark* mark,
   ImGearARTCoordinatesType type,
   string* groupName
)
public:
int AddMark(
   ImGearARTMark^ mark,
   ImGearARTCoordinatesType type,
   String^ groupName
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupName
Name of the group to add the mark to.

Return Value

Integer value.
Remarks
You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Please make sure the mark does not have parent group (i.e. ImGearARTMark.ParentGroup is null), otherwise ImageGear.Core.ImGearException will be thrown. If the mark to be added already has parent group, please clone it prior to adding to the page.

Example
  • C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();
  • Visual Basic
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class
ImGearARTCoordinatesType Enumeration


AddMark(ImGearARTMark,ImGearARTCoordinatesType,Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > AddMark Method : AddMark(ImGearARTMark,ImGearARTCoordinatesType,Int32) Method
Reference to the mark to add.
Type of the coordinate system the mark coordinates are specified in.
Index of the group to add the mark to.
Adds the specified mark into the annotation page group specified by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddMark( _
   ByVal mark As ImGearARTMark, _
   ByVal type As ImGearARTCoordinatesType, _
   ByVal groupIndex As Integer _
) As Integer
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim type As ImGearARTCoordinatesType
Dim groupIndex As Integer
Dim value As Integer

value = instance.AddMark(mark, type, groupIndex)
public int AddMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type,
   int groupIndex
)
public: int AddMark(
   ImGearARTMark* mark,
   ImGearARTCoordinatesType type,
   int groupIndex
)
public:
int AddMark(
   ImGearARTMark^ mark,
   ImGearARTCoordinatesType type,
   int groupIndex
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupIndex
Index of the group to add the mark to.

Return Value

Integer value.
Remarks
You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Please make sure the mark does not have parent group (i.e. ImGearARTMark.ParentGroup is null), otherwise ImageGear.Core.ImGearException will be thrown. If the mark to be added already has parent group, please clone it prior to adding to the page.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class
ImGearARTCoordinatesType Enumeration


AddMark(ImGearARTMark,ImGearARTCoordinatesType) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > AddMark Method : AddMark(ImGearARTMark,ImGearARTCoordinatesType) Method
Reference to the mark to add.
Type of the coordinate system the mark coordinates are specified in.
Adds the specified mark into default annotation page group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddMark( _
   ByVal mark As ImGearARTMark, _
   ByVal type As ImGearARTCoordinatesType _
) As Integer
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim type As ImGearARTCoordinatesType
Dim value As Integer

value = instance.AddMark(mark, type)
public int AddMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type
)
public: int AddMark(
   ImGearARTMark* mark,
   ImGearARTCoordinatesType type
)
public:
int AddMark(
   ImGearARTMark^ mark,
   ImGearARTCoordinatesType type
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.

Return Value

Integer value.
Remarks
You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Please make sure the mark does not have parent group (i.e. ImGearARTMark.ParentGroup is null), otherwise ImageGear.Core.ImGearException will be thrown. If the mark to be added already has parent group, please clone it prior to adding to the page.

Example
  • C#
// Setup rectangle for new annotation.
ImGearRectangle igRectangle = new ImGearRectangle(0,0,200,20);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the annotation.
ImGearARTTypedText igARTTypedText = new ImGearARTTypedText(
    igRectangle, "Test Typed Text Annotation", igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
'Setup rectangle for new annotation.
Dim igRectangle As ImGearRectangle = New ImGearRectangle(0, 0, 200, 20)
'Setup color for annotation.
Dim igRGBQuad As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)
'Create the annotation.
Dim igARTTypedText As ImGearARTTypedText = New ImGearARTTypedText( _
        igRectangle, "Test Typed Text Annotation", igRGBQuad _
        )
'Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class
ImGearARTCoordinatesType Enumeration


ApplyToImage Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : ApplyToImage Method
Image page to apply the encryption marks to.
Applies the encryption marks from the annotation page to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ApplyToImage( _
   ByVal image As ImGearPage _
)
'Usage

Dim instance As ImGearARTPage
Dim image As ImGearPage

instance.ApplyToImage(image)
public void ApplyToImage(
   ImGearPage image
)
public: void ApplyToImage(
   ImGearPage* image
)
public:
void ApplyToImage(
   ImGearPage^ image
)

Parameters

image
Image page to apply the encryption marks to.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


ConvertCoordinates Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Overload List
Overload | Description
ConvertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
ConvertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


ConvertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,Array) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,Array) Method
IImGearScrollableView interface of the page view control.
PageDisplay associated with the page view control.
Graphics object used for drawing.
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
Array of ImGearPoint or ImGearDoublePoint elements to convert.
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay, _
   ByVal graphics As Graphics, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal points As Array _
)
'Usage

Dim instance As ImGearARTPage
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim graphics As Graphics
Dim mode As ImGearCoordConvModes
Dim points As Array

instance.ConvertCoordinates(pageView, pageDisplay, graphics, mode, points)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay,
   Graphics graphics,
   ImGearCoordConvModes mode,
   Array points
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay,
   Graphics* graphics,
   ImGearCoordConvModes mode,
   Array* points
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay,
   Graphics^ graphics,
   ImGearCoordConvModes mode,
   Array^ points
)

Parameters

pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
graphics
Graphics object used for drawing.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.
Remarks
The conversion depends on mode parameter and taks into account the annotation page orientation.
Example
  • C#
// Create array for use of ConvertCoordinates method.
ImGearPoint[] igPoints = new ImGearPoint[1];
// Setup location for the point based on display coordinates,
//  often received from mouse events.
igPoints[0] = new ImGearPoint(100, 100);
// Convert point from display coordinates to image coordinates.
igARTPage.ConvertCoordinates(
    igPageView, igPageView.Display, igPageView.CreateGraphics(),
    ImGearCoordConvModes.DEVICE_TO_IMAGE, igPoints
);
// Setup color for the point.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the point annotation with a width of 10 and 60% opacity
ImGearARTPoint igARTPoint = new ImGearARTPoint(
    igPoints[0], igRGBQuad, 10, (int)(0.60 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
'Create array for use of ConvertCoordinates function.
Dim igPoints As ImGearPoint() = New ImGearPoint(0) {}
' Setup location for the point based on display coordinates,
'  often received from mouse events.
igPoints(0) = New ImGearPoint(100, 100)
' Convert point from display coordinates to image coordinates.
igARTPage.ConvertCoordinates(igPageView, igPageView.Display, igPageView.CreateGraphics(), _
 ImGearCoordConvModes.DEVICE_TO_IMAGE, igPoints)
' Setup color for the point.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the point annotation with a width of 10 and 60% opacity
Dim igARTPoint As New ImGearARTPoint(igPoints(0), igRGBQuad, 10, CInt((0.6 * 255)))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
IImGearScrollableView Interface
IImGearPageDisplay Interface
ImGearCoordConvModes Enumeration


ConvertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,Array) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,Array) Method
IImGearScrollableView interface of the page view control.
PageDisplay associated with the page view control.
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
Array of ImGearPoint or ImGearDoublePoint elements to convert.
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal points As Array _
)
'Usage

Dim instance As ImGearARTPage
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim mode As ImGearCoordConvModes
Dim points As Array

instance.ConvertCoordinates(pageView, pageDisplay, mode, points)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearCoordConvModes mode,
   Array points
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearCoordConvModes mode,
   Array* points
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearCoordConvModes mode,
   Array^ points
)

Parameters

pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.
Remarks
The conversion depends on mode parameter and taks into account the annotation page orientation.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
IImGearScrollableView Interface
IImGearPageDisplay Interface
ImGearCoordConvModes Enumeration


CopyMarks Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : CopyMarks Method
Copies specified marks to the Windows clipboard.
Overload List
Overload | Description
CopyMarks(ArrayList) | Copies collection of specified marks to the Windows clipboard.
CopyMarks(Int32[]) | Copies array of specified marks to the Windows clipboard.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


CopyMarks(ArrayList) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > CopyMarks Method : CopyMarks(ArrayList) Method
Collection of marks to copy.
Copies collection of specified marks to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CopyMarks( _
   ByVal marks As ArrayList _
)
'Usage

Dim instance As ImGearARTPage
Dim marks As ArrayList

instance.CopyMarks(marks)
public void CopyMarks(
   ArrayList marks
)
public: void CopyMarks(
   ArrayList* marks
)
public:
void CopyMarks(
   ArrayList^ marks
)

Parameters

marks
Collection of marks to copy.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
Example
  • C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i)
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Copy the marks from the page to the clipboard.
igARTPage.CopyMarks(igARTMarkList);
// Move all the marks
foreach (ImGearARTMark igARTMark in igARTPage)
{
    igARTMark.Move(50, 50);
}
//Paste the original marks back onto the page.
igARTPage.PasteMarks();
  • Visual Basic
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Copy the marks from the page to the clipboard.
igARTPage.CopyMarks(igARTMarkList)
' Move all the marks
For Each igARTMark As ImGearARTMark In igARTPage
    igARTMark.Move(50, 50)
Next
'Paste the original marks back onto the page.
igARTPage.PasteMarks()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


CopyMarks(Int32[]) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > CopyMarks Method : CopyMarks(Int32[]) Method
Array of mark IDs to copy.
Copies array of specified marks to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CopyMarks( _
   ByVal marksIds() As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim marksIds() As Integer

instance.CopyMarks(marksIds)
public void CopyMarks(
   int[] marksIds
)
public: void CopyMarks(
   int[]* marksIds
)
public:
void CopyMarks(
   array<int>^ marksIds
)

Parameters

marksIds
Array of mark IDs to copy.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


CutMarks Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : CutMarks Method
Cuts specified marks from the annotation page to the Windows clipboard.
Overload List
Overload | Description
CutMarks(ArrayList) | Cuts collection of specified marks from the annotation page to the Windows clipboard.
CutMarks(Int32[]) | Cuts array of specified marks from the annotation page to the Windows clipboard.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


CutMarks(ArrayList) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > CutMarks Method : CutMarks(ArrayList) Method
Collection of marks to cut.
Cuts collection of specified marks from the annotation page to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CutMarks( _
   ByVal marks As ArrayList _
)
'Usage

Dim instance As ImGearARTPage
Dim marks As ArrayList

instance.CutMarks(marks)
public void CutMarks(
   ArrayList marks
)
public: void CutMarks(
   ArrayList* marks
)
public:
void CutMarks(
   ArrayList^ marks
)

Parameters

marks
Collection of marks to cut.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
Example
  • C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();
  • Visual Basic
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


CutMarks(Int32[]) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > CutMarks Method : CutMarks(Int32[]) Method
Array of mark IDs to cut.
Cuts array of specified marks from the annotation page to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CutMarks( _
   ByVal markIds() As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markIds() As Integer

instance.CutMarks(markIds)
public void CutMarks(
   int[] markIds
)
public: void CutMarks(
   int[]* markIds
)
public:
void CutMarks(
   array<int>^ markIds
)

Parameters

markIds
Array of mark IDs to cut.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


Flip Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Flip Method
The center point, around which to flip the page.
Flip direction.
Flips entire ART page around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPage
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)

Parameters

center
The center point, around which to flip the page.
flipMode
Flip direction.
Remarks
Note: The center parameter must be provided in the same coordinate system, as the marks were created and added to the ART page (image or device).
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


GetEnumerator Method (ImGearARTPage)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : GetEnumerator Method
Gets the page enumerator class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As ImGearARTPageEnumerator
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTPageEnumerator

value = instance.GetEnumerator()
public ImGearARTPageEnumerator GetEnumerator()
public: ImGearARTPageEnumerator* GetEnumerator();
public:
ImGearARTPageEnumerator^ GetEnumerator();

Return Value

ImGearARTPageEnumerator class object.
Example
  • C#
// Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
//  to get a ImGearARTPageEnumerator which is used for the foreach.
foreach( ImGearARTMark igARTMark in igARTPage)
{
    //Move the art mark.
    igARTMark.Move(50, 50);
}
  • Visual Basic
' Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
'  to get a ImGearARTPageEnumerator which is used for the foreach.
For Each igARTMark As ImGearARTMark In igARTPage
    'Move the art mark.
    igARTMark.Move(50, 50)
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearARTPageEnumerator Class


HitTest Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : HitTest Method
Returns the index of topmost annotation mark of a hit test.
Overload List
Overload | Description
HitTest | Returns the index of topmost annotation mark of a hit test.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


HitTest(ImGearPoint,IImGearScrollableView,ImGearPageDisplay,Graphics,Int32,Int32) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : HitTest(ImGearPoint,IImGearScrollableView,ImGearPageDisplay,Graphics,Int32,Int32) Method
Screen point to test.
PageView control that contains the marks.
PageDisplay associated with PageView control.
System graphics.
Offset from left.
Offset from top.
Returns the index of topmost annotation mark of a hit test.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function HitTest( _
   ByVal devicePoint As ImGearPoint, _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay, _
   ByVal graphics As Graphics, _
   ByVal offsetLeft As Integer, _
   ByVal offsetTop As Integer _
) As Integer
'Usage

Dim instance As ImGearARTPage
Dim devicePoint As ImGearPoint
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim graphics As Graphics
Dim offsetLeft As Integer
Dim offsetTop As Integer
Dim value As Integer

value = instance.HitTest(devicePoint, pageView, pageDisplay, graphics, offsetLeft, offsetTop)
public int HitTest(
   ImGearPoint devicePoint,
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay,
   Graphics graphics,
   int offsetLeft,
   int offsetTop
)
public: int HitTest(
   ImGearPoint devicePoint,
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay,
   Graphics* graphics,
   int offsetLeft,
   int offsetTop
)
public:
int HitTest(
   ImGearPoint devicePoint,
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay,
   Graphics^ graphics,
   int offsetLeft,
   int offsetTop
)

Parameters

devicePoint
Screen point to test.
pageView
PageView control that contains the marks.
pageDisplay
PageDisplay associated with PageView control.
graphics
System graphics.
offsetLeft
Offset from left.
offsetTop
Offset from top.

Return Value

Integer value.
Remarks
Returns the index of the mark located at the screen position [x, y]. If there are no marks at [x,y], the return value from this method is -1.
Example
  • C#
// Within a MouseDown event where e.X and e.Y are coordinates
// relative to the page view control:

// Create point parameter for current mouse position.
ImGearPoint igPoint = new ImGearPoint(e.X, e.Y);
// Get the Graphics object for the current PageView.
Graphics igGraphics = imGearPageView1.CreateGraphics();
// Run HitTest on current position getting the top most mark.
int markID = igARTPage.HitTest(igPoint, imGearPageView1,
    imGearPageView1.Display, igGraphics, 0, 0);
// Check if any mark was found.
if (markID >= 0)
{
    // Select the mark found at the hit test.
    igARTPage.MarkSelect(markID, true);
    // Update the page view.
    imGearPageView1.Invalidate();
}
  • Visual Basic
' Within a MouseDown event where e.X and e.Y are coordinates
' relative to the page view control:

' Create point parameter for current mouse position.
Dim igPoint As ImGearPoint = New ImGearPoint(e.X, e.Y)
' Get the Graphics object for the current PageView.
Dim igGraphics As Graphics = ImGearPageView1.CreateGraphics()
' Run HitTest on current position getting the top most mark.
Dim markID As Integer = igARTPage.HitTest(igPoint, ImGearPageView1, _
 ImGearPageView1.Display, igGraphics, 0, 0)
' Check if any mark was found.
If (markID >= 0) Then
    ' Select the mark found at the hit test.
    igARTPage.MarkSelect(markID, True)
    ' Update the page view.
    ImGearPageView1.Invalidate()
End If
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearPoint Structure
IImGearScrollableView Interface
ImGearPageDisplay Class


MarkBringToFront Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkBringToFront Method
Moves the specified mark to the top of Z-Order.
Overload List
Overload | Description
MarkBringToFront(ImGearARTMark) | Moves the specified mark to the top of Z-Order.
MarkBringToFront(Int32) | Moves the mark specified by ID to the top of Z-Order.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkBringToFront(ImGearARTMark) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkBringToFront Method : MarkBringToFront(ImGearARTMark) Method
Mark to move.
Moves the specified mark to the top of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkBringToFront( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark

instance.MarkBringToFront(mark)
public void MarkBringToFront(
   ImGearARTMark mark
)
public: void MarkBringToFront(
   ImGearARTMark* mark
)
public:
void MarkBringToFront(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to move.
Example
  • C#
// Send any text marks true the back of the z order, and line marks to the front.
foreach (ImGearARTMark igARTMark in igARTPage.Groups[0])
{
    if (igARTMark is ImGearARTText)
        igARTPage.MarkSendToBack(igARTMark);
    else if (igARTMark is ImGearARTLine)
        igARTPage.MarkBringToFront(igARTMark);
}
  • Visual Basic
' Send any text marks true the back of the z order, and line marks to the front.
For Each igARTMark As ImGearARTMark In igARTPage.Groups(0)
    If TypeOf igARTMark Is ImGearARTText Then
        igARTPage.MarkSendToBack(igARTMark)
    ElseIf TypeOf igARTMark Is ImGearARTLine Then
        igARTPage.MarkBringToFront(igARTMark)
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkBringToFront(Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkBringToFront Method : MarkBringToFront(Int32) Method
ID of the mark to move.
Moves the mark specified by ID to the top of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkBringToFront( _
   ByVal markId As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer

instance.MarkBringToFront(markId)
public void MarkBringToFront(
   int markId
)
public: void MarkBringToFront(
   int markId
)
public:
void MarkBringToFront(
   int markId
)

Parameters

markId
ID of the mark to move.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkCopy Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkCopy Method
Copies the specified mark to the Windows clipboard.
Overload List
Overload | Description
MarkCopy(ImGearARTMark) | Copies the specified mark to the Windows clipboard.
MarkCopy(Int32) | Copies the specified mark to the Windows clipboard.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkCopy(ImGearARTMark) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkCopy Method : MarkCopy(ImGearARTMark) Method
Mark to copy.
Copies the specified mark to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkCopy( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark

instance.MarkCopy(mark)
public void MarkCopy(
   ImGearARTMark mark
)
public: void MarkCopy(
   ImGearARTMark* mark
)
public:
void MarkCopy(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to copy.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
Example
  • C#
// Copy first mark found to be selected to the clipboard
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
    {
        igARTPage.MarkCopy(igARTMark);
        break;
    }
}
  • Visual Basic
' Copy first mark found to be selected to the clipboard
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkCopy(igARTMark)
        Exit For
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkCopy(Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkCopy Method : MarkCopy(Int32) Method
ID of the mark to copy.
Copies the specified mark to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkCopy( _
   ByVal markId As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer

instance.MarkCopy(markId)
public void MarkCopy(
   int markId
)
public: void MarkCopy(
   int markId
)
public:
void MarkCopy(
   int markId
)

Parameters

markId
ID of the mark to copy.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkCut Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkCut Method
Cuts the mark from the annotation page to the Windows clipboard.
Overload List
Overload | Description
MarkCut(ImGearARTMark) | Cuts the specified mark from the annotation page to the Windows clipboard.
MarkCut(Int32) | Cuts the mark specified by ID from the annotation page to the Windows clipboard.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkCut(ImGearARTMark) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkCut Method : MarkCut(ImGearARTMark) Method
Mark to cut.
Cuts the specified mark from the annotation page to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkCut( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark

instance.MarkCut(mark)
public void MarkCut(
   ImGearARTMark mark
)
public: void MarkCut(
   ImGearARTMark* mark
)
public:
void MarkCut(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to cut.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
Example
  • C#
// Cut first mark found to be selected to the clipboard
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
    {
        igARTPage.MarkCut(igARTMark);
        break;
    }
}
  • Visual Basic
' Cut first mark found to be selected to the clipboard
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkCut(igARTMark)
        Exit For
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkCut(Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkCut Method : MarkCut(Int32) Method
ID of the mark to cut.
Cuts the mark specified by ID from the annotation page to the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkCut( _
   ByVal markId As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer

instance.MarkCut(markId)
public void MarkCut(
   int markId
)
public: void MarkCut(
   int markId
)
public:
void MarkCut(
   int markId
)

Parameters

markId
ID of the mark to cut.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkGet Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkGet Method
Mark's ID.
Gets a mark by its ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MarkGet( _
   ByVal markId As Integer _
) As ImGearARTMark
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer
Dim value As ImGearARTMark

value = instance.MarkGet(markId)
public ImGearARTMark MarkGet(
   int markId
)
public: ImGearARTMark* MarkGet(
   int markId
)
public:
ImGearARTMark^ MarkGet(
   int markId
)

Parameters

markId
Mark's ID.

Return Value

ImGearARTMark class object.
Example
  • C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();
  • Visual Basic
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearARTMark Class


MarkIsSelected Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkIsSelected Method
Checks if the specified mark is selected.
Overload List
Overload | Description
MarkIsSelected(ImGearARTMark) | Checks if the specified mark is selected.
MarkIsSelected(Int32) | Checks if the mark specified by ID is selected.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkIsSelected(ImGearARTMark) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkIsSelected Method : MarkIsSelected(ImGearARTMark) Method
The mark to check.
Checks if the specified mark is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function MarkIsSelected( _
   ByVal mark As ImGearARTMark _
) As Boolean
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim value As Boolean

value = instance.MarkIsSelected(mark)
public bool MarkIsSelected(
   ImGearARTMark mark
)
public: bool MarkIsSelected(
   ImGearARTMark* mark
)
public:
bool MarkIsSelected(
   ImGearARTMark^ mark
)

Parameters

mark
The mark to check.

Return Value

Returns true if the mark is selected, false - otherwise.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkIsSelected(Int32) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkIsSelected Method : MarkIsSelected(Int32) Method
ID of the mark to check.
Checks if the mark specified by ID is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function MarkIsSelected( _
   ByVal markId As Integer _
) As Boolean
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer
Dim value As Boolean

value = instance.MarkIsSelected(markId)
public bool MarkIsSelected(
   int markId
)
public: bool MarkIsSelected(
   int markId
)
public:
bool MarkIsSelected(
   int markId
)

Parameters

markId
ID of the mark to check.

Return Value

Returns true if the mark is selected, false - otherwise.
Example
  • C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}
  • Visual Basic
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkIsValid Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkIsValid Method
Checks if the mark is valid.
Overload List
Overload | Description
MarkIsValid(Int32) | Checks if the mark is valid.
MarkIsValid(ImGearARTMark) | Checks if the mark is valid.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkIsValid(Int32) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkIsValid Method : MarkIsValid(Int32) Method
ID of the mark to check.
Checks if the mark is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function MarkIsValid( _
   ByVal markId As Integer _
) As Boolean
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer
Dim value As Boolean

value = instance.MarkIsValid(markId)
public bool MarkIsValid(
   int markId
)
public: bool MarkIsValid(
   int markId
)
public:
bool MarkIsValid(
   int markId
)

Parameters

markId
ID of the mark to check.

Return Value

Returns true if the mark is valid, false - otherwise.
Example
  • C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();
  • Visual Basic
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkIsValid(ImGearARTMark) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkIsValid Method : MarkIsValid(ImGearARTMark) Method
Mark to check.
Checks if the mark is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function MarkIsValid( _
   ByVal mark As ImGearARTMark _
) As Boolean
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim value As Boolean

value = instance.MarkIsValid(mark)
public bool MarkIsValid(
   ImGearARTMark mark
)
public: bool MarkIsValid(
   ImGearARTMark* mark
)
public:
bool MarkIsValid(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to check.

Return Value

Returns true if the mark is valid, false - otherwise.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkRemove Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkRemove Method
Deletes the mark.
Overload List
Overload | Description
MarkRemove(Int32) | Deletes the mark.
MarkRemove(ImGearARTMark) | Deletes the mark.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkRemove(Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkRemove Method : MarkRemove(Int32) Method
ID of the mark to delete.
Deletes the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkRemove( _
   ByVal markId As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer

instance.MarkRemove(markId)
public void MarkRemove(
   int markId
)
public: void MarkRemove(
   int markId
)
public:
void MarkRemove(
   int markId
)

Parameters

markId
ID of the mark to delete.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkRemove(ImGearARTMark) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkRemove Method : MarkRemove(ImGearARTMark) Method
Mark to delete.
Deletes the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkRemove( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark

instance.MarkRemove(mark)
public void MarkRemove(
   ImGearARTMark mark
)
public: void MarkRemove(
   ImGearARTMark* mark
)
public:
void MarkRemove(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to delete.
Example
  • C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}
  • Visual Basic
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkSelect Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkSelect Method
Selects or deselects the specified mark.
Overload List
Overload | Description
MarkSelect(Int32,Boolean) | Selects or deselects the specified mark.
MarkSelect(ImGearARTMark,Boolean) | Selects or deselects the specified mark.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkSelect(Int32,Boolean) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSelect Method : MarkSelect(Int32,Boolean) Method
Mark ID to select or deselect.
Pass true to select the mark, false to deselect.
Selects or deselects the specified mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSelect( _
   ByVal markId As Integer, _
   ByVal state As Boolean _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer
Dim state As Boolean

instance.MarkSelect(markId, state)
public void MarkSelect(
   int markId,
   bool state
)
public: void MarkSelect(
   int markId,
   bool state
)
public:
void MarkSelect(
   int markId,
   bool state
)

Parameters

markId
Mark ID to select or deselect.
state
Pass true to select the mark, false to deselect.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkSelect(ImGearARTMark,Boolean) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSelect Method : MarkSelect(ImGearARTMark,Boolean) Method
Mark to select or deselect.
Pass true to select the mark, false to deselect.
Selects or deselects the specified mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSelect( _
   ByVal mark As ImGearARTMark, _
   ByVal state As Boolean _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim state As Boolean

instance.MarkSelect(mark, state)
public void MarkSelect(
   ImGearARTMark mark,
   bool state
)
public: void MarkSelect(
   ImGearARTMark* mark,
   bool state
)
public:
void MarkSelect(
   ImGearARTMark^ mark,
   bool state
)

Parameters

mark
Mark to select or deselect.
state
Pass true to select the mark, false to deselect.
Example
  • C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}
  • Visual Basic
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkSendToBack Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkSendToBack Method
Moves the specified mark to the bottom of Z-Order.
Overload List
Overload | Description
MarkSendToBack(ImGearARTMark) | Moves the specified mark to the bottom of Z-Order.
MarkSendToBack(Int32) | Moves the mark specified by ID to the bottom of Z-Order.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkSendToBack(ImGearARTMark) Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSendToBack Method : MarkSendToBack(ImGearARTMark) Method
Mark to move.
Moves the specified mark to the bottom of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSendToBack( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark

instance.MarkSendToBack(mark)
public void MarkSendToBack(
   ImGearARTMark mark
)
public: void MarkSendToBack(
   ImGearARTMark* mark
)
public:
void MarkSendToBack(
   ImGearARTMark^ mark
)

Parameters

mark
Mark to move.
Example
  • C#
// Send any text marks true the back of the z order, and line marks to the front.
foreach (ImGearARTMark igARTMark in igARTPage.Groups[0])
{
    if (igARTMark is ImGearARTText)
        igARTPage.MarkSendToBack(igARTMark);
    else if (igARTMark is ImGearARTLine)
        igARTPage.MarkBringToFront(igARTMark);
}
  • Visual Basic
' Send any text marks true the back of the z order, and line marks to the front.
For Each igARTMark As ImGearARTMark In igARTPage.Groups(0)
    If TypeOf igARTMark Is ImGearARTText Then
        igARTPage.MarkSendToBack(igARTMark)
    ElseIf TypeOf igARTMark Is ImGearARTLine Then
        igARTPage.MarkBringToFront(igARTMark)
    End If
Next
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTMark Class


MarkSendToBack(Int32) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSendToBack Method : MarkSendToBack(Int32) Method
ID of the mark to move.
Moves the mark specified by ID to the bottom of Z-Order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSendToBack( _
   ByVal markId As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer

instance.MarkSendToBack(markId)
public void MarkSendToBack(
   int markId
)
public: void MarkSendToBack(
   int markId
)
public:
void MarkSendToBack(
   int markId
)

Parameters

markId
ID of the mark to move.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


MarkSetCoordType Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkSetCoordType Method
Sets new type of the coordinates system for the specified mark.
Overload List
Overload | Description
MarkSetCoordType(Int32,ImGearARTCoordinatesType) | Sets new type of the coordinates system for the specified mark.
MarkSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) | Sets new type of the coordinates system for the specified mark.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkSetCoordType(Int32,ImGearARTCoordinatesType) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSetCoordType Method : MarkSetCoordType(Int32,ImGearARTCoordinatesType) Method
Index of the mark whose coordinates type is changed.
New type of the coordinate system.
Sets new type of the coordinates system for the specified mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSetCoordType( _
   ByVal markId As Integer, _
   ByVal type As ImGearARTCoordinatesType _
)
'Usage

Dim instance As ImGearARTPage
Dim markId As Integer
Dim type As ImGearARTCoordinatesType

instance.MarkSetCoordType(markId, type)
public void MarkSetCoordType(
   int markId,
   ImGearARTCoordinatesType type
)
public: void MarkSetCoordType(
   int markId,
   ImGearARTCoordinatesType type
)
public:
void MarkSetCoordType(
   int markId,
   ImGearARTCoordinatesType type
)

Parameters

markId
Index of the mark whose coordinates type is changed.
type
New type of the coordinate system.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTCoordinatesType Enumeration


MarkSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > MarkSetCoordType Method : MarkSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) Method
Mark whose coordinates type is changed.
New type of the coordinate system.
Sets new type of the coordinates system for the specified mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MarkSetCoordType( _
   ByVal mark As ImGearARTMark, _
   ByVal type As ImGearARTCoordinatesType _
)
'Usage

Dim instance As ImGearARTPage
Dim mark As ImGearARTMark
Dim type As ImGearARTCoordinatesType

instance.MarkSetCoordType(mark, type)
public void MarkSetCoordType(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type
)
public: void MarkSetCoordType(
   ImGearARTMark* mark,
   ImGearARTCoordinatesType type
)
public:
void MarkSetCoordType(
   ImGearARTMark^ mark,
   ImGearARTCoordinatesType type
)

Parameters

mark
Mark whose coordinates type is changed.
type
New type of the coordinate system.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List
ImGearARTCoordinatesType Enumeration
ImGearARTMark Class


OnMarkAdded Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : OnMarkAdded Method
Event arguments.
Occurs when a mark is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkAdded( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPage
Dim e As ImGearARTMarkEventArgs

instance.OnMarkAdded(e)
protected void OnMarkAdded(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkAdded(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkAdded(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


OnMarkChanged Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : OnMarkChanged Method
Event arguments.
Occurs when a mark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPage
Dim e As ImGearARTMarkEventArgs

instance.OnMarkChanged(e)
protected void OnMarkChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


OnMarkRemoved Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : OnMarkRemoved Method
Event arguments.
Occurs when a mark is removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPage
Dim e As ImGearARTMarkEventArgs

instance.OnMarkRemoved(e)
protected void OnMarkRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


OnMarkSelectionChanged Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : OnMarkSelectionChanged Method
Event arguments.
Occurs when a mark's selection is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkSelectionChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPage
Dim e As ImGearARTMarkEventArgs

instance.OnMarkSelectionChanged(e)
protected void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


OnMarkZOrderChanged Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : OnMarkZOrderChanged Method
Event arguments.
Occurs when a mark's Z-Order is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkZOrderChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPage
Dim e As ImGearARTMarkEventArgs

instance.OnMarkZOrderChanged(e)
protected void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


PasteMarks Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : PasteMarks Method
Pastes all marks from the Windows clipboard to the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PasteMarks()
'Usage

Dim instance As ImGearARTPage

instance.PasteMarks()
public void PasteMarks()
public: void PasteMarks();
public:
void PasteMarks();
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
Example
  • C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();
  • Visual Basic
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


RemoveMarks Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : RemoveMarks Method
Deletes marks from the annotation page.
Overload List
Overload | Description
RemoveMarks() | Deletes all marks from the annotation page.
RemoveMarks(ArrayList) | Deletes collection of specified marks from the annotation page.
RemoveMarks(Int32[]) | Deletes array of specified marks from the annotation page.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


RemoveMarks() Method
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > RemoveMarks Method : RemoveMarks() Method
Deletes all marks from the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RemoveMarks()
'Usage

Dim instance As ImGearARTPage

instance.RemoveMarks()
public void RemoveMarks()
public: void RemoveMarks();
public:
void RemoveMarks();
Remarks
The method also deletes all Groups groups of the annotation page and resets following properties to their default values:
  • Orientation
  • MarksChanged
  • Bounds
Example
  • C#
ImGearPage igPage;
// Load an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test1_art.tif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Load the ImGearARTPage from the metadata in the ImGearPage.
ImGearARTPage igARTPage = ImGearART.LoadPage(igPage);
// Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.ALL, null);
imGearPageView1.Page = igPage;
// Clear the annotations from the art page.
igARTPage.RemoveMarks();
// Update the Display with the new ARTPage.
if (igARTPage != null)
    imGearPageView1.Display.ARTPage = igARTPage;
  • Visual Basic
Dim igPage As ImGearPage
' Load an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test1_art.tif", FileMode.Open)
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Load the ImGearARTPage from the metadata in the ImGearPage.
Dim igARTPage As ImGearARTPage = ImGearART.LoadPage(igPage)
' Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.ALL, Nothing)
ImGearPageView1.Page = igPage
' Clear the annotations from the art page.
igARTPage.RemoveMarks()
' Update the Display with the new ARTPage.
If igARTPage IsNot Nothing Then
    ImGearPageView1.Display.ARTPage = igARTPage
End If
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


RemoveMarks(ArrayList) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > RemoveMarks Method : RemoveMarks(ArrayList) Method
Collection of marks to delete.
Deletes collection of specified marks from the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RemoveMarks( _
   ByVal marks As ArrayList _
)
'Usage

Dim instance As ImGearARTPage
Dim marks As ArrayList

instance.RemoveMarks(marks)
public void RemoveMarks(
   ArrayList marks
)
public: void RemoveMarks(
   ArrayList* marks
)
public:
void RemoveMarks(
   ArrayList^ marks
)

Parameters

marks
Collection of marks to delete.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


RemoveMarks(Int32[]) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class > RemoveMarks Method : RemoveMarks(Int32[]) Method
Array of mark IDs to delete.
Deletes array of specified marks from the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RemoveMarks( _
   ByVal marksIds() As Integer _
)
'Usage

Dim instance As ImGearARTPage
Dim marksIds() As Integer

instance.RemoveMarks(marksIds)
public void RemoveMarks(
   int[] marksIds
)
public: void RemoveMarks(
   int[]* marksIds
)
public:
void RemoveMarks(
   array<int>^ marksIds
)

Parameters

marksIds
Array of mark IDs to delete.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


Rotate Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Rotate Method
The center point, around which to rotate the page.
Rotation angle.
Rotates entire ART page around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationValue As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPage
Dim center As ImGearPoint
Dim rotationValue As ImGearRotationValues

instance.Rotate(center, rotationValue)
public void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationValue
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationValue
)
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationValue
)

Parameters

center
The center point, around which to rotate the page.
rotationValue
Rotation angle.
Remarks
Note: The center parameter must be provided in the same coordinate system, as the marks were created and added to the ART page (image or device).
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Scale Method (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the entire ART page in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPage
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
)
public:
void Scale(
   double scaleX,
   double scaleY
)

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


SelectMarks Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : SelectMarks Method
Pass true to select all marks in the page, false to deselect.
Selects or deselects all marks in the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectMarks( _
   ByVal state As Boolean _
)
'Usage

Dim instance As ImGearARTPage
Dim state As Boolean

instance.SelectMarks(state)
public void SelectMarks(
   bool state
)
public: void SelectMarks(
   bool state
)
public:
void SelectMarks(
   bool state
)

Parameters

state
Pass true to select all marks in the page, false to deselect.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


SetCoordType Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : SetCoordType Method
New type of the coordinate system.
Sets new type of the coordinates system for the entire mark collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCoordType( _
   ByVal type As ImGearARTCoordinatesType _
)
'Usage

Dim instance As ImGearARTPage
Dim type As ImGearARTCoordinatesType

instance.SetCoordType(type)
public void SetCoordType(
   ImGearARTCoordinatesType type
)
public: void SetCoordType(
   ImGearARTCoordinatesType type
)
public:
void SetCoordType(
   ImGearARTCoordinatesType type
)

Parameters

type
New type of the coordinate system.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearARTCoordinatesType Enumeration


%%PageItemTitle%% $$Properties$$

ImGearARTPage Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPage Class

For a list of all members of this type, see ImGearARTPage members.

Public Properties
 | Name | Description
Public Property | AccessController | Gets or sets access controller for this page.
Public Property | AspectKind | Gets or sets a value indicating the aspect kind.
Public Property | Author | Gets or sets the author for the page.
Public Property | Bounds | Gets or sets the bounding rectangle of the annotation page.
Public Property | Comments | Gets or sets the comments for the page.
Public Property | Groups | Gets an array of annotation groups in the page.
Public Property | History | Gets the history object.
Public Property | MarkCount | Gets the marks count in the page.
Public Property | MarksChanged | Gets or sets a value indicating whether the marks changed since they were last saved or loaded.
Public Property | Orientation | Gets or sets the orientation of the annotation page layout.
Public Property | PasteCount | Gets the number of marks currently in the Windows clipboard.
Public Property | PopupTextIcon | Gets or sets the icon associated with the ImGearARTPopupText annotation.
Public Property | Resolution | Gets or sets the resolution, used by ImGearARTRuler and ImGearARTPolyRuler annotations for measurement purposes.
Public Property | SecureObjectData | Gets or sets data object for the AccessController property.
Public Property | StartIndex | Gets or sets the start index of the marks enumeration on the page.
Public Property | Subject | Gets or sets the subject for the page.
Public Property | Title | Gets or sets the title for the page.
Public Property | UserDataAttributes | Gets the user data dictionary specified for the page.
Top
See Also

Reference

ImGearARTPage Class
ImageGear.ART Namespace


AccessController Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : AccessController Property
Gets or sets access controller for this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AccessController As ImGearARTAccessController
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTAccessController

instance.AccessController = value

value = instance.AccessController
public ImGearARTAccessController AccessController {get; set;}
public: __property ImGearARTAccessController* get_AccessController();
public: __property void set_AccessController(
   ImGearARTAccessController* value
);
public:
property ImGearARTAccessController^ AccessController {
   ImGearARTAccessController^ get();
   void set (    ImGearARTAccessController^ value);
}

Property Value

ImGearARTAccessController class instance.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


AspectKind Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : AspectKind Property
Gets or sets a value indicating the aspect kind.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectKind As ImGearARTAspectKind
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTAspectKind

instance.AspectKind = value

value = instance.AspectKind
public ImGearARTAspectKind AspectKind {get; set;}
public: __property ImGearARTAspectKind get_AspectKind();
public: __property void set_AspectKind(
   ImGearARTAspectKind value
);
public:
property ImGearARTAspectKind AspectKind {
   ImGearARTAspectKind get();
   void set (    ImGearARTAspectKind value);
}

Property Value

ImGearARTAspectKind value.
Remarks
AspectKind sets displaying mode for ImGearARTRuler and ImGearARTPolyRuler annotations.

Absolute mode is default mode, where measuring length is calculated according to AspectNumeratorX/AspectDenominatorX/AspectNumeratorY/AspectDenominatorY properties of ImGearARTRuler or ImGearARTPolyRuler annotations. In this mode, a change to the resolution of the underlying image will not affect the physical measurements of the ruler/poly-ruler marks on the screen.

In Relative mode AspectNumeratorX/AspectDenominatorX/AspectNumeratorY/AspectDenominatorY properties keep aspect values of the ImGearARTMeasurementUnit structure. In contrast to Absolute mode, in Relative mode the measuring length of ImGearARTRuler and ImGearARTPolyRuler is calculated dynamically depending on the resolution of the currently displayed underlying image.

Note: If the page contains ImGearARTRuler or ImGearARTPolyRuler annotation(s), prior to setting a new value to this property, please initialize Resolution property first, otherwise ImageGear.Core.ImGearException will be thrown. The resolution is necessary for automatic reinitialization of AspectNumeratorX/AspectDenominatorX/AspectNumeratorY/AspectDenominatorY properties of the ruler and poly-ruler marks.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImageResolution Property
DIB Property


Author Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Author Property
Gets or sets the author for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As ImGearARTPage
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Bounds Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Bounds Property
Gets or sets the bounding rectangle of the annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bounds As IImGearRectangle
'Usage

Dim instance As ImGearARTPage
Dim value As IImGearRectangle

instance.Bounds = value

value = instance.Bounds
public IImGearRectangle Bounds {get; set;}
public: __property IImGearRectangle* get_Bounds();
public: __property void set_Bounds(
   IImGearRectangle* value
);
public:
property IImGearRectangle^ Bounds {
   IImGearRectangle^ get();
   void set (    IImGearRectangle^ value);
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
This is a rectangle that encloses all annotation marks on the page.

This property can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this property is set to null and ART page is associated with ImageGear.Core.ImGearPage class the ImageGear.Core.ImGearPage class's rectangle is used.

The default value is null.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearRectangle Structure


Comments Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Comments Property
Gets or sets the comments for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Comments As String
'Usage

Dim instance As ImGearARTPage
Dim value As String

instance.Comments = value

value = instance.Comments
public string Comments {get; set;}
public: __property string* get_Comments();
public: __property void set_Comments(
   string* value
);
public:
property String^ Comments {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Groups Property
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Groups Property
Gets an array of annotation groups in the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Groups As ImGearARTGroupArray
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTGroupArray

value = instance.Groups
public ImGearARTGroupArray Groups {get;}
public: __property ImGearARTGroupArray* get_Groups();
public:
property ImGearARTGroupArray^ Groups {
   ImGearARTGroupArray^ get();
}

Property Value

ImGearARTGroupArray class object.
Example
  • C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();
  • Visual Basic
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearARTGroupArray Class


History Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : History Property
Gets the history object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property History As ImGearARTHistory
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTHistory

value = instance.History
public ImGearARTHistory History {get;}
public: __property ImGearARTHistory* get_History();
public:
property ImGearARTHistory^ History {
   ImGearARTHistory^ get();
}

Property Value

ImGearARTHistory value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkCount Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkCount Property
Gets the marks count in the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkCount As Integer
'Usage

Dim instance As ImGearARTPage
Dim value As Integer

value = instance.MarkCount
public int MarkCount {get;}
public: __property int get_MarkCount();
public:
property int MarkCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarksChanged Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarksChanged Property
Gets or sets a value indicating whether the marks changed since they were last saved or loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MarksChanged As Boolean
'Usage

Dim instance As ImGearARTPage
Dim value As Boolean

instance.MarksChanged = value

value = instance.MarksChanged
public bool MarksChanged {get; set;}
public: __property bool get_MarksChanged();
public: __property void set_MarksChanged(
   bool value
);
public:
property bool MarksChanged {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Orientation Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Orientation Property
Gets or sets the orientation of the annotation page layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As IImGearOrientation
'Usage

Dim instance As ImGearARTPage
Dim value As IImGearOrientation

instance.Orientation = value

value = instance.Orientation
public IImGearOrientation Orientation {get; set;}
public: __property IImGearOrientation* get_Orientation();
public: __property void set_Orientation(
   IImGearOrientation* value
);
public:
property IImGearOrientation^ Orientation {
   IImGearOrientation^ get();
   void set (    IImGearOrientation^ value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See Bounds property for more information about the page layout rectangle.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImGearOrientation Structure
ImGearOrientationModes Enumeration


PasteCount Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : PasteCount Property
Gets the number of marks currently in the Windows clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PasteCount As Integer
'Usage

Dim instance As ImGearARTPage
Dim value As Integer

value = instance.PasteCount
public int PasteCount {get;}
public: __property int get_PasteCount();
public:
property int PasteCount {
   int get();
}

Property Value

Integer value.
Remarks
The Clipboard API can only be used in threads set to single thread apartment (STA) mode.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


PopupTextIcon Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : PopupTextIcon Property
Gets or sets the icon associated with the ImGearARTPopupText annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupTextIcon As ImGearRasterPage
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearRasterPage

instance.PopupTextIcon = value

value = instance.PopupTextIcon
public ImGearRasterPage PopupTextIcon {get; set;}
public: __property ImGearRasterPage* get_PopupTextIcon();
public: __property void set_PopupTextIcon(
   ImGearRasterPage* value
);
public:
property ImGearRasterPage^ PopupTextIcon {
   ImGearRasterPage^ get();
   void set (    ImGearRasterPage^ value);
}

Property Value

ImGearARTPopupText class instance.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Resolution Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Resolution Property
Gets or sets the resolution, used by ImGearARTRuler and ImGearARTPolyRuler annotations for measurement purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Resolution As IImGearResolution
'Usage

Dim instance As ImGearARTPage
Dim value As IImGearResolution

instance.Resolution = value

value = instance.Resolution
public IImGearResolution Resolution {get; set;}
public: __property IImGearResolution* get_Resolution();
public: __property void set_Resolution(
   IImGearResolution* value
);
public:
property IImGearResolution^ Resolution {
   IImGearResolution^ get();
   void set (    IImGearResolution^ value);
}

Property Value

ImageGear.Core.IImGearResolution value.
Remarks
Depending on the value of AspectKind, this parameter is being used by following properties:
  • ImGearARTRuler.Length
  • ImGearARTRuler.MeasurementUnit
  • ImGearARTPolyRuler.Length
  • ImGearARTPolyRuler.MeasurementUnit
So, prior to using above mentioned functionality, please initialize this property first by the resolution of currently displayed underlying image.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
ImageResolution Property
DIB Property


SecureObjectData Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : SecureObjectData Property
Gets or sets data object for the AccessController property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SecureObjectData As ImGearARTSecureObjectData
'Usage

Dim instance As ImGearARTPage
Dim value As ImGearARTSecureObjectData

instance.SecureObjectData = value

value = instance.SecureObjectData
public ImGearARTSecureObjectData SecureObjectData {get; set;}
public: __property ImGearARTSecureObjectData* get_SecureObjectData();
public: __property void set_SecureObjectData(
   ImGearARTSecureObjectData* value
);
public:
property ImGearARTSecureObjectData^ SecureObjectData {
   ImGearARTSecureObjectData^ get();
   void set (    ImGearARTSecureObjectData^ value);
}

Property Value

ImGearARTSecureObjectData class instance.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


StartIndex Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : StartIndex Property
Gets or sets the start index of the marks enumeration on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartIndex As Integer
'Usage

Dim instance As ImGearARTPage
Dim value As Integer

instance.StartIndex = value

value = instance.StartIndex
public int StartIndex {get; set;}
public: __property int get_StartIndex();
public: __property void set_StartIndex(
   int value
);
public:
property int StartIndex {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Subject Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Subject Property
Gets or sets the subject for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As ImGearARTPage
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


Title Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : Title Property
Gets or sets the title for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As ImGearARTPage
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


UserDataAttributes Property (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : UserDataAttributes Property
Gets the user data dictionary specified for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UserDataAttributes As IDictionary(Of String,String)
'Usage

Dim instance As ImGearARTPage
Dim value As IDictionary(Of String,String)

value = instance.UserDataAttributes
public IDictionary<string,string> UserDataAttributes {get;}
public: __property IDictionary<string*,string*>* get_UserDataAttributes();
public:
property IDictionary<String^,String^>^ UserDataAttributes {
   IDictionary<String^,String^>^ get();
}

Property Value

IDictionary interface.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%% $$Events$$

ImGearARTPage Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPage Class

For a list of all members of this type, see ImGearARTPage members.

Public Events
 | Name | Description
Public Event | MarkAdded | Occurs when a mark is added.
Public Event | MarkChanged | Occurs when a mark is changed.
Public Event | MarkRemoved | Occurs when a mark is removed.
Public Event | MarkSelectionChanged | Occurs when a mark's selection is changed.
Public Event | MarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top
See Also

Reference

ImGearARTPage Class
ImageGear.ART Namespace


MarkAdded Event (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkAdded Event
Occurs when a mark is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkAdded As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPage
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkAdded, handler
public event ImGearARTMarkEventHandler MarkAdded
public: __event ImGearARTMarkEventHandler* MarkAdded
public:
event ImGearARTMarkEventHandler^ MarkAdded
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkChanged Event (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkChanged Event
Occurs when a mark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPage
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkChanged, handler
public event ImGearARTMarkEventHandler MarkChanged
public: __event ImGearARTMarkEventHandler* MarkChanged
public:
event ImGearARTMarkEventHandler^ MarkChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkRemoved Event (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkRemoved Event
Occurs when a mark is removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPage
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkRemoved, handler
public event ImGearARTMarkEventHandler MarkRemoved
public: __event ImGearARTMarkEventHandler* MarkRemoved
public:
event ImGearARTMarkEventHandler^ MarkRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkSelectionChanged Event (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkSelectionChanged Event
Occurs when a mark's selection is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkSelectionChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPage
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkSelectionChanged, handler
public event ImGearARTMarkEventHandler MarkSelectionChanged
public: __event ImGearARTMarkEventHandler* MarkSelectionChanged
public:
event ImGearARTMarkEventHandler^ MarkSelectionChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


MarkZOrderChanged Event (ImGearARTPage)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPage Class : MarkZOrderChanged Event
Occurs when a mark's Z-Order is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkZOrderChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPage
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkZOrderChanged, handler
public event ImGearARTMarkEventHandler MarkZOrderChanged
public: __event ImGearARTMarkEventHandler* MarkZOrderChanged
public:
event ImGearARTMarkEventHandler^ MarkZOrderChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

ImGearARTPageEnumerator Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPageEnumerator Class
Provides marks iteration capabilities over the annotation page.
Object Model
ImGearARTPageEnumerator ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPageEnumerator
'Usage

Dim instance As ImGearARTPageEnumerator
public class ImGearARTPageEnumerator
public __gc class ImGearARTPageEnumerator
public ref class ImGearARTPageEnumerator
Remarks
Page enumerator class is used for ImGearARTPage class to iterate through the collection of marks by using foreach statement.
Example
  • C#
// Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
//  to get a ImGearARTPageEnumerator which is used for the foreach.
foreach( ImGearARTMark igARTMark in igARTPage)
{
    //Move the art mark.
    igARTMark.Move(50, 50);
}
  • Visual Basic
' Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
'  to get a ImGearARTPageEnumerator which is used for the foreach.
For Each igARTMark As ImGearARTMark In igARTPage
    'Move the art mark.
    igARTMark.Move(50, 50)
Next
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTPageEnumerator

See Also

Reference

ImGearARTPageEnumerator Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPageEnumerator Class Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPageEnumerator Class

The following tables list the members exposed by ImGearARTPageEnumerator.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPageEnumerator Constructor | Initializes a new instance of the ImGearARTPageEnumerator class object.
Top
Public Properties
 | Name | Description
Public Property | Current | Gets the current element in the collection.
Top
Public Methods
 | Name | Description
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

ImGearARTPageEnumerator Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPageEnumerator Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPageEnumerator Class : ImGearARTPageEnumerator Constructor
Annotation page to enumerate the marks from.
Initializes a new instance of the ImGearARTPageEnumerator class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal artPage As ImGearARTPage _
)
'Usage

Dim artPage As ImGearARTPage

Dim instance As New ImGearARTPageEnumerator(artPage)
public ImGearARTPageEnumerator(
   ImGearARTPage artPage
)
public: ImGearARTPageEnumerator(
   ImGearARTPage* artPage
)
public:
ImGearARTPageEnumerator(
   ImGearARTPage^ artPage
)

Parameters

artPage
Annotation page to enumerate the marks from.
See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members
ImGearARTPage Class


%%PageItemTitle%% $$Methods$$

ImGearARTPageEnumerator Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPageEnumerator Class

For a list of all members of this type, see ImGearARTPageEnumerator members.

Public Methods
 | Name | Description
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

ImGearARTPageEnumerator Class
ImageGear.ART Namespace


MoveNext Method (ImGearARTPageEnumerator)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPageEnumerator Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As ImGearARTPageEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

Boolean value.
Remarks

True if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members


%%PageItemTitle%% $$Properties$$

ImGearARTPageEnumerator Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPageEnumerator Class

For a list of all members of this type, see ImGearARTPageEnumerator members.

Public Properties
 | Name | Description
Public Property | Current | Gets the current element in the collection.
Top
See Also

Reference

ImGearARTPageEnumerator Class
ImageGear.ART Namespace


Current Property (ImGearARTPageEnumerator)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPageEnumerator Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As ImGearARTMark
'Usage

Dim instance As ImGearARTPageEnumerator
Dim value As ImGearARTMark

value = instance.Current
public ImGearARTMark Current {get;}
public: __property ImGearARTMark* get_Current();
public:
property ImGearARTMark^ Current {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark class object.
See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTPin Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPin Class
Provides text mark's pin attirbutes.
Object Model
ImGearARTPin ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPin
'Usage

Dim instance As ImGearARTPin
public class ImGearARTPin
public __gc class ImGearARTPin
public ref class ImGearARTPin
Example
  • C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTPin

See Also

Reference

ImGearARTPin Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPin Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPin Class

The following tables list the members exposed by ImGearARTPin.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPin Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of the pin icon.
Public Property | Color | Gets or sets the color of the pin icon.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTPin Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPin Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : ImGearARTPin Constructor
Overload List
Overload | Description
ImGearARTPin Constructor(IImGearRGBQuad) | Initializes a new instance of the ImGearARTPin class object.
ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment) | Initializes a new instance of the ImGearARTPin class object.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

ImGearARTPin Constructor(IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class > ImGearARTPin Constructor : ImGearARTPin Constructor(IImGearRGBQuad)
Color of the pin icon.
Initializes a new instance of the ImGearARTPin class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim color As IImGearRGBQuad

Dim instance As New ImGearARTPin(color)
public ImGearARTPin(
   IImGearRGBQuad color
)
public: ImGearARTPin(
   IImGearRGBQuad* color
)
public:
ImGearARTPin(
   IImGearRGBQuad^ color
)

Parameters

color
Color of the pin icon.
Remarks

The pin color is not supported in WPF renderer.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class > ImGearARTPin Constructor : ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment)
Color of the pin icon.
Pin icon alignment.
Initializes a new instance of the ImGearARTPin class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As IImGearRGBQuad, _
   ByVal alignment As ImGearARTPinAlignment _
)
'Usage

Dim color As IImGearRGBQuad
Dim alignment As ImGearARTPinAlignment

Dim instance As New ImGearARTPin(color, alignment)
public ImGearARTPin(
   IImGearRGBQuad color,
   ImGearARTPinAlignment alignment
)
public: ImGearARTPin(
   IImGearRGBQuad* color,
   ImGearARTPinAlignment alignment
)
public:
ImGearARTPin(
   IImGearRGBQuad^ color,
   ImGearARTPinAlignment alignment
)

Parameters

color
Color of the pin icon.
alignment
Pin icon alignment.
Remarks

The pin color is not supported in WPF renderer.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List
ImGearRGBQuad Structure
ImGearARTPinAlignment Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTPin Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPin Class

For a list of all members of this type, see ImGearARTPin members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Overloaded. Occurs when a property value changes.
Top
See Also

Reference

ImGearARTPin Class
ImageGear.ART Namespace


OnPropertyChanged Method (ImGearARTPin)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : OnPropertyChanged Method
Occurs when a property value changes.
Overload List
Overload | Description
OnPropertyChanged(String) | Occurs when a property value changes.
OnPropertyChanged(String,Object,Object) | Occurs when a ART property value changes.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


OnPropertyChanged(String) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class > OnPropertyChanged Method : OnPropertyChanged(String) Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearARTPin
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List


OnPropertyChanged(String,Object,Object) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class > OnPropertyChanged Method : OnPropertyChanged(String,Object,Object) Method
The name of the property that changed.
The old value of the property before changing.
The new value of the property after changing.
Occurs when a ART property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub OnPropertyChanged( _
   ByVal name As String, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As ImGearARTPin
Dim name As String
Dim oldValue As Object
Dim newValue As Object

instance.OnPropertyChanged(name, oldValue, newValue)
protected void OnPropertyChanged(
   string name,
   object oldValue,
   object newValue
)
protected: void OnPropertyChanged(
   string* name,
   Object* oldValue,
   Object* newValue
)
protected:
void OnPropertyChanged(
   String^ name,
   Object^ oldValue,
   Object^ newValue
)

Parameters

name
The name of the property that changed.
oldValue
The old value of the property before changing.
newValue
The new value of the property after changing.
Remarks
Note: this method does not call itself the OnPropertyChanged(String), which is responsible for firing of PropertyChanged event. To provide System.ComponentModel.INotifyPropertyChanged functionality, please call OnPropertyChanged(String) explicitly.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearARTPin Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPin Class

For a list of all members of this type, see ImGearARTPin members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of the pin icon.
Public Property | Color | Gets or sets the color of the pin icon.
Top
See Also

Reference

ImGearARTPin Class
ImageGear.ART Namespace


Alignment Property (ImGearARTPin)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : Alignment Property
Gets or sets the alignment of the pin icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Alignment As ImGearARTPinAlignment
'Usage

Dim instance As ImGearARTPin
Dim value As ImGearARTPinAlignment

instance.Alignment = value

value = instance.Alignment
public ImGearARTPinAlignment Alignment {get; set;}
public: __property ImGearARTPinAlignment get_Alignment();
public: __property void set_Alignment(
   ImGearARTPinAlignment value
);
public:
property ImGearARTPinAlignment Alignment {
   ImGearARTPinAlignment get();
   void set (    ImGearARTPinAlignment value);
}

Property Value

ImGearARTPinAlignment enumeration value.
Remarks
The default value is ImGearARTPinAlignment.LEFT_TOP.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
ImGearARTPinAlignment Enumeration


Color Property (ImGearARTPin)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : Color Property
Gets or sets the color of the pin icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPin
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
Remarks

The pin color is not supported in WPF renderer.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
ImGearRGBQuad Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Events$$

ImGearARTPin Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPin Class

For a list of all members of this type, see ImGearARTPin members.

Public Events
 | Name | Description
Public Event | ARTPropertyChanged | Occurs when a property value changes and presents old and new values of the property.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearARTPin Class
ImageGear.ART Namespace


ARTPropertyChanged Event (ImGearARTPin)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : ARTPropertyChanged Event
Occurs when a property value changes and presents old and new values of the property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ARTPropertyChanged As ARTPropertyChangedEventHandler
'Usage

Dim instance As ImGearARTPin
Dim handler As ARTPropertyChangedEventHandler

AddHandler instance.ARTPropertyChanged, handler
public event ARTPropertyChangedEventHandler ARTPropertyChanged
public: __event ARTPropertyChangedEventHandler* ARTPropertyChanged
public:
event ARTPropertyChangedEventHandler^ ARTPropertyChanged
Event Data

The event handler receives an argument of type ImGearARTPropertyChangedEventArgs containing data related to this event. The following ImGearARTPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewPropertyValue | Gets new value of changed property.
OldPropertyValue | Gets old value of changed property.
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


PropertyChanged Event (ImGearARTPin)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPin Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearARTPin
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

ImGearARTPinUpText Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinUpText Class
Represents legacy ART Pin-Up-Text mark.
Object Model
ImGearARTPinUpText ClassImGearRectangle StructureImGearRectangle StructureIImGearRGBQuad InterfaceIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPinUpText
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTPinUpText
public class ImGearARTPinUpText : ImGearARTMark
public __gc class ImGearARTPinUpText : public ImGearARTMark
public ref class ImGearARTPinUpText : public ImGearARTMark
Example
  • C#
// Setup rectangle for the pinup mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 0);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(40, 200, 40);
// Create pinup mark using size 14 bold Arial font
ImGearARTPinUpText igARTPinUpText = new ImGearARTPinUpText(
    igRectangle, "ImGearARTPinUpText test", igRGBQuadText, "Arial", (float)14.0, ImGearARTFontStyles.Bold, igRGBQuadPin
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPinUpText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the pinup mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 0)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(40, 200, 40)
' Create pinup mark using size 14 bold Arial font
Dim igARTPinUpText As New ImGearARTPinUpText( _
 igRectangle, "ImGearARTPinUpText test", igRGBQuadText, _
 "Arial", CSng(14), ImGearARTFontStyles.Bold, igRGBQuadPin)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPinUpText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPinUpText

See Also

Reference

ImGearARTPinUpText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPinUpText Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinUpText Class

The following tables list the members exposed by ImGearARTPinUpText.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPinUpText Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | PinColor | Gets or sets the pin color.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark rectangle.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPinUpText Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPinUpText Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : ImGearARTPinUpText Constructor
Overload List
Overload | Description
ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPinUpText class object.
ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPinUpText class object.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class > ImGearARTPinUpText Constructor : ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad)
Rectangle of the mark.
The mark's text string.
The mark's text color.
Initializes a new instance of the ImGearARTPinUpText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTPinUpText(rect, text, textColor)
public ImGearARTPinUpText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTPinUpText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTPinUpText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class > ImGearARTPinUpText Constructor : ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,IImGearRGBQuad)
Rectangle of the mark.
The mark's text string.
The mark's text color.
The mark's text font name.
The mark's text font size.
The mark's text font style.
The mark's pin color.
Initializes a new instance of the ImGearARTPinUpText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles, _
   ByVal pinColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles
Dim pinColor As IImGearRGBQuad

Dim instance As New ImGearARTPinUpText(rect, text, textColor, fontName, fontSize, fontStyle, pinColor)
public ImGearARTPinUpText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   IImGearRGBQuad pinColor
)
public: ImGearARTPinUpText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   IImGearRGBQuad* pinColor
)
public:
ImGearARTPinUpText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   IImGearRGBQuad^ pinColor
)

Parameters

rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color.
fontName
The mark's text font name.
fontSize
The mark's text font size.
fontStyle
The mark's text font style.
pinColor
The mark's pin color.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTPinUpText Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinUpText Class

For a list of all members of this type, see ImGearARTPinUpText members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPinUpText Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTPinUpText Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinUpText Class

For a list of all members of this type, see ImGearARTPinUpText members.

See Also

Reference

ImGearARTPinUpText Class
ImageGear.ART Namespace


Flip Method (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPinUpText
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Flip Method


GetRenderBounds Method (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPinUpText
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Move Method (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPinUpText
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Rotate Method (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPinUpText
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Rotate Method


Scale Method (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPinUpText
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTPinUpText Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinUpText Class

For a list of all members of this type, see ImGearARTPinUpText members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | PinColor | Gets or sets the pin color.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark rectangle.
Top
See Also

Reference

ImGearARTPinUpText Class
ImageGear.ART Namespace


Bounds Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPinUpText
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
ImGearRectangle Structure


FontDisablePPM Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


FontName Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTPinUpText
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


FontSize Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


FontStyleART Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTPinUpText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Height Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


PinColor Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : PinColor Property
Gets or sets the pin color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PinColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPinUpText
Dim value As IImGearRGBQuad

instance.PinColor = value

value = instance.PinColor
public IImGearRGBQuad PinColor {get; set;}
public: __property IImGearRGBQuad* get_PinColor();
public: __property void set_PinColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ PinColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
ImGearRGBQuad Structure


SelectionType Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPinUpText
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Text Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Text Property
Gets or sets the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTPinUpText
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


TextColor Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPinUpText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
Remarks
The color of the mark's text.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
ImGearRGBQuad Structure


Type Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPinUpText
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Width Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


X Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : X Property
Gets or sets the X coordinate of the top-left point of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


Y Property (ImGearARTPinUpText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPinUpText Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTPinUpText
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

ImGearARTPoint Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPoint Class
Represents ART Point mark.
Object Model
ImGearARTPoint ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPoint
   Inherits ImGearARTMark
   Implements IImGearARTPoint
'Usage

Dim instance As ImGearARTPoint
public class ImGearARTPoint : ImGearARTMark, IImGearARTPoint
public __gc class ImGearARTPoint : public ImGearARTMark, IImGearARTPoint
public ref class ImGearARTPoint : public ImGearARTMark, IImGearARTPoint
Example
  • C#
// Setup location for the point
ImGearPoint igPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for the point.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the point annotation with a width of 10 and 60% opacity
ImGearARTPoint igARTPoint = new ImGearARTPoint(
    igPoint, igRGBQuad, 10, (int)(0.60 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup location for the point
Dim igPoint As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for the point.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the point annotation with a width of 10 and 60% opacity
Dim igARTPoint As New ImGearARTPoint( _
 igPoint, igRGBQuad, 10, CInt(0.6 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPoint

See Also

Reference

ImGearARTPoint Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPoint Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPoint Class

The following tables list the members exposed by ImGearARTPoint.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPoint Constructor | Overloaded. Initializes a new instance of the ImGearARTPoint class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the color of the mark.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the mark.
Public Property | Y | Gets or sets the Y coordinate of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPoint Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPoint Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : ImGearARTPoint Constructor
Initializes a new instance of the ImGearARTPoint class.
Overload List
Overload | Description
ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPoint class object.
ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,Int32,Int32) | Initializes a new instance of the ImGearARTPoint class object.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class > ImGearARTPoint Constructor : ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad)
The point mark.
Color of the mark.
Initializes a new instance of the ImGearARTPoint class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As IImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim point As IImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTPoint(point, color)
public ImGearARTPoint(
   IImGearPoint point,
   IImGearRGBQuad color
)
public: ImGearARTPoint(
   IImGearPoint* point,
   IImGearRGBQuad* color
)
public:
ImGearARTPoint(
   IImGearPoint^ point,
   IImGearRGBQuad^ color
)

Parameters

point
The point mark.
color
Color of the mark.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class > ImGearARTPoint Constructor : ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,Int32,Int32)
The point mark.
Color of the mark.
Width of the mark.
Opacity of the mark.
Initializes a new instance of the ImGearARTPoint class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As IImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal width As Integer, _
   ByVal opacity As Integer _
)
'Usage

Dim point As IImGearPoint
Dim color As IImGearRGBQuad
Dim width As Integer
Dim opacity As Integer

Dim instance As New ImGearARTPoint(point, color, width, opacity)
public ImGearARTPoint(
   IImGearPoint point,
   IImGearRGBQuad color,
   int width,
   int opacity
)
public: ImGearARTPoint(
   IImGearPoint* point,
   IImGearRGBQuad* color,
   int width,
   int opacity
)
public:
ImGearARTPoint(
   IImGearPoint^ point,
   IImGearRGBQuad^ color,
   int width,
   int opacity
)

Parameters

point
The point mark.
color
Color of the mark.
width
Width of the mark.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTPoint Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPoint Class

For a list of all members of this type, see ImGearARTPoint members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPoint Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTPoint Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPoint Class

For a list of all members of this type, see ImGearARTPoint members.

See Also

Reference

ImGearARTPoint Class
ImageGear.ART Namespace


Flip Method (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPoint
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Flip Method


GetRenderBounds Method (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPoint
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


Move Method (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPoint
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


Rotate Method (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPoint
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Rotate Method


Scale Method (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPoint
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTPoint Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPoint Class

For a list of all members of this type, see ImGearARTPoint members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Color | Gets or sets the color of the mark.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Public Property | X | Gets or sets the X coordinate of the mark.
Public Property | Y | Gets or sets the Y coordinate of the mark.
Top
See Also

Reference

ImGearARTPoint Class
ImageGear.ART Namespace


Bounds Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPoint
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
ImGearRectangle Structure


Color Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPoint
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
ImGearRGBQuad Structure


Opacity Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTPoint
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Any integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


SelectionPoints Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTPoint
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


SelectionType Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPoint
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


Type Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPoint
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPoint
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


Width Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTPoint
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


X Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : X Property
Gets or sets the X coordinate of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTPoint
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


Y Property (ImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPoint Class : Y Property
Gets or sets the Y coordinate of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTPoint
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

ImGearARTPointMarkStat Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPointMarkStat Class
Represents statistics information about the point annotation marks.
Object Model
ImGearARTPointMarkStat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPointMarkStat
   Inherits ImGearARTMarkStat
'Usage

Dim instance As ImGearARTPointMarkStat
public class ImGearARTPointMarkStat : ImGearARTMarkStat
public __gc class ImGearARTPointMarkStat : public ImGearARTMarkStat
public ref class ImGearARTPointMarkStat : public ImGearARTMarkStat
Remarks
Currently this class does only represent the ImGearARTMarkType.POINT mark type. There is no detailed statistic information available for such mark type.

An instance of the ImGearARTPointMarkStat class is always created for the specified mark object and should not be used after destroying that mark object.

Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTMarkStat
ImageGear.ART.ImGearARTPointMarkStat

See Also

Reference

ImGearARTPointMarkStat Members
ImageGear.ART Namespace
ImGearARTLineMarkStat Class
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTMarkType Enumeration


%%PageItemTitle%% $$Members$$

ImGearARTPointMarkStat Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPointMarkStat Class

The following tables list the members exposed by ImGearARTPointMarkStat.

See Also

Reference

ImGearARTPointMarkStat Class
ImageGear.ART Namespace
ImGearARTLineMarkStat Class
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTMarkType Enumeration


%%PageItemTitle%% $$Properties$$

ImGearARTPointMarkStat Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPointMarkStat Class

For a list of all members of this type, see ImGearARTPointMarkStat members.

See Also

Reference

ImGearARTPointMarkStat Class
ImageGear.ART Namespace
ImGearARTLineMarkStat Class
ImGearARTMarkStat Class
ImGearARTShapeMarkStat Class
ImGearARTMarkType Enumeration


%%PageItemTitle%%

ImGearARTPolygon Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolygon Class
Represents ART Polygon mark.
Object Model
ImGearARTPolygon ClassImGearARTBorder ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPolygon
   Inherits ImGearARTMark
   Implements IImGearARTPolygon
'Usage

Dim instance As ImGearARTPolygon
public class ImGearARTPolygon : ImGearARTMark, IImGearARTPolygon
public __gc class ImGearARTPolygon : public ImGearARTMark, IImGearARTPolygon
public ref class ImGearARTPolygon : public ImGearARTMark, IImGearARTPolygon
Example
  • C#
// Create an array of 5 points for the polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the polygon fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Setup color for the polygon border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 0, 0);
// Create polygon with a solid border of width 10, and 33% opacity
ImGearARTPolygon igARTPolygon = new ImGearARTPolygon(
    igPoints, igRGBQuadFill, igRGBQuadBorder,
    ImGearARTPenStyle.SOLID, 10, (int)(0.33 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolygon, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the polygon fill.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Setup color for the polygon border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 0, 0)
' Create polygon with a solid border of width 10, and 33% opacity
Dim igARTPolygon As New ImGearARTPolygon( _
 igPoints, igRGBQuadFill, igRGBQuadBorder, _
 ImGearARTPenStyle.SOLID, 10, CInt((0.33 * 255)))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolygon, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPolygon

See Also

Reference

ImGearARTPolygon Members
ImageGear.ART Namespace
ImGearARTMark Class


%%PageItemTitle%% $$Members$$

ImGearARTPolygon Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolygon Class

The following tables list the members exposed by ImGearARTPolygon.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPolygon Constructor | Overloaded. Initializes a new instance of the ImGearARTPolygon class.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FillRule | Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | NumberOfPoints | Gets or sets the actual number of points on the mark.
Public Property | Opacity | Gets or sets the mark opacity.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolygon Class
ImageGear.ART Namespace
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTPolygon Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : ImGearARTPolygon Constructor
Initializes a new instance of the ImGearARTPolygon class.
Overload List
Overload | Description
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolygon class object.
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32) | Initializes a new instance of the ImGearARTPolygon class object.
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32) | Initializes a new instance of the ImGearARTPolygon class object.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
The mark's points.
Fill color of the mark.
Initializes a new instance of the ImGearARTPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTPolygon(points, fillColor)
public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor
)
public: ImGearARTPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ fillColor
)

Parameters

points
The mark's points.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32)
The mark's points.
The border color of the mark.
The border style of the mark.
The border width of the mark.
Initializes a new instance of the ImGearARTPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer _
)
'Usage

Dim points() As ImGearPoint
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer

Dim instance As New ImGearARTPolygon(points, borderColor, borderStyle, borderWidth)
public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public: ImGearARTPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public:
ImGearARTPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

points
The mark's points.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)
The mark's points.
Fill color of the mark.
The border color of the mark.
The border style of the mark.
The border width of the mark.
Opacity of the mark.
Initializes a new instance of the ImGearARTPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer, _
   ByVal opacity As Integer _
)
'Usage

Dim points() As ImGearPoint
Dim fillColor As IImGearRGBQuad
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer
Dim opacity As Integer

Dim instance As New ImGearARTPolygon(points, fillColor, borderColor, borderStyle, borderWidth, opacity)
public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public: ImGearARTPolygon(
   ImGearPoint[]* points,
   IImGearRGBQuad* fillColor,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public:
ImGearARTPolygon(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ fillColor,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

points
The mark's points.
fillColor
Fill color of the mark.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTPolygon Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolygon Class

For a list of all members of this type, see ImGearARTPolygon members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolygon Class
ImageGear.ART Namespace
ImGearARTMark Class


AddPoint Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolygon
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearPoint Structure


Flip Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPolygon
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Flip Method


GetPoint Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : GetPoint Method
The index of the point to get.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTPolygon
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
The index of the point to get.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPolygon
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


Move Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPolygon
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


OnPointAdded Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


OnPointChanged Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolygon
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


OnPointsRemoved Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPolygon
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


RemovePoints Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTPolygon
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


Rotate Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPolygon
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Rotate Method


Scale Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPolygon
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Scale Method


SetPoint Method (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolygon
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTPolygon Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolygon Class

For a list of all members of this type, see ImGearARTPolygon members.

Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FillRule | Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | NumberOfPoints | Gets or sets the actual number of points on the mark.
Public Property | Opacity | Gets or sets the mark opacity.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Top
See Also

Reference

ImGearARTPolygon Class
ImageGear.ART Namespace
ImGearARTMark Class


Border Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTPolygon
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearARTBorder Class


Bounds Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPolygon
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearRectangle Structure


FillColor Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPolygon
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearRGBQuad Structure


FillRule Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : FillRule Property
Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillRule As ImGearARTFillRule
'Usage

Dim instance As ImGearARTPolygon
Dim value As ImGearARTFillRule

instance.FillRule = value

value = instance.FillRule
public ImGearARTFillRule FillRule {get; set;}
public: __property ImGearARTFillRule get_FillRule();
public: __property void set_FillRule(
   ImGearARTFillRule value
);
public:
property ImGearARTFillRule FillRule {
   ImGearARTFillRule get();
   void set (    ImGearARTFillRule value);
}

Property Value

ImGearARTFillRule enumeration value.
Remarks
default value is ImGearARTFillRule.EvenOdd.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


IsHighlighter Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHighlighter As Boolean
'Usage

Dim instance As ImGearARTPolygon
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
public bool IsHighlighter {get; set;}
public: __property bool get_IsHighlighter();
public: __property void set_IsHighlighter(
   bool value
);
public:
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


NumberOfPoints Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : NumberOfPoints Property
Gets or sets the actual number of points on the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTPolygon
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearPoint Structure


Opacity Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Opacity Property
Gets or sets the mark opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTPolygon
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


Points Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTPolygon
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTPolygon
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


SelectionType Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPolygon
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


Type Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPolygon
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPolygon
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%% $$Events$$

ImGearARTPolygon Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolygon Class

For a list of all members of this type, see ImGearARTPolygon members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolygon Class
ImageGear.ART Namespace
ImGearARTMark Class


PointAdded Event (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


PointChanged Event (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolygon
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


PointsRemoved Event (ImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolygon Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPolygon
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

ImGearARTPolyline Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyline Class
Represents ART Polyline mark.
Object Model
ImGearARTPolyline ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPolyline
   Inherits ImGearARTMark
   Implements IImGearARTPolyline
'Usage

Dim instance As ImGearARTPolyline
public class ImGearARTPolyline : ImGearARTMark, IImGearARTPolyline
public __gc class ImGearARTPolyline : public ImGearARTMark, IImGearARTPolyline
public ref class ImGearARTPolyline : public ImGearARTMark, IImGearARTPolyline
Example
  • C#
// Create an array of 5 points for the line.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create poly line with a dot-dashed pattern, width of 4, 100% opaque, closed,
//  and no heads.
ImGearARTPolyline igARTPolyLine = new ImGearARTPolyline(
    igPoints, igRGBQuad, ImGearARTPenStyle.DASHDOT, 4, 255, true,
    null, ImGearARTLineHeadType.NONE, 0, 0, ImGearARTLineHeadType.NONE, 0, 0
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyLine, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Create an array of 5 points for the line.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create poly line with a dot-dashed pattern, width of 4, 100% opaque, closed,
'  and no heads.
Dim igARTPolyLine As New ImGearARTPolyline( _
 igPoints, igRGBQuad, ImGearARTPenStyle.DASHDOT, 4, 255, True, _
 Nothing, ImGearARTLineHeadType.NONE, 0, 0, ImGearARTLineHeadType.NONE, 0, 0)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyLine, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPolyline

See Also

Reference

ImGearARTPolyline Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPolyline Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyline Class

The following tables list the members exposed by ImGearARTPolyline.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPolyline Constructor | Overloaded. Initializes a new instance of the ImGearARTPolyline class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndHeadAngle | Gets or sets the end head angle of the mark.
Public Property | EndHeadLength | Gets or sets the end head length of the mark.
Public Property | EndHeadType | Gets or sets the end head type of the mark.
Public Property | HeadFillColor | Gets or sets the fill color of the line's head.
Public Property | IsClosed | Gets or sets a value indicating whether the polyline is closed.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartHeadAngle | Gets or sets the start head angle of the mark.
Public Property | StartHeadLength | Gets or sets the start head length of the mark.
Public Property | StartHeadType | Gets or sets the start head type of the mark.
Public Property | Style | Gets or sets the style of the mark.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyline Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPolyline Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : ImGearARTPolyline Constructor
Initializes a new instance of the ImGearARTPolyline class.
Overload List
Overload | Description
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolyline class object.
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean) | Initializes a new instance of the ImGearARTPolyline class object.
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32) | Initializes a new instance of the ImGearARTPolyline class object.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad)
The mark's points.
Color of the mark.
Initializes a new instance of the ImGearARTPolyline class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTPolyline(points, color)
public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color
)
public: ImGearARTPolyline(
   ImGearPoint[]* points,
   IImGearRGBQuad* color
)
public:
ImGearARTPolyline(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color
)

Parameters

points
The mark's points.
color
Color of the mark.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean)
The mark's points.
Color of the mark.
The line style.
The line width.
Opacity of the mark.
Specifies whether the line is closed or not.
Initializes a new instance of the ImGearARTPolyline class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal isClosed As Boolean _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim isClosed As Boolean

Dim instance As New ImGearARTPolyline(points, color, style, width, opacity, isClosed)
public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed
)
public: ImGearARTPolyline(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed
)
public:
ImGearARTPolyline(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed
)

Parameters

points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Boolean,IImGearRGBQuad,ImGearARTLineHeadType,Int32,Int32,ImGearARTLineHeadType,Int32,Int32)
The mark's points.
Color of the mark.
The line style.
The line width.
Opacity of the mark.
Specifies whether the line is closed or not.
Fill color of the line's head.
Start head type.
Start head angle.
Start head length.
End head type.
End head angle.
End head length.
Initializes a new instance of the ImGearARTPolyline class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal isClosed As Boolean, _
   ByVal headFillColor As IImGearRGBQuad, _
   ByVal startHeadType As ImGearARTLineHeadType, _
   ByVal startHeadAngle As Integer, _
   ByVal startHeadLength As Integer, _
   ByVal endHeadType As ImGearARTLineHeadType, _
   ByVal endHeadAngle As Integer, _
   ByVal endHeadLength As Integer _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim isClosed As Boolean
Dim headFillColor As IImGearRGBQuad
Dim startHeadType As ImGearARTLineHeadType
Dim startHeadAngle As Integer
Dim startHeadLength As Integer
Dim endHeadType As ImGearARTLineHeadType
Dim endHeadAngle As Integer
Dim endHeadLength As Integer

Dim instance As New ImGearARTPolyline(points, color, style, width, opacity, isClosed, headFillColor, startHeadType, startHeadAngle, startHeadLength, endHeadType, endHeadAngle, endHeadLength)
public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed,
   IImGearRGBQuad headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)
public: ImGearARTPolyline(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed,
   IImGearRGBQuad* headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)
public:
ImGearARTPolyline(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   bool isClosed,
   IImGearRGBQuad^ headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)

Parameters

points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not.
headFillColor
Fill color of the line's head.
startHeadType
Start head type.
startHeadAngle
Start head angle.
startHeadLength
Start head length.
endHeadType
End head type.
endHeadAngle
End head angle.
endHeadLength
End head length.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration
ImGearARTLineHeadType Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTPolyline Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyline Class

For a list of all members of this type, see ImGearARTPolyline members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyline Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolyline
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearPoint Structure


Flip Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPolyline
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Flip Method


GetPoint Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : GetPoint Method
Index of the point.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTPolyline
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPolyline
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


Move Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPolyline
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


OnPointAdded Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolyline
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


OnPointChanged Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolyline
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


OnPointsRemoved Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPolyline
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


RemovePoints Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTPolyline
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


Rotate Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPolyline
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Rotate Method


Scale Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPolyline
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Scale Method


SetPoint Method (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolyline
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTPolyline Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyline Class

For a list of all members of this type, see ImGearARTPolyline members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndHeadAngle | Gets or sets the end head angle of the mark.
Public Property | EndHeadLength | Gets or sets the end head length of the mark.
Public Property | EndHeadType | Gets or sets the end head type of the mark.
Public Property | HeadFillColor | Gets or sets the fill color of the line's head.
Public Property | IsClosed | Gets or sets a value indicating whether the polyline is closed.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartHeadAngle | Gets or sets the start head angle of the mark.
Public Property | StartHeadLength | Gets or sets the start head length of the mark.
Public Property | StartHeadType | Gets or sets the start head type of the mark.
Public Property | Style | Gets or sets the style of the mark.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark.
Top
See Also

Reference

ImGearARTPolyline Class
ImageGear.ART Namespace


Bounds Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearRectangle Structure


CapStyle Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPolyline
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearRGBQuad Structure


EndHeadAngle Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : EndHeadAngle Property
Gets or sets the end head angle of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadAngle As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.EndHeadAngle = value

value = instance.EndHeadAngle
public int EndHeadAngle {get; set;}
public: __property int get_EndHeadAngle();
public: __property void set_EndHeadAngle(
   int value
);
public:
property int EndHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


EndHeadLength Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : EndHeadLength Property
Gets or sets the end head length of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadLength As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.EndHeadLength = value

value = instance.EndHeadLength
public int EndHeadLength {get; set;}
public: __property int get_EndHeadLength();
public: __property void set_EndHeadLength(
   int value
);
public:
property int EndHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


EndHeadType Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : EndHeadType Property
Gets or sets the end head type of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndHeadType As ImGearARTLineHeadType
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTLineHeadType

instance.EndHeadType = value

value = instance.EndHeadType
public ImGearARTLineHeadType EndHeadType {get; set;}
public: __property ImGearARTLineHeadType get_EndHeadType();
public: __property void set_EndHeadType(
   ImGearARTLineHeadType value
);
public:
property ImGearARTLineHeadType EndHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTLineHeadType Enumeration


HeadFillColor Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : HeadFillColor Property
Gets or sets the fill color of the line's head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadFillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPolyline
Dim value As IImGearRGBQuad

instance.HeadFillColor = value

value = instance.HeadFillColor
public IImGearRGBQuad HeadFillColor {get; set;}
public: __property IImGearRGBQuad* get_HeadFillColor();
public: __property void set_HeadFillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ HeadFillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearRGBQuad Structure


IsClosed Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : IsClosed Property
Gets or sets a value indicating whether the polyline is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsClosed As Boolean
'Usage

Dim instance As ImGearARTPolyline
Dim value As Boolean

instance.IsClosed = value

value = instance.IsClosed
public bool IsClosed {get; set;}
public: __property bool get_IsClosed();
public: __property void set_IsClosed(
   bool value
);
public:
property bool IsClosed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


IsHighlighter Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHighlighter As Boolean
'Usage

Dim instance As ImGearARTPolyline
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
public bool IsHighlighter {get; set;}
public: __property bool get_IsHighlighter();
public: __property void set_IsHighlighter(
   bool value
);
public:
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


JoinStyle Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
public ImGearARTJoinStyle JoinStyle {get; set;}
public: __property ImGearARTJoinStyle get_JoinStyle();
public: __property void set_JoinStyle(
   ImGearARTJoinStyle value
);
public:
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTJoinStyle Enumeration


NumberOfPoints Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : NumberOfPoints Property
Gets or sets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


Opacity Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


Points Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTPolyline
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearPoint Structure


SelectionPoints Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTPolyline
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


SelectionType Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


StartHeadAngle Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : StartHeadAngle Property
Gets or sets the start head angle of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadAngle As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.StartHeadAngle = value

value = instance.StartHeadAngle
public int StartHeadAngle {get; set;}
public: __property int get_StartHeadAngle();
public: __property void set_StartHeadAngle(
   int value
);
public:
property int StartHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


StartHeadLength Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : StartHeadLength Property
Gets or sets the start head length of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadLength As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.StartHeadLength = value

value = instance.StartHeadLength
public int StartHeadLength {get; set;}
public: __property int get_StartHeadLength();
public: __property void set_StartHeadLength(
   int value
);
public:
property int StartHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


StartHeadType Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : StartHeadType Property
Gets or sets the start head type of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartHeadType As ImGearARTLineHeadType
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTLineHeadType

instance.StartHeadType = value

value = instance.StartHeadType
public ImGearARTLineHeadType StartHeadType {get; set;}
public: __property ImGearARTLineHeadType get_StartHeadType();
public: __property void set_StartHeadType(
   ImGearARTLineHeadType value
);
public:
property ImGearARTLineHeadType StartHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTLineHeadType Enumeration


Style Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Style Property
Gets or sets the style of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTPenStyle Enumeration


Type Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPolyline
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPolyline
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


Width Property (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTPolyline
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%% $$Events$$

ImGearARTPolyline Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyline Class

For a list of all members of this type, see ImGearARTPolyline members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyline Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolyline
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


PointChanged Event (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolyline
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


PointsRemoved Event (ImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyline Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPolyline
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

ImGearARTPolyRuler Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyRuler Class
Represents ART Polyline Ruler mark.
Object Model
ImGearARTPolyRuler ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearARTMeasurementUnit StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPolyRuler
   Inherits ImGearARTMark
   Implements IImGearARTPolyRuler
'Usage

Dim instance As ImGearARTPolyRuler
public class ImGearARTPolyRuler : ImGearARTMark, IImGearARTPolyRuler
public __gc class ImGearARTPolyRuler : public ImGearARTMark, IImGearARTPolyRuler
public ref class ImGearARTPolyRuler : public ImGearARTMark, IImGearARTPolyRuler
Example
  • C#
// Setup points for the ruler.
ImGearPoint[] igPoints = new ImGearPoint[4];
igPoints[0] = new ImGearPoint(10, 10);
igPoints[1] = new ImGearPoint(10, 20);
igPoints[2] = new ImGearPoint(20, 15);
igPoints[3] = new ImGearPoint(30, 10);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the ruler annotation with a solid line of width 2 and 75% opacity,
//  1:1 aspect ratio, end lines of width 50, 3 decimal places of precision,
//  and a label in size 12 regular Arial font.
ImGearARTPolyRuler igARTPolyRuler = new ImGearARTPolyRuler(
    igPoints, igRGBQuad,
    ImGearARTPenStyle.SOLID, 2, (int)(0.75 * 255),
    1, 1, 1, 1, 50, 50, 3,
    "ImGearARTPolyRuler test", "Arial", (float)12.0, ImGearARTFontStyles.Regular);

// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup points for the ruler.
Dim igPoints As ImGearPoint() = New ImGearPoint(3) {}
igPoints(0) = New ImGearPoint(10, 10)
igPoints(1) = New ImGearPoint(10, 20)
igPoints(2) = New ImGearPoint(20, 15)
igPoints(3) = New ImGearPoint(30, 10)
' Setup color for annotation.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the ruler annotation with a solid line of width 2 and 75% opacity,
'  1:1 aspect ratio, end lines of width 50, 3 decimal places of precision,
'  and a label in size 12 regular Arial font.
Dim igARTPolyRuler As New ImGearARTPolyRuler(igPoints, igRGBQuad, ImGearARTPenStyle.SOLID, 2, CInt(Math.Truncate(0.75 * 255)), 1, _
 1, 1, 1, 50, 50, 3, _
 "ImGearARTPolyRuler test", "Arial", CSng(12.0), ImGearARTFontStyles.Regular)

' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyRuler, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPolyRuler

See Also

Reference

ImGearARTPolyRuler Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPolyRuler Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyRuler Class

The following tables list the members exposed by ImGearARTPolyRuler.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPolyRuler Constructor | Overloaded. Initializes a new instance of the ImGearARTPolyRuler class.
Top
Public Properties
 | Name | Description
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndLineLength | Gets or sets the length of the mark's end line.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | Label | Gets or sets the mark label.
Public Property | Length | Gets the length of the PolyRuler mark.
Public Property | MeasurementUnit | Gets or sets the measurement unit of the PolyRuler.
Public Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartLineLength | Gets or sets the length of the mark's start line.
Public Property | Style | Gets or sets the mark's line style.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the mark's line width.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyRuler Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPolyRuler Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : ImGearARTPolyRuler Constructor
Initializes a new instance of the ImGearARTPolyRuler class.
Overload List
Overload | Description
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolyRuler class object.
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution) | Initializes a new instance of the ImGearARTPolyRuler class object using start and end points, color and image resolution.
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTPolyRuler class object.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad)
The mark's points.
Mark color.
Initializes a new instance of the ImGearARTPolyRuler class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTPolyRuler(points, color)
public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color
)
public: ImGearARTPolyRuler(
   ImGearPoint[]* points,
   IImGearRGBQuad* color
)
public:
ImGearARTPolyRuler(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color
)

Parameters

points
The mark's points.
color
Mark color.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution)
The mark's points.
Ruler color.
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.
Initializes a new instance of the ImGearARTPolyRuler class object using start and end points, color and image resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal resolution As IImGearResolution _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim resolution As IImGearResolution

Dim instance As New ImGearARTPolyRuler(points, color, resolution)
public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   IImGearResolution resolution
)
public: ImGearARTPolyRuler(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   IImGearResolution* resolution
)
public:
ImGearARTPolyRuler(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   IImGearResolution^ resolution
)

Parameters

points
The mark's points.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles)
The mark's points.
Mark color.
Mark's line style.
Mark's line width.
Opacity of the mark.
Mark's X aspect numerator value.
Mark's X aspect denominator value.
Mark's Y aspect numerator value.
Mark's Y aspect denominator value.
Length of the start line of the mark.
Length of the end line of the mark.
The number of decimal digits displayed for the mark.
Mark's label.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTPolyRuler class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal points() As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal aspectNumeratorX As Integer, _
   ByVal aspectDenominatorX As Integer, _
   ByVal aspectNumeratorY As Integer, _
   ByVal aspectDenominatorY As Integer, _
   ByVal startLineLength As Integer, _
   ByVal endLineLength As Integer, _
   ByVal precision As Integer, _
   ByVal label As String, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim points() As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim aspectNumeratorX As Integer
Dim aspectDenominatorX As Integer
Dim aspectNumeratorY As Integer
Dim aspectDenominatorY As Integer
Dim startLineLength As Integer
Dim endLineLength As Integer
Dim precision As Integer
Dim label As String
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTPolyRuler(points, color, style, width, opacity, aspectNumeratorX, aspectDenominatorX, aspectNumeratorY, aspectDenominatorY, startLineLength, endLineLength, precision, label, fontName, fontSize, fontStyle)
public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   string label,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTPolyRuler(
   ImGearPoint[]* points,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   string* label,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTPolyRuler(
   array<ImGearPoint>^ points,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   String^ label,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

points
The mark's points.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTPolyRuler Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyRuler Class

For a list of all members of this type, see ImGearARTPolyRuler members.

Public Methods
 | Name | Description
Public Method | AddPoint | Adds the specified point.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetPoint | Gets mark's point with the specified index.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | RemovePoints | Removes the specified number of points, starting at the specified index.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Public Method | SetPoint | Sets mark's point at the specified index.
Top
Protected Methods
 | Name | Description
Protected Method | OnPointAdded | Occurs when a point is added to the mark.
Protected Method | OnPointChanged | Occurs when a point is changed.
Protected Method | OnPointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyRuler Class
ImageGear.ART Namespace


AddPoint Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : AddPoint Method
The point to add.
Adds the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim point As ImGearPoint

instance.AddPoint(point)
public void AddPoint(
   ImGearPoint point
)
public: void AddPoint(
   ImGearPoint point
)
public:
void AddPoint(
   ImGearPoint point
)

Parameters

point
The point to add.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearPoint Structure


Flip Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Flip Method


GetPoint Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : GetPoint Method
Index of the point.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As ImGearARTPolyRuler
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
public ImGearPoint GetPoint(
   int index
)
public: ImGearPoint GetPoint(
   int index
)
public:
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearPoint Structure


GetRenderBounds Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPolyRuler
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Move Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


OnPointAdded Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : OnPointAdded Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointAdded( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointAdded(e)
protected void OnPointAdded(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointAdded(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointAdded(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


OnPointChanged Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : OnPointChanged Method
Event arguments.
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointChanged( _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim e As ImGearARTMarkPointEventArgs

instance.OnPointChanged(e)
protected void OnPointChanged(
   ImGearARTMarkPointEventArgs e
)
protected: void OnPointChanged(
   ImGearARTMarkPointEventArgs* e
)
protected:
void OnPointChanged(
   ImGearARTMarkPointEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


OnPointsRemoved Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : OnPointsRemoved Method
Event arguments.
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPointsRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim e As ImGearARTMarkEventArgs

instance.OnPointsRemoved(e)
protected void OnPointsRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnPointsRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnPointsRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


RemovePoints Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : RemovePoints Method
The index of the first point to remove.
The number of points to remove.
Removes the specified number of points, starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoints( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim index As Integer
Dim count As Integer

instance.RemovePoints(index, count)
public void RemovePoints(
   int index,
   int count
)
public: void RemovePoints(
   int index,
   int count
)
public:
void RemovePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.
Remarks
An error will occur if the specified index or specified number of points to remove is out of range.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Rotate Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Rotate Method


Scale Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Scale Method


SetPoint Method (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As ImGearARTPolyRuler
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearPoint point
)
public: void SetPoint(
   int index,
   ImGearPoint point
)
public:
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearARTPolyRuler Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyRuler Class

For a list of all members of this type, see ImGearARTPolyRuler members.

Public Properties
 | Name | Description
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndLineLength | Gets or sets the length of the mark's end line.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | Label | Gets or sets the mark label.
Public Property | Length | Gets the length of the PolyRuler mark.
Public Property | MeasurementUnit | Gets or sets the measurement unit of the PolyRuler.
Public Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Points | Gets the raw points array.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartLineLength | Gets or sets the length of the mark's start line.
Public Property | Style | Gets or sets the mark's line style.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the mark's line width.
Top
See Also

Reference

ImGearARTPolyRuler Class
ImageGear.ART Namespace


AspectDenominatorX Property (ImGearARTPolyRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorX As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
public int AspectDenominatorX {get; set;}
public: __property int get_AspectDenominatorX();
public: __property void set_AspectDenominatorX(
   int value
);
public:
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.
Example
  • C#
// Setup points for the ruler.
ImGearPoint[] igPoints = new ImGearPoint[4];
igPoints[0] = new ImGearPoint(10, 10);
igPoints[1] = new ImGearPoint(10, 20);
igPoints[2] = new ImGearPoint(20, 15);
igPoints[3] = new ImGearPoint(30, 10);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTPolyRuler polyRuler = new ImGearARTPolyRuler(igPoints, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
polyRuler.AspectNumeratorX = 1;
polyRuler.AspectNumeratorY = 1;

polyRuler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000;
polyRuler.AspectNumeratorY = 1000;

polyRuler.Label = "%d mm";

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup points for the ruler.
Dim igPoints As ImGearPoint() = New ImGearPoint(3) {}
igPoints(0) = New ImGearPoint(10, 10)
igPoints(1) = New ImGearPoint(10, 20)
igPoints(2) = New ImGearPoint(20, 15)
igPoints(3) = New ImGearPoint(30, 10)

' Setup color for the ruler.
Dim color As New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As New ImGearResolution(igPage.DIB.ImageResolution.XNumerator, igPage.DIB.ImageResolution.XDenominator, igPage.DIB.ImageResolution.YNumerator, igPage.DIB.ImageResolution.YDenominator, igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim polyRuler As New ImGearARTPolyRuler(igPoints, color, imageResolution)

' Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
polyRuler.AspectNumeratorX = 1
polyRuler.AspectNumeratorY = 1

polyRuler.Label = "%d in"

' Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000
polyRuler.AspectNumeratorY = 1000

polyRuler.Label = "%d mm"

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


AspectDenominatorY Property (ImGearARTPolyRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorY As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
public int AspectDenominatorY {get; set;}
public: __property int get_AspectDenominatorY();
public: __property void set_AspectDenominatorY(
   int value
);
public:
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup points for the ruler.
ImGearPoint[] igPoints = new ImGearPoint[4];
igPoints[0] = new ImGearPoint(10, 10);
igPoints[1] = new ImGearPoint(10, 20);
igPoints[2] = new ImGearPoint(20, 15);
igPoints[3] = new ImGearPoint(30, 10);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTPolyRuler polyRuler = new ImGearARTPolyRuler(igPoints, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
polyRuler.AspectNumeratorX = 1;
polyRuler.AspectNumeratorY = 1;

polyRuler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000;
polyRuler.AspectNumeratorY = 1000;

polyRuler.Label = "%d mm";

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup points for the ruler.
Dim igPoints As ImGearPoint() = New ImGearPoint(3) {}
igPoints(0) = New ImGearPoint(10, 10)
igPoints(1) = New ImGearPoint(10, 20)
igPoints(2) = New ImGearPoint(20, 15)
igPoints(3) = New ImGearPoint(30, 10)

' Setup color for the ruler.
Dim color As New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As New ImGearResolution(igPage.DIB.ImageResolution.XNumerator, igPage.DIB.ImageResolution.XDenominator, igPage.DIB.ImageResolution.YNumerator, igPage.DIB.ImageResolution.YDenominator, igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim polyRuler As New ImGearARTPolyRuler(igPoints, color, imageResolution)

' Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
polyRuler.AspectNumeratorX = 1
polyRuler.AspectNumeratorY = 1

polyRuler.Label = "%d in"

' Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000
polyRuler.AspectNumeratorY = 1000

polyRuler.Label = "%d mm"

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


AspectNumeratorX Property (ImGearARTPolyRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorX As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
public int AspectNumeratorX {get; set;}
public: __property int get_AspectNumeratorX();
public: __property void set_AspectNumeratorX(
   int value
);
public:
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup points for the ruler.
ImGearPoint[] igPoints = new ImGearPoint[4];
igPoints[0] = new ImGearPoint(10, 10);
igPoints[1] = new ImGearPoint(10, 20);
igPoints[2] = new ImGearPoint(20, 15);
igPoints[3] = new ImGearPoint(30, 10);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTPolyRuler polyRuler = new ImGearARTPolyRuler(igPoints, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
polyRuler.AspectNumeratorX = 1;
polyRuler.AspectNumeratorY = 1;

polyRuler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000;
polyRuler.AspectNumeratorY = 1000;

polyRuler.Label = "%d mm";

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup points for the ruler.
Dim igPoints As ImGearPoint() = New ImGearPoint(3) {}
igPoints(0) = New ImGearPoint(10, 10)
igPoints(1) = New ImGearPoint(10, 20)
igPoints(2) = New ImGearPoint(20, 15)
igPoints(3) = New ImGearPoint(30, 10)

' Setup color for the ruler.
Dim color As New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As New ImGearResolution(igPage.DIB.ImageResolution.XNumerator, igPage.DIB.ImageResolution.XDenominator, igPage.DIB.ImageResolution.YNumerator, igPage.DIB.ImageResolution.YDenominator, igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim polyRuler As New ImGearARTPolyRuler(igPoints, color, imageResolution)

' Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
polyRuler.AspectNumeratorX = 1
polyRuler.AspectNumeratorY = 1

polyRuler.Label = "%d in"

' Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000
polyRuler.AspectNumeratorY = 1000

polyRuler.Label = "%d mm"

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


AspectNumeratorY Property (ImGearARTPolyRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorY As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
public int AspectNumeratorY {get; set;}
public: __property int get_AspectNumeratorY();
public: __property void set_AspectNumeratorY(
   int value
);
public:
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup points for the ruler.
ImGearPoint[] igPoints = new ImGearPoint[4];
igPoints[0] = new ImGearPoint(10, 10);
igPoints[1] = new ImGearPoint(10, 20);
igPoints[2] = new ImGearPoint(20, 15);
igPoints[3] = new ImGearPoint(30, 10);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTPolyRuler polyRuler = new ImGearARTPolyRuler(igPoints, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
polyRuler.AspectNumeratorX = 1;
polyRuler.AspectNumeratorY = 1;

polyRuler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
polyRuler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000;
polyRuler.AspectNumeratorY = 1000;

polyRuler.Label = "%d mm";

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup points for the ruler.
Dim igPoints As ImGearPoint() = New ImGearPoint(3) {}
igPoints(0) = New ImGearPoint(10, 10)
igPoints(1) = New ImGearPoint(10, 20)
igPoints(2) = New ImGearPoint(20, 15)
igPoints(3) = New ImGearPoint(30, 10)

' Setup color for the ruler.
Dim color As New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As New ImGearResolution(igPage.DIB.ImageResolution.XNumerator, igPage.DIB.ImageResolution.XDenominator, igPage.DIB.ImageResolution.YNumerator, igPage.DIB.ImageResolution.YDenominator, igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim polyRuler As New ImGearARTPolyRuler(igPoints, color, imageResolution)

' Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
polyRuler.AspectNumeratorX = 1
polyRuler.AspectNumeratorY = 1

polyRuler.Label = "%d in"

' Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
polyRuler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
polyRuler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
polyRuler.AspectNumeratorX = 1000
polyRuler.AspectNumeratorY = 1000

polyRuler.Label = "%d mm"

igARTPage.AddMark(polyRuler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Bounds Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearRectangle Structure


CapStyle Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearRGBQuad Structure


EndLineLength Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : EndLineLength Property
Gets or sets the length of the mark's end line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndLineLength As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.EndLineLength = value

value = instance.EndLineLength
public int EndLineLength {get; set;}
public: __property int get_EndLineLength();
public: __property void set_EndLineLength(
   int value
);
public:
property int EndLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 20.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


FontDisablePPM Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


FontName Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The default value is "Arial".
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


FontSize Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


FontStyleART Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


IsLabelVisible Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : IsLabelVisible Property
Gets or sets a value indicating whether the label is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsLabelVisible As Boolean
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
public bool IsLabelVisible {get; set;}
public: __property bool get_IsLabelVisible();
public: __property void set_IsLabelVisible(
   bool value
);
public:
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean variable.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


JoinStyle Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
public ImGearARTJoinStyle JoinStyle {get; set;}
public: __property ImGearARTJoinStyle get_JoinStyle();
public: __property void set_JoinStyle(
   ImGearARTJoinStyle value
);
public:
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearARTJoinStyle Enumeration


Label Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Label Property
Gets or sets the mark label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Label As String
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As String

instance.Label = value

value = instance.Label
public string Label {get; set;}
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
public:
property String^ Label {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The default value is "%d mm".
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Length Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Length Property
Gets the length of the PolyRuler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Double
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Double

value = instance.Length
public double Length {get;}
public: __property double get_Length();
public:
property double Length {
   double get();
}

Property Value

Double value.
Remarks
Note: The annotation must be added to the ImGearARTPage prior to using this property.

Note: If the AspectKind is ImGearARTAspectKind.Relative, please initialize Resolution prior to using this property, otherwise ImageGear.Core.ImGearException will be thrown. The resolution is necessary for length calculation in Relative mode.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
IImGearResolution Interface
Resolution Property
ImageResolution Property
DIB Property


MeasurementUnit Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : MeasurementUnit Property
Gets or sets the measurement unit of the PolyRuler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MeasurementUnit As ImGearARTMeasurementUnit
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTMeasurementUnit

instance.MeasurementUnit = value

value = instance.MeasurementUnit
public ImGearARTMeasurementUnit MeasurementUnit {get; set;}
public: __property ImGearARTMeasurementUnit get_MeasurementUnit();
public: __property void set_MeasurementUnit(
   ImGearARTMeasurementUnit value
);
public:
property ImGearARTMeasurementUnit MeasurementUnit {
   ImGearARTMeasurementUnit get();
   void set (    ImGearARTMeasurementUnit value);
}

Property Value

ImGearARTMeasurementUnit value.
Remarks
The getter returns either instance of some predefined measurement unit, associated with currently initialized AspectNumeratorX, AspectDenominatorX, AspectNumeratorY and AspectDenominatorY values, or instance of the ImGearARTMeasurementUnit with Name equal to "Custom" and Aspect values, initialized from corresponding Aspect values of the PolyRuler.

Note: The annotation must be added to the ImGearARTPage prior to using this property.

Note: If the AspectKind is ImGearARTAspectKind.Absolute, please initialize Resolution prior to using this property, otherwise ImageGear.Core.ImGearException will be thrown. The resolution is necessary for initialization of Aspect properties in Absolute mode.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
IImGearResolution Interface
Resolution Property
ImageResolution Property
DIB Property


NumberOfPoints Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : NumberOfPoints Property
Gets or sets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")>
Public Property NumberOfPoints As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
public int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
public: __property int get_NumberOfPoints();
public: __property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
public:
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Opacity Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Points Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")>
Public ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As ImGearARTPolyRuler
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
public ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
public: __property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
public:
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearPoint Structure


Precision Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
public:
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


SelectionPoints Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


SelectionType Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


StartLineLength Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : StartLineLength Property
Gets or sets the length of the mark's start line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartLineLength As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.StartLineLength = value

value = instance.StartLineLength
public int StartLineLength {get; set;}
public: __property int get_StartLineLength();
public: __property void set_StartLineLength(
   int value
);
public:
property int StartLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 20.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Style Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Style Property
Gets or sets the mark's line style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearARTPenStyle Enumeration


Type Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


Width Property (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : Width Property
Gets or sets the mark's line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTPolyRuler
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%% $$Events$$

ImGearARTPolyRuler Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPolyRuler Class

For a list of all members of this type, see ImGearARTPolyRuler members.

Public Events
 | Name | Description
Public Event | PointAdded | Occurs when a point is added to the mark.
Public Event | PointChanged | Occurs when a point is changed.
Public Event | PointsRemoved | Occurs when points are removed.
Top
See Also

Reference

ImGearARTPolyRuler Class
ImageGear.ART Namespace


PointAdded Event (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : PointAdded Event
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointAdded As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolyRuler
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointAdded, handler
public event ImGearARTMarkPointEventHandler PointAdded
public: __event ImGearARTMarkPointEventHandler* PointAdded
public:
event ImGearARTMarkPointEventHandler^ PointAdded
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


PointChanged Event (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : PointChanged Event
Occurs when a point is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointChanged As ImGearARTMarkPointEventHandler
'Usage

Dim instance As ImGearARTPolyRuler
Dim handler As ImGearARTMarkPointEventHandler

AddHandler instance.PointChanged, handler
public event ImGearARTMarkPointEventHandler PointChanged
public: __event ImGearARTMarkPointEventHandler* PointChanged
public:
event ImGearARTMarkPointEventHandler^ PointChanged
Event Data

The event handler receives an argument of type ImGearARTMarkPointEventArgs containing data related to this event. The following ImGearARTMarkPointEventArgs properties provide information specific to this event.

Property | Description
Point | Gets the point that was added or changed.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


PointsRemoved Event (ImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPolyRuler Class : PointsRemoved Event
Occurs when points are removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PointsRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As ImGearARTPolyRuler
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.PointsRemoved, handler
public event ImGearARTMarkEventHandler PointsRemoved
public: __event ImGearARTMarkEventHandler* PointsRemoved
public:
event ImGearARTMarkEventHandler^ PointsRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

ImGearARTPopupText Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPopupText Class
Represents ART Text mark.
Object Model
ImGearARTPopupText ClassImGearARTBorder ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle StructureImGearARTThickness StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPopupText
   Inherits ImGearARTMark
   Implements IImGearARTPopupText
'Usage

Dim instance As ImGearARTPopupText
public class ImGearARTPopupText : ImGearARTMark, IImGearARTPopupText
public __gc class ImGearARTPopupText : public ImGearARTMark, IImGearARTPopupText
public ref class ImGearARTPopupText : public ImGearARTMark, IImGearARTPopupText
Example
  • C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTPopupText

See Also

Reference

ImGearARTPopupText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPopupText Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPopupText Class

The following tables list the members exposed by ImGearARTPopupText.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPopupText Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ActualText | Gets or sets the actual text you can see on display.
Public Property | AlignmentH | Gets or sets the horizontal text alignment.
Public Property | AlignmentV | Gets or sets the vertical text alignment.
Public Property | AnchorX | Gets or sets the anchor's X location.
Public Property | AnchorY | Gets or sets the anchor's Y location.
Public Property | AutoSize | Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Public Property | Border | Gets or sets the mark border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the mark text.
Public Property | FontSize | Gets or sets the font size of the mark text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | IsOpen | Gets or sets a value indicating whether the popup text is opened.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Orientation | Gets or sets the text orientation.
Public Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the color of the mark text.
Public Property | TextOpacity | Gets or sets a separate opacity used for text string.
Public Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Public Property | TextType | Gets or sets the text type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins the text editing process.
Public Method | EndEdit | Ends the text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPopupText Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPopupText Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : ImGearARTPopupText Constructor
Overload List
Overload | Description
ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPopupText class object.
ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout) | Initializes a new instance of the ImGearARTPopupText class object.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


%%PageItemTitle%%

ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class > ImGearARTPopupText Constructor : ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Initializes a new instance of the ImGearARTPopupText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTPopupText(rect, text, textColor)
public ImGearARTPopupText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTPopupText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTPopupText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class > ImGearARTPopupText Constructor : ImGearARTPopupText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Text type.
Text opacity.
Fill color of the mark.
Border of the mark.
Specifies whether the mark's border is shaded or not.
Opacity of the mark.
The name of the font.
The size of the font in points.
The style of the font.
ImGearARTPin class object that specifies mark's pin icon attributes.
ImGearARTCallout class object that specifies mark's callout attributes.
Initializes a new instance of the ImGearARTPopupText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal textType As ImGearARTTextType, _
   ByVal textOpacity As Integer, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal border As ImGearARTBorder, _
   ByVal isBorderShaded As Boolean, _
   ByVal opacity As Integer, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles, _
   ByVal pin As ImGearARTPin, _
   ByVal callout As ImGearARTCallout _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim textType As ImGearARTTextType
Dim textOpacity As Integer
Dim fillColor As IImGearRGBQuad
Dim border As ImGearARTBorder
Dim isBorderShaded As Boolean
Dim opacity As Integer
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles
Dim pin As ImGearARTPin
Dim callout As ImGearARTCallout

Dim instance As New ImGearARTPopupText(rect, text, textColor, textType, textOpacity, fillColor, border, isBorderShaded, opacity, fontName, fontSize, fontStyle, pin, callout)
public ImGearARTPopupText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad fillColor,
   ImGearARTBorder border,
   bool isBorderShaded,
   int opacity,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin pin,
   ImGearARTCallout callout
)
public: ImGearARTPopupText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad* fillColor,
   ImGearARTBorder* border,
   bool isBorderShaded,
   int opacity,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin* pin,
   ImGearARTCallout* callout
)
public:
ImGearARTPopupText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad^ fillColor,
   ImGearARTBorder^ border,
   bool isBorderShaded,
   int opacity,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin^ pin,
   ImGearARTCallout^ callout
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
textType
Text type.
textOpacity
Text opacity.
fillColor
Fill color of the mark.
border
Border of the mark.
isBorderShaded
Specifies whether the mark's border is shaded or not.
opacity
Opacity of the mark.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
pin
ImGearARTPin class object that specifies mark's pin icon attributes.
callout
ImGearARTCallout class object that specifies mark's callout attributes.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTTextType Enumeration
ImGearARTBorder Class
ImGearARTPin Class
ImGearARTCallout Class


%%PageItemTitle%% $$Methods$$

ImGearARTPopupText Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPopupText Class

For a list of all members of this type, see ImGearARTPopupText members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins the text editing process.
Public Method | EndEdit | Ends the text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTPopupText Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTPopupText Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPopupText Class

For a list of all members of this type, see ImGearARTPopupText members.

See Also

Reference

ImGearARTPopupText Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins the text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTPopupText
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : EndEdit Method
PageView control that contains text mark.
Ends the text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTPopupText
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
IImGearScrollableView Interface


Flip Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTPopupText
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Flip Method


GetRenderBounds Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPopupText
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Move Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Move Method
X offset in abstract coordinates.
Y offset in abstract coordinates.
Moves mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTPopupText
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Rotate Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTPopupText
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Rotate Method


Scale Method (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTPopupText
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTPopupText Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPopupText Class

For a list of all members of this type, see ImGearARTPopupText members.

Public Properties
 | Name | Description
Public Property | ActualText | Gets or sets the actual text you can see on display.
Public Property | AlignmentH | Gets or sets the horizontal text alignment.
Public Property | AlignmentV | Gets or sets the vertical text alignment.
Public Property | AnchorX | Gets or sets the anchor's X location.
Public Property | AnchorY | Gets or sets the anchor's Y location.
Public Property | AutoSize | Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Public Property | Border | Gets or sets the mark border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the mark text.
Public Property | FontSize | Gets or sets the font size of the mark text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | IsOpen | Gets or sets a value indicating whether the popup text is opened.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Orientation | Gets or sets the text orientation.
Public Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the color of the mark text.
Public Property | TextOpacity | Gets or sets a separate opacity used for text string.
Public Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Public Property | TextType | Gets or sets the text type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTPopupText Class
ImageGear.ART Namespace


ActualText Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : ActualText Property
Gets or sets the actual text you can see on display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActualText As String
'Usage

Dim instance As ImGearARTPopupText
Dim value As String

instance.ActualText = value

value = instance.ActualText
public string ActualText {get; set;}
public: __property string* get_ActualText();
public: __property void set_ActualText(
   string* value
);
public:
property String^ ActualText {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
If TextType value is ImGearARTTextType.FILE_NAME the ActualText property holds a string with the file content. If TextType value is ImGearARTTextType.DIRECT_TEXT the ActualText property holds a string containing the same value as Text property.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
Text Property


AlignmentH Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : AlignmentH Property
Gets or sets the horizontal text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
public ImGearAlignmentHModes AlignmentH {get; set;}
public: __property ImGearAlignmentHModes get_AlignmentH();
public: __property void set_AlignmentH(
   ImGearAlignmentHModes value
);
public:
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
Remarks
The default value is ImGearAlignmentHModes.LEFT.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : AlignmentV Property
Gets or sets the vertical text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
public ImGearAlignmentVModes AlignmentV {get; set;}
public: __property ImGearAlignmentVModes get_AlignmentV();
public: __property void set_AlignmentV(
   ImGearAlignmentVModes value
);
public:
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
Remarks
The default value is ImGearAlignmentVModes.TOP.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearAlignmentVModes Enumeration


AnchorX Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : AnchorX Property
Gets or sets the anchor's X location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnchorX As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.AnchorX = value

value = instance.AnchorX
public int AnchorX {get; set;}
public: __property int get_AnchorX();
public: __property void set_AnchorX(
   int value
);
public:
property int AnchorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the left edge of the text mark.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


AnchorY Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : AnchorY Property
Gets or sets the anchor's Y location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnchorY As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.AnchorY = value

value = instance.AnchorY
public int AnchorY {get; set;}
public: __property int get_AnchorY();
public: __property void set_AnchorY(
   int value
);
public:
property int AnchorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the top edge of the text mark.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


AutoSize Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : AutoSize Property
Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoSize As Boolean
'Usage

Dim instance As ImGearARTPopupText
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
public bool AutoSize {get; set;}
public: __property bool get_AutoSize();
public: __property void set_AutoSize(
   bool value
);
public:
property bool AutoSize {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Border Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Border Property
Gets or sets the mark border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearARTBorder Class


Bounds Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearRectangle Structure


FillColor Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPopupText
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearRGBQuad Structure


FontDisablePPM Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTPopupText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


FontName Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : FontName Property
Gets or sets the font name of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTPopupText
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String name.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


FontSize Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : FontSize Property
Gets or sets the font size of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTPopupText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


FontStyleART Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : FontStyleART Property
Gets or sets the font style of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Height Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


IsOpen Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : IsOpen Property
Gets or sets a value indicating whether the popup text is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsOpen As Boolean
'Usage

Dim instance As ImGearARTPopupText
Dim value As Boolean

instance.IsOpen = value

value = instance.IsOpen
public bool IsOpen {get; set;}
public: __property bool get_IsOpen();
public: __property void set_IsOpen(
   bool value
);
public:
property bool IsOpen {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Opacity Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
This Opacity property is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use TextOpacity property. The default value is 255.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Orientation Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Orientation Property
Gets or sets the text orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearOrientationModes Enumeration


Padding Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Padding Property
Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Padding As ImGearARTThickness
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTThickness

instance.Padding = value

value = instance.Padding
public ImGearARTThickness Padding {get; set;}
public: __property ImGearARTThickness get_Padding();
public: __property void set_Padding(
   ImGearARTThickness value
);
public:
property ImGearARTThickness Padding {
   ImGearARTThickness get();
   void set (    ImGearARTThickness value);
}

Property Value

ImGearARTThickness structure instance.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


SelectionType Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Text Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Text Property
Gets or sets the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTPopupText
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
If TextType value is ImGearARTTextType.FILE_NAME the Text property holds a string with the file name. If TextType value is ImGearARTTextType.DIRECT_TEXT the Text property holds the actual text. Use ActualText to get the file content if TextType value is ImGearARTTextType.FILE_NAME.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ActualText Property


TextColor Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : TextColor Property
Gets or sets the color of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTPopupText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearRGBQuad Structure


TextOpacity Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : TextOpacity Property
Gets or sets a separate opacity used for text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextOpacity As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.TextOpacity = value

value = instance.TextOpacity
public int TextOpacity {get; set;}
public: __property int get_TextOpacity();
public: __property void set_TextOpacity(
   int value
);
public:
property int TextOpacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the Opacity property used to set the opacity for the entire mark. The default value is 255.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


TextTrimming Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : TextTrimming Property
Gets or sets the text trimming behavior to employ when content overflows the content area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextTrimming As ImGearARTTextTrimming
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTTextTrimming

instance.TextTrimming = value

value = instance.TextTrimming
public ImGearARTTextTrimming TextTrimming {get; set;}
public: __property ImGearARTTextTrimming get_TextTrimming();
public: __property void set_TextTrimming(
   ImGearARTTextTrimming value
);
public:
property ImGearARTTextTrimming TextTrimming {
   ImGearARTTextTrimming get();
   void set (    ImGearARTTextTrimming value);
}

Property Value

ImGearARTTextTrimming enumeration value.
Remarks
NOTE: The text trimming behavior is only supported by WPF annotation renderer. It is not currently supported in WinForms applications.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


TextType Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : TextType Property
Gets or sets the text type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextType As ImGearARTTextType
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTTextType

instance.TextType = value

value = instance.TextType
public ImGearARTTextType TextType {get; set;}
public: __property ImGearARTTextType get_TextType();
public: __property void set_TextType(
   ImGearARTTextType value
);
public:
property ImGearARTTextType TextType {
   ImGearARTTextType get();
   void set (    ImGearARTTextType value);
}

Property Value

ImGearARTTextType enumeration value.
Remarks
The default value is ImGearARTTextType.DIRECT_TEXT.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearARTTextType Enumeration
Text Property
ActualText Property


Type Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTPopupText
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTPopupText
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Width Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


X Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


Y Property (ImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPopupText Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTPopupText
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTPopupText Class
ImGearARTPopupText Members


%%PageItemTitle%%

ImGearARTPropertyChangedEventArgs Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPropertyChangedEventArgs Class
Provides data for the ARTPropertyChanged events.
Object Model
ImGearARTPropertyChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPropertyChangedEventArgs
   Inherits System.ComponentModel.PropertyChangedEventArgs
'Usage

Dim instance As ImGearARTPropertyChangedEventArgs
public class ImGearARTPropertyChangedEventArgs : System.ComponentModel.PropertyChangedEventArgs
public __gc class ImGearARTPropertyChangedEventArgs : public System.ComponentModel.PropertyChangedEventArgs
public ref class ImGearARTPropertyChangedEventArgs : public System.ComponentModel.PropertyChangedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.PropertyChangedEventArgs
ImageGear.ART.ImGearARTPropertyChangedEventArgs

See Also

Reference

ImGearARTPropertyChangedEventArgs Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPropertyChangedEventArgs Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPropertyChangedEventArgs Class

The following tables list the members exposed by ImGearARTPropertyChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPropertyChangedEventArgs Constructor | Initializes a new instance of the ImGearARTPropertyChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | NewPropertyValue | Gets new value of changed property.
Public Property | OldPropertyValue | Gets old value of changed property.
Top
See Also

Reference

ImGearARTPropertyChangedEventArgs Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPropertyChangedEventArgs Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPropertyChangedEventArgs Class : ImGearARTPropertyChangedEventArgs Constructor
The name of changed property.
The old value of changed property.
The new value of changed property.
Initializes a new instance of the ImGearARTPropertyChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal propertyName As String, _
   ByVal oldPropertyValue As Object, _
   ByVal newPropertyValue As Object _
)
'Usage

Dim propertyName As String
Dim oldPropertyValue As Object
Dim newPropertyValue As Object

Dim instance As New ImGearARTPropertyChangedEventArgs(propertyName, oldPropertyValue, newPropertyValue)
public ImGearARTPropertyChangedEventArgs(
   string propertyName,
   object oldPropertyValue,
   object newPropertyValue
)
public: ImGearARTPropertyChangedEventArgs(
   string* propertyName,
   Object* oldPropertyValue,
   Object* newPropertyValue
)
public:
ImGearARTPropertyChangedEventArgs(
   String^ propertyName,
   Object^ oldPropertyValue,
   Object^ newPropertyValue
)

Parameters

propertyName
The name of changed property.
oldPropertyValue
The old value of changed property.
newPropertyValue
The new value of changed property.
See Also

Reference

ImGearARTPropertyChangedEventArgs Class
ImGearARTPropertyChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearARTPropertyChangedEventArgs Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPropertyChangedEventArgs Class

For a list of all members of this type, see ImGearARTPropertyChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | NewPropertyValue | Gets new value of changed property.
Public Property | OldPropertyValue | Gets old value of changed property.
Top
See Also

Reference

ImGearARTPropertyChangedEventArgs Class
ImageGear.ART Namespace


NewPropertyValue Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPropertyChangedEventArgs Class : NewPropertyValue Property
Gets new value of changed property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewPropertyValue As Object
'Usage

Dim instance As ImGearARTPropertyChangedEventArgs
Dim value As Object

value = instance.NewPropertyValue
public object NewPropertyValue {get;}
public: __property Object* get_NewPropertyValue();
public:
property Object^ NewPropertyValue {
   Object^ get();
}

Property Value

Object value.
See Also

Reference

ImGearARTPropertyChangedEventArgs Class
ImGearARTPropertyChangedEventArgs Members


OldPropertyValue Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTPropertyChangedEventArgs Class : OldPropertyValue Property
Gets old value of changed property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldPropertyValue As Object
'Usage

Dim instance As ImGearARTPropertyChangedEventArgs
Dim value As Object

value = instance.OldPropertyValue
public object OldPropertyValue {get;}
public: __property Object* get_OldPropertyValue();
public:
property Object^ OldPropertyValue {
   Object^ get();
}

Property Value

Object value.
See Also

Reference

ImGearARTPropertyChangedEventArgs Class
ImGearARTPropertyChangedEventArgs Members


%%PageItemTitle%%

ImGearARTProtractor Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTProtractor Class
Represents ART Protractor mark.
Object Model
ImGearARTProtractor ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTProtractor
   Inherits ImGearARTMark
   Implements IImGearARTProtractor
'Usage

Dim instance As ImGearARTProtractor
public class ImGearARTProtractor : ImGearARTMark, IImGearARTProtractor
public __gc class ImGearARTProtractor : public ImGearARTMark, IImGearARTProtractor
public ref class ImGearARTProtractor : public ImGearARTMark, IImGearARTProtractor
Example
  • C#
// Setup location for the protractor
ImGearPoint igPointStart = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
ImGearPoint igPointHead = new ImGearPoint(50, 50);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, 50);
// Setup color for the protractor.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the protractor annotation with a width of 3 and 90% opacity,
// 1:1 aspect ratio, radius of 100 for the arc drawn in the protractor,
// 3 decimals of precision, and size 12 regular Times New Roman font.
ImGearARTProtractor igARTProtractor = new ImGearARTProtractor(
    igPointStart, igPointHead, igPointEnd, igRGBQuad,
    ImGearARTPenStyle.SOLID, 3, (int)(0.90 * 255),
    1, 1, 1, 1, 100,
    3, "Times New Roman", (float)12.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTProtractor, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup location for the protractor
Dim igPointStart As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
Dim igPointHead As New ImGearPoint(50, 50)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, 50)
' Setup color for the protractor.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the protractor annotation with a width of 3 and 90% opacity,
' 1:1 aspect ratio, radius of 100 for the arc drawn in the protractor,
' 3 decimals of precision, and size 12 regular Times New Roman font.
Dim igARTProtractor As New ImGearARTProtractor( _
 igPointStart, igPointHead, igPointEnd, igRGBQuad, _
 ImGearARTPenStyle.SOLID, 3, CInt(0.9 * 255), _
 1, 1, 1, 1, 100, _
 3, "Times New Roman", CSng(12), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTProtractor, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTProtractor

See Also

Reference

ImGearARTProtractor Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTProtractor Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTProtractor Class

The following tables list the members exposed by ImGearARTProtractor.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTProtractor Constructor | Overloaded. Initializes a new instance of the ImGearARTProtractor class.
Top
Public Properties
 | Name | Description
Public Property | ArcRadius | Gets or sets the radius of the arc drawn in the mark.
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the mark color.
Public Property | EndPoint | Gets or sets the end point of the protractor.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | HeadPoint | Gets or sets the head point of the protractor.
Public Property | IsLabelVisible | Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartPoint | Gets or sets the start point of the protractor.
Public Property | Style | Gets or sets the style of the mark's line.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's line.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTProtractor Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTProtractor Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : ImGearARTProtractor Constructor
Initializes a new instance of the ImGearARTProtractor class.
Overload List
Overload | Description
ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTProtractor class object.
ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTProtractor class object.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class > ImGearARTProtractor Constructor : ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad)
Start point of the mark.
Head point of the mark.
End point of the mark.
Mark color.
Initializes a new instance of the ImGearARTProtractor class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal headPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim startPoint As ImGearPoint
Dim headPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTProtractor(startPoint, headPoint, endPoint, color)
public ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)
public: ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color
)
public:
ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color
)

Parameters

startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class > ImGearARTProtractor Constructor : ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,Single,ImGearARTFontStyles)
Start point of the mark.
Head point of the mark.
End point of the mark.
Mark color.
Mark's line style.
Mark's line width.
Opacity of the mark.
Mark's X aspect numerator value.
Mark's X aspect denominator value.
Mark's Y aspect numerator value.
Mark's Y aspect denominator value.
The radius, in pixels, of the arc drawn in the mark.
The number of decimal digits displayed for the mark.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTProtractor class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal headPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal aspectNumeratorX As Integer, _
   ByVal aspectDenominatorX As Integer, _
   ByVal aspectNumeratorY As Integer, _
   ByVal aspectDenominatorY As Integer, _
   ByVal arcRadius As Integer, _
   ByVal precision As Integer, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim startPoint As ImGearPoint
Dim headPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim aspectNumeratorX As Integer
Dim aspectDenominatorX As Integer
Dim aspectNumeratorY As Integer
Dim aspectDenominatorY As Integer
Dim arcRadius As Integer
Dim precision As Integer
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTProtractor(startPoint, headPoint, endPoint, color, style, width, opacity, aspectNumeratorX, aspectDenominatorX, aspectNumeratorY, aspectDenominatorY, arcRadius, precision, fontName, fontSize, fontStyle)
public ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int arcRadius,
   int precision,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int arcRadius,
   int precision,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int arcRadius,
   int precision,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
arcRadius
The radius, in pixels, of the arc drawn in the mark.
precision
The number of decimal digits displayed for the mark.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTProtractor Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTProtractor Class

For a list of all members of this type, see ImGearARTProtractor members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTProtractor Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTProtractor Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTProtractor Class

For a list of all members of this type, see ImGearARTProtractor members.

See Also

Reference

ImGearARTProtractor Class
ImageGear.ART Namespace


Flip Method (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTProtractor
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Flip Method


GetRenderBounds Method (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTProtractor
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


Move Method (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTProtractor
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


Rotate Method (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTProtractor
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Rotate Method


Scale Method (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTProtractor
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTProtractor Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTProtractor Class

For a list of all members of this type, see ImGearARTProtractor members.

Public Properties
 | Name | Description
Public Property | ArcRadius | Gets or sets the radius of the arc drawn in the mark.
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the mark color.
Public Property | EndPoint | Gets or sets the end point of the protractor.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | HeadPoint | Gets or sets the head point of the protractor.
Public Property | IsLabelVisible | Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Public Property | JoinStyle | Gets or sets the style of two lines joins.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartPoint | Gets or sets the start point of the protractor.
Public Property | Style | Gets or sets the style of the mark's line.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's line.
Top
See Also

Reference

ImGearARTProtractor Class
ImageGear.ART Namespace


ArcRadius Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : ArcRadius Property
Gets or sets the radius of the arc drawn in the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArcRadius As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.ArcRadius = value

value = instance.ArcRadius
public int ArcRadius {get; set;}
public: __property int get_ArcRadius();
public: __property void set_ArcRadius(
   int value
);
public:
property int ArcRadius {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The radius is measured in pixels. The default value is 0.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


AspectDenominatorX Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorX As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
public int AspectDenominatorX {get; set;}
public: __property int get_AspectDenominatorX();
public: __property void set_AspectDenominatorX(
   int value
);
public:
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


AspectDenominatorY Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorY As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
public int AspectDenominatorY {get; set;}
public: __property int get_AspectDenominatorY();
public: __property void set_AspectDenominatorY(
   int value
);
public:
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


AspectNumeratorX Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorX As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
public int AspectNumeratorX {get; set;}
public: __property int get_AspectNumeratorX();
public: __property void set_AspectNumeratorX(
   int value
);
public:
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


AspectNumeratorY Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorY As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
public int AspectNumeratorY {get; set;}
public: __property int get_AspectNumeratorY();
public: __property void set_AspectNumeratorY(
   int value
);
public:
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


Bounds Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearRectangle Structure


CapStyle Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Color Property
Gets or sets the mark color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTProtractor
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearRGBQuad Structure


EndPoint Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : EndPoint Property
Gets or sets the end point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoint As ImGearPoint
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
public ImGearPoint EndPoint {get; set;}
public: __property ImGearPoint get_EndPoint();
public: __property void set_EndPoint(
   ImGearPoint value
);
public:
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearPoint Structure


FontDisablePPM Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTProtractor
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


FontName Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTProtractor
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


FontSize Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTProtractor
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


FontStyleART Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


HeadPoint Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : HeadPoint Property
Gets or sets the head point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadPoint As ImGearPoint
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearPoint

instance.HeadPoint = value

value = instance.HeadPoint
public ImGearPoint HeadPoint {get; set;}
public: __property ImGearPoint get_HeadPoint();
public: __property void set_HeadPoint(
   ImGearPoint value
);
public:
property ImGearPoint HeadPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearPoint Structure


IsLabelVisible Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : IsLabelVisible Property
Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsLabelVisible As Boolean
'Usage

Dim instance As ImGearARTProtractor
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
public bool IsLabelVisible {get; set;}
public: __property bool get_IsLabelVisible();
public: __property void set_IsLabelVisible(
   bool value
);
public:
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


JoinStyle Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
public ImGearARTJoinStyle JoinStyle {get; set;}
public: __property ImGearARTJoinStyle get_JoinStyle();
public: __property void set_JoinStyle(
   ImGearARTJoinStyle value
);
public:
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearARTJoinStyle Enumeration


Opacity Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


Precision Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
public:
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


SelectionPoints Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTProtractor
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


SelectionType Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


StartPoint Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : StartPoint Property
Gets or sets the start point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPoint As ImGearPoint
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
public ImGearPoint StartPoint {get; set;}
public: __property ImGearPoint get_StartPoint();
public: __property void set_StartPoint(
   ImGearPoint value
);
public:
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearPoint Structure


Style Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Style Property
Gets or sets the style of the mark's line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearARTPenStyle Enumeration


Type Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTProtractor
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTProtractor
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


Width Property (ImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTProtractor Class : Width Property
Gets or sets the width of the mark's line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTProtractor
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

ImGearARTRectangle Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRectangle Class
Represents ART Rectangle mark.
Object Model
ImGearARTRectangle ClassImGearARTBorder ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTRectangle
   Inherits ImGearARTMark
   Implements IImGearARTRectangle
'Usage

Dim instance As ImGearARTRectangle
public class ImGearARTRectangle : ImGearARTMark, IImGearARTRectangle
public __gc class ImGearARTRectangle : public ImGearARTMark, IImGearARTRectangle
public ref class ImGearARTRectangle : public ImGearARTMark, IImGearARTRectangle
Example
  • C#
// Setup rectangle for the rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the rectangle.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Setup color for the rectangle border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 0, 0);
// Create rectangle with a solid border of width 10, and 33% opacity.
ImGearARTRectangle igARTRectangle = new ImGearARTRectangle(
    igRectangle, igRGBQuadFill, igRGBQuadBorder,
    ImGearARTPenStyle.SOLID, 10, (int)(0.33 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the rectangle.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Setup color for the rectangle border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 0, 0)
' Create rectangle with a solid border of width 10, and 33% opacity.
Dim igARTRectangle As New ImGearARTRectangle( _
 igRectangle, igRGBQuadFill, igRGBQuadBorder, _
 ImGearARTPenStyle.SOLID, 10, CInt(0.33 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTRectangle

See Also

Reference

ImGearARTRectangle Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRectangle Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRectangle Class

The following tables list the members exposed by ImGearARTRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTRectangle Constructor | Overloaded. Initializes a new instance of the ImGearARTRectangle class.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the rectangle.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | Opacity | Gets or sets the opacity of the rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRectangle Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : ImGearARTRectangle Constructor
Initializes a new instance of the ImGearARTRectangle class.
Overload List
Overload | Description
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTRectangle class object.
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32) | Initializes a new instance of the ImGearARTRectangle class object.
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32) | Initializes a new instance of the ImGearARTRectangle class object.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
Mark's rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTRectangle(rect, fillColor)
public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTRectangle(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTRectangle(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,Int32)
The mark's rectangle.
Border color of the mark.
Border style of the mark.
Border width of the mark.
Initializes a new instance of the ImGearARTRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer

Dim instance As New ImGearARTRectangle(rect, borderColor, borderStyle, borderWidth)
public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public: ImGearARTRectangle(
   IImGearRectangle* rect,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)
public:
ImGearARTRectangle(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

rect
The mark's rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32)
Mark's rectangle.
Fill color of the mark.
Border color of the mark.
Border style of the mark.
Border width of the mark.
Opacity of the mark.
Initializes a new instance of the ImGearARTRectangle class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal borderColor As IImGearRGBQuad, _
   ByVal borderStyle As ImGearARTPenStyle, _
   ByVal borderWidth As Integer, _
   ByVal opacity As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad
Dim borderColor As IImGearRGBQuad
Dim borderStyle As ImGearARTPenStyle
Dim borderWidth As Integer
Dim opacity As Integer

Dim instance As New ImGearARTRectangle(rect, fillColor, borderColor, borderStyle, borderWidth, opacity)
public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public: ImGearARTRectangle(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor,
   IImGearRGBQuad* borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)
public:
ImGearARTRectangle(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor,
   IImGearRGBQuad^ borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTRectangle Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRectangle Class

For a list of all members of this type, see ImGearARTRectangle members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRectangle Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRectangle Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRectangle Class

For a list of all members of this type, see ImGearARTRectangle members.

See Also

Reference

ImGearARTRectangle Class
ImageGear.ART Namespace


Flip Method (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTRectangle
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Flip Method


GetRenderBounds Method (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTRectangle
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Move Method (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTRectangle
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Rotate Method (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTRectangle
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Rotate Method


Scale Method (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTRectangle
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTRectangle Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRectangle Class

For a list of all members of this type, see ImGearARTRectangle members.

Public Properties
 | Name | Description
Public Property | Border | Gets or sets the border of the mark.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the rectangle.
Public Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Public Property | Opacity | Gets or sets the opacity of the rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark.
Top
See Also

Reference

ImGearARTRectangle Class
ImageGear.ART Namespace


Border Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTRectangle
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
ImGearARTBorder Class


Bounds Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTRectangle
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
ImGearRectangle Structure


FillColor Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTRectangle
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
ImGearRGBQuad Structure


Height Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Height Property
Gets or sets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTRectangle
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


IsHighlighter Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHighlighter As Boolean
'Usage

Dim instance As ImGearARTRectangle
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
public bool IsHighlighter {get; set;}
public: __property bool get_IsHighlighter();
public: __property void set_IsHighlighter(
   bool value
);
public:
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Opacity Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Opacity Property
Gets or sets the opacity of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTRectangle
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


SelectionType Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTRectangle
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Type Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTRectangle
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTRectangle
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Width Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Width Property
Gets or sets the width of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTRectangle
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


X Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : X Property
Gets or sets the X coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTRectangle
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


Y Property (ImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRectangle Class : Y Property
Gets or sets the Y coordinate of top-left point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTRectangle
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

ImGearARTRedaction Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRedaction Class
Represents legacy ART Redaction mark.
Object Model
ImGearARTRedaction ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTRedaction
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTRedaction
public class ImGearARTRedaction : ImGearARTMark
public __gc class ImGearARTRedaction : public ImGearARTMark
public ref class ImGearARTRedaction : public ImGearARTMark
Example
  • C#
// Setup rectangle for the red action mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the red action.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(255, 0, 0);
// Create red action mark.
ImGearARTRedaction igARTRedaction = new ImGearARTRedaction(
    igRectangle, igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRedaction, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the red action mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the red action.
Dim igRGBQuad As New ImGearRGBQuad(255, 0, 0)
' Create red action mark.
Dim igARTRedaction As New ImGearARTRedaction( _
 igRectangle, igRGBQuad)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRedaction, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTRedaction

See Also

Reference

ImGearARTRedaction Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRedaction Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRedaction Class

The following tables list the members exposed by ImGearARTRedaction.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTRedaction Constructor | Initializes a new instance of the ImGearARTRedaction class object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRedaction Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRedaction Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : ImGearARTRedaction Constructor
Mark's rectangle.
Fill color of the mark.
Initializes a new instance of the ImGearARTRedaction class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim fillColor As IImGearRGBQuad

Dim instance As New ImGearARTRedaction(rect, fillColor)
public ImGearARTRedaction(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)
public: ImGearARTRedaction(
   IImGearRectangle* rect,
   IImGearRGBQuad* fillColor
)
public:
ImGearARTRedaction(
   IImGearRectangle^ rect,
   IImGearRGBQuad^ fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%% $$Methods$$

ImGearARTRedaction Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRedaction Class

For a list of all members of this type, see ImGearARTRedaction members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRedaction Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRedaction Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRedaction Class

For a list of all members of this type, see ImGearARTRedaction members.

See Also

Reference

ImGearARTRedaction Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRedaction Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : ImGearARTRedaction Constructor
Overload List
Overload | Description
ImGearARTRedaction Constructor | Initializes a new instance of the ImGearARTRedaction class object.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Flip Method (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTRedaction
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
Flip Method


GetRenderBounds Method (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTRedaction
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Move Method (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTRedaction
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Rotate Method (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTRedaction
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
Rotate Method


Scale Method (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTRedaction
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTRedaction Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRedaction Class

For a list of all members of this type, see ImGearARTRedaction members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTRedaction Class
ImageGear.ART Namespace


Bounds Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTRedaction
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
ImGearRectangle Structure


FillColor Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTRedaction
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
ImGearRGBQuad Structure


Height Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTRedaction
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


SelectionType Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTRedaction
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Type Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTRedaction
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTRedaction)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTRedaction
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Visible Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTRedaction
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Width Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTRedaction
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


X Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTRedaction
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


Y Property (ImGearARTRedaction)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRedaction Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTRedaction
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

ImGearARTRichText Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichText Class
Represents ART Rich Text mark.
Object Model
ImGearARTRichText ClassImGearARTBorder ClassImGearRectangle StructureImGearARTRichTextControl ClassIImGearRGBQuad InterfaceImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTRichText
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTRichText
public class ImGearARTRichText : ImGearARTMark
public __gc class ImGearARTRichText : public ImGearARTMark
public ref class ImGearARTRichText : public ImGearARTMark
Example
  • C#
// Setup color for the rich text border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Setup rectangle for the rich text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 40);
// Setup fill color for the rich text mark.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(210, 210, 210);
// Set initial rich text string
string richText = "{\\rtf1\\ansi\\ansicpg1252\\deff0\\deflang1033{\\fonttbl{\\f0\\fnil\\fcharset0 Arial;}}\r\n";
richText += "\\viewkind4\\uc1\\pard\\fs23 ImGearARTRichText test\\par\r\n}\r\n";
// Create rich text mark with 70% opacity
ImGearARTRichText igARTRichText = new ImGearARTRichText(
    igRectangle, richText, igRGBQuad, igARTBorder, (int)(0.70 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRichText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the rich text border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Setup rectangle for the rich text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 40)
' Setup fill color for the rich text mark.
Dim igRGBQuad As New ImGearRGBQuad(210, 210, 210)
' Set initial rich text string
Dim richText As String = "{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 Arial;}}"
richText += Chr(13) & "" & Chr(10) & "\viewkind4\uc1\pard\fs23 ImGearARTRichText test\par"
richText += Chr(13) & "" & Chr(10) & "}" & Chr(13) & "" & Chr(10) & ""
' Create rich text mark with 70% opacity
Dim igARTRichText As New ImGearARTRichText( _
 igRectangle, richText, igRGBQuad, igARTBorder, CInt(0.7 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRichText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTRichText

See Also

Reference

ImGearARTRichText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRichText Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichText Class

The following tables list the members exposed by ImGearARTRichText.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTRichText Constructor | Overloaded. Initializes a new instance of the ImGearARTRichText class.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets or sets the mark's border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Control | This property has been deprecated. Gets the ART Rich Text control based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
Public Property | FillColor | Gets or sets the RichText mark's fill color.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | Opacity | Gets or sets opacity of the RichText mark.
Public Property | Orientation | Gets or sets Rich text orientation.
Public Property | Rtf | Gets or sets the annotation text in the rich text format.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRichText Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRichText Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : ImGearARTRichText Constructor
Initializes a new instance of the ImGearARTRichText class.
Overload List
Overload | Description
ImGearARTRichText Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTRichText class object.
ImGearARTRichText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTBorder,Int32) | Initializes a new instance of the ImGearARTRichText class object.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


%%PageItemTitle%%

ImGearARTRichText Constructor(IImGearRectangle,String)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class > ImGearARTRichText Constructor : ImGearARTRichText Constructor(IImGearRectangle,String)
Mark's rectangle.
RTF formatted text.
Initializes a new instance of the ImGearARTRichText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal richText As String _
)
'Usage

Dim rect As IImGearRectangle
Dim richText As String

Dim instance As New ImGearARTRichText(rect, richText)
public ImGearARTRichText(
   IImGearRectangle rect,
   string richText
)
public: ImGearARTRichText(
   IImGearRectangle* rect,
   string* richText
)
public:
ImGearARTRichText(
   IImGearRectangle^ rect,
   String^ richText
)

Parameters

rect
Mark's rectangle.
richText
RTF formatted text.
Remarks
This constructor validates if the richText argument is a valid RTF-formatted string and throws the ImGearException with a PARAMETER_HAS_INVALID_VALUE error code if it is not.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
Overload List
ImGearRectangle Structure


%%PageItemTitle%%

ImGearARTRichText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTBorder,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class > ImGearARTRichText Constructor : ImGearARTRichText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTBorder,Int32)
Mark's rectangle.
RTF formatted text.
The mark's fill color.
The mark's border.
Opacity of the the mark.
Initializes a new instance of the ImGearARTRichText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal richText As String, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal border As ImGearARTBorder, _
   ByVal opacity As Integer _
)
'Usage

Dim rect As IImGearRectangle
Dim richText As String
Dim fillColor As IImGearRGBQuad
Dim border As ImGearARTBorder
Dim opacity As Integer

Dim instance As New ImGearARTRichText(rect, richText, fillColor, border, opacity)
public ImGearARTRichText(
   IImGearRectangle rect,
   string richText,
   IImGearRGBQuad fillColor,
   ImGearARTBorder border,
   int opacity
)
public: ImGearARTRichText(
   IImGearRectangle* rect,
   string* richText,
   IImGearRGBQuad* fillColor,
   ImGearARTBorder* border,
   int opacity
)
public:
ImGearARTRichText(
   IImGearRectangle^ rect,
   String^ richText,
   IImGearRGBQuad^ fillColor,
   ImGearARTBorder^ border,
   int opacity
)

Parameters

rect
Mark's rectangle.
richText
RTF formatted text.
fillColor
The mark's fill color.
border
The mark's border.
opacity
Opacity of the the mark.
Remarks
This constructor validates if the richText argument is a valid RTF-formatted string and throws the ImGearException with a PARAMETER_HAS_INVALID_VALUE error code if it is not.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTBorder Class


%%PageItemTitle%% $$Methods$$

ImGearARTRichText Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichText Class

For a list of all members of this type, see ImGearARTRichText members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRichText Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRichText Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichText Class

For a list of all members of this type, see ImGearARTRichText members.

See Also

Reference

ImGearARTRichText Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : BeginEdit Method
PageView control that contains the mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTRichText
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains the mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
IImGearScrollableView Interface
ImGearPageDisplay Class


EndEdit Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTRichText
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
IImGearScrollableView Interface


Flip Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTRichText
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
Flip Method


GetRenderBounds Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTRichText
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Move Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTRichText
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Rotate Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTRichText
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
Rotate Method


Scale Method (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTRichText
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTRichText Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichText Class

For a list of all members of this type, see ImGearARTRichText members.

Public Properties
 | Name | Description
Public Property | Border | Gets or sets the mark's border.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Control | This property has been deprecated. Gets the ART Rich Text control based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
Public Property | FillColor | Gets or sets the RichText mark's fill color.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | Opacity | Gets or sets opacity of the RichText mark.
Public Property | Orientation | Gets or sets Rich text orientation.
Public Property | Rtf | Gets or sets the annotation text in the rich text format.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTRichText Class
ImageGear.ART Namespace


Border Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Border Property
Gets or sets the mark's border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearARTBorder Class


Bounds Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearRectangle Structure


Control Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Control Property
This property has been deprecated. Gets the ART Rich Text control based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property's type depends on System.Windows.Forms and will be removed from the public API in a future release. Use Rtf property instead.")>
Public ReadOnly Property Control As ImGearARTRichTextControl
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearARTRichTextControl

value = instance.Control
[Obsolete("This property's type depends on System.Windows.Forms and will be removed from the public API in a future release. Use Rtf property instead.")]
public ImGearARTRichTextControl Control {get;}
[Obsolete("This property's type depends on System.Windows.Forms and will be removed from the public API in a future release. Use Rtf property instead.")]
public: __property ImGearARTRichTextControl* get_Control();
[Obsolete("This property's type depends on System.Windows.Forms and will be removed from the public API in a future release. Use Rtf property instead.")]
public:
property ImGearARTRichTextControl^ Control {
   ImGearARTRichTextControl^ get();
}

Property Value

ImGearARTRichTextControl class object.
Remarks

The Control property is deprecated and will be removed from the public API in the next release. Please use Rtf property instead.

See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearARTRichTextControl Class


FillColor Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : FillColor Property
Gets or sets the RichText mark's fill color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTRichText
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearRGBQuad Structure


Height Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTRichText
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Opacity Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Opacity Property
Gets or sets opacity of the RichText mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTRichText
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Orientation Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Orientation Property
Gets or sets Rich text orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearOrientationModes Enumeration


Rtf Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Rtf Property
Gets or sets the annotation text in the rich text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rtf As String
'Usage

Dim instance As ImGearARTRichText
Dim value As String

instance.Rtf = value

value = instance.Rtf
public string Rtf {get; set;}
public: __property string* get_Rtf();
public: __property void set_Rtf(
   string* value
);
public:
property String^ Rtf {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The setter validates if the provided value is a valid RTF-formatted string and throws the ImGearException with a PARAMETER_HAS_INVALID_VALUE error code if it is not.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


SelectionType Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Type Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTRichText
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTRichText
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Width Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTRichText
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


X Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTRichText
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


Y Property (ImGearARTRichText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRichText Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTRichText
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRichText Class
ImGearARTRichText Members


%%PageItemTitle%%

ImGearARTRichTextControl Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichTextControl Class
This class has been deprecated. Represents a control suitable for ART Rich Text processing and drawing.
Object Model
ImGearARTRichTextControl Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class depends on System.Windows.Forms and will be removed from the public API in a future release.")>
Public Class ImGearARTRichTextControl
   Inherits System.Windows.Forms.RichTextBox
'Usage

Dim instance As ImGearARTRichTextControl
[Obsolete("This class depends on System.Windows.Forms and will be removed from the public API in a future release.")]
public class ImGearARTRichTextControl : System.Windows.Forms.RichTextBox
[Obsolete("This class depends on System.Windows.Forms and will be removed from the public API in a future release.")]
public __gc class ImGearARTRichTextControl : public System.Windows.Forms.RichTextBox
[Obsolete("This class depends on System.Windows.Forms and will be removed from the public API in a future release.")]
public ref class ImGearARTRichTextControl : public System.Windows.Forms.RichTextBox
Remarks
The ART Rich Text control is based on System.Windows.Forms.RichTextBox.

The ImGearARTRichTextControl class is deprecated and will be removed from the public API in the next release. Please use ImGearARTRichText.Rtf property instead.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.RichTextBox
ImageGear.ART.ImGearARTRichTextControl

See Also

Reference

ImGearARTRichTextControl Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRichTextControl Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichTextControl Class

The following tables list the members exposed by ImGearARTRichTextControl.

See Also

Reference

ImGearARTRichTextControl Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTRichTextControl Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichTextControl Class

For a list of all members of this type, see ImGearARTRichTextControl members.

See Also

Reference

ImGearARTRichTextControl Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTRichTextControl Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichTextControl Class

For a list of all members of this type, see ImGearARTRichTextControl members.

See Also

Reference

ImGearARTRichTextControl Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRichTextControl Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRichTextControl Class

For a list of all members of this type, see ImGearARTRichTextControl members.

See Also

Reference

ImGearARTRichTextControl Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRuler Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRuler Class
Represents ART Ruler mark.
Object Model
ImGearARTRuler ClassImGearRectangle StructureIImGearRGBQuad InterfaceImGearPoint StructureImGearRectangle StructureImGearARTMeasurementUnit StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTRuler
   Inherits ImGearARTMark
   Implements IImGearARTRuler
'Usage

Dim instance As ImGearARTRuler
public class ImGearARTRuler : ImGearARTMark, IImGearARTRuler
public __gc class ImGearARTRuler : public ImGearARTMark, IImGearARTRuler
public ref class ImGearARTRuler : public ImGearARTMark, IImGearARTRuler
Example
  • C#
// Setup start and endpoint for the ruler.
ImGearPoint igPointStart = new ImGearPoint(10, 10);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the ruler annotation with a solid line of width 2 and 75% opacity,
//  1:1 aspect ratio, end lines of width 50, 3 decimal places of precision,
//  and a label in size 12 regular Arial font.
ImGearARTRuler igARTRuler = new ImGearARTRuler(
    igPointStart, igPointEnd, igRGBQuad,
    ImGearARTPenStyle.SOLID, 2, (int)(0.75 * 255),
    1, 1, 1, 1, 50, 50, 3,
    "ImGearARTRuler test", "Arial", (float)12.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRuler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the ruler.
Dim igPointStart As New ImGearPoint(10, 10)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for annotation.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the ruler annotation with a solid line of width 2 and 75% opacity,
'  1:1 aspect ratio, end lines of with 50, 3 decimal places of precision,
'  and a label in size 12 regular Arial font.
Dim igARTRuler As New ImGearARTRuler( _
 igPointStart, igPointEnd, igRGBQuad, _
 ImGearARTPenStyle.SOLID, 2, CInt(0.75 * 255), _
 1, 1, 1, 1, 50, 50, 3, _
 "ImGearARTRuler test", "Arial", CSng(12), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRuler, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTRuler

See Also

Reference

ImGearARTRuler Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRuler Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRuler Class

The following tables list the members exposed by ImGearARTRuler.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTRuler Constructor | Overloaded. Initializes a new instance of the ImGearARTRuler class.
Top
Public Properties
 | Name | Description
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndLineLength | Gets or sets the length of the mark's end line.
Public Property | EndPoint | Gets or sets the end point of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Public Property | Label | Gets or sets the mark label.
Public Property | Length | Gets the length of the Ruler mark.
Public Property | MeasurementUnit | Gets or sets the measurement unit of the Ruler.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartLineLength | Gets or sets the length of the mark's start line.
Public Property | StartPoint | Gets or sets the start point of the mark.
Public Property | Style | Gets or sets the mark's line style.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the mark's line width.
Top
Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRuler Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTRuler Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : ImGearARTRuler Constructor
Initializes a new instance of the ImGearARTRuler class.
Overload List
Overload | Description
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTRuler class object.
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution) | Initializes a new instance of the ImGearARTRuler class object using start and end points, color and image resolution.
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTRuler class object.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
Start point of the mark.
End point of the mark.
Mark color.
Initializes a new instance of the ImGearARTRuler class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad

Dim instance As New ImGearARTRuler(startPoint, endPoint, color)
public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)
public: ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color
)
public:
ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color
)

Parameters

startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution)
Start point of the ruler.
End point of the ruler.
Ruler color.
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.
Initializes a new instance of the ImGearARTRuler class object using start and end points, color and image resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal resolution As IImGearResolution _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim resolution As IImGearResolution

Dim instance As New ImGearARTRuler(startPoint, endPoint, color, resolution)
public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   IImGearResolution resolution
)
public: ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   IImGearResolution* resolution
)
public:
ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   IImGearResolution^ resolution
)

Parameters

startPoint
Start point of the ruler.
endPoint
End point of the ruler.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,String,Single,ImGearARTFontStyles)
Start point of the mark.
End point of the mark.
Mark color.
Mark's line style.
Mark's line width.
Opacity of the mark.
Mark's X aspect numerator value.
Mark's X aspect denominator value.
Mark's Y aspect numerator value.
Mark's Y aspect denominator value.
Length of the start line of the mark.
Length of the end line of the mark.
The number of decimal digits displayed for the mark.
Mark's label.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTRuler class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPoint As ImGearPoint, _
   ByVal endPoint As ImGearPoint, _
   ByVal color As IImGearRGBQuad, _
   ByVal style As ImGearARTPenStyle, _
   ByVal width As Integer, _
   ByVal opacity As Integer, _
   ByVal aspectNumeratorX As Integer, _
   ByVal aspectDenominatorX As Integer, _
   ByVal aspectNumeratorY As Integer, _
   ByVal aspectDenominatorY As Integer, _
   ByVal startLineLength As Integer, _
   ByVal endLineLength As Integer, _
   ByVal precision As Integer, _
   ByVal label As String, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim startPoint As ImGearPoint
Dim endPoint As ImGearPoint
Dim color As IImGearRGBQuad
Dim style As ImGearARTPenStyle
Dim width As Integer
Dim opacity As Integer
Dim aspectNumeratorX As Integer
Dim aspectDenominatorX As Integer
Dim aspectNumeratorY As Integer
Dim aspectDenominatorY As Integer
Dim startLineLength As Integer
Dim endLineLength As Integer
Dim precision As Integer
Dim label As String
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTRuler(startPoint, endPoint, color, style, width, opacity, aspectNumeratorX, aspectDenominatorX, aspectNumeratorY, aspectDenominatorY, startLineLength, endLineLength, precision, label, fontName, fontSize, fontStyle)
public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   string label,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad* color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   string* label,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad^ color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   String^ label,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List
ImGearPoint Structure
ImGearRGBQuad Structure
ImGearARTPenStyle Enumeration
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTRuler Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRuler Class

For a list of all members of this type, see ImGearARTRuler members.

Public Methods
 | Name | Description
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTRuler Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRuler Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRuler Class

For a list of all members of this type, see ImGearARTRuler members.

See Also

Reference

ImGearARTRuler Class
ImageGear.ART Namespace


Flip Method (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTRuler
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Flip Method


GetRenderBounds Method (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTRuler
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Move Method (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTRuler
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Rotate Method (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTRuler
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Rotate Method


Scale Method (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTRuler
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTRuler Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTRuler Class

For a list of all members of this type, see ImGearARTRuler members.

Public Properties
 | Name | Description
Public Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Public Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Public Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Public Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | CapStyle | Gets or sets the style of a line end.
Public Property | Color | Gets or sets the color of the mark.
Public Property | EndLineLength | Gets or sets the length of the mark's end line.
Public Property | EndPoint | Gets or sets the end point of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text font.
Public Property | FontSize | Gets or sets the font size of the text font.
Public Property | FontStyleART | Gets or sets the font style of the text font.
Public Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Public Property | Label | Gets or sets the mark label.
Public Property | Length | Gets the length of the Ruler mark.
Public Property | MeasurementUnit | Gets or sets the measurement unit of the Ruler.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Public Property | SelectionPoints | Overridden. Gets the selection points.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | StartLineLength | Gets or sets the length of the mark's start line.
Public Property | StartPoint | Gets or sets the start point of the mark.
Public Property | Style | Gets or sets the mark's line style.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the mark's line width.
Top
See Also

Reference

ImGearARTRuler Class
ImageGear.ART Namespace


AspectDenominatorX Property (ImGearARTRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorX As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
public int AspectDenominatorX {get; set;}
public: __property int get_AspectDenominatorX();
public: __property void set_AspectDenominatorX(
   int value
);
public:
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.
Example
  • C#
// Setup start and endpoint for the ruler.
ImGearPoint startPoint = new ImGearPoint(10, 10);
ImGearPoint endPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTRuler ruler = new ImGearARTRuler(startPoint, endPoint, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
ruler.AspectNumeratorX = 1;
ruler.AspectNumeratorY = 1;

ruler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
ruler.AspectNumeratorX = 1000;
ruler.AspectNumeratorY = 1000;

ruler.Label = "%d mm";

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the ruler.
Dim startPoint As ImGearPoint = New ImGearPoint(10, 10)
Dim endPoint As ImGearPoint = New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)

' Setup color for the ruler.
Dim color As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As ImGearResolution = New ImGearResolution( _
  igPage.DIB.ImageResolution.XNumerator, _
  igPage.DIB.ImageResolution.XDenominator, _
  igPage.DIB.ImageResolution.YNumerator, _
  igPage.DIB.ImageResolution.YDenominator, _
  igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim ruler As ImGearARTRuler = New ImGearARTRuler(startPoint, endPoint, color, imageResolution)

' Let's change measurement unit to inches.

imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
ruler.AspectNumeratorX = 1
ruler.AspectNumeratorY = 1

ruler.Label = "%d in"

' Change measurement units back to the mm.

imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
ruler.AspectNumeratorX = 1000
ruler.AspectNumeratorY = 1000

ruler.Label = "%d mm"

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


AspectDenominatorY Property (ImGearARTRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectDenominatorY As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
public int AspectDenominatorY {get; set;}
public: __property int get_AspectDenominatorY();
public: __property void set_AspectDenominatorY(
   int value
);
public:
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup start and endpoint for the ruler.
ImGearPoint startPoint = new ImGearPoint(10, 10);
ImGearPoint endPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTRuler ruler = new ImGearARTRuler(startPoint, endPoint, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
ruler.AspectNumeratorX = 1;
ruler.AspectNumeratorY = 1;

ruler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
ruler.AspectNumeratorX = 1000;
ruler.AspectNumeratorY = 1000;

ruler.Label = "%d mm";

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the ruler.
Dim startPoint As ImGearPoint = New ImGearPoint(10, 10)
Dim endPoint As ImGearPoint = New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)

' Setup color for the ruler.
Dim color As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As ImGearResolution = New ImGearResolution( _
  igPage.DIB.ImageResolution.XNumerator, _
  igPage.DIB.ImageResolution.XDenominator, _
  igPage.DIB.ImageResolution.YNumerator, _
  igPage.DIB.ImageResolution.YDenominator, _
  igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim ruler As ImGearARTRuler = New ImGearARTRuler(startPoint, endPoint, color, imageResolution)

' Let's change measurement unit to inches.

imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
ruler.AspectNumeratorX = 1
ruler.AspectNumeratorY = 1

ruler.Label = "%d in"

' Change measurement units back to the mm.

imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
ruler.AspectNumeratorX = 1000
ruler.AspectNumeratorY = 1000

ruler.Label = "%d mm"

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


AspectNumeratorX Property (ImGearARTRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorX As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
public int AspectNumeratorX {get; set;}
public: __property int get_AspectNumeratorX();
public: __property void set_AspectNumeratorX(
   int value
);
public:
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup start and endpoint for the ruler.
ImGearPoint startPoint = new ImGearPoint(10, 10);
ImGearPoint endPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTRuler ruler = new ImGearARTRuler(startPoint, endPoint, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
ruler.AspectNumeratorX = 1;
ruler.AspectNumeratorY = 1;

ruler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
ruler.AspectNumeratorX = 1000;
ruler.AspectNumeratorY = 1000;

ruler.Label = "%d mm";

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the ruler.
Dim startPoint As ImGearPoint = New ImGearPoint(10, 10)
Dim endPoint As ImGearPoint = New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)

' Setup color for the ruler.
Dim color As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As ImGearResolution = New ImGearResolution( _
  igPage.DIB.ImageResolution.XNumerator, _
  igPage.DIB.ImageResolution.XDenominator, _
  igPage.DIB.ImageResolution.YNumerator, _
  igPage.DIB.ImageResolution.YDenominator, _
  igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim ruler As ImGearARTRuler = New ImGearARTRuler(startPoint, endPoint, color, imageResolution)

' Let's change measurement unit to inches.

imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
ruler.AspectNumeratorX = 1
ruler.AspectNumeratorY = 1

ruler.Label = "%d in"

' Change measurement units back to the mm.

imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
ruler.AspectNumeratorX = 1000
ruler.AspectNumeratorY = 1000

ruler.Label = "%d mm"

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


AspectNumeratorY Property (ImGearARTRuler)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AspectNumeratorY As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
public int AspectNumeratorY {get; set;}
public: __property int get_AspectNumeratorY();
public: __property void set_AspectNumeratorY(
   int value
);
public:
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.
Example
  • C#
// Setup start and endpoint for the ruler.
ImGearPoint startPoint = new ImGearPoint(10, 10);
ImGearPoint endPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);

// Setup color for the ruler.
ImGearRGBQuad color = new ImGearRGBQuad(0, 255, 0);

// Get and initialize image resolution for the ruler.
ImGearResolution imageResolution = new ImGearResolution(
        igPage.DIB.ImageResolution.XNumerator,
        igPage.DIB.ImageResolution.XDenominator,
        igPage.DIB.ImageResolution.YNumerator,
        igPage.DIB.ImageResolution.YDenominator,
        igPage.DIB.ImageResolution.Units);

// Create ruler, note that the ruler is always created with measurement units set to mm
// and it doesn't depend on ImGearResolution measurement units.
ImGearARTRuler ruler = new ImGearARTRuler(startPoint, endPoint, color, imageResolution);

// Let's change measurement units to inches.
imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES);

// Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 inch scale.
ruler.AspectNumeratorX = 1;
ruler.AspectNumeratorY = 1;

ruler.Label = "%d in";

// Now change the measurement units back to the mm.
imageResolution.ConvertUnits(ImGearResolutionUnits.METERS);

// Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * (int)Math.Round((double)imageResolution.XNumerator / (double)imageResolution.XDenominator);
ruler.AspectDenominatorY = 1 * (int)Math.Round((double)imageResolution.YNumerator / (double)imageResolution.YDenominator);

// Set 1 mm scale.
ruler.AspectNumeratorX = 1000;
ruler.AspectNumeratorY = 1000;

ruler.Label = "%d mm";

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup start and endpoint for the ruler.
Dim startPoint As ImGearPoint = New ImGearPoint(10, 10)
Dim endPoint As ImGearPoint = New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)

' Setup color for the ruler.
Dim color As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)

' Get and initialize image resolution for the ruler.
Dim imageResolution As ImGearResolution = New ImGearResolution( _
  igPage.DIB.ImageResolution.XNumerator, _
  igPage.DIB.ImageResolution.XDenominator, _
  igPage.DIB.ImageResolution.YNumerator, _
  igPage.DIB.ImageResolution.YDenominator, _
  igPage.DIB.ImageResolution.Units)

' Create ruler, note that the ruler is always created with measurement units set to mm
' and it doesn't depend on ImGearResolution measurement units.
Dim ruler As ImGearARTRuler = New ImGearARTRuler(startPoint, endPoint, color, imageResolution)

' Let's change measurement unit to inches.

imageResolution.ConvertUnits(ImGearResolutionUnits.INCHES)

' Set number of pixels per 1 inch.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 inch scale.
ruler.AspectNumeratorX = 1
ruler.AspectNumeratorY = 1

ruler.Label = "%d in"

' Change measurement units back to the mm.

imageResolution.ConvertUnits(ImGearResolutionUnits.METERS)

' Set number of pixels per 1 meter.
ruler.AspectDenominatorX = 1 * CInt(Math.Round(CDbl(imageResolution.XNumerator) / CDbl(imageResolution.XDenominator)))
ruler.AspectDenominatorY = 1 * CInt(Math.Round(CDbl(imageResolution.YNumerator) / CDbl(imageResolution.YDenominator)))

' Set 1 mm scale.
ruler.AspectNumeratorX = 1000
ruler.AspectNumeratorY = 1000

ruler.Label = "%d mm"

igARTPage.AddMark(ruler, ImGearARTCoordinatesType.IMAGE_COORD)
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Bounds Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearRectangle Structure


CapStyle Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
public ImGearARTCapStyle CapStyle {get; set;}
public: __property ImGearARTCapStyle get_CapStyle();
public: __property void set_CapStyle(
   ImGearARTCapStyle value
);
public:
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearARTCapStyle Enumeration


Color Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As IImGearRGBQuad
'Usage

Dim instance As ImGearARTRuler
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
public IImGearRGBQuad Color {get; set;}
public: __property IImGearRGBQuad* get_Color();
public: __property void set_Color(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearRGBQuad Structure


EndLineLength Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : EndLineLength Property
Gets or sets the length of the mark's end line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndLineLength As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.EndLineLength = value

value = instance.EndLineLength
public int EndLineLength {get; set;}
public: __property int get_EndLineLength();
public: __property void set_EndLineLength(
   int value
);
public:
property int EndLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 20.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


EndPoint Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : EndPoint Property
Gets or sets the end point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoint As ImGearPoint
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
public ImGearPoint EndPoint {get; set;}
public: __property ImGearPoint get_EndPoint();
public: __property void set_EndPoint(
   ImGearPoint value
);
public:
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearPoint Structure


FontDisablePPM Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTRuler
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


FontName Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTRuler
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The default value is "Arial".
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


FontSize Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTRuler
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


FontStyleART Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


IsLabelVisible Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : IsLabelVisible Property
Gets or sets a value indicating whether the label is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsLabelVisible As Boolean
'Usage

Dim instance As ImGearARTRuler
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
public bool IsLabelVisible {get; set;}
public: __property bool get_IsLabelVisible();
public: __property void set_IsLabelVisible(
   bool value
);
public:
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean variable.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Label Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Label Property
Gets or sets the mark label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Label As String
'Usage

Dim instance As ImGearARTRuler
Dim value As String

instance.Label = value

value = instance.Label
public string Label {get; set;}
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
public:
property String^ Label {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The default value is "%d mm".
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Length Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Length Property
Gets the length of the Ruler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Double
'Usage

Dim instance As ImGearARTRuler
Dim value As Double

value = instance.Length
public double Length {get;}
public: __property double get_Length();
public:
property double Length {
   double get();
}

Property Value

Double value.
Remarks
Note: The annotation must be added to the ImGearARTPage prior to using this property.

Note: If the AspectKind is ImGearARTAspectKind.Relative, please initialize Resolution prior to using this property, otherwise ImageGear.Core.ImGearException will be thrown. The resolution is necessary for length calculation in Relative mode.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
IImGearResolution Interface
Resolution Property
ImageResolution Property
DIB Property


MeasurementUnit Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : MeasurementUnit Property
Gets or sets the measurement unit of the Ruler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MeasurementUnit As ImGearARTMeasurementUnit
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTMeasurementUnit

instance.MeasurementUnit = value

value = instance.MeasurementUnit
public ImGearARTMeasurementUnit MeasurementUnit {get; set;}
public: __property ImGearARTMeasurementUnit get_MeasurementUnit();
public: __property void set_MeasurementUnit(
   ImGearARTMeasurementUnit value
);
public:
property ImGearARTMeasurementUnit MeasurementUnit {
   ImGearARTMeasurementUnit get();
   void set (    ImGearARTMeasurementUnit value);
}

Property Value

ImGearARTMeasurementUnit value.
Remarks
The getter returns either instance of some predefined measurement unit, associated with currently initialized AspectNumeratorX, AspectDenominatorX, AspectNumeratorY and AspectDenominatorY values, or instance of the ImGearARTMeasurementUnit with Name equal to "Custom" and Aspect values, initialized from corresponding Aspect values of the Ruler.

Note: The annotation must be added to the ImGearARTPage prior to using this property.

Note: If the AspectKind is ImGearARTAspectKind.Absolute, please initialize Resolution prior to using this property, otherwise ImageGear.Core.ImGearException will be thrown. The resolution is necessary for initialization of Aspect properties in Absolute mode.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
IImGearResolution Interface
Resolution Property
ImageResolution Property
DIB Property


Opacity Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
The default value is 255.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Precision Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
public:
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


SelectionPoints Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTRuler
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public override ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property ReadOnlyCollection<ImGearPoint>* get_SelectionPoints() override;
public:
property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get() override;
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


SelectionType Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


StartLineLength Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : StartLineLength Property
Gets or sets the length of the mark's start line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartLineLength As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.StartLineLength = value

value = instance.StartLineLength
public int StartLineLength {get; set;}
public: __property int get_StartLineLength();
public: __property void set_StartLineLength(
   int value
);
public:
property int StartLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 20.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


StartPoint Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : StartPoint Property
Gets or sets the start point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPoint As ImGearPoint
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
public ImGearPoint StartPoint {get; set;}
public: __property ImGearPoint get_StartPoint();
public: __property void set_StartPoint(
   ImGearPoint value
);
public:
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearPoint Structure


Style Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Style Property
Gets or sets the mark's line style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As ImGearARTPenStyle
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
public ImGearARTPenStyle Style {get; set;}
public: __property ImGearARTPenStyle get_Style();
public: __property void set_Style(
   ImGearARTPenStyle value
);
public:
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearARTPenStyle Enumeration


Type Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTRuler
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTRuler
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


Width Property (ImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTRuler Class : Width Property
Gets or sets the mark's line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTRuler
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

ImGearARTSecureObjectData Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSecureObjectData Class
The base class for secure object data.
Object Model
ImGearARTSecureObjectData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTSecureObjectData
'Usage

Dim instance As ImGearARTSecureObjectData
public class ImGearARTSecureObjectData
public __gc class ImGearARTSecureObjectData
public ref class ImGearARTSecureObjectData
Remarks
Access controller requires some data associated with a secure object. The structure of this data can be varied and depends on the implementation. It could implement ACL (Access Control List) or something else.
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSecureObjectData

See Also

Reference

ImGearARTSecureObjectData Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTSecureObjectData Class Members
Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSecureObjectData Class

The following tables list the members exposed by ImGearARTSecureObjectData.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTSecureObjectData Constructor |
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | GetSerializationString | Gets encoded string that has to be serialized.
Top
See Also

Reference

ImGearARTSecureObjectData Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTSecureObjectData Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTSecureObjectData Class : ImGearARTSecureObjectData Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTSecureObjectData()
public ImGearARTSecureObjectData()
public: ImGearARTSecureObjectData();
public:
ImGearARTSecureObjectData();
See Also

Reference

ImGearARTSecureObjectData Class
ImGearARTSecureObjectData Members


%%PageItemTitle%% $$Methods$$

ImGearARTSecureObjectData Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSecureObjectData Class

For a list of all members of this type, see ImGearARTSecureObjectData members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | GetSerializationString | Gets encoded string that has to be serialized.
Top
See Also

Reference

ImGearARTSecureObjectData Class
ImageGear.ART Namespace


Clone Method (ImGearARTSecureObjectData)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTSecureObjectData Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As ImGearARTSecureObjectData
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public: virtual Object* Clone();
public:
virtual Object^ Clone();

Return Value

A new object that is a copy of this instance.
See Also

Reference

ImGearARTSecureObjectData Class
ImGearARTSecureObjectData Members


GetSerializationString Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTSecureObjectData Class : GetSerializationString Method
Gets encoded string that has to be serialized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetSerializationString() As String
'Usage

Dim instance As ImGearARTSecureObjectData
Dim value As String

value = instance.GetSerializationString()
public virtual string GetSerializationString()
public: virtual string* GetSerializationString();
public:
virtual String^ GetSerializationString();

Return Value

String value. If the return value is null or empty, it means there is nothing to serialize.
Remarks
The method is called in case of saving Secure object to Xml file. If you need to save data into Xml file, override this method in children classes. Use ImGearARTLoadEvents.CreatingMark, ImGearARTLoadEvents.CreatingGroup, and ImGearARTLoadEvents.CreatingPage events to load this string from Xml file.
See Also

Reference

ImGearARTSecureObjectData Class
ImGearARTSecureObjectData Members


%%PageItemTitle%%

ImGearARTSelection Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSelection Class
Provides the abstract class that defines mark selection interface.
Object Model
ImGearARTSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTSelection
'Usage

Dim instance As ImGearARTSelection
public abstract class ImGearARTSelection
public __gc abstract class ImGearARTSelection
public ref class ImGearARTSelection abstract
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark

See Also

Reference

ImGearARTSelection Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTSelection Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSelection Class

The following tables list the members exposed by ImGearARTSelection.

Public Properties
 | Name | Description
Public Property | SelectionPoints | Gets the selection points.
Public Property | SelectionType | Gets the selection type.
Top
See Also

Reference

ImGearARTSelection Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTSelection Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSelection Class

For a list of all members of this type, see ImGearARTSelection members.

Public Properties
 | Name | Description
Public Property | SelectionPoints | Gets the selection points.
Public Property | SelectionType | Gets the selection type.
Top
See Also

Reference

ImGearARTSelection Class
ImageGear.ART Namespace


SelectionPoints Property (ImGearARTSelection)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTSelection Class : SelectionPoints Property
Gets the selection points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property SelectionPoints As ReadOnlyCollection(Of ImGearPoint)
'Usage

Dim instance As ImGearARTSelection
Dim value As ReadOnlyCollection(Of ImGearPoint)

value = instance.SelectionPoints
public abstract ReadOnlyCollection<ImGearPoint> SelectionPoints {get;}
public: __property abstract ReadOnlyCollection<ImGearPoint>* get_SelectionPoints();
public:
abstract property ReadOnlyCollection<ImGearPoint>^ SelectionPoints {
   ReadOnlyCollection<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint collection.
See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


SelectionType Property (ImGearARTSelection)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTSelection Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTSelection
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public abstract ImGearARTSelectionType SelectionType {get;}
public: __property abstract ImGearARTSelectionType get_SelectionType();
public:
abstract property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get();
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

ImGearARTShapeMarkStat Class
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTShapeMarkStat Class
Represents statistics information about the shaped annotation marks.
Object Model
ImGearARTShapeMarkStat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTShapeMarkStat
   Inherits ImGearARTMarkStat
'Usage

Dim instance As ImGearARTShapeMarkStat
public class ImGearARTShapeMarkStat : ImGearARTMarkStat
public __gc class ImGearARTShapeMarkStat : public ImGearARTMarkStat
public ref class ImGearARTShapeMarkStat : public ImGearARTMarkStat
Remarks
The information is: area and perimeter of the mark.

An instance of the ImGearARTShapeMarkStat class is always created for the specified mark object and should not be used after destroying that mark object.

Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTMarkStat
ImageGear.ART.ImGearARTShapeMarkStat

See Also

Reference

ImGearARTShapeMarkStat Members
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Members$$

ImGearARTShapeMarkStat Class Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTShapeMarkStat Class

The following tables list the members exposed by ImGearARTShapeMarkStat.

Public Properties
 | Name | Description
Public Property | Area | Gets the area of the shape mark.
Public Property | Perimeter | Gets the perimeter of the shape mark.
Top
See Also

Reference

ImGearARTShapeMarkStat Class
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


%%PageItemTitle%% $$Properties$$

ImGearARTShapeMarkStat Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTShapeMarkStat Class

For a list of all members of this type, see ImGearARTShapeMarkStat members.

Public Properties
 | Name | Description
Public Property | Area | Gets the area of the shape mark.
Public Property | Perimeter | Gets the perimeter of the shape mark.
Top
See Also

Reference

ImGearARTShapeMarkStat Class
ImageGear.ART Namespace
ImGearARTMarkStat Class
ImGearARTLineMarkStat Class
ImGearARTPointMarkStat Class


Area Property (ImGearARTShapeMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTShapeMarkStat Class : Area Property
Gets the area of the shape mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Area As Double
'Usage

Dim instance As ImGearARTShapeMarkStat
Dim value As Double

value = instance.Area
public double Area {get;}
public: __property double get_Area();
public:
property double Area {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTShapeMarkStat Class
ImGearARTShapeMarkStat Members


Perimeter Property (ImGearARTShapeMarkStat)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTShapeMarkStat Class : Perimeter Property
Gets the perimeter of the shape mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Perimeter As Double
'Usage

Dim instance As ImGearARTShapeMarkStat
Dim value As Double

value = instance.Perimeter
public double Perimeter {get;}
public: __property double get_Perimeter();
public:
property double Perimeter {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearARTShapeMarkStat Class
ImGearARTShapeMarkStat Members


%%PageItemTitle%%

ImGearARTText Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTText Class
Represents ART Text mark.
Object Model
ImGearARTText ClassImGearARTBorder ClassImGearRectangle StructureImGearARTCallout ClassIImGearRGBQuad InterfaceImGearSize StructureImGearRectangle StructureImGearRectangle StructureImGearARTThickness StructureImGearARTPin ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTText
   Inherits ImGearARTMark
   Implements IImGearARTText
'Usage

Dim instance As ImGearARTText
public class ImGearARTText : ImGearARTMark, IImGearARTText
public __gc class ImGearARTText : public ImGearARTMark, IImGearARTText
public ref class ImGearARTText : public ImGearARTMark, IImGearARTText
Example
  • C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, 255, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTText

See Also

Reference

ImGearARTText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTText Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTText Class

The following tables list the members exposed by ImGearARTText.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTText Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ActualText | Gets or sets the actual text you can see on display.
Public Property | AlignmentH | Gets or sets the horizontal text alignment.
Public Property | AlignmentV | Gets or sets the vertical text alignment.
Public Property | AutoSize | Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Public Property | Border | Gets or sets the mark border.
Public Property | BorderShading | Gets or sets a value indicating whether the border is shaded or not.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Callout | Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the mark text.
Public Property | FontSize | Gets or sets the font size of the mark text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | HitTestBounds | Overridden. Gets the mark's boundling rectangle used for hit test.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Orientation | Gets or sets the text orientation.
Public Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Public Property | Pin | Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the color of the mark text.
Public Property | TextOpacity | Gets or sets a separate opacity used for text string.
Public Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Public Property | TextType | Gets or sets the text type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins the text editing process.
Public Method | EndEdit | Ends the text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTText Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTText Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : ImGearARTText Constructor
Overload List
Overload | Description
ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTText class object.
ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout) | Initializes a new instance of the ImGearARTText class object.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class > ImGearARTText Constructor : ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Initializes a new instance of the ImGearARTText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTText(rect, text, textColor)
public ImGearARTText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class > ImGearARTText Constructor : ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,Int32,IImGearRGBQuad,ImGearARTBorder,Boolean,Int32,String,Single,ImGearARTFontStyles,ImGearARTPin,ImGearARTCallout)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Text type.
Text opacity.
Fill color of the mark.
Border of the mark.
Specifies whether the mark's border is shaded or not.
Opacity of the mark.
The name of the font.
The size of the font in points.
The style of the font.
ImGearARTPin class object that specifies mark's pin icon attributes.
ImGearARTCallout class object that specifies mark's callout attributes.
Initializes a new instance of the ImGearARTText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal textType As ImGearARTTextType, _
   ByVal textOpacity As Integer, _
   ByVal fillColor As IImGearRGBQuad, _
   ByVal border As ImGearARTBorder, _
   ByVal isBorderShaded As Boolean, _
   ByVal opacity As Integer, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles, _
   ByVal pin As ImGearARTPin, _
   ByVal callout As ImGearARTCallout _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim textType As ImGearARTTextType
Dim textOpacity As Integer
Dim fillColor As IImGearRGBQuad
Dim border As ImGearARTBorder
Dim isBorderShaded As Boolean
Dim opacity As Integer
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles
Dim pin As ImGearARTPin
Dim callout As ImGearARTCallout

Dim instance As New ImGearARTText(rect, text, textColor, textType, textOpacity, fillColor, border, isBorderShaded, opacity, fontName, fontSize, fontStyle, pin, callout)
public ImGearARTText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad fillColor,
   ImGearARTBorder border,
   bool isBorderShaded,
   int opacity,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin pin,
   ImGearARTCallout callout
)
public: ImGearARTText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad* fillColor,
   ImGearARTBorder* border,
   bool isBorderShaded,
   int opacity,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin* pin,
   ImGearARTCallout* callout
)
public:
ImGearARTText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad^ fillColor,
   ImGearARTBorder^ border,
   bool isBorderShaded,
   int opacity,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTPin^ pin,
   ImGearARTCallout^ callout
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
textType
Text type.
textOpacity
Text opacity.
fillColor
Fill color of the mark.
border
Border of the mark.
isBorderShaded
Specifies whether the mark's border is shaded or not.
opacity
Opacity of the mark.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
pin
ImGearARTPin class object that specifies mark's pin icon attributes.
callout
ImGearARTCallout class object that specifies mark's callout attributes.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTTextType Enumeration
ImGearARTBorder Class
ImGearARTPin Class
ImGearARTCallout Class


%%PageItemTitle%% $$Methods$$

ImGearARTText Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTText Class

For a list of all members of this type, see ImGearARTText members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins the text editing process.
Public Method | EndEdit | Ends the text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTText Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTText Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTText Class

For a list of all members of this type, see ImGearARTText members.

See Also

Reference

ImGearARTText Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins the text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTText
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : EndEdit Method
PageView control that contains text mark.
Ends the text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTText
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
IImGearScrollableView Interface


Flip Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTText
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTText Class
ImGearARTText Members
Flip Method


GetAutoFitSize Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : GetAutoFitSize Method
The page view control that contains text mark.
The page display of the page view control.
The auto fit mode.
Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAutoFitSize( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal autoFitMode As ImGearARTTextAutoFitMode _
) As ImGearSize
'Usage

Dim instance As ImGearARTText
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim autoFitMode As ImGearARTTextAutoFitMode
Dim value As ImGearSize

value = instance.GetAutoFitSize(pageView, pageDisplay, autoFitMode)
public ImGearSize GetAutoFitSize(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public: ImGearSize GetAutoFitSize(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public:
ImGearSize GetAutoFitSize(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.
autoFitMode
The auto fit mode.

Return Value

ImageGear.Core.ImGearSize value with necessary dimensions of the mark's bounds.
Remarks
Calculated bounding box size depends on the autoFitMode. Possible values are:
  • ImGearARTTextAutoFitMode.AdjustHeight - in this mode the width remains unchanged, the height is adjusted to fit entire text without clipping.
  • ImGearARTTextAutoFitMode.AdjustWidth - in this mode the height remains unchanged, the width is adjusted to fit the widest text line without clipping from the right.
  • ImGearARTTextAutoFitMode.AdjustHeight | ImGearARTTextAutoFitMode.AdjustWidth - in this mode both height and width are adjusted to fit entire text without clipping.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


GetOverflowedTextLength Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : GetOverflowedTextLength Method
The page view control that contains text mark.
The page display of the page view control.
Calculates the number of characters that do not completely fit into displayable area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOverflowedTextLength( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay _
) As Integer
'Usage

Dim instance As ImGearARTText
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim value As Integer

value = instance.GetOverflowedTextLength(pageView, pageDisplay)
public int GetOverflowedTextLength(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay
)
public: int GetOverflowedTextLength(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay
)
public:
int GetOverflowedTextLength(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.

Return Value

The number of not fully displayable characters, 0 otherwise.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


GetRenderBounds Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTText
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTText Class
ImGearARTText Members


Move Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Move Method
X offset in abstract coordinates.
Y offset in abstract coordinates.
Moves mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTText
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Rotate Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTText
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTText Class
ImGearARTText Members
Rotate Method


Scale Method (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTText
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTText Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTText Class

For a list of all members of this type, see ImGearARTText members.

Public Properties
 | Name | Description
Public Property | ActualText | Gets or sets the actual text you can see on display.
Public Property | AlignmentH | Gets or sets the horizontal text alignment.
Public Property | AlignmentV | Gets or sets the vertical text alignment.
Public Property | AutoSize | Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Public Property | Border | Gets or sets the mark border.
Public Property | BorderShading | Gets or sets a value indicating whether the border is shaded or not.
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Callout | Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Public Property | FillColor | Gets or sets the fill color of the mark.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the mark text.
Public Property | FontSize | Gets or sets the font size of the mark text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark's rectangle.
Public Property | HitTestBounds | Overridden. Gets the mark's boundling rectangle used for hit test.
Public Property | Opacity | Gets or sets the opacity of the mark.
Public Property | Orientation | Gets or sets the text orientation.
Public Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Public Property | Pin | Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text of the mark.
Public Property | TextColor | Gets or sets the color of the mark text.
Public Property | TextOpacity | Gets or sets a separate opacity used for text string.
Public Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Public Property | TextType | Gets or sets the text type.
Public Property | Type | Overridden. Gets mark's type.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTText Class
ImageGear.ART Namespace


ActualText Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : ActualText Property
Gets or sets the actual text you can see on display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActualText As String
'Usage

Dim instance As ImGearARTText
Dim value As String

instance.ActualText = value

value = instance.ActualText
public string ActualText {get; set;}
public: __property string* get_ActualText();
public: __property void set_ActualText(
   string* value
);
public:
property String^ ActualText {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
If TextType value is ImGearARTTextType.FILE_NAME the ActualText property holds a string with the file content. If TextType value is ImGearARTTextType.DIRECT_TEXT the ActualText property holds a string containing the same value as Text property.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
Text Property


AlignmentH Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : AlignmentH Property
Gets or sets the horizontal text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As ImGearARTText
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
public ImGearAlignmentHModes AlignmentH {get; set;}
public: __property ImGearAlignmentHModes get_AlignmentH();
public: __property void set_AlignmentH(
   ImGearAlignmentHModes value
);
public:
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
Remarks
The default value is ImGearAlignmentHModes.LEFT.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : AlignmentV Property
Gets or sets the vertical text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As ImGearARTText
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
public ImGearAlignmentVModes AlignmentV {get; set;}
public: __property ImGearAlignmentVModes get_AlignmentV();
public: __property void set_AlignmentV(
   ImGearAlignmentVModes value
);
public:
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
Remarks
The default value is ImGearAlignmentVModes.TOP.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearAlignmentVModes Enumeration


AutoSize Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : AutoSize Property
Gets or sets a value indicating whether the annotation size will be automatically expanded (or shrunk) to fit the given text within the text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoSize As Boolean
'Usage

Dim instance As ImGearARTText
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
public bool AutoSize {get; set;}
public: __property bool get_AutoSize();
public: __property void set_AutoSize(
   bool value
);
public:
property bool AutoSize {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Border Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Border Property
Gets or sets the mark border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As ImGearARTBorder
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
public ImGearARTBorder Border {get; set;}
public: __property ImGearARTBorder* get_Border();
public: __property void set_Border(
   ImGearARTBorder* value
);
public:
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearARTBorder Class


BorderShading Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : BorderShading Property
Gets or sets a value indicating whether the border is shaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderShading As Boolean
'Usage

Dim instance As ImGearARTText
Dim value As Boolean

instance.BorderShading = value

value = instance.BorderShading
public bool BorderShading {get; set;}
public: __property bool get_BorderShading();
public: __property void set_BorderShading(
   bool value
);
public:
property bool BorderShading {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Bounds Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTText
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearRectangle Structure


Callout Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Callout Property
Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Callout As ImGearARTCallout
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTCallout

instance.Callout = value

value = instance.Callout
public ImGearARTCallout Callout {get; set;}
public: __property ImGearARTCallout* get_Callout();
public: __property void set_Callout(
   ImGearARTCallout* value
);
public:
property ImGearARTCallout^ Callout {
   ImGearARTCallout^ get();
   void set (    ImGearARTCallout^ value);
}

Property Value

ImGearARTCallout class object.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearARTCallout Class


FillColor Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTText
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
public IImGearRGBQuad FillColor {get; set;}
public: __property IImGearRGBQuad* get_FillColor();
public: __property void set_FillColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearRGBQuad Structure


FontDisablePPM Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


FontName Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : FontName Property
Gets or sets the font name of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTText
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String name.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


FontSize Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : FontSize Property
Gets or sets the font size of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


FontStyleART Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : FontStyleART Property
Gets or sets the font style of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Height Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


HitTestBounds Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : HitTestBounds Property
Gets the mark's boundling rectangle used for hit test.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property HitTestBounds As ImGearRectangle
'Usage

Dim instance As ImGearARTText
Dim value As ImGearRectangle

value = instance.HitTestBounds
public override ImGearRectangle HitTestBounds {get;}
public: __property ImGearRectangle get_HitTestBounds() override;
public:
property ImGearRectangle HitTestBounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearRectangle Structure


Opacity Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
This Opacity property is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use TextOpacity property. The default value is 255.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Orientation Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Orientation Property
Gets or sets the text orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearOrientationModes
'Usage

Dim instance As ImGearARTText
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
public ImGearOrientationModes Orientation {get; set;}
public: __property ImGearOrientationModes get_Orientation();
public: __property void set_Orientation(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearOrientationModes Enumeration


Padding Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Padding Property
Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Padding As ImGearARTThickness
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTThickness

instance.Padding = value

value = instance.Padding
public ImGearARTThickness Padding {get; set;}
public: __property ImGearARTThickness get_Padding();
public: __property void set_Padding(
   ImGearARTThickness value
);
public:
property ImGearARTThickness Padding {
   ImGearARTThickness get();
   void set (    ImGearARTThickness value);
}

Property Value

ImGearARTThickness structure instance.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Pin Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Pin Property
Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Pin As ImGearARTPin
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTPin

instance.Pin = value

value = instance.Pin
public ImGearARTPin Pin {get; set;}
public: __property ImGearARTPin* get_Pin();
public: __property void set_Pin(
   ImGearARTPin* value
);
public:
property ImGearARTPin^ Pin {
   ImGearARTPin^ get();
   void set (    ImGearARTPin^ value);
}

Property Value

ImGearARTPin class object.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearARTPin Class


SelectionType Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Text Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Text Property
Gets or sets the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTText
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
If TextType value is ImGearARTTextType.FILE_NAME the Text property holds a string with the file name. If TextType value is ImGearARTTextType.DIRECT_TEXT the Text property holds the actual text. Use ActualText to get the file content if TextType value is ImGearARTTextType.FILE_NAME.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ActualText Property


TextColor Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : TextColor Property
Gets or sets the color of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearRGBQuad Structure


TextOpacity Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : TextOpacity Property
Gets or sets a separate opacity used for text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextOpacity As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.TextOpacity = value

value = instance.TextOpacity
public int TextOpacity {get; set;}
public: __property int get_TextOpacity();
public: __property void set_TextOpacity(
   int value
);
public:
property int TextOpacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the Opacity property used to set the opacity for the entire mark. The default value is 255.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


TextTrimming Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : TextTrimming Property
Gets or sets the text trimming behavior to employ when content overflows the content area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextTrimming As ImGearARTTextTrimming
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTTextTrimming

instance.TextTrimming = value

value = instance.TextTrimming
public ImGearARTTextTrimming TextTrimming {get; set;}
public: __property ImGearARTTextTrimming get_TextTrimming();
public: __property void set_TextTrimming(
   ImGearARTTextTrimming value
);
public:
property ImGearARTTextTrimming TextTrimming {
   ImGearARTTextTrimming get();
   void set (    ImGearARTTextTrimming value);
}

Property Value

ImGearARTTextTrimming enumeration value.
Remarks
NOTE: The text trimming behavior is only supported by WPF annotation renderer. It is not currently supported in WinForms applications.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


TextType Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : TextType Property
Gets or sets the text type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextType As ImGearARTTextType
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTTextType

instance.TextType = value

value = instance.TextType
public ImGearARTTextType TextType {get; set;}
public: __property ImGearARTTextType get_TextType();
public: __property void set_TextType(
   ImGearARTTextType value
);
public:
property ImGearARTTextType TextType {
   ImGearARTTextType get();
   void set (    ImGearARTTextType value);
}

Property Value

ImGearARTTextType enumeration value.
Remarks
The default value is ImGearARTTextType.DIRECT_TEXT.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearARTTextType Enumeration
Text Property
ActualText Property


Type Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTText
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members
ImGearARTMarkType Enumeration


Visible Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTText
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Width Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


X Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


Y Property (ImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTText Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTText
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

ImGearARTTextCallout Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextCallout Class
Represents legacy ART Callout Text mark.
Object Model
ImGearARTTextCallout ClassImGearRectangle StructureImGearARTCallout ClassImGearSize StructureImGearRectangle StructureImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTTextCallout
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTTextCallout
public class ImGearARTTextCallout : ImGearARTMark
public __gc class ImGearARTTextCallout : public ImGearARTMark
public ref class ImGearARTTextCallout : public ImGearARTMark
Example
  • C#
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorderCallout, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text callout annotation.
ImGearARTTextCallout igARTTextCallout = new ImGearARTTextCallout(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    "Arial", (float)14.0, ImGearARTFontStyles.Regular, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextCallout, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorderCallout, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, _
 igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text callout annotation.
Dim igARTTextCallout As New ImGearARTTextCallout( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 "Arial", CSng(14), ImGearARTFontStyles.Regular, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextCallout, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTTextCallout

See Also

Reference

ImGearARTTextCallout Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTTextCallout Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextCallout Class

The following tables list the members exposed by ImGearARTTextCallout.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTTextCallout Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Callout | Gets or sets the ImGearARTCallout class object that specifies mark's callout attributes.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | HitTestBounds | Overridden. Gets the mark's boundling rectangle used for hit test.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text string.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextCallout Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextCallout Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : ImGearARTTextCallout Constructor
Overload List
Overload | Description
ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout) | Initializes a new instance of the ImGearARTTextCallout class object.
ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,ImGearARTCallout) | Initializes a new instance of the ImGearARTTextCallout class object.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class > ImGearARTTextCallout Constructor : ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout)
Mark's rectangle.
Text string.
Color of the text.
ImGearARTCallout object that specifies mark's callout attributes.
Initializes a new instance of the ImGearARTTextCallout class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal callout As ImGearARTCallout _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim callout As ImGearARTCallout

Dim instance As New ImGearARTTextCallout(rect, text, textColor, callout)
public ImGearARTTextCallout(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   ImGearARTCallout callout
)
public: ImGearARTTextCallout(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   ImGearARTCallout* callout
)
public:
ImGearARTTextCallout(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   ImGearARTCallout^ callout
)

Parameters

rect
Mark's rectangle.
text
Text string.
textColor
Color of the text.
callout
ImGearARTCallout object that specifies mark's callout attributes.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTCallout Class


%%PageItemTitle%%

ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,ImGearARTCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class > ImGearARTTextCallout Constructor : ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles,ImGearARTCallout)
Mark's rectangle.
Text string.
Color of the mark's text.
The name of the font.
The size of the font in points.
The style of the font.
ImGearARTCallout object that specifies mark's callout attributes.
Initializes a new instance of the ImGearARTTextCallout class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles, _
   ByVal callout As ImGearARTCallout _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles
Dim callout As ImGearARTCallout

Dim instance As New ImGearARTTextCallout(rect, text, textColor, fontName, fontSize, fontStyle, callout)
public ImGearARTTextCallout(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTCallout callout
)
public: ImGearARTTextCallout(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTCallout* callout
)
public:
ImGearARTTextCallout(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle,
   ImGearARTCallout^ callout
)

Parameters

rect
Mark's rectangle.
text
Text string.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
callout
ImGearARTCallout object that specifies mark's callout attributes.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration
ImGearARTCallout Class


%%PageItemTitle%% $$Methods$$

ImGearARTTextCallout Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextCallout Class

For a list of all members of this type, see ImGearARTTextCallout members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves the mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextCallout Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTTextCallout Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextCallout Class

For a list of all members of this type, see ImGearARTTextCallout members.

See Also

Reference

ImGearARTTextCallout Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTTextCallout
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTTextCallout
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
IImGearScrollableView Interface


Flip Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTTextCallout
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Flip Method


GetAutoFitSize Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : GetAutoFitSize Method
The page view control that contains text mark.
The page display of the page view control.
The auto fit mode.
Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAutoFitSize( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal autoFitMode As ImGearARTTextAutoFitMode _
) As ImGearSize
'Usage

Dim instance As ImGearARTTextCallout
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim autoFitMode As ImGearARTTextAutoFitMode
Dim value As ImGearSize

value = instance.GetAutoFitSize(pageView, pageDisplay, autoFitMode)
public ImGearSize GetAutoFitSize(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public: ImGearSize GetAutoFitSize(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public:
ImGearSize GetAutoFitSize(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.
autoFitMode
The auto fit mode.

Return Value

ImageGear.Core.ImGearSize value with necessary dimensions of the mark's bounds.
Remarks
Calculated bounding box size depends on the autoFitMode. Possible values are:
  • ImGearARTTextAutoFitMode.AdjustHeight - in this mode the width remains unchanged, the height is adjusted to fit entire text without clipping.
  • ImGearARTTextAutoFitMode.AdjustWidth - in this mode the height remains unchanged, the width is adjusted to fit the widest text line without clipping from the right.
  • ImGearARTTextAutoFitMode.AdjustHeight | ImGearARTTextAutoFitMode.AdjustWidth - in this mode both height and width are adjusted to fit entire text without clipping.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


GetOverflowedTextLength Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : GetOverflowedTextLength Method
The page view control that contains text mark.
The page display of the page view control.
Calculates the number of characters that do not completely fit into displayable area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOverflowedTextLength( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay _
) As Integer
'Usage

Dim instance As ImGearARTTextCallout
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim value As Integer

value = instance.GetOverflowedTextLength(pageView, pageDisplay)
public int GetOverflowedTextLength(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay
)
public: int GetOverflowedTextLength(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay
)
public:
int GetOverflowedTextLength(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.

Return Value

The number of not fully displayable characters, 0 otherwise.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


GetRenderBounds Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTTextCallout
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Move Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Move Method
X offset to move.
Y offset to move.
Moves the mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTTextCallout
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Rotate Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTTextCallout
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Rotate Method


Scale Method (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTTextCallout
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTTextCallout Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextCallout Class

For a list of all members of this type, see ImGearARTTextCallout members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | Callout | Gets or sets the ImGearARTCallout class object that specifies mark's callout attributes.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the mark text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | HitTestBounds | Overridden. Gets the mark's boundling rectangle used for hit test.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text string.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTTextCallout Class
ImageGear.ART Namespace


Bounds Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
ImGearRectangle Structure


Callout Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Callout Property
Gets or sets the ImGearARTCallout class object that specifies mark's callout attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Callout As ImGearARTCallout
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearARTCallout

instance.Callout = value

value = instance.Callout
public ImGearARTCallout Callout {get; set;}
public: __property ImGearARTCallout* get_Callout();
public: __property void set_Callout(
   ImGearARTCallout* value
);
public:
property ImGearARTCallout^ Callout {
   ImGearARTCallout^ get();
   void set (    ImGearARTCallout^ value);
}

Property Value

ImGearARTCallout class object.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


FontDisablePPM Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

System.Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


FontName Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : FontName Property
Gets or sets the font name of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTTextCallout
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


FontSize Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : FontSize Property
Gets or sets the font size of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


FontStyleART Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : FontStyleART Property
Gets or sets the font style of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Height Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Height Property
Gets or sets the height of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


HitTestBounds Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : HitTestBounds Property
Gets the mark's boundling rectangle used for hit test.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property HitTestBounds As ImGearRectangle
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearRectangle

value = instance.HitTestBounds
public override ImGearRectangle HitTestBounds {get;}
public: __property ImGearRectangle get_HitTestBounds() override;
public:
property ImGearRectangle HitTestBounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
ImGearRectangle Structure


SelectionType Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Text Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Text Property
Gets or sets the text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTTextCallout
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


TextColor Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : TextColor Property
Gets or sets the color of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTTextCallout
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
ImGearRGBQuad Structure


Type Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTTextCallout
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTTextCallout)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Visible Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Width Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Width Property
Gets or sets the width of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


X Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : X Property
Gets or sets the X coordinate of top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


Y Property (ImGearARTTextCallout)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextCallout Class : Y Property
Gets or sets the Y coordinate of top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTTextCallout
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

ImGearARTTextFromFile Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextFromFile Class
Represents legacy ART Text From File mark.
Object Model
ImGearARTTextFromFile ClassImGearRectangle StructureImGearSize StructureImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTTextFromFile
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTTextFromFile
public class ImGearARTTextFromFile : ImGearARTMark
public __gc class ImGearARTTextFromFile : public ImGearARTMark
public ref class ImGearARTTextFromFile : public ImGearARTMark
Example
  • C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text annotation with the contents of test.txt.
ImGearARTTextFromFile igARTTextFromFile = new ImGearARTTextFromFile(
    igRectangle, "test.txt", igRGBQuadText,
    "Arial", (float)14.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextFromFile, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text annotation with the contents of test.txt.
Dim igARTTextFromFile As New ImGearARTTextFromFile( _
 igRectangle, "test.txt", igRGBQuadText, _
 "Arial", CSng(14), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextFromFile, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTTextFromFile

See Also

Reference

ImGearARTTextFromFile Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTTextFromFile Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextFromFile Class

The following tables list the members exposed by ImGearARTTextFromFile.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTTextFromFile Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the path to the text file.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextFromFile Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextFromFile Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : ImGearARTTextFromFile Constructor
Overload List
Overload | Description
ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTextFromFile class object.
ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTTextFromFile class object.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class > ImGearARTTextFromFile Constructor : ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad)
Mark's rectangle.
Path to the file to load text from.
Color of the mark's text.
Initializes a new instance of the ImGearARTTextFromFile class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTTextFromFile(rect, text, textColor)
public ImGearARTTextFromFile(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTTextFromFile(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTTextFromFile(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class > ImGearARTTextFromFile Constructor : ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)
Mark's rectangle.
Path to the file to load text from.
Color of the mark's text.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTTextFromFile class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTTextFromFile(rect, text, textColor, fontName, fontSize, fontStyle)
public ImGearARTTextFromFile(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTTextFromFile(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTTextFromFile(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTTextFromFile Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextFromFile Class

For a list of all members of this type, see ImGearARTTextFromFile members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextFromFile Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTTextFromFile Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextFromFile Class

For a list of all members of this type, see ImGearARTTextFromFile members.

See Also

Reference

ImGearARTTextFromFile Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTTextFromFile
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTTextFromFile
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
IImGearScrollableView Interface


Flip Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTTextFromFile
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Flip Method


GetAutoFitSize Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : GetAutoFitSize Method
The page view control that contains text mark.
The page display of the page view control.
The auto fit mode.
Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAutoFitSize( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal autoFitMode As ImGearARTTextAutoFitMode _
) As ImGearSize
'Usage

Dim instance As ImGearARTTextFromFile
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim autoFitMode As ImGearARTTextAutoFitMode
Dim value As ImGearSize

value = instance.GetAutoFitSize(pageView, pageDisplay, autoFitMode)
public ImGearSize GetAutoFitSize(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public: ImGearSize GetAutoFitSize(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public:
ImGearSize GetAutoFitSize(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.
autoFitMode
The auto fit mode.

Return Value

ImageGear.Core.ImGearSize value with necessary dimensions of the mark's bounds.
Remarks
Calculated bounding box size depends on the autoFitMode. Possible values are:
  • ImGearARTTextAutoFitMode.AdjustHeight - in this mode the width remains unchanged, the height is adjusted to fit entire text without clipping.
  • ImGearARTTextAutoFitMode.AdjustWidth - in this mode the height remains unchanged, the width is adjusted to fit the widest text line without clipping from the right.
  • ImGearARTTextAutoFitMode.AdjustHeight | ImGearARTTextAutoFitMode.AdjustWidth - in this mode both height and width are adjusted to fit entire text without clipping.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


GetOverflowedTextLength Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : GetOverflowedTextLength Method
The page view control that contains text mark.
The page display of the page view control.
Calculates the number of characters that do not completely fit into displayable area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOverflowedTextLength( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay _
) As Integer
'Usage

Dim instance As ImGearARTTextFromFile
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim value As Integer

value = instance.GetOverflowedTextLength(pageView, pageDisplay)
public int GetOverflowedTextLength(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay
)
public: int GetOverflowedTextLength(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay
)
public:
int GetOverflowedTextLength(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.

Return Value

The number of not fully displayable characters, 0 otherwise.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


GetRenderBounds Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTTextFromFile
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Move Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Move Method
X offset in abstract coordinates.
Y offset in abstract coordinates.
Moves mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTTextFromFile
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Rotate Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTTextFromFile
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Rotate Method


Scale Method (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTTextFromFile
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTTextFromFile Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextFromFile Class

For a list of all members of this type, see ImGearARTTextFromFile members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the path to the text file.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTTextFromFile Class
ImageGear.ART Namespace


Bounds Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
ImGearRectangle Structure


FontDisablePPM Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


FontName Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : FontName Property
Gets or sets the font name of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


FontSize Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : FontSize Property
Gets or sets the font size of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


FontStyleART Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : FontStyleART Property
Gets or sets the font style of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Height Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Height Property
Gets or sets the height of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


SelectionType Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Text Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Text Property
Gets or sets the path to the text file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


TextColor Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
ImGearRGBQuad Structure


Type Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTTextFromFile)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Visible Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Width Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Width Property
Gets or sets the width of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


X Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


Y Property (ImGearARTTextFromFile)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextFromFile Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTTextFromFile
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

ImGearARTTextStamp Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextStamp Class
Represents legacy ART Text Stamp mark.
Object Model
ImGearARTTextStamp ClassImGearRectangle StructureImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTTextStamp
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTTextStamp
public class ImGearARTTextStamp : ImGearARTMark
public __gc class ImGearARTTextStamp : public ImGearARTMark
public ref class ImGearARTTextStamp : public ImGearARTMark
Example
  • C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text stamp annotation
ImGearARTTextStamp igARTTextStamp = new ImGearARTTextStamp(
    igRectangle, "ImGearARTTextStamp test", igRGBQuadText,
    "Arial", (float)14.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextStamp, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text stamp annotation
Dim igARTTextStamp As New ImGearARTTextStamp( _
 igRectangle, "ImGearARTTextStamp test", igRGBQuadText, _
 "Arial", CSng(14), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextStamp, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTTextStamp

See Also

Reference

ImGearARTTextStamp Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTTextStamp Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextStamp Class

The following tables list the members exposed by ImGearARTTextStamp.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTTextStamp Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the stamp text.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextStamp Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextStamp Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : ImGearARTTextStamp Constructor
Overload List
Overload | Description
ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTextStamp class object.
ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTTextStamp class object.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class > ImGearARTTextStamp Constructor : ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Initializes a new instance of the ImGearARTTextStamp class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTTextStamp(rect, text, textColor)
public ImGearARTTextStamp(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTTextStamp(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTTextStamp(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class > ImGearARTTextStamp Constructor : ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTTextStamp class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTTextStamp(rect, text, textColor, fontName, fontSize, fontStyle)
public ImGearARTTextStamp(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTTextStamp(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTTextStamp(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTTextStamp Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextStamp Class

For a list of all members of this type, see ImGearARTTextStamp members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTextStamp Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTTextStamp Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextStamp Class

For a list of all members of this type, see ImGearARTTextStamp members.

See Also

Reference

ImGearARTTextStamp Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTTextStamp
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTTextStamp
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
IImGearScrollableView Interface


Flip Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTTextStamp
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Flip Method


GetRenderBounds Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTTextStamp
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Move Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Move Method
X offset in abstract coordinates.
Y offset in abstract coordinates.
Moves mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTTextStamp
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Rotate Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTTextStamp
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Rotate Method


Scale Method (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTTextStamp
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTTextStamp Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextStamp Class

For a list of all members of this type, see ImGearARTTextStamp members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the stamp text.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTTextStamp Class
ImageGear.ART Namespace


Bounds Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTTextStamp
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
ImGearRectangle Structure


FontDisablePPM Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


FontName Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : FontName Property
Gets or sets the font name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTTextStamp
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


FontSize Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : FontSize Property
Gets or sets the font size of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


FontStyleART Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : FontStyleART Property
Gets or sets the font style of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTTextStamp
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Height Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Height Property
Gets or sets the height of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


SelectionType Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTTextStamp
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Text Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Text Property
Gets or sets the stamp text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTTextStamp
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


TextColor Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : TextColor Property
Gets or sets the color of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTTextStamp
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
ImGearRGBQuad Structure


Type Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTTextStamp
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTTextStamp)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Visible Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Width Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Width Property
Gets or sets the width of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


X Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


Y Property (ImGearARTTextStamp)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTextStamp Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTTextStamp
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

ImGearARTTypedText Class
Members Example

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTypedText Class
Represents legacy ART Typed Text mark.
Object Model
ImGearARTTypedText ClassImGearRectangle StructureImGearSize StructureImGearRectangle StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTTypedText
   Inherits ImGearARTMark
'Usage

Dim instance As ImGearARTTypedText
public class ImGearARTTypedText : ImGearARTMark
public __gc class ImGearARTTypedText : public ImGearARTMark
public ref class ImGearARTTypedText : public ImGearARTMark
Example
  • C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 255);
// Create the typed text annotation
ImGearARTTypedText igARTTypedText = new ImGearARTTypedText(
    igRectangle, "ImGearARTTypedText test", igRGBQuadText,
    "Arial", (float)14.0, ImGearARTFontStyles.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD);
  • Visual Basic
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 255)
' Create the typed text annotation
Dim igARTTypedText As New ImGearARTTypedText( _
 igRectangle, "ImGearARTTypedText test", igRGBQuadText, _
 "Arial", CSng(14), ImGearARTFontStyles.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD)
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTSelection
ImageGear.ART.ImGearARTMark
ImageGear.ART.ImGearARTTypedText

See Also

Reference

ImGearARTTypedText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTTypedText Class Members
Properties Methods Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTypedText Class

The following tables list the members exposed by ImGearARTTypedText.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTTypedText Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text string of the mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTypedText Class
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTypedText Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : ImGearARTTypedText Constructor
Overload List
Overload | Description
ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTypedText class object.
ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles) | Initializes a new instance of the ImGearARTTypedText class object.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class > ImGearARTTypedText Constructor : ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
Initializes a new instance of the ImGearARTTypedText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad

Dim instance As New ImGearARTTypedText(rect, text, textColor)
public ImGearARTTypedText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor
)
public: ImGearARTTypedText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor
)
public:
ImGearARTTypedText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class > ImGearARTTypedText Constructor : ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,Single,ImGearARTFontStyles)
Mark's rectangle.
Text of the mark.
Color of the mark's text.
The name of the font.
The size of the font in points.
The style of the font.
Initializes a new instance of the ImGearARTTypedText class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle, _
   ByVal text As String, _
   ByVal textColor As IImGearRGBQuad, _
   ByVal fontName As String, _
   ByVal fontSize As Single, _
   ByVal fontStyle As ImGearARTFontStyles _
)
'Usage

Dim rect As IImGearRectangle
Dim text As String
Dim textColor As IImGearRGBQuad
Dim fontName As String
Dim fontSize As Single
Dim fontStyle As ImGearARTFontStyles

Dim instance As New ImGearARTTypedText(rect, text, textColor, fontName, fontSize, fontStyle)
public ImGearARTTypedText(
   IImGearRectangle rect,
   string text,
   IImGearRGBQuad textColor,
   string fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public: ImGearARTTypedText(
   IImGearRectangle* rect,
   string* text,
   IImGearRGBQuad* textColor,
   string* fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)
public:
ImGearARTTypedText(
   IImGearRectangle^ rect,
   String^ text,
   IImGearRGBQuad^ textColor,
   String^ fontName,
   float fontSize,
   ImGearARTFontStyles fontStyle
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The size of the font in points.
fontStyle
The style of the font.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Overload List
ImGearRectangle Structure
ImGearRGBQuad Structure
ImGearARTFontStyles Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTTypedText Class Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTypedText Class

For a list of all members of this type, see ImGearARTTypedText members.

Public Methods
 | Name | Description
Public Method | BeginEdit | Begins text editing process.
Public Method | EndEdit | Ends text editing process.
Public Method | Flip | Overridden. Flips the mark around the center in vertical or horizontal direction.
Public Method | GetAutoFitSize | Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Public Method | GetOverflowedTextLength | Calculates the number of characters that do not completely fit into displayable area.
Public Method | GetRenderBounds | Overridden. Gets rendering bounding rectangle of the mark in abstract coordinates.
Public Method | Move | Overridden. Moves mark by specified offset.
Public Method | Rotate | Overridden. Rotates the mark around the center.
Public Method | Scale | Overridden. Scales the mark in horizontal and vertical directions.
Top
See Also

Reference

ImGearARTTypedText Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Events$$

ImGearARTTypedText Class Events

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTypedText Class

For a list of all members of this type, see ImGearARTTypedText members.

See Also

Reference

ImGearARTTypedText Class
ImageGear.ART Namespace


BeginEdit Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : BeginEdit Method
PageView control that contains text mark.
PageDisplay of the PageView control.
Begins text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginEdit( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As ImGearPageDisplay _
) As Boolean
'Usage

Dim instance As ImGearARTTypedText
Dim pageView As IImGearScrollableView
Dim pageDisplay As ImGearPageDisplay
Dim value As Boolean

value = instance.BeginEdit(pageView, pageDisplay)
public bool BeginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)
public: bool BeginEdit(
   IImGearScrollableView* pageView,
   ImGearPageDisplay* pageDisplay
)
public:
bool BeginEdit(
   IImGearScrollableView^ pageView,
   ImGearPageDisplay^ pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
ImGearPageDisplay Class
IImGearScrollableView Interface


EndEdit Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : EndEdit Method
PageView control that contains text mark.
Ends text editing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearARTTypedText
Dim pageView As IImGearScrollableView

instance.EndEdit(pageView)
public void EndEdit(
   IImGearScrollableView pageView
)
public: void EndEdit(
   IImGearScrollableView* pageView
)
public:
void EndEdit(
   IImGearScrollableView^ pageView
)

Parameters

pageView
PageView control that contains text mark.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
IImGearScrollableView Interface


Flip Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Flip Method
The center point, around which to flip the mark.
Flip direction.
Flips the mark around the center in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flip( _
   ByVal center As ImGearPoint, _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearARTTypedText
Dim center As ImGearPoint
Dim flipMode As ImGearFlipModes

instance.Flip(center, flipMode)
public override void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override
public:
void Flip(
   ImGearPoint center,
   ImGearFlipModes flipMode
) override

Parameters

center
The center point, around which to flip the mark.
flipMode
Flip direction.
Remarks
The method is called when ART page is flipped.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Flip Method


GetAutoFitSize Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : GetAutoFitSize Method
The page view control that contains text mark.
The page display of the page view control.
The auto fit mode.
Calculates mark's bounding box size that will fit either entire text, or the widest text line of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAutoFitSize( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal autoFitMode As ImGearARTTextAutoFitMode _
) As ImGearSize
'Usage

Dim instance As ImGearARTTypedText
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim autoFitMode As ImGearARTTextAutoFitMode
Dim value As ImGearSize

value = instance.GetAutoFitSize(pageView, pageDisplay, autoFitMode)
public ImGearSize GetAutoFitSize(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public: ImGearSize GetAutoFitSize(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)
public:
ImGearSize GetAutoFitSize(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay,
   ImGearARTTextAutoFitMode autoFitMode
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.
autoFitMode
The auto fit mode.

Return Value

ImageGear.Core.ImGearSize value with necessary dimensions of the mark's bounds.
Remarks
Calculated bounding box size depends on the autoFitMode. Possible values are:
  • ImGearARTTextAutoFitMode.AdjustHeight - in this mode the width remains unchanged, the height is adjusted to fit entire text without clipping.
  • ImGearARTTextAutoFitMode.AdjustWidth - in this mode the height remains unchanged, the width is adjusted to fit the widest text line without clipping from the right.
  • ImGearARTTextAutoFitMode.AdjustHeight | ImGearARTTextAutoFitMode.AdjustWidth - in this mode both height and width are adjusted to fit entire text without clipping.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


GetOverflowedTextLength Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : GetOverflowedTextLength Method
The page view control that contains text mark.
The page display of the page view control.
Calculates the number of characters that do not completely fit into displayable area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOverflowedTextLength( _
   ByVal pageView As IImGearScrollableView, _
   ByVal pageDisplay As IImGearPageDisplay _
) As Integer
'Usage

Dim instance As ImGearARTTypedText
Dim pageView As IImGearScrollableView
Dim pageDisplay As IImGearPageDisplay
Dim value As Integer

value = instance.GetOverflowedTextLength(pageView, pageDisplay)
public int GetOverflowedTextLength(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay
)
public: int GetOverflowedTextLength(
   IImGearScrollableView* pageView,
   IImGearPageDisplay* pageDisplay
)
public:
int GetOverflowedTextLength(
   IImGearScrollableView^ pageView,
   IImGearPageDisplay^ pageDisplay
)

Parameters

pageView
The page view control that contains text mark.
pageDisplay
The page display of the page view control.

Return Value

The number of not fully displayable characters, 0 otherwise.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


GetRenderBounds Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : GetRenderBounds Method
The page display.
Gets rendering bounding rectangle of the mark in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetRenderBounds( _
   ByVal pageDisplay As IImGearPageDisplay _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTTypedText
Dim pageDisplay As IImGearPageDisplay
Dim value As ImGearRectangle

value = instance.GetRenderBounds(pageDisplay)
public override ImGearRectangle GetRenderBounds(
   IImGearPageDisplay pageDisplay
)
public: ImGearRectangle GetRenderBounds(
   IImGearPageDisplay* pageDisplay
) override
public:
ImGearRectangle GetRenderBounds(
   IImGearPageDisplay^ pageDisplay
) override

Parameters

pageDisplay
The page display.

Return Value

ImageGear.Core.ImGearRectangle value.
Remarks
The type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.

As opposed to Bounds property, which takes into account mark's bounding points only, this method considers all rendering elements of the mark - i.e. in addition to the bounding points it takes into account additional attributes, if any: border, line width, label, selection, etc...

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Move Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Move Method
X offset in abstract coordinates.
Y offset in abstract coordinates.
Moves mark by specified offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Move( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearARTTypedText
Dim offsetX As Integer
Dim offsetY As Integer

instance.Move(offsetX, offsetY)
public override void Move(
   int offsetX,
   int offsetY
)
public: void Move(
   int offsetX,
   int offsetY
) override
public:
void Move(
   int offsetX,
   int offsetY
) override

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Rotate Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Rotate Method
The center point, around which to rotate the mark.
Rotation angle.
Rotates the mark around the center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Rotate( _
   ByVal center As ImGearPoint, _
   ByVal rotationAngle As ImGearRotationValues _
)
'Usage

Dim instance As ImGearARTTypedText
Dim center As ImGearPoint
Dim rotationAngle As ImGearRotationValues

instance.Rotate(center, rotationAngle)
public override void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
)
public: void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override
public:
void Rotate(
   ImGearPoint center,
   ImGearRotationValues rotationAngle
) override

Parameters

center
The center point, around which to rotate the mark.
rotationAngle
Rotation angle.
Remarks
The method is called when the ART page is rotated.

Note: The center parameter must be provided in the same coordinate system, as the mark was created and added to the ART page (image or device).

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Rotate Method


Scale Method (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Scale Method
The horizontal scaling factor.
The vertical scaling factor.
Scales the mark in horizontal and vertical directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
)
'Usage

Dim instance As ImGearARTTypedText
Dim scaleX As Double
Dim scaleY As Double

instance.Scale(scaleX, scaleY)
public override void Scale(
   double scaleX,
   double scaleY
)
public: void Scale(
   double scaleX,
   double scaleY
) override
public:
void Scale(
   double scaleX,
   double scaleY
) override

Parameters

scaleX
The horizontal scaling factor.
scaleY
The vertical scaling factor.
Remarks
The method is called when ART page is scaled.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Scale Method


%%PageItemTitle%% $$Properties$$

ImGearARTTypedText Class Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTypedText Class

For a list of all members of this type, see ImGearARTTypedText members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Gets mark's bounding rectangle in abstract coordinates.
Public Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Public Property | FontName | Gets or sets the font name of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyleART | Gets or sets the font style of the text.
Public Property | Height | Gets or sets the height of the mark rectangle.
Public Property | SelectionType | Overridden. Gets the selection type.
Public Property | Text | Gets or sets the text string of the mark.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Overridden. Gets mark's type.
Public Property | UserData | Overridden. Gets or sets the user data specified for the mark.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the mark is visible or not.
Public Property | Width | Gets or sets the width of the mark's rectangle.
Public Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Public Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

ImGearARTTypedText Class
ImageGear.ART Namespace


Bounds Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Bounds Property
Gets mark's bounding rectangle in abstract coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Bounds As ImGearRectangle
'Usage

Dim instance As ImGearARTTypedText
Dim value As ImGearRectangle

value = instance.Bounds
public override ImGearRectangle Bounds {get;}
public: __property ImGearRectangle get_Bounds() override;
public:
property ImGearRectangle Bounds {
   ImGearRectangle get() override;
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
Type of the mark's coordinate system is specifying when using ImGearARTPage.AddMark method.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
ImGearRectangle Structure


FontDisablePPM Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontDisablePPM As Boolean
'Usage

Dim instance As ImGearARTTypedText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
public bool FontDisablePPM {get; set;}
public: __property bool get_FontDisablePPM();
public: __property void set_FontDisablePPM(
   bool value
);
public:
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations. The default value is false.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


FontName Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : FontName Property
Gets or sets the font name of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As String
'Usage

Dim instance As ImGearARTTypedText
Dim value As String

instance.FontName = value

value = instance.FontName
public string FontName {get; set;}
public: __property string* get_FontName();
public: __property void set_FontName(
   string* value
);
public:
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


FontSize Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : FontSize Property
Gets or sets the font size of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSize As Single
'Usage

Dim instance As ImGearARTTypedText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
public float FontSize {get; set;}
public: __property float get_FontSize();
public: __property void set_FontSize(
   float value
);
public:
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


FontStyleART Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : FontStyleART Property
Gets or sets the font style of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As ImGearARTTypedText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
public ImGearARTFontStyles FontStyleART {get; set;}
public: __property ImGearARTFontStyles get_FontStyleART();
public: __property void set_FontStyleART(
   ImGearARTFontStyles value
);
public:
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Height Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Height Property
Gets or sets the height of the mark rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearARTTypedText
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


SelectionType Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : SelectionType Property
Gets the selection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property SelectionType As ImGearARTSelectionType
'Usage

Dim instance As ImGearARTTypedText
Dim value As ImGearARTSelectionType

value = instance.SelectionType
public override ImGearARTSelectionType SelectionType {get;}
public: __property ImGearARTSelectionType get_SelectionType() override;
public:
property ImGearARTSelectionType SelectionType {
   ImGearARTSelectionType get() override;
}

Property Value

ImGearARTSelectionType value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Text Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Text Property
Gets or sets the text string of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearARTTypedText
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


TextColor Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As IImGearRGBQuad
'Usage

Dim instance As ImGearARTTypedText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
public IImGearRGBQuad TextColor {get; set;}
public: __property IImGearRGBQuad* get_TextColor();
public: __property void set_TextColor(
   IImGearRGBQuad* value
);
public:
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
ImGearRGBQuad Structure


Type Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Type Property
Gets mark's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearARTMarkType
'Usage

Dim instance As ImGearARTTypedText
Dim value As ImGearARTMarkType

value = instance.Type
public override ImGearARTMarkType Type {get;}
public: __property ImGearARTMarkType get_Type() override;
public:
property ImGearARTMarkType Type {
   ImGearARTMarkType get() override;
}

Property Value

ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
ImGearARTMarkType Enumeration


UserData Property (ImGearARTTypedText)
Example

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : UserData Property
Gets or sets the user data specified for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property UserData As Object
'Usage

Dim instance As ImGearARTTypedText
Dim value As Object

instance.UserData = value

value = instance.UserData
public override object UserData {get; set;}
public: __property Object* get_UserData() override;
public: __property void set_UserData(
   Object* value
) override;
public:
property Object^ UserData {
   Object^ get() override;
   void set (    Object^ value) override;
}

Property Value

Object value.
Remarks
You can load/save the data associated with this property from/to XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData.

Example
  • C#
[Serializable]
public class UserData
{
    private string _textData;
    private int _integerData;

    public UserData(string textData, int integerData)
    {
        this.TextData = textData;
        this.IntegerData = integerData;
    }

    public string TextData
    {
        get
        {
            return _textData;
        }

        private set
        {
            _textData = value;
        }
    }

    public int IntegerData
    {
        get
        {
            return _integerData;
        }

        private set
        {
            _integerData = value;
        }
    }
}
  • Visual Basic
<SerializableAttribute()> _
Public Class UserData
    Private _textData As String
    Private _integerData As String

    Public Sub New(ByVal textData As String, ByVal integerData As Integer)
        Me.TextData = textData
        Me.IntegerData = integerData
    End Sub
    Public Property TextData() As String
        Get
            Return _textData
        End Get
        Set(ByVal Value As String)
            _textData = Value
        End Set
    End Property
    Public Property IntegerData() As Integer
        Get
            Return _integerData
        End Get
        Set(ByVal Value As Integer)
            _integerData = Value
        End Set
    End Property
End Class
  • C#
// Create user data.
UserData userData = new UserData("Text data to export to XML.", 99);

// Get annotation to assign user data to.
ImGearARTMark mark = igARTPage.MarkGet(markId);

// Set corresponding property of the mark.
mark.UserData = userData;

// Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML);

stream.Seek(0, SeekOrigin.Begin);

// Create new ART Page from the stream and get the annotation with the user data.
ImGearARTPage newArtPage = ImGearART.LoadPage(stream, 0);
ImGearARTMark newMark = newArtPage.MarkGet(markId);
UserData newUserData = (UserData)newMark.UserData;

System.Diagnostics.Debug.Assert(newUserData.IntegerData == userData.IntegerData);
System.Diagnostics.Debug.Assert(newUserData.TextData == userData.TextData);
  • Visual Basic
' Create user data.
Dim userData As UserData = New UserData("Textual data to export to XML", 99)

' Get annotation to assign user data to.
Dim mark As ImGearARTMark = igARTPage.MarkGet(markId)

' Set corresponding property of the mark.
mark.UserData = userData

' Save page with annotation and user data to a stream.
ImGearART.SavePage(igARTPage, stream, 0, ImGearSavingModes.OVERWRITE, ImGearARTSaveType.XML)

stream.Seek(0, SeekOrigin.Begin)

' Create new ART Page from the stream and get the annotation with the user data.
Dim newArtPage As ImGearARTPage = ImGearART.LoadPage(stream, 0)
Dim newMark As ImGearARTMark = newArtPage.MarkGet(markId)
Dim newUserData As UserData = CType(newMark.UserData, UserData)

System.Diagnostics.Debug.Assert(newUserData.IntegerData = userData.IntegerData)
System.Diagnostics.Debug.Assert(newUserData.TextData = userData.TextData)
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Visible Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Visible Property
Gets or sets a value indicating whether the mark is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Visible As Boolean
'Usage

Dim instance As ImGearARTTypedText
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public override bool Visible {get; set;}
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
public:
property bool Visible {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Width Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearARTTypedText
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


X Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearARTTypedText
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


Y Property (ImGearARTTypedText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTTypedText Class : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearARTTypedText
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

ImGearARTAccess Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAccess Enumeration
Specifies annotations group access level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTAccess
   Inherits System.Enum
'Usage

Dim instance As ImGearARTAccess
public enum ImGearARTAccess : System.Enum
__value public enum ImGearARTAccess : public System.Enum
public enum class ImGearARTAccess : public System.Enum
Members
Member | Value | Description
LOCKED | 1 | Access denied.
UNLOCKED | 2 | Access granted.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTAccess

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTAspectKind Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTAspectKind Enumeration
Specifies the kinds of aspects for the ruler annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTAspectKind
   Inherits System.Enum
'Usage

Dim instance As ImGearARTAspectKind
public enum ImGearARTAspectKind : System.Enum
__value public enum ImGearARTAspectKind : public System.Enum
public enum class ImGearARTAspectKind : public System.Enum
Members
Member | Value | Description
Absolute | 1 | The aspect values are absolute and do not depend on resolution.
Relative | 0 | The aspect values are relative to the resolution.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTAspectKind

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTBurnInOptions Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTBurnInOptions Enumeration
Specifies options to burn in annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTBurnInOptions
   Inherits System.Enum
'Usage

Dim instance As ImGearARTBurnInOptions
public enum ImGearARTBurnInOptions : System.Enum
__value public enum ImGearARTBurnInOptions : public System.Enum
public enum class ImGearARTBurnInOptions : public System.Enum
Members
Member | Value | Description
ALL | 0x00000001 | Burn in all annotation marks.
DELETE_MARKS | 0x00010000 | Delete affected annotation marks after burning them in.
SELECTED | 0x00000010 | Burn in all selected annotation marks.
VISIBLE | 0x00000008 | Burn in all visible annotation marks.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTBurnInOptions

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTButtonState Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTButtonState Enumeration
Specifies button mark's state options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTButtonState
   Inherits System.Enum
'Usage

Dim instance As ImGearARTButtonState
public enum ImGearARTButtonState : System.Enum
__value public enum ImGearARTButtonState : public System.Enum
public enum class ImGearARTButtonState : public System.Enum
Members
Member | Value | Description
NORMAL | 0 | Button is unpressed.
PRESSED | 1 | Button is pressed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTButtonState

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTCalloutType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCalloutType Enumeration
Specifies callout types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTCalloutType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTCalloutType
public enum ImGearARTCalloutType : System.Enum
__value public enum ImGearARTCalloutType : public System.Enum
public enum class ImGearARTCalloutType : public System.Enum
Members
Member | Value | Description
LINE | 0 | Linear callout.
TRIANGLE | 1 | Triangular callout.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTCalloutType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTCapStyle Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCapStyle Enumeration
Specifies the available cap styles of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTCapStyle
   Inherits System.Enum
'Usage

Dim instance As ImGearARTCapStyle
public enum ImGearARTCapStyle : System.Enum
__value public enum ImGearARTCapStyle : public System.Enum
public enum class ImGearARTCapStyle : public System.Enum
Members
Member | Value | Description
Flat | 0 | Specifies a flat line cap.
Round | 1 | Specifies a round line cap.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTCapStyle

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTCoordinatesType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTCoordinatesType Enumeration
Specifies mark's coordinate types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTCoordinatesType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTCoordinatesType
public enum ImGearARTCoordinatesType : System.Enum
__value public enum ImGearARTCoordinatesType : public System.Enum
public enum class ImGearARTCoordinatesType : public System.Enum
Members
Member | Value | Description
DEVICE_COORD | 2 | Device coordinate system.
IMAGE_COORD | 1 | Image coordinate system.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTCoordinatesType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFillRule Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFillRule Enumeration
Specifies how the intersecting areas of the shape are combined to form the filling area of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTFillRule
   Inherits System.Enum
'Usage

Dim instance As ImGearARTFillRule
public enum ImGearARTFillRule : System.Enum
__value public enum ImGearARTFillRule : public System.Enum
public enum class ImGearARTFillRule : public System.Enum
Members
Member | Value | Description
EvenOdd | 0 | Rule that determines whether a point is in the fill region by drawing a ray from that point to infinity in any direction and counting the number of path segments within the given shape that the ray crosses. If this number is odd, the point is inside; if even, the point is outside.
NonZero | 1 | Rule that determines whether a point is in the fill region of the path by drawing a ray from that point to infinity in any direction and then examining the places where a segment of the shape crosses the ray. Starting with a count of zero, add one each time a segment crosses the ray from left to right and subtract one each time a path segment crosses the ray from right to left. After counting the crossings, if the result is zero then the point is outside the path. Otherwise, it is inside.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTFillRule

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTFontStyles Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTFontStyles Enumeration
Specifies text font style information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearARTFontStyles
   Inherits System.Enum
'Usage

Dim instance As ImGearARTFontStyles
[Flags()]
public enum ImGearARTFontStyles : System.Enum
[Flags()]
__value public enum ImGearARTFontStyles : public System.Enum
[Flags()]
public enum class ImGearARTFontStyles : public System.Enum
Members
Member | Value | Description
Bold | 0x00000001 | Bold text.
Italic | 0x00000002 | Italic text.
Regular | 0x00000000 | Normal text.
Strikeout | 0x00000008 | Text with a line through the middle.
Underline | 0x00000004 | Underlined text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTFontStyles

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTJoinStyle Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTJoinStyle Enumeration
Specifies the available styles of the shape that joins two lines of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTJoinStyle
   Inherits System.Enum
'Usage

Dim instance As ImGearARTJoinStyle
public enum ImGearARTJoinStyle : System.Enum
__value public enum ImGearARTJoinStyle : public System.Enum
public enum class ImGearARTJoinStyle : public System.Enum
Members
Member | Value | Description
Miter | 0 | Specifies a mitered join.
Round | 1 | Specifies a circular join.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTJoinStyle

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTLineHeadType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLineHeadType Enumeration
Specifies line mark's head types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTLineHeadType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTLineHeadType
public enum ImGearARTLineHeadType : System.Enum
__value public enum ImGearARTLineHeadType : public System.Enum
public enum class ImGearARTLineHeadType : public System.Enum
Members
Member | Value | Description
CIRCLE | 7 | Circle head.
DIAMOND | 6 | Diamond head.
NONE | 4 | Without head.
OPEN | 2 | Open pointer head.
POINTER | 0 | Regular pointer head.
POINTER_SOLID | 3 | Solid pointer head.
SLASH | 8 | Slash head.
SOLID | 1 | Solid head.
SQUARE | 5 | Square head.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTLineHeadType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkHitTest Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkHitTest Enumeration
Specifies the hit test results.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTMarkHitTest
   Inherits System.Enum
'Usage

Dim instance As ImGearARTMarkHitTest
public enum ImGearARTMarkHitTest : System.Enum
__value public enum ImGearARTMarkHitTest : public System.Enum
public enum class ImGearARTMarkHitTest : public System.Enum
Members
Member | Value | Description
INBOUNDARY | 2 | Within the mark's boundary, but not on the mark.
ONMARK | 3 | On the mark.
OUTSIDE | 1 | Outside of the mark's boundary.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTMarkHitTest

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkType Enumeration
Specifies types of annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTMarkType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTMarkType
public enum ImGearARTMarkType : System.Enum
__value public enum ImGearARTMarkType : public System.Enum
public enum class ImGearARTMarkType : public System.Enum
Members
Member | Value | Description
ARROW | 506 | Legacy ART 2.0 Arrow mark.
ATTACH_A_NOTE | 10 | Legacy ART 2.0 Attach-A-Note mark.
AUDIO | 503 | ART 3.0/2.0 Audio mark.
BUTTON | 512 | ART 3.0/2.0 Button mark.
CALLOUT | 518 | Legacy ART 2.0 Callout mark.
CURVE | 517 | ART 3.0/2.0 Curve mark.
CUSTOM | 800 | ART 3.0 Custom mark.
ELLIPSE | 601 | ART 3.0 Ellipse mark.
ENCRYPTION | 509 | ART 3.0/2.0 Encryption mark.
FILLED_ELLIPSE | 504 | Legacy ART 2.0 Filled Ellipse mark.
FILLED_POLYGON | 500 | Legacy ART 2.0 Filled Polygon mark.
FILLED_RECTANGLE | 6 | Legacy ART 2.0 Filled Rectangle mark.
FREEHAND_LINE | 4 | ART 3.0/2.0 Freehand Line mark.
HIGHLIGHTER | 514 | Legacy ART 2.0 Highlighter mark.
HOLLOW_ELLIPSE | 505 | Legacy ART 2.0 Hollow Ellipse mark.
HOLLOW_POLYGON | 501 | Legacy ART 2.0 Hollow Polygon mark.
HOLLOW_RECTANGLE | 5 | Legacy ART 2.0 Hollow Rectangle mark.
HOTSPOT | 507 | ART 3.0/2.0 HotSpot mark.
IMAGE | 606 | ART 3.0 Image mark.
IMAGE_EMBEDDED | 1 | Legacy ART 2.0 Embedded Image mark.
IMAGE_REFERENCE | 2 | Legacy ART 2.0 Image Reference mark.
LINE | 3 | ART 3.0/2.0 Line mark.
PIN_UP_TEXT | 513 | Legacy ART 2.0 Pin-Up Text mark.
POINT | 516 | ART 3.0/2.0 Point mark.
POLYGON | 604 | ART 3.0 Polygon mark.
POLYLINE | 502 | ART 3.0/2.0 Polyline mark.
POLYRULER | 607 | ART 3.0 PolyRuler mark.
POPUPTEXT | 608 | ART 3.0 Popup Text mark.
PROTRACTOR | 511 | ART 3.0/2.0 Protractor mark.
RECTANGLE | 600 | ART 3.0 Rectangle mark.
REDACTION | 508 | Legacy ART 2.0 Redaction mark.
RICH_TEXT | 515 | ART 3.0/2.0 Rich Text mark.
RULER | 510 | ART 3.0/2.0 Ruler mark.
SELECT | 0 | Mark selector.
TEXT | 605 | ART 3.0 Text mark.
TEXT_FROM_FILE | 8 | Legacy ART 2.0 Text From File mark.
TEXT_STAMP | 9 | Legacy ART 2.0 Text Stamp mark.
TYPED_TEXT | 7 | Legacy ART 2.0 Typed Text mark.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTMarkType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPenStyle Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPenStyle Enumeration
Specifies pen styles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTPenStyle
   Inherits System.Enum
'Usage

Dim instance As ImGearARTPenStyle
public enum ImGearARTPenStyle : System.Enum
__value public enum ImGearARTPenStyle : public System.Enum
public enum class ImGearARTPenStyle : public System.Enum
Members
Member | Value | Description
DASH | 1 | Line consisting of dashes.
DASHDOT | 3 | Line consisting of a repeating pattern of dash-dot.
DASHDOTDOT | 4 | Line consisting of a repeating pattern of dash-dot-dot.
DOT | 2 | Line consisting of dots.
PDFDASH1 | 5 | Dash pattern compatible with Adobe Acrobat's "Dashed 1" style.
PDFDASH2 | 6 | Dash pattern compatible with Adobe Acrobat's "Dashed 2" style.
PDFDASH3 | 7 | Dash pattern compatible with Adobe Acrobat's "Dashed 3" style.
PDFDASH4 | 8 | Dash pattern compatible with Adobe Acrobat's "Dashed 4" style.
PDFDASH5 | 9 | Dash pattern compatible with Adobe Acrobat's "Dashed 5" style.
PDFDASH6 | 10 | Dash pattern compatible with Adobe Acrobat's "Dashed 6" style.
SOLID | 0 | Solid line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTPenStyle

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTPinAlignment Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTPinAlignment Enumeration
Specifies an alignment of the pin icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTPinAlignment
   Inherits System.Enum
'Usage

Dim instance As ImGearARTPinAlignment
public enum ImGearARTPinAlignment : System.Enum
__value public enum ImGearARTPinAlignment : public System.Enum
public enum class ImGearARTPinAlignment : public System.Enum
Members
Member | Value | Description
LEFT_BOTTOM | 1 | Left bottom alignment.
LEFT_TOP | 0 | Left top alignment.
RIGHT_BOTTOM | 3 | Right bottom alignment.
RIGHT_BOTTON | 3 | Right bottom alignment.
RIGHT_TOP | 2 | Right top alignment.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTPinAlignment

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTSaveType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTSaveType Enumeration
Specifies annotations save formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTSaveType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTSaveType
public enum ImGearARTSaveType : System.Enum
__value public enum ImGearARTSaveType : public System.Enum
public enum class ImGearARTSaveType : public System.Enum
Members
Member | Value | Description
LEGACY | 2 | Legacy ART 2.0 storage format.
WANG | 3 | WANG storage format.
XML | 1 | XML storage format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTSaveType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextAutoFitMode Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextAutoFitMode Enumeration
Specifies auto fit mode for text annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearARTTextAutoFitMode
   Inherits System.Enum
'Usage

Dim instance As ImGearARTTextAutoFitMode
[Flags()]
public enum ImGearARTTextAutoFitMode : System.Enum
[Flags()]
__value public enum ImGearARTTextAutoFitMode : public System.Enum
[Flags()]
public enum class ImGearARTTextAutoFitMode : public System.Enum
Members
Member | Value | Description
AdjustHeight | 0x00000001 | Text annotation's height will be automatically adjusted to fit the text within the annotation.
AdjustWidth | 0x00000002 | Text annotation's width will be automatically adjusted to fit the widest text line within the annotation.
None | 0x00000000 | No adjustment of text annotation's dimensions is required.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTTextAutoFitMode

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextTrimming Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextTrimming Enumeration
Describes how text is trimmed when it overflows the bounds of annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTTextTrimming
   Inherits System.Enum
'Usage

Dim instance As ImGearARTTextTrimming
public enum ImGearARTTextTrimming : System.Enum
__value public enum ImGearARTTextTrimming : public System.Enum
public enum class ImGearARTTextTrimming : public System.Enum
Members
Member | Value | Description
None | 0 | Text is not trimmed.
WordEllipsis | 1 | Text is trimmed at a word boundary. An ellipsis (...) is drawn in place of remaining text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTTextTrimming

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTTextType Enumeration

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTTextType Enumeration
Specifies a type of string in the text mark's "Text" property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTTextType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTTextType
public enum ImGearARTTextType : System.Enum
__value public enum ImGearARTTextType : public System.Enum
public enum class ImGearARTTextType : public System.Enum
Members
Member | Value | Description
DIRECT_TEXT | 0 | Text is stored directly in the mark.
FILE_NAME | 1 | Text is stored in the file specified by mark's "Text" property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.ImGearARTTextType

See Also

Reference

ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTLoadEvents Structure
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLoadEvents Structure
Contains fields that can be used to pass event delegates to LoadPage method of the ImGearART.
Object Model
ImGearARTLoadEvents Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearARTLoadEvents
   Inherits System.ValueType
'Usage

Dim instance As ImGearARTLoadEvents
public struct ImGearARTLoadEvents : System.ValueType
public __value struct ImGearARTLoadEvents : public System.ValueType
public value class ImGearARTLoadEvents : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.ART.ImGearARTLoadEvents

See Also

Reference

ImGearARTLoadEvents Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTLoadEvents Structure Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLoadEvents Structure

The following tables list the members exposed by ImGearARTLoadEvents.

Public Properties
 | Name | Description
Public Property | CreateSecureObjectData | Gets or sets the CreateSecureObjectData event handler.
Public Property | CreatingGroup | Gets or sets the event handler that handles CreatingGroup event.
Public Property | CreatingMark | Gets or sets the event handler that handles CreatingMark event.
Public Property | CreatingPage | Gets or sets the event handler that handles CreatingPage event.
Public Property | DroppedAttribute | Gets or sets the event handler that handles DroppedAttribute event.
Public Property | DroppedMark | Gets or sets the event handler that handles DroppedMark event.
Public Property | GetNotateXpressLayerPassword | Gets or sets the GetLayerPassword event handler.
Top
See Also

Reference

ImGearARTLoadEvents Structure
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTLoadEvents Structure Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTLoadEvents Structure

For a list of all members of this type, see ImGearARTLoadEvents members.

Public Properties
 | Name | Description
Public Property | CreateSecureObjectData | Gets or sets the CreateSecureObjectData event handler.
Public Property | CreatingGroup | Gets or sets the event handler that handles CreatingGroup event.
Public Property | CreatingMark | Gets or sets the event handler that handles CreatingMark event.
Public Property | CreatingPage | Gets or sets the event handler that handles CreatingPage event.
Public Property | DroppedAttribute | Gets or sets the event handler that handles DroppedAttribute event.
Public Property | DroppedMark | Gets or sets the event handler that handles DroppedMark event.
Public Property | GetNotateXpressLayerPassword | Gets or sets the GetLayerPassword event handler.
Top
See Also

Reference

ImGearARTLoadEvents Structure
ImageGear.ART Namespace


CreateSecureObjectData Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : CreateSecureObjectData Property
Gets or sets the CreateSecureObjectData event handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreateSecureObjectData As EventHandler(Of ImGearARTCreateSecureObjectDataEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTCreateSecureObjectDataEventArgs)

instance.CreateSecureObjectData = value

value = instance.CreateSecureObjectData
public EventHandler<ImGearARTCreateSecureObjectDataEventArgs> CreateSecureObjectData {get; set;}
public: __property EventHandler<ImGearARTCreateSecureObjectDataEventArgs*>* get_CreateSecureObjectData();
public: __property void set_CreateSecureObjectData(
   EventHandler<ImGearARTCreateSecureObjectDataEventArgs*>* value
);
public:
property EventHandler<ImGearARTCreateSecureObjectDataEventArgs^>^ CreateSecureObjectData {
   EventHandler<ImGearARTCreateSecureObjectDataEventArgs^>^ get();
   void set (    EventHandler<ImGearARTCreateSecureObjectDataEventArgs^>^ value);
}

Property Value

EventHandler value.
Remarks
The event is sent if the loaded Art object contains SecureObjectData.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTCreateSecureObjectDataEventArgs Class
ImGearARTSecureObjectData Class


CreatingGroup Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : CreatingGroup Property
Gets or sets the event handler that handles CreatingGroup event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatingGroup As EventHandler(Of ImGearARTCreatingGroupEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTCreatingGroupEventArgs)

instance.CreatingGroup = value

value = instance.CreatingGroup
public EventHandler<ImGearARTCreatingGroupEventArgs> CreatingGroup {get; set;}
public: __property EventHandler<ImGearARTCreatingGroupEventArgs*>* get_CreatingGroup();
public: __property void set_CreatingGroup(
   EventHandler<ImGearARTCreatingGroupEventArgs*>* value
);
public:
property EventHandler<ImGearARTCreatingGroupEventArgs^>^ CreatingGroup {
   EventHandler<ImGearARTCreatingGroupEventArgs^>^ get();
   void set (    EventHandler<ImGearARTCreatingGroupEventArgs^>^ value);
}

Property Value

EventHandler value.
Remarks
The event is called before adding group object to ImGearARTPage.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTCreatingGroupEventArgs Class


CreatingMark Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : CreatingMark Property
Gets or sets the event handler that handles CreatingMark event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatingMark As EventHandler(Of ImGearARTCreatingMarkEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTCreatingMarkEventArgs)

instance.CreatingMark = value

value = instance.CreatingMark
public EventHandler<ImGearARTCreatingMarkEventArgs> CreatingMark {get; set;}
public: __property EventHandler<ImGearARTCreatingMarkEventArgs*>* get_CreatingMark();
public: __property void set_CreatingMark(
   EventHandler<ImGearARTCreatingMarkEventArgs*>* value
);
public:
property EventHandler<ImGearARTCreatingMarkEventArgs^>^ CreatingMark {
   EventHandler<ImGearARTCreatingMarkEventArgs^>^ get();
   void set (    EventHandler<ImGearARTCreatingMarkEventArgs^>^ value);
}

Property Value

EventHandler value.
Remarks
The event is called before adding mark object to ImGearARTPage.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTCreatingMarkEventArgs Class


CreatingPage Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : CreatingPage Property
Gets or sets the event handler that handles CreatingPage event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatingPage As EventHandler(Of ImGearARTCreatingPageEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTCreatingPageEventArgs)

instance.CreatingPage = value

value = instance.CreatingPage
public EventHandler<ImGearARTCreatingPageEventArgs> CreatingPage {get; set;}
public: __property EventHandler<ImGearARTCreatingPageEventArgs*>* get_CreatingPage();
public: __property void set_CreatingPage(
   EventHandler<ImGearARTCreatingPageEventArgs*>* value
);
public:
property EventHandler<ImGearARTCreatingPageEventArgs^>^ CreatingPage {
   EventHandler<ImGearARTCreatingPageEventArgs^>^ get();
   void set (    EventHandler<ImGearARTCreatingPageEventArgs^>^ value);
}

Property Value

EventHandler value.
Remarks
The event is called before returning a constructed Art Page object.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTCreatingPageEventArgs Class


DroppedAttribute Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : DroppedAttribute Property
Gets or sets the event handler that handles DroppedAttribute event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DroppedAttribute As EventHandler(Of ImGearARTDroppedAttributeEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTDroppedAttributeEventArgs)

instance.DroppedAttribute = value

value = instance.DroppedAttribute
public EventHandler<ImGearARTDroppedAttributeEventArgs> DroppedAttribute {get; set;}
public: __property EventHandler<ImGearARTDroppedAttributeEventArgs*>* get_DroppedAttribute();
public: __property void set_DroppedAttribute(
   EventHandler<ImGearARTDroppedAttributeEventArgs*>* value
);
public:
property EventHandler<ImGearARTDroppedAttributeEventArgs^>^ DroppedAttribute {
   EventHandler<ImGearARTDroppedAttributeEventArgs^>^ get();
   void set (    EventHandler<ImGearARTDroppedAttributeEventArgs^>^ value);
}

Property Value

EventHandler value.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTDroppedAttributeEventArgs Class


DroppedMark Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : DroppedMark Property
Gets or sets the event handler that handles DroppedMark event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DroppedMark As EventHandler(Of ImGearARTDroppedMarkEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTDroppedMarkEventArgs)

instance.DroppedMark = value

value = instance.DroppedMark
public EventHandler<ImGearARTDroppedMarkEventArgs> DroppedMark {get; set;}
public: __property EventHandler<ImGearARTDroppedMarkEventArgs*>* get_DroppedMark();
public: __property void set_DroppedMark(
   EventHandler<ImGearARTDroppedMarkEventArgs*>* value
);
public:
property EventHandler<ImGearARTDroppedMarkEventArgs^>^ DroppedMark {
   EventHandler<ImGearARTDroppedMarkEventArgs^>^ get();
   void set (    EventHandler<ImGearARTDroppedMarkEventArgs^>^ value);
}

Property Value

EventHandler value.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTDroppedMarkEventArgs Class


GetNotateXpressLayerPassword Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTLoadEvents Structure : GetNotateXpressLayerPassword Property
Gets or sets the GetLayerPassword event handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GetNotateXpressLayerPassword As EventHandler(Of ImGearARTGetNotateXpressLayerPasswordEventArgs)
'Usage

Dim instance As ImGearARTLoadEvents
Dim value As EventHandler(Of ImGearARTGetNotateXpressLayerPasswordEventArgs)

instance.GetNotateXpressLayerPassword = value

value = instance.GetNotateXpressLayerPassword
public EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs> GetNotateXpressLayerPassword {get; set;}
public: __property EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs*>* get_GetNotateXpressLayerPassword();
public: __property void set_GetNotateXpressLayerPassword(
   EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs*>* value
);
public:
property EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs^>^ GetNotateXpressLayerPassword {
   EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs^>^ get();
   void set (    EventHandler<ImGearARTGetNotateXpressLayerPasswordEventArgs^>^ value);
}

Property Value

EventHandler value.
Remarks
The GetLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.
See Also

Reference

ImGearARTLoadEvents Structure
ImGearARTLoadEvents Members
ImGearARTGetNotateXpressLayerPasswordEventArgs Class


%%PageItemTitle%%

ImGearARTMeasurementUnit Structure
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMeasurementUnit Structure
Represents a measurement unit, such as Meter, Inch etc.
Object Model
ImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit StructureImGearARTMeasurementUnit Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearARTMeasurementUnit
   Inherits System.ValueType
'Usage

Dim instance As ImGearARTMeasurementUnit
public struct ImGearARTMeasurementUnit : System.ValueType
public __value struct ImGearARTMeasurementUnit : public System.ValueType
public value class ImGearARTMeasurementUnit : public System.ValueType
Remarks
Measurement unit is defined by its name, abbreviation, and aspect values. Several most commonly used measurement units are available as static properties.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.ART.ImGearARTMeasurementUnit

See Also

Reference

ImGearARTMeasurementUnit Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMeasurementUnit Structure Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMeasurementUnit Structure

The following tables list the members exposed by ImGearARTMeasurementUnit.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTMeasurementUnit Constructor | Initializes a new instance of the ImGearARTMeasurementUnit struct.
Top
Public Properties
 | Name | Description
Public Property | Abbreviation | Gets an abbreviation of the unit.
Public Property | AspectDenominator | Gets a denominator value, relative to PPM.
Public Property | AspectNumerator | Gets a numerator value, relative to PPM.
static (Shared in Visual Basic) | Centimeter | Gets a predefined Centimeter measurement unit.
static (Shared in Visual Basic) | Decimeter | Gets a predefined Decimeter measurement unit.
static (Shared in Visual Basic) | Dekameter | Gets a predefined Dekameter measurement unit.
static (Shared in Visual Basic) | Foot | Gets a predefined Foot measurement unit.
static (Shared in Visual Basic) | Inch | Gets a predefined Inch measurement unit.
static (Shared in Visual Basic) | Kilometer | Gets a predefined Kilometer measurement unit.
static (Shared in Visual Basic) | Meter | Gets a predefined Meter measurement unit.
static (Shared in Visual Basic) | Micrometer | Gets a predefined Micrometer measurement unit.
static (Shared in Visual Basic) | Mile | Gets a predefined Mile measurement unit.
static (Shared in Visual Basic) | Millimeter | Gets a predefined Millimeter measurement unit.
Public Property | Name | Gets a full name of the unit.
static (Shared in Visual Basic) | Pixel | Gets a predefined Pixel measurement unit.
static (Shared in Visual Basic) | Twip | Gets a predefined Twips measurement unit.
static (Shared in Visual Basic) | Yard | Gets a predefined Yard measurement unit.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overrides an Equal operator.
static (Shared in Visual Basic) | Find | Finds corresponding to aspectNumerator and aspectDenominator parameters predefined measurement unit, if any. In case of no match returns instance with Name equal to "Custom", empty Abbreviation and Aspect values, initialized from input parameters aspectNumerator and aspectDenominator.
Public Method | GetHashCode | Returns a hash code.
Public Method | ToString | Returns a String that represents the current measurement unit.
Top
Public Operators
public Operator Equality | Returns true if its two operands are equal.
public Operator Inequality | Returns true if its two operands are not equal.
Top
See Also

Reference

ImGearARTMeasurementUnit Structure
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMeasurementUnit Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : ImGearARTMeasurementUnit Constructor
Measurement unit name, such as 'Kilometer'.
Measurement unit abbreviation, such as 'km'.
Measurement unit numerator value, relative to PPM.
Measurement unit denominator value, relative to PPM.
Initializes a new instance of the ImGearARTMeasurementUnit struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal abbreviation As String, _
   ByVal aspectNumerator As Integer, _
   ByVal aspectDenominator As Integer _
)
'Usage

Dim name As String
Dim abbreviation As String
Dim aspectNumerator As Integer
Dim aspectDenominator As Integer

Dim instance As New ImGearARTMeasurementUnit(name, abbreviation, aspectNumerator, aspectDenominator)
public ImGearARTMeasurementUnit(
   string name,
   string abbreviation,
   int aspectNumerator,
   int aspectDenominator
)
public: ImGearARTMeasurementUnit(
   string* name,
   string* abbreviation,
   int aspectNumerator,
   int aspectDenominator
)
public:
ImGearARTMeasurementUnit(
   String^ name,
   String^ abbreviation,
   int aspectNumerator,
   int aspectDenominator
)

Parameters

name
Measurement unit name, such as 'Kilometer'.
abbreviation
Measurement unit abbreviation, such as 'km'.
aspectNumerator
Measurement unit numerator value, relative to PPM.
aspectDenominator
Measurement unit denominator value, relative to PPM.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


%%PageItemTitle%% $$Methods$$

ImGearARTMeasurementUnit Structure Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMeasurementUnit Structure

For a list of all members of this type, see ImGearARTMeasurementUnit members.

Public Methods
 | Name | Description
Public Method | Equals | Overrides an Equal operator.
static (Shared in Visual Basic) | Find | Finds corresponding to aspectNumerator and aspectDenominator parameters predefined measurement unit, if any. In case of no match returns instance with Name equal to "Custom", empty Abbreviation and Aspect values, initialized from input parameters aspectNumerator and aspectDenominator.
Public Method | GetHashCode | Returns a hash code.
Public Method | ToString | Returns a String that represents the current measurement unit.
Top
See Also

Reference

ImGearARTMeasurementUnit Structure
ImageGear.ART Namespace


Equals Method (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Equals Method
An object to compare.
Overrides an Equal operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
public override bool Equals(
   object other
)
public: bool Equals(
   Object* other
) override
public:
bool Equals(
   Object^ other
) override

Parameters

other
An object to compare.

Return Value

True if objects are equal.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Find Method (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Find Method
The aspect numerator to look up.
The aspect denominator to look up.
Finds corresponding to aspectNumerator and aspectDenominator parameters predefined measurement unit, if any. In case of no match returns instance with Name equal to "Custom", empty Abbreviation and Aspect values, initialized from input parameters aspectNumerator and aspectDenominator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Find( _
   ByVal aspectNumerator As Integer, _
   ByVal aspectDenominator As Integer _
) As ImGearARTMeasurementUnit
'Usage

Dim aspectNumerator As Integer
Dim aspectDenominator As Integer
Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Find(aspectNumerator, aspectDenominator)
public static ImGearARTMeasurementUnit Find(
   int aspectNumerator,
   int aspectDenominator
)
public: static ImGearARTMeasurementUnit Find(
   int aspectNumerator,
   int aspectDenominator
)
public:
static ImGearARTMeasurementUnit Find(
   int aspectNumerator,
   int aspectDenominator
)

Parameters

aspectNumerator
The aspect numerator to look up.
aspectDenominator
The aspect denominator to look up.

Return Value

ImGearARTMeasurementUnit instance.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


GetHashCode Method (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : GetHashCode Method
Returns a hash code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

Integer value.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


ToString Method (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : ToString Method
Returns a String that represents the current measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


%%PageItemTitle%% $$Properties$$

ImGearARTMeasurementUnit Structure Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMeasurementUnit Structure

For a list of all members of this type, see ImGearARTMeasurementUnit members.

Public Properties
 | Name | Description
Public Property | Abbreviation | Gets an abbreviation of the unit.
Public Property | AspectDenominator | Gets a denominator value, relative to PPM.
Public Property | AspectNumerator | Gets a numerator value, relative to PPM.
static (Shared in Visual Basic) | Centimeter | Gets a predefined Centimeter measurement unit.
static (Shared in Visual Basic) | Decimeter | Gets a predefined Decimeter measurement unit.
static (Shared in Visual Basic) | Dekameter | Gets a predefined Dekameter measurement unit.
static (Shared in Visual Basic) | Foot | Gets a predefined Foot measurement unit.
static (Shared in Visual Basic) | Inch | Gets a predefined Inch measurement unit.
static (Shared in Visual Basic) | Kilometer | Gets a predefined Kilometer measurement unit.
static (Shared in Visual Basic) | Meter | Gets a predefined Meter measurement unit.
static (Shared in Visual Basic) | Micrometer | Gets a predefined Micrometer measurement unit.
static (Shared in Visual Basic) | Mile | Gets a predefined Mile measurement unit.
static (Shared in Visual Basic) | Millimeter | Gets a predefined Millimeter measurement unit.
Public Property | Name | Gets a full name of the unit.
static (Shared in Visual Basic) | Pixel | Gets a predefined Pixel measurement unit.
static (Shared in Visual Basic) | Twip | Gets a predefined Twips measurement unit.
static (Shared in Visual Basic) | Yard | Gets a predefined Yard measurement unit.
Top
See Also

Reference

ImGearARTMeasurementUnit Structure
ImageGear.ART Namespace


Abbreviation Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Abbreviation Property
Gets an abbreviation of the unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Abbreviation As String
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As String

value = instance.Abbreviation
public string Abbreviation {get;}
public: __property string* get_Abbreviation();
public:
property String^ Abbreviation {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


AspectDenominator Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : AspectDenominator Property
Gets a denominator value, relative to PPM.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AspectDenominator As Integer
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As Integer

value = instance.AspectDenominator
public int AspectDenominator {get;}
public: __property int get_AspectDenominator();
public:
property int AspectDenominator {
   int get();
}

Property Value

Integer value.
Remarks
For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


AspectNumerator Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : AspectNumerator Property
Gets a numerator value, relative to PPM.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AspectNumerator As Integer
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As Integer

value = instance.AspectNumerator
public int AspectNumerator {get;}
public: __property int get_AspectNumerator();
public:
property int AspectNumerator {
   int get();
}

Property Value

Integer value.
Remarks
For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Centimeter Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Centimeter Property
Gets a predefined Centimeter measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Centimeter As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Centimeter
public static ImGearARTMeasurementUnit Centimeter {get;}
public: __property static ImGearARTMeasurementUnit get_Centimeter();
public:
static property ImGearARTMeasurementUnit Centimeter {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Decimeter Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Decimeter Property
Gets a predefined Decimeter measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Decimeter As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Decimeter
public static ImGearARTMeasurementUnit Decimeter {get;}
public: __property static ImGearARTMeasurementUnit get_Decimeter();
public:
static property ImGearARTMeasurementUnit Decimeter {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Dekameter Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Dekameter Property
Gets a predefined Dekameter measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Dekameter As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Dekameter
public static ImGearARTMeasurementUnit Dekameter {get;}
public: __property static ImGearARTMeasurementUnit get_Dekameter();
public:
static property ImGearARTMeasurementUnit Dekameter {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Foot Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Foot Property
Gets a predefined Foot measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Foot As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Foot
public static ImGearARTMeasurementUnit Foot {get;}
public: __property static ImGearARTMeasurementUnit get_Foot();
public:
static property ImGearARTMeasurementUnit Foot {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Inch Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Inch Property
Gets a predefined Inch measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Inch As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Inch
public static ImGearARTMeasurementUnit Inch {get;}
public: __property static ImGearARTMeasurementUnit get_Inch();
public:
static property ImGearARTMeasurementUnit Inch {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Kilometer Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Kilometer Property
Gets a predefined Kilometer measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Kilometer As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Kilometer
public static ImGearARTMeasurementUnit Kilometer {get;}
public: __property static ImGearARTMeasurementUnit get_Kilometer();
public:
static property ImGearARTMeasurementUnit Kilometer {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Meter Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Meter Property
Gets a predefined Meter measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Meter As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Meter
public static ImGearARTMeasurementUnit Meter {get;}
public: __property static ImGearARTMeasurementUnit get_Meter();
public:
static property ImGearARTMeasurementUnit Meter {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Micrometer Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Micrometer Property
Gets a predefined Micrometer measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Micrometer As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Micrometer
public static ImGearARTMeasurementUnit Micrometer {get;}
public: __property static ImGearARTMeasurementUnit get_Micrometer();
public:
static property ImGearARTMeasurementUnit Micrometer {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Mile Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Mile Property
Gets a predefined Mile measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Mile As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Mile
public static ImGearARTMeasurementUnit Mile {get;}
public: __property static ImGearARTMeasurementUnit get_Mile();
public:
static property ImGearARTMeasurementUnit Mile {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Millimeter Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Millimeter Property
Gets a predefined Millimeter measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Millimeter As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Millimeter
public static ImGearARTMeasurementUnit Millimeter {get;}
public: __property static ImGearARTMeasurementUnit get_Millimeter();
public:
static property ImGearARTMeasurementUnit Millimeter {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Name Property (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Name Property
Gets a full name of the unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearARTMeasurementUnit
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Pixel Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Pixel Property
Gets a predefined Pixel measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Pixel As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Pixel
public static ImGearARTMeasurementUnit Pixel {get;}
public: __property static ImGearARTMeasurementUnit get_Pixel();
public:
static property ImGearARTMeasurementUnit Pixel {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Twip Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Twip Property
Gets a predefined Twips measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Twip As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Twip
public static ImGearARTMeasurementUnit Twip {get;}
public: __property static ImGearARTMeasurementUnit get_Twip();
public:
static property ImGearARTMeasurementUnit Twip {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Yard Property

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Yard Property
Gets a predefined Yard measurement unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yard As ImGearARTMeasurementUnit
'Usage

Dim value As ImGearARTMeasurementUnit

value = ImGearARTMeasurementUnit.Yard
public static ImGearARTMeasurementUnit Yard {get;}
public: __property static ImGearARTMeasurementUnit get_Yard();
public:
static property ImGearARTMeasurementUnit Yard {
   ImGearARTMeasurementUnit get();
}

Property Value

ImGearARTMeasurementUnit class object.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Equality Operator (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Equality Operator
First object to compare.
Second object to compare.
Returns true if its two operands are equal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator =( _
   ByVal a As ImGearARTMeasurementUnit, _
   ByVal b As ImGearARTMeasurementUnit _
) As Boolean
'Usage

public bool operator ==(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)
public: bool op_Equality(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)
public:
bool operator ==(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)

Parameters

a
First object to compare.
b
Second object to compare.

Return Value

True if objects are equal.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


Inequality Operator (ImGearARTMeasurementUnit)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTMeasurementUnit Structure : Inequality Operator
First object to compare.
Second object to compare.
Returns true if its two operands are not equal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator <>( _
   ByVal a As ImGearARTMeasurementUnit, _
   ByVal b As ImGearARTMeasurementUnit _
) As Boolean
'Usage

public bool operator !=(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)
public: bool op_Inequality(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)
public:
bool operator !=(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)

Parameters

a
First object to compare.
b
Second object to compare.

Return Value

True if objects are not equal.
See Also

Reference

ImGearARTMeasurementUnit Structure
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

ImGearARTThickness Structure
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTThickness Structure
Specifies the thickness of a rectangular frame.
Object Model
ImGearARTThickness Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearARTThickness
   Inherits System.ValueType
'Usage

Dim instance As ImGearARTThickness
public struct ImGearARTThickness : System.ValueType
public __value struct ImGearARTThickness : public System.ValueType
public value class ImGearARTThickness : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.ART.ImGearARTThickness

See Also

Reference

ImGearARTThickness Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTThickness Structure Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTThickness Structure

The following tables list the members exposed by ImGearARTThickness.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTThickness Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the width, in pixels, of the lower side of the bounding rectangle.
Public Property | Left | Gets or sets the width of the left side of the bounding rectangle.
Public Property | Right | Gets or sets the width of the right side of the bounding rectangle.
Public Property | Top | Gets or sets the width of the upper side of the bounding rectangle.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Compares this ImGearARTThickness structure to another System.Object for equality.
Public Method | GetHashCode | Returns the hash code of the structure.
Top
Public Operators
public Operator Equality | Compares the value of two ImGearARTThickness structures for equality.
public Operator Inequality | Compares two ImGearARTThickness structures for inequality.
Top
See Also

Reference

ImGearARTThickness Structure
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTThickness Constructor

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : ImGearARTThickness Constructor
Overload List
Overload | Description
ImGearARTThickness Constructor(Int32) | Initializes a new instance of the ImGearARTThickness structure that has the specified uniform length on each side.
ImGearARTThickness Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearARTThickness structure that has specific lengths applied to each side of the rectangle.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


%%PageItemTitle%%

ImGearARTThickness Constructor(Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure > ImGearARTThickness Constructor : ImGearARTThickness Constructor(Int32)
The uniform length applied to all four sides of the bounding rectangle.
Initializes a new instance of the ImGearARTThickness structure that has the specified uniform length on each side.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uniformLength As Integer _
)
'Usage

Dim uniformLength As Integer

Dim instance As New ImGearARTThickness(uniformLength)
public ImGearARTThickness(
   int uniformLength
)
public: ImGearARTThickness(
   int uniformLength
)
public:
ImGearARTThickness(
   int uniformLength
)

Parameters

uniformLength
The uniform length applied to all four sides of the bounding rectangle.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members
Overload List


%%PageItemTitle%%

ImGearARTThickness Constructor(Int32,Int32,Int32,Int32)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure > ImGearARTThickness Constructor : ImGearARTThickness Constructor(Int32,Int32,Int32,Int32)
The thickness for the left side of the rectangle.
The thickness for the upper side of the rectangle.
The thickness for the right side of the rectangle.
The thickness for the lower side of the rectangle.
Initializes a new instance of the ImGearARTThickness structure that has specific lengths applied to each side of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim right As Integer
Dim bottom As Integer

Dim instance As New ImGearARTThickness(left, top, right, bottom)
public ImGearARTThickness(
   int left,
   int top,
   int right,
   int bottom
)
public: ImGearARTThickness(
   int left,
   int top,
   int right,
   int bottom
)
public:
ImGearARTThickness(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The thickness for the left side of the rectangle.
top
The thickness for the upper side of the rectangle.
right
The thickness for the right side of the rectangle.
bottom
The thickness for the lower side of the rectangle.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearARTThickness Structure Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTThickness Structure

For a list of all members of this type, see ImGearARTThickness members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Compares this ImGearARTThickness structure to another System.Object for equality.
Public Method | GetHashCode | Returns the hash code of the structure.
Top
See Also

Reference

ImGearARTThickness Structure
ImageGear.ART Namespace


Equals Method (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Equals Method
Compares this ImGearARTThickness structure to another System.Object for equality.
Overload List
Overload | Description
Equals(Object) | Compares this ImGearARTThickness structure to another System.Object for equality.
Equals(ImGearARTThickness) | Compares this ImGearARTThickness structure to another ImGearARTThickness structure for equality.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Equals(Object) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure > Equals Method : Equals(Object) Method
The object to compare.
Compares this ImGearARTThickness structure to another System.Object for equality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As ImGearARTThickness
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The object to compare.

Return Value

Returns true if the two objects are equal; otherwise, false.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members
Overload List


Equals(ImGearARTThickness) Method

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure > Equals Method : Equals(ImGearARTThickness) Method
An instance of ImGearARTThickness to compare for equality.
Compares this ImGearARTThickness structure to another ImGearARTThickness structure for equality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Equals( _
   ByVal t As ImGearARTThickness _
) As Boolean
'Usage

Dim instance As ImGearARTThickness
Dim t As ImGearARTThickness
Dim value As Boolean

value = instance.Equals(t)
public bool Equals(
   ImGearARTThickness t
)
public: bool Equals(
   ImGearARTThickness t
)
public:
bool Equals(
   ImGearARTThickness t
)

Parameters

t
An instance of ImGearARTThickness to compare for equality.

Return Value

Returns true if the two instances of ImGearARTThickness are equal; otherwise, false.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members
Overload List


GetHashCode Method (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : GetHashCode Method
Returns the hash code of the structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As ImGearARTThickness
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

A hash code for this instance of ImGearARTThickness.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


%%PageItemTitle%% $$Properties$$

ImGearARTThickness Structure Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTThickness Structure

For a list of all members of this type, see ImGearARTThickness members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the width, in pixels, of the lower side of the bounding rectangle.
Public Property | Left | Gets or sets the width of the left side of the bounding rectangle.
Public Property | Right | Gets or sets the width of the right side of the bounding rectangle.
Public Property | Top | Gets or sets the width of the upper side of the bounding rectangle.
Top
See Also

Reference

ImGearARTThickness Structure
ImageGear.ART Namespace


Bottom Property (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Bottom Property
Gets or sets the width, in pixels, of the lower side of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bottom As Integer
'Usage

Dim instance As ImGearARTThickness
Dim value As Integer

instance.Bottom = value

value = instance.Bottom
public int Bottom {get; set;}
public: __property int get_Bottom();
public: __property void set_Bottom(
   int value
);
public:
property int Bottom {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Left Property (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Left Property
Gets or sets the width of the left side of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Integer
'Usage

Dim instance As ImGearARTThickness
Dim value As Integer

instance.Left = value

value = instance.Left
public int Left {get; set;}
public: __property int get_Left();
public: __property void set_Left(
   int value
);
public:
property int Left {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Right Property (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Right Property
Gets or sets the width of the right side of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Right As Integer
'Usage

Dim instance As ImGearARTThickness
Dim value As Integer

instance.Right = value

value = instance.Right
public int Right {get; set;}
public: __property int get_Right();
public: __property void set_Right(
   int value
);
public:
property int Right {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default is 0.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Top Property (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Top Property
Gets or sets the width of the upper side of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Integer
'Usage

Dim instance As ImGearARTThickness
Dim value As Integer

instance.Top = value

value = instance.Top
public int Top {get; set;}
public: __property int get_Top();
public: __property void set_Top(
   int value
);
public:
property int Top {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default is 0.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Equality Operator (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Equality Operator
The first structure to compare.
The other structure to compare.
Compares the value of two ImGearARTThickness structures for equality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator =( _
   ByVal t1 As ImGearARTThickness, _
   ByVal t2 As ImGearARTThickness _
) As Boolean
'Usage

public bool operator ==(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)
public: bool op_Equality(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)
public:
bool operator ==(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)

Parameters

t1
The first structure to compare.
t2
The other structure to compare.

Return Value

Returns true if the two instances of ImGearARTThickness are equal; otherwise, false.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


Inequality Operator (ImGearARTThickness)

ImageGear22.Art Assembly > ImageGear.ART Namespace > ImGearARTThickness Structure : Inequality Operator
The first structure to compare.
The other structure to compare.
Compares two ImGearARTThickness structures for inequality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator <>( _
   ByVal t1 As ImGearARTThickness, _
   ByVal t2 As ImGearARTThickness _
) As Boolean
'Usage

public bool operator !=(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)
public: bool op_Inequality(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)
public:
bool operator !=(
   ImGearARTThickness t1,
   ImGearARTThickness t2
)

Parameters

t1
The first structure to compare.
t2
The other structure to compare.

Return Value

Returns true if the two instances of ImGearARTThickness are not equal; otherwise, false.
See Also

Reference

ImGearARTThickness Structure
ImGearARTThickness Members


%%PageItemTitle%%

IImGearARTCurve Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTCurve Interface
Defines ART Curve mark interface.
Object Model
IImGearARTCurve InterfaceIImGearRGBQuad InterfaceImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTCurve
'Usage

Dim instance As IImGearARTCurve
public interface IImGearARTCurve
public __gc __interface IImGearARTCurve
public interface class IImGearARTCurve
See Also

Reference

IImGearARTCurve Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTCurve Interface Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTCurve Interface

The following tables list the members exposed by IImGearARTCurve.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | NumberOfPoints | Gets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | Style | Gets or sets the style of the mark.
Property | Tension | Gets or sets the tension of the curve.
Property | Width | Gets or sets the width of the mark.
Top
Public Methods
 | Name | Description
Method | GetPoint | Gets the point with the specified index.
Method | SetPoint | Sets the point with the specified index.
Top
See Also

Reference

IImGearARTCurve Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTCurve Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTCurve Interface

For a list of all members of this type, see IImGearARTCurve members.

Public Methods
 | Name | Description
Method | GetPoint | Gets the point with the specified index.
Method | SetPoint | Sets the point with the specified index.
Top
See Also

Reference

IImGearARTCurve Interface
ImageGear.ART Namespace


GetPoint Method (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : GetPoint Method
Index of the point.
Gets the point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As IImGearARTCurve
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearPoint Structure


SetPoint Method (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : SetPoint Method
Index of the point.
The point to set.
Sets the point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As IImGearARTCurve
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

IImGearARTCurve Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTCurve Interface

For a list of all members of this type, see IImGearARTCurve members.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | NumberOfPoints | Gets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | Style | Gets or sets the style of the mark.
Property | Tension | Gets or sets the tension of the curve.
Property | Width | Gets or sets the width of the mark.
Top
See Also

Reference

IImGearARTCurve Interface
ImageGear.ART Namespace


CapStyle Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTCurve
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTCurve
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearRGBQuad Structure


NumberOfPoints Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : NumberOfPoints Property
Gets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")>
ReadOnly Property NumberOfPoints As Integer
'Usage

Dim instance As IImGearARTCurve
Dim value As Integer

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
int NumberOfPoints {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
__property int get_NumberOfPoints();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints.Count property instead.")]
property int NumberOfPoints {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


Opacity Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTCurve
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


Points Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")>
ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As IImGearARTCurve
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
__property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTCurve.SelectionPoints property instead.")]
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearPoint Structure


Style Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Style Property
Gets or sets the style of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTCurve
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members
ImGearARTPenStyle Enumeration


Tension Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Tension Property
Gets or sets the tension of the curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Tension As Single
'Usage

Dim instance As IImGearARTCurve
Dim value As Single

instance.Tension = value

value = instance.Tension
float Tension {get; set;}
__property float get_Tension();
__property void set_Tension(
   float value
);
property float Tension {
   float get();
   void set (    float value);
}

Property Value

Float value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


Width Property (IImGearARTCurve)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTCurve Interface : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTCurve
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

IImGearARTEllipse Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTEllipse Interface
Defines ART Ellipse mark interface.
Object Model
IImGearARTEllipse InterfaceImGearARTBorder ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTEllipse
'Usage

Dim instance As IImGearARTEllipse
public interface IImGearARTEllipse
public __gc __interface IImGearARTEllipse
public interface class IImGearARTEllipse
See Also

Reference

IImGearARTEllipse Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTEllipse Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTEllipse Interface

The following tables list the members exposed by IImGearARTEllipse.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the opacity of the mark.
Top
See Also

Reference

IImGearARTEllipse Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTEllipse Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTEllipse Interface

For a list of all members of this type, see IImGearARTEllipse members.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the opacity of the mark.
Top
See Also

Reference

IImGearARTEllipse Interface
ImageGear.ART Namespace


Border Property (IImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTEllipse Interface : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Border As ImGearARTBorder
'Usage

Dim instance As IImGearARTEllipse
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
ImGearARTBorder Border {get; set;}
__property ImGearARTBorder* get_Border();
__property void set_Border(
   ImGearARTBorder* value
);
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members
ImGearARTBorder Class


FillColor Property (IImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTEllipse Interface : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTEllipse
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
IImGearRGBQuad FillColor {get; set;}
__property IImGearRGBQuad* get_FillColor();
__property void set_FillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object.
See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members
ImGearRGBQuad Structure


IsHighlighter Property (IImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTEllipse Interface : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsHighlighter As Boolean
'Usage

Dim instance As IImGearARTEllipse
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
bool IsHighlighter {get; set;}
__property bool get_IsHighlighter();
__property void set_IsHighlighter(
   bool value
);
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


Opacity Property (IImGearARTEllipse)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTEllipse Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTEllipse
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

IImGearARTLine Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTLine Interface
Defines ART Line mark interface.
Object Model
IImGearARTLine InterfaceIImGearRGBQuad InterfaceImGearPoint StructureIImGearRGBQuad InterfaceImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTLine
'Usage

Dim instance As IImGearARTLine
public interface IImGearARTLine
public __gc __interface IImGearARTLine
public interface class IImGearARTLine
See Also

Reference

IImGearARTLine Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTLine Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTLine Interface

The following tables list the members exposed by IImGearARTLine.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the line color.
Property | EndHeadAngle | Gets or sets the angle of the line's end head.
Property | EndHeadLength | Gets or sets the length of the line's end head.
Property | EndHeadType | Gets or sets the type of the line's end head.
Property | EndPoint | Gets or sets the end point of the line.
Property | HeadFillColor | Gets or sets the fill color of the line's head.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the line opacity.
Property | StartHeadAngle | Gets or sets the angle of the line's start head.
Property | StartHeadLength | Gets or sets the length of the line's start head.
Property | StartHeadType | Gets or sets the type of the line's start head.
Property | StartPoint | Gets or sets the start point of the line.
Property | Style | Gets or sets the style of the line.
Property | Width | Gets or sets the line width.
Top
See Also

Reference

IImGearARTLine Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTLine Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTLine Interface

For a list of all members of this type, see IImGearARTLine members.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the line color.
Property | EndHeadAngle | Gets or sets the angle of the line's end head.
Property | EndHeadLength | Gets or sets the length of the line's end head.
Property | EndHeadType | Gets or sets the type of the line's end head.
Property | EndPoint | Gets or sets the end point of the line.
Property | HeadFillColor | Gets or sets the fill color of the line's head.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the line opacity.
Property | StartHeadAngle | Gets or sets the angle of the line's start head.
Property | StartHeadLength | Gets or sets the length of the line's start head.
Property | StartHeadType | Gets or sets the type of the line's start head.
Property | StartPoint | Gets or sets the start point of the line.
Property | Style | Gets or sets the style of the line.
Property | Width | Gets or sets the line width.
Top
See Also

Reference

IImGearARTLine Interface
ImageGear.ART Namespace


CapStyle Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : Color Property
Gets or sets the line color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTLine
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearRGBQuad Structure


EndHeadAngle Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : EndHeadAngle Property
Gets or sets the angle of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadAngle As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.EndHeadAngle = value

value = instance.EndHeadAngle
int EndHeadAngle {get; set;}
__property int get_EndHeadAngle();
__property void set_EndHeadAngle(
   int value
);
property int EndHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


EndHeadLength Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : EndHeadLength Property
Gets or sets the length of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadLength As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.EndHeadLength = value

value = instance.EndHeadLength
int EndHeadLength {get; set;}
__property int get_EndHeadLength();
__property void set_EndHeadLength(
   int value
);
property int EndHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


EndHeadType Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : EndHeadType Property
Gets or sets the type of the line's end head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadType As ImGearARTLineHeadType
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearARTLineHeadType

instance.EndHeadType = value

value = instance.EndHeadType
ImGearARTLineHeadType EndHeadType {get; set;}
__property ImGearARTLineHeadType get_EndHeadType();
__property void set_EndHeadType(
   ImGearARTLineHeadType value
);
property ImGearARTLineHeadType EndHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearARTLineHeadType Enumeration


EndPoint Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : EndPoint Property
Gets or sets the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndPoint As ImGearPoint
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
ImGearPoint EndPoint {get; set;}
__property ImGearPoint get_EndPoint();
__property void set_EndPoint(
   ImGearPoint value
);
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearPoint Structure


HeadFillColor Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : HeadFillColor Property
Gets or sets the fill color of the line's head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HeadFillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTLine
Dim value As IImGearRGBQuad

instance.HeadFillColor = value

value = instance.HeadFillColor
IImGearRGBQuad HeadFillColor {get; set;}
__property IImGearRGBQuad* get_HeadFillColor();
__property void set_HeadFillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ HeadFillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
IImGearRGBQuad Interface


IsHighlighter Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsHighlighter As Boolean
'Usage

Dim instance As IImGearARTLine
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
bool IsHighlighter {get; set;}
__property bool get_IsHighlighter();
__property void set_IsHighlighter(
   bool value
);
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


Opacity Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : Opacity Property
Gets or sets the line opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


StartHeadAngle Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : StartHeadAngle Property
Gets or sets the angle of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadAngle As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.StartHeadAngle = value

value = instance.StartHeadAngle
int StartHeadAngle {get; set;}
__property int get_StartHeadAngle();
__property void set_StartHeadAngle(
   int value
);
property int StartHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


StartHeadLength Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : StartHeadLength Property
Gets or sets the length of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadLength As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.StartHeadLength = value

value = instance.StartHeadLength
int StartHeadLength {get; set;}
__property int get_StartHeadLength();
__property void set_StartHeadLength(
   int value
);
property int StartHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


StartHeadType Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : StartHeadType Property
Gets or sets the type of the line's start head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadType As ImGearARTLineHeadType
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearARTLineHeadType

instance.StartHeadType = value

value = instance.StartHeadType
ImGearARTLineHeadType StartHeadType {get; set;}
__property ImGearARTLineHeadType get_StartHeadType();
__property void set_StartHeadType(
   ImGearARTLineHeadType value
);
property ImGearARTLineHeadType StartHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearARTLineHeadType Enumeration


StartPoint Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : StartPoint Property
Gets or sets the start point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartPoint As ImGearPoint
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
ImGearPoint StartPoint {get; set;}
__property ImGearPoint get_StartPoint();
__property void set_StartPoint(
   ImGearPoint value
);
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearPoint Structure


Style Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : Style Property
Gets or sets the style of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTLine
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members
ImGearARTPenStyle Enumeration


Width Property (IImGearARTLine)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTLine Interface : Width Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTLine
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

IImGearARTMarkIDEnumerable Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerable Interface
Exposes the enumerator, which supports a simple iteration over a collection of annotation marks.
Object Model
IImGearARTMarkIDEnumerable Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTMarkIDEnumerable
'Usage

Dim instance As IImGearARTMarkIDEnumerable
public interface IImGearARTMarkIDEnumerable
public __gc __interface IImGearARTMarkIDEnumerable
public interface class IImGearARTMarkIDEnumerable
See Also

Reference

IImGearARTMarkIDEnumerable Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTMarkIDEnumerable Interface Members
Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerable Interface

The following tables list the members exposed by IImGearARTMarkIDEnumerable.

Public Methods
 | Name | Description
Method | GetEnumerator | Gets the page enumerator.
Top
See Also

Reference

IImGearARTMarkIDEnumerable Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTMarkIDEnumerable Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerable Interface

For a list of all members of this type, see IImGearARTMarkIDEnumerable members.

Public Methods
 | Name | Description
Method | GetEnumerator | Gets the page enumerator.
Top
See Also

Reference

IImGearARTMarkIDEnumerable Interface
ImageGear.ART Namespace


GetEnumerator Method (IImGearARTMarkIDEnumerable)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTMarkIDEnumerable Interface : GetEnumerator Method
Gets the page enumerator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetEnumerator() As IImGearARTMarkIDEnumerator
'Usage

Dim instance As IImGearARTMarkIDEnumerable
Dim value As IImGearARTMarkIDEnumerator

value = instance.GetEnumerator()
IImGearARTMarkIDEnumerator GetEnumerator()
IImGearARTMarkIDEnumerator* GetEnumerator();
IImGearARTMarkIDEnumerator^ GetEnumerator();

Return Value

IImGearARTMarkIDEnumerator class object.
See Also

Reference

IImGearARTMarkIDEnumerable Interface
IImGearARTMarkIDEnumerable Members


%%PageItemTitle%%

IImGearARTMarkIDEnumerator Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerator Interface
Supports a simple iteration over a collection of annotation marks.
Object Model
IImGearARTMarkIDEnumerator Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTMarkIDEnumerator
'Usage

Dim instance As IImGearARTMarkIDEnumerator
public interface IImGearARTMarkIDEnumerator
public __gc __interface IImGearARTMarkIDEnumerator
public interface class IImGearARTMarkIDEnumerator
See Also

Reference

IImGearARTMarkIDEnumerator Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTMarkIDEnumerator Interface Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerator Interface

The following tables list the members exposed by IImGearARTMarkIDEnumerator.

See Also

Reference

IImGearARTMarkIDEnumerator Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTMarkIDEnumerator Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerator Interface

For a list of all members of this type, see IImGearARTMarkIDEnumerator members.

See Also

Reference

IImGearARTMarkIDEnumerator Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTMarkIDEnumerator Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTMarkIDEnumerator Interface

For a list of all members of this type, see IImGearARTMarkIDEnumerator members.

See Also

Reference

IImGearARTMarkIDEnumerator Interface
ImageGear.ART Namespace


%%PageItemTitle%%

IImGearARTPoint Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPoint Interface
Defines ART Point mark interface.
Object Model
IImGearARTPoint InterfaceIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTPoint
'Usage

Dim instance As IImGearARTPoint
public interface IImGearARTPoint
public __gc __interface IImGearARTPoint
public interface class IImGearARTPoint
See Also

Reference

IImGearARTPoint Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTPoint Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPoint Interface

The following tables list the members exposed by IImGearARTPoint.

Public Properties
 | Name | Description
Property | Color | Gets or sets the color of the mark.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Width | Gets or sets the width of the mark.
Property | X | Gets or sets the X coordinate of the mark.
Property | Y | Gets or sets the Y coordinate of the mark.
Top
See Also

Reference

IImGearARTPoint Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTPoint Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPoint Interface

For a list of all members of this type, see IImGearARTPoint members.

Public Properties
 | Name | Description
Property | Color | Gets or sets the color of the mark.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Width | Gets or sets the width of the mark.
Property | X | Gets or sets the X coordinate of the mark.
Property | Y | Gets or sets the Y coordinate of the mark.
Top
See Also

Reference

IImGearARTPoint Interface
ImageGear.ART Namespace


Color Property (IImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPoint Interface : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPoint
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure.
See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members
IImGearRGBQuad Interface


Opacity Property (IImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPoint Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTPoint
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Any integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


Width Property (IImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPoint Interface : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTPoint
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


X Property (IImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPoint Interface : X Property
Gets or sets the X coordinate of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property X As Integer
'Usage

Dim instance As IImGearARTPoint
Dim value As Integer

instance.X = value

value = instance.X
int X {get; set;}
__property int get_X();
__property void set_X(
   int value
);
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


Y Property (IImGearARTPoint)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPoint Interface : Y Property
Gets or sets the Y coordinate of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Y As Integer
'Usage

Dim instance As IImGearARTPoint
Dim value As Integer

instance.Y = value

value = instance.Y
int Y {get; set;}
__property int get_Y();
__property void set_Y(
   int value
);
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

IImGearARTPolygon Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolygon Interface
Defines ART Polygon mark interface.
Object Model
IImGearARTPolygon InterfaceImGearARTBorder ClassIImGearRGBQuad InterfaceImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTPolygon
'Usage

Dim instance As IImGearARTPolygon
public interface IImGearARTPolygon
public __gc __interface IImGearARTPolygon
public interface class IImGearARTPolygon
See Also

Reference

IImGearARTPolygon Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTPolygon Interface Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolygon Interface

The following tables list the members exposed by IImGearARTPolygon.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FillRule | Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | NumberOfPoints | Gets or sets the actual number of points on the mark.
Property | Opacity | Gets or sets the mark opacity.
Property | Points | Gets the raw points array.
Top
Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolygon Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTPolygon Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolygon Interface

For a list of all members of this type, see IImGearARTPolygon members.

Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolygon Interface
ImageGear.ART Namespace


GetPoint Method (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : GetPoint Method
The index of the point to get.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As IImGearARTPolygon
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)

Parameters

index
The index of the point to get.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
ImGearPoint Structure


SetPoint Method (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As IImGearARTPolygon
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

IImGearARTPolygon Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolygon Interface

For a list of all members of this type, see IImGearARTPolygon members.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FillRule | Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | NumberOfPoints | Gets or sets the actual number of points on the mark.
Property | Opacity | Gets or sets the mark opacity.
Property | Points | Gets the raw points array.
Top
See Also

Reference

IImGearARTPolygon Interface
ImageGear.ART Namespace


Border Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Border As ImGearARTBorder
'Usage

Dim instance As IImGearARTPolygon
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
ImGearARTBorder Border {get; set;}
__property ImGearARTBorder* get_Border();
__property void set_Border(
   ImGearARTBorder* value
);
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
ImGearARTBorder Class


FillColor Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPolygon
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
IImGearRGBQuad FillColor {get; set;}
__property IImGearRGBQuad* get_FillColor();
__property void set_FillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
IImGearRGBQuad Interface


FillRule Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : FillRule Property
Gets or sets a ImGearARTFillRule enumeration that specifies how the interior fill of the polygon is determined.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillRule As ImGearARTFillRule
'Usage

Dim instance As IImGearARTPolygon
Dim value As ImGearARTFillRule

instance.FillRule = value

value = instance.FillRule
ImGearARTFillRule FillRule {get; set;}
__property ImGearARTFillRule get_FillRule();
__property void set_FillRule(
   ImGearARTFillRule value
);
property ImGearARTFillRule FillRule {
   ImGearARTFillRule get();
   void set (    ImGearARTFillRule value);
}

Property Value

ImGearARTFillRule enumeration value.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


IsHighlighter Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsHighlighter As Boolean
'Usage

Dim instance As IImGearARTPolygon
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
bool IsHighlighter {get; set;}
__property bool get_IsHighlighter();
__property void set_IsHighlighter(
   bool value
);
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


NumberOfPoints Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : NumberOfPoints Property
Gets or sets the actual number of points on the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")>
Property NumberOfPoints As Integer
'Usage

Dim instance As IImGearARTPolygon
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
__property int get_NumberOfPoints();
__property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints.Count property instead.")]
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
ImGearPoint Structure


Opacity Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : Opacity Property
Gets or sets the mark opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTPolygon
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


Points Property (IImGearARTPolygon)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolygon Interface : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")>
ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As IImGearARTPolygon
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
__property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolygon.SelectionPoints property instead.")]
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members
ImGearPoint Structure


%%PageItemTitle%%

IImGearARTPolyline Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyline Interface
Defines ART Polyline mark interface.
Object Model
IImGearARTPolyline InterfaceIImGearRGBQuad InterfaceImGearPoint StructureIImGearRGBQuad InterfaceImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTPolyline
'Usage

Dim instance As IImGearARTPolyline
public interface IImGearARTPolyline
public __gc __interface IImGearARTPolyline
public interface class IImGearARTPolyline
See Also

Reference

IImGearARTPolyline Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTPolyline Interface Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyline Interface

The following tables list the members exposed by IImGearARTPolyline.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndHeadAngle | Gets or sets the end head angle of the mark.
Property | EndHeadLength | Gets or sets the end head length of the mark.
Property | EndHeadType | Gets or sets the end head type of the mark.
Property | HeadFillColor | Gets or sets the fill color of the line's head.
Property | IsClosed | Gets or sets a value indicating whether the polyline is closed.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | StartHeadAngle | Gets or sets the start head angle of the mark.
Property | StartHeadLength | Gets or sets the start head length of the mark.
Property | StartHeadType | Gets or sets the start head type of the mark.
Property | Style | Gets or sets the style of the mark.
Property | Width | Gets or sets the width of the mark.
Top
Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolyline Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTPolyline Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyline Interface

For a list of all members of this type, see IImGearARTPolyline members.

Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolyline Interface
ImageGear.ART Namespace


GetPoint Method (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : GetPoint Method
Index of the point.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As IImGearARTPolyline
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearPoint Structure


SetPoint Method (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As IImGearARTPolyline
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

IImGearARTPolyline Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyline Interface

For a list of all members of this type, see IImGearARTPolyline members.

Public Properties
 | Name | Description
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndHeadAngle | Gets or sets the end head angle of the mark.
Property | EndHeadLength | Gets or sets the end head length of the mark.
Property | EndHeadType | Gets or sets the end head type of the mark.
Property | HeadFillColor | Gets or sets the fill color of the line's head.
Property | IsClosed | Gets or sets a value indicating whether the polyline is closed.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | StartHeadAngle | Gets or sets the start head angle of the mark.
Property | StartHeadLength | Gets or sets the start head length of the mark.
Property | StartHeadType | Gets or sets the start head type of the mark.
Property | Style | Gets or sets the style of the mark.
Property | Width | Gets or sets the width of the mark.
Top
See Also

Reference

IImGearARTPolyline Interface
ImageGear.ART Namespace


CapStyle Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTPolyline
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPolyline
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
IImGearRGBQuad Interface


EndHeadAngle Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : EndHeadAngle Property
Gets or sets the end head angle of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadAngle As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.EndHeadAngle = value

value = instance.EndHeadAngle
int EndHeadAngle {get; set;}
__property int get_EndHeadAngle();
__property void set_EndHeadAngle(
   int value
);
property int EndHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


EndHeadLength Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : EndHeadLength Property
Gets or sets the end head length of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadLength As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.EndHeadLength = value

value = instance.EndHeadLength
int EndHeadLength {get; set;}
__property int get_EndHeadLength();
__property void set_EndHeadLength(
   int value
);
property int EndHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


EndHeadType Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : EndHeadType Property
Gets or sets the end head type of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndHeadType As ImGearARTLineHeadType
'Usage

Dim instance As IImGearARTPolyline
Dim value As ImGearARTLineHeadType

instance.EndHeadType = value

value = instance.EndHeadType
ImGearARTLineHeadType EndHeadType {get; set;}
__property ImGearARTLineHeadType get_EndHeadType();
__property void set_EndHeadType(
   ImGearARTLineHeadType value
);
property ImGearARTLineHeadType EndHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearARTLineHeadType Enumeration


HeadFillColor Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : HeadFillColor Property
Gets or sets the fill color of the line's head.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HeadFillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPolyline
Dim value As IImGearRGBQuad

instance.HeadFillColor = value

value = instance.HeadFillColor
IImGearRGBQuad HeadFillColor {get; set;}
__property IImGearRGBQuad* get_HeadFillColor();
__property void set_HeadFillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ HeadFillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
IImGearRGBQuad Interface


IsClosed Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : IsClosed Property
Gets or sets a value indicating whether the polyline is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsClosed As Boolean
'Usage

Dim instance As IImGearARTPolyline
Dim value As Boolean

instance.IsClosed = value

value = instance.IsClosed
bool IsClosed {get; set;}
__property bool get_IsClosed();
__property void set_IsClosed(
   bool value
);
property bool IsClosed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


IsHighlighter Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsHighlighter As Boolean
'Usage

Dim instance As IImGearARTPolyline
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
bool IsHighlighter {get; set;}
__property bool get_IsHighlighter();
__property void set_IsHighlighter(
   bool value
);
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


JoinStyle Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As IImGearARTPolyline
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
ImGearARTJoinStyle JoinStyle {get; set;}
__property ImGearARTJoinStyle get_JoinStyle();
__property void set_JoinStyle(
   ImGearARTJoinStyle value
);
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearARTJoinStyle Enumeration


NumberOfPoints Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : NumberOfPoints Property
Gets or sets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")>
Property NumberOfPoints As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
__property int get_NumberOfPoints();
__property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints.Count property instead.")]
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


Opacity Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


Points Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")>
ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As IImGearARTPolyline
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
__property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyline.SelectionPoints property instead.")]
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearPoint Structure


StartHeadAngle Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : StartHeadAngle Property
Gets or sets the start head angle of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadAngle As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.StartHeadAngle = value

value = instance.StartHeadAngle
int StartHeadAngle {get; set;}
__property int get_StartHeadAngle();
__property void set_StartHeadAngle(
   int value
);
property int StartHeadAngle {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


StartHeadLength Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : StartHeadLength Property
Gets or sets the start head length of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadLength As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.StartHeadLength = value

value = instance.StartHeadLength
int StartHeadLength {get; set;}
__property int get_StartHeadLength();
__property void set_StartHeadLength(
   int value
);
property int StartHeadLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


StartHeadType Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : StartHeadType Property
Gets or sets the start head type of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartHeadType As ImGearARTLineHeadType
'Usage

Dim instance As IImGearARTPolyline
Dim value As ImGearARTLineHeadType

instance.StartHeadType = value

value = instance.StartHeadType
ImGearARTLineHeadType StartHeadType {get; set;}
__property ImGearARTLineHeadType get_StartHeadType();
__property void set_StartHeadType(
   ImGearARTLineHeadType value
);
property ImGearARTLineHeadType StartHeadType {
   ImGearARTLineHeadType get();
   void set (    ImGearARTLineHeadType value);
}

Property Value

ImGearARTLineHeadType enumeration value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearARTLineHeadType Enumeration


Style Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : Style Property
Gets or sets the style of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTPolyline
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members
ImGearARTPenStyle Enumeration


Width Property (IImGearARTPolyline)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyline Interface : Width Property
Gets or sets the width of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTPolyline
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

IImGearARTPolyRuler Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyRuler Interface
Defines ART Polyline Ruler mark interface.
Object Model
IImGearARTPolyRuler InterfaceIImGearRGBQuad InterfaceImGearPoint StructureImGearARTMeasurementUnit StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTPolyRuler
'Usage

Dim instance As IImGearARTPolyRuler
public interface IImGearARTPolyRuler
public __gc __interface IImGearARTPolyRuler
public interface class IImGearARTPolyRuler
See Also

Reference

IImGearARTPolyRuler Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTPolyRuler Interface Members
Properties Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyRuler Interface

The following tables list the members exposed by IImGearARTPolyRuler.

Public Properties
 | Name | Description
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndLineLength | Gets or sets the length of the mark's end line.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | Label | Gets or sets the mark label.
Property | Length | Gets the length of the PolyRuler mark.
Property | MeasurementUnit | Gets or sets the measurement unit of the PolyRuler.
Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartLineLength | Gets or sets the length of the mark's start line.
Property | Style | Gets or sets the mark's line style.
Property | Width | Gets or sets the mark's line width.
Top
Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolyRuler Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

IImGearARTPolyRuler Interface Methods

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyRuler Interface

For a list of all members of this type, see IImGearARTPolyRuler members.

Public Methods
 | Name | Description
Method | GetPoint | Gets mark's point with the specified index.
Method | SetPoint | Sets mark's point at the specified index.
Top
See Also

Reference

IImGearARTPolyRuler Interface
ImageGear.ART Namespace


GetPoint Method (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : GetPoint Method
Index of the point.
Gets mark's point with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetPoint( _
   ByVal index As Integer _
) As ImGearPoint
'Usage

Dim instance As IImGearARTPolyRuler
Dim index As Integer
Dim value As ImGearPoint

value = instance.GetPoint(index)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)
ImGearPoint GetPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearPoint Structure


SetPoint Method (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : SetPoint Method
Index of the point.
The point to set.
Sets mark's point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearPoint _
)
'Usage

Dim instance As IImGearARTPolyRuler
Dim index As Integer
Dim point As ImGearPoint

instance.SetPoint(index, point)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)
void SetPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

IImGearARTPolyRuler Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPolyRuler Interface

For a list of all members of this type, see IImGearARTPolyRuler members.

Public Properties
 | Name | Description
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndLineLength | Gets or sets the length of the mark's end line.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | Label | Gets or sets the mark label.
Property | Length | Gets the length of the PolyRuler mark.
Property | MeasurementUnit | Gets or sets the measurement unit of the PolyRuler.
Property | NumberOfPoints | Gets or sets the actual number of mark's points.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Points | Gets the raw points array.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartLineLength | Gets or sets the length of the mark's start line.
Property | Style | Gets or sets the mark's line style.
Property | Width | Gets or sets the mark's line width.
Top
See Also

Reference

IImGearARTPolyRuler Interface
ImageGear.ART Namespace


AspectDenominatorX Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorX As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
int AspectDenominatorX {get; set;}
__property int get_AspectDenominatorX();
__property void set_AspectDenominatorX(
   int value
);
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


AspectDenominatorY Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorY As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
int AspectDenominatorY {get; set;}
__property int get_AspectDenominatorY();
__property void set_AspectDenominatorY(
   int value
);
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


AspectNumeratorX Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorX As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
int AspectNumeratorX {get; set;}
__property int get_AspectNumeratorX();
__property void set_AspectNumeratorX(
   int value
);
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


AspectNumeratorY Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorY As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
int AspectNumeratorY {get; set;}
__property int get_AspectNumeratorY();
__property void set_AspectNumeratorY(
   int value
);
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


CapStyle Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
IImGearRGBQuad Interface


EndLineLength Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : EndLineLength Property
Gets or sets the length of the mark's end line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndLineLength As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.EndLineLength = value

value = instance.EndLineLength
int EndLineLength {get; set;}
__property int get_EndLineLength();
__property void set_EndLineLength(
   int value
);
property int EndLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


FontDisablePPM Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontDisablePPM As Boolean
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
bool FontDisablePPM {get; set;}
__property bool get_FontDisablePPM();
__property void set_FontDisablePPM(
   bool value
);
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


FontName Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontName As String
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As String

instance.FontName = value

value = instance.FontName
string FontName {get; set;}
__property string* get_FontName();
__property void set_FontName(
   string* value
);
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


FontSize Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontSize As Single
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Single

instance.FontSize = value

value = instance.FontSize
float FontSize {get; set;}
__property float get_FontSize();
__property void set_FontSize(
   float value
);
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


FontStyleART Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
ImGearARTFontStyles FontStyleART {get; set;}
__property ImGearARTFontStyles get_FontStyleART();
__property void set_FontStyleART(
   ImGearARTFontStyles value
);
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


IsLabelVisible Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : IsLabelVisible Property
Gets or sets a value indicating whether the label is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsLabelVisible As Boolean
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
bool IsLabelVisible {get; set;}
__property bool get_IsLabelVisible();
__property void set_IsLabelVisible(
   bool value
);
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean variable.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


JoinStyle Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
ImGearARTJoinStyle JoinStyle {get; set;}
__property ImGearARTJoinStyle get_JoinStyle();
__property void set_JoinStyle(
   ImGearARTJoinStyle value
);
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearARTJoinStyle Enumeration


Label Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Label Property
Gets or sets the mark label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Label As String
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As String

instance.Label = value

value = instance.Label
string Label {get; set;}
__property string* get_Label();
__property void set_Label(
   string* value
);
property String^ Label {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


Length Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Length Property
Gets the length of the PolyRuler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Length As Double
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Double

value = instance.Length
double Length {get;}
__property double get_Length();
property double Length {
   double get();
}

Property Value

Double value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


MeasurementUnit Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : MeasurementUnit Property
Gets or sets the measurement unit of the PolyRuler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property MeasurementUnit As ImGearARTMeasurementUnit
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As ImGearARTMeasurementUnit

instance.MeasurementUnit = value

value = instance.MeasurementUnit
ImGearARTMeasurementUnit MeasurementUnit {get; set;}
__property ImGearARTMeasurementUnit get_MeasurementUnit();
__property void set_MeasurementUnit(
   ImGearARTMeasurementUnit value
);
property ImGearARTMeasurementUnit MeasurementUnit {
   ImGearARTMeasurementUnit get();
   void set (    ImGearARTMeasurementUnit value);
}

Property Value

ImGearARTMeasurementUnit value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


NumberOfPoints Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : NumberOfPoints Property
Gets or sets the actual number of mark's points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")>
Property NumberOfPoints As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.NumberOfPoints = value

value = instance.NumberOfPoints
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
int NumberOfPoints {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
__property int get_NumberOfPoints();
__property void set_NumberOfPoints(
   int value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints.Count property instead.")]
property int NumberOfPoints {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


Opacity Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


Points Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Points Property
Gets the raw points array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")>
ReadOnly Property Points As ImGearPoint()
'Usage

Dim instance As IImGearARTPolyRuler
Dim value() As ImGearPoint

value = instance.Points
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
ImGearPoint[] Points {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
__property ImGearPoint[]* get_Points();
[Obsolete("This property is deprecated and will be removed from the public API in a future release. Please use the ImGearARTPolyRuler.SelectionPoints property instead.")]
property array<ImGearPoint>^ Points {
   array<ImGearPoint>^ get();
}

Property Value

ImageGear.Core.ImGearPoint structure array.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearPoint Structure


Precision Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Precision As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.Precision = value

value = instance.Precision
int Precision {get; set;}
__property int get_Precision();
__property void set_Precision(
   int value
);
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


StartLineLength Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : StartLineLength Property
Gets or sets the length of the mark's start line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartLineLength As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.StartLineLength = value

value = instance.StartLineLength
int StartLineLength {get; set;}
__property int get_StartLineLength();
__property void set_StartLineLength(
   int value
);
property int StartLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


Style Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Style Property
Gets or sets the mark's line style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members
ImGearARTPenStyle Enumeration


Width Property (IImGearARTPolyRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPolyRuler Interface : Width Property
Gets or sets the mark's line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTPolyRuler
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

IImGearARTPopupText Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPopupText Interface
Defines ART Text mark interface.
Object Model
IImGearARTPopupText InterfaceImGearARTBorder ClassIImGearRGBQuad InterfaceImGearARTThickness StructureIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTPopupText
'Usage

Dim instance As IImGearARTPopupText
public interface IImGearARTPopupText
public __gc __interface IImGearARTPopupText
public interface class IImGearARTPopupText
See Also

Reference

IImGearARTPopupText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTPopupText Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPopupText Interface

The following tables list the members exposed by IImGearARTPopupText.

Public Properties
 | Name | Description
Property | ActualText | Gets or sets the actual text you can see on display.
Property | AlignmentH | Gets or sets the horizontal text alignment.
Property | AlignmentV | Gets or sets the vertical text alignment.
Property | AnchorX | Gets or sets the anchor's X location.
Property | AnchorY | Gets or sets the anchor's Y location.
Property | Border | Gets or sets the mark border.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the mark text.
Property | FontSize | Gets or sets the font size of the mark text.
Property | FontStyleART | Gets or sets the font style of the mark text.
Property | Height | Gets or sets the height of the mark's rectangle.
Property | IsOpen | Gets or sets a value indicating whether the popup text is opened.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Orientation | Gets or sets the text orientation.
Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Property | Text | Gets or sets the text of the mark.
Property | TextColor | Gets or sets the color of the mark text.
Property | TextOpacity | Gets or sets a separate opacity used for text string.
Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Property | TextType | Gets or sets the text type.
Property | Width | Gets or sets the width of the mark's rectangle.
Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

IImGearARTPopupText Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTPopupText Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTPopupText Interface

For a list of all members of this type, see IImGearARTPopupText members.

Public Properties
 | Name | Description
Property | ActualText | Gets or sets the actual text you can see on display.
Property | AlignmentH | Gets or sets the horizontal text alignment.
Property | AlignmentV | Gets or sets the vertical text alignment.
Property | AnchorX | Gets or sets the anchor's X location.
Property | AnchorY | Gets or sets the anchor's Y location.
Property | Border | Gets or sets the mark border.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the mark text.
Property | FontSize | Gets or sets the font size of the mark text.
Property | FontStyleART | Gets or sets the font style of the mark text.
Property | Height | Gets or sets the height of the mark's rectangle.
Property | IsOpen | Gets or sets a value indicating whether the popup text is opened.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Orientation | Gets or sets the text orientation.
Property | Padding | Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Property | Text | Gets or sets the text of the mark.
Property | TextColor | Gets or sets the color of the mark text.
Property | TextOpacity | Gets or sets a separate opacity used for text string.
Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Property | TextType | Gets or sets the text type.
Property | Width | Gets or sets the width of the mark's rectangle.
Property | X | Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Property | Y | Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Top
See Also

Reference

IImGearARTPopupText Interface
ImageGear.ART Namespace


ActualText Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : ActualText Property
Gets or sets the actual text you can see on display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ActualText As String
'Usage

Dim instance As IImGearARTPopupText
Dim value As String

instance.ActualText = value

value = instance.ActualText
string ActualText {get; set;}
__property string* get_ActualText();
__property void set_ActualText(
   string* value
);
property String^ ActualText {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
Text Property


AlignmentH Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : AlignmentH Property
Gets or sets the horizontal text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AlignmentH As ImGearAlignmentHModes
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearAlignmentHModes

instance.AlignmentH = value

value = instance.AlignmentH
ImGearAlignmentHModes AlignmentH {get; set;}
__property ImGearAlignmentHModes get_AlignmentH();
__property void set_AlignmentH(
   ImGearAlignmentHModes value
);
property ImGearAlignmentHModes AlignmentH {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentHModes enumeration value.
Remarks
The default value is ImGearAlignmentHModes.LEFT.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearAlignmentHModes Enumeration


AlignmentV Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : AlignmentV Property
Gets or sets the vertical text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AlignmentV As ImGearAlignmentVModes
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearAlignmentVModes

instance.AlignmentV = value

value = instance.AlignmentV
ImGearAlignmentVModes AlignmentV {get; set;}
__property ImGearAlignmentVModes get_AlignmentV();
__property void set_AlignmentV(
   ImGearAlignmentVModes value
);
property ImGearAlignmentVModes AlignmentV {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImageGear.Display.ImGearAlignmentVModes enumeration value.
Remarks
The default value is ImGearAlignmentVModes.TOP.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearAlignmentVModes Enumeration


AnchorX Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : AnchorX Property
Gets or sets the anchor's X location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AnchorX As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.AnchorX = value

value = instance.AnchorX
int AnchorX {get; set;}
__property int get_AnchorX();
__property void set_AnchorX(
   int value
);
property int AnchorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the left edge of the text mark.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


AnchorY Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : AnchorY Property
Gets or sets the anchor's Y location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AnchorY As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.AnchorY = value

value = instance.AnchorY
int AnchorY {get; set;}
__property int get_AnchorY();
__property void set_AnchorY(
   int value
);
property int AnchorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The coordinate is relative to the top edge of the text mark.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Border Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Border Property
Gets or sets the mark border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Border As ImGearARTBorder
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
ImGearARTBorder Border {get; set;}
__property ImGearARTBorder* get_Border();
__property void set_Border(
   ImGearARTBorder* value
);
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearARTBorder Class


FillColor Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPopupText
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
IImGearRGBQuad FillColor {get; set;}
__property IImGearRGBQuad* get_FillColor();
__property void set_FillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearRGBQuad Structure


FontDisablePPM Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontDisablePPM As Boolean
'Usage

Dim instance As IImGearARTPopupText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
bool FontDisablePPM {get; set;}
__property bool get_FontDisablePPM();
__property void set_FontDisablePPM(
   bool value
);
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


FontName Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : FontName Property
Gets or sets the font name of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontName As String
'Usage

Dim instance As IImGearARTPopupText
Dim value As String

instance.FontName = value

value = instance.FontName
string FontName {get; set;}
__property string* get_FontName();
__property void set_FontName(
   string* value
);
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


FontSize Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : FontSize Property
Gets or sets the font size of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontSize As Single
'Usage

Dim instance As IImGearARTPopupText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
float FontSize {get; set;}
__property float get_FontSize();
__property void set_FontSize(
   float value
);
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


FontStyleART Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : FontStyleART Property
Gets or sets the font style of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
ImGearARTFontStyles FontStyleART {get; set;}
__property ImGearARTFontStyles get_FontStyleART();
__property void set_FontStyleART(
   ImGearARTFontStyles value
);
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Height Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Height Property
Gets or sets the height of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Height As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.Height = value

value = instance.Height
int Height {get; set;}
__property int get_Height();
__property void set_Height(
   int value
);
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


IsOpen Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : IsOpen Property
Gets or sets a value indicating whether the popup text is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsOpen As Boolean
'Usage

Dim instance As IImGearARTPopupText
Dim value As Boolean

instance.IsOpen = value

value = instance.IsOpen
bool IsOpen {get; set;}
__property bool get_IsOpen();
__property void set_IsOpen(
   bool value
);
property bool IsOpen {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Opacity Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
This Opacity property is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use TextOpacity property.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Orientation Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Orientation Property
Gets or sets the text orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Orientation As ImGearOrientationModes
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearOrientationModes

instance.Orientation = value

value = instance.Orientation
ImGearOrientationModes Orientation {get; set;}
__property ImGearOrientationModes get_Orientation();
__property void set_Orientation(
   ImGearOrientationModes value
);
property ImGearOrientationModes Orientation {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

ImageGear.Core.ImGearOrientationModes enumeration value.
Remarks
The default value is ImGearOrientationModes.TOP_LEFT.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearOrientationModes Enumeration


Padding Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Padding Property
Gets or sets a value indicating the thickness of padding space between the boundaries of the content area and the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Padding As ImGearARTThickness
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearARTThickness

instance.Padding = value

value = instance.Padding
ImGearARTThickness Padding {get; set;}
__property ImGearARTThickness get_Padding();
__property void set_Padding(
   ImGearARTThickness value
);
property ImGearARTThickness Padding {
   ImGearARTThickness get();
   void set (    ImGearARTThickness value);
}

Property Value

ImGearARTThickness structure instance.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Text Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Text Property
Gets or sets the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Text As String
'Usage

Dim instance As IImGearARTPopupText
Dim value As String

instance.Text = value

value = instance.Text
string Text {get; set;}
__property string* get_Text();
__property void set_Text(
   string* value
);
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ActualText Property


TextColor Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : TextColor Property
Gets or sets the color of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTPopupText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
IImGearRGBQuad TextColor {get; set;}
__property IImGearRGBQuad* get_TextColor();
__property void set_TextColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearRGBQuad Structure


TextOpacity Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : TextOpacity Property
Gets or sets a separate opacity used for text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextOpacity As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.TextOpacity = value

value = instance.TextOpacity
int TextOpacity {get; set;}
__property int get_TextOpacity();
__property void set_TextOpacity(
   int value
);
property int TextOpacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the Opacity property used to set the opacity for the entire mark.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


TextTrimming Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : TextTrimming Property
Gets or sets the text trimming behavior to employ when content overflows the content area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextTrimming As ImGearARTTextTrimming
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearARTTextTrimming

instance.TextTrimming = value

value = instance.TextTrimming
ImGearARTTextTrimming TextTrimming {get; set;}
__property ImGearARTTextTrimming get_TextTrimming();
__property void set_TextTrimming(
   ImGearARTTextTrimming value
);
property ImGearARTTextTrimming TextTrimming {
   ImGearARTTextTrimming get();
   void set (    ImGearARTTextTrimming value);
}

Property Value

ImGearARTTextTrimming enumeration value.
Remarks
NOTE: The text trimming behavior is only supported by WPF annotation renderer. It is not currently supported in WinForms applications.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


TextType Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : TextType Property
Gets or sets the text type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextType As ImGearARTTextType
'Usage

Dim instance As IImGearARTPopupText
Dim value As ImGearARTTextType

instance.TextType = value

value = instance.TextType
ImGearARTTextType TextType {get; set;}
__property ImGearARTTextType get_TextType();
__property void set_TextType(
   ImGearARTTextType value
);
property ImGearARTTextType TextType {
   ImGearARTTextType get();
   void set (    ImGearARTTextType value);
}

Property Value

ImGearARTTextType enumeration value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members
ImGearARTTextType Enumeration
Text Property
ActualText Property


Width Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Width Property
Gets or sets the width of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


X Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : X Property
Gets or sets the X coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property X As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.X = value

value = instance.X
int X {get; set;}
__property int get_X();
__property void set_X(
   int value
);
property int X {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


Y Property (IImGearARTPopupText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTPopupText Interface : Y Property
Gets or sets the Y coordinate of the top-left point of the mark's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Y As Integer
'Usage

Dim instance As IImGearARTPopupText
Dim value As Integer

instance.Y = value

value = instance.Y
int Y {get; set;}
__property int get_Y();
__property void set_Y(
   int value
);
property int Y {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTPopupText Interface
IImGearARTPopupText Members


%%PageItemTitle%%

IImGearARTProtractor Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTProtractor Interface
Defines ART Protractor mark interface.
Object Model
IImGearARTProtractor InterfaceIImGearRGBQuad InterfaceImGearPoint StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTProtractor
'Usage

Dim instance As IImGearARTProtractor
public interface IImGearARTProtractor
public __gc __interface IImGearARTProtractor
public interface class IImGearARTProtractor
See Also

Reference

IImGearARTProtractor Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTProtractor Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTProtractor Interface

The following tables list the members exposed by IImGearARTProtractor.

Public Properties
 | Name | Description
Property | ArcRadius | Gets or sets the radius of the arc drawn in the mark.
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the mark color.
Property | EndPoint | Gets or sets the end point of the protractor.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | HeadPoint | Gets or sets the head point of the protractor.
Property | IsLabelVisible | Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartPoint | Gets or sets the start point of the protractor.
Property | Style | Gets or sets the style of the mark's line.
Property | Width | Gets or sets the width of the mark's line.
Top
See Also

Reference

IImGearARTProtractor Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTProtractor Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTProtractor Interface

For a list of all members of this type, see IImGearARTProtractor members.

Public Properties
 | Name | Description
Property | ArcRadius | Gets or sets the radius of the arc drawn in the mark.
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the mark color.
Property | EndPoint | Gets or sets the end point of the protractor.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | HeadPoint | Gets or sets the head point of the protractor.
Property | IsLabelVisible | Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Property | JoinStyle | Gets or sets the style of two lines joins.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartPoint | Gets or sets the start point of the protractor.
Property | Style | Gets or sets the style of the mark's line.
Property | Width | Gets or sets the width of the mark's line.
Top
See Also

Reference

IImGearARTProtractor Interface
ImageGear.ART Namespace


ArcRadius Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : ArcRadius Property
Gets or sets the radius of the arc drawn in the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ArcRadius As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.ArcRadius = value

value = instance.ArcRadius
int ArcRadius {get; set;}
__property int get_ArcRadius();
__property void set_ArcRadius(
   int value
);
property int ArcRadius {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


AspectDenominatorX Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorX As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
int AspectDenominatorX {get; set;}
__property int get_AspectDenominatorX();
__property void set_AspectDenominatorX(
   int value
);
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


AspectDenominatorY Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorY As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
int AspectDenominatorY {get; set;}
__property int get_AspectDenominatorY();
__property void set_AspectDenominatorY(
   int value
);
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


AspectNumeratorX Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorX As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
int AspectNumeratorX {get; set;}
__property int get_AspectNumeratorX();
__property void set_AspectNumeratorX(
   int value
);
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


AspectNumeratorY Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorY As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
int AspectNumeratorY {get; set;}
__property int get_AspectNumeratorY();
__property void set_AspectNumeratorY(
   int value
);
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


CapStyle Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : Color Property
Gets or sets the mark color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTProtractor
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
IImGearRGBQuad Interface


EndPoint Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : EndPoint Property
Gets or sets the end point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndPoint As ImGearPoint
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
ImGearPoint EndPoint {get; set;}
__property ImGearPoint get_EndPoint();
__property void set_EndPoint(
   ImGearPoint value
);
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearPoint Structure


FontDisablePPM Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontDisablePPM As Boolean
'Usage

Dim instance As IImGearARTProtractor
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
bool FontDisablePPM {get; set;}
__property bool get_FontDisablePPM();
__property void set_FontDisablePPM(
   bool value
);
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


FontName Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontName As String
'Usage

Dim instance As IImGearARTProtractor
Dim value As String

instance.FontName = value

value = instance.FontName
string FontName {get; set;}
__property string* get_FontName();
__property void set_FontName(
   string* value
);
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


FontSize Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontSize As Single
'Usage

Dim instance As IImGearARTProtractor
Dim value As Single

instance.FontSize = value

value = instance.FontSize
float FontSize {get; set;}
__property float get_FontSize();
__property void set_FontSize(
   float value
);
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any Float positive value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


FontStyleART Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
ImGearARTFontStyles FontStyleART {get; set;}
__property ImGearARTFontStyles get_FontStyleART();
__property void set_FontStyleART(
   ImGearARTFontStyles value
);
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


HeadPoint Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : HeadPoint Property
Gets or sets the head point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HeadPoint As ImGearPoint
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearPoint

instance.HeadPoint = value

value = instance.HeadPoint
ImGearPoint HeadPoint {get; set;}
__property ImGearPoint get_HeadPoint();
__property void set_HeadPoint(
   ImGearPoint value
);
property ImGearPoint HeadPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearPoint Structure


IsLabelVisible Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : IsLabelVisible Property
Gets or sets a value indicating whether or not the label is displayed adjacent to the protractor annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsLabelVisible As Boolean
'Usage

Dim instance As IImGearARTProtractor
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
bool IsLabelVisible {get; set;}
__property bool get_IsLabelVisible();
__property void set_IsLabelVisible(
   bool value
);
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


JoinStyle Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : JoinStyle Property
Gets or sets the style of two lines joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property JoinStyle As ImGearARTJoinStyle
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearARTJoinStyle

instance.JoinStyle = value

value = instance.JoinStyle
ImGearARTJoinStyle JoinStyle {get; set;}
__property ImGearARTJoinStyle get_JoinStyle();
__property void set_JoinStyle(
   ImGearARTJoinStyle value
);
property ImGearARTJoinStyle JoinStyle {
   ImGearARTJoinStyle get();
   void set (    ImGearARTJoinStyle value);
}

Property Value

ImGearARTJoinStyle enumeration value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearARTJoinStyle Enumeration


Opacity Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


Precision Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Precision As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.Precision = value

value = instance.Precision
int Precision {get; set;}
__property int get_Precision();
__property void set_Precision(
   int value
);
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


StartPoint Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : StartPoint Property
Gets or sets the start point of the protractor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartPoint As ImGearPoint
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
ImGearPoint StartPoint {get; set;}
__property ImGearPoint get_StartPoint();
__property void set_StartPoint(
   ImGearPoint value
);
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearPoint Structure


Style Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : Style Property
Gets or sets the style of the mark's line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTProtractor
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members
ImGearARTPenStyle Enumeration


Width Property (IImGearARTProtractor)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTProtractor Interface : Width Property
Gets or sets the width of the mark's line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTProtractor
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

IImGearARTRectangle Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRectangle Interface
Defines ART Rectangle mark interface.
Object Model
IImGearARTRectangle InterfaceImGearARTBorder ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTRectangle
'Usage

Dim instance As IImGearARTRectangle
public interface IImGearARTRectangle
public __gc __interface IImGearARTRectangle
public interface class IImGearARTRectangle
See Also

Reference

IImGearARTRectangle Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTRectangle Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRectangle Interface

The following tables list the members exposed by IImGearARTRectangle.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the opacity of the rectangle.
Top
See Also

Reference

IImGearARTRectangle Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTRectangle Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRectangle Interface

For a list of all members of this type, see IImGearARTRectangle members.

Public Properties
 | Name | Description
Property | Border | Gets or sets the border of the mark.
Property | FillColor | Gets or sets the fill color of the mark.
Property | IsHighlighter | Gets or sets a value indicating whether the mark is displayed as highlighter.
Property | Opacity | Gets or sets the opacity of the rectangle.
Top
See Also

Reference

IImGearARTRectangle Interface
ImageGear.ART Namespace


Border Property (IImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRectangle Interface : Border Property
Gets or sets the border of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Border As ImGearARTBorder
'Usage

Dim instance As IImGearARTRectangle
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
ImGearARTBorder Border {get; set;}
__property ImGearARTBorder* get_Border();
__property void set_Border(
   ImGearARTBorder* value
);
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members
ImGearARTBorder Class


FillColor Property (IImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRectangle Interface : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTRectangle
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
IImGearRGBQuad FillColor {get; set;}
__property IImGearRGBQuad* get_FillColor();
__property void set_FillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members
IImGearRGBQuad Interface


IsHighlighter Property (IImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRectangle Interface : IsHighlighter Property
Gets or sets a value indicating whether the mark is displayed as highlighter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsHighlighter As Boolean
'Usage

Dim instance As IImGearARTRectangle
Dim value As Boolean

instance.IsHighlighter = value

value = instance.IsHighlighter
bool IsHighlighter {get; set;}
__property bool get_IsHighlighter();
__property void set_IsHighlighter(
   bool value
);
property bool IsHighlighter {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


Opacity Property (IImGearARTRectangle)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRectangle Interface : Opacity Property
Gets or sets the opacity of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTRectangle
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

IImGearARTRuler Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRuler Interface
Defines ART Ruler mark interface.
Object Model
IImGearARTRuler InterfaceIImGearRGBQuad InterfaceImGearPoint StructureImGearARTMeasurementUnit StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTRuler
'Usage

Dim instance As IImGearARTRuler
public interface IImGearARTRuler
public __gc __interface IImGearARTRuler
public interface class IImGearARTRuler
See Also

Reference

IImGearARTRuler Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTRuler Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRuler Interface

The following tables list the members exposed by IImGearARTRuler.

Public Properties
 | Name | Description
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndLineLength | Gets or sets the length of the mark's end line.
Property | EndPoint | Gets or sets the end point of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Property | Label | Gets or sets the mark label.
Property | Length | Gets the length of the Ruler mark.
Property | MeasurementUnit | Gets or sets the measurement unit of the Ruler.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartLineLength | Gets or sets the length of the mark's start line.
Property | StartPoint | Gets or sets the start point of the mark.
Property | Style | Gets or sets the mark's line style.
Property | Width | Gets or sets the mark's line width.
Top
See Also

Reference

IImGearARTRuler Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTRuler Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTRuler Interface

For a list of all members of this type, see IImGearARTRuler members.

Public Properties
 | Name | Description
Property | AspectDenominatorX | Gets or sets the mark's X aspect denominator value.
Property | AspectDenominatorY | Gets or sets the Mark's Y aspect denominator value.
Property | AspectNumeratorX | Gets or sets the mark's X aspect numerator value.
Property | AspectNumeratorY | Gets or sets the mark's Y aspect numerator value.
Property | CapStyle | Gets or sets the style of a line end.
Property | Color | Gets or sets the color of the mark.
Property | EndLineLength | Gets or sets the length of the mark's end line.
Property | EndPoint | Gets or sets the end point of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the text font.
Property | FontSize | Gets or sets the font size of the text font.
Property | FontStyleART | Gets or sets the font style of the text font.
Property | IsLabelVisible | Gets or sets a value indicating whether the label is displayed.
Property | Label | Gets or sets the mark label.
Property | Length | Gets the length of the Ruler mark.
Property | MeasurementUnit | Gets or sets the measurement unit of the Ruler.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Precision | Gets or sets the number of decimal digits displayed for the mark.
Property | StartLineLength | Gets or sets the length of the mark's start line.
Property | StartPoint | Gets or sets the start point of the mark.
Property | Style | Gets or sets the mark's line style.
Property | Width | Gets or sets the mark's line width.
Top
See Also

Reference

IImGearARTRuler Interface
ImageGear.ART Namespace


AspectDenominatorX Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : AspectDenominatorX Property
Gets or sets the mark's X aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorX As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.AspectDenominatorX = value

value = instance.AspectDenominatorX
int AspectDenominatorX {get; set;}
__property int get_AspectDenominatorX();
__property void set_AspectDenominatorX(
   int value
);
property int AspectDenominatorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


AspectDenominatorY Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : AspectDenominatorY Property
Gets or sets the Mark's Y aspect denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectDenominatorY As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.AspectDenominatorY = value

value = instance.AspectDenominatorY
int AspectDenominatorY {get; set;}
__property int get_AspectDenominatorY();
__property void set_AspectDenominatorY(
   int value
);
property int AspectDenominatorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


AspectNumeratorX Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : AspectNumeratorX Property
Gets or sets the mark's X aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorX As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.AspectNumeratorX = value

value = instance.AspectNumeratorX
int AspectNumeratorX {get; set;}
__property int get_AspectNumeratorX();
__property void set_AspectNumeratorX(
   int value
);
property int AspectNumeratorX {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


AspectNumeratorY Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : AspectNumeratorY Property
Gets or sets the mark's Y aspect numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AspectNumeratorY As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.AspectNumeratorY = value

value = instance.AspectNumeratorY
int AspectNumeratorY {get; set;}
__property int get_AspectNumeratorY();
__property void set_AspectNumeratorY(
   int value
);
property int AspectNumeratorY {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


CapStyle Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : CapStyle Property
Gets or sets the style of a line end.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property CapStyle As ImGearARTCapStyle
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearARTCapStyle

instance.CapStyle = value

value = instance.CapStyle
ImGearARTCapStyle CapStyle {get; set;}
__property ImGearARTCapStyle get_CapStyle();
__property void set_CapStyle(
   ImGearARTCapStyle value
);
property ImGearARTCapStyle CapStyle {
   ImGearARTCapStyle get();
   void set (    ImGearARTCapStyle value);
}

Property Value

ImGearARTCapStyle enumeration value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members
ImGearARTCapStyle Enumeration


Color Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Color Property
Gets or sets the color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearARTRuler
Dim value As IImGearRGBQuad

instance.Color = value

value = instance.Color
IImGearRGBQuad Color {get; set;}
__property IImGearRGBQuad* get_Color();
__property void set_Color(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.IImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members
IImGearRGBQuad Interface


EndLineLength Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : EndLineLength Property
Gets or sets the length of the mark's end line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndLineLength As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.EndLineLength = value

value = instance.EndLineLength
int EndLineLength {get; set;}
__property int get_EndLineLength();
__property void set_EndLineLength(
   int value
);
property int EndLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


EndPoint Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : EndPoint Property
Gets or sets the end point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property EndPoint As ImGearPoint
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearPoint

instance.EndPoint = value

value = instance.EndPoint
ImGearPoint EndPoint {get; set;}
__property ImGearPoint get_EndPoint();
__property void set_EndPoint(
   ImGearPoint value
);
property ImGearPoint EndPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members
ImGearPoint Structure


FontDisablePPM Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontDisablePPM As Boolean
'Usage

Dim instance As IImGearARTRuler
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
bool FontDisablePPM {get; set;}
__property bool get_FontDisablePPM();
__property void set_FontDisablePPM(
   bool value
);
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


FontName Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : FontName Property
Gets or sets the font name of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontName As String
'Usage

Dim instance As IImGearARTRuler
Dim value As String

instance.FontName = value

value = instance.FontName
string FontName {get; set;}
__property string* get_FontName();
__property void set_FontName(
   string* value
);
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


FontSize Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : FontSize Property
Gets or sets the font size of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontSize As Single
'Usage

Dim instance As IImGearARTRuler
Dim value As Single

instance.FontSize = value

value = instance.FontSize
float FontSize {get; set;}
__property float get_FontSize();
__property void set_FontSize(
   float value
);
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


FontStyleART Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : FontStyleART Property
Gets or sets the font style of the text font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
ImGearARTFontStyles FontStyleART {get; set;}
__property ImGearARTFontStyles get_FontStyleART();
__property void set_FontStyleART(
   ImGearARTFontStyles value
);
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


IsLabelVisible Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : IsLabelVisible Property
Gets or sets a value indicating whether the label is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsLabelVisible As Boolean
'Usage

Dim instance As IImGearARTRuler
Dim value As Boolean

instance.IsLabelVisible = value

value = instance.IsLabelVisible
bool IsLabelVisible {get; set;}
__property bool get_IsLabelVisible();
__property void set_IsLabelVisible(
   bool value
);
property bool IsLabelVisible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean variable.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


Label Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Label Property
Gets or sets the mark label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Label As String
'Usage

Dim instance As IImGearARTRuler
Dim value As String

instance.Label = value

value = instance.Label
string Label {get; set;}
__property string* get_Label();
__property void set_Label(
   string* value
);
property String^ Label {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


Length Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Length Property
Gets the length of the Ruler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Length As Double
'Usage

Dim instance As IImGearARTRuler
Dim value As Double

value = instance.Length
double Length {get;}
__property double get_Length();
property double Length {
   double get();
}

Property Value

Double value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


MeasurementUnit Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : MeasurementUnit Property
Gets or sets the measurement unit of the Ruler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property MeasurementUnit As ImGearARTMeasurementUnit
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearARTMeasurementUnit

instance.MeasurementUnit = value

value = instance.MeasurementUnit
ImGearARTMeasurementUnit MeasurementUnit {get; set;}
__property ImGearARTMeasurementUnit get_MeasurementUnit();
__property void set_MeasurementUnit(
   ImGearARTMeasurementUnit value
);
property ImGearARTMeasurementUnit MeasurementUnit {
   ImGearARTMeasurementUnit get();
   void set (    ImGearARTMeasurementUnit value);
}

Property Value

ImGearARTMeasurementUnit value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


Opacity Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


Precision Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Precision Property
Gets or sets the number of decimal digits displayed for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Precision As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.Precision = value

value = instance.Precision
int Precision {get; set;}
__property int get_Precision();
__property void set_Precision(
   int value
);
property int Precision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


StartLineLength Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : StartLineLength Property
Gets or sets the length of the mark's start line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartLineLength As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.StartLineLength = value

value = instance.StartLineLength
int StartLineLength {get; set;}
__property int get_StartLineLength();
__property void set_StartLineLength(
   int value
);
property int StartLineLength {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


StartPoint Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : StartPoint Property
Gets or sets the start point of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property StartPoint As ImGearPoint
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearPoint

instance.StartPoint = value

value = instance.StartPoint
ImGearPoint StartPoint {get; set;}
__property ImGearPoint get_StartPoint();
__property void set_StartPoint(
   ImGearPoint value
);
property ImGearPoint StartPoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure object.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members
ImGearPoint Structure


Style Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Style Property
Gets or sets the mark's line style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Style As ImGearARTPenStyle
'Usage

Dim instance As IImGearARTRuler
Dim value As ImGearARTPenStyle

instance.Style = value

value = instance.Style
ImGearARTPenStyle Style {get; set;}
__property ImGearARTPenStyle get_Style();
__property void set_Style(
   ImGearARTPenStyle value
);
property ImGearARTPenStyle Style {
   ImGearARTPenStyle get();
   void set (    ImGearARTPenStyle value);
}

Property Value

ImGearARTPenStyle enumeration value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members
ImGearARTPenStyle Enumeration


Width Property (IImGearARTRuler)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTRuler Interface : Width Property
Gets or sets the mark's line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Width As Integer
'Usage

Dim instance As IImGearARTRuler
Dim value As Integer

instance.Width = value

value = instance.Width
int Width {get; set;}
__property int get_Width();
__property void set_Width(
   int value
);
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

IImGearARTText Interface
Members

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTText Interface
Defines ART Text mark interface.
Object Model
IImGearARTText InterfaceImGearARTBorder ClassImGearARTCallout ClassIImGearRGBQuad InterfaceImGearARTPin ClassIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearARTText
'Usage

Dim instance As IImGearARTText
public interface IImGearARTText
public __gc __interface IImGearARTText
public interface class IImGearARTText
See Also

Reference

IImGearARTText Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

IImGearARTText Interface Members
Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTText Interface

The following tables list the members exposed by IImGearARTText.

Public Properties
 | Name | Description
Property | ActualText | Gets or sets the actual text you can see on display.
Property | Border | Gets or sets the mark border.
Property | BorderShading | Gets or sets a value indicating whether the border is shaded or not.
Property | Callout | Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the mark text.
Property | FontSize | Gets or sets the font size of the mark text.
Property | FontStyleART | Gets or sets the font style of the mark text.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Pin | Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Property | Text | Gets or sets the text of the mark.
Property | TextColor | Gets or sets the color of the mark text.
Property | TextOpacity | Gets or sets a separate opacity used for text string.
Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Property | TextType | Gets or sets the text type.
Top
See Also

Reference

IImGearARTText Interface
ImageGear.ART Namespace


%%PageItemTitle%% $$Properties$$

IImGearARTText Interface Properties

ImageGear22.Art Assembly > ImageGear.ART Namespace : IImGearARTText Interface

For a list of all members of this type, see IImGearARTText members.

Public Properties
 | Name | Description
Property | ActualText | Gets or sets the actual text you can see on display.
Property | Border | Gets or sets the mark border.
Property | BorderShading | Gets or sets a value indicating whether the border is shaded or not.
Property | Callout | Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Property | FillColor | Gets or sets the fill color of the mark.
Property | FontDisablePPM | Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Property | FontName | Gets or sets the font name of the mark text.
Property | FontSize | Gets or sets the font size of the mark text.
Property | FontStyleART | Gets or sets the font style of the mark text.
Property | Opacity | Gets or sets the opacity of the mark.
Property | Pin | Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Property | Text | Gets or sets the text of the mark.
Property | TextColor | Gets or sets the color of the mark text.
Property | TextOpacity | Gets or sets a separate opacity used for text string.
Property | TextTrimming | Gets or sets the text trimming behavior to employ when content overflows the content area.
Property | TextType | Gets or sets the text type.
Top
See Also

Reference

IImGearARTText Interface
ImageGear.ART Namespace


ActualText Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : ActualText Property
Gets or sets the actual text you can see on display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ActualText As String
'Usage

Dim instance As IImGearARTText
Dim value As String

instance.ActualText = value

value = instance.ActualText
string ActualText {get; set;}
__property string* get_ActualText();
__property void set_ActualText(
   string* value
);
property String^ ActualText {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
Text Property


Border Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : Border Property
Gets or sets the mark border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Border As ImGearARTBorder
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTBorder

instance.Border = value

value = instance.Border
ImGearARTBorder Border {get; set;}
__property ImGearARTBorder* get_Border();
__property void set_Border(
   ImGearARTBorder* value
);
property ImGearARTBorder^ Border {
   ImGearARTBorder^ get();
   void set (    ImGearARTBorder^ value);
}

Property Value

ImGearARTBorder class object.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearARTBorder Class


BorderShading Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : BorderShading Property
Gets or sets a value indicating whether the border is shaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property BorderShading As Boolean
'Usage

Dim instance As IImGearARTText
Dim value As Boolean

instance.BorderShading = value

value = instance.BorderShading
bool BorderShading {get; set;}
__property bool get_BorderShading();
__property void set_BorderShading(
   bool value
);
property bool BorderShading {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


Callout Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : Callout Property
Gets or sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Callout As ImGearARTCallout
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTCallout

instance.Callout = value

value = instance.Callout
ImGearARTCallout Callout {get; set;}
__property ImGearARTCallout* get_Callout();
__property void set_Callout(
   ImGearARTCallout* value
);
property ImGearARTCallout^ Callout {
   ImGearARTCallout^ get();
   void set (    ImGearARTCallout^ value);
}

Property Value

ImGearARTCallout class object.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearARTCallout Class


FillColor Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : FillColor Property
Gets or sets the fill color of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FillColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTText
Dim value As IImGearRGBQuad

instance.FillColor = value

value = instance.FillColor
IImGearRGBQuad FillColor {get; set;}
__property IImGearRGBQuad* get_FillColor();
__property void set_FillColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ FillColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearRGBQuad Structure


FontDisablePPM Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : FontDisablePPM Property
Gets or sets a value indicating whether the PPM option is disabled in font size calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontDisablePPM As Boolean
'Usage

Dim instance As IImGearARTText
Dim value As Boolean

instance.FontDisablePPM = value

value = instance.FontDisablePPM
bool FontDisablePPM {get; set;}
__property bool get_FontDisablePPM();
__property void set_FontDisablePPM(
   bool value
);
property bool FontDisablePPM {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


FontName Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : FontName Property
Gets or sets the font name of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontName As String
'Usage

Dim instance As IImGearARTText
Dim value As String

instance.FontName = value

value = instance.FontName
string FontName {get; set;}
__property string* get_FontName();
__property void set_FontName(
   string* value
);
property String^ FontName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


FontSize Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : FontSize Property
Gets or sets the font size of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontSize As Single
'Usage

Dim instance As IImGearARTText
Dim value As Single

instance.FontSize = value

value = instance.FontSize
float FontSize {get; set;}
__property float get_FontSize();
__property void set_FontSize(
   float value
);
property float FontSize {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The font size is measured in points.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


FontStyleART Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : FontStyleART Property
Gets or sets the font style of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FontStyleART As ImGearARTFontStyles
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTFontStyles

instance.FontStyleART = value

value = instance.FontStyleART
ImGearARTFontStyles FontStyleART {get; set;}
__property ImGearARTFontStyles get_FontStyleART();
__property void set_FontStyleART(
   ImGearARTFontStyles value
);
property ImGearARTFontStyles FontStyleART {
   ImGearARTFontStyles get();
   void set (    ImGearARTFontStyles value);
}

Property Value

ImGearARTFontStyles enumeration value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


Opacity Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : Opacity Property
Gets or sets the opacity of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Opacity As Integer
'Usage

Dim instance As IImGearARTText
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
int Opacity {get; set;}
__property int get_Opacity();
__property void set_Opacity(
   int value
);
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
This Opacity property is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use TextOpacity property.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


Pin Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : Pin Property
Gets or sets the ImGearARTPin object that specifies mark's pin icon attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Pin As ImGearARTPin
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTPin

instance.Pin = value

value = instance.Pin
ImGearARTPin Pin {get; set;}
__property ImGearARTPin* get_Pin();
__property void set_Pin(
   ImGearARTPin* value
);
property ImGearARTPin^ Pin {
   ImGearARTPin^ get();
   void set (    ImGearARTPin^ value);
}

Property Value

ImGearARTPin class object.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearARTPin Class


Text Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : Text Property
Gets or sets the text of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Text As String
'Usage

Dim instance As IImGearARTText
Dim value As String

instance.Text = value

value = instance.Text
string Text {get; set;}
__property string* get_Text();
__property void set_Text(
   string* value
);
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ActualText Property


TextColor Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : TextColor Property
Gets or sets the color of the mark text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextColor As IImGearRGBQuad
'Usage

Dim instance As IImGearARTText
Dim value As IImGearRGBQuad

instance.TextColor = value

value = instance.TextColor
IImGearRGBQuad TextColor {get; set;}
__property IImGearRGBQuad* get_TextColor();
__property void set_TextColor(
   IImGearRGBQuad* value
);
property IImGearRGBQuad^ TextColor {
   IImGearRGBQuad^ get();
   void set (    IImGearRGBQuad^ value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearRGBQuad Structure


TextOpacity Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : TextOpacity Property
Gets or sets a separate opacity used for text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextOpacity As Integer
'Usage

Dim instance As IImGearARTText
Dim value As Integer

instance.TextOpacity = value

value = instance.TextOpacity
int TextOpacity {get; set;}
__property int get_TextOpacity();
__property void set_TextOpacity(
   int value
);
property int TextOpacity {
   int get();
   void set (    int value);
}

Property Value

Integer value from 0 (transparent) to 255 (opaque).
Remarks
When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the Opacity property used to set the opacity for the entire mark.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


TextTrimming Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : TextTrimming Property
Gets or sets the text trimming behavior to employ when content overflows the content area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextTrimming As ImGearARTTextTrimming
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTTextTrimming

instance.TextTrimming = value

value = instance.TextTrimming
ImGearARTTextTrimming TextTrimming {get; set;}
__property ImGearARTTextTrimming get_TextTrimming();
__property void set_TextTrimming(
   ImGearARTTextTrimming value
);
property ImGearARTTextTrimming TextTrimming {
   ImGearARTTextTrimming get();
   void set (    ImGearARTTextTrimming value);
}

Property Value

ImGearARTTextTrimming enumeration value.
Remarks
NOTE: The text trimming behavior is only supported by WPF annotation renderer. It is not currently supported in WinForms applications.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members


TextType Property (IImGearARTText)

ImageGear22.Art Assembly > ImageGear.ART Namespace > IImGearARTText Interface : TextType Property
Gets or sets the text type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TextType As ImGearARTTextType
'Usage

Dim instance As IImGearARTText
Dim value As ImGearARTTextType

instance.TextType = value

value = instance.TextType
ImGearARTTextType TextType {get; set;}
__property ImGearARTTextType get_TextType();
__property void set_TextType(
   ImGearARTTextType value
);
property ImGearARTTextType TextType {
   ImGearARTTextType get();
   void set (    ImGearARTTextType value);
}

Property Value

ImGearARTTextType enumeration value.
See Also

Reference

IImGearARTText Interface
IImGearARTText Members
ImGearARTTextType Enumeration
Text Property
ActualText Property


%%PageItemTitle%%

ARTPropertyChangedEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ARTPropertyChangedEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ARTPropertyChanged events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ARTPropertyChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTPropertyChangedEventArgs _
)
'Usage

Dim instance As New ARTPropertyChangedEventHandler(AddressOf HandlerMethod)
public delegate void ARTPropertyChangedEventHandler(
   object sender,
   ImGearARTPropertyChangedEventArgs e
)
public: __gc __delegate void ARTPropertyChangedEventHandler(
   Object* sender,
   ImGearARTPropertyChangedEventArgs* e
)
public delegate void ARTPropertyChangedEventHandler(
   Object^ sender,
   ImGearARTPropertyChangedEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ARTPropertyChangedEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTHistoryEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTHistoryEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ImGearARTHistory.HistoryChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTHistoryEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTHistoryEventArgs _
)
'Usage

Dim instance As New ImGearARTHistoryEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTHistoryEventHandler(
   object sender,
   ImGearARTHistoryEventArgs e
)
public: __gc __delegate void ImGearARTHistoryEventHandler(
   Object* sender,
   ImGearARTHistoryEventArgs* e
)
public delegate void ImGearARTHistoryEventHandler(
   Object^ sender,
   ImGearARTHistoryEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTHistoryEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ImGearARTPage.MarkChanged, ImGearARTPage.MarkAdded, ImGearARTPage.MarkRemoved, ImGearARTPage.MarkZOrderChanged and ImGearARTPage.MarkSelectionChanged events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkEventHandler(
   object sender,
   ImGearARTMarkEventArgs e
)
public: __gc __delegate void ImGearARTMarkEventHandler(
   Object* sender,
   ImGearARTMarkEventArgs* e
)
public delegate void ImGearARTMarkEventHandler(
   Object^ sender,
   ImGearARTMarkEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkFlipEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkFlipEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring MarkFlipped event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkFlipEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkFlipEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkFlipEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkFlipEventHandler(
   object sender,
   ImGearARTMarkFlipEventArgs e
)
public: __gc __delegate void ImGearARTMarkFlipEventHandler(
   Object* sender,
   ImGearARTMarkFlipEventArgs* e
)
public delegate void ImGearARTMarkFlipEventHandler(
   Object^ sender,
   ImGearARTMarkFlipEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkFlipEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkMoveEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkMoveEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring MarkMoved event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkMoveEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkMoveEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkMoveEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkMoveEventHandler(
   object sender,
   ImGearARTMarkMoveEventArgs e
)
public: __gc __delegate void ImGearARTMarkMoveEventHandler(
   Object* sender,
   ImGearARTMarkMoveEventArgs* e
)
public delegate void ImGearARTMarkMoveEventHandler(
   Object^ sender,
   ImGearARTMarkMoveEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkMoveEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkPointEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkPointEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring PointChanged and PointAdded events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkPointEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkPointEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkPointEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkPointEventHandler(
   object sender,
   ImGearARTMarkPointEventArgs e
)
public: __gc __delegate void ImGearARTMarkPointEventHandler(
   Object* sender,
   ImGearARTMarkPointEventArgs* e
)
public delegate void ImGearARTMarkPointEventHandler(
   Object^ sender,
   ImGearARTMarkPointEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkPointEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkRotateEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkRotateEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring MarkRotated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkRotateEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkRotateEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkRotateEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkRotateEventHandler(
   object sender,
   ImGearARTMarkRotateEventArgs e
)
public: __gc __delegate void ImGearARTMarkRotateEventHandler(
   Object* sender,
   ImGearARTMarkRotateEventArgs* e
)
public delegate void ImGearARTMarkRotateEventHandler(
   Object^ sender,
   ImGearARTMarkRotateEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkRotateEventHandler Members
ImageGear.ART Namespace


%%PageItemTitle%%

ImGearARTMarkScaleEventHandler Delegate

ImageGear22.Art Assembly > ImageGear.ART Namespace : ImGearARTMarkScaleEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring MarkScaled event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTMarkScaleEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTMarkScaleEventArgs _
)
'Usage

Dim instance As New ImGearARTMarkScaleEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTMarkScaleEventHandler(
   object sender,
   ImGearARTMarkScaleEventArgs e
)
public: __gc __delegate void ImGearARTMarkScaleEventHandler(
   Object* sender,
   ImGearARTMarkScaleEventArgs* e
)
public delegate void ImGearARTMarkScaleEventHandler(
   Object^ sender,
   ImGearARTMarkScaleEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearARTMarkScaleEventHandler Members
ImageGear.ART Namespace


ImageGear22.Art.Forms Assembly
Namespaces
Namespace | Description
ImageGear.ART.Forms | The ImageGear.ART.Forms namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. It provides ART GUI functionality that can simplify development of ImageGear based applications. This functionality is implemented in WinForms assembly, using only public ImageGear API, with source code provided to enable modifications.


ImageGear.ART.Forms Namespace
Inheritance Hierarchy
ImageGear22.Art.Forms Assembly : ImageGear.ART.Forms Namespace
The ImageGear.ART.Forms namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. It provides ART GUI functionality that can simplify development of ImageGear based applications. This functionality is implemented in WinForms assembly, using only public ImageGear API, with source code provided to enable modifications.
Classes
 | Class | Description
Class | ImGearART3DToolBar | Provides control for rotating, scaling and moving 3D data, as well as changing 3D light and view settings.
Class | ImGearARTForms | Provides properties and methods for using ART forms functionality.
Class | ImGearARTFormsCreateMarkData | This class provides mark creation data.
Class | ImGearARTFormsMarkController | Abstract class defining methods for mark's controller.
Class | ImGearARTFormsMarkControllerData | This class provides mark controller data.
Class | ImGearARTFormsMarkCreatedEventArgs | Provides MarkCreated event data.
Class | ImGearARTFormsMarkCreatingEventArgs | Provides MarkCreating event data.
Class | ImGearARTFormsMouseEventArgs | Provides mouse event data.
Class | ImGearARTFormsPolyController | Mark annotator controller that implements mouse interaction for marks defined by a set of points, like Polyline, Polygon etc.
Class | ImGearARTFormsPreviewData | This class provides mark controller data.
Class | ImGearARTFormsRectangleController | Mark annotator controller that implements mouse interaction for marks with rectangular bounds, like Ellipse, Text etc.
Class | ImGearARTFormsToolbarButtonInfo | Contains iformation that is needed to create a mark's toolbar button.
Class | ImGearARTMarkTemplates | Provides templates for creating annotations using the mouse.
Class | ImGearARTPropertyDialog | Represents GUI dialog class for accessing ART annotations properties.
Class | ImGearARTRTFToolBar | Represents toolbar for editing text and style of the RTF annotations.
Class | ImGearARTToolBar | Represents toolbar for creating, selecting and editing ART annotations.
Class | InputBox | Represents a window for prompting the user for an input string.
Delegates
 | Delegate | Description
Delegate | ImGearARTForms.DelegateButtonAction | A delegate for interacting with the Button annotation.
Delegate | ImGearARTForms.DelegateHotSpotAction | A delegate for interacting with the Hot Spot annotation.
Delegate | ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler | Represents the method that will handle MarkCreated event.
Delegate | ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler | Represents the method that will handle MarkCreating event.
Delegate | ImGearARTForms.ImGearARTFormsMouseEventHandler | Represents the method that will handle Mouse events.
Delegate | ImGearARTToolBar.DelegateCreateMark | A delegate for notifications when annotation mark is created.
Delegate | ImGearARTToolBar.DelegateDeleteMark | A delegate for notifications when annotation mark is being deleted.
Delegate | ImGearARTToolBar.DelegateModifyMark | A delegate for notifications when annotation mark is changed.
Delegate | ImGearARTToolBar.DelegatePreCreateMark | A delegate for notifications prior to creating annotation marks.
Delegate | ImGearARTToolBar.DelegateSelect | A delegate for notifications when annotation type is selected.
Delegate | InputBox.FindProc | A delegate method called when Find button is clicked.
Enumerations
 | Enumeration | Description
Enumeration | ImGearARTFormsResizeType | Specifies how the mark is being resized.
Enumeration | ImGearARTInteractionArea | Specifies the interaction area for editing annotations.
Enumeration | ImGearARTModes | Specifies the annotation mode.
Enumeration | ImGearARTModifyReason | Specifies type of the annotation's change.
Enumeration | ImGearARTToolBarModes | Specifies ART toolbar mode: legacy 2.0 marks and 3.0 marks.
See Also

Reference

ImageGear22.Art.Forms Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.ART.Forms Namespace Inheritance Hierarchy
ImageGear22.Art.Forms Assembly : ImageGear.ART.Forms Namespace
Inheritance Hierarchy
System.Object
ImageGear.ART.Forms.ImGearARTForms
ImageGear.ART.Forms.ImGearARTFormsCreateMarkData
ImageGear.ART.Forms.ImGearARTFormsMarkController
ImageGear.ART.Forms.ImGearARTFormsPolyController
ImageGear.ART.Forms.ImGearARTFormsRectangleController
ImageGear.ART.Forms.ImGearARTFormsMarkControllerData
ImageGear.ART.Forms.ImGearARTFormsPreviewData
ImageGear.ART.Forms.ImGearARTFormsToolbarButtonInfo
ImageGear.ART.Forms.ImGearARTMarkTemplates
System.EventArgs
ImageGear.ART.Forms.ImGearARTFormsMarkCreatedEventArgs
ImageGear.ART.Forms.ImGearARTFormsMarkCreatingEventArgs
ImageGear.ART.Forms.ImGearARTFormsMouseEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.ImGearART3DToolBar
ImageGear.ART.Forms.ImGearARTPropertyDialog
ImageGear.ART.Forms.ImGearARTRTFToolBar
ImageGear.ART.Forms.ImGearARTToolBar
ImageGear.ART.Forms.InputBox
See Also

Reference

ImageGear22.Art.Forms Assembly


%%PageItemTitle%%

ImGearART3DToolBar Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearART3DToolBar Class
Provides control for rotating, scaling and moving 3D data, as well as changing 3D light and view settings.
Object Model
ImGearART3DToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearART3DToolBar
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearART3DToolBar
public class ImGearART3DToolBar : System.Windows.Forms.Form
public __gc class ImGearART3DToolBar : public System.Windows.Forms.Form
public ref class ImGearART3DToolBar : public System.Windows.Forms.Form
Remarks
This toolbar enables 3D interaction capabilities for CAD and 3D PDF artwork when annotation RUN mode is enabled.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.ImGearART3DToolBar

See Also

Reference

ImGearART3DToolBar Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearART3DToolBar Class Members
Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearART3DToolBar Class

The following tables list the members exposed by ImGearART3DToolBar.

Public Constructors
 | Name | Description
Public Constructor | ImGearART3DToolBar Constructor | Initializes a new instance of the ImGearART3DToolBar class.
Top
Public Methods
 | Name | Description
Public Method | OnMouseDown | Mouse down event handler to receive a call to the client mouse down event.
Public Method | OnMouseMove | Mouse move event handler to receive a call to the client mouse move event.
Public Method | OnMouseUp | Overloaded. Mouse up event handler to receive a call to the client mouse up event.
Top
See Also

Reference

ImGearART3DToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearART3DToolBar Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearART3DToolBar Class

For a list of all members of this type, see ImGearART3DToolBar members.

See Also

Reference

ImGearART3DToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearART3DToolBar Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : ImGearART3DToolBar Constructor
Reference to ImageGear.Windows.Forms.ImGearPageView control.
Reference to ImageGear.ART.ImGearARTMark annotation the 3D toolbar will be working with.
Initializes a new instance of the ImGearART3DToolBar class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal imageMark As ImGearARTMark _
)
'Usage

Dim pageView As ImGearPageView
Dim imageMark As ImGearARTMark

Dim instance As New ImGearART3DToolBar(pageView, imageMark)
public ImGearART3DToolBar(
   ImGearPageView pageView,
   ImGearARTMark imageMark
)
public: ImGearART3DToolBar(
   ImGearPageView* pageView,
   ImGearARTMark* imageMark
)
public:
ImGearART3DToolBar(
   ImGearPageView^ pageView,
   ImGearARTMark^ imageMark
)

Parameters

pageView
Reference to ImageGear.Windows.Forms.ImGearPageView control.
imageMark
Reference to ImageGear.ART.ImGearARTMark annotation the 3D toolbar will be working with.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


%%PageItemTitle%% $$Methods$$

ImGearART3DToolBar Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearART3DToolBar Class

For a list of all members of this type, see ImGearART3DToolBar members.

Public Methods
 | Name | Description
Public Method | OnMouseDown | Mouse down event handler to receive a call to the client mouse down event.
Public Method | OnMouseMove | Mouse move event handler to receive a call to the client mouse move event.
Public Method | OnMouseUp | Overloaded. Mouse up event handler to receive a call to the client mouse up event.
Top
See Also

Reference

ImGearART3DToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearART3DToolBar Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearART3DToolBar Class

For a list of all members of this type, see ImGearART3DToolBar members.

See Also

Reference

ImGearART3DToolBar Class
ImageGear.ART.Forms Namespace


Dispose Method (ImGearART3DToolBar)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : Dispose Method
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


Dispose(Boolean) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class > Dispose Method : Dispose(Boolean) Method
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearART3DToolBar
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Remarks
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members
Overload List


OnMouseDown Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : OnMouseDown Method
Mouse down event handler to receive a call to the client mouse down event.
Overload List
Overload | Description
OnMouseDown | Mouse down event handler to receive a call to the client mouse down event.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


OnMouseDown(MouseEventArgs) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : OnMouseDown(MouseEventArgs) Method
Event arguments.
Mouse down event handler to receive a call to the client mouse down event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearART3DToolBar
Dim e As MouseEventArgs

instance.OnMouseDown(e)
public void OnMouseDown(
   MouseEventArgs e
)
public: void OnMouseDown(
   MouseEventArgs* e
)
public:
void OnMouseDown(
   MouseEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


OnMouseMove Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : OnMouseMove Method
Mouse move event handler to receive a call to the client mouse move event.
Overload List
Overload | Description
OnMouseMove | Mouse move event handler to receive a call to the client mouse move event.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


OnMouseMove(MouseEventArgs) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : OnMouseMove(MouseEventArgs) Method
Event arguments.
Mouse move event handler to receive a call to the client mouse move event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearART3DToolBar
Dim e As MouseEventArgs

instance.OnMouseMove(e)
public void OnMouseMove(
   MouseEventArgs e
)
public: void OnMouseMove(
   MouseEventArgs* e
)
public:
void OnMouseMove(
   MouseEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


OnMouseUp Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class : OnMouseUp Method
Mouse up event handler to receive a call to the client mouse up event.
Overload List
Overload | Description
OnMouseUp() | Mouse up event handler to receive a call to the client mouse up event.
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members


OnMouseUp() Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearART3DToolBar Class > OnMouseUp Method : OnMouseUp() Method
Mouse up event handler to receive a call to the client mouse up event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub OnMouseUp()
'Usage

Dim instance As ImGearART3DToolBar

instance.OnMouseUp()
public void OnMouseUp()
public: void OnMouseUp();
public:
void OnMouseUp();
See Also

Reference

ImGearART3DToolBar Class
ImGearART3DToolBar Members
Overload List


%%PageItemTitle%%

ImGearARTForms Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class
Provides properties and methods for using ART forms functionality.
Object Model
ImGearARTForms ClassImGearARTPage ClassImGearPageView ClassImGearARTMarkTemplates ClassImGearARTToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearARTForms
'Usage

Dim instance As ImGearARTForms
public sealed class ImGearARTForms
public __gc __sealed class ImGearARTForms
public ref class ImGearARTForms sealed
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTForms

See Also

Reference

ImGearARTForms Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTForms Class Members
Fields Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class

The following tables list the members exposed by ImGearARTForms.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTForms Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | PropertyDialog | Reference to the property dialog object.
Top
Public Properties
 | Name | Description
Public Property | AggregateSelect | Gets or sets a value indicating whether the aggregate selection of annotations is allowed.
Public Property | ButtonAction | Gets or sets a reference to ButtonAction delegate if registered.
Public Property | HotSpotAction | Gets or sets a reference to HotSpotAction delegate if registered.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | Mode | Gets or sets the annotation mode.
Public Property | Page | Gets or sets a reference to the working annotation page.
Public Property | PageView | Gets or sets a reference to the page view control.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | Templates | Gets or sets the templates for creating annotations using the mouse.
Public Property | ToolBar | Gets or sets a reference to the annotation toolbar.
Top
Public Methods
 | Name | Description
Public Method | MouseDown | Provides mouse down interaction functionality.
Public Method | MouseMove | Provides mouse move interaction functionality.
Public Method | MouseUp | Provides mouse up interaction functionality.
Top
Public Events
 | Name | Description
Public Event | MarkCreated | Occurs right after an annotation is created.
Public Event | MarkCreating | Occurs just before an annotation is created.
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseMoved | Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of an annotation mark.
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Top
See Also

Reference

ImGearARTForms Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTForms Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : ImGearARTForms Constructor
Overload List
Overload | Description
ImGearARTForms Constructor(ImGearPageView) | Initializes a new instance of the ImGearARTForms class object.
ImGearARTForms Constructor(ImGearPageView,ImGearARTToolBarModes) | Initializes a new instance of the ImGearARTForms class object.
ImGearARTForms Constructor(ImGearPageView,ImGearARTPage,ImGearARTToolBarModes) | Initializes a new instance of the ImGearARTForms class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


%%PageItemTitle%%

ImGearARTForms Constructor(ImGearPageView)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class > ImGearARTForms Constructor : ImGearARTForms Constructor(ImGearPageView)
Reference to the page view control.
Initializes a new instance of the ImGearARTForms class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearARTForms(pageView)
public ImGearARTForms(
   ImGearPageView pageView
)
public: ImGearARTForms(
   ImGearPageView* pageView
)
public:
ImGearARTForms(
   ImGearPageView^ pageView
)

Parameters

pageView
Reference to the page view control.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
Overload List
ImGearPageView Class


%%PageItemTitle%%

ImGearARTForms Constructor(ImGearPageView,ImGearARTToolBarModes)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class > ImGearARTForms Constructor : ImGearARTForms Constructor(ImGearPageView,ImGearARTToolBarModes)
Reference to the page view control.
Specifies ART toolbar mode: legacy 2.0 marks or 3.0 marks.
Initializes a new instance of the ImGearARTForms class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal mode As ImGearARTToolBarModes _
)
'Usage

Dim pageView As ImGearPageView
Dim mode As ImGearARTToolBarModes

Dim instance As New ImGearARTForms(pageView, mode)
public ImGearARTForms(
   ImGearPageView pageView,
   ImGearARTToolBarModes mode
)
public: ImGearARTForms(
   ImGearPageView* pageView,
   ImGearARTToolBarModes mode
)
public:
ImGearARTForms(
   ImGearPageView^ pageView,
   ImGearARTToolBarModes mode
)

Parameters

pageView
Reference to the page view control.
mode
Specifies ART toolbar mode: legacy 2.0 marks or 3.0 marks.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
Overload List
ImGearPageView Class
ImGearARTToolBarModes Enumeration


%%PageItemTitle%%

ImGearARTForms Constructor(ImGearPageView,ImGearARTPage,ImGearARTToolBarModes)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class > ImGearARTForms Constructor : ImGearARTForms Constructor(ImGearPageView,ImGearARTPage,ImGearARTToolBarModes)
Reference to the page view control.
Reference to working annotation page.
Specifies ART toolbar mode: legacy 2.0 marks or 3.0 marks.
Initializes a new instance of the ImGearARTForms class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal page As ImGearARTPage, _
   ByVal mode As ImGearARTToolBarModes _
)
'Usage

Dim pageView As ImGearPageView
Dim page As ImGearARTPage
Dim mode As ImGearARTToolBarModes

Dim instance As New ImGearARTForms(pageView, page, mode)
public ImGearARTForms(
   ImGearPageView pageView,
   ImGearARTPage page,
   ImGearARTToolBarModes mode
)
public: ImGearARTForms(
   ImGearPageView* pageView,
   ImGearARTPage* page,
   ImGearARTToolBarModes mode
)
public:
ImGearARTForms(
   ImGearPageView^ pageView,
   ImGearARTPage^ page,
   ImGearARTToolBarModes mode
)

Parameters

pageView
Reference to the page view control.
page
Reference to working annotation page.
mode
Specifies ART toolbar mode: legacy 2.0 marks or 3.0 marks.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
Overload List
ImGearPageView Class
ImGearARTPage Class
ImGearARTToolBarModes Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTForms Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class

For a list of all members of this type, see ImGearARTForms members.

Public Methods
 | Name | Description
Public Method | MouseDown | Provides mouse down interaction functionality.
Public Method | MouseMove | Provides mouse move interaction functionality.
Public Method | MouseUp | Provides mouse up interaction functionality.
Top
See Also

Reference

ImGearARTForms Class
ImageGear.ART.Forms Namespace


MouseDown Method (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseDown Method
Sender object.
Event arguments.
Provides mouse down interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearARTForms
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseDown(sender, e)
public void MouseDown(
   object sender,
   MouseEventArgs e
)
public: void MouseDown(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseDown(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseDown event handler.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseMove Method (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseMove Method
Sender object.
Event arguments.
Provides mouse move interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearARTForms
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseMove(sender, e)
public void MouseMove(
   object sender,
   MouseEventArgs e
)
public: void MouseMove(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseMove(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseMove event handler.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseUp Method (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseUp Method
Sender object.
Event arguments.
Provides mouse up interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearARTForms
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseUp(sender, e)
public void MouseUp(
   object sender,
   MouseEventArgs e
)
public: void MouseUp(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseUp(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseUp event handler.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


%%PageItemTitle%% $$Properties$$

ImGearARTForms Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class

For a list of all members of this type, see ImGearARTForms members.

Public Properties
 | Name | Description
Public Property | AggregateSelect | Gets or sets a value indicating whether the aggregate selection of annotations is allowed.
Public Property | ButtonAction | Gets or sets a reference to ButtonAction delegate if registered.
Public Property | HotSpotAction | Gets or sets a reference to HotSpotAction delegate if registered.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | Mode | Gets or sets the annotation mode.
Public Property | Page | Gets or sets a reference to the working annotation page.
Public Property | PageView | Gets or sets a reference to the page view control.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | Templates | Gets or sets the templates for creating annotations using the mouse.
Public Property | ToolBar | Gets or sets a reference to the annotation toolbar.
Top
See Also

Reference

ImGearARTForms Class
ImageGear.ART.Forms Namespace


AggregateSelect Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : AggregateSelect Property
Gets or sets a value indicating whether the aggregate selection of annotations is allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AggregateSelect As Boolean
'Usage

Dim instance As ImGearARTForms
Dim value As Boolean

instance.AggregateSelect = value

value = instance.AggregateSelect
public bool AggregateSelect {get; set;}
public: __property bool get_AggregateSelect();
public: __property void set_AggregateSelect(
   bool value
);
public:
property bool AggregateSelect {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


ButtonAction Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : ButtonAction Property
Gets or sets a reference to ButtonAction delegate if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ButtonAction As ImGearARTForms.DelegateButtonAction
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTForms.DelegateButtonAction

instance.ButtonAction = value

value = instance.ButtonAction
public ImGearARTForms.DelegateButtonAction ButtonAction {get; set;}
public: __property ImGearARTForms.DelegateButtonAction* get_ButtonAction();
public: __property void set_ButtonAction(
   ImGearARTForms.DelegateButtonAction* value
);
public:
property ImGearARTForms.DelegateButtonAction^ ButtonAction {
   ImGearARTForms.DelegateButtonAction^ get();
   void set (    ImGearARTForms.DelegateButtonAction^ value);
}

Property Value

ImGearARTForms.DelegateButtonAction delegate.
Remarks
It is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTForms.DelegateButtonAction Delegate


HotSpotAction Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : HotSpotAction Property
Gets or sets a reference to HotSpotAction delegate if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HotSpotAction As ImGearARTForms.DelegateHotSpotAction
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTForms.DelegateHotSpotAction

instance.HotSpotAction = value

value = instance.HotSpotAction
public ImGearARTForms.DelegateHotSpotAction HotSpotAction {get; set;}
public: __property ImGearARTForms.DelegateHotSpotAction* get_HotSpotAction();
public: __property void set_HotSpotAction(
   ImGearARTForms.DelegateHotSpotAction* value
);
public:
property ImGearARTForms.DelegateHotSpotAction^ HotSpotAction {
   ImGearARTForms.DelegateHotSpotAction^ get();
   void set (    ImGearARTForms.DelegateHotSpotAction^ value);
}

Property Value

ImGearARTForms.DelegateHotSpotAction delegate.
Remarks
It is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTForms.DelegateHotSpotAction Delegate


InteractionArea Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearARTInteractionArea
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearARTInteractionArea InteractionArea {get; set;}
public: __property ImGearARTInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearARTInteractionArea value
);
public:
property ImGearARTInteractionArea InteractionArea {
   ImGearARTInteractionArea get();
   void set (    ImGearARTInteractionArea value);
}

Property Value

ImGearARTInteractionArea enumeration value.
Remarks
The default value is ImGearARTInteractionArea .Device, which corresponds to the device area limited to page view control area. You can also choose to limit the annotation editing area to the image portion of the page view or keep it unlimited to the entire device. This affects creating, selecting, resizing, and moving annotations.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


IsPolylineAutoCloseEnabled Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : IsPolylineAutoCloseEnabled Property
Gets or sets a value indicating whether the polyline auto-close is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolylineAutoCloseEnabled As Boolean
'Usage

Dim instance As ImGearARTForms
Dim value As Boolean

instance.IsPolylineAutoCloseEnabled = value

value = instance.IsPolylineAutoCloseEnabled
public bool IsPolylineAutoCloseEnabled {get; set;}
public: __property bool get_IsPolylineAutoCloseEnabled();
public: __property void set_IsPolylineAutoCloseEnabled(
   bool value
);
public:
property bool IsPolylineAutoCloseEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the polyline mark is created. If true, then the mark is auto-completed and its "Closed" value is set to "true" when current mouse position is close to the starting poly mark point. In this case the PolyMarkPointRadiusThreshold properly should define a max distance, in pixels, between the current mouse position and the starting point position, to consider that poly mark creation process must be finished and the mark must be closed. The default value is false.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


IsPolyMarkAutoRollbackEnabled Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : IsPolyMarkAutoRollbackEnabled Property
Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolyMarkAutoRollbackEnabled As Boolean
'Usage

Dim instance As ImGearARTForms
Dim value As Boolean

instance.IsPolyMarkAutoRollbackEnabled = value

value = instance.IsPolyMarkAutoRollbackEnabled
public bool IsPolyMarkAutoRollbackEnabled {get; set;}
public: __property bool get_IsPolyMarkAutoRollbackEnabled();
public: __property void set_IsPolyMarkAutoRollbackEnabled(
   bool value
);
public:
property bool IsPolyMarkAutoRollbackEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the Curve, Polyline, Polygon, Polyruler or Freelhand line mark is created. If true, then the user has an ability to erase segments of poly mark by dragging mouse over recently drawn segments (for Freehand line) or by clicking on the point that starts the segment chain to be deleted. In this case the PolyMarkPointRadiusThreshold property should define a max distance, in pixels, between the current mouse position and one of the previously added points, to consider that user wants to remove a chain of segments. The default value is false.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


Mode Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : Mode Property
Gets or sets the annotation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As ImGearARTModes
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTModes

instance.Mode = value

value = instance.Mode
public ImGearARTModes Mode {get; set;}
public: __property ImGearARTModes get_Mode();
public: __property void set_Mode(
   ImGearARTModes value
);
public:
property ImGearARTModes Mode {
   ImGearARTModes get();
   void set (    ImGearARTModes value);
}

Property Value

ImGearARTModes enumeration value.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTModes Enumeration


Page Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : Page Property
Gets or sets a reference to the working annotation page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearARTPage
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTPage

instance.Page = value

value = instance.Page
public ImGearARTPage Page {get; set;}
public: __property ImGearARTPage* get_Page();
public: __property void set_Page(
   ImGearARTPage* value
);
public:
property ImGearARTPage^ Page {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImageGear.ART.ImGearARTPage class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTPage Class


PageView Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : PageView Property
Gets or sets a reference to the page view control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageView As ImGearPageView
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearPageView

instance.PageView = value

value = instance.PageView
public ImGearPageView PageView {get; set;}
public: __property ImGearPageView* get_PageView();
public: __property void set_PageView(
   ImGearPageView* value
);
public:
property ImGearPageView^ PageView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImageGear.Windows.Forms.ImGearPageView class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearPageView Class


PolyMarkAutoRollbackThreshold Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : PolyMarkAutoRollbackThreshold Property
Gets or sets a value indicating a poly mark loop auto- correction threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkAutoRollbackThreshold As Double
'Usage

Dim instance As ImGearARTForms
Dim value As Double

instance.PolyMarkAutoRollbackThreshold = value

value = instance.PolyMarkAutoRollbackThreshold
public double PolyMarkAutoRollbackThreshold {get; set;}
public: __property double get_PolyMarkAutoRollbackThreshold();
public: __property void set_PolyMarkAutoRollbackThreshold(
   double value
);
public:
property double PolyMarkAutoRollbackThreshold {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
This value indicates a min loop perimeter/area ratio for which the loop will be considered as correction and removed from the path. The smaller value shows that poly mark correction will be easier, but user wont be able to draw thin shapes; loop with relatively small area will be treated as correction and excluded from the polyline. Minimal possible value is 4*PI (that means round loop). With this threshold value any loop will be removed. The default value is 40 * PI.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


PolyMarkPointRadiusThreshold Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : PolyMarkPointRadiusThreshold Property
Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkPointRadiusThreshold As Integer
'Usage

Dim instance As ImGearARTForms
Dim value As Integer

instance.PolyMarkPointRadiusThreshold = value

value = instance.PolyMarkPointRadiusThreshold
public int PolyMarkPointRadiusThreshold {get; set;}
public: __property int get_PolyMarkPointRadiusThreshold();
public: __property void set_PolyMarkPointRadiusThreshold(
   int value
);
public:
property int PolyMarkPointRadiusThreshold {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Also see IsPolylineAutoCloseEnabled and IsPolyMarkAutoRollbackEnabled. The default value is 50.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


Templates Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : Templates Property
Gets or sets the templates for creating annotations using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Templates As ImGearARTMarkTemplates
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTMarkTemplates

instance.Templates = value

value = instance.Templates
public ImGearARTMarkTemplates Templates {get; set;}
public: __property ImGearARTMarkTemplates* get_Templates();
public: __property void set_Templates(
   ImGearARTMarkTemplates* value
);
public:
property ImGearARTMarkTemplates^ Templates {
   ImGearARTMarkTemplates^ get();
   void set (    ImGearARTMarkTemplates^ value);
}

Property Value

ImGearARTMarkTemplates class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTMarkTemplates Class


ToolBar Property (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : ToolBar Property
Gets or sets a reference to the annotation toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToolBar As ImGearARTToolBar
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTToolBar

instance.ToolBar = value

value = instance.ToolBar
public ImGearARTToolBar ToolBar {get; set;}
public: __property ImGearARTToolBar* get_ToolBar();
public: __property void set_ToolBar(
   ImGearARTToolBar* value
);
public:
property ImGearARTToolBar^ ToolBar {
   ImGearARTToolBar^ get();
   void set (    ImGearARTToolBar^ value);
}

Property Value

ImGearARTToolBar class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTToolBar Class


%%PageItemTitle%% $$Fields$$

ImGearARTForms Class Fields

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class

For a list of all members of this type, see ImGearARTForms members.

Public Fields
 | Name | Description
Public Field | PropertyDialog | Reference to the property dialog object.
Top
See Also

Reference

ImGearARTForms Class
ImageGear.ART.Forms Namespace


PropertyDialog Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : PropertyDialog Field
Reference to the property dialog object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PropertyDialog As ImGearARTPropertyDialog
'Usage

Dim instance As ImGearARTForms
Dim value As ImGearARTPropertyDialog

value = instance.PropertyDialog

instance.PropertyDialog = value
public ImGearARTPropertyDialog PropertyDialog
public: ImGearARTPropertyDialog* PropertyDialog
public:
ImGearARTPropertyDialog^ PropertyDialog

Field Value

ImGearARTPropertyDialog class object.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTPropertyDialog Class


%%PageItemTitle%% $$Events$$

ImGearARTForms Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms Class

For a list of all members of this type, see ImGearARTForms members.

Public Events
 | Name | Description
Public Event | MarkCreated | Occurs right after an annotation is created.
Public Event | MarkCreating | Occurs just before an annotation is created.
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseMoved | Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of an annotation mark.
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Top
See Also

Reference

ImGearARTForms Class
ImageGear.ART.Forms Namespace


MarkCreated Event

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MarkCreated Event
Occurs right after an annotation is created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkCreated As ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler

AddHandler instance.MarkCreated, handler
public event ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler MarkCreated
public: __event ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler* MarkCreated
public:
event ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler^ MarkCreated
Event Data

The event handler receives an argument of type ImGearARTFormsMarkCreatedEventArgs containing data related to this event. The following ImGearARTFormsMarkCreatedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Mark | Gets a reference to the annotation object being created.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler Delegate


MarkCreating Event (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MarkCreating Event
Occurs just before an annotation is created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkCreating As ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler

AddHandler instance.MarkCreating, handler
public event ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler MarkCreating
public: __event ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler* MarkCreating
public:
event ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler^ MarkCreating
Event Data

The event handler receives an argument of type ImGearARTFormsMarkCreatingEventArgs containing data related to this event. The following ImGearARTFormsMarkCreatingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Mark | Gets a reference to the annotation object being created.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members
ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler Delegate


MouseLeftButtonDown Event (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseLeftButtonDown Event
Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseLeftButtonDown As ImGearARTForms.ImGearARTFormsMouseEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMouseEventHandler

AddHandler instance.MouseLeftButtonDown, handler
public event ImGearARTForms.ImGearARTFormsMouseEventHandler MouseLeftButtonDown
public: __event ImGearARTForms.ImGearARTFormsMouseEventHandler* MouseLeftButtonDown
public:
event ImGearARTForms.ImGearARTFormsMouseEventHandler^ MouseLeftButtonDown
Event Data

The event handler receives an argument of type ImGearARTFormsMouseEventArgs containing data related to this event. The following ImGearARTFormsMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseLeftButtonUp Event (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseLeftButtonUp Event
Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseLeftButtonUp As ImGearARTForms.ImGearARTFormsMouseEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMouseEventHandler

AddHandler instance.MouseLeftButtonUp, handler
public event ImGearARTForms.ImGearARTFormsMouseEventHandler MouseLeftButtonUp
public: __event ImGearARTForms.ImGearARTFormsMouseEventHandler* MouseLeftButtonUp
public:
event ImGearARTForms.ImGearARTFormsMouseEventHandler^ MouseLeftButtonUp
Event Data

The event handler receives an argument of type ImGearARTFormsMouseEventArgs containing data related to this event. The following ImGearARTFormsMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseMoved Event

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseMoved Event
Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseMoved As ImGearARTForms.ImGearARTFormsMouseEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMouseEventHandler

AddHandler instance.MouseMoved, handler
public event ImGearARTForms.ImGearARTFormsMouseEventHandler MouseMoved
public: __event ImGearARTForms.ImGearARTFormsMouseEventHandler* MouseMoved
public:
event ImGearARTForms.ImGearARTFormsMouseEventHandler^ MouseMoved
Event Data

The event handler receives an argument of type ImGearARTFormsMouseEventArgs containing data related to this event. The following ImGearARTFormsMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseRightButtonDown Event (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseRightButtonDown Event
Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseRightButtonDown As ImGearARTForms.ImGearARTFormsMouseEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMouseEventHandler

AddHandler instance.MouseRightButtonDown, handler
public event ImGearARTForms.ImGearARTFormsMouseEventHandler MouseRightButtonDown
public: __event ImGearARTForms.ImGearARTFormsMouseEventHandler* MouseRightButtonDown
public:
event ImGearARTForms.ImGearARTFormsMouseEventHandler^ MouseRightButtonDown
Event Data

The event handler receives an argument of type ImGearARTFormsMouseEventArgs containing data related to this event. The following ImGearARTFormsMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


MouseRightButtonUp Event (ImGearARTForms)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTForms Class : MouseRightButtonUp Event
Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseRightButtonUp As ImGearARTForms.ImGearARTFormsMouseEventHandler
'Usage

Dim instance As ImGearARTForms
Dim handler As ImGearARTForms.ImGearARTFormsMouseEventHandler

AddHandler instance.MouseRightButtonUp, handler
public event ImGearARTForms.ImGearARTFormsMouseEventHandler MouseRightButtonUp
public: __event ImGearARTForms.ImGearARTFormsMouseEventHandler* MouseRightButtonUp
public:
event ImGearARTForms.ImGearARTFormsMouseEventHandler^ MouseRightButtonUp
Event Data

The event handler receives an argument of type ImGearARTFormsMouseEventArgs containing data related to this event. The following ImGearARTFormsMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

ImGearARTForms Class
ImGearARTForms Members


%%PageItemTitle%%

ImGearARTFormsCreateMarkData Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsCreateMarkData Class
This class provides mark creation data.
Object Model
ImGearARTFormsCreateMarkData ClassImGearARTForms ClassImGearARTFormsMouseEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsCreateMarkData
'Usage

Dim instance As ImGearARTFormsCreateMarkData
public class ImGearARTFormsCreateMarkData
public __gc class ImGearARTFormsCreateMarkData
public ref class ImGearARTFormsCreateMarkData
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsCreateMarkData

See Also

Reference

ImGearARTFormsCreateMarkData Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsCreateMarkData Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsCreateMarkData Class

The following tables list the members exposed by ImGearARTFormsCreateMarkData.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | CustomData | Gets or sets custom data.
Public Property | MouseArgs | Gets argument of latest mouse event.
Top
See Also

Reference

ImGearARTFormsCreateMarkData Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsCreateMarkData Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsCreateMarkData Class

For a list of all members of this type, see ImGearARTFormsCreateMarkData members.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | CustomData | Gets or sets custom data.
Public Property | MouseArgs | Gets argument of latest mouse event.
Top
See Also

Reference

ImGearARTFormsCreateMarkData Class
ImageGear.ART.Forms Namespace


Annotator Property (ImGearARTFormsCreateMarkData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsCreateMarkData Class : Annotator Property
Gets the annotator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotator As ImGearARTForms
'Usage

Dim instance As ImGearARTFormsCreateMarkData
Dim value As ImGearARTForms

value = instance.Annotator
public ImGearARTForms Annotator {get;}
public: __property ImGearARTForms* get_Annotator();
public:
property ImGearARTForms^ Annotator {
   ImGearARTForms^ get();
}

Property Value

ImGearARTForms object.
See Also

Reference

ImGearARTFormsCreateMarkData Class
ImGearARTFormsCreateMarkData Members
ImGearARTForms Class


CustomData Property (ImGearARTFormsCreateMarkData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsCreateMarkData Class : CustomData Property
Gets or sets custom data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomData As Object
'Usage

Dim instance As ImGearARTFormsCreateMarkData
Dim value As Object

instance.CustomData = value

value = instance.CustomData
public object CustomData {get; set;}
public: __property Object* get_CustomData();
public: __property void set_CustomData(
   Object* value
);
public:
property Object^ CustomData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property can be used to keep track of the state of the mark creation operation so that the current mark creation behavior can affect the behavior of the operation later.
See Also

Reference

ImGearARTFormsCreateMarkData Class
ImGearARTFormsCreateMarkData Members


MouseArgs Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsCreateMarkData Class : MouseArgs Property
Gets argument of latest mouse event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MouseArgs As ImGearARTFormsMouseEventArgs
'Usage

Dim instance As ImGearARTFormsCreateMarkData
Dim value As ImGearARTFormsMouseEventArgs

value = instance.MouseArgs
public ImGearARTFormsMouseEventArgs MouseArgs {get;}
public: __property ImGearARTFormsMouseEventArgs* get_MouseArgs();
public:
property ImGearARTFormsMouseEventArgs^ MouseArgs {
   ImGearARTFormsMouseEventArgs^ get();
}

Property Value

ImGearARTFormsMouseEventArgs class object.
See Also

Reference

ImGearARTFormsCreateMarkData Class
ImGearARTFormsCreateMarkData Members
ImGearARTFormsMouseEventArgs Class


%%PageItemTitle%%

ImGearARTFormsMarkController Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkController Class
Abstract class defining methods for mark's controller.
Object Model
ImGearARTFormsMarkController ClassImGearARTMark ClassImGearARTFormsMarkController ClassImGearARTFormsToolbarButtonInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTFormsMarkController
'Usage

Dim instance As ImGearARTFormsMarkController
public abstract class ImGearARTFormsMarkController
public __gc abstract class ImGearARTFormsMarkController
public ref class ImGearARTFormsMarkController abstract
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsMarkController
ImageGear.ART.Forms.ImGearARTFormsPolyController
ImageGear.ART.Forms.ImGearARTFormsRectangleController

See Also

Reference

ImGearARTFormsMarkController Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsMarkController Class Members
Properties Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkController Class

The following tables list the members exposed by ImGearARTFormsMarkController.

Public Properties
 | Name | Description
Public Property | ToolbarInfo | Gets an object providing a custom mark's toolbar button info.
Top
Public Methods
 | Name | Description
Public Method | CanCreateMark | Checks if a new mark can be created.
Public Method | CreateMark | Creates a mark using a given set of points.
Public Method | DrawPreview | Draws a schematic representation of the mark being created before it is created actually.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark annotator controller.
Public Method | GetPropertiesWindow | Returns a property window for a given mark.
Public Method | ManageCursor | Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
static (Shared in Visual Basic) | RegisterCustomController | Registers a controller for a custom mark type.
Public Method | Resize | Called by Annotator on Resize action.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | UpdateCursor | Checks if a given mouse point is over mark's point and changes a mouse cursor accordingly.
Top
See Also

Reference

ImGearARTFormsMarkController Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTFormsMarkController Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkController Class

For a list of all members of this type, see ImGearARTFormsMarkController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Checks if a new mark can be created.
Public Method | CreateMark | Creates a mark using a given set of points.
Public Method | DrawPreview | Draws a schematic representation of the mark being created before it is created actually.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark annotator controller.
Public Method | GetPropertiesWindow | Returns a property window for a given mark.
Public Method | ManageCursor | Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
static (Shared in Visual Basic) | RegisterCustomController | Registers a controller for a custom mark type.
Public Method | Resize | Called by Annotator on Resize action.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | UpdateCursor | Checks if a given mouse point is over mark's point and changes a mouse cursor accordingly.
Top
See Also

Reference

ImGearARTFormsMarkController Class
ImageGear.ART.Forms Namespace


CanCreateMark Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : CanCreateMark Method
Point already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createData As ImGearARTFormsCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearARTFormsMarkController
Dim points As IEnumerable(Of ImGearPoint)
Dim createData As ImGearARTFormsCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createData)
public virtual bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsCreateMarkData createData
)
public: virtual bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsCreateMarkData* createData
)
public:
virtual bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsCreateMarkData^ createData
)

Parameters

points
Point already entered by user.
createData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


CreateMark Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : CreateMark Method
Points list.
Data associated with create action.
Creates a mark using a given set of points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function CreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createData As ImGearARTFormsCreateMarkData _
) As ImGearARTMark
'Usage

Dim instance As ImGearARTFormsMarkController
Dim points As IEnumerable(Of ImGearPoint)
Dim createData As ImGearARTFormsCreateMarkData
Dim value As ImGearARTMark

value = instance.CreateMark(points, createData)
public virtual ImGearARTMark CreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsCreateMarkData createData
)
public: virtual ImGearARTMark* CreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsCreateMarkData* createData
)
public:
virtual ImGearARTMark^ CreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsCreateMarkData^ createData
)

Parameters

points
Points list.
createData
Data associated with create action.

Return Value

Newly created mark.
Remarks
When creating a custom mark annotation controller, user must override this method with custom mark's creation code.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


DrawPreview Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : DrawPreview Method
Mark's points that are already entered.
The draw preview data.
Draws a schematic representation of the mark being created before it is created actually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub DrawPreview( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal previewData As ImGearARTFormsPreviewData _
)
'Usage

Dim instance As ImGearARTFormsMarkController
Dim points As IEnumerable(Of ImGearPoint)
Dim previewData As ImGearARTFormsPreviewData

instance.DrawPreview(points, previewData)
public virtual void DrawPreview(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsPreviewData previewData
)
public: virtual void DrawPreview(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsPreviewData* previewData
)
public:
virtual void DrawPreview(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsPreviewData^ previewData
)

Parameters

points
Mark's points that are already entered.
previewData
The draw preview data.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


GetCustomController Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : GetCustomController Method
String representing the type of the custom mark.
Returns a registered custom mark annotator controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetCustomController( _
   ByVal userType As String _
) As ImGearARTFormsMarkController
'Usage

Dim userType As String
Dim value As ImGearARTFormsMarkController

value = ImGearARTFormsMarkController.GetCustomController(userType)
public static ImGearARTFormsMarkController GetCustomController(
   string userType
)
public: static ImGearARTFormsMarkController* GetCustomController(
   string* userType
)
public:
static ImGearARTFormsMarkController^ GetCustomController(
   String^ userType
)

Parameters

userType
String representing the type of the custom mark.

Return Value

Registered custom controller.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


GetPropertiesWindow Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : GetPropertiesWindow Method
Mark to edit.
ImageGear view (used as a parent for a new form).
Returns a property window for a given mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetPropertiesWindow( _
   ByVal mark As ImGearARTMark, _
   ByVal view As ImGearPageView _
) As Form
'Usage

Dim instance As ImGearARTFormsMarkController
Dim mark As ImGearARTMark
Dim view As ImGearPageView
Dim value As Form

value = instance.GetPropertiesWindow(mark, view)
public virtual Form GetPropertiesWindow(
   ImGearARTMark mark,
   ImGearPageView view
)
public: virtual Form* GetPropertiesWindow(
   ImGearARTMark* mark,
   ImGearPageView* view
)
public:
virtual Form^ GetPropertiesWindow(
   ImGearARTMark^ mark,
   ImGearPageView^ view
)

Parameters

mark
Mark to edit.
view
ImageGear view (used as a parent for a new form).

Return Value

A form with a given mark properties.
Remarks
For common marks it returns an existing property window included in Annotator. For custom mark user is responsible to implement his own property window.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


ManageCursor Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : ManageCursor Method
The mark the mouse is over.
The position of the mouse (in device pixels).
The mark controller data.
Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
)
'Usage

Dim instance As ImGearARTFormsMarkController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public virtual void ManageCursor(
   ImGearARTMark mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData markControllerData
)
public: virtual void ManageCursor(
   ImGearARTMark* mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData* markControllerData
)
public:
virtual void ManageCursor(
   ImGearARTMark^ mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData^ markControllerData
)

Parameters

mark
The mark the mouse is over.
mousePoint
The position of the mouse (in device pixels).
markControllerData
The mark controller data.
Remarks
You can override this method to check if the mouse is over a point in your custom mark. If it is, you can set the cursor parameter to specify which cursor to display, and you can set the ID of the point the cursor is over and the type of resizing to perform for the point. If the mouse is clicked, the specified point ID and resize type will be passed to the ImGearARTFormsMarkController.Resize method, which can use this information to modify the size of the mark or the position of a point in the mark. By default the point ID is set to -1 and the resize type is set to Point.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


RegisterCustomController Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : RegisterCustomController Method
String representing the type of the custom mark.
MarkAnnotatorController object.
Registers a controller for a custom mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterCustomController( _
   ByVal userType As String, _
   ByVal controller As ImGearARTFormsMarkController _
)
'Usage

Dim userType As String
Dim controller As ImGearARTFormsMarkController

ImGearARTFormsMarkController.RegisterCustomController(userType, controller)
public static void RegisterCustomController(
   string userType,
   ImGearARTFormsMarkController controller
)
public: static void RegisterCustomController(
   string* userType,
   ImGearARTFormsMarkController* controller
)
public:
static void RegisterCustomController(
   String^ userType,
   ImGearARTFormsMarkController^ controller
)

Parameters

userType
String representing the type of the custom mark.
controller
MarkAnnotatorController object.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


Resize Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : Resize Method
Mark to be resized.
Current position of the resized point/rectangle side.
The mark controller data.
Called by Annotator on Resize action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Resize( _
   ByVal mark As ImGearARTMark, _
   ByVal point As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
)
'Usage

Dim instance As ImGearARTFormsMarkController
Dim mark As ImGearARTMark
Dim point As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData

instance.Resize(mark, point, markControllerData)
public virtual void Resize(
   ImGearARTMark mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData markControllerData
)
public: virtual void Resize(
   ImGearARTMark* mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData* markControllerData
)
public:
virtual void Resize(
   ImGearARTMark^ mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData^ markControllerData
)

Parameters

mark
Mark to be resized.
point
Current position of the resized point/rectangle side.
markControllerData
The mark controller data.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


UpdateCursor Method (ImGearARTFormsMarkController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : UpdateCursor Method
Mark's point.
Mouse point.
The mark controller data.
Checks if a given mouse point is over mark's point and changes a mouse cursor accordingly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Shared Function UpdateCursor( _
   ByVal point As ImGearPoint, _
   ByVal mousePoint As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
) As Boolean
'Usage

Dim point As ImGearPoint
Dim mousePoint As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData
Dim value As Boolean

value = ImGearARTFormsMarkController.UpdateCursor(point, mousePoint, markControllerData)
protected static bool UpdateCursor(
   ImGearPoint point,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData markControllerData
)
protected: static bool UpdateCursor(
   ImGearPoint point,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData* markControllerData
)
protected:
static bool UpdateCursor(
   ImGearPoint point,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData^ markControllerData
)

Parameters

point
Mark's point.
mousePoint
Mouse point.
markControllerData
The mark controller data.

Return Value

True if mouse is over the given point.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


%%PageItemTitle%% $$Properties$$

ImGearARTFormsMarkController Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkController Class

For a list of all members of this type, see ImGearARTFormsMarkController members.

Public Properties
 | Name | Description
Public Property | ToolbarInfo | Gets an object providing a custom mark's toolbar button info.
Top
See Also

Reference

ImGearARTFormsMarkController Class
ImageGear.ART.Forms Namespace


ToolbarInfo Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkController Class : ToolbarInfo Property
Gets an object providing a custom mark's toolbar button info.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property ToolbarInfo As ImGearARTFormsToolbarButtonInfo
'Usage

Dim instance As ImGearARTFormsMarkController
Dim value As ImGearARTFormsToolbarButtonInfo

value = instance.ToolbarInfo
public virtual ImGearARTFormsToolbarButtonInfo ToolbarInfo {get;}
public: __property virtual ImGearARTFormsToolbarButtonInfo* get_ToolbarInfo();
public:
virtual property ImGearARTFormsToolbarButtonInfo^ ToolbarInfo {
   ImGearARTFormsToolbarButtonInfo^ get();
}

Property Value

ImGearARTFormsToolbarButtonInfo class object or null.
Remarks
This method is called by Annotator's toolbar when toolbar buttons are positioned.
See Also

Reference

ImGearARTFormsMarkController Class
ImGearARTFormsMarkController Members


%%PageItemTitle%%

ImGearARTFormsMarkControllerData Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkControllerData Class
This class provides mark controller data.
Object Model
ImGearARTFormsMarkControllerData ClassImGearARTForms Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsMarkControllerData
'Usage

Dim instance As ImGearARTFormsMarkControllerData
public class ImGearARTFormsMarkControllerData
public __gc class ImGearARTFormsMarkControllerData
public ref class ImGearARTFormsMarkControllerData
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsMarkControllerData

See Also

Reference

ImGearARTFormsMarkControllerData Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsMarkControllerData Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkControllerData Class

The following tables list the members exposed by ImGearARTFormsMarkControllerData.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | ClickPrecision | Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point.
Public Property | Cursor | Gets or sets the cursor to update.
Public Property | CustomData | Gets or sets custom data.
Public Property | PointId | Gets or sets the ID of the point in the mark that the cursor is over.
Public Property | ResizeType | Gets or sets the type of resizing to perform for this point.
Top
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsMarkControllerData Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkControllerData Class

For a list of all members of this type, see ImGearARTFormsMarkControllerData members.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | ClickPrecision | Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point.
Public Property | Cursor | Gets or sets the cursor to update.
Public Property | CustomData | Gets or sets custom data.
Public Property | PointId | Gets or sets the ID of the point in the mark that the cursor is over.
Public Property | ResizeType | Gets or sets the type of resizing to perform for this point.
Top
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImageGear.ART.Forms Namespace


Annotator Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : Annotator Property
Gets the annotator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotator As ImGearARTForms
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As ImGearARTForms

value = instance.Annotator
public ImGearARTForms Annotator {get;}
public: __property ImGearARTForms* get_Annotator();
public:
property ImGearARTForms^ Annotator {
   ImGearARTForms^ get();
}

Property Value

ImGearARTForms object.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members
ImGearARTForms Class


ClickPrecision Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : ClickPrecision Property
Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClickPrecision As Integer
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As Integer

instance.ClickPrecision = value

value = instance.ClickPrecision
public int ClickPrecision {get; set;}
public: __property int get_ClickPrecision();
public: __property void set_ClickPrecision(
   int value
);
public:
property int ClickPrecision {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members


Cursor Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : Cursor Property
Gets or sets the cursor to update.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

Cursor object.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members


CustomData Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : CustomData Property
Gets or sets custom data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomData As Object
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As Object

instance.CustomData = value

value = instance.CustomData
public object CustomData {get; set;}
public: __property Object* get_CustomData();
public: __property void set_CustomData(
   Object* value
);
public:
property Object^ CustomData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property can be used to keep track of the state of the resize or manage cursor operation so that the current resize or manage cursor behavior can affect the behavior of the operation later.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members


PointId Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : PointId Property
Gets or sets the ID of the point in the mark that the cursor is over.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PointId As Integer
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As Integer

instance.PointId = value

value = instance.PointId
public int PointId {get; set;}
public: __property int get_PointId();
public: __property void set_PointId(
   int value
);
public:
property int PointId {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members


ResizeType Property (ImGearARTFormsMarkControllerData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkControllerData Class : ResizeType Property
Gets or sets the type of resizing to perform for this point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResizeType As ImGearARTFormsResizeType
'Usage

Dim instance As ImGearARTFormsMarkControllerData
Dim value As ImGearARTFormsResizeType

instance.ResizeType = value

value = instance.ResizeType
public ImGearARTFormsResizeType ResizeType {get; set;}
public: __property ImGearARTFormsResizeType get_ResizeType();
public: __property void set_ResizeType(
   ImGearARTFormsResizeType value
);
public:
property ImGearARTFormsResizeType ResizeType {
   ImGearARTFormsResizeType get();
   void set (    ImGearARTFormsResizeType value);
}

Property Value

ResizeType value.
See Also

Reference

ImGearARTFormsMarkControllerData Class
ImGearARTFormsMarkControllerData Members


%%PageItemTitle%%

ImGearARTFormsMarkCreatedEventArgs Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatedEventArgs Class
Provides MarkCreated event data.
Object Model
ImGearARTFormsMarkCreatedEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsMarkCreatedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTFormsMarkCreatedEventArgs
public class ImGearARTFormsMarkCreatedEventArgs : System.EventArgs
public __gc class ImGearARTFormsMarkCreatedEventArgs : public System.EventArgs
public ref class ImGearARTFormsMarkCreatedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Forms.ImGearARTFormsMarkCreatedEventArgs

See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsMarkCreatedEventArgs Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatedEventArgs Class

The following tables list the members exposed by ImGearARTFormsMarkCreatedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFormsMarkCreatedEventArgs Constructor | Initializes a new instance of the ImGearARTFormsMarkCreatedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTFormsMarkCreatedEventArgs Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatedEventArgs Class : ImGearARTFormsMarkCreatedEventArgs Constructor
Reference to the annotation object being created.
Initializes a new instance of the ImGearARTFormsMarkCreatedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New ImGearARTFormsMarkCreatedEventArgs(mark)
public ImGearARTFormsMarkCreatedEventArgs(
   ImGearARTMark mark
)
public: ImGearARTFormsMarkCreatedEventArgs(
   ImGearARTMark* mark
)
public:
ImGearARTFormsMarkCreatedEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
Reference to the annotation object being created.
See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Class
ImGearARTFormsMarkCreatedEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearARTFormsMarkCreatedEventArgs Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatedEventArgs Class

For a list of all members of this type, see ImGearARTFormsMarkCreatedEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Class
ImageGear.ART.Forms Namespace


Cancel Property (ImGearARTFormsMarkCreatedEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatedEventArgs Class : Cancel Property
Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As ImGearARTFormsMarkCreatedEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set to true if you want to cancel the annotation creation, otherwise set to false.
See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Class
ImGearARTFormsMarkCreatedEventArgs Members


Mark Property (ImGearARTFormsMarkCreatedEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatedEventArgs Class : Mark Property
Gets a reference to the annotation object being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTFormsMarkCreatedEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class.
See Also

Reference

ImGearARTFormsMarkCreatedEventArgs Class
ImGearARTFormsMarkCreatedEventArgs Members


%%PageItemTitle%%

ImGearARTFormsMarkCreatingEventArgs Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatingEventArgs Class
Provides MarkCreating event data.
Object Model
ImGearARTFormsMarkCreatingEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsMarkCreatingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTFormsMarkCreatingEventArgs
public class ImGearARTFormsMarkCreatingEventArgs : System.EventArgs
public __gc class ImGearARTFormsMarkCreatingEventArgs : public System.EventArgs
public ref class ImGearARTFormsMarkCreatingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Forms.ImGearARTFormsMarkCreatingEventArgs

See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsMarkCreatingEventArgs Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatingEventArgs Class

The following tables list the members exposed by ImGearARTFormsMarkCreatingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFormsMarkCreatingEventArgs Constructor | Initializes a new instance of the ImGearARTFormsMarkCreatingEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTFormsMarkCreatingEventArgs Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatingEventArgs Class : ImGearARTFormsMarkCreatingEventArgs Constructor
Reference to the annotation object being created.
Initializes a new instance of the ImGearARTFormsMarkCreatingEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New ImGearARTFormsMarkCreatingEventArgs(mark)
public ImGearARTFormsMarkCreatingEventArgs(
   ImGearARTMark mark
)
public: ImGearARTFormsMarkCreatingEventArgs(
   ImGearARTMark* mark
)
public:
ImGearARTFormsMarkCreatingEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
Reference to the annotation object being created.
See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Class
ImGearARTFormsMarkCreatingEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearARTFormsMarkCreatingEventArgs Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMarkCreatingEventArgs Class

For a list of all members of this type, see ImGearARTFormsMarkCreatingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Class
ImageGear.ART.Forms Namespace


Cancel Property (ImGearARTFormsMarkCreatingEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatingEventArgs Class : Cancel Property
Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As ImGearARTFormsMarkCreatingEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set to true if you want to cancel the annotation creation, otherwise set to false.
See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Class
ImGearARTFormsMarkCreatingEventArgs Members


Mark Property (ImGearARTFormsMarkCreatingEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMarkCreatingEventArgs Class : Mark Property
Gets a reference to the annotation object being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTFormsMarkCreatingEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class.
See Also

Reference

ImGearARTFormsMarkCreatingEventArgs Class
ImGearARTFormsMarkCreatingEventArgs Members


%%PageItemTitle%%

ImGearARTFormsMouseEventArgs Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMouseEventArgs Class
Provides mouse event data.
Object Model
ImGearARTFormsMouseEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsMouseEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearARTFormsMouseEventArgs
public class ImGearARTFormsMouseEventArgs : System.EventArgs
public __gc class ImGearARTFormsMouseEventArgs : public System.EventArgs
public ref class ImGearARTFormsMouseEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Forms.ImGearARTFormsMouseEventArgs

See Also

Reference

ImGearARTFormsMouseEventArgs Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsMouseEventArgs Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMouseEventArgs Class

The following tables list the members exposed by ImGearARTFormsMouseEventArgs.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ImGearARTFormsMouseEventArgs Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsMouseEventArgs Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsMouseEventArgs Class

For a list of all members of this type, see ImGearARTFormsMouseEventArgs members.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ImGearARTFormsMouseEventArgs Class
ImageGear.ART.Forms Namespace


EventData Property (ImGearARTFormsMouseEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMouseEventArgs Class : EventData Property
Gets mouse event data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property EventData As MouseEventArgs
'Usage

Dim instance As ImGearARTFormsMouseEventArgs
Dim value As MouseEventArgs

value = instance.EventData
public MouseEventArgs EventData {get;}
public: __property MouseEventArgs* get_EventData();
public:
property MouseEventArgs^ EventData {
   MouseEventArgs^ get();
}

Property Value

System.Windows.Input.MouseEventArgs class object.
See Also

Reference

ImGearARTFormsMouseEventArgs Class
ImGearARTFormsMouseEventArgs Members


Mark Property (ImGearARTFormsMouseEventArgs)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsMouseEventArgs Class : Mark Property
Gets the annotation mark object the mouse pointer is over or null otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearARTFormsMouseEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class object.
See Also

Reference

ImGearARTFormsMouseEventArgs Class
ImGearARTFormsMouseEventArgs Members


%%PageItemTitle%%

ImGearARTFormsPolyController Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPolyController Class
Mark annotator controller that implements mouse interaction for marks defined by a set of points, like Polyline, Polygon etc.
Object Model
ImGearARTFormsPolyController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTFormsPolyController
   Inherits ImGearARTFormsMarkController
'Usage

Dim instance As ImGearARTFormsPolyController
public abstract class ImGearARTFormsPolyController : ImGearARTFormsMarkController
public __gc abstract class ImGearARTFormsPolyController : public ImGearARTFormsMarkController
public ref class ImGearARTFormsPolyController abstract : public ImGearARTFormsMarkController
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsMarkController
ImageGear.ART.Forms.ImGearARTFormsPolyController

See Also

Reference

ImGearARTFormsPolyController Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsPolyController Class Members
Properties Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPolyController Class

The following tables list the members exposed by ImGearARTFormsPolyController.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | DrawPreview | Overridden. Draws a schematic representation of the mark being created before it is created actually.
Public Method | ManageCursor | Overridden. Updates a cursor regarding the current mouse position in relation to mark.
Top
See Also

Reference

ImGearARTFormsPolyController Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsPolyController Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPolyController Class

For a list of all members of this type, see ImGearARTFormsPolyController members.

See Also

Reference

ImGearARTFormsPolyController Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTFormsPolyController Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPolyController Class

For a list of all members of this type, see ImGearARTFormsPolyController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | DrawPreview | Overridden. Draws a schematic representation of the mark being created before it is created actually.
Public Method | ManageCursor | Overridden. Updates a cursor regarding the current mouse position in relation to mark.
Top
See Also

Reference

ImGearARTFormsPolyController Class
ImageGear.ART.Forms Namespace


CanCreateMark Method (ImGearARTFormsPolyController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPolyController Class : CanCreateMark Method
Point already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createData As ImGearARTFormsCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearARTFormsPolyController
Dim points As IEnumerable(Of ImGearPoint)
Dim createData As ImGearARTFormsCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createData)
public override bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsCreateMarkData createData
)
public: bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsCreateMarkData* createData
) override
public:
bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsCreateMarkData^ createData
) override

Parameters

points
Point already entered by user.
createData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearARTFormsPolyController Class
ImGearARTFormsPolyController Members


DrawPreview Method (ImGearARTFormsPolyController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPolyController Class : DrawPreview Method
Mark's points that are already entered.
The draw preview data.
Draws a schematic representation of the mark being created before it is created actually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub DrawPreview( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal previewData As ImGearARTFormsPreviewData _
)
'Usage

Dim instance As ImGearARTFormsPolyController
Dim points As IEnumerable(Of ImGearPoint)
Dim previewData As ImGearARTFormsPreviewData

instance.DrawPreview(points, previewData)
public override void DrawPreview(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsPreviewData previewData
)
public: void DrawPreview(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsPreviewData* previewData
) override
public:
void DrawPreview(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsPreviewData^ previewData
) override

Parameters

points
Mark's points that are already entered.
previewData
The draw preview data.
See Also

Reference

ImGearARTFormsPolyController Class
ImGearARTFormsPolyController Members


ManageCursor Method (ImGearARTFormsPolyController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPolyController Class : ManageCursor Method
Mark under the mouse pointer.
Current mouse coordinates.
The mark controller data.
Updates a cursor regarding the current mouse position in relation to mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
)
'Usage

Dim instance As ImGearARTFormsPolyController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public override void ManageCursor(
   ImGearARTMark mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData markControllerData
)
public: void ManageCursor(
   ImGearARTMark* mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData* markControllerData
) override
public:
void ManageCursor(
   ImGearARTMark^ mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData^ markControllerData
) override

Parameters

mark
Mark under the mouse pointer.
mousePoint
Current mouse coordinates.
markControllerData
The mark controller data.
See Also

Reference

ImGearARTFormsPolyController Class
ImGearARTFormsPolyController Members


%%PageItemTitle%%

ImGearARTFormsPreviewData Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPreviewData Class
This class provides mark controller data.
Object Model
ImGearARTFormsPreviewData ClassImGearARTForms Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsPreviewData
'Usage

Dim instance As ImGearARTFormsPreviewData
public class ImGearARTFormsPreviewData
public __gc class ImGearARTFormsPreviewData
public ref class ImGearARTFormsPreviewData
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsPreviewData

See Also

Reference

ImGearARTFormsPreviewData Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsPreviewData Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPreviewData Class

The following tables list the members exposed by ImGearARTFormsPreviewData.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | CustomData | Gets or sets custom data.
Public Property | Graphics | Gets a graphics object on which mark's preview is to be drawn.
Top
See Also

Reference

ImGearARTFormsPreviewData Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsPreviewData Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsPreviewData Class

For a list of all members of this type, see ImGearARTFormsPreviewData members.

Public Properties
 | Name | Description
Public Property | Annotator | Gets the annotator object.
Public Property | CustomData | Gets or sets custom data.
Public Property | Graphics | Gets a graphics object on which mark's preview is to be drawn.
Top
See Also

Reference

ImGearARTFormsPreviewData Class
ImageGear.ART.Forms Namespace


Annotator Property (ImGearARTFormsPreviewData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPreviewData Class : Annotator Property
Gets the annotator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotator As ImGearARTForms
'Usage

Dim instance As ImGearARTFormsPreviewData
Dim value As ImGearARTForms

value = instance.Annotator
public ImGearARTForms Annotator {get;}
public: __property ImGearARTForms* get_Annotator();
public:
property ImGearARTForms^ Annotator {
   ImGearARTForms^ get();
}

Property Value

ImGearARTForms object.
See Also

Reference

ImGearARTFormsPreviewData Class
ImGearARTFormsPreviewData Members
ImGearARTForms Class


CustomData Property (ImGearARTFormsPreviewData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPreviewData Class : CustomData Property
Gets or sets custom data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomData As Object
'Usage

Dim instance As ImGearARTFormsPreviewData
Dim value As Object

instance.CustomData = value

value = instance.CustomData
public object CustomData {get; set;}
public: __property Object* get_CustomData();
public: __property void set_CustomData(
   Object* value
);
public:
property Object^ CustomData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property can be used to keep track of the state of the mark creation operation so that the current mark creation behavior can affect the behavior of the operation later.
See Also

Reference

ImGearARTFormsPreviewData Class
ImGearARTFormsPreviewData Members


Graphics Property (ImGearARTFormsPreviewData)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsPreviewData Class : Graphics Property
Gets a graphics object on which mark's preview is to be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As Graphics
'Usage

Dim instance As ImGearARTFormsPreviewData
Dim value As Graphics

value = instance.Graphics
public Graphics Graphics {get;}
public: __property Graphics* get_Graphics();
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Property Value

Graphics class object.
See Also

Reference

ImGearARTFormsPreviewData Class
ImGearARTFormsPreviewData Members


%%PageItemTitle%%

ImGearARTFormsRectangleController Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsRectangleController Class
Mark annotator controller that implements mouse interaction for marks with rectangular bounds, like Ellipse, Text etc.
Object Model
ImGearARTFormsRectangleController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTFormsRectangleController
   Inherits ImGearARTFormsMarkController
'Usage

Dim instance As ImGearARTFormsRectangleController
public abstract class ImGearARTFormsRectangleController : ImGearARTFormsMarkController
public __gc abstract class ImGearARTFormsRectangleController : public ImGearARTFormsMarkController
public ref class ImGearARTFormsRectangleController abstract : public ImGearARTFormsMarkController
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsMarkController
ImageGear.ART.Forms.ImGearARTFormsRectangleController

See Also

Reference

ImGearARTFormsRectangleController Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsRectangleController Class Members
Properties Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsRectangleController Class

The following tables list the members exposed by ImGearARTFormsRectangleController.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | DrawPreview | Overridden. Draws a schematic representation of the mark being created before it is created actually.
Public Method | ManageCursor | Overridden. Updates a cursor regarding the current mouse position in relation to mark.
Public Method | Resize | Overridden. Called by Annotator on Resize action.
Public Method | UpdateBounds | Updates size and position of a given mark.
Top
See Also

Reference

ImGearARTFormsRectangleController Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTFormsRectangleController Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsRectangleController Class

For a list of all members of this type, see ImGearARTFormsRectangleController members.

See Also

Reference

ImGearARTFormsRectangleController Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTFormsRectangleController Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsRectangleController Class

For a list of all members of this type, see ImGearARTFormsRectangleController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | DrawPreview | Overridden. Draws a schematic representation of the mark being created before it is created actually.
Public Method | ManageCursor | Overridden. Updates a cursor regarding the current mouse position in relation to mark.
Public Method | Resize | Overridden. Called by Annotator on Resize action.
Public Method | UpdateBounds | Updates size and position of a given mark.
Top
See Also

Reference

ImGearARTFormsRectangleController Class
ImageGear.ART.Forms Namespace


CanCreateMark Method (ImGearARTFormsRectangleController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsRectangleController Class : CanCreateMark Method
Point already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createData As ImGearARTFormsCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearARTFormsRectangleController
Dim points As IEnumerable(Of ImGearPoint)
Dim createData As ImGearARTFormsCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createData)
public override bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsCreateMarkData createData
)
public: bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsCreateMarkData* createData
) override
public:
bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsCreateMarkData^ createData
) override

Parameters

points
Point already entered by user.
createData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearARTFormsRectangleController Class
ImGearARTFormsRectangleController Members


DrawPreview Method (ImGearARTFormsRectangleController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsRectangleController Class : DrawPreview Method
Mark's points that are already entered.
The draw preview data.
Draws a schematic representation of the mark being created before it is created actually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub DrawPreview( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal previewData As ImGearARTFormsPreviewData _
)
'Usage

Dim instance As ImGearARTFormsRectangleController
Dim points As IEnumerable(Of ImGearPoint)
Dim previewData As ImGearARTFormsPreviewData

instance.DrawPreview(points, previewData)
public override void DrawPreview(
   IEnumerable<ImGearPoint> points,
   ImGearARTFormsPreviewData previewData
)
public: void DrawPreview(
   IEnumerable<ImGearPoint>* points,
   ImGearARTFormsPreviewData* previewData
) override
public:
void DrawPreview(
   IEnumerable<ImGearPoint>^ points,
   ImGearARTFormsPreviewData^ previewData
) override

Parameters

points
Mark's points that are already entered.
previewData
The draw preview data.
See Also

Reference

ImGearARTFormsRectangleController Class
ImGearARTFormsRectangleController Members


ManageCursor Method (ImGearARTFormsRectangleController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsRectangleController Class : ManageCursor Method
Mark under the mouse pointer.
Current mouse coordinates.
The mark controller data.
Updates a cursor regarding the current mouse position in relation to mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
)
'Usage

Dim instance As ImGearARTFormsRectangleController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public override void ManageCursor(
   ImGearARTMark mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData markControllerData
)
public: void ManageCursor(
   ImGearARTMark* mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData* markControllerData
) override
public:
void ManageCursor(
   ImGearARTMark^ mark,
   ImGearPoint mousePoint,
   ImGearARTFormsMarkControllerData^ markControllerData
) override

Parameters

mark
Mark under the mouse pointer.
mousePoint
Current mouse coordinates.
markControllerData
The mark controller data.
See Also

Reference

ImGearARTFormsRectangleController Class
ImGearARTFormsRectangleController Members


Resize Method (ImGearARTFormsRectangleController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsRectangleController Class : Resize Method
Mark to be resized.
Current position of the resized point/rectangle side.
The mark controller data.
Called by Annotator on Resize action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Resize( _
   ByVal mark As ImGearARTMark, _
   ByVal point As ImGearPoint, _
   ByVal markControllerData As ImGearARTFormsMarkControllerData _
)
'Usage

Dim instance As ImGearARTFormsRectangleController
Dim mark As ImGearARTMark
Dim point As ImGearPoint
Dim markControllerData As ImGearARTFormsMarkControllerData

instance.Resize(mark, point, markControllerData)
public override void Resize(
   ImGearARTMark mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData markControllerData
)
public: void Resize(
   ImGearARTMark* mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData* markControllerData
) override
public:
void Resize(
   ImGearARTMark^ mark,
   ImGearPoint point,
   ImGearARTFormsMarkControllerData^ markControllerData
) override

Parameters

mark
Mark to be resized.
point
Current position of the resized point/rectangle side.
markControllerData
The mark controller data.
See Also

Reference

ImGearARTFormsRectangleController Class
ImGearARTFormsRectangleController Members


UpdateBounds Method (ImGearARTFormsRectangleController)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsRectangleController Class : UpdateBounds Method
Mark which bounds are to be updated.
New bounds.
Updates size and position of a given mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub UpdateBounds( _
   ByVal mark As ImGearARTMark, _
   ByVal newBounds As IImGearRectangle _
)
'Usage

Dim instance As ImGearARTFormsRectangleController
Dim mark As ImGearARTMark
Dim newBounds As IImGearRectangle

instance.UpdateBounds(mark, newBounds)
public virtual void UpdateBounds(
   ImGearARTMark mark,
   IImGearRectangle newBounds
)
public: virtual void UpdateBounds(
   ImGearARTMark* mark,
   IImGearRectangle* newBounds
)
public:
virtual void UpdateBounds(
   ImGearARTMark^ mark,
   IImGearRectangle^ newBounds
)

Parameters

mark
Mark which bounds are to be updated.
newBounds
New bounds.
Remarks
User is responsible to implement this method to get the resize working.
See Also

Reference

ImGearARTFormsRectangleController Class
ImGearARTFormsRectangleController Members


%%PageItemTitle%%

ImGearARTFormsToolbarButtonInfo Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsToolbarButtonInfo Class
Contains iformation that is needed to create a mark's toolbar button.
Object Model
ImGearARTFormsToolbarButtonInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTFormsToolbarButtonInfo
'Usage

Dim instance As ImGearARTFormsToolbarButtonInfo
public class ImGearARTFormsToolbarButtonInfo
public __gc class ImGearARTFormsToolbarButtonInfo
public ref class ImGearARTFormsToolbarButtonInfo
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTFormsToolbarButtonInfo

See Also

Reference

ImGearARTFormsToolbarButtonInfo Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTFormsToolbarButtonInfo Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsToolbarButtonInfo Class

The following tables list the members exposed by ImGearARTFormsToolbarButtonInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTFormsToolbarButtonInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | Image | Gets or sets the icon for new button.
Public Property | Tooltip | Gets or sets the tooltip string that will be displayed when mouse is over the button.
Public Property | UserType | Gets or sets the mark's user type.
Top
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTFormsToolbarButtonInfo Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsToolbarButtonInfo Class : ImGearARTFormsToolbarButtonInfo Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTFormsToolbarButtonInfo()
public ImGearARTFormsToolbarButtonInfo()
public: ImGearARTFormsToolbarButtonInfo();
public:
ImGearARTFormsToolbarButtonInfo();
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImGearARTFormsToolbarButtonInfo Members


%%PageItemTitle%% $$Properties$$

ImGearARTFormsToolbarButtonInfo Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsToolbarButtonInfo Class

For a list of all members of this type, see ImGearARTFormsToolbarButtonInfo members.

Public Properties
 | Name | Description
Public Property | Image | Gets or sets the icon for new button.
Public Property | Tooltip | Gets or sets the tooltip string that will be displayed when mouse is over the button.
Public Property | UserType | Gets or sets the mark's user type.
Top
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImageGear.ART.Forms Namespace


Image Property (ImGearARTFormsToolbarButtonInfo)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsToolbarButtonInfo Class : Image Property
Gets or sets the icon for new button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As Bitmap
'Usage

Dim instance As ImGearARTFormsToolbarButtonInfo
Dim value As Bitmap

instance.Image = value

value = instance.Image
public Bitmap Image {get; set;}
public: __property Bitmap* get_Image();
public: __property void set_Image(
   Bitmap* value
);
public:
property Bitmap^ Image {
   Bitmap^ get();
   void set (    Bitmap^ value);
}

Property Value

Bitmap object.
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImGearARTFormsToolbarButtonInfo Members


Tooltip Property (ImGearARTFormsToolbarButtonInfo)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsToolbarButtonInfo Class : Tooltip Property
Gets or sets the tooltip string that will be displayed when mouse is over the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tooltip As String
'Usage

Dim instance As ImGearARTFormsToolbarButtonInfo
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
public string Tooltip {get; set;}
public: __property string* get_Tooltip();
public: __property void set_Tooltip(
   string* value
);
public:
property String^ Tooltip {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImGearARTFormsToolbarButtonInfo Members


UserType Property (ImGearARTFormsToolbarButtonInfo)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTFormsToolbarButtonInfo Class : UserType Property
Gets or sets the mark's user type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserType As String
'Usage

Dim instance As ImGearARTFormsToolbarButtonInfo
Dim value As String

instance.UserType = value

value = instance.UserType
public string UserType {get; set;}
public: __property string* get_UserType();
public: __property void set_UserType(
   string* value
);
public:
property String^ UserType {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearARTFormsToolbarButtonInfo Class
ImGearARTFormsToolbarButtonInfo Members


%%PageItemTitle%%

ImGearARTMarkTemplates Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTMarkTemplates Class
Provides templates for creating annotations using the mouse.
Object Model
ImGearARTMarkTemplates ClassImGearARTArrow ClassImGearARTAudio ClassImGearARTButton ClassImGearARTTextCallout ClassImGearARTCurve ClassImGearARTEllipse ClassImGearARTEncryption ClassImGearARTFilledEllipse ClassImGearARTFilledPolygon ClassImGearARTFilledRectangle ClassImGearARTPolyline ClassImGearARTHighlighter ClassImGearARTHollowEllipse ClassImGearARTHollowPolygon ClassImGearARTHollowRectangle ClassImGearARTHotSpot ClassImGearARTImage ClassImGearARTImageEmb ClassImGearARTImageRef ClassImGearARTLine ClassImGearARTNote ClassImGearARTPinUpText ClassImGearARTPoint ClassImGearARTPolygon ClassImGearARTPolyline ClassImGearARTPolyRuler ClassImGearARTPopupText ClassImGearARTProtractor ClassImGearARTRectangle ClassImGearARTRedaction ClassImGearARTRichText ClassImGearARTRuler ClassImGearARTTextStamp ClassImGearARTText ClassImGearARTTextFromFile ClassImGearARTTypedText Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTMarkTemplates
'Usage

Dim instance As ImGearARTMarkTemplates
public class ImGearARTMarkTemplates
public __gc class ImGearARTMarkTemplates
public ref class ImGearARTMarkTemplates
Remarks
This class can be used to specify a template for each mark that will be used when creating marks using the mouse. Some properties, such as the size, points, and location, are not used since those are determined when creating the mark. If a page resolution is specified for the Ruler or PolyRuler template, it will not be used; Ruler and PolyRuler marks use the page resolution of the currently displayed page.
Inheritance Hierarchy

System.Object
ImageGear.ART.Forms.ImGearARTMarkTemplates

See Also

Reference

ImGearARTMarkTemplates Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTMarkTemplates Class Members
Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTMarkTemplates Class

The following tables list the members exposed by ImGearARTMarkTemplates.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTMarkTemplates Constructor | Initializes a new instance of the ImGearARTMarkTemplates class with default settings.
Top
Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets an Arrow mark to be used as a template when creating Arrow marks using the mouse.
Public Property | Audio | Gets or sets an Audio mark to be used as a template when creating audio marks using the mouse.
Public Property | Button | Gets or sets a Button mark to be used as a template when creating marks using the mouse.
Public Property | Callout | Gets or sets a Callout Text mark to be used as a template when creating Text marks using the mouse.
Public Property | Curve | Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Public Property | Ellipse | Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Public Property | Encryption | Gets or sets a Encryption mark to be used as a template when creating marks using the mouse.
Public Property | FilledEllipse | Gets or sets a Filled Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Public Property | FilledPolygon | Gets or sets a Filled Polygon mark to be used as a template when creating polygon marks using the mouse.
Public Property | FilledRectangle | Gets or sets a Filled Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Freehand | Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Public Property | Highlight | Gets or sets a Highlighter mark to be used as a template when creating Highlighter marks using the mouse.
Public Property | HollowEllipse | Gets or sets a Hollow Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Public Property | HollowPolygon | Gets or sets a Hollow Polygon mark to be used as a template when creating polygon marks using the mouse.
Public Property | HollowRectangle | Gets or sets a Hollow Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | HotSpot | Gets or sets a HotSpot mark to be used as a template when creating marks using the mouse.
Public Property | Image | Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Public Property | ImageEmbedded | Gets or sets an Image Embedded mark to be used as a template when creating Image marks using the mouse.
Public Property | ImageReference | Gets or sets an Image Reference mark to be used as a template when creating Image marks using the mouse.
Public Property | Line | Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Public Property | Note | Gets or sets an Attach-a-note Text mark to be used as a template when creating Text marks using the mouse.
Public Property | PinUp | Gets or sets a PinUp Text mark to be used as a template when creating Text marks using the mouse.
Public Property | Point | Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Public Property | Polygon | Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Public Property | Polyline | Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Public Property | PolyRuler | Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Public Property | PopupText | Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Public Property | Protractor | Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Public Property | Rectangle | Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Redaction | Gets or sets a Redaction mark to be used as a template when creating Redaction marks using the mouse.
Public Property | RichText | Gets or sets a Rich Text mark to be used as a template when creating Rich Text marks using the mouse.
Public Property | Ruler | Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Public Property | Stamp | Gets or sets a Stamp mark to be used as a template when creating Text marks using the mouse.
Public Property | Text | Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Public Property | TextFromFile | Gets or sets a TextFromFile mark to be used as a template when creating Text marks using the mouse.
Public Property | TypedText | Gets or sets a Typed Text mark to be used as a template when creating Text marks using the mouse.
Top
See Also

Reference

ImGearARTMarkTemplates Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTMarkTemplates Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : ImGearARTMarkTemplates Constructor
Initializes a new instance of the ImGearARTMarkTemplates class with default settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearARTMarkTemplates()
public ImGearARTMarkTemplates()
public: ImGearARTMarkTemplates();
public:
ImGearARTMarkTemplates();
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


%%PageItemTitle%% $$Properties$$

ImGearARTMarkTemplates Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTMarkTemplates Class

For a list of all members of this type, see ImGearARTMarkTemplates members.

Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets an Arrow mark to be used as a template when creating Arrow marks using the mouse.
Public Property | Audio | Gets or sets an Audio mark to be used as a template when creating audio marks using the mouse.
Public Property | Button | Gets or sets a Button mark to be used as a template when creating marks using the mouse.
Public Property | Callout | Gets or sets a Callout Text mark to be used as a template when creating Text marks using the mouse.
Public Property | Curve | Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Public Property | Ellipse | Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Public Property | Encryption | Gets or sets a Encryption mark to be used as a template when creating marks using the mouse.
Public Property | FilledEllipse | Gets or sets a Filled Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Public Property | FilledPolygon | Gets or sets a Filled Polygon mark to be used as a template when creating polygon marks using the mouse.
Public Property | FilledRectangle | Gets or sets a Filled Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Freehand | Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Public Property | Highlight | Gets or sets a Highlighter mark to be used as a template when creating Highlighter marks using the mouse.
Public Property | HollowEllipse | Gets or sets a Hollow Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Public Property | HollowPolygon | Gets or sets a Hollow Polygon mark to be used as a template when creating polygon marks using the mouse.
Public Property | HollowRectangle | Gets or sets a Hollow Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | HotSpot | Gets or sets a HotSpot mark to be used as a template when creating marks using the mouse.
Public Property | Image | Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Public Property | ImageEmbedded | Gets or sets an Image Embedded mark to be used as a template when creating Image marks using the mouse.
Public Property | ImageReference | Gets or sets an Image Reference mark to be used as a template when creating Image marks using the mouse.
Public Property | Line | Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Public Property | Note | Gets or sets an Attach-a-note Text mark to be used as a template when creating Text marks using the mouse.
Public Property | PinUp | Gets or sets a PinUp Text mark to be used as a template when creating Text marks using the mouse.
Public Property | Point | Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Public Property | Polygon | Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Public Property | Polyline | Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Public Property | PolyRuler | Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Public Property | PopupText | Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Public Property | Protractor | Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Public Property | Rectangle | Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Redaction | Gets or sets a Redaction mark to be used as a template when creating Redaction marks using the mouse.
Public Property | RichText | Gets or sets a Rich Text mark to be used as a template when creating Rich Text marks using the mouse.
Public Property | Ruler | Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Public Property | Stamp | Gets or sets a Stamp mark to be used as a template when creating Text marks using the mouse.
Public Property | Text | Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Public Property | TextFromFile | Gets or sets a TextFromFile mark to be used as a template when creating Text marks using the mouse.
Public Property | TypedText | Gets or sets a Typed Text mark to be used as a template when creating Text marks using the mouse.
Top
See Also

Reference

ImGearARTMarkTemplates Class
ImageGear.ART.Forms Namespace


Arrow Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Arrow Property
Gets or sets an Arrow mark to be used as a template when creating Arrow marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Arrow As ImGearARTArrow
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTArrow

instance.Arrow = value

value = instance.Arrow
public ImGearARTArrow Arrow {get; set;}
public: __property ImGearARTArrow* get_Arrow();
public: __property void set_Arrow(
   ImGearARTArrow* value
);
public:
property ImGearARTArrow^ Arrow {
   ImGearARTArrow^ get();
   void set (    ImGearARTArrow^ value);
}

Property Value

ImGearARTArrow value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Audio Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Audio Property
Gets or sets an Audio mark to be used as a template when creating audio marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Audio As ImGearARTAudio
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTAudio

instance.Audio = value

value = instance.Audio
public ImGearARTAudio Audio {get; set;}
public: __property ImGearARTAudio* get_Audio();
public: __property void set_Audio(
   ImGearARTAudio* value
);
public:
property ImGearARTAudio^ Audio {
   ImGearARTAudio^ get();
   void set (    ImGearARTAudio^ value);
}

Property Value

ImGearARTAudio value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Button Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Button Property
Gets or sets a Button mark to be used as a template when creating marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Button As ImGearARTButton
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTButton

instance.Button = value

value = instance.Button
public ImGearARTButton Button {get; set;}
public: __property ImGearARTButton* get_Button();
public: __property void set_Button(
   ImGearARTButton* value
);
public:
property ImGearARTButton^ Button {
   ImGearARTButton^ get();
   void set (    ImGearARTButton^ value);
}

Property Value

ImGearARTButton value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Callout Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Callout Property
Gets or sets a Callout Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Callout As ImGearARTTextCallout
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTTextCallout

instance.Callout = value

value = instance.Callout
public ImGearARTTextCallout Callout {get; set;}
public: __property ImGearARTTextCallout* get_Callout();
public: __property void set_Callout(
   ImGearARTTextCallout* value
);
public:
property ImGearARTTextCallout^ Callout {
   ImGearARTTextCallout^ get();
   void set (    ImGearARTTextCallout^ value);
}

Property Value

ImGearARTTextCallout value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Curve Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Curve Property
Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Curve As ImGearARTCurve
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTCurve

instance.Curve = value

value = instance.Curve
public ImGearARTCurve Curve {get; set;}
public: __property ImGearARTCurve* get_Curve();
public: __property void set_Curve(
   ImGearARTCurve* value
);
public:
property ImGearARTCurve^ Curve {
   ImGearARTCurve^ get();
   void set (    ImGearARTCurve^ value);
}

Property Value

ImGearARTCurve value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Ellipse Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Ellipse Property
Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ellipse As ImGearARTEllipse
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTEllipse

instance.Ellipse = value

value = instance.Ellipse
public ImGearARTEllipse Ellipse {get; set;}
public: __property ImGearARTEllipse* get_Ellipse();
public: __property void set_Ellipse(
   ImGearARTEllipse* value
);
public:
property ImGearARTEllipse^ Ellipse {
   ImGearARTEllipse^ get();
   void set (    ImGearARTEllipse^ value);
}

Property Value

ImGearARTEllipse value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Encryption Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Encryption Property
Gets or sets a Encryption mark to be used as a template when creating marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encryption As ImGearARTEncryption
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTEncryption

instance.Encryption = value

value = instance.Encryption
public ImGearARTEncryption Encryption {get; set;}
public: __property ImGearARTEncryption* get_Encryption();
public: __property void set_Encryption(
   ImGearARTEncryption* value
);
public:
property ImGearARTEncryption^ Encryption {
   ImGearARTEncryption^ get();
   void set (    ImGearARTEncryption^ value);
}

Property Value

ImGearARTEncryption value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


FilledEllipse Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : FilledEllipse Property
Gets or sets a Filled Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FilledEllipse As ImGearARTFilledEllipse
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTFilledEllipse

instance.FilledEllipse = value

value = instance.FilledEllipse
public ImGearARTFilledEllipse FilledEllipse {get; set;}
public: __property ImGearARTFilledEllipse* get_FilledEllipse();
public: __property void set_FilledEllipse(
   ImGearARTFilledEllipse* value
);
public:
property ImGearARTFilledEllipse^ FilledEllipse {
   ImGearARTFilledEllipse^ get();
   void set (    ImGearARTFilledEllipse^ value);
}

Property Value

ImGearARTFilledEllipse value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


FilledPolygon Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : FilledPolygon Property
Gets or sets a Filled Polygon mark to be used as a template when creating polygon marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FilledPolygon As ImGearARTFilledPolygon
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTFilledPolygon

instance.FilledPolygon = value

value = instance.FilledPolygon
public ImGearARTFilledPolygon FilledPolygon {get; set;}
public: __property ImGearARTFilledPolygon* get_FilledPolygon();
public: __property void set_FilledPolygon(
   ImGearARTFilledPolygon* value
);
public:
property ImGearARTFilledPolygon^ FilledPolygon {
   ImGearARTFilledPolygon^ get();
   void set (    ImGearARTFilledPolygon^ value);
}

Property Value

ImGearARTFilledPolygon value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


FilledRectangle Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : FilledRectangle Property
Gets or sets a Filled Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FilledRectangle As ImGearARTFilledRectangle
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTFilledRectangle

instance.FilledRectangle = value

value = instance.FilledRectangle
public ImGearARTFilledRectangle FilledRectangle {get; set;}
public: __property ImGearARTFilledRectangle* get_FilledRectangle();
public: __property void set_FilledRectangle(
   ImGearARTFilledRectangle* value
);
public:
property ImGearARTFilledRectangle^ FilledRectangle {
   ImGearARTFilledRectangle^ get();
   void set (    ImGearARTFilledRectangle^ value);
}

Property Value

ImGearARTFilledRectangle value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Freehand Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Freehand Property
Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Freehand As ImGearARTPolyline
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPolyline

instance.Freehand = value

value = instance.Freehand
public ImGearARTPolyline Freehand {get; set;}
public: __property ImGearARTPolyline* get_Freehand();
public: __property void set_Freehand(
   ImGearARTPolyline* value
);
public:
property ImGearARTPolyline^ Freehand {
   ImGearARTPolyline^ get();
   void set (    ImGearARTPolyline^ value);
}

Property Value

ImGearARTPolyline value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Highlight Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Highlight Property
Gets or sets a Highlighter mark to be used as a template when creating Highlighter marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlight As ImGearARTHighlighter
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTHighlighter

instance.Highlight = value

value = instance.Highlight
public ImGearARTHighlighter Highlight {get; set;}
public: __property ImGearARTHighlighter* get_Highlight();
public: __property void set_Highlight(
   ImGearARTHighlighter* value
);
public:
property ImGearARTHighlighter^ Highlight {
   ImGearARTHighlighter^ get();
   void set (    ImGearARTHighlighter^ value);
}

Property Value

ImGearARTHighlighter value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


HollowEllipse Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : HollowEllipse Property
Gets or sets a Hollow Ellipse mark to be used as a template when creating ellipse marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HollowEllipse As ImGearARTHollowEllipse
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTHollowEllipse

instance.HollowEllipse = value

value = instance.HollowEllipse
public ImGearARTHollowEllipse HollowEllipse {get; set;}
public: __property ImGearARTHollowEllipse* get_HollowEllipse();
public: __property void set_HollowEllipse(
   ImGearARTHollowEllipse* value
);
public:
property ImGearARTHollowEllipse^ HollowEllipse {
   ImGearARTHollowEllipse^ get();
   void set (    ImGearARTHollowEllipse^ value);
}

Property Value

ImGearARTHollowEllipse value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


HollowPolygon Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : HollowPolygon Property
Gets or sets a Hollow Polygon mark to be used as a template when creating polygon marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HollowPolygon As ImGearARTHollowPolygon
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTHollowPolygon

instance.HollowPolygon = value

value = instance.HollowPolygon
public ImGearARTHollowPolygon HollowPolygon {get; set;}
public: __property ImGearARTHollowPolygon* get_HollowPolygon();
public: __property void set_HollowPolygon(
   ImGearARTHollowPolygon* value
);
public:
property ImGearARTHollowPolygon^ HollowPolygon {
   ImGearARTHollowPolygon^ get();
   void set (    ImGearARTHollowPolygon^ value);
}

Property Value

ImGearARTHollowPolygon value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


HollowRectangle Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : HollowRectangle Property
Gets or sets a Hollow Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HollowRectangle As ImGearARTHollowRectangle
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTHollowRectangle

instance.HollowRectangle = value

value = instance.HollowRectangle
public ImGearARTHollowRectangle HollowRectangle {get; set;}
public: __property ImGearARTHollowRectangle* get_HollowRectangle();
public: __property void set_HollowRectangle(
   ImGearARTHollowRectangle* value
);
public:
property ImGearARTHollowRectangle^ HollowRectangle {
   ImGearARTHollowRectangle^ get();
   void set (    ImGearARTHollowRectangle^ value);
}

Property Value

ImGearARTHollowRectangle value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


HotSpot Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : HotSpot Property
Gets or sets a HotSpot mark to be used as a template when creating marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HotSpot As ImGearARTHotSpot
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTHotSpot

instance.HotSpot = value

value = instance.HotSpot
public ImGearARTHotSpot HotSpot {get; set;}
public: __property ImGearARTHotSpot* get_HotSpot();
public: __property void set_HotSpot(
   ImGearARTHotSpot* value
);
public:
property ImGearARTHotSpot^ HotSpot {
   ImGearARTHotSpot^ get();
   void set (    ImGearARTHotSpot^ value);
}

Property Value

ImGearARTHotSpot value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Image Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Image Property
Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As ImGearARTImage
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTImage

instance.Image = value

value = instance.Image
public ImGearARTImage Image {get; set;}
public: __property ImGearARTImage* get_Image();
public: __property void set_Image(
   ImGearARTImage* value
);
public:
property ImGearARTImage^ Image {
   ImGearARTImage^ get();
   void set (    ImGearARTImage^ value);
}

Property Value

ImGearARTImage value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


ImageEmbedded Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : ImageEmbedded Property
Gets or sets an Image Embedded mark to be used as a template when creating Image marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageEmbedded As ImGearARTImageEmb
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTImageEmb

instance.ImageEmbedded = value

value = instance.ImageEmbedded
public ImGearARTImageEmb ImageEmbedded {get; set;}
public: __property ImGearARTImageEmb* get_ImageEmbedded();
public: __property void set_ImageEmbedded(
   ImGearARTImageEmb* value
);
public:
property ImGearARTImageEmb^ ImageEmbedded {
   ImGearARTImageEmb^ get();
   void set (    ImGearARTImageEmb^ value);
}

Property Value

ImGearARTImageEmb value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


ImageReference Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : ImageReference Property
Gets or sets an Image Reference mark to be used as a template when creating Image marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageReference As ImGearARTImageRef
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTImageRef

instance.ImageReference = value

value = instance.ImageReference
public ImGearARTImageRef ImageReference {get; set;}
public: __property ImGearARTImageRef* get_ImageReference();
public: __property void set_ImageReference(
   ImGearARTImageRef* value
);
public:
property ImGearARTImageRef^ ImageReference {
   ImGearARTImageRef^ get();
   void set (    ImGearARTImageRef^ value);
}

Property Value

ImGearARTImageRef value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Line Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Line Property
Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Line As ImGearARTLine
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTLine

instance.Line = value

value = instance.Line
public ImGearARTLine Line {get; set;}
public: __property ImGearARTLine* get_Line();
public: __property void set_Line(
   ImGearARTLine* value
);
public:
property ImGearARTLine^ Line {
   ImGearARTLine^ get();
   void set (    ImGearARTLine^ value);
}

Property Value

ImGearARTLine value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Note Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Note Property
Gets or sets an Attach-a-note Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Note As ImGearARTNote
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTNote

instance.Note = value

value = instance.Note
public ImGearARTNote Note {get; set;}
public: __property ImGearARTNote* get_Note();
public: __property void set_Note(
   ImGearARTNote* value
);
public:
property ImGearARTNote^ Note {
   ImGearARTNote^ get();
   void set (    ImGearARTNote^ value);
}

Property Value

ImGearARTNote value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


PinUp Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : PinUp Property
Gets or sets a PinUp Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PinUp As ImGearARTPinUpText
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPinUpText

instance.PinUp = value

value = instance.PinUp
public ImGearARTPinUpText PinUp {get; set;}
public: __property ImGearARTPinUpText* get_PinUp();
public: __property void set_PinUp(
   ImGearARTPinUpText* value
);
public:
property ImGearARTPinUpText^ PinUp {
   ImGearARTPinUpText^ get();
   void set (    ImGearARTPinUpText^ value);
}

Property Value

ImGearARTPinUpText value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Point Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Point Property
Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Point As ImGearARTPoint
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPoint

instance.Point = value

value = instance.Point
public ImGearARTPoint Point {get; set;}
public: __property ImGearARTPoint* get_Point();
public: __property void set_Point(
   ImGearARTPoint* value
);
public:
property ImGearARTPoint^ Point {
   ImGearARTPoint^ get();
   void set (    ImGearARTPoint^ value);
}

Property Value

ImGearARTPoint value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Polygon Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Polygon Property
Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polygon As ImGearARTPolygon
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPolygon

instance.Polygon = value

value = instance.Polygon
public ImGearARTPolygon Polygon {get; set;}
public: __property ImGearARTPolygon* get_Polygon();
public: __property void set_Polygon(
   ImGearARTPolygon* value
);
public:
property ImGearARTPolygon^ Polygon {
   ImGearARTPolygon^ get();
   void set (    ImGearARTPolygon^ value);
}

Property Value

ImGearARTPolygon value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Polyline Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Polyline Property
Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polyline As ImGearARTPolyline
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPolyline

instance.Polyline = value

value = instance.Polyline
public ImGearARTPolyline Polyline {get; set;}
public: __property ImGearARTPolyline* get_Polyline();
public: __property void set_Polyline(
   ImGearARTPolyline* value
);
public:
property ImGearARTPolyline^ Polyline {
   ImGearARTPolyline^ get();
   void set (    ImGearARTPolyline^ value);
}

Property Value

ImGearARTPolyline value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


PolyRuler Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : PolyRuler Property
Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyRuler As ImGearARTPolyRuler
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPolyRuler

instance.PolyRuler = value

value = instance.PolyRuler
public ImGearARTPolyRuler PolyRuler {get; set;}
public: __property ImGearARTPolyRuler* get_PolyRuler();
public: __property void set_PolyRuler(
   ImGearARTPolyRuler* value
);
public:
property ImGearARTPolyRuler^ PolyRuler {
   ImGearARTPolyRuler^ get();
   void set (    ImGearARTPolyRuler^ value);
}

Property Value

ImGearARTPolyRuler value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


PopupText Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : PopupText Property
Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupText As ImGearARTPopupText
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTPopupText

instance.PopupText = value

value = instance.PopupText
public ImGearARTPopupText PopupText {get; set;}
public: __property ImGearARTPopupText* get_PopupText();
public: __property void set_PopupText(
   ImGearARTPopupText* value
);
public:
property ImGearARTPopupText^ PopupText {
   ImGearARTPopupText^ get();
   void set (    ImGearARTPopupText^ value);
}

Property Value

ImGearARTPopupText value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Protractor Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Protractor Property
Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protractor As ImGearARTProtractor
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTProtractor

instance.Protractor = value

value = instance.Protractor
public ImGearARTProtractor Protractor {get; set;}
public: __property ImGearARTProtractor* get_Protractor();
public: __property void set_Protractor(
   ImGearARTProtractor* value
);
public:
property ImGearARTProtractor^ Protractor {
   ImGearARTProtractor^ get();
   void set (    ImGearARTProtractor^ value);
}

Property Value

ImGearARTProtractor value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Rectangle Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Rectangle Property
Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rectangle As ImGearARTRectangle
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTRectangle

instance.Rectangle = value

value = instance.Rectangle
public ImGearARTRectangle Rectangle {get; set;}
public: __property ImGearARTRectangle* get_Rectangle();
public: __property void set_Rectangle(
   ImGearARTRectangle* value
);
public:
property ImGearARTRectangle^ Rectangle {
   ImGearARTRectangle^ get();
   void set (    ImGearARTRectangle^ value);
}

Property Value

ImGearARTRectangle value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Redaction Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Redaction Property
Gets or sets a Redaction mark to be used as a template when creating Redaction marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Redaction As ImGearARTRedaction
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTRedaction

instance.Redaction = value

value = instance.Redaction
public ImGearARTRedaction Redaction {get; set;}
public: __property ImGearARTRedaction* get_Redaction();
public: __property void set_Redaction(
   ImGearARTRedaction* value
);
public:
property ImGearARTRedaction^ Redaction {
   ImGearARTRedaction^ get();
   void set (    ImGearARTRedaction^ value);
}

Property Value

ImGearARTRedaction value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


RichText Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : RichText Property
Gets or sets a Rich Text mark to be used as a template when creating Rich Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RichText As ImGearARTRichText
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTRichText

instance.RichText = value

value = instance.RichText
public ImGearARTRichText RichText {get; set;}
public: __property ImGearARTRichText* get_RichText();
public: __property void set_RichText(
   ImGearARTRichText* value
);
public:
property ImGearARTRichText^ RichText {
   ImGearARTRichText^ get();
   void set (    ImGearARTRichText^ value);
}

Property Value

ImGearARTRichText value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Ruler Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Ruler Property
Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ruler As ImGearARTRuler
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTRuler

instance.Ruler = value

value = instance.Ruler
public ImGearARTRuler Ruler {get; set;}
public: __property ImGearARTRuler* get_Ruler();
public: __property void set_Ruler(
   ImGearARTRuler* value
);
public:
property ImGearARTRuler^ Ruler {
   ImGearARTRuler^ get();
   void set (    ImGearARTRuler^ value);
}

Property Value

ImGearARTRuler value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Stamp Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Stamp Property
Gets or sets a Stamp mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stamp As ImGearARTTextStamp
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTTextStamp

instance.Stamp = value

value = instance.Stamp
public ImGearARTTextStamp Stamp {get; set;}
public: __property ImGearARTTextStamp* get_Stamp();
public: __property void set_Stamp(
   ImGearARTTextStamp* value
);
public:
property ImGearARTTextStamp^ Stamp {
   ImGearARTTextStamp^ get();
   void set (    ImGearARTTextStamp^ value);
}

Property Value

ImGearARTTextStamp value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


Text Property (ImGearARTMarkTemplates)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : Text Property
Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As ImGearARTText
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTText

instance.Text = value

value = instance.Text
public ImGearARTText Text {get; set;}
public: __property ImGearARTText* get_Text();
public: __property void set_Text(
   ImGearARTText* value
);
public:
property ImGearARTText^ Text {
   ImGearARTText^ get();
   void set (    ImGearARTText^ value);
}

Property Value

ImGearARTText value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


TextFromFile Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : TextFromFile Property
Gets or sets a TextFromFile mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextFromFile As ImGearARTTextFromFile
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTTextFromFile

instance.TextFromFile = value

value = instance.TextFromFile
public ImGearARTTextFromFile TextFromFile {get; set;}
public: __property ImGearARTTextFromFile* get_TextFromFile();
public: __property void set_TextFromFile(
   ImGearARTTextFromFile* value
);
public:
property ImGearARTTextFromFile^ TextFromFile {
   ImGearARTTextFromFile^ get();
   void set (    ImGearARTTextFromFile^ value);
}

Property Value

ImGearARTTextFromFile value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


TypedText Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTMarkTemplates Class : TypedText Property
Gets or sets a Typed Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TypedText As ImGearARTTypedText
'Usage

Dim instance As ImGearARTMarkTemplates
Dim value As ImGearARTTypedText

instance.TypedText = value

value = instance.TypedText
public ImGearARTTypedText TypedText {get; set;}
public: __property ImGearARTTypedText* get_TypedText();
public: __property void set_TypedText(
   ImGearARTTypedText* value
);
public:
property ImGearARTTypedText^ TypedText {
   ImGearARTTypedText^ get();
   void set (    ImGearARTTypedText^ value);
}

Property Value

ImGearARTTypedText value.
See Also

Reference

ImGearARTMarkTemplates Class
ImGearARTMarkTemplates Members


%%PageItemTitle%%

ImGearARTPropertyDialog Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTPropertyDialog Class
Represents GUI dialog class for accessing ART annotations properties.
Object Model
ImGearARTPropertyDialog Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPropertyDialog
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearARTPropertyDialog
public class ImGearARTPropertyDialog : System.Windows.Forms.Form
public __gc class ImGearARTPropertyDialog : public System.Windows.Forms.Form
public ref class ImGearARTPropertyDialog : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.ImGearARTPropertyDialog

See Also

Reference

ImGearARTPropertyDialog Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPropertyDialog Class Members
Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTPropertyDialog Class

The following tables list the members exposed by ImGearARTPropertyDialog.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTPropertyDialog Constructor | Initializes a new instance of the ImGearARTPropertyDialog class.
Top
See Also

Reference

ImGearARTPropertyDialog Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTPropertyDialog Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTPropertyDialog Class

For a list of all members of this type, see ImGearARTPropertyDialog members.

See Also

Reference

ImGearARTPropertyDialog Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTPropertyDialog Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTPropertyDialog Class : ImGearARTPropertyDialog Constructor
Reference to the page view control.
Reference to the annotation mark whose properties are requested.
Initializes a new instance of the ImGearARTPropertyDialog class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim pageView As ImGearPageView
Dim mark As ImGearARTMark

Dim instance As New ImGearARTPropertyDialog(pageView, mark)
public ImGearARTPropertyDialog(
   ImGearPageView pageView,
   ImGearARTMark mark
)
public: ImGearARTPropertyDialog(
   ImGearPageView* pageView,
   ImGearARTMark* mark
)
public:
ImGearARTPropertyDialog(
   ImGearPageView^ pageView,
   ImGearARTMark^ mark
)

Parameters

pageView
Reference to the page view control.
mark
Reference to the annotation mark whose properties are requested.

Return Value

The new instance of ImGearARTPropertyDialog class GUI object.
See Also

Reference

ImGearARTPropertyDialog Class
ImGearARTPropertyDialog Members
ImGearPageView Class
ImGearARTMark Class


%%PageItemTitle%% $$Methods$$

ImGearARTPropertyDialog Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTPropertyDialog Class

For a list of all members of this type, see ImGearARTPropertyDialog members.

See Also

Reference

ImGearARTPropertyDialog Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearARTPropertyDialog Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTPropertyDialog Class

For a list of all members of this type, see ImGearARTPropertyDialog members.

See Also

Reference

ImGearARTPropertyDialog Class
ImageGear.ART.Forms Namespace


Dispose Method (ImGearARTPropertyDialog)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTPropertyDialog Class : Dispose Method
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearARTPropertyDialog Class
ImGearARTPropertyDialog Members


Dispose(Boolean) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTPropertyDialog Class > Dispose Method : Dispose(Boolean) Method
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearARTPropertyDialog
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Remarks
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearARTPropertyDialog Class
ImGearARTPropertyDialog Members
Overload List


%%PageItemTitle%%

ImGearARTRTFToolBar Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTRTFToolBar Class
Represents toolbar for editing text and style of the RTF annotations.
Object Model
ImGearARTRTFToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTRTFToolBar
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearARTRTFToolBar
public class ImGearARTRTFToolBar : System.Windows.Forms.Form
public __gc class ImGearARTRTFToolBar : public System.Windows.Forms.Form
public ref class ImGearARTRTFToolBar : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.ImGearARTRTFToolBar

See Also

Reference

ImGearARTRTFToolBar Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTRTFToolBar Class Members
Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTRTFToolBar Class

The following tables list the members exposed by ImGearARTRTFToolBar.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTRTFToolBar Constructor | Overloaded.
Top
See Also

Reference

ImGearARTRTFToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTRTFToolBar Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTRTFToolBar Class

For a list of all members of this type, see ImGearARTRTFToolBar members.

See Also

Reference

ImGearARTRTFToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTRTFToolBar Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTRTFToolBar Class : ImGearARTRTFToolBar Constructor
Overload List
Overload | Description
ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichText) | Initializes a new instance of the ImGearARTRTFToolBar class object.
ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichTextControl) | This constructor has been deprecated. Initializes a new instance of the ImGearARTRTFToolBar class object.
See Also

Reference

ImGearARTRTFToolBar Class
ImGearARTRTFToolBar Members


%%PageItemTitle%%

ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichText)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTRTFToolBar Class > ImGearARTRTFToolBar Constructor : ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichText)
Reference to the page view control.
Reference to RTF annotation object to edit.
Initializes a new instance of the ImGearARTRTFToolBar class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal richText As ImGearARTRichText _
)
'Usage

Dim pageView As ImGearPageView
Dim richText As ImGearARTRichText

Dim instance As New ImGearARTRTFToolBar(pageView, richText)
public ImGearARTRTFToolBar(
   ImGearPageView pageView,
   ImGearARTRichText richText
)
public: ImGearARTRTFToolBar(
   ImGearPageView* pageView,
   ImGearARTRichText* richText
)
public:
ImGearARTRTFToolBar(
   ImGearPageView^ pageView,
   ImGearARTRichText^ richText
)

Parameters

pageView
Reference to the page view control.
richText
Reference to RTF annotation object to edit.
Remarks
This constructor creates a new instance of ImGearARTRTFToolBar class object.
See Also

Reference

ImGearARTRTFToolBar Class
ImGearARTRTFToolBar Members
Overload List
ImGearPageView Class
ImGearARTRichText Class


%%PageItemTitle%%

ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichTextControl)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTRTFToolBar Class > ImGearARTRTFToolBar Constructor : ImGearARTRTFToolBar Constructor(ImGearPageView,ImGearARTRichTextControl)
Reference to the page view control.
Reference to RTF annotation object to edit.
This constructor has been deprecated. Initializes a new instance of the ImGearARTRTFToolBar class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use ImGearARTRTFToolBar(ImGearPageView, ImGearARTRichText) instead.")>
Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal control As ImGearARTRichTextControl _
)
'Usage

Dim pageView As ImGearPageView
Dim control As ImGearARTRichTextControl

Dim instance As New ImGearARTRTFToolBar(pageView, control)
[Obsolete("Use ImGearARTRTFToolBar(ImGearPageView, ImGearARTRichText) instead.")]
public ImGearARTRTFToolBar(
   ImGearPageView pageView,
   ImGearARTRichTextControl control
)
[Obsolete("Use ImGearARTRTFToolBar(ImGearPageView, ImGearARTRichText) instead.")]
public: ImGearARTRTFToolBar(
   ImGearPageView* pageView,
   ImGearARTRichTextControl* control
)
[Obsolete("Use ImGearARTRTFToolBar(ImGearPageView, ImGearARTRichText) instead.")]
public:
ImGearARTRTFToolBar(
   ImGearPageView^ pageView,
   ImGearARTRichTextControl^ control
)

Parameters

pageView
Reference to the page view control.
control
Reference to RTF annotation object to edit.
Remarks

NOTE:

This ImGearARTRTFToolBar constructor is deprecated and will be removed from the public API in the next release. Please use ImGearARTRTFToolBar constructor instead.

See Also

Reference

ImGearARTRTFToolBar Class
ImGearARTRTFToolBar Members
Overload List
ImGearPageView Class
ImGearARTRichTextControl Class


%%PageItemTitle%% $$Methods$$

ImGearARTRTFToolBar Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTRTFToolBar Class

For a list of all members of this type, see ImGearARTRTFToolBar members.

See Also

Reference

ImGearARTRTFToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearARTRTFToolBar Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTRTFToolBar Class

For a list of all members of this type, see ImGearARTRTFToolBar members.

See Also

Reference

ImGearARTRTFToolBar Class
ImageGear.ART.Forms Namespace


Dispose Method (ImGearARTRTFToolBar)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTRTFToolBar Class : Dispose Method
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearARTRTFToolBar Class
ImGearARTRTFToolBar Members


Dispose(Boolean) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTRTFToolBar Class > Dispose Method : Dispose(Boolean) Method
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearARTRTFToolBar
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Remarks
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearARTRTFToolBar Class
ImGearARTRTFToolBar Members
Overload List


%%PageItemTitle%%

ImGearARTToolBar Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class
Represents toolbar for creating, selecting and editing ART annotations.
Object Model
ImGearARTToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTToolBar
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearARTToolBar
public class ImGearARTToolBar : System.Windows.Forms.Form
public __gc class ImGearARTToolBar : public System.Windows.Forms.Form
public ref class ImGearARTToolBar : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.ImGearARTToolBar

See Also

Reference

ImGearARTToolBar Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTToolBar Class Members
Fields Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class

The following tables list the members exposed by ImGearARTToolBar.

Public Constructors
 | Name | Description
Public Constructor | ImGearARTToolBar Constructor | Initializes a new instance of the ImGearARTToolBar class object.
Top
Public Fields
 | Name | Description
Public Field | btnSelect | Reference to select button object.
Public Field | Button | Reference to the currectly selected toolbar button.
Public Field | NotifyCreateMark | Specifies a reference to ImGearARTToolBar.DelegateCreateMark delegate, if registered.
Public Field | NotifyDeleteMark | Specifies a reference to ImGearARTToolBar.DelegateDeleteMark delegate, if registered.
Public Field | NotifyModifyMark | Specifies a reference to ImGearARTToolBar.DelegateModifyMark delegate, if registered.
Public Field | NotifyPreCreateMark | Specifies a reference to ImGearARTToolBar.DelegatePreCreateMark delegate, if registered.
Public Field | NotifySelect | Specifies a reference to ImGearARTToolBar.DelegateSelect delegate, if registered.
Public Field | UserType | Custom mark type name.
Top
Public Methods
 | Name | Description
Public Method | IsButtonVisible | Returns visible state of a button corresponding to a given mark type.
Public Method | SetButtonVisible | Sets visible state of a button corresponding to a given mark type.
Top
See Also

Reference

ImGearARTToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTToolBar Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : ImGearARTToolBar Constructor
ART toolbar mode.
Initializes a new instance of the ImGearARTToolBar class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mode As ImGearARTToolBarModes _
)
'Usage

Dim mode As ImGearARTToolBarModes

Dim instance As New ImGearARTToolBar(mode)
public ImGearARTToolBar(
   ImGearARTToolBarModes mode
)
public: ImGearARTToolBar(
   ImGearARTToolBarModes mode
)
public:
ImGearARTToolBar(
   ImGearARTToolBarModes mode
)

Parameters

mode
ART toolbar mode.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBarModes Enumeration


%%PageItemTitle%% $$Methods$$

ImGearARTToolBar Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class

For a list of all members of this type, see ImGearARTToolBar members.

Public Methods
 | Name | Description
Public Method | IsButtonVisible | Returns visible state of a button corresponding to a given mark type.
Public Method | SetButtonVisible | Sets visible state of a button corresponding to a given mark type.
Top
See Also

Reference

ImGearARTToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearARTToolBar Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class

For a list of all members of this type, see ImGearARTToolBar members.

See Also

Reference

ImGearARTToolBar Class
ImageGear.ART.Forms Namespace


Dispose Method (ImGearARTToolBar)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : Dispose Method
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members


Dispose(Boolean) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class > Dispose Method : Dispose(Boolean) Method
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearARTToolBar
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Remarks
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
Overload List


IsButtonVisible Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : IsButtonVisible Method
The mark type.
Returns visible state of a button corresponding to a given mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsButtonVisible( _
   ByVal markType As ImGearARTMarkType _
) As Boolean
'Usage

Dim instance As ImGearARTToolBar
Dim markType As ImGearARTMarkType
Dim value As Boolean

value = instance.IsButtonVisible(markType)
public bool IsButtonVisible(
   ImGearARTMarkType markType
)
public: bool IsButtonVisible(
   ImGearARTMarkType markType
)
public:
bool IsButtonVisible(
   ImGearARTMarkType markType
)

Parameters

markType
The mark type.

Return Value

Boolean value.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTMarkType Enumeration


SetButtonVisible Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : SetButtonVisible Method
The mark type.
Visible state of a button.
Sets visible state of a button corresponding to a given mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetButtonVisible( _
   ByVal markType As ImGearARTMarkType, _
   ByVal visible As Boolean _
)
'Usage

Dim instance As ImGearARTToolBar
Dim markType As ImGearARTMarkType
Dim visible As Boolean

instance.SetButtonVisible(markType, visible)
public void SetButtonVisible(
   ImGearARTMarkType markType,
   bool visible
)
public: void SetButtonVisible(
   ImGearARTMarkType markType,
   bool visible
)
public:
void SetButtonVisible(
   ImGearARTMarkType markType,
   bool visible
)

Parameters

markType
The mark type.
visible
Visible state of a button.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTMarkType Enumeration


%%PageItemTitle%% $$Fields$$

ImGearARTToolBar Class Fields

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class

For a list of all members of this type, see ImGearARTToolBar members.

Public Fields
 | Name | Description
Public Field | btnSelect | Reference to select button object.
Public Field | Button | Reference to the currectly selected toolbar button.
Public Field | NotifyCreateMark | Specifies a reference to ImGearARTToolBar.DelegateCreateMark delegate, if registered.
Public Field | NotifyDeleteMark | Specifies a reference to ImGearARTToolBar.DelegateDeleteMark delegate, if registered.
Public Field | NotifyModifyMark | Specifies a reference to ImGearARTToolBar.DelegateModifyMark delegate, if registered.
Public Field | NotifyPreCreateMark | Specifies a reference to ImGearARTToolBar.DelegatePreCreateMark delegate, if registered.
Public Field | NotifySelect | Specifies a reference to ImGearARTToolBar.DelegateSelect delegate, if registered.
Public Field | UserType | Custom mark type name.
Top
See Also

Reference

ImGearARTToolBar Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearARTToolBar Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar Class

For a list of all members of this type, see ImGearARTToolBar members.

See Also

Reference

ImGearARTToolBar Class
ImageGear.ART.Forms Namespace


btnSelect Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : btnSelect Field
Reference to select button object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public btnSelect As Button
'Usage

Dim instance As ImGearARTToolBar
Dim value As Button

value = instance.btnSelect

instance.btnSelect = value
public Button btnSelect
public: Button* btnSelect
public:
Button^ btnSelect

Field Value

System.Windows.Forms.Button value.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members


Button Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : Button Field
Reference to the currectly selected toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Button As ImGearARTMarkType
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTMarkType

value = instance.Button

instance.Button = value
public ImGearARTMarkType Button
public: ImGearARTMarkType Button
public:
ImGearARTMarkType Button

Field Value

ImageGear.ART.ImGearARTMarkType enumeration value.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTMarkType Enumeration


NotifyCreateMark Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : NotifyCreateMark Field
Specifies a reference to ImGearARTToolBar.DelegateCreateMark delegate, if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotifyCreateMark As ImGearARTToolBar.DelegateCreateMark
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTToolBar.DelegateCreateMark

value = instance.NotifyCreateMark

instance.NotifyCreateMark = value
public ImGearARTToolBar.DelegateCreateMark NotifyCreateMark
public: ImGearARTToolBar.DelegateCreateMark* NotifyCreateMark
public:
ImGearARTToolBar.DelegateCreateMark^ NotifyCreateMark

Field Value

ImGearARTToolBar.DelegateCreateMark delegate value.
Remarks
This delegate is automatically called from the ART forms when the user creates a mark.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBar.DelegateCreateMark Delegate


NotifyDeleteMark Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : NotifyDeleteMark Field
Specifies a reference to ImGearARTToolBar.DelegateDeleteMark delegate, if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotifyDeleteMark As ImGearARTToolBar.DelegateDeleteMark
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTToolBar.DelegateDeleteMark

value = instance.NotifyDeleteMark

instance.NotifyDeleteMark = value
public ImGearARTToolBar.DelegateDeleteMark NotifyDeleteMark
public: ImGearARTToolBar.DelegateDeleteMark* NotifyDeleteMark
public:
ImGearARTToolBar.DelegateDeleteMark^ NotifyDeleteMark

Field Value

ImGearARTToolBar.DelegateDeleteMark delegate value.
Remarks
This delegate is automatically called from the ART forms when the user deletes a mark.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBar.DelegateDeleteMark Delegate


NotifyModifyMark Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : NotifyModifyMark Field
Specifies a reference to ImGearARTToolBar.DelegateModifyMark delegate, if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotifyModifyMark As ImGearARTToolBar.DelegateModifyMark
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTToolBar.DelegateModifyMark

value = instance.NotifyModifyMark

instance.NotifyModifyMark = value
public ImGearARTToolBar.DelegateModifyMark NotifyModifyMark
public: ImGearARTToolBar.DelegateModifyMark* NotifyModifyMark
public:
ImGearARTToolBar.DelegateModifyMark^ NotifyModifyMark

Field Value

ImGearARTToolBar.DelegateModifyMark delegate value.
Remarks
This delegate is automatically called from the ART forms when the user modifies a mark.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBar.DelegateModifyMark Delegate


NotifyPreCreateMark Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : NotifyPreCreateMark Field
Specifies a reference to ImGearARTToolBar.DelegatePreCreateMark delegate, if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotifyPreCreateMark As ImGearARTToolBar.DelegatePreCreateMark
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTToolBar.DelegatePreCreateMark

value = instance.NotifyPreCreateMark

instance.NotifyPreCreateMark = value
public ImGearARTToolBar.DelegatePreCreateMark NotifyPreCreateMark
public: ImGearARTToolBar.DelegatePreCreateMark* NotifyPreCreateMark
public:
ImGearARTToolBar.DelegatePreCreateMark^ NotifyPreCreateMark

Field Value

ImGearARTToolBar.DelegatePreCreateMark delegate value.
Remarks
This delegate is automatically called from the ART forms when the user is about to create a mark. It can be used to change a mark's default attributes before its creation.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBar.DelegatePreCreateMark Delegate


NotifySelect Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : NotifySelect Field
Specifies a reference to ImGearARTToolBar.DelegateSelect delegate, if registered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotifySelect As ImGearARTToolBar.DelegateSelect
'Usage

Dim instance As ImGearARTToolBar
Dim value As ImGearARTToolBar.DelegateSelect

value = instance.NotifySelect

instance.NotifySelect = value
public ImGearARTToolBar.DelegateSelect NotifySelect
public: ImGearARTToolBar.DelegateSelect* NotifySelect
public:
ImGearARTToolBar.DelegateSelect^ NotifySelect

Field Value

ImGearARTToolBar.DelegateSelect delegate value.
Remarks
This delegate is automatically called from the ART forms when the user clicks toolbar button to select a mark type.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members
ImGearARTToolBar.DelegateSelect Delegate


UserType Field

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > ImGearARTToolBar Class : UserType Field
Custom mark type name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UserType As String
'Usage

Dim instance As ImGearARTToolBar
Dim value As String

value = instance.UserType

instance.UserType = value
public string UserType
public: string* UserType
public:
String^ UserType
Remarks
If the currently select button os one of the custom marks, it contains a custom mark type name, otherwise it's an empty string.
See Also

Reference

ImGearARTToolBar Class
ImGearARTToolBar Members


%%PageItemTitle%%

InputBox Class
Members

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox Class
Represents a window for prompting the user for an input string.
Object Model
InputBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class InputBox
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As InputBox
public class InputBox : System.Windows.Forms.Form
public __gc class InputBox : public System.Windows.Forms.Form
public ref class InputBox : public System.Windows.Forms.Form
Remarks
It can be used to gather simple text or numeric input from the user without the need for creating a custom window.

It can also provide a search interface if the appropriate constructor used. In this case, a Find button is shown instead of an OK button. When the Find button is clicked, the given FindProc method is called and the window is not closed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.ART.Forms.InputBox

See Also

Reference

InputBox Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Members$$

InputBox Class Members
Properties Methods Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox Class

The following tables list the members exposed by InputBox.

Public Constructors
 | Name | Description
Public Constructor | InputBox Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DlgText | Gets content of the edit box where the user can enter a string.
Top
See Also

Reference

InputBox Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

InputBox Constructor

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class : InputBox Constructor
Overload List
Overload | Description
InputBox Constructor(String,String,String,Boolean) | Initializes a new instance of the InputBox class to allow the user to input a string.
InputBox Constructor(String,String,String,FindProc,Int32) | Initializes a new instance of the InputBox class to act as a search interface.
See Also

Reference

InputBox Class
InputBox Members


%%PageItemTitle%%

InputBox Constructor(String,String,String,Boolean)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class > InputBox Constructor : InputBox Constructor(String,String,String,Boolean)
Window title.
Explanatory text shown at top of window.
Initial text to populate edit box with.
If true, the edit box is used to enter a password with its contents obscured during text entry.
Initializes a new instance of the InputBox class to allow the user to input a string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal title As String, _
   ByVal caption As String, _
   ByVal text As String, _
   ByVal isPassword As Boolean _
)
'Usage

Dim title As String
Dim caption As String
Dim text As String
Dim isPassword As Boolean

Dim instance As New InputBox(title, caption, text, isPassword)
public InputBox(
   string title,
   string caption,
   string text,
   bool isPassword
)
public: InputBox(
   string* title,
   string* caption,
   string* text,
   bool isPassword
)
public:
InputBox(
   String^ title,
   String^ caption,
   String^ text,
   bool isPassword
)

Parameters

title
Window title.
caption
Explanatory text shown at top of window.
text
Initial text to populate edit box with.
isPassword
If true, the edit box is used to enter a password with its contents obscured during text entry.

Return Value

The new instance of InputBox class.
See Also

Reference

InputBox Class
InputBox Members
Overload List


%%PageItemTitle%%

InputBox Constructor(String,String,String,FindProc,Int32)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class > InputBox Constructor : InputBox Constructor(String,String,String,FindProc,Int32)
Window title.
Explanatory text shown at top of window.
Initial text to populate edit box with.
Method to call when Find button is clicked.
An integer passed to FindProc, used to provide context for a search operation.
Initializes a new instance of the InputBox class to act as a search interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal title As String, _
   ByVal caption As String, _
   ByVal findText As String, _
   ByVal findCallback As InputBox.FindProc, _
   ByVal startPosition As Integer _
)
'Usage

Dim title As String
Dim caption As String
Dim findText As String
Dim findCallback As InputBox.FindProc
Dim startPosition As Integer

Dim instance As New InputBox(title, caption, findText, findCallback, startPosition)
public InputBox(
   string title,
   string caption,
   string findText,
   InputBox.FindProc findCallback,
   int startPosition
)
public: InputBox(
   string* title,
   string* caption,
   string* findText,
   InputBox.FindProc* findCallback,
   int startPosition
)
public:
InputBox(
   String^ title,
   String^ caption,
   String^ findText,
   InputBox.FindProc^ findCallback,
   int startPosition
)

Parameters

title
Window title.
caption
Explanatory text shown at top of window.
findText
Initial text to populate edit box with.
findCallback
Method to call when Find button is clicked.
startPosition
An integer passed to FindProc, used to provide context for a search operation.

Return Value

The new instance of InputBox class.
Remarks
When this constructor is used, a Find button is shown instead of an OK button. When the Find button is clicked, the given FindProc method is called and the window is not closed.
See Also

Reference

InputBox Class
InputBox Members
Overload List


%%PageItemTitle%% $$Methods$$

InputBox Class Methods

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox Class

For a list of all members of this type, see InputBox members.

See Also

Reference

InputBox Class
ImageGear.ART.Forms Namespace


%%PageItemTitle%% $$Events$$

InputBox Class Events

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox Class

For a list of all members of this type, see InputBox members.

See Also

Reference

InputBox Class
ImageGear.ART.Forms Namespace


Dispose Method (InputBox)

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class : Dispose Method
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
See Also

Reference

InputBox Class
InputBox Members


Dispose(Boolean) Method

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class > Dispose Method : Dispose(Boolean) Method
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As InputBox
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Indicates whether both managed and unmanaged resources have to be released or only unmanaged resources.
Remarks
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

InputBox Class
InputBox Members
Overload List


%%PageItemTitle%% $$Properties$$

InputBox Class Properties

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox Class

For a list of all members of this type, see InputBox members.

Public Properties
 | Name | Description
Public Property | DlgText | Gets content of the edit box where the user can enter a string.
Top
See Also

Reference

InputBox Class
ImageGear.ART.Forms Namespace


DlgText Property

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace > InputBox Class : DlgText Property
Gets content of the edit box where the user can enter a string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DlgText As String
'Usage

Dim instance As InputBox
Dim value As String

value = instance.DlgText
public string DlgText {get;}
public: __property string* get_DlgText();
public:
property String^ DlgText {
   String^ get();
}

Property Value

Any string.
See Also

Reference

InputBox Class
InputBox Members


%%PageItemTitle%%

ImGearARTFormsResizeType Enumeration

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTFormsResizeType Enumeration
Specifies how the mark is being resized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTFormsResizeType
   Inherits System.Enum
'Usage

Dim instance As ImGearARTFormsResizeType
public enum ImGearARTFormsResizeType : System.Enum
__value public enum ImGearARTFormsResizeType : public System.Enum
public enum class ImGearARTFormsResizeType : public System.Enum
Members
Member | Value | Description
East | 1 | Resize east.
North | 2 | Resize north.
NorthEast | 6 | Resize northeast.
NorthWest | 4 | Resize northwest.
Point | 8 | Move a point.
South | 3 | Resize south.
SouthEast | 7 | Resize southeast.
SouthWest | 5 | Resize southwest.
West | 0 | Resize west.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Forms.ImGearARTFormsResizeType

See Also

Reference

ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTInteractionArea Enumeration

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTInteractionArea Enumeration
Specifies the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTInteractionArea
   Inherits System.Enum
'Usage

Dim instance As ImGearARTInteractionArea
public enum ImGearARTInteractionArea : System.Enum
__value public enum ImGearARTInteractionArea : public System.Enum
public enum class ImGearARTInteractionArea : public System.Enum
Members
Member | Value | Description
Device | 0 | Limits the annotation editing area to the page view control area.
Image | 1 | Limits the annotation editing area to the image portion of the page view.
Unbound | 2 | Allows unlimited annotation editing to the entire device.
Remarks
You can choose to limit the annotation editing area to the page view control area, the image portion of the page view, or keep it unlimited to the entire device. This affects creating, selecting, resizing and moving annotations.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Forms.ImGearARTInteractionArea

See Also

Reference

ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTModes Enumeration

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTModes Enumeration
Specifies the annotation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTModes
   Inherits System.Enum
'Usage

Dim instance As ImGearARTModes
public enum ImGearARTModes : System.Enum
__value public enum ImGearARTModes : public System.Enum
public enum class ImGearARTModes : public System.Enum
Members
Member | Value | Description
EDIT | 0 | Edit mode allows users to create, edit and delete annotations.
RUN | 1 | Run mode allows users operate on hot spot, audio, and button activities.
VIEW | 2 | View-only mode allows users to view marks, not add or modify them.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Forms.ImGearARTModes

See Also

Reference

ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTModifyReason Enumeration

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTModifyReason Enumeration
Specifies type of the annotation's change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTModifyReason
   Inherits System.Enum
'Usage

Dim instance As ImGearARTModifyReason
public enum ImGearARTModifyReason : System.Enum
__value public enum ImGearARTModifyReason : public System.Enum
public enum class ImGearARTModifyReason : public System.Enum
Members
Member | Value | Description
ATTRIBUTE_CHANGE | 2 | Annotation attribute change. .
MOVE | 3 | Annotation move.
RESIZE | 4 | Annotation resize.
RTF_EDIT | 1 | RTF annotation change.
TEXT_EDIT | 0 | Annotation text change.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Forms.ImGearARTModifyReason

See Also

Reference

ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTToolBarModes Enumeration

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBarModes Enumeration
Specifies ART toolbar mode: legacy 2.0 marks and 3.0 marks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearARTToolBarModes
   Inherits System.Enum
'Usage

Dim instance As ImGearARTToolBarModes
public enum ImGearARTToolBarModes : System.Enum
__value public enum ImGearARTToolBarModes : public System.Enum
public enum class ImGearARTToolBarModes : public System.Enum
Members
Member | Value | Description
ART20 | 1 | Legacy ART 2.0 mode. Specifies the old style marks.
ART30 | 0 | ART 3.0 marks mode. Specifies the new style marks.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Forms.ImGearARTToolBarModes

See Also

Reference

ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTForms.DelegateButtonAction Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms.DelegateButtonAction Delegate
Reference to the Button mark.
A delegate for interacting with the Button annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTForms.DelegateButtonAction( _
   ByVal mark As ImGearARTButton _
)
'Usage

Dim instance As New ImGearARTForms.DelegateButtonAction(AddressOf HandlerMethod)
public delegate void ImGearARTForms.DelegateButtonAction(
   ImGearARTButton mark
)
public: __gc __delegate void ImGearARTForms.DelegateButtonAction(
   ImGearARTButton* mark
)
public delegate void ImGearARTForms.DelegateButtonAction(
   ImGearARTButton^ mark
)

Parameters

mark
Reference to the Button mark.
Remarks
This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.
See Also

Reference

ImGearARTForms.DelegateButtonAction Members
ImageGear.ART.Forms Namespace
ImGearARTButton Class
ButtonAction Property


%%PageItemTitle%%

ImGearARTForms.DelegateHotSpotAction Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms.DelegateHotSpotAction Delegate
Reference to the Hot Spot mark.
A delegate for interacting with the Hot Spot annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTForms.DelegateHotSpotAction( _
   ByVal mark As ImGearARTHotSpot _
)
'Usage

Dim instance As New ImGearARTForms.DelegateHotSpotAction(AddressOf HandlerMethod)
public delegate void ImGearARTForms.DelegateHotSpotAction(
   ImGearARTHotSpot mark
)
public: __gc __delegate void ImGearARTForms.DelegateHotSpotAction(
   ImGearARTHotSpot* mark
)
public delegate void ImGearARTForms.DelegateHotSpotAction(
   ImGearARTHotSpot^ mark
)

Parameters

mark
Reference to the Hot Spot mark.
Remarks
This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.
See Also

Reference

ImGearARTForms.DelegateHotSpotAction Members
ImageGear.ART.Forms Namespace
ImGearARTHotSpot Class


%%PageItemTitle%%

ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler Delegate
The source of the event.
ImGearARTFormsMarkCreatedEventArgs class that contains ImGearARTForms.MarkCreated event data.
Represents the method that will handle MarkCreated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTFormsMarkCreatedEventArgs _
)
'Usage

Dim instance As New ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler(
   object sender,
   ImGearARTFormsMarkCreatedEventArgs e
)
public: __gc __delegate void ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler(
   Object* sender,
   ImGearARTFormsMarkCreatedEventArgs* e
)
public delegate void ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler(
   Object^ sender,
   ImGearARTFormsMarkCreatedEventArgs^ e
)

Parameters

sender
The source of the event.
e
ImGearARTFormsMarkCreatedEventArgs class that contains ImGearARTForms.MarkCreated event data.
See Also

Reference

ImGearARTForms.ImGearARTFormsMarkCreatedEventHandler Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler Delegate
The source of the event.
ImGearARTFormsMarkCreatingEventArgs class that contains ImGearARTForms.MarkCreating event data.
Represents the method that will handle MarkCreating event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTFormsMarkCreatingEventArgs _
)
'Usage

Dim instance As New ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler(
   object sender,
   ImGearARTFormsMarkCreatingEventArgs e
)
public: __gc __delegate void ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler(
   Object* sender,
   ImGearARTFormsMarkCreatingEventArgs* e
)
public delegate void ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler(
   Object^ sender,
   ImGearARTFormsMarkCreatingEventArgs^ e
)

Parameters

sender
The source of the event.
e
ImGearARTFormsMarkCreatingEventArgs class that contains ImGearARTForms.MarkCreating event data.
See Also

Reference

ImGearARTForms.ImGearARTFormsMarkCreatingEventHandler Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTForms.ImGearARTFormsMouseEventHandler Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTForms.ImGearARTFormsMouseEventHandler Delegate
The source of the event.
ImGearARTFormsMouseEventArgs class that contains mouse button event event data.
Represents the method that will handle Mouse events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTForms.ImGearARTFormsMouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearARTFormsMouseEventArgs _
)
'Usage

Dim instance As New ImGearARTForms.ImGearARTFormsMouseEventHandler(AddressOf HandlerMethod)
public delegate void ImGearARTForms.ImGearARTFormsMouseEventHandler(
   object sender,
   ImGearARTFormsMouseEventArgs e
)
public: __gc __delegate void ImGearARTForms.ImGearARTFormsMouseEventHandler(
   Object* sender,
   ImGearARTFormsMouseEventArgs* e
)
public delegate void ImGearARTForms.ImGearARTFormsMouseEventHandler(
   Object^ sender,
   ImGearARTFormsMouseEventArgs^ e
)

Parameters

sender
The source of the event.
e
ImGearARTFormsMouseEventArgs class that contains mouse button event event data.
See Also

Reference

ImGearARTForms.ImGearARTFormsMouseEventHandler Members
ImageGear.ART.Forms Namespace


%%PageItemTitle%%

ImGearARTToolBar.DelegateCreateMark Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar.DelegateCreateMark Delegate
Reference to ART page object.
Reference to the created mark.
A delegate for notifications when annotation mark is created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTToolBar.DelegateCreateMark( _
   ByVal page As ImGearARTPage, _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As New ImGearARTToolBar.DelegateCreateMark(AddressOf HandlerMethod)
public delegate void ImGearARTToolBar.DelegateCreateMark(
   ImGearARTPage page,
   ImGearARTMark mark
)
public: __gc __delegate void ImGearARTToolBar.DelegateCreateMark(
   ImGearARTPage* page,
   ImGearARTMark* mark
)
public delegate void ImGearARTToolBar.DelegateCreateMark(
   ImGearARTPage^ page,
   ImGearARTMark^ mark
)

Parameters

page
Reference to ART page object.
mark
Reference to the created mark.
Remarks
This delegate, if registered, is automatically called from the ART forms when the user creates a mark.
See Also

Reference

ImGearARTToolBar.DelegateCreateMark Members
ImageGear.ART.Forms Namespace
ImGearARTPage Class
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTToolBar.DelegateDeleteMark Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar.DelegateDeleteMark Delegate
Reference to ART page object.
Reference to mark to delete.
A delegate for notifications when annotation mark is being deleted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTToolBar.DelegateDeleteMark( _
   ByVal page As ImGearARTPage, _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As New ImGearARTToolBar.DelegateDeleteMark(AddressOf HandlerMethod)
public delegate void ImGearARTToolBar.DelegateDeleteMark(
   ImGearARTPage page,
   ImGearARTMark mark
)
public: __gc __delegate void ImGearARTToolBar.DelegateDeleteMark(
   ImGearARTPage* page,
   ImGearARTMark* mark
)
public delegate void ImGearARTToolBar.DelegateDeleteMark(
   ImGearARTPage^ page,
   ImGearARTMark^ mark
)

Parameters

page
Reference to ART page object.
mark
Reference to mark to delete.
Remarks
This delegate, if registered, is automatically called from the ART forms when the user deletes a mark.
See Also

Reference

ImGearARTToolBar.DelegateDeleteMark Members
ImageGear.ART.Forms Namespace
ImGearARTPage Class
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTToolBar.DelegateModifyMark Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar.DelegateModifyMark Delegate
Reference to ART page object.
Reference to the modofied mark.
Reason of the mark is change .
A delegate for notifications when annotation mark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTToolBar.DelegateModifyMark( _
   ByVal page As ImGearARTPage, _
   ByVal mark As ImGearARTMark, _
   ByVal reason As ImGearARTModifyReason _
)
'Usage

Dim instance As New ImGearARTToolBar.DelegateModifyMark(AddressOf HandlerMethod)
public delegate void ImGearARTToolBar.DelegateModifyMark(
   ImGearARTPage page,
   ImGearARTMark mark,
   ImGearARTModifyReason reason
)
public: __gc __delegate void ImGearARTToolBar.DelegateModifyMark(
   ImGearARTPage* page,
   ImGearARTMark* mark,
   ImGearARTModifyReason reason
)
public delegate void ImGearARTToolBar.DelegateModifyMark(
   ImGearARTPage^ page,
   ImGearARTMark^ mark,
   ImGearARTModifyReason reason
)

Parameters

page
Reference to ART page object.
mark
Reference to the modofied mark.
reason
Reason of the mark is change .
Remarks
This delegate, if registered, is automatically called from the ART forms when the user modifies a mark.
See Also

Reference

ImGearARTToolBar.DelegateModifyMark Members
ImageGear.ART.Forms Namespace
ImGearARTPage Class
ImGearARTMark Class
ImGearARTModifyReason Enumeration


%%PageItemTitle%%

ImGearARTToolBar.DelegatePreCreateMark Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar.DelegatePreCreateMark Delegate
Reference to ART page object..
Reference to the creating mark.
A delegate for notifications prior to creating annotation marks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTToolBar.DelegatePreCreateMark( _
   ByVal page As ImGearARTPage, _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim instance As New ImGearARTToolBar.DelegatePreCreateMark(AddressOf HandlerMethod)
public delegate void ImGearARTToolBar.DelegatePreCreateMark(
   ImGearARTPage page,
   ImGearARTMark mark
)
public: __gc __delegate void ImGearARTToolBar.DelegatePreCreateMark(
   ImGearARTPage* page,
   ImGearARTMark* mark
)
public delegate void ImGearARTToolBar.DelegatePreCreateMark(
   ImGearARTPage^ page,
   ImGearARTMark^ mark
)

Parameters

page
Reference to ART page object..
mark
Reference to the creating mark.
Remarks
This delegate, if registered, is automatically called from the ART forms when the user is about to create a mark. It can be used to change a mark's default attributes before its creation.
See Also

Reference

ImGearARTToolBar.DelegatePreCreateMark Members
ImageGear.ART.Forms Namespace
ImGearARTPage Class
ImGearARTMark Class


%%PageItemTitle%%

ImGearARTToolBar.DelegateSelect Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : ImGearARTToolBar.DelegateSelect Delegate
Selected mark type.
A delegate for notifications when annotation type is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearARTToolBar.DelegateSelect( _
   ByVal button As ImGearARTMarkType _
)
'Usage

Dim instance As New ImGearARTToolBar.DelegateSelect(AddressOf HandlerMethod)
public delegate void ImGearARTToolBar.DelegateSelect(
   ImGearARTMarkType button
)
public: __gc __delegate void ImGearARTToolBar.DelegateSelect(
   ImGearARTMarkType button
)
public delegate void ImGearARTToolBar.DelegateSelect(
   ImGearARTMarkType button
)

Parameters

button
Selected mark type.
Remarks
This delegate, if registered, is automatically called from the ART forms when the user clicks toolbar button to select a mark type.
See Also

Reference

ImGearARTToolBar.DelegateSelect Members
ImageGear.ART.Forms Namespace
ImGearARTMarkType Enumeration


%%PageItemTitle%%

InputBox.FindProc Delegate

ImageGear22.Art.Forms Assembly > ImageGear.ART.Forms Namespace : InputBox.FindProc Delegate
Specifies instance of InputBox class where Find button is clicked.
The context of search operation.
A delegate method called when Find button is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function InputBox.FindProc( _
   ByVal dialog As InputBox, _
   ByVal startPosition As Integer _
) As Integer
'Usage

Dim instance As New InputBox.FindProc(AddressOf HandlerMethod)
public delegate int InputBox.FindProc(
   InputBox dialog,
   int startPosition
)
public: __gc __delegate int InputBox.FindProc(
   InputBox* dialog,
   int startPosition
)
public delegate int InputBox.FindProc(
   InputBox^ dialog,
   int startPosition
)

Parameters

dialog
Specifies instance of InputBox class where Find button is clicked.
startPosition
The context of search operation.

Return Value

The value to pass for the StartPos parameter for the next call to FindProc.
Remarks
This delegate is used for the method called when the Find button is clicked, when the InputBox is being used for search purposes. This method is passed an integer initially provided in the constructor, and then from subsequent calls to FindProc. This integer is used to provide context for the search operation - for example, the index of a current position in a string.
See Also

Reference

InputBox.FindProc Members
ImageGear.ART.Forms Namespace


ImageGear22.Art.Windows.Controls Assembly
Namespaces
Namespace | Description
ImageGear.ART.Windows.Controls | The ImageGear.ART.Windows.Controls Namespace provides WPF Annotation controls and UI.


ImageGear.ART.Windows.Controls Namespace
Inheritance Hierarchy
ImageGear22.Art.Windows.Controls Assembly : ImageGear.ART.Windows.Controls Namespace
The ImageGear.ART.Windows.Controls Namespace provides WPF Annotation controls and UI.
Classes
 | Class | Description
Class | Annotator | This class has been deprecated. Provides properties and methods that implement base user interface for annotating.
Class | AnnotatorSettings | This class has been deprecated. Provides a set of settings for the annotation user interface.
Class | ArtMouseButtonEventArgs | This class has been deprecated. Provides mouse button event data.
Class | ArtMouseEventArgs | This class has been deprecated. Provides mouse event data.
Class | ModifyMarkEventArgs | This class has been deprecated. Provides ModifyMark event data.
Class | PreCreateMarkEventArgs | This class has been deprecated. Provides PreCreateMark event data.
Class | PreDeleteMarkEventArgs | This class has been deprecated. Provides PreDeleteMark event data.
Class | ToolBar | This class has been deprecated. Provides control for creating, selecting and editing annotations. ToolBar
Class | ToolBarAnnotator | This class has been deprecated. Provides properties and methods that implement user interface for annotating using ToolBar.
Delegates
 | Delegate | Description
Delegate | Annotator.ArtMouseButtonEventHandler | This delegate has been deprecated. Represents the method that will handle mouse button events.
Delegate | Annotator.ArtMouseEventHandler | This delegate has been deprecated. Represents the method that will handle Mouse events.
Delegate | Annotator.ModifyMarkEventHandler | This delegate has been deprecated. Represents the method that will handle ModifyMark event.
Delegate | Annotator.PreCreateMarkEventHandler | This delegate has been deprecated. Represents the method that will handle PreCreateMark event.
Delegate | Annotator.PreDeleteMarkEventHandler | This delegate has been deprecated. Represents the method that will handle PreDeleteMark event.
Enumerations
 | Enumeration | Description
Enumeration | InteractionArea | This enumeration has been deprecated. Specifies the interaction area for editing annotations.
Enumeration | Mode | This enumeration has been deprecated. Specifies the annotation modes.
Enumeration | ModifyReason | This enumeration has been deprecated. Specifies types of annotation's change.
See Also

Reference

ImageGear22.Art.Windows.Controls Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.ART.Windows.Controls Namespace Inheritance Hierarchy
ImageGear22.Art.Windows.Controls Assembly : ImageGear.ART.Windows.Controls Namespace
Inheritance Hierarchy
System.Object
ImageGear.ART.Windows.Controls.Annotator
ImageGear.ART.Windows.Controls.ToolBarAnnotator
ImageGear.ART.Windows.Controls.AnnotatorSettings
System.EventArgs
ImageGear.ART.Windows.Controls.ArtMouseButtonEventArgs
ImageGear.ART.Windows.Controls.ArtMouseEventArgs
ImageGear.ART.Windows.Controls.ModifyMarkEventArgs
ImageGear.ART.Windows.Controls.PreCreateMarkEventArgs
ImageGear.ART.Windows.Controls.PreDeleteMarkEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
ImageGear.ART.Windows.Controls.ToolBar
See Also

Reference

ImageGear22.Art.Windows.Controls Assembly


%%PageItemTitle%%

Annotator Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator Class
This class has been deprecated. Provides properties and methods that implement base user interface for annotating.
Object Model
Annotator ClassPageView ClassAnnotatorSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class Annotator
'Usage

Dim instance As Annotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class Annotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class Annotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class Annotator
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
ImageGear.ART.Windows.Controls.Annotator
ImageGear.ART.Windows.Controls.ToolBarAnnotator

See Also

Reference

Annotator Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Annotator Class Members
Properties Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator Class

The following tables list the members exposed by Annotator.

Public Constructors
 | Name | Description
Public Constructor | Annotator Constructor | This constructor has been deprecated. Initializes a new instance of the Annotator class.
Top
Public Properties
 | Name | Description
Public Property | Mode | Gets or sets the annotation mode.
Public Property | PageView | Gets or sets a reference to the page view control.
Public Property | Settings | Gets or sets a reference to the settings for annotating user interface.
Public Property | Tool | Gets or sets annotation selected tool.
Top
Public Events
 | Name | Description
Public Event | ModifyMark | Occurs after an annotation has been changed, moved or resized using the Annotator.
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of zan annotation mark.
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | PreCreateMark | Occurs just before an annotation is created.
Public Event | PreDeleteMark | Occurs just before an annotation is deleted.
Top
See Also

Reference

Annotator Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : Annotator Constructor
Reference to the page view control.
This constructor has been deprecated. Initializes a new instance of the Annotator class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Function New( _
   ByVal pageView As PageView _
)
'Usage

Dim pageView As PageView

Dim instance As New Annotator(pageView)
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public Annotator(
   PageView pageView
)
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public: Annotator(
   PageView* pageView
)
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public:
Annotator(
   PageView^ pageView
)

Parameters

pageView
Reference to the page view control.
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
See Also

Reference

Annotator Class
Annotator Members
PageView Property


%%PageItemTitle%% $$Properties$$

Annotator Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator Class

For a list of all members of this type, see Annotator members.

Public Properties
 | Name | Description
Public Property | Mode | Gets or sets the annotation mode.
Public Property | PageView | Gets or sets a reference to the page view control.
Public Property | Settings | Gets or sets a reference to the settings for annotating user interface.
Public Property | Tool | Gets or sets annotation selected tool.
Top
See Also

Reference

Annotator Class
ImageGear.ART.Windows.Controls Namespace


Mode Property (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : Mode Property
Gets or sets the annotation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As Mode
'Usage

Dim instance As Annotator
Dim value As Mode

instance.Mode = value

value = instance.Mode
public Mode Mode {get; set;}
public: __property Mode get_Mode();
public: __property void set_Mode(
   Mode value
);
public:
property Mode Mode {
   Mode get();
   void set (    Mode value);
}

Property Value

Mode enumeration value.
See Also

Reference

Annotator Class
Annotator Members


PageView Property (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : PageView Property
Gets or sets a reference to the page view control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageView As PageView
'Usage

Dim instance As Annotator
Dim value As PageView

instance.PageView = value

value = instance.PageView
public PageView PageView {get; set;}
public: __property PageView* get_PageView();
public: __property void set_PageView(
   PageView* value
);
public:
property PageView^ PageView {
   PageView^ get();
   void set (    PageView^ value);
}

Property Value

PageView class.
See Also

Reference

Annotator Class
Annotator Members


Settings Property (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : Settings Property
Gets or sets a reference to the settings for annotating user interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Settings As AnnotatorSettings
'Usage

Dim instance As Annotator
Dim value As AnnotatorSettings

instance.Settings = value

value = instance.Settings
public AnnotatorSettings Settings {get; set;}
public: __property AnnotatorSettings* get_Settings();
public: __property void set_Settings(
   AnnotatorSettings* value
);
public:
property AnnotatorSettings^ Settings {
   AnnotatorSettings^ get();
   void set (    AnnotatorSettings^ value);
}

Property Value

AnnotatorSettings class.
See Also

Reference

Annotator Class
Annotator Members


Tool Property (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : Tool Property
Gets or sets annotation selected tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Tool As ImGearARTMarkType
'Usage

Dim instance As Annotator
Dim value As ImGearARTMarkType

instance.Tool = value

value = instance.Tool
public virtual ImGearARTMarkType Tool {get; set;}
public: __property virtual ImGearARTMarkType get_Tool();
public: __property virtual void set_Tool(
   ImGearARTMarkType value
);
public:
virtual property ImGearARTMarkType Tool {
   ImGearARTMarkType get();
   void set (    ImGearARTMarkType value);
}

Property Value

ImageGear.ART.ImGearARTMarkType enumeration value.
See Also

Reference

Annotator Class
Annotator Members


%%PageItemTitle%% $$Events$$

Annotator Class Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator Class

For a list of all members of this type, see Annotator members.

Public Events
 | Name | Description
Public Event | ModifyMark | Occurs after an annotation has been changed, moved or resized using the Annotator.
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of zan annotation mark.
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Public Event | PreCreateMark | Occurs just before an annotation is created.
Public Event | PreDeleteMark | Occurs just before an annotation is deleted.
Top
See Also

Reference

Annotator Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : Annotator Constructor
Overload List
Overload | Description
Annotator Constructor | This constructor has been deprecated. Initializes a new instance of the Annotator class.
See Also

Reference

Annotator Class
Annotator Members


ModifyMark Event

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : ModifyMark Event
Occurs after an annotation has been changed, moved or resized using the Annotator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ModifyMark As Annotator.ModifyMarkEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ModifyMarkEventHandler

AddHandler instance.ModifyMark, handler
public event Annotator.ModifyMarkEventHandler ModifyMark
public: __event Annotator.ModifyMarkEventHandler* ModifyMark
public:
event Annotator.ModifyMarkEventHandler^ ModifyMark
Event Data

The event handler receives an argument of type ModifyMarkEventArgs containing data related to this event. The following ModifyMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets a reference to the annotation object being changed, moved or resized using the Annotator.
Reason | Gets type of the annotation's change.
See Also

Reference

Annotator Class
Annotator Members


MouseLeftButtonDown Event (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : MouseLeftButtonDown Event
Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseLeftButtonDown As Annotator.ArtMouseButtonEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ArtMouseButtonEventHandler

AddHandler instance.MouseLeftButtonDown, handler
public event Annotator.ArtMouseButtonEventHandler MouseLeftButtonDown
public: __event Annotator.ArtMouseButtonEventHandler* MouseLeftButtonDown
public:
event Annotator.ArtMouseButtonEventHandler^ MouseLeftButtonDown
Event Data

The event handler receives an argument of type ArtMouseButtonEventArgs containing data related to this event. The following ArtMouseButtonEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse button event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

Annotator Class
Annotator Members


MouseLeftButtonUp Event (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : MouseLeftButtonUp Event
Occurs when the left mouse button is released while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseLeftButtonUp As Annotator.ArtMouseButtonEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ArtMouseButtonEventHandler

AddHandler instance.MouseLeftButtonUp, handler
public event Annotator.ArtMouseButtonEventHandler MouseLeftButtonUp
public: __event Annotator.ArtMouseButtonEventHandler* MouseLeftButtonUp
public:
event Annotator.ArtMouseButtonEventHandler^ MouseLeftButtonUp
Event Data

The event handler receives an argument of type ArtMouseButtonEventArgs containing data related to this event. The following ArtMouseButtonEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse button event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

Annotator Class
Annotator Members


MouseMove Event (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : MouseMove Event
Occurs when the coordinate position of the mouse (or stylus) changes while over or outside of zan annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseMove As Annotator.ArtMouseEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ArtMouseEventHandler

AddHandler instance.MouseMove, handler
public event Annotator.ArtMouseEventHandler MouseMove
public: __event Annotator.ArtMouseEventHandler* MouseMove
public:
event Annotator.ArtMouseEventHandler^ MouseMove
Event Data

The event handler receives an argument of type ArtMouseEventArgs containing data related to this event. The following ArtMouseEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

Annotator Class
Annotator Members


MouseRightButtonDown Event (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : MouseRightButtonDown Event
Occurs when the right mouse button is pressed while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseRightButtonDown As Annotator.ArtMouseButtonEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ArtMouseButtonEventHandler

AddHandler instance.MouseRightButtonDown, handler
public event Annotator.ArtMouseButtonEventHandler MouseRightButtonDown
public: __event Annotator.ArtMouseButtonEventHandler* MouseRightButtonDown
public:
event Annotator.ArtMouseButtonEventHandler^ MouseRightButtonDown
Event Data

The event handler receives an argument of type ArtMouseButtonEventArgs containing data related to this event. The following ArtMouseButtonEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse button event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

Annotator Class
Annotator Members


MouseRightButtonUp Event (Annotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : MouseRightButtonUp Event
Occurs when the right mouse button is released while the mouse pointer is over or outside of an annotation mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MouseRightButtonUp As Annotator.ArtMouseButtonEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.ArtMouseButtonEventHandler

AddHandler instance.MouseRightButtonUp, handler
public event Annotator.ArtMouseButtonEventHandler MouseRightButtonUp
public: __event Annotator.ArtMouseButtonEventHandler* MouseRightButtonUp
public:
event Annotator.ArtMouseButtonEventHandler^ MouseRightButtonUp
Event Data

The event handler receives an argument of type ArtMouseButtonEventArgs containing data related to this event. The following ArtMouseButtonEventArgs properties provide information specific to this event.

Property | Description
EventData | Gets mouse button event data.
Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
See Also

Reference

Annotator Class
Annotator Members


PreCreateMark Event

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : PreCreateMark Event
Occurs just before an annotation is created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PreCreateMark As Annotator.PreCreateMarkEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.PreCreateMarkEventHandler

AddHandler instance.PreCreateMark, handler
public event Annotator.PreCreateMarkEventHandler PreCreateMark
public: __event Annotator.PreCreateMarkEventHandler* PreCreateMark
public:
event Annotator.PreCreateMarkEventHandler^ PreCreateMark
Event Data

The event handler receives an argument of type PreCreateMarkEventArgs containing data related to this event. The following PreCreateMarkEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Mark | Gets a reference to the annotation object being created.
See Also

Reference

Annotator Class
Annotator Members
Annotator.PreCreateMarkEventHandler Delegate


PreDeleteMark Event

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > Annotator Class : PreDeleteMark Event
Occurs just before an annotation is deleted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PreDeleteMark As Annotator.PreDeleteMarkEventHandler
'Usage

Dim instance As Annotator
Dim handler As Annotator.PreDeleteMarkEventHandler

AddHandler instance.PreDeleteMark, handler
public event Annotator.PreDeleteMarkEventHandler PreDeleteMark
public: __event Annotator.PreDeleteMarkEventHandler* PreDeleteMark
public:
event Annotator.PreDeleteMarkEventHandler^ PreDeleteMark
Event Data

The event handler receives an argument of type PreDeleteMarkEventArgs containing data related to this event. The following PreDeleteMarkEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the process of annotation deletion has to be canceled.
Mark | Gets a reference to the annotation object being deleted.
See Also

Reference

Annotator Class
Annotator Members
Annotator.PreDeleteMarkEventHandler Delegate


%%PageItemTitle%%

AnnotatorSettings Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : AnnotatorSettings Class
This class has been deprecated. Provides a set of settings for the annotation user interface.
Object Model
AnnotatorSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public NotInheritable Class AnnotatorSettings
'Usage

Dim instance As AnnotatorSettings
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public sealed class AnnotatorSettings
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc __sealed class AnnotatorSettings
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class AnnotatorSettings sealed
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
ImageGear.ART.Windows.Controls.AnnotatorSettings

See Also

Reference

AnnotatorSettings Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

AnnotatorSettings Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : AnnotatorSettings Class

The following tables list the members exposed by AnnotatorSettings.

Public Constructors
 | Name | Description
Public Constructor | AnnotatorSettings Constructor | Initializes a new instance of the AnnotatorSettings class with default settings.
Top
Public Properties
 | Name | Description
Public Property | CreatorColor | Gets or sets color of a shape drawn when an annotation it is being created.
Public Property | CreatorOpacity | Gets or sets opacity level of a shape drawn when an annotation it is being created.
Public Property | DoubleClickThreshold | Gets or sets double click threshold value in milliseconds.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsContextMenuEnabled | Gets or sets a value indicating whether the annotations context menu is enabled.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | IsResetToolEnabled | Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Public Property | IsTextClipboardEnabled | Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | SelectorColor | Gets or sets color of the annotation selecting rectangle.
Public Property | SelectorOpacity | Gets or sets opacity level of the annotation selecting rectangle.
Top
See Also

Reference

AnnotatorSettings Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

AnnotatorSettings Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : AnnotatorSettings Constructor
Initializes a new instance of the AnnotatorSettings class with default settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New AnnotatorSettings()
public AnnotatorSettings()
public: AnnotatorSettings();
public:
AnnotatorSettings();
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


%%PageItemTitle%% $$Properties$$

AnnotatorSettings Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : AnnotatorSettings Class

For a list of all members of this type, see AnnotatorSettings members.

Public Properties
 | Name | Description
Public Property | CreatorColor | Gets or sets color of a shape drawn when an annotation it is being created.
Public Property | CreatorOpacity | Gets or sets opacity level of a shape drawn when an annotation it is being created.
Public Property | DoubleClickThreshold | Gets or sets double click threshold value in milliseconds.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsContextMenuEnabled | Gets or sets a value indicating whether the annotations context menu is enabled.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | IsResetToolEnabled | Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Public Property | IsTextClipboardEnabled | Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | SelectorColor | Gets or sets color of the annotation selecting rectangle.
Public Property | SelectorOpacity | Gets or sets opacity level of the annotation selecting rectangle.
Top
See Also

Reference

AnnotatorSettings Class
ImageGear.ART.Windows.Controls Namespace


CreatorColor Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : CreatorColor Property
Gets or sets color of a shape drawn when an annotation it is being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorColor As Color
'Usage

Dim instance As AnnotatorSettings
Dim value As Color

instance.CreatorColor = value

value = instance.CreatorColor
public Color CreatorColor {get; set;}
public: __property Color get_CreatorColor();
public: __property void set_CreatorColor(
   Color value
);
public:
property Color CreatorColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Windows.Media.Color value.
Remarks
The default value is Colors.Gray.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


CreatorOpacity Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : CreatorOpacity Property
Gets or sets opacity level of a shape drawn when an annotation it is being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorOpacity As Byte
'Usage

Dim instance As AnnotatorSettings
Dim value As Byte

instance.CreatorOpacity = value

value = instance.CreatorOpacity
public byte CreatorOpacity {get; set;}
public: __property byte get_CreatorOpacity();
public: __property void set_CreatorOpacity(
   byte value
);
public:
property byte CreatorOpacity {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
The default value is 127.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


DoubleClickThreshold Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : DoubleClickThreshold Property
Gets or sets double click threshold value in milliseconds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DoubleClickThreshold As Long
'Usage

Dim instance As AnnotatorSettings
Dim value As Long

instance.DoubleClickThreshold = value

value = instance.DoubleClickThreshold
public long DoubleClickThreshold {get; set;}
public: __property long get_DoubleClickThreshold();
public: __property void set_DoubleClickThreshold(
   long value
);
public:
property int64 DoubleClickThreshold {
   int64 get();
   void set (    int64 value);
}

Property Value

Long value.
Remarks
The default value is 250.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


InteractionArea Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As InteractionArea
'Usage

Dim instance As AnnotatorSettings
Dim value As InteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public InteractionArea InteractionArea {get; set;}
public: __property InteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   InteractionArea value
);
public:
property InteractionArea InteractionArea {
   InteractionArea get();
   void set (    InteractionArea value);
}

Property Value

InteractionArea enumeration value.
Remarks
By default, it is set to InteractionArea enumeration.Device, which corresponds to the unlimited device area. You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device. This affects creating, selecting, resizing and moving annotations.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


IsContextMenuEnabled Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : IsContextMenuEnabled Property
Gets or sets a value indicating whether the annotations context menu is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsContextMenuEnabled As Boolean
'Usage

Dim instance As AnnotatorSettings
Dim value As Boolean

instance.IsContextMenuEnabled = value

value = instance.IsContextMenuEnabled
public bool IsContextMenuEnabled {get; set;}
public: __property bool get_IsContextMenuEnabled();
public: __property void set_IsContextMenuEnabled(
   bool value
);
public:
property bool IsContextMenuEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


IsPolylineAutoCloseEnabled Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : IsPolylineAutoCloseEnabled Property
Gets or sets a value indicating whether the polyline auto-close is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolylineAutoCloseEnabled As Boolean
'Usage

Dim instance As AnnotatorSettings
Dim value As Boolean

instance.IsPolylineAutoCloseEnabled = value

value = instance.IsPolylineAutoCloseEnabled
public bool IsPolylineAutoCloseEnabled {get; set;}
public: __property bool get_IsPolylineAutoCloseEnabled();
public: __property void set_IsPolylineAutoCloseEnabled(
   bool value
);
public:
property bool IsPolylineAutoCloseEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the polyline mark is created. If true, then the mark is auto-completed and its "Closed" value is set to "true" when current mouse position is close to the starting poly mark point. In this case the PolyMarkPointRadiusThreshold properly should define a max distance, in pixels, between the current mouse position and the starting point position, to consider that poly mark creation process must be finished and the mark must be closed. The default value is false.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


IsPolyMarkAutoRollbackEnabled Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : IsPolyMarkAutoRollbackEnabled Property
Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolyMarkAutoRollbackEnabled As Boolean
'Usage

Dim instance As AnnotatorSettings
Dim value As Boolean

instance.IsPolyMarkAutoRollbackEnabled = value

value = instance.IsPolyMarkAutoRollbackEnabled
public bool IsPolyMarkAutoRollbackEnabled {get; set;}
public: __property bool get_IsPolyMarkAutoRollbackEnabled();
public: __property void set_IsPolyMarkAutoRollbackEnabled(
   bool value
);
public:
property bool IsPolyMarkAutoRollbackEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the Curve, Polyline, Polygon, Polyruler or Freelhand line mark is created. If true, then the user has an ability to erase segments of poly mark by dragging mouse over recently drawn segments (for Freehand line) or by clicking on the point that starts the segment chain to be deleted. In this case the PolyMarkPointRadiusThreshold property should define a max distance, in pixels, between the current mouse position and one of the previously added points, to consider that user wants to remove a chain of segments. The default value is false.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


IsResetToolEnabled Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : IsResetToolEnabled Property
Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsResetToolEnabled As Boolean
'Usage

Dim instance As AnnotatorSettings
Dim value As Boolean

instance.IsResetToolEnabled = value

value = instance.IsResetToolEnabled
public bool IsResetToolEnabled {get; set;}
public: __property bool get_IsResetToolEnabled();
public: __property void set_IsResetToolEnabled(
   bool value
);
public:
property bool IsResetToolEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


IsTextClipboardEnabled Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : IsTextClipboardEnabled Property
Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsTextClipboardEnabled As Boolean
'Usage

Dim instance As AnnotatorSettings
Dim value As Boolean

instance.IsTextClipboardEnabled = value

value = instance.IsTextClipboardEnabled
public bool IsTextClipboardEnabled {get; set;}
public: __property bool get_IsTextClipboardEnabled();
public: __property void set_IsTextClipboardEnabled(
   bool value
);
public:
property bool IsTextClipboardEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


PolyMarkAutoRollbackThreshold Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : PolyMarkAutoRollbackThreshold Property
Gets or sets a value indicating a poly mark loop auto- correction threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkAutoRollbackThreshold As Double
'Usage

Dim instance As AnnotatorSettings
Dim value As Double

instance.PolyMarkAutoRollbackThreshold = value

value = instance.PolyMarkAutoRollbackThreshold
public double PolyMarkAutoRollbackThreshold {get; set;}
public: __property double get_PolyMarkAutoRollbackThreshold();
public: __property void set_PolyMarkAutoRollbackThreshold(
   double value
);
public:
property double PolyMarkAutoRollbackThreshold {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
This value indicates a min loop perimeter/area ratio for which the loop will be considered as correction and removed from the path. The smaller value shows that poly mark correction will be easier, but user won’t be able to draw thin shapes; loop with relatively small area will be treated as correction and excluded from the polyline. Minimal possible value is 4*PI (that means round loop). With this threshold value any loop will be removed. The default value is 40 * PI.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


PolyMarkPointRadiusThreshold Property (AnnotatorSettings)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : PolyMarkPointRadiusThreshold Property
Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkPointRadiusThreshold As Integer
'Usage

Dim instance As AnnotatorSettings
Dim value As Integer

instance.PolyMarkPointRadiusThreshold = value

value = instance.PolyMarkPointRadiusThreshold
public int PolyMarkPointRadiusThreshold {get; set;}
public: __property int get_PolyMarkPointRadiusThreshold();
public: __property void set_PolyMarkPointRadiusThreshold(
   int value
);
public:
property int PolyMarkPointRadiusThreshold {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Also see IsPolylineAutoCloseEnabled and IsPolyMarkAutoRollbackEnabled. The default value is 50.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


SelectorColor Property

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : SelectorColor Property
Gets or sets color of the annotation selecting rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectorColor As Color
'Usage

Dim instance As AnnotatorSettings
Dim value As Color

instance.SelectorColor = value

value = instance.SelectorColor
public Color SelectorColor {get; set;}
public: __property Color get_SelectorColor();
public: __property void set_SelectorColor(
   Color value
);
public:
property Color SelectorColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Windows.Media.Color value.
Remarks
The default value is Colors.Gray.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


SelectorOpacity Property

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > AnnotatorSettings Class : SelectorOpacity Property
Gets or sets opacity level of the annotation selecting rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectorOpacity As Byte
'Usage

Dim instance As AnnotatorSettings
Dim value As Byte

instance.SelectorOpacity = value

value = instance.SelectorOpacity
public byte SelectorOpacity {get; set;}
public: __property byte get_SelectorOpacity();
public: __property void set_SelectorOpacity(
   byte value
);
public:
property byte SelectorOpacity {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
The default value is 127.
See Also

Reference

AnnotatorSettings Class
AnnotatorSettings Members


%%PageItemTitle%%

ArtMouseButtonEventArgs Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseButtonEventArgs Class
This class has been deprecated. Provides mouse button event data.
Object Model
ArtMouseButtonEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class ArtMouseButtonEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ArtMouseButtonEventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class ArtMouseButtonEventArgs : System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class ArtMouseButtonEventArgs : public System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class ArtMouseButtonEventArgs : public System.EventArgs
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Windows.Controls.ArtMouseButtonEventArgs

See Also

Reference

ArtMouseButtonEventArgs Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ArtMouseButtonEventArgs Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseButtonEventArgs Class

The following tables list the members exposed by ArtMouseButtonEventArgs.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse button event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ArtMouseButtonEventArgs Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ArtMouseButtonEventArgs Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseButtonEventArgs Class

For a list of all members of this type, see ArtMouseButtonEventArgs members.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse button event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ArtMouseButtonEventArgs Class
ImageGear.ART.Windows.Controls Namespace


EventData Property (ArtMouseButtonEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ArtMouseButtonEventArgs Class : EventData Property
Gets mouse button event data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property EventData As MouseButtonEventArgs
'Usage

Dim instance As ArtMouseButtonEventArgs
Dim value As MouseButtonEventArgs

value = instance.EventData
public MouseButtonEventArgs EventData {get;}
public: __property MouseButtonEventArgs* get_EventData();
public:
property MouseButtonEventArgs^ EventData {
   MouseButtonEventArgs^ get();
}

Property Value

System.Windows.Input.MouseButtonEventArgs class object.
See Also

Reference

ArtMouseButtonEventArgs Class
ArtMouseButtonEventArgs Members


Mark Property (ArtMouseButtonEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ArtMouseButtonEventArgs Class : Mark Property
Gets the annotation mark object the mouse pointer is over or null otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ArtMouseButtonEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class object.
See Also

Reference

ArtMouseButtonEventArgs Class
ArtMouseButtonEventArgs Members


%%PageItemTitle%%

ArtMouseEventArgs Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseEventArgs Class
This class has been deprecated. Provides mouse event data.
Object Model
ArtMouseEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class ArtMouseEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ArtMouseEventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class ArtMouseEventArgs : System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class ArtMouseEventArgs : public System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class ArtMouseEventArgs : public System.EventArgs
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Windows.Controls.ArtMouseEventArgs

See Also

Reference

ArtMouseEventArgs Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ArtMouseEventArgs Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseEventArgs Class

The following tables list the members exposed by ArtMouseEventArgs.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ArtMouseEventArgs Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ArtMouseEventArgs Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ArtMouseEventArgs Class

For a list of all members of this type, see ArtMouseEventArgs members.

Public Properties
 | Name | Description
Public Property | EventData | Gets mouse event data.
Public Property | Mark | Gets the annotation mark object the mouse pointer is over or null otherwise.
Top
See Also

Reference

ArtMouseEventArgs Class
ImageGear.ART.Windows.Controls Namespace


EventData Property (ArtMouseEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ArtMouseEventArgs Class : EventData Property
Gets mouse event data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property EventData As MouseEventArgs
'Usage

Dim instance As ArtMouseEventArgs
Dim value As MouseEventArgs

value = instance.EventData
public MouseEventArgs EventData {get;}
public: __property MouseEventArgs* get_EventData();
public:
property MouseEventArgs^ EventData {
   MouseEventArgs^ get();
}

Property Value

System.Windows.Input.MouseEventArgs class object.
See Also

Reference

ArtMouseEventArgs Class
ArtMouseEventArgs Members


Mark Property (ArtMouseEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ArtMouseEventArgs Class : Mark Property
Gets the annotation mark object the mouse pointer is over or null otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ArtMouseEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class object.
See Also

Reference

ArtMouseEventArgs Class
ArtMouseEventArgs Members


%%PageItemTitle%%

ModifyMarkEventArgs Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ModifyMarkEventArgs Class
This class has been deprecated. Provides ModifyMark event data.
Object Model
ModifyMarkEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class ModifyMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ModifyMarkEventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class ModifyMarkEventArgs : System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class ModifyMarkEventArgs : public System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class ModifyMarkEventArgs : public System.EventArgs
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Windows.Controls.ModifyMarkEventArgs

See Also

Reference

ModifyMarkEventArgs Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ModifyMarkEventArgs Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ModifyMarkEventArgs Class

The following tables list the members exposed by ModifyMarkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ModifyMarkEventArgs Constructor | Initializes a new instance of the ModifyMarkEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Mark | Gets a reference to the annotation object being changed, moved or resized using the Annotator.
Public Property | Reason | Gets type of the annotation's change.
Top
See Also

Reference

ModifyMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

ModifyMarkEventArgs Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ModifyMarkEventArgs Class : ModifyMarkEventArgs Constructor
Reference to the annotation object being changed, moved or resized using the Annotator.
Type of the annotation's change.
Initializes a new instance of the ModifyMarkEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark, _
   ByVal reason As ModifyReason _
)
'Usage

Dim mark As ImGearARTMark
Dim reason As ModifyReason

Dim instance As New ModifyMarkEventArgs(mark, reason)
public ModifyMarkEventArgs(
   ImGearARTMark mark,
   ModifyReason reason
)
public: ModifyMarkEventArgs(
   ImGearARTMark* mark,
   ModifyReason reason
)
public:
ModifyMarkEventArgs(
   ImGearARTMark^ mark,
   ModifyReason reason
)

Parameters

mark
Reference to the annotation object being changed, moved or resized using the Annotator.
reason
Type of the annotation's change.
See Also

Reference

ModifyMarkEventArgs Class
ModifyMarkEventArgs Members


%%PageItemTitle%% $$Properties$$

ModifyMarkEventArgs Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ModifyMarkEventArgs Class

For a list of all members of this type, see ModifyMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Mark | Gets a reference to the annotation object being changed, moved or resized using the Annotator.
Public Property | Reason | Gets type of the annotation's change.
Top
See Also

Reference

ModifyMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


Mark Property (ModifyMarkEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ModifyMarkEventArgs Class : Mark Property
Gets a reference to the annotation object being changed, moved or resized using the Annotator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As ModifyMarkEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class.
See Also

Reference

ModifyMarkEventArgs Class
ModifyMarkEventArgs Members


Reason Property

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ModifyMarkEventArgs Class : Reason Property
Gets type of the annotation's change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Reason As ModifyReason
'Usage

Dim instance As ModifyMarkEventArgs
Dim value As ModifyReason

value = instance.Reason
public ModifyReason Reason {get;}
public: __property ModifyReason get_Reason();
public:
property ModifyReason Reason {
   ModifyReason get();
}

Property Value

ModifyReason enumeration value.
See Also

Reference

ModifyMarkEventArgs Class
ModifyMarkEventArgs Members


%%PageItemTitle%%

PreCreateMarkEventArgs Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreCreateMarkEventArgs Class
This class has been deprecated. Provides PreCreateMark event data.
Object Model
PreCreateMarkEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class PreCreateMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PreCreateMarkEventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class PreCreateMarkEventArgs : System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class PreCreateMarkEventArgs : public System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class PreCreateMarkEventArgs : public System.EventArgs
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Windows.Controls.PreCreateMarkEventArgs

See Also

Reference

PreCreateMarkEventArgs Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

PreCreateMarkEventArgs Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreCreateMarkEventArgs Class

The following tables list the members exposed by PreCreateMarkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PreCreateMarkEventArgs Constructor | Initializes a new instance of the PreCreateMarkEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

PreCreateMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

PreCreateMarkEventArgs Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreCreateMarkEventArgs Class : PreCreateMarkEventArgs Constructor
Reference to the annotation object being created.
Initializes a new instance of the PreCreateMarkEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New PreCreateMarkEventArgs(mark)
public PreCreateMarkEventArgs(
   ImGearARTMark mark
)
public: PreCreateMarkEventArgs(
   ImGearARTMark* mark
)
public:
PreCreateMarkEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
Reference to the annotation object being created.
See Also

Reference

PreCreateMarkEventArgs Class
PreCreateMarkEventArgs Members


%%PageItemTitle%% $$Properties$$

PreCreateMarkEventArgs Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreCreateMarkEventArgs Class

For a list of all members of this type, see PreCreateMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being created.
Top
See Also

Reference

PreCreateMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


Cancel Property (PreCreateMarkEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreCreateMarkEventArgs Class : Cancel Property
Gets or sets a value indicating whether the process of annotation creation has to be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PreCreateMarkEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set to true if you want to cancel the annotation creation, otherwise set to false.
See Also

Reference

PreCreateMarkEventArgs Class
PreCreateMarkEventArgs Members


Mark Property (PreCreateMarkEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreCreateMarkEventArgs Class : Mark Property
Gets a reference to the annotation object being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As PreCreateMarkEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class.
See Also

Reference

PreCreateMarkEventArgs Class
PreCreateMarkEventArgs Members


%%PageItemTitle%%

PreDeleteMarkEventArgs Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreDeleteMarkEventArgs Class
This class has been deprecated. Provides PreDeleteMark event data.
Object Model
PreDeleteMarkEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class PreDeleteMarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PreDeleteMarkEventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class PreDeleteMarkEventArgs : System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class PreDeleteMarkEventArgs : public System.EventArgs
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class PreDeleteMarkEventArgs : public System.EventArgs
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.ART.Windows.Controls.PreDeleteMarkEventArgs

See Also

Reference

PreDeleteMarkEventArgs Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

PreDeleteMarkEventArgs Class Members
Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreDeleteMarkEventArgs Class

The following tables list the members exposed by PreDeleteMarkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PreDeleteMarkEventArgs Constructor | Initializes a new instance of the PreDeleteMarkEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation deletion has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being deleted.
Top
See Also

Reference

PreDeleteMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

PreDeleteMarkEventArgs Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreDeleteMarkEventArgs Class : PreDeleteMarkEventArgs Constructor
Reference to the annotation object being deleted.
Initializes a new instance of the PreDeleteMarkEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New PreDeleteMarkEventArgs(mark)
public PreDeleteMarkEventArgs(
   ImGearARTMark mark
)
public: PreDeleteMarkEventArgs(
   ImGearARTMark* mark
)
public:
PreDeleteMarkEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
Reference to the annotation object being deleted.
See Also

Reference

PreDeleteMarkEventArgs Class
PreDeleteMarkEventArgs Members


%%PageItemTitle%% $$Properties$$

PreDeleteMarkEventArgs Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : PreDeleteMarkEventArgs Class

For a list of all members of this type, see PreDeleteMarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the process of annotation deletion has to be canceled.
Public Property | Mark | Gets a reference to the annotation object being deleted.
Top
See Also

Reference

PreDeleteMarkEventArgs Class
ImageGear.ART.Windows.Controls Namespace


Cancel Property (PreDeleteMarkEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreDeleteMarkEventArgs Class : Cancel Property
Gets or sets a value indicating whether the process of annotation deletion has to be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PreDeleteMarkEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set to true if you want to cancel the annotation deletion, otherwise set to false.
See Also

Reference

PreDeleteMarkEventArgs Class
PreDeleteMarkEventArgs Members


Mark Property (PreDeleteMarkEventArgs)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > PreDeleteMarkEventArgs Class : Mark Property
Gets a reference to the annotation object being deleted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mark As ImGearARTMark
'Usage

Dim instance As PreDeleteMarkEventArgs
Dim value As ImGearARTMark

value = instance.Mark
public ImGearARTMark Mark {get;}
public: __property ImGearARTMark* get_Mark();
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
}

Property Value

ImageGear.ART.ImGearARTMark class.
See Also

Reference

PreDeleteMarkEventArgs Class
PreDeleteMarkEventArgs Members


%%PageItemTitle%%

ToolBar Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBar Class
This class has been deprecated. Provides control for creating, selecting and editing annotations. ToolBar
Object Model
ToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public NotInheritable Class ToolBar
   Inherits System.Windows.Controls.UserControl
'Usage

Dim instance As ToolBar
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public sealed class ToolBar : System.Windows.Controls.UserControl
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc __sealed class ToolBar : public System.Windows.Controls.UserControl
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class ToolBar sealed : public System.Windows.Controls.UserControl
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
ImageGear.ART.Windows.Controls.ToolBar

See Also

Reference

ToolBar Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ToolBar Class Members
Properties Methods Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBar Class

The following tables list the members exposed by ToolBar.

Public Constructors
 | Name | Description
Public Constructor | ToolBar Constructor | Initializes a new instance of the ToolBar class.
Top
Public Properties
 | Name | Description
Public Property | Button | Gets or sets a reference to the currectly selected Toolbar button.
Top
Public Methods
 | Name | Description
Public Method | InitializeComponent | InitializeComponent
Top
See Also

Reference

ToolBar Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

ToolBar Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBar Class : ToolBar Constructor
Initializes a new instance of the ToolBar class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolBar()
public ToolBar()
public: ToolBar();
public:
ToolBar();
See Also

Reference

ToolBar Class
ToolBar Members


%%PageItemTitle%% $$Methods$$

ToolBar Class Methods

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

Public Methods
 | Name | Description
Public Method | InitializeComponent | InitializeComponent
Top
See Also

Reference

ToolBar Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ToolBar Class Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

See Also

Reference

ToolBar Class
ImageGear.ART.Windows.Controls Namespace


InitializeComponent Method (ToolBar)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBar Class : InitializeComponent Method
InitializeComponent
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<GeneratedCodeAttribute(Tool="PresentationBuildTasks", Version="4.0.0.0")>
Public Sub InitializeComponent()
'Usage

Dim instance As ToolBar

instance.InitializeComponent()
[DebuggerNonUserCode()]
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
public void InitializeComponent()
[DebuggerNonUserCode()]
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
public: void InitializeComponent();
[DebuggerNonUserCode()]
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
public:
void InitializeComponent();
See Also

Reference

ToolBar Class
ToolBar Members


%%PageItemTitle%% $$Properties$$

ToolBar Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

Public Properties
 | Name | Description
Public Property | Button | Gets or sets a reference to the currectly selected Toolbar button.
Top
See Also

Reference

ToolBar Class
ImageGear.ART.Windows.Controls Namespace


Button Property (ToolBar)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBar Class : Button Property
Gets or sets a reference to the currectly selected Toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Button As ImGearARTMarkType
'Usage

Dim instance As ToolBar
Dim value As ImGearARTMarkType

instance.Button = value

value = instance.Button
public ImGearARTMarkType Button {get; set;}
public: __property ImGearARTMarkType get_Button();
public: __property void set_Button(
   ImGearARTMarkType value
);
public:
property ImGearARTMarkType Button {
   ImGearARTMarkType get();
   void set (    ImGearARTMarkType value);
}

Property Value

ImageGear.ART.ImGearARTMarkType enumeration value.
See Also

Reference

ToolBar Class
ToolBar Members


%%PageItemTitle%%

ToolBarAnnotator Class
Members

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBarAnnotator Class
This class has been deprecated. Provides properties and methods that implement user interface for annotating using ToolBar.
Object Model
ToolBarAnnotator ClassToolBar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Class ToolBarAnnotator
   Inherits Annotator
'Usage

Dim instance As ToolBarAnnotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public class ToolBarAnnotator : Annotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public __gc class ToolBarAnnotator : public Annotator
[Obsolete("This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public ref class ToolBarAnnotator : public Annotator
Remarks
This class will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
ImageGear.ART.Windows.Controls.Annotator
ImageGear.ART.Windows.Controls.ToolBarAnnotator

See Also

Reference

ToolBarAnnotator Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ToolBarAnnotator Class Members
Properties Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBarAnnotator Class

The following tables list the members exposed by ToolBarAnnotator.

Public Constructors
 | Name | Description
Public Constructor | ToolBarAnnotator Constructor | Initializes a new instance of the ToolBarAnnotator class.
Top
Public Properties
 | Name | Description
Public Property | Tool | Overridden. Gets or sets annotation selected tool.
Public Property | ToolBar | Gets or sets a reference to the annotation ToolBar control.
Top
See Also

Reference

ToolBarAnnotator Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

ToolBarAnnotator Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBarAnnotator Class : ToolBarAnnotator Constructor
Reference to the page view control.
Reference to the ToolBar class.
Initializes a new instance of the ToolBarAnnotator class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As PageView, _
   ByVal toolBar As ToolBar _
)
'Usage

Dim pageView As PageView
Dim toolBar As ToolBar

Dim instance As New ToolBarAnnotator(pageView, toolBar)
public ToolBarAnnotator(
   PageView pageView,
   ToolBar toolBar
)
public: ToolBarAnnotator(
   PageView* pageView,
   ToolBar* toolBar
)
public:
ToolBarAnnotator(
   PageView^ pageView,
   ToolBar^ toolBar
)

Parameters

pageView
Reference to the page view control.
toolBar
Reference to the ToolBar class.
See Also

Reference

ToolBarAnnotator Class
ToolBarAnnotator Members
PageView Class
ToolBar Property


%%PageItemTitle%% $$Properties$$

ToolBarAnnotator Class Properties

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBarAnnotator Class

For a list of all members of this type, see ToolBarAnnotator members.

Public Properties
 | Name | Description
Public Property | Tool | Overridden. Gets or sets annotation selected tool.
Public Property | ToolBar | Gets or sets a reference to the annotation ToolBar control.
Top
See Also

Reference

ToolBarAnnotator Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ToolBarAnnotator Class Events

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ToolBarAnnotator Class

For a list of all members of this type, see ToolBarAnnotator members.

See Also

Reference

ToolBarAnnotator Class
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

ToolBarAnnotator Constructor

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBarAnnotator Class : ToolBarAnnotator Constructor
Overload List
Overload | Description
ToolBarAnnotator Constructor | Initializes a new instance of the ToolBarAnnotator class.
See Also

Reference

ToolBarAnnotator Class
ToolBarAnnotator Members


Tool Property (ToolBarAnnotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBarAnnotator Class : Tool Property
Gets or sets annotation selected tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Tool As ImGearARTMarkType
'Usage

Dim instance As ToolBarAnnotator
Dim value As ImGearARTMarkType

instance.Tool = value

value = instance.Tool
public override ImGearARTMarkType Tool {get; set;}
public: __property ImGearARTMarkType get_Tool() override;
public: __property void set_Tool(
   ImGearARTMarkType value
) override;
public:
property ImGearARTMarkType Tool {
   ImGearARTMarkType get() override;
   void set (    ImGearARTMarkType value) override;
}

Property Value

ImageGear.ART.ImGearARTMarkType enumeration value.
See Also

Reference

ToolBarAnnotator Class
ToolBarAnnotator Members


ToolBar Property (ToolBarAnnotator)

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace > ToolBarAnnotator Class : ToolBar Property
Gets or sets a reference to the annotation ToolBar control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToolBar As ToolBar
'Usage

Dim instance As ToolBarAnnotator
Dim value As ToolBar

instance.ToolBar = value

value = instance.ToolBar
public ToolBar ToolBar {get; set;}
public: __property ToolBar* get_ToolBar();
public: __property void set_ToolBar(
   ToolBar* value
);
public:
property ToolBar^ ToolBar {
   ToolBar^ get();
   void set (    ToolBar^ value);
}

Property Value

ToolBar class.
See Also

Reference

ToolBarAnnotator Class
ToolBarAnnotator Members


%%PageItemTitle%%

InteractionArea Enumeration

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : InteractionArea Enumeration
This enumeration has been deprecated. Specifies the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Enum InteractionArea
   Inherits System.Enum
'Usage

Dim instance As InteractionArea
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum InteractionArea : System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
__value public enum InteractionArea : public System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum class InteractionArea : public System.Enum
Members
Member | Value | Description
Device | 0 | Allows unlimited annotation editing for the entire device.
Image | 1 | Limits the annotation editing area to the image portion of the page view.
Remarks

You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device. This affects creating, selecting, resizing and moving annotations.

This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Windows.Controls.InteractionArea

See Also

Reference

ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Mode Enumeration

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Mode Enumeration
This enumeration has been deprecated. Specifies the annotation modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Enum Mode
   Inherits System.Enum
'Usage

Dim instance As Mode
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum Mode : System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
__value public enum Mode : public System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum class Mode : public System.Enum
Members
Member | Value | Description
Edit | 0 | Edit mode allows users to create, edit and delete annotations.
Run | 1 | Run mode allows users operate on hot spot, audio, and button activities.
View | 2 | View-only mode allows users to view marks, not add or modify them.
Remarks
This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Windows.Controls.Mode

See Also

Reference

ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

ModifyReason Enumeration

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : ModifyReason Enumeration
This enumeration has been deprecated. Specifies types of annotation's change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")>
Public Enum ModifyReason
   Inherits System.Enum
'Usage

Dim instance As ModifyReason
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum ModifyReason : System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
__value public enum ModifyReason : public System.Enum
[Obsolete("This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.")]
public enum class ModifyReason : public System.Enum
Members
Member | Value | Description
AttributeChange | 1 | Annotation attribute change.
Move | 2 | Annotation move.
Resize | 3 | Annotation resize.
TextEdit | 0 | Annotation text change.
Remarks
This enumeration will be removed from the public API in a future release. The annotation user interface can now be accessed directly through the PageView control by referencing the ImageGear.Windows.Controls.Art.dll assembly.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.ART.Windows.Controls.ModifyReason

See Also

Reference

ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator.ArtMouseButtonEventHandler Delegate

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator.ArtMouseButtonEventHandler Delegate
The source of the event.
ArtMouseButtonEventArgs class object that contains mouse button event data.
This delegate has been deprecated. Represents the method that will handle mouse button events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Annotator.ArtMouseButtonEventHandler( _
   ByVal sender As Object, _
   ByVal e As ArtMouseButtonEventArgs _
)
'Usage

Dim instance As New Annotator.ArtMouseButtonEventHandler(AddressOf HandlerMethod)
public delegate void Annotator.ArtMouseButtonEventHandler(
   object sender,
   ArtMouseButtonEventArgs e
)
public: __gc __delegate void Annotator.ArtMouseButtonEventHandler(
   Object* sender,
   ArtMouseButtonEventArgs* e
)
public delegate void Annotator.ArtMouseButtonEventHandler(
   Object^ sender,
   ArtMouseButtonEventArgs^ e
)

Parameters

sender
The source of the event.
e
ArtMouseButtonEventArgs class object that contains mouse button event data.
See Also

Reference

Annotator.ArtMouseButtonEventHandler Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator.ArtMouseEventHandler Delegate

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator.ArtMouseEventHandler Delegate
The source of the event.
ArtMouseEventArgs class that contains mouse button event event data.
This delegate has been deprecated. Represents the method that will handle Mouse events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Annotator.ArtMouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As ArtMouseEventArgs _
)
'Usage

Dim instance As New Annotator.ArtMouseEventHandler(AddressOf HandlerMethod)
public delegate void Annotator.ArtMouseEventHandler(
   object sender,
   ArtMouseEventArgs e
)
public: __gc __delegate void Annotator.ArtMouseEventHandler(
   Object* sender,
   ArtMouseEventArgs* e
)
public delegate void Annotator.ArtMouseEventHandler(
   Object^ sender,
   ArtMouseEventArgs^ e
)

Parameters

sender
The source of the event.
e
ArtMouseEventArgs class that contains mouse button event event data.
See Also

Reference

Annotator.ArtMouseEventHandler Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator.ModifyMarkEventHandler Delegate

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator.ModifyMarkEventHandler Delegate
The source of the event.
ModifyMarkEventArgs class that contains Annotator.ModifyMark event data.
This delegate has been deprecated. Represents the method that will handle ModifyMark event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Annotator.ModifyMarkEventHandler( _
   ByVal sender As Object, _
   ByVal e As ModifyMarkEventArgs _
)
'Usage

Dim instance As New Annotator.ModifyMarkEventHandler(AddressOf HandlerMethod)
public delegate void Annotator.ModifyMarkEventHandler(
   object sender,
   ModifyMarkEventArgs e
)
public: __gc __delegate void Annotator.ModifyMarkEventHandler(
   Object* sender,
   ModifyMarkEventArgs* e
)
public delegate void Annotator.ModifyMarkEventHandler(
   Object^ sender,
   ModifyMarkEventArgs^ e
)

Parameters

sender
The source of the event.
e
ModifyMarkEventArgs class that contains Annotator.ModifyMark event data.
See Also

Reference

Annotator.ModifyMarkEventHandler Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator.PreCreateMarkEventHandler Delegate

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator.PreCreateMarkEventHandler Delegate
The source of the event.
PreCreateMarkEventArgs class that contains Annotator.PreCreateMark event data.
This delegate has been deprecated. Represents the method that will handle PreCreateMark event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Annotator.PreCreateMarkEventHandler( _
   ByVal sender As Object, _
   ByVal e As PreCreateMarkEventArgs _
)
'Usage

Dim instance As New Annotator.PreCreateMarkEventHandler(AddressOf HandlerMethod)
public delegate void Annotator.PreCreateMarkEventHandler(
   object sender,
   PreCreateMarkEventArgs e
)
public: __gc __delegate void Annotator.PreCreateMarkEventHandler(
   Object* sender,
   PreCreateMarkEventArgs* e
)
public delegate void Annotator.PreCreateMarkEventHandler(
   Object^ sender,
   PreCreateMarkEventArgs^ e
)

Parameters

sender
The source of the event.
e
PreCreateMarkEventArgs class that contains Annotator.PreCreateMark event data.
See Also

Reference

Annotator.PreCreateMarkEventHandler Members
ImageGear.ART.Windows.Controls Namespace


%%PageItemTitle%%

Annotator.PreDeleteMarkEventHandler Delegate

ImageGear22.Art.Windows.Controls Assembly > ImageGear.ART.Windows.Controls Namespace : Annotator.PreDeleteMarkEventHandler Delegate
The source of the event.
PreDeleteMarkEventArgs class that contains Annotator.PreDeleteMark event data.
This delegate has been deprecated. Represents the method that will handle PreDeleteMark event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Annotator.PreDeleteMarkEventHandler( _
   ByVal sender As Object, _
   ByVal e As PreDeleteMarkEventArgs _
)
'Usage

Dim instance As New Annotator.PreDeleteMarkEventHandler(AddressOf HandlerMethod)
public delegate void Annotator.PreDeleteMarkEventHandler(
   object sender,
   PreDeleteMarkEventArgs e
)
public: __gc __delegate void Annotator.PreDeleteMarkEventHandler(
   Object* sender,
   PreDeleteMarkEventArgs* e
)
public delegate void Annotator.PreDeleteMarkEventHandler(
   Object^ sender,
   PreDeleteMarkEventArgs^ e
)

Parameters

sender
The source of the event.
e
PreDeleteMarkEventArgs class that contains Annotator.PreDeleteMark event data.
See Also

Reference

Annotator.PreDeleteMarkEventHandler Members
ImageGear.ART.Windows.Controls Namespace


ImageGear22.Barcode Assembly
Namespaces
Namespace | Description
ImageGear.Barcode | The ImageGear.Bardcode namespace provides a set of objects that provide access to barcode recognition technology.


ImageGear.Barcode Namespace
Inheritance Hierarchy
ImageGear22.Barcode Assembly : ImageGear.Barcode Namespace
The ImageGear.Bardcode namespace provides a set of objects that provide access to barcode recognition technology.
Classes
 | Class | Description
Class | ImGearBarcode | The main object for this component. DJS sealed is for consistancy with IG.
Class | ImGearBarcodeReader | The ImGearBarcodeReader Class includes methods and properties to be used in recognizing barcodes.
Class | ImGearBarcodeResult | The Results Class includes properties used to return barcode recognition results.
Class | ImGearBarcodeWriter | The ImGearBarcodeWriter Class is inherited from the ImGearBarcodeWriterBase Class and is used to create barcodes.
Class | ImGearBarcodeWriterBase | The ImGearBarcodeWriterBase Class includes properties used to write barcode recognition results.
Class | ImGearBarcodeWriterDataMatrix | ImGearBarcodeWriterDataMatrix extends the writer class to include the writing of DataMatrix barcodes.
Class | ImGearBarcodeWriterPDF417 | ImGearBarcodeWriterPDF417 extends the writer class to include the writing of PDF417 barcodes.
Enumerations
 | Enumeration | Description
Enumeration | EvaluationMode | The evaluation choice of the component.
Enumeration | ImGearBarcodeAustralianPostCustomDecodeType | The Australian Post 4 State barocde supports a custom section in both the Customer Barcode 2 and Customer Barcode 3 formats.
Enumeration | ImGearBarcodeDataMatrixSizes | The rows and columns are encoded in the value of the enumerations using this equation: RowsXColumnsY = X * 256 + Y. AutoRowsAndColumns is -1.
Enumeration | ImGearBarcodeInkColorInfo | Specifies the ink color for barcodes search.
Enumeration | ImGearBarcodeLicenseFeature | Identifies public license features.
Enumeration | ImGearBarcodeOrientationInfo | Specifies the orientation for the barcode search.
Enumeration | ImGearBarcodePDF417ErrorCorrectionLevel | PDF417 Error correction levels.
Enumeration | ImGearBarcodeShowTextInfo | Specifies the text to display adjacent to the created barcode.
Enumeration | ImGearBarcodeType | Specifies a barcode type.
See Also

Reference

ImageGear22.Barcode Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Barcode Namespace Inheritance Hierarchy
ImageGear22.Barcode Assembly : ImageGear.Barcode Namespace
Inheritance Hierarchy
System.Object
ImageGear.Barcode.ImGearBarcode
ImageGear.Barcode.ImGearBarcodeReader
ImageGear.Barcode.ImGearBarcodeResult
ImageGear.Barcode.ImGearBarcodeWriterBase
ImageGear.Barcode.ImGearBarcodeWriter
ImageGear.Barcode.ImGearBarcodeWriterDataMatrix
ImageGear.Barcode.ImGearBarcodeWriterPDF417
See Also

Reference

ImageGear22.Barcode Assembly


%%PageItemTitle%%

ImGearBarcode Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcode Class
The main object for this component. DJS sealed is for consistancy with IG.
Object Model
ImGearBarcode ClassImGearBarcodeReader ClassImGearBarcodeWriter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearBarcode
'Usage

Dim instance As ImGearBarcode
public sealed class ImGearBarcode
public __gc __sealed class ImGearBarcode
public ref class ImGearBarcode sealed
Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcode

See Also

Reference

ImGearBarcode Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcode Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcode Class

The following tables list the members exposed by ImGearBarcode.

Public Constructors
 | Name | Description
Public Constructor | ImGearBarcode Constructor | Initializes a new instance of the ImGearBarcode class.
Top
Public Properties
 | Name | Description
Public Property | Reader | Gets access to the reader object.
Public Property | Writer | Gets access to the writer object.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Shuts down the barcode engine.
Public Method | IsFeatureLicensed | Returns whether or not a given barcode feature is licensed.
Public Method | ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method | WriteToStream | Writes some properties of this object to a specially-formatted stream.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearBarcode class.
Top
See Also

Reference

ImGearBarcode Class
ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcode Constructor

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : ImGearBarcode Constructor
Initializes a new instance of the ImGearBarcode class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBarcode()
public ImGearBarcode()
public: ImGearBarcode();
public:
ImGearBarcode();
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


Dispose Method (ImGearBarcode)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : Dispose Method
Shuts down the barcode engine.
Overload List
Overload | Description
Dispose | Shuts down the barcode engine.
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


%%PageItemTitle%% $$Methods$$

ImGearBarcode Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcode Class

For a list of all members of this type, see ImGearBarcode members.

Public Methods
 | Name | Description
Public Method | Dispose | Shuts down the barcode engine.
Public Method | IsFeatureLicensed | Returns whether or not a given barcode feature is licensed.
Public Method | ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method | WriteToStream | Writes some properties of this object to a specially-formatted stream.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearBarcode class.
Top
See Also

Reference

ImGearBarcode Class
ImageGear.Barcode Namespace


Dispose() Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : Dispose() Method
Shuts down the barcode engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearBarcode

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This is a standard .NET Dispose method for the ImGearBarcode object. It shuts down the Barcode engine, freeing its associated resources. After this method has been called, the application should refrain from accessing any methods or properties of ImGearBarcode or any associated objects.

It is acceptable to call this Dispose method, instantiate a new ImGearBarcode object, and then use that object.

See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


Finalize Method (ImGearBarcode)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : Finalize Method
Finalizes an instance of the ImGearBarcode class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearBarcode

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


IsFeatureLicensed Method (ImGearBarcode)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : IsFeatureLicensed Method
Feature to be verified.
Returns whether or not a given barcode feature is licensed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsFeatureLicensed( _
   ByVal feature As ImGearBarcodeLicenseFeature _
) As Boolean
'Usage

Dim instance As ImGearBarcode
Dim feature As ImGearBarcodeLicenseFeature
Dim value As Boolean

value = instance.IsFeatureLicensed(feature)
public bool IsFeatureLicensed(
   ImGearBarcodeLicenseFeature feature
)
public: bool IsFeatureLicensed(
   ImGearBarcodeLicenseFeature feature
)
public:
bool IsFeatureLicensed(
   ImGearBarcodeLicenseFeature feature
)

Parameters

feature
Feature to be verified.

Return Value

True if the feature is licensed, False - otherwise.
Remarks
Verifies whether a barcode feature is licensed or not.
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members
ImGearBarcodeLicenseFeature Enumeration


ReadFromStream Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : ReadFromStream Method
A stream that the method created.
Reads a specially-formatted stream and places the values into properties of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Sub ReadFromStream( _
   ByVal streamIn As String _
)
'Usage

Dim instance As ImGearBarcode
Dim streamIn As String

instance.ReadFromStream(streamIn)
[Browsable(true)]
public void ReadFromStream(
   string streamIn
)
[Browsable(true)]
public: void ReadFromStream(
   string* streamIn
)
[Browsable(true)]
public:
void ReadFromStream(
   String^ streamIn
)

Parameters

streamIn
A stream that the method created.
Remarks

This method reads a stream, which contains the values of roperties for this object. It provides a convenient way to store and retrieve the values and preserves as much future compatibility as possible.

This method should read any stream that the WriteToStream method created, even if an older version of this component created it.

Note: You should retrieve the value for the stream from the Construction property of a FormDirector FormDefinition object. When the Type property of that object is "ImGearBarcode", the Content property contains a string that you should send to this method.

See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


WriteToStream Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : WriteToStream Method
Writes some properties of this object to a specially-formatted stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Function WriteToStream() As String
'Usage

Dim instance As ImGearBarcode
Dim value As String

value = instance.WriteToStream()
[Browsable(true)]
public string WriteToStream()
[Browsable(true)]
public: string* WriteToStream();
[Browsable(true)]
public:
String^ WriteToStream();

Return Value

A stream that can reloaded using the ReadFromStream method.
Remarks

This method writes certain properties of this object to a stream. The stream is intended for use only by the ReadFromStream method and its format may change in a future release of this component. However, even if the format changes, future versions of this components will be able to read streams that this method generates.

Note: You should save the stream in the Construcion property of a FormDirector FormDefinition object. You should set the Type to "ImGearBarcode" and the Content to the value that this method returns.

See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


%%PageItemTitle%% $$Properties$$

ImGearBarcode Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcode Class

For a list of all members of this type, see ImGearBarcode members.

Public Properties
 | Name | Description
Public Property | Reader | Gets access to the reader object.
Public Property | Writer | Gets access to the writer object.
Top
See Also

Reference

ImGearBarcode Class
ImageGear.Barcode Namespace


Reader Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : Reader Property
Gets access to the reader object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Reader As ImGearBarcodeReader
'Usage

Dim instance As ImGearBarcode
Dim value As ImGearBarcodeReader

value = instance.Reader
[Browsable(false)]
public ImGearBarcodeReader Reader {get;}
[Browsable(false)]
public: __property ImGearBarcodeReader* get_Reader();
[Browsable(false)]
public:
property ImGearBarcodeReader^ Reader {
   ImGearBarcodeReader^ get();
}

Property Value

The main object for reading a barcode.
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


Writer Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcode Class : Writer Property
Gets access to the writer object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Writer As ImGearBarcodeWriter
'Usage

Dim instance As ImGearBarcode
Dim value As ImGearBarcodeWriter

value = instance.Writer
[Browsable(false)]
public ImGearBarcodeWriter Writer {get;}
[Browsable(false)]
public: __property ImGearBarcodeWriter* get_Writer();
[Browsable(false)]
public:
property ImGearBarcodeWriter^ Writer {
   ImGearBarcodeWriter^ get();
}

Property Value

The main object for writing a barcode.
See Also

Reference

ImGearBarcode Class
ImGearBarcode Members


%%PageItemTitle%%

ImGearBarcodeReader Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeReader Class
The ImGearBarcodeReader Class includes methods and properties to be used in recognizing barcodes.
Object Model
ImGearBarcodeReader ClassImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeReader
'Usage

Dim instance As ImGearBarcodeReader
public class ImGearBarcodeReader
public __gc class ImGearBarcodeReader
public ref class ImGearBarcodeReader
Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeReader

See Also

Reference

ImGearBarcodeReader Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeReader Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeReader Class

The following tables list the members exposed by ImGearBarcodeReader.

Public Properties
 | Name | Description
Public Property | AppendCheckSum | Gets or sets a value indicating whether a check sum value is appended to the barcode during recognition.
Public Property | Area | Gets or sets the area of the image, in pixels, to analyze for barcode recognition.
Public Property | AustralianPostCustomDecodeMode | Gets or sets the ImGearBarcodeAustralianPostCustomDecodeType.
Public Property | BarcodeTypes | Gets the type of barcodes to analyze during recognition processing.
Public Property | IncludeControlCharacters | Gets or sets a value indicating whether the control chracters are included in the barcode value during recognition processing.
Public Property | InkColor | Gets or sets the ink color of barcodes to search for during recognition processing.
Public Property | MaximumBarcodes | Gets or sets the maximum number of barcodes to recognize.
Public Property | Orientation | Gets or sets the orientation of the barcodes to analyze during recognition.
Public Property | Performance | Gets the barcode capability and performance for the system.
Public Property | ReturnPossibleBarcodes | Gets or sets a value indicating whether possible barcodes are returned in the result collection.
Public Property | ScanDistance | Gets or sets the scan distance in pixels between line sweeps when searching for 1D barcodes.
Top
Public Methods
 | Name | Description
Public Method | Analyze | Detects barcodes on the given ImGearPage image.
Top
See Also

Reference

ImGearBarcodeReader Class
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Methods$$

ImGearBarcodeReader Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeReader Class

For a list of all members of this type, see ImGearBarcodeReader members.

Public Methods
 | Name | Description
Public Method | Analyze | Detects barcodes on the given ImGearPage image.
Top
See Also

Reference

ImGearBarcodeReader Class
ImageGear.Barcode Namespace


Analyze Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : Analyze Method
Detects barcodes on the given image.
Overload List
Overload | Description
Analyze | Detects barcodes on the given ImGearPage image.
See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


Analyze(ImGearPage) Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : Analyze(ImGearPage) Method
ImGearPage object containing the image to be analyzed.
Detects barcodes on the given ImGearPage image.
Detects barcodes on the given image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Analyze( _
   ByVal page As ImGearPage _
) As Collection(Of ImGearBarcodeResult)
'Usage

Dim instance As ImGearBarcodeReader
Dim page As ImGearPage
Dim value As Collection(Of ImGearBarcodeResult)

value = instance.Analyze(page)
public Collection<ImGearBarcodeResult> Analyze(
   ImGearPage page
)
public: Collection<ImGearBarcodeResult*>* Analyze(
   ImGearPage* page
)
public:
Collection<ImGearBarcodeResult^>^ Analyze(
   ImGearPage^ page
)

Parameters

page
ImGearPage object containing the image to be analyzed.

Return Value

Each element of the ImGearBarcodeResult Class contains the results of a single recognized barcode.
See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members
ImGearBarcodeResult Class


%%PageItemTitle%% $$Properties$$

ImGearBarcodeReader Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeReader Class

For a list of all members of this type, see ImGearBarcodeReader members.

Public Properties
 | Name | Description
Public Property | AppendCheckSum | Gets or sets a value indicating whether a check sum value is appended to the barcode during recognition.
Public Property | Area | Gets or sets the area of the image, in pixels, to analyze for barcode recognition.
Public Property | AustralianPostCustomDecodeMode | Gets or sets the ImGearBarcodeAustralianPostCustomDecodeType.
Public Property | BarcodeTypes | Gets the type of barcodes to analyze during recognition processing.
Public Property | IncludeControlCharacters | Gets or sets a value indicating whether the control chracters are included in the barcode value during recognition processing.
Public Property | InkColor | Gets or sets the ink color of barcodes to search for during recognition processing.
Public Property | MaximumBarcodes | Gets or sets the maximum number of barcodes to recognize.
Public Property | Orientation | Gets or sets the orientation of the barcodes to analyze during recognition.
Public Property | Performance | Gets the barcode capability and performance for the system.
Public Property | ReturnPossibleBarcodes | Gets or sets a value indicating whether possible barcodes are returned in the result collection.
Public Property | ScanDistance | Gets or sets the scan distance in pixels between line sweeps when searching for 1D barcodes.
Top
See Also

Reference

ImGearBarcodeReader Class
ImageGear.Barcode Namespace


AppendCheckSum Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : AppendCheckSum Property
Gets or sets a value indicating whether a check sum value is appended to the barcode during recognition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AppendCheckSum As Boolean
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Boolean

instance.AppendCheckSum = value

value = instance.AppendCheckSum
public bool AppendCheckSum {get; set;}
public: __property bool get_AppendCheckSum();
public: __property void set_AppendCheckSum(
   bool value
);
public:
property bool AppendCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which designates the check sum.
Remarks

If this property is set to true, check sum values will be appened for barcode types that require a check sum. This property does not have any effect for barcode types which do not have a check sum or the check sum is optional.

Default value: false

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


Area Property (ImGearBarcodeReader)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : Area Property
Gets or sets the area of the image, in pixels, to analyze for barcode recognition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As ImGearRectangle
'Usage

Dim instance As ImGearBarcodeReader
Dim value As ImGearRectangle

instance.Area = value

value = instance.Area
public ImGearRectangle Area {get; set;}
public: __property ImGearRectangle get_Area();
public: __property void set_Area(
   ImGearRectangle value
);
public:
property ImGearRectangle Area {
   ImGearRectangle get();
   void set (    ImGearRectangle value);
}

Property Value

A ImageGear.Core.ImGearRectangle object.
Remarks

If it is desired to analyze the entire image, set the Area property values (x, y, width and height) to zero.

Default value: 0,0,0,0

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


AustralianPostCustomDecodeMode Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : AustralianPostCustomDecodeMode Property
Gets or sets the ImGearBarcodeAustralianPostCustomDecodeType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AustralianPostCustomDecodeMode As ImGearBarcodeAustralianPostCustomDecodeType
'Usage

Dim instance As ImGearBarcodeReader
Dim value As ImGearBarcodeAustralianPostCustomDecodeType

instance.AustralianPostCustomDecodeMode = value

value = instance.AustralianPostCustomDecodeMode
public ImGearBarcodeAustralianPostCustomDecodeType AustralianPostCustomDecodeMode {get; set;}
public: __property ImGearBarcodeAustralianPostCustomDecodeType get_AustralianPostCustomDecodeMode();
public: __property void set_AustralianPostCustomDecodeMode(
   ImGearBarcodeAustralianPostCustomDecodeType value
);
public:
property ImGearBarcodeAustralianPostCustomDecodeType AustralianPostCustomDecodeMode {
   ImGearBarcodeAustralianPostCustomDecodeType get();
   void set (    ImGearBarcodeAustralianPostCustomDecodeType value);
}

Property Value

The ImGearBarcodeAustralianPostCustomDecodeType set.
Remarks

This property gets and sets the custom section in both the Customer Barcode 2 and Customer Barcode 3 formats. The ImGearBarcodeAustralianPostCustomDecodeType enumeration is used to set this value.

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


BarcodeTypes Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : BarcodeTypes Property
Gets the type of barcodes to analyze during recognition processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BarcodeTypes As Collection(Of ImGearBarcodeType)
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Collection(Of ImGearBarcodeType)

value = instance.BarcodeTypes
public Collection<ImGearBarcodeType> BarcodeTypes {get;}
public: __property Collection<ImGearBarcodeType>* get_BarcodeTypes();
public:
property Collection<ImGearBarcodeType>^ BarcodeTypes {
   Collection<ImGearBarcodeType>^ get();
}

Property Value

The ImGearBarcodeType set.
Remarks

By default, the barcode engine searches for all 1D barcodes. The 1D barcode set includes all types, except PatchCodeBarcode, PostNetBarcode, PDF417Barcode, Aztec and DataMatrixBarcode

Barcode types can be combined. The C# example below demonstrates creating a generic collection of BarcodeTypes.

Default value: ImGearBarcodeType.UnknownBarcode

Example

// Clear all barcode types

// Remember by default, the barcode engine searches for all 1D barcodes

IGBarcode.Reader.BarcodeTypes.Clear();

// Add barcode types

IGBarcode.Reader.BarcodeTypes.Add(ImGearBarcodeType.Industry2of5Barcode);

IGBarcode.Reader.BarcodeTypes.Add(ImGearBarcodeType.Interleaved2of5Barcode);

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


IncludeControlCharacters Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : IncludeControlCharacters Property
Gets or sets a value indicating whether the control chracters are included in the barcode value during recognition processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeControlCharacters As Boolean
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Boolean

instance.IncludeControlCharacters = value

value = instance.IncludeControlCharacters
public bool IncludeControlCharacters {get; set;}
public: __property bool get_IncludeControlCharacters();
public: __property void set_IncludeControlCharacters(
   bool value
);
public:
property bool IncludeControlCharacters {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which represents if control characters are included or not.
Remarks

If this property is set to True, the barcode control characters are included in the barcode read value. This has no effect for barcodes which do not support control characters.

Codabar barcode returns the Start and Stop characters.

Default value: False

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


InkColor Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : InkColor Property
Gets or sets the ink color of barcodes to search for during recognition processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InkColor As ImGearBarcodeInkColorInfo
'Usage

Dim instance As ImGearBarcodeReader
Dim value As ImGearBarcodeInkColorInfo

instance.InkColor = value

value = instance.InkColor
public ImGearBarcodeInkColorInfo InkColor {get; set;}
public: __property ImGearBarcodeInkColorInfo get_InkColor();
public: __property void set_InkColor(
   ImGearBarcodeInkColorInfo value
);
public:
property ImGearBarcodeInkColorInfo InkColor {
   ImGearBarcodeInkColorInfo get();
   void set (    ImGearBarcodeInkColorInfo value);
}

Property Value

The InkColor enumeration set.
Remarks

The barcode recognition engine is capable of detecting barcodes in an image without any prior knowledge of the barcode color. However, you can speed up the recognition process by specifying a barcode color.

Default value: ImGearBarcodeInkColorInfo.Black

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


MaximumBarcodes Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : MaximumBarcodes Property
Gets or sets the maximum number of barcodes to recognize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumBarcodes As Integer
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Integer

instance.MaximumBarcodes = value

value = instance.MaximumBarcodes
public int MaximumBarcodes {get; set;}
public: __property int get_MaximumBarcodes();
public: __property void set_MaximumBarcodes(
   int value
);
public:
property int MaximumBarcodes {
   int get();
   void set (    int value);
}

Property Value

A long which represents the maximum of barcodes to recognize.
Remarks

Note: Processing will halt after this number of barcodes have been found.

Default value: 100

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


Orientation Property (ImGearBarcodeReader)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : Orientation Property
Gets or sets the orientation of the barcodes to analyze during recognition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearBarcodeOrientationInfo
'Usage

Dim instance As ImGearBarcodeReader
Dim value As ImGearBarcodeOrientationInfo

instance.Orientation = value

value = instance.Orientation
public ImGearBarcodeOrientationInfo Orientation {get; set;}
public: __property ImGearBarcodeOrientationInfo get_Orientation();
public: __property void set_Orientation(
   ImGearBarcodeOrientationInfo value
);
public:
property ImGearBarcodeOrientationInfo Orientation {
   ImGearBarcodeOrientationInfo get();
   void set (    ImGearBarcodeOrientationInfo value);
}

Property Value

The ImGearBarcodeOrientationInfo value set.
Remarks

The barcode recognition engine is capable of detecting barcodes in an image without any prior knowledge of the barcode orientation. However, you can speed up the recognition process by specifying a barcode orientation.

Default value: ImGearBarcodeOrientationInfo.HorizontalVertical

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


Performance Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : Performance Property
Gets the barcode capability and performance for the system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Performance As String
'Usage

Dim instance As ImGearBarcodeReader
Dim value As String

value = instance.Performance
public string Performance {get;}
public: __property string* get_Performance();
public:
property String^ Performance {
   String^ get();
}

Property Value

A string which represents the performance of the barcode.
Remarks

This property returns the number of barcodes detected as well as the total recognition time, in milliseconds.

Note: The performance value is only valid after the Analyze method has been called.

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


ReturnPossibleBarcodes Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : ReturnPossibleBarcodes Property
Gets or sets a value indicating whether possible barcodes are returned in the result collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReturnPossibleBarcodes As Boolean
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Boolean

instance.ReturnPossibleBarcodes = value

value = instance.ReturnPossibleBarcodes
public bool ReturnPossibleBarcodes {get; set;}
public: __property bool get_ReturnPossibleBarcodes();
public: __property void set_ReturnPossibleBarcodes(
   bool value
);
public:
property bool ReturnPossibleBarcodes {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which represents if possible barcodes are returned or not.
Remarks

The default value is false.

When this property is set to True, the barcode engine returns candidate barcodes which could not be decoded in the results collection.

For 1D barcodes, any unsolved regions of interest in the barcode result collection have a ImGearBarcodeType of UnknownBarcode and the ImGearBarcodeResult.BarcodeValue property will be NULL.

For the following 2D barcodes types including DataMatrix, PDF417, Aztec, QRcode, PostNet, Intelligent Mail, Australian Post and Royal Post 4, the currently selected ImGearBarcodeType is returned as the candidate region type.

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


ScanDistance Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeReader Class : ScanDistance Property
Gets or sets the scan distance in pixels between line sweeps when searching for 1D barcodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScanDistance As Integer
'Usage

Dim instance As ImGearBarcodeReader
Dim value As Integer

instance.ScanDistance = value

value = instance.ScanDistance
public int ScanDistance {get; set;}
public: __property int get_ScanDistance();
public: __property void set_ScanDistance(
   int value
);
public:
property int ScanDistance {
   int get();
   void set (    int value);
}

Property Value

The scan distance in pixels between line sweeps when searching for 1D barcodes.
Remarks

Reducing this value can help in finding barcodes which are short relative to their height.

This value effects the run time of the barcode search. Smaller values will require more processing of the image.

Default value: 5

Valid values are 1 through 10.

See Also

Reference

ImGearBarcodeReader Class
ImGearBarcodeReader Members


%%PageItemTitle%%

ImGearBarcodeResult Class
Members Example

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeResult Class
The Results Class includes properties used to return barcode recognition results.
Object Model
ImGearBarcodeResult ClassImGearRectangle StructureImGearPoint StructureImGearPoint StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeResult
'Usage

Dim instance As ImGearBarcodeResult
public class ImGearBarcodeResult
public __gc class ImGearBarcodeResult
public ref class ImGearBarcodeResult
Remarks

The ImGearBarcodeReader.Analyze method returns a collection of ImGearBarcodeResult objects. Each element of the ImGearBarcodeResult collection contains the results of a single recognized barcode (or unsolved barcode. See ImGearBarcodeReader.ReturnPossibleBarcodes).

Since ImGearBarcode can return multiple barcode results from a single scan, the detected barcode results (both solved and unsolved) are sorted using the following criteria.

Note: All solved barcodes are ordered before unsolved barcodes.

  • The confidence factor is used to sort the barcode results from the highest confidence to the lowest confidence.
  • For any barcodes with the same confidence value, they are sorted by their location, from top to bottom, then left to right.

Four points describe the location of the barcode on the image:

  • Point1
  • Point2
  • Point3
  • Point4

Example
  • C#
using ImageGear.Barcode;

// call Analyze to detect barcodes in the image
// all detected barcodes will be returned to the
// ImGearBarcodeResult object collection.
List<ImGearBarcodeResult> results = new List<ImGearBarcodeResult>();
results.AddRange(myBarcode.ImGearBarcodeReader.Analyze(myPage));

// get some results info, if any
foreach (ImGearBarcodeResult curResult in results)
{

   // do something with results
   MessageBox.Show(curResult.BarcodeName);
   MessageBox.Show(curResult.BarcodeValue);
}
Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeResult

See Also

Reference

ImGearBarcodeResult Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeResult Class Members
Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeResult Class

The following tables list the members exposed by ImGearBarcodeResult.

Public Properties
 | Name | Description
Public Property | Area | Gets the bounding rectangular area of the recognized barcode.
Public Property | BarcodeDataAsByte | Gets the recognized barcode data value in bytes.
Public Property | BarcodeName | Gets the name of the recognized barcode.
Public Property | BarcodeType | Gets the type of the recognized barcode.
Public Property | BarcodeValue | Gets the value of the recognized barcode.
Public Property | Confidence | Gets the confidence of the recognized barcode.
Public Property | IsCheckSumValid | Gets a value indicating whether there is a valid check sum for a recognized barcode.
Public Property | Length | Gets the length of the result string.
Public Property | NumberCheckSumChars | Gets the number of characters in the recognized check sum.
Public Property | Point1 | Gets the top-left point of the recognized barcode.
Public Property | Point2 | Gets the top-right point of the recognized barcode.
Public Property | Point3 | Gets the bottom-right point of the recognized barcode.
Public Property | Point4 | Gets the bottom-left point of the recognized barcode.
Public Property | Skew | Gets the angle of skew for the recognized barcode analyzed.
Top
See Also

Reference

ImGearBarcodeResult Class
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Properties$$

ImGearBarcodeResult Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeResult Class

For a list of all members of this type, see ImGearBarcodeResult members.

Public Properties
 | Name | Description
Public Property | Area | Gets the bounding rectangular area of the recognized barcode.
Public Property | BarcodeDataAsByte | Gets the recognized barcode data value in bytes.
Public Property | BarcodeName | Gets the name of the recognized barcode.
Public Property | BarcodeType | Gets the type of the recognized barcode.
Public Property | BarcodeValue | Gets the value of the recognized barcode.
Public Property | Confidence | Gets the confidence of the recognized barcode.
Public Property | IsCheckSumValid | Gets a value indicating whether there is a valid check sum for a recognized barcode.
Public Property | Length | Gets the length of the result string.
Public Property | NumberCheckSumChars | Gets the number of characters in the recognized check sum.
Public Property | Point1 | Gets the top-left point of the recognized barcode.
Public Property | Point2 | Gets the top-right point of the recognized barcode.
Public Property | Point3 | Gets the bottom-right point of the recognized barcode.
Public Property | Point4 | Gets the bottom-left point of the recognized barcode.
Public Property | Skew | Gets the angle of skew for the recognized barcode analyzed.
Top
See Also

Reference

ImGearBarcodeResult Class
ImageGear.Barcode Namespace


Area Property (ImGearBarcodeResult)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Area Property
Gets the bounding rectangular area of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Area As ImGearRectangle
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearRectangle

value = instance.Area
public ImGearRectangle Area {get;}
public: __property ImGearRectangle get_Area();
public:
property ImGearRectangle Area {
   ImGearRectangle get();
}

Property Value

A ImageGear.Core.ImGearRectangle object.
Remarks

The rectangular area consists of the ImageGear.Core.ImGearRectangle object which contains the coordinates x, y, width and height that the area surrounding the barcode analyzed.

See the ImGearBarcodeResult Class desription for general information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


BarcodeDataAsByte Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : BarcodeDataAsByte Property
Gets the recognized barcode data value in bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Barcode Xpress historical compatibility")>
Public ReadOnly Property BarcodeDataAsByte As Byte()
'Usage

Dim instance As ImGearBarcodeResult
Dim value() As Byte

value = instance.BarcodeDataAsByte
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Barcode Xpress historical compatibility")]
public byte[] BarcodeDataAsByte {get;}
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Barcode Xpress historical compatibility")]
public: __property byte[]* get_BarcodeDataAsByte();
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Barcode Xpress historical compatibility")]
public:
property array<byte>^ BarcodeDataAsByte {
   array<byte>^ get();
}

Property Value

The byte value.
See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


BarcodeName Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : BarcodeName Property
Gets the name of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BarcodeName As String
'Usage

Dim instance As ImGearBarcodeResult
Dim value As String

value = instance.BarcodeName
public string BarcodeName {get;}
public: __property string* get_BarcodeName();
public:
property String^ BarcodeName {
   String^ get();
}

Property Value

A string value which represents the name of the barcode.
Remarks

This property gets the name of the barcode (e.g. "Code39"), not the value of the barcode. The BarcodeValue property returns the value of the barcode.

If ImGearBarcodeReader.ReturnPossibleBarcodes is True, and only a region of interest is returned in the results, then the barcode name is a null string.

See the ImGearBarcodeResult for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


BarcodeType Property (ImGearBarcodeResult)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : BarcodeType Property
Gets the type of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BarcodeType As ImGearBarcodeType
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearBarcodeType

value = instance.BarcodeType
public ImGearBarcodeType BarcodeType {get;}
public: __property ImGearBarcodeType get_BarcodeType();
public:
property ImGearBarcodeType BarcodeType {
   ImGearBarcodeType get();
}

Property Value

The ImGearBarcodeType set.
Remarks

If ImGearBarcodeReader.ReturnPossibleBarcodes is True, and only a region of interest is returned in the results, then the barcode type is ImGearBarcodeType.UnknownBarcode.

See the ImGearBarcodeResult for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


BarcodeValue Property (ImGearBarcodeResult)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : BarcodeValue Property
Gets the value of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BarcodeValue As String
'Usage

Dim instance As ImGearBarcodeResult
Dim value As String

value = instance.BarcodeValue
public string BarcodeValue {get;}
public: __property string* get_BarcodeValue();
public:
property String^ BarcodeValue {
   String^ get();
}

Property Value

A string which contains one or many characters which represent the value of the barcode.
Remarks

If ImGearBarcodeReader.ReturnPossibleBarcodes is True, and only a region of interest is returned in the results, then the barcode value is a null string.

If the barcodes being recognized are encoding binary data, use the BarcodeDataAsByte property to return the result value instead.

See the ImGearBarcodeResult for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Confidence Property (ImGearBarcodeResult)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Confidence Property
Gets the confidence of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As ImGearBarcodeResult
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

A long which represents the confidence of the barcode.
Remarks

Barcodes are assumed to have a 100 percent confidence from which points are deducted. Confidence reporting is based on several factors:

  • Barcodes that require the use of check digits that have not produced the anticipated check sum value will cause a reduced confidence. Invalid check sums will have a reduction of at least 50.
  • Barcodes that are recognized but that also include errors will cause a reduction in confidence. These could be barcodes that were recovered because of the check sum. The confidence of these barcodes is reduced by as much as 30.

All of these modifications of the confidence can be combined.

See the ImGearBarcodeResult Class for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


IsCheckSumValid Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : IsCheckSumValid Property
Gets a value indicating whether there is a valid check sum for a recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsCheckSumValid As Boolean
'Usage

Dim instance As ImGearBarcodeResult
Dim value As Boolean

value = instance.IsCheckSumValid
public bool IsCheckSumValid {get;}
public: __property bool get_IsCheckSumValid();
public:
property bool IsCheckSumValid {
   bool get();
}

Property Value

A boolean value which designates if a valid check sum is returned for a recognized barcode.
Remarks

For barcodes with a check sum, it returns whether the check sum is valid. A value of 1 represents True, a value of 0 represents False.

For barcodes without a check sum, it returns False.

For barcodes with error correction, it returns True.

See the ImGearBarcodeResult Class for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Length Property (ImGearBarcodeResult)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Length Property
Gets the length of the result string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Integer
'Usage

Dim instance As ImGearBarcodeResult
Dim value As Integer

value = instance.Length
public int Length {get;}
public: __property int get_Length();
public:
property int Length {
   int get();
}

Property Value

A long which represents the length of the resulting string.
Remarks

This property is used in conjuction with the BarcodeDataAsByte property to return the recognized barcode's value.

See the ImGearBarcodeResult for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


NumberCheckSumChars Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : NumberCheckSumChars Property
Gets the number of characters in the recognized check sum.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NumberCheckSumChars As Integer
'Usage

Dim instance As ImGearBarcodeResult
Dim value As Integer

value = instance.NumberCheckSumChars
public int NumberCheckSumChars {get;}
public: __property int get_NumberCheckSumChars();
public:
property int NumberCheckSumChars {
   int get();
}

Property Value

A long which represents the number of characters.
Remarks

If a check sum does not exist, or the check sum evaluated incorrectly, this property will return 0.

See the ImGearBarcodeResult for more information about retrieving results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Point1 Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Point1 Property
Gets the top-left point of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Point1 As ImGearPoint
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearPoint

value = instance.Point1
public ImGearPoint Point1 {get;}
public: __property ImGearPoint get_Point1();
public:
property ImGearPoint Point1 {
   ImGearPoint get();
}

Property Value

A ImageGear.Core.ImGearPoint object.
Remarks

See the ImGearBarcodeResult Class description for general information about retrieving results.

Point properties 1 through 4 locate the corner points of linear 1D barcodes. When the barcode is in the horizontal orientation, ImGearBarcode reads it from left to right, assigning values to the Point 1 through 4 properties. The Point1 property is the upper-left corner point of the barcode. With any rotation of the barcode on the image, the Point value assigned to the corners rotate with the barcode. no matter what the rotation is, the Point properties always identify the same corner point of the barcode.

See the Boundary and Point Properties topic for more information.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Point2 Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Point2 Property
Gets the top-right point of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Point2 As ImGearPoint
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearPoint

value = instance.Point2
public ImGearPoint Point2 {get;}
public: __property ImGearPoint get_Point2();
public:
property ImGearPoint Point2 {
   ImGearPoint get();
}

Property Value

A ImageGear.Core.ImGearPoint object.
Remarks

See the ImGearBarcodeResult Class description for general information about retrieving results.

Point properties 1 through 4 locate the corner points of linear 1D barcodes. When the barcode is in the horizontal orientation, ImGearBarcode reads it from left to right, assigning values to the Point 1 through 4 properties. The Point1 property is the upper-left corner point of the barcode. With any rotation of the barcode on the image, the Point value assigned to the corners rotate with the barcode. no matter what the rotation is, the Point properties always identify the same corner point of the barcode.

See the Boundary and Point Properties topic for more information.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Point3 Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Point3 Property
Gets the bottom-right point of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Point3 As ImGearPoint
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearPoint

value = instance.Point3
public ImGearPoint Point3 {get;}
public: __property ImGearPoint get_Point3();
public:
property ImGearPoint Point3 {
   ImGearPoint get();
}

Property Value

A ImageGear.Core.ImGearPoint object.
Remarks

See the ImGearBarcodeResult Class description for general information about retrieving results.

Point properties 1 through 4 locate the corner points of linear 1D barcodes. When the barcode is in the horizontal orientation, ImGearBarcode reads it from left to right, assigning values to the Point 1 through 4 properties. The Point1 property is the upper-left corner point of the barcode. With any rotation of the barcode on the image, the Point value assigned to the corners rotate with the barcode. no matter what the rotation is, the Point properties always identify the same corner point of the barcode.

See the Boundary and Point Properties topic for more information.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Point4 Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Point4 Property
Gets the bottom-left point of the recognized barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Point4 As ImGearPoint
'Usage

Dim instance As ImGearBarcodeResult
Dim value As ImGearPoint

value = instance.Point4
public ImGearPoint Point4 {get;}
public: __property ImGearPoint get_Point4();
public:
property ImGearPoint Point4 {
   ImGearPoint get();
}

Property Value

A ImageGear.Core.ImGearPoint object.
Remarks

See the ImGearBarcodeResult Class description for general information about retrieving results.

Point properties 1 through 4 locate the corner points of linear 1D barcodes. When the barcode is in the horizontal orientation, ImGearBarcode reads it from left to right, assigning values to the Point 1 through 4 properties. The Point1 property is the upper-left corner point of the barcode. With any rotation of the barcode on the image, the Point value assigned to the corners rotate with the barcode. no matter what the rotation is, the Point properties always identify the same corner point of the barcode.

See the Boundary and Point Properties topic for more information.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


Skew Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeResult Class : Skew Property
Gets the angle of skew for the recognized barcode analyzed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Skew As Integer
'Usage

Dim instance As ImGearBarcodeResult
Dim value As Integer

value = instance.Skew
public int Skew {get;}
public: __property int get_Skew();
public:
property int Skew {
   int get();
}

Property Value

The angle of skew for the recognized barcode.
Remarks

The skew angle is measured in degrees. 0 degrees is horizontal.

See the ImGearBarcodeResult Class for more information about retrievin results.

See Also

Reference

ImGearBarcodeResult Class
ImGearBarcodeResult Members


%%PageItemTitle%%

ImGearBarcodeWriter Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriter Class
The ImGearBarcodeWriter Class is inherited from the ImGearBarcodeWriterBase Class and is used to create barcodes.
Object Model
ImGearBarcodeWriter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeWriter
   Inherits ImGearBarcodeWriterBase
'Usage

Dim instance As ImGearBarcodeWriter
public class ImGearBarcodeWriter : ImGearBarcodeWriterBase
public __gc class ImGearBarcodeWriter : public ImGearBarcodeWriterBase
public ref class ImGearBarcodeWriter : public ImGearBarcodeWriterBase
Remarks

Written barcode types:

  • Industry 2 of 5
  • Interleaved 2 of 5
  • Codabar
  • Code 39
  • Code 39 Extended
  • Code 93
  • Code 93 Extended
  • Code128
  • DataMatrix
  • EAN 128
  • EAN 13
  • EAN 8
  • UPCA
  • UPCE
  • PatchCode
  • PDF417

Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeWriterBase
ImageGear.Barcode.ImGearBarcodeWriter

See Also

Reference

ImGearBarcodeWriter Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeWriter Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriter Class

The following tables list the members exposed by ImGearBarcodeWriter.

Public Constructors
 | Name | Description
Public Constructor | ImGearBarcodeWriter Constructor | Initializes a new instance of the ImGearBarcodeWriter class which takes in the barcode class.
Top
Public Properties
 | Name | Description
Public Property | BarcodeType | Gets or sets the type of barcode to create.
Public Property | EnableCheckSum | Gets or sets the checksum write flag for barcodes that optionally use checksums.
Public Property | HorizontalTextGap | Gets or sets the amount of gap between the outside text and the barcode when creating a barcode.
Public Property | OutsideTextFont | Gets or sets the font used to display the UPC values that appear outside of the left and right guard bars.
Public Property | OutsideVerticalTextOffset | Gets or sets the vertical offset text.
Public Property | ShowText | Gets or sets if the barcode value is written as text adjacent to the created barcode.
Public Property | TextFont | Gets or sets the font of the barcode written as text adjacent to the barcode being created.
Public Property | TextNotchPercent | Gets or sets the notch percent of the barcode for the text value.
Public Property | VerticalTextGap | Gets or sets the amount of gap between the text and the barcode when creating a barcode.
Top
See Also

Reference

ImGearBarcodeWriter Class
ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeWriter Constructor

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : ImGearBarcodeWriter Constructor
The barcode class.
Initializes a new instance of the ImGearBarcodeWriter class which takes in the barcode class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal barcodeParent As ImGearBarcode _
)
'Usage

Dim barcodeParent As ImGearBarcode

Dim instance As New ImGearBarcodeWriter(barcodeParent)
public ImGearBarcodeWriter(
   ImGearBarcode barcodeParent
)
public: ImGearBarcodeWriter(
   ImGearBarcode* barcodeParent
)
public:
ImGearBarcodeWriter(
   ImGearBarcode^ barcodeParent
)

Parameters

barcodeParent
The barcode class.
See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


%%PageItemTitle%% $$Properties$$

ImGearBarcodeWriter Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriter Class

For a list of all members of this type, see ImGearBarcodeWriter members.

Public Properties
 | Name | Description
Public Property | BarcodeType | Gets or sets the type of barcode to create.
Public Property | EnableCheckSum | Gets or sets the checksum write flag for barcodes that optionally use checksums.
Public Property | HorizontalTextGap | Gets or sets the amount of gap between the outside text and the barcode when creating a barcode.
Public Property | OutsideTextFont | Gets or sets the font used to display the UPC values that appear outside of the left and right guard bars.
Public Property | OutsideVerticalTextOffset | Gets or sets the vertical offset text.
Public Property | ShowText | Gets or sets if the barcode value is written as text adjacent to the created barcode.
Public Property | TextFont | Gets or sets the font of the barcode written as text adjacent to the barcode being created.
Public Property | TextNotchPercent | Gets or sets the notch percent of the barcode for the text value.
Public Property | VerticalTextGap | Gets or sets the amount of gap between the text and the barcode when creating a barcode.
Top
See Also

Reference

ImGearBarcodeWriter Class
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Methods$$

ImGearBarcodeWriter Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriter Class

For a list of all members of this type, see ImGearBarcodeWriter members.

See Also

Reference

ImGearBarcodeWriter Class
ImageGear.Barcode Namespace


BarcodeType Property (ImGearBarcodeWriter)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : BarcodeType Property
Gets or sets the type of barcode to create.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property BarcodeType As ImGearBarcodeType
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As ImGearBarcodeType

instance.BarcodeType = value

value = instance.BarcodeType
public new ImGearBarcodeType BarcodeType {get; set;}
public: __property new ImGearBarcodeType get_BarcodeType();
public: __property new void set_BarcodeType(
   ImGearBarcodeType value
);
public:
new property ImGearBarcodeType BarcodeType {
   ImGearBarcodeType get();
   void set (    ImGearBarcodeType value);
}

Property Value

The ImGearBarcodeType value set.
Remarks

Required to create a barcode. When set, the ImGearBarcodeType property verifies the specified type is valid for writing. If not, the "Unsupported barcode type" exception is thrown.

Below are the barcode types which can be written:

  • Industry 2 of 5
  • Interleaved 2 of 5
  • Codabar
  • Code 39
  • Code 39 Extended
  • Code 93
  • Code 93 Extended
  • Code 128
  • DataMatrix
  • EAN 128
  • EAN-13
  • EAN 8
  • UPCA
  • UPCE
  • PatchCode
  • PDF417

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members
ImGearBarcodeWriter Class
ImGearBarcodeType Enumeration


EnableCheckSum Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : EnableCheckSum Property
Gets or sets the checksum write flag for barcodes that optionally use checksums.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property EnableCheckSum As Integer
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Integer

instance.EnableCheckSum = value

value = instance.EnableCheckSum
public new int EnableCheckSum {get; set;}
public: __property new int get_EnableCheckSum();
public: __property new void set_EnableCheckSum(
   int value
);
public:
new property int EnableCheckSum {
   int get();
   void set (    int value);
}

Property Value

A long which determines if the barcode uses a check sum.
Remarks

A value of 1 will write optional check sums, and a value of 0 will not write optional check sums.

Currently, of the supported barcode types that ImGearBarcode can write, only types Industry 2 of 5, Interleaved 2 of 5, Code 39, and Code 39 Extended allows an optional check sum. This property is ignored for other barcode types that require check sums.

Default value: 0 (False)

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


HorizontalTextGap Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : HorizontalTextGap Property
Gets or sets the amount of gap between the outside text and the barcode when creating a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property HorizontalTextGap As Integer
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Integer

instance.HorizontalTextGap = value

value = instance.HorizontalTextGap
public new int HorizontalTextGap {get; set;}
public: __property new int get_HorizontalTextGap();
public: __property new void set_HorizontalTextGap(
   int value
);
public:
new property int HorizontalTextGap {
   int get();
   void set (    int value);
}

Property Value

A long which represents the gap.
Remarks

Outside text is only written with certain barcodes where this is standard. The barcode types that support a text notch are UPC-A, UPC-E, EAN-8 and EAN-13. For all other types, this value is ignored.

Default value: 5 pixels

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


OutsideTextFont Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : OutsideTextFont Property
Gets or sets the font used to display the UPC values that appear outside of the left and right guard bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property OutsideTextFont As Font
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Font

instance.OutsideTextFont = value

value = instance.OutsideTextFont
public new Font OutsideTextFont {get; set;}
public: __property new Font* get_OutsideTextFont();
public: __property new void set_OutsideTextFont(
   Font* value
);
public:
new property Font^ OutsideTextFont {
   Font^ get();
   void set (    Font^ value);
}

Property Value

The Font set.
Remarks

Outside value text is only written for certain barcodes where this is standard. The barcode types that support outside text are UPC-A, UPC-E, EAN-8 and EAN-13. For all other types, this value is ignored.

Default value: Arial, 16, Normal

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


OutsideVerticalTextOffset Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : OutsideVerticalTextOffset Property
Gets or sets the vertical offset text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property OutsideVerticalTextOffset As Integer
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Integer

instance.OutsideVerticalTextOffset = value

value = instance.OutsideVerticalTextOffset
public new int OutsideVerticalTextOffset {get; set;}
public: __property new int get_OutsideVerticalTextOffset();
public: __property new void set_OutsideVerticalTextOffset(
   int value
);
public:
new property int OutsideVerticalTextOffset {
   int get();
   void set (    int value);
}

Property Value

A long which represents the vertical offset value.
Remarks

A value less than 0 will raise the outside value text above the standard value text. A value greater than 0 will lower the outside value text below the standard value text.

Outside value text is only written for certain barcodes where this is standard. The barcode types that support outside text are UPC-A, UPC-E, EAN-8 and EAN-13. For all other types this value is ignored.

Default value: 0 pixels

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


ShowText Property (ImGearBarcodeWriter)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : ShowText Property
Gets or sets if the barcode value is written as text adjacent to the created barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property ShowText As ImGearBarcodeShowTextInfo
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As ImGearBarcodeShowTextInfo

instance.ShowText = value

value = instance.ShowText
public new ImGearBarcodeShowTextInfo ShowText {get; set;}
public: __property new ImGearBarcodeShowTextInfo get_ShowText();
public: __property new void set_ShowText(
   ImGearBarcodeShowTextInfo value
);
public:
new property ImGearBarcodeShowTextInfo ShowText {
   ImGearBarcodeShowTextInfo get();
   void set (    ImGearBarcodeShowTextInfo value);
}

Property Value

The ImGearBarcodeShowTextInfo enumeration value set.
Remarks

Note: This property is ignored when writing 2D barcode types since there is typically a large amount of data encoded by them. The barcode's value will not be written adjacent to 2D barcodes.

Default value: ImGearBarcodeShowTextInfo.All

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


TextFont Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : TextFont Property
Gets or sets the font of the barcode written as text adjacent to the barcode being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property TextFont As Font
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Font

instance.TextFont = value

value = instance.TextFont
public new Font TextFont {get; set;}
public: __property new Font* get_TextFont();
public: __property new void set_TextFont(
   Font* value
);
public:
new property Font^ TextFont {
   Font^ get();
   void set (    Font^ value);
}

Property Value

The Font set.
Remarks

Default value: Arial, 16, Normal

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


TextNotchPercent Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : TextNotchPercent Property
Gets or sets the notch percent of the barcode for the text value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property TextNotchPercent As Integer
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Integer

instance.TextNotchPercent = value

value = instance.TextNotchPercent
public new int TextNotchPercent {get; set;}
public: __property new int get_TextNotchPercent();
public: __property new void set_TextNotchPercent(
   int value
);
public:
new property int TextNotchPercent {
   int get();
   void set (    int value);
}

Property Value

A long which represents the percentage.
Remarks

This property is used by supported barcodes UPC-A and EAN13. Otherwise this value is ignored.

Notch percent is only used with certain barcodes where this is standard. The barcode types that support a text notch are UPC-A, UPC-E, EAN-8 and EAN-13.

Default value: 10 percent.

Valid values: 0 - 50

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


VerticalTextGap Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriter Class : VerticalTextGap Property
Gets or sets the amount of gap between the text and the barcode when creating a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property VerticalTextGap As Integer
'Usage

Dim instance As ImGearBarcodeWriter
Dim value As Integer

instance.VerticalTextGap = value

value = instance.VerticalTextGap
public new int VerticalTextGap {get; set;}
public: __property new int get_VerticalTextGap();
public: __property new void set_VerticalTextGap(
   int value
);
public:
new property int VerticalTextGap {
   int get();
   void set (    int value);
}

Property Value

A long which represents the gap.
Remarks

This property value can be positive or negative. Positive values move the value text further away from the bottom of the bars while negative values move the text closer to the bars, even overlapping.

Note: In the case where the value text overlaps the barcode, this may prevent the barcode from being recognized.

Default value: 0 pixels

See Also

Reference

ImGearBarcodeWriter Class
ImGearBarcodeWriter Members


%%PageItemTitle%%

ImGearBarcodeWriterBase Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterBase Class
The ImGearBarcodeWriterBase Class includes properties used to write barcode recognition results.
Object Model
ImGearBarcodeWriterBase ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeWriterBase
'Usage

Dim instance As ImGearBarcodeWriterBase
public class ImGearBarcodeWriterBase
public __gc class ImGearBarcodeWriterBase
public ref class ImGearBarcodeWriterBase
Remarks

Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeWriterBase
ImageGear.Barcode.ImGearBarcodeWriter
ImageGear.Barcode.ImGearBarcodeWriterDataMatrix
ImageGear.Barcode.ImGearBarcodeWriterPDF417

See Also

Reference

ImGearBarcodeWriterBase Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeWriterBase Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterBase Class

The following tables list the members exposed by ImGearBarcodeWriterBase.

Public Constructors
 | Name | Description
Public Constructor | ImGearBarcodeWriterBase Constructor | Initializes a new instance of the ImGearBarcodeWriterBase class which the ImGearBarcodeWriter class inherits from.
Top
Public Properties
 | Name | Description
Public Property | AdjustBarWidth | Gets or sets a value indicating whether dynamic adjustment of the bar widths during barcode creation are allowed.
Public Property | AutoSize | Gets or sets a value indicating whether the barcode area is automatically sized during barcode creation.
Public Property | BarcodeValue | Gets or sets the value of the barcode to be created.
Public Property | BarcodeValueAsByte | Gets or sets the current barcode value as an array of bytes.
Public Property | BarWidth | Gets the bar width in pixels of a bar that was created.
Public Property | Height | Gets or sets the height of the image in pixels.
Public Property | HorizontalWhiteSpace | Gets or sets the amount of white space on the sides of the barcode during creation.
Public Property | MinimumBarHeight | Gets or sets the minimum height of the bars when creating a barcode.
Public Property | MinimumBarWidth | Gets or sets the minimum bar width when creating a barcode.
Public Property | RequiredHeight | Gets the required height of the image in pixels based on the current settings.
Public Property | RequiredWidth | Gets the required width of the image in pixels based on the current settings.
Public Property | ShowText | Gets or sets the display level of the barcode value written as text adjacent to the created barcode.
Public Property | VerticalWhiteSpace | Gets or sets the amount of white space above and below the barcode during creation.
Public Property | Width | Gets or sets the width of the image in pixels.
Top
Protected Properties
 | Name | Description
Protected Property | BarcodeId | Gets instance ID of the barcode object.
Top
Public Methods
 | Name | Description
Public Method | CreatePage | The method for creating ImGearPage barcodes.
Public Method | Dispose | Disposes of unmanaged resources.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearBarcodeWriterBase class.
Top
See Also

Reference

ImGearBarcodeWriterBase Class
ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeWriterBase Constructor

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : ImGearBarcodeWriterBase Constructor
The barcode parent.
Initializes a new instance of the ImGearBarcodeWriterBase class which the ImGearBarcodeWriter class inherits from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal barcodeParent As ImGearBarcode _
)
'Usage

Dim barcodeParent As ImGearBarcode

Dim instance As New ImGearBarcodeWriterBase(barcodeParent)
public ImGearBarcodeWriterBase(
   ImGearBarcode barcodeParent
)
public: ImGearBarcodeWriterBase(
   ImGearBarcode* barcodeParent
)
public:
ImGearBarcodeWriterBase(
   ImGearBarcode^ barcodeParent
)

Parameters

barcodeParent
The barcode parent.
See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


%%PageItemTitle%% $$Methods$$

ImGearBarcodeWriterBase Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterBase Class

For a list of all members of this type, see ImGearBarcodeWriterBase members.

Public Methods
 | Name | Description
Public Method | CreatePage | The method for creating ImGearPage barcodes.
Public Method | Dispose | Disposes of unmanaged resources.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearBarcodeWriterBase class.
Top
See Also

Reference

ImGearBarcodeWriterBase Class
ImageGear.Barcode Namespace


CreatePage Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : CreatePage Method
The method for creating ImGearPage barcodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Reliability",
   CheckId="CA2002:DoNotLockOnObjectsWithWeakIdentity",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")>
Public Function CreatePage() As ImGearPage
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As ImGearPage

value = instance.CreatePage()
[SuppressMessage(Category="Microsoft.Reliability",
   CheckId="CA2002:DoNotLockOnObjectsWithWeakIdentity",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public ImGearPage CreatePage()
[SuppressMessage(Category="Microsoft.Reliability",
   CheckId="CA2002:DoNotLockOnObjectsWithWeakIdentity",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public: ImGearPage* CreatePage();
[SuppressMessage(Category="Microsoft.Reliability",
   CheckId="CA2002:DoNotLockOnObjectsWithWeakIdentity",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public:
ImGearPage^ CreatePage();

Return Value

An ImGearPage with the image of the requested barcode.
Remarks

The CreatePage method returns a ImGearPage with an image of the barcode.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


Dispose Method (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : Dispose Method
Disposes of unmanaged resources.
Overload List
Overload | Description
Dispose | Disposes of unmanaged resources.
See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


Dispose() Method

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : Dispose() Method
Disposes of unmanaged resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearBarcodeWriterBase

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks

This method is part of the IDisposable interface.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


Finalize Method (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : Finalize Method
Finalizes an instance of the ImGearBarcodeWriterBase class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearBarcodeWriterBase

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


%%PageItemTitle%% $$Properties$$

ImGearBarcodeWriterBase Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterBase Class

For a list of all members of this type, see ImGearBarcodeWriterBase members.

Public Properties
 | Name | Description
Public Property | AdjustBarWidth | Gets or sets a value indicating whether dynamic adjustment of the bar widths during barcode creation are allowed.
Public Property | AutoSize | Gets or sets a value indicating whether the barcode area is automatically sized during barcode creation.
Public Property | BarcodeValue | Gets or sets the value of the barcode to be created.
Public Property | BarcodeValueAsByte | Gets or sets the current barcode value as an array of bytes.
Public Property | BarWidth | Gets the bar width in pixels of a bar that was created.
Public Property | Height | Gets or sets the height of the image in pixels.
Public Property | HorizontalWhiteSpace | Gets or sets the amount of white space on the sides of the barcode during creation.
Public Property | MinimumBarHeight | Gets or sets the minimum height of the bars when creating a barcode.
Public Property | MinimumBarWidth | Gets or sets the minimum bar width when creating a barcode.
Public Property | RequiredHeight | Gets the required height of the image in pixels based on the current settings.
Public Property | RequiredWidth | Gets the required width of the image in pixels based on the current settings.
Public Property | ShowText | Gets or sets the display level of the barcode value written as text adjacent to the created barcode.
Public Property | VerticalWhiteSpace | Gets or sets the amount of white space above and below the barcode during creation.
Public Property | Width | Gets or sets the width of the image in pixels.
Top
Protected Properties
 | Name | Description
Protected Property | BarcodeId | Gets instance ID of the barcode object.
Top
See Also

Reference

ImGearBarcodeWriterBase Class
ImageGear.Barcode Namespace


AdjustBarWidth Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : AdjustBarWidth Property
Gets or sets a value indicating whether dynamic adjustment of the bar widths during barcode creation are allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AdjustBarWidth As Boolean
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Boolean

instance.AdjustBarWidth = value

value = instance.AdjustBarWidth
public bool AdjustBarWidth {get; set;}
public: __property bool get_AdjustBarWidth();
public: __property void set_AdjustBarWidth(
   bool value
);
public:
property bool AdjustBarWidth {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if dynamic adjustment is allowed. Otherwise, false is returned.
Remarks

This property gets and sets an indicator to allow barcode bar width dynamic adjustment during barcode creation.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


AutoSize Property (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : AutoSize Property
Gets or sets a value indicating whether the barcode area is automatically sized during barcode creation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoSize As Boolean
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
public bool AutoSize {get; set;}
public: __property bool get_AutoSize();
public: __property void set_AutoSize(
   bool value
);
public:
property bool AutoSize {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the barcode area is automatically sized. Otherwise, false is returned.
Remarks

The default value is true.

When this property is set to true, the component will calculate the required height and width of the output image during barcode creation.

The image height and width are calculated using the barcode value, minimum bar width, horizontal gaps, vertical gaps and the size of the text font. If the calculated height or width is greater than the user input height and width, the image size will be increased to create the barcode.

When this property is set to false, the component will use the Height and Width parameters.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


BarcodeId Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : BarcodeId Property
Gets instance ID of the barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected ReadOnly Property BarcodeId As IntPtr
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As IntPtr

value = instance.BarcodeId
protected IntPtr BarcodeId {get;}
protected: __property IntPtr get_BarcodeId();
protected:
property IntPtr BarcodeId {
   IntPtr get();
}

Property Value

The ID of the barcode object.
See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


BarcodeValue Property (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : BarcodeValue Property
Gets or sets the value of the barcode to be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarcodeValue As String
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As String

instance.BarcodeValue = value

value = instance.BarcodeValue
public string BarcodeValue {get; set;}
public: __property string* get_BarcodeValue();
public: __property void set_BarcodeValue(
   string* value
);
public:
property String^ BarcodeValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the value of the barcode.
Remarks

The default valueis an empty string "".

Use BarcodeValueAsByte property only if non-ASCII text values are needed.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


BarcodeValueAsByte Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : BarcodeValueAsByte Property
Gets or sets the current barcode value as an array of bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")>
Public Property BarcodeValueAsByte As Byte()
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value() As Byte

instance.BarcodeValueAsByte = value

value = instance.BarcodeValueAsByte
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public byte[] BarcodeValueAsByte {get; set;}
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public: __property byte[]* get_BarcodeValueAsByte();
public: __property void set_BarcodeValueAsByte(
   byte[]* value
);
[SuppressMessage(Category="Microsoft.Performance",
   CheckId="CA1819:PropertiesShouldNotReturnArrays",
   Scope="",
   Target="",
   MessageId="",
   Justification="Historical matching with Barcode Xpress")]
public:
property array<byte>^ BarcodeValueAsByte {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A string value which represents the value of the barcode.
Remarks

The default valueis an empty string "".

Use BarcodeValueAsByte property only if non-ASCII text values are needed.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


BarWidth Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : BarWidth Property
Gets the bar width in pixels of a bar that was created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BarWidth As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

value = instance.BarWidth
public int BarWidth {get;}
public: __property int get_BarWidth();
public:
property int BarWidth {
   int get();
}

Property Value

An integer value which represents the width of the bar.
Remarks

The value is the number of pixels which make up the width of the bar.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


Height Property (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : Height Property
Gets or sets the height of the image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the height of the barcode image.
Remarks

The default valueis 600.

The value is the number of pixels it takes to make the height of the barcode image.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


HorizontalWhiteSpace Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : HorizontalWhiteSpace Property
Gets or sets the amount of white space on the sides of the barcode during creation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalWhiteSpace As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.HorizontalWhiteSpace = value

value = instance.HorizontalWhiteSpace
public int HorizontalWhiteSpace {get; set;}
public: __property int get_HorizontalWhiteSpace();
public: __property void set_HorizontalWhiteSpace(
   int value
);
public:
property int HorizontalWhiteSpace {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the amount of white space.
Remarks

The default value is 50.

The white space surrounding the barcode is also known as the quiet zone. The component requires a quiet zone for accurate barcode detection.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


MinimumBarHeight Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : MinimumBarHeight Property
Gets or sets the minimum height of the bars when creating a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumBarHeight As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.MinimumBarHeight = value

value = instance.MinimumBarHeight
public int MinimumBarHeight {get; set;}
public: __property int get_MinimumBarHeight();
public: __property void set_MinimumBarHeight(
   int value
);
public:
property int MinimumBarHeight {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the barcode minimum height.
Remarks

The default value is 100 (PDF417 should set this value between 3 and 5)

This value is used to set the bar height in 1D barcodes. PDF417 uses this value as a multiplier of the minimum barcode width to set the row module height.

This property does not affect DataMatrix and QRcodes.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


MinimumBarWidth Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : MinimumBarWidth Property
Gets or sets the minimum bar width when creating a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumBarWidth As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.MinimumBarWidth = value

value = instance.MinimumBarWidth
public int MinimumBarWidth {get; set;}
public: __property int get_MinimumBarWidth();
public: __property void set_MinimumBarWidth(
   int value
);
public:
property int MinimumBarWidth {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the barcode minimum width.
Remarks

The default value is 3.

This value is used to set the bar width in 1D and PDF417 barcodes and the module size (black and white squares that make up the barcode) in DataMatrix and QR barcodes.

This value will be overridden if AdjustBarWidth parameter is set to true

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


RequiredHeight Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : RequiredHeight Property
Gets the required height of the image in pixels based on the current settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RequiredHeight As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

value = instance.RequiredHeight
public int RequiredHeight {get;}
public: __property int get_RequiredHeight();
public:
property int RequiredHeight {
   int get();
}

Property Value

An integer value which represents the required height.
Remarks

The required height is the sum of the minimum bar height + 2 * vertical spacing + the space required for the text (if displayed).

This is the required height given the input parameters to create a barcode image. It is only valid after trying to make the barcode.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


RequiredWidth Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : RequiredWidth Property
Gets the required width of the image in pixels based on the current settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RequiredWidth As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

value = instance.RequiredWidth
public int RequiredWidth {get;}
public: __property int get_RequiredWidth();
public:
property int RequiredWidth {
   int get();
}

Property Value

An integer value which represents the required width.
Remarks

The required width is the size of the barcode value bars * bar width + 2 * horizontal spacing + size of the outside text (if displayed). The bar should either be the minimal bar width or the calculated bar width if the AdjustBarWidth property is set to true.

This is the required width given the input parameters to create a barcode image. It is only valid after trying to make the barcode.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


ShowText Property (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : ShowText Property
Gets or sets the display level of the barcode value written as text adjacent to the created barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShowText As ImGearBarcodeShowTextInfo
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As ImGearBarcodeShowTextInfo

instance.ShowText = value

value = instance.ShowText
public ImGearBarcodeShowTextInfo ShowText {get; set;}
public: __property ImGearBarcodeShowTextInfo get_ShowText();
public: __property void set_ShowText(
   ImGearBarcodeShowTextInfo value
);
public:
property ImGearBarcodeShowTextInfo ShowText {
   ImGearBarcodeShowTextInfo get();
   void set (    ImGearBarcodeShowTextInfo value);
}

Property Value

The ImGearBarcodeShowTextInfo value.
Remarks

The default value is ImGearBarcodeShowTextInfo.All.

This property determines if the barcode value is written as text adjacent to the created barcode.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


VerticalWhiteSpace Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : VerticalWhiteSpace Property
Gets or sets the amount of white space above and below the barcode during creation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalWhiteSpace As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.VerticalWhiteSpace = value

value = instance.VerticalWhiteSpace
public int VerticalWhiteSpace {get; set;}
public: __property int get_VerticalWhiteSpace();
public: __property void set_VerticalWhiteSpace(
   int value
);
public:
property int VerticalWhiteSpace {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the amount of white space.
Remarks

The default value is 50.

The white space surrounding the barcode is also known as the quiet zone. The component requires a quiet zone for accurate barcode detection.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


Width Property (ImGearBarcodeWriterBase)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterBase Class : Width Property
Gets or sets the width of the image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearBarcodeWriterBase
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the width of the barcode image.
Remarks

The default valueis 600.

The value is the number of pixels it takes to make the width of the barcode image.

See Also

Reference

ImGearBarcodeWriterBase Class
ImGearBarcodeWriterBase Members


%%PageItemTitle%%

ImGearBarcodeWriterDataMatrix Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterDataMatrix Class
ImGearBarcodeWriterDataMatrix extends the writer class to include the writing of DataMatrix barcodes.
Object Model
ImGearBarcodeWriterDataMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeWriterDataMatrix
   Inherits ImGearBarcodeWriterBase
'Usage

Dim instance As ImGearBarcodeWriterDataMatrix
public class ImGearBarcodeWriterDataMatrix : ImGearBarcodeWriterBase
public __gc class ImGearBarcodeWriterDataMatrix : public ImGearBarcodeWriterBase
public ref class ImGearBarcodeWriterDataMatrix : public ImGearBarcodeWriterBase
Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeWriterBase
ImageGear.Barcode.ImGearBarcodeWriterDataMatrix

See Also

Reference

ImGearBarcodeWriterDataMatrix Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeWriterDataMatrix Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterDataMatrix Class

The following tables list the members exposed by ImGearBarcodeWriterDataMatrix.

Public Constructors
 | Name | Description
Public Constructor | ImGearBarcodeWriterDataMatrix Constructor | Initializes a new instance of the ImGearBarcodeWriterDataMatrix class. It requires an instance to the barcode component.
Top
Public Properties
 | Name | Description
Public Property | RowsAndColumns | Gets or sets the number of rows and columns desired in creating a DataMatrix barcode.
Public Property | RowsAndColumnsCreated | Gets the number of rows and columns created in the DataMatrix barcode.
Top
See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeWriterDataMatrix Constructor

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterDataMatrix Class : ImGearBarcodeWriterDataMatrix Constructor
Instance of the barcode control.
Initializes a new instance of the ImGearBarcodeWriterDataMatrix class. It requires an instance to the barcode component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal barcodeParent As ImGearBarcode _
)
'Usage

Dim barcodeParent As ImGearBarcode

Dim instance As New ImGearBarcodeWriterDataMatrix(barcodeParent)
public ImGearBarcodeWriterDataMatrix(
   ImGearBarcode barcodeParent
)
public: ImGearBarcodeWriterDataMatrix(
   ImGearBarcode* barcodeParent
)
public:
ImGearBarcodeWriterDataMatrix(
   ImGearBarcode^ barcodeParent
)

Parameters

barcodeParent
Instance of the barcode control.
See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImGearBarcodeWriterDataMatrix Members


%%PageItemTitle%% $$Properties$$

ImGearBarcodeWriterDataMatrix Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterDataMatrix Class

For a list of all members of this type, see ImGearBarcodeWriterDataMatrix members.

Public Properties
 | Name | Description
Public Property | RowsAndColumns | Gets or sets the number of rows and columns desired in creating a DataMatrix barcode.
Public Property | RowsAndColumnsCreated | Gets the number of rows and columns created in the DataMatrix barcode.
Top
See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Methods$$

ImGearBarcodeWriterDataMatrix Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterDataMatrix Class

For a list of all members of this type, see ImGearBarcodeWriterDataMatrix members.

See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImageGear.Barcode Namespace


RowsAndColumns Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterDataMatrix Class : RowsAndColumns Property
Gets or sets the number of rows and columns desired in creating a DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RowsAndColumns As ImGearBarcodeDataMatrixSizes
'Usage

Dim instance As ImGearBarcodeWriterDataMatrix
Dim value As ImGearBarcodeDataMatrixSizes

instance.RowsAndColumns = value

value = instance.RowsAndColumns
public ImGearBarcodeDataMatrixSizes RowsAndColumns {get; set;}
public: __property ImGearBarcodeDataMatrixSizes get_RowsAndColumns();
public: __property void set_RowsAndColumns(
   ImGearBarcodeDataMatrixSizes value
);
public:
property ImGearBarcodeDataMatrixSizes RowsAndColumns {
   ImGearBarcodeDataMatrixSizes get();
   void set (    ImGearBarcodeDataMatrixSizes value);
}

Property Value

The ImGearBarcodeDataMatrixSizes value set.
Remarks

The range is obtained from the ImGearBarcodeDataMatrixSizes enumeration where AutoRowsAndColumns is the default.

See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImGearBarcodeWriterDataMatrix Members


RowsAndColumnsCreated Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterDataMatrix Class : RowsAndColumnsCreated Property
Gets the number of rows and columns created in the DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RowsAndColumnsCreated As ImGearBarcodeDataMatrixSizes
'Usage

Dim instance As ImGearBarcodeWriterDataMatrix
Dim value As ImGearBarcodeDataMatrixSizes

value = instance.RowsAndColumnsCreated
public ImGearBarcodeDataMatrixSizes RowsAndColumnsCreated {get;}
public: __property ImGearBarcodeDataMatrixSizes get_RowsAndColumnsCreated();
public:
property ImGearBarcodeDataMatrixSizes RowsAndColumnsCreated {
   ImGearBarcodeDataMatrixSizes get();
}

Property Value

The ImGearBarcodeDataMatrixSizes value set.
Remarks

The value is a range from ImGearBarcodeDataMatrixSizes read from the RowsAndColumns property.

See Also

Reference

ImGearBarcodeWriterDataMatrix Class
ImGearBarcodeWriterDataMatrix Members


%%PageItemTitle%%

ImGearBarcodeWriterPDF417 Class
Members

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 extends the writer class to include the writing of PDF417 barcodes.
Object Model
ImGearBarcodeWriterPDF417 Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBarcodeWriterPDF417
   Inherits ImGearBarcodeWriterBase
'Usage

Dim instance As ImGearBarcodeWriterPDF417
public class ImGearBarcodeWriterPDF417 : ImGearBarcodeWriterBase
public __gc class ImGearBarcodeWriterPDF417 : public ImGearBarcodeWriterBase
public ref class ImGearBarcodeWriterPDF417 : public ImGearBarcodeWriterBase
Inheritance Hierarchy

System.Object
ImageGear.Barcode.ImGearBarcodeWriterBase
ImageGear.Barcode.ImGearBarcodeWriterPDF417

See Also

Reference

ImGearBarcodeWriterPDF417 Members
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Members$$

ImGearBarcodeWriterPDF417 Class Members
Properties Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterPDF417 Class

The following tables list the members exposed by ImGearBarcodeWriterPDF417.

Public Constructors
 | Name | Description
Public Constructor | ImGearBarcodeWriterPDF417 Constructor | Initializes a new instance of the ImGearBarcodeWriterPDF417 class. It requires an instance to the barcode component.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns desired in the PDF417 barcode.
Public Property | ColumnsCreated | Gets the columns created in the PDF417 barcode.
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level desired in the PDF417 barcode.
Public Property | ErrorCorrectionLevelUsed | Gets the error correction level used in creating the PDF417 barcode.
Public Property | Rows | Gets or sets the number of rows desired in the PDF417 barcode.
Public Property | RowsCreated | Gets the rows created in the PDF417 barcode.
Top
See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeWriterPDF417 Constructor

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : ImGearBarcodeWriterPDF417 Constructor
Instance of the barcode control.
Initializes a new instance of the ImGearBarcodeWriterPDF417 class. It requires an instance to the barcode component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal barcodeParent As ImGearBarcode _
)
'Usage

Dim barcodeParent As ImGearBarcode

Dim instance As New ImGearBarcodeWriterPDF417(barcodeParent)
public ImGearBarcodeWriterPDF417(
   ImGearBarcode barcodeParent
)
public: ImGearBarcodeWriterPDF417(
   ImGearBarcode* barcodeParent
)
public:
ImGearBarcodeWriterPDF417(
   ImGearBarcode^ barcodeParent
)

Parameters

barcodeParent
Instance of the barcode control.
See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


%%PageItemTitle%% $$Properties$$

ImGearBarcodeWriterPDF417 Class Properties

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterPDF417 Class

For a list of all members of this type, see ImGearBarcodeWriterPDF417 members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns desired in the PDF417 barcode.
Public Property | ColumnsCreated | Gets the columns created in the PDF417 barcode.
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level desired in the PDF417 barcode.
Public Property | ErrorCorrectionLevelUsed | Gets the error correction level used in creating the PDF417 barcode.
Public Property | Rows | Gets or sets the number of rows desired in the PDF417 barcode.
Public Property | RowsCreated | Gets the rows created in the PDF417 barcode.
Top
See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImageGear.Barcode Namespace


%%PageItemTitle%% $$Methods$$

ImGearBarcodeWriterPDF417 Class Methods

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeWriterPDF417 Class

For a list of all members of this type, see ImGearBarcodeWriterPDF417 members.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImageGear.Barcode Namespace


Columns Property (ImGearBarcodeWriterPDF417)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : Columns Property
Gets or sets the number of columns desired in the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of columns.
Remarks

The default value is -1.

If the value is -1 then the number of columns will be determined when the barcode is created.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


ColumnsCreated Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : ColumnsCreated Property
Gets the columns created in the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColumnsCreated As Integer
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As Integer

value = instance.ColumnsCreated
public int ColumnsCreated {get;}
public: __property int get_ColumnsCreated();
public:
property int ColumnsCreated {
   int get();
}

Property Value

An integer value which represents the number of columns created.
Remarks

This property gets the number of columns that were created in the PDF417 barcode.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


ErrorCorrectionLevel Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : ErrorCorrectionLevel Property
Gets or sets the error correction level desired in the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As ImGearBarcodePDF417ErrorCorrectionLevel
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As ImGearBarcodePDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public ImGearBarcodePDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public: __property ImGearBarcodePDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   ImGearBarcodePDF417ErrorCorrectionLevel value
);
public:
property ImGearBarcodePDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   ImGearBarcodePDF417ErrorCorrectionLevel get();
   void set (    ImGearBarcodePDF417ErrorCorrectionLevel value);
}

Property Value

The ImGearBarcodePDF417ErrorCorrectionLevel value set.
Remarks

The default value is ImGearBarcodePDF417ErrorCorrectionLevel.ErrorCorrectionAuto.

The error correction level for the PDF417 ranges from ImGearBarcodePDF417ErrorCorrectionLevel.ErrorCorrection0 to a high of ImGearBarcodePDF417ErrorCorrectionLevel.ErrorCorrection8. A high error correction level should be used in application where symbol damage is expected. It is recommended that the ImGearBarcodePDF417ErrorCorrectionLevel.ErrorCorrectionAuto level be used in most cases.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


ErrorCorrectionLevelUsed Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : ErrorCorrectionLevelUsed Property
Gets the error correction level used in creating the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorCorrectionLevelUsed As ImGearBarcodePDF417ErrorCorrectionLevel
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As ImGearBarcodePDF417ErrorCorrectionLevel

value = instance.ErrorCorrectionLevelUsed
public ImGearBarcodePDF417ErrorCorrectionLevel ErrorCorrectionLevelUsed {get;}
public: __property ImGearBarcodePDF417ErrorCorrectionLevel get_ErrorCorrectionLevelUsed();
public:
property ImGearBarcodePDF417ErrorCorrectionLevel ErrorCorrectionLevelUsed {
   ImGearBarcodePDF417ErrorCorrectionLevel get();
}

Property Value

The ImGearBarcodePDF417ErrorCorrectionLevel value set.
Remarks

This property gets the error correction level value used in creation of the PDF417 barcode.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


Rows Property (ImGearBarcodeWriterPDF417)

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : Rows Property
Gets or sets the number of rows desired in the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of rows.
Remarks

The default value is -1

If the value is -1 then the number of rows will be determined when the barcode is created.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


RowsCreated Property

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace > ImGearBarcodeWriterPDF417 Class : RowsCreated Property
Gets the rows created in the PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RowsCreated As Integer
'Usage

Dim instance As ImGearBarcodeWriterPDF417
Dim value As Integer

value = instance.RowsCreated
public int RowsCreated {get;}
public: __property int get_RowsCreated();
public:
property int RowsCreated {
   int get();
}

Property Value

An integer value which represents the number of rows created.
Remarks

This property gets the number of rows that were created in the PDF417 barcode.

See Also

Reference

ImGearBarcodeWriterPDF417 Class
ImGearBarcodeWriterPDF417 Members


%%PageItemTitle%%

EvaluationMode Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : EvaluationMode Enumeration
The evaluation choice of the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EvaluationMode
   Inherits System.Enum
'Usage

Dim instance As EvaluationMode
public enum EvaluationMode : System.Enum
__value public enum EvaluationMode : public System.Enum
public enum class EvaluationMode : public System.Enum
Members
Member | Value | Description
Timeout | 1 | Timeout evaluation mode. When running in evaluation mode, this component will timeout after 5 minutes instead of displaying the evaluation mode dialog box. This is the appropriate evaluation mode for applications that have no user interface.
TrialDialog | 0 | Automatic evaluation mode. When possible, this component will automatically detect that it is running without a user interface and switch to another evaluation mode. Otherwise, it will display the evaluation mode dialog box.
Watermark | 2 | Watermark evaluation mode. When running in evaluation mode, this component will insert the string "UNLICENSED accusoft.com" into the barcode value. This is an appropriate evaluation mode for applications that have no user interface.
Remarks

To simplify your evaluation of this component, Accusoft has implemented an evaluation mode. Normally, this mode will display a dialog box reminding you that you are using evaluation mode. In certain environments with no user interface, such as services, displaying a dialog box will cause the application to stop and you must change the evaluation mode to avoid that problem.

Note: In addition to a dialog box displaying while using the trial version, Barcode Xpress will randomly insert "UNLICENSED accusoft.com" into the data stream of created DataMatrix and PDF417 barcodes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.EvaluationMode

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeAustralianPostCustomDecodeType Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeAustralianPostCustomDecodeType Enumeration
The Australian Post 4 State barocde supports a custom section in both the Customer Barcode 2 and Customer Barcode 3 formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Enum ImGearBarcodeAustralianPostCustomDecodeType
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeAustralianPostCustomDecodeType
[Browsable(true)]
public enum ImGearBarcodeAustralianPostCustomDecodeType : System.Enum
[Browsable(true)]
__value public enum ImGearBarcodeAustralianPostCustomDecodeType : public System.Enum
[Browsable(true)]
public enum class ImGearBarcodeAustralianPostCustomDecodeType : public System.Enum
Members
Member | Value | Description
BarStates | 0 | Returns the bar states of the custom section. This will be a string of A D F T values, where A - Ascending Bar D - Decending Bar F - Full Bar T - Tracking Bar.
NoCustomDecode | 3 | The bars in the custom section are not decoded.
TableC | 2 | The bars in the custom section are decoded using the "C" Table defined by the Australian Post 4 State Barcode specification. This will result in Alphanumeric values, for the custom section, of the barcode value.
TableN | 1 | The bars in the custom section are decoded using the "N" Table defined by the Australian Post 4 State Barcode specification. This will result in numeric values, for the custom section, of the barcode value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeAustralianPostCustomDecodeType

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeDataMatrixSizes Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeDataMatrixSizes Enumeration
The rows and columns are encoded in the value of the enumerations using this equation: RowsXColumnsY = X * 256 + Y. AutoRowsAndColumns is -1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="reviewed and acceptable")>
Public Enum ImGearBarcodeDataMatrixSizes
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeDataMatrixSizes
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="reviewed and acceptable")]
public enum ImGearBarcodeDataMatrixSizes : System.Enum
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="reviewed and acceptable")]
__value public enum ImGearBarcodeDataMatrixSizes : public System.Enum
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="reviewed and acceptable")]
public enum class ImGearBarcodeDataMatrixSizes : public System.Enum
Members
Member | Value | Description
AutoRowsAndColumns | -1 | Auto size the Datamatrix barcode .
Rows104Columns104 | 26728 | 104 x 104 Datamatrix.
Rows10Columns10 | 2570 | 10 x 10 Datamatrix.
Rows120Columns120 | 30840 | 120 x 120 Datamatrix.
Rows12Columns12 | 3084 | 12 x 12 Datamatrix.
Rows12Columns26 | 3098 | 12 x 26 Datamatrix.
Rows12Columns36 | 3108 | 12 x 36 Datamatrix.
Rows132Columns132 | 33924 | 132 x 132 Datamatrix.
Rows144Columns144 | 37008 | 144 x 144 Datamatrix.
Rows14Columns14 | 3598 | 14 x 14 Datamatrix.
Rows16Columns16 | 4112 | 16 x 16 Datamatrix.
Rows16Columns36 | 4132 | 16 x 36 Datamatrix.
Rows16Columns48 | 4144 | 16 x 48 Datamatrix.
Rows18Columns18 | 4626 | 18 x 18 Datamatrix.
Rows20Columns20 | 5140 | 20 x 20 Datamatrix.
Rows22Columns22 | 5654 | 22 x 22 Datamatrix.
Rows24Columns24 | 6168 | 24 x 24 Datamatrix.
Rows26Columns26 | 6682 | 26 x 26 Datamatrix.
Rows32Columns32 | 8224 | 32 x 32 Datamatrix.
Rows36Columns36 | 9252 | 36 x 36 Datamatrix.
Rows40Columns40 | 10280 | 40 x 40 Datamatrix.
Rows44Columns44 | 11308 | 44 x 44 Datamatrix.
Rows48Columns48 | 12336 | 48 x 48 Datamatrix.
Rows52Columns52 | 13364 | 52 x 52 Datamatrix.
Rows64Columns64 | 16448 | 64 x 64 Datamatrix.
Rows72Columns72 | 18504 | 72 x 72 Datamatrix.
Rows80Columns80 | 20560 | 80 x 80 Datamatrix.
Rows88Columns88 | 22616 | 88 x 88 Datamatrix.
Rows8Columns18 | 2066 | 8 x 18 Datamatrix.
Rows8Columns32 | 2080 | 8 x 32 Datamatrix.
Rows96Columns96 | 24672 | 96 x 96 Datamatrix.
Remarks

A C# type cast of (ImGearBarcodeDataMatrixSizes) (22 * 256 + 22) is equivalent to Rows22Columns22. use this with caution since only the specified sizes of the enumerations are allowed and all others will cause an exception.

Caution: An anomaly has been identified for DataMatrix 144 x 144 barcodes written by several competitors'components. For this size only, barcodes created using those components do not adhere to the DataMatrix barcode specification. Because Accusoft does adhere to the DataMatrix specification, those competitors'components will not correctly read 144 x 144 size DataMatrix written by ImGearBarcode.

When reading 144 x 144 DataMatrix barcodes, ImGearBarcode will assume that the barcodes adhere to the specification. If reading fails, the component will automatically attempt to apply the recognition algorithm that will work on barcodes written by the competitors components, and report the results. The barcode reader will not be notified that the barcode did not adhere to the specification. For these barcodes only, recognition speed will be impacted.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeDataMatrixSizes

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeInkColorInfo Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeInkColorInfo Enumeration
Specifies the ink color for barcodes search.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Enum ImGearBarcodeInkColorInfo
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeInkColorInfo
[Browsable(true)]
public enum ImGearBarcodeInkColorInfo : System.Enum
[Browsable(true)]
__value public enum ImGearBarcodeInkColorInfo : public System.Enum
[Browsable(true)]
public enum class ImGearBarcodeInkColorInfo : public System.Enum
Members
Member | Value | Description
Black | 1 | Black ink colored barcodes will be searched. This is the default.
Unknown | 0 | Both black and white ink color barcodes will be searched.
White | 2 | White ink colored barcodes will be searched.
Remarks

To improve recognition and speed by reducing search criteria, set this property correctly.

Default value: Black

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeInkColorInfo

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeLicenseFeature Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeLicenseFeature Enumeration
Identifies public license features.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBarcodeLicenseFeature
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeLicenseFeature
public enum ImGearBarcodeLicenseFeature : System.Enum
__value public enum ImGearBarcodeLicenseFeature : public System.Enum
public enum class ImGearBarcodeLicenseFeature : public System.Enum
Members
Member | Value | Description
Barcode1D | 0 | 1D barcode read/write with speed limited to 40 pages per minute; designed for desktop or other moderate-volume applications.
Barcode1D2D | 1 | 1D and 2D barcode read/write with speed limited to 40 pages per minute; designed for desktop or other moderate-volume applications.
UnlimitedSpeed | 2 | Specified barcode read/write with no preset speed limitations; go as fast as your processor will allow; designed for high-end, high-volume applications.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeLicenseFeature

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeOrientationInfo Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeOrientationInfo Enumeration
Specifies the orientation for the barcode search.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Enum ImGearBarcodeOrientationInfo
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeOrientationInfo
[Browsable(true)]
public enum ImGearBarcodeOrientationInfo : System.Enum
[Browsable(true)]
__value public enum ImGearBarcodeOrientationInfo : public System.Enum
[Browsable(true)]
public enum class ImGearBarcodeOrientationInfo : public System.Enum
Members
Member | Value | Description
Horizontal | 1 | Barcodes with only a horizontal orientation will be searched.
HorizontalVertical | 0 | Search for barcodes in horizontal and vertical direction.
HorizontalVerticalDiagonal | 3 | Barcodes will be searched for in Horizotal, Vertical and 45 degrees. This will increase processing time.
Vertical | 2 | Barcodes with only a vertical orientation will be searched.
Remarks

The default value is HorizontalVertical.

To improve recognition and speed by reducing search criteria, set this property correctly.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeOrientationInfo

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodePDF417ErrorCorrectionLevel Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodePDF417ErrorCorrectionLevel Enumeration
PDF417 Error correction levels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBarcodePDF417ErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodePDF417ErrorCorrectionLevel
public enum ImGearBarcodePDF417ErrorCorrectionLevel : System.Enum
__value public enum ImGearBarcodePDF417ErrorCorrectionLevel : public System.Enum
public enum class ImGearBarcodePDF417ErrorCorrectionLevel : public System.Enum
Members
Member | Value | Description
ErrorCorrection0 | 0 | Error Correction Level 0 - 2 Code words.
ErrorCorrection1 | 1 | Error Correction Level 1 - 4 Code words.
ErrorCorrection2 | 2 | Error Correction Level 2 - 8 Code words.
ErrorCorrection3 | 3 | Error Correction Level 3 - 16 Code words.
ErrorCorrection4 | 4 | Error Correction Level 4 - 32 Code words.
ErrorCorrection5 | 5 | Error Correction Level 5 - 64 Code words.
ErrorCorrection6 | 6 | Error Correction Level 6 - 128 Code words.
ErrorCorrection7 | 7 | Error Correction Level 7 - 256 Code words.
ErrorCorrection8 | 8 | Error Correction Level 8 - 512 Code words.
ErrorCorrectionAuto | -1 | Auto error correction level - choses the best error correction level based on the number of code words in the data stream.
Remarks

The error correction level for the PDF417 ranges from a low of 0 (2 code words of error correction) to a high of 8 (512 code words of error correction). A high error correction level should be used in application where symbol damage is expected. It is recommended that the Auto error correction level be used in most cases.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodePDF417ErrorCorrectionLevel

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeShowTextInfo Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeShowTextInfo Enumeration
Specifies the text to display adjacent to the created barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Enum ImGearBarcodeShowTextInfo
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeShowTextInfo
[Browsable(true)]
public enum ImGearBarcodeShowTextInfo : System.Enum
[Browsable(true)]
__value public enum ImGearBarcodeShowTextInfo : public System.Enum
[Browsable(true)]
public enum class ImGearBarcodeShowTextInfo : public System.Enum
Members
Member | Value | Description
All | 3 | All possible text is displayed.
None | 0 | No text is displayed.
Value | 1 | Only the value is displayed.
ValueAndCheckSum | 2 | The value and check sum is displayed.
Remarks

The default value isAll.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeShowTextInfo

See Also

Reference

ImageGear.Barcode Namespace


%%PageItemTitle%%

ImGearBarcodeType Enumeration

ImageGear22.Barcode Assembly > ImageGear.Barcode Namespace : ImGearBarcodeType Enumeration
Specifies a barcode type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Enum ImGearBarcodeType
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeType
[Browsable(true)]
public enum ImGearBarcodeType : System.Enum
[Browsable(true)]
__value public enum ImGearBarcodeType : public System.Enum
[Browsable(true)]
public enum class ImGearBarcodeType : public System.Enum
Members
Member | Value | Description
Add2Barcode | 20 | Indicates an Add 2 barcode type.
Add5Barcode | 19 | Indicates an Add 5 barcode type.
AustralianPost4StateBarcode | 29 | Australian Post 4 State barcode.
AztecBarcode | 30 | Aztec barcode.
BCDMatrixBarcode | 6 | Indicates a BCD Matrix barcode type.
CodabarBarcode | 11 | Indicates a Codabar barcode type.
Code128Barcode | 14 | Indicates a Code 128 barcode type.
Code32Barcode | 8 | Indicates a Code 32 barcode type.
Code39Barcode | 9 | Indicates a Code 39 barcode type.
Code39ExtendedBarcode | 10 | Indicates a Code 39 Extended barcode type.
Code93Barcode | 12 | Indicates a Code 93 barcode type.
Code93ExtendedBarcode | 13 | Indicates a Code 93 Extended barcode type.
DataLogic2of5Barcode | 4 | Indicates a DataLogic 2 of 5 barcode type.
DataMatrixBarcode | 25 | Indicates a DataMatrix barcode type.
EAN128Barcode | 21 | Indicates an EAN-128 barcode type.
EAN13Barcode | 15 | Indicates an EAN-13 barcode. This also supports a JAN barcode which is an EAN-13 with country code 49.
EAN8Barcode | 16 | Indicates an EAN-8 barcode type.
IATA2of5Barcode | 3 | Indicates an IATA 2 of 5 barcode type.
Industry2of5Barcode | 1 | Indicates an Industry 2 of 5 barcode type.
IntelligentMailBarcode | 27 | United States Postal IntelligentMail 4 State barcode.
Interleaved2of5Barcode | 2 | Indicates an Interleaved 2 of 5 barcode type.
Invert2of5Barcode | 5 | Indicates an Inverted 2 of 5 barcode type.
Matrix2of5Barcode | 7 | Indicates a Matrix 2 of 5 barcode type.
PatchCodeBarcode | 22 | Indicates a Patch Code.
PDF417Barcode | 24 | Indicates a PDF417 barcode type.
PostNetBarcode | 23 | Indicates a PostNet barcode type.
QRCodeBarcode | 26 | QR Code barcode.
RoyalPost4StateBarcode | 28 | Royal Post 4 State barcode.
UnknownBarcode | 0 | Indicates an unknown barcode.
UPCABarcode | 17 | Indicates a UPC-A barcode type.
UPCEBarcode | 18 | Indicates a UPC-E barcode type.
Remarks

The default value is UnknownBarcode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Barcode.ImGearBarcodeType

See Also

Reference

ImageGear.Barcode Namespace


ImageGear22.Core Assembly
Namespaces
Namespace | Description
ImageGear.Core | The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit. This namespace contains classes to operate with graphics primitives, to license the product and, most importantly, primary ImageGear entities like page and document.
ImageGear.Display | The ImageGear.Display namespace provides the ImageGear for .NET API for displaying and printing.
ImageGear.Formats | ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
ImageGear.Formats.JPG | This namespace provides enumerations values for JPEG format filter control parameters.
ImageGear.Formats.TIF | This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.
ImageGear.Processing | This namespace represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as remove red eye, perspective, solarize, warp, wave, etc.
ImageGear.Processing.Layers | ImageGear.Processing.Layers namespace provides API for creating and editing image layers. It includes ImGearLayeredPage class, which contains a raster composition image and an array of layers.


ImageGear.Core Namespace (ImageGear22.Core)
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Core Namespace
The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit. This namespace contains classes to operate with graphics primitives, to license the product and, most importantly, primary ImageGear entities like page and document.
Classes
 | Class | Description
Class | ImGearColorBook | Represents a color book.
Class | ImGearColorBookColor | Represents a color in the color book.
Class | ImGearColorBooks | Represents a static collection of color books.
Class | ImGearColorChannelInfo | Spot channel class that uses regular color space like RGB, CMYK, etc.
Class | ImGearColorProfile | Represents a color profile.
Class | ImGearColorProfileManager | Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.
Class | ImGearDIB | Encapsulates an image, which consists of the pixel data and its attributes.
Class | ImGearDisplayChannel | Represents display attributes for individual channel.
Class | ImGearDisplayChannels | Represents a collection of ImGearDisplayChannel class objects.
Class | ImGearDocument | Represents a collection of ImGearPage objects.
Class | ImGearDocumentPageArray | Represents a collection of pages within ImGearDocument object.
Class | ImGearException | Base class for all exceptions thrown by the ImageGear for .NET library. Contains error codes and optionally supplied data.
Class | ImGearExtraChannelInfo | This is a general extra channel class.
Class | ImGearFullLUT | Represents a lookup table that contains a full table of values for each possible input index.
Class | ImGearLicense | Manages licensing data (i.e., license type and key).
Class | ImGearLinearLUT | This class represents a lookup table that does not store the actual LUT values, but calculates output values dynamically using a linear formula.
Class | ImGearLUT | Provides a base for lookup tables (LUTs) that are used in ImageGear.
Class | ImGearMaskColorChannelInfo | Represents mask color channel info.
Class | ImGearMaskSpotChannelInfo | Represents a mask spot channel that uses a special (like Pantone) color.
Class | ImGearMetadataDictionary | Provides access to Metadata Dictionary that is used in ImageGear.
Class | ImGearMetadataHead | Head of metadata tree.
Class | ImGearMetadataLeaf | Represents metadata node that contains a data value and cannot reference other metadata nodes.
Class | ImGearMetadataNode | Provides generic functionality for the ImageGear metadata objects.
Class | ImGearMetadataNodeList | Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.
Class | ImGearMetadataTree | Encapsulates entity of file format metadata tree.
Class | ImGearMultichannelLUT | Represents a multichannel lookup table (LUT).
Class | ImGearPage | Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.
Class | ImGearPixel | Encapsulates all attributes and operations for an image pixel.
Class | ImGearPixelArray | One dimensional array of image pixels.
Class | ImGearPolygon | Defines a polygon shape.
Class | ImGearRasterPage | The class represents a raster image.
Class | ImGearRGBLUT | Represents RGB lookup table (LUT).
Class | ImGearROI | Region of interest associated with an ImGearPage instance.
Class | ImGearROIMask | 1-bit (binary) raster image that specifies a free shaped region of interest.
Class | ImGearROIRectangle | Rectangular region of interest.
Class | ImGearSpotChannelInfo | Spot channel class that uses a special color, such as Pantone.
Class | ImGearTransparency | Specifies image transparency attributes like transparent color for display.
Class | ImGearVectorPage | Represents a page that contains vector data.
Class | ImGearVersion | This class provides static properties to retrieve version info for the product assembly.
Class | ImGearWarning | Base class for all warnings handled by the ImageGear for .NET library. Contains error code and optionally supplied data.
Interfaces
 | Interface | Description
Interface | IImGearBinocular | Defines Binocular shape interface.
Interface | IImGearColorBook | Defines color book interface.
Interface | IImGearColorBookColor | Defines color book color interface.
Interface | IImGearDICOMDisplaySettings | Specifies baseline features for DICOM display settings.
Interface | IImGearDoublePoint | Defines DoublePoint interface.
Interface | IImGearDoubleRectangle | Defines DoubleRectangle interface.
Interface | IImGearEllipse | Defines Ellipse interface.
Interface | IImGearMetadataDictRecord | Specifies baseline features for a metadata dictionary record.
Interface | IImGearOrientation | Defines Orientation interface.
Interface | IImGearPoint | Defines Point interface.
Interface | IImGearRectangle | Defines IImGearRectangle interface.
Interface | IImGearResolution | Represents image resolution interface.
Interface | IImGearRGBQuad | Defines palette entry interface.
Interface | IImGearRoundedRectangle | Represents a rounded rectangle.
Interface | IImGearShape | Defines Shape interface.
Interface | IImGearSize | Defines Size interface.
Structures
 | Structure | Description
Structure | ImGearArrayRef | Represents a reference to a particular location in an array.
Structure | ImGearBinocular | Defines Binocular shape.
Structure | ImGearChannelRange | Describes channels to be processed with ImageGear.Processing.ImGearProcessing class methods.
Structure | ImGearColorSpace | Defines semantics of information, stored in all image channels.
Structure | ImGearCommonMetadataDictRecord | Contains data for a common metadata dictionary record.
Structure | ImGearDoublePoint | Stores a set of two double precision numbers that represent the point.
Structure | ImGearDoubleRectangle | Stores a set of four double precision numbers that represent the location and size of a rectangle.
Structure | ImGearEllipse | Stores a set of two ImGear values that represent the location and size of an ellipse.
Structure | ImGearOrientation | Specifies orientation of page or display.
Structure | ImGearPoint | Encapsulates a point in a 2-D coordinate system.
Structure | ImGearRationalInt | Specifies rational fraction as an indicated division of Numerator/Denominator.
Structure | ImGearRationalUInt | Specifies rational fraction as an indicated division of Numerator/Denominator.
Structure | ImGearRect | Stores a set of four integer numbers that represent the location and size of the rectangle.
Structure | ImGearRectangle | Stores a set of four integer numbers that represent the location and size of a rectangle.
Structure | ImGearResolution | Stores ImageGear resolution data.
Structure | ImGearRGBQuad | Specifies an RGB value.
Structure | ImGearRoundedRectangle | This structure represents a rounded rectangle.
Structure | ImGearSize | Implements a relative coordinate or position.
Delegates
 | Delegate | Description
Delegate | ImGearAddWarning | Specifies the warning processing routine to be called when the warning is added.
Enumerations
 | Enumeration | Description
Enumeration | ImGearChannelGroups | Specifies alpha channels.
Enumeration | ImGearColorSpaceIDs | Specifies ImageGear color space IDs.
Enumeration | ImGearErrorCodes | Specifies ImageGear error codes.
Enumeration | ImGearExtraChannelType | Specifies all the supported types of extra channels.
Enumeration | ImGearFlipModes | Specifies ImageGear flip modes.
Enumeration | ImGearMaskChannelModes | Specifies whether the color indicates masked or selected area.
Enumeration | ImGearOrientationModes | Specifies ImageGear orientation modes.
Enumeration | ImGearRenderingIntents | Lists identifiers that controls how colors are transformed during color space conversion using color profiles.
Enumeration | ImGearResolutionUnits | Specifies the measurements of image resolution units.
Enumeration | ImGearRotationValues | Specifies the value of the rotation angle.
Enumeration | ImGearSpotColorVendorID | Specifies all supported vendor IDs.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Core Namespace (ImageGear22.Core) Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Core Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearColorBook
ImageGear.Core.ImGearColorBookColor
ImageGear.Core.ImGearColorBooks
ImageGear.Core.ImGearColorProfile
ImageGear.Core.ImGearColorProfileManager
ImageGear.Core.ImGearDIB
ImageGear.Core.ImGearDisplayChannel
ImageGear.Core.ImGearDisplayChannels
ImageGear.Core.ImGearDocument
ImageGear.Core.ImGearDocumentPageArray
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearColorChannelInfo
ImageGear.Core.ImGearMaskColorChannelInfo
ImageGear.Core.ImGearSpotChannelInfo
ImageGear.Core.ImGearMaskSpotChannelInfo
ImageGear.Core.ImGearLicense
ImageGear.Core.ImGearLUT
ImageGear.Core.ImGearFullLUT
ImageGear.Core.ImGearLinearLUT
ImageGear.Core.ImGearMetadataDictionary
ImageGear.Core.ImGearMetadataNode
ImageGear.Core.ImGearMetadataHead
ImageGear.Core.ImGearMetadataLeaf
ImageGear.Core.ImGearMetadataTree
ImageGear.Core.ImGearMetadataNodeList
ImageGear.Core.ImGearMultichannelLUT
ImageGear.Core.ImGearRGBLUT
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearRasterPage
ImageGear.Processing.Layers.ImGearLayeredPage
ImageGear.Core.ImGearVectorPage
ImageGear.Core.ImGearPixel
ImageGear.Core.ImGearPixelArray
ImageGear.Core.ImGearPolygon
ImageGear.Core.ImGearROI
ImageGear.Core.ImGearROIMask
ImageGear.Core.ImGearROIRectangle
ImageGear.Core.ImGearTransparency
ImageGear.Core.ImGearVersion
ImageGear.Core.ImGearWarning
System.Exception
ImageGear.Core.ImGearException
System.ValueType
ImageGear.Core.ImGearArrayRef
ImageGear.Core.ImGearBinocular
ImageGear.Core.ImGearChannelRange
ImageGear.Core.ImGearColorSpace
ImageGear.Core.ImGearCommonMetadataDictRecord
ImageGear.Core.ImGearDoublePoint
ImageGear.Core.ImGearDoubleRectangle
ImageGear.Core.ImGearEllipse
ImageGear.Core.ImGearOrientation
ImageGear.Core.ImGearPoint
ImageGear.Core.ImGearRationalInt
ImageGear.Core.ImGearRationalUInt
ImageGear.Core.ImGearRect
ImageGear.Core.ImGearRectangle
ImageGear.Core.ImGearResolution
ImageGear.Core.ImGearRGBQuad
ImageGear.Core.ImGearRoundedRectangle
ImageGear.Core.ImGearSize
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearColorBook Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBook Class
Represents a color book.
Object Model
ImGearColorBook Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearColorBook
   Implements IImGearColorBook
'Usage

Dim instance As ImGearColorBook
public sealed class ImGearColorBook : IImGearColorBook
public __gc __sealed class ImGearColorBook : public IImGearColorBook
public ref class ImGearColorBook sealed : public IImGearColorBook
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearColorBook

See Also

Reference

ImGearColorBook Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorBook Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBook Class

The following tables list the members exposed by ImGearColorBook.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorBook Constructor | Overloaded. Initializes a new instance of the ImGearColorBook class.
Top
Public Properties
 | Name | Description
Public Property | Colors | Gets the array of individual color records held by the color book.
Public Property | ColorsPerPage | Gets the maximum number of colors that can appear on a page.
Public Property | ColorType | Gets the color space value used for displaying all the colors from the color book.
Public Property | Description | Gets the color book copyright information.
Public Property | FileName | Gets the color book file name.
Public Property | KeyColorPage | Gets the key color on the page.
Public Property | NumberOfColors | Gets the number of colors in the color book.
Public Property | Postfix | Gets the color book postfix string value.
Public Property | Prefix | Gets the color book prefix string value.
Public Property | Title | Gets the color book title.
Public Property | VendorID | Gets the color book vendor ID value.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a color to the color book.
static (Shared in Visual Basic) | Create | Creates and initializes an instance of ImGearColorBook class.
Public Method | Get | Returns a color with the specified ID from the color book.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all the colors in the color book.
Top
See Also

Reference

ImGearColorBook Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorBook Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : ImGearColorBook Constructor
Initializes a new instance of the ImGearColorBook class.
Overload List
Overload | Description
ImGearColorBook Constructor(FileStream) | Initializes a new instance of the ImGearColorBook class from specified file stream.
ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,Int32,Int32,ImGearColorSpaceIDs) | Initializes a new instance of the ImGearColorBook class with specified parameters.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

ImGearColorBook Constructor(FileStream)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class > ImGearColorBook Constructor : ImGearColorBook Constructor(FileStream)
File stream to load color book from.
Initializes a new instance of the ImGearColorBook class from specified file stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As FileStream _
)
'Usage

Dim content As FileStream

Dim instance As New ImGearColorBook(content)
public ImGearColorBook(
   FileStream content
)
public: ImGearColorBook(
   FileStream* content
)
public:
ImGearColorBook(
   FileStream^ content
)

Parameters

content
File stream to load color book from.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
Overload List


%%PageItemTitle%%

ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,Int32,Int32,ImGearColorSpaceIDs)
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class > ImGearColorBook Constructor : ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,Int32,Int32,ImGearColorSpaceIDs)
Color book vendor ID.
Color book file name.
Color book title.
Color book prefix.
Color book postfix.
Color book description.
Number of colors in color book.
Number of colors per page in color book.
Color type.
Initializes a new instance of the ImGearColorBook class with specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal vendorId As ImGearSpotColorVendorID, _
   ByVal fileName As String, _
   ByVal title As String, _
   ByVal prefix As String, _
   ByVal postfix As String, _
   ByVal description As String, _
   ByVal numberOfColors As Integer, _
   ByVal colorsPerPage As Integer, _
   ByVal colorType As ImGearColorSpaceIDs _
)
'Usage

Dim vendorId As ImGearSpotColorVendorID
Dim fileName As String
Dim title As String
Dim prefix As String
Dim postfix As String
Dim description As String
Dim numberOfColors As Integer
Dim colorsPerPage As Integer
Dim colorType As ImGearColorSpaceIDs

Dim instance As New ImGearColorBook(vendorId, fileName, title, prefix, postfix, description, numberOfColors, colorsPerPage, colorType)
public ImGearColorBook(
   ImGearSpotColorVendorID vendorId,
   string fileName,
   string title,
   string prefix,
   string postfix,
   string description,
   int numberOfColors,
   int colorsPerPage,
   ImGearColorSpaceIDs colorType
)
public: ImGearColorBook(
   ImGearSpotColorVendorID vendorId,
   string* fileName,
   string* title,
   string* prefix,
   string* postfix,
   string* description,
   int numberOfColors,
   int colorsPerPage,
   ImGearColorSpaceIDs colorType
)
public:
ImGearColorBook(
   ImGearSpotColorVendorID vendorId,
   String^ fileName,
   String^ title,
   String^ prefix,
   String^ postfix,
   String^ description,
   int numberOfColors,
   int colorsPerPage,
   ImGearColorSpaceIDs colorType
)

Parameters

vendorId
Color book vendor ID.
fileName
Color book file name.
title
Color book title.
prefix
Color book prefix.
postfix
Color book postfix.
description
Color book description.
numberOfColors
Number of colors in color book.
colorsPerPage
Number of colors per page in color book.
colorType
Color type.
Example
  • C#
ImGearColorBooks.Initialize(files);
ImGearColorBook book = new ImGearColorBook(ImGearSpotColorVendorID.PantoneProcess, "", "My Color Book", "Prefix", "Postfix", "Description", 2, 2, ImGearColorSpaceIDs.LAB);
ImGearPixel p = new ImGearPixel(3, 8);
p[0] = 138; p[1] = 202; p[2] = 169;
book.Add(new ImGearColorBookColor("PANTONE Red 032 C", 90452819915331, p, ImGearColorSpaceIDs.LAB));
p[0] = 48; p[1] = 160; p[2] = 54;
book.Add(new ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB));
ImGearColorBooks.Add(book);
  • Visual Basic
ImGearColorBooks.Initialize(files)
book = New ImGearColorBook(ImGearSpotColorVendorID.PantoneProcess, "", "My Color Book", "Prefix", "Postfix", "Description", 2, 2, ImGearColorSpaceIDs.LAB)
p = New ImGearPixel(3, 8)
p(0) = 138
p(1) = 202
p(2) = 169
book.Add(New ImGearColorBookColor("PANTONE Red 032 C", 90452819915331, p, ImGearColorSpaceIDs.LAB))
p(0) = 48
p(1) = 160
p(2) = 54
book.Add(New ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB))
ImGearColorBooks.Add(book)
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearColorBook Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBook Class

For a list of all members of this type, see ImGearColorBook members.

Public Methods
 | Name | Description
Public Method | Add | Adds a color to the color book.
static (Shared in Visual Basic) | Create | Creates and initializes an instance of ImGearColorBook class.
Public Method | Get | Returns a color with the specified ID from the color book.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all the colors in the color book.
Top
See Also

Reference

ImGearColorBook Class
ImageGear.Core Namespace


Add Method (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Add Method
Color book color object.
Adds a color to the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal color As ImGearColorBookColor _
)
'Usage

Dim instance As ImGearColorBook
Dim color As ImGearColorBookColor

instance.Add(color)
public void Add(
   ImGearColorBookColor color
)
public: void Add(
   ImGearColorBookColor* color
)
public:
void Add(
   ImGearColorBookColor^ color
)

Parameters

color
Color book color object.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearColorBookColor Class


Create Method (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Create Method
Color book vendor ID.
Color book title.
Color type.
Creates and initializes an instance of ImGearColorBook class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Create( _
   ByVal vendorId As ImGearSpotColorVendorID, _
   ByVal title As String, _
   ByVal colorType As ImGearColorSpaceIDs _
) As ImGearColorBook
'Usage

Dim vendorId As ImGearSpotColorVendorID
Dim title As String
Dim colorType As ImGearColorSpaceIDs
Dim value As ImGearColorBook

value = ImGearColorBook.Create(vendorId, title, colorType)
public static ImGearColorBook Create(
   ImGearSpotColorVendorID vendorId,
   string title,
   ImGearColorSpaceIDs colorType
)
public: static ImGearColorBook* Create(
   ImGearSpotColorVendorID vendorId,
   string* title,
   ImGearColorSpaceIDs colorType
)
public:
static ImGearColorBook^ Create(
   ImGearSpotColorVendorID vendorId,
   String^ title,
   ImGearColorSpaceIDs colorType
)

Parameters

vendorId
Color book vendor ID.
title
Color book title.
colorType
Color type.

Return Value

ImGearColorBook class object.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearSpotColorVendorID Enumeration
ImGearColorSpaceIDs Enumeration


Get Method (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Get Method
ID of the requested color.
Returns a color with the specified ID from the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Get( _
   ByVal id As Long _
) As ImGearColorBookColor
'Usage

Dim instance As ImGearColorBook
Dim id As Long
Dim value As ImGearColorBookColor

value = instance.Get(id)
public ImGearColorBookColor Get(
   long id
)
public: ImGearColorBookColor* Get(
   long id
)
public:
ImGearColorBookColor^ Get(
   int64 id
)

Parameters

id
ID of the requested color.

Return Value

ImGearColorBookColor class object.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearColorBookColor Class


GetEnumerator Method (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : GetEnumerator Method
Returns IEnumerator interface used for enumeration all the colors in the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearColorBook
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface..
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%% $$Properties$$

ImGearColorBook Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBook Class

For a list of all members of this type, see ImGearColorBook members.

Public Properties
 | Name | Description
Public Property | Colors | Gets the array of individual color records held by the color book.
Public Property | ColorsPerPage | Gets the maximum number of colors that can appear on a page.
Public Property | ColorType | Gets the color space value used for displaying all the colors from the color book.
Public Property | Description | Gets the color book copyright information.
Public Property | FileName | Gets the color book file name.
Public Property | KeyColorPage | Gets the key color on the page.
Public Property | NumberOfColors | Gets the number of colors in the color book.
Public Property | Postfix | Gets the color book postfix string value.
Public Property | Prefix | Gets the color book prefix string value.
Public Property | Title | Gets the color book title.
Public Property | VendorID | Gets the color book vendor ID value.
Top
See Also

Reference

ImGearColorBook Class
ImageGear.Core Namespace


Colors Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Colors Property
Gets the array of individual color records held by the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Colors As ImGearColorBookColor()
'Usage

Dim instance As ImGearColorBook
Dim value() As ImGearColorBookColor

value = instance.Colors
public ImGearColorBookColor[] Colors {get;}
public: __property ImGearColorBookColor*[]* get_Colors();
public:
property array<ImGearColorBookColor^>^ Colors {
   array<ImGearColorBookColor^>^ get();
}

Property Value

ImGearColorBookColor class object.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearColorBookColor Class


ColorsPerPage Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : ColorsPerPage Property
Gets the maximum number of colors that can appear on a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorsPerPage As Integer
'Usage

Dim instance As ImGearColorBook
Dim value As Integer

value = instance.ColorsPerPage
public int ColorsPerPage {get;}
public: __property int get_ColorsPerPage();
public:
property int ColorsPerPage {
   int get();
}

Property Value

Integer value.
Remarks
The maximum number of colors per page must be less than or equal to 9.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


ColorType Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : ColorType Property
Gets the color space value used for displaying all the colors from the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorType As ImGearColorSpaceIDs
'Usage

Dim instance As ImGearColorBook
Dim value As ImGearColorSpaceIDs

value = instance.ColorType
public ImGearColorSpaceIDs ColorType {get;}
public: __property ImGearColorSpaceIDs get_ColorType();
public:
property ImGearColorSpaceIDs ColorType {
   ImGearColorSpaceIDs get();
}

Property Value

ImGearColorSpaceIDs enumeration value.
Remarks
This value can be RGB, CMYK or Lab.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearColorSpaceIDs Enumeration


Description Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Description Property
Gets the color book copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Description As String
'Usage

Dim instance As ImGearColorBook
Dim value As String

value = instance.Description
public string Description {get;}
public: __property string* get_Description();
public:
property String^ Description {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


FileName Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : FileName Property
Gets the color book file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FileName As String
'Usage

Dim instance As ImGearColorBook
Dim value As String

value = instance.FileName
public string FileName {get;}
public: __property string* get_FileName();
public:
property String^ FileName {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


KeyColorPage Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : KeyColorPage Property
Gets the key color on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property KeyColorPage As Integer
'Usage

Dim instance As ImGearColorBook
Dim value As Integer

value = instance.KeyColorPage
public int KeyColorPage {get;}
public: __property int get_KeyColorPage();
public:
property int KeyColorPage {
   int get();
}

Property Value

Integer value.
Remarks
Key color on the page must be less than or equal to colors per page.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


NumberOfColors Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : NumberOfColors Property
Gets the number of colors in the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NumberOfColors As Integer
'Usage

Dim instance As ImGearColorBook
Dim value As Integer

value = instance.NumberOfColors
public int NumberOfColors {get;}
public: __property int get_NumberOfColors();
public:
property int NumberOfColors {
   int get();
}

Property Value

Integer value.
Remarks
The number of colors in the color book must be less than or equal to 8000.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


Postfix Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Postfix Property
Gets the color book postfix string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Postfix As String
'Usage

Dim instance As ImGearColorBook
Dim value As String

value = instance.Postfix
public string Postfix {get;}
public: __property string* get_Postfix();
public:
property String^ Postfix {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


Prefix Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Prefix Property
Gets the color book prefix string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Prefix As String
'Usage

Dim instance As ImGearColorBook
Dim value As String

value = instance.Prefix
public string Prefix {get;}
public: __property string* get_Prefix();
public:
property String^ Prefix {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


Title Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : Title Property
Gets the color book title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Title As String
'Usage

Dim instance As ImGearColorBook
Dim value As String

value = instance.Title
public string Title {get;}
public: __property string* get_Title();
public:
property String^ Title {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


VendorID Property (ImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBook Class : VendorID Property
Gets the color book vendor ID value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VendorID As ImGearSpotColorVendorID
'Usage

Dim instance As ImGearColorBook
Dim value As ImGearSpotColorVendorID

value = instance.VendorID
public ImGearSpotColorVendorID VendorID {get;}
public: __property ImGearSpotColorVendorID get_VendorID();
public:
property ImGearSpotColorVendorID VendorID {
   ImGearSpotColorVendorID get();
}

Property Value

ImGearSpotColorVendorID enumeration.
See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
ImGearSpotColorVendorID Enumeration


%%PageItemTitle%%

ImGearColorBookColor Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBookColor Class
Represents a color in the color book.
Object Model
ImGearColorBookColor ClassImGearColorSpace StructureImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearColorBookColor
   Implements IImGearColorBookColor
'Usage

Dim instance As ImGearColorBookColor
public sealed class ImGearColorBookColor : IImGearColorBookColor
public __gc __sealed class ImGearColorBookColor : public IImGearColorBookColor
public ref class ImGearColorBookColor sealed : public IImGearColorBookColor
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearColorBookColor

See Also

Reference

ImGearColorBookColor Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorBookColor Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBookColor Class

The following tables list the members exposed by ImGearColorBookColor.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorBookColor Constructor | Initializes a new instance of the ImGearColorBookColor class.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the color space of the color used for display.
Public Property | ID | Gets the catalog code of the color.
Public Property | Name | Gets the full name of the color.
Top
Public Methods
 | Name | Description
Public Method | GetColorValueCopy | Returns a copy of the color value used for display.
Top
See Also

Reference

ImGearColorBookColor Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorBookColor Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBookColor Class : ImGearColorBookColor Constructor
Name of the color.
ID of the color.
ImGearPixel value of the color.
Color space.
Initializes a new instance of the ImGearColorBookColor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal id As Long, _
   ByVal color As ImGearPixel, _
   ByVal colorType As ImGearColorSpaceIDs _
)
'Usage

Dim name As String
Dim id As Long
Dim color As ImGearPixel
Dim colorType As ImGearColorSpaceIDs

Dim instance As New ImGearColorBookColor(name, id, color, colorType)
public ImGearColorBookColor(
   string name,
   long id,
   ImGearPixel color,
   ImGearColorSpaceIDs colorType
)
public: ImGearColorBookColor(
   string* name,
   long id,
   ImGearPixel* color,
   ImGearColorSpaceIDs colorType
)
public:
ImGearColorBookColor(
   String^ name,
   int64 id,
   ImGearPixel^ color,
   ImGearColorSpaceIDs colorType
)

Parameters

name
Name of the color.
id
ID of the color.
color
ImGearPixel value of the color.
colorType
Color space.
See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members
ImGearPixel Class
ImGearColorSpaceIDs Enumeration


%%PageItemTitle%% $$Methods$$

ImGearColorBookColor Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBookColor Class

For a list of all members of this type, see ImGearColorBookColor members.

Public Methods
 | Name | Description
Public Method | GetColorValueCopy | Returns a copy of the color value used for display.
Top
See Also

Reference

ImGearColorBookColor Class
ImageGear.Core Namespace


GetColorValueCopy Method (ImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBookColor Class : GetColorValueCopy Method
Returns a copy of the color value used for display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorValueCopy() As ImGearPixel
'Usage

Dim instance As ImGearColorBookColor
Dim value As ImGearPixel

value = instance.GetColorValueCopy()
public ImGearPixel GetColorValueCopy()
public: ImGearPixel* GetColorValueCopy();
public:
ImGearPixel^ GetColorValueCopy();

Return Value

A new instance of ImGearPixel class.
See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members
ImGearPixel Class


%%PageItemTitle%% $$Properties$$

ImGearColorBookColor Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBookColor Class

For a list of all members of this type, see ImGearColorBookColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the color space of the color used for display.
Public Property | ID | Gets the catalog code of the color.
Public Property | Name | Gets the full name of the color.
Top
See Also

Reference

ImGearColorBookColor Class
ImageGear.Core Namespace


ColorSpace Property (ImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBookColor Class : ColorSpace Property
Gets the color space of the color used for display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearColorBookColor
Dim value As ImGearColorSpace

value = instance.ColorSpace
public ImGearColorSpace ColorSpace {get;}
public: __property ImGearColorSpace get_ColorSpace();
public:
property ImGearColorSpace ColorSpace {
   ImGearColorSpace get();
}

Property Value

ImGearColorSpace structure.
See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members
ImGearColorSpace Structure


ID Property (ImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBookColor Class : ID Property
Gets the catalog code of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As Long
'Usage

Dim instance As ImGearColorBookColor
Dim value As Long

value = instance.ID
public long ID {get;}
public: __property long get_ID();
public:
property int64 ID {
   int64 get();
}

Property Value

Long value.
See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


Name Property (ImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBookColor Class : Name Property
Gets the full name of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearColorBookColor
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%%

ImGearColorBooks Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBooks Class
Represents a static collection of color books.
Object Model
ImGearColorBooks Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearColorBooks
'Usage

Dim instance As ImGearColorBooks
public sealed class ImGearColorBooks
public __gc __sealed class ImGearColorBooks
public ref class ImGearColorBooks sealed
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearColorBooks

See Also

Reference

ImGearColorBooks Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorBooks Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBooks Class

The following tables list the members exposed by ImGearColorBooks.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorBooks Constructor | Initializes a new instance of the ImGearColorBooks class object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of color books in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Adds a new color book to the collection.
static (Shared in Visual Basic) | AddBookFromFile | Adds a new color book to the collection from the specified file name.
Public Method | CopyTo | Copies a range of elements to the specified array.
static (Shared in Visual Basic) | Get | Retrieves a color book for the specified vendor ID.
static (Shared in Visual Basic) | GetAllBooks | Retrieves the entire collection of color books.
static (Shared in Visual Basic) | GetByIndex | Retrieves a color book with the specified index.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all the color books in the collection.
static (Shared in Visual Basic) | GetSynonyms | Returns an array of vendor IDs associated with the specified ID.
static (Shared in Visual Basic) | Initialize | Loads the color book collection from the list of file paths.
static (Shared in Visual Basic) | Remove | Removes color book for the specified vendor ID.
static (Shared in Visual Basic) | RemoveAt | Removes color book with the specified index.
Top
See Also

Reference

ImGearColorBooks Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorBooks Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : ImGearColorBooks Constructor
Initializes a new instance of the ImGearColorBooks class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearColorBooks()
public ImGearColorBooks()
public: ImGearColorBooks();
public:
ImGearColorBooks();
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%% $$Methods$$

ImGearColorBooks Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBooks Class

For a list of all members of this type, see ImGearColorBooks members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Adds a new color book to the collection.
static (Shared in Visual Basic) | AddBookFromFile | Adds a new color book to the collection from the specified file name.
Public Method | CopyTo | Copies a range of elements to the specified array.
static (Shared in Visual Basic) | Get | Retrieves a color book for the specified vendor ID.
static (Shared in Visual Basic) | GetAllBooks | Retrieves the entire collection of color books.
static (Shared in Visual Basic) | GetByIndex | Retrieves a color book with the specified index.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all the color books in the collection.
static (Shared in Visual Basic) | GetSynonyms | Returns an array of vendor IDs associated with the specified ID.
static (Shared in Visual Basic) | Initialize | Loads the color book collection from the list of file paths.
static (Shared in Visual Basic) | Remove | Removes color book for the specified vendor ID.
static (Shared in Visual Basic) | RemoveAt | Removes color book with the specified index.
Top
See Also

Reference

ImGearColorBooks Class
ImageGear.Core Namespace


Add Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : Add Method
New color book to add.
Adds a new color book to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Add( _
   ByVal newColorBook As ImGearColorBook _
) As Integer
'Usage

Dim newColorBook As ImGearColorBook
Dim value As Integer

value = ImGearColorBooks.Add(newColorBook)
public static int Add(
   ImGearColorBook newColorBook
)
public: static int Add(
   ImGearColorBook* newColorBook
)
public:
static int Add(
   ImGearColorBook^ newColorBook
)

Parameters

newColorBook
New color book to add.

Return Value

Integer value.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


AddBookFromFile Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : AddBookFromFile Method
Color book file.
Adds a new color book to the collection from the specified file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function AddBookFromFile( _
   ByVal fileName As String _
) As Integer
'Usage

Dim fileName As String
Dim value As Integer

value = ImGearColorBooks.AddBookFromFile(fileName)
public static int AddBookFromFile(
   string fileName
)
public: static int AddBookFromFile(
   string* fileName
)
public:
static int AddBookFromFile(
   String^ fileName
)

Parameters

fileName
Color book file.

Return Value

Integer value.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


CopyTo Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : CopyTo Method
ImGearColorBook array to copy the color elements to.
The zero-based index in array at which copying begins.
Copies a range of elements to the specified array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearColorBooks
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Array array,
   int index
)
public: void CopyTo(
   Array* array,
   int index
)
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
ImGearColorBook array to copy the color elements to.
index
The zero-based index in array at which copying begins.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


Get Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : Get Method
Vendor ID for which to get the color book.
Retrieves a color book for the specified vendor ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Get( _
   ByVal vendorId As ImGearSpotColorVendorID _
) As ImGearColorBook
'Usage

Dim vendorId As ImGearSpotColorVendorID
Dim value As ImGearColorBook

value = ImGearColorBooks.Get(vendorId)
public static ImGearColorBook Get(
   ImGearSpotColorVendorID vendorId
)
public: static ImGearColorBook* Get(
   ImGearSpotColorVendorID vendorId
)
public:
static ImGearColorBook^ Get(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID for which to get the color book.

Return Value

ImGearColorBook class object.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class
ImGearSpotColorVendorID Enumeration


GetAllBooks Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : GetAllBooks Method
Retrieves the entire collection of color books.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetAllBooks() As ImGearColorBook()
'Usage

Dim value() As ImGearColorBook

value = ImGearColorBooks.GetAllBooks()
public static ImGearColorBook[] GetAllBooks()
public: static ImGearColorBook*[]* GetAllBooks();
public:
static array<ImGearColorBook^>^ GetAllBooks();

Return Value

ImGearColorBook class object.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


GetByIndex Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : GetByIndex Method
Index of the color book to get.
Retrieves a color book with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetByIndex( _
   ByVal index As Integer _
) As ImGearColorBook
'Usage

Dim index As Integer
Dim value As ImGearColorBook

value = ImGearColorBooks.GetByIndex(index)
public static ImGearColorBook GetByIndex(
   int index
)
public: static ImGearColorBook* GetByIndex(
   int index
)
public:
static ImGearColorBook^ GetByIndex(
   int index
)

Parameters

index
Index of the color book to get.

Return Value

ImGearColorBook class object.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


GetEnumerator Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : GetEnumerator Method
Returns IEnumerator interface used for enumeration all the color books in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearColorBooks
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


GetSynonyms Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : GetSynonyms Method
Vendor ID.
Returns an array of vendor IDs associated with the specified ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetSynonyms( _
   ByVal vendorId As ImGearSpotColorVendorID _
) As ImGearSpotColorVendorID()
'Usage

Dim vendorId As ImGearSpotColorVendorID
Dim value() As ImGearSpotColorVendorID

value = ImGearColorBooks.GetSynonyms(vendorId)
public static ImGearSpotColorVendorID[] GetSynonyms(
   ImGearSpotColorVendorID vendorId
)
public: static ImGearSpotColorVendorID[]* GetSynonyms(
   ImGearSpotColorVendorID vendorId
)
public:
static array<ImGearSpotColorVendorID>^ GetSynonyms(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID.

Return Value

ImGearSpotColorVendorID array.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class
ImGearSpotColorVendorID Enumeration


Initialize Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : Initialize Method
List of color book paths.
Loads the color book collection from the list of file paths.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize( _
   ByVal colorBookFiles() As String _
)
'Usage

Dim colorBookFiles() As String

ImGearColorBooks.Initialize(colorBookFiles)
public static void Initialize(
   string[] colorBookFiles
)
public: static void Initialize(
   string*[]* colorBookFiles
)
public:
static void Initialize(
   array<String^>^ colorBookFiles
)

Parameters

colorBookFiles
List of color book paths.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


Remove Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : Remove Method
Vendor ID.
Removes color book for the specified vendor ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Remove( _
   ByVal vendorId As ImGearSpotColorVendorID _
)
'Usage

Dim vendorId As ImGearSpotColorVendorID

ImGearColorBooks.Remove(vendorId)
public static void Remove(
   ImGearSpotColorVendorID vendorId
)
public: static void Remove(
   ImGearSpotColorVendorID vendorId
)
public:
static void Remove(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class
ImGearSpotColorVendorID Enumeration


RemoveAt Method (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : RemoveAt Method
Color book index.
Removes color book with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim index As Integer

ImGearColorBooks.RemoveAt(index)
public static void RemoveAt(
   int index
)
public: static void RemoveAt(
   int index
)
public:
static void RemoveAt(
   int index
)

Parameters

index
Color book index.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members
ImGearColorBook Class


%%PageItemTitle%% $$Properties$$

ImGearColorBooks Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorBooks Class

For a list of all members of this type, see ImGearColorBooks members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of color books in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

ImGearColorBooks Class
ImageGear.Core Namespace


Count Property (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : Count Property
Gets the number of color books in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearColorBooks
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


IsSynchronized Property (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearColorBooks
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


SyncRoot Property (ImGearColorBooks)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorBooks Class : SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearColorBooks
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

Object value.
See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

ImGearColorChannelInfo Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorChannelInfo Class
Spot channel class that uses regular color space like RGB, CMYK, etc.
Object Model
ImGearColorChannelInfo ClassImGearColorSpace StructureImGearPixel ClassImGearPixel ClassImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearColorChannelInfo
   Inherits ImGearExtraChannelInfo
'Usage

Dim instance As ImGearColorChannelInfo
public class ImGearColorChannelInfo : ImGearExtraChannelInfo
public __gc class ImGearColorChannelInfo : public ImGearExtraChannelInfo
public ref class ImGearColorChannelInfo : public ImGearExtraChannelInfo
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearColorChannelInfo
ImageGear.Core.ImGearMaskColorChannelInfo

See Also

Reference

ImGearColorChannelInfo Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorChannelInfo Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorChannelInfo Class

The following tables list the members exposed by ImGearColorChannelInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorChannelInfo Constructor | Initializes a new instance of the ImGearColorChannelInfo class by using color space and color value.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets color channel's color space.
Public Property | Opacity | Gets or sets opacity of the color channel.
Top
Public Methods
 | Name | Description
Public Method | GetColorValueCopy | Returns a copy of the color value.
Public Method | GetColorValueCopy16 | Returns a copy of the color value in 16-bit format.
Public Method | GetColorValueCopy8 | Returns a copy of the color value in 8-bit format.
Top
See Also

Reference

ImGearColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearColorChannelInfo Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorChannelInfo Class

For a list of all members of this type, see ImGearColorChannelInfo members.

See Also

Reference

ImGearColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : ImGearColorChannelInfo Constructor
Color space object.
Color value.
Initializes a new instance of the ImGearColorChannelInfo class by using color space and color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal colorValue As ImGearPixel _
)
'Usage

Dim colorSpace As ImGearColorSpace
Dim colorValue As ImGearPixel

Dim instance As New ImGearColorChannelInfo(colorSpace, colorValue)
public ImGearColorChannelInfo(
   ImGearColorSpace colorSpace,
   ImGearPixel colorValue
)
public: ImGearColorChannelInfo(
   ImGearColorSpace colorSpace,
   ImGearPixel* colorValue
)
public:
ImGearColorChannelInfo(
   ImGearColorSpace colorSpace,
   ImGearPixel^ colorValue
)

Parameters

colorSpace
Color space object.
colorValue
Color value.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members
ImGearColorSpace Structure
ImGearPixel Class


%%PageItemTitle%% $$Methods$$

ImGearColorChannelInfo Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorChannelInfo Class

For a list of all members of this type, see ImGearColorChannelInfo members.

Public Methods
 | Name | Description
Public Method | GetColorValueCopy | Returns a copy of the color value.
Public Method | GetColorValueCopy16 | Returns a copy of the color value in 16-bit format.
Public Method | GetColorValueCopy8 | Returns a copy of the color value in 8-bit format.
Top
See Also

Reference

ImGearColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : ImGearColorChannelInfo Constructor
Overload List
Overload | Description
ImGearColorChannelInfo Constructor | Initializes a new instance of the ImGearColorChannelInfo class by using color space and color value.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


GetColorValueCopy Method (ImGearColorChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : GetColorValueCopy Method
Returns a copy of the color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorValueCopy() As ImGearPixel
'Usage

Dim instance As ImGearColorChannelInfo
Dim value As ImGearPixel

value = instance.GetColorValueCopy()
public ImGearPixel GetColorValueCopy()
public: ImGearPixel* GetColorValueCopy();
public:
ImGearPixel^ GetColorValueCopy();

Return Value

A new instance of ImGearPixel class.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members
ImGearPixel Class


GetColorValueCopy16 Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : GetColorValueCopy16 Method
Returns a copy of the color value in 16-bit format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorValueCopy16() As ImGearPixel
'Usage

Dim instance As ImGearColorChannelInfo
Dim value As ImGearPixel

value = instance.GetColorValueCopy16()
public ImGearPixel GetColorValueCopy16()
public: ImGearPixel* GetColorValueCopy16();
public:
ImGearPixel^ GetColorValueCopy16();

Return Value

ImGearPixel class value with 16 bits per channel.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members
ImGearPixel Class


GetColorValueCopy8 Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : GetColorValueCopy8 Method
Returns a copy of the color value in 8-bit format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorValueCopy8() As ImGearPixel
'Usage

Dim instance As ImGearColorChannelInfo
Dim value As ImGearPixel

value = instance.GetColorValueCopy8()
public ImGearPixel GetColorValueCopy8()
public: ImGearPixel* GetColorValueCopy8();
public:
ImGearPixel^ GetColorValueCopy8();

Return Value

ImGearPixel class object with 8 bits per channel.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members
ImGearPixel Class


%%PageItemTitle%% $$Properties$$

ImGearColorChannelInfo Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorChannelInfo Class

For a list of all members of this type, see ImGearColorChannelInfo members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets color channel's color space.
Public Property | Opacity | Gets or sets opacity of the color channel.
Top
See Also

Reference

ImGearColorChannelInfo Class
ImageGear.Core Namespace


ColorSpace Property (ImGearColorChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : ColorSpace Property
Gets color channel's color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearColorChannelInfo
Dim value As ImGearColorSpace

value = instance.ColorSpace
public ImGearColorSpace ColorSpace {get;}
public: __property ImGearColorSpace get_ColorSpace();
public:
property ImGearColorSpace ColorSpace {
   ImGearColorSpace get();
}

Property Value

ImGearColorSpace structure.
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members
ImGearColorSpace Structure


Opacity Property (ImGearColorChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorChannelInfo Class : Opacity Property
Gets or sets opacity of the color channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearColorChannelInfo
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value in range [0...100].
See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

ImGearColorProfile Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfile Class
Represents a color profile.
Object Model
ImGearColorProfile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearColorProfile
'Usage

Dim instance As ImGearColorProfile
public sealed class ImGearColorProfile
public __gc __sealed class ImGearColorProfile
public ref class ImGearColorProfile sealed
Remarks
For more information about working with color profile, see "Working with Color Profiles" article.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearColorProfile

See Also

Reference

ImGearColorProfile Members
ImageGear.Core Namespace
ImGearColorProfileManager Class


%%PageItemTitle%% $$Members$$

ImGearColorProfile Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfile Class

The following tables list the members exposed by ImGearColorProfile.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorProfile Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the color space of the color profile.
Public Property | ProfileData | Gets the color profile data.
Public Property | RenderingIntent | Gets the rendering intent type associated with the color profile.
Top
See Also

Reference

ImGearColorProfile Class
ImageGear.Core Namespace
ImGearColorProfileManager Class


%%PageItemTitle%%

ImGearColorProfile Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class : ImGearColorProfile Constructor
Overload List
Overload | Description
ImGearColorProfile Constructor(Byte[]) | Initializes a new instance of the ImGearColorProfile class.
ImGearColorProfile Constructor(Stream) | Initializes a new instance of the ImGearColorProfile class.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


%%PageItemTitle%%

ImGearColorProfile Constructor(Byte[])

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class > ImGearColorProfile Constructor : ImGearColorProfile Constructor(Byte[])
Profile data to read.
Initializes a new instance of the ImGearColorProfile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal profileStore() As Byte _
)
'Usage

Dim profileStore() As Byte

Dim instance As New ImGearColorProfile(profileStore)
public ImGearColorProfile(
   byte[] profileStore
)
public: ImGearColorProfile(
   byte[]* profileStore
)
public:
ImGearColorProfile(
   array<byte>^ profileStore
)

Parameters

profileStore
Profile data to read.
Remarks
This constructor reads profile data from a byte array. Profile data must be in standard ICC color profile format.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
Overload List


%%PageItemTitle%%

ImGearColorProfile Constructor(Stream)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class > ImGearColorProfile Constructor : ImGearColorProfile Constructor(Stream)
Profile data.
Initializes a new instance of the ImGearColorProfile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal profileStore As Stream _
)
'Usage

Dim profileStore As Stream

Dim instance As New ImGearColorProfile(profileStore)
public ImGearColorProfile(
   Stream profileStore
)
public: ImGearColorProfile(
   Stream* profileStore
)
public:
ImGearColorProfile(
   Stream^ profileStore
)

Parameters

profileStore
Profile data.
Remarks
This constructor reads profile data from a stream. Profile data must be in standard ICC color profile format.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearColorProfile Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfile Class

For a list of all members of this type, see ImGearColorProfile members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the color space of the color profile.
Public Property | ProfileData | Gets the color profile data.
Public Property | RenderingIntent | Gets the rendering intent type associated with the color profile.
Top
See Also

Reference

ImGearColorProfile Class
ImageGear.Core Namespace
ImGearColorProfileManager Class


ColorSpace Property (ImGearColorProfile)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class : ColorSpace Property
Gets the color space of the color profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ImGearColorSpaceIDs
'Usage

Dim instance As ImGearColorProfile
Dim value As ImGearColorSpaceIDs

value = instance.ColorSpace
public ImGearColorSpaceIDs ColorSpace {get;}
public: __property ImGearColorSpaceIDs get_ColorSpace();
public:
property ImGearColorSpaceIDs ColorSpace {
   ImGearColorSpaceIDs get();
}

Property Value

ImGearColorSpaceIDs enumeration value.
Remarks
Returns color space of the color profile, typically RGB or CMYK.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
ImGearColorSpaceIDs Enumeration


ProfileData Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class : ProfileData Property
Gets the color profile data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ProfileData As Byte()
'Usage

Dim instance As ImGearColorProfile
Dim value() As Byte

value = instance.ProfileData
public byte[] ProfileData {get;}
public: __property byte[]* get_ProfileData();
public:
property array<byte>^ ProfileData {
   array<byte>^ get();
}

Property Value

Array of bytes.
Remarks
Provides read-only access to color profile data. Color profiles are not updated through this property; create a new ImGearColorProfile class object instead.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


RenderingIntent Property (ImGearColorProfile)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfile Class : RenderingIntent Property
Gets the rendering intent type associated with the color profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RenderingIntent As ImGearRenderingIntents
'Usage

Dim instance As ImGearColorProfile
Dim value As ImGearRenderingIntents

value = instance.RenderingIntent
public ImGearRenderingIntents RenderingIntent {get;}
public: __property ImGearRenderingIntents get_RenderingIntent();
public:
property ImGearRenderingIntents RenderingIntent {
   ImGearRenderingIntents get();
}

Property Value

ImGearRenderingIntents enumeration value.
Remarks
Rendering intent controls how color matching is performed during color space conversion.
See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
ImGearRenderingIntents Enumeration


%%PageItemTitle%%

ImGearColorProfileManager Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfileManager Class
Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.
Object Model
ImGearColorProfileManager ClassImGearColorProfile ClassImGearColorProfile ClassImGearColorProfile ClassImGearColorProfile ClassImGearColorProfile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearColorProfileManager
'Usage

Dim instance As ImGearColorProfileManager
public sealed class ImGearColorProfileManager
public __gc __sealed class ImGearColorProfileManager
public ref class ImGearColorProfileManager sealed
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearColorProfileManager

See Also

Reference

ImGearColorProfileManager Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorProfileManager Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfileManager Class

The following tables list the members exposed by ImGearColorProfileManager.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | CmykProfile | Gets or sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled.
static (Shared in Visual Basic) | EnableProfiles | Gets or sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled.
static (Shared in Visual Basic) | GrayProfile | Gets or sets a color profile for Grayscale color space.
static (Shared in Visual Basic) | LabProfile | Gets or sets a color profile for Lab color space.
static (Shared in Visual Basic) | RenderingIntent | Gets or sets rendering intent to use for implicit color space conversions when global profiles are enabled.
static (Shared in Visual Basic) | RgbProfile | Gets or sets global RGB color profile to use for implicit color space conversions when global profiles are enabled.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AssignProfile | Associates a given instance of a color profile with the specified color space.
static (Shared in Visual Basic) | GetProfile | Returns an instance of a color profile associated with the given color space.
Top
See Also

Reference

ImGearColorProfileManager Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearColorProfileManager Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfileManager Class

For a list of all members of this type, see ImGearColorProfileManager members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AssignProfile | Associates a given instance of a color profile with the specified color space.
static (Shared in Visual Basic) | GetProfile | Returns an instance of a color profile associated with the given color space.
Top
See Also

Reference

ImGearColorProfileManager Class
ImageGear.Core Namespace


AssignProfile Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : AssignProfile Method
Color space.
Color profile.
Associates a given instance of a color profile with the specified color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub AssignProfile( _
   ByVal colorSpace As ImGearColorSpaceIDs, _
   ByVal colorProfile As ImGearColorProfile _
)
'Usage

Dim colorSpace As ImGearColorSpaceIDs
Dim colorProfile As ImGearColorProfile

ImGearColorProfileManager.AssignProfile(colorSpace, colorProfile)
public static void AssignProfile(
   ImGearColorSpaceIDs colorSpace,
   ImGearColorProfile colorProfile
)
public: static void AssignProfile(
   ImGearColorSpaceIDs colorSpace,
   ImGearColorProfile* colorProfile
)
public:
static void AssignProfile(
   ImGearColorSpaceIDs colorSpace,
   ImGearColorProfile^ colorProfile
)

Parameters

colorSpace
Color space.
colorProfile
Color profile.
Remarks
Represents an alternative way of assigning global profiles with color spaces. In particular, to assign a global profile with a gray color space, either GrayProfile property or AssignProfile(ImGearColorSpaceIDs.Gy)call could be used.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorProfile Class
ImGearColorSpaceIDs Enumeration


GetProfile Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : GetProfile Method
Color space.
Returns an instance of a color profile associated with the given color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetProfile( _
   ByVal colorSpace As ImGearColorSpaceIDs _
) As ImGearColorProfile
'Usage

Dim colorSpace As ImGearColorSpaceIDs
Dim value As ImGearColorProfile

value = ImGearColorProfileManager.GetProfile(colorSpace)
public static ImGearColorProfile GetProfile(
   ImGearColorSpaceIDs colorSpace
)
public: static ImGearColorProfile* GetProfile(
   ImGearColorSpaceIDs colorSpace
)
public:
static ImGearColorProfile^ GetProfile(
   ImGearColorSpaceIDs colorSpace
)

Parameters

colorSpace
Color space.

Return Value

ImGearColorProfile class object.
Remarks
Represents an alternative way of obtaining profiles associated with color spaces. In particular, the profile associated with the gray color space could be obtained using GrayProfile property or calling GetProfile method with .Gy parameter.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorSpaceIDs Enumeration
ImGearColorProfile Class
ImGearColorSpaceIDs Enumeration


%%PageItemTitle%% $$Properties$$

ImGearColorProfileManager Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorProfileManager Class

For a list of all members of this type, see ImGearColorProfileManager members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | CmykProfile | Gets or sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled.
static (Shared in Visual Basic) | EnableProfiles | Gets or sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled.
static (Shared in Visual Basic) | GrayProfile | Gets or sets a color profile for Grayscale color space.
static (Shared in Visual Basic) | LabProfile | Gets or sets a color profile for Lab color space.
static (Shared in Visual Basic) | RenderingIntent | Gets or sets rendering intent to use for implicit color space conversions when global profiles are enabled.
static (Shared in Visual Basic) | RgbProfile | Gets or sets global RGB color profile to use for implicit color space conversions when global profiles are enabled.
Top
See Also

Reference

ImGearColorProfileManager Class
ImageGear.Core Namespace


CmykProfile Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : CmykProfile Property
Gets or sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property CmykProfile As ImGearColorProfile
'Usage

Dim value As ImGearColorProfile

ImGearColorProfileManager.CmykProfile = value

value = ImGearColorProfileManager.CmykProfile
public static ImGearColorProfile CmykProfile {get; set;}
public: __property static ImGearColorProfile* get_CmykProfile();
public: __property static void set_CmykProfile(
   ImGearColorProfile* value
);
public:
static property ImGearColorProfile^ CmykProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile class object.
Remarks
The default value is null.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorProfile Class


EnableProfiles Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : EnableProfiles Property
Gets or sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property EnableProfiles As Boolean
'Usage

Dim value As Boolean

ImGearColorProfileManager.EnableProfiles = value

value = ImGearColorProfileManager.EnableProfiles
public static bool EnableProfiles {get; set;}
public: __property static bool get_EnableProfiles();
public: __property static void set_EnableProfiles(
   bool value
);
public:
static property bool EnableProfiles {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If this property is enabled, global color profiles (specified by other properties of this object such as CmykProfile property and RgbProfile property) and local color profiles (ImGearRasterPage.ColorProfile property) will be used to perform color space conversions. The default value is false.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


GrayProfile Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : GrayProfile Property
Gets or sets a color profile for Grayscale color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property GrayProfile As ImGearColorProfile
'Usage

Dim value As ImGearColorProfile

ImGearColorProfileManager.GrayProfile = value

value = ImGearColorProfileManager.GrayProfile
public static ImGearColorProfile GrayProfile {get; set;}
public: __property static ImGearColorProfile* get_GrayProfile();
public: __property static void set_GrayProfile(
   ImGearColorProfile* value
);
public:
static property ImGearColorProfile^ GrayProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile class object.
Remarks
The default value is null.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorProfile Class


LabProfile Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : LabProfile Property
Gets or sets a color profile for Lab color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property LabProfile As ImGearColorProfile
'Usage

Dim value As ImGearColorProfile

ImGearColorProfileManager.LabProfile = value

value = ImGearColorProfileManager.LabProfile
public static ImGearColorProfile LabProfile {get; set;}
public: __property static ImGearColorProfile* get_LabProfile();
public: __property static void set_LabProfile(
   ImGearColorProfile* value
);
public:
static property ImGearColorProfile^ LabProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile class object.
Remarks
The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorProfile Class


RenderingIntent Property (ImGearColorProfileManager)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : RenderingIntent Property
Gets or sets rendering intent to use for implicit color space conversions when global profiles are enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property RenderingIntent As ImGearRenderingIntents
'Usage

Dim value As ImGearRenderingIntents

ImGearColorProfileManager.RenderingIntent = value

value = ImGearColorProfileManager.RenderingIntent
public static ImGearRenderingIntents RenderingIntent {get; set;}
public: __property static ImGearRenderingIntents get_RenderingIntent();
public: __property static void set_RenderingIntent(
   ImGearRenderingIntents value
);
public:
static property ImGearRenderingIntents RenderingIntent {
   ImGearRenderingIntents get();
   void set (    ImGearRenderingIntents value);
}

Property Value

ImGearRenderingIntents enumeration value.
Remarks
Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearRenderingIntents Enumeration


RgbProfile Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorProfileManager Class : RgbProfile Property
Gets or sets global RGB color profile to use for implicit color space conversions when global profiles are enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property RgbProfile As ImGearColorProfile
'Usage

Dim value As ImGearColorProfile

ImGearColorProfileManager.RgbProfile = value

value = ImGearColorProfileManager.RgbProfile
public static ImGearColorProfile RgbProfile {get; set;}
public: __property static ImGearColorProfile* get_RgbProfile();
public: __property static void set_RgbProfile(
   ImGearColorProfile* value
);
public:
static property ImGearColorProfile^ RgbProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile class object.
Remarks
The default value is null.
See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members
ImGearColorProfile Class


%%PageItemTitle%%

ImGearDIB Class
Members Example

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDIB Class
Encapsulates an image, which consists of the pixel data and its attributes.
Object Model
ImGearDIB ClassImGearDIB ClassImGearColorSpace StructureImGearExtraChannelInfo ClassImGearPixelArray ClassImGearPixelArray ClassImGearArrayRef StructureImGearPixelArray ClassImGearPixel ClassImGearArrayRef StructureImGearPixelArray ClassIImGearResolution InterfaceImGearRGBQuad Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearDIB
'Usage

Dim instance As ImGearDIB
public abstract class ImGearDIB
public __gc abstract class ImGearDIB
public ref class ImGearDIB abstract
Remarks
This class does not have public constructors. Instances of ImGearDIB exist only as a member objects of ImGearPage or ImGearROIMask classes.
Example
  • C#
ImGearPage igPage;
// Load an image into a ImGearPage object
using (FileStream localFile = new FileStream(localFilePath, FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Create a black pixel appropriate to this image.
ImGearPixel igPixel = new ImGearPixel(igPage.DIB.ChannelCount,igPage.DIB.BitsPerChannel);
for (int channel = 0; channel < igPixel.ChannelCount; ++channel)
    igPixel[channel] = 0;
// Change a diagonal line across image to this igPixel.
for (int row = 0; row < igPage.DIB.Height && row < igPage.DIB.Width; ++row)
    igPage.DIB.UpdatePixelFrom(row,row,igPixel);
  • Visual Basic
Dim igPage As ImGearPage
'Load an image into a ImGearPage object
Dim localFile As FileStream = New FileStream(localFilePath, FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Create a black pixel appropiate to this image.
Dim igPixel As ImGearPixel = New ImGearPixel(igPage.DIB.ChannelCount, igPage.DIB.BitsPerChannel)
For channel As Integer = 0 To (igPixel.ChannelCount - 1)
    igPixel(channel) = 0
Next
'Change a diagonal line across image to this igPixel.
Dim shorter As Integer
If (igPage.DIB.Width < igPage.DIB.Height) Then
    shorter = igPage.DIB.Width - 1
Else
    shorter = igPage.DIB.Height - 1
End If
For row As Integer = 0 To shorter
    igPage.DIB.UpdatePixelFrom(row, row, igPixel)
Next
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDIB

See Also

Reference

ImGearDIB Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDIB Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDIB Class

The following tables list the members exposed by ImGearDIB.

Protected Fields
 | Name | Description
Protected Field | m_BitDepth | Total quantity of bits used to represent a single pixel.
Protected Field | m_BitsPerChannel | Allocated (actual) size of store for each channel in bits.
Protected Field | m_ChannelDepths | Depth of image channels.
Protected Field | m_ColorSpace | Color space attribute.
Protected Field | m_ExtraChannelInfo | Information on image Extra channels.
Protected Field | m_Height | Image heigth in pixels.
Protected Field | m_ImageResolution | Image resolution information.
Protected Field | m_Palette | Image palette, for images that have Indexed colorspace.
Protected Field | m_Signed | Specifies whether the image is signed.
Protected Field | m_Width | Image width in pixels.
Top
Public Properties
 | Name | Description
Public Property | BitDepth | Gets total quantity of bits used to store a single pixel.
Public Property | BitsPerChannel | Gets allocated (actual) size of store for each channel in bits.
Public Property | ChannelCount | Gets total quantity of channels in image.
Public Property | ChannelDepths | Gets the bit depth of each color channel in the image.
Public Property | ColorSpace | Gets color Space of current image.
Public Property | ExtraChannelInfo | Gets or sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
Public Property | Height | Gets height of image in pixels.
Public Property | ImageResolution | Gets or sets image resolution.
Public Property | Palette | Gets or sets image palette, for images that have Indexed colorspace.
Public Property | Signed | Gets or sets a value indicating whether image is signed or not.
Public Property | Width | Gets width of image in pixels.
Top
Public Methods
 | Name | Description
Public Method | AllocateImage | Allocates pixel data based on the DIB header information.
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | GetAreaCopy | Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
Public Method | GetColumnCopy | Returns an array of pixels that are exact copies of pixels located in requested column part.
Public Method | GetImage | Returns a reference to raw image store. Should be used to gain direct access to image pixels.
Public Method | GetLineCopy | Returns an array of pixels that are exact copies of pixels located in the requested area of image.
Public Method | GetPixelCopy | Returns exact copy of requested pixel.
Public Method | GetRaster | Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
Public Method | GetRowCopy | Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.
Public Method | IsEmpty | Tells whether store for the pixels has been allocated.
Public Method | UpdateAreaFrom | Updates the pixels of the specified rectangular area.
Public Method | UpdateColumnFrom | Updates part of column with new pixels.
Public Method | UpdateLineFrom | Exchanges the pixels of the specified line with new pixels.
Public Method | UpdatePixelFrom | Updates single pixel with new value.
Public Method | UpdateRowFrom | Updates part of row with new pixels.
Top
Protected Methods
 | Name | Description
Protected Method | CopyImageTo | Copies internal image data to incoming dib.
Top
See Also

Reference

ImGearDIB Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearDIB Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDIB Class

For a list of all members of this type, see ImGearDIB members.

Public Methods
 | Name | Description
Public Method | AllocateImage | Allocates pixel data based on the DIB header information.
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | GetAreaCopy | Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
Public Method | GetColumnCopy | Returns an array of pixels that are exact copies of pixels located in requested column part.
Public Method | GetImage | Returns a reference to raw image store. Should be used to gain direct access to image pixels.
Public Method | GetLineCopy | Returns an array of pixels that are exact copies of pixels located in the requested area of image.
Public Method | GetPixelCopy | Returns exact copy of requested pixel.
Public Method | GetRaster | Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
Public Method | GetRowCopy | Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.
Public Method | IsEmpty | Tells whether store for the pixels has been allocated.
Public Method | UpdateAreaFrom | Updates the pixels of the specified rectangular area.
Public Method | UpdateColumnFrom | Updates part of column with new pixels.
Public Method | UpdateLineFrom | Exchanges the pixels of the specified line with new pixels.
Public Method | UpdatePixelFrom | Updates single pixel with new value.
Public Method | UpdateRowFrom | Updates part of row with new pixels.
Top
Protected Methods
 | Name | Description
Protected Method | CopyImageTo | Copies internal image data to incoming dib.
Top
See Also

Reference

ImGearDIB Class
ImageGear.Core Namespace


AllocateImage Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : AllocateImage Method
Allocates pixel data based on the DIB header information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub AllocateImage()
'Usage

Dim instance As ImGearDIB

instance.AllocateImage()
public abstract void AllocateImage()
public: abstract void AllocateImage();
public:
abstract void AllocateImage();
Remarks
Allocates store for pixel data based on the DIB header information. Previous store will be lost if any allocation was made before.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


Clone Method (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearDIB
'Usage

Dim instance As ImGearDIB
Dim value As ImGearDIB

value = instance.Clone()
public ImGearDIB Clone()
public: ImGearDIB* Clone();
public:
ImGearDIB^ Clone();

Return Value

Non-null instance of ImGearDIB class.
Remarks
In contrast to MemberwiseClone, this member provides deep copy of object (i.e., all internal objects are cloned as well).
See Also

Reference

ImGearDIB Class
ImGearDIB Members


CopyImageTo Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : CopyImageTo Method
Dib for copy to.
Copies internal image data to incoming dib.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub CopyImageTo( _
   ByVal dib As ImGearDIB _
)
'Usage

Dim instance As ImGearDIB
Dim dib As ImGearDIB

instance.CopyImageTo(dib)
protected abstract void CopyImageTo(
   ImGearDIB dib
)
protected: abstract void CopyImageTo(
   ImGearDIB* dib
)
protected:
abstract void CopyImageTo(
   ImGearDIB^ dib
)

Parameters

dib
Dib for copy to.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


GetAreaCopy Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetAreaCopy Method
X coordinate of top-left point of rectangular area.
Y coordinate of top-left point of rectangular area.
X coordinate of bottom-right point of rectangular area.
Y coordinate of bottom-right point of rectangular area.
Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetAreaCopy( _
   ByVal startColumn As Integer, _
   ByVal startRow As Integer, _
   ByVal endColumn As Integer, _
   ByVal endRow As Integer _
) As ImGearPixelArray
'Usage

Dim instance As ImGearDIB
Dim startColumn As Integer
Dim startRow As Integer
Dim endColumn As Integer
Dim endRow As Integer
Dim value As ImGearPixelArray

value = instance.GetAreaCopy(startColumn, startRow, endColumn, endRow)
public abstract ImGearPixelArray GetAreaCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)
public: abstract ImGearPixelArray* GetAreaCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)
public:
abstract ImGearPixelArray^ GetAreaCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)

Parameters

startColumn
X coordinate of top-left point of rectangular area.
startRow
Y coordinate of top-left point of rectangular area.
endColumn
X coordinate of bottom-right point of rectangular area.
endRow
Y coordinate of bottom-right point of rectangular area.

Return Value

ImGearPixelArray class object.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


GetColumnCopy Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetColumnCopy Method
Number of column in image.
Y offset in requested column.
Quantity of pixels to be retrieved.
Returns an array of pixels that are exact copies of pixels located in requested column part.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetColumnCopy( _
   ByVal column As Integer, _
   ByVal row As Integer, _
   ByVal pixelsQty As Integer _
) As ImGearPixelArray
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim pixelsQty As Integer
Dim value As ImGearPixelArray

value = instance.GetColumnCopy(column, row, pixelsQty)
public abstract ImGearPixelArray GetColumnCopy(
   int column,
   int row,
   int pixelsQty
)
public: abstract ImGearPixelArray* GetColumnCopy(
   int column,
   int row,
   int pixelsQty
)
public:
abstract ImGearPixelArray^ GetColumnCopy(
   int column,
   int row,
   int pixelsQty
)

Parameters

column
Number of column in image.
row
Y offset in requested column.
pixelsQty
Quantity of pixels to be retrieved.

Return Value

ImGearPixelArray class instance.
Remarks
Throws exception if specified points are outside image bounds.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


GetImage Method (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetImage Method
Returns a reference to raw image store. Should be used to gain direct access to image pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetImage() As ImGearArrayRef
'Usage

Dim instance As ImGearDIB
Dim value As ImGearArrayRef

value = instance.GetImage()
public abstract ImGearArrayRef GetImage()
public: abstract ImGearArrayRef GetImage();
public:
abstract ImGearArrayRef GetImage();

Return Value

ImGearArrayRef structure instance.
Remarks
May be used to obtain direct access to the entire image store.

Structure of image store depends on channels structure and may differ for different DIBs.

Rasters in ImageGear for .NET pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for .NET can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

Note that the +31 and & ~31 indicate DWORD alignment.

See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearArrayRef Structure


GetLineCopy Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetLineCopy Method
X dimension of line start point.
Y dimension of line start point.
X dimension of line end point.
Y dimension of line end point.
Returns an array of pixels that are exact copies of pixels located in the requested area of image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetLineCopy( _
   ByVal startColumn As Integer, _
   ByVal startRow As Integer, _
   ByVal endColumn As Integer, _
   ByVal endRow As Integer _
) As ImGearPixelArray
'Usage

Dim instance As ImGearDIB
Dim startColumn As Integer
Dim startRow As Integer
Dim endColumn As Integer
Dim endRow As Integer
Dim value As ImGearPixelArray

value = instance.GetLineCopy(startColumn, startRow, endColumn, endRow)
public abstract ImGearPixelArray GetLineCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)
public: abstract ImGearPixelArray* GetLineCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)
public:
abstract ImGearPixelArray^ GetLineCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)

Parameters

startColumn
X dimension of line start point.
startRow
Y dimension of line start point.
endColumn
X dimension of line end point.
endRow
Y dimension of line end point.

Return Value

ImGearPixelArray class instance.
Remarks
Incoming coordinates must not exceed the image area bounds. Otherwise, an exception will be thrown.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


GetPixelCopy Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetPixelCopy Method
X coordinate of requested pixel.
Y coordinate of requested pixel.
Returns exact copy of requested pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetPixelCopy( _
   ByVal column As Integer, _
   ByVal row As Integer _
) As ImGearPixel
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim value As ImGearPixel

value = instance.GetPixelCopy(column, row)
public abstract ImGearPixel GetPixelCopy(
   int column,
   int row
)
public: abstract ImGearPixel* GetPixelCopy(
   int column,
   int row
)
public:
abstract ImGearPixel^ GetPixelCopy(
   int column,
   int row
)

Parameters

column
X coordinate of requested pixel.
row
Y coordinate of requested pixel.

Return Value

ImGearPixel class instance.
Remarks
Throws an exception if the coordinates of the requested pixel are outside of the image bounds.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixel Class


GetRaster Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetRaster Method
Number of requested row.
Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetRaster( _
   ByVal row As Integer _
) As ImGearArrayRef
'Usage

Dim instance As ImGearDIB
Dim row As Integer
Dim value As ImGearArrayRef

value = instance.GetRaster(row)
public abstract ImGearArrayRef GetRaster(
   int row
)
public: abstract ImGearArrayRef GetRaster(
   int row
)
public:
abstract ImGearArrayRef GetRaster(
   int row
)

Parameters

row
Number of requested row.

Return Value

ImGearArrayRef structure instance that refers to the raster raw store.
Remarks
May be used to obtain direct access to the pixels in the raster.

In ImageGear for .NET, all rasters are kept and indexed in the normal form: the first raster is the top raster, the last raster is the bottom raster. This differs from BMP and older ImageGear versions, where rasters are stored in reverse mode: from bottom to top.

Rasters in ImageGear for .NET pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for .NET can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

The +31 and & ~31 indicate DWORD alignment. The raster size is in terms of channel values. To calculate the raster size in terms of bytes, divide by 8 instead of BitsPerChannel.

See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearArrayRef Structure


GetRowCopy Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : GetRowCopy Method
X offset in requested row.
Number of row in image.
Quantity of pixels to be retrieved.
Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function GetRowCopy( _
   ByVal column As Integer, _
   ByVal row As Integer, _
   ByVal pixelsQty As Integer _
) As ImGearPixelArray
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim pixelsQty As Integer
Dim value As ImGearPixelArray

value = instance.GetRowCopy(column, row, pixelsQty)
public abstract ImGearPixelArray GetRowCopy(
   int column,
   int row,
   int pixelsQty
)
public: abstract ImGearPixelArray* GetRowCopy(
   int column,
   int row,
   int pixelsQty
)
public:
abstract ImGearPixelArray^ GetRowCopy(
   int column,
   int row,
   int pixelsQty
)

Parameters

column
X offset in requested row.
row
Number of row in image.
pixelsQty
Quantity of pixels to be retrieved.

Return Value

Non-null reference to ImGearPixelArray class.
Remarks
Throws an exception if the specified points are outside of the image area.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


IsEmpty Method (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : IsEmpty Method
Tells whether store for the pixels has been allocated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function IsEmpty() As Boolean
'Usage

Dim instance As ImGearDIB
Dim value As Boolean

value = instance.IsEmpty()
public abstract bool IsEmpty()
public: abstract bool IsEmpty();
public:
abstract bool IsEmpty();

Return Value

Boolean value.
Remarks
Pixel store can be allocated during DIB (page) creation or by AllocateImage method.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
AllocateImage Method


UpdateAreaFrom Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : UpdateAreaFrom Method
X coordinate of top-left point of area to be updated.
Y coordinate of top-left point of area to be updated.
X coordinate of bottom-right point of area to be updated.
Y coordinate of bottom-right point of area to be updated.
New values for the pixels being updated.
Updates the pixels of the specified rectangular area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub UpdateAreaFrom( _
   ByVal startColumn As Integer, _
   ByVal startRow As Integer, _
   ByVal endColumn As Integer, _
   ByVal endRow As Integer, _
   ByVal pixels As ImGearPixelArray _
)
'Usage

Dim instance As ImGearDIB
Dim startColumn As Integer
Dim startRow As Integer
Dim endColumn As Integer
Dim endRow As Integer
Dim pixels As ImGearPixelArray

instance.UpdateAreaFrom(startColumn, startRow, endColumn, endRow, pixels)
public abstract void UpdateAreaFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray pixels
)
public: abstract void UpdateAreaFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray* pixels
)
public:
abstract void UpdateAreaFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray^ pixels
)

Parameters

startColumn
X coordinate of top-left point of area to be updated.
startRow
Y coordinate of top-left point of area to be updated.
endColumn
X coordinate of bottom-right point of area to be updated.
endRow
Y coordinate of bottom-right point of area to be updated.
pixels
New values for the pixels being updated.
Example
  • C#
ImGearPage igPage;
// Load an image into a ImGearPage object
using (FileStream localFile = new FileStream(localFilePath, FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Get the upper left square of the image to perform a transpose on.
int transposeSize;
if ( igPage.DIB.Height > igPage.DIB.Width)
    transposeSize = igPage.DIB.Width / 2;
else
    transposeSize = igPage.DIB.Height / 2;
ImGearPixelArray igPixelArray = igPage.DIB.GetAreaCopy(0, 0, transposeSize - 1, transposeSize - 1);
// Transpose the pixels in igPixelArray
int channelData;
int transposePosition1, transposePosition2;
for (int row = 1; row < transposeSize; ++ row)
    for (int column = 0; column < row; ++column)
    {
        transposePosition1 = (row * transposeSize) + column;
        transposePosition2 = (column * transposeSize) + row;
        for (int channel = 0; channel < igPixelArray.ChannelCount; channel++)
        {
            channelData = igPixelArray[transposePosition1,channel];
            igPixelArray[transposePosition1, channel] = igPixelArray[transposePosition2,channel];
            igPixelArray[transposePosition2, channel] = channelData;
        }
    }
// Update the original image with the transposed array
igPage.DIB.UpdateAreaFrom(0, 0, transposeSize - 1, transposeSize - 1, igPixelArray);
  • Visual Basic
Dim igPage As ImGearPage
'Load an image into a ImGearPage object
Dim localFile As FileStream = New FileStream(localFilePath, FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Get the upper left square of the image to perform a transpose on.
Dim transposeSize As Integer
If (igPage.DIB.Height > igPage.DIB.Width) Then
    transposeSize = igPage.DIB.Width / 2
Else
    transposeSize = igPage.DIB.Height / 2
End If
Dim igPixelArray As ImGearPixelArray = igPage.DIB.GetAreaCopy(0, 0, transposeSize - 1, transposeSize - 1)
'Transpose the pixels in igPixelArray
Dim channelData, transposePosition1, transposePosition2 As Integer
For row As Integer = 1 To transposeSize - 1
    For column As Integer = 0 To row - 1
        transposePosition1 = (row * transposeSize) + column
        transposePosition2 = (column * transposeSize) + row
        For channel As Integer = 0 To igPixelArray.ChannelCount - 1
            channelData = igPixelArray(transposePosition1, channel)
            igPixelArray(transposePosition1, channel) = igPixelArray(transposePosition2, channel)
            igPixelArray(transposePosition2, channel) = channelData
        Next
    Next
Next
'Update the original image with the transposed array
igPage.DIB.UpdateAreaFrom(0, 0, transposeSize - 1, transposeSize - 1, igPixelArray)
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


UpdateColumnFrom Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : UpdateColumnFrom Method
Number of column to update.
Y offset in column.
New values for pixels being updated.
Updates part of column with new pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub UpdateColumnFrom( _
   ByVal column As Integer, _
   ByVal row As Integer, _
   ByVal pixels As ImGearPixelArray _
)
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim pixels As ImGearPixelArray

instance.UpdateColumnFrom(column, row, pixels)
public abstract void UpdateColumnFrom(
   int column,
   int row,
   ImGearPixelArray pixels
)
public: abstract void UpdateColumnFrom(
   int column,
   int row,
   ImGearPixelArray* pixels
)
public:
abstract void UpdateColumnFrom(
   int column,
   int row,
   ImGearPixelArray^ pixels
)

Parameters

column
Number of column to update.
row
Y offset in column.
pixels
New values for pixels being updated.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


UpdateLineFrom Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : UpdateLineFrom Method
X coordinate of line start.
Y coordinate of line start.
X coordinate of line end.
Y coordinate of line end.
New values for pixels being updated.
Exchanges the pixels of the specified line with new pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub UpdateLineFrom( _
   ByVal startColumn As Integer, _
   ByVal startRow As Integer, _
   ByVal endColumn As Integer, _
   ByVal endRow As Integer, _
   ByVal pixels As ImGearPixelArray _
)
'Usage

Dim instance As ImGearDIB
Dim startColumn As Integer
Dim startRow As Integer
Dim endColumn As Integer
Dim endRow As Integer
Dim pixels As ImGearPixelArray

instance.UpdateLineFrom(startColumn, startRow, endColumn, endRow, pixels)
public abstract void UpdateLineFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray pixels
)
public: abstract void UpdateLineFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray* pixels
)
public:
abstract void UpdateLineFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray^ pixels
)

Parameters

startColumn
X coordinate of line start.
startRow
Y coordinate of line start.
endColumn
X coordinate of line end.
endRow
Y coordinate of line end.
pixels
New values for pixels being updated.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


UpdatePixelFrom Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : UpdatePixelFrom Method
X coordinate of pixel.
Y coordinate of pixel.
New value for the pixel.
Updates single pixel with new value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub UpdatePixelFrom( _
   ByVal column As Integer, _
   ByVal row As Integer, _
   ByVal pixel As ImGearPixel _
)
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim pixel As ImGearPixel

instance.UpdatePixelFrom(column, row, pixel)
public abstract void UpdatePixelFrom(
   int column,
   int row,
   ImGearPixel pixel
)
public: abstract void UpdatePixelFrom(
   int column,
   int row,
   ImGearPixel* pixel
)
public:
abstract void UpdatePixelFrom(
   int column,
   int row,
   ImGearPixel^ pixel
)

Parameters

column
X coordinate of pixel.
row
Y coordinate of pixel.
pixel
New value for the pixel.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixel Class


UpdateRowFrom Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : UpdateRowFrom Method
X offset in row.
Number of row to be updated.
New values for the pixels being updated.
Updates part of row with new pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub UpdateRowFrom( _
   ByVal column As Integer, _
   ByVal row As Integer, _
   ByVal pixels As ImGearPixelArray _
)
'Usage

Dim instance As ImGearDIB
Dim column As Integer
Dim row As Integer
Dim pixels As ImGearPixelArray

instance.UpdateRowFrom(column, row, pixels)
public abstract void UpdateRowFrom(
   int column,
   int row,
   ImGearPixelArray pixels
)
public: abstract void UpdateRowFrom(
   int column,
   int row,
   ImGearPixelArray* pixels
)
public:
abstract void UpdateRowFrom(
   int column,
   int row,
   ImGearPixelArray^ pixels
)

Parameters

column
X offset in row.
row
Number of row to be updated.
pixels
New values for the pixels being updated.
Remarks
Updates the pixels of the specified row area.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearPixelArray Class


%%PageItemTitle%% $$Properties$$

ImGearDIB Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDIB Class

For a list of all members of this type, see ImGearDIB members.

Public Properties
 | Name | Description
Public Property | BitDepth | Gets total quantity of bits used to store a single pixel.
Public Property | BitsPerChannel | Gets allocated (actual) size of store for each channel in bits.
Public Property | ChannelCount | Gets total quantity of channels in image.
Public Property | ChannelDepths | Gets the bit depth of each color channel in the image.
Public Property | ColorSpace | Gets color Space of current image.
Public Property | ExtraChannelInfo | Gets or sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
Public Property | Height | Gets height of image in pixels.
Public Property | ImageResolution | Gets or sets image resolution.
Public Property | Palette | Gets or sets image palette, for images that have Indexed colorspace.
Public Property | Signed | Gets or sets a value indicating whether image is signed or not.
Public Property | Width | Gets width of image in pixels.
Top
See Also

Reference

ImGearDIB Class
ImageGear.Core Namespace


BitDepth Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : BitDepth Property
Gets total quantity of bits used to store a single pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitDepth As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.BitDepth
public int BitDepth {get;}
public: __property int get_BitDepth();
public:
property int BitDepth {
   int get();
}

Property Value

Positive value that represents size of a single pixel in bits.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


BitsPerChannel Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : BitsPerChannel Property
Gets allocated (actual) size of store for each channel in bits.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerChannel As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.BitsPerChannel
public int BitsPerChannel {get;}
public: __property int get_BitsPerChannel();
public:
property int BitsPerChannel {
   int get();
}

Property Value

Positive number that specifies the actual size of channel in bits.
Remarks

Returns allocated (actual) size of any image channel in bits. The values 8, 16 and 32 are used as a basis for the array allocation.

Value returned by this property is correct for uncompressed DIBs only. Compressed DIBs have a different channel structure. For these sorts of DIBs this property always returns 8, although this value has no real meaning.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


ChannelCount Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : ChannelCount Property
Gets total quantity of channels in image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelCount As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.ChannelCount
public int ChannelCount {get;}
public: __property int get_ChannelCount();
public:
property int ChannelCount {
   int get();
}

Property Value

Non-zero channels quantity.
Remarks
Returns the same value as ChannelDepth.Length.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


ChannelDepths Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : ChannelDepths Property
Gets the bit depth of each color channel in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelDepths As Integer()
'Usage

Dim instance As ImGearDIB
Dim value() As Integer

value = instance.ChannelDepths
public int[] ChannelDepths {get;}
public: __property int[]* get_ChannelDepths();
public:
property array<int>^ ChannelDepths {
   array<int>^ get();
}

Property Value

Integer array.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


ColorSpace Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : ColorSpace Property
Gets color Space of current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearDIB
Dim value As ImGearColorSpace

value = instance.ColorSpace
public ImGearColorSpace ColorSpace {get;}
public: __property ImGearColorSpace get_ColorSpace();
public:
property ImGearColorSpace ColorSpace {
   ImGearColorSpace get();
}

Property Value

ImGearColorSpace structure.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearColorSpace Structure


ExtraChannelInfo Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : ExtraChannelInfo Property
Gets or sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtraChannelInfo As ImGearExtraChannelInfo()
'Usage

Dim instance As ImGearDIB
Dim value() As ImGearExtraChannelInfo

instance.ExtraChannelInfo = value

value = instance.ExtraChannelInfo
public ImGearExtraChannelInfo[] ExtraChannelInfo {get; set;}
public: __property ImGearExtraChannelInfo*[]* get_ExtraChannelInfo();
public: __property void set_ExtraChannelInfo(
   ImGearExtraChannelInfo*[]* value
);
public:
property array<ImGearExtraChannelInfo^>^ ExtraChannelInfo {
   array<ImGearExtraChannelInfo^>^ get();
   void set (    array<ImGearExtraChannelInfo^>^ value);
}

Property Value

Array of ImGearExtraChannelInfo class objects.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearExtraChannelInfo Class


Height Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : Height Property
Gets height of image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


ImageResolution Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : ImageResolution Property
Gets or sets image resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageResolution As IImGearResolution
'Usage

Dim instance As ImGearDIB
Dim value As IImGearResolution

instance.ImageResolution = value

value = instance.ImageResolution
public IImGearResolution ImageResolution {get; set;}
public: __property IImGearResolution* get_ImageResolution();
public: __property void set_ImageResolution(
   IImGearResolution* value
);
public:
property IImGearResolution^ ImageResolution {
   IImGearResolution^ get();
   void set (    IImGearResolution^ value);
}

Property Value

ImGearResolution structure object.
See Also

Reference

ImGearDIB Class
ImGearDIB Members
IImGearResolution Interface


Palette Property
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : Palette Property
Gets or sets image palette, for images that have Indexed colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Palette As ImGearRGBQuad()
'Usage

Dim instance As ImGearDIB
Dim value() As ImGearRGBQuad

instance.Palette = value

value = instance.Palette
public ImGearRGBQuad[] Palette {get; set;}
public: __property ImGearRGBQuad[]* get_Palette();
public: __property void set_Palette(
   ImGearRGBQuad[]* value
);
public:
property array<ImGearRGBQuad>^ Palette {
   array<ImGearRGBQuad>^ get();
   void set (    array<ImGearRGBQuad>^ value);
}

Property Value

Array of ImGearRGBQuad structure objects or null.
Remarks
Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

Example
  • C#
ImGearPage igPage;
// Load an image into a ImGearPage object.
using (FileStream localFile = new FileStream(localFilePath, FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Build and apply palette if image is indexed.
if (igPage.DIB.ColorSpace.Value == ImGearColorSpaceIDs.I)
{
    // Create a simple palette of red colors
    ImGearRGBQuad[] igRGBQuad = new ImGearRGBQuad[256];
    for (int i = 0; i < 256; ++i)
        igRGBQuad[i].Red = (byte)i;
    // Assign the new Palette
    igPage.DIB.Palette = igRGBQuad;
}
  • Visual Basic
Dim igPage As ImGearPage
'Load an image into a ImGearPage object.
Dim localFile As FileStream = New FileStream(localFilePath, FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
' Build and apply palette if image is indexed.
If (igPage.DIB.ColorSpace.Value = ImGearColorSpaceIDs.I) Then
    'Create a simple palette of red colors
    Dim igRGBQuad(256) As ImGearRGBQuad
    For i As Integer = 0 To 255
        igRGBQuad(i).Red = i
    Next
    'Assign the new Palette
    igPage.DIB.Palette = igRGBQuad
End If
See Also

Reference

ImGearDIB Class
ImGearDIB Members
ImGearRGBQuad Structure


Signed Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : Signed Property
Gets or sets a value indicating whether image is signed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Signed As Boolean
'Usage

Dim instance As ImGearDIB
Dim value As Boolean

instance.Signed = value

value = instance.Signed
public bool Signed {get; set;}
public: __property bool get_Signed();
public: __property void set_Signed(
   bool value
);
public:
property bool Signed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


Width Property (ImGearDIB)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : Width Property
Gets width of image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%% $$Fields$$

ImGearDIB Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDIB Class

For a list of all members of this type, see ImGearDIB members.

Protected Fields
 | Name | Description
Protected Field | m_BitDepth | Total quantity of bits used to represent a single pixel.
Protected Field | m_BitsPerChannel | Allocated (actual) size of store for each channel in bits.
Protected Field | m_ChannelDepths | Depth of image channels.
Protected Field | m_ColorSpace | Color space attribute.
Protected Field | m_ExtraChannelInfo | Information on image Extra channels.
Protected Field | m_Height | Image heigth in pixels.
Protected Field | m_ImageResolution | Image resolution information.
Protected Field | m_Palette | Image palette, for images that have Indexed colorspace.
Protected Field | m_Signed | Specifies whether the image is signed.
Protected Field | m_Width | Image width in pixels.
Top
See Also

Reference

ImGearDIB Class
ImageGear.Core Namespace


m_BitDepth Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_BitDepth Field
Total quantity of bits used to represent a single pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_BitDepth As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.m_BitDepth

instance.m_BitDepth = value
protected int m_BitDepth
protected: int m_BitDepth
protected:
int m_BitDepth
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_BitsPerChannel Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_BitsPerChannel Field
Allocated (actual) size of store for each channel in bits.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_BitsPerChannel As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.m_BitsPerChannel

instance.m_BitsPerChannel = value
protected int m_BitsPerChannel
protected: int m_BitsPerChannel
protected:
int m_BitsPerChannel
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_ChannelDepths Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_ChannelDepths Field
Depth of image channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_ChannelDepths As Integer()
'Usage

Dim instance As ImGearDIB
Dim value() As Integer

value = instance.m_ChannelDepths

instance.m_ChannelDepths = value
protected int[] m_ChannelDepths
protected: int[]* m_ChannelDepths
protected:
array<int>^ m_ChannelDepths
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_ColorSpace Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_ColorSpace Field
Color space attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_ColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearDIB
Dim value As ImGearColorSpace

value = instance.m_ColorSpace

instance.m_ColorSpace = value
protected ImGearColorSpace m_ColorSpace
protected: ImGearColorSpace m_ColorSpace
protected:
ImGearColorSpace m_ColorSpace
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_ExtraChannelInfo Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_ExtraChannelInfo Field
Information on image Extra channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_ExtraChannelInfo As ImGearExtraChannelInfo()
'Usage

Dim instance As ImGearDIB
Dim value() As ImGearExtraChannelInfo

value = instance.m_ExtraChannelInfo

instance.m_ExtraChannelInfo = value
protected ImGearExtraChannelInfo[] m_ExtraChannelInfo
protected: ImGearExtraChannelInfo*[]* m_ExtraChannelInfo
protected:
array<ImGearExtraChannelInfo^>^ m_ExtraChannelInfo
Remarks
Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_Height Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_Height Field
Image heigth in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Height As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.m_Height

instance.m_Height = value
protected int m_Height
protected: int m_Height
protected:
int m_Height
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_ImageResolution Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_ImageResolution Field
Image resolution information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_ImageResolution As IImGearResolution
'Usage

Dim instance As ImGearDIB
Dim value As IImGearResolution

value = instance.m_ImageResolution

instance.m_ImageResolution = value
protected IImGearResolution m_ImageResolution
protected: IImGearResolution* m_ImageResolution
protected:
IImGearResolution^ m_ImageResolution
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_Palette Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_Palette Field
Image palette, for images that have Indexed colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Palette As ImGearRGBQuad()
'Usage

Dim instance As ImGearDIB
Dim value() As ImGearRGBQuad

value = instance.m_Palette

instance.m_Palette = value
protected ImGearRGBQuad[] m_Palette
protected: ImGearRGBQuad[]* m_Palette
protected:
array<ImGearRGBQuad>^ m_Palette
Remarks
Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_Signed Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_Signed Field
Specifies whether the image is signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Signed As Boolean
'Usage

Dim instance As ImGearDIB
Dim value As Boolean

value = instance.m_Signed

instance.m_Signed = value
protected bool m_Signed
protected: bool m_Signed
protected:
bool m_Signed
See Also

Reference

ImGearDIB Class
ImGearDIB Members


m_Width Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDIB Class : m_Width Field
Image width in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Width As Integer
'Usage

Dim instance As ImGearDIB
Dim value As Integer

value = instance.m_Width

instance.m_Width = value
protected int m_Width
protected: int m_Width
protected:
int m_Width
See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

ImGearDisplayChannel Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannel Class
Represents display attributes for individual channel.
Object Model
ImGearDisplayChannel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDisplayChannel
'Usage

Dim instance As ImGearDisplayChannel
public class ImGearDisplayChannel
public __gc class ImGearDisplayChannel
public ref class ImGearDisplayChannel
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDisplayChannel

See Also

Reference

ImGearDisplayChannel Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDisplayChannel Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannel Class

The following tables list the members exposed by ImGearDisplayChannel.

Public Constructors
 | Name | Description
Public Constructor | ImGearDisplayChannel Constructor | Initializes a new instance of the ImGearDisplayChannel class object.
Top
Public Properties
 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the display channel is visibile.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannel Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDisplayChannel Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannel Class : ImGearDisplayChannel Constructor
Initializes a new instance of the ImGearDisplayChannel class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDisplayChannel()
public ImGearDisplayChannel()
public: ImGearDisplayChannel();
public:
ImGearDisplayChannel();
See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%% $$Methods$$

ImGearDisplayChannel Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannel Class

For a list of all members of this type, see ImGearDisplayChannel members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannel Class
ImageGear.Core Namespace


OnPropertyChanged Method (ImGearDisplayChannel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannel Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearDisplayChannel
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%% $$Properties$$

ImGearDisplayChannel Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannel Class

For a list of all members of this type, see ImGearDisplayChannel members.

Public Properties
 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the display channel is visibile.
Top
See Also

Reference

ImGearDisplayChannel Class
ImageGear.Core Namespace


Visible Property (ImGearDisplayChannel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannel Class : Visible Property
Gets or sets a value indicating whether the display channel is visibile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As ImGearDisplayChannel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%% $$Events$$

ImGearDisplayChannel Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannel Class

For a list of all members of this type, see ImGearDisplayChannel members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannel Class
ImageGear.Core Namespace


PropertyChanged Event (ImGearDisplayChannel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannel Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearDisplayChannel
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

ImGearDisplayChannels Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannels Class
Represents a collection of ImGearDisplayChannel class objects.
Object Model
ImGearDisplayChannels ClassImGearDisplayChannel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearDisplayChannels
'Usage

Dim instance As ImGearDisplayChannels
[DefaultMember("Item")]
public class ImGearDisplayChannels
[DefaultMember("Item")]
public __gc class ImGearDisplayChannels
[DefaultMember("Item")]
public ref class ImGearDisplayChannels
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDisplayChannels

See Also

Reference

ImGearDisplayChannels Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDisplayChannels Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannels Class

The following tables list the members exposed by ImGearDisplayChannels.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of ImGearDisplayChannel class objects in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | Item | Gets the collection member with specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Public Methods
 | Name | Description
Public Method | CopyTo | Copies a range of elements to the specified array.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all ImGearDisplayChannel class objects in the collection.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannels Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearDisplayChannels Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannels Class

For a list of all members of this type, see ImGearDisplayChannels members.

Public Methods
 | Name | Description
Public Method | CopyTo | Copies a range of elements to the specified array.
Public Method | GetEnumerator | Returns IEnumerator interface used for enumeration all ImGearDisplayChannel class objects in the collection.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannels Class
ImageGear.Core Namespace


CopyTo Method (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : CopyTo Method
ImGearDisplayChannel array to copy the color elements to.
The zero-based index in array at which copying begins.
Copies a range of elements to the specified array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearDisplayChannels
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Array array,
   int index
)
public: void CopyTo(
   Array* array,
   int index
)
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
ImGearDisplayChannel array to copy the color elements to.
index
The zero-based index in array at which copying begins.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


GetEnumerator Method (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : GetEnumerator Method
Returns IEnumerator interface used for enumeration all ImGearDisplayChannel class objects in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearDisplayChannels
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


OnPropertyChanged Method (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearDisplayChannels
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%% $$Properties$$

ImGearDisplayChannels Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannels Class

For a list of all members of this type, see ImGearDisplayChannels members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of ImGearDisplayChannel class objects in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | Item | Gets the collection member with specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

ImGearDisplayChannels Class
ImageGear.Core Namespace


Count Property (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : Count Property
Gets the number of ImGearDisplayChannel class objects in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearDisplayChannels
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members
ImGearDisplayChannel Class


IsSynchronized Property (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearDisplayChannels
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


Item Property (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : Item Property
The zero-based index.
Gets the collection member with specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImGearDisplayChannel
'Usage

Dim instance As ImGearDisplayChannels
Dim index As Integer
Dim value As ImGearDisplayChannel

instance.Item(index) = value

value = instance.Item(index)
public ImGearDisplayChannel this[
   int index
]; {get; set;}
public: __property ImGearDisplayChannel* get_Item   int index
;
public: __property void set_Item   int index,
   ImGearDisplayChannel* value
;
public:
property ImGearDisplayChannel^ default [int] {
   ImGearDisplayChannel^ get(int index);
   void set (int index, ImGearDisplayChannel^ value);
}

Parameters

index
The zero-based index.

Property Value

ImGearDisplayChannel class object.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


SyncRoot Property (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearDisplayChannels
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

Object value.
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%% $$Events$$

ImGearDisplayChannels Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDisplayChannels Class

For a list of all members of this type, see ImGearDisplayChannels members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDisplayChannels Class
ImageGear.Core Namespace


PropertyChanged Event (ImGearDisplayChannels)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDisplayChannels Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearDisplayChannels
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

ImGearDocument Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocument Class
Represents a collection of ImGearPage objects.
Object Model
ImGearDocument ClassImGearDocument ClassImGearMetadataHead ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDocument
'Usage

Dim instance As ImGearDocument
public class ImGearDocument
public __gc class ImGearDocument
public ref class ImGearDocument
Remarks

In addition to pages the object provides access to document level metadata.

In case of PDF or PS, ImGearDocument object may be associated with an external file.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearExcelBookDocument
ImageGear.Formats.Office.ImGearExcelSheetDocument
ImageGear.Formats.Office.ImGearPowerPointDocument
ImageGear.Formats.Office.ImGearWordDocument
ImageGear.Formats.PDF.ImGearPDFDocument
ImageGear.WPF.XPS.ImGearXPSDocument

See Also

Reference

ImGearDocument Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDocument Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocument Class

The following tables list the members exposed by ImGearDocument.

Public Constructors
 | Name | Description
Public Constructor | ImGearDocument Constructor | Initializes a new instance of the ImGearDocument class from list of pages and metadata tree.
Top
Protected Fields
 | Name | Description
Protected Field | m_Metadata | Document-level metadata tree.
Protected Field | m_Pages | List of pages available in the document.
Top
Public Properties
 | Name | Description
Public Property | Metadata | Gets document-level metadata tree.
Public Property | Pages | Gets the list of pages available in the document.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is the exact copy of the current instance.
Public Method | Dispose | Overloaded. Releases all resources, being used.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearDocument class.
Top
See Also

Reference

ImGearDocument Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDocument Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : ImGearDocument Constructor
Initializes a new instance of the ImGearDocument class from list of pages and metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDocument()
public ImGearDocument()
public: ImGearDocument();
public:
ImGearDocument();
See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%% $$Methods$$

ImGearDocument Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocument Class

For a list of all members of this type, see ImGearDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is the exact copy of the current instance.
Public Method | Dispose | Overloaded. Releases all resources, being used.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearDocument class.
Top
See Also

Reference

ImGearDocument Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDocument Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : ImGearDocument Constructor
Overload List
Overload | Description
ImGearDocument Constructor | Initializes a new instance of the ImGearDocument class from list of pages and metadata tree.
See Also

Reference

ImGearDocument Class
ImGearDocument Members


Clone Method (ImGearDocument)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : Clone Method
Creates a new object that is the exact copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearDocument
Dim value As ImGearDocument

value = instance.Clone()
public virtual ImGearDocument Clone()
public: virtual ImGearDocument* Clone();
public:
virtual ImGearDocument^ Clone();

Return Value

A new instance of ImGearDocument class.
Remarks
In contrast to MemberwiseClone, this method performs a deep copy (i.e., all objects, including contained pages, are cloned as well).
See Also

Reference

ImGearDocument Class
ImGearDocument Members


Dispose Method (ImGearDocument)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose() | Releases all resources, being used.
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearDocument Class
ImGearDocument Members


Dispose() Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class > Dispose Method : Dispose() Method
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Dispose()
'Usage

Dim instance As ImGearDocument

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearDocument Class
ImGearDocument Members
Overload List


Dispose(Boolean) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected virtual void Dispose(
   bool disposing
)
protected: virtual void Dispose(
   bool disposing
)
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearDocument Class
ImGearDocument Members
Overload List


Finalize Method (ImGearDocument)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : Finalize Method
Finalizes an instance of the ImGearDocument class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearDocument

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%% $$Properties$$

ImGearDocument Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocument Class

For a list of all members of this type, see ImGearDocument members.

Public Properties
 | Name | Description
Public Property | Metadata | Gets document-level metadata tree.
Public Property | Pages | Gets the list of pages available in the document.
Top
See Also

Reference

ImGearDocument Class
ImageGear.Core Namespace


Metadata Property (ImGearDocument)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : Metadata Property
Gets document-level metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Metadata As ImGearMetadataHead
'Usage

Dim instance As ImGearDocument
Dim value As ImGearMetadataHead

value = instance.Metadata
public ImGearMetadataHead Metadata {get;}
public: __property ImGearMetadataHead* get_Metadata();
public:
property ImGearMetadataHead^ Metadata {
   ImGearMetadataHead^ get();
}

Property Value

ImGearMetadataHead class object.
See Also

Reference

ImGearDocument Class
ImGearDocument Members
ImGearMetadataHead Class


Pages Property (ImGearDocument)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : Pages Property
Gets the list of pages available in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public virtual ImGearDocumentPageArray Pages {get;}
public: __property virtual ImGearDocumentPageArray* get_Pages();
public:
virtual property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get();
}

Property Value

ImGearDocumentPageArray class object.
Remarks
Returns a modifiable list of pages available in the document.
See Also

Reference

ImGearDocument Class
ImGearDocument Members
ImGearDocumentPageArray Class


%%PageItemTitle%% $$Fields$$

ImGearDocument Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocument Class

For a list of all members of this type, see ImGearDocument members.

Protected Fields
 | Name | Description
Protected Field | m_Metadata | Document-level metadata tree.
Protected Field | m_Pages | List of pages available in the document.
Top
See Also

Reference

ImGearDocument Class
ImageGear.Core Namespace


m_Metadata Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : m_Metadata Field
Document-level metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Metadata As ImGearMetadataHead
'Usage

Dim instance As ImGearDocument
Dim value As ImGearMetadataHead

value = instance.m_Metadata

instance.m_Metadata = value
protected ImGearMetadataHead m_Metadata
protected: ImGearMetadataHead* m_Metadata
protected:
ImGearMetadataHead^ m_Metadata
See Also

Reference

ImGearDocument Class
ImGearDocument Members
ImGearMetadataHead Class


m_Pages Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocument Class : m_Pages Field
List of pages available in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearDocument
Dim value As ImGearDocumentPageArray

value = instance.m_Pages

instance.m_Pages = value
protected ImGearDocumentPageArray m_Pages
protected: ImGearDocumentPageArray* m_Pages
protected:
ImGearDocumentPageArray^ m_Pages
See Also

Reference

ImGearDocument Class
ImGearDocument Members
ImGearDocumentPageArray Class


%%PageItemTitle%%

ImGearDocumentPageArray Class
Members Example

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocumentPageArray Class
Represents a collection of pages within ImGearDocument object.
Object Model
ImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearDocumentPageArray
'Usage

Dim instance As ImGearDocumentPageArray
[DefaultMember("Item")]
public class ImGearDocumentPageArray
[DefaultMember("Item")]
public __gc class ImGearDocumentPageArray
[DefaultMember("Item")]
public ref class ImGearDocumentPageArray
Remarks
On adding pages, checks that the new page is not attached to any other document. The Remove method detaches a page from the document. If it is referenced from anywhere else, it remains a valid stand-alone page.

The content of the array can only include the pages that correspond with the type of the document. For example, if the page array is a part of ImGearPDFDocument the type of pages should be ImGearPDFPage. The addition of any pages that do not correspond with the document type will cause an exception.

Well-formed page array may contain any number of null entries. An exception is made for the formats where pages are physically continuous (i.e., PDF). Note that setting a page to null is different from removing a page from the document - the former does not change page count, whereas the latter does.

Example
The following example illustrates how to change the order of pages in the document. This way of page array reordering is useful only for ImGearRasterPage because such pages do not support the System.IDisposable interface. For disposable pages like ImGearPDFPage removing pages from an array calls the Dispose() method, and any further page additions to this array will cause System.ObjectDisposedException. To avoid the addition of a disposed page, it should be cloned before pulling it out from the array, and the clone should be inserted in the required position.
  • C#
int pageCount;
ImGearDocument igDocument;
using (FileStream localFile = new FileStream(localFilePath, FileMode.Open))
{
    pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN);
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount);
}

//Check pages swap possibility
if (pageCount > 1)
{
    ImGearPage igPage = igDocument.Pages[0];
    igDocument.Pages.Remove(igPage);
    igDocument.Pages.Insert(1, igPage);
}
  • Visual Basic
Dim pageCount As Integer
Dim igDocument As ImGearDocument
Dim localFile As FileStream = New FileStream(localFilePath, FileMode.Open)
Try
    pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN)
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount)
Finally
    localFile.Close()
End Try

'Check pages swap possibility
If (pageCount > 1) Then
    Dim igPage As ImGearPage = igDocument.Pages(0)
    igDocument.Pages.Remove(igPage)
    igDocument.Pages.Insert(1, igPage)
End If
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocumentPageArray
ImageGear.Formats.PDF.ImGearPDFDocumentPageArray

See Also

Reference

ImGearDocumentPageArray Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDocumentPageArray Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocumentPageArray Class

The following tables list the members exposed by ImGearDocumentPageArray.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of pages contained in the document.
Public Property | IsFixedSize | Gets a value indicating whether the Array has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the Array is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the Array is synchronized (thread-safe).
Public Property | Item | Gets or sets the page at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the Array.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new ImGearPage to the end of the array of pages.
Public Method | Clear | Removes all pages from the document.
Public Method | Clone | Performs a deep copy of the page array (i.e., clones the pages as well.).
Public Method | Contains | Tells whether the array contains a particular page.
Public Method | CopyTo | Copies all the pages from the current page array to the page array starting at the specified index.
Public Method | GetEnumerator | Returns an enumerator that can iterate through the page array.
Public Method | IndexOf | Returns the index of a page in the array.
Public Method | Insert | Inserts a page into the array at index position.
Public Method | Remove | Removes a page from the array.
Public Method | RemoveAt | This method removes page with specified index from the array.
Top
See Also

Reference

ImGearDocumentPageArray Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearDocumentPageArray Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocumentPageArray Class

For a list of all members of this type, see ImGearDocumentPageArray members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new ImGearPage to the end of the array of pages.
Public Method | Clear | Removes all pages from the document.
Public Method | Clone | Performs a deep copy of the page array (i.e., clones the pages as well.).
Public Method | Contains | Tells whether the array contains a particular page.
Public Method | CopyTo | Copies all the pages from the current page array to the page array starting at the specified index.
Public Method | GetEnumerator | Returns an enumerator that can iterate through the page array.
Public Method | IndexOf | Returns the index of a page in the array.
Public Method | Insert | Inserts a page into the array at index position.
Public Method | Remove | Removes a page from the array.
Public Method | RemoveAt | This method removes page with specified index from the array.
Top
See Also

Reference

ImGearDocumentPageArray Class
ImageGear.Core Namespace


Add Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Add Method
Page to be added.
Adds a new ImGearPage to the end of the array of pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Add( _
   ByVal page As ImGearPage _
) As Integer
'Usage

Dim instance As ImGearDocumentPageArray
Dim page As ImGearPage
Dim value As Integer

value = instance.Add(page)
public virtual int Add(
   ImGearPage page
)
public: virtual int Add(
   ImGearPage* page
)
public:
virtual int Add(
   ImGearPage^ page
)

Parameters

page
Page to be added.

Return Value

Index in the array where new page is added.
Remarks
The method throws an exception if the page is already attached to another document.

An exception is thrown also when the page type does not correspond with the document type array containing the page.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


Clear Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Clear Method
Removes all pages from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Clear()
'Usage

Dim instance As ImGearDocumentPageArray

instance.Clear()
public virtual void Clear()
public: virtual void Clear();
public:
virtual void Clear();
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


Clone Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Clone Method
Performs a deep copy of the page array (i.e., clones the pages as well.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearDocumentPageArray
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As ImGearDocumentPageArray

value = instance.Clone()
public ImGearDocumentPageArray Clone()
public: ImGearDocumentPageArray* Clone();
public:
ImGearDocumentPageArray^ Clone();

Return Value

Copy of ImGearDocumentPageArray.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


Contains Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Contains Method
The page to check for.
Tells whether the array contains a particular page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal value As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As ImGearPage
Dim value As Boolean

value = instance.Contains(value)
public bool Contains(
   ImGearPage value
)
public: bool Contains(
   ImGearPage* value
)
public:
bool Contains(
   ImGearPage^ value
)

Parameters

value
The page to check for.

Return Value

Boolean value.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


CopyTo Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : CopyTo Method
Destination array.
Starting index.
Copies all the pages from the current page array to the page array starting at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearDocumentPageArray
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public virtual void CopyTo(
   Array array,
   int index
)
public: virtual void CopyTo(
   Array* array,
   int index
)
public:
virtual void CopyTo(
   Array^ array,
   int index
)

Parameters

array
Destination array.
index
Starting index.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


GetEnumerator Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : GetEnumerator Method
Returns an enumerator that can iterate through the page array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that can be used to iterate through the page array.
Remarks
Note:

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection. Initially, the enumerator is positioned before the first element in the collection.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


IndexOf Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : IndexOf Method
Page to retrieve index of.
Returns the index of a page in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As ImGearPage _
) As Integer
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As ImGearPage
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   ImGearPage value
)
public: int IndexOf(
   ImGearPage* value
)
public:
int IndexOf(
   ImGearPage^ value
)

Parameters

value
Page to retrieve index of.

Return Value

The location (index) of a page in the array, or -1 if the page is not in the list.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


Insert Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Insert Method
Position to insert at.
Page to insert.
Inserts a page into the array at index position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal page As ImGearPage _
)
'Usage

Dim instance As ImGearDocumentPageArray
Dim index As Integer
Dim page As ImGearPage

instance.Insert(index, page)
public virtual void Insert(
   int index,
   ImGearPage page
)
public: virtual void Insert(
   int index,
   ImGearPage* page
)
public:
virtual void Insert(
   int index,
   ImGearPage^ page
)

Parameters

index
Position to insert at.
page
Page to insert.
Remarks
The method throws an exception if the page is already attached to another document.

An exception is thrown also when the page type does not correspond with the document type array containing the page.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


Remove Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Remove Method
Page to remove.
Removes a page from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Remove( _
   ByVal value As ImGearPage _
)
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As ImGearPage

instance.Remove(value)
public virtual void Remove(
   ImGearPage value
)
public: virtual void Remove(
   ImGearPage* value
)
public:
virtual void Remove(
   ImGearPage^ value
)

Parameters

value
Page to remove.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


RemoveAt Method (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : RemoveAt Method
Page index to remove at.
This method removes page with specified index from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearDocumentPageArray
Dim index As Integer

instance.RemoveAt(index)
public virtual void RemoveAt(
   int index
)
public: virtual void RemoveAt(
   int index
)
public:
virtual void RemoveAt(
   int index
)

Parameters

index
Page index to remove at.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%% $$Properties$$

ImGearDocumentPageArray Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDocumentPageArray Class

For a list of all members of this type, see ImGearDocumentPageArray members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of pages contained in the document.
Public Property | IsFixedSize | Gets a value indicating whether the Array has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the Array is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the Array is synchronized (thread-safe).
Public Property | Item | Gets or sets the page at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the Array.
Top
See Also

Reference

ImGearDocumentPageArray Class
ImageGear.Core Namespace


Count Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Count Property
Gets the number of pages contained in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Any positive integer value.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


IsFixedSize Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : IsFixedSize Property
Gets a value indicating whether the Array has a fixed size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As Boolean

value = instance.IsFixedSize
public bool IsFixedSize {get;}
public: __property bool get_IsFixedSize();
public:
property bool IsFixedSize {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


IsReadOnly Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : IsReadOnly Property
Gets a value indicating whether the Array is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As Boolean

value = instance.IsReadOnly
public bool IsReadOnly {get;}
public: __property bool get_IsReadOnly();
public:
property bool IsReadOnly {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


IsSynchronized Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : IsSynchronized Property
Gets a value indicating whether access to the Array is synchronized (thread-safe).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


Item Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : Item Property
Index of the page to get or set.
Gets or sets the page at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Default Property Item( _
   ByVal index As Integer _
) As ImGearPage
'Usage

Dim instance As ImGearDocumentPageArray
Dim index As Integer
Dim value As ImGearPage

instance.Item(index) = value

value = instance.Item(index)
public virtual ImGearPage this[
   int index
]; {get; set;}
public: __property virtual ImGearPage* get_Item   int index
;
public: __property virtual void set_Item   int index,
   ImGearPage* value
;
public:
virtual property ImGearPage^ default [int] {
   ImGearPage^ get(int index);
   void set (int index, ImGearPage^ value);
}

Parameters

index
Index of the page to get or set.

Property Value

ImGearPage class object.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
ImGearPage Class


SyncRoot Property (ImGearDocumentPageArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDocumentPageArray Class : SyncRoot Property
Gets an object that can be used to synchronize access to the Array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearDocumentPageArray
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object that can be used to synchronize access to the Array.
See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

ImGearException Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearException Class
Base class for all exceptions thrown by the ImageGear for .NET library. Contains error codes and optionally supplied data.
Object Model
ImGearException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearException
   Inherits System.Exception
'Usage

Dim instance As ImGearException
public class ImGearException : System.Exception
public __gc class ImGearException : public System.Exception
public ref class ImGearException : public System.Exception
Remarks
Contains detailed information about the error that occured.

This class does not have any public constructors. All instances are created implicitly by overloads of ThrowError static method.

Inheritance Hierarchy

System.Object
System.Exception
ImageGear.Core.ImGearException
ImageGear.ART.ImGearARTAccessDeniedException

See Also

Reference

ImGearException Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearException Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearException Class

The following tables list the members exposed by ImGearException.

Public Properties
 | Name | Description
Public Property | ErrorCode | Gets or sets error code from ImGearErrorCodes enumeration.
Public Property | Value1 | Gets or sets integer data supplied to error code.
Public Property | Value2 | Gets or sets integer data supplied to error code.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ThrowError | Overloaded. Throws exception of ImGearException class.
Top
See Also

Reference

ImGearException Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearException Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearException Class

For a list of all members of this type, see ImGearException members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ThrowError | Overloaded. Throws exception of ImGearException class.
Top
See Also

Reference

ImGearException Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Events$$

ImGearException Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearException Class

For a list of all members of this type, see ImGearException members.

See Also

Reference

ImGearException Class
ImageGear.Core Namespace


ThrowError Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class : ThrowError Method
Throws exception of ImGearException class.
Overload List
Overload | Description
ThrowError(ImGearErrorCodes,String,Int32,Int32) | Throws exception of ImGearException class.
ThrowError(ImGearErrorCodes,String,Int32) | Throws exception of ImGearException class.
ThrowError(ImGearErrorCodes,String) | Throws exception of ImGearException class.
ThrowError(ImGearErrorCodes) | Throws exception of ImGearException class.
See Also

Reference

ImGearException Class
ImGearException Members


ThrowError(ImGearErrorCodes,String,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class > ThrowError Method : ThrowError(ImGearErrorCodes,String,Int32,Int32) Method
Numeric code of error from ImGearErrorCodes enumeration.
Human readable information about reason of exception.
Integer data of the Value1 supplied to error code. Its meaning depends on reason of exception.
Integer data of the Value2 supplied to error code. Its meaning depends on reason of exception.
Throws exception of ImGearException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ThrowError( _
   ByVal errorCode As ImGearErrorCodes, _
   ByVal description As String, _
   ByVal value1 As Integer, _
   ByVal value2 As Integer _
)
'Usage

Dim errorCode As ImGearErrorCodes
Dim description As String
Dim value1 As Integer
Dim value2 As Integer

ImGearException.ThrowError(errorCode, description, value1, value2)
public static void ThrowError(
   ImGearErrorCodes errorCode,
   string description,
   int value1,
   int value2
)
public: static void ThrowError(
   ImGearErrorCodes errorCode,
   string* description,
   int value1,
   int value2
)
public:
static void ThrowError(
   ImGearErrorCodes errorCode,
   String^ description,
   int value1,
   int value2
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data of the Value1 supplied to error code. Its meaning depends on reason of exception.
value2
Integer data of the Value2 supplied to error code. Its meaning depends on reason of exception.
See Also

Reference

ImGearException Class
ImGearException Members
Overload List
ImGearErrorCodes Enumeration


ThrowError(ImGearErrorCodes,String,Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class > ThrowError Method : ThrowError(ImGearErrorCodes,String,Int32) Method
Numeric code of error from ImGearErrorCodes enumeration.
Human readable information about reason of exception.
Integer data supplied to error code. Its meaning depends on reason of exception.
Throws exception of ImGearException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ThrowError( _
   ByVal errorCode As ImGearErrorCodes, _
   ByVal description As String, _
   ByVal value1 As Integer _
)
'Usage

Dim errorCode As ImGearErrorCodes
Dim description As String
Dim value1 As Integer

ImGearException.ThrowError(errorCode, description, value1)
public static void ThrowError(
   ImGearErrorCodes errorCode,
   string description,
   int value1
)
public: static void ThrowError(
   ImGearErrorCodes errorCode,
   string* description,
   int value1
)
public:
static void ThrowError(
   ImGearErrorCodes errorCode,
   String^ description,
   int value1
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data supplied to error code. Its meaning depends on reason of exception.
See Also

Reference

ImGearException Class
ImGearException Members
Overload List
ImGearErrorCodes Enumeration


ThrowError(ImGearErrorCodes,String) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class > ThrowError Method : ThrowError(ImGearErrorCodes,String) Method
Numeric code of error from ImGearErrorCodes enumeration.
Human readable information about reason of exception.
Throws exception of ImGearException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ThrowError( _
   ByVal errorCode As ImGearErrorCodes, _
   ByVal description As String _
)
'Usage

Dim errorCode As ImGearErrorCodes
Dim description As String

ImGearException.ThrowError(errorCode, description)
public static void ThrowError(
   ImGearErrorCodes errorCode,
   string description
)
public: static void ThrowError(
   ImGearErrorCodes errorCode,
   string* description
)
public:
static void ThrowError(
   ImGearErrorCodes errorCode,
   String^ description
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
See Also

Reference

ImGearException Class
ImGearException Members
Overload List
ImGearErrorCodes Enumeration


ThrowError(ImGearErrorCodes) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class > ThrowError Method : ThrowError(ImGearErrorCodes) Method
Numeric code of error from ImGearErrorCodes enumeration.
Throws exception of ImGearException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ThrowError( _
   ByVal errorCode As ImGearErrorCodes _
)
'Usage

Dim errorCode As ImGearErrorCodes

ImGearException.ThrowError(errorCode)
public static void ThrowError(
   ImGearErrorCodes errorCode
)
public: static void ThrowError(
   ImGearErrorCodes errorCode
)
public:
static void ThrowError(
   ImGearErrorCodes errorCode
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
See Also

Reference

ImGearException Class
ImGearException Members
Overload List
ImGearErrorCodes Enumeration


%%PageItemTitle%% $$Properties$$

ImGearException Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearException Class

For a list of all members of this type, see ImGearException members.

Public Properties
 | Name | Description
Public Property | ErrorCode | Gets or sets error code from ImGearErrorCodes enumeration.
Public Property | Value1 | Gets or sets integer data supplied to error code.
Public Property | Value2 | Gets or sets integer data supplied to error code.
Top
See Also

Reference

ImGearException Class
ImageGear.Core Namespace


ErrorCode Property (ImGearException)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class : ErrorCode Property
Gets or sets error code from ImGearErrorCodes enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCode As ImGearErrorCodes
'Usage

Dim instance As ImGearException
Dim value As ImGearErrorCodes

instance.ErrorCode = value

value = instance.ErrorCode
public ImGearErrorCodes ErrorCode {get; set;}
public: __property ImGearErrorCodes get_ErrorCode();
public: __property void set_ErrorCode(
   ImGearErrorCodes value
);
public:
property ImGearErrorCodes ErrorCode {
   ImGearErrorCodes get();
   void set (    ImGearErrorCodes value);
}

Property Value

ImGearErrorCodes enumeration value.
Remarks
Returns or updates the code of the error that occured.
See Also

Reference

ImGearException Class
ImGearException Members
ImGearErrorCodes Enumeration


Value1 Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class : Value1 Property
Gets or sets integer data supplied to error code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value1 As Integer
'Usage

Dim instance As ImGearException
Dim value As Integer

instance.Value1 = value

value = instance.Value1
public int Value1 {get; set;}
public: __property int get_Value1();
public: __property void set_Value1(
   int value
);
public:
property int Value1 {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Value meaning depends on the reason of exception.
See Also

Reference

ImGearException Class
ImGearException Members


Value2 Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearException Class : Value2 Property
Gets or sets integer data supplied to error code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value2 As Integer
'Usage

Dim instance As ImGearException
Dim value As Integer

instance.Value2 = value

value = instance.Value2
public int Value2 {get; set;}
public: __property int get_Value2();
public: __property void set_Value2(
   int value
);
public:
property int Value2 {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Value meaning depends on the reason of exception.
See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

ImGearExtraChannelInfo Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearExtraChannelInfo Class
This is a general extra channel class.
Object Model
ImGearExtraChannelInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExtraChannelInfo
'Usage

Dim instance As ImGearExtraChannelInfo
public class ImGearExtraChannelInfo
public __gc class ImGearExtraChannelInfo
public ref class ImGearExtraChannelInfo
Remarks
Each extra channel in image has ImGearExtraChannelInfo object associated with it.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearColorChannelInfo
ImageGear.Core.ImGearSpotChannelInfo

See Also

Reference

ImGearExtraChannelInfo Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearExtraChannelInfo Class Members
Fields Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearExtraChannelInfo Class

The following tables list the members exposed by ImGearExtraChannelInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearExtraChannelInfo Constructor | Initializes a new instance of the ImGearExtraChannelInfo class object.
Top
Protected Fields
 | Name | Description
Protected Field | m_Type | Gets the type of extra channel.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of extra channel.
Public Property | Type | Gets the type of extra channel.
Top
See Also

Reference

ImGearExtraChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearExtraChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearExtraChannelInfo Class : ImGearExtraChannelInfo Constructor
Initializes a new instance of the ImGearExtraChannelInfo class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearExtraChannelInfo()
public ImGearExtraChannelInfo()
public: ImGearExtraChannelInfo();
public:
ImGearExtraChannelInfo();
See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%% $$Properties$$

ImGearExtraChannelInfo Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearExtraChannelInfo Class

For a list of all members of this type, see ImGearExtraChannelInfo members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of extra channel.
Public Property | Type | Gets the type of extra channel.
Top
See Also

Reference

ImGearExtraChannelInfo Class
ImageGear.Core Namespace


Name Property (ImGearExtraChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearExtraChannelInfo Class : Name Property
Gets or sets the name of extra channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearExtraChannelInfo
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


Type Property (ImGearExtraChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearExtraChannelInfo Class : Type Property
Gets the type of extra channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearExtraChannelType
'Usage

Dim instance As ImGearExtraChannelInfo
Dim value As ImGearExtraChannelType

value = instance.Type
public ImGearExtraChannelType Type {get;}
public: __property ImGearExtraChannelType get_Type();
public:
property ImGearExtraChannelType Type {
   ImGearExtraChannelType get();
}

Property Value

ImGearExtraChannelType enumeration value.
See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members
ImGearExtraChannelType Enumeration


%%PageItemTitle%% $$Fields$$

ImGearExtraChannelInfo Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearExtraChannelInfo Class

For a list of all members of this type, see ImGearExtraChannelInfo members.

Protected Fields
 | Name | Description
Protected Field | m_Type | Gets the type of extra channel.
Top
See Also

Reference

ImGearExtraChannelInfo Class
ImageGear.Core Namespace


m_Type Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearExtraChannelInfo Class : m_Type Field
Gets the type of extra channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_Type As ImGearExtraChannelType
'Usage

Dim instance As ImGearExtraChannelInfo
Dim value As ImGearExtraChannelType

value = instance.m_Type

instance.m_Type = value
protected ImGearExtraChannelType m_Type
protected: ImGearExtraChannelType m_Type
protected:
ImGearExtraChannelType m_Type

Field Value

ImGearExtraChannelType enumeration value.
See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%%

ImGearFullLUT Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class
Represents a lookup table that contains a full table of values for each possible input index.
Object Model
ImGearFullLUT ClassImGearLUT ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearFullLUT
   Inherits ImGearLUT
'Usage

Dim instance As ImGearFullLUT
[DefaultMember("Item")]
public class ImGearFullLUT : ImGearLUT
[DefaultMember("Item")]
public __gc class ImGearFullLUT : public ImGearLUT
[DefaultMember("Item")]
public ref class ImGearFullLUT : public ImGearLUT
Remarks
Lookup table contains values for entire input range. Table of values can be accessed directly.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearLUT
ImageGear.Core.ImGearFullLUT

See Also

Reference

ImGearFullLUT Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearFullLUT Class Members
Fields Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class

The following tables list the members exposed by ImGearFullLUT.

Public Constructors
 | Name | Description
Public Constructor | ImGearFullLUT Constructor | Initializes a new instance of the ImGearFullLUT class.
Top
Public Fields
 | Name | Description
Public Field | Table | Provides direct access to the LUT table.
Top
Public Properties
 | Name | Description
Public Property | InputDepth | Overridden. Specifies input depth of the LUT.
Public Property | InputIsSigned | Overridden. Specifies whether LUT input values are signed.
Public Property | Item | Overridden. Returns LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Overridden. Specifies output depth of the LUT.
Public Property | OutputIsSigned | Overridden. Specifies whether LUT output values are signed.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the object.
Public Method | Concatenate | Overridden. Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Overridden. Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.
Public Method | GetTableIndex | Overloaded. Obtains index in the table corresponding to Int32 input value.
Top
See Also

Reference

ImGearFullLUT Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearFullLUT Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : ImGearFullLUT Constructor
Specifies input depth of the LUT.
Specifies whether LUT input is signed.
Specifies output depth of the LUT.
Specifies whether LUT output is signed.
Initializes a new instance of the ImGearFullLUT class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal inputDepth As Integer, _
   ByVal inputIsSigned As Boolean, _
   ByVal outputDepth As Integer, _
   ByVal outputIsSigned As Boolean _
)
'Usage

Dim inputDepth As Integer
Dim inputIsSigned As Boolean
Dim outputDepth As Integer
Dim outputIsSigned As Boolean

Dim instance As New ImGearFullLUT(inputDepth, inputIsSigned, outputDepth, outputIsSigned)
public ImGearFullLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)
public: ImGearFullLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)
public:
ImGearFullLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)

Parameters

inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.
Remarks
This constructor creates a new instance of ImGearFullLUT object and allocates the internal table, according to input and output depths.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%% $$Methods$$

ImGearFullLUT Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class

For a list of all members of this type, see ImGearFullLUT members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the object.
Public Method | Concatenate | Overridden. Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Overridden. Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.
Public Method | GetTableIndex | Overloaded. Obtains index in the table corresponding to Int32 input value.
Top
See Also

Reference

ImGearFullLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Events$$

ImGearFullLUT Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class

For a list of all members of this type, see ImGearFullLUT members.

See Also

Reference

ImGearFullLUT Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearFullLUT Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : ImGearFullLUT Constructor
Overload List
Overload | Description
ImGearFullLUT Constructor | Initializes a new instance of the ImGearFullLUT class.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


Clone Method (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearLUT
'Usage

Dim instance As ImGearFullLUT
Dim value As ImGearLUT

value = instance.Clone()
public override ImGearLUT Clone()
public: ImGearLUT* Clone(); override
public:
ImGearLUT^ Clone(); override

Return Value

The new instance of ImGearLUT class object.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


Concatenate Method (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : Concatenate Method
LUT to be concatenated.
Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Concatenate( _
   ByVal lookupTable As ImGearLUT _
) As ImGearLUT
'Usage

Dim instance As ImGearFullLUT
Dim lookupTable As ImGearLUT
Dim value As ImGearLUT

value = instance.Concatenate(lookupTable)
public override ImGearLUT Concatenate(
   ImGearLUT lookupTable
)
public: ImGearLUT* Concatenate(
   ImGearLUT* lookupTable
) override
public:
ImGearLUT^ Concatenate(
   ImGearLUT^ lookupTable
) override

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
ImGearLUT Class


CopyFrom Method (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : CopyFrom Method
LUT to be copied.
Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub CopyFrom( _
   ByVal lookupTable As ImGearLUT _
)
'Usage

Dim instance As ImGearFullLUT
Dim lookupTable As ImGearLUT

instance.CopyFrom(lookupTable)
public override void CopyFrom(
   ImGearLUT lookupTable
)
public: void CopyFrom(
   ImGearLUT* lookupTable
) override
public:
void CopyFrom(
   ImGearLUT^ lookupTable
) override

Parameters

lookupTable
LUT to be copied.
Remarks
LUT type and depths attributes must be compatible with the class this method is called from.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


GetTableIndex Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : GetTableIndex Method
Obtains index in the table corresponding to Int32 input value.
Overload List
Overload | Description
GetTableIndex(Int32) | Obtains index in the table corresponding to Int32 input value.
GetTableIndex(Int64) | Obtains index in the table corresponding to Int64 input value.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


GetTableIndex(Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class > GetTableIndex Method : GetTableIndex(Int32) Method
LUT input value.
Obtains index in the table corresponding to Int32 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetTableIndex( _
   ByVal inputValue As Integer _
) As UInteger
'Usage

Dim instance As ImGearFullLUT
Dim inputValue As Integer
Dim value As UInteger

value = instance.GetTableIndex(inputValue)
public uint GetTableIndex(
   int inputValue
)
public: uint GetTableIndex(
   int inputValue
)
public:
uint GetTableIndex(
   int inputValue
)

Parameters

inputValue
LUT input value.

Return Value

Integer number.
Remarks
This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


GetTableIndex(Int64) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class > GetTableIndex Method : GetTableIndex(Int64) Method
LUT input value.
Obtains index in the table corresponding to Int64 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetTableIndex( _
   ByVal inputValue As Long _
) As UInteger
'Usage

Dim instance As ImGearFullLUT
Dim inputValue As Long
Dim value As UInteger

value = instance.GetTableIndex(inputValue)
public uint GetTableIndex(
   long inputValue
)
public: uint GetTableIndex(
   long inputValue
)
public:
uint GetTableIndex(
   int64 inputValue
)

Parameters

inputValue
LUT input value.

Return Value

Integer number.
Remarks
This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearFullLUT Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class

For a list of all members of this type, see ImGearFullLUT members.

Public Properties
 | Name | Description
Public Property | InputDepth | Overridden. Specifies input depth of the LUT.
Public Property | InputIsSigned | Overridden. Specifies whether LUT input values are signed.
Public Property | Item | Overridden. Returns LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Overridden. Specifies output depth of the LUT.
Public Property | OutputIsSigned | Overridden. Specifies whether LUT output values are signed.
Top
See Also

Reference

ImGearFullLUT Class
ImageGear.Core Namespace


InputDepth Property (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : InputDepth Property
Specifies input depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputDepth As Integer
'Usage

Dim instance As ImGearFullLUT
Dim value As Integer

value = instance.InputDepth
public override int InputDepth {get;}
public: __property int get_InputDepth() override;
public:
property int InputDepth {
   int get() override;
}

Property Value

Any integer number.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


InputIsSigned Property (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : InputIsSigned Property
Specifies whether LUT input values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputIsSigned As Boolean
'Usage

Dim instance As ImGearFullLUT
Dim value As Boolean

value = instance.InputIsSigned
public override bool InputIsSigned {get;}
public: __property bool get_InputIsSigned() override;
public:
property bool InputIsSigned {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


Item Property (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : Item Property
Index of the LUT to get.
Returns LUT output value corresponding to Int32 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Default Property Item( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearFullLUT
Dim index As Integer
Dim value As Integer

instance.Item(index) = value

value = instance.Item(index)
public override int this[
   int index
]; {get; set;}
public: __property int get_Item   int index
 override;
public: __property void set_Item   int index,
   int value
 override;
public:
property int default [int] override {
   int get(int index) override;
   void set (int index, int value) override;
}

Parameters

index
Index of the LUT to get.

Property Value

Integer number.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


OutputDepth Property (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : OutputDepth Property
Specifies output depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutputDepth As Integer
'Usage

Dim instance As ImGearFullLUT
Dim value As Integer

value = instance.OutputDepth
public override int OutputDepth {get;}
public: __property int get_OutputDepth() override;
public:
property int OutputDepth {
   int get() override;
}

Property Value

Any integer number.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


OutputIsSigned Property (ImGearFullLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : OutputIsSigned Property
Specifies whether LUT output values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutputIsSigned As Boolean
'Usage

Dim instance As ImGearFullLUT
Dim value As Boolean

value = instance.OutputIsSigned
public override bool OutputIsSigned {get;}
public: __property bool get_OutputIsSigned() override;
public:
property bool OutputIsSigned {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%% $$Fields$$

ImGearFullLUT Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFullLUT Class

For a list of all members of this type, see ImGearFullLUT members.

Public Fields
 | Name | Description
Public Field | Table | Provides direct access to the LUT table.
Top
See Also

Reference

ImGearFullLUT Class
ImageGear.Core Namespace


Table Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearFullLUT Class : Table Field
Provides direct access to the LUT table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Table As Array
'Usage

Dim instance As ImGearFullLUT
Dim value As Array

value = instance.Table

instance.Table = value
public Array Table
public: Array* Table
public:
Array^ Table

Field Value

byte[ ], Int16[ ] or Int32[ ]
Remarks
Actual type of the array depends on the output depth of the LUT:
  • If output depth is between 1 and 8, Table is byte[ ]
  • If output depth is between 9 and 16, Table is Int16[ ]
  • If output depth is between 17 and 32, Table is Int32[ ]

Length of the table depends on the input depth, as follows:

Length = 2 ^ inputDepth.
See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

ImGearLicense Class
Members Example

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLicense Class
Manages licensing data (i.e., license type and key).
Object Model
ImGearLicense Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearLicense
'Usage

Dim instance As ImGearLicense
public sealed class ImGearLicense
public __gc __sealed class ImGearLicense
public ref class ImGearLicense sealed
Example
  • C#
// Solution Name, Key, and License Key provided by AccuSoft for your deployment.
ImGearLicense.SetSolutionName("YourSolutionName");
ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345);
ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation...");
  • Visual Basic
'Solution Name, Key, and License Key provided by Accusoft for your deployment.
ImGearLicense.SetSolutionName("YourSolutionName")
ImGearLicense.SetSolutionKey(12345, 12345, 12345, 12345)
ImGearLicense.SetOEMLicenseKey("2.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation...")
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearLicense

See Also

Reference

ImGearLicense Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearLicense Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLicense Class

The following tables list the members exposed by ImGearLicense.

Public Constructors
 | Name | Description
Public Constructor | ImGearLicense Constructor | Initializes a new instance of the ImGearLicense class object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | SetOEMLicenseKey | Sets the licensing OEM key.
static (Shared in Visual Basic) | SetSolutionKey | Sets the licensing solution key.
static (Shared in Visual Basic) | SetSolutionName | Sets the licensing solution name.
Top
See Also

Reference

ImGearLicense Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearLicense Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLicense Class : ImGearLicense Constructor
Initializes a new instance of the ImGearLicense class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearLicense()
public ImGearLicense()
public: ImGearLicense();
public:
ImGearLicense();
See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%% $$Methods$$

ImGearLicense Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLicense Class

For a list of all members of this type, see ImGearLicense members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | SetOEMLicenseKey | Sets the licensing OEM key.
static (Shared in Visual Basic) | SetSolutionKey | Sets the licensing solution key.
static (Shared in Visual Basic) | SetSolutionName | Sets the licensing solution name.
Top
See Also

Reference

ImGearLicense Class
ImageGear.Core Namespace


SetOEMLicenseKey Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLicense Class : SetOEMLicenseKey Method
Obtained from Accusoft OEM license key.
Sets the licensing OEM key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SetOEMLicenseKey( _
   ByVal licenseKey As String _
)
'Usage

Dim licenseKey As String

ImGearLicense.SetOEMLicenseKey(licenseKey)
public static void SetOEMLicenseKey(
   string licenseKey
)
public: static void SetOEMLicenseKey(
   string* licenseKey
)
public:
static void SetOEMLicenseKey(
   String^ licenseKey
)

Parameters

licenseKey
Obtained from Accusoft OEM license key.
Remarks
Use this method for deployment licensing only. Solution name and solution key must be set up in addition to the OEM license key. For more information about licensing, see Licensing and Distributing ImageGear for .NET.
See Also

Reference

ImGearLicense Class
ImGearLicense Members


SetSolutionKey Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLicense Class : SetSolutionKey Method
Key1 part of solution key.
Key2 part of solution key.
Key3 part of solution key.
Key4 part of solution key.
Sets the licensing solution key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

ImGearLicense.SetSolutionKey(key1, key2, key3, key4)
public static void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: static void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
static void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Key1 part of solution key.
key2
Key2 part of solution key.
key3
Key3 part of solution key.
key4
Key4 part of solution key.
Remarks
Use this method for deployment licensing only. Solution name must be set up in addition to the solution key. For more information about licensing, see Licensing and Distributing ImageGear for .NET.
See Also

Reference

ImGearLicense Class
ImGearLicense Members


SetSolutionName Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLicense Class : SetSolutionName Method
Name of solution.
Sets the licensing solution name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim solutionName As String

ImGearLicense.SetSolutionName(solutionName)
public static void SetSolutionName(
   string solutionName
)
public: static void SetSolutionName(
   string* solutionName
)
public:
static void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
Name of solution.
Remarks
When this method is used for deployment licensing, the solution key must be set up in addition to the name. For OEM deployment licensing, the OEM license key must be set up in addition to the solution name and key. For more information about licensing, see Licensing and Distributing ImageGear for .NET.
See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%%

ImGearLinearLUT Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLinearLUT Class
This class represents a lookup table that does not store the actual LUT values, but calculates output values dynamically using a linear formula.
Object Model
ImGearLinearLUT ClassImGearLUT ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearLinearLUT
   Inherits ImGearLUT
'Usage

Dim instance As ImGearLinearLUT
[DefaultMember("Item")]
public class ImGearLinearLUT : ImGearLUT
[DefaultMember("Item")]
public __gc class ImGearLinearLUT : public ImGearLUT
[DefaultMember("Item")]
public ref class ImGearLinearLUT : public ImGearLUT
Remarks
Such LUTs can be used for window levelling of 17-32 bit per channel images.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearLUT
ImageGear.Core.ImGearLinearLUT

See Also

Reference

ImGearLinearLUT Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearLinearLUT Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLinearLUT Class

The following tables list the members exposed by ImGearLinearLUT.

Public Constructors
 | Name | Description
Public Constructor | ImGearLinearLUT Constructor | Initializes a new instance of the ImGearLinearLUT class.
Top
Public Properties
 | Name | Description
Public Property | InputDepth | Overridden. Gets input depth of the LUT.
Public Property | InputIsSigned | Overridden. Gets a value whether LUT input values are signed.
Public Property | Intercept | Gets or sets LUT Intercept value.
Public Property | Item | Overridden. Gets or sets LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Overridden. Gets output depth of the LUT.
Public Property | OutputIsSigned | Overridden. Gets a value whether LUT output values are signed.
Public Property | Slope | Gets or sets LUT Slope value.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the object.
Public Method | Concatenate | Overridden. Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Overridden. Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.
Top
See Also

Reference

ImGearLinearLUT Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearLinearLUT Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : ImGearLinearLUT Constructor
Specifies input depth of the LUT.
Specifies whether LUT input is signed.
Specifies output depth of the LUT.
Specifies whether LUT output is signed.
Initializes a new instance of the ImGearLinearLUT class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal inputDepth As Integer, _
   ByVal inputIsSigned As Boolean, _
   ByVal outputDepth As Integer, _
   ByVal outputIsSigned As Boolean _
)
'Usage

Dim inputDepth As Integer
Dim inputIsSigned As Boolean
Dim outputDepth As Integer
Dim outputIsSigned As Boolean

Dim instance As New ImGearLinearLUT(inputDepth, inputIsSigned, outputDepth, outputIsSigned)
public ImGearLinearLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)
public: ImGearLinearLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)
public:
ImGearLinearLUT(
   int inputDepth,
   bool inputIsSigned,
   int outputDepth,
   bool outputIsSigned
)

Parameters

inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.
Remarks
Slope and Intercept will be initialized to default values of 1.0 and 0.0. They should be initialized later, if necessary, via corresponding set properties.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%% $$Methods$$

ImGearLinearLUT Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLinearLUT Class

For a list of all members of this type, see ImGearLinearLUT members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the object.
Public Method | Concatenate | Overridden. Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Overridden. Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.
Top
See Also

Reference

ImGearLinearLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Events$$

ImGearLinearLUT Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLinearLUT Class

For a list of all members of this type, see ImGearLinearLUT members.

See Also

Reference

ImGearLinearLUT Class
ImageGear.Core Namespace


Clone Method (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearLUT
'Usage

Dim instance As ImGearLinearLUT
Dim value As ImGearLUT

value = instance.Clone()
public override ImGearLUT Clone()
public: ImGearLUT* Clone(); override
public:
ImGearLUT^ Clone(); override

Return Value

The new instance of ImGearLinearLUT class object.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


Concatenate Method (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : Concatenate Method
LUT to be concatenated.
Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Concatenate( _
   ByVal lookupTable As ImGearLUT _
) As ImGearLUT
'Usage

Dim instance As ImGearLinearLUT
Dim lookupTable As ImGearLUT
Dim value As ImGearLUT

value = instance.Concatenate(lookupTable)
public override ImGearLUT Concatenate(
   ImGearLUT lookupTable
)
public: ImGearLUT* Concatenate(
   ImGearLUT* lookupTable
) override
public:
ImGearLUT^ Concatenate(
   ImGearLUT^ lookupTable
) override

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object.
Remarks
If the lookupTable parameter is not an ImGearLinearLUT class object, the method throws ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members
ImGearLUT Class


CopyFrom Method (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : CopyFrom Method
LUT to be copied.
Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub CopyFrom( _
   ByVal lookupTable As ImGearLUT _
)
'Usage

Dim instance As ImGearLinearLUT
Dim lookupTable As ImGearLUT

instance.CopyFrom(lookupTable)
public override void CopyFrom(
   ImGearLUT lookupTable
)
public: void CopyFrom(
   ImGearLUT* lookupTable
) override
public:
void CopyFrom(
   ImGearLUT^ lookupTable
) override

Parameters

lookupTable
LUT to be copied.
Remarks
LUT type and depths attributes must be compatible with the class from which this method is called.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%% $$Properties$$

ImGearLinearLUT Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLinearLUT Class

For a list of all members of this type, see ImGearLinearLUT members.

Public Properties
 | Name | Description
Public Property | InputDepth | Overridden. Gets input depth of the LUT.
Public Property | InputIsSigned | Overridden. Gets a value whether LUT input values are signed.
Public Property | Intercept | Gets or sets LUT Intercept value.
Public Property | Item | Overridden. Gets or sets LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Overridden. Gets output depth of the LUT.
Public Property | OutputIsSigned | Overridden. Gets a value whether LUT output values are signed.
Public Property | Slope | Gets or sets LUT Slope value.
Top
See Also

Reference

ImGearLinearLUT Class
ImageGear.Core Namespace


InputDepth Property (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : InputDepth Property
Gets input depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputDepth As Integer
'Usage

Dim instance As ImGearLinearLUT
Dim value As Integer

value = instance.InputDepth
public override int InputDepth {get;}
public: __property int get_InputDepth() override;
public:
property int InputDepth {
   int get() override;
}

Property Value

Any integer number.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


InputIsSigned Property (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : InputIsSigned Property
Gets a value whether LUT input values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputIsSigned As Boolean
'Usage

Dim instance As ImGearLinearLUT
Dim value As Boolean

value = instance.InputIsSigned
public override bool InputIsSigned {get;}
public: __property bool get_InputIsSigned() override;
public:
property bool InputIsSigned {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


Intercept Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : Intercept Property
Gets or sets LUT Intercept value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Intercept As Double
'Usage

Dim instance As ImGearLinearLUT
Dim value As Double

instance.Intercept = value

value = instance.Intercept
public double Intercept {get; set;}
public: __property double get_Intercept();
public: __property void set_Intercept(
   double value
);
public:
property double Intercept {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


Item Property (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : Item Property
Index of the LUT to get.
Gets or sets LUT output value corresponding to Int32 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Default Property Item( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearLinearLUT
Dim index As Integer
Dim value As Integer

instance.Item(index) = value

value = instance.Item(index)
public override int this[
   int index
]; {get; set;}
public: __property int get_Item   int index
 override;
public: __property void set_Item   int index,
   int value
 override;
public:
property int default [int] override {
   int get(int index) override;
   void set (int index, int value) override;
}

Parameters

index
Index of the LUT to get.

Property Value

Integer value.
Remarks
LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


OutputDepth Property (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : OutputDepth Property
Gets output depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutputDepth As Integer
'Usage

Dim instance As ImGearLinearLUT
Dim value As Integer

value = instance.OutputDepth
public override int OutputDepth {get;}
public: __property int get_OutputDepth() override;
public:
property int OutputDepth {
   int get() override;
}

Property Value

Any integer number.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


OutputIsSigned Property (ImGearLinearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : OutputIsSigned Property
Gets a value whether LUT output values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutputIsSigned As Boolean
'Usage

Dim instance As ImGearLinearLUT
Dim value As Boolean

value = instance.OutputIsSigned
public override bool OutputIsSigned {get;}
public: __property bool get_OutputIsSigned() override;
public:
property bool OutputIsSigned {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


Slope Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLinearLUT Class : Slope Property
Gets or sets LUT Slope value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Slope As Double
'Usage

Dim instance As ImGearLinearLUT
Dim value As Double

instance.Slope = value

value = instance.Slope
public double Slope {get; set;}
public: __property double get_Slope();
public: __property void set_Slope(
   double value
);
public:
property double Slope {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

ImGearLUT Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLUT Class
Provides a base for lookup tables (LUTs) that are used in ImageGear.
Object Model
ImGearLUT ClassImGearLUT ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class ImGearLUT
'Usage

Dim instance As ImGearLUT
[DefaultMember("Item")]
public abstract class ImGearLUT
[DefaultMember("Item")]
public __gc abstract class ImGearLUT
[DefaultMember("Item")]
public ref class ImGearLUT abstract
Remarks
A LUT is characterized by input depth and output depth; both input and output of the LUT can be signed or unsigned.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearLUT
ImageGear.Core.ImGearFullLUT
ImageGear.Core.ImGearLinearLUT

See Also

Reference

ImGearLUT Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearLUT Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLUT Class

The following tables list the members exposed by ImGearLUT.

Public Properties
 | Name | Description
Public Property | InputDepth | Gets input depth of the LUT.
Public Property | InputIsSigned | Gets a value indicating whether LUT input values are signed.
Public Property | Item | Overloaded. Returns LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Gets output depth of the LUT.
Public Property | OutputIsSigned | Gets a value indicating whether LUT output values are signed.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Public Method | Concatenate | Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearLUT Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLUT Class

For a list of all members of this type, see ImGearLUT members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Public Method | Concatenate | Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Public Method | CopyFrom | Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearLUT Class
ImageGear.Core Namespace


Clone Method (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Clone() As ImGearLUT
'Usage

Dim instance As ImGearLUT
Dim value As ImGearLUT

value = instance.Clone()
public abstract ImGearLUT Clone()
public: abstract ImGearLUT* Clone();
public:
abstract ImGearLUT^ Clone();

Return Value

A new instance of ImGearLUT class object.
Remarks
This method clones ImGearLUT object.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


Concatenate Method (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : Concatenate Method
LUT to be concatenated.
Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Concatenate( _
   ByVal lookupTable As ImGearLUT _
) As ImGearLUT
'Usage

Dim instance As ImGearLUT
Dim lookupTable As ImGearLUT
Dim value As ImGearLUT

value = instance.Concatenate(lookupTable)
public abstract ImGearLUT Concatenate(
   ImGearLUT lookupTable
)
public: abstract ImGearLUT* Concatenate(
   ImGearLUT* lookupTable
)
public:
abstract ImGearLUT^ Concatenate(
   ImGearLUT^ lookupTable
)

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


CopyFrom Method (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : CopyFrom Method
LUT to be copied.
Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub CopyFrom( _
   ByVal lookupTable As ImGearLUT _
)
'Usage

Dim instance As ImGearLUT
Dim lookupTable As ImGearLUT

instance.CopyFrom(lookupTable)
public abstract void CopyFrom(
   ImGearLUT lookupTable
)
public: abstract void CopyFrom(
   ImGearLUT* lookupTable
)
public:
abstract void CopyFrom(
   ImGearLUT^ lookupTable
)

Parameters

lookupTable
LUT to be copied.
Remarks
LUT type and depths attributes must be compatible with the class this method is called from.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


OnPropertyChanged Method (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearLUT
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%% $$Properties$$

ImGearLUT Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLUT Class

For a list of all members of this type, see ImGearLUT members.

Public Properties
 | Name | Description
Public Property | InputDepth | Gets input depth of the LUT.
Public Property | InputIsSigned | Gets a value indicating whether LUT input values are signed.
Public Property | Item | Overloaded. Returns LUT output value corresponding to Int32 input value.
Public Property | OutputDepth | Gets output depth of the LUT.
Public Property | OutputIsSigned | Gets a value indicating whether LUT output values are signed.
Top
See Also

Reference

ImGearLUT Class
ImageGear.Core Namespace


InputDepth Property (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : InputDepth Property
Gets input depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property InputDepth As Integer
'Usage

Dim instance As ImGearLUT
Dim value As Integer

value = instance.InputDepth
public abstract int InputDepth {get;}
public: __property abstract int get_InputDepth();
public:
abstract property int InputDepth {
   int get();
}

Property Value

Any integer number.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


InputIsSigned Property (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : InputIsSigned Property
Gets a value indicating whether LUT input values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property InputIsSigned As Boolean
'Usage

Dim instance As ImGearLUT
Dim value As Boolean

value = instance.InputIsSigned
public abstract bool InputIsSigned {get;}
public: __property abstract bool get_InputIsSigned();
public:
abstract property bool InputIsSigned {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


Item Property (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : Item Property
Returns LUT output value corresponding to Int32 input value.
Overload List
Overload | Description
Item(Int32) | Returns LUT output value corresponding to Int32 input value.
Item(Int64) | Returns LUT output value corresponding to Int64 input value.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


Item(Int32) Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class > Item Property : Item(Int32) Property
Index of the LUT to get.
Returns LUT output value corresponding to Int32 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Property Item( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearLUT
Dim index As Integer
Dim value As Integer

instance.Item(index) = value

value = instance.Item(index)
public abstract int Item(
   int index
) {get; set;}
public: __property abstract int get_Item(
   int index
);
public: __property abstract void set_Item(
   int index,
   int value
);
public:
abstract property int Item {
   int get(int index);
   void set (int index, int value);
}

Parameters

index
Index of the LUT to get.

Property Value

Integer number.
See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


Item(Int64) Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class > Item Property : Item(Int64) Property
Index of the LUT to get.
Returns LUT output value corresponding to Int64 input value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Property Item( _
   ByVal index As Long _
) As Long
'Usage

Dim instance As ImGearLUT
Dim index As Long
Dim value As Long

instance.Item(index) = value

value = instance.Item(index)
public abstract long Item(
   long index
) {get; set;}
public: __property abstract long get_Item(
   long index
);
public: __property abstract void set_Item(
   long index,
   long value
);
public:
abstract property int64 Item {
   int64 get(int64 index);
   void set (int64 index, int64 value);
}

Parameters

index
Index of the LUT to get.

Property Value

Long number.
See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


OutputDepth Property (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : OutputDepth Property
Gets output depth of the LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property OutputDepth As Integer
'Usage

Dim instance As ImGearLUT
Dim value As Integer

value = instance.OutputDepth
public abstract int OutputDepth {get;}
public: __property abstract int get_OutputDepth();
public:
abstract property int OutputDepth {
   int get();
}

Property Value

Any integer number.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


OutputIsSigned Property (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : OutputIsSigned Property
Gets a value indicating whether LUT output values are signed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property OutputIsSigned As Boolean
'Usage

Dim instance As ImGearLUT
Dim value As Boolean

value = instance.OutputIsSigned
public abstract bool OutputIsSigned {get;}
public: __property abstract bool get_OutputIsSigned();
public:
abstract property bool OutputIsSigned {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%% $$Events$$

ImGearLUT Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearLUT Class

For a list of all members of this type, see ImGearLUT members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearLUT Class
ImageGear.Core Namespace


PropertyChanged Event (ImGearLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearLUT Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearLUT
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

ImGearMaskColorChannelInfo Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskColorChannelInfo Class
Represents mask color channel info.
Object Model
ImGearMaskColorChannelInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMaskColorChannelInfo
   Inherits ImGearColorChannelInfo
'Usage

Dim instance As ImGearMaskColorChannelInfo
public class ImGearMaskColorChannelInfo : ImGearColorChannelInfo
public __gc class ImGearMaskColorChannelInfo : public ImGearColorChannelInfo
public ref class ImGearMaskColorChannelInfo : public ImGearColorChannelInfo
Remarks
Class uses regular color space like RGB, CMYK, etc.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearColorChannelInfo
ImageGear.Core.ImGearMaskColorChannelInfo

See Also

Reference

ImGearMaskColorChannelInfo Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMaskColorChannelInfo Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskColorChannelInfo Class

The following tables list the members exposed by ImGearMaskColorChannelInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearMaskColorChannelInfo Constructor | Initializes a new instance of the ImGearMaskColorChannelInfo class using the supplied color channel mode, color space and color value.
Top
Public Properties
 | Name | Description
Public Property | Mode | Gets or sets mask channel mode.
Top
See Also

Reference

ImGearMaskColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearMaskColorChannelInfo Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskColorChannelInfo Class

For a list of all members of this type, see ImGearMaskColorChannelInfo members.

See Also

Reference

ImGearMaskColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMaskColorChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskColorChannelInfo Class : ImGearMaskColorChannelInfo Constructor
Color channel mode.
Color space.
Color value.
Initializes a new instance of the ImGearMaskColorChannelInfo class using the supplied color channel mode, color space and color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mode As ImGearMaskChannelModes, _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal colorValue As ImGearPixel _
)
'Usage

Dim mode As ImGearMaskChannelModes
Dim colorSpace As ImGearColorSpace
Dim colorValue As ImGearPixel

Dim instance As New ImGearMaskColorChannelInfo(mode, colorSpace, colorValue)
public ImGearMaskColorChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearColorSpace colorSpace,
   ImGearPixel colorValue
)
public: ImGearMaskColorChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearColorSpace colorSpace,
   ImGearPixel* colorValue
)
public:
ImGearMaskColorChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearColorSpace colorSpace,
   ImGearPixel^ colorValue
)

Parameters

mode
Color channel mode.
colorSpace
Color space.
colorValue
Color value.
See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members
ImGearMaskChannelModes Enumeration
ImGearColorSpace Structure
ImGearPixel Class


%%PageItemTitle%% $$Properties$$

ImGearMaskColorChannelInfo Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskColorChannelInfo Class

For a list of all members of this type, see ImGearMaskColorChannelInfo members.

Public Properties
 | Name | Description
Public Property | Mode | Gets or sets mask channel mode.
Top
See Also

Reference

ImGearMaskColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearMaskColorChannelInfo Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskColorChannelInfo Class

For a list of all members of this type, see ImGearMaskColorChannelInfo members.

See Also

Reference

ImGearMaskColorChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMaskColorChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskColorChannelInfo Class : ImGearMaskColorChannelInfo Constructor
Overload List
Overload | Description
ImGearMaskColorChannelInfo Constructor | Initializes a new instance of the ImGearMaskColorChannelInfo class using the supplied color channel mode, color space and color value.
See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members


Mode Property (ImGearMaskColorChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskColorChannelInfo Class : Mode Property
Gets or sets mask channel mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As ImGearMaskChannelModes
'Usage

Dim instance As ImGearMaskColorChannelInfo
Dim value As ImGearMaskChannelModes

instance.Mode = value

value = instance.Mode
public ImGearMaskChannelModes Mode {get; set;}
public: __property ImGearMaskChannelModes get_Mode();
public: __property void set_Mode(
   ImGearMaskChannelModes value
);
public:
property ImGearMaskChannelModes Mode {
   ImGearMaskChannelModes get();
   void set (    ImGearMaskChannelModes value);
}

Property Value

ImGearMaskChannelModes enumeration value.
See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members
ImGearMaskChannelModes Enumeration


%%PageItemTitle%%

ImGearMaskSpotChannelInfo Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskSpotChannelInfo Class
Represents a mask spot channel that uses a special (like Pantone) color.
Object Model
ImGearMaskSpotChannelInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMaskSpotChannelInfo
   Inherits ImGearSpotChannelInfo
'Usage

Dim instance As ImGearMaskSpotChannelInfo
public class ImGearMaskSpotChannelInfo : ImGearSpotChannelInfo
public __gc class ImGearMaskSpotChannelInfo : public ImGearSpotChannelInfo
public ref class ImGearMaskSpotChannelInfo : public ImGearSpotChannelInfo
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearSpotChannelInfo
ImageGear.Core.ImGearMaskSpotChannelInfo

See Also

Reference

ImGearMaskSpotChannelInfo Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMaskSpotChannelInfo Class Members
Fields Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskSpotChannelInfo Class

The following tables list the members exposed by ImGearMaskSpotChannelInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearMaskSpotChannelInfo Constructor | Initializes a new instance of the ImGearMaskSpotChannelInfo class by using mode, color space and color value.
Top
Public Properties
 | Name | Description
Public Property | Mode | Gets or sets mask channel mode.
Top
See Also

Reference

ImGearMaskSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearMaskSpotChannelInfo Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskSpotChannelInfo Class

For a list of all members of this type, see ImGearMaskSpotChannelInfo members.

See Also

Reference

ImGearMaskSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMaskSpotChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskSpotChannelInfo Class : ImGearMaskSpotChannelInfo Constructor
ImGearMaskChannelModes value.
Vendor ID of the spot color.
Spot color ID in Vendor's color book.
Initializes a new instance of the ImGearMaskSpotChannelInfo class by using mode, color space and color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mode As ImGearMaskChannelModes, _
   ByVal vendorId As ImGearSpotColorVendorID, _
   ByVal colorId As Long _
)
'Usage

Dim mode As ImGearMaskChannelModes
Dim vendorId As ImGearSpotColorVendorID
Dim colorId As Long

Dim instance As New ImGearMaskSpotChannelInfo(mode, vendorId, colorId)
public ImGearMaskSpotChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearSpotColorVendorID vendorId,
   long colorId
)
public: ImGearMaskSpotChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearSpotColorVendorID vendorId,
   long colorId
)
public:
ImGearMaskSpotChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearSpotColorVendorID vendorId,
   int64 colorId
)

Parameters

mode
ImGearMaskChannelModes value.
vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book.
See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members
ImGearMaskChannelModes Enumeration
ImGearSpotColorVendorID Enumeration


%%PageItemTitle%% $$Properties$$

ImGearMaskSpotChannelInfo Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskSpotChannelInfo Class

For a list of all members of this type, see ImGearMaskSpotChannelInfo members.

Public Properties
 | Name | Description
Public Property | Mode | Gets or sets mask channel mode.
Top
See Also

Reference

ImGearMaskSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMaskSpotChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskSpotChannelInfo Class : ImGearMaskSpotChannelInfo Constructor
Overload List
Overload | Description
ImGearMaskSpotChannelInfo Constructor | Initializes a new instance of the ImGearMaskSpotChannelInfo class by using mode, color space and color value.
See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members


Mode Property (ImGearMaskSpotChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMaskSpotChannelInfo Class : Mode Property
Gets or sets mask channel mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As ImGearMaskChannelModes
'Usage

Dim instance As ImGearMaskSpotChannelInfo
Dim value As ImGearMaskChannelModes

instance.Mode = value

value = instance.Mode
public ImGearMaskChannelModes Mode {get; set;}
public: __property ImGearMaskChannelModes get_Mode();
public: __property void set_Mode(
   ImGearMaskChannelModes value
);
public:
property ImGearMaskChannelModes Mode {
   ImGearMaskChannelModes get();
   void set (    ImGearMaskChannelModes value);
}

Property Value

ImGearMaskChannelModes enumeration value.
See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members
ImGearMaskChannelModes Enumeration


%%PageItemTitle%%

ImGearMetadataDictionary Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataDictionary Class
Provides access to Metadata Dictionary that is used in ImageGear.
Object Model
ImGearMetadataDictionary ClassIImGearMetadataDictRecord Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMetadataDictionary
'Usage

Dim instance As ImGearMetadataDictionary
public class ImGearMetadataDictionary
public __gc class ImGearMetadataDictionary
public ref class ImGearMetadataDictionary
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataDictionary

See Also

Reference

ImGearMetadataDictionary Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataDictionary Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataDictionary Class

The following tables list the members exposed by ImGearMetadataDictionary.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddRecord | This method adds a new record to the dictionary.
static (Shared in Visual Basic) | LookUp | Looks up a record in the dictionary, based on metadata format and tag ID.
static (Shared in Visual Basic) | Reset | Resets the dictionary to its default state, i.e. removes all user added data.
Top
See Also

Reference

ImGearMetadataDictionary Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearMetadataDictionary Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataDictionary Class

For a list of all members of this type, see ImGearMetadataDictionary members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddRecord | This method adds a new record to the dictionary.
static (Shared in Visual Basic) | LookUp | Looks up a record in the dictionary, based on metadata format and tag ID.
static (Shared in Visual Basic) | Reset | Resets the dictionary to its default state, i.e. removes all user added data.
Top
See Also

Reference

ImGearMetadataDictionary Class
ImageGear.Core Namespace


AddRecord Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataDictionary Class : AddRecord Method
Metadata format associated with the record.
New record.
This method adds a new record to the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub AddRecord( _
   ByVal format As ImGearMetadataFormats, _
   ByVal record As IImGearMetadataDictRecord _
)
'Usage

Dim format As ImGearMetadataFormats
Dim record As IImGearMetadataDictRecord

ImGearMetadataDictionary.AddRecord(format, record)
public static void AddRecord(
   ImGearMetadataFormats format,
   IImGearMetadataDictRecord record
)
public: static void AddRecord(
   ImGearMetadataFormats format,
   IImGearMetadataDictRecord* record
)
public:
static void AddRecord(
   ImGearMetadataFormats format,
   IImGearMetadataDictRecord^ record
)

Parameters

format
Metadata format associated with the record.
record
New record.
See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members


LookUp Method (ImGearMetadataDictionary)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataDictionary Class : LookUp Method
Metadata format.
Tag ID value.
Looks up a record in the dictionary, based on metadata format and tag ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function LookUp( _
   ByVal format As ImGearMetadataFormats, _
   ByVal tag As Integer _
) As IImGearMetadataDictRecord
'Usage

Dim format As ImGearMetadataFormats
Dim tag As Integer
Dim value As IImGearMetadataDictRecord

value = ImGearMetadataDictionary.LookUp(format, tag)
public static IImGearMetadataDictRecord LookUp(
   ImGearMetadataFormats format,
   int tag
)
public: static IImGearMetadataDictRecord* LookUp(
   ImGearMetadataFormats format,
   int tag
)
public:
static IImGearMetadataDictRecord^ LookUp(
   ImGearMetadataFormats format,
   int tag
)

Parameters

format
Metadata format.
tag
Tag ID value.

Return Value

IImGearMetadataDictRecord interface object.
See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members
ImGearMetadataFormats Enumeration
IImGearMetadataDictRecord Interface


Reset Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataDictionary Class : Reset Method
Resets the dictionary to its default state, i.e. removes all user added data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Reset()
'Usage

ImGearMetadataDictionary.Reset()
public static void Reset()
public: static void Reset();
public:
static void Reset();
See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members


%%PageItemTitle%%

ImGearMetadataHead Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataHead Class
Head of metadata tree.
Object Model
ImGearMetadataHead ClassImGearMetadataNode ClassImGearMetadataNode ClassImGearCommonMetadata ClassImGearFormatMetadata ClassImGearFormatMetadata ClassImGearFormatMetadata ClassImGearFormatMetadata ClassImGearFormatMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearMetadataHead
   Inherits ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataHead
public sealed class ImGearMetadataHead : ImGearMetadataNode
public __gc __sealed class ImGearMetadataHead : public ImGearMetadataNode
public ref class ImGearMetadataHead sealed : public ImGearMetadataNode
Remarks
ImGearMetadataHead is a special kind of metadata node with a null Parent field and not more than one child. It is present in every instance of ImGearPage class and ImGearDocument class as class member.

If the page or document has metadata, an instance of ImGearMetadataTree class is attached to the head as a child node. Otherwise, Child is null.

ImGearMetadataHead may only be the root of metadata tree. Attempting to attach this class to any node causes ImageGear to throw an exception.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataNode
ImageGear.Core.ImGearMetadataHead

See Also

Reference

ImGearMetadataHead Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataHead Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataHead Class

The following tables list the members exposed by ImGearMetadataHead.

Public Constructors
 | Name | Description
Public Constructor | ImGearMetadataHead Constructor | Overloaded. Initializes a new instance of the ImGearMetadataHead class.
Top
Public Properties
 | Name | Description
Public Property | Child | Gets or sets reference to child node.
Public Property | Common | Gets access to metadata that is common for all format filters.
Public Property | EXIF | Gets or sets simplified access to EXIF metadata.
Public Property | IPTC | Gets or sets simplified access to IPTC metadata.
Public Property | TIFF | Gets or sets simplified access to TIFF metadata.
Public Property | XMP | Gets or sets simplified access to XMP metadata.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | GetAccessor | Get accessor to Simplified Metadata for spesified metadata Format.
Public Method | GetTargetFormat | Returns target format of the page metadata.
Public Method | SetAccessor | Set accessor to Simplified Metadata for spesified metadata Format.
Public Method | SetTargetFormat | Sets target format of the page metadata.
Top
See Also

Reference

ImGearMetadataHead Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearMetadataHead Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataHead Class

For a list of all members of this type, see ImGearMetadataHead members.

See Also

Reference

ImGearMetadataHead Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMetadataHead Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : ImGearMetadataHead Constructor
Initializes a new instance of the ImGearMetadataHead class.
Overload List
Overload | Description
ImGearMetadataHead Constructor(ImGearMetadataFormats) | Initializes a new instance of the ImGearMetadataHead class for the specified format.
ImGearMetadataHead Constructor() | Initializes a new instance of the ImGearMetadataHead class.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

ImGearMetadataHead Constructor(ImGearMetadataFormats)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class > ImGearMetadataHead Constructor : ImGearMetadataHead Constructor(ImGearMetadataFormats)
ImageGear.Formats.ImGearMetadataFormats enum value to specify metadata format.
Initializes a new instance of the ImGearMetadataHead class for the specified format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal format As ImGearMetadataFormats _
)
'Usage

Dim format As ImGearMetadataFormats

Dim instance As New ImGearMetadataHead(format)
public ImGearMetadataHead(
   ImGearMetadataFormats format
)
public: ImGearMetadataHead(
   ImGearMetadataFormats format
)
public:
ImGearMetadataHead(
   ImGearMetadataFormats format
)

Parameters

format
ImageGear.Formats.ImGearMetadataFormats enum value to specify metadata format.
Remarks
Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
Overload List


%%PageItemTitle%%

ImGearMetadataHead Constructor()

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class > ImGearMetadataHead Constructor : ImGearMetadataHead Constructor()
Initializes a new instance of the ImGearMetadataHead class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMetadataHead()
public ImGearMetadataHead()
public: ImGearMetadataHead();
public:
ImGearMetadataHead();
Remarks
Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearMetadataHead Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataHead Class

For a list of all members of this type, see ImGearMetadataHead members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | GetAccessor | Get accessor to Simplified Metadata for spesified metadata Format.
Public Method | GetTargetFormat | Returns target format of the page metadata.
Public Method | SetAccessor | Set accessor to Simplified Metadata for spesified metadata Format.
Public Method | SetTargetFormat | Sets target format of the page metadata.
Top
See Also

Reference

ImGearMetadataHead Class
ImageGear.Core Namespace


Clone Method (ImGearMetadataHead)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearMetadataNode

value = instance.Clone()
public override ImGearMetadataNode Clone()
public: ImGearMetadataNode* Clone(); override
public:
ImGearMetadataNode^ Clone(); override

Return Value

ImGearMetadataNode class object that is a copy of the current instance.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearMetadataNode Class


GetAccessor Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : GetAccessor Method
Metadata format ID to get accessor.
Get accessor to Simplified Metadata for spesified metadata Format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAccessor( _
   ByVal metadataFormat As ImGearMetadataFormats _
) As ImGearFormatMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim metadataFormat As ImGearMetadataFormats
Dim value As ImGearFormatMetadata

value = instance.GetAccessor(metadataFormat)
public ImGearFormatMetadata GetAccessor(
   ImGearMetadataFormats metadataFormat
)
public: ImGearFormatMetadata* GetAccessor(
   ImGearMetadataFormats metadataFormat
)
public:
ImGearFormatMetadata^ GetAccessor(
   ImGearMetadataFormats metadataFormat
)

Parameters

metadataFormat
Metadata format ID to get accessor.

Return Value

ImageGear.Formats.ImGearFormatMetadata class object to simplified metadata access.
Remarks
This method throws ImGearException if the metadata format does not allow access to simplified metadata.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearXMPMetadataRoot Class
ImGearMetadataFormats Enumeration


GetTargetFormat Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : GetTargetFormat Method
Returns target format of the page metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTargetFormat() As ImGearFormats
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearFormats

value = instance.GetTargetFormat()
public ImGearFormats GetTargetFormat()
public: ImGearFormats GetTargetFormat();
public:
ImGearFormats GetTargetFormat();

Return Value

ImageGear.Formats.ImGearFormats enumeration object that is a copy of the current instance.
Remarks
The target format is the file format to which the current metadata tree can be saved. For example, if ImGearPage has been loaded from a JFIF JPEG image, its target format is JPEG. The application can modify metadata tags and save the image back to JPEG; modified metadata will be saved to the resultant file. However, if target format is JPEG, and the image is saved to BMP, metadata modifications will not be saved to the result file, because of incompatibilities with the metadata formats.

The target format can affect the functionality of the Simplified Metadata API. A simplified metadata accessor can be initialized for the metadata tree only if it has a compatible target format. For example, if the target format is TIFF or JPEG, the application can initialize an IPTC accessor for the metadata tree and add IPTC tags. But if target format is BMP, adding an IPTC accessor will result in an exception.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearFormats Enumeration


SetAccessor Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : SetAccessor Method
Metadata format ID to set accessor.
An instance of ImageGear.Formats.ImGearFormatMetadata accessor to set.
Set accessor to Simplified Metadata for spesified metadata Format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAccessor( _
   ByVal metadataFormat As ImGearMetadataFormats, _
   ByVal accessor As ImGearFormatMetadata _
)
'Usage

Dim instance As ImGearMetadataHead
Dim metadataFormat As ImGearMetadataFormats
Dim accessor As ImGearFormatMetadata

instance.SetAccessor(metadataFormat, accessor)
public void SetAccessor(
   ImGearMetadataFormats metadataFormat,
   ImGearFormatMetadata accessor
)
public: void SetAccessor(
   ImGearMetadataFormats metadataFormat,
   ImGearFormatMetadata* accessor
)
public:
void SetAccessor(
   ImGearMetadataFormats metadataFormat,
   ImGearFormatMetadata^ accessor
)

Parameters

metadataFormat
Metadata format ID to set accessor.
accessor
An instance of ImageGear.Formats.ImGearFormatMetadata accessor to set.
Remarks
This method throws ImGearException if the metadata format does not allow access to simplified metadata.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearXMPMetadataRoot Class
ImGearMetadataFormats Enumeration


SetTargetFormat Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : SetTargetFormat Method
ImageGear.Formats.ImGearFormats enumeration value.
Sets target format of the page metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTargetFormat( _
   ByVal format As ImGearFormats _
)
'Usage

Dim instance As ImGearMetadataHead
Dim format As ImGearFormats

instance.SetTargetFormat(format)
public void SetTargetFormat(
   ImGearFormats format
)
public: void SetTargetFormat(
   ImGearFormats format
)
public:
void SetTargetFormat(
   ImGearFormats format
)

Parameters

format
ImageGear.Formats.ImGearFormats enumeration value.
Remarks
If the new target format is the same as current target format, no action is taken. If the new format is different from the current format, the existing metadata is discarded and a new empty tree with specified target format is created.

See GetTargetFormat for details on target format usage.

ImageGear.Formats.ImGearFormats enumeration.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%% $$Properties$$

ImGearMetadataHead Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataHead Class

For a list of all members of this type, see ImGearMetadataHead members.

Public Properties
 | Name | Description
Public Property | Child | Gets or sets reference to child node.
Public Property | Common | Gets access to metadata that is common for all format filters.
Public Property | EXIF | Gets or sets simplified access to EXIF metadata.
Public Property | IPTC | Gets or sets simplified access to IPTC metadata.
Public Property | TIFF | Gets or sets simplified access to TIFF metadata.
Public Property | XMP | Gets or sets simplified access to XMP metadata.
Top
See Also

Reference

ImGearMetadataHead Class
ImageGear.Core Namespace


Child Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : Child Property
Gets or sets reference to child node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Child As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearMetadataNode

instance.Child = value

value = instance.Child
public ImGearMetadataNode Child {get; set;}
public: __property ImGearMetadataNode* get_Child();
public: __property void set_Child(
   ImGearMetadataNode* value
);
public:
property ImGearMetadataNode^ Child {
   ImGearMetadataNode^ get();
   void set (    ImGearMetadataNode^ value);
}

Property Value

ImGearMetadataNode class object. May be null.
Remarks
Value being assigned must be stand-alone (ImGearMetadataNode.Parent == null) and not an instance of ImGearMetadataHead class.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearMetadataNode Class


Common Property (ImGearMetadataHead)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : Common Property
Gets access to metadata that is common for all format filters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Common As ImGearCommonMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearCommonMetadata

value = instance.Common
public ImGearCommonMetadata Common {get;}
public: __property ImGearCommonMetadata* get_Common();
public:
property ImGearCommonMetadata^ Common {
   ImGearCommonMetadata^ get();
}

Property Value

ImageGear.Formats.ImageGear.Formats.ImGearCommonMetadata class object.
Remarks
This property provides access to metadata that is common for all format filters.
See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearCommonMetadata Class


EXIF Property (ImGearMetadataHead)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : EXIF Property
Gets or sets simplified access to EXIF metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EXIF As ImGearFormatMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearFormatMetadata

instance.EXIF = value

value = instance.EXIF
public ImGearFormatMetadata EXIF {get; set;}
public: __property ImGearFormatMetadata* get_EXIF();
public: __property void set_EXIF(
   ImGearFormatMetadata* value
);
public:
property ImGearFormatMetadata^ EXIF {
   ImGearFormatMetadata^ get();
   void set (    ImGearFormatMetadata^ value);
}

Property Value

ImageGear.Formats.EXIF.ImGearEXIFMetadata class object.
Remarks
The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the property returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of ImageGear.Formats.EXIF.ImGearEXIFMetadata class and assigning it to the EXIF property. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearEXIFMetadata Class


IPTC Property (ImGearMetadataHead)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : IPTC Property
Gets or sets simplified access to IPTC metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IPTC As ImGearFormatMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearFormatMetadata

instance.IPTC = value

value = instance.IPTC
public ImGearFormatMetadata IPTC {get; set;}
public: __property ImGearFormatMetadata* get_IPTC();
public: __property void set_IPTC(
   ImGearFormatMetadata* value
);
public:
property ImGearFormatMetadata^ IPTC {
   ImGearFormatMetadata^ get();
   void set (    ImGearFormatMetadata^ value);
}

Property Value

ImageGear.Formats.IPTC.ImGearIPTCMetadata class object.
Remarks
The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the property returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of ImageGear.Formats.IPTC.ImGearIPTCMetadata class and assigning it to the IPTC property. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearIPTCMetadata Class


TIFF Property (ImGearMetadataHead)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : TIFF Property
Gets or sets simplified access to TIFF metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TIFF As ImGearFormatMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearFormatMetadata

instance.TIFF = value

value = instance.TIFF
public ImGearFormatMetadata TIFF {get; set;}
public: __property ImGearFormatMetadata* get_TIFF();
public: __property void set_TIFF(
   ImGearFormatMetadata* value
);
public:
property ImGearFormatMetadata^ TIFF {
   ImGearFormatMetadata^ get();
   void set (    ImGearFormatMetadata^ value);
}

Property Value

ImageGear.Formats.TIF.ImGearTIFFMetadata class object.
Remarks
The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the property returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of ImageGear.Formats.TIF.ImGearTIFFMetadata class and assigning it to the TIFF property. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearTIFFMetadata Class


XMP Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataHead Class : XMP Property
Gets or sets simplified access to XMP metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XMP As ImGearFormatMetadata
'Usage

Dim instance As ImGearMetadataHead
Dim value As ImGearFormatMetadata

instance.XMP = value

value = instance.XMP
public ImGearFormatMetadata XMP {get; set;}
public: __property ImGearFormatMetadata* get_XMP();
public: __property void set_XMP(
   ImGearFormatMetadata* value
);
public:
property ImGearFormatMetadata^ XMP {
   ImGearFormatMetadata^ get();
   void set (    ImGearFormatMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPMetadataRoot class value.
Remarks
The property returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of ImageGear.Formats.XMP.ImGearXMPMetadataRoot class and assigning it to the XMP property. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS, GIF, PNG, JP2 and JPX.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
ImGearXMPMetadataRoot Class


%%PageItemTitle%%

ImGearMetadataLeaf Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataLeaf Class
Represents metadata node that contains a data value and cannot reference other metadata nodes.
Object Model
ImGearMetadataLeaf ClassImGearMetadataNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearMetadataLeaf
   Inherits ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataLeaf
public sealed class ImGearMetadataLeaf : ImGearMetadataNode
public __gc __sealed class ImGearMetadataLeaf : public ImGearMetadataNode
public ref class ImGearMetadataLeaf sealed : public ImGearMetadataNode
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataNode
ImageGear.Core.ImGearMetadataLeaf

See Also

Reference

ImGearMetadataLeaf Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataLeaf Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataLeaf Class

The following tables list the members exposed by ImGearMetadataLeaf.

Public Constructors
 | Name | Description
Public Constructor | ImGearMetadataLeaf Constructor | Overloaded. Initializes a new instance of the ImGearMetadataLeaf class.
Top
Public Fields
 | Name | Description
Public Field | NativeType | Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets reference to opaque data stored in leaf. Type of object returned by this property depends on value of NativeType field.
Public Property | IgnoredOnSave | Gets a value indicating whether current node should be ignored during page/document saving or not.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | IsValidDataObject | Indicates whether the data type of an object is valid (supported by metadata leaf).
Top
See Also

Reference

ImGearMetadataLeaf Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMetadataLeaf Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : ImGearMetadataLeaf Constructor
Initializes a new instance of the ImGearMetadataLeaf class.
Overload List
Overload | Description
ImGearMetadataLeaf Constructor() | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean,String) | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean) | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

ImGearMetadataLeaf Constructor()

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor()
Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMetadataLeaf()
public ImGearMetadataLeaf()
public: ImGearMetadataLeaf();
public:
ImGearMetadataLeaf();
Remarks
It is good for several leaves to refer to the same data object.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%%

ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean,String)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean,String)
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Represents identifier of metadata for particular file format.
Actual data to be stored in metadata node.
Identifier of attached data type.
Specifies whether node should be ignored during page (document) saving or not.
Name of the leaf.
Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal format As ImGearMetadataFormats, _
   ByVal tag As Integer, _
   ByVal data As Object, _
   ByVal nativeType As Object, _
   ByVal ignoredOnSave As Boolean, _
   ByVal name As String _
)
'Usage

Dim format As ImGearMetadataFormats
Dim tag As Integer
Dim data As Object
Dim nativeType As Object
Dim ignoredOnSave As Boolean
Dim name As String

Dim instance As New ImGearMetadataLeaf(format, tag, data, nativeType, ignoredOnSave, name)
public ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   object data,
   object nativeType,
   bool ignoredOnSave,
   string name
)
public: ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   Object* data,
   Object* nativeType,
   bool ignoredOnSave,
   string* name
)
public:
ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   Object^ data,
   Object^ nativeType,
   bool ignoredOnSave,
   String^ name
)

Parameters

format
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
nativeType
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.
name
Name of the leaf.

Return Value

A new instance of ImGearMetadataLeaf class.
Remarks
It is good for several leaves to refer to the same data object.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%%

ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor(ImGearMetadataFormats,Int32,Object,Object,Boolean)
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Represents identifier of metadata for particular file format.
Actual data to be stored in metadata node.
Identifier of attached data type.
Specifies whether node should be ignored during page (document) saving or not.
Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of ImageGear.Formats.ImGearNativeDataTypes enum.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal format As ImGearMetadataFormats, _
   ByVal tag As Integer, _
   ByVal data As Object, _
   ByVal nativeType As Object, _
   ByVal ignoredOnSave As Boolean _
)
'Usage

Dim format As ImGearMetadataFormats
Dim tag As Integer
Dim data As Object
Dim nativeType As Object
Dim ignoredOnSave As Boolean

Dim instance As New ImGearMetadataLeaf(format, tag, data, nativeType, ignoredOnSave)
public ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   object data,
   object nativeType,
   bool ignoredOnSave
)
public: ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   Object* data,
   Object* nativeType,
   bool ignoredOnSave
)
public:
ImGearMetadataLeaf(
   ImGearMetadataFormats format,
   int tag,
   Object^ data,
   Object^ nativeType,
   bool ignoredOnSave
)

Parameters

format
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
nativeType
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.
Remarks
It is good for several leaves to refer to the same data object.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearMetadataLeaf Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataLeaf Class

For a list of all members of this type, see ImGearMetadataLeaf members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | IsValidDataObject | Indicates whether the data type of an object is valid (supported by metadata leaf).
Top
See Also

Reference

ImGearMetadataLeaf Class
ImageGear.Core Namespace


Clone Method (ImGearMetadataLeaf)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataLeaf
Dim value As ImGearMetadataNode

value = instance.Clone()
public override ImGearMetadataNode Clone()
public: ImGearMetadataNode* Clone(); override
public:
ImGearMetadataNode^ Clone(); override

Return Value

ImGearMetadataNode class object that is a copy of the current instance.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


IsValidDataObject Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : IsValidDataObject Method
The data to be validated.
Indicates whether the data type of an object is valid (supported by metadata leaf).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function IsValidDataObject( _
   ByVal value As Object _
) As Boolean
'Usage

Dim value As Object
Dim value As Boolean

value = ImGearMetadataLeaf.IsValidDataObject(value)
public static bool IsValidDataObject(
   object value
)
public: static bool IsValidDataObject(
   Object* value
)
public:
static bool IsValidDataObject(
   Object^ value
)

Parameters

value
The data to be validated.

Return Value

Boolean value.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%% $$Properties$$

ImGearMetadataLeaf Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataLeaf Class

For a list of all members of this type, see ImGearMetadataLeaf members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets reference to opaque data stored in leaf. Type of object returned by this property depends on value of NativeType field.
Public Property | IgnoredOnSave | Gets a value indicating whether current node should be ignored during page/document saving or not.
Top
See Also

Reference

ImGearMetadataLeaf Class
ImageGear.Core Namespace


Data Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : Data Property
Gets or sets reference to opaque data stored in leaf. Type of object returned by this property depends on value of NativeType field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As Object
'Usage

Dim instance As ImGearMetadataLeaf
Dim value As Object

instance.Data = value

value = instance.Data
public object Data {get; set;}
public: __property Object* get_Data();
public: __property void set_Data(
   Object* value
);
public:
property Object^ Data {
   Object^ get();
   void set (    Object^ value);
}

Property Value

System.Object value.
Remarks
Represents (meta) data assigned to metadata node as System.Object. The following types of objects are allowed to be stored:
  • System.ValueType
  • System.String
  • System.Array

Otherwise, an exception will be thrown.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


IgnoredOnSave Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : IgnoredOnSave Property
Gets a value indicating whether current node should be ignored during page/document saving or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IgnoredOnSave As Boolean
'Usage

Dim instance As ImGearMetadataLeaf
Dim value As Boolean

value = instance.IgnoredOnSave
public bool IgnoredOnSave {get;}
public: __property bool get_IgnoredOnSave();
public:
property bool IgnoredOnSave {
   bool get();
}

Property Value

Boolean value.
Remarks
If this property is set to true, data contained in ImGearMetadataLeaf is ignored during image saving and data from the medatada container (page or document) will be used instead.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%% $$Fields$$

ImGearMetadataLeaf Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataLeaf Class

For a list of all members of this type, see ImGearMetadataLeaf members.

Public Fields
 | Name | Description
Public Field | NativeType | Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.
Top
See Also

Reference

ImGearMetadataLeaf Class
ImageGear.Core Namespace


NativeType Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataLeaf Class : NativeType Field
Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NativeType As Object
'Usage

Dim instance As ImGearMetadataLeaf
Dim value As Object

value = instance.NativeType

instance.NativeType = value
public object NativeType
public: Object* NativeType
public:
Object^ NativeType

Field Value

ImageGear.Formats.ImGearNativeDataTypes or ImageGear.Formats.DICOM.ImGearDICOMValueRepresentations enumeration value, passed as System.Object.
Remarks

When metadata is loaded from a file, all leaves have this field set to explicit values.

When the application creates a leaf, it can either specify an explicit NativeType value or use the default value ImageGear.Formats.ImGearNativeDataTypes.UNKNOWN.

At the time of image saving, most file formats ignore this field and use the file format's standard types for metadata tags. Two file formats take NativeType field into account:

  • TIFF format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is ImageGear.Formats.ImGearNativeDataTypes.UNKNOWN, TIFF filter skips the tag.
  • DICOM format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is ImageGear.Formats.ImGearNativeDataTypes.UNKNOWN, DICOM filter looks up the native type from its Data Dictionary. If the value is not found, it saves the tag as ImageGear.Formats.DICOM.ImGearDICOMValueRepresentations.Unknown.
See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

ImGearMetadataNode Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNode Class
Provides generic functionality for the ImageGear metadata objects.
Object Model
ImGearMetadataNode ClassImGearMetadataNode ClassImGearMetadataNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNode
public abstract class ImGearMetadataNode
public __gc abstract class ImGearMetadataNode
public ref class ImGearMetadataNode abstract
Remarks
An ImGearMetadataNode can be referenced from one parent node or can be unreferenced. It cannot however be referenced from multiple parents. A node can never refer to itself either directly or indirectly.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataNode
ImageGear.Core.ImGearMetadataHead
ImageGear.Core.ImGearMetadataLeaf
ImageGear.Core.ImGearMetadataTree

See Also

Reference

ImGearMetadataNode Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataNode Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNode Class

The following tables list the members exposed by ImGearMetadataNode.

Public Fields
 | Name | Description
Public Field | Format | Identifier of the File format to which the metadata belongs.
Public Field | Tag | Represents identifier of metadata node for particular file format.
Top
Protected Fields
 | Name | Description
Protected Field | m_name | Returns string name of tag.
Top
Public Properties
 | Name | Description
Public Property | FormatName | Gets the name of the type of the file format to which metadata belongs.
Public Property | Name | Gets or sets returns string name of tag.
Public Property | Parent | Gets reference to parent node.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImGearMetadataNode Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearMetadataNode Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNode Class

For a list of all members of this type, see ImGearMetadataNode members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImGearMetadataNode Class
ImageGear.Core Namespace


Clone Method (ImGearMetadataNode)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Clone() As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNode
Dim value As ImGearMetadataNode

value = instance.Clone()
public abstract ImGearMetadataNode Clone()
public: abstract ImGearMetadataNode* Clone();
public:
abstract ImGearMetadataNode^ Clone();

Return Value

ImGearMetadataNode class that is a copy of the current instance.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


CompareTo Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : CompareTo Method
An object to compare with this instance.
Compares the current instance with another object of the same type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
'Usage

Dim instance As ImGearMetadataNode
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
public int CompareTo(
   object obj
)
public: int CompareTo(
   Object* obj
)
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Value

Following values defined:
  • -1 - This instance is less than obj.
  • 0 - This instance is equal to obj.
  • 1 - This instance is greater than obj.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%% $$Properties$$

ImGearMetadataNode Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNode Class

For a list of all members of this type, see ImGearMetadataNode members.

Public Properties
 | Name | Description
Public Property | FormatName | Gets the name of the type of the file format to which metadata belongs.
Public Property | Name | Gets or sets returns string name of tag.
Public Property | Parent | Gets reference to parent node.
Top
See Also

Reference

ImGearMetadataNode Class
ImageGear.Core Namespace


FormatName Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : FormatName Property
Gets the name of the type of the file format to which metadata belongs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FormatName As String
'Usage

Dim instance As ImGearMetadataNode
Dim value As String

value = instance.FormatName
public string FormatName {get;}
public: __property string* get_FormatName();
public:
property String^ FormatName {
   String^ get();
}

Property Value

Any string name of format.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


Name Property (ImGearMetadataNode)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : Name Property
Gets or sets returns string name of tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearMetadataNode
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

String identifier of medatada tag.
Remarks
Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for .NET.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


Parent Property (ImGearMetadataNode)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : Parent Property
Gets reference to parent node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNode
Dim value As ImGearMetadataNode

value = instance.Parent
public ImGearMetadataNode Parent {get;}
public: __property ImGearMetadataNode* get_Parent();
public:
property ImGearMetadataNode^ Parent {
   ImGearMetadataNode^ get();
}

Property Value

ImGearMetadataNode class object.
Remarks
Specifies reference to parent node in metadata tree. This property may be null. Accordingly, the instance is stand-alone (not attached), or otherwise, has special type like ImGearMetadataHead.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%% $$Fields$$

ImGearMetadataNode Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNode Class

For a list of all members of this type, see ImGearMetadataNode members.

Public Fields
 | Name | Description
Public Field | Format | Identifier of the File format to which the metadata belongs.
Public Field | Tag | Represents identifier of metadata node for particular file format.
Top
Protected Fields
 | Name | Description
Protected Field | m_name | Returns string name of tag.
Top
See Also

Reference

ImGearMetadataNode Class
ImageGear.Core Namespace


Format Field (ImGearMetadataNode)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : Format Field
Identifier of the File format to which the metadata belongs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Format As ImGearMetadataFormats
'Usage

Dim instance As ImGearMetadataNode
Dim value As ImGearMetadataFormats

value = instance.Format

instance.Format = value
public ImGearMetadataFormats Format
public: ImGearMetadataFormats Format
public:
ImGearMetadataFormats Format

Field Value

ImageGear.Formats.ImGearMetadataFormats enumeration
Remarks

It is possible for a metadata tree to contain subtrees defined in another metadata format. For example, JPEG metadata tree may contain subtrees containing EXIF or IPTC metadata.

ImageGear.Formats.ImGearFormats.UNKNOWN means custom (unknown) format.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members
ImGearMetadataFormats Enumeration


m_name Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : m_name Field
Returns string name of tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_name As String
'Usage

Dim instance As ImGearMetadataNode
Dim value As String

value = instance.m_name

instance.m_name = value
protected string m_name
protected: string* m_name
protected:
String^ m_name

Field Value

String identifier of medatada tag.
Remarks
Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for .NET.
See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


Tag Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNode Class : Tag Field
Represents identifier of metadata node for particular file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Tag As Integer
'Usage

Dim instance As ImGearMetadataNode
Dim value As Integer

value = instance.Tag

instance.Tag = value
public int Tag
public: int Tag
public:
int Tag

Field Value

Integer value
Remarks
Identifies what kind of data is stored in metadata node. Specific for particular file format.

Values for the tags are taken from tag list of file formats, represented in ImageGear for .NET as ImGearFORMATTagIDs (where FORMAT is BMP, TIFF, etc.) enumerations.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

ImGearMetadataNodeList Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNodeList Class
Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.
Object Model
ImGearMetadataNodeList ClassImGearMetadataNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearMetadataNodeList
'Usage

Dim instance As ImGearMetadataNodeList
[DefaultMember("Item")]
public sealed class ImGearMetadataNodeList
[DefaultMember("Item")]
public __gc __sealed class ImGearMetadataNodeList
[DefaultMember("Item")]
public ref class ImGearMetadataNodeList sealed
Remarks
Represents container (list) of ImGearMetadataNode instances and provides additional verifications for stored objects. For example, on adding, new MetadataNode is checked to be non-null, stand-alone (ImGearMetadataNode.Parent == null) and not the same as the top node of the tree to which it is added.

Nodes with different Format values are allowed to be present in the same list. Multiple nodes with the same Tag value are also allowed. The list is not sorted automatically because the order of items may be significant for a particular format.

This class does not have any public constructor. Instances exist only as members of ImGearMetadataTree objects.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataNodeList

See Also

Reference

ImGearMetadataNodeList Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataNodeList Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNodeList Class

The following tables list the members exposed by ImGearMetadataNodeList.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the List.
Public Property | IsFixedSize | Gets a value indicating whether the List has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the List is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the List is synchronized (thread-safe).
Public Property | Item | Provides access to single node within the node list.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the List.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a node to the list.
Public Method | AddOrdered | Adds a node to the list.
Public Method | Clear | Clears the list.
Public Method | Clone | Clones the list.
Public Method | Contains | Checks whether or not the list contains the specified node.
Public Method | CopyTo | Copies the list to the specified array at the specified position.
Public Method | GetEnumerator | Returns enumerator for the collection.
Public Method | IndexOf | Returns index of the node.
Public Method | Insert | Inserts a node at the specified position.
Public Method | LookUp | Overloaded. Searches the node list for a node which Tag is equal to the specified tag ID.
Public Method | LookUpLeaf | Overloaded. This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a leaf is not present, the method returns null. The method does not search in the subtrees of the node list.
Public Method | RecursiveSort | Sorts the list items recursively so that items within each level are sorted.
Public Method | Remove | Overloaded. Removes the specified node.
Public Method | RemoveAt | Removes the node at the specified index.
Public Method | Sort | Sorts the list items.
Top
See Also

Reference

ImGearMetadataNodeList Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearMetadataNodeList Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNodeList Class

For a list of all members of this type, see ImGearMetadataNodeList members.

Public Methods
 | Name | Description
Public Method | Add | Adds a node to the list.
Public Method | AddOrdered | Adds a node to the list.
Public Method | Clear | Clears the list.
Public Method | Clone | Clones the list.
Public Method | Contains | Checks whether or not the list contains the specified node.
Public Method | CopyTo | Copies the list to the specified array at the specified position.
Public Method | GetEnumerator | Returns enumerator for the collection.
Public Method | IndexOf | Returns index of the node.
Public Method | Insert | Inserts a node at the specified position.
Public Method | LookUp | Overloaded. Searches the node list for a node which Tag is equal to the specified tag ID.
Public Method | LookUpLeaf | Overloaded. This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a leaf is not present, the method returns null. The method does not search in the subtrees of the node list.
Public Method | RecursiveSort | Sorts the list items recursively so that items within each level are sorted.
Public Method | Remove | Overloaded. Removes the specified node.
Public Method | RemoveAt | Removes the node at the specified index.
Public Method | Sort | Sorts the list items.
Top
See Also

Reference

ImGearMetadataNodeList Class
ImageGear.Core Namespace


Add Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Add Method
The ImGearMetadataNode to add.
Adds a node to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal node As ImGearMetadataNode _
) As Integer
'Usage

Dim instance As ImGearMetadataNodeList
Dim node As ImGearMetadataNode
Dim value As Integer

value = instance.Add(node)
public int Add(
   ImGearMetadataNode node
)
public: int Add(
   ImGearMetadataNode* node
)
public:
int Add(
   ImGearMetadataNode^ node
)

Parameters

node
The ImGearMetadataNode to add.

Return Value

The index of the ImGearMetadataNode added.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


AddOrdered Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : AddOrdered Method
The node to add.
Adds a node to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AddOrdered( _
   ByVal node As ImGearMetadataNode _
) As Integer
'Usage

Dim instance As ImGearMetadataNodeList
Dim node As ImGearMetadataNode
Dim value As Integer

value = instance.AddOrdered(node)
public int AddOrdered(
   ImGearMetadataNode node
)
public: int AddOrdered(
   ImGearMetadataNode* node
)
public:
int AddOrdered(
   ImGearMetadataNode^ node
)

Parameters

node
The node to add.

Return Value

Index of added node.
Remarks
This method adds a node to the end of the list. If there are already tags with this ID, put new tag after existing ones.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


Clear Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Clear Method
Clears the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearMetadataNodeList

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


Clone Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Clone Method
Clones the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearMetadataNodeList
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As ImGearMetadataNodeList

value = instance.Clone()
public ImGearMetadataNodeList Clone()
public: ImGearMetadataNodeList* Clone();
public:
ImGearMetadataNodeList^ Clone();

Return Value

ImGearMetadataNodeList class object.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


Contains Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Contains Method
The specified node.
Checks whether or not the list contains the specified node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal node As ImGearMetadataNode _
) As Boolean
'Usage

Dim instance As ImGearMetadataNodeList
Dim node As ImGearMetadataNode
Dim value As Boolean

value = instance.Contains(node)
public bool Contains(
   ImGearMetadataNode node
)
public: bool Contains(
   ImGearMetadataNode* node
)
public:
bool Contains(
   ImGearMetadataNode^ node
)

Parameters

node
The specified node.

Return Value

Boolean value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


CopyTo Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : CopyTo Method
The specified array.
The specified position.
Copies the list to the specified array at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Array array,
   int index
)
public: void CopyTo(
   Array* array,
   int index
)
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
The specified array.
index
The specified position.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


GetEnumerator Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : GetEnumerator Method
Returns enumerator for the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


IndexOf Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : IndexOf Method
The specified node.
Returns index of the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal node As ImGearMetadataNode _
) As Integer
'Usage

Dim instance As ImGearMetadataNodeList
Dim node As ImGearMetadataNode
Dim value As Integer

value = instance.IndexOf(node)
public int IndexOf(
   ImGearMetadataNode node
)
public: int IndexOf(
   ImGearMetadataNode* node
)
public:
int IndexOf(
   ImGearMetadataNode^ node
)

Parameters

node
The specified node.

Return Value

Integer value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


Insert Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Insert Method
The specified position.
The node to insert.
Inserts a node at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal node As ImGearMetadataNode _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim index As Integer
Dim node As ImGearMetadataNode

instance.Insert(index, node)
public void Insert(
   int index,
   ImGearMetadataNode node
)
public: void Insert(
   int index,
   ImGearMetadataNode* node
)
public:
void Insert(
   int index,
   ImGearMetadataNode^ node
)

Parameters

index
The specified position.
node
The node to insert.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


LookUp Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : LookUp Method
Searches the node list for a node which Tag is equal to the specified tag ID.
Overload List
Overload | Description
LookUp(Int32) | Searches the node list for a node which Tag is equal to the specified tag ID.
LookUp(Enum) | Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.
LookUp(String) | Searches the node list for a node whose Name is equal to the specified string value.
LookUp(Enum[]) | Searches the node list recursively for a node, according to the path parameter.
LookUp(String[]) | This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a node is not present, the method returns null. The method does not search in the subtrees of the node list.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


LookUp(Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUp Method : LookUp(Int32) Method
Tag ID to search for.
Searches the node list for a node which Tag is equal to the specified tag ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUp( _
   ByVal tag As Integer _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim tag As Integer
Dim value As ImGearMetadataNode

value = instance.LookUp(tag)
public ImGearMetadataNode LookUp(
   int tag
)
public: ImGearMetadataNode* LookUp(
   int tag
)
public:
ImGearMetadataNode^ LookUp(
   int tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataNode class object.
Remarks
If the list contains several nodes with this tag ID, the method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
ImGearMetadataNode Class


LookUp(Enum) Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUp Method : LookUp(Enum) Method
Tag ID to search for.
Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUp( _
   ByVal tag As Enum _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim tag As Enum
Dim value As ImGearMetadataNode

value = instance.LookUp(tag)
public ImGearMetadataNode LookUp(
   Enum tag
)
public: ImGearMetadataNode* LookUp(
   Enum* tag
)
public:
ImGearMetadataNode^ LookUp(
   Enum^ tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataNode class object.
Remarks
If the list contains several nodes with this tag ID, method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

Example
  • C#
ImGearMetadataTree rootTree = (ImGearMetadataTree)page.Metadata.Child;
ImGearMetadataNode node = rootTree.Children.LookUp(ImGearBMPTagIDs.BITCOUNT);
  • Visual Basic
Dim rootTree As ImGearMetadataTree = igPage.Metadata.Child
Dim node As ImGearMetadataNode = rootTree.Children.LookUp(CInt(ImGearBMPTagIDs.BITCOUNT))
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


LookUp(String) Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUp Method : LookUp(String) Method
Tag Name for which to search.
Searches the node list for a node whose Name is equal to the specified string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUp( _
   ByVal name As String _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim name As String
Dim value As ImGearMetadataNode

value = instance.LookUp(name)
public ImGearMetadataNode LookUp(
   string name
)
public: ImGearMetadataNode* LookUp(
   string* name
)
public:
ImGearMetadataNode^ LookUp(
   String^ name
)

Parameters

name
Tag Name for which to search.

Return Value

ImGearMetadataNode class object.
Remarks
If the list contains several nodes with this Name, method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

Example
  • C#
ImGearMetadataTree rootTree = (ImGearMetadataTree)page.Metadata.Child;
ImGearMetadataNode node = rootTree.Children.LookUp("ImageWidth");
  • Visual Basic
Dim rootTree As ImGearMetadataTree = igPage.Metadata.Child
Dim node As ImGearMetadataNode = rootTree.Children.LookUp("ImageWidth")
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
ImGearMetadataNode Class


LookUp(Enum[]) Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUp Method : LookUp(Enum[]) Method
Path to a data element in the metadata structure.
Searches the node list recursively for a node, according to the path parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUp( _
   ByVal path() As Enum _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim path() As Enum
Dim value As ImGearMetadataNode

value = instance.LookUp(path)
public ImGearMetadataNode LookUp(
   Enum[] path
)
public: ImGearMetadataNode* LookUp(
   Enum*[]* path
)
public:
ImGearMetadataNode^ LookUp(
   array<Enum^>^ path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataNode class object.
Remarks
Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

Example
  • C#
System.Enum[] path = new Enum[]
 {
     ImGearDICOMTagsIDs.DataSet,
     ImGearDICOMTagsIDs.DeviceSequence,
     ImGearDICOMTagsIDs.Item,
     ImGearDICOMTagsIDs.CodeValue
 };
ImGearMetadataNode Node = rootNode.Children.LookUp(path);
  • Visual Basic
Dim path(3) As System.Enum
path(0) = ImGearDICOMTagsIDs.DataSet
path(1) = ImGearDICOMTagsIDs.DeviceSequence
path(2) = ImGearDICOMTagsIDs.Item
path(3) = ImGearDICOMTagsIDs.CodeValue
Dim Node As ImGearMetadataNode = rootNode.Children.LookUp(path)
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
IImGearMetadataDictRecord Interface


LookUp(String[]) Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUp Method : LookUp(String[]) Method
Path to a data element in the metadata structure.
This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUp( _
   ByVal path() As String _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim path() As String
Dim value As ImGearMetadataNode

value = instance.LookUp(path)
public ImGearMetadataNode LookUp(
   string[] path
)
public: ImGearMetadataNode* LookUp(
   string*[]* path
)
public:
ImGearMetadataNode^ LookUp(
   array<String^>^ path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataNode class object.
Example
  • C#
ImGearMetadataNode Node = rootNode.Children.LookUp(ImGearDICOMTagsIDs.DataSet);
  • Visual Basic
'Use CType in VB.Net to help the compiler choose the correct overload.
Dim Node As ImGearMetadataNode = rootNode.Children.LookUp(CType(ImGearDICOMTagsIDs.DataSet, System.Enum))
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
IImGearMetadataDictRecord Interface


LookUpLeaf Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : LookUpLeaf Method
This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

Overload List
Overload | Description
LookUpLeaf(String[]) | This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a leaf is not present, the method returns null. The method does not search in the subtrees of the node list.
LookUpLeaf(Int32) | Searches the leaf list for a node which Tag is equal to the specified tag ID.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


LookUpLeaf(String[]) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUpLeaf Method : LookUpLeaf(String[]) Method
Path to a data element in the metadata structure.
This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUpLeaf( _
   ByVal path() As String _
) As ImGearMetadataLeaf
'Usage

Dim instance As ImGearMetadataNodeList
Dim path() As String
Dim value As ImGearMetadataLeaf

value = instance.LookUpLeaf(path)
public ImGearMetadataLeaf LookUpLeaf(
   string[] path
)
public: ImGearMetadataLeaf* LookUpLeaf(
   string*[]* path
)
public:
ImGearMetadataLeaf^ LookUpLeaf(
   array<String^>^ path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataLeaf class object.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
IImGearMetadataDictRecord Interface


LookUpLeaf(Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > LookUpLeaf Method : LookUpLeaf(Int32) Method
Tag ID to search for.
Searches the leaf list for a node which Tag is equal to the specified tag ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function LookUpLeaf( _
   ByVal tag As Integer _
) As ImGearMetadataLeaf
'Usage

Dim instance As ImGearMetadataNodeList
Dim tag As Integer
Dim value As ImGearMetadataLeaf

value = instance.LookUpLeaf(tag)
public ImGearMetadataLeaf LookUpLeaf(
   int tag
)
public: ImGearMetadataLeaf* LookUpLeaf(
   int tag
)
public:
ImGearMetadataLeaf^ LookUpLeaf(
   int tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataLeaf class object.
Remarks
If the list contains several leafs with this tag ID, the method returns the first leaf. If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
ImGearMetadataNode Class


RecursiveSort Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : RecursiveSort Method
Sorts the list items recursively so that items within each level are sorted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RecursiveSort()
'Usage

Dim instance As ImGearMetadataNodeList

instance.RecursiveSort()
public void RecursiveSort()
public: void RecursiveSort();
public:
void RecursiveSort();
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


Remove Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Remove Method
Removes the specified node.
Overload List
Overload | Description
Remove(ImGearMetadataNode) | Removes the specified node.
Remove(Int32) | Removes the node with the specified ID.
Remove(String) | Removes the node whose name is equal to the specified string value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


Remove(ImGearMetadataNode) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > Remove Method : Remove(ImGearMetadataNode) Method
The node to remove.
Removes the specified node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal node As ImGearMetadataNode _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim node As ImGearMetadataNode

instance.Remove(node)
public void Remove(
   ImGearMetadataNode node
)
public: void Remove(
   ImGearMetadataNode* node
)
public:
void Remove(
   ImGearMetadataNode^ node
)

Parameters

node
The node to remove.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
ImGearMetadataNode Class


Remove(Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > Remove Method : Remove(Int32) Method
The ID of the node to remove.
Removes the node with the specified ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal id As Integer _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim id As Integer

instance.Remove(id)
public void Remove(
   int id
)
public: void Remove(
   int id
)
public:
void Remove(
   int id
)

Parameters

id
The ID of the node to remove.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


Remove(String) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class > Remove Method : Remove(String) Method
The name of the node to remove.
Removes the node whose name is equal to the specified string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim name As String

instance.Remove(name)
public void Remove(
   string name
)
public: void Remove(
   string* name
)
public:
void Remove(
   String^ name
)

Parameters

name
The name of the node to remove.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


RemoveAt Method (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : RemoveAt Method
The specified index.
Removes the node at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearMetadataNodeList
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
The specified index.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


Sort Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Sort Method
Sorts the list items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Sort()
'Usage

Dim instance As ImGearMetadataNodeList

instance.Sort()
public void Sort()
public: void Sort();
public:
void Sort();
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%% $$Properties$$

ImGearMetadataNodeList Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataNodeList Class

For a list of all members of this type, see ImGearMetadataNodeList members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the List.
Public Property | IsFixedSize | Gets a value indicating whether the List has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the List is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the List is synchronized (thread-safe).
Public Property | Item | Provides access to single node within the node list.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the List.
Top
See Also

Reference

ImGearMetadataNodeList Class
ImageGear.Core Namespace


Count Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Count Property
Gets the number of elements contained in the List.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


IsFixedSize Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : IsFixedSize Property
Gets a value indicating whether the List has a fixed size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As Boolean

value = instance.IsFixedSize
public bool IsFixedSize {get;}
public: __property bool get_IsFixedSize();
public:
property bool IsFixedSize {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


IsReadOnly Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : IsReadOnly Property
Gets a value indicating whether the List is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As Boolean

value = instance.IsReadOnly
public bool IsReadOnly {get;}
public: __property bool get_IsReadOnly();
public:
property bool IsReadOnly {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


IsSynchronized Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : IsSynchronized Property
Gets a value indicating whether access to the List is synchronized (thread-safe).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


Item Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : Item Property
Index of the node to get or set.
Provides access to single node within the node list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataNodeList
Dim index As Integer
Dim value As ImGearMetadataNode

instance.Item(index) = value

value = instance.Item(index)
public ImGearMetadataNode this[
   int index
]; {get; set;}
public: __property ImGearMetadataNode* get_Item   int index
;
public: __property void set_Item   int index,
   ImGearMetadataNode* value
;
public:
property ImGearMetadataNode^ default [int] {
   ImGearMetadataNode^ get(int index);
   void set (int index, ImGearMetadataNode^ value);
}

Parameters

index
Index of the node to get or set.

Property Value

ImGearMetadataNode class object.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
ImGearMetadataNode Class


SyncRoot Property (ImGearMetadataNodeList)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataNodeList Class : SyncRoot Property
Gets an object that can be used to synchronize access to the List.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearMetadataNodeList
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object that can be used to synchronize access to the List.
See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

ImGearMetadataTree Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataTree Class
Encapsulates entity of file format metadata tree.
Object Model
ImGearMetadataTree ClassImGearMetadataNodeList ClassImGearMetadataNode ClassImGearMetadataNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearMetadataTree
   Inherits ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataTree
public sealed class ImGearMetadataTree : ImGearMetadataNode
public __gc __sealed class ImGearMetadataTree : public ImGearMetadataNode
public ref class ImGearMetadataTree sealed : public ImGearMetadataNode
Remarks
Represents metadata tree with structure of any complexity. Similar to ImGearMetadataHead, ImGearMetadataTree, this is a special case of metadata node with Parent property set to null.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMetadataNode
ImageGear.Core.ImGearMetadataTree

See Also

Reference

ImGearMetadataTree Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMetadataTree Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataTree Class

The following tables list the members exposed by ImGearMetadataTree.

Public Constructors
 | Name | Description
Public Constructor | ImGearMetadataTree Constructor | Overloaded. Initializes a new instance of the ImGearMetadataTree class.
Top
Public Properties
 | Name | Description
Public Property | Children | Gets array of child nodes.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

ImGearMetadataTree Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearMetadataTree Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataTree Class

For a list of all members of this type, see ImGearMetadataTree members.

See Also

Reference

ImGearMetadataTree Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMetadataTree Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class : ImGearMetadataTree Constructor
Initializes a new instance of the ImGearMetadataTree class.
Overload List
Overload | Description
ImGearMetadataTree Constructor() | Initializes a new instance of the ImGearMetadataTree class.
ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32) | Initializes a new instance of the ImGearMetadataTree class.
ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32,String) | Initializes a new instance of the ImGearMetadataTree class.
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%%

ImGearMetadataTree Constructor()

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor()
Initializes a new instance of the ImGearMetadataTree class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMetadataTree()
public ImGearMetadataTree()
public: ImGearMetadataTree();
public:
ImGearMetadataTree();
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List


%%PageItemTitle%%

ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32)
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Identifies type of metadata node for file format.
Initializes a new instance of the ImGearMetadataTree class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal format As ImGearMetadataFormats, _
   ByVal tag As Integer _
)
'Usage

Dim format As ImGearMetadataFormats
Dim tag As Integer

Dim instance As New ImGearMetadataTree(format, tag)
public ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag
)
public: ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag
)
public:
ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag
)

Parameters

format
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
Identifies type of metadata node for file format.
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List
ImGearMetadataFormats Enumeration


%%PageItemTitle%%

ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32,String)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor(ImGearMetadataFormats,Int32,String)
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Identifies type of metadata node for file format.
Name of the tag.
Initializes a new instance of the ImGearMetadataTree class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal format As ImGearMetadataFormats, _
   ByVal tag As Integer, _
   ByVal name As String _
)
'Usage

Dim format As ImGearMetadataFormats
Dim tag As Integer
Dim name As String

Dim instance As New ImGearMetadataTree(format, tag, name)
public ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag,
   string name
)
public: ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag,
   string* name
)
public:
ImGearMetadataTree(
   ImGearMetadataFormats format,
   int tag,
   String^ name
)

Parameters

format
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
Identifies type of metadata node for file format.
name
Name of the tag.
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List
ImGearMetadataFormats Enumeration


%%PageItemTitle%% $$Methods$$

ImGearMetadataTree Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataTree Class

For a list of all members of this type, see ImGearMetadataTree members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

ImGearMetadataTree Class
ImageGear.Core Namespace


Clone Method (ImGearMetadataTree)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearMetadataNode
'Usage

Dim instance As ImGearMetadataTree
Dim value As ImGearMetadataNode

value = instance.Clone()
public override ImGearMetadataNode Clone()
public: ImGearMetadataNode* Clone(); override
public:
ImGearMetadataNode^ Clone(); override

Return Value

ImGearMetadataTree class that is a copy of the current instance.
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%% $$Properties$$

ImGearMetadataTree Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMetadataTree Class

For a list of all members of this type, see ImGearMetadataTree members.

Public Properties
 | Name | Description
Public Property | Children | Gets array of child nodes.
Top
See Also

Reference

ImGearMetadataTree Class
ImageGear.Core Namespace


Children Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMetadataTree Class : Children Property
Gets array of child nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Children As ImGearMetadataNodeList
'Usage

Dim instance As ImGearMetadataTree
Dim value As ImGearMetadataNodeList

value = instance.Children
public ImGearMetadataNodeList Children {get;}
public: __property ImGearMetadataNodeList* get_Children();
public:
property ImGearMetadataNodeList^ Children {
   ImGearMetadataNodeList^ get();
}

Property Value

ImGearMetadataNodeList class instance or null.
Remarks
List of children nodes as ImGearMetadataNodeList class.
See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
ImGearMetadataNodeList Class


%%PageItemTitle%%

ImGearMultichannelLUT Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class
Represents a multichannel lookup table (LUT).
Object Model
ImGearMultichannelLUT ClassImGearMultichannelLUT ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearMultichannelLUT
'Usage

Dim instance As ImGearMultichannelLUT
[DefaultMember("Item")]
public class ImGearMultichannelLUT
[DefaultMember("Item")]
public __gc class ImGearMultichannelLUT
[DefaultMember("Item")]
public ref class ImGearMultichannelLUT
Remarks
An ImGearMultichannelLUT object contains an array of single-channel ImGearLUT class objects.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMultichannelLUT
ImageGear.Core.ImGearRGBLUT

See Also

Reference

ImGearMultichannelLUT Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearMultichannelLUT Class Members
Fields Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class

The following tables list the members exposed by ImGearMultichannelLUT.

Public Constructors
 | Name | Description
Public Constructor | ImGearMultichannelLUT Constructor | Overloaded. Initializes a new instance of the ImGearMultichannelLUT class.
Top
Protected Fields
 | Name | Description
Protected Field | luts_ | Array of single channel LUTs.
Top
Public Properties
 | Name | Description
Public Property | ChannelCount | Gets number of single channel LUTs in the multi-channel LUT. .
Public Property | Item | Provides access to single channel LUTs within the multichannel LUT.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMultichannelLUT Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMultichannelLUT Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : ImGearMultichannelLUT Constructor
Initializes a new instance of the ImGearMultichannelLUT class.
Overload List
Overload | Description
ImGearMultichannelLUT Constructor(Int32) | Initializes a new instance of the ImGearMultichannelLUT class with the specified number of single-channel LUTs.
ImGearMultichannelLUT Constructor(Int32,Int32,Int32) | Initializes a new instance of the ImGearMultichannelLUT class and allocates its elements with default single-channel LUTs.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

ImGearMultichannelLUT Constructor(Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class > ImGearMultichannelLUT Constructor : ImGearMultichannelLUT Constructor(Int32)
Specifies number of channels in the multichannel LUT.
Initializes a new instance of the ImGearMultichannelLUT class with the specified number of single-channel LUTs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal channelCount As Integer _
)
'Usage

Dim channelCount As Integer

Dim instance As New ImGearMultichannelLUT(channelCount)
public ImGearMultichannelLUT(
   int channelCount
)
public: ImGearMultichannelLUT(
   int channelCount
)
public:
ImGearMultichannelLUT(
   int channelCount
)

Parameters

channelCount
Specifies number of channels in the multichannel LUT.
Remarks
This constructor allocates the array of channel LUTs and initializes its elements with nulls.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members
Overload List


%%PageItemTitle%%

ImGearMultichannelLUT Constructor(Int32,Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class > ImGearMultichannelLUT Constructor : ImGearMultichannelLUT Constructor(Int32,Int32,Int32)
Specifies number of channels in the multichannel LUT.
Specifies input depth for single-channel LUTs.
Specifies output depth for single-channel LUTs.
Initializes a new instance of the ImGearMultichannelLUT class and allocates its elements with default single-channel LUTs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal channelCount As Integer, _
   ByVal inputDepth As Integer, _
   ByVal outputDepth As Integer _
)
'Usage

Dim channelCount As Integer
Dim inputDepth As Integer
Dim outputDepth As Integer

Dim instance As New ImGearMultichannelLUT(channelCount, inputDepth, outputDepth)
public ImGearMultichannelLUT(
   int channelCount,
   int inputDepth,
   int outputDepth
)
public: ImGearMultichannelLUT(
   int channelCount,
   int inputDepth,
   int outputDepth
)
public:
ImGearMultichannelLUT(
   int channelCount,
   int inputDepth,
   int outputDepth
)

Parameters

channelCount
Specifies number of channels in the multichannel LUT.
inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearMultichannelLUT Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class

For a list of all members of this type, see ImGearMultichannelLUT members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMultichannelLUT Class
ImageGear.Core Namespace


Clone Method (ImGearMultichannelLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearMultichannelLUT
'Usage

Dim instance As ImGearMultichannelLUT
Dim value As ImGearMultichannelLUT

value = instance.Clone()
public ImGearMultichannelLUT Clone()
public: ImGearMultichannelLUT* Clone();
public:
ImGearMultichannelLUT^ Clone();

Return Value

The new instance of ImGearMultichannelLUT class object.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


OnPropertyChanged Method (ImGearMultichannelLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearMultichannelLUT
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%% $$Properties$$

ImGearMultichannelLUT Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class

For a list of all members of this type, see ImGearMultichannelLUT members.

Public Properties
 | Name | Description
Public Property | ChannelCount | Gets number of single channel LUTs in the multi-channel LUT. .
Public Property | Item | Provides access to single channel LUTs within the multichannel LUT.
Top
See Also

Reference

ImGearMultichannelLUT Class
ImageGear.Core Namespace


ChannelCount Property (ImGearMultichannelLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : ChannelCount Property
Gets number of single channel LUTs in the multi-channel LUT. .
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelCount As Integer
'Usage

Dim instance As ImGearMultichannelLUT
Dim value As Integer

value = instance.ChannelCount
public int ChannelCount {get;}
public: __property int get_ChannelCount();
public:
property int ChannelCount {
   int get();
}

Property Value

Any integer number.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


Item Property (ImGearMultichannelLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : Item Property
Index of the LUT to get.
Provides access to single channel LUTs within the multichannel LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImGearLUT
'Usage

Dim instance As ImGearMultichannelLUT
Dim index As Integer
Dim value As ImGearLUT

instance.Item(index) = value

value = instance.Item(index)
public ImGearLUT this[
   int index
]; {get; set;}
public: __property ImGearLUT* get_Item   int index
;
public: __property void set_Item   int index,
   ImGearLUT* value
;
public:
property ImGearLUT^ default [int] {
   ImGearLUT^ get(int index);
   void set (int index, ImGearLUT^ value);
}

Parameters

index
Index of the LUT to get.

Property Value

ImGearLUT class object.
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members
ImGearLUT Class


%%PageItemTitle%% $$Fields$$

ImGearMultichannelLUT Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class

For a list of all members of this type, see ImGearMultichannelLUT members.

Protected Fields
 | Name | Description
Protected Field | luts_ | Array of single channel LUTs.
Top
See Also

Reference

ImGearMultichannelLUT Class
ImageGear.Core Namespace


luts_ Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : luts_ Field
Array of single channel LUTs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected luts_ As ImGearLUT()
'Usage

Dim instance As ImGearMultichannelLUT
Dim value() As ImGearLUT

value = instance.luts_

instance.luts_ = value
protected ImGearLUT[] luts_
protected: ImGearLUT*[]* luts_
protected:
array<ImGearLUT^>^ luts_
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%% $$Events$$

ImGearMultichannelLUT Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMultichannelLUT Class

For a list of all members of this type, see ImGearMultichannelLUT members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMultichannelLUT Class
ImageGear.Core Namespace


PropertyChanged Event (ImGearMultichannelLUT)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearMultichannelLUT Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearMultichannelLUT
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

ImGearPage Class
Members Example

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPage Class
Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.
Object Model
ImGearPage ClassImGearPage ClassImGearDIB ClassImGearDocument ClassImGearMetadataHead Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPage
'Usage

Dim instance As ImGearPage
public abstract class ImGearPage
public __gc abstract class ImGearPage
public ref class ImGearPage abstract
Remarks
Represents the image and consists of three main parts:
  • Image data (pixels)
  • Metadata (non-image data)
  • Region of interest

The page can be either stand-alone (not referenced from any ImGearDocument classinstance) or attached to a document.

Region of interest (ImGearROI class) represents free-shape image area (rectangular, non-rectangular or entire space) and specifies a meaningful part of an image. For example, it may be set up for some image processing methods to define the area to which the filter should be applied.

Metadata is non-image data. It is available for most image file formats. In some formats, such as TIFF or PNG, it can be very complex. It can include data of various types and can use a complex structure. ImageGear for .NET offers a set of classes designed specifically to manipulate this data consisting of ImGearMetadataNode class, ImGearMetadataNodeList class, ImGearMetadataTree class and their descendants. The metadata for each instance of ImGearPage may be accessed through its Metadata property.

The Image data (or simply, image) is available through the DIB property. Color Space, channels, width and height are among the major attributes that define the image structure.

Example
  • C#
// Creates a 512x512 24bit RGB image
ImGearPage igPage = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    new int[] { 8, 8, 8 },true);
  • Visual Basic
'Creates a 512x512 24bit RGB image
Dim igPage As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.RGB), _
    New Integer() {8, 8, 8}, True)
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearRasterPage
ImageGear.Core.ImGearVectorPage

See Also

Reference

ImGearPage Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearPage Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPage Class

The following tables list the members exposed by ImGearPage.

Public Fields
 | Name | Description
Public Field | Orientation | Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees.
Public Field | Transparency | Specifies image transparency attributes like transparent color for display.
Top
Public Properties
 | Name | Description
Public Property | DIB | Gets a reference to the ImGearDIB class object. This object contains the page's pixel data.
Public Property | Document | Gets the document to which the page belongs, or null if the page is stand-alone.
Public Property | Metadata | Gets the head, ImGearMetadataHead, of the page's metadata tree.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates new object that is exact copy of current instance.
Top
See Also

Reference

ImGearPage Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearPage Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPage Class

For a list of all members of this type, see ImGearPage members.

Public Methods
 | Name | Description
Public Method | Clone | Creates new object that is exact copy of current instance.
Top
See Also

Reference

ImGearPage Class
ImageGear.Core Namespace


Clone Method (ImGearPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : Clone Method
Creates new object that is exact copy of current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Clone() As ImGearPage
'Usage

Dim instance As ImGearPage
Dim value As ImGearPage

value = instance.Clone()
public abstract ImGearPage Clone()
public: abstract ImGearPage* Clone();
public:
abstract ImGearPage^ Clone();

Return Value

ImGearPage class object that is a copy of the current instance.
See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%% $$Properties$$

ImGearPage Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPage Class

For a list of all members of this type, see ImGearPage members.

Public Properties
 | Name | Description
Public Property | DIB | Gets a reference to the ImGearDIB class object. This object contains the page's pixel data.
Public Property | Document | Gets the document to which the page belongs, or null if the page is stand-alone.
Public Property | Metadata | Gets the head, ImGearMetadataHead, of the page's metadata tree.
Top
See Also

Reference

ImGearPage Class
ImageGear.Core Namespace


DIB Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : DIB Property
Gets a reference to the ImGearDIB class object. This object contains the page's pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DIB As ImGearDIB
'Usage

Dim instance As ImGearPage
Dim value As ImGearDIB

value = instance.DIB
public ImGearDIB DIB {get;}
public: __property ImGearDIB* get_DIB();
public:
property ImGearDIB^ DIB {
   ImGearDIB^ get();
}

Property Value

Non-null reference to an instance of ImGearDIB class.
Remarks

Provides access to image properties and image pixel data.

The DIB property always returns a non-null reference. However, an ImGearPage object can also be used without allocating its DIB's pixel store. The property ImGearDIB.IsEmpty is available to detect whether the pixel store has been allocated.

See Also

Reference

ImGearPage Class
ImGearPage Members
ImGearDIB Class


Document Property (ImGearPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : Document Property
Gets the document to which the page belongs, or null if the page is stand-alone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As ImGearDocument
'Usage

Dim instance As ImGearPage
Dim value As ImGearDocument

value = instance.Document
public ImGearDocument Document {get;}
public: __property ImGearDocument* get_Document();
public:
property ImGearDocument^ Document {
   ImGearDocument^ get();
}

Property Value

ImGearDocument class instance or null, if page is stand-alone.
See Also

Reference

ImGearPage Class
ImGearPage Members


Metadata Property (ImGearPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : Metadata Property
Gets the head, ImGearMetadataHead, of the page's metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Metadata As ImGearMetadataHead
'Usage

Dim instance As ImGearPage
Dim value As ImGearMetadataHead

value = instance.Metadata
public ImGearMetadataHead Metadata {get;}
public: __property ImGearMetadataHead* get_Metadata();
public:
property ImGearMetadataHead^ Metadata {
   ImGearMetadataHead^ get();
}

Property Value

Non-null reference to ImGearMetadataHead class object.
See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%% $$Fields$$

ImGearPage Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPage Class

For a list of all members of this type, see ImGearPage members.

Public Fields
 | Name | Description
Public Field | Orientation | Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees.
Public Field | Transparency | Specifies image transparency attributes like transparent color for display.
Top
See Also

Reference

ImGearPage Class
ImageGear.Core Namespace


Orientation Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : Orientation Field
Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Orientation As IImGearOrientation
'Usage

Dim instance As ImGearPage
Dim value As IImGearOrientation

value = instance.Orientation

instance.Orientation = value
public IImGearOrientation Orientation
public: IImGearOrientation* Orientation
public:
IImGearOrientation^ Orientation

Field Value

Non-null reference to an instance of ImGearOrientation structure.
Remarks
This field defines the orientation of an ImGearPage instance. It works on the image representation and thus allows the manipulation of page orientation without modifying the pixel data.
See Also

Reference

ImGearPage Class
ImGearPage Members
ImGearOrientation Structure


Transparency Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPage Class : Transparency Field
Specifies image transparency attributes like transparent color for display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Transparency As ImGearTransparency
'Usage

Dim instance As ImGearPage
Dim value As ImGearTransparency

value = instance.Transparency

instance.Transparency = value
public ImGearTransparency Transparency
public: ImGearTransparency* Transparency
public:
ImGearTransparency^ Transparency

Field Value

ImGearTransparency class object.
See Also

Reference

ImGearPage Class
ImGearPage Members
ImGearTransparency Class


%%PageItemTitle%%

ImGearPixel Class
Members Example

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixel Class
Encapsulates all attributes and operations for an image pixel.
Object Model
ImGearPixel ClassImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearPixel
'Usage

Dim instance As ImGearPixel
[DefaultMember("Item")]
public sealed class ImGearPixel
[DefaultMember("Item")]
public __gc __sealed class ImGearPixel
[DefaultMember("Item")]
public ref class ImGearPixel sealed
Remarks
This class encapsulates an image pixel and represents the color store for each channel value.

For simplicity, ImGearPixel does not contain any information about channels depths and color space. Therefore pixels that are identical in structure (ImGearPixel constructor parameters) may belong to images with significantly different channels, structure and color space.

NOTE: for initialization of pixel value for using it with bitonal images, i.e. Run-Ends DIBs, please use 0 value for black color, and 1 value for white color.

Example
  • C#
// Create a pixel for an image with an 8bit palette.
ImGearPixel igPixelIndexed = new ImGearPixel(1, 8);
// Assign the pixel palette position 176.
igPixelIndexed[0] = 176;
// Create a 512x512 8bit indexed image.
ImGearPage igPageIndex = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 8 }, true);
// Allocate a new palette
igPageIndex.DIB.Palette = new ImGearRGBQuad[256];
// Set the 176th palette entry to green.
igPageIndex.DIB.Palette[176].Red = 0;
igPageIndex.DIB.Palette[176].Green = 127;
igPageIndex.DIB.Palette[176].Blue = 0;
// Update the full image with this pixel.
for (int height = 0; height < igPageIndex.DIB.Height; height++)
    for (int width = 0; width < igPageIndex.DIB.Width; width++)
        igPageIndex.DIB.UpdatePixelFrom(width, height, igPixelIndexed);

// Create a pixel for a 32bit CMYK image.
ImGearPixel igPixelCMYK = new ImGearPixel(4, 8);
// Assign the pixel a blue color.
igPixelCMYK[0] = 255;
igPixelCMYK[1] = 255;
igPixelCMYK[2] = 0;
igPixelCMYK[3] = 127;
// Creates a 512x512 32bit CMYK image.
ImGearPage igPageCMYK = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.CMYK),
    new int[] { 8, 8, 8, 8 }, true);
for (int height = 0; height < igPageCMYK.DIB.Height; height++)
    for (int width = 0; width < igPageCMYK.DIB.Width; width++)
        igPageCMYK.DIB.UpdatePixelFrom(width, height, igPixelCMYK);
  • Visual Basic
'Create a pixel for an image with an 8bit palette.
Dim igPixelIndexed As ImGearPixel = New ImGearPixel(1, 8)
'Assign the pixel palette position 176.
igPixelIndexed(0) = 176
'Create a 512x512 8bit indexed image.
Dim igPageIndex As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.I), _
    New Integer() {8}, True)
'Allocate a new palette
ReDim igPageIndex.DIB.Palette(256)
'Set the 176th palette entry to green.
igPageIndex.DIB.Palette(176).Red = 0
igPageIndex.DIB.Palette(176).Green = 127
igPageIndex.DIB.Palette(176).Blue = 0
'Update the full image with this pixel.
For height As Integer = 0 To igPageIndex.DIB.Height - 1
    For width As Integer = 0 To igPageIndex.DIB.Width - 1
        igPageIndex.DIB.UpdatePixelFrom(width, height, igPixelIndexed)
    Next
Next

'Create a pixel for a 32bit CMYK image.
Dim igPixelCMYK As ImGearPixel = New ImGearPixel(4, 8)
'Assign the pixel a blue color.
igPixelCMYK(0) = 255
igPixelCMYK(1) = 255
igPixelCMYK(2) = 0
igPixelCMYK(3) = 127
'Creates a 512x512 32bit CMYK image.
Dim igPageCMYK As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.CMYK), _
    New Integer() {8, 8, 8, 8}, True)
For height As Integer = 0 To igPageCMYK.DIB.Height - 1
    For width As Integer = 0 To igPageCMYK.DIB.Width - 1
        igPageCMYK.DIB.UpdatePixelFrom(width, height, igPixelCMYK)
    Next
Next
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPixel

See Also

Reference

ImGearPixel Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearPixel Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixel Class

The following tables list the members exposed by ImGearPixel.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixel Constructor | Initializes a new instance of the ImGearPixel class.
Top
Public Properties
 | Name | Description
Public Property | BitsPerChannel | Gets the number of bits per color channel.
Public Property | ChannelCount | Gets quantity of channels in pixel.
Public Property | Item | Channels indexing property.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

ImGearPixel Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearPixel Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixel Class : ImGearPixel Constructor
Number of channels in the image.
Space, in bits, to allocate for each image channel.
Initializes a new instance of the ImGearPixel class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal channelCount As Integer, _
   ByVal bitsPerChannel As Integer _
)
'Usage

Dim channelCount As Integer
Dim bitsPerChannel As Integer

Dim instance As New ImGearPixel(channelCount, bitsPerChannel)
public ImGearPixel(
   int channelCount,
   int bitsPerChannel
)
public: ImGearPixel(
   int channelCount,
   int bitsPerChannel
)
public:
ImGearPixel(
   int channelCount,
   int bitsPerChannel
)

Parameters

channelCount
Number of channels in the image.
bitsPerChannel
Space, in bits, to allocate for each image channel.
See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%% $$Methods$$

ImGearPixel Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixel Class

For a list of all members of this type, see ImGearPixel members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

ImGearPixel Class
ImageGear.Core Namespace


Clone Method (ImGearPixel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixel Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearPixel
'Usage

Dim instance As ImGearPixel
Dim value As ImGearPixel

value = instance.Clone()
public ImGearPixel Clone()
public: ImGearPixel* Clone();
public:
ImGearPixel^ Clone();

Return Value

ImGearPixel class object that is a copy of the current instance.
See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%% $$Properties$$

ImGearPixel Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixel Class

For a list of all members of this type, see ImGearPixel members.

Public Properties
 | Name | Description
Public Property | BitsPerChannel | Gets the number of bits per color channel.
Public Property | ChannelCount | Gets quantity of channels in pixel.
Public Property | Item | Channels indexing property.
Top
See Also

Reference

ImGearPixel Class
ImageGear.Core Namespace


BitsPerChannel Property (ImGearPixel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixel Class : BitsPerChannel Property
Gets the number of bits per color channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerChannel As Integer
'Usage

Dim instance As ImGearPixel
Dim value As Integer

value = instance.BitsPerChannel
public int BitsPerChannel {get;}
public: __property int get_BitsPerChannel();
public:
property int BitsPerChannel {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearPixel Class
ImGearPixel Members


ChannelCount Property (ImGearPixel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixel Class : ChannelCount Property
Gets quantity of channels in pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelCount As Integer
'Usage

Dim instance As ImGearPixel
Dim value As Integer

value = instance.ChannelCount
public int ChannelCount {get;}
public: __property int get_ChannelCount();
public:
property int ChannelCount {
   int get();
}

Property Value

Non-zero value.
See Also

Reference

ImGearPixel Class
ImGearPixel Members


Item Property (ImGearPixel)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixel Class : Item Property
Channel index.
Channels indexing property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearPixel
Dim index As Integer
Dim value As Integer

instance.Item(index) = value

value = instance.Item(index)
public int this[
   int index
]; {get; set;}
public: __property int get_Item   int index
;
public: __property void set_Item   int index,
   int value
;
public:
property int default [int] {
   int get(int index);
   void set (int index, int value);
}

Parameters

index
Channel index.

Property Value

Value from 0 to 2^(ChannelDepth) - 1 range.
Remarks

Gets or sets the color value using channel index.

NOTE: for initialization of pixel value for using it with bitonal images, i.e. Run-Ends DIBs, please use 0 value for black color, and 1 value for white color.

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

ImGearPixelArray Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixelArray Class
One dimensional array of image pixels.
Object Model
ImGearPixelArray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearPixelArray
'Usage

Dim instance As ImGearPixelArray
[DefaultMember("Item")]
public sealed class ImGearPixelArray
[DefaultMember("Item")]
public __gc __sealed class ImGearPixelArray
[DefaultMember("Item")]
public ref class ImGearPixelArray sealed
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPixelArray

See Also

Reference

ImGearPixelArray Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearPixelArray Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixelArray Class

The following tables list the members exposed by ImGearPixelArray.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelArray Constructor | Initializes a new instance of the ImGearPixelArray class.
Top
Public Properties
 | Name | Description
Public Property | ChannelCount | Gets quantity of channels in each pixel contained in the array.
Public Property | Item | Indexed property for direct access to contained pixels.
Public Property | PixelCount | Gets quantity of pixels in array.
Top
See Also

Reference

ImGearPixelArray Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearPixelArray Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixelArray Class : ImGearPixelArray Constructor
Quantity of pixels to be stored in array.
Quantity of channels in an image whose pixels are stored in array.
Actual size of store to contain color value for each image channel.
Initializes a new instance of the ImGearPixelArray class.
Initializes a new instance of the ImGearPixelArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pixelCount As Integer, _
   ByVal channelCount As Integer, _
   ByVal bitsPerChannel As Integer _
)
'Usage

Dim pixelCount As Integer
Dim channelCount As Integer
Dim bitsPerChannel As Integer

Dim instance As New ImGearPixelArray(pixelCount, channelCount, bitsPerChannel)
public ImGearPixelArray(
   int pixelCount,
   int channelCount,
   int bitsPerChannel
)
public: ImGearPixelArray(
   int pixelCount,
   int channelCount,
   int bitsPerChannel
)
public:
ImGearPixelArray(
   int pixelCount,
   int channelCount,
   int bitsPerChannel
)

Parameters

pixelCount
Quantity of pixels to be stored in array.
channelCount
Quantity of channels in an image whose pixels are stored in array.
bitsPerChannel
Actual size of store to contain color value for each image channel.
Remarks
Initializes the pixel store using the pixel's defining attributes and the length of the array.
See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%% $$Properties$$

ImGearPixelArray Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPixelArray Class

For a list of all members of this type, see ImGearPixelArray members.

Public Properties
 | Name | Description
Public Property | ChannelCount | Gets quantity of channels in each pixel contained in the array.
Public Property | Item | Indexed property for direct access to contained pixels.
Public Property | PixelCount | Gets quantity of pixels in array.
Top
See Also

Reference

ImGearPixelArray Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearPixelArray Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixelArray Class : ImGearPixelArray Constructor
Initializes a new instance of the ImGearPixelArray class.
Overload List
Overload | Description
ImGearPixelArray Constructor | Initializes a new instance of the ImGearPixelArray class.
See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


ChannelCount Property (ImGearPixelArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixelArray Class : ChannelCount Property
Gets quantity of channels in each pixel contained in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelCount As Integer
'Usage

Dim instance As ImGearPixelArray
Dim value As Integer

value = instance.ChannelCount
public int ChannelCount {get;}
public: __property int get_ChannelCount();
public:
property int ChannelCount {
   int get();
}

Property Value

Non-zero quantity of channels.
See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


Item Property (ImGearPixelArray)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixelArray Class : Item Property
Index of pixel in the array.
Channel number in particular pixel.
Indexed property for direct access to contained pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal pixel As Integer, _
   ByVal channel As Integer _
) As Integer
'Usage

Dim instance As ImGearPixelArray
Dim pixel As Integer
Dim channel As Integer
Dim value As Integer

instance.Item(pixel, channel) = value

value = instance.Item(pixel, channel)
public int this[
   int pixel,
   int channel
]; {get; set;}
public: __property int get_Item   int pixel,
   int channel
;
public: __property void set_Item   int pixel,
   int channel,
   int value
;
public:
property int default [int,int] {
   int get(int pixel, int channel);
   void set (int pixel, int channel, int value);
}

Parameters

pixel
Index of pixel in the array.
channel
Channel number in particular pixel.

Property Value

Color value of requested channel in requested pixel.
Remarks
Provides access to color values of stored pixels and their channels.
See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


PixelCount Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPixelArray Class : PixelCount Property
Gets quantity of pixels in array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PixelCount As Integer
'Usage

Dim instance As ImGearPixelArray
Dim value As Integer

value = instance.PixelCount
public int PixelCount {get;}
public: __property int get_PixelCount();
public:
property int PixelCount {
   int get();
}

Property Value

Array length.
Remarks
Obtains the number of ImGearPixel elements in the array.
See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members
ImGearPixel Class


%%PageItemTitle%%

ImGearPolygon Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPolygon Class
Defines a polygon shape.
Object Model
ImGearPolygon Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPolygon
   Implements IImGearShape
'Usage

Dim instance As ImGearPolygon
public class ImGearPolygon : IImGearShape
public __gc class ImGearPolygon : public IImGearShape
public ref class ImGearPolygon : public IImGearShape
Remarks
Represents a polygon, i.e., a 2D shape defined by two or more points sequentilly connected by straight lines.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPolygon

See Also

Reference

ImGearPolygon Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearPolygon Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPolygon Class

The following tables list the members exposed by ImGearPolygon.

Public Constructors
 | Name | Description
Public Constructor | ImGearPolygon Constructor | Initializes a new instance of the ImGearPolygon class object.
Top
Public Fields
 | Name | Description
Public Field | Points | Array of points that define polygon structure.
Top
See Also

Reference

ImGearPolygon Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearPolygon Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPolygon Class : ImGearPolygon Constructor
Initializes a new instance of the ImGearPolygon class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPolygon()
public ImGearPolygon()
public: ImGearPolygon();
public:
ImGearPolygon();
See Also

Reference

ImGearPolygon Class
ImGearPolygon Members


%%PageItemTitle%% $$Fields$$

ImGearPolygon Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPolygon Class

For a list of all members of this type, see ImGearPolygon members.

Public Fields
 | Name | Description
Public Field | Points | Array of points that define polygon structure.
Top
See Also

Reference

ImGearPolygon Class
ImageGear.Core Namespace


Points Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPolygon Class : Points Field
Array of points that define polygon structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Points As ImGearPoint()
'Usage

Dim instance As ImGearPolygon
Dim value() As ImGearPoint

value = instance.Points

instance.Points = value
public ImGearPoint[] Points
public: ImGearPoint[]* Points
public:
array<ImGearPoint>^ Points

Field Value

Array of ImGearPoint structure objects or null.
See Also

Reference

ImGearPolygon Class
ImGearPolygon Members


%%PageItemTitle%%

ImGearRasterPage Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRasterPage Class
The class represents a raster image.
Object Model
ImGearRasterPage ClassImGearPage ClassImGearColorProfile ClassImGearRasterPage ClassImGearRasterPage ClassIImGearDICOMDisplaySettings InterfaceImGearRasterPage ClassImGearRasterPage ClassImGearROI Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRasterPage
   Inherits ImGearPage
'Usage

Dim instance As ImGearRasterPage
public class ImGearRasterPage : ImGearPage
public __gc class ImGearRasterPage : public ImGearPage
public ref class ImGearRasterPage : public ImGearPage
Remarks
Instances of this class can be used as the destination of Accusoft's standard methods for passing images between different components: CopyTo(object destination) and TransferTo(object destination). When used as the destination object, this class will only accept the uncompressed Indexed RGB: 1, 4, 8 bpp or RGB: 15, 16, 24, 32 bpp image data.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearRasterPage
ImageGear.Processing.Layers.ImGearLayeredPage

See Also

Reference

ImGearRasterPage Members
ImageGear.Core Namespace
ImGearPage Class


%%PageItemTitle%% $$Members$$

ImGearRasterPage Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRasterPage Class

The following tables list the members exposed by ImGearRasterPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearRasterPage Constructor | Overloaded. Initializes a new instance of the ImGearRasterPage class.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | CanGetFromClipboard | Gets a value indicating whether there is a valid image available in the system clipboard.
Public Property | ColorProfile | Gets or sets a local color profile associated with the image.
Public Property | DICOMDisplaySettings | Gets or sets DICOM specific display contrast settings.
Public Property | ROI | Gets or sets region of interest.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates new object that is an exact copy of the current instance.
Public Method | CopyTo | Makes a copy of the raster page's image data and gives the new image data to the destination object.
Public Method | CopyToClipboard | Copies the page (or a portion of the page) into system clipboard.
static (Shared in Visual Basic) | CreateFromDIB | Creates new page with same image data as given DIB.
static (Shared in Visual Basic) | CreateFromImage | Creates a new ImGearRasterPage using the image data from incoming System.Drawing.Image.
Public Method | CutToClipboard | Cuts the page (or a portion of the page) into system clipboard.
Public Method | DuplicateRect | Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.
static (Shared in Visual Basic) | GetFromClipboard | Creates the ImGearRasterPage by getting the image from the system clipboard.
Top
See Also

Reference

ImGearRasterPage Class
ImageGear.Core Namespace
ImGearPage Class


%%PageItemTitle%% $$Fields$$

ImGearRasterPage Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRasterPage Class

For a list of all members of this type, see ImGearRasterPage members.

See Also

Reference

ImGearRasterPage Class
ImageGear.Core Namespace
ImGearPage Class


%%PageItemTitle%%

ImGearRasterPage Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : ImGearRasterPage Constructor
Initializes a new instance of the ImGearRasterPage class.
Overload List
Overload | Description
ImGearRasterPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean) | Initializes a new instance of the ImGearRasterPage class with provided attributes.
ImGearRasterPage Constructor() | Initializes a new instance of the ImGearRasterPage class with default attributes.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

ImGearRasterPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class > ImGearRasterPage Constructor : ImGearRasterPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean)
Width of page in pixels.
Height of page in pixels.
Pixel's color space.
Channels depths of new page.
Indicates whether the pixel store should be allocated.
Initializes a new instance of the ImGearRasterPage class with provided attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal channelDepths() As Integer, _
   ByVal allocatePixels As Boolean _
)
'Usage

Dim width As Integer
Dim height As Integer
Dim colorSpace As ImGearColorSpace
Dim channelDepths() As Integer
Dim allocatePixels As Boolean

Dim instance As New ImGearRasterPage(width, height, colorSpace, channelDepths, allocatePixels)
public ImGearRasterPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   bool allocatePixels
)
public: ImGearRasterPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[]* channelDepths,
   bool allocatePixels
)
public:
ImGearRasterPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   array<int>^ channelDepths,
   bool allocatePixels
)

Parameters

width
Width of page in pixels.
height
Height of page in pixels.
colorSpace
Pixel's color space.
channelDepths
Channels depths of new page.
allocatePixels
Indicates whether the pixel store should be allocated.
Remarks
The ImGearPage is initialized with a set of image defining attributes. Optionally a store for pixels may also be allocated.

An exception may be thrown while constructing the page instance if incompatible image attributes are passed (e.g., ChannelDepths has length smaller than colors channels quantity in specified color space).

This constructor does not allocate a palette. After creating an indexed image the user should allocate a palette, initialize its entries, and attach it to the ImGearRasterPage's DIB. The Palette's length should be equal to 2^depth, where depth is bit depth of the indexed image.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
Overload List


%%PageItemTitle%%

ImGearRasterPage Constructor()

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class > ImGearRasterPage Constructor : ImGearRasterPage Constructor()
Initializes a new instance of the ImGearRasterPage class with default attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRasterPage()
public ImGearRasterPage()
public: ImGearRasterPage();
public:
ImGearRasterPage();
Remarks
This default ImGearRasterPage constructor allocates and initializes a 1 x 1 24-bit RGB image.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRasterPage Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRasterPage Class

For a list of all members of this type, see ImGearRasterPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates new object that is an exact copy of the current instance.
Public Method | CopyTo | Makes a copy of the raster page's image data and gives the new image data to the destination object.
Public Method | CopyToClipboard | Copies the page (or a portion of the page) into system clipboard.
static (Shared in Visual Basic) | CreateFromDIB | Creates new page with same image data as given DIB.
static (Shared in Visual Basic) | CreateFromImage | Creates a new ImGearRasterPage using the image data from incoming System.Drawing.Image.
Public Method | CutToClipboard | Cuts the page (or a portion of the page) into system clipboard.
Public Method | DuplicateRect | Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.
static (Shared in Visual Basic) | GetFromClipboard | Creates the ImGearRasterPage by getting the image from the system clipboard.
Top
See Also

Reference

ImGearRasterPage Class
ImageGear.Core Namespace
ImGearPage Class


Clone Method (ImGearRasterPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : Clone Method
Creates new object that is an exact copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearRasterPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImGearRasterPage class object that is a copy of the current instance.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


CopyTo Method (ImGearRasterPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CopyTo Method
Object to copy the new image data to.
Makes a copy of the raster page's image data and gives the new image data to the destination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal destination As Object _
)
'Usage

Dim instance As ImGearRasterPage
Dim destination As Object

instance.CopyTo(destination)
public void CopyTo(
   object destination
)
public: void CopyTo(
   Object* destination
)
public:
void CopyTo(
   Object^ destination
)

Parameters

destination
Object to copy the new image data to.
Remarks

Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.

This method produces the new image data in one of the following pixel formats: Indexed RGB: 1, 4, 8 bpp or RGB: 24 bpp. If the raster page is not directly compatible with either of these formats, its image data will be converted to the best match.

Not all object types are valid destinations for this method. If the destination object does not support being copied to, a System.ArgumentException will be thrown. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.

If the provided destination object is an ImGearRasterPage, its internal DIB is replaced with a clone of the raster page's DIB.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


CopyToClipboard Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CopyToClipboard Method
Copies the page (or a portion of the page) into system clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyToClipboard()
'Usage

Dim instance As ImGearRasterPage

instance.CopyToClipboard()
public void CopyToClipboard()
public: void CopyToClipboard();
public:
void CopyToClipboard();
Remarks
Prior to processing the image, the method checks whether the page has the ROI initialized (rectangular or non-rectangular), and if it exists, copies the portion of the image, specified by bounding rectangle of the ROI. The non-rectangular ROI image (ImGearROIMask) also will be placed into the clipboard using ImageGear's proprietary format, then automatically will be retrieved and attached to the main image upon call of the GetFromClipboard.

Any third party application that supports pasting from the clipboard, will be able to retrieve the copied image. However, if it has the ROI, the mask will not be honored. Instead, the entire rectangular region beneath the bounding box, defined by the mask, will be pasted.

Note: The copied pixels will be converted to 1-, 4-, 8-bit Indexed or 24-bit RGB format for copying to the clipboard.

Note: The clipboard API can only be used in threads set to single thread apartment (STA) mode.

Note: The Windows clipboard does not support multiple access at the same time. It means, that attempt to use CopyToClipboard or GetFromClipboard simultaneously from multiple threads will lead to impossibility to copy/paste the image to/from the clipboard - the ImGearException will be thrown.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
ROI Property
ImGearROI Class
ImGearROIRectangle Class
ImGearROIMask Class


CreateFromDIB Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CreateFromDIB Method
Non-null reference to ImGearDIB instance.
Creates new page with same image data as given DIB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateFromDIB( _
   ByVal dib As ImGearDIB _
) As ImGearRasterPage
'Usage

Dim dib As ImGearDIB
Dim value As ImGearRasterPage

value = ImGearRasterPage.CreateFromDIB(dib)
public static ImGearRasterPage CreateFromDIB(
   ImGearDIB dib
)
public: static ImGearRasterPage* CreateFromDIB(
   ImGearDIB* dib
)
public:
static ImGearRasterPage^ CreateFromDIB(
   ImGearDIB^ dib
)

Parameters

dib
Non-null reference to ImGearDIB instance.

Return Value

A new instance of ImGearRasterPage class.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
ImGearDIB Class


CreateFromImage Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CreateFromImage Method
Non-null reference to a System.Drawing.Image.
Creates a new ImGearRasterPage using the image data from incoming System.Drawing.Image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateFromImage( _
   ByVal image As Image _
) As ImGearRasterPage
'Usage

Dim image As Image
Dim value As ImGearRasterPage

value = ImGearRasterPage.CreateFromImage(image)
public static ImGearRasterPage CreateFromImage(
   Image image
)
public: static ImGearRasterPage* CreateFromImage(
   Image* image
)
public:
static ImGearRasterPage^ CreateFromImage(
   Image^ image
)

Parameters

image
Non-null reference to a System.Drawing.Image.

Return Value

A new instance of ImGearRasterPage class.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


CutToClipboard Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CutToClipboard Method
The solid fill color, specified in RGB format, used to fill the cut region. If the actual color space of the image is not RGB, the provided color will be automatically converted to corresponding closest pixel value of that color space.
Cuts the page (or a portion of the page) into system clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CutToClipboard( _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim instance As ImGearRasterPage
Dim fillColor As IImGearRGBQuad

instance.CutToClipboard(fillColor)
public void CutToClipboard(
   IImGearRGBQuad fillColor
)
public: void CutToClipboard(
   IImGearRGBQuad* fillColor
)
public:
void CutToClipboard(
   IImGearRGBQuad^ fillColor
)

Parameters

fillColor
The solid fill color, specified in RGB format, used to fill the cut region. If the actual color space of the image is not RGB, the provided color will be automatically converted to corresponding closest pixel value of that color space.
Remarks
Prior to processing the image, the method checks whether the page has the ROI initialized (rectangular or non-rectangular), and if it exists, cuts the portion of the image, specified by bounding rectangle of the ROI. If the ROI is non-rectangular (ImGearROIMask), will be filled that non-rectangular region only. The non-rectangular ROI image also will be placed into the clipboard using ImageGear's proprietary format, then automatically will be retrieved and attached to the main image upon call of the GetFromClipboard.

Any third party application that supports pasting from the clipboard, will be able to retrieve the copied image. However, if it has the ROI, the mask will not be honored. Instead, the entire rectangular region beneath the bounding box, defined by the mask, will be pasted.

The fillColor cannot be null. If fill color is not necessary, please use CopyToClipboard instead.

Note: The copied pixels will be converted to 1-, 4-, 8-bit Indexed or 24-bit RGB format for copying to the clipboard.

Note: The clipboard API can only be used in threads set to single thread apartment (STA) mode.

Note: The Windows clipboard does not support multiple access at the same time. It means, that attempt to use CutToClipboard or GetFromClipboard simultaneously from multiple threads will lead to impossibility to copy/paste the image to/from the clipboard - the ImGearException will be thrown.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
CopyToClipboard Method
ImGearColorSpace Structure


DuplicateRect Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : DuplicateRect Method
Non null instance of ImGearRectangle.
Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function DuplicateRect( _
   ByVal rect As ImGearRectangle _
) As ImGearRasterPage
'Usage

Dim instance As ImGearRasterPage
Dim rect As ImGearRectangle
Dim value As ImGearRasterPage

value = instance.DuplicateRect(rect)
public ImGearRasterPage DuplicateRect(
   ImGearRectangle rect
)
public: ImGearRasterPage* DuplicateRect(
   ImGearRectangle rect
)
public:
ImGearRasterPage^ DuplicateRect(
   ImGearRectangle rect
)

Parameters

rect
Non null instance of ImGearRectangle.

Return Value

A new instance of ImGearRasterPage class.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


GetFromClipboard Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : GetFromClipboard Method
Creates the ImGearRasterPage by getting the image from the system clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetFromClipboard() As ImGearRasterPage
'Usage

Dim value As ImGearRasterPage

value = ImGearRasterPage.GetFromClipboard()
public static ImGearRasterPage GetFromClipboard()
public: static ImGearRasterPage* GetFromClipboard();
public:
static ImGearRasterPage^ GetFromClipboard();

Return Value

ImGearRasterPage instance, if the system clipboard contains valid image. Otherwise returns null.
Remarks
Prior to calling this method, call CanGetFromClipboard to verify that there is a paste-able image in the clipboard. If the clipboard contains ImageGear's non-rectangular ROI (ImGearROIMask instance), it will be also retrieved and attached to the image as a ROI property.

Note: The supported pixel formats are 1-, 4-, 8-bit Indexed or 24-bit RGB format.

Note: The clipboard API can only be used in threads set to single thread apartment (STA) mode.

Note: The Windows clipboard does not support multiple access at the same time. It means, that attempt to use CopyToClipboard or GetFromClipboard simultaneously from multiple threads will lead to impossibility to copy/paste the image to/from the clipboard - the ImGearException will be thrown.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
ROI Property
ImGearROI Class
ImGearROIMask Class


%%PageItemTitle%% $$Properties$$

ImGearRasterPage Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRasterPage Class

For a list of all members of this type, see ImGearRasterPage members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | CanGetFromClipboard | Gets a value indicating whether there is a valid image available in the system clipboard.
Public Property | ColorProfile | Gets or sets a local color profile associated with the image.
Public Property | DICOMDisplaySettings | Gets or sets DICOM specific display contrast settings.
Public Property | ROI | Gets or sets region of interest.
Top
See Also

Reference

ImGearRasterPage Class
ImageGear.Core Namespace
ImGearPage Class


CanGetFromClipboard Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : CanGetFromClipboard Property
Gets a value indicating whether there is a valid image available in the system clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CanGetFromClipboard As Boolean
'Usage

Dim value As Boolean

value = ImGearRasterPage.CanGetFromClipboard
public static bool CanGetFromClipboard {get;}
public: __property static bool get_CanGetFromClipboard();
public:
static property bool CanGetFromClipboard {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


ColorProfile Property (ImGearRasterPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : ColorProfile Property
Gets or sets a local color profile associated with the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorProfile As ImGearColorProfile
'Usage

Dim instance As ImGearRasterPage
Dim value As ImGearColorProfile

instance.ColorProfile = value

value = instance.ColorProfile
public ImGearColorProfile ColorProfile {get; set;}
public: __property ImGearColorProfile* get_ColorProfile();
public: __property void set_ColorProfile(
   ImGearColorProfile* value
);
public:
property ImGearColorProfile^ ColorProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile class object.
Remarks
If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


DICOMDisplaySettings Property (ImGearRasterPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : DICOMDisplaySettings Property
Gets or sets DICOM specific display contrast settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DICOMDisplaySettings As IImGearDICOMDisplaySettings
'Usage

Dim instance As ImGearRasterPage
Dim value As IImGearDICOMDisplaySettings

instance.DICOMDisplaySettings = value

value = instance.DICOMDisplaySettings
public IImGearDICOMDisplaySettings DICOMDisplaySettings {get; set;}
public: __property IImGearDICOMDisplaySettings* get_DICOMDisplaySettings();
public: __property void set_DICOMDisplaySettings(
   IImGearDICOMDisplaySettings* value
);
public:
property IImGearDICOMDisplaySettings^ DICOMDisplaySettings {
   IImGearDICOMDisplaySettings^ get();
   void set (    IImGearDICOMDisplaySettings^ value);
}

Property Value

IImGearDICOMDisplaySettings interface.
Remarks

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings property of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a ImageGear.Display.ImGearPageDisplay class. If ImageGear.Display.ImGearPageDisplay.DICOMDisplaySettings property is not null, ImageGear uses it for display. If ImageGear.Display.ImGearPageDisplay.DICOMDisplaySettings property is null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImageGear.Display.ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

DICOMDisplaySettings property can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this property is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class.

The default value is null.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
IImGearDICOMDisplaySettings Interface


ROI Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRasterPage Class : ROI Property
Gets or sets region of interest.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ROI As ImGearROI
'Usage

Dim instance As ImGearRasterPage
Dim value As ImGearROI

instance.ROI = value

value = instance.ROI
public ImGearROI ROI {get; set;}
public: __property ImGearROI* get_ROI();
public: __property void set_ROI(
   ImGearROI* value
);
public:
property ImGearROI^ ROI {
   ImGearROI^ get();
   void set (    ImGearROI^ value);
}

Property Value

ImGearROI class instance or null.
Remarks
The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.
See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
ImGearROI Class


%%PageItemTitle%%

ImGearRGBLUT Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class
Represents RGB lookup table (LUT).
Object Model
ImGearRGBLUT ClassImGearLUT ClassImGearLUT ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRGBLUT
   Inherits ImGearMultichannelLUT
'Usage

Dim instance As ImGearRGBLUT
public class ImGearRGBLUT : ImGearMultichannelLUT
public __gc class ImGearRGBLUT : public ImGearMultichannelLUT
public ref class ImGearRGBLUT : public ImGearMultichannelLUT
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearMultichannelLUT
ImageGear.Core.ImGearRGBLUT

See Also

Reference

ImGearRGBLUT Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRGBLUT Class Members
Fields Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class

The following tables list the members exposed by ImGearRGBLUT.

Public Constructors
 | Name | Description
Public Constructor | ImGearRGBLUT Constructor | Overloaded. Initializes a new instance of the ImGearRGBLUT class.
Top
Public Properties
 | Name | Description
Public Property | BlueLUT | Gets or sets the single-channel LUT for the Blue channel.
Public Property | GreenLUT | Gets or sets the single-channel LUT for the Green channel.
Public Property | RedLUT | Gets or sets the single-channel LUT for the Red channel.
Top
See Also

Reference

ImGearRGBLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearRGBLUT Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class

For a list of all members of this type, see ImGearRGBLUT members.

See Also

Reference

ImGearRGBLUT Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRGBLUT Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class : ImGearRGBLUT Constructor
Initializes a new instance of the ImGearRGBLUT class.
Overload List
Overload | Description
ImGearRGBLUT Constructor() | Initializes a new instance of the ImGearRGBLUT class.
ImGearRGBLUT Constructor(Int32,Int32) | Initializes a new instance of the ImGearRGBLUT class and allocates its single-channel LUTs.
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

ImGearRGBLUT Constructor()

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class > ImGearRGBLUT Constructor : ImGearRGBLUT Constructor()
Initializes a new instance of the ImGearRGBLUT class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRGBLUT()
public ImGearRGBLUT()
public: ImGearRGBLUT();
public:
ImGearRGBLUT();
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members
Overload List


%%PageItemTitle%%

ImGearRGBLUT Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class > ImGearRGBLUT Constructor : ImGearRGBLUT Constructor(Int32,Int32)
Specifies input depth for single-channel LUTs.
Specifies output depth for single-channel LUTs.
Initializes a new instance of the ImGearRGBLUT class and allocates its single-channel LUTs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal inputDepth As Integer, _
   ByVal outputDepth As Integer _
)
'Usage

Dim inputDepth As Integer
Dim outputDepth As Integer

Dim instance As New ImGearRGBLUT(inputDepth, outputDepth)
public ImGearRGBLUT(
   int inputDepth,
   int outputDepth
)
public: ImGearRGBLUT(
   int inputDepth,
   int outputDepth
)
public:
ImGearRGBLUT(
   int inputDepth,
   int outputDepth
)

Parameters

inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearRGBLUT Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class

For a list of all members of this type, see ImGearRGBLUT members.

Public Properties
 | Name | Description
Public Property | BlueLUT | Gets or sets the single-channel LUT for the Blue channel.
Public Property | GreenLUT | Gets or sets the single-channel LUT for the Green channel.
Public Property | RedLUT | Gets or sets the single-channel LUT for the Red channel.
Top
See Also

Reference

ImGearRGBLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearRGBLUT Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class

For a list of all members of this type, see ImGearRGBLUT members.

See Also

Reference

ImGearRGBLUT Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Events$$

ImGearRGBLUT Class Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBLUT Class

For a list of all members of this type, see ImGearRGBLUT members.

See Also

Reference

ImGearRGBLUT Class
ImageGear.Core Namespace


BlueLUT Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class : BlueLUT Property
Gets or sets the single-channel LUT for the Blue channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlueLUT As ImGearLUT
'Usage

Dim instance As ImGearRGBLUT
Dim value As ImGearLUT

instance.BlueLUT = value

value = instance.BlueLUT
public ImGearLUT BlueLUT {get; set;}
public: __property ImGearLUT* get_BlueLUT();
public: __property void set_BlueLUT(
   ImGearLUT* value
);
public:
property ImGearLUT^ BlueLUT {
   ImGearLUT^ get();
   void set (    ImGearLUT^ value);
}

Property Value

ImGearLUT class object.
Remarks
The default value is null.
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


GreenLUT Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class : GreenLUT Property
Gets or sets the single-channel LUT for the Green channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GreenLUT As ImGearLUT
'Usage

Dim instance As ImGearRGBLUT
Dim value As ImGearLUT

instance.GreenLUT = value

value = instance.GreenLUT
public ImGearLUT GreenLUT {get; set;}
public: __property ImGearLUT* get_GreenLUT();
public: __property void set_GreenLUT(
   ImGearLUT* value
);
public:
property ImGearLUT^ GreenLUT {
   ImGearLUT^ get();
   void set (    ImGearLUT^ value);
}

Property Value

ImGearLUT class object.
Remarks
The default value is null.
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


RedLUT Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBLUT Class : RedLUT Property
Gets or sets the single-channel LUT for the Red channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedLUT As ImGearLUT
'Usage

Dim instance As ImGearRGBLUT
Dim value As ImGearLUT

instance.RedLUT = value

value = instance.RedLUT
public ImGearLUT RedLUT {get; set;}
public: __property ImGearLUT* get_RedLUT();
public: __property void set_RedLUT(
   ImGearLUT* value
);
public:
property ImGearLUT^ RedLUT {
   ImGearLUT^ get();
   void set (    ImGearLUT^ value);
}

Property Value

ImGearLUT class object.
Remarks
The default value is null.
See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

ImGearROI Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROI Class
Region of interest associated with an ImGearPage instance.
Object Model
ImGearROI ClassImGearRectangle StructureImGearROI ClassImGearROI Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearROI
'Usage

Dim instance As ImGearROI
public abstract class ImGearROI
public __gc abstract class ImGearROI
public ref class ImGearROI abstract
Remarks
The region of interest (ROI) represents freely shaped image area (rectangular, non-rectangular or entire space) that specifies the meaningful part of an image. For example - it may be used to define the area of an image to which an image processing method's filter should be applied.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearROI
ImageGear.Core.ImGearROIMask
ImageGear.Core.ImGearROIRectangle

See Also

Reference

ImGearROI Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearROI Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROI Class

The following tables list the members exposed by ImGearROI.

Public Fields
 | Name | Description
Public Field | Left | X offset of region in the image.
Public Field | Top | Y offset of region in the image.
Top
Public Properties
 | Name | Description
Public Property | BoundRectangle | Gets the bounding rectangle.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | Intersect | Creates a new ImGearROI instance that is calculated as an intersection of specified ROI and image rectangles.
Public Method | PointInRegion | Checks whether or not the specified point is in the ROI.
Top
See Also

Reference

ImGearROI Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearROI Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROI Class

For a list of all members of this type, see ImGearROI members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | Intersect | Creates a new ImGearROI instance that is calculated as an intersection of specified ROI and image rectangles.
Public Method | PointInRegion | Checks whether or not the specified point is in the ROI.
Top
See Also

Reference

ImGearROI Class
ImageGear.Core Namespace


Clone Method (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Clone() As ImGearROI
'Usage

Dim instance As ImGearROI
Dim value As ImGearROI

value = instance.Clone()
public abstract ImGearROI Clone()
public: abstract ImGearROI* Clone();
public:
abstract ImGearROI^ Clone();

Return Value

ImGearROI class object that is a copy of the current instance.
See Also

Reference

ImGearROI Class
ImGearROI Members


Intersect Method (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : Intersect Method
First ROI to merge.
First image rectangle.
Second ROI to merge.
Second image rectangle.
Horisontal offset of the second ROI and image rectangle.
Vertical offset of the second ROI and image rectangle.
Creates a new ImGearROI instance that is calculated as an intersection of specified ROI and image rectangles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Intersect( _
   ByVal region1 As ImGearROI, _
   ByVal imageRect1 As ImGearRectangle, _
   ByVal region2 As ImGearROI, _
   ByVal imageRect2 As ImGearRectangle, _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
) As ImGearROI
'Usage

Dim region1 As ImGearROI
Dim imageRect1 As ImGearRectangle
Dim region2 As ImGearROI
Dim imageRect2 As ImGearRectangle
Dim offsetX As Integer
Dim offsetY As Integer
Dim value As ImGearROI

value = ImGearROI.Intersect(region1, imageRect1, region2, imageRect2, offsetX, offsetY)
public static ImGearROI Intersect(
   ImGearROI region1,
   ImGearRectangle imageRect1,
   ImGearROI region2,
   ImGearRectangle imageRect2,
   int offsetX,
   int offsetY
)
public: static ImGearROI* Intersect(
   ImGearROI* region1,
   ImGearRectangle imageRect1,
   ImGearROI* region2,
   ImGearRectangle imageRect2,
   int offsetX,
   int offsetY
)
public:
static ImGearROI^ Intersect(
   ImGearROI^ region1,
   ImGearRectangle imageRect1,
   ImGearROI^ region2,
   ImGearRectangle imageRect2,
   int offsetX,
   int offsetY
)

Parameters

region1
First ROI to merge.
imageRect1
First image rectangle.
region2
Second ROI to merge.
imageRect2
Second image rectangle.
offsetX
Horisontal offset of the second ROI and image rectangle.
offsetY
Vertical offset of the second ROI and image rectangle.

Return Value

ImGearROI class object.
Remarks
This method calculate an intersection of regions of interest from two images. Images can have different dimensions, and second image may be positioned at a specified offset relative to the first one. Coordinates of result ROI are relative to the left top corner of the first image.
See Also

Reference

ImGearROI Class
ImGearROI Members
ImGearRectangle Structure


PointInRegion Method (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : PointInRegion Method
The x coordinate of the point.
The y coordinate of the point.
Checks whether or not the specified point is in the ROI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function PointInRegion( _
   ByVal coordinateX As Integer, _
   ByVal coordinateY As Integer _
) As Boolean
'Usage

Dim instance As ImGearROI
Dim coordinateX As Integer
Dim coordinateY As Integer
Dim value As Boolean

value = instance.PointInRegion(coordinateX, coordinateY)
public abstract bool PointInRegion(
   int coordinateX,
   int coordinateY
)
public: abstract bool PointInRegion(
   int coordinateX,
   int coordinateY
)
public:
abstract bool PointInRegion(
   int coordinateX,
   int coordinateY
)

Parameters

coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Return Value

Boolean value.
See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%% $$Properties$$

ImGearROI Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROI Class

For a list of all members of this type, see ImGearROI members.

Public Properties
 | Name | Description
Public Property | BoundRectangle | Gets the bounding rectangle.
Top
See Also

Reference

ImGearROI Class
ImageGear.Core Namespace


BoundRectangle Property (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : BoundRectangle Property
Gets the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property BoundRectangle As ImGearRectangle
'Usage

Dim instance As ImGearROI
Dim value As ImGearRectangle

value = instance.BoundRectangle
public abstract ImGearRectangle BoundRectangle {get;}
public: __property abstract ImGearRectangle get_BoundRectangle();
public:
abstract property ImGearRectangle BoundRectangle {
   ImGearRectangle get();
}

Property Value

ImGearRectangle structure.
See Also

Reference

ImGearROI Class
ImGearROI Members
ImGearRectangle Structure


%%PageItemTitle%% $$Fields$$

ImGearROI Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROI Class

For a list of all members of this type, see ImGearROI members.

Public Fields
 | Name | Description
Public Field | Left | X offset of region in the image.
Public Field | Top | Y offset of region in the image.
Top
See Also

Reference

ImGearROI Class
ImageGear.Core Namespace


Left Field (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : Left Field
X offset of region in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Left As Integer
'Usage

Dim instance As ImGearROI
Dim value As Integer

value = instance.Left

instance.Left = value
public int Left
public: int Left
public:
int Left

Field Value

Integer value
Remarks
Specifies left side of rectangle in case of ImGearROIRectangle, and reference point in case of ImGearROIMask.
See Also

Reference

ImGearROI Class
ImGearROI Members


Top Field (ImGearROI)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROI Class : Top Field
Y offset of region in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Top As Integer
'Usage

Dim instance As ImGearROI
Dim value As Integer

value = instance.Top

instance.Top = value
public int Top
public: int Top
public:
int Top

Field Value

Integer value
Remarks
Specifies top side of rectangle in case of ImGearROIRectangle, and the reference point in case of ImGearROIMask.
See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

ImGearROIMask Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIMask Class
1-bit (binary) raster image that specifies a free shaped region of interest.
Object Model
ImGearROIMask ClassImGearRectangle StructureImGearROI ClassImGearDIB Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearROIMask
   Inherits ImGearROI
'Usage

Dim instance As ImGearROIMask
public sealed class ImGearROIMask : ImGearROI
public __gc __sealed class ImGearROIMask : public ImGearROI
public ref class ImGearROIMask sealed : public ImGearROI
Remarks
You can create an ImGearROIMask class object from a binary raster image or from a shape. If the mask is created from a shape, it represents a rasterized version of the shape.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearROI
ImageGear.Core.ImGearROIMask

See Also

Reference

ImGearROIMask Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearROIMask Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIMask Class

The following tables list the members exposed by ImGearROIMask.

Public Constructors
 | Name | Description
Public Constructor | ImGearROIMask Constructor | Overloaded. Initializes a new instance of the ImGearROIMask class.
Top
Public Properties
 | Name | Description
Public Property | BoundRectangle | Overridden. Gets the bounding rectangle.
Public Property | Mask | Gets 1-bit image that defines region shape.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Dilate | Dilates ROI mask on the specified pixel count.
Public Method | Erode | Erodes ROI mask on the specified pixel count.
Public Method | PointInRegion | Overridden. Checks whether the specified point is in the ROI.
Top
See Also

Reference

ImGearROIMask Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearROIMask Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIMask Class

For a list of all members of this type, see ImGearROIMask members.

See Also

Reference

ImGearROIMask Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearROIMask Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : ImGearROIMask Constructor
Initializes a new instance of the ImGearROIMask class.
Overload List
Overload | Description
ImGearROIMask Constructor(ImGearPage) | Initializes a new instance of the ImGearROIMask class, using the specified bitonal image.
ImGearROIMask Constructor(Int32,Int32,ImGearPage) | Initializes a new instance of the ImGearROIMask class, using the specified offset and a bitonal image.
ImGearROIMask Constructor(Int32,Int32,IImGearShape) | Initializes a new instance of the ImGearROIMask class from an IImGearShape object.
ImGearROIMask Constructor(ImGearPage,ImGearPixel,Boolean) | Initializes a new instance of the ImGearROIMask class, corresponding to an area in the specified page that is filled with the specified color.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

ImGearROIMask Constructor(ImGearPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(ImGearPage)
1-bit image that defines ROI shape.
Initializes a new instance of the ImGearROIMask class, using the specified bitonal image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mask As ImGearPage _
)
'Usage

Dim mask As ImGearPage

Dim instance As New ImGearROIMask(mask)
public ImGearROIMask(
   ImGearPage mask
)
public: ImGearROIMask(
   ImGearPage* mask
)
public:
ImGearROIMask(
   ImGearPage^ mask
)

Parameters

mask
1-bit image that defines ROI shape.
Remarks
Initializes mask from an (ImGearPage) class object.

This constructor clones incoming image and assigns it as a ROI mask, positioned at zero offset.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(Int32,Int32,ImGearPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(Int32,Int32,ImGearPage)
X coordinate of the left top corner of the region.
Y coordinate of the left top corner of the region.
1-bit image that defines ROI shape. Must not be null.
Initializes a new instance of the ImGearROIMask class, using the specified offset and a bitonal image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal mask As ImGearPage _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim mask As ImGearPage

Dim instance As New ImGearROIMask(left, top, mask)
public ImGearROIMask(
   int left,
   int top,
   ImGearPage mask
)
public: ImGearROIMask(
   int left,
   int top,
   ImGearPage* mask
)
public:
ImGearROIMask(
   int left,
   int top,
   ImGearPage^ mask
)

Parameters

left
X coordinate of the left top corner of the region.
top
Y coordinate of the left top corner of the region.
mask
1-bit image that defines ROI shape. Must not be null.
Remarks
This constructor clones incoming image (mask) and assigns to the ROI mask.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(Int32,Int32,IImGearShape)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(Int32,Int32,IImGearShape)
X coordinate of the left top corner of the region.
Y coordinate of the left top corner of the region.
Shape from which the mask will be generated.
Initializes a new instance of the ImGearROIMask class from an IImGearShape object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal shape As IImGearShape _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim shape As IImGearShape

Dim instance As New ImGearROIMask(left, top, shape)
public ImGearROIMask(
   int left,
   int top,
   IImGearShape shape
)
public: ImGearROIMask(
   int left,
   int top,
   IImGearShape* shape
)
public:
ImGearROIMask(
   int left,
   int top,
   IImGearShape^ shape
)

Parameters

left
X coordinate of the left top corner of the region.
top
Y coordinate of the left top corner of the region.
shape
Shape from which the mask will be generated.
Remarks
This constructor generates mask image from the shape with minimal possible dimensions. The shape is rasterized (drawn) onto the mask image at the time of the mask creation. Left member is set to the sum of left parameter and x coordinate of left-most point of the Shape. The Top member is set to the sum of the top parameter and the y coordinate of the topmost point of the Shape.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(ImGearPage,ImGearPixel,Boolean)
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(ImGearPage,ImGearPixel,Boolean)
The page used to construct the ROI mask. Binary (1-bit) pages are not supported.
Mask color.
Set to true to build mask according to area not filled with MaskColor.
Initializes a new instance of the ImGearROIMask class, corresponding to an area in the specified page that is filled with the specified color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage, _
   ByVal maskColor As ImGearPixel, _
   ByVal invertSelection As Boolean _
)
'Usage

Dim page As ImGearPage
Dim maskColor As ImGearPixel
Dim invertSelection As Boolean

Dim instance As New ImGearROIMask(page, maskColor, invertSelection)
public ImGearROIMask(
   ImGearPage page,
   ImGearPixel maskColor,
   bool invertSelection
)
public: ImGearROIMask(
   ImGearPage* page,
   ImGearPixel* maskColor,
   bool invertSelection
)
public:
ImGearROIMask(
   ImGearPage^ page,
   ImGearPixel^ maskColor,
   bool invertSelection
)

Parameters

page
The page used to construct the ROI mask. Binary (1-bit) pages are not supported.
maskColor
Mask color.
invertSelection
Set to true to build mask according to area not filled with MaskColor.
Remarks
Creates an instance of ImGearROIMask object corresponding to area in the page that is filled with maskColor. If invertSelection is true, the mask is created for the area that is not filled with maskColor.

The ImGearPixel passed as maskColor should correspond to page's number of channels and bit depth.

This constructor can be used to create an ROI Mask based on the DICOM Pixel Padding Value.

Example
  • C#
// Set ROI to area that is not filled with Pixel Padding Value
ImGearPixel ppv = new ImGearPixel(1, 16);
ppv[0] = 1024;
ImGearRasterPage rasterPage = (ImGearRasterPage)page;
rasterPage.ROI = new ImGearROIMask(page, ppv, true);
  • Visual Basic
' Set ROI to area that is not filled with Pixel Padding Value
Dim ppv As ImGearPixel = New ImGearPixel(1, 16)
ppv(0) = 1024
Dim rasterPage As ImGearRasterPage = igPage
rasterPage.ROI = New ImGearROIMask(igPage, ppv, True)
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearROIMask Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIMask Class

For a list of all members of this type, see ImGearROIMask members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Dilate | Dilates ROI mask on the specified pixel count.
Public Method | Erode | Erodes ROI mask on the specified pixel count.
Public Method | PointInRegion | Overridden. Checks whether the specified point is in the ROI.
Top
See Also

Reference

ImGearROIMask Class
ImageGear.Core Namespace


Clone Method (ImGearROIMask)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearROI
'Usage

Dim instance As ImGearROIMask
Dim value As ImGearROI

value = instance.Clone()
public override ImGearROI Clone()
public: ImGearROI* Clone(); override
public:
ImGearROI^ Clone(); override

Return Value

ImGearROI class that is a copy of the current instance.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
ImGearROI Class


Dilate Method (ImGearROIMask)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : Dilate Method
The pixel count.
Dilates ROI mask on the specified pixel count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dilate( _
   ByVal pixCount As Integer _
)
'Usage

Dim instance As ImGearROIMask
Dim pixCount As Integer

instance.Dilate(pixCount)
public void Dilate(
   int pixCount
)
public: void Dilate(
   int pixCount
)
public:
void Dilate(
   int pixCount
)

Parameters

pixCount
The pixel count.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Erode Method


Erode Method (ImGearROIMask)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : Erode Method
The pixel count.
Erodes ROI mask on the specified pixel count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Erode( _
   ByVal pixCount As Integer _
)
'Usage

Dim instance As ImGearROIMask
Dim pixCount As Integer

instance.Erode(pixCount)
public void Erode(
   int pixCount
)
public: void Erode(
   int pixCount
)
public:
void Erode(
   int pixCount
)

Parameters

pixCount
The pixel count.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Dilate Method


PointInRegion Method (ImGearROIMask)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : PointInRegion Method
The x coordinate of the point.
The y coordinate of the point.
Checks whether the specified point is in the ROI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function PointInRegion( _
   ByVal coordinateX As Integer, _
   ByVal coordinateY As Integer _
) As Boolean
'Usage

Dim instance As ImGearROIMask
Dim coordinateX As Integer
Dim coordinateY As Integer
Dim value As Boolean

value = instance.PointInRegion(coordinateX, coordinateY)
public override bool PointInRegion(
   int coordinateX,
   int coordinateY
)
public: bool PointInRegion(
   int coordinateX,
   int coordinateY
) override
public:
bool PointInRegion(
   int coordinateX,
   int coordinateY
) override

Parameters

coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Return Value

Boolean value.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%% $$Properties$$

ImGearROIMask Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIMask Class

For a list of all members of this type, see ImGearROIMask members.

Public Properties
 | Name | Description
Public Property | BoundRectangle | Overridden. Gets the bounding rectangle.
Public Property | Mask | Gets 1-bit image that defines region shape.
Top
See Also

Reference

ImGearROIMask Class
ImageGear.Core Namespace


BoundRectangle Property (ImGearROIMask)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : BoundRectangle Property
Gets the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property BoundRectangle As ImGearRectangle
'Usage

Dim instance As ImGearROIMask
Dim value As ImGearRectangle

value = instance.BoundRectangle
public override ImGearRectangle BoundRectangle {get;}
public: __property ImGearRectangle get_BoundRectangle() override;
public:
property ImGearRectangle BoundRectangle {
   ImGearRectangle get() override;
}

Property Value

ImGearRectangle structure.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
ImGearRectangle Structure


Mask Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIMask Class : Mask Property
Gets 1-bit image that defines region shape.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Mask As ImGearDIB
'Usage

Dim instance As ImGearROIMask
Dim value As ImGearDIB

value = instance.Mask
public ImGearDIB Mask {get;}
public: __property ImGearDIB* get_Mask();
public:
property ImGearDIB^ Mask {
   ImGearDIB^ get();
}

Property Value

ImGearDIB class object.
Remarks
Region of interest is represented by a binary (1-bit) image.
See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
ImGearDIB Class


%%PageItemTitle%%

ImGearROIRectangle Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIRectangle Class
Rectangular region of interest.
Object Model
ImGearROIRectangle ClassImGearRectangle StructureImGearROI Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearROIRectangle
   Inherits ImGearROI
'Usage

Dim instance As ImGearROIRectangle
public sealed class ImGearROIRectangle : ImGearROI
public __gc __sealed class ImGearROIRectangle : public ImGearROI
public ref class ImGearROIRectangle sealed : public ImGearROI
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearROI
ImageGear.Core.ImGearROIRectangle

See Also

Reference

ImGearROIRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearROIRectangle Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIRectangle Class

The following tables list the members exposed by ImGearROIRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearROIRectangle Constructor | Overloaded. Initializes a new instance of the ImGearROIRectangle class.
Top
Public Fields
 | Name | Description
Public Field | Height | Height of rectangle in pixels.
Public Field | Width | Width of rectangle in pixels.
Top
Public Properties
 | Name | Description
Public Property | BoundRectangle | Overridden. Gets the bounding rectangle.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | PointInRegion | Overridden. Checks whether or not the specified point is in the ROI.
Top
See Also

Reference

ImGearROIRectangle Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearROIRectangle Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : ImGearROIRectangle Constructor
Initializes a new instance of the ImGearROIRectangle class.
Overload List
Overload | Description
ImGearROIRectangle Constructor(Int32,Int32) | Initializes a new instance of the ImGearROIRectangle class with zero offset and specified size.
ImGearROIRectangle Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearROIRectangle class with specified offset and size.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

ImGearROIRectangle Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class > ImGearROIRectangle Constructor : ImGearROIRectangle Constructor(Int32,Int32)
Width of rectangle.
Height of rectangle.
Initializes a new instance of the ImGearROIRectangle class with zero offset and specified size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim width As Integer
Dim height As Integer

Dim instance As New ImGearROIRectangle(width, height)
public ImGearROIRectangle(
   int width,
   int height
)
public: ImGearROIRectangle(
   int width,
   int height
)
public:
ImGearROIRectangle(
   int width,
   int height
)

Parameters

width
Width of rectangle.
height
Height of rectangle.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Overload List


%%PageItemTitle%%

ImGearROIRectangle Constructor(Int32,Int32,Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class > ImGearROIRectangle Constructor : ImGearROIRectangle Constructor(Int32,Int32,Int32,Int32)
Left side of rectangle.
Top side of rectangle.
Width of rectangle.
Height of rectangle.
Initializes a new instance of the ImGearROIRectangle class with specified offset and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim width As Integer
Dim height As Integer

Dim instance As New ImGearROIRectangle(left, top, width, height)
public ImGearROIRectangle(
   int left,
   int top,
   int width,
   int height
)
public: ImGearROIRectangle(
   int left,
   int top,
   int width,
   int height
)
public:
ImGearROIRectangle(
   int left,
   int top,
   int width,
   int height
)

Parameters

left
Left side of rectangle.
top
Top side of rectangle.
width
Width of rectangle.
height
Height of rectangle.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearROIRectangle Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIRectangle Class

For a list of all members of this type, see ImGearROIRectangle members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | PointInRegion | Overridden. Checks whether or not the specified point is in the ROI.
Top
See Also

Reference

ImGearROIRectangle Class
ImageGear.Core Namespace


Clone Method (ImGearROIRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearROI
'Usage

Dim instance As ImGearROIRectangle
Dim value As ImGearROI

value = instance.Clone()
public override ImGearROI Clone()
public: ImGearROI* Clone(); override
public:
ImGearROI^ Clone(); override

Return Value

ImGearROI class that is a copy of the current instance.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
ImGearROI Class


PointInRegion Method (ImGearROIRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : PointInRegion Method
The x value of the point.
The y value of the point.
Checks whether or not the specified point is in the ROI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function PointInRegion( _
   ByVal coordinateX As Integer, _
   ByVal coordinateY As Integer _
) As Boolean
'Usage

Dim instance As ImGearROIRectangle
Dim coordinateX As Integer
Dim coordinateY As Integer
Dim value As Boolean

value = instance.PointInRegion(coordinateX, coordinateY)
public override bool PointInRegion(
   int coordinateX,
   int coordinateY
)
public: bool PointInRegion(
   int coordinateX,
   int coordinateY
) override
public:
bool PointInRegion(
   int coordinateX,
   int coordinateY
) override

Parameters

coordinateX
The x value of the point.
coordinateY
The y value of the point.

Return Value

Boolean value.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
ImGearROIMask Class


%%PageItemTitle%% $$Properties$$

ImGearROIRectangle Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIRectangle Class

For a list of all members of this type, see ImGearROIRectangle members.

Public Properties
 | Name | Description
Public Property | BoundRectangle | Overridden. Gets the bounding rectangle.
Top
See Also

Reference

ImGearROIRectangle Class
ImageGear.Core Namespace


BoundRectangle Property (ImGearROIRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : BoundRectangle Property
Gets the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property BoundRectangle As ImGearRectangle
'Usage

Dim instance As ImGearROIRectangle
Dim value As ImGearRectangle

value = instance.BoundRectangle
public override ImGearRectangle BoundRectangle {get;}
public: __property ImGearRectangle get_BoundRectangle() override;
public:
property ImGearRectangle BoundRectangle {
   ImGearRectangle get() override;
}

Property Value

ImGearRectangle structure.
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
ImGearRectangle Structure


%%PageItemTitle%% $$Fields$$

ImGearROIRectangle Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearROIRectangle Class

For a list of all members of this type, see ImGearROIRectangle members.

Public Fields
 | Name | Description
Public Field | Height | Height of rectangle in pixels.
Public Field | Width | Width of rectangle in pixels.
Top
See Also

Reference

ImGearROIRectangle Class
ImageGear.Core Namespace


Height Field (ImGearROIRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : Height Field
Height of rectangle in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearROIRectangle
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Integer value
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Width Field


Width Field (ImGearROIRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearROIRectangle Class : Width Field
Width of rectangle in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearROIRectangle
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Integer value
See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Height Field


%%PageItemTitle%%

ImGearSpotChannelInfo Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSpotChannelInfo Class
Spot channel class that uses a special color, such as Pantone.
Object Model
ImGearSpotChannelInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSpotChannelInfo
   Inherits ImGearExtraChannelInfo
'Usage

Dim instance As ImGearSpotChannelInfo
public class ImGearSpotChannelInfo : ImGearExtraChannelInfo
public __gc class ImGearSpotChannelInfo : public ImGearExtraChannelInfo
public ref class ImGearSpotChannelInfo : public ImGearExtraChannelInfo
Remarks
This class does not store a color name, but looks it up from the loaded color books when necessary.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearExtraChannelInfo
ImageGear.Core.ImGearSpotChannelInfo
ImageGear.Core.ImGearMaskSpotChannelInfo

See Also

Reference

ImGearSpotChannelInfo Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearSpotChannelInfo Class Members
Fields Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSpotChannelInfo Class

The following tables list the members exposed by ImGearSpotChannelInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearSpotChannelInfo Constructor | Initializes a new instance of the ImGearSpotChannelInfo class by using spot color vendor ID and color ID.
Top
Public Properties
 | Name | Description
Public Property | ColorID | Gets ID of the spot color.
Public Property | ColorName | Gets color name from internal color books.
Public Property | Opacity | Gets or sets opacity of the spot color.
Public Property | VendorID | Gets vendor ID of the spot color.
Top
See Also

Reference

ImGearSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearSpotChannelInfo Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSpotChannelInfo Class

For a list of all members of this type, see ImGearSpotChannelInfo members.

See Also

Reference

ImGearSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearSpotChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : ImGearSpotChannelInfo Constructor
Vendor ID of the spot color.
Spot color ID in Vendor's color book.
Initializes a new instance of the ImGearSpotChannelInfo class by using spot color vendor ID and color ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal vendorId As ImGearSpotColorVendorID, _
   ByVal colorId As Long _
)
'Usage

Dim vendorId As ImGearSpotColorVendorID
Dim colorId As Long

Dim instance As New ImGearSpotChannelInfo(vendorId, colorId)
public ImGearSpotChannelInfo(
   ImGearSpotColorVendorID vendorId,
   long colorId
)
public: ImGearSpotChannelInfo(
   ImGearSpotColorVendorID vendorId,
   long colorId
)
public:
ImGearSpotChannelInfo(
   ImGearSpotColorVendorID vendorId,
   int64 colorId
)

Parameters

vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book.
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%% $$Properties$$

ImGearSpotChannelInfo Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSpotChannelInfo Class

For a list of all members of this type, see ImGearSpotChannelInfo members.

Public Properties
 | Name | Description
Public Property | ColorID | Gets ID of the spot color.
Public Property | ColorName | Gets color name from internal color books.
Public Property | Opacity | Gets or sets opacity of the spot color.
Public Property | VendorID | Gets vendor ID of the spot color.
Top
See Also

Reference

ImGearSpotChannelInfo Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearSpotChannelInfo Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : ImGearSpotChannelInfo Constructor
Overload List
Overload | Description
ImGearSpotChannelInfo Constructor | Initializes a new instance of the ImGearSpotChannelInfo class by using spot color vendor ID and color ID.
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


ColorID Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : ColorID Property
Gets ID of the spot color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorID As Long
'Usage

Dim instance As ImGearSpotChannelInfo
Dim value As Long

value = instance.ColorID
public long ColorID {get;}
public: __property long get_ColorID();
public:
property int64 ColorID {
   int64 get();
}

Property Value

Long value.
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


ColorName Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : ColorName Property
Gets color name from internal color books.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorName As String
'Usage

Dim instance As ImGearSpotChannelInfo
Dim value As String

value = instance.ColorName
public string ColorName {get;}
public: __property string* get_ColorName();
public:
property String^ ColorName {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


Opacity Property (ImGearSpotChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : Opacity Property
Gets or sets opacity of the spot color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearSpotChannelInfo
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value in range [0...100].
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


VendorID Property (ImGearSpotChannelInfo)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSpotChannelInfo Class : VendorID Property
Gets vendor ID of the spot color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VendorID As ImGearSpotColorVendorID
'Usage

Dim instance As ImGearSpotChannelInfo
Dim value As ImGearSpotColorVendorID

value = instance.VendorID
public ImGearSpotColorVendorID VendorID {get;}
public: __property ImGearSpotColorVendorID get_VendorID();
public:
property ImGearSpotColorVendorID VendorID {
   ImGearSpotColorVendorID get();
}

Property Value

ImGearSpotColorVendorID enumeration value.
See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

ImGearTransparency Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearTransparency Class
Specifies image transparency attributes like transparent color for display.
Object Model
ImGearTransparency Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearTransparency
'Usage

Dim instance As ImGearTransparency
public class ImGearTransparency
public __gc class ImGearTransparency
public ref class ImGearTransparency
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearTransparency

See Also

Reference

ImGearTransparency Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearTransparency Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearTransparency Class

The following tables list the members exposed by ImGearTransparency.

Public Constructors
 | Name | Description
Public Constructor | ImGearTransparency Constructor | Initializes a new instance of the ImGearTransparency class by specifying a transparent color for display in RGB format.
Top
Public Fields
 | Name | Description
Public Field | DisplayColor | Specifies transparent color for display.
Top
See Also

Reference

ImGearTransparency Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearTransparency Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearTransparency Class : ImGearTransparency Constructor
Red value of the transparent color for display.
Green value of the transparent color for display.
Blue value of the transparent color for display.
Initializes a new instance of the ImGearTransparency class by specifying a transparent color for display in RGB format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal redDisplayColor As Byte, _
   ByVal greenDisplayColor As Byte, _
   ByVal blueDisplayColor As Byte _
)
'Usage

Dim redDisplayColor As Byte
Dim greenDisplayColor As Byte
Dim blueDisplayColor As Byte

Dim instance As New ImGearTransparency(redDisplayColor, greenDisplayColor, blueDisplayColor)
public ImGearTransparency(
   byte redDisplayColor,
   byte greenDisplayColor,
   byte blueDisplayColor
)
public: ImGearTransparency(
   byte redDisplayColor,
   byte greenDisplayColor,
   byte blueDisplayColor
)
public:
ImGearTransparency(
   byte redDisplayColor,
   byte greenDisplayColor,
   byte blueDisplayColor
)

Parameters

redDisplayColor
Red value of the transparent color for display.
greenDisplayColor
Green value of the transparent color for display.
blueDisplayColor
Blue value of the transparent color for display.
See Also

Reference

ImGearTransparency Class
ImGearTransparency Members


%%PageItemTitle%% $$Fields$$

ImGearTransparency Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearTransparency Class

For a list of all members of this type, see ImGearTransparency members.

Public Fields
 | Name | Description
Public Field | DisplayColor | Specifies transparent color for display.
Top
See Also

Reference

ImGearTransparency Class
ImageGear.Core Namespace


DisplayColor Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearTransparency Class : DisplayColor Field
Specifies transparent color for display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public DisplayColor As IImGearRGBQuad
'Usage

Dim instance As ImGearTransparency
Dim value As IImGearRGBQuad

value = instance.DisplayColor

instance.DisplayColor = value
public IImGearRGBQuad DisplayColor
public: IImGearRGBQuad* DisplayColor
public:
IImGearRGBQuad^ DisplayColor

Field Value

ImGearRGBQuad structure.
Remarks
Note:

This attribute is not supported by the WPF display renderer.

See Also

Reference

ImGearTransparency Class
ImGearTransparency Members
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearVectorPage Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVectorPage Class
Represents a page that contains vector data.
Object Model
ImGearVectorPage ClassImGearPage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearVectorPage
   Inherits ImGearPage
'Usage

Dim instance As ImGearVectorPage
public abstract class ImGearVectorPage : ImGearPage
public __gc abstract class ImGearVectorPage : public ImGearPage
public ref class ImGearVectorPage abstract : public ImGearPage
Remarks
The DIB property will non-null for the instances of this type but it will contain no pixel data.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearExcelBookPage
ImageGear.Formats.Office.ImGearExcelSheetPage
ImageGear.Formats.Office.ImGearPowerPointPage
ImageGear.Formats.Office.ImGearWordPage
ImageGear.Formats.PDF.ImGearPDFPage
ImageGear.Vector.ImGearVectPage
ImageGear.WPF.XPS.ImGearXPSPage

See Also

Reference

ImGearVectorPage Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorPage Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVectorPage Class

The following tables list the members exposed by ImGearVectorPage.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Rasterize | Overloaded. Creates raster image representation of contained vector image.
Top
See Also

Reference

ImGearVectorPage Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorPage Class Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVectorPage Class

For a list of all members of this type, see ImGearVectorPage members.

See Also

Reference

ImGearVectorPage Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorPage Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVectorPage Class

For a list of all members of this type, see ImGearVectorPage members.

See Also

Reference

ImGearVectorPage Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorPage Class Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVectorPage Class

For a list of all members of this type, see ImGearVectorPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Rasterize | Overloaded. Creates raster image representation of contained vector image.
Top
See Also

Reference

ImGearVectorPage Class
ImageGear.Core Namespace


Clone Method (ImGearVectorPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVectorPage Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides MustOverride Function Clone() As ImGearPage
'Usage

Dim instance As ImGearVectorPage
Dim value As ImGearPage

value = instance.Clone()
public override abstract ImGearPage Clone()
public: abstract ImGearPage* Clone(); override
public:
abstract ImGearPage^ Clone(); override

Return Value

ImGearVectorPage class that is a copy of the current instance.
See Also

Reference

ImGearVectorPage Class
ImGearVectorPage Members


Rasterize Method (ImGearVectorPage)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVectorPage Class : Rasterize Method
Creates raster image representation of contained vector image.
Overload List
Overload | Description
Rasterize() | Creates raster image representation of contained vector image.
Rasterize(Int32,Int32,Int32) | Rasterizes the page using provided bit depth and resolution parameters.
See Also

Reference

ImGearVectorPage Class
ImGearVectorPage Members


Rasterize() Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVectorPage Class > Rasterize Method : Rasterize() Method
Creates raster image representation of contained vector image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearVectorPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public abstract ImGearRasterPage Rasterize()
public: abstract ImGearRasterPage* Rasterize();
public:
abstract ImGearRasterPage^ Rasterize();

Return Value

Stand-alone instance of ImGearPage class.
Remarks
Rasterizes vector data into raster page.
Example
  • C#
ImGearPage igPage;
// Load a vector image into a ImGearPage object
using (FileStream localFile = new FileStream("vector.cgm", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Check if vector page, and rasterize if it is.
if (igPage is ImGearVectorPage)
{
    // Adjust the image size to 1024 width maintaining aspect ratio
    ImGearProcessing.Resize(igPage, 1024,
        igPage.DIB.Height * 1024 / igPage.DIB.Width, null);
    // Get a rasterized version of the vector image at this resolution
    igPage = ((ImGearVectorPage)igPage).Rasterize();
}
  • Visual Basic
Dim igPage As ImGearPage
'Load a vector image into a ImGearPage object.
Dim localFile As FileStream = New FileStream("vector.cgm", FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Check if vector page, and rasterize if it is.
If (TypeOf igPage Is ImGearVectorPage) Then
    'Adjust the image size to 1024 width maintaining aspect ratio.
    ImGearProcessing.Resize(igPage, 1024, _
        igPage.DIB.Height * 1024 / igPage.DIB.Width, Nothing)
    'Get a rasterized version of the vector image at this resolution.
    igPage = CType(igPage, ImGearVectorPage).Rasterize()
End If
See Also

Reference

ImGearVectorPage Class
ImGearVectorPage Members
Overload List
ImGearPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVectorPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
Rasterizes the page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearVectorPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public abstract ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: abstract ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public:
abstract ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.

Return Value

ImGearRasterPage class instance with rasterized vector data.
Remarks
The support level for parameter bitDepth depends on each particular vector format, i.e it may either just ignore it, or consider limited set of bit depths. Please see below the table of Vector formats, that describes how they handle the parameter bitDepth.
File Format | bitDepth supported | Remarks
Adobe PDF/Adobe PS | Yes | Supported values: 1, 8 and 24.
Computer Graphics Metafile (SGM) | No | Uses 8 bit Indexed or 24 bit RGB color space.
MicroStation Drawing (DGN) | No | Uses 8 bit Indexed or 24 bit RGB color space.
Design Web Format (DWF) | No | Uses 24 bit RGB color space.
AutoDesk AutoCAD (DWG) | No | Uses 8 bit Indexed or 24 bit RGB color space.
Drawing eXchange Format (DXF) | No | Uses 8 bit Indexed or 24 bit RGB color space.
Hewlett Packard Graphics Language (HPGL) | No | Uses 8 bit Indexed or 24 bit RGB color space.
Universal 3D (U3D) | No | Uses 24 bit RGB color space.
XML Paper Specification (XPS) | No | Uses 32 bit RGBA color space.
Scalable Vector Graphics (SVG) | Yes | Supported values: 24 and 32.
Office Open XML Word (DOCX) | No | Uses 24 bit RGB color space.
Office Open XML Excel (XLSX) | No | Uses 24 bit RGB color space.
Office Open XML PowerPoint (PPTX) | No | Uses 24 bit RGB color space.
See Also

Reference

ImGearVectorPage Class
ImGearVectorPage Members
Overload List
ImGearRasterPage Class


%%PageItemTitle%%

ImGearVersion Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVersion Class
This class provides static properties to retrieve version info for the product assembly.
Object Model
ImGearVersion Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearVersion
'Usage

Dim instance As ImGearVersion
public sealed class ImGearVersion
public __gc __sealed class ImGearVersion
public ref class ImGearVersion sealed
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearVersion

See Also

Reference

ImGearVersion Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearVersion Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVersion Class

The following tables list the members exposed by ImGearVersion.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AssemblyVersion | Gets version info for this assembly.
static (Shared in Visual Basic) | AssemblyVersionInfo | Gets version info for this assembly.
static (Shared in Visual Basic) | Build | Gets build number.
static (Shared in Visual Basic) | Copyright | Gets copyright information.
static (Shared in Visual Basic) | Major | Gets major version number.
static (Shared in Visual Basic) | Minor | Gets minor version number.
static (Shared in Visual Basic) | ProductName | Gets product name.
static (Shared in Visual Basic) | Revision | Gets revision number.
static (Shared in Visual Basic) | VersionString | Gets product version in the string format.
Top
See Also

Reference

ImGearVersion Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearVersion Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearVersion Class

For a list of all members of this type, see ImGearVersion members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AssemblyVersion | Gets version info for this assembly.
static (Shared in Visual Basic) | AssemblyVersionInfo | Gets version info for this assembly.
static (Shared in Visual Basic) | Build | Gets build number.
static (Shared in Visual Basic) | Copyright | Gets copyright information.
static (Shared in Visual Basic) | Major | Gets major version number.
static (Shared in Visual Basic) | Minor | Gets minor version number.
static (Shared in Visual Basic) | ProductName | Gets product name.
static (Shared in Visual Basic) | Revision | Gets revision number.
static (Shared in Visual Basic) | VersionString | Gets product version in the string format.
Top
See Also

Reference

ImGearVersion Class
ImageGear.Core Namespace


AssemblyVersion Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : AssemblyVersion Property
Gets version info for this assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AssemblyVersion As Version
'Usage

Dim value As Version

value = ImGearVersion.AssemblyVersion
public static Version AssemblyVersion {get;}
public: __property static Version* get_AssemblyVersion();
public:
static property Version^ AssemblyVersion {
   Version^ get();
}

Property Value

System.Version value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


AssemblyVersionInfo Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : AssemblyVersionInfo Property
Gets version info for this assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AssemblyVersionInfo As FileVersionInfo
'Usage

Dim value As FileVersionInfo

value = ImGearVersion.AssemblyVersionInfo
public static FileVersionInfo AssemblyVersionInfo {get;}
public: __property static FileVersionInfo* get_AssemblyVersionInfo();
public:
static property FileVersionInfo^ AssemblyVersionInfo {
   FileVersionInfo^ get();
}

Property Value

System.Diagnostics.FileVersionInfo value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


Build Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : Build Property
Gets build number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Build As Integer
'Usage

Dim value As Integer

value = ImGearVersion.Build
public static int Build {get;}
public: __property static int get_Build();
public:
static property int Build {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


Copyright Property (ImGearVersion)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : Copyright Property
Gets copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Copyright As String
'Usage

Dim value As String

value = ImGearVersion.Copyright
public static string Copyright {get;}
public: __property static string* get_Copyright();
public:
static property String^ Copyright {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


Major Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : Major Property
Gets major version number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Major As Integer
'Usage

Dim value As Integer

value = ImGearVersion.Major
public static int Major {get;}
public: __property static int get_Major();
public:
static property int Major {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


Minor Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : Minor Property
Gets minor version number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Minor As Integer
'Usage

Dim value As Integer

value = ImGearVersion.Minor
public static int Minor {get;}
public: __property static int get_Minor();
public:
static property int Minor {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


ProductName Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : ProductName Property
Gets product name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProductName As String
'Usage

Dim value As String

value = ImGearVersion.ProductName
public static string ProductName {get;}
public: __property static string* get_ProductName();
public:
static property String^ ProductName {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


Revision Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : Revision Property
Gets revision number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Revision As Integer
'Usage

Dim value As Integer

value = ImGearVersion.Revision
public static int Revision {get;}
public: __property static int get_Revision();
public:
static property int Revision {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


VersionString Property (ImGearVersion)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearVersion Class : VersionString Property
Gets product version in the string format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property VersionString As String
'Usage

Dim value As String

value = ImGearVersion.VersionString
public static string VersionString {get;}
public: __property static string* get_VersionString();
public:
static property String^ VersionString {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

ImGearWarning Class
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearWarning Class
Base class for all warnings handled by the ImageGear for .NET library. Contains error code and optionally supplied data.
Object Model
ImGearWarning Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearWarning
'Usage

Dim instance As ImGearWarning
public sealed class ImGearWarning
public __gc __sealed class ImGearWarning
public ref class ImGearWarning sealed
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearWarning

See Also

Reference

ImGearWarning Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearWarning Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearWarning Class

The following tables list the members exposed by ImGearWarning.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AddWarning | Gets or sets reference to the AddWarning delegate.
Public Property | Description | Gets or sets warning description.
Public Property | ErrorCode | Gets or sets warning code.
Top
See Also

Reference

ImGearWarning Class
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearWarning Class Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearWarning Class

For a list of all members of this type, see ImGearWarning members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AddWarning | Gets or sets reference to the AddWarning delegate.
Public Property | Description | Gets or sets warning description.
Public Property | ErrorCode | Gets or sets warning code.
Top
See Also

Reference

ImGearWarning Class
ImageGear.Core Namespace


AddWarning Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearWarning Class : AddWarning Property
Gets or sets reference to the AddWarning delegate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property AddWarning As ImGearAddWarning
'Usage

Dim value As ImGearAddWarning

ImGearWarning.AddWarning = value

value = ImGearWarning.AddWarning
public static ImGearAddWarning AddWarning {get; set;}
public: __property static ImGearAddWarning* get_AddWarning();
public: __property static void set_AddWarning(
   ImGearAddWarning* value
);
public:
static property ImGearAddWarning^ AddWarning {
   ImGearAddWarning^ get();
   void set (    ImGearAddWarning^ value);
}

Property Value

ImGearAddWarning Delegate.
See Also

Reference

ImGearWarning Class
ImGearWarning Members
ImGearAddWarning Delegate


Description Property (ImGearWarning)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearWarning Class : Description Property
Gets or sets warning description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As ImGearWarning
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearWarning Class
ImGearWarning Members


ErrorCode Property (ImGearWarning)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearWarning Class : ErrorCode Property
Gets or sets warning code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCode As ImGearErrorCodes
'Usage

Dim instance As ImGearWarning
Dim value As ImGearErrorCodes

instance.ErrorCode = value

value = instance.ErrorCode
public ImGearErrorCodes ErrorCode {get; set;}
public: __property ImGearErrorCodes get_ErrorCode();
public: __property void set_ErrorCode(
   ImGearErrorCodes value
);
public:
property ImGearErrorCodes ErrorCode {
   ImGearErrorCodes get();
   void set (    ImGearErrorCodes value);
}

Property Value

ImGearErrorCodes enumeration value.
See Also

Reference

ImGearWarning Class
ImGearWarning Members
ImGearErrorCodes Enumeration


%%PageItemTitle%%

ImGearChannelGroups Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearChannelGroups Enumeration
Specifies alpha channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearChannelGroups
   Inherits System.Enum
'Usage

Dim instance As ImGearChannelGroups
public enum ImGearChannelGroups : System.Enum
__value public enum ImGearChannelGroups : public System.Enum
public enum class ImGearChannelGroups : public System.Enum
Members
Member | Value | Description
ALL | 5 | All channels.
ALPHA | 1 | Alpha channels.
ALPHA_EXTRA | 4 | Extra and alpha channels.
COLOR | 0 | Color channels.
COLOR_ALPHA | 3 | Color and alpha channels.
EXTRA | 2 | Extra channels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearChannelGroups

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorSpaceIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorSpaceIDs Enumeration
Specifies ImageGear color space IDs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearColorSpaceIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearColorSpaceIDs
public enum ImGearColorSpaceIDs : System.Enum
__value public enum ImGearColorSpaceIDs : public System.Enum
public enum class ImGearColorSpaceIDs : public System.Enum
Members
Member | Value | Description
A | 0x00000100 | Image has alpha channel; color channels are not pre-multiplied by Alpha channel.
CMY | 0x00000008 | CMY color space.
CMYK | 0x00000009 | CMYK color space.
CMYKEx | 0x00000409 | CMYK + Extra channel.
ColorMask | 0x000000FF | Bitmask used to access color space description for color channels only (e.g., RGBEx & ColorMask == RGB; GyA & ColorMask == Gy).
Ex | 0x00000400 | Extra channel.
Gy | 0x00000002 | Grayscale color space.
GyA | 0x00000102 | Grayscale + Alpha channel.
GyPA | 0x00000202 | Grayscale + premultiplied alpha channel.
GyPAEx | 0x00000602 | Grayscale + premultiplied alpha channel + extra channel.
HLS | 0x00000005 | HLS color space.
I | 0x00000003 | Indexed RGB color space. Has RGBQuad palette and one channel. Channel depth is <= 8; the number of palette entries is 2^<channel depth>. No other color space can have non-null palette.
IHS | 0x00000004 | IHS color space.
LAB | 0x00000006 | LAB color space.
NONE | 0x00000000 | No color space is specified.
P | 0x00000200 | Premultiplied channel.
RGB | 0x00000001 | RGB color space.
RGBA | 0x00000101 | RGB + alpha channel.
RGBAEx | 0x00000501 | RGB + alpha + extra channel.
RGBEx | 0x00000401 | RGB + extra channel.
RGBPA | 0x00000201 | RGB + premultiplied alpha channel.
RGBPAEx | 0x00000601 | RGB + premultiplied alpha channel + extra channel.
Unknown | 0x00000400 | Only ‘Extra’ channels are present (1 or more channels).
YCbCr | 0x0000000A | YCbCr color space.
YIQ | 0x00000007 | YIQ color space.
YUV | 0x0000000B | YUV color space.
Remarks
Specifies color space IDs. All colorspaces listed in this enumeration are supported for internal image storage.

ImageGear also supports colorspaces corresponding to valid combinations of ImGearColorSpaceIDs identifiers. Valid values are composed of a color identifier, such as RGB, Gy, Lab, etc, an optional Alpha and premulultiplied Alpha channel identifiers, and an optional Extra channel identifier. If Premultiplied Alpha bit is set, Alpha bit shall also be set. Only RGB and Gy colorspaces are currently allowed to be combined with Alpha or Premultiplied Alpha.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearColorSpaceIDs

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearErrorCodes Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearErrorCodes Enumeration
Specifies ImageGear error codes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearErrorCodes
   Inherits System.Enum
'Usage

Dim instance As ImGearErrorCodes
public enum ImGearErrorCodes : System.Enum
__value public enum ImGearErrorCodes : public System.Enum
public enum class ImGearErrorCodes : public System.Enum
Members
Member | Value | Description
ART_ACCESS_DENIED | 53 | Don't have sufficient permissions to access the ART object.
ART_FAILURE | 54 | The ART failure.
BARCODE_FAILURE | 48 | The barcode generic failure.
CANT_ADD_COLOR_TO_COLORBOOK | 45 | Cannot add color to color book.
CANT_CREATE_COLORBOOK | 46 | Cannot create new color book.
CANT_DETECT_FORMAT | 12 | Cannot detect format.
CANT_FIND_FORMAT | 13 | Cannot find format.
CANT_LOAD_LIBRARY | 39 | Cannot load a specified library.
CANT_READ_PIXELS | 18 | Cannot read image pixels.
CANT_READ_PROFILE | 36 | Cannot read profile.
CANT_SAVE_FORMAT | 21 | Cannot save format.
CYCLIC_REFERENCE | 8 | Cyclic reference.
DATA_STREAM_INCOMPLETE | 23 | Data stream incomplete.
DICOM_MPR_FAILURE | 52 | DICOM Multi-Planar Reconstruction failure.
FFTW_NOT_INITIALIZED | 43 | Support for FFTW is not initialized.
FORMAT_ALREADY_ADDED | 14 | The specified format is already in the collection.
INTERNAL_FAILURE | 35 | Internal failure.
INVALID_BITCOUNT_FOR_FORMAT | 9 | Invalid bit depth for the specified format.
INVALID_COMPLEX_OBJECT | 42 | Invalid complex object.
INVALID_COMPRESSED_DATA | 22 | Invalid compression data.
INVALID_COMPRESSION | 15 | Invalid compression.
INVALID_HEADER_FOR_FORMAT | 10 | Invalid header for the format.
INVALID_IMAGE_DIMENSIONS | 19 | Invalid image dimensions.
INVALID_IMAGE_TILE_DIMENSIONS | 20 | Invalid image tile dimensions.
INVALID_LOOK_UP_TABLE | 24 | Invalid lookup table.
INVALID_RESOLUTION_VALUE_FOR_FORMAT | 11 | Invalid resolution for using format.
INVALID_TYPE | 4 | Invalid type.
IP_FUNCTION_NOT_APPLICABLE_TO_DIB | 26 | The IP method is not supported for the specified DIB.
JPEG2K_FAILURE | 28 | The JPEG 2000 failure.
MEDC_FAILURE | 47 | MedC specific error code.
NOT_IMPLEMENTED_YET | 2 | The API is not yet implemented.
NOT_LICENSED | 1 | The product of feature are not licensed.
OWNER_ALREADY_ASSIGNED | 6 | Owner has already been assigned.
OWNER_NOT_ASSIGNED | 7 | Owner has not been assigned.
PAGE_NOT_PRESENT | 16 | The specified page is not present.
PARAMETER_HAS_INVALID_VALUE | 3 | The parameter has an invalid value.
PDF_FAILURE | 27 | The PDF failure.
PROFILE_CONVERSION_FAILED | 37 | Profile conversion failed..
REC_CANT_CREATE_UNIQUE_SETTINGS | 50 | Cannot create a new settings collection.
REC_CHAR_UNREPRESENTABLE_BY_FONT | 49 | The PDF font selected for PDF export cannot fully represent all the characters in the output text.
REC_ENGINE_FAILURE | 33 | The recognition engine failure..
REC_FAILURE | 32 | The recognition generic failure.
REC_INSTANCE_DISPOSED | 51 | The ImGearRecognition instance has been disposed.
REC_PDFA_STRUCTURE_FAILURE | 55 | Cannot create PDF/A-1 compatible document.
REC_ZERO_RESOLUTION | 34 | Image is with zero resolution.
REQUIRE_8_16_32BIT_GRAYSCALE_1CHANNEL | 41 | Require 8, 16 or 32bit gray-scale image with one channel.
REQUIRE_8BIT_GRAYSCALE_1CHANNEL | 40 | Require 8bit gray-scale image with one channel.
SPOT_COLOR_IS_UNKNOWN | 44 | Spot color is absent and cannot be displayed.
SUCCESS | 0 | No errors have been reported.
THUMBNAIL_NOT_PRESENT | 25 | This image does not contain a thumbnail.
TILE_NOT_PRESENT | 17 | The specified tile is not present.
TWAIN_FAILURE | 29 | The TWAIN failure.
TWAIN_OPERATION_CANCELED | 30 | The TWAIN operation is canceled.
TWAIN_OPERATION_CANCELED_BY_EVENT | 31 | The TWAIN operation is canceled by event handler.
VALUES_ARE_INCOMPATIBLE | 5 | The specified values are incompatible.
WRONG_METADATA_FORMAT | 38 | Wrong metadata format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearErrorCodes

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearExtraChannelType Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearExtraChannelType Enumeration
Specifies all the supported types of extra channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearExtraChannelType
   Inherits System.Enum
'Usage

Dim instance As ImGearExtraChannelType
public enum ImGearExtraChannelType : System.Enum
__value public enum ImGearExtraChannelType : public System.Enum
public enum class ImGearExtraChannelType : public System.Enum
Members
Member | Value | Description
Mask | 1 | Mask channel.
Spot | 2 | Spot channel.
Unknown | 0 | Unknown channel.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearExtraChannelType

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearFlipModes Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearFlipModes Enumeration
Specifies ImageGear flip modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFlipModes
   Inherits System.Enum
'Usage

Dim instance As ImGearFlipModes
public enum ImGearFlipModes : System.Enum
__value public enum ImGearFlipModes : public System.Enum
public enum class ImGearFlipModes : public System.Enum
Members
Member | Value | Description
HORIZONTAL | 0 | Flip around horizontal axis.
VERTICAL | 1 | Flip around vertical axis.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearFlipModes

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearMaskChannelModes Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearMaskChannelModes Enumeration
Specifies whether the color indicates masked or selected area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMaskChannelModes
   Inherits System.Enum
'Usage

Dim instance As ImGearMaskChannelModes
public enum ImGearMaskChannelModes : System.Enum
__value public enum ImGearMaskChannelModes : public System.Enum
public enum class ImGearMaskChannelModes : public System.Enum
Members
Member | Value | Description
ColorIndicatesMaskedArea | 1 | Specifies that color indicates masked area.
ColorIndicatesSelectedArea | 0 | Specifies that color indicates selected area.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearMaskChannelModes

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearOrientationModes Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientationModes Enumeration
Specifies ImageGear orientation modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearOrientationModes
   Inherits System.Enum
'Usage

Dim instance As ImGearOrientationModes
public enum ImGearOrientationModes : System.Enum
__value public enum ImGearOrientationModes : public System.Enum
public enum class ImGearOrientationModes : public System.Enum
Members
Member | Value | Description
BOTTOM_LEFT | 4 | Bottom to the Left orientation.
BOTTOM_RIGHT | 3 | Bottom to the Right orientation.
LEFT_BOTTOM | 8 | Left to the Bottom orientation.
LEFT_TOP | 5 | Left to the Top orientation.
RIGHT_BOTTOM | 7 | Right to the Bottom orientation.
RIGHT_TOP | 6 | Right to the Top orientation.
TOP_LEFT | 1 | Top to the Left orientation.
TOP_RIGHT | 2 | Top to the Right orientation.
Remarks
Specifies ImageGear orientation modes.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearOrientationModes

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRenderingIntents Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRenderingIntents Enumeration
Lists identifiers that controls how colors are transformed during color space conversion using color profiles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRenderingIntents
   Inherits System.Enum
'Usage

Dim instance As ImGearRenderingIntents
public enum ImGearRenderingIntents : System.Enum
__value public enum ImGearRenderingIntents : public System.Enum
public enum class ImGearRenderingIntents : public System.Enum
Members
Member | Value | Description
ABSOLUTE_COLORIMETRIC | 3 | Absolute colorimetric, also known as Match intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is preserved.
PERCEPTUAL | 0 | Perceptual intent, also known as Picture intent, is the most commonly used intent. It scales all colors in the gamut to fit the new color space, preserving gray balance at the possible expense of colorimetric accuracy.
RELATIVE_COLORIMETRIC | 1 | Relative colorimetric intent, also known as Proof intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is not preserved.
SATURATION | 2 | Saturation intent, also known as Graphic intent, preserves the saturation of the image at the possible expense of hue and lightness. It is intended for graphics such as charts.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearRenderingIntents

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearResolutionUnits Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearResolutionUnits Enumeration
Specifies the measurements of image resolution units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearResolutionUnits
   Inherits System.Enum
'Usage

Dim instance As ImGearResolutionUnits
public enum ImGearResolutionUnits : System.Enum
__value public enum ImGearResolutionUnits : public System.Enum
public enum class ImGearResolutionUnits : public System.Enum
Members
Member | Value | Description
CENTIMETERS | 3 | Centimeters resolution unit.
INCHES | 2 | Inches resolution unit.
METERS | 1 | Meters resolution unit.
NO_ABS | 0 | No absolute resolution unit.
TEN_CENTIMETERS | 5 | Ten centimeters resolution unit.
TEN_INCHES | 4 | Ten inches resolution unit.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearResolutionUnits

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRotationValues Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRotationValues Enumeration
Specifies the value of the rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRotationValues
   Inherits System.Enum
'Usage

Dim instance As ImGearRotationValues
public enum ImGearRotationValues : System.Enum
__value public enum ImGearRotationValues : public System.Enum
public enum class ImGearRotationValues : public System.Enum
Members
Member | Value | Description
VALUE_0 | 0 | No rotation.
VALUE_180 | 2 | Rotation on 180 grades.
VALUE_270 | 3 | Rotation on 270 grades.
VALUE_90 | 1 | Rotation on 90 grades.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearRotationValues

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearSpotColorVendorID Enumeration

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSpotColorVendorID Enumeration
Specifies all supported vendor IDs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSpotColorVendorID
   Inherits System.Enum
'Usage

Dim instance As ImGearSpotColorVendorID
public enum ImGearSpotColorVendorID : System.Enum
__value public enum ImGearSpotColorVendorID : public System.Enum
public enum class ImGearSpotColorVendorID : public System.Enum
Members
Member | Value | Description
ANPA | 3000 | ANPA vendor ID.
DIC | 3012 | DIC vendor ID.
Focoltone | 3001 | Focoltone vendor ID.
HKSE | 3008 | HKSE vendor ID.
HKSEProcess | 3024 | HKSEProcess vendor ID.
HKSK | 3009 | HKSK vendor ID.
HKSKProcess | 3025 | HKSKProcess vendor ID.
HKSN | 3010 | HKSN vendor ID.
HKSNProcess | 3026 | HKSNProcess vendor ID.
HKSZ | 3011 | HKSZ vendor ID.
HKSZProcess | 3027 | HKSZProcess vendor ID.
PantoneCoated | 3002 | PantoneCoated vendor ID.
PantoneMatte | 3013 | PantoneMatte vendor ID.
PantoneMetallic | 3022 | PantoneMetallic vendor ID.
PantonePastelCoated | 3020 | PantonePastelCoated vendor ID.
PantonePastelUncoated | 3021 | PantonePastelUncoated vendor ID.
PantoneProcess | 3003 | PantoneProcess vendor ID.
PantoneProcessUncoated | 3029 | PantoneProcessUncoated vendor ID.
PantoneProSlim | 3004 | PantoneProSlim vendor ID.
PantoneProSlimEuro | 3028 | PantoneProSlimEuro vendor ID.
PantoneUncoated | 3005 | PantoneUncoated vendor ID.
SynDIC | 11 | DIC group (synonym) vendor ID.
SynFocoltone | 4 | Focoltone group (synonym) vendor ID.
SynHKS | 10 | HKS group (synonym) vendor ID.
SynPantone | 3 | Pantone group (synonym) vendor ID.
SynToyo | 6 | Toyo group (synonym) vendor ID.
SynTrumatch | 5 | Trumatch group (synonym) vendor ID.
Toyo | 3006 | Toyo vendor ID.
Trumatch | 3007 | Trumatch vendor ID.
UserColorBook | 3100 | Vendor ID reserved for user color books.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Core.ImGearSpotColorVendorID

See Also

Reference

ImageGear.Core Namespace


%%PageItemTitle%%

ImGearArrayRef Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearArrayRef Structure
Represents a reference to a particular location in an array.
Object Model
ImGearArrayRef Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearArrayRef
   Inherits System.ValueType
'Usage

Dim instance As ImGearArrayRef
public struct ImGearArrayRef : System.ValueType
public __value struct ImGearArrayRef : public System.ValueType
public value class ImGearArrayRef : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearArrayRef

See Also

Reference

ImGearArrayRef Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearArrayRef Structure Members
Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearArrayRef Structure

The following tables list the members exposed by ImGearArrayRef.

Public Constructors
 | Name | Description
Public Constructor | ImGearArrayRef Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Content | Specifies structure content.
Public Field | Offset | Specifies structure offset.
Top
See Also

Reference

ImGearArrayRef Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearArrayRef Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearArrayRef Structure : ImGearArrayRef Constructor
Overload List
Overload | Description
ImGearArrayRef Constructor(Array,Int32) | Initializes a new instance of the ImGearArrayRef structure.
ImGearArrayRef Constructor(Array) | Initializes a new instance of the ImGearArrayRef structure.
See Also

Reference

ImGearArrayRef Structure
ImGearArrayRef Members


%%PageItemTitle%%

ImGearArrayRef Constructor(Array,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearArrayRef Structure > ImGearArrayRef Constructor : ImGearArrayRef Constructor(Array,Int32)
Structure content.
Offset value.
Initializes a new instance of the ImGearArrayRef structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As Array, _
   ByVal offset As Integer _
)
'Usage

Dim content As Array
Dim offset As Integer

Dim instance As New ImGearArrayRef(content, offset)
public ImGearArrayRef(
   Array content,
   int offset
)
public: ImGearArrayRef(
   Array* content,
   int offset
)
public:
ImGearArrayRef(
   Array^ content,
   int offset
)

Parameters

content
Structure content.
offset
Offset value.
See Also

Reference

ImGearArrayRef Structure
ImGearArrayRef Members
Overload List


%%PageItemTitle%%

ImGearArrayRef Constructor(Array)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearArrayRef Structure > ImGearArrayRef Constructor : ImGearArrayRef Constructor(Array)
Structure content.
Initializes a new instance of the ImGearArrayRef structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As Array _
)
'Usage

Dim content As Array

Dim instance As New ImGearArrayRef(content)
public ImGearArrayRef(
   Array content
)
public: ImGearArrayRef(
   Array* content
)
public:
ImGearArrayRef(
   Array^ content
)

Parameters

content
Structure content.
See Also

Reference

ImGearArrayRef Structure
ImGearArrayRef Members
Overload List


%%PageItemTitle%% $$Fields$$

ImGearArrayRef Structure Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearArrayRef Structure

For a list of all members of this type, see ImGearArrayRef members.

Public Fields
 | Name | Description
Public Field | Content | Specifies structure content.
Public Field | Offset | Specifies structure offset.
Top
See Also

Reference

ImGearArrayRef Structure
ImageGear.Core Namespace


Content Field (ImGearArrayRef)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearArrayRef Structure : Content Field
Specifies structure content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Content As Array
'Usage

Dim instance As ImGearArrayRef
Dim value As Array

value = instance.Content

instance.Content = value
public Array Content
public: Array* Content
public:
Array^ Content
See Also

Reference

ImGearArrayRef Structure
ImGearArrayRef Members


Offset Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearArrayRef Structure : Offset Field
Specifies structure offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Offset As Integer
'Usage

Dim instance As ImGearArrayRef
Dim value As Integer

value = instance.Offset

instance.Offset = value
public int Offset
public: int Offset
public:
int Offset
See Also

Reference

ImGearArrayRef Structure
ImGearArrayRef Members


%%PageItemTitle%%

ImGearBinocular Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearBinocular Structure
Defines Binocular shape.
Object Model
ImGearBinocular StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearBinocular
   Inherits System.ValueType
   Implements IImGearBinocular, IImGearShape
'Usage

Dim instance As ImGearBinocular
public struct ImGearBinocular : System.ValueType, IImGearBinocular, IImGearShape
public __value struct ImGearBinocular : public System.ValueType, IImGearBinocular, IImGearShape
public value class ImGearBinocular : public System.ValueType, IImGearBinocular, IImGearShape
Remarks
Binocular shape is composed of two ellipses inscribed in the bounding rectangle. Distance property defines the distance between ellipse centers.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearBinocular

See Also

Reference

ImGearBinocular Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearBinocular Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearBinocular Structure

The following tables list the members exposed by ImGearBinocular.

Public Properties
 | Name | Description
Public Property | Distance | Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Public Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Public Property | RightBottom | Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Top
See Also

Reference

ImGearBinocular Structure
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearBinocular Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearBinocular Structure

For a list of all members of this type, see ImGearBinocular members.

Public Properties
 | Name | Description
Public Property | Distance | Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Public Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Public Property | RightBottom | Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Top
See Also

Reference

ImGearBinocular Structure
ImageGear.Core Namespace


Distance Property (ImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearBinocular Structure : Distance Property
Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Distance As Integer
'Usage

Dim instance As ImGearBinocular
Dim value As Integer

instance.Distance = value

value = instance.Distance
public int Distance {get; set;}
public: __property int get_Distance();
public: __property void set_Distance(
   int value
);
public:
property int Distance {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearBinocular Structure
ImGearBinocular Members


LeftTop Property (ImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearBinocular Structure : LeftTop Property
Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftTop As ImGearPoint
'Usage

Dim instance As ImGearBinocular
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
public ImGearPoint LeftTop {get; set;}
public: __property ImGearPoint get_LeftTop();
public: __property void set_LeftTop(
   ImGearPoint value
);
public:
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearBinocular Structure
ImGearBinocular Members
ImGearPoint Structure


RightBottom Property (ImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearBinocular Structure : RightBottom Property
Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightBottom As ImGearPoint
'Usage

Dim instance As ImGearBinocular
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
public ImGearPoint RightBottom {get; set;}
public: __property ImGearPoint get_RightBottom();
public: __property void set_RightBottom(
   ImGearPoint value
);
public:
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearBinocular Structure
ImGearBinocular Members
ImGearPoint Structure


%%PageItemTitle%%

ImGearChannelRange Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearChannelRange Structure
Describes channels to be processed with ImageGear.Processing.ImGearProcessing class methods.
Object Model
ImGearChannelRange Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearChannelRange
   Inherits System.ValueType
'Usage

Dim instance As ImGearChannelRange
public struct ImGearChannelRange : System.ValueType
public __value struct ImGearChannelRange : public System.ValueType
public value class ImGearChannelRange : public System.ValueType
Remarks
This structure is passed to some processing methods such as ImageGear.Processing.ImGearRasterProcessing.AdjustContrast.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearChannelRange

See Also

Reference

ImGearChannelRange Members
ImageGear.Core Namespace
ImGearRasterProcessing Class


%%PageItemTitle%% $$Members$$

ImGearChannelRange Structure Members
Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearChannelRange Structure

The following tables list the members exposed by ImGearChannelRange.

Public Constructors
 | Name | Description
Public Constructor | ImGearChannelRange Constructor | Overloaded. Initializes a new instance of the ImGearChannelRange structure.
Top
Public Fields
 | Name | Description
Public Field | Count | Channel count in the range (-1 indicates from Start to last channel of the DIB).
Public Field | Start | Start channel in the channel range.
Top
See Also

Reference

ImGearChannelRange Structure
ImageGear.Core Namespace
ImGearRasterProcessing Class


%%PageItemTitle%%

ImGearChannelRange Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearChannelRange Structure : ImGearChannelRange Constructor
Initializes a new instance of the ImGearChannelRange structure.
Overload List
Overload | Description
ImGearChannelRange Constructor(Int32,Int32) | Initializes a new instance of the ImGearChannelRange structure with start channel number and channel count.
ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups) | Initializes a new instance of the ImGearChannelRange structure with color space and channel group identifier.
See Also

Reference

ImGearChannelRange Structure
ImGearChannelRange Members


%%PageItemTitle%%

ImGearChannelRange Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearChannelRange Structure > ImGearChannelRange Constructor : ImGearChannelRange Constructor(Int32,Int32)
Start channel number.
Channel count.
Initializes a new instance of the ImGearChannelRange structure with start channel number and channel count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal start As Integer, _
   ByVal count As Integer _
)
'Usage

Dim start As Integer
Dim count As Integer

Dim instance As New ImGearChannelRange(start, count)
public ImGearChannelRange(
   int start,
   int count
)
public: ImGearChannelRange(
   int start,
   int count
)
public:
ImGearChannelRange(
   int start,
   int count
)

Parameters

start
Start channel number.
count
Channel count.
See Also

Reference

ImGearChannelRange Structure
ImGearChannelRange Members
Overload List


%%PageItemTitle%%

ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearChannelRange Structure > ImGearChannelRange Constructor : ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups)
Color Space for which the channel range structure is created.
Channel group constant.
Initializes a new instance of the ImGearChannelRange structure with color space and channel group identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal group As ImGearChannelGroups _
)
'Usage

Dim colorSpace As ImGearColorSpace
Dim group As ImGearChannelGroups

Dim instance As New ImGearChannelRange(colorSpace, group)
public ImGearChannelRange(
   ImGearColorSpace colorSpace,
   ImGearChannelGroups group
)
public: ImGearChannelRange(
   ImGearColorSpace colorSpace,
   ImGearChannelGroups group
)
public:
ImGearChannelRange(
   ImGearColorSpace colorSpace,
   ImGearChannelGroups group
)

Parameters

colorSpace
Color Space for which the channel range structure is created.
group
Channel group constant.
See Also

Reference

ImGearChannelRange Structure
ImGearChannelRange Members
Overload List
ImGearColorSpace Structure
ImGearChannelGroups Enumeration


%%PageItemTitle%% $$Fields$$

ImGearChannelRange Structure Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearChannelRange Structure

For a list of all members of this type, see ImGearChannelRange members.

Public Fields
 | Name | Description
Public Field | Count | Channel count in the range (-1 indicates from Start to last channel of the DIB).
Public Field | Start | Start channel in the channel range.
Top
See Also

Reference

ImGearChannelRange Structure
ImageGear.Core Namespace
ImGearRasterProcessing Class


Count Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearChannelRange Structure : Count Field
Channel count in the range (-1 indicates from Start to last channel of the DIB).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Count As Integer
'Usage

Dim instance As ImGearChannelRange
Dim value As Integer

value = instance.Count

instance.Count = value
public int Count
public: int Count
public:
int Count

Field Value

Integer value in range [0 .. maximum channel count] or -1.
See Also

Reference

ImGearChannelRange Structure
ImGearChannelRange Members


Start Field

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearChannelRange Structure : Start Field
Start channel in the channel range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Start As Integer
'Usage

Dim instance As ImGearChannelRange
Dim value As Integer

value = instance.Start

instance.Start = value
public int Start
public: int Start
public:
int Start

Field Value

Integer value in the range of 0 .. maximum channel number.
See Also

Reference

ImGearChannelRange Structure
ImGearChannelRange Members


%%PageItemTitle%%

ImGearColorSpace Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorSpace Structure
Defines semantics of information, stored in all image channels.
Object Model
ImGearColorSpace Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearColorSpace
   Inherits System.ValueType
'Usage

Dim instance As ImGearColorSpace
public struct ImGearColorSpace : System.ValueType
public __value struct ImGearColorSpace : public System.ValueType
public value class ImGearColorSpace : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearColorSpace

See Also

Reference

ImGearColorSpace Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearColorSpace Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorSpace Structure

The following tables list the members exposed by ImGearColorSpace.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorSpace Constructor | Initializes a new instance of the ImGearColorSpace struct.
Top
Public Properties
 | Name | Description
Public Property | AlphaChannelCount | Gets the number of alpha channels in the color space.
Public Property | AlphaIndex | Gets the Index of the alpha channel in the color space.
Public Property | Color | Gets color part of value identifier.
Public Property | ColorChannelCount | Gets quantity of color channels. It does not include Alpha and Extra channels.
Public Property | ContainsAlpha | Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not.
Public Property | ContainsExtra | Gets a value indicating whether the colorspace contains extra (unknown) channels.
Public Property | ExtraStartIndex | Gets the index of the first extra channel in the color space.
Public Property | IsPremultiplied | Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not.
Public Property | Value | Gets or sets the color space identifier.
Top
Public Methods
 | Name | Description
Public Method | GetExtraChannelCount | Overloaded. Calculates quantity of extra channels in color space with given total channels quantity.
static (Shared in Visual Basic) | IsWellFormed | Verifies whether color space combination is valid (supported).
Top
See Also

Reference

ImGearColorSpace Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearColorSpace Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : ImGearColorSpace Constructor
Well-formed combination of ImGearColorSpaceIDs flags.
Initializes a new instance of the ImGearColorSpace struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As ImGearColorSpaceIDs _
)
'Usage

Dim value As ImGearColorSpaceIDs

Dim instance As New ImGearColorSpace(value)
public ImGearColorSpace(
   ImGearColorSpaceIDs value
)
public: ImGearColorSpace(
   ImGearColorSpaceIDs value
)
public:
ImGearColorSpace(
   ImGearColorSpaceIDs value
)

Parameters

value
Well-formed combination of ImGearColorSpaceIDs flags.
Remarks
Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit. See ImGearColorSpaceIDs for information on valid combinations of flags.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


%%PageItemTitle%% $$Methods$$

ImGearColorSpace Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorSpace Structure

For a list of all members of this type, see ImGearColorSpace members.

Public Methods
 | Name | Description
Public Method | GetExtraChannelCount | Overloaded. Calculates quantity of extra channels in color space with given total channels quantity.
static (Shared in Visual Basic) | IsWellFormed | Verifies whether color space combination is valid (supported).
Top
See Also

Reference

ImGearColorSpace Structure
ImageGear.Core Namespace


GetExtraChannelCount Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : GetExtraChannelCount Method
Calculates quantity of extra channels in color space with given total channels quantity.
Overload List
Overload | Description
GetExtraChannelCount(Int32) | Calculates quantity of extra channels in color space with given total channels quantity.
GetExtraChannelCount(Int32[]) | Calculates quantity of extra channels in color space with given channels array.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


GetExtraChannelCount(Int32) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure > GetExtraChannelCount Method : GetExtraChannelCount(Int32) Method
Total quantity of channels in the image.
Calculates quantity of extra channels in color space with given total channels quantity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetExtraChannelCount( _
   ByVal totalChannelCount As Integer _
) As Integer
'Usage

Dim instance As ImGearColorSpace
Dim totalChannelCount As Integer
Dim value As Integer

value = instance.GetExtraChannelCount(totalChannelCount)
public int GetExtraChannelCount(
   int totalChannelCount
)
public: int GetExtraChannelCount(
   int totalChannelCount
)
public:
int GetExtraChannelCount(
   int totalChannelCount
)

Parameters

totalChannelCount
Total quantity of channels in the image.

Return Value

Quantity of extra channels or zero in case if color-space value doesn't contain ImGearColorSpaceIDs.Ex bit.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
Overload List
ImGearColorSpaceIDs Enumeration


GetExtraChannelCount(Int32[]) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure > GetExtraChannelCount Method : GetExtraChannelCount(Int32[]) Method
Array of channels in the image.
Calculates quantity of extra channels in color space with given channels array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetExtraChannelCount( _
   ByVal channels() As Integer _
) As Integer
'Usage

Dim instance As ImGearColorSpace
Dim channels() As Integer
Dim value As Integer

value = instance.GetExtraChannelCount(channels)
public int GetExtraChannelCount(
   int[] channels
)
public: int GetExtraChannelCount(
   int[]* channels
)
public:
int GetExtraChannelCount(
   array<int>^ channels
)

Parameters

channels
Array of channels in the image.

Return Value

Quantity of extra channels or zero in case if color-space value doesn’t contain ImGearColorSpaceIDs.Ex bit.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
Overload List
ImGearColorSpaceIDs Enumeration


IsWellFormed Method (ImGearColorSpace)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : IsWellFormed Method
Color space ID.
Verifies whether color space combination is valid (supported).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function IsWellFormed( _
   ByVal value As ImGearColorSpaceIDs _
) As Boolean
'Usage

Dim value As ImGearColorSpaceIDs
Dim value As Boolean

value = ImGearColorSpace.IsWellFormed(value)
public static bool IsWellFormed(
   ImGearColorSpaceIDs value
)
public: static bool IsWellFormed(
   ImGearColorSpaceIDs value
)
public:
static bool IsWellFormed(
   ImGearColorSpaceIDs value
)

Parameters

value
Color space ID.

Return Value

Boolean value.
Remarks
See ImGearColorSpaceIDs for information on valid combinations of flags.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


%%PageItemTitle%% $$Properties$$

ImGearColorSpace Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearColorSpace Structure

For a list of all members of this type, see ImGearColorSpace members.

Public Properties
 | Name | Description
Public Property | AlphaChannelCount | Gets the number of alpha channels in the color space.
Public Property | AlphaIndex | Gets the Index of the alpha channel in the color space.
Public Property | Color | Gets color part of value identifier.
Public Property | ColorChannelCount | Gets quantity of color channels. It does not include Alpha and Extra channels.
Public Property | ContainsAlpha | Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not.
Public Property | ContainsExtra | Gets a value indicating whether the colorspace contains extra (unknown) channels.
Public Property | ExtraStartIndex | Gets the index of the first extra channel in the color space.
Public Property | IsPremultiplied | Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not.
Public Property | Value | Gets or sets the color space identifier.
Top
See Also

Reference

ImGearColorSpace Structure
ImageGear.Core Namespace


AlphaChannelCount Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : AlphaChannelCount Property
Gets the number of alpha channels in the color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AlphaChannelCount As Integer
'Usage

Dim instance As ImGearColorSpace
Dim value As Integer

value = instance.AlphaChannelCount
public int AlphaChannelCount {get;}
public: __property int get_AlphaChannelCount();
public:
property int AlphaChannelCount {
   int get();
}

Property Value

Any positive integer value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


AlphaIndex Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : AlphaIndex Property
Gets the Index of the alpha channel in the color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AlphaIndex As Integer
'Usage

Dim instance As ImGearColorSpace
Dim value As Integer

value = instance.AlphaIndex
public int AlphaIndex {get;}
public: __property int get_AlphaIndex();
public:
property int AlphaIndex {
   int get();
}

Property Value

Any positive integer value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


Color Property (ImGearColorSpace)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : Color Property
Gets color part of value identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Color As ImGearColorSpaceIDs
'Usage

Dim instance As ImGearColorSpace
Dim value As ImGearColorSpaceIDs

value = instance.Color
public ImGearColorSpaceIDs Color {get;}
public: __property ImGearColorSpaceIDs get_Color();
public:
property ImGearColorSpaceIDs Color {
   ImGearColorSpaceIDs get();
}

Property Value

ImGearColorSpaceIDs enumeration value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


ColorChannelCount Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : ColorChannelCount Property
Gets quantity of color channels. It does not include Alpha and Extra channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorChannelCount As Integer
'Usage

Dim instance As ImGearColorSpace
Dim value As Integer

value = instance.ColorChannelCount
public int ColorChannelCount {get;}
public: __property int get_ColorChannelCount();
public:
property int ColorChannelCount {
   int get();
}

Property Value

Non-negative value that represents quantity of color channels.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


ContainsAlpha Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : ContainsAlpha Property
Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContainsAlpha As Boolean
'Usage

Dim instance As ImGearColorSpace
Dim value As Boolean

value = instance.ContainsAlpha
public bool ContainsAlpha {get;}
public: __property bool get_ContainsAlpha();
public:
property bool ContainsAlpha {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


ContainsExtra Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : ContainsExtra Property
Gets a value indicating whether the colorspace contains extra (unknown) channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContainsExtra As Boolean
'Usage

Dim instance As ImGearColorSpace
Dim value As Boolean

value = instance.ContainsExtra
public bool ContainsExtra {get;}
public: __property bool get_ContainsExtra();
public:
property bool ContainsExtra {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


ExtraStartIndex Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : ExtraStartIndex Property
Gets the index of the first extra channel in the color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ExtraStartIndex As Integer
'Usage

Dim instance As ImGearColorSpace
Dim value As Integer

value = instance.ExtraStartIndex
public int ExtraStartIndex {get;}
public: __property int get_ExtraStartIndex();
public:
property int ExtraStartIndex {
   int get();
}

Property Value

Any positive integer value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


IsPremultiplied Property

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : IsPremultiplied Property
Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsPremultiplied As Boolean
'Usage

Dim instance As ImGearColorSpace
Dim value As Boolean

value = instance.IsPremultiplied
public bool IsPremultiplied {get;}
public: __property bool get_IsPremultiplied();
public:
property bool IsPremultiplied {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members
ImGearColorSpaceIDs Enumeration


Value Property (ImGearColorSpace)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearColorSpace Structure : Value Property
Gets or sets the color space identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As ImGearColorSpaceIDs
'Usage

Dim instance As ImGearColorSpace
Dim value As ImGearColorSpaceIDs

instance.Value = value

value = instance.Value
public ImGearColorSpaceIDs Value {get; set;}
public: __property ImGearColorSpaceIDs get_Value();
public: __property void set_Value(
   ImGearColorSpaceIDs value
);
public:
property ImGearColorSpaceIDs Value {
   ImGearColorSpaceIDs get();
   void set (    ImGearColorSpaceIDs value);
}

Property Value

Well-formed combination of ImGearColorSpaceIDs enumeration values.
Remarks
See ImGearColorSpaceIDs for information on valid combinations of flags.

Set accessor throws ImGearException if invalid value is passed.

See Also

Reference

ImGearColorSpace Structure
ImGearColorSpace Members


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearCommonMetadataDictRecord Structure
Contains data for a common metadata dictionary record.
Object Model
ImGearCommonMetadataDictRecord Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearCommonMetadataDictRecord
   Inherits System.ValueType
   Implements IImGearMetadataDictRecord
'Usage

Dim instance As ImGearCommonMetadataDictRecord
public struct ImGearCommonMetadataDictRecord : System.ValueType, IImGearMetadataDictRecord
public __value struct ImGearCommonMetadataDictRecord : public System.ValueType, IImGearMetadataDictRecord
public value class ImGearCommonMetadataDictRecord : public System.ValueType, IImGearMetadataDictRecord
Remarks
This structure is used with most ImageGear supported formats.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearCommonMetadataDictRecord

See Also

Reference

ImGearCommonMetadataDictRecord Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearCommonMetadataDictRecord Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearCommonMetadataDictRecord Structure

The following tables list the members exposed by ImGearCommonMetadataDictRecord.

Public Constructors
 | Name | Description
Public Constructor | ImGearCommonMetadataDictRecord Constructor | Initializes a new instance of the ImGearCommonMetadataDictRecord struct.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the Tag name.
Public Property | Tag | Gets or sets the Tag ID value.
Top
See Also

Reference

ImGearCommonMetadataDictRecord Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearCommonMetadataDictRecord Structure : ImGearCommonMetadataDictRecord Constructor
Tag ID value.
Tag name value.
Initializes a new instance of the ImGearCommonMetadataDictRecord struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As Integer, _
   ByVal name As String _
)
'Usage

Dim tag As Integer
Dim name As String

Dim instance As New ImGearCommonMetadataDictRecord(tag, name)
public ImGearCommonMetadataDictRecord(
   int tag,
   string name
)
public: ImGearCommonMetadataDictRecord(
   int tag,
   string* name
)
public:
ImGearCommonMetadataDictRecord(
   int tag,
   String^ name
)

Parameters

tag
Tag ID value.
name
Tag name value.
See Also

Reference

ImGearCommonMetadataDictRecord Structure
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%% $$Properties$$

ImGearCommonMetadataDictRecord Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearCommonMetadataDictRecord Structure

For a list of all members of this type, see ImGearCommonMetadataDictRecord members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the Tag name.
Public Property | Tag | Gets or sets the Tag ID value.
Top
See Also

Reference

ImGearCommonMetadataDictRecord Structure
ImageGear.Core Namespace


Name Property (ImGearCommonMetadataDictRecord)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearCommonMetadataDictRecord Structure : Name Property
Gets or sets the Tag name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearCommonMetadataDictRecord
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string.
Remarks
The default value is ““.
See Also

Reference

ImGearCommonMetadataDictRecord Structure
ImGearCommonMetadataDictRecord Members


Tag Property (ImGearCommonMetadataDictRecord)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearCommonMetadataDictRecord Structure : Tag Property
Gets or sets the Tag ID value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tag As Integer
'Usage

Dim instance As ImGearCommonMetadataDictRecord
Dim value As Integer

instance.Tag = value

value = instance.Tag
public int Tag {get; set;}
public: __property int get_Tag();
public: __property void set_Tag(
   int value
);
public:
property int Tag {
   int get();
   void set (    int value);
}

Property Value

Any integer number.
Remarks
The default value is 0.
See Also

Reference

ImGearCommonMetadataDictRecord Structure
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

ImGearDoublePoint Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoublePoint Structure
Stores a set of two double precision numbers that represent the point.
Object Model
ImGearDoublePoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearDoublePoint
   Inherits System.ValueType
   Implements IImGearDoublePoint
'Usage

Dim instance As ImGearDoublePoint
public struct ImGearDoublePoint : System.ValueType, IImGearDoublePoint
public __value struct ImGearDoublePoint : public System.ValueType, IImGearDoublePoint
public value class ImGearDoublePoint : public System.ValueType, IImGearDoublePoint
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearDoublePoint

See Also

Reference

ImGearDoublePoint Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDoublePoint Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoublePoint Structure

The following tables list the members exposed by ImGearDoublePoint.

Public Constructors
 | Name | Description
Public Constructor | ImGearDoublePoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets X coordinate of the point.
Public Property | Y | Gets or sets Y coordinate of the point.
Top
Public Methods
 | Name | Description
Public Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

ImGearDoublePoint Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDoublePoint Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure : ImGearDoublePoint Constructor
Overload List
Overload | Description
ImGearDoublePoint Constructor(IImGearDoublePoint) | Initializes a new instance of the ImGearDoublePoint struct.
ImGearDoublePoint Constructor(Double,Double) | Initializes a new instance of the ImGearDoublePoint struct.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members


%%PageItemTitle%%

ImGearDoublePoint Constructor(IImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure > ImGearDoublePoint Constructor : ImGearDoublePoint Constructor(IImGearDoublePoint)
IImGearDoublePoint interface.
Initializes a new instance of the ImGearDoublePoint struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As IImGearDoublePoint _
)
'Usage

Dim point As IImGearDoublePoint

Dim instance As New ImGearDoublePoint(point)
public ImGearDoublePoint(
   IImGearDoublePoint point
)
public: ImGearDoublePoint(
   IImGearDoublePoint* point
)
public:
ImGearDoublePoint(
   IImGearDoublePoint^ point
)

Parameters

point
IImGearDoublePoint interface.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members
Overload List


%%PageItemTitle%%

ImGearDoublePoint Constructor(Double,Double)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure > ImGearDoublePoint Constructor : ImGearDoublePoint Constructor(Double,Double)
X coordinate.
Y coordinate.
Initializes a new instance of the ImGearDoublePoint struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pointX As Double, _
   ByVal pointY As Double _
)
'Usage

Dim pointX As Double
Dim pointY As Double

Dim instance As New ImGearDoublePoint(pointX, pointY)
public ImGearDoublePoint(
   double pointX,
   double pointY
)
public: ImGearDoublePoint(
   double pointX,
   double pointY
)
public:
ImGearDoublePoint(
   double pointX,
   double pointY
)

Parameters

pointX
X coordinate.
pointY
Y coordinate.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearDoublePoint Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoublePoint Structure

For a list of all members of this type, see ImGearDoublePoint members.

Public Methods
 | Name | Description
Public Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

ImGearDoublePoint Structure
ImageGear.Core Namespace


Offset Method (ImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure : Offset Method
X coordinate.
Y coordinate.
Shifts the points coordinates by the specified coordinateX and coordinateY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Offset( _
   ByVal offsetX As Double, _
   ByVal offsetY As Double _
)
'Usage

Dim instance As ImGearDoublePoint
Dim offsetX As Double
Dim offsetY As Double

instance.Offset(offsetX, offsetY)
public void Offset(
   double offsetX,
   double offsetY
)
public: void Offset(
   double offsetX,
   double offsetY
)
public:
void Offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
X coordinate.
offsetY
Y coordinate.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members


%%PageItemTitle%% $$Properties$$

ImGearDoublePoint Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoublePoint Structure

For a list of all members of this type, see ImGearDoublePoint members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets X coordinate of the point.
Public Property | Y | Gets or sets Y coordinate of the point.
Top
See Also

Reference

ImGearDoublePoint Structure
ImageGear.Core Namespace


X Property (ImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure : X Property
Gets or sets X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As ImGearDoublePoint
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public: __property double get_X();
public: __property void set_X(
   double value
);
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

Any double value.
Remarks
The default value is 0.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members


Y Property (ImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoublePoint Structure : Y Property
Gets or sets Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As ImGearDoublePoint
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public: __property double get_Y();
public: __property void set_Y(
   double value
);
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

Any double value.
Remarks
The default value is 0.
See Also

Reference

ImGearDoublePoint Structure
ImGearDoublePoint Members


%%PageItemTitle%%

ImGearDoubleRectangle Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoubleRectangle Structure
Stores a set of four double precision numbers that represent the location and size of a rectangle.
Object Model
ImGearDoubleRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearDoubleRectangle
   Inherits System.ValueType
   Implements IImGearDoubleRectangle, IImGearShape
'Usage

Dim instance As ImGearDoubleRectangle
public struct ImGearDoubleRectangle : System.ValueType, IImGearDoubleRectangle, IImGearShape
public __value struct ImGearDoubleRectangle : public System.ValueType, IImGearDoubleRectangle, IImGearShape
public value class ImGearDoubleRectangle : public System.ValueType, IImGearDoubleRectangle, IImGearShape
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearDoubleRectangle

See Also

Reference

ImGearDoubleRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDoubleRectangle Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoubleRectangle Structure

The following tables list the members exposed by ImGearDoubleRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearDoubleRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Height | Gets the height of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Public Property | Width | Gets the width of the rectangle.
Top
Public Methods
 | Name | Description
Public Method | CopyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Public Method | Intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Public Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Public Method | IsWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Public Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
See Also

Reference

ImGearDoubleRectangle Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDoubleRectangle Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : ImGearDoubleRectangle Constructor
Overload List
Overload | Description
ImGearDoubleRectangle Constructor(Double,Double) | Initializes a new instance of the ImGearDoubleRectangle struct.
ImGearDoubleRectangle Constructor(Double,Double,Double,Double) | Initializes a new instance of the ImGearDoubleRectangle struct.
ImGearDoubleRectangle Constructor(IImGearDoubleRectangle) | Initializes a new instance of the ImGearDoubleRectangle struct.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(Double,Double)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(Double,Double)
Width of the rectangle.
Height of the rectangle.
Initializes a new instance of the ImGearDoubleRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New ImGearDoubleRectangle(width, height)
public ImGearDoubleRectangle(
   double width,
   double height
)
public: ImGearDoubleRectangle(
   double width,
   double height
)
public:
ImGearDoubleRectangle(
   double width,
   double height
)

Parameters

width
Width of the rectangle.
height
Height of the rectangle.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(Double,Double,Double,Double)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(Double,Double,Double,Double)
X coordinate of left-top rectangular point.
Y coordinate of left-top rectangular point.
Width of the rectangle.
Height of the rectangle.
Initializes a new instance of the ImGearDoubleRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As New ImGearDoubleRectangle(left, top, width, height)
public ImGearDoubleRectangle(
   double left,
   double top,
   double width,
   double height
)
public: ImGearDoubleRectangle(
   double left,
   double top,
   double width,
   double height
)
public:
ImGearDoubleRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
X coordinate of left-top rectangular point.
top
Y coordinate of left-top rectangular point.
width
Width of the rectangle.
height
Height of the rectangle.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(IImGearDoubleRectangle)
IImGearDoubleRectangle interface.
Initializes a new instance of the ImGearDoubleRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearDoubleRectangle _
)
'Usage

Dim rect As IImGearDoubleRectangle

Dim instance As New ImGearDoubleRectangle(rect)
public ImGearDoubleRectangle(
   IImGearDoubleRectangle rect
)
public: ImGearDoubleRectangle(
   IImGearDoubleRectangle* rect
)
public:
ImGearDoubleRectangle(
   IImGearDoubleRectangle^ rect
)

Parameters

rect
IImGearDoubleRectangle interface.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearDoubleRectangle Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoubleRectangle Structure

For a list of all members of this type, see ImGearDoubleRectangle members.

Public Methods
 | Name | Description
Public Method | CopyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Public Method | Intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Public Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Public Method | IsWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Public Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
See Also

Reference

ImGearDoubleRectangle Structure
ImageGear.Core Namespace


CopyFrom Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : CopyFrom Method
Rectangle to copy.
This method copies rectangle from IImGearDoubleRectangle interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal rect As IImGearDoubleRectangle _
)
'Usage

Dim instance As ImGearDoubleRectangle
Dim rect As IImGearDoubleRectangle

instance.CopyFrom(rect)
public void CopyFrom(
   IImGearDoubleRectangle rect
)
public: void CopyFrom(
   IImGearDoubleRectangle* rect
)
public:
void CopyFrom(
   IImGearDoubleRectangle^ rect
)

Parameters

rect
Rectangle to copy.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Empty Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Empty Method
Sets all numeric properties of the rectangle to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Empty()
'Usage

Dim instance As ImGearDoubleRectangle

instance.Empty()
public void Empty()
public: void Empty();
public:
void Empty();
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Intersect Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Intersect Method
Double rectangle.
Checks whether or not the rectangle is intersected with the specified rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Intersect( _
   ByVal rect As IImGearDoubleRectangle _
) As Boolean
'Usage

Dim instance As ImGearDoubleRectangle
Dim rect As IImGearDoubleRectangle
Dim value As Boolean

value = instance.Intersect(rect)
public bool Intersect(
   IImGearDoubleRectangle rect
)
public: bool Intersect(
   IImGearDoubleRectangle* rect
)
public:
bool Intersect(
   IImGearDoubleRectangle^ rect
)

Parameters

rect
Double rectangle.

Return Value

Boolean value.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


IsEmpty Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsEmpty() As Boolean
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Boolean

value = instance.IsEmpty()
public bool IsEmpty()
public: bool IsEmpty();
public:
bool IsEmpty();

Return Value

Boolean value.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


IsWellFormed Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : IsWellFormed Method
Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsWellFormed() As Boolean
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Boolean

value = instance.IsWellFormed()
public bool IsWellFormed()
public: bool IsWellFormed();
public:
bool IsWellFormed();

Return Value

Boolean value.
Remarks
This method checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Offset Method (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Offset Method
The X shift value.
The Y shift value.
Shifts the rectangle points by the specified shiftX and shiftY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Offset( _
   ByVal offsetX As Double, _
   ByVal offsetY As Double _
)
'Usage

Dim instance As ImGearDoubleRectangle
Dim offsetX As Double
Dim offsetY As Double

instance.Offset(offsetX, offsetY)
public void Offset(
   double offsetX,
   double offsetY
)
public: void Offset(
   double offsetX,
   double offsetY
)
public:
void Offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


%%PageItemTitle%% $$Properties$$

ImGearDoubleRectangle Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearDoubleRectangle Structure

For a list of all members of this type, see ImGearDoubleRectangle members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Height | Gets the height of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Public Property | Width | Gets the width of the rectangle.
Top
See Also

Reference

ImGearDoubleRectangle Structure
ImageGear.Core Namespace


Bottom Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Bottom Property
Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bottom As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

instance.Bottom = value

value = instance.Bottom
public double Bottom {get; set;}
public: __property double get_Bottom();
public: __property void set_Bottom(
   double value
);
public:
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Height Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Height Property
Gets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

Any double precision number.
Remarks
Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Left Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Left Property
Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Right Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Right Property
Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Right As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

instance.Right = value

value = instance.Right
public double Right {get; set;}
public: __property double get_Right();
public: __property void set_Right(
   double value
);
public:
property double Right {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Top Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Top Property
Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public: __property double get_Top();
public: __property void set_Top(
   double value
);
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


Width Property (ImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearDoubleRectangle Structure : Width Property
Gets the width of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As ImGearDoubleRectangle
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

Any double precision number.
Remarks
Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

See Also

Reference

ImGearDoubleRectangle Structure
ImGearDoubleRectangle Members


%%PageItemTitle%%

ImGearEllipse Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearEllipse Structure
Stores a set of two ImGear values that represent the location and size of an ellipse.
Object Model
ImGearEllipse StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearEllipse
   Inherits System.ValueType
   Implements IImGearEllipse, IImGearShape
'Usage

Dim instance As ImGearEllipse
public struct ImGearEllipse : System.ValueType, IImGearEllipse, IImGearShape
public __value struct ImGearEllipse : public System.ValueType, IImGearEllipse, IImGearShape
public value class ImGearEllipse : public System.ValueType, IImGearEllipse, IImGearShape
Remarks
The center of the ellipse is the center of the specified bounding rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearEllipse

See Also

Reference

ImGearEllipse Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearEllipse Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearEllipse Structure

The following tables list the members exposed by ImGearEllipse.

Public Properties
 | Name | Description
Public Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Public Property | RightBottom | Gets or sets the coordinate of the lower-right corner of the bounding rectangle.
Top
See Also

Reference

ImGearEllipse Structure
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearEllipse Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearEllipse Structure

For a list of all members of this type, see ImGearEllipse members.

Public Properties
 | Name | Description
Public Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Public Property | RightBottom | Gets or sets the coordinate of the lower-right corner of the bounding rectangle.
Top
See Also

Reference

ImGearEllipse Structure
ImageGear.Core Namespace


LeftTop Property (ImGearEllipse)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearEllipse Structure : LeftTop Property
Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftTop As ImGearPoint
'Usage

Dim instance As ImGearEllipse
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
public ImGearPoint LeftTop {get; set;}
public: __property ImGearPoint get_LeftTop();
public: __property void set_LeftTop(
   ImGearPoint value
);
public:
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearEllipse Structure
ImGearEllipse Members
ImGearPoint Structure


RightBottom Property (ImGearEllipse)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearEllipse Structure : RightBottom Property
Gets or sets the coordinate of the lower-right corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightBottom As ImGearPoint
'Usage

Dim instance As ImGearEllipse
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
public ImGearPoint RightBottom {get; set;}
public: __property ImGearPoint get_RightBottom();
public: __property void set_RightBottom(
   ImGearPoint value
);
public:
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearEllipse Structure
ImGearEllipse Members
ImGearPoint Structure


%%PageItemTitle%%

ImGearOrientation Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientation Structure
Specifies orientation of page or display.
Object Model
ImGearOrientation StructureImGearOrientation Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearOrientation
   Inherits System.ValueType
   Implements IImGearOrientation
'Usage

Dim instance As ImGearOrientation
public struct ImGearOrientation : System.ValueType, IImGearOrientation
public __value struct ImGearOrientation : public System.ValueType, IImGearOrientation
public value class ImGearOrientation : public System.ValueType, IImGearOrientation
Remarks

This structure defines the orientation of an image. It works on the image representation and thus allows you to flip and rotate an image without modification of its data (pixels).

It is useful to manipulate the orientation of scanned black-and-white images. Since ImageGear for .NET stores such images using lossless compression, this may avoid significant expansion of memory usage while operating on these images.

Some file formats support orientation natively and this allows you to save flipped or rotated images without loss of pixel data or file size enlargement when using compression.

Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearOrientation

See Also

Reference

ImGearOrientation Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearOrientation Structure Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientation Structure

The following tables list the members exposed by ImGearOrientation.

Public Constructors
 | Name | Description
Public Constructor | ImGearOrientation Constructor | Initializes a new instance of the ImGearOrientation struct.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets orientation identifier.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Combine | Returns orientation that is super-imposition of two values.
Public Method | Flip | Changes orientation to flip image.
Public Method | Rotate | Changes orientation to rotate image.
Public Method | SetToDefault | Resets orientation to default (top-left) state.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearOrientation Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearOrientation Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : ImGearOrientation Constructor
ImGearOrientationModes enum value.
Initializes a new instance of the ImGearOrientation struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal newValue As ImGearOrientationModes _
)
'Usage

Dim newValue As ImGearOrientationModes

Dim instance As New ImGearOrientation(newValue)
public ImGearOrientation(
   ImGearOrientationModes newValue
)
public: ImGearOrientation(
   ImGearOrientationModes newValue
)
public:
ImGearOrientation(
   ImGearOrientationModes newValue
)

Parameters

newValue
ImGearOrientationModes enum value.
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members


Combine Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : Combine Method
Returns orientation that is super-imposition of two values.
Overload List
Overload | Description
Combine | Returns orientation that is super-imposition of two values.
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members


%%PageItemTitle%% $$Methods$$

ImGearOrientation Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientation Structure

For a list of all members of this type, see ImGearOrientation members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Combine | Returns orientation that is super-imposition of two values.
Public Method | Flip | Changes orientation to flip image.
Public Method | Rotate | Changes orientation to rotate image.
Public Method | SetToDefault | Resets orientation to default (top-left) state.
Top
See Also

Reference

ImGearOrientation Structure
ImageGear.Core Namespace


Combine(IImGearOrientation,IImGearOrientation) Method
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : Combine(IImGearOrientation,IImGearOrientation) Method
First orientation value to be combined.
Second orientation value to be combined.
Returns orientation that is super-imposition of two values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Combine( _
   ByVal orientation1 As IImGearOrientation, _
   ByVal orientation2 As IImGearOrientation _
) As ImGearOrientation
'Usage

Dim orientation1 As IImGearOrientation
Dim orientation2 As IImGearOrientation
Dim value As ImGearOrientation

value = ImGearOrientation.Combine(orientation1, orientation2)
public static ImGearOrientation Combine(
   IImGearOrientation orientation1,
   IImGearOrientation orientation2
)
public: static ImGearOrientation Combine(
   IImGearOrientation* orientation1,
   IImGearOrientation* orientation2
)
public:
static ImGearOrientation Combine(
   IImGearOrientation^ orientation1,
   IImGearOrientation^ orientation2
)

Parameters

orientation1
First orientation value to be combined.
orientation2
Second orientation value to be combined.

Return Value

New ImGearOrientation structure value.
Remarks
Returns super-imposition of two orientations. Returned value equals to sequential application of two given orientations onto one source.
Example
  • C#
igPage.Orientation = ImGearOrientation.Combine(
   igPage.Orientation, igPageDisplay.Orientation);
igPageDisplay.Orientation.SetToDefault();
  • Visual Basic
igPage.Orientation = ImGearOrientation.Combine( _
       igPage.Orientation, igPageDisplay.Orientation)
igPageDisplay.Orientation.SetToDefault()
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members


Flip Method (ImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : Flip Method
Specifies how to flip orientation.
Changes orientation to flip image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Flip( _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As ImGearOrientation
Dim flipMode As ImGearFlipModes

instance.Flip(flipMode)
public void Flip(
   ImGearFlipModes flipMode
)
public: void Flip(
   ImGearFlipModes flipMode
)
public:
void Flip(
   ImGearFlipModes flipMode
)

Parameters

flipMode
Specifies how to flip orientation.
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members
ImGearFlipModes Enumeration


Rotate Method (ImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : Rotate Method
Specifies how to rotate orientation.
Changes orientation to rotate image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal rotationValue As ImGearRotationValues _
)
'Usage

Dim instance As ImGearOrientation
Dim rotationValue As ImGearRotationValues

instance.Rotate(rotationValue)
public void Rotate(
   ImGearRotationValues rotationValue
)
public: void Rotate(
   ImGearRotationValues rotationValue
)
public:
void Rotate(
   ImGearRotationValues rotationValue
)

Parameters

rotationValue
Specifies how to rotate orientation.
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members
ImGearRotationValues Enumeration


SetToDefault Method (ImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : SetToDefault Method
Resets orientation to default (top-left) state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToDefault()
'Usage

Dim instance As ImGearOrientation

instance.SetToDefault()
public void SetToDefault()
public: void SetToDefault();
public:
void SetToDefault();
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members


%%PageItemTitle%% $$Properties$$

ImGearOrientation Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientation Structure

For a list of all members of this type, see ImGearOrientation members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets orientation identifier.
Top
See Also

Reference

ImGearOrientation Structure
ImageGear.Core Namespace


Value Property (ImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : Value Property
Gets or sets orientation identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As ImGearOrientationModes
'Usage

Dim instance As ImGearOrientation
Dim value As ImGearOrientationModes

instance.Value = value

value = instance.Value
public ImGearOrientationModes Value {get; set;}
public: __property ImGearOrientationModes get_Value();
public: __property void set_Value(
   ImGearOrientationModes value
);
public:
property ImGearOrientationModes Value {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

Any of ImGearOrientationModes enumeration values.
Remarks
Represents orientation as numeric value.
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members
ImGearOrientationModes Enumeration


%%PageItemTitle%% $$Events$$

ImGearOrientation Structure Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearOrientation Structure

For a list of all members of this type, see ImGearOrientation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearOrientation Structure
ImageGear.Core Namespace


PropertyChanged Event (ImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearOrientation Structure : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearOrientation
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearOrientation Structure
ImGearOrientation Members


%%PageItemTitle%%

ImGearPoint Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPoint Structure
Encapsulates a point in a 2-D coordinate system.
Object Model
ImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearPoint
   Inherits System.ValueType
   Implements IImGearPoint
'Usage

Dim instance As ImGearPoint
public struct ImGearPoint : System.ValueType, IImGearPoint
public __value struct ImGearPoint : public System.ValueType, IImGearPoint
public value class ImGearPoint : public System.ValueType, IImGearPoint
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearPoint

See Also

Reference

ImGearPoint Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearPoint Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPoint Structure

The following tables list the members exposed by ImGearPoint.

Public Constructors
 | Name | Description
Public Constructor | ImGearPoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of the point.
Public Property | Y | Gets or sets the y-coordinate of the point.
Top
Public Methods
 | Name | Description
Public Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

ImGearPoint Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearPoint Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure : ImGearPoint Constructor
Overload List
Overload | Description
ImGearPoint Constructor(IImGearPoint) | Initializes a new instance of the ImGearPoint struct.
ImGearPoint Constructor(Int32,Int32) | Initializes a new instance of the ImGearPoint struct.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members


%%PageItemTitle%%

ImGearPoint Constructor(IImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure > ImGearPoint Constructor : ImGearPoint Constructor(IImGearPoint)
An IImGearPoint interface to copy.
Initializes a new instance of the ImGearPoint struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As IImGearPoint _
)
'Usage

Dim point As IImGearPoint

Dim instance As New ImGearPoint(point)
public ImGearPoint(
   IImGearPoint point
)
public: ImGearPoint(
   IImGearPoint* point
)
public:
ImGearPoint(
   IImGearPoint^ point
)

Parameters

point
An IImGearPoint interface to copy.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members
Overload List


%%PageItemTitle%%

ImGearPoint Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure > ImGearPoint Constructor : ImGearPoint Constructor(Int32,Int32)
X coordinate.
Y coordinate.
Initializes a new instance of the ImGearPoint struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pointX As Integer, _
   ByVal pointY As Integer _
)
'Usage

Dim pointX As Integer
Dim pointY As Integer

Dim instance As New ImGearPoint(pointX, pointY)
public ImGearPoint(
   int pointX,
   int pointY
)
public: ImGearPoint(
   int pointX,
   int pointY
)
public:
ImGearPoint(
   int pointX,
   int pointY
)

Parameters

pointX
X coordinate.
pointY
Y coordinate.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearPoint Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPoint Structure

For a list of all members of this type, see ImGearPoint members.

Public Methods
 | Name | Description
Public Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

ImGearPoint Structure
ImageGear.Core Namespace


Offset Method (ImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure : Offset Method
The x coordinate value.
The y coordinate value.
Shifts the points coordinates by the specified coordinateX and coordinateY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Offset( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearPoint
Dim offsetX As Integer
Dim offsetY As Integer

instance.Offset(offsetX, offsetY)
public void Offset(
   int offsetX,
   int offsetY
)
public: void Offset(
   int offsetX,
   int offsetY
)
public:
void Offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The x coordinate value.
offsetY
The y coordinate value.
Remarks
This method shifts the points coordinates by the specified dx and dy values.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members


%%PageItemTitle%% $$Properties$$

ImGearPoint Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearPoint Structure

For a list of all members of this type, see ImGearPoint members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of the point.
Public Property | Y | Gets or sets the y-coordinate of the point.
Top
See Also

Reference

ImGearPoint Structure
ImageGear.Core Namespace


X Property (ImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure : X Property
Gets or sets the x-coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Integer
'Usage

Dim instance As ImGearPoint
Dim value As Integer

instance.X = value

value = instance.X
public int X {get; set;}
public: __property int get_X();
public: __property void set_X(
   int value
);
public:
property int X {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members


Y Property (ImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearPoint Structure : Y Property
Gets or sets the y-coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Integer
'Usage

Dim instance As ImGearPoint
Dim value As Integer

instance.Y = value

value = instance.Y
public int Y {get; set;}
public: __property int get_Y();
public: __property void set_Y(
   int value
);
public:
property int Y {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearPoint Structure
ImGearPoint Members


%%PageItemTitle%%

ImGearRationalInt Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
Object Model
ImGearRationalInt StructureImGearRationalInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRationalInt
   Inherits System.ValueType
'Usage

Dim instance As ImGearRationalInt
public struct ImGearRationalInt : System.ValueType
public __value struct ImGearRationalInt : public System.ValueType
public value class ImGearRationalInt : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRationalInt

See Also

Reference

ImGearRationalInt Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRationalInt Structure Members
Fields Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalInt Structure

The following tables list the members exposed by ImGearRationalInt.

Public Constructors
 | Name | Description
Public Constructor | ImGearRationalInt Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Denominator | Denominator value.
Public Field | Numerator | Numerator value.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromString | Creates a ImGearRationalInt from the specified string.
Public Method | ToDouble | Converts the value of this instance to its equivalent double representation.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearRationalInt Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRationalInt Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : ImGearRationalInt Constructor
Overload List
Overload | Description
ImGearRationalInt Constructor(Int32) | Initializes a new instance of the ImGearRationalInt structure.
ImGearRationalInt Constructor(Int32,Int32) | Initializes a new instance of the ImGearRationalInt structure.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members


%%PageItemTitle%%

ImGearRationalInt Constructor(Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure > ImGearRationalInt Constructor : ImGearRationalInt Constructor(Int32)
Integer that represents the numerator of a fraction. Must be nonnegative.
Initializes a new instance of the ImGearRationalInt structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal numerator As Integer _
)
'Usage

Dim numerator As Integer

Dim instance As New ImGearRationalInt(numerator)
public ImGearRationalInt(
   int numerator
)
public: ImGearRationalInt(
   int numerator
)
public:
ImGearRationalInt(
   int numerator
)

Parameters

numerator
Integer that represents the numerator of a fraction. Must be nonnegative.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members
Overload List


%%PageItemTitle%%

ImGearRationalInt Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure > ImGearRationalInt Constructor : ImGearRationalInt Constructor(Int32,Int32)
Integer that represents the numerator of a fraction. Must be nonnegative.
Integer that represents the denominator of a fraction. Must be nonnegative.
Initializes a new instance of the ImGearRationalInt structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal numerator As Integer, _
   ByVal denominator As Integer _
)
'Usage

Dim numerator As Integer
Dim denominator As Integer

Dim instance As New ImGearRationalInt(numerator, denominator)
public ImGearRationalInt(
   int numerator,
   int denominator
)
public: ImGearRationalInt(
   int numerator,
   int denominator
)
public:
ImGearRationalInt(
   int numerator,
   int denominator
)

Parameters

numerator
Integer that represents the numerator of a fraction. Must be nonnegative.
denominator
Integer that represents the denominator of a fraction. Must be nonnegative.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRationalInt Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalInt Structure

For a list of all members of this type, see ImGearRationalInt members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromString | Creates a ImGearRationalInt from the specified string.
Public Method | ToDouble | Converts the value of this instance to its equivalent double representation.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearRationalInt Structure
ImageGear.Core Namespace


FromString Method (ImGearRationalInt)
Example

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : FromString Method
The string to parse.
Creates a ImGearRationalInt from the specified string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromString( _
   ByVal value As String _
) As ImGearRationalInt
'Usage

Dim value As String
Dim value As ImGearRationalInt

value = ImGearRationalInt.FromString(value)
public static ImGearRationalInt FromString(
   string value
)
public: static ImGearRationalInt FromString(
   string* value
)
public:
static ImGearRationalInt FromString(
   String^ value
)

Parameters

value
The string to parse.

Return Value

A new ImGearRationalInt structure.
Example
  • C#
ImGearRationalInt rational = ImGearRationalInt.FromString("2/4");
  • Visual Basic
Dim rational As ImGearRationalInt
rational = ImGearRationalInt.FromString("2/4")
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members


ToDouble Method (ImGearRationalInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : ToDouble Method
Converts the value of this instance to its equivalent double representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToDouble() As Double
'Usage

Dim instance As ImGearRationalInt
Dim value As Double

value = instance.ToDouble()
public double ToDouble()
public: double ToDouble();
public:
double ToDouble();

Return Value

Double value.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members
ToString Method


ToString Method (ImGearRationalInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : ToString Method
Converts the value of this instance to its equivalent string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearRationalInt
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members
ToDouble Method


%%PageItemTitle%% $$Fields$$

ImGearRationalInt Structure Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalInt Structure

For a list of all members of this type, see ImGearRationalInt members.

Public Fields
 | Name | Description
Public Field | Denominator | Denominator value.
Public Field | Numerator | Numerator value.
Top
See Also

Reference

ImGearRationalInt Structure
ImageGear.Core Namespace


Denominator Field (ImGearRationalInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : Denominator Field
Denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Denominator As Integer
'Usage

Dim instance As ImGearRationalInt
Dim value As Integer

value = instance.Denominator

instance.Denominator = value
public int Denominator
public: int Denominator
public:
int Denominator

Field Value

Any integer value.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members


Numerator Field (ImGearRationalInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalInt Structure : Numerator Field
Numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Numerator As Integer
'Usage

Dim instance As ImGearRationalInt
Dim value As Integer

value = instance.Numerator

instance.Numerator = value
public int Numerator
public: int Numerator
public:
int Numerator

Field Value

Any integer value.
See Also

Reference

ImGearRationalInt Structure
ImGearRationalInt Members


%%PageItemTitle%%

ImGearRationalUInt Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalUInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
Object Model
ImGearRationalUInt StructureImGearRationalUInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRationalUInt
   Inherits System.ValueType
'Usage

Dim instance As ImGearRationalUInt
public struct ImGearRationalUInt : System.ValueType
public __value struct ImGearRationalUInt : public System.ValueType
public value class ImGearRationalUInt : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRationalUInt

See Also

Reference

ImGearRationalUInt Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRationalUInt Structure Members
Fields Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalUInt Structure

The following tables list the members exposed by ImGearRationalUInt.

Public Constructors
 | Name | Description
Public Constructor | ImGearRationalUInt Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Denominator | Denominator value.
Public Field | Numerator | Numerator value.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromString | Creates a ImGearRationalUInt from the specified string.
Public Method | ToDouble | Converts the value of this instance to its equivalent double representation.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearRationalUInt Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRationalUInt Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : ImGearRationalUInt Constructor
Overload List
Overload | Description
ImGearRationalUInt Constructor(UInt32) | Initializes a new instance of the ImGearRationalUInt structure.
ImGearRationalUInt Constructor(UInt32,UInt32) | Initializes a new instance of the ImGearRationalUInt structure.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members


%%PageItemTitle%%

ImGearRationalUInt Constructor(UInt32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure > ImGearRationalUInt Constructor : ImGearRationalUInt Constructor(UInt32)
UInt value that represents the numerator of a fraction. Must be nonnegative.
Initializes a new instance of the ImGearRationalUInt structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal numerator As UInteger _
)
'Usage

Dim numerator As UInteger

Dim instance As New ImGearRationalUInt(numerator)
public ImGearRationalUInt(
   uint numerator
)
public: ImGearRationalUInt(
   uint numerator
)
public:
ImGearRationalUInt(
   uint numerator
)

Parameters

numerator
UInt value that represents the numerator of a fraction. Must be nonnegative.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members
Overload List


%%PageItemTitle%%

ImGearRationalUInt Constructor(UInt32,UInt32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure > ImGearRationalUInt Constructor : ImGearRationalUInt Constructor(UInt32,UInt32)
Uint value that represents the numerator of a fraction. Must be nonnegative.
Uint value that represents the denominator of a fraction. Must be nonnegative.
Initializes a new instance of the ImGearRationalUInt structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal numerator As UInteger, _
   ByVal denominator As UInteger _
)
'Usage

Dim numerator As UInteger
Dim denominator As UInteger

Dim instance As New ImGearRationalUInt(numerator, denominator)
public ImGearRationalUInt(
   uint numerator,
   uint denominator
)
public: ImGearRationalUInt(
   uint numerator,
   uint denominator
)
public:
ImGearRationalUInt(
   uint numerator,
   uint denominator
)

Parameters

numerator
Uint value that represents the numerator of a fraction. Must be nonnegative.
denominator
Uint value that represents the denominator of a fraction. Must be nonnegative.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRationalUInt Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalUInt Structure

For a list of all members of this type, see ImGearRationalUInt members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromString | Creates a ImGearRationalUInt from the specified string.
Public Method | ToDouble | Converts the value of this instance to its equivalent double representation.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearRationalUInt Structure
ImageGear.Core Namespace


FromString Method (ImGearRationalUInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : FromString Method
The string to parse.
Creates a ImGearRationalUInt from the specified string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromString( _
   ByVal value As String _
) As ImGearRationalUInt
'Usage

Dim value As String
Dim value As ImGearRationalUInt

value = ImGearRationalUInt.FromString(value)
public static ImGearRationalUInt FromString(
   string value
)
public: static ImGearRationalUInt FromString(
   string* value
)
public:
static ImGearRationalUInt FromString(
   String^ value
)

Parameters

value
The string to parse.

Return Value

A new ImGearRationalUInt structure.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members


ToDouble Method (ImGearRationalUInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : ToDouble Method
Converts the value of this instance to its equivalent double representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToDouble() As Double
'Usage

Dim instance As ImGearRationalUInt
Dim value As Double

value = instance.ToDouble()
public double ToDouble()
public: double ToDouble();
public:
double ToDouble();

Return Value

Double value.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members
ToString Method


ToString Method (ImGearRationalUInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : ToString Method
Converts the value of this instance to its equivalent string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearRationalUInt
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members
ToDouble Method


%%PageItemTitle%% $$Fields$$

ImGearRationalUInt Structure Fields

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRationalUInt Structure

For a list of all members of this type, see ImGearRationalUInt members.

Public Fields
 | Name | Description
Public Field | Denominator | Denominator value.
Public Field | Numerator | Numerator value.
Top
See Also

Reference

ImGearRationalUInt Structure
ImageGear.Core Namespace


Denominator Field (ImGearRationalUInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : Denominator Field
Denominator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Denominator As UInteger
'Usage

Dim instance As ImGearRationalUInt
Dim value As UInteger

value = instance.Denominator

instance.Denominator = value
public uint Denominator
public: uint Denominator
public:
uint Denominator

Field Value

Any unsigned integer value.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members


Numerator Field (ImGearRationalUInt)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRationalUInt Structure : Numerator Field
Numerator value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Numerator As UInteger
'Usage

Dim instance As ImGearRationalUInt
Dim value As UInteger

value = instance.Numerator

instance.Numerator = value
public uint Numerator
public: uint Numerator
public:
uint Numerator

Field Value

Any unsigned integer value.
See Also

Reference

ImGearRationalUInt Structure
ImGearRationalUInt Members


%%PageItemTitle%%

ImGearRect Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRect Structure
Stores a set of four integer numbers that represent the location and size of the rectangle.
Object Model
ImGearRect Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRect
   Inherits System.ValueType
'Usage

Dim instance As ImGearRect
public struct ImGearRect : System.ValueType
public __value struct ImGearRect : public System.ValueType
public value class ImGearRect : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRect

See Also

Reference

ImGearRect Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRect Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRect Structure

The following tables list the members exposed by ImGearRect.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Top
See Also

Reference

ImGearRect Structure
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearRect Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRect Structure

For a list of all members of this type, see ImGearRect members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Top
See Also

Reference

ImGearRect Structure
ImageGear.Core Namespace


Bottom Property (ImGearRect)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRect Structure : Bottom Property
Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bottom As IntPtr
'Usage

Dim instance As ImGearRect
Dim value As IntPtr

instance.Bottom = value

value = instance.Bottom
public IntPtr Bottom {get; set;}
public: __property IntPtr get_Bottom();
public: __property void set_Bottom(
   IntPtr value
);
public:
property IntPtr Bottom {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRect Structure
ImGearRect Members


Left Property (ImGearRect)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRect Structure : Left Property
Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As IntPtr
'Usage

Dim instance As ImGearRect
Dim value As IntPtr

instance.Left = value

value = instance.Left
public IntPtr Left {get; set;}
public: __property IntPtr get_Left();
public: __property void set_Left(
   IntPtr value
);
public:
property IntPtr Left {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRect Structure
ImGearRect Members


Right Property (ImGearRect)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRect Structure : Right Property
Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Right As IntPtr
'Usage

Dim instance As ImGearRect
Dim value As IntPtr

instance.Right = value

value = instance.Right
public IntPtr Right {get; set;}
public: __property IntPtr get_Right();
public: __property void set_Right(
   IntPtr value
);
public:
property IntPtr Right {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRect Structure
ImGearRect Members


Top Property (ImGearRect)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRect Structure : Top Property
Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As IntPtr
'Usage

Dim instance As ImGearRect
Dim value As IntPtr

instance.Top = value

value = instance.Top
public IntPtr Top {get; set;}
public: __property IntPtr get_Top();
public: __property void set_Top(
   IntPtr value
);
public:
property IntPtr Top {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRect Structure
ImGearRect Members


%%PageItemTitle%%

ImGearRectangle Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRectangle Structure
Stores a set of four integer numbers that represent the location and size of a rectangle.
Object Model
ImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRectangle
   Inherits System.ValueType
   Implements IImGearRectangle, IImGearShape
'Usage

Dim instance As ImGearRectangle
public struct ImGearRectangle : System.ValueType, IImGearRectangle, IImGearShape
public __value struct ImGearRectangle : public System.ValueType, IImGearRectangle, IImGearShape
public value class ImGearRectangle : public System.ValueType, IImGearRectangle, IImGearShape
Remarks
Stores a set of API that represent the rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRectangle

See Also

Reference

ImGearRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRectangle Structure Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRectangle Structure

The following tables list the members exposed by ImGearRectangle.

Public Constructors
 | Name | Description
Public Constructor | ImGearRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Height | Gets the height of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Public Property | Width | Gets the width of the rectangle.
Top
Public Methods
 | Name | Description
Public Method | Contains | Checks if the specified point's coordinates are inside of the rectangle.
Public Method | CopyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Public Method | Intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Public Method | IsEmpty | Tests whether all numeric properties of the rectangle are set to their initial values.
Public Method | IsWellFormed | Tests whether the rectangle is valid.
Public Method | Join | Changes the rectangle's points to contain the specified point.
Public Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearRectangle Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRectangle Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : ImGearRectangle Constructor
Overload List
Overload | Description
ImGearRectangle Constructor(Int32,Int32) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(IImGearRectangle) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(IImGearPoint,IImGearPoint) | Initializes a new instance of the ImGearRectangle struct.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


%%PageItemTitle%%

ImGearRectangle Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure > ImGearRectangle Constructor : ImGearRectangle Constructor(Int32,Int32)
Width of a rectangle.
Height of a rectangle.
Initializes a new instance of the ImGearRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim width As Integer
Dim height As Integer

Dim instance As New ImGearRectangle(width, height)
public ImGearRectangle(
   int width,
   int height
)
public: ImGearRectangle(
   int width,
   int height
)
public:
ImGearRectangle(
   int width,
   int height
)

Parameters

width
Width of a rectangle.
height
Height of a rectangle.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(Int32,Int32,Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure > ImGearRectangle Constructor : ImGearRectangle Constructor(Int32,Int32,Int32,Int32)
X-coordinate of the upper-left corner of a rectangle.
Y-coordinate of the upper-left corner of a rectangle.
X-coordinate of the lower-right corner of a rectangle.
Y-coordinate of the lower-right corner of a rectangle.
Initializes a new instance of the ImGearRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim width As Integer
Dim height As Integer

Dim instance As New ImGearRectangle(left, top, width, height)
public ImGearRectangle(
   int left,
   int top,
   int width,
   int height
)
public: ImGearRectangle(
   int left,
   int top,
   int width,
   int height
)
public:
ImGearRectangle(
   int left,
   int top,
   int width,
   int height
)

Parameters

left
X-coordinate of the upper-left corner of a rectangle.
top
Y-coordinate of the upper-left corner of a rectangle.
width
X-coordinate of the lower-right corner of a rectangle.
height
Y-coordinate of the lower-right corner of a rectangle.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure > ImGearRectangle Constructor : ImGearRectangle Constructor(IImGearRectangle)
A rectangle object.
Initializes a new instance of the ImGearRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim rect As IImGearRectangle

Dim instance As New ImGearRectangle(rect)
public ImGearRectangle(
   IImGearRectangle rect
)
public: ImGearRectangle(
   IImGearRectangle* rect
)
public:
ImGearRectangle(
   IImGearRectangle^ rect
)

Parameters

rect
A rectangle object.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(IImGearPoint,IImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure > ImGearRectangle Constructor : ImGearRectangle Constructor(IImGearPoint,IImGearPoint)
Used to initialize Left and Top points of the rectangle.
Used to initialize Right and Bottom points of the rectangle.
Initializes a new instance of the ImGearRectangle struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal leftTop As IImGearPoint, _
   ByVal rightBottom As IImGearPoint _
)
'Usage

Dim leftTop As IImGearPoint
Dim rightBottom As IImGearPoint

Dim instance As New ImGearRectangle(leftTop, rightBottom)
public ImGearRectangle(
   IImGearPoint leftTop,
   IImGearPoint rightBottom
)
public: ImGearRectangle(
   IImGearPoint* leftTop,
   IImGearPoint* rightBottom
)
public:
ImGearRectangle(
   IImGearPoint^ leftTop,
   IImGearPoint^ rightBottom
)

Parameters

leftTop
Used to initialize Left and Top points of the rectangle.
rightBottom
Used to initialize Right and Bottom points of the rectangle.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRectangle Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRectangle Structure

For a list of all members of this type, see ImGearRectangle members.

Public Methods
 | Name | Description
Public Method | Contains | Checks if the specified point's coordinates are inside of the rectangle.
Public Method | CopyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Public Method | Intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Public Method | IsEmpty | Tests whether all numeric properties of the rectangle are set to their initial values.
Public Method | IsWellFormed | Tests whether the rectangle is valid.
Public Method | Join | Changes the rectangle's points to contain the specified point.
Public Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
See Also

Reference

ImGearRectangle Structure
ImageGear.Core Namespace


Contains Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Contains Method
The point.
Checks if the specified point's coordinates are inside of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal point As IImGearPoint _
) As Boolean
'Usage

Dim instance As ImGearRectangle
Dim point As IImGearPoint
Dim value As Boolean

value = instance.Contains(point)
public bool Contains(
   IImGearPoint point
)
public: bool Contains(
   IImGearPoint* point
)
public:
bool Contains(
   IImGearPoint^ point
)

Parameters

point
The point.

Return Value

Boolean value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
ImGearPoint Structure


CopyFrom Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : CopyFrom Method
A rectangle object.
Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim instance As ImGearRectangle
Dim rect As IImGearRectangle

instance.CopyFrom(rect)
public void CopyFrom(
   IImGearRectangle rect
)
public: void CopyFrom(
   IImGearRectangle* rect
)
public:
void CopyFrom(
   IImGearRectangle^ rect
)

Parameters

rect
A rectangle object.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Empty Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Empty Method
Sets all numeric properties of the rectangle to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Empty()
'Usage

Dim instance As ImGearRectangle

instance.Empty()
public void Empty()
public: void Empty();
public:
void Empty();
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Intersect Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Intersect Method
A rectangle object.
Replaces this rectangle with the intersection of itself and another rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Intersect( _
   ByVal rect As IImGearRectangle _
) As Boolean
'Usage

Dim instance As ImGearRectangle
Dim rect As IImGearRectangle
Dim value As Boolean

value = instance.Intersect(rect)
public bool Intersect(
   IImGearRectangle rect
)
public: bool Intersect(
   IImGearRectangle* rect
)
public:
bool Intersect(
   IImGearRectangle^ rect
)

Parameters

rect
A rectangle object.

Return Value

Boolean value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


IsEmpty Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : IsEmpty Method
Tests whether all numeric properties of the rectangle are set to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsEmpty() As Boolean
'Usage

Dim instance As ImGearRectangle
Dim value As Boolean

value = instance.IsEmpty()
public bool IsEmpty()
public: bool IsEmpty();
public:
bool IsEmpty();

Return Value

Boolean value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


IsWellFormed Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : IsWellFormed Method
Tests whether the rectangle is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsWellFormed() As Boolean
'Usage

Dim instance As ImGearRectangle
Dim value As Boolean

value = instance.IsWellFormed()
public bool IsWellFormed()
public: bool IsWellFormed();
public:
bool IsWellFormed();

Return Value

Boolean value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Join Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Join Method
The point.
Changes the rectangle's points to contain the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Join( _
   ByVal point As IImGearPoint _
)
'Usage

Dim instance As ImGearRectangle
Dim point As IImGearPoint

instance.Join(point)
public void Join(
   IImGearPoint point
)
public: void Join(
   IImGearPoint* point
)
public:
void Join(
   IImGearPoint^ point
)

Parameters

point
The point.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members
ImGearPoint Structure


Offset Method (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Offset Method
The X shift value.
The Y shift value.
Shifts the rectangle points by the specified shiftX and shiftY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Offset( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As ImGearRectangle
Dim offsetX As Integer
Dim offsetY As Integer

instance.Offset(offsetX, offsetY)
public void Offset(
   int offsetX,
   int offsetY
)
public: void Offset(
   int offsetX,
   int offsetY
)
public:
void Offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


%%PageItemTitle%% $$Properties$$

ImGearRectangle Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRectangle Structure

For a list of all members of this type, see ImGearRectangle members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Public Property | Height | Gets the height of the rectangle.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Public Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Public Property | Width | Gets the width of the rectangle.
Top
See Also

Reference

ImGearRectangle Structure
ImageGear.Core Namespace


Bottom Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Bottom Property
Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bottom As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

instance.Bottom = value

value = instance.Bottom
public int Bottom {get; set;}
public: __property int get_Bottom();
public: __property void set_Bottom(
   int value
);
public:
property int Bottom {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Height Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Height Property
Gets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

Any integer value.
Remarks
Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Left Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Left Property
Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

instance.Left = value

value = instance.Left
public int Left {get; set;}
public: __property int get_Left();
public: __property void set_Left(
   int value
);
public:
property int Left {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Right Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Right Property
Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Right As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

instance.Right = value

value = instance.Right
public int Right {get; set;}
public: __property int get_Right();
public: __property void set_Right(
   int value
);
public:
property int Right {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Top Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Top Property
Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

instance.Top = value

value = instance.Top
public int Top {get; set;}
public: __property int get_Top();
public: __property void set_Top(
   int value
);
public:
property int Top {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


Width Property (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : Width Property
Gets the width of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImGearRectangle
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

Any integer value.
Remarks
Note:

The Height and Width properties assume that the rectangle is being used with endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


%%PageItemTitle%% $$Events$$

ImGearRectangle Structure Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRectangle Structure

For a list of all members of this type, see ImGearRectangle members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearRectangle Structure
ImageGear.Core Namespace


PropertyChanged Event (ImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRectangle Structure : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearRectangle
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearRectangle Structure
ImGearRectangle Members


%%PageItemTitle%%

ImGearResolution Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearResolution Structure
Stores ImageGear resolution data.
Object Model
ImGearResolution Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearResolution
   Inherits System.ValueType
   Implements IImGearResolution
'Usage

Dim instance As ImGearResolution
public struct ImGearResolution : System.ValueType, IImGearResolution
public __value struct ImGearResolution : public System.ValueType, IImGearResolution
public value class ImGearResolution : public System.ValueType, IImGearResolution
Remarks
Specifies image resolution attributes.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearResolution

See Also

Reference

ImGearResolution Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearResolution Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearResolution Structure

The following tables list the members exposed by ImGearResolution.

Public Constructors
 | Name | Description
Public Constructor | ImGearResolution Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Units | Gets or sets resolution units.
Public Property | XDenominator | Gets or sets the denominator of the X component of the resolution.
Public Property | XNumerator | Gets or sets the numerator of the X component of the resolution.
Public Property | YDenominator | Gets or sets the denominator of the Y component of the resolution.
Public Property | YNumerator | Gets or sets the numerator of the Y component of the resolution.
Top
Public Methods
 | Name | Description
Public Method | ConvertUnits | Converts resolution data into new units.
Top
See Also

Reference

ImGearResolution Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearResolution Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : ImGearResolution Constructor
Overload List
Overload | Description
ImGearResolution Constructor(ImGearResolutionUnits) | Initializes a new instance of the ImGearResolution structure.
ImGearResolution Constructor(Int32,Int32,Int32,Int32,ImGearResolutionUnits) | Initializes a new instance of the ImGearResolution structure.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members


%%PageItemTitle%%

ImGearResolution Constructor(ImGearResolutionUnits)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure > ImGearResolution Constructor : ImGearResolution Constructor(ImGearResolutionUnits)
Resolution units.
Initializes a new instance of the ImGearResolution structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal units As ImGearResolutionUnits _
)
'Usage

Dim units As ImGearResolutionUnits

Dim instance As New ImGearResolution(units)
public ImGearResolution(
   ImGearResolutionUnits units
)
public: ImGearResolution(
   ImGearResolutionUnits units
)
public:
ImGearResolution(
   ImGearResolutionUnits units
)

Parameters

units
Resolution units.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members
Overload List
ImGearResolutionUnits Enumeration


%%PageItemTitle%%

ImGearResolution Constructor(Int32,Int32,Int32,Int32,ImGearResolutionUnits)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure > ImGearResolution Constructor : ImGearResolution Constructor(Int32,Int32,Int32,Int32,ImGearResolutionUnits)
Numerator of the X component of the resolution.
Denominator of the X component of the resolution.
Numerator of the Y component of the resolution.
Denominator of the Y component of the resolution.
Resolution units.
Initializes a new instance of the ImGearResolution structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal numeratorX As Integer, _
   ByVal denominatorX As Integer, _
   ByVal numeratorY As Integer, _
   ByVal denominatorY As Integer, _
   ByVal units As ImGearResolutionUnits _
)
'Usage

Dim numeratorX As Integer
Dim denominatorX As Integer
Dim numeratorY As Integer
Dim denominatorY As Integer
Dim units As ImGearResolutionUnits

Dim instance As New ImGearResolution(numeratorX, denominatorX, numeratorY, denominatorY, units)
public ImGearResolution(
   int numeratorX,
   int denominatorX,
   int numeratorY,
   int denominatorY,
   ImGearResolutionUnits units
)
public: ImGearResolution(
   int numeratorX,
   int denominatorX,
   int numeratorY,
   int denominatorY,
   ImGearResolutionUnits units
)
public:
ImGearResolution(
   int numeratorX,
   int denominatorX,
   int numeratorY,
   int denominatorY,
   ImGearResolutionUnits units
)

Parameters

numeratorX
Numerator of the X component of the resolution.
denominatorX
Denominator of the X component of the resolution.
numeratorY
Numerator of the Y component of the resolution.
denominatorY
Denominator of the Y component of the resolution.
units
Resolution units.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members
Overload List
ImGearResolutionUnits Enumeration


%%PageItemTitle%% $$Methods$$

ImGearResolution Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearResolution Structure

For a list of all members of this type, see ImGearResolution members.

Public Methods
 | Name | Description
Public Method | ConvertUnits | Converts resolution data into new units.
Top
See Also

Reference

ImGearResolution Structure
ImageGear.Core Namespace


ConvertUnits Method (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : ConvertUnits Method
New resolution data units.
Converts resolution data into new units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ConvertUnits( _
   ByVal newUnits As ImGearResolutionUnits _
)
'Usage

Dim instance As ImGearResolution
Dim newUnits As ImGearResolutionUnits

instance.ConvertUnits(newUnits)
public void ConvertUnits(
   ImGearResolutionUnits newUnits
)
public: void ConvertUnits(
   ImGearResolutionUnits newUnits
)
public:
void ConvertUnits(
   ImGearResolutionUnits newUnits
)

Parameters

newUnits
New resolution data units.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members
ImGearResolutionUnits Enumeration


%%PageItemTitle%% $$Properties$$

ImGearResolution Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearResolution Structure

For a list of all members of this type, see ImGearResolution members.

Public Properties
 | Name | Description
Public Property | Units | Gets or sets resolution units.
Public Property | XDenominator | Gets or sets the denominator of the X component of the resolution.
Public Property | XNumerator | Gets or sets the numerator of the X component of the resolution.
Public Property | YDenominator | Gets or sets the denominator of the Y component of the resolution.
Public Property | YNumerator | Gets or sets the numerator of the Y component of the resolution.
Top
See Also

Reference

ImGearResolution Structure
ImageGear.Core Namespace


Units Property (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : Units Property
Gets or sets resolution units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Units As ImGearResolutionUnits
'Usage

Dim instance As ImGearResolution
Dim value As ImGearResolutionUnits

instance.Units = value

value = instance.Units
public ImGearResolutionUnits Units {get; set;}
public: __property ImGearResolutionUnits get_Units();
public: __property void set_Units(
   ImGearResolutionUnits value
);
public:
property ImGearResolutionUnits Units {
   ImGearResolutionUnits get();
   void set (    ImGearResolutionUnits value);
}

Property Value

ImGearResolutionUnits enumeration values.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members
ImGearResolutionUnits Enumeration


XDenominator Property (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : XDenominator Property
Gets or sets the denominator of the X component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XDenominator As Integer
'Usage

Dim instance As ImGearResolution
Dim value As Integer

instance.XDenominator = value

value = instance.XDenominator
public int XDenominator {get; set;}
public: __property int get_XDenominator();
public: __property void set_XDenominator(
   int value
);
public:
property int XDenominator {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members


XNumerator Property (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : XNumerator Property
Gets or sets the numerator of the X component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XNumerator As Integer
'Usage

Dim instance As ImGearResolution
Dim value As Integer

instance.XNumerator = value

value = instance.XNumerator
public int XNumerator {get; set;}
public: __property int get_XNumerator();
public: __property void set_XNumerator(
   int value
);
public:
property int XNumerator {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members


YDenominator Property (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : YDenominator Property
Gets or sets the denominator of the Y component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YDenominator As Integer
'Usage

Dim instance As ImGearResolution
Dim value As Integer

instance.YDenominator = value

value = instance.YDenominator
public int YDenominator {get; set;}
public: __property int get_YDenominator();
public: __property void set_YDenominator(
   int value
);
public:
property int YDenominator {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members


YNumerator Property (ImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearResolution Structure : YNumerator Property
Gets or sets the numerator of the Y component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YNumerator As Integer
'Usage

Dim instance As ImGearResolution
Dim value As Integer

instance.YNumerator = value

value = instance.YNumerator
public int YNumerator {get; set;}
public: __property int get_YNumerator();
public: __property void set_YNumerator(
   int value
);
public:
property int YNumerator {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearResolution Structure
ImGearResolution Members


%%PageItemTitle%%

ImGearRGBQuad Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBQuad Structure
Specifies an RGB value.
Object Model
ImGearRGBQuad Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRGBQuad
   Inherits System.ValueType
   Implements IImGearRGBQuad
'Usage

Dim instance As ImGearRGBQuad
public struct ImGearRGBQuad : System.ValueType, IImGearRGBQuad
public __value struct ImGearRGBQuad : public System.ValueType, IImGearRGBQuad
public value class ImGearRGBQuad : public System.ValueType, IImGearRGBQuad
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRGBQuad

See Also

Reference

ImGearRGBQuad Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRGBQuad Structure Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBQuad Structure

The following tables list the members exposed by ImGearRGBQuad.

Public Constructors
 | Name | Description
Public Constructor | ImGearRGBQuad Constructor | Overloaded. Initializes a new instance of the ImGearRGBQuad structure.
Top
Public Properties
 | Name | Description
Public Property | Blue | Gets or sets blue value.
Public Property | Green | Gets or sets green value.
Public Property | Red | Gets or sets red value.
Public Property | Reserved | Gets or sets reserved value.
Top
Public Methods
 | Name | Description
Public Method | IsGray | Overloaded. Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearRGBQuad Structure
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearRGBQuad Constructor

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : ImGearRGBQuad Constructor
Initializes a new instance of the ImGearRGBQuad structure.
Overload List
Overload | Description
ImGearRGBQuad Constructor(Int32) | Initializes a new instance of the ImGearRGBQuad structure with specified gray value.
ImGearRGBQuad Constructor(IImGearRGBQuad) | Initializes a new instance of the ImGearRGBQuad structure from the specified IImGearRGBQuad object.
ImGearRGBQuad Constructor(Int32,Int32,Int32) | Initializes a new instance of the ImGearRGBQuad structure with specified red, green and blue color values.
ImGearRGBQuad Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearRGBQuad structure with specified red, green, blue and reserved color values.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


%%PageItemTitle%%

ImGearRGBQuad Constructor(Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(Int32)
Gray color value.
Initializes a new instance of the ImGearRGBQuad structure with specified gray value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal gray As Integer _
)
'Usage

Dim gray As Integer

Dim instance As New ImGearRGBQuad(gray)
public ImGearRGBQuad(
   int gray
)
public: ImGearRGBQuad(
   int gray
)
public:
ImGearRGBQuad(
   int gray
)

Parameters

gray
Gray color value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(IImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(IImGearRGBQuad)
IImGearRGBQuad interface.
Initializes a new instance of the ImGearRGBQuad structure from the specified IImGearRGBQuad object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As IImGearRGBQuad _
)
'Usage

Dim color As IImGearRGBQuad

Dim instance As New ImGearRGBQuad(color)
public ImGearRGBQuad(
   IImGearRGBQuad color
)
public: ImGearRGBQuad(
   IImGearRGBQuad* color
)
public:
ImGearRGBQuad(
   IImGearRGBQuad^ color
)

Parameters

color
IImGearRGBQuad interface.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(Int32,Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(Int32,Int32,Int32)
Red color value.
Green color value.
Blue color value.
Initializes a new instance of the ImGearRGBQuad structure with specified red, green and blue color values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer _
)
'Usage

Dim red As Integer
Dim green As Integer
Dim blue As Integer

Dim instance As New ImGearRGBQuad(red, green, blue)
public ImGearRGBQuad(
   int red,
   int green,
   int blue
)
public: ImGearRGBQuad(
   int red,
   int green,
   int blue
)
public:
ImGearRGBQuad(
   int red,
   int green,
   int blue
)

Parameters

red
Red color value.
green
Green color value.
blue
Blue color value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(Int32,Int32,Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(Int32,Int32,Int32,Int32)
Red color value.
Green color value.
Blue color value.
Reserved value.
Initializes a new instance of the ImGearRGBQuad structure with specified red, green, blue and reserved color values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer, _
   ByVal reserved As Integer _
)
'Usage

Dim red As Integer
Dim green As Integer
Dim blue As Integer
Dim reserved As Integer

Dim instance As New ImGearRGBQuad(red, green, blue, reserved)
public ImGearRGBQuad(
   int red,
   int green,
   int blue,
   int reserved
)
public: ImGearRGBQuad(
   int red,
   int green,
   int blue,
   int reserved
)
public:
ImGearRGBQuad(
   int red,
   int green,
   int blue,
   int reserved
)

Parameters

red
Red color value.
green
Green color value.
blue
Blue color value.
reserved
Reserved value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRGBQuad Structure Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBQuad Structure

For a list of all members of this type, see ImGearRGBQuad members.

Public Methods
 | Name | Description
Public Method | IsGray | Overloaded. Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
Top
See Also

Reference

ImGearRGBQuad Structure
ImageGear.Core Namespace


IsGray Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : IsGray Method
Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
Overload List
Overload | Description
IsGray() | Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
IsGray(Byte) | This method checks whether the RGB value is both grayscale and equal to specified value, i.e., Red = Green = Blue = value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


IsGray() Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > IsGray Method : IsGray() Method
Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsGray() As Boolean
'Usage

Dim instance As ImGearRGBQuad
Dim value As Boolean

value = instance.IsGray()
public bool IsGray()
public: bool IsGray();
public:
bool IsGray();

Return Value

Boolean value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


IsGray(Byte) Method

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure > IsGray Method : IsGray(Byte) Method
Gray color value.
This method checks whether the RGB value is both grayscale and equal to specified value, i.e., Red = Green = Blue = value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsGray( _
   ByVal value As Byte _
) As Boolean
'Usage

Dim instance As ImGearRGBQuad
Dim value As Byte
Dim value As Boolean

value = instance.IsGray(value)
public bool IsGray(
   byte value
)
public: bool IsGray(
   byte value
)
public:
bool IsGray(
   byte value
)

Parameters

value
Gray color value.

Return Value

Boolean value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearRGBQuad Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBQuad Structure

For a list of all members of this type, see ImGearRGBQuad members.

Public Properties
 | Name | Description
Public Property | Blue | Gets or sets blue value.
Public Property | Green | Gets or sets green value.
Public Property | Red | Gets or sets red value.
Public Property | Reserved | Gets or sets reserved value.
Top
See Also

Reference

ImGearRGBQuad Structure
ImageGear.Core Namespace


Blue Property (ImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : Blue Property
Gets or sets blue value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Blue As Byte
'Usage

Dim instance As ImGearRGBQuad
Dim value As Byte

instance.Blue = value

value = instance.Blue
public byte Blue {get; set;}
public: __property byte get_Blue();
public: __property void set_Blue(
   byte value
);
public:
property byte Blue {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


Green Property (ImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : Green Property
Gets or sets green value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Green As Byte
'Usage

Dim instance As ImGearRGBQuad
Dim value As Byte

instance.Green = value

value = instance.Green
public byte Green {get; set;}
public: __property byte get_Green();
public: __property void set_Green(
   byte value
);
public:
property byte Green {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


Red Property (ImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : Red Property
Gets or sets red value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Red As Byte
'Usage

Dim instance As ImGearRGBQuad
Dim value As Byte

instance.Red = value

value = instance.Red
public byte Red {get; set;}
public: __property byte get_Red();
public: __property void set_Red(
   byte value
);
public:
property byte Red {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


Reserved Property (ImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : Reserved Property
Gets or sets reserved value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Reserved As Byte
'Usage

Dim instance As ImGearRGBQuad
Dim value As Byte

instance.Reserved = value

value = instance.Reserved
public byte Reserved {get; set;}
public: __property byte get_Reserved();
public: __property void set_Reserved(
   byte value
);
public:
property byte Reserved {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
This value should be 0.
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


%%PageItemTitle%% $$Events$$

ImGearRGBQuad Structure Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRGBQuad Structure

For a list of all members of this type, see ImGearRGBQuad members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearRGBQuad Structure
ImageGear.Core Namespace


PropertyChanged Event (ImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRGBQuad Structure : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearRGBQuad
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearRGBQuad Structure
ImGearRGBQuad Members


%%PageItemTitle%%

ImGearRoundedRectangle Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRoundedRectangle Structure
This structure represents a rounded rectangle.
Object Model
ImGearRoundedRectangle StructureImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRoundedRectangle
   Inherits System.ValueType
   Implements IImGearRoundedRectangle, IImGearShape
'Usage

Dim instance As ImGearRoundedRectangle
public struct ImGearRoundedRectangle : System.ValueType, IImGearRoundedRectangle, IImGearShape
public __value struct ImGearRoundedRectangle : public System.ValueType, IImGearRoundedRectangle, IImGearShape
public value class ImGearRoundedRectangle : public System.ValueType, IImGearRoundedRectangle, IImGearShape
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearRoundedRectangle

See Also

Reference

ImGearRoundedRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearRoundedRectangle Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRoundedRectangle Structure

The following tables list the members exposed by ImGearRoundedRectangle.

Public Properties
 | Name | Description
Public Property | LeftTop | Gets or sets coordinates of the upper-left corner of the rectangle.
Public Property | Radius | Gets or sets the radius for the rounded edges.
Public Property | RightBottom | Gets or sets coordinates of the right-bottom corner of the rectangle.
Top
See Also

Reference

ImGearRoundedRectangle Structure
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearRoundedRectangle Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearRoundedRectangle Structure

For a list of all members of this type, see ImGearRoundedRectangle members.

Public Properties
 | Name | Description
Public Property | LeftTop | Gets or sets coordinates of the upper-left corner of the rectangle.
Public Property | Radius | Gets or sets the radius for the rounded edges.
Public Property | RightBottom | Gets or sets coordinates of the right-bottom corner of the rectangle.
Top
See Also

Reference

ImGearRoundedRectangle Structure
ImageGear.Core Namespace


LeftTop Property (ImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRoundedRectangle Structure : LeftTop Property
Gets or sets coordinates of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftTop As ImGearPoint
'Usage

Dim instance As ImGearRoundedRectangle
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
public ImGearPoint LeftTop {get; set;}
public: __property ImGearPoint get_LeftTop();
public: __property void set_LeftTop(
   ImGearPoint value
);
public:
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearRoundedRectangle Structure
ImGearRoundedRectangle Members


Radius Property (ImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRoundedRectangle Structure : Radius Property
Gets or sets the radius for the rounded edges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Radius As Integer
'Usage

Dim instance As ImGearRoundedRectangle
Dim value As Integer

instance.Radius = value

value = instance.Radius
public int Radius {get; set;}
public: __property int get_Radius();
public: __property void set_Radius(
   int value
);
public:
property int Radius {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRoundedRectangle Structure
ImGearRoundedRectangle Members


RightBottom Property (ImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearRoundedRectangle Structure : RightBottom Property
Gets or sets coordinates of the right-bottom corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightBottom As ImGearPoint
'Usage

Dim instance As ImGearRoundedRectangle
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
public ImGearPoint RightBottom {get; set;}
public: __property ImGearPoint get_RightBottom();
public: __property void set_RightBottom(
   ImGearPoint value
);
public:
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

ImGearRoundedRectangle Structure
ImGearRoundedRectangle Members


%%PageItemTitle%%

ImGearSize Structure
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSize Structure
Implements a relative coordinate or position.
Object Model
ImGearSize Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearSize
   Inherits System.ValueType
   Implements IImGearSize
'Usage

Dim instance As ImGearSize
public struct ImGearSize : System.ValueType, IImGearSize
public __value struct ImGearSize : public System.ValueType, IImGearSize
public value class ImGearSize : public System.ValueType, IImGearSize
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Core.ImGearSize

See Also

Reference

ImGearSize Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearSize Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSize Structure

The following tables list the members exposed by ImGearSize.

Public Properties
 | Name | Description
Public Property | cX | Gets or sets the rectangle's width.
Public Property | cY | Gets or sets the rectangle's height.
Top
See Also

Reference

ImGearSize Structure
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

ImGearSize Structure Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearSize Structure

For a list of all members of this type, see ImGearSize members.

Public Properties
 | Name | Description
Public Property | cX | Gets or sets the rectangle's width.
Public Property | cY | Gets or sets the rectangle's height.
Top
See Also

Reference

ImGearSize Structure
ImageGear.Core Namespace


cX Property (ImGearSize)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSize Structure : cX Property
Gets or sets the rectangle's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property cX As Integer
'Usage

Dim instance As ImGearSize
Dim value As Integer

instance.cX = value

value = instance.cX
public int cX {get; set;}
public: __property int get_cX();
public: __property void set_cX(
   int value
);
public:
property int cX {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearSize Structure
ImGearSize Members


cY Property (ImGearSize)

ImageGear22.Core Assembly > ImageGear.Core Namespace > ImGearSize Structure : cY Property
Gets or sets the rectangle's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property cY As Integer
'Usage

Dim instance As ImGearSize
Dim value As Integer

instance.cY = value

value = instance.cY
public int cY {get; set;}
public: __property int get_cY();
public: __property void set_cY(
   int value
);
public:
property int cY {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

ImGearSize Structure
ImGearSize Members


%%PageItemTitle%%

IImGearBinocular Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearBinocular Interface
Defines Binocular shape interface.
Object Model
IImGearBinocular InterfaceImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearBinocular
   Inherits IImGearShape
'Usage

Dim instance As IImGearBinocular
public interface IImGearBinocular : IImGearShape
public __gc __interface IImGearBinocular : public IImGearShape
public interface class IImGearBinocular : public IImGearShape
Remarks
Binocular shape is composed of two ellipses inscribed in the bounding rectangle. Distance property defines the distance between ellipse centers.
See Also

Reference

IImGearBinocular Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearBinocular Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearBinocular Interface

The following tables list the members exposed by IImGearBinocular.

Public Properties
 | Name | Description
Property | Distance | Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Property | RightBottom | Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Top
See Also

Reference

IImGearBinocular Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearBinocular Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearBinocular Interface

For a list of all members of this type, see IImGearBinocular members.

Public Properties
 | Name | Description
Property | Distance | Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Property | RightBottom | Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Top
See Also

Reference

IImGearBinocular Interface
ImageGear.Core Namespace


Distance Property (IImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearBinocular Interface : Distance Property
Gets or sets the distance between centers of the ellipses which constitute the binocular shape.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Distance As Integer
'Usage

Dim instance As IImGearBinocular
Dim value As Integer

instance.Distance = value

value = instance.Distance
int Distance {get; set;}
__property int get_Distance();
__property void set_Distance(
   int value
);
property int Distance {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearBinocular Interface
IImGearBinocular Members


LeftTop Property (IImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearBinocular Interface : LeftTop Property
Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property LeftTop As ImGearPoint
'Usage

Dim instance As IImGearBinocular
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
ImGearPoint LeftTop {get; set;}
__property ImGearPoint get_LeftTop();
__property void set_LeftTop(
   ImGearPoint value
);
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

IImGearBinocular Interface
IImGearBinocular Members
ImGearPoint Structure
ImGearBinocular Structure


RightBottom Property (IImGearBinocular)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearBinocular Interface : RightBottom Property
Gets or sets the coordinate of the right-bottom corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property RightBottom As ImGearPoint
'Usage

Dim instance As IImGearBinocular
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
ImGearPoint RightBottom {get; set;}
__property ImGearPoint get_RightBottom();
__property void set_RightBottom(
   ImGearPoint value
);
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

IImGearBinocular Interface
IImGearBinocular Members
ImGearPoint Structure


%%PageItemTitle%%

IImGearColorBook Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBook Interface
Defines color book interface.
Object Model
IImGearColorBook InterfaceImGearColorBookColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearColorBook
'Usage

Dim instance As IImGearColorBook
public interface IImGearColorBook
public __gc __interface IImGearColorBook
public interface class IImGearColorBook
See Also

Reference

IImGearColorBook Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearColorBook Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBook Interface

The following tables list the members exposed by IImGearColorBook.

Public Properties
 | Name | Description
Property | Colors | Gets the array of individual color records held by the color book.
Property | ColorsPerPage | Gets the maximum number of colors that can appear on a page.
Property | ColorType | Gets the color space value used for displaying all the colors from the color book.
Property | Description | Gets the color book copyright information.
Property | FileName | Gets the color book file name.
Property | KeyColorPage | Gets the key color on the page.
Property | NumberOfColors | Gets the number of colors in the color book.
Property | Postfix | Gets the color book postfix string value.
Property | Prefix | Gets the color book prefix string value.
Property | Title | Gets the color book title.
Property | VendorID | Gets the color book vendor ID value.
Top
See Also

Reference

IImGearColorBook Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearColorBook Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBook Interface

For a list of all members of this type, see IImGearColorBook members.

Public Properties
 | Name | Description
Property | Colors | Gets the array of individual color records held by the color book.
Property | ColorsPerPage | Gets the maximum number of colors that can appear on a page.
Property | ColorType | Gets the color space value used for displaying all the colors from the color book.
Property | Description | Gets the color book copyright information.
Property | FileName | Gets the color book file name.
Property | KeyColorPage | Gets the key color on the page.
Property | NumberOfColors | Gets the number of colors in the color book.
Property | Postfix | Gets the color book postfix string value.
Property | Prefix | Gets the color book prefix string value.
Property | Title | Gets the color book title.
Property | VendorID | Gets the color book vendor ID value.
Top
See Also

Reference

IImGearColorBook Interface
ImageGear.Core Namespace


Colors Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : Colors Property
Gets the array of individual color records held by the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Colors As ImGearColorBookColor()
'Usage

Dim instance As IImGearColorBook
Dim value() As ImGearColorBookColor

value = instance.Colors
ImGearColorBookColor[] Colors {get;}
__property ImGearColorBookColor*[]* get_Colors();
property array<ImGearColorBookColor^>^ Colors {
   array<ImGearColorBookColor^>^ get();
}

Property Value

Array instances of ImGearColorBookColor class.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members
IImGearColorBookColor Interface


ColorsPerPage Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : ColorsPerPage Property
Gets the maximum number of colors that can appear on a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ColorsPerPage As Integer
'Usage

Dim instance As IImGearColorBook
Dim value As Integer

value = instance.ColorsPerPage
int ColorsPerPage {get;}
__property int get_ColorsPerPage();
property int ColorsPerPage {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


ColorType Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : ColorType Property
Gets the color space value used for displaying all the colors from the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ColorType As ImGearColorSpaceIDs
'Usage

Dim instance As IImGearColorBook
Dim value As ImGearColorSpaceIDs

value = instance.ColorType
ImGearColorSpaceIDs ColorType {get;}
__property ImGearColorSpaceIDs get_ColorType();
property ImGearColorSpaceIDs ColorType {
   ImGearColorSpaceIDs get();
}

Property Value

ImGearColorSpaceIDs enumeration value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members
ImGearColorSpaceIDs Enumeration


Description Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : Description Property
Gets the color book copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Description As String
'Usage

Dim instance As IImGearColorBook
Dim value As String

value = instance.Description
string Description {get;}
__property string* get_Description();
property String^ Description {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


FileName Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : FileName Property
Gets the color book file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property FileName As String
'Usage

Dim instance As IImGearColorBook
Dim value As String

value = instance.FileName
string FileName {get;}
__property string* get_FileName();
property String^ FileName {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


KeyColorPage Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : KeyColorPage Property
Gets the key color on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property KeyColorPage As Integer
'Usage

Dim instance As IImGearColorBook
Dim value As Integer

value = instance.KeyColorPage
int KeyColorPage {get;}
__property int get_KeyColorPage();
property int KeyColorPage {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


NumberOfColors Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : NumberOfColors Property
Gets the number of colors in the color book.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property NumberOfColors As Integer
'Usage

Dim instance As IImGearColorBook
Dim value As Integer

value = instance.NumberOfColors
int NumberOfColors {get;}
__property int get_NumberOfColors();
property int NumberOfColors {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


Postfix Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : Postfix Property
Gets the color book postfix string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Postfix As String
'Usage

Dim instance As IImGearColorBook
Dim value As String

value = instance.Postfix
string Postfix {get;}
__property string* get_Postfix();
property String^ Postfix {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


Prefix Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : Prefix Property
Gets the color book prefix string value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Prefix As String
'Usage

Dim instance As IImGearColorBook
Dim value As String

value = instance.Prefix
string Prefix {get;}
__property string* get_Prefix();
property String^ Prefix {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


Title Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : Title Property
Gets the color book title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Title As String
'Usage

Dim instance As IImGearColorBook
Dim value As String

value = instance.Title
string Title {get;}
__property string* get_Title();
property String^ Title {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


VendorID Property (IImGearColorBook)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBook Interface : VendorID Property
Gets the color book vendor ID value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property VendorID As ImGearSpotColorVendorID
'Usage

Dim instance As IImGearColorBook
Dim value As ImGearSpotColorVendorID

value = instance.VendorID
ImGearSpotColorVendorID VendorID {get;}
__property ImGearSpotColorVendorID get_VendorID();
property ImGearSpotColorVendorID VendorID {
   ImGearSpotColorVendorID get();
}

Property Value

ImGearSpotColorVendorID enumeration value.
See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

IImGearColorBookColor Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBookColor Interface
Defines color book color interface.
Object Model
IImGearColorBookColor InterfaceImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearColorBookColor
'Usage

Dim instance As IImGearColorBookColor
public interface IImGearColorBookColor
public __gc __interface IImGearColorBookColor
public interface class IImGearColorBookColor
See Also

Reference

IImGearColorBookColor Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearColorBookColor Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBookColor Interface

The following tables list the members exposed by IImGearColorBookColor.

Public Properties
 | Name | Description
Property | ID | Gets the catalog code of the color.
Property | Name | Gets the full name of the color.
Top
Public Methods
 | Name | Description
Method | GetColorValueCopy | Returns a copy of the color value used for display.
Top
See Also

Reference

IImGearColorBookColor Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearColorBookColor Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBookColor Interface

For a list of all members of this type, see IImGearColorBookColor members.

Public Methods
 | Name | Description
Method | GetColorValueCopy | Returns a copy of the color value used for display.
Top
See Also

Reference

IImGearColorBookColor Interface
ImageGear.Core Namespace


GetColorValueCopy Method (IImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBookColor Interface : GetColorValueCopy Method
Returns a copy of the color value used for display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetColorValueCopy() As ImGearPixel
'Usage

Dim instance As IImGearColorBookColor
Dim value As ImGearPixel

value = instance.GetColorValueCopy()
ImGearPixel GetColorValueCopy()
ImGearPixel* GetColorValueCopy();
ImGearPixel^ GetColorValueCopy();

Return Value

ImGearPixel class object.
See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


%%PageItemTitle%% $$Properties$$

IImGearColorBookColor Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearColorBookColor Interface

For a list of all members of this type, see IImGearColorBookColor members.

Public Properties
 | Name | Description
Property | ID | Gets the catalog code of the color.
Property | Name | Gets the full name of the color.
Top
See Also

Reference

IImGearColorBookColor Interface
ImageGear.Core Namespace


ID Property (IImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBookColor Interface : ID Property
Gets the catalog code of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ID As Long
'Usage

Dim instance As IImGearColorBookColor
Dim value As Long

value = instance.ID
long ID {get;}
__property long get_ID();
property int64 ID {
   int64 get();
}

Property Value

Long value.
See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


Name Property (IImGearColorBookColor)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearColorBookColor Interface : Name Property
Gets the full name of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Name As String
'Usage

Dim instance As IImGearColorBookColor
Dim value As String

value = instance.Name
string Name {get;}
__property string* get_Name();
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


%%PageItemTitle%%

IImGearDICOMDisplaySettings Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDICOMDisplaySettings Interface
Specifies baseline features for DICOM display settings.
Object Model
IImGearDICOMDisplaySettings InterfaceImGearLUT ClassIImGearDICOMDisplaySettings InterfaceImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearDICOMDisplaySettings
'Usage

Dim instance As IImGearDICOMDisplaySettings
public interface IImGearDICOMDisplaySettings
public __gc __interface IImGearDICOMDisplaySettings
public interface class IImGearDICOMDisplaySettings
Remarks
This interface specifies baseline features for DICOM display settings. This interface is declared in the Core assembly, allowing you to attach DICOM Display settings to ImGearPage class and ImageGear.Display.ImGearPageDisplay class. However, DICOM Display Settings are only available when the ImageGear.Formats.DICOM component is attached. Cast IImGearDICOMDisplaySettings interface to ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class to access its features.
See Also

Reference

IImGearDICOMDisplaySettings Members
ImageGear.Core Namespace
ImGearDICOMDisplaySettings Class


%%PageItemTitle%% $$Members$$

IImGearDICOMDisplaySettings Interface Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDICOMDisplaySettings Interface

The following tables list the members exposed by IImGearDICOMDisplaySettings.

Public Properties
 | Name | Description
Property | DisplaySummaryLUT | Gets summary LUT based on all settings of the object.
Property | Inverted | Gets or sets a value indicating whether image contrast is inverted.
Top
Public Methods
 | Name | Description
Method | BuildSummaryLUT | Builds a standalone ImGearLUT class object based on the transforms that are present in the ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class object.
Method | Clone | Creates a deep copy of the object.
Method | UpdateDisplaySummaryLUT | Updates DisplaySummaryLUT property with current settings of the members.
Top
Public Events
 | Name | Description
Event | DisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Top
See Also

Reference

IImGearDICOMDisplaySettings Interface
ImageGear.Core Namespace
ImGearDICOMDisplaySettings Class


%%PageItemTitle%% $$Methods$$

IImGearDICOMDisplaySettings Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDICOMDisplaySettings Interface

For a list of all members of this type, see IImGearDICOMDisplaySettings members.

Public Methods
 | Name | Description
Method | BuildSummaryLUT | Builds a standalone ImGearLUT class object based on the transforms that are present in the ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class object.
Method | Clone | Creates a deep copy of the object.
Method | UpdateDisplaySummaryLUT | Updates DisplaySummaryLUT property with current settings of the members.
Top
See Also

Reference

IImGearDICOMDisplaySettings Interface
ImageGear.Core Namespace
ImGearDICOMDisplaySettings Class


BuildSummaryLUT Method (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : BuildSummaryLUT Method
DIB for which the DisplaySummaryLUT is to be built.
Builds a standalone ImGearLUT class object based on the transforms that are present in the ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function BuildSummaryLUT( _
   ByVal dib As ImGearDIB _
) As ImGearLUT
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim dib As ImGearDIB
Dim value As ImGearLUT

value = instance.BuildSummaryLUT(dib)
ImGearLUT BuildSummaryLUT(
   ImGearDIB dib
)
ImGearLUT* BuildSummaryLUT(
   ImGearDIB* dib
)
ImGearLUT^ BuildSummaryLUT(
   ImGearDIB^ dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

Return Value

ImGearLUT object.
See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members
ImGearDIB Class
ImGearLUT Class


Clone Method (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Clone() As IImGearDICOMDisplaySettings
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim value As IImGearDICOMDisplaySettings

value = instance.Clone()
IImGearDICOMDisplaySettings Clone()
IImGearDICOMDisplaySettings* Clone();
IImGearDICOMDisplaySettings^ Clone();

Return Value

A new instance of ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class object.
Remarks
This method creates a deep copy of an object that implements IImGearDICOMDisplaySettings interface.
See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members
ImGearDICOMDisplaySettings Class


UpdateDisplaySummaryLUT Method (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : UpdateDisplaySummaryLUT Method
DIB for which the DisplaySummaryLUT is to be built.
Updates DisplaySummaryLUT property with current settings of the members.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub UpdateDisplaySummaryLUT( _
   ByVal dib As ImGearDIB _
)
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim dib As ImGearDIB

instance.UpdateDisplaySummaryLUT(dib)
void UpdateDisplaySummaryLUT(
   ImGearDIB dib
)
void UpdateDisplaySummaryLUT(
   ImGearDIB* dib
)
void UpdateDisplaySummaryLUT(
   ImGearDIB^ dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.
Remarks
This method updates DisplaySummaryLUT property based on the transforms that are present in the object that implements IImGearDICOMDisplaySettings interface.
See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members
ImGearDIB Class
ImGearDICOMDisplaySettings Class


%%PageItemTitle%% $$Properties$$

IImGearDICOMDisplaySettings Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDICOMDisplaySettings Interface

For a list of all members of this type, see IImGearDICOMDisplaySettings members.

Public Properties
 | Name | Description
Property | DisplaySummaryLUT | Gets summary LUT based on all settings of the object.
Property | Inverted | Gets or sets a value indicating whether image contrast is inverted.
Top
See Also

Reference

IImGearDICOMDisplaySettings Interface
ImageGear.Core Namespace
ImGearDICOMDisplaySettings Class


DisplaySummaryLUT Property (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : DisplaySummaryLUT Property
Gets summary LUT based on all settings of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property DisplaySummaryLUT As ImGearLUT
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim value As ImGearLUT

value = instance.DisplaySummaryLUT
ImGearLUT DisplaySummaryLUT {get;}
__property ImGearLUT* get_DisplaySummaryLUT();
property ImGearLUT^ DisplaySummaryLUT {
   ImGearLUT^ get();
}

Property Value

ImGearLUT class object.
Remarks
This property concatenates all transforms that are present in a object that implements IImGearDICOMDisplaySettings interface, and builds a summary LUT. Display code does not check any other transforms of the ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow the display to use the changed settings.

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members
ImGearLUT Class


Inverted Property (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : Inverted Property
Gets or sets a value indicating whether image contrast is inverted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Inverted As Boolean
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim value As Boolean

instance.Inverted = value

value = instance.Inverted
bool Inverted {get; set;}
__property bool get_Inverted();
__property void set_Inverted(
   bool value
);
property bool Inverted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property tells whether the image shall be displayed with inverted contrast. ImageGear sets this property to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this property into account when it builds the summary LUT.

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%% $$Events$$

IImGearDICOMDisplaySettings Interface Events

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDICOMDisplaySettings Interface

For a list of all members of this type, see IImGearDICOMDisplaySettings members.

Public Events
 | Name | Description
Event | DisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Top
See Also

Reference

IImGearDICOMDisplaySettings Interface
ImageGear.Core Namespace
ImGearDICOMDisplaySettings Class


DisplaySummaryLUTUpdated Event (IImGearDICOMDisplaySettings)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDICOMDisplaySettings Interface : DisplaySummaryLUTUpdated Event
Occurs when the display summary LUT is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event DisplaySummaryLUTUpdated As EventHandler
'Usage

Dim instance As IImGearDICOMDisplaySettings
Dim handler As EventHandler

AddHandler instance.DisplaySummaryLUTUpdated, handler
event EventHandler DisplaySummaryLUTUpdated
__event EventHandler* DisplaySummaryLUTUpdated
event EventHandler^ DisplaySummaryLUTUpdated
See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

IImGearDoublePoint Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoublePoint Interface
Defines DoublePoint interface.
Object Model
IImGearDoublePoint Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearDoublePoint
'Usage

Dim instance As IImGearDoublePoint
public interface IImGearDoublePoint
public __gc __interface IImGearDoublePoint
public interface class IImGearDoublePoint
See Also

Reference

IImGearDoublePoint Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearDoublePoint Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoublePoint Interface

The following tables list the members exposed by IImGearDoublePoint.

Public Properties
 | Name | Description
Property | X | Gets or sets X coordinate of the point.
Property | Y | Gets or sets Y coordinate of the point.
Top
Public Methods
 | Name | Description
Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

IImGearDoublePoint Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearDoublePoint Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoublePoint Interface

For a list of all members of this type, see IImGearDoublePoint members.

Public Methods
 | Name | Description
Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

IImGearDoublePoint Interface
ImageGear.Core Namespace


Offset Method (IImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoublePoint Interface : Offset Method
X coordinate value.
Y coordinate value.
Shifts the points coordinates by the specified coordinateX and coordinateY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Offset( _
   ByVal offsetX As Double, _
   ByVal offsetY As Double _
)
'Usage

Dim instance As IImGearDoublePoint
Dim offsetX As Double
Dim offsetY As Double

instance.Offset(offsetX, offsetY)
void Offset(
   double offsetX,
   double offsetY
)
void Offset(
   double offsetX,
   double offsetY
)
void Offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
X coordinate value.
offsetY
Y coordinate value.
See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%% $$Properties$$

IImGearDoublePoint Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoublePoint Interface

For a list of all members of this type, see IImGearDoublePoint members.

Public Properties
 | Name | Description
Property | X | Gets or sets X coordinate of the point.
Property | Y | Gets or sets Y coordinate of the point.
Top
See Also

Reference

IImGearDoublePoint Interface
ImageGear.Core Namespace


X Property (IImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoublePoint Interface : X Property
Gets or sets X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property X As Double
'Usage

Dim instance As IImGearDoublePoint
Dim value As Double

instance.X = value

value = instance.X
double X {get; set;}
__property double get_X();
__property void set_X(
   double value
);
property double X {
   double get();
   void set (    double value);
}

Property Value

Any double value.
See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


Y Property (IImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoublePoint Interface : Y Property
Gets or sets Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Y As Double
'Usage

Dim instance As IImGearDoublePoint
Dim value As Double

instance.Y = value

value = instance.Y
double Y {get; set;}
__property double get_Y();
__property void set_Y(
   double value
);
property double Y {
   double get();
   void set (    double value);
}

Property Value

Any double value.
See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

IImGearDoubleRectangle Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoubleRectangle Interface
Defines DoubleRectangle interface.
Object Model
IImGearDoubleRectangle Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearDoubleRectangle
   Inherits IImGearShape
'Usage

Dim instance As IImGearDoubleRectangle
public interface IImGearDoubleRectangle : IImGearShape
public __gc __interface IImGearDoubleRectangle : public IImGearShape
public interface class IImGearDoubleRectangle : public IImGearShape
See Also

Reference

IImGearDoubleRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearDoubleRectangle Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoubleRectangle Interface

The following tables list the members exposed by IImGearDoubleRectangle.

Public Properties
 | Name | Description
Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Property | Height | Gets the height of the rectangle.
Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Property | Width | Gets the width of the rectangle.
Top
Public Methods
 | Name | Description
Method | CopyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Method | Intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | IsWellFormed | Checks if rectangle’s width is greater than or equal to zero and if its height is greater than or equal to zero.
Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
See Also

Reference

IImGearDoubleRectangle Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearDoubleRectangle Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoubleRectangle Interface

For a list of all members of this type, see IImGearDoubleRectangle members.

Public Methods
 | Name | Description
Method | CopyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Method | Intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | IsWellFormed | Checks if rectangle’s width is greater than or equal to zero and if its height is greater than or equal to zero.
Method | Offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Top
See Also

Reference

IImGearDoubleRectangle Interface
ImageGear.Core Namespace


CopyFrom Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : CopyFrom Method
Rectangle interface.
This method copies rectangle from IImGearDoubleRectangle interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub CopyFrom( _
   ByVal rect As IImGearDoubleRectangle _
)
'Usage

Dim instance As IImGearDoubleRectangle
Dim rect As IImGearDoubleRectangle

instance.CopyFrom(rect)
void CopyFrom(
   IImGearDoubleRectangle rect
)
void CopyFrom(
   IImGearDoubleRectangle* rect
)
void CopyFrom(
   IImGearDoubleRectangle^ rect
)

Parameters

rect
Rectangle interface.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Empty Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Empty Method
Sets all numeric properties of the rectangle to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Empty()
'Usage

Dim instance As IImGearDoubleRectangle

instance.Empty()
void Empty()
void Empty();
void Empty();
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Intersect Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Intersect Method
Double rectangle interface.
Checks whether or not the rectangle is intersected with the specified rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Intersect( _
   ByVal rect As IImGearDoubleRectangle _
) As Boolean
'Usage

Dim instance As IImGearDoubleRectangle
Dim rect As IImGearDoubleRectangle
Dim value As Boolean

value = instance.Intersect(rect)
bool Intersect(
   IImGearDoubleRectangle rect
)
bool Intersect(
   IImGearDoubleRectangle* rect
)
bool Intersect(
   IImGearDoubleRectangle^ rect
)

Parameters

rect
Double rectangle interface.

Return Value

Boolean value.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


IsEmpty Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsEmpty() As Boolean
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Boolean

value = instance.IsEmpty()
bool IsEmpty()
bool IsEmpty();
bool IsEmpty();

Return Value

Boolean value.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


IsWellFormed Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : IsWellFormed Method
Checks if rectangle’s width is greater than or equal to zero and if its height is greater than or equal to zero.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsWellFormed() As Boolean
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Boolean

value = instance.IsWellFormed()
bool IsWellFormed()
bool IsWellFormed();
bool IsWellFormed();

Return Value

Boolean value.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Offset Method (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Offset Method
The X shift value.
The Y shift value.
Shifts the rectangle points by the specified shiftX and shiftY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Offset( _
   ByVal offsetX As Double, _
   ByVal offsetY As Double _
)
'Usage

Dim instance As IImGearDoubleRectangle
Dim offsetX As Double
Dim offsetY As Double

instance.Offset(offsetX, offsetY)
void Offset(
   double offsetX,
   double offsetY
)
void Offset(
   double offsetX,
   double offsetY
)
void Offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%% $$Properties$$

IImGearDoubleRectangle Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearDoubleRectangle Interface

For a list of all members of this type, see IImGearDoubleRectangle members.

Public Properties
 | Name | Description
Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Property | Height | Gets the height of the rectangle.
Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Property | Width | Gets the width of the rectangle.
Top
See Also

Reference

IImGearDoubleRectangle Interface
ImageGear.Core Namespace


Bottom Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Bottom Property
Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Bottom As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

instance.Bottom = value

value = instance.Bottom
double Bottom {get; set;}
__property double get_Bottom();
__property void set_Bottom(
   double value
);
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Height Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Height Property
Gets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Height As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

value = instance.Height
double Height {get;}
__property double get_Height();
property double Height {
   double get();
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Left Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Left Property
Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Left As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

instance.Left = value

value = instance.Left
double Left {get; set;}
__property double get_Left();
__property void set_Left(
   double value
);
property double Left {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Right Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Right Property
Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Right As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

instance.Right = value

value = instance.Right
double Right {get; set;}
__property double get_Right();
__property void set_Right(
   double value
);
property double Right {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Top Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Top Property
Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Top As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

instance.Top = value

value = instance.Top
double Top {get; set;}
__property double get_Top();
__property void set_Top(
   double value
);
property double Top {
   double get();
   void set (    double value);
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


Width Property (IImGearDoubleRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearDoubleRectangle Interface : Width Property
Gets the width of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Width As Double
'Usage

Dim instance As IImGearDoubleRectangle
Dim value As Double

value = instance.Width
double Width {get;}
__property double get_Width();
property double Width {
   double get();
}

Property Value

Any double precision number.
See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

IImGearEllipse Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearEllipse Interface
Defines Ellipse interface.
Object Model
IImGearEllipse InterfaceImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearEllipse
   Inherits IImGearShape
'Usage

Dim instance As IImGearEllipse
public interface IImGearEllipse : IImGearShape
public __gc __interface IImGearEllipse : public IImGearShape
public interface class IImGearEllipse : public IImGearShape
See Also

Reference

IImGearEllipse Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearEllipse Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearEllipse Interface

The following tables list the members exposed by IImGearEllipse.

Public Properties
 | Name | Description
Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Property | RightBottom | Gets or sets the x-coordinate of the lower-right corner of the bounding rectangle.
Top
See Also

Reference

IImGearEllipse Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearEllipse Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearEllipse Interface

For a list of all members of this type, see IImGearEllipse members.

Public Properties
 | Name | Description
Property | LeftTop | Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Property | RightBottom | Gets or sets the x-coordinate of the lower-right corner of the bounding rectangle.
Top
See Also

Reference

IImGearEllipse Interface
ImageGear.Core Namespace


LeftTop Property (IImGearEllipse)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearEllipse Interface : LeftTop Property
Gets or sets the coordinate of the upper-left corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property LeftTop As ImGearPoint
'Usage

Dim instance As IImGearEllipse
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
ImGearPoint LeftTop {get; set;}
__property ImGearPoint get_LeftTop();
__property void set_LeftTop(
   ImGearPoint value
);
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint class object.
See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members
IImGearPoint Interface


RightBottom Property (IImGearEllipse)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearEllipse Interface : RightBottom Property
Gets or sets the x-coordinate of the lower-right corner of the bounding rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property RightBottom As ImGearPoint
'Usage

Dim instance As IImGearEllipse
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
ImGearPoint RightBottom {get; set;}
__property ImGearPoint get_RightBottom();
__property void set_RightBottom(
   ImGearPoint value
);
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint class object.
See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members
IImGearPoint Interface


%%PageItemTitle%%

IImGearMetadataDictRecord Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearMetadataDictRecord Interface
Specifies baseline features for a metadata dictionary record.
Object Model
IImGearMetadataDictRecord Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearMetadataDictRecord
'Usage

Dim instance As IImGearMetadataDictRecord
public interface IImGearMetadataDictRecord
public __gc __interface IImGearMetadataDictRecord
public interface class IImGearMetadataDictRecord
See Also

Reference

IImGearMetadataDictRecord Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearMetadataDictRecord Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearMetadataDictRecord Interface

The following tables list the members exposed by IImGearMetadataDictRecord.

Public Properties
 | Name | Description
Property | Name | Gets or sets the Tag name.
Property | Tag | Gets or sets the Tag ID value.
Top
See Also

Reference

IImGearMetadataDictRecord Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearMetadataDictRecord Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearMetadataDictRecord Interface

For a list of all members of this type, see IImGearMetadataDictRecord members.

Public Properties
 | Name | Description
Property | Name | Gets or sets the Tag name.
Property | Tag | Gets or sets the Tag ID value.
Top
See Also

Reference

IImGearMetadataDictRecord Interface
ImageGear.Core Namespace


Name Property (IImGearMetadataDictRecord)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearMetadataDictRecord Interface : Name Property
Gets or sets the Tag name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Name As String
'Usage

Dim instance As IImGearMetadataDictRecord
Dim value As String

instance.Name = value

value = instance.Name
string Name {get; set;}
__property string* get_Name();
__property void set_Name(
   string* value
);
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string.
Remarks
The default value is ““.
See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


Tag Property (IImGearMetadataDictRecord)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearMetadataDictRecord Interface : Tag Property
Gets or sets the Tag ID value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Tag As Integer
'Usage

Dim instance As IImGearMetadataDictRecord
Dim value As Integer

instance.Tag = value

value = instance.Tag
int Tag {get; set;}
__property int get_Tag();
__property void set_Tag(
   int value
);
property int Tag {
   int get();
   void set (    int value);
}

Property Value

Any integer number.
Remarks
The default value is 0.
See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


%%PageItemTitle%%

IImGearOrientation Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearOrientation Interface
Defines Orientation interface.
Object Model
IImGearOrientation Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearOrientation
'Usage

Dim instance As IImGearOrientation
public interface IImGearOrientation
public __gc __interface IImGearOrientation
public interface class IImGearOrientation
See Also

Reference

IImGearOrientation Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearOrientation Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearOrientation Interface

The following tables list the members exposed by IImGearOrientation.

Public Properties
 | Name | Description
Property | Value | Gets or sets orientation identifier.
Top
Public Methods
 | Name | Description
Method | Flip | Changes orientation to flip image.
Method | Rotate | Changes orientation to rotate image.
Method | SetToDefault | Resets orientation to default (top-left) state.
Top
See Also

Reference

IImGearOrientation Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearOrientation Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearOrientation Interface

For a list of all members of this type, see IImGearOrientation members.

Public Methods
 | Name | Description
Method | Flip | Changes orientation to flip image.
Method | Rotate | Changes orientation to rotate image.
Method | SetToDefault | Resets orientation to default (top-left) state.
Top
See Also

Reference

IImGearOrientation Interface
ImageGear.Core Namespace


Flip Method (IImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearOrientation Interface : Flip Method
Specifies how to flip orientation.
Changes orientation to flip image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Flip( _
   ByVal flipMode As ImGearFlipModes _
)
'Usage

Dim instance As IImGearOrientation
Dim flipMode As ImGearFlipModes

instance.Flip(flipMode)
void Flip(
   ImGearFlipModes flipMode
)
void Flip(
   ImGearFlipModes flipMode
)
void Flip(
   ImGearFlipModes flipMode
)

Parameters

flipMode
Specifies how to flip orientation.
See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members
ImGearFlipModes Enumeration


Rotate Method (IImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearOrientation Interface : Rotate Method
Specifies how to rotate orientation.
Changes orientation to rotate image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Rotate( _
   ByVal rotationValue As ImGearRotationValues _
)
'Usage

Dim instance As IImGearOrientation
Dim rotationValue As ImGearRotationValues

instance.Rotate(rotationValue)
void Rotate(
   ImGearRotationValues rotationValue
)
void Rotate(
   ImGearRotationValues rotationValue
)
void Rotate(
   ImGearRotationValues rotationValue
)

Parameters

rotationValue
Specifies how to rotate orientation.
See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members
ImGearRotationValues Enumeration


SetToDefault Method (IImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearOrientation Interface : SetToDefault Method
Resets orientation to default (top-left) state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetToDefault()
'Usage

Dim instance As IImGearOrientation

instance.SetToDefault()
void SetToDefault()
void SetToDefault();
void SetToDefault();
See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%% $$Properties$$

IImGearOrientation Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearOrientation Interface

For a list of all members of this type, see IImGearOrientation members.

Public Properties
 | Name | Description
Property | Value | Gets or sets orientation identifier.
Top
See Also

Reference

IImGearOrientation Interface
ImageGear.Core Namespace


Value Property (IImGearOrientation)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearOrientation Interface : Value Property
Gets or sets orientation identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Value As ImGearOrientationModes
'Usage

Dim instance As IImGearOrientation
Dim value As ImGearOrientationModes

instance.Value = value

value = instance.Value
ImGearOrientationModes Value {get; set;}
__property ImGearOrientationModes get_Value();
__property void set_Value(
   ImGearOrientationModes value
);
property ImGearOrientationModes Value {
   ImGearOrientationModes get();
   void set (    ImGearOrientationModes value);
}

Property Value

Any of ImGearOrientationModes enumerationvalues.
See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members
ImGearOrientationModes Enumeration


%%PageItemTitle%%

IImGearPoint Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearPoint Interface
Defines Point interface.
Object Model
IImGearPoint Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearPoint
'Usage

Dim instance As IImGearPoint
public interface IImGearPoint
public __gc __interface IImGearPoint
public interface class IImGearPoint
See Also

Reference

IImGearPoint Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearPoint Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearPoint Interface

The following tables list the members exposed by IImGearPoint.

Public Properties
 | Name | Description
Property | X | Gets or sets the x-coordinate of the point.
Property | Y | Gets or sets the y-coordinate of the point.
Top
Public Methods
 | Name | Description
Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

IImGearPoint Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearPoint Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearPoint Interface

For a list of all members of this type, see IImGearPoint members.

Public Methods
 | Name | Description
Method | Offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Top
See Also

Reference

IImGearPoint Interface
ImageGear.Core Namespace


Offset Method (IImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearPoint Interface : Offset Method
The x coordinate value.
The y coordinate value.
Shifts the points coordinates by the specified coordinateX and coordinateY values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Offset( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As IImGearPoint
Dim offsetX As Integer
Dim offsetY As Integer

instance.Offset(offsetX, offsetY)
void Offset(
   int offsetX,
   int offsetY
)
void Offset(
   int offsetX,
   int offsetY
)
void Offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The x coordinate value.
offsetY
The y coordinate value.
See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%% $$Properties$$

IImGearPoint Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearPoint Interface

For a list of all members of this type, see IImGearPoint members.

Public Properties
 | Name | Description
Property | X | Gets or sets the x-coordinate of the point.
Property | Y | Gets or sets the y-coordinate of the point.
Top
See Also

Reference

IImGearPoint Interface
ImageGear.Core Namespace


X Property (IImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearPoint Interface : X Property
Gets or sets the x-coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property X As Integer
'Usage

Dim instance As IImGearPoint
Dim value As Integer

instance.X = value

value = instance.X
int X {get; set;}
__property int get_X();
__property void set_X(
   int value
);
property int X {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearPoint Interface
IImGearPoint Members


Y Property (IImGearPoint)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearPoint Interface : Y Property
Gets or sets the y-coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Y As Integer
'Usage

Dim instance As IImGearPoint
Dim value As Integer

instance.Y = value

value = instance.Y
int Y {get; set;}
__property int get_Y();
__property void set_Y(
   int value
);
property int Y {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

IImGearRectangle Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRectangle Interface
Defines IImGearRectangle interface.
Object Model
IImGearRectangle Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearRectangle
   Inherits IImGearShape
'Usage

Dim instance As IImGearRectangle
public interface IImGearRectangle : IImGearShape
public __gc __interface IImGearRectangle : public IImGearShape
public interface class IImGearRectangle : public IImGearShape
See Also

Reference

IImGearRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearRectangle Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRectangle Interface

The following tables list the members exposed by IImGearRectangle.

Public Properties
 | Name | Description
Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Property | Height | Gets the height of the rectangle.
Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Property | Width | Gets the width of the rectangle.
Top
Public Methods
 | Name | Description
Method | Contains | Checks if the specified point’s coordinates are inside of the rectangle.
Method | CopyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Method | Intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | IsWellFormed | Tests whether the rectangle is valid.
Method | Join | Changes the rectangle’s points to contain the specified point.
Method | Offset | Shifts the rectangle points by the specified xShift and yShift values.
Top
See Also

Reference

IImGearRectangle Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearRectangle Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRectangle Interface

For a list of all members of this type, see IImGearRectangle members.

Public Methods
 | Name | Description
Method | Contains | Checks if the specified point’s coordinates are inside of the rectangle.
Method | CopyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Method | Intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Method | IsEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | IsWellFormed | Tests whether the rectangle is valid.
Method | Join | Changes the rectangle’s points to contain the specified point.
Method | Offset | Shifts the rectangle points by the specified xShift and yShift values.
Top
See Also

Reference

IImGearRectangle Interface
ImageGear.Core Namespace


Contains Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Contains Method
The point interface.
Checks if the specified point’s coordinates are inside of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Contains( _
   ByVal point As IImGearPoint _
) As Boolean
'Usage

Dim instance As IImGearRectangle
Dim point As IImGearPoint
Dim value As Boolean

value = instance.Contains(point)
bool Contains(
   IImGearPoint point
)
bool Contains(
   IImGearPoint* point
)
bool Contains(
   IImGearPoint^ point
)

Parameters

point
The point interface.

Return Value

Boolean value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members
IImGearPoint Interface


CopyFrom Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : CopyFrom Method
A rectangle interface.
Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub CopyFrom( _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim instance As IImGearRectangle
Dim rect As IImGearRectangle

instance.CopyFrom(rect)
void CopyFrom(
   IImGearRectangle rect
)
void CopyFrom(
   IImGearRectangle* rect
)
void CopyFrom(
   IImGearRectangle^ rect
)

Parameters

rect
A rectangle interface.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Empty Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Empty Method
Sets all numeric properties of the rectangle to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Empty()
'Usage

Dim instance As IImGearRectangle

instance.Empty()
void Empty()
void Empty();
void Empty();
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Intersect Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Intersect Method
A rectangle interface.
Replaces this rectangle with the intersection of itself and another rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Intersect( _
   ByVal rect As IImGearRectangle _
) As Boolean
'Usage

Dim instance As IImGearRectangle
Dim rect As IImGearRectangle
Dim value As Boolean

value = instance.Intersect(rect)
bool Intersect(
   IImGearRectangle rect
)
bool Intersect(
   IImGearRectangle* rect
)
bool Intersect(
   IImGearRectangle^ rect
)

Parameters

rect
A rectangle interface.

Return Value

Boolean value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


IsEmpty Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsEmpty() As Boolean
'Usage

Dim instance As IImGearRectangle
Dim value As Boolean

value = instance.IsEmpty()
bool IsEmpty()
bool IsEmpty();
bool IsEmpty();

Return Value

Boolean value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


IsWellFormed Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : IsWellFormed Method
Tests whether the rectangle is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsWellFormed() As Boolean
'Usage

Dim instance As IImGearRectangle
Dim value As Boolean

value = instance.IsWellFormed()
bool IsWellFormed()
bool IsWellFormed();
bool IsWellFormed();

Return Value

Boolean value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Join Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Join Method
The point interface.
Changes the rectangle’s points to contain the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Join( _
   ByVal point As IImGearPoint _
)
'Usage

Dim instance As IImGearRectangle
Dim point As IImGearPoint

instance.Join(point)
void Join(
   IImGearPoint point
)
void Join(
   IImGearPoint* point
)
void Join(
   IImGearPoint^ point
)

Parameters

point
The point interface.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members
IImGearPoint Interface


Offset Method (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Offset Method
The X shift value.
The Y shift value.
Shifts the rectangle points by the specified xShift and yShift values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Offset( _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer _
)
'Usage

Dim instance As IImGearRectangle
Dim offsetX As Integer
Dim offsetY As Integer

instance.Offset(offsetX, offsetY)
void Offset(
   int offsetX,
   int offsetY
)
void Offset(
   int offsetX,
   int offsetY
)
void Offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%% $$Properties$$

IImGearRectangle Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRectangle Interface

For a list of all members of this type, see IImGearRectangle members.

Public Properties
 | Name | Description
Property | Bottom | Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Property | Height | Gets the height of the rectangle.
Property | Left | Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Property | Right | Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Property | Top | Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Property | Width | Gets the width of the rectangle.
Top
See Also

Reference

IImGearRectangle Interface
ImageGear.Core Namespace


Bottom Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Bottom Property
Gets or sets the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Bottom As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

instance.Bottom = value

value = instance.Bottom
int Bottom {get; set;}
__property int get_Bottom();
__property void set_Bottom(
   int value
);
property int Bottom {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Height Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Height Property
Gets the height of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Height As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

value = instance.Height
int Height {get;}
__property int get_Height();
property int Height {
   int get();
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Left Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Left Property
Gets or sets the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Left As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

instance.Left = value

value = instance.Left
int Left {get; set;}
__property int get_Left();
__property void set_Left(
   int value
);
property int Left {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Right Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Right Property
Gets or sets the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Right As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

instance.Right = value

value = instance.Right
int Right {get; set;}
__property int get_Right();
__property void set_Right(
   int value
);
property int Right {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Top Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Top Property
Gets or sets the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Top As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

instance.Top = value

value = instance.Top
int Top {get; set;}
__property int get_Top();
__property void set_Top(
   int value
);
property int Top {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


Width Property (IImGearRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRectangle Interface : Width Property
Gets the width of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Width As Integer
'Usage

Dim instance As IImGearRectangle
Dim value As Integer

value = instance.Width
int Width {get;}
__property int get_Width();
property int Width {
   int get();
}

Property Value

Any integer value.
See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

IImGearResolution Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearResolution Interface
Represents image resolution interface.
Object Model
IImGearResolution Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearResolution
'Usage

Dim instance As IImGearResolution
public interface IImGearResolution
public __gc __interface IImGearResolution
public interface class IImGearResolution
See Also

Reference

IImGearResolution Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearResolution Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearResolution Interface

The following tables list the members exposed by IImGearResolution.

Public Properties
 | Name | Description
Property | Units | Gets or sets resolution units.
Property | XDenominator | Gets or sets denominator of the X component of the resolution.
Property | XNumerator | Gets or sets numerator of the X component of the resolution.
Property | YDenominator | Gets or sets denominator of the Y component of the resolution.
Property | YNumerator | Gets or sets numerator of the Y component of the resolution.
Top
Public Methods
 | Name | Description
Method | ConvertUnits | Converts resolution data into new units.
Top
See Also

Reference

IImGearResolution Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Methods$$

IImGearResolution Interface Methods

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearResolution Interface

For a list of all members of this type, see IImGearResolution members.

Public Methods
 | Name | Description
Method | ConvertUnits | Converts resolution data into new units.
Top
See Also

Reference

IImGearResolution Interface
ImageGear.Core Namespace


ConvertUnits Method (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : ConvertUnits Method
New resolution units.
Converts resolution data into new units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub ConvertUnits( _
   ByVal newUnits As ImGearResolutionUnits _
)
'Usage

Dim instance As IImGearResolution
Dim newUnits As ImGearResolutionUnits

instance.ConvertUnits(newUnits)
void ConvertUnits(
   ImGearResolutionUnits newUnits
)
void ConvertUnits(
   ImGearResolutionUnits newUnits
)
void ConvertUnits(
   ImGearResolutionUnits newUnits
)

Parameters

newUnits
New resolution units.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%% $$Properties$$

IImGearResolution Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearResolution Interface

For a list of all members of this type, see IImGearResolution members.

Public Properties
 | Name | Description
Property | Units | Gets or sets resolution units.
Property | XDenominator | Gets or sets denominator of the X component of the resolution.
Property | XNumerator | Gets or sets numerator of the X component of the resolution.
Property | YDenominator | Gets or sets denominator of the Y component of the resolution.
Property | YNumerator | Gets or sets numerator of the Y component of the resolution.
Top
See Also

Reference

IImGearResolution Interface
ImageGear.Core Namespace


Units Property (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : Units Property
Gets or sets resolution units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Units As ImGearResolutionUnits
'Usage

Dim instance As IImGearResolution
Dim value As ImGearResolutionUnits

instance.Units = value

value = instance.Units
ImGearResolutionUnits Units {get; set;}
__property ImGearResolutionUnits get_Units();
__property void set_Units(
   ImGearResolutionUnits value
);
property ImGearResolutionUnits Units {
   ImGearResolutionUnits get();
   void set (    ImGearResolutionUnits value);
}

Property Value

ImGearResolutionUnits enumeration.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


XDenominator Property (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : XDenominator Property
Gets or sets denominator of the X component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property XDenominator As Integer
'Usage

Dim instance As IImGearResolution
Dim value As Integer

instance.XDenominator = value

value = instance.XDenominator
int XDenominator {get; set;}
__property int get_XDenominator();
__property void set_XDenominator(
   int value
);
property int XDenominator {
   int get();
   void set (    int value);
}

Property Value

Int32 value.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


XNumerator Property (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : XNumerator Property
Gets or sets numerator of the X component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property XNumerator As Integer
'Usage

Dim instance As IImGearResolution
Dim value As Integer

instance.XNumerator = value

value = instance.XNumerator
int XNumerator {get; set;}
__property int get_XNumerator();
__property void set_XNumerator(
   int value
);
property int XNumerator {
   int get();
   void set (    int value);
}

Property Value

Int32 value.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


YDenominator Property (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : YDenominator Property
Gets or sets denominator of the Y component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property YDenominator As Integer
'Usage

Dim instance As IImGearResolution
Dim value As Integer

instance.YDenominator = value

value = instance.YDenominator
int YDenominator {get; set;}
__property int get_YDenominator();
__property void set_YDenominator(
   int value
);
property int YDenominator {
   int get();
   void set (    int value);
}

Property Value

Int32 value.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


YNumerator Property (IImGearResolution)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearResolution Interface : YNumerator Property
Gets or sets numerator of the Y component of the resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property YNumerator As Integer
'Usage

Dim instance As IImGearResolution
Dim value As Integer

instance.YNumerator = value

value = instance.YNumerator
int YNumerator {get; set;}
__property int get_YNumerator();
__property void set_YNumerator(
   int value
);
property int YNumerator {
   int get();
   void set (    int value);
}

Property Value

Int32 value.
See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

IImGearRGBQuad Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRGBQuad Interface
Defines palette entry interface.
Object Model
IImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearRGBQuad
'Usage

Dim instance As IImGearRGBQuad
public interface IImGearRGBQuad
public __gc __interface IImGearRGBQuad
public interface class IImGearRGBQuad
See Also

Reference

IImGearRGBQuad Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearRGBQuad Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRGBQuad Interface

The following tables list the members exposed by IImGearRGBQuad.

Public Properties
 | Name | Description
Property | Blue | Gets or sets blue value.
Property | Green | Gets or sets green value.
Property | Red | Gets or sets red value.
Property | Reserved | Gets or sets reserved value.
Top
See Also

Reference

IImGearRGBQuad Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearRGBQuad Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRGBQuad Interface

For a list of all members of this type, see IImGearRGBQuad members.

Public Properties
 | Name | Description
Property | Blue | Gets or sets blue value.
Property | Green | Gets or sets green value.
Property | Red | Gets or sets red value.
Property | Reserved | Gets or sets reserved value.
Top
See Also

Reference

IImGearRGBQuad Interface
ImageGear.Core Namespace


Blue Property (IImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRGBQuad Interface : Blue Property
Gets or sets blue value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Blue As Byte
'Usage

Dim instance As IImGearRGBQuad
Dim value As Byte

instance.Blue = value

value = instance.Blue
byte Blue {get; set;}
__property byte get_Blue();
__property void set_Blue(
   byte value
);
property byte Blue {
   byte get();
   void set (    byte value);
}

Property Value

Blue color value.
See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


Green Property (IImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRGBQuad Interface : Green Property
Gets or sets green value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Green As Byte
'Usage

Dim instance As IImGearRGBQuad
Dim value As Byte

instance.Green = value

value = instance.Green
byte Green {get; set;}
__property byte get_Green();
__property void set_Green(
   byte value
);
property byte Green {
   byte get();
   void set (    byte value);
}

Property Value

Green color value.
See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


Red Property (IImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRGBQuad Interface : Red Property
Gets or sets red value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Red As Byte
'Usage

Dim instance As IImGearRGBQuad
Dim value As Byte

instance.Red = value

value = instance.Red
byte Red {get; set;}
__property byte get_Red();
__property void set_Red(
   byte value
);
property byte Red {
   byte get();
   void set (    byte value);
}

Property Value

Red color value.
See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


Reserved Property (IImGearRGBQuad)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRGBQuad Interface : Reserved Property
Gets or sets reserved value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Reserved As Byte
'Usage

Dim instance As IImGearRGBQuad
Dim value As Byte

instance.Reserved = value

value = instance.Reserved
byte Reserved {get; set;}
__property byte get_Reserved();
__property void set_Reserved(
   byte value
);
property byte Reserved {
   byte get();
   void set (    byte value);
}

Property Value

Reserved color value.
See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

IImGearRoundedRectangle Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRoundedRectangle Interface
Represents a rounded rectangle.
Object Model
IImGearRoundedRectangle InterfaceImGearPoint StructureImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearRoundedRectangle
   Inherits IImGearShape
'Usage

Dim instance As IImGearRoundedRectangle
public interface IImGearRoundedRectangle : IImGearShape
public __gc __interface IImGearRoundedRectangle : public IImGearShape
public interface class IImGearRoundedRectangle : public IImGearShape
See Also

Reference

IImGearRoundedRectangle Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearRoundedRectangle Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRoundedRectangle Interface

The following tables list the members exposed by IImGearRoundedRectangle.

Public Properties
 | Name | Description
Property | LeftTop | Gets or sets coordinates of the upper-left corner of the rectangle.
Property | Radius | Gets or sets the radius for the rounded edges.
Property | RightBottom | Gets or sets coordinates of the right-bottom corner of the rectangle.
Top
See Also

Reference

IImGearRoundedRectangle Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearRoundedRectangle Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearRoundedRectangle Interface

For a list of all members of this type, see IImGearRoundedRectangle members.

Public Properties
 | Name | Description
Property | LeftTop | Gets or sets coordinates of the upper-left corner of the rectangle.
Property | Radius | Gets or sets the radius for the rounded edges.
Property | RightBottom | Gets or sets coordinates of the right-bottom corner of the rectangle.
Top
See Also

Reference

IImGearRoundedRectangle Interface
ImageGear.Core Namespace


LeftTop Property (IImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRoundedRectangle Interface : LeftTop Property
Gets or sets coordinates of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property LeftTop As ImGearPoint
'Usage

Dim instance As IImGearRoundedRectangle
Dim value As ImGearPoint

instance.LeftTop = value

value = instance.LeftTop
ImGearPoint LeftTop {get; set;}
__property ImGearPoint get_LeftTop();
__property void set_LeftTop(
   ImGearPoint value
);
property ImGearPoint LeftTop {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


Radius Property (IImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRoundedRectangle Interface : Radius Property
Gets or sets the radius for the rounded edges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Radius As Integer
'Usage

Dim instance As IImGearRoundedRectangle
Dim value As Integer

instance.Radius = value

value = instance.Radius
int Radius {get; set;}
__property int get_Radius();
__property void set_Radius(
   int value
);
property int Radius {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


RightBottom Property (IImGearRoundedRectangle)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearRoundedRectangle Interface : RightBottom Property
Gets or sets coordinates of the right-bottom corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property RightBottom As ImGearPoint
'Usage

Dim instance As IImGearRoundedRectangle
Dim value As ImGearPoint

instance.RightBottom = value

value = instance.RightBottom
ImGearPoint RightBottom {get; set;}
__property ImGearPoint get_RightBottom();
__property void set_RightBottom(
   ImGearPoint value
);
property ImGearPoint RightBottom {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint structure.
See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

IImGearShape Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearShape Interface
Defines Shape interface.
Object Model
IImGearShape Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearShape
'Usage

Dim instance As IImGearShape
public interface IImGearShape
public __gc __interface IImGearShape
public interface class IImGearShape
See Also

Reference

IImGearShape Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearShape Interface Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearShape Interface

The following tables list the members exposed by IImGearShape.

See Also

Reference

IImGearShape Interface
ImageGear.Core Namespace


%%PageItemTitle%%

IImGearSize Interface
Members

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearSize Interface
Defines Size interface.
Object Model
IImGearSize Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearSize
'Usage

Dim instance As IImGearSize
public interface IImGearSize
public __gc __interface IImGearSize
public interface class IImGearSize
See Also

Reference

IImGearSize Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

IImGearSize Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearSize Interface

The following tables list the members exposed by IImGearSize.

Public Properties
 | Name | Description
Property | cX | Gets or sets the X size.
Property | cY | Gets or sets the Y size.
Top
See Also

Reference

IImGearSize Interface
ImageGear.Core Namespace


%%PageItemTitle%% $$Properties$$

IImGearSize Interface Properties

ImageGear22.Core Assembly > ImageGear.Core Namespace : IImGearSize Interface

For a list of all members of this type, see IImGearSize members.

Public Properties
 | Name | Description
Property | cX | Gets or sets the X size.
Property | cY | Gets or sets the Y size.
Top
See Also

Reference

IImGearSize Interface
ImageGear.Core Namespace


cX Property (IImGearSize)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearSize Interface : cX Property
Gets or sets the X size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property cX As Integer
'Usage

Dim instance As IImGearSize
Dim value As Integer

instance.cX = value

value = instance.cX
int cX {get; set;}
__property int get_cX();
__property void set_cX(
   int value
);
property int cX {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearSize Interface
IImGearSize Members


cY Property (IImGearSize)

ImageGear22.Core Assembly > ImageGear.Core Namespace > IImGearSize Interface : cY Property
Gets or sets the Y size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property cY As Integer
'Usage

Dim instance As IImGearSize
Dim value As Integer

instance.cY = value

value = instance.cY
int cY {get; set;}
__property int get_cY();
__property void set_cY(
   int value
);
property int cY {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

ImGearAddWarning Delegate

ImageGear22.Core Assembly > ImageGear.Core Namespace : ImGearAddWarning Delegate
ImGearWarning class object.
Specifies the warning processing routine to be called when the warning is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearAddWarning( _
   ByVal warning As ImGearWarning _
)
'Usage

Dim instance As New ImGearAddWarning(AddressOf HandlerMethod)
public delegate void ImGearAddWarning(
   ImGearWarning warning
)
public: __gc __delegate void ImGearAddWarning(
   ImGearWarning* warning
)
public delegate void ImGearAddWarning(
   ImGearWarning^ warning
)

Parameters

warning
ImGearWarning class object.
See Also

Reference

ImGearAddWarning Members
ImageGear.Core Namespace
ImGearWarning Class
AddWarning Property


ImageGear.Display Namespace (ImageGear22.Core)
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Display Namespace
The ImageGear.Display namespace provides the ImageGear for .NET API for displaying and printing.
Classes
 | Class | Description
Class | ImGearAnnotationPage | Abstract class used by the ImGearPageDisplay.ARTPage property of ImGearPageDisplay class.
Class | ImGearPageDisplay | Main class, implementing the entire IG .NET display API.
Class | ImGearPageDisplayConverter | Converts between ImGearPageDisplay class and other types, such as string.
Class | ImGearScrollChangedEventArgs | Provides data for the page scrolled event.
Class | ImGearScrollComponentInfoConverter | Converts between ImGearScrollComponentInfo class and other types, such as string.
Class | ImGearZoomInfoConverter | Converts between ImGearZoomInfo class and other types, such as string.
Interfaces
 | Interface | Description
Interface | IImGearAlignment | Provides access to display alignment modes.
Interface | IImGearAntiAlias | Provides access to bitonal anti-aliasing attributes.
Interface | IImGearAspectRatio | Provides access to display aspect ratio attributes.
Interface | IImGearBackground | Provides access to display background attributes.
Interface | IImGearColorAntiAlias | Provides access to color anti-aliasing attributes.
Interface | IImGearContrastSettings | Contrast settings interface used by ImGearPageDisplay.UpdateLUT method.
Interface | IImGearDisplayObject | Base interface for display API objects. Implemented in several display code structures.
Interface | IImGearLayout | Provides access to display layout attributes.
Interface | IImGearPageDisplay | Defines interface for page display.
Interface | IImGearResample | Provides access to re-sampling attributes.
Interface | IImGearScrollableView | Obtains all information required by IG display code and modifies some attributes of underlying window (scrollbars state).
Structures
 | Structure | Description
Structure | ImGearContrastSettings | Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.
Structure | ImGearScrollComponentInfo | Implements state of one scrollbar and uses pass scrolling information to and from ImageGear display code.
Structure | ImGearScrollInfo | Represents scrolling state of the image.
Structure | ImGearZoomComponentInfo | Stores information about image zoom in one dimension (vertical or horizontal).
Structure | ImGearZoomInfo | Represents complete image zoom information.
Delegates
 | Delegate | Description
Delegate | ImGearScrollChangedEventHandler | Used for declaring ImGearPageDisplay.ScrollChanged events.
Enumerations
 | Enumeration | Description
Enumeration | ImGearAliasModes | Identifies different types of image aliasing.
Enumeration | ImGearAlignmentHModes | Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
Enumeration | ImGearAlignmentVModes | Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
Enumeration | ImGearBackgroundModes | Specifies ImageGear background modes.
Enumeration | ImGearColorAliasModes | Specifies color anti-aliasing mode.
Enumeration | ImGearCoordConvModes | Identifies coordinate translation methods.
Enumeration | ImGearFitModes | Identifies how an image fits to the device rectangle.
Enumeration | ImGearResampleModes | Specifies re-sampling mode.
Enumeration | ImGearScrollBarModes | Identifies scroll bar visibility methods.
Enumeration | ImGearScrollBarType | Identifies scrollbar types.
Enumeration | ImGearScrollChangeType | This enumeration specifies the type of scrollbar change.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Display Namespace (ImageGear22.Core) Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Display Namespace
Inheritance Hierarchy
System.Object
ImageGear.Display.ImGearAnnotationPage
ImageGear.Display.ImGearPageDisplay
System.ComponentModel.TypeConverter
ImageGear.Display.ImGearPageDisplayConverter
ImageGear.Display.ImGearScrollComponentInfoConverter
ImageGear.Display.ImGearZoomInfoConverter
System.EventArgs
ImageGear.Display.ImGearScrollChangedEventArgs
System.ValueType
ImageGear.Display.ImGearContrastSettings
ImageGear.Display.ImGearScrollComponentInfo
ImageGear.Display.ImGearScrollInfo
ImageGear.Display.ImGearZoomComponentInfo
ImageGear.Display.ImGearZoomInfo
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearAnnotationPage Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAnnotationPage Class
Abstract class used by the ImGearPageDisplay.ARTPage property of ImGearPageDisplay class.
Object Model
ImGearAnnotationPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearAnnotationPage
'Usage

Dim instance As ImGearAnnotationPage
public abstract class ImGearAnnotationPage
public __gc abstract class ImGearAnnotationPage
public ref class ImGearAnnotationPage abstract
Remarks

This class does not expose any public members.

Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearAnnotationPage
ImageGear.ART.ImGearARTPage

See Also

Reference

ImGearAnnotationPage Members
ImageGear.Display Namespace
ImGearPageDisplay Class


%%PageItemTitle%% $$Members$$

ImGearAnnotationPage Class Members
Methods Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAnnotationPage Class

The following tables list the members exposed by ImGearAnnotationPage.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearAnnotationPage Class
ImageGear.Display Namespace
ImGearPageDisplay Class


%%PageItemTitle%% $$Methods$$

ImGearAnnotationPage Class Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAnnotationPage Class

For a list of all members of this type, see ImGearAnnotationPage members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearAnnotationPage Class
ImageGear.Display Namespace
ImGearPageDisplay Class


OnPropertyChanged Method (ImGearAnnotationPage)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearAnnotationPage Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearAnnotationPage
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%% $$Events$$

ImGearAnnotationPage Class Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAnnotationPage Class

For a list of all members of this type, see ImGearAnnotationPage members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearAnnotationPage Class
ImageGear.Display Namespace
ImGearPageDisplay Class


PropertyChanged Event (ImGearAnnotationPage)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearAnnotationPage Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearAnnotationPage
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

ImGearPageDisplay Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplay Class
Main class, implementing the entire IG .NET display API.
Object Model
ImGearPageDisplay ClassIImGearAntiAlias InterfaceImGearAnnotationPage ClassIImGearBackground InterfaceImGearDisplayChannels ClassImGearDisplayChannel ClassImGearPageDisplay ClassIImGearColorAntiAlias InterfaceIImGearDICOMDisplaySettings InterfaceImGearScrollInfo StructureImGearZoomInfo StructureIImGearLayout InterfaceImGearMultichannelLUT ClassIImGearOrientation InterfaceImGearPage ClassIImGearResample InterfaceImGearScrollInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TypeConverterAttribute("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")>
Public Class ImGearPageDisplay
   Implements IImGearPageDisplay
'Usage

Dim instance As ImGearPageDisplay
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public class ImGearPageDisplay : IImGearPageDisplay
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public __gc class ImGearPageDisplay : public IImGearPageDisplay
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public ref class ImGearPageDisplay : public IImGearPageDisplay
Remarks
See Displaying Images section for more information.
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearPageDisplay

See Also

Reference

ImGearPageDisplay Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearPageDisplay Class Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplay Class

The following tables list the members exposed by ImGearPageDisplay.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageDisplay Constructor | Overloaded. Initializes a new instance of the ImGearPageDisplay class.
Top
Public Properties
 | Name | Description
Public Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Public Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Public Property | Background | Gets background drawing attributes.
Public Property | Brightness | Gets or sets the brightness level of the displayed image.
Public Property | Channels | Gets the list of extra channels and their display options.
Public Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Public Property | Contrast | Gets or sets the contrast level of the displayed image.
Public Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Public Property | Gamma | Gets or sets the gamma level of the displayed image.
Public Property | Layout | Gets image display layout settings.
Public Property | LUT | Gets or sets a display lookup table.
Public Property | Orientation | Gets image orientation attributes.
Public Property | Page | Gets or sets ImGearPage object associated with this display page.
Public Property | Resampling | Gets re-sampling attributes.
Top
Public Methods
 | Name | Description
Public Method | Clone | Copies ImGearPageDisplay class object.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Public Method | Draw | Draws image on .NET Graphics.
Public Method | DrawEx | Draws image on .NET Graphics.
Public Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Public Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Public Method | HandleScroll | Handles scrolling events.
Public Method | HandleUpdate | Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Public Method | InternalUseOnly | Gets the ImGearPageDisplay.
Public Method | Print | Draws the image on .NET Graphics for printing. Call to Print(hdc) is equal to call DrawEx(null, hdc, true).
Public Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Public Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Public Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Public Method | UpdateZoomFrom | Updates image zoom attributes.
Public Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
Protected Methods
 | Name | Description
Protected Method | OnLUTUpdated | Occurs when the lookup table is updated.
Protected Method | OnPageScrolled | Occurs when a page is scrolled.
Protected Method | OnPageZoomed | Occurs when a page is zoomed.
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Protected Method | OnScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
Public Events
 | Name | Description
Public Event | LUTUpdated | Occurs when the lookup table is updated.
Public Event | PageScrolled | Occurs when a page is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

ImGearPageDisplay Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearPageDisplay Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ImGearPageDisplay Constructor
Initializes a new instance of the ImGearPageDisplay class.
Overload List
Overload | Description
ImGearPageDisplay Constructor() | Initializes a new instance of the ImGearPageDisplay class.
ImGearPageDisplay Constructor(ImGearPage) | Initializes a new instance of the ImGearPageDisplay class.
ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage) | Initializes a new instance of the ImGearPageDisplay class using the specified ImageGear.Core.ImGearPage and ImGearAnnotationPage objects.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

ImGearPageDisplay Constructor()

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor()
Initializes a new instance of the ImGearPageDisplay class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageDisplay()
public ImGearPageDisplay()
public: ImGearPageDisplay();
public:
ImGearPageDisplay();

Return Value

A new instance of ImGearPageDisplay class.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%%

ImGearPageDisplay Constructor(ImGearPage)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor(ImGearPage)
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.
Initializes a new instance of the ImGearPageDisplay class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

Dim instance As New ImGearPageDisplay(page)
public ImGearPageDisplay(
   ImGearPage page
)
public: ImGearPageDisplay(
   ImGearPage* page
)
public:
ImGearPageDisplay(
   ImGearPage^ page
)

Parameters

page
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List
ImGearPage Class


%%PageItemTitle%%

ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)
Specifies the ImageGear.Core.ImGearPage object to associate with new ImGearPageDisplay instance.
ImageGear.ART.ImGearARTPage object to associate with ImageGear.Core.ImGearPage for display.
Initializes a new instance of the ImGearPageDisplay class using the specified ImageGear.Core.ImGearPage and ImGearAnnotationPage objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage, _
   ByVal artPage As ImGearAnnotationPage _
)
'Usage

Dim page As ImGearPage
Dim artPage As ImGearAnnotationPage

Dim instance As New ImGearPageDisplay(page, artPage)
public ImGearPageDisplay(
   ImGearPage page,
   ImGearAnnotationPage artPage
)
public: ImGearPageDisplay(
   ImGearPage* page,
   ImGearAnnotationPage* artPage
)
public:
ImGearPageDisplay(
   ImGearPage^ page,
   ImGearAnnotationPage^ artPage
)

Parameters

page
Specifies the ImageGear.Core.ImGearPage object to associate with new ImGearPageDisplay instance.
artPage
ImageGear.ART.ImGearARTPage object to associate with ImageGear.Core.ImGearPage for display.

Return Value

A new instance of ImGearPageDisplay class.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List
ImGearPage Class
ImGearAnnotationPage Class


%%PageItemTitle%% $$Methods$$

ImGearPageDisplay Class Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplay Class

For a list of all members of this type, see ImGearPageDisplay members.

Public Methods
 | Name | Description
Public Method | Clone | Copies ImGearPageDisplay class object.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Public Method | Draw | Draws image on .NET Graphics.
Public Method | DrawEx | Draws image on .NET Graphics.
Public Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Public Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Public Method | HandleScroll | Handles scrolling events.
Public Method | HandleUpdate | Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Public Method | InternalUseOnly | Gets the ImGearPageDisplay.
Public Method | Print | Draws the image on .NET Graphics for printing. Call to Print(hdc) is equal to call DrawEx(null, hdc, true).
Public Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Public Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Public Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Public Method | UpdateZoomFrom | Updates image zoom attributes.
Public Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
Protected Methods
 | Name | Description
Protected Method | OnLUTUpdated | Occurs when the lookup table is updated.
Protected Method | OnPageScrolled | Occurs when a page is scrolled.
Protected Method | OnPageZoomed | Occurs when a page is zoomed.
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Protected Method | OnScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

ImGearPageDisplay Class
ImageGear.Display Namespace


Clone Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Clone Method
Copies ImGearPageDisplay class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearPageDisplay
'Usage

Dim instance As ImGearPageDisplay
Dim value As ImGearPageDisplay

value = instance.Clone()
public ImGearPageDisplay Clone()
public: ImGearPageDisplay* Clone();
public:
ImGearPageDisplay^ Clone();

Return Value

New instance of ImGearPageDisplay class object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


ConvertCoordinates Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ConvertCoordinates Method
Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Overload List
Overload | Description
ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method
IImGearScrollableView interface; represents .NET form to draw the image on.
Graphics object used to draw the image.
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
Array with point coordinates.
Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal graphics As Graphics, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim graphics As Graphics
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, graphics, mode, array)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   Graphics graphics,
   ImGearCoordConvModes mode,
   Array array
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   Graphics* graphics,
   ImGearCoordConvModes mode,
   Array* array
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   Graphics^ graphics,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image on.
graphics
Graphics object used to draw the image.
mode
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
array
Array with point coordinates.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method
Represents the scrollable view object on which the image is drawn.
Specifies translation direction.
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, mode, array)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   ImGearCoordConvModes mode,
   Array array
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   ImGearCoordConvModes mode,
   Array* array
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Remarks

In GDI+ environment, device coordinates are expressed in pixels.

In .Net WPF environment, device coordinates are expressed in WPF device independent units (1/96th inch per unit).

If you display or print an image without an IImGearScrollableView object, use one of these overloads:

  • In GDI+: ConvertCoordinates(IImGearScrollableView, System.Drawing.Graphics, ImGearCoordConvModes, System.Array)
  • In WPF: ConvertCoordinates(System.Windows.Controls.Canvas, ImGearCoordConvModes, System.Array).
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


Draw Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Draw Method
IImGearScrollableView interface; represents .NET form to draw the image on.
Graphics object to draw image on.
Draws image on .NET Graphics.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Draw( _
   ByVal pageView As IImGearScrollableView, _
   ByVal graphics As Graphics _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim graphics As Graphics

instance.Draw(pageView, graphics)
public void Draw(
   IImGearScrollableView pageView,
   Graphics graphics
)
public: void Draw(
   IImGearScrollableView* pageView,
   Graphics* graphics
)
public:
void Draw(
   IImGearScrollableView^ pageView,
   Graphics^ graphics
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image on.
graphics
Graphics object to draw image on.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearScrollableView Interface


DrawEx Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : DrawEx Method
Draws image on .NET Graphics.
Overload List
Overload | Description
DrawEx | Draws image on .NET Graphics.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


DrawEx(IImGearScrollableView,Graphics,Boolean) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : DrawEx(IImGearScrollableView,Graphics,Boolean) Method
IImGearScrollableView interface, represents .NET Form to draw the image in.
Graphics object to draw the image on.
Boolean flag indicating whether the drawing is performed for printer Graphics or not.
Draws image on .NET Graphics.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DrawEx( _
   ByVal pageView As IImGearScrollableView, _
   ByVal graphics As Graphics, _
   ByVal doPrint As Boolean _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim graphics As Graphics
Dim doPrint As Boolean

instance.DrawEx(pageView, graphics, doPrint)
public void DrawEx(
   IImGearScrollableView pageView,
   Graphics graphics,
   bool doPrint
)
public: void DrawEx(
   IImGearScrollableView* pageView,
   Graphics* graphics,
   bool doPrint
)
public:
void DrawEx(
   IImGearScrollableView^ pageView,
   Graphics^ graphics,
   bool doPrint
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw the image in.
graphics
Graphics object to draw the image on.
doPrint
Boolean flag indicating whether the drawing is performed for printer Graphics or not.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearScrollableView Interface


GetScrollInfo Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : GetScrollInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns new instance of image scrolling attributes object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetScrollInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearScrollInfo
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearScrollInfo

value = instance.GetScrollInfo(pageView)
public ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView pageView
)
public: ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView* pageView
)
public:
ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearScrollInfo structure object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


GetZoomInfo Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : GetZoomInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns a new instance of an object containing current zoom settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetZoomInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearZoomInfo
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearZoomInfo

value = instance.GetZoomInfo(pageView)
public ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView pageView
)
public: ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView* pageView
)
public:
ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearZoomInfo structure object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearZoomInfo Structure
IImGearScrollableView Interface


HandleScroll Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : HandleScroll Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
Scroll value. Specifies new scrolling position.
Handles scrolling events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HandleScroll( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollValue As Integer _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim scrollValue As Integer

instance.HandleScroll(pageView, scrollBarType, scrollValue)
public void HandleScroll(
   IImGearScrollableView pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
public: void HandleScroll(
   IImGearScrollableView* pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
public:
void HandleScroll(
   IImGearScrollableView^ pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position.
Remarks
Use this method only to handle scrolling events. To scroll image to particular position, use ScrollTo method instead.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearScrollableView Interface
ImGearScrollBarType Enumeration


HandleUpdate Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : HandleUpdate Method
IImGearScrollableView page view control to draw image in.
Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HandleUpdate( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView

instance.HandleUpdate(pageView)
public void HandleUpdate(
   IImGearScrollableView pageView
)
public: void HandleUpdate(
   IImGearScrollableView* pageView
)
public:
void HandleUpdate(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView page view control to draw image in.
Remarks
The Update() method of page view control can make updates to the page display asynchronously. It means, that some parameters of the page display may be incorrect immediately after calling the Update() method of page view. As a result some methods, such as GetZoomInfo may return incorrect results.

This method synchronizes the internal data structures. Any custom page viewer, which implements IImGearScrollableView interface, should call this handler from Update() method to allow the page display to update some internal parameters synchronously.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


InternalUseOnly Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : InternalUseOnly Method
Gets the ImGearPageDisplay.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function InternalUseOnly() As Object
'Usage

Dim instance As ImGearPageDisplay
Dim value As Object

value = instance.InternalUseOnly()
public object InternalUseOnly()
public: Object* InternalUseOnly();
public:
Object^ InternalUseOnly();

Return Value

ImGearPageDisplay object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


OnLUTUpdated Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : OnLUTUpdated Method
Event arguments.
Occurs when the lookup table is updated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnLUTUpdated( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As ImGearPageDisplay
Dim e As EventArgs

instance.OnLUTUpdated(e)
protected void OnLUTUpdated(
   EventArgs e
)
protected: void OnLUTUpdated(
   EventArgs* e
)
protected:
void OnLUTUpdated(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


OnPageScrolled Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : OnPageScrolled Method
Event arguments.
Occurs when a page is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPageScrolled( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As ImGearPageDisplay
Dim e As EventArgs

instance.OnPageScrolled(e)
protected void OnPageScrolled(
   EventArgs e
)
protected: void OnPageScrolled(
   EventArgs* e
)
protected:
void OnPageScrolled(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


OnPageZoomed Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : OnPageZoomed Method
Event arguments.
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPageZoomed( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As ImGearPageDisplay
Dim e As EventArgs

instance.OnPageZoomed(e)
protected void OnPageZoomed(
   EventArgs e
)
protected: void OnPageZoomed(
   EventArgs* e
)
protected:
void OnPageZoomed(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


OnPropertyChanged Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearPageDisplay
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


OnScrollChanged Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : OnScrollChanged Method
Event arguments.
Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnScrollChanged( _
   ByVal e As ImGearScrollChangedEventArgs _
)
'Usage

Dim instance As ImGearPageDisplay
Dim e As ImGearScrollChangedEventArgs

instance.OnScrollChanged(e)
protected void OnScrollChanged(
   ImGearScrollChangedEventArgs e
)
protected: void OnScrollChanged(
   ImGearScrollChangedEventArgs* e
)
protected:
void OnScrollChanged(
   ImGearScrollChangedEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


Print Method (ImGearPageDisplay)
Example

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Print Method
Graphics object to draw the image on.
Draws the image on .NET Graphics for printing. Call to Print(hdc) is equal to call DrawEx(null, hdc, true).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Print( _
   ByVal graphics As Graphics _
)
'Usage

Dim instance As ImGearPageDisplay
Dim graphics As Graphics

instance.Print(graphics)
public void Print(
   Graphics graphics
)
public: void Print(
   Graphics* graphics
)
public:
void Print(
   Graphics^ graphics
)

Parameters

graphics
Graphics object to draw the image on.
Example
  • C#
private void PrintPage(object sender, EventArgs e)
{
    // Load an image
    ImGearPage igPage;
    using (FileStream localFile = new FileStream("test1.tif", FileMode.Open))
    {
        igPage = ImGearFileFormats.LoadPage(localFile, 0);
    }
    // Create a new ImGearPageDisplay based upon an ImGearPage.
    ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
    // Set the current ImGearPageView to use this new display.
    imGearPageView.Display = igPageDisplay;
    // Initialize a PrintDialog for the user to select a printer.
    using (PrintDocument document = new PrintDocument())
    using (PrintDialog printDialog = new PrintDialog())
    {
        printDialog.Document = document;
        // Set the page range to 1 page.
        printDialog.AllowSomePages = true;
        printDialog.PrinterSettings.MinimumPage = 1;
        printDialog.PrinterSettings.MaximumPage = 1;
        printDialog.PrinterSettings.FromPage = 1;
        printDialog.PrinterSettings.ToPage = 1;

        if (DialogResult.OK == printDialog.ShowDialog(this))
        {
            // Set a name for the print job.
            document.DocumentName = this.Text;
            // Define a PrintPage event handler and start printing.
            document.PrintPage +=
                new PrintPageEventHandler(HandlePrinting);
            document.Print();
        }
    }
}

void HandlePrinting(object sender, PrintPageEventArgs args)
{
    // Clone the current Display for use as a printing display.
    ImGearPageDisplay igPageDisplayPrinting =
        imGearPageView.Display.Clone();
    igPageDisplayPrinting.Page = imGearPageView.Display.Page;
    // Get the current Zoom settings and disabled fixed zoom.
    ImGearZoomInfo igZoomInfo =
        igPageDisplayPrinting.GetZoomInfo(imGearPageView);
    igZoomInfo.Horizontal.Fixed =
        igZoomInfo.Vertical.Fixed = false;
    igPageDisplayPrinting.UpdateZoomFrom(igZoomInfo);
    // Disable any background before printing.
    igPageDisplayPrinting.Background.Mode =
        ImGearBackgroundModes.NONE;
    // Print to the Graphics device chosen from the PrintDialog.
    igPageDisplayPrinting.Print(args.Graphics);
    // Let the PrintDialog know there are no more pages.
    args.HasMorePages = false;
}
  • Visual Basic
Private Sub PrintPage(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles ImGearPageDisplayPrintToolStripMenuItem.Click
    'Load an image
    Dim igPage As ImGearPage
    Dim localFile As FileStream = New FileStream("test1.tif", FileMode.Open)
    Try
        igPage = ImGearFileFormats.LoadPage(localFile, 0)
    Finally
        localFile.Close()
    End Try
    'Create a new ImGearPageDisplay based upon an ImGearPage.
    Dim igPageDisplay As ImGearPageDisplay = New ImGearPageDisplay(igPage)
    'Set the current ImGearPageView to use this new display.
    ImGearPageView1.Display = igPageDisplay
    'Initialize a PrintDialog for the user to select a printer.

    Dim document As PrintDocument = New PrintDocument()
    Dim printDialog As PrintDialog = New PrintDialog()
    Try
        printDialog.Document = document
        'Set the page range to 1 page.
        printDialog.AllowSomePages = True
        printDialog.PrinterSettings.MinimumPage = 1
        printDialog.PrinterSettings.MaximumPage = 1
        printDialog.PrinterSettings.FromPage = 1
        printDialog.PrinterSettings.ToPage = 1

        If (printDialog.ShowDialog(Me) = DialogResult.OK) Then
            'Set a name for the print job.
            document.DocumentName = Me.Text
            'Define a PrintPage event handler and start printing.
            AddHandler document.PrintPage, _
                New PrintPageEventHandler(AddressOf HandlePrinting)
            document.Print()
        End If
    Finally
        printDialog.Dispose()
        document.Dispose()
    End Try
End Sub

Private Sub HandlePrinting(ByVal sender As Object, ByVal args As PrintPageEventArgs)
    'Clone the current Display for use as a printing display.
    Dim igPageDisplayPrinting As ImGearPageDisplay = _
        ImGearPageView1.Display.Clone()
    igPageDisplayPrinting.Page = ImGearPageView1.Display.Page
    'Get the current Zoom settings and disabled fixed zoom.
    Dim igZoomInfo As ImGearZoomInfo = _
        igPageDisplayPrinting.GetZoomInfo(ImGearPageView1)
    igZoomInfo.Horizontal.Fixed = False
    igZoomInfo.Vertical.Fixed = False
    igPageDisplayPrinting.UpdateZoomFrom(igZoomInfo)
    'Disable any background before printing.
    igPageDisplayPrinting.Background.Mode = _
        ImGearBackgroundModes.NONE
    'Print to the Graphics device chosen from the PrintDialog.
    igPageDisplayPrinting.Print(args.Graphics)
    'Let the PrintDialog know there are no more pages.
    args.HasMorePages = False
End Sub
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


ScrollTo Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ScrollTo Method
IImGearScrollableView interface; represents .NET form to draw the image in.
New horizontal scroll position.
New vertical scroll position.
Scrolls the image to the specified position and updates the scrollbars accordingly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ScrollTo( _
   ByVal pageView As IImGearScrollableView, _
   ByVal positionX As Integer, _
   ByVal positionY As Integer _
) As ImGearScrollInfo
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim positionX As Integer
Dim positionY As Integer
Dim value As ImGearScrollInfo

value = instance.ScrollTo(pageView, positionX, positionY)
public ImGearScrollInfo ScrollTo(
   IImGearScrollableView pageView,
   int positionX,
   int positionY
)
public: ImGearScrollInfo ScrollTo(
   IImGearScrollableView* pageView,
   int positionX,
   int positionY
)
public:
ImGearScrollInfo ScrollTo(
   IImGearScrollableView^ pageView,
   int positionX,
   int positionY
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Return Value

Instance of ImGearScrollInfo structure object.
Remarks
This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with GetScrollInfo method.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


UpdateLUT Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : UpdateLUT Method
Multichannel lookup table.
Contrast settings.
Updates the ImGearPageDisplay lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateLUT( _
   ByVal colorLUT As ImGearMultichannelLUT, _
   ByVal contrastSettings As IImGearContrastSettings _
)
'Usage

Dim instance As ImGearPageDisplay
Dim colorLUT As ImGearMultichannelLUT
Dim contrastSettings As IImGearContrastSettings

instance.UpdateLUT(colorLUT, contrastSettings)
public void UpdateLUT(
   ImGearMultichannelLUT colorLUT,
   IImGearContrastSettings contrastSettings
)
public: void UpdateLUT(
   ImGearMultichannelLUT* colorLUT,
   IImGearContrastSettings* contrastSettings
)
public:
void UpdateLUT(
   ImGearMultichannelLUT^ colorLUT,
   IImGearContrastSettings^ contrastSettings
)

Parameters

colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.
Remarks
The ImGearPageDisplay lookup table is updated as follows:
  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearMultichannelLUT Class
IImGearContrastSettings Interface


UpdateScrollFrom Method (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : UpdateScrollFrom Method
IImGearScrollableView interface; represents .NET form to draw image in.
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
Updates image scroll attributes with new values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateScrollFrom( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollInfo As ImGearScrollInfo

instance.UpdateScrollFrom(pageView, scrollInfo)
public void UpdateScrollFrom(
   IImGearScrollableView pageView,
   ImGearScrollInfo scrollInfo
)
public: void UpdateScrollFrom(
   IImGearScrollableView* pageView,
   ImGearScrollInfo scrollInfo
)
public:
void UpdateScrollFrom(
   IImGearScrollableView^ pageView,
   ImGearScrollInfo scrollInfo
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearScrollableView Interface
ImGearScrollInfo Structure


UpdateZoomFrom Method (ImGearPageDisplay)
Example

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : UpdateZoomFrom Method
ImGearZoomInfo object with new zoom attributes.
Updates image zoom attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateZoomFrom( _
   ByVal zoomInfo As ImGearZoomInfo _
)
'Usage

Dim instance As ImGearPageDisplay
Dim zoomInfo As ImGearZoomInfo

instance.UpdateZoomFrom(zoomInfo)
public void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
public: void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
public:
void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)

Parameters

zoomInfo
ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Get the current Zoom settings
ImGearZoomInfo igZoomInfo =
    imGearPageView.Display.GetZoomInfo(imGearPageView);
// Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Vertical.Fixed = true;
// Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2;
igZoomInfo.Vertical.Value *= 2;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
// Cause a redraw with the new zoom.
imGearPageView.Invalidate();
  • Visual Basic
'Get the current Zoom settings
Dim igZoomInfo As ImGearZoomInfo = _
    ImGearPageView1.Display.GetZoomInfo(ImGearPageView1)
'Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = True
igZoomInfo.Vertical.Fixed = True
'Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2
igZoomInfo.Vertical.Value *= 2
ImGearPageView1.Display.UpdateZoomFrom(igZoomInfo)
'Cause a redraw with the new zoom.
ImGearPageView1.Invalidate()
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearZoomInfo Structure


ZoomToRectangle Method (ImGearPageDisplay)
Example

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ZoomToRectangle Method
ImGearZoomInfo object with new zoom attributes.
Specified device rectangle.
Performs zooming to specified device rectangle and returns new zoom information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ZoomToRectangle( _
   ByVal pageView As IImGearScrollableView, _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As ImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim rect As ImGearRectangle

instance.ZoomToRectangle(pageView, rect)
public void ZoomToRectangle(
   IImGearScrollableView pageView,
   ImGearRectangle rect
)
public: void ZoomToRectangle(
   IImGearScrollableView* pageView,
   ImGearRectangle rect
)
public:
void ZoomToRectangle(
   IImGearScrollableView^ pageView,
   ImGearRectangle rect
)

Parameters

pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle.
Remarks
This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo.Fixed field to true, calculates and modifies ImGearZoomComponentInfo.Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Variable to toggle if user is currently selecting an area.
private bool m_bZoomToRectSelect = false;
// Set of points defining the selected area.
private ImGearPoint[] igPointsZoomToRect;
// Color of selection box.
private Color m_SelectorColor = Color.White;

// Method to return appropriate height for a specific width
// based upon the size of a scrollable view.
private int GetHeight(IImGearScrollableView igScrollableView, int Width)
{
    return Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width;
}

private void menuZoomToRect_Click(object sender, EventArgs e)
{
    // Menu item used to toggle if Zoom to Rectangle is on or not.
    menuZoomToRect.Checked = !menuZoomToRect.Checked;
}

private void imGearPageView1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (menuZoomToRect.Checked)
    {
        // Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = true;
        // Create a new pair of points to define the rectangle,
        // setting the first point to the current position.
        igPointsZoomToRect = new ImGearPoint[2];
        igPointsZoomToRect[0].X = e.X;
        igPointsZoomToRect[0].Y = e.Y;
        // Register method to draw the selection rectangle.
        imGearPageView.RegisterAfterDraw(
            new ImGearPageView.AfterDraw(DrawSelector));
    }
}

private void imGearPageView1_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Leave Zoom to Rectangle selection mode.
        imGearPageView.RegisterAfterDraw(null);
        m_bZoomToRectSelect = false;
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Create a rectangle based upon the 2 points.
        ImGearRectangle igRectangle = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        if (igRectangle.Width <= 1 || igRectangle.Height <= 1)
            return;
        // Zoom to the selected rectangle
        imGearPageView.Display.ZoomToRectangle(imGearPageView, igRectangle);
        imGearPageView.Invalidate();
        // Disable Zoom to Rectangle.
        menuZoomToRect.Checked = false;
    }
}

private void imGearPageView1_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Cause a redraw which will update the zoom selection rectangle.
        imGearPageView.Invalidate();
    }
}

private void DrawSelector(System.Drawing.Graphics gr)
{
    if (m_bZoomToRectSelect)
    {
        // Create a new pen to draw dotted lines.
        Pen pen = new Pen(m_SelectorColor);
        pen.DashStyle = DashStyle.Dot;
        // Define the currently selected zoom rectangle.
        ImGearRectangle igRectangleZoom = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top,
            igRectangleZoom.Width, igRectangleZoom.Height);
    }
}
  • Visual Basic
'Variable to toggle if user is currently selecting an area.
Private m_bZoomToRectSelect As Boolean = False
'Set of points defining the selected area.
Private igPointsZoomToRect() As ImGearPoint
'Color of selection box.
Private m_SelectorColor As Color = Color.White

'Function to return appropriate height for a specific width
' based upon the size of a scrollable view.
Private Function GetHeight(ByVal igScrollableView As IImGearScrollableView, ByVal Width As Integer) As Integer
    GetHeight = Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width
End Function

Private Sub menuZoomtoRect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles menuZoomtoRect.Click
    menuZoomtoRect.Checked = Not menuZoomtoRect.Checked
End Sub

Private Sub ImGearPageView1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseDown
    If (menuZoomtoRect.Checked) Then
        'Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = True
        'Create a new pair of points to define the rectangle,
        ' setting the first point to the current position.
        ReDim igPointsZoomToRect(2)
        igPointsZoomToRect(0).X = e.X
        igPointsZoomToRect(0).Y = e.Y
        'Register function to draw the selection rectangle.
        ImGearPageView1.RegisterAfterDraw( _
            New ImGearPageView.AfterDraw(AddressOf DrawSelector))
    End If
End Sub

Private Sub ImGearPageView1_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseUp
    If (m_bZoomToRectSelect) Then
        'Leave Zoom to Rectangle selection mode.
        ImGearPageView1.RegisterAfterDraw(Nothing)
        m_bZoomToRectSelect = False
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Create a rectangle based upon the 2 points.
        Dim igRectangle As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        If (igRectangle.Width <= 1 Or igRectangle.Height <= 1) Then
            Return
        End If
        'Zoom to the selected rectangle
        ImGearPageView1.Display.ZoomToRectangle(ImGearPageView1, igRectangle)
        ImGearPageView1.Invalidate()
        'Disable Zoom to Rectangle.
        menuZoomtoRect.Checked = False
    End If
End Sub

Private Sub ImGearPageView1_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseMove
    If (m_bZoomToRectSelect) Then
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Cause a redraw which will update the zoom selection rectangle.
        ImGearPageView1.Invalidate()
    End If
End Sub

Private Sub DrawSelector(ByVal gr As System.Drawing.Graphics)
    If (m_bZoomToRectSelect) Then
        'Create a new pen to draw dotted lines.
        Dim pen As Pen = New Pen(m_SelectorColor)
        Pen.DashStyle = DashStyle.Dot
        'Define the currently selected zoom rectangle.
        Dim igRectangleZoom As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top, igRectangleZoom.Width, igRectangleZoom.Height)
    End If
End Sub
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearScrollableView Interface
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

ImGearPageDisplay Class Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplay Class

For a list of all members of this type, see ImGearPageDisplay members.

Public Properties
 | Name | Description
Public Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Public Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Public Property | Background | Gets background drawing attributes.
Public Property | Brightness | Gets or sets the brightness level of the displayed image.
Public Property | Channels | Gets the list of extra channels and their display options.
Public Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Public Property | Contrast | Gets or sets the contrast level of the displayed image.
Public Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Public Property | Gamma | Gets or sets the gamma level of the displayed image.
Public Property | Layout | Gets image display layout settings.
Public Property | LUT | Gets or sets a display lookup table.
Public Property | Orientation | Gets image orientation attributes.
Public Property | Page | Gets or sets ImGearPage object associated with this display page.
Public Property | Resampling | Gets re-sampling attributes.
Top
See Also

Reference

ImGearPageDisplay Class
ImageGear.Display Namespace


AntiAliasing Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : AntiAliasing Property
Gets bitonal anti-aliasing settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AntiAliasing As IImGearAntiAlias
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearAntiAlias

value = instance.AntiAliasing
public IImGearAntiAlias AntiAliasing {get;}
public: __property IImGearAntiAlias* get_AntiAliasing();
public:
property IImGearAntiAlias^ AntiAliasing {
   IImGearAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearAntiAlias Interface


ARTPage Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ARTPage Property
Gets or sets ImGearAnnotationPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ARTPage As ImGearAnnotationPage
'Usage

Dim instance As ImGearPageDisplay
Dim value As ImGearAnnotationPage

instance.ARTPage = value

value = instance.ARTPage
public ImGearAnnotationPage ARTPage {get; set;}
public: __property ImGearAnnotationPage* get_ARTPage();
public: __property void set_ARTPage(
   ImGearAnnotationPage* value
);
public:
property ImGearAnnotationPage^ ARTPage {
   ImGearAnnotationPage^ get();
   void set (    ImGearAnnotationPage^ value);
}

Property Value

ImGearAnnotationPage class.
Remarks
Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class ImageGear.ART.ImGearARTPage class, defined in ImageGear22.Art assembly.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


Background Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Background Property
Gets background drawing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Background As IImGearBackground
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearBackground

value = instance.Background
public IImGearBackground Background {get;}
public: __property IImGearBackground* get_Background();
public:
property IImGearBackground^ Background {
   IImGearBackground^ get();
}

Property Value

IImGearBackground interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearBackground Interface


Brightness Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Brightness Property
Gets or sets the brightness level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Brightness As Double
'Usage

Dim instance As ImGearPageDisplay
Dim value As Double

instance.Brightness = value

value = instance.Brightness
public virtual double Brightness {get; set;}
public: __property virtual double get_Brightness();
public: __property virtual void set_Brightness(
   double value
);
public:
virtual property double Brightness {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


Channels Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Channels Property
Gets the list of extra channels and their display options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Channels As ImGearDisplayChannels
'Usage

Dim instance As ImGearPageDisplay
Dim value As ImGearDisplayChannels

value = instance.Channels
public ImGearDisplayChannels Channels {get;}
public: __property ImGearDisplayChannels* get_Channels();
public:
property ImGearDisplayChannels^ Channels {
   ImGearDisplayChannels^ get();
}

Property Value

ImageGear.Core.ImGearDisplayChannels class object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearDisplayChannels Class


ColorAntiAliasing Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ColorAntiAliasing Property
Gets color anti-aliasing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorAntiAliasing As IImGearColorAntiAlias
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearColorAntiAlias

value = instance.ColorAntiAliasing
public IImGearColorAntiAlias ColorAntiAliasing {get;}
public: __property IImGearColorAntiAlias* get_ColorAntiAliasing();
public:
property IImGearColorAntiAlias^ ColorAntiAliasing {
   IImGearColorAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearAntiAlias Interface


Contrast Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Contrast Property
Gets or sets the contrast level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Contrast As Double
'Usage

Dim instance As ImGearPageDisplay
Dim value As Double

instance.Contrast = value

value = instance.Contrast
public virtual double Contrast {get; set;}
public: __property virtual double get_Contrast();
public: __property virtual void set_Contrast(
   double value
);
public:
virtual property double Contrast {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


DICOMDisplaySettings Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : DICOMDisplaySettings Property
Gets or sets the DICOM specific display contrast settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DICOMDisplaySettings As IImGearDICOMDisplaySettings
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearDICOMDisplaySettings

instance.DICOMDisplaySettings = value

value = instance.DICOMDisplaySettings
public IImGearDICOMDisplaySettings DICOMDisplaySettings {get; set;}
public: __property IImGearDICOMDisplaySettings* get_DICOMDisplaySettings();
public: __property void set_DICOMDisplaySettings(
   IImGearDICOMDisplaySettings* value
);
public:
property IImGearDICOMDisplaySettings^ DICOMDisplaySettings {
   IImGearDICOMDisplaySettings^ get();
   void set (    IImGearDICOMDisplaySettings^ value);
}

Property Value

ImageGear.Core.IImGearDICOMDisplaySettings interface.
Remarks
DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of ImageGear.Core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An ImageGear.Core.IImGearDICOMDisplaySettings interface object can be attached to an ImageGear.Core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImageGear.Core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This property affects grayscale images with bit depths from 2 to 16. Type of this property is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast ImageGear.Core.IImGearDICOMDisplaySettings interface to the actual class ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class. The default value is null.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearDICOMDisplaySettings Interface
ImGearDICOMDisplaySettings Class


Gamma Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Gamma Property
Gets or sets the gamma level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Gamma As Double
'Usage

Dim instance As ImGearPageDisplay
Dim value As Double

instance.Gamma = value

value = instance.Gamma
public virtual double Gamma {get; set;}
public: __property virtual double get_Gamma();
public: __property virtual void set_Gamma(
   double value
);
public:
virtual property double Gamma {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


Layout Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Layout Property
Gets image display layout settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Layout As IImGearLayout
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearLayout

value = instance.Layout
public IImGearLayout Layout {get;}
public: __property IImGearLayout* get_Layout();
public:
property IImGearLayout^ Layout {
   IImGearLayout^ get();
}

Property Value

IImGearLayout interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearLayout Interface


LUT Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : LUT Property
Gets or sets a display lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LUT As ImGearMultichannelLUT
'Usage

Dim instance As ImGearPageDisplay
Dim value As ImGearMultichannelLUT

instance.LUT = value

value = instance.LUT
public ImGearMultichannelLUT LUT {get; set;}
public: __property ImGearMultichannelLUT* get_LUT();
public: __property void set_LUT(
   ImGearMultichannelLUT* value
);
public:
property ImGearMultichannelLUT^ LUT {
   ImGearMultichannelLUT^ get();
   void set (    ImGearMultichannelLUT^ value);
}

Property Value

ImageGear.Core.ImGearMultichannelLUT class.
Remarks
This property only supports ImageGear.Core.ImGearRGBLUT class objects.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearMultichannelLUT Class


Orientation Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Orientation Property
Gets image orientation attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Orientation As IImGearOrientation
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearOrientation

value = instance.Orientation
public IImGearOrientation Orientation {get;}
public: __property IImGearOrientation* get_Orientation();
public:
property IImGearOrientation^ Orientation {
   IImGearOrientation^ get();
}

Property Value

ImageGear.Core.ImGearOrientation structure.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearOrientation Structure


Page Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Page Property
Gets or sets ImGearPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearPage
'Usage

Dim instance As ImGearPageDisplay
Dim value As ImGearPage

instance.Page = value

value = instance.Page
public ImGearPage Page {get; set;}
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

Valid ImageGear.Core.ImGearPage class object or null.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
ImGearPage Class


Resampling Property (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : Resampling Property
Gets re-sampling attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Resampling As IImGearResample
'Usage

Dim instance As ImGearPageDisplay
Dim value As IImGearResample

value = instance.Resampling
public IImGearResample Resampling {get;}
public: __property IImGearResample* get_Resampling();
public:
property IImGearResample^ Resampling {
   IImGearResample^ get();
}

Property Value

IImGearResample interface object.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
IImGearResample Interface


%%PageItemTitle%% $$Events$$

ImGearPageDisplay Class Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplay Class

For a list of all members of this type, see ImGearPageDisplay members.

Public Events
 | Name | Description
Public Event | LUTUpdated | Occurs when the lookup table is updated.
Public Event | PageScrolled | Occurs when a page is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

ImGearPageDisplay Class
ImageGear.Display Namespace


LUTUpdated Event (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : LUTUpdated Event
Occurs when the lookup table is updated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event LUTUpdated As EventHandler
'Usage

Dim instance As ImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.LUTUpdated, handler
public event EventHandler LUTUpdated
public: __event EventHandler* LUTUpdated
public:
event EventHandler^ LUTUpdated
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


PageScrolled Event (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : PageScrolled Event
Occurs when a page is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event instead.")>
Public Event PageScrolled As EventHandler
'Usage

Dim instance As ImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.PageScrolled, handler
[Obsolete("Use the ScrollChanged event instead.")]
public event EventHandler PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public: __event EventHandler* PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public:
event EventHandler^ PageScrolled
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


PageZoomed Event (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : PageZoomed Event
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageZoomed As EventHandler
'Usage

Dim instance As ImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.PageZoomed, handler
public event EventHandler PageZoomed
public: __event EventHandler* PageZoomed
public:
event EventHandler^ PageZoomed
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


PropertyChanged Event (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearPageDisplay
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


ScrollChanged Event (ImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplay Class : ScrollChanged Event
Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ScrollChanged As ImGearScrollChangedEventHandler
'Usage

Dim instance As ImGearPageDisplay
Dim handler As ImGearScrollChangedEventHandler

AddHandler instance.ScrollChanged, handler
public event ImGearScrollChangedEventHandler ScrollChanged
public: __event ImGearScrollChangedEventHandler* ScrollChanged
public:
event ImGearScrollChangedEventHandler^ ScrollChanged
Event Data

The event handler receives an argument of type ImGearScrollChangedEventArgs containing data related to this event. The following ImGearScrollChangedEventArgs properties provide information specific to this event.

Property | Description
IsEnabled | Gets a value indicating whether the scrollbar is enabled.
IsVisible | Gets a value indicating whether the scrollbar is visible.
Redraw | Gets a value indicating whether or not the view should be redrawn.
ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
ScrollChangeType | Gets the type of scrollbar change.
ScrollInformation | Gets the scrolling information.
See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

ImGearPageDisplayConverter Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplayConverter Class
Converts between ImGearPageDisplay class and other types, such as string.
Object Model
ImGearPageDisplayConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageDisplayConverter
   Inherits System.ComponentModel.TypeConverter
'Usage

Dim instance As ImGearPageDisplayConverter
public class ImGearPageDisplayConverter : System.ComponentModel.TypeConverter
public __gc class ImGearPageDisplayConverter : public System.ComponentModel.TypeConverter
public ref class ImGearPageDisplayConverter : public System.ComponentModel.TypeConverter
Remarks
Only conversions between ImGearPageDisplay class and string are currently supported.
Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
ImageGear.Display.ImGearPageDisplayConverter

See Also

Reference

ImGearPageDisplayConverter Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearPageDisplayConverter Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplayConverter Class

The following tables list the members exposed by ImGearPageDisplayConverter.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageDisplayConverter Constructor | Initializes a new instance of the ImGearPageDisplayConverter class..
Top
Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearPageDisplayConverter Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearPageDisplayConverter Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class : ImGearPageDisplayConverter Constructor
Initializes a new instance of the ImGearPageDisplayConverter class..
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageDisplayConverter()
public ImGearPageDisplayConverter()
public: ImGearPageDisplayConverter();
public:
ImGearPageDisplayConverter();

Return Value

The new instance of ImGearPageDisplayConverter class.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members


%%PageItemTitle%% $$Methods$$

ImGearPageDisplayConverter Class Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearPageDisplayConverter Class

For a list of all members of this type, see ImGearPageDisplayConverter members.

Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearPageDisplayConverter Class
ImageGear.Display Namespace


CanConvertFrom Method (ImGearPageDisplayConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class : CanConvertFrom Method
Returns true if conversion from specified type is supported.
Overload List
Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns true if conversion from specified type is supported.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
The type from which you want to convert.
Returns true if conversion from specified type is supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
'Usage

Dim instance As ImGearPageDisplayConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
The type from which you want to convert.

Return Value

This method returns true if this object can perform the conversion; otherwise, false.
Remarks
The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members
Overload List
ImGearPageDisplay Class


ConvertFrom Method (ImGearPageDisplayConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class : ConvertFrom Method
Converts the value from the specified type.
Overload List
Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the value from the specified type.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
Converts the value from the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
'Usage

Dim instance As ImGearPageDisplayConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.

Return Value

The converted object. This method will throw an exception if the conversion could not be performed.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members
Overload List
ImGearPageDisplay Class


ConvertTo Method (ImGearPageDisplayConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class : ConvertTo Method
Converts the value to the specified type.
Overload List
Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the value to the specified type.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearPageDisplayConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
The type to convert the object to.
Converts the value to the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
'Usage

Dim instance As ImGearPageDisplayConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.
See Also

Reference

ImGearPageDisplayConverter Class
ImGearPageDisplayConverter Members
Overload List
ImGearPageDisplay Class


%%PageItemTitle%%

ImGearScrollChangedEventArgs Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollChangedEventArgs Class
Provides data for the page scrolled event.
Object Model
ImGearScrollChangedEventArgs ClassImGearScrollInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearScrollChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearScrollChangedEventArgs
public class ImGearScrollChangedEventArgs : System.EventArgs
public __gc class ImGearScrollChangedEventArgs : public System.EventArgs
public ref class ImGearScrollChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Display.ImGearScrollChangedEventArgs

See Also

Reference

ImGearScrollChangedEventArgs Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearScrollChangedEventArgs Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollChangedEventArgs Class

The following tables list the members exposed by ImGearScrollChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearScrollChangedEventArgs Constructor | Initializes a new instance of the ImGearScrollChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | IsEnabled | Gets a value indicating whether the scrollbar is enabled.
Public Property | IsVisible | Gets a value indicating whether the scrollbar is visible.
Public Property | Redraw | Gets a value indicating whether or not the view should be redrawn.
Public Property | ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
Public Property | ScrollChangeType | Gets the type of scrollbar change.
Public Property | ScrollInformation | Gets the scrolling information.
Top
See Also

Reference

ImGearScrollChangedEventArgs Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearScrollChangedEventArgs Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : ImGearScrollChangedEventArgs Constructor
The type of scrollbar change.
The type of the scrollbar that is being scrolled.
The scrolling information.
Whether or not the view should be redrawn.
Whether or not the scrollbar is enabled.
Whether or not the scrollbar is visible.
Initializes a new instance of the ImGearScrollChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal scrollChangeType As ImGearScrollChangeType, _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollInfo As ImGearScrollInfo, _
   ByVal redraw As Boolean, _
   ByVal isEnabled As Boolean, _
   ByVal isVisible As Boolean _
)
'Usage

Dim scrollChangeType As ImGearScrollChangeType
Dim scrollBarType As ImGearScrollBarType
Dim scrollInfo As ImGearScrollInfo
Dim redraw As Boolean
Dim isEnabled As Boolean
Dim isVisible As Boolean

Dim instance As New ImGearScrollChangedEventArgs(scrollChangeType, scrollBarType, scrollInfo, redraw, isEnabled, isVisible)
public ImGearScrollChangedEventArgs(
   ImGearScrollChangeType scrollChangeType,
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw,
   bool isEnabled,
   bool isVisible
)
public: ImGearScrollChangedEventArgs(
   ImGearScrollChangeType scrollChangeType,
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw,
   bool isEnabled,
   bool isVisible
)
public:
ImGearScrollChangedEventArgs(
   ImGearScrollChangeType scrollChangeType,
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw,
   bool isEnabled,
   bool isVisible
)

Parameters

scrollChangeType
The type of scrollbar change.
scrollBarType
The type of the scrollbar that is being scrolled.
scrollInfo
The scrolling information.
redraw
Whether or not the view should be redrawn.
isEnabled
Whether or not the scrollbar is enabled.
isVisible
Whether or not the scrollbar is visible.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearScrollChangedEventArgs Class Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollChangedEventArgs Class

For a list of all members of this type, see ImGearScrollChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | IsEnabled | Gets a value indicating whether the scrollbar is enabled.
Public Property | IsVisible | Gets a value indicating whether the scrollbar is visible.
Public Property | Redraw | Gets a value indicating whether or not the view should be redrawn.
Public Property | ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
Public Property | ScrollChangeType | Gets the type of scrollbar change.
Public Property | ScrollInformation | Gets the scrolling information.
Top
See Also

Reference

ImGearScrollChangedEventArgs Class
ImageGear.Display Namespace


IsEnabled Property (ImGearScrollChangedEventArgs)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : IsEnabled Property
Gets a value indicating whether the scrollbar is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsEnabled As Boolean
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As Boolean

value = instance.IsEnabled
public bool IsEnabled {get;}
public: __property bool get_IsEnabled();
public:
property bool IsEnabled {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


IsVisible Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : IsVisible Property
Gets a value indicating whether the scrollbar is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsVisible As Boolean
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As Boolean

value = instance.IsVisible
public bool IsVisible {get;}
public: __property bool get_IsVisible();
public:
property bool IsVisible {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


Redraw Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : Redraw Property
Gets a value indicating whether or not the view should be redrawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Redraw As Boolean
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As Boolean

value = instance.Redraw
public bool Redraw {get;}
public: __property bool get_Redraw();
public:
property bool Redraw {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


ScrollBarType Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : ScrollBarType Property
Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollBarType As ImGearScrollBarType
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As ImGearScrollBarType

value = instance.ScrollBarType
public ImGearScrollBarType ScrollBarType {get;}
public: __property ImGearScrollBarType get_ScrollBarType();
public:
property ImGearScrollBarType ScrollBarType {
   ImGearScrollBarType get();
}

Property Value

ImGearScrollBarType value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


ScrollChangeType Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : ScrollChangeType Property
Gets the type of scrollbar change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollChangeType As ImGearScrollChangeType
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As ImGearScrollChangeType

value = instance.ScrollChangeType
public ImGearScrollChangeType ScrollChangeType {get;}
public: __property ImGearScrollChangeType get_ScrollChangeType();
public:
property ImGearScrollChangeType ScrollChangeType {
   ImGearScrollChangeType get();
}

Property Value

ImGearScrollBarType value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


ScrollInformation Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollChangedEventArgs Class : ScrollInformation Property
Gets the scrolling information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollInformation As ImGearScrollInfo
'Usage

Dim instance As ImGearScrollChangedEventArgs
Dim value As ImGearScrollInfo

value = instance.ScrollInformation
public ImGearScrollInfo ScrollInformation {get;}
public: __property ImGearScrollInfo get_ScrollInformation();
public:
property ImGearScrollInfo ScrollInformation {
   ImGearScrollInfo get();
}

Property Value

ImGearScrollInfo value.
See Also

Reference

ImGearScrollChangedEventArgs Class
ImGearScrollChangedEventArgs Members


%%PageItemTitle%%

ImGearScrollComponentInfoConverter Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfoConverter Class
Converts between ImGearScrollComponentInfo class and other types, such as string.
Object Model
ImGearScrollComponentInfoConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearScrollComponentInfoConverter
   Inherits System.ComponentModel.TypeConverter
'Usage

Dim instance As ImGearScrollComponentInfoConverter
public class ImGearScrollComponentInfoConverter : System.ComponentModel.TypeConverter
public __gc class ImGearScrollComponentInfoConverter : public System.ComponentModel.TypeConverter
public ref class ImGearScrollComponentInfoConverter : public System.ComponentModel.TypeConverter
Remarks
Only conversions between ImGearScrollComponentInfo class and string are currently supported.
Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
ImageGear.Display.ImGearScrollComponentInfoConverter

See Also

Reference

ImGearScrollComponentInfoConverter Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearScrollComponentInfoConverter Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfoConverter Class

The following tables list the members exposed by ImGearScrollComponentInfoConverter.

Public Constructors
 | Name | Description
Public Constructor | ImGearScrollComponentInfoConverter Constructor | Initializes a new instance of the ImGearScrollComponentInfoConverter class.
Top
Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearScrollComponentInfoConverter Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class : ImGearScrollComponentInfoConverter Constructor
Initializes a new instance of the ImGearScrollComponentInfoConverter class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearScrollComponentInfoConverter()
public ImGearScrollComponentInfoConverter()
public: ImGearScrollComponentInfoConverter();
public:
ImGearScrollComponentInfoConverter();
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members


%%PageItemTitle%% $$Methods$$

ImGearScrollComponentInfoConverter Class Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfoConverter Class

For a list of all members of this type, see ImGearScrollComponentInfoConverter members.

Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImageGear.Display Namespace


CanConvertFrom Method (ImGearScrollComponentInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class : CanConvertFrom Method
Returns true if conversion from specified type is supported.
Overload List
Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns true if conversion from specified type is supported.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
The type from which you want to convert.
Returns true if conversion from specified type is supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
'Usage

Dim instance As ImGearScrollComponentInfoConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
The type from which you want to convert.

Return Value

This method returns true if this object can perform the conversion; otherwise, false.
Remarks
The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members
Overload List
ImGearScrollComponentInfo Structure


ConvertFrom Method (ImGearScrollComponentInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class : ConvertFrom Method
Converts the value from the specified type.
Overload List
Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the value from the specified type.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
Converts the value from the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
'Usage

Dim instance As ImGearScrollComponentInfoConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.

Return Value

The converted object. This method will throw an exception if the conversion could not be performed.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members
Overload List
ImGearScrollComponentInfo Structure


ConvertTo Method (ImGearScrollComponentInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class : ConvertTo Method
Converts the value to the specified type.
Overload List
Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the value to the specified type.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfoConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
The type to convert the object to.
Converts the value to the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
'Usage

Dim instance As ImGearScrollComponentInfoConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.
See Also

Reference

ImGearScrollComponentInfoConverter Class
ImGearScrollComponentInfoConverter Members
Overload List
ImGearScrollComponentInfo Structure


%%PageItemTitle%%

ImGearZoomInfoConverter Class
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfoConverter Class
Converts between ImGearZoomInfo class and other types, such as string.
Object Model
ImGearZoomInfoConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearZoomInfoConverter
   Inherits System.ComponentModel.TypeConverter
'Usage

Dim instance As ImGearZoomInfoConverter
public class ImGearZoomInfoConverter : System.ComponentModel.TypeConverter
public __gc class ImGearZoomInfoConverter : public System.ComponentModel.TypeConverter
public ref class ImGearZoomInfoConverter : public System.ComponentModel.TypeConverter
Remarks
Only conversions between ImGearZoomInfo class and string are currently supported.
Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
ImageGear.Display.ImGearZoomInfoConverter

See Also

Reference

ImGearZoomInfoConverter Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearZoomInfoConverter Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfoConverter Class

The following tables list the members exposed by ImGearZoomInfoConverter.

Public Constructors
 | Name | Description
Public Constructor | ImGearZoomInfoConverter Constructor | Initializes a new instance of the ImGearZoomInfoConverter class.
Top
Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearZoomInfoConverter Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearZoomInfoConverter Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class : ImGearZoomInfoConverter Constructor
Initializes a new instance of the ImGearZoomInfoConverter class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearZoomInfoConverter()
public ImGearZoomInfoConverter()
public: ImGearZoomInfoConverter();
public:
ImGearZoomInfoConverter();
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members


%%PageItemTitle%% $$Methods$$

ImGearZoomInfoConverter Class Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfoConverter Class

For a list of all members of this type, see ImGearZoomInfoConverter members.

Public Methods
 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns true if conversion from specified type is supported.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the value from the specified type.
Public Method | ConvertTo | Overloaded. Overridden. Converts the value to the specified type.
Top
See Also

Reference

ImGearZoomInfoConverter Class
ImageGear.Display Namespace


CanConvertFrom Method (ImGearZoomInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class : CanConvertFrom Method
Returns true if conversion from specified type is supported.
Overload List
Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns true if conversion from specified type is supported.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
The type from which you want to convert.
Returns true if conversion from specified type is supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
'Usage

Dim instance As ImGearZoomInfoConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
The type from which you want to convert.

Return Value

This method returns true if this object can perform the conversion; otherwise, false.
Remarks
The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members
Overload List
ImGearZoomInfo Structure


ConvertFrom Method (ImGearZoomInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class : ConvertFrom Method
Converts the value from the specified type.
Overload List
Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the value from the specified type.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
A TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
Converts the value from the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
'Usage

Dim instance As ImGearZoomInfoConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
A TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.

Return Value

The converted object. This method will throw an exception if the conversion could not be performed.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members
Overload List
ImGearZoomInfo Structure


ConvertTo Method (ImGearZoomInfoConverter)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class : ConvertTo Method
Converts the value to the specified type.
Overload List
Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the value to the specified type.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfoConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
A CultureInfo object that specifies the culture to represent the Color.
The object to convert.
The type to convert the object to.
Converts the value to the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
'Usage

Dim instance As ImGearZoomInfoConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
A CultureInfo object that specifies the culture to represent the Color.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.
See Also

Reference

ImGearZoomInfoConverter Class
ImGearZoomInfoConverter Members
Overload List
ImGearZoomInfo Structure


%%PageItemTitle%%

ImGearAliasModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAliasModes Enumeration
Identifies different types of image aliasing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAliasModes
   Inherits System.Enum
'Usage

Dim instance As ImGearAliasModes
public enum ImGearAliasModes : System.Enum
__value public enum ImGearAliasModes : public System.Enum
public enum class ImGearAliasModes : public System.Enum
Members
Member | Value | Description
NONE | 0 | Anti-aliasing is not used.
PRESERVE_BLACK | 2 | This mode directs ImageGear to preserve black pixels while drawing.
PRESERVE_WHITE | 3 | This mode directs ImageGear to preserve white pixels while drawing.
SCALE_TO_GRAY | 1 | The scale-to-gray algorithm is used. The output is in 8 bits per pixel format.
Remarks
Applicable only if a 1-bit-per-pixel image is to be drawn and only if the destination image has a lower resolution than the original one.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearAliasModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearAlignmentHModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAlignmentHModes Enumeration
Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAlignmentHModes
   Inherits System.Enum
'Usage

Dim instance As ImGearAlignmentHModes
public enum ImGearAlignmentHModes : System.Enum
__value public enum ImGearAlignmentHModes : public System.Enum
public enum class ImGearAlignmentHModes : public System.Enum
Members
Member | Value | Description
CENTER | 0x00000010 | The image is centered horizontally.
LEFT | 0x00000000 | The image is aligned to the left border of the device rectangle.
RIGHT | 0x00000020 | The image is aligned to the right border of the device rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearAlignmentHModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearAlignmentVModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearAlignmentVModes Enumeration
Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAlignmentVModes
   Inherits System.Enum
'Usage

Dim instance As ImGearAlignmentVModes
public enum ImGearAlignmentVModes : System.Enum
__value public enum ImGearAlignmentVModes : public System.Enum
public enum class ImGearAlignmentVModes : public System.Enum
Members
Member | Value | Description
BOTTOM | 0x00000002 | The image is aligned to the bottom border of the device rectangle.
CENTER | 0x00000001 | The image is centered vertically.
TOP | 0x00000000 | The image is aligned to the top border of the device rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearAlignmentVModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearBackgroundModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearBackgroundModes Enumeration
Specifies ImageGear background modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBackgroundModes
   Inherits System.Enum
'Usage

Dim instance As ImGearBackgroundModes
public enum ImGearBackgroundModes : System.Enum
__value public enum ImGearBackgroundModes : public System.Enum
public enum class ImGearBackgroundModes : public System.Enum
Members
Member | Value | Description
BEYOND_IMAGE | 0x00000002 | Fill device rectangle beyond the image area with background color.
NONE | 0x00000000 | Do not draw background.
UNDER_IMAGE | 0x00000001 | Fill the area under the image with background color. This mode has effect if image has transparent color or alpha channel.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearBackgroundModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearColorAliasModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearColorAliasModes Enumeration
Specifies color anti-aliasing mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearColorAliasModes
   Inherits System.Enum
'Usage

Dim instance As ImGearColorAliasModes
public enum ImGearColorAliasModes : System.Enum
__value public enum ImGearColorAliasModes : public System.Enum
public enum class ImGearColorAliasModes : public System.Enum
Members
Member | Value | Description
INTERPOLATE | 1 | Interpolation anti-aliasing is used for color images.
NONE | 0 | Anti-aliasing is not used for color images.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearColorAliasModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearCoordConvModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearCoordConvModes Enumeration
Identifies coordinate translation methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCoordConvModes
   Inherits System.Enum
'Usage

Dim instance As ImGearCoordConvModes
public enum ImGearCoordConvModes : System.Enum
__value public enum ImGearCoordConvModes : public System.Enum
public enum class ImGearCoordConvModes : public System.Enum
Members
Member | Value | Description
DEVICE_TO_IMAGE | 1 | Convert coordinates from device to image.
IMAGE_TO_DEVICE | 0 | Convert coordinates from image to device.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearCoordConvModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearFitModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearFitModes Enumeration
Identifies how an image fits to the device rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFitModes
   Inherits System.Enum
'Usage

Dim instance As ImGearFitModes
public enum ImGearFitModes : System.Enum
__value public enum ImGearFitModes : public System.Enum
public enum class ImGearFitModes : public System.Enum
Members
Member | Value | Description
ACTUAL_SIZE | 3 | The device rectangle is ignored, and the image is scaled 1:1.
FIT_TO_DEVICE | 0 | The image is scaled to fit both the width and height of the device rectangle.
FIT_TO_HEIGHT | 2 | The image is scaled to fit the height of the device rectangle.
FIT_TO_WIDTH | 1 | The image is scaled to fit the width of the device rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearFitModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearResampleModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearResampleModes Enumeration
Specifies re-sampling mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearResampleModes
   Inherits System.Enum
'Usage

Dim instance As ImGearResampleModes
public enum ImGearResampleModes : System.Enum
__value public enum ImGearResampleModes : public System.Enum
public enum class ImGearResampleModes : public System.Enum
Members
Member | Value | Description
BILINEAR | 1 | Bilinear re-sampling is used.
NONE | 0 | Re-sampling is not used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearResampleModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearScrollBarModes Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollBarModes Enumeration
Identifies scroll bar visibility methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearScrollBarModes
   Inherits System.Enum
'Usage

Dim instance As ImGearScrollBarModes
public enum ImGearScrollBarModes : System.Enum
__value public enum ImGearScrollBarModes : public System.Enum
public enum class ImGearScrollBarModes : public System.Enum
Members
Member | Value | Description
SCROLLBAR_AUTO | 0x00000080 | Automatically show and hide scrollbar when required according to image zoom.
SCROLLBAR_DISABLE | 0x00000002 | Always hide scrollbar.
SCROLLBAR_ENABLE | 0x00000001 | Always show scrollbar.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearScrollBarModes

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearScrollBarType Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollBarType Enumeration
Identifies scrollbar types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearScrollBarType
   Inherits System.Enum
'Usage

Dim instance As ImGearScrollBarType
public enum ImGearScrollBarType : System.Enum
__value public enum ImGearScrollBarType : public System.Enum
public enum class ImGearScrollBarType : public System.Enum
Members
Member | Value | Description
HORIZONTAL | 1 | Horizontal scrollbar.
VERTICAL | 2 | Vertical scrollbar.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearScrollBarType

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearScrollChangeType Enumeration

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollChangeType Enumeration
This enumeration specifies the type of scrollbar change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearScrollChangeType
   Inherits System.Enum
'Usage

Dim instance As ImGearScrollChangeType
public enum ImGearScrollChangeType : System.Enum
__value public enum ImGearScrollChangeType : public System.Enum
public enum class ImGearScrollChangeType : public System.Enum
Members
Member | Value | Description
PageScrolled | 0 | The page scrolled.
ScrollBarEnabledChanged | 1 | A scrollbar was enabled or disabled.
ScrollBarVisibleChanged | 2 | The visibility of a scrollbar changed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Display.ImGearScrollChangeType

See Also

Reference

ImageGear.Display Namespace


%%PageItemTitle%%

ImGearContrastSettings Structure
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearContrastSettings Structure
Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.
Object Model
ImGearContrastSettings StructureImGearContrastSettings Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearContrastSettings
   Inherits System.ValueType
   Implements IImGearContrastSettings
'Usage

Dim instance As ImGearContrastSettings
public struct ImGearContrastSettings : System.ValueType, IImGearContrastSettings
public __value struct ImGearContrastSettings : public System.ValueType, IImGearContrastSettings
public value class ImGearContrastSettings : public System.ValueType, IImGearContrastSettings
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Display.ImGearContrastSettings

See Also

Reference

ImGearContrastSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearContrastSettings Structure Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearContrastSettings Structure

The following tables list the members exposed by ImGearContrastSettings.

Public Properties
 | Name | Description
Public Property | Brightness | Gets or sets brightness attribute.
Public Property | Contrast | Gets or sets contrast attribute.
Public Property | Gamma | Gets or sets gamma attribute.
Top
Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearContrastSettings structure object.
static (Shared in Visual Basic) | CreateDefault | Creates ImGearContrastSettings structure with default attributes.
Top
See Also

Reference

ImGearContrastSettings Structure
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

ImGearContrastSettings Structure Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearContrastSettings Structure

For a list of all members of this type, see ImGearContrastSettings members.

Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearContrastSettings structure object.
static (Shared in Visual Basic) | CreateDefault | Creates ImGearContrastSettings structure with default attributes.
Top
See Also

Reference

ImGearContrastSettings Structure
ImageGear.Display Namespace


CopyFrom Method (ImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearContrastSettings Structure : CopyFrom Method
An ImGearContrastSettings structure object to copy.
Initializes the object from existing ImGearContrastSettings structure object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal value As IImGearContrastSettings _
)
'Usage

Dim instance As ImGearContrastSettings
Dim value As IImGearContrastSettings

instance.CopyFrom(value)
public void CopyFrom(
   IImGearContrastSettings value
)
public: void CopyFrom(
   IImGearContrastSettings* value
)
public:
void CopyFrom(
   IImGearContrastSettings^ value
)

Parameters

value
An ImGearContrastSettings structure object to copy.
See Also

Reference

ImGearContrastSettings Structure
ImGearContrastSettings Members
IImGearContrastSettings Interface


CreateDefault Method (ImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearContrastSettings Structure : CreateDefault Method
Creates ImGearContrastSettings structure with default attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateDefault() As ImGearContrastSettings
'Usage

Dim value As ImGearContrastSettings

value = ImGearContrastSettings.CreateDefault()
public static ImGearContrastSettings CreateDefault()
public: static ImGearContrastSettings CreateDefault();
public:
static ImGearContrastSettings CreateDefault();

Return Value

ImGearContrastSettings structure object.
Remarks
This method sets the following default attributes:
Contrast = 1.0
Brightness = 0.0
Gamma = 1.0.
See Also

Reference

ImGearContrastSettings Structure
ImGearContrastSettings Members


%%PageItemTitle%% $$Properties$$

ImGearContrastSettings Structure Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearContrastSettings Structure

For a list of all members of this type, see ImGearContrastSettings members.

Public Properties
 | Name | Description
Public Property | Brightness | Gets or sets brightness attribute.
Public Property | Contrast | Gets or sets contrast attribute.
Public Property | Gamma | Gets or sets gamma attribute.
Top
See Also

Reference

ImGearContrastSettings Structure
ImageGear.Display Namespace


Brightness Property (ImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearContrastSettings Structure : Brightness Property
Gets or sets brightness attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Brightness As Double
'Usage

Dim instance As ImGearContrastSettings
Dim value As Double

instance.Brightness = value

value = instance.Brightness
public double Brightness {get; set;}
public: __property double get_Brightness();
public: __property void set_Brightness(
   double value
);
public:
property double Brightness {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearContrastSettings Structure
ImGearContrastSettings Members
IImGearContrastSettings Interface


Contrast Property (ImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearContrastSettings Structure : Contrast Property
Gets or sets contrast attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contrast As Double
'Usage

Dim instance As ImGearContrastSettings
Dim value As Double

instance.Contrast = value

value = instance.Contrast
public double Contrast {get; set;}
public: __property double get_Contrast();
public: __property void set_Contrast(
   double value
);
public:
property double Contrast {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearContrastSettings Structure
ImGearContrastSettings Members
IImGearContrastSettings Interface


Gamma Property (ImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearContrastSettings Structure : Gamma Property
Gets or sets gamma attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Gamma As Double
'Usage

Dim instance As ImGearContrastSettings
Dim value As Double

instance.Gamma = value

value = instance.Gamma
public double Gamma {get; set;}
public: __property double get_Gamma();
public: __property void set_Gamma(
   double value
);
public:
property double Gamma {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearContrastSettings Structure
ImGearContrastSettings Members
IImGearContrastSettings Interface


%%PageItemTitle%%

ImGearScrollComponentInfo Structure
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfo Structure
Implements state of one scrollbar and uses pass scrolling information to and from ImageGear display code.
Object Model
ImGearScrollComponentInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TypeConverterAttribute("ImageGear.Display.ImGearScrollComponentInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")>
Public Structure ImGearScrollComponentInfo
   Inherits System.ValueType
'Usage

Dim instance As ImGearScrollComponentInfo
[TypeConverter("ImageGear.Display.ImGearScrollComponentInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public struct ImGearScrollComponentInfo : System.ValueType
[TypeConverter("ImageGear.Display.ImGearScrollComponentInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public __value struct ImGearScrollComponentInfo : public System.ValueType
[TypeConverter("ImageGear.Display.ImGearScrollComponentInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public value class ImGearScrollComponentInfo : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Display.ImGearScrollComponentInfo

See Also

Reference

ImGearScrollComponentInfo Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearScrollComponentInfo Structure Members
Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfo Structure

The following tables list the members exposed by ImGearScrollComponentInfo.

Public Fields
 | Name | Description
Public Field | Max | Specifies maximim scrolling position.
Public Field | Min | Specifies minimum scrolling position.
Public Field | Mode | Specifies the scrollbar visibility mode.
Public Field | Page | Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box.
Public Field | Pos | Specifies current image scrolling position.
Top
See Also

Reference

ImGearScrollComponentInfo Structure
ImageGear.Display Namespace


%%PageItemTitle%% $$Fields$$

ImGearScrollComponentInfo Structure Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollComponentInfo Structure

For a list of all members of this type, see ImGearScrollComponentInfo members.

Public Fields
 | Name | Description
Public Field | Max | Specifies maximim scrolling position.
Public Field | Min | Specifies minimum scrolling position.
Public Field | Mode | Specifies the scrollbar visibility mode.
Public Field | Page | Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box.
Public Field | Pos | Specifies current image scrolling position.
Top
See Also

Reference

ImGearScrollComponentInfo Structure
ImageGear.Display Namespace


Max Field (ImGearScrollComponentInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfo Structure : Max Field
Specifies maximim scrolling position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Max As Integer
'Usage

Dim instance As ImGearScrollComponentInfo
Dim value As Integer

value = instance.Max

instance.Max = value
public int Max
public: int Max
public:
int Max

Field Value

Integer value.
See Also

Reference

ImGearScrollComponentInfo Structure
ImGearScrollComponentInfo Members
ImGearScrollComponentInfo Structure


Min Field (ImGearScrollComponentInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfo Structure : Min Field
Specifies minimum scrolling position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Min As Integer
'Usage

Dim instance As ImGearScrollComponentInfo
Dim value As Integer

value = instance.Min

instance.Min = value
public int Min
public: int Min
public:
int Min

Field Value

Integer value.
See Also

Reference

ImGearScrollComponentInfo Structure
ImGearScrollComponentInfo Members
ImGearScrollComponentInfo Structure


Mode Field (ImGearScrollComponentInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfo Structure : Mode Field
Specifies the scrollbar visibility mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Mode As ImGearScrollBarModes
'Usage

Dim instance As ImGearScrollComponentInfo
Dim value As ImGearScrollBarModes

value = instance.Mode

instance.Mode = value
public ImGearScrollBarModes Mode
public: ImGearScrollBarModes Mode
public:
ImGearScrollBarModes Mode

Field Value

ImGearScrollBarModes enumeration values.
See Also

Reference

ImGearScrollComponentInfo Structure
ImGearScrollComponentInfo Members
ImGearScrollBarModes Enumeration


Page Field

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfo Structure : Page Field
Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Page As Integer
'Usage

Dim instance As ImGearScrollComponentInfo
Dim value As Integer

value = instance.Page

instance.Page = value
public int Page
public: int Page
public:
int Page

Field Value

Integer value.
See Also

Reference

ImGearScrollComponentInfo Structure
ImGearScrollComponentInfo Members
ImGearScrollComponentInfo Structure


Pos Field

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollComponentInfo Structure : Pos Field
Specifies current image scrolling position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Pos As Integer
'Usage

Dim instance As ImGearScrollComponentInfo
Dim value As Integer

value = instance.Pos

instance.Pos = value
public int Pos
public: int Pos
public:
int Pos

Field Value

Integer value.
See Also

Reference

ImGearScrollComponentInfo Structure
ImGearScrollComponentInfo Members
ImGearScrollComponentInfo Structure


%%PageItemTitle%%

ImGearScrollInfo Structure
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollInfo Structure
Represents scrolling state of the image.
Object Model
ImGearScrollInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearScrollInfo
   Inherits System.ValueType
   Implements IImGearDisplayObject
'Usage

Dim instance As ImGearScrollInfo
public struct ImGearScrollInfo : System.ValueType, IImGearDisplayObject
public __value struct ImGearScrollInfo : public System.ValueType, IImGearDisplayObject
public value class ImGearScrollInfo : public System.ValueType, IImGearDisplayObject
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Display.ImGearScrollInfo

See Also

Reference

ImGearScrollInfo Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearScrollInfo Structure Members
Fields Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollInfo Structure

The following tables list the members exposed by ImGearScrollInfo.

Public Fields
 | Name | Description
Public Field | Horizontal | Stores information about horizontal image scrolling state.
Public Field | Vertical | Stores information about vertical image scrolling state.
Top
Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearScrollInfo structure object.
Public Method | InitToDefault | Initializes the object with default valid values.
Top
See Also

Reference

ImGearScrollInfo Structure
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

ImGearScrollInfo Structure Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollInfo Structure

For a list of all members of this type, see ImGearScrollInfo members.

Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearScrollInfo structure object.
Public Method | InitToDefault | Initializes the object with default valid values.
Top
See Also

Reference

ImGearScrollInfo Structure
ImageGear.Display Namespace


CopyFrom Method (ImGearScrollInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollInfo Structure : CopyFrom Method
An ImGearScrollInfo structure object to copy.
Initializes the object from existing ImGearScrollInfo structure object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal value As IImGearDisplayObject _
)
'Usage

Dim instance As ImGearScrollInfo
Dim value As IImGearDisplayObject

instance.CopyFrom(value)
public void CopyFrom(
   IImGearDisplayObject value
)
public: void CopyFrom(
   IImGearDisplayObject* value
)
public:
void CopyFrom(
   IImGearDisplayObject^ value
)

Parameters

value
An ImGearScrollInfo structure object to copy.
See Also

Reference

ImGearScrollInfo Structure
ImGearScrollInfo Members
IImGearDisplayObject Interface


InitToDefault Method (ImGearScrollInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollInfo Structure : InitToDefault Method
Initializes the object with default valid values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InitToDefault()
'Usage

Dim instance As ImGearScrollInfo

instance.InitToDefault()
public void InitToDefault()
public: void InitToDefault();
public:
void InitToDefault();
Remarks
Default scroll values for both vertical and horizontal directions are following:
  • Scrollbar mode is set to ImGearScrollBarModes.SCROLLBAR_AUTO
  • Min, Max, Pos and Page properties are set to 0
See Also

Reference

ImGearScrollInfo Structure
ImGearScrollInfo Members
ImGearScrollBarModes Enumeration


%%PageItemTitle%% $$Fields$$

ImGearScrollInfo Structure Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollInfo Structure

For a list of all members of this type, see ImGearScrollInfo members.

Public Fields
 | Name | Description
Public Field | Horizontal | Stores information about horizontal image scrolling state.
Public Field | Vertical | Stores information about vertical image scrolling state.
Top
See Also

Reference

ImGearScrollInfo Structure
ImageGear.Display Namespace


Horizontal Field (ImGearScrollInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollInfo Structure : Horizontal Field
Stores information about horizontal image scrolling state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Horizontal As ImGearScrollComponentInfo
'Usage

Dim instance As ImGearScrollInfo
Dim value As ImGearScrollComponentInfo

value = instance.Horizontal

instance.Horizontal = value
public ImGearScrollComponentInfo Horizontal
public: ImGearScrollComponentInfo Horizontal
public:
ImGearScrollComponentInfo Horizontal

Field Value

ImGearScrollComponentInfo structure object.
See Also

Reference

ImGearScrollInfo Structure
ImGearScrollInfo Members
ImGearScrollComponentInfo Structure


Vertical Field (ImGearScrollInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearScrollInfo Structure : Vertical Field
Stores information about vertical image scrolling state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Vertical As ImGearScrollComponentInfo
'Usage

Dim instance As ImGearScrollInfo
Dim value As ImGearScrollComponentInfo

value = instance.Vertical

instance.Vertical = value
public ImGearScrollComponentInfo Vertical
public: ImGearScrollComponentInfo Vertical
public:
ImGearScrollComponentInfo Vertical

Field Value

ImGearScrollComponentInfo structure.
See Also

Reference

ImGearScrollInfo Structure
ImGearScrollInfo Members
ImGearScrollComponentInfo Structure


%%PageItemTitle%%

ImGearZoomComponentInfo Structure
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomComponentInfo Structure
Stores information about image zoom in one dimension (vertical or horizontal).
Object Model
ImGearZoomComponentInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearZoomComponentInfo
   Inherits System.ValueType
'Usage

Dim instance As ImGearZoomComponentInfo
public struct ImGearZoomComponentInfo : System.ValueType
public __value struct ImGearZoomComponentInfo : public System.ValueType
public value class ImGearZoomComponentInfo : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Display.ImGearZoomComponentInfo

See Also

Reference

ImGearZoomComponentInfo Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearZoomComponentInfo Structure Members
Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomComponentInfo Structure

The following tables list the members exposed by ImGearZoomComponentInfo.

Public Fields
 | Name | Description
Public Field | Fixed | Specifies fixed or non-fixed zoom mode.
Public Field | Value | Specifies zoom value.
Top
See Also

Reference

ImGearZoomComponentInfo Structure
ImageGear.Display Namespace


%%PageItemTitle%% $$Fields$$

ImGearZoomComponentInfo Structure Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomComponentInfo Structure

For a list of all members of this type, see ImGearZoomComponentInfo members.

Public Fields
 | Name | Description
Public Field | Fixed | Specifies fixed or non-fixed zoom mode.
Public Field | Value | Specifies zoom value.
Top
See Also

Reference

ImGearZoomComponentInfo Structure
ImageGear.Display Namespace


Fixed Field

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomComponentInfo Structure : Fixed Field
Specifies fixed or non-fixed zoom mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Fixed As Boolean
'Usage

Dim instance As ImGearZoomComponentInfo
Dim value As Boolean

value = instance.Fixed

instance.Fixed = value
public bool Fixed
public: bool Fixed
public:
bool Fixed

Field Value

Boolean value.
Remarks
Fixed zoom value (true) indicates that Value field is in use. With non-fixed zoom value (false), actual zoom factor is calculated without Value field information.
See Also

Reference

ImGearZoomComponentInfo Structure
ImGearZoomComponentInfo Members


Value Field (ImGearZoomComponentInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomComponentInfo Structure : Value Field
Specifies zoom value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Value As Double
'Usage

Dim instance As ImGearZoomComponentInfo
Dim value As Double

value = instance.Value

instance.Value = value
public double Value
public: double Value
public:
double Value

Field Value

Any positive double value.
Remarks
When zoom mode (Fixed field) is set to false, this field is ignored.
See Also

Reference

ImGearZoomComponentInfo Structure
ImGearZoomComponentInfo Members


%%PageItemTitle%%

ImGearZoomInfo Structure
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfo Structure
Represents complete image zoom information.
Object Model
ImGearZoomInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TypeConverterAttribute("ImageGear.Display.ImGearZoomInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")>
Public Structure ImGearZoomInfo
   Inherits System.ValueType
   Implements IImGearDisplayObject
'Usage

Dim instance As ImGearZoomInfo
[TypeConverter("ImageGear.Display.ImGearZoomInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public struct ImGearZoomInfo : System.ValueType, IImGearDisplayObject
[TypeConverter("ImageGear.Display.ImGearZoomInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public __value struct ImGearZoomInfo : public System.ValueType, IImGearDisplayObject
[TypeConverter("ImageGear.Display.ImGearZoomInfoConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public value class ImGearZoomInfo : public System.ValueType, IImGearDisplayObject
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Display.ImGearZoomInfo

See Also

Reference

ImGearZoomInfo Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearZoomInfo Structure Members
Fields Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfo Structure

The following tables list the members exposed by ImGearZoomInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearZoomInfo Constructor | Initializes a new instance of the ImGearZoomInfo structure using the specified values.
Top
Public Fields
 | Name | Description
Public Field | Horizontal | Scecifies horizontal zoom information.
Public Field | Vertical | Specifies vertical zoom information.
Top
Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearZoomInfo structure object.
Public Method | InitToDefault | Initializes the object with default valid values.
Top
See Also

Reference

ImGearZoomInfo Structure
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearZoomInfo Constructor

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfo Structure : ImGearZoomInfo Constructor
Horizontal zoom value.
Vertical zoom value.
A value indicating whether horizontal zoom is fixed.
A value indicating whether vertical zoom is fixed.
Initializes a new instance of the ImGearZoomInfo structure using the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal horizontalZoomValue As Double, _
   ByVal verticalZoomValue As Double, _
   ByVal isHorizontalZoomFixed As Boolean, _
   ByVal isVerticalZoomFixed As Boolean _
)
'Usage

Dim horizontalZoomValue As Double
Dim verticalZoomValue As Double
Dim isHorizontalZoomFixed As Boolean
Dim isVerticalZoomFixed As Boolean

Dim instance As New ImGearZoomInfo(horizontalZoomValue, verticalZoomValue, isHorizontalZoomFixed, isVerticalZoomFixed)
public ImGearZoomInfo(
   double horizontalZoomValue,
   double verticalZoomValue,
   bool isHorizontalZoomFixed,
   bool isVerticalZoomFixed
)
public: ImGearZoomInfo(
   double horizontalZoomValue,
   double verticalZoomValue,
   bool isHorizontalZoomFixed,
   bool isVerticalZoomFixed
)
public:
ImGearZoomInfo(
   double horizontalZoomValue,
   double verticalZoomValue,
   bool isHorizontalZoomFixed,
   bool isVerticalZoomFixed
)

Parameters

horizontalZoomValue
Horizontal zoom value.
verticalZoomValue
Vertical zoom value.
isHorizontalZoomFixed
A value indicating whether horizontal zoom is fixed.
isVerticalZoomFixed
A value indicating whether vertical zoom is fixed.
See Also

Reference

ImGearZoomInfo Structure
ImGearZoomInfo Members


%%PageItemTitle%% $$Methods$$

ImGearZoomInfo Structure Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfo Structure

For a list of all members of this type, see ImGearZoomInfo members.

Public Methods
 | Name | Description
Public Method | CopyFrom | Initializes the object from existing ImGearZoomInfo structure object.
Public Method | InitToDefault | Initializes the object with default valid values.
Top
See Also

Reference

ImGearZoomInfo Structure
ImageGear.Display Namespace


CopyFrom Method (ImGearZoomInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfo Structure : CopyFrom Method
An ImGearZoomInfo structure object to copy.
Initializes the object from existing ImGearZoomInfo structure object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal value As IImGearDisplayObject _
)
'Usage

Dim instance As ImGearZoomInfo
Dim value As IImGearDisplayObject

instance.CopyFrom(value)
public void CopyFrom(
   IImGearDisplayObject value
)
public: void CopyFrom(
   IImGearDisplayObject* value
)
public:
void CopyFrom(
   IImGearDisplayObject^ value
)

Parameters

value
An ImGearZoomInfo structure object to copy.
See Also

Reference

ImGearZoomInfo Structure
ImGearZoomInfo Members
IImGearDisplayObject Interface


InitToDefault Method (ImGearZoomInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfo Structure : InitToDefault Method
Initializes the object with default valid values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InitToDefault()
'Usage

Dim instance As ImGearZoomInfo

instance.InitToDefault()
public void InitToDefault()
public: void InitToDefault();
public:
void InitToDefault();
Remarks
Default zoom value is 1 and non-fixed mode (for both vertical and horizontal directions).
See Also

Reference

ImGearZoomInfo Structure
ImGearZoomInfo Members


%%PageItemTitle%% $$Fields$$

ImGearZoomInfo Structure Fields

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearZoomInfo Structure

For a list of all members of this type, see ImGearZoomInfo members.

Public Fields
 | Name | Description
Public Field | Horizontal | Scecifies horizontal zoom information.
Public Field | Vertical | Specifies vertical zoom information.
Top
See Also

Reference

ImGearZoomInfo Structure
ImageGear.Display Namespace


Horizontal Field (ImGearZoomInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfo Structure : Horizontal Field
Scecifies horizontal zoom information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Horizontal As ImGearZoomComponentInfo
'Usage

Dim instance As ImGearZoomInfo
Dim value As ImGearZoomComponentInfo

value = instance.Horizontal

instance.Horizontal = value
public ImGearZoomComponentInfo Horizontal
public: ImGearZoomComponentInfo Horizontal
public:
ImGearZoomComponentInfo Horizontal

Field Value

ImGearZoomComponentInfo structure
See Also

Reference

ImGearZoomInfo Structure
ImGearZoomInfo Members
ImGearZoomComponentInfo Structure


Vertical Field (ImGearZoomInfo)

ImageGear22.Core Assembly > ImageGear.Display Namespace > ImGearZoomInfo Structure : Vertical Field
Specifies vertical zoom information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Vertical As ImGearZoomComponentInfo
'Usage

Dim instance As ImGearZoomInfo
Dim value As ImGearZoomComponentInfo

value = instance.Vertical

instance.Vertical = value
public ImGearZoomComponentInfo Vertical
public: ImGearZoomComponentInfo Vertical
public:
ImGearZoomComponentInfo Vertical

Field Value

ImGearZoomComponentInfo structure
See Also

Reference

ImGearZoomInfo Structure
ImGearZoomInfo Members
ImGearZoomComponentInfo Structure


%%PageItemTitle%%

IImGearAlignment Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAlignment Interface
Provides access to display alignment modes.
Object Model
IImGearAlignment Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearAlignment
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearAlignment
public interface IImGearAlignment : IImGearDisplayObject
public __gc __interface IImGearAlignment : public IImGearDisplayObject
public interface class IImGearAlignment : public IImGearDisplayObject
See Also

Reference

IImGearAlignment Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearAlignment Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAlignment Interface

The following tables list the members exposed by IImGearAlignment.

Public Properties
 | Name | Description
Property | Horizontal | Gets or sets image horizontal alignment mode.
Property | Vertical | Gets or sets image vertical alignment mode.
Top
See Also

Reference

IImGearAlignment Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearAlignment Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAlignment Interface

For a list of all members of this type, see IImGearAlignment members.

See Also

Reference

IImGearAlignment Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearAlignment Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAlignment Interface

For a list of all members of this type, see IImGearAlignment members.

Public Properties
 | Name | Description
Property | Horizontal | Gets or sets image horizontal alignment mode.
Property | Vertical | Gets or sets image vertical alignment mode.
Top
See Also

Reference

IImGearAlignment Interface
ImageGear.Display Namespace


Horizontal Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAlignment Interface : Horizontal Property
Gets or sets image horizontal alignment mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Horizontal As ImGearAlignmentHModes
'Usage

Dim instance As IImGearAlignment
Dim value As ImGearAlignmentHModes

instance.Horizontal = value

value = instance.Horizontal
ImGearAlignmentHModes Horizontal {get; set;}
__property ImGearAlignmentHModes get_Horizontal();
__property void set_Horizontal(
   ImGearAlignmentHModes value
);
property ImGearAlignmentHModes Horizontal {
   ImGearAlignmentHModes get();
   void set (    ImGearAlignmentHModes value);
}

Property Value

ImGearAlignmentHModes enumeration values.
See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members
ImGearAlignmentHModes Enumeration


Vertical Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAlignment Interface : Vertical Property
Gets or sets image vertical alignment mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Vertical As ImGearAlignmentVModes
'Usage

Dim instance As IImGearAlignment
Dim value As ImGearAlignmentVModes

instance.Vertical = value

value = instance.Vertical
ImGearAlignmentVModes Vertical {get; set;}
__property ImGearAlignmentVModes get_Vertical();
__property void set_Vertical(
   ImGearAlignmentVModes value
);
property ImGearAlignmentVModes Vertical {
   ImGearAlignmentVModes get();
   void set (    ImGearAlignmentVModes value);
}

Property Value

ImGearAlignmentVModes enumeration values.
See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members
ImGearAlignmentVModes Enumeration


%%PageItemTitle%%

IImGearAntiAlias Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAntiAlias Interface
Provides access to bitonal anti-aliasing attributes.
Object Model
IImGearAntiAlias Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearAntiAlias
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearAntiAlias
public interface IImGearAntiAlias : IImGearDisplayObject
public __gc __interface IImGearAntiAlias : public IImGearDisplayObject
public interface class IImGearAntiAlias : public IImGearDisplayObject
See Also

Reference

IImGearAntiAlias Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearAntiAlias Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAntiAlias Interface

The following tables list the members exposed by IImGearAntiAlias.

Public Properties
 | Name | Description
Property | Method | Gets or sets an image anti-aliasing method to use.
Property | Threshold | Gets or sets an image aliasing threshold attribute.
Top
See Also

Reference

IImGearAntiAlias Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearAntiAlias Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAntiAlias Interface

For a list of all members of this type, see IImGearAntiAlias members.

See Also

Reference

IImGearAntiAlias Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearAntiAlias Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAntiAlias Interface

For a list of all members of this type, see IImGearAntiAlias members.

Public Properties
 | Name | Description
Property | Method | Gets or sets an image anti-aliasing method to use.
Property | Threshold | Gets or sets an image aliasing threshold attribute.
Top
See Also

Reference

IImGearAntiAlias Interface
ImageGear.Display Namespace


Method Property (IImGearAntiAlias)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAntiAlias Interface : Method Property
Gets or sets an image anti-aliasing method to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Method As ImGearAliasModes
'Usage

Dim instance As IImGearAntiAlias
Dim value As ImGearAliasModes

instance.Method = value

value = instance.Method
ImGearAliasModes Method {get; set;}
__property ImGearAliasModes get_Method();
__property void set_Method(
   ImGearAliasModes value
);
property ImGearAliasModes Method {
   ImGearAliasModes get();
   void set (    ImGearAliasModes value);
}

Property Value

ImGearAliasModes enumeration value.
Remarks
This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one.
See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members
ImGearAliasModes Enumeration


Threshold Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAntiAlias Interface : Threshold Property
Gets or sets an image aliasing threshold attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Threshold As Integer
'Usage

Dim instance As IImGearAntiAlias
Dim value As Integer

instance.Threshold = value

value = instance.Threshold
int Threshold {get; set;}
__property int get_Threshold();
__property void set_Threshold(
   int value
);
property int Threshold {
   int get();
   void set (    int value);
}

Property Value

Integer in range [0..100].
Remarks
Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50.
See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members
ImGearAliasModes Enumeration
Method Property


%%PageItemTitle%%

IImGearAspectRatio Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAspectRatio Interface
Provides access to display aspect ratio attributes.
Object Model
IImGearAspectRatio Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearAspectRatio
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearAspectRatio
public interface IImGearAspectRatio : IImGearDisplayObject
public __gc __interface IImGearAspectRatio : public IImGearDisplayObject
public interface class IImGearAspectRatio : public IImGearDisplayObject
See Also

Reference

IImGearAspectRatio Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearAspectRatio Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAspectRatio Interface

The following tables list the members exposed by IImGearAspectRatio.

Public Properties
 | Name | Description
Property | Fixed | Gets or sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle.
Property | Value | Gets or sets image's display aspect ratio (i.e., width-to-height ratio).
Top
See Also

Reference

IImGearAspectRatio Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearAspectRatio Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAspectRatio Interface

For a list of all members of this type, see IImGearAspectRatio members.

See Also

Reference

IImGearAspectRatio Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearAspectRatio Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearAspectRatio Interface

For a list of all members of this type, see IImGearAspectRatio members.

Public Properties
 | Name | Description
Property | Fixed | Gets or sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle.
Property | Value | Gets or sets image's display aspect ratio (i.e., width-to-height ratio).
Top
See Also

Reference

IImGearAspectRatio Interface
ImageGear.Display Namespace


Fixed Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAspectRatio Interface : Fixed Property
Gets or sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Fixed As Boolean
'Usage

Dim instance As IImGearAspectRatio
Dim value As Boolean

instance.Fixed = value

value = instance.Fixed
bool Fixed {get; set;}
__property bool get_Fixed();
__property void set_Fixed(
   bool value
);
property bool Fixed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property identifies the different types of image display aspect ratio (i.e., width-to-height ratio). Setting this property to true indicates that the aspect ratio is specified by Value field parameter. Setting it to false indicates that the aspect ratio is specified by the device rectangle.
See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members
Value Property


Value Property (IImGearAspectRatio)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearAspectRatio Interface : Value Property
Gets or sets image's display aspect ratio (i.e., width-to-height ratio).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Value As Double
'Usage

Dim instance As IImGearAspectRatio
Dim value As Double

instance.Value = value

value = instance.Value
double Value {get; set;}
__property double get_Value();
__property void set_Value(
   double value
);
property double Value {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
When Fixed is set to true, specifies image aspect ratio. Otherwise, it is ignored.
See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members
Fixed Property


%%PageItemTitle%%

IImGearBackground Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearBackground Interface
Provides access to display background attributes.
Object Model
IImGearBackground InterfaceIImGearRGBQuad Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearBackground
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearBackground
public interface IImGearBackground : IImGearDisplayObject
public __gc __interface IImGearBackground : public IImGearDisplayObject
public interface class IImGearBackground : public IImGearDisplayObject
Remarks
There are no objects implementing this interface. It is accessed via ImGearPageDisplay.Background property of ImGearPageDisplay class.
See Also

Reference

IImGearBackground Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearBackground Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearBackground Interface

The following tables list the members exposed by IImGearBackground.

Public Properties
 | Name | Description
Property | Color | Gets a background color of displayed image. Area on screen not covered by image is filled with this color.
Property | Mode | Gets or sets a background drawing mode.
Top
See Also

Reference

IImGearBackground Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearBackground Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearBackground Interface

For a list of all members of this type, see IImGearBackground members.

See Also

Reference

IImGearBackground Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearBackground Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearBackground Interface

For a list of all members of this type, see IImGearBackground members.

Public Properties
 | Name | Description
Property | Color | Gets a background color of displayed image. Area on screen not covered by image is filled with this color.
Property | Mode | Gets or sets a background drawing mode.
Top
See Also

Reference

IImGearBackground Interface
ImageGear.Display Namespace


Color Property (IImGearBackground)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearBackground Interface : Color Property
Gets a background color of displayed image. Area on screen not covered by image is filled with this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Color As IImGearRGBQuad
'Usage

Dim instance As IImGearBackground
Dim value As IImGearRGBQuad

value = instance.Color
IImGearRGBQuad Color {get;}
__property IImGearRGBQuad* get_Color();
property IImGearRGBQuad^ Color {
   IImGearRGBQuad^ get();
}

Property Value

ImageGear.Core.ImGearRGBQuad structure object interface.
See Also

Reference

IImGearBackground Interface
IImGearBackground Members
ImGearRGBQuad Structure


Mode Property (IImGearBackground)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearBackground Interface : Mode Property
Gets or sets a background drawing mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Mode As ImGearBackgroundModes
'Usage

Dim instance As IImGearBackground
Dim value As ImGearBackgroundModes

instance.Mode = value

value = instance.Mode
ImGearBackgroundModes Mode {get; set;}
__property ImGearBackgroundModes get_Mode();
__property void set_Mode(
   ImGearBackgroundModes value
);
property ImGearBackgroundModes Mode {
   ImGearBackgroundModes get();
   void set (    ImGearBackgroundModes value);
}

Property Value

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
See Also

Reference

IImGearBackground Interface
IImGearBackground Members
ImGearBackgroundModes Enumeration


%%PageItemTitle%%

IImGearColorAntiAlias Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearColorAntiAlias Interface
Provides access to color anti-aliasing attributes.
Object Model
IImGearColorAntiAlias Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearColorAntiAlias
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearColorAntiAlias
public interface IImGearColorAntiAlias : IImGearDisplayObject
public __gc __interface IImGearColorAntiAlias : public IImGearDisplayObject
public interface class IImGearColorAntiAlias : public IImGearDisplayObject
See Also

Reference

IImGearColorAntiAlias Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearColorAntiAlias Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearColorAntiAlias Interface

The following tables list the members exposed by IImGearColorAntiAlias.

Public Properties
 | Name | Description
Property | Method | Gets or sets a color anti-aliasing method to use.
Top
See Also

Reference

IImGearColorAntiAlias Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearColorAntiAlias Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearColorAntiAlias Interface

For a list of all members of this type, see IImGearColorAntiAlias members.

See Also

Reference

IImGearColorAntiAlias Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearColorAntiAlias Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearColorAntiAlias Interface

For a list of all members of this type, see IImGearColorAntiAlias members.

Public Properties
 | Name | Description
Property | Method | Gets or sets a color anti-aliasing method to use.
Top
See Also

Reference

IImGearColorAntiAlias Interface
ImageGear.Display Namespace


Method Property (IImGearColorAntiAlias)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearColorAntiAlias Interface : Method Property
Gets or sets a color anti-aliasing method to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Method As ImGearColorAliasModes
'Usage

Dim instance As IImGearColorAntiAlias
Dim value As ImGearColorAliasModes

instance.Method = value

value = instance.Method
ImGearColorAliasModes Method {get; set;}
__property ImGearColorAliasModes get_Method();
__property void set_Method(
   ImGearColorAliasModes value
);
property ImGearColorAliasModes Method {
   ImGearColorAliasModes get();
   void set (    ImGearColorAliasModes value);
}

Property Value

ImGearColorAliasModes enumeration value.
Remarks
This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out.
See Also

Reference

IImGearColorAntiAlias Interface
IImGearColorAntiAlias Members
ImGearColorAliasModes Enumeration


%%PageItemTitle%%

IImGearContrastSettings Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearContrastSettings Interface
Contrast settings interface used by ImGearPageDisplay.UpdateLUT method.
Object Model
IImGearContrastSettings Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearContrastSettings
'Usage

Dim instance As IImGearContrastSettings
public interface IImGearContrastSettings
public __gc __interface IImGearContrastSettings
public interface class IImGearContrastSettings
See Also

Reference

IImGearContrastSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearContrastSettings Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearContrastSettings Interface

The following tables list the members exposed by IImGearContrastSettings.

Public Properties
 | Name | Description
Property | Brightness | Gets or sets brightness attribute.
Property | Contrast | Gets or sets contrast attribute.
Property | Gamma | Gets or sets gamma attribute.
Top
See Also

Reference

IImGearContrastSettings Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearContrastSettings Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearContrastSettings Interface

For a list of all members of this type, see IImGearContrastSettings members.

Public Properties
 | Name | Description
Property | Brightness | Gets or sets brightness attribute.
Property | Contrast | Gets or sets contrast attribute.
Property | Gamma | Gets or sets gamma attribute.
Top
See Also

Reference

IImGearContrastSettings Interface
ImageGear.Display Namespace


Brightness Property (IImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearContrastSettings Interface : Brightness Property
Gets or sets brightness attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Brightness As Double
'Usage

Dim instance As IImGearContrastSettings
Dim value As Double

instance.Brightness = value

value = instance.Brightness
double Brightness {get; set;}
__property double get_Brightness();
__property void set_Brightness(
   double value
);
property double Brightness {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


Contrast Property (IImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearContrastSettings Interface : Contrast Property
Gets or sets contrast attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Contrast As Double
'Usage

Dim instance As IImGearContrastSettings
Dim value As Double

instance.Contrast = value

value = instance.Contrast
double Contrast {get; set;}
__property double get_Contrast();
__property void set_Contrast(
   double value
);
property double Contrast {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


Gamma Property (IImGearContrastSettings)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearContrastSettings Interface : Gamma Property
Gets or sets gamma attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Gamma As Double
'Usage

Dim instance As IImGearContrastSettings
Dim value As Double

instance.Gamma = value

value = instance.Gamma
double Gamma {get; set;}
__property double get_Gamma();
__property void set_Gamma(
   double value
);
property double Gamma {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

IImGearDisplayObject Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearDisplayObject Interface
Base interface for display API objects. Implemented in several display code structures.
Object Model
IImGearDisplayObject Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearDisplayObject
'Usage

Dim instance As IImGearDisplayObject
public interface IImGearDisplayObject
public __gc __interface IImGearDisplayObject
public interface class IImGearDisplayObject
See Also

Reference

IImGearDisplayObject Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearDisplayObject Interface Members
Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearDisplayObject Interface

The following tables list the members exposed by IImGearDisplayObject.

Public Methods
 | Name | Description
Method | CopyFrom | Initializes IImGearDisplayObject object from existing object of the same type.
Method | InitToDefault | Initializes object to default value.
Top
See Also

Reference

IImGearDisplayObject Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearDisplayObject Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearDisplayObject Interface

For a list of all members of this type, see IImGearDisplayObject members.

Public Methods
 | Name | Description
Method | CopyFrom | Initializes IImGearDisplayObject object from existing object of the same type.
Method | InitToDefault | Initializes object to default value.
Top
See Also

Reference

IImGearDisplayObject Interface
ImageGear.Display Namespace


CopyFrom Method (IImGearDisplayObject)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearDisplayObject Interface : CopyFrom Method
Source object to copy.
Initializes IImGearDisplayObject object from existing object of the same type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub CopyFrom( _
   ByVal value As IImGearDisplayObject _
)
'Usage

Dim instance As IImGearDisplayObject
Dim value As IImGearDisplayObject

instance.CopyFrom(value)
void CopyFrom(
   IImGearDisplayObject value
)
void CopyFrom(
   IImGearDisplayObject* value
)
void CopyFrom(
   IImGearDisplayObject^ value
)

Parameters

value
Source object to copy.
Remarks
Source and destination objects must be of the same type and implements IImGearDisplayObject interface.
See Also

Reference

IImGearDisplayObject Interface
IImGearDisplayObject Members


InitToDefault Method (IImGearDisplayObject)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearDisplayObject Interface : InitToDefault Method
Initializes object to default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub InitToDefault()
'Usage

Dim instance As IImGearDisplayObject

instance.InitToDefault()
void InitToDefault()
void InitToDefault();
void InitToDefault();
Remarks
This method has been introduced to complement default structure constructor (that cannot be overloaded).
See Also

Reference

IImGearDisplayObject Interface
IImGearDisplayObject Members


%%PageItemTitle%%

IImGearLayout Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearLayout Interface
Provides access to display layout attributes.
Object Model
IImGearLayout InterfaceIImGearAlignment InterfaceIImGearAspectRatio InterfaceIImGearRectangle InterfaceIImGearRectangle InterfaceIImGearRectangle Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearLayout
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearLayout
public interface IImGearLayout : IImGearDisplayObject
public __gc __interface IImGearLayout : public IImGearDisplayObject
public interface class IImGearLayout : public IImGearDisplayObject
Remarks
There are no objects implementing this interface. It is accessed via Layout property of ImGearPageDisplay object.
See Also

Reference

IImGearLayout Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearLayout Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearLayout Interface

The following tables list the members exposed by IImGearLayout.

Public Properties
 | Name | Description
Property | Alignment | Gets image alignment attributes.
Property | AspectRatio | Gets image aspect ratio attributes.
Property | ClipRect | Gets image clip rectangle attribute.
Property | DeviceRect | Gets device rectangle attribute.
Property | FitMode | Gets or sets image fit mode.
Property | ImageRect | Gets image rectangle attribute.
Property | UseImageResolution | Gets or sets a value indicating whether or not the image resolution attribute affects displaying.
Top
See Also

Reference

IImGearLayout Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearLayout Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearLayout Interface

For a list of all members of this type, see IImGearLayout members.

See Also

Reference

IImGearLayout Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearLayout Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearLayout Interface

For a list of all members of this type, see IImGearLayout members.

Public Properties
 | Name | Description
Property | Alignment | Gets image alignment attributes.
Property | AspectRatio | Gets image aspect ratio attributes.
Property | ClipRect | Gets image clip rectangle attribute.
Property | DeviceRect | Gets device rectangle attribute.
Property | FitMode | Gets or sets image fit mode.
Property | ImageRect | Gets image rectangle attribute.
Property | UseImageResolution | Gets or sets a value indicating whether or not the image resolution attribute affects displaying.
Top
See Also

Reference

IImGearLayout Interface
ImageGear.Display Namespace


Alignment Property (IImGearLayout)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : Alignment Property
Gets image alignment attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Alignment As IImGearAlignment
'Usage

Dim instance As IImGearLayout
Dim value As IImGearAlignment

value = instance.Alignment
IImGearAlignment Alignment {get;}
__property IImGearAlignment* get_Alignment();
property IImGearAlignment^ Alignment {
   IImGearAlignment^ get();
}

Property Value

IImGearAlignment interface.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
IImGearAlignment Interface


AspectRatio Property (IImGearLayout)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : AspectRatio Property
Gets image aspect ratio attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property AspectRatio As IImGearAspectRatio
'Usage

Dim instance As IImGearLayout
Dim value As IImGearAspectRatio

value = instance.AspectRatio
IImGearAspectRatio AspectRatio {get;}
__property IImGearAspectRatio* get_AspectRatio();
property IImGearAspectRatio^ AspectRatio {
   IImGearAspectRatio^ get();
}

Property Value

IImGearAspectRatio interface.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
IImGearAspectRatio Interface


ClipRect Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : ClipRect Property
Gets image clip rectangle attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ClipRect As IImGearRectangle
'Usage

Dim instance As IImGearLayout
Dim value As IImGearRectangle

value = instance.ClipRect
IImGearRectangle ClipRect {get;}
__property IImGearRectangle* get_ClipRect();
property IImGearRectangle^ ClipRect {
   IImGearRectangle^ get();
}

Property Value

ImageGear.Core.ImGearRectangle object interface.
Remarks
Value returned is a reference to ImGearRectangle internal object. See Displaying Images section for more information.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
ImGearRectangle Structure


DeviceRect Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : DeviceRect Property
Gets device rectangle attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property DeviceRect As IImGearRectangle
'Usage

Dim instance As IImGearLayout
Dim value As IImGearRectangle

value = instance.DeviceRect
IImGearRectangle DeviceRect {get;}
__property IImGearRectangle* get_DeviceRect();
property IImGearRectangle^ DeviceRect {
   IImGearRectangle^ get();
}

Property Value

ImageGear.Core.ImGearRectangle object interface.
Remarks
Value returned is a reference to ImGearRectangle internal object. See Displaying Images section for more information.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
ImGearRectangle Structure


FitMode Property (IImGearLayout)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : FitMode Property
Gets or sets image fit mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property FitMode As ImGearFitModes
'Usage

Dim instance As IImGearLayout
Dim value As ImGearFitModes

instance.FitMode = value

value = instance.FitMode
ImGearFitModes FitMode {get; set;}
__property ImGearFitModes get_FitMode();
__property void set_FitMode(
   ImGearFitModes value
);
property ImGearFitModes FitMode {
   ImGearFitModes get();
   void set (    ImGearFitModes value);
}

Property Value

ImGearFitModes enumerationvalues.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
ImGearFitModes Enumeration


ImageRect Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : ImageRect Property
Gets image rectangle attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ImageRect As IImGearRectangle
'Usage

Dim instance As IImGearLayout
Dim value As IImGearRectangle

value = instance.ImageRect
IImGearRectangle ImageRect {get;}
__property IImGearRectangle* get_ImageRect();
property IImGearRectangle^ ImageRect {
   IImGearRectangle^ get();
}

Property Value

ImageGear.Core.ImGearRectangle object interface.
Remarks
Value returned is a reference to ImGearRectangle internal object. See Displaying Images section for more information.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
ImGearRectangle Structure


UseImageResolution Property

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearLayout Interface : UseImageResolution Property
Gets or sets a value indicating whether or not the image resolution attribute affects displaying.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property UseImageResolution As Boolean
'Usage

Dim instance As IImGearLayout
Dim value As Boolean

instance.UseImageResolution = value

value = instance.UseImageResolution
bool UseImageResolution {get; set;}
__property bool get_UseImageResolution();
__property void set_UseImageResolution(
   bool value
);
property bool UseImageResolution {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearLayout Interface
IImGearLayout Members
IImGearLayout Interface


%%PageItemTitle%%

IImGearPageDisplay Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearPageDisplay Interface
Defines interface for page display.
Object Model
IImGearPageDisplay InterfaceIImGearAntiAlias InterfaceImGearAnnotationPage ClassIImGearBackground InterfaceImGearDisplayChannels ClassImGearDisplayChannel ClassIImGearColorAntiAlias InterfaceIImGearDICOMDisplaySettings InterfaceImGearScrollInfo StructureImGearZoomInfo StructureIImGearLayout InterfaceImGearMultichannelLUT ClassIImGearOrientation InterfaceImGearPage ClassIImGearResample InterfaceImGearScrollInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ComVisibleAttribute(False)>
<TypeConverterAttribute("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")>
Public Interface IImGearPageDisplay
'Usage

Dim instance As IImGearPageDisplay
[ComVisible(false)]
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public interface IImGearPageDisplay
[ComVisible(false)]
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public __gc __interface IImGearPageDisplay
[ComVisible(false)]
[TypeConverter("ImageGear.Display.ImGearPageDisplayConverter, ImageGear22.Core, Version=22.0.30.9700, Culture=neutral, PublicKeyToken=80d669b8b606a2da")]
public interface class IImGearPageDisplay
Remarks
See Displaying Images section for more information.
See Also

Reference

IImGearPageDisplay Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearPageDisplay Interface Members
Properties Methods Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearPageDisplay Interface

The following tables list the members exposed by IImGearPageDisplay.

Public Properties
 | Name | Description
Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Property | Background | Gets background drawing attributes.
Property | Channels | Gets the list of extra channels and their display options.
Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Property | Layout | Gets image display layout settings.
Property | LUT | Gets or sets a display lookup table.
Property | Orientation | Gets image orientation attributes.
Property | Page | Gets or sets ImGearPage object associated with this display page.
Property | Resampling | Gets re-sampling attributes.
Top
Public Methods
 | Name | Description
Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Method | HandleScroll | Handles scrolling events.
Method | InternalUseOnly | This method is used by ImageGear internally.
Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Method | UpdateZoomFrom | Updates image zoom attributes.
Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
Public Events
 | Name | Description
Event | LUTUpdated | Occurs when the lookup table is updated.
Event | PageScrolled | Occurs when a page is scrolled.
Event | PageZoomed | Occurs when a page is zoomed.
Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visibile or enabled state changes.
Top
See Also

Reference

IImGearPageDisplay Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearPageDisplay Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearPageDisplay Interface

For a list of all members of this type, see IImGearPageDisplay members.

Public Methods
 | Name | Description
Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Method | HandleScroll | Handles scrolling events.
Method | InternalUseOnly | This method is used by ImageGear internally.
Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Method | UpdateZoomFrom | Updates image zoom attributes.
Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
See Also

Reference

IImGearPageDisplay Interface
ImageGear.Display Namespace


ConvertCoordinates Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ConvertCoordinates Method
Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Overload List
Overload | Description
ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method
IImGearScrollableView interface; represents .NET form to draw the image on.
Graphics object used to draw the image.
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
Array with point coordinates.
Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal graphics As Graphics, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim graphics As Graphics
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, graphics, mode, array)
void ConvertCoordinates(
   IImGearScrollableView pageView,
   Graphics graphics,
   ImGearCoordConvModes mode,
   Array array
)
void ConvertCoordinates(
   IImGearScrollableView* pageView,
   Graphics* graphics,
   ImGearCoordConvModes mode,
   Array* array
)
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   Graphics^ graphics,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image on.
graphics
Graphics object used to draw the image.
mode
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
array
Array with point coordinates.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method
Represents the scrollable view object on which the image is drawn.
Specifies translation direction.
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, mode, array)
void ConvertCoordinates(
   IImGearScrollableView pageView,
   ImGearCoordConvModes mode,
   Array array
)
void ConvertCoordinates(
   IImGearScrollableView* pageView,
   ImGearCoordConvModes mode,
   Array* array
)
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Remarks

In GDI+ environment, device coordinates are expressed in pixels.

In .Net WPF environment, device coordinates are expressed in WPF device independent units (1/96th inch per unit).

If you display or print an image without an IImGearScrollableView object, use one of these overloads:

  • In GDI+: ConvertCoordinates(IImGearScrollableView, System.Drawing.Graphics, ImGearCoordConvModes, System.Array)
  • In WPF: ConvertCoordinates(System.Windows.Controls.Canvas, ImGearCoordConvModes, System.Array).
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


GetScrollInfo Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : GetScrollInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns new instance of image scrolling attributes object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetScrollInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearScrollInfo
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearScrollInfo

value = instance.GetScrollInfo(pageView)
ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView pageView
)
ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView* pageView
)
ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearScrollInfo structure object.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


GetZoomInfo Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : GetZoomInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns a new instance of an object containing current zoom settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetZoomInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearZoomInfo
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearZoomInfo

value = instance.GetZoomInfo(pageView)
ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView pageView
)
ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView* pageView
)
ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearZoomInfo structure object.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearZoomInfo Structure
IImGearScrollableView Interface


HandleScroll Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : HandleScroll Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
Scroll value. Specifies new scrolling position.
Handles scrolling events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub HandleScroll( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollValue As Integer _
)
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim scrollValue As Integer

instance.HandleScroll(pageView, scrollBarType, scrollValue)
void HandleScroll(
   IImGearScrollableView pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
void HandleScroll(
   IImGearScrollableView* pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
void HandleScroll(
   IImGearScrollableView^ pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position.
Remarks
Use this method only to handle scrolling events. To scroll image to particular position, use ScrollTo method instead.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearScrollableView Interface
ImGearScrollBarType Enumeration


InternalUseOnly Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : InternalUseOnly Method
This method is used by ImageGear internally.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function InternalUseOnly() As Object
'Usage

Dim instance As IImGearPageDisplay
Dim value As Object

value = instance.InternalUseOnly()
object InternalUseOnly()
Object* InternalUseOnly();
Object^ InternalUseOnly();

Return Value

An object.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


ScrollTo Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ScrollTo Method
IImGearScrollableView interface; represents .NET form to draw the image in.
New horizontal scroll position.
New vertical scroll position.
Scrolls the image to the specified position and updates the scrollbars accordingly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function ScrollTo( _
   ByVal pageView As IImGearScrollableView, _
   ByVal positionX As Integer, _
   ByVal positionY As Integer _
) As ImGearScrollInfo
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim positionX As Integer
Dim positionY As Integer
Dim value As ImGearScrollInfo

value = instance.ScrollTo(pageView, positionX, positionY)
ImGearScrollInfo ScrollTo(
   IImGearScrollableView pageView,
   int positionX,
   int positionY
)
ImGearScrollInfo ScrollTo(
   IImGearScrollableView* pageView,
   int positionX,
   int positionY
)
ImGearScrollInfo ScrollTo(
   IImGearScrollableView^ pageView,
   int positionX,
   int positionY
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Return Value

Instance of ImGearScrollInfo structure object.
Remarks
This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with GetScrollInfo method.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


UpdateLUT Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : UpdateLUT Method
Multichannel lookup table.
Contrast settings.
Updates the ImGearPageDisplay lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub UpdateLUT( _
   ByVal colorLUT As ImGearMultichannelLUT, _
   ByVal contrastSettings As IImGearContrastSettings _
)
'Usage

Dim instance As IImGearPageDisplay
Dim colorLUT As ImGearMultichannelLUT
Dim contrastSettings As IImGearContrastSettings

instance.UpdateLUT(colorLUT, contrastSettings)
void UpdateLUT(
   ImGearMultichannelLUT colorLUT,
   IImGearContrastSettings contrastSettings
)
void UpdateLUT(
   ImGearMultichannelLUT* colorLUT,
   IImGearContrastSettings* contrastSettings
)
void UpdateLUT(
   ImGearMultichannelLUT^ colorLUT,
   IImGearContrastSettings^ contrastSettings
)

Parameters

colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.
Remarks
The ImGearPageDisplay lookup table is updated as follows:
  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearMultichannelLUT Class
IImGearContrastSettings Interface


UpdateScrollFrom Method (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : UpdateScrollFrom Method
IImGearScrollableView interface; represents .NET form to draw image in.
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
Updates image scroll attributes with new values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub UpdateScrollFrom( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollInfo As ImGearScrollInfo

instance.UpdateScrollFrom(pageView, scrollInfo)
void UpdateScrollFrom(
   IImGearScrollableView pageView,
   ImGearScrollInfo scrollInfo
)
void UpdateScrollFrom(
   IImGearScrollableView* pageView,
   ImGearScrollInfo scrollInfo
)
void UpdateScrollFrom(
   IImGearScrollableView^ pageView,
   ImGearScrollInfo scrollInfo
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearScrollableView Interface
ImGearScrollInfo Structure


UpdateZoomFrom Method (IImGearPageDisplay)
Example

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : UpdateZoomFrom Method
ImGearZoomInfo object with new zoom attributes.
Updates image zoom attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub UpdateZoomFrom( _
   ByVal zoomInfo As ImGearZoomInfo _
)
'Usage

Dim instance As IImGearPageDisplay
Dim zoomInfo As ImGearZoomInfo

instance.UpdateZoomFrom(zoomInfo)
void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)

Parameters

zoomInfo
ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Get the current Zoom settings
ImGearZoomInfo igZoomInfo =
    imGearPageView.Display.GetZoomInfo(imGearPageView);
// Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Vertical.Fixed = true;
// Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2;
igZoomInfo.Vertical.Value *= 2;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
// Cause a redraw with the new zoom.
imGearPageView.Invalidate();
  • Visual Basic
'Get the current Zoom settings
Dim igZoomInfo As ImGearZoomInfo = _
    ImGearPageView1.Display.GetZoomInfo(ImGearPageView1)
'Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = True
igZoomInfo.Vertical.Fixed = True
'Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2
igZoomInfo.Vertical.Value *= 2
ImGearPageView1.Display.UpdateZoomFrom(igZoomInfo)
'Cause a redraw with the new zoom.
ImGearPageView1.Invalidate()
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearZoomInfo Structure


ZoomToRectangle Method (IImGearPageDisplay)
Example

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ZoomToRectangle Method
ImGearZoomInfo object with new zoom attributes.
Specified device rectangle.
Performs zooming to specified device rectangle and returns new zoom information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub ZoomToRectangle( _
   ByVal pageView As IImGearScrollableView, _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As IImGearPageDisplay
Dim pageView As IImGearScrollableView
Dim rect As ImGearRectangle

instance.ZoomToRectangle(pageView, rect)
void ZoomToRectangle(
   IImGearScrollableView pageView,
   ImGearRectangle rect
)
void ZoomToRectangle(
   IImGearScrollableView* pageView,
   ImGearRectangle rect
)
void ZoomToRectangle(
   IImGearScrollableView^ pageView,
   ImGearRectangle rect
)

Parameters

pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle.
Remarks
This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo.Fixed field to true, calculates and modifies ImGearZoomComponentInfo.Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Variable to toggle if user is currently selecting an area.
private bool m_bZoomToRectSelect = false;
// Set of points defining the selected area.
private ImGearPoint[] igPointsZoomToRect;
// Color of selection box.
private Color m_SelectorColor = Color.White;

// Method to return appropriate height for a specific width
// based upon the size of a scrollable view.
private int GetHeight(IImGearScrollableView igScrollableView, int Width)
{
    return Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width;
}

private void menuZoomToRect_Click(object sender, EventArgs e)
{
    // Menu item used to toggle if Zoom to Rectangle is on or not.
    menuZoomToRect.Checked = !menuZoomToRect.Checked;
}

private void imGearPageView1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (menuZoomToRect.Checked)
    {
        // Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = true;
        // Create a new pair of points to define the rectangle,
        // setting the first point to the current position.
        igPointsZoomToRect = new ImGearPoint[2];
        igPointsZoomToRect[0].X = e.X;
        igPointsZoomToRect[0].Y = e.Y;
        // Register method to draw the selection rectangle.
        imGearPageView.RegisterAfterDraw(
            new ImGearPageView.AfterDraw(DrawSelector));
    }
}

private void imGearPageView1_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Leave Zoom to Rectangle selection mode.
        imGearPageView.RegisterAfterDraw(null);
        m_bZoomToRectSelect = false;
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Create a rectangle based upon the 2 points.
        ImGearRectangle igRectangle = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        if (igRectangle.Width <= 1 || igRectangle.Height <= 1)
            return;
        // Zoom to the selected rectangle
        imGearPageView.Display.ZoomToRectangle(imGearPageView, igRectangle);
        imGearPageView.Invalidate();
        // Disable Zoom to Rectangle.
        menuZoomToRect.Checked = false;
    }
}

private void imGearPageView1_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Cause a redraw which will update the zoom selection rectangle.
        imGearPageView.Invalidate();
    }
}

private void DrawSelector(System.Drawing.Graphics gr)
{
    if (m_bZoomToRectSelect)
    {
        // Create a new pen to draw dotted lines.
        Pen pen = new Pen(m_SelectorColor);
        pen.DashStyle = DashStyle.Dot;
        // Define the currently selected zoom rectangle.
        ImGearRectangle igRectangleZoom = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top,
            igRectangleZoom.Width, igRectangleZoom.Height);
    }
}
  • Visual Basic
'Variable to toggle if user is currently selecting an area.
Private m_bZoomToRectSelect As Boolean = False
'Set of points defining the selected area.
Private igPointsZoomToRect() As ImGearPoint
'Color of selection box.
Private m_SelectorColor As Color = Color.White

'Function to return appropriate height for a specific width
' based upon the size of a scrollable view.
Private Function GetHeight(ByVal igScrollableView As IImGearScrollableView, ByVal Width As Integer) As Integer
    GetHeight = Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width
End Function

Private Sub menuZoomtoRect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles menuZoomtoRect.Click
    menuZoomtoRect.Checked = Not menuZoomtoRect.Checked
End Sub

Private Sub ImGearPageView1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseDown
    If (menuZoomtoRect.Checked) Then
        'Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = True
        'Create a new pair of points to define the rectangle,
        ' setting the first point to the current position.
        ReDim igPointsZoomToRect(2)
        igPointsZoomToRect(0).X = e.X
        igPointsZoomToRect(0).Y = e.Y
        'Register function to draw the selection rectangle.
        ImGearPageView1.RegisterAfterDraw( _
            New ImGearPageView.AfterDraw(AddressOf DrawSelector))
    End If
End Sub

Private Sub ImGearPageView1_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseUp
    If (m_bZoomToRectSelect) Then
        'Leave Zoom to Rectangle selection mode.
        ImGearPageView1.RegisterAfterDraw(Nothing)
        m_bZoomToRectSelect = False
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Create a rectangle based upon the 2 points.
        Dim igRectangle As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        If (igRectangle.Width <= 1 Or igRectangle.Height <= 1) Then
            Return
        End If
        'Zoom to the selected rectangle
        ImGearPageView1.Display.ZoomToRectangle(ImGearPageView1, igRectangle)
        ImGearPageView1.Invalidate()
        'Disable Zoom to Rectangle.
        menuZoomtoRect.Checked = False
    End If
End Sub

Private Sub ImGearPageView1_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseMove
    If (m_bZoomToRectSelect) Then
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Cause a redraw which will update the zoom selection rectangle.
        ImGearPageView1.Invalidate()
    End If
End Sub

Private Sub DrawSelector(ByVal gr As System.Drawing.Graphics)
    If (m_bZoomToRectSelect) Then
        'Create a new pen to draw dotted lines.
        Dim pen As Pen = New Pen(m_SelectorColor)
        Pen.DashStyle = DashStyle.Dot
        'Define the currently selected zoom rectangle.
        Dim igRectangleZoom As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top, igRectangleZoom.Width, igRectangleZoom.Height)
    End If
End Sub
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearScrollableView Interface
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

IImGearPageDisplay Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearPageDisplay Interface

For a list of all members of this type, see IImGearPageDisplay members.

Public Properties
 | Name | Description
Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Property | Background | Gets background drawing attributes.
Property | Channels | Gets the list of extra channels and their display options.
Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Property | Layout | Gets image display layout settings.
Property | LUT | Gets or sets a display lookup table.
Property | Orientation | Gets image orientation attributes.
Property | Page | Gets or sets ImGearPage object associated with this display page.
Property | Resampling | Gets re-sampling attributes.
Top
See Also

Reference

IImGearPageDisplay Interface
ImageGear.Display Namespace


AntiAliasing Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : AntiAliasing Property
Gets bitonal anti-aliasing settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property AntiAliasing As IImGearAntiAlias
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearAntiAlias

value = instance.AntiAliasing
IImGearAntiAlias AntiAliasing {get;}
__property IImGearAntiAlias* get_AntiAliasing();
property IImGearAntiAlias^ AntiAliasing {
   IImGearAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearAntiAlias Interface


ARTPage Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ARTPage Property
Gets or sets ImGearAnnotationPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ARTPage As ImGearAnnotationPage
'Usage

Dim instance As IImGearPageDisplay
Dim value As ImGearAnnotationPage

instance.ARTPage = value

value = instance.ARTPage
ImGearAnnotationPage ARTPage {get; set;}
__property ImGearAnnotationPage* get_ARTPage();
__property void set_ARTPage(
   ImGearAnnotationPage* value
);
property ImGearAnnotationPage^ ARTPage {
   ImGearAnnotationPage^ get();
   void set (    ImGearAnnotationPage^ value);
}

Property Value

ImGearAnnotationPage class.
Remarks
Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class ImageGear.ART.ImGearARTPage class, defined in ImageGear22.Art assembly.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


Background Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Background Property
Gets background drawing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Background As IImGearBackground
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearBackground

value = instance.Background
IImGearBackground Background {get;}
__property IImGearBackground* get_Background();
property IImGearBackground^ Background {
   IImGearBackground^ get();
}

Property Value

IImGearBackground interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearBackground Interface


Channels Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Channels Property
Gets the list of extra channels and their display options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Channels As ImGearDisplayChannels
'Usage

Dim instance As IImGearPageDisplay
Dim value As ImGearDisplayChannels

value = instance.Channels
ImGearDisplayChannels Channels {get;}
__property ImGearDisplayChannels* get_Channels();
property ImGearDisplayChannels^ Channels {
   ImGearDisplayChannels^ get();
}

Property Value

ImageGear.Core.ImGearDisplayChannels class object.
Remarks
This property can be used to enable or disable image extra channels for display. Please note, this property cannot be used to disable base image channels for display.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearDisplayChannels Class


ColorAntiAliasing Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ColorAntiAliasing Property
Gets color anti-aliasing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ColorAntiAliasing As IImGearColorAntiAlias
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearColorAntiAlias

value = instance.ColorAntiAliasing
IImGearColorAntiAlias ColorAntiAliasing {get;}
__property IImGearColorAntiAlias* get_ColorAntiAliasing();
property IImGearColorAntiAlias^ ColorAntiAliasing {
   IImGearColorAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearAntiAlias Interface


DICOMDisplaySettings Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : DICOMDisplaySettings Property
Gets or sets the DICOM specific display contrast settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property DICOMDisplaySettings As IImGearDICOMDisplaySettings
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearDICOMDisplaySettings

instance.DICOMDisplaySettings = value

value = instance.DICOMDisplaySettings
IImGearDICOMDisplaySettings DICOMDisplaySettings {get; set;}
__property IImGearDICOMDisplaySettings* get_DICOMDisplaySettings();
__property void set_DICOMDisplaySettings(
   IImGearDICOMDisplaySettings* value
);
property IImGearDICOMDisplaySettings^ DICOMDisplaySettings {
   IImGearDICOMDisplaySettings^ get();
   void set (    IImGearDICOMDisplaySettings^ value);
}

Property Value

ImageGear.Core.IImGearDICOMDisplaySettings interface.
Remarks
DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of ImageGear.Core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An ImageGear.Core.IImGearDICOMDisplaySettings interface object can be attached to an ImageGear.Core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImageGear.Core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This property affects grayscale images with bit depths from 2 to 16. Type of this property is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast ImageGear.Core.IImGearDICOMDisplaySettings interface to the actual class ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class. The default value is null.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearDICOMDisplaySettings Interface
ImGearDICOMDisplaySettings Class


Layout Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Layout Property
Gets image display layout settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Layout As IImGearLayout
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearLayout

value = instance.Layout
IImGearLayout Layout {get;}
__property IImGearLayout* get_Layout();
property IImGearLayout^ Layout {
   IImGearLayout^ get();
}

Property Value

IImGearLayout interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearLayout Interface


LUT Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : LUT Property
Gets or sets a display lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property LUT As ImGearMultichannelLUT
'Usage

Dim instance As IImGearPageDisplay
Dim value As ImGearMultichannelLUT

instance.LUT = value

value = instance.LUT
ImGearMultichannelLUT LUT {get; set;}
__property ImGearMultichannelLUT* get_LUT();
__property void set_LUT(
   ImGearMultichannelLUT* value
);
property ImGearMultichannelLUT^ LUT {
   ImGearMultichannelLUT^ get();
   void set (    ImGearMultichannelLUT^ value);
}

Property Value

ImageGear.Core.ImGearMultichannelLUT class.
Remarks
This property only supports ImageGear.Core.ImGearRGBLUT class objects.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearMultichannelLUT Class


Orientation Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Orientation Property
Gets image orientation attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Orientation As IImGearOrientation
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearOrientation

value = instance.Orientation
IImGearOrientation Orientation {get;}
__property IImGearOrientation* get_Orientation();
property IImGearOrientation^ Orientation {
   IImGearOrientation^ get();
}

Property Value

ImageGear.Core.ImGearOrientation structure.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearOrientation Structure


Page Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Page Property
Gets or sets ImGearPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Page As ImGearPage
'Usage

Dim instance As IImGearPageDisplay
Dim value As ImGearPage

instance.Page = value

value = instance.Page
ImGearPage Page {get; set;}
__property ImGearPage* get_Page();
__property void set_Page(
   ImGearPage* value
);
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

Valid ImageGear.Core.ImGearPage class object or null.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
ImGearPage Class


Resampling Property (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : Resampling Property
Gets re-sampling attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Resampling As IImGearResample
'Usage

Dim instance As IImGearPageDisplay
Dim value As IImGearResample

value = instance.Resampling
IImGearResample Resampling {get;}
__property IImGearResample* get_Resampling();
property IImGearResample^ Resampling {
   IImGearResample^ get();
}

Property Value

IImGearResample interface object.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
IImGearResample Interface


%%PageItemTitle%% $$Events$$

IImGearPageDisplay Interface Events

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearPageDisplay Interface

For a list of all members of this type, see IImGearPageDisplay members.

Public Events
 | Name | Description
Event | LUTUpdated | Occurs when the lookup table is updated.
Event | PageScrolled | Occurs when a page is scrolled.
Event | PageZoomed | Occurs when a page is zoomed.
Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visibile or enabled state changes.
Top
See Also

Reference

IImGearPageDisplay Interface
ImageGear.Display Namespace


LUTUpdated Event (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : LUTUpdated Event
Occurs when the lookup table is updated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event LUTUpdated As EventHandler
'Usage

Dim instance As IImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.LUTUpdated, handler
event EventHandler LUTUpdated
__event EventHandler* LUTUpdated
event EventHandler^ LUTUpdated
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


PageScrolled Event (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : PageScrolled Event
Occurs when a page is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event PageScrolled As EventHandler
'Usage

Dim instance As IImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.PageScrolled, handler
event EventHandler PageScrolled
__event EventHandler* PageScrolled
event EventHandler^ PageScrolled
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


PageZoomed Event (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : PageZoomed Event
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event PageZoomed As EventHandler
'Usage

Dim instance As IImGearPageDisplay
Dim handler As EventHandler

AddHandler instance.PageZoomed, handler
event EventHandler PageZoomed
__event EventHandler* PageZoomed
event EventHandler^ PageZoomed
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


ScrollChanged Event (IImGearPageDisplay)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearPageDisplay Interface : ScrollChanged Event
Occurs when a page is scrolled or when the scrollbar visibile or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event ScrollChanged As ImGearScrollChangedEventHandler
'Usage

Dim instance As IImGearPageDisplay
Dim handler As ImGearScrollChangedEventHandler

AddHandler instance.ScrollChanged, handler
event ImGearScrollChangedEventHandler ScrollChanged
__event ImGearScrollChangedEventHandler* ScrollChanged
event ImGearScrollChangedEventHandler^ ScrollChanged
Event Data

The event handler receives an argument of type ImGearScrollChangedEventArgs containing data related to this event. The following ImGearScrollChangedEventArgs properties provide information specific to this event.

Property | Description
IsEnabled | Gets a value indicating whether the scrollbar is enabled.
IsVisible | Gets a value indicating whether the scrollbar is visible.
Redraw | Gets a value indicating whether or not the view should be redrawn.
ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
ScrollChangeType | Gets the type of scrollbar change.
ScrollInformation | Gets the scrolling information.
See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

IImGearResample Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearResample Interface
Provides access to re-sampling attributes.
Object Model
IImGearResample Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearResample
   Inherits IImGearDisplayObject
'Usage

Dim instance As IImGearResample
public interface IImGearResample : IImGearDisplayObject
public __gc __interface IImGearResample : public IImGearDisplayObject
public interface class IImGearResample : public IImGearDisplayObject
See Also

Reference

IImGearResample Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearResample Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearResample Interface

The following tables list the members exposed by IImGearResample.

Public Properties
 | Name | Description
Property | Method | Gets or sets a re-sampling method to use.
Top
See Also

Reference

IImGearResample Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearResample Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearResample Interface

For a list of all members of this type, see IImGearResample members.

See Also

Reference

IImGearResample Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Properties$$

IImGearResample Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearResample Interface

For a list of all members of this type, see IImGearResample members.

Public Properties
 | Name | Description
Property | Method | Gets or sets a re-sampling method to use.
Top
See Also

Reference

IImGearResample Interface
ImageGear.Display Namespace


Method Property (IImGearResample)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearResample Interface : Method Property
Gets or sets a re-sampling method to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Method As ImGearResampleModes
'Usage

Dim instance As IImGearResample
Dim value As ImGearResampleModes

instance.Method = value

value = instance.Method
ImGearResampleModes Method {get; set;}
__property ImGearResampleModes get_Method();
__property void set_Method(
   ImGearResampleModes value
);
property ImGearResampleModes Method {
   ImGearResampleModes get();
   void set (    ImGearResampleModes value);
}

Property Value

ImGearResampleModes enumeration value.
Remarks
This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in.
See Also

Reference

IImGearResample Interface
IImGearResample Members
ImGearResampleModes Enumeration


%%PageItemTitle%%

IImGearScrollableView Interface
Members

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearScrollableView Interface
Obtains all information required by IG display code and modifies some attributes of underlying window (scrollbars state).
Object Model
IImGearScrollableView InterfaceImGearRectangle StructureImGearSize Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearScrollableView
'Usage

Dim instance As IImGearScrollableView
public interface IImGearScrollableView
public __gc __interface IImGearScrollableView
public interface class IImGearScrollableView
Remarks
This interface is designed to separate IG display API from .NET windows and forms. Any object implementing this interface can be used. A null value can also be specified. In this case all required information will be obtained from Graphics object. In all display API calls IImGearScrollableView parameter is accompanied with Graphics object. To draw on a printer, null value should be passed to IImGearScrollableView parameter.
See Also

Reference

IImGearScrollableView Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

IImGearScrollableView Interface Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearScrollableView Interface

The following tables list the members exposed by IImGearScrollableView.

Public Properties
 | Name | Description
Property | ClientRectangle | Gets a rectangle of the client area.
Top
Public Methods
 | Name | Description
Method | EnableScrollBar | Enables or disables the scrollbars associated with window.
Method | GetScrollBarDimensions | Returns width and height dimensions of the windows scroll bar.
Method | GetScrollParams | Obtains the attributes of the scrollbar specified.
Method | IsScrollBarEnabled | Returns a value indicating whether the scrollbar is enabled.
Method | IsScrollBarVisible | Returns a value indicating whether the scrollbar is visible.
Method | SetScrollParams | Updates the state of specified scrollbar with new values.
Method | ShowScrollBar | Changes visibility state of scrollbars associated with window.
Top
See Also

Reference

IImGearScrollableView Interface
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

IImGearScrollableView Interface Methods

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearScrollableView Interface

For a list of all members of this type, see IImGearScrollableView members.

Public Methods
 | Name | Description
Method | EnableScrollBar | Enables or disables the scrollbars associated with window.
Method | GetScrollBarDimensions | Returns width and height dimensions of the windows scroll bar.
Method | GetScrollParams | Obtains the attributes of the scrollbar specified.
Method | IsScrollBarEnabled | Returns a value indicating whether the scrollbar is enabled.
Method | IsScrollBarVisible | Returns a value indicating whether the scrollbar is visible.
Method | SetScrollParams | Updates the state of specified scrollbar with new values.
Method | ShowScrollBar | Changes visibility state of scrollbars associated with window.
Top
See Also

Reference

IImGearScrollableView Interface
ImageGear.Display Namespace


EnableScrollBar Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : EnableScrollBar Method
Specifies the scrollbar whose attributes are changed.
Enable (true) or disable (false) scrollbar.
Enables or disables the scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")>
Sub EnableScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal state As Boolean _
)
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim state As Boolean

instance.EnableScrollBar(scrollBarType, state)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Enable (true) or disable (false) scrollbar.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration


GetScrollBarDimensions Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : GetScrollBarDimensions Method
Specifies the scrollbar whose attributes are requested.
Returns width and height dimensions of the windows scroll bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetScrollBarDimensions( _
   ByVal scrollBarType As ImGearScrollBarType _
) As ImGearSize
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim value As ImGearSize

value = instance.GetScrollBarDimensions(scrollBarType)
ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)
ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)
ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

ImageGear.Core.ImGearSize structure.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration
ImGearSize Structure


GetScrollParams Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : GetScrollParams Method
Specifies the scrollbar whose attributes are requested.
Output parameter; horizontal or vertical field of this parameter is updated with requested information.
Obtains the attributes of the scrollbar specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub GetScrollParams( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByRef scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim scrollInfo As ImGearScrollInfo

instance.GetScrollParams(scrollBarType, scrollInfo)
void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ref ImGearScrollInfo scrollInfo
)
void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ref ImGearScrollInfo scrollInfo
)
void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo% scrollInfo
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
Output parameter; horizontal or vertical field of this parameter is updated with requested information.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration
ImGearScrollInfo Structure


IsScrollBarEnabled Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : IsScrollBarEnabled Method
Specifies the scrollbar whose attributes are requested.
Returns a value indicating whether the scrollbar is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsScrollBarEnabled( _
   ByVal scrollBarType As ImGearScrollBarType _
) As Boolean
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim value As Boolean

value = instance.IsScrollBarEnabled(scrollBarType)
bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)
bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)
bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

Boolean value.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration


IsScrollBarVisible Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : IsScrollBarVisible Method
Specifies the scrollbar whose attributes are requested.
Returns a value indicating whether the scrollbar is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsScrollBarVisible( _
   ByVal scrollBarType As ImGearScrollBarType _
) As Boolean
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim value As Boolean

value = instance.IsScrollBarVisible(scrollBarType)
bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)
bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)
bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

Boolean value.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration


SetScrollParams Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : SetScrollParams Method
Specifies the scrollbar whose attributes are requested.
New scrollbar state.
Specifies whether or not to redraw image in window.
Updates the state of specified scrollbar with new values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")>
Sub SetScrollParams( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollInfo As ImGearScrollInfo, _
   ByVal redraw As Boolean _
)
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim scrollInfo As ImGearScrollInfo
Dim redraw As Boolean

instance.SetScrollParams(scrollBarType, scrollInfo, redraw)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
New scrollbar state.
redraw
Specifies whether or not to redraw image in window.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration
ImGearScrollInfo Structure


ShowScrollBar Method (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : ShowScrollBar Method
Specifies the scrollbar whose attributes are changed.
Show (true) or hide (false) scrollbar.
Changes visibility state of scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")>
Sub ShowScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal state As Boolean _
)
'Usage

Dim instance As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim state As Boolean

instance.ShowScrollBar(scrollBarType, state)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ScrollChanged event of the page display to receive notifications when the scroll changes.")]
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Show (true) or hide (false) scrollbar.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearScrollBarType Enumeration


%%PageItemTitle%% $$Properties$$

IImGearScrollableView Interface Properties

ImageGear22.Core Assembly > ImageGear.Display Namespace : IImGearScrollableView Interface

For a list of all members of this type, see IImGearScrollableView members.

Public Properties
 | Name | Description
Property | ClientRectangle | Gets a rectangle of the client area.
Top
See Also

Reference

IImGearScrollableView Interface
ImageGear.Display Namespace


ClientRectangle Property (IImGearScrollableView)

ImageGear22.Core Assembly > ImageGear.Display Namespace > IImGearScrollableView Interface : ClientRectangle Property
Gets a rectangle of the client area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ClientRectangle As ImGearRectangle
'Usage

Dim instance As IImGearScrollableView
Dim value As ImGearRectangle

value = instance.ClientRectangle
ImGearRectangle ClientRectangle {get;}
__property ImGearRectangle get_ClientRectangle();
property ImGearRectangle ClientRectangle {
   ImGearRectangle get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members
ImGearRectangle Structure


%%PageItemTitle%%

ImGearScrollChangedEventHandler Delegate

ImageGear22.Core Assembly > ImageGear.Display Namespace : ImGearScrollChangedEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ImGearPageDisplay.ScrollChanged events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearScrollChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearScrollChangedEventArgs _
)
'Usage

Dim instance As New ImGearScrollChangedEventHandler(AddressOf HandlerMethod)
public delegate void ImGearScrollChangedEventHandler(
   object sender,
   ImGearScrollChangedEventArgs e
)
public: __gc __delegate void ImGearScrollChangedEventHandler(
   Object* sender,
   ImGearScrollChangedEventArgs* e
)
public delegate void ImGearScrollChangedEventHandler(
   Object^ sender,
   ImGearScrollChangedEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearScrollChangedEventHandler Members
ImageGear.Display Namespace


ImageGear.Formats Namespace (ImageGear22.Core)
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats Namespace

ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.

Classes
 | Class | Description
Class | ImGearCommonMetadata | Provides access to metadata that is common for all format filters.
Class | ImGearControlParameter | Provides access to the attributes of a control parameter.
Class | ImGearFileFilters | Provides access to formats settings.
Class | ImGearFileFormats | Main class for working with file formats.
Class | ImGearFormatMetadata | This is the base class for the Simplified Metadata API accessor classes. For more information about Simplified Metadata API usage, see Simplified Access to Non-Image Data.
Class | ImGearFormatParameters | Allows you to manage format's control parameters.
Class | ImGearLoadOptions | Specifies additional loading options, such as thumbnail loading or loading an image specifying its format explicitly.
Class | ImGearNativeDataTypeHelper | Helps to work with ImageGear native data types associated with file formats metadata.
Class | ImGearRasterSaveOptions | Provides rasterization options for saving.
Class | ImGearSaveOptions | Specifies additional saving options.
Class | ImGearSaveThumbnailOptions | Specifies thumbnail attributes such as width and height to be used when saving a thumbnail.
Class | ImGearWebStream | Provides a specialized stream for loading of images from internet.
Interfaces
 | Interface | Description
Interface | IImGearFormat | Base interface for all file format filters.
Enumerations
 | Enumeration | Description
Enumeration | ImGearBMPTagIDs | Lists all BMP tag identifiers.
Enumeration | ImGearBTRTagIDs | Lists all BTR tag identifiers.
Enumeration | ImGearCALTagIDs | Lists all CAL tag identifiers.
Enumeration | ImGearCIFFAFInfoTagIDs | Lists all CIFF AF Info tag identifiers.
Enumeration | ImGearCIFFCanonCameraSettingsTagIDs | Lists all CIFF Canon Camera Settings tag identifiers.
Enumeration | ImGearCIFFFocalLengthTagIDs | Lists all CIFF Focal Length tag identifiers.
Enumeration | ImGearCIFFImageInfoTagIDs | Lists all CIFF Image Info tag identifiers.
Enumeration | ImGearCIFFShotInfoTagIDs | Lists all CIFF Shot Info tag identifiers.
Enumeration | ImGearCIFFTagIDs | Lists all CIFF tag identifiers.
Enumeration | ImGearCLPTagIDs | Lists all CLP tag identifiers.
Enumeration | ImGearCompressions | Lists all ImageGear supported compressions.
Enumeration | ImGearCUTTagIDs | Lists all CUT tag identifiers.
Enumeration | ImGearDCRAWTagIDs | Lists all Digital Camera RAW tag identifiers.
Enumeration | ImGearDCXTagIDs | Lists all DCX tag identifiers.
Enumeration | ImGearDisplayInfoTagIDs | Lists all Photoshop Display Info tag identifiers.
Enumeration | ImGearEXIFFPXRTagIDs | Lists all EXIF FPXR tag identifiers.
Enumeration | ImGearEXIFGPSTagIDs | Lists all EXIF GPS tag identifiers.
Enumeration | ImGearEXIFInterOpTagIDs | Lists all EXIF Interoperability tag identifiers.
Enumeration | ImGearEXIFMakerNoteFujiTagIDs | Lists all Fujifilm EXIF MakerNote tag identifiers.
Enumeration | ImGearEXIFMakerNoteNikonType1TagIDs | Lists all Nikon EXIF MakerNote Type 1 tag identifiers.
Enumeration | ImGearEXIFMakerNoteNikonType2TagIDs | Lists all Nikon EXIF MakerNote Type 2 tag identifiers.
Enumeration | ImGearEXIFMakerNoteOlympusTagIDs | Lists all Olympus EXIF MakerNote tag identifiers.
Enumeration | ImGearEXIFMakerNotePentaxTagIDs | Lists all Pentax EXIF MakerNote tag identifiers.
Enumeration | ImGearEXIFMakerNoteTagIDs | Lists all general EXIF MakerNote tag identifiers.
Enumeration | ImGearEXIFMakerNoteType | Lists all EXIF MakerNote types.
Enumeration | ImGearEXIFTagIDs | Lists all EXIF tag identifiers.
Enumeration | ImGearFillOrder | Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).
Enumeration | ImGearFormats | Lists all ImageGear supported file formats.
Enumeration | ImGearGEMTagIDs | Lists all GEM tag identifiers.
Enumeration | ImGearGIFTagIDs | Lists all GIF tag identifiers.
Enumeration | ImGearHDPhotoTagIDs | Lists all HD Photo tag identifiers.
Enumeration | ImGearICATagIDs | Lists all ICA tag identifiers.
Enumeration | ImGearICOTagIDs | Lists all ICO tag identifiers.
Enumeration | ImGearIFFTagIDs | Lists all IFF tag identifiers.
Enumeration | ImGearIMGTagIDs | Lists all IMG tag identifiers.
Enumeration | ImGearIMTTagIDs | Lists all IMT tag identifiers.
Enumeration | ImGearIPTCAppObjAttrTags | Lists IPTC Application Object Attributes.
Enumeration | ImGearIPTCAppObjTypeTags | Lists IPTC Application Object Types.
Enumeration | ImGearIPTCRecord1EnvDatasetTags | Lists all IPTC Record 1 (Envelope) DataSet tags.
Enumeration | ImGearIPTCRecord2AppDatasetTags | Lists all IPTC Record 2 (Application) DataSet tags.
Enumeration | ImGearIPTCRecord3PhotoDatasetTags | Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags.
Enumeration | ImGearIPTCRecord7PreObjDatasetTags | Lists all IPTC Record 7 (Pre-Object) DataSet tags.
Enumeration | ImGearIPTCRecord8ObjDatasetTags | Lists all IPTC Record 8 (Object) DataSet tags.
Enumeration | ImGearIPTCRecord9PostObjDatasetTags | Lists all IPTC Record 9 (Post-Object) DataSet tags.
Enumeration | ImGearIPTCRecordTags | Lists all IPTC Record tags.
Enumeration | ImGearIPTCTags | Lists all general IPTC tags.
Enumeration | ImGearJP2CodestreamTagIDs | Lists all JP2Codestream tag identifiers.
Enumeration | ImGearJP2FileFormatTagIDs | Lists all JP2FileFormat tag identifiers.
Enumeration | ImGearJP2TagIDs | Lists all JP2 tag identifiers.
Enumeration | ImGearJPEGTagIDs | Lists all JPEG tag identifiers.
Enumeration | ImGearJPXTagIDs | Lists all JPX tag identifiers.
Enumeration | ImGearKFXTagIDs | Lists all KFX tag identifiers.
Enumeration | ImGearLVTagIDs | Lists all LV tag identifiers.
Enumeration | ImGearMakerNoteOlympusApplicationModeIFD2TagIDs | Lists all Olympus application mode IFD 2 MakerNote types.
Enumeration | ImGearMakerNoteOlympusApplicationModeIFDTagIDs | Lists all Olympus application mode IFD MakerNote types.
Enumeration | ImGearMakerNoteOlympusCameraModeIFDTagIDs | Lists all Olympus camera mode IFD MakerNote types.
Enumeration | ImGearMakerNoteOlympusCSerieSettingsTagIDs | Lists all Olympus C-models serie settings IFD MakerNote types.
Enumeration | ImGearMakerNoteOlympusDebugIFDTagIDs | Lists all Olympus debug IFD MakerNote types.
Enumeration | ImGearMakerNoteOlympusHardwareIFDTagIDs | Lists all Olympus hardware IFD MakerNote types.
Enumeration | ImGearMakerNoteOlympusImageProcessorTagIDs | Lists all Olympus image processor IFD MakerNote types.
Enumeration | ImGearMetadataFormats | Lists all ImageGear supported metadata formats.
Enumeration | ImGearMJ2TagIDs | Reserved for future use.
Enumeration | ImGearMSPTagIDs | Lists all MSP tag identifiers.
Enumeration | ImGearNativeDataTypes | Specifies the data types that file formats use to store metadata values.
Enumeration | ImGearNCRTagIDs | Lists all NCR tag identifiers.
Enumeration | ImGearPBMTagIDs | Lists all PBM tag identifiers.
Enumeration | ImGearPCDTagIDs | Lists all PCD tag identifiers.
Enumeration | ImGearPCXTagIDs | Lists all PCX tag identifiers.
Enumeration | ImGearPDFTagIDs | Lists all PDF tag identifiers.
Enumeration | ImGearPhotoshopAdditionalLayerInfoTagIDs | Lists all Photoshop Additional Layer Info tag identifiers.
Enumeration | ImGearPhotoshopLayerInfoTagIDs | Lists all Photoshop Layer Info tag identifiers.
Enumeration | ImGearPhotoshopLayerMaskInfoTagIDs | Lists all Photoshop Layer Mask Info tag identifiers.
Enumeration | ImGearPhotoshopResourceGenericTagIDs | Lists all Photoshop Resource Generic tag identifiers.
Enumeration | ImGearPHOTOSHOPTagIDs | Lists all Photoshop tag identifiers.
Enumeration | ImGearPhotoshopVersionInfoTagIDs | Lists all Photoshop Version Info tag identifiers.
Enumeration | ImGearPNGTagIDs | Lists all PNG tag identifiers.
Enumeration | ImGearPSDTagIDs | Lists all PSD tag identifiers.
Enumeration | ImGearPSTagIDs | Lists all PostScript tag identifiers.
Enumeration | ImGearPTOCATagIDs | Lists all PTOCA tag identifiers.
Enumeration | ImGearRASTagIDs | Lists all RAS tag identifiers.
Enumeration | ImGearRasterConversionModes | Lists all raster conversion modes for image saving.
Enumeration | ImGearRectangleInfoTagIDs | Lists all Photoshop Rectangle Info tag ids.
Enumeration | ImGearResolutionInfoTagIDs | Lists all Photoshop Resolution Info tag ids.
Enumeration | ImGearSavingFormats | Lists all ImageGear saving formats.
Enumeration | ImGearSavingModes | Lists all saving modes.
Enumeration | ImGearSCITagIDs | Lists all SCI tag identifiers.
Enumeration | ImGearSGITagIDs | Lists all SGI tag identifiers.
Enumeration | ImGearTGATagIDs | Lists all TGA tag identifiers.
Enumeration | ImGearThumbnailInfoTagIDs | Lists all Photoshop Thumbnail Info tag identifiers.
Enumeration | ImGearTIFTagIDs | Lists all TIF tag identifiers.
Enumeration | ImGearWBMPTagIDs | Lists all WBMP tag identifiers.
Enumeration | ImGearWPGTagIDs | Lists all WPG tag identifiers.
Enumeration | ImGearXBMTagIDs | Lists all XBM tag identifiers.
Enumeration | ImGearXMPTagIDs | Lists all XMP tag identifiers.
Enumeration | ImGearXPMTagIDs | Lists all XPM tag identifiers.
Enumeration | ImGearXPSTagIDs | Lists all XPS tag identifiers.
Enumeration | ImGearXWDTagIDs | Lists all XWD tag identifiers.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats Namespace (ImageGear22.Core) Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearControlParameter
ImageGear.Formats.ImGearFileFilters
ImageGear.Formats.ImGearFileFormats
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.ImGearCommonMetadata
ImageGear.Formats.ImGearFormatParameters
ImageGear.Formats.ImGearLoadOptions
ImageGear.Formats.ImGearNativeDataTypeHelper
ImageGear.Formats.ImGearSaveOptions
ImageGear.Formats.ImGearRasterSaveOptions
ImageGear.Formats.ImGearSaveThumbnailOptions
System.MarshalByRefObject
System.IO.Stream
ImageGear.Formats.ImGearWebStream
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearCommonMetadata Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCommonMetadata Class
Provides access to metadata that is common for all format filters.
Object Model
ImGearCommonMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearCommonMetadata
   Inherits ImGearFormatMetadata
'Usage

Dim instance As ImGearCommonMetadata
public class ImGearCommonMetadata : ImGearFormatMetadata
public __gc class ImGearCommonMetadata : public ImGearFormatMetadata
public ref class ImGearCommonMetadata : public ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.ImGearCommonMetadata

See Also

Reference

ImGearCommonMetadata Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearCommonMetadata Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCommonMetadata Class

The following tables list the members exposed by ImGearCommonMetadata.

Public Properties
 | Name | Description
Public Property | ColorProfile | Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.
Public Property | Compression | Gets or sets compression of the file page from which the image was loaded.
Public Property | ResolutionLayersCount | Gets or sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions.
Top
See Also

Reference

ImGearCommonMetadata Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Properties$$

ImGearCommonMetadata Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCommonMetadata Class

For a list of all members of this type, see ImGearCommonMetadata members.

Public Properties
 | Name | Description
Public Property | ColorProfile | Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.
Public Property | Compression | Gets or sets compression of the file page from which the image was loaded.
Public Property | ResolutionLayersCount | Gets or sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions.
Top
See Also

Reference

ImGearCommonMetadata Class
ImageGear.Formats Namespace


ColorProfile Property (ImGearCommonMetadata)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearCommonMetadata Class : ColorProfile Property
Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorProfile As Byte()
'Usage

Dim instance As ImGearCommonMetadata
Dim value() As Byte

value = instance.ColorProfile
public byte[] ColorProfile {get;}
public: __property byte[]* get_ColorProfile();
public:
property array<byte>^ ColorProfile {
   array<byte>^ get();
}

Property Value

Byte array value.
Remarks
This property returns the color profile data of the file page from which the image was loaded. It returns null if the file page did not contain a profile or if the format filter does not support the loading of color profiles. This property also returns null (source file page color profile is undefined) if the page was created using a ImageGear.Core.ImGearRasterPage class or ImageGear.Core.ImGearVectorPage class constructor, or using an image processing method.

Note: This property is not updated during image conversions such as profile or colorspace conversions.

The property does not have a Set accessor. On image writing, ImageGear ignores this property, and uses the profile attached to the image DIB.

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


Compression Property (ImGearCommonMetadata)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearCommonMetadata Class : Compression Property
Gets or sets compression of the file page from which the image was loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As Nullable(Of ImGearCompressions)
'Usage

Dim instance As ImGearCommonMetadata
Dim value As Nullable(Of ImGearCompressions)

instance.Compression = value

value = instance.Compression
public Nullable<ImGearCompressions> Compression {get; set;}
public: __property Nullable<ImGearCompressions> get_Compression();
public: __property void set_Compression(
   Nullable<ImGearCompressions> value
);
public:
property Nullable<ImGearCompressions> Compression {
   Nullable<ImGearCompressions> get();
   void set (    Nullable<ImGearCompressions> value);
}

Property Value

Nullable (boxed) ImGearCompressions enumeration value.
Remarks
If the page was created using ImageGear.Core.ImGearRasterPage class or ImageGear.Core.ImGearVectorPage class constructor, or using an image processing method, this property returns null (source file page compression is undefined).
See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members
ImGearCompressions Enumeration
ImGearRasterPage Class
ImGearVectorPage Class


ResolutionLayersCount Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearCommonMetadata Class : ResolutionLayersCount Property
Gets or sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionLayersCount As Nullable(Of Integer)
'Usage

Dim instance As ImGearCommonMetadata
Dim value As Nullable(Of Integer)

instance.ResolutionLayersCount = value

value = instance.ResolutionLayersCount
public Nullable<int> ResolutionLayersCount {get; set;}
public: __property Nullable<int> get_ResolutionLayersCount();
public: __property void set_ResolutionLayersCount(
   Nullable<int> value
);
public:
property Nullable<int> ResolutionLayersCount {
   Nullable<int> get();
   void set (    Nullable<int> value);
}

Property Value

Nullable (boxed) Integer value. See Also: ImageGear.Core.ImGearPage class.
Remarks
Currently, only PCD format sets this property.
See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

ImGearControlParameter Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearControlParameter Class
Provides access to the attributes of a control parameter.
Object Model
ImGearControlParameter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearControlParameter
'Usage

Dim instance As ImGearControlParameter
public sealed class ImGearControlParameter
public __gc __sealed class ImGearControlParameter
public ref class ImGearControlParameter sealed
Remarks
Control parameters affect the way images are loaded and saved.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearControlParameter

See Also

Reference

ImGearControlParameter Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearControlParameter Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearControlParameter Class

The following tables list the members exposed by ImGearControlParameter.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the parameter.
Public Property | Value | Gets or sets current value of the parameter.
Top
Public Methods
 | Name | Description
Public Method | GetDefaultValue | Gets default value of the parameter.
Public Method | SetToDefault | Sets parameter to its default value.
Top
See Also

Reference

ImGearControlParameter Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearControlParameter Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearControlParameter Class

For a list of all members of this type, see ImGearControlParameter members.

Public Methods
 | Name | Description
Public Method | GetDefaultValue | Gets default value of the parameter.
Public Method | SetToDefault | Sets parameter to its default value.
Top
See Also

Reference

ImGearControlParameter Class
ImageGear.Formats Namespace


GetDefaultValue Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearControlParameter Class : GetDefaultValue Method
Gets default value of the parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDefaultValue() As Object
'Usage

Dim instance As ImGearControlParameter
Dim value As Object

value = instance.GetDefaultValue()
public object GetDefaultValue()
public: Object* GetDefaultValue();
public:
Object^ GetDefaultValue();

Return Value

Object containing parameter's value.
See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


SetToDefault Method (ImGearControlParameter)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearControlParameter Class : SetToDefault Method
Sets parameter to its default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToDefault()
'Usage

Dim instance As ImGearControlParameter

instance.SetToDefault()
public void SetToDefault()
public: void SetToDefault();
public:
void SetToDefault();
See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%% $$Properties$$

ImGearControlParameter Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearControlParameter Class

For a list of all members of this type, see ImGearControlParameter members.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the parameter.
Public Property | Value | Gets or sets current value of the parameter.
Top
See Also

Reference

ImGearControlParameter Class
ImageGear.Formats Namespace


Name Property (ImGearControlParameter)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearControlParameter Class : Name Property
Gets the name of the parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearControlParameter
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String containing parameter's name.
See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


Value Property (ImGearControlParameter)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearControlParameter Class : Value Property
Gets or sets current value of the parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As ImGearControlParameter
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object containing parameter's value.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the value is set to null.
ImageGear.Core.ImGearException | Thrown if the value is set to an object of a type incompatible for the specified control parameter.
Remarks
When setting this property, please make sure that the type of the object representing a new value is the same as that of the old value. Otherwise an exception will be thrown.
See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

ImGearFileFilters Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFilters Class
Provides access to formats settings.
Object Model
ImGearFileFilters Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearFileFilters
'Usage

Dim instance As ImGearFileFilters
public sealed class ImGearFileFilters
public __gc __sealed class ImGearFileFilters
public ref class ImGearFileFilters sealed
Remarks
This class allows you to manage file formats and provides access to their settings. It contains a list of formats ImageGear is working with and provides an API for accessing and editing this list. When the format of an image is being detected, the formats are called in the order in which they are contained in the list.

The majority of file formats are added to the list automatically during class initialization. However, you need to add optional formats such as PDF, PostScript, and JPEG 2000 explicitly. If you do not need a particular format, you can remove it from the list. Re-ordering formats in the list allows you to optimize the format detection process. You can control a format's settings by getting a format from the list and accessing it via the IImGearformat interface.

Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFileFilters

See Also

Reference

ImGearFileFilters Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearFileFilters Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFilters Class

The following tables list the members exposed by ImGearFileFilters.

Public Constructors
 | Name | Description
Public Constructor | ImGearFileFilters Constructor | Initializes a new instance of the ImGearFileFilters class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the total number of formats currently in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new format to the end of the list of formats.
Public Method | Contains | Tells whether a particular format is in the list of formats.
Public Method | CopyTo | Copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index.
Public Method | Get | Gets a format in the list based on the format ID.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets an index of a format in the list based on the format ID.
Public Method | Insert | Inserts a new format to the list of formats at the specified position.
Public Method | InsertAfter | Inserts a new format to the list of formats after the specified format.
Public Method | Remove | Removes a format from the list based on the format ID.
Public Method | RemoveAt | Removes a format from the list at the specified position.
Public Method | Set | Sets a format replacing the old one with the same ID.
Top
See Also

Reference

ImGearFileFilters Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearFileFilters Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : ImGearFileFilters Constructor
Initializes a new instance of the ImGearFileFilters class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearFileFilters()
public ImGearFileFilters()
public: ImGearFileFilters();
public:
ImGearFileFilters();
Remarks
Use this constructor if you need to pass a local copy of filter control parameters to a specific image loading or saving method, rather than change control parameters globally.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members
ImGearLoadOptions Class
ImGearSaveOptions Class


%%PageItemTitle%% $$Methods$$

ImGearFileFilters Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFilters Class

For a list of all members of this type, see ImGearFileFilters members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new format to the end of the list of formats.
Public Method | Contains | Tells whether a particular format is in the list of formats.
Public Method | CopyTo | Copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index.
Public Method | Get | Gets a format in the list based on the format ID.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets an index of a format in the list based on the format ID.
Public Method | Insert | Inserts a new format to the list of formats at the specified position.
Public Method | InsertAfter | Inserts a new format to the list of formats after the specified format.
Public Method | Remove | Removes a format from the list based on the format ID.
Public Method | RemoveAt | Removes a format from the list at the specified position.
Public Method | Set | Sets a format replacing the old one with the same ID.
Top
See Also

Reference

ImGearFileFilters Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearFileFilters Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : ImGearFileFilters Constructor
Overload List
Overload | Description
ImGearFileFilters Constructor | Initializes a new instance of the ImGearFileFilters class.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Add Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Add Method
New format to be added.
Adds a new format to the end of the list of formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal newFormat As IImGearFormat _
) As Integer
'Usage

Dim instance As ImGearFileFilters
Dim newFormat As IImGearFormat
Dim value As Integer

value = instance.Add(newFormat)
public int Add(
   IImGearFormat newFormat
)
public: int Add(
   IImGearFormat* newFormat
)
public:
int Add(
   IImGearFormat^ newFormat
)

Parameters

newFormat
New format to be added.

Return Value

A place in the list where new format is placed.
Remarks
If the list contains the format with the same ID as the new one, the new format is not added, and the index of the existing format is returned instead.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Contains Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Contains Method
ID of the format.
Tells whether a particular format is in the list of formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal formatId As ImGearFormats _
) As Boolean
'Usage

Dim instance As ImGearFileFilters
Dim formatId As ImGearFormats
Dim value As Boolean

value = instance.Contains(formatId)
public bool Contains(
   ImGearFormats formatId
)
public: bool Contains(
   ImGearFormats formatId
)
public:
bool Contains(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format.

Return Value

Boolean value.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


CopyTo Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : CopyTo Method
The one-dimensional Array of ImGearFormat elements that is the destination of the elements copied. The Array must have zero-based indexing.
The zero-based index in Array at which copying begins.
Copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearFileFilters
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Array array,
   int index
)
public: void CopyTo(
   Array* array,
   int index
)
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
The one-dimensional Array of ImGearFormat elements that is the destination of the elements copied. The Array must have zero-based indexing.
index
The zero-based index in Array at which copying begins.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Get Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Get Method
The ID of the format.
Gets a format in the list based on the format ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Get( _
   ByVal formatId As ImGearFormats _
) As IImGearFormat
'Usage

Dim instance As ImGearFileFilters
Dim formatId As ImGearFormats
Dim value As IImGearFormat

value = instance.Get(formatId)
public IImGearFormat Get(
   ImGearFormats formatId
)
public: IImGearFormat* Get(
   ImGearFormats formatId
)
public:
IImGearFormat^ Get(
   ImGearFormats formatId
)

Parameters

formatId
The ID of the format.

Return Value

The IImGearFormat interface of a format in the list.
Remarks
This method gets a format from the list, allowing you to access format's settings.

Use this method to manage format's control parameters and access the format's attributes (i.e., name, default file extension, etc.). If a format is not in the list, an exception is thrown.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


GetEnumerator Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearFileFilters
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that can be used to iterate through the collection.
Remarks
Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection. Initially, the enumerator is positioned before the first element in the collection.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


IndexOf Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : IndexOf Method
ID of the format.
Gets an index of a format in the list based on the format ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal formatId As ImGearFormats _
) As Integer
'Usage

Dim instance As ImGearFileFilters
Dim formatId As ImGearFormats
Dim value As Integer

value = instance.IndexOf(formatId)
public int IndexOf(
   ImGearFormats formatId
)
public: int IndexOf(
   ImGearFormats formatId
)
public:
int IndexOf(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format.

Return Value

The index of a format in the list, or -1 if the format is not in the list.
Remarks
The formats are called in the order in which they are kept in the list when the format of an image is detected during loading. Therefore, this method can be used to learn the place of a format in the detection process.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Insert Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Insert Method
Position where to insert a new format.
New format to be inserted.
Inserts a new format to the list of formats at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal newFormat As IImGearFormat _
)
'Usage

Dim instance As ImGearFileFilters
Dim index As Integer
Dim newFormat As IImGearFormat

instance.Insert(index, newFormat)
public void Insert(
   int index,
   IImGearFormat newFormat
)
public: void Insert(
   int index,
   IImGearFormat* newFormat
)
public:
void Insert(
   int index,
   IImGearFormat^ newFormat
)

Parameters

index
Position where to insert a new format.
newFormat
New format to be inserted.
Remarks
Use this method instead of Add if you want to control the detection process. If the format with the same ID exists in the list, an exception is thrown. You can use the Contains method to check if a format is already added, and call Remove or RemoveAt methods to remove a format.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


InsertAfter Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : InsertAfter Method
ID of the format after which to insert a new format.
New format to be inserted.
Inserts a new format to the list of formats after the specified format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InsertAfter( _
   ByVal formatId As ImGearFormats, _
   ByVal newFormat As IImGearFormat _
)
'Usage

Dim instance As ImGearFileFilters
Dim formatId As ImGearFormats
Dim newFormat As IImGearFormat

instance.InsertAfter(formatId, newFormat)
public void InsertAfter(
   ImGearFormats formatId,
   IImGearFormat newFormat
)
public: void InsertAfter(
   ImGearFormats formatId,
   IImGearFormat* newFormat
)
public:
void InsertAfter(
   ImGearFormats formatId,
   IImGearFormat^ newFormat
)

Parameters

formatId
ID of the format after which to insert a new format.
newFormat
New format to be inserted.
Remarks
Use this method if you want a new format to be called after a particular format during format detection. If a format with the same ID as the new one exists in the list, an exception is thrown. You can use Contains method to check if a format is already added, and call Remove or RemoveAt methods to remove a format.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Remove Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Remove Method
ID of the format to be removed.
Removes a format from the list based on the format ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal formatId As ImGearFormats _
)
'Usage

Dim instance As ImGearFileFilters
Dim formatId As ImGearFormats

instance.Remove(formatId)
public void Remove(
   ImGearFormats formatId
)
public: void Remove(
   ImGearFormats formatId
)
public:
void Remove(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format to be removed.
Remarks
Use this method if you do not need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can set its IImGearFormat.DetectionEnabled property to false. If the format is not in the list, nothing is done.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members
ImGearFormats Enumeration


RemoveAt Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : RemoveAt Method
Location (index) of an item to be removed.
Removes a format from the list at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearFileFilters
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
Location (index) of an item to be removed.
Remarks
Use this method if you don't need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can set its IImGearFormat.DetectionEnabled property to false. If the index is out of boundaries, an exception is thrown.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


Set Method (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Set Method
Format to be set.
Sets a format replacing the old one with the same ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Set( _
   ByVal format As IImGearFormat _
) As IImGearFormat
'Usage

Dim instance As ImGearFileFilters
Dim format As IImGearFormat
Dim value As IImGearFormat

value = instance.Set(format)
public IImGearFormat Set(
   IImGearFormat format
)
public: IImGearFormat* Set(
   IImGearFormat* format
)
public:
IImGearFormat^ Set(
   IImGearFormat^ format
)

Parameters

format
Format to be set.

Return Value

The previous format associated with the same IImGearFormat.ID value, or null if such format does not exist.
Remarks
The parameter format cannot be null.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%% $$Properties$$

ImGearFileFilters Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFilters Class

For a list of all members of this type, see ImGearFileFilters members.

Public Properties
 | Name | Description
Public Property | Count | Gets the total number of formats currently in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

ImGearFileFilters Class
ImageGear.Formats Namespace


Count Property (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : Count Property
Gets the total number of formats currently in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearFileFilters
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


IsSynchronized Property (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized (thread-safe).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearFileFilters
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


SyncRoot Property (ImGearFileFilters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFilters Class : SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearFileFilters
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object that can be used to synchronize access to the collection.
See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

ImGearFileFormats Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFormats Class
Main class for working with file formats.
Object Model
ImGearFileFormats ClassIImGearFormat InterfaceImGearFileFilters ClassImGearSavingFormats EnumerationImGearDocument ClassImGearMetadataHead ClassImGearPage ClassImGearPage ClassImGearMetadataHead Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearFileFormats
'Usage

Dim instance As ImGearFileFormats
public sealed class ImGearFileFormats
public __gc __sealed class ImGearFileFormats
public ref class ImGearFileFormats sealed
Remarks
This is the main class for working with file formats. It contains an API for loading, detecting and saving images, getting image information, and provides access to format's settings class. The image is read from and written to a .NET stream. In order for ImageGear to work with the stream, it must be seekable. Consult ImageGear sample code for the examples of how to create a .NET stream from different image sources (i.e., file, memory, URL).
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFileFormats

See Also

Reference

ImGearFileFormats Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearFileFormats Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFormats Class

The following tables list the members exposed by ImGearFileFormats.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Filters | Gets access to the file formats settings.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Detect | Detects the format of an image.
static (Shared in Visual Basic) | ExportPageToBitmap | Exports a System.Drawing.Bitmap, in one of the following formats, supported by System.Drawing.Bitmap: 1bpp Indexed, 4bpp Indexed, 8bpp Indexed, 24bpp RGB, 48bpp RGB, 64bpp ARGB.
static (Shared in Visual Basic) | GetPageCount | Overloaded. Calculates the number of pages in an image.
static (Shared in Visual Basic) | GetSavingFilter | Overloaded. Returns the saving filter for a particular format.
static (Shared in Visual Basic) | GetSavingFormats | Overloaded. Returns an array of all file saving formats compatible with a particular ImGearPage.
static (Shared in Visual Basic) | IsCameraRawFormat | Checks whether specified format is a Camera Raw format.
static (Shared in Visual Basic) | LoadDocument | Overloaded. Loads all pages from an image.
static (Shared in Visual Basic) | LoadDocumentMetadata | Overloaded. Loads document metadata without decoding pixel data.
static (Shared in Visual Basic) | LoadPage | Overloaded. Loads a single page from an image.
static (Shared in Visual Basic) | LoadPageHeader | Overloaded. Loads image metadata for a particular page without decoding pixel data.
static (Shared in Visual Basic) | LoadPageMetadata | Overloaded. Loads page metadata without decoding pixel data.
static (Shared in Visual Basic) | SaveDocument | Saves document to an image.
static (Shared in Visual Basic) | SavePage | Overloaded. Saves page to an image.
static (Shared in Visual Basic) | UpdateDocumentMetadata | Updates document metadata without changing pixel data.
static (Shared in Visual Basic) | UpdatePageMetadata | Overloaded. This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
Top
See Also

Reference

ImGearFileFormats Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearFileFormats Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFormats Class

For a list of all members of this type, see ImGearFileFormats members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Detect | Detects the format of an image.
static (Shared in Visual Basic) | ExportPageToBitmap | Exports a System.Drawing.Bitmap, in one of the following formats, supported by System.Drawing.Bitmap: 1bpp Indexed, 4bpp Indexed, 8bpp Indexed, 24bpp RGB, 48bpp RGB, 64bpp ARGB.
static (Shared in Visual Basic) | GetPageCount | Overloaded. Calculates the number of pages in an image.
static (Shared in Visual Basic) | GetSavingFilter | Overloaded. Returns the saving filter for a particular format.
static (Shared in Visual Basic) | GetSavingFormats | Overloaded. Returns an array of all file saving formats compatible with a particular ImGearPage.
static (Shared in Visual Basic) | IsCameraRawFormat | Checks whether specified format is a Camera Raw format.
static (Shared in Visual Basic) | LoadDocument | Overloaded. Loads all pages from an image.
static (Shared in Visual Basic) | LoadDocumentMetadata | Overloaded. Loads document metadata without decoding pixel data.
static (Shared in Visual Basic) | LoadPage | Overloaded. Loads a single page from an image.
static (Shared in Visual Basic) | LoadPageHeader | Overloaded. Loads image metadata for a particular page without decoding pixel data.
static (Shared in Visual Basic) | LoadPageMetadata | Overloaded. Loads page metadata without decoding pixel data.
static (Shared in Visual Basic) | SaveDocument | Saves document to an image.
static (Shared in Visual Basic) | SavePage | Overloaded. Saves page to an image.
static (Shared in Visual Basic) | UpdateDocumentMetadata | Updates document metadata without changing pixel data.
static (Shared in Visual Basic) | UpdatePageMetadata | Overloaded. This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
Top
See Also

Reference

ImGearFileFormats Class
ImageGear.Formats Namespace


Detect Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : Detect Method
Detects the format of an image.
Overload List
Overload | Description
Detect | Detects the format of an image.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


Detect(Stream) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : Detect(Stream) Method
The data stream containing an image.
Detects the format of an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Detect( _
   ByVal stream As Stream _
) As IImGearFormat
'Usage

Dim stream As Stream
Dim value As IImGearFormat

value = ImGearFileFormats.Detect(stream)
public static IImGearFormat Detect(
   Stream stream
)
public: static IImGearFormat* Detect(
   Stream* stream
)
public:
static IImGearFormat^ Detect(
   Stream^ stream
)

Parameters

stream
The data stream containing an image.

Return Value

The format from the list of formats.
Remarks
If an image cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


ExportPageToBitmap Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : ExportPageToBitmap Method
Exports a System.Drawing.Bitmap, in one of the following formats, supported by System.Drawing.Bitmap: 1bpp Indexed, 4bpp Indexed, 8bpp Indexed, 24bpp RGB, 48bpp RGB, 64bpp ARGB.
Overload List
Overload | Description
ExportPageToBitmap | Exports a System.Drawing.Bitmap, in one of the following formats, supported by System.Drawing.Bitmap: 1bpp Indexed, 4bpp Indexed, 8bpp Indexed, 24bpp RGB, 48bpp RGB, 64bpp ARGB.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


ExportPageToBitmap(ImGearPage) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : ExportPageToBitmap(ImGearPage) Method
Page to export.
Exports a System.Drawing.Bitmap, in one of the following formats, supported by System.Drawing.Bitmap: 1bpp Indexed, 4bpp Indexed, 8bpp Indexed, 24bpp RGB, 48bpp RGB, 64bpp ARGB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ExportPageToBitmap( _
   ByVal page As ImGearPage _
) As Bitmap
'Usage

Dim page As ImGearPage
Dim value As Bitmap

value = ImGearFileFormats.ExportPageToBitmap(page)
public static Bitmap ExportPageToBitmap(
   ImGearPage page
)
public: static Bitmap* ExportPageToBitmap(
   ImGearPage* page
)
public:
static Bitmap^ ExportPageToBitmap(
   ImGearPage^ page
)

Parameters

page
Page to export.

Return Value

System.Drawing.Bitmap class object, containing exported image.
Remarks
The method does not apply any processing to the image. It only converts image pixel format, if source format is not supported by System.Drawing.Bitmap. If source image contains Alpha channel, the method preserves it.

Due to a limitation in Microsoft .Net framework, the method exports 9-16bpp grayscale images to 48bpp RGB format rather than to 16bpp Grayscale.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
ImGearRasterProcessing Class


GetPageCount Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : GetPageCount Method
Calculates the number of pages in an image.
Overload List
Overload | Description
GetPageCount(Stream,ImGearFormats) | Calculates the number of pages in an image.
GetPageCount(Stream,ImGearFormats,ImGearLoadOptions) | Calculates the number of pages in an image.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


GetPageCount(Stream,ImGearFormats) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetPageCount Method : GetPageCount(Stream,ImGearFormats) Method
The data stream containing an image.
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.
Calculates the number of pages in an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetPageCount( _
   ByVal stream As Stream, _
   ByVal formatId As ImGearFormats _
) As Integer
'Usage

Dim stream As Stream
Dim formatId As ImGearFormats
Dim value As Integer

value = ImGearFileFormats.GetPageCount(stream, formatId)
public static int GetPageCount(
   Stream stream,
   ImGearFormats formatId
)
public: static int GetPageCount(
   Stream* stream,
   ImGearFormats formatId
)
public:
static int GetPageCount(
   Stream^ stream,
   ImGearFormats formatId
)

Parameters

stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.

Return Value

Number of pages in the image.
Remarks
If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearFormats Enumeration


GetPageCount(Stream,ImGearFormats,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetPageCount Method : GetPageCount(Stream,ImGearFormats,ImGearLoadOptions) Method
The data stream containing an image.
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.
The loading options.
Calculates the number of pages in an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetPageCount( _
   ByVal stream As Stream, _
   ByVal formatId As ImGearFormats, _
   ByVal options As ImGearLoadOptions _
) As Integer
'Usage

Dim stream As Stream
Dim formatId As ImGearFormats
Dim options As ImGearLoadOptions
Dim value As Integer

value = ImGearFileFormats.GetPageCount(stream, formatId, options)
public static int GetPageCount(
   Stream stream,
   ImGearFormats formatId,
   ImGearLoadOptions options
)
public: static int GetPageCount(
   Stream* stream,
   ImGearFormats formatId,
   ImGearLoadOptions* options
)
public:
static int GetPageCount(
   Stream^ stream,
   ImGearFormats formatId,
   ImGearLoadOptions^ options
)

Parameters

stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.
options
The loading options.

Return Value

Number of pages in the image.
Remarks
If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearFormats Enumeration
ImGearLoadOptions Class


GetSavingFilter Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : GetSavingFilter Method
Returns the saving filter for a particular format.
Overload List
Overload | Description
GetSavingFilter(ImGearSavingFormats) | Returns the saving filter for a particular format.
GetSavingFilter(ImGearSavingFormats,ImGearSaveOptions) | Returns the saving filter for a particular format.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


GetSavingFilter(ImGearSavingFormats) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetSavingFilter Method : GetSavingFilter(ImGearSavingFormats) Method
A format for which to return a filter.
Returns the saving filter for a particular format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetSavingFilter( _
   ByVal saveFormat As ImGearSavingFormats _
) As String
'Usage

Dim saveFormat As ImGearSavingFormats
Dim value As String

value = ImGearFileFormats.GetSavingFilter(saveFormat)
public static string GetSavingFilter(
   ImGearSavingFormats saveFormat
)
public: static string* GetSavingFilter(
   ImGearSavingFormats saveFormat
)
public:
static String^ GetSavingFilter(
   ImGearSavingFormats saveFormat
)

Parameters

saveFormat
A format for which to return a filter.

Return Value

Saving filter for a particular format.
Remarks
This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearSavingFormats Enumeration


GetSavingFilter(ImGearSavingFormats,ImGearSaveOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetSavingFilter Method : GetSavingFilter(ImGearSavingFormats,ImGearSaveOptions) Method
A format for which to return a filter.
Additional saving options such as allowed color conversions.
Returns the saving filter for a particular format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetSavingFilter( _
   ByVal saveFormat As ImGearSavingFormats, _
   ByVal options As ImGearSaveOptions _
) As String
'Usage

Dim saveFormat As ImGearSavingFormats
Dim options As ImGearSaveOptions
Dim value As String

value = ImGearFileFormats.GetSavingFilter(saveFormat, options)
public static string GetSavingFilter(
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions options
)
public: static string* GetSavingFilter(
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions* options
)
public:
static String^ GetSavingFilter(
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions^ options
)

Parameters

saveFormat
A format for which to return a filter.
options
Additional saving options such as allowed color conversions.

Return Value

Saving filter for a particular format.
Remarks
This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearSavingFormats Enumeration
ImGearSaveOptions Class


GetSavingFormats Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage.
Overload List
Overload | Description
GetSavingFormats(ImGearPage) | Returns an array of all file saving formats compatible with a particular ImGearPage.
GetSavingFormats(ImGearPage,ImGearRasterConversionModes) | Returns an array of all file saving formats compatible with a particular ImageGear.Core.ImGearPage and the conversion mode.
GetSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) | Returns an array of all file saving formats compatible with a particular ImageGear.Core.ImGearPage class oblect and the conversion mode.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


GetSavingFormats(ImGearPage) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetSavingFormats Method : GetSavingFormats(ImGearPage) Method
ImGearPage object to get saving formats for.
Returns an array of all file saving formats compatible with a particular ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetSavingFormats( _
   ByVal page As ImGearPage _
) As ImGearSavingFormats()
'Usage

Dim page As ImGearPage
Dim value() As ImGearSavingFormats

value = ImGearFileFormats.GetSavingFormats(page)
public static ImGearSavingFormats[] GetSavingFormats(
   ImGearPage page
)
public: static ImGearSavingFormats[]* GetSavingFormats(
   ImGearPage* page
)
public:
static array<ImGearSavingFormats>^ GetSavingFormats(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to get saving formats for.

Return Value

ImGearSavingFormats enumeration value.
Remarks
This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearSavingFormats Enumeration
ImGearPage Class


GetSavingFormats(ImGearPage,ImGearRasterConversionModes) Method
Example

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetSavingFormats Method : GetSavingFormats(ImGearPage,ImGearRasterConversionModes) Method
ImageGear.Core.ImGearPage object to get saving formats for.
Raster converter mode.
Returns an array of all file saving formats compatible with a particular ImageGear.Core.ImGearPage and the conversion mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetSavingFormats( _
   ByVal page As ImGearPage, _
   ByVal rasterConversionModes As ImGearRasterConversionModes _
) As ImGearSavingFormats()
'Usage

Dim page As ImGearPage
Dim rasterConversionModes As ImGearRasterConversionModes
Dim value() As ImGearSavingFormats

value = ImGearFileFormats.GetSavingFormats(page, rasterConversionModes)
public static ImGearSavingFormats[] GetSavingFormats(
   ImGearPage page,
   ImGearRasterConversionModes rasterConversionModes
)
public: static ImGearSavingFormats[]* GetSavingFormats(
   ImGearPage* page,
   ImGearRasterConversionModes rasterConversionModes
)
public:
static array<ImGearSavingFormats>^ GetSavingFormats(
   ImGearPage^ page,
   ImGearRasterConversionModes rasterConversionModes
)

Parameters

page
ImageGear.Core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.

Return Value

ImGearSavingFormats enumerationarray.
Remarks
This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.
Example
  • C#
ImGearSavingFormats[] formats = ImGearFileFormats.GetSavingFormats(igPage, ImGearRasterConversionModes.DIRECT_MATCH);
  • Visual Basic
Dim formats As ImGearSavingFormats() = ImGearFileFormats.GetSavingFormats(igPage, ImGearRasterConversionModes.DIRECT_MATCH)
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearSavingFormats Enumeration
ImGearPage Class
ImGearRasterConversionModes Enumeration


GetSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > GetSavingFormats Method : GetSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) Method
ImageGear.Core.ImGearPage object to get saving formats for.
Raster converter mode.
Additional saving options and filter control parameters.
Returns an array of all file saving formats compatible with a particular ImageGear.Core.ImGearPage class oblect and the conversion mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function GetSavingFormats( _
   ByVal page As ImGearPage, _
   ByVal rasterConversionModes As ImGearRasterConversionModes, _
   ByVal options As ImGearSaveOptions _
) As ImGearSavingFormats()
'Usage

Dim page As ImGearPage
Dim rasterConversionModes As ImGearRasterConversionModes
Dim options As ImGearSaveOptions
Dim value() As ImGearSavingFormats

value = ImGearFileFormats.GetSavingFormats(page, rasterConversionModes, options)
public static ImGearSavingFormats[] GetSavingFormats(
   ImGearPage page,
   ImGearRasterConversionModes rasterConversionModes,
   ImGearSaveOptions options
)
public: static ImGearSavingFormats[]* GetSavingFormats(
   ImGearPage* page,
   ImGearRasterConversionModes rasterConversionModes,
   ImGearSaveOptions* options
)
public:
static array<ImGearSavingFormats>^ GetSavingFormats(
   ImGearPage^ page,
   ImGearRasterConversionModes rasterConversionModes,
   ImGearSaveOptions^ options
)

Parameters

page
ImageGear.Core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.
options
Additional saving options and filter control parameters.

Return Value

ImGearSavingFormats enumerationarray.
Remarks
This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImageGear.Core.ImGearPage class object.

If options parameter is not null, rasterConversionModes supersedes options.ConversionMode field.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearSavingFormats Enumeration
ImGearPage Class
ImGearRasterConversionModes Enumeration
ImGearSaveOptions Class


IsCameraRawFormat Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : IsCameraRawFormat Method
Checks whether specified format is a Camera Raw format.
Overload List
Overload | Description
IsCameraRawFormat | Checks whether specified format is a Camera Raw format.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


IsCameraRawFormat(IImGearFormat) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : IsCameraRawFormat(IImGearFormat) Method
Format to check.
Checks whether specified format is a Camera Raw format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function IsCameraRawFormat( _
   ByVal format As IImGearFormat _
) As Boolean
'Usage

Dim format As IImGearFormat
Dim value As Boolean

value = ImGearFileFormats.IsCameraRawFormat(format)
public static bool IsCameraRawFormat(
   IImGearFormat format
)
public: static bool IsCameraRawFormat(
   IImGearFormat* format
)
public:
static bool IsCameraRawFormat(
   IImGearFormat^ format
)

Parameters

format
Format to check.

Return Value

Boolean value.
Remarks
For more information about working with Camera Raw formats, see Using ImageGear Digital Camera RAW Formats..
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadDocument Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : LoadDocument Method
Loads all pages from an image.
Overload List
Overload | Description
LoadDocument(Stream) | Loads all pages from an image.
LoadDocument(Stream,Int32,Int32) | Loads a range of pages from an image.
LoadDocument(Stream,Int32,Int32,ImGearLoadOptions) | Loads a range of pages from an image.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadDocument(Stream) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadDocument Method : LoadDocument(Stream) Method
The data stream containing an image.
Loads all pages from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocument( _
   ByVal stream As Stream _
) As ImGearDocument
'Usage

Dim stream As Stream
Dim value As ImGearDocument

value = ImGearFileFormats.LoadDocument(stream)
public static ImGearDocument LoadDocument(
   Stream stream
)
public: static ImGearDocument* LoadDocument(
   Stream* stream
)
public:
static ImGearDocument^ LoadDocument(
   Stream^ stream
)

Parameters

stream
The data stream containing an image.

Return Value

A new instance of ImageGear.Core.ImGearDocument class.
Remarks
This method allows you to load all pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


LoadDocument(Stream,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadDocument Method : LoadDocument(Stream,Int32,Int32) Method
The data stream containing an image.
The number of the first page to load.
Total number of pages to load.
Loads a range of pages from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocument( _
   ByVal stream As Stream, _
   ByVal startPageNumber As Integer, _
   ByVal count As Integer _
) As ImGearDocument
'Usage

Dim stream As Stream
Dim startPageNumber As Integer
Dim count As Integer
Dim value As ImGearDocument

value = ImGearFileFormats.LoadDocument(stream, startPageNumber, count)
public static ImGearDocument LoadDocument(
   Stream stream,
   int startPageNumber,
   int count
)
public: static ImGearDocument* LoadDocument(
   Stream* stream,
   int startPageNumber,
   int count
)
public:
static ImGearDocument^ LoadDocument(
   Stream^ stream,
   int startPageNumber,
   int count
)

Parameters

stream
The data stream containing an image.
startPageNumber
The number of the first page to load.
count
Total number of pages to load.

Return Value

A new instance of ImageGear.Core.ImGearDocument class.
Remarks
This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


LoadDocument(Stream,Int32,Int32,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadDocument Method : LoadDocument(Stream,Int32,Int32,ImGearLoadOptions) Method
The data stream containing an image.
The number of the first page to load.
Total number of pages to load.
The loading options.
Loads a range of pages from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocument( _
   ByVal stream As Stream, _
   ByVal startPageNumber As Integer, _
   ByVal count As Integer, _
   ByVal options As ImGearLoadOptions _
) As ImGearDocument
'Usage

Dim stream As Stream
Dim startPageNumber As Integer
Dim count As Integer
Dim options As ImGearLoadOptions
Dim value As ImGearDocument

value = ImGearFileFormats.LoadDocument(stream, startPageNumber, count, options)
public static ImGearDocument LoadDocument(
   Stream stream,
   int startPageNumber,
   int count,
   ImGearLoadOptions options
)
public: static ImGearDocument* LoadDocument(
   Stream* stream,
   int startPageNumber,
   int count,
   ImGearLoadOptions* options
)
public:
static ImGearDocument^ LoadDocument(
   Stream^ stream,
   int startPageNumber,
   int count,
   ImGearLoadOptions^ options
)

Parameters

stream
The data stream containing an image.
startPageNumber
The number of the first page to load.
count
Total number of pages to load.
options
The loading options.

Return Value

A new instance of ImageGear.Core.ImGearDocument class.
Remarks
This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearLoadOptions Class
ImGearDocument Class


LoadDocumentMetadata Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : LoadDocumentMetadata Method
Loads document metadata without decoding pixel data.
Overload List
Overload | Description
LoadDocumentMetadata(Stream) | Loads document metadata without decoding pixel data.
LoadDocumentMetadata(Stream,ImGearLoadOptions) | Loads document metadata without decoding pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadDocumentMetadata(Stream) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadDocumentMetadata Method : LoadDocumentMetadata(Stream) Method
Data stream containing an image.
Loads document metadata without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocumentMetadata( _
   ByVal stream As Stream _
) As ImGearMetadataHead
'Usage

Dim stream As Stream
Dim value As ImGearMetadataHead

value = ImGearFileFormats.LoadDocumentMetadata(stream)
public static ImGearMetadataHead LoadDocumentMetadata(
   Stream stream
)
public: static ImGearMetadataHead* LoadDocumentMetadata(
   Stream* stream
)
public:
static ImGearMetadataHead^ LoadDocumentMetadata(
   Stream^ stream
)

Parameters

stream
Data stream containing an image.

Return Value

Document metadata tree.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null.
Remarks
This method reads the specified image stream from the current position and loads the metadata associated with a document. This method does not load the metadata assotiated with individual pages. This method does not decode the actual pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


LoadDocumentMetadata(Stream,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadDocumentMetadata Method : LoadDocumentMetadata(Stream,ImGearLoadOptions) Method
Data stream containing an image.
Loading options or null.
Loads document metadata without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocumentMetadata( _
   ByVal stream As Stream, _
   ByVal options As ImGearLoadOptions _
) As ImGearMetadataHead
'Usage

Dim stream As Stream
Dim options As ImGearLoadOptions
Dim value As ImGearMetadataHead

value = ImGearFileFormats.LoadDocumentMetadata(stream, options)
public static ImGearMetadataHead LoadDocumentMetadata(
   Stream stream,
   ImGearLoadOptions options
)
public: static ImGearMetadataHead* LoadDocumentMetadata(
   Stream* stream,
   ImGearLoadOptions* options
)
public:
static ImGearMetadataHead^ LoadDocumentMetadata(
   Stream^ stream,
   ImGearLoadOptions^ options
)

Parameters

stream
Data stream containing an image.
options
Loading options or null.

Return Value

Document metadata tree.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null.
Remarks
This method reads the specified image stream from the current position and loads the metadata associated with a document. This method does not load the metadata assotiated with individual pages. This method does not decode the actual pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


LoadPage Method (ImGearFileFormats)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : LoadPage Method
Loads a single page from an image.
Overload List
Overload | Description
LoadPage(Stream,Int32) | Loads a single page from an image.
LoadPage(Stream,Int32,ImGearLoadOptions) | Loads a single page from an image.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadPage(Stream,Int32) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPage Method : LoadPage(Stream,Int32) Method
The data stream containing an image.
The number of page to load; this is a 0-based index.
Loads a single page from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPage( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImGearPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImGearPage

value = ImGearFileFormats.LoadPage(stream, pageNumber)
public static ImGearPage LoadPage(
   Stream stream,
   int pageNumber
)
public: static ImGearPage* LoadPage(
   Stream* stream,
   int pageNumber
)
public:
static ImGearPage^ LoadPage(
   Stream^ stream,
   int pageNumber
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load; this is a 0-based index.

Return Value

A new instance of ImageGear.Core.ImGearPage class.
Remarks
This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearPage Class


LoadPage(Stream,Int32,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPage Method : LoadPage(Stream,Int32,ImGearLoadOptions) Method
The data stream containing an image.
The number of page to load.
The loading options.
Loads a single page from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPage( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As ImGearLoadOptions _
) As ImGearPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim loadOptions As ImGearLoadOptions
Dim value As ImGearPage

value = ImGearFileFormats.LoadPage(stream, pageNumber, loadOptions)
public static ImGearPage LoadPage(
   Stream stream,
   int pageNumber,
   ImGearLoadOptions loadOptions
)
public: static ImGearPage* LoadPage(
   Stream* stream,
   int pageNumber,
   ImGearLoadOptions* loadOptions
)
public:
static ImGearPage^ LoadPage(
   Stream^ stream,
   int pageNumber,
   ImGearLoadOptions^ loadOptions
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load.
loadOptions
The loading options.

Return Value

A new instance of ImageGear.Core.ImGearPage class.
Remarks
This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearLoadOptions Class
ImGearPage Class


LoadPageHeader Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : LoadPageHeader Method
Loads image metadata for a particular page without decoding pixel data.
Overload List
Overload | Description
LoadPageHeader(Stream,Int32) | Loads image metadata for a particular page without decoding pixel data.
LoadPageHeader(Stream,Int32,ImGearLoadOptions) | Loads image metadata for a particular page without decoding pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadPageHeader(Stream,Int32) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPageHeader Method : LoadPageHeader(Stream,Int32) Method
The data stream containing an image.
The number of page to load header from.
Loads image metadata for a particular page without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPageHeader( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImGearPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImGearPage

value = ImGearFileFormats.LoadPageHeader(stream, pageNumber)
public static ImGearPage LoadPageHeader(
   Stream stream,
   int pageNumber
)
public: static ImGearPage* LoadPageHeader(
   Stream* stream,
   int pageNumber
)
public:
static ImGearPage^ LoadPageHeader(
   Stream^ stream,
   int pageNumber
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load header from.

Return Value

A new instance of ImageGear.Core.ImGearPage class.
Remarks
This method loads image metadata for a particular page without decoding pixel data.

This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearPage Class


LoadPageHeader(Stream,Int32,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPageHeader Method : LoadPageHeader(Stream,Int32,ImGearLoadOptions) Method
The data stream containing an image.
The number of page to load header from.
The loading options.
Loads image metadata for a particular page without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPageHeader( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal options As ImGearLoadOptions _
) As ImGearPage
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim options As ImGearLoadOptions
Dim value As ImGearPage

value = ImGearFileFormats.LoadPageHeader(stream, pageNumber, options)
public static ImGearPage LoadPageHeader(
   Stream stream,
   int pageNumber,
   ImGearLoadOptions options
)
public: static ImGearPage* LoadPageHeader(
   Stream* stream,
   int pageNumber,
   ImGearLoadOptions* options
)
public:
static ImGearPage^ LoadPageHeader(
   Stream^ stream,
   int pageNumber,
   ImGearLoadOptions^ options
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load header from.
options
The loading options.

Return Value

A new instance of ImageGear.Core.ImGearPage class.
Remarks
This method returns an ImageGear.Core.ImGearPage class containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearPage Class
ImGearLoadOptions Class


LoadPageMetadata Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : LoadPageMetadata Method
Loads page metadata without decoding pixel data.
Overload List
Overload | Description
LoadPageMetadata(Stream,Int32) | Loads page metadata without decoding pixel data.
LoadPageMetadata(Stream,Int32,ImGearLoadOptions) | Loads page metadata without decoding pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


LoadPageMetadata(Stream,Int32) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPageMetadata Method : LoadPageMetadata(Stream,Int32) Method
Data stream containing an image.
Zero based page number to load the metadata from.
Loads page metadata without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPageMetadata( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImGearMetadataHead
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImGearMetadataHead

value = ImGearFileFormats.LoadPageMetadata(stream, pageNumber)
public static ImGearMetadataHead LoadPageMetadata(
   Stream stream,
   int pageNumber
)
public: static ImGearMetadataHead* LoadPageMetadata(
   Stream* stream,
   int pageNumber
)
public:
static ImGearMetadataHead^ LoadPageMetadata(
   Stream^ stream,
   int pageNumber
)

Parameters

stream
Data stream containing an image.
pageNumber
Zero based page number to load the metadata from.

Return Value

Page metadata tree.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null.
ImageGear.Core.ImGearException | Thrown with ImGearErrorCodes.PAGE_NOT_PRESENT error code if the page with the specified page number does not exist in the image.
Remarks
This method reads the specified image stream from the current position and loads the metadata associated with the specified page. This method does not load the metadata assotiated with a document. This method does not decode the actual pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


LoadPageMetadata(Stream,Int32,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > LoadPageMetadata Method : LoadPageMetadata(Stream,Int32,ImGearLoadOptions) Method
Data stream containing an image.
Zero based page number to load the metadata from.
Loading options or null.
Loads page metadata without decoding pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadPageMetadata( _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal options As ImGearLoadOptions _
) As ImGearMetadataHead
'Usage

Dim stream As Stream
Dim pageNumber As Integer
Dim options As ImGearLoadOptions
Dim value As ImGearMetadataHead

value = ImGearFileFormats.LoadPageMetadata(stream, pageNumber, options)
public static ImGearMetadataHead LoadPageMetadata(
   Stream stream,
   int pageNumber,
   ImGearLoadOptions options
)
public: static ImGearMetadataHead* LoadPageMetadata(
   Stream* stream,
   int pageNumber,
   ImGearLoadOptions* options
)
public:
static ImGearMetadataHead^ LoadPageMetadata(
   Stream^ stream,
   int pageNumber,
   ImGearLoadOptions^ options
)

Parameters

stream
Data stream containing an image.
pageNumber
Zero based page number to load the metadata from.
options
Loading options or null.

Return Value

Page metadata tree.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null.
ImageGear.Core.ImGearException | Thrown with ImGearErrorCodes.PAGE_NOT_PRESENT error code if the page with the specified page number does not exist in the image.
Remarks
This method reads the specified image stream from the current position and loads the metadata associated with the specified page. This method does not load the metadata assotiated with a document. This method does not decode the actual pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


SaveDocument Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : SaveDocument Method
ImageGear document to save.
NET stream to write an image to.
The number of a start page in the image file where document pages are saved.
Specifies how new pages should be saved to an image; replace pages, insert pages, append pages, or overwrite the entire image.
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
Additional saving options such as thumbnail dimensions.
Saves document to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SaveDocument( _
   ByVal document As ImGearDocument, _
   ByVal stream As Stream, _
   ByVal startPageInFile As Integer, _
   ByVal mode As ImGearSavingModes, _
   ByVal saveFormat As ImGearSavingFormats, _
   ByVal saveOptions As ImGearSaveOptions _
)
'Usage

Dim document As ImGearDocument
Dim stream As Stream
Dim startPageInFile As Integer
Dim mode As ImGearSavingModes
Dim saveFormat As ImGearSavingFormats
Dim saveOptions As ImGearSaveOptions

ImGearFileFormats.SaveDocument(document, stream, startPageInFile, mode, saveFormat, saveOptions)
public static void SaveDocument(
   ImGearDocument document,
   Stream stream,
   int startPageInFile,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions saveOptions
)
public: static void SaveDocument(
   ImGearDocument* document,
   Stream* stream,
   int startPageInFile,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions* saveOptions
)
public:
static void SaveDocument(
   ImGearDocument^ document,
   Stream^ stream,
   int startPageInFile,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions^ saveOptions
)

Parameters

document
ImageGear document to save.
stream
NET stream to write an image to.
startPageInFile
The number of a start page in the image file where document pages are saved.
mode
Specifies how new pages should be saved to an image; replace pages, insert pages, append pages, or overwrite the entire image.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
Additional saving options such as thumbnail dimensions.
Remarks
This method allows you to save the entire document in a single call. Both page pixel data and page metadata are saved. If a new image is created (or overwritten), document level metadata is saved as well, otherwise, it is ignored.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
ImGearDocument Class
ImGearPage Class
ImGearSavingModes Enumeration
ImGearSavingFormats Enumeration
ImGearSaveOptions Class


SavePage Method (ImGearFileFormats)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : SavePage Method
Saves page to an image.
Overload List
Overload | Description
SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats) | Saves page to an image.
SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) | Saves page to an image.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > SavePage Method : SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats) Method
ImageGear page to save.
NET stream to write an image to.
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
Saves page to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SavePage( _
   ByVal page As ImGearPage, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal saveMode As ImGearSavingModes, _
   ByVal saveFormat As ImGearSavingFormats _
)
'Usage

Dim page As ImGearPage
Dim stream As Stream
Dim pageNumber As Integer
Dim saveMode As ImGearSavingModes
Dim saveFormat As ImGearSavingFormats

ImGearFileFormats.SavePage(page, stream, pageNumber, saveMode, saveFormat)
public static void SavePage(
   ImGearPage page,
   Stream stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearSavingFormats saveFormat
)
public: static void SavePage(
   ImGearPage* page,
   Stream* stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearSavingFormats saveFormat
)
public:
static void SavePage(
   ImGearPage^ page,
   Stream^ stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearSavingFormats saveFormat
)

Parameters

page
ImageGear page to save.
stream
NET stream to write an image to.
pageNumber
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
saveMode
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
Remarks
Both page pixel data and page metadata are saved by this method.

Note: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearPage Class
ImGearSavingModes Enumeration
ImGearSavingFormats Enumeration


SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > SavePage Method : SavePage(ImGearPage,Stream,Int32,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) Method
ImageGear page to save.
NET stream to write an image to.
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
Additional saving options such as thumbnail dimensions.
Saves page to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SavePage( _
   ByVal page As ImGearPage, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal mode As ImGearSavingModes, _
   ByVal saveFormat As ImGearSavingFormats, _
   ByVal saveOptions As ImGearSaveOptions _
)
'Usage

Dim page As ImGearPage
Dim stream As Stream
Dim pageNumber As Integer
Dim mode As ImGearSavingModes
Dim saveFormat As ImGearSavingFormats
Dim saveOptions As ImGearSaveOptions

ImGearFileFormats.SavePage(page, stream, pageNumber, mode, saveFormat, saveOptions)
public static void SavePage(
   ImGearPage page,
   Stream stream,
   int pageNumber,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions saveOptions
)
public: static void SavePage(
   ImGearPage* page,
   Stream* stream,
   int pageNumber,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions* saveOptions
)
public:
static void SavePage(
   ImGearPage^ page,
   Stream^ stream,
   int pageNumber,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions^ saveOptions
)

Parameters

page
ImageGear page to save.
stream
NET stream to write an image to.
pageNumber
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
mode
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
Additional saving options such as thumbnail dimensions.
Remarks
Both page pixel data and page metadata are saved by this method.

Note: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearPage Class
ImGearSavingModes Enumeration
ImGearSavingFormats Enumeration
ImGearSaveOptions Class


UpdateDocumentMetadata Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : UpdateDocumentMetadata Method
Data stream containing a source image.
Data stream to write the updated image to.
Document metadata tree to be saved to the new image.
Updates document metadata without changing pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub UpdateDocumentMetadata( _
   ByVal sourceStream As Stream, _
   ByVal destinationStream As Stream, _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim sourceStream As Stream
Dim destinationStream As Stream
Dim metadata As ImGearMetadataHead

ImGearFileFormats.UpdateDocumentMetadata(sourceStream, destinationStream, metadata)
public static void UpdateDocumentMetadata(
   Stream sourceStream,
   Stream destinationStream,
   ImGearMetadataHead metadata
)
public: static void UpdateDocumentMetadata(
   Stream* sourceStream,
   Stream* destinationStream,
   ImGearMetadataHead* metadata
)
public:
static void UpdateDocumentMetadata(
   Stream^ sourceStream,
   Stream^ destinationStream,
   ImGearMetadataHead^ metadata
)

Parameters

sourceStream
Data stream containing a source image.
destinationStream
Data stream to write the updated image to.
metadata
Document metadata tree to be saved to the new image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null or metadata parameter is null.
ImageGear.Core.ImGearException

Thrown with ImGearErrorCodes.PAGE_NOT_PRESENT error code if the source stream represents DICOM vector waveform data.

Thrown with ImGearErrorCodes.CANT_SAVE_FORMAT error code if the metadata cannot be updated due to invalid data in the source stream.

Remarks

This method replaces the metadata associated with a document loaded from the source image with the provided metadata and saves the updated image to the destination stream. This method does not replace the metadata assotiated with individual pages. This method does not change the actual pixel data. The structure of the provided metadata tree should correspond to the metadata tree from the source image. This method does not save any metadata tags provided in the metadata tree that are not supported by the source image format. See ImageGear.Core.ImGearMetadataNode for more details about the ImageGear metadata.

This method is only supported for PDF, PS and DICOM file formats.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


UpdatePageMetadata Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : UpdatePageMetadata Method
This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
Overload List
Overload | Description
UpdatePageMetadata(Stream,Stream,ImGearMetadataHead) | This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,ImGearLoadOptions) | This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,Int32) | Updates page metadata without changing pixel data.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


UpdatePageMetadata(Stream,Stream,ImGearMetadataHead) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > UpdatePageMetadata Method : UpdatePageMetadata(Stream,Stream,ImGearMetadataHead) Method
The data stream, containing source image.
The data stream to which to write result image.
Metadata to be saved to result file.
This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")>
Public Overloads Shared Sub UpdatePageMetadata( _
   ByVal sourceStream As Stream, _
   ByVal destinationStream As Stream, _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim sourceStream As Stream
Dim destinationStream As Stream
Dim metadata As ImGearMetadataHead

ImGearFileFormats.UpdatePageMetadata(sourceStream, destinationStream, metadata)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public static void UpdatePageMetadata(
   Stream sourceStream,
   Stream destinationStream,
   ImGearMetadataHead metadata
)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public: static void UpdatePageMetadata(
   Stream* sourceStream,
   Stream* destinationStream,
   ImGearMetadataHead* metadata
)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public:
static void UpdatePageMetadata(
   Stream^ sourceStream,
   Stream^ destinationStream,
   ImGearMetadataHead^ metadata
)

Parameters

sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.
Remarks
This method will be removed in future release. For supporting the same functionality it is required to use another overload that takes page number argument. For DICOM file format which does not use page number for page metadata UpdateDocumentMetadata method is recommended.

This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearMetadataHead Class


UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,ImGearLoadOptions) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > UpdatePageMetadata Method : UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,ImGearLoadOptions) Method
The data stream, containing source image.
The data stream to which to write result image.
Metadata to be saved to result file.
The loading options.
This method has been deprecated. Creates a new file with exact copy of source file's pixel data and with new metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")>
Public Overloads Shared Sub UpdatePageMetadata( _
   ByVal sourceStream As Stream, _
   ByVal destinationStream As Stream, _
   ByVal metadata As ImGearMetadataHead, _
   ByVal options As ImGearLoadOptions _
)
'Usage

Dim sourceStream As Stream
Dim destinationStream As Stream
Dim metadata As ImGearMetadataHead
Dim options As ImGearLoadOptions

ImGearFileFormats.UpdatePageMetadata(sourceStream, destinationStream, metadata, options)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public static void UpdatePageMetadata(
   Stream sourceStream,
   Stream destinationStream,
   ImGearMetadataHead metadata,
   ImGearLoadOptions options
)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public: static void UpdatePageMetadata(
   Stream* sourceStream,
   Stream* destinationStream,
   ImGearMetadataHead* metadata,
   ImGearLoadOptions* options
)
[Obsolete("This method will be removed from the public API in a future release. Use UpdateDocumentMetadata to update DICOM metadata.")]
public:
static void UpdatePageMetadata(
   Stream^ sourceStream,
   Stream^ destinationStream,
   ImGearMetadataHead^ metadata,
   ImGearLoadOptions^ options
)

Parameters

sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.
options
The loading options.
Remarks
This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List
ImGearMetadataHead Class
ImGearLoadOptions Class


UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,Int32) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class > UpdatePageMetadata Method : UpdatePageMetadata(Stream,Stream,ImGearMetadataHead,Int32) Method
Data stream containing a source image.
Data stream to write the updated image to.
Page metadata tree to be saved to the new image.
Zero based page number to update the metadata for.
Updates page metadata without changing pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub UpdatePageMetadata( _
   ByVal sourceStream As Stream, _
   ByVal destinationStream As Stream, _
   ByVal metadata As ImGearMetadataHead, _
   ByVal pageNumber As Integer _
)
'Usage

Dim sourceStream As Stream
Dim destinationStream As Stream
Dim metadata As ImGearMetadataHead
Dim pageNumber As Integer

ImGearFileFormats.UpdatePageMetadata(sourceStream, destinationStream, metadata, pageNumber)
public static void UpdatePageMetadata(
   Stream sourceStream,
   Stream destinationStream,
   ImGearMetadataHead metadata,
   int pageNumber
)
public: static void UpdatePageMetadata(
   Stream* sourceStream,
   Stream* destinationStream,
   ImGearMetadataHead* metadata,
   int pageNumber
)
public:
static void UpdatePageMetadata(
   Stream^ sourceStream,
   Stream^ destinationStream,
   ImGearMetadataHead^ metadata,
   int pageNumber
)

Parameters

sourceStream
Data stream containing a source image.
destinationStream
Data stream to write the updated image to.
metadata
Page metadata tree to be saved to the new image.
pageNumber
Zero based page number to update the metadata for.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the specified stream is null or metadata parameter is null.
ImageGear.Core.ImGearException

Thrown with ImGearErrorCodes.PAGE_NOT_PRESENT error code if the page with the specified page number does not exist in the image, or the page with the specified page number represents DICOM vector waveform data.

Thrown with ImGearErrorCodes.CANT_SAVE_FORMAT error code if the metadata cannot be updated due to invalid data in the source stream.

Remarks
This method replaces the metadata associated with the specified page loaded from the source image with the provided metadata and saves the updated image to the destination stream. This method does not replace the metadata assotiated with a document. This method does not change the actual pixel data. The structure of the provided metadata tree should correspond to the metadata tree from the source image. This method does not save any metadata tags provided in the metadata tree that are not supported by the source image format. See ImageGear.Core.ImGearMetadataNode for more details about the ImageGear metadata.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearFileFormats Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFileFormats Class

For a list of all members of this type, see ImGearFileFormats members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Filters | Gets access to the file formats settings.
Top
See Also

Reference

ImGearFileFormats Class
ImageGear.Formats Namespace


Filters Property (ImGearFileFormats)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFileFormats Class : Filters Property
Gets access to the file formats settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Filters As ImGearFileFilters
'Usage

Dim value As ImGearFileFilters

value = ImGearFileFormats.Filters
public static ImGearFileFilters Filters {get;}
public: __property static ImGearFileFilters* get_Filters();
public:
static property ImGearFileFilters^ Filters {
   ImGearFileFilters^ get();
}

Property Value

Instance of class for managing file formats.
Remarks
Use this property to get access to the ImGearFileFilters class instance that enables you to manage file formats and their settings.
See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
ImGearFileFilters Class


%%PageItemTitle%%

ImGearFormatMetadata Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatMetadata Class
This is the base class for the Simplified Metadata API accessor classes.

For more information about Simplified Metadata API usage, see Simplified Access to Non-Image Data.

Object Model
ImGearFormatMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearFormatMetadata
'Usage

Dim instance As ImGearFormatMetadata
public class ImGearFormatMetadata
public __gc class ImGearFormatMetadata
public ref class ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.EXIF.ImGearEXIFGPSMetadata
ImageGear.Formats.EXIF.ImGearEXIFInteropMetadata
ImageGear.Formats.EXIF.ImGearEXIFMetadata
ImageGear.Formats.ImGearCommonMetadata
ImageGear.Formats.IPTC.ImGearIPTCMetadata
ImageGear.Formats.TIF.ImGearTIFFMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.ImGearXMPMetadataRoot

See Also

Reference

ImGearFormatMetadata Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearFormatMetadata Class Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatMetadata Class

The following tables list the members exposed by ImGearFormatMetadata.

See Also

Reference

ImGearFormatMetadata Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearFormatParameters Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatParameters Class
Allows you to manage format's control parameters.
Object Model
ImGearFormatParameters ClassImGearControlParameter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearFormatParameters
'Usage

Dim instance As ImGearFormatParameters
[DefaultMember("Item")]
public sealed class ImGearFormatParameters
[DefaultMember("Item")]
public __gc __sealed class ImGearFormatParameters
[DefaultMember("Item")]
public ref class ImGearFormatParameters sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatParameters

See Also

Reference

ImGearFormatParameters Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearFormatParameters Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatParameters Class

The following tables list the members exposed by ImGearFormatParameters.

Public Properties
 | Name | Description
Public Property | Count | Gets the total number of control parameters for the format.
Public Property | Item | Gets control parameter by index.
Top
Public Methods
 | Name | Description
Public Method | GetByName | Gets control parameter by name.
Public Method | GetEnumerator | Gets enumerator that iterates through the collection.
Public Method | SetToDefault | Sets all control parameters to their default values.
Top
See Also

Reference

ImGearFormatParameters Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearFormatParameters Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatParameters Class

For a list of all members of this type, see ImGearFormatParameters members.

Public Methods
 | Name | Description
Public Method | GetByName | Gets control parameter by name.
Public Method | GetEnumerator | Gets enumerator that iterates through the collection.
Public Method | SetToDefault | Sets all control parameters to their default values.
Top
See Also

Reference

ImGearFormatParameters Class
ImageGear.Formats Namespace


GetByName Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFormatParameters Class : GetByName Method
The name of the parameter.
Gets control parameter by name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetByName( _
   ByVal name As String _
) As ImGearControlParameter
'Usage

Dim instance As ImGearFormatParameters
Dim name As String
Dim value As ImGearControlParameter

value = instance.GetByName(name)
public ImGearControlParameter GetByName(
   string name
)
public: ImGearControlParameter* GetByName(
   string* name
)
public:
ImGearControlParameter^ GetByName(
   String^ name
)

Parameters

name
The name of the parameter.

Return Value

The ImGearControlParameter control parameter from the collection of parameters.
See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members
ImGearControlParameter Class


GetEnumerator Method (ImGearFormatParameters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFormatParameters Class : GetEnumerator Method
Gets enumerator that iterates through the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearFormatParameters
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


SetToDefault Method (ImGearFormatParameters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFormatParameters Class : SetToDefault Method
Sets all control parameters to their default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToDefault()
'Usage

Dim instance As ImGearFormatParameters

instance.SetToDefault()
public void SetToDefault()
public: void SetToDefault();
public:
void SetToDefault();
See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%% $$Properties$$

ImGearFormatParameters Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormatParameters Class

For a list of all members of this type, see ImGearFormatParameters members.

Public Properties
 | Name | Description
Public Property | Count | Gets the total number of control parameters for the format.
Public Property | Item | Gets control parameter by index.
Top
See Also

Reference

ImGearFormatParameters Class
ImageGear.Formats Namespace


Count Property (ImGearFormatParameters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFormatParameters Class : Count Property
Gets the total number of control parameters for the format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearFormatParameters
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Any non-negative integer value.
See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


Item Property (ImGearFormatParameters)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearFormatParameters Class : Item Property
Index of control parameter to get.
Gets control parameter by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ImGearControlParameter
'Usage

Dim instance As ImGearFormatParameters
Dim index As Integer
Dim value As ImGearControlParameter

value = instance.Item(index)
public ImGearControlParameter this[
   int index
]; {get;}
public: __property ImGearControlParameter* get_Item   int index
;
public:
property ImGearControlParameter^ default [int] {
   ImGearControlParameter^ get(int index);
}

Parameters

index
Index of control parameter to get.

Property Value

The ImGearControlParameter class interface of the control parameter from the collection of parameters.The ImGearControlParameter control parameter from the collection of parameters.
See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members
ImGearControlParameter Class


%%PageItemTitle%%

ImGearLoadOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearLoadOptions Class
Specifies additional loading options, such as thumbnail loading or loading an image specifying its format explicitly.
Object Model
ImGearLoadOptions ClassImGearFileFilters ClassImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLoadOptions
'Usage

Dim instance As ImGearLoadOptions
public class ImGearLoadOptions
public __gc class ImGearLoadOptions
public ref class ImGearLoadOptions
Remarks
Pass an instance of this class to image loading methods, such as ImGearFileFormats.LoadPage
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearLoadOptions
ImageGear.Formats.ImGearRawLoadOptions

See Also

Reference

ImGearLoadOptions Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearLoadOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearLoadOptions Class

The following tables list the members exposed by ImGearLoadOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearLoadOptions Constructor | Initializes a new instance of the ImGearLoadOptions class object.
Top
Public Properties
 | Name | Description
Public Property | Filters | Gets or sets filter settings to be used in a particular image loading operation.
Public Property | Format | Gets or sets the file format of an image to load, or enables format autodetection.
Public Property | ParseXMP | Gets or sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.
Public Property | ThumbnailLoading | Gets or sets a value indicating whether to load image thumbnail instead of the actual image.
Public Property | TilesToStitch | Gets or sets the tiles to be stitched.
Top
See Also

Reference

ImGearLoadOptions Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearLoadOptions Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : ImGearLoadOptions Constructor
Initializes a new instance of the ImGearLoadOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearLoadOptions()
public ImGearLoadOptions()
public: ImGearLoadOptions();
public:
ImGearLoadOptions();
See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%% $$Properties$$

ImGearLoadOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearLoadOptions Class

For a list of all members of this type, see ImGearLoadOptions members.

Public Properties
 | Name | Description
Public Property | Filters | Gets or sets filter settings to be used in a particular image loading operation.
Public Property | Format | Gets or sets the file format of an image to load, or enables format autodetection.
Public Property | ParseXMP | Gets or sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.
Public Property | ThumbnailLoading | Gets or sets a value indicating whether to load image thumbnail instead of the actual image.
Public Property | TilesToStitch | Gets or sets the tiles to be stitched.
Top
See Also

Reference

ImGearLoadOptions Class
ImageGear.Formats Namespace


Filters Property (ImGearLoadOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : Filters Property
Gets or sets filter settings to be used in a particular image loading operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Filters As ImGearFileFilters
'Usage

Dim instance As ImGearLoadOptions
Dim value As ImGearFileFilters

instance.Filters = value

value = instance.Filters
public ImGearFileFilters Filters {get; set;}
public: __property ImGearFileFilters* get_Filters();
public: __property void set_Filters(
   ImGearFileFilters* value
);
public:
property ImGearFileFilters^ Filters {
   ImGearFileFilters^ get();
   void set (    ImGearFileFilters^ value);
}

Property Value

ImGearFileFilters class object.
Remarks
If this property is not null, it overrides the global settings specified by ImGearFileFormats.Filters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members
ImGearFileFilters Class


Format Property (ImGearLoadOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : Format Property
Gets or sets the file format of an image to load, or enables format autodetection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Format As ImGearFormats
'Usage

Dim instance As ImGearLoadOptions
Dim value As ImGearFormats

instance.Format = value

value = instance.Format
public ImGearFormats Format {get; set;}
public: __property ImGearFormats get_Format();
public: __property void set_Format(
   ImGearFormats value
);
public:
property ImGearFormats Format {
   ImGearFormats get();
   void set (    ImGearFormats value);
}

Property Value

Any member of ImGearFormats enumeration value.
Remarks
Use this property when you need to bypass auto-detection and specify image format explicitly. Specifying ImGearFormats.UNKNOWN will force auto-detection.

The default value is ImGearFormats.UNKNOWN.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members
ImGearFormats Enumeration


ParseXMP Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : ParseXMP Property
Gets or sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ParseXMP As Boolean
'Usage

Dim instance As ImGearLoadOptions
Dim value As Boolean

instance.ParseXMP = value

value = instance.ParseXMP
public bool ParseXMP {get; set;}
public: __property bool get_ParseXMP();
public: __property void set_ParseXMP(
   bool value
);
public:
property bool ParseXMP {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


ThumbnailLoading Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : ThumbnailLoading Property
Gets or sets a value indicating whether to load image thumbnail instead of the actual image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ThumbnailLoading As Boolean
'Usage

Dim instance As ImGearLoadOptions
Dim value As Boolean

instance.ThumbnailLoading = value

value = instance.ThumbnailLoading
public bool ThumbnailLoading {get; set;}
public: __property bool get_ThumbnailLoading();
public: __property void set_ThumbnailLoading(
   bool value
);
public:
property bool ThumbnailLoading {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Use this property if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code ImageGear.Core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using ImageGear.Processing.ImGearProcessing.CreateThumbnail method.

The default value is false.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


TilesToStitch Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearLoadOptions Class : TilesToStitch Property
Gets or sets the tiles to be stitched.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TilesToStitch As ImGearRectangle
'Usage

Dim instance As ImGearLoadOptions
Dim value As ImGearRectangle

instance.TilesToStitch = value

value = instance.TilesToStitch
public ImGearRectangle TilesToStitch {get; set;}
public: __property ImGearRectangle get_TilesToStitch();
public: __property void set_TilesToStitch(
   ImGearRectangle value
);
public:
property ImGearRectangle TilesToStitch {
   ImGearRectangle get();
   void set (    ImGearRectangle value);
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks

The default value is an empty ImageGear.Core.ImGearRectangle struct object.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

ImGearNativeDataTypeHelper Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearNativeDataTypeHelper Class
Helps to work with ImageGear native data types associated with file formats metadata.
Object Model
ImGearNativeDataTypeHelper Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearNativeDataTypeHelper
'Usage

Dim instance As ImGearNativeDataTypeHelper
public class ImGearNativeDataTypeHelper
public __gc class ImGearNativeDataTypeHelper
public ref class ImGearNativeDataTypeHelper
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearNativeDataTypeHelper

See Also

Reference

ImGearNativeDataTypeHelper Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearNativeDataTypeHelper Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearNativeDataTypeHelper Class

The following tables list the members exposed by ImGearNativeDataTypeHelper.

Public Constructors
 | Name | Description
Public Constructor | ImGearNativeDataTypeHelper Constructor | Initializes a new instance of the ImGearNativeDataTypeHelper class object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetValueSize | Returns the value size in bytes for the specified data type.
Top
See Also

Reference

ImGearNativeDataTypeHelper Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearNativeDataTypeHelper Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearNativeDataTypeHelper Class : ImGearNativeDataTypeHelper Constructor
Initializes a new instance of the ImGearNativeDataTypeHelper class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearNativeDataTypeHelper()
public ImGearNativeDataTypeHelper()
public: ImGearNativeDataTypeHelper();
public:
ImGearNativeDataTypeHelper();
See Also

Reference

ImGearNativeDataTypeHelper Class
ImGearNativeDataTypeHelper Members


%%PageItemTitle%% $$Methods$$

ImGearNativeDataTypeHelper Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearNativeDataTypeHelper Class

For a list of all members of this type, see ImGearNativeDataTypeHelper members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetValueSize | Returns the value size in bytes for the specified data type.
Top
See Also

Reference

ImGearNativeDataTypeHelper Class
ImageGear.Formats Namespace


GetValueSize Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearNativeDataTypeHelper Class : GetValueSize Method
Data type for which to get the size.
Returns the value size in bytes for the specified data type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetValueSize( _
   ByVal typeId As ImGearNativeDataTypes _
) As Integer
'Usage

Dim typeId As ImGearNativeDataTypes
Dim value As Integer

value = ImGearNativeDataTypeHelper.GetValueSize(typeId)
public static int GetValueSize(
   ImGearNativeDataTypes typeId
)
public: static int GetValueSize(
   ImGearNativeDataTypes typeId
)
public:
static int GetValueSize(
   ImGearNativeDataTypes typeId
)

Parameters

typeId
Data type for which to get the size.

Return Value

Value size for the data type.
See Also

Reference

ImGearNativeDataTypeHelper Class
ImGearNativeDataTypeHelper Members
ImGearNativeDataTypes Enumeration


%%PageItemTitle%%

ImGearRasterSaveOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRasterSaveOptions Class
Provides rasterization options for saving.
Object Model
ImGearRasterSaveOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRasterSaveOptions
   Inherits ImGearSaveOptions
'Usage

Dim instance As ImGearRasterSaveOptions
public class ImGearRasterSaveOptions : ImGearSaveOptions
public __gc class ImGearRasterSaveOptions : public ImGearSaveOptions
public ref class ImGearRasterSaveOptions : public ImGearSaveOptions
Remarks
This class can be used to define rasterization options for saving vector pages and documents to raster formats.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearSaveOptions
ImageGear.Formats.ImGearRasterSaveOptions

See Also

Reference

ImGearRasterSaveOptions Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearRasterSaveOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRasterSaveOptions Class

The following tables list the members exposed by ImGearRasterSaveOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearRasterSaveOptions Constructor | Initializes a new instance of the ImGearRasterSaveOptions class.
Top
Public Properties
 | Name | Description
Public Property | BitDepth | Gets or sets the bit depth.
Public Property | ScaleX | Gets or sets the x-axis scale factor.
Public Property | ScaleY | Gets or sets the y-axis scale factor.
Top
See Also

Reference

ImGearRasterSaveOptions Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRasterSaveOptions Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearRasterSaveOptions Class : ImGearRasterSaveOptions Constructor
Initializes a new instance of the ImGearRasterSaveOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRasterSaveOptions()
public ImGearRasterSaveOptions()
public: ImGearRasterSaveOptions();
public:
ImGearRasterSaveOptions();
See Also

Reference

ImGearRasterSaveOptions Class
ImGearRasterSaveOptions Members


%%PageItemTitle%% $$Properties$$

ImGearRasterSaveOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRasterSaveOptions Class

For a list of all members of this type, see ImGearRasterSaveOptions members.

Public Properties
 | Name | Description
Public Property | BitDepth | Gets or sets the bit depth.
Public Property | ScaleX | Gets or sets the x-axis scale factor.
Public Property | ScaleY | Gets or sets the y-axis scale factor.
Top
See Also

Reference

ImGearRasterSaveOptions Class
ImageGear.Formats Namespace


BitDepth Property (ImGearRasterSaveOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearRasterSaveOptions Class : BitDepth Property
Gets or sets the bit depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitDepth As Integer
'Usage

Dim instance As ImGearRasterSaveOptions
Dim value As Integer

instance.BitDepth = value

value = instance.BitDepth
public int BitDepth {get; set;}
public: __property int get_BitDepth();
public: __property void set_BitDepth(
   int value
);
public:
property int BitDepth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Value of 0 indicates that the vector page bit depth is not changed.

The default value is 0.

This parameter is only used when saving PDF pages to raster. The following non-default values are supported for PDF: 1, 8, 24 and 32.

This parameter is ignored when saving Office or CAD/Vector pages to raster.

See Also

Reference

ImGearRasterSaveOptions Class
ImGearRasterSaveOptions Members


ScaleX Property (ImGearRasterSaveOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearRasterSaveOptions Class : ScaleX Property
Gets or sets the x-axis scale factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleX As Double
'Usage

Dim instance As ImGearRasterSaveOptions
Dim value As Double

instance.ScaleX = value

value = instance.ScaleX
public double ScaleX {get; set;}
public: __property double get_ScaleX();
public: __property void set_ScaleX(
   double value
);
public:
property double ScaleX {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Values between 0.0 and 1.0 decrease the vector page width.

Values greater than 1.0 increase the vector page width.

Value of 1.0 indicates that the vector page width is not scaled in the x-direction.

The default value is 1.0.

See Also

Reference

ImGearRasterSaveOptions Class
ImGearRasterSaveOptions Members


ScaleY Property (ImGearRasterSaveOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearRasterSaveOptions Class : ScaleY Property
Gets or sets the y-axis scale factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleY As Double
'Usage

Dim instance As ImGearRasterSaveOptions
Dim value As Double

instance.ScaleY = value

value = instance.ScaleY
public double ScaleY {get; set;}
public: __property double get_ScaleY();
public: __property void set_ScaleY(
   double value
);
public:
property double ScaleY {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Values between 0.0 and 1.0 decrease the vector page height.

Values greater than 1.0 increase the vector page height.

Value of 1.0 indicates that the vector page height is not scaled in the y-direction.

The default value is 1.0.

See Also

Reference

ImGearRasterSaveOptions Class
ImGearRasterSaveOptions Members


%%PageItemTitle%%

ImGearSaveOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveOptions Class
Specifies additional saving options.
Object Model
ImGearSaveOptions ClassImGearFileFilters ClassImGearSaveThumbnailOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSaveOptions
'Usage

Dim instance As ImGearSaveOptions
public class ImGearSaveOptions
public __gc class ImGearSaveOptions
public ref class ImGearSaveOptions
Remarks
Pass an instance of this class to image saving methods, such as ImGearFileFormats.SavePage
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearSaveOptions
ImageGear.Formats.ImGearRasterSaveOptions
ImageGear.Formats.PDF.ImGearPDFSaveOptions

See Also

Reference

ImGearSaveOptions Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearSaveOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveOptions Class

The following tables list the members exposed by ImGearSaveOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearSaveOptions Constructor | Initializes a new instance of the ImGearSaveOptions class object.
Top
Public Properties
 | Name | Description
Public Property | ConversionMode | Gets or sets raster converter's conversion mode for saving.
Public Property | EmbedColorProfile | Gets or sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.
Public Property | Filters | Gets or sets filter settings to be used in a particular image saving operation.
Public Property | ForceColorspace | Gets or sets the value indicating that images should only be saved in the specified color space.
Public Property | Thumbnail | Gets access to thumbnail saving options.
Top
See Also

Reference

ImGearSaveOptions Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearSaveOptions Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : ImGearSaveOptions Constructor
Initializes a new instance of the ImGearSaveOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearSaveOptions()
public ImGearSaveOptions()
public: ImGearSaveOptions();
public:
ImGearSaveOptions();
See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%% $$Properties$$

ImGearSaveOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveOptions Class

For a list of all members of this type, see ImGearSaveOptions members.

Public Properties
 | Name | Description
Public Property | ConversionMode | Gets or sets raster converter's conversion mode for saving.
Public Property | EmbedColorProfile | Gets or sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.
Public Property | Filters | Gets or sets filter settings to be used in a particular image saving operation.
Public Property | ForceColorspace | Gets or sets the value indicating that images should only be saved in the specified color space.
Public Property | Thumbnail | Gets access to thumbnail saving options.
Top
See Also

Reference

ImGearSaveOptions Class
ImageGear.Formats Namespace


ConversionMode Property
Example

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : ConversionMode Property
Gets or sets raster converter's conversion mode for saving.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConversionMode As ImGearRasterConversionModes
'Usage

Dim instance As ImGearSaveOptions
Dim value As ImGearRasterConversionModes

instance.ConversionMode = value

value = instance.ConversionMode
public ImGearRasterConversionModes ConversionMode {get; set;}
public: __property ImGearRasterConversionModes get_ConversionMode();
public: __property void set_ConversionMode(
   ImGearRasterConversionModes value
);
public:
property ImGearRasterConversionModes ConversionMode {
   ImGearRasterConversionModes get();
   void set (    ImGearRasterConversionModes value);
}

Property Value

ImGearRasterConversionModes enumeration value.
Remarks

The default value is ImGearRasterConversionModes.ANY.

Example
  • C#
ImGearSaveOptions saveOptions = new ImGearSaveOptions();
saveOptions.ConversionMode = ImGearRasterConversionModes.DIRECT_MATCH;
  • Visual Basic
Dim saveOptions As ImGearSaveOptions = New ImGearSaveOptions()
saveOptions.ConversionMode = ImGearRasterConversionModes.DIRECT_MATCH
See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members
ImGearRasterConversionModes Enumeration


EmbedColorProfile Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : EmbedColorProfile Property
Gets or sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EmbedColorProfile As Boolean
'Usage

Dim instance As ImGearSaveOptions
Dim value As Boolean

instance.EmbedColorProfile = value

value = instance.EmbedColorProfile
public bool EmbedColorProfile {get; set;}
public: __property bool get_EmbedColorProfile();
public: __property void set_EmbedColorProfile(
   bool value
);
public:
property bool EmbedColorProfile {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

This option has effect only if:

  • ImageGear color profile support is activated through ImageGear.Core.ImGearColorProfileManager.EnableProfiles.
  • Destination file format supports profile embedding.

The default value is true.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members
ImGearColorProfileManager Class


Filters Property (ImGearSaveOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : Filters Property
Gets or sets filter settings to be used in a particular image saving operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Filters As ImGearFileFilters
'Usage

Dim instance As ImGearSaveOptions
Dim value As ImGearFileFilters

instance.Filters = value

value = instance.Filters
public ImGearFileFilters Filters {get; set;}
public: __property ImGearFileFilters* get_Filters();
public: __property void set_Filters(
   ImGearFileFilters* value
);
public:
property ImGearFileFilters^ Filters {
   ImGearFileFilters^ get();
   void set (    ImGearFileFilters^ value);
}

Property Value

ImGearFileFilters class object.
Remarks
If this property is not null, it overrides the global settings specified by ImGearFileFormats.Filters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members
ImGearFileFilters Class


ForceColorspace Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : ForceColorspace Property
Gets or sets the value indicating that images should only be saved in the specified color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ForceColorspace As ImGearColorSpaceIDs
'Usage

Dim instance As ImGearSaveOptions
Dim value As ImGearColorSpaceIDs

instance.ForceColorspace = value

value = instance.ForceColorspace
public ImGearColorSpaceIDs ForceColorspace {get; set;}
public: __property ImGearColorSpaceIDs get_ForceColorspace();
public: __property void set_ForceColorspace(
   ImGearColorSpaceIDs value
);
public:
property ImGearColorSpaceIDs ForceColorspace {
   ImGearColorSpaceIDs get();
   void set (    ImGearColorSpaceIDs value);
}

Property Value

ImageGear.Core.ImGearColorSpaceIDs enumeration.
Remarks
Set this property to a specific color space ID to tell ImageGear use only this color space for image saving. If the file format supports this color space for saving, and other settings and control parameters allow saving to this color space, the image will be saved with the specified color space. Otherwise, ImageGear will throw an exception with ImageGear.Core.ImGearErrorCodes.CANT_SAVE_FORMAT error code.

This mode can be used for conversion of image files from one color space to another, without having to store converted image in memory. To convert an image, load it into ImageGear, set ForceColorspace to desired color space, and save the image.

If the property is set to ImageGear.Core.ImGearColorSpaceIDs.NONE, ImageGear does not force conversion to any color space, and saves the image using the color space that is supported by the saving format and best matches the source image.

The default value is ImageGear.Core.ImGearColorSpaceIDs.NONE.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members
ImGearErrorCodes Enumeration
ImGearColorSpaceIDs Enumeration


Thumbnail Property (ImGearSaveOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveOptions Class : Thumbnail Property
Gets access to thumbnail saving options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Thumbnail As ImGearSaveThumbnailOptions
'Usage

Dim instance As ImGearSaveOptions
Dim value As ImGearSaveThumbnailOptions

value = instance.Thumbnail
public ImGearSaveThumbnailOptions Thumbnail {get;}
public: __property ImGearSaveThumbnailOptions* get_Thumbnail();
public:
property ImGearSaveThumbnailOptions^ Thumbnail {
   ImGearSaveThumbnailOptions^ get();
}

Property Value

ImGearSaveThumbnailOptions class object.
See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members
ImGearSaveThumbnailOptions Class


%%PageItemTitle%%

ImGearSaveThumbnailOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveThumbnailOptions Class
Specifies thumbnail attributes such as width and height to be used when saving a thumbnail.
Object Model
ImGearSaveThumbnailOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearSaveThumbnailOptions
'Usage

Dim instance As ImGearSaveThumbnailOptions
public sealed class ImGearSaveThumbnailOptions
public __gc __sealed class ImGearSaveThumbnailOptions
public ref class ImGearSaveThumbnailOptions sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearSaveThumbnailOptions

See Also

Reference

ImGearSaveThumbnailOptions Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearSaveThumbnailOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveThumbnailOptions Class

The following tables list the members exposed by ImGearSaveThumbnailOptions.

Public Properties
 | Name | Description
Public Property | Compressed | Gets or sets a value indicating whether the thumbnail should be compressed.
Public Property | Enabled | Gets or sets a value indicating whether thumbnail saving is enabled or not.
Public Property | Height | Gets or sets the height of the thumbnail.
Public Property | Width | Gets or sets the width of the thumbnail.
Top
See Also

Reference

ImGearSaveThumbnailOptions Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Properties$$

ImGearSaveThumbnailOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSaveThumbnailOptions Class

For a list of all members of this type, see ImGearSaveThumbnailOptions members.

Public Properties
 | Name | Description
Public Property | Compressed | Gets or sets a value indicating whether the thumbnail should be compressed.
Public Property | Enabled | Gets or sets a value indicating whether thumbnail saving is enabled or not.
Public Property | Height | Gets or sets the height of the thumbnail.
Public Property | Width | Gets or sets the width of the thumbnail.
Top
See Also

Reference

ImGearSaveThumbnailOptions Class
ImageGear.Formats Namespace


Compressed Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveThumbnailOptions Class : Compressed Property
Gets or sets a value indicating whether the thumbnail should be compressed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compressed As Boolean
'Usage

Dim instance As ImGearSaveThumbnailOptions
Dim value As Boolean

instance.Compressed = value

value = instance.Compressed
public bool Compressed {get; set;}
public: __property bool get_Compressed();
public: __property void set_Compressed(
   bool value
);
public:
property bool Compressed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

The default value is false.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


Enabled Property (ImGearSaveThumbnailOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveThumbnailOptions Class : Enabled Property
Gets or sets a value indicating whether thumbnail saving is enabled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As ImGearSaveThumbnailOptions
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Setting this property to true will enable saving a thumbnail.

The default value is false.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


Height Property (ImGearSaveThumbnailOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveThumbnailOptions Class : Height Property
Gets or sets the height of the thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearSaveThumbnailOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Any integer value greater than 0.
Remarks

The default value is 64.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


Width Property (ImGearSaveThumbnailOptions)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearSaveThumbnailOptions Class : Width Property
Gets or sets the width of the thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearSaveThumbnailOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Any integer value greater than 0.
Remarks

The default value is 64.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

ImGearWebStream Class
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWebStream Class
Provides a specialized stream for loading of images from internet.
Object Model
ImGearWebStream Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearWebStream
   Inherits System.IO.Stream
'Usage

Dim instance As ImGearWebStream
public class ImGearWebStream : System.IO.Stream
public __gc class ImGearWebStream : public System.IO.Stream
public ref class ImGearWebStream : public System.IO.Stream
Remarks
This class is most useful for loading of multipage images, because it downloads only the necessary portion of remote file.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
ImageGear.Formats.ImGearWebStream

See Also

Reference

ImGearWebStream Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearWebStream Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWebStream Class

The following tables list the members exposed by ImGearWebStream.

Public Constructors
 | Name | Description
Public Constructor | ImGearWebStream Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CanRead | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports reading.
Public Property | CanSeek | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
Public Property | CanWrite | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Public Property | Length | Overridden. When overridden in a derived class, gets the length in bytes of the stream.
Public Property | Position | Overridden. When overridden in a derived class, gets or sets the position within the current stream.
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Public Method | Flush | Overridden. When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Public Method | Read | Overridden. When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Public Method | Seek | Overridden. When overridden in a derived class, sets the position within the current stream.
Public Method | SetLength | Overridden. When overridden in a derived class, sets the length of the current stream.
Public Method | Write | Overridden. When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearWebStream class.
Top
See Also

Reference

ImGearWebStream Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearWebStream Constructor

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : ImGearWebStream Constructor
Overload List
Overload | Description
ImGearWebStream Constructor(String) | Initializes a new instance of the ImGearWebStream class.
ImGearWebStream Constructor(String,NetworkCredential,IWebProxy) | Initializes a new instance of the ImGearWebStream class.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


%%PageItemTitle%%

ImGearWebStream Constructor(String)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class > ImGearWebStream Constructor : ImGearWebStream Constructor(String)
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.
Initializes a new instance of the ImGearWebStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal path As String _
)
'Usage

Dim path As String

Dim instance As New ImGearWebStream(path)
public ImGearWebStream(
   string path
)
public: ImGearWebStream(
   string* path
)
public:
ImGearWebStream(
   String^ path
)

Parameters

path
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members
Overload List


%%PageItemTitle%%

ImGearWebStream Constructor(String,NetworkCredential,IWebProxy)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class > ImGearWebStream Constructor : ImGearWebStream Constructor(String,NetworkCredential,IWebProxy)
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.
Authentication information.
Proxy information.
Initializes a new instance of the ImGearWebStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal path As String, _
   ByVal credentials As NetworkCredential, _
   ByVal proxy As IWebProxy _
)
'Usage

Dim path As String
Dim credentials As NetworkCredential
Dim proxy As IWebProxy

Dim instance As New ImGearWebStream(path, credentials, proxy)
public ImGearWebStream(
   string path,
   NetworkCredential credentials,
   IWebProxy proxy
)
public: ImGearWebStream(
   string* path,
   NetworkCredential* credentials,
   IWebProxy* proxy
)
public:
ImGearWebStream(
   String^ path,
   NetworkCredential^ credentials,
   IWebProxy^ proxy
)

Parameters

path
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.
credentials
Authentication information.
proxy
Proxy information.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearWebStream Class Methods

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWebStream Class

For a list of all members of this type, see ImGearWebStream members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Public Method | Flush | Overridden. When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Public Method | Read | Overridden. When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Public Method | Seek | Overridden. When overridden in a derived class, sets the position within the current stream.
Public Method | SetLength | Overridden. When overridden in a derived class, sets the length of the current stream.
Public Method | Write | Overridden. When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearWebStream class.
Top
See Also

Reference

ImGearWebStream Class
ImageGear.Formats Namespace


Close Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Close Method
Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As ImGearWebStream

instance.Close()
public override void Close()
public: void Close(); override
public:
void Close(); override
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Dispose Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Dispose Method
Disposes ImGearWebStream instance.
Overload List
Overload | Description
Dispose(Boolean) | Disposes ImGearWebStream instance.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Dispose(Boolean) Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class > Dispose Method : Dispose(Boolean) Method
Specifies whether the associated resources shall be disposed.
Disposes ImGearWebStream instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearWebStream
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Specifies whether the associated resources shall be disposed.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members
Overload List


Finalize Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Finalize Method
Finalizes an instance of the ImGearWebStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearWebStream

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
Remarks
Use Close method to correctly close the stream and release the associated resources.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Flush Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Flush Method
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flush()
'Usage

Dim instance As ImGearWebStream

instance.Flush()
public override void Flush()
public: void Flush(); override
public:
void Flush(); override
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Read Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Read Method
When this method returns, contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
The byte offset in array at which to begin reading.
The maximum number of bytes to read.
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
'Usage

Dim instance As ImGearWebStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
When this method returns, contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
The byte offset in array at which to begin reading.
count
The maximum number of bytes to read.

Return Value

Integer value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Seek Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Seek Method
The point relative to origin from which to begin seeking.
Specifies the beginning, the end, or the current position as a reference point for origin, using a value of type SeekOrigin.
When overridden in a derived class, sets the position within the current stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
'Usage

Dim instance As ImGearWebStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
public override long Seek(
   long offset,
   SeekOrigin origin
)
public: long Seek(
   long offset,
   SeekOrigin origin
) override
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The point relative to origin from which to begin seeking.
origin
Specifies the beginning, the end, or the current position as a reference point for origin, using a value of type SeekOrigin.

Return Value

Integer value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


SetLength Method

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : SetLength Method
The new length of the stream.
When overridden in a derived class, sets the length of the current stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub SetLength( _
   ByVal value As Long _
)
'Usage

Dim instance As ImGearWebStream
Dim value As Long

instance.SetLength(value)
public override void SetLength(
   long value
)
public: void SetLength(
   long value
) override
public:
void SetLength(
   int64 value
) override

Parameters

value
The new length of the stream.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Write Method (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Write Method
The array to which bytes are written.
The byte offset in array at which to begin writing.
The maximum number of bytes to write.
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearWebStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array to which bytes are written.
offset
The byte offset in array at which to begin writing.
count
The maximum number of bytes to write.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


%%PageItemTitle%% $$Properties$$

ImGearWebStream Class Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWebStream Class

For a list of all members of this type, see ImGearWebStream members.

Public Properties
 | Name | Description
Public Property | CanRead | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports reading.
Public Property | CanSeek | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
Public Property | CanWrite | Overridden. When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Public Property | Length | Overridden. When overridden in a derived class, gets the length in bytes of the stream.
Public Property | Position | Overridden. When overridden in a derived class, gets or sets the position within the current stream.
Top
See Also

Reference

ImGearWebStream Class
ImageGear.Formats Namespace


CanRead Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : CanRead Property
When overridden in a derived class, gets a value indicating whether the current stream supports reading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property CanRead As Boolean
'Usage

Dim instance As ImGearWebStream
Dim value As Boolean

value = instance.CanRead
public override bool CanRead {get;}
public: __property bool get_CanRead() override;
public:
property bool CanRead {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


CanSeek Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : CanSeek Property
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property CanSeek As Boolean
'Usage

Dim instance As ImGearWebStream
Dim value As Boolean

value = instance.CanSeek
public override bool CanSeek {get;}
public: __property bool get_CanSeek() override;
public:
property bool CanSeek {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


CanWrite Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : CanWrite Property
When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property CanWrite As Boolean
'Usage

Dim instance As ImGearWebStream
Dim value As Boolean

value = instance.CanWrite
public override bool CanWrite {get;}
public: __property bool get_CanWrite() override;
public:
property bool CanWrite {
   bool get() override;
}

Property Value

Boolean value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Length Property (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Length Property
When overridden in a derived class, gets the length in bytes of the stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Length As Long
'Usage

Dim instance As ImGearWebStream
Dim value As Long

value = instance.Length
public override long Length {get;}
public: __property long get_Length() override;
public:
property int64 Length {
   int64 get() override;
}

Property Value

Any positive value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


Position Property (ImGearWebStream)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > ImGearWebStream Class : Position Property
When overridden in a derived class, gets or sets the position within the current stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Position As Long
'Usage

Dim instance As ImGearWebStream
Dim value As Long

instance.Position = value

value = instance.Position
public override long Position {get; set;}
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

Property Value

Any non-negative value.
See Also

Reference

ImGearWebStream Class
ImGearWebStream Members


%%PageItemTitle%%

ImGearBMPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearBMPTagIDs Enumeration
Lists all BMP tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBMPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearBMPTagIDs
public enum ImGearBMPTagIDs : System.Enum
__value public enum ImGearBMPTagIDs : public System.Enum
public enum class ImGearBMPTagIDs : public System.Enum
Members
Member | Value | Description
BITCOUNT | 104 | Image bit count.
CLRIMPORTANT | 109 | Number of color indexes required for displaying the bitmap.
CLRUSED | 108 | Number of color indexes in the color table that are actually used by the bitmap.
COLORENCODING | 115 | Color model used in bitmap (IBM OS/2 2.x).
COMPRESSION | 105 | Image compression type.
FORMAT | 1 | BMP metadata format identifier.
HEIGHT | 102 | Image height.
IDENTIFIER | 116 | Reserved for application use (IBM OS/2 2.x).
PLANES | 103 | Number of color planes.
RECORDING | 111 | Recording algorithm (IBM OS/2 2.x).
RENDERING | 112 | Halftoning algorithm used (IBM OS/2 2.x).
SIZE | 100 | Image size.
SIZE1 | 113 | Reserved for halftoning algorithm use (IBM OS/2 2.x).
SIZE2 | 114 | Reserved for halftoning algorithm use (IBM OS/2 2.x).
TYPE | 117 | BMP format type.
UNITS | 110 | Type of units used to measure resolution (IBM OS/2 2.x).
WIDTH | 101 | Image width.
XPELSPERMETER | 106 | Horizontal resolution in pixels per meter.
YPELSPERMETER | 107 | Vertical resolution in pixels per meter.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearBMPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearBTRTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearBTRTagIDs Enumeration
Lists all BTR tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBTRTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearBTRTagIDs
public enum ImGearBTRTagIDs : System.Enum
__value public enum ImGearBTRTagIDs : public System.Enum
public enum class ImGearBTRTagIDs : public System.Enum
Members
Member | Value | Description
BITSPERPIXEL | 905 | Bits per pixel.
FORMAT | 29 | BTR metadata format identifier.
HORZRES | 903 | Horizontal resolution.
IMAGETYPE | 902 | Image type.
MANUFACTURER | 900 | Manufacturer value.
NEXTPAGE | 910 | Next page.
NUMLINES | 911 | Number of lines.
PIXELSPERLINE | 906 | Pixels per line.
PREVPAGE | 909 | Previous page.
STORAGEFMT | 907 | Storage format.
TRANSFMT | 908 | Trans format.
VERSION | 901 | Version value.
VERTRES | 904 | Vertical resolution.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearBTRTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCALTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCALTagIDs Enumeration
Lists all CAL tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCALTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCALTagIDs
public enum ImGearCALTagIDs : System.Enum
__value public enum ImGearCALTagIDs : public System.Enum
public enum class ImGearCALTagIDs : public System.Enum
Members
Member | Value | Description
DOCCLS | 310 | Document security lable.
DSTDOCID | 302 | Destination system document identifier.
FIGID | 304 | Figure or table identifier. This is the number by which the image page figure is referenced.
FORMAT | 2 | CAL metadata format identifier.
FOSIPUBID | 311 | PUBLIC identifier of an associated FOSI.
NOTES | 312 | Notes information that is not applicable to any of the other records in the CALS raster file header.
RDENSITY | 308 | Raster image density.
RORIENT | 306 | Raster image orientation.
RPELCNT | 307 | Raster image pel count.
RTYPE | 305 | Raster data type. This is the format of raster image data that follows the header record data block in this file.
SPECVERSION | 300 | Spec version.
SRCDOCID | 301 | Source system document identifier.
SRCGPH | 309 | Source system graphics filename.
TXTFILID | 303 | Text file identifier. This record contains a string indicating the document page that this image page contains.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCALTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFAFInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFAFInfoTagIDs Enumeration
Lists all CIFF AF Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFAFInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFAFInfoTagIDs
public enum ImGearCIFFAFInfoTagIDs : System.Enum
__value public enum ImGearCIFFAFInfoTagIDs : public System.Enum
public enum class ImGearCIFFAFInfoTagIDs : public System.Enum
Members
Member | Value | Description
AF_AREA_HEIGHT | 7 | AF area height.
AF_AREA_WIDTH | 6 | AF area width.
AF_AREA_X_POSITIONS | 8 | AF area X position.
AF_AREA_Y_POSITIONS | 9 | AF area Y position.
AF_IMAGE_HEIGHT | 5 | AF image height.
AF_IMAGE_WIDTH | 4 | AF image width.
AF_POINTS_IN_FOCUS | 10 | AF points in focus.
AFPOINTS_USED | 22 | AF points used.
AFPOINTS_USED1 | 26 | AF points used1.
CANON_IMAGE_HEIGHT | 3 | Canon image height.
CANON_IMAGE_WIDTH | 2 | Canon image width.
FORMAT | 1305 | CIFF AF Info metadata format identifier.
NUM_AF_POINTS | 0 | Number of AF points.
PRIMARY_AF_POINT | 12 | Primary AF point.
PRIMARY_AF_POINT_or_AFInfo | 11 | Primary AF point or AFInfo.
VALID_AF_POINTS | 1 | Valid AF points.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFAFInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFCanonCameraSettingsTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFCanonCameraSettingsTagIDs Enumeration
Lists all CIFF Canon Camera Settings tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFCanonCameraSettingsTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFCanonCameraSettingsTagIDs
public enum ImGearCIFFCanonCameraSettingsTagIDs : System.Enum
__value public enum ImGearCIFFCanonCameraSettingsTagIDs : public System.Enum
public enum class ImGearCIFFCanonCameraSettingsTagIDs : public System.Enum
Members
Member | Value | Description
AE_SETTING | 33 | AE setting.
AFPOINT | 19 | AF point setting.
CANON_EXPOSURE_MODE | 20 | Canon exposure mode.
CANON_FLASH_MODE | 4 | Canon flash mode.
CANON_IMAGE_SIZE | 10 | Canon image size.
COLOR_TONE | 42 | Color tone.
CONTINUOUS_DRIVE | 5 | Continuous drive.
CONTRAST | 13 | Contrast setting.
DIGITAL_ZOOM | 12 | Digital zoom.
DISPLAY_APERTURE | 35 | Display aperture.
EASY_MODE | 11 | Easy mode.
FLASH_ACTIVITY | 28 | Flash activity.
FLASH_BITS | 29 | Flash bits.
FOCAL_UNITS | 25 | Focal units.
FOCUS_CONTINUOUS | 32 | Focus continuous.
FOCUS_MODE | 7 | Focus mode.
FOCUS_TYPE | 18 | Focus type.
FORMAT | 1302 | CIFFCanonCameraSettings metadata format identifier.
IMAGE_STABILIZATION | 34 | Image stabilization.
ISO | 16 | Camera ISO.
LENS_TYPE | 22 | Lens type.
LONG_FOCAL | 23 | Long focal.
MACRO_MODE | 1 | Macro mode.
MANUAL_FLASH_OUTPUT | 41 | Manual flash output.
MAX_APERTURE | 26 | Max aperture.
METERING_MODE | 17 | Metering mode.
MIN_APERTURE | 27 | Min aperture.
PHOTO_EFFECT | 40 | Photo effec.
QUALITY | 3 | Quality setting.
RECORD_MODE | 9 | Record mode.
SATURATION | 14 | Saturation setting.
SELF_TIMER | 2 | Self-timer value.
SHARPNESS | 15 | Sharpness setting.
SHORT_FOCAL | 24 | Short focal.
ZOOMED_RESOLUTION | 36 | Zoomed resolution.
ZOOMED_RESOLUTION_BASE | 37 | Zoomed resolution base.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFCanonCameraSettingsTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFFocalLengthTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFFocalLengthTagIDs Enumeration
Lists all CIFF Focal Length tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFFocalLengthTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFFocalLengthTagIDs
public enum ImGearCIFFFocalLengthTagIDs : System.Enum
__value public enum ImGearCIFFFocalLengthTagIDs : public System.Enum
public enum class ImGearCIFFFocalLengthTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1303 | CIFFFocalLength metadata format identifier.
LENGTH | 1 | Focal length.
PLANE_XSIZE | 2 | Focal plane X size.
PLANE_YSIZE | 3 | Focal plane Y size.
TYPE | 0 | Focal length type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFFocalLengthTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFImageInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFImageInfoTagIDs Enumeration
Lists all CIFF Image Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFImageInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFImageInfoTagIDs
public enum ImGearCIFFImageInfoTagIDs : System.Enum
__value public enum ImGearCIFFImageInfoTagIDs : public System.Enum
public enum class ImGearCIFFImageInfoTagIDs : public System.Enum
Members
Member | Value | Description
COLOR_BIT_DEPTH | 5 | Color bit depth.
COLOR_BW | 6 | Color BW information.
COMPONENT_BIT_DEPTH | 4 | Component bit depth.
FORMAT | 1306 | CIFF image Info metadata format identifier.
HEIGHT | 1 | Height CIFF image Info.
PIXEL_ASPECT_RATIO | 2 | Pixel aspect ratio.
ROTATION | 3 | Rotation CIFF image Info.
WIDTH | 0 | Width CIFF image Info.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFImageInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFShotInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFShotInfoTagIDs Enumeration
Lists all CIFF Shot Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFShotInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFShotInfoTagIDs
public enum ImGearCIFFShotInfoTagIDs : System.Enum
__value public enum ImGearCIFFShotInfoTagIDs : public System.Enum
public enum class ImGearCIFFShotInfoTagIDs : public System.Enum
Members
Member | Value | Description
AEBBRACKET_VALUE | 17 | AEB bracket value.
AUTO_EXPOSURE_BRACKETING | 16 | Auto exposure bracketing.
AUTO_ISO | 1 | Auto ISO value.
AUTO_ROTATE | 27 | Auto rotate.
BULB_DURATION | 24 | Bulb duration.
CAMERA_TYPE | 26 | Camera type.
EXPOSURE_COMPENSATION | 6 | Exposure compensation.
EXPOSURE_TIME | 22 | Exposure time.
FLASH_EXPOSURE_COMP | 15 | Flash exposure comp.
FLASH_GUIDE_NUMBER | 13 | Flash GUIDE number.
FLASH_OUTPUT | 33 | Flash output.
FNUMBER | 21 | F number value.
FOCUS_DISTANCE_LOWER | 20 | Focus distance lower.
FOCUS_DISTANCE_UPPER | 19 | Focus distance upper.
FORMAT | 1304 | CIFF Shot Info metadata format identifier.
ISO | 2 | Base ISO value.
IXUS_AFPOINT | 14 | Ixus AF point.
MEASURED_EV | 3 | Measured EV.
ND_FILTER | 28 | No filter.
OPTICAL_ZOOM_CODE | 10 | Optical zoom code.
SELF_TIMER2 | 29 | Self-timer 2.
SEQUENCE_NUMBER | 9 | Sequence number.
SLOW_SHUTTER | 8 | Slow shutter.
TARGET_APERTURE | 4 | Target aperture.
TARGET_EXPOSURETIME | 5 | Target exposition.
WHITE_BALANCE | 7 | White balance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFShotInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCIFFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCIFFTagIDs Enumeration
Lists all CIFF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCIFFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCIFFTagIDs
public enum ImGearCIFFTagIDs : System.Enum
__value public enum ImGearCIFFTagIDs : public System.Enum
public enum class ImGearCIFFTagIDs : public System.Enum
Members
Member | Value | Description
BASE_ISO | 0x0000101C | Base ISO number.
CAMERA_OBJECT | 0x00002807 | Camera object.
CAMERA_SPECIFICATION | 0x00003004 | Camera specification.
CANON_CAMERA_SETTINGS | 0x0000102D | Canon camera settings.
CANON_COLOR_INFO1 | 0x00000032 | Canon color info 1.
CANON_COLOR_INFO2 | 0x0000102C | Canon color info 2.
CANON_CUSTOM_FUNCTIONS | 0x00001033 | Canon custom functions.
CANON_FILE_DESCRIPTION | 0x00000805 | Canon file description.
CANON_FIRMWARE_VERSION | 0x0000080B | Canon firmware version.
CANON_IMAGE_TYPE | 0x00000815 | Canon image type.
CANON_PICTURE_INFO | 0x00001038 | Canon picture info.
CANON_RAW_MAKE_MODEL | 0x0000080A | Canon raw make model.
CANON_SHOT_INFO | 0x0000102A | Canon shot info.
COLOR_SPACE | 0x000010B4 | Color space.
COLOR_TEMPERATURE | 0x000010AE | Color temperature.
COMPONENT_VERSION | 0x0000080C | Component version.
DECODER_TABLE | 0x00001835 | Decoder table.
EXIF_INFORMATION | 0x0000300B | Exif information.
EXPOSURE_INFO | 0x00001818 | Exposure info.
FILE_NUMBER | 0x00001817 | File number.
FLASH_INFO | 0x00001813 | Flash info.
FOCAL_LENGTH | 0x00001029 | Focal length.
FORMAT | 0x00000515 | CIFF metadata format identifier.
FREE_BYTES | 0x00000001 | Free bytes.
IMAGE_DESCRIPTION | 0x00002804 | Image description.
IMAGE_FORMAT | 0x00001803 | Image format.
IMAGE_INFO | 0x00001810 | Image info.
IMAGE_PROPS | 0x0000300A | Image props.
JPG_FROM_RAW | 0x00002007 | Jpg from raw.
MEASURED_EV | 0x00001814 | Measured EV.
MEASURED_INFO | 0x00003003 | Measured info.
NULL_RECORD | 0x00000000 | Null record.
ORIGINAL_FILE_NAME | 0x00000816 | Original file name.
OWNER_NAME | 0x00000810 | Owner name.
RAW_DATA | 0x00002005 | The raw data.
RECORD_ID | 0x00001804 | Record ID.
RELEASE_SETTING | 0x00001016 | Release setting.
ROM_OPERATION_MODE | 0x0000080D | ROM operation mode.
SELF_TIMER_TIME | 0x00001806 | Self timer time.
SENSOR_INFO | 0x00001031 | Sensor info.
SERIAL_NUMBER | 0x0000180B | Serial number.
SHOOTING_RECORD | 0x00003002 | Shooting record.
SHUTTER_RELEASE_METHOD | 0x00001010 | Shutter release method.
SHUTTER_RELEASE_TIMING | 0x00001011 | Shutter release timing.
TARGET_DISTANCE_SETTING | 0x00001807 | Target distance setting.
TARGET_IMAGE_TYPE | 0x0000100A | Target image type.
THUMBNAIL_FILE_NAME | 0x00000817 | Thumbnail file name.
THUMBNAIL_IMAGE | 0x00002008 | Thumbnail image.
TIME_STAMP | 0x0000180E | Time stamp.
USER_COMMENT | 0x00000805 | User comment.
WHITE_BALANCE_TABLE | 0x000010A9 | White balance table.
WHITE_SAMPLE | 0x00001030 | White sample.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCIFFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCLPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCLPTagIDs Enumeration
Lists all CLP tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCLPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCLPTagIDs
public enum ImGearCLPTagIDs : System.Enum
__value public enum ImGearCLPTagIDs : public System.Enum
public enum class ImGearCLPTagIDs : public System.Enum
Members
Member | Value | Description
FILE_ID | 1701 | File magic id value.
FORMAT | 3 | CLP metadata format identifier.
FORMAT_COUNT | 1702 | Format count.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCLPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCompressions Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCompressions Enumeration
Lists all ImageGear supported compressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCompressions
   Inherits System.Enum
'Usage

Dim instance As ImGearCompressions
public enum ImGearCompressions : System.Enum
__value public enum ImGearCompressions : public System.Enum
public enum class ImGearCompressions : public System.Enum
Members
Member | Value | Description
ABIC | 0x0000000F | IBM ABIC compression.
ABIC_BW | 0x00000010 | IBM ABIC Bilevel compression.
ABIC_GRAY | 0x00000011 | IBM ABIC Concatenated compression.
ASCII | 0x0000000C | ASCII compression.
AUTO | 0x00000000 | On loading: compression is unknown. On saving: compression is selected by file format.
CANON_CRW | 0x00000015 | Canon CRW compression.
CCITT_G3 | 0x00000003 | CCITT Group 3 compression.
CCITT_G32D | 0x00000005 | CCITT Group 3 2D compression.
CCITT_G4 | 0x00000004 | CCITT Group 4.compression.
DEFLATE | 0x0000000A | Deflate compression.
HDPhoto | 0x00000014 | HD Photo compression.
HUFFMAN | 0x00000002 | Huffman compression.
IBM_MMR | 0x0000000E | IBM MMR compression.
JBIG | 0x00000012 | JBIG compression.
JBIG2 | 0x00000013 | JBIG2 compression.
JPEG | 0x00000007 | JPEG compression.
JPEG2K | 0x0000000B | JPEG 2000 compression.
KODAK_RAW | 0x00000016 | Kodak RAW compression.
LZW | 0x00000009 | LZW compression.
NONE | 0x00000001 | No compression.
PACKED_BITS | 0x00000006 | Packed bits compression.
RAW | 0x0000000D | Raw compression.
RLE | 0x00000008 | Run Length Encoding compression.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCompressions

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearCUTTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearCUTTagIDs Enumeration
Lists all CUT tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCUTTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearCUTTagIDs
public enum ImGearCUTTagIDs : System.Enum
__value public enum ImGearCUTTagIDs : public System.Enum
public enum class ImGearCUTTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 35 | CUT metadata format identifier.
HEIGHT | 1 | Image height.
RESERVED | 2 | Reserved value.
WIDTH | 0 | Image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearCUTTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearDCRAWTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearDCRAWTagIDs Enumeration
Lists all Digital Camera RAW tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDCRAWTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearDCRAWTagIDs
public enum ImGearDCRAWTagIDs : System.Enum
__value public enum ImGearDCRAWTagIDs : public System.Enum
public enum class ImGearDCRAWTagIDs : public System.Enum
Members
Member | Value | Description
AS_SHOT_WHITEXY | 4227 | As shot white XY.
ASSHOTNEUTRAL | 4215 | As shot neutral.
BASELINEEXPOSURE | 4221 | Baseline exposure.
BITSPERSAMPLE | 4204 | Bits per sample.
BLACKLEVEL | 4214 | Black level.
BLACKLEVELREPEATDIM | 4213 | Black level repeat dim.
CALIBRATIONILLUMINANT1 | 4217 | Calibration illuminant 1.
CALIBRATIONILLUMINANT2 | 4218 | Calibration illuminant 2.
CFAPATTERN | 4212 | CFA pattern.
CFAREPEATPATTERNDIM | 4211 | CFA repeat pattern dim.
COLORMATRIX1 | 4219 | Color matrix 1.
COLORMATRIX2 | 4220 | Color matrix 2.
COLORPLANES | 4226 | Color planes.
COMMON | 4200 | Common metadata section.
FORMAT | 1300 | DCRAW metadata format identifier.
IMAGEHEIGHT | 4203 | Image height.
IMAGEWIDTH | 4202 | Image width.
MAKE | 4208 | Camera producer.
MODEL | 4209 | Camera model.
PHOTOMETRICINTERPRETATION | 4205 | Photometric interpretation.
RAWHEIGHT | 4225 | Raw height.
RAWLEFT | 4222 | Actual raw image start left position.
RAWTOP | 4223 | Actual raw image start top position.
RAWWIDTH | 4224 | Raw width.
SAMPLESPERPIXEL | 4206 | Samples per pixel.
STATISTICS | 4201 | Statistics metadata section.
TIMESTAMP | 4210 | Time stamp.
UNIQUECAMERAMODEL | 4207 | Unique camera model.
WHITELEVEL | 4216 | White level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearDCRAWTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearDCXTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearDCXTagIDs Enumeration
Lists all DCX tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDCXTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearDCXTagIDs
public enum ImGearDCXTagIDs : System.Enum
__value public enum ImGearDCXTagIDs : public System.Enum
public enum class ImGearDCXTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 4 | DCX metadata format identifier.
MAGIC | 500 | Magic value.
PAGE_LIST | 501 | Page list.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearDCXTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearDisplayInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearDisplayInfoTagIDs Enumeration
Lists all Photoshop Display Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDisplayInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearDisplayInfoTagIDs
public enum ImGearDisplayInfoTagIDs : System.Enum
__value public enum ImGearDisplayInfoTagIDs : public System.Enum
public enum class ImGearDisplayInfoTagIDs : public System.Enum
Members
Member | Value | Description
DATA | 1 | Display data.
FORMAT | 1124 | Display info metadata format identifier.
LENGTH | 0 | Display length.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearDisplayInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFFPXRTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFFPXRTagIDs Enumeration
Lists all EXIF FPXR tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFFPXRTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFFPXRTagIDs
public enum ImGearEXIFFPXRTagIDs : System.Enum
__value public enum ImGearEXIFFPXRTagIDs : public System.Enum
public enum class ImGearEXIFFPXRTagIDs : public System.Enum
Members
Member | Value | Description
EXTENSIONID | 61223 | FPXR extension ID.
FORMAT | 1103 | EXIF_FPXR metadata format identifier.
HEADER | 61221 | FPXR header.
INDEXTOCONTENTSLIST | 61225 | FPXR index to contents list.
INTEROPERABILITYCOUNT | 61224 | FPXR interoperability count.
OFFSETTOSTREAM | 61226 | FPXR offset to stream.
RESERVEDDATA | 61228 | FPXR reserved data.
STREAMDATA | 61227 | FPXR stream data.
VERSION | 61222 | FPXR version.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFFPXRTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFGPSTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFGPSTagIDs Enumeration
Lists all EXIF GPS tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSTagIDs
public enum ImGearEXIFGPSTagIDs : System.Enum
__value public enum ImGearEXIFGPSTagIDs : public System.Enum
public enum class ImGearEXIFGPSTagIDs : public System.Enum
Members
Member | Value | Description
ALTITUDE | 6 | GPS altitude.
ALTITUDEREF | 5 | GPS altitude ref.
AREAINFORMATION | 28 | GPS area information.
DATESTAMP | 29 | GPS date stamp.
DESTBEARING | 24 | GPS dest bearing.
DESTBEARINGREF | 23 | GPS dest bearing ref.
DESTDISTANCE | 26 | GPS dest distance.
DESTDISTANCEREF | 25 | GPS dest distance ref.
DESTLATITUDE | 20 | GPS dest latitude.
DESTLATITUDEREF | 19 | GPS dest latitude ref.
DESTLONGITUDE | 22 | GPS dest longitude.
DESTLONGITUDEREF | 21 | GPS dest longitude ref.
DIFFERENTIAL | 30 | GPS differential.
DOP | 11 | Measurement precision.
FORMAT | 1101 | EXIF_GPS metadata format identifier.
IMGDIRECTION | 17 | GPS img direction.
IMGDIRECTIONREF | 16 | GPS img direction ref.
LATITUDE | 2 | GPS latitude.
LATITUDEREF | 1 | GPS latitude ref.
LONGITUDE | 4 | GPS longitude.
LONGITUDEREF | 3 | GPS longitude ref.
MAPDATUM | 18 | GPS map datum.
MEASUREMODE | 10 | GPS measure mode.
PROCESSINGMETHOD | 27 | GPS processing method.
SATELLITES | 8 | GPS satellites.
SPEED | 13 | GPS speed.
SPEEDREF | 12 | GPS speed ref.
STATUS | 9 | GPS status.
TIMESTAMP | 7 | GPS time stamp.
TRACK | 15 | GPS track.
TRACKREF | 14 | GPS track ref.
VERSIONID | 0 | GPS version ID.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFGPSTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFInterOpTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFInterOpTagIDs Enumeration
Lists all EXIF Interoperability tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFInterOpTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFInterOpTagIDs
public enum ImGearEXIFInterOpTagIDs : System.Enum
__value public enum ImGearEXIFInterOpTagIDs : public System.Enum
public enum class ImGearEXIFInterOpTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1102 | EXIF_Interoperability metadata format identifier.
INTEROPERABILITYINDEX | 1 | Interoperability index.
INTEROPERABILITYVERSION | 2 | Interoperability version.
RELATEDIMAGEFILEFORMAT | 4096 | Related image file format.
RELATEDIMAGELENGTH | 4098 | Related image length.
RELATEDIMAGEWIDTH | 4097 | Related image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFInterOpTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteFujiTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteFujiTagIDs Enumeration
Lists all Fujifilm EXIF MakerNote tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteFujiTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteFujiTagIDs
public enum ImGearEXIFMakerNoteFujiTagIDs : System.Enum
__value public enum ImGearEXIFMakerNoteFujiTagIDs : public System.Enum
public enum class ImGearEXIFMakerNoteFujiTagIDs : public System.Enum
Members
Member | Value | Description
AUTOEXPOSUREWARNING | 0x00001302 | Auto exposure warning.
BLURWARNING | 0x00001300 | Blur warning.
COLOUR | 0x00001003 | Chroma saturation setting.
CONTINUOUSTAKINGORAUTOBRACKETINGMODE | 0x00001100 | Continuous taking or auto bracketting mode.
FLASHMODE | 0x00001010 | Flash mode.
FLASHSTRENGTH | 0x00001011 | Flash strength.
FOCUSMODE | 0x00001021 | Focus mode.
FOCUSWARNING | 0x00001301 | Focus warning.
FORMAT | 0x000004B4 | EXIF_MakerNote_Fuji metadata format identifier.
MACRO | 0x00001020 | Macro mode setting.
PICTUREMODE | 0x00001031 | Picture mode.
QUALITY | 0x00001000 | Image quality setting.
SHARPNESS | 0x00001001 | Sharpness setting.
SLOWSYNCMODE | 0x00001030 | Slow synchro mode.
TONE | 0x00001004 | Contrast setting.
VERSION | 0x00000000 | Makernote version.
WHITEBALANCE | 0x00001002 | White balance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteFujiTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteNikonType1TagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteNikonType1TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 1 tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteNikonType1TagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteNikonType1TagIDs
public enum ImGearEXIFMakerNoteNikonType1TagIDs : System.Enum
__value public enum ImGearEXIFMakerNoteNikonType1TagIDs : public System.Enum
public enum class ImGearEXIFMakerNoteNikonType1TagIDs : public System.Enum
Members
Member | Value | Description
CCDSENSITIVITY | 6 | CCD sensitivity.
COLOURMODE | 4 | Colour mode.
CONVERTER | 11 | Converter info.
DIGITALZOOM | 10 | Digital zoom.
FORMAT | 1202 | EXIF_MakerNote_NikonType metadata format identifier.
IMAGEADJUSTMENT | 5 | Image adjustment.
QUALITY | 3 | Image quality setting.
WHITEBALANCE | 8 | White balance.
WHITEBALANCELOOKUP | 7 | White balance lookup.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteNikonType1TagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteNikonType2TagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteNikonType2TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 2 tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteNikonType2TagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteNikonType2TagIDs
public enum ImGearEXIFMakerNoteNikonType2TagIDs : System.Enum
__value public enum ImGearEXIFMakerNoteNikonType2TagIDs : public System.Enum
public enum class ImGearEXIFMakerNoteNikonType2TagIDs : public System.Enum
Members
Member | Value | Description
AEBRACKETCOMPENSATIONAPPLIED | 25 | AE bracket compensation applied.
AUTOFLASHMODE | 9 | Auto flash mode.
AUTOFOCUSAREA | 136 | Auto focus area.
AUXILIARYLENS | 130 | Auxiliary lens.
BRACKETINGANDSHOOTINGMODE | 137 | Bracketing and shooting mode.
COLOURMODE1 | 3 | Colour mode.
COLOURMODE2 | 141 | Colour mode.
DIGITALVARIPROGRAM | 171 | Digital vari program.
DIGITALZOOMFACTOR | 134 | Digital zoom factor.
FLASHBRACKETCOMPENSATIONAPPLIED | 24 | Flash bracket compensation applied.
FLASHCOMPENSATION | 18 | Flash compensation.
FLASHSETTING | 8 | Flash setting.
FLASHUSED | 135 | Flash used.
FOCUSMODE | 7 | Focus mode.
FORMAT | 1203 | EXIF_MakerNote_NikonType2 metadata format identifier.
HUEADJUSTMENT | 146 | Hue adjustment.
IMAGEADJUSTMENT | 128 | Image adjustment.
IMAGEOPTIMIZATION | 169 | Image optimization.
ISOSELECTION | 15 | ISO selection.
ISOSPEEDREQUESTED | 19 | ISO speed requested.
ISOSPEEDUSED | 2 | ISO speed used.
LENSMINMAXFOCALLENGTHMAXAPERTURE | 132 | Lens min/Max focal length max aperture.
LENSTYPE | 131 | Lens type.
LIGHTINGTYPE | 144 | Lighting type.
MANUALFOCUSDISTANCE | 133 | Manual focus distance.
NIKONMAKERNOTEVERSION | 1 | Nikon makernote version.
NOISEREDUCTION | 149 | Noise reduction.
PHOTOCORNERCOORDINATES | 22 | Photo corner coordinates.
QUALITY | 4 | Image quality setting.
SATURATION | 170 | Saturation setting.
SATURATIONLOOKUP | 148 | Saturation numeric lookup value.
SCENEMODE | 143 | Scene mode.
SHARPNING | 6 | Image sharpening setting.
TONECOMPENSATION | 129 | Tone compensation.
TOTALNUMBEROFSHUTTERRELEASESFORCAMERA | 167 | Total numberof shutter releasesfor camera.
WHITEBALANCE | 5 | White balance.
WHITEBALANCEBIASVALUE | 11 | White balance bias value.
WHITEBALANCEREDBLUECOEFFISIENTS | 12 | White balance red blue coefficients.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteNikonType2TagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteOlympusTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteOlympusTagIDs Enumeration
Lists all Olympus EXIF MakerNote tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteOlympusTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteOlympusTagIDs
public enum ImGearEXIFMakerNoteOlympusTagIDs : System.Enum
__value public enum ImGearEXIFMakerNoteOlympusTagIDs : public System.Enum
public enum class ImGearEXIFMakerNoteOlympusTagIDs : public System.Enum
Members
Member | Value | Description
APETUREVALUE | 0x00001002 | Aperture value.
APPLICATIONMODEIFD | 0x00002030 | Application IFD.
APPLICATIONMODEIFD2 | 0x00002031 | Application IFD2.
BLACKLEVEL | 0x00001012 | Black level.
BLUEBALANCE | 0x00001018 | Blue balance.
BODYFIRMWARE | 0x00000104 | Body firmware.
BRACKET | 0x00001006 | Exposure compensation value.
BRIGHTNESSVALUE | 0x00001003 | Brightness value.
BWMODE | 0x00000203 | Black and white mode.
CAMERAID | 0x00000209 | Camera ID.
CAMERAMODEIFD | 0x00002020 | Camera model IFD.
COLORCONTROL | 0x0000102B | Color control.
COLORMATRIX | 0x00001011 | Color matrix.
CONTRAST | 0x00001029 | Contrast setting.
CORINGFILTER | 0x0000102D | Coring filter.
DATADUMP | 0x00000F00 | Data dump.
DEBUGIFD | 0x00002050 | Debug IFD.
DIAGNOSTICINFO | 0x00000F01 | Diagnostic info.
DIAGNOSTICINFO2 | 0x00000F02 | Diagnostic info2.
DIAGNOSTICINFO3 | 0x00000F03 | Diagnostic info3.
DIGITALZOOM | 0x00000204 | Digital zoom ratio.
FIRMWARE | 0x00000404 | Firmware value.
FIRMWAREVERSION | 0x00000207 | Firmware version.
FLASHBIAS | 0x00001023 | Flash bias.
FLASHDEVICE | 0x00001005 | Flash device.
FLASHMODE | 0x00001004 | Flash mode.
FOCALPLANEDIAGONAL | 0x00000205 | Focal plane diagonal.
FOCUSDISTANCE | 0x0000100C | Focus distance.
FOCUSMODE | 0x0000100B | Focus mode.
FOCUSRANGE | 0x0000100A | Focus range.
FORMAT | 0x000004B0 | EXIF_MakerNote_Olympus metadata format identifier.
HARDWAREIFD | 0x00002010 | Hardware IFD.
IMAGEHEIGHT | 0x0000102F | Image height.
IMAGEPROCESSORIFD | 0x00002040 | Imageprocessor IFD.
IMAGEWIDTH | 0x0000102E | Image width.
LENSTEMPERATURE | 0x00001008 | Lens temperature.
LIGHTCONDITION | 0x00001009 | Light condition.
MACROFOCUS | 0x0000100E | Macro focus step count.
MAKRO | 0x00000202 | Macro mode.
MCS | 0x00000404 | MCS value.
ONETOUCHWB | 0x00000302 | One touch white balance.
PICTUREINFO | 0x00000208 | Picture info.
PRECAPTUREFRAMES | 0x00000300 | Pre capture frames.
PRINTMACHING | 0x00000305 | Print maching.
QUALITY | 0x00000201 | Image quality setting.
REDBALANCE | 0x00001017 | Red balance.
SCENEMODE | 0x00000403 | Scene mode.
SENSITIVEVALUE | 0x00001001 | Sensitive value.
SENSORTEMPERATURE | 0x00001007 | Sensor temperature.
SERIALNUMBER | 0x0000101A | Serial number.
SHARPNESS | 0x0000100F | Sharpness factor.
SHARPNESSFACTOR | 0x0000102A | Sharpness factor.
SPECIALMODE | 0x00000200 | Special mode.
THUMBNAILFILE | 0x00000100 | Thumbnail file.
TIMEVALUE | 0x00001000 | Time value.
VALIDBITS | 0x0000102C | Valid bits.
WBBLUEVALUE | 0x00000304 | WB blue value.
WBBRACKET | 0x00000303 | WB bracket.
WHITEBALANCE | 0x00001015 | White balance.
WHITEBOARD | 0x00000301 | White board.
ZOOM | 0x0000100D | Zoom step count.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteOlympusTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNotePentaxTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNotePentaxTagIDs Enumeration
Lists all Pentax EXIF MakerNote tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNotePentaxTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNotePentaxTagIDs
public enum ImGearEXIFMakerNotePentaxTagIDs : System.Enum
__value public enum ImGearEXIFMakerNotePentaxTagIDs : public System.Enum
public enum class ImGearEXIFMakerNotePentaxTagIDs : public System.Enum
Members
Member | Value | Description
CAPTUREMODE | 0x00000001 | Capture mode.
COLOUR | 0x00000017 | Colour information.
CONTRAST | 0x0000000C | Pentax MakerNote ñontrast.
DAYLIGHTSAVINGS | 0x00001001 | Daylight savings.
DIGITALZOOM | 0x0000000A | Digital zoom.
FLASHMODE | 0x00000003 | Flash mode.
FOCUSMODE | 0x00000003 | Focus mode.
FORMAT | 0x000004B1 | EXIF_MakerNote_Pentax metadata format identifier.
ISOSPEED | 0x00000014 | ISO speed.
PRINTIMAGEMMATCHINGINFO | 0x00000E00 | Print image matching info.
QUALITYLEVEL | 0x00000002 | Quality level.
SATURATION | 0x0000000D | Pentax MakerNote ûaturation.
SHARPNESS | 0x0000000B | Pentax MakerNote ûharpness.
TIMEZONE | 0x00001000 | Time zone.
WHITEBALANCE | 0x00000007 | White balance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNotePentaxTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteTagIDs Enumeration
Lists all general EXIF MakerNote tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteTagIDs
public enum ImGearEXIFMakerNoteTagIDs : System.Enum
__value public enum ImGearEXIFMakerNoteTagIDs : public System.Enum
public enum class ImGearEXIFMakerNoteTagIDs : public System.Enum
Members
Member | Value | Description
BINARY | 1000 | Binary data.
DATA_IFD | 1001 | Makernote data IFD.
FORMAT | 1104 | EXIF_Maker note metadata format identifier.
PREFIX | 2 | Makernote prefix.
TYPE | 1 | Makernote type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFMakerNoteType Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFMakerNoteType Enumeration
Lists all EXIF MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMakerNoteType
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMakerNoteType
public enum ImGearEXIFMakerNoteType : System.Enum
__value public enum ImGearEXIFMakerNoteType : public System.Enum
public enum class ImGearEXIFMakerNoteType : public System.Enum
Members
Member | Value | Description
IFD | 1 | TIFF IFD. Makernote is a valid TIF IFD.
IFD_PREFIXED | 2 | Prefixed TIFF IFD. Same as IFD, but with a short prefix before the IFD. The prefix is also preserved, so the whole Makernote is preserved when writing to a file.
IFD_PREFIXED_OFFSET_II | 4 | Makernote starts with a prefix, then goes offset to the IFD, then IFD itself. Makernote IFD uses Intel byte ordering (II), even though the whole file uses Motorola ordering.
IG_MAKERNOTE_TYPES_MAX | 4 | Keep the number identical to the last makernote type.
TIF_HEADER_PREFIXED | 3 | Makernote starts with a prefix, then goes TIF image header, which points to an IFD.
UNKNOWN | 0 | Unknown. This is the default type. This type means that ImageGear can't decect Makernote as any other type. Preserving such makernote and saving it with the file, most likely, does not make any sence, because IFD offsets will be corrupted.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFMakerNoteType

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearEXIFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearEXIFTagIDs Enumeration
Lists all EXIF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFTagIDs
public enum ImGearEXIFTagIDs : System.Enum
__value public enum ImGearEXIFTagIDs : public System.Enum
public enum class ImGearEXIFTagIDs : public System.Enum
Members
Member | Value | Description
APERTUREVALUE | 37378 | Aperture value.
BRIGHTNESSVALUE | 37379 | Brightness value.
CFAPATTERN | 41730 | CFA pattern.
COLORSPACE | 40961 | Color space.
COMPONENTCONFIGURATION | 37121 | Components configuration.
COMPRESSEDBITSPERPIXEL | 37122 | Compressed bits per pixel.
CONTRAST | 41992 | Indicates the direction of contrast processing applied by the camera when the image was shot.
CUSTOMRENDERED | 41985 | Custom rendered.
DATETIMEDIGITIZED | 36868 | Date time digitized.
DATETIMEORIGINAL | 36867 | Date time original.
DEVICESETTINGDESCRIPTION | 41995 | Device setting description.
DIGITALZOOMRATIO | 41988 | Digital zoom ratio.
EXPOSUREBIASVALUE | 37380 | Exposure bias value.
EXPOSUREINDEX | 41493 | Exposure index.
EXPOSUREMODE | 41986 | Exposure mode.
EXPOSUREPROGRAM | 34850 | Exposure program.
EXPOSURETIME | 33434 | Exposure time.
FILESOURCE | 41728 | File source.
FLASH | 37385 | Indicates weither or not flash used when the image was captured.
FLASHENERGY | 41483 | Flash energy.
FLASHPIXVERSION | 40960 | Flash pix version.
FNUMBER | 33437 | F number value.
FOCALLENGTH | 37386 | Focal length.
FOCALLENGTHIN35MMFILM | 41989 | Focal length in 35mm film.
FOCALPLANERESOLUTIONUNIT | 41488 | Focal plane resolution unit.
FOCALPLANEXRESOLUTION | 41486 | Focal plane X resolution.
FOCALPLANEYRESOLUTION | 41487 | Focal plane Y resolution.
FORMAT | 1100 | EXIF metadata format identifier.
GAINCONTROL | 41991 | Gain control.
HEADER | 59935 | This enumeration value is for internal use only.
IMAGEUNIQUEID | 42016 | Indicates an identifier assigned uniquely to each image.
INTEROPERABILITYIFD | 40965 | Interoperability IFD pointer.
ISOSPEEDRATING | 34855 | ISO speed ratings.
LIGHTSOURCE | 37384 | Light source.
MAKERNOTE | 37500 | Maker note.
MAXAPERTUREVALUE | 37381 | Max aperture value.
METERINGMODE | 37383 | Metering mode.
OECF | 34856 | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524.
PIXELXDIMENSION | 40962 | Pixel X dimension.
PIXELYDIMENSION | 40963 | Pixel Y dimension.
RELATEDSOUNDFILE | 40964 | Related sound file.
SATURATION | 41993 | Indicates the direction of saturation processing applied by the camera when the image was shot.
SCENECAPTURETYPE | 41990 | Scene capture type.
SCENETYPE | 41729 | Scene type.
SENSINGMETHOD | 41495 | Sensing method.
SHARPNESS | 41994 | Indicates the direction of sharpness processing applied by the camera when the image was shot.
SHUTTERSPEEDVALUE | 37377 | Shutter speed value.
SPATIALFREQUENCYRESPONSE | 41484 | Spatial frequency response.
SPECTRALSENSITIVITY | 34852 | Spectral sensitivity.
SUBJECTAREA | 37396 | Subject area.
SUBJECTDISTANCE | 37382 | Subject distance.
SUBJECTDISTANCERANGE | 41996 | Subject distance range.
SUBJECTLOCATION | 41492 | Subject location.
SUBSECTIME | 37520 | Sub sec time.
SUBSECTIMEDIGITIZED | 37522 | Sub sec time digitized.
SUBSECTIMEORIGINAL | 37521 | Sub sec time original.
USERCOMMENT | 37510 | User comment.
VERSION | 36864 | Exif version.
WHITEBALANCE | 41987 | White balance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearEXIFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearFillOrder Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFillOrder Enumeration
Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFillOrder
   Inherits System.Enum
'Usage

Dim instance As ImGearFillOrder
public enum ImGearFillOrder : System.Enum
__value public enum ImGearFillOrder : public System.Enum
public enum class ImGearFillOrder : public System.Enum
Members
Member | Value | Description
LSB | 2 | Least significant bit is stored first.
MSB | 1 | Most significant bit is stored first.
Remarks
This enumeration specifies fill order that is used for saving some file formats, like TIFF, CCITT Group3/Group4, etc., or for loading raw CCITT data.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearFillOrder

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearFormats Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearFormats Enumeration
Lists all ImageGear supported file formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFormats
   Inherits System.Enum
'Usage

Dim instance As ImGearFormats
public enum ImGearFormats : System.Enum
__value public enum ImGearFormats : public System.Enum
public enum class ImGearFormats : public System.Enum
Members
Member | Value | Description
BMP | 0x00000001 | Standard Windows format including OS/2 bitmap format.
BTR | 0x0000001D | Brooktrout FAX format.
CAL | 0x00000002 | CALS raster, Type I.
CGM | 0x00000017 | Computer Graphics Metafile.
CLP | 0x00000003 | Windows Clipboard format for raster images.
CR2 | 0x00000033 | Canon CR2 digital camera RAW format.
CRW | 0x00000034 | Canon CRW digital camera RAW format.
CUR | 0x0000001B | Windows mouse cursor format.
CUT | 0x00000023 | Dr. Halo CUT format.
DCRAW | 0x00000514 | Common identifier for Digital Camera RAW formats.
DCX | 0x00000004 | Intel multi-page FAX format.
DGN | 0x00000018 | MicroStation Drawing (Drawing format used by MicroStation construction design software).
DICOM | 0x00000030 | DICOM file format. Public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images.
DNG | 0x0000003E | Digital Negative file format.
DOCX | 0x00000048 | Office Open XML Word format.
DWF | 0x00000040 | Autodesk Design Web Format.
DWG | 0x00000015 | DWG (AutoDesk AutoCAD) format.
DXF | 0x00000016 | DXF (AutoDesk AutoCAD) format.
GEM | 0x00000024 | GEM Paint Raster format.
GIF | 0x00000005 | Graphic Image format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm.
Hasselblad | 0x00000046 | Hasselblad digital camera RAW format.
HDPHOTO | 0x00000032 | HD Photo (Windows Media Photo) format.
HeaderlessRaw | 0x00000044 | Headerless digital camera RAW format.
HPGL | 0x00000019 | Hewlett-Packard Graphics Language format.
ICA | 0x00000006 | IBM Image Object Content Architecture.
ICO | 0x0000001A | Windows ICON format.
IFF | 0x00000025 | Electronic Arts Interchange File Format.
Imacon | 0x00000045 | Imacon digital camera RAW format.
IMG | 0x0000002A | Xerox raster format.
IMR | 0x0000001E | IMRS-Raster image format.
IMT | 0x0000001F | IMNET format.
JP2 | 0x0000002D | JPEG 2000 file format.
JPG | 0x0000002E | JPEG File Interchange Format.
JPX | 0x0000002F | JPX file format (JPEG 2000 extensions).
KDC | 0x0000003D | Kodak digital camera RAW format.
KFX | 0x00000020 | Kofax format.
LeicaRaw | 0x0000003B | Leica/Panasonic digital camera RAW format.
LV | 0x00000021 | LaserView (LaserData) format.
MEF | 0x00000043 | Mamiya digital camera RAW format.
MJ2 | 0x0000001C | Reserved for future use.
MODCA | 0x00000007 | IBM Mixed Object Document Content Architecture format.
MOS | 0x0000003C | Leaf digital camera RAW format.
MRW | 0x00000035 | Konica-Minolta digital camera RAW format.
MSP | 0x00000009 | Microsoft Paint format.
NCR | 0x00000022 | NCR format.
NEF | 0x00000036 | Nikon digital camera RAW format.
ORF | 0x00000037 | Olympus digital camera RAW format.
PBM | 0x0000000A | Portable BitMap (UNIX graphic file format).
PCD | 0x0000000B | Kodak format for high resolution photographs.
PCX | 0x0000000C | PC Paintbrush format.
PDF | 0x0000000D | Adobe Portable Document Format.
PEF | 0x00000038 | Pentax/Samsung digital camera RAW format.
PhaseOne | 0x00000047 | Phase One digital camera RAW format.
PNG | 0x0000000E | Portable Network Graphics.
PPTX | 0x0000004B | Office Open XML PowerPoint format.
PS | 0x0000000F | PostScript language files.
PSB | 0x00000041 | Adobe Photoshop Big file format.
PSD | 0x00000010 | Adobe Photoshop file format.
PTOCA | 0x00000008 | IBM Presentation Text Object Content Architecture format for IBM's AFP printer architecture.
RAF | 0x00000039 | FujiFilm digital camera RAW format.
RAS | 0x00000026 | SUN raster format.
RAW | 0x00000049 | Headerless RAW format.
SCI | 0x00000011 | SCITEX file format. It is used for electronic pre-press and visual communications systems, is a part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols.
SGI | 0x00000012 | Silicon Graphics raster format.
SonyRaw | 0x0000003A | Sony digital camera RAW format.
SVG | 0x00000031 | Scalable Vector Graphics format.
TGA | 0x00000013 | Targa file format.
TIF | 0x00000014 | Tagged Image File Format.
U3D | 0x00000042 | Universal 3D format.
UNKNOWN | 0x00000000 | Unknown format.
WBMP | 0x00000028 | Wireless BMP format.
WPG | 0x00000027 | WordPerfect Graphic Format.
XBM | 0x0000002B | X Window Bitmap format.
XLSX | 0x0000004A | Office Open XML Excel format.
XPM | 0x0000002C | X Window Pixmap format.
XPS | 0x0000003F | XML Paper Specification format.
XWD | 0x00000029 | X Window Dump format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearFormats

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearGEMTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearGEMTagIDs Enumeration
Lists all GEM tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearGEMTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearGEMTagIDs
public enum ImGearGEMTagIDs : System.Enum
__value public enum ImGearGEMTagIDs : public System.Enum
public enum class ImGearGEMTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 36 | GEM metadata format identifier.
HEADERSIZE | 1 | Header size.
HEIGHT | 5 | Image height.
PATTERNLENGTH | 3 | Pattern length.
PLANES | 2 | Color map ID.
VERSION | 0 | Version valie.
WIDTH | 4 | Image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearGEMTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearGIFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearGIFTagIDs Enumeration
Lists all GIF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearGIFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearGIFTagIDs
public enum ImGearGIFTagIDs : System.Enum
__value public enum ImGearGIFTagIDs : public System.Enum
public enum class ImGearGIFTagIDs : public System.Enum
Members
Member | Value | Description
AFTER_IMAGE_EXT | 0x00000FFF | After image extensions.
APP_AUTH_CODE | 0x00000FF2 | Application authentication code.
APP_DATA | 0x00000FF3 | Application data.
APP_EXTENSION | 0x000000FF | Application extension.
APP_IDENTIFIER | 0x00000FF1 | Application identifier.
COMMENT_EXTENSION | 0x000000FE | Comment extension.
FORMAT | 0x00000005 | GIF metadata format identifier.
GCE_DELAY_TIME | 0x00000F95 | Delay time.
GCE_FIELDS | 0x00000F91 | Graphic control extension packed fields.
GCE_FLD_DISPOSAL_METHOD | 0x00000F92 | Disposal method.
GCE_FLD_TRANSPARENT | 0x00000F94 | Transparent color flag.
GCE_FLD_USER_INPUT | 0x00000F93 | User input flag.
GCE_TRANSPARENT_COLOR | 0x00000F96 | Transparent color index.
GLOBAL_COLOR_TABLE | 0x00000030 | Global color table.
GRAPHIC_CONTROL_EXT | 0x000000F9 | Graphic control extension.
HDR_SIGNATURE | 0x00000101 | Identifies the GIF Data Stream.
HDR_VERSION | 0x00000102 | Version number.
HEADER | 0x00000010 | GIF header.
IMAGE_DESCRIPTOR | 0x0000002C | Image descriptor.
IMG_FIELDS | 0x000002C5 | Image descriptor packed field.
IMG_FLD_INTERLACE | 0x000002C7 | Interlace flag.
IMG_FLD_LOC_COLOR_TABLE | 0x000002C6 | Local color table flag.
IMG_FLD_SIZE | 0x000002C9 | Local color table size.
IMG_FLD_SORT | 0x000002C8 | Sort flag.
IMG_IMAGE_HEIGHT | 0x000002C4 | Image height.
IMG_IMAGE_WIDTH | 0x000002C3 | Image width.
IMG_LEFT_POSITION | 0x000002C1 | Image left position.
IMG_TOP_POSITION | 0x000002C2 | Image top position.
LOCAL_COLOR_TABLE | 0x00000040 | Local color table.
PLAIN_TEXT_EXTENSION | 0x00000001 | Plain text extension.
SCR_ASPECT_RATIO | 0x00000204 | Pixel aspect ratio.
SCR_BACKGROUND_COLOR | 0x00000203 | Background color index.
SCR_FIELDS | 0x00000205 | Logical screen packed fields.
SCR_FLD_COLOR_RES | 0x00000207 | Color resolution.
SCR_FLD_GL_COLOR_TABLE | 0x00000206 | Global color table flag.
SCR_FLD_SIZE | 0x00000209 | Global color table size.
SCR_FLD_SORT | 0x00000208 | Sort flag.
SCR_SCREEN_HEIGHT | 0x00000202 | Logical screen height.
SCR_SCREEN_WIDTH | 0x00000201 | Logical screen width.
SCREEN_DESCRIPTOR | 0x00000020 | Logical screen descriptor.
TXT_BACKGROUND_COLOR | 0x00000018 | Text background color index.
TXT_CELL_HEIGHT | 0x00000016 | Character cell height.
TXT_CELL_WIDTH | 0x00000015 | Character cell width.
TXT_FOREGROUND_COLOR | 0x00000017 | Text foreground color index.
TXT_GRID_HEIGHT | 0x00000014 | Text grid height.
TXT_GRID_LEFT | 0x00000011 | Text grid left position.
TXT_GRID_TOP | 0x00000012 | Text grid top position.
TXT_GRID_WIDTH | 0x00000013 | Text grid width.
TXT_TEXT_DATA | 0x00000019 | Plain text data.
XMP | 0x00000FF4 | XMP metadata stream.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearGIFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearHDPhotoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearHDPhotoTagIDs Enumeration
Lists all HD Photo tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearHDPhotoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearHDPhotoTagIDs
public enum ImGearHDPhotoTagIDs : System.Enum
__value public enum ImGearHDPhotoTagIDs : public System.Enum
public enum class ImGearHDPhotoTagIDs : public System.Enum
Members
Member | Value | Description
ALPHABYTECOUNT | 48323 | Alpha byte count.
ALPHADATADISCARD | 48325 | Alpha data discard.
ALPHAOFFSET | 48322 | Alpha offset.
BIMIPTC | 52 | IPTC metadata.
BIMIPTCPSTRING | 53 | IPTC metadata.
BIMIPTCSUB | 54 | IPTC subtree.
FORMAT | 50 | HD Photo metadata format identifier.
HEIGHTRES | 48259 | Height resolution.
IMAGEBYTECOUNT | 48321 | Image byte count.
IMAGEDATADISCARD | 48324 | Image data discard.
IMAGEOFFSET | 48320 | Image offset.
IMAGETYPE | 48132 | Image type.
IMAGEWIDTH | 48256 | Image width.
IMAGHEIGHT | 48257 | Image height.
PIXELFORMAT | 48129 | Pixel format.
RATING | 18249 | Rating info.
SIMPLERATING | 18246 | Simple rating.
TRANSFORMATION | 48130 | Transformation to be applied when decoding the image to present the desired representation.
UNCOMPRESSED | 48131 | Specifies that the image data is uncompressed.
WIDHTRES | 48258 | Width resolution.
XMP | 51 | XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearHDPhotoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearICATagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearICATagIDs Enumeration
Lists all ICA tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearICATagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearICATagIDs
public enum ImGearICATagIDs : System.Enum
__value public enum ImGearICATagIDs : public System.Enum
public enum class ImGearICATagIDs : public System.Enum
Members
Member | Value | Description
BASE | 1007 | Size units value.
BITORDER | 1006 | Bit order.
COMPRESSION | 1008 | Image compression.
DEPTH | 1003 | Image depth.
FILLORDER | 1009 | Fill order.
FORMAT | 6 | IOCA metadata format identifier.
HEIGHT | 1002 | Image height.
WIDTH | 1001 | Image width.
XDPI | 1004 | Horizontal image resolution.
YDPI | 1005 | Vertical image resolution.
Remarks
This enumeration lists all IOCA tag identifiers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearICATagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearICOTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearICOTagIDs Enumeration
Lists all ICO tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearICOTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearICOTagIDs
public enum ImGearICOTagIDs : System.Enum
__value public enum ImGearICOTagIDs : public System.Enum
public enum class ImGearICOTagIDs : public System.Enum
Members
Member | Value | Description
COUNT | 4 | Images count in the file.
DOCUMENT_METADATA | 2 | Document metadata.
FORMAT | 26 | ICO metadata format identifier.
PAGE_METADATA | 1 | Page metadata.
TYPE | 3 | Resource type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearICOTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIFFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIFFTagIDs Enumeration
Lists all IFF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIFFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearIFFTagIDs
public enum ImGearIFFTagIDs : System.Enum
__value public enum ImGearIFFTagIDs : public System.Enum
public enum class ImGearIFFTagIDs : public System.Enum
Members
Member | Value | Description
COMPRESSION | 6 | Image compression.
FORMAT | 37 | IFF metadata format identifier.
HIGH | 1 | Image height.
MASK | 5 | Mask info.
PAGE_H | 9 | Page height.
PAGE_W | 8 | Page width.
PLANES | 4 | Color map planes.
TRAN_ASPT | 7 | Tran aspt.
TRANSP_COLOR | 11 | Transp color.
VIEW_MODE | 10 | View mode.
WIDE | 0 | Image width.
X_ASPECT | 12 | X aspect resolution.
XORG | 2 | Image X origin.
Y_ASPECT | 13 | Y aspect resolution.
YORG | 3 | Image Y origin.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIFFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIMGTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIMGTagIDs Enumeration
Lists all IMG tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIMGTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearIMGTagIDs
public enum ImGearIMGTagIDs : System.Enum
__value public enum ImGearIMGTagIDs : public System.Enum
public enum class ImGearIMGTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 42 | IMG metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIMGTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIMTTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIMTTagIDs Enumeration
Lists all IMT tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIMTTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearIMTTagIDs
public enum ImGearIMTTagIDs : System.Enum
__value public enum ImGearIMTTagIDs : public System.Enum
public enum class ImGearIMTTagIDs : public System.Enum
Members
Member | Value | Description
BITSWAP | 1005 | Swap bits.
FMT | 1001 | File format.
FORMAT | 31 | IMT metadata format identifier.
HEIGHT | 1002 | Image height.
INVERT | 1007 | Invert pixel values flag.
RESOLUTION | 1004 | Image resolution.
SWAB | 1006 | Swap byte.
TYPE | 1000 | IMT file type.
WIDTH | 1003 | Image Width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIMTTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCAppObjAttrTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCAppObjAttrTags Enumeration
Lists IPTC Application Object Attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCAppObjAttrTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCAppObjAttrTags
public enum ImGearIPTCAppObjAttrTags : System.Enum
__value public enum ImGearIPTCAppObjAttrTags : public System.Enum
public enum class ImGearIPTCAppObjAttrTags : public System.Enum
Members
Member | Value | Description
ANALYSIS | 2 | The object contains data and conclusions drawn by a journalist who has researched the story in depth.
ARCHIVE_MATERIAL | 3 | The object contains material distributed previously that has been selected from the originator’s archives.
BACKGROUND | 4 | The object provides some scene-setting and explanation for the event being reported.
CURRENT | 1 | Object content is about events taking place at the time of the report.
FEATURE | 5 | The object content is about a particular event or individual that may not be significant to current breaking news.
FORECAST | 6 | The object contains opinion as to the outcome of a future event.
HISTORY | 7 | The object content is based on previous rather than current events.
OBITUARY | 8 | The object contains a narrative about an individual’s life and achievements for publication after his or her death.
OPINION | 9 | The object contains an editorial comment that reflects the views of the author.
POLLS_SURVEYS | 10 | The object contains numeric or other information produced as a result of questionnaires or interviews.
PROFILE | 11 | The object contains a description of the life or activity of a news subject (often a living individual).
RES_LISTINGS_TABLES | 12 | The object contains alphanumeric data suitable for presentation in tabular form.
SIDE_BAR_SUPPORTING_INFO | 13 | The object contains a related story that provides additional insight into the news event being reported.
SUMMARY | 14 | The object is a collection of synopses on news items (generally unrelated).
TRANSCRIPT_VERBATIM | 15 | The object contains a word-for-word report of a discussion or briefing without significant journalistic intervention.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCAppObjAttrTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCAppObjTypeTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCAppObjTypeTags Enumeration
Lists IPTC Application Object Types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCAppObjTypeTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCAppObjTypeTags
public enum ImGearIPTCAppObjTypeTags : System.Enum
__value public enum ImGearIPTCAppObjTypeTags : public System.Enum
public enum class ImGearIPTCAppObjTypeTags : public System.Enum
Members
Member | Value | Description
ADVISORY | 3 | Object type is Advisory (content provider messages, generally not published).
DATA | 2 | Object type is Data (intended for tables such as statistics or lists, as opposed to narrative text).
NEWS | 1 | Object type is News (default).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCAppObjTypeTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord1EnvDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord1EnvDatasetTags Enumeration
Lists all IPTC Record 1 (Envelope) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord1EnvDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord1EnvDatasetTags
public enum ImGearIPTCRecord1EnvDatasetTags : System.Enum
__value public enum ImGearIPTCRecord1EnvDatasetTags : public System.Enum
public enum class ImGearIPTCRecord1EnvDatasetTags : public System.Enum
Members
Member | Value | Description
ARM_IDENTIFIER | 120 | ARM identifier.
ARM_VERSION | 122 | ARM version.
CODED_CHARACTER_SET | 90 | Coded character set.
DATE_SENT | 70 | Date sent.
DESTINATION | 5 | Destination information (additional routing information.
ENVELOPE_NUMBER | 40 | Envelope number.
ENVELOPE_PRIORITY | 60 | Envelope priority.
FILE_FORMAT | 20 | File format.
FILE_FORMAT_VERSION | 22 | File format version.
FORMAT | 1108 | IPTC_EnvDataset metadata format identifier.
MODEL_VERSION | 0 | Model version.
PRODUCT_ID | 50 | Product ID.
SERVICE_IDENTIFIER | 30 | Service identifier.
TIME_SENT | 80 | Time sent.
UNO | 100 | Unique Name of Object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord1EnvDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord2AppDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord2AppDatasetTags Enumeration
Lists all IPTC Record 2 (Application) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord2AppDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord2AppDatasetTags
public enum ImGearIPTCRecord2AppDatasetTags : System.Enum
__value public enum ImGearIPTCRecord2AppDatasetTags : public System.Enum
public enum class ImGearIPTCRecord2AppDatasetTags : public System.Enum
Members
Member | Value | Description
ACTION_ADVISED | 42 | Action advised.
AUDIO_DURATION | 153 | Audio duration.
AUDIO_OUTCUE | 154 | Audio outcue.
AUDIO_SAMPLING_RATE | 151 | Audio sampling rate.
AUDIO_SAMPLING_RESOLUTION | 152 | Audio sampling resolution.
AUDIO_TYPE | 150 | Audio type.
BY_LINE | 80 | By-line information.
BY_LINE_TITLE | 85 | By-line title.
CAPTION_ABSTRACT | 120 | Caption / Abstract.
CATEGORY | 15 | Category that identifies the subject of the object in the opinion of the image provider.
CITY | 90 | City information.
CONTACT | 118 | Contact information.
CONTENT_LOCATION_CODE | 26 | Content location code.
CONTENT_LOCATION_NAME | 27 | Content location name.
COPYRIGHT_NOTICE | 116 | Copyright notice.
COUNTRY_PRIMARY_LOC_CODE | 100 | Country/Primary location code.
COUNTRY_PRIMARY_LOC_NAME | 101 | Country/Primary location name.
CREDIT | 110 | Credit information.
DATE_CREATED | 55 | Date created.
DIGITAL_CREATION_DATE | 62 | Digital creation date.
DIGITAL_CREATION_TIME | 63 | Digital creation time.
EDIT_STATUS | 7 | Edit status.
EDITORIAL_UPDATE | 8 | Editorial update.
EXPIRATION_DATE | 37 | Expiration date.
EXPIRATION_TIME | 38 | Expiration time.
FIXTURE_IDENTIFIER | 22 | Fixture identifier.
FORMAT | 1109 | IPTC_AppDataset metadata format identifier.
HEADLINE | 105 | Synopsis of the subject matter.
IMAGE_ORIENTATION | 131 | Image orientation.
IMAGE_TYPE | 130 | Image type.
KEYWORDS | 25 | Keywords to description.
LANGUAGE_IDENTIFIER | 135 | Language identifier.
OBJ_ATTRIBUTE_REF | 4 | Object attribute reference.
OBJ_DATA_PREV_DATA | 202 | Object data preview data.
OBJ_DATA_PREV_FILE_FORMAT | 200 | Object data preview file format.
OBJ_DATA_PREV_FILE_FORMAT_VER | 201 | Object data preview file format version.
OBJ_NAME | 5 | Object name.
OBJ_TYPE_REF | 3 | Object type reference.
OBJECT_CYCLE | 75 | Object cycle.
ORIGINAL_TRANSM_REF | 103 | Original transmission reference.
ORIGINATING_PROGRAM | 65 | Originating program.
PROGRAM_VERSION | 70 | Program version.
PROVINCE_STATE | 95 | Province / State.
RASTERIZED_CAPTION | 125 | Rasterized caption.
RECORD_VERSION | 0 | Record version.
REFERENCE_DATE | 47 | Reference date.
REFERENCE_NUMBER | 50 | Reference number.
REFERENCE_SERVICE | 45 | Reference service.
RELEASE_DATE | 30 | Release date.
RELEASE_TIME | 35 | Release time.
SOURCE | 115 | Source that identifies the original owner / creator.
SPECIAL_INSTRUCTIONS | 40 | Special instructions.
SUBJECT_REFERENCE | 12 | Subject reference.
SUBLOCATION | 92 | Sub-location information.
SUPPLEMENTAL_CATEGORY | 20 | Supplemental category.
TIME_CREATED | 60 | Time created.
URGENCY | 10 | Editorial urgency.
WRITER_EDITOR | 122 | Writer / Editor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord2AppDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord3PhotoDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord3PhotoDatasetTags Enumeration
Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord3PhotoDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord3PhotoDatasetTags
public enum ImGearIPTCRecord3PhotoDatasetTags : System.Enum
__value public enum ImGearIPTCRecord3PhotoDatasetTags : public System.Enum
public enum class ImGearIPTCRecord3PhotoDatasetTags : public System.Enum
Members
Member | Value | Description
BITS_PER_COMPONENT | 135 | Bits per component.
COLOUR_MATRIX_TABLE | 70 | Colour calibration matrix table.
COLOUR_PALETTE | 85 | Colour palette.
COLOUR_REPRESENTATION | 60 | Colour representation.
COLOUR_SEQUENCE | 65 | Colour sequence.
DATA_COMPRESSION_METHOD | 110 | Data compression method.
END_POINTS | 125 | End points.
EXCURSION_TOLERANCE | 130 | Excursion tolerance.
FORMAT | 1110 | IPTC_PhotoDataset metadata format identifier.
GAMMA_COMPENSATED_VALUE | 145 | Gamma compensated value.
ICC_INPUT_COLOUR_PROFILE | 66 | ICC input colour profile.
IMAGE_ROTATION | 102 | Image rotation.
INTERCHANGE_COLOUR_SPACE | 64 | Interchange colour space.
LOOKUP_TABLE | 80 | Lookup table.
MAXIMUM_DENSITY_RANGE | 140 | Maximum density range.
NUMBER_OF_BITS_PER_SAMPLE | 86 | Number of bits per sample.
NUMBER_OF_INDEX_ENTRIES | 84 | Number of index entries.
NUMBER_OF_LINE | 30 | Number of line.
PICTURE_NUMBER | 10 | Picture number.
PIXEL_SIZE_PERP_DIR | 50 | Pixel size perpendicular to scanning direction.
PIXEL_SIZE_SCAN_DIR | 40 | Pixel size in scanning direction.
PIXELS_PER_LINE | 20 | Pixels per line.
QUANTISATION_METHOD | 120 | Quantisation method.
RECORD_VERSION | 0 | Record version.
SAMPLING_STRUCTURE | 90 | Sampling structure.
SCANNING_DIRECTION | 100 | Scanning direction.
SUPPLEMENT_TYPE | 55 | Supplement type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord3PhotoDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord7PreObjDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord7PreObjDatasetTags Enumeration
Lists all IPTC Record 7 (Pre-Object) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord7PreObjDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord7PreObjDatasetTags
public enum ImGearIPTCRecord7PreObjDatasetTags : System.Enum
__value public enum ImGearIPTCRecord7PreObjDatasetTags : public System.Enum
public enum class ImGearIPTCRecord7PreObjDatasetTags : public System.Enum
Members
Member | Value | Description
FORMAT | 1111 | IPTC_PreObjDataset metadata format identifier.
MAX_OBJ_DATA_SIZE | 95 | Maximum object data size.
MAX_SUBFILE_SIZE | 20 | Max subfile size.
OBJ_DATA_SIZE_ANN | 90 | Object data size announced.
SIZE_MODE | 10 | Size mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord7PreObjDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord8ObjDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord8ObjDatasetTags Enumeration
Lists all IPTC Record 8 (Object) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord8ObjDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord8ObjDatasetTags
public enum ImGearIPTCRecord8ObjDatasetTags : System.Enum
__value public enum ImGearIPTCRecord8ObjDatasetTags : public System.Enum
public enum class ImGearIPTCRecord8ObjDatasetTags : public System.Enum
Members
Member | Value | Description
FORMAT | 1112 | IPTC_ObjDataset metadata format identifier.
SUBFILE | 10 | IPTC ObjectData subfile.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord8ObjDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecord9PostObjDatasetTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecord9PostObjDatasetTags Enumeration
Lists all IPTC Record 9 (Post-Object) DataSet tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecord9PostObjDatasetTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecord9PostObjDatasetTags
public enum ImGearIPTCRecord9PostObjDatasetTags : System.Enum
__value public enum ImGearIPTCRecord9PostObjDatasetTags : public System.Enum
public enum class ImGearIPTCRecord9PostObjDatasetTags : public System.Enum
Members
Member | Value | Description
CONFIRMED_OBJ_DATA_SIZE | 10 | Confirmed object data size.
FORMAT | 1113 | IPTC_PostObjDataset metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecord9PostObjDatasetTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCRecordTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCRecordTags Enumeration
Lists all IPTC Record tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCRecordTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCRecordTags
public enum ImGearIPTCRecordTags : System.Enum
__value public enum ImGearIPTCRecordTags : public System.Enum
public enum class ImGearIPTCRecordTags : public System.Enum
Members
Member | Value | Description
APPLICATION_RECORD | 2 | Application record.
DIG_NEWS_PHOTO_PAR_RECORD | 3 | Digital Newsphoto Pararameter record.
ENVELOPE_RECORD | 1 | Envelope record.
FORMAT | 1107 | IPTC_Record metadata format identifier.
OBJECT_RECORD | 8 | Object record.
POSTOBJ_DESC_RECORD | 9 | Post-object record.
PREOBJ_DESC_RECORD | 7 | Pre-object record.
UNDEFINED | 999 | Undefined record.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCRecordTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearIPTCTags Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearIPTCTags Enumeration
Lists all general IPTC tags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCTags
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCTags
public enum ImGearIPTCTags : System.Enum
__value public enum ImGearIPTCTags : public System.Enum
public enum class ImGearIPTCTags : public System.Enum
Members
Member | Value | Description
IPTC_FORMAT | 7168 | IPTC metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearIPTCTags

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearJP2CodestreamTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearJP2CodestreamTagIDs Enumeration
Lists all JP2Codestream tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJP2CodestreamTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearJP2CodestreamTagIDs
public enum ImGearJP2CodestreamTagIDs : System.Enum
__value public enum ImGearJP2CodestreamTagIDs : public System.Enum
public enum class ImGearJP2CodestreamTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 4000 | JP2Codestream metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearJP2CodestreamTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearJP2FileFormatTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearJP2FileFormatTagIDs Enumeration
Lists all JP2FileFormat tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJP2FileFormatTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearJP2FileFormatTagIDs
public enum ImGearJP2FileFormatTagIDs : System.Enum
__value public enum ImGearJP2FileFormatTagIDs : public System.Enum
public enum class ImGearJP2FileFormatTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 5000 | JP2Format metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearJP2FileFormatTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearJP2TagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearJP2TagIDs Enumeration
Lists all JP2 tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJP2TagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearJP2TagIDs
public enum ImGearJP2TagIDs : System.Enum
__value public enum ImGearJP2TagIDs : public System.Enum
public enum class ImGearJP2TagIDs : public System.Enum
Members
Member | Value | Description
ALPHA_1 | 7 | Alpha channel 1 info.
ALPHA_2 | 8 | Alpha channel 2 info.
ALPHA_3 | 9 | Alpha channel 3 info.
ALPHA_CHANNELS | 1001 | Alpha channel.
ALPHA_MAPPING | 4 | Alpha channel mapping.
CAPTURE_RESOLUTION_X | 25 | Capture resloution X.
CAPTURE_RESOLUTION_Y | 27 | Capture resloution Y.
COMMENT | 20 | Comment info.
COMPRESSION | 1002 | Image compression.
DISPLAY_RESOLUTION_X | 24 | Display resloution X.
DISPLAY_RESOLUTION_Y | 26 | Display resloution Y.
FORMAT | 45 | JP2 metadata format identifier.
IPR | 1003 | Intellectual property rights.
RESOLUTION | 21 | Resolution info.
TYPE | 1005 | File format type.
UUID | 28 | This tag identifies the UUID metadata tree.
UUID_DATA | 30 | This tag specifies the UUID data.
UUID_ID | 29 | This tag specifies the UUID identifier.
XML | 1006 | XML metadata.
XMP | 31 | XML packet containing XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearJP2TagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearJPEGTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearJPEGTagIDs Enumeration
Lists all JPEG tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEGTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEGTagIDs
public enum ImGearJPEGTagIDs : System.Enum
__value public enum ImGearJPEGTagIDs : public System.Enum
public enum class ImGearJPEGTagIDs : public System.Enum
Members
Member | Value | Description
APP1 | 0x0000FFE1 | Application marker - first.
APP10 | 0x0000FFEA | Application marker - 10.
APP11 | 0x0000FFEB | Application marker - 11.
APP12 | 0x0000FFEC | Application marker - 12.
APP13 | 0x0000FFED | Application marker - 13.
APP14 | 0x0000FFEE | Application marker - 14.
APP15 | 0x0000FFEF | Application marker - last.
APP2 | 0x0000FFE2 | Application marker - 2.
APP3 | 0x0000FFE3 | Application marker - 3.
APP4 | 0x0000FFE4 | Application marker - 4.
APP5 | 0x0000FFE5 | Application marker - 5.
APP6 | 0x0000FFE6 | Application marker - 6.
APP7 | 0x0000FFE7 | Application marker - 7.
APP8 | 0x0000FFE8 | Application marker - 8.
APP9 | 0x0000FFE9 | Application marker - 9.
BINARY_DATA | 0x00000172 | Segment binary data.
CHUNKNUMBER | 0x0000018A | Chunk number.
COM | 0x0000FFFE | Comment value.
COMMENT | 0x0000015E | Comment value.
DAC | 0x0000FFCC | DAC - Define Arithmetic coding Conditioning.
DHP | 0x0000FFDE | Define hierarchical progression.
DHT | 0x0000FFC4 | Huffman tables.
DNL | 0x0000FFDC | Define number of lines.
DQT | 0x0000FFDB | Quantization tables.
DRI | 0x0000FFDD | Restart Interval.
EOI | 0x0000FFD9 | End of Image.
EXIF_ID | 0x0000017C | EXIF ID tag.
EXP | 0x0000FFDF | Expand reference image.
FORMAT | 0x0000002E | JPEG metadata format identifier.
FRAME_COMPONENT_HV_SAMPLING | 0x00000132 | SOF Component HV Sampling.
FRAME_COMPONENT_ID | 0x00000131 | SOF Component ID.
FRAME_COMPONENT_QUANT_SELECTOR | 0x00000133 | SOF Component quantization table selector.
FRAME_COMPONENT_SPEC | 0x00000130 | SOF Component specification.
FRAME_LINES | 0x0000012D | SOF Lines.
FRAME_NUMBER_OF_COMPONENTS | 0x0000012F | SOF Number of components.
FRAME_PRECISION | 0x0000012C | SOF Precision.
FRAME_SAMPLES_PER_LINE | 0x0000012E | SOF Samples Per Line.
HUFFMAN_TABLE | 0x00000140 | Huffman table.
HUFFMAN_TABLE_DESCRIPTOR | 0x00000141 | Huffman table descriptor.
HUFFMAN_TABLE_LENGTHS | 0x00000142 | Huffman table lengths.
HUFFMAN_TABLE_VALUES | 0x00000143 | Huffman table values.
ICCPROFILEDATA | 0x00000189 | ICC Profile data.
IDENTIFIER | 0x00000188 | Segment identifier.
JFIF | 0x0000FFE0 | Application marker - JFIF header (APP0).
JFIF_ID | 0x00000168 | JFIF ID value.
JFIF_THUMB_HEIGHT | 0x0000016E | JFIF thumbnail height.
JFIF_THUMB_WIDTH | 0x0000016D | JFIF thumbnail width.
JFIF_UNITS | 0x0000016A | JFIF resolution unit.
JFIF_VERSION | 0x00000169 | JFIF version.
JFIF_X_RES | 0x0000016B | JFIF X resolution.
JFIF_Y_RES | 0x0000016C | JFIF Y resolution.
JPG | 0x0000FFC8 | Reserved for JPEG extensions.
PHOTOSHOP_ID | 0x00000186 | Photoshop ID.
PHOTOSHOP_RESOURCES | 0x00000187 | Photoshop Resources.
QUANT_TABLE | 0x00000136 | Quantization table.
QUANT_TABLE_DESCRIPTOR | 0x00000137 | Quantization table descriptor.
QUANT_TABLE_ELEMENTS | 0x00000138 | Quantization table elements.
RESTART_INTERVAL | 0x00000154 | Restart interval.
RST0 | 0x0000FFD0 | Restart marker.
RST1 | 0x0000FFD1 | Restart marker.
RST2 | 0x0000FFD2 | Restart marker.
RST3 | 0x0000FFD3 | Restart marker.
RST4 | 0x0000FFD4 | Restart marker.
RST5 | 0x0000FFD5 | Restart marker.
RST6 | 0x0000FFD6 | Restart marker.
RST7 | 0x0000FFD7 | Restart marker.
SCAN_AH_AL | 0x00000150 | Scan AH, AL.
SCAN_COMPONENT | 0x0000014B | Scan component.
SCAN_COMPONENT_NUMBER | 0x0000014A | Scan component number.
SCAN_DC_AC | 0x0000014D | Scan AC, DC.
SCAN_SELECTOR | 0x0000014C | Scan selector.
SCAN_SP_END | 0x0000014F | Scan spectral end.
SCAN_SP_START | 0x0000014E | Scan spectral start.
SOF0 | 0x0000FFC0 | Baseline DCT.
SOF1 | 0x0000FFC1 | Extended sequential DCT.
SOF10 | 0x0000FFCA | Progressive DCT - arithmetic encoding.
SOF11 | 0x0000FFCB | Lossless sequential - arithmetic encoding.
SOF13 | 0x0000FFCD | Differential sequential DCT - arithmetic encoding.
SOF14 | 0x0000FFCE | Differential progressive DCT - arithmetic encoding.
SOF15 | 0x0000FFCF | Differential lossless - arithmetic encoding.
SOF2 | 0x0000FFC2 | Progressive DCT.
SOF3 | 0x0000FFC3 | Lossless (sequential).
SOF5 | 0x0000FFC5 | Differential sequential DCT.
SOF6 | 0x0000FFC6 | Differential progressive DCT.
SOF7 | 0x0000FFC7 | Differential lossless.
SOF9 | 0x0000FFC9 | Extended sequential DCT - arithmetic encoding.
SOI | 0x0000FFD8 | Start of Image.
SOS | 0x0000FFDA | Start of Segment.
TEM | 0x0000FF01 | TEM marker.
XMP | 0x0000018B | XML packet containing XMP metadata.
XMP_IDENTIFIER | 0x0000018C | XMP identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearJPEGTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearJPXTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearJPXTagIDs Enumeration
Lists all JPX tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPXTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearJPXTagIDs
public enum ImGearJPXTagIDs : System.Enum
__value public enum ImGearJPXTagIDs : public System.Enum
public enum class ImGearJPXTagIDs : public System.Enum
Members
Member | Value | Description
ALPHA_1 | 7 | Alpha channel 1 info.
ALPHA_2 | 8 | Alpha channel 2 info.
ALPHA_3 | 9 | Alpha channel 3 info.
ALPHA_4 | 10 | Alpha channel 4 info.
ALPHA_MAPPING | 4 | Alpha channel mapping.
CAPTURE_RESOLUTION_X | 25 | Capture resloution X.
CAPTURE_RESOLUTION_Y | 27 | Capture resloution Y.
CHROMA | 1007 | Chroma key data.
COMMENT | 20 | Comment info.
COMPRESSION | 1002 | Image compression.
DISPLAY_RESOLUTION_X | 24 | Display resloution X.
DISPLAY_RESOLUTION_Y | 26 | Display resloution Y.
FORMAT | 47 | JPX metadata format identifier.
IPR | 1003 | Intellectual property rights.
RESOLUTION | 21 | Resolution info.
TYPE | 1005 | This value has been deprecated. File format type.
UUID | 28 | This tag identifies the UUID metadata tree.
UUID_DATA | 30 | This tag specifies the UUID data.
UUID_ID | 29 | This tag specifies the UUID identifier.
XML | 1006 | XML metadata.
XMP | 31 | XML packet containing XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearJPXTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearKFXTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearKFXTagIDs Enumeration
Lists all KFX tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearKFXTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearKFXTagIDs
public enum ImGearKFXTagIDs : System.Enum
__value public enum ImGearKFXTagIDs : public System.Enum
public enum class ImGearKFXTagIDs : public System.Enum
Members
Member | Value | Description
BIT_SEX | 1908 | Bit sex info.
BITS_PER_PIX | 1913 | Bits per pixel.
COLOR | 1909 | Color info.
COM_LEN | 1921 | Com length.
COM_OFFSET | 1920 | Com offset.
DATA_LEN | 1925 | Data length.
DATA_OFFSET | 1924 | Data offset.
DATE_ACC | 1917 | Access date.
DATE_CRT | 1915 | Creation date.
DATE_MOD | 1916 | Modification date.
FORMAT | 32 | KFX metadata format identifier.
HDR_SIZE | 1902 | Header size.
HDR_VER | 1903 | Header version.
ID | 1901 | Image identifier.
IDX_LEN | 1919 | Index length.
IDX_OFFSET | 1918 | Index offset.
IMAGE_ID | 1904 | Image ID value.
KFX_FORMAT | 1907 | KFX format.
LENGTH | 1906 | Image length.
PAPER_SIZE | 1914 | Paper size.
PLANES | 1912 | Planes info.
USER_LEN | 1923 | User length.
USER_OFFSET | 1922 | User Offset.
WIDTH | 1905 | Image width.
XRES | 1910 | Horizontal image resolution.
YRES | 1911 | Vertical image resolution.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearKFXTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearLVTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearLVTagIDs Enumeration
Lists all LV tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLVTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearLVTagIDs
public enum ImGearLVTagIDs : System.Enum
__value public enum ImGearLVTagIDs : public System.Enum
public enum class ImGearLVTagIDs : public System.Enum
Members
Member | Value | Description
BITSPIX | 1104 | Bits per pixel.
BLOCKLENGTH | 1114 | Block length.
BYTEFORMAT | 1106 | Byte format.
COMPRESSION | 1105 | Image compression.
COMPVERSION | 1107 | Comp version.
DISPLAYMETHOD | 1111 | Display method.
FORMAT | 33 | LV metadata format identifier.
LINES | 1102 | Number of lines.
NBLOCKTYPE | 1110 | N Block type.
PIXELS | 1103 | Number of columns.
TEXT | 1115 | Text info.
XAXIS | 1109 | X axis info.
XORIGIN | 1101 | Image X origin.
XSEPERATION | 1112 | X separation.
YAXIS | 1108 | Y axis info.
YORIGIN | 1100 | Image Y origin.
YSEPERATION | 1113 | Y separation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearLVTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusApplicationModeIFD2TagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusApplicationModeIFD2TagIDs Enumeration
Lists all Olympus application mode IFD 2 MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusApplicationModeIFD2TagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusApplicationModeIFD2TagIDs
public enum ImGearMakerNoteOlympusApplicationModeIFD2TagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusApplicationModeIFD2TagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusApplicationModeIFD2TagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1208 | Olympus application mode IFD 2 MakerNote metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusApplicationModeIFD2TagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusApplicationModeIFDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusApplicationModeIFDTagIDs Enumeration
Lists all Olympus application mode IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusApplicationModeIFDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusApplicationModeIFDTagIDs
public enum ImGearMakerNoteOlympusApplicationModeIFDTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusApplicationModeIFDTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusApplicationModeIFDTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1207 | Olympus application mode IFD MakerNote metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusApplicationModeIFDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusCameraModeIFDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusCameraModeIFDTagIDs Enumeration
Lists all Olympus camera mode IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusCameraModeIFDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusCameraModeIFDTagIDs
public enum ImGearMakerNoteOlympusCameraModeIFDTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusCameraModeIFDTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusCameraModeIFDTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1206 | Olympus camera mode IFD MakerNote metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusCameraModeIFDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusCSerieSettingsTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusCSerieSettingsTagIDs Enumeration
Lists all Olympus C-models serie settings IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusCSerieSettingsTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusCSerieSettingsTagIDs
public enum ImGearMakerNoteOlympusCSerieSettingsTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusCSerieSettingsTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusCSerieSettingsTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1211 | Olympus C-models serie settings IFD MakerNote metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusCSerieSettingsTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusDebugIFDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusDebugIFDTagIDs Enumeration
Lists all Olympus debug IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusDebugIFDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusDebugIFDTagIDs
public enum ImGearMakerNoteOlympusDebugIFDTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusDebugIFDTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusDebugIFDTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1210 | Olympus debug IFD MakerNote metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusDebugIFDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusHardwareIFDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusHardwareIFDTagIDs Enumeration
Lists all Olympus hardware IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusHardwareIFDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusHardwareIFDTagIDs
public enum ImGearMakerNoteOlympusHardwareIFDTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusHardwareIFDTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusHardwareIFDTagIDs : public System.Enum
Members
Member | Value | Description
BODYFIRMWARE | 0x00000104 | Body firmware.
CAMERAÅTYPE2 | 0x00000100 | This value has been deprecated, use CAMERATYPE2 instead.
CAMERATYPE2 | 0x00000100 | Camera type.
EXTENSION | 0x00000301 | Hardware extension.
EXTENSIONfIRMWARE | 0x00000304 | This value has been deprecated, use EXTENSIONFIRMWARE instead.
EXTENSIONFIRMWARE | 0x00000304 | Extension firmware.
EXTENSIONID | 0x00000303 | Extension ID.
EXTENSIONSERIALNUMBER | 0x00000302 | Extension serial number.
FLASHFIRMWARE | 0x00001002 | Flash firmware.
FLASHMODEL | 0x00001001 | Flash model.
FLASHSERIALNUMBER | 0x00001003 | Flash serial number.
FLASHTYPE | 0x00001000 | Flash type.
FOCUSPLANEDIAGONAL2 | 0x00000103 | Focus plane diagonal.
FORMAT | 0x000004B5 | Olympus hardware IFD MakerNote metadata format identifier.
HARDWAREIFDVERSION | 0x00000000 | Hardware IFD version.
LENS | 0x00000201 | Lens setting.
LENSfEATURES | 0x0000020B | This value has been deprecated, use LENSFEATURES instead.
LENSFEATURES | 0x0000020B | Lens features.
LENSFIRMWARE | 0x00000204 | Lens firmware.
LENSID | 0x00000203 | Lens ID value.
LENSMAXAPERTUREATCURRENTFOCAL | 0x0000020A | Lens max aperture at current focal.
LENSSERIALNUMBER | 0x00000202 | Lens serial number.
LENSTELEAPERTURE | 0x00000206 | Lens tele aperture.
LENSTELEFOCALlENGTH | 0x00000208 | This value has been deprecated, use LENSTELEFOCALLENGTH instead.
LENSTELEFOCALLENGTH | 0x00000208 | Lens tele focal length.
LENSWIDEAPERTURE | 0x00000205 | Lens wide aperture.
LENSWIDEFOCALlENGTH | 0x00000207 | This value has been deprecated, use LENSWIDEFOCALLENGTH instead.
LENSWIDEFOCALLENGTH | 0x00000207 | Lens wide focal length.
MCS | 0x00000102 | MCS setting.
SERIALNUMBER | 0x00000101 | Serial number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusHardwareIFDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMakerNoteOlympusImageProcessorTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMakerNoteOlympusImageProcessorTagIDs Enumeration
Lists all Olympus image processor IFD MakerNote types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMakerNoteOlympusImageProcessorTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMakerNoteOlympusImageProcessorTagIDs
public enum ImGearMakerNoteOlympusImageProcessorTagIDs : System.Enum
__value public enum ImGearMakerNoteOlympusImageProcessorTagIDs : public System.Enum
public enum class ImGearMakerNoteOlympusImageProcessorTagIDs : public System.Enum
Members
Member | Value | Description
BLACKLEVEL2 | 0x00000600 | Black level 2.
CHROMASUPPLESS_5_0601 | 0x00000601 | Chroma suppless 5_0601.
CHROMASUPPLESS_5_0602 | 0x00000602 | Chroma suppless 5_0602.
CHROMASUPPLESS_5_0603 | 0x00000603 | Chroma suppless 5_0603.
CHROMASUPPLESS_5_0604 | 0x00000604 | Chroma suppless 5_0604.
COLORMATRICES | 0x00000259 | Color Matrices.
COLORMATRICES_ADOBERGB1 | 0x00000253 | Color Matrices Adobe RGB.
COLORMATRICES_ADOBERGB2 | 0x00000254 | Color Matrices Adobe RGB.
COLORMATRICES_ADOBERGB3 | 0x00000255 | Color Matrices Adobe RGB.
COLORMATRICES_PROPHOTORGB1 | 0x00000256 | Color Matrices ProPhoto RGB.
COLORMATRICES_PROPHOTORGB2 | 0x00000257 | Color Matrices ProPhoto RGB.
COLORMATRICES_PROPHOTORGB3 | 0x00000258 | Color Matrices ProPhoto RGB.
COLORMATRICES_sRGB1 | 0x00000250 | Color Matrices sRGB.
COLORMATRICES_sRGB2 | 0x00000251 | Color Matrices sRGB.
COLORMATRICES_sRGB3 | 0x00000252 | Color Matrices sRGB.
COLORMATRICESADOBERGB0 | 0x0000020E | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB1 | 0x0000020F | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB10 | 0x00000218 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB11 | 0x00000219 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB12 | 0x0000021A | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB2 | 0x00000210 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB3 | 0x00000211 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB4 | 0x00000212 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB5 | 0x00000213 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB6 | 0x00000214 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB7 | 0x00000215 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB8 | 0x00000216 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB9 | 0x00000217 | Color Matrice Adobe RGB.
COLORMATRICESPROPHOTORGB0 | 0x0000021B | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB1 | 0x0000021C | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB10 | 0x00000226 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB11 | 0x00000227 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB12 | 0x00000227 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB2 | 0x0000021D | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB3 | 0x0000021E | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB4 | 0x0000021F | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB5 | 0x00000221 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB6 | 0x00000222 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB7 | 0x00000223 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB8 | 0x00000224 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB9 | 0x00000225 | Color Matrice ProPhoto RGB.
COLORMATRICESSRGB0 | 0x00000201 | Color Matrice sRGB.
COLORMATRICESSRGB1 | 0x00000202 | Color Matrice sRGB.
COLORMATRICESSRGB10 | 0x0000020B | Color Matrice sRGB.
COLORMATRICESSRGB11 | 0x0000020C | Color Matrice sRGB.
COLORMATRICESSRGB12 | 0x0000020D | Color Matrice sRGB.
COLORMATRICESSRGB2 | 0x00000203 | Color Matrice sRGB.
COLORMATRICESSRGB3 | 0x00000204 | Color Matrice sRGB.
COLORMATRICESSRGB4 | 0x00000205 | Color Matrice sRGB.
COLORMATRICESSRGB5 | 0x00000206 | Color Matrice sRGB.
COLORMATRICESSRGB6 | 0x00000207 | Color Matrice sRGB.
COLORMATRICESSRGB7 | 0x00000208 | Color Matrice sRGB.
COLORMATRICESSRGB8 | 0x00000209 | Color Matrice sRGB.
COLORMATRICESSRGB9 | 0x0000020A | Color Matrice sRGB.
COLORMATRIX_1 | 0x00000228 | Color matrix.
COLORMATRIX_2 | 0x00000229 | Color matrix.
COLORMATRIX2 | 0x00000200 | Color Matrix 2.
CORINGVALUES | 0x00000311 | Coring values.
EDITDISTORTIONCORRECTION | 0x00001011 | Edit distortion correction.
EDITNOISEREDUCTION | 0x00001010 | Edit noise reduction.
EDITSHADINGCOMPENSATION | 0x00001012 | Edit shading compensation.
ENHANCERVALUES | 0x00000301 | Enhancer values.
FACEAREA | 0x00001201 | Face area.
FACEDETECT | 0x00001200 | Face detect.
FINALHEIGHT | 0x00000615 | Final height.
FINALWIDTH | 0x00000614 | Final width.
FORMAT | 0x000004B9 | Olympus image processor IFD MakerNote metadata format identifier.
GAINBASE | 0x00000610 | GainBase setting.
GREENBIAS3000K | 0x00000113 | Green bias 3000K.
GREENBIAS3300K | 0x00000114 | Green bias 3300K.
GREENBIAS3600K | 0x00000115 | Green bias 3600K.
GREENBIAS3900K | 0x00000116 | Green bias 3900K.
GREENBIAS4000K | 0x00000117 | Green bias 4000K.
GREENBIAS4300K | 0x00000118 | Green bias 4300K.
GREENBIAS4500K | 0x00000119 | Green bias 4500K.
GREENBIAS4800K | 0x0000011A | Green bias 4800K.
GREENBIAS5300K | 0x0000011B | Green bias 5300K.
GREENBIAS6000K | 0x0000011C | Green bias 6000K.
GREENBIAS6600K | 0x0000011D | Green bias 6600K.
GREENBIAS7500K | 0x0000011E | Green bias 7500K.
GREENBIASASSHOT | 0x0000011F | Green bias as shot.
IMAGEPROCESSORIFDVERSION | 0x00000000 | Image processor IFD version.
LENSDISTORTIONPARAMS | 0x00000800 | Lens distortion params.
LENSSHADINGPARAMS | 0x00000801 | Lens shading params.
REDBLUEBIAS3000K | 0x00000102 | Red blue bias 3000K.
REDBLUEBIAS3300K | 0x00000103 | Red blue bias 3300K.
REDBLUEBIAS3600K | 0x00000104 | Red blue bias 3600K.
REDBLUEBIAS3900K | 0x00000105 | Red blue bias 3900K.
REDBLUEBIAS4000K | 0x00000106 | Red blue bias 4000K.
REDBLUEBIAS4300K | 0x00000107 | Red blue bias 4300K.
REDBLUEBIAS4500K | 0x00000108 | Red blue bias 4500K.
REDBLUEBIAS4800K | 0x00000109 | Red blue bias 4800K.
REDBLUEBIAS5300K | 0x0000010A | Red blue bias 5300K.
REDBLUEBIAS6000K | 0x0000010B | Red blue bias 6000K.
REDBLUEBIAS6600K | 0x0000010C | Red blue bias 6600K.
REDBLUEBIAS7500K | 0x0000010D | Red blue bias 7500K.
REDBLUEBIASASSHOT | 0x00000100 | Red blue bias as shot.
REDBLUEBIASCWB1 | 0x0000010E | Red blue bias CWB1.
REDBLUEBIASCWB2 | 0x0000010F | Red blue bias CWB2.
REDBLUEBIASCWB3 | 0x00000110 | Red blue bias CWB3.
REDBLUEBIASCWB4 | 0x00000111 | Red blue bias CWB4.
STARTOFFSETX | 0x00000612 | Start offset X.
STARTOFFSETY | 0x00000613 | Start offset Y.
VALIDBitsPerPixel2 | 0x00000611 | Valid bits per pixel 2.
VALUEOfCORING2 | 0x00000310 | Value of coring 2.
VALUEOfENHANCER2 | 0x00000300 | Value of enhancer 2.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMakerNoteOlympusImageProcessorTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMetadataFormats Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMetadataFormats Enumeration
Lists all ImageGear supported metadata formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMetadataFormats
   Inherits System.Enum
'Usage

Dim instance As ImGearMetadataFormats
public enum ImGearMetadataFormats : System.Enum
__value public enum ImGearMetadataFormats : public System.Enum
public enum class ImGearMetadataFormats : public System.Enum
Members
Member | Value | Description
BMP | 0x00000001 | BMP metadata.
BTR | 0x0000001D | BTR metadata.
CAL | 0x00000002 | CALS metadata.
CIFF | 0x00000515 | CIFF metadata.
CIFFAFInfo | 0x00000519 | CIFF AF Info metadata.
CIFFCanonCameraSettings | 0x00000516 | CIFF Canon Camera Settings metadata.
CIFFFocalLength | 0x00000517 | CIFF Focal Length metadata.
CIFFImageInfo | 0x0000051A | CIFF Image Info metadata.
CIFFShotInfo | 0x00000518 | CIFF Shot Info metadata.
CLP | 0x00000003 | CLP metadata.
Common | 0x000007D0 | Used internally.
CUT | 0x00000023 | CUT metadata.
DCRAW | 0x00000514 | Digital Camera RAW Formats metadata.
DCX | 0x00000004 | DCX metadata.
DICOM | 0x00000030 | DICOM metadata.
DisplayInfo | 0x00000464 | Photoshop Display info metadata.
EXIF | 0x0000044C | EXIF metadata. Can only exist as a subtree within EXIF or JPEG metadata.
EXIF_FPXR | 0x0000044F | EXIF FPX Ready metadata. Can only exist as a subtree within EXIF metadata.
EXIF_GPS | 0x0000044D | EXIF GPS metadata. Can only exist as a subtree within EXIF metadata.
EXIF_InterOp | 0x0000044E | EXIF Interoperability metadata. Can only exist as a subtree within EXIF metadata.
EXIF_MakerNote | 0x00000450 | EXIF Makernote metadata. Can only exist as a subtree within EXIF metadata.
EXIF_MakerNote_Fuji | 0x000004B4 | Fujifilm EXIF Makernote metadata.
EXIF_MakerNote_NikonType1 | 0x000004B2 | Nikon EXIF Makernote Type 1 metadata.
EXIF_MakerNote_NikonType2 | 0x000004B3 | Nikon EXIF Makernote Type 2 metadata.
EXIF_MakerNote_Olympus | 0x000004B0 | Olympus EXIF Makernote metadata.
EXIF_MakerNote_Pentax | 0x000004B1 | Pentax EXIF Makernote metadata.
GEM | 0x00000024 | GEM metadata.
GIF | 0x00000005 | GIF metadata.
HDPHOTO | 0x00000032 | HDPhoto metadata.
ICA | 0x00000006 | ICA metadata.
ICO | 0x0000001A | ICO metadata.
IFF | 0x00000025 | IFF metadata.
IMG | 0x0000002A | IMG metadata.
IMR | 0x0000001E | IMR metadata.
IMT | 0x0000001F | IMT metadata.
IPTC | 0x0000045F | General IPTC metadata.
IPTC_AppDataset | 0x00000455 | IPTC Record 2 (Application) metadata.
IPTC_EnvDataset | 0x00000454 | IPTC Record 1 (Envelope) metadata.
IPTC_ObjDataset | 0x00000458 | IPTC Record 8 (Object) metadata.
IPTC_PhotoDataset | 0x00000456 | IPTC Record 3 (Digital Newsphoto Parameter) metadata.
IPTC_PostObjDataset | 0x00000459 | IPTC Record 9 (Post-Object) metadata.
IPTC_PreObjDataset | 0x00000457 | IPTC Record 7 (Pre-Object) metadata.
IPTC_Record | 0x00000453 | IPTC Record metadata.
JP2 | 0x0000002D | JPEG 2000 metadata.
JP2Codestream | 0x00000FA0 | JP2 Codestream Metadata.
JP2FileFormat | 0x00001388 | JP2 File Format Metadata.
JPG | 0x0000002E | JPEG metadata.
JPX | 0x0000002F | JPX metadata.
KFX | 0x00000020 | KFX metadata.
LV | 0x00000021 | LV metadata.
MakerNote_Olympus_ApplicationModeIFD | 0x000004B7 | Olympus application mode IFD Makernote metadata.
MakerNote_Olympus_ApplicationModeIFD2 | 0x000004B8 | Olympus application mode IFD 2 Makernote metadata.
MakerNote_Olympus_CameraModeIFD | 0x000004B6 | Olympus camera mode IFD Makernote metadata.
MakerNote_Olympus_CSerieSettings | 0x000004BB | Olympus C-models serie settings IFD Makernote metadata.
MakerNote_Olympus_DebugIFD | 0x000004BA | Olympus debug IFD Makernote metadata.
MakerNote_Olympus_HardwareIFD | 0x000004B5 | Olympus hardware IFD Makernote metadata.
MakerNote_Olympus_ImageProcessorIFD | 0x000004B9 | Olympus image processor IFD Makernote metadata.
MJ2 | 0x0000001C | Reserved for future use.
MODCA | 0x00000007 | MODCA metadata.
MSP | 0x00000009 | MSP metadata.
NCR | 0x00000022 | NCR metadata.
PBM | 0x0000000A | PBM metadata.
PCD | 0x0000000B | PhotoCD metadata.
PCX | 0x0000000C | PCX metadata.
PDF | 0x0000000D | PDF metadata.
PhotoshopAdditionalLayerInfo | 0x00000468 | Photoshop Additional LayerInfo metadata.
PhotoshopLayerInfo | 0x00000466 | Photoshop Layer Info metadata.
PhotoshopLayerMaskInfo | 0x00000467 | Photoshop Layer MaskI nfo metadata.
PhotoshopResourceGeneric | 0x00000460 | Photoshop Resource Generic metadata.
PhotoshopResources | 0x00000461 | Photoshop Resources metadata.
PhotoshopVersionInfo | 0x00000465 | Photoshop Version Info metadata.
PNG | 0x0000000E | PNG metadata.
PS | 0x0000000F | PostScript metadata.
PSB | 0x00000041 | PSB metadata.
PSD | 0x00000010 | PSD metadata.
PTOCA | 0x00000008 | PTOCA metadata.
RAS | 0x00000026 | RAS metadata.
RAWFileFormat | 0x00001770 | RAW File Format Metadata.
Rectangle | 0x0000047E | Photoshop Rectangle Info metadata.
ResolutionInfo | 0x00000462 | Photoshop Resolution Info metadata.
SCI | 0x00000011 | Scitex CT metadata.
SGI | 0x00000012 | SGI metadata.
TGA | 0x00000013 | TGA metadata.
ThumbnailInfo | 0x00000463 | Photoshop Thumbnail Info metadata.
TIF | 0x00000014 | TIFF metadata.
UNKNOWN | 0x00000000 | Unknown metadata.
WBMP | 0x00000028 | Wireless Bitmap metadata.
WPG | 0x00000027 | WPG metadata.
XBM | 0x0000002B | XBM metadata.
XMP | 0x00000BB8 | XMP Metadata.
XPM | 0x0000002C | XPM metadata.
XPS | 0x0000003F | XPS metadata.
XWD | 0x00000029 | XWD metadata.
Remarks
This enumeration lists all formats that are used for storing file format metadata. Most of the members of this enum correspond to members of ImGearFormats. However, some file formats allow storing complex metadata, or metadata structures of various types. ImGearMetadataFormats enum has special members for such metadata structures.

For example, a TIFF image can have metadata of ImGearMetadataFormats.TIF, which in turn can have a subtree with metadata of type ImGearMetadataFormats.EXIF

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMetadataFormats

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMJ2TagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMJ2TagIDs Enumeration
Reserved for future use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMJ2TagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMJ2TagIDs
public enum ImGearMJ2TagIDs : System.Enum
__value public enum ImGearMJ2TagIDs : public System.Enum
public enum class ImGearMJ2TagIDs : public System.Enum
Members
Member | Value | Description
ALPHA_1 | 7 | Alpha channel 1 info.
ALPHA_2 | 8 | Alpha channel 2 info.
ALPHA_3 | 9 | Alpha channel 3 info.
ALPHA_CHANNELS | 1001 | Alpha channels.
ALPHA_MAPPING | 4 | Alpha mapping.
COMPRESSION | 1002 | Image compression.
FORMAT | 28 | MJ2 metadata format identifier.
IPR | 1003 | Intellectual property rights.
TYPE | 1005 | File format type.
XML | 1006 | XML metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMJ2TagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearMSPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearMSPTagIDs Enumeration
Lists all MSP tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMSPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearMSPTagIDs
public enum ImGearMSPTagIDs : System.Enum
__value public enum ImGearMSPTagIDs : public System.Enum
public enum class ImGearMSPTagIDs : public System.Enum
Members
Member | Value | Description
CHECKSUM | 1812 | Checksum of previous 24 bytes.
FORMAT | 9 | MSP metadata format identifier.
HEIGHT | 1803 | Height of the bitmap in pixels.
KEY1 | 1800 | Magic number.
KEY2 | 1801 | Magic number.
PADDING | 1813 | Unused padding.
PRINTERHEIGHT | 1809 | Height of the printer in pixels.
PRINTERWIDTH | 1808 | Width of the printer in pixels.
WIDTH | 1802 | Width of the bitmap in pixels.
XARBITMAP | 1804 | X Aspect ratio of the bitmap.
XARPRINTER | 1806 | X Aspect ratio of the printer.
XASPECTCORR | 1810 | X aspect correction (unused).
YARBITMAP | 1805 | Y Aspect ratio of the bitmap.
YARPRINTER | 1807 | Y Aspect ratio of the printer.
YASPECTCORR | 1811 | Y aspect correction (unused).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearMSPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearNativeDataTypes Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearNativeDataTypes Enumeration
Specifies the data types that file formats use to store metadata values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearNativeDataTypes
   Inherits System.Enum
'Usage

Dim instance As ImGearNativeDataTypes
public enum ImGearNativeDataTypes : System.Enum
__value public enum ImGearNativeDataTypes : public System.Enum
public enum class ImGearNativeDataTypes : public System.Enum
Members
Member | Value | Description
BOOL | 7 | Boolean data type.
DOUBLE | 12 | 64-bit IEEE floating point number.
FLOAT | 11 | 32-bit IEEE floating point number.
INT16 | 3 | 16-bit signed integer.
INT32 | 5 | 32-bit signed integer.
INT64 | 14 | 64-bit signed integer.
INT8 | 1 | 8-bit signed integer.
RATIONAL_INT32 | 9 | A pair of 32-bit signed integers: Numerator and Denominator of a rational number.
RATIONAL_UINT32 | 10 | A pair of 32-bit unsigned integers: Numerator and Denominator of a rational number.
RAW_DATA | 13 | Byte array.
STRING | 8 | ASCII string.
UINT16 | 4 | 16-bit unsigned integer.
UINT32 | 6 | 32-bit unsigned integer.
UINT64 | 15 | 64-bit unsigned integer.
UINT8 | 2 | 8-bit unsigned integer.
UNKNOWN | 0 | Data type is unknown.
VARIABLE_UINT | 16 | This value is for internal use only.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearNativeDataTypes

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearNCRTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearNCRTagIDs Enumeration
Lists all NCR tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearNCRTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearNCRTagIDs
public enum ImGearNCRTagIDs : System.Enum
__value public enum ImGearNCRTagIDs : public System.Enum
public enum class ImGearNCRTagIDs : public System.Enum
Members
Member | Value | Description
AUTH_MAC | 2005 | Authentication Mac info.
AUTHENTICATION | 2004 | Authentication info.
DATA_ENDIAN | 2015 | Data endian.
DATA_FORMAT | 2001 | Data format.
DATA_SIZE | 2006 | Data size.
ENCRYPTION | 2003 | Encryption info.
ERROR | 2023 | Error info.
FILL_ORDER | 2016 | Fill order.
FORMAT | 34 | NCR metadata format identifier.
GRANULARITY | 2017 | Granularity info.
MAX_PIX_VALUE | 2019 | Max pix value.
MIN_PIX_VALUE | 2018 | Min pix value.
OPTIONS | 2002 | Options info.
ORIENT | 2013 | Orientation setting.
PMI | 2014 | Invert pixels flag.
REAL_BPP | 2007 | Real bpp value.
REAL_HEIGHT | 2011 | Real height.
REAL_WIDTH | 2009 | Real width.
RES_UNIT | 2022 | Resolution unit.
STORE_BPP | 2008 | Store bpp.
STORE_HEIGHT | 2012 | Store height.
STORE_WIDTH | 2010 | Store width.
X_RES | 2020 | Horizontal resolution.
Y_RES | 2021 | Vertical resolution.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearNCRTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPBMTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPBMTagIDs Enumeration
Lists all PBM tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPBMTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPBMTagIDs
public enum ImGearPBMTagIDs : System.Enum
__value public enum ImGearPBMTagIDs : public System.Enum
public enum class ImGearPBMTagIDs : public System.Enum
Members
Member | Value | Description
BITCOUNT | 4 | Bit count.
COMMENTS | 5 | Comments string.
FORMAT | 10 | PBM metadata format identifier.
HEIGHT | 2 | Image height.
MAXCOLOR | 3 | Max color value.
TYPE | 0 | File type.
WIDTH | 1 | Image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPBMTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPCDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPCDTagIDs Enumeration
Lists all PCD tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPCDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPCDTagIDs
public enum ImGearPCDTagIDs : System.Enum
__value public enum ImGearPCDTagIDs : public System.Enum
public enum class ImGearPCDTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 11 | PCD metadata format identifier.
IPI_COPYRIGHT_FILENAME | 4026 | IPI copyright filename.
IPI_COPYRIGHT_STATUS | 4025 | IPI copyright status.
IPI_EQUIPMENT_MANUFACTURER | 4020 | IPI equipment manufacturer.
IPI_IMAGE_MAG_DESCRIPTION | 4009 | IPI image mag description.
IPI_IMAGE_SCAN_TIME | 4010 | IPI image scan time.
IPI_LAST_MODIFICATION_DATE | 4011 | IPI last modification date.
IPI_MED_ORIGINAL_RECORDING | 4012 | IPI med original recording.
IPI_PHOTONAME | 4023 | IPI photoname.
IPI_PHOTONAME_CHAR_SET | 4021 | IPI photoname char set.
IPI_PHOTONAME_ESC_SEQ | 4022 | IPI photoname esc seq.
IPI_SBA_DATA | 4024 | IPI SBA data.
IPI_SCANNER_FIRMWARE_DATE | 4017 | IPI scanner firmware date.
IPI_SCANNER_FIRMWARE_LEVEL | 4016 | IPI scanner firmware level.
IPI_SCANNER_PIXEL_SIZE | 4019 | IPI scanner pixel size.
IPI_SCANNER_PRODUCT | 4015 | IPI scanner product.
IPI_SCANNER_SERIAL_NUMBER | 4018 | IPI scanner serial number.
IPI_SCANNER_VENDOR | 4014 | IPI scanner vendor.
IPI_SIGNATURE | 4006 | IPI signature.
IPI_SOFTWARE_RELEASE | 4008 | IPI software release.
IPI_TYPE_ORIGINAL_RECORDING | 4013 | IPI type original recording.
IPI_VERSION_NUMBER | 4007 | IPI version number.
IPICA_BASE16_STOP_OFFSET | 4003 | IPICA base16 stop offset.
IPICA_BASE4_STOP_OFFSET | 4002 | IPICA base4 stop offset.
IPICA_IMAGE_PACK_PARAMS | 4001 | IPICA image pack params.
IPICA_IP_INTERLEAVE_RATIO | 4005 | IPICA IP interleave ratio.
IPICA_IPE_STOP_OFFSET | 4004 | IPICA IPE stop offset.
IPICA_RESERVED | 4000 | IPICA reserved.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPCDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPCXTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPCXTagIDs Enumeration
Lists all PCX tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPCXTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPCXTagIDs
public enum ImGearPCXTagIDs : System.Enum
__value public enum ImGearPCXTagIDs : public System.Enum
public enum class ImGearPCXTagIDs : public System.Enum
Members
Member | Value | Description
BIT_PER_PLANE | 403 | Bit per plane.
BYTES_PER_LINE | 413 | Bytes per line.
ENCODE | 402 | Encoding type.
EXTRA | 417 | Extra data length.
FORMAT | 12 | PCX metadata format identifier.
H_RES | 408 | Horizontal Resolution of creating device.
MANUFACTURER | 400 | Manufacturer magic value.
NUM_OF_PLANES | 412 | Num of planes.
PALETTE_INFO | 414 | Palette info.
PALETTE_TABLE | 410 | Palette table.
SCANNER_H_RES | 415 | Scanner H_Res.
SCANNER_V_RES | 416 | Scanner V_Res.
V_RES | 409 | Vertical Resolution of creating device.
VERSION_INFO | 401 | Version info.
VIDEO_MODE | 411 | Video mode.
X1 | 404 | Left image coordinate to display.
X2 | 406 | RIght image coordinate to display.
Y1 | 405 | Top image coordinate to display.
Y2 | 407 | Bottom image coordinate to display.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPCXTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPDFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPDFTagIDs Enumeration
Lists all PDF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFTagIDs
public enum ImGearPDFTagIDs : System.Enum
__value public enum ImGearPDFTagIDs : public System.Enum
public enum class ImGearPDFTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 13 | PDF metadata format identifier.
XMP | 14 | XML packet containing XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPDFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration
Lists all Photoshop Additional Layer Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoshopAdditionalLayerInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoshopAdditionalLayerInfoTagIDs
public enum ImGearPhotoshopAdditionalLayerInfoTagIDs : System.Enum
__value public enum ImGearPhotoshopAdditionalLayerInfoTagIDs : public System.Enum
public enum class ImGearPhotoshopAdditionalLayerInfoTagIDs : public System.Enum
Members
Member | Value | Description
Data | 1 | Photoshop additional layer data.
FORMAT | 1128 | Photoshop additional layer info metadata format identifier.
Key | 0 | Photoshop additional layer key.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPhotoshopAdditionalLayerInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPhotoshopLayerInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPhotoshopLayerInfoTagIDs Enumeration
Lists all Photoshop Layer Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoshopLayerInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoshopLayerInfoTagIDs
public enum ImGearPhotoshopLayerInfoTagIDs : System.Enum
__value public enum ImGearPhotoshopLayerInfoTagIDs : public System.Enum
public enum class ImGearPhotoshopLayerInfoTagIDs : public System.Enum
Members
Member | Value | Description
BlendingRanges | 9 | Photoshop layer blending ranges.
BlendModeKey | 4 | Photoshop layer blend mode key.
BlendModeSignature | 3 | Photoshop layer blend mode signature.
ChannelCount | 1 | Photoshop layer channel count.
ChannelID | 2 | Photoshop layer channel ID.
Clipping | 6 | Photoshop layer clipping.
ExtraData | 11 | Photoshop layer extra data.
Flags | 7 | Photoshop layer flags.
FORMAT | 1126 | Photoshop layer info metadata format identifier.
MaskData | 8 | Photoshop layer mask data.
Name | 10 | Photoshop layer Name.
Opacity | 5 | Photoshop layer opacity.
Rectangle | 0 | Photoshop layer rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPhotoshopLayerInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPhotoshopLayerMaskInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPhotoshopLayerMaskInfoTagIDs Enumeration
Lists all Photoshop Layer Mask Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoshopLayerMaskInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoshopLayerMaskInfoTagIDs
public enum ImGearPhotoshopLayerMaskInfoTagIDs : System.Enum
__value public enum ImGearPhotoshopLayerMaskInfoTagIDs : public System.Enum
public enum class ImGearPhotoshopLayerMaskInfoTagIDs : public System.Enum
Members
Member | Value | Description
DefaultColor | 1 | Photoshop layer mask default color.
Flags | 2 | Photoshop layer mask flags.
FORMAT | 1127 | Photoshop layer mask info metadata format identifier.
RealFlags | 3 | Photoshop layer mask real flags.
RealUserMaskBg | 4 | Photoshop layer mask real user mask bg.
Rectangle | 0 | Photoshop layer mask rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPhotoshopLayerMaskInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPhotoshopResourceGenericTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPhotoshopResourceGenericTagIDs Enumeration
Lists all Photoshop Resource Generic tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoshopResourceGenericTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoshopResourceGenericTagIDs
public enum ImGearPhotoshopResourceGenericTagIDs : System.Enum
__value public enum ImGearPhotoshopResourceGenericTagIDs : public System.Enum
public enum class ImGearPhotoshopResourceGenericTagIDs : public System.Enum
Members
Member | Value | Description
DATA | 3 | Photoshop resource generic data.
FORMAT | 1120 | Photoshop resource generic metadata format identifier.
ID | 1 | Photoshop resource generic ID.
NAME | 2 | Photoshop resource generic name.
SIGNATURE | 0 | Photoshop resource generic signature.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPhotoshopResourceGenericTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPHOTOSHOPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPHOTOSHOPTagIDs Enumeration
Lists all Photoshop tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPHOTOSHOPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPHOTOSHOPTagIDs
public enum ImGearPHOTOSHOPTagIDs : System.Enum
__value public enum ImGearPHOTOSHOPTagIDs : public System.Enum
public enum class ImGearPHOTOSHOPTagIDs : public System.Enum
Members
Member | Value | Description
AlphaIdentifiers | 0x0000041D | Alpha identifiers.
AlphaNames | 0x000003EE | Alpha names.
Caption | 0x000003F0 | The caption.
COMMENT | 0x00000003 | Resource block comment.
DisplayInfo | 0x000003EF | Display info.
FORMAT | 0x00000461 | PhotoshopResource metadata format identifier.
HEADER | 0x00000000 | Header data section.
ICCProfile | 0x0000040F | ICC profile.
IPTC | 0x00000404 | IPTC-NAA record.
ResolutionInfo | 0x000003ED | Resolution info.
RESOURCE | 0x00000001 | Resource block.
RESOURCE_SIZE | 0x00000002 | Resource size.
SEGMENTDATA | 0x00000004 | Segment data.
Thumbnail | 0x0000040C | Thumbnail resource.
ThumbnailLegacy | 0x00000409 | Thumbnail legacy.
TransparencyIndex | 0x00000417 | Transparency index.
UnicodeAlphaNames | 0x00000415 | Unicode alpha names.
VersionInfo | 0x00000421 | Version info.
XMP | 0x00000424 | XML packet containing XMP metadata.
Remarks
This enumeration lists all general Photoshop tag identifiers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPHOTOSHOPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPhotoshopVersionInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPhotoshopVersionInfoTagIDs Enumeration
Lists all Photoshop Version Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoshopVersionInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoshopVersionInfoTagIDs
public enum ImGearPhotoshopVersionInfoTagIDs : System.Enum
__value public enum ImGearPhotoshopVersionInfoTagIDs : public System.Enum
public enum class ImGearPhotoshopVersionInfoTagIDs : public System.Enum
Members
Member | Value | Description
FileVersion | 4 | File version.
FORMAT | 1125 | Photoshop version info metadata format identifier.
hasRealMergedData | 1 | Has real merged data.
ReaderName | 3 | Reader name.
Version | 0 | Photoshop version.
WriteName | 2 | Write name.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPhotoshopVersionInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPNGTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPNGTagIDs Enumeration
Lists all PNG tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPNGTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPNGTagIDs
public enum ImGearPNGTagIDs : System.Enum
__value public enum ImGearPNGTagIDs : public System.Enum
public enum class ImGearPNGTagIDs : public System.Enum
Members
Member | Value | Description
BACKGROUND | 0x624B4744 | Background information.
CALIBRATION | 0x7043414C | Calibration information.
CHRM_BLUE | 0x70485983 | Chromaticities blue.
CHRM_GREEN | 0x70485982 | Chromaticities green.
CHRM_RED | 0x70485981 | Chromaticities red.
CHRM_WHITE | 0x70485980 | White point.
CHRM_X | 0x70485984 | Chromaticities X.
CHRM_Y | 0x70485985 | Chromaticities Y.
CHROMATICITIES | 0x6348524D | Chromaticities information.
COMPRESSED_TEXT | 0x7A545874 | Compressed textual data information.
CTXT_COMPR_METHOD | 0x70485989 | Compression method.
CTXT_KEYWORD | 0x70485988 | Compressed textual data chunk keyword that indicates the type of information represented by the text string.
CTXT_TEXT | 0x7048598A | Compressed textual data chunk text.
FORMAT | 0x0000000E | PNG metadata format identifier.
FRACTAL_PARAMETERS | 0x66524163 | Fractal parameters information.
GAMMA | 0x67414D41 | Gamma information.
GIF_APP_EXT | 0x67494678 | GIF application extension information.
GIF_CONTROL | 0x67494667 | GIF contro information.
GIF_TEXT_EXT | 0x67494674 | Gif text extension information.
GIFG_DELAY_TIME | 0x704859B0 | Delay time.
GIFG_DISPOSAL_METHOD | 0x704859AE | Disposal method.
GIFG_USER_INPUT_FLAG | 0x704859AF | User Input flag.
GIFT_BACK_COLOR | 0x704859BB | Text background color.
GIFT_CELL_HEIGHT | 0x704859B9 | Character cell height.
GIFT_CELL_WIDTH | 0x704859B8 | Character cell width.
GIFT_FORE_COLOR | 0x704859BA | Text foreground color.
GIFT_GRID_HEIGHT | 0x704859B7 | Text grid height.
GIFT_GRID_WIDTH | 0x704859B6 | Text grid width.
GIFT_LEFT_POSITION | 0x704859B4 | Text grid left position.
GIFT_PLAIN_TEXT | 0x704859BC | Plain text data.
GIFT_TOP_POSITION | 0x704859B5 | Text grid top position.
GIFX_APP_DATA | 0x704859B3 | Application data.
GIFX_APP_ID | 0x704859B1 | Application identifier.
GIFX_AUTHENTICATION | 0x704859B2 | Authentication code.
HEADER | 0x49484452 | Header information.
HISTOGRAM | 0x68495354 | Histogram information.
ICC_PROFILE | 0x69434350 | ICC profile information.
ICCP_DATA | 0x7048597F | Profile data.
ICCP_NAME | 0x7048597E | Profile name.
IHDR_BIT_DEPTH | 0x70485976 | Image bit depth.
IHDR_COLOR_TYPE | 0x70485977 | Color type.
IHDR_COMPRESSION | 0x70485978 | Compression type.
IHDR_FILTER_TYPE | 0x70485979 | Filter type.
IHDR_HEIGHT | 0x70485975 | Image height.
IHDR_INTERLACE_TYPE | 0x7048597A | Interlace type.
IHDR_WIDTH | 0x70485974 | Image width.
IMAGE_OFFSET | 0x6F464673 | Image offset.
INTERNATIONAL_TEXT | 0x69545874 | International textual data information.
ITXT_COMPR_FLAG | 0x7048598C | Compression flag.
ITXT_COMPR_METHOD | 0x7048598D | Compression method.
ITXT_KEYWORD | 0x7048598B | International textual data chunk keyword that indicates the type of information represented by the text string.
ITXT_LANGUAGE | 0x7048598E | Language tag.
ITXT_TEXT | 0x70485990 | International textual data chunk text.
ITXT_TRANSL_KEYWORD | 0x7048598F | Translated keyword.
OFFS_UNIT | 0x704859A2 | Unit specifier.
OFFS_X_POSITION | 0x704859A0 | X position.
OFFS_Y_POSITION | 0x704859A1 | Y position.
PCAL_EQUATION | 0x704859A6 | Equation type.
PCAL_NAME | 0x704859A3 | Calibration name.
PCAL_PAR_COUNT | 0x704859A7 | Number of parameters.
PCAL_PARAMETER | 0x704859AA | Calibration parameter.
PCAL_UNIT | 0x704859A8 | Unit root.
PCAL_UNIT_NAME | 0x704859A9 | Unit name.
PCAL_X0 | 0x704859A4 | Original zero(x0).
PCAL_X1 | 0x704859A5 | Original Max(x1).
PHYS_UNIT | 0x7048597D | Unit specifier.
PHYS_X_AXIS | 0x7048597B | Intended pixel size or aspect ratio by X axis for display .
PHYS_Y_AXIS | 0x7048597C | Intended pixel size or aspect ratio by Y axis for display.
PHYSICAL_SCALE | 0x7343414C | Physical scale information.
RESOLUTION | 0x70485973 | Resolution information.
SCAL_HEIGHT | 0x704859AD | Pixel height.
SCAL_UNIT | 0x704859AB | Unit specifier.
SCAL_WIDTH | 0x704859AC | Pixel width.
SIGNIFICANT_BITS | 0x73424954 | Significant bits information.
SPLT_ALPHA | 0x70485998 | Suggested palette alpha entry value.
SPLT_BLUE | 0x70485997 | Suggested palette blue entry value.
SPLT_DEPTH | 0x70485992 | Sample depth.
SPLT_ENTRY | 0x70485994 | Suggested palette entry.
SPLT_ENTRY_COUNT | 0x70485993 | Suggested palette entry count.
SPLT_FREQUENCY | 0x70485999 | Suggested palette frequency entry value.
SPLT_GREEN | 0x70485996 | Suggested palette green entry value.
SPLT_NAME | 0x70485991 | Palette name.
SPLT_RED | 0x70485995 | Suggested palette red entry value.
SRGB | 0x73524742 | Standard RGB information.
SUGGESTED_PALETTE | 0x73504C54 | Suggested palette information.
TEXT | 0x74455874 | Text data information.
TEXT_KEYWORD | 0x70485986 | Textual data chunk keyword that indicates the type of information represented by the text string.
TEXT_TEXT | 0x70485987 | Textual data chunk text.
TIME | 0x74494D45 | Time image last modification information.
TIME_DAY | 0x7048599C | Image last-modification time day value.
TIME_HOUR | 0x7048599D | Image last-modification time hour value.
TIME_MINUTE | 0x7048599E | Image last-modification time minute value.
TIME_MONTH | 0x7048599B | Image last-modification time month value.
TIME_SECOND | 0x7048599F | Image last-modification time second value.
TIME_YEAR | 0x7048599A | Image last-modification time year value.
TRANSPARENCY | 0x74524E53 | Transparency information.
XMP | 0x704859BD | XML packet containing XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPNGTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPSDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPSDTagIDs Enumeration
Lists all PSD tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPSDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPSDTagIDs
public enum ImGearPSDTagIDs : System.Enum
__value public enum ImGearPSDTagIDs : public System.Enum
public enum class ImGearPSDTagIDs : public System.Enum
Members
Member | Value | Description
CHANNELS | 2152 | Number of image channels.
COLOR_DATA | 2109 | Color data.
COLS | 2103 | The width of the image in pixels.
COMPRESSION | 2107 | Image data compression.
DEPTH | 2104 | The number of bits per channel.
EXTRA_LAYERS_DATA | 2112 | Extra layers data.
FILE_HDR | 2108 | File header.
FORMAT | 16 | PSD metadata format identifier.
HEADER | 2150 | Header data section.
IPTC_NAA | 2153 | IPTC NAA data section.
LAYER_COUNT | 2154 | Layer count.
LAYERS | 2111 | Layers data.
MODE | 2105 | Color mode.
MODE_LEN | 2106 | Color mode data length.
PHOTOSHOP_RESOURCES | 2110 | Photoshop resources.
RESERVED_HDR | 2151 | Reserved HDR.
ROWS | 2102 | The height of the image in pixels.
SIGNATURE | 2100 | File type identifier.
VERSION | 2101 | Version number.
XMP | 2200 | XMP data section.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPSDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPSTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPSTagIDs Enumeration
Lists all PostScript tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPSTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPSTagIDs
public enum ImGearPSTagIDs : System.Enum
__value public enum ImGearPSTagIDs : public System.Enum
public enum class ImGearPSTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 15 | PS metadata format identifier.
XMP | 16 | XML packet containing XMP metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPSTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPTOCATagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearPTOCATagIDs Enumeration
Lists all PTOCA tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPTOCATagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearPTOCATagIDs
public enum ImGearPTOCATagIDs : System.Enum
__value public enum ImGearPTOCATagIDs : public System.Enum
public enum class ImGearPTOCATagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 8 | PTOCA metadata format identifier.
HEIGHT | 1002 | Image height.
WIDTH | 1001 | Image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPTOCATagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRASTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRASTagIDs Enumeration
Lists all RAS tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRASTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearRASTagIDs
public enum ImGearRASTagIDs : System.Enum
__value public enum ImGearRASTagIDs : public System.Enum
public enum class ImGearRASTagIDs : public System.Enum
Members
Member | Value | Description
COLOR_MAP_LENGTH | 7 | Color map length.
COLOR_MAP_TYPE | 6 | Color map type.
DEPTH | 3 | Image depth.
FORMAT | 38 | RAS metadata format identifier.
HEIGHT | 2 | Image height.
LENGTH | 4 | Length of the image data (which is the length of the file minus the length of the header and colormap).
MAGIC | 0 | RAS magic value.
TYPE | 5 | RAS format type.
WIDTH | 1 | Image width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearRASTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRasterConversionModes Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRasterConversionModes Enumeration
Lists all raster conversion modes for image saving.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRasterConversionModes
   Inherits System.Enum
'Usage

Dim instance As ImGearRasterConversionModes
public enum ImGearRasterConversionModes : System.Enum
__value public enum ImGearRasterConversionModes : public System.Enum
public enum class ImGearRasterConversionModes : public System.Enum
Members
Member | Value | Description
ANY | 0 | Allow any conversion supported by ImageGear.
DIRECT_MATCH | 2 | Allow saving only unchanged pixel data.
NO_QUALITY_LOSS | 1 | Only allow pixel data conversion that does not degrade image quality.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearRasterConversionModes

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRectangleInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearRectangleInfoTagIDs Enumeration
Lists all Photoshop Rectangle Info tag ids.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRectangleInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearRectangleInfoTagIDs
public enum ImGearRectangleInfoTagIDs : System.Enum
__value public enum ImGearRectangleInfoTagIDs : public System.Enum
public enum class ImGearRectangleInfoTagIDs : public System.Enum
Members
Member | Value | Description
Bottom | 3 | Rectangle bottom coordinate.
FORMAT | 1150 | Rectangle metadata format identifier.
Left | 0 | Rectangle left coordinate.
Right | 2 | Rectangle right coordinate.
Top | 1 | Rectangle top coordinate.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearRectangleInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearResolutionInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearResolutionInfoTagIDs Enumeration
Lists all Photoshop Resolution Info tag ids.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearResolutionInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearResolutionInfoTagIDs
public enum ImGearResolutionInfoTagIDs : System.Enum
__value public enum ImGearResolutionInfoTagIDs : public System.Enum
public enum class ImGearResolutionInfoTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 1122 | Resolution info metadata format identifier.
H_RESOLUTION | 0 | Horizontal resolution.
H_RESOLUTION_UNIT | 1 | Horizontal unit.
HEIGHT_UNIT | 5 | Height unit.
V_RESOLUTION | 3 | Vertical resolution.
V_RESOLUTION_UNIT | 4 | Vertical unit.
WIDTH_UNIT | 2 | Width unit.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearResolutionInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearSavingFormats Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSavingFormats Enumeration
Lists all ImageGear saving formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSavingFormats
   Inherits System.Enum
'Usage

Dim instance As ImGearSavingFormats
public enum ImGearSavingFormats : System.Enum
__value public enum ImGearSavingFormats : public System.Enum
public enum class ImGearSavingFormats : public System.Enum
Members
Member | Value | Description
BMP_RLE | 0x00080001 | BMP RLE format.
BMP_UNCOMP | 0x00010001 | BMP Uncompressed.
BTR | 0x0000001D | BTR CCITT Group 3.
BTR_G3_2D | 0x0005001D | BTR CCITT Group 3 2D.
CAL | 0x00000002 | CAL CCITT Group 4.
CGM | 0x00000017 | CGM (vector).
CLP | 0x00000003 | CLP Uncompressed.
CLP_RLE | 0x00080003 | CLP RLE format.
CUR | 0x0000001B | CUR Uncompressed.
CUT_RLE | 0x00000023 | CUT RLE format.
DCX | 0x00000004 | DCX RLE format.
DICOM | 0x00000030 | DICOM (Control parameters define compression).
DICOM_JPEG | 0x00070030 | DICOM JPEG.
DICOM_JPEG2K | 0x000B0030 | DICOM JPEG2K.
DICOM_RLE | 0x00080030 | DICOM RLE format.
DICOM_UNCOMP | 0x00010030 | DICOM Uncompressed.
DWF | 0x00000040 | DWF (vector).
DWG | 0x00000015 | DWG (vector).
DXF | 0x00000016 | DXF (vector).
GIF | 0x00000005 | GIF LZW format.
HDPHOTO | 0x00000032 | HD PHOTO format.
ICA_G3 | 0x00030006 | ICA CCITT Group 3.
ICA_G4 | 0x00040006 | ICA CCITT Group 4.
ICA_MMR | 0x000E0006 | ICA IBM MMR.
ICO | 0x0000001A | ICO Uncompressed.
IFF | 0x00000025 | IFF Uncompressed.
IFF_RLE | 0x00080025 | IFF RLE format.
JP2 | 0x0000002D | JP2 JPEG2K.
JPG | 0x0000002E | JPG JPEG format.
JPX | 0x0000002F | JPX JPEG2K.
MJ2 | 0x0000001C | Reserved for future use.
MODCA_G3 | 0x00030007 | MODCA CCITT Group 3.
MODCA_G4 | 0x00040007 | MODCA CCITT Group 4.
MODCA_MMR | 0x000E0007 | MODCA IBM MMR.
NCR | 0x00000022 | NCR CCITT Group 4.
PBM_ASCII | 0x000C000A | PBM ASCII.
PBM_RAW | 0x000D000A | PBM RAW format.
PCX | 0x0000000C | PCX RLE format.
PDF | 0x0000000D | PDF Uncompressed.
PDF_DEFLATE | 0x000A000D | PDF Deflate.
PDF_G3 | 0x0003000D | PDF CCITT Group 3.
PDF_G3_2D | 0x0005000D | PDF CCITT Group 3 2D.
PDF_G4 | 0x0004000D | PDF CCITT Group 4.
PDF_JPEG2K | 0x000B000D | PDF JPEG2K.
PDF_JPG | 0x0007000D | PDF JPEG format.
PDF_LZW | 0x0009000D | PDF LZW format.
PDF_RLE | 0x0008000D | PDF RLE format.
PDF_UNCOMP | 0x0001000D | PDF Uncompressed.
PNG | 0x0000000E | PNG Deflate.
PS | 0x0000000F | PS Uncompressed.
PS_DEFLATE | 0x000A000F | PS Deflate.
PS_G3 | 0x0003000F | PS CCITT Group 3.
PS_G3_2D | 0x0005000F | PS CCITT Group 3 2D.
PS_G4 | 0x0004000F | PS CCITT Group 4.
PS_JPEG2K | 0x000B000F | PS JPEG2K.
PS_JPG | 0x0007000F | PS JPEG format.
PS_LZW | 0x0009000F | PS LZW format.
PS_RLE | 0x0008000F | PS RLE format.
PS_UNCOMP | 0x0001000F | PS Uncompressed.
PSB_PACKED | 0x00060041 | PSB RLE format.
PSB_UNCOMP | 0x00010041 | PSB Uncompressed.
PSD_PACKED | 0x00060010 | PSD RLE format.
PSD_UNCOMP | 0x00010010 | PSD Uncompressed.
RAS | 0x00000026 | RAS Uncompressed.
RAS_RLE | 0x00080026 | RAS RLE format.
SCI | 0x00000011 | SCI Uncompressed.
SGI | 0x00000012 | SGI Uncompressed.
SGI_RLE | 0x00080012 | SGI RLE format.
SVG | 0x00000031 | SVG (Vector).
TGA_RLE | 0x00080013 | TGA RLE format.
TGA_UNCOMP | 0x00010013 | TGA Uncompressed.
TIF_DEFLATE | 0x000A0014 | TIFF Deflate.
TIF_G3 | 0x00030014 | TIFF CCITT Group 3.
TIF_G3_2D | 0x00050014 | TIFF CCITT Group 3 2D.
TIF_G4 | 0x00040014 | TIFF CCITT Group 4.
TIF_HUFFMAN | 0x00020014 | TIFF Huffman.
TIF_JPG | 0x00070014 | TIFF JPEG format.
TIF_LZW | 0x00090014 | TIFF LZW format.
TIF_PACKED | 0x00060014 | TIFF PackBits.
TIF_UNCOMP | 0x00010014 | TIFF Uncompressed.
U3D | 0x00010042 | U3D (Vector).
UNKNOWN | 0x00000000 | Unknown format. Specifying it on saving tells ImageGear to use file name extension to determine the saving format.
WBMP | 0x00000028 | WBMP Uncompressed.
XBM | 0x0000002B | XBM Uncompressed.
XPM | 0x0000002C | XPM Uncompressed.
XPS | 0x0000003F | XPS (Vector).
XWD | 0x00000029 | XWD Uncompressed.
Remarks
Each saving format is a combination of a file format and a compression (e.g., TIF_G4 specifies TIF file format and CCITT Group4 compression). ImGearCompressions.AUTO specifies default compression for the format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearSavingFormats

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearSavingModes Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSavingModes Enumeration
Lists all saving modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSavingModes
   Inherits System.Enum
'Usage

Dim instance As ImGearSavingModes
public enum ImGearSavingModes : System.Enum
__value public enum ImGearSavingModes : public System.Enum
public enum class ImGearSavingModes : public System.Enum
Members
Member | Value | Description
APPEND | 1 | New pages are appended to existing image. Any time ImGearFileFormats.SavePage method is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
INSERT | 2 | New pages are inserted into existing image.
OVERWRITE | 0 | A new image is created during saving. If old image exists, it is overwritten.
REPLACE | 3 | New pages replace existing pages in the image.
Remarks
This enumeration specifies available saving modes, such as overwrite image, insert page, etc.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearSavingModes

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearSCITagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSCITagIDs Enumeration
Lists all SCI tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSCITagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearSCITagIDs
public enum ImGearSCITagIDs : System.Enum
__value public enum ImGearSCITagIDs : public System.Enum
public enum class ImGearSCITagIDs : public System.Enum
Members
Member | Value | Description
BLOCKSIZE | 4101 | Block size.
FORMAT | 17 | SCI metadata format identifier.
PRM_HEIGHT_IN_PIXELS | 4107 | PRM height in pixels.
PRM_HEIGHT_IN_UNITS | 4105 | PRM height in units.
PRM_NUM_COLOR_SEPARATIONS | 4103 | PRM num color separations.
PRM_SCAN_DIRECTION | 4109 | PRM scan direction.
PRM_SEPARATIONS_BIT_MASK | 4104 | PRM separations bit mask.
PRM_UNITS_OF_MEASUREMENT | 4102 | PRM units of measurement.
PRM_WIDTH_IN_PIXELS | 4108 | PRM width in pixels.
PRM_WIDTH_IN_UNITS | 4106 | PRM width in units.
TYPE | 4100 | File type identifier.
Remarks
This enumeration lists all Scitex CT tag identifiers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearSCITagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearSGITagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearSGITagIDs Enumeration
Lists all SGI tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSGITagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearSGITagIDs
public enum ImGearSGITagIDs : System.Enum
__value public enum ImGearSGITagIDs : public System.Enum
public enum class ImGearSGITagIDs : public System.Enum
Members
Member | Value | Description
BPC | 1402 | Number of bytes per pixel channel.
COLOR_MAP | 1411 | Color map.
DIMENSION | 1403 | Number of dimensions.
DUMMY1 | 1409 | Dummy 1 value.
DUMMY2 | 1412 | Dummy 2 value.
FORMAT | 18 | SGI metadata format identifier.
IMAGE_NAME | 1410 | Image name.
MAGIC | 1400 | IRIS image file magic number.
PIX_MAX | 1408 | Maximum pixel value.
PIX_MIN | 1407 | Minimum pixel value.
STORAGE | 1401 | Storage format.
X_SIZE | 1404 | X size in pixels.
Y_SIZE | 1405 | Y size in pixels.
Z_SIZE | 1406 | Number of channels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearSGITagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearTGATagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearTGATagIDs Enumeration
Lists all TGA tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTGATagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearTGATagIDs
public enum ImGearTGATagIDs : System.Enum
__value public enum ImGearTGATagIDs : public System.Enum
public enum class ImGearTGATagIDs : public System.Enum
Members
Member | Value | Description
EXT | 18 | Extension data section.
EXT_ATTRIBUTESTYPE | 43 | Attributes type.
EXT_AUTHORCOMMENT | 21 | Author comment.
EXT_AUTHORNAME | 20 | Author name.
EXT_COLOROFFSET | 40 | Color offset.
EXT_GAMMADENOMINATOR | 39 | Gamma denominator.
EXT_GAMMANUMERATOR | 38 | Gamma numerator.
EXT_JOBHOUR | 29 | Job hour value.
EXT_JOBMINUTE | 30 | Job minute value.
EXT_JOBNAME | 28 | Job name .
EXT_JOBSECOND | 31 | Job second value.
EXT_KEYCOLOR | 35 | Key color.
EXT_PIXELDENOMINATOR | 37 | Pixel denominator.
EXT_PIXELNUMERATOR | 36 | Pixel numerator.
EXT_SCANOFFSET | 42 | Scan offset.
EXT_SIZE | 119 | Extension size.
EXT_SOFTWAREID | 32 | Software ID.
EXT_STAMPDAY | 23 | Stamp day.
EXT_STAMPHOUR | 25 | Stamp hour.
EXT_STAMPMINUTE | 26 | Stamp minute.
EXT_STAMPMONTH | 22 | Stamp month.
EXT_STAMPOFFSET | 41 | Stamp offset.
EXT_STAMPSECOND | 27 | Stamp second.
EXT_STAMPYEAR | 24 | Stamp year.
EXT_VERSIONLETTER | 34 | Version letter.
EXT_VERSIONNUMBER | 33 | Version number.
FOOT | 14 | Footer data section.
FOOT_DEVELOPER_OFFSET | 16 | Developer offset.
FOOT_EXTENSION_OFFSET | 15 | Extension offset.
FOOT_SIGNATURE | 17 | Signature string.
FORMAT | 19 | TGA metadata format identifier.
HEAD | 1 | Header data section.
HEAD_CMAPDEPTH | 7 | CMap depth.
HEAD_CMAPLENGTH | 6 | CMap length.
HEAD_CMAPSTART | 5 | CMap start.
HEAD_COLORMAPTYPE | 3 | Color map type.
HEAD_HEIGHT | 11 | Image height.
HEAD_IDLENGTH | 2 | ID length.
HEAD_IMAGEDESCRIPTOR | 13 | Image descriptor.
HEAD_IMAGETYPE | 4 | Image type.
HEAD_PIXELDEPTH | 12 | Pixel depth.
HEAD_WIDTH | 10 | Image width.
HEAD_XOFFSET | 8 | Absolute horizontal coordinate for the lower left corner of the image as it is positioned on a display device having an origin at the lower left of the screen.
HEAD_YOFFSET | 9 | Absolute vertical coordinate for the lower left corner of the image as it is positioned on a display device having an origin at the lower left of the screen.
IMAGE_ID | 44 | Image ID tag.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearTGATagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearThumbnailInfoTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearThumbnailInfoTagIDs Enumeration
Lists all Photoshop Thumbnail Info tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearThumbnailInfoTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearThumbnailInfoTagIDs
public enum ImGearThumbnailInfoTagIDs : System.Enum
__value public enum ImGearThumbnailInfoTagIDs : public System.Enum
public enum class ImGearThumbnailInfoTagIDs : public System.Enum
Members
Member | Value | Description
BITS_PER_PIXEL | 6 | Bits per pixel.
FORMAT | 1123 | Thumbnail info metadata format identifier.
HEIGHT | 2 | Thumbnail height.
IMG_FORMAT | 0 | Image format.
OFFSET | 8 | Thumbnail offset.
PLANES | 7 | Thumbnail planes.
SIZE_COMPRESSED | 5 | Size compressed.
SIZE_TOTAL | 4 | Size total.
WIDTH | 1 | Thumbnail width.
WIDTHBYTES | 3 | Width bytes.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearThumbnailInfoTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearTIFTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearTIFTagIDs Enumeration
Lists all TIF tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFTagIDs
public enum ImGearTIFTagIDs : System.Enum
__value public enum ImGearTIFTagIDs : public System.Enum
public enum class ImGearTIFTagIDs : public System.Enum
Members
Member | Value | Description
ACTIVE_AREA | 50829 | Active area.
ANALOG_BALANCE | 50727 | Analog balance.
ANTI_ALIAS_STRENGTH | 50738 | Anti alias strength.
APERTURE_VALUE | 37378 | Aperture value.
ART_DATA | 32932 | ART annotation data (ImageGear tag).
ARTIST | 315 | Person who created the image.
AS_SHOT_NEUTRAL | 50728 | As shot neutral.
AS_SHOT_WHITEXY | 50729 | As shot white XY.
ASSHOT_ICC_PROFILE | 50831 | As shot ICC profile.
ASSHOT_PRE_PROFILE_MATRIX | 50832 | As shot pre profile matrix.
BASELINE_EXPOSURE | 50730 | Baseline exposure.
BASELINE_NOISE | 50731 | Baseline noise.
BASELINE_SHARPNESS | 50732 | Baseline sharpness.
BATTERY_LEVEL | 33423 | Battery level.
BAYER_GREEN_SPLIT | 50733 | Bayer green split.
BEST_QUALITY_SCALE | 50780 | Best quality scale.
BITS_PER_SAMPLE | 258 | Bits per sample.
BLACK_LEVEL | 50714 | Black level.
BLACK_LEVEL_DELTAH | 50715 | Black level delta H.
BLACK_LEVEL_DELTAV | 50716 | Black level delta V.
BLACK_LEVELREPEAT_DIM | 50713 | Black level repeat dim.
BRIGHTNESS_VALUE | 37379 | Brightness value.
BYTE_ORDER | 59937 | Byte order.
CALIBRATION_ILLUMINANT1 | 50778 | Calibration illuminant 1.
CALIBRATION_ILLUMINANT2 | 50779 | Calibration illuminant 2.
CAMERA_CALIBRATION1 | 50723 | Camera calibration 1.
CAMERA_CALIBRATION2 | 50724 | Camera calibration 2.
CAMERA_SERIAL_NUMBER | 50735 | Camera serial number.
CELL_HEIGHT | 265 | Cell height.
CELL_WIDTH | 264 | Cell width.
CFA_LAYOUT | 50711 | CFA layout.
CFA_PATTERN | 33422 | CFA pattern.
CFA_PlANECOLOR | 50710 | CFA plane color.
CFA_REPEAT_PATTERN_DIM | 33421 | CFA repeat pattern dim.
CHROMA_BLUR_RADIUS | 50737 | Chroma blur radius.
COLOR_MAP | 320 | Color map.
COLOR_MATRIX1 | 50721 | Color matrix 1.
COLOR_MATRIX2 | 50722 | Color matrix 2.
COMPRESSEDBITSPERPIXEL | 37122 | Compressed bits per pixel.
COMPRESSION | 259 | Image data compression type.
COPYRIGHT | 33432 | Copyright notice.
CURRENT_ICC_PROFILE | 50833 | Current ICC profile.
CURRENT_PRE_PROFILE_MATRIX | 50834 | Current pre profile matrix.
DATE_TIME | 306 | Date time.
DATETIMEORIGINAL | 36867 | Date time original.
DEFAULT_CROP_ORIGIN | 50719 | Default crop origin.
DEFAULT_CROP_SIZE | 50720 | Default crop size.
DEFAULT_SCALE | 50718 | Default scale.
DESCRIPTION | 270 | Image description.
DNG_BACKWARDVERSION | 50707 | DNG backward version.
DNG_PRIVATE_DATA | 50740 | DNG private data.
DNG_VERSION | 50706 | DNG version.
DOC_NAME | 269 | Document name.
DOT_RANGE | 336 | Dot range.
EXIF_IFDPOINTER | 34665 | Exif IFD pointer.
EXPOSURE_BIAS_VALUE | 37380 | Exposure bias value.
EXPOSURE_INDEX | 37397 | Exposure index.
EXPOSURE_PROGRAM | 34850 | Exposure program.
EXPOSURE_TIME | 33434 | Exposure time.
EXTRA_SAMPLES | 338 | Extra samples.
FILL_ORDER | 266 | Fill order.
FLASH | 37385 | Indicates weither or not flash used when the image was captured.
FLASHENERGY | 37387 | Flash energy.
FNUMBER | 33437 | Actual lens f-number used when the image was captured.
FOCAL_LENGTH | 37386 | Focal length.
FOCAL_PLANE_RESOLUTION_UNIT | 37392 | Focal plane resolution unit.
FOCAL_PLANE_XRESOLUTION | 37390 | Focal plane xresolution.
FOCAL_PLANE_YRESOLUTION | 37391 | Focal plane yresolution.
FORMAT | 20 | TIF metadata format identifier.
FREE_BYTE_COUNTS | 289 | Free byte counts.
FREE_OFFSETS | 288 | Free offsets.
GPSINFOIFDPOINTER | 34853 | GPS info IFD pointer.
GRAY_RESPONSE_CURVE | 291 | Gray response curve.
GRAY_RESPONSE_UNIT | 290 | Gray response unit.
HALFTONE_HINTS | 321 | Halftone hints.
HOST_COMPUTER | 316 | Host computer.
ICC_PROFILE | 34675 | ICC color profile.
IDENTIFIER | 59938 | TIFF format Identifier.
IMAGE_HEIGHT | 257 | Image height.
IMAGE_HISTORY | 37395 | Image history.
IMAGE_NUMBER | 37393 | Image number.
IMAGE_WIDTH | 256 | Image width.
INK_NAMES | 333 | Ink names.
INK_SET | 332 | The set of inks used.
INTERLACE | 34857 | Indicates the field number of multifield images.
IPTC_NAA | 33723 | IPTC / NAA.
ISOSPEEDRAITINGS | 34855 | ISO speed raitings.
JPEG_AC_TABLES | 521 | JPEG AC tables.
JPEG_DC_TABLES | 520 | JPEG DC tables.
JPEG_INTERCHANGE | 513 | JPEG interchange format.
JPEG_INTERCHANGE_LEN | 514 | JPEG interchange format length.
JPEG_LOSSLESS_PREDICTOR | 517 | JPEG lossless predictors.
JPEG_POINT_TRANSFORMS | 518 | JPEG point transforms.
JPEG_PROC | 512 | JPEG proc.
JPEG_Q_TABLES | 519 | JPEG Q tables.
JPEG_RESTART_INTERVAL | 515 | JPEG restart interval.
JPEG_TABLES | 347 | JPEG tables.
LENS_INFO | 50736 | Lens info.
LIGHT_SOURCE | 37384 | Light source.
LINEAR_RESPONSE_LIMIT | 50734 | Linear response limit.
LINEARIZATION_TABLE | 50712 | Linearization table.
LOCALIZED_CAMERAMODEL | 50709 | Localized camera model.
MAKE | 271 | Manufacturer of equipment used to generate the image.
MAKER_NOTE_SAFETY | 50741 | Maker note safety.
MASKED_AREAS | 50830 | Masked areas.
MAX_SAMPLE_VAL | 281 | Max sample value.
MAXAPERTURE_VALUE | 37381 | Max aperture value.
METERING_MODE | 37383 | Metering mode.
MICROSOFT_PHOTO_RATING | 18249 | Microsoft photo rating.
MIN_SAMPLE_VAL | 280 | Min sample value.
MODEL | 272 | The model name of equipment used to generate the image.
NEW_SUBFILE_TYPE | 254 | New subfile type.
NOISE | 37389 | Noise measurement values.
NUMBER_OF_INKS | 334 | Number of inks.
OECF | 34856 | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524.
ORIENTATION | 274 | Image orientation.
ORIGINAL_RAW_FILE_DATA | 50828 | Original raw file data.
ORIGINAL_RAW_FILE_NAME | 50827 | Original raw file name.
PAGE_NAME | 285 | Page name.
PAGE_NUMBER | 297 | Page number.
PHOTO_INTERP | 262 | Photometric interpretation.
PHOTOSHOP_RESOURCES | 34377 | Photoshop resources.
PLANAR_CONFIG | 284 | Planar configuration.
PREDICTOR | 317 | Mathematical operator that is applied to the image data before an encoding scheme is applied.
PRIMARY_CHROMA | 319 | Primary chromaticities.
RATING | 18246 | Image rating.
RAW_DATA_UNIQUE_ID | 50781 | Raw data unique ID.
REDUCTION_MATRIX1 | 50725 | Reduction matrix 1.
REDUCTION_MATRIX2 | 50726 | Reduction matrix 2.
REFERENCE_BLACK_WHITE | 532 | Reference black white.
RES_UNIT | 296 | Resolution unit.
ROWS_PER_STRIP | 278 | Rows per strip.
SAMPLE_FORMAT | 339 | Sample format.
SAMPLES_PER_PIXEL | 277 | Samples per pixel.
SECURITY_CLASSIFICATION | 37394 | Security classification.
SELFTIMER_MODE | 34859 | Self timer mode.
SENSING_METHOD | 37399 | Sensing method.
SHADOW_SCALE | 50739 | Shadow scale.
SHUTTERSPEED_VALUE | 37377 | Shutter speed value.
SMAX_SAMPLE_VAL | 341 | S max sample value.
SMIN_SAMPLE_VAL | 340 | S min sample value.
SOFTWARE | 305 | Name and version number of the software package(s) used to create the image.
SPATIAL_FREQUENCY_RESPONSE | 37388 | Spatial frequency response.
SPECTRAL_SENSITIVITY | 34852 | Spectral sensitivity.
STRIP_BYTE_COUNT | 279 | Strip byte counts.
STRIP_OFFSETS | 273 | Strip offsets.
SUB_IFDS | 330 | Child IFDs offsets.
SUBFILE_TYPE | 255 | Subfile type.
SUBJECT_LOCATION | 37396 | Subject location.
SUBJECTDISTANCE | 37382 | Subject distance.
T4_OPTIONS | 292 | T4 options.
T6_OPTIONS | 293 | T6 options.
TARGET_PRINTER | 337 | Target printer.
THRESHOLDING | 263 | The technique used to convert from gray to black and white pixels.
TIFFEP_STANDARDID | 37398 | TIFF/EP standard ID.
TILE_BYTE_COUNT | 325 | Tile byte counts.
TILE_HEIGHT | 323 | Tile height.
TILE_OFFSETS | 324 | Tile offsets.
TILE_WIDTH | 322 | Tile width.
TIMEZONE_OFFSET | 34858 | Time zone offset.
TRANSFER_FUNC | 301 | Transfer function.
TRANSFER_RANGE | 342 | Transfer range.
UNIQUE_CAMERAMODEL | 50708 | Unique camera model.
WHITE_LEVEL | 50717 | White level.
WHITE_POINT | 318 | White point.
X_POS | 286 | X position.
X_RES | 282 | X resolution.
XMP | 700 | XML packet containing XMP metadata.
Y_POS | 287 | Y position.
Y_RES | 283 | Y resolution.
YCBCR_COEFFICIENTS | 529 | YCbCr coefficients.
YCBCR_POS | 531 | YCbCr positioning.
YCBCR_SUBSAMPLING | 530 | YCbCr sub sampling.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearTIFTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearWBMPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWBMPTagIDs Enumeration
Lists all WBMP tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearWBMPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearWBMPTagIDs
public enum ImGearWBMPTagIDs : System.Enum
__value public enum ImGearWBMPTagIDs : public System.Enum
public enum class ImGearWBMPTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 40 | WBMP metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearWBMPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearWPGTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearWPGTagIDs Enumeration
Lists all WPG tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearWPGTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearWPGTagIDs
public enum ImGearWPGTagIDs : System.Enum
__value public enum ImGearWPGTagIDs : public System.Enum
public enum class ImGearWPGTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 39 | WPG metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearWPGTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearXBMTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearXBMTagIDs Enumeration
Lists all XBM tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXBMTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearXBMTagIDs
public enum ImGearXBMTagIDs : System.Enum
__value public enum ImGearXBMTagIDs : public System.Enum
public enum class ImGearXBMTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 43 | XBM metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearXBMTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearXMPTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearXMPTagIDs Enumeration
Lists all XMP tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXMPTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearXMPTagIDs
public enum ImGearXMPTagIDs : System.Enum
__value public enum ImGearXMPTagIDs : public System.Enum
public enum class ImGearXMPTagIDs : public System.Enum
Members
Member | Value | Description
About | 2 | About attribute value.
Alt | 11 | Alternative array of values tree.
Bag | 9 | Bag of values (unordered array) tree.
Description | 1 | XMP Schema tree.
FORMAT | 0 | XMP Metadata Format identifier.
Item | 12 | Array item tree.
Lang | 13 | Language alternative tree.
Namespace | 3 | Namespace tree.
Prefix | 4 | Namespace prefix value.
Properties | 6 | Properties tree.
Property | 7 | Property tree.
Qualifier | 16 | Qualifier tree.
Qualifiers | 15 | Qualifiers tree.
Seq | 10 | Sequence of values (ordered array) tree.
Struct | 14 | Structure tree.
URI | 5 | Namespace URI value.
Value | 8 | Property value.
Remarks
These identifiers represent structural types of XMP metadata, such as Value, Sequence, Bag, Qualifier, etc. ImageGear does not provide enumerations for particilar properties of XMP schemes. For more information about XMP metadata support, see Working with XMP Metadata.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearXMPTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearXPMTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearXPMTagIDs Enumeration
Lists all XPM tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXPMTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearXPMTagIDs
public enum ImGearXPMTagIDs : System.Enum
__value public enum ImGearXPMTagIDs : public System.Enum
public enum class ImGearXPMTagIDs : public System.Enum
Members
Member | Value | Description
FORMAT | 44 | XPM metadata format identifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearXPMTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearXPSTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearXPSTagIDs Enumeration
Lists all XPS tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXPSTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearXPSTagIDs
public enum ImGearXPSTagIDs : System.Enum
__value public enum ImGearXPSTagIDs : public System.Enum
public enum class ImGearXPSTagIDs : public System.Enum
Members
Member | Value | Description
CATEGORY | 64 | The category of the content that is contained in the file.
CONTENT_STATUS | 65 | Example ContentStatus values include "Draft", "Reviewed", and "Final".
CONTENT_TYPE | 66 | Example ContentType values include "Whitepaper", "Security Bulletin", and "Exam".
CREATED | 67 | The date and time the file was initially created.
CREATOR | 68 | The individual or entity that created the file and its content.
DESCRIPTION | 69 | The Description may include, but is not limited to: an abstract, table of contents, reference to a graphical representation of content, or a free-text account of the content.
FORMAT | 63 | XPS metadata format identifier.
IDENTIFIER | 70 | A value that unambiguously identifies the file and its content.
KEYWORDS | 71 | A delimited set of keywords to support searching and indexing the Package and content. The Keywords property typically contains a list of terms that are not available elsewhere in file metadata.
LANGUAGE | 72 | A value that identifies the file content language.
LAST_MODIFIED_BY | 73 | The user who last modified the file content.
LAST_PRINTED | 74 | The date and time the file content was last printed.
MODIFIED | 75 | The date and time the file was last changed.
REVISION | 76 | The revision number of the file. The Revision property indicates the number of changed saves or revisions. The application is responsible for updating the Revision property value after each revision.
SUBJECT | 77 | The topic of the file content.
TITLE | 78 | The name given to the file and its content.
VERSION | 79 | The version number of the file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearXPSTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearXWDTagIDs Enumeration

ImageGear22.Core Assembly > ImageGear.Formats Namespace : ImGearXWDTagIDs Enumeration
Lists all XWD tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXWDTagIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearXWDTagIDs
public enum ImGearXWDTagIDs : System.Enum
__value public enum ImGearXWDTagIDs : public System.Enum
public enum class ImGearXWDTagIDs : public System.Enum
Members
Member | Value | Description
FILE_VERSION | 2 | File version.
FORMAT | 41 | XWD metadata format identifier.
HEADER_SIZE | 1 | Header size.
X11_BITMAP_BIT_ORDER | 10 | Bitmap bit order (MSBFirst, LSBFirst).
X11_BITMAP_PAD | 11 | Bitmap scanline pad.
X11_BITMAP_UNIT | 9 | Bitmap unit.
X11_BITS_PER_PIXEL | 12 | Bits per pixel.
X11_BITS_PER_RGB | 18 | Log2 of distinct color values.
X11_BLUE_MASK | 17 | Blue mask.
X11_BYTE_ORDER | 8 | Byte order.
X11_BYTES_PER_LINE | 13 | Bytes per scanline.
X11_COLOR_MAP_ENTRIES | 20 | Color map entries.
X11_GREEN_MASK | 16 | Green mask.
X11_NUMBER_OF_COLORS | 19 | Colors number.
X11_PIXMAP_DEPTH | 4 | Pixmap depth.
X11_PIXMAP_FORMAT | 3 | Pixmap format.
X11_PIXMAP_HEIGHT | 6 | Pixmap height.
X11_PIXMAP_WIDTH | 5 | Pixmap width.
X11_RED_MASK | 15 | Red mask.
X11_VISUAL_CLASS | 14 | Class of colormap.
X11_WINDOW_BORDER_WIDTH | 25 | Window border width.
X11_WINDOW_HEIGHT | 22 | Window height.
X11_WINDOW_WIDTH | 21 | Window width.
X11_WINDOW_X | 23 | Window upper left X coordinate.
X11_WINDOW_Y | 24 | Window upper left Y coordinate.
X11_X_OFFSET | 7 | Bitmap x offset.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearXWDTagIDs

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

IImGearFormat Interface
Members

ImageGear22.Core Assembly > ImageGear.Formats Namespace : IImGearFormat Interface
Base interface for all file format filters.
Object Model
IImGearFormat InterfaceImGearFormatParameters ClassImGearControlParameter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearFormat
'Usage

Dim instance As IImGearFormat
public interface IImGearFormat
public __gc __interface IImGearFormat
public interface class IImGearFormat
Remarks
This interface provides access to format filters' settings.
See Also

Reference

IImGearFormat Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

IImGearFormat Interface Members
Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : IImGearFormat Interface

The following tables list the members exposed by IImGearFormat.

Public Properties
 | Name | Description
Property | DefaultExtension | Gets the default extension used when naming files containing images in this format (e.g., ‘*.bmp’ for the BMP format).
Property | DetectionEnabled | Gets or sets a value indicating whether the format should be used in the image detection process.
Property | FullName | Gets the full name of the format.
Property | ID | Gets the ID of the format.
Property | MIMEType | Gets the MIME Media Type associated with the format.
Property | Name | Gets the short name of the format.
Property | Parameters | Gets format's control parameters.
Top
See Also

Reference

IImGearFormat Interface
ImageGear.Formats Namespace


%%PageItemTitle%% $$Properties$$

IImGearFormat Interface Properties

ImageGear22.Core Assembly > ImageGear.Formats Namespace : IImGearFormat Interface

For a list of all members of this type, see IImGearFormat members.

Public Properties
 | Name | Description
Property | DefaultExtension | Gets the default extension used when naming files containing images in this format (e.g., ‘*.bmp’ for the BMP format).
Property | DetectionEnabled | Gets or sets a value indicating whether the format should be used in the image detection process.
Property | FullName | Gets the full name of the format.
Property | ID | Gets the ID of the format.
Property | MIMEType | Gets the MIME Media Type associated with the format.
Property | Name | Gets the short name of the format.
Property | Parameters | Gets format's control parameters.
Top
See Also

Reference

IImGearFormat Interface
ImageGear.Formats Namespace


DefaultExtension Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : DefaultExtension Property
Gets the default extension used when naming files containing images in this format (e.g., ‘*.bmp’ for the BMP format).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property DefaultExtension As String
'Usage

Dim instance As IImGearFormat
Dim value As String

value = instance.DefaultExtension
string DefaultExtension {get;}
__property string* get_DefaultExtension();
property String^ DefaultExtension {
   String^ get();
}

Property Value

String containing format extension.
Remarks
This property specifies the default extension used when naming files containing images in this format (e.g., ‘*.bmp’ for the BMP format).

This property is used when populating the filter for the SaveFileDialog.

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


DetectionEnabled Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : DetectionEnabled Property
Gets or sets a value indicating whether the format should be used in the image detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property DetectionEnabled As Boolean
'Usage

Dim instance As IImGearFormat
Dim value As Boolean

instance.DetectionEnabled = value

value = instance.DetectionEnabled
bool DetectionEnabled {get; set;}
__property bool get_DetectionEnabled();
__property void set_DetectionEnabled(
   bool value
);
property bool DetectionEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Detection is enabled for all formats by default. Use this property to exclude a format from detection.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members


FullName Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : FullName Property
Gets the full name of the format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property FullName As String
'Usage

Dim instance As IImGearFormat
Dim value As String

value = instance.FullName
string FullName {get;}
__property string* get_FullName();
property String^ FullName {
   String^ get();
}

Property Value

String containing the format's name.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members


ID Property (IImGearFormat)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : ID Property
Gets the ID of the format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ID As ImGearFormats
'Usage

Dim instance As IImGearFormat
Dim value As ImGearFormats

value = instance.ID
ImGearFormats ID {get;}
__property ImGearFormats get_ID();
property ImGearFormats ID {
   ImGearFormats get();
}

Property Value

Any member of the ImGearFormats enumeration except ImGearFormats.UNKNOWN.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members
ImGearFormats Enumeration


MIMEType Property

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : MIMEType Property
Gets the MIME Media Type associated with the format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property MIMEType As String
'Usage

Dim instance As IImGearFormat
Dim value As String

value = instance.MIMEType
string MIMEType {get;}
__property string* get_MIMEType();
property String^ MIMEType {
   String^ get();
}

Property Value

String containing the format's MIME Type.
Remarks
This property provides the MIME Media Type assiciated with the format, such as "image/jpeg", "image/tiff", etc.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members


Name Property (IImGearFormat)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : Name Property
Gets the short name of the format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Name As String
'Usage

Dim instance As IImGearFormat
Dim value As String

value = instance.Name
string Name {get;}
__property string* get_Name();
property String^ Name {
   String^ get();
}

Property Value

String containing the format's name.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members


Parameters Property (IImGearFormat)

ImageGear22.Core Assembly > ImageGear.Formats Namespace > IImGearFormat Interface : Parameters Property
Gets format's control parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Parameters As ImGearFormatParameters
'Usage

Dim instance As IImGearFormat
Dim value As ImGearFormatParameters

value = instance.Parameters
ImGearFormatParameters Parameters {get;}
__property ImGearFormatParameters* get_Parameters();
property ImGearFormatParameters^ Parameters {
   ImGearFormatParameters^ get();
}

Property Value

An instance of the class for managing format's control parameters.
Remarks
This property provides access to format's control parameters.
See Also

Reference

IImGearFormat Interface
IImGearFormat Members
ImGearFormatParameters Class


ImageGear.Formats.JPG Namespace
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats.JPG Namespace
This namespace provides enumerations values for JPEG format filter control parameters.
Enumerations
 | Enumeration | Description
Enumeration | ImGearDecimationTypes | This enumeration lists all possible JPEG decimation values.
Enumeration | ImGearJpegSaveType | Represents JPEG save types.
Enumeration | ImGearQuadComponentColorSpace | This enumeration specifies a mode for setting color space value for quad component JPEG files on load.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.JPG Namespace Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats.JPG Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearDecimationTypes Enumeration

ImageGear22.Core Assembly > ImageGear.Formats.JPG Namespace : ImGearDecimationTypes Enumeration
This enumeration lists all possible JPEG decimation values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDecimationTypes
   Inherits System.Enum
'Usage

Dim instance As ImGearDecimationTypes
public enum ImGearDecimationTypes : System.Enum
__value public enum ImGearDecimationTypes : public System.Enum
public enum class ImGearDecimationTypes : public System.Enum
Members
Member | Value | Description
Decim_1x1_1x1_1x1 | 0 | For each Y sample, one Cb sample and one Cr sample are stored.
Decim_1x2_1x1_1x1 | 2 | For each vertical pair of Y samples, one Cb sample and one Cr sample are stored.
Decim_1x4_1x1_1x1 | 8 | For each four vertical Y samples, one Cb sample and one Cr sample are stored.
Decim_1x4_1x2_1x2 | 10 | For each four vertical Y samples, two vertical Cb samples and two vertical Cr samples are stored.
Decim_2x1_1x1_1x1 | 1 | For each horizontal pair of Y samples, one Cb sample and one Cr sample are stored.
Decim_2x2_1x1_1x1 | 3 | For each four (two horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_2x2_2x1_2x1 | 4 | For each four (two horizontal by two vertical) Y samples, two horizontal Cb samples and two horizontal Cr samples are stored.
Decim_2x4_1x1_1x1 | 6 | For each eight (two horizontal by four vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_4x1_1x1_1x1 | 7 | For each four horizontal Y samples, one Cb sample and one Cr sample are stored.
Decim_4x1_2x1_2x1 | 9 | For each four horizontal Y samples, two horizontal Cb samples and two horizontal Cr samples are stored.
Decim_4x2_1x1_1x1 | 5 | For each eight (four horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_4x4_2x2_2x2 | 11 | For each 16 (four horizontal by four vertical) Y samples, four (two horizontal by two vertical) Cb samples and four (two horizontal by two vertical) Cr samples are stored.
Remarks
The format of these ImageGear decimation constants is: Decim_(H1)x(V1)_(H2)x(V2)_(H3)x(V3),

where Hi, Vi = horizontal and vertical decimation values for the i-channel.

The following is a simple example of decimation. For a more detailed definition, please see the JPEG Specification.

A decimation setting of Decim_4x2_1x1_1x1 would yield the following results:

As shown, 8 Y components in the source image have yielded one Cb and one Cr component. In general, this setting will reduce the quality of the compression, unless the image has many continuous tone areas.

Maximum quality can be reached using a value of Decim_1x1_1x1_1x1.

Maximum compression ratio can be reached with a value of Decim_4x4_2x2_2x2.

The ImageGear default decimation value is: Decim_2x2_1x1_1x1.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPG.ImGearDecimationTypes

See Also

Reference

ImageGear.Formats.JPG Namespace
ImageGear.Formats.JPG Namespace


%%PageItemTitle%%

ImGearJpegSaveType Enumeration

ImageGear22.Core Assembly > ImageGear.Formats.JPG Namespace : ImGearJpegSaveType Enumeration
Represents JPEG save types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJpegSaveType
   Inherits System.Enum
'Usage

Dim instance As ImGearJpegSaveType
public enum ImGearJpegSaveType : System.Enum
__value public enum ImGearJpegSaveType : public System.Enum
public enum class ImGearJpegSaveType : public System.Enum
Members
Member | Value | Description
Lossless | 1 | JPEG lossless format.
Lossy | 0 | JPEG lossy format.
Progressive | 2 | JPEG progressive format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPG.ImGearJpegSaveType

See Also

Reference

ImageGear.Formats.JPG Namespace


%%PageItemTitle%%

ImGearQuadComponentColorSpace Enumeration

ImageGear22.Core Assembly > ImageGear.Formats.JPG Namespace : ImGearQuadComponentColorSpace Enumeration
This enumeration specifies a mode for setting color space value for quad component JPEG files on load.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearQuadComponentColorSpace
   Inherits System.Enum
'Usage

Dim instance As ImGearQuadComponentColorSpace
public enum ImGearQuadComponentColorSpace : System.Enum
__value public enum ImGearQuadComponentColorSpace : public System.Enum
public enum class ImGearQuadComponentColorSpace : public System.Enum
Members
Member | Value | Description
Auto | 0 | Forces ImageGear to autodetect the color space.
Cmyk | 2 | Forces to load quad component JPEG directly as CMYK.
Rgba | 1 | Forces to load quad component JPEG directly as RGBA.
Ycck | 3 | Forces to load quad component JPEG as CMYK by converting the image pixels from YCCK colorspace.
Remarks
This enumeration is used for JFIF QuadComponentColorSpace control parameter to either let the ImageGear to detect the color space or let the user set the color space explicitly.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPG.ImGearQuadComponentColorSpace

See Also

Reference

ImageGear.Formats.JPG Namespace


ImageGear.Formats.TIF Namespace (ImageGear22.Core)
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats.TIF Namespace

This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.

Enumerations
 | Enumeration | Description
Enumeration | ImGearPhotoInterpretations | This enumeration specifies all the supported types of TIFF photometric interpretations.
Enumeration | ImGearStripModes | This enumeration specifies all the supported strip and tile modes for TIFF image writing.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.TIF Namespace (ImageGear22.Core) Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Formats.TIF Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearPhotoInterpretations Enumeration

ImageGear22.Core Assembly > ImageGear.Formats.TIF Namespace : ImGearPhotoInterpretations Enumeration
This enumeration specifies all the supported types of TIFF photometric interpretations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPhotoInterpretations
   Inherits System.Enum
'Usage

Dim instance As ImGearPhotoInterpretations
public enum ImGearPhotoInterpretations : System.Enum
__value public enum ImGearPhotoInterpretations : public System.Enum
public enum class ImGearPhotoInterpretations : public System.Enum
Members
Member | Value | Description
BLACKZERO | 1 | Black is zero. For bilevel and grayscale images: 0 is imaged as black. 2**BitsPerSample-1 is imaged as white.
CFA | -32733 | Color Filter Array photometric interpretation.
CIELAB | 8 | CIE Lab (using TIFF format for storing a and b values).
CMYK | 5 | CMYK photometric interpretation.
ICC_CIELAB | 9 | CIE Lab (using ICC format for storing a and b values).
PALETTE | 3 | Palette color photometric interpretation.
RGB | 2 | RGB photometric interpretation.
TRANSPARENCY | 4 | Transparency photometric interpretation.
WHITEZERO | 0 | White is zero. For bilevel and grayscale images: 0 is imaged as white. 2**BitsPerSample-1 is imaged as black.
YCBCR | 6 | YCbCr photometric interpretation.
YUV | -30644 | YUV photometric interpretation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearPhotoInterpretations

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearStripModes Enumeration

ImageGear22.Core Assembly > ImageGear.Formats.TIF Namespace : ImGearStripModes Enumeration
This enumeration specifies all the supported strip and tile modes for TIFF image writing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearStripModes
   Inherits System.Enum
'Usage

Dim instance As ImGearStripModes
public enum ImGearStripModes : System.Enum
__value public enum ImGearStripModes : public System.Enum
public enum class ImGearStripModes : public System.Enum
Members
Member | Value | Description
FIXED_BUFFER | 0x00000001 | Save image using strips not exceeding specified size.
FIXED_COUNT | 0x00000000 | Save image using specified number of strips.
TILED_FIXED_COUNT | 0x00000011 | Save image using specified number of tiles vertically and horizontally.
TILED_FIXED_SIZE | 0x00000010 | Save image using tiles of specified size.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearStripModes

See Also

Reference

ImageGear.Formats.TIF Namespace
ImageGear.Formats.TIF Namespace


ImageGear.Processing Namespace (ImageGear22.Core)
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Processing Namespace
This namespace represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as remove red eye, perspective, solarize, warp, wave, etc.
Classes
 | Class | Description
Class | IGDoubleMatrix | Represents class to matrix store and matrix operations.
Class | ImGearAverageInterpolationOptions | Represents options for average interpolation.
Class | ImGearBayerReductionOptions | Defines reduction options for Bayer reduction.
Class | ImGearBicubicInterpolationOptions | Represents options for bicubic interpolation.
Class | ImGearBilinearInterpolationOptions | Represents options for bilinear interpolation.
Class | ImGearBitonalReductionOptions | Defines reduction options for bitonal reduction.
Class | ImGearCameraRawProcessing | Contains methods for color reconstruction of digital camera RAW images.
Class | ImGearColorInterpolationOptions | Represents color interpolation options.
Class | ImGearContrastOptions | Represents contrast options.
Class | ImGearDiffuseReductionOptions | Defines reduction options for diffuse reduction.
Class | ImGearGrayScaleInterpolationOptions | Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions class.
Class | ImGearHalftoneReductionOptions | Defines reduction options for halftone reduction.
Class | ImGearInterpolationOptions | Base class for all interpolation options passed to ImGearProcessing.Resize and ImGearProcessing.CreateThumbnail methods.
Class | ImGearMedianCutReductionOptions | Defines reduction options for median cut reduction.
Class | ImGearNearestNeighborInterpolationOptions | Represents options for nearest neighbor interpolation.
Class | ImGearNoneInterpolationOptions | Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.
Class | ImGearOctreeReductionOptions | Defines options for octree reduction.
Class | ImGearPixelProcessorRedEyeRGB | Processes the RGB pixel using red-eye removal algorithm.
Class | ImGearPopularityReductionOptions | Defines options for popularity reduction.
Class | ImGearPreserveBlackInterpolationOptions | Represents options for PreserveWhite interpolation.
Class | ImGearPreserveWhiteInterpolationOptions | Represents options for PreserveWhite interpolation.
Class | ImGearProcessing | Provides image processing methods that can be applied to both Raster and Vector images.
Class | ImGearProcessingVerifier | Contains static methods that check whether particular ImGearProcessing operations are applicable to the page.
Class | ImGearRasterProcessing | Contains IG raster processing methods.
Class | ImGearRasterProcessingVerifier | Contains static methods that check whether particular ImGearRasterProcessing operations are applicable to the page.
Class | ImGearReductionOptions | Specifies options for performing color reduction using the ImGearRasterProcessing.Reduce method.
Class | ImGearScaleReductionOptions | Defines reduction options for scale reduction.
Class | ImGearWhiteBalance | Represents white balance as a pair of color temperature and tint.
Interfaces
 | Interface | Description
Interface | IImGearPixelProcessor | An implementation of this interface is passed to ProcessArea method.
Structures
 | Structure | Description
Structure | ImGearChannelRef | Represents pixel channel in ImageGear.Core.ImGearPage.
Structure | ImGearChannelStatistics | Stores statistics for an image channel.
Enumerations
 | Enumeration | Description
Enumeration | ImGearBitonalReductionModes | Specifies modes for the bitonal color reduction method.
Enumeration | ImGearBrushType | Specifies brush types for Pointillist effect.
Enumeration | ImGearCFAColor | Specifies the available colors for Color Filter Array encoded images.
Enumeration | ImGearChannelGroups | Specifies groups of DIB channels.
Enumeration | ImGearContrastModes | Specifies contrast processing modes.
Enumeration | ImGearConvolutionResults | Specifies types of convolution result.
Enumeration | ImGearDirection | Defines a direction of a shadow effect (location of the light source).
Enumeration | ImGearEdgeDetectionMethods | Defines the edge detection methods supported by ImageGear.
Enumeration | ImGearEdgeMapMethods | Specifies types of edge map operation.
Enumeration | ImGearHalftoneReductionModes | Specifies mode of halftone color reduction method.
Enumeration | ImGearIlluminant | Lists standard illuminants.
Enumeration | ImGearInterpolations | Specifies type of interpolation method.
Enumeration | ImGearLensFlareType | Specifies types of lens flare effects.
Enumeration | ImGearMergeModes | Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.
Enumeration | ImGearMosaicType | Defines a type of Mosaic effect.
Enumeration | ImGearNightVisionPresets | Specifies Night Vision effects supported by ImageGear.
Enumeration | ImGearPixelateCellType | Defines cell types for Pixelate operation.
Enumeration | ImGearPixelateFillMethod | Defines fill methods for Pixelate operation.
Enumeration | ImGearReductionMethods | Specifies ImageGear color reduction methods.
Enumeration | ImGearRipplePattern | Specifies predefined patterns for the Ripple effect.
Enumeration | ImGearRotationModes | Specifies ImageGear rotation mode.
Enumeration | ImGearShearFillStyle | Specifies fill styles for the Shear effect.
Enumeration | ImGearWhiteBalancePreset | Lists constants for preset white balance values.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Processing Namespace (ImageGear22.Core) Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Processing Namespace
Inheritance Hierarchy
System.Object
ImageGear.Processing.IGDoubleMatrix
ImageGear.Processing.ImGearBayerReductionOptions
ImageGear.Processing.ImGearBitonalReductionOptions
ImageGear.Processing.ImGearCameraRawProcessing
ImageGear.Processing.ImGearContrastOptions
ImageGear.Processing.ImGearDiffuseReductionOptions
ImageGear.Processing.ImGearHalftoneReductionOptions
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearAverageInterpolationOptions
ImageGear.Processing.ImGearBicubicInterpolationOptions
ImageGear.Processing.ImGearBilinearInterpolationOptions
ImageGear.Processing.ImGearColorInterpolationOptions
ImageGear.Processing.ImGearGrayScaleInterpolationOptions
ImageGear.Processing.ImGearNearestNeighborInterpolationOptions
ImageGear.Processing.ImGearNoneInterpolationOptions
ImageGear.Processing.ImGearPreserveBlackInterpolationOptions
ImageGear.Processing.ImGearPreserveWhiteInterpolationOptions
ImageGear.Processing.ImGearMedianCutReductionOptions
ImageGear.Processing.ImGearOctreeReductionOptions
ImageGear.Processing.ImGearPixelProcessorRedEyeRGB
ImageGear.Processing.ImGearPopularityReductionOptions
ImageGear.Processing.ImGearProcessing
ImageGear.Processing.ImGearProcessingVerifier
ImageGear.Processing.ImGearRasterProcessing
ImageGear.Processing.ImGearRasterProcessingVerifier
ImageGear.Processing.ImGearReductionOptions
ImageGear.Processing.ImGearScaleReductionOptions
ImageGear.Processing.ImGearWhiteBalance
System.ValueType
ImageGear.Processing.ImGearChannelRef
ImageGear.Processing.ImGearChannelStatistics
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

IGDoubleMatrix Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IGDoubleMatrix Class
Represents class to matrix store and matrix operations.
Object Model
IGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix ClassIGDoubleMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
public class IGDoubleMatrix
public __gc class IGDoubleMatrix
public ref class IGDoubleMatrix
Inheritance Hierarchy

System.Object
ImageGear.Processing.IGDoubleMatrix

See Also

Reference

IGDoubleMatrix Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

IGDoubleMatrix Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IGDoubleMatrix Class

The following tables list the members exposed by IGDoubleMatrix.

Public Constructors
 | Name | Description
Public Constructor | IGDoubleMatrix Constructor | Overloaded. Initializes a new instance of the IGDoubleMatrix class.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clone IGDoubleMatrix object.
static (Shared in Visual Basic) | Create | Overloaded. Returns a new IGDoubleMatrix class object.
static (Shared in Visual Basic) | CreateDefault | Returns a new IGDoubleMatrix class object.
Public Method | CreateIdentity | Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.
Public Method | GetColCount | Gets the count of columns in the matrix.
Public Method | GetElem | Gets matrix element according to matrix column and row coordinate.
Public Method | GetRowCount | Gets matrix rows count.
Public Method | GetValues | Get matrix element as double values two dimentioned array.
Public Method | Inverse | Inverse IGDoubleMatrix square matrix.
Public Method | LeftMultiply | Multiplies vector by IGDoubleMatrix matrix (vector * matrix).
Public Method | MultiplyByVector | Overloaded. Multiplies matrix by vector.
Public Method | MultiplyByVectorWithCast | Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.
Public Method | PseudoInverse | Returns pseudo inverse IGDoubleMatrix matrix object.
Public Method | Scale | Scale matrix values (matrixA * scaleValue).
Public Method | SetElem | Sets matrix element value.
Public Method | Transpose | Transpose the matrix.
Top
Public Operators
public Operator Addition | Adds one IGDoubleMatrix matrix to another (matrixA + matrixB).
public Operator Multiplication | Overloaded. Returns copy of IGDoubleMatrix matrix scaled to value.
Top
See Also

Reference

IGDoubleMatrix Class
ImageGear.Processing Namespace


%%PageItemTitle%%

IGDoubleMatrix Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : IGDoubleMatrix Constructor
Initializes a new instance of the IGDoubleMatrix class.
Overload List
Overload | Description
IGDoubleMatrix Constructor(Double[,]) | Initializes a new instance of the IGDoubleMatrix class.
IGDoubleMatrix Constructor(Int32,Int32) | Initializes a new instance of the IGDoubleMatrix class.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


%%PageItemTitle%%

IGDoubleMatrix Constructor(Double[,])

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > IGDoubleMatrix Constructor : IGDoubleMatrix Constructor(Double[,])
Two dimentions array of doubles.
Initializes a new instance of the IGDoubleMatrix class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal values(,) As Double _
)
'Usage

Dim values() As Double

Dim instance As New IGDoubleMatrix(values)
public IGDoubleMatrix(
   double[,] values
)
public: IGDoubleMatrix(
   double[,]* values
)
public:
IGDoubleMatrix(
   array<double>^ values
)

Parameters

values
Two dimentions array of doubles.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


%%PageItemTitle%%

IGDoubleMatrix Constructor(Int32,Int32)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > IGDoubleMatrix Constructor : IGDoubleMatrix Constructor(Int32,Int32)
Matrix rows count.
Matrix columns count.
Initializes a new instance of the IGDoubleMatrix class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rowCount As Integer, _
   ByVal columnCount As Integer _
)
'Usage

Dim rowCount As Integer
Dim columnCount As Integer

Dim instance As New IGDoubleMatrix(rowCount, columnCount)
public IGDoubleMatrix(
   int rowCount,
   int columnCount
)
public: IGDoubleMatrix(
   int rowCount,
   int columnCount
)
public:
IGDoubleMatrix(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


%%PageItemTitle%% $$Methods$$

IGDoubleMatrix Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IGDoubleMatrix Class

For a list of all members of this type, see IGDoubleMatrix members.

Public Methods
 | Name | Description
Public Method | Clone | Clone IGDoubleMatrix object.
static (Shared in Visual Basic) | Create | Overloaded. Returns a new IGDoubleMatrix class object.
static (Shared in Visual Basic) | CreateDefault | Returns a new IGDoubleMatrix class object.
Public Method | CreateIdentity | Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.
Public Method | GetColCount | Gets the count of columns in the matrix.
Public Method | GetElem | Gets matrix element according to matrix column and row coordinate.
Public Method | GetRowCount | Gets matrix rows count.
Public Method | GetValues | Get matrix element as double values two dimentioned array.
Public Method | Inverse | Inverse IGDoubleMatrix square matrix.
Public Method | LeftMultiply | Multiplies vector by IGDoubleMatrix matrix (vector * matrix).
Public Method | MultiplyByVector | Overloaded. Multiplies matrix by vector.
Public Method | MultiplyByVectorWithCast | Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.
Public Method | PseudoInverse | Returns pseudo inverse IGDoubleMatrix matrix object.
Public Method | Scale | Scale matrix values (matrixA * scaleValue).
Public Method | SetElem | Sets matrix element value.
Public Method | Transpose | Transpose the matrix.
Top
See Also

Reference

IGDoubleMatrix Class
ImageGear.Processing Namespace


Clone Method (IGDoubleMatrix)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Clone Method
Clone IGDoubleMatrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
Dim value As IGDoubleMatrix

value = instance.Clone()
public IGDoubleMatrix Clone()
public: IGDoubleMatrix* Clone();
public:
IGDoubleMatrix^ Clone();

Return Value

IGDoubleMatrix object value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Create Method (IGDoubleMatrix)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Create Method
Returns a new IGDoubleMatrix class object.
Overload List
Overload | Description
Create(Int32,Int32) | Returns a new IGDoubleMatrix class object.
Create(Double[,]) | Returns a new IGDoubleMatrix class object.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Create(Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > Create Method : Create(Int32,Int32) Method
Matrix rows count.
Matrix columns count.
Returns a new IGDoubleMatrix class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal rowCount As Integer, _
   ByVal columnCount As Integer _
) As IGDoubleMatrix
'Usage

Dim rowCount As Integer
Dim columnCount As Integer
Dim value As IGDoubleMatrix

value = IGDoubleMatrix.Create(rowCount, columnCount)
public static IGDoubleMatrix Create(
   int rowCount,
   int columnCount
)
public: static IGDoubleMatrix* Create(
   int rowCount,
   int columnCount
)
public:
static IGDoubleMatrix^ Create(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.

Return Value

IGDoubleMatrix class object with zero initialized elements values.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


Create(Double[,]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > Create Method : Create(Double[,]) Method
Double values array.
Returns a new IGDoubleMatrix class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal values(,) As Double _
) As IGDoubleMatrix
'Usage

Dim values() As Double
Dim value As IGDoubleMatrix

value = IGDoubleMatrix.Create(values)
public static IGDoubleMatrix Create(
   double[,] values
)
public: static IGDoubleMatrix* Create(
   double[,]* values
)
public:
static IGDoubleMatrix^ Create(
   array<double>^ values
)

Parameters

values
Double values array.

Return Value

IGDoubleMatrix class object with zero initialized elements values.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


CreateDefault Method (IGDoubleMatrix)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : CreateDefault Method
Matrix rows count.
Matrix columns count.
Returns a new IGDoubleMatrix class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateDefault( _
   ByVal rowCount As Integer, _
   ByVal columnCount As Integer _
) As IGDoubleMatrix
'Usage

Dim rowCount As Integer
Dim columnCount As Integer
Dim value As IGDoubleMatrix

value = IGDoubleMatrix.CreateDefault(rowCount, columnCount)
public static IGDoubleMatrix CreateDefault(
   int rowCount,
   int columnCount
)
public: static IGDoubleMatrix* CreateDefault(
   int rowCount,
   int columnCount
)
public:
static IGDoubleMatrix^ CreateDefault(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.

Return Value

IGDoubleMatrix class object with zero initialized elements values.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


CreateIdentity Method (IGDoubleMatrix)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : CreateIdentity Method
Matrix row count.
Matrix column count.
Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateIdentity( _
   ByVal rowCount As Integer, _
   ByVal columnCount As Integer _
) As IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
Dim rowCount As Integer
Dim columnCount As Integer
Dim value As IGDoubleMatrix

value = instance.CreateIdentity(rowCount, columnCount)
public IGDoubleMatrix CreateIdentity(
   int rowCount,
   int columnCount
)
public: IGDoubleMatrix* CreateIdentity(
   int rowCount,
   int columnCount
)
public:
IGDoubleMatrix^ CreateIdentity(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix row count.
columnCount
Matrix column count.

Return Value

IGDoubleMatrix class object.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


GetColCount Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : GetColCount Method
Gets the count of columns in the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColCount() As Integer
'Usage

Dim instance As IGDoubleMatrix
Dim value As Integer

value = instance.GetColCount()
public int GetColCount()
public: int GetColCount();
public:
int GetColCount();

Return Value

Integer value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


GetElem Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : GetElem Method
Row coordinate of the matrix element.
Column coordinate of the matrix element.
Gets matrix element according to matrix column and row coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetElem( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As Double
'Usage

Dim instance As IGDoubleMatrix
Dim row As Integer
Dim column As Integer
Dim value As Double

value = instance.GetElem(row, column)
public double GetElem(
   int row,
   int column
)
public: double GetElem(
   int row,
   int column
)
public:
double GetElem(
   int row,
   int column
)

Parameters

row
Row coordinate of the matrix element.
column
Column coordinate of the matrix element.

Return Value

Double value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


GetRowCount Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : GetRowCount Method
Gets matrix rows count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRowCount() As Integer
'Usage

Dim instance As IGDoubleMatrix
Dim value As Integer

value = instance.GetRowCount()
public int GetRowCount()
public: int GetRowCount();
public:
int GetRowCount();

Return Value

Integer value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


GetValues Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : GetValues Method
Get matrix element as double values two dimentioned array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValues() As Double(,)
'Usage

Dim instance As IGDoubleMatrix
Dim value() As Double

value = instance.GetValues()
public double[,] GetValues()
public: double[,]* GetValues();
public:
array<double,>^ GetValues();

Return Value

Two dimention array of doubles.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Inverse Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Inverse Method
Inverse IGDoubleMatrix square matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Inverse() As IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
Dim value As IGDoubleMatrix

value = instance.Inverse()
public IGDoubleMatrix Inverse()
public: IGDoubleMatrix* Inverse();
public:
IGDoubleMatrix^ Inverse();

Return Value

IGDoubleMatrix result matrix.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


LeftMultiply Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : LeftMultiply Method
Vector value.
Multiplies vector by IGDoubleMatrix matrix (vector * matrix).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function LeftMultiply( _
   ByVal vector() As Double _
) As Double()
'Usage

Dim instance As IGDoubleMatrix
Dim vector() As Double
Dim value() As Double

value = instance.LeftMultiply(vector)
public double[] LeftMultiply(
   double[] vector
)
public: double[]* LeftMultiply(
   double[]* vector
)
public:
array<double>^ LeftMultiply(
   array<double>^ vector
)

Parameters

vector
Vector value.

Return Value

Result vector value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


MultiplyByVector Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : MultiplyByVector Method
Multiplies matrix by vector.
Overload List
Overload | Description
MultiplyByVector(UInt32[],UInt32[]) | Multiplies matrix by vector.
MultiplyByVector(UInt16[],Int32) | Multiplies matrix by vector found in vectorContent array at the specified offset and stores result in the same place.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


MultiplyByVector(UInt32[],UInt32[]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > MultiplyByVector Method : MultiplyByVector(UInt32[],UInt32[]) Method
Vector value.
Result vector value.
Multiplies matrix by vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MultiplyByVector( _
   ByVal vectorToMultiply() As UInteger, _
   ByVal resultVector() As UInteger _
)
'Usage

Dim instance As IGDoubleMatrix
Dim vectorToMultiply() As UInteger
Dim resultVector() As UInteger

instance.MultiplyByVector(vectorToMultiply, resultVector)
public void MultiplyByVector(
   uint[] vectorToMultiply,
   uint[] resultVector
)
public: void MultiplyByVector(
   uint[]* vectorToMultiply,
   uint[]* resultVector
)
public:
void MultiplyByVector(
   array<uint>^ vectorToMultiply,
   array<uint>^ resultVector
)

Parameters

vectorToMultiply
Vector value.
resultVector
Result vector value.
Remarks
Result vector should has length same as matrix row count.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


MultiplyByVector(UInt16[],Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > MultiplyByVector Method : MultiplyByVector(UInt16[],Int32) Method
Array containing vector coordinates.
Offset to vector to multiply the matrix with.
Multiplies matrix by vector found in vectorContent array at the specified offset and stores result in the same place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub MultiplyByVector( _
   ByVal vectorContent() As UShort, _
   ByVal vectorOffset As Integer _
)
'Usage

Dim instance As IGDoubleMatrix
Dim vectorContent() As UShort
Dim vectorOffset As Integer

instance.MultiplyByVector(vectorContent, vectorOffset)
public void MultiplyByVector(
   ushort[] vectorContent,
   int vectorOffset
)
public: void MultiplyByVector(
   ushort[]* vectorContent,
   int vectorOffset
)
public:
void MultiplyByVector(
   array<ushort>^ vectorContent,
   int vectorOffset
)

Parameters

vectorContent
Array containing vector coordinates.
vectorOffset
Offset to vector to multiply the matrix with.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


MultiplyByVectorWithCast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : MultiplyByVectorWithCast Method
Vector value.
Start offset to vectorToMultiply vector.
Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MultiplyByVectorWithCast( _
   ByVal vectorContent() As Short, _
   ByVal vectorOffset As Integer _
)
'Usage

Dim instance As IGDoubleMatrix
Dim vectorContent() As Short
Dim vectorOffset As Integer

instance.MultiplyByVectorWithCast(vectorContent, vectorOffset)
public void MultiplyByVectorWithCast(
   short[] vectorContent,
   int vectorOffset
)
public: void MultiplyByVectorWithCast(
   short[]* vectorContent,
   int vectorOffset
)
public:
void MultiplyByVectorWithCast(
   array<short>^ vectorContent,
   int vectorOffset
)

Parameters

vectorContent
Vector value.
vectorOffset
Start offset to vectorToMultiply vector.
Remarks
Result vector values are set to 65535 if operation result exceed 65535.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


PseudoInverse Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : PseudoInverse Method
Returns pseudo inverse IGDoubleMatrix matrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function PseudoInverse() As IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
Dim value As IGDoubleMatrix

value = instance.PseudoInverse()
public IGDoubleMatrix PseudoInverse()
public: IGDoubleMatrix* PseudoInverse();
public:
IGDoubleMatrix^ PseudoInverse();

Return Value

Operation makes: Ax = Inverse(At*A)*At Where A is the matrix and At is transpose of A.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Scale Method (IGDoubleMatrix)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Scale Method
Double value to scale each matrix value.
Scale matrix values (matrixA * scaleValue).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal value As Double _
)
'Usage

Dim instance As IGDoubleMatrix
Dim value As Double

instance.Scale(value)
public void Scale(
   double value
)
public: void Scale(
   double value
)
public:
void Scale(
   double value
)

Parameters

value
Double value to scale each matrix value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


SetElem Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : SetElem Method
Row coordinate of the matrix element to set.
Column coordinate of the matrix element to set.
Double value.
Sets matrix element value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetElem( _
   ByVal row As Integer, _
   ByVal column As Integer, _
   ByVal value As Double _
)
'Usage

Dim instance As IGDoubleMatrix
Dim row As Integer
Dim column As Integer
Dim value As Double

instance.SetElem(row, column, value)
public void SetElem(
   int row,
   int column,
   double value
)
public: void SetElem(
   int row,
   int column,
   double value
)
public:
void SetElem(
   int row,
   int column,
   double value
)

Parameters

row
Row coordinate of the matrix element to set.
column
Column coordinate of the matrix element to set.
value
Double value.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Transpose Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Transpose Method
Transpose the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Transpose() As IGDoubleMatrix
'Usage

Dim instance As IGDoubleMatrix
Dim value As IGDoubleMatrix

value = instance.Transpose()
public IGDoubleMatrix Transpose()
public: IGDoubleMatrix* Transpose();
public:
IGDoubleMatrix^ Transpose();

Return Value

IGDoubleMatrix with transposed values.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Addition Operator

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Addition Operator
IGDoubleMatrix matrix 1.
IGDoubleMatrix matrix 2.
Adds one IGDoubleMatrix matrix to another (matrixA + matrixB).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator +( _
   ByVal matrix1 As IGDoubleMatrix, _
   ByVal matrix2 As IGDoubleMatrix _
) As IGDoubleMatrix
'Usage

public IGDoubleMatrix operator +(
   IGDoubleMatrix matrix1,
   IGDoubleMatrix matrix2
)
public: IGDoubleMatrix* op_Addition(
   IGDoubleMatrix* matrix1,
   IGDoubleMatrix* matrix2
)
public:
IGDoubleMatrix^ operator +(
   IGDoubleMatrix^ matrix1,
   IGDoubleMatrix^ matrix2
)

Parameters

matrix1
IGDoubleMatrix matrix 1.
matrix2
IGDoubleMatrix matrix 2.

Return Value

IGDoubleMatrix result matrix.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Multiplication Operator

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class : Multiplication Operator
Returns copy of IGDoubleMatrix matrix scaled to value.
Overload List
Overload | Description
Multiplication(IGDoubleMatrix,Double) | Returns copy of IGDoubleMatrix matrix scaled to value.
Multiplication(IGDoubleMatrix,Double[]) | Multiplies IGDoubleMatrix matrix by vector (matrix * vector).
Multiplication(IGDoubleMatrix,IGDoubleMatrix) | Multiplies two IGDoubleMatrix matrix (matrixA * matrixB).
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members


Multiplication(IGDoubleMatrix,Double) Operator

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > Multiplication Operator : Multiplication(IGDoubleMatrix,Double) Operator
IGDoubleMatrix matrix value.
Scale value.
Returns copy of IGDoubleMatrix matrix scaled to value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator *( _
   ByVal matrix As IGDoubleMatrix, _
   ByVal value As Double _
) As IGDoubleMatrix
'Usage

public IGDoubleMatrix operator *(
   IGDoubleMatrix matrix,
   double value
)
public: IGDoubleMatrix* op_Multiply(
   IGDoubleMatrix* matrix,
   double value
)
public:
IGDoubleMatrix^ operator *(
   IGDoubleMatrix^ matrix,
   double value
)

Parameters

matrix
IGDoubleMatrix matrix value.
value
Scale value.

Return Value

IGDoubleMatrix class object with scaled elements.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


Multiplication(IGDoubleMatrix,Double[]) Operator

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > Multiplication Operator : Multiplication(IGDoubleMatrix,Double[]) Operator
IGDoubleMatrix matrix.
Vector value.
Multiplies IGDoubleMatrix matrix by vector (matrix * vector).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator *( _
   ByVal matrix As IGDoubleMatrix, _
   ByVal vector() As Double _
) As Double()
'Usage

public double[] operator *(
   IGDoubleMatrix matrix,
   double[] vector
)
public: double[]* op_Multiply(
   IGDoubleMatrix* matrix,
   double[]* vector
)
public:
array<double>^ operator *(
   IGDoubleMatrix^ matrix,
   array<double>^ vector
)

Parameters

matrix
IGDoubleMatrix matrix.
vector
Vector value.

Return Value

Result operation vector.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


Multiplication(IGDoubleMatrix,IGDoubleMatrix) Operator

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IGDoubleMatrix Class > Multiplication Operator : Multiplication(IGDoubleMatrix,IGDoubleMatrix) Operator
IGDoubleMatrix matrix 1.
IGDoubleMatrix matrix 2.
Multiplies two IGDoubleMatrix matrix (matrixA * matrixB).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator *( _
   ByVal matrix1 As IGDoubleMatrix, _
   ByVal matrix2 As IGDoubleMatrix _
) As IGDoubleMatrix
'Usage

public IGDoubleMatrix operator *(
   IGDoubleMatrix matrix1,
   IGDoubleMatrix matrix2
)
public: IGDoubleMatrix* op_Multiply(
   IGDoubleMatrix* matrix1,
   IGDoubleMatrix* matrix2
)
public:
IGDoubleMatrix^ operator *(
   IGDoubleMatrix^ matrix1,
   IGDoubleMatrix^ matrix2
)

Parameters

matrix1
IGDoubleMatrix matrix 1.
matrix2
IGDoubleMatrix matrix 2.

Return Value

IGDoubleMatrix result matrix object.
See Also

Reference

IGDoubleMatrix Class
IGDoubleMatrix Members
Overload List


%%PageItemTitle%%

ImGearAverageInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearAverageInterpolationOptions Class
Represents options for average interpolation.
Object Model
ImGearAverageInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAverageInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearAverageInterpolationOptions
public class ImGearAverageInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearAverageInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearAverageInterpolationOptions : public ImGearInterpolationOptions
Remarks
This class has no public fields and methods and is used to identify average interpolation by itself in image processing functions.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearAverageInterpolationOptions

See Also

Reference

ImGearAverageInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearAverageInterpolationOptions Class Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearAverageInterpolationOptions Class

The following tables list the members exposed by ImGearAverageInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearAverageInterpolationOptions Constructor | Initializes a new instance of the ImGearAverageInterpolationOptions class.
Top
See Also

Reference

ImGearAverageInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearAverageInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearAverageInterpolationOptions Class : ImGearAverageInterpolationOptions Constructor
Initializes a new instance of the ImGearAverageInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearAverageInterpolationOptions()
public ImGearAverageInterpolationOptions()
public: ImGearAverageInterpolationOptions();
public:
ImGearAverageInterpolationOptions();
See Also

Reference

ImGearAverageInterpolationOptions Class
ImGearAverageInterpolationOptions Members
ImGearAverageInterpolationOptions Class


%%PageItemTitle%%

ImGearBayerReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBayerReductionOptions Class
Defines reduction options for Bayer reduction.
Object Model
ImGearBayerReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBayerReductionOptions
'Usage

Dim instance As ImGearBayerReductionOptions
public class ImGearBayerReductionOptions
public __gc class ImGearBayerReductionOptions
public ref class ImGearBayerReductionOptions
Remarks
A Bayer dithering algorithm is used to reduce the number of colors (or shades of gray) in the image. Note that setting the output channel depth to 1 will reduce the image to monochrome or black-and-white. Also, the output channel depth must be less than the input channel depth, or an error will result.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearBayerReductionOptions

See Also

Reference

ImGearBayerReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearBayerReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBayerReductionOptions Class

The following tables list the members exposed by ImGearBayerReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearBayerReductionOptions Constructor |
Top
Public Fields
 | Name | Description
Public Field | Palette | Palette to use for the output.
Top
See Also

Reference

ImGearBayerReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearBayerReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBayerReductionOptions Class : ImGearBayerReductionOptions Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBayerReductionOptions()
public ImGearBayerReductionOptions()
public: ImGearBayerReductionOptions();
public:
ImGearBayerReductionOptions();
See Also

Reference

ImGearBayerReductionOptions Class
ImGearBayerReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearBayerReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBayerReductionOptions Class

For a list of all members of this type, see ImGearBayerReductionOptions members.

Public Fields
 | Name | Description
Public Field | Palette | Palette to use for the output.
Top
See Also

Reference

ImGearBayerReductionOptions Class
ImageGear.Processing Namespace


Palette Field (ImGearBayerReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBayerReductionOptions Class : Palette Field
Palette to use for the output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Palette As ImGearRGBQuad()
'Usage

Dim instance As ImGearBayerReductionOptions
Dim value() As ImGearRGBQuad

value = instance.Palette

instance.Palette = value
public ImGearRGBQuad[] Palette
public: ImGearRGBQuad[]* Palette
public:
array<ImGearRGBQuad>^ Palette

Field Value

A 16-color palette or null.
Remarks
This option lets you specify a palette containing the colors to use for the output image. It’s only used when the output channel depth is 4. If no palette is specified, a default palette is used.
See Also

Reference

ImGearBayerReductionOptions Class
ImGearBayerReductionOptions Members
ImGearRGBQuad Structure


%%PageItemTitle%%

ImGearBicubicInterpolationOptions Class
Members Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBicubicInterpolationOptions Class
Represents options for bicubic interpolation.
Object Model
ImGearBicubicInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBicubicInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearBicubicInterpolationOptions
public class ImGearBicubicInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearBicubicInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearBicubicInterpolationOptions : public ImGearInterpolationOptions
Example
  • C#
// Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
int newHeight = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width;
ImGearBicubicInterpolationOptions igBicubicInterpolationOptions = new ImGearBicubicInterpolationOptions();
igBicubicInterpolationOptions.Sharpness = 1.5;
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions);
  • Visual Basic
' Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
Dim newHeight As Integer = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width
Dim igBicubicInterpolationOptions As New ImGearBicubicInterpolationOptions()
igBicubicInterpolationOptions.Sharpness = 1.5
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearBicubicInterpolationOptions

See Also

Reference

ImGearBicubicInterpolationOptions Members
ImageGear.Processing Namespace
ImGearBilinearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearBicubicInterpolationOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBicubicInterpolationOptions Class

The following tables list the members exposed by ImGearBicubicInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearBicubicInterpolationOptions Constructor | Initializes a new instance of the ImGearBicubicInterpolationOptions class.
Top
Public Properties
 | Name | Description
Public Property | Sharpness | Gets or sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top
See Also

Reference

ImGearBicubicInterpolationOptions Class
ImageGear.Processing Namespace
ImGearBilinearInterpolationOptions Class


%%PageItemTitle%%

ImGearBicubicInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBicubicInterpolationOptions Class : ImGearBicubicInterpolationOptions Constructor
Initializes a new instance of the ImGearBicubicInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBicubicInterpolationOptions()
public ImGearBicubicInterpolationOptions()
public: ImGearBicubicInterpolationOptions();
public:
ImGearBicubicInterpolationOptions();
See Also

Reference

ImGearBicubicInterpolationOptions Class
ImGearBicubicInterpolationOptions Members
ImGearBicubicInterpolationOptions Class


%%PageItemTitle%% $$Properties$$

ImGearBicubicInterpolationOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBicubicInterpolationOptions Class

For a list of all members of this type, see ImGearBicubicInterpolationOptions members.

Public Properties
 | Name | Description
Public Property | Sharpness | Gets or sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top
See Also

Reference

ImGearBicubicInterpolationOptions Class
ImageGear.Processing Namespace
ImGearBilinearInterpolationOptions Class


Sharpness Property (ImGearBicubicInterpolationOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBicubicInterpolationOptions Class : Sharpness Property
Gets or sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image.

Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sharpness As Double
'Usage

Dim instance As ImGearBicubicInterpolationOptions
Dim value As Double

instance.Sharpness = value

value = instance.Sharpness
public double Sharpness {get; set;}
public: __property double get_Sharpness();
public: __property void set_Sharpness(
   double value
);
public:
property double Sharpness {
   double get();
   void set (    double value);
}

Property Value

Any positive value.
See Also

Reference

ImGearBicubicInterpolationOptions Class
ImGearBicubicInterpolationOptions Members


%%PageItemTitle%%

ImGearBilinearInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBilinearInterpolationOptions Class
Represents options for bilinear interpolation.
Object Model
ImGearBilinearInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBilinearInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearBilinearInterpolationOptions
public class ImGearBilinearInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearBilinearInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearBilinearInterpolationOptions : public ImGearInterpolationOptions
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearBilinearInterpolationOptions

See Also

Reference

ImGearBilinearInterpolationOptions Members
ImageGear.Processing Namespace
ImGearBicubicInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearBilinearInterpolationOptions Class Members
Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBilinearInterpolationOptions Class

The following tables list the members exposed by ImGearBilinearInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearBilinearInterpolationOptions Constructor | Initializes a new instance of the ImGearBilinearInterpolationOptions class.
Top
Public Properties
 | Name | Description
Public Property | Sharpness | Gets or sets the sharpness of the resized image if the image is being scaled down.
Top
See Also

Reference

ImGearBilinearInterpolationOptions Class
ImageGear.Processing Namespace
ImGearBicubicInterpolationOptions Class


%%PageItemTitle%%

ImGearBilinearInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBilinearInterpolationOptions Class : ImGearBilinearInterpolationOptions Constructor
Initializes a new instance of the ImGearBilinearInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBilinearInterpolationOptions()
public ImGearBilinearInterpolationOptions()
public: ImGearBilinearInterpolationOptions();
public:
ImGearBilinearInterpolationOptions();
See Also

Reference

ImGearBilinearInterpolationOptions Class
ImGearBilinearInterpolationOptions Members
ImGearBilinearInterpolationOptions Class


%%PageItemTitle%% $$Properties$$

ImGearBilinearInterpolationOptions Class Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBilinearInterpolationOptions Class

For a list of all members of this type, see ImGearBilinearInterpolationOptions members.

Public Properties
 | Name | Description
Public Property | Sharpness | Gets or sets the sharpness of the resized image if the image is being scaled down.
Top
See Also

Reference

ImGearBilinearInterpolationOptions Class
ImageGear.Processing Namespace
ImGearBicubicInterpolationOptions Class


Sharpness Property (ImGearBilinearInterpolationOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBilinearInterpolationOptions Class : Sharpness Property
Gets or sets the sharpness of the resized image if the image is being scaled down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sharpness As Double
'Usage

Dim instance As ImGearBilinearInterpolationOptions
Dim value As Double

instance.Sharpness = value

value = instance.Sharpness
public double Sharpness {get; set;}
public: __property double get_Sharpness();
public: __property void set_Sharpness(
   double value
);
public:
property double Sharpness {
   double get();
   void set (    double value);
}

Property Value

Any positive value.
Remarks
This property affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
See Also

Reference

ImGearBilinearInterpolationOptions Class
ImGearBilinearInterpolationOptions Members


%%PageItemTitle%%

ImGearBitonalReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBitonalReductionOptions Class
Defines reduction options for bitonal reduction.
Object Model
ImGearBitonalReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBitonalReductionOptions
'Usage

Dim instance As ImGearBitonalReductionOptions
public class ImGearBitonalReductionOptions
public __gc class ImGearBitonalReductionOptions
public ref class ImGearBitonalReductionOptions
Remarks
Bitonal reduction reduces an image to black and white by comparing each pixel to a threshold value. Several modes, defined in ImGearBitonalReductionModes, are available for determining how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to ImGearBitonalReductionModes.WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These “weights” are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have “no weight.”

Setting Mode to ImGearBitonalReductionModes.GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of ImGearBitonalReductionModes.AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Use the Threshold option to set the threshold value for converting pixels to black or white. If the value, as calculated by one of the above reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white.

Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearBitonalReductionOptions

See Also

Reference

ImGearBitonalReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearBitonalReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBitonalReductionOptions Class

The following tables list the members exposed by ImGearBitonalReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearBitonalReductionOptions Constructor |
Top
Public Fields
 | Name | Description
Public Field | Mode | Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.
Public Field | Threshold | This option sets the threshold value for converting pixels to black or white.
Public Field | Weight1 | This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the Threshold field value.
Public Field | Weight2 | This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the Threshold field value.
Public Field | Weight3 | This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the Threshold field value.
Top
See Also

Reference

ImGearBitonalReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearBitonalReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : ImGearBitonalReductionOptions Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBitonalReductionOptions()
public ImGearBitonalReductionOptions()
public: ImGearBitonalReductionOptions();
public:
ImGearBitonalReductionOptions();
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearBitonalReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBitonalReductionOptions Class

For a list of all members of this type, see ImGearBitonalReductionOptions members.

Public Fields
 | Name | Description
Public Field | Mode | Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.
Public Field | Threshold | This option sets the threshold value for converting pixels to black or white.
Public Field | Weight1 | This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the Threshold field value.
Public Field | Weight2 | This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the Threshold field value.
Public Field | Weight3 | This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the Threshold field value.
Top
See Also

Reference

ImGearBitonalReductionOptions Class
ImageGear.Processing Namespace


Mode Field (ImGearBitonalReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : Mode Field
Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Mode As ImGearBitonalReductionModes
'Usage

Dim instance As ImGearBitonalReductionOptions
Dim value As ImGearBitonalReductionModes

value = instance.Mode

instance.Mode = value
public ImGearBitonalReductionModes Mode
public: ImGearBitonalReductionModes Mode
public:
ImGearBitonalReductionModes Mode

Field Value

Value from ImGearBitonalReductionModes enumeration.
Remarks
If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These “weights” are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have “no weight”.

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);
.
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


Threshold Field (ImGearBitonalReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : Threshold Field
This option sets the threshold value for converting pixels to black or white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearBitonalReductionOptions
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Integer in the range 0-255.
Remarks
If the value of a pixel, as calculated by one of the reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white. So, a smaller value for Threshold will make the output appear more black, while a larger value will make the output appear more white.
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


Weight1 Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : Weight1 Field
This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the Threshold field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Weight1 As Integer
'Usage

Dim instance As ImGearBitonalReductionOptions
Dim value As Integer

value = instance.Weight1

instance.Weight1 = value
public int Weight1
public: int Weight1
public:
int Weight1

Field Value

Integer in the range 0-255.
Remarks
This option is only used if Mode field is set to WEIGHTED.
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


Weight2 Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : Weight2 Field
This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the Threshold field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Weight2 As Integer
'Usage

Dim instance As ImGearBitonalReductionOptions
Dim value As Integer

value = instance.Weight2

instance.Weight2 = value
public int Weight2
public: int Weight2
public:
int Weight2

Field Value

Integer in the range 0-255.
Remarks
This option is only used, if Mode field is set to WEIGHTED.
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


Weight3 Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearBitonalReductionOptions Class : Weight3 Field
This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the Threshold field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Weight3 As Integer
'Usage

Dim instance As ImGearBitonalReductionOptions
Dim value As Integer

value = instance.Weight3

instance.Weight3 = value
public int Weight3
public: int Weight3
public:
int Weight3

Field Value

Integer in the range 0-255.
Remarks
This option is only used if Mode field is set to WEIGHTED.
See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

ImGearCameraRawProcessing Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearCameraRawProcessing Class
Contains methods for color reconstruction of digital camera RAW images.
Object Model
ImGearCameraRawProcessing ClassImGearLUT ClassImGearLUT ClassImGearDoublePoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCameraRawProcessing
'Usage

Dim instance As ImGearCameraRawProcessing
public sealed class ImGearCameraRawProcessing
public __gc __sealed class ImGearCameraRawProcessing
public ref class ImGearCameraRawProcessing sealed
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearCameraRawProcessing

See Also

Reference

ImGearCameraRawProcessing Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearCameraRawProcessing Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearCameraRawProcessing Class

The following tables list the members exposed by ImGearCameraRawProcessing.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BuildSRGBGammaLUT | Builds sRGB Gamma LUT.
static (Shared in Visual Basic) | BuildToneLUT | Builds tone correction LUT.
static (Shared in Visual Basic) | CalculateCameraToRGBMatrix | Overloaded. Calculates the matrix for conversion from camera color space to linear sRGB color space.
static (Shared in Visual Basic) | CalculateWhitePoint | Overloaded. Calculates the white point corresponding to neutral color in camera color space.
Top
See Also

Reference

ImGearCameraRawProcessing Class
ImageGear.Processing Namespace


%%PageItemTitle%% $$Methods$$

ImGearCameraRawProcessing Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearCameraRawProcessing Class

For a list of all members of this type, see ImGearCameraRawProcessing members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BuildSRGBGammaLUT | Builds sRGB Gamma LUT.
static (Shared in Visual Basic) | BuildToneLUT | Builds tone correction LUT.
static (Shared in Visual Basic) | CalculateCameraToRGBMatrix | Overloaded. Calculates the matrix for conversion from camera color space to linear sRGB color space.
static (Shared in Visual Basic) | CalculateWhitePoint | Overloaded. Calculates the white point corresponding to neutral color in camera color space.
Top
See Also

Reference

ImGearCameraRawProcessing Class
ImageGear.Processing Namespace


BuildSRGBGammaLUT Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class : BuildSRGBGammaLUT Method
Bit depth of the LUT.
Builds sRGB Gamma LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function BuildSRGBGammaLUT( _
   ByVal channelDepth As Integer _
) As ImGearLUT
'Usage

Dim channelDepth As Integer
Dim value As ImGearLUT

value = ImGearCameraRawProcessing.BuildSRGBGammaLUT(channelDepth)
public static ImGearLUT BuildSRGBGammaLUT(
   int channelDepth
)
public: static ImGearLUT* BuildSRGBGammaLUT(
   int channelDepth
)
public:
static ImGearLUT^ BuildSRGBGammaLUT(
   int channelDepth
)

Parameters

channelDepth
Bit depth of the LUT.

Return Value

ImageGear.Core.ImGearLUT class.
See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members
ImGearLUT Class


BuildToneLUT Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class : BuildToneLUT Method
Builds tone correction LUT.
Overload List
Overload | Description
BuildToneLUT | Builds tone correction LUT.
See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members


BuildToneLUT(Int32,Double,Double) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class : BuildToneLUT(Int32,Double,Double) Method
Bit depth of the LUT.
Amount by which to move the black point.
Exposure compensation, in f/stops.
Builds tone correction LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function BuildToneLUT( _
   ByVal channelDepth As Integer, _
   ByVal shadows As Double, _
   ByVal exposure As Double _
) As ImGearLUT
'Usage

Dim channelDepth As Integer
Dim shadows As Double
Dim exposure As Double
Dim value As ImGearLUT

value = ImGearCameraRawProcessing.BuildToneLUT(channelDepth, shadows, exposure)
public static ImGearLUT BuildToneLUT(
   int channelDepth,
   double shadows,
   double exposure
)
public: static ImGearLUT* BuildToneLUT(
   int channelDepth,
   double shadows,
   double exposure
)
public:
static ImGearLUT^ BuildToneLUT(
   int channelDepth,
   double shadows,
   double exposure
)

Parameters

channelDepth
Bit depth of the LUT.
shadows
Amount by which to move the black point.
exposure
Exposure compensation, in f/stops.

Return Value

ImageGear.Core.ImGearLUT object value.
Remarks
The LUT moves image's black point by 1/1000 * shadows, and adjusts the white point, which gives similar results to modifying the camera exposure.
See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members


CalculateCameraToRGBMatrix Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class : CalculateCameraToRGBMatrix Method
Calculates the matrix for conversion from camera color space to linear sRGB color space.
Overload List
Overload | Description
CalculateCameraToRGBMatrix(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,ImGearDoublePoint) | Calculates the matrix for conversion from camera color space to linear sRGB color space.
CalculateCameraToRGBMatrix(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,ImGearDoublePoint) | Calculates the matrix for conversion from camera color space to linear sRGB color space.
See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members


CalculateCameraToRGBMatrix(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,ImGearDoublePoint) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class > CalculateCameraToRGBMatrix Method : CalculateCameraToRGBMatrix(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,ImGearDoublePoint) Method
XYZ to camera colorspace conversion matrix under Illuminant 1.
Illuminant 1 value.
XYZ to camera colorspace conversion matrix under Illuminant 2.
Illuminant 2 value.
XY coordinates of camera white point.
Calculates the matrix for conversion from camera color space to linear sRGB color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CalculateCameraToRGBMatrix( _
   ByVal colorMatrix1(,) As Double, _
   ByVal illuminant1 As ImGearIlluminant, _
   ByVal colorMatrix2(,) As Double, _
   ByVal illuminant2 As ImGearIlluminant, _
   ByVal whitePoint As ImGearDoublePoint _
) As Double(,)
'Usage

Dim colorMatrix1() As Double
Dim illuminant1 As ImGearIlluminant
Dim colorMatrix2() As Double
Dim illuminant2 As ImGearIlluminant
Dim whitePoint As ImGearDoublePoint
Dim value() As Double

value = ImGearCameraRawProcessing.CalculateCameraToRGBMatrix(colorMatrix1, illuminant1, colorMatrix2, illuminant2, whitePoint)
public static double[,] CalculateCameraToRGBMatrix(
   double[,] colorMatrix1,
   ImGearIlluminant illuminant1,
   double[,] colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)
public: static double[,]* CalculateCameraToRGBMatrix(
   double[,]* colorMatrix1,
   ImGearIlluminant illuminant1,
   double[,]* colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)
public:
static array<double,>^ CalculateCameraToRGBMatrix(
   array<double>^ colorMatrix1,
   ImGearIlluminant illuminant1,
   array<double>^ colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)

Parameters

colorMatrix1
XYZ to camera colorspace conversion matrix under Illuminant 1.
illuminant1
Illuminant 1 value.
colorMatrix2
XYZ to camera colorspace conversion matrix under Illuminant 2.
illuminant2
Illuminant 2 value.
whitePoint
XY coordinates of camera white point.

Return Value

Double array.
Remarks
Calculates the matrix for conversion from camera color space to linear sRGB color space, based on two known color matrices corresponding to different light conditions, and a white point. By "linear sRGB color space" we assume a linear (Gamma = 1.0) RGB color space that uses sRGB primaries and reference white. This color space can be converted to sRGB by applying sRGB gamma correction function.

If only one color matrix is known, pass null to colorMatrix2.

Dimensions of colorMatrix1 and colorMatrix2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4). Result matrix dimensions are (3, n).

See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members
Overload List
ImGearIlluminant Enumeration
ImGearDoublePoint Structure


CalculateCameraToRGBMatrix(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,ImGearDoublePoint) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class > CalculateCameraToRGBMatrix Method : CalculateCameraToRGBMatrix(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,ImGearDoublePoint) Method
XYZ to camera colorspace conversion matrix under Illuminant 1.
Illuminant 1 value.
XYZ to camera colorspace conversion matrix under Illuminant 2.
Illuminant 2 value.
XY coordinates of camera white point.
Calculates the matrix for conversion from camera color space to linear sRGB color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CalculateCameraToRGBMatrix( _
   ByVal colorMatrix1 As IGDoubleMatrix, _
   ByVal illuminant1 As ImGearIlluminant, _
   ByVal colorMatrix2 As IGDoubleMatrix, _
   ByVal illuminant2 As ImGearIlluminant, _
   ByVal whitePoint As ImGearDoublePoint _
) As Double(,)
'Usage

Dim colorMatrix1 As IGDoubleMatrix
Dim illuminant1 As ImGearIlluminant
Dim colorMatrix2 As IGDoubleMatrix
Dim illuminant2 As ImGearIlluminant
Dim whitePoint As ImGearDoublePoint
Dim value() As Double

value = ImGearCameraRawProcessing.CalculateCameraToRGBMatrix(colorMatrix1, illuminant1, colorMatrix2, illuminant2, whitePoint)
public static double[,] CalculateCameraToRGBMatrix(
   IGDoubleMatrix colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)
public: static double[,]* CalculateCameraToRGBMatrix(
   IGDoubleMatrix* colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix* colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)
public:
static array<double,>^ CalculateCameraToRGBMatrix(
   IGDoubleMatrix^ colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix^ colorMatrix2,
   ImGearIlluminant illuminant2,
   ImGearDoublePoint whitePoint
)

Parameters

colorMatrix1
XYZ to camera colorspace conversion matrix under Illuminant 1.
illuminant1
Illuminant 1 value.
colorMatrix2
XYZ to camera colorspace conversion matrix under Illuminant 2.
illuminant2
Illuminant 2 value.
whitePoint
XY coordinates of camera white point.

Return Value

Double array.
Remarks
Calculates the matrix for conversion from camera color space to linear sRGB color space, based on two known color matrices corresponding to different light conditions, and a white point. By "linear sRGB color space" we assume a linear (Gamma = 1.0) RGB color space that uses sRGB primaries and reference white. This color space can be converted to sRGB by applying sRGB gamma correction function.

If only one color matrix is known, pass null to colorMatrix2.

Dimensions of colorMatrix1 and colorMatrix2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4). Result matrix dimensions are (3, n).

See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members
Overload List
ImGearIlluminant Enumeration
ImGearDoublePoint Structure


CalculateWhitePoint Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class : CalculateWhitePoint Method
Calculates the white point corresponding to neutral color in camera color space.
Overload List
Overload | Description
CalculateWhitePoint(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,Double[]) | Calculates the white point corresponding to neutral color in camera color space.
CalculateWhitePoint(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,Double[]) | Calculates the white point corresponding to neutral color in camera color space.
See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members


CalculateWhitePoint(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,Double[]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class > CalculateWhitePoint Method : CalculateWhitePoint(Double[,],ImGearIlluminant,Double[,],ImGearIlluminant,Double[]) Method
XYZ to camera colorspace conversion matrix under Illuminant 1.
Illuminant 1.
XYZ to camera colorspace conversion matrix under Illuminant 2.
Illuminant 2.
Normalized coordinates of a neutral color.
Calculates the white point corresponding to neutral color in camera color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CalculateWhitePoint( _
   ByVal colorMatrix1(,) As Double, _
   ByVal illuminant1 As ImGearIlluminant, _
   ByVal colorMatrix2(,) As Double, _
   ByVal illuminant2 As ImGearIlluminant, _
   ByVal neutralColor() As Double _
) As ImGearDoublePoint
'Usage

Dim colorMatrix1() As Double
Dim illuminant1 As ImGearIlluminant
Dim colorMatrix2() As Double
Dim illuminant2 As ImGearIlluminant
Dim neutralColor() As Double
Dim value As ImGearDoublePoint

value = ImGearCameraRawProcessing.CalculateWhitePoint(colorMatrix1, illuminant1, colorMatrix2, illuminant2, neutralColor)
public static ImGearDoublePoint CalculateWhitePoint(
   double[,] colorMatrix1,
   ImGearIlluminant illuminant1,
   double[,] colorMatrix2,
   ImGearIlluminant illuminant2,
   double[] neutralColor
)
public: static ImGearDoublePoint CalculateWhitePoint(
   double[,]* colorMatrix1,
   ImGearIlluminant illuminant1,
   double[,]* colorMatrix2,
   ImGearIlluminant illuminant2,
   double[]* neutralColor
)
public:
static ImGearDoublePoint CalculateWhitePoint(
   array<double>^ colorMatrix1,
   ImGearIlluminant illuminant1,
   array<double>^ colorMatrix2,
   ImGearIlluminant illuminant2,
   array<double>^ neutralColor
)

Parameters

colorMatrix1
XYZ to camera colorspace conversion matrix under Illuminant 1.
illuminant1
Illuminant 1.
colorMatrix2
XYZ to camera colorspace conversion matrix under Illuminant 2.
illuminant2
Illuminant 2.
neutralColor
Normalized coordinates of a neutral color.

Return Value

ImageGear.Core.ImGearDoublePoint structure.
Remarks
Calculates white point corresponding to neutral color in camera color space based on two known color matrices corresponding to different light conditions.

If only one color matrix is known, pass null to >colorMatrix2.

Dimensions of >colorMatrix1 and >colorMatrix2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4).

See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members
Overload List
ImGearDoublePoint Structure
ImGearIlluminant Enumeration


CalculateWhitePoint(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,Double[]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearCameraRawProcessing Class > CalculateWhitePoint Method : CalculateWhitePoint(IGDoubleMatrix,ImGearIlluminant,IGDoubleMatrix,ImGearIlluminant,Double[]) Method
XYZ to camera colorspace conversion matrix under Illuminant 1.
Illuminant 1.
XYZ to camera colorspace conversion matrix under Illuminant 2.
Illuminant 2.
Normalized coordinates of a neutral color.
Calculates the white point corresponding to neutral color in camera color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CalculateWhitePoint( _
   ByVal colorMatrix1 As IGDoubleMatrix, _
   ByVal illuminant1 As ImGearIlluminant, _
   ByVal colorMatrix2 As IGDoubleMatrix, _
   ByVal illuminant2 As ImGearIlluminant, _
   ByVal neutralColor() As Double _
) As ImGearDoublePoint
'Usage

Dim colorMatrix1 As IGDoubleMatrix
Dim illuminant1 As ImGearIlluminant
Dim colorMatrix2 As IGDoubleMatrix
Dim illuminant2 As ImGearIlluminant
Dim neutralColor() As Double
Dim value As ImGearDoublePoint

value = ImGearCameraRawProcessing.CalculateWhitePoint(colorMatrix1, illuminant1, colorMatrix2, illuminant2, neutralColor)
public static ImGearDoublePoint CalculateWhitePoint(
   IGDoubleMatrix colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix colorMatrix2,
   ImGearIlluminant illuminant2,
   double[] neutralColor
)
public: static ImGearDoublePoint CalculateWhitePoint(
   IGDoubleMatrix* colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix* colorMatrix2,
   ImGearIlluminant illuminant2,
   double[]* neutralColor
)
public:
static ImGearDoublePoint CalculateWhitePoint(
   IGDoubleMatrix^ colorMatrix1,
   ImGearIlluminant illuminant1,
   IGDoubleMatrix^ colorMatrix2,
   ImGearIlluminant illuminant2,
   array<double>^ neutralColor
)

Parameters

colorMatrix1
XYZ to camera colorspace conversion matrix under Illuminant 1.
illuminant1
Illuminant 1.
colorMatrix2
XYZ to camera colorspace conversion matrix under Illuminant 2.
illuminant2
Illuminant 2.
neutralColor
Normalized coordinates of a neutral color.

Return Value

ImageGear.Core.ImGearDoublePoint structure.
Remarks
Calculates white point corresponding to neutral color in camera color space based on two known color matrices corresponding to different light conditions.

If only one color matrix is known, pass null to >colorMatrix2.

Dimensions of >colorMatrix1 and >colorMatrix2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4).

See Also

Reference

ImGearCameraRawProcessing Class
ImGearCameraRawProcessing Members
Overload List
ImGearDoublePoint Structure
ImGearIlluminant Enumeration


%%PageItemTitle%%

ImGearColorInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearColorInterpolationOptions Class
Represents color interpolation options.
Object Model
ImGearColorInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearColorInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearColorInterpolationOptions
public class ImGearColorInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearColorInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearColorInterpolationOptions : public ImGearInterpolationOptions
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearColorInterpolationOptions

See Also

Reference

ImGearColorInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearColorInterpolationOptions Class Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearColorInterpolationOptions Class

The following tables list the members exposed by ImGearColorInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorInterpolationOptions Constructor | Initializes a new instance of the ImGearColorInterpolationOptions class.
Top
See Also

Reference

ImGearColorInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearColorInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearColorInterpolationOptions Class : ImGearColorInterpolationOptions Constructor
Initializes a new instance of the ImGearColorInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearColorInterpolationOptions()
public ImGearColorInterpolationOptions()
public: ImGearColorInterpolationOptions();
public:
ImGearColorInterpolationOptions();
See Also

Reference

ImGearColorInterpolationOptions Class
ImGearColorInterpolationOptions Members
ImGearColorInterpolationOptions Class


%%PageItemTitle%%

ImGearContrastOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearContrastOptions Class
Represents contrast options.
Object Model
ImGearContrastOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearContrastOptions
'Usage

Dim instance As ImGearContrastOptions
public class ImGearContrastOptions
public __gc class ImGearContrastOptions
public ref class ImGearContrastOptions
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearContrastOptions

See Also

Reference

ImGearContrastOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearContrastOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearContrastOptions Class

The following tables list the members exposed by ImGearContrastOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearContrastOptions Constructor | Initializes a new instance of the ImGearContrastOptions class.
Top
Public Fields
 | Name | Description
Public Field | IgnoreDICOMDisplaySettings | Determines whether to ignore DICOM display settings in contrast processing operations.
Top
See Also

Reference

ImGearContrastOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearContrastOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearContrastOptions Class : ImGearContrastOptions Constructor
Initializes a new instance of the ImGearContrastOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearContrastOptions()
public ImGearContrastOptions()
public: ImGearContrastOptions();
public:
ImGearContrastOptions();
See Also

Reference

ImGearContrastOptions Class
ImGearContrastOptions Members
ImGearContrastOptions Class


%%PageItemTitle%% $$Fields$$

ImGearContrastOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearContrastOptions Class

For a list of all members of this type, see ImGearContrastOptions members.

Public Fields
 | Name | Description
Public Field | IgnoreDICOMDisplaySettings | Determines whether to ignore DICOM display settings in contrast processing operations.
Top
See Also

Reference

ImGearContrastOptions Class
ImageGear.Processing Namespace


IgnoreDICOMDisplaySettings Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearContrastOptions Class : IgnoreDICOMDisplaySettings Field
Determines whether to ignore DICOM display settings in contrast processing operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public IgnoreDICOMDisplaySettings As Boolean
'Usage

Dim instance As ImGearContrastOptions
Dim value As Boolean

value = instance.IgnoreDICOMDisplaySettings

instance.IgnoreDICOMDisplaySettings = value
public bool IgnoreDICOMDisplaySettings
public: bool IgnoreDICOMDisplaySettings
public:
bool IgnoreDICOMDisplaySettings

Field Value

Boolean value.
See Also

Reference

ImGearContrastOptions Class
ImGearContrastOptions Members
ImGearDICOMDisplaySettings Class


%%PageItemTitle%%

ImGearDiffuseReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearDiffuseReductionOptions Class
Defines reduction options for diffuse reduction.
Object Model
ImGearDiffuseReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDiffuseReductionOptions
'Usage

Dim instance As ImGearDiffuseReductionOptions
public class ImGearDiffuseReductionOptions
public __gc class ImGearDiffuseReductionOptions
public ref class ImGearDiffuseReductionOptions
Remarks
Diffuse reduction reduces an image to either black and white or 4bpp color by performing dithering according to a threshold. The type of dithering used is known as error diffusion, which attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image.

A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

When reducing to 4bpp, a palette containing colors to use for the output image can optionally be specified. If this palette is not supplied, a default palette will be used.

Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearDiffuseReductionOptions

See Also

Reference

ImGearDiffuseReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearDiffuseReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearDiffuseReductionOptions Class

The following tables list the members exposed by ImGearDiffuseReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearDiffuseReductionOptions Constructor | Initializes a new instance of the ImGearDiffuseReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | Palette | Palette to use for output.
Public Field | Threshold | Threshold value for dithering, 0-255.
Top
See Also

Reference

ImGearDiffuseReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearDiffuseReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearDiffuseReductionOptions Class : ImGearDiffuseReductionOptions Constructor
Initializes a new instance of the ImGearDiffuseReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDiffuseReductionOptions()
public ImGearDiffuseReductionOptions()
public: ImGearDiffuseReductionOptions();
public:
ImGearDiffuseReductionOptions();
See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearDiffuseReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearDiffuseReductionOptions Class

For a list of all members of this type, see ImGearDiffuseReductionOptions members.

Public Fields
 | Name | Description
Public Field | Palette | Palette to use for output.
Public Field | Threshold | Threshold value for dithering, 0-255.
Top
See Also

Reference

ImGearDiffuseReductionOptions Class
ImageGear.Processing Namespace


Palette Field (ImGearDiffuseReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearDiffuseReductionOptions Class : Palette Field
Palette to use for output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Palette As ImGearRGBQuad()
'Usage

Dim instance As ImGearDiffuseReductionOptions
Dim value() As ImGearRGBQuad

value = instance.Palette

instance.Palette = value
public ImGearRGBQuad[] Palette
public: ImGearRGBQuad[]* Palette
public:
array<ImGearRGBQuad>^ Palette

Field Value

A 16-color palette, or null.
Remarks
This option lets you specify a palette containing the colors to use for the output image. It’s only used when the output channel depth is 4. If no palette is specified, a default palette is used.
See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members
ImGearRGBQuad Structure


Threshold Field (ImGearDiffuseReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearDiffuseReductionOptions Class : Threshold Field
Threshold value for dithering, 0-255.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearDiffuseReductionOptions
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Integer in the range 0-255.
Remarks
A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.
See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members


%%PageItemTitle%%

ImGearGrayScaleInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearGrayScaleInterpolationOptions Class
Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions class.
Object Model
ImGearGrayScaleInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearGrayScaleInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearGrayScaleInterpolationOptions
public class ImGearGrayScaleInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearGrayScaleInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearGrayScaleInterpolationOptions : public ImGearInterpolationOptions
Remarks
This class defines interpolation options for scale-to-gray interpolation.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearGrayScaleInterpolationOptions

See Also

Reference

ImGearGrayScaleInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearGrayScaleInterpolationOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearGrayScaleInterpolationOptions Class

The following tables list the members exposed by ImGearGrayScaleInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearGrayScaleInterpolationOptions Constructor | Initializes a new instance of the ImGearGrayScaleInterpolationOptions class.
Top
Public Fields
 | Name | Description
Public Field | Threshold | ScaleToGray threshold in percents.
Top
See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearGrayScaleInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearGrayScaleInterpolationOptions Class : ImGearGrayScaleInterpolationOptions Constructor
Interpolation threshold.
Initializes a new instance of the ImGearGrayScaleInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal threshold As Integer _
)
'Usage

Dim threshold As Integer

Dim instance As New ImGearGrayScaleInterpolationOptions(threshold)
public ImGearGrayScaleInterpolationOptions(
   int threshold
)
public: ImGearGrayScaleInterpolationOptions(
   int threshold
)
public:
ImGearGrayScaleInterpolationOptions(
   int threshold
)

Parameters

threshold
Interpolation threshold.
See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImGearGrayScaleInterpolationOptions Members
ImGearGrayScaleInterpolationOptions Class


%%PageItemTitle%% $$Fields$$

ImGearGrayScaleInterpolationOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearGrayScaleInterpolationOptions Class

For a list of all members of this type, see ImGearGrayScaleInterpolationOptions members.

Public Fields
 | Name | Description
Public Field | Threshold | ScaleToGray threshold in percents.
Top
See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


Threshold Field (ImGearGrayScaleInterpolationOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearGrayScaleInterpolationOptions Class : Threshold Field
ScaleToGray threshold in percents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearGrayScaleInterpolationOptions
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Integer in the range 0-100.
See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImGearGrayScaleInterpolationOptions Members


%%PageItemTitle%%

ImGearHalftoneReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearHalftoneReductionOptions Class
Defines reduction options for halftone reduction.
Object Model
ImGearHalftoneReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearHalftoneReductionOptions
'Usage

Dim instance As ImGearHalftoneReductionOptions
public class ImGearHalftoneReductionOptions
public __gc class ImGearHalftoneReductionOptions
public ref class ImGearHalftoneReductionOptions
Remarks
Halftone reduction reduces an image to black and white in such a way that it is suitable for half-toning. The resulting image will consist of small squares of varying sizes that will give the appearance of varying shades of gray.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearHalftoneReductionOptions

See Also

Reference

ImGearHalftoneReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearHalftoneReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearHalftoneReductionOptions Class

The following tables list the members exposed by ImGearHalftoneReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearHalftoneReductionOptions Constructor | Initializes a new instance of the ImGearHalftoneReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | Mode | Mode to use for halftone reduction.
Top
See Also

Reference

ImGearHalftoneReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearHalftoneReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearHalftoneReductionOptions Class : ImGearHalftoneReductionOptions Constructor
Initializes a new instance of the ImGearHalftoneReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearHalftoneReductionOptions()
public ImGearHalftoneReductionOptions()
public: ImGearHalftoneReductionOptions();
public:
ImGearHalftoneReductionOptions();
See Also

Reference

ImGearHalftoneReductionOptions Class
ImGearHalftoneReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearHalftoneReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearHalftoneReductionOptions Class

For a list of all members of this type, see ImGearHalftoneReductionOptions members.

Public Fields
 | Name | Description
Public Field | Mode | Mode to use for halftone reduction.
Top
See Also

Reference

ImGearHalftoneReductionOptions Class
ImageGear.Processing Namespace


Mode Field (ImGearHalftoneReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearHalftoneReductionOptions Class : Mode Field
Mode to use for halftone reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Mode As ImGearHalftoneReductionModes
'Usage

Dim instance As ImGearHalftoneReductionOptions
Dim value As ImGearHalftoneReductionModes

value = instance.Mode

instance.Mode = value
public ImGearHalftoneReductionModes Mode
public: ImGearHalftoneReductionModes Mode
public:
ImGearHalftoneReductionModes Mode

Field Value

Value from ImGearHalftoneReductionModes enumeration
Remarks
This option lets you specify a mode to use for halftone reduction. Possible modes are listed in the ImGearHalftoneReductionModes enumeration. Currently the only available mode is SQUARES.
See Also

Reference

ImGearHalftoneReductionOptions Class
ImGearHalftoneReductionOptions Members
ImGearHalftoneReductionModes Enumeration


%%PageItemTitle%%

ImGearInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearInterpolationOptions Class
Base class for all interpolation options passed to ImGearProcessing.Resize and ImGearProcessing.CreateThumbnail methods.
Object Model
ImGearInterpolationOptions ClassImGearInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearInterpolationOptions
'Usage

Dim instance As ImGearInterpolationOptions
public class ImGearInterpolationOptions
public __gc class ImGearInterpolationOptions
public ref class ImGearInterpolationOptions
Remarks
Use the base class for interpolation modes that do not need additional options. Use derived classes to pass specific options. If a base class is passed for a mode that has a derived class, the default option values are used.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearAverageInterpolationOptions
ImageGear.Processing.ImGearBicubicInterpolationOptions
ImageGear.Processing.ImGearBilinearInterpolationOptions
ImageGear.Processing.ImGearColorInterpolationOptions
ImageGear.Processing.ImGearGrayScaleInterpolationOptions
ImageGear.Processing.ImGearNearestNeighborInterpolationOptions
ImageGear.Processing.ImGearNoneInterpolationOptions
ImageGear.Processing.ImGearPreserveBlackInterpolationOptions
ImageGear.Processing.ImGearPreserveWhiteInterpolationOptions

See Also

Reference

ImGearInterpolationOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearInterpolationOptions Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearInterpolationOptions Class

The following tables list the members exposed by ImGearInterpolationOptions.

Protected Constructors
 | Name | Description
Protected Constructor | ImGearInterpolationOptions Constructor | Initializes a new instance of the ImGearInterpolationOptions class.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetDefault | Instance of ImGearInterpolationOptions class.
Top
See Also

Reference

ImGearInterpolationOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearInterpolationOptions Class : ImGearInterpolationOptions Constructor
Interpolation method.
Initializes a new instance of the ImGearInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function New( _
   ByVal interpolationType As ImGearInterpolations _
)
'Usage

Dim interpolationType As ImGearInterpolations

Dim instance As New ImGearInterpolationOptions(interpolationType)
protected ImGearInterpolationOptions(
   ImGearInterpolations interpolationType
)
protected: ImGearInterpolationOptions(
   ImGearInterpolations interpolationType
)
protected:
ImGearInterpolationOptions(
   ImGearInterpolations interpolationType
)

Parameters

interpolationType
Interpolation method.
See Also

Reference

ImGearInterpolationOptions Class
ImGearInterpolationOptions Members
ImGearInterpolationOptions Class
ImGearInterpolations Enumeration


%%PageItemTitle%% $$Methods$$

ImGearInterpolationOptions Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearInterpolationOptions Class

For a list of all members of this type, see ImGearInterpolationOptions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetDefault | Instance of ImGearInterpolationOptions class.
Top
See Also

Reference

ImGearInterpolationOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearInterpolationOptions Class : ImGearInterpolationOptions Constructor
Overload List
Overload | Description
ImGearInterpolationOptions Constructor | Initializes a new instance of the ImGearInterpolationOptions class.
See Also

Reference

ImGearInterpolationOptions Class
ImGearInterpolationOptions Members


GetDefault Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearInterpolationOptions Class : GetDefault Method
Interpolation method.
Instance of ImGearInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetDefault( _
   ByVal interpolationType As ImGearInterpolations _
) As ImGearInterpolationOptions
'Usage

Dim interpolationType As ImGearInterpolations
Dim value As ImGearInterpolationOptions

value = ImGearInterpolationOptions.GetDefault(interpolationType)
public static ImGearInterpolationOptions GetDefault(
   ImGearInterpolations interpolationType
)
public: static ImGearInterpolationOptions* GetDefault(
   ImGearInterpolations interpolationType
)
public:
static ImGearInterpolationOptions^ GetDefault(
   ImGearInterpolations interpolationType
)

Parameters

interpolationType
Interpolation method.

Return Value

ImGearInterpolationOptions class object.
Remarks
Returns instance of options with most commonly used attributes for specified type of interpolation.
Example
  • C#
// Creates a thumbnail 100 pixels wide maintaining aspect ratio.

// Determine appropriate height.
int newHeight = 100 * igPage.DIB.Height / igPage.DIB.Width;

// Set default interpolation to none.
ImGearInterpolations igInterpolations = ImGearInterpolations.NONE;

// If the image is 1-bit and larger than 100x100, use grayscale interpolation.
if (igPage is ImGearRasterPage &&
    1 == igPage.DIB.BitDepth &&
    igPage.DIB.Width >= 100 &&
    igPage.DIB.Height >= 100)
{
    igInterpolations = ImGearInterpolations.GRAYSCALE;
}

// Create the thumbnail using the default options for the chosen interpolation.
ImGearPage igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight,
    ImGearInterpolationOptions.GetDefault(igInterpolations));
  • Visual Basic
' Creates a thumbnail 100 pixels wide maintaining aspect ratio.

' Determine appropriate height.
Dim newHeight As Integer = 100 * igPage.DIB.Height / igPage.DIB.Width

' Set default interpolation to none.
Dim igInterpolations As ImGearInterpolations = ImGearInterpolations.NONE

' If the image is 1-bit and larger than 100x100, use grayscale interpolation.
If TypeOf igPage Is ImGearRasterPage AndAlso 1 = igPage.DIB.BitDepth AndAlso _
 igPage.DIB.Width >= 100 AndAlso igPage.DIB.Height >= 100 Then
    igInterpolations = ImGearInterpolations.GRAYSCALE
End If

' Create the thumbnail using the default options for the chosen interpolation.
Dim igPageThumbnail As ImGearPage
igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight, _
 ImGearInterpolationOptions.GetDefault(igInterpolations))
See Also

Reference

ImGearInterpolationOptions Class
ImGearInterpolationOptions Members
ImGearInterpolationOptions Class
ImGearInterpolations Enumeration


%%PageItemTitle%%

ImGearMedianCutReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearMedianCutReductionOptions Class
Defines reduction options for median cut reduction.
Object Model
ImGearMedianCutReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMedianCutReductionOptions
'Usage

Dim instance As ImGearMedianCutReductionOptions
public class ImGearMedianCutReductionOptions
public __gc class ImGearMedianCutReductionOptions
public ref class ImGearMedianCutReductionOptions
Remarks
Median cut reduction reduces an image to 8bpp by dividing it into a number of equally sized squares. The number of squares is equal to the number of desired output colors. The colors of the pixels in each square will be averaged to produce a resulting color. The resulting image will contain only these colors.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearMedianCutReductionOptions

See Also

Reference

ImGearMedianCutReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearMedianCutReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearMedianCutReductionOptions Class

The following tables list the members exposed by ImGearMedianCutReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearMedianCutReductionOptions Constructor | Initializes a new instance of the ImGearMedianCutReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | FastRemap | Specifies whether to optimize for speed or quality.
Public Field | MaxColors | Maximum number of colors used by the output image.
Top
See Also

Reference

ImGearMedianCutReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearMedianCutReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearMedianCutReductionOptions Class : ImGearMedianCutReductionOptions Constructor
Initializes a new instance of the ImGearMedianCutReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMedianCutReductionOptions()
public ImGearMedianCutReductionOptions()
public: ImGearMedianCutReductionOptions();
public:
ImGearMedianCutReductionOptions();
See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearMedianCutReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearMedianCutReductionOptions Class

For a list of all members of this type, see ImGearMedianCutReductionOptions members.

Public Fields
 | Name | Description
Public Field | FastRemap | Specifies whether to optimize for speed or quality.
Public Field | MaxColors | Maximum number of colors used by the output image.
Top
See Also

Reference

ImGearMedianCutReductionOptions Class
ImageGear.Processing Namespace


FastRemap Field (ImGearMedianCutReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearMedianCutReductionOptions Class : FastRemap Field
Specifies whether to optimize for speed or quality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FastRemap As Boolean
'Usage

Dim instance As ImGearMedianCutReductionOptions
Dim value As Boolean

value = instance.FastRemap

instance.FastRemap = value
public bool FastRemap
public: bool FastRemap
public:
bool FastRemap

Field Value

Set to true to optimize for speed; set to false to optimize for quality.
See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


MaxColors Field (ImGearMedianCutReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearMedianCutReductionOptions Class : MaxColors Field
Maximum number of colors used by the output image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxColors As Integer
'Usage

Dim instance As ImGearMedianCutReductionOptions
Dim value As Integer

value = instance.MaxColors

instance.MaxColors = value
public int MaxColors
public: int MaxColors
public:
int MaxColors

Field Value

Integer value in range [16...256]
Remarks
The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


%%PageItemTitle%%

ImGearNearestNeighborInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearNearestNeighborInterpolationOptions Class
Represents options for nearest neighbor interpolation.
Object Model
ImGearNearestNeighborInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearNearestNeighborInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearNearestNeighborInterpolationOptions
public class ImGearNearestNeighborInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearNearestNeighborInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearNearestNeighborInterpolationOptions : public ImGearInterpolationOptions
Remarks
This class has no public fields and methods and is used to identify nearest neighborhood interpolation by itself in image processing functions.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearNearestNeighborInterpolationOptions

See Also

Reference

ImGearNearestNeighborInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearNearestNeighborInterpolationOptions Class Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearNearestNeighborInterpolationOptions Class

The following tables list the members exposed by ImGearNearestNeighborInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearNearestNeighborInterpolationOptions Constructor | Initializes a new instance of the ImGearNearestNeighborInterpolationOptions class.
Top
See Also

Reference

ImGearNearestNeighborInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearNearestNeighborInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearNearestNeighborInterpolationOptions Class : ImGearNearestNeighborInterpolationOptions Constructor
Initializes a new instance of the ImGearNearestNeighborInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearNearestNeighborInterpolationOptions()
public ImGearNearestNeighborInterpolationOptions()
public: ImGearNearestNeighborInterpolationOptions();
public:
ImGearNearestNeighborInterpolationOptions();
See Also

Reference

ImGearNearestNeighborInterpolationOptions Class
ImGearNearestNeighborInterpolationOptions Members
ImGearNearestNeighborInterpolationOptions Class


%%PageItemTitle%%

ImGearNoneInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearNoneInterpolationOptions Class
Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.
Object Model
ImGearNoneInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearNoneInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearNoneInterpolationOptions
public class ImGearNoneInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearNoneInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearNoneInterpolationOptions : public ImGearInterpolationOptions
Remarks
This class has no public fields and methods and is used to identify interpolation by itself in image processing functions.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearNoneInterpolationOptions

See Also

Reference

ImGearNoneInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearNoneInterpolationOptions Class Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearNoneInterpolationOptions Class

The following tables list the members exposed by ImGearNoneInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearNoneInterpolationOptions Constructor | Initializes a new instance of the ImGearNoneInterpolationOptions class.
Top
See Also

Reference

ImGearNoneInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearNoneInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearNoneInterpolationOptions Class : ImGearNoneInterpolationOptions Constructor
Initializes a new instance of the ImGearNoneInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearNoneInterpolationOptions()
public ImGearNoneInterpolationOptions()
public: ImGearNoneInterpolationOptions();
public:
ImGearNoneInterpolationOptions();
See Also

Reference

ImGearNoneInterpolationOptions Class
ImGearNoneInterpolationOptions Members
ImGearNoneInterpolationOptions Class


%%PageItemTitle%%

ImGearOctreeReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearOctreeReductionOptions Class
Defines options for octree reduction.
Object Model
ImGearOctreeReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearOctreeReductionOptions
'Usage

Dim instance As ImGearOctreeReductionOptions
public class ImGearOctreeReductionOptions
public __gc class ImGearOctreeReductionOptions
public ref class ImGearOctreeReductionOptions
Remarks
Octree reduction reduces an image to 4bpp or 8bpp by repeatedly subdividing cubic representations of the RGB color space according to image content.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearOctreeReductionOptions

See Also

Reference

ImGearOctreeReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearOctreeReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearOctreeReductionOptions Class

The following tables list the members exposed by ImGearOctreeReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearOctreeReductionOptions Constructor | Initializes a new instance of the ImGearOctreeReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | ErrorDiffusion | Specifies whether to improve accuracy using error diffusion.
Public Field | FastRemap | Specifies whether to optimize for speed or quality.
Public Field | MaxColors | Maximum number of colors used by the output image.
Public Field | Palette | Palette to use for output.
Public Field | PaletteSize | Number of colors present in specified Palette.
Top
See Also

Reference

ImGearOctreeReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearOctreeReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : ImGearOctreeReductionOptions Constructor
Initializes a new instance of the ImGearOctreeReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearOctreeReductionOptions()
public ImGearOctreeReductionOptions()
public: ImGearOctreeReductionOptions();
public:
ImGearOctreeReductionOptions();
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearOctreeReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearOctreeReductionOptions Class

For a list of all members of this type, see ImGearOctreeReductionOptions members.

Public Fields
 | Name | Description
Public Field | ErrorDiffusion | Specifies whether to improve accuracy using error diffusion.
Public Field | FastRemap | Specifies whether to optimize for speed or quality.
Public Field | MaxColors | Maximum number of colors used by the output image.
Public Field | Palette | Palette to use for output.
Public Field | PaletteSize | Number of colors present in specified Palette.
Top
See Also

Reference

ImGearOctreeReductionOptions Class
ImageGear.Processing Namespace


ErrorDiffusion Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : ErrorDiffusion Field
Specifies whether to improve accuracy using error diffusion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ErrorDiffusion As Boolean
'Usage

Dim instance As ImGearOctreeReductionOptions
Dim value As Boolean

value = instance.ErrorDiffusion

instance.ErrorDiffusion = value
public bool ErrorDiffusion
public: bool ErrorDiffusion
public:
bool ErrorDiffusion

Field Value

Boolean value.
Remarks
Error diffusion attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image. It increases overall accuracy, but can give the image a more speckled or dithered appearance. It also decreases the effectiveness of most compression algorithms since adjacent pixels are less likely to be the same color. Using octree reduction without error diffusion is sometimes known as ?nearest color? reduction.
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


FastRemap Field (ImGearOctreeReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : FastRemap Field
Specifies whether to optimize for speed or quality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FastRemap As Boolean
'Usage

Dim instance As ImGearOctreeReductionOptions
Dim value As Boolean

value = instance.FastRemap

instance.FastRemap = value
public bool FastRemap
public: bool FastRemap
public:
bool FastRemap

Field Value

Set to true to optimize for speed; set to false to optimize for quality.
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


MaxColors Field (ImGearOctreeReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : MaxColors Field
Maximum number of colors used by the output image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxColors As Integer
'Usage

Dim instance As ImGearOctreeReductionOptions
Dim value As Integer

value = instance.MaxColors

instance.MaxColors = value
public int MaxColors
public: int MaxColors
public:
int MaxColors

Field Value

Integer value in range [8...256].
Remarks
Note: If 16 or less colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


Palette Field (ImGearOctreeReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : Palette Field
Palette to use for output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Palette As ImGearRGBQuad()
'Usage

Dim instance As ImGearOctreeReductionOptions
Dim value() As ImGearRGBQuad

value = instance.Palette

instance.Palette = value
public ImGearRGBQuad[] Palette
public: ImGearRGBQuad[]* Palette
public:
array<ImGearRGBQuad>^ Palette

Field Value

A 16-256 color palette or null.
Remarks
This option lets you specify a palette containing the colors to use for the output image. If no palette is specified, an optimized palette is constructed based on the contents of the image.
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members
ImGearRGBQuad Structure


PaletteSize Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearOctreeReductionOptions Class : PaletteSize Field
Number of colors present in specified Palette.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PaletteSize As Integer
'Usage

Dim instance As ImGearOctreeReductionOptions
Dim value As Integer

value = instance.PaletteSize

instance.PaletteSize = value
public int PaletteSize
public: int PaletteSize
public:
int PaletteSize

Field Value

Integer in range [8...256]. If Palette field is non-null, this must less than or equal to the number of colors in Palette field, and greater than or equal to MaxColors field.
Remarks
If no palette is specified (Palette field is null), this option is ignored and an optimized palette is automatically generated.
See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

ImGearPixelProcessorRedEyeRGB Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPixelProcessorRedEyeRGB Class
Processes the RGB pixel using red-eye removal algorithm.
Object Model
ImGearPixelProcessorRedEyeRGB ClassImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelProcessorRedEyeRGB
   Implements IImGearPixelProcessor
'Usage

Dim instance As ImGearPixelProcessorRedEyeRGB
public class ImGearPixelProcessorRedEyeRGB : IImGearPixelProcessor
public __gc class ImGearPixelProcessorRedEyeRGB : public IImGearPixelProcessor
public ref class ImGearPixelProcessorRedEyeRGB : public IImGearPixelProcessor
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelProcessorRedEyeRGB

See Also

Reference

ImGearPixelProcessorRedEyeRGB Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearPixelProcessorRedEyeRGB Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPixelProcessorRedEyeRGB Class

The following tables list the members exposed by ImGearPixelProcessorRedEyeRGB.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelProcessorRedEyeRGB Constructor | Initializes a new instance of the ImGearPixelProcessorRedEyeRGB class.
Top
Public Methods
 | Name | Description
Public Method | ProcessPixel | Returns the new pixel after processing.
Top
See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearPixelProcessorRedEyeRGB Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPixelProcessorRedEyeRGB Class : ImGearPixelProcessorRedEyeRGB Constructor
DIB the pixel belongs to.
A value in the range 0.5..2 that specifies a part of the red component in the pixel color.
Brightness of the pixel after processing. The range is -1...1.
Initializes a new instance of the ImGearPixelProcessorRedEyeRGB class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dib As ImGearDIB, _
   ByVal threshold As Double, _
   ByVal brightness As Double _
)
'Usage

Dim dib As ImGearDIB
Dim threshold As Double
Dim brightness As Double

Dim instance As New ImGearPixelProcessorRedEyeRGB(dib, threshold, brightness)
public ImGearPixelProcessorRedEyeRGB(
   ImGearDIB dib,
   double threshold,
   double brightness
)
public: ImGearPixelProcessorRedEyeRGB(
   ImGearDIB* dib,
   double threshold,
   double brightness
)
public:
ImGearPixelProcessorRedEyeRGB(
   ImGearDIB^ dib,
   double threshold,
   double brightness
)

Parameters

dib
DIB the pixel belongs to.
threshold
A value in the range 0.5..2 that specifies a part of the red component in the pixel color.
brightness
Brightness of the pixel after processing. The range is -1...1.
See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImGearPixelProcessorRedEyeRGB Members
ImGearPixelProcessorRedEyeRGB Class
ImGearDIB Class


%%PageItemTitle%% $$Methods$$

ImGearPixelProcessorRedEyeRGB Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPixelProcessorRedEyeRGB Class

For a list of all members of this type, see ImGearPixelProcessorRedEyeRGB members.

Public Methods
 | Name | Description
Public Method | ProcessPixel | Returns the new pixel after processing.
Top
See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImageGear.Processing Namespace


ProcessPixel Method (ImGearPixelProcessorRedEyeRGB)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPixelProcessorRedEyeRGB Class : ProcessPixel Method
ImageGear.Core.ImGearPixel class object representing pixel to be processed.
Returns the new pixel after processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ProcessPixel( _
   ByVal pixel As ImGearPixel _
) As ImGearPixel
'Usage

Dim instance As ImGearPixelProcessorRedEyeRGB
Dim pixel As ImGearPixel
Dim value As ImGearPixel

value = instance.ProcessPixel(pixel)
public ImGearPixel ProcessPixel(
   ImGearPixel pixel
)
public: ImGearPixel* ProcessPixel(
   ImGearPixel* pixel
)
public:
ImGearPixel^ ProcessPixel(
   ImGearPixel^ pixel
)

Parameters

pixel
ImageGear.Core.ImGearPixel class object representing pixel to be processed.

Return Value

ImageGear.Core.ImGearPixel class object.
See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImGearPixelProcessorRedEyeRGB Members
ImGearPixel Class


%%PageItemTitle%%

ImGearPopularityReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPopularityReductionOptions Class
Defines options for popularity reduction.
Object Model
ImGearPopularityReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPopularityReductionOptions
'Usage

Dim instance As ImGearPopularityReductionOptions
public class ImGearPopularityReductionOptions
public __gc class ImGearPopularityReductionOptions
public ref class ImGearPopularityReductionOptions
Remarks
Popularity reduction reduces an image to 8bpp while retaining its most popular, or prevalent, colors. Use the MaxColors field option to specify the maximum number of colors wanted in the result.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPopularityReductionOptions

See Also

Reference

ImGearPopularityReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearPopularityReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPopularityReductionOptions Class

The following tables list the members exposed by ImGearPopularityReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPopularityReductionOptions Constructor | Initializes a new instance of the ImGearPopularityReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | MaxColors | Maximum number of colors used by the output image.
Top
See Also

Reference

ImGearPopularityReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearPopularityReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPopularityReductionOptions Class : ImGearPopularityReductionOptions Constructor
Initializes a new instance of the ImGearPopularityReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPopularityReductionOptions()
public ImGearPopularityReductionOptions()
public: ImGearPopularityReductionOptions();
public:
ImGearPopularityReductionOptions();
See Also

Reference

ImGearPopularityReductionOptions Class
ImGearPopularityReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearPopularityReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPopularityReductionOptions Class

For a list of all members of this type, see ImGearPopularityReductionOptions members.

Public Fields
 | Name | Description
Public Field | MaxColors | Maximum number of colors used by the output image.
Top
See Also

Reference

ImGearPopularityReductionOptions Class
ImageGear.Processing Namespace


MaxColors Field (ImGearPopularityReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPopularityReductionOptions Class : MaxColors Field
Maximum number of colors used by the output image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxColors As Integer
'Usage

Dim instance As ImGearPopularityReductionOptions
Dim value As Integer

value = instance.MaxColors

instance.MaxColors = value
public int MaxColors
public: int MaxColors
public:
int MaxColors

Field Value

Integer in range [8...256].
Remarks
The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
See Also

Reference

ImGearPopularityReductionOptions Class
ImGearPopularityReductionOptions Members


%%PageItemTitle%%

ImGearPreserveBlackInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveBlackInterpolationOptions Class
Represents options for PreserveWhite interpolation.
Object Model
ImGearPreserveBlackInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPreserveBlackInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearPreserveBlackInterpolationOptions
public class ImGearPreserveBlackInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearPreserveBlackInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearPreserveBlackInterpolationOptions : public ImGearInterpolationOptions
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearPreserveBlackInterpolationOptions

See Also

Reference

ImGearPreserveBlackInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearPreserveBlackInterpolationOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveBlackInterpolationOptions Class

The following tables list the members exposed by ImGearPreserveBlackInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPreserveBlackInterpolationOptions Constructor | Initializes a new instance of the ImGearPreserveBlackInterpolationOptions class.
Top
Public Fields
 | Name | Description
Public Field | Threshold | Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.
Top
See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearPreserveBlackInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPreserveBlackInterpolationOptions Class : ImGearPreserveBlackInterpolationOptions Constructor
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.
Initializes a new instance of the ImGearPreserveBlackInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal threshold As Integer _
)
'Usage

Dim threshold As Integer

Dim instance As New ImGearPreserveBlackInterpolationOptions(threshold)
public ImGearPreserveBlackInterpolationOptions(
   int threshold
)
public: ImGearPreserveBlackInterpolationOptions(
   int threshold
)
public:
ImGearPreserveBlackInterpolationOptions(
   int threshold
)

Parameters

threshold
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.
See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImGearPreserveBlackInterpolationOptions Members


%%PageItemTitle%% $$Fields$$

ImGearPreserveBlackInterpolationOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveBlackInterpolationOptions Class

For a list of all members of this type, see ImGearPreserveBlackInterpolationOptions members.

Public Fields
 | Name | Description
Public Field | Threshold | Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.
Top
See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


Threshold Field (ImGearPreserveBlackInterpolationOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPreserveBlackInterpolationOptions Class : Threshold Field
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearPreserveBlackInterpolationOptions
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Any integer value.
See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImGearPreserveBlackInterpolationOptions Members
ImGearPreserveBlackInterpolationOptions Class


%%PageItemTitle%%

ImGearPreserveWhiteInterpolationOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveWhiteInterpolationOptions Class
Represents options for PreserveWhite interpolation.
Object Model
ImGearPreserveWhiteInterpolationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPreserveWhiteInterpolationOptions
   Inherits ImGearInterpolationOptions
'Usage

Dim instance As ImGearPreserveWhiteInterpolationOptions
public class ImGearPreserveWhiteInterpolationOptions : ImGearInterpolationOptions
public __gc class ImGearPreserveWhiteInterpolationOptions : public ImGearInterpolationOptions
public ref class ImGearPreserveWhiteInterpolationOptions : public ImGearInterpolationOptions
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearInterpolationOptions
ImageGear.Processing.ImGearPreserveWhiteInterpolationOptions

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Members
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%% $$Members$$

ImGearPreserveWhiteInterpolationOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveWhiteInterpolationOptions Class

The following tables list the members exposed by ImGearPreserveWhiteInterpolationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPreserveWhiteInterpolationOptions Constructor | Initializes a new instance of the ImGearPreserveWhiteInterpolationOptions class.
Top
Public Fields
 | Name | Description
Public Field | Threshold | Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.
Top
See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


%%PageItemTitle%%

ImGearPreserveWhiteInterpolationOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPreserveWhiteInterpolationOptions Class : ImGearPreserveWhiteInterpolationOptions Constructor
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.
Initializes a new instance of the ImGearPreserveWhiteInterpolationOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal threshold As Integer _
)
'Usage

Dim threshold As Integer

Dim instance As New ImGearPreserveWhiteInterpolationOptions(threshold)
public ImGearPreserveWhiteInterpolationOptions(
   int threshold
)
public: ImGearPreserveWhiteInterpolationOptions(
   int threshold
)
public:
ImGearPreserveWhiteInterpolationOptions(
   int threshold
)

Parameters

threshold
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.
See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImGearPreserveWhiteInterpolationOptions Members


%%PageItemTitle%% $$Fields$$

ImGearPreserveWhiteInterpolationOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPreserveWhiteInterpolationOptions Class

For a list of all members of this type, see ImGearPreserveWhiteInterpolationOptions members.

Public Fields
 | Name | Description
Public Field | Threshold | Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.
Top
See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImageGear.Processing Namespace
ImGearInterpolationOptions Class


Threshold Field (ImGearPreserveWhiteInterpolationOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearPreserveWhiteInterpolationOptions Class : Threshold Field
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearPreserveWhiteInterpolationOptions
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Any integer value.
See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImGearPreserveWhiteInterpolationOptions Members
ImGearPreserveWhiteInterpolationOptions Class


%%PageItemTitle%%

ImGearProcessing Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessing Class
Provides image processing methods that can be applied to both Raster and Vector images.
Object Model
ImGearProcessing ClassImGearPage ClassImGearProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearProcessing
'Usage

Dim instance As ImGearProcessing
public sealed class ImGearProcessing
public __gc __sealed class ImGearProcessing
public ref class ImGearProcessing sealed
Remarks
This class does not have a public constructor because all its functionality is implemented through static members.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearProcessing

See Also

Reference

ImGearProcessing Members
ImageGear.Processing Namespace
ImGearProcessingVerifier Class


%%PageItemTitle%% $$Members$$

ImGearProcessing Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessing Class

The following tables list the members exposed by ImGearProcessing.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets ImGearProcessingVerifier class object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateThumbnail | Creates a thumbnail image according to the specified dimensions.
static (Shared in Visual Basic) | Crop | Crops an image according to the specified offsets and dimensions.
static (Shared in Visual Basic) | Flip | Flips an image in vertical or horizontal direction.
static (Shared in Visual Basic) | Resize | Resizes an image according to the specified dimensions.
static (Shared in Visual Basic) | ResizeCanvas | This method changes the dimensions of the ImageGear.Core.ImGearPage class object.
static (Shared in Visual Basic) | Rotate | Overloaded. Rotates an image.
Top
See Also

Reference

ImGearProcessing Class
ImageGear.Processing Namespace
ImGearProcessingVerifier Class


%%PageItemTitle%% $$Methods$$

ImGearProcessing Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessing Class

For a list of all members of this type, see ImGearProcessing members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateThumbnail | Creates a thumbnail image according to the specified dimensions.
static (Shared in Visual Basic) | Crop | Crops an image according to the specified offsets and dimensions.
static (Shared in Visual Basic) | Flip | Flips an image in vertical or horizontal direction.
static (Shared in Visual Basic) | Resize | Resizes an image according to the specified dimensions.
static (Shared in Visual Basic) | ResizeCanvas | This method changes the dimensions of the ImageGear.Core.ImGearPage class object.
static (Shared in Visual Basic) | Rotate | Overloaded. Rotates an image.
Top
See Also

Reference

ImGearProcessing Class
ImageGear.Processing Namespace
ImGearProcessingVerifier Class


CreateThumbnail Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : CreateThumbnail Method
Source image from which the thumbnail is created.
Width of the thumbnail.
Height of the thumbnail.
Interpolation options.
Creates a thumbnail image according to the specified dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateThumbnail( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal options As ImGearInterpolationOptions _
) As ImGearPage
'Usage

Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim options As ImGearInterpolationOptions
Dim value As ImGearPage

value = ImGearProcessing.CreateThumbnail(page, width, height, options)
public static ImGearPage CreateThumbnail(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)
public: static ImGearPage* CreateThumbnail(
   ImGearPage* page,
   int width,
   int height,
   ImGearInterpolationOptions* options
)
public:
static ImGearPage^ CreateThumbnail(
   ImGearPage^ page,
   int width,
   int height,
   ImGearInterpolationOptions^ options
)

Parameters

page
Source image from which the thumbnail is created.
width
Width of the thumbnail.
height
Height of the thumbnail.
options
Interpolation options.

Return Value

New thumbnail image.
Remarks
This method processes all channels of the image.

Interpolation options depend on the color space and bit depth of the image. Grayscale, PreserveBlack and PreserveWhite interpolations are applicable only to 1 bit images.

Average and Bilinear interpolations are not applicable to 1 bit images nor to images having a non-gray palette. Also, Bilinear interpolation cannot be applied to the images if one of the dimensions is decreased.

Use ImGearProcessingVerifier.CanApplyCreateThumbnail method to check whether the operation can be performed.

Example
  • C#
// Creates a thumbnail 100 pixels wide maintaining aspect ratio.

// Determine appropriate height.
int newHeight = 100 * igPage.DIB.Height / igPage.DIB.Width;

// Set default interpolation to none.
ImGearInterpolations igInterpolations = ImGearInterpolations.NONE;

// If the image is 1-bit and larger than 100x100, use grayscale interpolation.
if (igPage is ImGearRasterPage &&
    1 == igPage.DIB.BitDepth &&
    igPage.DIB.Width >= 100 &&
    igPage.DIB.Height >= 100)
{
    igInterpolations = ImGearInterpolations.GRAYSCALE;
}

// Create the thumbnail using the default options for the chosen interpolation.
ImGearPage igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight,
    ImGearInterpolationOptions.GetDefault(igInterpolations));
  • Visual Basic
' Creates a thumbnail 100 pixels wide maintaining aspect ratio.

' Determine appropriate height.
Dim newHeight As Integer = 100 * igPage.DIB.Height / igPage.DIB.Width

' Set default interpolation to none.
Dim igInterpolations As ImGearInterpolations = ImGearInterpolations.NONE

' If the image is 1-bit and larger than 100x100, use grayscale interpolation.
If TypeOf igPage Is ImGearRasterPage AndAlso 1 = igPage.DIB.BitDepth AndAlso _
 igPage.DIB.Width >= 100 AndAlso igPage.DIB.Height >= 100 Then
    igInterpolations = ImGearInterpolations.GRAYSCALE
End If

' Create the thumbnail using the default options for the chosen interpolation.
Dim igPageThumbnail As ImGearPage
igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight, _
 ImGearInterpolationOptions.GetDefault(igInterpolations))
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearRasterPage Class
ImGearInterpolationOptions Class
CanApplyCreateThumbnail Method
ImGearPage Class


Crop Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : Crop Method
Image to crop.
Left border of the new image.
Top border of the new image.
Width of the new image.
Height of the new image.
Crops an image according to the specified offsets and dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Crop( _
   ByVal page As ImGearPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim page As ImGearPage
Dim left As Integer
Dim top As Integer
Dim width As Integer
Dim height As Integer

ImGearProcessing.Crop(page, left, top, width, height)
public static void Crop(
   ImGearPage page,
   int left,
   int top,
   int width,
   int height
)
public: static void Crop(
   ImGearPage* page,
   int left,
   int top,
   int width,
   int height
)
public:
static void Crop(
   ImGearPage^ page,
   int left,
   int top,
   int width,
   int height
)

Parameters

page
Image to crop.
left
Left border of the new image.
top
Top border of the new image.
width
Width of the new image.
height
Height of the new image.
Remarks
This method processes all channels of the image. It may shift reference point of image's ROI, if it exists, but does not crop it.

ImGearProcessingVerifier.CanApplyCrop method can be called to check whether the operation can be performed.

Example
  • C#
// Crops 100 pixels off the top of an image.
ImGearProcessing.Crop(igRasterPage, 0, 100, igRasterPage.DIB.Width, igRasterPage.DIB.Height - 100);
  • Visual Basic
' Crops 100 pixels off the top of an image.
ImGearProcessing.Crop(igRasterPage, 0, 100, igRasterPage.DIB.Width, igRasterPage.DIB.Height - 100)
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearPage Class
CanApplyCrop Method


Flip Method (ImGearProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : Flip Method
Image to flip.
Constant defining flip direction. Possible values are ImageGear.Core.ImGearFlipModes.HORIZONTAL and ImageGear.Core.ImGearFlipModes.VERTICAL.
Flips an image in vertical or horizontal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Flip( _
   ByVal page As ImGearPage, _
   ByVal mode As ImGearFlipModes _
)
'Usage

Dim page As ImGearPage
Dim mode As ImGearFlipModes

ImGearProcessing.Flip(page, mode)
public static void Flip(
   ImGearPage page,
   ImGearFlipModes mode
)
public: static void Flip(
   ImGearPage* page,
   ImGearFlipModes mode
)
public:
static void Flip(
   ImGearPage^ page,
   ImGearFlipModes mode
)

Parameters

page
Image to flip.
mode
Constant defining flip direction. Possible values are ImageGear.Core.ImGearFlipModes.HORIZONTAL and ImageGear.Core.ImGearFlipModes.VERTICAL.
Remarks
This method processes all channels of the image as well as image's ROI, if it exists.

ImGearProcessingVerifier.CanApplyFlip method can be called to check whether the operation can be performed.

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearPage Class
CanApplyFlip Method
ImGearFlipModes Enumeration


Resize Method (ImGearProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : Resize Method
Image to resize.
New image width.
New image height.
Interpolation options.
Resizes an image according to the specified dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Resize( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal options As ImGearInterpolationOptions _
)
'Usage

Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim options As ImGearInterpolationOptions

ImGearProcessing.Resize(page, width, height, options)
public static void Resize(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)
public: static void Resize(
   ImGearPage* page,
   int width,
   int height,
   ImGearInterpolationOptions* options
)
public:
static void Resize(
   ImGearPage^ page,
   int width,
   int height,
   ImGearInterpolationOptions^ options
)

Parameters

page
Image to resize.
width
New image width.
height
New image height.
options
Interpolation options.
Remarks
This method processes all channels of the image as well as the image's ROI, if it exists.

Interpolation options are ignored when resizing vector images.

Applicability of interpolation options to raster images depend on the color space and bit depth of the image. The following table specifies applicability of interpolation options to different types of raster images.

ImGearInterpolations | Bitonal images | Non-bitonal images
NONE | Yes | Yes
AVERAGE | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
BILINEAR | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
NEAREST_NEIGHBOR | Yes | Yes
GRAYSCALE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_WHITE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_BLACK | Only if both new width and height are not greater than original width and height. | No
BICUBIC | No | Yes, except indexed images where palette is not grayscale or inverted grayscale.

ImGearProcessingVerifier.CanApplyResize method can be called to check whether the operation can be performed.

This method is not supported for vector PDF pages.

Example
  • C#
// Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
int newHeight = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width;
ImGearBicubicInterpolationOptions igBicubicInterpolationOptions = new ImGearBicubicInterpolationOptions();
igBicubicInterpolationOptions.Sharpness = 1.5;
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions);
  • Visual Basic
' Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
Dim newHeight As Integer = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width
Dim igBicubicInterpolationOptions As New ImGearBicubicInterpolationOptions()
igBicubicInterpolationOptions.Sharpness = 1.5
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions)
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearPage Class


ResizeCanvas Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : ResizeCanvas Method
Image to resize.
New image width.
New image height.
X offset at which to put left top corner of the image after resize.
Y offset at which to put left top corner of the image after resize.
Background color to fill the out of picture area; null (Nothing in VB NET) results in black background.
This method changes the dimensions of the ImageGear.Core.ImGearPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ResizeCanvas( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer, _
   ByVal background As ImGearPixel _
)
'Usage

Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim offsetX As Integer
Dim offsetY As Integer
Dim background As ImGearPixel

ImGearProcessing.ResizeCanvas(page, width, height, offsetX, offsetY, background)
public static void ResizeCanvas(
   ImGearPage page,
   int width,
   int height,
   int offsetX,
   int offsetY,
   ImGearPixel background
)
public: static void ResizeCanvas(
   ImGearPage* page,
   int width,
   int height,
   int offsetX,
   int offsetY,
   ImGearPixel* background
)
public:
static void ResizeCanvas(
   ImGearPage^ page,
   int width,
   int height,
   int offsetX,
   int offsetY,
   ImGearPixel^ background
)

Parameters

page
Image to resize.
width
New image width.
height
New image height.
offsetX
X offset at which to put left top corner of the image after resize.
offsetY
Y offset at which to put left top corner of the image after resize.
background
Background color to fill the out of picture area; null (Nothing in VB NET) results in black background.
Remarks
The image data in the bitmap is not stretched or compressed, but copied to the specified offset in the new image.

Use ImGearProcessingVerifier.CanApplyResizeCanvas method to check whether the operation can be performed on the specified image.

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearPage Class
CanApplyResizeCanvas Method


Rotate Method (ImGearProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : Rotate Method
Rotates an image.
Overload List
Overload | Description
Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel) | Rotates an image.
Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) | Rotates an image using interpolation.
Rotate(ImGearPage,ImGearRotationValues) | Rotates an image on 90, 180, or 270 degrees.
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class > Rotate Method : Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel) Method
Image to rotate.
Rotation angle in degrees.
Rotation mode. ImGearRotationModes.CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut. ImGearRotationModes.EXPAND changes the image size according to the new picture boundary.
Background color to fill the out of picture area. Can be null (Nothing in VB NET).
Rotates an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Rotate( _
   ByVal page As ImGearPage, _
   ByVal angle As Double, _
   ByVal mode As ImGearRotationModes, _
   ByVal background As ImGearPixel _
)
'Usage

Dim page As ImGearPage
Dim angle As Double
Dim mode As ImGearRotationModes
Dim background As ImGearPixel

ImGearProcessing.Rotate(page, angle, mode, background)
public static void Rotate(
   ImGearPage page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel background
)
public: static void Rotate(
   ImGearPage* page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel* background
)
public:
static void Rotate(
   ImGearPage^ page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel^ background
)

Parameters

page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode. ImGearRotationModes.CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut. ImGearRotationModes.EXPAND changes the image size according to the new picture boundary.
background
Background color to fill the out of picture area. Can be null (Nothing in VB NET).
Remarks
This method processes all channels of the image as well as image's ROI, if it exists.

Background should be in the same color space as the Page, including Alpha and Extra channels. Background must have the same channel count and bit depth as a DIB?s color space.

Use CanApplyRotate method to check whether the operation can be performed.

Example
  • C#
// Find the skew angle of an image.
double angle = ImGearRasterProcessing.FindSkewAngle(igRasterPage);

// Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, null);
  • Visual Basic
' Find the skew angle of an image.
Dim angle As Double = ImGearRasterProcessing.FindSkewAngle(igRasterPage)

' Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, Nothing)
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List
ImGearPage Class
ImGearRotationModes Enumeration
ImGearPixel Class


Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class > Rotate Method : Rotate(ImGearPage,Double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) Method
Image to rotate.
Rotation angle in degrees.
Rotation mode (clip or expand).
Background color to fill the out of picture area; null (Nothing in VB NET) results in black background.
Interpolation to use for rotation.
Rotates an image using interpolation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Rotate( _
   ByVal page As ImGearPage, _
   ByVal angle As Double, _
   ByVal mode As ImGearRotationModes, _
   ByVal background As ImGearPixel, _
   ByVal interpolation As ImGearInterpolations _
)
'Usage

Dim page As ImGearPage
Dim angle As Double
Dim mode As ImGearRotationModes
Dim background As ImGearPixel
Dim interpolation As ImGearInterpolations

ImGearProcessing.Rotate(page, angle, mode, background, interpolation)
public static void Rotate(
   ImGearPage page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel background,
   ImGearInterpolations interpolation
)
public: static void Rotate(
   ImGearPage* page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel* background,
   ImGearInterpolations interpolation
)
public:
static void Rotate(
   ImGearPage^ page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel^ background,
   ImGearInterpolations interpolation
)

Parameters

page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode (clip or expand).
background
Background color to fill the out of picture area; null (Nothing in VB NET) results in black background.
interpolation
Interpolation to use for rotation.
Remarks
This method processes all channels of the image as well as image's ROI, if it exists.

Background should be in the same color space as the Page, including Alpha and Extra channels. Background must have the same channel count and bit depth as a DIB?s color space.

Use CanApplyRotate method to check whether the operation can be performed.

Supported interpolations are BILINEAR and BICUBIC. Interpolation is supported for non-indexed images, and for indexed images with grayscale palette. It is not supported for 1bpp images.

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List
ImGearPage Class
ImGearRotationModes Enumeration
ImGearPixel Class
ImGearInterpolations Enumeration


Rotate(ImGearPage,ImGearRotationValues) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class > Rotate Method : Rotate(ImGearPage,ImGearRotationValues) Method
Image to rotate.
A value specifying the rotation angle: 0, 90, 180 or 270 degrees.
Rotates an image on 90, 180, or 270 degrees.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Rotate( _
   ByVal page As ImGearPage, _
   ByVal rotationValue As ImGearRotationValues _
)
'Usage

Dim page As ImGearPage
Dim rotationValue As ImGearRotationValues

ImGearProcessing.Rotate(page, rotationValue)
public static void Rotate(
   ImGearPage page,
   ImGearRotationValues rotationValue
)
public: static void Rotate(
   ImGearPage* page,
   ImGearRotationValues rotationValue
)
public:
static void Rotate(
   ImGearPage^ page,
   ImGearRotationValues rotationValue
)

Parameters

page
Image to rotate.
rotationValue
A value specifying the rotation angle: 0, 90, 180 or 270 degrees.
Remarks
This method rotates ImageGear.Core.ImGearPage class object on 90, 180, or 270 degrees. Processes all channels of the image and ROI.

Rotation direction is clockwise (left coordinate system).

Rotation on 90 and 270 degrees changes image dimensions.

Use CanApplyRotate method to check whether the operation can be performed.

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List
ImGearPage Class
ImGearRotationValues Enumeration


%%PageItemTitle%% $$Properties$$

ImGearProcessing Class Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessing Class

For a list of all members of this type, see ImGearProcessing members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets ImGearProcessingVerifier class object.
Top
See Also

Reference

ImGearProcessing Class
ImageGear.Processing Namespace
ImGearProcessingVerifier Class


Verifier Property (ImGearProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessing Class : Verifier Property
Gets ImGearProcessingVerifier class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGearProcessingVerifier
'Usage

Dim value As ImGearProcessingVerifier

value = ImGearProcessing.Verifier
public static ImGearProcessingVerifier Verifier {get;}
public: __property static ImGearProcessingVerifier* get_Verifier();
public:
static property ImGearProcessingVerifier^ Verifier {
   ImGearProcessingVerifier^ get();
}

Property Value

ImGearProcessingVerifier class object.
See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
ImGearProcessingVerifier Class


%%PageItemTitle%%

ImGearProcessingVerifier Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessingVerifier Class
Contains static methods that check whether particular ImGearProcessing operations are applicable to the page.
Object Model
ImGearProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearProcessingVerifier
'Usage

Dim instance As ImGearProcessingVerifier
public sealed class ImGearProcessingVerifier
public __gc __sealed class ImGearProcessingVerifier
public ref class ImGearProcessingVerifier sealed
Remarks
These methods should be used to distinguish a sub-set of pages for which a particular filter is applicable.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearProcessingVerifier

See Also

Reference

ImGearProcessingVerifier Members
ImageGear.Processing Namespace
ImGearProcessing Class


%%PageItemTitle%% $$Members$$

ImGearProcessingVerifier Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessingVerifier Class

The following tables list the members exposed by ImGearProcessingVerifier.

Public Methods
 | Name | Description
Public Method | CanApplyCreateThumbnail | Returns true if ImGearProcessing.CreateThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.
Public Method | CanApplyCrop | Returns true if ImGearProcessing.Crop method can be applied to the specified page, false otherwise.
Public Method | CanApplyFlip | Returns true if ImGearProcessing.Flip method can be applied to the specified page, false otherwise.
Public Method | CanApplyResize | Verifies if ImGearProcessing.Resize method can be applied to the Page.
Public Method | CanApplyResizeCanvas | Returns true if ImGearProcessing.ResizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.
Public Method | CanApplyRotate | Overloaded. Returns true if the Rotate Method can be applied to the specified Page, false otherwise.
Top
See Also

Reference

ImGearProcessingVerifier Class
ImageGear.Processing Namespace
ImGearProcessing Class


%%PageItemTitle%% $$Methods$$

ImGearProcessingVerifier Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearProcessingVerifier Class

For a list of all members of this type, see ImGearProcessingVerifier members.

Public Methods
 | Name | Description
Public Method | CanApplyCreateThumbnail | Returns true if ImGearProcessing.CreateThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.
Public Method | CanApplyCrop | Returns true if ImGearProcessing.Crop method can be applied to the specified page, false otherwise.
Public Method | CanApplyFlip | Returns true if ImGearProcessing.Flip method can be applied to the specified page, false otherwise.
Public Method | CanApplyResize | Verifies if ImGearProcessing.Resize method can be applied to the Page.
Public Method | CanApplyResizeCanvas | Returns true if ImGearProcessing.ResizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.
Public Method | CanApplyRotate | Overloaded. Returns true if the Rotate Method can be applied to the specified Page, false otherwise.
Top
See Also

Reference

ImGearProcessingVerifier Class
ImageGear.Processing Namespace
ImGearProcessing Class


CanApplyCreateThumbnail Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyCreateThumbnail Method
Page to verify.
Page width.
Page height.
Interpolation options.
Returns true if ImGearProcessing.CreateThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCreateThumbnail( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal options As ImGearInterpolationOptions _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim options As ImGearInterpolationOptions
Dim value As Boolean

value = instance.CanApplyCreateThumbnail(page, width, height, options)
public bool CanApplyCreateThumbnail(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)
public: bool CanApplyCreateThumbnail(
   ImGearPage* page,
   int width,
   int height,
   ImGearInterpolationOptions* options
)
public:
bool CanApplyCreateThumbnail(
   ImGearPage^ page,
   int width,
   int height,
   ImGearInterpolationOptions^ options
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
CreateThumbnail Method
ImGearPage Class
ImGearInterpolationOptions Class


CanApplyCrop Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyCrop Method
Page to verify.
Returns true if ImGearProcessing.Crop method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCrop( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyCrop(page)
public bool CanApplyCrop(
   ImGearPage page
)
public: bool CanApplyCrop(
   ImGearPage* page
)
public:
bool CanApplyCrop(
   ImGearPage^ page
)

Parameters

page
Page to verify.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Crop Method
ImGearPage Class


CanApplyFlip Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyFlip Method
Page to verify.
Returns true if ImGearProcessing.Flip method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFlip( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyFlip(page)
public bool CanApplyFlip(
   ImGearPage page
)
public: bool CanApplyFlip(
   ImGearPage* page
)
public:
bool CanApplyFlip(
   ImGearPage^ page
)

Parameters

page
Page to verify.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Flip Method
ImGearPage Class


CanApplyResize Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyResize Method
Page to verify.
Page width.
Page height.
Interpolation options.
Verifies if ImGearProcessing.Resize method can be applied to the Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyResize( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal options As ImGearInterpolationOptions _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim options As ImGearInterpolationOptions
Dim value As Boolean

value = instance.CanApplyResize(page, width, height, options)
public bool CanApplyResize(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)
public: bool CanApplyResize(
   ImGearPage* page,
   int width,
   int height,
   ImGearInterpolationOptions* options
)
public:
bool CanApplyResize(
   ImGearPage^ page,
   int width,
   int height,
   ImGearInterpolationOptions^ options
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Return Value

Boolean value.
Remarks
Returns true if ImGearProcessing.Resize method can be applied to the specified page, with the specified dimensions and interpolation, false otherwise.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Resize Method
ImGearPage Class
ImGearInterpolationOptions Class


CanApplyResizeCanvas Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyResizeCanvas Method
Page to verify.
Page width.
Page height.
Returns true if ImGearProcessing.ResizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyResizeCanvas( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim value As Boolean

value = instance.CanApplyResizeCanvas(page, width, height)
public bool CanApplyResizeCanvas(
   ImGearPage page,
   int width,
   int height
)
public: bool CanApplyResizeCanvas(
   ImGearPage* page,
   int width,
   int height
)
public:
bool CanApplyResizeCanvas(
   ImGearPage^ page,
   int width,
   int height
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
ResizeCanvas Method
ImGearPage Class


CanApplyRotate Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class : CanApplyRotate Method
Returns true if the Rotate Method can be applied to the specified Page, false otherwise.
Overload List
Overload | Description
CanApplyRotate(ImGearPage,ImGearRotationModes) | Returns true if the Rotate Method can be applied to the specified Page, false otherwise.
CanApplyRotate(ImGearPage,ImGearInterpolations) | Returns true if Rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.
CanApplyRotate(ImGearPage,ImGearRotationValues) | Returns true if the Rotate Method can be applied to the specified page, with the specified rotationValue, false otherwise.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


CanApplyRotate(ImGearPage,ImGearRotationModes) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class > CanApplyRotate Method : CanApplyRotate(ImGearPage,ImGearRotationModes) Method
Page to verify.
Rotation mode.
Returns true if the Rotate Method can be applied to the specified Page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyRotate( _
   ByVal page As ImGearPage, _
   ByVal rotationMode As ImGearRotationModes _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim rotationMode As ImGearRotationModes
Dim value As Boolean

value = instance.CanApplyRotate(page, rotationMode)
public bool CanApplyRotate(
   ImGearPage page,
   ImGearRotationModes rotationMode
)
public: bool CanApplyRotate(
   ImGearPage* page,
   ImGearRotationModes rotationMode
)
public:
bool CanApplyRotate(
   ImGearPage^ page,
   ImGearRotationModes rotationMode
)

Parameters

page
Page to verify.
rotationMode
Rotation mode.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List
ImGearPage Class


CanApplyRotate(ImGearPage,ImGearInterpolations) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class > CanApplyRotate Method : CanApplyRotate(ImGearPage,ImGearInterpolations) Method
Page to verify.
Specified interpolation.
Returns true if Rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyRotate( _
   ByVal page As ImGearPage, _
   ByVal interpolation As ImGearInterpolations _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim interpolation As ImGearInterpolations
Dim value As Boolean

value = instance.CanApplyRotate(page, interpolation)
public bool CanApplyRotate(
   ImGearPage page,
   ImGearInterpolations interpolation
)
public: bool CanApplyRotate(
   ImGearPage* page,
   ImGearInterpolations interpolation
)
public:
bool CanApplyRotate(
   ImGearPage^ page,
   ImGearInterpolations interpolation
)

Parameters

page
Page to verify.
interpolation
Specified interpolation.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List
ImGearPage Class
ImGearInterpolations Enumeration


CanApplyRotate(ImGearPage,ImGearRotationValues) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearProcessingVerifier Class > CanApplyRotate Method : CanApplyRotate(ImGearPage,ImGearRotationValues) Method
Page to verify.
Rotation value.
Returns true if the Rotate Method can be applied to the specified page, with the specified rotationValue, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyRotate( _
   ByVal page As ImGearPage, _
   ByVal rotationValue As ImGearRotationValues _
) As Boolean
'Usage

Dim instance As ImGearProcessingVerifier
Dim page As ImGearPage
Dim rotationValue As ImGearRotationValues
Dim value As Boolean

value = instance.CanApplyRotate(page, rotationValue)
public bool CanApplyRotate(
   ImGearPage page,
   ImGearRotationValues rotationValue
)
public: bool CanApplyRotate(
   ImGearPage* page,
   ImGearRotationValues rotationValue
)
public:
bool CanApplyRotate(
   ImGearPage^ page,
   ImGearRotationValues rotationValue
)

Parameters

page
Page to verify.
rotationValue
Rotation value.

Return Value

Boolean value.
See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List
ImGearPage Class
ImGearPixel Class


%%PageItemTitle%%

ImGearRasterProcessing Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessing Class
Contains IG raster processing methods.
Object Model
ImGearRasterProcessing ClassImGearChannelStatistics StructureImGearRasterPage ClassImGearRasterPage ClassImGearChannelRef StructureImGearRasterProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRasterProcessing
'Usage

Dim instance As ImGearRasterProcessing
public sealed class ImGearRasterProcessing
public __gc __sealed class ImGearRasterProcessing
public ref class ImGearRasterProcessing sealed
Remarks
This is the main class for all image raster processing operations.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearRasterProcessing

See Also

Reference

ImGearRasterProcessing Members
ImageGear.Processing Namespace
ImGearRasterProcessingVerifier Class


%%PageItemTitle%% $$Members$$

ImGearRasterProcessing Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessing Class

The following tables list the members exposed by ImGearRasterProcessing.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets ImGearRasterProcessingVerifier class object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddTilt | Adds a specified plane to the input image to correct for a tilt in the image luminance.
static (Shared in Visual Basic) | AdjustContrast | Overloaded. Adjusts contrast, brightness, and gamma.
static (Shared in Visual Basic) | Blend | Overloaded. Blends two images based on the weight (in percents) of the secondary image.
static (Shared in Visual Basic) | BlendWithAlpha | Blends two images with alpha channel.
static (Shared in Visual Basic) | CalculateStatistics | Calculates statistics for all channels of the image, separately for each channel.
static (Shared in Visual Basic) | ChangeChannelDepths | Overloaded. Changes bit depths of image channels.
static (Shared in Visual Basic) | Close | Applies closing effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | CombineChannels | Combines image channels according to the specified color space.
static (Shared in Visual Basic) | ConvertColorSpace | Overloaded. Converts page to a new color space.
static (Shared in Visual Basic) | ConvertPixelFormat | Overloaded. Converts a single pixel to color space and channel depths of the specified ImageGear.Core.ImGearPage class object.
static (Shared in Visual Basic) | Convolve | Provides filtering on the base of 2-dimensional convolution matrix.
static (Shared in Visual Basic) | CreateChannelCopy | Overloaded. Copies a channel to a new page.
static (Shared in Visual Basic) | Decrypt | Decrypts a raster page.
static (Shared in Visual Basic) | Deskew | Deskews an image page.
static (Shared in Visual Basic) | Despeckle | Removes color noise from a binary (1-bit) image.
static (Shared in Visual Basic) | Dilate | Applies dilation effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Encrypt | Encrypts a raster page.
static (Shared in Visual Basic) | EnhanceLocal | Enhances an image using the local standard deviation and mean.
static (Shared in Visual Basic) | EqualizeContrast | Overloaded. Equalizes image contrast.
static (Shared in Visual Basic) | Erode | Applies erosion effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Export | Overloaded. Exports content of raster page to managed GDI+ image.
static (Shared in Visual Basic) | Fill | Fills the image by specified solid color.
static (Shared in Visual Basic) | FilterWithMedian | Overloaded. Removes color noise from the image.
static (Shared in Visual Basic) | FilterWithUnsharpMask | Overloaded. Provides UnsharpMask filtering.
static (Shared in Visual Basic) | FindSkewAngle | Determines skew angle.
static (Shared in Visual Basic) | FindTilt | Computes the least-squares best fit plane for an image.
static (Shared in Visual Basic) | GaussianBlur | Overloaded. Blurs an image using Gaussian transform.
static (Shared in Visual Basic) | GeomDespeckle | Reduces speckle noise from an image by using the Crimmins algorithm.
static (Shared in Visual Basic) | ImageIsGray | Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.
static (Shared in Visual Basic) | InsertChannel | Inserts a channel to the page's DIB and changes page's color space.
static (Shared in Visual Basic) | InvertContrast | Overloaded. Inverts image contrast.
static (Shared in Visual Basic) | Merge | Overloaded. Merges two images according to the specified merge mode.
static (Shared in Visual Basic) | Open | Applies opening effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Reduce | Reduces bit depth of an image using the specified reduction method.
static (Shared in Visual Basic) | RemoveChannel | Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.
static (Shared in Visual Basic) | RemoveTilt | This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
static (Shared in Visual Basic) | SeparateChannels | Creates an array of pages, where each page contains one channel with color space set to grayscale.
static (Shared in Visual Basic) | Sharpen | Overloaded. Sharpens an image according to the specified sharpen factor.
static (Shared in Visual Basic) | Smooth | Overloaded. Provides smooth filtering.
static (Shared in Visual Basic) | StretchContrast | Overloaded. Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
static (Shared in Visual Basic) | SwapChannels | Swaps two channels in page's DIB.
static (Shared in Visual Basic) | TabulateHistogram | Tabulates histograms for all image channels.
static (Shared in Visual Basic) | TransformWithLUT | Applies lookup tables to each channel of the image, optionally changing channel depths.
static (Shared in Visual Basic) | UpdateChannelFrom | Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.
Top
See Also

Reference

ImGearRasterProcessing Class
ImageGear.Processing Namespace
ImGearRasterProcessingVerifier Class


%%PageItemTitle%% $$Methods$$

ImGearRasterProcessing Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessing Class

For a list of all members of this type, see ImGearRasterProcessing members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddTilt | Adds a specified plane to the input image to correct for a tilt in the image luminance.
static (Shared in Visual Basic) | AdjustContrast | Overloaded. Adjusts contrast, brightness, and gamma.
static (Shared in Visual Basic) | Blend | Overloaded. Blends two images based on the weight (in percents) of the secondary image.
static (Shared in Visual Basic) | BlendWithAlpha | Blends two images with alpha channel.
static (Shared in Visual Basic) | CalculateStatistics | Calculates statistics for all channels of the image, separately for each channel.
static (Shared in Visual Basic) | ChangeChannelDepths | Overloaded. Changes bit depths of image channels.
static (Shared in Visual Basic) | Close | Applies closing effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | CombineChannels | Combines image channels according to the specified color space.
static (Shared in Visual Basic) | ConvertColorSpace | Overloaded. Converts page to a new color space.
static (Shared in Visual Basic) | ConvertPixelFormat | Overloaded. Converts a single pixel to color space and channel depths of the specified ImageGear.Core.ImGearPage class object.
static (Shared in Visual Basic) | Convolve | Provides filtering on the base of 2-dimensional convolution matrix.
static (Shared in Visual Basic) | CreateChannelCopy | Overloaded. Copies a channel to a new page.
static (Shared in Visual Basic) | Decrypt | Decrypts a raster page.
static (Shared in Visual Basic) | Deskew | Deskews an image page.
static (Shared in Visual Basic) | Despeckle | Removes color noise from a binary (1-bit) image.
static (Shared in Visual Basic) | Dilate | Applies dilation effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Encrypt | Encrypts a raster page.
static (Shared in Visual Basic) | EnhanceLocal | Enhances an image using the local standard deviation and mean.
static (Shared in Visual Basic) | EqualizeContrast | Overloaded. Equalizes image contrast.
static (Shared in Visual Basic) | Erode | Applies erosion effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Export | Overloaded. Exports content of raster page to managed GDI+ image.
static (Shared in Visual Basic) | Fill | Fills the image by specified solid color.
static (Shared in Visual Basic) | FilterWithMedian | Overloaded. Removes color noise from the image.
static (Shared in Visual Basic) | FilterWithUnsharpMask | Overloaded. Provides UnsharpMask filtering.
static (Shared in Visual Basic) | FindSkewAngle | Determines skew angle.
static (Shared in Visual Basic) | FindTilt | Computes the least-squares best fit plane for an image.
static (Shared in Visual Basic) | GaussianBlur | Overloaded. Blurs an image using Gaussian transform.
static (Shared in Visual Basic) | GeomDespeckle | Reduces speckle noise from an image by using the Crimmins algorithm.
static (Shared in Visual Basic) | ImageIsGray | Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.
static (Shared in Visual Basic) | InsertChannel | Inserts a channel to the page's DIB and changes page's color space.
static (Shared in Visual Basic) | InvertContrast | Overloaded. Inverts image contrast.
static (Shared in Visual Basic) | Merge | Overloaded. Merges two images according to the specified merge mode.
static (Shared in Visual Basic) | Open | Applies opening effect to provided raster page using the specified structuring element.
static (Shared in Visual Basic) | Reduce | Reduces bit depth of an image using the specified reduction method.
static (Shared in Visual Basic) | RemoveChannel | Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.
static (Shared in Visual Basic) | RemoveTilt | This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
static (Shared in Visual Basic) | SeparateChannels | Creates an array of pages, where each page contains one channel with color space set to grayscale.
static (Shared in Visual Basic) | Sharpen | Overloaded. Sharpens an image according to the specified sharpen factor.
static (Shared in Visual Basic) | Smooth | Overloaded. Provides smooth filtering.
static (Shared in Visual Basic) | StretchContrast | Overloaded. Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
static (Shared in Visual Basic) | SwapChannels | Swaps two channels in page's DIB.
static (Shared in Visual Basic) | TabulateHistogram | Tabulates histograms for all image channels.
static (Shared in Visual Basic) | TransformWithLUT | Applies lookup tables to each channel of the image, optionally changing channel depths.
static (Shared in Visual Basic) | UpdateChannelFrom | Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.
Top
See Also

Reference

ImGearRasterProcessing Class
ImageGear.Processing Namespace
ImGearRasterProcessingVerifier Class


AddTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : AddTilt Method
Adds a specified plane to the input image to correct for a tilt in the image luminance.
Overload List
Overload | Description
AddTilt | Adds a specified plane to the input image to correct for a tilt in the image luminance.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


AddTilt(ImGearRasterPage,Double,Double) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : AddTilt(ImGearRasterPage,Double,Double) Method
An ImageGear.Core.ImGearRasterPage class object to process.
Specifies the slope of the plane in X direction, in units per pixel.
Specifies the slope of the plane in Y direction, in units per pixel.
Adds a specified plane to the input image to correct for a tilt in the image luminance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub AddTilt( _
   ByVal page As ImGearRasterPage, _
   ByVal slopeX As Double, _
   ByVal slopeY As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim slopeX As Double
Dim slopeY As Double

ImGearRasterProcessing.AddTilt(page, slopeX, slopeY)
public static void AddTilt(
   ImGearRasterPage page,
   double slopeX,
   double slopeY
)
public: static void AddTilt(
   ImGearRasterPage* page,
   double slopeX,
   double slopeY
)
public:
static void AddTilt(
   ImGearRasterPage^ page,
   double slopeX,
   double slopeY
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to process.
slopeX
Specifies the slope of the plane in X direction, in units per pixel.
slopeY
Specifies the slope of the plane in Y direction, in units per pixel.
Remarks
This method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with dSlopeX and dSlopeY as specified in the arguments.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

Example
  • C#
// Find the tilt of an image.
double slopeX, slopeY, piston;
ImGearRasterProcessing.FindTilt(igRasterPage, out slopeX, out slopeY, out piston);

// Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY);
  • Visual Basic
' Find the tilt of an image.
Dim slopeX As Double, slopeY As Double, piston As Double
ImGearRasterProcessing.FindTilt(igRasterPage, slopeX, slopeY, piston)

' Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


AdjustContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : AdjustContrast Method
Adjusts contrast, brightness, and gamma.
Overload List
Overload | Description
AdjustContrast(ImGearRasterPage,Double,Double,Double) | Adjusts contrast, brightness, and gamma.
AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange) | This method adjusts contrast, brightness, and gamma.
AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) | This method adjusts contrast, brightness, and gamma.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


AdjustContrast(ImGearRasterPage,Double,Double,Double) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > AdjustContrast Method : AdjustContrast(ImGearRasterPage,Double,Double,Double) Method
Image to adjust contrast.
Contrast value.
Brightness value.
Gamma value.
Adjusts contrast, brightness, and gamma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub AdjustContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal contrast As Double, _
   ByVal brightness As Double, _
   ByVal gamma As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim contrast As Double
Dim brightness As Double
Dim gamma As Double

ImGearRasterProcessing.AdjustContrast(page, contrast, brightness, gamma)
public static void AdjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma
)
public: static void AdjustContrast(
   ImGearRasterPage* page,
   double contrast,
   double brightness,
   double gamma
)
public:
static void AdjustContrast(
   ImGearRasterPage^ page,
   double contrast,
   double brightness,
   double gamma
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
Remarks
If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. Processes only color channels. Contrast mode is ImGearContrastModes.AUTO.

Average parameter range:

  • Contrast: -2 ... +2 (negative means contrast inversion. In case of 1 no changes)
  • Brightness: -128...+128
  • Gamma: 0...10

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier.CanApplyAdjustContrast (ImGearPage page) can be called to check whether the operation can be performed.

Example
  • C#
// Increases the contrast, lowers the brightness, and increases the gamma a little.
ImGearRasterProcessing.AdjustContrast(igRasterPage, 1.4, -40, 3.5);
  • Visual Basic
' Increases the contrast, lowers the brightness, and increases the gamma a little.
ImGearRasterProcessing.AdjustContrast(igRasterPage, 1.4, -40, 3.5)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > AdjustContrast Method : AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange) Method
Image to adjust contrast.
Contrast value.
Brightness value.
Gamma value.
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have a palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
Structure that defines the channel range to process.
This method adjusts contrast, brightness, and gamma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub AdjustContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal contrast As Double, _
   ByVal brightness As Double, _
   ByVal gamma As Double, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim contrast As Double
Dim brightness As Double
Dim gamma As Double
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange

ImGearRasterProcessing.AdjustContrast(page, contrast, brightness, gamma, mode, channels)
public static void AdjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public: static void AdjustContrast(
   ImGearRasterPage* page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public:
static void AdjustContrast(
   ImGearRasterPage^ page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have a palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines the channel range to process.
Remarks
Processes the specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.CanApplyAdjustContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearContrastOptions Class
ImGearContrastModes Enumeration
ImGearChannelRange Structure
ImGearRasterPage Class


AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > AdjustContrast Method : AdjustContrast(ImGearRasterPage,Double,Double,Double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
Image to adjust contrast.
Contrast value.
Brightness value.
Gamma value.
One of the following values:ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
Structure that defines channel range to process.
ImGearContrastOptions class object.
This method adjusts contrast, brightness, and gamma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub AdjustContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal contrast As Double, _
   ByVal brightness As Double, _
   ByVal gamma As Double, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange, _
   ByVal options As ImGearContrastOptions _
)
'Usage

Dim page As ImGearRasterPage
Dim contrast As Double
Dim brightness As Double
Dim gamma As Double
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange
Dim options As ImGearContrastOptions

ImGearRasterProcessing.AdjustContrast(page, contrast, brightness, gamma, mode, channels, options)
public static void AdjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions options
)
public: static void AdjustContrast(
   ImGearRasterPage* page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions* options
)
public:
static void AdjustContrast(
   ImGearRasterPage^ page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions^ options
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values:ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines channel range to process.
options
ImGearContrastOptions class object.
Remarks
Processes the specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use method ImGearRasterProcessingVerifier.CanApplyAdjustContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearContrastOptions Class
ImGearChannelRange Structure
ImGearContrastModes Enumeration
ImGearRasterPage Class


Blend Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Blend Method
Blends two images based on the weight (in percents) of the secondary image.
Overload List
Overload | Description
Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double) | Blends two images based on the weight (in percents) of the secondary image.
Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double,ImGearChannelRange) | Blends two images based on the weight (in percents) of the secondary image.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Blend Method : Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double) Method
Page to process.
Left margin of blended image.
Top margin of blended image.
Image to blend with page.
A value from 0 to 100 defining the % weight of the pageToBlendWith image to be blended.
Blends two images based on the weight (in percents) of the secondary image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Blend( _
   ByVal page As ImGearRasterPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal pageToBlendWith As ImGearRasterPage, _
   ByVal weight As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim left As Integer
Dim top As Integer
Dim pageToBlendWith As ImGearRasterPage
Dim weight As Double

ImGearRasterProcessing.Blend(page, left, top, pageToBlendWith, weight)
public static void Blend(
   ImGearRasterPage page,
   int left,
   int top,
   ImGearRasterPage pageToBlendWith,
   double weight
)
public: static void Blend(
   ImGearRasterPage* page,
   int left,
   int top,
   ImGearRasterPage* pageToBlendWith,
   double weight
)
public:
static void Blend(
   ImGearRasterPage^ page,
   int left,
   int top,
   ImGearRasterPage^ pageToBlendWith,
   double weight
)

Parameters

page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Image to blend with page.
weight
A value from 0 to 100 defining the % weight of the pageToBlendWith image to be blended.
Remarks

This method blends all channels of page with corresponding channels of pageToBlendWith, using the following formula:

pagePixel = (pagePixel * (100.0 - weight) + pageToBlendPixel * weight) / 100.0

The method validates input pages for further processing according to following logics:

  • This method is applicable to any colorspace, but both images must have the same base colorspace (i.e. upon validation of input images will be considered color channels only - Alpha or Extra channels will be ignored. So, for example, any combination of pages with RGB(A/Ex) colorspaces (e.g. RGB and RGBA) are valid input parameters).
  • This method is applicable to any supported by ImageGear channel depth for given colorspace, but channel depths of both images must be the same.

The method processes the input pages according to following logics:

  • This method processes all channels of input pages. In order to process a specific group of image channels, e.g. color channels only, use another overload Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double,ImGearChannelRange).
  • If page and pageToBlendWith have different number of channels, the method blends the minimal number of channels between the images. For example, for images with RGB and RGBEx colorspaces will be processed 3 channels. The remaining redundant channels will be handled as following:
    • If page has more channels than pageToBlendWith (an Alpha or Extras), they will remain intact.
    • If pageToBlendWith has more channels than page (an Alpha or Extras), they will be ignored.
  • This method does not not provide any special handling for the Alpha channel (i.e. it processes it as ordinary color channel), please use BlendWithAlpha method to blend images using the Alpha channel.

Example
  • C#
// Opens an image and blends it into an already open image.
using (FileStream file = new FileStream("photo.jpg",
                   FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igPageToBlend = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);

    // Blend the page with a weight of 25% starting from the point 100,100.
    ImGearRasterProcessing.Blend(igRasterPage, 100, 100, igPageToBlend, 25.0);
}
  • Visual Basic
' Opens an image and blends it into an already open image.
Using file As New FileStream("photo.jpg", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igPageToBlend As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)

    ' Blend the page with a weight of 25% starting from the point 100,100.
    ImGearRasterProcessing.Blend(igRasterPage, 100, 100, igPageToBlend, 25)
End Using
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
BlendWithAlpha Method
ImGearRasterPage Class


Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Blend Method : Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double,ImGearChannelRange) Method
Page to process.
Left margin of blended image.
Top margin of blended image.
Image to blend with page.
A value from 0 to 100 defining the % weight of the pageToBlendWith image to be blended.
Channel range to process.
Blends two images based on the weight (in percents) of the secondary image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Blend( _
   ByVal page As ImGearRasterPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal pageToBlendWith As ImGearRasterPage, _
   ByVal weight As Double, _
   ByVal channelsRange As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim left As Integer
Dim top As Integer
Dim pageToBlendWith As ImGearRasterPage
Dim weight As Double
Dim channelsRange As ImGearChannelRange

ImGearRasterProcessing.Blend(page, left, top, pageToBlendWith, weight, channelsRange)
public static void Blend(
   ImGearRasterPage page,
   int left,
   int top,
   ImGearRasterPage pageToBlendWith,
   double weight,
   ImGearChannelRange channelsRange
)
public: static void Blend(
   ImGearRasterPage* page,
   int left,
   int top,
   ImGearRasterPage* pageToBlendWith,
   double weight,
   ImGearChannelRange channelsRange
)
public:
static void Blend(
   ImGearRasterPage^ page,
   int left,
   int top,
   ImGearRasterPage^ pageToBlendWith,
   double weight,
   ImGearChannelRange channelsRange
)

Parameters

page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Image to blend with page.
weight
A value from 0 to 100 defining the % weight of the pageToBlendWith image to be blended.
channelsRange
Channel range to process.
Remarks

This method blends the specified channels of page with corresponding channels of pageToBlendWith, using the following formula:

pagePixel = (pagePixel * (100.0 - weight) + pageToBlendPixel * weight) / 100.0

The method validates input pages for further processing according to following logics:

  • This method is applicable to any colorspace, but both images must have the same base colorspace (i.e. upon validation of input images will be considered color channels only - Alpha or Extra channels will be ignored. So, for example, any combination of pages with RGB(A/Ex) colorspaces (e.g. RGB and RGBA) are valid input parameters).
  • This method is applicable to any supported by ImageGear channel depth for given colorspace, but channel depths of both images must be the same.

The method processes the input pages according to following logics:

  • This method processes only specified channels range of input pages. In order to process all image channels, use another overload Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double).
  • The method blends minimal number of channels, determined by channelsRange and channels count between the images. The remaining out-of-range channels, if any, will not be considered for blending, and:
    • If page has more channels than specified by channelsRange, they will remain intact.
    • If pageToBlendWith has more channels than specified by channelsRange, they will be ignored.
  • This method does not not provide any special handling for the Alpha channel (i.e. it processes it as ordinary color channel), please use BlendWithAlpha method to blend images using the Alpha channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
BlendWithAlpha Method
ImGearRasterPage Class
ImGearChannelRange Structure


BlendWithAlpha Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : BlendWithAlpha Method
Page to process.
Left margin of blended image.
Top margin of blended image.
Image to blend with page1.
Blends two images with alpha channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub BlendWithAlpha( _
   ByVal page1 As ImGearRasterPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal page2 As ImGearRasterPage _
)
'Usage

Dim page1 As ImGearRasterPage
Dim left As Integer
Dim top As Integer
Dim page2 As ImGearRasterPage

ImGearRasterProcessing.BlendWithAlpha(page1, left, top, page2)
public static void BlendWithAlpha(
   ImGearRasterPage page1,
   int left,
   int top,
   ImGearRasterPage page2
)
public: static void BlendWithAlpha(
   ImGearRasterPage* page1,
   int left,
   int top,
   ImGearRasterPage* page2
)
public:
static void BlendWithAlpha(
   ImGearRasterPage^ page1,
   int left,
   int top,
   ImGearRasterPage^ page2
)

Parameters

page1
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
page2
Image to blend with page1.
Remarks
This method blends page2 over page1 and stores result in page1.

The method validates input pages for further processing according to following logics:

  • The page2 should contain an Alpha channel, otherwise, an error is returned.
  • It is not essential whether page1 contains an Alpha channel or not, see about it below.
  • This method is applicable to any colorspace, that can have Alpha channel. Both images must have the same base colorspace (i.e. upon validation of input images will be considered color channels only - Extra channels will be ignored).
  • This method is applicable to any supported by ImageGear color channel depth for given colorspace, but channel depths of both images must be the same.

If page1 does not contain an Alpha channel, page2 is composited over it using page1 as the background. The resulting image does not contain an Alpha channel. The following formulas are used:

If page2 is not pre-multiplied,

I1 = I2 * A2 + I1 (1-A2)

If page2 is pre-multiplied,

I1 = I2 + I1 (1-A2)

If page1 contains an Alpha channel, page1 and page2 are blended together. The resulting image contains an alpha channel. Blending two images, both of which contain an Alpha channel, can be interpreted as placing one semi-transparent film over another semi-transparent film. The result of applying such combined images to some background is the same as applying one image over background and then applying another image to the result. Using pseudocode,

BlendWithAlpha(page1, page2) BlendWithAlpha(BackPage, page1)

produces the same result as

BlendWithAlpha(BackPage, page1) BlendWithAlpha(BackPage, page2)

The following formulas are used:

if (A1=A2=0)

I1 = 0; A1 = 0;

else

If both page1 and page2 are not pre-multiplied,

I1 = (I2*A2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is not pre-multiplied, and page2 is pre-multiplied:

I1 = (I2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is pre-multiplied, and page2 is not:

I1 = I2*A2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

If both page1 and page2 are pre-multiplied:

I1 = I2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

Alpha values are mapped to a float value between 0.0 and 1.0, where 0.0 means full transparency and 1.0 means full opaquity. Alpha value of 0 corresponds to float value of 0.0 and alpha value of 2^n-1 (where n is alpha channel's bit depth) corresponds to float value of 1.0.

This method does not process Extra channels, i.e:

  • If page1 has Extra channels, they will remain intact.
  • If page2 has Extra channels, they will be ignored.

Example
  • C#
//Loads an image with an alpha channel and blends it with an already loaded image.
using (FileStream file = new FileStream("PNGTEST.png",
           FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igRasterPageAlpha = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);

    ImGearRasterProcessing.BlendWithAlpha(
        igRasterPage, 10, 10, igRasterPageAlpha);
}
  • Visual Basic
'Loads an image with an alpha channel and blends it with an already loaded image.
Using file As New FileStream("PNGTEST.png", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igRasterPageAlpha As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)

    ImGearRasterProcessing.BlendWithAlpha(igRasterPage, 10, 10, igRasterPageAlpha)
End Using
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Blend(ImGearRasterPage,Int32,Int32,ImGearRasterPage,Double) Method
ImGearRasterPage Class


CalculateStatistics Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : CalculateStatistics Method
Raster page object process.
Calculates statistics for all channels of the image, separately for each channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CalculateStatistics( _
   ByVal page As ImGearRasterPage _
) As ImGearChannelStatistics()
'Usage

Dim page As ImGearRasterPage
Dim value() As ImGearChannelStatistics

value = ImGearRasterProcessing.CalculateStatistics(page)
public static ImGearChannelStatistics[] CalculateStatistics(
   ImGearRasterPage page
)
public: static ImGearChannelStatistics[]* CalculateStatistics(
   ImGearRasterPage* page
)
public:
static array<ImGearChannelStatistics>^ CalculateStatistics(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object process.

Return Value

ImGearChannelStatistics structure.
Remarks
This method takes image's Region of Interest (ROI) into account.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearROI Class
ImGearChannelStatistics Structure
ImGearRasterPage Class


ChangeChannelDepths Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : ChangeChannelDepths Method
Changes bit depths of image channels.
Overload List
Overload | Description
ChangeChannelDepths(ImGearRasterPage,Int32[]) | Changes bit depths of image channels.
ChangeChannelDepths(ImGearRasterPage,Int32[],Boolean) | Changes bit depth of image channels.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


ChangeChannelDepths(ImGearRasterPage,Int32[]) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ChangeChannelDepths Method : ChangeChannelDepths(ImGearRasterPage,Int32[]) Method
Page to process.
Array containing new channels depths.
Changes bit depths of image channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ChangeChannelDepths( _
   ByVal page As ImGearRasterPage, _
   ByVal newChannelDepths() As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim newChannelDepths() As Integer

ImGearRasterProcessing.ChangeChannelDepths(page, newChannelDepths)
public static void ChangeChannelDepths(
   ImGearRasterPage page,
   int[] newChannelDepths
)
public: static void ChangeChannelDepths(
   ImGearRasterPage* page,
   int[]* newChannelDepths
)
public:
static void ChangeChannelDepths(
   ImGearRasterPage^ page,
   array<int>^ newChannelDepths
)

Parameters

page
Page to process.
newChannelDepths
Array containing new channels depths.
Example
  • C#
// Change the channel depths of 3 channel image to 3,3,2
ImGearRasterProcessing.ChangeChannelDepths(igRasterPage, new int[] { 3, 3, 2 });
  • Visual Basic
' Change the channel depths of 3 channel image to 3,3,2
ImGearRasterProcessing.ChangeChannelDepths(igRasterPage, New Integer() {3, 3, 2})
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


ChangeChannelDepths(ImGearRasterPage,Int32[],Boolean) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ChangeChannelDepths Method : ChangeChannelDepths(ImGearRasterPage,Int32[],Boolean) Method
Page to process.
Array containing new channels depths.
Flags indicating whether to scale pixel values according to the new channel depth.
Changes bit depth of image channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ChangeChannelDepths( _
   ByVal page As ImGearRasterPage, _
   ByVal newChannelDepths() As Integer, _
   ByVal doNotScalePixels As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim newChannelDepths() As Integer
Dim doNotScalePixels As Boolean

ImGearRasterProcessing.ChangeChannelDepths(page, newChannelDepths, doNotScalePixels)
public static void ChangeChannelDepths(
   ImGearRasterPage page,
   int[] newChannelDepths,
   bool doNotScalePixels
)
public: static void ChangeChannelDepths(
   ImGearRasterPage* page,
   int[]* newChannelDepths,
   bool doNotScalePixels
)
public:
static void ChangeChannelDepths(
   ImGearRasterPage^ page,
   array<int>^ newChannelDepths,
   bool doNotScalePixels
)

Parameters

page
Page to process.
newChannelDepths
Array containing new channels depths.
doNotScalePixels
Flags indicating whether to scale pixel values according to the new channel depth.
Remarks
This method does not change an image's color space, and can be applied to all colorspaces except indexed.

If dontScalePixels is false (default), pixel values are scaled according to new channel depth. Unused gaps should be filled with 0 when channel is reduced.

If dontScalePixels is true, channel depth is changed, but pixel values are not scaled. If the channel depth is increased, the pixel data is not changed. If the channel depth is decreased, the pixel value is not changed in the case when it can be accommodated within the new depth. Otherwise, it is set to the maximum value allowed by the new depth (0x0...01...1).

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


Close Method (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Close Method
Page class object to apply effect to.

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Applies closing effect to provided raster page using the specified structuring element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Close( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix(,) As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer

ImGearRasterProcessing.Close(page, matrix)
public static void Close(
   ImGearRasterPage page,
   int[,] matrix
)
public: static void Close(
   ImGearRasterPage* page,
   int[,]* matrix
)
public:
static void Close(
   ImGearRasterPage^ page,
   array<int>^ matrix
)

Parameters

page
Page class object to apply effect to.
matrix

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Remarks
This method is applicable to:
  • 1-bit indexed images (1 bit per pixel images with ImageGear.Core.ImGearColorSpaceIDs.I color space).
  • Any grayscale images (images with ImageGear.Core.ImGearColorSpaceIDs.Gy color space).

Closing is similar in some ways to dilation (see Dilate) in that it tends to enlarge the boundaries of foreground (bright) regions in an image (and shrink background color holes in such regions), but it is less destructive of the original boundary shape. The exact operation is determined by the matrix structuring element. The effect of the operator is to preserve background regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of background pixels.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


CombineChannels Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : CombineChannels Method
Color space of the resulting multichannel page.
Array of channels reference to combine to multichannel page.
Combines image channels according to the specified color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CombineChannels( _
   ByVal space As ImGearColorSpace, _
   ByVal channels() As ImGearChannelRef _
) As ImGearRasterPage
'Usage

Dim space As ImGearColorSpace
Dim channels() As ImGearChannelRef
Dim value As ImGearRasterPage

value = ImGearRasterProcessing.CombineChannels(space, channels)
public static ImGearRasterPage CombineChannels(
   ImGearColorSpace space,
   ImGearChannelRef[] channels
)
public: static ImGearRasterPage* CombineChannels(
   ImGearColorSpace space,
   ImGearChannelRef[]* channels
)
public:
static ImGearRasterPage^ CombineChannels(
   ImGearColorSpace space,
   array<ImGearChannelRef>^ channels
)

Parameters

space
Color space of the resulting multichannel page.
channels
Array of channels reference to combine to multichannel page.

Return Value

ImageGear.Core.ImGearRasterPage class.
Remarks
This method puts together image channels according to the destination color space specified by the space parameter. This method does not do any color space or pixel conversions, it merely merges pixel data from different channels together. The number of channel pages should be compatible with the destination color space. Each Page in ChannelPages array must have exactly one channel. All pages must have the same BitsPerChannel and dimensions.
Example
  • C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);
  • Visual Basic
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearColorSpace Structure
ImGearChannelRef Structure


ConvertColorSpace Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : ConvertColorSpace Method
Converts page to a new color space.
Overload List
Overload | Description
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace) | Converts page to a new color space.
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean) | Converts page to a new color space, allowing to skip pixel data conversion.
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) | Converts page to a new color space, using the specified background color for images that contain Alpha channel.
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean,ImGearPixel) | Converts page to a new color space, using the specified background color for images that contain Alpha channel, or allowing to skip pixel data conversion.
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,]) | Converts page to a new color space using the specified matrix.
ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) | Converts page to a new color space using the specified color profiles and rendering intent.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace) Method
Image to convert color space.
New color space.
Converts page to a new color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace
)

Parameters

page
Image to convert color space.
newColorSpace
New color space.
Remarks
Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,])
Example
  • C#
// Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.Gy));
ImGearEffects.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE);
  • Visual Basic
' Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.Gy))
ImGearEffects.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean) Method
Image to convert.
New color space.
Flag indicating whether to change pixel values according to the new color space.
Converts page to a new color space, allowing to skip pixel data conversion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace, _
   ByVal doNotScalePixels As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace
Dim doNotScalePixels As Boolean

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace, doNotScalePixels)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels
)

Parameters

page
Image to convert.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.
Remarks

This method Converts page to the newColorSpace. This method works in two modes:

If dontScalePixels is false (default), the image's pixels are recalculated.

If the new color space differs from the old color space only by an alpha channel (add, remove, set to pre-multiplied/non-pre-multiplied), ChannelDepths of color channels are preserved. For example, 5-6-5-8 RGBA will be converted to 5-6-5 RGB. Otherwise, ChannelDepths of color channels are set to maximum of original channel depths. For example, 3-5-4 RGB will be converted to 5-5-5-5 CMYK.

Any conversions are supported, except for conversion into Indexed color space.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels and newColorSpace contains extra channels, the method does not change them.

If dontScalePixels is true, the page's color space property is changed, but the pixels are not modified. The number of channels of newColorSpace should be the same as that of the original image. When converting from Indexed to Grayscale, the palette is removed. When converting from Grayscale to Indexed, a default palette is created. Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,])

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) Method
Image to change color space.
New color space.
Background to composite the image over when removing alpha channel.
Converts page to a new color space, using the specified background color for images that contain Alpha channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace, _
   ByVal backgroundColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace
Dim backgroundColor As ImGearPixel

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace, backgroundColor)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   ImGearPixel backgroundColor
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace,
   ImGearPixel* backgroundColor
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace,
   ImGearPixel^ backgroundColor
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
backgroundColor
Background to composite the image over when removing alpha channel.
Remarks

If conversion removes the alpha channel from the image, the image is composited over a solid background specified by BackColor. Background should be in the same color space as the original image, but without the Alpha channel. For example, if the original image is in RGBA color space and newColorSpace is CMYK, background should have an RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,])

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean,ImGearPixel) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Boolean,ImGearPixel) Method
Image to change color space.
New color space.
Flag indicating whether to change pixel values according to the new color space.
Background to composite the image over when removing alpha channel.
Converts page to a new color space, using the specified background color for images that contain Alpha channel, or allowing to skip pixel data conversion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace, _
   ByVal doNotScalePixels As Boolean, _
   ByVal backgroundColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace
Dim doNotScalePixels As Boolean
Dim backgroundColor As ImGearPixel

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace, doNotScalePixels, backgroundColor)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels,
   ImGearPixel backgroundColor
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels,
   ImGearPixel* backgroundColor
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace,
   bool doNotScalePixels,
   ImGearPixel^ backgroundColor
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.
backgroundColor
Background to composite the image over when removing alpha channel.
Remarks

If conversion removes the alpha channel from an image, the image is composited over a solid background specified by BackColor. BackColor should be in the same color space as the original image, but without the Alpha channel. For example, if original image is in RGBA color space and newColorSpace is CMYK, BackColor should have RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

  • If Page is not pre-multiplied: I = I * A + B (1-A)
  • If Page is pre-multiplied: I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure
ImGearPixel Class


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,Double[,]) Method
Image to change color space.
New color space.
Conversion matrix.
Converts page to a new color space using the specified matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace, _
   ByVal conversionMatrix(,) As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace
Dim conversionMatrix() As Double

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace, conversionMatrix)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   double[,] conversionMatrix
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace,
   double[,]* conversionMatrix
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace,
   array<double>^ conversionMatrix
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
conversionMatrix
Conversion matrix.
Remarks

Converts an image to a new color space using a conversion matrix. Destination pixels are calculated as Dst = M * Src, where M is conversion matrix. Number of channels after conversion will be equal to first of the conversionMatrix. Second dimension of conversionMatrix should be equal to number of channels in the source page.

Note: ImageGear provides this method for color reconstruction of Digital Camera Raw images.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure
ImGearCameraRawProcessing Class
ImGearWhiteBalance Class


ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertColorSpace Method : ConvertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) Method
Image to change color space.
New color space.
Initial color space profile.
The new color space profile.
Rendering intent.
Converts page to a new color space using the specified color profiles and rendering intent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal newColorSpace As ImGearColorSpace, _
   ByVal sourceProfile As ImGearColorProfile, _
   ByVal destinationProfile As ImGearColorProfile, _
   ByVal renderingIntent As ImGearRenderingIntents _
)
'Usage

Dim page As ImGearRasterPage
Dim newColorSpace As ImGearColorSpace
Dim sourceProfile As ImGearColorProfile
Dim destinationProfile As ImGearColorProfile
Dim renderingIntent As ImGearRenderingIntents

ImGearRasterProcessing.ConvertColorSpace(page, newColorSpace, sourceProfile, destinationProfile, renderingIntent)
public static void ConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   ImGearColorProfile sourceProfile,
   ImGearColorProfile destinationProfile,
   ImGearRenderingIntents renderingIntent
)
public: static void ConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace newColorSpace,
   ImGearColorProfile* sourceProfile,
   ImGearColorProfile* destinationProfile,
   ImGearRenderingIntents renderingIntent
)
public:
static void ConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace newColorSpace,
   ImGearColorProfile^ sourceProfile,
   ImGearColorProfile^ destinationProfile,
   ImGearRenderingIntents renderingIntent
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
sourceProfile
Initial color space profile.
destinationProfile
The new color space profile.
renderingIntent
Rendering intent.
Remarks
The image's pixel data is modified to conform to the new color space. This method does not concern itself with any of the settings of ImageGear.Core.ImGearColorProfileManager class. Instead, it allows immediate and explicit specification of color profiles to use for the conversion.
Example
  • C#
// Load color profiles and convert an image from CMYK into RGB color space.

// Get the base path for the running executable.
string exePath = Assembly.GetExecutingAssembly().Location;
Int32 nIndex = exePath.LastIndexOf("\\");
exePath = exePath.Remove(nIndex + 1, exePath.Length - nIndex - 1);
// Read color profiles from the executable's path.
using (FileStream fs = File.OpenRead(exePath + "ig_cmyk_profile.icm"))
    ImGearColorProfileManager.CmykProfile = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead(exePath + "ig_rgb_profile.icm"))
    ImGearColorProfileManager.RgbProfile = new ImGearColorProfile(fs);
// Convert an opened CMYK image into the RGB colorspace using ImageGear color profiles.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB), ImGearColorProfileManager.CmykProfile,
    ImGearColorProfileManager.RgbProfile, ImGearRenderingIntents.PERCEPTUAL);
  • Visual Basic
' Load color profiles and convert an image from CMYK into RGB color space.

' Get the base path for the running executable.
Dim exePath As String = Assembly.GetExecutingAssembly().Location
Dim nIndex As Int32 = exePath.LastIndexOf("\")
exePath = exePath.Remove(nIndex + 1, exePath.Length - nIndex - 1)
' Read color profiles from the executable's path.
Using fs As FileStream = File.OpenRead(exePath + "ig_cmyk_profile.icm")
    ImGearColorProfileManager.CmykProfile = New ImGearColorProfile(fs)
End Using
Using fs As FileStream = File.OpenRead(exePath + "ig_rgb_profile.icm")
    ImGearColorProfileManager.RgbProfile = New ImGearColorProfile(fs)
End Using
' Convert an opened CMYK image into the RGB colorspace using ImageGear color profiles.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGB), _
 ImGearColorProfileManager.CmykProfile, ImGearColorProfileManager.RgbProfile, ImGearRenderingIntents.PERCEPTUAL)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearColorSpace Structure
ImGearColorProfile Class
ImGearRenderingIntents Enumeration


ConvertPixelFormat Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : ConvertPixelFormat Method
Converts a single pixel to color space and channel depths of the specified ImageGear.Core.ImGearPage class object.
Overload List
Overload | Description
ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearPage) | Converts a single pixel to color space and channel depths of the specified ImageGear.Core.ImGearPage class object.
ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearColorSpace,Int32[],ImGearRGBQuad[]) | Converts a single pixel to new color space and channel depths.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertPixelFormat Method : ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearPage) Method
Pixel to convert to the new format.
Source colorspace of the pixel.
Source channel depths of the pixel. Length of the channel depths array should correspond to the srcColorSpace parameter.
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
Page whose colorspace, channel depths, and palette will be used for destination format when converting the pixel.
Converts a single pixel to color space and channel depths of the specified ImageGear.Core.ImGearPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertPixelFormat( _
   ByVal pixel As ImGearPixel, _
   ByVal sourceColorSpace As ImGearColorSpace, _
   ByVal sourceChannelDepths() As Integer, _
   ByVal sourcePalette() As ImGearRGBQuad, _
   ByVal pageToConvertFormatTo As ImGearPage _
)
'Usage

Dim pixel As ImGearPixel
Dim sourceColorSpace As ImGearColorSpace
Dim sourceChannelDepths() As Integer
Dim sourcePalette() As ImGearRGBQuad
Dim pageToConvertFormatTo As ImGearPage

ImGearRasterProcessing.ConvertPixelFormat(pixel, sourceColorSpace, sourceChannelDepths, sourcePalette, pageToConvertFormatTo)
public static void ConvertPixelFormat(
   ImGearPixel pixel,
   ImGearColorSpace sourceColorSpace,
   int[] sourceChannelDepths,
   ImGearRGBQuad[] sourcePalette,
   ImGearPage pageToConvertFormatTo
)
public: static void ConvertPixelFormat(
   ImGearPixel* pixel,
   ImGearColorSpace sourceColorSpace,
   int[]* sourceChannelDepths,
   ImGearRGBQuad[]* sourcePalette,
   ImGearPage* pageToConvertFormatTo
)
public:
static void ConvertPixelFormat(
   ImGearPixel^ pixel,
   ImGearColorSpace sourceColorSpace,
   array<int>^ sourceChannelDepths,
   array<ImGearRGBQuad>^ sourcePalette,
   ImGearPage^ pageToConvertFormatTo
)

Parameters

pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the channel depths array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
pageToConvertFormatTo
Page whose colorspace, channel depths, and palette will be used for destination format when converting the pixel.
Remarks
Note: Using this method in a cycle for large array of pixels could be inefficient. Consider creating a temporary ImageGear.Core.ImGearPage class object and converting its colorspace and channel depths in this case.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearColorSpace,Int32[],ImGearRGBQuad[]) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > ConvertPixelFormat Method : ConvertPixelFormat(ImGearPixel,ImGearColorSpace,Int32[],ImGearRGBQuad[],ImGearColorSpace,Int32[],ImGearRGBQuad[]) Method
Pixel to convert to the new format.
Source colorspace of the pixel.
Source channel depths of the pixel. Length of the array should correspond to the srcColorSpace parameter.
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
Colorspace to convert the pixel to.
New channel depths for the pixel. Length of the array should correspond to the dstColorSpace parameter.
Destination palette for the pixel, if destination colorspace is Indexed, or null otherwise.
Converts a single pixel to new color space and channel depths.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertPixelFormat( _
   ByVal pixel As ImGearPixel, _
   ByVal sourceColorSpace As ImGearColorSpace, _
   ByVal sourceChannelDepths() As Integer, _
   ByVal sourcePalette() As ImGearRGBQuad, _
   ByVal destinationColorSpace As ImGearColorSpace, _
   ByVal destinationChannelDepths() As Integer, _
   ByVal destinationPalette() As ImGearRGBQuad _
)
'Usage

Dim pixel As ImGearPixel
Dim sourceColorSpace As ImGearColorSpace
Dim sourceChannelDepths() As Integer
Dim sourcePalette() As ImGearRGBQuad
Dim destinationColorSpace As ImGearColorSpace
Dim destinationChannelDepths() As Integer
Dim destinationPalette() As ImGearRGBQuad

ImGearRasterProcessing.ConvertPixelFormat(pixel, sourceColorSpace, sourceChannelDepths, sourcePalette, destinationColorSpace, destinationChannelDepths, destinationPalette)
public static void ConvertPixelFormat(
   ImGearPixel pixel,
   ImGearColorSpace sourceColorSpace,
   int[] sourceChannelDepths,
   ImGearRGBQuad[] sourcePalette,
   ImGearColorSpace destinationColorSpace,
   int[] destinationChannelDepths,
   ImGearRGBQuad[] destinationPalette
)
public: static void ConvertPixelFormat(
   ImGearPixel* pixel,
   ImGearColorSpace sourceColorSpace,
   int[]* sourceChannelDepths,
   ImGearRGBQuad[]* sourcePalette,
   ImGearColorSpace destinationColorSpace,
   int[]* destinationChannelDepths,
   ImGearRGBQuad[]* destinationPalette
)
public:
static void ConvertPixelFormat(
   ImGearPixel^ pixel,
   ImGearColorSpace sourceColorSpace,
   array<int>^ sourceChannelDepths,
   array<ImGearRGBQuad>^ sourcePalette,
   ImGearColorSpace destinationColorSpace,
   array<int>^ destinationChannelDepths,
   array<ImGearRGBQuad>^ destinationPalette
)

Parameters

pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
destinationColorSpace
Colorspace to convert the pixel to.
destinationChannelDepths
New channel depths for the pixel. Length of the array should correspond to the dstColorSpace parameter.
destinationPalette
Destination palette for the pixel, if destination colorspace is Indexed, or null otherwise.
Remarks
Note: Using this method in a cycle for a large array of pixels could be inefficient. Consider creating a temporary ImageGear.Core.ImGearPage class and converting its colorspace and channel depths in this case.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


Convolve Method (ImGearRasterProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Convolve Method
Image to convolve.
Two-dimensional convolution matrix.
Normalizer (i.e., denominator for every color component value).
Mode that defines how the resulting color component value interacts with the source:
  • ImGearConvolutionResults.RAW - the new color component replaces the old one. If the new value is negative then 0 is applied.
  • ImGearConvolutionResults.ABS the new color component replaces the old one. If the new color component is negative then its absolute value is applied.
  • ImGearConvolutionResults.SIGNED - the new color component replaces the old one. If the new color component is negative then it is added to the maximum value of the component range.
  • ImGearConvolutionResults.CENTERED - the new color component is added to the component range center and replaces the old one.
If this flag is true then the calculated values are added to the original ones.
Range of the channels to convolve.
Provides filtering on the base of 2-dimensional convolution matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Convolve( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix(,) As Integer, _
   ByVal normalizer As Double, _
   ByVal resultMode As ImGearConvolutionResults, _
   ByVal addResultToOriginalPixels As Boolean, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer
Dim normalizer As Double
Dim resultMode As ImGearConvolutionResults
Dim addResultToOriginalPixels As Boolean
Dim channels As ImGearChannelRange

ImGearRasterProcessing.Convolve(page, matrix, normalizer, resultMode, addResultToOriginalPixels, channels)
public static void Convolve(
   ImGearRasterPage page,
   int[,] matrix,
   double normalizer,
   ImGearConvolutionResults resultMode,
   bool addResultToOriginalPixels,
   ImGearChannelRange channels
)
public: static void Convolve(
   ImGearRasterPage* page,
   int[,]* matrix,
   double normalizer,
   ImGearConvolutionResults resultMode,
   bool addResultToOriginalPixels,
   ImGearChannelRange channels
)
public:
static void Convolve(
   ImGearRasterPage^ page,
   array<int>^ matrix,
   double normalizer,
   ImGearConvolutionResults resultMode,
   bool addResultToOriginalPixels,
   ImGearChannelRange channels
)

Parameters

page
Image to convolve.
matrix
Two-dimensional convolution matrix.
normalizer
Normalizer (i.e., denominator for every color component value).
resultMode
Mode that defines how the resulting color component value interacts with the source:
  • ImGearConvolutionResults.RAW - the new color component replaces the old one. If the new value is negative then 0 is applied.
  • ImGearConvolutionResults.ABS the new color component replaces the old one. If the new color component is negative then its absolute value is applied.
  • ImGearConvolutionResults.SIGNED - the new color component replaces the old one. If the new color component is negative then it is added to the maximum value of the component range.
  • ImGearConvolutionResults.CENTERED - the new color component is added to the component range center and replaces the old one.
addResultToOriginalPixels
If this flag is true then the calculated values are added to the original ones.
channels
Range of the channels to convolve.
Remarks
The method processes specified range of channels. It does not provide any special handling for Alpha channel.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Example
  • C#
// Convolve an image according to a matrix and normalizer.
// Convolution matrix:
int[,] matrix = new int[,] {
    {-1,1,1},
    {-1,0,1},
    {-1,-1,1}
};
// normalizer to be used as denominator for the matrix.
const double normalizer = 6;
// Channel range to convolve on.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Apply the convolution, in this case it has an emboss effect.
ImGearRasterProcessing.Convolve(igRasterPage, matrix, normalizer,
    ImGearConvolutionResults.RAW, true, igChannelRange);
  • Visual Basic
' Convolve an image according to a matrix and normalizer.
' Convolution matrix:
Dim matrix As Integer(,) = New Integer(,) { _
 {-1, 1, 1}, _
 {-1, 0, 1}, _
 {-1, -1, 1}}
' normalizer to be used as denominator for the matrix.
Dim normalizer As Double = 6
' Channel range to convolve on.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Apply the convolution, in this case it has an emboss effect.
ImGearRasterProcessing.Convolve(igRasterPage, matrix, normalizer, _
 ImGearConvolutionResults.RAW, True, igChannelRange)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearConvolutionResults Enumeration
ImGearRasterPage Class
ImGearChannelRange Structure


CreateChannelCopy Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : CreateChannelCopy Method
Copies a channel to a new page.
Overload List
Overload | Description
CreateChannelCopy(ImGearRasterPage,Int32) | Copies a channel to a new page.
CreateChannelCopy(ImGearChannelRef) | Returns a copy of a page's image channel.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


CreateChannelCopy(ImGearRasterPage,Int32) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > CreateChannelCopy Method : CreateChannelCopy(ImGearRasterPage,Int32) Method
Page from which the channel is obtained.
Channel number.
Copies a channel to a new page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateChannelCopy( _
   ByVal page As ImGearRasterPage, _
   ByVal channelNumber As Integer _
) As ImGearRasterPage
'Usage

Dim page As ImGearRasterPage
Dim channelNumber As Integer
Dim value As ImGearRasterPage

value = ImGearRasterProcessing.CreateChannelCopy(page, channelNumber)
public static ImGearRasterPage CreateChannelCopy(
   ImGearRasterPage page,
   int channelNumber
)
public: static ImGearRasterPage* CreateChannelCopy(
   ImGearRasterPage* page,
   int channelNumber
)
public:
static ImGearRasterPage^ CreateChannelCopy(
   ImGearRasterPage^ page,
   int channelNumber
)

Parameters

page
Page from which the channel is obtained.
channelNumber
Channel number.

Return Value

ImageGear.Core.ImGearRasterPage class containing a copy of the channel.
Remarks
ChannelNumber can be within the [0..ChannelCount-1] range.
Example
  • C#
// Create a new image by copying the third channel of an existing image.
ImGearRasterPage igRasterPageNew = ImGearRasterProcessing.CreateChannelCopy(
    igRasterPage, 2);
  • Visual Basic
' Create a new image by copying the third channel of an existing image.
Dim igRasterPageNew As ImGearRasterPage = ImGearRasterProcessing.CreateChannelCopy(igRasterPage, 2)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


CreateChannelCopy(ImGearChannelRef) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > CreateChannelCopy Method : CreateChannelCopy(ImGearChannelRef) Method
Channel to copy.
Returns a copy of a page's image channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateChannelCopy( _
   ByVal channel As ImGearChannelRef _
) As ImGearChannelRef
'Usage

Dim channel As ImGearChannelRef
Dim value As ImGearChannelRef

value = ImGearRasterProcessing.CreateChannelCopy(channel)
public static ImGearChannelRef CreateChannelCopy(
   ImGearChannelRef channel
)
public: static ImGearChannelRef CreateChannelCopy(
   ImGearChannelRef channel
)
public:
static ImGearChannelRef CreateChannelCopy(
   ImGearChannelRef channel
)

Parameters

channel
Channel to copy.

Return Value

The copy of ImGearChannelRef structure.
Remarks
Content of returned ImGearChannelRef instance represents a standalone instance of ImageGear.Core.ImGearRasterPage class with grayscaled color space.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearChannelRef Structure
ImGearRasterPage Class


Decrypt Method (ImGearRasterProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Decrypt Method
Page to decrypt.
Decryption password.
Decrypts a raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Decrypt( _
   ByVal page As ImGearRasterPage, _
   ByVal password As String _
)
'Usage

Dim page As ImGearRasterPage
Dim password As String

ImGearRasterProcessing.Decrypt(page, password)
public static void Decrypt(
   ImGearRasterPage page,
   string password
)
public: static void Decrypt(
   ImGearRasterPage* page,
   string* password
)
public:
static void Decrypt(
   ImGearRasterPage^ page,
   String^ password
)

Parameters

page
Page to decrypt.
password
Decryption password.
Example
  • C#
// Decrypts an image using a pass-phrase.
ImGearRasterProcessing.Decrypt(igRasterPage, "abcdefg");
  • Visual Basic
' Decrypts an image using a pass-phrase.
ImGearRasterProcessing.Decrypt(igRasterPage, "abcdefg")
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Encrypt Method
ImGearRasterPage Class


Deskew Method (ImGearRasterProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Deskew Method
Image to deskew.
Deskew angle.
Deskew mode.
Background color.
Deskews an image page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Deskew( _
   ByVal page As ImGearRasterPage, _
   ByVal angleThresh As Double, _
   ByVal mode As ImGearRotationModes, _
   ByVal backgroundColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim angleThresh As Double
Dim mode As ImGearRotationModes
Dim backgroundColor As ImGearPixel

ImGearRasterProcessing.Deskew(page, angleThresh, mode, backgroundColor)
public static void Deskew(
   ImGearRasterPage page,
   double angleThresh,
   ImGearRotationModes mode,
   ImGearPixel backgroundColor
)
public: static void Deskew(
   ImGearRasterPage* page,
   double angleThresh,
   ImGearRotationModes mode,
   ImGearPixel* backgroundColor
)
public:
static void Deskew(
   ImGearRasterPage^ page,
   double angleThresh,
   ImGearRotationModes mode,
   ImGearPixel^ backgroundColor
)

Parameters

page
Image to deskew.
angleThresh
Deskew angle.
mode
Deskew mode.
backgroundColor
Background color.
Example
  • C#
// Deskew an image if it is skewed by over 0.1 degrees.
ImGearRasterProcessing.Deskew(igRasterPage,
    0.1, ImGearRotationModes.CLIP, null);
  • Visual Basic
' Deskew an image if it is skewed by over 0.1 degrees.
ImGearRasterProcessing.Deskew(igRasterPage, 0.1, ImGearRotationModes.CLIP, Nothing)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearRotationModes Enumeration
ImGearPixel Class


Despeckle Method (ImGearRasterProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Despeckle Method
Image to filter.
Width of the square area.
Height of the square area.
Removes color noise from a binary (1-bit) image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Despeckle( _
   ByVal page As ImGearRasterPage, _
   ByVal neighborhoodWidth As Integer, _
   ByVal neighborhoodHeight As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim neighborhoodWidth As Integer
Dim neighborhoodHeight As Integer

ImGearRasterProcessing.Despeckle(page, neighborhoodWidth, neighborhoodHeight)
public static void Despeckle(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight
)
public: static void Despeckle(
   ImGearRasterPage* page,
   int neighborhoodWidth,
   int neighborhoodHeight
)
public:
static void Despeckle(
   ImGearRasterPage^ page,
   int neighborhoodWidth,
   int neighborhoodHeight
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.
Remarks
Despeckle is used to help reduce the amount of noise in the image. Single pixels and pixel spurs on letters and graphics are removed while leaving the solid areas alone. It is typically used on 1-bit document images.

The despeckle operation performs a median filter on the image. For each pixel in the original image, a single pixel is produced in the output image. The output pixel is the median of the pixel values in the neighborhood area defined by neighborhoodWidth and neighborhoodHeight parameters.

Example
  • C#
// Despeckle a 1-bit image using a 3x3 area.
ImGearRasterProcessing.Despeckle(igRasterPage, 3, 3);
  • Visual Basic
' Despeckle a 1-bit image using a 3x3 area.
ImGearRasterProcessing.Despeckle(igRasterPage, 3, 3)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


Dilate Method (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Dilate Method
Page class object to apply effect to.

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Applies dilation effect to provided raster page using the specified structuring element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Dilate( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix(,) As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer

ImGearRasterProcessing.Dilate(page, matrix)
public static void Dilate(
   ImGearRasterPage page,
   int[,] matrix
)
public: static void Dilate(
   ImGearRasterPage* page,
   int[,]* matrix
)
public:
static void Dilate(
   ImGearRasterPage^ page,
   array<int>^ matrix
)

Parameters

page
Page class object to apply effect to.
matrix

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Remarks
This method is applicable to:
  • 1-bit indexed images (1 bit per pixel images with ImageGear.Core.ImGearColorSpaceIDs.I color space).
  • Any grayscale images (images with ImageGear.Core.ImGearColorSpaceIDs.Gy color space).

Dilation adds pixels to the boundaries of objects in an image. The number of pixels added or removed from the objects in an image depends on the size and shape of the matrix structuring element, used to process the image.

In the morphological dilation and erosion operations, the state of any given pixel in the output image is determined by applying a rule to the corresponding pixel and its neighbors in the input image. The rule for dilation operation is following:

The value of the output pixel is the maximum value of all the pixels in the input pixel's neighborhood. In a binary image, if any of the pixels is set to the value 1, the output pixel is set to 1.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearColorSpaceIDs Enumeration
ImGearRasterPage Class


Encrypt Method (ImGearRasterProcessing)
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Encrypt Method
Page to encrypt.
Encryption password.
Encrypts a raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Encrypt( _
   ByVal page As ImGearRasterPage, _
   ByVal password As String _
)
'Usage

Dim page As ImGearRasterPage
Dim password As String

ImGearRasterProcessing.Encrypt(page, password)
public static void Encrypt(
   ImGearRasterPage page,
   string password
)
public: static void Encrypt(
   ImGearRasterPage* page,
   string* password
)
public:
static void Encrypt(
   ImGearRasterPage^ page,
   String^ password
)

Parameters

page
Page to encrypt.
password
Encryption password.
Example
  • C#
// Encrypts an image using a pass-phrase.
ImGearRasterProcessing.Encrypt(igRasterPage, "abcdefg");
  • Visual Basic
' Encrypts an image using a pass-phrase.
ImGearRasterProcessing.Encrypt(igRasterPage, "abcdefg")
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
Decrypt Method


EnhanceLocal Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : EnhanceLocal Method
Enhances an image using the local standard deviation and mean.
Overload List
Overload | Description
EnhanceLocal | Enhances an image using the local standard deviation and mean.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


EnhanceLocal(ImGearRasterPage,Int32,Int32,Double,Double) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : EnhanceLocal(ImGearRasterPage,Int32,Int32,Double,Double) Method
An ImageGear.Core.ImGearRasterPage class object to enhance.
Width of the local window.
Height of the local window.
Scaling factor.
Minimum allowed standard deviation.
Enhances an image using the local standard deviation and mean.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub EnhanceLocal( _
   ByVal page As ImGearRasterPage, _
   ByVal windowWidth As Integer, _
   ByVal windowHeight As Integer, _
   ByVal scaleFactor As Double, _
   ByVal minStandardDeviation As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim windowWidth As Integer
Dim windowHeight As Integer
Dim scaleFactor As Double
Dim minStandardDeviation As Double

ImGearRasterProcessing.EnhanceLocal(page, windowWidth, windowHeight, scaleFactor, minStandardDeviation)
public static void EnhanceLocal(
   ImGearRasterPage page,
   int windowWidth,
   int windowHeight,
   double scaleFactor,
   double minStandardDeviation
)
public: static void EnhanceLocal(
   ImGearRasterPage* page,
   int windowWidth,
   int windowHeight,
   double scaleFactor,
   double minStandardDeviation
)
public:
static void EnhanceLocal(
   ImGearRasterPage^ page,
   int windowWidth,
   int windowHeight,
   double scaleFactor,
   double minStandardDeviation
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to enhance.
windowWidth
Width of the local window.
windowHeight
Height of the local window.
scaleFactor
Scaling factor.
minStandardDeviation
Minimum allowed standard deviation.
Remarks
This method transforms the input image f(x, y) to a new image g(x, y) based on the following formula:

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8bit grayscale images with one channel.

Example
  • C#
// Enhance the image using EnhanceLocal using a 3x3 window,
//  0.5 scale factor, and 1.0 minimum standard deviation.
ImGearRasterProcessing.EnhanceLocal(igRasterPage, 3, 3, 0.5, 1.0);
  • Visual Basic
' Enhance the image using EnhanceLocal using a 3x3 window,
'  0.5 scale factor, and 1.0 minimum standard deviation.
ImGearRasterProcessing.EnhanceLocal(igRasterPage, 3, 3, 0.5, 1)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


EqualizeContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : EqualizeContrast Method
Equalizes image contrast.
Overload List
Overload | Description
EqualizeContrast(ImGearRasterPage) | Equalizes image contrast.
EqualizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Equalizes image contrast.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


EqualizeContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > EqualizeContrast Method : EqualizeContrast(ImGearRasterPage) Method
Page to equalize.
Equalizes image contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub EqualizeContrast( _
   ByVal page As ImGearRasterPage _
)
'Usage

Dim page As ImGearRasterPage

ImGearRasterProcessing.EqualizeContrast(page)
public static void EqualizeContrast(
   ImGearRasterPage page
)
public: static void EqualizeContrast(
   ImGearRasterPage* page
)
public:
static void EqualizeContrast(
   ImGearRasterPage^ page
)

Parameters

page
Page to equalize.
Remarks
If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. It processes only color channels.

This method can be applied only to the raster pages with standard (non Run-Ends) DIB.

Use CanApplyEqualizeContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


EqualizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > EqualizeContrast Method : EqualizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
Page to equalize.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to apply EqualizeContrast.
Equalizes image contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub EqualizeContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange

ImGearRasterProcessing.EqualizeContrast(page, mode, channels)
public static void EqualizeContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public: static void EqualizeContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public:
static void EqualizeContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Page to equalize.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to apply EqualizeContrast.
Remarks
If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.

It can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.CanApplyEqualizeContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


Erode Method (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Erode Method
Page class object to apply effect to.

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Applies erosion effect to provided raster page using the specified structuring element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Erode( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix(,) As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer

ImGearRasterProcessing.Erode(page, matrix)
public static void Erode(
   ImGearRasterPage page,
   int[,] matrix
)
public: static void Erode(
   ImGearRasterPage* page,
   int[,]* matrix
)
public:
static void Erode(
   ImGearRasterPage^ page,
   array<int>^ matrix
)

Parameters

page
Page class object to apply effect to.
matrix

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Remarks
This method is applicable to:
  • 1-bit indexed images (1 bit per pixel images with ImageGear.Core.ImGearColorSpaceIDs.I color space).
  • Any grayscale images (images with ImageGear.Core.ImGearColorSpaceIDs.Gy color space).

Erosion operation removes pixels on object boundaries. The number of pixels added or removed from the objects in an image depends on the size and shape of the matrix structuring element, used to process the image.

In the morphological dilation and erosion operations, the state of any given pixel in the output image is determined by applying a rule to the corresponding pixel and its neighbors in the input image. The rule for erosion operation is following:

The value of the output pixel is the minimum value of all the pixels in the input pixel's neighborhood. In a binary image, if any of the pixels is set to the value 0, the output pixel is set to 0.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearColorSpaceIDs Enumeration
ImGearRasterPage Class


Export Method (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Export Method
Exports content of raster page to managed GDI+ image.
Overload List
Overload | Description
Export(ImGearRasterPage,Int32,Int32) | Exports content of raster page to managed GDI+ image.
Export(ImGearRasterPage,ImGearRGBQuad,Int32,Int32) | Exports content of raster page to managed GDI+ image.
Export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,Int32,Int32) | Exports content of raster page to managed GDI+ image.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


Export(ImGearRasterPage,Int32,Int32) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Export Method : Export(ImGearRasterPage,Int32,Int32) Method
Raster page to be exported.
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Exports content of raster page to managed GDI+ image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Export( _
   ByVal page As ImGearRasterPage, _
   ByVal ppmX As Integer, _
   ByVal ppmY As Integer _
) As Bitmap
'Usage

Dim page As ImGearRasterPage
Dim ppmX As Integer
Dim ppmY As Integer
Dim value As Bitmap

value = ImGearRasterProcessing.Export(page, ppmX, ppmY)
public static Bitmap Export(
   ImGearRasterPage page,
   int ppmX,
   int ppmY
)
public: static Bitmap* Export(
   ImGearRasterPage* page,
   int ppmX,
   int ppmY
)
public:
static Bitmap^ Export(
   ImGearRasterPage^ page,
   int ppmX,
   int ppmY
)

Parameters

page
Raster page to be exported.
ppmX
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

An instance of System.Drawing.Bitmap class.
Remarks
Since Bitmap stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.
Example
  • C#
// Source rectangle to export.
ImGearRectangle igRectangleSource = new ImGearRectangle(igRasterPage.DIB.Width, igRasterPage.DIB.Height);
// Destination rectangle to export.
ImGearRectangle igRectangleDestination = new ImGearRectangle(32, 32);
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Export the image to a bitmap and assign that to a standard picturebox.
Bitmap bitmapExport = ImGearRasterProcessing.Export(igRasterPage, 2834, 2834);
bitmapForm.pictureBox1.Image = bitmapExport;
  • Visual Basic
' Source rectangle to export.
Dim igRectangleSource As New ImGearRectangle(igRasterPage.DIB.Width, igRasterPage.DIB.Height)
' Destination rectangle to export.
Dim igRectangleDestination As New ImGearRectangle(32, 32)
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Export the image to a bitmap and assign that to a standard picturebox.
Dim bitmapExport As Bitmap = ImGearRasterProcessing.Export(igRasterPage, 2834, 2834)
bitmapForm1.PictureBox1.Image = bitmapExport
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ExportPageToBitmap(ImGearPage) Method


Export(ImGearRasterPage,ImGearRGBQuad,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Export Method : Export(ImGearRasterPage,ImGearRGBQuad,Int32,Int32) Method
Page to be exported.
Background pixel to blend exporting page with. It's used only if given page contains alpha or premultiplied alpha channel.
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Exports content of raster page to managed GDI+ image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Export( _
   ByVal page As ImGearRasterPage, _
   ByVal backgroundColor As ImGearRGBQuad, _
   ByVal ppmX As Integer, _
   ByVal ppmY As Integer _
) As Bitmap
'Usage

Dim page As ImGearRasterPage
Dim backgroundColor As ImGearRGBQuad
Dim ppmX As Integer
Dim ppmY As Integer
Dim value As Bitmap

value = ImGearRasterProcessing.Export(page, backgroundColor, ppmX, ppmY)
public static Bitmap Export(
   ImGearRasterPage page,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)
public: static Bitmap* Export(
   ImGearRasterPage* page,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)
public:
static Bitmap^ Export(
   ImGearRasterPage^ page,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)

Parameters

page
Page to be exported.
backgroundColor
Background pixel to blend exporting page with. It's used only if given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

An instance of System.Drawing.Bitmap class.
Remarks
Exports an image of the given page to GDI+ image. If the incoming page contains an alpha or a premultiplied alpha channel, background pixel is used to blend the image with.

Since Bitmap stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearRGBQuad Structure
ExportPageToBitmap(ImGearPage) Method


Export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Export Method : Export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,Int32,Int32) Method
Page to be exported.
Part of image to export.
Output area onto which exported image part will be scaled.
Interested part of device rectangle.
Interpolation method used to resize from image rectangle to device.
Background pixel to blend exporting page with. It's used only if the given page contains alpha or premultiplied alpha channel.
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
Exports content of raster page to managed GDI+ image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Export( _
   ByVal page As ImGearRasterPage, _
   ByVal imageRect As ImGearRectangle, _
   ByVal deviceRect As ImGearRectangle, _
   ByVal clipRect As ImGearRectangle, _
   ByVal interpolationOptions As ImGearInterpolationOptions, _
   ByVal backgroundColor As ImGearRGBQuad, _
   ByVal ppmX As Integer, _
   ByVal ppmY As Integer _
) As Bitmap
'Usage

Dim page As ImGearRasterPage
Dim imageRect As ImGearRectangle
Dim deviceRect As ImGearRectangle
Dim clipRect As ImGearRectangle
Dim interpolationOptions As ImGearInterpolationOptions
Dim backgroundColor As ImGearRGBQuad
Dim ppmX As Integer
Dim ppmY As Integer
Dim value As Bitmap

value = ImGearRasterProcessing.Export(page, imageRect, deviceRect, clipRect, interpolationOptions, backgroundColor, ppmX, ppmY)
public static Bitmap Export(
   ImGearRasterPage page,
   ImGearRectangle imageRect,
   ImGearRectangle deviceRect,
   ImGearRectangle clipRect,
   ImGearInterpolationOptions interpolationOptions,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)
public: static Bitmap* Export(
   ImGearRasterPage* page,
   ImGearRectangle imageRect,
   ImGearRectangle deviceRect,
   ImGearRectangle clipRect,
   ImGearInterpolationOptions* interpolationOptions,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)
public:
static Bitmap^ Export(
   ImGearRasterPage^ page,
   ImGearRectangle imageRect,
   ImGearRectangle deviceRect,
   ImGearRectangle clipRect,
   ImGearInterpolationOptions^ interpolationOptions,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)

Parameters

page
Page to be exported.
imageRect
Part of image to export.
deviceRect
Output area onto which exported image part will be scaled.
clipRect
Interested part of device rectangle.
interpolationOptions
Interpolation method used to resize from image rectangle to device.
backgroundColor
Background pixel to blend exporting page with. It's used only if the given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

Instance of System.Drawing.Bitmap class.
Remarks
Exports an image of the page to GDI+ bitmap with the ability to specify the rectangular part of the image being exported and the interpolation method that should be used to resize the specified image part to device rectangle.

For more information see Displaying images topic.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearRectangle Structure
ImGearInterpolationOptions Class
ImGearRGBQuad Structure
ExportPageToBitmap(ImGearPage) Method


Fill Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Fill Method
Image to fill.
The fill color. It should be specified by RGB format. The method will convert it to destination pixel value according to the actual color space and bit depth of the page.
Fills the image by specified solid color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Fill( _
   ByVal page As ImGearRasterPage, _
   ByVal fillColor As IImGearRGBQuad _
)
'Usage

Dim page As ImGearRasterPage
Dim fillColor As IImGearRGBQuad

ImGearRasterProcessing.Fill(page, fillColor)
public static void Fill(
   ImGearRasterPage page,
   IImGearRGBQuad fillColor
)
public: static void Fill(
   ImGearRasterPage* page,
   IImGearRGBQuad* fillColor
)
public:
static void Fill(
   ImGearRasterPage^ page,
   IImGearRGBQuad^ fillColor
)

Parameters

page
Image to fill.
fillColor
The fill color. It should be specified by RGB format. The method will convert it to destination pixel value according to the actual color space and bit depth of the page.
Remarks
If the page has ROI initialized (rectangular or non-rectangular), will be filled corresponding ROI region only.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearColorSpace Structure


FilterWithMedian Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : FilterWithMedian Method
Removes color noise from the image.
Overload List
Overload | Description
FilterWithMedian(ImGearRasterPage,Int32,Int32) | Removes color noise from the image.
FilterWithMedian(ImGearRasterPage,Int32,Int32,ImGearChannelRange) | Removes color noise from the image.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


FilterWithMedian(ImGearRasterPage,Int32,Int32) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > FilterWithMedian Method : FilterWithMedian(ImGearRasterPage,Int32,Int32) Method
Image to filter.
Width of the square area.
Height of the square area.
Removes color noise from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub FilterWithMedian( _
   ByVal page As ImGearRasterPage, _
   ByVal neighborhoodWidth As Integer, _
   ByVal neighborhoodHeight As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim neighborhoodWidth As Integer
Dim neighborhoodHeight As Integer

ImGearRasterProcessing.FilterWithMedian(page, neighborhoodWidth, neighborhoodHeight)
public static void FilterWithMedian(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight
)
public: static void FilterWithMedian(
   ImGearRasterPage* page,
   int neighborhoodWidth,
   int neighborhoodHeight
)
public:
static void FilterWithMedian(
   ImGearRasterPage^ page,
   int neighborhoodWidth,
   int neighborhoodHeight
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.
Remarks
This method looks for an average color value inside the square area near the pixel and replaces the pixel with this value. Processes color channels only.
Example
  • C#
// Changes each pixel to the median of a 3x3 area around the pixel.
ImGearRasterProcessing.FilterWithMedian(igRasterPage, 3, 3);
  • Visual Basic
' Changes each pixel to the median of a 3x3 area around the pixel.
ImGearRasterProcessing.FilterWithMedian(igRasterPage, 3, 3)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


FilterWithMedian(ImGearRasterPage,Int32,Int32,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > FilterWithMedian Method : FilterWithMedian(ImGearRasterPage,Int32,Int32,ImGearChannelRange) Method
Image to filter.
Width of the square area.
Height of the square area.
Channel range.
Removes color noise from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub FilterWithMedian( _
   ByVal page As ImGearRasterPage, _
   ByVal neighborhoodWidth As Integer, _
   ByVal neighborhoodHeight As Integer, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim neighborhoodWidth As Integer
Dim neighborhoodHeight As Integer
Dim channels As ImGearChannelRange

ImGearRasterProcessing.FilterWithMedian(page, neighborhoodWidth, neighborhoodHeight, channels)
public static void FilterWithMedian(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight,
   ImGearChannelRange channels
)
public: static void FilterWithMedian(
   ImGearRasterPage* page,
   int neighborhoodWidth,
   int neighborhoodHeight,
   ImGearChannelRange channels
)
public:
static void FilterWithMedian(
   ImGearRasterPage^ page,
   int neighborhoodWidth,
   int neighborhoodHeight,
   ImGearChannelRange channels
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.
channels
Channel range.
Remarks
This method looks for an average color value inside the square area near the pixel and replaces the pixels with this value. Processes a specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearChannelRange Structure


FilterWithUnsharpMask Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : FilterWithUnsharpMask Method
Provides UnsharpMask filtering.
Overload List
Overload | Description
FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32) | Provides UnsharpMask filtering.
FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32,ImGearChannelRange) | Provides UnsharpMask filtering.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > FilterWithUnsharpMask Method : FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32) Method
Page to filter.
Radius of unsharp mask.
Amount of unsharpening.
Unsharpening threshold.
Provides UnsharpMask filtering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub FilterWithUnsharpMask( _
   ByVal page As ImGearRasterPage, _
   ByVal radius As Double, _
   ByVal amount As Integer, _
   ByVal threshold As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim radius As Double
Dim amount As Integer
Dim threshold As Integer

ImGearRasterProcessing.FilterWithUnsharpMask(page, radius, amount, threshold)
public static void FilterWithUnsharpMask(
   ImGearRasterPage page,
   double radius,
   int amount,
   int threshold
)
public: static void FilterWithUnsharpMask(
   ImGearRasterPage* page,
   double radius,
   int amount,
   int threshold
)
public:
static void FilterWithUnsharpMask(
   ImGearRasterPage^ page,
   double radius,
   int amount,
   int threshold
)

Parameters

page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.
Remarks
This method processes color channels only.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32,ImGearChannelRange) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > FilterWithUnsharpMask Method : FilterWithUnsharpMask(ImGearRasterPage,Double,Int32,Int32,ImGearChannelRange) Method
Page to filter.
Radius of unsharp mask.
Amount of unsharpening.
Unsharpening threshold.
Channel range.
Provides UnsharpMask filtering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub FilterWithUnsharpMask( _
   ByVal page As ImGearRasterPage, _
   ByVal radius As Double, _
   ByVal amount As Integer, _
   ByVal threshold As Integer, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim radius As Double
Dim amount As Integer
Dim threshold As Integer
Dim channels As ImGearChannelRange

ImGearRasterProcessing.FilterWithUnsharpMask(page, radius, amount, threshold, channels)
public static void FilterWithUnsharpMask(
   ImGearRasterPage page,
   double radius,
   int amount,
   int threshold,
   ImGearChannelRange channels
)
public: static void FilterWithUnsharpMask(
   ImGearRasterPage* page,
   double radius,
   int amount,
   int threshold,
   ImGearChannelRange channels
)
public:
static void FilterWithUnsharpMask(
   ImGearRasterPage^ page,
   double radius,
   int amount,
   int threshold,
   ImGearChannelRange channels
)

Parameters

page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.
channels
Channel range.
Remarks
This method processes a specified range of channels.
Example
  • C#
// Channel range to calculate.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Apply an unsharp mask to the image with a radius of 7.5, strength of 100, and threshold of 30
ImGearRasterProcessing.FilterWithUnsharpMask(igRasterPage, 7.5, 100, 30, igChannelRange);
  • Visual Basic
' Channel range to calculate.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Apply an unsharp mask to the image with a radius of 7.5, strength of 100, and threshold of 30
ImGearRasterProcessing.FilterWithUnsharpMask(igRasterPage, 7.5, 100, 30, igChannelRange)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearChannelRange Structure


FindSkewAngle Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : FindSkewAngle Method
Page to deskew.
Determines skew angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FindSkewAngle( _
   ByVal page As ImGearRasterPage _
) As Double
'Usage

Dim page As ImGearRasterPage
Dim value As Double

value = ImGearRasterProcessing.FindSkewAngle(page)
public static double FindSkewAngle(
   ImGearRasterPage page
)
public: static double FindSkewAngle(
   ImGearRasterPage* page
)
public:
static double FindSkewAngle(
   ImGearRasterPage^ page
)

Parameters

page
Page to deskew.

Return Value

ImageGear.Core.ImGearRasterPage class object.
Example
  • C#
// Find the skew angle of an image.
double angle = ImGearRasterProcessing.FindSkewAngle(igRasterPage);

// Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, null);
  • Visual Basic
' Find the skew angle of an image.
Dim angle As Double = ImGearRasterProcessing.FindSkewAngle(igRasterPage)

' Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, Nothing)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


FindTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : FindTilt Method
Computes the least-squares best fit plane for an image.
Overload List
Overload | Description
FindTilt | Computes the least-squares best fit plane for an image.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


FindTilt(ImGearRasterPage,Double,Double,Double) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : FindTilt(ImGearRasterPage,Double,Double,Double) Method
An ImageGear.Core.ImGearRasterPage class object to process.
Returns the slope in the X direction of the tilt plane.
Returns the slope in the Y direction of the tilt plane.
Returns the piston of the tilt plane.
Computes the least-squares best fit plane for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub FindTilt( _
   ByVal page As ImGearRasterPage, _
   ByRef slopeX As Double, _
   ByRef slopeY As Double, _
   ByRef piston As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim slopeX As Double
Dim slopeY As Double
Dim piston As Double

ImGearRasterProcessing.FindTilt(page, slopeX, slopeY, piston)
public static void FindTilt(
   ImGearRasterPage page,
   out double slopeX,
   out double slopeY,
   out double piston
)
public: static void FindTilt(
   ImGearRasterPage* page,
   [PARAMFLAG::Out] double slopeX,
   [PARAMFLAG::Out] double slopeY,
   [PARAMFLAG::Out] double piston
)
public:
static void FindTilt(
   ImGearRasterPage^ page,
   [Out] double slopeX,
   [Out] double slopeY,
   [Out] double piston
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to process.
slopeX
Returns the slope in the X direction of the tilt plane.
slopeY
Returns the slope in the Y direction of the tilt plane.
piston
Returns the piston of the tilt plane.
Remarks
This method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.

Can be applied only to 8, 16 or 32bit grayscale images with one channel.

Example
  • C#
// Find the tilt of an image.
double slopeX, slopeY, piston;
ImGearRasterProcessing.FindTilt(igRasterPage, out slopeX, out slopeY, out piston);

// Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY);
  • Visual Basic
' Find the tilt of an image.
Dim slopeX As Double, slopeY As Double, piston As Double
ImGearRasterProcessing.FindTilt(igRasterPage, slopeX, slopeY, piston)

' Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


GaussianBlur Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : GaussianBlur Method
Blurs an image using Gaussian transform.
Overload List
Overload | Description
GaussianBlur(ImGearRasterPage,Double) | Blurs an image using Gaussian transform.
GaussianBlur(ImGearRasterPage,Double,ImGearChannelRange) | Blurs an image using Gaussian transform.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


GaussianBlur(ImGearRasterPage,Double) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > GaussianBlur Method : GaussianBlur(ImGearRasterPage,Double) Method
Page to process.
Defines the neighborhood to be considered for each pixel.
Blurs an image using Gaussian transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub GaussianBlur( _
   ByVal page As ImGearRasterPage, _
   ByVal radius As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim radius As Double

ImGearRasterProcessing.GaussianBlur(page, radius)
public static void GaussianBlur(
   ImGearRasterPage page,
   double radius
)
public: static void GaussianBlur(
   ImGearRasterPage* page,
   double radius
)
public:
static void GaussianBlur(
   ImGearRasterPage^ page,
   double radius
)

Parameters

page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.
Remarks
This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method only blurs color channels of the image. If the image contains Alpha or Extra channels, the method does not blur them.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


GaussianBlur(ImGearRasterPage,Double,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > GaussianBlur Method : GaussianBlur(ImGearRasterPage,Double,ImGearChannelRange) Method
Page to process.
Defines the neighborhood to be considered for each pixel.
Defines image channels to apply the transform to.
Blurs an image using Gaussian transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub GaussianBlur( _
   ByVal page As ImGearRasterPage, _
   ByVal radius As Double, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim radius As Double
Dim channels As ImGearChannelRange

ImGearRasterProcessing.GaussianBlur(page, radius, channels)
public static void GaussianBlur(
   ImGearRasterPage page,
   double radius,
   ImGearChannelRange channels
)
public: static void GaussianBlur(
   ImGearRasterPage* page,
   double radius,
   ImGearChannelRange channels
)
public:
static void GaussianBlur(
   ImGearRasterPage^ page,
   double radius,
   ImGearChannelRange channels
)

Parameters

page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.
channels
Defines image channels to apply the transform to.
Remarks
This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method allows to specify the range of channels to blur.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearChannelRange Structure


GeomDespeckle Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : GeomDespeckle Method
Reduces speckle noise from an image by using the Crimmins algorithm.
Overload List
Overload | Description
GeomDespeckle | Reduces speckle noise from an image by using the Crimmins algorithm.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


GeomDespeckle(ImGearRasterPage,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : GeomDespeckle(ImGearRasterPage,Int32) Method
An ImageGear.Core.ImGearRasterPage class object on which algorithm will be performed.
Number of iterations to apply the despeckle filter.
Reduces speckle noise from an image by using the Crimmins algorithm.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub GeomDespeckle( _
   ByVal page As ImGearRasterPage, _
   ByVal iterations As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim iterations As Integer

ImGearRasterProcessing.GeomDespeckle(page, iterations)
public static void GeomDespeckle(
   ImGearRasterPage page,
   int iterations
)
public: static void GeomDespeckle(
   ImGearRasterPage* page,
   int iterations
)
public:
static void GeomDespeckle(
   ImGearRasterPage^ page,
   int iterations
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object on which algorithm will be performed.
iterations
Number of iterations to apply the despeckle filter.
Remarks
This method reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique.

The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image.

Can be applied only to 8bit grayscale images with one channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


ImageIsGray Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : ImageIsGray Method
Image to test.
Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ImageIsGray( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim page As ImGearRasterPage
Dim value As Boolean

value = ImGearRasterProcessing.ImageIsGray(page)
public static bool ImageIsGray(
   ImGearRasterPage page
)
public: static bool ImageIsGray(
   ImGearRasterPage* page
)
public:
static bool ImageIsGray(
   ImGearRasterPage^ page
)

Parameters

page
Image to test.

Return Value

Boolean value.
Remarks
This method returns true if either of the two conditions are met:
  • Image has grayscale color space.
  • Image has indexed color space, and palette is either linear gray, or inverted gray.
Example
  • C#
// Make sure the image is gray.
if (!ImGearRasterProcessing.ImageIsGray(igRasterPage))
    return;
// Create a LUT to convert image from 8bit to 4bit while also inverting.
ImGearMultichannelLUT igMultichannelLUT = new ImGearMultichannelLUT(
    igRasterPage.DIB.ChannelCount, 8, 4);
for (int i = 0; i < 255; ++i )
{
    igMultichannelLUT[0][i] = 15 - (i / 16);
}
// Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage,igMultichannelLUT);
  • Visual Basic
' Make sure the image is gray.
If Not ImGearRasterProcessing.ImageIsGray(igRasterPage) Then
    Return
End If
' Create a LUT to convert image from 8bit to 4bit while also inverting.
Dim igMultichannelLUT As New ImGearMultichannelLUT(igRasterPage.DIB.ChannelCount, 8, 4)
For i As Integer = 0 To 254
    igMultichannelLUT(0)(i) = 15 - (i / 16)
Next
' Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage, igMultichannelLUT)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


InsertChannel Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : InsertChannel Method
Page to insert channel to.
Position of the channel in the page.
Reference to the channel to be inserted.
Inserts a channel to the page's DIB and changes page's color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InsertChannel( _
   ByVal page As ImGearRasterPage, _
   ByVal newChannelPos As Integer, _
   ByVal channel As ImGearChannelRef _
)
'Usage

Dim page As ImGearRasterPage
Dim newChannelPos As Integer
Dim channel As ImGearChannelRef

ImGearRasterProcessing.InsertChannel(page, newChannelPos, channel)
public static void InsertChannel(
   ImGearRasterPage page,
   int newChannelPos,
   ImGearChannelRef channel
)
public: static void InsertChannel(
   ImGearRasterPage* page,
   int newChannelPos,
   ImGearChannelRef channel
)
public:
static void InsertChannel(
   ImGearRasterPage^ page,
   int newChannelPos,
   ImGearChannelRef channel
)

Parameters

page
Page to insert channel to.
newChannelPos
Position of the channel in the page.
channel
Reference to the channel to be inserted.
Example
  • C#
// Separate image into separate images for each channel.
ImGearChannelRef[] igChannelRef = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3);
// Save the page out without the alpha channel.
using (FileStream localFile = new FileStream("withoutalpha.jpg", FileMode.Create))
{
    ImGearFileFormats.SavePage(igRasterPage,localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
}
//Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(
    igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.RGBA));
// Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef[3]);
// Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4);
  • Visual Basic
' Separate image into separate images for each channel.
Dim igChannelRef As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3)
' Save the page out without the alpha channel.
Using localFile As New FileStream("withoutalpha.jpg", FileMode.Create)
    ImGearFileFormats.SavePage(igRasterPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG)
End Using
'Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGBA))
' Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef(3))
' Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearChannelRef Structure


InvertContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : InvertContrast Method
Inverts image contrast.
Overload List
Overload | Description
InvertContrast(ImGearRasterPage) | Inverts image contrast.
InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Inverts image contrast.
InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) | Inverts image contrast.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


InvertContrast(ImGearRasterPage) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > InvertContrast Method : InvertContrast(ImGearRasterPage) Method
Image to invert contrast.
Inverts image contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub InvertContrast( _
   ByVal page As ImGearRasterPage _
)
'Usage

Dim page As ImGearRasterPage

ImGearRasterProcessing.InvertContrast(page)
public static void InvertContrast(
   ImGearRasterPage page
)
public: static void InvertContrast(
   ImGearRasterPage* page
)
public:
static void InvertContrast(
   ImGearRasterPage^ page
)

Parameters

page
Image to invert contrast.
Remarks
If the image is indexed and the palette is not grayscale, this method modifies image's palette, otherwise it modifies image's pixels. The method processes only color channels.

Use ImGearRasterProcessingVerifier.CanApplyInvertContrast method to check whether the operation can be performed.

Example
  • C#
// Detect an area around a point in an image based upon a base pixel and threshold.

// Top left corner of image
ImGearPoint igPoint = new ImGearPoint(0, 0);
//Get the Pixel currently there.
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// Detection class, threshold is difference in pixel channel values from specified pixel.
ImGearPixelCheckerThreshold igPixelCheckerThreshold = new ImGearPixelCheckerThreshold(igPixel, 100);
// Detect the region around target point within the threshold.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold);

// Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage);
  • Visual Basic
' Detect an area around a point in an image based upon a base pixel and threshold.

' Top left corner of image
Dim igPoint As New ImGearPoint(0, 0)
'Get the Pixel currently there.
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' Detection class, threshold is difference in pixel channel values from specified pixel.
Dim igPixelCheckerThreshold As New ImGearPixelCheckerThreshold(igPixel, 100)
' Detect the region around target point within the threshold.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold)

' Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > InvertContrast Method : InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
Image to invert contrast.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to invert contrast.
Inverts image contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub InvertContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange

ImGearRasterProcessing.InvertContrast(page, mode, channels)
public static void InvertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public: static void InvertContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public:
static void InvertContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.
Remarks
Processes specified range of channels.

If mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.CanApplyInvertContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration
ImGearChannelRange Structure


InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > InvertContrast Method : InvertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
Image to invert contrast.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to invert contrast.
Contrast options. See ImGearContrastOptions class.
Inverts image contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub InvertContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange, _
   ByVal options As ImGearContrastOptions _
)
'Usage

Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange
Dim options As ImGearContrastOptions

ImGearRasterProcessing.InvertContrast(page, mode, channels, options)
public static void InvertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions options
)
public: static void InvertContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions* options
)
public:
static void InvertContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions^ options
)

Parameters

page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.
options
Contrast options. See ImGearContrastOptions class.
Remarks
Processes specified range of channels.

If Mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.CanApplyInvertContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration
ImGearChannelRange Structure
ImGearContrastOptions Class


Merge Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Merge Method
Merges two images according to the specified merge mode.
Overload List
Overload | Description
Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes) | Merges two images according to the specified merge mode.
Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes,ImGearChannelRange) | Merges two images according to the specified merge mode.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Merge Method : Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes) Method
First image to merge. It will contain result image after merging.
Second image to merge.
Left position of the source image on the destination one.
Top position of the source image on the destination one.
Merge mode constant. See ImGearMergeModes enumeration.
Merges two images according to the specified merge mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Merge( _
   ByVal page As ImGearRasterPage, _
   ByVal pageToMergeWith As ImGearRasterPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal mode As ImGearMergeModes _
)
'Usage

Dim page As ImGearRasterPage
Dim pageToMergeWith As ImGearRasterPage
Dim left As Integer
Dim top As Integer
Dim mode As ImGearMergeModes

ImGearRasterProcessing.Merge(page, pageToMergeWith, left, top, mode)
public static void Merge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode
)
public: static void Merge(
   ImGearRasterPage* page,
   ImGearRasterPage* pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode
)
public:
static void Merge(
   ImGearRasterPage^ page,
   ImGearRasterPage^ pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode
)

Parameters

page
First image to merge. It will contain result image after merging.
pageToMergeWith
Second image to merge.
left
Left position of the source image on the destination one.
top
Top position of the source image on the destination one.
mode
Merge mode constant. See ImGearMergeModes enumeration.
Remarks
Processes color channels only.

DIBs or both pages must have the same color space.

Use ImGearRasterProcessingVerifier.CanApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

Example
  • C#
// Opens an image and merges it into an already open image.
using (FileStream file = new FileStream("photo.jpg",
                   FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igRasterPageToMerge = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);

    // Subtract the opened image from the existing image.
    ImGearRasterProcessing.Merge(igRasterPage, igRasterPageToMerge, 0, 0, ImGearMergeModes.SUB);
}
  • Visual Basic
' Opens an image and merges it into an already open image.
Using file As New FileStream("photo.jpg", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igRasterPageToMerge As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)

    ' Subtract the opened image from the existing image.
    ImGearRasterProcessing.Merge(igRasterPage, igRasterPageToMerge, 0, 0, ImGearMergeModes.[SUB])
End Using
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearMergeModes Enumeration


Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes,ImGearChannelRange) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Merge Method : Merge(ImGearRasterPage,ImGearRasterPage,Int32,Int32,ImGearMergeModes,ImGearChannelRange) Method
First image to merge. It will contain resultant image after merging.
Second image to merge.
Left position of the source image on the destination one.
Top position of the source image on the destination one.
Merge mode.
Range of channels.
Merges two images according to the specified merge mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Merge( _
   ByVal page As ImGearRasterPage, _
   ByVal pageToMergeWith As ImGearRasterPage, _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal mode As ImGearMergeModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim pageToMergeWith As ImGearRasterPage
Dim left As Integer
Dim top As Integer
Dim mode As ImGearMergeModes
Dim channels As ImGearChannelRange

ImGearRasterProcessing.Merge(page, pageToMergeWith, left, top, mode, channels)
public static void Merge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode,
   ImGearChannelRange channels
)
public: static void Merge(
   ImGearRasterPage* page,
   ImGearRasterPage* pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode,
   ImGearChannelRange channels
)
public:
static void Merge(
   ImGearRasterPage^ page,
   ImGearRasterPage^ pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode,
   ImGearChannelRange channels
)

Parameters

page
First image to merge. It will contain resultant image after merging.
pageToMergeWith
Second image to merge.
left
Left position of the source image on the destination one.
top
Top position of the source image on the destination one.
mode
Merge mode.
channels
Range of channels.
Remarks
Processes specified range of channels.

Both page DIBs must have the same color space.

Use ImGearRasterProcessingVerifier.CanApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearMergeModes Enumeration
ImGearChannelRange Structure
CanApplyMerge Method


Open Method (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Open Method
Page class object to apply effect to.

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Applies opening effect to provided raster page using the specified structuring element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Open( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix(,) As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer

ImGearRasterProcessing.Open(page, matrix)
public static void Open(
   ImGearRasterPage page,
   int[,] matrix
)
public: static void Open(
   ImGearRasterPage* page,
   int[,]* matrix
)
public:
static void Open(
   ImGearRasterPage^ page,
   array<int>^ matrix
)

Parameters

page
Page class object to apply effect to.
matrix

Matrix specifying a structuring element (sometimes called the kernel) used to probe the input image. It consists of only 0's and 1's that can have any arbitrary shape and size. The pixels with values of 1 define the neighborhood.

Two-dimensional, or flat, structuring elements are typically much smaller than the image being processed. The center pixel of the structuring element, called the origin, identifies the pixel of interest - the pixel being processed. The pixels in the structuring element containing 1's define the neighborhood of the structuring element. These pixels are also considered in dilation or erosion processing.

You typically choose a structuring element the same size and shape as the objects you want to process in the input image. For example, to find lines in an image, create a linear structuring element.

Remarks
This method is applicable to:
  • 1-bit indexed images (1 bit per pixel images with ImageGear.Core.ImGearColorSpaceIDs.I color space).
  • Any grayscale images (images with ImageGear.Core.ImGearColorSpaceIDs.Gy color space).

The basic effect of an opening is somewhat like erosion (Erode) in that it tends to remove some of the foreground (bright) pixels from the edges of regions of foreground pixels. However it is less destructive than erosion in general. The exact operation is determined by the matrix structuring element. The effect of the operator is to preserve foreground regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of foreground pixels.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


Reduce Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Reduce Method
Image to reduce bit depth.
Color space to reduce image to.
Channel depths to reduce image to.
Method to use for reducing bit depth.
Options to use for reduction, or set to null to use defaults.
Reduces bit depth of an image using the specified reduction method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Reduce( _
   ByVal page As ImGearRasterPage, _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal channelDepths() As Integer, _
   ByVal reductionMethod As ImGearReductionMethods, _
   ByVal options As ImGearReductionOptions _
)
'Usage

Dim page As ImGearRasterPage
Dim colorSpace As ImGearColorSpace
Dim channelDepths() As Integer
Dim reductionMethod As ImGearReductionMethods
Dim options As ImGearReductionOptions

ImGearRasterProcessing.Reduce(page, colorSpace, channelDepths, reductionMethod, options)
public static void Reduce(
   ImGearRasterPage page,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   ImGearReductionMethods reductionMethod,
   ImGearReductionOptions options
)
public: static void Reduce(
   ImGearRasterPage* page,
   ImGearColorSpace colorSpace,
   int[]* channelDepths,
   ImGearReductionMethods reductionMethod,
   ImGearReductionOptions* options
)
public:
static void Reduce(
   ImGearRasterPage^ page,
   ImGearColorSpace colorSpace,
   array<int>^ channelDepths,
   ImGearReductionMethods reductionMethod,
   ImGearReductionOptions^ options
)

Parameters

page
Image to reduce bit depth.
colorSpace
Color space to reduce image to.
channelDepths
Channel depths to reduce image to.
reductionMethod
Method to use for reducing bit depth.
options
Options to use for reduction, or set to null to use defaults.
Remarks
All methods except for ImGearReductionMethods.SCALE change the color space of the image to Indexed. ImGearReductionMethods.SCALE does not change the image's color space, but only scales the channel depths. Different reduction methods have their own options, which can be set using the options parameter.

For more information about a particular method, see its options. The following reduction methods are available in ImGearReductionMethods:

Method | Input color spaces and bit depths | Output color spaces and bit depths | Options
BAYER | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearBayerReductionOptions
BITONAL | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearBitonalReductionOptions
DIFFUSE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearDiffuseReductionOptions
HALFTONE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearHalftoneReductionOptions
MEDIAN | RGB (24)Grayscale (8) | Indexed (8) | ImGearMedianCutReductionOptions
OCTREE | RGB (24)Grayscale (8) | Indexed (4 or 8) | ImGearOctreeReductionOptions
POPULARITY | RGB (24)Grayscale (8) | Indexed (8) | ImGearPopularityReductionOptions
SCALE | Any color space except Indexed | Same color space as input | ImGearScaleReductionOptions
Example
  • C#
// Reduce the bit depth of an image to 4 bit

// Create reduction options object and setup a few values for a 16 color 4-bit reduction.
ImGearReductionOptions igReductionOptions = new ImGearReductionOptions();
igReductionOptions.Octree.MaxColors = 16;
igReductionOptions.Octree.FastRemap = false;
igReductionOptions.Octree.ErrorDiffusion = true;
//Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 4 }, ImGearReductionMethods.OCTREE, igReductionOptions);
  • Visual Basic
' Reduce the bit depth of an image to 4 bit

' Create reduction options object and setup a few values for a 16 color 4-bit reduction.
Dim igReductionOptions As New ImGearReductionOptions()
igReductionOptions.Octree.MaxColors = 16
igReductionOptions.Octree.FastRemap = False
igReductionOptions.Octree.ErrorDiffusion = True
'Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.I), New Integer() {4}, _
 ImGearReductionMethods.OCTREE, igReductionOptions)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearColorSpace Structure
ImGearReductionOptions Class
ImGearReductionMethods Enumeration


RemoveChannel Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : RemoveChannel Method
Page to remove channel.
Position of the channel to be removed.
Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveChannel( _
   ByVal page As ImGearRasterPage, _
   ByVal channelNumber As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim channelNumber As Integer

ImGearRasterProcessing.RemoveChannel(page, channelNumber)
public static void RemoveChannel(
   ImGearRasterPage page,
   int channelNumber
)
public: static void RemoveChannel(
   ImGearRasterPage* page,
   int channelNumber
)
public:
static void RemoveChannel(
   ImGearRasterPage^ page,
   int channelNumber
)

Parameters

page
Page to remove channel.
channelNumber
Position of the channel to be removed.
Remarks
channelNumber can be within the [0..ChannelCount-1] range.

Color Space is changed as follows:

  • If page has more than one Extra channel, color space is unchanged.
  • If page has one Extra channel, ExtraMask is cleared.
  • If page has Alpha channel and no Extra channels, AlphaMask and PremultAlphaMask are cleared.
  • If page has only color channels, color space is changed to Unknown, and all remaining channels are considered Extra channels.
Example
  • C#
// Separate image into separate images for each channel.
ImGearChannelRef[] igChannelRef = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3);
// Save the page out without the alpha channel.
using (FileStream localFile = new FileStream("withoutalpha.jpg", FileMode.Create))
{
    ImGearFileFormats.SavePage(igRasterPage,localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
}
//Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(
    igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.RGBA));
// Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef[3]);
// Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4);
  • Visual Basic
' Separate image into separate images for each channel.
Dim igChannelRef As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3)
' Save the page out without the alpha channel.
Using localFile As New FileStream("withoutalpha.jpg", FileMode.Create)
    ImGearFileFormats.SavePage(igRasterPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG)
End Using
'Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGBA))
' Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef(3))
' Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


RemoveTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : RemoveTilt Method
This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
Overload List
Overload | Description
RemoveTilt | This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


RemoveTilt(ImGearRasterPage,Boolean) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : RemoveTilt(ImGearRasterPage,Boolean) Method
An ImageGear.Core.ImGearRasterPage class object to process.
Flag to indicate whether to remove the mean from the de-tilted image, giving it zero-mean statistics.
This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveTilt( _
   ByVal page As ImGearRasterPage, _
   ByVal removeMean As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim removeMean As Boolean

ImGearRasterProcessing.RemoveTilt(page, removeMean)
public static void RemoveTilt(
   ImGearRasterPage page,
   bool removeMean
)
public: static void RemoveTilt(
   ImGearRasterPage* page,
   bool removeMean
)
public:
static void RemoveTilt(
   ImGearRasterPage^ page,
   bool removeMean
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to process.
removeMean
Flag to indicate whether to remove the mean from the de-tilted image, giving it zero-mean statistics.
Remarks
This method is very handy for correcting illumination gradients in a poorly digitized image.

If removeMean argument is set to true, then global mean is removed from the image as well.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


SeparateChannels Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : SeparateChannels Method
Multichannel page to separate.
Creates an array of pages, where each page contains one channel with color space set to grayscale.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SeparateChannels( _
   ByVal page As ImGearRasterPage _
) As ImGearChannelRef()
'Usage

Dim page As ImGearRasterPage
Dim value() As ImGearChannelRef

value = ImGearRasterProcessing.SeparateChannels(page)
public static ImGearChannelRef[] SeparateChannels(
   ImGearRasterPage page
)
public: static ImGearChannelRef[]* SeparateChannels(
   ImGearRasterPage* page
)
public:
static array<ImGearChannelRef>^ SeparateChannels(
   ImGearRasterPage^ page
)

Parameters

page
Multichannel page to separate.

Return Value

An array of channels reference - ImGearChannelRef structure.
Remarks
This method does not do any of the color space or pixel conversions.
Example
  • C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);
  • Visual Basic
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearChannelRef Structure
ImGearRasterPage Class


Sharpen Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Sharpen Method
Sharpens an image according to the specified sharpen factor.
Overload List
Overload | Description
Sharpen(ImGearRasterPage,Int32) | Sharpens an image according to the specified sharpen factor.
Sharpen(ImGearRasterPage,Int32,ImGearChannelRange) | Sharpens an image according to the specified sharpen factor.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


Sharpen(ImGearRasterPage,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Sharpen Method : Sharpen(ImGearRasterPage,Int32) Method
Image to sharpen.
Sharpen factor. Allowed values are from 1 to 7 inclusive. For any factor beyond this range the method will do nothing. The larger this factor, the sharper image will become.
Sharpens an image according to the specified sharpen factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Sharpen( _
   ByVal page As ImGearRasterPage, _
   ByVal factor As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim factor As Integer

ImGearRasterProcessing.Sharpen(page, factor)
public static void Sharpen(
   ImGearRasterPage page,
   int factor
)
public: static void Sharpen(
   ImGearRasterPage* page,
   int factor
)
public:
static void Sharpen(
   ImGearRasterPage^ page,
   int factor
)

Parameters

page
Image to sharpen.
factor
Sharpen factor. Allowed values are from 1 to 7 inclusive. For any factor beyond this range the method will do nothing. The larger this factor, the sharper image will become.
Remarks
Processes color channels only.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


Sharpen(ImGearRasterPage,Int32,ImGearChannelRange) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Sharpen Method : Sharpen(ImGearRasterPage,Int32,ImGearChannelRange) Method
Image to sharpen.
Sharpen factor. Allowed values are from 1 to 7 inclusive. For any factor beyond this range the method will do nothing. The larger this factor, the sharper image will become.
Channel range to sharpen.
Sharpens an image according to the specified sharpen factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Sharpen( _
   ByVal page As ImGearRasterPage, _
   ByVal factor As Integer, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim factor As Integer
Dim channels As ImGearChannelRange

ImGearRasterProcessing.Sharpen(page, factor, channels)
public static void Sharpen(
   ImGearRasterPage page,
   int factor,
   ImGearChannelRange channels
)
public: static void Sharpen(
   ImGearRasterPage* page,
   int factor,
   ImGearChannelRange channels
)
public:
static void Sharpen(
   ImGearRasterPage^ page,
   int factor,
   ImGearChannelRange channels
)

Parameters

page
Image to sharpen.
factor
Sharpen factor. Allowed values are from 1 to 7 inclusive. For any factor beyond this range the method will do nothing. The larger this factor, the sharper image will become.
channels
Channel range to sharpen.
Remarks
This method processes a specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

Example
  • C#
// Sharpen the first channel of an image by a factor of 3.
ImGearRasterProcessing.Sharpen(igRasterPage, 3, new ImGearChannelRange(0, 1));
  • Visual Basic
' Sharpen the first channel of an image by a factor of 3.
ImGearRasterProcessing.Sharpen(igRasterPage, 3, New ImGearChannelRange(0, 1))
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearChannelRange Structure


Smooth Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Smooth Method
Provides smooth filtering.
Overload List
Overload | Description
Smooth(ImGearRasterPage,Int32) | Provides smooth filtering.
Smooth(ImGearRasterPage,Int32,ImGearChannelRange) | Provides smooth filtering.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


Smooth(ImGearRasterPage,Int32) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Smooth Method : Smooth(ImGearRasterPage,Int32) Method
Page to process.
Smooth factor.
Provides smooth filtering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Smooth( _
   ByVal page As ImGearRasterPage, _
   ByVal factor As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim factor As Integer

ImGearRasterProcessing.Smooth(page, factor)
public static void Smooth(
   ImGearRasterPage page,
   int factor
)
public: static void Smooth(
   ImGearRasterPage* page,
   int factor
)
public:
static void Smooth(
   ImGearRasterPage^ page,
   int factor
)

Parameters

page
Page to process.
factor
Smooth factor.
Remarks
This method processes color channels only.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


Smooth(ImGearRasterPage,Int32,ImGearChannelRange) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > Smooth Method : Smooth(ImGearRasterPage,Int32,ImGearChannelRange) Method
Image to process.
Smooth factor.
Channel range to process.
Provides smooth filtering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Smooth( _
   ByVal page As ImGearRasterPage, _
   ByVal factor As Integer, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim factor As Integer
Dim channels As ImGearChannelRange

ImGearRasterProcessing.Smooth(page, factor, channels)
public static void Smooth(
   ImGearRasterPage page,
   int factor,
   ImGearChannelRange channels
)
public: static void Smooth(
   ImGearRasterPage* page,
   int factor,
   ImGearChannelRange channels
)
public:
static void Smooth(
   ImGearRasterPage^ page,
   int factor,
   ImGearChannelRange channels
)

Parameters

page
Image to process.
factor
Smooth factor.
channels
Channel range to process.
Remarks
Processes specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Example
  • C#
// Smooth the first channel of an image by a factor of 3.
ImGearRasterProcessing.Smooth(igRasterPage, 3, new ImGearChannelRange(0,1));
  • Visual Basic
' Smooth the first channel of an image by a factor of 3.
ImGearRasterProcessing.Smooth(igRasterPage, 3, New ImGearChannelRange(0, 1))
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearChannelRange Structure


StretchContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : StretchContrast Method
Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
Overload List
Overload | Description
StretchContrast(ImGearRasterPage) | Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
StretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Stretches image contrast. Processes specified range of channels.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


StretchContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > StretchContrast Method : StretchContrast(ImGearRasterPage) Method
Image to process.
Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub StretchContrast( _
   ByVal page As ImGearRasterPage _
)
'Usage

Dim page As ImGearRasterPage

ImGearRasterProcessing.StretchContrast(page)
public static void StretchContrast(
   ImGearRasterPage page
)
public: static void StretchContrast(
   ImGearRasterPage* page
)
public:
static void StretchContrast(
   ImGearRasterPage^ page
)

Parameters

page
Image to process.
Remarks
Can be applied only to raster pages with standard (non Run-Ends) DIB.

Use CanApplyStretchContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class


StretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class > StretchContrast Method : StretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
Image to process.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to process.
Stretches image contrast. Processes specified range of channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub StretchContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange

ImGearRasterProcessing.StretchContrast(page, mode, channels)
public static void StretchContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public: static void StretchContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public:
static void StretchContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to process.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to process.
Remarks
Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.CanApplyStretchContrast method to check whether the operation can be performed.

Example
  • C#
// Channel range to adjust contrast.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Stretch the contrast.
ImGearRasterProcessing.StretchContrast(igRasterPage,
    ImGearContrastModes.AUTO, igChannelRange);
  • Visual Basic
' Channel range to adjust contrast.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Stretch the contrast.
ImGearRasterProcessing.StretchContrast(igRasterPage, ImGearContrastModes.AUTO, igChannelRange)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration
ImGearChannelRange Structure


SwapChannels Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : SwapChannels Method
Page to swap the channels.
Index of the first channel to be swapped.
Index of the second channel to be swapped.
Swaps two channels in page's DIB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SwapChannels( _
   ByVal page As ImGearRasterPage, _
   ByVal channelIndex1 As Integer, _
   ByVal channelIndex2 As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim channelIndex1 As Integer
Dim channelIndex2 As Integer

ImGearRasterProcessing.SwapChannels(page, channelIndex1, channelIndex2)
public static void SwapChannels(
   ImGearRasterPage page,
   int channelIndex1,
   int channelIndex2
)
public: static void SwapChannels(
   ImGearRasterPage* page,
   int channelIndex1,
   int channelIndex2
)
public:
static void SwapChannels(
   ImGearRasterPage^ page,
   int channelIndex1,
   int channelIndex2
)

Parameters

page
Page to swap the channels.
channelIndex1
Index of the first channel to be swapped.
channelIndex2
Index of the second channel to be swapped.
Example
  • C#
// Swaps the first and third channels.  In an RGB image this swaps the red and blue channels.
ImGearRasterProcessing.SwapChannels(igRasterPage, 0, 2);
  • Visual Basic
' Swaps the first and third channels.  In an RGB image this swaps the red and blue channels.
ImGearRasterProcessing.SwapChannels(DirectCast(igRasterPage, ImGearRasterPage), 0, 2)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class


TabulateHistogram Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : TabulateHistogram Method
Page for which to tabulate histogram.
Two dimensional array that is filled with histogram data. It must be allocated prior to calling the method. First dimension corresponds to channel number, second dimension corresponds to histogram bin number.
Specifies image channels for which histogram shall be tabulated.
Tabulates histograms for all image channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub TabulateHistogram( _
   ByVal page As ImGearRasterPage, _
   ByVal histogram(,) As Integer, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim histogram() As Integer
Dim channels As ImGearChannelRange

ImGearRasterProcessing.TabulateHistogram(page, histogram, channels)
public static void TabulateHistogram(
   ImGearRasterPage page,
   int[,] histogram,
   ImGearChannelRange channels
)
public: static void TabulateHistogram(
   ImGearRasterPage* page,
   int[,]* histogram,
   ImGearChannelRange channels
)
public:
static void TabulateHistogram(
   ImGearRasterPage^ page,
   array<int>^ histogram,
   ImGearChannelRange channels
)

Parameters

page
Page for which to tabulate histogram.
histogram
Two dimensional array that is filled with histogram data. It must be allocated prior to calling the method. First dimension corresponds to channel number, second dimension corresponds to histogram bin number.
channels
Specifies image channels for which histogram shall be tabulated.
Remarks
This method tabulates histograms for all image channels.

This method supports images with channel depths ranging from 2 to 16.

Example
  • C#
// Calculate image histogram.

// Channel range to calculate.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Integer array to hold histogram data
int[,] histogramData = new int[igRasterPage.DIB.ChannelCount,(int)Math.Pow(2,igRasterPage.DIB.BitsPerChannel)];

//Tabulate the histogram data.
ImGearRasterProcessing.TabulateHistogram(igRasterPage, histogramData, igChannelRange);

// Show a piece of the data.
MessageBox.Show(histogramData[0,0] + " pixels had the value 0 for the first channel.", "Histogram Data");
  • Visual Basic
' Calculate image histogram.

' Channel range to calculate.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Integer array to hold histogram data
Dim numberOfValues As Integer
numberOfValues = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel))
Dim histogramData As Integer(,) = New Integer(igRasterPage.DIB.ChannelCount - 1, numberOfValues - 1) {}

'Tabulate the histogram data.
ImGearRasterProcessing.TabulateHistogram(igRasterPage, histogramData, igChannelRange)

' Show a piece of the data.
MessageBox.Show(histogramData(0, 0).ToString() + " pixels had the value 0 for the first channel.", "Histogram Data")
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearChannelRange Structure


TransformWithLUT Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : TransformWithLUT Method
Page to apply the LUT to.
Multichannel LUT that shall be applied.
Applies lookup tables to each channel of the image, optionally changing channel depths.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub TransformWithLUT( _
   ByVal page As ImGearRasterPage, _
   ByVal LUT As ImGearMultichannelLUT _
)
'Usage

Dim page As ImGearRasterPage
Dim LUT As ImGearMultichannelLUT

ImGearRasterProcessing.TransformWithLUT(page, LUT)
public static void TransformWithLUT(
   ImGearRasterPage page,
   ImGearMultichannelLUT LUT
)
public: static void TransformWithLUT(
   ImGearRasterPage* page,
   ImGearMultichannelLUT* LUT
)
public:
static void TransformWithLUT(
   ImGearRasterPage^ page,
   ImGearMultichannelLUT^ LUT
)

Parameters

page
Page to apply the LUT to.
LUT
Multichannel LUT that shall be applied.
Remarks
This method applies a multichannel lookup table to each channel of the image, optionally changing channel depths.

Number of single-channel LUTs in the multichannel LUT must match number of image channels. Input depth of each single-channel LUT must match the depth of corresponding channel. Depths of image channels after transform are determined by output depths of the coresponding single-channel LUTs.

Example
  • C#
// Make sure the image is gray.
if (!ImGearRasterProcessing.ImageIsGray(igRasterPage))
    return;
// Create a LUT to convert image from 8bit to 4bit while also inverting.
ImGearMultichannelLUT igMultichannelLUT = new ImGearMultichannelLUT(
    igRasterPage.DIB.ChannelCount, 8, 4);
for (int i = 0; i < 255; ++i )
{
    igMultichannelLUT[0][i] = 15 - (i / 16);
}
// Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage,igMultichannelLUT);
  • Visual Basic
' Make sure the image is gray.
If Not ImGearRasterProcessing.ImageIsGray(igRasterPage) Then
    Return
End If
' Create a LUT to convert image from 8bit to 4bit while also inverting.
Dim igMultichannelLUT As New ImGearMultichannelLUT(igRasterPage.DIB.ChannelCount, 8, 4)
For i As Integer = 0 To 254
    igMultichannelLUT(0)(i) = 15 - (i / 16)
Next
' Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage, igMultichannelLUT)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearRasterPage Class
ImGearMultichannelLUT Class


UpdateChannelFrom Method
Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : UpdateChannelFrom Method
Destination channel.
Source channel.
Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub UpdateChannelFrom( _
   ByVal channelToUpdate As ImGearChannelRef, _
   ByVal channelUpdateWith As ImGearChannelRef _
)
'Usage

Dim channelToUpdate As ImGearChannelRef
Dim channelUpdateWith As ImGearChannelRef

ImGearRasterProcessing.UpdateChannelFrom(channelToUpdate, channelUpdateWith)
public static void UpdateChannelFrom(
   ImGearChannelRef channelToUpdate,
   ImGearChannelRef channelUpdateWith
)
public: static void UpdateChannelFrom(
   ImGearChannelRef channelToUpdate,
   ImGearChannelRef channelUpdateWith
)
public:
static void UpdateChannelFrom(
   ImGearChannelRef channelToUpdate,
   ImGearChannelRef channelUpdateWith
)

Parameters

channelToUpdate
Destination channel.
channelUpdateWith
Source channel.
Example
  • C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);
  • Visual Basic
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
ImGearChannelRef Structure


%%PageItemTitle%% $$Properties$$

ImGearRasterProcessing Class Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessing Class

For a list of all members of this type, see ImGearRasterProcessing members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets ImGearRasterProcessingVerifier class object.
Top
See Also

Reference

ImGearRasterProcessing Class
ImageGear.Processing Namespace
ImGearRasterProcessingVerifier Class


Verifier Property (ImGearRasterProcessing)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessing Class : Verifier Property
Gets ImGearRasterProcessingVerifier class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGearRasterProcessingVerifier
'Usage

Dim value As ImGearRasterProcessingVerifier

value = ImGearRasterProcessing.Verifier
public static ImGearRasterProcessingVerifier Verifier {get;}
public: __property static ImGearRasterProcessingVerifier* get_Verifier();
public:
static property ImGearRasterProcessingVerifier^ Verifier {
   ImGearRasterProcessingVerifier^ get();
}

Property Value

ImGearRasterProcessingVerifier class object.
See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

ImGearRasterProcessingVerifier Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessingVerifier Class
Contains static methods that check whether particular ImGearRasterProcessing operations are applicable to the page.
Object Model
ImGearRasterProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRasterProcessingVerifier
'Usage

Dim instance As ImGearRasterProcessingVerifier
public sealed class ImGearRasterProcessingVerifier
public __gc __sealed class ImGearRasterProcessingVerifier
public ref class ImGearRasterProcessingVerifier sealed
Remarks
These methods should be used to distinguish a sub-set of pages for which particular filter is applicable; e.g., CanApplyGaussianBlur method returns true only if incoming page image is not binary, that is BitDepth > 1. Parameters of all IP methods are checked separately.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearRasterProcessingVerifier

See Also

Reference

ImGearRasterProcessingVerifier Members
ImageGear.Processing Namespace
ImGearRasterProcessing Class


%%PageItemTitle%% $$Members$$

ImGearRasterProcessingVerifier Class Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessingVerifier Class

The following tables list the members exposed by ImGearRasterProcessingVerifier.

Public Methods
 | Name | Description
Public Method | CanApplyAddTilt | Returns true if AddTilt method can be applied to the specified page.
Public Method | CanApplyAdjustContrast | Overloaded. Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyBlend | Returns true if Blend Method can be applied to the specified page, false otherwise.
Public Method | CanApplyBlendWithAlpha | Returns true if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified page, false otherwise.
Public Method | CanApplyCalculateStatistics | Returns true if ImGearRasterProcessing.CalculateStatistics method can be applied to the specified page, false otherwise.
Public Method | CanApplyClose | Checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.
Public Method | CanApplyConvertColorSpace | Returns true if ConvertColorSpace Method can be applied to the specified page, false otherwise.
Public Method | CanApplyConvolve | Returns true if ImGearRasterProcessing.Convolve method can be applied to the specified page, false otherwise.
Public Method | CanApplyCrypt | Returns true if ImGearRasterProcessing.Encrypt and ImGearRasterProcessing.Decrypt methods can be applied to the specified page, false otherwise.
Public Method | CanApplyDeskew | Returns true if ImGearRasterProcessing.Deskew method can be applied to the specified page, false otherwise.
Public Method | CanApplyDespeckle | Returns true if ImGearRasterProcessing.Despeckle method can be applied to the specified page, false otherwise.
Public Method | CanApplyDilate | Checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.
Public Method | CanApplyEnhanceLocal | Returns true if EnhanceLocal method can be applied to the specified page, false otherwise.
Public Method | CanApplyEqualizeContrast | Overloaded. Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyErode | Checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.
Public Method | CanApplyFill | Returns true if ImGearRasterProcessing.Fill method can be applied to the specified page using provided fillColor, false otherwise.
Public Method | CanApplyFilterWithMedian | Returns true if FilterWithMedian method can be applied to the specified page, false otherwise.
Public Method | CanApplyFilterWithUnsharpMask | Returns true if FilterWithUnsharpMask method can be applied to the specified page, false otherwise.
Public Method | CanApplyFindSkewAngle | Returns true if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified page, false otherwise.
Public Method | CanApplyFindTilt | Returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified page, false otherwise.
Public Method | CanApplyGaussianBlur | Returns true if Gaussian Method can be applied to the specified page, false otherwise.
Public Method | CanApplyGeomDespeckle | Returns true if GeomDespeckle method can be applied to the specified page, false otherwise.
Public Method | CanApplyInvertContrast | Overloaded. Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyMerge | Returns true if Merge Method can be applied to the specified page, false otherwise.
Public Method | CanApplyOpen | Checks if ImGearRasterProcessing.Open method can be applied to the specified raster page.
Public Method | CanApplyReduce | Returns true if ImGearRasterProcessing.Reduce method can be applied to the specified page, using specified reduction method, false otherwise.
Public Method | CanApplyRemoveTilt | Returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified page, false otherwise.
Public Method | CanApplySharpen | Returns true if Sharpen method can be applied to the specified page, false otherwise.
Public Method | CanApplySmooth | Verifies if Smooth method can be applied to the specified Page.
Public Method | CanApplyStretchContrast | Overloaded. Returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyTabulateHistogram | Checks whether ImGearRasterProcessing.TabulateHistogram method can be applied to the page.
Public Method | CanApplyTransformWithLUT | Checks whether ImGearRasterProcessing.TransformWithLUT method can be applied to the page.
Top
See Also

Reference

ImGearRasterProcessingVerifier Class
ImageGear.Processing Namespace
ImGearRasterProcessing Class


%%PageItemTitle%% $$Methods$$

ImGearRasterProcessingVerifier Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRasterProcessingVerifier Class

For a list of all members of this type, see ImGearRasterProcessingVerifier members.

Public Methods
 | Name | Description
Public Method | CanApplyAddTilt | Returns true if AddTilt method can be applied to the specified page.
Public Method | CanApplyAdjustContrast | Overloaded. Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyBlend | Returns true if Blend Method can be applied to the specified page, false otherwise.
Public Method | CanApplyBlendWithAlpha | Returns true if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified page, false otherwise.
Public Method | CanApplyCalculateStatistics | Returns true if ImGearRasterProcessing.CalculateStatistics method can be applied to the specified page, false otherwise.
Public Method | CanApplyClose | Checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.
Public Method | CanApplyConvertColorSpace | Returns true if ConvertColorSpace Method can be applied to the specified page, false otherwise.
Public Method | CanApplyConvolve | Returns true if ImGearRasterProcessing.Convolve method can be applied to the specified page, false otherwise.
Public Method | CanApplyCrypt | Returns true if ImGearRasterProcessing.Encrypt and ImGearRasterProcessing.Decrypt methods can be applied to the specified page, false otherwise.
Public Method | CanApplyDeskew | Returns true if ImGearRasterProcessing.Deskew method can be applied to the specified page, false otherwise.
Public Method | CanApplyDespeckle | Returns true if ImGearRasterProcessing.Despeckle method can be applied to the specified page, false otherwise.
Public Method | CanApplyDilate | Checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.
Public Method | CanApplyEnhanceLocal | Returns true if EnhanceLocal method can be applied to the specified page, false otherwise.
Public Method | CanApplyEqualizeContrast | Overloaded. Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyErode | Checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.
Public Method | CanApplyFill | Returns true if ImGearRasterProcessing.Fill method can be applied to the specified page using provided fillColor, false otherwise.
Public Method | CanApplyFilterWithMedian | Returns true if FilterWithMedian method can be applied to the specified page, false otherwise.
Public Method | CanApplyFilterWithUnsharpMask | Returns true if FilterWithUnsharpMask method can be applied to the specified page, false otherwise.
Public Method | CanApplyFindSkewAngle | Returns true if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified page, false otherwise.
Public Method | CanApplyFindTilt | Returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified page, false otherwise.
Public Method | CanApplyGaussianBlur | Returns true if Gaussian Method can be applied to the specified page, false otherwise.
Public Method | CanApplyGeomDespeckle | Returns true if GeomDespeckle method can be applied to the specified page, false otherwise.
Public Method | CanApplyInvertContrast | Overloaded. Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyMerge | Returns true if Merge Method can be applied to the specified page, false otherwise.
Public Method | CanApplyOpen | Checks if ImGearRasterProcessing.Open method can be applied to the specified raster page.
Public Method | CanApplyReduce | Returns true if ImGearRasterProcessing.Reduce method can be applied to the specified page, using specified reduction method, false otherwise.
Public Method | CanApplyRemoveTilt | Returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified page, false otherwise.
Public Method | CanApplySharpen | Returns true if Sharpen method can be applied to the specified page, false otherwise.
Public Method | CanApplySmooth | Verifies if Smooth method can be applied to the specified Page.
Public Method | CanApplyStretchContrast | Overloaded. Returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.
Public Method | CanApplyTabulateHistogram | Checks whether ImGearRasterProcessing.TabulateHistogram method can be applied to the page.
Public Method | CanApplyTransformWithLUT | Checks whether ImGearRasterProcessing.TransformWithLUT method can be applied to the page.
Top
See Also

Reference

ImGearRasterProcessingVerifier Class
ImageGear.Processing Namespace
ImGearRasterProcessing Class


CanApplyAddTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyAddTilt Method
Raster page object to verify.
Returns true if AddTilt method can be applied to the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyAddTilt( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyAddTilt(page)
public bool CanApplyAddTilt(
   ImGearRasterPage page
)
public: bool CanApplyAddTilt(
   ImGearRasterPage* page
)
public:
bool CanApplyAddTilt(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyAdjustContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyAdjustContrast Method
Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.
Overload List
Overload | Description
CanApplyAdjustContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.
CanApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page with the specified contrast mode, false otherwise.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


CanApplyAdjustContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyAdjustContrast Method : CanApplyAdjustContrast(ImGearRasterPage) Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyAdjustContrast( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyAdjustContrast(page)
public bool CanApplyAdjustContrast(
   ImGearRasterPage page
)
public: bool CanApplyAdjustContrast(
   ImGearRasterPage* page
)
public:
bool CanApplyAdjustContrast(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
Remarks
This method works in the same way as CanApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class


CanApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyAdjustContrast Method : CanApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) Method
Raster page object to verify.
Contrast mode.
Returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page with the specified contrast mode, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyAdjustContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim value As Boolean

value = instance.CanApplyAdjustContrast(page, mode)
public bool CanApplyAdjustContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)
public: bool CanApplyAdjustContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode
)
public:
bool CanApplyAdjustContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value.
Remarks
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration


CanApplyBlend Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyBlend Method
Raster page object to verify.
Page to blend with.
Returns true if Blend Method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyBlend( _
   ByVal page As ImGearRasterPage, _
   ByVal pageToBlendWith As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim pageToBlendWith As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyBlend(page, pageToBlendWith)
public bool CanApplyBlend(
   ImGearRasterPage page,
   ImGearRasterPage pageToBlendWith
)
public: bool CanApplyBlend(
   ImGearRasterPage* page,
   ImGearRasterPage* pageToBlendWith
)
public:
bool CanApplyBlend(
   ImGearRasterPage^ page,
   ImGearRasterPage^ pageToBlendWith
)

Parameters

page
Raster page object to verify.
pageToBlendWith
Page to blend with.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyBlendWithAlpha Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyBlendWithAlpha Method
Raster page object to verify.
Page to blend with.
Returns true if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyBlendWithAlpha( _
   ByVal page As ImGearRasterPage, _
   ByVal alpha As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim alpha As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyBlendWithAlpha(page, alpha)
public bool CanApplyBlendWithAlpha(
   ImGearRasterPage page,
   ImGearRasterPage alpha
)
public: bool CanApplyBlendWithAlpha(
   ImGearRasterPage* page,
   ImGearRasterPage* alpha
)
public:
bool CanApplyBlendWithAlpha(
   ImGearRasterPage^ page,
   ImGearRasterPage^ alpha
)

Parameters

page
Raster page object to verify.
alpha
Page to blend with.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
BlendWithAlpha Method


CanApplyCalculateStatistics Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyCalculateStatistics Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.CalculateStatistics method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCalculateStatistics( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyCalculateStatistics(page)
public bool CanApplyCalculateStatistics(
   ImGearRasterPage page
)
public: bool CanApplyCalculateStatistics(
   ImGearRasterPage* page
)
public:
bool CanApplyCalculateStatistics(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
CalculateStatistics Method


CanApplyClose Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyClose Method
Raster page object to verify.
Checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyClose( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyClose(page)
public bool CanApplyClose(
   ImGearRasterPage page
)
public: bool CanApplyClose(
   ImGearRasterPage* page
)
public:
bool CanApplyClose(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Close Method


CanApplyConvertColorSpace Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyConvertColorSpace Method
Raster page object to verify.
Color space.
Returns true if ConvertColorSpace Method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyConvertColorSpace( _
   ByVal page As ImGearRasterPage, _
   ByVal space As ImGearColorSpace _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim space As ImGearColorSpace
Dim value As Boolean

value = instance.CanApplyConvertColorSpace(page, space)
public bool CanApplyConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace space
)
public: bool CanApplyConvertColorSpace(
   ImGearRasterPage* page,
   ImGearColorSpace space
)
public:
bool CanApplyConvertColorSpace(
   ImGearRasterPage^ page,
   ImGearColorSpace space
)

Parameters

page
Raster page object to verify.
space
Color space.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
ImGearColorSpace Structure


CanApplyConvolve Method (ImGearRasterProcessingVerifier)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyConvolve Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.Convolve method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyConvolve( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyConvolve(page)
public bool CanApplyConvolve(
   ImGearRasterPage page
)
public: bool CanApplyConvolve(
   ImGearRasterPage* page
)
public:
bool CanApplyConvolve(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Convolve Method


CanApplyCrypt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyCrypt Method
Raster page object to verify.
Password to Encrypt/Decrypt the image with.
Returns true if ImGearRasterProcessing.Encrypt and ImGearRasterProcessing.Decrypt methods can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCrypt( _
   ByVal page As ImGearRasterPage, _
   ByVal password As String _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim password As String
Dim value As Boolean

value = instance.CanApplyCrypt(page, password)
public bool CanApplyCrypt(
   ImGearRasterPage page,
   string password
)
public: bool CanApplyCrypt(
   ImGearRasterPage* page,
   string* password
)
public:
bool CanApplyCrypt(
   ImGearRasterPage^ page,
   String^ password
)

Parameters

page
Raster page object to verify.
password
Password to Encrypt/Decrypt the image with.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Decrypt Method
Encrypt Method


CanApplyDeskew Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyDeskew Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.Deskew method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyDeskew( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyDeskew(page)
public bool CanApplyDeskew(
   ImGearRasterPage page
)
public: bool CanApplyDeskew(
   ImGearRasterPage* page
)
public:
bool CanApplyDeskew(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Deskew Method


CanApplyDespeckle Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyDespeckle Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.Despeckle method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyDespeckle( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyDespeckle(page)
public bool CanApplyDespeckle(
   ImGearRasterPage page
)
public: bool CanApplyDespeckle(
   ImGearRasterPage* page
)
public:
bool CanApplyDespeckle(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Despeckle Method


CanApplyDilate Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyDilate Method
Raster page object to verify.
Checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyDilate( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyDilate(page)
public bool CanApplyDilate(
   ImGearRasterPage page
)
public: bool CanApplyDilate(
   ImGearRasterPage* page
)
public:
bool CanApplyDilate(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Dilate Method


CanApplyEnhanceLocal Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyEnhanceLocal Method
Raster page object to verify.
Returns true if EnhanceLocal method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyEnhanceLocal( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyEnhanceLocal(page)
public bool CanApplyEnhanceLocal(
   ImGearRasterPage page
)
public: bool CanApplyEnhanceLocal(
   ImGearRasterPage* page
)
public:
bool CanApplyEnhanceLocal(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyEqualizeContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyEqualizeContrast Method
Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.
Overload List
Overload | Description
CanApplyEqualizeContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.
CanApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page and contrast mode, false otherwise.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


CanApplyEqualizeContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyEqualizeContrast Method : CanApplyEqualizeContrast(ImGearRasterPage) Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyEqualizeContrast( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyEqualizeContrast(page)
public bool CanApplyEqualizeContrast(
   ImGearRasterPage page
)
public: bool CanApplyEqualizeContrast(
   ImGearRasterPage* page
)
public:
bool CanApplyEqualizeContrast(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
Remarks
This method works in the same way as CanApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class


CanApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyEqualizeContrast Method : CanApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) Method
Raster page object to verify.
Contrast mode.
Returns true if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page and contrast mode, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyEqualizeContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim value As Boolean

value = instance.CanApplyEqualizeContrast(page, mode)
public bool CanApplyEqualizeContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)
public: bool CanApplyEqualizeContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode
)
public:
bool CanApplyEqualizeContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration


CanApplyErode Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyErode Method
Raster page object to verify.
Checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyErode( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyErode(page)
public bool CanApplyErode(
   ImGearRasterPage page
)
public: bool CanApplyErode(
   ImGearRasterPage* page
)
public:
bool CanApplyErode(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Erode Method


CanApplyFill Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyFill Method
Raster page object to verify.
The fill color. It must not be null.
Returns true if ImGearRasterProcessing.Fill method can be applied to the specified page using provided fillColor, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFill( _
   ByVal page As ImGearRasterPage, _
   ByVal fillColor As IImGearRGBQuad _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim fillColor As IImGearRGBQuad
Dim value As Boolean

value = instance.CanApplyFill(page, fillColor)
public bool CanApplyFill(
   ImGearRasterPage page,
   IImGearRGBQuad fillColor
)
public: bool CanApplyFill(
   ImGearRasterPage* page,
   IImGearRGBQuad* fillColor
)
public:
bool CanApplyFill(
   ImGearRasterPage^ page,
   IImGearRGBQuad^ fillColor
)

Parameters

page
Raster page object to verify.
fillColor
The fill color. It must not be null.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
IImGearRGBQuad Interface


CanApplyFilterWithMedian Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyFilterWithMedian Method
Raster page object to verify.
Returns true if FilterWithMedian method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFilterWithMedian( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFilterWithMedian(page)
public bool CanApplyFilterWithMedian(
   ImGearRasterPage page
)
public: bool CanApplyFilterWithMedian(
   ImGearRasterPage* page
)
public:
bool CanApplyFilterWithMedian(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyFilterWithUnsharpMask Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyFilterWithUnsharpMask Method
Raster page object to verify.
Returns true if FilterWithUnsharpMask method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFilterWithUnsharpMask( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFilterWithUnsharpMask(page)
public bool CanApplyFilterWithUnsharpMask(
   ImGearRasterPage page
)
public: bool CanApplyFilterWithUnsharpMask(
   ImGearRasterPage* page
)
public:
bool CanApplyFilterWithUnsharpMask(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyFindSkewAngle Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyFindSkewAngle Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFindSkewAngle( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFindSkewAngle(page)
public bool CanApplyFindSkewAngle(
   ImGearRasterPage page
)
public: bool CanApplyFindSkewAngle(
   ImGearRasterPage* page
)
public:
bool CanApplyFindSkewAngle(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
FindSkewAngle Method


CanApplyFindTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyFindTilt Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFindTilt( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFindTilt(page)
public bool CanApplyFindTilt(
   ImGearRasterPage page
)
public: bool CanApplyFindTilt(
   ImGearRasterPage* page
)
public:
bool CanApplyFindTilt(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyGaussianBlur Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyGaussianBlur Method
Raster page object to verify.
Returns true if Gaussian Method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyGaussianBlur( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyGaussianBlur(page)
public bool CanApplyGaussianBlur(
   ImGearRasterPage page
)
public: bool CanApplyGaussianBlur(
   ImGearRasterPage* page
)
public:
bool CanApplyGaussianBlur(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


CanApplyGeomDespeckle Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyGeomDespeckle Method
Raster page object to verify.
Returns true if GeomDespeckle method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyGeomDespeckle( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyGeomDespeckle(page)
public bool CanApplyGeomDespeckle(
   ImGearRasterPage page
)
public: bool CanApplyGeomDespeckle(
   ImGearRasterPage* page
)
public:
bool CanApplyGeomDespeckle(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyInvertContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyInvertContrast Method
Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page, false otherwise.
Overload List
Overload | Description
CanApplyInvertContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page, false otherwise.
CanApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page and specified contrast mode, false otherwise.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


CanApplyInvertContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyInvertContrast Method : CanApplyInvertContrast(ImGearRasterPage) Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyInvertContrast( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyInvertContrast(page)
public bool CanApplyInvertContrast(
   ImGearRasterPage page
)
public: bool CanApplyInvertContrast(
   ImGearRasterPage* page
)
public:
bool CanApplyInvertContrast(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
Remarks
This method works in the same way as CanApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class


CanApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyInvertContrast Method : CanApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) Method
Raster page object to verify.
Contrast mode.
Returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page and specified contrast mode, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyInvertContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim value As Boolean

value = instance.CanApplyInvertContrast(page, mode)
public bool CanApplyInvertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)
public: bool CanApplyInvertContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode
)
public:
bool CanApplyInvertContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration


CanApplyMerge Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyMerge Method
Raster page object to verify.
Page to merge.
Returns true if Merge Method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyMerge( _
   ByVal page As ImGearRasterPage, _
   ByVal pageToMergeWith As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim pageToMergeWith As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyMerge(page, pageToMergeWith)
public bool CanApplyMerge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith
)
public: bool CanApplyMerge(
   ImGearRasterPage* page,
   ImGearRasterPage* pageToMergeWith
)
public:
bool CanApplyMerge(
   ImGearRasterPage^ page,
   ImGearRasterPage^ pageToMergeWith
)

Parameters

page
Raster page object to verify.
pageToMergeWith
Page to merge.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyOpen Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyOpen Method
Raster page object to verify.
Checks if ImGearRasterProcessing.Open method can be applied to the specified raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyOpen( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyOpen(page)
public bool CanApplyOpen(
   ImGearRasterPage page
)
public: bool CanApplyOpen(
   ImGearRasterPage* page
)
public:
bool CanApplyOpen(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Open Method


CanApplyReduce Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyReduce Method
Raster page to verify.
Reduction method.
Returns true if ImGearRasterProcessing.Reduce method can be applied to the specified page, using specified reduction method, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyReduce( _
   ByVal page As ImGearRasterPage, _
   ByVal reductionMethod As ImGearReductionMethods _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim reductionMethod As ImGearReductionMethods
Dim value As Boolean

value = instance.CanApplyReduce(page, reductionMethod)
public bool CanApplyReduce(
   ImGearRasterPage page,
   ImGearReductionMethods reductionMethod
)
public: bool CanApplyReduce(
   ImGearRasterPage* page,
   ImGearReductionMethods reductionMethod
)
public:
bool CanApplyReduce(
   ImGearRasterPage^ page,
   ImGearReductionMethods reductionMethod
)

Parameters

page
Raster page to verify.
reductionMethod
Reduction method.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
Reduce Method
ImGearReductionMethods Enumeration


CanApplyRemoveTilt Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyRemoveTilt Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRemoveTilt( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyRemoveTilt(page)
public bool CanApplyRemoveTilt(
   ImGearRasterPage page
)
public: bool CanApplyRemoveTilt(
   ImGearRasterPage* page
)
public:
bool CanApplyRemoveTilt(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplySharpen Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplySharpen Method
Raster page object to verify.
Returns true if Sharpen method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySharpen( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySharpen(page)
public bool CanApplySharpen(
   ImGearRasterPage page
)
public: bool CanApplySharpen(
   ImGearRasterPage* page
)
public:
bool CanApplySharpen(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplySmooth Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplySmooth Method
Raster page object to verify.
Verifies if Smooth method can be applied to the specified Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySmooth( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySmooth(page)
public bool CanApplySmooth(
   ImGearRasterPage page
)
public: bool CanApplySmooth(
   ImGearRasterPage* page
)
public:
bool CanApplySmooth(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class


CanApplyStretchContrast Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyStretchContrast Method
Returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.
Overload List
Overload | Description
CanApplyStretchContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.
CanApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) | Returns true, if ImGearRasterProcessing.StretchContrast method can be applied to the specified page with the specified contrast mode, false otherwise.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


CanApplyStretchContrast(ImGearRasterPage) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyStretchContrast Method : CanApplyStretchContrast(ImGearRasterPage) Method
Raster page object to verify.
Returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyStretchContrast( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyStretchContrast(page)
public bool CanApplyStretchContrast(
   ImGearRasterPage page
)
public: bool CanApplyStretchContrast(
   ImGearRasterPage* page
)
public:
bool CanApplyStretchContrast(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
Remarks
This method works in the same way as CanApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


CanApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class > CanApplyStretchContrast Method : CanApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) Method
Raster page object to verify.
Contrast mode.
Returns true, if ImGearRasterProcessing.StretchContrast method can be applied to the specified page with the specified contrast mode, false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CanApplyStretchContrast( _
   ByVal page As ImGearRasterPage, _
   ByVal mode As ImGearContrastModes _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim mode As ImGearContrastModes
Dim value As Boolean

value = instance.CanApplyStretchContrast(page, mode)
public bool CanApplyStretchContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)
public: bool CanApplyStretchContrast(
   ImGearRasterPage* page,
   ImGearContrastModes mode
)
public:
bool CanApplyStretchContrast(
   ImGearRasterPage^ page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List
ImGearRasterPage Class
ImGearContrastModes Enumeration


CanApplyTabulateHistogram Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyTabulateHistogram Method
Raster page object to verify.
Checks whether ImGearRasterProcessing.TabulateHistogram method can be applied to the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyTabulateHistogram( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyTabulateHistogram(page)
public bool CanApplyTabulateHistogram(
   ImGearRasterPage page
)
public: bool CanApplyTabulateHistogram(
   ImGearRasterPage* page
)
public:
bool CanApplyTabulateHistogram(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
TabulateHistogram Method


CanApplyTransformWithLUT Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearRasterProcessingVerifier Class : CanApplyTransformWithLUT Method
Raster page object to verify.
Checks whether ImGearRasterProcessing.TransformWithLUT method can be applied to the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyTransformWithLUT( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearRasterProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyTransformWithLUT(page)
public bool CanApplyTransformWithLUT(
   ImGearRasterPage page
)
public: bool CanApplyTransformWithLUT(
   ImGearRasterPage* page
)
public:
bool CanApplyTransformWithLUT(
   ImGearRasterPage^ page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.
See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
ImGearRasterPage Class
TransformWithLUT Method


%%PageItemTitle%%

ImGearReductionOptions Class
Members Example

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearReductionOptions Class
Specifies options for performing color reduction using the ImGearRasterProcessing.Reduce method.
Object Model
ImGearReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearReductionOptions
'Usage

Dim instance As ImGearReductionOptions
public class ImGearReductionOptions
public __gc class ImGearReductionOptions
public ref class ImGearReductionOptions
Remarks
The only options used by the ImGearRasterProcessing.Reduce method are the ones which correspond to the type of reduction as specified by the reductionMethod parameter of the ImGearRasterProcessing.Reduce method.
Example
  • C#
// Reduce the bit depth of an image to 4 bit

// Create reduction options object and setup a few values for a 16 color 4-bit reduction.
ImGearReductionOptions igReductionOptions = new ImGearReductionOptions();
igReductionOptions.Octree.MaxColors = 16;
igReductionOptions.Octree.FastRemap = false;
igReductionOptions.Octree.ErrorDiffusion = true;
//Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 4 }, ImGearReductionMethods.OCTREE, igReductionOptions);
  • Visual Basic
' Reduce the bit depth of an image to 4 bit

' Create reduction options object and setup a few values for a 16 color 4-bit reduction.
Dim igReductionOptions As New ImGearReductionOptions()
igReductionOptions.Octree.MaxColors = 16
igReductionOptions.Octree.FastRemap = False
igReductionOptions.Octree.ErrorDiffusion = True
'Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.I), New Integer() {4}, _
 ImGearReductionMethods.OCTREE, igReductionOptions)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearReductionOptions

See Also

Reference

ImGearReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearReductionOptions Class

The following tables list the members exposed by ImGearReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearReductionOptions Constructor | Initializes a new instance of the ImGearReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | Bayer | Specifies ImGearBayerReductionOptions class options for color reduction.
Public Field | Bitonal | Specifies ImGearBitonalReductionOptions class options for color reduction.
Public Field | Diffuse | Specifies ImGearDiffuseReductionOptions class options for color reduction.
Public Field | Halftone | Specifies ImGearHalftoneReductionOptions class options for color reduction.
Public Field | Median | Specifies ImGearMedianCutReductionOptions class options for color reduction.
Public Field | Octree | Specifies ImGearOctreeReductionOptions class options for color reduction.
Public Field | Popularity | Specifies ImGearPopularityReductionOptions class options for color reduction.
Public Field | Scale | Specifies ImGearScaleReductionOptions class options for color reduction.
Top
See Also

Reference

ImGearReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : ImGearReductionOptions Constructor
Initializes a new instance of the ImGearReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearReductionOptions()
public ImGearReductionOptions()
public: ImGearReductionOptions();
public:
ImGearReductionOptions();
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearReductionOptions Class


%%PageItemTitle%% $$Fields$$

ImGearReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearReductionOptions Class

For a list of all members of this type, see ImGearReductionOptions members.

Public Fields
 | Name | Description
Public Field | Bayer | Specifies ImGearBayerReductionOptions class options for color reduction.
Public Field | Bitonal | Specifies ImGearBitonalReductionOptions class options for color reduction.
Public Field | Diffuse | Specifies ImGearDiffuseReductionOptions class options for color reduction.
Public Field | Halftone | Specifies ImGearHalftoneReductionOptions class options for color reduction.
Public Field | Median | Specifies ImGearMedianCutReductionOptions class options for color reduction.
Public Field | Octree | Specifies ImGearOctreeReductionOptions class options for color reduction.
Public Field | Popularity | Specifies ImGearPopularityReductionOptions class options for color reduction.
Public Field | Scale | Specifies ImGearScaleReductionOptions class options for color reduction.
Top
See Also

Reference

ImGearReductionOptions Class
ImageGear.Processing Namespace


Bayer Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Bayer Field
Specifies ImGearBayerReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Bayer As ImGearBayerReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearBayerReductionOptions

value = instance.Bayer

instance.Bayer = value
public ImGearBayerReductionOptions Bayer
public: ImGearBayerReductionOptions* Bayer
public:
ImGearBayerReductionOptions^ Bayer

Field Value

ImGearBayerReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearBayerReductionOptions Class


Bitonal Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Bitonal Field
Specifies ImGearBitonalReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Bitonal As ImGearBitonalReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearBitonalReductionOptions

value = instance.Bitonal

instance.Bitonal = value
public ImGearBitonalReductionOptions Bitonal
public: ImGearBitonalReductionOptions* Bitonal
public:
ImGearBitonalReductionOptions^ Bitonal

Field Value

ImGearBitonalReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearBitonalReductionOptions Class


Diffuse Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Diffuse Field
Specifies ImGearDiffuseReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Diffuse As ImGearDiffuseReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearDiffuseReductionOptions

value = instance.Diffuse

instance.Diffuse = value
public ImGearDiffuseReductionOptions Diffuse
public: ImGearDiffuseReductionOptions* Diffuse
public:
ImGearDiffuseReductionOptions^ Diffuse

Field Value

ImGearDiffuseReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearDiffuseReductionOptions Class


Halftone Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Halftone Field
Specifies ImGearHalftoneReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Halftone As ImGearHalftoneReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearHalftoneReductionOptions

value = instance.Halftone

instance.Halftone = value
public ImGearHalftoneReductionOptions Halftone
public: ImGearHalftoneReductionOptions* Halftone
public:
ImGearHalftoneReductionOptions^ Halftone

Field Value

ImGearHalftoneReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearHalftoneReductionOptions Class


Median Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Median Field
Specifies ImGearMedianCutReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Median As ImGearMedianCutReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearMedianCutReductionOptions

value = instance.Median

instance.Median = value
public ImGearMedianCutReductionOptions Median
public: ImGearMedianCutReductionOptions* Median
public:
ImGearMedianCutReductionOptions^ Median

Field Value

ImGearMedianCutReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearMedianCutReductionOptions Class


Octree Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Octree Field
Specifies ImGearOctreeReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Octree As ImGearOctreeReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearOctreeReductionOptions

value = instance.Octree

instance.Octree = value
public ImGearOctreeReductionOptions Octree
public: ImGearOctreeReductionOptions* Octree
public:
ImGearOctreeReductionOptions^ Octree

Field Value

ImGearOctreeReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearOctreeReductionOptions Class


Popularity Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Popularity Field
Specifies ImGearPopularityReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Popularity As ImGearPopularityReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearPopularityReductionOptions

value = instance.Popularity

instance.Popularity = value
public ImGearPopularityReductionOptions Popularity
public: ImGearPopularityReductionOptions* Popularity
public:
ImGearPopularityReductionOptions^ Popularity

Field Value

ImGearPopularityReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearPopularityReductionOptions Class


Scale Field (ImGearReductionOptions)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearReductionOptions Class : Scale Field
Specifies ImGearScaleReductionOptions class options for color reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Scale As ImGearScaleReductionOptions
'Usage

Dim instance As ImGearReductionOptions
Dim value As ImGearScaleReductionOptions

value = instance.Scale

instance.Scale = value
public ImGearScaleReductionOptions Scale
public: ImGearScaleReductionOptions* Scale
public:
ImGearScaleReductionOptions^ Scale

Field Value

ImGearScaleReductionOptions class object.
See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members
ImGearScaleReductionOptions Class


%%PageItemTitle%%

ImGearScaleReductionOptions Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearScaleReductionOptions Class
Defines reduction options for scale reduction.
Object Model
ImGearScaleReductionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearScaleReductionOptions
'Usage

Dim instance As ImGearScaleReductionOptions
public class ImGearScaleReductionOptions
public __gc class ImGearScaleReductionOptions
public ref class ImGearScaleReductionOptions
Remarks
This class defines reduction options for scale reduction. Scale reduction can be performed on an image whose color space is anything but indexed. The output image will always have the same color space as the input image. It works by linearly scaling the component values for each pixel to the desired output depths. For example, you could reduce a 24bpp (8-8-8) RGB image to 16bpp (5-6-5) RGB. Simply specify the desired output channel depths (and color space) in the parameters for the Reduce method.

Note: You can set DontScalePixels option to true to avoid scaling the pixel values. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different.

Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearScaleReductionOptions

See Also

Reference

ImGearScaleReductionOptions Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearScaleReductionOptions Class Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearScaleReductionOptions Class

The following tables list the members exposed by ImGearScaleReductionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearScaleReductionOptions Constructor | Initializes a new instance of the ImGearScaleReductionOptions class object.
Top
Public Fields
 | Name | Description
Public Field | DontScalePixels | Set to true to avoid scaling the pixel values.
Top
See Also

Reference

ImGearScaleReductionOptions Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearScaleReductionOptions Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearScaleReductionOptions Class : ImGearScaleReductionOptions Constructor
Initializes a new instance of the ImGearScaleReductionOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearScaleReductionOptions()
public ImGearScaleReductionOptions()
public: ImGearScaleReductionOptions();
public:
ImGearScaleReductionOptions();
See Also

Reference

ImGearScaleReductionOptions Class
ImGearScaleReductionOptions Members


%%PageItemTitle%% $$Fields$$

ImGearScaleReductionOptions Class Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearScaleReductionOptions Class

For a list of all members of this type, see ImGearScaleReductionOptions members.

Public Fields
 | Name | Description
Public Field | DontScalePixels | Set to true to avoid scaling the pixel values.
Top
See Also

Reference

ImGearScaleReductionOptions Class
ImageGear.Processing Namespace


DontScalePixels Field

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearScaleReductionOptions Class : DontScalePixels Field
Set to true to avoid scaling the pixel values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public DontScalePixels As Boolean
'Usage

Dim instance As ImGearScaleReductionOptions
Dim value As Boolean

value = instance.DontScalePixels

instance.DontScalePixels = value
public bool DontScalePixels
public: bool DontScalePixels
public:
bool DontScalePixels

Field Value

Boolean value.
Remarks
In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different. For example, if you have a 16bpp grayscale image but each pixel value actually only ranges from 0-255, and you want 0 to represent black and 255 to represent white, it makes sense to set this option to true and avoid scaling the values. If scaling were used in such a case, the image would appear black since the brightest possible value (255) would be scaled down to almost nothing: (255/65535) * 255 = 1.
See Also

Reference

ImGearScaleReductionOptions Class
ImGearScaleReductionOptions Members


%%PageItemTitle%%

ImGearWhiteBalance Class
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearWhiteBalance Class
Represents white balance as a pair of color temperature and tint.
Object Model
ImGearWhiteBalance ClassImGearDoublePoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearWhiteBalance
'Usage

Dim instance As ImGearWhiteBalance
public sealed class ImGearWhiteBalance
public __gc __sealed class ImGearWhiteBalance
public ref class ImGearWhiteBalance sealed
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearWhiteBalance

See Also

Reference

ImGearWhiteBalance Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearWhiteBalance Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearWhiteBalance Class

The following tables list the members exposed by ImGearWhiteBalance.

Public Constructors
 | Name | Description
Public Constructor | ImGearWhiteBalance Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Temperature | Gets or sets the color temperature.
Public Property | Tint | Gets or sets the tint.
Top
Public Methods
 | Name | Description
Public Method | GetWhiteXY | Returns XY coordinates of white point, corresponding to the color temperature.
Top
See Also

Reference

ImGearWhiteBalance Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearWhiteBalance Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class : ImGearWhiteBalance Constructor
Overload List
Overload | Description
ImGearWhiteBalance Constructor(Double,Double) | Initializes a new instance of the ImGearWhiteBalance class.
ImGearWhiteBalance Constructor(ImGearDoublePoint) | Initializes a new instance of the ImGearWhiteBalance class from XY coordinates of a white point.
ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset) | Initializes a new instance of the ImGearWhiteBalance class using preset values.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

ImGearWhiteBalance Constructor(Double,Double)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(Double,Double)
Color temperature in Kelvins.
Tint value.
Initializes a new instance of the ImGearWhiteBalance class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal temperature As Double, _
   ByVal tint As Double _
)
'Usage

Dim temperature As Double
Dim tint As Double

Dim instance As New ImGearWhiteBalance(temperature, tint)
public ImGearWhiteBalance(
   double temperature,
   double tint
)
public: ImGearWhiteBalance(
   double temperature,
   double tint
)
public:
ImGearWhiteBalance(
   double temperature,
   double tint
)

Parameters

temperature
Color temperature in Kelvins.
tint
Tint value.
Remarks
Setting a greater temperature for an image results in more yellow color; lower temperature results in more blue color. Useful range for temperature is between 2000 and 10000.

Setting a greater tint value for an image results in a more magenta color, lower tint values result in a greener color. Useful range for tint is between -50 and 50.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List
ImGearWhiteBalance Class


%%PageItemTitle%%

ImGearWhiteBalance Constructor(ImGearDoublePoint)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(ImGearDoublePoint)
Coordinates of a white point.
Initializes a new instance of the ImGearWhiteBalance class from XY coordinates of a white point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal whitePoint As ImGearDoublePoint _
)
'Usage

Dim whitePoint As ImGearDoublePoint

Dim instance As New ImGearWhiteBalance(whitePoint)
public ImGearWhiteBalance(
   ImGearDoublePoint whitePoint
)
public: ImGearWhiteBalance(
   ImGearDoublePoint whitePoint
)
public:
ImGearWhiteBalance(
   ImGearDoublePoint whitePoint
)

Parameters

whitePoint
Coordinates of a white point.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List
ImGearWhiteBalance Class
ImGearDoublePoint Structure


%%PageItemTitle%%

ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset)
Preset white balance identifier.
Initializes a new instance of the ImGearWhiteBalance class using preset values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal preset As ImGearWhiteBalancePreset _
)
'Usage

Dim preset As ImGearWhiteBalancePreset

Dim instance As New ImGearWhiteBalance(preset)
public ImGearWhiteBalance(
   ImGearWhiteBalancePreset preset
)
public: ImGearWhiteBalance(
   ImGearWhiteBalancePreset preset
)
public:
ImGearWhiteBalance(
   ImGearWhiteBalancePreset preset
)

Parameters

preset
Preset white balance identifier.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List
ImGearWhiteBalance Class
ImGearWhiteBalancePreset Enumeration


%%PageItemTitle%% $$Methods$$

ImGearWhiteBalance Class Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearWhiteBalance Class

For a list of all members of this type, see ImGearWhiteBalance members.

Public Methods
 | Name | Description
Public Method | GetWhiteXY | Returns XY coordinates of white point, corresponding to the color temperature.
Top
See Also

Reference

ImGearWhiteBalance Class
ImageGear.Processing Namespace


GetWhiteXY Method

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class : GetWhiteXY Method
Returns XY coordinates of white point, corresponding to the color temperature.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetWhiteXY() As ImGearDoublePoint
'Usage

Dim instance As ImGearWhiteBalance
Dim value As ImGearDoublePoint

value = instance.GetWhiteXY()
public ImGearDoublePoint GetWhiteXY()
public: ImGearDoublePoint GetWhiteXY();
public:
ImGearDoublePoint GetWhiteXY();

Return Value

ImageGear.Core.ImGearDoublePoint structure.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
ImGearDoublePoint Structure
ImGearWhiteBalance Class


%%PageItemTitle%% $$Properties$$

ImGearWhiteBalance Class Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearWhiteBalance Class

For a list of all members of this type, see ImGearWhiteBalance members.

Public Properties
 | Name | Description
Public Property | Temperature | Gets or sets the color temperature.
Public Property | Tint | Gets or sets the tint.
Top
See Also

Reference

ImGearWhiteBalance Class
ImageGear.Processing Namespace


Temperature Property (ImGearWhiteBalance)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class : Temperature Property
Gets or sets the color temperature.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Temperature As Double
'Usage

Dim instance As ImGearWhiteBalance
Dim value As Double

instance.Temperature = value

value = instance.Temperature
public double Temperature {get; set;}
public: __property double get_Temperature();
public: __property void set_Temperature(
   double value
);
public:
property double Temperature {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
ImGearWhiteBalance Class


Tint Property (ImGearWhiteBalance)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearWhiteBalance Class : Tint Property
Gets or sets the tint.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tint As Double
'Usage

Dim instance As ImGearWhiteBalance
Dim value As Double

instance.Tint = value

value = instance.Tint
public double Tint {get; set;}
public: __property double get_Tint();
public: __property void set_Tint(
   double value
);
public:
property double Tint {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
ImGearWhiteBalance Class


%%PageItemTitle%%

ImGearBitonalReductionModes Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBitonalReductionModes Enumeration
Specifies modes for the bitonal color reduction method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBitonalReductionModes
   Inherits System.Enum
'Usage

Dim instance As ImGearBitonalReductionModes
public enum ImGearBitonalReductionModes : System.Enum
__value public enum ImGearBitonalReductionModes : public System.Enum
public enum class ImGearBitonalReductionModes : public System.Enum
Members
Member | Value | Description
AVERAGE | 1 | Average mode.
GRAYSCALE | 0 | Grayscale mode.
WEIGHTED | 2 | Weighted mode.
Remarks
Please, see ImGearBitonalReductionOptions class reference.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearBitonalReductionModes

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearBrushType Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearBrushType Enumeration
Specifies brush types for Pointillist effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBrushType
   Inherits System.Enum
'Usage

Dim instance As ImGearBrushType
public enum ImGearBrushType : System.Enum
__value public enum ImGearBrushType : public System.Enum
public enum class ImGearBrushType : public System.Enum
Members
Member | Value | Description
Points | 0 | Each point is a randomly shaped polygon whose shape imitates a paint brush contacting the canvas.
Sticker | 1 | Each point is a circle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearBrushType

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearCFAColor Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearCFAColor Enumeration
Specifies the available colors for Color Filter Array encoded images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCFAColor
   Inherits System.Enum
'Usage

Dim instance As ImGearCFAColor
public enum ImGearCFAColor : System.Enum
__value public enum ImGearCFAColor : public System.Enum
public enum class ImGearCFAColor : public System.Enum
Members
Member | Value | Description
Blue | 2 | Blue color.
Cyan | 3 | Cyan color.
Green | 1 | Green color.
Magenta | 4 | Magenta color.
Red | 0 | Red color.
White | 6 | White color.
Yellow | 5 | Yellow color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearCFAColor

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearChannelGroups Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelGroups Enumeration
Specifies groups of DIB channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearChannelGroups
   Inherits System.Enum
'Usage

Dim instance As ImGearChannelGroups
public enum ImGearChannelGroups : System.Enum
__value public enum ImGearChannelGroups : public System.Enum
public enum class ImGearChannelGroups : public System.Enum
Members
Member | Value | Description
ALL | 5 | All channels.
ALPHA | 1 | Alpha channel.
ALPHA_EXTRA | 4 | Alpha and extra channels.
COLOR | 0 | Color channels.
COLOR_ALPHA | 3 | Color and alpha channels.
EXTRA | 2 | Extra channels.
Remarks
These values are passed to the ImageGear.Core.ImGearChannelRange structure constructor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearChannelGroups

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearContrastModes Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearContrastModes Enumeration
Specifies contrast processing modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearContrastModes
   Inherits System.Enum
'Usage

Dim instance As ImGearContrastModes
public enum ImGearContrastModes : System.Enum
__value public enum ImGearContrastModes : public System.Enum
public enum class ImGearContrastModes : public System.Enum
Members
Member | Value | Description
AUTO | 2 | If image is Indexed and its palette is not grayscale, applies contrast on palette; otherwise applies contrast on pixels.
PALETTE | 0 | Applies contrast on image palette. If the image does not have a palette, an exception is generated.
PIXEL | 1 | Applies contrast on image pixels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearContrastModes

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearConvolutionResults Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearConvolutionResults Enumeration
Specifies types of convolution result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearConvolutionResults
   Inherits System.Enum
'Usage

Dim instance As ImGearConvolutionResults
public enum ImGearConvolutionResults : System.Enum
__value public enum ImGearConvolutionResults : public System.Enum
public enum class ImGearConvolutionResults : public System.Enum
Members
Member | Value | Description
ABS | 1 | Absolute value of the signed result is stored.
CENTERED | 3 | Result is stored as 8-bit signed, but 0 is equal to 0x7F. Positive numbers are from 0x7E to 0x00. Negative numbers are from 0x80 to 0xFF. This is used for images that are to be used as background tiles or watermarks.
RAW | 0 | Result is stored as is.
SIGNED | 2 | Result is stored as 8-bit signed values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearConvolutionResults

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearDirection Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearDirection Enumeration
Defines a direction of a shadow effect (location of the light source).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDirection
   Inherits System.Enum
'Usage

Dim instance As ImGearDirection
public enum ImGearDirection : System.Enum
__value public enum ImGearDirection : public System.Enum
public enum class ImGearDirection : public System.Enum
Members
Member | Value | Description
East | 3 | East location.
North | 0 | North location.
NorthEast | 7 | NorthEast location.
NorthWest | 4 | NorthWest location.
South | 2 | South location.
SouthEast | 6 | SouthEast location.
SouthWest | 5 | SouthWest location.
West | 1 | West location.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearDirection

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearEdgeDetectionMethods Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearEdgeDetectionMethods Enumeration
Defines the edge detection methods supported by ImageGear.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEdgeDetectionMethods
   Inherits System.Enum
'Usage

Dim instance As ImGearEdgeDetectionMethods
public enum ImGearEdgeDetectionMethods : System.Enum
__value public enum ImGearEdgeDetectionMethods : public System.Enum
public enum class ImGearEdgeDetectionMethods : public System.Enum
Members
Member | Value | Description
DIFF_RECURSIVE | 2 | Edge detection using an optimal difference recursive filter.
MAXGRADIENT | 0 | Edge detection using the maxima of gradient, i.e., maxima of the first order derivative.
ZEROXC_DERIV2ND | 1 | Edge detection using the zero-crossings of second order derivative along the gradient.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearEdgeDetectionMethods

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearEdgeMapMethods Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearEdgeMapMethods Enumeration
Specifies types of edge map operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEdgeMapMethods
   Inherits System.Enum
'Usage

Dim instance As ImGearEdgeMapMethods
public enum ImGearEdgeMapMethods : System.Enum
__value public enum ImGearEdgeMapMethods : public System.Enum
public enum class ImGearEdgeMapMethods : public System.Enum
Members
Member | Value | Description
DIAG_NEG_45 | 7 | Diagonal negative edge map.
DIAG_POS_45 | 6 | Diagonal positive edge map.
HORIZONTAL | 4 | Horizontal edge map.
LAPLACIAN | 3 | Laplacian edge map.
LOG | 8 | Laplacian of Gaussian edge map.
PREWITT | 0 | Prewitt edge map.
ROBERTS | 1 | Roberts edge map.
SOBEL | 2 | Sobel edge map.
VERTICAL | 5 | Vertical edge map.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearEdgeMapMethods

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearHalftoneReductionModes Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearHalftoneReductionModes Enumeration
Specifies mode of halftone color reduction method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearHalftoneReductionModes
   Inherits System.Enum
'Usage

Dim instance As ImGearHalftoneReductionModes
public enum ImGearHalftoneReductionModes : System.Enum
__value public enum ImGearHalftoneReductionModes : public System.Enum
public enum class ImGearHalftoneReductionModes : public System.Enum
Members
Member | Value | Description
SQUARES | 0 | Squares mode.
Remarks
See ImGearHalftoneReductionOptions class description for more details.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearHalftoneReductionModes

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearIlluminant Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearIlluminant Enumeration
Lists standard illuminants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIlluminant
   Inherits System.Enum
'Usage

Dim instance As ImGearIlluminant
public enum ImGearIlluminant : System.Enum
__value public enum ImGearIlluminant : public System.Enum
public enum class ImGearIlluminant : public System.Enum
Members
Member | Value | Description
CloudyWeather | 10 | CloudyWeather illuminant.
CoolWhiteFluorescent | 14 | CoolWhiteFluorescent illuminant.
D50 | 23 | D50 illuminant.
D55 | 20 | D55 illuminant.
D65 | 21 | D65 illuminant.
D75 | 22 | D75 illuminant.
Daylight | 1 | Daylight illuminant.
DaylightFluorescent | 12 | DaylightFluorescent illuminant.
DayWhiteFluorescent | 13 | DayWhiteFluorescent illuminant.
FineWeather | 9 | FineWeather illuminant.
Flash | 4 | Flash illuminant.
Fluorescent | 2 | Fluorescent illuminant.
ISOStudioTungsten | 24 | ISOStudioTungsten illuminant.
Other | 255 | Other illuminant.
Shade | 11 | Shade illuminant.
StandardA | 17 | StandardA illuminant.
StandardB | 18 | StandardB illuminant.
StandardC | 19 | StandardC illuminant.
Tungsten | 3 | Tungsten illuminant.
Unknown | 0 | Unknown illuminant.
WhiteFluorescent | 15 | WhiteFluorescent illuminant.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearIlluminant

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearInterpolations Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearInterpolations Enumeration
Specifies type of interpolation method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearInterpolations
   Inherits System.Enum
'Usage

Dim instance As ImGearInterpolations
public enum ImGearInterpolations : System.Enum
__value public enum ImGearInterpolations : public System.Enum
public enum class ImGearInterpolations : public System.Enum
Members
Member | Value | Description
AVERAGE | 1 | Average value interpolation.
BICUBIC | 7 | Bicubic interpolation.
BILINEAR | 2 | Bilinear interpolation.
GRAYSCALE | 4 | Grayscale interpolation.
NEAREST_NEIGHBOR | 3 | Nearest neighborhood interpolation.
NONE | 0 | No interpolation.
PRESERVE_BLACK | 6 | Interpolation method that preserves black pixels.
PRESERVE_WHITE | 5 | Interpolation method that preserves white pixels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearInterpolations

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearLensFlareType Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearLensFlareType Enumeration
Specifies types of lens flare effects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLensFlareType
   Inherits System.Enum
'Usage

Dim instance As ImGearLensFlareType
public enum ImGearLensFlareType : System.Enum
__value public enum ImGearLensFlareType : public System.Enum
public enum class ImGearLensFlareType : public System.Enum
Members
Member | Value | Description
Digital | 1 | Digital camera lens.
Prime35mm | 3 | 35mm prime lens.
Rainbow | 2 | Rainbow halo effect.
Zoom50_300 | 0 | 50-300mm zoom lens.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearLensFlareType

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearMergeModes Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearMergeModes Enumeration
Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMergeModes
   Inherits System.Enum
'Usage

Dim instance As ImGearMergeModes
public enum ImGearMergeModes : System.Enum
__value public enum ImGearMergeModes : public System.Enum
public enum class ImGearMergeModes : public System.Enum
Members
Member | Value | Description
ADD | 0 | Img1 = Img1 + Img2..
ADD_SIGN_CENTERED | 7 | Img1 = Img1+ SC_Img2.
AND | 4 | Img1 = Img1 & Img2.
DIVIDE | 3 | Img1 = Img1 / Img2.
MULT | 2 | Img1 = Img1 * Img2.
NOT | 8 | Img1 = ~Img1.
OR | 5 | Img1 = Img1 | Img2.
OVER | 9 | Img1 = Img2.
SUB | 1 | Img1 = Img1 - Img2.
XOR | 6 | Img1 = Img1 ^ Img2.
Remarks
For example, if you set ARITH_ADD merge method, the resulting pixel values (of those pixels that intersected from the two images) equal the sum of the value of the pixel in the original image and the value of pixel in the image being merged.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearMergeModes

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearMosaicType Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearMosaicType Enumeration
Defines a type of Mosaic effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMosaicType
   Inherits System.Enum
'Usage

Dim instance As ImGearMosaicType
public enum ImGearMosaicType : System.Enum
__value public enum ImGearMosaicType : public System.Enum
public enum class ImGearMosaicType : public System.Enum
Members
Member | Value | Description
Cartesian | 0 | Mosaic is drawn in Cartesian coordinate system.
Polar | 1 | Mosaic is drawn in Polar coordinate system.
Spiderweb | 2 | Mosaic is drawn in Polar coordinate system, but segments of circles between radial lines are straight.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearMosaicType

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearNightVisionPresets Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearNightVisionPresets Enumeration
Specifies Night Vision effects supported by ImageGear.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearNightVisionPresets
   Inherits System.Enum
'Usage

Dim instance As ImGearNightVisionPresets
public enum ImGearNightVisionPresets : System.Enum
__value public enum ImGearNightVisionPresets : public System.Enum
public enum class ImGearNightVisionPresets : public System.Enum
Members
Member | Value | Description
Binoculars | 1 | Night vision goggles effect.
Camera | 0 | General night vision camera effect.
Martian | 5 | Martian view effect.
Moonlight | 6 | Moon view effect.
Sniper | 2 | Night vision weapon sight effect.
SpyPhoto | 3 | Spy camera effect.
Television | 4 | Old television effect.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearNightVisionPresets

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearPixelateCellType Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPixelateCellType Enumeration
Defines cell types for Pixelate operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPixelateCellType
   Inherits System.Enum
'Usage

Dim instance As ImGearPixelateCellType
public enum ImGearPixelateCellType : System.Enum
__value public enum ImGearPixelateCellType : public System.Enum
public enum class ImGearPixelateCellType : public System.Enum
Members
Member | Value | Description
Circle | 1 | The cell is a circle.
Rectangle | 0 | The cell is rounded or non-rounded rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearPixelateCellType

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearPixelateFillMethod Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearPixelateFillMethod Enumeration
Defines fill methods for Pixelate operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPixelateFillMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearPixelateFillMethod
public enum ImGearPixelateFillMethod : System.Enum
__value public enum ImGearPixelateFillMethod : public System.Enum
public enum class ImGearPixelateFillMethod : public System.Enum
Members
Member | Value | Description
Average | 0 | The cell is filled with an average color of the cell rectangle.
Center | 3 | The cell is filled with a color on the center of the cell rectangle.
Color | 5 | Every cell is filled with a specified color.
Maximum | 2 | The cell is filled with a maximum color of the cell rectangle.
Minimum | 1 | The cell is filled with a minimum color of the cell rectangle.
Random | 4 | The cell is filled with a randomly chosen color of the cell rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearPixelateFillMethod

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearReductionMethods Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearReductionMethods Enumeration
Specifies ImageGear color reduction methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearReductionMethods
   Inherits System.Enum
'Usage

Dim instance As ImGearReductionMethods
public enum ImGearReductionMethods : System.Enum
__value public enum ImGearReductionMethods : public System.Enum
public enum class ImGearReductionMethods : public System.Enum
Members
Member | Value | Description
BAYER | 0 | Bayer color reduction method.
BITONAL | 1 | Bitonal color reduction method.
DIFFUSE | 2 | Diffuse color reduction method.
HALFTONE | 3 | Halftone color reduction method.
MEDIAN | 4 | Median color reduction method.
OCTREE | 5 | Octree color reduction method.
POPULARITY | 6 | Popularity color reduction method.
SCALE | 7 | Scale color reduction method.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearReductionMethods

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearRipplePattern Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRipplePattern Enumeration
Specifies predefined patterns for the Ripple effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRipplePattern
   Inherits System.Enum
'Usage

Dim instance As ImGearRipplePattern
public enum ImGearRipplePattern : System.Enum
__value public enum ImGearRipplePattern : public System.Enum
public enum class ImGearRipplePattern : public System.Enum
Members
Member | Value | Description
Pattern0 | 0 | Ripple pattern 0.
Pattern1 | 1 | Ripple pattern 1.
Pattern2 | 2 | Ripple pattern 2.
Pattern3 | 3 | Ripple pattern 3.
Pattern4 | 4 | Ripple pattern 4.
Pattern5 | 5 | Ripple pattern 5.
Remarks
See ImGearEffects.Ripple method for more information.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearRipplePattern

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearRotationModes Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearRotationModes Enumeration
Specifies ImageGear rotation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRotationModes
   Inherits System.Enum
'Usage

Dim instance As ImGearRotationModes
public enum ImGearRotationModes : System.Enum
__value public enum ImGearRotationModes : public System.Enum
public enum class ImGearRotationModes : public System.Enum
Members
Member | Value | Description
CLIP | 0 | Clips rotated image to keep the image dimensions unchanged.
EXPAND | 1 | Expands the size of the bitmap if necessary to retain the entire rotated image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearRotationModes

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearShearFillStyle Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearShearFillStyle Enumeration
Specifies fill styles for the Shear effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearShearFillStyle
   Inherits System.Enum
'Usage

Dim instance As ImGearShearFillStyle
public enum ImGearShearFillStyle : System.Enum
__value public enum ImGearShearFillStyle : public System.Enum
public enum class ImGearShearFillStyle : public System.Enum
Members
Member | Value | Description
FillColor | 1 | Empty area is filled with the specified color.
NoChange | 0 | Empty area remains unchanged.
RepeatEdge | 2 | Empty area is filled with the first or last raster color.
RepeatRaster | 3 | The raster is repeated periodically across the empty area.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearShearFillStyle

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearWhiteBalancePreset Enumeration

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearWhiteBalancePreset Enumeration
Lists constants for preset white balance values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearWhiteBalancePreset
   Inherits System.Enum
'Usage

Dim instance As ImGearWhiteBalancePreset
public enum ImGearWhiteBalancePreset : System.Enum
__value public enum ImGearWhiteBalancePreset : public System.Enum
public enum class ImGearWhiteBalancePreset : public System.Enum
Members
Member | Value | Description
Cloudy | 1 | Cloudy balance.
Daylight | 0 | Daylight balance.
Flash | 5 | Flash balance.
Fluorescent | 4 | Fluorescent balance.
Shade | 2 | Shade balance.
Tungsten | 3 | Tungsten balance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearWhiteBalancePreset

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearChannelRef Structure
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelRef Structure
Represents pixel channel in ImageGear.Core.ImGearPage.
Object Model
ImGearChannelRef Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearChannelRef
   Inherits System.ValueType
'Usage

Dim instance As ImGearChannelRef
public struct ImGearChannelRef : System.ValueType
public __value struct ImGearChannelRef : public System.ValueType
public value class ImGearChannelRef : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Processing.ImGearChannelRef

See Also

Reference

ImGearChannelRef Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearChannelRef Structure Members
Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelRef Structure

The following tables list the members exposed by ImGearChannelRef.

Public Constructors
 | Name | Description
Public Constructor | ImGearChannelRef Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Content | Gets or sets a reference to the raster page.
Public Field | Number | Gets or sets an index of a pixel channel in the associated raster page.
Top
See Also

Reference

ImGearChannelRef Structure
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearChannelRef Constructor

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelRef Structure : ImGearChannelRef Constructor
Overload List
Overload | Description
ImGearChannelRef Constructor(ImGearRasterPage) | Initializes a new instance of the ImGearChannelRef structure.
ImGearChannelRef Constructor(ImGearRasterPage,Int32) | Initializes a new instance of the ImGearChannelRef structure.
See Also

Reference

ImGearChannelRef Structure
ImGearChannelRef Members


%%PageItemTitle%%

ImGearChannelRef Constructor(ImGearRasterPage)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelRef Structure > ImGearChannelRef Constructor : ImGearChannelRef Constructor(ImGearRasterPage)
Reference to page whose image contains channel data.
Initializes a new instance of the ImGearChannelRef structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As ImGearRasterPage _
)
'Usage

Dim content As ImGearRasterPage

Dim instance As New ImGearChannelRef(content)
public ImGearChannelRef(
   ImGearRasterPage content
)
public: ImGearChannelRef(
   ImGearRasterPage* content
)
public:
ImGearChannelRef(
   ImGearRasterPage^ content
)

Parameters

content
Reference to page whose image contains channel data.
Remarks
This constructor sets the Number property to 0.
See Also

Reference

ImGearChannelRef Structure
ImGearChannelRef Members
Overload List
ImGearChannelRef Structure
ImGearRasterPage Class


%%PageItemTitle%%

ImGearChannelRef Constructor(ImGearRasterPage,Int32)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelRef Structure > ImGearChannelRef Constructor : ImGearChannelRef Constructor(ImGearRasterPage,Int32)
Reference to the raster page.
Index of a pixel channel in the raster page.
Initializes a new instance of the ImGearChannelRef structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As ImGearRasterPage, _
   ByVal number As Integer _
)
'Usage

Dim content As ImGearRasterPage
Dim number As Integer

Dim instance As New ImGearChannelRef(content, number)
public ImGearChannelRef(
   ImGearRasterPage content,
   int number
)
public: ImGearChannelRef(
   ImGearRasterPage* content,
   int number
)
public:
ImGearChannelRef(
   ImGearRasterPage^ content,
   int number
)

Parameters

content
Reference to the raster page.
number
Index of a pixel channel in the raster page.
See Also

Reference

ImGearChannelRef Structure
ImGearChannelRef Members
Overload List
ImGearChannelRef Structure
ImGearRasterPage Class


%%PageItemTitle%% $$Fields$$

ImGearChannelRef Structure Fields

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelRef Structure

For a list of all members of this type, see ImGearChannelRef members.

Public Fields
 | Name | Description
Public Field | Content | Gets or sets a reference to the raster page.
Public Field | Number | Gets or sets an index of a pixel channel in the associated raster page.
Top
See Also

Reference

ImGearChannelRef Structure
ImageGear.Processing Namespace


Content Field (ImGearChannelRef)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelRef Structure : Content Field
Gets or sets a reference to the raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Content As ImGearRasterPage
'Usage

Dim instance As ImGearChannelRef
Dim value As ImGearRasterPage

value = instance.Content

instance.Content = value
public ImGearRasterPage Content
public: ImGearRasterPage* Content
public:
ImGearRasterPage^ Content

Field Value

ImageGear.Core.ImGearRasterPage class object.
See Also

Reference

ImGearChannelRef Structure
ImGearChannelRef Members
ImGearRasterPage Class
ImGearChannelRef Structure
ImGearChannelRef Structure


Number Field (ImGearChannelRef)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelRef Structure : Number Field
Gets or sets an index of a pixel channel in the associated raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Number As Integer
'Usage

Dim instance As ImGearChannelRef
Dim value As Integer

value = instance.Number

instance.Number = value
public int Number
public: int Number
public:
int Number

Field Value

Integer value.
See Also

Reference

ImGearChannelRef Structure
ImGearChannelRef Members
ImGearChannelRef Structure


%%PageItemTitle%%

ImGearChannelStatistics Structure
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelStatistics Structure
Stores statistics for an image channel.
Object Model
ImGearChannelStatistics Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearChannelStatistics
   Inherits System.ValueType
'Usage

Dim instance As ImGearChannelStatistics
public struct ImGearChannelStatistics : System.ValueType
public __value struct ImGearChannelStatistics : public System.ValueType
public value class ImGearChannelStatistics : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Processing.ImGearChannelStatistics

See Also

Reference

ImGearChannelStatistics Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearChannelStatistics Structure Members
Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelStatistics Structure

The following tables list the members exposed by ImGearChannelStatistics.

Public Properties
 | Name | Description
Public Property | Average | Gets or sets average value of the image channel.
Public Property | Max | Gets or sets a 32-bit integer, representing max value of the channel.
Public Property | Max64 | Gets or sets a 64-bit integer, representing maximum value of the image channel.
Public Property | Min | Gets or sets a 32-bit integer, representing min value of the channel.
Public Property | Min64 | Gets or sets a 64-bit integer, representing minimum value of the image channel.
Top
See Also

Reference

ImGearChannelStatistics Structure
ImageGear.Processing Namespace


%%PageItemTitle%% $$Properties$$

ImGearChannelStatistics Structure Properties

ImageGear22.Core Assembly > ImageGear.Processing Namespace : ImGearChannelStatistics Structure

For a list of all members of this type, see ImGearChannelStatistics members.

Public Properties
 | Name | Description
Public Property | Average | Gets or sets average value of the image channel.
Public Property | Max | Gets or sets a 32-bit integer, representing max value of the channel.
Public Property | Max64 | Gets or sets a 64-bit integer, representing maximum value of the image channel.
Public Property | Min | Gets or sets a 32-bit integer, representing min value of the channel.
Public Property | Min64 | Gets or sets a 64-bit integer, representing minimum value of the image channel.
Top
See Also

Reference

ImGearChannelStatistics Structure
ImageGear.Processing Namespace


Average Property

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelStatistics Structure : Average Property
Gets or sets average value of the image channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Average As Double
'Usage

Dim instance As ImGearChannelStatistics
Dim value As Double

instance.Average = value

value = instance.Average
public double Average {get; set;}
public: __property double get_Average();
public: __property void set_Average(
   double value
);
public:
property double Average {
   double get();
   void set (    double value);
}

Property Value

Any double value.
See Also

Reference

ImGearChannelStatistics Structure
ImGearChannelStatistics Members


Max Property (ImGearChannelStatistics)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelStatistics Structure : Max Property
Gets or sets a 32-bit integer, representing max value of the channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Max As Integer
'Usage

Dim instance As ImGearChannelStatistics
Dim value As Integer

instance.Max = value

value = instance.Max
public int Max {get; set;}
public: __property int get_Max();
public: __property void set_Max(
   int value
);
public:
property int Max {
   int get();
   void set (    int value);
}

Property Value

32-bit Integer number.
Remarks
This property represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the Max property throws ImageGear.Core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

Use Max64 property if you are working with 32-bit per channel images.

See Also

Reference

ImGearChannelStatistics Structure
ImGearChannelStatistics Members
ImGearErrorCodes Enumeration


Max64 Property (ImGearChannelStatistics)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelStatistics Structure : Max64 Property
Gets or sets a 64-bit integer, representing maximum value of the image channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Max64 As Long
'Usage

Dim instance As ImGearChannelStatistics
Dim value As Long

instance.Max64 = value

value = instance.Max64
public long Max64 {get; set;}
public: __property long get_Max64();
public: __property void set_Max64(
   long value
);
public:
property int64 Max64 {
   int64 get();
   void set (    int64 value);
}

Property Value

64-bit Integer value.
See Also

Reference

ImGearChannelStatistics Structure
ImGearChannelStatistics Members


Min Property (ImGearChannelStatistics)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelStatistics Structure : Min Property
Gets or sets a 32-bit integer, representing min value of the channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Min As Integer
'Usage

Dim instance As ImGearChannelStatistics
Dim value As Integer

instance.Min = value

value = instance.Min
public int Min {get; set;}
public: __property int get_Min();
public: __property void set_Min(
   int value
);
public:
property int Min {
   int get();
   void set (    int value);
}

Property Value

32-bit Integer value.
Remarks
This property represents the 32-bit integer minimum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the Min property throws ImageGear.Core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

Use Min64 property if you are working with 32-bit per channel images.

See Also

Reference

ImGearChannelStatistics Structure
ImGearChannelStatistics Members
ImGearErrorCodes Enumeration


Min64 Property (ImGearChannelStatistics)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > ImGearChannelStatistics Structure : Min64 Property
Gets or sets a 64-bit integer, representing minimum value of the image channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Min64 As Long
'Usage

Dim instance As ImGearChannelStatistics
Dim value As Long

instance.Min64 = value

value = instance.Min64
public long Min64 {get; set;}
public: __property long get_Min64();
public: __property void set_Min64(
   long value
);
public:
property int64 Min64 {
   int64 get();
   void set (    int64 value);
}

Property Value

64-bit Integer value.
See Also

Reference

ImGearChannelStatistics Structure
ImGearChannelStatistics Members


%%PageItemTitle%%

IImGearPixelProcessor Interface
Members

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IImGearPixelProcessor Interface
An implementation of this interface is passed to ProcessArea method.
Object Model
IImGearPixelProcessor InterfaceImGearPixel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearPixelProcessor
'Usage

Dim instance As IImGearPixelProcessor
public interface IImGearPixelProcessor
public __gc __interface IImGearPixelProcessor
public interface class IImGearPixelProcessor
Remarks
This interface declares one method ProcessPixel which must be implemented by the user.
See Also

Reference

IImGearPixelProcessor Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

IImGearPixelProcessor Interface Members
Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IImGearPixelProcessor Interface

The following tables list the members exposed by IImGearPixelProcessor.

Public Methods
 | Name | Description
Method | ProcessPixel | The method must return the new pixel after processing.
Top
See Also

Reference

IImGearPixelProcessor Interface
ImageGear.Processing Namespace


%%PageItemTitle%% $$Methods$$

IImGearPixelProcessor Interface Methods

ImageGear22.Core Assembly > ImageGear.Processing Namespace : IImGearPixelProcessor Interface

For a list of all members of this type, see IImGearPixelProcessor members.

Public Methods
 | Name | Description
Method | ProcessPixel | The method must return the new pixel after processing.
Top
See Also

Reference

IImGearPixelProcessor Interface
ImageGear.Processing Namespace


ProcessPixel Method (IImGearPixelProcessor)

ImageGear22.Core Assembly > ImageGear.Processing Namespace > IImGearPixelProcessor Interface : ProcessPixel Method
The pixel to be processed.
The method must return the new pixel after processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function ProcessPixel( _
   ByVal pixel As ImGearPixel _
) As ImGearPixel
'Usage

Dim instance As IImGearPixelProcessor
Dim pixel As ImGearPixel
Dim value As ImGearPixel

value = instance.ProcessPixel(pixel)
ImGearPixel ProcessPixel(
   ImGearPixel pixel
)
ImGearPixel* ProcessPixel(
   ImGearPixel* pixel
)
ImGearPixel^ ProcessPixel(
   ImGearPixel^ pixel
)

Parameters

pixel
The pixel to be processed.

Return Value

ImageGear.Core.ImGearPixel class object.
See Also

Reference

IImGearPixelProcessor Interface
IImGearPixelProcessor Members
ImGearPixel Class


ImageGear.Processing.Layers Namespace
Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Processing.Layers Namespace
ImageGear.Processing.Layers namespace provides API for creating and editing image layers. It includes ImGearLayeredPage class, which contains a raster composition image and an array of layers.
Classes
 | Class | Description
Class | ImGearImageLayer | Represents image layer and its attributes.
Class | ImGearLayer | Represents generic layer and its attributes.
Class | ImGearLayerArray | Defines composition of layers.
Class | ImGearLayeredPage | Represents a page with image layers.
Enumerations
 | Enumeration | Description
Enumeration | ImGearLayerType | Supported layer types.
See Also

Reference

ImageGear22.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Processing.Layers Namespace Inheritance Hierarchy
ImageGear22.Core Assembly : ImageGear.Processing.Layers Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearRasterPage
ImageGear.Processing.Layers.ImGearLayeredPage
ImageGear.Processing.Layers.ImGearLayer
ImageGear.Processing.Layers.ImGearImageLayer
ImageGear.Processing.Layers.ImGearLayerArray
See Also

Reference

ImageGear22.Core Assembly


%%PageItemTitle%%

ImGearImageLayer Class
Members

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearImageLayer Class
Represents image layer and its attributes.
Object Model
ImGearImageLayer ClassImGearPage ClassImGearPoint Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearImageLayer
   Inherits ImGearLayer
'Usage

Dim instance As ImGearImageLayer
public class ImGearImageLayer : ImGearLayer
public __gc class ImGearImageLayer : public ImGearLayer
public ref class ImGearImageLayer : public ImGearLayer
Remarks
Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.
Inheritance Hierarchy

System.Object
ImageGear.Processing.Layers.ImGearLayer
ImageGear.Processing.Layers.ImGearImageLayer

See Also

Reference

ImGearImageLayer Members
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Members$$

ImGearImageLayer Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearImageLayer Class

The following tables list the members exposed by ImGearImageLayer.

Public Constructors
 | Name | Description
Public Constructor | ImGearImageLayer Constructor | Initializes a new instance of the ImGearImageLayer class from the specified raster page.
Top
Protected Fields
 | Name | Description
Protected Field | m_nOpacity | Level of opacity for the image layer.
Protected Field | m_rcPoint | Rectangle specifying the location of the image layer.
Top
Public Properties
 | Name | Description
Public Property | Image | Gets image specifying the layer.
Public Property | Location | Gets or sets rectangle specifying the location of the image layer.
Public Property | Opacity | Gets or sets level of opacity for the image layer.
Public Property | Type | Overridden. Image layer type.
Top
See Also

Reference

ImGearImageLayer Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%%

ImGearImageLayer Constructor

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : ImGearImageLayer Constructor
Raster page to create layer from.
Initializes a new instance of the ImGearImageLayer class from the specified raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

Dim instance As New ImGearImageLayer(page)
public ImGearImageLayer(
   ImGearPage page
)
public: ImGearImageLayer(
   ImGearPage* page
)
public:
ImGearImageLayer(
   ImGearPage^ page
)

Parameters

page
Raster page to create layer from.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members
ImGearPage Class


%%PageItemTitle%% $$Properties$$

ImGearImageLayer Class Properties

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearImageLayer Class

For a list of all members of this type, see ImGearImageLayer members.

Public Properties
 | Name | Description
Public Property | Image | Gets image specifying the layer.
Public Property | Location | Gets or sets rectangle specifying the location of the image layer.
Public Property | Opacity | Gets or sets level of opacity for the image layer.
Public Property | Type | Overridden. Image layer type.
Top
See Also

Reference

ImGearImageLayer Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Methods$$

ImGearImageLayer Class Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearImageLayer Class

For a list of all members of this type, see ImGearImageLayer members.

See Also

Reference

ImGearImageLayer Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%%

ImGearImageLayer Constructor

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : ImGearImageLayer Constructor
Overload List
Overload | Description
ImGearImageLayer Constructor | Initializes a new instance of the ImGearImageLayer class from the specified raster page.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


Image Property (ImGearImageLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : Image Property
Gets image specifying the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As ImGearPage
'Usage

Dim instance As ImGearImageLayer
Dim value As ImGearPage

value = instance.Image
public ImGearPage Image {get;}
public: __property ImGearPage* get_Image();
public:
property ImGearPage^ Image {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class object.
Remarks
This property specifies the image to put in the layer. It is read-only.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


Location Property (ImGearImageLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : Location Property
Gets or sets rectangle specifying the location of the image layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As ImGearPoint
'Usage

Dim instance As ImGearImageLayer
Dim value As ImGearPoint

instance.Location = value

value = instance.Location
public ImGearPoint Location {get; set;}
public: __property ImGearPoint get_Location();
public: __property void set_Location(
   ImGearPoint value
);
public:
property ImGearPoint Location {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


Opacity Property (ImGearImageLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : Opacity Property
Gets or sets level of opacity for the image layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearImageLayer
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


Type Property (ImGearImageLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : Type Property
Image layer type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As ImGearLayerType
'Usage

Dim instance As ImGearImageLayer
Dim value As ImGearLayerType

value = instance.Type
public override ImGearLayerType Type {get;}
public: __property ImGearLayerType get_Type() override;
public:
property ImGearLayerType Type {
   ImGearLayerType get() override;
}

Property Value

ImGearLayerType value.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%% $$Fields$$

ImGearImageLayer Class Fields

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearImageLayer Class

For a list of all members of this type, see ImGearImageLayer members.

Protected Fields
 | Name | Description
Protected Field | m_nOpacity | Level of opacity for the image layer.
Protected Field | m_rcPoint | Rectangle specifying the location of the image layer.
Top
See Also

Reference

ImGearImageLayer Class
ImageGear.Processing.Layers Namespace


m_nOpacity Field

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : m_nOpacity Field
Level of opacity for the image layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_nOpacity As Integer
'Usage

Dim instance As ImGearImageLayer
Dim value As Integer

value = instance.m_nOpacity

instance.m_nOpacity = value
protected int m_nOpacity
protected: int m_nOpacity
protected:
int m_nOpacity

Field Value

Integer value.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


m_rcPoint Field

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearImageLayer Class : m_rcPoint Field
Rectangle specifying the location of the image layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_rcPoint As ImGearPoint
'Usage

Dim instance As ImGearImageLayer
Dim value As ImGearPoint

value = instance.m_rcPoint

instance.m_rcPoint = value
protected ImGearPoint m_rcPoint
protected: ImGearPoint m_rcPoint
protected:
ImGearPoint m_rcPoint

Field Value

ImageGear.Core.ImGearPoint structure.
See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

ImGearLayer Class
Members

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayer Class
Represents generic layer and its attributes.
Object Model
ImGearLayer ClassImGearLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLayer
'Usage

Dim instance As ImGearLayer
public class ImGearLayer
public __gc class ImGearLayer
public ref class ImGearLayer
Remarks
Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.
Inheritance Hierarchy

System.Object
ImageGear.Processing.Layers.ImGearLayer
ImageGear.Processing.Layers.ImGearImageLayer

See Also

Reference

ImGearLayer Members
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Members$$

ImGearLayer Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayer Class

The following tables list the members exposed by ImGearLayer.

Protected Fields
 | Name | Description
Protected Field | m_bVisible | Specifies visibility state of the layer.
Protected Field | m_strName | Specifies name of the layer.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the layer.
Public Property | Type | Gets the type of the layer.
Public Property | Visible | Gets or sets a value indicating whether the layer is visible.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the layer.
Top
See Also

Reference

ImGearLayer Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Methods$$

ImGearLayer Class Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayer Class

For a list of all members of this type, see ImGearLayer members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the layer.
Top
See Also

Reference

ImGearLayer Class
ImageGear.Processing.Layers Namespace


Clone Method (ImGearLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : Clone Method
Clones the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearLayer
'Usage

Dim instance As ImGearLayer
Dim value As ImGearLayer

value = instance.Clone()
public ImGearLayer Clone()
public: ImGearLayer* Clone();
public:
ImGearLayer^ Clone();

Return Value

Returns a copy of the layer.
See Also

Reference

ImGearLayer Class
ImGearLayer Members
ImGearLayer Class


%%PageItemTitle%% $$Properties$$

ImGearLayer Class Properties

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayer Class

For a list of all members of this type, see ImGearLayer members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the layer.
Public Property | Type | Gets the type of the layer.
Public Property | Visible | Gets or sets a value indicating whether the layer is visible.
Top
See Also

Reference

ImGearLayer Class
ImageGear.Processing.Layers Namespace


Name Property (ImGearLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : Name Property
Gets or sets the name of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearLayer
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearLayer Class
ImGearLayer Members


Type Property (ImGearLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : Type Property
Gets the type of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Type As ImGearLayerType
'Usage

Dim instance As ImGearLayer
Dim value As ImGearLayerType

value = instance.Type
public virtual ImGearLayerType Type {get;}
public: __property virtual ImGearLayerType get_Type();
public:
virtual property ImGearLayerType Type {
   ImGearLayerType get();
}

Property Value

ImGearLayerType enumeration value.
See Also

Reference

ImGearLayer Class
ImGearLayer Members


Visible Property (ImGearLayer)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : Visible Property
Gets or sets a value indicating whether the layer is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As ImGearLayer
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%% $$Fields$$

ImGearLayer Class Fields

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayer Class

For a list of all members of this type, see ImGearLayer members.

Protected Fields
 | Name | Description
Protected Field | m_bVisible | Specifies visibility state of the layer.
Protected Field | m_strName | Specifies name of the layer.
Top
See Also

Reference

ImGearLayer Class
ImageGear.Processing.Layers Namespace


m_bVisible Field

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : m_bVisible Field
Specifies visibility state of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_bVisible As Boolean
'Usage

Dim instance As ImGearLayer
Dim value As Boolean

value = instance.m_bVisible

instance.m_bVisible = value
protected bool m_bVisible
protected: bool m_bVisible
protected:
bool m_bVisible

Field Value

Boolean value.
See Also

Reference

ImGearLayer Class
ImGearLayer Members


m_strName Field

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayer Class : m_strName Field
Specifies name of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected m_strName As String
'Usage

Dim instance As ImGearLayer
Dim value As String

value = instance.m_strName

instance.m_strName = value
protected string m_strName
protected: string* m_strName
protected:
String^ m_strName

Field Value

String value.
See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

ImGearLayerArray Class
Members

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayerArray Class
Defines composition of layers.
Object Model
ImGearLayerArray ClassImGearLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearLayerArray
'Usage

Dim instance As ImGearLayerArray
[DefaultMember("Item")]
public class ImGearLayerArray
[DefaultMember("Item")]
public __gc class ImGearLayerArray
[DefaultMember("Item")]
public ref class ImGearLayerArray
Remarks
The composition of layers from a Adobe PSD image is stored in the array of layers associated with the ImGearLayeredPage. Users can manipulate the composition by creating new layers, editing and deleting the existing ones using this class.
Inheritance Hierarchy

System.Object
ImageGear.Processing.Layers.ImGearLayerArray

See Also

Reference

ImGearLayerArray Members
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Members$$

ImGearLayerArray Class Members
Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayerArray Class

The following tables list the members exposed by ImGearLayerArray.

Public Constructors
 | Name | Description
Public Constructor | ImGearLayerArray Constructor | Initializes a new instance of the ImGearLayerArray class. Created layer array is empty.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets number of layers in the array.
Public Property | IsFixedSize | Gets a value indicating whether ImGearLayerArray array has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether ImGearLayerArray array is read-only.
Public Property | IsSynchronized | Gets a value indicating whether is access to the ImGearLayerArray array is synchronized.
Public Property | Item | Specifies a reference to the indexed element of array.
Public Property | SyncRoot | Gets an object that can be used to synchronize an access to the ImGearLayerArray array .
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new layer to the array.
Public Method | Clear | Removes all of the layers from the array.
Public Method | Clone | Clones the array of layers.
Public Method | Contains | Checks if the array contains the specified layer.
Public Method | CopyTo | Copies the current array of layers into the specified array at specified position.
Public Method | GetEnumerator | Gets the IEnumerator interface.
Public Method | IndexOf | Gets the index of the specified layer.
Public Method | Insert | Insets the specified layer at the spefied position in the array.
Public Method | Remove | Removes the specified layer from the array.
Public Method | RemoveAt | Removes layer with the specified index from the array.
Top
See Also

Reference

ImGearLayerArray Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%%

ImGearLayerArray Constructor

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : ImGearLayerArray Constructor
Initializes a new instance of the ImGearLayerArray class. Created layer array is empty.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearLayerArray()
public ImGearLayerArray()
public: ImGearLayerArray();
public:
ImGearLayerArray();
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%% $$Methods$$

ImGearLayerArray Class Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayerArray Class

For a list of all members of this type, see ImGearLayerArray members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new layer to the array.
Public Method | Clear | Removes all of the layers from the array.
Public Method | Clone | Clones the array of layers.
Public Method | Contains | Checks if the array contains the specified layer.
Public Method | CopyTo | Copies the current array of layers into the specified array at specified position.
Public Method | GetEnumerator | Gets the IEnumerator interface.
Public Method | IndexOf | Gets the index of the specified layer.
Public Method | Insert | Insets the specified layer at the spefied position in the array.
Public Method | Remove | Removes the specified layer from the array.
Public Method | RemoveAt | Removes layer with the specified index from the array.
Top
See Also

Reference

ImGearLayerArray Class
ImageGear.Processing.Layers Namespace


Add Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Add Method
New layer to add.
Adds a new layer to the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Add( _
   ByVal layer As ImGearLayer _
) As Integer
'Usage

Dim instance As ImGearLayerArray
Dim layer As ImGearLayer
Dim value As Integer

value = instance.Add(layer)
public virtual int Add(
   ImGearLayer layer
)
public: virtual int Add(
   ImGearLayer* layer
)
public:
virtual int Add(
   ImGearLayer^ layer
)

Parameters

layer
New layer to add.

Return Value

Integer value of added layer index in the array..
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
ImGearLayer Class


Clear Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Clear Method
Removes all of the layers from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Clear()
'Usage

Dim instance As ImGearLayerArray

instance.Clear()
public virtual void Clear()
public: virtual void Clear();
public:
virtual void Clear();
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


Clone Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Clone Method
Clones the array of layers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearLayerArray
'Usage

Dim instance As ImGearLayerArray
Dim value As ImGearLayerArray

value = instance.Clone()
public ImGearLayerArray Clone()
public: ImGearLayerArray* Clone();
public:
ImGearLayerArray^ Clone();

Return Value

ImGearLayerArray class object.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


Contains Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Contains Method
Layer to check.
Checks if the array contains the specified layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal value As ImGearLayer _
) As Boolean
'Usage

Dim instance As ImGearLayerArray
Dim value As ImGearLayer
Dim value As Boolean

value = instance.Contains(value)
public bool Contains(
   ImGearLayer value
)
public: bool Contains(
   ImGearLayer* value
)
public:
bool Contains(
   ImGearLayer^ value
)

Parameters

value
Layer to check.

Return Value

Boolean value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
ImGearLayer Class


CopyTo Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : CopyTo Method
Destination array.
Position in the destination array to copy to.
Copies the current array of layers into the specified array at specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearLayerArray
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public virtual void CopyTo(
   Array array,
   int index
)
public: virtual void CopyTo(
   Array* array,
   int index
)
public:
virtual void CopyTo(
   Array^ array,
   int index
)

Parameters

array
Destination array.
index
Position in the destination array to copy to.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


GetEnumerator Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : GetEnumerator Method
Gets the IEnumerator interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearLayerArray
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


IndexOf Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : IndexOf Method
Layer to get index of.
Gets the index of the specified layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As ImGearLayer _
) As Integer
'Usage

Dim instance As ImGearLayerArray
Dim value As ImGearLayer
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   ImGearLayer value
)
public: int IndexOf(
   ImGearLayer* value
)
public:
int IndexOf(
   ImGearLayer^ value
)

Parameters

value
Layer to get index of.

Return Value

Integer value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
ImGearLayer Class


Insert Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Insert Method
Position in the current array to insert layer to.
Layer to insert.
Insets the specified layer at the spefied position in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal layer As ImGearLayer _
)
'Usage

Dim instance As ImGearLayerArray
Dim index As Integer
Dim layer As ImGearLayer

instance.Insert(index, layer)
public virtual void Insert(
   int index,
   ImGearLayer layer
)
public: virtual void Insert(
   int index,
   ImGearLayer* layer
)
public:
virtual void Insert(
   int index,
   ImGearLayer^ layer
)

Parameters

index
Position in the current array to insert layer to.
layer
Layer to insert.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
ImGearLayer Class


Remove Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Remove Method
Layer to remove from the array.
Removes the specified layer from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Remove( _
   ByVal value As ImGearLayer _
)
'Usage

Dim instance As ImGearLayerArray
Dim value As ImGearLayer

instance.Remove(value)
public virtual void Remove(
   ImGearLayer value
)
public: virtual void Remove(
   ImGearLayer* value
)
public:
virtual void Remove(
   ImGearLayer^ value
)

Parameters

value
Layer to remove from the array.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


RemoveAt Method (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : RemoveAt Method
Layer index to remove from the array.
Removes layer with the specified index from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearLayerArray
Dim index As Integer

instance.RemoveAt(index)
public virtual void RemoveAt(
   int index
)
public: virtual void RemoveAt(
   int index
)
public:
virtual void RemoveAt(
   int index
)

Parameters

index
Layer index to remove from the array.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
ImGearLayer Class


%%PageItemTitle%% $$Properties$$

ImGearLayerArray Class Properties

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayerArray Class

For a list of all members of this type, see ImGearLayerArray members.

Public Properties
 | Name | Description
Public Property | Count | Gets number of layers in the array.
Public Property | IsFixedSize | Gets a value indicating whether ImGearLayerArray array has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether ImGearLayerArray array is read-only.
Public Property | IsSynchronized | Gets a value indicating whether is access to the ImGearLayerArray array is synchronized.
Public Property | Item | Specifies a reference to the indexed element of array.
Public Property | SyncRoot | Gets an object that can be used to synchronize an access to the ImGearLayerArray array .
Top
See Also

Reference

ImGearLayerArray Class
ImageGear.Processing.Layers Namespace


Count Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Count Property
Gets number of layers in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearLayerArray
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


IsFixedSize Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : IsFixedSize Property
Gets a value indicating whether ImGearLayerArray array has a fixed size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As ImGearLayerArray
Dim value As Boolean

value = instance.IsFixedSize
public bool IsFixedSize {get;}
public: __property bool get_IsFixedSize();
public:
property bool IsFixedSize {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


IsReadOnly Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : IsReadOnly Property
Gets a value indicating whether ImGearLayerArray array is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ImGearLayerArray
Dim value As Boolean

value = instance.IsReadOnly
public bool IsReadOnly {get;}
public: __property bool get_IsReadOnly();
public:
property bool IsReadOnly {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


IsSynchronized Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : IsSynchronized Property
Gets a value indicating whether is access to the ImGearLayerArray array is synchronized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ImGearLayerArray
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


Item Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : Item Property
The indexed element.
Specifies a reference to the indexed element of array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Default Property Item( _
   ByVal index As Integer _
) As ImGearLayer
'Usage

Dim instance As ImGearLayerArray
Dim index As Integer
Dim value As ImGearLayer

instance.Item(index) = value

value = instance.Item(index)
public virtual ImGearLayer this[
   int index
]; {get; set;}
public: __property virtual ImGearLayer* get_Item   int index
;
public: __property virtual void set_Item   int index,
   ImGearLayer* value
;
public:
virtual property ImGearLayer^ default [int] {
   ImGearLayer^ get(int index);
   void set (int index, ImGearLayer^ value);
}

Parameters

index
The indexed element.

Property Value

ImGearLayer class object.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


SyncRoot Property (ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayerArray Class : SyncRoot Property
Gets an object that can be used to synchronize an access to the ImGearLayerArray array .
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ImGearLayerArray
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

Object value.
See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

ImGearLayeredPage Class
Members

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayeredPage Class
Represents a page with image layers.
Object Model
ImGearLayeredPage ClassImGearPage ClassImGearPage ClassImGearColorSpace StructureImGearSize StructureImGearLayerArray ClassImGearLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLayeredPage
   Inherits ImageGear.Core.ImGearRasterPage
'Usage

Dim instance As ImGearLayeredPage
public class ImGearLayeredPage : ImageGear.Core.ImGearRasterPage
public __gc class ImGearLayeredPage : public ImageGear.Core.ImGearRasterPage
public ref class ImGearLayeredPage : public ImageGear.Core.ImGearRasterPage
Remarks
Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearRasterPage
ImageGear.Processing.Layers.ImGearLayeredPage

See Also

Reference

ImGearLayeredPage Members
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Members$$

ImGearLayeredPage Class Members
Fields Properties Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayeredPage Class

The following tables list the members exposed by ImGearLayeredPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearLayeredPage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Composition | Gets layered page composition.
Public Property | CompositionChanellDepths | Gets or sets chanell depths composition.
Public Property | CompositionColorSpace | Gets or sets raster composition ImageGear.Core.ImGearColorSpace value.
Public Property | CompositionDimensions | Gets or sets dimensions composition.
Public Property | Layers | Gets the array of layers from the layered page.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the layered page object.
Public Method | Flatten | This method renders all the visible layers into the raster composition DIB.
Top
See Also

Reference

ImGearLayeredPage Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%% $$Fields$$

ImGearLayeredPage Class Fields

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayeredPage Class

For a list of all members of this type, see ImGearLayeredPage members.

See Also

Reference

ImGearLayeredPage Class
ImageGear.Processing.Layers Namespace


%%PageItemTitle%%

ImGearLayeredPage Constructor

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : ImGearLayeredPage Constructor
Overload List
Overload | Description
ImGearLayeredPage Constructor(ImGearLayerArray) | Initializes a new instance of the ImGearLayeredPage class.
ImGearLayeredPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean) | Initializes a new instance of the ImGearLayeredPage class.
ImGearLayeredPage Constructor(ImGearPage) | Initializes a new instance of the ImGearLayeredPage class.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

ImGearLayeredPage Constructor(ImGearLayerArray)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(ImGearLayerArray)
Composition of layers.
Initializes a new instance of the ImGearLayeredPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal layers As ImGearLayerArray _
)
'Usage

Dim layers As ImGearLayerArray

Dim instance As New ImGearLayeredPage(layers)
public ImGearLayeredPage(
   ImGearLayerArray layers
)
public: ImGearLayeredPage(
   ImGearLayerArray* layers
)
public:
ImGearLayeredPage(
   ImGearLayerArray^ layers
)

Parameters

layers
Composition of layers.
Remarks
Creates a blank layered page from the specified composition of layers.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List
ImGearLayerArray Class


%%PageItemTitle%%

ImGearLayeredPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(Int32,Int32,ImGearColorSpace,Int32[],Boolean)
Width of the page.
Height of the page.
Color space of the page.
Channel depths of the page.
If true, allocate DIB pixels; false otherwise.
Initializes a new instance of the ImGearLayeredPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal channelDepths() As Integer, _
   ByVal allocatePixels As Boolean _
)
'Usage

Dim width As Integer
Dim height As Integer
Dim colorSpace As ImGearColorSpace
Dim channelDepths() As Integer
Dim allocatePixels As Boolean

Dim instance As New ImGearLayeredPage(width, height, colorSpace, channelDepths, allocatePixels)
public ImGearLayeredPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   bool allocatePixels
)
public: ImGearLayeredPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[]* channelDepths,
   bool allocatePixels
)
public:
ImGearLayeredPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   array<int>^ channelDepths,
   bool allocatePixels
)

Parameters

width
Width of the page.
height
Height of the page.
colorSpace
Color space of the page.
channelDepths
Channel depths of the page.
allocatePixels
If true, allocate DIB pixels; false otherwise.
Remarks
Creates a blank layered page from the specified attributes.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List
ImGearColorSpace Structure


%%PageItemTitle%%

ImGearLayeredPage Constructor(ImGearPage)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(ImGearPage)
Page to copy DIB and Metadata from.
Initializes a new instance of the ImGearLayeredPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

Dim instance As New ImGearLayeredPage(page)
public ImGearLayeredPage(
   ImGearPage page
)
public: ImGearLayeredPage(
   ImGearPage* page
)
public:
ImGearLayeredPage(
   ImGearPage^ page
)

Parameters

page
Page to copy DIB and Metadata from.
Remarks
Creates a layered page from the specified ImageGear.Core.ImGearPage, by copying its DIB and Metadata, and creating an empty array of layers.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearLayeredPage Class Methods

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayeredPage Class

For a list of all members of this type, see ImGearLayeredPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the layered page object.
Public Method | Flatten | This method renders all the visible layers into the raster composition DIB.
Top
See Also

Reference

ImGearLayeredPage Class
ImageGear.Processing.Layers Namespace


Clone Method (ImGearLayeredPage)

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : Clone Method
Clones the layered page object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearLayeredPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


Flatten Method

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : Flatten Method
This method renders all the visible layers into the raster composition DIB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Flatten()
'Usage

Dim instance As ImGearLayeredPage

instance.Flatten()
public void Flatten()
public: void Flatten();
public:
void Flatten();
Remarks
This method can be used to flatten the layered page into the raster page. As a result of this method, the base ImageGear.Core.ImGearRasterPage class object is regenerated and can be used to access the result of the flattening operation.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
ImGearRasterPage Class


%%PageItemTitle%% $$Properties$$

ImGearLayeredPage Class Properties

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayeredPage Class

For a list of all members of this type, see ImGearLayeredPage members.

Public Properties
 | Name | Description
Public Property | Composition | Gets layered page composition.
Public Property | CompositionChanellDepths | Gets or sets chanell depths composition.
Public Property | CompositionColorSpace | Gets or sets raster composition ImageGear.Core.ImGearColorSpace value.
Public Property | CompositionDimensions | Gets or sets dimensions composition.
Public Property | Layers | Gets the array of layers from the layered page.
Top
See Also

Reference

ImGearLayeredPage Class
ImageGear.Processing.Layers Namespace


Composition Property

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : Composition Property
Gets layered page composition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Composition As ImGearPage
'Usage

Dim instance As ImGearLayeredPage
Dim value As ImGearPage

value = instance.Composition
public ImGearPage Composition {get;}
public: __property ImGearPage* get_Composition();
public:
property ImGearPage^ Composition {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class object as layers composition.
Remarks
Property renders all the visible layers into the raster composition DIB.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


CompositionChanellDepths Property

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : CompositionChanellDepths Property
Gets or sets chanell depths composition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompositionChanellDepths As Integer()
'Usage

Dim instance As ImGearLayeredPage
Dim value() As Integer

instance.CompositionChanellDepths = value

value = instance.CompositionChanellDepths
public int[] CompositionChanellDepths {get; set;}
public: __property int[]* get_CompositionChanellDepths();
public: __property void set_CompositionChanellDepths(
   int[]* value
);
public:
property array<int>^ CompositionChanellDepths {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

Array of integer.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


CompositionColorSpace Property

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : CompositionColorSpace Property
Gets or sets raster composition ImageGear.Core.ImGearColorSpace value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompositionColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearLayeredPage
Dim value As ImGearColorSpace

instance.CompositionColorSpace = value

value = instance.CompositionColorSpace
public ImGearColorSpace CompositionColorSpace {get; set;}
public: __property ImGearColorSpace get_CompositionColorSpace();
public: __property void set_CompositionColorSpace(
   ImGearColorSpace value
);
public:
property ImGearColorSpace CompositionColorSpace {
   ImGearColorSpace get();
   void set (    ImGearColorSpace value);
}

Property Value

ImageGear.Core.ImGearColorSpace value.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
ImGearColorSpace Structure


CompositionDimensions Property

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : CompositionDimensions Property
Gets or sets dimensions composition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompositionDimensions As ImGearSize
'Usage

Dim instance As ImGearLayeredPage
Dim value As ImGearSize

instance.CompositionDimensions = value

value = instance.CompositionDimensions
public ImGearSize CompositionDimensions {get; set;}
public: __property ImGearSize get_CompositionDimensions();
public: __property void set_CompositionDimensions(
   ImGearSize value
);
public:
property ImGearSize CompositionDimensions {
   ImGearSize get();
   void set (    ImGearSize value);
}

Property Value

ImageGear.Core.ImGearSize class object.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


Layers Property

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace > ImGearLayeredPage Class : Layers Property
Gets the array of layers from the layered page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Layers As ImGearLayerArray
'Usage

Dim instance As ImGearLayeredPage
Dim value As ImGearLayerArray

value = instance.Layers
public ImGearLayerArray Layers {get;}
public: __property ImGearLayerArray* get_Layers();
public:
property ImGearLayerArray^ Layers {
   ImGearLayerArray^ get();
}

Property Value

ImGearLayerArray class object.
See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
ImGearLayerArray Class


%%PageItemTitle%%

ImGearLayerType Enumeration

ImageGear22.Core Assembly > ImageGear.Processing.Layers Namespace : ImGearLayerType Enumeration
Supported layer types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLayerType
   Inherits System.Enum
'Usage

Dim instance As ImGearLayerType
public enum ImGearLayerType : System.Enum
__value public enum ImGearLayerType : public System.Enum
public enum class ImGearLayerType : public System.Enum
Members
Member | Value | Description
Image | 1 | Image layer type.
Unknown | 0 | Unknown (unrecognized by ImageGear) layer type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.Layers.ImGearLayerType

See Also

Reference

ImageGear.Processing.Layers Namespace


ImageGear22.Dicom.Forms Assembly
Namespaces
Namespace | Description
ImageGear.Dicom.Forms | The ImageGear.Dicom.Forms namespace provides functionality to support the end user’s interaction and UI for multi-planar reconstruction (MPR).


ImageGear.Dicom.Forms Namespace
Inheritance Hierarchy
ImageGear22.Dicom.Forms Assembly : ImageGear.Dicom.Forms Namespace
The ImageGear.Dicom.Forms namespace provides functionality to support the end user’s interaction and UI for multi-planar reconstruction (MPR).
Classes
 | Class | Description
Class | ImGearMprAxialController | Represents controller for performing MPR operations on axial stack of images.
Class | ImGearMprController | Represents controller for performing MPR operations.
Class | ImGearMprCoronalController | Represents controller for performing MPR operations on coronal stack of images.
Class | ImGearMprSagittalController | Represents contoller for performing MPR operations on sagittal stack of images.
Class | ImGearMprSettings | Represents MPR settings.
Class | ImGearMprVisualizer | Represents view for visualizing MPR results. Represents view for visualizing MPR results.
See Also

Reference

ImageGear22.Dicom.Forms Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Dicom.Forms Namespace Inheritance Hierarchy
ImageGear22.Dicom.Forms Assembly : ImageGear.Dicom.Forms Namespace
Inheritance Hierarchy
System.Object
ImageGear.Dicom.Forms.ImGearMprController
ImageGear.Dicom.Forms.ImGearMprAxialController
ImageGear.Dicom.Forms.ImGearMprCoronalController
ImageGear.Dicom.Forms.ImGearMprSagittalController
ImageGear.Dicom.Forms.ImGearMprSettings
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ImageGear.Dicom.Forms.ImGearMprVisualizer
See Also

Reference

ImageGear22.Dicom.Forms Assembly


%%PageItemTitle%%

ImGearMprAxialController Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprAxialController Class
Represents controller for performing MPR operations on axial stack of images.
Object Model
ImGearMprAxialController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprAxialController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprAxialController
public class ImGearMprAxialController : ImGearMprController
public __gc class ImGearMprAxialController : public ImGearMprController
public ref class ImGearMprAxialController : public ImGearMprController
Inheritance Hierarchy

System.Object
ImageGear.Dicom.Forms.ImGearMprController
ImageGear.Dicom.Forms.ImGearMprAxialController

See Also

Reference

ImGearMprAxialController Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprAxialController Class Members
Properties Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprAxialController Class

The following tables list the members exposed by ImGearMprAxialController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprAxialController Constructor | Initializes a new instance of the ImGearMprAxialController class.
Top
Public Properties
 | Name | Description
Public Property | CoronalViews | Gets a collection of output coronal views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Public Property | SagittalViews | Gets a collection of output sagittal views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprAxialController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%%

ImGearMprAxialController Constructor

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprAxialController Class : ImGearMprAxialController Constructor
Associated page view.
Initializes a new instance of the ImGearMprAxialController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearMprAxialController(pageView)
public ImGearMprAxialController(
   ImGearPageView pageView
)
public: ImGearMprAxialController(
   ImGearPageView* pageView
)
public:
ImGearMprAxialController(
   ImGearPageView^ pageView
)

Parameters

pageView
Associated page view.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


%%PageItemTitle%% $$Properties$$

ImGearMprAxialController Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

Public Properties
 | Name | Description
Public Property | CoronalViews | Gets a collection of output coronal views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Public Property | SagittalViews | Gets a collection of output sagittal views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprAxialController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprAxialController Class Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

See Also

Reference

ImGearMprAxialController Class
ImageGear.Dicom.Forms Namespace


ControllerType Property (ImGearMprAxialController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprAxialController Class : ControllerType Property
Gets MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprAxialController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


CoronalViews Property (ImGearMprAxialController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprAxialController Class : CoronalViews Property
Gets a collection of output coronal views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprAxialController
Dim value As ICollection(Of ImGearPageView)

value = instance.CoronalViews
public ICollection<ImGearPageView> CoronalViews {get;}
public: __property ICollection<ImGearPageView*>* get_CoronalViews();
public:
property ICollection<ImGearPageView^>^ CoronalViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


ObliqueViews Property (ImGearMprAxialController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprAxialController Class : ObliqueViews Property
Gets a collection of output oblique views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprAxialController
Dim value As ICollection(Of ImGearPageView)

value = instance.ObliqueViews
public ICollection<ImGearPageView> ObliqueViews {get;}
public: __property ICollection<ImGearPageView*>* get_ObliqueViews();
public:
property ICollection<ImGearPageView^>^ ObliqueViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


SagittalViews Property (ImGearMprAxialController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprAxialController Class : SagittalViews Property
Gets a collection of output sagittal views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprAxialController
Dim value As ICollection(Of ImGearPageView)

value = instance.SagittalViews
public ICollection<ImGearPageView> SagittalViews {get;}
public: __property ICollection<ImGearPageView*>* get_SagittalViews();
public:
property ICollection<ImGearPageView^>^ SagittalViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


%%PageItemTitle%%

ImGearMprController Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprController Class
Represents controller for performing MPR operations.
Object Model
ImGearMprController ClassImGearDocumentPageArray ClassImGearPage ClassImGearPageView ClassImGearMprSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearMprController
'Usage

Dim instance As ImGearMprController
public abstract class ImGearMprController
public __gc abstract class ImGearMprController
public ref class ImGearMprController abstract
Inheritance Hierarchy

System.Object
ImageGear.Dicom.Forms.ImGearMprController
ImageGear.Dicom.Forms.ImGearMprAxialController
ImageGear.Dicom.Forms.ImGearMprCoronalController
ImageGear.Dicom.Forms.ImGearMprSagittalController

See Also

Reference

ImGearMprController Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprController Class Members
Properties Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprController Class

The following tables list the members exposed by ImGearMprController.

Public Properties
 | Name | Description
Public Property | PageCount | Gets number of pages for current view.
Public Property | PageNumber | Gets or sets page's number to display.
Public Property | Pages | Gets collection of pages to perform MPR on.
Public Property | PagesViewType | Gets pages view type.
Public Property | PageView | Gets associated page view.
Public Property | Settings | Gets MPR settings.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Gets MPR controller type.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Overloaded. Disposes any resources being used.
Public Method | MouseDown | Provides mouse down interaction functionality.
Public Method | MouseMove | Provides mouse move interaction functionality.
Public Method | MouseUp | Provides mouse up interaction functionality.
Public Method | SetPages | Sets collection of pages to perform MPR on.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprController Class Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

Public Methods
 | Name | Description
Public Method | Dispose | Overloaded. Disposes any resources being used.
Public Method | MouseDown | Provides mouse down interaction functionality.
Public Method | MouseMove | Provides mouse move interaction functionality.
Public Method | MouseUp | Provides mouse up interaction functionality.
Public Method | SetPages | Sets collection of pages to perform MPR on.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Dicom.Forms Namespace


Dispose Method (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : Dispose Method
Disposes any resources being used.
Overload List
Overload | Description
Dispose() | Disposes any resources being used.
Dispose(Boolean) | Disposes any resources being used.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Dispose() Method

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class > Dispose Method : Dispose() Method
Disposes any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Dispose()
'Usage

Dim instance As ImGearMprController

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearMprController Class
ImGearMprController Members
Overload List


Dispose(Boolean) Method

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Disposes any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearMprController
Dim disposing As Boolean

instance.Dispose(disposing)
protected virtual void Dispose(
   bool disposing
)
protected: virtual void Dispose(
   bool disposing
)
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearMprController Class
ImGearMprController Members
Overload List


MouseDown Method (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : MouseDown Method
Sender object.
Event arguments.
Provides mouse down interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearMprController
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseDown(sender, e)
public void MouseDown(
   object sender,
   MouseEventArgs e
)
public: void MouseDown(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseDown(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseDown event handler.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


MouseMove Method (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : MouseMove Method
Sender object.
Event arguments.
Provides mouse move interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearMprController
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseMove(sender, e)
public void MouseMove(
   object sender,
   MouseEventArgs e
)
public: void MouseMove(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseMove(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseMove event handler.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


MouseUp Method (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : MouseUp Method
Sender object.
Event arguments.
Provides mouse up interaction functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearMprController
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseUp(sender, e)
public void MouseUp(
   object sender,
   MouseEventArgs e
)
public: void MouseUp(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseUp(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
Remarks
This method is supposed to be called from the application's PageView_MouseUp event handler.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


SetPages Method (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : SetPages Method
Collection of pages.
View type of the pages.
Sets collection of pages to perform MPR on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPages( _
   ByVal pageArray As ImGearDocumentPageArray, _
   ByVal viewType As ImGearMprViewType _
)
'Usage

Dim instance As ImGearMprController
Dim pageArray As ImGearDocumentPageArray
Dim viewType As ImGearMprViewType

instance.SetPages(pageArray, viewType)
public void SetPages(
   ImGearDocumentPageArray pageArray,
   ImGearMprViewType viewType
)
public: void SetPages(
   ImGearDocumentPageArray* pageArray,
   ImGearMprViewType viewType
)
public:
void SetPages(
   ImGearDocumentPageArray^ pageArray,
   ImGearMprViewType viewType
)

Parameters

pageArray
Collection of pages.
viewType
View type of the pages.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


%%PageItemTitle%% $$Properties$$

ImGearMprController Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

Public Properties
 | Name | Description
Public Property | PageCount | Gets number of pages for current view.
Public Property | PageNumber | Gets or sets page's number to display.
Public Property | Pages | Gets collection of pages to perform MPR on.
Public Property | PagesViewType | Gets pages view type.
Public Property | PageView | Gets associated page view.
Public Property | Settings | Gets MPR settings.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Gets MPR controller type.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Dicom.Forms Namespace


ControllerType Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : ControllerType Property
Gets MPR controller type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected abstract ImGearMprViewType ControllerType {get;}
protected: __property abstract ImGearMprViewType get_ControllerType();
protected:
abstract property ImGearMprViewType ControllerType {
   ImGearMprViewType get();
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageCount Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : PageCount Property
Gets number of pages for current view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageNumber Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : PageNumber Property
Gets or sets page's number to display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Pages Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : Pages Property
Gets collection of pages to perform MPR on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearMprController
Dim value As ImGearDocumentPageArray

value = instance.Pages
public ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages();
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get();
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PagesViewType Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : PagesViewType Property
Gets pages view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PagesViewType As ImGearMprViewType
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprViewType

value = instance.PagesViewType
public ImGearMprViewType PagesViewType {get;}
public: __property ImGearMprViewType get_PagesViewType();
public:
property ImGearMprViewType PagesViewType {
   ImGearMprViewType get();
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageView Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : PageView Property
Gets associated page view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageView As ImGearPageView
'Usage

Dim instance As ImGearMprController
Dim value As ImGearPageView

value = instance.PageView
public ImGearPageView PageView {get;}
public: __property ImGearPageView* get_PageView();
public:
property ImGearPageView^ PageView {
   ImGearPageView^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearPageView class object.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Settings Property (ImGearMprController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprController Class : Settings Property
Gets MPR settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Settings As ImGearMprSettings
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprSettings

value = instance.Settings
public ImGearMprSettings Settings {get;}
public: __property ImGearMprSettings* get_Settings();
public:
property ImGearMprSettings^ Settings {
   ImGearMprSettings^ get();
}

Property Value

ImGearMprSettings class object.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


%%PageItemTitle%%

ImGearMprCoronalController Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprCoronalController Class
Represents controller for performing MPR operations on coronal stack of images.
Object Model
ImGearMprCoronalController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprCoronalController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprCoronalController
public class ImGearMprCoronalController : ImGearMprController
public __gc class ImGearMprCoronalController : public ImGearMprController
public ref class ImGearMprCoronalController : public ImGearMprController
Inheritance Hierarchy

System.Object
ImageGear.Dicom.Forms.ImGearMprController
ImageGear.Dicom.Forms.ImGearMprCoronalController

See Also

Reference

ImGearMprCoronalController Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprCoronalController Class Members
Properties Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprCoronalController Class

The following tables list the members exposed by ImGearMprCoronalController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprCoronalController Constructor | Initializes a new instance of the ImGearMprCoronalController class.
Top
Public Properties
 | Name | Description
Public Property | AxialViews | Gets a collection of output axial views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Public Property | SagittalViews | Gets a collection of output sagittal views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprCoronalController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%%

ImGearMprCoronalController Constructor

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprCoronalController Class : ImGearMprCoronalController Constructor
Associated page view.
Initializes a new instance of the ImGearMprCoronalController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearMprCoronalController(pageView)
public ImGearMprCoronalController(
   ImGearPageView pageView
)
public: ImGearMprCoronalController(
   ImGearPageView* pageView
)
public:
ImGearMprCoronalController(
   ImGearPageView^ pageView
)

Parameters

pageView
Associated page view.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


%%PageItemTitle%% $$Properties$$

ImGearMprCoronalController Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

Public Properties
 | Name | Description
Public Property | AxialViews | Gets a collection of output axial views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Public Property | SagittalViews | Gets a collection of output sagittal views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprCoronalController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprCoronalController Class Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

See Also

Reference

ImGearMprCoronalController Class
ImageGear.Dicom.Forms Namespace


AxialViews Property (ImGearMprCoronalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprCoronalController Class : AxialViews Property
Gets a collection of output axial views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ICollection(Of ImGearPageView)

value = instance.AxialViews
public ICollection<ImGearPageView> AxialViews {get;}
public: __property ICollection<ImGearPageView*>* get_AxialViews();
public:
property ICollection<ImGearPageView^>^ AxialViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


ControllerType Property (ImGearMprCoronalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprCoronalController Class : ControllerType Property
Gets MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


ObliqueViews Property (ImGearMprCoronalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprCoronalController Class : ObliqueViews Property
Gets a collection of output oblique views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ICollection(Of ImGearPageView)

value = instance.ObliqueViews
public ICollection<ImGearPageView> ObliqueViews {get;}
public: __property ICollection<ImGearPageView*>* get_ObliqueViews();
public:
property ICollection<ImGearPageView^>^ ObliqueViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


SagittalViews Property (ImGearMprCoronalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprCoronalController Class : SagittalViews Property
Gets a collection of output sagittal views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ICollection(Of ImGearPageView)

value = instance.SagittalViews
public ICollection<ImGearPageView> SagittalViews {get;}
public: __property ICollection<ImGearPageView*>* get_SagittalViews();
public:
property ICollection<ImGearPageView^>^ SagittalViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


%%PageItemTitle%%

ImGearMprSagittalController Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSagittalController Class
Represents contoller for performing MPR operations on sagittal stack of images.
Object Model
ImGearMprSagittalController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprSagittalController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprSagittalController
public class ImGearMprSagittalController : ImGearMprController
public __gc class ImGearMprSagittalController : public ImGearMprController
public ref class ImGearMprSagittalController : public ImGearMprController
Inheritance Hierarchy

System.Object
ImageGear.Dicom.Forms.ImGearMprController
ImageGear.Dicom.Forms.ImGearMprSagittalController

See Also

Reference

ImGearMprSagittalController Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprSagittalController Class Members
Properties Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSagittalController Class

The following tables list the members exposed by ImGearMprSagittalController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprSagittalController Constructor | Initializes a new instance of the ImGearMprSagittalController class.
Top
Public Properties
 | Name | Description
Public Property | AxialViews | Gets a collection of output axial views.
Public Property | CoronalViews | Gets a collection of output coronal views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprSagittalController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%%

ImGearMprSagittalController Constructor

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSagittalController Class : ImGearMprSagittalController Constructor
Associated page view.
Initializes a new instance of the ImGearMprSagittalController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearMprSagittalController(pageView)
public ImGearMprSagittalController(
   ImGearPageView pageView
)
public: ImGearMprSagittalController(
   ImGearPageView* pageView
)
public:
ImGearMprSagittalController(
   ImGearPageView^ pageView
)

Parameters

pageView
Associated page view.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


%%PageItemTitle%% $$Properties$$

ImGearMprSagittalController Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

Public Properties
 | Name | Description
Public Property | AxialViews | Gets a collection of output axial views.
Public Property | CoronalViews | Gets a collection of output coronal views.
Public Property | ObliqueViews | Gets a collection of output oblique views.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets MPR view type.
Top
See Also

Reference

ImGearMprSagittalController Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprSagittalController Class Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

See Also

Reference

ImGearMprSagittalController Class
ImageGear.Dicom.Forms Namespace


AxialViews Property (ImGearMprSagittalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSagittalController Class : AxialViews Property
Gets a collection of output axial views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ICollection(Of ImGearPageView)

value = instance.AxialViews
public ICollection<ImGearPageView> AxialViews {get;}
public: __property ICollection<ImGearPageView*>* get_AxialViews();
public:
property ICollection<ImGearPageView^>^ AxialViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


ControllerType Property (ImGearMprSagittalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSagittalController Class : ControllerType Property
Gets MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


CoronalViews Property (ImGearMprSagittalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSagittalController Class : CoronalViews Property
Gets a collection of output coronal views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ICollection(Of ImGearPageView)

value = instance.CoronalViews
public ICollection<ImGearPageView> CoronalViews {get;}
public: __property ICollection<ImGearPageView*>* get_CoronalViews();
public:
property ICollection<ImGearPageView^>^ CoronalViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


ObliqueViews Property (ImGearMprSagittalController)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSagittalController Class : ObliqueViews Property
Gets a collection of output oblique views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueViews As ICollection(Of ImGearPageView)
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ICollection(Of ImGearPageView)

value = instance.ObliqueViews
public ICollection<ImGearPageView> ObliqueViews {get;}
public: __property ICollection<ImGearPageView*>* get_ObliqueViews();
public:
property ICollection<ImGearPageView^>^ ObliqueViews {
   ICollection<ImGearPageView^>^ get();
}

Property Value

Collection of ImGearPageView objects.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


%%PageItemTitle%%

ImGearMprSettings Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSettings Class
Represents MPR settings.
Object Model
ImGearMprSettings ClassImGearRGBQuad StructureImGearRGBQuad StructureImGearRGBQuad StructureImGearRGBQuad Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprSettings
'Usage

Dim instance As ImGearMprSettings
public class ImGearMprSettings
public __gc class ImGearMprSettings
public ref class ImGearMprSettings
Inheritance Hierarchy

System.Object
ImageGear.Dicom.Forms.ImGearMprSettings

See Also

Reference

ImGearMprSettings Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprSettings Class Members
Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSettings Class

The following tables list the members exposed by ImGearMprSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprSettings Constructor | Initializes a new instance of the ImGearMprSettings class.
Top
Public Properties
 | Name | Description
Public Property | AxialLineColor | Gets or sets the color of MPR line for axial view reconstruction.
Public Property | CoronalLineColor | Gets or sets the color of MPR line for coronal view reconstruction.
Public Property | ObliqueLineColor | Gets or sets the color of MPR line for oblique view reconstruction.
Public Property | SagittalLineColor | Gets or sets the color of MPR line for sagittal view reconstruction.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%%

ImGearMprSettings Constructor

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSettings Class : ImGearMprSettings Constructor
Initializes a new instance of the ImGearMprSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprSettings()
public ImGearMprSettings()
public: ImGearMprSettings();
public:
ImGearMprSettings();
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%% $$Properties$$

ImGearMprSettings Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprSettings Class

For a list of all members of this type, see ImGearMprSettings members.

Public Properties
 | Name | Description
Public Property | AxialLineColor | Gets or sets the color of MPR line for axial view reconstruction.
Public Property | CoronalLineColor | Gets or sets the color of MPR line for coronal view reconstruction.
Public Property | ObliqueLineColor | Gets or sets the color of MPR line for oblique view reconstruction.
Public Property | SagittalLineColor | Gets or sets the color of MPR line for sagittal view reconstruction.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Dicom.Forms Namespace


AxialLineColor Property

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSettings Class : AxialLineColor Property
Gets or sets the color of MPR line for axial view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AxialLineColor As ImGearRGBQuad
'Usage

Dim instance As ImGearMprSettings
Dim value As ImGearRGBQuad

instance.AxialLineColor = value

value = instance.AxialLineColor
public ImGearRGBQuad AxialLineColor {get; set;}
public: __property ImGearRGBQuad get_AxialLineColor();
public: __property void set_AxialLineColor(
   ImGearRGBQuad value
);
public:
property ImGearRGBQuad AxialLineColor {
   ImGearRGBQuad get();
   void set (    ImGearRGBQuad value);
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


CoronalLineColor Property

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSettings Class : CoronalLineColor Property
Gets or sets the color of MPR line for coronal view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CoronalLineColor As ImGearRGBQuad
'Usage

Dim instance As ImGearMprSettings
Dim value As ImGearRGBQuad

instance.CoronalLineColor = value

value = instance.CoronalLineColor
public ImGearRGBQuad CoronalLineColor {get; set;}
public: __property ImGearRGBQuad get_CoronalLineColor();
public: __property void set_CoronalLineColor(
   ImGearRGBQuad value
);
public:
property ImGearRGBQuad CoronalLineColor {
   ImGearRGBQuad get();
   void set (    ImGearRGBQuad value);
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


ObliqueLineColor Property

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSettings Class : ObliqueLineColor Property
Gets or sets the color of MPR line for oblique view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObliqueLineColor As ImGearRGBQuad
'Usage

Dim instance As ImGearMprSettings
Dim value As ImGearRGBQuad

instance.ObliqueLineColor = value

value = instance.ObliqueLineColor
public ImGearRGBQuad ObliqueLineColor {get; set;}
public: __property ImGearRGBQuad get_ObliqueLineColor();
public: __property void set_ObliqueLineColor(
   ImGearRGBQuad value
);
public:
property ImGearRGBQuad ObliqueLineColor {
   ImGearRGBQuad get();
   void set (    ImGearRGBQuad value);
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


SagittalLineColor Property

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprSettings Class : SagittalLineColor Property
Gets or sets the color of MPR line for sagittal view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SagittalLineColor As ImGearRGBQuad
'Usage

Dim instance As ImGearMprSettings
Dim value As ImGearRGBQuad

instance.SagittalLineColor = value

value = instance.SagittalLineColor
public ImGearRGBQuad SagittalLineColor {get; set;}
public: __property ImGearRGBQuad get_SagittalLineColor();
public: __property void set_SagittalLineColor(
   ImGearRGBQuad value
);
public:
property ImGearRGBQuad SagittalLineColor {
   ImGearRGBQuad get();
   void set (    ImGearRGBQuad value);
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%%

ImGearMprVisualizer Class
Members

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprVisualizer Class
Represents view for visualizing MPR results. Represents view for visualizing MPR results.
Object Model
ImGearMprVisualizer ClassImGearMprAxialController ClassImGearMprCoronalController ClassImGearPageView ClassImGearMprSagittalController ClassImGearMprSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprVisualizer
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As ImGearMprVisualizer
public class ImGearMprVisualizer : System.Windows.Forms.UserControl
public __gc class ImGearMprVisualizer : public System.Windows.Forms.UserControl
public ref class ImGearMprVisualizer : public System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ImageGear.Dicom.Forms.ImGearMprVisualizer

See Also

Reference

ImGearMprVisualizer Members
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearMprVisualizer Class Members
Properties Methods Events

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprVisualizer Class

The following tables list the members exposed by ImGearMprVisualizer.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprVisualizer Constructor | Initializes a new instance of the ImGearMprVisualizer class.
Top
Public Properties
 | Name | Description
Public Property | AxialController | Gets MPR axial controller.
Public Property | CoronalController | Gets MPR coronal controller.
Public Property | ObliqueView | Gets oblique view.
Public Property | SagittalController | Gets MPR sagittal controller.
Public Property | Settings | Gets MPR settings.
Top
Public Methods
 | Name | Description
Public Method | Initialize | Initializes the visualizer with pages in specified view type. Should be called before loading.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%%

ImGearMprVisualizer Constructor

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : ImGearMprVisualizer Constructor
Initializes a new instance of the ImGearMprVisualizer class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprVisualizer()
public ImGearMprVisualizer()
public: ImGearMprVisualizer();
public:
ImGearMprVisualizer();
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


%%PageItemTitle%% $$Methods$$

ImGearMprVisualizer Class Methods

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

Public Methods
 | Name | Description
Public Method | Initialize | Initializes the visualizer with pages in specified view type. Should be called before loading.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Dicom.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearMprVisualizer Class Events

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

See Also

Reference

ImGearMprVisualizer Class
ImageGear.Dicom.Forms Namespace


Dispose Method (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose(Boolean) | Clean up any resources being used.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


Dispose(Boolean) Method

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class > Dispose Method : Dispose(Boolean) Method
True if managed resources should be disposed; otherwise, false.
Clean up any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearMprVisualizer
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
True if managed resources should be disposed; otherwise, false.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members
Overload List


Initialize Method (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : Initialize Method
Collection of pages to perform MPR on.
Type of MPR view the page collection represents.
Initializes the visualizer with pages in specified view type. Should be called before loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Initialize( _
   ByVal pageCollection As ImGearDocumentPageArray, _
   ByVal collectionViewType As ImGearMprViewType _
)
'Usage

Dim instance As ImGearMprVisualizer
Dim pageCollection As ImGearDocumentPageArray
Dim collectionViewType As ImGearMprViewType

instance.Initialize(pageCollection, collectionViewType)
public void Initialize(
   ImGearDocumentPageArray pageCollection,
   ImGearMprViewType collectionViewType
)
public: void Initialize(
   ImGearDocumentPageArray* pageCollection,
   ImGearMprViewType collectionViewType
)
public:
void Initialize(
   ImGearDocumentPageArray^ pageCollection,
   ImGearMprViewType collectionViewType
)

Parameters

pageCollection
Collection of pages to perform MPR on.
collectionViewType
Type of MPR view the page collection represents.
Exceptions
Exception | Description
System.ArgumentNullException | Page collection is null.
System.ArgumentException | View type cannot be Oblique.
ImageGear.Core.ImGearException | The MPR Visualizer is already initialized.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


%%PageItemTitle%% $$Properties$$

ImGearMprVisualizer Class Properties

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

Public Properties
 | Name | Description
Public Property | AxialController | Gets MPR axial controller.
Public Property | CoronalController | Gets MPR coronal controller.
Public Property | ObliqueView | Gets oblique view.
Public Property | SagittalController | Gets MPR sagittal controller.
Public Property | Settings | Gets MPR settings.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Dicom.Forms Namespace


AxialController Property (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : AxialController Property
Gets MPR axial controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialController As ImGearMprAxialController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprAxialController

value = instance.AxialController
public ImGearMprAxialController AxialController {get;}
public: __property ImGearMprAxialController* get_AxialController();
public:
property ImGearMprAxialController^ AxialController {
   ImGearMprAxialController^ get();
}

Property Value

ImGearMprAxialController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


CoronalController Property (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : CoronalController Property
Gets MPR coronal controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalController As ImGearMprCoronalController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprCoronalController

value = instance.CoronalController
public ImGearMprCoronalController CoronalController {get;}
public: __property ImGearMprCoronalController* get_CoronalController();
public:
property ImGearMprCoronalController^ CoronalController {
   ImGearMprCoronalController^ get();
}

Property Value

ImGearMprCoronalController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


ObliqueView Property

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : ObliqueView Property
Gets oblique view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueView As ImGearPageView
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearPageView

value = instance.ObliqueView
public ImGearPageView ObliqueView {get;}
public: __property ImGearPageView* get_ObliqueView();
public:
property ImGearPageView^ ObliqueView {
   ImGearPageView^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearPageView value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


SagittalController Property (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : SagittalController Property
Gets MPR sagittal controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalController As ImGearMprSagittalController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprSagittalController

value = instance.SagittalController
public ImGearMprSagittalController SagittalController {get;}
public: __property ImGearMprSagittalController* get_SagittalController();
public:
property ImGearMprSagittalController^ SagittalController {
   ImGearMprSagittalController^ get();
}

Property Value

ImGearMprSagittalController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


Settings Property (ImGearMprVisualizer)

ImageGear22.Dicom.Forms Assembly > ImageGear.Dicom.Forms Namespace > ImGearMprVisualizer Class : Settings Property
Gets MPR settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Settings As ImGearMprSettings
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprSettings

value = instance.Settings
public ImGearMprSettings Settings {get;}
public: __property ImGearMprSettings* get_Settings();
public:
property ImGearMprSettings^ Settings {
   ImGearMprSettings^ get();
}

Property Value

ImGearMprSettings class object.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


ImageGear22.Evaluation Assembly
Namespaces
Namespace | Description
ImageGear.Evaluation | The ImageGear.Evaluation namespace provides the evaluation manager used for product evaluation either in trial dialog mode (default) or watermarks mode.


ImageGear.Evaluation Namespace
Inheritance Hierarchy
ImageGear22.Evaluation Assembly : ImageGear.Evaluation Namespace
The ImageGear.Evaluation namespace provides the evaluation manager used for product evaluation either in trial dialog mode (default) or watermarks mode.
Classes
 | Class | Description
Class | ImGearEvaluationManager | Provides an evaluation licensing manager.
Enumerations
 | Enumeration | Description
Enumeration | ImGearEvaluationMode | Specifies product evaluation mode.
See Also

Reference

ImageGear22.Evaluation Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Evaluation Namespace Inheritance Hierarchy
ImageGear22.Evaluation Assembly : ImageGear.Evaluation Namespace
Inheritance Hierarchy
System.Object
ImageGear.Evaluation.ImGearEvaluationManager
See Also

Reference

ImageGear22.Evaluation Assembly


%%PageItemTitle%%

ImGearEvaluationManager Class
Members

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace : ImGearEvaluationManager Class
Provides an evaluation licensing manager.
Object Model
ImGearEvaluationManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEvaluationManager
'Usage

Dim instance As ImGearEvaluationManager
public class ImGearEvaluationManager
public __gc class ImGearEvaluationManager
public ref class ImGearEvaluationManager
Remarks
This class must be initialized prior to using any other licensing call when the product is running in evaluation mode.
Inheritance Hierarchy

System.Object
ImageGear.Evaluation.ImGearEvaluationManager

See Also

Reference

ImGearEvaluationManager Members
ImageGear.Evaluation Namespace


%%PageItemTitle%% $$Members$$

ImGearEvaluationManager Class Members
Properties Methods

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace : ImGearEvaluationManager Class

The following tables list the members exposed by ImGearEvaluationManager.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Mode | Gets or sets the product evaluation mode.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Evaluation.dll assembly.
Top
See Also

Reference

ImGearEvaluationManager Class
ImageGear.Evaluation Namespace


%%PageItemTitle%% $$Methods$$

ImGearEvaluationManager Class Methods

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace : ImGearEvaluationManager Class

For a list of all members of this type, see ImGearEvaluationManager members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Evaluation.dll assembly.
Top
See Also

Reference

ImGearEvaluationManager Class
ImageGear.Evaluation Namespace


Initialize Method (ImGearEvaluationManager)

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace > ImGearEvaluationManager Class : Initialize Method
Initializes the ImageGear22.Evaluation.dll assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize()
'Usage

ImGearEvaluationManager.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks

This method initializes the evaluation licensing and must be called prior to using any other licensing call.

See Also

Reference

ImGearEvaluationManager Class
ImGearEvaluationManager Members


%%PageItemTitle%% $$Properties$$

ImGearEvaluationManager Class Properties

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace : ImGearEvaluationManager Class

For a list of all members of this type, see ImGearEvaluationManager members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Mode | Gets or sets the product evaluation mode.
Top
See Also

Reference

ImGearEvaluationManager Class
ImageGear.Evaluation Namespace


Mode Property (ImGearEvaluationManager)

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace > ImGearEvaluationManager Class : Mode Property
Gets or sets the product evaluation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property Mode As ImGearEvaluationMode
'Usage

Dim value As ImGearEvaluationMode

ImGearEvaluationManager.Mode = value

value = ImGearEvaluationManager.Mode
public static ImGearEvaluationMode Mode {get; set;}
public: __property static ImGearEvaluationMode get_Mode();
public: __property static void set_Mode(
   ImGearEvaluationMode value
);
public:
static property ImGearEvaluationMode Mode {
   ImGearEvaluationMode get();
   void set (    ImGearEvaluationMode value);
}

Property Value

ImGearEvaluationMode enumeration value.
Remarks
The default value is ImGearEvaluationMode.TrialDialog.
See Also

Reference

ImGearEvaluationManager Class
ImGearEvaluationManager Members


%%PageItemTitle%%

ImGearEvaluationMode Enumeration

ImageGear22.Evaluation Assembly > ImageGear.Evaluation Namespace : ImGearEvaluationMode Enumeration
Specifies product evaluation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEvaluationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEvaluationMode
public enum ImGearEvaluationMode : System.Enum
__value public enum ImGearEvaluationMode : public System.Enum
public enum class ImGearEvaluationMode : public System.Enum
Members
Member | Value | Description
TrialDialog | 0 | Always displays the evaluation dialog on initial licensing validation and periodically afterwards, as well as when save operation is performed.
Watermark | 1 | Causes a watermark to be applied to images displayed on screen, saved to stream and sent to a printer.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Evaluation.ImGearEvaluationMode

See Also

Reference

ImageGear.Evaluation Namespace


ImageGear22.Formats.Advanced Assembly
Namespaces
Namespace | Description
ImageGear.Formats | ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.


ImageGear.Formats Namespace (ImageGear22.Formats.Advanced)
Inheritance Hierarchy
ImageGear22.Formats.Advanced Assembly : ImageGear.Formats Namespace
ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
Classes
 | Class | Description
Class | ImGearAdvancedFormats | Initializes the ImageGear22.Formats.Advanced.dll assembly.
See Also

Reference

ImageGear22.Formats.Advanced Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats Namespace (ImageGear22.Formats.Advanced) Inheritance Hierarchy
ImageGear22.Formats.Advanced Assembly : ImageGear.Formats Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearAdvancedFormats
See Also

Reference

ImageGear22.Formats.Advanced Assembly


%%PageItemTitle%%

ImGearAdvancedFormats Class
Members

ImageGear22.Formats.Advanced Assembly > ImageGear.Formats Namespace : ImGearAdvancedFormats Class
Initializes the ImageGear22.Formats.Advanced.dll assembly.
Object Model
ImGearAdvancedFormats Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearAdvancedFormats
'Usage

Dim instance As ImGearAdvancedFormats
public sealed class ImGearAdvancedFormats
public __gc __sealed class ImGearAdvancedFormats
public ref class ImGearAdvancedFormats sealed
Remarks
This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
Information about supported formats in the component can be found in "ImageGear for .NET Assemblies" article.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearAdvancedFormats

See Also

Reference

ImGearAdvancedFormats Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearAdvancedFormats Class Members
Methods

ImageGear22.Formats.Advanced Assembly > ImageGear.Formats Namespace : ImGearAdvancedFormats Class

The following tables list the members exposed by ImGearAdvancedFormats.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.Advanced.dll assembly.
Top
See Also

Reference

ImGearAdvancedFormats Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearAdvancedFormats Class Methods

ImageGear22.Formats.Advanced Assembly > ImageGear.Formats Namespace : ImGearAdvancedFormats Class

For a list of all members of this type, see ImGearAdvancedFormats members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.Advanced.dll assembly.
Top
See Also

Reference

ImGearAdvancedFormats Class
ImageGear.Formats Namespace


Initialize Method (ImGearAdvancedFormats)

ImageGear22.Formats.Advanced Assembly > ImageGear.Formats Namespace > ImGearAdvancedFormats Class : Initialize Method
Initializes the ImageGear22.Formats.Advanced.dll assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize()
'Usage

ImGearAdvancedFormats.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks
This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
See Also

Reference

ImGearAdvancedFormats Class
ImGearAdvancedFormats Members


ImageGear22.Formats.CameraRaw Assembly
Namespaces
Namespace | Description
ImageGear.Formats | ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.


ImageGear.Formats Namespace (ImageGear22.Formats.CameraRaw)
Inheritance Hierarchy
ImageGear22.Formats.CameraRaw Assembly : ImageGear.Formats Namespace

ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.

Classes
 | Class | Description
Class | ImGearCameraRawFormats | Initializes the ImageGear22.Formats.CameraRaw.dll assembly.
See Also

Reference

ImageGear22.Formats.CameraRaw Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats Namespace (ImageGear22.Formats.CameraRaw) Inheritance Hierarchy
ImageGear22.Formats.CameraRaw Assembly : ImageGear.Formats Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearCameraRawFormats
See Also

Reference

ImageGear22.Formats.CameraRaw Assembly


%%PageItemTitle%%

ImGearCameraRawFormats Class
Members

ImageGear22.Formats.CameraRaw Assembly > ImageGear.Formats Namespace : ImGearCameraRawFormats Class
Initializes the ImageGear22.Formats.CameraRaw.dll assembly.
Object Model
ImGearCameraRawFormats Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCameraRawFormats
'Usage

Dim instance As ImGearCameraRawFormats
public sealed class ImGearCameraRawFormats
public __gc __sealed class ImGearCameraRawFormats
public ref class ImGearCameraRawFormats sealed
Remarks
This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
See " ImageGear Supported Digital Camera RAW Formats Reference" for information about supported formats.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearCameraRawFormats

See Also

Reference

ImGearCameraRawFormats Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearCameraRawFormats Class Members
Methods

ImageGear22.Formats.CameraRaw Assembly > ImageGear.Formats Namespace : ImGearCameraRawFormats Class

The following tables list the members exposed by ImGearCameraRawFormats.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.CameraRaw.dll assembly.
Top
See Also

Reference

ImGearCameraRawFormats Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearCameraRawFormats Class Methods

ImageGear22.Formats.CameraRaw Assembly > ImageGear.Formats Namespace : ImGearCameraRawFormats Class

For a list of all members of this type, see ImGearCameraRawFormats members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.CameraRaw.dll assembly.
Top
See Also

Reference

ImGearCameraRawFormats Class
ImageGear.Formats Namespace


Initialize Method (ImGearCameraRawFormats)

ImageGear22.Formats.CameraRaw Assembly > ImageGear.Formats Namespace > ImGearCameraRawFormats Class : Initialize Method
Initializes the ImageGear22.Formats.CameraRaw.dll assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize()
'Usage

ImGearCameraRawFormats.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks
This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
See Also

Reference

ImGearCameraRawFormats Class
ImGearCameraRawFormats Members


ImageGear22.Formats.Common Assembly
Namespaces
Namespace | Description
ImageGear.Formats | ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
ImageGear.Formats.EXIF | This namespace provides the API for operating with EXIF non-image data.
ImageGear.Formats.TIF | This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.


ImageGear.Formats Namespace (ImageGear22.Formats.Common)
Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats Namespace
ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
Classes
 | Class | Description
Class | ImGearCommonFormats | Initializes the ImageGear22.Formats.Common.dll assembly.
Class | ImGearRawLoadOptions | Specifies loading options for header-less RAW formats.
Enumerations
 | Enumeration | Description
Enumeration | ImGearPNGCompLevel | Lists all PNG compression levels.
Enumeration | ImGearPngImprovingFilter | Lists all PNG Filter for improving the raster compression.
Enumeration | ImGearPNGStrip | Lists all PNG strip modes.
Enumeration | ImGearRawAlignment | Represents alignment of bytes in raster line.
See Also

Reference

ImageGear22.Formats.Common Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats Namespace (ImageGear22.Formats.Common) Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearCommonFormats
ImageGear.Formats.ImGearLoadOptions
ImageGear.Formats.ImGearRawLoadOptions
See Also

Reference

ImageGear22.Formats.Common Assembly


%%PageItemTitle%%

ImGearCommonFormats Class
Members

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearCommonFormats Class
Initializes the ImageGear22.Formats.Common.dll assembly.
Object Model
ImGearCommonFormats ClassIImGearFormat InterfaceIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCommonFormats
'Usage

Dim instance As ImGearCommonFormats
public sealed class ImGearCommonFormats
public __gc __sealed class ImGearCommonFormats
public ref class ImGearCommonFormats sealed
Remarks
This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
Information about supported formats in the component can be found in "ImageGear for .NET Assemblies" article.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearCommonFormats

See Also

Reference

ImGearCommonFormats Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearCommonFormats Class Members
Methods

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearCommonFormats Class

The following tables list the members exposed by ImGearCommonFormats.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateJpegFormat | Creates advanced JPEG format instance.
static (Shared in Visual Basic) | CreatePngFormat | Creates advanced PNG format instance.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes the ImageGear22.Formats.Common.dll assembly.
Top
See Also

Reference

ImGearCommonFormats Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearCommonFormats Class Methods

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearCommonFormats Class

For a list of all members of this type, see ImGearCommonFormats members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateJpegFormat | Creates advanced JPEG format instance.
static (Shared in Visual Basic) | CreatePngFormat | Creates advanced PNG format instance.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes the ImageGear22.Formats.Common.dll assembly.
Top
See Also

Reference

ImGearCommonFormats Class
ImageGear.Formats Namespace


CreateJpegFormat Method

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearCommonFormats Class : CreateJpegFormat Method
Creates advanced JPEG format instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateJpegFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearCommonFormats.CreateJpegFormat()
public static IImGearFormat CreateJpegFormat()
public: static IImGearFormat* CreateJpegFormat();
public:
static IImGearFormat^ CreateJpegFormat();

Return Value

IImGearFormat instance of JPEG format.
Remarks
The Initialize(String) method adds to the ImageGear's global formats list default JPEG format instance. Use this method to create instance with more advanced image compression features. Use ImGearFileFilters.Set to replace existing default JPEG format with this advanced one.
See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members


CreatePngFormat Method

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearCommonFormats Class : CreatePngFormat Method
Creates advanced PNG format instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreatePngFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearCommonFormats.CreatePngFormat()
public static IImGearFormat CreatePngFormat()
public: static IImGearFormat* CreatePngFormat();
public:
static IImGearFormat^ CreatePngFormat();

Return Value

IImGearFormat instance of PNG format.
Remarks
The Initialize(String) method adds to the ImageGear's global formats list default PNG format instance. Use this method to create instance with more advanced image compression features. Use ImGearFileFilters.Set to replace existing default PNG format with this advanced one.
See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members


Initialize Method (ImGearCommonFormats)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearCommonFormats Class : Initialize Method
Initializes the ImageGear22.Formats.Common.dll assembly.
Overload List
Overload | Description
Initialize() | Initializes the ImageGear22.Formats.Common.dll assembly.
Initialize(String) | Initializes the ImageGear22.Formats.Common.dll assembly with path to binary modules.
See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members


Initialize() Method

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearCommonFormats Class > Initialize Method : Initialize() Method
Initializes the ImageGear22.Formats.Common.dll assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Initialize()
'Usage

ImGearCommonFormats.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks
This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members
Overload List


Initialize(String) Method

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearCommonFormats Class > Initialize Method : Initialize(String) Method
Path to the binary dynamic libraries participating in reading/writting of the common file formats.
Initializes the ImageGear22.Formats.Common.dll assembly with path to binary modules.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Initialize( _
   ByVal binaryPath As String _
)
'Usage

Dim binaryPath As String

ImGearCommonFormats.Initialize(binaryPath)
public static void Initialize(
   string binaryPath
)
public: static void Initialize(
   string* binaryPath
)
public:
static void Initialize(
   String^ binaryPath
)

Parameters

binaryPath
Path to the binary dynamic libraries participating in reading/writting of the common file formats.
Remarks
This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization. Unlike Initialize() method without parameters this method allows to use ImageGear22.Formats.Common.dll outside ImageGear installation directory.
See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members
Overload List


%%PageItemTitle%%

ImGearRawLoadOptions Class
Members

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearRawLoadOptions Class
Specifies loading options for header-less RAW formats.
Object Model
ImGearRawLoadOptions ClassImGearColorSpace Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRawLoadOptions
   Inherits ImGearLoadOptions
'Usage

Dim instance As ImGearRawLoadOptions
public class ImGearRawLoadOptions : ImGearLoadOptions
public __gc class ImGearRawLoadOptions : public ImGearLoadOptions
public ref class ImGearRawLoadOptions : public ImGearLoadOptions
Remarks
Use this class with ImGearFileFormats.LoadPage.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearLoadOptions
ImageGear.Formats.ImGearRawLoadOptions

See Also

Reference

ImGearRawLoadOptions Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearRawLoadOptions Class Members
Properties

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearRawLoadOptions Class

The following tables list the members exposed by ImGearRawLoadOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearRawLoadOptions Constructor | Initializes a new instance of the ImGearRawLoadOptions class object.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets alignment of bytes in raster line.
Public Property | BitsPerChannel | Gets or sets the number of bits per color channel.
Public Property | ColorSpace | Gets or sets image color space.
Public Property | Compression | Gets or sets image compression.
Public Property | FillOrder | Gets or sets fill order of pixels in byte.
Public Property | Height | Gets or sets image height in pixels.
Public Property | IsRasterPacked | Gets or sets a value indicating whether the raster bits are packed.
Public Property | Offset | Gets or sets image data offset in the stream.
Public Property | Width | Gets or sets image width in pixels.
Top
See Also

Reference

ImGearRawLoadOptions Class
ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRawLoadOptions Constructor

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : ImGearRawLoadOptions Constructor
Initializes a new instance of the ImGearRawLoadOptions class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRawLoadOptions()
public ImGearRawLoadOptions()
public: ImGearRawLoadOptions();
public:
ImGearRawLoadOptions();
Remarks
Use this class with ImGearFileFormats.LoadPage.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%% $$Properties$$

ImGearRawLoadOptions Class Properties

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearRawLoadOptions Class

For a list of all members of this type, see ImGearRawLoadOptions members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets alignment of bytes in raster line.
Public Property | BitsPerChannel | Gets or sets the number of bits per color channel.
Public Property | ColorSpace | Gets or sets image color space.
Public Property | Compression | Gets or sets image compression.
Public Property | FillOrder | Gets or sets fill order of pixels in byte.
Public Property | Height | Gets or sets image height in pixels.
Public Property | IsRasterPacked | Gets or sets a value indicating whether the raster bits are packed.
Public Property | Offset | Gets or sets image data offset in the stream.
Public Property | Width | Gets or sets image width in pixels.
Top
See Also

Reference

ImGearRawLoadOptions Class
ImageGear.Formats Namespace


Alignment Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : Alignment Property
Gets or sets alignment of bytes in raster line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Alignment As ImGearRawAlignment
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As ImGearRawAlignment

instance.Alignment = value

value = instance.Alignment
public ImGearRawAlignment Alignment {get; set;}
public: __property ImGearRawAlignment get_Alignment();
public: __property void set_Alignment(
   ImGearRawAlignment value
);
public:
property ImGearRawAlignment Alignment {
   ImGearRawAlignment get();
   void set (    ImGearRawAlignment value);
}

Property Value

ImGearRawAlignment enumeration value.
Remarks
For additional information see ImGearRawAlignment.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


BitsPerChannel Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : BitsPerChannel Property
Gets or sets the number of bits per color channel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerChannel As Integer
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As Integer

instance.BitsPerChannel = value

value = instance.BitsPerChannel
public int BitsPerChannel {get; set;}
public: __property int get_BitsPerChannel();
public: __property void set_BitsPerChannel(
   int value
);
public:
property int BitsPerChannel {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


ColorSpace Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : ColorSpace Property
Gets or sets image color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As ImGearColorSpace
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As ImGearColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public ImGearColorSpace ColorSpace {get; set;}
public: __property ImGearColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ImGearColorSpace value
);
public:
property ImGearColorSpace ColorSpace {
   ImGearColorSpace get();
   void set (    ImGearColorSpace value);
}

Property Value

ImGearColorSpace structure.
Remarks
For additional information see ImageGear.Core.ImGearColorSpace.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


Compression Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : Compression Property
Gets or sets image compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As ImGearCompressions
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As ImGearCompressions

instance.Compression = value

value = instance.Compression
public ImGearCompressions Compression {get; set;}
public: __property ImGearCompressions get_Compression();
public: __property void set_Compression(
   ImGearCompressions value
);
public:
property ImGearCompressions Compression {
   ImGearCompressions get();
   void set (    ImGearCompressions value);
}

Property Value

ImGearCompressions enumeration value.
Remarks
For additional information see ImGearCompressions.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


FillOrder Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : FillOrder Property
Gets or sets fill order of pixels in byte.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillOrder As ImGearFillOrder
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As ImGearFillOrder

instance.FillOrder = value

value = instance.FillOrder
public ImGearFillOrder FillOrder {get; set;}
public: __property ImGearFillOrder get_FillOrder();
public: __property void set_FillOrder(
   ImGearFillOrder value
);
public:
property ImGearFillOrder FillOrder {
   ImGearFillOrder get();
   void set (    ImGearFillOrder value);
}

Property Value

ImGearFillOrder enumeration value.
Remarks
For additional information see ImGearFillOrder.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


Height Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : Height Property
Gets or sets image height in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


IsRasterPacked Property

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : IsRasterPacked Property
Gets or sets a value indicating whether the raster bits are packed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsRasterPacked As Boolean
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As Boolean

instance.IsRasterPacked = value

value = instance.IsRasterPacked
public bool IsRasterPacked {get; set;}
public: __property bool get_IsRasterPacked();
public: __property void set_IsRasterPacked(
   bool value
);
public:
property bool IsRasterPacked {
   bool get();
   void set (    bool value);
}

Property Value

True if the raster bits are packed (the raster bits are not aligned in this case), False - otherwise.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


Offset Property

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : Offset Property
Gets or sets image data offset in the stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Offset As Integer
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As Integer

instance.Offset = value

value = instance.Offset
public int Offset {get; set;}
public: __property int get_Offset();
public: __property void set_Offset(
   int value
);
public:
property int Offset {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


Width Property (ImGearRawLoadOptions)

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace > ImGearRawLoadOptions Class : Width Property
Gets or sets image width in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearRawLoadOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

ImGearPNGCompLevel Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearPNGCompLevel Enumeration
Lists all PNG compression levels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPNGCompLevel
   Inherits System.Enum
'Usage

Dim instance As ImGearPNGCompLevel
public enum ImGearPNGCompLevel : System.Enum
__value public enum ImGearPNGCompLevel : public System.Enum
public enum class ImGearPNGCompLevel : public System.Enum
Members
Member | Value | Description
DEFAULT_COMPRESSION | 6 | Default compression.
MAX_COMPRESSION | 9 | Maximum compression.
MIN_COMPRESSION | 0 | Minimum compression.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPNGCompLevel

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPngImprovingFilter Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearPngImprovingFilter Enumeration
Lists all PNG Filter for improving the raster compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPngImprovingFilter
   Inherits System.Enum
'Usage

Dim instance As ImGearPngImprovingFilter
public enum ImGearPngImprovingFilter : System.Enum
__value public enum ImGearPngImprovingFilter : public System.Enum
public enum class ImGearPngImprovingFilter : public System.Enum
Members
Member | Value | Description
Average | 3 | The "Average" filter is used.
None | 0 | The filter is not used.
Optimal | 5 | The best of the four filters.
Paeth | 4 | The "Paeth" filter is used.
Sub | 1 | The "Sub" filter is used.
Up | 2 | The "Up" filter is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPngImprovingFilter

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearPNGStrip Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearPNGStrip Enumeration
Lists all PNG strip modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPNGStrip
   Inherits System.Enum
'Usage

Dim instance As ImGearPNGStrip
public enum ImGearPNGStrip : System.Enum
__value public enum ImGearPNGStrip : public System.Enum
public enum class ImGearPNGStrip : public System.Enum
Members
Member | Value | Description
STRIP_FIXED_BUFFER | 1 | Fixed buffer.
STRIP_FIXED_COUNT | 0 | Fixed strip count.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearPNGStrip

See Also

Reference

ImageGear.Formats Namespace


%%PageItemTitle%%

ImGearRawAlignment Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats Namespace : ImGearRawAlignment Enumeration
Represents alignment of bytes in raster line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRawAlignment
   Inherits System.Enum
'Usage

Dim instance As ImGearRawAlignment
public enum ImGearRawAlignment : System.Enum
__value public enum ImGearRawAlignment : public System.Enum
public enum class ImGearRawAlignment : public System.Enum
Members
Member | Value | Description
Byte | 0 | Raster lines are byte aligned.
DoubleWord | 2 | Raster lines are double word aligned.
Word | 1 | Raster lines are word aligned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.ImGearRawAlignment

See Also

Reference

ImageGear.Formats Namespace


ImageGear.Formats.EXIF Namespace (ImageGear22.Formats.Common)
Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats.EXIF Namespace
This namespace provides the API for operating with EXIF non-image data.
Enumerations
 | Enumeration | Description
Enumeration | ImGearEXIFColorSpace | Represents EXIF color spaces.
Enumeration | ImGearEXIFContrastMode | Represents EXIF contrast modes.
Enumeration | ImGearEXIFCustomRendered | Represents EXIF custom rendered modes.
Enumeration | ImGearEXIFExposureMode | Represents EXIF exposure modes.
Enumeration | ImGearEXIFExposureProgram | Represents EXIF exposure programs.
Enumeration | ImGearEXIFFileSource | Represents EXIF File Sources.
Enumeration | ImGearEXIFFlashMode | Represents EXIF flash mode.
Enumeration | ImGearEXIFFlashReturn | Represents EXIF flash return.
Enumeration | ImGearEXIFGainControl | Represents EXIF gain controls.
Enumeration | ImGearEXIFGPSAltitudeReference | Represents EXIF GPS altitude references.
Enumeration | ImGearEXIFGPSDifferential | Represents EXIF GPS differentials.
Enumeration | ImGearEXIFGPSDirectionReference | Represents EXIF GPS direction references.
Enumeration | ImGearEXIFGPSDistanceReference | Represents EXIF GPS distance references.
Enumeration | ImGearEXIFGPSLatitudeReference | Represents EXIF GPS latitude references.
Enumeration | ImGearEXIFGPSLongitudeReference | Represents EXIF GPS longitude references.
Enumeration | ImGearEXIFGPSMeasureMode | Represents EXIF GPS measure modes.
Enumeration | ImGearEXIFGPSSpeedReference | Represents EXIF GPS speed reference modes.
Enumeration | ImGearEXIFGPSStatus | Represents EXIF GPS statuses.
Enumeration | ImGearEXIFLightSource | Represents EXIF light sources.
Enumeration | ImGearEXIFMeteringMode | Represents EXIF Metering Modes.
Enumeration | ImGearEXIFSaturationMode | Represents EXIF saturation modes.
Enumeration | ImGearEXIFSceneCaptureType | Represents EXIF scene capture types.
Enumeration | ImGearEXIFSceneType | Represents EXIF scene types.
Enumeration | ImGearEXIFSensingMethod | Represents EXIF sensing methods.
Enumeration | ImGearEXIFSharpnessMode | Represents EXIF sharpness modes.
Enumeration | ImGearEXIFSubjectDistanceRange | Represents EXIF subject distance ranges.
Enumeration | ImGearEXIFWhiteBalanceMode | Represents EXIF white balance modes.
See Also

Reference

ImageGear22.Formats.Common Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.EXIF Namespace (ImageGear22.Formats.Common) Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats.EXIF Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ImageGear22.Formats.Common Assembly


%%PageItemTitle%%

ImGearEXIFColorSpace Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFColorSpace Enumeration
Represents EXIF color spaces.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFColorSpace
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFColorSpace
public enum ImGearEXIFColorSpace : System.Enum
__value public enum ImGearEXIFColorSpace : public System.Enum
public enum class ImGearEXIFColorSpace : public System.Enum
Members
Member | Value | Description
SRGB | 0x00000001 | Color space is sRGB.
Uncalibrated | 0x0000FFFF | Color space other than sRGB is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFColorSpace

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFContrastMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFContrastMode Enumeration
Represents EXIF contrast modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFContrastMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFContrastMode
public enum ImGearEXIFContrastMode : System.Enum
__value public enum ImGearEXIFContrastMode : public System.Enum
public enum class ImGearEXIFContrastMode : public System.Enum
Members
Member | Value | Description
Hard | 2 | Hard mode.
Normal | 0 | Normal mode.
Soft | 1 | Soft mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFContrastMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFCustomRendered Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFCustomRendered Enumeration
Represents EXIF custom rendered modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFCustomRendered
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFCustomRendered
public enum ImGearEXIFCustomRendered : System.Enum
__value public enum ImGearEXIFCustomRendered : public System.Enum
public enum class ImGearEXIFCustomRendered : public System.Enum
Members
Member | Value | Description
CustomProcess | 1 | Custom process.
NormalProcess | 0 | Normal process.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFCustomRendered

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFExposureMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFExposureMode Enumeration
Represents EXIF exposure modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFExposureMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFExposureMode
public enum ImGearEXIFExposureMode : System.Enum
__value public enum ImGearEXIFExposureMode : public System.Enum
public enum class ImGearEXIFExposureMode : public System.Enum
Members
Member | Value | Description
AutoBracket | 2 | Auto bracket.
AutoExposure | 0 | Auto exposure.
ManualExposure | 1 | Manual exposure.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFExposureMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFExposureProgram Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFExposureProgram Enumeration
Represents EXIF exposure programs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFExposureProgram
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFExposureProgram
public enum ImGearEXIFExposureProgram : System.Enum
__value public enum ImGearEXIFExposureProgram : public System.Enum
public enum class ImGearEXIFExposureProgram : public System.Enum
Members
Member | Value | Description
ActionProgram | 6 | Action program (biased toward fast shutter speed).
AperturePriority | 3 | Aperture priority.
CreativeProgram | 5 | Creative program (biased toward depth of field).
LandscapeMode | 8 | Landscape mode (for landscape photos with the background in focus).
Manual | 1 | Manual program.
NormalProgram | 2 | Normal program.
PortraitMode | 7 | Portrait mode (for closeup photos with the background out of focus).
ShutterPriority | 4 | Shutter program.
Undefined | 0 | Undefined program.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFExposureProgram

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFFileSource Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFFileSource Enumeration
Represents EXIF File Sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFFileSource
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFFileSource
public enum ImGearEXIFFileSource : System.Enum
__value public enum ImGearEXIFFileSource : public System.Enum
public enum class ImGearEXIFFileSource : public System.Enum
Members
Member | Value | Description
DSC | 3 | Digital still camera.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFFileSource

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFFlashMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFFlashMode Enumeration
Represents EXIF flash mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFFlashMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFFlashMode
public enum ImGearEXIFFlashMode : System.Enum
__value public enum ImGearEXIFFlashMode : public System.Enum
public enum class ImGearEXIFFlashMode : public System.Enum
Members
Member | Value | Description
AutoMode | 3 | Auto mode.
CompulsoryFlashFiring | 1 | Compulsory flash firing.
CompulsoryFlashSuppression | 2 | Compulsory flash suppression.
Unknown | 0 | Unknown mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFFlashMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFFlashReturn Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFFlashReturn Enumeration
Represents EXIF flash return.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFFlashReturn
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFFlashReturn
public enum ImGearEXIFFlashReturn : System.Enum
__value public enum ImGearEXIFFlashReturn : public System.Enum
public enum class ImGearEXIFFlashReturn : public System.Enum
Members
Member | Value | Description
NoStrobeReturnDetection | 0 | No strobe return detection.
StrobeReturnLightDetected | 3 | Strobe return light detected.
StrobeReturnLightNotDetected | 2 | Strobe return light not detected.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFFlashReturn

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGainControl Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGainControl Enumeration
Represents EXIF gain controls.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGainControl
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGainControl
public enum ImGearEXIFGainControl : System.Enum
__value public enum ImGearEXIFGainControl : public System.Enum
public enum class ImGearEXIFGainControl : public System.Enum
Members
Member | Value | Description
HighGainDown | 4 | High gain down.
HighGainUp | 2 | High gain up.
LowGainDown | 3 | Low gain down.
LowGainUp | 1 | Low gain up.
None | 0 | No gain control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGainControl

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSAltitudeReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSAltitudeReference Enumeration
Represents EXIF GPS altitude references.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSAltitudeReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSAltitudeReference
public enum ImGearEXIFGPSAltitudeReference : System.Enum
__value public enum ImGearEXIFGPSAltitudeReference : public System.Enum
public enum class ImGearEXIFGPSAltitudeReference : public System.Enum
Members
Member | Value | Description
SeaLevel | 0 | The altitude reference is sea level.
SeaLevelReference | 1 | The altitude is below sea level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSAltitudeReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSDifferential Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSDifferential Enumeration
Represents EXIF GPS differentials.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSDifferential
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSDifferential
public enum ImGearEXIFGPSDifferential : System.Enum
__value public enum ImGearEXIFGPSDifferential : public System.Enum
public enum class ImGearEXIFGPSDifferential : public System.Enum
Members
Member | Value | Description
DifferentialCorrectionApplied | 1 | Differential correction applied.
WithoutDifferentialCorrection | 0 | Measurement without differential correction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSDifferential

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSDirectionReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSDirectionReference Enumeration
Represents EXIF GPS direction references.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSDirectionReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSDirectionReference
public enum ImGearEXIFGPSDirectionReference : System.Enum
__value public enum ImGearEXIFGPSDirectionReference : public System.Enum
public enum class ImGearEXIFGPSDirectionReference : public System.Enum
Members
Member | Value | Description
Magnetic | 1 | Magnetic direction.
True | 0 | True direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSDirectionReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSDistanceReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSDistanceReference Enumeration
Represents EXIF GPS distance references.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSDistanceReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSDistanceReference
public enum ImGearEXIFGPSDistanceReference : System.Enum
__value public enum ImGearEXIFGPSDistanceReference : public System.Enum
public enum class ImGearEXIFGPSDistanceReference : public System.Enum
Members
Member | Value | Description
Kilometers | 0 | Kilometers distance reference.
Knots | 2 | Knots distance reference.
Miles | 1 | Miles distance reference.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSDistanceReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSLatitudeReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSLatitudeReference Enumeration
Represents EXIF GPS latitude references.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSLatitudeReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSLatitudeReference
public enum ImGearEXIFGPSLatitudeReference : System.Enum
__value public enum ImGearEXIFGPSLatitudeReference : public System.Enum
public enum class ImGearEXIFGPSLatitudeReference : public System.Enum
Members
Member | Value | Description
North | 0 | North latitude reference.
South | 1 | South latitude reference.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSLatitudeReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSLongitudeReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSLongitudeReference Enumeration
Represents EXIF GPS longitude references.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSLongitudeReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSLongitudeReference
public enum ImGearEXIFGPSLongitudeReference : System.Enum
__value public enum ImGearEXIFGPSLongitudeReference : public System.Enum
public enum class ImGearEXIFGPSLongitudeReference : public System.Enum
Members
Member | Value | Description
East | 0 | East longitude reference.
West | 1 | West longitude reference.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSLongitudeReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSMeasureMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSMeasureMode Enumeration
Represents EXIF GPS measure modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSMeasureMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSMeasureMode
public enum ImGearEXIFGPSMeasureMode : System.Enum
__value public enum ImGearEXIFGPSMeasureMode : public System.Enum
public enum class ImGearEXIFGPSMeasureMode : public System.Enum
Members
Member | Value | Description
Mode2D | 0 | Two-dimensional measurement.
Mode3D | 1 | Three-dimensional measurement.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSMeasureMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSSpeedReference Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSSpeedReference Enumeration
Represents EXIF GPS speed reference modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSSpeedReference
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSSpeedReference
public enum ImGearEXIFGPSSpeedReference : System.Enum
__value public enum ImGearEXIFGPSSpeedReference : public System.Enum
public enum class ImGearEXIFGPSSpeedReference : public System.Enum
Members
Member | Value | Description
KilometersPerHour | 0 | Kilometers per hour.
Knots | 2 | Knots (1.87 km/h).
MilesPerHour | 1 | Miles per hour.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSSpeedReference

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSStatus Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSStatus Enumeration
Represents EXIF GPS statuses.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFGPSStatus
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFGPSStatus
public enum ImGearEXIFGPSStatus : System.Enum
__value public enum ImGearEXIFGPSStatus : public System.Enum
public enum class ImGearEXIFGPSStatus : public System.Enum
Members
Member | Value | Description
InProgress | 0 | Measurement is in progress.
Interoperability | 1 | Measurement is interoperability.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFGPSStatus

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFLightSource Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFLightSource Enumeration
Represents EXIF light sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFLightSource
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFLightSource
public enum ImGearEXIFLightSource : System.Enum
__value public enum ImGearEXIFLightSource : public System.Enum
public enum class ImGearEXIFLightSource : public System.Enum
Members
Member | Value | Description
CloudyWeather | 10 | Cloudy weather.
CoolWhiteFluorescent | 14 | Cool white fluorescent.
D50 | 23 | D50 source.
D55 | 20 | D55 source.
D65 | 21 | D65 source.
D75 | 22 | D75 source.
Daylight | 1 | Daylight source.
DaylightFluorescent | 12 | Daylight fluorescent.
DayWhiteFluorescent | 13 | Day white fluorescent.
FineWeather | 9 | Fine weather.
Flash | 4 | Flash source.
Fluorescent | 2 | Fluorescent source.
ISOStudioTungsten | 24 | ISO studio tungsten.
Other | 255 | Other light source.
Shade | 11 | Shade source.
StandardLightA | 17 | Standard light A.
StandardLightB | 18 | Standard light B.
StandardLightC | 19 | Standard light C.
Tungsten | 3 | Tungsten source.
Unknown | 0 | Unknown light source.
WhiteFluorescent | 15 | White fluorescent.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFLightSource

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFMeteringMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFMeteringMode Enumeration
Represents EXIF Metering Modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFMeteringMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFMeteringMode
public enum ImGearEXIFMeteringMode : System.Enum
__value public enum ImGearEXIFMeteringMode : public System.Enum
public enum class ImGearEXIFMeteringMode : public System.Enum
Members
Member | Value | Description
Average | 1 | Average metering mode.
CenterWeightedAverage | 2 | Center weighted average metering mode.
MultiSpot | 4 | MultiSpot metering mode.
Other | 255 | Other metering mode.
Partial | 6 | Partial metering mode.
Pattern | 5 | Pattern metering mode.
Spot | 3 | Spot metering mode.
Unknown | 0 | Unknown metering mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFMeteringMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSaturationMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSaturationMode Enumeration
Represents EXIF saturation modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSaturationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSaturationMode
public enum ImGearEXIFSaturationMode : System.Enum
__value public enum ImGearEXIFSaturationMode : public System.Enum
public enum class ImGearEXIFSaturationMode : public System.Enum
Members
Member | Value | Description
High | 2 | High saturation mode.
Low | 1 | Low saturation mode.
Normal | 0 | Normal saturation mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSaturationMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSceneCaptureType Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSceneCaptureType Enumeration
Represents EXIF scene capture types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSceneCaptureType
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSceneCaptureType
public enum ImGearEXIFSceneCaptureType : System.Enum
__value public enum ImGearEXIFSceneCaptureType : public System.Enum
public enum class ImGearEXIFSceneCaptureType : public System.Enum
Members
Member | Value | Description
Landscape | 1 | Landscape scene capture type.
NightScene | 3 | Night scene capture type.
Portrait | 2 | Portrait scene capture type.
Standard | 0 | Standard scene capture type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSceneCaptureType

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSceneType Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSceneType Enumeration
Represents EXIF scene types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSceneType
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSceneType
public enum ImGearEXIFSceneType : System.Enum
__value public enum ImGearEXIFSceneType : public System.Enum
public enum class ImGearEXIFSceneType : public System.Enum
Members
Member | Value | Description
DirectlyPhotographedImage | 1 | Directly photographed image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSceneType

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSensingMethod Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSensingMethod Enumeration
Represents EXIF sensing methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSensingMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSensingMethod
public enum ImGearEXIFSensingMethod : System.Enum
__value public enum ImGearEXIFSensingMethod : public System.Enum
public enum class ImGearEXIFSensingMethod : public System.Enum
Members
Member | Value | Description
ColorSequentialAreaSensor | 5 | Color sequential area sensor.
ColorSequentialLinearSensor | 8 | Color sequential linear sensor.
OneChipColorAreaSensor | 2 | One chip color area sensor.
ThreeChipColorAreaSensor | 4 | Three chip color area sensor.
TrilinearSensor | 7 | Trilinear sensor.
TwoChipColorAreaSensor | 3 | Two chip color area sensor.
Undefined | 1 | Undefined sensing method.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSensingMethod

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSharpnessMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSharpnessMode Enumeration
Represents EXIF sharpness modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSharpnessMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSharpnessMode
public enum ImGearEXIFSharpnessMode : System.Enum
__value public enum ImGearEXIFSharpnessMode : public System.Enum
public enum class ImGearEXIFSharpnessMode : public System.Enum
Members
Member | Value | Description
Hard | 2 | Hard mode.
Normal | 0 | Normal mode.
Soft | 1 | Soft mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSharpnessMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFSubjectDistanceRange Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFSubjectDistanceRange Enumeration
Represents EXIF subject distance ranges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFSubjectDistanceRange
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFSubjectDistanceRange
public enum ImGearEXIFSubjectDistanceRange : System.Enum
__value public enum ImGearEXIFSubjectDistanceRange : public System.Enum
public enum class ImGearEXIFSubjectDistanceRange : public System.Enum
Members
Member | Value | Description
CloseView | 2 | Close view.
DistantView | 3 | Distant view.
Macro | 1 | Macro distance.
Unknown | 0 | Unknown distance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFSubjectDistanceRange

See Also

Reference

ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFWhiteBalanceMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFWhiteBalanceMode Enumeration
Represents EXIF white balance modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearEXIFWhiteBalanceMode
   Inherits System.Enum
'Usage

Dim instance As ImGearEXIFWhiteBalanceMode
public enum ImGearEXIFWhiteBalanceMode : System.Enum
__value public enum ImGearEXIFWhiteBalanceMode : public System.Enum
public enum class ImGearEXIFWhiteBalanceMode : public System.Enum
Members
Member | Value | Description
Auto | 0 | Auto mode.
Manual | 1 | Manual mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.EXIF.ImGearEXIFWhiteBalanceMode

See Also

Reference

ImageGear.Formats.EXIF Namespace


ImageGear.Formats.TIF Namespace (ImageGear22.Formats.Common)
Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats.TIF Namespace
This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.
Enumerations
 | Enumeration | Description
Enumeration | ImGearTIFFBitonalPaletteMode | Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
Enumeration | ImGearTIFFCompression | Represents TIFF compressions.
Enumeration | ImGearTIFFFillOrder | Represents TIFF fill orders.
Enumeration | ImGearTIFFNewSubFileTypeMasks | Represents TIFF New Subfile Type masks.
Enumeration | ImGearTIFFOrientation | Represents TIFF orientations.
Enumeration | ImGearTIFFPhotoInterpretation | Represents TIFF photometric interpretations.
Enumeration | ImGearTIFFPlanarConfig | Represents TIFF planar configurations.
Enumeration | ImGearTIFFPredictorType | Represents TIFF predictor types.
Enumeration | ImGearTIFFResolutionUnit | Represents TIFF resolution units.
Enumeration | ImGearTIFFSubFileType | Represents TIFF subfile types.
See Also

Reference

ImageGear22.Formats.Common Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.TIF Namespace (ImageGear22.Formats.Common) Inheritance Hierarchy
ImageGear22.Formats.Common Assembly : ImageGear.Formats.TIF Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ImageGear22.Formats.Common Assembly


%%PageItemTitle%%

ImGearTIFFBitonalPaletteMode Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFBitonalPaletteMode Enumeration
Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFBitonalPaletteMode
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFBitonalPaletteMode
public enum ImGearTIFFBitonalPaletteMode : System.Enum
__value public enum ImGearTIFFBitonalPaletteMode : public System.Enum
public enum class ImGearTIFFBitonalPaletteMode : public System.Enum
Members
Member | Value | Description
FIX | 2 | Fix strange looking palettes, as follows: if (R0+G0+B0)/3 <, (R1+G1+B1)/3 change palette to (black, white). Otherwise, change palette to (white, black). Specifically, constant palettes (all-black, all-white) are replaced with (white, black) palette.
KEEP_AS_IS | 1 | Keep palette as is, even if it is all-black or red-green. If photometric interpretation is PALETTE_COLOR, but COLORMAP tag is absent, assume all-black palette.
LEGACY | 0 | Keep ImageGear 16.0 behavior: read all 1-bit palettes as is. If palette is missing, assume increasing (blackzero) palette.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFBitonalPaletteMode

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFCompression Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFCompression Enumeration
Represents TIFF compressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFCompression
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFCompression
public enum ImGearTIFFCompression : System.Enum
__value public enum ImGearTIFFCompression : public System.Enum
public enum class ImGearTIFFCompression : public System.Enum
Members
Member | Value | Description
ABIC_BW | 0x00008008 | ABIC b/w image.
ABIC_Concatenated | 0x00007D0A | ABIC concatenated image.
ABIC_GRAY | 0x0000800A | ABIC gray image.
ABIC_IOCA | 0x00008009 | ABIC IOCA image.
CCITT_1D | 0x00000002 | CCITT 1D compression.
Deflate | 0x00000008 | Deflate compression.
DeflateObsolete | 0x000080B2 | Legacy constant for Deflate compression.
GROUP_3 | 0x00000003 | CCITT Group 3 compression.
GROUP_4 | 0x00000004 | CCITT Group 4 compression.
JBIG | 0x0000800C | JBIG compression.
JPEG | 0x00000006 | JPEG (using TIFF 6.0 specification).
JPEG_2 | 0x00000007 | JPEG (using TIFF Technical Note 2 specification).
LZW | 0x00000005 | Lempel-Ziv and Welch compression.
Packbits | 0x00008005 | Packed Bits.
Thunderscan | 0x00008029 | Thunderscan RLE compression.
Uncompressed | 0x00000001 | Uncompressed (no compression).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFCompression

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFFillOrder Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFFillOrder Enumeration
Represents TIFF fill orders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFFillOrder
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFFillOrder
public enum ImGearTIFFFillOrder : System.Enum
__value public enum ImGearTIFFFillOrder : public System.Enum
public enum class ImGearTIFFFillOrder : public System.Enum
Members
Member | Value | Description
LeastSignificantBitFirst | 2 | Pixels are arranged within a byte such that pixels with lower column values are stored in the lower-order bits of the byte.
MostSignificantBitFirst | 1 | Pixels are arranged within a byte such that pixels with lower column values are stored in the higher-order bits of the byte.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFFillOrder

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFNewSubFileTypeMasks Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFNewSubFileTypeMasks Enumeration
Represents TIFF New Subfile Type masks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFNewSubFileTypeMasks
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFNewSubFileTypeMasks
public enum ImGearTIFFNewSubFileTypeMasks : System.Enum
__value public enum ImGearTIFFNewSubFileTypeMasks : public System.Enum
public enum class ImGearTIFFNewSubFileTypeMasks : public System.Enum
Members
Member | Value | Description
Alpha | 0x00000004 | The image defines a transparency mask for another image in this TIFF file.
PageOfMultipageImage | 0x00000002 | The image is a single page of a multi-page image.
Thumbnail | 0x00000001 | The image is a reduced-resolution version of another image in this TIFF file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFNewSubFileTypeMasks

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFOrientation Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFOrientation Enumeration
Represents TIFF orientations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFOrientation
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFOrientation
public enum ImGearTIFFOrientation : System.Enum
__value public enum ImGearTIFFOrientation : public System.Enum
public enum class ImGearTIFFOrientation : public System.Enum
Members
Member | Value | Description
BottomLeft | 4 | The 0th row represents the visual bottom of the image, and the 0th column represents the visual left-hand side.
BottomRight | 3 | The 0th row represents the visual bottom of the image, and the 0th column represents the visual right-hand side.
LeftBottom | 8 | The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual bottom.
LeftTop | 5 | The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual top.
RightBottom | 7 | The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual bottom.
RightTop | 6 | The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual top.
TopLeft | 1 | The 0th row represents the visual top of the image, and the 0th column represents the visual left-hand side.
TopRight | 2 | The 0th row represents the visual top of the image, and the 0th column represents the visual right-hand side.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFOrientation

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFPhotoInterpretation Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFPhotoInterpretation Enumeration
Represents TIFF photometric interpretations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFPhotoInterpretation
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFPhotoInterpretation
public enum ImGearTIFFPhotoInterpretation : System.Enum
__value public enum ImGearTIFFPhotoInterpretation : public System.Enum
public enum class ImGearTIFFPhotoInterpretation : public System.Enum
Members
Member | Value | Description
Blackzero | 1 | Black is zero. For bilevel and grayscale images: 0 is imaged as black. 2**BitsPerSample-1 is imaged as white.
CFA | 32803 | Color Filter Array.
CIELab | 8 | CIE Lab (using TIFF format for storing a and b values).
CMYK | 5 | CMYK photometric interpretation.
ICC_CIELab | 9 | CIE Lab (using ICC format for storing a and b values).
Palette | 3 | Palette color.
RGB | 2 | RGB photometric interpretation.
Transparency | 4 | Transparency photometric interpretation.
Whitezero | 0 | White is zero. For bilevel and grayscale images: 0 is imaged as white. 2**BitsPerSample-1 is imaged as black.
YCbCb | 6 | YCbCr photometric interpretation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFPhotoInterpretation

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFPlanarConfig Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFPlanarConfig Enumeration
Represents TIFF planar configurations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFPlanarConfig
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFPlanarConfig
public enum ImGearTIFFPlanarConfig : System.Enum
__value public enum ImGearTIFFPlanarConfig : public System.Enum
public enum class ImGearTIFFPlanarConfig : public System.Enum
Members
Member | Value | Description
Chunky | 1 | Chunky format. The component values for each pixel are stored contiguously.
Planar | 2 | Planar format. The components are stored in separate "component planes".
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFPlanarConfig

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFPredictorType Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFPredictorType Enumeration
Represents TIFF predictor types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFPredictorType
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFPredictorType
public enum ImGearTIFFPredictorType : System.Enum
__value public enum ImGearTIFFPredictorType : public System.Enum
public enum class ImGearTIFFPredictorType : public System.Enum
Members
Member | Value | Description
HORIZ_DIFF | 2 | Horizontal differencing.
NONE | 1 | No prediction scheme used before coding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFPredictorType

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFResolutionUnit Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFResolutionUnit Enumeration
Represents TIFF resolution units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFResolutionUnit
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFResolutionUnit
public enum ImGearTIFFResolutionUnit : System.Enum
__value public enum ImGearTIFFResolutionUnit : public System.Enum
public enum class ImGearTIFFResolutionUnit : public System.Enum
Members
Member | Value | Description
Centimeter | 3 | Centimeter resolution unit.
Inch | 2 | Inch resolution unit.
NoAbsoluteUnit | 1 | No absolute unit of measurement. Used for images that may have a non-square aspect ratio but no meaningful absolute dimensions.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFResolutionUnit

See Also

Reference

ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFSubFileType Enumeration

ImageGear22.Formats.Common Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFSubFileType Enumeration
Represents TIFF subfile types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearTIFFSubFileType
   Inherits System.Enum
'Usage

Dim instance As ImGearTIFFSubFileType
public enum ImGearTIFFSubFileType : System.Enum
__value public enum ImGearTIFFSubFileType : public System.Enum
public enum class ImGearTIFFSubFileType : public System.Enum
Members
Member | Value | Description
FullResolutionImage | 1 | Full resolution image.
PageOfMultipageImage | 3 | Page of a multipage image.
Thumbnail | 2 | Thumbnail type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.TIF.ImGearTIFFSubFileType

See Also

Reference

ImageGear.Formats.TIF Namespace


ImageGear22.Formats.Dicom Assembly
Namespaces
Namespace | Description
ImageGear.Core | The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit.
ImageGear.Formats.DICOM | ImageGear.Formats.DICOM namespace provides features that are used with medical and DICOM images. This chapter provides you with ImageGear.Formats.DICOM namespace API reference.


ImageGear.Core Namespace (ImageGear22.Formats.Dicom)
Inheritance Hierarchy
ImageGear22.Formats.Dicom Assembly : ImageGear.Core Namespace
The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit.
Classes
 | Class | Description
Class | ImGearDICOMMetadataDictRecord | Represents basic information about DICOM Data Element.
See Also

Reference

ImageGear22.Formats.Dicom Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Core Namespace (ImageGear22.Formats.Dicom) Inheritance Hierarchy
ImageGear22.Formats.Dicom Assembly : ImageGear.Core Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearDICOMMetadataDictRecord
See Also

Reference

ImageGear22.Formats.Dicom Assembly


%%PageItemTitle%%

ImGearDICOMMetadataDictRecord Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace : ImGearDICOMMetadataDictRecord Class
Represents basic information about DICOM Data Element.
Object Model
ImGearDICOMMetadataDictRecord Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDICOMMetadataDictRecord
   Implements IImGearMetadataDictRecord
'Usage

Dim instance As ImGearDICOMMetadataDictRecord
public class ImGearDICOMMetadataDictRecord : IImGearMetadataDictRecord
public __gc class ImGearDICOMMetadataDictRecord : public IImGearMetadataDictRecord
public ref class ImGearDICOMMetadataDictRecord : public IImGearMetadataDictRecord
Remarks
See PS 3.6 2008, Registry of DICOM data elements table. The names of properties are equivalents to corresponding columns of the table.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDICOMMetadataDictRecord

See Also

Reference

ImGearDICOMMetadataDictRecord Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearDICOMMetadataDictRecord Class Members
Fields Properties

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace : ImGearDICOMMetadataDictRecord Class

The following tables list the members exposed by ImGearDICOMMetadataDictRecord.

Public Constructors
 | Name | Description
Public Constructor | ImGearDICOMMetadataDictRecord Constructor | Initializes a new instance of the ImGearDICOMMetadataDictRecord class object.
Top
Public Fields
 | Name | Description
Public Field | MaxMultiplicity | Provides access to max value multiplicity.
Public Field | ValueRepresentation | Provides access to value representation.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets DICOM tag name.
Public Property | Tag | Gets or sets DICOM tag ID.
Top
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearDICOMMetadataDictRecord Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace > ImGearDICOMMetadataDictRecord Class : ImGearDICOMMetadataDictRecord Constructor
DICOM tag ID.
DICM tag name.
Value representation.
Maximal value multiplicity.
Initializes a new instance of the ImGearDICOMMetadataDictRecord class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As Integer, _
   ByVal name As String, _
   ByVal valueRepresentation As ImGearDICOMValueRepresentations, _
   ByVal maxValueMultiplicity As Integer _
)
'Usage

Dim tag As Integer
Dim name As String
Dim valueRepresentation As ImGearDICOMValueRepresentations
Dim maxValueMultiplicity As Integer

Dim instance As New ImGearDICOMMetadataDictRecord(tag, name, valueRepresentation, maxValueMultiplicity)
public ImGearDICOMMetadataDictRecord(
   int tag,
   string name,
   ImGearDICOMValueRepresentations valueRepresentation,
   int maxValueMultiplicity
)
public: ImGearDICOMMetadataDictRecord(
   int tag,
   string* name,
   ImGearDICOMValueRepresentations valueRepresentation,
   int maxValueMultiplicity
)
public:
ImGearDICOMMetadataDictRecord(
   int tag,
   String^ name,
   ImGearDICOMValueRepresentations valueRepresentation,
   int maxValueMultiplicity
)

Parameters

tag
DICOM tag ID.
name
DICM tag name.
valueRepresentation
Value representation.
maxValueMultiplicity
Maximal value multiplicity.
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%% $$Properties$$

ImGearDICOMMetadataDictRecord Class Properties

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace : ImGearDICOMMetadataDictRecord Class

For a list of all members of this type, see ImGearDICOMMetadataDictRecord members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets DICOM tag name.
Public Property | Tag | Gets or sets DICOM tag ID.
Top
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImageGear.Core Namespace


Name Property (ImGearDICOMMetadataDictRecord)

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace > ImGearDICOMMetadataDictRecord Class : Name Property
Gets or sets DICOM tag name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearDICOMMetadataDictRecord
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string value.
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


Tag Property (ImGearDICOMMetadataDictRecord)

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace > ImGearDICOMMetadataDictRecord Class : Tag Property
Gets or sets DICOM tag ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tag As Integer
'Usage

Dim instance As ImGearDICOMMetadataDictRecord
Dim value As Integer

instance.Tag = value

value = instance.Tag
public int Tag {get; set;}
public: __property int get_Tag();
public: __property void set_Tag(
   int value
);
public:
property int Tag {
   int get();
   void set (    int value);
}

Property Value

Any valid DICOM tag ID.
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%% $$Fields$$

ImGearDICOMMetadataDictRecord Class Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace : ImGearDICOMMetadataDictRecord Class

For a list of all members of this type, see ImGearDICOMMetadataDictRecord members.

Public Fields
 | Name | Description
Public Field | MaxMultiplicity | Provides access to max value multiplicity.
Public Field | ValueRepresentation | Provides access to value representation.
Top
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImageGear.Core Namespace


MaxMultiplicity Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace > ImGearDICOMMetadataDictRecord Class : MaxMultiplicity Field
Provides access to max value multiplicity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxMultiplicity As Integer
'Usage

Dim instance As ImGearDICOMMetadataDictRecord
Dim value As Integer

value = instance.MaxMultiplicity

instance.MaxMultiplicity = value
public int MaxMultiplicity
public: int MaxMultiplicity
public:
int MaxMultiplicity
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


ValueRepresentation Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Core Namespace > ImGearDICOMMetadataDictRecord Class : ValueRepresentation Field
Provides access to value representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ValueRepresentation As ImGearDICOMValueRepresentations
'Usage

Dim instance As ImGearDICOMMetadataDictRecord
Dim value As ImGearDICOMValueRepresentations

value = instance.ValueRepresentation

instance.ValueRepresentation = value
public ImGearDICOMValueRepresentations ValueRepresentation
public: ImGearDICOMValueRepresentations ValueRepresentation
public:
ImGearDICOMValueRepresentations ValueRepresentation
See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


ImageGear.Formats.DICOM Namespace
Inheritance Hierarchy
ImageGear22.Formats.Dicom Assembly : ImageGear.Formats.DICOM Namespace
ImageGear.Formats.DICOM namespace provides features that are used with medical and DICOM images. This chapter provides you with ImageGear.Formats.DICOM namespace API reference.
Classes
 | Class | Description
Class | ImGearDICOM | Provides DICOM specific features, such as DICOM Presentation State support.
Class | ImGearDICOMDisplaySettings | Provides the means to display medical images with proper contrast.
Class | ImGearModalityTransform | Implements DICOM Modality transform.
Class | ImGearMprProcessor | Provides Multi-planar reconstruction features.
Class | ImGearVOITransform | Implements DICOM Value Of Interest (VOI) transform.
Structures
 | Structure | Description
Structure | ImGearLinearTransform | Encapsulates coefficients for a linear floating-point one-dimensional transform.
Structure | ImGearPresStateOptions | Encapsulates options for loading and saving presentation state objects.
Structure | ImGearVOIWindow | Encapsulates linear DICOM VOI transform.
Enumerations
 | Enumeration | Description
Enumeration | ImGearDICOMPhotoInterpretations | Specifies DICOM Photometric Interpretations.
Enumeration | ImGearDICOMPixelRepresenations | Specifies DICOM Pixel Representations.
Enumeration | ImGearDICOMPlanarConfigurations | Specifies DICOM Planar Configurations.
Enumeration | ImGearDICOMServiceObjectPairs | Specifies DICOM Service Object Pair (SOP) constants.
Enumeration | ImGearDICOMTagsIDs | Specifies DICOM tag identifiers.
Enumeration | ImGearDICOMTransferSyntaxes | Specifies DICOM Transfer Syntaxes.
Enumeration | ImGearDICOMValueRepresentations | Specifies DICOM Value Representations.
Enumeration | ImGearMprViewType | Represents types of the MPR view.
Enumeration | ImGearPseudocolorSchemes | Specifies predefined pseudocoloring schemes.
See Also

Reference

ImageGear22.Formats.Dicom Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.DICOM Namespace Inheritance Hierarchy
ImageGear22.Formats.Dicom Assembly : ImageGear.Formats.DICOM Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.DICOM.ImGearDICOM
ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings
ImageGear.Formats.DICOM.ImGearModalityTransform
ImageGear.Formats.DICOM.ImGearMprProcessor
ImageGear.Formats.DICOM.ImGearVOITransform
System.ValueType
ImageGear.Formats.DICOM.ImGearLinearTransform
ImageGear.Formats.DICOM.ImGearPresStateOptions
ImageGear.Formats.DICOM.ImGearVOIWindow
See Also

Reference

ImageGear22.Formats.Dicom Assembly


%%PageItemTitle%%

ImGearDICOM Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOM Class
Provides DICOM specific features, such as DICOM Presentation State support.
Object Model
ImGearDICOM ClassImGearFullLUT ClassIImGearFormat InterfaceImGearARTPage ClassImGearMetadataHead ClassImGearMetadataHead Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearDICOM
'Usage

Dim instance As ImGearDICOM
public sealed class ImGearDICOM
public __gc __sealed class ImGearDICOM
public ref class ImGearDICOM sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.DICOM.ImGearDICOM

See Also

Reference

ImGearDICOM Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearDICOM Class Members
Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOM Class

The following tables list the members exposed by ImGearDICOM.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BuildColorLimitsLUT | Builds a LUT that highlights image extremes.
static (Shared in Visual Basic) | BuildPseudocolorLUT | Builds a pseudocolor LUT.
static (Shared in Visual Basic) | BuildStandardDisplayLUT | Builds Standard Display LUT.
static (Shared in Visual Basic) | CreateDICOMFormat | Creates an instance of DICOM format.
static (Shared in Visual Basic) | LoadOverlay | Overloaded. Loads overlay planes from DICOM metadata
static (Shared in Visual Basic) | LoadPresState | Loads Presentation State object and applies it to an image.
static (Shared in Visual Basic) | PreparePresStateMetadata | Prepares Presentation State metadata based on current image display settings and annotations.
static (Shared in Visual Basic) | SaveOverlay | Saves ART marks into DICOM dataset as overlay planes.
static (Shared in Visual Basic) | SavePresState | Saves Presentation State metadata to a Presentation State object.
Top
See Also

Reference

ImGearDICOM Class
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Methods$$

ImGearDICOM Class Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOM Class

For a list of all members of this type, see ImGearDICOM members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BuildColorLimitsLUT | Builds a LUT that highlights image extremes.
static (Shared in Visual Basic) | BuildPseudocolorLUT | Builds a pseudocolor LUT.
static (Shared in Visual Basic) | BuildStandardDisplayLUT | Builds Standard Display LUT.
static (Shared in Visual Basic) | CreateDICOMFormat | Creates an instance of DICOM format.
static (Shared in Visual Basic) | LoadOverlay | Overloaded. Loads overlay planes from DICOM metadata
static (Shared in Visual Basic) | LoadPresState | Loads Presentation State object and applies it to an image.
static (Shared in Visual Basic) | PreparePresStateMetadata | Prepares Presentation State metadata based on current image display settings and annotations.
static (Shared in Visual Basic) | SaveOverlay | Saves ART marks into DICOM dataset as overlay planes.
static (Shared in Visual Basic) | SavePresState | Saves Presentation State metadata to a Presentation State object.
Top
See Also

Reference

ImGearDICOM Class
ImageGear.Formats.DICOM Namespace


BuildColorLimitsLUT Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : BuildColorLimitsLUT Method
Lower pixel value limit. All pixels at or below this value will be pseudocolored.
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or smaller than lowThreshold.
Higher pixel value limit. All pixels at or above this value will be pseudocolored.
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or greater than highThreshold.
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.
Builds a LUT that highlights image extremes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub BuildColorLimitsLUT( _
   ByVal lowThreshold As Integer, _
   ByVal lowFillColor As ImGearPixel, _
   ByVal highThreshold As Integer, _
   ByVal highFillColor As ImGearPixel, _
   ByVal lookupTable As ImGearRGBLUT _
)
'Usage

Dim lowThreshold As Integer
Dim lowFillColor As ImGearPixel
Dim highThreshold As Integer
Dim highFillColor As ImGearPixel
Dim lookupTable As ImGearRGBLUT

ImGearDICOM.BuildColorLimitsLUT(lowThreshold, lowFillColor, highThreshold, highFillColor, lookupTable)
public static void BuildColorLimitsLUT(
   int lowThreshold,
   ImGearPixel lowFillColor,
   int highThreshold,
   ImGearPixel highFillColor,
   ImGearRGBLUT lookupTable
)
public: static void BuildColorLimitsLUT(
   int lowThreshold,
   ImGearPixel* lowFillColor,
   int highThreshold,
   ImGearPixel* highFillColor,
   ImGearRGBLUT* lookupTable
)
public:
static void BuildColorLimitsLUT(
   int lowThreshold,
   ImGearPixel^ lowFillColor,
   int highThreshold,
   ImGearPixel^ highFillColor,
   ImGearRGBLUT^ lookupTable
)

Parameters

lowThreshold
Lower pixel value limit. All pixels at or below this value will be pseudocolored.
lowFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or smaller than lowThreshold.
highThreshold
Higher pixel value limit. All pixels at or above this value will be pseudocolored.
highFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or greater than highThreshold.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.
Remarks
This method fills the lookup table (LUT) so that it highlights the brightest and darkest pixels in a grayscale image. Use this method to initialize ImageGear.Display.ImGearPageDisplay.LUT property. This is typically used to clearly see pixel values that are over-saturated (255 and up) or under-saturated (0 and below). However, this method lets you to customize the settings for the upper and lower pixel value limits with lowThreshold and highThreshold.

ImageGear.Display.ImGearPageDisplay.LUT property is used on the last stage of display processing, after that all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

Example
  • C#
ImGearPageDisplay pageDisplay = igPageView.Display;
// Highlight low values with blue
ImGearPixel lowColor = new ImGearPixel(3, 8);
lowColor[0] = 0;
lowColor[1] = 0;
lowColor[2] = 255;
// Highlight high values with red
ImGearPixel highColor = new ImGearPixel(3, 8);
highColor[0] = 255;
highColor[1] = 0;
highColor[2] = 0;
ImGearRGBLUT LUT = new ImGearRGBLUT(8, 8);
ImGearContrastSettings contrastSettings = ImGearContrastSettings.CreateDefault();
ImGearDICOM.BuildColorLimitsLUT(0, lowColor, 255, highColor, LUT);
pageDisplay.UpdateLUT(LUT, contrastSettings);
  • Visual Basic
Dim pageDisplay As ImGearPageDisplay = igPageView.Display
' Highlight low values with blue
Dim lowColor As ImGearPixel = New ImGearPixel(3, 8)
lowColor(0) = 0
lowColor(1) = 0
lowColor(2) = 255
' Highlight high values with red
Dim highColor As ImGearPixel = New ImGearPixel(3, 8)
highColor(0) = 255
highColor(1) = 0
highColor(2) = 0
Dim LUT As ImGearRGBLUT = New ImGearRGBLUT(8, 8)
Dim contrastSettings As ImGearContrastSettings = ImGearContrastSettings.CreateDefault()
ImGearDICOM.BuildColorLimitsLUT(0, lowColor, 255, highColor, LUT)
pageDisplay.UpdateLUT(LUT, contrastSettings)
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearPixel Class
ImGearRGBLUT Class


BuildPseudocolorLUT Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : BuildPseudocolorLUT Method
Predefined pseudocoloring scheme.
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.
Builds a pseudocolor LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub BuildPseudocolorLUT( _
   ByVal scheme As ImGearPseudocolorSchemes, _
   ByVal lookupTable As ImGearRGBLUT _
)
'Usage

Dim scheme As ImGearPseudocolorSchemes
Dim lookupTable As ImGearRGBLUT

ImGearDICOM.BuildPseudocolorLUT(scheme, lookupTable)
public static void BuildPseudocolorLUT(
   ImGearPseudocolorSchemes scheme,
   ImGearRGBLUT lookupTable
)
public: static void BuildPseudocolorLUT(
   ImGearPseudocolorSchemes scheme,
   ImGearRGBLUT* lookupTable
)
public:
static void BuildPseudocolorLUT(
   ImGearPseudocolorSchemes scheme,
   ImGearRGBLUT^ lookupTable
)

Parameters

scheme
Predefined pseudocoloring scheme.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.
Remarks
This method fills a lookup table (LUT) according to one of the predefined 24-bit RGB to 24-bit RGB pseudocoloring schemes. Use this method to initialize ImageGear.Display.ImGearPageDisplay.LUT property.

ImageGear.Display.ImGearPageDisplay.LUT property is used on the last stage of display processing, when all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

Example
  • C#
ImGearPageDisplay pageDisplay = igPageView.Display;
ImGearContrastSettings contrastSettings = ImGearContrastSettings.CreateDefault();
ImGearRGBLUT LUT = new ImGearRGBLUT(8, 8);
ImGearDICOM.BuildPseudocolorLUT(ImGearPseudocolorSchemes.OilFilm, LUT);
pageDisplay.UpdateLUT(LUT, contrastSettings);
  • Visual Basic
Dim pageDisplay As ImGearPageDisplay = igPageView.Display
Dim contrastSettings As ImGearContrastSettings = ImGearContrastSettings.CreateDefault()
Dim LUT As ImGearRGBLUT = New ImGearRGBLUT(8, 8)
ImGearDICOM.BuildPseudocolorLUT(ImGearPseudocolorSchemes.OilFilm, LUT)
pageDisplay.UpdateLUT(LUT, contrastSettings)
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearRGBLUT Class
ImGearPseudocolorSchemes Enumeration


BuildStandardDisplayLUT Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : BuildStandardDisplayLUT Method
Input depth of the LUT. inputDepth = 12 is the typical value, sufficient for most medical images.
Output depth of the LUT. Set to 8 for a monitor that can display 256 shades of gray.
Characteristic curve of the display device.
Builds Standard Display LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function BuildStandardDisplayLUT( _
   ByVal inputDepth As Integer, _
   ByVal outputDepth As Integer, _
   ByVal characteristicCurve() As Double _
) As ImGearFullLUT
'Usage

Dim inputDepth As Integer
Dim outputDepth As Integer
Dim characteristicCurve() As Double
Dim value As ImGearFullLUT

value = ImGearDICOM.BuildStandardDisplayLUT(inputDepth, outputDepth, characteristicCurve)
public static ImGearFullLUT BuildStandardDisplayLUT(
   int inputDepth,
   int outputDepth,
   double[] characteristicCurve
)
public: static ImGearFullLUT* BuildStandardDisplayLUT(
   int inputDepth,
   int outputDepth,
   double[]* characteristicCurve
)
public:
static ImGearFullLUT^ BuildStandardDisplayLUT(
   int inputDepth,
   int outputDepth,
   array<double>^ characteristicCurve
)

Parameters

inputDepth
Input depth of the LUT. inputDepth = 12 is the typical value, sufficient for most medical images.
outputDepth
Output depth of the LUT. Set to 8 for a monitor that can display 256 shades of gray.
characteristicCurve
Characteristic curve of the display device.

Return Value

New instance of ImageGear.Core.ImGearFullLUT class object, containing the Standard Display LUT, based on the provided characteristic curve.
Remarks
This method builds a lookup table that maps pixel intensities from DICOM Presentation space (P-Values) into pixel intensities of the display device. Use this lookup table to initialize ImGearDICOMDisplaySettings class.

The source data for this method is a characteristic curve - an array that lists luminosities of display device corresponding to each pixel intensity.

Example
  • C#
double[] characteristicCurve = new double[] { };
// Fill characteristic curve, e.g. load from a file
ImGearFullLUT stdLUT = ImGearDICOM.BuildStandardDisplayLUT(12, 8, characteristicCurve);
  • Visual Basic
Dim characteristicCurve As Double() = New Double() {}
' Fill characteristic curve, e.g. load from a file
Dim stdLUT As ImGearFullLUT = ImGearDICOM.BuildStandardDisplayLUT(12, 8, characteristicCurve)
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearFullLUT Class


CreateDICOMFormat Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : CreateDICOMFormat Method
Creates an instance of DICOM format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateDICOMFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearDICOM.CreateDICOMFormat()
public static IImGearFormat CreateDICOMFormat()
public: static IImGearFormat* CreateDICOMFormat();
public:
static IImGearFormat^ CreateDICOMFormat();

Return Value

An instance of DICOM format.
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
IImGearFormat Interface


LoadOverlay Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : LoadOverlay Method
Loads overlay planes from DICOM metadata
Overload List
Overload | Description
LoadOverlay(ImGearPage) | Loads overlay planes from DICOM metadata of the specified page.
LoadOverlay(ImGearPage,Boolean) | Loads overlay planes from DICOM metadata of the specified page, taking into account useLegacyMarks flag.
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


LoadOverlay(ImGearPage) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class > LoadOverlay Method : LoadOverlay(ImGearPage) Method
Page from which to load overlay planes.
Loads overlay planes from DICOM metadata of the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadOverlay( _
   ByVal source As ImGearPage _
) As ImGearARTPage
'Usage

Dim source As ImGearPage
Dim value As ImGearARTPage

value = ImGearDICOM.LoadOverlay(source)
public static ImGearARTPage LoadOverlay(
   ImGearPage source
)
public: static ImGearARTPage* LoadOverlay(
   ImGearPage* source
)
public:
static ImGearARTPage^ LoadOverlay(
   ImGearPage^ source
)

Parameters

source
Page from which to load overlay planes.

Return Value

New ImageGear.ART.ImGearARTPage class with annotations loaded from overlay.
Remarks
Loads overlay planes from DICOM metadata (DataSet), attached to the image, and creates ART marks of type ImageGear.ART.ImGearARTImageEmb class for each overlay plane. Each mark is placed in a separate ART group.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet. By default ImageGear uses yellow color to display overlays. The application can change overlay color by going through all marks in the ImageGear.ART.ImGearARTPage class and changing palette of ImageGear.ART.ImGearARTImageEmb class marks.

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
Overload List
ImGearRasterPage Class
ImGearARTPage Class
ImGearARTImageEmb Class


LoadOverlay(ImGearPage,Boolean) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class > LoadOverlay Method : LoadOverlay(ImGearPage,Boolean) Method
Page from which to load overlay planes.
Specifies whether to create overlays using legacy ImageGear.ART.ImGearARTImageEmb or new ImageGear.ART.ImGearARTImage mark. As far as in ImageGear for Silverlight ImageGear.ART.ImGearARTImageEmb mark is not available, this parameter in case of Silverlighr framework must be false, otherwise ImageGear.Core.ImGearException will be thrown, indicating wrong usage.
Loads overlay planes from DICOM metadata of the specified page, taking into account useLegacyMarks flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadOverlay( _
   ByVal source As ImGearPage, _
   ByVal useLegacyMarks As Boolean _
) As ImGearARTPage
'Usage

Dim source As ImGearPage
Dim useLegacyMarks As Boolean
Dim value As ImGearARTPage

value = ImGearDICOM.LoadOverlay(source, useLegacyMarks)
public static ImGearARTPage LoadOverlay(
   ImGearPage source,
   bool useLegacyMarks
)
public: static ImGearARTPage* LoadOverlay(
   ImGearPage* source,
   bool useLegacyMarks
)
public:
static ImGearARTPage^ LoadOverlay(
   ImGearPage^ source,
   bool useLegacyMarks
)

Parameters

source
Page from which to load overlay planes.
useLegacyMarks
Specifies whether to create overlays using legacy ImageGear.ART.ImGearARTImageEmb or new ImageGear.ART.ImGearARTImage mark. As far as in ImageGear for Silverlight ImageGear.ART.ImGearARTImageEmb mark is not available, this parameter in case of Silverlighr framework must be false, otherwise ImageGear.Core.ImGearException will be thrown, indicating wrong usage.

Return Value

New ImageGear.ART.ImGearARTPage class with annotations loaded from overlay data.
Remarks
Loads overlay planes from DICOM metadata (DataSet), attached to the image, and creates ART marks of type either ImageGear.ART.ImGearARTImage or ImageGear.ART.ImGearARTImageEmb class for each overlay plane. Each mark is placed in a separate ART group.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet. By default ImageGear uses yellow color to display overlays. The application can change overlay color by going through all marks in the ImageGear.ART.ImGearARTPage class and changing palette of either ImageGear.ART.ImGearARTImage or ImageGear.ART.ImGearARTImageEmb class marks.

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
Overload List
ImGearRasterPage Class
ImGearARTPage Class
ImGearARTImage Class
ImGearARTImageEmb Class


LoadPresState Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : LoadPresState Method
Stream, containing presentation state object.
Page to apply Presentation State to.
PageDisplay to apply Presentation State to.
Options structure, tells which settings need to be applied.
Loads Presentation State object and applies it to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function LoadPresState( _
   ByVal stream As Stream, _
   ByVal page As ImGearRasterPage, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal options As ImGearPresStateOptions _
) As ImGearMetadataHead
'Usage

Dim stream As Stream
Dim page As ImGearRasterPage
Dim pageDisplay As IImGearPageDisplay
Dim options As ImGearPresStateOptions
Dim value As ImGearMetadataHead

value = ImGearDICOM.LoadPresState(stream, page, pageDisplay, options)
public static ImGearMetadataHead LoadPresState(
   Stream stream,
   ImGearRasterPage page,
   IImGearPageDisplay pageDisplay,
   ImGearPresStateOptions options
)
public: static ImGearMetadataHead* LoadPresState(
   Stream* stream,
   ImGearRasterPage* page,
   IImGearPageDisplay* pageDisplay,
   ImGearPresStateOptions options
)
public:
static ImGearMetadataHead^ LoadPresState(
   Stream^ stream,
   ImGearRasterPage^ page,
   IImGearPageDisplay^ pageDisplay,
   ImGearPresStateOptions options
)

Parameters

stream
Stream, containing presentation state object.
page
Page to apply Presentation State to.
pageDisplay
PageDisplay to apply Presentation State to.
options
Options structure, tells which settings need to be applied.

Return Value

New instance of ImageGear.Core.ImGearMetadataHead class object, containing metadata loaded from the Presentation State object.
Remarks
This method loads Presentation State object from a stream and applies settings, found in this object, to the page and to the pageDisplay. Specifically:
  • Adjusts page's ImGearDICOMDisplaySettings class member using VOI, Modality and Presentation LUTs, found in the Presentation State DataSet.
  • Sets image rectangle and orientation of the pageDisplay;
  • Adds annotation objects to the pageDisplay.

All previous settings and annotations of the page and pageDisplay are discarded.

This method also returns all metadata found in the Presentation State object.

Example
  • C#
ImGearMetadataHead presStateOrigMetadata;
using (FileStream fileContent = new FileStream(fileName, FileMode.Open))
{
    ImGearPresStateOptions opts = new ImGearPresStateOptions();
    presStateOrigMetadata =
        ImGearDICOM.LoadPresState(fileContent, (ImGearRasterPage)igPage, igPageView.Display, opts);
}
  • Visual Basic
Dim presStateOrigMetadata As ImGearMetadataHead
Using fileContent = New FileStream(fileName, FileMode.Open)
    Dim opts As ImGearPresStateOptions = New ImGearPresStateOptions()
    presStateOrigMetadata = ImGearDICOM.LoadPresState(fileContent, igPage, igPageView.Display, opts)
End Using
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearRasterPage Class
ImGearPresStateOptions Structure
IImGearPageDisplay Interface


PreparePresStateMetadata Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : PreparePresStateMetadata Method
Page from which presentation state settings shall be extracted.
PageDisplay from which presentation state settings shall be extracted.
User supplied metadata.
Options structure telling which settings shall be extracted to the presentation state metadata.
Prepares Presentation State metadata based on current image display settings and annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function PreparePresStateMetadata( _
   ByVal page As ImGearRasterPage, _
   ByVal pageDisplay As IImGearPageDisplay, _
   ByVal userMetadata As ImGearMetadataHead, _
   ByVal options As ImGearPresStateOptions _
) As ImGearMetadataHead
'Usage

Dim page As ImGearRasterPage
Dim pageDisplay As IImGearPageDisplay
Dim userMetadata As ImGearMetadataHead
Dim options As ImGearPresStateOptions
Dim value As ImGearMetadataHead

value = ImGearDICOM.PreparePresStateMetadata(page, pageDisplay, userMetadata, options)
public static ImGearMetadataHead PreparePresStateMetadata(
   ImGearRasterPage page,
   IImGearPageDisplay pageDisplay,
   ImGearMetadataHead userMetadata,
   ImGearPresStateOptions options
)
public: static ImGearMetadataHead* PreparePresStateMetadata(
   ImGearRasterPage* page,
   IImGearPageDisplay* pageDisplay,
   ImGearMetadataHead* userMetadata,
   ImGearPresStateOptions options
)
public:
static ImGearMetadataHead^ PreparePresStateMetadata(
   ImGearRasterPage^ page,
   IImGearPageDisplay^ pageDisplay,
   ImGearMetadataHead^ userMetadata,
   ImGearPresStateOptions options
)

Parameters

page
Page from which presentation state settings shall be extracted.
pageDisplay
PageDisplay from which presentation state settings shall be extracted.
userMetadata
User supplied metadata.
options
Options structure telling which settings shall be extracted to the presentation state metadata.

Return Value

New instance of ImageGear.Core.ImGearMetadataTree class object, containing presentation state metadata.
Remarks
This method prepares metadata for a presentation state object, based on page's DICOMDisplaySettings member, on pageDisplay settings, and on annotations that are attached to image, if any.

After that presentation state metadata has been prepared, application may add or edit it, and then save as presentation state object using SavePresState method.

The following features of the ImGearDICOMDisplaySettings class are saved to presentation state metadata:

  • VOI LUT
  • Modality LUT
  • Presentation LUT

The following settings of pageDisplay are saved to presentation state metadata:

  • Orientation
  • Image rectangle

The following annotations are saved to saved to presentation state metadata: Text, Callout, Polygon, Polyline, Point, Curve, Ellipse.

This method takes user metadata as a parameter. If this parameter is not null and contains a DICOM metadata tree, the method will use it as a base for building output metadata.

Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
ImGearPresStateOptions opt = new ImGearPresStateOptions();
ImGearMetadataHead prepPresStateMetadata =
    ImGearDICOM.PreparePresStateMetadata(
        rasterPage, igPageView.Display, presStateOrigMetadata, opt);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim opt As ImGearPresStateOptions = New ImGearPresStateOptions()
Dim prepPresStateMetadata As ImGearMetadataHead = ImGearDICOM.PreparePresStateMetadata(rasterPage, igPageView.Display, presStateOrigMetadata, opt)
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearRasterPage Class
ImGearMetadataHead Class
ImGearPresStateOptions Structure
ImGearPageDisplay Class
ImGearMetadataTree Class


SaveOverlay Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : SaveOverlay Method
ART page with marks to save to overlay.
Page to which to save annotations.
Saves ART marks into DICOM dataset as overlay planes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SaveOverlay( _
   ByVal artPage As ImGearARTPage, _
   ByVal page As ImGearRasterPage _
)
'Usage

Dim artPage As ImGearARTPage
Dim page As ImGearRasterPage

ImGearDICOM.SaveOverlay(artPage, page)
public static void SaveOverlay(
   ImGearARTPage artPage,
   ImGearRasterPage page
)
public: static void SaveOverlay(
   ImGearARTPage* artPage,
   ImGearRasterPage* page
)
public:
static void SaveOverlay(
   ImGearARTPage^ artPage,
   ImGearRasterPage^ page
)

Parameters

artPage
ART page with marks to save to overlay.
page
Page to which to save annotations.
Remarks
Each ART group is saved into a separate overlay plane.

Since overlay planes do not support any types of graphic objects other than bitonal bitmaps, all ART marks from a group are converted into a bitmap before saving into an overlay.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet.

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearRasterPage Class
ImGearARTPage Class
ImGearARTImage Class


SavePresState Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOM Class : SavePresState Method
Stream to save presentation state to.
Presentation state metadata.
Saves Presentation State metadata to a Presentation State object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SavePresState( _
   ByVal stream As Stream, _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim stream As Stream
Dim metadata As ImGearMetadataHead

ImGearDICOM.SavePresState(stream, metadata)
public static void SavePresState(
   Stream stream,
   ImGearMetadataHead metadata
)
public: static void SavePresState(
   Stream* stream,
   ImGearMetadataHead* metadata
)
public:
static void SavePresState(
   Stream^ stream,
   ImGearMetadataHead^ metadata
)

Parameters

stream
Stream to save presentation state to.
metadata
Presentation state metadata.
Remarks
Use PreparePresStateMetadata method to extract presentation state settings from page and pageDisplay and build metadata for presentation state.

This method expects DICOM metadata tree in the metadata parameter:

  • Preamble (optional)
  • MetaInfoHeader (optional)
  • DataSet (required)
Example
  • C#
ImGearPresStateOptions options = new ImGearPresStateOptions();
ImGearMetadataHead presStateMetadata =
    ImGearDICOM.PreparePresStateMetadata(
            (ImGearRasterPage)igPage, igPageView.Display, presStateOrigMetadata, options);
using(FileStream fileContent = new FileStream(fileName, FileMode.Create))
{
    ImGearDICOM.SavePresState(fileContent, presStateMetadata);
}
  • Visual Basic
Dim options As ImGearPresStateOptions = New ImGearPresStateOptions()
Dim presStateMetadata As ImGearMetadataHead = ImGearDICOM.PreparePresStateMetadata(igPage, igPageView.Display, presStateOrigMetadata, options)
Using fileContent = New FileStream(fileName, FileMode.Create)
    ImGearDICOM.SavePresState(fileContent, presStateMetadata)
End Using
See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
ImGearMetadataHead Class


%%PageItemTitle%%

ImGearDICOMDisplaySettings Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class
Provides the means to display medical images with proper contrast.
Object Model
ImGearDICOMDisplaySettings ClassImGearLUT ClassImGearDICOMDisplaySettings ClassImGearLUT Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDICOMDisplaySettings
   Implements ImageGear.Core.IImGearDICOMDisplaySettings
'Usage

Dim instance As ImGearDICOMDisplaySettings
public class ImGearDICOMDisplaySettings : ImageGear.Core.IImGearDICOMDisplaySettings
public __gc class ImGearDICOMDisplaySettings : public ImageGear.Core.IImGearDICOMDisplaySettings
public ref class ImGearDICOMDisplaySettings : public ImageGear.Core.IImGearDICOMDisplaySettings
Inheritance Hierarchy

System.Object
ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings

See Also

Reference

ImGearDICOMDisplaySettings Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearDICOMDisplaySettings Class Members
Fields Properties Methods Events

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class

The following tables list the members exposed by ImGearDICOMDisplaySettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearDICOMDisplaySettings Constructor | Initializes a new instance of the ImGearDICOMDisplaySettings class object.
Top
Public Fields
 | Name | Description
Public Field | Modality | Provides access to Modality transform.
Public Field | PresentationLUT | Provides access to Presentation LUT.
Public Field | StandardDisplayLUT | Provides access to Standard Display LUT.
Public Field | VOI | Provides access to VOI transform.
Top
Public Properties
 | Name | Description
Public Property | DisplaySummaryLUT | Gets or sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.
Public Property | Inverted | Gets or sets a value indicating whether image contrast is inverted.
Top
Public Methods
 | Name | Description
Public Method | BuildSummaryLUT | Builds a standalone ImageGear.Core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
Public Method | Clone | Creates a deep copy of the ImGearDICOMDisplaySettings class object.
Public Method | SetAutoVOITransform | Automatically calculates VOI transform based on image's contrast range.
Public Method | UpdateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.
Public Method | UpdateFromMetadata | Updates the object from DICOM metadata.
Public Method | UpdateFromPresStateMetadata | Updates the object from DICOM Presentation State metadata.
Top
Protected Methods
 | Name | Description
Protected Method | OnDisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | DisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDICOMDisplaySettings Class
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMDisplaySettings Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : ImGearDICOMDisplaySettings Constructor
Initializes a new instance of the ImGearDICOMDisplaySettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDICOMDisplaySettings()
public ImGearDICOMDisplaySettings()
public: ImGearDICOMDisplaySettings();
public:
ImGearDICOMDisplaySettings();

Return Value

The new instance of ImGearDICOMDisplaySettings class object.
Remarks
This constructor creates new instance of ImGearDICOMDisplaySettings class object.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


BuildSummaryLUT Method (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : BuildSummaryLUT Method
Builds a standalone ImageGear.Core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
Overload List
Overload | Description
BuildSummaryLUT | Builds a standalone ImageGear.Core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%% $$Methods$$

ImGearDICOMDisplaySettings Class Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Methods
 | Name | Description
Public Method | BuildSummaryLUT | Builds a standalone ImageGear.Core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
Public Method | Clone | Creates a deep copy of the ImGearDICOMDisplaySettings class object.
Public Method | SetAutoVOITransform | Automatically calculates VOI transform based on image's contrast range.
Public Method | UpdateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.
Public Method | UpdateFromMetadata | Updates the object from DICOM metadata.
Public Method | UpdateFromPresStateMetadata | Updates the object from DICOM Presentation State metadata.
Top
Protected Methods
 | Name | Description
Protected Method | OnDisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDICOMDisplaySettings Class
ImageGear.Formats.DICOM Namespace


BuildSummaryLUT(ImGearDIB) Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : BuildSummaryLUT(ImGearDIB) Method
DIB for which the DisplaySummaryLUT is to be built.
Builds a standalone ImageGear.Core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BuildSummaryLUT( _
   ByVal dib As ImGearDIB _
) As ImGearLUT
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim dib As ImGearDIB
Dim value As ImGearLUT

value = instance.BuildSummaryLUT(dib)
public ImGearLUT BuildSummaryLUT(
   ImGearDIB dib
)
public: ImGearLUT* BuildSummaryLUT(
   ImGearDIB* dib
)
public:
ImGearLUT^ BuildSummaryLUT(
   ImGearDIB^ dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

Return Value

ImGearLUT object.
Remarks
Transforms are applied in the following order:
  1. Modality
  2. VOI
  3. Inverted
  4. Presentation LUT
  5. Standard Display LUT

Resulting ImageGear.Core.ImGearLUT class object has input and output depths equal to bit depth of the first image channel. Use this method to build a LUT that will not change image bit depths after being applied to the image.

Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
ImGearLUT lut = rasterPage.DICOMDisplaySettings.BuildSummaryLUT(rasterPage.DIB);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim lut As ImGearLUT = rasterPage.DICOMDisplaySettings.BuildSummaryLUT(rasterPage.DIB)
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearDIB Class
ImGearLUT Class


Clone Method (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : Clone Method
Creates a deep copy of the ImGearDICOMDisplaySettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearDICOMDisplaySettings
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearDICOMDisplaySettings

value = instance.Clone()
public ImGearDICOMDisplaySettings Clone()
public: ImGearDICOMDisplaySettings* Clone();
public:
ImGearDICOMDisplaySettings^ Clone();

Return Value

The new instance of ImGearDICOMDisplaySettings class object.
Remarks
This method creates a deep copy of the ImGearDICOMDisplaySettings class object.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


OnDisplaySummaryLUTUpdated Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : OnDisplaySummaryLUTUpdated Method
Event arguments.
Occurs when the display summary LUT is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnDisplaySummaryLUTUpdated( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim e As EventArgs

instance.OnDisplaySummaryLUTUpdated(e)
protected void OnDisplaySummaryLUTUpdated(
   EventArgs e
)
protected: void OnDisplaySummaryLUTUpdated(
   EventArgs* e
)
protected:
void OnDisplaySummaryLUTUpdated(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


OnPropertyChanged Method (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


SetAutoVOITransform Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : SetAutoVOITransform Method
Page which minimum and maximum values are obtained to build the transform.
Automatically calculates VOI transform based on image's contrast range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAutoVOITransform( _
   ByVal page As ImGearRasterPage _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim page As ImGearRasterPage

instance.SetAutoVOITransform(page)
public void SetAutoVOITransform(
   ImGearRasterPage page
)
public: void SetAutoVOITransform(
   ImGearRasterPage* page
)
public:
void SetAutoVOITransform(
   ImGearRasterPage^ page
)

Parameters

page
Page which minimum and maximum values are obtained to build the transform.
Remarks
This method automatically calculates the linear VOI transform coefficients (Window Center and Width) based on image minimum and maximum values. It takes image's ROI (Region Of Interest) into account.
Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage) igPage;
ImGearDICOMDisplaySettings dicomDisplaySettings = new ImGearDICOMDisplaySettings();
dicomDisplaySettings.SetAutoVOITransform(rasterPage);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim dicomDisplaySettings As ImGearDICOMDisplaySettings = New ImGearDICOMDisplaySettings()
dicomDisplaySettings.SetAutoVOITransform(rasterPage)
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearRasterPage Class


UpdateDisplaySummaryLUT Method (ImGearDICOMDisplaySettings)
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : UpdateDisplaySummaryLUT Method
DIB for which the DisplaySummaryLUT is to be built.
Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateDisplaySummaryLUT( _
   ByVal dib As ImGearDIB _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim dib As ImGearDIB

instance.UpdateDisplaySummaryLUT(dib)
public void UpdateDisplaySummaryLUT(
   ImGearDIB dib
)
public: void UpdateDisplaySummaryLUT(
   ImGearDIB* dib
)
public:
void UpdateDisplaySummaryLUT(
   ImGearDIB^ dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.
Remarks
This method updates DisplaySummaryLUT property based on the transforms that are present in the ImGearDICOMDisplaySettings class object.

Transforms are applied in the following order:

Modality

VOIInvertedPresentation LUTStandard Display LUT

Resulting DisplaySummaryLUT property has input depth equal to image bit depth and output depth equal to grayscale depth of the display device (8).

Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
rasterPage.DICOMDisplaySettings.UpdateDisplaySummaryLUT(rasterPage.DIB);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
rasterPage.DICOMDisplaySettings.UpdateDisplaySummaryLUT(rasterPage.DIB)
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearDIB Class


UpdateFromMetadata Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : UpdateFromMetadata Method
Updates the object from DICOM metadata.
Overload List
Overload | Description
UpdateFromMetadata | Updates the object from DICOM metadata.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


UpdateFromMetadata(ImGearMetadataHead) Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : UpdateFromMetadata(ImGearMetadataHead) Method
DICOM Metadata, from which display settings shall be obtained.
Updates the object from DICOM metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateFromMetadata( _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim metadata As ImGearMetadataHead

instance.UpdateFromMetadata(metadata)
public void UpdateFromMetadata(
   ImGearMetadataHead metadata
)
public: void UpdateFromMetadata(
   ImGearMetadataHead* metadata
)
public:
void UpdateFromMetadata(
   ImGearMetadataHead^ metadata
)

Parameters

metadata
DICOM Metadata, from which display settings shall be obtained.
Remarks
This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:
  • Modality
  • VOI
  • Inverted

Presentation State metadata uses a different structure than metadata of a DICOM image. To update ImGearDICOMDisplaySettings class from presentation state metadata, use UpdateFromPresStateMetadata(ImGearMetadataHead) method.

NOTE:

This method does not update DisplaySummaryLUT property. Use UpdateDisplaySummaryLUT method for this.

Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
ImGearDICOMDisplaySettings dicomDisplaySettings = new ImGearDICOMDisplaySettings();
dicomDisplaySettings.UpdateFromMetadata(rasterPage.Metadata);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim dicomDisplaySettings As ImGearDICOMDisplaySettings = New ImGearDICOMDisplaySettings()
dicomDisplaySettings.UpdateFromMetadata(rasterPage.Metadata)
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearMetadataHead Class


UpdateFromPresStateMetadata Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : UpdateFromPresStateMetadata Method
Updates the object from DICOM Presentation State metadata.
Overload List
Overload | Description
UpdateFromPresStateMetadata | Updates the object from DICOM Presentation State metadata.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


UpdateFromPresStateMetadata(ImGearMetadataHead) Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : UpdateFromPresStateMetadata(ImGearMetadataHead) Method
Presentation State metadata from which display settings shall be obtained.
Updates the object from DICOM Presentation State metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateFromPresStateMetadata( _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim metadata As ImGearMetadataHead

instance.UpdateFromPresStateMetadata(metadata)
public void UpdateFromPresStateMetadata(
   ImGearMetadataHead metadata
)
public: void UpdateFromPresStateMetadata(
   ImGearMetadataHead* metadata
)
public:
void UpdateFromPresStateMetadata(
   ImGearMetadataHead^ metadata
)

Parameters

metadata
Presentation State metadata from which display settings shall be obtained.
Remarks
This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:
  • Modality
  • VOI
  • Inverted
  • Presentation LUT
Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
ImGearDICOMDisplaySettings dicomDisplaySettings = new ImGearDICOMDisplaySettings();
dicomDisplaySettings.UpdateFromPresStateMetadata(rasterPage.Metadata);
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim dicomDisplaySettings As ImGearDICOMDisplaySettings = New ImGearDICOMDisplaySettings()
dicomDisplaySettings.UpdateFromPresStateMetadata(rasterPage.Metadata)
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearMetadataHead Class


%%PageItemTitle%% $$Properties$$

ImGearDICOMDisplaySettings Class Properties

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Properties
 | Name | Description
Public Property | DisplaySummaryLUT | Gets or sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.
Public Property | Inverted | Gets or sets a value indicating whether image contrast is inverted.
Top
See Also

Reference

ImGearDICOMDisplaySettings Class
ImageGear.Formats.DICOM Namespace


DisplaySummaryLUT Property (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : DisplaySummaryLUT Property
Gets or sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplaySummaryLUT As ImGearLUT
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearLUT

instance.DisplaySummaryLUT = value

value = instance.DisplaySummaryLUT
public ImGearLUT DisplaySummaryLUT {get; set;}
public: __property ImGearLUT* get_DisplaySummaryLUT();
public: __property void set_DisplaySummaryLUT(
   ImGearLUT* value
);
public:
property ImGearLUT^ DisplaySummaryLUT {
   ImGearLUT^ get();
   void set (    ImGearLUT^ value);
}

Property Value

ImageGear.Core.ImGearLUT class object.
Remarks
This property concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearLUT Class


Inverted Property (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : Inverted Property
Gets or sets a value indicating whether image contrast is inverted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Inverted As Boolean
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As Boolean

instance.Inverted = value

value = instance.Inverted
public bool Inverted {get; set;}
public: __property bool get_Inverted();
public: __property void set_Inverted(
   bool value
);
public:
property bool Inverted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property tells whether the image shall be displayed with inverted contrast. ImageGear sets this property to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this property into account when it builds the summary LUT.

The default value is false.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%% $$Fields$$

ImGearDICOMDisplaySettings Class Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Fields
 | Name | Description
Public Field | Modality | Provides access to Modality transform.
Public Field | PresentationLUT | Provides access to Presentation LUT.
Public Field | StandardDisplayLUT | Provides access to Standard Display LUT.
Public Field | VOI | Provides access to VOI transform.
Top
See Also

Reference

ImGearDICOMDisplaySettings Class
ImageGear.Formats.DICOM Namespace


Modality Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : Modality Field
Provides access to Modality transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Modality As ImGearModalityTransform
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearModalityTransform

value = instance.Modality

instance.Modality = value
public ImGearModalityTransform Modality
public: ImGearModalityTransform* Modality
public:
ImGearModalityTransform^ Modality

Field Value

ImGearModalityTransform class object.
Remarks
The default value is null.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearModalityTransform Class


PresentationLUT Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : PresentationLUT Field
Provides access to Presentation LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PresentationLUT As ImGearFullLUT
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearFullLUT

value = instance.PresentationLUT

instance.PresentationLUT = value
public ImGearFullLUT PresentationLUT
public: ImGearFullLUT* PresentationLUT
public:
ImGearFullLUT^ PresentationLUT

Field Value

ImageGear.Core.ImGearFullLUT class object.
Remarks
The default value is null.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearFullLUT Class


StandardDisplayLUT Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : StandardDisplayLUT Field
Provides access to Standard Display LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public StandardDisplayLUT As ImGearFullLUT
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearFullLUT

value = instance.StandardDisplayLUT

instance.StandardDisplayLUT = value
public ImGearFullLUT StandardDisplayLUT
public: ImGearFullLUT* StandardDisplayLUT
public:
ImGearFullLUT^ StandardDisplayLUT

Field Value

ImageGear.Core.ImGearFullLUT class object.
Remarks
The default value is null.
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearFullLUT Class


VOI Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : VOI Field
Provides access to VOI transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public VOI As ImGearVOITransform
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim value As ImGearVOITransform

value = instance.VOI

instance.VOI = value
public ImGearVOITransform VOI
public: ImGearVOITransform* VOI
public:
ImGearVOITransform^ VOI

Field Value

ImGearVOITransform class object.
Remarks
This property provides access to DICOM Value Of Interest (VOI) transform.

The default value is null.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members
ImGearVOITransform Class


%%PageItemTitle%% $$Events$$

ImGearDICOMDisplaySettings Class Events

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMDisplaySettings Class

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Events
 | Name | Description
Public Event | DisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearDICOMDisplaySettings Class
ImageGear.Formats.DICOM Namespace


DisplaySummaryLUTUpdated Event (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : DisplaySummaryLUTUpdated Event
Occurs when the display summary LUT is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event DisplaySummaryLUTUpdated As EventHandler
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim handler As EventHandler

AddHandler instance.DisplaySummaryLUTUpdated, handler
public event EventHandler DisplaySummaryLUTUpdated
public: __event EventHandler* DisplaySummaryLUTUpdated
public:
event EventHandler^ DisplaySummaryLUTUpdated
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


PropertyChanged Event (ImGearDICOMDisplaySettings)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearDICOMDisplaySettings Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearDICOMDisplaySettings
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

ImGearModalityTransform Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearModalityTransform Class
Implements DICOM Modality transform.
Object Model
ImGearModalityTransform ClassImGearModalityTransform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearModalityTransform
'Usage

Dim instance As ImGearModalityTransform
public class ImGearModalityTransform
public __gc class ImGearModalityTransform
public ref class ImGearModalityTransform
Inheritance Hierarchy

System.Object
ImageGear.Formats.DICOM.ImGearModalityTransform

See Also

Reference

ImGearModalityTransform Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearModalityTransform Class Members
Fields Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearModalityTransform Class

The following tables list the members exposed by ImGearModalityTransform.

Public Constructors
 | Name | Description
Public Constructor | ImGearModalityTransform Constructor | Initializes a new instance of the ImGearModalityTransform class.
Top
Public Fields
 | Name | Description
Public Field | LUT | Specifies non-linear lookup table (LUT).
Public Field | Rescale | Specifies linear modality transform.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
See Also

Reference

ImGearModalityTransform Class
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearModalityTransform Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearModalityTransform Class : ImGearModalityTransform Constructor
Initializes a new instance of the ImGearModalityTransform class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearModalityTransform()
public ImGearModalityTransform()
public: ImGearModalityTransform();
public:
ImGearModalityTransform();

Return Value

The new instance of ImGearModalityTransform class object.
Remarks
This constructor creates new instance of ImGearModalityTransform class object.
See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%% $$Methods$$

ImGearModalityTransform Class Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearModalityTransform Class

For a list of all members of this type, see ImGearModalityTransform members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
See Also

Reference

ImGearModalityTransform Class
ImageGear.Formats.DICOM Namespace


Clone Method (ImGearModalityTransform)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearModalityTransform Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearModalityTransform
'Usage

Dim instance As ImGearModalityTransform
Dim value As ImGearModalityTransform

value = instance.Clone()
public ImGearModalityTransform Clone()
public: ImGearModalityTransform* Clone();
public:
ImGearModalityTransform^ Clone();

Return Value

The new instance of ImGearModalityTransform class object.
Remarks
This method makes a deep copy of the ImGearModalityTransform class object.
See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%% $$Fields$$

ImGearModalityTransform Class Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearModalityTransform Class

For a list of all members of this type, see ImGearModalityTransform members.

Public Fields
 | Name | Description
Public Field | LUT | Specifies non-linear lookup table (LUT).
Public Field | Rescale | Specifies linear modality transform.
Top
See Also

Reference

ImGearModalityTransform Class
ImageGear.Formats.DICOM Namespace


LUT Field (ImGearModalityTransform)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearModalityTransform Class : LUT Field
Specifies non-linear lookup table (LUT).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public LUT As ImGearLUT
'Usage

Dim instance As ImGearModalityTransform
Dim value As ImGearLUT

value = instance.LUT

instance.LUT = value
public ImGearLUT LUT
public: ImGearLUT* LUT
public:
ImGearLUT^ LUT
Remarks
The default value is null.
See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


Rescale Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearModalityTransform Class : Rescale Field
Specifies linear modality transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Rescale As ImGearLinearTransform
'Usage

Dim instance As ImGearModalityTransform
Dim value As ImGearLinearTransform

value = instance.Rescale

instance.Rescale = value
public ImGearLinearTransform Rescale
public: ImGearLinearTransform Rescale
public:
ImGearLinearTransform Rescale

Field Value

ImGearLinearTransform structure object.
Remarks
This transform corresponds to RescaleSlope and RescaleIntercept DICOM tags.
See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members
ImGearLinearTransform Structure


%%PageItemTitle%%

ImGearMprProcessor Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearMprProcessor Class
Provides Multi-planar reconstruction features.
Object Model
ImGearMprProcessor ClassImGearRasterPage ClassIImGearSize Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprProcessor
'Usage

Dim instance As ImGearMprProcessor
public class ImGearMprProcessor
public __gc class ImGearMprProcessor
public ref class ImGearMprProcessor
Inheritance Hierarchy

System.Object
ImageGear.Formats.DICOM.ImGearMprProcessor

See Also

Reference

ImGearMprProcessor Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearMprProcessor Class Members
Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearMprProcessor Class

The following tables list the members exposed by ImGearMprProcessor.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprProcessor Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | GetPlane | Overloaded. Returns image view reconstructed from pages in the provided plane.
Public Method | GetPlaneSize | Overloaded. Returns expected size of the reconstructed view in the provided plane.
static (Shared in Visual Basic) | ValidatePages | Overloaded. Determines whether multi-planar reconstruction could be performed on provided pages.
Top
See Also

Reference

ImGearMprProcessor Class
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearMprProcessor Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class : ImGearMprProcessor Constructor
Overload List
Overload | Description
ImGearMprProcessor Constructor(ImGearDocumentPageArray,ImGearMprViewType) | Initializes a new instance of the ImGearMprProcessor class.
ImGearMprProcessor Constructor(IEnumerable<ImGearPage>,ImGearMprViewType) | Initializes a new instance of the ImGearMprProcessor class.
ImGearMprProcessor Constructor(IEnumerable<String>,ImGearMprViewType) | Initializes a new instance of the ImGearMprProcessor class.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members


%%PageItemTitle%%

ImGearMprProcessor Constructor(ImGearDocumentPageArray,ImGearMprViewType)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > ImGearMprProcessor Constructor : ImGearMprProcessor Constructor(ImGearDocumentPageArray,ImGearMprViewType)
Collection of pages in corresponding orientation.
Orientation of pages.
Initializes a new instance of the ImGearMprProcessor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pages As ImGearDocumentPageArray, _
   ByVal orientation As ImGearMprViewType _
)
'Usage

Dim pages As ImGearDocumentPageArray
Dim orientation As ImGearMprViewType

Dim instance As New ImGearMprProcessor(pages, orientation)
public ImGearMprProcessor(
   ImGearDocumentPageArray pages,
   ImGearMprViewType orientation
)
public: ImGearMprProcessor(
   ImGearDocumentPageArray* pages,
   ImGearMprViewType orientation
)
public:
ImGearMprProcessor(
   ImGearDocumentPageArray^ pages,
   ImGearMprViewType orientation
)

Parameters

pages
Collection of pages in corresponding orientation.
orientation
Orientation of pages.
Exceptions
Exception | Description
System.ArgumentNullException | pages is null reference (Nothing in Visual Basic).
ImageGear.Core.ImGearException | Not enough pages. -or- Pages have different dimensions. -or- Pages have different color spaces. -or- Pages have different bit depths.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


%%PageItemTitle%%

ImGearMprProcessor Constructor(IEnumerable<ImGearPage>,ImGearMprViewType)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > ImGearMprProcessor Constructor : ImGearMprProcessor Constructor(IEnumerable<ImGearPage>,ImGearMprViewType)
Collection of pages in corresponding orientation.
Orientation of pages.
Initializes a new instance of the ImGearMprProcessor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pages As IEnumerable(Of ImGearPage), _
   ByVal orientation As ImGearMprViewType _
)
'Usage

Dim pages As IEnumerable(Of ImGearPage)
Dim orientation As ImGearMprViewType

Dim instance As New ImGearMprProcessor(pages, orientation)
public ImGearMprProcessor(
   IEnumerable<ImGearPage> pages,
   ImGearMprViewType orientation
)
public: ImGearMprProcessor(
   IEnumerable<ImGearPage*>* pages,
   ImGearMprViewType orientation
)
public:
ImGearMprProcessor(
   IEnumerable<ImGearPage^>^ pages,
   ImGearMprViewType orientation
)

Parameters

pages
Collection of pages in corresponding orientation.
orientation
Orientation of pages.
Exceptions
Exception | Description
System.ArgumentNullException | pages is null reference (Nothing in Visual Basic).
ImageGear.Core.ImGearException | Not enough pages. -or- Pages have different dimensions. -or- Pages have different color spaces. -or- Pages have different bit depths.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


%%PageItemTitle%%

ImGearMprProcessor Constructor(IEnumerable<String>,ImGearMprViewType)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > ImGearMprProcessor Constructor : ImGearMprProcessor Constructor(IEnumerable<String>,ImGearMprViewType)
Collection of one-paged files in corresponding orientation.
Orientation of pages.
Initializes a new instance of the ImGearMprProcessor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal files As IEnumerable(Of String), _
   ByVal orientation As ImGearMprViewType _
)
'Usage

Dim files As IEnumerable(Of String)
Dim orientation As ImGearMprViewType

Dim instance As New ImGearMprProcessor(files, orientation)
public ImGearMprProcessor(
   IEnumerable<string> files,
   ImGearMprViewType orientation
)
public: ImGearMprProcessor(
   IEnumerable<string*>* files,
   ImGearMprViewType orientation
)
public:
ImGearMprProcessor(
   IEnumerable<String^>^ files,
   ImGearMprViewType orientation
)

Parameters

files
Collection of one-paged files in corresponding orientation.
orientation
Orientation of pages.
Exceptions
Exception | Description
System.ArgumentNullException | files is null reference (Nothing in Visual Basic).
ImageGear.Core.ImGearException | Not enough pages. -or- Pages have different dimensions. -or- Pages have different color spaces. -or- Pages have different bit depths.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearMprProcessor Class Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearMprProcessor Class

For a list of all members of this type, see ImGearMprProcessor members.

Public Methods
 | Name | Description
Public Method | GetPlane | Overloaded. Returns image view reconstructed from pages in the provided plane.
Public Method | GetPlaneSize | Overloaded. Returns expected size of the reconstructed view in the provided plane.
static (Shared in Visual Basic) | ValidatePages | Overloaded. Determines whether multi-planar reconstruction could be performed on provided pages.
Top
See Also

Reference

ImGearMprProcessor Class
ImageGear.Formats.DICOM Namespace


GetPlane Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class : GetPlane Method
Returns image view reconstructed from pages in the provided plane.
Overload List
Overload | Description
GetPlane(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) | Returns image view reconstructed from pages in the provided plane.
GetPlane(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) | Returns image view reconstructed from pages in the provided plane.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members


GetPlane(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > GetPlane Method : GetPlane(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) Method
Start X coordinate of the plane.
Start Y coordinate of the plane.
End X coordinate of the plane.
End Y coordinate of the plane.
Start position of the plane within the stack of images.
End position of the plane within the stack of images.
Specifies on which view to perform reconstruction.
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
Indicates whether to update LUT for output image.
Returns image view reconstructed from pages in the provided plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPlane( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal startPageNumber As Integer, _
   ByVal endPageNumber As Integer, _
   ByVal viewType As ImGearMprViewType, _
   ByVal rotateAxes As Boolean, _
   ByVal updateLUT As Boolean _
) As ImGearRasterPage
'Usage

Dim instance As ImGearMprProcessor
Dim x1 As Integer
Dim y1 As Integer
Dim x2 As Integer
Dim y2 As Integer
Dim startPageNumber As Integer
Dim endPageNumber As Integer
Dim viewType As ImGearMprViewType
Dim rotateAxes As Boolean
Dim updateLUT As Boolean
Dim value As ImGearRasterPage

value = instance.GetPlane(x1, y1, x2, y2, startPageNumber, endPageNumber, viewType, rotateAxes, updateLUT)
public ImGearRasterPage GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   int startPageNumber,
   int endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)
public: ImGearRasterPage* GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   int startPageNumber,
   int endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)
public:
ImGearRasterPage^ GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   int startPageNumber,
   int endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)

Parameters

x1
Start X coordinate of the plane.
y1
Start Y coordinate of the plane.
x2
End X coordinate of the plane.
y2
End Y coordinate of the plane.
startPageNumber
Start position of the plane within the stack of images.
endPageNumber
End position of the plane within the stack of images.
viewType
Specifies on which view to perform reconstruction.
rotateAxes
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
updateLUT
Indicates whether to update LUT for output image.

Return Value

Page containing reconstructed view.
Remarks
X and Y represent starting and ending coordinates of the line used to specify the plane for reconstructing the view.

E.g. if original stack of images represents axial view, then:

To get coronal view, y1 and y2 should be equal to each other.

To get sagittal view, x1 and x2 should be equal to each other.

Any other set of X and Y coordinates will produce oblique view.

The x1 and x2 values range from 0 to the original image's width.

The y1 and y2 values range from 0 to the original image's height.

See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


GetPlane(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > GetPlane Method : GetPlane(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean,Boolean) Method
Start X coordinate of the plane.
Start Y coordinate of the plane.
End X coordinate of the plane.
End Y coordinate of the plane.
Specifies on which view to perform reconstruction.
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
Indicates whether to update LUT.
Returns image view reconstructed from pages in the provided plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPlane( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal viewType As ImGearMprViewType, _
   ByVal rotateAxes As Boolean, _
   ByVal updateLUT As Boolean _
) As ImGearRasterPage
'Usage

Dim instance As ImGearMprProcessor
Dim x1 As Integer
Dim y1 As Integer
Dim x2 As Integer
Dim y2 As Integer
Dim viewType As ImGearMprViewType
Dim rotateAxes As Boolean
Dim updateLUT As Boolean
Dim value As ImGearRasterPage

value = instance.GetPlane(x1, y1, x2, y2, viewType, rotateAxes, updateLUT)
public ImGearRasterPage GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)
public: ImGearRasterPage* GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)
public:
ImGearRasterPage^ GetPlane(
   int x1,
   int y1,
   int x2,
   int y2,
   ImGearMprViewType viewType,
   bool rotateAxes,
   bool updateLUT
)

Parameters

x1
Start X coordinate of the plane.
y1
Start Y coordinate of the plane.
x2
End X coordinate of the plane.
y2
End Y coordinate of the plane.
viewType
Specifies on which view to perform reconstruction.
rotateAxes
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
updateLUT
Indicates whether to update LUT.

Return Value

Page containing reconstructed view.
Remarks
X and Y represent starting and ending coordinates of the line used to specify the plane for reconstructing the view.

E.g. if original stack of images represents axial view, then:

To get coronal view, y1 and y2 should be equal to each other.

To get sagittal view, x1 and x2 should be equal to each other.

Any other set of X and Y coordinates will produce oblique view.

The x1 and x2 values range from 0 to the original image's width.

The y1 and y2 values range from 0 to the original image's height.

See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


GetPlaneSize Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class : GetPlaneSize Method
Returns expected size of the reconstructed view in the provided plane.
Overload List
Overload | Description
GetPlaneSize(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) | Returns expected size of the reconstructed view in the provided plane.
GetPlaneSize(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) | Returns expected size of the reconstructed view in the provided plane.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members


GetPlaneSize(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > GetPlaneSize Method : GetPlaneSize(Int32,Int32,Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) Method
Start X coordinate of the plane.
Start Y coordinate of the plane.
End X coordinate of the plane.
End Y coordinate of the plane.
Start position of the plane within the stack of images.
End position of the plane within the stack of images.
Specifies on which view to perform calculation.
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
Returns expected size of the reconstructed view in the provided plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPlaneSize( _
   ByRef x1 As Integer, _
   ByRef y1 As Integer, _
   ByRef x2 As Integer, _
   ByRef y2 As Integer, _
   ByRef startPageNumber As Integer, _
   ByRef endPageNumber As Integer, _
   ByVal viewType As ImGearMprViewType, _
   ByVal rotateAxes As Boolean _
) As IImGearSize
'Usage

Dim instance As ImGearMprProcessor
Dim x1 As Integer
Dim y1 As Integer
Dim x2 As Integer
Dim y2 As Integer
Dim startPageNumber As Integer
Dim endPageNumber As Integer
Dim viewType As ImGearMprViewType
Dim rotateAxes As Boolean
Dim value As IImGearSize

value = instance.GetPlaneSize(x1, y1, x2, y2, startPageNumber, endPageNumber, viewType, rotateAxes)
public IImGearSize GetPlaneSize(
   ref int x1,
   ref int y1,
   ref int x2,
   ref int y2,
   ref int startPageNumber,
   ref int endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes
)
public: IImGearSize* GetPlaneSize(
   ref int x1,
   ref int y1,
   ref int x2,
   ref int y2,
   ref int startPageNumber,
   ref int endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes
)
public:
IImGearSize^ GetPlaneSize(
   int% x1,
   int% y1,
   int% x2,
   int% y2,
   int% startPageNumber,
   int% endPageNumber,
   ImGearMprViewType viewType,
   bool rotateAxes
)

Parameters

x1
Start X coordinate of the plane.
y1
Start Y coordinate of the plane.
x2
End X coordinate of the plane.
y2
End Y coordinate of the plane.
startPageNumber
Start position of the plane within the stack of images.
endPageNumber
End position of the plane within the stack of images.
viewType
Specifies on which view to perform calculation.
rotateAxes
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.

Return Value

Expected size of the reconstructed view.
Remarks
X and Y represent starting and ending coordinates of the line used to specify the plane for reconstructing the view.

E.g. if original stack of images represents axial view, then:

To get coronal view, y1 and y2 should be equal to each other.

To get sagittal view, x1 and x2 should be equal to each other.

Any other set of X and Y coordinates will produce oblique view.

The x1 and x2 values range from 0 to the original image's width.

The y1 and y2 values range from 0 to the original image's height.

See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


GetPlaneSize(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > GetPlaneSize Method : GetPlaneSize(Int32,Int32,Int32,Int32,ImGearMprViewType,Boolean) Method
Start X coordinate of the plane.
Start Y coordinate of the plane.
End X coordinate of the plane.
End Y coordinate of the plane.
Specifies on which view to perform calculation.
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.
Returns expected size of the reconstructed view in the provided plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPlaneSize( _
   ByRef x1 As Integer, _
   ByRef y1 As Integer, _
   ByRef x2 As Integer, _
   ByRef y2 As Integer, _
   ByVal viewType As ImGearMprViewType, _
   ByVal rotateAxes As Boolean _
) As IImGearSize
'Usage

Dim instance As ImGearMprProcessor
Dim x1 As Integer
Dim y1 As Integer
Dim x2 As Integer
Dim y2 As Integer
Dim viewType As ImGearMprViewType
Dim rotateAxes As Boolean
Dim value As IImGearSize

value = instance.GetPlaneSize(x1, y1, x2, y2, viewType, rotateAxes)
public IImGearSize GetPlaneSize(
   ref int x1,
   ref int y1,
   ref int x2,
   ref int y2,
   ImGearMprViewType viewType,
   bool rotateAxes
)
public: IImGearSize* GetPlaneSize(
   ref int x1,
   ref int y1,
   ref int x2,
   ref int y2,
   ImGearMprViewType viewType,
   bool rotateAxes
)
public:
IImGearSize^ GetPlaneSize(
   int% x1,
   int% y1,
   int% x2,
   int% y2,
   ImGearMprViewType viewType,
   bool rotateAxes
)

Parameters

x1
Start X coordinate of the plane.
y1
Start Y coordinate of the plane.
x2
End X coordinate of the plane.
y2
End Y coordinate of the plane.
viewType
Specifies on which view to perform calculation.
rotateAxes
Indicates whether to rotate axes, so vertical axis becomes horizontal and vise versa. Should be true when reconstructing sagittal view from coronal view, or axial and coronal views from saggital view; false otherwise.

Return Value

Expected size of the reconstructed view.
Remarks
X and Y represent starting and ending coordinates of the line used to specify the plane for reconstructing the view.

E.g. if original stack of images represents axial view, then:

To get coronal view, y1 and y2 should be equal to each other.

To get sagittal view, x1 and x2 should be equal to each other.

Any other set of X and Y coordinates will produce oblique view.

The x1 and x2 values range from 0 to the original image's width.

The y1 and y2 values range from 0 to the original image's height.

See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


ValidatePages Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class : ValidatePages Method
Determines whether multi-planar reconstruction could be performed on provided pages.
Overload List
Overload | Description
ValidatePages(ImGearDocumentPageArray) | Determines whether multi-planar reconstruction could be performed on provided pages.
ValidatePages(IEnumerable<ImGearPage>) | Determines whether multi-planar reconstruction could be performed on provided pages.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members


ValidatePages(ImGearDocumentPageArray) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > ValidatePages Method : ValidatePages(ImGearDocumentPageArray) Method
Collection of pages to validate.
Determines whether multi-planar reconstruction could be performed on provided pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ValidatePages( _
   ByVal pages As ImGearDocumentPageArray _
)
'Usage

Dim pages As ImGearDocumentPageArray

ImGearMprProcessor.ValidatePages(pages)
public static void ValidatePages(
   ImGearDocumentPageArray pages
)
public: static void ValidatePages(
   ImGearDocumentPageArray* pages
)
public:
static void ValidatePages(
   ImGearDocumentPageArray^ pages
)

Parameters

pages
Collection of pages to validate.
Exceptions
Exception | Description
System.ArgumentNullException | pages is null reference (Nothing in Visual Basic).
ImageGear.Core.ImGearException | Not enough pages. -or- Pages have different dimensions. -or- Pages have different color spaces. -or- Pages have different bit depths.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


ValidatePages(IEnumerable<ImGearPage>) Method

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearMprProcessor Class > ValidatePages Method : ValidatePages(IEnumerable<ImGearPage>) Method
Collection of pages to validate.
Determines whether multi-planar reconstruction could be performed on provided pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ValidatePages( _
   ByVal pages As IEnumerable(Of ImGearPage) _
)
'Usage

Dim pages As IEnumerable(Of ImGearPage)

ImGearMprProcessor.ValidatePages(pages)
public static void ValidatePages(
   IEnumerable<ImGearPage> pages
)
public: static void ValidatePages(
   IEnumerable<ImGearPage*>* pages
)
public:
static void ValidatePages(
   IEnumerable<ImGearPage^>^ pages
)

Parameters

pages
Collection of pages to validate.
Exceptions
Exception | Description
System.ArgumentNullException | pages is null reference (Nothing in Visual Basic).
ImageGear.Core.ImGearException | Not enough pages. -or- Pages have different dimensions. -or- Pages have different color spaces. -or- Pages have different bit depths.
See Also

Reference

ImGearMprProcessor Class
ImGearMprProcessor Members
Overload List


%%PageItemTitle%%

ImGearVOITransform Class
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOITransform Class
Implements DICOM Value Of Interest (VOI) transform.
Object Model
ImGearVOITransform ClassImGearVOITransform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVOITransform
'Usage

Dim instance As ImGearVOITransform
public class ImGearVOITransform
public __gc class ImGearVOITransform
public ref class ImGearVOITransform
Inheritance Hierarchy

System.Object
ImageGear.Formats.DICOM.ImGearVOITransform

See Also

Reference

ImGearVOITransform Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearVOITransform Class Members
Fields Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOITransform Class

The following tables list the members exposed by ImGearVOITransform.

Public Constructors
 | Name | Description
Public Constructor | ImGearVOITransform Constructor | Initializes a new instance of the ImGearVOITransform class.
Top
Public Fields
 | Name | Description
Public Field | LUT | Specifies non-linear lookup table (LUT).
Public Field | Window | Specifies linear VOI transform.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
See Also

Reference

ImGearVOITransform Class
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearVOITransform Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOITransform Class : ImGearVOITransform Constructor
Initializes a new instance of the ImGearVOITransform class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearVOITransform()
public ImGearVOITransform()
public: ImGearVOITransform();
public:
ImGearVOITransform();
See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%% $$Methods$$

ImGearVOITransform Class Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOITransform Class

For a list of all members of this type, see ImGearVOITransform members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a deep copy of the object.
Top
See Also

Reference

ImGearVOITransform Class
ImageGear.Formats.DICOM Namespace


Clone Method (ImGearVOITransform)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOITransform Class : Clone Method
Creates a deep copy of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearVOITransform
'Usage

Dim instance As ImGearVOITransform
Dim value As ImGearVOITransform

value = instance.Clone()
public ImGearVOITransform Clone()
public: ImGearVOITransform* Clone();
public:
ImGearVOITransform^ Clone();

Return Value

The new instance of ImGearVOITransform class object.
Remarks
This method creates a deep copy of the ImGearVOITransform class object.
See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%% $$Fields$$

ImGearVOITransform Class Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOITransform Class

For a list of all members of this type, see ImGearVOITransform members.

Public Fields
 | Name | Description
Public Field | LUT | Specifies non-linear lookup table (LUT).
Public Field | Window | Specifies linear VOI transform.
Top
See Also

Reference

ImGearVOITransform Class
ImageGear.Formats.DICOM Namespace


LUT Field (ImGearVOITransform)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOITransform Class : LUT Field
Specifies non-linear lookup table (LUT).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public LUT As ImGearLUT
'Usage

Dim instance As ImGearVOITransform
Dim value As ImGearLUT

value = instance.LUT

instance.LUT = value
public ImGearLUT LUT
public: ImGearLUT* LUT
public:
ImGearLUT^ LUT
Remarks
The default value is null.
See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


Window Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOITransform Class : Window Field
Specifies linear VOI transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Window As ImGearVOIWindow
'Usage

Dim instance As ImGearVOITransform
Dim value As ImGearVOIWindow

value = instance.Window

instance.Window = value
public ImGearVOIWindow Window
public: ImGearVOIWindow Window
public:
ImGearVOIWindow Window

Field Value

ImGearVOIWindow structure object.
Remarks
This corresponds to WindowCenter and WindowWidth DICOM tags.
See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members
ImGearVOIWindow Structure


%%PageItemTitle%%

ImGearDICOMPhotoInterpretations Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMPhotoInterpretations Enumeration
Specifies DICOM Photometric Interpretations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMPhotoInterpretations
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMPhotoInterpretations
public enum ImGearDICOMPhotoInterpretations : System.Enum
__value public enum ImGearDICOMPhotoInterpretations : public System.Enum
public enum class ImGearDICOMPhotoInterpretations : public System.Enum
Members
Member | Value | Description
ARGB | 6 | Retired in DICOM standard.
CMYK | 7 | Retired in DICOM standard.
HSV | 5 | Retired in DICOM standard.
MONOCHROME1 | 1 | Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as white.
MONOCHROME2 | 2 | Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as black.
PALETTE_COLOR | 3 | Pixel data describe a color image with a single sample per pixel (single image plane). The pixel value is used as an index into each of the Red, Blue, and Green Palette Color Lookup Tables.
RGB | 4 | Pixel data represent a color image described by red, green, and blue image planes.
UNKNOWN | 0 | Photometric interpretation is unknown.
YBR_FULL | 8 | Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr).
YBR_FULL_422 | 9 | The same as YBR_FULL except that the Cb and Cr values are sampled horizontally at half the Y rate and as a result there are half as many Cb and Cr values as Y values.
YBR_ICT | 11 | Irreversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.
YBR_PARTIAL_422 | 10 | The same as YBR_FULL_422 with certain limitations. See DICOM specification PS 3.3 for more detail.
YBR_RCT | 12 | Reversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMPhotoInterpretations

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMPixelRepresenations Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMPixelRepresenations Enumeration
Specifies DICOM Pixel Representations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMPixelRepresenations
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMPixelRepresenations
public enum ImGearDICOMPixelRepresenations : System.Enum
__value public enum ImGearDICOMPixelRepresenations : public System.Enum
public enum class ImGearDICOMPixelRepresenations : public System.Enum
Members
Member | Value | Description
COMPLEMENT_2S | 1 | Pixels are signed, encoded in 2's complement form.
UNKNOWN | 99 | Unknown pixel representation.
UNSIGNED | 0 | Pixels are unsigned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMPixelRepresenations

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMPlanarConfigurations Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMPlanarConfigurations Enumeration
Specifies DICOM Planar Configurations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMPlanarConfigurations
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMPlanarConfigurations
public enum ImGearDICOMPlanarConfigurations : System.Enum
__value public enum ImGearDICOMPlanarConfigurations : public System.Enum
public enum class ImGearDICOMPlanarConfigurations : public System.Enum
Members
Member | Value | Description
PIXEL_BY_PIXEL | 0 | Pixel by pixel (interleaved by color channel. RGB, RGB, RGB).
PLANE_BY_PLANE | 1 | Plane by plane (not interleaved by color channel. RRR, GGG, BBB).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMPlanarConfigurations

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMServiceObjectPairs Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMServiceObjectPairs Enumeration
Specifies DICOM Service Object Pair (SOP) constants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMServiceObjectPairs
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMServiceObjectPairs
public enum ImGearDICOMServiceObjectPairs : System.Enum
__value public enum ImGearDICOMServiceObjectPairs : public System.Enum
public enum class ImGearDICOMServiceObjectPairs : public System.Enum
Members
Member | Value | Description
ABSTRACT_MULTIDIMENSIONAL_IMAGE_MODEL | 246 | Abstract Multi-Dimensional Image Model.
AMBULATORY_ECG_WAVEFORM_STORAGE | 84 | Ambulatory ECG Waveform Storage.
ARTERIAL_PULSE_WAVEFORM_STORAGE | 189 | Arterial Pulse Waveform Storage.
AUTOREFRACTION_MEASUREMENTS_STORAGE | 195 | Autorefraction Measurements Storage.
BASIC_ANNOTATION_BOX | 36 | Basic Annotation Box SOP Class.
BASIC_COLOR_IMG_BOX | 31 | Basic Color Image Box SOP Class.
BASIC_COLOR_PRINT_MGMT_META | 41 | Basic Color Print Management Meta SOP Class.
BASIC_FILM_BOX | 29 | Basic Film Box SOP Class.
BASIC_FILM_SESSION | 28 | Basic Film Session SOP Class.
BASIC_GRAY_IMG_BOX | 30 | Basic Grayscale Image Box SOP Class.
BASIC_GRAY_PRINT_MGMT_META | 33 | Basic Grayscale Print Management Meta SOP Class.
BASIC_PRINT_IMAGE_OVERLAY_BOX | 46 | Basic Print Image Overlay Box SOP Class (Retired).
BASIC_STRUCTURED_DISPLAY_STORAGE | 203 | Basic Structured Display Storage.
BASIC_STUDY_CONTENT_NOTIFICATION | 3 | Basic Study Content Notification SOP Class (Retired).
BASIC_VOICE_AUDIO_WAVEFORM_STORAGE | 87 | Basic Voice Audio Waveform Storage.
BLENDING_SOFTCOPY_PRES_STATE_STORAGE | 93 | Blending Softcopy Presentation State Storage SOP Class.
BREAST_IMAGING_RELEVANT_PATIENT_INFORMATION_QUERY | 172 | Breast Imaging Relevant Patient Information Query.
BREAST_TOMOSYNTHESIS_IMAGE_STORAGE | 192 | Breast Tomosynthesis Image Storage.
CARDIAC_ELECTROPHYSIOLOGY_WAVEFORM_STORAGE | 86 | Cardiac Electrophysiology Waveform Storage.
CARDIAC_RELEVANT_PATIENT_INFORMATION_QUERY | 173 | Cardiac Relevant Patient Information Query.
COLON_CAD_SR_STORAGE | 201 | Colon CAD SR Storage.
COLOR_PALETTE_INFORMATION_MODEL_FIND | 209 | Color Palette Information Model – FIND.
COLOR_PALETTE_INFORMATION_MODEL_GET | 211 | Color Palette Information Model – GET.
COLOR_PALETTE_INFORMATION_MODEL_MOVE | 210 | Color Palette Information Model – MOVE.
COLOR_PALETTE_STORAGE | 208 | Color Palette Storage.
COLOR_SOFTCOPY_PRES_STATE_STORAGE | 91 | Color Softcopy Presentation State Storage SOP Class.
COMPOSITE_INSTANCE_RETRIEVE_WITHOUT_BULK_DATA_GET | 206 | Composite Instance Retrieve Without Bulk Data - GET.
COMPOSITE_INSTANCE_ROOT_RETRIEVE_GET | 205 | Composite Instance Root Retrieve - GET.
COMPOSITE_INSTANCE_ROOT_RETRIEVE_MOVE | 204 | Composite Instance Root Retrieve - MOVE.
CR_STORAGE | 55 | Computed Radiography Image Storage.
CT_ENHANCED_STORAGE | 63 | Enhanced CT Image Storage.
CT_STORAGE | 62 | CT Image storage.
CURVE_STORAGE | 78 | Standalone Curve Storage (Retired).
DEFORMABLE_SPATIAL_REGISTRATION_STORAGE | 105 | Deformable Spatial Registration Storage.
DICOM_APP_CONTEXT | 14 | DICOM Application Context Name.
DICOM_CONTROLLED_TERMINOLOGY | 13 | DICOM Controlled Terminology (Coding Scheme).
DICOM_UID_REGISTRY | 12 | DICOM UID Registry (DICOM UIDs as a Coding Scheme).
DICOS_CT_IMAGE_STORAGE | 219 | DICOS CT Image Storage.
DICOS_DIGITAL_XRAY_IMAGE_STORAGE_FOR_PRESENTATION | 220 | DICOS Digital X-Ray Image Storage - For Presentation.
DICOS_DIGITAL_XRAY_IMAGE_STORAGE_FOR_PROCESSING | 221 | DICOS Digital X-Ray Image Storage - For Processing.
DICOS_THREAT_DETECTION_REPORT_STORAGE | 222 | DICOS Threat Detection Report Storage.
DIGI_INTRA_ORAL_PRES_IMG_STORAGE | 60 | Digital Intra-oral X-Ray Image Storage - For Presentation.
DIGI_INTRA_ORAL_PROC_IMG_STORAGE | 61 | Digital Intra-oral X-Ray Image Storage - For Processing.
DIGI_MAMMO_PRES_IMG_STORAGE | 58 | Digital Mammography X-Ray Image Storage - For Presentation.
DIGI_MAMMO_PROC_IMG_STORAGE | 59 | Digital Mammography X-Ray Image Storage - For Processing.
DIGI_XRAY_PRES_IMG_STORAGE | 56 | Digital X-Ray Image Storage - For Presentation.
DIGI_XRAY_PROC_IMG_STORAGE | 57 | Digital X-Ray Image Storage - For Processing.
EDDY_CURRENT_IMAGE_STORAGE | 223 | Eddy Current Image Storage.
EDDY_CURRENT_MULTIFRAME_IMAGE_STORAGE | 224 | Eddy Current Multi-frame Image Storage.
ENCAPSULATED_CDA_STORAGE | 134 | Encapsulated CDA Storage.
ENCAPSULATED_PDF_STORAGE | 133 | Encapsulated PDF Storage.
ENHANCED_MR_COLOR_IMAGE_STORAGE | 186 | Enhanced MR Color Image Storage.
ENHANCED_PET_IMAGE_STORAGE | 202 | Enhanced PET Image Storage.
ENHANCED_US_VOLUME_STORAGE | 187 | Enhanced US Volume Storage.
ENHANCED_XRF_IMAGE_STORAGE | 97 | Enhanced XRF Image Storage.
GE_MACHINE_STORAGE | 180 | GE Machine Storage.
GE_PLAN_STORAGE | 179 | GE Plan Storage.
GEN_PERFORMED_PROC_STEP | 160 | General Purpose Performed Procedure Step.
GEN_SCHEDULED_PROC_STEP | 159 | General Purpose Scheduled Procedure Step.
GEN_WORKLIST_FIND | 158 | General Purpose Worklist Information Model - FIND.
GEN_WORKLIST_MANAGEMENT_META | 157 | General Purpose Worklist Management Meta SOP Class.
GENERAL_AUDIO_WAVEFORM_STORAGE | 188 | General Audio Waveform Storage.
GENERAL_RELEVANT_PATIENT_INFORMATION_QUERY | 171 | General Relevant Patient Information Query.
GENERIC_IMPLANT_TEMPLATE_INFORMATION_MODEL_FIND | 234 | Generic Implant Template Information Model - FIND.
GENERIC_IMPLANT_TEMPLATE_INFORMATION_MODEL_GET | 236 | Generic Implant Template Information Model - GET.
GENERIC_IMPLANT_TEMPLATE_INFORMATION_MODEL_MOVE | 235 | Generic Implant Template Information Model - MOVE.
GENERIC_IMPLANT_TEMPLATE_STORAGE | 233 | Generic Implant Template Storage.
GRAY_SOFTCOPY_PRES_STATE_STORAGE | 90 | Grayscale Softcopy Presentation State Storage SOP Class.
HANGING_PROTOCOL_INFORMATION_MODEL_FIND | 175 | Hanging Protocol Information Model - FIND.
HANGING_PROTOCOL_INFORMATION_MODEL_GET | 207 | Hanging Protocol Information Model - GET.
HANGING_PROTOCOL_INFORMATION_MODEL_MOVE | 176 | Hanging Protocol Information Model - MOVE.
HANGING_PROTOCOL_STORAGE | 174 | Hanging Protocol Storage.
HARDCOPY_COLOR_STORAGE | 51 | Hardcopy Color Image Storage SOP Class (Retired).
HARDCOPY_GRAYSCALE_STORAGE | 50 | Hardcopy Grayscale Image Storage SOP Class (Retired).
HOT_IRON_COLOR_PALETTE_INSTANCE | 182 | Hot Iron Color Palette SOP Instance (Well-known).
HOT_METAL_BLUE_COLOR_PALETTE_INSTANCE | 184 | Hot Metal Blue Color Palette SOP Instance (Well-known).
IMG_OVLY_BOX | 45 | Image Overlay Box SOP Class (Retired).
IMPLANT_ASSEMBLY_TEMPLATE_INFORMATION_MODEL_FIND | 238 | Implant Assembly Template Information Model - FIND.
IMPLANT_ASSEMBLY_TEMPLATE_INFORMATION_MODEL_GET | 240 | Implant Assembly Template Information Model - GET.
IMPLANT_ASSEMBLY_TEMPLATE_INFORMATION_MODEL_MOVE | 239 | Implant Assembly Template Information Model - MOVE.
IMPLANT_ASSEMBLY_TEMPLATE_STORAGE | 237 | Implant Assembly Template Storage.
IMPLANT_TEMPLATE_GROUP_INFORMATION_MODEL_FIND | 242 | Implant Template Group Information Model - FIND.
IMPLANT_TEMPLATE_GROUP_INFORMATION_MODEL_GET | 244 | Implant Template Group Information Model - GET.
IMPLANT_TEMPLATE_GROUP_INFORMATION_MODEL_MOVE | 243 | Implant Template Group Information Model - MOVE.
IMPLANT_TEMPLATE_GROUP_STORAGE | 241 | Implant Template Group Storage.
IMPLANTATION_PLAIN_SR_STORAGE | 218 | Implantation Plan SR Storage.
INSTANCE_AVAILABILITY_NOTIFICATION | 161 | Instance Availability Notification SOP Class.
INTERP_MGMT_DET | 26 | Detached Interpretation Management SOP Class (Retired).
INTRAOCULAR_LENS_CALCULATIONS_STORAGE | 216 | Intraocular Lens Calculations Storage.
INTRAVASCULAR_OPTICAL_COHERENCE_TOMOGRAPHY_IMAGE_STORAGE_FOR_PRESENTATION | 212 | Intravascular Optical Coherence Tomography Image Storage - For Presentation.
INTRAVASCULAR_OPTICAL_COHERENCE_TOMOGRAPHY_IMAGE_STORAGE_FOR_PROCESSING | 213 | Intravascular Optical Coherence Tomography Image Storage - For Processing.
KERATOMETRY_MEASUREMENTS_STORAGE | 196 | Keratometry Measurements Storage.
KEY_OBJECT_SELECTION_DOCUMENT | 130 | Key Object Selection Document Storage.
LENSOMETRY_MEASUREMENTS_STORAGE | 194 | Lensometry Measurements Storage.
MACULAR_GRID_THICKNESS_AND_VOLUME_REPORT_STORAGE | 200 | Macular Grid Thickness and Volume Report Storage.
MEDIA_CREATION_MANAGEMENT_UID | 54 | Media Creation Management UID SOP Class.
MEDIA_STORAGE_DIR_STORAGE | 2 | Media Storage Directory Storage.
MOD_LUT_STORAGE | 88 | Standalone Modality LUT Storage (Retired).
MOD_PERF_PROC_STEP | 20 | Modality Performed Procedure Step SOP Class.
MOD_PERF_PROC_STEP_NOTIFY | 22 | Modality Performed Procedure Step Notification SOP Class.
MOD_PERF_PROC_STEP_RETRIEVE | 21 | Modality Performed Procedure Step Retrieve SOP Class.
MODALITY_WORKLIST_FIND | 156 | Modality Worklist Information Model - FIND.
MR_ENHANCED_IMAGE_STORAGE | 67 | Enhanced MR Image Storage.
MR_SPECTROSCOPY_STORAGE | 68 | MR Spectroscopy Storage.
MR_STORAGE | 66 | MR Image Storage.
MSICOM3_LZW_STORAGE | 181 | MsiCOM3 LZW storage.
NATIVE_DICOM_MODEL | 245 | Native DICOM Model.
NM_STORAGE | 101 | Nuclear Medicine Image storage.
NM_STORAGE__RET | 69 | Nuclear Medicine Image Storage (Retired).
NULL | 0 | Null class.
OPHTALMIC_AXIAL_MEASUREMENTS_STORAGE | 215 | Ophthalmic Axial Measurements Storage.
OPHTALMIC_VISUAL_FILED_STATIC_PERIMETRY_MEASUREMENTS_STORAGE | 217 | Ophthalmic Visual Field Static Perimetry Measurements Storage.
OPHTHALMIC_PHOTOGRAPHY_16_BIT_IMAGE_STORAGE | 118 | Ophthalmic Photography 16 Bit Image Storage.
OPHTHALMIC_PHOTOGRAPHY_8_BIT_IMAGE_STORAGE | 117 | Ophthalmic Photography 8 Bit Image Storage.
OPHTHALMIC_TOMOGRAPHY_IMAGE_STORAGE | 120 | Ophthalmic Tomography Image Storage.
OVERLAY_STORAGE | 77 | Standalone Overlay Storage (Retired).
PAT_MGMT_DET | 15 | Detached Patient Management SOP Class (Retired).
PAT_MGMT_META | 16 | Detached Patient Management Meta SOP Class (Retired).
PAT_ROOT_QR_FIND | 147 | Patient Root Query/Retrieve Information Model - FIND.
PAT_ROOT_QR_GET | 149 | Patient Root Query/Retrieve Information Model - GET.
PAT_ROOT_QR_MOVE | 148 | Patient Root Query/Retrieve Information Model - MOVE.
PAT_STUDY_ROOT_QR_FIND | 153 | Patient/Study Only Query/Retrieve Information Model - FIND (Retired).
PAT_STUDY_ROOT_QR_GET | 155 | Patient/Study Only Query/Retrieve Information Model - GET (Retired).
PAT_STUDY_ROOT_QR_MOVE | 154 | Patient/Study Only Query/Retrieve Information Model - MOVE (Retired).
PET_20_STEP_COLOR_PALETTE_INSTANCE | 185 | PET 20 Step Color Palette SOP Instance (Well-known).
PET_COLOR_PALETTE_INSTANCE | 183 | PET Color Palette SOP Instance (Well-known).
PET_CURVE_STORAGE | 136 | Standalone PET Curve Storage (Retired).
PET_STORAGE | 135 | Positron Emission Tomography Image Storage.
PRESENTATION_LUT | 44 | Presentation LUT SOP Class.
PRINT_JOB | 35 | Print Job SOP Class.
PRINT_QUEUE_INSTANCE | 47 | Print Queue SOP Instance (Well-known) (Retired).
PRINT_QUEUE_MGMT | 48 | Print Queue Management SOP Class (Retired).
PRINTER | 37 | Printer SOP Class.
PRINTER_CONFIGURATION_RETRIEVAL | 38 | Printer Configuration Retrieval SOP Class.
PRINTER_CONFIGURATION_RETRIEVAL_INSTANCE | 40 | Printer Configuration Retrieval SOP Instance (Well-known).
PRINTER_INSTANCE | 39 | Printer SOP Instance (Well-known).
PROCEDURAL_EVENT_LOGGING | 8 | Procedural Event Logging SOP Class.
PROCEDURAL_EVENT_LOGGING_INSTANCE | 9 | Procedural Event Logging SOP Instance (Well-known).
PROCEDURE_LOG | 128 | Procedure Log Storage.
PRODUCT_CHARACTERISTICS | 177 | Product Characteristics Query SOP Class.
PSEUDO_COLOR_SOFTCOPY_PRES_STATE_STORAGE | 92 | Pseudo-Color Softcopy Presentation State Storage SOP Class.
PULL_PRINT_REQUEST | 52 | Pull Print Request SOP Class (Retired).
PULL_STORED_PRINT_MGMT_META | 53 | Pull Stored Print Management Meta SOP Class (Retired).
RAW_DATA_STORAGE | 102 | RAW data storage.
REAL_WORLD_VALUE_MAPPING_STORAGE | 107 | Real World Value Mapping Storage.
REF_COLOR_PRINT_MGMT_META | 42 | Referenced Color Print Management Meta SOP class (Retired).
REF_GRAY_PRINT_MGMT_META | 34 | Referenced Grayscale Print Management Meta SOP Class (Retired).
REF_IMG_BOX | 32 | Reference Image Box SOP Class (Retired).
RESPIRATORY_WAVEFORM_STORAGE | 190 | Respiratory Waveform Storage.
RESULT_MGMT_DET | 23 | Detached Results Management SOP Class (Retired).
RESULT_MGMT_META | 24 | Detached Results Management Meta SOP Class (Retired).
RT_BEAMS_DELIVERY_INSTRUCTION_STORAGE | 230 | RT Beams Delivery Instruction Storage.
RT_BEAMS_DELIVERY_INSTRUCTION_STORAGE_TRIAL | 162 | RT Beams Delivery Instruction Storage - Trial (Retired).
RT_BEAMS_TREATMENT_RECORD_STORAGE | 140 | RT Beams Treatment Record Storage.
RT_BRACHY_TREATMENT_RECORD_STORAGE | 143 | RT Brachy Treatment Record Storage.
RT_CONVENTIONAL_MACHINE_VERIFICATION | 231 | RT Conventional Machine Verification.
RT_CONVENTIONAL_MACHINE_VERIFICATION_TRIAL | 163 | RT Conventional Machine Verification - Trial (Retired).
RT_DOSE_STORAGE | 138 | RT Dose Storage.
RT_IMG_STORAGE | 137 | RT image storage.
RT_ION_BEAMS_TREATMENT_RECORD_STORAGE | 146 | RT Ion Beams Treatment Record Storage.
RT_ION_MACHINE_VERIFICATION | 232 | RT Ion Machine Verification.
RT_ION_MACHINE_VERIFICATION_TRIAL | 164 | RT Ion Machine Verification - Trial (Retired).
RT_ION_PLAN_STORAGE | 145 | RT Ion Plan Storage.
RT_PLAN_STORAGE | 142 | RT Plan Storage.
RT_STRUCTURE_SET_STORAGE | 139 | RT Structure Set Storage.
RT_TREATMENT_RECORD_STORAGE | 141 | RT Beams Treatment Record Storage.
RT_TREATMENT_SUMMARY_RECORD_STORAGE | 144 | RT Treatment Summary Record Storage.
SC_MF_GRAYSCALE_BYTE_IMAGE_STORAGE | 74 | Multiframe Grayscale Byte Secondary Capture Image Storage.
SC_MF_GRAYSCALE_WORD_IMAGE_STORAGE | 75 | Multiframe Grayscale Word Secondary Capture Image Storage.
SC_MF_SINGLE_BIT_IMAGE_STORAGE | 73 | Multiframe Single Bit Secondary Capture Image Storage.
SC_MF_TRUE_COLOR_IMAGE_STORAGE | 76 | Multiframe True Color Secondary Capture Image Storage.
SC_STORAGE | 72 | Secondary Capture Image Storage.
SEGMENTATION_STORAGE | 106 | Segmentation Storage.
SPATIAL_FIDUCIALS_STORAGE | 104 | Spatial Fiducials Storage.
SPATIAL_REGISTRATION_STORAGE | 103 | Spatial Registration Storage.
SPECTACLE_PRESCRIPTION_REPORTS_STORAGE | 199 | Spectacle Prescription Reports Storage.
SR_AUDIO_STORAGE | 122 | Audio SR Storage - Trial (Retired).
SR_BASIC_TEXT | 125 | Basic Text SR Storage.
SR_CHEST_CAD | 131 | Chest CAD SR Storage.
SR_COMPREHENSIVE | 127 | Comprehensive SR Storage.
SR_COMPREHENSIVE_STORAGE | 124 | Comprehensive SR Storage - Trial (Retired).
SR_DETAIL_STORAGE | 123 | Detail SR Storage - Trial (Retired).
SR_ENHANCED | 126 | Enhanced SR Storage.
SR_MAMMO_CAD | 129 | Mammography CAD SR Storage.
SR_TEXT_STORAGE | 121 | Text SR Storage - Trial (Retired).
STEREOMETRIC_RELATIONSHIP_STORAGE | 119 | Stereometric Relationship Storage.
STORAGE_COMMITMENT_PULL_CLASS | 6 | Storage Commitment Pull Model SOP Class (Retired).
STORAGE_COMMITMENT_PULL_INSTANCE | 7 | Storage Commitment Pull Model SOP Instance (Well-known) (Retired).
STORAGE_COMMITMENT_PUSH_CLASS | 4 | Storage Commitment Push Model SOP Class.
STORAGE_COMMITMENT_PUSH_INSTANCE | 5 | Storage Commitment Push Model SOP Instance (Well-known).
STORAGE_SERVICE_CLASS | 27 | Storage Service Class.
STORED_PRINT_STORAGE | 49 | Stored Print Storage SOP Class (Retired).
STUDY_MGMT_COMP | 19 | Study Component Management SOP Class (Retired).
STUDY_MGMT_DET | 18 | Detached Study Management SOP Class (Retired).
STUDY_MGMT_META | 25 | Detached Study Management Meta SOP Class (Retired).
STUDY_ROOT_QR_FIND | 150 | Study Root Query/Retrieve Information Model - FIND.
STUDY_ROOT_QR_GET | 152 | Study Root Query/Retrieve Information Model - GET.
STUDY_ROOT_QR_MOVE | 151 | Study Root Query/Retrieve Information Model - MOVE.
SUBJECTIVE_REFRACTION_MEASUREMENTS_STORAGE | 197 | Subjective Refraction Measurements Storage.
SUBSTANCE_ADMINISTRATION_LOGGING | 10 | Substance Administration Logging SOP Class.
SUBSTANCE_ADMINISTRATION_LOGGING_INSTANCE | 11 | Substance Administration Logging SOP Instance (Well-known).
SUBSTANCE_APPROVAL_QUERY | 178 | Substance Approval Query SOP Class.
SURFACE_SEGMENTATION_STORAGE | 193 | Surface Segmentation Storage.
UNIFIED_PROC_STEP_EVENT | 169 | Unified Procedure Step - Event SOP Class - Trial (Retired).
UNIFIED_PROC_STEP_PULL | 168 | Unified Procedure Step - Pull SOP Class - Trial (Retired).
UNIFIED_PROC_STEP_PUSH | 166 | Unified Procedure Step - Push SOP Class - Trial (Retired).
UNIFIED_PROC_STEP_WATCH | 167 | Unified Procedure Step - Watch SOP Class - Trial (Retired).
UNIFIED_PROCEDURE_STEP_EVENT | 229 | Unified Procedure Step - Event SOP Class.
UNIFIED_PROCEDURE_STEP_PULL | 228 | Unified Procedure Step - Pull SOP Class.
UNIFIED_PROCEDURE_STEP_PUSH | 226 | Unified Procedure Step - Push SOP Class.
UNIFIED_PROCEDURE_STEP_WATCH | 227 | Unified Procedure Step - Watch SOP Class.
UNIFIED_WORKLIST_AND_PROCEDURE_STEP_SERVICE_CLASS | 225 | Unified Worklist and Procedure Step Service Class.
UNIFIED_WORKLIST_PROC_STEP_INSTANCE | 170 | Unified Worklist and Procedure Step SOP Instance (Well-known).
UNIFIED_WORKLIST_PROC_STEP_SERVICE_CLASS | 165 | Unified Worklist and Procedure Step Service class - Trial (Retired).
US_STORAGE | 71 | Ultrasound Image Storage.
US_STORAGE__RET | 70 | Ultrasound Image Storage (Retired).
USMF_STORAGE | 65 | Ultrasound Multi-frame Image Storage.
USMF_STORAGE__RET | 64 | Ultrasound Multi-frame Image Storage (Retired).
VERIFICATION | 1 | Verification SOP Class.
VIDEO_ENDOSCOPIC_IMAGE_STORAGE | 111 | Video Endoscopic Image Storage.
VIDEO_MICROSCOPIC_IMAGE_STORAGE | 113 | Video Microscopic Image Storage.
VIDEO_PHOTOGRAPHIC_IMAGE_STORAGE | 116 | Video Photographic Image Storage.
VISIT_MGMT_DET | 17 | Detached Visit Management SOP Class (Retired).
VISUAL_ACUITY_MEASUREMENTS_STORAGE | 198 | Visual Acuity Measurements Storage.
VL_ENDO_IMG_STORAGE | 110 | VL Endoscopic Image Storage.
VL_IMG_STORAGE | 108 | VL Image Storage - Trial (Retired).
VL_MICRO_IMG_STORAGE | 112 | VL Microscopic Image Storage.
VL_MULTIFRAME_IMG_STORAGE | 109 | VL Multi-frame Image Storage - Trial (Retired).
VL_PHOTO_IMG_STORAGE | 115 | VL Photographic Image Storage.
VL_SLIDE_MICRO_IMG_STORAGE | 114 | VL Slide-Coordinates Microscopic Image Storage.
VL_WHOLE_SLIDE_MICROSCOPY_IMAGE_STORAGE | 214 | VL Whole Slide Microscopy Image Storage.
VOI_LUT_BOX | 43 | VOI LUT Box SOP Class.
VOI_LUT_STORAGE | 89 | Standalone VOI LUT Storage (Retired).
WAVEFORM_12_LEAD_ECG_STORAGE | 80 | 12-lead ECG Waveform Storage.
WAVEFORM_AUDIO_STORAGE | 83 | Waveform Audio Storage.
WAVEFORM_ECG_STORAGE | 81 | General ECG Waveform Storage.
WAVEFORM_GEN_ECG_STORAGE | 82 | General ECG Waveform Storage.
WAVEFORM_HEMO_STORAGE | 85 | Hemodynamic Waveform Storage.
WAVEFORM_STORAGE | 79 | Waveform Storage - Trial (Retired).
XA_XRF_GRAYSCALE_SOFTCOPY_PRES_STATE_STORAGE | 191 | XA/XRF Grayscale Softcopy Presentation State Storage SOP Class.
XRAY_3D_ANGIOGRAPHIC_STORAGE | 99 | X-Ray 3D Angiographic Image Storage.
XRAY_3D_CRANIOFACIAL_STORAGE | 100 | X-Ray 3D Craniofacial Image Storage.
XRAY_ANGIO_BI_PLANE_STORAGE | 98 | X-Ray Angiographic Bi-Plane Image storage (Retired).
XRAY_ANGIO_STORAGE | 94 | X-Ray Angiographic Image Storage.
XRAY_ENHANCED_XA_IMAGE_STORAGE | 95 | Enhanced XA Image Storage.
XRAY_RADIATION_DOSE_SR_STORAGE | 132 | X-Ray Radiation Dose SR Storage.
XRAY_RF_STORAGE | 96 | X-Ray Radiofluoroscopic Image Storage.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMServiceObjectPairs

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMTagsIDs Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMTagsIDs Enumeration
Specifies DICOM tag identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMTagsIDs
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMTagsIDs
public enum ImGearDICOMTagsIDs : System.Enum
__value public enum ImGearDICOMTagsIDs : public System.Enum
public enum class ImGearDICOMTagsIDs : public System.Enum
Members
Member | Value | Description
AbortFlag | 0x40101024 | Abort Flag.
AbortReason | 0x40101021 | Abort Reason.
AbsoluteChannelDisplayScale | 0x003A0248 | Absolute Channel Display Scale.
AbstractPriorCodeSequence | 0x0072003E | Abstract Prior Code Sequence.
AbstractPriorValue | 0x0072003C | Abstract Prior Value.
AccessionNumber | 0x00080050 | Accession Number.
AccessoryCode | 0x300A00F9 | Accessory Code.
AcqStartCondition | 0x00180073 | Acquisition Start Condition. This tag name has been deprecated, use tag with the same value defined in the previous line.
AcqStartConditionData | 0x00180074 | Acquisition Start Condition Data. This tag name has been deprecated, use tag with the same value defined in the previous line.
AcqStopConditionData | 0x00180075 | Acquisition Termination Condition Data. This tag name has been deprecated, use tag with the same value defined in the previous line.
AcquiredImageAreaDoseProduct | 0x00189473 | Acquired Image Area Dose Product.
AcquiredSoundpathLength | 0x00144031 | Acquired Soundpath Length.
AcquisitionComments | 0x00184000 | Acquisition Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AcquisitionCompressionType | 0x00144032 | Acquisition Compression Type.
AcquisitionContextDesc | 0x00400556 | Acquisition Context Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
AcquisitionContextDescription | 0x00400556 | Acquisition Context Description.
AcquisitionContextSequence | 0x00400555 | Acquisition Context Sequence.
AcquisitionContrast | 0x00089209 | Acquisition Contrast.
AcquisitionDate | 0x00080022 | Acquisition Date.
AcquisitionDatetime | 0x0008002A | Acquisition DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
AcquisitionDateTime | 0x0008002A | Acquisition DateTime.
AcquisitionDeviceProcessingCode | 0x00181401 | Acquisition Device Processing Code.
AcquisitionDeviceProcessingDescription | 0x00181400 | Acquisition Device Processing Description.
AcquisitionDeviceTypeCodeSequence | 0x00220015 | Acquisition Device Type Code Sequence.
AcquisitionDuration | 0x00189073 | Acquisition Duration.
AcquisitionIndex | 0x00209518 | Acquisition Index.
AcquisitionMatrix | 0x00181310 | Acquisition Matrix.
AcquisitionNumber | 0x00200012 | Acquisition Number.
AcquisitionProtocolDescription | 0x00189424 | Acquisition Protocol Description.
AcquisitionProtocolName | 0x00189423 | Acquisition Protocol Name.
AcquisitionSampleSize | 0x00144033 | Acquisition Sample Size.
AcquisitionsInSeries | 0x00201001 | Acquisitions in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AcquisitionsInStudy | 0x00201004 | Acquisitions in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AcquisitionStartCondition | 0x00180073 | Acquisition Start Condition.
AcquisitionStartConditionData | 0x00180074 | Acquisition Start Condition Data.
AcquisitionStatus | 0x40101044 | Acquisition Status.
AcquisitionTerminationCondition | 0x00180071 | Acquisition Termination Condition.
AcquisitionTerminationConditionData | 0x00180075 | Acquisition Termination Condition Data.
AcquisitionTime | 0x00080032 | Acquisition Time.
AcquisitionTimeSynchronized | 0x00181800 | Acquisition Time Synchronized.
AcquisitionType | 0x00189302 | Acquisition Type.
AcrossScanSpatialResolution | 0x00220048 | Across-scan Spatial Resolution.
ActionTypeID | 0x00001008 | Action Type ID.
ActiveSourceDiameter | 0x300A0218 | Active Source Diameter.
ActiveSourceLength | 0x300A021A | Active Source Length.
ActualCardiacTriggerDelayTime | 0x00209252 | Actual Cardiac Trigger Delay Time.
ActualCardiacTriggerTimePriorToRPeak | 0x00209155 | Actual Cardiac Trigger Time Prior To R-Peak.
ActualEnvironmentalConditions | 0x00141010 | Actual Environmental Conditions.
ActualFrameDuration | 0x00181242 | Actual Frame Duration.
ActualHumanPerformerSequence | 0x00404035 | Actual Human Performers Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ActualHumanPerformersSequence | 0x00404035 | Actual Human Performers Sequence.
ActualRespiratoryTriggerDelayTime | 0x00209257 | Actual Respiratory Trigger Delay Time.
AdaptiveMapFormat | 0x00280730 | Adaptive Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AddGrayScale | 0x00005150 | Add Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AddIntermediateSequence | 0x00460101 | Add Intermediate Sequence.
AdditionalDrugSequence | 0x0018002A | Additional Drug Sequence.
AdditionalPatientHistory | 0x001021B0 | Additional Patient History.
AddNearSequence | 0x00460100 | Add Near Sequence.
AddOtherSequence | 0x00460102 | Add Other Sequence.
AddPower | 0x00460104 | Add Power.
Address | 0x0040A353 | Address (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AddressTrial | 0x0040A353 | Address (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AdministrationRouteCodeSequence | 0x00540302 | Administration Route Code Sequence.
AdmissionID | 0x00380010 | Admission ID.
AdmittingDate | 0x00380020 | Admitting Date.
AdmittingDiagnosesCodeSequence | 0x00081084 | Admitting Diagnoses Code Sequence.
AdmittingDiagnosesDescription | 0x00081080 | Admitting Diagnoses Description.
AdmittingDiagnosisCodeSequence | 0x00081084 | Admitting Diagnoses Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
AdmittingTime | 0x00380021 | Admitting Time.
AffectedSOPClassUID | 0x00000002 | Affected SOP Class UID.
AffectedSOPInstanceUID | 0x00001000 | Affected SOP Instance UID.
AgeCorrectedSensitivityDeviationAlgorithmSequence | 0x00240065 | Age Corrected Sensitivity Deviation Algorithm Sequence.
AgeCorrectedSensitivityDeviationProbabilityValue | 0x00240100 | Age Corrected Sensitivity Deviation Probability Value.
AgeCorrectedSensitivityDeviationValue | 0x00240092 | Age Corrected Sensitivity Deviation Value.
AirCounts | 0x00143070 | Air Counts.
AlarmDecision | 0x40101031 | Alarm Decision.
AlarmDecisionTime | 0x4010102B | Alarm Decision Time.
AlertCodeSequence | 0x0040A057 | Alert Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
AlgorithmCodeSequenceTrial | 0x0040A296 | Algorithm Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AlgorithmDescription | 0x00189528 | Algorithm Description.
AlgorithmDescriptionTrial | 0x0040A297 | Algorithm Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AlgorithmFamilyCodeSequence | 0x0066002F | Algorithm Family Code Sequence.
AlgorithmName | 0x00660036 | Algorithm Name.
AlgorithmNameCodeSequence | 0x00660030 | Algorithm Name Code Sequence.
AlgorithmParameters | 0x00660032 | Algorithm Parameters.
AlgorithmRoutingCodeSequence | 0x40101064 | Algorithm Routing Code Sequence.
AlgorithmSource | 0x00240202 | Algorithm Source.
AlgorithmType | 0x00189527 | Algorithm Type.
AlgorithmVersion | 0x00660031 | Algorithm Version.
AliasedDataType | 0x0018980B | Aliased Data Type.
ALinePixelSpacing | 0x00520014 | A?line Pixel Spacing.
ALineRate | 0x00520011 | A?line Rate.
ALinesPerFrame | 0x00520012 | A?lines Per Frame.
Allergies | 0x00102110 | Allergies value.
AllowLossyCompression | 0x2200000F | Allow Lossy Compression.
AllowMediaSplitting | 0x22000007 | Allow Media Splitting.
AlongScanSpatialResolution | 0x00220037 | Along-scan Spatial Resolution.
AlphaLUTTransferFunction | 0x00281410 | Alpha LUT Transfer Function.
AlphaPaletteColorLookupTableData | 0x00281204 | Alpha Palette Color Lookup Table Data.
AlphaPaletteColorLookupTableDescriptor | 0x00281104 | Alpha Palette Color Lookup Table Descriptor.
AlternateContainerIdentifierSequence | 0x00400515 | Alternate Container Identifier Sequence.
AlternateContentDescriptionSequence | 0x00700087 | Alternate Content Description Sequence.
AlternateRepresentationSequence | 0x00083001 | Alternate Representation Sequence.
AmplifierType | 0x0014400A | Amplifier Type.
AnatomicalOrientationType | 0x00102210 | Anatomical Orientation Type.
AnatomicApproachDirectionCodeSequence | 0x00082255 | Anatomic Approach Direction Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicLocationOfExaminingInstrumentCodeSequence | 0x00082259 | Anatomic Location Of Examining Instrument Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicLocationOfExaminingInstrumentDescription | 0x00082258 | Anatomic Location Of Examining Instrument Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicPerspectiveCodeSequence | 0x00082257 | Anatomic Perspective Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicPerspectiveDescription | 0x00082256 | Anatomic Perspective Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicPortalOfEntranceCodeSequence | 0x00082253 | Anatomic Portal Of Entrance Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicRegionModifierSequence | 0x00082220 | Anatomic Region Modifier Sequence.
AnatomicRegionSequence | 0x00082218 | Anatomic Region Sequence.
AnatomicStructure | 0x00082208 | Anatomic Structure.
AnatomicStructureSpaceOrRegionCodeSequence | 0x00082251 | Anatomic Structure Space Or Region Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicStructureSpaceOrRegionModifierCodeSequence | 0x0008225A | Anatomic Structure Space Or Region Modifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnatomicStructureSpaceOrRegionSequence | 0x00082229 | Anatomic Structure, Space or Region Sequence.
AnatomicStructureSpaceRegionSequence | 0x00082229 | Anatomic Structure, Space or Region Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
AnchorPoint | 0x00700014 | Anchor Point.
AnchorPointAnnotationUnits | 0x00700004 | Anchor Point Annotation Units.
AnchorPointVisibility | 0x00700015 | Anchor Point Visibility.
AngioFlag | 0x00180025 | Angio Flag.
AngleNumber | 0x00200018 | Angle Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AngularPosition | 0x00181141 | Angular Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AngularStep | 0x00181144 | Angular Step.
AngularViewVector | 0x00540090 | Angular View Vector.
AnnotationContentSequence | 0x21300050 | Annotation Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnnotationDisplayFormatID | 0x20100030 | Annotation Display Format ID.
AnnotationFlag | 0x20000065 | Annotation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AnnotationGroupNumber | 0x0040A180 | Annotation Group Number.
AnnotationPosition | 0x20300010 | Annotation Position.
AnnotationSequence | 0x0040B020 | Waveform Annotation Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
AnodeTargetMaterial | 0x00181191 | Anode Target Material.
AnteriorChamberDepth | 0x00221131 | Anterior Chamber Depth.
AnteriorChamberDepthDefinitionCodeSequence | 0x00221125 | Anterior Chamber Depth Definition Code Sequence.
ApexPosition | 0x00209308 | Apex Position.
ApplicableFrameRange | 0x00286102 | Applicable Frame Range.
ApplicableSafetyStandardAgency | 0x00189174 | Applicable Safety Standard Agency.
ApplicableSafetyStandardDesc | 0x00189175 | Applicable Safety Standard Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
ApplicableSafetyStandardDescription | 0x00189175 | Applicable Safety Standard Description.
ApplicationManufacturer | 0x00189526 | Application Manufacturer.
ApplicationMaximumRepaintTime | 0x0072010E | Application Maximum Repaint Time.
ApplicationName | 0x00189524 | Application Name.
ApplicationSetupCheck | 0x30080116 | Application Setup Check.
ApplicationSetupManufacturer | 0x300A0238 | Application Setup Manufacturer.
ApplicationSetupName | 0x300A0236 | Application Setup Name.
ApplicationSetupNumber | 0x300A0234 | Application Setup Number.
ApplicationSetupSequence | 0x300A0230 | Application Setup Sequence.
ApplicationSetupType | 0x300A0232 | Application Setup Type.
ApplicationVersion | 0x00189525 | Application Version.
ApplicatorApertureShape | 0x300A0432 | Applicator Aperture Shape.
ApplicatorDescription | 0x300A010A | Applicator Description.
ApplicatorGeometrySequence | 0x300A0431 | Applicator Geometry Sequence.
ApplicatorID | 0x300A0108 | Applicator ID.
ApplicatorOpening | 0x300A0433 | Applicator Opening.
ApplicatorOpeningX | 0x300A0434 | Applicator Opening X.
ApplicatorOpeningY | 0x300A0435 | Applicator Opening Y.
ApplicatorSequence | 0x300A0107 | Applicator Sequence.
ApplicatorType | 0x300A0109 | Applicator Type.
ApprovalStatus | 0x300E0002 | Approval Status.
ApprovalStatusDateTime | 0x00440004 | Approval Status DateTime.
ApprovalStatusFurtherDescription | 0x00440003 | Approval Status Further Description.
AppSetupCheck | 0x30080116 | Application Setup Check. This tag name has been deprecated, use tag with the same value defined in the previous line.
Arbitrary | 0x40000010 | Arbitrary. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ArchiveRequested | 0x0040A494 | Archive Requested.
ArterialSpinLabelingContrast | 0x00189250 | Arterial Spin Labeling Contrast.
ASLBolusCutoffDelayTime | 0x0018925F | ASL Bolus Cut-off Delay Time.
ASLBolusCutoffFlag | 0x0018925C | ASL Bolus Cut-off Flag.
ASLBolusCutoffTechnique | 0x0018925E | ASL Bolus Cut-off Technique.
ASLBolusCutoffTimingSequence | 0x0018925D | ASL Bolus Cut-off Timing Sequence.
ASLContext | 0x00189257 | ASL Context.
ASLCrusherDescription | 0x0018925B | ASL Crusher Description.
ASLCrusherFlag | 0x00189259 | ASL Crusher Flag.
ASLCrusherFlow | 0x0018925A | ASL Crusher Flow.
ASLMidSlabPosition | 0x00189256 | ASL Mid Slab Position.
ASLPulseTrainDuration | 0x00189258 | ASL Pulse Train Duration.
ASLSlabNumber | 0x00189253 | ASL Slab Number.
ASLSlabOrientation | 0x00189255 | ASL Slab Orientation.
ASLSlabSequence | 0x00189260 | ASL Slab Sequence.
ASLSlabThickness | 0x00189254 | ASL Slab Thickness.
ASLTechniqueDescription | 0x00189252 | ASL Technique Description.
AssignedLocation | 0x4010102A | Assigned Location.
AssigningAgencyOrDepartmentCodeSequence | 0x0040003A | Assigning Agency or Department Code Sequence.
AssigningFacilitySequence | 0x00400036 | Assigning Facility Sequence.
AssigningJurisdictionCodeSequence | 0x00400039 | Assigning Jurisdiction Code Sequence.
ATDAbilityAssessment | 0x40101014 | ATD Ability Assessment.
ATDAssessmentFlag | 0x40101015 | ATD Assessment Flag.
ATDAssessmentProbability | 0x40101016 | ATD Assessment Probability.
ATDAssessmentSequence | 0x40101038 | ATD Assessment Sequence.
AttachedContours | 0x30060049 | Attached Contours.
AttenuationCorrected | 0x00189759 | Attenuation Corrected.
AttenuationCorrectionMethod | 0x00541101 | Attenuation Correction Method.
AttenuationCorrectionSource | 0x00189738 | Attenuation Correction Source.
AttenuationCorrectionTemporalRelationship | 0x00189770 | Attenuation Correction Temporal Relationship.
AttributeIdentifierList | 0x00001005 | Attribute Identifier List.
AttributeItemSelector | 0x00741054 | Attribute Item Selector.
AttributeModificationDatetime | 0x04000562 | Attribute Modification DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
AttributeModificationDateTime | 0x04000562 | Attribute Modification DateTime.
AttributeOccurrencePointer | 0x00741052 | Attribute Occurrence Pointer.
AttributeOccurrencePrivateCreator | 0x00741056 | Attribute Occurrence Private Creator.
AttributeOccurrenceSequence | 0x00741050 | Attribute Occurrence Sequence.
AudioComments | 0x50FF200E | Audio Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AudioSampleData | 0x50FF200C | Audio Sample Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AudioSampleFormat | 0x50FF2002 | Audio Sample Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AudioType | 0x50FF2000 | Audio Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AuthorizationEquipmentCertificationNumber | 0x01000426 | Authorization Equipment Certification Number.
AuthorObserverSequence | 0x0040A078 | Author Observer Sequence.
AutorefractionLeftEyeSequence | 0x00460052 | Autorefraction Left Eye Sequence.
AutorefractionRightEyeSequence | 0x00460050 | Autorefraction Right Eye Sequence.
AveragePulseWidth | 0x00181154 | Average Pulse Width.
AxialAcceptance | 0x00541200 | Axial Acceptance.
AxialDetectorDimension | 0x00189727 | Axial Detector Dimension.
AxialLengthOfTheEye | 0x00220030 | Axial Length of the Eye.
AxialMash | 0x00541201 | Axial Mash.
AxialResolution | 0x00520008 | Axial Resolution.
AxisLabels | 0x50FF0040 | Axis Labels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
AxisOfRotation | 0x0066001B | Axis of Rotation.
AxisUnits | 0x50FF0030 | Axis Units. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BackgroundColor | 0x00460092 | Background Color.
BackgroundIlluminationColorCodeSequence | 0x00240024 | Background Illumination Color Code Sequence.
BackgroundLuminance | 0x00240020 | Background Luminance.
BadPixelImage | 0x00143080 | Bad Pixel Image.
BarcodeSymbology | 0x22000006 | Barcode Symbology.
BarcodeValue | 0x22000005 | Barcode Value.
BaselineCorrection | 0x00189067 | Baseline Correction.
BasicColorImageSequence | 0x20200111 | Basic Color Image Sequence.
BasicGrayscaleImageSequence | 0x20200110 | Basic Grayscale Image Sequence.
BasisMaterialsCodeSequence | 0x40101045 | Basis Materials Code Sequence.
BeamAngle | 0x00189449 | Beam Angle.
BeamCurrentModulationID | 0x300A034C | Beam Current Modulation ID.
BeamDescription | 0x300A00C3 | Beam Description.
BeamDose | 0x300A0084 | Beam Dose.
BeamDosePointDepth | 0x300A0088 | Beam Dose Point Depth.
BeamDosePointEquivalentDepth | 0x300A0089 | Beam Dose Point Equivalent Depth.
BeamDosePointSSD | 0x300A008A | Beam Dose Point SSD.
BeamDoseSpecificationPoint | 0x300A0082 | Beam Dose Specification Point.
BeamLimitingDeviceAngle | 0x300A0120 | Beam Limiting Device Angle.
BeamLimitingDeviceAngleTolerance | 0x300A0046 | Beam Limiting Device Angle Tolerance.
BeamLimitingDeviceLeafPairSequence | 0x300800A0 | Beam Limiting Device Leaf Pairs Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
BeamLimitingDeviceLeafPairsSequence | 0x300800A0 | Beam Limiting Device Leaf Pairs Sequence.
BeamLimitingDevicePositionSequence | 0x300A011A | Beam Limiting Device Position Sequence.
BeamLimitingDevicePositionTolerance | 0x300A004A | Beam Limiting Device Position Tolerance.
BeamLimitingDeviceRotationDirection | 0x300A0121 | Beam Limiting Device Rotation Direction.
BeamLimitingDeviceSequence | 0x300A00B6 | Beam Limiting Device Sequence.
BeamLimitingDeviceToleranceSequence | 0x300A0048 | Beam Limiting Device Tolerance Sequence.
BeamMeterset | 0x300A0086 | Beam Meterset.
BeamName | 0x300A00C2 | Beam Name.
BeamNumber | 0x300A00C0 | Beam Number.
BeamOrderIndex | 0x00741324 | Beam Order Index.
BeamOrderIndexTrial | 0x00741024 | Beam Order Index (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BeamSequence | 0x300A00B0 | Beam Sequence.
BeamSpotSize | 0x00520003 | Beam Spot Size.
BeamStopperPosition | 0x30080230 | Beam Stopper Position.
BeamTaskSequence | 0x00741020 | Beam Task Sequence.
BeamTaskType | 0x00741022 | Beam Task Type.
BeamType | 0x300A00C4 | Beam Type.
BeatRejectionFlag | 0x00181080 | Beat Rejection Flag.
BeltHeight | 0x40101062 | Belt Height.
BibliographicCitationTrial | 0x0040A16A | Bibliographic Citation (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BillingItemSequence | 0x00400296 | Billing Item Sequence.
BillingProcedureStepSequence | 0x00400320 | Billing Procedure Step Sequence.
BillingSuppliesAndDevicesSequence | 0x00400324 | Billing Supplies and Devices Sequence.
BillingSupplyDeviceSequence | 0x00400324 | Billing Supplies and Devices Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
BiPlaneAcquisitionSequence | 0x00285000 | Bi-Plane Acquisition Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BitAllocated | 0x60FF0100 | Overlay Bits Allocated. This tag name has been deprecated, use tag with the same value defined in the previous line.
BitPosition | 0x60FF0102 | Overlay Bit Position. This tag name has been deprecated, use tag with the same value defined in the previous line.
BitsAllocated | 0x00280100 | Bits Allocated.
BitsForCodeWord | 0x002808F4 | Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BitsGrouped | 0x00280069 | Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BitsMappedToColorLookupTable | 0x00281403 | Bits Mapped to Color Lookup Table.
BitsStored | 0x00280101 | Bits Stored.
BlendingLookupTableData | 0x00281408 | Blending Lookup Table Data.
BlendingLookupTableDescriptor | 0x00281407 | Blending Lookup Table Descriptor.
BlendingLUT1Sequence | 0x00281404 | Blending LUT 1 Sequence.
BlendingLUT1TransferFunction | 0x00281405 | Blending LUT 1 Transfer Function.
BlendingLUT2Sequence | 0x0028140C | Blending LUT 2 Sequence.
BlendingLUT2TransferFunction | 0x0028140D | Blending LUT 2 Transfer Function.
BlendingOperationType | 0x00720500 | Blending Operation Type.
BlendingPosition | 0x00700405 | Blending Position.
BlendingSequence | 0x00700402 | Blending Sequence.
BlendingWeightConstant | 0x00281406 | Blending Weight Constant.
BlindSpotLocalized | 0x00240106 | Blind Spot Localized.
BlindSpotXCoordinate | 0x00240107 | Blind Spot X-Coordinate.
BlindSpotYCoordinate | 0x00240108 | Blind Spot Y-Coordinate.
BlockColumns | 0x00280092 | Block Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BlockData | 0x300A0106 | Block Data.
BlockDivergence | 0x300A00FA | Block Divergence.
BlockedPixels | 0x00280090 | Blocked Pixels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BlockMountingPosition | 0x300A00FB | Block Mounting Position.
BlockName | 0x300A00FE | Block Name.
BlockNumber | 0x300A00FC | Block Number.
BlockNumberOfPoints | 0x300A0104 | Block Number of Points.
BlockRows | 0x00280091 | Block Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BlockSequence | 0x300A00F4 | Block Sequence.
BlockThickness | 0x300A0100 | Block Thickness.
BlockTransmission | 0x300A0102 | Block Transmission.
BlockTrayID | 0x300A00F5 | Block Tray ID.
BlockType | 0x300A00F8 | Block Type.
BloodSignalNulling | 0x00189022 | Blood Signal Nulling.
BluePaletteColorLookupTableData | 0x00281203 | Blue Palette Color Lookup Table Data.
BluePaletteColorLookupTableDescriptor | 0x00281103 | Blue Palette Color Lookup Table Descriptor.
BoardingPassID | 0x4010101A | Boarding Pass ID.
BodyPartExamined | 0x00180015 | Body Part Examined.
BodyPartThickness | 0x001811A0 | Body Part Thickness.
Bold | 0x00700249 | Bold.
BolusDescription | 0x300A00DD | Bolus Description.
BolusID | 0x300A00DC | Bolus Identifier.
BoneThermalIndex | 0x00185024 | Bone Thermal Index.
BorderDensity | 0x20100100 | Border Density.
Borders | 0x00005160 | Borders. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BottomRightHandCornerOfLocalizerArea | 0x00480202 | Bottom Right Hand Corner of Localizer Area.
BoundingBoxAnnotationUnits | 0x00700003 | Bounding Box Annotation Units.
BoundingBoxBottomRightHandCorner | 0x00700011 | Bounding Box Bottom Right Hand Corner.
BoundingBoxTextHorizontalJustification | 0x00700012 | Bounding Box Text Horizontal Justification.
BoundingBoxTopLeftHandCorner | 0x00700010 | Bounding Box Top Left Hand Corner.
BoundingPolygon | 0x4010101D | Bounding Polygon.
BoundingRectangle | 0x00686347 | Bounding Rectangle.
BrachyAccDeviceID | 0x300A0263 | Brachy Accessory Device ID. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceName | 0x300A0266 | Brachy Accessory Device Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceNominalThickness | 0x300A026A | Brachy Accessory Device Nominal Thickness. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceNominalTransmission | 0x300A026C | Brachy Accessory Device Nominal Transmission. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceNumber | 0x300A0262 | Brachy Accessory Device Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceSequence | 0x300A0260 | Brachy Accessory Device Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccDeviceType | 0x300A0264 | Brachy Accessory Device Type. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyAccessoryDeviceID | 0x300A0263 | Brachy Accessory Device ID.
BrachyAccessoryDeviceName | 0x300A0266 | Brachy Accessory Device Name.
BrachyAccessoryDeviceNominalThickness | 0x300A026A | Brachy Accessory Device Nominal Thickness.
BrachyAccessoryDeviceNominalTransmission | 0x300A026C | Brachy Accessory Device Nominal Transmission.
BrachyAccessoryDeviceNumber | 0x300A0262 | Brachy Accessory Device Number.
BrachyAccessoryDeviceSequence | 0x300A0260 | Brachy Accessory Device Sequence.
BrachyAccessoryDeviceType | 0x300A0264 | Brachy Accessory Device Type.
BrachyApplicationSetupDose | 0x300A00A4 | Brachy Application Setup Dose.
BrachyApplicationSetupDoseSpecificationPoint | 0x300A00A2 | Brachy Application Setup Dose Specification Point.
BrachyChannelLength | 0x300A0284 | Channel Length. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyChannelNumber | 0x300A0282 | Channel Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyChannelSequence | 0x300A0280 | Channel Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyChannelTotalTime | 0x300A0286 | Channel Total Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyControlPointDeliveredSequence | 0x30080160 | Brachy Control Point Delivered Sequence.
BrachyControlPointSequence | 0x300A02D0 | Brachy Control Point Sequence.
BrachyReferencedDoseReferenceSequence | 0x300C0055 | Brachy Referenced Dose Reference Sequence.
BrachySetupDose | 0x300A00A4 | Brachy Application Setup Dose. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachySetupDoseSpecificationPoint | 0x300A00A2 | Brachy Application Setup Dose Specification Point. This tag name has been deprecated, use tag with the same value defined in the previous line.
BrachyTreatmentTechnique | 0x300A0200 | Brachy Treatment Technique.
BrachyTreatmentType | 0x300A0202 | Brachy Treatment Type.
BranchOfService | 0x00101081 | Branch of Service.
BreastImplantPresent | 0x00281300 | Breast Implant Present.
BreedRegistrationNumber | 0x00102295 | Breed Registration Number.
BreedRegistrationSequence | 0x00102294 | Breed Registration Sequence.
BreedRegistryCodeSequence | 0x00102296 | Breed Registry Code Sequence.
BulkMotionCompensationTechnique | 0x00189172 | Bulk Motion Compensation Technique.
BulkMotionCompTechnique | 0x00189172 | Bulk Motion Compensation Technique. This tag name has been deprecated, use tag with the same value defined in the previous line.
BulkMotionSignalSource | 0x00189173 | Bulk Motion Signal Source.
BulkMotionStatus | 0x00189166 | Bulk Motion Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
BurnedInAnnotation | 0x00280301 | Burned In Annotation.
CADFileFormat | 0x00140023 | CAD File Format.
CalcDoseRefDesc | 0x30080074 | Calculated Dose Reference Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
CalcDoseRefDoseValue | 0x30080076 | Calculated Dose Reference Dose Value. This tag name has been deprecated, use tag with the same value defined in the previous line.
CalcDoseRefNumber | 0x30080072 | Calculated Dose Reference Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
CalcDoseRefSequence | 0x30080070 | Calculated Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
CalciumScoringMassFactorDevice | 0x00189352 | Calcium Scoring Mass Factor Device.
CalciumScoringMassFactorPatient | 0x00189351 | Calcium Scoring Mass Factor Patient.
CalculatedAnatomyThickness | 0x00189452 | Calculated Anatomy Thickness.
CalculatedDoseReferenceDescription | 0x30080074 | Calculated Dose Reference Description.
CalculatedDoseReferenceDoseValue | 0x30080076 | Calculated Dose Reference Dose Value.
CalculatedDoseReferenceNumber | 0x30080072 | Calculated Dose Reference Number.
CalculatedDoseReferenceSequence | 0x30080070 | Calculated Dose Reference Sequence.
CalculatedFrameList | 0x00081162 | Calculated Frame List.
CalibrationDataSequence | 0x00540306 | Calibration Data Sequence.
CalibrationDate | 0x0014407E | Calibration Date.
CalibrationImage | 0x00500004 | Calibration Image.
CalibrationNotes | 0x00143099 | Calibration Notes.
CalibrationProcedure | 0x00144072 | Calibration Procedure.
CalibrationSequence | 0x00189455 | Calibration Sequence.
CalibrationSettingsSequence | 0x00144070 | Calibration Settings Sequence.
CalibrationTime | 0x0014407C | Calibration Time.
CameraAngleOfView | 0x0022001E | Camera Angle of View.
CardiacBeatRejectionTechnique | 0x00189169 | Cardiac Beat Rejection Technique.
CardiacCyclePosition | 0x00189236 | Cardiac Cycle Position.
CardiacFramingType | 0x00181064 | Cardiac Framing Type.
CardiacNumberOfImages | 0x00181090 | Cardiac Number of Images.
CardiacRRintervalSpecified | 0x00189070 | Cardiac R-R Interval Specified.
CardiacSignalSource | 0x00189085 | Cardiac Signal Source.
CardiacSynchronizationSequence | 0x00189118 | Cardiac Synchronization Sequence.
CardiacSynchronizationTechnique | 0x00189037 | Cardiac Synchronization Technique.
CardiacSyncTechnique | 0x00189037 | Cardiac Synchronization Technique. This tag name has been deprecated, use tag with the same value defined in the previous line.
CardiacTriggerSequence | 0x00189118 | Cardiac Synchronization Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
CarmPositionerTabletopRelationship | 0x00189474 | C-arm Positioner Tabletop Relationship.
CarrierID | 0x40101058 | Carrier ID.
CarrierIDAssigningAuthority | 0x40101059 | Carrier ID Assigning Authority.
CassetteID | 0x00181007 | Cassette ID.
CassetteOrientation | 0x00181402 | Cassette Orientation.
CassetteSize | 0x00181403 | Cassette Size.
CatchTrialsDataFlag | 0x00240055 | Catch Trials Data Flag.
CatheterDirectionOfRotation | 0x00520031 | Catheter Direction of Rotation.
CatheterRotationalRate | 0x00520013 | Catheter Rotational Rate.
CenterOfCircularCollimator | 0x00181710 | Center of Circular Collimator.
CenterofCircularExposureControlSensingRegion | 0x00189440 | Center of Circular Exposure Control Sensing Region.
CenterOfCircularShutter | 0x00181610 | Center of Circular Shutter.
CenterOfMass | 0x4010101B | Center of Mass.
CenterOfPTO | 0x4010101C | Center of PTO.
CenterOfRotation | 0x0066001C | Center of Rotation.
CenterOfRotationOffset | 0x00181145 | Center of Rotation Offset.
CertificateOfSigner | 0x04000115 | Certificate of Signer.
CertificateType | 0x04000110 | Certificate Type.
CertifiedTimestamp | 0x04000310 | Certified Timestamp.
CertifiedTimestampType | 0x04000305 | Certified Timestamp Type.
ChannelBaseline | 0x003A0213 | Channel Baseline.
ChannelDefinitionSequence | 0x003A0200 | Channel Definition Sequence.
ChannelDerivationDescription | 0x003A020C | Channel Derivation Description.
ChannelDescriptionCodeSequence | 0x0022001A | Channel Description Code Sequence.
ChannelDisplaySequence | 0x003A0242 | Channel Display Sequence.
ChannelIdentificationCode | 0x003A0301 | Channel Identification Code.
ChannelLabel | 0x003A0203 | Channel Label.
ChannelLength | 0x300A0284 | Channel Length.
ChannelMaximumValue | 0x54000112 | Channel Maximum Value.
ChannelMinimumValue | 0x54000110 | Channel Minimum Value.
ChannelMode | 0x003A0302 | Channel Mode.
ChannelNumber | 0x300A0282 | Channel Number.
ChannelOffset | 0x003A0218 | Channel Offset.
ChannelPosition | 0x003A0245 | Channel Position.
ChannelRecommendedDisplayCIELabValue | 0x003A0244 | Channel Recommended Display CIELab Value.
ChannelSampleSkew | 0x003A0215 | Channel Sample Skew.
ChannelSensitivity | 0x003A0210 | Channel Sensitivity.
ChannelSensitivityCorrectionFactor | 0x003A0212 | Channel Sensitivity Correction Factor.
ChannelSensitivityUnits | 0x003A0211 | Channel Sensitivity Units Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ChannelSensitivityUnitsSequence | 0x003A0211 | Channel Sensitivity Units Sequence.
ChannelSequence | 0x300A0280 | Channel Sequence.
ChannelShieldID | 0x300A02B3 | Channel Shield ID.
ChannelShieldName | 0x300A02B4 | Channel Shield Name.
ChannelShieldNominalThickness | 0x300A02B8 | Channel Shield Nominal Thickness.
ChannelShieldNominalTransmission | 0x300A02BA | Channel Shield Nominal Transmission.
ChannelShieldNumber | 0x300A02B2 | Channel Shield Number.
ChannelShieldSequence | 0x300A02B0 | Channel Shield Sequence.
ChannelSourceModifiersSequence | 0x003A0209 | Channel Source Modifiers Sequence.
ChannelSourceSequence | 0x003A0208 | Channel Source Sequence.
ChannelStatus | 0x003A0205 | Channel Status.
ChannelTimeSkew | 0x003A0214 | Channel Time Skew.
ChannelTotalTime | 0x300A0286 | Channel Total Time.
ChannelWidth | 0x00460042 | Channel Width.
CharSet | 0x00041142 | Specific Character Set of File-set Descriptor File. This tag name has been deprecated, use tag with the same value defined in the previous line.
ChemicalShiftMaximumIntegrationLimitInppm | 0x00189296 | Chemical Shift Maximum Integration Limit in ppm.
ChemicalShiftMinimumIntegrationLimitInppm | 0x00189295 | Chemical Shift Minimum Integration Limit in ppm.
ChemicalShiftReference | 0x00189053 | Chemical Shift Reference.
ChemicalShiftSequence | 0x00189084 | Chemical Shift Sequence.
ChemicalShiftsMaximumIntegrationLimitInHz | 0x00189196 | Chemical Shifts Maximum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ChemicalShiftsMaximumIntegrationLimitinppm | 0x00189296 | Chemical Shift Maximum Integration Limit in ppm. This tag name has been deprecated, use tag with the same value defined in the previous line.
ChemicalShiftsMinimumIntegrationLimitInHz | 0x00189195 | Chemical Shifts Minimum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ChemicalShiftsMinimumIntegrationLimitinppm | 0x00189295 | Chemical Shift Minimum Integration Limit in ppm. This tag name has been deprecated, use tag with the same value defined in the previous line.
CineRate | 0x00180040 | Cine Rate.
CineRelativetoRealTime | 0x00720330 | Cine Relative to Real-Time.
ClinicalTrialCenterName | 0x00120060 | Clinical Trial Coordinating Center Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
ClinicalTrialCoordinatingCenterName | 0x00120060 | Clinical Trial Coordinating Center Name.
ClinicalTrialProtocolEthicsCommitteeApprovalNumber | 0x00120082 | Clinical Trial Protocol Ethics Committee Approval Number.
ClinicalTrialProtocolEthicsCommitteeName | 0x00120081 | Clinical Trial Protocol Ethics Committee Name.
ClinicalTrialProtocolID | 0x00120020 | Clinical Trial Protocol ID.
ClinicalTrialProtocolName | 0x00120021 | Clinical Trial Protocol Name.
ClinicalTrialSeriesDescription | 0x00120072 | Clinical Trial Series Description.
ClinicalTrialSeriesID | 0x00120071 | Clinical Trial Series ID.
ClinicalTrialSiteID | 0x00120030 | Clinical Trial Site ID.
ClinicalTrialSiteName | 0x00120031 | Clinical Trial Site Name.
ClinicalTrialSponsorName | 0x00120010 | Clinical Trial Sponsor Name.
ClinicalTrialSubjectID | 0x00120040 | Clinical Trial Subject ID.
ClinicalTrialSubjectReadingID | 0x00120042 | Clinical Trial Subject Reading ID.
ClinicalTrialTimePointDesc | 0x00120051 | Clinical Trial Time Point Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
ClinicalTrialTimePointDescription | 0x00120051 | Clinical Trial Time Point Description.
ClinicalTrialTimePointID | 0x00120050 | Clinical Trial Time Point ID.
CoatingMaterialsCodeSequence | 0x006863A4 | Coating Materials Code Sequence.
CodeLabel | 0x002808F0 | Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CodeMeaning | 0x00080104 | Code Meaning.
CodeNumberFormat | 0x00280740 | Code Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CodeTableLocation | 0x002808F3 | Code Table Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CodeValue | 0x00080100 | Code Value.
CodingSchemeDesignator | 0x00080102 | Coding Scheme Designator.
CodingSchemeExternalID | 0x00080114 | Coding Scheme External ID.
CodingSchemeIdentificationSequence | 0x00080110 | Coding Scheme Identification Sequence.
CodingSchemeIDSequence | 0x00080110 | Coding Scheme Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
CodingSchemeName | 0x00080115 | Coding Scheme Name.
CodingSchemeRegistry | 0x00080112 | Coding Scheme Registry.
CodingSchemeResponsibleOrganization | 0x00080116 | Coding Scheme Responsible Organization.
CodingSchemeUID | 0x0008010C | Coding Scheme UID.
CodingSchemeVersion | 0x00080103 | Coding Scheme Version.
CoefficientCoding | 0x002804F2 | Coefficient Coding. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoefficientCodingPointers | 0x002804F3 | Coefficient Coding Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoefficientsSDDN | 0x7FE00040 | Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoefficientsSDHN | 0x7FE00030 | Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoefficientsSDVN | 0x7FE00020 | Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoincidenceWindowWidth | 0x00541210 | Coincidence Window Width.
CollationFlag | 0x20000063 | Collation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CollimatorGridName | 0x00181180 | Collimator/grid Name.
CollimatorLeftVerticalEdge | 0x00181702 | Collimator Left Vertical Edge.
CollimatorLowerHorizontalEdge | 0x00181708 | Collimator Lower Horizontal Edge.
CollimatorRightVerticalEdge | 0x00181704 | Collimator Right Vertical Edge.
CollimatorShape | 0x00181700 | Collimator Shape.
CollimatorShapeSequence | 0x00189407 | Collimator Shape Sequence.
CollimatorType | 0x00181181 | Collimator Type.
CollimatorUpperHorizontalEdge | 0x00181706 | Collimator Upper Horizontal Edge.
ColorImagePrintingFlag | 0x20000062 | Color Image Printing Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ColumnAngulation | 0x00181450 | Column Angulation.
ColumnAngulationPatient | 0x00189447 | Column Angulation (Patient).
ColumnOverlap | 0x00280094 | Column Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ColumnPositionInTotalImagePixelMatrix | 0x0048021F | Column Position In Total Image Pixel Matrix.
Columns | 0x00280011 | Columns. Width of the DICOM image.
ColumnsForNthOrderCoefficients | 0x002804F1 | Columns For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CommandField | 0x00000100 | Command Field.
CommandGroupLength | 0x00000000 | Command Group Length.
CommandLengthToEnd | 0x00000001 | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CommentsOnPatientPerformanceOfVisualField | 0x00240044 | Comments on Patient's Performance of Visual Field.
CommentsOnRadiationDose | 0x00400310 | Comments on Radiation Dose.
CommentsOnThePerformedProcedureStep | 0x00400280 | Comments on the Performed Procedure Step.
CommentsOnTheScheduledProcedureStep | 0x00400400 | Comments on the Scheduled Procedure Step.
CompensatorColumn | 0x300A00E8 | Compensator Columns. This tag name has been deprecated, use tag with the same value defined in the previous line.
CompensatorColumnOffset | 0x300A02E5 | Compensator Column Offset.
CompensatorColumns | 0x300A00E8 | Compensator Columns.
CompensatorDescription | 0x300A02EB | Compensator Description.
CompensatorDivergence | 0x300A02E0 | Compensator Divergence.
CompensatorID | 0x300A00E5 | Compensator ID.
CompensatorMillingToolDiameter | 0x300A02E8 | Compensator Milling Tool Diameter.
CompensatorMountingPosition | 0x300A02E1 | Compensator Mounting Position.
CompensatorNumber | 0x300A00E4 | Compensator Number.
CompensatorPixelSpacing | 0x300A00E9 | Compensator Pixel Spacing.
CompensatorPosition | 0x300A00EA | Compensator Position.
CompensatorRelativeStoppingPowerRatio | 0x300A02E7 | Compensator Relative Stopping Power Ratio.
CompensatorRow | 0x300A00E7 | Compensator Rows. This tag name has been deprecated, use tag with the same value defined in the previous line.
CompensatorRows | 0x300A00E7 | Compensator Rows.
CompensatorSequence | 0x300A00E3 | Compensator Sequence.
CompensatorThicknessData | 0x300A00EC | Compensator Thickness Data.
CompensatorTransmissionData | 0x300A00EB | Compensator Transmission Data.
CompensatorType | 0x300A00EE | Compensator Type.
CompletionFlag | 0x0040A491 | Completion Flag.
CompletionFlagDescription | 0x0040A492 | Completion Flag Description.
ComplexImageComponent | 0x00089208 | Complex Image Component.
ComplexImgComponent | 0x00089208 | Complex Image Component. This tag name has been deprecated, use tag with the same value defined in the previous line.
Component1ReferencedID | 0x00760070 | Component 1 Referenced ID.
Component1ReferencedMatingFeatureID | 0x00760090 | Component 1 Referenced Mating Feature ID.
Component1ReferencedMatingFeatureSetID | 0x00760080 | Component 1 Referenced Mating Feature Set ID.
Component2ReferencedID | 0x007600A0 | Component 2 Referenced ID.
Component2ReferencedMatingFeatureID | 0x007600C0 | Component 2 Referenced Mating Feature ID.
Component2ReferencedMatingFeatureSetID | 0x007600B0 | Component 2 Referenced Mating Feature Set ID.
ComponentAssemblySequence | 0x00760060 | Component Assembly Sequence.
ComponentID | 0x00760055 | Component ID.
ComponentManufacturer | 0x00140028 | Component Manufacturer.
ComponentManufacturingProcedure | 0x00140025 | Component Manufacturing Procedure.
ComponentReferenceSystem | 0x00140024 | Component Reference System.
ComponentSequence | 0x00760040 | Component Sequence.
ComponentShape | 0x00140050 | Component Shape.
ComponentTypeCodeSequence | 0x00760034 | Component Type Code Sequence.
ComponentTypesSequence | 0x00760032 | Component Types Sequence.
CompoundGraphicInstanceID | 0x00700226 | Compound Graphic Instance ID.
CompoundGraphicSequence | 0x00700209 | Compound Graphic Sequence.
CompoundGraphicType | 0x00700294 | Compound Graphic Type.
CompoundGraphicUnits | 0x00700282 | Compound Graphic Units.
CompressionCode | 0x00280060 | Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionDescription | 0x00280063 | Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionForce | 0x001811A2 | Compression Force.
CompressionLabel | 0x00280062 | Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionOriginator | 0x00280061 | Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionRecognitionCode | 0x0028005F | Compression Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionSequence | 0x00280065 | Compression Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CompressionStepPointers | 0x00280066 | Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ConcatenationFrameOffsetNumber | 0x00209228 | Concatenation Frame Offset Number.
ConcatenationUID | 0x00209161 | Concatenation UID.
ConceptCodeSequence | 0x0040A168 | Concept Code Sequence.
ConceptCodeSequenceModifier | 0x0040A195 | Modifier Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ConceptNameCodeSequence | 0x0040A043 | Concept Name Code Sequence.
CondenserLensPower | 0x00480111 | Condenser Lens Power.
ConfidentialityCode | 0x00401008 | Confidentiality Code.
ConfidentialityConstraint | 0x00403001 | Confidentiality Constraint on Patient Data Description.
ConfidentialityConstraintOnPatientDataDescription | 0x00403001 | Confidentiality Constraint on Patient Data Description.
ConfigurationInformation | 0x20100150 | Configuration Information.
ConfigurationInformationDescription | 0x20100152 | Configuration Information Description.
ConsentForClinicalTrialUseSequence | 0x00120083 | Consent for Clinical Trial Use Sequence.
ConsentForDistributionFlag | 0x00120085 | Consent for Distribution Flag.
ConsraintWeight | 0x300A0021 | Constraint Weight. This tag name has been deprecated, use tag with the same value defined in the previous line.
ConstantVolumeFlag | 0x00189333 | Constant Volume Flag.
ConstraintWeight | 0x300A0021 | Constraint Weight.
ContactDisplayName | 0x0074100C | Contact Display Name.
ContactURI | 0x0074100A | Contact URI.
ContainerComponentDescription | 0x0050001E | Container Component Description.
ContainerComponentDiameter | 0x0050001D | Container Component Diameter.
ContainerComponentID | 0x0050001B | Container Component ID.
ContainerComponentLength | 0x0050001C | Container Component Length.
ContainerComponentMaterial | 0x0050001A | Container Component Material.
ContainerComponentSequence | 0x00400520 | Container Component Sequence.
ContainerComponentThickness | 0x00500013 | Container Component Thickness.
ContainerComponentTypeCodeSequence | 0x00500012 | Container Component Type Code Sequence.
ContainerComponentWidth | 0x00500015 | Container Component Width.
ContainerDescription | 0x0040051A | Container Description.
ContainerIdentifier | 0x00400512 | Container Identifier.
ContainerTypeCodeSequence | 0x00400518 | Container Type Code Sequence.
ContentCreatorIdentificationCodeSequence | 0x00700086 | Content Creator's Identification Code Sequence.
ContentCreatorName | 0x00700084 | Content Creator's Name.
ContentCreatorsIdentificationCodeSequence | 0x00700086 | Content Creator's Identification Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ContentCreatorsName | 0x00700084 | Content Creator's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
ContentDate | 0x00080023 | Content Date.
ContentDescription | 0x00700081 | Content Description.
ContentItemModifierSequence | 0x00400441 | Content Item Modifier Sequence.
ContentLabel | 0x00700080 | Content Label.
ContentQualification | 0x00189004 | Content Qualification.
ContentSequence | 0x0040A730 | Content Sequence.
ContentTemplateSequence | 0x0040A504 | Content Template Sequence.
ContentTime | 0x00080033 | Content Time.
ContextGroupExtensionCreatorUID | 0x0008010D | Context Group Extension Creator UID.
ContextGroupExtensionFlag | 0x0008010B | Context Group Extension Flag.
ContextGroupLocalVersion | 0x00080107 | Context Group Local Version.
ContextGroupVersion | 0x00080106 | Context Group Version.
ContextIdentifier | 0x0008010F | Context Identifier.
ContextUID | 0x00080117 | Context UID.
ContinuationEndMeterset | 0x00740121 | Continuation End Meterset.
ContinuationStartMeterset | 0x00740120 | Continuation Start Meterset.
ContinuityOfContent | 0x0040A050 | Continuity Of Content.
ContourData | 0x30060050 | Contour Data.
ContourGeometricType | 0x30060042 | Contour Geometric Type.
ContourImageSequence | 0x30060016 | Contour Image Sequence.
ContourNumber | 0x30060048 | Contour Number.
ContourOffsetVector | 0x30060045 | Contour Offset Vector.
ContourSequence | 0x30060040 | Contour Sequence.
ContourSlabThickness | 0x30060044 | Contour Slab Thickness.
ContourUncertaintyRadius | 0x00700312 | Contour Uncertainty Radius.
ContrastAdministrationProfileSequence | 0x00189340 | Contrast Administration Profile Sequence.
ContrastAllergies | 0x00102110 | Allergies value. This tag name has been deprecated, use tag with the same value defined in the previous line.
ContrastBolusAdministrationRouteSequence | 0x00180014 | Contrast/Bolus Administration Route Sequence.
ContrastBolusAdminRouteSequence | 0x00180014 | Contrast/Bolus Administration Route Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ContrastBolusAgent | 0x00180010 | Contrast/Bolus Agent.
ContrastBolusAgentAdministered | 0x00189342 | Contrast/Bolus Agent Administered.
ContrastBolusAgentDetected | 0x00189343 | Contrast/Bolus Agent Detected.
ContrastBolusAgentNumber | 0x00189337 | Contrast/Bolus Agent Number.
ContrastBolusAgentPhase | 0x00189344 | Contrast/Bolus Agent Phase.
ContrastBolusAgentSequence | 0x00180012 | Contrast/Bolus Agent Sequence.
ContrastBolusIngredient | 0x00181048 | Contrast/Bolus Ingredient.
ContrastBolusIngredientCodeSequence | 0x00189338 | Contrast/Bolus Ingredient Code Sequence.
ContrastBolusIngredientConcentration | 0x00181049 | Contrast/Bolus Ingredient Concentration.
ContrastBolusIngredientOpaque | 0x00189425 | Contrast/Bolus Ingredient Opaque.
ContrastBolusIngredientPercentByVolume | 0x00520001 | Contrast/Bolus Ingredient Percent by Volume.
ContrastBolusRoute | 0x00181040 | Contrast/Bolus Route.
ContrastBolusStartTime | 0x00181042 | Contrast/Bolus Start Time.
ContrastBolusStopTime | 0x00181043 | Contrast/Bolus Stop Time.
ContrastBolusTotalDose | 0x00181044 | Contrast/Bolus Total Dose.
ContrastBolusUsageSequence | 0x00189341 | Contrast/Bolus Usage Sequence.
ContrastBolusVolume | 0x00181041 | Contrast/Bolus Volume.
ContrastFlowDuration | 0x00181047 | Contrast Flow Duration.
ContrastFlowRate | 0x00181046 | Contrast Flow Rate.
ContrastFrameAveraging | 0x00286112 | Contrast Frame Averaging.
ContributingEquipmentSequence | 0x0018A001 | Contributing Equipment Sequence.
ContributingSOPInstancesReferenceSequence | 0x00209529 | Contributing SOP Instances Reference Sequence.
ContributingSourcesSequence | 0x00189506 | Contributing Sources Sequence.
ContributionDateTime | 0x0018A002 | Contribution Date Time.
ContributionDesc | 0x0018A003 | Contribution Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
ContributionDescription | 0x0018A003 | Contribution Description.
ControlPoint3dPosition | 0x300A02D4 | Control Point 3D Position.
ControlPointDeliverySequence | 0x30080040 | Control Point Delivery Sequence.
ControlPointIndex | 0x300A0112 | Control Point Index.
ControlPointOrientation | 0x300A0412 | Control Point Orientation.
ControlPointRelativePosition | 0x300A02D2 | Control Point Relative Position.
ControlPointSequence | 0x300A0111 | Control Point Sequence.
ConventionalControlPointVerificationSequence | 0x0074104C | Conventional Control Point Verification Sequence.
ConventionalMachineVerificationSequence | 0x00741044 | Conventional Machine Verification Sequence.
ConversionType | 0x00080064 | Conversion Type.
ConvolutionKernel | 0x00181210 | Convolution Kernel.
ConvolutionKernelGroup | 0x00189316 | Convolution Kernel Group.
CoordinateGeometricType | 0x0040A290 | Coordinate Geometric Type. This tag name has been deprecated, use tag with the same value defined in the previous line.
CoordinatesSetGeometricTypeTrial | 0x0040A290 | Coordinates Set Geometric Type (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoordinateStartValue | 0x50FF0112 | Coordinate Start Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoordinateStepValue | 0x50FF0114 | Coordinate Step Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoordinateSystemAxesSequence | 0x00142204 | Coordinate System Axes Sequence.
CoordinateSystemAxisCodeSequence | 0x004008DA | Coordinate System Axis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CoordinateSystemAxisDescription | 0x00142206 | Coordinate System Axis Description.
CoordinateSystemAxisNumber | 0x0014220A | Coordinate System Axis Number.
CoordinateSystemAxisType | 0x0014220C | Coordinate System Axis Type.
CoordinateSystemAxisUnits | 0x0014220E | Coordinate System Axis Units.
CoordinateSystemAxisValues | 0x00142210 | Coordinate System Axis Values.
CoordinateSystemDataSetMapping | 0x00142208 | Coordinate System Data Set Mapping.
CoordinateSystemNumberOfAxes | 0x00142202 | Coordinate System Number of Axes.
CoordinateSystemTransformRotationAndScaleMatrix | 0x0014222A | Coordinate System Transform Rotation and Scale Matrix.
CoordinateSystemTransformSequence | 0x00142220 | Coordinate System Transform Sequence.
CoordinateSystemTransformTranslationMatrix | 0x0014222C | Coordinate System Transform Translation Matrix.
CoordSystemAxisCodeSequence | 0x004008DA | Coordinate System Axis Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
Copies | 0x00005170 | Copies. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CornealSize | 0x00460046 | Corneal Size.
CorrectedImage | 0x00280051 | Corrected Image.
CorrectedLocalizedDeviationFromNormal | 0x00240079 | Corrected Localized Deviation From Normal.
CorrectedLocalizedDeviationFromNormalCalculated | 0x00240078 | Corrected Localized Deviation From Normal Calculated.
CorrectedLocalizedDeviationFromNormalProbability | 0x00240081 | Corrected Localized Deviation From Normal Probability.
CorrectedLocalizedDeviationFromNormalProbabilityCalculated | 0x00240080 | Corrected Localized Deviation From Normal Probability Calculated.
CorrectedParameterSequence | 0x30080068 | Corrected Parameter Sequence.
CorrectionValue | 0x3008006A | Correction Value.
CountLossNormalizationCorrected | 0x00189764 | Count Loss Normalization Corrected.
CountRate | 0x00181243 | Count Rate.
CountryOfResidence | 0x00102150 | Country of Residence.
CountsAccumulated | 0x00180070 | Counts Accumulated.
CountsIncluded | 0x00541400 | Counts Included. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CountsSource | 0x00541002 | Counts Source.
CouplingMedium | 0x00144056 | Coupling Medium.
CouplingTechnique | 0x00144054 | Coupling Technique.
CouplingVelocity | 0x00144057 | Coupling Velocity.
CoverageOfKspace | 0x00189094 | Coverage of k-Space.
CranialThermalIndex | 0x00185026 | Cranial Thermal Index.
CreationDate | 0x21000040 | Creation Date.
CreationTime | 0x21000050 | Creation Time.
CreatorVersionUID | 0x00089123 | Creator Version UID.
CrystalCenterLocationX | 0x00144058 | Crystal Center Location X.
CrystalCenterLocationZ | 0x00144059 | Crystal Center Location Z.
CSSFontName | 0x00700229 | CSS Font Name.
CTAcquisitionDetailsSequence | 0x00189304 | CT Acquisition Details Sequence.
CTAcquisitionTypeSequence | 0x00189301 | CT Acquisition Type Sequence.
CTAdditionalXRaySourceSequence | 0x00189360 | CT Additional X-Ray Source Sequence.
CTDIPhantomTypeCodeSequence | 0x00189346 | CTDI Phantom Type Code Sequence.
CTDIvol | 0x00189345 | The CTDIvol.
CTExposureSequence | 0x00189321 | CT Exposure Sequence.
CTGeometrySequence | 0x00189312 | CT Geometry Sequence.
CTImageFrameTypeSequence | 0x00189329 | CT Image Frame Type Sequence.
CTPositionSequence | 0x00189326 | CT Position Sequence.
CTReconstructionSequence | 0x00189314 | CT Reconstruction Sequence.
CTTableDynamicsSequence | 0x00189308 | CT Table Dynamics Sequence.
CTX_rayDetailsSequence | 0x00189325 | CT X-Ray Details Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
CTXRayDetailsSequence | 0x00189325 | CT X-Ray Details Sequence.
CumulativeDoseReferenceCoefficient | 0x300A010C | Cumulative Dose Reference Coefficient.
CumulativeDoseToDoseRef | 0x30080052 | Cumulative Dose to Dose Reference. This tag name has been deprecated, use tag with the same value defined in the previous line.
CumulativeDoseToDoseReference | 0x30080052 | Cumulative Dose to Dose Reference.
CumulativeMetersetWeight | 0x300A0134 | Cumulative Meterset Weight.
CumulativeTimeWeight | 0x300A02D6 | Cumulative Time Weight.
CurrentFractionNumber | 0x30080022 | Current Fraction Number.
CurrentObserverTrial | 0x0040A307 | Current Observer (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurrentPatientLocation | 0x00380300 | Current Patient Location.
CurrentRequestedProcedureEvidenceSequence | 0x0040A375 | Current Requested Procedure Evidence Sequence.
CurrentTreatmentStatus | 0x30080200 | Current Treatment Status.
CurvatureType | 0x00140052 | Curvature Type.
CurveActivationLayer | 0x50FF1001 | Curve Activation Layer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveData | 0x50FF3000 | Curve Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveDataDescriptor | 0x50FF0110 | Curve Data Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveDate | 0x00080025 | Curve Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveDescription | 0x50FF0022 | Curve Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveDimensions | 0x50FF0005 | Curve Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveLabel | 0x50FF2500 | Curve Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveNumber | 0x00200024 | Curve Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveRange | 0x50FF0106 | Curve Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveReferencedOverlayGroup | 0x50FF2610 | Curve Referenced Overlay Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveReferencedOverlaySequence | 0x50FF2600 | Curve Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CurveTime | 0x00080035 | Curve Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
CustodialOrganizationSequence | 0x0040A07C | Custodial Organization Sequence.
CylinderAxis | 0x00220009 | Cylinder Axis.
CylinderLensPower | 0x00220008 | Cylinder Lens Power.
CylinderPower | 0x00460147 | Cylinder Power.
CylinderSequence | 0x00460018 | Cylinder Sequence.
DACAmplitude | 0x0014403C | DAC Amplitude.
DACGainPoints | 0x00144038 | DAC Gain Points.
DACSequence | 0x00144035 | DAC Sequence.
DACTimePoints | 0x0014403A | DAC Time Points.
DACType | 0x00144036 | DAC Type.
Damping | 0x00144028 | Damping.
DarkCurrentCounts | 0x00143050 | Dark Current Counts.
DarkCurrentSequence | 0x00143040 | Dark Current Sequence.
DataBlock | 0x00280702 | Data Block. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DataBlockDescription | 0x00280701 | Data Block Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DataCollectionCenterPatient | 0x00189313 | Data Collection Center (Patient).
DataCollectionDiameter | 0x00180090 | Data Collection Diameter.
DataElementsSigned | 0x04000020 | Data Elements Signed.
DataFrameAssignmentSequence | 0x00281401 | Data Frame Assignment Sequence.
DataInformationSequence | 0x00540063 | Data Information Sequence.
DataInfoSequence | 0x00540063 | Data Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
DataObservationSequence | 0x00240325 | Data Observation Sequence.
DataPathAssignment | 0x00281402 | Data Path Assignment.
DataPathID | 0x0028140E | Data Path ID.
DataPointColumns | 0x00289002 | Data Point Columns.
DataPointRows | 0x00289001 | Data Point Rows.
DataRepresentation | 0x00289108 | Data Representation.
DataSet | 0x00000007 | DICOM dataset.
DataSetDescription | 0x00240309 | Data Set Description.
DataSetName | 0x00240306 | Data Set Name.
DatasetPadding | 0xFFFCFFFC | Data Set Trailing Padding. This tag name has been deprecated, use tag with the same value defined in the previous line.
DataSetSource | 0x00240308 | Data Set Source.
DataSetSubtype | 0x00080041 | Data Set Subtype. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DataSetTrailingPadding | 0xFFFCFFFC | Data Set Trailing Padding.
DataSetType | 0x00000800 | Data Set Type.
DataSetTypeRetired | 0x00080040 | Data Set Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DataSetVersion | 0x00240307 | Data Set Version.
DataStreamEncodingFragment | 0xFFFEE000 | Data Stream Encoding Fragment.
DataType | 0x00189808 | Data Type.
DataValueRepresentation | 0x50FF0103 | Data Value Representation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Date | 0x0040A121 | Date value.
DateOfDocumentOrVerbalTransactionTrial | 0x0040A110 | Date of Document or Verbal Transaction (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DateOfGainCalibration | 0x00143076 | Date of Gain Calibration.
DateOfLastCalibration | 0x00181200 | Date of Last Calibration.
DateOfLastDetectorCalibration | 0x0018700C | Date of Last Detector Calibration.
DateOfSecondaryCapture | 0x00181012 | Date of Secondary Capture.
DateTime | 0x0040A120 | DateTime value.
DbDt | 0x00181318 | The dB/dt.
DCTLabel | 0x00280700 | DCT Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DeadTimeCorrected | 0x00189761 | Dead Time Corrected.
DeadTimeCorrectionFlag | 0x00541401 | Dead Time Correction Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DeadTimeFactor | 0x00541324 | Dead Time Factor.
DecayCorrected | 0x00189758 | Decay Corrected.
DecayCorrection | 0x00541102 | Decay Correction.
DecayCorrectionDateTime | 0x00189701 | Decay Correction DateTime.
DecayFactor | 0x00541321 | Decay Factor.
DecimalVisualAcuity | 0x00460137 | Decimal Visual Acuity.
DecimateCropRequested | 0x20200040 | Requested Decimate/Crop Behavior. This tag name has been deprecated, use tag with the same value defined in the previous line.
DecimateCropResult | 0x202000A2 | Decimate/Crop Result.
DecoupledNucleus | 0x00189060 | De-coupled Nucleus.
Decoupling | 0x00189059 | De-coupling value.
DecouplingChemicalShiftReference | 0x00189063 | De-coupling Chemical Shift Reference.
DecouplingFrequency | 0x00189061 | De-coupling Frequency.
DecouplingMethod | 0x00189062 | De-coupling Method.
DefaultMagnificationType | 0x201000A6 | Default Magnification Type.
DefaultPrinterResolutionID | 0x20100054 | Default Printer Resolution ID.
DefaultSmoothingType | 0x201000A8 | Default Smoothing Type.
DeformableRegistrationGridSequence | 0x00640005 | Deformable Registration Grid Sequence.
DeformableRegistrationSequence | 0x00640002 | Deformable Registration Sequence.
DegreeofDilation | 0x0022000E | Degree of Dilation.
DegreeOfFreedomID | 0x00686410 | Degree of Freedom ID.
DegreeOfFreedomType | 0x00686420 | Degree of Freedom Type.
DeidentificationMethod | 0x00120063 | De-identification Method.
DeidentificationMethodCodeSequence | 0x00120064 | De-identification Method Code Sequence.
DelayLawIdentifier | 0x0014405C | Delay Law Identifier.
DeletionLock | 0x00741230 | Deletion Lock.
DeliveredChannelTotalTime | 0x30080134 | Delivered Channel Total Time.
DeliveredMeterset | 0x30080044 | Delivered Meterset.
DeliveredNumberofPulses | 0x30080138 | Delivered Number of Pulses.
DeliveredPrimaryMeterset | 0x30080036 | Delivered Primary Meterset.
DeliveredPulseRepetitionInterval | 0x3008013C | Delivered Pulse Repetition Interval.
DeliveredSecondaryMeterset | 0x30080037 | Delivered Secondary Meterset.
DeliveredTreatmentTime | 0x3008003B | Delivered Treatment Time.
DeliveryMaximumDose | 0x300A0023 | Delivery Maximum Dose.
DeliveryVerificationImageSequence | 0x00741030 | Delivery Verification Image Sequence.
DeliveryWarningDose | 0x300A0022 | Delivery Warning Dose.
Density | 0x40101018 | Density.
DepthOfScanField | 0x00185050 | Depth of Scan Field.
DepthOfTransverseImage | 0x00220041 | Depth of Transverse Image.
DepthsOfFocus | 0x00189801 | Depth(s) of Focus.
DepthSpatialResolution | 0x00220035 | Depth Spatial Resolution.
DerivationCodeSequence | 0x00089215 | Derivation Code Sequence.
DerivationDescription | 0x00082111 | Derivation Description.
DerivationImageSequence | 0x00089124 | Derivation Image Sequence.
DerivationImgSequence | 0x00089124 | Derivation Image Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
DerivationImplantAssemblyTemplateSequence | 0x0076000E | Derivation Implant Assembly Template Sequence.
DerivationImplantTemplateSequence | 0x00686224 | Derivation Implant Template Sequence.
DestinationAe | 0x21000140 | Destination AE. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DetailsOfCoefficients | 0x00280404 | Details of Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DetectorActivationOffset | 0x00187016 | Detector Activation Offset From Exposure. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorActivationOffsetFromExposure | 0x00187016 | Detector Activation Offset From Exposure.
DetectorActiveDimension | 0x00187026 | Detector Active Dimension(s). This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorActiveDimensions | 0x00187026 | Detector Active Dimension(s).
DetectorActiveOrigin | 0x00187028 | Detector Active Origin.
DetectorActiveShape | 0x00187024 | Detector Active Shape.
DetectorActiveTime | 0x00187014 | Detector Active Time.
DetectorBinning | 0x0018701A | Detector Binning.
DetectorCalibrationData | 0x4010106C | Detector Calibration Data.
DetectorCalibrationDate | 0x0018700C | Date of Last Detector Calibration. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorCalibrationTime | 0x0018700E | Time of Last Detector Calibration. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorConditionsNominalFlag | 0x00187000 | Detector Conditions Nominal Flag.
DetectorConfiguration | 0x00187005 | Detector Configuration.
DetectorDescription | 0x00187006 | Detector Description.
DetectorElementPhysicalSize | 0x00187020 | Detector Element Physical Size.
DetectorElementSize | 0x00541203 | Detector Element Size.
DetectorElementSpacing | 0x00187022 | Detector Element Spacing.
DetectorGeometry | 0x00189725 | Detector Geometry.
DetectorGeometrySequence | 0x40100004 | Detector Geometry Sequence.
DetectorID | 0x0018700A | Detector ID.
DetectorInformationSequence | 0x00540022 | Detector Information Sequence.
DetectorInfoSequence | 0x00540022 | Detector Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorLinesOfResponseUsed | 0x00541104 | Detector Lines of Response Used.
DetectorManufacturerModelName | 0x0018702B | Detector Manufacturer's Model Name.
DetectorManufacturerName | 0x0018702A | Detector Manufacturer Name.
DetectorManufacturersModelName | 0x0018702B | Detector Manufacturer's Model Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorMode | 0x00187008 | Detector Mode.
DetectorNormalizationCorrection | 0x00189768 | Detector Normalization Correction.
DetectorPrimaryAngle | 0x00181530 | Detector Primary Angle.
DetectorSecondaryAngle | 0x00181531 | Detector Secondary Angle.
DetectorTemperature | 0x00187001 | Detector Temperature.
DetectorTemperatureSequence | 0x00143020 | Detector Temperature Sequence.
DetectorTimeSinceExposure | 0x00187012 | Detector Time Since Last Exposure. This tag name has been deprecated, use tag with the same value defined in the previous line.
DetectorTimeSinceLastExposure | 0x00187012 | Detector Time Since Last Exposure.
DetectorType | 0x00187004 | Detector Type.
DetectorVector | 0x00540020 | Detector Vector.
DeviationIndex | 0x00181413 | Deviation Index.
DeviceDescription | 0x00500020 | Device Description.
DeviceDiameter | 0x00500016 | Device Diameter.
DeviceDiameterUnit | 0x00500017 | Device Diameter Units. This tag name has been deprecated, use tag with the same value defined in the previous line.
DeviceDiameterUnits | 0x00500017 | Device Diameter Units.
DeviceID | 0x00181003 | Device ID.
DeviceLength | 0x00500014 | Device Length.
DeviceSequence | 0x00500010 | Device Sequence.
DeviceSerialNumber | 0x00181000 | Device Serial Number.
DeviceUID | 0x00181002 | Device UID.
DeviceVolume | 0x00500018 | Device Volume.
DIALOGReceiver | 0x00004000 | DIALOG Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DiameterOfVisibility | 0x00700262 | Diameter of Visibility.
DiaphragmPosition | 0x30020034 | Diaphragm Position.
DICOMMediaRetrievalSequence | 0x0040E022 | DICOM Media Retrieval Sequence.
DICOMRetrievalSequence | 0x0040E021 | DICOM Retrieval Sequence.
DICOSVersion | 0x4010103A | DICOS Version.
DifferentialWaveformSource | 0x003A020A | Source Waveform Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
DifferentialWaveformSourceModifiers | 0x003A020B | Differential Waveform Source Modifiers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Diffusion_b_matrixSequence | 0x00189601 | Diffusion b-matrix Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_value | 0x00189087 | Diffusion b-value. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueXX | 0x00189602 | Diffusion b-value XX. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueXY | 0x00189603 | Diffusion b-value XY. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueXZ | 0x00189604 | Diffusion b-value XZ. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueYY | 0x00189605 | Diffusion b-value YY. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueYZ | 0x00189606 | Diffusion b-value YZ. This tag name has been deprecated, use tag with the same value defined in the previous line.
Diffusion_b_valueZZ | 0x00189607 | Diffusion b-value ZZ. This tag name has been deprecated, use tag with the same value defined in the previous line.
DiffusionAnisotropyType | 0x00189147 | Diffusion Anisotropy Type.
DiffusionBMatrixSequence | 0x00189601 | Diffusion b-matrix Sequence.
DiffusionBvalue | 0x00189087 | Diffusion b-value.
DiffusionBValueXX | 0x00189602 | Diffusion b-value XX.
DiffusionBValueXY | 0x00189603 | Diffusion b-value XY.
DiffusionBValueXZ | 0x00189604 | Diffusion b-value XZ.
DiffusionBValueYY | 0x00189605 | Diffusion b-value YY.
DiffusionBValueYZ | 0x00189606 | Diffusion b-value YZ.
DiffusionBValueZZ | 0x00189607 | Diffusion b-value ZZ.
DiffusionDirectionality | 0x00189075 | Diffusion Directionality.
DiffusionGradientDirectionSequence | 0x00189076 | Diffusion Gradient Direction Sequence.
DiffusionGradientOrientation | 0x00189089 | Diffusion Gradient Orientation.
DigitalImageFormatAcquired | 0x00181023 | Digital Image Format Acquired.
DigitalSignatureDateTime | 0x04000105 | Digital Signature DateTime.
DigitalSignaturePurposeCodeSequence | 0x04000401 | Digital Signature Purpose Code Sequence.
DigitalSignaturesSequence | 0xFFFAFFFA | Digital Signatures Sequence.
DigitalSignatureUID | 0x04000100 | Digital Signature UID.
DigitizingDeviceTransportDirection | 0x00182020 | Digitizing Device Transport Direction.
DimensionDescriptionLabel | 0x00209421 | Dimension Description Label.
DimensionIndexPointer | 0x00209165 | Dimension Index Pointer.
DimensionIndexPrivateCreator | 0x00209213 | Dimension Index Private Creator.
DimensionIndexSequence | 0x00209222 | Dimension Index Sequence.
DimensionIndexValue | 0x00209157 | Dimension Index Values. This tag name has been deprecated, use tag with the same value defined in the previous line.
DimensionIndexValues | 0x00209157 | Dimension Index Values.
DimensionOrganizationSequence | 0x00209221 | Dimension Organization Sequence.
DimensionOrganizationType | 0x00209311 | Dimension Organization Type.
DimensionOrganizationUID | 0x00209164 | Dimension Organization UID.
DirectoryRecordSequence | 0x00041220 | Directory Record Sequence.
DirectoryRecordType | 0x00041430 | Directory Record Type.
DischargeDate | 0x00380030 | Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DischargeDiagnosisCodeSequence | 0x00380044 | Discharge Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DischargeDiagnosisDescription | 0x00380040 | Discharge Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DischargeTime | 0x00380032 | Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DisplayedAreaBottomRightHandCorner | 0x00700053 | Displayed Area Bottom Right Hand Corner.
DisplayedAreaBottomRightHandCornerTrial | 0x00700051 | Displayed Area Bottom Right Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DisplayedAreaSelectionSequence | 0x0070005A | Displayed Area Selection Sequence.
DisplayedAreaTopLeftHandCorner | 0x00700052 | Displayed Area Top Left Hand Corner.
DisplayedAreaTopLeftHandCornerTrial | 0x00700050 | Displayed Area Top Left Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DisplayEnvironmentSpatialPosition | 0x00720108 | Display Environment Spatial Position.
DisplayFilterPercentage | 0x00289411 | Display Filter Percentage.
DisplayFormat | 0x00005110 | Display Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DisplaySetHorizontalJustification | 0x00720717 | Display Set Horizontal Justification.
DisplaySetLabel | 0x00720203 | Display Set Label.
DisplaySetNumber | 0x00720202 | Display Set Number.
DisplaySetPatientOrientation | 0x00720700 | Display Set Patient Orientation.
DisplaySetPatientOrientationCS2 | 0x00720700 | Display Set Patient Orientation. This tag name has been deprecated, use tag with the same value defined in the previous line.
DisplaySetPresentationGroup | 0x00720204 | Display Set Presentation Group.
DisplaySetPresentationGroupDescription | 0x00720206 | Display Set Presentation Group Description.
DisplaySetScrollingGroup | 0x00720212 | Display Set Scrolling Group.
DisplaySetsSequence | 0x00720200 | Display Sets Sequence.
DisplaySetVerticalJustification | 0x00720718 | Display Set Vertical Justification.
DisplayShadingFlag | 0x003A0246 | Display Shading Flag.
DisplayWindowLabelVector | 0x00182006 | Display Window Label Vector.
DistanceBetweenFocalPlanes | 0x00480014 | Distance Between Focal Planes.
DistanceObjecttoTableTop | 0x00189403 | Distance Object to Table Top.
DistancePupillaryDistance | 0x00460060 | Distance Pupillary Distance.
DistanceReceptorPlanetoDetectorHousing | 0x00189426 | Distance Receptor Plane to Detector Housing.
DistanceSourcetoDataCollectionCenter | 0x00189335 | Distance Source to Data Collection Center.
DistanceSourceToDetector | 0x00181110 | Distance Source to Detector.
DistanceSourceToEntrance | 0x00400306 | Distance Source to Entrance.
DistanceSourcetoIsocenter | 0x00189402 | Distance Source to Isocenter.
DistanceSourceToPatient | 0x00181111 | Distance Source to Patient.
DistanceSourcetoSupport | 0x00400307 | Distance Source to Support. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DistributionAddress | 0x4008011A | Distribution Address. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DistributionName | 0x40080119 | Distribution Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DistributionType | 0x00120084 | Distribution Type.
DocumentAuthorIdentifierCodeSequenceTrial | 0x0040A068 | Document Author Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DocumentAuthorTrial | 0x0040A067 | Document Author (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DocumentClassCodeSequence | 0x0040E008 | Document Class Code Sequence.
DocumentIdentifierCodeSequenceTrial | 0x0040A066 | Document Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DocumentingObserverIdentifierCodeSequenceTrial | 0x0040A076 | Documenting Observer Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DocumentingOrganizationIdentifierCodeSequenceTrial | 0x0040A028 | Documenting Organization Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DocumentTitle | 0x00420010 | Document Title.
DopplerCorrectionAngle | 0x00186034 | Doppler Correction Angle.
DopplerSampleVolumeXPosition | 0x00186039 | Doppler Sample Volume X Position.
DopplerSampleVolumeXPositionRetired | 0x00186038 | Doppler Sample Volume X Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DopplerSampleVolumeYPosition | 0x0018603B | Doppler Sample Volume Y Position.
DopplerSampleVolumeYPositionRetired | 0x0018603A | Doppler Sample Volume Y Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DoseCalibrationFactor | 0x00541322 | Dose Calibration Factor.
DoseComment | 0x30040006 | Dose Comment.
DoseGridScaling | 0x3004000E | Dose Grid Scaling.
DoseRateDelivered | 0x30080048 | Dose Rate Delivered.
DoseRateSet | 0x300A0115 | Dose Rate Set.
DoseReferenceDescription | 0x300A0016 | Dose Reference Description.
DoseReferenceNumber | 0x300A0012 | Dose Reference Number.
DoseReferencePointCoordinate | 0x300A0018 | Dose Reference Point Coordinates. This tag name has been deprecated, use tag with the same value defined in the previous line.
DoseReferencePointCoordinates | 0x300A0018 | Dose Reference Point Coordinates.
DoseReferenceSequence | 0x300A0010 | Dose Reference Sequence.
DoseReferenceStructureType | 0x300A0014 | Dose Reference Structure Type.
DoseReferenceType | 0x300A0020 | Dose Reference Type.
DoseReferenceUID | 0x300A0013 | Dose Reference UID.
DoseSummationType | 0x3004000A | Dose Summation Type.
DoseType | 0x30040004 | Dose Type.
DoseUnit | 0x30040002 | Dose Units. This tag name has been deprecated, use tag with the same value defined in the previous line.
DoseUnits | 0x30040002 | Dose Units.
DoseValue | 0x30040012 | Dose Value.
DoubleExposureFieldDelta | 0x0074133A | Double Exposure Field Delta.
DoubleExposureFieldDeltaTrial | 0x0074103A | Double Exposure Field Delta (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DoubleExposureFlag | 0x00741034 | Double Exposure Flag.
DoubleExposureMeterset | 0x00741338 | Double Exposure Meterset.
DoubleExposureMetersetTrial | 0x00741038 | Double Exposure Meterset (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
DoubleExposureOrdering | 0x00741036 | Double Exposure Ordering.
DvhData | 0x30040058 | The DVH Data.
DvhDoseScaling | 0x30040052 | DVH Dose Scaling.
DvhMaximumDose | 0x30040072 | DVH Maximum Dose.
DvhMeanDose | 0x30040074 | DVH Mean Dose.
DvhMinimumDose | 0x30040070 | DVH Minimum Dose.
DvhNormalizationDoseValue | 0x30040042 | DVH Normalization Dose Value.
DvhNormalizationPoint | 0x30040040 | DVH Normalization Point.
DvhNumberOfBins | 0x30040056 | DVH Number of Bins.
DvhReferencedRoiSequence | 0x30040060 | DVH Referenced ROI Sequence.
DvhRoiContributionType | 0x30040062 | DVH ROI Contribution Type.
DvhSequence | 0x30040050 | DVH Sequence.
DvhType | 0x30040001 | DVH (Dose-volume histogram) Type.
DvhVolumeUnit | 0x30040054 | DVH Volume Units. This tag name has been deprecated, use tag with the same value defined in the previous line.
DvhVolumeUnits | 0x30040054 | DVH Volume Units.
DynamicRange | 0x00185030 | Dynamic Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
EchoNumbers | 0x00180086 | Echo Number(s).
EchoPlanarPulseSequence | 0x00189018 | Echo Planar Pulse Sequence.
EchoPulseSequence | 0x00189008 | Echo Pulse Sequence.
EchoTime | 0x00180081 | Echo Time.
EchoTrainLength | 0x00180091 | Echo Train Length.
EdgePointIndexList | 0x00660024 | Edge Point Index List.
EffectiveDateTime | 0x00686226 | Effective DateTime.
EffectiveDuration | 0x00180072 | Effective Duration.
EffectiveEchoTime | 0x00189082 | Effective Echo Time.
EffectiveRefractiveIndex | 0x00520004 | Effective Refractive Index.
EffectiveSeriesDuration | 0x00180072 | Effective Duration. This tag name has been deprecated, use tag with the same value defined in the previous line.
ElementDimensionA | 0x00144014 | Element Dimension A.
ElementDimensionB | 0x00144015 | Element Dimension B.
ElementPitch | 0x00144016 | Element Pitch.
ElementShape | 0x00144013 | Element Shape.
EmmetropicMagnification | 0x0022000A | Emmetropic Magnification.
EmptyImageBoxCIELabValue | 0x00720421 | Empty Image Box CIELab Value.
EmptyImageDensity | 0x20100110 | Empty Image Density.
EncapsulatedDocument | 0x00420011 | Encapsulated Document.
EncryptedAttributesSequence | 0x04000500 | Encrypted Attributes Sequence.
EncryptedContent | 0x04000520 | Encrypted Content.
EncryptedContentTransferSyntaxUID | 0x04000510 | Encrypted Content Transfer Syntax UID.
EndAcquisitionDateTime | 0x00189517 | End Acquisition DateTime.
EndCumulativeMetersetWeight | 0x300C0009 | End Cumulative Meterset Weight.
EndingRespiratoryAmplitude | 0x00209248 | Ending Respiratory Amplitude.
EndingRespiratoryPhase | 0x00209249 | Ending Respiratory Phase.
EndMessageID | 0x00005020 | End Message ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
EndMeterset | 0x3008007A | End Meterset.
EnergyWeightingFactor | 0x00189353 | Energy Weighting Factor.
EnergyWindowCenterline | 0x00180032 | Energy Window Centerline. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
EnergyWindowInformationSequence | 0x00540012 | Energy Window Information Sequence.
EnergyWindowInfoSequence | 0x00540012 | Energy Window Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
EnergyWindowLowerLimit | 0x00540014 | Energy Window Lower Limit.
EnergyWindowName | 0x00540018 | Energy Window Name.
EnergyWindowNumber | 0x00540308 | Energy Window Number.
EnergyWindowRangeSequence | 0x00540013 | Energy Window Range Sequence.
EnergyWindowTotalWidth | 0x00180033 | Energy Window Total Width. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
EnergyWindowUpperLimit | 0x00540015 | Energy Window Upper Limit.
EnergyWindowVector | 0x00540010 | Energy Window Vector.
EnhancedPaletteColorLookupTableSequence | 0x0028140B | Enhanced Palette Color Lookup Table Sequence.
EntranceDose | 0x00400302 | Entrance Dose.
EntranceDoseInmGy | 0x00408302 | Entrance Dose in mGy.
EnvironmentalConditions | 0x00141040 | Environmental Conditions.
EquipmentCoordinateSystemIdentification | 0x00289537 | Equipment Coordinate System Identification.
EquivalentCDADocumentSequence | 0x0040A090 | Equivalent CDA Document Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Erase | 0x00005190 | Erase. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ErrorComment | 0x00000902 | Error Comment.
ErrorID | 0x00000903 | Error Identifier.
EscapeTriplet | 0x1000FFF0 | Escape Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
EstimatedDoseSaving | 0x00189324 | Estimated Dose Saving.
EstimatedRadiographicMagnificationFactor | 0x00181114 | Estimated Radiographic Magnification Factor.
EstRadiographicMagFactor | 0x00181114 | Estimated Radiographic Magnification Factor. This tag name has been deprecated, use tag with the same value defined in the previous line.
EthnicGroup | 0x00102160 | Ethnic Group.
EvaluationAttempt | 0x00142008 | Evaluation Attempt.
EvaluatorName | 0x00142006 | Evaluator Name.
EvaluatorNumber | 0x00142004 | Evaluator Number.
EvaluatorSequence | 0x00142002 | Evaluator Sequence.
EventCodeSequence | 0x00082135 | Event Code Sequence.
EventElapsedTimes | 0x00082130 | Event Elapsed Time(s).
EventTimeOffset | 0x00082134 | Event Time Offset.
EventTimerNames | 0x00082132 | Event Timer Name(s).
EventTimerSequence | 0x00082133 | Event Timer Sequence.
EventTypeID | 0x00001002 | Event Type ID.
ExaminedBodyThickness | 0x00109431 | Examined Body Thickness.
ExcessiveFalseNegatives | 0x00240052 | Excessive False Negatives.
ExcessiveFalseNegativesDataFlag | 0x00240051 | Excessive False Negatives Data Flag.
ExcessiveFalsePositives | 0x00240062 | Excessive False Positives.
ExcessiveFalsePositivesDataFlag | 0x00240061 | Excessive False Positives Data Flag.
ExcessiveFixationLosses | 0x00240040 | Excessive Fixation Losses.
ExcessiveFixationLossesDataFlag | 0x00240039 | Excessive Fixation Losses Data Flag.
ExcitationFrequency | 0x00144024 | Excitation Frequency.
ExcludedIntervalsSequence | 0x00189803 | Excluded Intervals Sequence.
ExclusionDuration | 0x00189805 | Exclusion Duration.
ExclusionStartDatetime | 0x00189804 | Exclusion Start Datetime.
ExclusiveComponentType | 0x00760036 | Exclusive Component Type.
ExecutionStatus | 0x21000020 | Execution Status.
ExecutionStatusInfo | 0x21000030 | Execution Status Info.
ExpectedCompletionDateAndTime | 0x00404011 | Expected Completion Date and Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExpectedCompletionDateTime | 0x00404011 | Expected Completion Date Time.
ExpectedCompletionDT | 0x00404011 | Expected Completion Date and Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExpiryDate | 0x00141020 | Expiry Date.
ExposedArea | 0x00400303 | Exposed Area.
Exposure | 0x00181152 | Exposure value.
ExposureControlMode | 0x00187060 | Exposure Control Mode.
ExposureControlModeDesc | 0x00187062 | Exposure Control Mode Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureControlModeDescription | 0x00187062 | Exposure Control Mode Description.
ExposureControlSensingRegionLeftVerticalEdge | 0x00189436 | Exposure Control Sensing Region Left Vertical Edge.
ExposureControlSensingRegionLowerHorizontal | 0x00189439 | Exposure Control Sensing Region Lower Horizontal Edge. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureControlSensingRegionLowerHorizontalEdge | 0x00189439 | Exposure Control Sensing Region Lower Horizontal Edge.
ExposureControlSensingRegionRightVerticalEdge | 0x00189437 | Exposure Control Sensing Region Right Vertical Edge.
ExposureControlSensingRegionShape | 0x00189435 | Exposure Control Sensing Region Shape.
ExposureControlSensingRegionsSequence | 0x00189434 | Exposure Control Sensing Regions Sequence.
ExposureControlSensingRegionUpperHorizontal | 0x00189438 | Exposure Control Sensing Region Upper Horizontal Edge. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureControlSensingRegionUpperHorizontalEdge | 0x00189438 | Exposure Control Sensing Region Upper Horizontal Edge.
ExposureDoseSequence | 0x0040030E | Exposure Dose Sequence.
ExposureIndex | 0x00181411 | Exposure Index.
ExposureinmAs | 0x00189332 | Exposure in mAs.
ExposureInMicroA | 0x00181153 | Exposure in micro As. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureInMicroAs | 0x00181153 | Exposure in micro As. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureInuAs | 0x00181153 | Exposure in micro As.
ExposureModulationType | 0x00189323 | Exposure Modulation Type.
ExposureOnPlate | 0x00181404 | Exposures on Plate. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureSequence | 0x30020030 | Exposure Sequence.
ExposuresOnDetectorSinceLastCalibration | 0x00187010 | Exposures on Detector Since Last Calibration.
ExposuresOnDetectorSinceManufactured | 0x00187011 | Exposures on Detector Since Manufactured.
ExposuresOnPlate | 0x00181404 | Exposures on Plate.
ExposuresSinceCalibration | 0x00187010 | Exposures on Detector Since Last Calibration. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposuresSinceManufactured | 0x00187011 | Exposures on Detector Since Manufactured. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureStatus | 0x00187064 | Exposure Status.
ExposureTime | 0x00181150 | Exposure Time.
ExposureTimeIn_mS | 0x00188150 | Exposure Time in micro S. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureTimeInMicroS | 0x00188150 | Exposure Time in micro S. This tag name has been deprecated, use tag with the same value defined in the previous line.
ExposureTimeinms | 0x00189328 | Exposure Time in ms.
ExposureTimeInuS | 0x00188150 | Exposure Time in micro S.
ExtendedDepthOfField | 0x00480012 | Extended Depth of Field.
FacetSequence | 0x00660034 | Facet Sequence.
FailedAttributesSequence | 0x00741048 | Failed Attributes Sequence.
FailedSOPInstanceUIDList | 0x00080058 | Failed SOP Instance UID List.
FailedSOPSequence | 0x00081198 | Failed SOP Sequence.
FailureAttributes | 0x2200000E | Failure Attributes.
FailureReason | 0x00081197 | Failure Reason.
FalseNegativesEstimate | 0x00240046 | False Negatives Estimate.
FalseNegativesEstimateFlag | 0x00240045 | False Negatives Estimate Flag.
FalseNegativesQuantity | 0x00240050 | False Negatives Quantity.
FalsePositivesEstimate | 0x00240054 | False Positives Estimate.
FalsePositivesEstimateFlag | 0x00240053 | False Positives Estimate Flag.
FalsePositivesQuantity | 0x00240060 | False Positives Quantity.
FiducialDescription | 0x0070030F | Fiducial Description.
FiducialIdentifier | 0x00700310 | Fiducial Identifier.
FiducialIdentifierCodeSequence | 0x00700311 | Fiducial Identifier Code Sequence.
FiducialSequence | 0x0070031E | Fiducial Sequence.
FiducialSetSequence | 0x0070031C | Fiducial Set Sequence.
FiducialUID | 0x0070031A | Fiducial UID.
FieldofViewDescription | 0x00189433 | Field of View Description.
FieldOfViewDimensions | 0x00181149 | Field of View Dimension(s).
FieldofViewDimensionsInFloat | 0x00189461 | Field of View Dimension(s) in Float.
FieldOfViewHorizontalFlip | 0x00187034 | Field of View Horizontal Flip.
FieldOfViewOrigin | 0x00187030 | Field of View Origin.
FieldOfViewRotation | 0x00187032 | Field of View Rotation.
FieldofViewSequence | 0x00189432 | Field of View Sequence.
FieldOfViewShape | 0x00181147 | Field of View Shape.
FileMetaInformationGroupLength | 0x00020000 | File Meta Information Group Length.
FileMetaInformationVersion | 0x00020001 | File Meta Information Version.
FilesetConsistencyFlag | 0x00041212 | File-set Consistency Flag.
FilesetDescriptorFileID | 0x00041141 | File-set Descriptor File ID.
FilesetID | 0x00041130 | File-set ID.
FillerOrderNumberImagingServiceRequest | 0x00402017 | Filler Order Number / Imaging Service Request.
FillerOrderNumberImagingServiceRequestRetired | 0x00402007 | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FillerOrderNumberProcedure | 0x00401007 | Filler Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FillMode | 0x00700257 | Fill Mode.
FillPattern | 0x00700256 | Fill Pattern.
FillStyleSequence | 0x00700233 | Fill Style Sequence.
FilmBoxContentSequence | 0x21300030 | Film Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FilmConsumptionSequence | 0x00400321 | Film Consumption Sequence.
FilmDestination | 0x20000040 | Film Destination.
FilmImagePosition | 0x20200010 | Image Box Position. This tag name has been deprecated, use tag with the same value defined in the previous line.
FilmOrientation | 0x20100040 | Film Orientation.
FilmSessionLabel | 0x20000050 | Film Session Label.
FilmSizeID | 0x20100050 | Film Size ID.
FilterBeamPathLengthMaximum | 0x00187058 | Filter Beam Path Length Maximum.
FilterBeamPathLengthMinimum | 0x00187056 | Filter Beam Path Length Minimum.
FilterbyAttributePresence | 0x00720404 | Filter-by Attribute Presence.
FilterbyCategory | 0x00720402 | Filter-by Category.
FilterbyOperator | 0x00720406 | Filter-by Operator.
FilterHighFrequency | 0x003A0221 | Filter High Frequency.
FilterLowFrequency | 0x003A0220 | Filter Low Frequency.
FilterMaterial | 0x00187050 | Filter Material.
FilterMaterialUsedInGainCalibration | 0x00143074 | Filter Material Used in Gain Calibration.
FilterMaxThickness | 0x00187054 | Filter Thickness Maximum. This tag name has been deprecated, use tag with the same value defined in the previous line.
FilterMinThickness | 0x00187052 | Filter Thickness Minimum. This tag name has been deprecated, use tag with the same value defined in the previous line.
FilterOperationsSequence | 0x00720400 | Filter Operations Sequence.
FilterThicknessMaximum | 0x00187054 | Filter Thickness Maximum.
FilterThicknessMinimum | 0x00187052 | Filter Thickness Minimum.
FilterThicknessUsedInGainCalibration | 0x00143075 | Filter Thickness Used in Gain Calibration.
FilterType | 0x00181160 | Filter Type.
FinalCumulativeMetersetWeight | 0x300A010E | Final Cumulative Meterset Weight.
FinalCumulativeTimeWeight | 0x300A02C8 | Final Cumulative Time Weight.
FindingsFlagTrial | 0x0040A007 | Findings Flag (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindingsGroupRecordingDateTrial | 0x0040A023 | Findings Group Recording Date (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindingsGroupRecordingTimeTrial | 0x0040A024 | Findings Group Recording Time (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindingsGroupUIDTrial | 0x0040A021 | Findings Group UID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindingsSequenceTrial | 0x0040A020 | Findings Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindingsSourceCategoryCodeSequenceTrial | 0x0040A026 | Findings Source Category Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FindLocation | 0x00000400 | Find Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
FiniteVolume | 0x0066000E | Finite Volume.
FirstALineLocation | 0x00520034 | First A?line Location.
FirstOrderPhaseCorrection | 0x00189198 | First Order Phase Correction.
FirstOrderPhaseCorrectionAngle | 0x56000010 | First Order Phase Correction Angle.
FirstTreatmentDate | 0x30080054 | First Treatment Date.
FixationCheckedQuantity | 0x00240035 | Fixation Checked Quantity.
FixationDeviceDescription | 0x300A0196 | Fixation Device Description.
FixationDeviceLabel | 0x300A0194 | Fixation Device Label.
FixationDevicePitchAngle | 0x300A0199 | Fixation Device Pitch Angle.
FixationDevicePosition | 0x300A0198 | Fixation Device Position.
FixationDeviceRollAngle | 0x300A019A | Fixation Device Roll Angle.
FixationDeviceSequence | 0x300A0190 | Fixation Device Sequence.
FixationDeviceType | 0x300A0192 | Fixation Device Type.
FixationLightAzimuthalAngle | 0x300A0356 | Fixation Light Azimuthal Angle.
FixationLightPolarAngle | 0x300A0358 | Fixation Light Polar Angle.
FixationMethodCodeSequence | 0x006863AC | Fixation Method Code Sequence.
FixationMonitoringCodeSequence | 0x00240033 | Fixation Monitoring Code Sequence.
FixationSequence | 0x00240032 | Fixation Sequence.
FlatKeratometricAxisSequence | 0x00460080 | Flat Keratometric Axis Sequence.
FlipAngle | 0x00181314 | Flip Angle.
FlowCompDirection | 0x00189183 | Flow Compensation Direction. This tag name has been deprecated, use tag with the same value defined in the previous line.
FlowCompensation | 0x00189010 | Flow Compensation.
FlowCompensationDirection | 0x00189183 | Flow Compensation Direction.
FluenceDataScale | 0x30020042 | Fluence Data Scale.
FluenceDataSource | 0x30020041 | Fluence Data Source.
FluenceMapSequence | 0x30020040 | Fluence Map Sequence.
FluenceMode | 0x30020051 | Fluence Mode.
FluenceModeID | 0x30020052 | Fluence Mode ID.
FluoroscopyFlag | 0x00189334 | Fluoroscopy Flag.
FocalDistance | 0x00181182 | Focal Distance.
FocalSpots | 0x00181190 | Focal Spot(s).
FocusDepth | 0x00185012 | Focus Depth.
FocusMethod | 0x00480011 | Focus Method.
FontName | 0x00700227 | Font Name.
FontNameType | 0x00700228 | Font Name Type.
FORMAT | 0x00000030 | DICOM format marker.
FovealPointNormativeDataFlag | 0x00240117 | Foveal Point Normative Data Flag.
FovealPointProbabilityValue | 0x00240118 | Foveal Point Probability Value.
FovealSensitivity | 0x00240087 | Foveal Sensitivity.
FovealSensitivityMeasured | 0x00240086 | Foveal Sensitivity Measured.
FovHorizontalFlip | 0x00187034 | Field of View Horizontal Flip. This tag name has been deprecated, use tag with the same value defined in the previous line.
FovOrigin | 0x00187030 | Field of View Origin. This tag name has been deprecated, use tag with the same value defined in the previous line.
FovRotation | 0x00187032 | Field of View Rotation. This tag name has been deprecated, use tag with the same value defined in the previous line.
FractionalChannelDisplayScale | 0x003A0247 | Fractional Channel Display Scale.
FractionGroupDescription | 0x300A0072 | Fraction Group Description.
FractionGroupNumber | 0x300A0071 | Fraction Group Number.
FractionGroupSequence | 0x300A0070 | Fraction Group Sequence.
FractionGroupSummarySequence | 0x30080220 | Fraction Group Summary Sequence.
FractionGroupType | 0x30080224 | Fraction Group Type.
FractionNumber | 0x30020029 | Fraction Number.
FractionPattern | 0x300A007B | Fraction Pattern.
FractionStatusSummarySequence | 0x30080240 | Fraction Status Summary Sequence.
FrameAcqDatetime | 0x00189074 | Frame Acquisition DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrameAcqDuration | 0x00189220 | Frame Acquisition Duration. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrameAcqNumber | 0x00209156 | Frame Acquisition Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrameAcquisitionDateTime | 0x00189074 | Frame Acquisition DateTime.
FrameAcquisitionDuration | 0x00189220 | Frame Acquisition Duration.
FrameAcquisitionNumber | 0x00209156 | Frame Acquisition Number.
FrameAcquisitionSequence | 0x00189417 | Frame Acquisition Sequence.
FrameAnatomySequence | 0x00209071 | Frame Anatomy Sequence.
FrameComments | 0x00209158 | Frame Comments.
FrameContentSequence | 0x00209111 | Frame Content Sequence.
FrameDelay | 0x00181066 | Frame Delay.
FrameDetectorParametersSequence | 0x00189451 | Frame Detector Parameters Sequence.
FrameDimensionPointer | 0x0028000A | Frame Dimension Pointer.
FrameDisplaySequence | 0x00089458 | Frame Display Sequence.
FrameDisplayShutterSequence | 0x00189472 | Frame Display Shutter Sequence.
FrameExtractionSequence | 0x00081164 | Frame Extraction Sequence.
FrameIncrementPointer | 0x00280009 | Frame Increment Pointer.
FrameLabel | 0x00209453 | Frame Label.
FrameLabelVector | 0x00182002 | Frame Label Vector.
FrameLaterality | 0x00209072 | Frame Laterality.
FrameNumbersOfInterest | 0x00286020 | Frame Numbers of Interest (FOI).
FrameOfInterestDescription | 0x00286022 | Frame of Interest Description.
FrameofInterestType | 0x00286023 | Frame of Interest Type.
FrameOfReferenceRelationshipSequence | 0x300600C0 | Frame of Reference Relationship Sequence.
FrameOfReferenceTransformationComment | 0x300600C8 | Frame of Reference Transformation Comment.
FrameOfReferenceTransformationMatrix | 0x300600C6 | Frame of Reference Transformation Matrix.
FrameofReferenceTransformationMatrixType | 0x0070030C | Frame of Reference Transformation Matrix Type.
FrameOfReferenceTransformationType | 0x300600C4 | Frame of Reference Transformation Type.
FrameOfReferenceUID | 0x00200052 | Frame of Reference UID.
FramePixelDataPropertiesSequence | 0x00289443 | Frame Pixel Data Properties Sequence.
FramePixelShiftSequence | 0x00289415 | Frame Pixel Shift Sequence.
FramePrimaryAngleVector | 0x00182003 | Frame Primary Angle Vector.
FrameReferenceDatetime | 0x00189151 | Frame Reference DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrameReferenceDateTime | 0x00189151 | Frame Reference DateTime.
FrameReferenceTime | 0x00541300 | Frame Reference Time.
FrameSecondaryAngleVector | 0x00182004 | Frame Secondary Angle Vector.
FramesOfInterestDescription | 0x00286022 | Frame of Interest Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrameTime | 0x00181063 | Frame Time.
FrameTimeVector | 0x00181065 | Frame Time Vector.
FrameType | 0x00089007 | Frame Type.
FrameVoiLutSequence | 0x00289132 | Frame VOI LUT Sequence.
FramingType | 0x00181064 | Cardiac Framing Type. This tag name has been deprecated, use tag with the same value defined in the previous line.
FrequencyCorrection | 0x00189101 | Frequency Correction.
FunctionalGroupPointer | 0x00209167 | Functional Group Pointer.
FunctionalGroupPrivateCreator | 0x00209238 | Functional Group Private Creator.
GainCorrectionReferenceSequence | 0x00143060 | Gain Correction Reference Sequence.
GantryAngle | 0x300A011E | Gantry Angle.
GantryAngleTolerance | 0x300A0044 | Gantry Angle Tolerance.
GantryDetectorSlew | 0x00181121 | Gantry/Detector Slew.
GantryDetectorTilt | 0x00181120 | Gantry/Detector Tilt.
GantryID | 0x00181008 | Gantry ID.
GantryMotionCorrected | 0x00189762 | Gantry Motion Corrected.
GantryPitchAngle | 0x300A014A | Gantry Pitch Angle.
GantryPitchAngleTolerance | 0x300A014E | Gantry Pitch Angle Tolerance.
GantryPitchRotationDirection | 0x300A014C | Gantry Pitch Rotation Direction.
GantryRotationDirection | 0x300A011F | Gantry Rotation Direction.
GantryType | 0x40101008 | Gantry Type.
GapLength | 0x00700261 | Gap Length.
GatedInformationSequence | 0x00540062 | Gated Information Sequence.
GatedInfoSequence | 0x00540062 | Gated Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
GateSettingsSequence | 0x00144060 | Gate Settings Sequence.
GateThreshold | 0x00144062 | Gate Threshold.
GeneralAccessoryDescription | 0x300A0422 | General Accessory Description.
GeneralAccessoryID | 0x300A0421 | General Accessory ID.
GeneralAccessoryNumber | 0x300A0424 | General Accessory Number.
GeneralAccessorySequence | 0x300A0420 | General Accessory Sequence.
GeneralAccessoryType | 0x300A0423 | General Accessory Type.
GeneralizedDefectCorrectedSensitivityDeviationFlag | 0x00240102 | Generalized Defect Corrected Sensitivity Deviation Flag.
GeneralizedDefectCorrectedSensitivityDeviationProbabilityValue | 0x00240104 | Generalized Defect Corrected Sensitivity Deviation Probability Value.
GeneralizedDefectCorrectedSensitivityDeviationValue | 0x00240103 | Generalized Defect Corrected Sensitivity Deviation Value.
GeneralizedDefectSensitivityDeviationAlgorithmSequence | 0x00240067 | Generalized Defect Sensitivity Deviation Algorithm Sequence.
GeneralMachineVerificationSequence | 0x00741042 | General Machine Verification Sequence.
GeneralPerformedProcedureStepStatus | 0x00404002 | General Purpose Performed Procedure Step Status. This tag name has been deprecated, use tag with the same value defined in the previous line.
GeneralPurposePerformedProcedureStepStatus | 0x00404002 | General Purpose Performed Procedure Step Status.
GeneralPurposeScheduledProcedureStepPriority | 0x00404003 | General Purpose Scheduled Procedure Step Priority.
GeneralPurposeScheduledProcedureStepStatus | 0x00404001 | General Purpose Scheduled Procedure Step Status.
GeneralScheduledProcedureStepPriority | 0x00404003 | General Purpose Scheduled Procedure Step Priority. This tag name has been deprecated, use tag with the same value defined in the previous line.
GeneralScheduledProcedureStepStatus | 0x00404001 | General Purpose Scheduled Procedure Step Status. This tag name has been deprecated, use tag with the same value defined in the previous line.
GeneratorID | 0x00181005 | Generator ID.
GeneratorPower | 0x00181170 | Generator Power.
GeometricalProperties | 0x00289444 | Geometrical Properties.
GeometricMaximumDistortion | 0x00289445 | Geometric Maximum Distortion.
GeometryOfKspaceTraversal | 0x00189032 | Geometry of k-Space Traversal.
GlobalDeviationFromNormal | 0x00240066 | Global Deviation From Normal.
GlobalDeviationProbability | 0x00240071 | Global Deviation Probability.
GlobalDeviationProbabilityNormalsFlag | 0x00240059 | Global Deviation Probability Normals Flag.
GlobalDeviationProbabilitySequence | 0x00240083 | Global Deviation Probability Sequence.
GradientEchoTrainLength | 0x00189241 | Gradient Echo Train Length.
GradientOutput | 0x00189182 | Gradient Output.
GradientOutputType | 0x00189180 | Gradient Output Type.
GraphicAnnotationSequence | 0x00700001 | Graphic Annotation Sequence.
GraphicAnnotationUnits | 0x00700005 | Graphic Annotation Units.
GraphicCoordinatesDataSequence | 0x00700318 | Graphic Coordinates Data Sequence.
GraphicData | 0x00700022 | Graphic Data.
GraphicDimensions | 0x00700020 | Graphic Dimensions.
GraphicFilled | 0x00700024 | Graphic Filled.
GraphicGroupDescription | 0x00700208 | Graphic Group Description.
GraphicGroupID | 0x00700295 | Graphic Group ID.
GraphicGroupLabel | 0x00700207 | Graphic Group Label.
GraphicGroupSequence | 0x00700234 | Graphic Group Sequence.
GraphicLayer | 0x00700002 | Graphic Layer.
GraphicLayerDescription | 0x00700068 | Graphic Layer Description.
GraphicLayerOrder | 0x00700062 | Graphic Layer Order.
GraphicLayerRecommendedDisplayCIELabValue | 0x00700401 | Graphic Layer Recommended Display CIELab Value.
GraphicLayerRecommendedDisplayGrayscaleValue | 0x00700066 | Graphic Layer Recommended Display Grayscale Value.
GraphicLayerRecommendedDisplayRGBValue | 0x00700067 | Graphic Layer Recommended Display RGB Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
GraphicLayerSequence | 0x00700060 | Graphic Layer Sequence.
GraphicObjectSequence | 0x00700009 | Graphic Object Sequence.
GraphicType | 0x00700023 | Graphic Type.
GrayLookupTableData | 0x00281200 | Gray Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
GrayLookupTableDescriptor | 0x00281100 | Gray Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
GrayScale | 0x00281080 | Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
GreenPaletteColorLookupTableData | 0x00281202 | Green Palette Color Lookup Table Data.
GreenPaletteColorLookupTableDescriptor | 0x00281102 | Green Palette Color Lookup Table Descriptor.
Grid | 0x00181166 | Grid value.
GridAbsorbingMaterial | 0x00187040 | Grid Absorbing Material.
GridAspectRatio | 0x00187046 | Grid Aspect Ratio.
GridDimensions | 0x00640007 | Grid Dimensions.
GridFocalDistance | 0x0018704C | Grid Focal Distance.
GridFrameOffsetVector | 0x3004000C | Grid Frame Offset Vector.
GridID | 0x00181006 | Grid Identifier.
GridPeriod | 0x00187048 | Grid Period.
GridPitch | 0x00187044 | Grid Pitch.
GridResolution | 0x00640008 | Grid Resolution.
GridSpacingMaterial | 0x00187041 | Grid Spacing Material.
GridThickness | 0x00187042 | Grid Thickness.
Group0000Length | 0x00000000 | Command Group Length. This tag name has been deprecated, use tag with the same value defined in the previous line.
Group0000LengthToEnd | 0x00000001 | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0002Length | 0x00020000 | File Meta Information Group Length. This tag name has been deprecated, use tag with the same value defined in the previous line.
Group0004Length | 0x00040000 | Group 0004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0008Length | 0x00080000 | Group 0008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0008LengthToEnd | 0x00080001 | Group 0008 Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0010Length | 0x00100000 | Group 0010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0012Length | 0x00120000 | Group 0012 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0014Length | 0x00140000 | Group 0014 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0018Length | 0x00180000 | Group 0018 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0020Length | 0x00200000 | Group 0020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0022Length | 0x00220000 | Group 0022 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0024Length | 0x00240000 | Group 0024 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0028Length | 0x00280000 | Group 0028 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0032Length | 0x00320000 | Group 0032 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0038Length | 0x00380000 | Group 0038 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group003ALength | 0x003A0000 | Group 003A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0040Length | 0x00400000 | Group 0040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0042Length | 0x00420000 | Group 0042 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0044Length | 0x00440000 | Group 0044 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0046Length | 0x00460000 | Group 0046 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0048Length | 0x00480000 | Group 0048 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0050Length | 0x00500000 | Group 0050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0052Length | 0x00520000 | Group 0052 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0054Length | 0x00540000 | Group 0054 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0060Length | 0x00600000 | Group 0060 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0062Length | 0x00620000 | Group 0062 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0064Length | 0x00640000 | Group 0064 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0066Length | 0x00660000 | Group 0066 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0068Length | 0x00680000 | Group 0068 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0070Length | 0x00700000 | Group 0070 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0072Length | 0x00720000 | Group 0072 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0074Length | 0x00740000 | Group 0074 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0076Length | 0x00760000 | Group 0076 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0078Length | 0x00780000 | Group 0078 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0088Length | 0x00880000 | Group 0088 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0100Length | 0x01000000 | Group 0100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group0400Length | 0x04000000 | Group 0400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group1000Length | 0x10000000 | Group 1000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group1010Length | 0x10100000 | Group 1010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2000Length | 0x20000000 | Group 2000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2010Length | 0x20100000 | Group 2010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2020Length | 0x20200000 | Group 2020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2030Length | 0x20300000 | Group 2030 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2040Length | 0x20400000 | Group 2040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2050Length | 0x20500000 | Group 2050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2100Length | 0x21000000 | Group 2100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2110Length | 0x21100000 | Group 2110 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2120Length | 0x21200000 | Group 2120 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2130Length | 0x21300000 | Group 2130 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group2200Length | 0x22000000 | Group 2200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group3002Length | 0x30020000 | Group 3002 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group3004Length | 0x30040000 | Group 3004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group3006Length | 0x30060000 | Group 3006 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group3008Length | 0x30080000 | Group 3008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group300ALength | 0x300A0000 | Group 300A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group300CLength | 0x300C0000 | Group 300C Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group300ELength | 0x300E0000 | Group 300E Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group4000Length | 0x40000000 | Group 4000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group4008Length | 0x40080000 | Group 4008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group4010Length | 0x40100000 | Group 4010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group4FFELength | 0x4FFE0000 | Group 4FFE Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group50xxLength | 0x50FF0000 | Group 50xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group5200Length | 0x52000000 | Group 5200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group5400Length | 0x54000000 | Group 5400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group5600Length | 0x56000000 | Group 5600 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group60xxLength | 0x60FF0000 | Group 60xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group7FE0Length | 0x7FE00000 | Group 7FE0 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Group7FFFLength | 0x7FFF0000 | Group 7FFF Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
GroupLabel | 0x003A0020 | Multiplex Group Label. This tag name has been deprecated, use tag with the same value defined in the previous line.
HalfValueLayer | 0x00400314 | Half Value Layer.
HangingProtocolCreationDatetime | 0x0072000A | Hanging Protocol Creation DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
HangingProtocolCreationDateTime | 0x0072000A | Hanging Protocol Creation DateTime.
HangingProtocolCreator | 0x00720008 | Hanging Protocol Creator.
HangingProtocolDefinitionSequence | 0x0072000C | Hanging Protocol Definition Sequence.
HangingProtocolDescription | 0x00720004 | Hanging Protocol Description.
HangingProtocolLevel | 0x00720006 | Hanging Protocol Level.
HangingProtocolName | 0x00720002 | Hanging Protocol Name.
HangingProtocolUserGroupName | 0x00720010 | Hanging Protocol User Group Name.
HangingProtocolUserIdentificationCodeSequence | 0x0072000E | Hanging Protocol User Identification Code Sequence.
HardcopyCreationDeviceID | 0x00181011 | Hardcopy Creation Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HardcopyDeviceManufacturer | 0x00181017 | Hardcopy Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HardcopyDeviceManufacturersModelName | 0x0018101B | Hardcopy Device Manufacturer's Model Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HardcopyDeviceSoftwareVersion | 0x0018101A | Hardcopy Device Software Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HeadFixationAngle | 0x300A0148 | Head Fixation Angle.
HeartRate | 0x00181088 | Heart Rate.
HighBit | 0x00280102 | Image High Bit.
HighDoseTechniqueType | 0x300A00C7 | High-Dose Technique Type.
HighEnergyDetectors | 0x40100002 | High Energy Detectors.
HighRrValue | 0x00181082 | High R-R Value.
HistogramBinNumber | 0x00603002 | Histogram Number of Bins. This tag name has been deprecated, use tag with the same value defined in the previous line.
HistogramBinWidth | 0x00603008 | Histogram Bin Width.
HistogramData | 0x00603020 | Histogram Data.
HistogramExplanation | 0x00603010 | Histogram Explanation.
HistogramFirstBinValue | 0x00603004 | Histogram First Bin Value.
HistogramLastBinValue | 0x00603006 | Histogram Last Bin Value.
HistogramNumberOfBins | 0x00603002 | Histogram Number of Bins.
HistogramSequence | 0x00603000 | Histogram Sequence.
HL7DocumentEffectiveTime | 0x0040E004 | HL7 Document Effective Time.
HL7DocumentTypeCodeSequence | 0x0040E006 | HL7 Document Type Code Sequence.
HL7InstanceIdentifier | 0x0040E001 | HL7 Instance Identifier.
HL7StructuredDocumentReferenceSequence | 0x0040A390 | HL7 Structured Document Reference Sequence.
HomeCommunityID | 0x0040E031 | Home Community ID.
HorizontalAlignment | 0x00700242 | Horizontal Alignment.
HorizontalFieldofView | 0x0022000C | Horizontal Field of View.
HorizontalOffsetOfSensor | 0x00143024 | Horizontal Offset of Sensor.
HorizontalPrismBase | 0x00460032 | Horizontal Prism Base.
HorizontalPrismPower | 0x00460030 | Horizontal Prism Power.
HPGLContourPenNumber | 0x00686310 | HPGL Contour Pen Number.
HPGLDocument | 0x00686300 | HPGL Document.
HPGLDocumentID | 0x006862D0 | HPGL Document ID.
HPGLDocumentLabel | 0x006862D5 | HPGL Document Label.
HPGLDocumentScaling | 0x006862F2 | HPGL Document Scaling.
HPGLDocumentSequence | 0x006862C0 | HPGL Document Sequence.
HPGLPenDescription | 0x00686345 | HPGL Pen Description.
HPGLPenLabel | 0x00686340 | HPGL Pen Label.
HPGLPenNumber | 0x00686330 | HPGL Pen Number.
HPGLPenSequence | 0x00686320 | HPGL Pen Sequence.
HuffmanTableSize | 0x1000FFF2 | Huffman Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HuffmanTableTriplet | 0x1000FFF3 | Huffman Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
HumanPerformerCodeSequence | 0x00404009 | Human Performer Code Sequence.
HumanPerformerName | 0x00404037 | Human Performer's Name.
HumanPerformerOrganization | 0x00404036 | Human Performer's Organization.
HumanPerformersName | 0x00404037 | Human Performer's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
HumanPerformersOrganization | 0x00404036 | Human Performer's Organization. This tag name has been deprecated, use tag with the same value defined in the previous line.
ICCProfile | 0x00282000 | ICC Profile.
IconImageSequence | 0x00880200 | Icon Image Sequence.
IdenticalDocumentsSequence | 0x0040A525 | Identical Documents Sequence.
IdentificationDescriptionTrial | 0x0040A224 | Identification Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IdentifierCodeSequenceTrial | 0x0040A070 | Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IdentifierTypeCode | 0x00400035 | Identifier Type Code.
IdentifyingComments | 0x00084000 | Identifying Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Illumination | 0x2010015E | Illumination value.
IlluminationBandwidth | 0x00220057 | Illumination Bandwidth.
IlluminationColorCodeSequence | 0x00480108 | Illumination Color Code Sequence.
IlluminationPower | 0x00220056 | Illumination Power.
IlluminationTypeCodeSequence | 0x00220016 | Illumination Type Code Sequence.
IlluminationWaveLength | 0x00220055 | Illumination Wave Length.
IlluminatorTypeCodeSequence | 0x00480100 | Illuminator Type Code Sequence.
ImageAndFluoroscopyAreaDoseProduct | 0x0018115E | Image and Fluoroscopy Area Dose Product.
ImageAreaDoseProduct | 0x0018115E | Image and Fluoroscopy Area Dose Product. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImageBoxContentSequence | 0x21300040 | Image Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageBoxesSequence | 0x00720300 | Image Boxes Sequence.
ImageBoxLargeScrollAmount | 0x00720318 | Image Box Large Scroll Amount.
ImageBoxLargeScrollType | 0x00720316 | Image Box Large Scroll Type.
ImageBoxLayoutType | 0x00720304 | Image Box Layout Type.
ImageBoxNumber | 0x00720302 | Image Box Number.
ImageBoxOverlapPriority | 0x00720320 | Image Box Overlap Priority.
ImageBoxPosition | 0x20200010 | Image Box Position.
ImageBoxPresentationLUTFlag | 0x2000006A | Image Box Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageBoxScrollDirection | 0x00720310 | Image Box Scroll Direction.
ImageBoxSmallScrollAmount | 0x00720314 | Image Box Small Scroll Amount.
ImageBoxSmallScrollType | 0x00720312 | Image Box Small Scroll Type.
ImageBoxSynchronizationSequence | 0x00720430 | Image Box Synchronization Sequence.
ImageBoxTileHorizontalDimension | 0x00720306 | Image Box Tile Horizontal Dimension.
ImageBoxTileVerticalDimension | 0x00720308 | Image Box Tile Vertical Dimension.
ImageCenterPointCoordinatesSequence | 0x0040071A | Image Center Point Coordinates Sequence.
ImageCenterPointCoordSequence | 0x0040071A | Image Center Point Coordinates Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImageComments | 0x00204000 | Image Comments.
ImageDataLocation | 0x002808F8 | Image Data Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageDataTypeSequence | 0x00189807 | Image Data Type Sequence.
ImageDimensions | 0x00280005 | Image Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageDisplayFormat | 0x20100010 | Image Display Format.
ImagedNucleus | 0x00180085 | Imaged Nucleus.
ImagedVolumeDepth | 0x00480003 | Imaged Volume Depth.
ImagedVolumeHeight | 0x00480002 | Imaged Volume Height.
ImagedVolumeWidth | 0x00480001 | Imaged Volume Width.
ImageFilter | 0x00189320 | Image Filter.
ImageFormat | 0x00280040 | Image Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageFrameOrigin | 0x60FF0051 | Image Frame Origin.
ImageGeometryType | 0x00200070 | Image Geometry Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageHorizontalFlip | 0x00700041 | Image Horizontal Flip.
ImageID | 0x00540400 | Image Identifier.
ImageIndex | 0x00541330 | Image Index.
ImageLaterality | 0x00200062 | Image Laterality.
ImageLocation | 0x00280200 | Image Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageOrientation | 0x00200035 | Image Orientation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageOrientationPatient | 0x00200037 | Image Orientation (Patient).
ImageOrientationSlide | 0x00480102 | Image Orientation (Slide).
ImageOrientationVolume | 0x00209302 | Image Orientation (Volume).
ImageOverlayBoxContentSequence | 0x21300060 | Image Overlay Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageOverlayFlag | 0x20000067 | Image Overlay Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagePathFilterPassBand | 0x00220004 | Image Path Filter Pass Band.
ImagePathFilterPassThroughWavelength | 0x00220003 | Image Path Filter Pass-Through Wavelength.
ImagePathFilterTypeStackCodeSequence | 0x00220018 | Image Path Filter Type Stack Code Sequence.
ImagePlanePixelSpacing | 0x30020011 | Image Plane Pixel Spacing.
ImagePosition | 0x00200030 | Image Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagePositionPatient | 0x00200032 | Image Position (Patient).
ImagePositionVolume | 0x00209301 | Image Position (Volume).
ImagePresentationComments | 0x00284000 | Image Presentation Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageProcessingApplied | 0x00289446 | Image Processing Applied.
ImageRotation | 0x00700042 | Image Rotation.
ImageRotationRetired | 0x00700040 | Image Rotation (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagerPixelSpacing | 0x00181164 | Imager Pixel Spacing.
ImageSetLabel | 0x00720040 | Image Set Label.
ImageSetNumber | 0x00720032 | Image Set Number.
ImageSetSelectorCategory | 0x00720034 | Image Set Selector Category.
ImageSetSelectorSequence | 0x00720022 | Image Set Selector Sequence.
ImageSetSelectorUsageFlag | 0x00720024 | Image Set Selector Usage Flag.
ImageSetsSequence | 0x00720020 | Image Sets Sequence.
ImagesInAcquisition | 0x00201002 | Images in Acquisition.
ImagesInSeries | 0x00201003 | Images in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagesInStudy | 0x00201005 | Images in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageSizeFlagRequested | 0x202000A0 | Requested Image Size Flag. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImageToEquipmentMappingMatrix | 0x00289520 | Image to Equipment Mapping Matrix.
ImageTransformationMatrix | 0x00185210 | Image Transformation Matrix. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageTranslationVector | 0x00185212 | Image Translation Vector. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImageTriggerDelay | 0x00181067 | Image Trigger Delay.
ImageType | 0x00080008 | Image Type.
ImagingDeviceSpecificAcqParameter | 0x300A00CC | Imaging Device-Specific Acquisition Parameters. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImagingDeviceSpecificAcquisitionParameters | 0x300A00CC | Imaging Device-Specific Acquisition Parameters.
ImagingFrequency | 0x00180084 | Imaging Frequency.
ImagingServiceRequestComment | 0x00402400 | Imaging Service Request Comments. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImagingServiceRequestComments | 0x00402400 | Imaging Service Request Comments.
ImagingServiceRequestDate | 0x00402004 | Issue Date of Imaging Service Request. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImagingServiceRequestFillerOrderNum | 0x00402007 | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagingServiceRequestPlacerOrderNum | 0x00402006 | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ImagingServiceRequestTime | 0x00402005 | Issue Time of Imaging Service Request. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImplantAssemblyTemplateIssuer | 0x00760003 | Implant Assembly Template Issuer.
ImplantAssemblyTemplateName | 0x00760001 | Implant Assembly Template Name.
ImplantAssemblyTemplateTargetAnatomySequence | 0x00760010 | Implant Assembly Template Target Anatomy Sequence.
ImplantAssemblyTemplateType | 0x0076000A | Implant Assembly Template Type.
ImplantAssemblyTemplateVersion | 0x00760006 | Implant Assembly Template Version.
ImplantPresent | 0x00281300 | Breast Implant Present. This tag name has been deprecated, use tag with the same value defined in the previous line.
ImplantRegulatoryDisapprovalCodeSequence | 0x006862A0 | Implant Regulatory Disapproval Code Sequence.
ImplantSize | 0x00686210 | Implant Size.
ImplantTargetAnatomySequence | 0x00686230 | Implant Target Anatomy Sequence.
ImplantTemplate3DModelSurfaceNumber | 0x00686350 | Implant Template 3D Model Surface Number.
ImplantTemplateGroupDescription | 0x00780010 | Implant Template Group Description.
ImplantTemplateGroupIssuer | 0x00780020 | Implant Template Group Issuer.
ImplantTemplateGroupMemberID | 0x0078002E | Implant Template Group Member ID.
ImplantTemplateGroupMemberMatching2DCoordinatesSequence | 0x00780070 | Implant Template Group Member Matching 2D Coordinates Sequence.
ImplantTemplateGroupMembersSequence | 0x0078002A | Implant Template Group Members Sequence.
ImplantTemplateGroupName | 0x00780001 | Implant Template Group Name.
ImplantTemplateGroupTargetAnatomySequence | 0x00780028 | Implant Template Group Target Anatomy Sequence.
ImplantTemplateGroupVariationDimensionName | 0x007800B2 | Implant Template Group Variation Dimension Name.
ImplantTemplateGroupVariationDimensionRank | 0x007800B8 | Implant Template Group Variation Dimension Rank.
ImplantTemplateGroupVariationDimensionRankSequence | 0x007800B4 | Implant Template Group Variation Dimension Rank Sequence.
ImplantTemplateGroupVariationDimensionSequence | 0x007800B0 | Implant Template Group Variation Dimension Sequence.
ImplantTemplateGroupVersion | 0x00780024 | Implant Template Group Version.
ImplantTemplateVersion | 0x00686221 | Implant Template Version.
ImplantType | 0x00686223 | Implant Type.
ImplantTypeCodeSequence | 0x006863A8 | Implant Type Code Sequence.
ImplementationClassUID | 0x00020012 | Implementation Class UID.
ImplementationVersionName | 0x00020013 | Implementation Version Name.
Impressions | 0x40080300 | Impressions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InboundArrivalType | 0x40101056 | Inbound Arrival Type.
IncidentAngle | 0x00144052 | Incident Angle.
IncludeDisplayApplication | 0x22000009 | Include Display Application.
IncludeNonDICOMObjects | 0x22000008 | Include Non-DICOM Objects.
InConcatenationNumber | 0x00209162 | In-concatenation Number.
InConcatenationTotalNumber | 0x00209163 | In-concatenation Total Number.
IndexNormalsFlag | 0x00240338 | Index Normals Flag.
IndexProbability | 0x00240341 | Index Probability.
IndexProbabilitySequence | 0x00240344 | Index Probability Sequence.
IndicationDescription | 0x00142018 | Indication Description.
IndicationDisposition | 0x0014201C | Indication Disposition.
IndicationLabel | 0x00142016 | Indication Label.
IndicationNumber | 0x00142014 | Indication Number.
IndicationPhysicalPropertySequence | 0x00142030 | Indication Physical Property Sequence.
IndicationROISequence | 0x0014201E | Indication ROI Sequence.
IndicationSequence | 0x00142012 | Indication Sequence.
IndicationType | 0x0014201A | Indication Type.
InformationFromManufacturerSequence | 0x00686260 | Information From Manufacturer Sequence.
InformationIssueDateTime | 0x00686270 | Information Issue DateTime.
InformationSummary | 0x00686280 | Information Summary.
InitialCineRunState | 0x00180042 | Initial Cine Run State.
InnerDiameter | 0x00140056 | Inner Diameter.
InPlanePhaseEncodingDirection | 0x00181312 | In-plane Phase Encoding Direction.
InputAvailabilityFlag | 0x00404020 | Input Availability Flag.
InputInformationSequence | 0x00404021 | Input Information Sequence.
InputReadinessState | 0x00404041 | Input Readiness State.
InStackPositionNumber | 0x00209057 | In-Stack Position Number.
InstanceAvailability | 0x00080056 | Instance Availability.
InstanceCreationDate | 0x00080012 | Instance Creation Date.
InstanceCreationTime | 0x00080013 | Instance Creation Time.
InstanceCreatorUID | 0x00080014 | Instance Creator UID.
InstanceNumber | 0x00200013 | Instance Number.
InstitutionAddress | 0x00080081 | Institution Address.
InstitutionalDepartmentName | 0x00081040 | Institutional Department Name.
InstitutionCodeSequence | 0x00080082 | Institution Code Sequence.
InstitutionName | 0x00080080 | Institution Name.
InsurancePlanIdentification | 0x00101050 | Insurance Plan Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IntendedRecipientOfResultIDSequence | 0x00401011 | Intended Recipients of Results Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
IntendedRecipients | 0x00401010 | Names of Intended Recipients of Results. This tag name has been deprecated, use tag with the same value defined in the previous line.
IntendedRecipientsOfResultsIdentificationSequence | 0x00401011 | Intended Recipients of Results Identification Sequence.
IntensifierActiveDimensions | 0x00189428 | Intensifier Active Dimension(s).
IntensifierActiveShape | 0x00189427 | Intensifier Active Shape.
IntensifierSize | 0x00181162 | Intensifier Size.
InterMarkerDistance | 0x00500019 | Inter-Marker Distance.
IntermediatePupillaryDistance | 0x00460063 | Intermediate Pupillary Distance.
InternalDetectorFrameTime | 0x00143011 | Internal Detector Frame Time.
InternationalRouteSegment | 0x40101028 | International Route Segment.
InterpolationType | 0x00520039 | Interpolation Type.
InterpretationApprovalDate | 0x40080112 | Interpretation Approval Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationApprovalTime | 0x40080113 | Interpretation Approval Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationApproverSequence | 0x40080111 | Interpretation Approver Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationAuthor | 0x4008010C | Interpretation Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationDiagnosisCodeSequence | 0x40080117 | Interpretation Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationDiagnosisDescription | 0x40080115 | Interpretation Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationID | 0x40080200 | Interpretation ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationIDIssuer | 0x40080202 | Interpretation ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationRecordedDate | 0x40080100 | Interpretation Recorded Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationRecordedTime | 0x40080101 | Interpretation Recorded Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationRecorder | 0x40080102 | Interpretation Recorder. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationStatusID | 0x40080212 | Interpretation Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationText | 0x4008010B | Interpretation Text. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationTranscriber | 0x4008010A | Interpretation Transcriber. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationTranscriptionDate | 0x40080108 | Interpretation Transcription Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationTranscriptionTime | 0x40080109 | Interpretation Transcription Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
InterpretationTypeID | 0x40080210 | Interpretation Type ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IntervalNumber | 0x00200016 | Interval Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IntervalsAcquired | 0x00181083 | Intervals Acquired.
IntervalsRejected | 0x00181084 | Intervals Rejected.
InterventionalStatus | 0x00180038 | Intervention Status. This tag name has been deprecated, use tag with the same value defined in the previous line.
InterventionalTherapySequence | 0x00180036 | Intervention Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
InterventionDescription | 0x0018003A | Intervention Description.
InterventionDrugCodeSequence | 0x00180029 | Intervention Drug Code Sequence.
InterventionDrugDose | 0x00180028 | Intervention Drug Dose.
InterventionDrugInformationSequence | 0x00180026 | Intervention Drug Information Sequence.
InterventionDrugInfoSequence | 0x00180026 | Intervention Drug Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
InterventionDrugName | 0x00180034 | Intervention Drug Name.
InterventionDrugSequence | 0x00180029 | Intervention Drug Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
InterventionDrugStartTime | 0x00180035 | Intervention Drug Start Time.
InterventionDrugStopTime | 0x00180027 | Intervention Drug Stop Time.
InterventionSequence | 0x00180036 | Intervention Sequence.
InterventionStatus | 0x00180038 | Intervention Status.
IntraocularLensCalculationsLeftEyeSequence | 0x00221310 | Intraocular Lens Calculations Left Eye Sequence.
IntraocularLensCalculationsRightEyeSequence | 0x00221300 | Intraocular Lens Calculations Right Eye Sequence.
IntraOcularPressure | 0x0022000B | Intra Ocular Pressure.
IntravascularFrameContentSequence | 0x00520027 | Intravascular Frame Content Sequence.
IntravascularLongitudinalDistance | 0x00520028 | Intravascular Longitudinal Distance.
IntravascularOCTFrameContentSequence | 0x00520029 | Intravascular OCT Frame Content Sequence.
IntravascularOCTFrameTypeSequence | 0x00520025 | Intravascular OCT Frame Type Sequence.
InversionRecovery | 0x00189009 | Inversion Recovery.
InversionTime | 0x00180082 | Inversion Time.
InversionTimes | 0x00189079 | Inversion Times.
IOLFormulaCodeSequence | 0x00221028 | IOL Formula Code Sequence.
IOLFormulaDetail | 0x00221029 | IOL Formula Detail.
IOLManufacturer | 0x00221093 | IOL Manufacturer.
IOLPower | 0x00221053 | IOL Power.
IOLPowerForExactEmmetropia | 0x00221121 | IOL Power For Exact Emmetropia.
IOLPowerForExactTargetRefraction | 0x00221122 | IOL Power For Exact Target Refraction.
IOLPowerSequence | 0x00221090 | IOL Power Sequence.
IonBeamLimitingDeviceSequence | 0x300A03A4 | Ion Beam Limiting Device Sequence.
IonBeamSequence | 0x300A03A2 | Ion Beam Sequence.
IonBlockSequence | 0x300A03A6 | Ion Block Sequence.
IonControlPointDeliverySequence | 0x30080041 | Ion Control Point Delivery Sequence.
IonControlPointSequence | 0x300A03A8 | Ion Control Point Sequence.
IonControlPointVerificationSequence | 0x0074104E | Ion Control Point Verification Sequence.
IonMachineVerificationSequence | 0x00741046 | Ion Machine Verification Sequence.
IonRangeCompensatorSequence | 0x300A02EA | Ion Range Compensator Sequence.
IonToleranceTableSequence | 0x300A03A0 | Ion Tolerance Table Sequence.
IonWedgePositionSequence | 0x300A03AC | Ion Wedge Position Sequence.
IonWedgeSequence | 0x300A03AA | Ion Wedge Sequence.
IrradiationEventIdentificationSequence | 0x00189477 | Irradiation Event Identification Sequence.
IrradiationEventUID | 0x00083010 | Irradiation Event UID.
IsocenterPosition | 0x300A012C | Isocenter Position.
IsocenterReferenceSystemSequence | 0x00189462 | Isocenter Reference System Sequence.
IsocentertoBeamLimitingDeviceDistance | 0x300A00BB | Isocenter to Beam Limiting Device Distance.
IsocentertoBlockTrayDistance | 0x300A00F7 | Isocenter to Block Tray Distance.
IsocentertoCompensatorDistances | 0x300A02E6 | Isocenter to Compensator Distances.
IsocentertoCompensatorTrayDistance | 0x300A02E4 | Isocenter to Compensator Tray Distance.
IsocentertoLateralSpreadingDeviceDistance | 0x300A0374 | Isocenter to Lateral Spreading Device Distance.
IsocentertoRangeModulatorDistance | 0x300A038A | Isocenter to Range Modulator Distance.
IsocentertoRangeShifterDistance | 0x300A0364 | Isocenter to Range Shifter Distance.
IsocentertoWedgeTrayDistance | 0x300A00D9 | Isocenter to Wedge Tray Distance.
IsotopeNumber | 0x00200014 | Isotope Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IssueDateOfImagingServiceRequest | 0x00402004 | Issue Date of Imaging Service Request.
IssuerOfAccessionNumberSequence | 0x00080051 | Issuer of Accession Number Sequence.
IssuerOfAdmissionID | 0x00380011 | Issuer of Admission ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IssuerOfAdmissionIDSequence | 0x00380014 | Issuer of Admission ID Sequence.
IssuerOfPatientID | 0x00100021 | Issuer of Patient ID.
IssuerOfPatientIDQualifiersSequence | 0x00100024 | Issuer of Patient ID Qualifiers Sequence.
IssuerOfServiceEpisodeID | 0x00380061 | Issuer of Service Episode ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
IssuerOfServiceEpisodeIDSequence | 0x00380064 | Issuer of Service Episode ID Sequence.
IssuerOfTheContainerIdentifierSequence | 0x00400513 | Issuer of the Container Identifier Sequence.
IssuerOfTheSpecimenIdentifierSequence | 0x00400562 | Issuer of the Specimen Identifier Sequence.
IssueTimeOfImagingServiceRequest | 0x00402005 | Issue Time of Imaging Service Request.
Italic | 0x00700250 | Italic.
Item | 0xFFFEE000 | Item marker.
ItemDelimitationItem | 0xFFFEE00D | Item Delimitation Item.
ItemItem | 0xFFFEE000 | Item marker. This tag name has been deprecated, use tag with the same value defined in the previous line.
ItemNumber | 0x00200019 | Item Number.
IterativeReconstructionMethod | 0x00189769 | Iterative Reconstruction Method.
ItineraryID | 0x40101051 | Itinerary ID.
ItineraryIDAssigningAuthority | 0x40101053 | Itinerary ID Assigning Authority.
ItineraryIDType | 0x40101052 | Itinerary ID Type.
IvusAcquisition | 0x00183100 | IVUS Acquisition.
IvusGatedRate | 0x00183102 | IVUS Gated Rate.
IvusPullbackRate | 0x00183101 | IVUS Pullback Rate.
IvusPullbackStartFrameNumber | 0x00183103 | IVUS Pullback Start Frame Number.
IvusPullbackStopFrameNumber | 0x00183104 | IVUS Pullback Stop Frame Number.
KeratometerIndex | 0x00221033 | Keratometer Index.
KeratometricAxis | 0x00460077 | Keratometric Axis.
KeratometricPower | 0x00460076 | Keratometric Power.
KeratometryLeftEyeSequence | 0x00460071 | Keratometry Left Eye Sequence.
KeratometryMeasurementTypeCodeSequence | 0x00221096 | Keratometry Measurement Type Code Sequence.
KeratometryRightEyeSequence | 0x00460070 | Keratometry Right Eye Sequence.
KspaceFiltering | 0x00189064 | K-space Filtering.
Kvp | 0x00180060 | KVP (kilovolts peak).
KVUsedInGainCalibration | 0x00143071 | KV Used in Gain Calibration.
LabelStyleSelection | 0x22000003 | Label Style Selection.
LabelText | 0x22000002 | Label Text.
LabelUsingInformationExtractedFromInstances | 0x22000001 | Label Using Information Extracted From Instances.
LanguageCodeSequence | 0x00080006 | Language Code Sequence.
LanguageCodeSequenceTrial | 0x0040A744 | Language Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargeBluePaletteColorLookupTableData | 0x00281213 | Large Blue Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargeBluePaletteColorLookupTableDescriptor | 0x00281113 | Large Blue Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargeGreenPaletteColorLookupTableData | 0x00281212 | Large Green Palette Color Lookup Table Data(RET). See DICOM specification for alternatives.
LargeGreenPaletteColorLookupTableDescriptor | 0x00281112 | Large Green Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargePaletteColorLookupTableUID | 0x00281214 | Large Palette Color Lookup Table UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargeRedPaletteColorLookupTableData | 0x00281211 | Large Red Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargeRedPaletteColorLookupTableDescriptor | 0x00281111 | Large Red Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargestImagePixelValue | 0x00280107 | Largest Image Pixel Value.
LargestImagePixelValueInPlane | 0x00280111 | Largest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargestMonochromePixelValue | 0x00289099 | Largest Monochrome Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LargestPixelValueInSeries | 0x00280109 | Largest Pixel Value in Series.
LargestValidPixelValue | 0x00280105 | Largest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LastMenstrualDate | 0x001021D0 | Last Menstrual Date.
Laterality | 0x00200060 | The Laterality.
LateralSpreadingDeviceDescription | 0x300A033A | Lateral Spreading Device Description.
LateralSpreadingDeviceID | 0x300A0336 | Lateral Spreading Device ID.
LateralSpreadingDeviceNumber | 0x300A0334 | Lateral Spreading Device Number.
LateralSpreadingDeviceSequence | 0x300A0332 | Lateral Spreading Device Sequence.
LateralSpreadingDeviceSetting | 0x300A0372 | Lateral Spreading Device Setting.
LateralSpreadingDeviceSettingsSequence | 0x300A0370 | Lateral Spreading Device Settings Sequence.
LateralSpreadingDeviceType | 0x300A0338 | Lateral Spreading Device Type.
LateralSpreadingDeviceWaterEquivalentThickness | 0x300A033C | Lateral Spreading Device Water Equivalent Thickness.
LeafJawPosition | 0x300A011C | Leaf/Jaw Positions.
LeafJawPositions | 0x300A011C | Leaf/Jaw Positions.
LeafPositionBoundaries | 0x300A00BE | Leaf Position Boundaries.
LeftImageSequence | 0x00220021 | Left Image Sequence.
LeftLensSequence | 0x00460015 | Left Lens Sequence.
LengthToEnd | 0x00000001 | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LensConstantDescription | 0x00221094 | Lens Constant Description.
LensConstantSequence | 0x00221092 | Lens Constant Sequence.
LensDescription | 0x00460012 | Lens Description.
LensesCodeSequence | 0x00220019 | Lenses Code Sequence.
LensSegmentType | 0x00460038 | Lens Segment Type.
LensStatusCodeSequence | 0x00221024 | Lens Status Code Sequence.
LensStatusDescription | 0x00221065 | Lens Status Description.
LensThickness | 0x00221130 | Lens Thickness.
LesionNumber | 0x00183105 | Lesion Number.
LightPathFilterPassBand | 0x00220002 | Light Path Filter Pass Band.
LightPathFilterPassThroughWavelength | 0x00220001 | Light Path Filter Pass-Through Wavelength.
LightPathFilterTypeStackCodeSequence | 0x00220017 | Light Path Filter Type Stack Code Sequence.
LINACEnergy | 0x00145002 | LINAC Energy.
LINACOutput | 0x00145004 | LINAC Output.
LineDashingStyle | 0x00700254 | Line Dashing Style.
LinePattern | 0x00700255 | Line Pattern.
LineSequence | 0x00660028 | Line Sequence.
LineStyleSequence | 0x00700232 | Line Style Sequence.
LineThickness | 0x00700253 | Line Thickness.
ListOfMIMETypes | 0x00420014 | List of MIME Types.
LocalDeviationProbabilityNormalsFlag | 0x00240072 | Local Deviation Probability Normals Flag.
LocalizedDeviationfromNormal | 0x00240068 | Localized Deviation from Normal.
LocalizedDeviationProbability | 0x00240073 | Localized Deviation Probability.
LocalizedDeviationProbabilitySequence | 0x00240085 | Localized Deviation Probability Sequence.
LocalNamespaceEntityID | 0x00400031 | Local Namespace Entity ID.
Location | 0x00200050 | Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LocationOfMeasuredBeamDiameter | 0x00144019 | Location of Measured Beam Diameter.
LongitudinalTemporalInformationModified | 0x00280303 | Longitudinal Temporal Information Modified.
LookupTableNumber | 0x00200026 | Lookup Table Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LossyImageCompression | 0x00282110 | Lossy Image Compression.
LossyImageCompressionMethod | 0x00282114 | Lossy Image Compression Method.
LossyImageCompressionRatio | 0x00282112 | Lossy Image Compression Ratio.
LossyImageCompressionRetired | 0x00082110 | Lossy Image Compression (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LowEnergyDetectors | 0x40100001 | Low Energy Detectors.
LowRrValue | 0x00181081 | Low R-R Value.
LUTData | 0x00283006 | LUT (Lookup Table) Data.
LUTDescriptor | 0x00283002 | LUT Descriptor.
LUTExplanation | 0x00283003 | LUT Explanation.
LUTFrameRange | 0x00289507 | LUT Frame Range.
LUTFunction | 0x00289474 | LUT Function.
LutLabel | 0x00409210 | LUT Label.
LUTNumber | 0x00200026 | LUT Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
LutUID | 0x00281199 | Palette Color Lookup Table UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
MAC | 0x04000404 | MAC (Message Authentication Code).
MacAlgorithm | 0x04000015 | MAC Algorithm.
MacCalcTransferSyntaxUID | 0x04000010 | MAC Calculation Transfer Syntax UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
MacCalculationTransferSyntaxUID | 0x04000010 | MAC Calculation Transfer Syntax UID.
MacIDNumber | 0x04000005 | MAC ID Number.
MacParametersSequence | 0x4FFE0001 | MAC Parameters Sequence.
MagneticFieldStrength | 0x00180087 | Magnetic Field Strength.
MagnetizationTransfer | 0x00189020 | Magnetization Transfer.
MagnificationType | 0x20100060 | Magnification Type.
MagnifytoNumberofColumns | 0x20400074 | Magnify to Number of Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MajorTicksSequence | 0x00700287 | Major Ticks Sequence.
MandatoryComponentType | 0x00760038 | Mandatory Component Type.
Manifold | 0x00660010 | Manifold tag.
ManipulatedImage | 0x00280050 | Manipulated Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Manufacturer | 0x00080070 | The Manufacturer.
ManufacturerModelName | 0x00081090 | Manufacturer's Model Name.
ManufacturersModelName | 0x00081090 | Manufacturer's Model Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
MappingResource | 0x00080105 | Mapping Resource.
MaskFrameNumbers | 0x00286110 | Mask Frame Numbers.
MaskingImage | 0x00200080 | Masking Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MaskOperation | 0x00286101 | Mask Operation.
MaskOperationExplanation | 0x00286190 | Mask Operation Explanation.
MaskPointers | 0x00286030 | Mask Pointer(s). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MaskSelectionMode | 0x00289454 | Mask Selection Mode.
MaskSubpixelShift | 0x00286114 | Mask Sub-pixel Shift.
MaskSubtractionSequence | 0x00286100 | Mask Subtraction Sequence.
MaskVisibilityPercentage | 0x00289478 | Mask Visibility Percentage.
Mass | 0x40101017 | Mass.
MaterialGrade | 0x00140042 | Material Grade.
MaterialID | 0x300A00E1 | Material ID.
MaterialIsolationDiameter | 0x00140034 | Material Isolation Diameter.
MaterialNotes | 0x00140046 | Material Notes.
MaterialPipeDiameter | 0x00140032 | Material Pipe Diameter.
MaterialPropertiesFileFormat | 0x00140045 | Material Properties File Format.
MaterialPropertiesFileID | 0x00140044 | Material Properties File ID.
MaterialsCodeSequence | 0x006863A0 | Materials Code Sequence.
MaterialThickness | 0x00140030 | Material Thickness.
MatingFeatureDegreeOfFreedomSequence | 0x00686400 | Mating Feature Degree of Freedom Sequence.
MatingFeatureID | 0x006863F0 | Mating Feature ID.
MatingFeatureSequence | 0x006863E0 | Mating Feature Sequence.
MatingFeatureSetID | 0x006863C0 | Mating Feature Set ID.
MatingFeatureSetLabel | 0x006863D0 | Mating Feature Set Label.
MatingFeatureSetsSequence | 0x006863B0 | Mating Feature Sets Sequence.
MatrixRegistrationSequence | 0x00700309 | Matrix Registration Sequence.
MatrixSequence | 0x0070030A | Matrix Sequence.
MAUsedInGainCalibration | 0x00143072 | MA Used in Gain Calibration.
MaxDensity | 0x20100130 | Max Density.
MaximumAcrossScanDistortion | 0x00220049 | Maximum Across-scan Distortion.
MaximumAlongScanDistortion | 0x00220038 | Maximum Along-scan Distortion.
MaximumCollatedFilms | 0x20100154 | Maximum Collated Films.
MaximumCoordinateValue | 0x50FF0105 | Maximum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MaximumDepthDistortion | 0x00220036 | Maximum Depth Distortion.
MaximumFractionalValue | 0x0062000E | Maximum Fractional Value.
MaximumMemoryAllocation | 0x20000061 | Maximum Memory Allocation.
MaximumPointDistance | 0x00660019 | Maximum Point Distance.
MaximumStimulusLuminance | 0x00240018 | Maximum Stimulus Luminance.
MaxMemoryAllocation | 0x20000061 | Maximum Memory Allocation. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeanPointDistance | 0x00660018 | Mean Point Distance.
MeasuredBandwidth | 0x0014401C | Measured Bandwidth.
MeasuredBeamDimensionA | 0x00144017 | Measured Beam Dimension A.
MeasuredBeamDimensionB | 0x00144018 | Measured Beam Dimension B.
MeasuredCenterFrequency | 0x0014401B | Measured Center Frequency.
MeasuredDoseDesc | 0x30080012 | Measured Dose Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeasuredDoseDescription | 0x30080012 | Measured Dose Description.
MeasuredDoseReferenceNumber | 0x30080064 | Measured Dose Reference Number.
MeasuredDoseReferenceSequence | 0x30080010 | Measured Dose Reference Sequence.
MeasuredDoseRefNumber | 0x30080064 | Measured Dose Reference Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeasuredDoseRefSequence | 0x30080010 | Measured Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeasuredDoseType | 0x30080014 | Measured Dose Type.
MeasuredDoseValue | 0x30080016 | Measured Dose Value.
MeasuredValueSequence | 0x0040A300 | Measured Value Sequence.
MeasurementAutomationTrial | 0x0040A194 | Measurement Automation (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MeasurementLaterality | 0x00240113 | Measurement Laterality.
MeasurementPrecisionDescriptionTrial | 0x0040A047 | Measurement Precision Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MeasurementUnitCodeSequence | 0x004008EA | Measurement Units Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeasurementUnitsCodeSequence | 0x004008EA | Measurement Units Code Sequence.
MeasuringUnitSequence | 0x00400295 | Measuring Units Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
MeasuringUnitsSequence | 0x00400295 | Measuring Units Sequence.
MechanicalIndex | 0x00185022 | Mechanical Index.
MediaDisposition | 0x22000004 | Media Disposition.
MediaInstalledSequence | 0x200000A2 | Media Installed Sequence.
MediaStorageSOPClassUID | 0x00020002 | Media Storage SOP Class UID.
MediaStorageSOPInstanceUID | 0x00020003 | Media Storage SOP Instance UID.
MediaStoredSOPClassUID | 0x00020002 | Media Storage SOP Class UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
MediaStoredSOPInstanceUID | 0x00020003 | Media Storage SOP Instance UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
MedicalAlerts | 0x00102000 | Medical Alerts.
MedicalRecordLocator | 0x00101090 | Medical Record Locator.
MediumType | 0x20000030 | Medium Type.
MemoryAllocation | 0x20000060 | Memory Allocation.
MemoryBitDepth | 0x200000A0 | Memory Bit Depth.
MessageID | 0x00000110 | Message ID.
MessageIDBeingRespondedTo | 0x00000120 | Message ID Being Responded To.
MessageSetID | 0x00005010 | Message Set ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MetaboliteMapCodeSequence | 0x00189083 | Metabolite Map Code Sequence.
MetaboliteMapDesc | 0x00189080 | Metabolite Map Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
MetaboliteMapDescription | 0x00189080 | Metabolite Map Description.
MetaInfoHeader | 0x00000006 | DICOM meta information header.
MetersetExposure | 0x30020032 | Meterset Exposure.
MetersetRate | 0x300A035A | Meterset Rate.
MetersetRateDelivered | 0x30080046 | Meterset Rate Delivered.
MetersetRateSet | 0x30080045 | Meterset Rate Set.
MidSlabPosition | 0x00189106 | Mid Slab Position.
MilitaryRank | 0x00101080 | Military Rank.
MIMETypeofEncapsulatedDocument | 0x00420012 | MIME Type of Encapsulated Document.
MinDensity | 0x20100120 | Min Density.
MinimumCoordinateValue | 0x50FF0104 | Minimum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MinimumSensitivityValue | 0x00240105 | Minimum Sensitivity Value.
ModalitiesInStudy | 0x00080061 | Modalities in Study.
Modality | 0x00080060 | Modality value.
ModalityLUTSequence | 0x00283000 | Modality LUT Sequence.
ModalityLUTType | 0x00283004 | Modality LUT Type.
ModeOfPercutaneousAccessSequence | 0x00520016 | Mode of Percutaneous Access Sequence.
ModifiedAttributesSequence | 0x04000550 | Modified Attributes Sequence.
ModifiedImageDate | 0x00203403 | Modified Image Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifiedImageDescription | 0x00203406 | Modified Image Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifiedImageID | 0x00203402 | Modified Image ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifiedImageTime | 0x00203405 | Modified Image Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifierCodeSequence | 0x0040A195 | Modifier Code Sequence.
ModifyingDeviceID | 0x00203401 | Modifying Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifyingDeviceManufacturer | 0x00203404 | Modifying Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ModifyingSystem | 0x04000563 | Modifying System.
ModulationType | 0x00144026 | Modulation Type.
MostRecentTreatmentDate | 0x30080056 | Most Recent Treatment Date.
MotionSynchronizationSequence | 0x300A0410 | Motion Synchronization Sequence.
MoveDestination | 0x00000600 | Move Destination.
MoveOriginatorApplicationEntityTitle | 0x00001030 | Move Originator Application Entity Title.
MoveOriginatorMessageID | 0x00001031 | Move Originator Message ID.
MrAcqFrequencyEncodingSteps | 0x00189058 | MR Acquisition Frequency Encoding Steps. This tag name has been deprecated, use tag with the same value defined in the previous line.
MrAcqPhaseEncodingStepsInPlane | 0x00189231 | MR Acquisition Phase Encoding Steps in-plane. This tag name has been deprecated, use tag with the same value defined in the previous line.
MrAcqPhaseEncodingStepsOutOfPlane | 0x00189232 | MR Acquisition Phase Encoding Steps out-of-plane. This tag name has been deprecated, use tag with the same value defined in the previous line.
MRAcquisitionFrequencyEncodingSteps | 0x00189058 | MR Acquisition Frequency Encoding Steps.
MRAcquisitionPhaseEncodingStepsInPlane | 0x00189231 | MR Acquisition Phase Encoding Steps in-plane.
MRAcquisitionPhaseEncodingStepsOutOfPlane | 0x00189232 | MR Acquisition Phase Encoding Steps out-of-plane.
MrAcquisitionType | 0x00180023 | MR Acquisition Type.
MRArterialSpinLabelingSequence | 0x00189251 | MR Arterial Spin Labeling Sequence.
MrAveragesSequence | 0x00189119 | MR Averages Sequence.
MrDiffusionSequence | 0x00189117 | MR Diffusion Sequence.
MRDRDirectoryRecordOffset | 0x00041504 | MRDR Directory Record Offset. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
MrEchoSequence | 0x00189114 | MR Echo Sequence.
MrFovGeometrySequence | 0x00189125 | MR FOV/Geometry Sequence.
MrImageFrameTypeSequence | 0x00189226 | MR Image Frame Type Sequence.
MrImagingModifierSequence | 0x00189006 | MR Imaging Modifier Sequence.
MrMetaboliteMapSequence | 0x00189152 | MR Metabolite Map Sequence.
MrModifierSequence | 0x00189115 | MR Modifier Sequence.
MrReceiveCoilSequence | 0x00189042 | MR Receive Coil Sequence.
MrSpatialSaturationSequence | 0x00189107 | MR Spatial Saturation Sequence.
MrSpectroscopyAcqType | 0x00189200 | MR Spectroscopy Acquisition Type. This tag name has been deprecated, use tag with the same value defined in the previous line.
MRSpectroscopyAcquisitionType | 0x00189200 | MR Spectroscopy Acquisition Type.
MrSpectroscopyFovGeometrySequence | 0x00189103 | MR Spectroscopy FOV/Geometry Sequence.
MrSpectroscopyFrameTypeSequence | 0x00189227 | MR Spectroscopy Frame Type Sequence.
MrTimingAndRelatedParametersSequence | 0x00189112 | MR Timing and Related Parameters Sequence.
MrTimingParameterSequence | 0x00189112 | MR Timing and Related Parameters Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
MrTransmitCoilSequence | 0x00189049 | MR Transmit Coil Sequence.
MrVelocityEncodingSequence | 0x00189197 | MR Velocity Encoding Sequence.
MultiCoilConfiguration | 0x00189046 | Multi-Coil Configuration.
MultiCoilDefinitionSequence | 0x00189045 | Multi-Coil Definition Sequence.
MultiCoilElementName | 0x00189047 | Multi-Coil Element Name.
MultiCoilElementUsed | 0x00189048 | Multi-Coil Element Used.
MultiFramePresentationSequence | 0x00289505 | Multi-frame Presentation Sequence.
MultiFrameSourceSOPInstanceUID | 0x00081167 | Multi-Frame Source SOP Instance UID.
MultiPlanarExcitation | 0x00189012 | Multi-planar Excitation.
MultipleCopiesFlag | 0x00404006 | Multiple Copies Flag.
MultipleSpinEcho | 0x00189011 | Multiple Spin Echo.
MultiplexedAudioChannelsDescriptionCodeSequence | 0x003A0300 | Multiplexed Audio Channels Description Code Sequence.
MultiplexGroupLabel | 0x003A0020 | Multiplex Group Label.
MultiplexGroupTimeOffset | 0x00181068 | Multiplex Group Time Offset.
MydriaticAgentCodeSequence | 0x0022001C | Mydriatic Agent Code Sequence.
MydriaticAgentConcentration | 0x0022004E | Mydriatic Agent Concentration.
MydriaticAgentConcentrationUnitsSequence | 0x00220042 | Mydriatic Agent Concentration Units Sequence.
MydriaticAgentSequence | 0x00220058 | Mydriatic Agent Sequence.
NameOfPhysiciansReadingStudy | 0x00081060 | Name of Physician(s) Reading Study.
NamesOfIntendedRecipientsOfResults | 0x00401010 | Names of Intended Recipients of Results.
NavigationDisplaySet | 0x00720216 | Navigation Display Set.
NavigationIndicatorSequence | 0x00720214 | Navigation Indicator Sequence.
NearPupillaryDistance | 0x00460062 | Near Pupillary Distance.
NegativeCatchTrialsQuantity | 0x00240048 | Negative Catch Trials Quantity.
NetworkID | 0x00081000 | Network ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NextDirectoryRecordOffset | 0x00041400 | Offset of the Next Directory Record. This tag name has been deprecated, use tag with the same value defined in the previous line.
NominalBeamEnergy | 0x300A0114 | Nominal Beam Energy.
NominalBeamEnergyUnit | 0x300A0015 | Nominal Beam Energy Unit.
NominalCardiacTriggerDelayTime | 0x00209153 | Nominal Cardiac Trigger Delay Time.
NominalCardiacTriggerTimePriorToRPeak | 0x00209154 | Nominal Cardiac Trigger Time Prior To R-Peak.
NominalFrequency | 0x0014401A | Nominal Frequency.
NominalInterval | 0x00181062 | Nominal Interval.
NominalPercentageOfCardiacPhase | 0x00209241 | Nominal Percentage of Cardiac Phase.
NominalPercentageOfRespiratoryPhase | 0x00209245 | Nominal Percentage of Respiratory Phase.
NominalPriorDose | 0x300A001A | Nominal Prior Dose.
NominalRespiratoryTriggerDelayTime | 0x00209255 | Nominal Respiratory Trigger Delay Time.
NominalScannedPixelSpacing | 0x00182010 | Nominal Scanned Pixel Spacing.
NominalScreenDefinitionSequence | 0x00720102 | Nominal Screen Definition Sequence.
NonDICOMOutputCodeSequence | 0x00404032 | Non-DICOM Output Code Sequence.
NonUniformRadialSamplingCorrected | 0x00189766 | Non-uniform Radial Sampling Corrected.
NormalizationFactorFormat | 0x00280710 | Normalization Factor Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NormalizationPoint | 0x30040008 | Normalization Point.
NormalReverse | 0x00005140 | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NorRev | 0x00005140 | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NotchFilterBandwidth | 0x003A0223 | Notch Filter Bandwidth.
NotchFilterFrequency | 0x003A0222 | Notch Filter Frequency.
NotificationFromManufacturerSequence | 0x00686265 | Notification From Manufacturer Sequence.
NTPSourceAddress | 0x00181803 | NTP Source Address.
NuclearMedicineSeriesType | 0x00080042 | Nuclear Medicine Series Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfAlarmObjects | 0x40101034 | Number of Alarm Objects.
NumberOfAverages | 0x00180083 | Number of Averages.
NumberOfBeams | 0x300A0080 | Number of Beams.
NumberOfBlock | 0x300A00F0 | Number of Blocks. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfBlocks | 0x300A00F0 | Number of Blocks.
NumberOfBoli | 0x300A00ED | Number of Boli.
NumberOfBrachyApplicationSetup | 0x300A00A0 | Number of Brachy Application Setups. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfBrachyApplicationSetups | 0x300A00A0 | Number of Brachy Application Setups.
NumberOfChannels | 0x50FF2004 | Number of Channels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfCompensator | 0x300A00E0 | Number of Compensators. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfCompensators | 0x300A00E0 | Number of Compensators.
NumberOfCompletedSuboperations | 0x00001021 | Number of Completed Sub-operations.
NumberOfContourPoints | 0x30060046 | Number of Contour Points.
NumberOfControlPoints | 0x300A0110 | Number of Control Points.
NumberOfCopies | 0x20000010 | Number of Copies.
NumberOfDetectors | 0x00540021 | Number of Detectors.
NumberOfElements | 0x00144012 | Number of Elements.
NumberOfEnergyWindows | 0x00540011 | Number of Energy Windows.
NumberOfEventTimers | 0x00082129 | Number of Event Timers.
NumberOfFailedSuboperations | 0x00001022 | Number of Failed Sub-operations.
NumberOfFilms | 0x21000170 | Number of Films.
NumberOfFocalPlanes | 0x00480013 | Number of Focal Planes.
NumberOfFractionDelivered | 0x3008005A | Number of Fractions Delivered. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfFractionPatternDigitsPerDay | 0x300A0079 | Number of Fraction Pattern Digits Per Day.
NumberOfFractionPerDay | 0x300A0079 | Number of Fraction Pattern Digits Per Day. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfFractionPlanned | 0x300A0078 | Number of Fractions Planned. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfFractionsDelivered | 0x3008005A | Number of Fractions Delivered.
NumberOfFractionsPlanned | 0x300A0078 | Number of Fractions Planned.
NumberOfFrames | 0x00280008 | Number of Frames.
NumberOfFramesInOverlay | 0x60FF0015 | Number of Frames in Overlay.
NumberOfFramesInPhase | 0x00540033 | Number of Frames in Phase.
NumberOfFramesInRotation | 0x00540053 | Number of Frames in Rotation.
NumberOfFramesIntegrated | 0x00143012 | Number of Frames Integrated.
NumberOfFramesUsedForIntegration | 0x00143073 | Number of Frames Used for Integration.
NumberOfGraphicPoints | 0x00700021 | Number of Graphic Points.
NumberofHorizontalPixels | 0x00720106 | Number of Horizontal Pixels.
NumberOfIterations | 0x00189739 | Number of Iterations.
NumberOfKspaceTrajectories | 0x00189093 | Number of k-Space Trajectories.
NumberofLateralSpreadingDevices | 0x300A0330 | Number of Lateral Spreading Devices.
NumberOfLeafJawPairs | 0x300A00BC | Number of Leaf/Jaw Pairs.
NumberOfMatches | 0x00000850 | Number of Matches. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfPaddedAlines | 0x00520038 | Number of Padded A?lines.
NumberofPaintings | 0x300A039A | Number of Paintings.
NumberOfPatientRelatedInstances | 0x00201204 | Number of Patient Related Instances.
NumberOfPatientRelatedSeries | 0x00201202 | Number of Patient Related Series.
NumberOfPatientRelatedStudies | 0x00201200 | Number of Patient Related Studies.
NumberOfPhaseEncodingSteps | 0x00180089 | Number of Phase Encoding Steps.
NumberOfPhases | 0x00540031 | Number of Phases.
NumberOfPoints | 0x50FF0010 | Number of Points. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberofPriorsReferenced | 0x00720014 | Number of Priors Referenced.
NumberOfPulses | 0x300A028A | Number of Pulses.
NumberofRangeModulators | 0x300A0340 | Number of Range Modulators.
NumberofRangeShifters | 0x300A0312 | Number of Range Shifters.
NumberOfReferences | 0x00041600 | Number of References. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfRemainingSuboperations | 0x00001020 | Number of Remaining Sub-operations.
NumberOfRotations | 0x00540051 | Number of Rotations.
NumberOfRrIntervals | 0x00540061 | Number of R-R Intervals.
NumberOfSamples | 0x50FF2006 | Number of Samples. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberofScanSpotPositions | 0x300A0392 | Number of Scan Spot Positions.
NumberofScreens | 0x00720100 | Number of Screens.
NumberOfSeriesRelatedInstances | 0x00201209 | Number of Series Related Instances.
NumberOfSlices | 0x00540081 | Number of Slices.
NumberOfStages | 0x00082124 | Number of Stages.
NumberOfStudyRelatedInstances | 0x00201208 | Number of Study Related Instances.
NumberOfStudyRelatedSeries | 0x00201206 | Number of Study Related Series.
NumberOfSubsets | 0x00189740 | Number of Subsets.
NumberOfSurfacePoints | 0x00660015 | Number of Surface Points.
NumberOfSurfaces | 0x00660001 | Number of Surfaces.
NumberOfTable | 0x002808F2 | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfTableBreakPoints | 0x00186050 | Number of Table Break Points.
NumberOfTableEntries | 0x00186056 | Number of Table Entries.
NumberOfTables | 0x002808F2 | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfTemporalPositions | 0x00200105 | Number of Temporal Positions.
NumberOfTimeSlices | 0x00540101 | Number of Time Slices.
NumberOfTimeSlots | 0x00540071 | Number of Time Slots.
NumberOfTomosynthesisSourceImages | 0x00181495 | Number of Tomosynthesis Source Images.
NumberOfTotalObjects | 0x40101033 | Number of Total Objects.
NumberOfTransformSteps | 0x00280402 | Number of Transform Steps. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
NumberOfTriggersInPhase | 0x00540211 | Number of Triggers in Phase.
NumberOfVectors | 0x0066001E | Number of Vectors.
NumberofVerticalPixels | 0x00720104 | Number of Vertical Pixels.
NumberOfViewsInStage | 0x0008212A | Number of Views in Stage.
NumberOfVisualStimuli | 0x00240038 | Number of Visual Stimuli.
NumberOfWarningSuboperations | 0x00001023 | Number of Warning Sub-operations.
NumberOfWaveformChannels | 0x003A0005 | Number of Waveform Channels.
NumberOfWaveformSamples | 0x003A0010 | Number of Waveform Samples.
NumberOfWedge | 0x300A00D0 | Number of Wedges. This tag name has been deprecated, use tag with the same value defined in the previous line.
NumberOfWedges | 0x300A00D0 | Number of Wedges.
NumberOfZeroFills | 0x00189066 | Number of Zero fills.
NumericValue | 0x0040A30A | Numeric Value.
NumericValueQualifierCodeSequence | 0x0040A301 | Numeric Value Qualifier Code Sequence.
ObjectBinaryIdentifierTrial | 0x0040A074 | Object Binary Identifier (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObjectDirectoryBinaryIdentifierTrial | 0x0040A089 | Object Directory Binary Identifier (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObjectiveLensNumericalAperture | 0x00480113 | Objective Lens Numerical Aperture.
ObjectiveLensPower | 0x00480112 | Objective Lens Power.
ObjectPixelSpacinginCenterofBeam | 0x00189404 | Object Pixel Spacing in Center of Beam.
ObjectThicknessSequence | 0x00189456 | Object Thickness Sequence.
ObservationCategoryCodeSequenceTrial | 0x0040A167 | Observation Category Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationDateTime | 0x0040A032 | Observation Date Time.
ObservationDateTrial | 0x0040A192 | Observation Date (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationNumber | 0x30060082 | Observation Number.
ObservationSubjectClassTrial | 0x0040A403 | Observation Subject Class (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationSubjectContextFlagTrial | 0x0040A600 | Observation Subject Context Flag (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationSubjectTypeCodeSequenceTrial | 0x0040A404 | Observation Subject Type Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationSubjectUIDTrial | 0x0040A402 | Observation Subject UID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationTimeTrial | 0x0040A193 | Observation Time (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObservationUIDTrial | 0x0040A171 | Observation UID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObserverContextFlagTrial | 0x0040A601 | Observer Context Flag (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ObserverType | 0x0040A084 | Observer Type.
Occupation | 0x00102180 | Patient's Occupation.
OCTAcquisitionDomain | 0x00520006 | OCT Acquisition Domain.
OCTFocalDistance | 0x00520002 | OCT Focal Distance.
OCTOpticalCenterWavelength | 0x00520007 | OCT Optical Center Wavelength.
OCTZOffsetApplied | 0x00520026 | OCT Z Offset Applied.
OCTZOffsetCorrection | 0x00520030 | OCT Z Offset Correction.
OffendingElement | 0x00000901 | Offending Element.
OffsetOfReferencedLowerLevelDirectoryEntity | 0x00041420 | Offset of Referenced Lower-Level Directory Entity.
OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | 0x00041200 | Offset of the First Directory Record of the Root Directory Entity.
OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | 0x00041202 | Offset of the Last Directory Record of the Root Directory Entity.
OffsetOfTheNextDirectoryRecord | 0x00041400 | Offset of the Next Directory Record.
OnAxisBackgroundAnatomicStructureCodeSequence | 0x0008225C | OnAxis Background Anatomic Structure Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OOIOwnerCreationTime | 0x40101041 | OOI Owner Creation Time.
OOIOwnerSequence | 0x40101047 | OOI Owner Sequence.
OOIOwnerType | 0x40101009 | OOI Owner Type.
OOISize | 0x40101043 | OOI Size.
OOIType | 0x40101042 | OOI Type.
OOITypeDescriptor | 0x40101068 | OOI Type Descriptor.
OperatingMode | 0x00189178 | Operating Mode.
OperatingModeSequence | 0x00189176 | Operating Mode Sequence.
OperatingModeType | 0x00189177 | Operating Mode Type.
OperatorIdentificationSequence | 0x00081072 | Operator Identification Sequence.
OperatorIDSequence | 0x00081072 | Operator Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
OperatorsName | 0x00081070 | Operators' Name.
OphthalmicAxialLength | 0x00221019 | Ophthalmic Axial Length.
OphthalmicAxialLengthAcquisitionMethodCodeSequence | 0x00221153 | Ophthalmic Axial Length Acquisition Method Code Sequence.
OphthalmicAxialLengthDataSourceCodeSequence | 0x00221150 | Ophthalmic Axial Length Data Source Code Sequence.
OphthalmicAxialLengthDataSourceDescription | 0x00221159 | Ophthalmic Axial Length Data Source Description.
OphthalmicAxialLengthMeasurementModified | 0x00221140 | Ophthalmic Axial Length Measurement Modified.
OphthalmicAxialLengthMeasurementsLengthSummationSequence | 0x00221212 | Ophthalmic Axial Length Measurements Length Summation Sequence.
OphthalmicAxialLengthMeasurementsSegmentalLengthSequence | 0x00221211 | Ophthalmic Axial Length Measurements Segmental Length Sequence.
OphthalmicAxialLengthMeasurementsSegmentNameCodeSequence | 0x00221101 | Ophthalmic Axial Length Measurements Segment Name Code Sequence.
OphthalmicAxialLengthMeasurementsSequence | 0x00221050 | Ophthalmic Axial Length Measurements Sequence.
OphthalmicAxialLengthMeasurementsTotalLengthSequence | 0x00221210 | Ophthalmic Axial Length Measurements Total Length Sequence.
OphthalmicAxialLengthMeasurementsType | 0x00221010 | Ophthalmic Axial Length Measurements Type.
OphthalmicAxialLengthQualityMetricSequence | 0x00221262 | Ophthalmic Axial Length Quality Metric Sequence.
OphthalmicAxialLengthQualityMetricTypeDescription | 0x00221273 | Ophthalmic Axial Length Quality Metric Type Description.
OphthalmicAxialLengthSelectionMethodCodeSequence | 0x00221250 | Ophthalmic Axial Length Selection Method Code Sequence.
OphthalmicAxialLengthVelocity | 0x00221059 | Ophthalmic Axial Length Velocity.
OphthalmicAxialMeasurementsLeftEyeSequence | 0x00221008 | Ophthalmic Axial Measurements Left Eye Sequence.
OphthalmicAxialMeasurementsRightEyeSequence | 0x00221007 | Ophthalmic Axial Measurements Right Eye Sequence.
OphthalmicFrameLocationSequence | 0x00220031 | Ophthalmic Frame Location Sequence.
OphthalmicImageOrientation | 0x00220039 | Ophthalmic Image Orientation.
OphthalmicPatientClinicalInformationLeftEyeSequence | 0x00240114 | Ophthalmic Patient Clinical Information Left Eye Sequence.
OphthalmicPatientClinicalInformationRightEyeSequence | 0x00240115 | Ophthalmic Patient Clinical Information Right Eye Sequence.
OphthalmicUltrasoundAxialMeasurementsTypeCodeSequence | 0x00221044 | Ophthalmic Ultrasound Axial Measurements Type Code Sequence.
OpticalOphthalmicAxialLengthMeasurementsSequence | 0x00221225 | Optical Ophthalmic Axial Length Measurements Sequence.
OpticalPathDescription | 0x00480107 | Optical Path Description.
OpticalPathIdentificationSequence | 0x00480207 | Optical Path Identification Sequence.
OpticalPathIdentifier | 0x00480106 | Optical Path Identifier.
OpticalPathSequence | 0x00480105 | Optical Path Sequence.
OpticalSelectedOphthalmicAxialLengthSequence | 0x00221255 | Optical Selected Ophthalmic Axial Length Sequence.
OpticalTransmittance | 0x00460040 | Optical Transmittance.
Optotype | 0x00460094 | Optotype tag.
OptotypeDetailedDefinition | 0x00460139 | Optotype Detailed Definition.
OptotypePresentation | 0x00460095 | Optotype Presentation.
OrderCallbackPhoneNumber | 0x00402010 | Order Callback Phone Number.
OrderEnteredBy | 0x00402008 | Order Entered By.
OrderEnterer | 0x00402008 | Order Entered By. This tag name has been deprecated, use tag with the same value defined in the previous line.
OrderEntererLocation | 0x00402009 | Order Enterer's Location. This tag name has been deprecated, use tag with the same value defined in the previous line.
OrderEnterersLocation | 0x00402009 | Order Enterer's Location.
OrderFillerIdentifierSequence | 0x00400027 | Order Filler Identifier Sequence.
OrderPlacerIdentifierSequence | 0x00400026 | Order Placer Identifier Sequence.
OrganAtRiskFullVolumeDose | 0x300A002A | Organ at Risk Full-volume Dose.
OrganAtRiskLimitDose | 0x300A002B | Organ at Risk Limit Dose.
OrganAtRiskMaximumDose | 0x300A002C | Organ at Risk Maximum Dose.
OrganAtRiskOverdoseVolumeFraction | 0x300A002D | Organ at Risk Overdose Volume Fraction.
OrganDose | 0x00400316 | Organ Dose.
OrganExposed | 0x00400318 | Organ Exposed.
Origin | 0x60FF0050 | Overlay Origin. This tag name has been deprecated, use tag with the same value defined in the previous line.
OriginalAttributesSequence | 0x04000561 | Original Attributes Sequence.
OriginalImageIdentification | 0x00205000 | Original Image Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OriginalImageIdentificationNomenclature | 0x00205002 | Original Image Identification Nomenclature. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OriginalImageSequence | 0x213000C0 | Original Image Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OriginalImplantAssemblyTemplateSequence | 0x0076000C | Original Implant Assembly Template Sequence.
OriginalImplantTemplateSequence | 0x00686225 | Original Implant Template Sequence.
OriginalSpecialized | 0x0008001B | Original Specialized SOP Class UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
OriginalSpecializedSOPClassUID | 0x0008001B | Original Specialized SOP Class UID.
Originator | 0x21000070 | The Originator.
OtherMagnificationTypesAvailable | 0x201000A7 | Other Magnification Types Available.
OtherMediaAvailableSequence | 0x200000A4 | Other Media Available Sequence.
OtherPatientIDs | 0x00101000 | Other Patient IDs.
OtherPatientIDsSequence | 0x00101002 | Other Patient IDs Sequence.
OtherPatientNames | 0x00101001 | Other Patient Names.
OtherPupillaryDistance | 0x00460064 | Other Pupillary Distance.
OtherSmoothingTypesAvailable | 0x201000A9 | Other Smoothing Types Available.
OtherStudyNumbers | 0x00201070 | Other Study Numbers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OuterDiameter | 0x00140054 | Outer Diameter.
OutputInformationSequence | 0x00404033 | Output Information Sequence.
OutputPower | 0x00185000 | Output Power.
OverallTemplateSpatialTolerance | 0x006862A5 | Overall Template Spatial Tolerance.
OverlayActivationLayer | 0x60FF1001 | Overlay Activation Layer.
OverlayBackgroundDensity | 0x20400082 | Overlay Background Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayBitPosition | 0x60FF0102 | Overlay Bit Position.
OverlayBitsAllocated | 0x60FF0100 | Overlay Bits Allocated.
OverlayBitsForCodeWord | 0x60FF0804 | Overlay Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayBitsGrouped | 0x60FF0069 | Overlay Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCodeLabel | 0x60FF0800 | Overlay Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCodeTableLocation | 0x60FF0803 | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayColumns | 0x60FF0011 | Overlay Columns.
OverlayComments | 0x60FF4000 | Overlay Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCompressionCode | 0x60FF0060 | Overlay Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCompressionDescription | 0x60FF0063 | Overlay Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCompressionLabel | 0x60FF0062 | Overlay Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCompressionOriginator | 0x60FF0061 | Overlay Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayCompressionStepPointers | 0x60FF0066 | Overlay Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayData | 0x60FF3000 | Overlay Data.
OverlayDate | 0x00080024 | Overlay Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayDescription | 0x60FF0022 | Overlay Description.
OverlayDescriptorBlue | 0x60FF1103 | Overlay Descriptor - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayDescriptorGray | 0x60FF1100 | Overlay Descriptor - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayDescriptorGreen | 0x60FF1102 | Overlay Descriptor - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayDescriptorRed | 0x60FF1101 | Overlay Descriptor - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayForegroundDensity | 0x20400080 | Overlay Foreground Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayFormat | 0x60FF0110 | Overlay Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayLabel | 0x60FF1500 | Overlay Label.
OverlayLocation | 0x60FF0200 | Overlay Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayMagnificationType | 0x20400060 | Overlay Magnification Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayMode | 0x20400090 | Overlay Mode. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayNumber | 0x00200022 | Overlay Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayNumberOfTables | 0x60FF0802 | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayOrigin | 0x60FF0050 | Overlay Origin.
OverlayorImageMagnification | 0x20400072 | Overlay or Image Magnification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayPixelDataSequence | 0x20400020 | Overlay Pixel Data Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayPlaneOrigin | 0x60FF0052 | Overlay Plane Origin. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayPlanes | 0x60FF0012 | Overlay Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayRepeatInterval | 0x60FF0068 | Overlay Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayRows | 0x60FF0010 | Overlay Rows.
Overlays | 0x000051B0 | Overlays. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaysBlue | 0x60FF1203 | Overlays - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaysGray | 0x60FF1200 | Overlays - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaysGreen | 0x60FF1202 | Overlays - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaySmoothingType | 0x20400070 | Overlay Smoothing Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaysRed | 0x60FF1201 | Overlays - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlaySubtype | 0x60FF0045 | Overlay Subtype.
OverlayTime | 0x00080034 | Overlay Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
OverlayType | 0x60FF0040 | Overlay Type.
OverriddenAttributesSequence | 0x0074104A | Overridden Attributes Sequence.
OverrideParameterPointer | 0x30080062 | Override Parameter Pointer.
OverrideReason | 0x30080066 | Override Reason.
OverrideSequence | 0x30080060 | Override Sequence.
OverSamplingPhase | 0x00189029 | Oversampling Phase.
OwnerID | 0x21000160 | Owner Identifier.
PageNumberVector | 0x00182001 | Page Number Vector.
PagePositionID | 0x00005120 | Page Position ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PaletteColorLookupTableSequence | 0x00480120 | Palette Color Lookup Table Sequence.
PaletteColorLookupTableUID | 0x00281199 | Palette Color Lookup Table UID.
ParallelAcqTechnique | 0x00189078 | Parallel Acquisition Technique. This tag name has been deprecated, use tag with the same value defined in the previous line.
ParallelAcquisition | 0x00189077 | Parallel Acquisition.
ParallelAcquisitionTechnique | 0x00189078 | Parallel Acquisition Technique.
ParallelReductionFactorInPlane | 0x00189069 | Parallel Reduction Factor In-plane.
ParallelReductionFactorInPlaneRetired | 0x00189096 | Parallel Reduction Factor In-plane (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ParallelReductionFactorOutOfPlane | 0x00189155 | Parallel Reduction Factor out-of-plane.
ParallelReductionFactorSecondInPlane | 0x00189168 | Parallel Reduction Factor Second In-plane.
ParameterItemIndex | 0x30080063 | Parameter Item Index.
ParameterPointer | 0x30080065 | Parameter Pointer.
ParameterSequencePointer | 0x30080061 | Parameter Sequence Pointer.
PartialDataDisplayHandling | 0x00720208 | Partial Data Display Handling.
PartialFourier | 0x00189081 | Partial Fourier.
PartialFourierDirection | 0x00189036 | Partial Fourier Direction.
PartialView | 0x00281350 | Partial View.
PartialViewCodeSequence | 0x00281352 | Partial View Code Sequence.
PartialViewDescription | 0x00281351 | Partial View Description.
ParticipantSequence | 0x0040A07A | Participant Sequence.
ParticipationDatetime | 0x0040A082 | Participation DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
ParticipationDateTime | 0x0040A082 | Participation DateTime.
ParticipationType | 0x0040A080 | Participation Type.
PatientAdditionalPosition | 0x300A0184 | Patient Additional Position.
PatientAddress | 0x00101040 | Patient's Address.
PatientAge | 0x00101010 | Patient's Age.
PatientBirthDate | 0x00100030 | Patient's Birth Date.
PatientBirthName | 0x00101005 | Patient's Birth Name.
PatientBirthTime | 0x00100032 | Patient's Birth Time.
PatientBreedCodeSequence | 0x00102293 | Patient Breed Code Sequence.
PatientBreedDescription | 0x00102292 | Patient Breed Description.
PatientClinicalTrialParticipationSequence | 0x00380502 | Patient Clinical Trial Participation Sequence.
PatientComments | 0x00104000 | Patient Comments.
PatientEyeMovementCommandCodeSequence | 0x00220006 | Patient Eye Movement Command Code Sequence.
PatientEyeMovementCommanded | 0x00220005 | Patient Eye Movement Commanded.
PatientFrameOfReferenceSource | 0x0020930C | Patient Frame of Reference Source.
PatientGantryRelationCodeSequence | 0x00540414 | Patient Gantry Relationship Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientGantryRelationshipCodeSequence | 0x00540414 | Patient Gantry Relationship Code Sequence.
PatientID | 0x00100020 | Patient ID.
PatientIdentityRemoved | 0x00120062 | Patient Identity Removed.
PatientInstitutionResidence | 0x00380400 | Patient's Institution Residence.
PatientInsurancePlanCodeSequence | 0x00100050 | Patient's Insurance Plan Code Sequence.
PatientMotherBirthName | 0x00101060 | Patient's Mother's Birth Name.
PatientMotionCorrected | 0x00189763 | Patient Motion Corrected.
PatientName | 0x00100010 | Patient's Name.
PatientNotProperlyFixatedQuantity | 0x00240036 | Patient Not Properly Fixated Quantity.
PatientOrientation | 0x00200020 | Patient Orientation.
PatientOrientationCodeSequence | 0x00540410 | Patient Orientation Code Sequence.
PatientOrientationinFrameSequence | 0x00209450 | Patient Orientation in Frame Sequence.
PatientOrientationModifierCodeSequence | 0x00540412 | Patient Orientation Modifier Code Sequence.
PatientOrientCodeSequence | 0x00540410 | Patient Orientation Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientOrientModifierCodeSequence | 0x00540412 | Patient Orientation Modifier Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientPhysiologicalStateCodeSequence | 0x00189772 | Patient Physiological State Code Sequence.
PatientPhysiologicalStateSequence | 0x00189771 | Patient Physiological State Sequence.
PatientPosition | 0x00185100 | Patient Position.
PatientPrimaryLangCodeModSequence | 0x00100102 | Patient's Primary Language Code Modifier Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientPrimaryLangCodeSequence | 0x00100101 | Patient's Primary Language Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientPrimaryLanguageCodeSequence | 0x00100101 | Patient's Primary Language Code Sequence.
PatientPrimaryLanguageModifierCodeSequence | 0x00100102 | Patient's Primary Language Modifier Code Sequence.
PatientReliabilityIndicator | 0x00240069 | Patient Reliability Indicator.
PatientReligiousPreference | 0x001021F0 | Patient's Religious Preference.
PatientResponsibleOrganization | 0x00102299 | Responsible Organization. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsAddress | 0x00101040 | Patient's Address. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsAge | 0x00101010 | Patient's Age. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsBirthDate | 0x00100030 | Patient's Birth Date. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsBirthName | 0x00101005 | Patient's Birth Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsBirthTime | 0x00100032 | Patient's Birth Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientSetupLabel | 0x300A0183 | Patient Setup Label.
PatientSetupNumber | 0x300A0182 | Patient Setup Number.
PatientSetupSequence | 0x300A0180 | Patient Setup Sequence.
PatientSex | 0x00100040 | Patient's Sex.
PatientSexNeutered | 0x00102203 | Patient's Sex Neutered.
PatientsInstitutionResidence | 0x00380400 | Patient's Institution Residence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsInsurancePlanCodeSequence | 0x00100050 | Patient's Insurance Plan Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientSize | 0x00101020 | Patient's Size.
PatientSizeCodeSequence | 0x00101021 | Patient's Size Code Sequence.
PatientsMothersBirthName | 0x00101060 | Patient's Mother's Birth Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsName | 0x00100010 | Patient's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientSpeciesCodeSequence | 0x00102202 | Patient Species Code Sequence.
PatientSpeciesDescription | 0x00102201 | Patient Species Description.
PatientsPrimaryLanguageCodeModifierSequence | 0x00100102 | Patient's Primary Language Code Modifier Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsPrimaryLanguageCodeSequence | 0x00100101 | Patient's Primary Language Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsReligiousPreference | 0x001021F0 | Patient's Religious Preference. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsSex | 0x00100040 | Patient's Sex. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsSexNeutered | 0x00102203 | Patient's Sex Neutered. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientsSize | 0x00101020 | Patient's Size. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientState | 0x00380500 | Patient State.
PatientsTelephoneNumbers | 0x00102154 | Patient's Telephone Numbers. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientSupportAccessoryCode | 0x300A0354 | Patient Support Accessory Code.
PatientSupportAdjustedAngle | 0x0074102A | Patient Support Adjusted Angle.
PatientSupportAngle | 0x300A0122 | Patient Support Angle.
PatientSupportAngleTolerance | 0x300A004C | Patient Support Angle Tolerance.
PatientSupportID | 0x300A0352 | Patient Support ID.
PatientSupportRotationDirection | 0x300A0123 | Patient Support Rotation Direction.
PatientSupportType | 0x300A0350 | Patient Support Type.
PatientsWeight | 0x00101030 | Patient's Weight. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientTelephoneNumbers | 0x00102154 | Patient's Telephone Numbers.
PatientTransport | 0x00401004 | Patient Transport Arrangements. This tag name has been deprecated, use tag with the same value defined in the previous line.
PatientTransportArrangements | 0x00401004 | Patient Transport Arrangements.
PatientWeight | 0x00101030 | Patient's Weight.
PatternOffColorCIELabValue | 0x00700252 | Pattern Off Color CIELab Value.
PatternOffOpacity | 0x00700285 | Pattern Off Opacity.
PatternOnColorCIELabValue | 0x00700251 | Pattern On Color CIELab Value.
PatternOnOpacity | 0x00700284 | Pattern On Opacity.
PauseBetweenFrames | 0x00540038 | Pause Between Frames.
PercentPhaseFieldOfView | 0x00180094 | Percent Phase Field of View.
PercentSampling | 0x00180093 | Percent Sampling.
PerformedActionItemSequence | 0x00400260 | Performed Protocol Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedLocation | 0x00400243 | Performed Location.
PerformedProcedureCodeSequence | 0x0040A372 | Performed Procedure Code Sequence.
PerformedProcedureStepComment | 0x00400280 | Comments on the Performed Procedure Step. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedProcedureStepDesc | 0x00400254 | Performed Procedure Step Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedProcedureStepDescription | 0x00400254 | Performed Procedure Step Description.
PerformedProcedureStepDiscontinuationReasonCodeSequence | 0x00400281 | Performed Procedure Step Discontinuation Reason Code Sequence.
PerformedProcedureStepEndDate | 0x00400250 | Performed Procedure Step End Date.
PerformedProcedureStepEndDateTime | 0x00404051 | Performed Procedure Step End DateTime.
PerformedProcedureStepEndTime | 0x00400251 | Performed Procedure Step End Time.
PerformedProcedureStepID | 0x00400253 | Performed Procedure Step ID.
PerformedProcedureStepStartDate | 0x00400244 | Performed Procedure Step Start Date.
PerformedProcedureStepStartDateTime | 0x00404050 | Performed Procedure Step Start DateTime.
PerformedProcedureStepStartTime | 0x00400245 | Performed Procedure Step Start Time.
PerformedProcedureStepStatus | 0x00400252 | Performed Procedure Step Status.
PerformedProcedureTypeDesc | 0x00400255 | Performed Procedure Type Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedProcedureTypeDescription | 0x00400255 | Performed Procedure Type Description.
PerformedProcessingAppCodeSequence | 0x00404007 | Performed Processing Applications Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedProcessingApplicationsCodeSequence | 0x00404007 | Performed Processing Applications Code Sequence.
PerformedProcessingParametersSequence | 0x00741212 | Performed Processing Parameters Sequence.
PerformedProtocolCodeSequence | 0x00400260 | Performed Protocol Code Sequence.
PerformedProtocolType | 0x00400261 | Performed Protocol Type.
PerformedSeriesSequence | 0x00400340 | Performed Series Sequence.
PerformedStationAeTitle | 0x00400241 | Performed Station AE Title.
PerformedStationClassCodeSequence | 0x00404029 | Performed Station Class Code Sequence.
PerformedStationGeographicLocationCodeSequence | 0x00404030 | Performed Station Geographic Location Code Sequence.
PerformedStationGeoLocationCode | 0x00404030 | Performed Station Geographic Location Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformedStationName | 0x00400242 | Performed Station Name.
PerformedStationNameCodeSequence | 0x00404028 | Performed Station Name Code Sequence.
PerformedWorkitemCodeSequence | 0x00404019 | Performed Workitem Code Sequence.
PerformingPhysicianIdentificationSequence | 0x00081052 | Performing Physician Identification Sequence.
PerformingPhysicianIDSequence | 0x00081052 | Performing Physician Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerformingPhysicianName | 0x00081050 | Performing Physician's Name.
PerformingPhysiciansName | 0x00081050 | Performing Physician's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerfProcStepDiscontReasonCodeSequence | 0x00400281 | Performed Procedure Step Discontinuation Reason Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerFrameFunctionalGroupSequence | 0x52009230 | Per-frame Functional Groups Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PerFrameFunctionalGroupsSequence | 0x52009230 | Per-frame Functional Groups Sequence.
PerimeterTable | 0x00280070 | Perimeter Table. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PerimeterValue | 0x00280071 | Perimeter Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PerProjectionAcquisitionSequence | 0x00189538 | Per Projection Acquisition Sequence.
PersonAddress | 0x00401102 | Person's Address. This tag name has been deprecated, use tag with the same value defined in the previous line.
PersonIDCodeSequence | 0x00401101 | Person Identification Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PersonIdentificationCodeSequence | 0x00401101 | Person Identification Code Sequence.
PersonName | 0x0040A123 | Person Name.
PersonsAddress | 0x00401102 | Person's Address.
PersonsTelephoneNumbers | 0x00401103 | Person's Telephone Numbers. This tag name has been deprecated, use tag with the same value defined in the previous line.
PersonTelephoneNumber | 0x00401103 | Person's Telephone Numbers. This tag name has been deprecated, use tag with the same value defined in the previous line.
PersonTelephoneNumbers | 0x00401103 | Person's Telephone Numbers.
PertinentDocumentsSequence | 0x00380100 | Pertinent Documents Sequence.
PertinentOtherEvidenceSequence | 0x0040A385 | Pertinent Other Evidence Sequence.
PETDetectorMotionDetailsSequence | 0x00189733 | PET Detector Motion Details Sequence.
PETFrameAcquisitionSequence | 0x00189732 | PET Frame Acquisition Sequence.
PETFrameCorrectionFactorsSequence | 0x00189736 | PET Frame Correction Factors Sequence.
PETFrameTypeSequence | 0x00189751 | PET Frame Type Sequence.
PETPositionSequence | 0x00189735 | PET Position Sequence.
PETReconstructionSequence | 0x00189749 | PET Reconstruction Sequence.
PETTableDynamicsSequence | 0x00189734 | PET Table Dynamics Sequence.
PhantomType | 0x40101046 | Phantom Type.
PhaseContrast | 0x00189014 | Phase Contrast.
PhaseDelay | 0x00540036 | Phase Delay.
PhaseDescription | 0x00540039 | Phase Description.
PhaseInformationSequence | 0x00540032 | Phase Information Sequence.
PhaseInfoSequence | 0x00540032 | Phase Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PhaseNumber | 0x00200015 | Phase Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PhaseVector | 0x00540030 | Phase Vector.
PhosphorType | 0x00181261 | Phosphor Type.
PhotometricInterpretation | 0x00280004 | Photometric Interpretation.
PhototimerSetting | 0x00187065 | Phototimer Setting.
PhysicalDeltaX | 0x0018602C | Physical Delta X.
PhysicalDeltaY | 0x0018602E | Physical Delta Y.
PhysicalDetectorSize | 0x00189429 | Physical Detector Size.
PhysicalUnitsXDirection | 0x00186024 | Physical Units X Direction.
PhysicalUnitsYDirection | 0x00186026 | Physical Units Y Direction.
PhysicianApprovingInterpretation | 0x40080114 | Physician Approving Interpretation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PhysicianOfRecordIDSequence | 0x00081049 | Physician(s) of Record Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PhysicianReadingStudyIDSequence | 0x00081062 | Physician(s) Reading Study Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PhysiciansOfRecord | 0x00081048 | Physician(s) of Record.
PhysiciansOfRecordIdentificationSequence | 0x00081049 | Physician(s) of Record Identification Sequence.
PhysiciansReadingStudyIdentificationSequence | 0x00081062 | Physician(s) Reading Study Identification Sequence.
PixelAspectRatio | 0x00280034 | Pixel Aspect Ratio.
PixelBandwidth | 0x00180095 | Pixel Bandwidth.
PixelComponentDataType | 0x0018604E | Pixel Component Data Type.
PixelComponentMask | 0x00186046 | Pixel Component Mask.
PixelComponentOrganization | 0x00186044 | Pixel Component Organization.
PixelComponentPhysicalUnits | 0x0018604C | Pixel Component Physical Units.
PixelComponentRangeStart | 0x00186048 | Pixel Component Range Start.
PixelComponentRangeStop | 0x0018604A | Pixel Component Range Stop.
PixelCoordinateSet | 0x0040A29A | Pixel Coordinate Set. This tag name has been deprecated, use tag with the same value defined in the previous line.
PixelCoordinatesSetTrial | 0x0040A29A | Pixel Coordinates Set (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PixelData | 0x7FE00010 | Pixel Data.
PixelDataAreaOriginRelativeToFOV | 0x00187036 | Pixel Data Area Origin Relative To FOV.
PixelDataAreaRotationAngleRelativeToFOV | 0x00187038 | Pixel Data Area Rotation Angle Relative To FOV.
PixelDataProviderURL | 0x00287FE0 | Pixel Data Provider URL.
PixelIntensityRelationship | 0x00281040 | Pixel Intensity Relationship.
PixelIntensityRelationshipLUTSequence | 0x00289422 | Pixel Intensity Relationship LUT Sequence.
PixelIntensityRelationshipSign | 0x00281041 | Pixel Intensity Relationship Sign.
PixelMeasuresSequence | 0x00289110 | Pixel Measures Sequence.
PixelOriginInterpretation | 0x00480301 | Pixel Origin Interpretation.
PixelPaddingRangeLimit | 0x00280121 | Pixel Padding Range Limit.
PixelPaddingValue | 0x00280120 | Pixel Padding Value.
PixelPresentation | 0x00089205 | Pixel Presentation.
PixelRepresentation | 0x00280103 | Pixel Representation.
PixelShiftFrameRange | 0x00289506 | Pixel Shift Frame Range.
PixelShiftSequence | 0x00289501 | Pixel Shift Sequence.
PixelSpacing | 0x00280030 | Pixel Spacing.
PixelSpacingCalibrationDescription | 0x00280A04 | Pixel Spacing Calibration Description.
PixelSpacingCalibrationType | 0x00280A02 | Pixel Spacing Calibration Type.
PixelSpacingSequence | 0x004008D8 | Pixel Spacing Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PixelValueMappingCodeSequence | 0x00409098 | Pixel Value Mapping Code Sequence.
PixelValueTransformationSequence | 0x00289145 | Pixel Value Transformation Sequence.
PlacerOrderNumberImagingServiceRequest | 0x00402016 | Placer Order Number / Imaging Service Request.
PlacerOrderNumberImagingServiceRequestRetired | 0x00402006 | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PlacerOrderNumberProcedure | 0x00401006 | Placer Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PlanarConfiguration | 0x00280006 | Planar Configuration.
PlaneIdentification | 0x00189457 | Plane Identification.
PlaneOrientationSequence | 0x00209116 | Plane Orientation Sequence.
PlaneOrientationVolumeSequence | 0x0020930F | Plane Orientation (Volume) Sequence.
PlanePositionSequence | 0x00209113 | Plane Position Sequence.
PlanePositionSlideSequence | 0x0048021A | Plane Position (Slide) Sequence.
PlanePositionVolumeSequence | 0x0020930E | Plane Position (Volume) Sequence.
Planes | 0x00280012 | Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PlanesInAcquisition | 0x00189410 | Planes in Acquisition.
PlanIntent | 0x300A000A | Plan Intent.
PlannedVerificationImageSequence | 0x300A00CA | Planned Verification Image Sequence.
PlanningLandmarkDescription | 0x00686540 | Planning Landmark Description.
PlanningLandmarkID | 0x00686530 | Planning Landmark ID.
PlanningLandmarkIdentificationCodeSequence | 0x00686545 | Planning Landmark Identification Code Sequence.
PlanningLandmarkLineSequence | 0x00686510 | Planning Landmark Line Sequence.
PlanningLandmarkPlaneSequence | 0x00686520 | Planning Landmark Plane Sequence.
PlanningLandmarkPointSequence | 0x00686500 | Planning Landmark Point Sequence.
PlateID | 0x00181004 | Plate Identifier.
PlateType | 0x00181260 | Plate Type.
PointCoordinatesData | 0x00660016 | Point Coordinates Data.
PointPositionAccuracy | 0x00660017 | Point Position Accuracy.
PointsBoundingBoxCoordinates | 0x0066001A | Points Bounding Box Coordinates.
Polarity | 0x20200020 | Image Polarity.
PolygonalCollimatorVertices | 0x00181720 | Vertices of the Polygonal Collimator. This tag name has been deprecated, use tag with the same value defined in the previous line.
PolygonalShutterVertices | 0x00181620 | Vertices of the Polygonal Shutter. This tag name has been deprecated, use tag with the same value defined in the previous line.
PositionerIsocenterDetectorRotationAngle | 0x00189465 | Positioner Isocenter Detector Rotation Angle.
PositionerIsocenterPrimaryAngle | 0x00189463 | Positioner Isocenter Primary Angle.
PositionerIsocenterSecondaryAngle | 0x00189464 | Positioner Isocenter Secondary Angle.
PositionerMotion | 0x00181500 | Positioner Motion.
PositionerPositionSequence | 0x00189405 | Positioner Position Sequence.
PositionerPrimaryAngle | 0x00181510 | Positioner Primary Angle.
PositionerPrimaryAngleIncr | 0x00181520 | Positioner Primary Angle Increment. This tag name has been deprecated, use tag with the same value defined in the previous line.
PositionerPrimaryAngleIncrement | 0x00181520 | Positioner Primary Angle Increment.
PositionerSecondaryAngle | 0x00181511 | Positioner Secondary Angle.
PositionerSecondaryAngleIncr | 0x00181521 | Positioner Secondary Angle Increment. This tag name has been deprecated, use tag with the same value defined in the previous line.
PositionerSecondaryAngleIncrement | 0x00181521 | Positioner Secondary Angle Increment.
PositionerType | 0x00181508 | Positioner Type.
PositionMeasuringDeviceUsed | 0x0018980C | Position Measuring Device Used.
PositionofIsocenterProjection | 0x00189430 | Position of Isocenter Projection.
PositionReferenceIndicator | 0x00201040 | Position Reference Indicator.
PositiveCatchTrialsQuantity | 0x00240056 | Positive Catch Trials Quantity.
PostDeformationMatrixRegistrationSequence | 0x00640010 | Post Deformation Matrix Registration Sequence.
PostprocessingFunction | 0x00185021 | Postprocessing Function. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PotentialThreatObjectID | 0x40101010 | Potential Threat Object ID.
Preamble | 0x00000005 | DICOM preamble.
PreAmplifierEquipmentSequence | 0x0014400E | Pre-Amplifier Equipment Sequence.
PreAmplifierNotes | 0x0014400F | Pre-Amplifier Notes.
PreAmplifierSettingsSequence | 0x00144040 | Pre-Amplifier Settings Sequence.
PredecessorDocumentsSequence | 0x0040A360 | Predecessor Documents Sequence.
PreDeformationMatrixRegistrationSequence | 0x0064000F | Pre Deformation Matrix Registration Sequence.
PredictedRefractiveError | 0x00221054 | Predicted Refractive Error.
PredictorColumns | 0x00280081 | Predictor Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PredictorConstants | 0x00280082 | Predictor Constants. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PredictorRows | 0x00280080 | Predictor Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PreferredPlaybackSequencing | 0x00181244 | Preferred Playback Sequencing.
PreformattedColorImageSequence | 0x20200111 | Basic Color Image Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PreformattedGrayscaleImageSequence | 0x20200110 | Basic Grayscale Image Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PregnancyStatus | 0x001021C0 | Pregnancy Status.
PreliminaryFlag | 0x0040A496 | Preliminary Flag.
PreMedication | 0x00400012 | Pre Medication.
PreprocessingFunction | 0x00185020 | Processing Function. This tag name has been deprecated, use tag with the same value defined in the previous line.
PrescriptionDescription | 0x300A000E | Prescription Description.
PresentationCreationDate | 0x00700082 | Presentation Creation Date.
PresentationCreationTime | 0x00700083 | Presentation Creation Time.
PresentationCreatorsName | 0x00700084 | Content Creator's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
PresentationDescription | 0x00700081 | Content Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
PresentationGroupNumber | 0x003A0241 | Presentation Group Number.
PresentationIntentType | 0x00080068 | Presentation Intent Type.
PresentationLabel | 0x00700080 | Content Label. This tag name has been deprecated, use tag with the same value defined in the previous line.
PresentationLutContentSequence | 0x21300080 | Presentation LUT Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PresentationLutFlag | 0x20000069 | Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PresentationLutSequence | 0x20500010 | Presentation LUT Sequence.
PresentationLutShape | 0x20500020 | Presentation LUT Shape.
PresentationPixelAspectRatio | 0x00700102 | Presentation Pixel Aspect Ratio.
PresentationPixelMagnificationRatio | 0x00700103 | Presentation Pixel Magnification Ratio.
PresentationPixelSpacing | 0x00700101 | Presentation Pixel Spacing.
PresentationSizeMode | 0x00700100 | Presentation Size Mode.
PresentedVisualStimuliDataFlag | 0x00240037 | Presented Visual Stimuli Data Flag.
PreserveCompositeInstancesAfterMediaCreation | 0x2200000A | Preserve Composite Instances After Media Creation.
PrimaryAnatomicStructureModifierSequence | 0x00082230 | Primary Anatomic Structure Modifier Sequence.
PrimaryAnatomicStructureSequence | 0x00082228 | Primary Anatomic Structure Sequence.
PrimaryCountsAccumulated | 0x00541310 | Primary (Prompts) Counts Accumulated. This tag name has been deprecated, use tag with the same value defined in the previous line.
PrimaryDosimeterUnit | 0x300A00B3 | Primary Dosimeter Unit.
PrimaryFluenceModeSequence | 0x30020050 | Primary Fluence Mode Sequence.
PrimaryPositionerIncrement | 0x00189514 | Primary Positioner Increment.
PrimaryPositionerScanArc | 0x00189508 | Primary Positioner Scan Arc.
PrimaryPositionerScanStartAngle | 0x00189510 | Primary Positioner Scan Start Angle.
PrimaryPromptsCountsAccumulated | 0x00541310 | Primary (Prompts) Counts Accumulated.
PrimitivePointIndexList | 0x00660029 | Primitive Point Index List.
Print | 0x000051A0 | Print. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PrinterCharacteristicsSequence | 0x21300015 | Printer Characteristics Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PrinterConfigSequence | 0x2000001E | Printer Configuration Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PrinterConfigurationSequence | 0x2000001E | Printer Configuration Sequence.
PrinterName | 0x21100030 | Printer Name.
PrinterPixelSpacing | 0x20100376 | Printer Pixel Spacing.
PrinterResolutionID | 0x20100052 | Printer Resolution ID.
PrinterStatus | 0x21100010 | Printer Status.
PrinterStatusInfo | 0x21100020 | Printer Status Info.
PrintingBitDepth | 0x200000A1 | Printing Bit Depth.
PrintJobDescriptionSequence | 0x21200050 | Print Job Description Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PrintJobID | 0x21000010 | Print Job ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PrintManagementCapabilitiesSequence | 0x21300010 | Print Management Capabilities Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
PrintPriority | 0x20000020 | Print Priority.
PrintQueueID | 0x21100099 | Print Queue ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Priority | 0x00000700 | Operation Priority.
PrismSequence | 0x00460028 | Prism Sequence.
PrivateInformation | 0x00020102 | Private Information.
PrivateInformationCreatorUID | 0x00020100 | Private Information Creator UID.
PrivateRecordUID | 0x00041432 | Private Record UID.
ProcedureCodeSequence | 0x00081032 | Procedure Code Sequence.
ProcedureContextFlagTrial | 0x0040A603 | Procedure Context Flag (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ProcedureContextSequenceTrial | 0x0040A340 | Procedure Context Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ProcedureCreationDate | 0x00144076 | Procedure Creation Date.
ProcedureExpirationDate | 0x00144078 | Procedure Expiration Date.
ProcedureIdentifierCodeSequenceTrial | 0x0040A085 | Procedure Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ProcedureLastModifiedDate | 0x0014407A | Procedure Last Modified Date.
ProcedureStepCancellationDateTime | 0x00404052 | Procedure Step Cancellation DateTime.
ProcedureStepCommunicationsURISequence | 0x00741008 | Procedure Step Communications URI Sequence.
ProcedureStepDiscontinuationReasonCodeSequence | 0x0074100E | Procedure Step Discontinuation Reason Code Sequence.
ProcedureStepLabel | 0x00741204 | Procedure Step Label.
ProcedureStepProgress | 0x00741004 | Procedure Step Progress.
ProcedureStepProgressDescription | 0x00741006 | Procedure Step Progress Description.
ProcedureStepProgressInformationSequence | 0x00741002 | Procedure Step Progress Information Sequence.
ProcedureStepRelationshipType | 0x00741222 | Procedure Step Relationship Type.
ProcedureStepState | 0x00741000 | Procedure Step State.
ProcedureTypeCodeSequence | 0x00760020 | Procedure Type Code Sequence.
ProcedureVersion | 0x00144074 | Procedure Version.
ProcessingFunction | 0x00185020 | Processing Function.
ProductDescription | 0x00440009 | Product Description.
ProductExpirationDateTime | 0x0044000B | Product Expiration DateTime.
ProductLotIdentifier | 0x0044000A | Product Lot Identifier.
ProductName | 0x00440008 | Product Name.
ProductPackageIdentifier | 0x00440001 | Product Package Identifier.
ProductParameterSequence | 0x00440013 | Product Parameter Sequence.
ProductTypeCodeSequence | 0x00440007 | Product Type Code Sequence.
ProjectionEponymousNameCodeSequence | 0x00185104 | Projection Eponymous Name Code Sequence.
ProjectionPixelCalibrationSequence | 0x00189401 | Projection Pixel Calibration Sequence.
ProjEponymousNameCodeSequence | 0x00185104 | Projection Eponymous Name Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
PropertyLabel | 0x00142032 | Property Label.
ProposedStudySequence | 0x213000A0 | Proposed Study Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ProtocolContextSequence | 0x00400440 | Protocol Context Sequence.
ProtocolName | 0x00181030 | Protocol Name.
PseudoColorPaletteInstanceReferenceSequence | 0x00720705 | Pseudo-Color Palette Instance Reference Sequence.
PseudocolorType | 0x00720704 | Pseudo-color Type.
PTORepresentationSequence | 0x40101037 | PTO Representation Sequence.
PulseRepetitionFrequency | 0x00186032 | Pulse Repetition Frequency.
PulseRepetitionInterval | 0x300A028C | Pulse Repetition Interval.
PulserEquipmentSequence | 0x00144002 | Pulser Equipment Sequence.
PulserNotes | 0x00144006 | Pulser Notes.
PulserSettingsSequence | 0x00144020 | Pulser Settings Sequence.
PulserType | 0x00144004 | Pulser Type.
PulseSequenceName | 0x00189005 | Pulse Sequence Name.
PulseWidth | 0x00144022 | Pulse Width.
PupilDilated | 0x0022000D | Pupil Dilated.
PupilSize | 0x00460044 | Pupil Size.
PurposeOfReferenceCodeSequence | 0x0040A170 | Purpose of Reference Code Sequence.
PvcRejection | 0x00181085 | PVC Rejection.
QuadratureReceiveCoil | 0x00189044 | Quadrature Receive Coil.
QualityControlImage | 0x00280300 | Quality Control Image.
QuantifiedDefect | 0x00240098 | Quantified Defect.
Quantity | 0x00400294 | Quantity value.
QuantitySequence | 0x00400293 | Quantity Sequence.
QueryRetrieveLevel | 0x00080052 | Query/Retrieve Level.
QueueStatus | 0x21200010 | Queue Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
R_Wave_Time_Vector | 0x00186060 | R Wave Time Vector. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadialPosition | 0x00181142 | Radial Position.
RadiationAtomicNumber | 0x300A0304 | Radiation Atomic Number.
RadiationChargeState | 0x300A0306 | Radiation Charge State.
RadiationDoseComment | 0x00400310 | Comments on Radiation Dose. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiationMachineName | 0x30020020 | Radiation Machine Name.
RadiationMachineSad | 0x30020022 | Radiation Machine SAD.
RadiationMachineSsd | 0x30020024 | Radiation Machine SSD.
RadiationMassNumber | 0x300A0302 | Radiation Mass Number.
RadiationMode | 0x0018115A | Radiation Mode.
RadiationSetting | 0x00181155 | Radiation Setting.
RadiationType | 0x300A00C6 | Radiation Type.
Radionuclide | 0x00180030 | Radionuclide. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RadionuclideCodeSequence | 0x00540300 | Radionuclide Code Sequence.
RadionuclideHalfLife | 0x00181075 | Radionuclide Half Life.
RadionuclidePositronFraction | 0x00181076 | Radionuclide Positron Fraction.
RadionuclideTotalDose | 0x00181074 | Radionuclide Total Dose.
Radiopharmaceutical | 0x00180031 | Radiopharmaceutical value.
RadiopharmaceuticalAgentNumber | 0x00189729 | Radiopharmaceutical Agent Number.
RadiopharmaceuticalCodeSequence | 0x00540304 | Radiopharmaceutical Code Sequence.
RadiopharmaceuticalInformationSequence | 0x00540016 | Radiopharmaceutical Information Sequence.
RadiopharmaceuticalRoute | 0x00181070 | Radiopharmaceutical Route.
RadiopharmaceuticalSpecificActivity | 0x00181077 | Radiopharmaceutical Specific Activity.
RadiopharmaceuticalStartDatetime | 0x00181078 | Radiopharmaceutical Start DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaceuticalStartDateTime | 0x00181078 | Radiopharmaceutical Start DateTime.
RadiopharmaceuticalStartTime | 0x00181072 | Radiopharmaceutical Start Time.
RadiopharmaceuticalStopDatetime | 0x00181079 | Radiopharmaceutical Stop DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaceuticalStopDateTime | 0x00181079 | Radiopharmaceutical Stop DateTime.
RadiopharmaceuticalStopTime | 0x00181073 | Radiopharmaceutical Stop Time.
RadiopharmaceuticalUsageSequence | 0x00189737 | Radiopharmaceutical Usage Sequence.
RadiopharmaceuticalVolume | 0x00181071 | Radiopharmaceutical Volume.
RadiopharmaCodeSequence | 0x00540304 | Radiopharmaceutical Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaInfoSequence | 0x00540016 | Radiopharmaceutical Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaRoute | 0x00181070 | Radiopharmaceutical Route. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaSpecificActivity | 0x00181077 | Radiopharmaceutical Specific Activity. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaStartTime | 0x00181072 | Radiopharmaceutical Start Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaStopTime | 0x00181073 | Radiopharmaceutical Stop Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiopharmaVolume | 0x00181071 | Radiopharmaceutical Volume. This tag name has been deprecated, use tag with the same value defined in the previous line.
RadiusOfCircularCollimator | 0x00181712 | Radius of Circular Collimator.
RadiusofCircularExposureControlSensingRegion | 0x00189441 | Radius of Circular Exposure Control Sensing Region.
RadiusOfCircularShutter | 0x00181612 | Radius of Circular Shutter.
RadiusOfCurvature | 0x00460075 | Radius of Curvature.
RandomsCorrected | 0x00189765 | Randoms Corrected.
RandomsCorrectionMethod | 0x00541100 | Randoms Correction Method.
RangeModulatorDescription | 0x300A034A | Range Modulator Description.
RangeModulatorGatingStartValue | 0x300A0382 | Range Modulator Gating Start Value.
RangeModulatorGatingStartWaterEquivalent | 0x300A0386 | Range Modulator Gating Start Water Equivalent Thickness. This tag name has been deprecated, use tag with the same value defined in the previous line.
RangeModulatorGatingStartWaterEquivalentThickness | 0x300A0386 | Range Modulator Gating Start Water Equivalent Thickness.
RangeModulatorGatingStopValue | 0x300A0384 | Range Modulator Gating Stop Value.
RangeModulatorGatingStopWaterEquivalent | 0x300A0388 | Range Modulator Gating Stop Water Equivalent Thickness. This tag name has been deprecated, use tag with the same value defined in the previous line.
RangeModulatorGatingStopWaterEquivalentThickness | 0x300A0388 | Range Modulator Gating Stop Water Equivalent Thickness.
RangeModulatorID | 0x300A0346 | Range Modulator ID.
RangeModulatorNumber | 0x300A0344 | Range Modulator Number.
RangeModulatorSequence | 0x300A0342 | Range Modulator Sequence.
RangeModulatorSettingsSequence | 0x300A0380 | Range Modulator Settings Sequence.
RangeModulatorType | 0x300A0348 | Range Modulator Type.
RangeOfFreedom | 0x006864A0 | Range of Freedom.
RangeShifterDescription | 0x300A0322 | Range Shifter Description.
RangeShifterID | 0x300A0318 | Range Shifter ID.
RangeShifterNumber | 0x300A0316 | Range Shifter Number.
RangeShifterSequence | 0x300A0314 | Range Shifter Sequence.
RangeShifterSetting | 0x300A0362 | Range Shifter Setting.
RangeShifterSettingsSequence | 0x300A0360 | Range Shifter Settings Sequence.
RangeShifterType | 0x300A0320 | Range Shifter Type.
RangeShifterWaterEquivalentThickness | 0x300A0366 | Range Shifter Water Equivalent Thickness.
RangingDepth | 0x00520009 | Ranging Depth.
RawDataHandling | 0x00404040 | Raw Data Handling.
RealWorldValFirstValMapped | 0x00409216 | Real World Value First Value Mapped. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValIntercept | 0x00409224 | Real World Value Intercept. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValLastValMapped | 0x00409211 | Real World Value Last Value Mapped. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValLutData | 0x00409212 | Real World Value LUT Data. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValMappingSequence | 0x00409096 | Real World Value Mapping Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValSlope | 0x00409225 | Real World Value Slope. This tag name has been deprecated, use tag with the same value defined in the previous line.
RealWorldValueFirstValueMapped | 0x00409216 | Real World Value First Value Mapped.
RealWorldValueIntercept | 0x00409224 | Real World Value Intercept.
RealWorldValueLastValueMapped | 0x00409211 | Real World Value Last Value Mapped.
RealWorldValueLUTData | 0x00409212 | Real World Value LUT Data.
RealWorldValueMappingSequence | 0x00409096 | Real World Value Mapping Sequence.
RealWorldValueSlope | 0x00409225 | Real World Value Slope.
ReasonForCancellation | 0x00741238 | Reason for Cancellation.
ReasonForPerformedProcedureCodeSequence | 0x00401012 | Reason For Performed Procedure Code Sequence.
ReasonforRequestedProcedureCodeSequence | 0x0040100A | Reason for Requested Procedure Code Sequence.
ReasonForStudy | 0x00321030 | Reason for Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReasonForTheAttributeModification | 0x04000565 | Reason for the Attribute Modification.
ReasonForTheImagingServiceRequest | 0x00402001 | Reason for the Imaging Service Request. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReasonForTheRequestedProcedure | 0x00401002 | Reason for the Requested Procedure.
ReceiveCoilManufacturerName | 0x00189041 | Receive Coil Manufacturer Name.
ReceiveCoilName | 0x00181250 | Receive Coil Name.
ReceiveCoilType | 0x00189043 | Receive Coil Type.
ReceiverAeTitle | 0x00000300 | Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReceiverEquipmentSequence | 0x00144008 | Receiver Equipment Sequence.
ReceiverNotes | 0x0014400C | Receiver Notes.
ReceiverSettingsSequence | 0x00144030 | Receiver Settings Sequence.
ReceiveTransducerSequence | 0x00144011 | Receive Transducer Sequence.
ReceiveTransducerSettingsSequence | 0x00144051 | Receive Transducer Settings Sequence.
ReceivingAE | 0x00741234 | Receiving AE.
RecognitionCode | 0x00000010 | Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RecognitionCodeRetired | 0x00080010 | Recognition Code (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RecognizableVisualFeatures | 0x00280302 | Recognizable Visual Features.
RecommendedAbsentPixelCIELabValue | 0x00480015 | Recommended Absent Pixel CIELab Value.
RecommendedDisplayCIELabValue | 0x0062000D | Recommended Display CIELab Value.
RecommendedDisplayFrameRate | 0x00082144 | Recommended Display Frame Rate.
RecommendedDisplayFrameRateinFloat | 0x00089459 | Recommended Display Frame Rate in Float.
RecommendedDisplayGrayscaleValue | 0x0062000C | Recommended Display Grayscale Value.
RecommendedPresentationOpacity | 0x0066000C | Recommended Presentation Opacity.
RecommendedPresentationType | 0x0066000D | Recommended Presentation Type.
RecommendedRotationPoint | 0x00686346 | Recommended Rotation Point.
RecommendedViewingMode | 0x00281090 | Recommended Viewing Mode.
ReconstructionAlgorithm | 0x00189315 | Reconstruction Algorithm.
ReconstructionAngle | 0x00189319 | Reconstruction Angle.
ReconstructionDescription | 0x00189531 | Reconstruction Description.
ReconstructionDiameter | 0x00181100 | Reconstruction Diameter.
ReconstructionFieldofView | 0x00189317 | Reconstruction Field of View.
ReconstructionIndex | 0x00209536 | Reconstruction Index.
ReconstructionMethod | 0x00541103 | Reconstruction Method.
ReconstructionPixelSpacing | 0x00189322 | Reconstruction Pixel Spacing.
ReconstructionTargetCenterPatient | 0x00189318 | Reconstruction Target Center (Patient).
ReconstructionType | 0x00189756 | Reconstruction Type.
RecordedBlockSequence | 0x300800D0 | Recorded Block Sequence.
RecordedBrachyAccDeviceSequence | 0x30080120 | Recorded Brachy Accessory Device Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RecordedBrachyAccessoryDeviceSequence | 0x30080120 | Recorded Brachy Accessory Device Sequence.
RecordedChannelSequence | 0x30080130 | Recorded Channel Sequence.
RecordedChannelShieldSequence | 0x30080150 | Recorded Channel Shield Sequence.
RecordedCompensatorSequence | 0x300800C0 | Recorded Compensator Sequence.
RecordedLateralSpreadingDeviceSequence | 0x300800F4 | Recorded Lateral Spreading Device Sequence.
RecordedRangeModulatorSequence | 0x300800F6 | Recorded Range Modulator Sequence.
RecordedRangeShifterSequence | 0x300800F2 | Recorded Range Shifter Sequence.
RecordedSnoutSequence | 0x300800F0 | Recorded Snout Sequence.
RecordedSourceApplicatorSequence | 0x30080140 | Recorded Source Applicator Sequence.
RecordedSourceSequence | 0x30080100 | Recorded Source Sequence.
RecordedWedgeSequence | 0x300800B0 | Recorded Wedge Sequence.
RecordInUseFlag | 0x00041410 | Record In-use Flag.
RectificationType | 0x00181156 | Rectification Type.
RectifierSmoothing | 0x00144034 | Rectifier Smoothing.
RectilinearPhaseEncodeReordering | 0x00189034 | Rectilinear Phase Encode Reordering.
RedPaletteColorLookupTableData | 0x00281201 | Red Palette Color Lookup Table Data.
RedPaletteColorLookupTableDescriptor | 0x00281101 | Red Palette Color Lookup Table Descriptor.
RefBrachyAccDevNumber | 0x30080122 | Referenced Brachy Accessory Device Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefCalcDoseRefNumber | 0x30080092 | Referenced Calculated Dose Reference Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefCalcDoseRefSequence | 0x30080090 | Referenced Calculated Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
Reference | 0x00201020 | Reference. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferenceAirKermaRate | 0x300A022A | Reference Air Kerma Rate.
ReferenceCoordinates | 0x00220032 | Reference Coordinates.
ReferencedAccessionSequenceTrial | 0x0040A313 | Referenced Accession Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedBasicAnnotationBoxSequence | 0x20100520 | Referenced Basic Annotation Box Sequence.
ReferencedBasicImageBoxSequence | 0x20100510 | Referenced Image Box Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedBeamNumber | 0x300C0006 | Referenced Beam Number.
ReferencedBeamSequence | 0x300C0004 | Referenced Beam Sequence.
ReferencedBlockNumber | 0x300C00E0 | Referenced Block Number.
ReferencedBolusSequence | 0x300C00B0 | Referenced Bolus Sequence.
ReferencedBrachyAccessoryDeviceNumber | 0x30080122 | Referenced Brachy Accessory Device Number.
ReferencedBrachyApplicationSetupNumber | 0x300C000C | Referenced Brachy Application Setup Number.
ReferencedBrachyApplicationSetupSequence | 0x300C000A | Referenced Brachy Application Setup Sequence.
ReferencedBrachyAppSetupNumber | 0x300C000C | Referenced Brachy Application Setup Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedBrachyAppSetupSequence | 0x300C000A | Referenced Brachy Application Setup Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedCalculatedDoseReferenceNumber | 0x30080092 | Referenced Calculated Dose Reference Number.
ReferencedCalculatedDoseReferenceSequence | 0x30080090 | Referenced Calculated Dose Reference Sequence.
ReferencedChannelShieldNumber | 0x30080152 | Referenced Channel Shield Number.
ReferencedColorPaletteInstanceUID | 0x00280304 | Referenced Color Palette Instance UID.
ReferencedCompensatorNumber | 0x300C00D0 | Referenced Compensator Number.
ReferencedContentItemID | 0x0040DB73 | Referenced Content Item Identifier. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedContentItemIdentifier | 0x0040DB73 | Referenced Content Item Identifier.
ReferencedControlPoint | 0x300C00F0 | Referenced Control Point Index. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedControlPointIndex | 0x300C00F0 | Referenced Control Point Index.
ReferencedControlPointSequence | 0x300C00F2 | Referenced Control Point Sequence.
ReferencedCurveSequence | 0x00081145 | Referenced Curve Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedDatetime | 0x0040A13A | Referenced DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedDateTime | 0x0040A13A | Referenced DateTime.
ReferencedDigitalSignatureSequence | 0x04000402 | Referenced Digital Signature Sequence.
ReferencedDoseReferenceNumber | 0x300C0051 | Referenced Dose Reference Number.
ReferencedDoseReferenceSequence | 0x300C0050 | Referenced Dose Reference Sequence.
ReferencedDoseSequence | 0x300C0080 | Referenced Dose Sequence.
ReferencedFileID | 0x00041500 | Referenced File ID.
ReferencedFileXferSynUID | 0x00041512 | Referenced Transfer Syntax UID in File.
ReferencedFilmBoxSequence | 0x20000500 | Referenced Film Box Sequence.
ReferencedFilmSessionSequence | 0x20100500 | Referenced Film Session Sequence.
ReferencedFindingsGroupUIDTrial | 0x0040A022 | Referenced Findings Group UID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedFirstFrameSequence | 0x00720427 | Referenced First Frame Sequence.
ReferencedFractionGroupNumber | 0x300C0022 | Referenced Fraction Group Number.
ReferencedFractionGroupSequence | 0x300C0020 | Referenced Fraction Group Sequence.
ReferencedFractionNumber | 0x30080223 | Referenced Fraction Number.
ReferencedFrameNumber | 0x00081160 | Referenced Frame Number.
ReferencedFrameNumbers | 0x0040A136 | Referenced Frame Numbers.
ReferencedFrameOfReferenceSequence | 0x30060010 | Referenced Frame of Reference Sequence.
ReferencedFrameOfReferenceUID | 0x30060024 | Referenced Frame of Reference UID.
ReferencedGeneralPurposeScheduledProcedureStepSequence | 0x00404016 | Referenced General Purpose Scheduled Procedure Step Sequence.
ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | 0x00404023 | Referenced General Purpose Scheduled Procedure Step Transaction UID.
ReferencedGenScheduledProcStepUID | 0x00404023 | Referenced General Purpose Scheduled Procedure Step Transaction UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedGrayscalePresentationStateSequence | 0x00089237 | Referenced Grayscale Presentation State Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedHPGLDocumentID | 0x00686440 | Referenced HPGL Document ID.
ReferencedImageBoxSequence | 0x20100510 | Referenced Image Box Sequence.
ReferencedImageBoxSequenceRetired | 0x20400500 | Referenced Image Box Sequence (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedImageEvidenceSequence | 0x00089092 | Referenced Image Evidence Sequence.
ReferencedImageNavigationSequence | 0x00480200 | Referenced Image Navigation Sequence.
ReferencedImageOverlayBoxSequence | 0x20200130 | Referenced Image Overlay Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedImageRealWorldValueMappingSequence | 0x00409094 | Referenced Image Real World Value Mapping Sequence.
ReferencedImageSequence | 0x00081140 | Referenced Image Sequence.
ReferencedImplantTemplateGroupMemberID | 0x007800B6 | Referenced Implant Template Group Member ID.
ReferencedInstanceSequence | 0x0008114A | Referenced Instance Sequence.
ReferencedInterpretationSequence | 0x40080050 | Referenced Interpretation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferenceDisplaySets | 0x00720218 | Reference Display Sets.
ReferencedLateralSpreadingDeviceNumber | 0x300C0102 | Referenced Lateral Spreading Device Number.
ReferencedLowerlevelDirectoryEntityOffset | 0x00041420 | Offset of Referenced Lower-Level Directory Entity. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedMeasuredDoseReferenceNumber | 0x30080082 | Referenced Measured Dose Reference Number.
ReferencedMeasuredDoseReferenceSequence | 0x30080080 | Referenced Measured Dose Reference Sequence.
ReferencedNonImageCompositeSOPInstanceSequence | 0x00400220 | Referenced Non-Image Composite SOP Instance Sequence.
ReferencedObjectObservationClassTrial | 0x0040A174 | Referenced Object Observation Class (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedObservationClassTrial | 0x0040A173 | Referenced Observation Class (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedObservationUIDTrial | 0x0040A172 | Referenced Observation UID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedOphthalmicAxialLengthMeasurementQCImageSequence | 0x00221330 | Referenced Ophthalmic Axial Length Measurement QC Image Sequence.
ReferencedOphthalmicAxialMeasurementsSequence | 0x00221100 | Referenced Ophthalmic Axial Measurements Sequence.
ReferencedOtherPlaneSequence | 0x00089410 | Referenced Other Plane Sequence.
ReferencedOverlayPlaneGroups | 0x20400011 | Referenced Overlay Plane Groups. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedOverlayPlaneSequence | 0x20400010 | Referenced Overlay Plane Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedOverlaySequence | 0x00081130 | Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedPatientAliasSequence | 0x00380004 | Referenced Patient Alias Sequence.
ReferencedPatientSequence | 0x00081120 | Referenced Patient Sequence.
ReferencedPatientSetupNumber | 0x300C006A | Referenced Patient Setup Number.
ReferencedPerformedProcedureStepSequence | 0x00081111 | Referenced Performed Procedure Step Sequence.
ReferencedPerformedProcStepSequence | 0x00081111 | Referenced Performed Procedure Step Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedPresentationLutSequence | 0x20500500 | Referenced Presentation LUT Sequence.
ReferencedPresentationStateSequence | 0x00089237 | Referenced Presentation State Sequence.
ReferencedPreviousWaveform | 0x00081148 | Referenced Previous Waveform.
ReferencedPrintJobSequence | 0x21200070 | Referenced Print Job Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedPrintJobSequencePullStoredPrint | 0x21000500 | Referenced Print Job Sequence (Pull Stored Print). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedProcedureStepSequence | 0x00400330 | Referenced Procedure Step Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedRangeModulatorNumber | 0x300C0104 | Referenced Range Modulator Number.
ReferencedRangeShifterNumber | 0x300C0100 | Referenced Range Shifter Number.
ReferencedRawDataSequence | 0x00089121 | Referenced Raw Data Sequence.
ReferencedRealWorldValueMappingInstance | 0x0008114B | Referenced Real World Value Mapping Instance Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedRealWorldValueMappingInstanceSequence | 0x0008114B | Referenced Real World Value Mapping Instance Sequence.
ReferencedReferenceImageNumber | 0x300C0007 | Referenced Reference Image Number.
ReferencedReferenceImageSequence | 0x300C0042 | Referenced Reference Image Sequence.
ReferencedRefractiveMeasurementsSequence | 0x00460145 | Referenced Refractive Measurements Sequence.
ReferencedRelatedGeneralSOPClassUIDinFile | 0x0004151A | Referenced Related General SOP Class UID in File.
ReferencedRequestSequence | 0x0040A370 | Referenced Request Sequence.
ReferencedResultsSequence | 0x00081100 | Referenced Results Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedRoiNumber | 0x30060084 | Referenced ROI Number.
ReferencedRtPlanSequence | 0x300C0002 | Referenced RT Plan Sequence.
ReferencedSampleOffsets | 0x0040A132 | Referenced Sample Positions. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedSamplePositions | 0x0040A132 | Referenced Sample Positions.
ReferencedSegmentNumber | 0x0062000B | Referenced Segment Number.
ReferencedSeriesSequence | 0x00081115 | Referenced Series Sequence.
ReferencedSetupImageSequence | 0x300A0401 | Referenced Setup Image Sequence.
ReferencedSimultaneousWaveforms | 0x0008114A | Referenced Instance Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferencedSOPClassUID | 0x00081150 | Referenced SOP Class UID.
ReferencedSOPClassUIDInFile | 0x00041510 | Referenced SOP Class UID in File.
ReferencedSOPInstanceMACSequence | 0x04000403 | Referenced SOP Instance MAC Sequence.
ReferencedSOPInstanceUID | 0x00081155 | Referenced SOP Instance UID.
ReferencedSOPInstanceUIDInFile | 0x00041511 | Referenced SOP Instance UID in File.
ReferencedSOPSequence | 0x00081199 | Referenced SOP Sequence.
ReferencedSourceApplicatorNumber | 0x30080142 | Referenced Source Applicator Number.
ReferencedSourceNumber | 0x300C000E | Referenced Source Number.
ReferencedSpatialRegistrationSequence | 0x00700404 | Referenced Spatial Registration Sequence.
ReferencedStartControlPointIndex | 0x300C00F4 | Referenced Start Control Point Index.
ReferencedStereometricInstanceSequence | 0x00081134 | Referenced Stereometric Instance Sequence.
ReferencedStopControlPointIndex | 0x300C00F6 | Referenced Stop Control Point Index.
ReferencedStorageMediaSequence | 0x2200000D | Referenced Storage Media Sequence.
ReferencedStoredPrintSequence | 0x20000510 | Referenced Stored Print Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedStructureSetSequence | 0x300C0060 | Referenced Structure Set Sequence.
ReferencedStudySequence | 0x00081110 | Referenced Study Sequence.
ReferencedSubsequentWaveform | 0x0008114C | Referenced Subsequent Waveform. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedSurfaceNumber | 0x0066002C | Referenced Surface Number.
ReferencedSurfaceSequence | 0x0066002B | Referenced Surface Sequence.
ReferencedTimeOffsets | 0x0040A138 | Referenced Time Offsets.
ReferencedToleranceTableNumber | 0x300C00A0 | Referenced Tolerance Table Number.
ReferencedTransferSyntaxUIDInFile | 0x00041512 | Referenced Transfer Syntax UID in File.
ReferencedTreatmentRecordSequence | 0x30080030 | Referenced Treatment Record Sequence.
ReferencedTypeofData | 0x0040A0A0 | Referenced Type of Data.
ReferencedVerificationImageSequence | 0x300C0040 | Referenced Verification Image Sequence.
ReferencedVisitSequence | 0x00081125 | Referenced Visit Sequence.
ReferencedVOILUTBoxSequence | 0x20200140 | Referenced VOI LUT Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferencedWaveformChannels | 0x0040A0B0 | Referenced Waveform Channels.
ReferencedWaveformSequence | 0x0008113A | Referenced Waveform Sequence.
ReferencedWedgeNumber | 0x300C00C0 | Referenced Wedge Number.
ReferenceImageNumber | 0x300A00C8 | Reference Image Number.
ReferencePixelPhysicalValueX | 0x00186028 | Reference Pixel Physical Value X.
ReferencePixelPhysicalValueY | 0x0018602A | Reference Pixel Physical Value Y.
ReferencePixelX0 | 0x00186020 | Reference Pixel X0.
ReferencePixelY0 | 0x00186022 | Reference Pixel Y0.
ReferencetoRecordedSound | 0x40080103 | Reference to Recorded Sound. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReferringPhysicianAddress | 0x00080092 | Referring Physician's Address.
ReferringPhysicianIdentificationSequence | 0x00080096 | Referring Physician Identification Sequence.
ReferringPhysicianIDSequence | 0x00080096 | Referring Physician Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferringPhysicianName | 0x00080090 | Referring Physician's Name.
ReferringPhysiciansAddress | 0x00080092 | Referring Physician's Address. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferringPhysiciansName | 0x00080090 | Referring Physician's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferringPhysiciansTelephoneNumbers | 0x00080094 | Referring Physician's Telephone Numbers. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReferringPhysicianTelephoneNumbers | 0x00080094 | Referring Physician's Telephone Numbers.
RefGenScheduledProcStepSequence | 0x00404016 | Referenced General Purpose Scheduled Procedure Step Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefGrayscalePresStateSequence | 0x00089237 | Referenced Grayscale Presentation State Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefImgEvidenceSequence | 0x00089092 | Referenced Image Evidence Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReflectedAmbientLight | 0x20100160 | Reflected Ambient Light.
RefMeasuredDoseRefNumber | 0x30080082 | Referenced Measured Dose Reference Number. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefMeasuredDoseRefSequence | 0x30080080 | Referenced Measured Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ReformattingInterval | 0x00720514 | Reformatting Interval.
ReformattingOperationInitialViewDirection | 0x00720516 | Reformatting Operation Initial View Direction.
ReformattingOperationType | 0x00720510 | Reformatting Operation Type.
ReformattingThickness | 0x00720512 | Reformatting Thickness.
RefractiveErrorBeforeRefractiveSurgeryCodeSequence | 0x00221103 | Refractive Error Before Refractive Surgery Code Sequence.
RefractiveIndexApplied | 0x0052003A | Refractive Index Applied.
RefractiveParametersUsedOnPatientSequence | 0x00240112 | Refractive Parameters Used on Patient Sequence.
RefractiveProcedureOccurred | 0x00221039 | Refractive Procedure Occurred.
RefractiveStateSequence | 0x0022001B | Refractive State Sequence.
RefractiveSurgeryTypeCodeSequence | 0x00221040 | Refractive Surgery Type Code Sequence.
RefRawDataSequence | 0x00089121 | Referenced Raw Data Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefStandaloneSOPInstSequence | 0x00400220 | Referenced Non-Image Composite SOP Instance Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RefTreatmentRecSequence | 0x30080030 | Referenced Treatment Record Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RegionDataType | 0x00186014 | Region Data Type.
RegionFlags | 0x00186016 | Region Flags.
RegionLocationMaxX1 | 0x0018601C | Region Location Max X1.
RegionLocationMaxY1 | 0x0018601E | Region Location Max Y1.
RegionLocationMinX0 | 0x00186018 | Region Location Min X0.
RegionLocationMinY0 | 0x0018601A | Region Location Min Y0.
RegionOfResidence | 0x00102152 | Region of Residence.
RegionPixelShiftSequence | 0x00289502 | Region Pixel Shift Sequence.
RegionSpatialFormat | 0x00186012 | Region Spatial Format.
RegistrationSequence | 0x00700308 | Registration Sequence.
RegistrationTypeCodeSequence | 0x0070030D | Registration Type Code Sequence.
RelatedFrameOfReferenceUID | 0x300600C2 | Related Frame of Reference UID.
RelatedGeneral | 0x0008001A | Related General SOP Class UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
RelatedGeneralSOPClassUID | 0x0008001A | Related General SOP Class UID.
RelatedProcedureStepSequence | 0x00741220 | Related Procedure Step Sequence.
RelatedReferenceRTImageSequence | 0x00741040 | Related Reference RT Image Sequence.
RelatedRtRoiObservationSequence | 0x300600A0 | Related RT ROI Observations Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RelatedRtRoiObservationsSequence | 0x300600A0 | Related RT ROI Observations Sequence.
RelatedSeriesSequence | 0x00081250 | Related Series Sequence.
RelationshipSequenceTrial | 0x0040A731 | Relationship Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RelationshipType | 0x0040A010 | Relationship Type.
RelationshipTypeCodeSequence | 0x0040A732 | Relationship Type Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RelationshipTypeCodeSequenceTrial | 0x0040A732 | Relationship Type Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RelativeImagePositionCodeSequence | 0x0022001D | Relative Image Position Code Sequence.
RelativeOpacity | 0x00700403 | Relative Opacity.
RelativeTime | 0x00720038 | Relative Time.
RelativeTimeUnits | 0x0072003A | Relative Time Units.
RelativeXrayExposure | 0x00181405 | Relative X-Ray Exposure. This tag name has been deprecated, use tag with the same value defined in the previous line.
RelativeXRayExposure | 0x00181405 | Relative X-Ray Exposure.
RelevantInformationSequence | 0x00404022 | Relevant Information Sequence.
RenderingType3D | 0x00720520 | 3D Rendering Type. This tag name has been deprecated, use tag with the same value defined in the previous line.
RepeatFractionCycleLength | 0x300A007A | Repeat Fraction Cycle Length.
RepeatInterval | 0x00280068 | Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RepetitionTime | 0x00180080 | Repetition Time.
ReplacedImplantAssemblyTemplateSequence | 0x00760008 | Replaced Implant Assembly Template Sequence.
ReplacedImplantTemplateGroupSequence | 0x00780026 | Replaced Implant Template Group Sequence.
ReplacedImplantTemplateSequence | 0x00686222 | Replaced Implant Template Sequence.
ReplacedProcedureStepSequence | 0x00741224 | Replaced Procedure Step Sequence.
ReportDetailSequenceTrial | 0x0040A380 | Report Detail Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReportedValuesOrigin | 0x3002000A | Reported Values Origin.
ReportingPriority | 0x00401009 | Reporting Priority.
ReportNumber | 0x002000AA | Report Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReportProductionStatusTrial | 0x400800FF | Report Production Status (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReportStatusCommentTrial | 0x0040A33A | Report Status Comment (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ReportStatusIDTrial | 0x0040A125 | Report Status ID (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RepositoryUniqueID | 0x0040E030 | Repository Unique ID.
RepresentativeFrameNumber | 0x00286010 | Representative Frame Number.
ReprojectionMethod | 0x00541004 | Reprojection Method.
RequestAttributesSequence | 0x00400275 | Request Attributes Sequence.
RequestedContrastAgent | 0x00321070 | Requested Contrast Agent.
RequestedDecimateCropBehavior | 0x20200040 | Requested Decimate/Crop Behavior.
RequestedImageSize | 0x20200030 | Requested Image Size.
RequestedImageSizeFlag | 0x202000A0 | Requested Image Size Flag.
RequestedMediaApplicationProfile | 0x2200000C | Requested Media Application Profile.
RequestedProcedureCodeSequence | 0x00321064 | Requested Procedure Code Sequence.
RequestedProcedureComment | 0x00401400 | Requested Procedure Comments. This tag name has been deprecated, use tag with the same value defined in the previous line.
RequestedProcedureComments | 0x00401400 | Requested Procedure Comments.
RequestedProcedureDescription | 0x00321060 | Requested Procedure Description.
RequestedProcedureDescriptionTrial | 0x00401060 | Requested Procedure Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RequestedProcedureID | 0x00401001 | Requested Procedure ID.
RequestedProcedureLocation | 0x00401005 | Requested Procedure Location.
RequestedProcedurePriority | 0x00401003 | Requested Procedure Priority.
RequestedProcedureReason | 0x00401002 | Reason for the Requested Procedure. This tag name has been deprecated, use tag with the same value defined in the previous line.
RequestedResolutionID | 0x20200050 | Requested Resolution ID.
RequestedSOPClassUID | 0x00000003 | Requested SOP Class UID.
RequestedSOPInstanceUID | 0x00001001 | Requested SOP Instance UID.
RequestedSubsequentWorkitemCodeSequence | 0x00404031 | Requested Subsequent Workitem Code Sequence.
RequestedSubsWorkitemCodeSequence | 0x00404031 | Requested Subsequent Workitem Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RequestingAE | 0x00741236 | Requesting AE.
RequestingPhysician | 0x00321032 | Requesting Physician.
RequestingPhysicianIdentificationSequence | 0x00321031 | Requesting Physician Identification Sequence.
RequestingPhysicianIDSequence | 0x00321031 | Requesting Physician Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RequestingService | 0x00321033 | Requesting Service.
RequestingServiceCodeSequence | 0x00321034 | Requesting Service Code Sequence.
RequestPriority | 0x22000020 | Request Priority.
RescaleIntercept | 0x00281052 | Rescale Intercept.
RescaleSlope | 0x00281053 | Rescale Slope.
RescaleType | 0x00281054 | Rescale Type.
ResidualSyringeCounts | 0x00540017 | Residual Syringe Counts.
ResolutionIDRequested | 0x20200050 | Requested Resolution ID. This tag name has been deprecated, use tag with the same value defined in the previous line.
ResonantNucleus | 0x00189100 | Resonant Nucleus.
RespiratoryCyclePosition | 0x00189214 | Respiratory Cycle Position.
RespiratoryIntervalTime | 0x00209254 | Respiratory Interval Time.
RespiratoryMotionCompensationTechnique | 0x00189170 | Respiratory Motion Compensation Technique.
RespiratoryMotionCompensationTechniqueDescription | 0x00189185 | Respiratory Motion Compensation Technique Description.
RespiratoryMotionCompTechnique | 0x00189170 | Respiratory Motion Compensation Technique. This tag name has been deprecated, use tag with the same value defined in the previous line.
RespiratorySignalSource | 0x00189171 | Respiratory Signal Source.
RespiratorySignalSourceID | 0x00189186 | Respiratory Signal Source ID.
RespiratorySynchronizationSequence | 0x00209253 | Respiratory Synchronization Sequence.
RespiratoryTriggerDelayThreshold | 0x00209256 | Respiratory Trigger Delay Threshold.
RespiratoryTriggerDelayTime | 0x00209255 | Nominal Respiratory Trigger Delay Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
RespiratoryTriggerSequence | 0x00209253 | Respiratory Synchronization Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RespiratoryTriggerType | 0x00209250 | Respiratory Trigger Type.
ResponseSequenceNumber | 0x00000860 | Response Sequence Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ResponsibleOrganization | 0x00102299 | Responsible Organization.
ResponsiblePerson | 0x00102297 | Responsible Person.
ResponsiblePersonRole | 0x00102298 | Responsible Person Role.
ResultingGeneralPurposePerformedProcedureStepsSequence | 0x00404015 | Resulting General Purpose Performed Procedure Steps Sequence.
ResultingGenPerformedProcStepSequence | 0x00404015 | Resulting General Purpose Performed Procedure Steps Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ResultsComments | 0x40084000 | Results Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ResultsDistributionListSequence | 0x40080118 | Results Distribution List Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ResultsID | 0x40080040 | Results ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ResultsIDIssuer | 0x40080042 | Results ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ResultsNormalsSequence | 0x00240064 | Results Normals Sequence.
RET | 0x00189445 | RET. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RetestSensitivityValue | 0x00240096 | Retest Sensitivity Value.
RetestStimulusSeen | 0x00240095 | Retest Stimulus Seen.
RetrieveAETitle | 0x00080054 | Retrieve AE Title.
RetrieveLocationUID | 0x0040E011 | Retrieve Location UID.
RetrieveURI | 0x0040E010 | Retrieve URI.
ReviewDate | 0x300E0004 | Review Date.
ReviewerName | 0x300E0008 | Reviewer Name.
ReviewTime | 0x300E0005 | Review Time.
RevolutionTime | 0x00189305 | Revolution Time.
RFEchoTrainLength | 0x00189240 | RF Echo Train Length.
RGBLUTTransferFunction | 0x0028140F | RGB LUT Transfer Function.
RightImageSequence | 0x00220022 | Right Image Sequence.
RightLensSequence | 0x00460014 | Right Lens Sequence.
RoiArea | 0x60FF1301 | The ROI Area.
RoiContourSequence | 0x30060039 | ROI Contour Sequence.
RoiDescription | 0x30060028 | ROI Description.
RoiDisplayColor | 0x3006002A | ROI Display Color.
ROIElementalCompositionAtomicMassFraction | 0x300600B8 | ROI Elemental Composition Atomic Mass Fraction.
ROIElementalCompositionAtomicNumber | 0x300600B7 | ROI Elemental Composition Atomic Number.
ROIElementalCompositionSequence | 0x300600B6 | ROI Elemental Composition Sequence.
RoiGenerationAlgorithm | 0x30060036 | ROI Generation Algorithm.
RoiGenerationDescription | 0x30060038 | ROI Generation Description.
RoiInterpreter | 0x300600A6 | ROI Interpreter.
RoiMean | 0x60FF1302 | The ROI Mean.
RoiName | 0x30060026 | ROI (Region of Interest) Name.
RoiNumber | 0x30060022 | ROI Number.
RoiObservationDescription | 0x30060088 | ROI Observation Description.
RoiObservationLabel | 0x30060085 | ROI Observation Label.
ROIPhysicalPropertiesSequence | 0x300600B0 | ROI Physical Properties Sequence.
RoiPhysicalProperty | 0x300600B2 | ROI Physical Property.
RoiPhysicalPropertySequence | 0x300600B0 | ROI Physical Properties Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RoiPhysicalPropertyValue | 0x300600B4 | ROI Physical Property Value.
RoiStandardDeviation | 0x60FF1303 | ROI Standard Deviation.
RoiVolume | 0x3006002C | ROI Volume.
RootDirectoryEntitysFirstDirectoryRecordOffset | 0x00041200 | Offset of the First Directory Record of the Root Directory Entity. This tag name has been deprecated, use tag with the same value defined in the previous line.
RootDirectoryEntitysLastDirectoryRecordOffset | 0x00041202 | Offset of the Last Directory Record of the Root Directory Entity. This tag name has been deprecated, use tag with the same value defined in the previous line.
RotationAngle | 0x00700230 | Rotation Angle.
RotationDirection | 0x00181140 | Rotation Direction.
RotationInformationSequence | 0x00540052 | Rotation Information Sequence.
RotationInfoSequence | 0x00540052 | Rotation Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RotationOffset | 0x00181146 | Rotation Offset.
RotationOfScannedFilm | 0x00182030 | Rotation of Scanned Film.
RotationPoint | 0x00700273 | Rotation Point.
RotationVector | 0x00540050 | Rotation Vector.
RouteID | 0x40101054 | Route ID.
RouteIDAssigningAuthority | 0x40101055 | Route ID Assigning Authority.
RouteOfAdmissions | 0x00380016 | Route of Admissions.
RouteSegmentEndLocationID | 0x4010101F | Route Segment End Location ID.
RouteSegmentEndTime | 0x40101026 | Route Segment End Time.
RouteSegmentID | 0x40101007 | Route Segment ID.
RouteSegmentLocationIDType | 0x40101020 | Route Segment Location ID Type.
RouteSegmentSequence | 0x4010100A | Route Segment Sequence.
RouteSegmentStartLocationID | 0x4010101E | Route Segment Start Location ID.
RouteSegmentStartTime | 0x40101025 | Route Segment Start Time.
RowOverlap | 0x00280093 | Row Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RowPositionInTotalImagePixelMatrix | 0x0048021E | Row Position In Total Image Pixel Matrix.
Rows | 0x00280010 | Rows. Height of the DICOM image.
RowsForNthOrderCoefficients | 0x002804F0 | Rows For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RRIntervalTimeMeasured | 0x00209251 | R-R Interval Time Nominal. This tag name has been deprecated, use tag with the same value defined in the previous line.
RRIntervalTimeNominal | 0x00209251 | R-R Interval Time Nominal.
RrIntervalVector | 0x00540060 | R-R Interval Vector.
RtBeamLimitingDeviceType | 0x300A00B8 | RT Beam Limiting Device Type.
RtDoseRoiSequence | 0x30040010 | RT Dose ROI Sequence.
RtImageDescription | 0x30020004 | RT Image Description.
RtImageLabel | 0x30020002 | RT Image Label.
RtImageName | 0x30020003 | RT Image Name.
RtImageOrientation | 0x30020010 | RT Image Orientation.
RtImagePlane | 0x3002000C | RT Image Plane.
RtImagePosition | 0x30020012 | RT Image Position.
RtImageSid | 0x30020026 | RT Image SID.
RtPlanDate | 0x300A0006 | RT Plan Date.
RtPlanDescription | 0x300A0004 | RT Plan Description.
RtPlanGeometry | 0x300A000C | RT Plan Geometry.
RtPlanLabel | 0x300A0002 | RT Plan Label.
RtPlanName | 0x300A0003 | RT Plan Name.
RtPlanRelationship | 0x300A0055 | RT Plan Relationship.
RtPlanTime | 0x300A0007 | RT Plan Time.
RtReferencedSeriesSequence | 0x30060014 | RT Referenced Series Sequence.
RtReferencedStudySequence | 0x30060012 | RT Referenced Study Sequence.
RtRelatedRoiSequence | 0x30060030 | RT Related ROI Sequence.
RtRoiIdentificationCodeSequence | 0x30060086 | RT ROI Identification Code Sequence.
RtRoiIndentificationCodeSequence | 0x30060086 | RT ROI Identification Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RtRoiInterpretedType | 0x300600A4 | RT ROI Interpreted Type.
RtRoiObservationSequence | 0x30060080 | RT ROI Observations Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
RtRoiObservationsSequence | 0x30060080 | RT ROI Observations Sequence.
RtRoiRelationship | 0x30060033 | RT ROI Relationship.
RunLengthTriplet | 0x1000FFF1 | Run Length Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
RWavePointer | 0x00286040 | R Wave Pointer.
RWavePoints | 0x00286040 | R Wave Pointer. This tag name has been deprecated, use tag with the same value defined in the previous line.
RWaveTimeVector | 0x00186060 | R Wave Time Vector.
SafePositionExitDate | 0x30080162 | Safe Position Exit Date.
SafePositionExitTime | 0x30080164 | Safe Position Exit Time.
SafePositionReturnDate | 0x30080166 | Safe Position Return Date.
SafePositionReturnTime | 0x30080168 | Safe Position Return Time.
SampleRate | 0x50FF2008 | Sample Rate. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SamplesPerPixel | 0x00280002 | Samples per Pixel.
SamplesperPixelUsed | 0x00280003 | Samples per Pixel Used.
SamplingFrequency | 0x003A001A | Sampling Frequency.
Sar | 0x00181316 | SAR (specific absorption rate).
SaturationRecovery | 0x00189024 | Saturation Recovery.
ScanArc | 0x00181143 | Scan Arc value.
ScanLength | 0x00181302 | Scan Length.
ScanMode | 0x300A0308 | Scan Mode.
ScanningSequence | 0x00180020 | Scanning Sequence.
ScanningSpotSize | 0x300A0398 | Scanning Spot Size.
ScanOptions | 0x00180022 | Scan Options.
ScanSpotMetersetsDelivered | 0x30080047 | Scan Spot Metersets Delivered.
ScanSpotMetersetWeights | 0x300A0396 | Scan Spot Meterset Weights.
ScanSpotPositionMap | 0x300A0394 | Scan Spot Position Map.
ScanSpotTuneID | 0x300A0390 | Scan Spot Tune ID.
ScanType | 0x40101048 | Scan Type.
ScanVelocity | 0x00181300 | Scan Velocity.
ScatterCorrected | 0x00189760 | Scatter Corrected.
ScatterCorrectionMethod | 0x00541105 | Scatter Correction Method.
ScatterFractionFactor | 0x00541323 | Scatter Fraction Factor.
ScheduledActionItemCodeSequence | 0x00400008 | Scheduled Protocol Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledAdmissionDate | 0x0038001A | Scheduled Admission Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledAdmissionTime | 0x0038001B | Scheduled Admission Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledDischargeDate | 0x0038001C | Scheduled Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledDischargeTime | 0x0038001D | Scheduled Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledHumanPerformerSequence | 0x00404034 | Scheduled Human Performers Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledHumanPerformersSequence | 0x00404034 | Scheduled Human Performers Sequence.
ScheduledPatientInstitutionResidence | 0x0038001E | Scheduled Patient Institution Residence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledPerformingPhysicianIdentificationSequence | 0x0040000B | Scheduled Performing Physician Identification Sequence.
ScheduledPerformingPhysicianIDSequence | 0x0040000B | Scheduled Performing Physician Identification Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledPerformingPhysicianName | 0x00400006 | Scheduled Performing Physician's Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledPerformingPhysiciansName | 0x00400006 | Scheduled Performing Physician's Name.
ScheduledProcedureComment | 0x00400400 | Comments on the Scheduled Procedure Step. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledProcedureStepDescription | 0x00400007 | Scheduled Procedure Step Description.
ScheduledProcedureStepEndDate | 0x00400004 | Scheduled Procedure Step End Date.
ScheduledProcedureStepEndTime | 0x00400005 | Scheduled Procedure Step End Time.
ScheduledProcedureStepID | 0x00400009 | Scheduled Procedure Step ID.
ScheduledProcedureStepLocation | 0x00400011 | Scheduled Procedure Step Location.
ScheduledProcedureStepModificationDateandTime | 0x00404010 | Scheduled Procedure Step Modification Date and Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledProcedureStepModificationDateTime | 0x00404010 | Scheduled Procedure Step Modification Date Time.
ScheduledProcedureStepPriority | 0x00741200 | Scheduled Procedure Step Priority.
ScheduledProcedureStepSequence | 0x00400100 | Scheduled Procedure Step Sequence.
ScheduledProcedureStepStartDate | 0x00400002 | Scheduled Procedure Step Start Date.
ScheduledProcedureStepStartDateAndTime | 0x00404005 | Scheduled Procedure Step Start DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledProcedureStepStartDateTime | 0x00404005 | Scheduled Procedure Step Start DateTime.
ScheduledProcedureStepStartDT | 0x00404005 | Scheduled Procedure Step Start DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledProcedureStepStartTime | 0x00400003 | Scheduled Procedure Step Start Time.
ScheduledProcedureStepStatus | 0x00400020 | Scheduled Procedure Step Status.
ScheduledProcessingAppCodeSequence | 0x00404004 | Scheduled Processing Applications Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledProcessingApplicationsCodeSequence | 0x00404004 | Scheduled Processing Applications Code Sequence.
ScheduledProcessingParametersSequence | 0x00741210 | Scheduled Processing Parameters Sequence.
ScheduledProtocolCodeSequence | 0x00400008 | Scheduled Protocol Code Sequence.
ScheduledSpecimenSequence | 0x00400500 | Scheduled Specimen Sequence.
ScheduledStationAeTitle | 0x00400001 | Scheduled Station AE Title.
ScheduledStationClassCodeSequence | 0x00404026 | Scheduled Station Class Code Sequence.
ScheduledStationGeographicLocationCodeSequence | 0x00404027 | Scheduled Station Geographic Location Code Sequence.
ScheduledStationGeoLocationCode | 0x00404027 | Scheduled Station Geographic Location Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ScheduledStationName | 0x00400010 | Scheduled Station Name.
ScheduledStationNameCodeSequence | 0x00404025 | Scheduled Station Name Code Sequence.
ScheduledStepAttributesSequence | 0x00400270 | Scheduled Step Attributes Sequence.
ScheduledStudyLocation | 0x00321020 | Scheduled Study Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledStudyLocationAeTitles | 0x00321021 | Scheduled Study Location AE Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledStudyStartDate | 0x00321000 | Scheduled Study Start Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledStudyStartTime | 0x00321001 | Scheduled Study Start Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledStudyStopDate | 0x00321010 | Scheduled Study Stop Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledStudyStopTime | 0x00321011 | Scheduled Study Stop Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ScheduledWorkitemCodeSequence | 0x00404018 | Scheduled Workitem Code Sequence.
SCPStatus | 0x00741242 | SCP Status.
ScreeningBaselineMeasured | 0x00240120 | Screening Baseline Measured.
ScreeningBaselineMeasuredSequence | 0x00240122 | Screening Baseline Measured Sequence.
ScreeningBaselineType | 0x00240124 | Screening Baseline Type.
ScreeningBaselineValue | 0x00240126 | Screening Baseline Value.
ScreeningTestModeCodeSequence | 0x00240016 | Screening Test Mode Code Sequence.
ScreenMinimumColorBitDepth | 0x0072010C | Screen Minimum Color Bit Depth.
ScreenMinimumGrayscaleBitDepth | 0x0072010A | Screen Minimum Grayscale Bit Depth.
SeamLineIndex | 0x00520036 | Seam Line Index.
SeamLineLocation | 0x00520033 | Seam Line Location.
SecondaryCaptureDeviceID | 0x00181010 | Secondary Capture Device ID.
SecondaryCaptureDeviceManufacturer | 0x00181016 | Secondary Capture Device Manufacturer.
SecondaryCaptureDeviceManufacturerModelName | 0x00181018 | Secondary Capture Device Manufacturer's Model Name.
SecondaryCaptureDeviceManufacturers | 0x00181016 | Secondary Capture Device Manufacturers. This tag name has been deprecated, use tag with the same value defined in the previous line.
SecondaryCaptureDeviceManufacturersModelName | 0x00181018 | Secondary Capture Device Manufacturer's Model Name. This tag name has been deprecated, use tag with the same value defined in the previous line.
SecondaryCaptureDeviceSoftwareVersions | 0x00181019 | Secondary Capture Device Software Version(s).
SecondaryCountsAccumulated | 0x00541311 | Secondary Counts Accumulated.
SecondaryCountsType | 0x00541220 | Secondary Counts Type.
SecondaryPositionerIncrement | 0x00189515 | Secondary Positioner Increment.
SecondaryPositionerScanArc | 0x00189509 | Secondary Positioner Scan Arc.
SecondaryPositionerScanStartAngle | 0x00189511 | Secondary Positioner Scan Start Angle.
SegmentAlgorithmName | 0x00620009 | Segment Algorithm Name.
SegmentAlgorithmType | 0x00620008 | Segment Algorithm Type.
SegmentationFractionalType | 0x00620010 | Segmentation Fractional Type.
SegmentationType | 0x00620001 | Segmentation Type.
SegmentDescription | 0x00620006 | Segment Description.
SegmentedBlueLutData | 0x00281223 | Segmented Blue Palette Color Lookup Table Data. This tag name has been deprecated, use tag with the same value defined in the previous line.
SegmentedBluePaletteColorLookupTableData | 0x00281223 | Segmented Blue Palette Color Lookup Table Data.
SegmentedGreenLutData | 0x00281222 | Segmented Green Palette Color Lookup Table Data. This tag name has been deprecated, use tag with the same value defined in the previous line.
SegmentedGreenPaletteColorLookupTableData | 0x00281222 | Segmented Green Palette Color Lookup Table Data.
SegmentedKspaceTraversal | 0x00189033 | Segmented k-Space Traversal.
SegmentedPropertyCategoryCodeSequence | 0x00620003 | Segmented Property Category Code Sequence.
SegmentedPropertyTypeCodeSequence | 0x0062000F | Segmented Property Type Code Sequence.
SegmentedRedLutData | 0x00281221 | Segmented Red Palette Color Lookup Table Data.This tag name has been deprecated, use tag with the same value defined in the previous line.
SegmentedRedPaletteColorLookupTableData | 0x00281221 | Segmented Red Palette Color Lookup Table Data.
SegmentIdentificationSequence | 0x0062000A | Segment Identification Sequence.
SegmentLabel | 0x00620005 | Segment Label.
SegmentNumber | 0x00620004 | Segment Number.
SegmentSequence | 0x00620002 | Segment Sequence.
SegmentSurfaceGenerationAlgorithmIdentificationSequence | 0x0066002D | Segment Surface Generation Algorithm Identification Sequence.
SegmentSurfaceSourceInstanceSequence | 0x0066002E | Segment Surface Source Instance Sequence.
SelectedSegmentalOphthalmicAxialLengthSequence | 0x00221257 | Selected Segmental Ophthalmic Axial Length Sequence.
SelectedTotalOphthalmicAxialLengthSequence | 0x00221260 | Selected Total Ophthalmic Axial Length Sequence.
SelectorAttribute | 0x00720026 | Selector Attribute.
SelectorAttributePrivateCreator | 0x00720056 | Selector Attribute Private Creator.
SelectorAttributeVR | 0x00720050 | Selector Attribute VR.
SelectorATValue | 0x00720060 | Selector AT Value.
SelectorCodeSequenceValue | 0x00720080 | Selector Code Sequence Value.
SelectorCSValue | 0x00720062 | Selector CS Value.
SelectorDSValue | 0x00720072 | Selector DS Value.
SelectorFDValue | 0x00720074 | Selector FD Value.
SelectorFLValue | 0x00720076 | Selector FL Value.
SelectorISValue | 0x00720064 | Selector IS Value.
SelectorLOValue | 0x00720066 | Selector LO Value.
SelectorLTValue | 0x00720068 | Selector LT Value.
SelectorPNValue | 0x0072006A | Selector PN Value.
SelectorSequencePointer | 0x00720052 | Selector Sequence Pointer.
SelectorSequencePointerItems | 0x00741057 | Selector Sequence Pointer Items.
SelectorSequencePointerPrivateCreator | 0x00720054 | Selector Sequence Pointer Private Creator.
SelectorSHValue | 0x0072006C | Selector SH Value.
SelectorSLValue | 0x0072007C | Selector SL Value.
SelectorSSValue | 0x0072007E | Selector SS Value.
SelectorSTValue | 0x0072006E | Selector ST Value.
SelectorULValue | 0x00720078 | Selector UL Value.
SelectorUSValue | 0x0072007A | Selector US Value.
SelectorUTValue | 0x00720070 | Selector UT Value.
SelectorValueNumber | 0x00720028 | Selector Value Number.
SenderAeTitle | 0x00000200 | Initiator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Sensitivity | 0x00186000 | Sensitivity value.
SensitivityCalibrated | 0x00189767 | Sensitivity Calibrated.
SensitivityValue | 0x00240094 | Sensitivity Value.
SensorName | 0x00143022 | Sensor Name.
SensorTemperature | 0x00143028 | Sensor Temperature.
SequenceDelimitationItem | 0xFFFEE0DD | Sequence Delimitation Item.
SequenceName | 0x00180024 | Sequence Name.
SequenceOfCompressedData | 0x00280403 | Sequence of Compressed Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SequenceOfUltrasoundRegions | 0x00186011 | Sequence of Ultrasound Regions.
SequenceVariant | 0x00180021 | Sequence Variant.
SequencingIndicatorTrial | 0x0040A060 | Sequencing Indicator (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SeriesDate | 0x00080021 | Series Date.
SeriesDescription | 0x0008103E | Series Description.
SeriesDescriptionCodeSequence | 0x0008103F | Series Description Code Sequence.
SeriesInstanceUID | 0x0020000E | Series Instance UID.
SeriesInStudy | 0x00201000 | Series in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SeriesNumber | 0x00200011 | Series Number.
SeriesTime | 0x00080031 | Series Time.
SeriesType | 0x00541000 | Series Type.
ServiceEpisodeDescription | 0x00380062 | Service Episode Description.
ServiceEpisodeID | 0x00380060 | Service Episode ID.
SetupDeviceDescription | 0x300A01BA | Setup Device Description.
SetupDeviceLabel | 0x300A01B8 | Setup Device Label.
SetupDeviceParameter | 0x300A01BC | Setup Device Parameter.
SetupDeviceSequence | 0x300A01B4 | Setup Device Sequence.
SetupDeviceType | 0x300A01B6 | Setup Device Type.
SetupImageComment | 0x300A0402 | Setup Image Comment.
SetupReferenceDescription | 0x300A01D0 | Setup Reference Description.
SetupTechnique | 0x300A01B0 | Setup Technique.
SetupTechniqueDescription | 0x300A01B2 | Setup Technique Description.
ShadowColorCIELabValue | 0x00700247 | Shadow Color CIELab Value.
ShadowOffsetX | 0x00700245 | Shadow Offset X.
ShadowOffsetY | 0x00700246 | Shadow Offset Y.
ShadowOpacity | 0x00700258 | Shadow Opacity.
ShadowStyle | 0x00700244 | Shadow Style.
ShapeType | 0x00700306 | Shape Type.
SharedFunctionalGroupSequence | 0x52009229 | Shared Functional Groups Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
SharedFunctionalGroupsSequence | 0x52009229 | Shared Functional Groups Sequence.
ShieldingDeviceDescription | 0x300A01A6 | Shielding Device Description.
ShieldingDeviceLabel | 0x300A01A4 | Shielding Device Label.
ShieldingDevicePosition | 0x300A01A8 | Shielding Device Position.
ShieldingDeviceSequence | 0x300A01A0 | Shielding Device Sequence.
ShieldingDeviceType | 0x300A01A2 | Shielding Device Type.
ShiftTableSize | 0x1000FFF4 | Shift Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ShiftTableTriplet | 0x1000FFF5 | Shift Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ShortTermFluctuation | 0x00240075 | Short Term Fluctuation.
ShortTermFluctuationCalculated | 0x00240074 | Short Term Fluctuation Calculated.
ShortTermFluctuationProbability | 0x00240077 | Short Term Fluctuation Probability.
ShortTermFluctuationProbabilityCalculated | 0x00240076 | Short Term Fluctuation Probability Calculated.
ShowAcquisitionTechniquesFlag | 0x00720716 | Show Acquisition Techniques Flag.
ShowGraphicAnnotationFlag | 0x00720712 | Show Graphic Annotation Flag.
ShowGrayscaleInverted | 0x00720706 | Show Grayscale Inverted.
ShowImageTrueSizeFlag | 0x00720710 | Show Image True Size Flag.
ShowPatientDemographicsFlag | 0x00720714 | Show Patient Demographics Flag.
ShowTickLabel | 0x00700278 | Show Tick Label.
ShutterLeftVerticalEdge | 0x00181602 | Shutter Left Vertical Edge.
ShutterLowerHorizontalEdge | 0x00181608 | Shutter Lower Horizontal Edge.
ShutterOverlayGroup | 0x00181623 | Shutter Overlay Group.
ShutterPresentationColorCIELabValue | 0x00181624 | Shutter Presentation Color CIELab Value.
ShutterPresentationValue | 0x00181622 | Shutter Presentation Value.
ShutterRightVerticalEdge | 0x00181604 | Shutter Right Vertical Edge.
ShutterShape | 0x00181600 | Shutter Shape.
ShutterUpperHorizontalEdge | 0x00181606 | Shutter Upper Horizontal Edge.
SignalDomainColumns | 0x00289003 | Signal Domain Columns.
SignalDomainRows | 0x00289235 | Signal Domain Rows.
SignalToNoiseRatio | 0x00221155 | Signal to Noise Ratio.
Signature | 0x04000120 | The Signature.
SimpleFrameList | 0x00081161 | Simple Frame List.
SingleCollimationWidth | 0x00189306 | Single Collimation Width.
SkipBeats | 0x00181086 | Skip Beats.
SkipFrameRangeFlag | 0x00089460 | Skip Frame Range Flag.
SlabOrientation | 0x00189105 | Slab Orientation.
SlabThickness | 0x00189104 | Slab Thickness.
SliceLocation | 0x00201041 | Slice Location.
SliceLocationVector | 0x00182005 | Slice Location Vector.
SliceProgressionDirection | 0x00540500 | Slice Progression Direction.
SliceSensitivityFactor | 0x00541320 | Slice Sensitivity Factor.
SliceThickness | 0x00180050 | Slice Thickness.
SliceVector | 0x00540080 | Slice Vector.
SlideIdentifier | 0x004006FA | Slide Identifier. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SmallestImagePixelValue | 0x00280106 | Smallest Image Pixel Value.
SmallestImagePixelValueInPlane | 0x00280110 | Smallest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SmallestPixelValueInSeries | 0x00280108 | Smallest Pixel Value in Series.
SmallestValidPixelValue | 0x00280104 | Smallest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SmokingStatus | 0x001021A0 | Smoking Status.
SmoothingType | 0x20100080 | Smoothing Type.
SnoutID | 0x300A030F | Snout Identifier.
SnoutPosition | 0x300A030D | Snout Position.
SnoutPositionTolerance | 0x300A004B | Snout Position Tolerance.
SnoutSequence | 0x300A030C | Snout Sequence.
SoftcopyVOILUTSequence | 0x00283110 | Softcopy VOI LUT Sequence.
SoftTissueFocusThermalIndex | 0x00185028 | Soft Tissue-focus Thermal Index.
SoftTissueSurfaceThermalIndex | 0x00185029 | Soft Tissue-surface Thermal Index.
SoftTissueThermalIndex | 0x00185027 | Soft Tissue Thermal Index.
SoftwareVersions | 0x00181020 | Software Version(s).
SOPAuthorizationComment | 0x01000424 | SOP Authorization Comment.
SOPAuthorizationDateandTime | 0x01000420 | SOP Authorization DateTime. This tag name has been deprecated, use tag with the same value defined in the previous line.
SOPAuthorizationDateTime | 0x01000420 | SOP Authorization DateTime.
SOPClassesInStudy | 0x00080062 | SOP Classes In Study.
SOPClassesSupported | 0x0008115A | SOP Classes Supported.
SOPClassSupported | 0x0008115A | SOP Classes Supported. This tag name has been deprecated, use tag with the same value defined in the previous line.
SOPClassUID | 0x00080016 | SOP Class UID.
SOPInstanceStatus | 0x01000410 | SOP Instance Status.
SOPInstanceUID | 0x00080018 | SOP Instance UID.
SOPInstanceUIDOfConcatenationSource | 0x00200242 | SOP Instance UID of Concatenation Source.
SortbyCategory | 0x00720602 | Sort-by Category.
SortingDirection | 0x00720604 | Sorting Direction.
SortingOperationsSequence | 0x00720600 | Sorting Operations Sequence.
SoundPathLength | 0x0014405A | Sound Path Length.
SourceApplicationEntityTitle | 0x00020016 | Source Application Entity Title.
SourceApplicatorID | 0x300A0291 | Source Applicator ID.
SourceApplicatorLength | 0x300A0296 | Source Applicator Length.
SourceApplicatorManufacturer | 0x300A0298 | Source Applicator Manufacturer.
SourceApplicatorName | 0x300A0294 | Source Applicator Name.
SourceApplicatorNumber | 0x300A0290 | Source Applicator Number.
SourceApplicatorStepSize | 0x300A02A0 | Source Applicator Step Size.
SourceApplicatorType | 0x300A0292 | Source Applicator Type.
SourceApplicatorWallNominalThickness | 0x300A029C | Source Applicator Wall Nominal Thickness.
SourceApplicatorWallNominalTransmission | 0x300A029E | Source Applicator Wall Nominal Transmission.
SourceAxisDistance | 0x300A00B4 | Source-Axis Distance.
SourceEncapsulationNominalThickness | 0x300A0222 | Source Encapsulation Nominal Thickness.
SourceEncapsulationNominalTransmission | 0x300A0224 | Source Encapsulation Nominal Transmission.
SourceFrameOfReferenceUID | 0x00640003 | Source Frame of Reference UID.
SourceHangingProtocolSequence | 0x00720012 | Source Hanging Protocol Sequence.
SourceImageEvidenceSequence | 0x00089154 | Source Image Evidence Sequence.
SourceImageIDs | 0x00203100 | Source Image IDs. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SourceImageSequence | 0x00082112 | Source Image Sequence.
SourceInstanceSequence | 0x00420013 | Source Instance Sequence.
SourceIsotopeHalfLife | 0x300A0228 | Source Isotope Half Life.
SourceIsotopeName | 0x300A0226 | Source Isotope Name.
SourceManufacturer | 0x300A0216 | Source Manufacturer.
SourceMovementType | 0x300A0288 | Source Movement Type.
SourceNumber | 0x300A0212 | Source Number.
SourceOfAnteriorChamberDepthDataCodeSequence | 0x00221133 | Source of Anterior Chamber Depth Data Code Sequence.
SourceOfLensThicknessDataCodeSequence | 0x00221132 | Source of Lens Thickness Data Code Sequence.
SourceOfOphthalmicAxialLengthCodeSequence | 0x00221035 | Source of Ophthalmic Axial Length Code Sequence.
SourceOfPreviousValues | 0x04000564 | Source of Previous Values.
SourceOfRefractiveErrorDataCodeSequence | 0x00221135 | Source of Refractive Error Data Code Sequence.
SourceOrientation | 0x40101060 | Source Orientation.
SourcePosition | 0x40101061 | Source Position.
SourceSequence | 0x300A0210 | Source Sequence.
SourceSerialNumber | 0x30080105 | Source Serial Number.
SourceStrength | 0x300A022B | Source Strength.
SourceStrengthAirKermaRateReferenceDateDA1 | 0x300A022C | Source Strength Reference Date. This tag name has been deprecated, use tag with the same value defined in the previous line.
SourceStrengthAirKermaRateReferenceTimeTM1 | 0x300A022E | Source Strength Reference Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
SourceStrengthReferenceDate | 0x300A022C | Source Strength Reference Date.
SourceStrengthReferenceTime | 0x300A022E | Source Strength Reference Time.
SourceStrengthUnits | 0x300A0229 | Source Strength Units.
SourceToApplicatorMountingPositionDistance | 0x300A0436 | Source to Applicator Mounting Position Distance.
SourceToBeamLimitingDeviceDistance | 0x300A00BA | Source to Beam Limiting Device Distance.
SourceToBlockTrayDistance | 0x300A00F6 | Source to Block Tray Distance.
SourceToCompensatorDistance | 0x300A02E2 | Source to Compensator Distance.
SourceToCompensatorTrayDistance | 0x300A00E6 | Source to Compensator Tray Distance.
SourceToEntranceDistance | 0x00400306 | Distance Source to Entrance. This tag name has been deprecated, use tag with the same value defined in the previous line.
SourceToReferenceObjectDistance | 0x30020028 | Source to Reference Object Distance.
SourceToSurfaceDistance | 0x300A0130 | Source to Surface Distance.
SourceToWedgeTrayDistance | 0x300A00DA | Source to Wedge Tray Distance.
SourceType | 0x300A0214 | Source Type.
SourceWaveformSequence | 0x003A020A | Source Waveform Sequence.
SpacingBetweenSlices | 0x00180088 | Spacing Between Slices.
SpatialLocationsPreserved | 0x0028135A | Spatial Locations Preserved.
SpatialPresaturation | 0x00189027 | Spatial Pre-saturation.
SpatialResolution | 0x00181050 | Spatial Resolution.
SpecialNeeds | 0x00380050 | Special Needs.
SpecificAbsorptionRateDefinition | 0x00189179 | Specific Absorption Rate Definition.
SpecificAbsorptionRateSequence | 0x00189239 | Specific Absorption Rate Sequence.
SpecificAbsorptionRateValue | 0x00189181 | Specific Absorption Rate Value.
SpecificCharacterSet | 0x00080005 | Specific Character Set.
SpecificCharacterSetOfFilesetDescriptorFile | 0x00041142 | Specific Character Set of File-set Descriptor File.
SpecifiedChannelTotalTime | 0x30080132 | Specified Channel Total Time.
SpecifiedMeterset | 0x30080042 | Specified Meterset.
SpecifiedNumberofPulses | 0x30080136 | Specified Number of Pulses.
SpecifiedPrimaryMeterset | 0x30080032 | Specified Primary Meterset.
SpecifiedPulseRepetitionInterval | 0x3008013A | Specified Pulse Repetition Interval.
SpecifiedSecondaryMeterset | 0x30080033 | Specified Secondary Meterset.
SpecifiedTreatmentTime | 0x3008003A | Specified Treatment Time.
SpecimenAccessionNumber | 0x0040050A | Specimen Accession Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SpecimenDescription | 0x00400553 | Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SpecimenDescriptionSequence | 0x00400560 | Specimen Description Sequence.
SpecimenDescriptionSequenceTrial | 0x00400552 | Specimen Description Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SpecimenDescriptionTrial | 0x00400553 | Specimen Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SpecimenDetailedDescription | 0x00400602 | Specimen Detailed Description.
SpecimenIdentifier | 0x00400551 | Specimen Identifier.
SpecimenLabelInImage | 0x00480010 | Specimen Label in Image.
SpecimenLocalizationContentItemSequence | 0x00400620 | Specimen Localization Content Item Sequence.
SpecimenPreparationSequence | 0x00400610 | Specimen Preparation Sequence.
SpecimenPreparationStepContentItemSequence | 0x00400612 | Specimen Preparation Step Content Item Sequence.
SpecimenReferenceSequence | 0x00480110 | Specimen Reference Sequence.
SpecimenSequence | 0x00400550 | Specimen Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SpecimenShortDescription | 0x00400600 | Specimen Short Description.
SpecimenTypeCodeSequence | 0x0040059A | Specimen Type Code Sequence.
SpecimenUID | 0x00400554 | Specimen UID.
SpectrallySelectedExcitation | 0x00189026 | Spectrally Selected Excitation.
SpectrallySelectedSuppression | 0x00189025 | Spectrally Selected Suppression.
SpectralWidth | 0x00189052 | Spectral Width.
SpectroscopyAcqDataColumns | 0x00189127 | Spectroscopy Acquisition Data Columns. This tag name has been deprecated, use tag with the same value defined in the previous line.
SpectroscopyAcqOutOfPlanePhaseStep | 0x00189159 | Spectroscopy Acquisition Out-of-plane Phase Steps. This tag name has been deprecated, use tag with the same value defined in the previous line.
SpectroscopyAcqPhaseColumns | 0x00189234 | Spectroscopy Acquisition Phase Columns. This tag name has been deprecated, use tag with the same value defined in the previous line.
SpectroscopyAcqPhaseRows | 0x00189095 | Spectroscopy Acquisition Phase Rows. This tag name has been deprecated, use tag with the same value defined in the previous line.
SpectroscopyAcquisitionDataColumns | 0x00189127 | Spectroscopy Acquisition Data Columns.
SpectroscopyAcquisitionOutOfPlanePhaseSteps | 0x00189159 | Spectroscopy Acquisition Out-of-plane Phase Steps.
SpectroscopyAcquisitionPhaseColumns | 0x00189234 | Spectroscopy Acquisition Phase Columns.
SpectroscopyAcquisitionPhaseRows | 0x00189095 | Spectroscopy Acquisition Phase Rows.
SpectroscopyData | 0x56000020 | Spectroscopy Data.
SpherePower | 0x00460146 | Sphere Power.
SphericalLensPower | 0x00220007 | Spherical Lens Power.
SpiralPitchFactor | 0x00189311 | Spiral Pitch Factor.
Spoiling | 0x00189016 | Spoiling value.
SrcImgEvidenceSequence | 0x00089154 | Source Image Evidence Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
StackID | 0x00209056 | Stack Identifier.
StageCodeSequence | 0x0040000A | Stage Code Sequence.
StageName | 0x00082120 | Stage Name.
StageNumber | 0x00082122 | Stage Number.
StartAcquisitionDateTime | 0x00189516 | Start Acquisition DateTime.
StartAngle | 0x00540200 | Start Angle.
StartAngleVector | 0x00540200 | Start Angle. This tag name has been deprecated, use tag with the same value defined in the previous line.
StartCardiacTriggerCountThreshold | 0x00189717 | Start Cardiac Trigger Count Threshold.
StartCumulativeMetersetWeight | 0x300C0008 | Start Cumulative Meterset Weight.
StartDensityThreshold | 0x00189715 | Start Density Threshold.
StartingRespiratoryAmplitude | 0x00209246 | Starting Respiratory Amplitude.
StartingRespiratoryPhase | 0x00209247 | Starting Respiratory Phase.
StartMeterset | 0x30080078 | Start Meterset.
StartRelativeDensityDifferenceThreshold | 0x00189716 | Start Relative Density Difference Threshold.
StartRespiratoryTriggerCountThreshold | 0x00189718 | Start Respiratory Trigger Count Threshold.
StartTrim | 0x00082142 | Start Trim.
StationName | 0x00081010 | Station Name.
Status | 0x00000900 | Operation Status.
SteadyStatePulseSequence | 0x00189017 | Steady State Pulse Sequence.
SteepKeratometricAxisSequence | 0x00460074 | Steep Keratometric Axis Sequence.
SteeringAngle | 0x00186036 | Steering Angle.
StereoBaselineAngle | 0x00220010 | Stereo Baseline Angle.
StereoBaselineDisplacement | 0x00220011 | Stereo Baseline Displacement.
StereoHorizontalPixelOffset | 0x00220012 | Stereo Horizontal Pixel Offset.
StereoPairsSequence | 0x00220020 | Stereo Pairs Sequence.
StereoRotation | 0x00220014 | Stereo Rotation.
StereoVerticalPixelOffset | 0x00220013 | Stereo Vertical Pixel Offset.
StimuliRetestingQuantity | 0x00240042 | Stimuli Retesting Quantity.
StimulusArea | 0x00240025 | Stimulus Area.
StimulusColorCodeSequence | 0x00240021 | Stimulus Color Code Sequence.
StimulusPresentationTime | 0x00240028 | Stimulus Presentation Time.
StimulusResults | 0x00240093 | Stimulus Results.
StopTrim | 0x00082143 | Stop Trim.
StorageMediaFilesetID | 0x00880130 | Storage Media File-set ID.
StorageMediaFilesetUID | 0x00880140 | Storage Media File-set UID.
StructuredDisplayBackgroundCIELabValue | 0x00720420 | Structured Display Background CIELab Value.
StructuredDisplayImageBoxSequence | 0x00720422 | Structured Display Image Box Sequence.
StructuredDisplayTextBoxSequence | 0x00720424 | Structured Display Text Box Sequence.
StructureSetDate | 0x30060008 | Structure Set Date.
StructureSetDescription | 0x30060006 | Structure Set Description.
StructureSetLabel | 0x30060002 | Structure Set Label.
StructureSetName | 0x30060004 | Structure Set Name.
StructureSetRoiSequence | 0x30060020 | Structure Set ROI Sequence.
StructureSetTime | 0x30060009 | Structure Set Time.
StudiesContainingOtherReferencedInstancesSequence | 0x00081200 | Studies Containing Other Referenced Instances Sequence.
StudyArrivalDate | 0x00321040 | Study Arrival Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyArrivalTime | 0x00321041 | Study Arrival Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyComments | 0x00324000 | Study Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyCompletionDate | 0x00321050 | Study Completion Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyCompletionTime | 0x00321051 | Study Completion Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyComponentStatusID | 0x00321055 | Study Component Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyDate | 0x00080020 | Study Date.
StudyDescription | 0x00081030 | Study Description.
StudyID | 0x00200010 | Study Identifier.
StudyIDIssuer | 0x00320012 | Study ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyInstanceUID | 0x0020000D | Study Instance UID.
StudyPriorityID | 0x0032000C | Study Priority ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyReadDate | 0x00320034 | Study Read Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyReadTime | 0x00320035 | Study Read Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyStatusID | 0x0032000A | Study Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyTime | 0x00080030 | Study Time.
StudyVerifiedDate | 0x00320032 | Study Verified Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
StudyVerifiedTime | 0x00320033 | Study Verified Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
SubjectiveRefractionLeftEyeSequence | 0x00460098 | Subjective Refraction Left Eye Sequence.
SubjectiveRefractionRightEyeSequence | 0x00460097 | Subjective Refraction Right Eye Sequence.
SubscriptionListStatus | 0x00741244 | Subscription List Status.
SubstanceAdministrationApproval | 0x00440002 | Substance Administration Approval.
SubstanceAdministrationDateTime | 0x00440010 | Substance Administration DateTime.
SubstanceAdministrationDeviceID | 0x00440012 | Substance Administration Device ID.
SubstanceAdministrationNotes | 0x00440011 | Substance Administration Notes.
SubstanceAdministrationParameterSequence | 0x00440019 | Substance Administration Parameter Sequence.
SubtractionItemID | 0x00289416 | Subtraction Item ID.
SupportedImageDisplayFormatsSequence | 0x200000A8 | Supported Image Display Formats Sequence.
SurfaceComments | 0x00660004 | Surface Comments.
SurfaceCount | 0x0066002A | Surface Count.
SurfaceEntryPoint | 0x300A012E | Surface Entry Point.
SurfaceMeshPrimitivesSequence | 0x00660013 | Surface Mesh Primitives Sequence.
SurfaceModelDescriptionSequence | 0x00686360 | Surface Model Description Sequence.
SurfaceModelLabel | 0x00686380 | Surface Model Label.
SurfaceModelScalingFactor | 0x00686390 | Surface Model Scaling Factor.
SurfaceNumber | 0x00660003 | Surface Number.
SurfacePointsNormalsSequence | 0x00660012 | Surface Points Normals Sequence.
SurfacePointsSequence | 0x00660011 | Surface Points Sequence.
SurfaceProcessing | 0x00660009 | Surface Processing.
SurfaceProcessingAlgorithmIdentificationSequence | 0x00660035 | Surface Processing Algorithm Identification Sequence.
SurfaceProcessingDescription | 0x0066000B | Surface Processing Description.
SurfaceProcessingRatio | 0x0066000A | Surface Processing Ratio.
SurfaceSequence | 0x00660002 | Surface Sequence.
SurgicalTechnique | 0x00760030 | Surgical Technique.
SUVType | 0x00541006 | SUV Type.
SyncFrameOfRefUID | 0x00200200 | Synchronization Frame of Reference UID. This tag name has been deprecated, use tag with the same value defined in the previous line.
SynchronizationChannel | 0x0018106C | Synchronization Channel.
SynchronizationFrameOfReferenceUID | 0x00200200 | Synchronization Frame of Reference UID.
SynchronizationTrigger | 0x0018106A | Synchronization Trigger.
SynchronizedImageBoxList | 0x00720432 | Synchronized Image Box List.
SynchronizedScrollingSequence | 0x00720210 | Synchronized Scrolling Sequence.
SyringeCounts | 0x00181045 | Syringe Counts.
T2Preparation | 0x00189021 | T2 Preparation.
TableAngle | 0x00181138 | Table Angle.
TableCradleTiltAngle | 0x00189471 | Table Cradle Tilt Angle.
TableFeedperRotation | 0x00189310 | Table Feed per Rotation.
TableFrameOfReferenceUID | 0x00209313 | Table Frame of Reference UID.
TableHeadTiltAngle | 0x00189470 | Table Head Tilt Angle.
TableHeight | 0x00181130 | Table Height.
TableHorizontalRotationAngle | 0x00189469 | Table Horizontal Rotation Angle.
TableLateralIncrement | 0x00181136 | Table Lateral Increment.
TableLongitudinalIncrement | 0x00181137 | Table Longitudinal Increment.
TableMotion | 0x00181134 | Table Motion.
TableOfParameterValues | 0x0018605A | Table of Parameter Values.
TableOfPixelValues | 0x00186058 | Table of Pixel Values.
TableOfXBreakPoints | 0x00186052 | Table of X Break Points.
TableOfYBreakPoints | 0x00186054 | Table of Y Break Points.
TablePosition | 0x00189327 | Table Position.
TablePositionSequence | 0x00189406 | Table Position Sequence.
TableSpeed | 0x00189309 | Table Speed.
TableTopEccentricAdjustedAngle | 0x0074102B | Table Top Eccentric Adjusted Angle.
TableTopEccentricAngle | 0x300A0125 | Table Top Eccentric Angle.
TableTopEccentricAngleTolerance | 0x300A004E | Table Top Eccentric Angle Tolerance.
TableTopEccentricAxisDistance | 0x300A0124 | Table Top Eccentric Axis Distance.
TableTopEccentricRotationDirection | 0x300A0126 | Table Top Eccentric Rotation Direction.
TableTopLateralAdjustedPosition | 0x00741028 | Table Top Lateral Adjusted Position.
TableTopLateralPosition | 0x300A012A | Table Top Lateral Position.
TableTopLateralPositionTolerance | 0x300A0053 | Table Top Lateral Position Tolerance.
TableTopLateralSetupDisplacement | 0x300A01D6 | Table Top Lateral Setup Displacement.
TableTopLogitudinalPositionTolerance | 0x300A0052 | Table Top Longitudinal Position Tolerance. This tag name has been deprecated, use tag with the same value defined in the previous line.
TableTopLogitudinalSetupDisplacement | 0x300A01D4 | Table Top Longitudinal Setup Displacement. This tag name has been deprecated, use tag with the same value defined in the previous line.
TableTopLongitudinalAdjustedPosition | 0x00741027 | Table Top Longitudinal Adjusted Position.
TableTopLongitudinalPosition | 0x300A0129 | Table Top Longitudinal Position.
TableTopLongitudinalPositionTolerance | 0x300A0052 | Table Top Longitudinal Position Tolerance.
TableTopLongitudinalSetupDisplacement | 0x300A01D4 | Table Top Longitudinal Setup Displacement.
TableTopPitchAdjustedAngle | 0x0074102C | Table Top Pitch Adjusted Angle.
TableTopPitchAngle | 0x300A0140 | Table Top Pitch Angle.
TableTopPitchAngleTolerance | 0x300A004F | Table Top Pitch Angle Tolerance.
TableTopPitchRotationDirection | 0x300A0142 | Table Top Pitch Rotation Direction.
TableTopRollAdjustedAngle | 0x0074102D | Table Top Roll Adjusted Angle.
TableTopRollAngle | 0x300A0144 | Table Top Roll Angle.
TableTopRollAngleTolerance | 0x300A0050 | Table Top Roll Angle Tolerance.
TableTopRollRotationDirection | 0x300A0146 | Table Top Roll Rotation Direction.
TableTopVerticalAdjustedPosition | 0x00741026 | Table Top Vertical Adjusted Position.
TableTopVerticalPosition | 0x300A0128 | Table Top Vertical Position.
TableTopVerticalPositionTolerance | 0x300A0051 | Table Top Vertical Position Tolerance.
TableTopVerticalSetupDisplacement | 0x300A01D2 | Table Top Vertical Setup Displacement.
TableTraverse | 0x00181131 | Table Traverse.
TableType | 0x0018113A | Table Type.
TableVerticalIncrement | 0x00181135 | Table Vertical Increment.
TableXPositiontoIsocenter | 0x00189466 | Table X Position to Isocenter.
TableYPositiontoIsocenter | 0x00189467 | Table Y Position to Isocenter.
TableZPositiontoIsocenter | 0x00189468 | Table Z Position to Isocenter.
TagAngleFirstAxis | 0x00189019 | Tag Angle First Axis.
TagAngleSecondAxis | 0x00189219 | Tag Angle Second Axis.
Tagging | 0x00189028 | Tagging value.
TaggingDelay | 0x00189184 | Tagging Delay.
TagSpacingFirstDimension | 0x00189030 | Tag Spacing First Dimension.
TagSpacingSecondDimension | 0x00189218 | Tag Spacing Second Dimension.
TagThickness | 0x00189035 | Tag Thickness.
TargetExposureIndex | 0x00181412 | Target Exposure Index.
TargetMaximumDose | 0x300A0027 | Target Maximum Dose.
TargetMinimumDose | 0x300A0025 | Target Minimum Dose.
TargetPrescriptionDose | 0x300A0026 | Target Prescription Dose.
TargetRefraction | 0x00221037 | Target Refraction.
TargetUnderdoseVolumeFraction | 0x300A0028 | Target Underdose Volume Fraction.
TDRType | 0x40101027 | TDR Type.
TelephoneNumber | 0x0040A354 | Telephone Number (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TelephoneNumberTrial | 0x0040A354 | Telephone Number (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemplateExtensionCreatorUID | 0x0040DB0D | Template Extension Creator UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemplateExtensionFlag | 0x0040DB0B | Template Extension Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemplateExtensionOrganizationUID | 0x0040DB0C | Template Extension Organization UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemplateIdentifier | 0x0040DB00 | Template Identifier.
TemplateLocalVersion | 0x0040DB07 | Template Local Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemplateName | 0x300A0244 | Template Name.
TemplateNumber | 0x300A0240 | Template Number.
TemplateType | 0x300A0242 | Template Type.
TemplateVersion | 0x0040DB06 | Template Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TemporalPositionIdentifier | 0x00200100 | Temporal Position Identifier.
TemporalPositionIndex | 0x00209128 | Temporal Position Index.
TemporalPositionSequence | 0x00209310 | Temporal Position Sequence.
TemporalPositionTimeOffset | 0x0020930D | Temporal Position Time Offset.
TemporalRangeType | 0x0040A130 | Temporal Range Type.
TemporalResolution | 0x00200110 | Temporal Resolution.
TerminalType | 0x00004010 | Terminal Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TerminationCardiacTriggerCountThreshold | 0x00189723 | Termination Cardiac Trigger Count Threshold.
TerminationCountsThreshold | 0x00189719 | Termination Counts Threshold.
TerminationDensityThreshold | 0x00189720 | Termination Density Threshold.
TerminationRelativeDensityThreshold | 0x00189721 | Termination Relative Density Threshold.
TerminationRespiratoryTriggerCountThreshold | 0x00189724 | Termination Respiratory Trigger Count Threshold.
TerminationTimeThreshold | 0x00189722 | Termination Time Threshold.
TestPointNormalsDataFlag | 0x00240057 | Test Point Normals Data Flag.
TestPointNormalsSequence | 0x00240058 | Test Point Normals Sequence.
TextColorCIELabValue | 0x00700241 | Text Color CIELab Value.
TextComments | 0x40004000 | Text Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TextFormatID | 0x00005130 | Text Format ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TextObjectSequence | 0x00700008 | Text Object Sequence.
TextString | 0x20300020 | Text String.
TextStyleSequence | 0x00700231 | Text Style Sequence.
TextValue | 0x0040A160 | Text Value.
TherapyDescription | 0x00180039 | Therapy Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TherapyType | 0x00180037 | Therapy Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ThreatCategory | 0x40101012 | Threat Category.
ThreatCategoryDescription | 0x40101013 | Threat Category Description.
ThreatDetectionAlgorithmandVersion | 0x40101029 | Threat Detection Algorithm and Version.
ThreatROIBase | 0x40101004 | Threat ROI Base.
ThreatROIBitmap | 0x40101006 | Threat ROI Bitmap.
ThreatROIExtents | 0x40101005 | Threat ROI Extents.
ThreatROIVoxelSequence | 0x40101001 | Threat ROI Voxel Sequence.
ThreatSequence | 0x40101011 | Threat Sequence.
ThreeDDegreeOfFreedomAxis | 0x00686490 | 3D Degree of Freedom Axis.
ThreeDImplantTemplateGroupMemberMatchingAxes | 0x00780060 | 3D Implant Template Group Member Matching Axes.
ThreeDImplantTemplateGroupMemberMatchingPoint | 0x00780050 | 3D Implant Template Group Member Matching Point.
ThreeDLineCoordinates | 0x006865D0 | 3D Line Coordinates.
ThreeDMatingAxes | 0x006864D0 | 3D Mating Axes.
ThreeDMatingPoint | 0x006864C0 | 3D Mating Point.
ThreeDPlaneNormal | 0x00686620 | 3D Plane Normal.
ThreeDPlaneOrigin | 0x00686610 | 3D Plane Origin.
ThreeDPointCoordinates | 0x00686590 | 3D Point Coordinates.
ThreeDRenderingType | 0x00720520 | 3D Rendering Type.
ThresholdDensity | 0x20400100 | Threshold Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TickAlignment | 0x00700274 | Tick Alignment.
TickLabel | 0x00700289 | Tick Label.
TickLabelAlignment | 0x00700279 | Tick Label Alignment.
TickPosition | 0x00700288 | Tick Position.
TidOffset | 0x00286120 | TID Offset.
Time | 0x0040A122 | Time value.
TimeBasedImageSetsSequence | 0x00720030 | Time Based Image Sets Sequence.
TimeDistributionProtocol | 0x00181802 | Time Distribution Protocol.
TimeDomainFiltering | 0x00189065 | Time Domain Filtering.
TimeOfDocumentCreationOrVerbalTransactionTrial | 0x0040A112 | Time of Document Creation or Verbal Transaction (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TimeOfFlightContrast | 0x00189015 | Time of Flight Contrast.
TimeOfFlightInformationUsed | 0x00189755 | Time of Flight Information Used.
TimeOfGainCalibration | 0x00143077 | Time of Gain Calibration.
TimeOfLastCalibration | 0x00181201 | Time of Last Calibration.
TimeOfLastDetectorCalibration | 0x0018700E | Time of Last Detector Calibration.
TimeOfSecondaryCapture | 0x00181014 | Time of Secondary Capture.
TimeRange | 0x00081163 | Time Range.
TimeSliceVector | 0x00540100 | Time Slice Vector.
TimeSlotInformationSequence | 0x00540072 | Time Slot Information Sequence.
TimeSlotInfoSequence | 0x00540072 | Time Slot Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
TimeSlotNumber | 0x00200017 | Time Slot Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TimeSlotTime | 0x00540073 | Time Slot Time.
TimeSlotVector | 0x00540070 | Time Slot Vector.
TimeSource | 0x00181801 | Time Source.
TimezoneOffsetFromUTC | 0x00080201 | Timezone Offset From UTC.
TIPType | 0x40101039 | TIP Type.
TissueHeterogeneityCorrection | 0x30040014 | Tissue Heterogeneity Correction.
TmLinePositionX0 | 0x0018603D | TM-Line Position X0.
TMLinePositionX0Retired | 0x0018603C | TM-Line Position X0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TmLinePositionX1 | 0x00186041 | TM-Line Position X1.
TMLinePositionX1Retired | 0x00186040 | TM-Line Position X1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TmLinePositionY0 | 0x0018603F | TM-Line Position Y0.
TMLinePositionY0Retired | 0x0018603E | TM-Line Position Y0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TmLinePositionY1 | 0x00186043 | TM-Line Position Y1.
TMLinePositionY1Retired | 0x00186042 | TM-Line Position Y1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ToleranceTableLabel | 0x300A0043 | Tolerance Table Label.
ToleranceTableNumber | 0x300A0042 | Tolerance Table Number.
ToleranceTableSequence | 0x300A0040 | Tolerance Table Sequence.
TomoAngle | 0x00181470 | Tomo Angle.
TomoClass | 0x00181491 | Tomo Class.
TomoLayerHeight | 0x00181460 | Tomo Layer Height.
TomoSourceImageNumber | 0x00181495 | Number of Tomosynthesis Source Images. This tag name has been deprecated, use tag with the same value defined in the previous line.
TomoTime | 0x00181480 | Tomo Time.
TomoType | 0x00181490 | Tomo Type.
TopicAuthor | 0x00880910 | Topic Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TopicKeywords | 0x00880912 | Topic Keywords. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TopicSubject | 0x00880906 | Topic Subject. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TopicTitle | 0x00880904 | Topic Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TopLeftHandCornerOfLocalizerArea | 0x00480201 | Top Left Hand Corner of Localizer Area.
TotalBlockTrayFactor | 0x300A00F2 | Total Block Tray Factor.
TotalBlockTrayWaterEquivalentThickness | 0x300A00F3 | Total Block Tray Water-Equivalent Thickness.
TotalCollimationWidth | 0x00189307 | Total Collimation Width.
TotalCompensatorTrayFactor | 0x300A00E2 | Total Compensator Tray Factor.
TotalCompensatorTrayWaterEquivalentThickness | 0x300A02E3 | Total Compensator Tray Water-Equivalent Thickness.
TotalGain | 0x00185040 | Total Gain. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TotalNumberofExposure | 0x00400301 | Total Number of Exposures. This tag name has been deprecated, use tag with the same value defined in the previous line.
TotalNumberofExposures | 0x00400301 | Total Number of Exposures.
TotalNumberofPiecesofMediaCreated | 0x2200000B | Total Number of Pieces of Media Created.
TotalPixelMatrixColumns | 0x00480006 | Total Pixel Matrix Columns.
TotalPixelMatrixOriginSequence | 0x00480008 | Total Pixel Matrix Origin Sequence.
TotalPixelMatrixRows | 0x00480007 | Total Pixel Matrix Rows.
TotalProcessingTime | 0x40101069 | Total Processing Time.
TotalReferenceAirKerma | 0x300A0250 | Total Reference Air Kerma.
TotalTime | 0x50FF200A | Total Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TotalTimeofFluoroscopy | 0x00400300 | Total Time of Fluoroscopy.
TotalWedgeTrayWaterEquivalentThickness | 0x300A00D7 | Total Wedge Tray Water-Equivalent Thickness.
TransactionUID | 0x00081195 | Transaction UID.
TransducerApplicationCodeSequence | 0x0018980F | Transducer Application Code Sequence.
TransducerBeamSteeringCodeSequence | 0x0018980E | Transducer Beam Steering Code Sequence.
TransducerData | 0x00185010 | Transducer Data.
TransducerFrequency | 0x00186030 | Transducer Frequency.
TransducerGeometryCodeSequence | 0x0018980D | Transducer Geometry Code Sequence.
TransducerOrientation | 0x00082204 | Transducer Orientation.
TransducerOrientationModifierSequence | 0x00082246 | Transducer Orientation Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransducerOrientationSequence | 0x00082244 | Transducer Orientation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransducerPosition | 0x00082200 | Transducer Position.
TransducerPositionModifierSequence | 0x00082242 | Transducer Position Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransducerPositionSequence | 0x00082240 | Transducer Position Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransducerScanPatternCodeSequence | 0x00189809 | Transducer Scan Pattern Code Sequence.
TransducerType | 0x00186031 | Transducer Type.
TransferSyntaxUID | 0x00020010 | Transfer Syntax UID. This tells whether the DICOM file uses big or little endian format, which compression is used, if any, and whether the file uses Implicit or Explicit Value Representation syntax.
TransferTubeLength | 0x300A02A4 | Transfer Tube Length.
TransferTubeNumber | 0x300A02A2 | Transfer Tube Number.
TransformDescription | 0x00142222 | Transform Description.
TransformedAxisUnits | 0x00142228 | Transformed Axis Units.
TransformLabel | 0x00280400 | Transform Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransformNumberOfAxes | 0x00142224 | Transform Number of Axes.
TransformOrderOfAxes | 0x00142226 | Transform Order of Axes.
TransformVersionNumber | 0x00280401 | Transform Version Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TransmitCoilManufacturerName | 0x00189050 | Transmit Coil Manufacturer Name.
TransmitCoilName | 0x00181251 | Transmit Coil Name.
TransmitCoilType | 0x00189051 | Transmit Coil Type.
TransmitterFrequency | 0x00189098 | Transmitter Frequency.
TransmitTransducerSequence | 0x00144010 | Transmit Transducer Sequence.
TransmitTransducerSettingsSequence | 0x00144050 | Transmit Transducer Settings Sequence.
TransportClassification | 0x40101067 | Transport Classification.
TransverseDetectorSeparation | 0x00189726 | Transverse Detector Separation.
TransverseMash | 0x00541202 | Transverse Mash.
TreatmentControlPointDate | 0x30080024 | Treatment Control Point Date.
TreatmentControlPointTime | 0x30080025 | Treatment Control Point Time.
TreatmentDate | 0x30080250 | Treatment Date.
TreatmentDeliveryType | 0x300A00CE | Treatment Delivery Type.
TreatmentIntent | 0x300A000A | Plan Intent. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentMachineName | 0x300A00B2 | Treatment Machine Name.
TreatmentMachineSequence | 0x300A0206 | Treatment Machine Sequence.
TreatmentProtocol | 0x300A0009 | Treatment Protocols. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentProtocols | 0x300A0009 | Treatment Protocols.
TreatmentSessionApplicationSetupSequence | 0x30080110 | Treatment Session Application Setup Sequence.
TreatmentSessionBeamSequence | 0x30080020 | Treatment Session Beam Sequence.
TreatmentSessionIonBeamSequence | 0x30080021 | Treatment Session Ion Beam Sequence.
TreatmentSessionSetupSequence | 0x30080110 | Treatment Session Application Setup Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentSite | 0x300A000B | Treatment Sites. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentSites | 0x300A000B | Treatment Sites.
TreatmentStatusComment | 0x30080202 | Treatment Status Comment.
TreatmentSummaryCalcDoseRef | 0x30080050 | Treatment Summary Calculated Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentSummaryCalculatedDoseReferenceSequence | 0x30080050 | Treatment Summary Calculated Dose Reference Sequence.
TreatmentSummaryMeasuredDoseReferenceSequence | 0x300800E0 | Treatment Summary Measured Dose Reference Sequence.
TreatmentSummarySequence | 0x300800E0 | Treatment Summary Measured Dose Reference Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
TreatmentTerminationCode | 0x3008002B | Treatment Termination Code.
TreatmentTerminationStatus | 0x3008002A | Treatment Termination Status.
TreatmentTime | 0x30080251 | Treatment Time.
TreatmentVerificationStatus | 0x3008002C | Treatment Verification Status.
TriangleFanSequence | 0x00660027 | Triangle Fan Sequence.
TrianglePointIndexList | 0x00660023 | Triangle Point Index List.
TriangleStripSequence | 0x00660026 | Triangle Strip Sequence.
TriggerDelayTime | 0x00209153 | Nominal Cardiac Trigger Delay Time. This tag name has been deprecated, use tag with the same value defined in the previous line.
TriggerSamplePosition | 0x0018106E | Trigger Sample Position.
TriggerSourceorType | 0x00181061 | Trigger Source or Type.
TriggerTime | 0x00181060 | Trigger Time.
TriggerTimeOffset | 0x00181069 | Trigger Time Offset.
TriggerVector | 0x00540210 | Trigger Vector.
TriggerWindow | 0x00181094 | Trigger Window.
Trim | 0x20100140 | Trim value.
TubeAngle | 0x00189303 | Tube Angle.
TwoDDegreeOfFreedomAxis | 0x006864F0 | 2D Degree of Freedom Axis.
TwoDDegreeOfFreedomSequence | 0x00686470 | 2D Degree of Freedom Sequence.
TwoDImplantTemplateGroupMemberMatchingAxes | 0x007800A0 | 2D Implant Template Group Member Matching Axes.
TwoDImplantTemplateGroupMemberMatchingPoint | 0x00780090 | 2D Implant Template Group Member Matching Point.
TwoDLineCoordinates | 0x006865B0 | 2D Line Coordinates.
TwoDLineCoordinatesSequence | 0x006865A0 | 2D Line Coordinates Sequence.
TwoDMatingAxes | 0x00686460 | 2D Mating Axes.
TwoDMatingFeatureCoordinatesSequence | 0x00686430 | 2D Mating Feature Coordinates Sequence.
TwoDMatingPoint | 0x00686450 | 2D Mating Point.
TwoDPlaneCoordinatesSequence | 0x006865E0 | 2D Plane Coordinates Sequence.
TwoDPlaneIntersection | 0x006865F0 | 2D Plane Intersection.
TwoDPointCoordinates | 0x00686560 | 2D Point Coordinates.
TwoDPointCoordinatesSequence | 0x00686550 | 2D Point Coordinates Sequence.
TypeOfData | 0x50FF0020 | Type of Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
TypeOfDetectorMotion | 0x00540202 | Type of Detector Motion.
TypeOfFilters | 0x00181161 | Type of Filters.
TypeOfInstances | 0x0040E020 | Type of Instances.
TypeOfPatientID | 0x00100022 | Type of Patient ID.
TypeOfSynchronization | 0x00720434 | Type of Synchronization.
UID | 0x0040A124 | UID (unique identifier).
UltrasoundAcquisitionGeometry | 0x00209307 | Ultrasound Acquisition Geometry.
UltrasoundColorDataPresent | 0x00280014 | Ultrasound Color Data Present.
UltrasoundOphthalmicAxialLengthMeasurementsSequence | 0x00221220 | Ultrasound Ophthalmic Axial Length Measurements Sequence.
UltrasoundSelectedOphthalmicAxialLengthSequence | 0x00221230 | Ultrasound Selected Ophthalmic Axial Length Sequence.
Underlined | 0x00700248 | Underlined.
UnformattedTextValue | 0x00700006 | Unformatted Text Value.
UnifiedProcedureStepCommunicationsURISequence | 0x00741008 | Unified Procedure Step Communications URI Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
UnifiedProcedureStepDiscontinuationReasonCodeSequence | 0x0074100E | Unified Procedure Step Discontinuation Reason Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
UnifiedProcedureStepListStatus | 0x00741246 | Unified Procedure Step List Status.
UnifiedProcedureStepPerformedProcedureSequence | 0x00741216 | Unified Procedure Step Performed Procedure Sequence.
UnifiedProcedureStepProgress | 0x00741004 | Unified Procedure Step Progress. This tag name has been deprecated, use tag with the same value defined in the previous line.
UnifiedProcedureStepProgressDescription | 0x00741006 | Unified Procedure Step Progress Description. This tag name has been deprecated, use tag with the same value defined in the previous line.
UnifiedProcedureStepProgressInformationSequence | 0x00741002 | Unified Procedure Step Progress Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
UnifiedProcedureStepState | 0x00741000 | Unified Procedure Step State. This tag name has been deprecated, use tag with the same value defined in the previous line.
UniformResourceLocatorTrial | 0x0040A992 | Uniform Resource Locator (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
Units | 0x00541001 | The Units.
UniversalEntityID | 0x00400032 | Universal Entity ID.
UniversalEntityIDType | 0x00400033 | Universal Entity ID Type.
UNKNOWN | 0x00000008 | Tag not found in the dictionary.
UnspecifiedLateralityLensSequence | 0x00460016 | Unspecified Laterality Lens Sequence.
UpperLowerPixelValues | 0x00181240 | Upper/Lower Pixel Values. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
UPSListStatus | 0x00741246 | Unified Procedure Step List Status. This tag name has been deprecated, use tag with the same value defined in the previous line.
UPSPerformedProcedureSequence | 0x00741216 | Unified Procedure Step Performed Procedure Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
UPSProgressInformationSequence | 0x00741002 | Unified Procedure Step Progress Information Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
UrgencyOrPriorityAlertsTrial | 0x0040A057 | Urgency or Priority Alerts (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
UsedFiducialsSequence | 0x00700314 | Used Fiducials Sequence.
USImageDescriptionSequence | 0x00189806 | US Image Description Sequence.
ValueType | 0x0040A040 | Value Type.
VariableCoefficientsSDDN | 0x7FFF0040 | Variable Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VariableCoefficientsSDHN | 0x7FFF0030 | Variable Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VariableCoefficientsSDVN | 0x7FFF0020 | Variable Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VariableFlipAngleFlag | 0x00181315 | Variable Flip Angle Flag.
VariableNextDataGroup | 0x7FFF0011 | Variable Next Data Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VariablePixelData | 0x7FFF0010 | Variable Pixel Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VectorAccuracy | 0x00660020 | Vector Accuracy.
VectorCoordinateData | 0x00660021 | Vector Coordinate Data.
VectorDimensionality | 0x0066001F | Vector Dimensionality.
VectorGridData | 0x00640009 | Vector Grid Data.
VelocityEncodingAcquisitionSequence | 0x00189092 | Velocity Encoding Acquisition Sequence.
VelocityEncodingDirection | 0x00189090 | Velocity Encoding Direction.
VelocityEncodingMaximumValue | 0x00189217 | Velocity Encoding Maximum Value.
VelocityEncodingMaxValue | 0x00189217 | Velocity Encoding Maximum Value. This tag name has been deprecated, use tag with the same value defined in the previous line.
VelocityEncodingMinimumValue | 0x00189091 | Velocity Encoding Minimum Value.
VelocityEncodingMinValue | 0x00189091 | Velocity Encoding Minimum Value. This tag name has been deprecated, use tag with the same value defined in the previous line.
VelocityOfSound | 0x00144064 | Velocity of Sound.
VerbalSourceIdentifierCodeSequenceTrial | 0x0040A358 | Verbal Source Identifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VerbalSourceTrial | 0x0040A352 | Verbal Source (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VerificationDateTime | 0x0040A030 | Verification Date Time.
VerificationFlag | 0x0040A493 | Verification Flag.
VerificationImageTiming | 0x00741032 | Verification Image Timing.
VerifyingObserverIDCodeSequence | 0x0040A088 | Verifying Observer Identification Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
VerifyingObserverIdentificationCodeSequence | 0x0040A088 | Verifying Observer Identification Code Sequence.
VerifyingObserverName | 0x0040A075 | Verifying Observer Name.
VerifyingObserverSequence | 0x0040A073 | Verifying Observer Sequence.
VerifyingOrganization | 0x0040A027 | Verifying Organization.
VertexPointIndexList | 0x00660025 | Vertex Point Index List.
VerticalAlignment | 0x00700243 | Vertical Alignment.
VerticalOffsetOfSensor | 0x00143026 | Vertical Offset of Sensor.
VerticalPrismBase | 0x00460036 | Vertical Prism Base.
VerticalPrismPower | 0x00460034 | Vertical Prism Power.
VerticesOfThePolygonalCollimator | 0x00181720 | Vertices of the Polygonal Collimator.
VerticesofthePolygonalExposureControlSensing | 0x00189442 | Vertices of the Polygonal Exposure Control Sensing Region. This tag name has been deprecated, use tag with the same value defined in the previous line.
VerticesOfThePolygonalExposureControlSensingRegion | 0x00189442 | Vertices of the Polygonal Exposure Control Sensing Region.
VerticesOfThePolygonalShutter | 0x00181620 | Vertices of the Polygonal Shutter.
VerticesOfTheRegion | 0x00289503 | Vertices of the Region.
VideoImageFormatAcquired | 0x00181022 | Video Image Format Acquired.
ViewAngulationModifierCodeSequence | 0x00540222 | View Modifier Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ViewCodeSequence | 0x00540220 | View Code Sequence.
ViewCodeSequnce | 0x00540220 | View Code Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
ViewingDistance | 0x00460106 | Viewing Distance.
ViewingDistanceType | 0x00460125 | Viewing Distance Type.
ViewModifierCodeSequence | 0x00540222 | View Modifier Code Sequence.
ViewName | 0x00082127 | View Name.
ViewNumber | 0x00082128 | View Number.
ViewOrientationCodeSequence | 0x006862E0 | View Orientation Code Sequence.
ViewOrientationModifier | 0x006862F0 | View Orientation Modifier.
ViewPosition | 0x00185101 | View Position.
VirtualSourceAxisDistances | 0x300A030A | Virtual Source-Axis Distances.
VisitComments | 0x00384000 | Visit Comments.
VisitStatusID | 0x00380008 | Visit Status ID.
VisualAcuityBothEyesOpenSequence | 0x00460124 | Visual Acuity Both Eyes Open Sequence.
VisualAcuityLeftEyeSequence | 0x00460123 | Visual Acuity Left Eye Sequence.
VisualAcuityMeasurementSequence | 0x00240110 | Visual Acuity Measurement Sequence.
VisualAcuityModifiers | 0x00460135 | Visual Acuity Modifiers.
VisualAcuityRightEyeSequence | 0x00460122 | Visual Acuity Right Eye Sequence.
VisualAcuityTypeCodeSequence | 0x00460121 | Visual Acuity Type Code Sequence.
VisualFieldCatchTrialSequence | 0x00240034 | Visual Field Catch Trial Sequence.
VisualFieldGlobalResultsIndexSequence | 0x00240320 | Visual Field Global Results Index Sequence.
VisualFieldHorizontalExtent | 0x00240010 | Visual Field Horizontal Extent.
VisualFieldMeanSensitivity | 0x00240070 | Visual Field Mean Sensitivity.
VisualFieldShape | 0x00240012 | Visual Field Shape.
VisualFieldTestDuration | 0x00240088 | Visual Field Test Duration.
VisualFieldTestNormalsFlag | 0x00240063 | Visual Field Test Normals Flag.
VisualFieldTestPointNormalsSequence | 0x00240097 | Visual Field Test Point Normals Sequence.
VisualFieldTestPointSequence | 0x00240089 | Visual Field Test Point Sequence.
VisualFieldTestPointXCoordinate | 0x00240090 | Visual Field Test Point X-Coordinate.
VisualFieldTestPointYCoordinate | 0x00240091 | Visual Field Test Point Y-Coordinate.
VisualFieldTestReliabilityGlobalIndexSequence | 0x00240317 | Visual Field Test Reliability Global Index Sequence.
VisualFieldVerticalExtent | 0x00240011 | Visual Field Vertical Extent.
VitalStainCodeSequence | 0x004009F8 | Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VitalStainCodeSequenceTrial | 0x004009F8 | Vital Stain Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
VitreousStatusCodeSequence | 0x00221025 | Vitreous Status Code Sequence.
VitreousStatusDescription | 0x00221066 | Vitreous Status Description.
VOILUTFunction | 0x00281056 | VOI LUT Function.
VOILUTSequence | 0x00283010 | VOI LUT Sequence.
VOIType | 0x00720702 | VOI (Value Of Interest) Type.
VolumeBasedCalcTechnique | 0x00089207 | Volume Based Calculation Technique. This tag name has been deprecated, use tag with the same value defined in the previous line.
VolumeBasedCalculationTechnique | 0x00089207 | Volume Based Calculation Technique.
VolumeFrameOfReferenceUID | 0x00209312 | Volume Frame of Reference UID.
VolumeLocalizationSequence | 0x00189126 | Volume Localization Sequence.
VolumeLocalizationTechnique | 0x00189054 | Volume Localization Technique.
VolumeOfPTO | 0x40101023 | Volume of PTO.
VolumeToTableMappingMatrix | 0x0020930A | Volume to Table Mapping Matrix.
VolumeToTransducerMappingMatrix | 0x00209309 | Volume to Transducer Mapping Matrix.
VolumetricProperties | 0x00089206 | Volumetric Properties.
WADORetrievalSequence | 0x0040E023 | WADO Retrieval Sequence.
WaterReferencedPhaseCorrection | 0x00189199 | Water Referenced Phase Correction.
WaveformAnnotationSequence | 0x0040B020 | Waveform Annotation Sequence.
WaveformBitsAllocated | 0x54001004 | Waveform Bits Allocated.
WaveformBitsStored | 0x003A021A | Waveform Bits Stored.
WaveformChannelNumber | 0x003A0202 | Waveform Channel Number.
WaveformData | 0x54001010 | Waveform Data.
WaveformDataDisplayScale | 0x003A0230 | Waveform Data Display Scale.
WaveformDisplayBackgroundCIELabValue | 0x003A0231 | Waveform Display Background CIELab Value.
WaveformOriginality | 0x003A0004 | Waveform Originality.
WaveformPaddingValue | 0x5400100A | Waveform Padding Value.
WaveformPresentationGroupSequence | 0x003A0240 | Waveform Presentation Group Sequence.
WaveformSampleInterpretation | 0x54001006 | Waveform Sample Interpretation.
WaveformSampleValueRepresentation | 0x003A0103 | Waveform Sample Value Representation.
WaveformSequence | 0x54000100 | Waveform Sequence.
WaveformSource | 0x003A0208 | Channel Source Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
WaveformSourceModifiers | 0x003A0209 | Channel Source Modifiers Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
WedgeAngle | 0x300A00D5 | Wedge Angle.
WedgeFactor | 0x300A00D6 | Wedge Factor.
WedgeID | 0x300A00D4 | Wedge Identifier.
WedgeNumber | 0x300A00D2 | Wedge Number.
WedgeOrientation | 0x300A00D8 | Wedge Orientation.
WedgePosition | 0x300A0118 | Wedge Position.
WedgePositionSequence | 0x300A0116 | Wedge Position Sequence.
WedgeSequence | 0x300A00D1 | Wedge Sequence.
WedgeThinEdgePosition | 0x300A00DB | Wedge Thin Edge Position.
WedgeType | 0x300A00D3 | Wedge Type.
WholeBodyTechnique | 0x00181301 | Whole Body Technique.
WindowCenter | 0x00281050 | Window Center.
WindowCenterAndWidthExplanation | 0x00281055 | Window Center and Width Explanation. This tag name has been deprecated, use tag with the same value defined in the previous line.
WindowCenterWidthExplanation | 0x00281055 | Window Center and Width Explanation.
WindowWidth | 0x00281051 | Window Width.
WorklistLabel | 0x00741202 | Worklist Label.
X_RayTubeCurrentinmA | 0x00189330 | X-Ray Tube Current in mA. This tag name has been deprecated, use tag with the same value defined in the previous line.
XA_XRFFrameCharacteristicsSequence | 0x00189412 | XA/XRF Frame Characteristics Sequence. This tag name has been deprecated, use tag with the same value defined in the previous line.
XAXRFFrameCharacteristicsSequence | 0x00189412 | XA/XRF Frame Characteristics Sequence.
XDSRetrievalSequence | 0x0040E024 | XDS Retrieval Sequence.
XFocusCenter | 0x00181183 | X Focus Center.
XOffset | 0x0040072A | X offset in Slide Coordinate System. This tag name has been deprecated, use tag with the same value defined in the previous line.
XOffsetInSlideCoordinateSystem | 0x0040072A | X offset in Slide Coordinate System.
XRay3DAcquisitionSequence | 0x00189507 | X-Ray 3D Acquisition Sequence.
XRay3DFrameTypeSequence | 0x00189504 | X-Ray 3D Frame Type Sequence.
XRay3DReconstructionSequence | 0x00189530 | X-Ray 3D Reconstruction Sequence.
XRayGeometrySequence | 0x00189476 | X-Ray Geometry Sequence.
XrayImageReceptorAngle | 0x3002000E | X-Ray Image Receptor Angle.
XRayImageReceptorTranslation | 0x3002000D | X-Ray Image Receptor Translation.
XrayOutput | 0x00400312 | X-Ray Output.
XRayReceptorType | 0x00189420 | X-Ray Receptor Type.
XrayTubeCurrent | 0x00181151 | X-Ray Tube Current. This tag name has been deprecated, use tag with the same value defined in the previous line.
XRayTubeCurrent | 0x00181151 | X-Ray Tube Current.
XRayTubeCurrentInmA | 0x00188151 | X-Ray Tube Current in micro A. This tag name has been deprecated, use tag with the same value defined in the previous line.
XRayTubeCurrentInMicroA | 0x00188151 | X-Ray Tube Current in micro A. This tag name has been deprecated, use tag with the same value defined in the previous line.
XRayTubeCurrentInMilliA | 0x00189330 | X-Ray Tube Current in mA.
XRayTubeCurrentInuA | 0x00188151 | X-Ray Tube Current in micro A.
YFocusCenter | 0x00181184 | Y Focus Center.
YOffset | 0x0040073A | Y offset in Slide Coordinate System. This tag name has been deprecated, use tag with the same value defined in the previous line.
YOffsetInSlideCoordinateSystem | 0x0040073A | Y offset in Slide Coordinate System.
ZEffective | 0x40101019 | Z Effective.
ZOffset | 0x0040074A | Z offset in Slide Coordinate System. This tag name has been deprecated, use tag with the same value defined in the previous line.
ZOffsetInSlideCoordinateSystem | 0x0040074A | Z offset in Slide Coordinate System.
ZonalMap | 0x1010FFFF | Zonal Map. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ZonalMapFormat | 0x00280722 | Zonal Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ZonalMapLocation | 0x00280721 | Zonal Map Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ZonalMapNumberFormat | 0x00280720 | Zonal Map Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
ZoomCenter | 0x00280032 | Zoom Center.
ZoomFactor | 0x00280031 | Zoom Factor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMTagsIDs

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMTransferSyntaxes Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMTransferSyntaxes Enumeration
Specifies DICOM Transfer Syntaxes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMTransferSyntaxes
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMTransferSyntaxes
public enum ImGearDICOMTransferSyntaxes : System.Enum
__value public enum ImGearDICOMTransferSyntaxes : public System.Enum
public enum class ImGearDICOMTransferSyntaxes : public System.Enum
Members
Member | Value | Description
AUTODETECT | 37 | Autodetect. This value is used with DICOM LoadSyntax format option, to allow automatic detection of transfer syntax.
DEFAULT | 34 | DICOM default transfer syntax: Implicit VR Little Endian.
DEFLATED_EXPLICIT_VR_LE | 3 | Deflated Explicit VR Little Endian.
EXPLICIT_VR_BE | 2 | Explicit VR Big Endian (uncompressed).
EXPLICIT_VR_LE | 1 | Explicit VR Little Endian (uncompressed).
IMPLICIT_VR_LE | 0 | Implicit VR Little Endian: Default Transfer Syntax for DICOM (uncompressed).
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION | 27 | JPEG 2000 Part 2 Multi-component Image Compression.
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION_Lossless_Only | 26 | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only).
JPEG_2K | 25 | JPEG 2000 Image Compression.
JPEG_2K_LOSSLESS_ONLY | 24 | JPEG 2000 Image Compression (Lossless Only).
JPEG_BASELINE_PR_1 | 4 | JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
JPEG_EXTENDED_HIER_PR_16_18 | 13 | JPEG Extended, Hierarchical (Process 16 & 18) (Retired).
JPEG_EXTENDED_HIER_PR_17_19 | 14 | JPEG Extended, Hierarchical (Process 17 & 19) (Retired).
JPEG_EXTENDED_PR_2_4 | 5 | JPEG Extended (Process 2 & 4): Default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only).
JPEG_EXTENDED_PR_3_5 | 6 | JPEG Extended (Process 3 & 5) (Retired).
JPEG_FULL_PROG_HIER_PR_24_26 | 17 | JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired).
JPEG_FULL_PROG_HIER_PR_25_27 | 18 | JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired).
JPEG_FULL_PROG_NONH_PR_10_12 | 9 | JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired).
JPEG_FULL_PROG_NONH_PR_11_13 | 10 | JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired).
JPEG_LOSSLESS | 39 | JPEG Lossless, Non-Hierarchical (Process 14).
JPEG_LOSSLESS_HIER_PR_28 | 19 | JPEG Lossless, Hierarchical (Process 28) (Retired).
JPEG_LOSSLESS_HIER_PR_29 | 20 | JPEG Lossless, Hierarchical (Process 29) (Retired).
JPEG_LOSSLESS_NONH_FIRSTORDER_PR_14 | 21 | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]): Default Transfer Syntax for Lossless JPEG Image Compression.
JPEG_LOSSLESS_NONH_PR_14 | 11 | JPEG Lossless, Non-Hierarchical (Process 14).
JPEG_LOSSLESS_NONH_PR_15 | 12 | JPEG Lossless, Non-Hierarchical (Process 15) (Retired).
JPEG_LOSSY | 38 | JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
JPEG_LS_LOSSLESS | 22 | JPEG-LS Lossless Image Compression.
JPEG_LS_LOSSY | 23 | JPEG-LS Lossy (Near-Lossless) Image Compression.
JPEG_SPECTRAL_HIER_PR_20_22 | 15 | JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired).
JPEG_SPECTRAL_HIER_PR_21_23 | 16 | JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired).
JPEG_SPECTRAL_NONH_PR_6_8 | 7 | JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired).
JPEG_SPECTRAL_NONH_PR_7_9 | 8 | JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired).
JPIP_REFERENCED | 28 | JPIP Referenced.
JPIP_REFERENCED_DEFLATE | 29 | JPIP Referenced Deflate.
MPEG2_MAIN_PROFILE | 30 | MPEG2 Main Profile @ Main Level.
MPEG2_MAIN_PROFILE_HIGH_LEVEL | 40 | MPEG2 Main Profile @ High Level.
MPEG4_AVC_H264_BD_COMPATIBLE_HIGH_PROFILE_LEVEL_4_1 | 42 | MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1.
MPEG4_AVC_H264_HIGH_PROFILE_LEVEL_4_1 | 41 | MPEG-4 AVC/H.264 High Profile / Level 4.1.
PART_10 | 36 | Autodetect. This value is used with DICOM LoadSyntax format option, to allow detection of DICOM Part10 compliant images.
RFC_2557_MIME_ENCAPSULATION | 32 | RFC 2557 MIME encapsulation.
RLE | 31 | RLE Lossless.
UNKNOWN | 35 | Unknown transfer syntax.
XML | 33 | XML Encoding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMTransferSyntaxes

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearDICOMValueRepresentations Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearDICOMValueRepresentations Enumeration
Specifies DICOM Value Representations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDICOMValueRepresentations
   Inherits System.Enum
'Usage

Dim instance As ImGearDICOMValueRepresentations
public enum ImGearDICOMValueRepresentations : System.Enum
__value public enum ImGearDICOMValueRepresentations : public System.Enum
public enum class ImGearDICOMValueRepresentations : public System.Enum
Members
Member | Value | Description
AgeString | 1 | Age String.
ApplicationEntity | 0 | Application Entity.
AttributeTag | 2 | Attribute Tag.
CodeString | 3 | Code String.
Date | 4 | Date (without time).
DateTime | 6 | Date Time.
DecimalString | 5 | Decimal String.
FloatingPointDouble | 8 | Floating Double Point.
FloatingPointSingle | 7 | Floating Single Point.
IntegerString | 9 | Integer String.
LongString | 10 | Long String.
LongText | 11 | Long Text.
None | 999 | None (unknown).
OtherByteString | 12 | Other Byte String.
OtherFloatString | 13 | Other Float String.
OtherWordString | 14 | Other Word String.
PersonName | 15 | Person Name.
SequenceOfItems | 18 | Sequence of Items.
ShortString | 16 | Short String.
ShortText | 20 | Short Text.
SignedLong | 17 | Signed Long.
SignedShort | 19 | Signed Short.
Time | 21 | Time (without date).
UniqueIdentifier | 22 | Unique Identifier.
Unknown | 25 | Unknown - supp 14.
UnlimitedText | 26 | Unlimited Text.
UnsignedLong | 23 | Unsigned Long.
UnsignedShort | 24 | Unsigned Short.
Remarks
Value Representation specifies type and format of the value(s) contained in data element.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearDICOMValueRepresentations

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearMprViewType Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearMprViewType Enumeration
Represents types of the MPR view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMprViewType
   Inherits System.Enum
'Usage

Dim instance As ImGearMprViewType
public enum ImGearMprViewType : System.Enum
__value public enum ImGearMprViewType : public System.Enum
public enum class ImGearMprViewType : public System.Enum
Members
Member | Value | Description
Axial | 0 | Axial view.
Coronal | 1 | Coronal view.
Sagittal | 2 | Sagittal view.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearMprViewType

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearPseudocolorSchemes Enumeration

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearPseudocolorSchemes Enumeration
Specifies predefined pseudocoloring schemes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPseudocolorSchemes
   Inherits System.Enum
'Usage

Dim instance As ImGearPseudocolorSchemes
public enum ImGearPseudocolorSchemes : System.Enum
__value public enum ImGearPseudocolorSchemes : public System.Enum
public enum class ImGearPseudocolorSchemes : public System.Enum
Members
Member | Value | Description
BrightRainbow | 6 | Bright rainbow color scheme.
DarkBlueToBightRed | 2 | From DarkBlue to BrightRed color scheme.
Default | 0 | Default color scheme.
GreenToRed | 3 | GreenToRed color scheme.
OilFilm | 1 | OilFilm color scheme.
RedGreenBlue | 4 | RGB color scheme.
Thermal | 5 | Thermal color scheme.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.DICOM.ImGearPseudocolorSchemes

See Also

Reference

ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearLinearTransform Structure
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearLinearTransform Structure
Encapsulates coefficients for a linear floating-point one-dimensional transform.
Object Model
ImGearLinearTransform StructureImGearLinearTransform Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearLinearTransform
   Inherits System.ValueType
'Usage

Dim instance As ImGearLinearTransform
public struct ImGearLinearTransform : System.ValueType
public __value struct ImGearLinearTransform : public System.ValueType
public value class ImGearLinearTransform : public System.ValueType
Remarks

Result of the transform is calculated as:

y = x * Slope + Intercept

This class can be used to hold DICOM Modality Rescale coefficients.

Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.DICOM.ImGearLinearTransform

See Also

Reference

ImGearLinearTransform Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearLinearTransform Structure Members
Fields Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearLinearTransform Structure

The following tables list the members exposed by ImGearLinearTransform.

Public Constructors
 | Name | Description
Public Constructor | ImGearLinearTransform Constructor | Initializes a new instance of the ImGearLinearTransform struct.
Top
Public Fields
 | Name | Description
Public Field | Intercept | Intercept coefficient.
Public Field | Slope | Slope coefficient.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateIdentity | Creates an identity transform.
Top
See Also

Reference

ImGearLinearTransform Structure
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearLinearTransform Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearLinearTransform Structure : ImGearLinearTransform Constructor
Slope coefficient.
Intercept coefficient.
Initializes a new instance of the ImGearLinearTransform struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal slope As Double, _
   ByVal intercept As Double _
)
'Usage

Dim slope As Double
Dim intercept As Double

Dim instance As New ImGearLinearTransform(slope, intercept)
public ImGearLinearTransform(
   double slope,
   double intercept
)
public: ImGearLinearTransform(
   double slope,
   double intercept
)
public:
ImGearLinearTransform(
   double slope,
   double intercept
)

Parameters

slope
Slope coefficient.
intercept
Intercept coefficient.

Return Value

The new instance of ImGearLinearTransform structure object.
Remarks
This constructor creates new instance of ImGearLinearTransform structure object.
See Also

Reference

ImGearLinearTransform Structure
ImGearLinearTransform Members


%%PageItemTitle%% $$Methods$$

ImGearLinearTransform Structure Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearLinearTransform Structure

For a list of all members of this type, see ImGearLinearTransform members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateIdentity | Creates an identity transform.
Top
See Also

Reference

ImGearLinearTransform Structure
ImageGear.Formats.DICOM Namespace


CreateIdentity Method (ImGearLinearTransform)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearLinearTransform Structure : CreateIdentity Method
Creates an identity transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateIdentity() As ImGearLinearTransform
'Usage

Dim value As ImGearLinearTransform

value = ImGearLinearTransform.CreateIdentity()
public static ImGearLinearTransform CreateIdentity()
public: static ImGearLinearTransform CreateIdentity();
public:
static ImGearLinearTransform CreateIdentity();

Return Value

ImGearLinearTransform structure object.
Remarks
This method creates an identity transform, using

Slope = 1.0;

Intercept = 0.0;

See Also

Reference

ImGearLinearTransform Structure
ImGearLinearTransform Members


%%PageItemTitle%% $$Fields$$

ImGearLinearTransform Structure Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearLinearTransform Structure

For a list of all members of this type, see ImGearLinearTransform members.

Public Fields
 | Name | Description
Public Field | Intercept | Intercept coefficient.
Public Field | Slope | Slope coefficient.
Top
See Also

Reference

ImGearLinearTransform Structure
ImageGear.Formats.DICOM Namespace


Intercept Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearLinearTransform Structure : Intercept Field
Intercept coefficient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Intercept As Double
'Usage

Dim instance As ImGearLinearTransform
Dim value As Double

value = instance.Intercept

instance.Intercept = value
public double Intercept
public: double Intercept
public:
double Intercept

Field Value

Any double value.
Remarks
This property specifies Intercept coefficient of the transform.

The default value is 0.0.

See Also

Reference

ImGearLinearTransform Structure
ImGearLinearTransform Members


Slope Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearLinearTransform Structure : Slope Field
Slope coefficient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Slope As Double
'Usage

Dim instance As ImGearLinearTransform
Dim value As Double

value = instance.Slope

instance.Slope = value
public double Slope
public: double Slope
public:
double Slope

Field Value

Any double value.
Remarks
This property specifies Slope coefficient of the transform.

The default value is 1.0.

See Also

Reference

ImGearLinearTransform Structure
ImGearLinearTransform Members


%%PageItemTitle%%

ImGearPresStateOptions Structure
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearPresStateOptions Structure
Encapsulates options for loading and saving presentation state objects.
Object Model
ImGearPresStateOptions Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearPresStateOptions
   Inherits System.ValueType
'Usage

Dim instance As ImGearPresStateOptions
public struct ImGearPresStateOptions : System.ValueType
public __value struct ImGearPresStateOptions : public System.ValueType
public value class ImGearPresStateOptions : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.DICOM.ImGearPresStateOptions

See Also

Reference

ImGearPresStateOptions Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearPresStateOptions Structure Members
Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearPresStateOptions Structure

The following tables list the members exposed by ImGearPresStateOptions.

Public Fields
 | Name | Description
Public Field | UseAnnotations | Tells whether to use or ignore annotations.
Public Field | UseDisplayedArea | Tells whether to use or ignore displayed area.
Public Field | UseModalityLUT | Tells whether to use or ignore Modality LUT.
Public Field | UseOrientation | Tells whether to use or ignore orientation.
Public Field | UsePresentationLUT | Tells whether to use or ignore Presentation LUT.
Public Field | UseVOILUT | Tells whether to use or ignore VOI LUT.
Top
See Also

Reference

ImGearPresStateOptions Structure
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Fields$$

ImGearPresStateOptions Structure Fields

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearPresStateOptions Structure

For a list of all members of this type, see ImGearPresStateOptions members.

Public Fields
 | Name | Description
Public Field | UseAnnotations | Tells whether to use or ignore annotations.
Public Field | UseDisplayedArea | Tells whether to use or ignore displayed area.
Public Field | UseModalityLUT | Tells whether to use or ignore Modality LUT.
Public Field | UseOrientation | Tells whether to use or ignore orientation.
Public Field | UsePresentationLUT | Tells whether to use or ignore Presentation LUT.
Public Field | UseVOILUT | Tells whether to use or ignore VOI LUT.
Top
See Also

Reference

ImGearPresStateOptions Structure
ImageGear.Formats.DICOM Namespace


UseAnnotations Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UseAnnotations Field
Tells whether to use or ignore annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseAnnotations As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UseAnnotations

instance.UseAnnotations = value
public bool UseAnnotations
public: bool UseAnnotations
public:
bool UseAnnotations

Field Value

Boolean value
Remarks
This property tells whether to use or ignore annotations when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


UseDisplayedArea Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UseDisplayedArea Field
Tells whether to use or ignore displayed area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseDisplayedArea As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UseDisplayedArea

instance.UseDisplayedArea = value
public bool UseDisplayedArea
public: bool UseDisplayedArea
public:
bool UseDisplayedArea

Field Value

Boolean value
Remarks
This property tells whether to use or ignore displayed area setting when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


UseModalityLUT Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UseModalityLUT Field
Tells whether to use or ignore Modality LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseModalityLUT As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UseModalityLUT

instance.UseModalityLUT = value
public bool UseModalityLUT
public: bool UseModalityLUT
public:
bool UseModalityLUT

Field Value

Boolean value
Remarks
This property tells whether to use or ignore Modality LUT when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


UseOrientation Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UseOrientation Field
Tells whether to use or ignore orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseOrientation As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UseOrientation

instance.UseOrientation = value
public bool UseOrientation
public: bool UseOrientation
public:
bool UseOrientation

Field Value

Boolean value
Remarks
This property tells whether to use or ignore orientation setting when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


UsePresentationLUT Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UsePresentationLUT Field
Tells whether to use or ignore Presentation LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UsePresentationLUT As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UsePresentationLUT

instance.UsePresentationLUT = value
public bool UsePresentationLUT
public: bool UsePresentationLUT
public:
bool UsePresentationLUT

Field Value

Boolean value
Remarks
This property tells whether to use or ignore Presentation LUT when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


UseVOILUT Field

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearPresStateOptions Structure : UseVOILUT Field
Tells whether to use or ignore VOI LUT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseVOILUT As Boolean
'Usage

Dim instance As ImGearPresStateOptions
Dim value As Boolean

value = instance.UseVOILUT

instance.UseVOILUT = value
public bool UseVOILUT
public: bool UseVOILUT
public:
bool UseVOILUT

Field Value

Boolean value
Remarks
This property tells whether to use or ignore VOI LUT when loading or saving a presentation state object.

The default value is true.

See Also

Reference

ImGearPresStateOptions Structure
ImGearPresStateOptions Members


%%PageItemTitle%%

ImGearVOIWindow Structure
Members

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOIWindow Structure
Encapsulates linear DICOM VOI transform.
Object Model
ImGearVOIWindow StructureImGearVOIWindow StructureImGearVOIWindow StructureImGearVOIWindow StructureImGearVOIWindow Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVOIWindow
   Inherits System.ValueType
'Usage

Dim instance As ImGearVOIWindow
public struct ImGearVOIWindow : System.ValueType
public __value struct ImGearVOIWindow : public System.ValueType
public value class ImGearVOIWindow : public System.ValueType
Remarks
This class contains two member values: Center property and Width property. This transform tells which contrast range of an image shall be mapped to contrast range of the display device.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.DICOM.ImGearVOIWindow

See Also

Reference

ImGearVOIWindow Members
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%% $$Members$$

ImGearVOIWindow Structure Members
Properties Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOIWindow Structure

The following tables list the members exposed by ImGearVOIWindow.

Public Constructors
 | Name | Description
Public Constructor | ImGearVOIWindow Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Center | Gets or sets Window Center value.
Public Property | Center64 | Gets or sets Window Center value as 64 bit integer.
Public Property | Max | Gets Window Maximum value.
Public Property | Max64 | Gets Window Maximum value as 64 bit integer.
Public Property | Min | Gets Window Minimum value.
Public Property | Min64 | Gets Window Minimum value as 64 bit integer.
Public Property | Width | Gets or sets Window Width value.
Public Property | Width64 | Gets or sets Window Width value as 64 bit integer.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates default VOI Window transform.
static (Shared in Visual Basic) | CreateFromChannelSpec | Creates a VOI Window transform based on channel depth and signed attribute.
static (Shared in Visual Basic) | CreateFromMinMax | Creates Window transform from Window minimum and maximum values.
static (Shared in Visual Basic) | CreateFromMinMax64 | Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.
Top
See Also

Reference

ImGearVOIWindow Structure
ImageGear.Formats.DICOM Namespace


%%PageItemTitle%%

ImGearVOIWindow Constructor

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : ImGearVOIWindow Constructor
Overload List
Overload | Description
ImGearVOIWindow Constructor(Int32,Int32) | Initializes a new instance of the ImGearVOIWindow struct.
ImGearVOIWindow Constructor(Int64,Int64) | Initializes a new instance of the ImGearVOIWindow struct.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


%%PageItemTitle%%

ImGearVOIWindow Constructor(Int32,Int32)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure > ImGearVOIWindow Constructor : ImGearVOIWindow Constructor(Int32,Int32)
Window Center.
Window Width.
Initializes a new instance of the ImGearVOIWindow struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal center As Integer, _
   ByVal width As Integer _
)
'Usage

Dim center As Integer
Dim width As Integer

Dim instance As New ImGearVOIWindow(center, width)
public ImGearVOIWindow(
   int center,
   int width
)
public: ImGearVOIWindow(
   int center,
   int width
)
public:
ImGearVOIWindow(
   int center,
   int width
)

Parameters

center
Window Center.
width
Window Width.

Return Value

The new instance of ImGearVOIWindow structure object.
Remarks
This constructor creates new instance of ImGearVOIWindow structure object, using the specified 32-bit values for window center and width.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members
Overload List


%%PageItemTitle%%

ImGearVOIWindow Constructor(Int64,Int64)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure > ImGearVOIWindow Constructor : ImGearVOIWindow Constructor(Int64,Int64)
Window Center.
Window Width.
Initializes a new instance of the ImGearVOIWindow struct.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal center As Long, _
   ByVal width As Long _
)
'Usage

Dim center As Long
Dim width As Long

Dim instance As New ImGearVOIWindow(center, width)
public ImGearVOIWindow(
   long center,
   long width
)
public: ImGearVOIWindow(
   long center,
   long width
)
public:
ImGearVOIWindow(
   int64 center,
   int64 width
)

Parameters

center
Window Center.
width
Window Width.

Return Value

The new instance of ImGearVOIWindow structure object.
Remarks
This constructor creates new instance of ImGearVOIWindow structure object, using the specified 64-bit values for window center and width.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearVOIWindow Structure Methods

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOIWindow Structure

For a list of all members of this type, see ImGearVOIWindow members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates default VOI Window transform.
static (Shared in Visual Basic) | CreateFromChannelSpec | Creates a VOI Window transform based on channel depth and signed attribute.
static (Shared in Visual Basic) | CreateFromMinMax | Creates Window transform from Window minimum and maximum values.
static (Shared in Visual Basic) | CreateFromMinMax64 | Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.
Top
See Also

Reference

ImGearVOIWindow Structure
ImageGear.Formats.DICOM Namespace


CreateDefault Method (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : CreateDefault Method
Creates default VOI Window transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateDefault() As ImGearVOIWindow
'Usage

Dim value As ImGearVOIWindow

value = ImGearVOIWindow.CreateDefault()
public static ImGearVOIWindow CreateDefault()
public: static ImGearVOIWindow CreateDefault();
public:
static ImGearVOIWindow CreateDefault();

Return Value

ImGearVOIWindow structure object.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


CreateFromChannelSpec Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : CreateFromChannelSpec Method
Depth of an image to which the Window transform will be applied.
Signed attribute of an image to which the Window transform will be applied.
Creates a VOI Window transform based on channel depth and signed attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateFromChannelSpec( _
   ByVal inputDepth As Integer, _
   ByVal isSigned As Boolean _
) As ImGearVOIWindow
'Usage

Dim inputDepth As Integer
Dim isSigned As Boolean
Dim value As ImGearVOIWindow

value = ImGearVOIWindow.CreateFromChannelSpec(inputDepth, isSigned)
public static ImGearVOIWindow CreateFromChannelSpec(
   int inputDepth,
   bool isSigned
)
public: static ImGearVOIWindow CreateFromChannelSpec(
   int inputDepth,
   bool isSigned
)
public:
static ImGearVOIWindow CreateFromChannelSpec(
   int inputDepth,
   bool isSigned
)

Parameters

inputDepth
Depth of an image to which the Window transform will be applied.
isSigned
Signed attribute of an image to which the Window transform will be applied.

Return Value

ImGearVOIWindow structure object.
Remarks
Transform is initialized according to minimum and maximum possible values of a signed or unsigned pixel.
Example
  • C#
ImGearRasterPage rasterPage = (ImGearRasterPage)igPage;
ImGearDICOMDisplaySettings dicomDisplaySettings = rasterPage.DICOMDisplaySettings as ImGearDICOMDisplaySettings;
if (dicomDisplaySettings != null && dicomDisplaySettings.VOI == null)
{
    dicomDisplaySettings.VOI = new ImGearVOITransform();
    dicomDisplaySettings.VOI.Window =
        ImGearVOIWindow.CreateFromChannelSpec(rasterPage.DIB.ChannelDepths[0], rasterPage.DIB.Signed);
}
  • Visual Basic
Dim rasterPage As ImGearRasterPage = igPage
Dim dicomDisplaySettings As ImGearDICOMDisplaySettings = rasterPage.DICOMDisplaySettings
If Not (dicomDisplaySettings Is Nothing) And dicomDisplaySettings.VOI Is Nothing Then
    dicomDisplaySettings.VOI = New ImGearVOITransform()
    dicomDisplaySettings.VOI.Window = ImGearVOIWindow.CreateFromChannelSpec(rasterPage.DIB.ChannelDepths(0), rasterPage.DIB.Signed)
End If
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


CreateFromMinMax Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : CreateFromMinMax Method
Window Minimum.
Window Maximum.
Creates Window transform from Window minimum and maximum values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateFromMinMax( _
   ByVal min As Integer, _
   ByVal max As Integer _
) As ImGearVOIWindow
'Usage

Dim min As Integer
Dim max As Integer
Dim value As ImGearVOIWindow

value = ImGearVOIWindow.CreateFromMinMax(min, max)
public static ImGearVOIWindow CreateFromMinMax(
   int min,
   int max
)
public: static ImGearVOIWindow CreateFromMinMax(
   int min,
   int max
)
public:
static ImGearVOIWindow CreateFromMinMax(
   int min,
   int max
)

Parameters

min
Window Minimum.
max
Window Maximum.

Return Value

ImGearVOIWindow structure object.
Remarks
This method creates Window transform from 32-bit integer Minimum and Maximum values. Please use CreateFromMinMax64 method if you are working with 17-32 bit per channel images.
Example
  • C#
ImGearVOIWindow window = ImGearVOIWindow.CreateFromMinMax(1024, 2048);
  • Visual Basic
Dim window As ImGearVOIWindow = ImGearVOIWindow.CreateFromMinMax(1024, 2048)
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


CreateFromMinMax64 Method
Example

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : CreateFromMinMax64 Method
Window Minimum.
Window Maximum.
Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateFromMinMax64( _
   ByVal min As Long, _
   ByVal max As Long _
) As ImGearVOIWindow
'Usage

Dim min As Long
Dim max As Long
Dim value As ImGearVOIWindow

value = ImGearVOIWindow.CreateFromMinMax64(min, max)
public static ImGearVOIWindow CreateFromMinMax64(
   long min,
   long max
)
public: static ImGearVOIWindow CreateFromMinMax64(
   long min,
   long max
)
public:
static ImGearVOIWindow CreateFromMinMax64(
   int64 min,
   int64 max
)

Parameters

min
Window Minimum.
max
Window Maximum.

Return Value

ImGearVOIWindow structure object.
Remarks
This method creates Window transform from Minimum and Maximum 64 bit values.
Example
  • C#
ImGearVOIWindow window64 = ImGearVOIWindow.CreateFromMinMax64(1024, 2048);
  • Visual Basic
Dim window64 As ImGearVOIWindow = ImGearVOIWindow.CreateFromMinMax64(1024, 2048)
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


%%PageItemTitle%% $$Properties$$

ImGearVOIWindow Structure Properties

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace : ImGearVOIWindow Structure

For a list of all members of this type, see ImGearVOIWindow members.

Public Properties
 | Name | Description
Public Property | Center | Gets or sets Window Center value.
Public Property | Center64 | Gets or sets Window Center value as 64 bit integer.
Public Property | Max | Gets Window Maximum value.
Public Property | Max64 | Gets Window Maximum value as 64 bit integer.
Public Property | Min | Gets Window Minimum value.
Public Property | Min64 | Gets Window Minimum value as 64 bit integer.
Public Property | Width | Gets or sets Window Width value.
Public Property | Width64 | Gets or sets Window Width value as 64 bit integer.
Top
See Also

Reference

ImGearVOIWindow Structure
ImageGear.Formats.DICOM Namespace


Center Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Center Property
Gets or sets Window Center value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Center As Integer
'Usage

Dim instance As ImGearVOIWindow
Dim value As Integer

instance.Center = value

value = instance.Center
public int Center {get; set;}
public: __property int get_Center();
public: __property void set_Center(
   int value
);
public:
property int Center {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
Remarks
This property provides access to Window Center value as a 32-bit integer. Please use Center64 property if you are working with 17-32 bit per channel images.

The default value is 0.

See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Center64 Property

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Center64 Property
Gets or sets Window Center value as 64 bit integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Center64 As Long
'Usage

Dim instance As ImGearVOIWindow
Dim value As Long

instance.Center64 = value

value = instance.Center64
public long Center64 {get; set;}
public: __property long get_Center64();
public: __property void set_Center64(
   long value
);
public:
property int64 Center64 {
   int64 get();
   void set (    int64 value);
}

Property Value

Any long integer value.
Remarks
This property provides access to Window Center value as 64 bit integer.

The default value is 0.

See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Max Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Max Property
Gets Window Maximum value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Max As Integer
'Usage

Dim instance As ImGearVOIWindow
Dim value As Integer

value = instance.Max
public int Max {get;}
public: __property int get_Max();
public:
property int Max {
   int get();
}

Property Value

Any integer number.
Remarks
This property returns maximum window value as a 32-bit integer. Please use Max64 property if you are working with 17-32 bit per channel images..
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Max64 Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Max64 Property
Gets Window Maximum value as 64 bit integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Max64 As Long
'Usage

Dim instance As ImGearVOIWindow
Dim value As Long

value = instance.Max64
public long Max64 {get;}
public: __property long get_Max64();
public:
property int64 Max64 {
   int64 get();
}

Property Value

Any long integer number.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Min Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Min Property
Gets Window Minimum value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Min As Integer
'Usage

Dim instance As ImGearVOIWindow
Dim value As Integer

value = instance.Min
public int Min {get;}
public: __property int get_Min();
public:
property int Min {
   int get();
}

Property Value

Any integer number.
Remarks
This property returns minimum window value as a 32-bit integer. Please use Min64 property if you are working with 17-32 bit per channel images.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Min64 Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Min64 Property
Gets Window Minimum value as 64 bit integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Min64 As Long
'Usage

Dim instance As ImGearVOIWindow
Dim value As Long

value = instance.Min64
public long Min64 {get;}
public: __property long get_Min64();
public:
property int64 Min64 {
   int64 get();
}

Property Value

Any long integer number.
See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Width Property (ImGearVOIWindow)

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Width Property
Gets or sets Window Width value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearVOIWindow
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Any integer number.
Remarks
This property provides access to Window Width value as a 32-bit integer. Please use Width64 property if you are working with 17-32 bit per channel images.

The default value is 0.

See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


Width64 Property

ImageGear22.Formats.Dicom Assembly > ImageGear.Formats.DICOM Namespace > ImGearVOIWindow Structure : Width64 Property
Gets or sets Window Width value as 64 bit integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width64 As Long
'Usage

Dim instance As ImGearVOIWindow
Dim value As Long

instance.Width64 = value

value = instance.Width64
public long Width64 {get; set;}
public: __property long get_Width64();
public: __property void set_Width64(
   long value
);
public:
property int64 Width64 {
   int64 get();
   void set (    int64 value);
}

Property Value

Any long integer number.
Remarks
This property provides access to Window Width value as 64 bit integer.

The default value is 0.

See Also

Reference

ImGearVOIWindow Structure
ImGearVOIWindow Members


ImageGear22.Formats.Jpeg2k Assembly
Namespaces
Namespace | Description
ImageGear.Formats.JPEG2K | This namespace provides methods to create JP2 and JPX formats as well as enumerations values for these formats filters control parameters.


ImageGear.Formats.JPEG2K Namespace
Inheritance Hierarchy
ImageGear22.Formats.Jpeg2k Assembly : ImageGear.Formats.JPEG2K Namespace
This namespace provides methods to create JP2 and JPX formats as well as enumerations values for these formats filters control parameters.
Classes
 | Class | Description
Class | ImGearJPEG2K | Core JPEG2K class is used to create JP2, JPX formats.
Enumerations
 | Enumeration | Description
Enumeration | ImGearJPEG2KCodeBlockStyles | Specifies JPEG2K code block styles.
Enumeration | ImGearJPEG2KCompressions | Specifies JPEG2K compression types.
Enumeration | ImGearJPEG2KCpuOptimizationMode | Specifies CPU optimization modes.
Enumeration | ImGearJPEG2KFilters | Specifies JPEG2K filters.
Enumeration | ImGearJPEG2KModes | Specifies JPEG2K codestream error checking and recovery modes.
Enumeration | ImGearJPEG2KProgressionOrders | Specifies JPEG2K progression orders.
Enumeration | ImGearJPEG2KType | Specifies JPEG2K file format types.
See Also

Reference

ImageGear22.Formats.Jpeg2k Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.JPEG2K Namespace Inheritance Hierarchy
ImageGear22.Formats.Jpeg2k Assembly : ImageGear.Formats.JPEG2K Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.JPEG2K.ImGearJPEG2K
See Also

Reference

ImageGear22.Formats.Jpeg2k Assembly


%%PageItemTitle%%

ImGearJPEG2K Class
Members

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2K Class
Core JPEG2K class is used to create JP2, JPX formats.
Object Model
ImGearJPEG2K ClassIImGearFormat InterfaceIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearJPEG2K
'Usage

Dim instance As ImGearJPEG2K
public sealed class ImGearJPEG2K
public __gc __sealed class ImGearJPEG2K
public ref class ImGearJPEG2K sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.JPEG2K.ImGearJPEG2K

See Also

Reference

ImGearJPEG2K Members
ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%% $$Members$$

ImGearJPEG2K Class Members
Methods

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2K Class

The following tables list the members exposed by ImGearJPEG2K.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateJP2Format | Overloaded. Creates an instance of JP2 format.
static (Shared in Visual Basic) | CreateJPXFormat | Overloaded. Creates an instance of JPX format.
Top
See Also

Reference

ImGearJPEG2K Class
ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%% $$Methods$$

ImGearJPEG2K Class Methods

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2K Class

For a list of all members of this type, see ImGearJPEG2K members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateJP2Format | Overloaded. Creates an instance of JP2 format.
static (Shared in Visual Basic) | CreateJPXFormat | Overloaded. Creates an instance of JPX format.
Top
See Also

Reference

ImGearJPEG2K Class
ImageGear.Formats.JPEG2K Namespace


CreateJP2Format Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class : CreateJP2Format Method
Creates an instance of JP2 format.
Overload List
Overload | Description
CreateJP2Format() | Creates an instance of JP2 format.
CreateJP2Format(String) | Creates an instance of JP2 format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members


CreateJP2Format() Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class > CreateJP2Format Method : CreateJP2Format() Method
Creates an instance of JP2 format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateJP2Format() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearJPEG2K.CreateJP2Format()
public static IImGearFormat CreateJP2Format()
public: static IImGearFormat* CreateJP2Format();
public:
static IImGearFormat^ CreateJP2Format();

Return Value

An instance of JP2 format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members
Overload List
ImGearJPEG2K Class
IImGearFormat Interface


CreateJP2Format(String) Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class > CreateJP2Format Method : CreateJP2Format(String) Method
Path to a folder to load JPEG2K native libraries from. If an empty string is passed, ImageGear attempts to load native libraries from current directory.
Creates an instance of JP2 format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateJP2Format( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearJPEG2K.CreateJP2Format(libraryPath)
public static IImGearFormat CreateJP2Format(
   string libraryPath
)
public: static IImGearFormat* CreateJP2Format(
   string* libraryPath
)
public:
static IImGearFormat^ CreateJP2Format(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load JPEG2K native libraries from. If an empty string is passed, ImageGear attempts to load native libraries from current directory.

Return Value

An instance of JP2 format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members
Overload List
ImGearJPEG2K Class
IImGearFormat Interface


CreateJPXFormat Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class : CreateJPXFormat Method
Creates an instance of JPX format.
Overload List
Overload | Description
CreateJPXFormat() | Creates an instance of JPX format.
CreateJPXFormat(String) | Creates an instance of JPX format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members


CreateJPXFormat() Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class > CreateJPXFormat Method : CreateJPXFormat() Method
Creates an instance of JPX format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateJPXFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearJPEG2K.CreateJPXFormat()
public static IImGearFormat CreateJPXFormat()
public: static IImGearFormat* CreateJPXFormat();
public:
static IImGearFormat^ CreateJPXFormat();

Return Value

An instance of JPX format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members
Overload List
ImGearJPEG2K Class
IImGearFormat Interface


CreateJPXFormat(String) Method

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace > ImGearJPEG2K Class > CreateJPXFormat Method : CreateJPXFormat(String) Method
Path to a folder to load JPEG2K native libraries from. If an empty string is passed, ImageGear attempts to load native libraries from current directory.
Creates an instance of JPX format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateJPXFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearJPEG2K.CreateJPXFormat(libraryPath)
public static IImGearFormat CreateJPXFormat(
   string libraryPath
)
public: static IImGearFormat* CreateJPXFormat(
   string* libraryPath
)
public:
static IImGearFormat^ CreateJPXFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load JPEG2K native libraries from. If an empty string is passed, ImageGear attempts to load native libraries from current directory.

Return Value

An instance of JPX format.
See Also

Reference

ImGearJPEG2K Class
ImGearJPEG2K Members
Overload List
ImGearJPEG2K Class
IImGearFormat Interface


%%PageItemTitle%%

ImGearJPEG2KCodeBlockStyles Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KCodeBlockStyles Enumeration
Specifies JPEG2K code block styles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KCodeBlockStyles
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KCodeBlockStyles
public enum ImGearJPEG2KCodeBlockStyles : System.Enum
__value public enum ImGearJPEG2KCodeBlockStyles : public System.Enum
public enum class ImGearJPEG2KCodeBlockStyles : public System.Enum
Members
Member | Value | Description
ALL_OFF | 0 | No code block styles.
BYPASS | 1 | Selective MQ coder bypass.
CAUSAL | 8 | Stripe-causal context formation.
ERTERM | 16 | Predictable tremination.
RESET | 2 | Reset context states.
RESTART | 4 | Terminate and restart MQ coder.
SEGMARK | 32 | Segmentation marker.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KCodeBlockStyles

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KCompressions Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KCompressions Enumeration
Specifies JPEG2K compression types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KCompressions
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KCompressions
public enum ImGearJPEG2KCompressions : System.Enum
__value public enum ImGearJPEG2KCompressions : public System.Enum
public enum class ImGearJPEG2KCompressions : public System.Enum
Members
Member | Value | Description
LOSSLESS | 1 | Lossless compression.
LOSSY | 0 | Lossy compression.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KCompressions

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KCpuOptimizationMode Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KCpuOptimizationMode Enumeration
Specifies CPU optimization modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KCpuOptimizationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KCpuOptimizationMode
public enum ImGearJPEG2KCpuOptimizationMode : System.Enum
__value public enum ImGearJPEG2KCpuOptimizationMode : public System.Enum
public enum class ImGearJPEG2KCpuOptimizationMode : public System.Enum
Members
Member | Value | Description
DisableAll | 1 | Disables all CPU-specific optimizations.
DisableMmx | 2 | Disables MMX and all later optimizations.
DisablePentium2 | 3 | Disables Pentium 2 and all later optimizations.
DisablePentium3 | 4 | Disables Pentium 3 (SSE) and all later optimizations.
DisablePentium4 | 5 | Disables Pentium 4 (SSE2) and all later optimizations.
EnableAll | 0 | Enables all CPU-specific optimizations.
Remarks
This enumeration is used by JPEG2K CpuOptimizationMode control parameter to enable or disable CPU specific optimizations. The CPU optimization features can be disabled in case if they are not supported by the OS.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KCpuOptimizationMode

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KFilters Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KFilters Enumeration
Specifies JPEG2K filters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KFilters
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KFilters
public enum ImGearJPEG2KFilters : System.Enum
__value public enum ImGearJPEG2KFilters : public System.Enum
public enum class ImGearJPEG2KFilters : public System.Enum
Members
Member | Value | Description
AUTO | -1 | Automatically selects the best transform depending on image type. It selects irreversible transform for true color and grayscale images, and reversible transform for paletted images.
IRREVERSIBLE | 1 | Irreversible transform based on Daubechies' 9/7 filter.
REVERSIBLE | 0 | Reversible transform based on 5/3 filter.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KFilters

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KModes Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KModes Enumeration
Specifies JPEG2K codestream error checking and recovery modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KModes
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KModes
public enum ImGearJPEG2KModes : System.Enum
__value public enum ImGearJPEG2KModes : public System.Enum
public enum class ImGearJPEG2KModes : public System.Enum
Members
Member | Value | Description
FAST | 0 | The fast mode is used by default. In this case, compliance is assumed and checking is minimized; there is no attempt to recover from any errors.
FUSSY | 1 | In the fussy mode, the code-stream management machinery makes a serious attempt to identify compliance violations and generates an appropriate terminal error message if it finds one.
RESILIENT | 2 | In the resilient mode, the code-stream management machinery makes a serious attempt to both detect and recover from errors in the code-stream. We attempt to guarantee that decompression will not fail, so long as the main header is uncorrupted and there is only one tile with one tile-part.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KModes

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KProgressionOrders Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KProgressionOrders Enumeration
Specifies JPEG2K progression orders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KProgressionOrders
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KProgressionOrders
public enum ImGearJPEG2KProgressionOrders : System.Enum
__value public enum ImGearJPEG2KProgressionOrders : public System.Enum
public enum class ImGearJPEG2KProgressionOrders : public System.Enum
Members
Member | Value | Description
CPRL | 4 | Component-Position-Resolution-Layer progression.
LRCP | 0 | Layer-Resolution-Component-Position progression.
PCRL | 3 | Position-Component-Resolution-Layer progression.
RLCP | 1 | Resolution-Layer-Component-Position progression.
RPCL | 2 | Resolution-Position-Component-Layer progression.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KProgressionOrders

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


%%PageItemTitle%%

ImGearJPEG2KType Enumeration

ImageGear22.Formats.Jpeg2k Assembly > ImageGear.Formats.JPEG2K Namespace : ImGearJPEG2KType Enumeration
Specifies JPEG2K file format types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEG2KType
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEG2KType
public enum ImGearJPEG2KType : System.Enum
__value public enum ImGearJPEG2KType : public System.Enum
public enum class ImGearJPEG2KType : public System.Enum
Members
Member | Value | Description
CODESTREAM | 0 | JPEG 2000 code stream.
FILE_FORMAT | 1 | JP2 file format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.JPEG2K.ImGearJPEG2KType

See Also

Reference

ImageGear.Formats.JPEG2K Namespace


ImageGear22.Formats.Office Assembly
Namespaces
Namespace | Description
ImageGear.Formats.Office | The ImageGear.Formats.Office namespace provides support for Microsoft Office formats.


ImageGear.Formats.Office Namespace
Inheritance Hierarchy
ImageGear22.Formats.Office Assembly : ImageGear.Formats.Office Namespace
The ImageGear.Formats.Office namespace provides support for Microsoft Office formats.
Classes
 | Class | Description
Class | ImGearExcelBookDocument | A document object that contains pages which represent an Excel document, where each page is a single sheet in the workbook.
Class | ImGearExcelBookPage | A page object that represents an entire sheet from an Excel workbook as a single page.
Class | ImGearExcelSheetDocument | A document object that contains pages which represent an Excel sheet that has been split into one or more pages.
Class | ImGearExcelSheetPage | A page object that represents a single page of an Excel sheet that has been paginated into smaller pages.
Class | ImGearOffice | Provides general Office formats functionality.
Class | ImGearPowerPointDocument | Represents PowerPoint Documents.
Class | ImGearPowerPointPage | Represents PowerPoint Document page.
Class | ImGearPowerPointTextExtractionOptions | Represents set of PowerPoint text extraction options.
Class | ImGearWordDocument | Represents Word Documents.
Class | ImGearWordPage | Represents Word Document page.
Class | ImGearWordTextExtractionOptions | Represents set of Word text extraction options.
Enumerations
 | Enumeration | Description
Enumeration | ImGearExcelPageOrder | Options for ordering the pages of a sheet during pagination.
Enumeration | ImGearPowerPointTextExtractionMethod | Specifies text extraction methods from PowerPoint document.
Enumeration | ImGearWordLineEndingType | Specifies line ending sequence for text extraction.
Enumeration | ImGearWordRenderOptions | Defines ImageGear Word rendering options.
Enumeration | ImGearWordTextExtractionAreas | Specifies text extraction areas of Word document.
Enumeration | ImGearWordTextExtractionMethod | Specifies text extraction methods from Word document.
See Also

Reference

ImageGear22.Formats.Office Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.Office Namespace Inheritance Hierarchy
ImageGear22.Formats.Office Assembly : ImageGear.Formats.Office Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearExcelBookDocument
ImageGear.Formats.Office.ImGearExcelSheetDocument
ImageGear.Formats.Office.ImGearPowerPointDocument
ImageGear.Formats.Office.ImGearWordDocument
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearExcelBookPage
ImageGear.Formats.Office.ImGearExcelSheetPage
ImageGear.Formats.Office.ImGearPowerPointPage
ImageGear.Formats.Office.ImGearWordPage
ImageGear.Formats.Office.ImGearOffice
ImageGear.Formats.Office.ImGearPowerPointTextExtractionOptions
ImageGear.Formats.Office.ImGearWordTextExtractionOptions
See Also

Reference

ImageGear22.Formats.Office Assembly


%%PageItemTitle%%

ImGearExcelBookDocument Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookDocument Class
A document object that contains pages which represent an Excel document, where each page is a single sheet in the workbook.
Object Model
ImGearExcelBookDocument ClassImGearDocument ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExcelBookDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearExcelBookDocument
public class ImGearExcelBookDocument : ImageGear.Core.ImGearDocument
public __gc class ImGearExcelBookDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearExcelBookDocument : public ImageGear.Core.ImGearDocument
Remarks

This class is the top level of the Excel class object hierarchy. It is used to access the individual sheets within the workbook of the document. After initially loading the document, each sheet is available as an ImGearExcelBookPage object accessible from the ImageGear.Core.ImGearDocument.Pages property. Each page will contain one entire sheet, which can be displayed or printed. If desired, the ImGearExcelBookPage object can be further paginated by calling the ImGearExcelBookPage.Repaginate method and specifying a custom, user-defined page size, or letting the page size be defined by the Excel document.

The document can be created and processed in any thread with any apartment state - STA or MTA. But if it should be displayed as well, then there are some concepts which should be taken into account.

  • In WPF display scale mode the document must be created in UI thread, otherwise System.InvalidOperationException will be thrown, stating that "The calling thread cannot access this object because a different thread owns it". This is requirement of Windows Presentation Foundation.
  • In Native display scale mode, which is the default for ImageGear, there are no restrictions for displaying Excel documents in a multi-threaded environment.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearExcelBookDocument

See Also

Reference

ImGearExcelBookDocument Members
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Members$$

ImGearExcelBookDocument Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookDocument Class

The following tables list the members exposed by ImGearExcelBookDocument.

Public Properties
 | Name | Description
Public Property | Pages | Overridden. Gets the list of pages available in the Excel document.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the current Excel workbook.
Top
See Also

Reference

ImGearExcelBookDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Fields$$

ImGearExcelBookDocument Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookDocument Class

For a list of all members of this type, see ImGearExcelBookDocument members.

See Also

Reference

ImGearExcelBookDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Methods$$

ImGearExcelBookDocument Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookDocument Class

For a list of all members of this type, see ImGearExcelBookDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the current Excel workbook.
Top
See Also

Reference

ImGearExcelBookDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


Clone Method (ImGearExcelBookDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookDocument Class : Clone Method
Creates a deep copy of the current Excel workbook.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearExcelBookDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

ImGearExcelBookDocument instance.
Remarks

This method will create a complete copy of the instance, including the underlying spreadsheet document. The new instance will be completely independent of the instance from which it was cloned.

See Also

Reference

ImGearExcelBookDocument Class
ImGearExcelBookDocument Members


Dispose Method (ImGearExcelBookDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearExcelBookDocument Class
ImGearExcelBookDocument Members


Dispose(Boolean) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearExcelBookDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearExcelBookDocument Class
ImGearExcelBookDocument Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearExcelBookDocument Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookDocument Class

For a list of all members of this type, see ImGearExcelBookDocument members.

Public Properties
 | Name | Description
Public Property | Pages | Overridden. Gets the list of pages available in the Excel document.
Top
See Also

Reference

ImGearExcelBookDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


Pages Property (ImGearExcelBookDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookDocument Class : Pages Property
Gets the list of pages available in the Excel document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearExcelBookDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
Remarks
Returns a readonly list of pages available in the Excel document.
See Also

Reference

ImGearExcelBookDocument Class
ImGearExcelBookDocument Members
ImGearDocumentPageArray Class


%%PageItemTitle%%

ImGearExcelBookPage Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookPage Class
A page object that represents an entire sheet from an Excel workbook as a single page.
Object Model
ImGearExcelBookPage ClassImGearPage ClassImGearRasterPage ClassImGearExcelSheetDocument Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExcelBookPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearExcelBookPage
public class ImGearExcelBookPage : ImageGear.Core.ImGearVectorPage
public __gc class ImGearExcelBookPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearExcelBookPage : public ImageGear.Core.ImGearVectorPage
Remarks

This class is used to display or print the entire sheet of an Excel document as a single page. To break a sheet into smaller pages displaying or printing, see the Repaginate(Double,Double) method.

Note: Use caution when displaying or printing a sheet as a single page. Because of the large sizes that are possible with Excel sheets, it’s possible that the memory necessary to render the page will exceed the resources of the system. In general, sheets with less than 20,000 cells are safe for rendering as a single page on a modern system. Though keep in mind, the larger the sheet the more time that will be needed to render the page. It is recommended that the paginated ImGearExcelSheetPage objects be used for displaying or printing by default unless the size the worksheets are known.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearExcelBookPage

See Also

Reference

ImGearExcelBookPage Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearExcelBookPage Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookPage Class

The following tables list the members exposed by ImGearExcelBookPage.

Public Properties
 | Name | Description
Public Property | IsHidden | Gets a value indicating whether the page (i.e. associated sheet) is hidden.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a copy of the current Excel workbook page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the Excel workbook page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Public Method | Repaginate | Overloaded. Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Top
See Also

Reference

ImGearExcelBookPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Fields$$

ImGearExcelBookPage Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookPage Class

For a list of all members of this type, see ImGearExcelBookPage members.

See Also

Reference

ImGearExcelBookPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Methods$$

ImGearExcelBookPage Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookPage Class

For a list of all members of this type, see ImGearExcelBookPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a copy of the current Excel workbook page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the Excel workbook page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Public Method | Repaginate | Overloaded. Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Top
See Also

Reference

ImGearExcelBookPage Class
ImageGear.Formats.Office Namespace


Clone Method (ImGearExcelBookPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class : Clone Method
Creates a copy of the current Excel workbook page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearExcelBookPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImGearExcelBookPage instance.
Remarks

The new instance returned by this method will be a deep copy, in that it will copy all the internal content needed for displaying or printing. However, it will have no connection to the document which the object this instance was cloned from was attached to.

The ReleaseRenderCache method will have no effect on cloned instances. Once you release all of your references to the clone it will be made available for garbage collection.

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members


Rasterize Method (ImGearExcelBookPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class : Rasterize Method
Rasterizes the Excel workbook page using the default parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the Excel workbook page using the default parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the Excel workbook page using provided bit depth and resolution parameters.
Rasterize(Double,Double) | Rasterizes the Excel workbook page using the provided parameters.
See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members


Rasterize() Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Rasterize Method : Rasterize() Method
Rasterizes the Excel workbook page using the default parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearExcelBookPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

Stand-alone instance of ImageGear.Core.ImGearRasterPage class.
Remarks

This method rasterizes the current vector page into a raster page.

The page is rasterized with default parameters of:

  • RGB color space
  • 24 bits per pixel depth
  • 96 x 96 dpi

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Excel workbook page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearExcelBookPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image will have RGB color space with 24 bits per pixel depth.
See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List
ImGearRasterPage Class


Rasterize(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Rasterize Method : Rasterize(Double,Double) Method
This parameter specifies the horizontal resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Excel workbook page using the provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Rasterize( _
   ByVal resolutionX As Double, _
   ByVal resolutionY As Double _
) As ImGearRasterPage
'Usage

Dim instance As ImGearExcelBookPage
Dim resolutionX As Double
Dim resolutionY As Double
Dim value As ImGearRasterPage

value = instance.Rasterize(resolutionX, resolutionY)
public ImGearRasterPage Rasterize(
   double resolutionX,
   double resolutionY
)
public: ImGearRasterPage* Rasterize(
   double resolutionX,
   double resolutionY
)
public:
ImGearRasterPage^ Rasterize(
   double resolutionX,
   double resolutionY
)

Parameters

resolutionX
This parameter specifies the horizontal resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
Remarks

The DIB of output raster image will have an RGB color space with 24 bits per pixel depth.

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List


ReleaseRenderCache Method (ImGearExcelBookPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class : ReleaseRenderCache Method
Clears the internal cache of this page, which contains data used for rendering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseRenderCache()
'Usage

Dim instance As ImGearExcelBookPage

instance.ReleaseRenderCache()
public void ReleaseRenderCache()
public: void ReleaseRenderCache();
public:
void ReleaseRenderCache();
Remarks

During normal operation, ImGearExcelBookPage page will not render its underlying content until it's certainly needed for display or printing. Once it does, however, the rendered content will be cached internally for quick access in the case it is needed again.

There are situations where this behavior is not desired and where this method can help. For example, if you are looping through all pages of a document to print them, each page need only be accessed for a short period of time, after which it is no longer needed. However, because each page will cache its rendered content, the processes memory will continue to grow as each page is printed and will only be released when the parent document is no longer referenced. If the sheet is very large, all the memory of the process could be exhausted while the pages are still being accessed.

Calling this method after accessing a page for display or printing will release the internal reference to the rendered content. The rendered content will be recreated later if it is needed.

This method has no effect on an instance created by the Clone method. A cloned instance has no connection to the original spreadsheet data, thus cannot regenerate the rendered content were it to be cleared.

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members


Repaginate Method (ImGearExcelBookPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class : Repaginate Method
Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Overload List
Overload | Description
Repaginate(Double,Double) | Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Repaginate(Double,Double,ImGearExcelPageOrder) | Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Repaginate(Double,Double,Boolean) | Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Repaginate(Double,Double,ImGearExcelPageOrder,Boolean) | Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members


Repaginate(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Repaginate Method : Repaginate(Double,Double) Method
The desired width of the page in pixels.
The desired height of the page in pixels.
Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double _
) As ImGearExcelSheetDocument
'Usage

Dim instance As ImGearExcelBookPage
Dim pageWidth As Double
Dim pageHeight As Double
Dim value As ImGearExcelSheetDocument

value = instance.Repaginate(pageWidth, pageHeight)
public ImGearExcelSheetDocument Repaginate(
   double pageWidth,
   double pageHeight
)
public: ImGearExcelSheetDocument* Repaginate(
   double pageWidth,
   double pageHeight
)
public:
ImGearExcelSheetDocument^ Repaginate(
   double pageWidth,
   double pageHeight
)

Parameters

pageWidth
The desired width of the page in pixels.
pageHeight
The desired height of the page in pixels.

Return Value

A new ImGearExcelSheetDocument instance.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions are not sufficient to represent any content, including page margins.
Remarks

Page dimensions of the sheet can be stored in the SpreadsheetML package. ImageGear retrieves them (if any) and applies upon loading of the document. If no page dimensions are defined within the package, the default letter size of 8.5"(width) x 11"(height) (1" is equal to 96 pixels) will be used.

Set both pageWidth and pageHeight parameters to 0 to use available page dimensions in the document or the default letter size.

If valid (non-zero) dimensions are supplied in the pageWidth and pageHeight parameters, then any page dimensions defined in the original Excel document are ignored and the parameter values are used.

The default page dimensions are 816 x 1056 pixels.

This method overload will use the default page order ImGearExcelPageOrder.DownThenOver

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List


Repaginate(Double,Double,ImGearExcelPageOrder) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Repaginate Method : Repaginate(Double,Double,ImGearExcelPageOrder) Method
The desired width of the page in pixels.
The desired height of the page in pixels.
The desired order of the pages contained in the ImGearExcelSheetDocument returned by this method.
Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double, _
   ByVal pageOrder As ImGearExcelPageOrder _
) As ImGearExcelSheetDocument
'Usage

Dim instance As ImGearExcelBookPage
Dim pageWidth As Double
Dim pageHeight As Double
Dim pageOrder As ImGearExcelPageOrder
Dim value As ImGearExcelSheetDocument

value = instance.Repaginate(pageWidth, pageHeight, pageOrder)
public ImGearExcelSheetDocument Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder
)
public: ImGearExcelSheetDocument* Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder
)
public:
ImGearExcelSheetDocument^ Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder
)

Parameters

pageWidth
The desired width of the page in pixels.
pageHeight
The desired height of the page in pixels.
pageOrder
The desired order of the pages contained in the ImGearExcelSheetDocument returned by this method.

Return Value

A new ImGearExcelSheetDocument instance.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions are not sufficient to represent any content, including page margins.
Remarks

Page dimensions of the sheet can be stored in the SpreadsheetML package. ImageGear retrieves them (if any) and applies upon loading of the document. If no page dimensions are defined within the package, the default letter size of 8.5"(width) x 11"(height) (1" is equal to 96 pixels) will be used.

Set both pageWidth and pageHeight parameters to 0 to use available page dimensions in the document or the default letter size.

If valid (non-zero) dimensions are supplied in the pageWidth and pageHeight parameters, then any page dimensions defined in the original Excel document are ignored and the parameter values are used.

The default page dimensions are 816 x 1056 pixels.

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List


Repaginate(Double,Double,Boolean) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Repaginate Method : Repaginate(Double,Double,Boolean) Method
The desired width of the page in pixels.
The desired height of the page in pixels.
The flag indicating that only cells within Print Area should be paginated, if that range is defined.
Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double, _
   ByVal usePrintArea As Boolean _
) As ImGearExcelSheetDocument
'Usage

Dim instance As ImGearExcelBookPage
Dim pageWidth As Double
Dim pageHeight As Double
Dim usePrintArea As Boolean
Dim value As ImGearExcelSheetDocument

value = instance.Repaginate(pageWidth, pageHeight, usePrintArea)
public ImGearExcelSheetDocument Repaginate(
   double pageWidth,
   double pageHeight,
   bool usePrintArea
)
public: ImGearExcelSheetDocument* Repaginate(
   double pageWidth,
   double pageHeight,
   bool usePrintArea
)
public:
ImGearExcelSheetDocument^ Repaginate(
   double pageWidth,
   double pageHeight,
   bool usePrintArea
)

Parameters

pageWidth
The desired width of the page in pixels.
pageHeight
The desired height of the page in pixels.
usePrintArea
The flag indicating that only cells within Print Area should be paginated, if that range is defined.

Return Value

A new ImGearExcelSheetDocument instance.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions are not sufficient to represent any content, including page margins.
Remarks

Page dimensions of the sheet can be stored in the SpreadsheetML package. ImageGear retrieves them (if any) and applies upon loading of the document. If no page dimensions are defined within the package, the default letter size of 8.5"(width) x 11"(height) (1" is equal to 96 pixels) will be used.

Set both pageWidth and pageHeight parameters to 0 to use available page dimensions in the document or the default letter size.

If valid (non-zero) dimensions are supplied in the pageWidth and pageHeight parameters, then any page dimensions defined in the original Excel document are ignored and the parameter values are used.

The default page dimensions are 816 x 1056 pixels.

This method overload will use the default page order ImGearExcelPageOrder.DownThenOver

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List


Repaginate(Double,Double,ImGearExcelPageOrder,Boolean) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class > Repaginate Method : Repaginate(Double,Double,ImGearExcelPageOrder,Boolean) Method
The desired width of the page in pixels.
The desired height of the page in pixels.
The desired order of the pages contained in the ImGearExcelSheetDocument returned by this method.
The flag indicating that only cells within Print Area should be paginated, if that range is defined.
Forces pagination of the sheet's content and returns a new ImGearExcelSheetDocument object containing the new pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double, _
   ByVal pageOrder As ImGearExcelPageOrder, _
   ByVal usePrintArea As Boolean _
) As ImGearExcelSheetDocument
'Usage

Dim instance As ImGearExcelBookPage
Dim pageWidth As Double
Dim pageHeight As Double
Dim pageOrder As ImGearExcelPageOrder
Dim usePrintArea As Boolean
Dim value As ImGearExcelSheetDocument

value = instance.Repaginate(pageWidth, pageHeight, pageOrder, usePrintArea)
public ImGearExcelSheetDocument Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder,
   bool usePrintArea
)
public: ImGearExcelSheetDocument* Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder,
   bool usePrintArea
)
public:
ImGearExcelSheetDocument^ Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearExcelPageOrder pageOrder,
   bool usePrintArea
)

Parameters

pageWidth
The desired width of the page in pixels.
pageHeight
The desired height of the page in pixels.
pageOrder
The desired order of the pages contained in the ImGearExcelSheetDocument returned by this method.
usePrintArea
The flag indicating that only cells within Print Area should be paginated, if that range is defined.

Return Value

A new ImGearExcelSheetDocument instance.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions are not sufficient to represent any content, including page margins.
Remarks

Page dimensions of the sheet can be stored in the SpreadsheetML package. ImageGear retrieves them (if any) and applies upon loading of the document. If no page dimensions are defined within the package, the default letter size of 8.5"(width) x 11"(height) (1" is equal to 96 pixels) will be used.

Set both pageWidth and pageHeight parameters to 0 to use available page dimensions in the document or the default letter size.

If valid (non-zero) dimensions are supplied in the pageWidth and pageHeight parameters, then any page dimensions defined in the original Excel document are ignored and the parameter values are used.

The default page dimensions are 816 x 1056 pixels.

See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearExcelBookPage Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelBookPage Class

For a list of all members of this type, see ImGearExcelBookPage members.

Public Properties
 | Name | Description
Public Property | IsHidden | Gets a value indicating whether the page (i.e. associated sheet) is hidden.
Top
See Also

Reference

ImGearExcelBookPage Class
ImageGear.Formats.Office Namespace


IsHidden Property

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelBookPage Class : IsHidden Property
Gets a value indicating whether the page (i.e. associated sheet) is hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsHidden As Boolean
'Usage

Dim instance As ImGearExcelBookPage
Dim value As Boolean

value = instance.IsHidden
public bool IsHidden {get;}
public: __property bool get_IsHidden();
public:
property bool IsHidden {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearExcelBookPage Class
ImGearExcelBookPage Members


%%PageItemTitle%%

ImGearExcelSheetDocument Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetDocument Class
A document object that contains pages which represent an Excel sheet that has been split into one or more pages.
Object Model
ImGearExcelSheetDocument ClassImGearDocument ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExcelSheetDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearExcelSheetDocument
public class ImGearExcelSheetDocument : ImageGear.Core.ImGearDocument
public __gc class ImGearExcelSheetDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearExcelSheetDocument : public ImageGear.Core.ImGearDocument
Remarks

A new instance of this class is returned by the Repaginate(Double,Double) method. This method is particularly helpful when the sheets of an Excel document are large and displaying or printing each one as a single page is impractical or impossible.

The document can be created and processed in any thread with any apartment state - STA or MTA. But if it should be displayed as well, then there are some concepts which should be taken into account.

  • In WPF display scale mode the document must be created in UI thread, otherwise System.InvalidOperationException will be thrown, stating that "The calling thread cannot access this object because a different thread owns it". This is requirement of Windows Presentation Foundation.
  • In Native display scale mode, which is the default for ImageGear, there are no restrictions for displaying Excel documents in a multi-threaded environment.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearExcelSheetDocument

See Also

Reference

ImGearExcelSheetDocument Members
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Members$$

ImGearExcelSheetDocument Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetDocument Class

The following tables list the members exposed by ImGearExcelSheetDocument.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the height, in pixels, of the pages of the sheet.
Public Property | Pages | Overridden. Gets the list of pages available in the Excel sheet.
Public Property | PageWidth | Gets the width, in pixels, of the pages of the sheet.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the current Excel sheet document.
Top
See Also

Reference

ImGearExcelSheetDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Fields$$

ImGearExcelSheetDocument Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetDocument Class

For a list of all members of this type, see ImGearExcelSheetDocument members.

See Also

Reference

ImGearExcelSheetDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Methods$$

ImGearExcelSheetDocument Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetDocument Class

For a list of all members of this type, see ImGearExcelSheetDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a deep copy of the current Excel sheet document.
Top
See Also

Reference

ImGearExcelSheetDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


Clone Method (ImGearExcelSheetDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetDocument Class : Clone Method
Creates a deep copy of the current Excel sheet document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearExcelSheetDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

ImGearExcelSheetDocument instance.
Remarks

This method will create a deep copy of the Excel sheet document and it's underlying contents. However, it will not modify the orginal Excel document in any way, like by adding a sheet to it.

The cloned document will operate independently from the document it was cloned from as it contains a copy of all the pages.

See Also

Reference

ImGearExcelSheetDocument Class
ImGearExcelSheetDocument Members


%%PageItemTitle%% $$Properties$$

ImGearExcelSheetDocument Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetDocument Class

For a list of all members of this type, see ImGearExcelSheetDocument members.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the height, in pixels, of the pages of the sheet.
Public Property | Pages | Overridden. Gets the list of pages available in the Excel sheet.
Public Property | PageWidth | Gets the width, in pixels, of the pages of the sheet.
Top
See Also

Reference

ImGearExcelSheetDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


PageHeight Property (ImGearExcelSheetDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetDocument Class : PageHeight Property
Gets the height, in pixels, of the pages of the sheet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageHeight As Double
'Usage

Dim instance As ImGearExcelSheetDocument
Dim value As Double

value = instance.PageHeight
public double PageHeight {get;}
public: __property double get_PageHeight();
public:
property double PageHeight {
   double get();
}

Property Value

Integer value.
Remarks

Page dimensions of a sheet can be stored in the SpreadsheetML package. ImageGear retrieves them, if available, and applies them when the sheet is paginated. Alternatively, you can specify your own page size to use.

If the page size is not defined for the sheet and the caller has not specified a page size to use, ImageGear will use the standard letter size 8.5"(width) x 11"(height), where 1" is equal to 96 pixels.

The default value will be the page width, in pixels, defined in the Excel Spreadsheet for the active sheet, else 1056 pixels.

See Also

Reference

ImGearExcelSheetDocument Class
ImGearExcelSheetDocument Members


Pages Property (ImGearExcelSheetDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetDocument Class : Pages Property
Gets the list of pages available in the Excel sheet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearExcelSheetDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
Remarks
Returns a readonly list of pages available in the Excel sheet.
See Also

Reference

ImGearExcelSheetDocument Class
ImGearExcelSheetDocument Members
ImGearDocumentPageArray Class


PageWidth Property (ImGearExcelSheetDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetDocument Class : PageWidth Property
Gets the width, in pixels, of the pages of the sheet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageWidth As Double
'Usage

Dim instance As ImGearExcelSheetDocument
Dim value As Double

value = instance.PageWidth
public double PageWidth {get;}
public: __property double get_PageWidth();
public:
property double PageWidth {
   double get();
}

Property Value

Integer value.
Remarks

Page dimensions of a sheet can be stored in the SpreadsheetML package. ImageGear retrieves them, if available, and applies them when the sheet is paginated. Alternatively, you can specify your own page size to use.

If the page size is not defined for the sheet and the caller has not specified a page size to use, ImageGear will use the standard letter size 8.5"(width) x 11"(height), where 1" is equal to 96 pixels.

The default value will be the page width, in pixels, defined in the sheet, else 816 pixels.

See Also

Reference

ImGearExcelSheetDocument Class
ImGearExcelSheetDocument Members


%%PageItemTitle%%

ImGearExcelSheetPage Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetPage Class
A page object that represents a single page of an Excel sheet that has been paginated into smaller pages.
Object Model
ImGearExcelSheetPage ClassImGearPage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExcelSheetPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearExcelSheetPage
public class ImGearExcelSheetPage : ImageGear.Core.ImGearVectorPage
public __gc class ImGearExcelSheetPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearExcelSheetPage : public ImageGear.Core.ImGearVectorPage
Remarks
The class is used to display or print a single sheet as a series of smaller pages. To view a sheet as a single page, see the ImGearExcelBookPage class.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearExcelSheetPage

See Also

Reference

ImGearExcelSheetPage Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearExcelSheetPage Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetPage Class

The following tables list the members exposed by ImGearExcelSheetPage.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a copy of the current Excel sheet page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the Excel sheet page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
See Also

Reference

ImGearExcelSheetPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Fields$$

ImGearExcelSheetPage Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetPage Class

For a list of all members of this type, see ImGearExcelSheetPage members.

See Also

Reference

ImGearExcelSheetPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Properties$$

ImGearExcelSheetPage Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetPage Class

For a list of all members of this type, see ImGearExcelSheetPage members.

See Also

Reference

ImGearExcelSheetPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Methods$$

ImGearExcelSheetPage Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelSheetPage Class

For a list of all members of this type, see ImGearExcelSheetPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a copy of the current Excel sheet page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the Excel sheet page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
See Also

Reference

ImGearExcelSheetPage Class
ImageGear.Formats.Office Namespace


Clone Method (ImGearExcelSheetPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class : Clone Method
Creates a copy of the current Excel sheet page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearExcelSheetPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImGearExcelSheetPage instance.
Remarks

The new instance returned by this method will be a deep clone, in that it will copy all the internal content needed for displaying or printing. However, it will have no connection to the document which the object this instance was cloned from was attached to.

The ReleaseRenderCache method will have no effect on cloned instances. Once you release all of your references to the clone it will be made available for garbage collection.

See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members


Rasterize Method (ImGearExcelSheetPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class : Rasterize Method
Rasterizes the Excel sheet page using the default parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the Excel sheet page using the default parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the Excel sheet page using provided bit depth and resolution parameters.
Rasterize(Double,Double) | Rasterizes the Excel sheet page using the provided parameters.
See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members


Rasterize() Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class > Rasterize Method : Rasterize() Method
Rasterizes the Excel sheet page using the default parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearExcelSheetPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

Stand-alone instance of ImageGear.Core.ImGearRasterPage class.
Remarks

This method rasterizes the current vector page into a raster page.

The page is rasterized with default parameters of:

  • RGB color space
  • 24 bits per pixel depth
  • 96 x 96 dpi

See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Excel sheet page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearExcelSheetPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image will have RGB color space with 24 bits per pixel depth.
See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members
Overload List
ImGearRasterPage Class


Rasterize(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class > Rasterize Method : Rasterize(Double,Double) Method
This parameter specifies the horizontal resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Excel sheet page using the provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Rasterize( _
   ByVal resolutionX As Double, _
   ByVal resolutionY As Double _
) As ImGearRasterPage
'Usage

Dim instance As ImGearExcelSheetPage
Dim resolutionX As Double
Dim resolutionY As Double
Dim value As ImGearRasterPage

value = instance.Rasterize(resolutionX, resolutionY)
public ImGearRasterPage Rasterize(
   double resolutionX,
   double resolutionY
)
public: ImGearRasterPage* Rasterize(
   double resolutionX,
   double resolutionY
)
public:
ImGearRasterPage^ Rasterize(
   double resolutionX,
   double resolutionY
)

Parameters

resolutionX
This parameter specifies the horizontal resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch used for converting an Excel page into a raster image. The greater this value, the higher the quality of the raster image will be. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
Remarks

The DIB of output raster image will have an RGB color space with 24 bits per pixel depth.

See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members
Overload List


ReleaseRenderCache Method (ImGearExcelSheetPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearExcelSheetPage Class : ReleaseRenderCache Method
Clears the internal cache of this page, which contains data used for rendering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseRenderCache()
'Usage

Dim instance As ImGearExcelSheetPage

instance.ReleaseRenderCache()
public void ReleaseRenderCache()
public: void ReleaseRenderCache();
public:
void ReleaseRenderCache();
Remarks

During normal operation, ImGearExcelSheetPage page will not render its underlying content until it's certainly needed for display or printing. Once it does, however, the rendered content will be cached internally for quick access in the case it is needed again.

There are situations where this behavior is not desired and where this method can help. For example, if you are looping through all pages of a document to print them, each page need only be accessed for a short period of time, after which it is no longer needed. However, because each page will cache its rendered content, the processes memory will continue to grow as each page is printed and will only be released when the parent document is no longer referenced. If the sheet is very large, all the memory of the process could be exhausted while the pages are still being accessed.

Calling this method after accessing a page for display or printing will release the internal reference to the rendered content. The rendered content will be recreated later if it is needed.

This method has no effect on an instance created by the Clone method. A cloned instance has no connection to the original spreadsheet data, thus cannot regenerate the rendered content were it to be cleared.

See Also

Reference

ImGearExcelSheetPage Class
ImGearExcelSheetPage Members


%%PageItemTitle%%

ImGearOffice Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearOffice Class
Provides general Office formats functionality.
Object Model
ImGearOffice ClassIImGearFormat InterfaceIImGearFormat InterfaceIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ImGearOffice
'Usage

Dim instance As ImGearOffice
public static class ImGearOffice
public __gc abstract __sealed class ImGearOffice
public ref class ImGearOffice abstract sealed
Remarks
Allows to load Microsoft Office documents in Open XML format.
Inheritance Hierarchy

System.Object
ImageGear.Formats.Office.ImGearOffice

See Also

Reference

ImGearOffice Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearOffice Class Members
Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearOffice Class

The following tables list the members exposed by ImGearOffice.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateExcelFormat | Creates an instance of Microsoft Excel format.
static (Shared in Visual Basic) | CreatePowerPointFormat | Creates an instance of Microsoft PowerPoint format.
static (Shared in Visual Basic) | CreateWordFormat | Creates an instance of Microsoft Word format.
Top
See Also

Reference

ImGearOffice Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Methods$$

ImGearOffice Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearOffice Class

For a list of all members of this type, see ImGearOffice members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateExcelFormat | Creates an instance of Microsoft Excel format.
static (Shared in Visual Basic) | CreatePowerPointFormat | Creates an instance of Microsoft PowerPoint format.
static (Shared in Visual Basic) | CreateWordFormat | Creates an instance of Microsoft Word format.
Top
See Also

Reference

ImGearOffice Class
ImageGear.Formats.Office Namespace


CreateExcelFormat Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearOffice Class : CreateExcelFormat Method
Creates an instance of Microsoft Excel format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateExcelFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearOffice.CreateExcelFormat()
public static IImGearFormat CreateExcelFormat()
public: static IImGearFormat* CreateExcelFormat();
public:
static IImGearFormat^ CreateExcelFormat();

Return Value

ImageGear.Formats.IImGearFormat instance.
See Also

Reference

ImGearOffice Class
ImGearOffice Members
IImGearFormat Interface


CreatePowerPointFormat Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearOffice Class : CreatePowerPointFormat Method
Creates an instance of Microsoft PowerPoint format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreatePowerPointFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearOffice.CreatePowerPointFormat()
public static IImGearFormat CreatePowerPointFormat()
public: static IImGearFormat* CreatePowerPointFormat();
public:
static IImGearFormat^ CreatePowerPointFormat();

Return Value

ImageGear.Formats.IImGearFormat instance.
See Also

Reference

ImGearOffice Class
ImGearOffice Members
IImGearFormat Interface


CreateWordFormat Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearOffice Class : CreateWordFormat Method
Creates an instance of Microsoft Word format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateWordFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearOffice.CreateWordFormat()
public static IImGearFormat CreateWordFormat()
public: static IImGearFormat* CreateWordFormat();
public:
static IImGearFormat^ CreateWordFormat();

Return Value

ImageGear.Formats.IImGearFormat instance.
See Also

Reference

ImGearOffice Class
ImGearOffice Members
IImGearFormat Interface


%%PageItemTitle%%

ImGearPowerPointDocument Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointDocument Class
Represents PowerPoint Documents.
Object Model
ImGearPowerPointDocument ClassImGearDocument ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPowerPointDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearPowerPointDocument
public class ImGearPowerPointDocument : ImageGear.Core.ImGearDocument
public __gc class ImGearPowerPointDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearPowerPointDocument : public ImageGear.Core.ImGearDocument
Remarks

This class displays PowerPoint documents.

The document can be created and processed in any thread with any apartment state - STA or MTA. But if it should be displayed as well, then there are some concepts, which should be taken into account.

In WPF display scale mode the document must be created in UI thread, otherwise System.InvalidOperationException will be thrown, telling that "The calling thread cannot access this object because a different thread owns it". This is requirement of Windows Presentation Foundation.

In Native display scale mode, which is default for ImageGear, there are no any restrictions for displaying PowerPoint pages in multithreaded environment.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearPowerPointDocument

See Also

Reference

ImGearPowerPointDocument Members
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Members$$

ImGearPowerPointDocument Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointDocument Class

The following tables list the members exposed by ImGearPowerPointDocument.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the preferred height in pixels for the document pages.
Public Property | Pages | Overridden. Gets the list of pages available in the PowerPoint document.
Public Property | PageWidth | Gets the preferred width in pixels for the document pages.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new instance of current PowerPoint document.
Public Method | ExtractText | Extracts plain text from the document.
Top
See Also

Reference

ImGearPowerPointDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Fields$$

ImGearPowerPointDocument Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointDocument Class

For a list of all members of this type, see ImGearPowerPointDocument members.

See Also

Reference

ImGearPowerPointDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Methods$$

ImGearPowerPointDocument Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointDocument Class

For a list of all members of this type, see ImGearPowerPointDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new instance of current PowerPoint document.
Public Method | ExtractText | Extracts plain text from the document.
Top
See Also

Reference

ImGearPowerPointDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


Clone Method (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : Clone Method
Creates a new instance of current PowerPoint document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearPowerPointDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

ImGearPowerPointDocument instance.
See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members


Dispose Method (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members


Dispose(Boolean) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearPowerPointDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members
Overload List


ExtractText Method (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : ExtractText Method
Start page index.
Page count.
The output stream.
Extraction options.
Extracts plain text from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ExtractText( _
   ByVal startPage As Integer, _
   ByVal count As Integer, _
   ByVal outputStream As Stream, _
   ByVal options As ImGearPowerPointTextExtractionOptions _
)
'Usage

Dim instance As ImGearPowerPointDocument
Dim startPage As Integer
Dim count As Integer
Dim outputStream As Stream
Dim options As ImGearPowerPointTextExtractionOptions

instance.ExtractText(startPage, count, outputStream, options)
public void ExtractText(
   int startPage,
   int count,
   Stream outputStream,
   ImGearPowerPointTextExtractionOptions options
)
public: void ExtractText(
   int startPage,
   int count,
   Stream* outputStream,
   ImGearPowerPointTextExtractionOptions* options
)
public:
void ExtractText(
   int startPage,
   int count,
   Stream^ outputStream,
   ImGearPowerPointTextExtractionOptions^ options
)

Parameters

startPage
Start page index.
count
Page count.
outputStream
The output stream.
options
Extraction options.
See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members
ImGearPowerPointTextExtractionOptions Class


%%PageItemTitle%% $$Properties$$

ImGearPowerPointDocument Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointDocument Class

For a list of all members of this type, see ImGearPowerPointDocument members.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the preferred height in pixels for the document pages.
Public Property | Pages | Overridden. Gets the list of pages available in the PowerPoint document.
Public Property | PageWidth | Gets the preferred width in pixels for the document pages.
Top
See Also

Reference

ImGearPowerPointDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


PageHeight Property (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : PageHeight Property
Gets the preferred height in pixels for the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageHeight As Double
'Usage

Dim instance As ImGearPowerPointDocument
Dim value As Double

value = instance.PageHeight
public double PageHeight {get;}
public: __property double get_PageHeight();
public:
property double PageHeight {
   double get();
}

Property Value

Double value.
Remarks

Page dimensions of the document are stored in the PresentationML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page height is 1056 pixels.

See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members


Pages Property (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : Pages Property
Gets the list of pages available in the PowerPoint document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearPowerPointDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
Remarks
Returns a readonly list of pages available in the PowerPoint document.
See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members
ImGearDocumentPageArray Class


PageWidth Property (ImGearPowerPointDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointDocument Class : PageWidth Property
Gets the preferred width in pixels for the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageWidth As Double
'Usage

Dim instance As ImGearPowerPointDocument
Dim value As Double

value = instance.PageWidth
public double PageWidth {get;}
public: __property double get_PageWidth();
public:
property double PageWidth {
   double get();
}

Property Value

Double value.
Remarks

Page dimensions of the document are stored in the PresentationML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page width is 816 pixels.

See Also

Reference

ImGearPowerPointDocument Class
ImGearPowerPointDocument Members


%%PageItemTitle%%

ImGearPowerPointPage Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointPage Class
Represents PowerPoint Document page.
Object Model
ImGearPowerPointPage ClassImGearPage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPowerPointPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearPowerPointPage
public class ImGearPowerPointPage : ImageGear.Core.ImGearVectorPage
public __gc class ImGearPowerPointPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearPowerPointPage : public ImageGear.Core.ImGearVectorPage
Remarks
The class displays PowerPoint document page.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearPowerPointPage

See Also

Reference

ImGearPowerPointPage Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearPowerPointPage Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointPage Class

The following tables list the members exposed by ImGearPowerPointPage.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates deep instance of current PowerPoint page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
See Also

Reference

ImGearPowerPointPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Fields$$

ImGearPowerPointPage Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointPage Class

For a list of all members of this type, see ImGearPowerPointPage members.

See Also

Reference

ImGearPowerPointPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Properties$$

ImGearPowerPointPage Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointPage Class

For a list of all members of this type, see ImGearPowerPointPage members.

See Also

Reference

ImGearPowerPointPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Methods$$

ImGearPowerPointPage Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointPage Class

For a list of all members of this type, see ImGearPowerPointPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates deep instance of current PowerPoint page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
See Also

Reference

ImGearPowerPointPage Class
ImageGear.Formats.Office Namespace


Clone Method (ImGearPowerPointPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class : Clone Method
Creates deep instance of current PowerPoint page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearPowerPointPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImGearPowerPointPage instance.
See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members


Rasterize Method (ImGearPowerPointPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class : Rasterize Method
Rasterizes the page using the default parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the page using the default parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the page using provided bit depth and resolution parameters.
Rasterize(Double,Double) | Rasterizes the page using the provided parameters.
See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members


Rasterize() Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class > Rasterize Method : Rasterize() Method
Rasterizes the page using the default parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearPowerPointPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

Stand-alone instance of ImageGear.Core.ImGearRasterPage class.
Remarks
Rasterizes vector page into raster page. The page is rasterized with default parameters: RGB color space, 24 bits per pixel depth, 96 x 96 dpi.
See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearPowerPointPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image will have RGB color space with 24 bits per pixel depth.
See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members
Overload List
ImGearRasterPage Class


Rasterize(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class > Rasterize Method : Rasterize(Double,Double) Method
This parameter specifies the horizontal resolution in dots-per-inch for PowerPoint page conversion into a raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch for PowerPoint page conversion into the raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the page using the provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Rasterize( _
   ByVal resolutionX As Double, _
   ByVal resolutionY As Double _
) As ImGearRasterPage
'Usage

Dim instance As ImGearPowerPointPage
Dim resolutionX As Double
Dim resolutionY As Double
Dim value As ImGearRasterPage

value = instance.Rasterize(resolutionX, resolutionY)
public ImGearRasterPage Rasterize(
   double resolutionX,
   double resolutionY
)
public: ImGearRasterPage* Rasterize(
   double resolutionX,
   double resolutionY
)
public:
ImGearRasterPage^ Rasterize(
   double resolutionX,
   double resolutionY
)

Parameters

resolutionX
This parameter specifies the horizontal resolution in dots-per-inch for PowerPoint page conversion into a raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch for PowerPoint page conversion into the raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
Remarks

The DIB of output raster image will have RGB color space with 24 bits per pixel depth.

See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members
Overload List


ReleaseRenderCache Method (ImGearPowerPointPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointPage Class : ReleaseRenderCache Method
Clears the internal cache of this page, which contains data used for rendering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseRenderCache()
'Usage

Dim instance As ImGearPowerPointPage

instance.ReleaseRenderCache()
public void ReleaseRenderCache()
public: void ReleaseRenderCache();
public:
void ReleaseRenderCache();
Remarks

During normal operation, ImGearPowerPointPage page will not render its underlying content until it's certainly needed for display or printing. Once it does, however, the rendered content will be cached internally for quick access in the case it is needed again.

There are situations where this behavior is not desired and where this method can help. For example, if you are looping through all pages of a document to print them, each page need only be accessed for a short period of time, after which it is no longer needed. However, because each page will cache its rendered content, the processes memory will continue to grow as each page is printed and will only be released when the parent document is no longer referenced. If the sheet is very large, all the memory of the process could be exhausted while the pages are still being accessed.

Calling this method after accessing a page for display or printing will release the internal reference to the rendered content. The rendered content will be recreated later if it is needed.

This method has no effect on an instance created by the Clone method. A cloned instance has no connection to the original spreadsheet data, thus cannot regenerate the rendered content were it to be cleared.

See Also

Reference

ImGearPowerPointPage Class
ImGearPowerPointPage Members


%%PageItemTitle%%

ImGearPowerPointTextExtractionOptions Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointTextExtractionOptions Class
Represents set of PowerPoint text extraction options.
Object Model
ImGearPowerPointTextExtractionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")>
<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")>
Public Class ImGearPowerPointTextExtractionOptions
'Usage

Dim instance As ImGearPowerPointTextExtractionOptions
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
public class ImGearPowerPointTextExtractionOptions
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
public __gc class ImGearPowerPointTextExtractionOptions
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
public ref class ImGearPowerPointTextExtractionOptions
Inheritance Hierarchy

System.Object
ImageGear.Formats.Office.ImGearPowerPointTextExtractionOptions

See Also

Reference

ImGearPowerPointTextExtractionOptions Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearPowerPointTextExtractionOptions Class Members
Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointTextExtractionOptions Class

The following tables list the members exposed by ImGearPowerPointTextExtractionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPowerPointTextExtractionOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ExtractionEncoding | Gets or sets text extraction encoding.
Public Property | ExtractionMethod | Gets or sets text extraction method.
Top
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearPowerPointTextExtractionOptions Constructor

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointTextExtractionOptions Class : ImGearPowerPointTextExtractionOptions Constructor
Overload List
Overload | Description
ImGearPowerPointTextExtractionOptions Constructor() | Initializes a new instance of the ImGearPowerPointTextExtractionOptions class.
ImGearPowerPointTextExtractionOptions Constructor(ImGearPowerPointTextExtractionMethod,Encoding) | Initializes a new instance of the ImGearPowerPointTextExtractionOptions class.
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImGearPowerPointTextExtractionOptions Members


%%PageItemTitle%%

ImGearPowerPointTextExtractionOptions Constructor()

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointTextExtractionOptions Class > ImGearPowerPointTextExtractionOptions Constructor : ImGearPowerPointTextExtractionOptions Constructor()
Initializes a new instance of the ImGearPowerPointTextExtractionOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPowerPointTextExtractionOptions()
public ImGearPowerPointTextExtractionOptions()
public: ImGearPowerPointTextExtractionOptions();
public:
ImGearPowerPointTextExtractionOptions();
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImGearPowerPointTextExtractionOptions Members
Overload List


%%PageItemTitle%%

ImGearPowerPointTextExtractionOptions Constructor(ImGearPowerPointTextExtractionMethod,Encoding)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointTextExtractionOptions Class > ImGearPowerPointTextExtractionOptions Constructor : ImGearPowerPointTextExtractionOptions Constructor(ImGearPowerPointTextExtractionMethod,Encoding)
Text extraction method.
Text extraction encoding.
Initializes a new instance of the ImGearPowerPointTextExtractionOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal extractionMethod As ImGearPowerPointTextExtractionMethod, _
   ByVal extractionEncoding As Encoding _
)
'Usage

Dim extractionMethod As ImGearPowerPointTextExtractionMethod
Dim extractionEncoding As Encoding

Dim instance As New ImGearPowerPointTextExtractionOptions(extractionMethod, extractionEncoding)
public ImGearPowerPointTextExtractionOptions(
   ImGearPowerPointTextExtractionMethod extractionMethod,
   Encoding extractionEncoding
)
public: ImGearPowerPointTextExtractionOptions(
   ImGearPowerPointTextExtractionMethod extractionMethod,
   Encoding* extractionEncoding
)
public:
ImGearPowerPointTextExtractionOptions(
   ImGearPowerPointTextExtractionMethod extractionMethod,
   Encoding^ extractionEncoding
)

Parameters

extractionMethod
Text extraction method.
extractionEncoding
Text extraction encoding.
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImGearPowerPointTextExtractionOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearPowerPointTextExtractionOptions Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointTextExtractionOptions Class

For a list of all members of this type, see ImGearPowerPointTextExtractionOptions members.

Public Properties
 | Name | Description
Public Property | ExtractionEncoding | Gets or sets text extraction encoding.
Public Property | ExtractionMethod | Gets or sets text extraction method.
Top
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImageGear.Formats.Office Namespace


ExtractionEncoding Property

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointTextExtractionOptions Class : ExtractionEncoding Property
Gets or sets text extraction encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtractionEncoding As Encoding
'Usage

Dim instance As ImGearPowerPointTextExtractionOptions
Dim value As Encoding

instance.ExtractionEncoding = value

value = instance.ExtractionEncoding
public Encoding ExtractionEncoding {get; set;}
public: __property Encoding* get_ExtractionEncoding();
public: __property void set_ExtractionEncoding(
   Encoding* value
);
public:
property Encoding^ ExtractionEncoding {
   Encoding^ get();
   void set (    Encoding^ value);
}
Remarks
The default is System.Text.Encoding.UTF8.
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImGearPowerPointTextExtractionOptions Members


ExtractionMethod Property

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearPowerPointTextExtractionOptions Class : ExtractionMethod Property
Gets or sets text extraction method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtractionMethod As ImGearPowerPointTextExtractionMethod
'Usage

Dim instance As ImGearPowerPointTextExtractionOptions
Dim value As ImGearPowerPointTextExtractionMethod

instance.ExtractionMethod = value

value = instance.ExtractionMethod
public ImGearPowerPointTextExtractionMethod ExtractionMethod {get; set;}
public: __property ImGearPowerPointTextExtractionMethod get_ExtractionMethod();
public: __property void set_ExtractionMethod(
   ImGearPowerPointTextExtractionMethod value
);
public:
property ImGearPowerPointTextExtractionMethod ExtractionMethod {
   ImGearPowerPointTextExtractionMethod get();
   void set (    ImGearPowerPointTextExtractionMethod value);
}
Remarks
The default is ImGearPowerPointTextExtractionMethod.ParagraphOrder.
See Also

Reference

ImGearPowerPointTextExtractionOptions Class
ImGearPowerPointTextExtractionOptions Members


%%PageItemTitle%%

ImGearWordDocument Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordDocument Class
Represents Word Documents.
Object Model
ImGearWordDocument ClassImGearDocument ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearWordDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearWordDocument
public class ImGearWordDocument : ImageGear.Core.ImGearDocument
public __gc class ImGearWordDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearWordDocument : public ImageGear.Core.ImGearDocument
Remarks

This class displays Word documents.

The document can be created and processed in any thread with any apartment state - STA or MTA. But if it should be displayed as well, then there are some concepts, which should be taken into account.

In WPF display scale mode the document must be created in UI thread, otherwise System.InvalidOperationException will be thrown, telling that "The calling thread cannot access this object because a different thread owns it". This is requirement of Windows Presentation Foundation.

In Native display scale mode, which is default for ImageGear, there are no any restrictions for displaying Word pages in multithreaded environment.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.Office.ImGearWordDocument

See Also

Reference

ImGearWordDocument Members
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Members$$

ImGearWordDocument Class Members
Fields Properties Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordDocument Class

The following tables list the members exposed by ImGearWordDocument.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the preferred height in pixels for the document pages.
Public Property | Pages | Overridden. Gets the list of pages available in the Word document.
Public Property | PageWidth | Gets the preferred width in pixels for the document pages.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new instance of current Word document.
Public Method | ExtractText | Extracts plain text from the document.
Public Method | Repaginate | Overloaded. Forces pagination of the document content, creates new Page array.
Top
See Also

Reference

ImGearWordDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Fields$$

ImGearWordDocument Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordDocument Class

For a list of all members of this type, see ImGearWordDocument members.

See Also

Reference

ImGearWordDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


%%PageItemTitle%% $$Methods$$

ImGearWordDocument Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordDocument Class

For a list of all members of this type, see ImGearWordDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new instance of current Word document.
Public Method | ExtractText | Extracts plain text from the document.
Public Method | Repaginate | Overloaded. Forces pagination of the document content, creates new Page array.
Top
See Also

Reference

ImGearWordDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


Clone Method (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : Clone Method
Creates a new instance of current Word document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearWordDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

ImGearWordDocument instance.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members


Dispose Method (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members


Dispose(Boolean) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearWordDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members
Overload List


ExtractText Method (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : ExtractText Method
Start page index.
Page count.
The output stream.
Extraction options. If this parameter isnull, default extraction options will be used.
Extracts plain text from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ExtractText( _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer, _
   ByVal outputStream As Stream, _
   ByVal options As ImGearWordTextExtractionOptions _
)
'Usage

Dim instance As ImGearWordDocument
Dim startPageNumber As Integer
Dim pageCount As Integer
Dim outputStream As Stream
Dim options As ImGearWordTextExtractionOptions

instance.ExtractText(startPageNumber, pageCount, outputStream, options)
public void ExtractText(
   int startPageNumber,
   int pageCount,
   Stream outputStream,
   ImGearWordTextExtractionOptions options
)
public: void ExtractText(
   int startPageNumber,
   int pageCount,
   Stream* outputStream,
   ImGearWordTextExtractionOptions* options
)
public:
void ExtractText(
   int startPageNumber,
   int pageCount,
   Stream^ outputStream,
   ImGearWordTextExtractionOptions^ options
)

Parameters

startPageNumber
Start page index.
pageCount
Page count.
outputStream
The output stream.
options
Extraction options. If this parameter isnull, default extraction options will be used.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members
ImGearWordTextExtractionOptions Class


Repaginate Method (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : Repaginate Method
Forces pagination of the document content, creates new Page array.
Overload List
Overload | Description
Repaginate(Double,Double) | Forces pagination of the document content, creates new Page array.
Repaginate(Double,Double,ImGearWordRenderOptions) | Forces pagination of the document content, creates new Page array.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members


Repaginate(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class > Repaginate Method : Repaginate(Double,Double) Method
Desired width of the page in pixels.
Desired height of the page in pixels.
Forces pagination of the document content, creates new Page array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double _
)
'Usage

Dim instance As ImGearWordDocument
Dim pageWidth As Double
Dim pageHeight As Double

instance.Repaginate(pageWidth, pageHeight)
public void Repaginate(
   double pageWidth,
   double pageHeight
)
public: void Repaginate(
   double pageWidth,
   double pageHeight
)
public:
void Repaginate(
   double pageWidth,
   double pageHeight
)

Parameters

pageWidth
Desired width of the page in pixels.
pageHeight
Desired height of the page in pixels.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions is invalid.
Remarks

Page dimensions of the document are stored in the WordprocessingML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page dimensions are 816 x 1056 pixels.

See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members
Overload List


Repaginate(Double,Double,ImGearWordRenderOptions) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class > Repaginate Method : Repaginate(Double,Double,ImGearWordRenderOptions) Method
Desired width of the page in pixels.
Desired height of the page in pixels.
The combination of render options.
Forces pagination of the document content, creates new Page array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Repaginate( _
   ByVal pageWidth As Double, _
   ByVal pageHeight As Double, _
   ByVal renderOptions As ImGearWordRenderOptions _
)
'Usage

Dim instance As ImGearWordDocument
Dim pageWidth As Double
Dim pageHeight As Double
Dim renderOptions As ImGearWordRenderOptions

instance.Repaginate(pageWidth, pageHeight, renderOptions)
public void Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearWordRenderOptions renderOptions
)
public: void Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearWordRenderOptions renderOptions
)
public:
void Repaginate(
   double pageWidth,
   double pageHeight,
   ImGearWordRenderOptions renderOptions
)

Parameters

pageWidth
Desired width of the page in pixels.
pageHeight
Desired height of the page in pixels.
renderOptions
The combination of render options.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if either of provided page dimensions is invalid.
Remarks

Page dimensions of the document are stored in the WordprocessingML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page dimensions are 816 x 1056 pixels.

The renderOptions provides rendering customization options.

See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members
Overload List
ImGearWordRenderOptions Enumeration


%%PageItemTitle%% $$Properties$$

ImGearWordDocument Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordDocument Class

For a list of all members of this type, see ImGearWordDocument members.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets the preferred height in pixels for the document pages.
Public Property | Pages | Overridden. Gets the list of pages available in the Word document.
Public Property | PageWidth | Gets the preferred width in pixels for the document pages.
Top
See Also

Reference

ImGearWordDocument Class
ImageGear.Formats.Office Namespace
ImageScaleSettings Property
ImGearNativeDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Class


PageHeight Property (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : PageHeight Property
Gets the preferred height in pixels for the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageHeight As Double
'Usage

Dim instance As ImGearWordDocument
Dim value As Double

value = instance.PageHeight
public double PageHeight {get;}
public: __property double get_PageHeight();
public:
property double PageHeight {
   double get();
}

Property Value

Double value.
Remarks

Page dimensions of the document are stored in the WordprocessingML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page height is 1056 pixels.

See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members


Pages Property (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : Pages Property
Gets the list of pages available in the Word document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearWordDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
Remarks
Returns a readonly list of pages available in the Word document.
See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members
ImGearDocumentPageArray Class


PageWidth Property (ImGearWordDocument)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordDocument Class : PageWidth Property
Gets the preferred width in pixels for the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageWidth As Double
'Usage

Dim instance As ImGearWordDocument
Dim value As Double

value = instance.PageWidth
public double PageWidth {get;}
public: __property double get_PageWidth();
public:
property double PageWidth {
   double get();
}

Property Value

Double value.
Remarks

Page dimensions of the document are stored in the WordprocessingML package. ImageGear retrieves them (if any) and applies upon loading of the document.

In case of absence of page dimensions within the package, ImageGear by default uses letter size: 8.5"(width) x 11"(height) (1" is equal to 96 pixels).

So, the default page width is 816 pixels.

See Also

Reference

ImGearWordDocument Class
ImGearWordDocument Members


%%PageItemTitle%%

ImGearWordPage Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class
Represents Word Document page.
Object Model
ImGearWordPage ClassImGearPage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearWordPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearWordPage
public class ImGearWordPage : ImageGear.Core.ImGearVectorPage
public __gc class ImGearWordPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearWordPage : public ImageGear.Core.ImGearVectorPage
Remarks
The class displays Word document page.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.Office.ImGearWordPage

See Also

Reference

ImGearWordPage Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearWordPage Class Members
Fields Properties Methods Events

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class

The following tables list the members exposed by ImGearWordPage.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates deep instance of current Word page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
Public Events
 | Name | Description
Public Event | PageDestroyed | Occurs when the document page is no longer actual.As a rule it happens after changing page dimensions and calling ImGearWordDocument.Repaginate method.
Top
See Also

Reference

ImGearWordPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Fields$$

ImGearWordPage Class Fields

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class

For a list of all members of this type, see ImGearWordPage members.

See Also

Reference

ImGearWordPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Properties$$

ImGearWordPage Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class

For a list of all members of this type, see ImGearWordPage members.

See Also

Reference

ImGearWordPage Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Methods$$

ImGearWordPage Class Methods

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class

For a list of all members of this type, see ImGearWordPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates deep instance of current Word page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the default parameters.
Public Method | ReleaseRenderCache | Clears the internal cache of this page, which contains data used for rendering.
Top
See Also

Reference

ImGearWordPage Class
ImageGear.Formats.Office Namespace


Clone Method (ImGearWordPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class : Clone Method
Creates deep instance of current Word page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearWordPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImGearWordPage instance.
See Also

Reference

ImGearWordPage Class
ImGearWordPage Members


Rasterize Method (ImGearWordPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class : Rasterize Method
Rasterizes the page using the default parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the page using the default parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the Word page using provided bit depth and resolution parameters.
Rasterize(Double,Double) | Rasterizes the Word page using provided parameters.
See Also

Reference

ImGearWordPage Class
ImGearWordPage Members


Rasterize() Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class > Rasterize Method : Rasterize() Method
Rasterizes the page using the default parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearWordPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

Stand-alone instance of ImageGear.Core.ImGearRasterPage class.
Remarks
Rasterizes vector page into raster page. The page is rasterized with default parameters: RGB color space, 24 bits per pixel depth, 96 x 96 dpi.
See Also

Reference

ImGearWordPage Class
ImGearWordPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Word page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearWordPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image will have RGB color space with 24 bits per pixel depth.
See Also

Reference

ImGearWordPage Class
ImGearWordPage Members
Overload List
ImGearRasterPage Class


Rasterize(Double,Double) Method

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class > Rasterize Method : Rasterize(Double,Double) Method
This parameter specifies the horizontal resolution in dots-per-inch for Word page conversion into a raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch for Word page conversion into the raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an Y resolution.
Rasterizes the Word page using provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Rasterize( _
   ByVal resolutionX As Double, _
   ByVal resolutionY As Double _
) As ImGearRasterPage
'Usage

Dim instance As ImGearWordPage
Dim resolutionX As Double
Dim resolutionY As Double
Dim value As ImGearRasterPage

value = instance.Rasterize(resolutionX, resolutionY)
public ImGearRasterPage Rasterize(
   double resolutionX,
   double resolutionY
)
public: ImGearRasterPage* Rasterize(
   double resolutionX,
   double resolutionY
)
public:
ImGearRasterPage^ Rasterize(
   double resolutionX,
   double resolutionY
)

Parameters

resolutionX
This parameter specifies the horizontal resolution in dots-per-inch for Word page conversion into a raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch for Word page conversion into the raster image. The greater this value, the higher the quality of the raster image will be after rasterization. The DIB of the output raster image will have this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
Remarks

The DIB of output raster image will have RGB color space with 24 bits per pixel depth.

See Also

Reference

ImGearWordPage Class
ImGearWordPage Members
Overload List


ReleaseRenderCache Method (ImGearWordPage)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class : ReleaseRenderCache Method
Clears the internal cache of this page, which contains data used for rendering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseRenderCache()
'Usage

Dim instance As ImGearWordPage

instance.ReleaseRenderCache()
public void ReleaseRenderCache()
public: void ReleaseRenderCache();
public:
void ReleaseRenderCache();
Remarks

During normal operation, ImGearWordPage page will not render its underlying content until it's certainly needed for display or printing. Once it does, however, the rendered content will be cached internally for quick access in the case it is needed again.

There are situations where this behavior is not desired and where this method can help. For example, if you are looping through all pages of a document to print them, each page need only be accessed for a short period of time, after which it is no longer needed. However, because each page will cache its rendered content, the processes memory will continue to grow as each page is printed and will only be released when the parent document is no longer referenced. If the sheet is very large, all the memory of the process could be exhausted while the pages are still being accessed.

Calling this method after accessing a page for display or printing will release the internal reference to the rendered content. The rendered content will be recreated later if it is needed.

This method has no effect on an instance created by the Clone method. A cloned instance has no connection to the original spreadsheet data, thus cannot regenerate the rendered content were it to be cleared.

See Also

Reference

ImGearWordPage Class
ImGearWordPage Members


%%PageItemTitle%% $$Events$$

ImGearWordPage Class Events

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordPage Class

For a list of all members of this type, see ImGearWordPage members.

Public Events
 | Name | Description
Public Event | PageDestroyed | Occurs when the document page is no longer actual.As a rule it happens after changing page dimensions and calling ImGearWordDocument.Repaginate method.
Top
See Also

Reference

ImGearWordPage Class
ImageGear.Formats.Office Namespace


PageDestroyed Event

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordPage Class : PageDestroyed Event
Occurs when the document page is no longer actual.As a rule it happens after changing page dimensions and calling ImGearWordDocument.Repaginate method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageDestroyed As EventHandler
'Usage

Dim instance As ImGearWordPage
Dim handler As EventHandler

AddHandler instance.PageDestroyed, handler
public event EventHandler PageDestroyed
public: __event EventHandler* PageDestroyed
public:
event EventHandler^ PageDestroyed
See Also

Reference

ImGearWordPage Class
ImGearWordPage Members


%%PageItemTitle%%

ImGearWordTextExtractionOptions Class
Members

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordTextExtractionOptions Class
Represents set of Word text extraction options.
Object Model
ImGearWordTextExtractionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")>
<SuppressMessageAttribute(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")>
Public Class ImGearWordTextExtractionOptions
'Usage

Dim instance As ImGearWordTextExtractionOptions
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
public class ImGearWordTextExtractionOptions
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
public __gc class ImGearWordTextExtractionOptions
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
[SuppressMessage(Category="Microsoft.StyleCop.CSharp.MaintainabilityRules",
   CheckId="SA1402:FileMayOnlyContainASingleClass",
   Scope="",
   Target="",
   MessageId="",
   Justification="This is logical groupping.")]
public ref class ImGearWordTextExtractionOptions
Inheritance Hierarchy

System.Object
ImageGear.Formats.Office.ImGearWordTextExtractionOptions

See Also

Reference

ImGearWordTextExtractionOptions Members
ImageGear.Formats.Office Namespace


%%PageItemTitle%% $$Members$$

ImGearWordTextExtractionOptions Class Members
Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordTextExtractionOptions Class

The following tables list the members exposed by ImGearWordTextExtractionOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearWordTextExtractionOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Areas | Gets or sets text extraction areas of Word document.
Public Property | Encoding | Gets or sets text extraction encoding.
Public Property | LineEnding | Gets or sets text extraction line ending sequence.
Public Property | Method | Gets or sets text extraction method.
Top
See Also

Reference

ImGearWordTextExtractionOptions Class
ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearWordTextExtractionOptions Constructor

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class : ImGearWordTextExtractionOptions Constructor
Overload List
Overload | Description
ImGearWordTextExtractionOptions Constructor() | Initializes a new instance of the ImGearWordTextExtractionOptions class.
ImGearWordTextExtractionOptions Constructor(ImGearWordTextExtractionAreas,ImGearWordTextExtractionMethod,Encoding,ImGearWordLineEndingType) | Initializes a new instance of the ImGearWordTextExtractionOptions class.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members


%%PageItemTitle%%

ImGearWordTextExtractionOptions Constructor()

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class > ImGearWordTextExtractionOptions Constructor : ImGearWordTextExtractionOptions Constructor()
Initializes a new instance of the ImGearWordTextExtractionOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearWordTextExtractionOptions()
public ImGearWordTextExtractionOptions()
public: ImGearWordTextExtractionOptions();
public:
ImGearWordTextExtractionOptions();
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members
Overload List


%%PageItemTitle%%

ImGearWordTextExtractionOptions Constructor(ImGearWordTextExtractionAreas,ImGearWordTextExtractionMethod,Encoding,ImGearWordLineEndingType)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class > ImGearWordTextExtractionOptions Constructor : ImGearWordTextExtractionOptions Constructor(ImGearWordTextExtractionAreas,ImGearWordTextExtractionMethod,Encoding,ImGearWordLineEndingType)
Text extraction areas of Word document.
Text extraction method.
Text extraction encoding.
Text extraction line ending sequence.
Initializes a new instance of the ImGearWordTextExtractionOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal areas As ImGearWordTextExtractionAreas, _
   ByVal method As ImGearWordTextExtractionMethod, _
   ByVal encoding As Encoding, _
   ByVal lineEnding As ImGearWordLineEndingType _
)
'Usage

Dim areas As ImGearWordTextExtractionAreas
Dim method As ImGearWordTextExtractionMethod
Dim encoding As Encoding
Dim lineEnding As ImGearWordLineEndingType

Dim instance As New ImGearWordTextExtractionOptions(areas, method, encoding, lineEnding)
public ImGearWordTextExtractionOptions(
   ImGearWordTextExtractionAreas areas,
   ImGearWordTextExtractionMethod method,
   Encoding encoding,
   ImGearWordLineEndingType lineEnding
)
public: ImGearWordTextExtractionOptions(
   ImGearWordTextExtractionAreas areas,
   ImGearWordTextExtractionMethod method,
   Encoding* encoding,
   ImGearWordLineEndingType lineEnding
)
public:
ImGearWordTextExtractionOptions(
   ImGearWordTextExtractionAreas areas,
   ImGearWordTextExtractionMethod method,
   Encoding^ encoding,
   ImGearWordLineEndingType lineEnding
)

Parameters

areas
Text extraction areas of Word document.
method
Text extraction method.
encoding
Text extraction encoding.
lineEnding
Text extraction line ending sequence.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearWordTextExtractionOptions Class Properties

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordTextExtractionOptions Class

For a list of all members of this type, see ImGearWordTextExtractionOptions members.

Public Properties
 | Name | Description
Public Property | Areas | Gets or sets text extraction areas of Word document.
Public Property | Encoding | Gets or sets text extraction encoding.
Public Property | LineEnding | Gets or sets text extraction line ending sequence.
Public Property | Method | Gets or sets text extraction method.
Top
See Also

Reference

ImGearWordTextExtractionOptions Class
ImageGear.Formats.Office Namespace


Areas Property

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class : Areas Property
Gets or sets text extraction areas of Word document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Areas As ImGearWordTextExtractionAreas
'Usage

Dim instance As ImGearWordTextExtractionOptions
Dim value As ImGearWordTextExtractionAreas

instance.Areas = value

value = instance.Areas
public ImGearWordTextExtractionAreas Areas {get; set;}
public: __property ImGearWordTextExtractionAreas get_Areas();
public: __property void set_Areas(
   ImGearWordTextExtractionAreas value
);
public:
property ImGearWordTextExtractionAreas Areas {
   ImGearWordTextExtractionAreas get();
   void set (    ImGearWordTextExtractionAreas value);
}
Remarks
The default is the combination of all areas.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members


Encoding Property (ImGearWordTextExtractionOptions)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class : Encoding Property
Gets or sets text extraction encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As Encoding
'Usage

Dim instance As ImGearWordTextExtractionOptions
Dim value As Encoding

instance.Encoding = value

value = instance.Encoding
public Encoding Encoding {get; set;}
public: __property Encoding* get_Encoding();
public: __property void set_Encoding(
   Encoding* value
);
public:
property Encoding^ Encoding {
   Encoding^ get();
   void set (    Encoding^ value);
}
Remarks
The default is System.Text.Encoding.UTF8.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members


LineEnding Property

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class : LineEnding Property
Gets or sets text extraction line ending sequence.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineEnding As ImGearWordLineEndingType
'Usage

Dim instance As ImGearWordTextExtractionOptions
Dim value As ImGearWordLineEndingType

instance.LineEnding = value

value = instance.LineEnding
public ImGearWordLineEndingType LineEnding {get; set;}
public: __property ImGearWordLineEndingType get_LineEnding();
public: __property void set_LineEnding(
   ImGearWordLineEndingType value
);
public:
property ImGearWordLineEndingType LineEnding {
   ImGearWordLineEndingType get();
   void set (    ImGearWordLineEndingType value);
}
Remarks
The default is ImGearWordLineEndingType.CRLF.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members


Method Property (ImGearWordTextExtractionOptions)

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace > ImGearWordTextExtractionOptions Class : Method Property
Gets or sets text extraction method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Method As ImGearWordTextExtractionMethod
'Usage

Dim instance As ImGearWordTextExtractionOptions
Dim value As ImGearWordTextExtractionMethod

instance.Method = value

value = instance.Method
public ImGearWordTextExtractionMethod Method {get; set;}
public: __property ImGearWordTextExtractionMethod get_Method();
public: __property void set_Method(
   ImGearWordTextExtractionMethod value
);
public:
property ImGearWordTextExtractionMethod Method {
   ImGearWordTextExtractionMethod get();
   void set (    ImGearWordTextExtractionMethod value);
}
Remarks
The default is ImGearWordTextExtractionMethod.ParagraphOrder.
See Also

Reference

ImGearWordTextExtractionOptions Class
ImGearWordTextExtractionOptions Members


%%PageItemTitle%%

ImGearExcelPageOrder Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearExcelPageOrder Enumeration
Options for ordering the pages of a sheet during pagination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearExcelPageOrder
   Inherits System.Enum
'Usage

Dim instance As ImGearExcelPageOrder
public enum ImGearExcelPageOrder : System.Enum
__value public enum ImGearExcelPageOrder : public System.Enum
public enum class ImGearExcelPageOrder : public System.Enum
Members
Member | Value | Description
DownThenOver | 0 | Default. Pages will be created in the order starting with the first page in the first column and moving down. When the end of the page column is reached, focus moves back up to the start of the next page column. This process is continued until all active content has added to pages.
OverThenDown | 1 | Default. Pages will be created in the order starting with the first page in the first row and moving across. When the end of the page row is reached, focus moves down to the start of the next page row. This process is continued until all active content has added to pages.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearExcelPageOrder

See Also

Reference

ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearPowerPointTextExtractionMethod Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearPowerPointTextExtractionMethod Enumeration
Specifies text extraction methods from PowerPoint document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")>
Public Enum ImGearPowerPointTextExtractionMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearPowerPointTextExtractionMethod
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
public enum ImGearPowerPointTextExtractionMethod : System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
__value public enum ImGearPowerPointTextExtractionMethod : public System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
public enum class ImGearPowerPointTextExtractionMethod : public System.Enum
Members
Member | Value | Description
LineBreakOrder | 1 | Extracts words according their coordinates on the slide.
ParagraphOrder | 0 | Extracts words in the native order they appear in the presentation (does not consider their coordinates on the slide).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearPowerPointTextExtractionMethod

See Also

Reference

ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearWordLineEndingType Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordLineEndingType Enumeration
Specifies line ending sequence for text extraction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")>
Public Enum ImGearWordLineEndingType
   Inherits System.Enum
'Usage

Dim instance As ImGearWordLineEndingType
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum ImGearWordLineEndingType : System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
__value public enum ImGearWordLineEndingType : public System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum class ImGearWordLineEndingType : public System.Enum
Members
Member | Value | Description
CR | 2 | Caret return only.
CRLF | 0 | Caret return and line feed.
LF | 1 | Line feed only.
LFCR | 3 | Line feed and caret return.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearWordLineEndingType

See Also

Reference

ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearWordRenderOptions Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordRenderOptions Enumeration
Defines ImageGear Word rendering options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")>
<FlagsAttribute()>
<SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="Default is more appropriate.")>
Public Enum ImGearWordRenderOptions
   Inherits System.Enum
'Usage

Dim instance As ImGearWordRenderOptions
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
[Flags()]
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="Default is more appropriate.")]
public enum ImGearWordRenderOptions : System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
[Flags()]
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="Default is more appropriate.")]
__value public enum ImGearWordRenderOptions : public System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="We have own naming rules.")]
[Flags()]
[SuppressMessage(Category="Microsoft.Design",
   CheckId="CA1008:EnumsShouldHaveZeroValue",
   Scope="",
   Target="",
   MessageId="",
   Justification="Default is more appropriate.")]
public enum class ImGearWordRenderOptions : public System.Enum
Members
Member | Value | Description
Default | 0 | The default rendering options.
OpaqueHeadersFooters | 1 | Render headers and footers 100% opaque.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearWordRenderOptions

See Also

Reference

ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearWordTextExtractionAreas Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordTextExtractionAreas Enumeration
Specifies text extraction areas of Word document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")>
Public Enum ImGearWordTextExtractionAreas
   Inherits System.Enum
'Usage

Dim instance As ImGearWordTextExtractionAreas
[Flags()]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum ImGearWordTextExtractionAreas : System.Enum
[Flags()]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
__value public enum ImGearWordTextExtractionAreas : public System.Enum
[Flags()]
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum class ImGearWordTextExtractionAreas : public System.Enum
Members
Member | Value | Description
Body | 2 | Extract text from document's regular body.
Footer | 4 | Extract text from document's footers.
Header | 1 | Extract text from document's headers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearWordTextExtractionAreas

See Also

Reference

ImageGear.Formats.Office Namespace


%%PageItemTitle%%

ImGearWordTextExtractionMethod Enumeration

ImageGear22.Formats.Office Assembly > ImageGear.Formats.Office Namespace : ImGearWordTextExtractionMethod Enumeration
Specifies text extraction methods from Word document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")>
Public Enum ImGearWordTextExtractionMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearWordTextExtractionMethod
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum ImGearWordTextExtractionMethod : System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
__value public enum ImGearWordTextExtractionMethod : public System.Enum
[SuppressMessage(Category="Microsoft.Naming",
   CheckId="CA1709:IdentifiersShouldBeCasedCorrectly",
   Scope="",
   Target="",
   MessageId="Im",
   Justification="ImageGear has own naming rules.")]
public enum class ImGearWordTextExtractionMethod : public System.Enum
Members
Member | Value | Description
LineBreakOrder | 1 | Extracts words according their coordinates on the page.
ParagraphOrder | 0 | Extracts words in the native order they appear in the Word file (does not consider their coordinates on the page).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.Office.ImGearWordTextExtractionMethod

See Also

Reference

ImageGear.Formats.Office Namespace


ImageGear22.Formats.Pdf Assembly
Namespaces
Namespace | Description
ImageGear.Formats.PDF | ImageGear PDF namespace provides full multi-page reading and writing support for the entire document, as well as for a specified set of pages. You can detect, read, write, append, insert, replace, swap, and delete a specified page in the PDF document, as well as to edit its content.
ImageGear.Formats.PDF.ToSVG |


ImageGear.Formats.PDF Namespace
Inheritance Hierarchy
ImageGear22.Formats.Pdf Assembly : ImageGear.Formats.PDF Namespace

ImageGear PDF namespace provides full multi-page reading and writing support for the entire document, as well as for a specified set of pages. You can detect, read, write, append, insert, replace, swap, and delete a specified page in the PDF document, as well as to edit its content.

Classes
 | Class | Description
Class | ImGearPDEClip | Represents a list of elements containing Paths and Texts that describe a clip state.
Class | ImGearPDEColorData | Provides the abstract class for PDE color data.
Class | ImGearPDEColorDataCalGray | Represents CalGray color space.
Class | ImGearPDEColorDataCalLab | Represents L*a*b* color space.
Class | ImGearPDEColorDataCalRGB | Represents CalRGB color space.
Class | ImGearPDEColorDataDeviceN | Represents DeviceN color space.
Class | ImGearPDEColorDataICCBased | Represents ICC based color space.
Class | ImGearPDEColorDataIndexed | Represents indexed color space.
Class | ImGearPDEColorDataSeparation | Represents separation color space.
Class | ImGearPDEColorRange | Represents PDE color range.
Class | ImGearPDEColorSpace | Represents a color space used on a page in a PDF file.
Class | ImGearPDEColorSpec | Represents PDE color specification.
Class | ImGearPDEColorValue | Represents PDE color value.
Class | ImGearPDEContainer | Represents a group of elements on a page in a PDF file.
Class | ImGearPDEContent | Represents a modifiable content of a PDF page, which contains elements.
Class | ImGearPDEContentAttrs | Provides attributes of the PDE Content object.
Class | ImGearPDEDash | Represents PDE dash.
Class | ImGearPDEElement | Represents base class for the elements of a page display list (PDE content) and for clip objects.
Class | ImGearPDEFilterArray | Represents an array of filter specifications usually containing two or less filters: encoding and/or compression.
Class | ImGearPDEFilterSpec | Represents a filter element in a filter array.
Class | ImGearPDEFont | Represents a font used on a page in a PDF file.
Class | ImGearPDEFontAttrs | Provides attributes for ImGearPDEFont and ImGearPDFSysFont.
Class | ImGearPDEFontCreateFromSysFontParams | Provides PDE Font creation parameters.
Class | ImGearPDEFontInfo | Represents PDE font information.
Class | ImGearPDEForm | Represents an element corresponding to an instance of XObject Form on a page or other containing stream.
Class | ImGearPDEGraphicState | Provides attributes of a PDE element or a PDE text sub-element.
Class | ImGearPDEGroup | Represents a group of objects in PDE content.
Class | ImGearPDEImage | Represents an Image XObject or in-line image.
Class | ImGearPDEImageAttrs | Provides attributes of a PDE Image object.
Class | ImGearPDEObject | Represents base class for all PDE objects.
Class | ImGearPDEPath | Represents a path.
Class | ImGearPDEPlace | Represents an element that marks a place on a page in a PDF file.
Class | ImGearPDEPostScript | Represents in-line or XObject pass-through PostScript object.
Class | ImGearPDEPSAttrs | Provides attributes of a PDE PostScript object.
Class | ImGearPDEShading | Represents a smooth shading object.
Class | ImGearPDESoftMask | Represents an object for creating and manipulating a soft mask in a PDF file.
Class | ImGearPDEText | Represents a text object.
Class | ImGearPDETextItem | Represents a text item object.
Class | ImGearPDETextState | Provides attributes of a PDE text element.
Class | ImGearPDEXGroup | Represents a transparency (XGroup) resource.
Class | ImGearPDEXObject | Represents an arbitrary XObject.
Class | ImGearPDEXYZColor | Represents XYZ color data.
Class | ImGearPDF | Provides general PDF functionality and access to the global properties and methods.
Class | ImGearPDFAction | Represents a task that performs when a user clicks on a link or a bookmark.
Class | ImGearPDFAtom | Represents a hashed token used in place of strings to optimize performance.
Class | ImGearPDFBasArray | Represents basic array object.
Class | ImGearPDFBasBool | Represents basic boolean object.
Class | ImGearPDFBasDict | Represents basic dictionary object.
Class | ImGearPDFBasFixed | Represents basic fixed object.
Class | ImGearPDFBasInt | Represents basic integer object.
Class | ImGearPDFBasName | Represents basic name object.
Class | ImGearPDFBasNull | Represents basic null object.
Class | ImGearPDFBasObj | Represents basic abstract object.
Class | ImGearPDFBasStream | Represents basic stream object.
Class | ImGearPDFBasString | Represents basic string object.
Class | ImGearPDFBookmark | Represents a PDF bookmark.
Class | ImGearPDFDestination | Represents a particular view of a page in a document.
Class | ImGearPDFDictionary | Represents a PDF dictionary.
Class | ImGearPDFDocument | Represents PDF document.
Class | ImGearPDFDocumentPageArray | Represents PDF document page array.
Class | ImGearPDFFixedMatrix | Describes a matrix containing fixed numbers.
Class | ImGearPDFFixedPoint | Describes a point (in two-dimensional space) represented by two fixed numbers.
Class | ImGearPDFFixedQuad | Describes a quadrilateral with four fixed points (one at each corner).
Class | ImGearPDFFixedRect | Describes a rectangle by the coordinates of its four sides.
Class | ImGearPDFLayer | Represents a named object whose state can be toggled to affect changes in visibility of content.
Class | ImGearPDFObject | Represents general PDF object that provides disposing routine for all unmanaged resources.
Class | ImGearPDFPage | Represents PDF and PS pages.
Class | ImGearPDFPreflight | Provides preflight capabilities.
Class | ImGearPDFPreflightConvertOptions | Provides preflight capabilities.
Class | ImGearPDFPreflightReport | Provides preflight reporting.
Class | ImGearPDFPrintOptions | Provides PDF printing options.
Class | ImGearPDFSaveOptions | Provides specific PDF options for saving.
Class | ImGearPDFSecurityData | Provides data for the standard security handler.
Class | ImGearPDFStream | Represents a data stream that may be a buffer in memory, or an arbitrary user-written procedure.
Class | ImGearPDFStyle | Represents information about the fonts, font sizes, and colors used in a word.
Class | ImGearPDFSysEncoding | Represents a system encoding for a PDF file.
Class | ImGearPDFSysFont | Represents a font installed in the host system.
Class | ImGearPDFWord | Represents a word in a PDF file.
Class | ImGearPDFWordFinder | Represents a word finder object that extracts words from a PDF file.
Delegates
 | Delegate | Description
Delegate | ImGearPDEClip.ImGearPDEClipEnumerate | Delegate for the clip enumeration procedure.
Delegate | ImGearPDFDocument.ImGearAuthProc | Delegate describing format of the authorization procedure.
Delegate | ImGearPDFStream.ImGearPDFStreamCleanUp | Delegate describing PDF stream clean up routine.
Delegate | ImGearPDFStream.ImGearPDFStreamReader | Delegate describing PDF stream reader.
Delegate | ImGearPDFStream.ImGearPDFStreamWriter | Delegate describing PDF stream writer.
Delegate | ImGearPDFSysFont.ImGearPDFSysFontEnumerate | Delegate describing system font enumeration routine.
Enumerations
 | Enumeration | Description
Enumeration | ImGearPDEContentFlags | Specifies PDE content attributes.
Enumeration | ImGearPDEElementCopyFlags | Specifies PDE element copy flags.
Enumeration | ImGearPDEFontCreateFlags | Specifies flags for PDE font creation routine.
Enumeration | ImGearPDEFontCreateNeedFlags | Specifies PDE font flags for creation.
Enumeration | ImGearPDEFontFlags | Specifies font's attributes.
Enumeration | ImGearPDEFontProtection | Specifies font protection.
Enumeration | ImGearPDEGraphicStateWasSetFlags | Specifies a graphics state that was set.
Enumeration | ImGearPDEImageAttrFlags | Specifies PDE image attributes.
Enumeration | ImGearPDEImageDataFlags | Specifies image data flags.
Enumeration | ImGearPDEInsertElement | Specifies pre-defined positions for inserting a PDE element into the content.
Enumeration | ImGearPDEPathElementType | Specifies path segment operators in PDE path elements.
Enumeration | ImGearPDEPathOpFlags | Specifies flags for paint operators in a PDE path.
Enumeration | ImGearPDEPSAttrFlags | Specifies PostScript attributes flags for ImGearPDEPSAttrs class.
Enumeration | ImGearPDESoftMaskCreateFlags | Specifies flags for SoftMask creation.
Enumeration | ImGearPDESysFontMatchFlags | Specifies font matching flags for SysFont find routine.
Enumeration | ImGearPDESysFontPackageType | Specifies system font package type.
Enumeration | ImGearPDETextFlags | Specifies PDE text flags.
Enumeration | ImGearPDEType | Specifies types of PDF editing objects.
Enumeration | ImGearPDEXGroupCreateFlags | Specifies creation flags for transparency group.
Enumeration | ImGearPDFBasicType | Specifies types of basic PDF objects.
Enumeration | ImGearPDFBookmarkFlags | Specifies PDF bookmark flags.
Enumeration | ImGearPDFCodePages | Specifies a code page character-mapping.
Enumeration | ImGearPDFContextFlags | Specifies context flags.
Enumeration | ImGearPDFDestinationType | Specifies the types of PDF object destination.
Enumeration | ImGearPDFFixedValues | Specifies predefined PDF fixed-point constants.
Enumeration | ImGearPDFInsertFlags | Specifies insert flags.
Enumeration | ImGearPDFOCMDVisPolicy | Specifies PDF dictionary (OCMD) visibility policy types.
Enumeration | ImGearPDFPageDrawMode | Specifies PDF rendering methods used to draw PDF page content.
Enumeration | ImGearPDFPageNumber | Specifies pre-defined page number values.
Enumeration | ImGearPDFPageRange | Specifies pre-defined page range values.
Enumeration | ImGearPDFPermReqObj | Specifies the target objects of a permission request.
Enumeration | ImGearPDFPermReqOpr | Specifies the target operations of a permissions request.
Enumeration | ImGearPDFPermReqStatus | Specifies the status of PDF document related permissions methods.
Enumeration | ImGearPDFPermsFlags | Specifies permissions wanted and granted for a document.
Enumeration | ImGearPDFPreflightProfile | Specifies types of supported preflight profiles.
Enumeration | ImGearPDFPreflightReportCodes | Specifies PDF preflight error codes describing incompliance with the specified profile.
Enumeration | ImGearPDFPreflightStatusCode | ImGearPDFPreflightStatusCode defines PDF preflight conversion result code.
Enumeration | ImGearPDFRevision | Specifies Acrobat revision numbers.
Enumeration | ImGearPDFSaveFlags | Specifies save flags for PDF document.
Enumeration | ImGearPDFSecurityInfoFlags | Specifies flags for various information about the security and permissions.
Enumeration | ImGearPDFSmoothFlags | Specifies how a page is rendered (bit flags).
Enumeration | ImGearPDFStdSecurityMethod | Specifies standard security algorithms.
Enumeration | ImGearPDFTextEncoding | Specifies PDF ASCII encoding.
Enumeration | ImGearPDFWordFinderVersion | Specifies word finder algorithm versions.
Enumeration | ImGearPSLevel | Specifies the PostScript language levels.
Enumeration | ImGearPSType | Specifies output PostScript types.
See Also

Reference

ImageGear22.Formats.Pdf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.PDF Namespace Inheritance Hierarchy
ImageGear22.Formats.Pdf Assembly : ImageGear.Formats.PDF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.PDF.ImGearPDFDocument
ImageGear.Core.ImGearDocumentPageArray
ImageGear.Formats.PDF.ImGearPDFDocumentPageArray
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.PDF.ImGearPDFPage
ImageGear.Formats.ImGearSaveOptions
ImageGear.Formats.PDF.ImGearPDFSaveOptions
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataCalGray
ImageGear.Formats.PDF.ImGearPDEColorDataCalLab
ImageGear.Formats.PDF.ImGearPDEColorDataCalRGB
ImageGear.Formats.PDF.ImGearPDEColorDataDeviceN
ImageGear.Formats.PDF.ImGearPDEColorDataICCBased
ImageGear.Formats.PDF.ImGearPDEColorDataIndexed
ImageGear.Formats.PDF.ImGearPDEColorDataSeparation
ImageGear.Formats.PDF.ImGearPDEColorRange
ImageGear.Formats.PDF.ImGearPDEContentAttrs
ImageGear.Formats.PDF.ImGearPDEDash
ImageGear.Formats.PDF.ImGearPDEFilterArray
ImageGear.Formats.PDF.ImGearPDEFilterSpec
ImageGear.Formats.PDF.ImGearPDEFontAttrs
ImageGear.Formats.PDF.ImGearPDEFontCreateFromSysFontParams
ImageGear.Formats.PDF.ImGearPDEFontInfo
ImageGear.Formats.PDF.ImGearPDEImageAttrs
ImageGear.Formats.PDF.ImGearPDEPSAttrs
ImageGear.Formats.PDF.ImGearPDETextState
ImageGear.Formats.PDF.ImGearPDEXYZColor
ImageGear.Formats.PDF.ImGearPDF
ImageGear.Formats.PDF.ImGearPDFFixedMatrix
ImageGear.Formats.PDF.ImGearPDFFixedPoint
ImageGear.Formats.PDF.ImGearPDFFixedQuad
ImageGear.Formats.PDF.ImGearPDFFixedRect
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEColorSpec
ImageGear.Formats.PDF.ImGearPDEColorValue
ImageGear.Formats.PDF.ImGearPDEGraphicState
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEColorSpace
ImageGear.Formats.PDF.ImGearPDEContent
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEClip
ImageGear.Formats.PDF.ImGearPDEContainer
ImageGear.Formats.PDF.ImGearPDEForm
ImageGear.Formats.PDF.ImGearPDEGroup
ImageGear.Formats.PDF.ImGearPDEImage
ImageGear.Formats.PDF.ImGearPDEPath
ImageGear.Formats.PDF.ImGearPDEPlace
ImageGear.Formats.PDF.ImGearPDEPostScript
ImageGear.Formats.PDF.ImGearPDEShading
ImageGear.Formats.PDF.ImGearPDESoftMask
ImageGear.Formats.PDF.ImGearPDEText
ImageGear.Formats.PDF.ImGearPDETextItem
ImageGear.Formats.PDF.ImGearPDEXGroup
ImageGear.Formats.PDF.ImGearPDEXObject
ImageGear.Formats.PDF.ImGearPDEFont
ImageGear.Formats.PDF.ImGearPDFSysEncoding
ImageGear.Formats.PDF.ImGearPDFSysFont
ImageGear.Formats.PDF.ImGearPDFAction
ImageGear.Formats.PDF.ImGearPDFAtom
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasArray
ImageGear.Formats.PDF.ImGearPDFBasBool
ImageGear.Formats.PDF.ImGearPDFBasDict
ImageGear.Formats.PDF.ImGearPDFBasFixed
ImageGear.Formats.PDF.ImGearPDFBasInt
ImageGear.Formats.PDF.ImGearPDFBasName
ImageGear.Formats.PDF.ImGearPDFBasNull
ImageGear.Formats.PDF.ImGearPDFBasStream
ImageGear.Formats.PDF.ImGearPDFBasString
ImageGear.Formats.PDF.ImGearPDFBookmark
ImageGear.Formats.PDF.ImGearPDFDestination
ImageGear.Formats.PDF.ImGearPDFDictionary
ImageGear.Formats.PDF.ImGearPDFLayer
ImageGear.Formats.PDF.ImGearPDFPreflight
ImageGear.Formats.PDF.ImGearPDFPreflightConvertOptions
ImageGear.Formats.PDF.ImGearPDFStream
ImageGear.Formats.PDF.ImGearPDFStyle
ImageGear.Formats.PDF.ImGearPDFWord
ImageGear.Formats.PDF.ImGearPDFWordFinder
ImageGear.Formats.PDF.ImGearPDFPreflightReport
ImageGear.Formats.PDF.ImGearPDFPrintOptions
ImageGear.Formats.PDF.ImGearPDFSecurityData
See Also

Reference

ImageGear22.Formats.Pdf Assembly


%%PageItemTitle%%

ImGearPDEClip Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEClip Class
Represents a list of elements containing Paths and Texts that describe a clip state.
Object Model
ImGearPDEClip ClassImGearPDEClip ClassImGearPDEElement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEClip
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEClip
public sealed class ImGearPDEClip : ImGearPDEElement
public __gc __sealed class ImGearPDEClip : public ImGearPDEElement
public ref class ImGearPDEClip sealed : public ImGearPDEElement
Remarks
Clips can be created and built up with PDE Clip methods. Any PDE Element object can have Clip associated with it. Clip objects can contain PDE Containers and PDE Groups to an arbitrary level of nesting. This allows PDE Containers to be used to mark clip objects.

PDE Groups inside PDE Clips that contain at least one PDE Text and no PDE Paths have a special meaning. All PDE Text objects contained in such a PDE Group are considered to be part of the same BT/ET block. This means that the union of these PDE Texts makes up a single clipping path-as opposed to the intersection of the PDE Texts.

See Section 5.3 in the PDF reference for more information about BT/ET block.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEClip

See Also

Reference

ImGearPDEClip Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEClip Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEClip Class

The following tables list the members exposed by ImGearPDEClip.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEClip Constructor | Initializes a new instance of the ImGearPDEClip class.
Top
Public Properties
 | Name | Description
Public Property | ElementCount | Gets the number of top-level elements in a clip object.
Top
Public Methods
 | Name | Description
Public Method | AddElement | Adds an element to a clip path.
Public Method | Clone | Overloaded. Makes a deep copy of a PDE Clip object.
static (Shared in Visual Basic) | Enumerate | Enumerates all the PDE Elements of the current clip in a flattened manner.
Public Method | GetElement | Gets an element from a clip object.
Public Method | RemoveElements | Removes one or more elements from a clip object.
Top
See Also

Reference

ImGearPDEClip Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEClip Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : ImGearPDEClip Constructor
Initializes a new instance of the ImGearPDEClip class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEClip()
public ImGearPDEClip()
public: ImGearPDEClip();
public:
ImGearPDEClip();

Return Value

The new instance of the clip object.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members


%%PageItemTitle%% $$Methods$$

ImGearPDEClip Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEClip Class

For a list of all members of this type, see ImGearPDEClip members.

Public Methods
 | Name | Description
Public Method | AddElement | Adds an element to a clip path.
Public Method | Clone | Overloaded. Makes a deep copy of a PDE Clip object.
static (Shared in Visual Basic) | Enumerate | Enumerates all the PDE Elements of the current clip in a flattened manner.
Public Method | GetElement | Gets an element from a clip object.
Public Method | RemoveElements | Removes one or more elements from a clip object.
Top
See Also

Reference

ImGearPDEClip Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEClip Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : ImGearPDEClip Constructor
Overload List
Overload | Description
ImGearPDEClip Constructor | Initializes a new instance of the ImGearPDEClip class.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members


AddElement Method (ImGearPDEClip)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : AddElement Method
The index after which to add Element. Use BEFORE_FIRST to insert an element at the beginning of the clip object.
The element added, which may be a PDE Path, a PDE Text, a PDE Container, a PDE Group or a PDE Place object.
Adds an element to a clip path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddElement( _
   ByVal precedingIndex As Integer, _
   ByVal element As ImGearPDEElement _
)
'Usage

Dim instance As ImGearPDEClip
Dim precedingIndex As Integer
Dim element As ImGearPDEElement

instance.AddElement(precedingIndex, element)
public void AddElement(
   int precedingIndex,
   ImGearPDEElement element
)
public: void AddElement(
   int precedingIndex,
   ImGearPDEElement* element
)
public:
void AddElement(
   int precedingIndex,
   ImGearPDEElement^ element
)

Parameters

precedingIndex
The index after which to add Element. Use BEFORE_FIRST to insert an element at the beginning of the clip object.
element
The element added, which may be a PDE Path, a PDE Text, a PDE Container, a PDE Group or a PDE Place object.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members
ImGearPDEElement Class


Clone Method (ImGearPDEClip)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : Clone Method
Makes a deep copy of a PDE Clip object.
Overload List
Overload | Description
Clone() | Makes a deep copy of a PDE Clip object.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members


Clone() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class > Clone Method : Clone() Method
Makes a deep copy of a PDE Clip object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Clone() As ImGearPDEClip
'Usage

Dim instance As ImGearPDEClip
Dim value As ImGearPDEClip

value = instance.Clone()
public ImGearPDEClip Clone()
public: ImGearPDEClip* Clone();
public:
ImGearPDEClip^ Clone();

Return Value

ImGearPDEClip class object, which is a deep copy of the current clip object.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members
Overload List


Enumerate Method (ImGearPDEClip)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : Enumerate Method
Callback function of ImGearPDEClipEnumerate type.
User data passed into EnumerateProc.
Enumerates all the PDE Elements of the current clip in a flattened manner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Enumerate( _
   ByVal clipEnumerationCallback As ImGearPDEClip.ImGearPDEClipEnumerate, _
   ByVal userData As Object _
)
'Usage

Dim clipEnumerationCallback As ImGearPDEClip.ImGearPDEClipEnumerate
Dim userData As Object

ImGearPDEClip.Enumerate(clipEnumerationCallback, userData)
public static void Enumerate(
   ImGearPDEClip.ImGearPDEClipEnumerate clipEnumerationCallback,
   object userData
)
public: static void Enumerate(
   ImGearPDEClip.ImGearPDEClipEnumerate* clipEnumerationCallback,
   Object* userData
)
public:
static void Enumerate(
   ImGearPDEClip.ImGearPDEClipEnumerate^ clipEnumerationCallback,
   Object^ userData
)

Parameters

clipEnumerationCallback
Callback function of ImGearPDEClipEnumerate type.
userData
User data passed into EnumerateProc.
Remarks
PDE containers and PDE Groups nested in the PDE Clip will not be handed back, but any PDE Paths and PDE Texts nested in them will be.

PDE Place objects inside the PDE Clip are not returned.

See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members
ImGearPDEClip.ImGearPDEClipEnumerate Delegate


GetElement Method (ImGearPDEClip)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : GetElement Method
Index of element to get from clip.
Gets an element from a clip object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetElement( _
   ByVal index As Integer _
) As ImGearPDEElement
'Usage

Dim instance As ImGearPDEClip
Dim index As Integer
Dim value As ImGearPDEElement

value = instance.GetElement(index)
public ImGearPDEElement GetElement(
   int index
)
public: ImGearPDEElement* GetElement(
   int index
)
public:
ImGearPDEElement^ GetElement(
   int index
)

Parameters

index
Index of element to get from clip.

Return Value

The new instance of ImGearPDEElement class object.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members
ImGearPDEElement Class


RemoveElements Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : RemoveElements Method
First element to remove.
Number of elements to remove.
Removes one or more elements from a clip object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveElements( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearPDEClip
Dim index As Integer
Dim count As Integer

instance.RemoveElements(index, count)
public void RemoveElements(
   int index,
   int count
)
public: void RemoveElements(
   int index,
   int count
)
public:
void RemoveElements(
   int index,
   int count
)

Parameters

index
First element to remove.
count
Number of elements to remove.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members


%%PageItemTitle%% $$Properties$$

ImGearPDEClip Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEClip Class

For a list of all members of this type, see ImGearPDEClip members.

Public Properties
 | Name | Description
Public Property | ElementCount | Gets the number of top-level elements in a clip object.
Top
See Also

Reference

ImGearPDEClip Class
ImageGear.Formats.PDF Namespace


ElementCount Property (ImGearPDEClip)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEClip Class : ElementCount Property
Gets the number of top-level elements in a clip object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ElementCount As Integer
'Usage

Dim instance As ImGearPDEClip
Dim value As Integer

value = instance.ElementCount
public int ElementCount {get;}
public: __property int get_ElementCount();
public:
property int ElementCount {
   int get();
}

Property Value

Integer value.
Remarks
Top-level elements may be a path or char-path, a marked content container or place, or a group. Paths are represented as PDE Path objects; char-paths are represented as PDE Text objects. If clip contains PDE Groups, this counts the top-level PDE Path, PDE Text, PDE Container, PDE Group, or PDE Place object. Use Enumerate to see only the PDE Path and PDE Text objects.
See Also

Reference

ImGearPDEClip Class
ImGearPDEClip Members


%%PageItemTitle%%

ImGearPDEColorData Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorData Class
Provides the abstract class for PDE color data.
Object Model
ImGearPDEColorData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorData
public abstract class ImGearPDEColorData
public __gc abstract class ImGearPDEColorData
public ref class ImGearPDEColorData abstract
Remarks

This class does not expose any public members.

See section 7.10 of the PDF Reference Manual for information on color spaces.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataCalGray
ImageGear.Formats.PDF.ImGearPDEColorDataCalLab
ImageGear.Formats.PDF.ImGearPDEColorDataCalRGB
ImageGear.Formats.PDF.ImGearPDEColorDataDeviceN
ImageGear.Formats.PDF.ImGearPDEColorDataICCBased
ImageGear.Formats.PDF.ImGearPDEColorDataIndexed
ImageGear.Formats.PDF.ImGearPDEColorDataSeparation

See Also

Reference

ImGearPDEColorData Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorData Class Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorData Class

The following tables list the members exposed by ImGearPDEColorData.

See Also

Reference

ImGearPDEColorData Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataCalGray Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalGray Class
Represents CalGray color space.
Object Model
ImGearPDEColorDataCalGray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataCalGray
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataCalGray
public sealed class ImGearPDEColorDataCalGray : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataCalGray : public ImGearPDEColorData
public ref class ImGearPDEColorDataCalGray sealed : public ImGearPDEColorData
Remarks
Default calGray = {{0, 0, 0}, {0, 0, 0}, 1};
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataCalGray

See Also

Reference

ImGearPDEColorDataCalGray Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataCalGray Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalGray Class

The following tables list the members exposed by ImGearPDEColorDataCalGray.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataCalGray Constructor | Initializes a new instance of the ImGearPDEColorDataCalGray class.
Top
Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets black point value.
Public Field | WhitePoint | Gets or sets white point value.
Top
Public Properties
 | Name | Description
Public Property | Gamma | Gets or sets gamma value.
Top
See Also

Reference

ImGearPDEColorDataCalGray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataCalGray Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalGray Class : ImGearPDEColorDataCalGray Constructor
Initializes a new instance of the ImGearPDEColorDataCalGray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataCalGray()
public ImGearPDEColorDataCalGray()
public: ImGearPDEColorDataCalGray();
public:
ImGearPDEColorDataCalGray();

Return Value

The new instance of ImGearPDEColorDataCalGray class object.
See Also

Reference

ImGearPDEColorDataCalGray Class
ImGearPDEColorDataCalGray Members


%%PageItemTitle%% $$Properties$$

ImGearPDEColorDataCalGray Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalGray Class

For a list of all members of this type, see ImGearPDEColorDataCalGray members.

Public Properties
 | Name | Description
Public Property | Gamma | Gets or sets gamma value.
Top
See Also

Reference

ImGearPDEColorDataCalGray Class
ImageGear.Formats.PDF Namespace


Gamma Property (ImGearPDEColorDataCalGray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalGray Class : Gamma Property
Gets or sets gamma value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Gamma As Single
'Usage

Dim instance As ImGearPDEColorDataCalGray
Dim value As Single

instance.Gamma = value

value = instance.Gamma
public float Gamma {get; set;}
public: __property float get_Gamma();
public: __property void set_Gamma(
   float value
);
public:
property float Gamma {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
Remarks
The default value is 1.
See Also

Reference

ImGearPDEColorDataCalGray Class
ImGearPDEColorDataCalGray Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataCalGray Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalGray Class

For a list of all members of this type, see ImGearPDEColorDataCalGray members.

Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets black point value.
Public Field | WhitePoint | Gets or sets white point value.
Top
See Also

Reference

ImGearPDEColorDataCalGray Class
ImageGear.Formats.PDF Namespace


BlackPoint Field (ImGearPDEColorDataCalGray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalGray Class : BlackPoint Field
Gets or sets black point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BlackPoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalGray
Dim value As ImGearPDEXYZColor

value = instance.BlackPoint

instance.BlackPoint = value
public ImGearPDEXYZColor BlackPoint
public: ImGearPDEXYZColor* BlackPoint
public:
ImGearPDEXYZColor^ BlackPoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalGray Class
ImGearPDEColorDataCalGray Members


WhitePoint Field (ImGearPDEColorDataCalGray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalGray Class : WhitePoint Field
Gets or sets white point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WhitePoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalGray
Dim value As ImGearPDEXYZColor

value = instance.WhitePoint

instance.WhitePoint = value
public ImGearPDEXYZColor WhitePoint
public: ImGearPDEXYZColor* WhitePoint
public:
ImGearPDEXYZColor^ WhitePoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalGray Class
ImGearPDEColorDataCalGray Members
ImGearPDEXYZColor Class


%%PageItemTitle%%

ImGearPDEColorDataCalLab Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalLab Class
Represents L*a*b* color space.
Object Model
ImGearPDEColorDataCalLab Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataCalLab
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataCalLab
public sealed class ImGearPDEColorDataCalLab : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataCalLab : public ImGearPDEColorData
public ref class ImGearPDEColorDataCalLab sealed : public ImGearPDEColorData
Remarks
Default lab = {{0, 0, 0}, {0, 0, 0}, {-100, 100}, {-100, 100}};
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataCalLab

See Also

Reference

ImGearPDEColorDataCalLab Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataCalLab Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalLab Class

The following tables list the members exposed by ImGearPDEColorDataCalLab.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataCalLab Constructor | Initializes a new instance of the ImGearPDEColorDataCalLab class.
Top
Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets the black point value.
Public Field | RangeA | Gets or sets the color range A.
Public Field | RangeB | Gets or sets the color range B.
Public Field | WhitePoint | Gets or sets the white point value.
Top
See Also

Reference

ImGearPDEColorDataCalLab Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataCalLab Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalLab Class : ImGearPDEColorDataCalLab Constructor
Initializes a new instance of the ImGearPDEColorDataCalLab class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataCalLab()
public ImGearPDEColorDataCalLab()
public: ImGearPDEColorDataCalLab();
public:
ImGearPDEColorDataCalLab();

Return Value

The new instance of ImGearPDEColorDataCalLab class object.
See Also

Reference

ImGearPDEColorDataCalLab Class
ImGearPDEColorDataCalLab Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataCalLab Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalLab Class

For a list of all members of this type, see ImGearPDEColorDataCalLab members.

Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets the black point value.
Public Field | RangeA | Gets or sets the color range A.
Public Field | RangeB | Gets or sets the color range B.
Public Field | WhitePoint | Gets or sets the white point value.
Top
See Also

Reference

ImGearPDEColorDataCalLab Class
ImageGear.Formats.PDF Namespace


BlackPoint Field (ImGearPDEColorDataCalLab)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalLab Class : BlackPoint Field
Gets or sets the black point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BlackPoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalLab
Dim value As ImGearPDEXYZColor

value = instance.BlackPoint

instance.BlackPoint = value
public ImGearPDEXYZColor BlackPoint
public: ImGearPDEXYZColor* BlackPoint
public:
ImGearPDEXYZColor^ BlackPoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalLab Class
ImGearPDEColorDataCalLab Members
ImGearPDEXYZColor Class


RangeA Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalLab Class : RangeA Field
Gets or sets the color range A.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public RangeA As ImGearPDEColorRange
'Usage

Dim instance As ImGearPDEColorDataCalLab
Dim value As ImGearPDEColorRange

value = instance.RangeA

instance.RangeA = value
public ImGearPDEColorRange RangeA
public: ImGearPDEColorRange* RangeA
public:
ImGearPDEColorRange^ RangeA

Field Value

ImGearPDEColorRange class object.
See Also

Reference

ImGearPDEColorDataCalLab Class
ImGearPDEColorDataCalLab Members
ImGearPDEColorRange Class


RangeB Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalLab Class : RangeB Field
Gets or sets the color range B.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public RangeB As ImGearPDEColorRange
'Usage

Dim instance As ImGearPDEColorDataCalLab
Dim value As ImGearPDEColorRange

value = instance.RangeB

instance.RangeB = value
public ImGearPDEColorRange RangeB
public: ImGearPDEColorRange* RangeB
public:
ImGearPDEColorRange^ RangeB

Field Value

ImGearPDEColorRange class object.
See Also

Reference

ImGearPDEColorDataCalLab Class
ImGearPDEColorDataCalLab Members
ImGearPDEColorRange Class


WhitePoint Field (ImGearPDEColorDataCalLab)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalLab Class : WhitePoint Field
Gets or sets the white point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WhitePoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalLab
Dim value As ImGearPDEXYZColor

value = instance.WhitePoint

instance.WhitePoint = value
public ImGearPDEXYZColor WhitePoint
public: ImGearPDEXYZColor* WhitePoint
public:
ImGearPDEXYZColor^ WhitePoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalLab Class
ImGearPDEColorDataCalLab Members
ImGearPDEXYZColor Class


%%PageItemTitle%%

ImGearPDEColorDataCalRGB Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalRGB Class
Represents CalRGB color space.
Object Model
ImGearPDEColorDataCalRGB Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataCalRGB
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataCalRGB
public sealed class ImGearPDEColorDataCalRGB : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataCalRGB : public ImGearPDEColorData
public ref class ImGearPDEColorDataCalRGB sealed : public ImGearPDEColorData
Remarks
Default calRGB = {{0, 0, 0}, {0, 0, 0}, 1, 1, 1, {1, 0, 0, 0, 1, 0, 0, 0, 1}};
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataCalRGB

See Also

Reference

ImGearPDEColorDataCalRGB Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataCalRGB Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalRGB Class

The following tables list the members exposed by ImGearPDEColorDataCalRGB.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataCalRGB Constructor | Initializes a new instance of the ImGearPDEColorDataCalRGB class.
Top
Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets the black point value.
Public Field | Matrix | Gets or sets the matrix.
Public Field | WhitePoint | Gets or sets the white point value.
Top
Public Properties
 | Name | Description
Public Property | BlueGamma | Gets or sets the blue gamma value.
Public Property | GreenGamma | Gets or sets the green gamma value.
Public Property | RedGamma | Gets or sets the red gamma value.
Top
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataCalRGB Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : ImGearPDEColorDataCalRGB Constructor
Initializes a new instance of the ImGearPDEColorDataCalRGB class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataCalRGB()
public ImGearPDEColorDataCalRGB()
public: ImGearPDEColorDataCalRGB();
public:
ImGearPDEColorDataCalRGB();

Return Value

The new instance of ImGearPDEColorDataCalRGB class object.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members


%%PageItemTitle%% $$Properties$$

ImGearPDEColorDataCalRGB Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalRGB Class

For a list of all members of this type, see ImGearPDEColorDataCalRGB members.

Public Properties
 | Name | Description
Public Property | BlueGamma | Gets or sets the blue gamma value.
Public Property | GreenGamma | Gets or sets the green gamma value.
Public Property | RedGamma | Gets or sets the red gamma value.
Top
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImageGear.Formats.PDF Namespace


BlueGamma Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : BlueGamma Property
Gets or sets the blue gamma value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlueGamma As Single
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value As Single

instance.BlueGamma = value

value = instance.BlueGamma
public float BlueGamma {get; set;}
public: __property float get_BlueGamma();
public: __property void set_BlueGamma(
   float value
);
public:
property float BlueGamma {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The default value is 1.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members


GreenGamma Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : GreenGamma Property
Gets or sets the green gamma value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GreenGamma As Single
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value As Single

instance.GreenGamma = value

value = instance.GreenGamma
public float GreenGamma {get; set;}
public: __property float get_GreenGamma();
public: __property void set_GreenGamma(
   float value
);
public:
property float GreenGamma {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The default value is 1.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members


RedGamma Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : RedGamma Property
Gets or sets the red gamma value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedGamma As Single
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value As Single

instance.RedGamma = value

value = instance.RedGamma
public float RedGamma {get; set;}
public: __property float get_RedGamma();
public: __property void set_RedGamma(
   float value
);
public:
property float RedGamma {
   float get();
   void set (    float value);
}

Property Value

Any positive float value.
Remarks
The default value is 1.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataCalRGB Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataCalRGB Class

For a list of all members of this type, see ImGearPDEColorDataCalRGB members.

Public Fields
 | Name | Description
Public Field | BlackPoint | Gets or sets the black point value.
Public Field | Matrix | Gets or sets the matrix.
Public Field | WhitePoint | Gets or sets the white point value.
Top
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImageGear.Formats.PDF Namespace


BlackPoint Field (ImGearPDEColorDataCalRGB)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : BlackPoint Field
Gets or sets the black point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BlackPoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value As ImGearPDEXYZColor

value = instance.BlackPoint

instance.BlackPoint = value
public ImGearPDEXYZColor BlackPoint
public: ImGearPDEXYZColor* BlackPoint
public:
ImGearPDEXYZColor^ BlackPoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members
ImGearPDEXYZColor Class


Matrix Field (ImGearPDEColorDataCalRGB)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : Matrix Field
Gets or sets the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Matrix As Single()
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value() As Single

value = instance.Matrix

instance.Matrix = value
public float[] Matrix
public: float[]* Matrix
public:
array<float>^ Matrix

Field Value

Array of positive float values.
Remarks
The default value is {1, 0, 0, 0, 1, 0, 0, 0, 1}.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members


WhitePoint Field (ImGearPDEColorDataCalRGB)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataCalRGB Class : WhitePoint Field
Gets or sets the white point value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WhitePoint As ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEColorDataCalRGB
Dim value As ImGearPDEXYZColor

value = instance.WhitePoint

instance.WhitePoint = value
public ImGearPDEXYZColor WhitePoint
public: ImGearPDEXYZColor* WhitePoint
public:
ImGearPDEXYZColor^ WhitePoint

Field Value

ImGearPDEXYZColor class object.
See Also

Reference

ImGearPDEColorDataCalRGB Class
ImGearPDEColorDataCalRGB Members
ImGearPDEXYZColor Class


%%PageItemTitle%%

ImGearPDEColorDataDeviceN Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataDeviceN Class
Represents DeviceN color space.
Object Model
ImGearPDEColorDataDeviceN Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataDeviceN
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataDeviceN
public sealed class ImGearPDEColorDataDeviceN : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataDeviceN : public ImGearPDEColorData
public ref class ImGearPDEColorDataDeviceN sealed : public ImGearPDEColorData
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataDeviceN

See Also

Reference

ImGearPDEColorDataDeviceN Members
ImageGear.Formats.PDF Namespace
ImGearPDEColorData Class


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataDeviceN Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataDeviceN Class

The following tables list the members exposed by ImGearPDEColorDataDeviceN.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataDeviceN Constructor | Initializes a new instance of the ImGearPDEColorDataDeviceN class.
Top
Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternative color space.
Public Field | Names | Gets or sets the names of colorants.
Public Field | TintTransform | Gets or sets the the tint transform dictionary or function.
Top
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImageGear.Formats.PDF Namespace
ImGearPDEColorData Class


%%PageItemTitle%%

ImGearPDEColorDataDeviceN Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataDeviceN Class : ImGearPDEColorDataDeviceN Constructor
Initializes a new instance of the ImGearPDEColorDataDeviceN class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataDeviceN()
public ImGearPDEColorDataDeviceN()
public: ImGearPDEColorDataDeviceN();
public:
ImGearPDEColorDataDeviceN();

Return Value

The new instance of ImGearPDEColorDataDeviceN class object.
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImGearPDEColorDataDeviceN Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataDeviceN Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataDeviceN Class

For a list of all members of this type, see ImGearPDEColorDataDeviceN members.

Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternative color space.
Public Field | Names | Gets or sets the names of colorants.
Public Field | TintTransform | Gets or sets the the tint transform dictionary or function.
Top
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImageGear.Formats.PDF Namespace
ImGearPDEColorData Class


AltColorSpace Field (ImGearPDEColorDataDeviceN)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataDeviceN Class : AltColorSpace Field
Gets or sets the alternative color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AltColorSpace As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEColorDataDeviceN
Dim value As ImGearPDEColorSpace

value = instance.AltColorSpace

instance.AltColorSpace = value
public ImGearPDEColorSpace AltColorSpace
public: ImGearPDEColorSpace* AltColorSpace
public:
ImGearPDEColorSpace^ AltColorSpace

Field Value

ImGearPDEColorSpace class object.
Remarks
The default value is null.
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImGearPDEColorDataDeviceN Members
ImGearPDEColorSpace Class


Names Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataDeviceN Class : Names Field
Gets or sets the names of colorants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Names As ImGearPDFAtom()
'Usage

Dim instance As ImGearPDEColorDataDeviceN
Dim value() As ImGearPDFAtom

value = instance.Names

instance.Names = value
public ImGearPDFAtom[] Names
public: ImGearPDFAtom*[]* Names
public:
array<ImGearPDFAtom^>^ Names

Field Value

Array of ImGearPDFAtom class objects.
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImGearPDEColorDataDeviceN Members
ImGearPDFAtom Class


TintTransform Field (ImGearPDEColorDataDeviceN)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataDeviceN Class : TintTransform Field
Gets or sets the the tint transform dictionary or function.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public TintTransform As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDEColorDataDeviceN
Dim value As ImGearPDFBasObj

value = instance.TintTransform

instance.TintTransform = value
public ImGearPDFBasObj TintTransform
public: ImGearPDFBasObj* TintTransform
public:
ImGearPDFBasObj^ TintTransform

Field Value

ImGearPDFBasObj class object.
Remarks
See Section 4.5.5 in the PDF Reference for more information. The default value is null.
See Also

Reference

ImGearPDEColorDataDeviceN Class
ImGearPDEColorDataDeviceN Members
ImGearPDFBasObj Class


%%PageItemTitle%%

ImGearPDEColorDataICCBased Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataICCBased Class
Represents ICC based color space.
Object Model
ImGearPDEColorDataICCBased Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataICCBased
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataICCBased
public sealed class ImGearPDEColorDataICCBased : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataICCBased : public ImGearPDEColorData
public ref class ImGearPDEColorDataICCBased sealed : public ImGearPDEColorData
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataICCBased

See Also

Reference

ImGearPDEColorDataICCBased Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataICCBased Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataICCBased Class

The following tables list the members exposed by ImGearPDEColorDataICCBased.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataICCBased Constructor | Initializes a new instance of the ImGearPDEColorDataICCBased class.
Top
Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternate color space.
Public Field | ICCStream | Gets or sets the stream containing ICC Profile.
Top
Public Properties
 | Name | Description
Public Property | CompsCount | Gets or sets the number of color components (1, 3, or 4).
Top
See Also

Reference

ImGearPDEColorDataICCBased Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataICCBased Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataICCBased Class : ImGearPDEColorDataICCBased Constructor
Initializes a new instance of the ImGearPDEColorDataICCBased class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataICCBased()
public ImGearPDEColorDataICCBased()
public: ImGearPDEColorDataICCBased();
public:
ImGearPDEColorDataICCBased();

Return Value

The new instance of ImGearPDEColorDataICCBased class object.
See Also

Reference

ImGearPDEColorDataICCBased Class
ImGearPDEColorDataICCBased Members


%%PageItemTitle%% $$Properties$$

ImGearPDEColorDataICCBased Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataICCBased Class

For a list of all members of this type, see ImGearPDEColorDataICCBased members.

Public Properties
 | Name | Description
Public Property | CompsCount | Gets or sets the number of color components (1, 3, or 4).
Top
See Also

Reference

ImGearPDEColorDataICCBased Class
ImageGear.Formats.PDF Namespace


CompsCount Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataICCBased Class : CompsCount Property
Gets or sets the number of color components (1, 3, or 4).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompsCount As Integer
'Usage

Dim instance As ImGearPDEColorDataICCBased
Dim value As Integer

instance.CompsCount = value

value = instance.CompsCount
public int CompsCount {get; set;}
public: __property int get_CompsCount();
public: __property void set_CompsCount(
   int value
);
public:
property int CompsCount {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEColorDataICCBased Class
ImGearPDEColorDataICCBased Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataICCBased Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataICCBased Class

For a list of all members of this type, see ImGearPDEColorDataICCBased members.

Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternate color space.
Public Field | ICCStream | Gets or sets the stream containing ICC Profile.
Top
See Also

Reference

ImGearPDEColorDataICCBased Class
ImageGear.Formats.PDF Namespace


AltColorSpace Field (ImGearPDEColorDataICCBased)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataICCBased Class : AltColorSpace Field
Gets or sets the alternate color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AltColorSpace As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEColorDataICCBased
Dim value As ImGearPDEColorSpace

value = instance.AltColorSpace

instance.AltColorSpace = value
public ImGearPDEColorSpace AltColorSpace
public: ImGearPDEColorSpace* AltColorSpace
public:
ImGearPDEColorSpace^ AltColorSpace

Field Value

ImGearPDEColorSpace class object.
Remarks
The default value is null.
See Also

Reference

ImGearPDEColorDataICCBased Class
ImGearPDEColorDataICCBased Members
ImGearPDEColorSpace Class


ICCStream Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataICCBased Class : ICCStream Field
Gets or sets the stream containing ICC Profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ICCStream As ImGearPDFStream
'Usage

Dim instance As ImGearPDEColorDataICCBased
Dim value As ImGearPDFStream

value = instance.ICCStream

instance.ICCStream = value
public ImGearPDFStream ICCStream
public: ImGearPDFStream* ICCStream
public:
ImGearPDFStream^ ICCStream

Field Value

ImGearPDFBasObj class object.
Remarks
The default value is null.
See Also

Reference

ImGearPDEColorDataICCBased Class
ImGearPDEColorDataICCBased Members
ImGearPDFBasObj Class


%%PageItemTitle%%

ImGearPDEColorDataIndexed Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataIndexed Class
Represents indexed color space.
Object Model
ImGearPDEColorDataIndexed Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataIndexed
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataIndexed
public sealed class ImGearPDEColorDataIndexed : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataIndexed : public ImGearPDEColorData
public ref class ImGearPDEColorDataIndexed sealed : public ImGearPDEColorData
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataIndexed

See Also

Reference

ImGearPDEColorDataIndexed Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataIndexed Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataIndexed Class

The following tables list the members exposed by ImGearPDEColorDataIndexed.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataIndexed Constructor | Initializes a new instance of the ImGearPDEColorDataIndexed class.
Top
Public Fields
 | Name | Description
Public Field | BaseColorSpace | Gets or sets the base color space.
Public Field | HiVal | Gets or sets the highest color value.
Public Field | LookUp | Gets or sets the indexed color lookup data.
Top
See Also

Reference

ImGearPDEColorDataIndexed Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataIndexed Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataIndexed Class : ImGearPDEColorDataIndexed Constructor
Initializes a new instance of the ImGearPDEColorDataIndexed class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataIndexed()
public ImGearPDEColorDataIndexed()
public: ImGearPDEColorDataIndexed();
public:
ImGearPDEColorDataIndexed();

Return Value

The new instance of ImGearPDEColorDataIndexed class object.
See Also

Reference

ImGearPDEColorDataIndexed Class
ImGearPDEColorDataIndexed Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataIndexed Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataIndexed Class

For a list of all members of this type, see ImGearPDEColorDataIndexed members.

Public Fields
 | Name | Description
Public Field | BaseColorSpace | Gets or sets the base color space.
Public Field | HiVal | Gets or sets the highest color value.
Public Field | LookUp | Gets or sets the indexed color lookup data.
Top
See Also

Reference

ImGearPDEColorDataIndexed Class
ImageGear.Formats.PDF Namespace


BaseColorSpace Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataIndexed Class : BaseColorSpace Field
Gets or sets the base color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BaseColorSpace As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEColorDataIndexed
Dim value As ImGearPDEColorSpace

value = instance.BaseColorSpace

instance.BaseColorSpace = value
public ImGearPDEColorSpace BaseColorSpace
public: ImGearPDEColorSpace* BaseColorSpace
public:
ImGearPDEColorSpace^ BaseColorSpace

Field Value

ImGearPDEColorSpace class object.
Remarks
The default value is null.
See Also

Reference

ImGearPDEColorDataIndexed Class
ImGearPDEColorDataIndexed Members
ImGearPDEColorSpace Class


HiVal Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataIndexed Class : HiVal Field
Gets or sets the highest color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public HiVal As Integer
'Usage

Dim instance As ImGearPDEColorDataIndexed
Dim value As Integer

value = instance.HiVal

instance.HiVal = value
public int HiVal
public: int HiVal
public:
int HiVal

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEColorDataIndexed Class
ImGearPDEColorDataIndexed Members


LookUp Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataIndexed Class : LookUp Field
Gets or sets the indexed color lookup data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public LookUp As Byte()
'Usage

Dim instance As ImGearPDEColorDataIndexed
Dim value() As Byte

value = instance.LookUp

instance.LookUp = value
public byte[] LookUp
public: byte[]* LookUp
public:
array<byte>^ LookUp

Field Value

Byte array.
See Also

Reference

ImGearPDEColorDataIndexed Class
ImGearPDEColorDataIndexed Members


%%PageItemTitle%%

ImGearPDEColorDataSeparation Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataSeparation Class
Represents separation color space.
Object Model
ImGearPDEColorDataSeparation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorDataSeparation
   Inherits ImGearPDEColorData
'Usage

Dim instance As ImGearPDEColorDataSeparation
public sealed class ImGearPDEColorDataSeparation : ImGearPDEColorData
public __gc __sealed class ImGearPDEColorDataSeparation : public ImGearPDEColorData
public ref class ImGearPDEColorDataSeparation sealed : public ImGearPDEColorData
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorData
ImageGear.Formats.PDF.ImGearPDEColorDataSeparation

See Also

Reference

ImGearPDEColorDataSeparation Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorDataSeparation Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataSeparation Class

The following tables list the members exposed by ImGearPDEColorDataSeparation.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorDataSeparation Constructor | Initializes a new instance of the ImGearPDEColorDataSeparation class.
Top
Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternative color space.
Public Field | Name | Gets or sets the name of separation or colorant.
Public Field | TintTransform | Gets or sets the tint transform dictionary or function.
Top
See Also

Reference

ImGearPDEColorDataSeparation Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorDataSeparation Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataSeparation Class : ImGearPDEColorDataSeparation Constructor
Initializes a new instance of the ImGearPDEColorDataSeparation class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorDataSeparation()
public ImGearPDEColorDataSeparation()
public: ImGearPDEColorDataSeparation();
public:
ImGearPDEColorDataSeparation();

Return Value

The new instance of ImGearPDEColorDataSeparation class object.
See Also

Reference

ImGearPDEColorDataSeparation Class
ImGearPDEColorDataSeparation Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorDataSeparation Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorDataSeparation Class

For a list of all members of this type, see ImGearPDEColorDataSeparation members.

Public Fields
 | Name | Description
Public Field | AltColorSpace | Gets or sets the alternative color space.
Public Field | Name | Gets or sets the name of separation or colorant.
Public Field | TintTransform | Gets or sets the tint transform dictionary or function.
Top
See Also

Reference

ImGearPDEColorDataSeparation Class
ImageGear.Formats.PDF Namespace


AltColorSpace Field (ImGearPDEColorDataSeparation)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataSeparation Class : AltColorSpace Field
Gets or sets the alternative color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AltColorSpace As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEColorDataSeparation
Dim value As ImGearPDEColorSpace

value = instance.AltColorSpace

instance.AltColorSpace = value
public ImGearPDEColorSpace AltColorSpace
public: ImGearPDEColorSpace* AltColorSpace
public:
ImGearPDEColorSpace^ AltColorSpace

Field Value

ImGearPDEColorSpace class object.
Remarks
The default value is null.
See Also

Reference

ImGearPDEColorDataSeparation Class
ImGearPDEColorDataSeparation Members
ImGearPDEColorSpace Class


Name Field (ImGearPDEColorDataSeparation)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataSeparation Class : Name Field
Gets or sets the name of separation or colorant.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEColorDataSeparation
Dim value As ImGearPDFAtom

value = instance.Name

instance.Name = value
public ImGearPDFAtom Name
public: ImGearPDFAtom* Name
public:
ImGearPDFAtom^ Name

Field Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEColorDataSeparation Class
ImGearPDEColorDataSeparation Members
ImGearPDFAtom Class


TintTransform Field (ImGearPDEColorDataSeparation)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorDataSeparation Class : TintTransform Field
Gets or sets the tint transform dictionary or function.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public TintTransform As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDEColorDataSeparation
Dim value As ImGearPDFBasObj

value = instance.TintTransform

instance.TintTransform = value
public ImGearPDFBasObj TintTransform
public: ImGearPDFBasObj* TintTransform
public:
ImGearPDFBasObj^ TintTransform

Field Value

ImGearPDFBasObj class object.
Remarks
See Section 4.5.5 in the PDF Reference for more information. The default value is null.
See Also

Reference

ImGearPDEColorDataSeparation Class
ImGearPDEColorDataSeparation Members
ImGearPDFBasObj Class


%%PageItemTitle%%

ImGearPDEColorRange Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorRange Class
Represents PDE color range.
Object Model
ImGearPDEColorRange Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorRange
'Usage

Dim instance As ImGearPDEColorRange
public sealed class ImGearPDEColorRange
public __gc __sealed class ImGearPDEColorRange
public ref class ImGearPDEColorRange sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEColorRange

See Also

Reference

ImGearPDEColorRange Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorRange Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorRange Class

The following tables list the members exposed by ImGearPDEColorRange.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorRange Constructor | Initializes a new instance of the ImGearPDEColorRange class.
Top
Public Fields
 | Name | Description
Public Field | Max | Gets or sets Max value.
Public Field | Min | Gets or sets Min value.
Top
See Also

Reference

ImGearPDEColorRange Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorRange Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorRange Class : ImGearPDEColorRange Constructor
Initializes a new instance of the ImGearPDEColorRange class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorRange()
public ImGearPDEColorRange()
public: ImGearPDEColorRange();
public:
ImGearPDEColorRange();
See Also

Reference

ImGearPDEColorRange Class
ImGearPDEColorRange Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorRange Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorRange Class

For a list of all members of this type, see ImGearPDEColorRange members.

Public Fields
 | Name | Description
Public Field | Max | Gets or sets Max value.
Public Field | Min | Gets or sets Min value.
Top
See Also

Reference

ImGearPDEColorRange Class
ImageGear.Formats.PDF Namespace


Max Field (ImGearPDEColorRange)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorRange Class : Max Field
Gets or sets Max value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Max As Single
'Usage

Dim instance As ImGearPDEColorRange
Dim value As Single

value = instance.Max

instance.Max = value
public float Max
public: float Max
public:
float Max

Field Value

Float value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEColorRange Class
ImGearPDEColorRange Members


Min Field (ImGearPDEColorRange)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorRange Class : Min Field
Gets or sets Min value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Min As Single
'Usage

Dim instance As ImGearPDEColorRange
Dim value As Single

value = instance.Min

instance.Min = value
public float Min
public: float Min
public:
float Min

Field Value

Float value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEColorRange Class
ImGearPDEColorRange Members


%%PageItemTitle%%

ImGearPDEColorSpace Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpace Class
Represents a color space used on a page in a PDF file.
Object Model
ImGearPDEColorSpace ClassImGearPDFAtom ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorSpace
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDEColorSpace
public sealed class ImGearPDEColorSpace : ImGearPDEObject
public __gc __sealed class ImGearPDEColorSpace : public ImGearPDEObject
public ref class ImGearPDEColorSpace sealed : public ImGearPDEObject
Remarks
The color space is a part of the graphics state attributes of a PDE Element.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEColorSpace

See Also

Reference

ImGearPDEColorSpace Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorSpace Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpace Class

The following tables list the members exposed by ImGearPDEColorSpace.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorSpace Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BaseColorComponents | Gets the number of components in the base color space of an indexed color space.
Public Property | BaseName | Gets the name of the base color space.
Public Property | ColorComponents | Gets the number of components in the color space.
Public Property | HiVal | Gets the highest index for the color lookup table for an indexed color space.
Public Property | Name | Gets the color space object's name.
Top
Public Methods
 | Name | Description
Public Method | GetCTable | Gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space.
Top
See Also

Reference

ImGearPDEColorSpace Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorSpace Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : ImGearPDEColorSpace Constructor
Overload List
Overload | Description
ImGearPDEColorSpace Constructor(ImGearPDFAtom) | Initializes a new instance of the ImGearPDEColorSpace class.
ImGearPDEColorSpace Constructor(ImGearPDFAtom,ImGearPDEColorData) | Initializes a new instance of the ImGearPDEColorSpace class.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members


%%PageItemTitle%%

ImGearPDEColorSpace Constructor(ImGearPDFAtom)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class > ImGearPDEColorSpace Constructor : ImGearPDEColorSpace Constructor(ImGearPDFAtom)
Supports the following PDF color spaces:

Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.

Device-independent names: CalGray, CalRGB, Lab, or ICCBased.

Special names: Indexed, Pattern, or Separation.

Initializes a new instance of the ImGearPDEColorSpace class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As ImGearPDFAtom _
)
'Usage

Dim name As ImGearPDFAtom

Dim instance As New ImGearPDEColorSpace(name)
public ImGearPDEColorSpace(
   ImGearPDFAtom name
)
public: ImGearPDEColorSpace(
   ImGearPDFAtom* name
)
public:
ImGearPDEColorSpace(
   ImGearPDFAtom^ name
)

Parameters

name
Supports the following PDF color spaces:

Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.

Device-independent names: CalGray, CalRGB, Lab, or ICCBased.

Special names: Indexed, Pattern, or Separation.

Return Value

The new instance of ImGearPDEColorSpace class object.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members
Overload List
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEColorSpace Constructor(ImGearPDFAtom,ImGearPDEColorData)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class > ImGearPDEColorSpace Constructor : ImGearPDEColorSpace Constructor(ImGearPDFAtom,ImGearPDEColorData)
Supports the following PDF color spaces:

Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.

Device-independent names: CalGray, CalRGB, Lab, or ICCBased.

Special names: Indexed, Pattern, or Separation.

Color data for the type of color space you want to create.
Initializes a new instance of the ImGearPDEColorSpace class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As ImGearPDFAtom, _
   ByVal colorData As ImGearPDEColorData _
)
'Usage

Dim name As ImGearPDFAtom
Dim colorData As ImGearPDEColorData

Dim instance As New ImGearPDEColorSpace(name, colorData)
public ImGearPDEColorSpace(
   ImGearPDFAtom name,
   ImGearPDEColorData colorData
)
public: ImGearPDEColorSpace(
   ImGearPDFAtom* name,
   ImGearPDEColorData* colorData
)
public:
ImGearPDEColorSpace(
   ImGearPDFAtom^ name,
   ImGearPDEColorData^ colorData
)

Parameters

name
Supports the following PDF color spaces:

Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.

Device-independent names: CalGray, CalRGB, Lab, or ICCBased.

Special names: Indexed, Pattern, or Separation.

colorData
Color data for the type of color space you want to create.

Return Value

The new instance of ImGearPDEColorSpace class object.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members
Overload List
ImGearPDFAtom Class
ImGearPDEColorData Class


%%PageItemTitle%% $$Methods$$

ImGearPDEColorSpace Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpace Class

For a list of all members of this type, see ImGearPDEColorSpace members.

Public Methods
 | Name | Description
Public Method | GetCTable | Gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space.
Top
See Also

Reference

ImGearPDEColorSpace Class
ImageGear.Formats.PDF Namespace


GetCTable Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : GetCTable Method
Gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCTable() As Byte()
'Usage

Dim instance As ImGearPDEColorSpace
Dim value() As Byte

value = instance.GetCTable()
public byte[] GetCTable()
public: byte[]* GetCTable();
public:
array<byte>^ GetCTable();

Return Value

Array of bytes.
Remarks
Each entry in the table contains BaseColorComponents bytes, and the table is indexed 0 to HiVal, where HiVal is the highest index in the color table. The table is indexed from 0 to HiVal, thus the table contains HiVal + 1 entries.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members


%%PageItemTitle%% $$Properties$$

ImGearPDEColorSpace Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpace Class

For a list of all members of this type, see ImGearPDEColorSpace members.

Public Properties
 | Name | Description
Public Property | BaseColorComponents | Gets the number of components in the base color space of an indexed color space.
Public Property | BaseName | Gets the name of the base color space.
Public Property | ColorComponents | Gets the number of components in the color space.
Public Property | HiVal | Gets the highest index for the color lookup table for an indexed color space.
Public Property | Name | Gets the color space object's name.
Top
See Also

Reference

ImGearPDEColorSpace Class
ImageGear.Formats.PDF Namespace


BaseColorComponents Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : BaseColorComponents Property
Gets the number of components in the base color space of an indexed color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BaseColorComponents As Integer
'Usage

Dim instance As ImGearPDEColorSpace
Dim value As Integer

value = instance.BaseColorComponents
public int BaseColorComponents {get;}
public: __property int get_BaseColorComponents();
public:
property int BaseColorComponents {
   int get();
}

Property Value

Integer value.
Remarks
For example, for DeviceRGB, the number of components is 3.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members


BaseName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : BaseName Property
Gets the name of the base color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BaseName As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEColorSpace
Dim value As ImGearPDFAtom

value = instance.BaseName
public ImGearPDFAtom BaseName {get;}
public: __property ImGearPDFAtom* get_BaseName();
public:
property ImGearPDFAtom^ BaseName {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
Remarks
This is a helper routine for indexed color spaces.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members
ImGearPDFAtom Class


ColorComponents Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : ColorComponents Property
Gets the number of components in the color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorComponents As Integer
'Usage

Dim instance As ImGearPDEColorSpace
Dim value As Integer

value = instance.ColorComponents
public int ColorComponents {get;}
public: __property int get_ColorComponents();
public:
property int ColorComponents {
   int get();
}

Property Value

Can be 1, 3, or 4.
Remarks
This property gets the number of components in the color space. For the following color spaces the number of components is:
  • DeviceGray, CalGray, Separation: 1.
  • DeviceRGB, CalRGB: 3.
  • DeviceCMYK, Lab: 4.
  • DeviceN, ICCBased: the number of components dependent on the specific color space object
  • Indexed: 1.

Use BaseColorComponents to get the number of components in the base color space.

See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members


HiVal Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : HiVal Property
Gets the highest index for the color lookup table for an indexed color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HiVal As Integer
'Usage

Dim instance As ImGearPDEColorSpace
Dim value As Integer

value = instance.HiVal
public int HiVal {get;}
public: __property int get_HiVal();
public:
property int HiVal {
   int get();
}

Property Value

Integer value.
Remarks
Since the color table is indexed from 0 to HiVal, the actual number of entries is HiVal + 1.
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members


Name Property (ImGearPDEColorSpace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpace Class : Name Property
Gets the color space object's name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEColorSpace
Dim value As ImGearPDFAtom

value = instance.Name
public ImGearPDFAtom Name {get;}
public: __property ImGearPDFAtom* get_Name();
public:
property ImGearPDFAtom^ Name {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
Remarks
Supports the following PDF color spaces:
  • Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.
  • Device-independent names: CalGray, CalRGB, Lab, or ICCBased.
  • Special names: Indexed, Pattern, or Separation..
See Also

Reference

ImGearPDEColorSpace Class
ImGearPDEColorSpace Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEColorSpec Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpec Class
Represents PDE color specification.
Object Model
ImGearPDEColorSpec Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorSpec
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDEColorSpec
public sealed class ImGearPDEColorSpec : ImGearPDFObject
public __gc __sealed class ImGearPDEColorSpec : public ImGearPDFObject
public ref class ImGearPDEColorSpec sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEColorSpec

See Also

Reference

ImGearPDEColorSpec Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorSpec Class Members
Fields Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpec Class

The following tables list the members exposed by ImGearPDEColorSpec.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorSpec Constructor | Initializes a new instance of the ImGearPDEColorSpec class.
Top
Public Fields
 | Name | Description
Public Field | Space | Color space object.
Public Field | Value | Color value object.
Top
See Also

Reference

ImGearPDEColorSpec Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorSpec Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpec Class : ImGearPDEColorSpec Constructor
Initializes a new instance of the ImGearPDEColorSpec class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorSpec()
public ImGearPDEColorSpec()
public: ImGearPDEColorSpec();
public:
ImGearPDEColorSpec();

Return Value

The new instance of ImGearPDEColorSpec class object.
See Also

Reference

ImGearPDEColorSpec Class
ImGearPDEColorSpec Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorSpec Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpec Class

For a list of all members of this type, see ImGearPDEColorSpec members.

Public Fields
 | Name | Description
Public Field | Space | Color space object.
Public Field | Value | Color value object.
Top
See Also

Reference

ImGearPDEColorSpec Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEColorSpec Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorSpec Class

For a list of all members of this type, see ImGearPDEColorSpec members.

See Also

Reference

ImGearPDEColorSpec Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorSpec Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpec Class : ImGearPDEColorSpec Constructor
Overload List
Overload | Description
ImGearPDEColorSpec Constructor | Initializes a new instance of the ImGearPDEColorSpec class.
See Also

Reference

ImGearPDEColorSpec Class
ImGearPDEColorSpec Members


Space Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpec Class : Space Field
Color space object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Space As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEColorSpec
Dim value As ImGearPDEColorSpace

value = instance.Space

instance.Space = value
public ImGearPDEColorSpace Space
public: ImGearPDEColorSpace* Space
public:
ImGearPDEColorSpace^ Space

Field Value

ImGearPDEColorSpace class object.
See Also

Reference

ImGearPDEColorSpec Class
ImGearPDEColorSpec Members
ImGearPDEColorSpace Class


Value Field (ImGearPDEColorSpec)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorSpec Class : Value Field
Color value object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Value As ImGearPDEColorValue
'Usage

Dim instance As ImGearPDEColorSpec
Dim value As ImGearPDEColorValue

value = instance.Value

instance.Value = value
public ImGearPDEColorValue Value
public: ImGearPDEColorValue* Value
public:
ImGearPDEColorValue^ Value

Field Value

ImGearPDEColorValue class object.
See Also

Reference

ImGearPDEColorSpec Class
ImGearPDEColorSpec Members
ImGearPDEColorValue Class


%%PageItemTitle%%

ImGearPDEColorValue Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorValue Class
Represents PDE color value.
Object Model
ImGearPDEColorValue Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEColorValue
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDEColorValue
public sealed class ImGearPDEColorValue : ImGearPDFObject
public __gc __sealed class ImGearPDEColorValue : public ImGearPDFObject
public ref class ImGearPDEColorValue sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEColorValue

See Also

Reference

ImGearPDEColorValue Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEColorValue Class Members
Fields Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorValue Class

The following tables list the members exposed by ImGearPDEColorValue.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEColorValue Constructor | Initializes a new instance of the ImGearPDEColorValue class.
Top
Public Fields
 | Name | Description
Public Field | Color | Color value components.
Public Field | ColorObj | Parameter for color spaces whose color values do not have numeric values.
Public Field | ColorObj2 | Parameter for DeviceN color space.
Top
See Also

Reference

ImGearPDEColorValue Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorValue Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorValue Class : ImGearPDEColorValue Constructor
Initializes a new instance of the ImGearPDEColorValue class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEColorValue()
public ImGearPDEColorValue()
public: ImGearPDEColorValue();
public:
ImGearPDEColorValue();

Return Value

The new instance of ImGearPDEColorValue class object.
See Also

Reference

ImGearPDEColorValue Class
ImGearPDEColorValue Members


%%PageItemTitle%% $$Fields$$

ImGearPDEColorValue Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorValue Class

For a list of all members of this type, see ImGearPDEColorValue members.

Public Fields
 | Name | Description
Public Field | Color | Color value components.
Public Field | ColorObj | Parameter for color spaces whose color values do not have numeric values.
Public Field | ColorObj2 | Parameter for DeviceN color space.
Top
See Also

Reference

ImGearPDEColorValue Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEColorValue Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEColorValue Class

For a list of all members of this type, see ImGearPDEColorValue members.

See Also

Reference

ImGearPDEColorValue Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEColorValue Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorValue Class : ImGearPDEColorValue Constructor
Overload List
Overload | Description
ImGearPDEColorValue Constructor | Initializes a new instance of the ImGearPDEColorValue class.
See Also

Reference

ImGearPDEColorValue Class
ImGearPDEColorValue Members


Color Field (ImGearPDEColorValue)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorValue Class : Color Field
Color value components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Color As Integer()
'Usage

Dim instance As ImGearPDEColorValue
Dim value() As Integer

value = instance.Color

instance.Color = value
public int[] Color
public: int[]* Color
public:
array<int>^ Color

Field Value

Array of 1, 3 or 4 integer values.
Remarks
Gray color space has 1 component, RGB color space has 3 components and CMYK has 4 components.
See Also

Reference

ImGearPDEColorValue Class
ImGearPDEColorValue Members


ColorObj Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorValue Class : ColorObj Field
Parameter for color spaces whose color values do not have numeric values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ColorObj As ImGearPDEObject
'Usage

Dim instance As ImGearPDEColorValue
Dim value As ImGearPDEObject

value = instance.ColorObj

instance.ColorObj = value
public ImGearPDEObject ColorObj
public: ImGearPDEObject* ColorObj
public:
ImGearPDEObject^ ColorObj

Field Value

ImGearPDEObject class object.
Remarks
Parameter for color spaces whose color values do not have numeric values, such as the Pattern and Separation color spaces.
See Also

Reference

ImGearPDEColorValue Class
ImGearPDEColorValue Members
ImGearPDEObject Class


ColorObj2 Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEColorValue Class : ColorObj2 Field
Parameter for DeviceN color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ColorObj2 As ImGearPDEObject
'Usage

Dim instance As ImGearPDEColorValue
Dim value As ImGearPDEObject

value = instance.ColorObj2

instance.ColorObj2 = value
public ImGearPDEObject ColorObj2
public: ImGearPDEObject* ColorObj2
public:
ImGearPDEObject^ ColorObj2

Field Value

ImGearPDEObject class object.
See Also

Reference

ImGearPDEColorValue Class
ImGearPDEColorValue Members
ImGearPDEObject Class


%%PageItemTitle%%

ImGearPDEContainer Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContainer Class
Represents a group of elements on a page in a PDF file.
Object Model
ImGearPDEContainer ClassImGearPDEContent ClassImGearPDFBasDict ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEContainer
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEContainer
public sealed class ImGearPDEContainer : ImGearPDEElement
public __gc __sealed class ImGearPDEContainer : public ImGearPDEElement
public ref class ImGearPDEContainer sealed : public ImGearPDEElement
Remarks

In the PDF file, containers are delimited by Marked Content BMC/EMC or BDC/EMC pairs. Every container has a Marked Content tag associated with it. In addition to grouping a set of elements, a BDC/EMC pair specifies a property list to be associated with the grouping. Thus a container corresponding to a BDC/EMC pair also has a property list dictionary associated with it.

See Section 10.5 in the PDF reference for more information about Marked Content operators.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEContainer

See Also

Reference

ImGearPDEContainer Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEContainer Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContainer Class

The following tables list the members exposed by ImGearPDEContainer.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEContainer Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | IsDictionaryInline | Gets a value indicating whether the dictionary is inline.
Top
Public Methods
 | Name | Description
Public Method | GetContent | Gets container's content object.
Public Method | GetDictionary | Gets marked Content dictionary for a container.
Public Method | GetMCTag | Gets Marked Content tag for a container.
Public Method | SetContent | Sets container's content object.
Public Method | SetDictionary | Changes the Marked Content dictionary for the container.
Public Method | SetMCTag | Sets Marked Content tag for a container.
Top
See Also

Reference

ImGearPDEContainer Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEContainer Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : ImGearPDEContainer Constructor
Overload List
Overload | Description
ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFBasObj,Boolean) | Initializes a new instance of the ImGearPDEContainer class.
ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFDictionary,Boolean) | Initializes a new instance of the ImGearPDEContainer class.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members


%%PageItemTitle%%

ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFBasObj,Boolean)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class > ImGearPDEContainer Constructor : ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFBasObj,Boolean)
Tag name for the container.
Optional Marked Content dictionary for the container.
If True, emits container into the page content stream inline.
Initializes a new instance of the ImGearPDEContainer class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As ImGearPDFAtom, _
   ByVal dictionary As ImGearPDFBasObj, _
   ByVal isInline As Boolean _
)
'Usage

Dim tag As ImGearPDFAtom
Dim dictionary As ImGearPDFBasObj
Dim isInline As Boolean

Dim instance As New ImGearPDEContainer(tag, dictionary, isInline)
public ImGearPDEContainer(
   ImGearPDFAtom tag,
   ImGearPDFBasObj dictionary,
   bool isInline
)
public: ImGearPDEContainer(
   ImGearPDFAtom* tag,
   ImGearPDFBasObj* dictionary,
   bool isInline
)
public:
ImGearPDEContainer(
   ImGearPDFAtom^ tag,
   ImGearPDFBasObj^ dictionary,
   bool isInline
)

Parameters

tag
Tag name for the container.
dictionary
Optional Marked Content dictionary for the container.
isInline
If True, emits container into the page content stream inline.

Return Value

The new instance of ImGearPDEContainer class object.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
Overload List
ImGearPDFAtom Class
ImGearPDFBasObj Class


%%PageItemTitle%%

ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFDictionary,Boolean)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class > ImGearPDEContainer Constructor : ImGearPDEContainer Constructor(ImGearPDFAtom,ImGearPDFDictionary,Boolean)
Tag name for the container.
Optional Marked Content dictionary for the container.
If True, emits container into the page content stream inline.
Initializes a new instance of the ImGearPDEContainer class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As ImGearPDFAtom, _
   ByVal dictionary As ImGearPDFDictionary, _
   ByVal isInline As Boolean _
)
'Usage

Dim tag As ImGearPDFAtom
Dim dictionary As ImGearPDFDictionary
Dim isInline As Boolean

Dim instance As New ImGearPDEContainer(tag, dictionary, isInline)
public ImGearPDEContainer(
   ImGearPDFAtom tag,
   ImGearPDFDictionary dictionary,
   bool isInline
)
public: ImGearPDEContainer(
   ImGearPDFAtom* tag,
   ImGearPDFDictionary* dictionary,
   bool isInline
)
public:
ImGearPDEContainer(
   ImGearPDFAtom^ tag,
   ImGearPDFDictionary^ dictionary,
   bool isInline
)

Parameters

tag
Tag name for the container.
dictionary
Optional Marked Content dictionary for the container.
isInline
If True, emits container into the page content stream inline.

Return Value

The new instance of ImGearPDEContainer class object.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
Overload List
ImGearPDFAtom Class
ImGearPDFDictionary Class


%%PageItemTitle%% $$Methods$$

ImGearPDEContainer Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContainer Class

For a list of all members of this type, see ImGearPDEContainer members.

Public Methods
 | Name | Description
Public Method | GetContent | Gets container's content object.
Public Method | GetDictionary | Gets marked Content dictionary for a container.
Public Method | GetMCTag | Gets Marked Content tag for a container.
Public Method | SetContent | Sets container's content object.
Public Method | SetDictionary | Changes the Marked Content dictionary for the container.
Public Method | SetMCTag | Sets Marked Content tag for a container.
Top
See Also

Reference

ImGearPDEContainer Class
ImageGear.Formats.PDF Namespace


GetContent Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : GetContent Method
Gets container's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearPDEContent
'Usage

Dim instance As ImGearPDEContainer
Dim value As ImGearPDEContent

value = instance.GetContent()
public ImGearPDEContent GetContent()
public: ImGearPDEContent* GetContent();
public:
ImGearPDEContent^ GetContent();

Return Value

ImGearPDEContent class object.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDEContent Class


GetDictionary Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : GetDictionary Method
Gets marked Content dictionary for a container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDEContainer
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public new ImGearPDFBasDict GetDictionary()
public: new ImGearPDFBasDict* GetDictionary();
public:
new ImGearPDFBasDict^ GetDictionary();

Return Value

ImGearPDFBasDict class object.
Remarks
Null if the container has no Marked Content dictionary.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDFBasDict Class


GetMCTag Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : GetMCTag Method
Gets Marked Content tag for a container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMCTag() As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEContainer
Dim value As ImGearPDFAtom

value = instance.GetMCTag()
public ImGearPDFAtom GetMCTag()
public: ImGearPDFAtom* GetMCTag();
public:
ImGearPDFAtom^ GetMCTag();

Return Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDFAtom Class


SetContent Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : SetContent Method
Container's content object.
Sets container's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetContent( _
   ByVal content As ImGearPDEContent _
)
'Usage

Dim instance As ImGearPDEContainer
Dim content As ImGearPDEContent

instance.SetContent(content)
public void SetContent(
   ImGearPDEContent content
)
public: void SetContent(
   ImGearPDEContent* content
)
public:
void SetContent(
   ImGearPDEContent^ content
)

Parameters

content
Container's content object.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDEContent Class


SetDictionary Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : SetDictionary Method
Marked Content dictionary being set into the container.
If True, the dictionary is emitted inline.
Changes the Marked Content dictionary for the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDictionary( _
   ByVal dictionary As ImGearPDFBasDict, _
   ByVal isInline As Boolean _
)
'Usage

Dim instance As ImGearPDEContainer
Dim dictionary As ImGearPDFBasDict
Dim isInline As Boolean

instance.SetDictionary(dictionary, isInline)
public void SetDictionary(
   ImGearPDFBasDict dictionary,
   bool isInline
)
public: void SetDictionary(
   ImGearPDFBasDict* dictionary,
   bool isInline
)
public:
void SetDictionary(
   ImGearPDFBasDict^ dictionary,
   bool isInline
)

Parameters

dictionary
Marked Content dictionary being set into the container.
isInline
If True, the dictionary is emitted inline.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDFBasDict Class


SetMCTag Method (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : SetMCTag Method
Marked Content tag for a container.
Sets Marked Content tag for a container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMCTag( _
   ByVal tag As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDEContainer
Dim tag As ImGearPDFAtom

instance.SetMCTag(tag)
public void SetMCTag(
   ImGearPDFAtom tag
)
public: void SetMCTag(
   ImGearPDFAtom* tag
)
public:
void SetMCTag(
   ImGearPDFAtom^ tag
)

Parameters

tag
Marked Content tag for a container.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members
ImGearPDFAtom Class


%%PageItemTitle%% $$Properties$$

ImGearPDEContainer Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContainer Class

For a list of all members of this type, see ImGearPDEContainer members.

Public Properties
 | Name | Description
Public Property | IsDictionaryInline | Gets a value indicating whether the dictionary is inline.
Top
See Also

Reference

ImGearPDEContainer Class
ImageGear.Formats.PDF Namespace


IsDictionaryInline Property (ImGearPDEContainer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContainer Class : IsDictionaryInline Property
Gets a value indicating whether the dictionary is inline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsDictionaryInline As Boolean
'Usage

Dim instance As ImGearPDEContainer
Dim value As Boolean

value = instance.IsDictionaryInline
public bool IsDictionaryInline {get;}
public: __property bool get_IsDictionaryInline();
public:
property bool IsDictionaryInline {
   bool get();
}

Property Value

Boolean value.
Remarks
Undefined if the container has no Marked Content dictionary.
See Also

Reference

ImGearPDEContainer Class
ImGearPDEContainer Members


%%PageItemTitle%%

ImGearPDEContent Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContent Class
Represents a modifiable content of a PDF page, which contains elements.
Object Model
ImGearPDEContent ClassImGearPDEContent ClassImGearPDEContentAttrs ClassImGearPDEColorSpace ClassImGearPDEElement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEContent
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDEContent
public sealed class ImGearPDEContent : ImGearPDEObject
public __gc __sealed class ImGearPDEContent : public ImGearPDEObject
public ref class ImGearPDEContent sealed : public ImGearPDEObject
Remarks
Content may be obtained from an existing page or from a Form XObject.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEContent

See Also

Reference

ImGearPDEContent Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEContent Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContent Class

The following tables list the members exposed by ImGearPDEContent.

Public Properties
 | Name | Description
Public Property | ElementCount | Gets a number of elements in the ImGearPDEContent.
Top
Public Methods
 | Name | Description
Public Method | AddElement | Inserts an element into content.
static (Shared in Visual Basic) | CreateEmptyContent | Creates empty ImGearPDEContent.
Public Method | GetAttributes | Gets the content attributes.
Public Method | GetDefaultColorSpace | Gets a default color space from the current content.
Public Method | GetElement | Obtains requested element from content.
Public Method | RemoveElement | Removes an element from content.
Top
See Also

Reference

ImGearPDEContent Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEContent Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContent Class

For a list of all members of this type, see ImGearPDEContent members.

Public Methods
 | Name | Description
Public Method | AddElement | Inserts an element into content.
static (Shared in Visual Basic) | CreateEmptyContent | Creates empty ImGearPDEContent.
Public Method | GetAttributes | Gets the content attributes.
Public Method | GetDefaultColorSpace | Gets a default color space from the current content.
Public Method | GetElement | Obtains requested element from content.
Public Method | RemoveElement | Removes an element from content.
Top
See Also

Reference

ImGearPDEContent Class
ImageGear.Formats.PDF Namespace


AddElement Method (ImGearPDEContent)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : AddElement Method
Location after which Element is added. Should be BEFORE_FIRST_PAGE to add to the beginning of the display list.
ImGearPDEElement interface of the element to insert into content.
Inserts an element into content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddElement( _
   ByVal precedingIndex As Integer, _
   ByVal element As ImGearPDEElement _
)
'Usage

Dim instance As ImGearPDEContent
Dim precedingIndex As Integer
Dim element As ImGearPDEElement

instance.AddElement(precedingIndex, element)
public void AddElement(
   int precedingIndex,
   ImGearPDEElement element
)
public: void AddElement(
   int precedingIndex,
   ImGearPDEElement* element
)
public:
void AddElement(
   int precedingIndex,
   ImGearPDEElement^ element
)

Parameters

precedingIndex
Location after which Element is added. Should be BEFORE_FIRST_PAGE to add to the beginning of the display list.
element
ImGearPDEElement interface of the element to insert into content.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members
ImGearPDEElement Class


CreateEmptyContent Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : CreateEmptyContent Method
Creates empty ImGearPDEContent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateEmptyContent() As ImGearPDEContent
'Usage

Dim value As ImGearPDEContent

value = ImGearPDEContent.CreateEmptyContent()
public static ImGearPDEContent CreateEmptyContent()
public: static ImGearPDEContent* CreateEmptyContent();
public:
static ImGearPDEContent^ CreateEmptyContent();

Return Value

The empty ImGearPDEContent class.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members
ImGearPDEElement Class


GetAttributes Method (ImGearPDEContent)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : GetAttributes Method
Gets the content attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttributes() As ImGearPDEContentAttrs
'Usage

Dim instance As ImGearPDEContent
Dim value As ImGearPDEContentAttrs

value = instance.GetAttributes()
public ImGearPDEContentAttrs GetAttributes()
public: ImGearPDEContentAttrs* GetAttributes();
public:
ImGearPDEContentAttrs^ GetAttributes();

Return Value

ImGearPDEContentAttrs class object.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members
ImGearPDEContentAttrs Class


GetDefaultColorSpace Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : GetDefaultColorSpace Method
An atom for the name of the desired color space. Must be an atom for one of DefaultRGB, DefaultCMYK, or DefaultGray.
Gets a default color space from the current content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDefaultColorSpace( _
   ByVal colorSpaceName As ImGearPDFAtom _
) As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEContent
Dim colorSpaceName As ImGearPDFAtom
Dim value As ImGearPDEColorSpace

value = instance.GetDefaultColorSpace(colorSpaceName)
public ImGearPDEColorSpace GetDefaultColorSpace(
   ImGearPDFAtom colorSpaceName
)
public: ImGearPDEColorSpace* GetDefaultColorSpace(
   ImGearPDFAtom* colorSpaceName
)
public:
ImGearPDEColorSpace^ GetDefaultColorSpace(
   ImGearPDFAtom^ colorSpaceName
)

Parameters

colorSpaceName
An atom for the name of the desired color space. Must be an atom for one of DefaultRGB, DefaultCMYK, or DefaultGray.

Return Value

ImGearPDEColorSpace class object. Returns Null, if ColorSpaceName does not correspond to a known default, such as DefaultRGB.
Remarks

See Section 4.5.4 in the PDF Reference for more information about default color spaces.

See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members
ImGearPDEColorSpace Class
ImGearPDFAtom Class


GetElement Method (ImGearPDEContent)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : GetElement Method
Index of the element to get.
Obtains requested element from content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetElement( _
   ByVal index As Integer _
) As ImGearPDEElement
'Usage

Dim instance As ImGearPDEContent
Dim index As Integer
Dim value As ImGearPDEElement

value = instance.GetElement(index)
public ImGearPDEElement GetElement(
   int index
)
public: ImGearPDEElement* GetElement(
   int index
)
public:
ImGearPDEElement^ GetElement(
   int index
)

Parameters

index
Index of the element to get.

Return Value

ImGearPDEElement class object.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members
ImGearPDEElement Class


RemoveElement Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : RemoveElement Method
Index of the element to remove.
Removes an element from content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveElement( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearPDEContent
Dim index As Integer

instance.RemoveElement(index)
public void RemoveElement(
   int index
)
public: void RemoveElement(
   int index
)
public:
void RemoveElement(
   int index
)

Parameters

index
Index of the element to remove.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members


%%PageItemTitle%% $$Properties$$

ImGearPDEContent Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContent Class

For a list of all members of this type, see ImGearPDEContent members.

Public Properties
 | Name | Description
Public Property | ElementCount | Gets a number of elements in the ImGearPDEContent.
Top
See Also

Reference

ImGearPDEContent Class
ImageGear.Formats.PDF Namespace


ElementCount Property (ImGearPDEContent)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContent Class : ElementCount Property
Gets a number of elements in the ImGearPDEContent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ElementCount As Integer
'Usage

Dim instance As ImGearPDEContent
Dim value As Integer

value = instance.ElementCount
public int ElementCount {get;}
public: __property int get_ElementCount();
public:
property int ElementCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDEContent Class
ImGearPDEContent Members


%%PageItemTitle%%

ImGearPDEContentAttrs Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContentAttrs Class
Provides attributes of the PDE Content object.
Object Model
ImGearPDEContentAttrs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEContentAttrs
'Usage

Dim instance As ImGearPDEContentAttrs
public sealed class ImGearPDEContentAttrs
public __gc __sealed class ImGearPDEContentAttrs
public ref class ImGearPDEContentAttrs sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEContentAttrs

See Also

Reference

ImGearPDEContentAttrs Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEContentAttrs Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContentAttrs Class

The following tables list the members exposed by ImGearPDEContentAttrs.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEContentAttrs Constructor | Initializes a new instance of the ImGearPDEContentAttrs class.
Top
Public Fields
 | Name | Description
Public Field | BBox | Bounding box of the content object.
Public Field | CacheDevice | Six cache device values contain the operands for the d1 (setcachdevice) page operator or 2 charwidth values.
Public Field | Flags | Content flags.
Public Field | FormType | Corresponds to FormType key in the XObject Form attributes dictionary.
Public Field | Matrix | Transformation matrix for the content object.
Top
See Also

Reference

ImGearPDEContentAttrs Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEContentAttrs Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : ImGearPDEContentAttrs Constructor
Initializes a new instance of the ImGearPDEContentAttrs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEContentAttrs()
public ImGearPDEContentAttrs()
public: ImGearPDEContentAttrs();
public:
ImGearPDEContentAttrs();

Return Value

The new instance of ImGearPDEContentAttrs class object.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members


%%PageItemTitle%% $$Fields$$

ImGearPDEContentAttrs Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContentAttrs Class

For a list of all members of this type, see ImGearPDEContentAttrs members.

Public Fields
 | Name | Description
Public Field | BBox | Bounding box of the content object.
Public Field | CacheDevice | Six cache device values contain the operands for the d1 (setcachdevice) page operator or 2 charwidth values.
Public Field | Flags | Content flags.
Public Field | FormType | Corresponds to FormType key in the XObject Form attributes dictionary.
Public Field | Matrix | Transformation matrix for the content object.
Top
See Also

Reference

ImGearPDEContentAttrs Class
ImageGear.Formats.PDF Namespace


BBox Field (ImGearPDEContentAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : BBox Field
Bounding box of the content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BBox As ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDEContentAttrs
Dim value As ImGearPDFFixedRect

value = instance.BBox

instance.BBox = value
public ImGearPDFFixedRect BBox
public: ImGearPDFFixedRect* BBox
public:
ImGearPDFFixedRect^ BBox

Field Value

ImGearPDFFixedRect class object.
Remarks
Only used if the content contains a Form. Corresponds to BBox key in the XObject Form attributes dictionary.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members
ImGearPDFFixedRect Class


CacheDevice Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : CacheDevice Field
Six cache device values contain the operands for the d1 (setcachdevice) page operator or 2 charwidth values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<MarshalAsAttribute(UnmanagedType.Bool Or  _
    UnmanagedType.U1 Or  _
    UnmanagedType.U2 Or  _
    UnmanagedType.U4 Or  _
    UnmanagedType.U8 Or  _
    UnmanagedType.R8 Or  _
    UnmanagedType.LPStr Or  _
    UnmanagedType.LPTStr Or  _
    UnmanagedType.IDispatch Or  _
    UnmanagedType.Interface Or  _
    UnmanagedType.ByValArray)>
Public CacheDevice As Integer()
'Usage

Dim instance As ImGearPDEContentAttrs
Dim value() As Integer

value = instance.CacheDevice

instance.CacheDevice = value
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public int[] CacheDevice
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public: int[]* CacheDevice
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public:
array<int>^ CacheDevice

Field Value

Array of integer values.
Remarks
If flags has SET_CACHE_DEVICE set, the first 6 cache device values contain the operands for the d1 (setcachdevice) page operator. If flags has SET_CHAR_WIDTH set, cacheDevice contains 2 charwidth values. The default value is {0, 0, 0, 0, 0, 0, 0, 0}.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members


Flags Field (ImGearPDEContentAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : Flags Field
Content flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Flags As ImGearPDEContentFlags
'Usage

Dim instance As ImGearPDEContentAttrs
Dim value As ImGearPDEContentFlags

value = instance.Flags

instance.Flags = value
public ImGearPDEContentFlags Flags
public: ImGearPDEContentFlags Flags
public:
ImGearPDEContentFlags Flags

Field Value

Combination of ImGearPDEContentFlags enumeration values.
Remarks
The default value is ImGearPDEContentFlags.NOT_SET.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members
ImGearPDEContentFlags Enumeration


FormType Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : FormType Field
Corresponds to FormType key in the XObject Form attributes dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FormType As Integer
'Usage

Dim instance As ImGearPDEContentAttrs
Dim value As Integer

value = instance.FormType

instance.FormType = value
public int FormType
public: int FormType
public:
int FormType

Field Value

Integer value.
Remarks
Only used if the content contains a Form XObject. The default value is 0.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members


Matrix Field (ImGearPDEContentAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEContentAttrs Class : Matrix Field
Transformation matrix for the content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Matrix As ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDEContentAttrs
Dim value As ImGearPDFFixedMatrix

value = instance.Matrix

instance.Matrix = value
public ImGearPDFFixedMatrix Matrix
public: ImGearPDFFixedMatrix* Matrix
public:
ImGearPDFFixedMatrix^ Matrix

Field Value

ImGearPDFFixedMatrix class object.
Remarks
Only used if the content contains a Form. Corresponds to Matrix key in the XObject Form attributes dictionary, which specifies the mapping from form space to the current user space. Each time the form XObject is painted by the Do operator, this matrix is concatenated with the current transformation matrix to define the mapping from form space to device space. See section '4.9 Form XObjects' of the PDF Reference for more details.
See Also

Reference

ImGearPDEContentAttrs Class
ImGearPDEContentAttrs Members
ImGearPDFFixedMatrix Class


%%PageItemTitle%%

ImGearPDEDash Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEDash Class
Represents PDE dash.
Object Model
ImGearPDEDash Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEDash
'Usage

Dim instance As ImGearPDEDash
public sealed class ImGearPDEDash
public __gc __sealed class ImGearPDEDash
public ref class ImGearPDEDash sealed
Remarks
See Section 4.3.2 for more information on line dash patterns.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEDash

See Also

Reference

ImGearPDEDash Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEDash Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEDash Class

The following tables list the members exposed by ImGearPDEDash.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEDash Constructor | Initializes a new instance of the ImGearPDEDash class.
Top
Public Fields
 | Name | Description
Public Field | Dashes | Gets or sets the dash array.
Top
Public Properties
 | Name | Description
Public Property | Phase | Gets or sets the dash phase.
Top
See Also

Reference

ImGearPDEDash Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEDash Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEDash Class : ImGearPDEDash Constructor
Initializes a new instance of the ImGearPDEDash class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEDash()
public ImGearPDEDash()
public: ImGearPDEDash();
public:
ImGearPDEDash();

Return Value

The new instance of ImGearPDEDash class object.
See Also

Reference

ImGearPDEDash Class
ImGearPDEDash Members


%%PageItemTitle%% $$Properties$$

ImGearPDEDash Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEDash Class

For a list of all members of this type, see ImGearPDEDash members.

Public Properties
 | Name | Description
Public Property | Phase | Gets or sets the dash phase.
Top
See Also

Reference

ImGearPDEDash Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEDash Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEDash Class : ImGearPDEDash Constructor
Overload List
Overload | Description
ImGearPDEDash Constructor | Initializes a new instance of the ImGearPDEDash class.
See Also

Reference

ImGearPDEDash Class
ImGearPDEDash Members


Phase Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEDash Class : Phase Property
Gets or sets the dash phase.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Phase As Integer
'Usage

Dim instance As ImGearPDEDash
Dim value As Integer

instance.Phase = value

value = instance.Phase
public int Phase {get; set;}
public: __property int get_Phase();
public: __property void set_Phase(
   int value
);
public:
property int Phase {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
A number that specifies a distance in user space into the dash pattern at which to begin marking the path. The default value is 0.
See Also

Reference

ImGearPDEDash Class
ImGearPDEDash Members


%%PageItemTitle%% $$Fields$$

ImGearPDEDash Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEDash Class

For a list of all members of this type, see ImGearPDEDash members.

Public Fields
 | Name | Description
Public Field | Dashes | Gets or sets the dash array.
Top
See Also

Reference

ImGearPDEDash Class
ImageGear.Formats.PDF Namespace


Dashes Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEDash Class : Dashes Field
Gets or sets the dash array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Dashes As Integer()
'Usage

Dim instance As ImGearPDEDash
Dim value() As Integer

value = instance.Dashes

instance.Dashes = value
public int[] Dashes
public: int[]* Dashes
public:
array<int>^ Dashes

Field Value

Array of integer values.
Remarks
Array that specifies distances in user space for the length of dashes and gaps.
See Also

Reference

ImGearPDEDash Class
ImGearPDEDash Members


%%PageItemTitle%%

ImGearPDEElement Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEElement Class
Represents base class for the elements of a page display list (PDE content) and for clip objects.
Object Model
ImGearPDEElement ClassImGearPDEElement ClassImGearPDFFixedRect ClassImGearPDEClip ClassImGearPDFDictionary ClassImGearPDEGraphicState ClassImGearPDFFixedMatrix ClassImGearPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPDEElement
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDEElement
public abstract class ImGearPDEElement : ImGearPDEObject
public __gc abstract class ImGearPDEElement : public ImGearPDEObject
public ref class ImGearPDEElement abstract : public ImGearPDEObject
Remarks
The general PDE element methods allow you to get and set general element properties.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEClip
ImageGear.Formats.PDF.ImGearPDEContainer
ImageGear.Formats.PDF.ImGearPDEForm
ImageGear.Formats.PDF.ImGearPDEGroup
ImageGear.Formats.PDF.ImGearPDEImage
ImageGear.Formats.PDF.ImGearPDEPath
ImageGear.Formats.PDF.ImGearPDEPlace
ImageGear.Formats.PDF.ImGearPDEPostScript
ImageGear.Formats.PDF.ImGearPDEShading
ImageGear.Formats.PDF.ImGearPDESoftMask
ImageGear.Formats.PDF.ImGearPDEText
ImageGear.Formats.PDF.ImGearPDETextItem
ImageGear.Formats.PDF.ImGearPDEXGroup
ImageGear.Formats.PDF.ImGearPDEXObject

See Also

Reference

ImGearPDEElement Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEElement Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEElement Class

The following tables list the members exposed by ImGearPDEElement.

Public Properties
 | Name | Description
Public Property | HasGState | Gets a value indicating whether the element has a graphics state.
Public Property | UniqueId | Gets some 32-bit integer that is unique for all Element objects.
Top
Public Methods
 | Name | Description
Public Method | Clone | Makes a copy of an element.
Public Method | GetBBox | Gets the bounding box for an element, specified in user space coordinates.
Public Method | GetClip | Gets the current clip for an element.
Public Method | GetDictionary | Returns a Dictionary (OCMD object) that is associated with this Element.
Public Method | GetGState | Gets the graphics state information for an element.
Public Method | GetMatrix | Gets the transformation matrix for an element.
Public Method | GetOCMDictionary | Gets a dictionary (OCMD object), which is associated with this Element.
Public Method | IsAtPoint | Tests whether a point is on an element.
Public Method | IsAtRect | Tests whether any part of a rectangle is on an element.
Public Method | SetClip | Sets the current clip for an element.
Public Method | SetGState | Sets the graphics state information for an element.
Public Method | SetMatrix | Sets the transformation matrix for an element.
Top
See Also

Reference

ImGearPDEElement Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEElement Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEElement Class

For a list of all members of this type, see ImGearPDEElement members.

Public Methods
 | Name | Description
Public Method | Clone | Makes a copy of an element.
Public Method | GetBBox | Gets the bounding box for an element, specified in user space coordinates.
Public Method | GetClip | Gets the current clip for an element.
Public Method | GetDictionary | Returns a Dictionary (OCMD object) that is associated with this Element.
Public Method | GetGState | Gets the graphics state information for an element.
Public Method | GetMatrix | Gets the transformation matrix for an element.
Public Method | GetOCMDictionary | Gets a dictionary (OCMD object), which is associated with this Element.
Public Method | IsAtPoint | Tests whether a point is on an element.
Public Method | IsAtRect | Tests whether any part of a rectangle is on an element.
Public Method | SetClip | Sets the current clip for an element.
Public Method | SetGState | Sets the graphics state information for an element.
Public Method | SetMatrix | Sets the transformation matrix for an element.
Top
See Also

Reference

ImGearPDEElement Class
ImageGear.Formats.PDF Namespace


Clone Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : Clone Method
Bit field of enumImGearPDEElementCopyFlags.
Makes a copy of an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone( _
   ByVal options As ImGearPDEElementCopyFlags _
) As ImGearPDEElement
'Usage

Dim instance As ImGearPDEElement
Dim options As ImGearPDEElementCopyFlags
Dim value As ImGearPDEElement

value = instance.Clone(options)
public ImGearPDEElement Clone(
   ImGearPDEElementCopyFlags options
)
public: ImGearPDEElement* Clone(
   ImGearPDEElementCopyFlags options
)
public:
ImGearPDEElement^ Clone(
   ImGearPDEElementCopyFlags options
)

Parameters

options
Bit field of enumImGearPDEElementCopyFlags.

Return Value

ImGearPDEElement class object.
See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDEElementCopyFlags Enumeration


GetBBox Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetBBox Method
Gets the bounding box for an element, specified in user space coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBBox() As ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDFFixedRect

value = instance.GetBBox()
public ImGearPDFFixedRect GetBBox()
public: ImGearPDFFixedRect* GetBBox();
public:
ImGearPDFFixedRect^ GetBBox();

Return Value

ImGearPDFFixedRect class object.
Remarks

The bounding box is guaranteed to encompass the element, but is not guaranteed to be the smallest box that could contain the element. For example, for an arc, the bounding box encloses the Bezier control points-not just the curve itself.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFFixedRect Class


GetClip Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetClip Method
Gets the current clip for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetClip() As ImGearPDEClip
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDEClip

value = instance.GetClip()
public ImGearPDEClip GetClip()
public: ImGearPDEClip* GetClip();
public:
ImGearPDEClip^ GetClip();

Return Value

ImGearPDEClip class object.
Remarks

A clip may be shared by many elements. Use care when modifying a clip. Copy it first if you want to modify the clip for a specific element.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDEClip Class


GetDictionary Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetDictionary Method
Returns a Dictionary (OCMD object) that is associated with this Element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDictionary() As ImGearPDFDictionary
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDFDictionary

value = instance.GetDictionary()
public ImGearPDFDictionary GetDictionary()
public: ImGearPDFDictionary* GetDictionary();
public:
ImGearPDFDictionary^ GetDictionary();

Return Value

Associated Dictionary, or Null if no Dictionary is associated.
Remarks
If no Dictionary is associated, returns Null.
See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFDictionary Class


GetGState Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetGState Method
Gets the graphics state information for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGState() As ImGearPDEGraphicState
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDEGraphicState

value = instance.GetGState()
public ImGearPDEGraphicState GetGState()
public: ImGearPDEGraphicState* GetGState();
public:
ImGearPDEGraphicState^ GetGState();

Return Value

ImGearPDEGraphicState class object.
Remarks

This method is only valid for PDE Form, PDE Image, PDE Path and PDE Shading elements.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDEGraphicState Class


GetMatrix Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetMatrix Method
Gets the transformation matrix for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatrix() As ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDFFixedMatrix

value = instance.GetMatrix()
public ImGearPDFFixedMatrix GetMatrix()
public: ImGearPDFFixedMatrix* GetMatrix();
public:
ImGearPDFFixedMatrix^ GetMatrix();

Return Value

ImGearPDFFixedMatrix class object.
Remarks

This matrix provides the transformation from user space to device space for the element. If there is no cm operator (concatmatrix) in the page stream, the matrix is the identity matrix.

For text object, it specifies the identity matrix.

Writing is not supported for PDE Container, a PDE Group, a PDE Place or a PDE Text.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFFixedMatrix Class


GetOCMDictionary Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : GetOCMDictionary Method
Gets a dictionary (OCMD object), which is associated with this Element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOCMDictionary() As ImGearPDFDictionary
'Usage

Dim instance As ImGearPDEElement
Dim value As ImGearPDFDictionary

value = instance.GetOCMDictionary()
public ImGearPDFDictionary GetOCMDictionary()
public: ImGearPDFDictionary* GetOCMDictionary();
public:
ImGearPDFDictionary^ GetOCMDictionary();

Return Value

Associated Dictionary, or null if no dictionary is associated.
Remarks
If no dictionary is associated, returns null.
See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFDictionary Class


IsAtPoint Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : IsAtPoint Method
A point, specified in user space coordinates.
Tests whether a point is on an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsAtPoint( _
   ByVal point As ImGearPDFFixedPoint _
) As Boolean
'Usage

Dim instance As ImGearPDEElement
Dim point As ImGearPDFFixedPoint
Dim value As Boolean

value = instance.IsAtPoint(point)
public bool IsAtPoint(
   ImGearPDFFixedPoint point
)
public: bool IsAtPoint(
   ImGearPDFFixedPoint* point
)
public:
bool IsAtPoint(
   ImGearPDFFixedPoint^ point
)

Parameters

point
A point, specified in user space coordinates.

Return Value

True if a point is on an element, False otherwise.
Remarks

If the current element is a Text or Image, it uses the bounding box of the element to make the check. If the current element is a Path and it is stroked, it checks if the point is on the path. If the current element is a Path and it is filled, it checks if the point is in the fill area, taking into consideration whether it is filled using the non-zero winding number rule or the even-odd rule.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFFixedPoint Class


IsAtRect Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : IsAtRect Method
A rectangle, specified in user space coordinates.
Tests whether any part of a rectangle is on an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsAtRect( _
   ByVal rect As ImGearPDFFixedRect _
) As Boolean
'Usage

Dim instance As ImGearPDEElement
Dim rect As ImGearPDFFixedRect
Dim value As Boolean

value = instance.IsAtRect(rect)
public bool IsAtRect(
   ImGearPDFFixedRect rect
)
public: bool IsAtRect(
   ImGearPDFFixedRect* rect
)
public:
bool IsAtRect(
   ImGearPDFFixedRect^ rect
)

Parameters

rect
A rectangle, specified in user space coordinates.

Return Value

True if any part of a rectangle is on an element, False otherwise.
Remarks

If the current element is a PDE Text or PDE Image, it uses the bounding box of the PDE Element to make the check. If the current element is a PDE Path and it is stroked, it checks if the rectangle is on the path.

If the current element is a PDE Path and it is filled, it checks if the rectangle is in the fill area, taking into consideration whether it is filled using the non-zero winding number rule or the even-odd rule.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFFixedRect Class


SetClip Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : SetClip Method
The clip for an element.
Sets the current clip for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetClip( _
   ByVal clip As ImGearPDEClip _
)
'Usage

Dim instance As ImGearPDEElement
Dim clip As ImGearPDEClip

instance.SetClip(clip)
public void SetClip(
   ImGearPDEClip clip
)
public: void SetClip(
   ImGearPDEClip* clip
)
public:
void SetClip(
   ImGearPDEClip^ clip
)

Parameters

clip
The clip for an element.
Remarks

A clip may be shared by many elements. Use care when modifying a clip. Copy it first if you want to modify the clip for a specific element.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDEClip Class


SetGState Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : SetGState Method
The graphics state information for an element.
Sets the graphics state information for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetGState( _
   ByVal graphicState As ImGearPDEGraphicState _
)
'Usage

Dim instance As ImGearPDEElement
Dim graphicState As ImGearPDEGraphicState

instance.SetGState(graphicState)
public void SetGState(
   ImGearPDEGraphicState graphicState
)
public: void SetGState(
   ImGearPDEGraphicState* graphicState
)
public:
void SetGState(
   ImGearPDEGraphicState^ graphicState
)

Parameters

graphicState
The graphics state information for an element.
Remarks

This method is only valid for PDE Form, PDE Image, PDE Path and PDE Shading elements.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDEGraphicState Class


SetMatrix Method (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : SetMatrix Method
The transformation matrix for an element.
Sets the transformation matrix for an element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatrix( _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDEElement
Dim matrix As ImGearPDFFixedMatrix

instance.SetMatrix(matrix)
public void SetMatrix(
   ImGearPDFFixedMatrix matrix
)
public: void SetMatrix(
   ImGearPDFFixedMatrix* matrix
)
public:
void SetMatrix(
   ImGearPDFFixedMatrix^ matrix
)

Parameters

matrix
The transformation matrix for an element.
Remarks

This matrix provides the transformation from user space to device space for the element. If there is no cm operator (concatmatrix) in the page stream, the matrix is the identity matrix.

For text object, it specifies the identity matrix.

Writing is not supported for PDE Container, a PDE Group, a PDE Place or a PDE Text.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFFixedMatrix Class


%%PageItemTitle%% $$Properties$$

ImGearPDEElement Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEElement Class

For a list of all members of this type, see ImGearPDEElement members.

Public Properties
 | Name | Description
Public Property | HasGState | Gets a value indicating whether the element has a graphics state.
Public Property | UniqueId | Gets some 32-bit integer that is unique for all Element objects.
Top
See Also

Reference

ImGearPDEElement Class
ImageGear.Formats.PDF Namespace


HasGState Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : HasGState Property
Gets a value indicating whether the element has a graphics state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasGState As Boolean
'Usage

Dim instance As ImGearPDEElement
Dim value As Boolean

value = instance.HasGState
public bool HasGState {get;}
public: __property bool get_HasGState();
public:
property bool HasGState {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members


UniqueId Property (ImGearPDEElement)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEElement Class : UniqueId Property
Gets some 32-bit integer that is unique for all Element objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UniqueId As Integer
'Usage

Dim instance As ImGearPDEElement
Dim value As Integer

value = instance.UniqueId
public int UniqueId {get;}
public: __property int get_UniqueId();
public:
property int UniqueId {
   int get();
}

Property Value

Integer value.
Remarks
It is guaranteed that there cannot be two Element objects with the same UniqueIds.

Can be used for Element object's identification.

See Also

Reference

ImGearPDEElement Class
ImGearPDEElement Members
ImGearPDFDictionary Class


%%PageItemTitle%%

ImGearPDEFilterArray Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterArray Class
Represents an array of filter specifications usually containing two or less filters: encoding and/or compression.
Object Model
ImGearPDEFilterArray ClassImGearPDEFilterSpec Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFilterArray
'Usage

Dim instance As ImGearPDEFilterArray
public sealed class ImGearPDEFilterArray
public __gc __sealed class ImGearPDEFilterArray
public ref class ImGearPDEFilterArray sealed
Remarks
Filter information for streams. Although the ImGearPDEFilterArray is declared as a one-member array in the header file, more members can be added by dynamically allocating the ImGearPDEFilterArray with space for as many filters as you would like to add. In practice, there is seldom need for more than two filters.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEFilterArray

See Also

Reference

ImGearPDEFilterArray Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFilterArray Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterArray Class

The following tables list the members exposed by ImGearPDEFilterArray.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFilterArray Constructor | Initializes a new instance of the ImGearPDEFilterArray class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets a number of filters in the array.
Top
Public Methods
 | Name | Description
Public Method | AddSpec | Adds new filter specification to the filters array.
Public Method | GetSpec | Gets a filter specification with specified Index.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDEFilterArray class.
Top
See Also

Reference

ImGearPDEFilterArray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFilterArray Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : ImGearPDEFilterArray Constructor
Initializes a new instance of the ImGearPDEFilterArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEFilterArray()
public ImGearPDEFilterArray()
public: ImGearPDEFilterArray();
public:
ImGearPDEFilterArray();

Return Value

The new instance of ImGearPDEFilterArray class object.
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members


%%PageItemTitle%% $$Methods$$

ImGearPDEFilterArray Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterArray Class

For a list of all members of this type, see ImGearPDEFilterArray members.

Public Methods
 | Name | Description
Public Method | AddSpec | Adds new filter specification to the filters array.
Public Method | GetSpec | Gets a filter specification with specified Index.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDEFilterArray class.
Top
See Also

Reference

ImGearPDEFilterArray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFilterArray Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : ImGearPDEFilterArray Constructor
Overload List
Overload | Description
ImGearPDEFilterArray Constructor | Initializes a new instance of the ImGearPDEFilterArray class.
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members


AddSpec Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : AddSpec Method
Filter specification to add.
Adds new filter specification to the filters array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddSpec( _
   ByVal filter As ImGearPDEFilterSpec _
)
'Usage

Dim instance As ImGearPDEFilterArray
Dim filter As ImGearPDEFilterSpec

instance.AddSpec(filter)
public void AddSpec(
   ImGearPDEFilterSpec filter
)
public: void AddSpec(
   ImGearPDEFilterSpec* filter
)
public:
void AddSpec(
   ImGearPDEFilterSpec^ filter
)

Parameters

filter
Filter specification to add.
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members
ImGearPDEFilterSpec Class


Finalize Method (ImGearPDEFilterArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : Finalize Method
Finalizes an instance of the ImGearPDEFilterArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearPDEFilterArray

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members


GetSpec Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : GetSpec Method
The index of specification to get.
Gets a filter specification with specified Index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSpec( _
   ByVal index As Integer _
) As ImGearPDEFilterSpec
'Usage

Dim instance As ImGearPDEFilterArray
Dim index As Integer
Dim value As ImGearPDEFilterSpec

value = instance.GetSpec(index)
public ImGearPDEFilterSpec GetSpec(
   int index
)
public: ImGearPDEFilterSpec* GetSpec(
   int index
)
public:
ImGearPDEFilterSpec^ GetSpec(
   int index
)

Parameters

index
The index of specification to get.

Return Value

ImGearPDEFilterSpec class object.
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members
ImGearPDEFilterSpec Class


%%PageItemTitle%% $$Properties$$

ImGearPDEFilterArray Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterArray Class

For a list of all members of this type, see ImGearPDEFilterArray members.

Public Properties
 | Name | Description
Public Property | Count | Gets a number of filters in the array.
Top
See Also

Reference

ImGearPDEFilterArray Class
ImageGear.Formats.PDF Namespace


Count Property (ImGearPDEFilterArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterArray Class : Count Property
Gets a number of filters in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearPDEFilterArray
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFilterArray Class
ImGearPDEFilterArray Members


%%PageItemTitle%%

ImGearPDEFilterSpec Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterSpec Class
Represents a filter element in a filter array.
Object Model
ImGearPDEFilterSpec Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFilterSpec
'Usage

Dim instance As ImGearPDEFilterSpec
public sealed class ImGearPDEFilterSpec
public __gc __sealed class ImGearPDEFilterSpec
public ref class ImGearPDEFilterSpec sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEFilterSpec

See Also

Reference

ImGearPDEFilterSpec Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFilterSpec Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterSpec Class

The following tables list the members exposed by ImGearPDEFilterSpec.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFilterSpec Constructor | Initializes a new instance of the ImGearPDEFilterSpec class.
Top
Public Fields
 | Name | Description
Public Field | DecodeParams | Parameters used by decoding filters specified with the Filter key.
Public Field | EncodeParams | Parameters used when encoding the stream.
Public Field | Name | Filter name.
Top
See Also

Reference

ImGearPDEFilterSpec Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFilterSpec Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterSpec Class : ImGearPDEFilterSpec Constructor
Initializes a new instance of the ImGearPDEFilterSpec class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEFilterSpec()
public ImGearPDEFilterSpec()
public: ImGearPDEFilterSpec();
public:
ImGearPDEFilterSpec();

Return Value

The new instance of ImGearPDEFilterSpec class object.
See Also

Reference

ImGearPDEFilterSpec Class
ImGearPDEFilterSpec Members


%%PageItemTitle%% $$Fields$$

ImGearPDEFilterSpec Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFilterSpec Class

For a list of all members of this type, see ImGearPDEFilterSpec members.

Public Fields
 | Name | Description
Public Field | DecodeParams | Parameters used by decoding filters specified with the Filter key.
Public Field | EncodeParams | Parameters used when encoding the stream.
Public Field | Name | Filter name.
Top
See Also

Reference

ImGearPDEFilterSpec Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFilterSpec Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterSpec Class : ImGearPDEFilterSpec Constructor
Overload List
Overload | Description
ImGearPDEFilterSpec Constructor | Initializes a new instance of the ImGearPDEFilterSpec class.
See Also

Reference

ImGearPDEFilterSpec Class
ImGearPDEFilterSpec Members


DecodeParams Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterSpec Class : DecodeParams Field
Parameters used by decoding filters specified with the Filter key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public DecodeParams As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDEFilterSpec
Dim value As ImGearPDFBasObj

value = instance.DecodeParams

instance.DecodeParams = value
public ImGearPDFBasObj DecodeParams
public: ImGearPDFBasObj* DecodeParams
public:
ImGearPDFBasObj^ DecodeParams

Field Value

ImGearPDFBasObj class object.
Remarks
Corresponds to DecodeParms key in the stream dictionary. Must be set to null if filter spec is specified but no decode parameters are specified. This can be done by zeroing the unused decode params. Required decode params for DCTDecode are Columns, Rows, and Colors. The default value is null.
See Also

Reference

ImGearPDEFilterSpec Class
ImGearPDEFilterSpec Members
ImGearPDFBasObj Class


EncodeParams Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterSpec Class : EncodeParams Field
Parameters used when encoding the stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public EncodeParams As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDEFilterSpec
Dim value As ImGearPDFBasObj

value = instance.EncodeParams

instance.EncodeParams = value
public ImGearPDFBasObj EncodeParams
public: ImGearPDFBasObj* EncodeParams
public:
ImGearPDFBasObj^ EncodeParams

Field Value

ImGearPDFBasObj class object.
Remarks
Required for DCTDecode filter; optional for other filters. Must be set to null if filter spec is specified but no encode parameters are specified. The default value is null.
See Also

Reference

ImGearPDEFilterSpec Class
ImGearPDEFilterSpec Members
ImGearPDFBasObj Class


Name Field (ImGearPDEFilterSpec)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFilterSpec Class : Name Field
Filter name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFilterSpec
Dim value As ImGearPDFAtom

value = instance.Name

instance.Name = value
public ImGearPDFAtom Name
public: ImGearPDFAtom* Name
public:
ImGearPDFAtom^ Name

Field Value

ImGearPDFAtom class object.
Remarks
Supported filters are:
  • ASCIIHexDecode
  • ASCII85Decode
  • LZWDecode
  • DCTDecode
  • CCITTFaxDecode
  • RunLengthDecode
  • FlateDecode
  • JPXDecode
See Also

Reference

ImGearPDEFilterSpec Class
ImGearPDEFilterSpec Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEFont Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFont Class
Represents a font used on a page in a PDF file.
Object Model
ImGearPDEFont ClassImGearPDEFontAttrs ClassImGearPDFAtom ClassImGearPDFSysEncoding ClassImGearPDFSysFont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFont
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDEFont
public sealed class ImGearPDEFont : ImGearPDEObject
public __gc __sealed class ImGearPDEFont : public ImGearPDEObject
public ref class ImGearPDEFont sealed : public ImGearPDEObject
Remarks
This font may be equated with a font in the system.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEFont

See Also

Reference

ImGearPDEFont Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFont Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFont Class

The following tables list the members exposed by ImGearPDEFont.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CreateNeedFlags | Gets flags indicating what needs to be done to make the current font complete.
Public Property | IsEmbedded | Gets a value indicating whether the font is embedded.
Public Property | IsMultibyte | Gets a value indicating whether the font contains any multi-byte characters.
Top
Public Methods
 | Name | Description
Public Method | CreateToUnicodeNow | Creates the /ToUnicode table.
Public Method | CreateWidthsNow | Creates width entries for font.
Public Method | EmbedNow | Embeds font stream.
Public Method | EmbedNowDontSubset | Embeds the font inside Doc without creating a subset.
Public Method | FindUnrepresentableCharacters | Gets a collection of characters in the Unicode string that could not be represented in the font.
Public Method | GetAttributes | Gets the font attributes.
Public Method | GetCodeByteCount | Gets the number of bytes in a string of single or multi-byte character codes.
Public Method | GetOneByteEncoding | Gets an atom array that is filled with the delta encodings for font.
Public Method | GetSysEncoding | Gets the system encoding object associated with a font object.
Public Method | GetSysFont | Gets the system font object associated with a font object.
Public Method | GetWidths | Gets widths array.
Public Method | GetWidthsNow | Creates width entries for font.
Public Method | IsTextRepresentable | Checks if the entire contents of a text are representable in the font.
Public Method | SetSysEncoding | Sets the system encoding object associated with a font object.
Public Method | SetSysFont | Sets the system font object associated with a font object.
Public Method | SubsetNow | Subsets a given PDE Font in Doc.
Public Method | SumWidths | Gets the sum to the widths from a string of single or multi-byte characters.
Top
See Also

Reference

ImGearPDEFont Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFont Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : ImGearPDEFont Constructor
Overload List
Overload | Description
ImGearPDEFont Constructor(ImGearPDEFontAttrs,Int32,Int32,Int16[],String[],ImGearPDFAtom,ImGearPDFStream,Int32,Int32,Int32) | Initializes a new instance of the ImGearPDEFont class.
ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFlags,ImGearPDFAtom,Int32[]) | Initializes a new instance of the ImGearPDEFont class.
ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDFSysEncoding,ImGearPDFAtom,ImGearPDEFontCreateFlags) | Initializes a new instance of the ImGearPDEFont class.
ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFromSysFontParams) | Initializes a new instance of the ImGearPDEFont class.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


%%PageItemTitle%%

ImGearPDEFont Constructor(ImGearPDEFontAttrs,Int32,Int32,Int16[],String[],ImGearPDFAtom,ImGearPDFStream,Int32,Int32,Int32)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class > ImGearPDEFont Constructor : ImGearPDEFont Constructor(ImGearPDEFontAttrs,Int32,Int32,Int16[],String[],ImGearPDFAtom,ImGearPDFStream,Int32,Int32,Int32)
ImGearPDEFontAttrsfor the font attributes.
First character index for the widths array, Widths.
Last character index for the widths array, Widths.
Widths array.
Array of 256 glyph names specifying the custom encoding. If any pointer is null, no encoding information is written for that entry.
Encoding base name if the encoding is a custom encoding. If encoding is null, encodingBaseName is used as the value of the encoding, and must be one of WinAnsiEncoding, MacRomanEncoding, or MacExpertEncoding. If no encoding value is desired, use null Atom.
Stream with font information.
Length in bytes of the ASCII portion of the Type 1 font file after it has been decoded. For other font formats, such as TrueType or CFF, only len1 is used, and it is the size of the font.
Length in bytes of the encrypted portion of the Type 1 font file after it has been decoded.
Length in bytes of the portion of the Type 1 font file that contains the 512 zeros, plus the cleartomark operator, plus any following data.
Initializes a new instance of the ImGearPDEFont class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal attributes As ImGearPDEFontAttrs, _
   ByVal firstCharacterIndex As Integer, _
   ByVal lastCharacterIndex As Integer, _
   ByVal widths() As Short, _
   ByVal glyphNames() As String, _
   ByVal encodingBaseName As ImGearPDFAtom, _
   ByVal fontStream As ImGearPDFStream, _
   ByVal length As Integer, _
   ByVal encryptedPartLength As Integer, _
   ByVal remainingPartLength As Integer _
)
'Usage

Dim attributes As ImGearPDEFontAttrs
Dim firstCharacterIndex As Integer
Dim lastCharacterIndex As Integer
Dim widths() As Short
Dim glyphNames() As String
Dim encodingBaseName As ImGearPDFAtom
Dim fontStream As ImGearPDFStream
Dim length As Integer
Dim encryptedPartLength As Integer
Dim remainingPartLength As Integer

Dim instance As New ImGearPDEFont(attributes, firstCharacterIndex, lastCharacterIndex, widths, glyphNames, encodingBaseName, fontStream, length, encryptedPartLength, remainingPartLength)
public ImGearPDEFont(
   ImGearPDEFontAttrs attributes,
   int firstCharacterIndex,
   int lastCharacterIndex,
   short[] widths,
   string[] glyphNames,
   ImGearPDFAtom encodingBaseName,
   ImGearPDFStream fontStream,
   int length,
   int encryptedPartLength,
   int remainingPartLength
)
public: ImGearPDEFont(
   ImGearPDEFontAttrs* attributes,
   int firstCharacterIndex,
   int lastCharacterIndex,
   short[]* widths,
   string*[]* glyphNames,
   ImGearPDFAtom* encodingBaseName,
   ImGearPDFStream* fontStream,
   int length,
   int encryptedPartLength,
   int remainingPartLength
)
public:
ImGearPDEFont(
   ImGearPDEFontAttrs^ attributes,
   int firstCharacterIndex,
   int lastCharacterIndex,
   array<short>^ widths,
   array<String^>^ glyphNames,
   ImGearPDFAtom^ encodingBaseName,
   ImGearPDFStream^ fontStream,
   int length,
   int encryptedPartLength,
   int remainingPartLength
)

Parameters

attributes
ImGearPDEFontAttrsfor the font attributes.
firstCharacterIndex
First character index for the widths array, Widths.
lastCharacterIndex
Last character index for the widths array, Widths.
widths
Widths array.
glyphNames
Array of 256 glyph names specifying the custom encoding. If any pointer is null, no encoding information is written for that entry.
encodingBaseName
Encoding base name if the encoding is a custom encoding. If encoding is null, encodingBaseName is used as the value of the encoding, and must be one of WinAnsiEncoding, MacRomanEncoding, or MacExpertEncoding. If no encoding value is desired, use null Atom.
fontStream
Stream with font information.
length
Length in bytes of the ASCII portion of the Type 1 font file after it has been decoded. For other font formats, such as TrueType or CFF, only len1 is used, and it is the size of the font.
encryptedPartLength
Length in bytes of the encrypted portion of the Type 1 font file after it has been decoded.
remainingPartLength
Length in bytes of the portion of the Type 1 font file that contains the 512 zeros, plus the cleartomark operator, plus any following data.

Return Value

The new instance of ImGearPDEFont class object.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
Overload List
ImGearPDEFontAttrs Class
ImGearPDFStream Class
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFlags,ImGearPDFAtom,Int32[])

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class > ImGearPDEFont Constructor : ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFlags,ImGearPDFAtom,Int32[])
PDF system font object referencing a system font.
Indicates whether to embed the font and whether to subset the font. Must be one of enumImGearPDEFontCreateFlags. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET options.
Name to be associated with this particular instantiation of the PDE Font.
Multiple master font design vector.
Initializes a new instance of the ImGearPDEFont class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal systemFont As ImGearPDFSysFont, _
   ByVal options As ImGearPDEFontCreateFlags, _
   ByVal snapshotName As ImGearPDFAtom, _
   ByVal designVector() As Integer _
)
'Usage

Dim systemFont As ImGearPDFSysFont
Dim options As ImGearPDEFontCreateFlags
Dim snapshotName As ImGearPDFAtom
Dim designVector() As Integer

Dim instance As New ImGearPDEFont(systemFont, options, snapshotName, designVector)
public ImGearPDEFont(
   ImGearPDFSysFont systemFont,
   ImGearPDEFontCreateFlags options,
   ImGearPDFAtom snapshotName,
   int[] designVector
)
public: ImGearPDEFont(
   ImGearPDFSysFont* systemFont,
   ImGearPDEFontCreateFlags options,
   ImGearPDFAtom* snapshotName,
   int[]* designVector
)
public:
ImGearPDEFont(
   ImGearPDFSysFont^ systemFont,
   ImGearPDEFontCreateFlags options,
   ImGearPDFAtom^ snapshotName,
   array<int>^ designVector
)

Parameters

systemFont
PDF system font object referencing a system font.
options
Indicates whether to embed the font and whether to subset the font. Must be one of enumImGearPDEFontCreateFlags. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET options.
snapshotName
Name to be associated with this particular instantiation of the PDE Font.
designVector
Multiple master font design vector.

Return Value

The new instance of ImGearPDEFont class object.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
Overload List
ImGearPDFSysFont Class
ImGearPDEFontCreateFlags Enumeration
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDFSysEncoding,ImGearPDFAtom,ImGearPDEFontCreateFlags)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class > ImGearPDEFont Constructor : ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDFSysEncoding,ImGearPDFAtom,ImGearPDEFontCreateFlags)
PDF system font object referencing a system font.
A PDF SysEncoding object.
The base font. An error will be set if the base font name passed is a subset name (XXXXXX+FontName) or an empty string.
One of the ImGearPDEFontCreateFlags values.
Initializes a new instance of the ImGearPDEFont class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal systemFont As ImGearPDFSysFont, _
   ByVal systemEncoding As ImGearPDFSysEncoding, _
   ByVal baseFontName As ImGearPDFAtom, _
   ByVal options As ImGearPDEFontCreateFlags _
)
'Usage

Dim systemFont As ImGearPDFSysFont
Dim systemEncoding As ImGearPDFSysEncoding
Dim baseFontName As ImGearPDFAtom
Dim options As ImGearPDEFontCreateFlags

Dim instance As New ImGearPDEFont(systemFont, systemEncoding, baseFontName, options)
public ImGearPDEFont(
   ImGearPDFSysFont systemFont,
   ImGearPDFSysEncoding systemEncoding,
   ImGearPDFAtom baseFontName,
   ImGearPDEFontCreateFlags options
)
public: ImGearPDEFont(
   ImGearPDFSysFont* systemFont,
   ImGearPDFSysEncoding* systemEncoding,
   ImGearPDFAtom* baseFontName,
   ImGearPDEFontCreateFlags options
)
public:
ImGearPDEFont(
   ImGearPDFSysFont^ systemFont,
   ImGearPDFSysEncoding^ systemEncoding,
   ImGearPDFAtom^ baseFontName,
   ImGearPDEFontCreateFlags options
)

Parameters

systemFont
PDF system font object referencing a system font.
systemEncoding
A PDF SysEncoding object.
baseFontName
The base font. An error will be set if the base font name passed is a subset name (XXXXXX+FontName) or an empty string.
options
One of the ImGearPDEFontCreateFlags values.

Return Value

The new instance of ImGearPDEFont class object.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
Overload List
ImGearPDFSysFont Class
ImGearPDEFontCreateFlags Enumeration
ImGearPDFSysEncoding Class
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFromSysFontParams)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class > ImGearPDEFont Constructor : ImGearPDEFont Constructor(ImGearPDFSysFont,ImGearPDEFontCreateFromSysFontParams)
PDF system font object referencing a system font.
Create parameters.
Initializes a new instance of the ImGearPDEFont class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal systemFont As ImGearPDFSysFont, _
   ByVal parameters As ImGearPDEFontCreateFromSysFontParams _
)
'Usage

Dim systemFont As ImGearPDFSysFont
Dim parameters As ImGearPDEFontCreateFromSysFontParams

Dim instance As New ImGearPDEFont(systemFont, parameters)
public ImGearPDEFont(
   ImGearPDFSysFont systemFont,
   ImGearPDEFontCreateFromSysFontParams parameters
)
public: ImGearPDEFont(
   ImGearPDFSysFont* systemFont,
   ImGearPDEFontCreateFromSysFontParams* parameters
)
public:
ImGearPDEFont(
   ImGearPDFSysFont^ systemFont,
   ImGearPDEFontCreateFromSysFontParams^ parameters
)

Parameters

systemFont
PDF system font object referencing a system font.
parameters
Create parameters.

Return Value

The new instance of ImGearPDEFont class object.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
Overload List
ImGearPDFSysFont Class
ImGearPDEFontCreateFromSysFontParams Class


%%PageItemTitle%% $$Methods$$

ImGearPDEFont Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFont Class

For a list of all members of this type, see ImGearPDEFont members.

Public Methods
 | Name | Description
Public Method | CreateToUnicodeNow | Creates the /ToUnicode table.
Public Method | CreateWidthsNow | Creates width entries for font.
Public Method | EmbedNow | Embeds font stream.
Public Method | EmbedNowDontSubset | Embeds the font inside Doc without creating a subset.
Public Method | FindUnrepresentableCharacters | Gets a collection of characters in the Unicode string that could not be represented in the font.
Public Method | GetAttributes | Gets the font attributes.
Public Method | GetCodeByteCount | Gets the number of bytes in a string of single or multi-byte character codes.
Public Method | GetOneByteEncoding | Gets an atom array that is filled with the delta encodings for font.
Public Method | GetSysEncoding | Gets the system encoding object associated with a font object.
Public Method | GetSysFont | Gets the system font object associated with a font object.
Public Method | GetWidths | Gets widths array.
Public Method | GetWidthsNow | Creates width entries for font.
Public Method | IsTextRepresentable | Checks if the entire contents of a text are representable in the font.
Public Method | SetSysEncoding | Sets the system encoding object associated with a font object.
Public Method | SetSysFont | Sets the system font object associated with a font object.
Public Method | SubsetNow | Subsets a given PDE Font in Doc.
Public Method | SumWidths | Gets the sum to the widths from a string of single or multi-byte characters.
Top
See Also

Reference

ImGearPDEFont Class
ImageGear.Formats.PDF Namespace


CreateToUnicodeNow Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : CreateToUnicodeNow Method
The container document.
Creates the /ToUnicode table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CreateToUnicodeNow( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.CreateToUnicodeNow(document)
public void CreateToUnicodeNow(
   ImGearPDFDocument document
)
public: void CreateToUnicodeNow(
   ImGearPDFDocument* document
)
public:
void CreateToUnicodeNow(
   ImGearPDFDocument^ document
)

Parameters

document
The container document.
Remarks
The user can check the value of CreateNeedFlags to see if calling of CreateToUnicodeNow is needed.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


CreateWidthsNow Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : CreateWidthsNow Method
The container document.
Creates width entries for font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CreateWidthsNow( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.CreateWidthsNow(document)
public void CreateWidthsNow(
   ImGearPDFDocument document
)
public: void CreateWidthsNow(
   ImGearPDFDocument* document
)
public:
void CreateWidthsNow(
   ImGearPDFDocument^ document
)

Parameters

document
The container document.
Remarks
The user can check the value of CreateNeedFlags to see if calling of CreateWidthsNow is needed.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


EmbedNow Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : EmbedNow Method
The container document.
Embeds font stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EmbedNow( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.EmbedNow(document)
public void EmbedNow(
   ImGearPDFDocument document
)
public: void EmbedNow(
   ImGearPDFDocument* document
)
public:
void EmbedNow(
   ImGearPDFDocument^ document
)

Parameters

document
The container document.
Remarks
The user can check the value of CreateNeedFlags to see if calling of EmbedNow is needed.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


EmbedNowDontSubset Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : EmbedNowDontSubset Method
The container document.
Embeds the font inside Doc without creating a subset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EmbedNowDontSubset( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.EmbedNowDontSubset(document)
public void EmbedNowDontSubset(
   ImGearPDFDocument document
)
public: void EmbedNowDontSubset(
   ImGearPDFDocument* document
)
public:
void EmbedNowDontSubset(
   ImGearPDFDocument^ document
)

Parameters

document
The container document.
Remarks
Use this method instead of EmbedNow method if you created font with the WILL_SUBSET flag but changed your mind.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


FindUnrepresentableCharacters Method
Example

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : FindUnrepresentableCharacters Method
String with Unicode characters.
Gets a collection of characters in the Unicode string that could not be represented in the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindUnrepresentableCharacters( _
   ByVal text As String _
) As ReadOnlyCollection(Of Char)
'Usage

Dim instance As ImGearPDEFont
Dim text As String
Dim value As ReadOnlyCollection(Of Char)

value = instance.FindUnrepresentableCharacters(text)
public ReadOnlyCollection<char> FindUnrepresentableCharacters(
   string text
)
public: ReadOnlyCollection<char>* FindUnrepresentableCharacters(
   string* text
)
public:
ReadOnlyCollection<char>^ FindUnrepresentableCharacters(
   String^ text
)

Parameters

text
String with Unicode characters.

Return Value

Collection of characters not representable in the font.
Remarks

The Unicode API methods require a TrueType or Type 0 font that can be embedded. This font must be created from a font file on the local machine, because the lookup tables used by these API only exist in the font files. This is required even if you only check for representable text. This method will raise an exception, if used with other fonts, like Type 1 or font retrieved from an existing PDF document.

Example
  • C#
string textToCheck =
    "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本";

// see the code example in ImGearPDEText.Add
ImGearPDEFont fontSerif = CreateFont("Times-Roman", "Type0", "Identity-H");

// Ensure that the text is fully representable by the font.
// Add a warning if not.
if (!fontSerif.IsTextRepresentable(textToCheck))
{
    System.Collections.Generic.IEnumerable<char> unrepresentableChars =
        fontSerif.FindUnrepresentableCharacters(textToCheck);

    string unrepresentableCharsString = String.Empty;
    foreach (char unrepresentableChar in unrepresentableChars)
    {
        if (unrepresentableCharsString != String.Empty)
        {
            unrepresentableCharsString += ",";
        }

        unrepresentableCharsString += unrepresentableChar;
    }

    MessageBox.Show(
        string.Format(
            "The selected font, {0}, does not support the following characters: [{1}]",
            fontSerif.GetAttributes().Name.String, unrepresentableCharsString));
}
  • Visual Basic
Dim textToCheck As String = "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本"

' see the code example in ImGearPDEText.Add
Dim fontSerif As ImGearPDEFont = CreateFont("Times-Roman", "Type0", "Identity-H")

' Ensure that the text is fully representable by the font.
' Add a warning if not.
If Not fontSerif.IsTextRepresentable(textToCheck) Then
    Dim unrepresentableChars As System.Collections.Generic.IEnumerable(Of Char) = fontSerif.FindUnrepresentableCharacters(textToCheck)

    Dim unrepresentableCharsString As String = [String].Empty
    For Each unrepresentableChar As Char In unrepresentableChars
        If unrepresentableCharsString <> [String].Empty Then
            unrepresentableCharsString += ","
        End If

        unrepresentableCharsString += unrepresentableChar
    Next

    MessageBox.Show(String.Format("The selected font, {0}, does not support the following characters: [{1}]", fontSerif.GetAttributes().Name.[String], unrepresentableCharsString))
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


GetAttributes Method (ImGearPDEFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetAttributes Method
Gets the font attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttributes() As ImGearPDEFontAttrs
'Usage

Dim instance As ImGearPDEFont
Dim value As ImGearPDEFontAttrs

value = instance.GetAttributes()
public ImGearPDEFontAttrs GetAttributes()
public: ImGearPDEFontAttrs* GetAttributes();
public:
ImGearPDEFontAttrs^ GetAttributes();

Return Value

ImGearPDEFontAttrs class object values.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDEFontAttrs Class


GetCodeByteCount Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetCodeByteCount Method
A string characters.
Gets the number of bytes in a string of single or multi-byte character codes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCodeByteCount( _
   ByVal text As String _
) As Integer
'Usage

Dim instance As ImGearPDEFont
Dim text As String
Dim value As Integer

value = instance.GetCodeByteCount(text)
public int GetCodeByteCount(
   string text
)
public: int GetCodeByteCount(
   string* text
)
public:
int GetCodeByteCount(
   String^ text
)

Parameters

text
A string characters.

Return Value

Number of bytes in the text.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


GetOneByteEncoding Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetOneByteEncoding Method
Gets an atom array that is filled with the delta encodings for font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOneByteEncoding() As ImGearPDFAtom()
'Usage

Dim instance As ImGearPDEFont
Dim value() As ImGearPDFAtom

value = instance.GetOneByteEncoding()
public ImGearPDFAtom[] GetOneByteEncoding()
public: ImGearPDFAtom*[]* GetOneByteEncoding();
public:
array<ImGearPDFAtom^>^ GetOneByteEncoding();

Return Value

ImGearPDFAtom class array object.
Remarks
Each entry is the atom for a glyph name that differs from the base encoding. See Section 5.5.5 in the PDF Reference for more information about font encodings.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFAtom Class


GetSysEncoding Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetSysEncoding Method
Gets the system encoding object associated with a font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSysEncoding() As ImGearPDFSysEncoding
'Usage

Dim instance As ImGearPDEFont
Dim value As ImGearPDFSysEncoding

value = instance.GetSysEncoding()
public ImGearPDFSysEncoding GetSysEncoding()
public: ImGearPDFSysEncoding* GetSysEncoding();
public:
ImGearPDFSysEncoding^ GetSysEncoding();

Return Value

ImGearPDFSysEncoding class object.
Remarks
Changing the system encoding may produce unexpected results.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFSysEncoding Class


GetSysFont Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetSysFont Method
Gets the system font object associated with a font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSysFont() As ImGearPDFSysFont
'Usage

Dim instance As ImGearPDEFont
Dim value As ImGearPDFSysFont

value = instance.GetSysFont()
public ImGearPDFSysFont GetSysFont()
public: ImGearPDFSysFont* GetSysFont();
public:
ImGearPDFSysFont^ GetSysFont();

Return Value

ImGearPDFSysFont class object.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFSysFont Class


GetWidths Method (ImGearPDEFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetWidths Method
Gets widths array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetWidths() As Short()
'Usage

Dim instance As ImGearPDEFont
Dim value() As Short

value = instance.GetWidths()
public short[] GetWidths()
public: short[]* GetWidths();
public:
array<short>^ GetWidths();

Return Value

Widths array.
Remarks
The widths are returned in character space (1000 EM units). An EM is a typographic unit of measurement equal to the size of a font. To convert to text space, divide the value returned by 1000. To convert to user space, multiply the text space value by the font size.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


GetWidthsNow Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : GetWidthsNow Method
The container document.
Creates width entries for font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetWidthsNow( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.GetWidthsNow(document)
public void GetWidthsNow(
   ImGearPDFDocument document
)
public: void GetWidthsNow(
   ImGearPDFDocument* document
)
public:
void GetWidthsNow(
   ImGearPDFDocument^ document
)

Parameters

document
The container document.
Remarks
Gets a Type0 font's width information for only the characters used in the file. Call this routine when the font was created with the DEFER_WIDTHS flag but without the CREATE_EMBEDDED flag (if the font is to be embedded, call SubsetNow method, which also gets the width info).
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


IsTextRepresentable Method
Example

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : IsTextRepresentable Method
String with Unicode characters to check.
Checks if the entire contents of a text are representable in the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsTextRepresentable( _
   ByVal text As String _
) As Boolean
'Usage

Dim instance As ImGearPDEFont
Dim text As String
Dim value As Boolean

value = instance.IsTextRepresentable(text)
public bool IsTextRepresentable(
   string text
)
public: bool IsTextRepresentable(
   string* text
)
public:
bool IsTextRepresentable(
   String^ text
)

Parameters

text
String with Unicode characters to check.

Return Value

True if the entire text is representable in the font, false otherwise.
Remarks

The Unicode API methods require a TrueType or Type 0 font that can be embedded. This font must be created from a font file on the local machine, because the lookup tables used by these API only exist in the font files. This is required even if you only check for representable text. This method will raise an exception, if used with other fonts, like Type 1 or font retrieved from an existing PDF document.

Example
  • C#
string textToCheck =
    "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本";

// see the code example in ImGearPDEText.Add
ImGearPDEFont fontSerif = CreateFont("Times-Roman", "Type0", "Identity-H");

// Ensure that the text is fully representable by the font.
// Add a warning if not.
if (!fontSerif.IsTextRepresentable(textToCheck))
{
    System.Collections.Generic.IEnumerable<char> unrepresentableChars =
        fontSerif.FindUnrepresentableCharacters(textToCheck);

    string unrepresentableCharsString = String.Empty;
    foreach (char unrepresentableChar in unrepresentableChars)
    {
        if (unrepresentableCharsString != String.Empty)
        {
            unrepresentableCharsString += ",";
        }

        unrepresentableCharsString += unrepresentableChar;
    }

    MessageBox.Show(
        string.Format(
            "The selected font, {0}, does not support the following characters: [{1}]",
            fontSerif.GetAttributes().Name.String, unrepresentableCharsString));
}
  • Visual Basic
Dim textToCheck As String = "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本"

' see the code example in ImGearPDEText.Add
Dim fontSerif As ImGearPDEFont = CreateFont("Times-Roman", "Type0", "Identity-H")

' Ensure that the text is fully representable by the font.
' Add a warning if not.
If Not fontSerif.IsTextRepresentable(textToCheck) Then
    Dim unrepresentableChars As System.Collections.Generic.IEnumerable(Of Char) = fontSerif.FindUnrepresentableCharacters(textToCheck)

    Dim unrepresentableCharsString As String = [String].Empty
    For Each unrepresentableChar As Char In unrepresentableChars
        If unrepresentableCharsString <> [String].Empty Then
            unrepresentableCharsString += ","
        End If

        unrepresentableCharsString += unrepresentableChar
    Next

    MessageBox.Show(String.Format("The selected font, {0}, does not support the following characters: [{1}]", fontSerif.GetAttributes().Name.[String], unrepresentableCharsString))
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


SetSysEncoding Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : SetSysEncoding Method
The system encoding object to set.
Sets the system encoding object associated with a font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSysEncoding( _
   ByVal systemEncoding As ImGearPDFSysEncoding _
)
'Usage

Dim instance As ImGearPDEFont
Dim systemEncoding As ImGearPDFSysEncoding

instance.SetSysEncoding(systemEncoding)
public void SetSysEncoding(
   ImGearPDFSysEncoding systemEncoding
)
public: void SetSysEncoding(
   ImGearPDFSysEncoding* systemEncoding
)
public:
void SetSysEncoding(
   ImGearPDFSysEncoding^ systemEncoding
)

Parameters

systemEncoding
The system encoding object to set.
Remarks
Changing the system encoding may produce unexpected results.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFSysEncoding Class


SetSysFont Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : SetSysFont Method
The system font object to set.
Sets the system font object associated with a font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSysFont( _
   ByVal systemFont As ImGearPDFSysFont _
)
'Usage

Dim instance As ImGearPDEFont
Dim systemFont As ImGearPDFSysFont

instance.SetSysFont(systemFont)
public void SetSysFont(
   ImGearPDFSysFont systemFont
)
public: void SetSysFont(
   ImGearPDFSysFont* systemFont
)
public:
void SetSysFont(
   ImGearPDFSysFont^ systemFont
)

Parameters

systemFont
The system font object to set.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFSysFont Class


SubsetNow Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : SubsetNow Method
The document whose font is subsetted.
Subsets a given PDE Font in Doc.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SubsetNow( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim instance As ImGearPDEFont
Dim document As ImGearPDFDocument

instance.SubsetNow(document)
public void SubsetNow(
   ImGearPDFDocument document
)
public: void SubsetNow(
   ImGearPDFDocument* document
)
public:
void SubsetNow(
   ImGearPDFDocument^ document
)

Parameters

document
The document whose font is subsetted.
Remarks
If you created font with CreatePDEFontFromSysFont, you must have set both the CREATE_EMBEDDED and WILL_SUBSET set in the options parameter to be able to subset font.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDFDocument Class


SumWidths Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : SumWidths Method
A string of characters.
Gets the sum to the widths from a string of single or multi-byte characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function SumWidths( _
   ByVal text As String _
) As Integer
'Usage

Dim instance As ImGearPDEFont
Dim text As String
Dim value As Integer

value = instance.SumWidths(text)
public int SumWidths(
   string text
)
public: int SumWidths(
   string* text
)
public:
int SumWidths(
   String^ text
)

Parameters

text
A string of characters.

Return Value

Width of text string in EM space. (In EM space, the width of 'M' is about 1000 EM units).
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


%%PageItemTitle%% $$Properties$$

ImGearPDEFont Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFont Class

For a list of all members of this type, see ImGearPDEFont members.

Public Properties
 | Name | Description
Public Property | CreateNeedFlags | Gets flags indicating what needs to be done to make the current font complete.
Public Property | IsEmbedded | Gets a value indicating whether the font is embedded.
Public Property | IsMultibyte | Gets a value indicating whether the font contains any multi-byte characters.
Top
See Also

Reference

ImGearPDEFont Class
ImageGear.Formats.PDF Namespace


CreateNeedFlags Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : CreateNeedFlags Property
Gets flags indicating what needs to be done to make the current font complete.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CreateNeedFlags As ImGearPDEFontCreateNeedFlags
'Usage

Dim instance As ImGearPDEFont
Dim value As ImGearPDEFontCreateNeedFlags

value = instance.CreateNeedFlags
public ImGearPDEFontCreateNeedFlags CreateNeedFlags {get;}
public: __property ImGearPDEFontCreateNeedFlags get_CreateNeedFlags();
public:
property ImGearPDEFontCreateNeedFlags CreateNeedFlags {
   ImGearPDEFontCreateNeedFlags get();
}

Property Value

ImGearPDEFontCreateNeedFlags enumeration values.
Remarks
WIDTHS can be cleared by CreateWidthsNow method. TO_UNICODE can be cleared by CreateToUnicodeNow method. EMBED can be cleared by EmbedNow method.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members
ImGearPDEFontCreateNeedFlags Enumeration


IsEmbedded Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : IsEmbedded Property
Gets a value indicating whether the font is embedded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsEmbedded As Boolean
'Usage

Dim instance As ImGearPDEFont
Dim value As Boolean

value = instance.IsEmbedded
public bool IsEmbedded {get;}
public: __property bool get_IsEmbedded();
public:
property bool IsEmbedded {
   bool get();
}

Property Value

Boolean value.
Remarks
Returns false if it was created in one document and embedded in a different document.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


IsMultibyte Property (ImGearPDEFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFont Class : IsMultibyte Property
Gets a value indicating whether the font contains any multi-byte characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsMultibyte As Boolean
'Usage

Dim instance As ImGearPDEFont
Dim value As Boolean

value = instance.IsMultibyte
public bool IsMultibyte {get;}
public: __property bool get_IsMultibyte();
public:
property bool IsMultibyte {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEFont Class
ImGearPDEFont Members


%%PageItemTitle%%

ImGearPDEFontAttrs Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontAttrs Class
Provides attributes for ImGearPDEFont and ImGearPDFSysFont.
Object Model
ImGearPDEFontAttrs ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFontAttrs
'Usage

Dim instance As ImGearPDEFontAttrs
public sealed class ImGearPDEFontAttrs
public __gc __sealed class ImGearPDEFontAttrs
public ref class ImGearPDEFontAttrs sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEFontAttrs

See Also

Reference

ImGearPDEFontAttrs Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFontAttrs Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontAttrs Class

The following tables list the members exposed by ImGearPDEFontAttrs.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFontAttrs Constructor | Initializes a new instance of the ImGearPDEFontAttrs class.
Top
Public Fields
 | Name | Description
Public Field | Ascent | Maximum ascender height.
Public Field | AvgWidth | Average character width.
Public Field | BBox | Font bounding box in 1000 EM units.
Public Field | CantEmbed | A non-zero value means the font cannot be embedded.
Public Field | CapHeight | Capital height.
Public Field | Descent | Maximum descender depth.
Public Field | Flags | Desired font flags, one or more values of enumImGearPDFFontFlags.
Public Field | ItalicAngle | Italic angle in degrees, if any.
Public Field | Leading | Additional leading between lines.
Public Field | MaxWidth | Additional leading between lines.
Public Field | MissingWidth | Width of missing character.
Public Field | PackageType | Package type, one of ImGearPDESysFontPackageType.
Public Field | Protection | Allows setting one of the following bits to disable font embedding.
Public Field | StemH | Horizontal stem width.
Public Field | StemV | Vertical stem width.
Public Field | Supplement | The SystemSupplement field from the CIDFont.
Public Field | WritingMode | Writing mode.
Public Field | XHeight | The X height.
Top
Public Properties
 | Name | Description
Public Property | CharSet | Gets or sets an atom for "Roman" or Null.
Public Property | CIDFontType | Gets or sets an atom representing the CID font type.
Public Property | DeltaEncoding | Gets or sets the name of the base encoding.
Public Property | Encoding | Gets or sets an atom for the font encoding.
Public Property | Lang | Gets or sets the atom representing the ISO 639 language code.
Public Property | Name | Gets or sets an atom for the font name.
Public Property | Ordering | Gets or sets the atom representing the CIDFont's Ordering information.
Public Property | PlatformName | Gets or sets the platform name.
Public Property | PSName | Gets or sets an atom representing the PostScript name of a TrueType font.
Public Property | Registry | Gets or sets the atom representing the CIDFont’s Registry information, as in "Adobe-Japan".
Public Property | Type | Gets or sets an atom for font type, corresponding to the Subtype key in a font dictionary.
Top
See Also

Reference

ImGearPDEFontAttrs Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontAttrs Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : ImGearPDEFontAttrs Constructor
Initializes a new instance of the ImGearPDEFontAttrs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEFontAttrs()
public ImGearPDEFontAttrs()
public: ImGearPDEFontAttrs();
public:
ImGearPDEFontAttrs();
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


%%PageItemTitle%% $$Properties$$

ImGearPDEFontAttrs Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontAttrs Class

For a list of all members of this type, see ImGearPDEFontAttrs members.

Public Properties
 | Name | Description
Public Property | CharSet | Gets or sets an atom for "Roman" or Null.
Public Property | CIDFontType | Gets or sets an atom representing the CID font type.
Public Property | DeltaEncoding | Gets or sets the name of the base encoding.
Public Property | Encoding | Gets or sets an atom for the font encoding.
Public Property | Lang | Gets or sets the atom representing the ISO 639 language code.
Public Property | Name | Gets or sets an atom for the font name.
Public Property | Ordering | Gets or sets the atom representing the CIDFont's Ordering information.
Public Property | PlatformName | Gets or sets the platform name.
Public Property | PSName | Gets or sets an atom representing the PostScript name of a TrueType font.
Public Property | Registry | Gets or sets the atom representing the CIDFont’s Registry information, as in "Adobe-Japan".
Public Property | Type | Gets or sets an atom for font type, corresponding to the Subtype key in a font dictionary.
Top
See Also

Reference

ImGearPDEFontAttrs Class
ImageGear.Formats.PDF Namespace


CharSet Property (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : CharSet Property
Gets or sets an atom for "Roman" or Null.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharSet As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.CharSet = value

value = instance.CharSet
public ImGearPDFAtom CharSet {get; set;}
public: __property ImGearPDFAtom* get_CharSet();
public: __property void set_CharSet(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ CharSet {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
If "Roman", the characters must be a subset of the Adobe Standard Roman Character Set.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


CIDFontType Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : CIDFontType Property
Gets or sets an atom representing the CID font type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CIDFontType As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.CIDFontType = value

value = instance.CIDFontType
public ImGearPDFAtom CIDFontType {get; set;}
public: __property ImGearPDFAtom* get_CIDFontType();
public: __property void set_CIDFontType(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ CIDFontType {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
CIDFontType0 or CIDFontType2.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


DeltaEncoding Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : DeltaEncoding Property
Gets or sets the name of the base encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeltaEncoding As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.DeltaEncoding = value

value = instance.DeltaEncoding
public ImGearPDFAtom DeltaEncoding {get; set;}
public: __property ImGearPDFAtom* get_DeltaEncoding();
public: __property void set_DeltaEncoding(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ DeltaEncoding {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class.
Remarks
The BaseEncoding entry in an encoding dictionary (see section 5.5.5 of the PDF Reference). The Differences entry of the encoding dictionary describes differences (deltas) from the base encoding.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Encoding Property (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Encoding Property
Gets or sets an atom for the font encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Encoding = value

value = instance.Encoding
public ImGearPDFAtom Encoding {get; set;}
public: __property ImGearPDFAtom* get_Encoding();
public: __property void set_Encoding(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Encoding {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
May be MacRomanEncoding, WinAnsiEncoding, or Null. In the case of Null, call ImGearPDFSysFont.GetEncoding to get more information about the encoding.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Lang Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Lang Property
Gets or sets the atom representing the ISO 639 language code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Lang As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Lang = value

value = instance.Lang
public ImGearPDFAtom Lang {get; set;}
public: __property ImGearPDFAtom* get_Lang();
public: __property void set_Lang(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Lang {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Name Property (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Name Property
Gets or sets an atom for the font name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Name = value

value = instance.Name
public ImGearPDFAtom Name {get; set;}
public: __property ImGearPDFAtom* get_Name();
public: __property void set_Name(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Name {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
Corresponds to the BaseFont key in the font dictionary of a PDF file (see Section 5.6.3 in the PDF Reference).
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Ordering Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Ordering Property
Gets or sets the atom representing the CIDFont's Ordering information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ordering As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Ordering = value

value = instance.Ordering
public ImGearPDFAtom Ordering {get; set;}
public: __property ImGearPDFAtom* get_Ordering();
public: __property void set_Ordering(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Ordering {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
For example, "1".
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


PlatformName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : PlatformName Property
Gets or sets the platform name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlatformName As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.PlatformName = value

value = instance.PlatformName
public ImGearPDFAtom PlatformName {get; set;}
public: __property ImGearPDFAtom* get_PlatformName();
public: __property void set_PlatformName(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ PlatformName {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


PSName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : PSName Property
Gets or sets an atom representing the PostScript name of a TrueType font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PSName As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.PSName = value

value = instance.PSName
public ImGearPDFAtom PSName {get; set;}
public: __property ImGearPDFAtom* get_PSName();
public: __property void set_PSName(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ PSName {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Registry Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Registry Property
Gets or sets the atom representing the CIDFont’s Registry information, as in "Adobe-Japan".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Registry As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Registry = value

value = instance.Registry
public ImGearPDFAtom Registry {get; set;}
public: __property ImGearPDFAtom* get_Registry();
public: __property void set_Registry(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Registry {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


Type Property (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Type Property
Gets or sets an atom for font type, corresponding to the Subtype key in a font dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFAtom

instance.Type = value

value = instance.Type
public ImGearPDFAtom Type {get; set;}
public: __property ImGearPDFAtom* get_Type();
public: __property void set_Type(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Type {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
May be "Type1", "TrueType", "MMType1", or "Type0".
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFAtom Class


%%PageItemTitle%% $$Fields$$

ImGearPDEFontAttrs Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontAttrs Class

For a list of all members of this type, see ImGearPDEFontAttrs members.

Public Fields
 | Name | Description
Public Field | Ascent | Maximum ascender height.
Public Field | AvgWidth | Average character width.
Public Field | BBox | Font bounding box in 1000 EM units.
Public Field | CantEmbed | A non-zero value means the font cannot be embedded.
Public Field | CapHeight | Capital height.
Public Field | Descent | Maximum descender depth.
Public Field | Flags | Desired font flags, one or more values of enumImGearPDFFontFlags.
Public Field | ItalicAngle | Italic angle in degrees, if any.
Public Field | Leading | Additional leading between lines.
Public Field | MaxWidth | Additional leading between lines.
Public Field | MissingWidth | Width of missing character.
Public Field | PackageType | Package type, one of ImGearPDESysFontPackageType.
Public Field | Protection | Allows setting one of the following bits to disable font embedding.
Public Field | StemH | Horizontal stem width.
Public Field | StemV | Vertical stem width.
Public Field | Supplement | The SystemSupplement field from the CIDFont.
Public Field | WritingMode | Writing mode.
Public Field | XHeight | The X height.
Top
See Also

Reference

ImGearPDEFontAttrs Class
ImageGear.Formats.PDF Namespace


Ascent Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Ascent Field
Maximum ascender height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Ascent As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.Ascent

instance.Ascent = value
public short Ascent
public: short Ascent
public:
short Ascent

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


AvgWidth Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : AvgWidth Field
Average character width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AvgWidth As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.AvgWidth

instance.AvgWidth = value
public short AvgWidth
public: short AvgWidth
public:
short AvgWidth

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


BBox Field (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : BBox Field
Font bounding box in 1000 EM units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BBox As ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDFFixedRect

value = instance.BBox

instance.BBox = value
public ImGearPDFFixedRect BBox
public: ImGearPDFFixedRect* BBox
public:
ImGearPDFFixedRect^ BBox

Field Value

ImGearPDFFixedRect class object.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDFFixedRect Class


CantEmbed Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : CantEmbed Field
A non-zero value means the font cannot be embedded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CantEmbed As Integer
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Integer

value = instance.CantEmbed

instance.CantEmbed = value
public int CantEmbed
public: int CantEmbed
public:
int CantEmbed

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


CapHeight Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : CapHeight Field
Capital height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CapHeight As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.CapHeight

instance.CapHeight = value
public short CapHeight
public: short CapHeight
public:
short CapHeight

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


Descent Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Descent Field
Maximum descender depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Descent As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.Descent

instance.Descent = value
public short Descent
public: short Descent
public:
short Descent

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


Flags Field (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Flags Field
Desired font flags, one or more values of enumImGearPDFFontFlags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Flags As ImGearPDEFontFlags
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDEFontFlags

value = instance.Flags

instance.Flags = value
public ImGearPDEFontFlags Flags
public: ImGearPDEFontFlags Flags
public:
ImGearPDEFontFlags Flags

Field Value

Combination of ImGearPDEFontFlags enumeration values.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDEFontFlags Enumeration


ItalicAngle Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : ItalicAngle Field
Italic angle in degrees, if any.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ItalicAngle As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.ItalicAngle

instance.ItalicAngle = value
public short ItalicAngle
public: short ItalicAngle
public:
short ItalicAngle

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


Leading Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Leading Field
Additional leading between lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Leading As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.Leading

instance.Leading = value
public short Leading
public: short Leading
public:
short Leading

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


MaxWidth Field (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : MaxWidth Field
Additional leading between lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxWidth As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.MaxWidth

instance.MaxWidth = value
public short MaxWidth
public: short MaxWidth
public:
short MaxWidth

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


MissingWidth Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : MissingWidth Field
Width of missing character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MissingWidth As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.MissingWidth

instance.MissingWidth = value
public short MissingWidth
public: short MissingWidth
public:
short MissingWidth

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


PackageType Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : PackageType Field
Package type, one of ImGearPDESysFontPackageType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PackageType As ImGearPDESysFontPackageType
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDESysFontPackageType

value = instance.PackageType

instance.PackageType = value
public ImGearPDESysFontPackageType PackageType
public: ImGearPDESysFontPackageType PackageType
public:
ImGearPDESysFontPackageType PackageType

Field Value

ImGearPDESysFontPackageType enumeration value.
Remarks
The default value is ImGearPDESysFontPackageType.UNKNOWN.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members
ImGearPDESysFontPackageType Enumeration


Protection Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Protection Field
Allows setting one of the following bits to disable font embedding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Protection As ImGearPDEFontProtection
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As ImGearPDEFontProtection

value = instance.Protection

instance.Protection = value
public ImGearPDEFontProtection Protection
public: ImGearPDEFontProtection Protection
public:
ImGearPDEFontProtection Protection

Field Value

ImGearPDEFontProtection enumeration value.
Remarks
    The default value is ImGearPDEFontProtection.NO_EMBEDDING.
    See Also

    Reference

    ImGearPDEFontAttrs Class
    ImGearPDEFontAttrs Members
    ImGearPDEFontProtection Enumeration


StemH Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : StemH Field
Horizontal stem width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public StemH As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.StemH

instance.StemH = value
public short StemH
public: short StemH
public:
short StemH

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


StemV Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : StemV Field
Vertical stem width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public StemV As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.StemV

instance.StemV = value
public short StemV
public: short StemV
public:
short StemV

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


Supplement Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : Supplement Field
The SystemSupplement field from the CIDFont.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Supplement As Integer
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Integer

value = instance.Supplement

instance.Supplement = value
public int Supplement
public: int Supplement
public:
int Supplement

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


WritingMode Field (ImGearPDEFontAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : WritingMode Field
Writing mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WritingMode As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.WritingMode

instance.WritingMode = value
public short WritingMode
public: short WritingMode
public:
short WritingMode

Field Value

Short value.
Remarks
Must be one of:
  • 0 for horizontal writing
  • 1 for vertical writing
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


XHeight Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontAttrs Class : XHeight Field
The X height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public XHeight As Short
'Usage

Dim instance As ImGearPDEFontAttrs
Dim value As Short

value = instance.XHeight

instance.XHeight = value
public short XHeight
public: short XHeight
public:
short XHeight

Field Value

Short value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontAttrs Class
ImGearPDEFontAttrs Members


%%PageItemTitle%%

ImGearPDEFontCreateFromSysFontParams Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateFromSysFontParams Class
Provides PDE Font creation parameters.
Object Model
ImGearPDEFontCreateFromSysFontParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFontCreateFromSysFontParams
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
public sealed class ImGearPDEFontCreateFromSysFontParams
public __gc __sealed class ImGearPDEFontCreateFromSysFontParams
public ref class ImGearPDEFontCreateFromSysFontParams sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEFontCreateFromSysFontParams

See Also

Reference

ImGearPDEFontCreateFromSysFontParams Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFontCreateFromSysFontParams Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateFromSysFontParams Class

The following tables list the members exposed by ImGearPDEFontCreateFromSysFontParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFontCreateFromSysFontParams Constructor | Initializes a new instance of the ImGearPDEFontCreateFromSysFontParams class.
Top
Public Fields
 | Name | Description
Public Field | Encoding | Used to specify which encoding to use with a CID font.
Public Field | MMDesignVec | Multiple master font design vector.
Public Field | SnapshotName | The name of a multiple master snapshot.
Top
Public Properties
 | Name | Description
Public Property | CodePage | Gets or sets a specific code page supported by the font.
Public Property | Flags | Gets or sets a bit mask of the ImGearPDEFontCreateFlags.
Top
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontCreateFromSysFontParams Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : ImGearPDEFontCreateFromSysFontParams Constructor
Initializes a new instance of the ImGearPDEFontCreateFromSysFontParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEFontCreateFromSysFontParams()
public ImGearPDEFontCreateFromSysFontParams()
public: ImGearPDEFontCreateFromSysFontParams();
public:
ImGearPDEFontCreateFromSysFontParams();

Return Value

The new instance of ImGearPDEFontCreateFromSysFontParams class object.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members


%%PageItemTitle%% $$Properties$$

ImGearPDEFontCreateFromSysFontParams Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateFromSysFontParams Class

For a list of all members of this type, see ImGearPDEFontCreateFromSysFontParams members.

Public Properties
 | Name | Description
Public Property | CodePage | Gets or sets a specific code page supported by the font.
Public Property | Flags | Gets or sets a bit mask of the ImGearPDEFontCreateFlags.
Top
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImageGear.Formats.PDF Namespace


CodePage Property (ImGearPDEFontCreateFromSysFontParams)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : CodePage Property
Gets or sets a specific code page supported by the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CodePage As Integer
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
Dim value As Integer

instance.CodePage = value

value = instance.CodePage
public int CodePage {get; set;}
public: __property int get_CodePage();
public: __property void set_CodePage(
   int value
);
public:
property int CodePage {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When a non-zero code page is supplied, embedding must be turned on and the ENCODE_BY_GID flag set. The default value is 0.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members


Flags Property (ImGearPDEFontCreateFromSysFontParams)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : Flags Property
Gets or sets a bit mask of the ImGearPDEFontCreateFlags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As ImGearPDEFontCreateFlags
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
Dim value As ImGearPDEFontCreateFlags

instance.Flags = value

value = instance.Flags
public ImGearPDEFontCreateFlags Flags {get; set;}
public: __property ImGearPDEFontCreateFlags get_Flags();
public: __property void set_Flags(
   ImGearPDEFontCreateFlags value
);
public:
property ImGearPDEFontCreateFlags Flags {
   ImGearPDEFontCreateFlags get();
   void set (    ImGearPDEFontCreateFlags value);
}

Property Value

ImGearPDEFontCreateFlags enumeration value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members
ImGearPDEFontCreateFlags Enumeration


%%PageItemTitle%% $$Fields$$

ImGearPDEFontCreateFromSysFontParams Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateFromSysFontParams Class

For a list of all members of this type, see ImGearPDEFontCreateFromSysFontParams members.

Public Fields
 | Name | Description
Public Field | Encoding | Used to specify which encoding to use with a CID font.
Public Field | MMDesignVec | Multiple master font design vector.
Public Field | SnapshotName | The name of a multiple master snapshot.
Top
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImageGear.Formats.PDF Namespace


Encoding Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : Encoding Field
Used to specify which encoding to use with a CID font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Encoding As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
Dim value As ImGearPDFAtom

value = instance.Encoding

instance.Encoding = value
public ImGearPDFAtom Encoding
public: ImGearPDFAtom* Encoding
public:
ImGearPDFAtom^ Encoding

Field Value

ImGearPDFAtom class object.
Remarks
Pass Null to use the platform default.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members
ImGearPDFAtom Class


MMDesignVec Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : MMDesignVec Field
Multiple master font design vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MMDesignVec As Integer()
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
Dim value() As Integer

value = instance.MMDesignVec

instance.MMDesignVec = value
public int[] MMDesignVec
public: int[]* MMDesignVec
public:
array<int>^ MMDesignVec

Field Value

Array of integer value.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members


SnapshotName Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontCreateFromSysFontParams Class : SnapshotName Field
The name of a multiple master snapshot.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public SnapshotName As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontCreateFromSysFontParams
Dim value As ImGearPDFAtom

value = instance.SnapshotName

instance.SnapshotName = value
public ImGearPDFAtom SnapshotName
public: ImGearPDFAtom* SnapshotName
public:
ImGearPDFAtom^ SnapshotName

Field Value

ImGearPDFAtom class object.
Remarks
See PDF Reference for more information on snapshots.
See Also

Reference

ImGearPDEFontCreateFromSysFontParams Class
ImGearPDEFontCreateFromSysFontParams Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEFontInfo Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontInfo Class
Represents PDE font information.
Object Model
ImGearPDEFontInfo ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEFontInfo
'Usage

Dim instance As ImGearPDEFontInfo
public sealed class ImGearPDEFontInfo
public __gc __sealed class ImGearPDEFontInfo
public ref class ImGearPDEFontInfo sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEFontInfo

See Also

Reference

ImGearPDEFontInfo Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEFontInfo Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontInfo Class

The following tables list the members exposed by ImGearPDEFontInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEFontInfo Constructor | Initializes a new instance of the ImGearPDEFontInfo class.
Top
Public Fields
 | Name | Description
Public Field | WritingMode | Writing mode.
Top
Public Properties
 | Name | Description
Public Property | CharSet | Gets or sets the character set.
Public Property | Encoding | Gets or sets the font encoding.
Public Property | Name | Gets or sets the font name.
Public Property | Type | Gets or sets the font type.
Top
See Also

Reference

ImGearPDEFontInfo Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontInfo Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : ImGearPDEFontInfo Constructor
Initializes a new instance of the ImGearPDEFontInfo class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEFontInfo()
public ImGearPDEFontInfo()
public: ImGearPDEFontInfo();
public:
ImGearPDEFontInfo();
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members


%%PageItemTitle%% $$Properties$$

ImGearPDEFontInfo Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontInfo Class

For a list of all members of this type, see ImGearPDEFontInfo members.

Public Properties
 | Name | Description
Public Property | CharSet | Gets or sets the character set.
Public Property | Encoding | Gets or sets the font encoding.
Public Property | Name | Gets or sets the font name.
Public Property | Type | Gets or sets the font type.
Top
See Also

Reference

ImGearPDEFontInfo Class
ImageGear.Formats.PDF Namespace


CharSet Property (ImGearPDEFontInfo)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : CharSet Property
Gets or sets the character set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharSet As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontInfo
Dim value As ImGearPDFAtom

instance.CharSet = value

value = instance.CharSet
public ImGearPDFAtom CharSet {get; set;}
public: __property ImGearPDFAtom* get_CharSet();
public: __property void set_CharSet(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ CharSet {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
Remarks
If "Roman", the characters must be a subset of the Adobe Standard Roman Character Set.
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members
ImGearPDFAtom Class


Encoding Property (ImGearPDEFontInfo)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : Encoding Property
Gets or sets the font encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontInfo
Dim value As ImGearPDFAtom

instance.Encoding = value

value = instance.Encoding
public ImGearPDFAtom Encoding {get; set;}
public: __property ImGearPDFAtom* get_Encoding();
public: __property void set_Encoding(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Encoding {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members
ImGearPDFAtom Class


Name Property (ImGearPDEFontInfo)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : Name Property
Gets or sets the font name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontInfo
Dim value As ImGearPDFAtom

instance.Name = value

value = instance.Name
public ImGearPDFAtom Name {get; set;}
public: __property ImGearPDFAtom* get_Name();
public: __property void set_Name(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Name {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members
ImGearPDFAtom Class


Type Property (ImGearPDEFontInfo)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : Type Property
Gets or sets the font type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEFontInfo
Dim value As ImGearPDFAtom

instance.Type = value

value = instance.Type
public ImGearPDFAtom Type {get; set;}
public: __property ImGearPDFAtom* get_Type();
public: __property void set_Type(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Type {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members
ImGearPDFAtom Class


%%PageItemTitle%% $$Fields$$

ImGearPDEFontInfo Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontInfo Class

For a list of all members of this type, see ImGearPDEFontInfo members.

Public Fields
 | Name | Description
Public Field | WritingMode | Writing mode.
Top
See Also

Reference

ImGearPDEFontInfo Class
ImageGear.Formats.PDF Namespace


WritingMode Field (ImGearPDEFontInfo)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEFontInfo Class : WritingMode Field
Writing mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WritingMode As Short
'Usage

Dim instance As ImGearPDEFontInfo
Dim value As Short

value = instance.WritingMode

instance.WritingMode = value
public short WritingMode
public: short WritingMode
public:
short WritingMode

Field Value

Short value.
Remarks
Must be one of:
  • 0 for horizontal writing
  • 1 for vertical writing
The default value is 0.
See Also

Reference

ImGearPDEFontInfo Class
ImGearPDEFontInfo Members


%%PageItemTitle%%

ImGearPDEForm Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEForm Class
Represents an element corresponding to an instance of XObject Form on a page or other containing stream.
Object Model
ImGearPDEForm ClassImGearPDEForm ClassImGearPDEContent ClassImGearPDEXGroup Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEForm
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEForm
public sealed class ImGearPDEForm : ImGearPDEElement
public __gc __sealed class ImGearPDEForm : public ImGearPDEElement
public ref class ImGearPDEForm sealed : public ImGearPDEElement
Remarks
The context associated with this instance includes the actual stream that represents the XObject Form and the initial conditions of the graphics state. The latter consists of the transformation matrix, initial color values, and so forth. It is possible to have two Forms that refer to the same XObject Form. The forms will exist at different places on the same page, depending on the transformation matrix. They may also have different colors or line stroking parameters. In the case of a transparency group, the opacity is specified in the gstate.

Within a Form, each element has its own gstate (or is a container, place, or group object). These gstates are independent of the parent Form gstate. Form elements may have their own opacity.

Content may be obtained from a Form to edit the form's display list.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEForm

See Also

Reference

ImGearPDEForm Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEForm Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEForm Class

The following tables list the members exposed by ImGearPDEForm.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEForm Constructor | Initializes a new instance of the ImGearPDEForm class.
Top
Public Properties
 | Name | Description
Public Property | HasXGroup | Gets a value indicating whether the XObject form has a Transparency XGroup.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overloaded. Creates a new form from an existing form object.
Public Method | GetContent | Gets Form's content object.
Public Method | GetXGroup | Gets the transparency group dictionary of the XObject form.
Public Method | SetContent | Overloaded. Sets Form's content object.
Top
See Also

Reference

ImGearPDEForm Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEForm Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : ImGearPDEForm Constructor
The XObject from which a PDEForm is created.
The XObject's resources dictionary.
The transformation matrix to use for the form.
Initializes a new instance of the ImGearPDEForm class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal formStream As ImGearPDFBasObj, _
   ByVal formDictionary As ImGearPDFBasObj, _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim formStream As ImGearPDFBasObj
Dim formDictionary As ImGearPDFBasObj
Dim matrix As ImGearPDFFixedMatrix

Dim instance As New ImGearPDEForm(formStream, formDictionary, matrix)
public ImGearPDEForm(
   ImGearPDFBasObj formStream,
   ImGearPDFBasObj formDictionary,
   ImGearPDFFixedMatrix matrix
)
public: ImGearPDEForm(
   ImGearPDFBasObj* formStream,
   ImGearPDFBasObj* formDictionary,
   ImGearPDFFixedMatrix* matrix
)
public:
ImGearPDEForm(
   ImGearPDFBasObj^ formStream,
   ImGearPDFBasObj^ formDictionary,
   ImGearPDFFixedMatrix^ matrix
)

Parameters

formStream
The XObject from which a PDEForm is created.
formDictionary
The XObject's resources dictionary.
matrix
The transformation matrix to use for the form.

Return Value

The new instance of ImGearPDEForm class object.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members


%%PageItemTitle%% $$Methods$$

ImGearPDEForm Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEForm Class

For a list of all members of this type, see ImGearPDEForm members.

Public Methods
 | Name | Description
Public Method | Clone | Overloaded. Creates a new form from an existing form object.
Public Method | GetContent | Gets Form's content object.
Public Method | GetXGroup | Gets the transparency group dictionary of the XObject form.
Public Method | SetContent | Overloaded. Sets Form's content object.
Top
See Also

Reference

ImGearPDEForm Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEForm Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : ImGearPDEForm Constructor
Overload List
Overload | Description
ImGearPDEForm Constructor | Initializes a new instance of the ImGearPDEForm class.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members


Clone Method (ImGearPDEForm)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : Clone Method
Creates a new form from an existing form object.
Overload List
Overload | Description
Clone() | Creates a new form from an existing form object.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members


Clone() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class > Clone Method : Clone() Method
Creates a new form from an existing form object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Clone() As ImGearPDEForm
'Usage

Dim instance As ImGearPDEForm
Dim value As ImGearPDEForm

value = instance.Clone()
public ImGearPDEForm Clone()
public: ImGearPDEForm* Clone();
public:
ImGearPDEForm^ Clone();

Return Value

The newly created ImGearPDEForm class object.
Remarks
Creates a copy of the PDE Form, including the underlying objects.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members
Overload List


GetContent Method (ImGearPDEForm)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : GetContent Method
Gets Form's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearPDEContent
'Usage

Dim instance As ImGearPDEForm
Dim value As ImGearPDEContent

value = instance.GetContent()
public ImGearPDEContent GetContent()
public: ImGearPDEContent* GetContent();
public:
ImGearPDEContent^ GetContent();

Return Value

ImGearPDEContent class object.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members
ImGearPDEContent Class


GetXGroup Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : GetXGroup Method
Gets the transparency group dictionary of the XObject form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetXGroup() As ImGearPDEXGroup
'Usage

Dim instance As ImGearPDEForm
Dim value As ImGearPDEXGroup

value = instance.GetXGroup()
public ImGearPDEXGroup GetXGroup()
public: ImGearPDEXGroup* GetXGroup();
public:
ImGearPDEXGroup^ GetXGroup();

Return Value

ImGearPDEXGroup class object.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members
ImGearPDEXGroup Class


SetContent Method (ImGearPDEForm)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : SetContent Method
Sets Form's content object.
Overload List
Overload | Description
SetContent(ImGearPDEContent) | Sets Form's content object.
SetContent(ImGearPDEXGroup) | Sets the transparency group dictionary of the XObject form.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members


SetContent(ImGearPDEContent) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class > SetContent Method : SetContent(ImGearPDEContent) Method
Content to set.
Sets Form's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetContent( _
   ByVal content As ImGearPDEContent _
)
'Usage

Dim instance As ImGearPDEForm
Dim content As ImGearPDEContent

instance.SetContent(content)
public void SetContent(
   ImGearPDEContent content
)
public: void SetContent(
   ImGearPDEContent* content
)
public:
void SetContent(
   ImGearPDEContent^ content
)

Parameters

content
Content to set.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members
Overload List
ImGearPDEContent Class


SetContent(ImGearPDEXGroup) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class > SetContent Method : SetContent(ImGearPDEXGroup) Method
The transparency group dictionary of the XObject form.
Sets the transparency group dictionary of the XObject form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetContent( _
   ByVal transparencyDictionary As ImGearPDEXGroup _
)
'Usage

Dim instance As ImGearPDEForm
Dim transparencyDictionary As ImGearPDEXGroup

instance.SetContent(transparencyDictionary)
public void SetContent(
   ImGearPDEXGroup transparencyDictionary
)
public: void SetContent(
   ImGearPDEXGroup* transparencyDictionary
)
public:
void SetContent(
   ImGearPDEXGroup^ transparencyDictionary
)

Parameters

transparencyDictionary
The transparency group dictionary of the XObject form.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members
Overload List
ImGearPDEXGroup Class


%%PageItemTitle%% $$Properties$$

ImGearPDEForm Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEForm Class

For a list of all members of this type, see ImGearPDEForm members.

Public Properties
 | Name | Description
Public Property | HasXGroup | Gets a value indicating whether the XObject form has a Transparency XGroup.
Top
See Also

Reference

ImGearPDEForm Class
ImageGear.Formats.PDF Namespace


HasXGroup Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEForm Class : HasXGroup Property
Gets a value indicating whether the XObject form has a Transparency XGroup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasXGroup As Boolean
'Usage

Dim instance As ImGearPDEForm
Dim value As Boolean

value = instance.HasXGroup
public bool HasXGroup {get;}
public: __property bool get_HasXGroup();
public:
property bool HasXGroup {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEForm Class
ImGearPDEForm Members


%%PageItemTitle%%

ImGearPDEGraphicState Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicState Class
Provides attributes of a PDE element or a PDE text sub-element.
Object Model
ImGearPDEGraphicState Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEGraphicState
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDEGraphicState
public sealed class ImGearPDEGraphicState : ImGearPDFObject
public __gc __sealed class ImGearPDEGraphicState : public ImGearPDFObject
public ref class ImGearPDEGraphicState sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEGraphicState

See Also

Reference

ImGearPDEGraphicState Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEGraphicState Class Members
Fields Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicState Class

The following tables list the members exposed by ImGearPDEGraphicState.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEGraphicState Constructor | Initializes a new instance of the ImGearPDEGraphicState class.
Top
Public Fields
 | Name | Description
Public Field | Dash | Gets or sets the dash specification.
Public Field | FillColorSpec | Fill color specification.
Public Field | RenderIntent | A color rendering intent, corresponding to the Intent key in the image dictionary.
Public Field | StrokeColorSpec | Stroke color specification.
Top
Public Properties
 | Name | Description
Public Property | Flatness | Gets or sets the line flatness, corresponding to the i (setflat) operator.
Public Property | LineCap | Gets or sets the line cap style, corresponding to the J (setlinecap) operator.
Public Property | LineJoin | Gets or sets the line join style, corresponding to the j (setlinejoin) operator.
Public Property | LineWidth | Gets or sets the line width, corresponding to the w (setlinewidth) operator.
Public Property | MiterLimit | Gets or sets the miter limit, corresponding to the M (setmiterlimit) operator.
Public Property | WasSetFlags | Gets or sets the value indicating whether an attribute has been set.
Top
See Also

Reference

ImGearPDEGraphicState Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEGraphicState Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : ImGearPDEGraphicState Constructor
Initializes a new instance of the ImGearPDEGraphicState class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEGraphicState()
public ImGearPDEGraphicState()
public: ImGearPDEGraphicState();
public:
ImGearPDEGraphicState();

Return Value

The new instance of ImGearPDEGraphicState class object.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members


%%PageItemTitle%% $$Properties$$

ImGearPDEGraphicState Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicState Class

For a list of all members of this type, see ImGearPDEGraphicState members.

Public Properties
 | Name | Description
Public Property | Flatness | Gets or sets the line flatness, corresponding to the i (setflat) operator.
Public Property | LineCap | Gets or sets the line cap style, corresponding to the J (setlinecap) operator.
Public Property | LineJoin | Gets or sets the line join style, corresponding to the j (setlinejoin) operator.
Public Property | LineWidth | Gets or sets the line width, corresponding to the w (setlinewidth) operator.
Public Property | MiterLimit | Gets or sets the miter limit, corresponding to the M (setmiterlimit) operator.
Public Property | WasSetFlags | Gets or sets the value indicating whether an attribute has been set.
Top
See Also

Reference

ImGearPDEGraphicState Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEGraphicState Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicState Class

For a list of all members of this type, see ImGearPDEGraphicState members.

See Also

Reference

ImGearPDEGraphicState Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEGraphicState Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : ImGearPDEGraphicState Constructor
Overload List
Overload | Description
ImGearPDEGraphicState Constructor | Initializes a new instance of the ImGearPDEGraphicState class.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members


Flatness Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : Flatness Property
Gets or sets the line flatness, corresponding to the i (setflat) operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flatness As Integer
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As Integer

instance.Flatness = value

value = instance.Flatness
public int Flatness {get; set;}
public: __property int get_Flatness();
public: __property void set_Flatness(
   int value
);
public:
property int Flatness {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members


LineCap Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : LineCap Property
Gets or sets the line cap style, corresponding to the J (setlinecap) operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineCap As Integer
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As Integer

instance.LineCap = value

value = instance.LineCap
public int LineCap {get; set;}
public: __property int get_LineCap();
public: __property void set_LineCap(
   int value
);
public:
property int LineCap {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members


LineJoin Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : LineJoin Property
Gets or sets the line join style, corresponding to the j (setlinejoin) operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineJoin As Integer
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As Integer

instance.LineJoin = value

value = instance.LineJoin
public int LineJoin {get; set;}
public: __property int get_LineJoin();
public: __property void set_LineJoin(
   int value
);
public:
property int LineJoin {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members


LineWidth Property (ImGearPDEGraphicState)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : LineWidth Property
Gets or sets the line width, corresponding to the w (setlinewidth) operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineWidth As Integer
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As Integer

instance.LineWidth = value

value = instance.LineWidth
public int LineWidth {get; set;}
public: __property int get_LineWidth();
public: __property void set_LineWidth(
   int value
);
public:
property int LineWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is ImGearPDFFixedValues.ONE.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDFFixedValues Enumeration


MiterLimit Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : MiterLimit Property
Gets or sets the miter limit, corresponding to the M (setmiterlimit) operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MiterLimit As Integer
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As Integer

instance.MiterLimit = value

value = instance.MiterLimit
public int MiterLimit {get; set;}
public: __property int get_MiterLimit();
public: __property void set_MiterLimit(
   int value
);
public:
property int MiterLimit {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is ImGearPDFFixedValues.TEN.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDFFixedValues Enumeration


WasSetFlags Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : WasSetFlags Property
Gets or sets the value indicating whether an attribute has been set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WasSetFlags As ImGearPDEGraphicStateWasSetFlags
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As ImGearPDEGraphicStateWasSetFlags

instance.WasSetFlags = value

value = instance.WasSetFlags
public ImGearPDEGraphicStateWasSetFlags WasSetFlags {get; set;}
public: __property ImGearPDEGraphicStateWasSetFlags get_WasSetFlags();
public: __property void set_WasSetFlags(
   ImGearPDEGraphicStateWasSetFlags value
);
public:
property ImGearPDEGraphicStateWasSetFlags WasSetFlags {
   ImGearPDEGraphicStateWasSetFlags get();
   void set (    ImGearPDEGraphicStateWasSetFlags value);
}

Property Value

Combination of ImGearPDEGraphicStateWasSetFlags enumeration values.
Remarks
Support for these flags is not complete. For compatibility, you should set them, but do not depend on reading their values back. The intended use is with XObject Forms to indicate whether the value is inherited or explicitly set. The default value is 0.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDEGraphicStateWasSetFlags Enumeration


%%PageItemTitle%% $$Fields$$

ImGearPDEGraphicState Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicState Class

For a list of all members of this type, see ImGearPDEGraphicState members.

Public Fields
 | Name | Description
Public Field | Dash | Gets or sets the dash specification.
Public Field | FillColorSpec | Fill color specification.
Public Field | RenderIntent | A color rendering intent, corresponding to the Intent key in the image dictionary.
Public Field | StrokeColorSpec | Stroke color specification.
Top
See Also

Reference

ImGearPDEGraphicState Class
ImageGear.Formats.PDF Namespace


Dash Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : Dash Field
Gets or sets the dash specification.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Dash As ImGearPDEDash
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As ImGearPDEDash

value = instance.Dash

instance.Dash = value
public ImGearPDEDash Dash
public: ImGearPDEDash* Dash
public:
ImGearPDEDash^ Dash

Field Value

ImGearPDEDash class value.
Remarks
The default value is {0,0,0,0,0,0,0,0,0,0,0}.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDEDash Class


FillColorSpec Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : FillColorSpec Field
Fill color specification.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FillColorSpec As ImGearPDEColorSpec
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As ImGearPDEColorSpec

value = instance.FillColorSpec

instance.FillColorSpec = value
public ImGearPDEColorSpec FillColorSpec
public: ImGearPDEColorSpec* FillColorSpec
public:
ImGearPDEColorSpec^ FillColorSpec

Field Value

ImGearPDEColorSpec class value
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDEColorSpec Class


RenderIntent Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : RenderIntent Field
A color rendering intent, corresponding to the Intent key in the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public RenderIntent As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As ImGearPDFAtom

value = instance.RenderIntent

instance.RenderIntent = value
public ImGearPDFAtom RenderIntent
public: ImGearPDFAtom* RenderIntent
public:
ImGearPDFAtom^ RenderIntent

Field Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDFAtom Class


StrokeColorSpec Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGraphicState Class : StrokeColorSpec Field
Stroke color specification.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public StrokeColorSpec As ImGearPDEColorSpec
'Usage

Dim instance As ImGearPDEGraphicState
Dim value As ImGearPDEColorSpec

value = instance.StrokeColorSpec

instance.StrokeColorSpec = value
public ImGearPDEColorSpec StrokeColorSpec
public: ImGearPDEColorSpec* StrokeColorSpec
public:
ImGearPDEColorSpec^ StrokeColorSpec

Field Value

ImGearPDEColorSpec class value
See Also

Reference

ImGearPDEGraphicState Class
ImGearPDEGraphicState Members
ImGearPDEColorSpec Class


%%PageItemTitle%%

ImGearPDEGroup Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGroup Class
Represents a group of objects in PDE content.
Object Model
ImGearPDEGroup ClassImGearPDEContent Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEGroup
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEGroup
public sealed class ImGearPDEGroup : ImGearPDEElement
public __gc __sealed class ImGearPDEGroup : public ImGearPDEElement
public ref class ImGearPDEGroup sealed : public ImGearPDEElement
Remarks
It has no state and is not represented in any way in a content stream (that is, Content).

When used in a Clip, this object is used to associate Text objects into a single clipping object.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEGroup

See Also

Reference

ImGearPDEGroup Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEGroup Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGroup Class

The following tables list the members exposed by ImGearPDEGroup.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEGroup Constructor | Initializes a new instance of the ImGearPDEGroup class.
Top
Public Methods
 | Name | Description
Public Method | GetContent | Gets Group's content object.
Public Method | SetContent | Sets Group's content object.
Top
See Also

Reference

ImGearPDEGroup Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDEGroup Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGroup Class

For a list of all members of this type, see ImGearPDEGroup members.

See Also

Reference

ImGearPDEGroup Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEGroup Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGroup Class : ImGearPDEGroup Constructor
Initializes a new instance of the ImGearPDEGroup class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEGroup()
public ImGearPDEGroup()
public: ImGearPDEGroup();
public:
ImGearPDEGroup();

Return Value

The new instance of ImGearPDEGroup class object.
See Also

Reference

ImGearPDEGroup Class
ImGearPDEGroup Members


%%PageItemTitle%% $$Methods$$

ImGearPDEGroup Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGroup Class

For a list of all members of this type, see ImGearPDEGroup members.

Public Methods
 | Name | Description
Public Method | GetContent | Gets Group's content object.
Public Method | SetContent | Sets Group's content object.
Top
See Also

Reference

ImGearPDEGroup Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEGroup Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGroup Class : ImGearPDEGroup Constructor
Overload List
Overload | Description
ImGearPDEGroup Constructor | Initializes a new instance of the ImGearPDEGroup class.
See Also

Reference

ImGearPDEGroup Class
ImGearPDEGroup Members


GetContent Method (ImGearPDEGroup)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGroup Class : GetContent Method
Gets Group's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearPDEContent
'Usage

Dim instance As ImGearPDEGroup
Dim value As ImGearPDEContent

value = instance.GetContent()
public ImGearPDEContent GetContent()
public: ImGearPDEContent* GetContent();
public:
ImGearPDEContent^ GetContent();

Return Value

ImGearPDEContent class object.
See Also

Reference

ImGearPDEGroup Class
ImGearPDEGroup Members
ImGearPDEContent Class


SetContent Method (ImGearPDEGroup)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEGroup Class : SetContent Method
Group's content object.
Sets Group's content object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetContent( _
   ByVal content As ImGearPDEContent _
)
'Usage

Dim instance As ImGearPDEGroup
Dim content As ImGearPDEContent

instance.SetContent(content)
public void SetContent(
   ImGearPDEContent content
)
public: void SetContent(
   ImGearPDEContent* content
)
public:
void SetContent(
   ImGearPDEContent^ content
)

Parameters

content
Group's content object.
See Also

Reference

ImGearPDEGroup Class
ImGearPDEGroup Members
ImGearPDEContent Class


%%PageItemTitle%%

ImGearPDEImage Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImage Class
Represents an Image XObject or in-line image.
Object Model
ImGearPDEImage ClassImGearPDEImageAttrs ClassImGearPDEColorSpace ClassImGearPDFStream ClassImGearPDFBasDict ClassImGearPDEFilterArray ClassImGearPDEImage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEImage
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEImage
public sealed class ImGearPDEImage : ImGearPDEElement
public __gc __sealed class ImGearPDEImage : public ImGearPDEElement
public ref class ImGearPDEImage sealed : public ImGearPDEElement
Remarks
You can associate data or a stream with an image.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEImage

See Also

Reference

ImGearPDEImage Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEImage Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImage Class

The following tables list the members exposed by ImGearPDEImage.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEImage Constructor | Initializes a new instance of the ImGearPDEImage class.
Top
Public Properties
 | Name | Description
Public Property | DataLength | Gets a number of bytes of image data, specified by the width, height, bits per component, and color space of the image.
Public Property | EncodedLength | Gets a length of the encoded data, if the data is encoded, that is, IsDataEncoded is True.
Public Property | HasSoftMask | Gets a value indicating whether the soft mask exists.
Public Property | IsDataEncoded | Gets a value indicating whether GetData returns encoded data.
Public Property | IsXObject | Gets a value indicating whether the image is an XObject image.
Top
Public Methods
 | Name | Description
Public Method | GetAttributes | Gets image attributes.
Public Method | GetColorMask | Obtains the Mask entry from the image dictionary.
Public Method | GetColorSpace | Gets the color space object for an image.
Public Method | GetData | Gets an image's data.
Public Method | GetDataStream | Gets a data stream for an image.
Public Method | GetDecodeArray | Gets the decode array for an image.
Public Method | GetDictionary | Gets the dictionary for an image.
Public Method | GetFilterArray | Gets the filter array for an image.
Public Method | GetMatteArray | Gets the matte array for the image XObject.
Public Method | GetSoftMask | Gets the soft mask for an image.
Public Method | SetColorMask | Sets the Mask entry from the image dictionary.
Public Method | SetColorSpace | Sets the color space object for an image.
Public Method | SetData | Sets data for an image.
Public Method | SetDataStream | Sets a data stream for an image.
Public Method | SetDecodeArray | Sets the decode array for an image.
Public Method | SetMatteArray | Sets the matte array for the image XObject.
Public Method | SetSoftMask | Sets the soft mask for an image.
Top
See Also

Reference

ImGearPDEImage Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEImage Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : ImGearPDEImage Constructor
ImGearPDEImageAttrs for the image attributes.
All images are defined in image space. Matrix defines the transformation from image space to user space.
ImGearPDEImageDataFlags options.
Color space of the image. When the image is an image mask, colorSpace is the color space of the color argument.
ImGearPDEColorValue object. If the image is an image mask, color must be provided.
ImGearPDEFilterArray that specifies which filters to use in encoding the contents; may be null. Filters will be used to encode the data in the order in which they are specified in the array.
Image data. If DataStream is non-null, Data parameter is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.
Single byte image data array. If DataStream is non-null, data is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.
Initializes a new instance of the ImGearPDEImage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal attributes As ImGearPDEImageAttrs, _
   ByVal matrix As ImGearPDFFixedMatrix, _
   ByVal options As ImGearPDEImageDataFlags, _
   ByVal colorSpace As ImGearPDEColorSpace, _
   ByVal color As ImGearPDEColorValue, _
   ByVal filters As ImGearPDEFilterArray, _
   ByVal dataStream As ImGearPDFStream, _
   ByVal data() As Byte _
)
'Usage

Dim attributes As ImGearPDEImageAttrs
Dim matrix As ImGearPDFFixedMatrix
Dim options As ImGearPDEImageDataFlags
Dim colorSpace As ImGearPDEColorSpace
Dim color As ImGearPDEColorValue
Dim filters As ImGearPDEFilterArray
Dim dataStream As ImGearPDFStream
Dim data() As Byte

Dim instance As New ImGearPDEImage(attributes, matrix, options, colorSpace, color, filters, dataStream, data)
public ImGearPDEImage(
   ImGearPDEImageAttrs attributes,
   ImGearPDFFixedMatrix matrix,
   ImGearPDEImageDataFlags options,
   ImGearPDEColorSpace colorSpace,
   ImGearPDEColorValue color,
   ImGearPDEFilterArray filters,
   ImGearPDFStream dataStream,
   byte[] data
)
public: ImGearPDEImage(
   ImGearPDEImageAttrs* attributes,
   ImGearPDFFixedMatrix* matrix,
   ImGearPDEImageDataFlags options,
   ImGearPDEColorSpace* colorSpace,
   ImGearPDEColorValue* color,
   ImGearPDEFilterArray* filters,
   ImGearPDFStream* dataStream,
   byte[]* data
)
public:
ImGearPDEImage(
   ImGearPDEImageAttrs^ attributes,
   ImGearPDFFixedMatrix^ matrix,
   ImGearPDEImageDataFlags options,
   ImGearPDEColorSpace^ colorSpace,
   ImGearPDEColorValue^ color,
   ImGearPDEFilterArray^ filters,
   ImGearPDFStream^ dataStream,
   array<byte>^ data
)

Parameters

attributes
ImGearPDEImageAttrs for the image attributes.
matrix
All images are defined in image space. Matrix defines the transformation from image space to user space.
options
ImGearPDEImageDataFlags options.
colorSpace
Color space of the image. When the image is an image mask, colorSpace is the color space of the color argument.
color
ImGearPDEColorValue object. If the image is an image mask, color must be provided.
filters
ImGearPDEFilterArray that specifies which filters to use in encoding the contents; may be null. Filters will be used to encode the data in the order in which they are specified in the array.
dataStream
Image data. If DataStream is non-null, Data parameter is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.
data
Single byte image data array. If DataStream is non-null, data is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.

Return Value

The new instance of ImGearPDEImage class object.
Remarks
The image data may be specified as a stream or as a buffer. If DataStream is non-null, Data is ignored.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEImageAttrs Class
ImGearPDFFixedMatrix Class
ImGearPDEImageDataFlags Enumeration
ImGearPDEColorSpace Class
ImGearPDEColorValue Class
ImGearPDEFilterArray Class
ImGearPDFStream Class


%%PageItemTitle%% $$Methods$$

ImGearPDEImage Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImage Class

For a list of all members of this type, see ImGearPDEImage members.

Public Methods
 | Name | Description
Public Method | GetAttributes | Gets image attributes.
Public Method | GetColorMask | Obtains the Mask entry from the image dictionary.
Public Method | GetColorSpace | Gets the color space object for an image.
Public Method | GetData | Gets an image's data.
Public Method | GetDataStream | Gets a data stream for an image.
Public Method | GetDecodeArray | Gets the decode array for an image.
Public Method | GetDictionary | Gets the dictionary for an image.
Public Method | GetFilterArray | Gets the filter array for an image.
Public Method | GetMatteArray | Gets the matte array for the image XObject.
Public Method | GetSoftMask | Gets the soft mask for an image.
Public Method | SetColorMask | Sets the Mask entry from the image dictionary.
Public Method | SetColorSpace | Sets the color space object for an image.
Public Method | SetData | Sets data for an image.
Public Method | SetDataStream | Sets a data stream for an image.
Public Method | SetDecodeArray | Sets the decode array for an image.
Public Method | SetMatteArray | Sets the matte array for the image XObject.
Public Method | SetSoftMask | Sets the soft mask for an image.
Top
See Also

Reference

ImGearPDEImage Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEImage Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : ImGearPDEImage Constructor
Overload List
Overload | Description
ImGearPDEImage Constructor | Initializes a new instance of the ImGearPDEImage class.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetAttributes Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetAttributes Method
Gets image attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttributes() As ImGearPDEImageAttrs
'Usage

Dim instance As ImGearPDEImage
Dim value As ImGearPDEImageAttrs

value = instance.GetAttributes()
public ImGearPDEImageAttrs GetAttributes()
public: ImGearPDEImageAttrs* GetAttributes();
public:
ImGearPDEImageAttrs^ GetAttributes();

Return Value

ImGearPDEImageAttrs class object.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEImageAttrs Class


GetColorMask Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetColorMask Method
Obtains the Mask entry from the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorMask() As Integer()
'Usage

Dim instance As ImGearPDEImage
Dim value() As Integer

value = instance.GetColorMask()
public int[] GetColorMask()
public: int[]* GetColorMask();
public:
array<int>^ GetColorMask();

Return Value

Integer array.
Remarks
Use this method to obtain the Mask entry from the image dictionary. The mask entry is an array specifying a range of colors to be masked out. Samples in the image that fall within this range are not painted, allowing the existing background to show through. The effect is similar to that of the video technique known as chroma-key.

The value of the Mask entry is an array of 2n integers, [min1 max1 ... minn maxn], where n is the number of color components in the image's color space. Each integer must be in the range 0 to 2 in power of BitsPerComponent - 1, representing color values before decoding with the Decode array. An image sample is masked (not painted) if all of its color components before decoding, c1...cn, fall within the specified ranges.

See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetColorSpace Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetColorSpace Method
Gets the color space object for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorSpace() As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEImage
Dim value As ImGearPDEColorSpace

value = instance.GetColorSpace()
public ImGearPDEColorSpace GetColorSpace()
public: ImGearPDEColorSpace* GetColorSpace();
public:
ImGearPDEColorSpace^ GetColorSpace();

Return Value

ImGearPDEColorSpace class value.
Remarks
Null if image an image mask.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEColorSpace Class


GetData Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetData Method
Gets an image's data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetData() As Byte()
'Usage

Dim instance As ImGearPDEImage
Dim value() As Byte

value = instance.GetData()
public byte[] GetData()
public: byte[]* GetData();
public:
array<byte>^ GetData();

Return Value

Array of bytes.
Remarks
If the image is a XObject image, data is always returned as decoded data.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetDataStream Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetDataStream Method
ImGearPDEImageDataFlags options. If the ENCODED flag is set, data is returned in encoded form. Otherwise, data is decoded.
Gets a data stream for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDataStream( _
   ByVal options As ImGearPDEImageDataFlags _
) As ImGearPDFStream
'Usage

Dim instance As ImGearPDEImage
Dim options As ImGearPDEImageDataFlags
Dim value As ImGearPDFStream

value = instance.GetDataStream(options)
public ImGearPDFStream GetDataStream(
   ImGearPDEImageDataFlags options
)
public: ImGearPDFStream* GetDataStream(
   ImGearPDEImageDataFlags options
)
public:
ImGearPDFStream^ GetDataStream(
   ImGearPDEImageDataFlags options
)

Parameters

options
ImGearPDEImageDataFlags options. If the ENCODED flag is set, data is returned in encoded form. Otherwise, data is decoded.

Return Value

ImGearPDFStream class object.
Remarks
May only be called for XObject images.

The caller must dispose of the returned stream by calling its Dispose() method.

See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDFStream Class
ImGearPDEImageDataFlags Enumeration


GetDecodeArray Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetDecodeArray Method
Gets the decode array for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDecodeArray() As Integer()
'Usage

Dim instance As ImGearPDEImage
Dim value() As Integer

value = instance.GetDecodeArray()
public int[] GetDecodeArray()
public: int[]* GetDecodeArray();
public:
array<int>^ GetDecodeArray();

Return Value

Integer array.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetDictionary Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetDictionary Method
Gets the dictionary for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDEImage
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public new ImGearPDFBasDict GetDictionary()
public: new ImGearPDFBasDict* GetDictionary();
public:
new ImGearPDFBasDict^ GetDictionary();

Return Value

ImGearPDFBasDict class object.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetFilterArray Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetFilterArray Method
Gets the filter array for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFilterArray() As ImGearPDEFilterArray
'Usage

Dim instance As ImGearPDEImage
Dim value As ImGearPDEFilterArray

value = instance.GetFilterArray()
public ImGearPDEFilterArray GetFilterArray()
public: ImGearPDEFilterArray* GetFilterArray();
public:
ImGearPDEFilterArray^ GetFilterArray();

Return Value

ImGearPDEFilterArray class object.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEFilterArray Class


GetMatteArray Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetMatteArray Method
Gets the matte array for the image XObject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatteArray() As Integer()
'Usage

Dim instance As ImGearPDEImage
Dim value() As Integer

value = instance.GetMatteArray()
public int[] GetMatteArray()
public: int[]* GetMatteArray();
public:
array<int>^ GetMatteArray();

Return Value

Integer array.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


GetSoftMask Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : GetSoftMask Method
Gets the soft mask for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSoftMask() As ImGearPDEImage
'Usage

Dim instance As ImGearPDEImage
Dim value As ImGearPDEImage

value = instance.GetSoftMask()
public ImGearPDEImage GetSoftMask()
public: ImGearPDEImage* GetSoftMask();
public:
ImGearPDEImage^ GetSoftMask();

Return Value

ImGearPDEImage class object.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


SetColorMask Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetColorMask Method
Array of long values containing the color mask.
Sets the Mask entry from the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetColorMask( _
   ByVal mask() As Integer _
)
'Usage

Dim instance As ImGearPDEImage
Dim mask() As Integer

instance.SetColorMask(mask)
public void SetColorMask(
   int[] mask
)
public: void SetColorMask(
   int[]* mask
)
public:
void SetColorMask(
   array<int>^ mask
)

Parameters

mask
Array of long values containing the color mask.
Remarks
The mask entry is an array specifying a range of colors to be masked out. Samples in the image that fall within this range are not painted, allowing the existing background to show through. The effect is similar to that of the video technique known as chroma-key.

The value of the Mask entry is an array of 2n integers, [min1 max1 ... minn maxn], where n is the number of color components in the image's color space. Each integer must be in the range 0 to 2 in power of BitsPerComponent - 1, representing color values before decoding with the Decode array. An image sample is masked (not painted) if all of its color components before decoding, c1...cn, fall within the specified ranges.

See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


SetColorSpace Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetColorSpace Method
The color space to set.
Sets the color space object for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetColorSpace( _
   ByVal colorSpace As ImGearPDEColorSpace _
)
'Usage

Dim instance As ImGearPDEImage
Dim colorSpace As ImGearPDEColorSpace

instance.SetColorSpace(colorSpace)
public void SetColorSpace(
   ImGearPDEColorSpace colorSpace
)
public: void SetColorSpace(
   ImGearPDEColorSpace* colorSpace
)
public:
void SetColorSpace(
   ImGearPDEColorSpace^ colorSpace
)

Parameters

colorSpace
The color space to set.
Remarks
Null if image is an image mask.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEColorSpace Class


SetData Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetData Method
A set of ImGearPDEImageDataFlags options. If ENCODED is set, the data must be encoded for the current filters. If the ENCODED flag is not set, data is not encoded.
Image data.
Sets data for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetData( _
   ByVal options As ImGearPDEImageDataFlags, _
   ByVal data() As Byte _
)
'Usage

Dim instance As ImGearPDEImage
Dim options As ImGearPDEImageDataFlags
Dim data() As Byte

instance.SetData(options, data)
public void SetData(
   ImGearPDEImageDataFlags options,
   byte[] data
)
public: void SetData(
   ImGearPDEImageDataFlags options,
   byte[]* data
)
public:
void SetData(
   ImGearPDEImageDataFlags options,
   array<byte>^ data
)

Parameters

options
A set of ImGearPDEImageDataFlags options. If ENCODED is set, the data must be encoded for the current filters. If the ENCODED flag is not set, data is not encoded.
data
Image data.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEImageDataFlags Enumeration


SetDataStream Method (ImGearPDEImage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetDataStream Method
ImGearPDEImageDataFlags options. If the ENCODED flag is set, the stream must be encoded.
ImGearPDEFilterArray object. If not Null, is used to build the objects for the Filter, DecodeParms, and EncodeParms objects. If is Null, the existing Filter and DecodeParms are used. EncodeParms is set to DecodeParms if it exists.
Stream for the image data.
Sets a data stream for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDataStream( _
   ByVal options As ImGearPDEImageDataFlags, _
   ByVal filters As ImGearPDEFilterArray, _
   ByVal dataStream As ImGearPDFStream _
)
'Usage

Dim instance As ImGearPDEImage
Dim options As ImGearPDEImageDataFlags
Dim filters As ImGearPDEFilterArray
Dim dataStream As ImGearPDFStream

instance.SetDataStream(options, filters, dataStream)
public void SetDataStream(
   ImGearPDEImageDataFlags options,
   ImGearPDEFilterArray filters,
   ImGearPDFStream dataStream
)
public: void SetDataStream(
   ImGearPDEImageDataFlags options,
   ImGearPDEFilterArray* filters,
   ImGearPDFStream* dataStream
)
public:
void SetDataStream(
   ImGearPDEImageDataFlags options,
   ImGearPDEFilterArray^ filters,
   ImGearPDFStream^ dataStream
)

Parameters

options
ImGearPDEImageDataFlags options. If the ENCODED flag is set, the stream must be encoded.
filters
ImGearPDEFilterArray object. If not Null, is used to build the objects for the Filter, DecodeParms, and EncodeParms objects. If is Null, the existing Filter and DecodeParms are used. EncodeParms is set to DecodeParms if it exists.
dataStream
Stream for the image data.
Remarks
Can only be used for XObject images.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members
ImGearPDEImageDataFlags Enumeration
ImGearPDEFilterArray Class
ImGearPDFStream Class


SetDecodeArray Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetDecodeArray Method
The decode array to set.
Sets the decode array for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDecodeArray( _
   ByVal decodeArray() As Integer _
)
'Usage

Dim instance As ImGearPDEImage
Dim decodeArray() As Integer

instance.SetDecodeArray(decodeArray)
public void SetDecodeArray(
   int[] decodeArray
)
public: void SetDecodeArray(
   int[]* decodeArray
)
public:
void SetDecodeArray(
   array<int>^ decodeArray
)

Parameters

decodeArray
The decode array to set.
Remarks
Normally, the decode array is accessed through the decode field in the ImGearPDEImageAttrs. However, this method defines a decode array to handle images with a color space that has more than 4 components.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


SetMatteArray Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetMatteArray Method
The matte array to set.
Sets the matte array for the image XObject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatteArray( _
   ByVal matteArray() As Integer _
)
'Usage

Dim instance As ImGearPDEImage
Dim matteArray() As Integer

instance.SetMatteArray(matteArray)
public void SetMatteArray(
   int[] matteArray
)
public: void SetMatteArray(
   int[]* matteArray
)
public:
void SetMatteArray(
   array<int>^ matteArray
)

Parameters

matteArray
The matte array to set.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


SetSoftMask Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetSoftMask Method
Sets the soft mask for an image.
Overload List
Overload | Description
SetSoftMask | Sets the soft mask for an image.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


SetSoftMask(ImGearPDEImage) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : SetSoftMask(ImGearPDEImage) Method
The soft mask to set.
Sets the soft mask for an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSoftMask( _
   ByVal softMask As ImGearPDEImage _
)
'Usage

Dim instance As ImGearPDEImage
Dim softMask As ImGearPDEImage

instance.SetSoftMask(softMask)
public void SetSoftMask(
   ImGearPDEImage softMask
)
public: void SetSoftMask(
   ImGearPDEImage* softMask
)
public:
void SetSoftMask(
   ImGearPDEImage^ softMask
)

Parameters

softMask
The soft mask to set.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


%%PageItemTitle%% $$Properties$$

ImGearPDEImage Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImage Class

For a list of all members of this type, see ImGearPDEImage members.

Public Properties
 | Name | Description
Public Property | DataLength | Gets a number of bytes of image data, specified by the width, height, bits per component, and color space of the image.
Public Property | EncodedLength | Gets a length of the encoded data, if the data is encoded, that is, IsDataEncoded is True.
Public Property | HasSoftMask | Gets a value indicating whether the soft mask exists.
Public Property | IsDataEncoded | Gets a value indicating whether GetData returns encoded data.
Public Property | IsXObject | Gets a value indicating whether the image is an XObject image.
Top
See Also

Reference

ImGearPDEImage Class
ImageGear.Formats.PDF Namespace


DataLength Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : DataLength Property
Gets a number of bytes of image data, specified by the width, height, bits per component, and color space of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DataLength As Integer
'Usage

Dim instance As ImGearPDEImage
Dim value As Integer

value = instance.DataLength
public int DataLength {get;}
public: __property int get_DataLength();
public:
property int DataLength {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


EncodedLength Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : EncodedLength Property
Gets a length of the encoded data, if the data is encoded, that is, IsDataEncoded is True.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property EncodedLength As Integer
'Usage

Dim instance As ImGearPDEImage
Dim value As Integer

value = instance.EncodedLength
public int EncodedLength {get;}
public: __property int get_EncodedLength();
public:
property int EncodedLength {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


HasSoftMask Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : HasSoftMask Property
Gets a value indicating whether the soft mask exists.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasSoftMask As Boolean
'Usage

Dim instance As ImGearPDEImage
Dim value As Boolean

value = instance.HasSoftMask
public bool HasSoftMask {get;}
public: __property bool get_HasSoftMask();
public:
property bool HasSoftMask {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


IsDataEncoded Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : IsDataEncoded Property
Gets a value indicating whether GetData returns encoded data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsDataEncoded As Boolean
'Usage

Dim instance As ImGearPDEImage
Dim value As Boolean

value = instance.IsDataEncoded
public bool IsDataEncoded {get;}
public: __property bool get_IsDataEncoded();
public:
property bool IsDataEncoded {
   bool get();
}

Property Value

Boolean value.
Remarks
Returns false for XObject images.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


IsXObject Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImage Class : IsXObject Property
Gets a value indicating whether the image is an XObject image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsXObject As Boolean
'Usage

Dim instance As ImGearPDEImage
Dim value As Boolean

value = instance.IsXObject
public bool IsXObject {get;}
public: __property bool get_IsXObject();
public:
property bool IsXObject {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEImage Class
ImGearPDEImage Members


%%PageItemTitle%%

ImGearPDEImageAttrs Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageAttrs Class
Provides attributes of a PDE Image object.
Object Model
ImGearPDEImageAttrs ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEImageAttrs
'Usage

Dim instance As ImGearPDEImageAttrs
public sealed class ImGearPDEImageAttrs
public __gc __sealed class ImGearPDEImageAttrs
public ref class ImGearPDEImageAttrs sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEImageAttrs

See Also

Reference

ImGearPDEImageAttrs Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEImageAttrs Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageAttrs Class

The following tables list the members exposed by ImGearPDEImageAttrs.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEImageAttrs Constructor | Initializes a new instance of the ImGearPDEImageAttrs class.
Top
Public Fields
 | Name | Description
Public Field | BitsPerComponent | Number of bits used to represent each color component in the image.
Public Field | Decode | Decode array.
Public Field | Flags | Indicates image attributes.
Public Field | Height | Height of the image, corresponding to the Height key in the image dictionary.
Public Field | Width | Width of the image, corresponding to the Width key in the image dictionary.
Top
Public Properties
 | Name | Description
Public Property | Intent | Gets or sets the color rendering intent, corresponding to the Intent key in the image dictionary.
Top
See Also

Reference

ImGearPDEImageAttrs Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEImageAttrs Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : ImGearPDEImageAttrs Constructor
Initializes a new instance of the ImGearPDEImageAttrs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEImageAttrs()
public ImGearPDEImageAttrs()
public: ImGearPDEImageAttrs();
public:
ImGearPDEImageAttrs();

Return Value

The new instance of ImGearPDEImageAttrs class object.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members


%%PageItemTitle%% $$Properties$$

ImGearPDEImageAttrs Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageAttrs Class

For a list of all members of this type, see ImGearPDEImageAttrs members.

Public Properties
 | Name | Description
Public Property | Intent | Gets or sets the color rendering intent, corresponding to the Intent key in the image dictionary.
Top
See Also

Reference

ImGearPDEImageAttrs Class
ImageGear.Formats.PDF Namespace


Intent Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : Intent Property
Gets or sets the color rendering intent, corresponding to the Intent key in the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Intent As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value As ImGearPDFAtom

instance.Intent = value

value = instance.Intent
public ImGearPDFAtom Intent {get; set;}
public: __property ImGearPDFAtom* get_Intent();
public: __property void set_Intent(
   ImGearPDFAtom* value
);
public:
property ImGearPDFAtom^ Intent {
   ImGearPDFAtom^ get();
   void set (    ImGearPDFAtom^ value);
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members
ImGearPDFAtom Class


%%PageItemTitle%% $$Fields$$

ImGearPDEImageAttrs Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageAttrs Class

For a list of all members of this type, see ImGearPDEImageAttrs members.

Public Fields
 | Name | Description
Public Field | BitsPerComponent | Number of bits used to represent each color component in the image.
Public Field | Decode | Decode array.
Public Field | Flags | Indicates image attributes.
Public Field | Height | Height of the image, corresponding to the Height key in the image dictionary.
Public Field | Width | Width of the image, corresponding to the Width key in the image dictionary.
Top
See Also

Reference

ImGearPDEImageAttrs Class
ImageGear.Formats.PDF Namespace


BitsPerComponent Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : BitsPerComponent Field
Number of bits used to represent each color component in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BitsPerComponent As Integer
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value As Integer

value = instance.BitsPerComponent

instance.BitsPerComponent = value
public int BitsPerComponent
public: int BitsPerComponent
public:
int BitsPerComponent

Field Value

Integer value.
Remarks
Corresponds to the BitsPerComponent key in the image dictionary. The default value is 0.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members


Decode Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : Decode Field
Decode array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<MarshalAsAttribute(UnmanagedType.Bool Or  _
    UnmanagedType.U1 Or  _
    UnmanagedType.U2 Or  _
    UnmanagedType.U4 Or  _
    UnmanagedType.U8 Or  _
    UnmanagedType.R8 Or  _
    UnmanagedType.LPStr Or  _
    UnmanagedType.LPTStr Or  _
    UnmanagedType.IDispatch Or  _
    UnmanagedType.Interface Or  _
    UnmanagedType.ByValArray)>
Public Decode As Integer()
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value() As Integer

value = instance.Decode

instance.Decode = value
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public int[] Decode
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public: int[]* Decode
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.U1 |
    UnmanagedType.U2 |
    UnmanagedType.U4 |
    UnmanagedType.U8 |
    UnmanagedType.R8 |
    UnmanagedType.LPStr |
    UnmanagedType.LPTStr |
    UnmanagedType.IDispatch |
    UnmanagedType.Interface |
    UnmanagedType.ByValArray)]
public:
array<int>^ Decode

Field Value

Array of integer values.
Remarks
An array of numbers specifying the mapping from sample values in the image to values appropriate for the current color space. These values correspond to the Decode key in the image dictionary. The default value is {0, 0, 0, 0, 0, 0, 0, 0}.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members


Flags Field (ImGearPDEImageAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : Flags Field
Indicates image attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Flags As ImGearPDEImageAttrFlags
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value As ImGearPDEImageAttrFlags

value = instance.Flags

instance.Flags = value
public ImGearPDEImageAttrFlags Flags
public: ImGearPDEImageAttrFlags Flags
public:
ImGearPDEImageAttrFlags Flags

Field Value

Combination of ImGearPDEImageAttrFlags enumeration values.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members
ImGearPDEImageAttrFlags Enumeration


Height Field (ImGearPDEImageAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : Height Field
Height of the image, corresponding to the Height key in the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members


Width Field (ImGearPDEImageAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEImageAttrs Class : Width Field
Width of the image, corresponding to the Width key in the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearPDEImageAttrs
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEImageAttrs Class
ImGearPDEImageAttrs Members


%%PageItemTitle%%

ImGearPDEObject Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEObject Class
Represents base class for all PDE objects.
Object Model
ImGearPDEObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPDEObject
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDEObject
public abstract class ImGearPDEObject : ImGearPDFObject
public __gc abstract class ImGearPDEObject : public ImGearPDFObject
public ref class ImGearPDEObject abstract : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEColorSpace
ImageGear.Formats.PDF.ImGearPDEContent
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEFont
ImageGear.Formats.PDF.ImGearPDFSysEncoding
ImageGear.Formats.PDF.ImGearPDFSysFont

See Also

Reference

ImGearPDEObject Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEObject Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEObject Class

The following tables list the members exposed by ImGearPDEObject.

Public Properties
 | Name | Description
Public Property | Type | Gets a type of the object.
Top
See Also

Reference

ImGearPDEObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDEObject Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEObject Class

For a list of all members of this type, see ImGearPDEObject members.

Public Properties
 | Name | Description
Public Property | Type | Gets a type of the object.
Top
See Also

Reference

ImGearPDEObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEObject Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEObject Class

For a list of all members of this type, see ImGearPDEObject members.

See Also

Reference

ImGearPDEObject Class
ImageGear.Formats.PDF Namespace


Type Property (ImGearPDEObject)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEObject Class : Type Property
Gets a type of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearPDEType
'Usage

Dim instance As ImGearPDEObject
Dim value As ImGearPDEType

value = instance.Type
public ImGearPDEType Type {get;}
public: __property ImGearPDEType get_Type();
public:
property ImGearPDEType Type {
   ImGearPDEType get();
}

Property Value

ImGearPDEType enumeration value.
See Also

Reference

ImGearPDEObject Class
ImGearPDEObject Members
ImGearPDEType Enumeration


%%PageItemTitle%%

ImGearPDEPath Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPath Class
Represents a path.
Object Model
ImGearPDEPath Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEPath
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEPath
public sealed class ImGearPDEPath : ImGearPDEElement
public __gc __sealed class ImGearPDEPath : public ImGearPDEElement
public ref class ImGearPDEPath sealed : public ImGearPDEElement
Remarks
Path objects can be stroked, filled, and/or serve as a clipping path.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEPath

See Also

Reference

ImGearPDEPath Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEPath Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPath Class

The following tables list the members exposed by ImGearPDEPath.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEPath Constructor | Initializes a new instance of the ImGearPDEPath class.
Top
Public Properties
 | Name | Description
Public Property | PaintOp | Gets or sets the fill and stroke attributes of a path.
Top
Public Methods
 | Name | Description
Public Method | AddSegment | Adds a segment to a path.
Public Method | GetData | Gets the path data.
Public Method | SetData | Sets new path data for a path element.
Top
See Also

Reference

ImGearPDEPath Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPath Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : ImGearPDEPath Constructor
Initializes a new instance of the ImGearPDEPath class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEPath()
public ImGearPDEPath()
public: ImGearPDEPath();
public:
ImGearPDEPath();

Return Value

The new instance of ImGearPDEPath class object.
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members


%%PageItemTitle%% $$Methods$$

ImGearPDEPath Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPath Class

For a list of all members of this type, see ImGearPDEPath members.

Public Methods
 | Name | Description
Public Method | AddSegment | Adds a segment to a path.
Public Method | GetData | Gets the path data.
Public Method | SetData | Sets new path data for a path element.
Top
See Also

Reference

ImGearPDEPath Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPath Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : ImGearPDEPath Constructor
Overload List
Overload | Description
ImGearPDEPath Constructor | Initializes a new instance of the ImGearPDEPath class.
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members


AddSegment Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : AddSegment Method
An ImGearPDEPathElementType value indicating the type of path to add.
X-coordinate of first point.
Y-coordinate of first point.
X-coordinate of second point.
Y-coordinate of second point.
X-coordinate of third point.
Y-coordinate of third point.
Adds a segment to a path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddSegment( _
   ByVal segmentType As ImGearPDEPathElementType, _
   ByVal point1X As Integer, _
   ByVal point1Y As Integer, _
   ByVal point2X As Integer, _
   ByVal point2Y As Integer, _
   ByVal point3X As Integer, _
   ByVal point3Y As Integer _
)
'Usage

Dim instance As ImGearPDEPath
Dim segmentType As ImGearPDEPathElementType
Dim point1X As Integer
Dim point1Y As Integer
Dim point2X As Integer
Dim point2Y As Integer
Dim point3X As Integer
Dim point3Y As Integer

instance.AddSegment(segmentType, point1X, point1Y, point2X, point2Y, point3X, point3Y)
public void AddSegment(
   ImGearPDEPathElementType segmentType,
   int point1X,
   int point1Y,
   int point2X,
   int point2Y,
   int point3X,
   int point3Y
)
public: void AddSegment(
   ImGearPDEPathElementType segmentType,
   int point1X,
   int point1Y,
   int point2X,
   int point2Y,
   int point3X,
   int point3Y
)
public:
void AddSegment(
   ImGearPDEPathElementType segmentType,
   int point1X,
   int point1Y,
   int point2X,
   int point2Y,
   int point3X,
   int point3Y
)

Parameters

segmentType
An ImGearPDEPathElementType value indicating the type of path to add.
point1X
X-coordinate of first point.
point1Y
Y-coordinate of first point.
point2X
X-coordinate of second point.
point2Y
Y-coordinate of second point.
point3X
X-coordinate of third point.
point3Y
Y-coordinate of third point.
Remarks
The number of values used depends upon segmentType:
  • MOVE_TO: point1X, point1Y
  • LINE_TO: point1X, point1Y
  • CURVE_TO: point1X, point1Y, point2X, point2Y, point3X, point3Y
  • CURVE_TO_V: point1X, point1Y, point2X, point2Y
  • CURVE_TO_Y: point1X, point1Y, point2X, point2Y
  • RECT: point1X, point1Y, point2X (width), point2Y (height)
  • CLOSE_PATH: None
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members
ImGearPDEPathElementType Enumeration


GetData Method (ImGearPDEPath)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : GetData Method
Gets the path data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetData() As Integer()
'Usage

Dim instance As ImGearPDEPath
Dim value() As Integer

value = instance.GetData()
public int[] GetData()
public: int[]* GetData();
public:
array<int>^ GetData();

Return Value

Integer array that contains a variable-sized array of path operators and operands. The format is a 32-bit operator followed by 0 to 3 ImGearPDFFixedPoint values, depending on the operator. Opcodes are codes for moveto, lineto, curveto, rect, or closepath operators; operands are ImGearPDFFixedPoint values. Returns raw path data. If you want the points in page coordinates, concatenate the path data points with the PDE Element matrix obtained from ImGearPDEElement.GetMatrix.
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members


SetData Method (ImGearPDEPath)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : SetData Method
Integer array, which is a variable-sized array of path operators and operands. The format is a 32-bit operator followed by 0 to 3 ImGearPDFFixedPoint values, depending on the operator. Operators are codes for moveto, lineto, curveto, rect, or closepath operators and must be one of ImGearPDEPathElementType. Operands are ImGearPDFFixedPoint values.
Sets new path data for a path element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetData( _
   ByVal data() As Integer _
)
'Usage

Dim instance As ImGearPDEPath
Dim data() As Integer

instance.SetData(data)
public void SetData(
   int[] data
)
public: void SetData(
   int[]* data
)
public:
void SetData(
   array<int>^ data
)

Parameters

data
Integer array, which is a variable-sized array of path operators and operands. The format is a 32-bit operator followed by 0 to 3 ImGearPDFFixedPoint values, depending on the operator. Operators are codes for moveto, lineto, curveto, rect, or closepath operators and must be one of ImGearPDEPathElementType. Operands are ImGearPDFFixedPoint values.
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members


%%PageItemTitle%% $$Properties$$

ImGearPDEPath Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPath Class

For a list of all members of this type, see ImGearPDEPath members.

Public Properties
 | Name | Description
Public Property | PaintOp | Gets or sets the fill and stroke attributes of a path.
Top
See Also

Reference

ImGearPDEPath Class
ImageGear.Formats.PDF Namespace


PaintOp Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPath Class : PaintOp Property
Gets or sets the fill and stroke attributes of a path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaintOp As ImGearPDEPathOpFlags
'Usage

Dim instance As ImGearPDEPath
Dim value As ImGearPDEPathOpFlags

instance.PaintOp = value

value = instance.PaintOp
public ImGearPDEPathOpFlags PaintOp {get; set;}
public: __property ImGearPDEPathOpFlags get_PaintOp();
public: __property void set_PaintOp(
   ImGearPDEPathOpFlags value
);
public:
property ImGearPDEPathOpFlags PaintOp {
   ImGearPDEPathOpFlags get();
   void set (    ImGearPDEPathOpFlags value);
}

Property Value

ImGearPDEPathOpFlags enumeration value.
See Also

Reference

ImGearPDEPath Class
ImGearPDEPath Members
ImGearPDEPathOpFlags Enumeration


%%PageItemTitle%%

ImGearPDEPlace Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPlace Class
Represents an element that marks a place on a page in a PDF file.
Object Model
ImGearPDEPlace ClassImGearPDFBasDict ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEPlace
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEPlace
public sealed class ImGearPDEPlace : ImGearPDEElement
public __gc __sealed class ImGearPDEPlace : public ImGearPDEElement
public ref class ImGearPDEPlace sealed : public ImGearPDEElement
Remarks
In a PDF file, a place is represented by the MP or DP Marked Content operators.

Marked content is useful for adding structure information to a PDF file. For instance, a drawing program may want to mark a point with information, such as the start of a path of a certain type. Marked content provides a way to retain this information in the PDF file. A DP operator functions the same as the MP operator and, in addition, allows a property list dictionary to be associated with a place.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEPlace

See Also

Reference

ImGearPDEPlace Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEPlace Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPlace Class

The following tables list the members exposed by ImGearPDEPlace.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEPlace Constructor | Initializes a new instance of the ImGearPDEPlace class.
Top
Public Properties
 | Name | Description
Public Property | IsDictionaryInline | Gets a value indicating whether the dictionary is inline.
Top
Public Methods
 | Name | Description
Public Method | GetDictionary | Gets marked Content dictionary for a place.
Public Method | GetMCTag | Gets Marked Content tag for a place.
Public Method | SetDictionary | Sets the Marked Content dictionary for a place.
Public Method | SetMCTag | Sets Marked Content tag for a place.
Top
See Also

Reference

ImGearPDEPlace Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPlace Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : ImGearPDEPlace Constructor
The tag name for the place. It must not contain any white space characters (for example, spaces or tabs).
An optional Marked Content dictionary associated with the place.
If true, it emits the place's dictionary into the content stream inline. If false, then the dictionary is emitted outside of the content stream and referenced by name.
Initializes a new instance of the ImGearPDEPlace class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As ImGearPDFAtom, _
   ByVal dictionary As ImGearPDFBasObj, _
   ByVal isInline As Boolean _
)
'Usage

Dim tag As ImGearPDFAtom
Dim dictionary As ImGearPDFBasObj
Dim isInline As Boolean

Dim instance As New ImGearPDEPlace(tag, dictionary, isInline)
public ImGearPDEPlace(
   ImGearPDFAtom tag,
   ImGearPDFBasObj dictionary,
   bool isInline
)
public: ImGearPDEPlace(
   ImGearPDFAtom* tag,
   ImGearPDFBasObj* dictionary,
   bool isInline
)
public:
ImGearPDEPlace(
   ImGearPDFAtom^ tag,
   ImGearPDFBasObj^ dictionary,
   bool isInline
)

Parameters

tag
The tag name for the place. It must not contain any white space characters (for example, spaces or tabs).
dictionary
An optional Marked Content dictionary associated with the place.
isInline
If true, it emits the place's dictionary into the content stream inline. If false, then the dictionary is emitted outside of the content stream and referenced by name.

Return Value

The new instance of ImGearPDEPlace class object.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members


%%PageItemTitle%% $$Methods$$

ImGearPDEPlace Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPlace Class

For a list of all members of this type, see ImGearPDEPlace members.

Public Methods
 | Name | Description
Public Method | GetDictionary | Gets marked Content dictionary for a place.
Public Method | GetMCTag | Gets Marked Content tag for a place.
Public Method | SetDictionary | Sets the Marked Content dictionary for a place.
Public Method | SetMCTag | Sets Marked Content tag for a place.
Top
See Also

Reference

ImGearPDEPlace Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPlace Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : ImGearPDEPlace Constructor
Overload List
Overload | Description
ImGearPDEPlace Constructor | Initializes a new instance of the ImGearPDEPlace class.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members


GetDictionary Method (ImGearPDEPlace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : GetDictionary Method
Gets marked Content dictionary for a place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDEPlace
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public new ImGearPDFBasDict GetDictionary()
public: new ImGearPDFBasDict* GetDictionary();
public:
new ImGearPDFBasDict^ GetDictionary();

Return Value

ImGearPDFBasDict class object.
Remarks
Null if the place has no Marked Content dictionary.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members
ImGearPDFBasDict Class


GetMCTag Method (ImGearPDEPlace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : GetMCTag Method
Gets Marked Content tag for a place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMCTag() As ImGearPDFAtom
'Usage

Dim instance As ImGearPDEPlace
Dim value As ImGearPDFAtom

value = instance.GetMCTag()
public ImGearPDFAtom GetMCTag()
public: ImGearPDFAtom* GetMCTag();
public:
ImGearPDFAtom^ GetMCTag();

Return Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members
ImGearPDFAtom Class


SetDictionary Method (ImGearPDEPlace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : SetDictionary Method
Marked Content dictionary for a place.
If True, the dictionary is emitted inline.
Sets the Marked Content dictionary for a place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDictionary( _
   ByVal dictionary As ImGearPDFBasDict, _
   ByVal isInline As Boolean _
)
'Usage

Dim instance As ImGearPDEPlace
Dim dictionary As ImGearPDFBasDict
Dim isInline As Boolean

instance.SetDictionary(dictionary, isInline)
public void SetDictionary(
   ImGearPDFBasDict dictionary,
   bool isInline
)
public: void SetDictionary(
   ImGearPDFBasDict* dictionary,
   bool isInline
)
public:
void SetDictionary(
   ImGearPDFBasDict^ dictionary,
   bool isInline
)

Parameters

dictionary
Marked Content dictionary for a place.
isInline
If True, the dictionary is emitted inline.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members
ImGearPDFBasDict Class


SetMCTag Method (ImGearPDEPlace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : SetMCTag Method
Marked Content tag for a place.
Sets Marked Content tag for a place.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMCTag( _
   ByVal tag As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDEPlace
Dim tag As ImGearPDFAtom

instance.SetMCTag(tag)
public void SetMCTag(
   ImGearPDFAtom tag
)
public: void SetMCTag(
   ImGearPDFAtom* tag
)
public:
void SetMCTag(
   ImGearPDFAtom^ tag
)

Parameters

tag
Marked Content tag for a place.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members
ImGearPDFAtom Class


%%PageItemTitle%% $$Properties$$

ImGearPDEPlace Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPlace Class

For a list of all members of this type, see ImGearPDEPlace members.

Public Properties
 | Name | Description
Public Property | IsDictionaryInline | Gets a value indicating whether the dictionary is inline.
Top
See Also

Reference

ImGearPDEPlace Class
ImageGear.Formats.PDF Namespace


IsDictionaryInline Property (ImGearPDEPlace)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPlace Class : IsDictionaryInline Property
Gets a value indicating whether the dictionary is inline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsDictionaryInline As Boolean
'Usage

Dim instance As ImGearPDEPlace
Dim value As Boolean

value = instance.IsDictionaryInline
public bool IsDictionaryInline {get;}
public: __property bool get_IsDictionaryInline();
public:
property bool IsDictionaryInline {
   bool get();
}

Property Value

Boolean value.
Remarks
Undefined if the place has no Marked Content dictionary.
See Also

Reference

ImGearPDEPlace Class
ImGearPDEPlace Members


%%PageItemTitle%%

ImGearPDEPostScript Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPostScript Class
Represents in-line or XObject pass-through PostScript object.
Object Model
ImGearPDEPostScript ClassImGearPDEPSAttrs ClassImGearPDFStream Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEPostScript
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEPostScript
public sealed class ImGearPDEPostScript : ImGearPDEElement
public __gc __sealed class ImGearPDEPostScript : public ImGearPDEElement
public ref class ImGearPDEPostScript sealed : public ImGearPDEElement
Remarks
XObject PostScripts are listed in page XObject resources.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEPostScript

See Also

Reference

ImGearPDEPostScript Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEPostScript Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPostScript Class

The following tables list the members exposed by ImGearPDEPostScript.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEPostScript Constructor | Initializes a new instance of the ImGearPDEPostScript class.
Top
Public Methods
 | Name | Description
Public Method | GetAttributes | Gets postscript attributes.
Public Method | GetData | Gets all or part of the image data.
Public Method | GetDataStream | Gets a stream for the data.
Public Method | SetData | Sets the data for the postscript.
Public Method | SetDataStream | Sets a stream for the data.
Top
See Also

Reference

ImGearPDEPostScript Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDEPostScript Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPostScript Class

For a list of all members of this type, see ImGearPDEPostScript members.

See Also

Reference

ImGearPDEPostScript Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPostScript Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : ImGearPDEPostScript Constructor
ImGearPDEPSAttrs object containing attributes.
PostScript data stream. May be null.
PostScript data. May be null.
Initializes a new instance of the ImGearPDEPostScript class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal attributes As ImGearPDEPSAttrs, _
   ByVal dataStream As ImGearPDFStream, _
   ByVal data() As Byte _
)
'Usage

Dim attributes As ImGearPDEPSAttrs
Dim dataStream As ImGearPDFStream
Dim data() As Byte

Dim instance As New ImGearPDEPostScript(attributes, dataStream, data)
public ImGearPDEPostScript(
   ImGearPDEPSAttrs attributes,
   ImGearPDFStream dataStream,
   byte[] data
)
public: ImGearPDEPostScript(
   ImGearPDEPSAttrs* attributes,
   ImGearPDFStream* dataStream,
   byte[]* data
)
public:
ImGearPDEPostScript(
   ImGearPDEPSAttrs^ attributes,
   ImGearPDFStream^ dataStream,
   array<byte>^ data
)

Parameters

attributes
ImGearPDEPSAttrs object containing attributes.
dataStream
PostScript data stream. May be null.
data
PostScript data. May be null.

Return Value

The new instance of ImGearPDEPostScript class object.
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members


%%PageItemTitle%% $$Methods$$

ImGearPDEPostScript Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPostScript Class

For a list of all members of this type, see ImGearPDEPostScript members.

Public Methods
 | Name | Description
Public Method | GetAttributes | Gets postscript attributes.
Public Method | GetData | Gets all or part of the image data.
Public Method | GetDataStream | Gets a stream for the data.
Public Method | SetData | Sets the data for the postscript.
Public Method | SetDataStream | Sets a stream for the data.
Top
See Also

Reference

ImGearPDEPostScript Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPostScript Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : ImGearPDEPostScript Constructor
Overload List
Overload | Description
ImGearPDEPostScript Constructor | Initializes a new instance of the ImGearPDEPostScript class.
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members


GetAttributes Method (ImGearPDEPostScript)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : GetAttributes Method
Gets postscript attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttributes() As ImGearPDEPSAttrs
'Usage

Dim instance As ImGearPDEPostScript
Dim value As ImGearPDEPSAttrs

value = instance.GetAttributes()
public ImGearPDEPSAttrs GetAttributes()
public: ImGearPDEPSAttrs* GetAttributes();
public:
ImGearPDEPSAttrs^ GetAttributes();

Return Value

ImGearPDEPSAttrs class value.
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members
ImGearPDEPSAttrs Class


GetData Method (ImGearPDEPostScript)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : GetData Method
Offset into the source data at which to start filling buffer.
Gets all or part of the image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetData( _
   ByVal offset As Integer _
) As Byte()
'Usage

Dim instance As ImGearPDEPostScript
Dim offset As Integer
Dim value() As Byte

value = instance.GetData(offset)
public byte[] GetData(
   int offset
)
public: byte[]* GetData(
   int offset
)
public:
array<byte>^ GetData(
   int offset
)

Parameters

offset
Offset into the source data at which to start filling buffer.

Return Value

Integer array.
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members


GetDataStream Method (ImGearPDEPostScript)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : GetDataStream Method
Gets a stream for the data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDataStream() As ImGearPDFStream
'Usage

Dim instance As ImGearPDEPostScript
Dim value As ImGearPDFStream

value = instance.GetDataStream()
public ImGearPDFStream GetDataStream()
public: ImGearPDFStream* GetDataStream();
public:
ImGearPDFStream^ GetDataStream();

Return Value

ImGearPDFStream class object.
Remarks
The data in the stream is decoded (no filters).
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members
ImGearPDFStream Class


SetData Method (ImGearPDEPostScript)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : SetData Method
The data to be set.
Sets the data for the postscript.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetData( _
   ByVal data() As Byte _
)
'Usage

Dim instance As ImGearPDEPostScript
Dim data() As Byte

instance.SetData(data)
public void SetData(
   byte[] data
)
public: void SetData(
   byte[]* data
)
public:
void SetData(
   array<byte>^ data
)

Parameters

data
The data to be set.
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members


SetDataStream Method (ImGearPDEPostScript)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPostScript Class : SetDataStream Method
Stream for the data.
Sets a stream for the data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDataStream( _
   ByVal dataStream As ImGearPDFStream _
)
'Usage

Dim instance As ImGearPDEPostScript
Dim dataStream As ImGearPDFStream

instance.SetDataStream(dataStream)
public void SetDataStream(
   ImGearPDFStream dataStream
)
public: void SetDataStream(
   ImGearPDFStream* dataStream
)
public:
void SetDataStream(
   ImGearPDFStream^ dataStream
)

Parameters

dataStream
Stream for the data.
Remarks
The data must be un-encoded (no filters).
See Also

Reference

ImGearPDEPostScript Class
ImGearPDEPostScript Members
ImGearPDFStream Class


%%PageItemTitle%%

ImGearPDEPSAttrs Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPSAttrs Class
Provides attributes of a PDE PostScript object.
Object Model
ImGearPDEPSAttrs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEPSAttrs
'Usage

Dim instance As ImGearPDEPSAttrs
public sealed class ImGearPDEPSAttrs
public __gc __sealed class ImGearPDEPSAttrs
public ref class ImGearPDEPSAttrs sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEPSAttrs

See Also

Reference

ImGearPDEPSAttrs Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEPSAttrs Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPSAttrs Class

The following tables list the members exposed by ImGearPDEPSAttrs.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEPSAttrs Constructor | Initializes a new instance of the ImGearPDEPSAttrs class.
Top
Public Fields
 | Name | Description
Public Field | Flags | Flags for PostScript.
Top
See Also

Reference

ImGearPDEPSAttrs Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPSAttrs Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPSAttrs Class : ImGearPDEPSAttrs Constructor
Initializes a new instance of the ImGearPDEPSAttrs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEPSAttrs()
public ImGearPDEPSAttrs()
public: ImGearPDEPSAttrs();
public:
ImGearPDEPSAttrs();
See Also

Reference

ImGearPDEPSAttrs Class
ImGearPDEPSAttrs Members


%%PageItemTitle%% $$Fields$$

ImGearPDEPSAttrs Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPSAttrs Class

For a list of all members of this type, see ImGearPDEPSAttrs members.

Public Fields
 | Name | Description
Public Field | Flags | Flags for PostScript.
Top
See Also

Reference

ImGearPDEPSAttrs Class
ImageGear.Formats.PDF Namespace


Flags Field (ImGearPDEPSAttrs)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEPSAttrs Class : Flags Field
Flags for PostScript.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Flags As ImGearPDEPSAttrFlags
'Usage

Dim instance As ImGearPDEPSAttrs
Dim value As ImGearPDEPSAttrFlags

value = instance.Flags

instance.Flags = value
public ImGearPDEPSAttrFlags Flags
public: ImGearPDEPSAttrFlags Flags
public:
ImGearPDEPSAttrFlags Flags

Field Value

ImGearPDEPSAttrFlags enumeration value.
Remarks
The default value is ImGearPDEPSAttrFlags.INLINE.
See Also

Reference

ImGearPDEPSAttrs Class
ImGearPDEPSAttrs Members
ImGearPDEPSAttrFlags Enumeration


%%PageItemTitle%%

ImGearPDEShading Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEShading Class
Represents a smooth shading object.
Object Model
ImGearPDEShading ClassImGearPDFBasDict Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEShading
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEShading
public sealed class ImGearPDEShading : ImGearPDEElement
public __gc __sealed class ImGearPDEShading : public ImGearPDEElement
public ref class ImGearPDEShading sealed : public ImGearPDEElement
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEShading

See Also

Reference

ImGearPDEShading Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEShading Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEShading Class

The following tables list the members exposed by ImGearPDEShading.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEShading Constructor | Initializes a new instance of the ImGearPDEShading class.
Top
Public Methods
 | Name | Description
Public Method | GetDictionary | This method gets dictionary for a shading.
Top
See Also

Reference

ImGearPDEShading Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDEShading Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEShading Class

For a list of all members of this type, see ImGearPDEShading members.

See Also

Reference

ImGearPDEShading Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEShading Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEShading Class : ImGearPDEShading Constructor
The shading dictionary.
The location and transformation matrix of the shading object.
Initializes a new instance of the ImGearPDEShading class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dictionary As ImGearPDFBasObj, _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim dictionary As ImGearPDFBasObj
Dim matrix As ImGearPDFFixedMatrix

Dim instance As New ImGearPDEShading(dictionary, matrix)
public ImGearPDEShading(
   ImGearPDFBasObj dictionary,
   ImGearPDFFixedMatrix matrix
)
public: ImGearPDEShading(
   ImGearPDFBasObj* dictionary,
   ImGearPDFFixedMatrix* matrix
)
public:
ImGearPDEShading(
   ImGearPDFBasObj^ dictionary,
   ImGearPDFFixedMatrix^ matrix
)

Parameters

dictionary
The shading dictionary.
matrix
The location and transformation matrix of the shading object.

Return Value

The new instance of ImGearPDEShading class object.
See Also

Reference

ImGearPDEShading Class
ImGearPDEShading Members


%%PageItemTitle%% $$Methods$$

ImGearPDEShading Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEShading Class

For a list of all members of this type, see ImGearPDEShading members.

Public Methods
 | Name | Description
Public Method | GetDictionary | This method gets dictionary for a shading.
Top
See Also

Reference

ImGearPDEShading Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEShading Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEShading Class : ImGearPDEShading Constructor
Overload List
Overload | Description
ImGearPDEShading Constructor | Initializes a new instance of the ImGearPDEShading class.
See Also

Reference

ImGearPDEShading Class
ImGearPDEShading Members


GetDictionary Method (ImGearPDEShading)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEShading Class : GetDictionary Method
This method gets dictionary for a shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDEShading
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public new ImGearPDFBasDict GetDictionary()
public: new ImGearPDFBasDict* GetDictionary();
public:
new ImGearPDFBasDict^ GetDictionary();

Return Value

ImGearPDFBasDict class object.
See Also

Reference

ImGearPDEShading Class
ImGearPDEShading Members
ImGearPDFBasDict Class


%%PageItemTitle%%

ImGearPDESoftMask Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESoftMask Class
Represents an object for creating and manipulating a soft mask in a PDF file.
Object Model
ImGearPDESoftMask ClassImGearPDEForm ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDESoftMask
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDESoftMask
public sealed class ImGearPDESoftMask : ImGearPDEElement
public __gc __sealed class ImGearPDESoftMask : public ImGearPDEElement
public ref class ImGearPDESoftMask sealed : public ImGearPDEElement
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDESoftMask

See Also

Reference

ImGearPDESoftMask Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDESoftMask Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESoftMask Class

The following tables list the members exposed by ImGearPDESoftMask.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDESoftMask Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets the soft mask name.
Top
Public Methods
 | Name | Description
Public Method | GetBackdropColor | Gets the array of color values of the backdrop color.
Public Method | GetForm | Acquires the form that defines the soft mask.
Public Method | SetBackdropColor | Sets the backdrop color values.
Public Method | SetForm | Sets the form that defines the soft mask.
Top
See Also

Reference

ImGearPDESoftMask Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDESoftMask Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : ImGearPDESoftMask Constructor
Overload List
Overload | Description
ImGearPDESoftMask Constructor(ImGearPDFDocument,ImGearPDESoftMaskCreateFlags,ImGearPDEForm) | Initializes a new instance of the ImGearPDESoftMask class.
ImGearPDESoftMask Constructor(ImGearPDFAtom) | Initializes a new instance of the ImGearPDESoftMask class.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members


%%PageItemTitle%%

ImGearPDESoftMask Constructor(ImGearPDFDocument,ImGearPDESoftMaskCreateFlags,ImGearPDEForm)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class > ImGearPDESoftMask Constructor : ImGearPDESoftMask Constructor(ImGearPDFDocument,ImGearPDESoftMaskCreateFlags,ImGearPDEForm)
The container document.
Specifies how the mask is to be computed. One of the ImGearPDESoftMaskCreateFlags values.
The form XObject that defines the soft mask. It is the source of the mask values and the color space in which the composite computation is to be done.
Initializes a new instance of the ImGearPDESoftMask class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal type As ImGearPDESoftMaskCreateFlags, _
   ByVal form As ImGearPDEForm _
)
'Usage

Dim document As ImGearPDFDocument
Dim type As ImGearPDESoftMaskCreateFlags
Dim form As ImGearPDEForm

Dim instance As New ImGearPDESoftMask(document, type, form)
public ImGearPDESoftMask(
   ImGearPDFDocument document,
   ImGearPDESoftMaskCreateFlags type,
   ImGearPDEForm form
)
public: ImGearPDESoftMask(
   ImGearPDFDocument* document,
   ImGearPDESoftMaskCreateFlags type,
   ImGearPDEForm* form
)
public:
ImGearPDESoftMask(
   ImGearPDFDocument^ document,
   ImGearPDESoftMaskCreateFlags type,
   ImGearPDEForm^ form
)

Parameters

document
The container document.
type
Specifies how the mask is to be computed. One of the ImGearPDESoftMaskCreateFlags values.
form
The form XObject that defines the soft mask. It is the source of the mask values and the color space in which the composite computation is to be done.

Return Value

The new instance of ImGearPDESoftMask class object.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members
Overload List
ImGearPDFDocument Class
ImGearPDESoftMaskCreateFlags Enumeration
ImGearPDEForm Class


%%PageItemTitle%%

ImGearPDESoftMask Constructor(ImGearPDFAtom)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class > ImGearPDESoftMask Constructor : ImGearPDESoftMask Constructor(ImGearPDFAtom)
The name of the soft mask.
Initializes a new instance of the ImGearPDESoftMask class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As ImGearPDFAtom _
)
'Usage

Dim name As ImGearPDFAtom

Dim instance As New ImGearPDESoftMask(name)
public ImGearPDESoftMask(
   ImGearPDFAtom name
)
public: ImGearPDESoftMask(
   ImGearPDFAtom* name
)
public:
ImGearPDESoftMask(
   ImGearPDFAtom^ name
)

Parameters

name
The name of the soft mask.

Return Value

The new instance of ImGearPDESoftMask class object.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members
Overload List
ImGearPDFAtom Class


%%PageItemTitle%% $$Methods$$

ImGearPDESoftMask Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESoftMask Class

For a list of all members of this type, see ImGearPDESoftMask members.

Public Methods
 | Name | Description
Public Method | GetBackdropColor | Gets the array of color values of the backdrop color.
Public Method | GetForm | Acquires the form that defines the soft mask.
Public Method | SetBackdropColor | Sets the backdrop color values.
Public Method | SetForm | Sets the form that defines the soft mask.
Top
See Also

Reference

ImGearPDESoftMask Class
ImageGear.Formats.PDF Namespace


GetBackdropColor Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : GetBackdropColor Method
Gets the array of color values of the backdrop color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBackdropColor() As Integer()
'Usage

Dim instance As ImGearPDESoftMask
Dim value() As Integer

value = instance.GetBackdropColor()
public int[] GetBackdropColor()
public: int[]* GetBackdropColor();
public:
array<int>^ GetBackdropColor();

Return Value

Array of color values.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members


GetForm Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : GetForm Method
Defines the transformation matrix from coordinate space to user space for the SoftMask object. The returned value corresponds to Matrix key in the XObject Form attributes dictionary, which specifies the mapping from form space to the current user space. Each time the form XObject is painted by the Do operator, this matrix is concatenated with the current transformation matrix to define the mapping from form space to device space. See section "4.9 Form XObjects" of the PDF Reference for more details.
Acquires the form that defines the soft mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetForm( _
   ByVal matrix As ImGearPDFFixedMatrix _
) As ImGearPDEForm
'Usage

Dim instance As ImGearPDESoftMask
Dim matrix As ImGearPDFFixedMatrix
Dim value As ImGearPDEForm

value = instance.GetForm(matrix)
public ImGearPDEForm GetForm(
   ImGearPDFFixedMatrix matrix
)
public: ImGearPDEForm* GetForm(
   ImGearPDFFixedMatrix* matrix
)
public:
ImGearPDEForm^ GetForm(
   ImGearPDFFixedMatrix^ matrix
)

Parameters

matrix
Defines the transformation matrix from coordinate space to user space for the SoftMask object. The returned value corresponds to Matrix key in the XObject Form attributes dictionary, which specifies the mapping from form space to the current user space. Each time the form XObject is painted by the Do operator, this matrix is concatenated with the current transformation matrix to define the mapping from form space to device space. See section "4.9 Form XObjects" of the PDF Reference for more details.

Return Value

ImGearPDEForm class object.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members
ImGearPDEForm Class
ImGearPDFFixedMatrix Class


SetBackdropColor Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : SetBackdropColor Method
Array of color values.
Sets the backdrop color values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetBackdropColor( _
   ByVal colorValues() As Integer _
)
'Usage

Dim instance As ImGearPDESoftMask
Dim colorValues() As Integer

instance.SetBackdropColor(colorValues)
public void SetBackdropColor(
   int[] colorValues
)
public: void SetBackdropColor(
   int[]* colorValues
)
public:
void SetBackdropColor(
   array<int>^ colorValues
)

Parameters

colorValues
Array of color values.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members


SetForm Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : SetForm Method
The form XObject.
Sets the form that defines the soft mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetForm( _
   ByVal form As ImGearPDEForm _
)
'Usage

Dim instance As ImGearPDESoftMask
Dim form As ImGearPDEForm

instance.SetForm(form)
public void SetForm(
   ImGearPDEForm form
)
public: void SetForm(
   ImGearPDEForm* form
)
public:
void SetForm(
   ImGearPDEForm^ form
)

Parameters

form
The form XObject.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members
ImGearPDEForm Class


%%PageItemTitle%% $$Properties$$

ImGearPDESoftMask Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESoftMask Class

For a list of all members of this type, see ImGearPDESoftMask members.

Public Properties
 | Name | Description
Public Property | Name | Gets the soft mask name.
Top
See Also

Reference

ImGearPDESoftMask Class
ImageGear.Formats.PDF Namespace


Name Property (ImGearPDESoftMask)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDESoftMask Class : Name Property
Gets the soft mask name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDESoftMask
Dim value As ImGearPDFAtom

value = instance.Name
public ImGearPDFAtom Name {get;}
public: __property ImGearPDFAtom* get_Name();
public:
property ImGearPDFAtom^ Name {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDESoftMask Class
ImGearPDESoftMask Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDEText Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEText Class
Represents a text object.
Object Model
ImGearPDEText ClassImGearPDFFixedPoint ClassImGearPDFFixedRect ClassImGearPDEFont ClassImGearPDEGraphicState ClassImGearPDETextItem ClassImGearPDFFixedMatrix ClassImGearPDFFixedQuad ClassImGearPDETextState ClassImGearPDFFixedMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEText
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEText
public sealed class ImGearPDEText : ImGearPDEElement
public __gc __sealed class ImGearPDEText : public ImGearPDEElement
public ref class ImGearPDEText sealed : public ImGearPDEElement
Remarks
It is a container for text as show strings or as individual characters. Each sub-element may have different graphics state properties. However, the same clip applies to all sub-elements of a Text. Also, the char path of a Text can be used to represent a clip.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEText

See Also

Reference

ImGearPDEText Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEText Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEText Class

The following tables list the members exposed by ImGearPDEText.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEText Constructor | Initializes a new instance of the ImGearPDEText class.
Top
Public Properties
 | Name | Description
Public Property | CharCount | Gets the number of characters in the text object.
Public Property | RunsCount | Gets the number of text runs (show strings) in the text object.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a character or a text run to a PDE Text object.
Public Method | AddItem | Adds a text item to a text element at a given index position.
Public Method | GetAdvance | Gets the advance width of a character or a text element.
Public Method | GetBBox | Overloaded. Gets the bounding box of a character or a text run.
Public Method | GetByteCount | Gets the number of bytes occupied by the character code or text run.
Public Method | GetFont | Gets the font for a text character or element.
Public Method | GetGState | Overloaded. Gets the graphics state of a character or a text run.
Public Method | GetItem | Obtains a text item from a text element at a given index position.
Public Method | GetMatrix | Overloaded. Returns the transformation matrix from text space to the user space for individual text character or run.
Public Method | GetQuad | Gets the quad bounding the specified text run or character.
Public Method | GetRunForChar | Gets the index of the text run that contains the nth character in a text object.
Public Method | GetState | Gets the text state of a character or a text element.
Public Method | GetStrokeMatrix | Returns the transformation matrix for the line width when stroking individual text character or run.
Public Method | GetText | Gets the text for a text run or character.
Public Method | IsAtPoint | Overloaded. Tests whether a point is on specified text.
Public Method | IsAtRect | Overloaded. Tests whether any part of a rectangle is on the specified text.
Public Method | Remove | Removes characters or text runs from a text object.
Public Method | RemoveItems | Removes contiguous text items from a text element starting at a given index position.
Public Method | ReplaceChars | Replaces characters in a text object.
Public Method | RunGetCharCount | Gets the number of characters in the specified text run.
Public Method | RunGetCharOffset | Gets the character offset of the first character of the specified text run.
Public Method | RunSetFont | Sets the font of a text run.
Public Method | RunSetGState | Sets the graphics state of a text run.
Public Method | RunSetMatrix | Sets the matrix of a text run.
Public Method | RunSetState | Sets the text state of a text run.
Public Method | RunSetStrokeMatrix | Sets the stroke matrix of a text run.
Public Method | SplitRunAt | Splits a text run into two text runs.
Top
See Also

Reference

ImGearPDEText Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEText Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : ImGearPDEText Constructor
Initializes a new instance of the ImGearPDEText class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEText()
public ImGearPDEText()
public: ImGearPDEText();
public:
ImGearPDEText();

Return Value

The new instance of ImGearPDEText class object.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


%%PageItemTitle%% $$Methods$$

ImGearPDEText Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEText Class

For a list of all members of this type, see ImGearPDEText members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a character or a text run to a PDE Text object.
Public Method | AddItem | Adds a text item to a text element at a given index position.
Public Method | GetAdvance | Gets the advance width of a character or a text element.
Public Method | GetBBox | Overloaded. Gets the bounding box of a character or a text run.
Public Method | GetByteCount | Gets the number of bytes occupied by the character code or text run.
Public Method | GetFont | Gets the font for a text character or element.
Public Method | GetGState | Overloaded. Gets the graphics state of a character or a text run.
Public Method | GetItem | Obtains a text item from a text element at a given index position.
Public Method | GetMatrix | Overloaded. Returns the transformation matrix from text space to the user space for individual text character or run.
Public Method | GetQuad | Gets the quad bounding the specified text run or character.
Public Method | GetRunForChar | Gets the index of the text run that contains the nth character in a text object.
Public Method | GetState | Gets the text state of a character or a text element.
Public Method | GetStrokeMatrix | Returns the transformation matrix for the line width when stroking individual text character or run.
Public Method | GetText | Gets the text for a text run or character.
Public Method | IsAtPoint | Overloaded. Tests whether a point is on specified text.
Public Method | IsAtRect | Overloaded. Tests whether any part of a rectangle is on the specified text.
Public Method | Remove | Removes characters or text runs from a text object.
Public Method | RemoveItems | Removes contiguous text items from a text element starting at a given index position.
Public Method | ReplaceChars | Replaces characters in a text object.
Public Method | RunGetCharCount | Gets the number of characters in the specified text run.
Public Method | RunGetCharOffset | Gets the character offset of the first character of the specified text run.
Public Method | RunSetFont | Sets the font of a text run.
Public Method | RunSetGState | Sets the graphics state of a text run.
Public Method | RunSetMatrix | Sets the matrix of a text run.
Public Method | RunSetState | Sets the text state of a text run.
Public Method | RunSetStrokeMatrix | Sets the stroke matrix of a text run.
Public Method | SplitRunAt | Splits a text run into two text runs.
Top
See Also

Reference

ImGearPDEText Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEText Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : ImGearPDEText Constructor
Overload List
Overload | Description
ImGearPDEText Constructor | Initializes a new instance of the ImGearPDEText class.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


Add Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : Add Method
Adds a character or a text run to a PDE Text object.
Overload List
Overload | Description
Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix) | Adds a Unicode character or a Unicode text run to a PDE Text object.
Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix,ImGearPDFFixedMatrix) | Adds a character or a text run to a PDE Text object.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix) Method
Example

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > Add Method : Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix) Method
ImGearPDETextFlags options that specify what kind of text to add. Must be either:CHAR - for a text character, or RUN - for a text run.
Index after which to add character or text run.
String with Unicode characters to add.
Font for the element. Must be TrueType or Type 0 font.
The graphics state for the element.
The text state for the element.
The coordinates of text are specified in text space. TextMatrix defines the transformation from text space to the user space. See section '5.3.1 Text-Positioning Operators' of the PDF Reference for more details.
Adds a Unicode character or a Unicode text run to a PDE Text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal text As String, _
   ByVal font As ImGearPDEFont, _
   ByVal graphicsState As ImGearPDEGraphicState, _
   ByVal textState As ImGearPDETextState, _
   ByVal textMatrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim text As String
Dim font As ImGearPDEFont
Dim graphicsState As ImGearPDEGraphicState
Dim textState As ImGearPDETextState
Dim textMatrix As ImGearPDFFixedMatrix

instance.Add(options, index, text, font, graphicsState, textState, textMatrix)
public void Add(
   ImGearPDETextFlags options,
   int index,
   string text,
   ImGearPDEFont font,
   ImGearPDEGraphicState graphicsState,
   ImGearPDETextState textState,
   ImGearPDFFixedMatrix textMatrix
)
public: void Add(
   ImGearPDETextFlags options,
   int index,
   string* text,
   ImGearPDEFont* font,
   ImGearPDEGraphicState* graphicsState,
   ImGearPDETextState* textState,
   ImGearPDFFixedMatrix* textMatrix
)
public:
void Add(
   ImGearPDETextFlags options,
   int index,
   String^ text,
   ImGearPDEFont^ font,
   ImGearPDEGraphicState^ graphicsState,
   ImGearPDETextState^ textState,
   ImGearPDFFixedMatrix^ textMatrix
)

Parameters

options
ImGearPDETextFlags options that specify what kind of text to add. Must be either:CHAR - for a text character, or RUN - for a text run.
index
Index after which to add character or text run.
text
String with Unicode characters to add.
font
Font for the element. Must be TrueType or Type 0 font.
graphicsState
The graphics state for the element.
textState
The text state for the element.
textMatrix
The coordinates of text are specified in text space. TextMatrix defines the transformation from text space to the user space. See section '5.3.1 Text-Positioning Operators' of the PDF Reference for more details.
Remarks

This method should be used for adding text encoded with Unicode.

The Unicode API methods require a TrueType or Type 0 font that can be embedded. This font must be created from a font file on the local machine, because the lookup tables used by these API only exist in the font files. This is required even if you only check for representable text. This method will raise an exception, if used with other fonts, like Type 1 or font retrieved from an existing PDF document.

Example
  • C#
private void addUnicodeTextToolStripMenuItem_Click(object sender, EventArgs e)
{
    if (igDocument is ImGearPDFDocument)
    {
        string textToAdd =
            "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本";

        ImGearPDFPage pdfPage = (ImGearPDFPage)igDocument.Pages[0];

        ImGearPDEContent pdfContent = pdfPage.GetContent();

        ImGearPDEFont fontSerif = CreateFont("Times-Roman", "Type0", "Identity-H");
        bool embedSerifFont = false;

        // Ensure that the text is fully representable by the font.
        // Add a warning if not.
        if (!fontSerif.IsTextRepresentable(textToAdd))
        {
            System.Collections.Generic.IEnumerable<char> unrepresentableChars =
                fontSerif.FindUnrepresentableCharacters(textToAdd);

            string unrepresentableCharsString = String.Empty;
            foreach (char unrepresentableChar in unrepresentableChars)
            {
                if (unrepresentableCharsString != String.Empty)
                {
                    unrepresentableCharsString += ",";
                }

                unrepresentableCharsString += unrepresentableChar;
            }

            MessageBox.Show(
                string.Format(
                    "The selected font, {0}, does not support the following characters: [{1}]",
                    fontSerif.GetAttributes().Name.String, unrepresentableCharsString));
        }

        ImGearPDEText text = CreateTextElement(
            textToAdd,
            fontSerif,
            11,
            10,
            30,
            300);

        if (text != null)
        {
            embedSerifFont = true;
            pdfContent.AddElement((int)ImGearPDEInsertElement.AFTER_LAST, text);
            text.Dispose();
        }

        // Finalize the content
        pdfPage.SetContent();

        // Embed and subset any fonts that were used. This is only
        // required when using Unicode fonts, and only in case if the font was actually used.
        if (embedSerifFont)
        {
            ImGearPDFDocument pdfDocument = igDocument as ImGearPDFDocument;
            fontSerif.CreateToUnicodeNow(pdfDocument);
            fontSerif.CreateWidthsNow(pdfDocument);
            fontSerif.SubsetNow(pdfDocument);
        }

        pdfPage.ReleaseContent();

        // Clean up editing objects
        if (fontSerif != null)
        {
            fontSerif.Dispose();
        }

        if (pdfContent != null)
        {
            pdfContent.Dispose();
        }

        pdfPage.ResetDisplayCache();

        this.imGearPageView1.Update();
    }
}

static ImGearPDEFont CreateFont(string FontName, string FontType, string sysEncodingName)
{
    ImGearPDEFontAttrs findAttrs = new ImGearPDEFontAttrs();
    findAttrs.Name = new ImGearPDFAtom(FontName);
    findAttrs.Type = new ImGearPDFAtom(FontType);
    ImGearPDFSysFont sysFont = ImGearPDFSysFont.FindSysFont(findAttrs, 0);

    ImGearPDFSysEncoding encoding = new ImGearPDFSysEncoding(new ImGearPDFAtom(sysEncodingName));

    ImGearPDEFont font = new ImGearPDEFont(
        sysFont,
        encoding,
        findAttrs.Name,
        ImGearPDEFontCreateFlags.CREATE_EMBEDDED | ImGearPDEFontCreateFlags.WILL_SUBSET | ImGearPDEFontCreateFlags.CREATE_TO_UNICODE | ImGearPDEFontCreateFlags.ENCODE_BY_GID);

    return font;
}

static ImGearPDEText CreateTextElement(
    string Text,
    ImGearPDEFont Font,
    Int32 FontSize,
    int x,
    int y,
    int w)
{
    ImGearPDEText textElement = null;

    ImGearPDEColorSpace colorSpace =
        new ImGearPDEColorSpace(new ImGearPDFAtom("DeviceGray"));

    ImGearPDEGraphicState gState = new ImGearPDEGraphicState();
    gState.StrokeColorSpec.Space = colorSpace;
    gState.FillColorSpec.Space = colorSpace;
    gState.MiterLimit = (int)ImGearPDFFixedValues.TEN;
    gState.Flatness = (int)ImGearPDFFixedValues.ONE;
    gState.LineWidth = (int)ImGearPDFFixedValues.ONE;

    ImGearPDFFixedMatrix textMatrix = new ImGearPDFFixedMatrix();
    textMatrix.A = ImGearPDF.IntToFixed(FontSize);
    textMatrix.D = ImGearPDF.IntToFixed(FontSize);
    textMatrix.H = ImGearPDF.IntToFixed(x);
    textMatrix.V = ImGearPDF.IntToFixed(y);

    textElement = new ImGearPDEText();

    textElement.Add(
        ImGearPDETextFlags.RUN,
        0,
        Text,
        Font,
        gState,
        null,
        textMatrix);

    colorSpace.Dispose();
    gState.Dispose();

    return textElement;
}
  • Visual Basic
Private Sub AddUnicodeTextToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AddUnicodeTextToolStripMenuItem.Click
    If TypeOf igDoc Is ImGearPDFDocument Then

        Dim textToAdd As String = "Russian: Русский Текст. Greek: Κείμενο στην ελληνική γλώσσα. Japanese (unrepresentable): 日本"

        Dim pdfPage As ImGearPDFPage = DirectCast(igDoc.Pages(0), ImGearPDFPage)

        Dim pdfContent As ImGearPDEContent = pdfPage.GetContent()

        Dim fontSerif As ImGearPDEFont = CreateFont("Times-Roman", "Type0", "Identity-H")
        Dim embedSerifFont As Boolean = False

        ' Ensure that the text is fully representable by the font.
        ' Add a warning if not.
        If Not fontSerif.IsTextRepresentable(textToAdd) Then
            Dim unrepresentableChars As System.Collections.Generic.IEnumerable(Of Char) = fontSerif.FindUnrepresentableCharacters(textToAdd)

            Dim unrepresentableCharsString As String = [String].Empty
            For Each unrepresentableChar As Char In unrepresentableChars
                If unrepresentableCharsString <> [String].Empty Then
                    unrepresentableCharsString += ","
                End If

                unrepresentableCharsString += unrepresentableChar
            Next

            MessageBox.Show(String.Format("The selected font, {0}, does not support the following characters: [{1}]", fontSerif.GetAttributes().Name.[String], unrepresentableCharsString))
        End If

        embedSerifFont = True

        Dim text As ImGearPDEText = CreateTextElement(textToAdd, fontSerif, 11, 10, 30, 300)

        If text IsNot Nothing Then
            pdfContent.AddElement(CInt(ImGearPDEInsertElement.AFTER_LAST), text)
            text.Dispose()
        End If

        ' Finalize the content
        pdfPage.SetContent()

        ' Embed and subset any fonts that were used. This is only
        ' required when using Unicode fonts, and only in case if the font was actually used.
        If embedSerifFont Then
            Dim pdfDocument As ImGearPDFDocument = TryCast(igDoc, ImGearPDFDocument)
            fontSerif.CreateToUnicodeNow(pdfDocument)
            fontSerif.CreateWidthsNow(pdfDocument)
            fontSerif.SubsetNow(pdfDocument)
        End If

        pdfPage.ReleaseContent()

        ' Clean up editing objects
        If fontSerif IsNot Nothing Then
            fontSerif.Dispose()
        End If

        If pdfContent IsNot Nothing Then
            pdfContent.Dispose()
        End If

        pdfPage.ResetDisplayCache()

        Me.ImGearPageView1.Update()
    End If
End Sub

Private Shared Function CreateFont(ByVal FontName As String, ByVal FontType As String, ByVal sysEncodingName As String) As ImGearPDEFont
    Dim findAttrs As New ImGearPDEFontAttrs()
    findAttrs.Name = New ImGearPDFAtom(FontName)
    findAttrs.Type = New ImGearPDFAtom(FontType)
    Dim sysFont As ImGearPDFSysFont = ImGearPDFSysFont.FindSysFont(findAttrs, 0)

    Dim encoding As New ImGearPDFSysEncoding(New ImGearPDFAtom(sysEncodingName))

    Dim font As New ImGearPDEFont(sysFont, encoding, findAttrs.Name, ImGearPDEFontCreateFlags.CREATE_EMBEDDED Or ImGearPDEFontCreateFlags.WILL_SUBSET Or ImGearPDEFontCreateFlags.CREATE_TO_UNICODE Or ImGearPDEFontCreateFlags.ENCODE_BY_GID)

    Return font
End Function

Private Shared Function CreateTextElement(ByVal Text As String, ByVal Font As ImGearPDEFont, ByVal FontSize As Int32, ByVal x As Integer, ByVal y As Integer, ByVal w As Integer) As ImGearPDEText
    Dim textElement As ImGearPDEText = Nothing

    Dim colorSpace As New ImGearPDEColorSpace(New ImGearPDFAtom("DeviceGray"))

    Dim gState As New ImGearPDEGraphicState()
    gState.StrokeColorSpec.Space = colorSpace
    gState.FillColorSpec.Space = colorSpace
    gState.MiterLimit = CInt(ImGearPDFFixedValues.TEN)
    gState.Flatness = CInt(ImGearPDFFixedValues.ONE)
    gState.LineWidth = CInt(ImGearPDFFixedValues.ONE)

    Dim textMatrix As New ImGearPDFFixedMatrix()
    textMatrix.A = ImGearPDF.IntToFixed(FontSize)
    textMatrix.D = ImGearPDF.IntToFixed(FontSize)
    textMatrix.H = ImGearPDF.IntToFixed(x)
    textMatrix.V = ImGearPDF.IntToFixed(y)

    textElement = New ImGearPDEText()

    textElement.Add(ImGearPDETextFlags.RUN, 0, Text, Font, gState, Nothing, _
     textMatrix)

    colorSpace.Dispose()
    gState.Dispose()

    Return textElement
End Function
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDEFont Class
ImGearPDEGraphicState Class
ImGearPDETextState Class
ImGearPDFFixedMatrix Class


Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix,ImGearPDFFixedMatrix) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > Add Method : Add(ImGearPDETextFlags,Int32,String,ImGearPDEFont,ImGearPDEGraphicState,ImGearPDETextState,ImGearPDFFixedMatrix,ImGearPDFFixedMatrix) Method
ImGearPDETextFlags options that specify what kind of text to add. Must be either:CHAR - for a text character, or RUN - for a text run.
Index after which to add character or text run.
String with characters to add. Passing Null for text can invalidate the text object but will not raise an error. Callers must not pass Null for this parameter.
Font for the element.
The graphics state for the element.
The text state for the element.
The coordinates of text are specified in text space. TextMatrix defines the transformation from text space to the user space. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
The transformation matrix for the line width when stroking text. May be Null. The line width parameter specifies the thickness of the line used to stroke a path. It is a non-negative number expressed in user space units; stroking a path entails painting all points whose perpendicular distance from the path in user space is less than or equal to half the line width. The effect produced in device space depends on the StrokeMatrix in effect at the time the path is stroked. See section '4.3.2 Details of Graphics State Parameters' of the PDF Reference for more details.
Adds a character or a text run to a PDE Text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal text As String, _
   ByVal font As ImGearPDEFont, _
   ByVal graphicsState As ImGearPDEGraphicState, _
   ByVal textState As ImGearPDETextState, _
   ByVal textMatrix As ImGearPDFFixedMatrix, _
   ByVal strokeMatrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim text As String
Dim font As ImGearPDEFont
Dim graphicsState As ImGearPDEGraphicState
Dim textState As ImGearPDETextState
Dim textMatrix As ImGearPDFFixedMatrix
Dim strokeMatrix As ImGearPDFFixedMatrix

instance.Add(options, index, text, font, graphicsState, textState, textMatrix, strokeMatrix)
public void Add(
   ImGearPDETextFlags options,
   int index,
   string text,
   ImGearPDEFont font,
   ImGearPDEGraphicState graphicsState,
   ImGearPDETextState textState,
   ImGearPDFFixedMatrix textMatrix,
   ImGearPDFFixedMatrix strokeMatrix
)
public: void Add(
   ImGearPDETextFlags options,
   int index,
   string* text,
   ImGearPDEFont* font,
   ImGearPDEGraphicState* graphicsState,
   ImGearPDETextState* textState,
   ImGearPDFFixedMatrix* textMatrix,
   ImGearPDFFixedMatrix* strokeMatrix
)
public:
void Add(
   ImGearPDETextFlags options,
   int index,
   String^ text,
   ImGearPDEFont^ font,
   ImGearPDEGraphicState^ graphicsState,
   ImGearPDETextState^ textState,
   ImGearPDFFixedMatrix^ textMatrix,
   ImGearPDFFixedMatrix^ strokeMatrix
)

Parameters

options
ImGearPDETextFlags options that specify what kind of text to add. Must be either:CHAR - for a text character, or RUN - for a text run.
index
Index after which to add character or text run.
text
String with characters to add. Passing Null for text can invalidate the text object but will not raise an error. Callers must not pass Null for this parameter.
font
Font for the element.
graphicsState
The graphics state for the element.
textState
The text state for the element.
textMatrix
The coordinates of text are specified in text space. TextMatrix defines the transformation from text space to the user space. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
strokeMatrix
The transformation matrix for the line width when stroking text. May be Null. The line width parameter specifies the thickness of the line used to stroke a path. It is a non-negative number expressed in user space units; stroking a path entails painting all points whose perpendicular distance from the path in user space is less than or equal to half the line width. The effect produced in device space depends on the StrokeMatrix in effect at the time the path is stroked. See section '4.3.2 Details of Graphics State Parameters' of the PDF Reference for more details.
Remarks
This method should be used for adding ASCII text.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDEFont Class
ImGearPDEGraphicState Class
ImGearPDETextState Class
ImGearPDFFixedMatrix Class


AddItem Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : AddItem Method
Index of the text item.
The text item to add.
Adds a text item to a text element at a given index position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddItem( _
   ByVal index As Integer, _
   ByVal textItem As ImGearPDETextItem _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim textItem As ImGearPDETextItem

instance.AddItem(index, textItem)
public void AddItem(
   int index,
   ImGearPDETextItem textItem
)
public: void AddItem(
   int index,
   ImGearPDETextItem* textItem
)
public:
void AddItem(
   int index,
   ImGearPDETextItem^ textItem
)

Parameters

index
Index of the text item.
textItem
The text item to add.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextItem Class


GetAdvance Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetAdvance Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text runIn addition, set the PAGE_SPACE flag to obtain the advance width in user space. If it is not set, the advance width is in character space.If this flag is not set, this method returns a value that is independent of any sizes, matrices, or scaling, simply adding up the font's raw glyph widths, supplemented only by unscaled character and word spacing.
Index of the character or text run in the text.
Gets the advance width of a character or a text element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAdvance( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDFFixedPoint

value = instance.GetAdvance(options, index)
public ImGearPDFFixedPoint GetAdvance(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDFFixedPoint* GetAdvance(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDFFixedPoint^ GetAdvance(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text runIn addition, set the PAGE_SPACE flag to obtain the advance width in user space. If it is not set, the advance width is in character space.If this flag is not set, this method returns a value that is independent of any sizes, matrices, or scaling, simply adding up the font's raw glyph widths, supplemented only by unscaled character and word spacing.
index
Index of the character or text run in the text.

Return Value

ImGearPDFFixedPoint class object indicating the advance width.
Remarks
Advance width is returned in either character space or user space. The advance width is the amount by which the current point advances when the character is drawn.

Advance width may be horizontal or vertical, depending on the writing style. Thus the return value has both a horizontal and vertical component.

See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDFFixedPoint Class
ImGearPDETextFlags Enumeration


GetBBox Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetBBox Method
Gets the bounding box of a character or a text run.
Overload List
Overload | Description
GetBBox(ImGearPDETextFlags,Int32) | Gets the bounding box of a character or a text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


GetBBox(ImGearPDETextFlags,Int32) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > GetBBox Method : GetBBox(ImGearPDETextFlags,Int32) Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
Index of the character or text run in the text object.
Gets the bounding box of a character or a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetBBox( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDFFixedRect

value = instance.GetBBox(options, index)
public ImGearPDFFixedRect GetBBox(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDFFixedRect* GetBBox(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDFFixedRect^ GetBBox(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDFFixedRect class object, which is the bounding box of specified character or text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDFFixedRect Class
ImGearPDETextFlags Enumeration


GetByteCount Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetByteCount Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Gets the number of bytes occupied by the character code or text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetByteCount( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As Integer

value = instance.GetByteCount(options, index)
public int GetByteCount(
   ImGearPDETextFlags options,
   int index
)
public: int GetByteCount(
   ImGearPDETextFlags options,
   int index
)
public:
int GetByteCount(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.

Return Value

Number of bytes occupied by the text run or character.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration


GetFont Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetFont Method
Specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
Index of the character or text run in the text object.
Gets the font for a text character or element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFont( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDEFont
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDEFont

value = instance.GetFont(options, index)
public ImGearPDEFont GetFont(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDEFont* GetFont(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDEFont^ GetFont(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
Specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDEFont class object.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration
ImGearPDEFont Class


GetGState Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetGState Method
Gets the graphics state of a character or a text run.
Overload List
Overload | Description
GetGState(ImGearPDETextFlags,Int32) | Gets the graphics state of a character or a text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


GetGState(ImGearPDETextFlags,Int32) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > GetGState Method : GetGState(ImGearPDETextFlags,Int32) Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Gets the graphics state of a character or a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetGState( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDEGraphicState
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDEGraphicState

value = instance.GetGState(options, index)
public ImGearPDEGraphicState GetGState(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDEGraphicState* GetGState(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDEGraphicState^ GetGState(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDEGraphicState class object, which is the graphics state of specified character or text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDEGraphicState Class


GetItem Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetItem Method
Index of the text item in the text object.
Obtains a text item from a text element at a given index position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItem( _
   ByVal index As Integer _
) As ImGearPDETextItem
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim value As ImGearPDETextItem

value = instance.GetItem(index)
public ImGearPDETextItem GetItem(
   int index
)
public: ImGearPDETextItem* GetItem(
   int index
)
public:
ImGearPDETextItem^ GetItem(
   int index
)

Parameters

index
Index of the text item in the text object.

Return Value

ImGearPDETextItem class object.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextItem Class


GetMatrix Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetMatrix Method
Returns the transformation matrix from text space to the user space for individual text character or run.
Overload List
Overload | Description
GetMatrix(ImGearPDETextFlags,Int32) | Returns the transformation matrix from text space to the user space for individual text character or run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


GetMatrix(ImGearPDETextFlags,Int32) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > GetMatrix Method : GetMatrix(ImGearPDETextFlags,Int32) Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
Index of the character or text run in the text object.
Returns the transformation matrix from text space to the user space for individual text character or run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetMatrix( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDFFixedMatrix

value = instance.GetMatrix(options, index)
public ImGearPDFFixedMatrix GetMatrix(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDFFixedMatrix* GetMatrix(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDFFixedMatrix^ GetMatrix(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR -- for a text characterRUN -- for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDFFixedMatrix class object that holds the matrix of specified character or text run.
Remarks
See section '5.3.1 Text-Positioning Operators' of the PDF Reference for more details.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDFFixedMatrix Class


GetQuad Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetQuad Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run. In addition, if the GET_BOUNDS flag is set, this method uses the font descriptor's FontBBox, which is the smallest rectangle that encloses all characters in the font. The advance portion is based on the x-coordinates of the left and right sides of FontBBox and the advance width.
Index of the character or text run in the text object.
Gets the quad bounding the specified text run or character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetQuad( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDFFixedQuad
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDFFixedQuad

value = instance.GetQuad(options, index)
public ImGearPDFFixedQuad GetQuad(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDFFixedQuad* GetQuad(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDFFixedQuad^ GetQuad(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run. In addition, if the GET_BOUNDS flag is set, this method uses the font descriptor's FontBBox, which is the smallest rectangle that encloses all characters in the font. The advance portion is based on the x-coordinates of the left and right sides of FontBBox and the advance width.
index
Index of the character or text run in the text object.

Return Value

ImGearPDFFixedQuad class object that bounds the specified character or text run.
Remarks
The advance portion of the quad is based on the left side bearing and advance width.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration
ImGearPDFFixedQuad Class


GetRunForChar Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetRunForChar Method
Index of the character to find in the text object.
Gets the index of the text run that contains the nth character in a text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRunForChar( _
   ByVal characterIndex As Integer _
) As Integer
'Usage

Dim instance As ImGearPDEText
Dim characterIndex As Integer
Dim value As Integer

value = instance.GetRunForChar(characterIndex)
public int GetRunForChar(
   int characterIndex
)
public: int GetRunForChar(
   int characterIndex
)
public:
int GetRunForChar(
   int characterIndex
)

Parameters

characterIndex
Index of the character to find in the text object.

Return Value

Index of the text run with the specified character index in the text object.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


GetState Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetState Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Gets the text state of a character or a text element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetState( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDETextState
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDETextState

value = instance.GetState(options, index)
public ImGearPDETextState GetState(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDETextState* GetState(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDETextState^ GetState(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDETextState class object, which is the text state of the specified character or text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration
ImGearPDETextState Class


GetStrokeMatrix Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetStrokeMatrix Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Returns the transformation matrix for the line width when stroking individual text character or run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStrokeMatrix( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As ImGearPDFFixedMatrix

value = instance.GetStrokeMatrix(options, index)
public ImGearPDFFixedMatrix GetStrokeMatrix(
   ImGearPDETextFlags options,
   int index
)
public: ImGearPDFFixedMatrix* GetStrokeMatrix(
   ImGearPDETextFlags options,
   int index
)
public:
ImGearPDFFixedMatrix^ GetStrokeMatrix(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.

Return Value

ImGearPDFFixedMatrix class object that that holds the stroke matrix of specified character or text run. This matrix is the transformation for line widths when stroking. The h and v values of the matrix are ignored.
Remarks
The line width parameter specifies the thickness of the line used to stroke a path. It is a non-negative number expressed in user space units; stroking a path entails painting all points whose perpendicular distance from the path in user space is less than or equal to half the line width. The effect produced in device space depends on the StrokeMatrix in effect at the time the path is stroked. See section '4.3.2 Details of Graphics State Parameters' of the PDF Reference for more details.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration
ImGearPDFFixedMatrix Class


GetText Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : GetText Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Gets the text for a text run or character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetText( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer _
) As String
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim value As String

value = instance.GetText(options, index)
public string GetText(
   ImGearPDETextFlags options,
   int index
)
public: string* GetText(
   ImGearPDETextFlags options,
   int index
)
public:
String^ GetText(
   ImGearPDETextFlags options,
   int index
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.

Return Value

String value. This result is useful only for ASCII-encoded text objects.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration


IsAtPoint Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : IsAtPoint Method
Tests whether a point is on specified text.
Overload List
Overload | Description
IsAtPoint(ImGearPDETextFlags,Int32,ImGearPDFFixedPoint) | Tests whether a point is on specified text.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


IsAtPoint(ImGearPDETextFlags,Int32,ImGearPDFFixedPoint) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > IsAtPoint Method : IsAtPoint(ImGearPDETextFlags,Int32,ImGearPDFFixedPoint) Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
A point, specified in user space coordinates.
Tests whether a point is on specified text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsAtPoint( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal point As ImGearPDFFixedPoint _
) As Boolean
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim point As ImGearPDFFixedPoint
Dim value As Boolean

value = instance.IsAtPoint(options, index, point)
public bool IsAtPoint(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedPoint point
)
public: bool IsAtPoint(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedPoint* point
)
public:
bool IsAtPoint(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedPoint^ point
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.
point
A point, specified in user space coordinates.

Return Value

True if the point is on the text, False otherwise.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDFFixedPoint Class


IsAtRect Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : IsAtRect Method
Tests whether any part of a rectangle is on the specified text.
Overload List
Overload | Description
IsAtRect(ImGearPDETextFlags,Int32,ImGearPDFFixedRect) | Tests whether any part of a rectangle is on the specified text.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


IsAtRect(ImGearPDETextFlags,Int32,ImGearPDFFixedRect) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class > IsAtRect Method : IsAtRect(ImGearPDETextFlags,Int32,ImGearPDFFixedRect) Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
A rectangle, specified in user space coordinates.
Tests whether any part of a rectangle is on the specified text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function IsAtRect( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal rect As ImGearPDFFixedRect _
) As Boolean
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim rect As ImGearPDFFixedRect
Dim value As Boolean

value = instance.IsAtRect(options, index, rect)
public bool IsAtRect(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedRect rect
)
public: bool IsAtRect(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedRect* rect
)
public:
bool IsAtRect(
   ImGearPDETextFlags options,
   int index,
   ImGearPDFFixedRect^ rect
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.
rect
A rectangle, specified in user space coordinates.

Return Value

True if the text is on the rectangle, False otherwise.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
Overload List
ImGearPDETextFlags Enumeration
ImGearPDFFixedRect Class


Remove Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : Remove Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Number of characters or text runs to remove.
Removes characters or text runs from a text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim count As Integer

instance.Remove(options, index, count)
public void Remove(
   ImGearPDETextFlags options,
   int index,
   int count
)
public: void Remove(
   ImGearPDETextFlags options,
   int index,
   int count
)
public:
void Remove(
   ImGearPDETextFlags options,
   int index,
   int count
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.
count
Number of characters or text runs to remove.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration


RemoveItems Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RemoveItems Method
Index of the first text item in pdeText to remove.
The number of text items to remove.
Removes contiguous text items from a text element starting at a given index position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveItems( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim count As Integer

instance.RemoveItems(index, count)
public void RemoveItems(
   int index,
   int count
)
public: void RemoveItems(
   int index,
   int count
)
public:
void RemoveItems(
   int index,
   int count
)

Parameters

index
Index of the first text item in pdeText to remove.
count
The number of text items to remove.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


ReplaceChars Method (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : ReplaceChars Method
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR for a text character or RUN for a text run.
Index of the character or text run in the text object.
Replacement text.
Replaces characters in a text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReplaceChars( _
   ByVal options As ImGearPDETextFlags, _
   ByVal index As Integer, _
   ByVal text As String _
)
'Usage

Dim instance As ImGearPDEText
Dim options As ImGearPDETextFlags
Dim index As Integer
Dim text As String

instance.ReplaceChars(options, index, text)
public void ReplaceChars(
   ImGearPDETextFlags options,
   int index,
   string text
)
public: void ReplaceChars(
   ImGearPDETextFlags options,
   int index,
   string* text
)
public:
void ReplaceChars(
   ImGearPDETextFlags options,
   int index,
   String^ text
)

Parameters

options
ImGearPDETextFlags value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:CHAR for a text character or RUN for a text run.
index
Index of the character or text run in the text object.
text
Replacement text.
Remarks
This method does not change the number of characters in the text object--extra characters are ignored.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextFlags Enumeration


RunGetCharCount Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunGetCharCount Method
Integer value from the range from 0 to RunsCount - 1.
Gets the number of characters in the specified text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function RunGetCharCount( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim value As Integer

value = instance.RunGetCharCount(index)
public int RunGetCharCount(
   int index
)
public: int RunGetCharCount(
   int index
)
public:
int RunGetCharCount(
   int index
)

Parameters

index
Integer value from the range from 0 to RunsCount - 1.

Return Value

Integer value.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


RunGetCharOffset Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunGetCharOffset Method
Integer value from the range from 0 to RunsCount - 1.
Gets the character offset of the first character of the specified text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function RunGetCharOffset( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim value As Integer

value = instance.RunGetCharOffset(index)
public int RunGetCharOffset(
   int index
)
public: int RunGetCharOffset(
   int index
)
public:
int RunGetCharOffset(
   int index
)

Parameters

index
Integer value from the range from 0 to RunsCount - 1.

Return Value

Integer value.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


RunSetFont Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunSetFont Method
Index of the text run.
New font for the text run.
Sets the font of a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RunSetFont( _
   ByVal index As Integer, _
   ByVal font As ImGearPDEFont _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim font As ImGearPDEFont

instance.RunSetFont(index, font)
public void RunSetFont(
   int index,
   ImGearPDEFont font
)
public: void RunSetFont(
   int index,
   ImGearPDEFont* font
)
public:
void RunSetFont(
   int index,
   ImGearPDEFont^ font
)

Parameters

index
Index of the text run.
font
New font for the text run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDEFont Class


RunSetGState Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunSetGState Method
Index of the text run.
ImGearPDEGraphicState with graphics state to set.
Sets the graphics state of a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RunSetGState( _
   ByVal index As Integer, _
   ByVal graphicsState As ImGearPDEGraphicState _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim graphicsState As ImGearPDEGraphicState

instance.RunSetGState(index, graphicsState)
public void RunSetGState(
   int index,
   ImGearPDEGraphicState graphicsState
)
public: void RunSetGState(
   int index,
   ImGearPDEGraphicState* graphicsState
)
public:
void RunSetGState(
   int index,
   ImGearPDEGraphicState^ graphicsState
)

Parameters

index
Index of the text run.
graphicsState
ImGearPDEGraphicState with graphics state to set.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDEGraphicState Class


RunSetMatrix Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunSetMatrix Method
Index of the text run.
The coordinates of text runs are specified in text space. Matrix defines the transformation from text space to the user space for individual text run. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
Sets the matrix of a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RunSetMatrix( _
   ByVal index As Integer, _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim matrix As ImGearPDFFixedMatrix

instance.RunSetMatrix(index, matrix)
public void RunSetMatrix(
   int index,
   ImGearPDFFixedMatrix matrix
)
public: void RunSetMatrix(
   int index,
   ImGearPDFFixedMatrix* matrix
)
public:
void RunSetMatrix(
   int index,
   ImGearPDFFixedMatrix^ matrix
)

Parameters

index
Index of the text run.
matrix
The coordinates of text runs are specified in text space. Matrix defines the transformation from text space to the user space for individual text run. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDFFixedMatrix Class


RunSetState Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunSetState Method
Index of the text run.
ImGearPDETextState class with state to set.
Sets the text state of a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RunSetState( _
   ByVal index As Integer, _
   ByVal textState As ImGearPDETextState _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim textState As ImGearPDETextState

instance.RunSetState(index, textState)
public void RunSetState(
   int index,
   ImGearPDETextState textState
)
public: void RunSetState(
   int index,
   ImGearPDETextState* textState
)
public:
void RunSetState(
   int index,
   ImGearPDETextState^ textState
)

Parameters

index
Index of the text run.
textState
ImGearPDETextState class with state to set.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDETextState Class


RunSetStrokeMatrix Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunSetStrokeMatrix Method
Index of the text run.
The transformation matrix for the line width when stroking text. The line width parameter specifies the thickness of the line used to stroke a path. It is a non-negative number expressed in user space units; stroking a path entails painting all points whose perpendicular distance from the path in user space is less than or equal to half the line width. The effect produced in device space depends on the StrokeMatrix in effect at the time the path is stroked. See section '4.3.2 Details of Graphics State Parameters' of the PDF Reference for more details.
Sets the stroke matrix of a text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RunSetStrokeMatrix( _
   ByVal index As Integer, _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDEText
Dim index As Integer
Dim matrix As ImGearPDFFixedMatrix

instance.RunSetStrokeMatrix(index, matrix)
public void RunSetStrokeMatrix(
   int index,
   ImGearPDFFixedMatrix matrix
)
public: void RunSetStrokeMatrix(
   int index,
   ImGearPDFFixedMatrix* matrix
)
public:
void RunSetStrokeMatrix(
   int index,
   ImGearPDFFixedMatrix^ matrix
)

Parameters

index
Index of the text run.
matrix
The transformation matrix for the line width when stroking text. The line width parameter specifies the thickness of the line used to stroke a path. It is a non-negative number expressed in user space units; stroking a path entails painting all points whose perpendicular distance from the path in user space is less than or equal to half the line width. The effect produced in device space depends on the StrokeMatrix in effect at the time the path is stroked. See section '4.3.2 Details of Graphics State Parameters' of the PDF Reference for more details.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members
ImGearPDFFixedMatrix Class


SplitRunAt Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : SplitRunAt Method
Split location, relative to the text object. The first text run is from character index 0 up to splitLoc. The second text run is from SplitLoc + 1 to the end of the run.
Splits a text run into two text runs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SplitRunAt( _
   ByVal splitLocation As Integer _
)
'Usage

Dim instance As ImGearPDEText
Dim splitLocation As Integer

instance.SplitRunAt(splitLocation)
public void SplitRunAt(
   int splitLocation
)
public: void SplitRunAt(
   int splitLocation
)
public:
void SplitRunAt(
   int splitLocation
)

Parameters

splitLocation
Split location, relative to the text object. The first text run is from character index 0 up to splitLoc. The second text run is from SplitLoc + 1 to the end of the run.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


%%PageItemTitle%% $$Properties$$

ImGearPDEText Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEText Class

For a list of all members of this type, see ImGearPDEText members.

Public Properties
 | Name | Description
Public Property | CharCount | Gets the number of characters in the text object.
Public Property | RunsCount | Gets the number of text runs (show strings) in the text object.
Top
See Also

Reference

ImGearPDEText Class
ImageGear.Formats.PDF Namespace


CharCount Property (ImGearPDEText)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : CharCount Property
Gets the number of characters in the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CharCount As Integer
'Usage

Dim instance As ImGearPDEText
Dim value As Integer

value = instance.CharCount
public int CharCount {get;}
public: __property int get_CharCount();
public:
property int CharCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


RunsCount Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEText Class : RunsCount Property
Gets the number of text runs (show strings) in the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RunsCount As Integer
'Usage

Dim instance As ImGearPDEText
Dim value As Integer

value = instance.RunsCount
public int RunsCount {get;}
public: __property int get_RunsCount();
public:
property int RunsCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDEText Class
ImGearPDEText Members


%%PageItemTitle%%

ImGearPDETextItem Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextItem Class
Represents a text item object.
Object Model
ImGearPDETextItem ClassImGearPDEFont ClassImGearPDEGraphicState ClassImGearPDFFixedMatrix ClassImGearPDETextState Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDETextItem
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDETextItem
public sealed class ImGearPDETextItem : ImGearPDEElement
public __gc __sealed class ImGearPDETextItem : public ImGearPDEElement
public ref class ImGearPDETextItem sealed : public ImGearPDEElement
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDETextItem

See Also

Reference

ImGearPDETextItem Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDETextItem Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextItem Class

The following tables list the members exposed by ImGearPDETextItem.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDETextItem Constructor | Initializes a new instance of the ImGearPDETextItem class.
Top
Public Properties
 | Name | Description
Public Property | TextLength | Gets a text length for a text item, in bytes.
Top
Public Methods
 | Name | Description
Public Method | CopyText | Copies the text from a text item element.
Public Method | GetFont | Gets the font for a text item.
Public Method | GetGState | Gets the graphics state for a text item.
Public Method | GetMatrix | Overloaded. Gets the matrix that defines the transformation from text space to the user space for individual text character.
Public Method | GetState | Gets the text state of a text item.
Public Method | RemoveChars | Removes contiguous characters from a text item.
Public Method | ReplaceChars | Replaces characters in a text item.
Public Method | ReplaceText | Replaces all of the text in a text item.
Public Method | SetFont | Sets a font for a text item.
Public Method | SetGState | Sets the graphics state of a text item.
Public Method | SetMatrix | Sets the matrix that defines the transformation from text space to the user space for individual text item.
Public Method | SetState | Sets the text state of a text item.
Top
See Also

Reference

ImGearPDETextItem Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDETextItem Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : ImGearPDETextItem Constructor
The text string.
The font for a text item.
The graphics state for a text item.
The text state of a text item.
The coordinates of text characters are specified in text space. TextMatrix defines the transformation from text space to the user space for individual text character. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
Initializes a new instance of the ImGearPDETextItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal font As ImGearPDEFont, _
   ByVal graphicsState As ImGearPDEGraphicState, _
   ByVal textState As ImGearPDETextState, _
   ByVal textMatrix As ImGearPDFFixedMatrix _
)
'Usage

Dim text As String
Dim font As ImGearPDEFont
Dim graphicsState As ImGearPDEGraphicState
Dim textState As ImGearPDETextState
Dim textMatrix As ImGearPDFFixedMatrix

Dim instance As New ImGearPDETextItem(text, font, graphicsState, textState, textMatrix)
public ImGearPDETextItem(
   string text,
   ImGearPDEFont font,
   ImGearPDEGraphicState graphicsState,
   ImGearPDETextState textState,
   ImGearPDFFixedMatrix textMatrix
)
public: ImGearPDETextItem(
   string* text,
   ImGearPDEFont* font,
   ImGearPDEGraphicState* graphicsState,
   ImGearPDETextState* textState,
   ImGearPDFFixedMatrix* textMatrix
)
public:
ImGearPDETextItem(
   String^ text,
   ImGearPDEFont^ font,
   ImGearPDEGraphicState^ graphicsState,
   ImGearPDETextState^ textState,
   ImGearPDFFixedMatrix^ textMatrix
)

Parameters

text
The text string.
font
The font for a text item.
graphicsState
The graphics state for a text item.
textState
The text state of a text item.
textMatrix
The coordinates of text characters are specified in text space. TextMatrix defines the transformation from text space to the user space for individual text character. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.

Return Value

The new instance of ImGearPDETextItem class object.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDEFont Class
ImGearPDEGraphicState Class
ImGearPDETextState Class
ImGearPDFFixedMatrix Class


%%PageItemTitle%% $$Methods$$

ImGearPDETextItem Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextItem Class

For a list of all members of this type, see ImGearPDETextItem members.

Public Methods
 | Name | Description
Public Method | CopyText | Copies the text from a text item element.
Public Method | GetFont | Gets the font for a text item.
Public Method | GetGState | Gets the graphics state for a text item.
Public Method | GetMatrix | Overloaded. Gets the matrix that defines the transformation from text space to the user space for individual text character.
Public Method | GetState | Gets the text state of a text item.
Public Method | RemoveChars | Removes contiguous characters from a text item.
Public Method | ReplaceChars | Replaces characters in a text item.
Public Method | ReplaceText | Replaces all of the text in a text item.
Public Method | SetFont | Sets a font for a text item.
Public Method | SetGState | Sets the graphics state of a text item.
Public Method | SetMatrix | Sets the matrix that defines the transformation from text space to the user space for individual text item.
Public Method | SetState | Sets the text state of a text item.
Top
See Also

Reference

ImGearPDETextItem Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDETextItem Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : ImGearPDETextItem Constructor
Overload List
Overload | Description
ImGearPDETextItem Constructor | Initializes a new instance of the ImGearPDETextItem class.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


CopyText Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : CopyText Method
Copies the text from a text item element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CopyText() As String
'Usage

Dim instance As ImGearPDETextItem
Dim value As String

value = instance.CopyText()
public string CopyText()
public: string* CopyText();
public:
String^ CopyText();

Return Value

Text string.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


GetFont Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : GetFont Method
Gets the font for a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFont() As ImGearPDEFont
'Usage

Dim instance As ImGearPDETextItem
Dim value As ImGearPDEFont

value = instance.GetFont()
public ImGearPDEFont GetFont()
public: ImGearPDEFont* GetFont();
public:
ImGearPDEFont^ GetFont();

Return Value

ImGearPDEFont class object.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDEFont Class


GetGState Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : GetGState Method
Gets the graphics state for a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetGState() As ImGearPDEGraphicState
'Usage

Dim instance As ImGearPDETextItem
Dim value As ImGearPDEGraphicState

value = instance.GetGState()
public new ImGearPDEGraphicState GetGState()
public: new ImGearPDEGraphicState* GetGState();
public:
new ImGearPDEGraphicState^ GetGState();

Return Value

ImGearPDEGraphicState class object.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDEGraphicState Class


GetMatrix Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : GetMatrix Method
Gets the matrix that defines the transformation from text space to the user space for individual text character.
Overload List
Overload | Description
GetMatrix(Int32) | Gets the matrix that defines the transformation from text space to the user space for individual text character.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


GetMatrix(Int32) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class > GetMatrix Method : GetMatrix(Int32) Method
Index of the character whose text matrix is obtained.
Gets the matrix that defines the transformation from text space to the user space for individual text character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetMatrix( _
   ByVal characterIndex As Integer _
) As ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDETextItem
Dim characterIndex As Integer
Dim value As ImGearPDFFixedMatrix

value = instance.GetMatrix(characterIndex)
public ImGearPDFFixedMatrix GetMatrix(
   int characterIndex
)
public: ImGearPDFFixedMatrix* GetMatrix(
   int characterIndex
)
public:
ImGearPDFFixedMatrix^ GetMatrix(
   int characterIndex
)

Parameters

characterIndex
Index of the character whose text matrix is obtained.

Return Value

ImGearPDFFixedMatrix class object.
Remarks
The coordinates of text items are specified in text space. This method gets the matrix that defines the transformation from text space to the user space for individual text character. See section '5.3.1Text-Positioning Operators' of the PDF Reference for more details.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
Overload List
ImGearPDFFixedMatrix Class


GetState Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : GetState Method
Gets the text state of a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetState() As ImGearPDETextState
'Usage

Dim instance As ImGearPDETextItem
Dim value As ImGearPDETextState

value = instance.GetState()
public ImGearPDETextState GetState()
public: ImGearPDETextState* GetState();
public:
ImGearPDETextState^ GetState();

Return Value

ImGearPDETextState class object.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDETextState Class


RemoveChars Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : RemoveChars Method
Index of the first character to remove.
The number of characters to remove.
Removes contiguous characters from a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveChars( _
   ByVal startIndex As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As ImGearPDETextItem
Dim startIndex As Integer
Dim count As Integer

instance.RemoveChars(startIndex, count)
public void RemoveChars(
   int startIndex,
   int count
)
public: void RemoveChars(
   int startIndex,
   int count
)
public:
void RemoveChars(
   int startIndex,
   int count
)

Parameters

startIndex
Index of the first character to remove.
count
The number of characters to remove.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


ReplaceChars Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : ReplaceChars Method
Index position of the characters to replace.
Replacement text.
Replaces characters in a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReplaceChars( _
   ByVal startIndex As Integer, _
   ByVal text As String _
)
'Usage

Dim instance As ImGearPDETextItem
Dim startIndex As Integer
Dim text As String

instance.ReplaceChars(startIndex, text)
public void ReplaceChars(
   int startIndex,
   string text
)
public: void ReplaceChars(
   int startIndex,
   string* text
)
public:
void ReplaceChars(
   int startIndex,
   String^ text
)

Parameters

startIndex
Index position of the characters to replace.
text
Replacement text.
Remarks
This method does not change the number of characters in the text item--extra characters are ignored.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


ReplaceText Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : ReplaceText Method
Replacement text.
Replaces all of the text in a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReplaceText( _
   ByVal text As String _
)
'Usage

Dim instance As ImGearPDETextItem
Dim text As String

instance.ReplaceText(text)
public void ReplaceText(
   string text
)
public: void ReplaceText(
   string* text
)
public:
void ReplaceText(
   String^ text
)

Parameters

text
Replacement text.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


SetFont Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : SetFont Method
Font set for a text item.
Sets a font for a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetFont( _
   ByVal font As ImGearPDEFont _
)
'Usage

Dim instance As ImGearPDETextItem
Dim font As ImGearPDEFont

instance.SetFont(font)
public void SetFont(
   ImGearPDEFont font
)
public: void SetFont(
   ImGearPDEFont* font
)
public:
void SetFont(
   ImGearPDEFont^ font
)

Parameters

font
Font set for a text item.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDEFont Class


SetGState Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : SetGState Method
The graphics state information to set.
Sets the graphics state of a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub SetGState( _
   ByVal graphicsState As ImGearPDEGraphicState _
)
'Usage

Dim instance As ImGearPDETextItem
Dim graphicsState As ImGearPDEGraphicState

instance.SetGState(graphicsState)
public new void SetGState(
   ImGearPDEGraphicState graphicsState
)
public: new void SetGState(
   ImGearPDEGraphicState* graphicsState
)
public:
new void SetGState(
   ImGearPDEGraphicState^ graphicsState
)

Parameters

graphicsState
The graphics state information to set.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDEGraphicState Class


SetMatrix Method (ImGearPDETextItem)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : SetMatrix Method
The new text matrix of the text item.
Sets the matrix that defines the transformation from text space to the user space for individual text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub SetMatrix( _
   ByVal matrix As ImGearPDFFixedMatrix _
)
'Usage

Dim instance As ImGearPDETextItem
Dim matrix As ImGearPDFFixedMatrix

instance.SetMatrix(matrix)
public new void SetMatrix(
   ImGearPDFFixedMatrix matrix
)
public: new void SetMatrix(
   ImGearPDFFixedMatrix* matrix
)
public:
new void SetMatrix(
   ImGearPDFFixedMatrix^ matrix
)

Parameters

matrix
The new text matrix of the text item.
Remarks
The coordinates of text items are specified in text space. This method sets the matrix that defines the transformation from text space to the user space for individual text item. See section '5.3.1 Text-Positioning Operators' of the PDF Reference for more details.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDFFixedMatrix Class


SetState Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : SetState Method
With new text state of the text item.
Sets the text state of a text item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetState( _
   ByVal textState As ImGearPDETextState _
)
'Usage

Dim instance As ImGearPDETextItem
Dim textState As ImGearPDETextState

instance.SetState(textState)
public void SetState(
   ImGearPDETextState textState
)
public: void SetState(
   ImGearPDETextState* textState
)
public:
void SetState(
   ImGearPDETextState^ textState
)

Parameters

textState
With new text state of the text item.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members
ImGearPDETextState Class


%%PageItemTitle%% $$Properties$$

ImGearPDETextItem Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextItem Class

For a list of all members of this type, see ImGearPDETextItem members.

Public Properties
 | Name | Description
Public Property | TextLength | Gets a text length for a text item, in bytes.
Top
See Also

Reference

ImGearPDETextItem Class
ImageGear.Formats.PDF Namespace


TextLength Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextItem Class : TextLength Property
Gets a text length for a text item, in bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextLength As Integer
'Usage

Dim instance As ImGearPDETextItem
Dim value As Integer

value = instance.TextLength
public int TextLength {get;}
public: __property int get_TextLength();
public:
property int TextLength {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDETextItem Class
ImGearPDETextItem Members


%%PageItemTitle%%

ImGearPDETextState Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextState Class
Provides attributes of a PDE text element.
Object Model
ImGearPDETextState Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDETextState
'Usage

Dim instance As ImGearPDETextState
public sealed class ImGearPDETextState
public __gc __sealed class ImGearPDETextState
public ref class ImGearPDETextState sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDETextState

See Also

Reference

ImGearPDETextState Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDETextState Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextState Class

The following tables list the members exposed by ImGearPDETextState.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDETextState Constructor | Initializes a new instance of the ImGearPDETextState class.
Top
Public Fields
 | Name | Description
Public Field | CharSpacing | Character spacing was set, corresponding to the Tc operator.
Public Field | FontSize | Font size.
Public Field | RenderMode | Text rendering mode, corresponding to the Tr operator.
Public Field | Scale | Scale in percents.
Public Field | TextRise | Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location.
Public Field | WasSetFlags | Indicates if an attribute has been set.
Public Field | WordSpacing | Word spacing, corresponding to the Tw operator.
Top
See Also

Reference

ImGearPDETextState Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDETextState Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : ImGearPDETextState Constructor
Initializes a new instance of the ImGearPDETextState class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDETextState()
public ImGearPDETextState()
public: ImGearPDETextState();
public:
ImGearPDETextState();
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


%%PageItemTitle%% $$Fields$$

ImGearPDETextState Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextState Class

For a list of all members of this type, see ImGearPDETextState members.

Public Fields
 | Name | Description
Public Field | CharSpacing | Character spacing was set, corresponding to the Tc operator.
Public Field | FontSize | Font size.
Public Field | RenderMode | Text rendering mode, corresponding to the Tr operator.
Public Field | Scale | Scale in percents.
Public Field | TextRise | Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location.
Public Field | WasSetFlags | Indicates if an attribute has been set.
Public Field | WordSpacing | Word spacing, corresponding to the Tw operator.
Top
See Also

Reference

ImGearPDETextState Class
ImageGear.Formats.PDF Namespace


CharSpacing Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : CharSpacing Field
Character spacing was set, corresponding to the Tc operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CharSpacing As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.CharSpacing

instance.CharSpacing = value
public int CharSpacing
public: int CharSpacing
public:
int CharSpacing

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


FontSize Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : FontSize Field
Font size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FontSize As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.FontSize

instance.FontSize = value
public int FontSize
public: int FontSize
public:
int FontSize

Field Value

Integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


RenderMode Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : RenderMode Field
Text rendering mode, corresponding to the Tr operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public RenderMode As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.RenderMode

instance.RenderMode = value
public int RenderMode
public: int RenderMode
public:
int RenderMode

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


Scale Field (ImGearPDETextState)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : Scale Field
Scale in percents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Scale As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.Scale

instance.Scale = value
public int Scale
public: int Scale
public:
int Scale

Field Value

Integer value.
Remarks
The default value is 100.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


TextRise Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : TextRise Field
Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public TextRise As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.TextRise

instance.TextRise = value
public int TextRise
public: int TextRise
public:
int TextRise

Field Value

Integer number.
Remarks
See Section 5.2.6 in the PDF Reference. The default value is 0.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


WasSetFlags Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : WasSetFlags Field
Indicates if an attribute has been set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WasSetFlags As ImGearPDEGraphicStateWasSetFlags
'Usage

Dim instance As ImGearPDETextState
Dim value As ImGearPDEGraphicStateWasSetFlags

value = instance.WasSetFlags

instance.WasSetFlags = value
public ImGearPDEGraphicStateWasSetFlags WasSetFlags
public: ImGearPDEGraphicStateWasSetFlags WasSetFlags
public:
ImGearPDEGraphicStateWasSetFlags WasSetFlags

Field Value

ImGearPDEGraphicStateWasSetFlags enumeration value.
Remarks
Support for these flags is not complete. For compatibility, you should set them, but do not depend on reading their values back. The intended use is with XObject Forms to indicate whether the value is inherited or explicitly set. The default value is 0.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members
ImGearPDEGraphicStateWasSetFlags Enumeration


WordSpacing Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDETextState Class : WordSpacing Field
Word spacing, corresponding to the Tw operator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WordSpacing As Integer
'Usage

Dim instance As ImGearPDETextState
Dim value As Integer

value = instance.WordSpacing

instance.WordSpacing = value
public int WordSpacing
public: int WordSpacing
public:
int WordSpacing

Field Value

Integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDETextState Class
ImGearPDETextState Members


%%PageItemTitle%%

ImGearPDEXGroup Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXGroup Class
Represents a transparency (XGroup) resource.
Object Model
ImGearPDEXGroup ClassImGearPDEColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEXGroup
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEXGroup
public sealed class ImGearPDEXGroup : ImGearPDEElement
public __gc __sealed class ImGearPDEXGroup : public ImGearPDEElement
public ref class ImGearPDEXGroup sealed : public ImGearPDEElement
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEXGroup

See Also

Reference

ImGearPDEXGroup Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEXGroup Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXGroup Class

The following tables list the members exposed by ImGearPDEXGroup.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEXGroup Constructor | Initializes a new instance of the ImGearPDEXGroup class.
Top
Public Properties
 | Name | Description
Public Property | Isolated | Gets or sets a value indicating whether the XGroup is isolated.
Public Property | Knockout | Gets or sets a value indicating whether the transparency group is knockouted.
Top
Public Methods
 | Name | Description
Public Method | GetColorSpace | Acquires the color space of the transparency group.
Public Method | SetColorSpace | Sets the color space for the XGroup.
Top
See Also

Reference

ImGearPDEXGroup Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEXGroup Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : ImGearPDEXGroup Constructor
The document in which the object will be created.
ImGearPDEXGroupCreateFlags value.
Initializes a new instance of the ImGearPDEXGroup class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal options As ImGearPDEXGroupCreateFlags _
)
'Usage

Dim document As ImGearPDFDocument
Dim options As ImGearPDEXGroupCreateFlags

Dim instance As New ImGearPDEXGroup(document, options)
public ImGearPDEXGroup(
   ImGearPDFDocument document,
   ImGearPDEXGroupCreateFlags options
)
public: ImGearPDEXGroup(
   ImGearPDFDocument* document,
   ImGearPDEXGroupCreateFlags options
)
public:
ImGearPDEXGroup(
   ImGearPDFDocument^ document,
   ImGearPDEXGroupCreateFlags options
)

Parameters

document
The document in which the object will be created.
options
ImGearPDEXGroupCreateFlags value.

Return Value

The new instance of ImGearPDEXGroup class object.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members
ImGearPDFDocument Class
ImGearPDEXGroupCreateFlags Enumeration


%%PageItemTitle%% $$Methods$$

ImGearPDEXGroup Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXGroup Class

For a list of all members of this type, see ImGearPDEXGroup members.

Public Methods
 | Name | Description
Public Method | GetColorSpace | Acquires the color space of the transparency group.
Public Method | SetColorSpace | Sets the color space for the XGroup.
Top
See Also

Reference

ImGearPDEXGroup Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEXGroup Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : ImGearPDEXGroup Constructor
Overload List
Overload | Description
ImGearPDEXGroup Constructor | Initializes a new instance of the ImGearPDEXGroup class.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members


GetColorSpace Method (ImGearPDEXGroup)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : GetColorSpace Method
Acquires the color space of the transparency group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorSpace() As ImGearPDEColorSpace
'Usage

Dim instance As ImGearPDEXGroup
Dim value As ImGearPDEColorSpace

value = instance.GetColorSpace()
public ImGearPDEColorSpace GetColorSpace()
public: ImGearPDEColorSpace* GetColorSpace();
public:
ImGearPDEColorSpace^ GetColorSpace();

Return Value

ImGearPDEColorSpace class object.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members
ImGearPDEColorSpace Class


SetColorSpace Method (ImGearPDEXGroup)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : SetColorSpace Method
The color space to associate with the XGroup.
Sets the color space for the XGroup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetColorSpace( _
   ByVal colorSpace As ImGearPDEColorSpace _
)
'Usage

Dim instance As ImGearPDEXGroup
Dim colorSpace As ImGearPDEColorSpace

instance.SetColorSpace(colorSpace)
public void SetColorSpace(
   ImGearPDEColorSpace colorSpace
)
public: void SetColorSpace(
   ImGearPDEColorSpace* colorSpace
)
public:
void SetColorSpace(
   ImGearPDEColorSpace^ colorSpace
)

Parameters

colorSpace
The color space to associate with the XGroup.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members
ImGearPDEColorSpace Class


%%PageItemTitle%% $$Properties$$

ImGearPDEXGroup Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXGroup Class

For a list of all members of this type, see ImGearPDEXGroup members.

Public Properties
 | Name | Description
Public Property | Isolated | Gets or sets a value indicating whether the XGroup is isolated.
Public Property | Knockout | Gets or sets a value indicating whether the transparency group is knockouted.
Top
See Also

Reference

ImGearPDEXGroup Class
ImageGear.Formats.PDF Namespace


Isolated Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : Isolated Property
Gets or sets a value indicating whether the XGroup is isolated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Isolated As Boolean
'Usage

Dim instance As ImGearPDEXGroup
Dim value As Boolean

instance.Isolated = value

value = instance.Isolated
public bool Isolated {get; set;}
public: __property bool get_Isolated();
public: __property void set_Isolated(
   bool value
);
public:
property bool Isolated {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Corresponds to the /I key within the XGroup's dictionary.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members


Knockout Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXGroup Class : Knockout Property
Gets or sets a value indicating whether the transparency group is knockouted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Knockout As Boolean
'Usage

Dim instance As ImGearPDEXGroup
Dim value As Boolean

instance.Knockout = value

value = instance.Knockout
public bool Knockout {get; set;}
public: __property bool get_Knockout();
public: __property void set_Knockout(
   bool value
);
public:
property bool Knockout {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDEXGroup Class
ImGearPDEXGroup Members


%%PageItemTitle%%

ImGearPDEXObject Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXObject Class
Represents an arbitrary XObject.
Object Model
ImGearPDEXObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEXObject
   Inherits ImGearPDEElement
'Usage

Dim instance As ImGearPDEXObject
public sealed class ImGearPDEXObject : ImGearPDEElement
public __gc __sealed class ImGearPDEXObject : public ImGearPDEElement
public ref class ImGearPDEXObject sealed : public ImGearPDEElement
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDEElement
ImageGear.Formats.PDF.ImGearPDEXObject

See Also

Reference

ImGearPDEXObject Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEXObject Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXObject Class

The following tables list the members exposed by ImGearPDEXObject.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEXObject Constructor | Initializes a new instance of the ImGearPDEXObject class.
Top
See Also

Reference

ImGearPDEXObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDEXObject Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXObject Class

For a list of all members of this type, see ImGearPDEXObject members.

See Also

Reference

ImGearPDEXObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDEXObject Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXObject Class

For a list of all members of this type, see ImGearPDEXObject members.

See Also

Reference

ImGearPDEXObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEXObject Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXObject Class : ImGearPDEXObject Constructor
Overload List
Overload | Description
ImGearPDEXObject Constructor | Initializes a new instance of the ImGearPDEXObject class.
See Also

Reference

ImGearPDEXObject Class
ImGearPDEXObject Members


%%PageItemTitle%%

ImGearPDEXObject Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXObject Class : ImGearPDEXObject Constructor
Basic PDF object.
Initializes a new instance of the ImGearPDEXObject class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As ImGearPDFBasObj _
)
'Usage

Dim value As ImGearPDFBasObj

Dim instance As New ImGearPDEXObject(value)
public ImGearPDEXObject(
   ImGearPDFBasObj value
)
public: ImGearPDEXObject(
   ImGearPDFBasObj* value
)
public:
ImGearPDEXObject(
   ImGearPDFBasObj^ value
)

Parameters

value
Basic PDF object.

Return Value

The new instance of ImGearPDEXObject class object.
Remarks
This constructor creates new instance of ImGearPDEXObject object.
See Also

Reference

ImGearPDEXObject Class
ImGearPDEXObject Members
ImGearPDFBasObj Class


%%PageItemTitle%%

ImGearPDEXYZColor Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXYZColor Class
Represents XYZ color data.
Object Model
ImGearPDEXYZColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDEXYZColor
'Usage

Dim instance As ImGearPDEXYZColor
public sealed class ImGearPDEXYZColor
public __gc __sealed class ImGearPDEXYZColor
public ref class ImGearPDEXYZColor sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDEXYZColor

See Also

Reference

ImGearPDEXYZColor Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDEXYZColor Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXYZColor Class

The following tables list the members exposed by ImGearPDEXYZColor.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDEXYZColor Constructor | Initializes a new instance of the ImGearPDEXYZColor class.
Top
Public Fields
 | Name | Description
Public Field | X | X color value.
Public Field | Y | Y color value.
Public Field | Z | Z color value.
Top
See Also

Reference

ImGearPDEXYZColor Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEXYZColor Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXYZColor Class : ImGearPDEXYZColor Constructor
Initializes a new instance of the ImGearPDEXYZColor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDEXYZColor()
public ImGearPDEXYZColor()
public: ImGearPDEXYZColor();
public:
ImGearPDEXYZColor();
See Also

Reference

ImGearPDEXYZColor Class
ImGearPDEXYZColor Members


%%PageItemTitle%% $$Fields$$

ImGearPDEXYZColor Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXYZColor Class

For a list of all members of this type, see ImGearPDEXYZColor members.

Public Fields
 | Name | Description
Public Field | X | X color value.
Public Field | Y | Y color value.
Public Field | Z | Z color value.
Top
See Also

Reference

ImGearPDEXYZColor Class
ImageGear.Formats.PDF Namespace


X Field (ImGearPDEXYZColor)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXYZColor Class : X Field
X color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public X As Single
'Usage

Dim instance As ImGearPDEXYZColor
Dim value As Single

value = instance.X

instance.X = value
public float X
public: float X
public:
float X

Field Value

Float value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEXYZColor Class
ImGearPDEXYZColor Members


Y Field (ImGearPDEXYZColor)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXYZColor Class : Y Field
Y color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Y As Single
'Usage

Dim instance As ImGearPDEXYZColor
Dim value As Single

value = instance.Y

instance.Y = value
public float Y
public: float Y
public:
float Y

Field Value

Float value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEXYZColor Class
ImGearPDEXYZColor Members


Z Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDEXYZColor Class : Z Field
Z color value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Z As Single
'Usage

Dim instance As ImGearPDEXYZColor
Dim value As Single

value = instance.Z

instance.Z = value
public float Z
public: float Z
public:
float Z

Field Value

Float value.
Remarks
The default value is 0.
See Also

Reference

ImGearPDEXYZColor Class
ImGearPDEXYZColor Members


%%PageItemTitle%%

ImGearPDF Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDF Class
Provides general PDF functionality and access to the global properties and methods.
Object Model
ImGearPDF ClassIImGearFormat InterfaceIImGearFormat InterfaceImGearPDEGraphicState Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDF
'Usage

Dim instance As ImGearPDF
public sealed class ImGearPDF
public __gc __sealed class ImGearPDF
public ref class ImGearPDF sealed
Remarks
Allows to create, initialize and terminate PDF and PS formats.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDF

See Also

Reference

ImGearPDF Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDF Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDF Class

The following tables list the members exposed by ImGearPDF.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDF Constructor | Initializes a new instance of the ImGearPDF class.
Top
Public Properties
 | Name | Description
Public Property | HostEncoding | Gets a flag that indicate what kind of host encoding a system uses.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreatePDFFormat | Overloaded. Creates an instance of PDF format.
static (Shared in Visual Basic) | CreatePSFormat | Overloaded. Creates an instance of PS format.
static (Shared in Visual Basic) | DoubleToFixed | Converts double value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | FixedRoundToInt | Converts fixed value to an integer, rounding it to the nearest integer value and returns it.
static (Shared in Visual Basic) | FixedRoundToShort | Converts fixed value to an integer.
static (Shared in Visual Basic) | FixedToDouble | Converts fixed value to a double value and returns it.
static (Shared in Visual Basic) | FixedTruncToInt | Converts fixed value to an integer, truncating it to the next lower integer value and returns it.
static (Shared in Visual Basic) | FixedTruncToShort | Converts fixed value to an integer, truncating it to the next lower short integer value and returns it.
static (Shared in Visual Basic) | GetDefaultGraphicState | Gets default graphic state attributes.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes PDF and PS libraries.
static (Shared in Visual Basic) | IntToFixed | Converts integer value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | ShortToFixed | Converts short value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | Terminate | Terminates PDF and PS libraries.
Top
See Also

Reference

ImGearPDF Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDF Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : ImGearPDF Constructor
Initializes a new instance of the ImGearPDF class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDF()
public ImGearPDF()
public: ImGearPDF();
public:
ImGearPDF();
See Also

Reference

ImGearPDF Class
ImGearPDF Members


%%PageItemTitle%% $$Methods$$

ImGearPDF Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDF Class

For a list of all members of this type, see ImGearPDF members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreatePDFFormat | Overloaded. Creates an instance of PDF format.
static (Shared in Visual Basic) | CreatePSFormat | Overloaded. Creates an instance of PS format.
static (Shared in Visual Basic) | DoubleToFixed | Converts double value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | FixedRoundToInt | Converts fixed value to an integer, rounding it to the nearest integer value and returns it.
static (Shared in Visual Basic) | FixedRoundToShort | Converts fixed value to an integer.
static (Shared in Visual Basic) | FixedToDouble | Converts fixed value to a double value and returns it.
static (Shared in Visual Basic) | FixedTruncToInt | Converts fixed value to an integer, truncating it to the next lower integer value and returns it.
static (Shared in Visual Basic) | FixedTruncToShort | Converts fixed value to an integer, truncating it to the next lower short integer value and returns it.
static (Shared in Visual Basic) | GetDefaultGraphicState | Gets default graphic state attributes.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes PDF and PS libraries.
static (Shared in Visual Basic) | IntToFixed | Converts integer value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | ShortToFixed | Converts short value to a PDF fixed value and returns it.
static (Shared in Visual Basic) | Terminate | Terminates PDF and PS libraries.
Top
See Also

Reference

ImGearPDF Class
ImageGear.Formats.PDF Namespace


CreatePDFFormat Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : CreatePDFFormat Method
Creates an instance of PDF format.
Overload List
Overload | Description
CreatePDFFormat() | Creates an instance of PDF format.
CreatePDFFormat(String) | Creates an instance of PDF format.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


CreatePDFFormat() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > CreatePDFFormat Method : CreatePDFFormat() Method
Creates an instance of PDF format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreatePDFFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearPDF.CreatePDFFormat()
public static IImGearFormat CreatePDFFormat()
public: static IImGearFormat* CreatePDFFormat();
public:
static IImGearFormat^ CreatePDFFormat();

Return Value

New instance of PDF format.
See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
IImGearFormat Interface


CreatePDFFormat(String) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > CreatePDFFormat Method : CreatePDFFormat(String) Method
Path to load PDF native libraries from.
Creates an instance of PDF format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreatePDFFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearPDF.CreatePDFFormat(libraryPath)
public static IImGearFormat CreatePDFFormat(
   string libraryPath
)
public: static IImGearFormat* CreatePDFFormat(
   string* libraryPath
)
public:
static IImGearFormat^ CreatePDFFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to load PDF native libraries from.

Return Value

New instance of PDF format.
Remarks
If libraryPath is blank than the current directory is used.
See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
IImGearFormat Interface


CreatePSFormat Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : CreatePSFormat Method
Creates an instance of PS format.
Overload List
Overload | Description
CreatePSFormat() | Creates an instance of PS format.
CreatePSFormat(String) | Creates an instance of PS format.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


CreatePSFormat() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > CreatePSFormat Method : CreatePSFormat() Method
Creates an instance of PS format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreatePSFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearPDF.CreatePSFormat()
public static IImGearFormat CreatePSFormat()
public: static IImGearFormat* CreatePSFormat();
public:
static IImGearFormat^ CreatePSFormat();

Return Value

New instance of PostScript format.
Remarks
PS support requires both ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(path)) and ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat(path)) calls be made before the call to ImGearPDF.Initialize(path).
See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
IImGearFormat Interface


CreatePSFormat(String) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > CreatePSFormat Method : CreatePSFormat(String) Method
Path to load PS native libraries from.
Creates an instance of PS format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreatePSFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearPDF.CreatePSFormat(libraryPath)
public static IImGearFormat CreatePSFormat(
   string libraryPath
)
public: static IImGearFormat* CreatePSFormat(
   string* libraryPath
)
public:
static IImGearFormat^ CreatePSFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to load PS native libraries from.

Return Value

New instance of PS format.
Remarks
If libraryPath is blank than the current directory is used. PS support requires both ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(path)) and ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat(path)) calls be made before the call to ImGearPDF.Initialize(path).
See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
IImGearFormat Interface


DoubleToFixed Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : DoubleToFixed Method
Double value to be converted to fixed.
Converts double value to a PDF fixed value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function DoubleToFixed( _
   ByVal value As Double _
) As Integer
'Usage

Dim value As Double
Dim value As Integer

value = ImGearPDF.DoubleToFixed(value)
public static int DoubleToFixed(
   double value
)
public: static int DoubleToFixed(
   double value
)
public:
static int DoubleToFixed(
   double value
)

Parameters

value
Double value to be converted to fixed.

Return Value

PDF fixed value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


FixedRoundToInt Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : FixedRoundToInt Method
Fixed value to be converted.
Converts fixed value to an integer, rounding it to the nearest integer value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FixedRoundToInt( _
   ByVal value As Integer _
) As Integer
'Usage

Dim value As Integer
Dim value As Integer

value = ImGearPDF.FixedRoundToInt(value)
public static int FixedRoundToInt(
   int value
)
public: static int FixedRoundToInt(
   int value
)
public:
static int FixedRoundToInt(
   int value
)

Parameters

value
Fixed value to be converted.

Return Value

Integer value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


FixedRoundToShort Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : FixedRoundToShort Method
Fixed value to be converted.
Converts fixed value to an integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FixedRoundToShort( _
   ByVal value As Integer _
) As Short
'Usage

Dim value As Integer
Dim value As Short

value = ImGearPDF.FixedRoundToShort(value)
public static short FixedRoundToShort(
   int value
)
public: static short FixedRoundToShort(
   int value
)
public:
static short FixedRoundToShort(
   int value
)

Parameters

value
Fixed value to be converted.

Return Value

Short integer value.
Remarks
Rounds a given fixed value to the nearest short integer value and returns it.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


FixedToDouble Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : FixedToDouble Method
Fixed value to be converted.
Converts fixed value to a double value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FixedToDouble( _
   ByVal value As Integer _
) As Double
'Usage

Dim value As Integer
Dim value As Double

value = ImGearPDF.FixedToDouble(value)
public static double FixedToDouble(
   int value
)
public: static double FixedToDouble(
   int value
)
public:
static double FixedToDouble(
   int value
)

Parameters

value
Fixed value to be converted.

Return Value

Double value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


FixedTruncToInt Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : FixedTruncToInt Method
Fixed value to be converted.
Converts fixed value to an integer, truncating it to the next lower integer value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FixedTruncToInt( _
   ByVal value As Integer _
) As Integer
'Usage

Dim value As Integer
Dim value As Integer

value = ImGearPDF.FixedTruncToInt(value)
public static int FixedTruncToInt(
   int value
)
public: static int FixedTruncToInt(
   int value
)
public:
static int FixedTruncToInt(
   int value
)

Parameters

value
Fixed value to be converted.

Return Value

Integer value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


FixedTruncToShort Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : FixedTruncToShort Method
Fixed value to be converted.
Converts fixed value to an integer, truncating it to the next lower short integer value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FixedTruncToShort( _
   ByVal value As Integer _
) As Short
'Usage

Dim value As Integer
Dim value As Short

value = ImGearPDF.FixedTruncToShort(value)
public static short FixedTruncToShort(
   int value
)
public: static short FixedTruncToShort(
   int value
)
public:
static short FixedTruncToShort(
   int value
)

Parameters

value
Fixed value to be converted.

Return Value

Short integer value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


GetDefaultGraphicState Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : GetDefaultGraphicState Method
Gets default graphic state attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetDefaultGraphicState() As ImGearPDEGraphicState
'Usage

Dim value As ImGearPDEGraphicState

value = ImGearPDF.GetDefaultGraphicState()
public static ImGearPDEGraphicState GetDefaultGraphicState()
public: static ImGearPDEGraphicState* GetDefaultGraphicState();
public:
static ImGearPDEGraphicState^ GetDefaultGraphicState();

Return Value

ImGearPDEGraphicState class object.
See Also

Reference

ImGearPDF Class
ImGearPDF Members
ImGearPDEGraphicState Class


Initialize Method (ImGearPDF)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : Initialize Method
Initializes PDF and PS libraries.
Overload List
Overload | Description
Initialize() | Initializes PDF and PS libraries.
Initialize(String) | Initializes PDF and PS libraries.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


Initialize() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > Initialize Method : Initialize() Method
Initializes PDF and PS libraries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Initialize()
'Usage

ImGearPDF.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks
This initialization method must be called for each thread in the multi-threaded application.

The resource content must be located in the same to ImageGear assembly place.

A call to an Initialize() method should be paired with a call to the Terminate method. The very first call to Initialize() will initialize the entire PDF library, while its paired call to Terminate method will de-initialize and release its memory. Multiple PDF initialization/termination pairs are supported in a multi-threaded PDF application, because it is required to initialize and terminate PDF in each child thread.

PS support requires both ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat()) and ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat()) calls be made before the call to ImGearPDF.Initialize().

See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
Terminate Method


Initialize(String) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class > Initialize Method : Initialize(String) Method
Path to PDF/PS library.
Initializes PDF and PS libraries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Initialize( _
   ByVal resourcePath As String _
)
'Usage

Dim resourcePath As String

ImGearPDF.Initialize(resourcePath)
public static void Initialize(
   string resourcePath
)
public: static void Initialize(
   string* resourcePath
)
public:
static void Initialize(
   String^ resourcePath
)

Parameters

resourcePath
Path to PDF/PS library.
Remarks
This initialization method must be called for each thread in the multi-threaded application.

A call to an Initialize() method should be paired with a call to the Terminate method. The very first call to Initialize() will initialize the entire PDF library, while its paired call to Terminate method will de-initialize and release its memory. Multiple PDF initialization/termination pairs are supported in a multi-threaded PDF application, because it is required to initialize and terminate PDF in each child thread.

PS support requires both ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(path)) and ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat(path)) calls be made before the call to ImGearPDF.Initialize(path).

See Also

Reference

ImGearPDF Class
ImGearPDF Members
Overload List
Terminate Method


IntToFixed Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : IntToFixed Method
Integer value to be converted.
Converts integer value to a PDF fixed value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function IntToFixed( _
   ByVal value As Integer _
) As Integer
'Usage

Dim value As Integer
Dim value As Integer

value = ImGearPDF.IntToFixed(value)
public static int IntToFixed(
   int value
)
public: static int IntToFixed(
   int value
)
public:
static int IntToFixed(
   int value
)

Parameters

value
Integer value to be converted.

Return Value

PDF fixed value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


ShortToFixed Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : ShortToFixed Method
Short value to be converted.
Converts short value to a PDF fixed value and returns it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ShortToFixed( _
   ByVal value As Short _
) As Integer
'Usage

Dim value As Short
Dim value As Integer

value = ImGearPDF.ShortToFixed(value)
public static int ShortToFixed(
   short value
)
public: static int ShortToFixed(
   short value
)
public:
static int ShortToFixed(
   short value
)

Parameters

value
Short value to be converted.

Return Value

PDF fixed value.
See Also

Reference

ImGearPDF Class
ImGearPDF Members


Terminate Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : Terminate Method
Terminates PDF and PS libraries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Terminate()
'Usage

ImGearPDF.Terminate()
public static void Terminate()
public: static void Terminate();
public:
static void Terminate();
Remarks
Must be paired with an Initialize() method. Call this method when the application is disposed.

A call to an Initialize() method should be paired with a call to the Terminate method. The very first call to Initialize() will initialize the entire PDF library, while its paired call to Terminate method will de-initialize and release its memory. Multiple PDF initialization/termination pairs are supported in a multi-threaded PDF application, because it is required to initialize and terminate PDF in each child thread.

See Also

Reference

ImGearPDF Class
ImGearPDF Members
Initialize Method


%%PageItemTitle%% $$Properties$$

ImGearPDF Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDF Class

For a list of all members of this type, see ImGearPDF members.

Public Properties
 | Name | Description
Public Property | HostEncoding | Gets a flag that indicate what kind of host encoding a system uses.
Top
See Also

Reference

ImGearPDF Class
ImageGear.Formats.PDF Namespace


HostEncoding Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDF Class : HostEncoding Property
Gets a flag that indicate what kind of host encoding a system uses.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HostEncoding As Integer
'Usage

Dim instance As ImGearPDF
Dim value As Integer

value = instance.HostEncoding
public int HostEncoding {get;}
public: __property int get_HostEncoding();
public:
property int HostEncoding {
   int get();
}

Property Value

Integer value.
Remarks
Allows you to determine whether a system is Roman or non-Roman. (Non-Roman is also known as CJK-capable, that is, capable of handling multi-byte character sets, such as Chinese, Japanese, or Korean.)

Host encoding is a platform-dependent encoding for the host machine. It is WinAnsiEncoding in Windows.

For non-Roman systems, the host encoding may be a variety of encodings, which are defined by a CMap (character map). See Section 5.6.4 in the PDF Reference for a list of predefined CMaps.

Use HostEncoding to determine if a system's host encoding is Roman or not. 0 for a Roman system; nonzero for a non-Roman system. Users should simply test whether this value is 0 or not.

See Also

Reference

ImGearPDF Class
ImGearPDF Members


%%PageItemTitle%%

ImGearPDFAction Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAction Class
Represents a task that performs when a user clicks on a link or a bookmark.
Object Model
ImGearPDFAction ClassImGearPDFDestination ClassImGearPDFBasDict ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFAction
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFAction
public sealed class ImGearPDFAction : ImGearPDFObject
public __gc __sealed class ImGearPDFAction : public ImGearPDFObject
public ref class ImGearPDFAction sealed : public ImGearPDFObject
Remarks
Action types include:
  • Going to another view within the same document
  • Going to a specified view in another PDF file
  • Launching an arbitrary file
  • Resolving a URL

See Section 8.5 in the PDF Reference for more information on actions.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFAction

See Also

Reference

ImGearPDFAction Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFAction Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAction Class

The following tables list the members exposed by ImGearPDFAction.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFAction Constructor | Overloaded. Initializes a new instance of the ImGearPDFAction class.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets action type.
Top
Public Methods
 | Name | Description
Public Method | GetDestination | Gets the action's destination view.
Public Method | GetDictionary | Gets the dictionary corresponding to the action.
Public Method | GetFileName | Gets a file name from the action.
Top
See Also

Reference

ImGearPDFAction Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFAction Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class : ImGearPDFAction Constructor
Initializes a new instance of the ImGearPDFAction class.
Overload List
Overload | Description
ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom) | Initializes a new instance of the ImGearPDFAction class.
ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFDestination) | Initializes a new instance of the ImGearPDFAction class.
ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom,String) | Initializes a new instance of the ImGearPDFAction class.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members


%%PageItemTitle%%

ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class > ImGearPDFAction Constructor : ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom)
PDF document.
PDF atom type.
Initializes a new instance of the ImGearPDFAction class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal type As ImGearPDFAtom _
)
'Usage

Dim document As ImGearPDFDocument
Dim type As ImGearPDFAtom

Dim instance As New ImGearPDFAction(document, type)
public ImGearPDFAction(
   ImGearPDFDocument document,
   ImGearPDFAtom type
)
public: ImGearPDFAction(
   ImGearPDFDocument* document,
   ImGearPDFAtom* type
)
public:
ImGearPDFAction(
   ImGearPDFDocument^ document,
   ImGearPDFAtom^ type
)

Parameters

document
PDF document.
type
PDF atom type.

Return Value

The new instance of ImGearPDFAction class object.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
Overload List
ImGearPDFDocument Class
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class > ImGearPDFAction Constructor : ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFDestination)
PDF document.
Destination view.
Initializes a new instance of the ImGearPDFAction class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal destination As ImGearPDFDestination _
)
'Usage

Dim document As ImGearPDFDocument
Dim destination As ImGearPDFDestination

Dim instance As New ImGearPDFAction(document, destination)
public ImGearPDFAction(
   ImGearPDFDocument document,
   ImGearPDFDestination destination
)
public: ImGearPDFAction(
   ImGearPDFDocument* document,
   ImGearPDFDestination* destination
)
public:
ImGearPDFAction(
   ImGearPDFDocument^ document,
   ImGearPDFDestination^ destination
)

Parameters

document
PDF document.
destination
Destination view.

Return Value

The new instance of ImGearPDFAction class object.
Remarks
This constructor creates a new action that takes the user to the specified destination view. This method can only be used for destinations in the same document as the source document. Cross-document links must be built up from the base level, populating the Action dictionary for the GotoR action as described in Section 8.5.3 in the PDF Reference.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
Overload List
ImGearPDFDocument Class
ImGearPDFDestination Class


%%PageItemTitle%%

ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom,String)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class > ImGearPDFAction Constructor : ImGearPDFAction Constructor(ImGearPDFDocument,ImGearPDFAtom,String)
PDF document.
PDF atom type.
The file name.
Initializes a new instance of the ImGearPDFAction class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal type As ImGearPDFAtom, _
   ByVal fileName As String _
)
'Usage

Dim document As ImGearPDFDocument
Dim type As ImGearPDFAtom
Dim fileName As String

Dim instance As New ImGearPDFAction(document, type, fileName)
public ImGearPDFAction(
   ImGearPDFDocument document,
   ImGearPDFAtom type,
   string fileName
)
public: ImGearPDFAction(
   ImGearPDFDocument* document,
   ImGearPDFAtom* type,
   string* fileName
)
public:
ImGearPDFAction(
   ImGearPDFDocument^ document,
   ImGearPDFAtom^ type,
   String^ fileName
)

Parameters

document
PDF document.
type
PDF atom type.
fileName
The file name.

Return Value

The new instance of ImGearPDFAction class object.
Remarks
This constructor creates an action of the specified type from a file name.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
Overload List
ImGearPDFDocument Class
ImGearPDFAtom Class


%%PageItemTitle%% $$Methods$$

ImGearPDFAction Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAction Class

For a list of all members of this type, see ImGearPDFAction members.

Public Methods
 | Name | Description
Public Method | GetDestination | Gets the action's destination view.
Public Method | GetDictionary | Gets the dictionary corresponding to the action.
Public Method | GetFileName | Gets a file name from the action.
Top
See Also

Reference

ImGearPDFAction Class
ImageGear.Formats.PDF Namespace


GetDestination Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class : GetDestination Method
Gets the action's destination view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDestination() As ImGearPDFDestination
'Usage

Dim instance As ImGearPDFAction
Dim value As ImGearPDFDestination

value = instance.GetDestination()
public ImGearPDFDestination GetDestination()
public: ImGearPDFDestination* GetDestination();
public:
ImGearPDFDestination^ GetDestination();

Return Value

The action's destination, which may be either an explicit or named (basic string or name object). Use the ImGearPDFDestination.Resolve on this returned value to obtain an explicit destination.
Remarks
This only works for actions that contain a view destination - that is, actions whose type is GoTo. For named destinations, this method may return a basic string or name object. See Section 8.2.1 in the PDF Reference for more information on named destinations.

Since this method may not return an explicit destination, use the ImGearPDFDestination.Resolve on the returned value to obtain an explicit destination.

See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
ImGearPDFDestination Class


GetDictionary Method (ImGearPDFAction)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class : GetDictionary Method
Gets the dictionary corresponding to the action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDFAction
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public ImGearPDFBasDict GetDictionary()
public: ImGearPDFBasDict* GetDictionary();
public:
ImGearPDFBasDict^ GetDictionary();

Return Value

Dictionary object for the action.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
ImGearPDFBasDict Class


GetFileName Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class : GetFileName Method
Gets a file name from the action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFileName() As String
'Usage

Dim instance As ImGearPDFAction
Dim value As String

value = instance.GetFileName()
public string GetFileName()
public: string* GetFileName();
public:
String^ GetFileName();

Return Value

The action's file name.
Remarks
Not all types of actions have file names; this method only works for actions that contain a file specification. See Section 8.5 in the PDF Reference for more information on the contents of various types of actions.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members


%%PageItemTitle%% $$Properties$$

ImGearPDFAction Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAction Class

For a list of all members of this type, see ImGearPDFAction members.

Public Properties
 | Name | Description
Public Property | Type | Gets action type.
Top
See Also

Reference

ImGearPDFAction Class
ImageGear.Formats.PDF Namespace


Type Property (ImGearPDFAction)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAction Class : Type Property
Gets action type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFAction
Dim value As ImGearPDFAtom

value = instance.Type
public ImGearPDFAtom Type {get;}
public: __property ImGearPDFAtom* get_Type();
public:
property ImGearPDFAtom^ Type {
   ImGearPDFAtom^ get();
}

Property Value

The atom corresponding to the action's type.
See Also

Reference

ImGearPDFAction Class
ImGearPDFAction Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFAtom Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAtom Class
Represents a hashed token used in place of strings to optimize performance.
Object Model
ImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPDFAtom
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFAtom
public class ImGearPDFAtom : ImGearPDFObject
public __gc class ImGearPDFAtom : public ImGearPDFObject
public ref class ImGearPDFAtom : public ImGearPDFObject
Remarks
It is much faster to compare Atoms than strings.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFAtom

See Also

Reference

ImGearPDFAtom Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFAtom Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAtom Class

The following tables list the members exposed by ImGearPDFAtom.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFAtom Constructor | Overloaded. Initializes a new instance of the ImGearPDFAtom class.
Top
Public Properties
 | Name | Description
Public Property | String | Gets or sets the string corresponding to the atom.
Top
See Also

Reference

ImGearPDFAtom Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFAtom Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAtom Class : ImGearPDFAtom Constructor
Initializes a new instance of the ImGearPDFAtom class.
Overload List
Overload | Description
ImGearPDFAtom Constructor() | Initializes a new instance of the ImGearPDFAtom class.
ImGearPDFAtom Constructor(String) | Initializes a new instance of the ImGearPDFAtom class.
See Also

Reference

ImGearPDFAtom Class
ImGearPDFAtom Members


%%PageItemTitle%%

ImGearPDFAtom Constructor()

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAtom Class > ImGearPDFAtom Constructor : ImGearPDFAtom Constructor()
Initializes a new instance of the ImGearPDFAtom class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFAtom()
public ImGearPDFAtom()
public: ImGearPDFAtom();
public:
ImGearPDFAtom();

Return Value

The new instance of ImGearPDFAtom class.
See Also

Reference

ImGearPDFAtom Class
ImGearPDFAtom Members
Overload List


%%PageItemTitle%%

ImGearPDFAtom Constructor(String)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAtom Class > ImGearPDFAtom Constructor : ImGearPDFAtom Constructor(String)
The string corresponding to the atom.
Initializes a new instance of the ImGearPDFAtom class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New ImGearPDFAtom(value)
public ImGearPDFAtom(
   string value
)
public: ImGearPDFAtom(
   string* value
)
public:
ImGearPDFAtom(
   String^ value
)

Parameters

value
The string corresponding to the atom.

Return Value

The new instance of ImGearPDFAtom class.
See Also

Reference

ImGearPDFAtom Class
ImGearPDFAtom Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearPDFAtom Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAtom Class

For a list of all members of this type, see ImGearPDFAtom members.

Public Properties
 | Name | Description
Public Property | String | Gets or sets the string corresponding to the atom.
Top
See Also

Reference

ImGearPDFAtom Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFAtom Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFAtom Class

For a list of all members of this type, see ImGearPDFAtom members.

See Also

Reference

ImGearPDFAtom Class
ImageGear.Formats.PDF Namespace


String Property (ImGearPDFAtom)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFAtom Class : String Property
Gets or sets the string corresponding to the atom.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property String As String
'Usage

Dim instance As ImGearPDFAtom
Dim value As String

instance.String = value

value = instance.String
public string String {get; set;}
public: __property string* get_String();
public: __property void set_String(
   string* value
);
public:
property String^ String {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPDFAtom Class
ImGearPDFAtom Members


%%PageItemTitle%%

ImGearPDFBasArray Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasArray Class
Represents basic array object.
Object Model
ImGearPDFBasArray ClassImGearPDFBasObj Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasArray
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasArray
public sealed class ImGearPDFBasArray : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasArray : public ImGearPDFBasObj
public ref class ImGearPDFBasArray sealed : public ImGearPDFBasObj
Remarks
Array is a one-dimensional collection of objects arranged sequentially. Unlike arrays in many other computer languages, PDF arrays may be heterogeneous; that is, an array's elements may be any combination of numbers, strings, dictionaries, or any other objects, including other arrays.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasArray

See Also

Reference

ImGearPDFBasArray Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasArray Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasArray Class

The following tables list the members exposed by ImGearPDFBasArray.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasArray Constructor | Initializes a new instance of the ImGearPDFBasArray class.
Top
Public Properties
 | Name | Description
Public Property | Length | Gets the number of elements in the array.
Top
Public Methods
 | Name | Description
Public Method | Get | Gets the specified element from an array.
Public Method | Put | Puts the specified object into the specified location in an array.
Public Method | PutBool | Puts the specified boolean value into the specified location in an array.
Public Method | PutFixed | Puts the specified fixed value into the specified location in an array.
Public Method | PutInt | Puts the specified integer value into the specified location in an array.
Public Method | PutName | Puts the name value into the specified location in an array.
Public Method | Remove | Finds the first element, if any, equal to the specified object and removes it from the array.
Public Method | RemoveAt | Removes element at index.
Top
See Also

Reference

ImGearPDFBasArray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasArray Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : ImGearPDFBasArray Constructor
The document in which the array is used.
If True, creates the array as an indirect object. If False, creates the array as a direct object.
Number of entries in the array. This value is only a hint - the arrays grow dynamically as needed.
Initializes a new instance of the ImGearPDFBasArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal length As UInteger _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim length As UInteger

Dim instance As New ImGearPDFBasArray(document, isIndirect, length)
public ImGearPDFBasArray(
   ImGearPDFDocument document,
   bool isIndirect,
   uint length
)
public: ImGearPDFBasArray(
   ImGearPDFDocument* document,
   bool isIndirect,
   uint length
)
public:
ImGearPDFBasArray(
   ImGearPDFDocument^ document,
   bool isIndirect,
   uint length
)

Parameters

document
The document in which the array is used.
isIndirect
If True, creates the array as an indirect object. If False, creates the array as a direct object.
length
Number of entries in the array. This value is only a hint - the arrays grow dynamically as needed.

Return Value

The new instance of ImGearPDFBasArray class object.
Remarks
This constructor creates a new array object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Methods$$

ImGearPDFBasArray Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasArray Class

For a list of all members of this type, see ImGearPDFBasArray members.

Public Methods
 | Name | Description
Public Method | Get | Gets the specified element from an array.
Public Method | Put | Puts the specified object into the specified location in an array.
Public Method | PutBool | Puts the specified boolean value into the specified location in an array.
Public Method | PutFixed | Puts the specified fixed value into the specified location in an array.
Public Method | PutInt | Puts the specified integer value into the specified location in an array.
Public Method | PutName | Puts the name value into the specified location in an array.
Public Method | Remove | Finds the first element, if any, equal to the specified object and removes it from the array.
Public Method | RemoveAt | Removes element at index.
Top
See Also

Reference

ImGearPDFBasArray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasArray Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : ImGearPDFBasArray Constructor
Overload List
Overload | Description
ImGearPDFBasArray Constructor | Initializes a new instance of the ImGearPDFBasArray class.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members


Get Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : Get Method
Index of an element to get. The first element in an array has an index of zero.
Gets the specified element from an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Get( _
   ByVal index As UInteger _
) As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasArray
Dim index As UInteger
Dim value As ImGearPDFBasObj

value = instance.Get(index)
public ImGearPDFBasObj Get(
   uint index
)
public: ImGearPDFBasObj* Get(
   uint index
)
public:
ImGearPDFBasObj^ Get(
   uint index
)

Parameters

index
Index of an element to get. The first element in an array has an index of zero.

Return Value

The basic object occupying the Index element of array. Returns Null object if index is outside the array bounds.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFBasObj Class


Put Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : Put Method
The location in array to store an object. The first element of an array has an index of zero.
The object to insert into array.
Puts the specified object into the specified location in an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Put( _
   ByVal index As Integer, _
   ByVal value As ImGearPDFBasObj _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer
Dim value As ImGearPDFBasObj

instance.Put(index, value)
public void Put(
   int index,
   ImGearPDFBasObj value
)
public: void Put(
   int index,
   ImGearPDFBasObj* value
)
public:
void Put(
   int index,
   ImGearPDFBasObj^ value
)

Parameters

index
The location in array to store an object. The first element of an array has an index of zero.
value
The object to insert into array.
Remarks
The array is extended as much as necessary.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFAtom Class
ImGearPDFBasObj Class


PutBool Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : PutBool Method
The location in array to store a value. The first element of an array has an index of zero.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
The integer value to insert into array.
Puts the specified boolean value into the specified location in an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutBool( _
   ByVal index As Integer, _
   ByVal isIndirect As Boolean, _
   ByVal value As Boolean _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer
Dim isIndirect As Boolean
Dim value As Boolean

instance.PutBool(index, isIndirect, value)
public void PutBool(
   int index,
   bool isIndirect,
   bool value
)
public: void PutBool(
   int index,
   bool isIndirect,
   bool value
)
public:
void PutBool(
   int index,
   bool isIndirect,
   bool value
)

Parameters

index
The location in array to store a value. The first element of an array has an index of zero.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
value
The integer value to insert into array.
Remarks
The array is extended as much as necessary.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFAtom Class


PutFixed Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : PutFixed Method
The location in array to store a value. The first element of an array has an index of zero.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Fixed value to put in the array.
Puts the specified fixed value into the specified location in an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutFixed( _
   ByVal index As Integer, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer
Dim isIndirect As Boolean
Dim value As Integer

instance.PutFixed(index, isIndirect, value)
public void PutFixed(
   int index,
   bool isIndirect,
   int value
)
public: void PutFixed(
   int index,
   bool isIndirect,
   int value
)
public:
void PutFixed(
   int index,
   bool isIndirect,
   int value
)

Parameters

index
The location in array to store a value. The first element of an array has an index of zero.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
value
Fixed value to put in the array.
Remarks
The array is extended as much as necessary.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFAtom Class


PutInt Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : PutInt Method
The location in array to store a value. The first element of an array has an index of zero.
If true, creates the key value as an isIndirect object. If false, creates the key value as a direct object.
Integer value to put in the array.
Puts the specified integer value into the specified location in an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutInt( _
   ByVal index As Integer, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer
Dim isIndirect As Boolean
Dim value As Integer

instance.PutInt(index, isIndirect, value)
public void PutInt(
   int index,
   bool isIndirect,
   int value
)
public: void PutInt(
   int index,
   bool isIndirect,
   int value
)
public:
void PutInt(
   int index,
   bool isIndirect,
   int value
)

Parameters

index
The location in array to store a value. The first element of an array has an index of zero.
isIndirect
If true, creates the key value as an isIndirect object. If false, creates the key value as a direct object.
value
Integer value to put in the array.
Remarks
The array is extended as much as necessary.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members


PutName Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : PutName Method
The location in array to store a value. The first element of an array has an index of zero.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Name value to put in the array.
Puts the name value into the specified location in an array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutName( _
   ByVal index As Integer, _
   ByVal isIndirect As Boolean, _
   ByVal name As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer
Dim isIndirect As Boolean
Dim name As ImGearPDFAtom

instance.PutName(index, isIndirect, name)
public void PutName(
   int index,
   bool isIndirect,
   ImGearPDFAtom name
)
public: void PutName(
   int index,
   bool isIndirect,
   ImGearPDFAtom* name
)
public:
void PutName(
   int index,
   bool isIndirect,
   ImGearPDFAtom^ name
)

Parameters

index
The location in array to store a value. The first element of an array has an index of zero.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
name
Name value to put in the array.
Remarks
The array is extended as much as necessary.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFAtom Class


Remove Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : Remove Method
The object to remove.
Finds the first element, if any, equal to the specified object and removes it from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal value As ImGearPDFBasObj _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim value As ImGearPDFBasObj

instance.Remove(value)
public void Remove(
   ImGearPDFBasObj value
)
public: void Remove(
   ImGearPDFBasObj* value
)
public:
void Remove(
   ImGearPDFBasObj^ value
)

Parameters

value
The object to remove.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members
ImGearPDFBasObj Class


RemoveAt Method (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : RemoveAt Method
The index for the array member to remove. Array indices start at 0.
Removes element at index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearPDFBasArray
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
The index for the array member to remove. Array indices start at 0.
Remarks
Checks whether the position is within the array bounds and then removes it from the array and moves each subsequent element to the slot with the next smaller index and decrements the array's length by 1.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members


%%PageItemTitle%% $$Properties$$

ImGearPDFBasArray Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasArray Class

For a list of all members of this type, see ImGearPDFBasArray members.

Public Properties
 | Name | Description
Public Property | Length | Gets the number of elements in the array.
Top
See Also

Reference

ImGearPDFBasArray Class
ImageGear.Formats.PDF Namespace


Length Property (ImGearPDFBasArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasArray Class : Length Property
Gets the number of elements in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Integer
'Usage

Dim instance As ImGearPDFBasArray
Dim value As Integer

value = instance.Length
public int Length {get;}
public: __property int get_Length();
public:
property int Length {
   int get();
}

Property Value

Integer number.
See Also

Reference

ImGearPDFBasArray Class
ImGearPDFBasArray Members


%%PageItemTitle%%

ImGearPDFBasBool Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasBool Class
Represents basic boolean object.
Object Model
ImGearPDFBasBool Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasBool
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasBool
public sealed class ImGearPDFBasBool : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasBool : public ImGearPDFBasObj
public ref class ImGearPDFBasBool sealed : public ImGearPDFBasObj
Remarks
PDF provides Boolean objects identified by the keywords true and false. Boolean objects can be used as the values of array elements and dictionary entries.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasBool

See Also

Reference

ImGearPDFBasBool Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasBool Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasBool Class

The following tables list the members exposed by ImGearPDFBasBool.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasBool Constructor | Initializes a new instance of the ImGearPDFBasBool class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets a value indicating whether the specified Boolean object is set to True.
Top
See Also

Reference

ImGearPDFBasBool Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasBool Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasBool Class : ImGearPDFBasBool Constructor
The document in which the boolean is used.
If True, creates the boolean object as an indirect object. If False, creates the boolean as a direct object.
The value the new boolean will have.
Initializes a new instance of the ImGearPDFBasBool class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal value As Boolean _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim value As Boolean

Dim instance As New ImGearPDFBasBool(document, isIndirect, value)
public ImGearPDFBasBool(
   ImGearPDFDocument document,
   bool isIndirect,
   bool value
)
public: ImGearPDFBasBool(
   ImGearPDFDocument* document,
   bool isIndirect,
   bool value
)
public:
ImGearPDFBasBool(
   ImGearPDFDocument^ document,
   bool isIndirect,
   bool value
)

Parameters

document
The document in which the boolean is used.
isIndirect
If True, creates the boolean object as an indirect object. If False, creates the boolean as a direct object.
value
The value the new boolean will have.

Return Value

The new instance of ImGearPDFBasBool class object.
Remarks
This constructor creates a new Boolean object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasBool Class
ImGearPDFBasBool Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Properties$$

ImGearPDFBasBool Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasBool Class

For a list of all members of this type, see ImGearPDFBasBool members.

Public Properties
 | Name | Description
Public Property | Value | Gets a value indicating whether the specified Boolean object is set to True.
Top
See Also

Reference

ImGearPDFBasBool Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasBool Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasBool Class

For a list of all members of this type, see ImGearPDFBasBool members.

See Also

Reference

ImGearPDFBasBool Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasBool Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasBool Class : ImGearPDFBasBool Constructor
Overload List
Overload | Description
ImGearPDFBasBool Constructor | Initializes a new instance of the ImGearPDFBasBool class.
See Also

Reference

ImGearPDFBasBool Class
ImGearPDFBasBool Members


Value Property (ImGearPDFBasBool)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasBool Class : Value Property
Gets a value indicating whether the specified Boolean object is set to True.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Boolean
'Usage

Dim instance As ImGearPDFBasBool
Dim value As Boolean

value = instance.Value
public bool Value {get;}
public: __property bool get_Value();
public:
property bool Value {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFBasBool Class
ImGearPDFBasBool Members


%%PageItemTitle%%

ImGearPDFBasDict Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasDict Class
Represents basic dictionary object.
Object Model
ImGearPDFBasDict ClassImGearPDFBasObj Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasDict
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasDict
public sealed class ImGearPDFBasDict : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasDict : public ImGearPDFBasObj
public ref class ImGearPDFBasDict sealed : public ImGearPDFBasObj
Remarks
Dictionary is an associative table containing pairs of objects, known as the dictionary's entries. The first element of each entry is the key and the second element is the value. The key must be a name. The value can be any kind of object, including another dictionary.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasDict

See Also

Reference

ImGearPDFBasDict Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasDict Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasDict Class

The following tables list the members exposed by ImGearPDFBasDict.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasDict Constructor | Initializes a new instance of the ImGearPDFBasDict class.
Top
Public Methods
 | Name | Description
Public Method | Get | Gets the value of the specified key in the specified dictionary.
Public Method | Known | Tests whether a specific key is found in the specified dictionary.
Public Method | Put | Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutBool | Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutFixed | Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutInt | Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutName | Sets the name value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | Remove | Removes a key-value pair from a dictionary.
Top
See Also

Reference

ImGearPDFBasDict Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFBasDict Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasDict Class

For a list of all members of this type, see ImGearPDFBasDict members.

See Also

Reference

ImGearPDFBasDict Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasDict Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : ImGearPDFBasDict Constructor
The document in which the dictionary is used.
If True, creates the dictionary as an indirect object. If False, creates the dictionary as a direct object.
Number of entries in the dictionary. This value is only a hint - the dictionaries grow dynamically as needed.
Initializes a new instance of the ImGearPDFBasDict class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal length As UInteger _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim length As UInteger

Dim instance As New ImGearPDFBasDict(document, isIndirect, length)
public ImGearPDFBasDict(
   ImGearPDFDocument document,
   bool isIndirect,
   uint length
)
public: ImGearPDFBasDict(
   ImGearPDFDocument* document,
   bool isIndirect,
   uint length
)
public:
ImGearPDFBasDict(
   ImGearPDFDocument^ document,
   bool isIndirect,
   uint length
)

Parameters

document
The document in which the dictionary is used.
isIndirect
If True, creates the dictionary as an indirect object. If False, creates the dictionary as a direct object.
length
Number of entries in the dictionary. This value is only a hint - the dictionaries grow dynamically as needed.

Return Value

The new instance of ImGearPDFBasDict class object.
Remarks
Creates a new dictionary object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Methods$$

ImGearPDFBasDict Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasDict Class

For a list of all members of this type, see ImGearPDFBasDict members.

Public Methods
 | Name | Description
Public Method | Get | Gets the value of the specified key in the specified dictionary.
Public Method | Known | Tests whether a specific key is found in the specified dictionary.
Public Method | Put | Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutBool | Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutFixed | Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutInt | Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | PutName | Sets the name value of a dictionary key, adding the key to the dictionary if it is not already present.
Public Method | Remove | Removes a key-value pair from a dictionary.
Top
See Also

Reference

ImGearPDFBasDict Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasDict Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : ImGearPDFBasDict Constructor
Overload List
Overload | Description
ImGearPDFBasDict Constructor | Initializes a new instance of the ImGearPDFBasDict class.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members


Get Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : Get Method
The key to get value of.
Gets the value of the specified key in the specified dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Get( _
   ByVal key As ImGearPDFAtom _
) As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim value As ImGearPDFBasObj

value = instance.Get(key)
public ImGearPDFBasObj Get(
   ImGearPDFAtom key
)
public: ImGearPDFBasObj* Get(
   ImGearPDFAtom* key
)
public:
ImGearPDFBasObj^ Get(
   ImGearPDFAtom^ key
)

Parameters

key
The key to get value of.

Return Value

ImGearPDFBasObj class object.
Remarks
If called with a stream object instead of a dictionary object, this method gets the value of the specified key from the stream's attributes dictionary.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFBasObj Class
ImGearPDFAtom Class


Known Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : Known Method
Key to test.
Tests whether a specific key is found in the specified dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Known( _
   ByVal key As ImGearPDFAtom _
) As Boolean
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim value As Boolean

value = instance.Known(key)
public bool Known(
   ImGearPDFAtom key
)
public: bool Known(
   ImGearPDFAtom* key
)
public:
bool Known(
   ImGearPDFAtom^ key
)

Parameters

key
Key to test.

Return Value

Boolean value.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


Put Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : Put Method
Key to set the value to.
Key Value to be set.
Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Put( _
   ByVal key As ImGearPDFAtom, _
   ByVal value As ImGearPDFBasObj _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim value As ImGearPDFBasObj

instance.Put(key, value)
public void Put(
   ImGearPDFAtom key,
   ImGearPDFBasObj value
)
public: void Put(
   ImGearPDFAtom* key,
   ImGearPDFBasObj* value
)
public:
void Put(
   ImGearPDFAtom^ key,
   ImGearPDFBasObj^ value
)

Parameters

key
Key to set the value to.
value
Key Value to be set.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class
ImGearPDFBasObj Class


PutBool Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : PutBool Method
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
The boolean value to set.
Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutBool( _
   ByVal key As ImGearPDFAtom, _
   ByVal isIndirect As Boolean, _
   ByVal value As Boolean _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim isIndirect As Boolean
Dim value As Boolean

instance.PutBool(key, isIndirect, value)
public void PutBool(
   ImGearPDFAtom key,
   bool isIndirect,
   bool value
)
public: void PutBool(
   ImGearPDFAtom* key,
   bool isIndirect,
   bool value
)
public:
void PutBool(
   ImGearPDFAtom^ key,
   bool isIndirect,
   bool value
)

Parameters

key
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
value
The boolean value to set.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


PutFixed Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : PutFixed Method
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
The fixed value to set.
Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutFixed( _
   ByVal key As ImGearPDFAtom, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim isIndirect As Boolean
Dim value As Integer

instance.PutFixed(key, isIndirect, value)
public void PutFixed(
   ImGearPDFAtom key,
   bool isIndirect,
   int value
)
public: void PutFixed(
   ImGearPDFAtom* key,
   bool isIndirect,
   int value
)
public:
void PutFixed(
   ImGearPDFAtom^ key,
   bool isIndirect,
   int value
)

Parameters

key
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
value
The fixed value to set.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


PutInt Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : PutInt Method
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
The integer value to set.
Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutInt( _
   ByVal key As ImGearPDFAtom, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim isIndirect As Boolean
Dim value As Integer

instance.PutInt(key, isIndirect, value)
public void PutInt(
   ImGearPDFAtom key,
   bool isIndirect,
   int value
)
public: void PutInt(
   ImGearPDFAtom* key,
   bool isIndirect,
   int value
)
public:
void PutInt(
   ImGearPDFAtom^ key,
   bool isIndirect,
   int value
)

Parameters

key
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
value
The integer value to set.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


PutName Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : PutName Method
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
The name value to set.
Sets the name value of a dictionary key, adding the key to the dictionary if it is not already present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PutName( _
   ByVal key As ImGearPDFAtom, _
   ByVal isIndirect As Boolean, _
   ByVal name As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom
Dim isIndirect As Boolean
Dim name As ImGearPDFAtom

instance.PutName(key, isIndirect, name)
public void PutName(
   ImGearPDFAtom key,
   bool isIndirect,
   ImGearPDFAtom name
)
public: void PutName(
   ImGearPDFAtom* key,
   bool isIndirect,
   ImGearPDFAtom* name
)
public:
void PutName(
   ImGearPDFAtom^ key,
   bool isIndirect,
   ImGearPDFAtom^ name
)

Parameters

key
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
isIndirect
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
name
The name value to set.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


Remove Method (ImGearPDFBasDict)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasDict Class : Remove Method
The key of object to remove.
Removes a key-value pair from a dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal key As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDFBasDict
Dim key As ImGearPDFAtom

instance.Remove(key)
public void Remove(
   ImGearPDFAtom key
)
public: void Remove(
   ImGearPDFAtom* key
)
public:
void Remove(
   ImGearPDFAtom^ key
)

Parameters

key
The key of object to remove.
See Also

Reference

ImGearPDFBasDict Class
ImGearPDFBasDict Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFBasFixed Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasFixed Class
Represents basic fixed object.
Object Model
ImGearPDFBasFixed Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasFixed
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasFixed
public sealed class ImGearPDFBasFixed : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasFixed : public ImGearPDFBasObj
public ref class ImGearPDFBasFixed sealed : public ImGearPDFBasObj
Remarks
Fixed objects approximate mathematical real numbers, but with limited range and precision. They are typically represented in fixed-point, rather than floating-point, form.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasFixed

See Also

Reference

ImGearPDFBasFixed Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasFixed Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasFixed Class

The following tables list the members exposed by ImGearPDFBasFixed.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasFixed Constructor | Initializes a new instance of the ImGearPDFBasFixed class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified fixed object.
Top
See Also

Reference

ImGearPDFBasFixed Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasFixed Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasFixed Class : ImGearPDFBasFixed Constructor
The document in which the fixed is used.
If True, creates the fixed as an indirect object. If False, creates the fixed as a direct object.
The value the new fixed will have.
Initializes a new instance of the ImGearPDFBasFixed class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim value As Integer

Dim instance As New ImGearPDFBasFixed(document, isIndirect, value)
public ImGearPDFBasFixed(
   ImGearPDFDocument document,
   bool isIndirect,
   int value
)
public: ImGearPDFBasFixed(
   ImGearPDFDocument* document,
   bool isIndirect,
   int value
)
public:
ImGearPDFBasFixed(
   ImGearPDFDocument^ document,
   bool isIndirect,
   int value
)

Parameters

document
The document in which the fixed is used.
isIndirect
If True, creates the fixed as an indirect object. If False, creates the fixed as a direct object.
value
The value the new fixed will have.

Return Value

The new instance of ImGearPDFBasFixed class object.
Remarks
Creates a new fixed object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasFixed Class
ImGearPDFBasFixed Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Properties$$

ImGearPDFBasFixed Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasFixed Class

For a list of all members of this type, see ImGearPDFBasFixed members.

Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified fixed object.
Top
See Also

Reference

ImGearPDFBasFixed Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasFixed Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasFixed Class

For a list of all members of this type, see ImGearPDFBasFixed members.

See Also

Reference

ImGearPDFBasFixed Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasFixed Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasFixed Class : ImGearPDFBasFixed Constructor
Overload List
Overload | Description
ImGearPDFBasFixed Constructor | Initializes a new instance of the ImGearPDFBasFixed class.
See Also

Reference

ImGearPDFBasFixed Class
ImGearPDFBasFixed Members


Value Property (ImGearPDFBasFixed)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasFixed Class : Value Property
Gets the value of the specified fixed object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Integer
'Usage

Dim instance As ImGearPDFBasFixed
Dim value As Integer

value = instance.Value
public int Value {get;}
public: __property int get_Value();
public:
property int Value {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFBasFixed Class
ImGearPDFBasFixed Members


%%PageItemTitle%%

ImGearPDFBasInt Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasInt Class
Represents basic integer object.
Object Model
ImGearPDFBasInt Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasInt
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasInt
public sealed class ImGearPDFBasInt : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasInt : public ImGearPDFBasObj
public ref class ImGearPDFBasInt sealed : public ImGearPDFBasObj
Remarks
Integer objects represent mathematical integers within a certain interval centered at 0.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasInt

See Also

Reference

ImGearPDFBasInt Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasInt Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasInt Class

The following tables list the members exposed by ImGearPDFBasInt.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasInt Constructor | Initializes a new instance of the ImGearPDFBasInt class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified integer object.
Top
See Also

Reference

ImGearPDFBasInt Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasInt Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasInt Class : ImGearPDFBasInt Constructor
The document in which the integer is used.
If True, creates the integer as an indirect object. If False, creates the integer as a direct object.
The value the new integer will have.
Initializes a new instance of the ImGearPDFBasInt class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal value As Integer _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim value As Integer

Dim instance As New ImGearPDFBasInt(document, isIndirect, value)
public ImGearPDFBasInt(
   ImGearPDFDocument document,
   bool isIndirect,
   int value
)
public: ImGearPDFBasInt(
   ImGearPDFDocument* document,
   bool isIndirect,
   int value
)
public:
ImGearPDFBasInt(
   ImGearPDFDocument^ document,
   bool isIndirect,
   int value
)

Parameters

document
The document in which the integer is used.
isIndirect
If True, creates the integer as an indirect object. If False, creates the integer as a direct object.
value
The value the new integer will have.

Return Value

The new instance of ImGearPDFBasInt class object.
Remarks
Creates a new integer object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasInt Class
ImGearPDFBasInt Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Properties$$

ImGearPDFBasInt Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasInt Class

For a list of all members of this type, see ImGearPDFBasInt members.

Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified integer object.
Top
See Also

Reference

ImGearPDFBasInt Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasInt Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasInt Class

For a list of all members of this type, see ImGearPDFBasInt members.

See Also

Reference

ImGearPDFBasInt Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasInt Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasInt Class : ImGearPDFBasInt Constructor
Overload List
Overload | Description
ImGearPDFBasInt Constructor | Initializes a new instance of the ImGearPDFBasInt class.
See Also

Reference

ImGearPDFBasInt Class
ImGearPDFBasInt Members


Value Property (ImGearPDFBasInt)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasInt Class : Value Property
Gets the value of the specified integer object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Integer
'Usage

Dim instance As ImGearPDFBasInt
Dim value As Integer

value = instance.Value
public int Value {get;}
public: __property int get_Value();
public:
property int Value {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFBasInt Class
ImGearPDFBasInt Members


%%PageItemTitle%%

ImGearPDFBasName Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasName Class
Represents basic name object.
Object Model
ImGearPDFBasName ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasName
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasName
public sealed class ImGearPDFBasName : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasName : public ImGearPDFBasObj
public ref class ImGearPDFBasName sealed : public ImGearPDFBasObj
Remarks
A name object is an atomic symbol uniquely defined by a sequence of characters. Uniquely defined means that any two name objects made up of the same sequence of characters are identically the same object. Atomic means that a name has no internal structure. Although it is defined by a sequence of characters, those characters are not "elements" of the name.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasName

See Also

Reference

ImGearPDFBasName Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasName Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasName Class

The following tables list the members exposed by ImGearPDFBasName.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasName Constructor | Initializes a new instance of the ImGearPDFBasName class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified name object.
Top
See Also

Reference

ImGearPDFBasName Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasName Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasName Class : ImGearPDFBasName Constructor
The document in which the name is used.
If True, creates the name as an indirect object. If False, creates the name as a direct object.
The value the new name will have.
Initializes a new instance of the ImGearPDFBasName class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal name As ImGearPDFAtom _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim name As ImGearPDFAtom

Dim instance As New ImGearPDFBasName(document, isIndirect, name)
public ImGearPDFBasName(
   ImGearPDFDocument document,
   bool isIndirect,
   ImGearPDFAtom name
)
public: ImGearPDFBasName(
   ImGearPDFDocument* document,
   bool isIndirect,
   ImGearPDFAtom* name
)
public:
ImGearPDFBasName(
   ImGearPDFDocument^ document,
   bool isIndirect,
   ImGearPDFAtom^ name
)

Parameters

document
The document in which the name is used.
isIndirect
If True, creates the name as an indirect object. If False, creates the name as a direct object.
name
The value the new name will have.

Return Value

The new instance of ImGearPDFBasName class object.
Remarks
Creates a new name object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasName Class
ImGearPDFBasName Members
ImGearPDFDocument Class
ImGearPDFAtom Class


%%PageItemTitle%% $$Properties$$

ImGearPDFBasName Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasName Class

For a list of all members of this type, see ImGearPDFBasName members.

Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified name object.
Top
See Also

Reference

ImGearPDFBasName Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasName Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasName Class

For a list of all members of this type, see ImGearPDFBasName members.

See Also

Reference

ImGearPDFBasName Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasName Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasName Class : ImGearPDFBasName Constructor
Overload List
Overload | Description
ImGearPDFBasName Constructor | Initializes a new instance of the ImGearPDFBasName class.
See Also

Reference

ImGearPDFBasName Class
ImGearPDFBasName Members


Value Property (ImGearPDFBasName)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasName Class : Value Property
Gets the value of the specified name object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFBasName
Dim value As ImGearPDFAtom

value = instance.Value
public ImGearPDFAtom Value {get;}
public: __property ImGearPDFAtom* get_Value();
public:
property ImGearPDFAtom^ Value {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDFBasName Class
ImGearPDFBasName Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFBasNull Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasNull Class
Represents basic null object.
Object Model
ImGearPDFBasNull Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasNull
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasNull
public sealed class ImGearPDFBasNull : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasNull : public ImGearPDFBasObj
public ref class ImGearPDFBasNull sealed : public ImGearPDFBasObj
Remarks
The null object has a type and value that are unequal to those of any other object. There is only one object of type null.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasNull

See Also

Reference

ImGearPDFBasNull Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasNull Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasNull Class

The following tables list the members exposed by ImGearPDFBasNull.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasNull Constructor | Initializes a new instance of the ImGearPDFBasNull class.
Top
See Also

Reference

ImGearPDFBasNull Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFBasNull Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasNull Class

For a list of all members of this type, see ImGearPDFBasNull members.

See Also

Reference

ImGearPDFBasNull Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasNull Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasNull Class

For a list of all members of this type, see ImGearPDFBasNull members.

See Also

Reference

ImGearPDFBasNull Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasNull Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasNull Class : ImGearPDFBasNull Constructor
Overload List
Overload | Description
ImGearPDFBasNull Constructor | Initializes a new instance of the ImGearPDFBasNull class.
See Also

Reference

ImGearPDFBasNull Class
ImGearPDFBasNull Members


%%PageItemTitle%%

ImGearPDFBasNull Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasNull Class : ImGearPDFBasNull Constructor
Initializes a new instance of the ImGearPDFBasNull class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFBasNull()
public ImGearPDFBasNull()
public: ImGearPDFBasNull();
public:
ImGearPDFBasNull();

Return Value

The new instance of ImGearPDFBasNull class object.
See Also

Reference

ImGearPDFBasNull Class
ImGearPDFBasNull Members


%%PageItemTitle%%

ImGearPDFBasObj Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasObj Class
Represents basic abstract object.
Object Model
ImGearPDFBasObj Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPDFBasObj
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFBasObj
public abstract class ImGearPDFBasObj : ImGearPDFObject
public __gc abstract class ImGearPDFBasObj : public ImGearPDFObject
public ref class ImGearPDFBasObj abstract : public ImGearPDFObject
Remarks
PDF supports eight basic types of object:
  • Boolean values
  • Integer and Fixed (real) numbers
  • Strings
  • Names
  • Arrays
  • Dictionaries
  • Streams
  • The null object

Objects may be labeled so that they can be referred to by other objects. A labeled object is called an indirect object.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasArray
ImageGear.Formats.PDF.ImGearPDFBasBool
ImageGear.Formats.PDF.ImGearPDFBasDict
ImageGear.Formats.PDF.ImGearPDFBasFixed
ImageGear.Formats.PDF.ImGearPDFBasInt
ImageGear.Formats.PDF.ImGearPDFBasName
ImageGear.Formats.PDF.ImGearPDFBasNull
ImageGear.Formats.PDF.ImGearPDFBasStream
ImageGear.Formats.PDF.ImGearPDFBasString

See Also

Reference

ImGearPDFBasObj Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasObj Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasObj Class

The following tables list the members exposed by ImGearPDFBasObj.

Public Properties
 | Name | Description
Public Property | Type | Gets object's type.
Top
See Also

Reference

ImGearPDFBasObj Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFBasObj Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasObj Class

For a list of all members of this type, see ImGearPDFBasObj members.

Public Properties
 | Name | Description
Public Property | Type | Gets object's type.
Top
See Also

Reference

ImGearPDFBasObj Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasObj Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasObj Class

For a list of all members of this type, see ImGearPDFBasObj members.

See Also

Reference

ImGearPDFBasObj Class
ImageGear.Formats.PDF Namespace


Type Property (ImGearPDFBasObj)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasObj Class : Type Property
Gets object's type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearPDFBasicType
'Usage

Dim instance As ImGearPDFBasObj
Dim value As ImGearPDFBasicType

value = instance.Type
public ImGearPDFBasicType Type {get;}
public: __property ImGearPDFBasicType get_Type();
public:
property ImGearPDFBasicType Type {
   ImGearPDFBasicType get();
}

Property Value

ImGearPDFBasicType enumeration value.
See Also

Reference

ImGearPDFBasObj Class
ImGearPDFBasObj Members
ImGearPDFBasicType Enumeration


%%PageItemTitle%%

ImGearPDFBasStream Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasStream Class
Represents basic stream object.
Object Model
ImGearPDFBasStream ClassImGearPDFBasDict Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasStream
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasStream
public sealed class ImGearPDFBasStream : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasStream : public ImGearPDFBasObj
public ref class ImGearPDFBasStream sealed : public ImGearPDFBasObj
Remarks
A stream is a sequence of characters that can be read a portion at a time. Streams are used for objects with large amounts of data, such as images, page content, or private data a plug-in creates. A stream consists of these elements, which are listed in their relative order in the stream object, starting at the beginning. See Section 3.2.7 in the PDF Reference for a description of the stream object.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasStream

See Also

Reference

ImGearPDFBasStream Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasStream Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasStream Class

The following tables list the members exposed by ImGearPDFBasStream.

Public Properties
 | Name | Description
Public Property | Dict | Gets the stream's attributes dictionary.
Public Property | Value | Gets the value of the specified stream object.
Top
See Also

Reference

ImGearPDFBasStream Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFBasStream Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasStream Class

For a list of all members of this type, see ImGearPDFBasStream members.

Public Properties
 | Name | Description
Public Property | Dict | Gets the stream's attributes dictionary.
Public Property | Value | Gets the value of the specified stream object.
Top
See Also

Reference

ImGearPDFBasStream Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasStream Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasStream Class

For a list of all members of this type, see ImGearPDFBasStream members.

See Also

Reference

ImGearPDFBasStream Class
ImageGear.Formats.PDF Namespace


Dict Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasStream Class : Dict Property
Gets the stream's attributes dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dict As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDFBasStream
Dim value As ImGearPDFBasDict

value = instance.Dict
public ImGearPDFBasDict Dict {get;}
public: __property ImGearPDFBasDict* get_Dict();
public:
property ImGearPDFBasDict^ Dict {
   ImGearPDFBasDict^ get();
}

Property Value

ImGearPDFBasDict class value.
See Also

Reference

ImGearPDFBasStream Class
ImGearPDFBasStream Members


Value Property (ImGearPDFBasStream)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasStream Class : Value Property
Gets the value of the specified stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Byte()
'Usage

Dim instance As ImGearPDFBasStream
Dim value() As Byte

value = instance.Value
public byte[] Value {get;}
public: __property byte[]* get_Value();
public:
property array<byte>^ Value {
   array<byte>^ get();
}

Property Value

Byte array.
See Also

Reference

ImGearPDFBasStream Class
ImGearPDFBasStream Members


%%PageItemTitle%%

ImGearPDFBasString Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasString Class
Represents basic string object.
Object Model
ImGearPDFBasString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBasString
   Inherits ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFBasString
public sealed class ImGearPDFBasString : ImGearPDFBasObj
public __gc __sealed class ImGearPDFBasString : public ImGearPDFBasObj
public ref class ImGearPDFBasString sealed : public ImGearPDFBasObj
Remarks
A string object consists of a series of bytes-unsigned integer values in the range 0 to 255. The string elements are not integer objects, but are stored in a more compact format.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBasString

See Also

Reference

ImGearPDFBasString Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBasString Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasString Class

The following tables list the members exposed by ImGearPDFBasString.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFBasString Constructor | Initializes a new instance of the ImGearPDFBasString class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified string object.
Top
See Also

Reference

ImGearPDFBasString Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasString Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasString Class : ImGearPDFBasString Constructor
The document in which the string is used.
If True, creates the string as an indirect object. If False, creates the string as a direct object.
The value the new string will have.
Initializes a new instance of the ImGearPDFBasString class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal isIndirect As Boolean, _
   ByVal value As String _
)
'Usage

Dim document As ImGearPDFDocument
Dim isIndirect As Boolean
Dim value As String

Dim instance As New ImGearPDFBasString(document, isIndirect, value)
public ImGearPDFBasString(
   ImGearPDFDocument document,
   bool isIndirect,
   string value
)
public: ImGearPDFBasString(
   ImGearPDFDocument* document,
   bool isIndirect,
   string* value
)
public:
ImGearPDFBasString(
   ImGearPDFDocument^ document,
   bool isIndirect,
   String^ value
)

Parameters

document
The document in which the string is used.
isIndirect
If True, creates the string as an indirect object. If False, creates the string as a direct object.
value
The value the new string will have.

Return Value

The new instance of ImGearPDFBasString class object.
Remarks
Creates a new string object associated with the specified document and with the specified value.
See Also

Reference

ImGearPDFBasString Class
ImGearPDFBasString Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Properties$$

ImGearPDFBasString Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasString Class

For a list of all members of this type, see ImGearPDFBasString members.

Public Properties
 | Name | Description
Public Property | Value | Gets the value of the specified string object.
Top
See Also

Reference

ImGearPDFBasString Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBasString Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasString Class

For a list of all members of this type, see ImGearPDFBasString members.

See Also

Reference

ImGearPDFBasString Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasString Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasString Class : ImGearPDFBasString Constructor
Overload List
Overload | Description
ImGearPDFBasString Constructor | Initializes a new instance of the ImGearPDFBasString class.
See Also

Reference

ImGearPDFBasString Class
ImGearPDFBasString Members


Value Property (ImGearPDFBasString)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBasString Class : Value Property
Gets the value of the specified string object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As ImGearPDFBasString
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearPDFBasString Class
ImGearPDFBasString Members


%%PageItemTitle%%

ImGearPDFBookmark Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBookmark Class
Represents a PDF bookmark.
Object Model
ImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFAction ClassImGearPixel ClassImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFBookmark ClassImGearPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFBookmark
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFBookmark
public sealed class ImGearPDFBookmark : ImGearPDFObject
public __gc __sealed class ImGearPDFBookmark : public ImGearPDFObject
public ref class ImGearPDFBookmark sealed : public ImGearPDFObject
Remarks
PDF bookmark allows the user to navigate interactively from one part of the document to another. It consists of a tree-structured hierarchy of bookmarks. Each bookmark has:
  • A title that appears on screen
  • An action that specifies what happens when the user clicks on the bookmark

The typical action for a user-created bookmark is to move to another location in the current document or outside of it. Each bookmark in the bookmark tree structure has zero or more children that appear indented on screen, and zero or more siblings that appear at the same indentation level. All bookmarks except the bookmark at the top level of the hierarchy have one parent, the bookmark under which it is indented. A bookmark is said to be open if its children are visible on screen, and closed if they are not. See section 8.2.2, "Document Outline", in the PDF Reference for more information on bookmarks.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFBookmark

See Also

Reference

ImGearPDFBookmark Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFBookmark Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBookmark Class

The following tables list the members exposed by ImGearPDFBookmark.

Public Properties
 | Name | Description
Public Property | Count | Gets a number of open bookmarks in the sub-tree (not including the current one).
Public Property | Flags | Gets or sets bookmark's flags.
Public Property | HasChildren | Gets a value indicating whether the bookmark has any children.
Public Property | Indent | Gets the indentation level of the bookmark in its containing tree.
Public Property | Open | Gets or sets a value indicating whether the bookmark is open (shows all its children).
Public Property | Title | Gets or sets string specifying the bookmark's title.
Top
Public Methods
 | Name | Description
Public Method | AddChild | Adds child as the last child of parent.
Public Method | AddNewChild | Adds a new bookmark to the tree containing the current bookmark, as the new last child of it.
Public Method | AddNewSibling | Adds a new bookmark to the tree containing the current bookmark as the new right sibling.
Public Method | AddNext | Adds next bookmark as the new right sibling to the current one.
Public Method | AddPrev | Adds bookmark as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.
Public Method | AddSubtree | Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark.
Public Method | FindTitle | Gets the first bookmark whose title is Title.
Public Method | GetAction | Gets the bookmark's action.
Public Method | GetColor | Gets the color of the bookmark.
Public Method | GetFirstChild | Gets the bookmark's first child.
Public Method | GetLastChild | Gets the bookmark's last child.
Public Method | GetNext | Gets the bookmark's next (right) sibling.
Public Method | GetParent | Gets the bookmark's parent bookmark.
Public Method | GetPrev | Gets the bookmark 's previous (left) sibling.
Public Method | Remove | Removes the bookmark's sub-tree from the bookmark tree containing it.
Public Method | RemoveAction | Removes the bookmark's action.
Public Method | SetAction | Sets the bookmark's action.
Public Method | SetColor | Sets the bookmark's color.
Public Method | Unlink | Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.
Top
See Also

Reference

ImGearPDFBookmark Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFBookmark Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBookmark Class

For a list of all members of this type, see ImGearPDFBookmark members.

Public Methods
 | Name | Description
Public Method | AddChild | Adds child as the last child of parent.
Public Method | AddNewChild | Adds a new bookmark to the tree containing the current bookmark, as the new last child of it.
Public Method | AddNewSibling | Adds a new bookmark to the tree containing the current bookmark as the new right sibling.
Public Method | AddNext | Adds next bookmark as the new right sibling to the current one.
Public Method | AddPrev | Adds bookmark as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.
Public Method | AddSubtree | Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark.
Public Method | FindTitle | Gets the first bookmark whose title is Title.
Public Method | GetAction | Gets the bookmark's action.
Public Method | GetColor | Gets the color of the bookmark.
Public Method | GetFirstChild | Gets the bookmark's first child.
Public Method | GetLastChild | Gets the bookmark's last child.
Public Method | GetNext | Gets the bookmark's next (right) sibling.
Public Method | GetParent | Gets the bookmark's parent bookmark.
Public Method | GetPrev | Gets the bookmark 's previous (left) sibling.
Public Method | Remove | Removes the bookmark's sub-tree from the bookmark tree containing it.
Public Method | RemoveAction | Removes the bookmark's action.
Public Method | SetAction | Sets the bookmark's action.
Public Method | SetColor | Sets the bookmark's color.
Public Method | Unlink | Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.
Top
See Also

Reference

ImGearPDFBookmark Class
ImageGear.Formats.PDF Namespace


AddChild Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddChild Method
The bookmark that will become the last child of the current bookmark. Child must have been previously unlinked.
Adds child as the last child of parent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddChild( _
   ByVal child As ImGearPDFBookmark _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim child As ImGearPDFBookmark

instance.AddChild(child)
public void AddChild(
   ImGearPDFBookmark child
)
public: void AddChild(
   ImGearPDFBookmark* child
)
public:
void AddChild(
   ImGearPDFBookmark^ child
)

Parameters

child
The bookmark that will become the last child of the current bookmark. Child must have been previously unlinked.
Remarks
Adds child, adjusting the tree containing parent appropriately. If parent previously had no children, it is open after the child is added.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


AddNewChild Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddNewChild Method
The new bookmark's title.
Adds a new bookmark to the tree containing the current bookmark, as the new last child of it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AddNewChild( _
   ByVal text As String _
) As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim text As String
Dim value As ImGearPDFBookmark

value = instance.AddNewChild(text)
public ImGearPDFBookmark AddNewChild(
   string text
)
public: ImGearPDFBookmark* AddNewChild(
   string* text
)
public:
ImGearPDFBookmark^ AddNewChild(
   String^ text
)

Parameters

text
The new bookmark's title.

Return Value

ImGearPDFBookmark class object.
Remarks
If the current bookmark previously had no children, it will be open after the child is added.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


AddNewSibling Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddNewSibling Method
The new bookmark's title.
Adds a new bookmark to the tree containing the current bookmark as the new right sibling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AddNewSibling( _
   ByVal text As String _
) As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim text As String
Dim value As ImGearPDFBookmark

value = instance.AddNewSibling(text)
public ImGearPDFBookmark AddNewSibling(
   string text
)
public: ImGearPDFBookmark* AddNewSibling(
   string* text
)
public:
ImGearPDFBookmark^ AddNewSibling(
   String^ text
)

Parameters

text
The new bookmark's title.

Return Value

The newly created bookmark.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


AddNext Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddNext Method
The bookmark to become the new right sibling of the current bookmark. Next must have been previously unlinked.
Adds next bookmark as the new right sibling to the current one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddNext( _
   ByVal bookmark As ImGearPDFBookmark _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim bookmark As ImGearPDFBookmark

instance.AddNext(bookmark)
public void AddNext(
   ImGearPDFBookmark bookmark
)
public: void AddNext(
   ImGearPDFBookmark* bookmark
)
public:
void AddNext(
   ImGearPDFBookmark^ bookmark
)

Parameters

bookmark
The bookmark to become the new right sibling of the current bookmark. Next must have been previously unlinked.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


AddPrev Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddPrev Method
The bookmark to become the new left sibling of the current bookmark. This bookmark must have been previously unlinked.
Adds bookmark as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPrev( _
   ByVal bookmark As ImGearPDFBookmark _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim bookmark As ImGearPDFBookmark

instance.AddPrev(bookmark)
public void AddPrev(
   ImGearPDFBookmark bookmark
)
public: void AddPrev(
   ImGearPDFBookmark* bookmark
)
public:
void AddPrev(
   ImGearPDFBookmark^ bookmark
)

Parameters

bookmark
The bookmark to become the new left sibling of the current bookmark. This bookmark must have been previously unlinked.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


AddSubtree Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : AddSubtree Method
The bookmark sub-tree to add.
The new bookmark's title.
Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddSubtree( _
   ByVal subtree As ImGearPDFBookmark, _
   ByVal sourceTitle As String _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim subtree As ImGearPDFBookmark
Dim sourceTitle As String

instance.AddSubtree(subtree, sourceTitle)
public void AddSubtree(
   ImGearPDFBookmark subtree,
   string sourceTitle
)
public: void AddSubtree(
   ImGearPDFBookmark* subtree,
   string* sourceTitle
)
public:
void AddSubtree(
   ImGearPDFBookmark^ subtree,
   String^ sourceTitle
)

Parameters

subtree
The bookmark sub-tree to add.
sourceTitle
The new bookmark's title.
Remarks
This new item will have the text value sourceTitle, will be open, and will have no destination attribute. Subtree must have been previously unlinked. If the current bookmark previously had no children, it will be open after the sub-tree is added.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


FindTitle Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : FindTitle Method
The text value to search for.
The number of sub-tree levels to search, not counting the root level. 0 - Only look at the current bookmark, not at any of its children. 1 - Check the current bookmark and its children, but not any grandchildren or great grandchildren, and so on. -1 - Check the entire sub-tree.
Gets the first bookmark whose title is Title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindTitle( _
   ByVal title As String, _
   ByVal maxDepth As Integer _
) As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim title As String
Dim maxDepth As Integer
Dim value As ImGearPDFBookmark

value = instance.FindTitle(title, maxDepth)
public ImGearPDFBookmark FindTitle(
   string title,
   int maxDepth
)
public: ImGearPDFBookmark* FindTitle(
   string* title,
   int maxDepth
)
public:
ImGearPDFBookmark^ FindTitle(
   String^ title,
   int maxDepth
)

Parameters

title
The text value to search for.
maxDepth
The number of sub-tree levels to search, not counting the root level. 0 - Only look at the current bookmark, not at any of its children. 1 - Check the current bookmark and its children, but not any grandchildren or great grandchildren, and so on. -1 - Check the entire sub-tree.

Return Value

The bookmark with the specified title or Null if there is no such bookmark.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


GetAction Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetAction Method
Gets the bookmark's action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAction() As ImGearPDFAction
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFAction

value = instance.GetAction()
public ImGearPDFAction GetAction()
public: ImGearPDFAction* GetAction();
public:
ImGearPDFAction^ GetAction();

Return Value

The bookmark's action - ImGearPDFAction class object.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members
ImGearPDFAction Class


GetColor Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetColor Method
Gets the color of the bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColor() As ImGearPixel
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPixel

value = instance.GetColor()
public ImGearPixel GetColor()
public: ImGearPixel* GetColor();
public:
ImGearPixel^ GetColor();

Return Value

ImageGear.Core.ImGearPixel class - Color of the bookmark.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members
ImGearPixel Class


GetFirstChild Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetFirstChild Method
Gets the bookmark's first child.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFirstChild() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmark

value = instance.GetFirstChild()
public ImGearPDFBookmark GetFirstChild()
public: ImGearPDFBookmark* GetFirstChild();
public:
ImGearPDFBookmark^ GetFirstChild();

Return Value

First child of the bookmark or Null if the bookmark has no children.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


GetLastChild Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetLastChild Method
Gets the bookmark's last child.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLastChild() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmark

value = instance.GetLastChild()
public ImGearPDFBookmark GetLastChild()
public: ImGearPDFBookmark* GetLastChild();
public:
ImGearPDFBookmark^ GetLastChild();

Return Value

Last child of the bookmark or Null if the bookmark has no children.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


GetNext Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetNext Method
Gets the bookmark's next (right) sibling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNext() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmark

value = instance.GetNext()
public ImGearPDFBookmark GetNext()
public: ImGearPDFBookmark* GetNext();
public:
ImGearPDFBookmark^ GetNext();

Return Value

The bookmark's next (right) sibling or Null if the bookmark has no next sibling (it is its parent's last child).
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


GetParent Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetParent Method
Gets the bookmark's parent bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetParent() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmark

value = instance.GetParent()
public ImGearPDFBookmark GetParent()
public: ImGearPDFBookmark* GetParent();
public:
ImGearPDFBookmark^ GetParent();

Return Value

Parent bookmark of the bookmark or Null if the bookmark is the root of its tree.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


GetPrev Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : GetPrev Method
Gets the bookmark 's previous (left) sibling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPrev() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmark

value = instance.GetPrev()
public ImGearPDFBookmark GetPrev()
public: ImGearPDFBookmark* GetPrev();
public:
ImGearPDFBookmark^ GetPrev();

Return Value

Previous (left) sibling of the bookmark or Null if the bookmark has no previous sibling (it is its parent's first child).
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


Remove Method (ImGearPDFBookmark)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Remove Method
Removes the bookmark's sub-tree from the bookmark tree containing it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove()
'Usage

Dim instance As ImGearPDFBookmark

instance.Remove()
public void Remove()
public: void Remove();
public:
void Remove();
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


RemoveAction Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : RemoveAction Method
Removes the bookmark's action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAction()
'Usage

Dim instance As ImGearPDFBookmark

instance.RemoveAction()
public void RemoveAction()
public: void RemoveAction();
public:
void RemoveAction();
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


SetAction Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : SetAction Method
The bookmark action to set.
Sets the bookmark's action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAction( _
   ByVal action As ImGearPDFAction _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim action As ImGearPDFAction

instance.SetAction(action)
public void SetAction(
   ImGearPDFAction action
)
public: void SetAction(
   ImGearPDFAction* action
)
public:
void SetAction(
   ImGearPDFAction^ action
)

Parameters

action
The bookmark action to set.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members
ImGearPDFAction Class


SetColor Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : SetColor Method
The bookmark's color to set. Must be RGB.
Sets the bookmark's color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetColor( _
   ByVal color As ImGearPixel _
)
'Usage

Dim instance As ImGearPDFBookmark
Dim color As ImGearPixel

instance.SetColor(color)
public void SetColor(
   ImGearPixel color
)
public: void SetColor(
   ImGearPixel* color
)
public:
void SetColor(
   ImGearPixel^ color
)

Parameters

color
The bookmark's color to set. Must be RGB.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members
ImGearPixel Class


Unlink Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Unlink Method
Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Unlink()
'Usage

Dim instance As ImGearPDFBookmark

instance.Unlink()
public void Unlink()
public: void Unlink();
public:
void Unlink();
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


%%PageItemTitle%% $$Properties$$

ImGearPDFBookmark Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBookmark Class

For a list of all members of this type, see ImGearPDFBookmark members.

Public Properties
 | Name | Description
Public Property | Count | Gets a number of open bookmarks in the sub-tree (not including the current one).
Public Property | Flags | Gets or sets bookmark's flags.
Public Property | HasChildren | Gets a value indicating whether the bookmark has any children.
Public Property | Indent | Gets the indentation level of the bookmark in its containing tree.
Public Property | Open | Gets or sets a value indicating whether the bookmark is open (shows all its children).
Public Property | Title | Gets or sets string specifying the bookmark's title.
Top
See Also

Reference

ImGearPDFBookmark Class
ImageGear.Formats.PDF Namespace


Count Property (ImGearPDFBookmark)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Count Property
Gets a number of open bookmarks in the sub-tree (not including the current one).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearPDFBookmark
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


Flags Property (ImGearPDFBookmark)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Flags Property
Gets or sets bookmark's flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As ImGearPDFBookmarkFlags
'Usage

Dim instance As ImGearPDFBookmark
Dim value As ImGearPDFBookmarkFlags

instance.Flags = value

value = instance.Flags
public ImGearPDFBookmarkFlags Flags {get; set;}
public: __property ImGearPDFBookmarkFlags get_Flags();
public: __property void set_Flags(
   ImGearPDFBookmarkFlags value
);
public:
property ImGearPDFBookmarkFlags Flags {
   ImGearPDFBookmarkFlags get();
   void set (    ImGearPDFBookmarkFlags value);
}

Property Value

ImGearPDFBookmarkFlags enumeration value.
Remarks
The OR value of the ImGearPDFBookmarkFlags.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members
ImGearPDFBookmarkFlags Enumeration


HasChildren Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : HasChildren Property
Gets a value indicating whether the bookmark has any children.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasChildren As Boolean
'Usage

Dim instance As ImGearPDFBookmark
Dim value As Boolean

value = instance.HasChildren
public bool HasChildren {get;}
public: __property bool get_HasChildren();
public:
property bool HasChildren {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


Indent Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Indent Property
Gets the indentation level of the bookmark in its containing tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Indent As Integer
'Usage

Dim instance As ImGearPDFBookmark
Dim value As Integer

value = instance.Indent
public int Indent {get;}
public: __property int get_Indent();
public:
property int Indent {
   int get();
}

Property Value

Integer value.
Remarks
The root level has an indentation level of zero.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


Open Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Open Property
Gets or sets a value indicating whether the bookmark is open (shows all its children).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Open As Boolean
'Usage

Dim instance As ImGearPDFBookmark
Dim value As Boolean

instance.Open = value

value = instance.Open
public bool Open {get; set;}
public: __property bool get_Open();
public: __property void set_Open(
   bool value
);
public:
property bool Open {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


Title Property (ImGearPDFBookmark)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFBookmark Class : Title Property
Gets or sets string specifying the bookmark's title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As ImGearPDFBookmark
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPDFBookmark Class
ImGearPDFBookmark Members


%%PageItemTitle%%

ImGearPDFDestination Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDestination Class
Represents a particular view of a page in a document.
Object Model
ImGearPDFDestination ClassImGearPDFAtom ClassImGearPDFBasObj ClassImGearPDFFixedRect ClassImGearPDFDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFDestination
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFDestination
public sealed class ImGearPDFDestination : ImGearPDFObject
public __gc __sealed class ImGearPDFDestination : public ImGearPDFObject
public ref class ImGearPDFDestination sealed : public ImGearPDFObject
Remarks
It contains a reference to a page, a rectangle on that page, and information specifying how to adjust the view to fit the window's size and shape. See section 8.2, "Document-Level Navigation," in the PDF Reference for more information on destinations.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFDestination

See Also

Reference

ImGearPDFDestination Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFDestination Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDestination Class

The following tables list the members exposed by ImGearPDFDestination.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFDestination Constructor | Initializes a new instance of the ImGearPDFDestination class.
Top
Public Properties
 | Name | Description
Public Property | FitType | Gets the destination's fit type.
Public Property | PageNumber | Gets the page number of the destination's page.
Public Property | Type | Gets the destination type.
Public Property | Zoom | Gets the destination's zoom factor.
Top
Public Methods
 | Name | Description
Public Method | GetName | Gets the destination's named attributes.
Public Method | GetRect | Gets the destination rectangle.
Public Method | Remove | Removes a view destination object.
Public Method | Resolve | Resolves the destination.
Top
See Also

Reference

ImGearPDFDestination Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDestination Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : ImGearPDFDestination Constructor
The document in which the destination is used.
The destination page.
Destination fit type. Must be one of the View Destination Fit Types. See section 8.2, "Document-Level Navigation", in the PDF Reference for more information on destinations, and specifically Table 8.2 for Destination Fit Types.
Destination rectangle, specified in user space coordinates. The appropriate information will be extracted from rect, depending on fitType, to create the destination. All four of rect's components should be set.
The zoom factor to set for the destination. Used only if fitType is XYZ.
Page number of the destination's page.
Initializes a new instance of the ImGearPDFDestination class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal page As ImGearPDFPage, _
   ByVal fitType As ImGearPDFAtom, _
   ByVal rect As ImGearPDFFixedRect, _
   ByVal zoom As Integer, _
   ByVal pageNumber As Integer _
)
'Usage

Dim document As ImGearPDFDocument
Dim page As ImGearPDFPage
Dim fitType As ImGearPDFAtom
Dim rect As ImGearPDFFixedRect
Dim zoom As Integer
Dim pageNumber As Integer

Dim instance As New ImGearPDFDestination(document, page, fitType, rect, zoom, pageNumber)
public ImGearPDFDestination(
   ImGearPDFDocument document,
   ImGearPDFPage page,
   ImGearPDFAtom fitType,
   ImGearPDFFixedRect rect,
   int zoom,
   int pageNumber
)
public: ImGearPDFDestination(
   ImGearPDFDocument* document,
   ImGearPDFPage* page,
   ImGearPDFAtom* fitType,
   ImGearPDFFixedRect* rect,
   int zoom,
   int pageNumber
)
public:
ImGearPDFDestination(
   ImGearPDFDocument^ document,
   ImGearPDFPage^ page,
   ImGearPDFAtom^ fitType,
   ImGearPDFFixedRect^ rect,
   int zoom,
   int pageNumber
)

Parameters

document
The document in which the destination is used.
page
The destination page.
fitType
Destination fit type. Must be one of the View Destination Fit Types. See section 8.2, "Document-Level Navigation", in the PDF Reference for more information on destinations, and specifically Table 8.2 for Destination Fit Types.
rect
Destination rectangle, specified in user space coordinates. The appropriate information will be extracted from rect, depending on fitType, to create the destination. All four of rect's components should be set.
zoom
The zoom factor to set for the destination. Used only if fitType is XYZ.
pageNumber
Page number of the destination's page.

Return Value

The new instance of ImGearPDFDestination class object.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFDocument Class
ImGearPDFPreflight Class
ImGearPDFAtom Class
ImGearPDFFixedRect Class


%%PageItemTitle%% $$Methods$$

ImGearPDFDestination Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDestination Class

For a list of all members of this type, see ImGearPDFDestination members.

Public Methods
 | Name | Description
Public Method | GetName | Gets the destination's named attributes.
Public Method | GetRect | Gets the destination rectangle.
Public Method | Remove | Removes a view destination object.
Public Method | Resolve | Resolves the destination.
Top
See Also

Reference

ImGearPDFDestination Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDestination Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : ImGearPDFDestination Constructor
Overload List
Overload | Description
ImGearPDFDestination Constructor | Initializes a new instance of the ImGearPDFDestination class.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members


GetName Method (ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : GetName Method
Gets the destination's named attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetName() As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFDestination
Dim value As ImGearPDFBasObj

value = instance.GetName()
public ImGearPDFBasObj GetName()
public: ImGearPDFBasObj* GetName();
public:
ImGearPDFBasObj^ GetName();

Return Value

Basic array object for the destination. Returns Null if the destination is invalid.
Remarks
Applies only to NAMED type of destination.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFBasObj Class


GetRect Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : GetRect Method
Gets the destination rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRect() As ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDFDestination
Dim value As ImGearPDFFixedRect

value = instance.GetRect()
public ImGearPDFFixedRect GetRect()
public: ImGearPDFFixedRect* GetRect();
public:
ImGearPDFFixedRect^ GetRect();

Return Value

The destination's rectangle specified in user space coordinates.
Remarks
Applies only to EXPLICIT type of destination.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFFixedRect Class


Remove Method (ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : Remove Method
Removes a view destination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove()
'Usage

Dim instance As ImGearPDFDestination

instance.Remove()
public void Remove()
public: void Remove();
public:
void Remove();
Remarks
Before deleting a view destination, ensure that no link or bookmark refers to it.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members


Resolve Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : Resolve Method
The PDF document that contains the destination.
Resolves the destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Resolve( _
   ByVal document As ImGearPDFDocument _
) As ImGearPDFDestination
'Usage

Dim instance As ImGearPDFDestination
Dim document As ImGearPDFDocument
Dim value As ImGearPDFDestination

value = instance.Resolve(document)
public ImGearPDFDestination Resolve(
   ImGearPDFDocument document
)
public: ImGearPDFDestination* Resolve(
   ImGearPDFDocument* document
)
public:
ImGearPDFDestination^ Resolve(
   ImGearPDFDocument^ document
)

Parameters

document
The PDF document that contains the destination.

Return Value

The resolved view destination.
Remarks
The destination is a value of the D key in an action. It can be a real destination (an array) or a name. If it is a name, look it up in Document Dests dictionary. The value found there can be a real destination (an array) or a dictionary. If it's a dictionary, look up the D key in that dictionary. This method is useful for getting an explicit view destination from an action.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFDocument Class


%%PageItemTitle%% $$Properties$$

ImGearPDFDestination Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDestination Class

For a list of all members of this type, see ImGearPDFDestination members.

Public Properties
 | Name | Description
Public Property | FitType | Gets the destination's fit type.
Public Property | PageNumber | Gets the page number of the destination's page.
Public Property | Type | Gets the destination type.
Public Property | Zoom | Gets the destination's zoom factor.
Top
See Also

Reference

ImGearPDFDestination Class
ImageGear.Formats.PDF Namespace


FitType Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : FitType Property
Gets the destination's fit type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FitType As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFDestination
Dim value As ImGearPDFAtom

value = instance.FitType
public ImGearPDFAtom FitType {get;}
public: __property ImGearPDFAtom* get_FitType();
public:
property ImGearPDFAtom^ FitType {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
Remarks
Applies only to EXPLICIT type of destination.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFAtom Class


PageNumber Property (ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : PageNumber Property
Gets the page number of the destination's page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearPDFDestination
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
Remarks
Applies only to EXPLICIT type of destination.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members


Type Property (ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : Type Property
Gets the destination type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearPDFDestinationType
'Usage

Dim instance As ImGearPDFDestination
Dim value As ImGearPDFDestinationType

value = instance.Type
public ImGearPDFDestinationType Type {get;}
public: __property ImGearPDFDestinationType get_Type();
public:
property ImGearPDFDestinationType Type {
   ImGearPDFDestinationType get();
}

Property Value

ImGearPDFDestinationType enumeration value.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members
ImGearPDFDestinationType Enumeration


Zoom Property (ImGearPDFDestination)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDestination Class : Zoom Property
Gets the destination's zoom factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Zoom As Integer
'Usage

Dim instance As ImGearPDFDestination
Dim value As Integer

value = instance.Zoom
public int Zoom {get;}
public: __property int get_Zoom();
public:
property int Zoom {
   int get();
}

Property Value

Integer value.
Remarks
Applies only to EXPLICIT type of destination.
See Also

Reference

ImGearPDFDestination Class
ImGearPDFDestination Members


%%PageItemTitle%%

ImGearPDFDictionary Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDictionary Class
Represents a PDF dictionary.
Object Model
ImGearPDFDictionary ClassImGearPDFBasObj ClassImGearPDFLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFDictionary
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFDictionary
public sealed class ImGearPDFDictionary : ImGearPDFObject
public __gc __sealed class ImGearPDFDictionary : public ImGearPDFObject
public ref class ImGearPDFDictionary sealed : public ImGearPDFObject
Remarks
PDF dictionary class is used to work with the optional content. Can be manipulated in a UI to affect changes in visibility of content. It is used when an element belongs to one or more OCGs (layer(s)). See Adobe PDF documentation for more information.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFDictionary

See Also

Reference

ImGearPDFDictionary Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFDictionary Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDictionary Class

The following tables list the members exposed by ImGearPDFDictionary.

Public Properties
 | Name | Description
Public Property | LayersCount | Gets the number of layers listed in a membership dictionary.
Public Property | UniqueId | Gets some 32-bit integer that is unique for all Dictionary objects.
Public Property | VisPolicy | Gets the optional-content membership dictionary's visibility policy.
Top
Public Methods
 | Name | Description
Public Method | GetBasObj | Returns basic object of the Dictionary.
Public Method | GetLayer | Gets the layer with the specified index in a membership dictionary.
Top
See Also

Reference

ImGearPDFDictionary Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFDictionary Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDictionary Class

For a list of all members of this type, see ImGearPDFDictionary members.

Public Methods
 | Name | Description
Public Method | GetBasObj | Returns basic object of the Dictionary.
Public Method | GetLayer | Gets the layer with the specified index in a membership dictionary.
Top
See Also

Reference

ImGearPDFDictionary Class
ImageGear.Formats.PDF Namespace


GetBasObj Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDictionary Class : GetBasObj Method
Returns basic object of the Dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBasObj() As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFDictionary
Dim value As ImGearPDFBasObj

value = instance.GetBasObj()
public ImGearPDFBasObj GetBasObj()
public: ImGearPDFBasObj* GetBasObj();
public:
ImGearPDFBasObj^ GetBasObj();

Return Value

ImGearPDFBasObj class of the Dictionary.
Remarks
Used for Container creation.
See Also

Reference

ImGearPDFDictionary Class
ImGearPDFDictionary Members
ImGearPDFBasObj Class


GetLayer Method (ImGearPDFDictionary)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDictionary Class : GetLayer Method
The index of the needed layer in the dictionary.
Gets the layer with the specified index in a membership dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLayer( _
   ByVal index As Integer _
) As ImGearPDFLayer
'Usage

Dim instance As ImGearPDFDictionary
Dim index As Integer
Dim value As ImGearPDFLayer

value = instance.GetLayer(index)
public ImGearPDFLayer GetLayer(
   int index
)
public: ImGearPDFLayer* GetLayer(
   int index
)
public:
ImGearPDFLayer^ GetLayer(
   int index
)

Parameters

index
The index of the needed layer in the dictionary.

Return Value

ImGearPDFLayer object.
See Also

Reference

ImGearPDFDictionary Class
ImGearPDFDictionary Members
ImGearPDFLayer Class


%%PageItemTitle%% $$Properties$$

ImGearPDFDictionary Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDictionary Class

For a list of all members of this type, see ImGearPDFDictionary members.

Public Properties
 | Name | Description
Public Property | LayersCount | Gets the number of layers listed in a membership dictionary.
Public Property | UniqueId | Gets some 32-bit integer that is unique for all Dictionary objects.
Public Property | VisPolicy | Gets the optional-content membership dictionary's visibility policy.
Top
See Also

Reference

ImGearPDFDictionary Class
ImageGear.Formats.PDF Namespace


LayersCount Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDictionary Class : LayersCount Property
Gets the number of layers listed in a membership dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayersCount As Integer
'Usage

Dim instance As ImGearPDFDictionary
Dim value As Integer

value = instance.LayersCount
public int LayersCount {get;}
public: __property int get_LayersCount();
public:
property int LayersCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFDictionary Class
ImGearPDFDictionary Members
ImGearPDFLayer Class


UniqueId Property (ImGearPDFDictionary)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDictionary Class : UniqueId Property
Gets some 32-bit integer that is unique for all Dictionary objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UniqueId As Integer
'Usage

Dim instance As ImGearPDFDictionary
Dim value As Integer

value = instance.UniqueId
public int UniqueId {get;}
public: __property int get_UniqueId();
public:
property int UniqueId {
   int get();
}

Property Value

Integer value.
Remarks
It is guaranteed that there cannot be two Dictionary objects with the same UniqueIds.

Can be used for Dictionary object's identification.

See Also

Reference

ImGearPDFDictionary Class
ImGearPDFDictionary Members
ImGearPDFLayer Class


VisPolicy Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDictionary Class : VisPolicy Property
Gets the optional-content membership dictionary's visibility policy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisPolicy As ImGearPDFOCMDVisPolicy
'Usage

Dim instance As ImGearPDFDictionary
Dim value As ImGearPDFOCMDVisPolicy

value = instance.VisPolicy
public ImGearPDFOCMDVisPolicy VisPolicy {get;}
public: __property ImGearPDFOCMDVisPolicy get_VisPolicy();
public:
property ImGearPDFOCMDVisPolicy VisPolicy {
   ImGearPDFOCMDVisPolicy get();
}

Property Value

ImGearPDFOCMDVisPolicy enumeration value.
Remarks
Gets the optional-content membership dictionary's visibility policy, which determines the visibility of content with respect to the ON-OFF state of the layers listed in the dictionary.
See Also

Reference

ImGearPDFDictionary Class
ImGearPDFDictionary Members
ImGearPDFOCMDVisPolicy Enumeration
ImGearPDFLayer Class


%%PageItemTitle%%

ImGearPDFDocument Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument Class
Represents PDF document.
Object Model
ImGearPDFDocument ClassImGearDocument ClassImGearPDFDictionary ClassImGearPDFLayer ClassImGearPDFPage ClassImGearPDFBookmark ClassImGearPDFLayer ClassImGearPDFAtom ClassImGearPDFSecurityData ClassImGearPDFBasDict ClassImGearPDFSecurityData ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearPDFDocument
public sealed class ImGearPDFDocument : ImageGear.Core.ImGearDocument
public __gc __sealed class ImGearPDFDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearPDFDocument sealed : public ImageGear.Core.ImGearDocument
Remarks
This class is used to work with PDF or PS documents.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.Formats.PDF.ImGearPDFDocument

See Also

Reference

ImGearPDFDocument Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFDocument Class Members
Fields Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument Class

The following tables list the members exposed by ImGearPDFDocument.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFDocument Constructor | Initializes a new instance of the ImGearPDFDocument class.
Top
Public Properties
 | Name | Description
Public Property | LayerCount | Gets layer count for the document.
Public Property | Pages | Overridden. Gets a collection of the document pages.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the document.
Public Method | CreateDictionary | Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.
Public Method | CreateLayer | Creates a new layer (optional-content group) object in the document.
Public Method | CreateNewPage | Creates new page in the document.
Public Method | ExtractText | Extracts text from the document.
Public Method | GetBookmark | Gets the root of the document's bookmark tree.
Public Method | GetInfo | Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.
Public Method | GetLayer | Gets the layer with a specified index.
Public Method | GetNewCryptHandler | This method gets the specified document's new security handler.
Public Method | GetNewSecurityData | This method gets the security data for the specified document's new security handler.
Public Method | GetNewSecurityInfo | This method gets the security information from the specified document's new security handler.
Public Method | GetRoot | This method returns the Catalog dictionary of the PDF document.
Public Method | GetSecurityData | This method gets the security data for the specified document's current security handler.
Public Method | InsertPages | Inserts pages from given document into the current document.
Public Method | PermRequest | Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.
Public Method | Print | Prints document.
static (Shared in Visual Basic) | RegisterAuthProc | Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set.
Public Method | RemoveLayer | Destroys the layer (optional-content group) object.
Public Method | Save | Overloaded. Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
Public Method | SetInfo | Sets the value of a key in a document's Info dictionary.
Public Method | SetNewCryptHandler | This method sets specified document's new security handler.
Public Method | SetNewSecurityData | This method sets the security data structure for the specified document's new security handler.
Top
See Also

Reference

ImGearPDFDocument Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Fields$$

ImGearPDFDocument Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument Class

For a list of all members of this type, see ImGearPDFDocument members.

See Also

Reference

ImGearPDFDocument Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDocument Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : ImGearPDFDocument Constructor
Initializes a new instance of the ImGearPDFDocument class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFDocument()
public ImGearPDFDocument()
public: ImGearPDFDocument();
public:
ImGearPDFDocument();

Return Value

The new instance of ImGearPDFDocument class object.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


%%PageItemTitle%% $$Methods$$

ImGearPDFDocument Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument Class

For a list of all members of this type, see ImGearPDFDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the document.
Public Method | CreateDictionary | Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.
Public Method | CreateLayer | Creates a new layer (optional-content group) object in the document.
Public Method | CreateNewPage | Creates new page in the document.
Public Method | ExtractText | Extracts text from the document.
Public Method | GetBookmark | Gets the root of the document's bookmark tree.
Public Method | GetInfo | Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.
Public Method | GetLayer | Gets the layer with a specified index.
Public Method | GetNewCryptHandler | This method gets the specified document's new security handler.
Public Method | GetNewSecurityData | This method gets the security data for the specified document's new security handler.
Public Method | GetNewSecurityInfo | This method gets the security information from the specified document's new security handler.
Public Method | GetRoot | This method returns the Catalog dictionary of the PDF document.
Public Method | GetSecurityData | This method gets the security data for the specified document's current security handler.
Public Method | InsertPages | Inserts pages from given document into the current document.
Public Method | PermRequest | Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.
Public Method | Print | Prints document.
static (Shared in Visual Basic) | RegisterAuthProc | Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set.
Public Method | RemoveLayer | Destroys the layer (optional-content group) object.
Public Method | Save | Overloaded. Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
Public Method | SetInfo | Sets the value of a key in a document's Info dictionary.
Public Method | SetNewCryptHandler | This method sets specified document's new security handler.
Public Method | SetNewSecurityData | This method sets the security data structure for the specified document's new security handler.
Top
See Also

Reference

ImGearPDFDocument Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDocument Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : ImGearPDFDocument Constructor
Overload List
Overload | Description
ImGearPDFDocument Constructor | Initializes a new instance of the ImGearPDFDocument class.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


Clone Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : Clone Method
Clones the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

Copy of the document.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


CreateDictionary Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : CreateDictionary Method
Array of layers to be members of the dictionary.
The visibility policy that determines the visibility of content with respect to the ON/OFF state of the layers listed in the dictionary.
Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateDictionary( _
   ByVal layers() As ImGearPDFLayer, _
   ByVal visibilityPolicy As ImGearPDFOCMDVisPolicy _
) As ImGearPDFDictionary
'Usage

Dim instance As ImGearPDFDocument
Dim layers() As ImGearPDFLayer
Dim visibilityPolicy As ImGearPDFOCMDVisPolicy
Dim value As ImGearPDFDictionary

value = instance.CreateDictionary(layers, visibilityPolicy)
public ImGearPDFDictionary CreateDictionary(
   ImGearPDFLayer[] layers,
   ImGearPDFOCMDVisPolicy visibilityPolicy
)
public: ImGearPDFDictionary* CreateDictionary(
   ImGearPDFLayer*[]* layers,
   ImGearPDFOCMDVisPolicy visibilityPolicy
)
public:
ImGearPDFDictionary^ CreateDictionary(
   array<ImGearPDFLayer^>^ layers,
   ImGearPDFOCMDVisPolicy visibilityPolicy
)

Parameters

layers
Array of layers to be members of the dictionary.
visibilityPolicy
The visibility policy that determines the visibility of content with respect to the ON/OFF state of the layers listed in the dictionary.

Return Value

The newly created dictionary object, or Null if no layers are supplied.
Remarks
To add a layer to the existing dictionary, get the current layers list, modify it, then create a new dictionary with the new list of layers.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFLayer Class
ImGearPDFOCMDVisPolicy Enumeration


CreateLayer Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : CreateLayer Method
The name of the layer.
Creates a new layer (optional-content group) object in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateLayer( _
   ByVal name As String _
) As ImGearPDFLayer
'Usage

Dim instance As ImGearPDFDocument
Dim name As String
Dim value As ImGearPDFLayer

value = instance.CreateLayer(name)
public ImGearPDFLayer CreateLayer(
   string name
)
public: ImGearPDFLayer* CreateLayer(
   string* name
)
public:
ImGearPDFLayer^ CreateLayer(
   String^ name
)

Parameters

name
The name of the layer.

Return Value

The newly created group object.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFLayer Class


CreateNewPage Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : CreateNewPage Method
The page number after which the new page is inserted. The first page is 0. Use BEFORE_FIRST_PAGE to insert the new page at the beginning of a document.
Rectangle specifying the page's media box, specified in user space coordinates.
Creates new page in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateNewPage( _
   ByVal precedingIndex As Integer, _
   ByVal mediaBox As ImGearPDFFixedRect _
) As ImGearPDFPage
'Usage

Dim instance As ImGearPDFDocument
Dim precedingIndex As Integer
Dim mediaBox As ImGearPDFFixedRect
Dim value As ImGearPDFPage

value = instance.CreateNewPage(precedingIndex, mediaBox)
public ImGearPDFPage CreateNewPage(
   int precedingIndex,
   ImGearPDFFixedRect mediaBox
)
public: ImGearPDFPage* CreateNewPage(
   int precedingIndex,
   ImGearPDFFixedRect* mediaBox
)
public:
ImGearPDFPage^ CreateNewPage(
   int precedingIndex,
   ImGearPDFFixedRect^ mediaBox
)

Parameters

precedingIndex
The page number after which the new page is inserted. The first page is 0. Use BEFORE_FIRST_PAGE to insert the new page at the beginning of a document.
mediaBox
Rectangle specifying the page's media box, specified in user space coordinates.

Return Value

ImGearPDFPreflight class object.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFPreflight Class
ImGearPDFFixedRect Class


Dispose Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


Dispose(Boolean) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearPDFDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
Overload List


ExtractText Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : ExtractText Method
Start page index.
Page count.
Context options.
Output stream.
Extracts text from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ExtractText( _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer, _
   ByVal options As ImGearPDFContextFlags, _
   ByVal outputStream As Stream _
)
'Usage

Dim instance As ImGearPDFDocument
Dim startPageNumber As Integer
Dim pageCount As Integer
Dim options As ImGearPDFContextFlags
Dim outputStream As Stream

instance.ExtractText(startPageNumber, pageCount, options, outputStream)
public void ExtractText(
   int startPageNumber,
   int pageCount,
   ImGearPDFContextFlags options,
   Stream outputStream
)
public: void ExtractText(
   int startPageNumber,
   int pageCount,
   ImGearPDFContextFlags options,
   Stream* outputStream
)
public:
void ExtractText(
   int startPageNumber,
   int pageCount,
   ImGearPDFContextFlags options,
   Stream^ outputStream
)

Parameters

startPageNumber
Start page index.
pageCount
Page count.
options
Context options.
outputStream
Output stream.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFContextFlags Enumeration


GetBookmark Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetBookmark Method
Gets the root of the document's bookmark tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBookmark() As ImGearPDFBookmark
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFBookmark

value = instance.GetBookmark()
public ImGearPDFBookmark GetBookmark()
public: ImGearPDFBookmark* GetBookmark();
public:
ImGearPDFBookmark^ GetBookmark();

Return Value

The document's root bookmark.
Remarks
The returned value is valid even if document's bookmark tree is empty.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFBookmark Class


GetInfo Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetInfo Method
The name of the Info dictionary key whose value is obtained.
Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetInfo( _
   ByVal key As String _
) As String
'Usage

Dim instance As ImGearPDFDocument
Dim key As String
Dim value As String

value = instance.GetInfo(key)
public string GetInfo(
   string key
)
public: string* GetInfo(
   string* key
)
public:
String^ GetInfo(
   String^ key
)

Parameters

key
The name of the Info dictionary key whose value is obtained.

Return Value

String containing the value associated with InfoKey.
Remarks

This method can be used to obtain the values of the following standard document information dictionary keys: "Title", "Author", "Subject", "Keywords", "Creator", "Producer", "Created" and "Modified".

See Section 10.2.1 in the PDF Reference for information about Info dictionaries. All values in the Info dictionary should be strings; other data types such as numbers and Booleans should not be used as values in the Info dictionary.

Users may define their own Info dictionary entries. In this case, it is strongly recommended that the key have the developer's prefix assigned by the Adobe Solutions Network.

See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class


GetLayer Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetLayer Method
Index of the layer to obtain.
Gets the layer with a specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLayer( _
   ByVal index As Integer _
) As ImGearPDFLayer
'Usage

Dim instance As ImGearPDFDocument
Dim index As Integer
Dim value As ImGearPDFLayer

value = instance.GetLayer(index)
public ImGearPDFLayer GetLayer(
   int index
)
public: ImGearPDFLayer* GetLayer(
   int index
)
public:
ImGearPDFLayer^ GetLayer(
   int index
)

Parameters

index
Index of the layer to obtain.

Return Value

ImGearPDFLayer class layer object.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFLayer Class


GetNewCryptHandler Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetNewCryptHandler Method
This method gets the specified document's new security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNewCryptHandler() As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFAtom

value = instance.GetNewCryptHandler()
public ImGearPDFAtom GetNewCryptHandler()
public: ImGearPDFAtom* GetNewCryptHandler();
public:
ImGearPDFAtom^ GetNewCryptHandler();

Return Value

ImGearPDFAtom class corresponding to the name of the document's new security handler. Null if the document does not have a new security handler.
Remarks
New security handler is the security handler that will be used after the document is saved). If the document does not have a new security handler, method returns the document's current security handler.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFAtom Class


GetNewSecurityData Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetNewSecurityData Method
This method gets the security data for the specified document's new security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNewSecurityData() As ImGearPDFSecurityData
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFSecurityData

value = instance.GetNewSecurityData()
public ImGearPDFSecurityData GetNewSecurityData()
public: ImGearPDFSecurityData* GetNewSecurityData();
public:
ImGearPDFSecurityData^ GetNewSecurityData();

Return Value

ImGearPDFSecurityData class object for the document's new security handler.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFSecurityData Class


GetNewSecurityInfo Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetNewSecurityInfo Method
This method gets the security information from the specified document's new security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNewSecurityInfo() As ImGearPDFSecurityInfoFlags
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFSecurityInfoFlags

value = instance.GetNewSecurityInfo()
public ImGearPDFSecurityInfoFlags GetNewSecurityInfo()
public: ImGearPDFSecurityInfoFlags GetNewSecurityInfo();
public:
ImGearPDFSecurityInfoFlags GetNewSecurityInfo();

Return Value

The document's new security information. The OR value of the ImGearPDFSecurityInfoFlags enumeration.
Remarks
No permissions are required to call this method.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFSecurityInfoFlags Enumeration


GetRoot Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetRoot Method
This method returns the Catalog dictionary of the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRoot() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFBasDict

value = instance.GetRoot()
public ImGearPDFBasDict GetRoot()
public: ImGearPDFBasDict* GetRoot();
public:
ImGearPDFBasDict^ GetRoot();

Return Value

The resulting Catalog dictionary.
Remarks
Catalog dictionary is the root of a PDF document's object hierarchy.

See also the PDF Reference, ch.3.6.

See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFBasDict Class


GetSecurityData Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : GetSecurityData Method
This method gets the security data for the specified document's current security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSecurityData() As ImGearPDFSecurityData
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearPDFSecurityData

value = instance.GetSecurityData()
public ImGearPDFSecurityData GetSecurityData()
public: ImGearPDFSecurityData* GetSecurityData();
public:
ImGearPDFSecurityData^ GetSecurityData();

Return Value

ImGearPDFSecurityData class - the document's current security data object.
Remarks
Use GetNewSecurityData to get the data for the document's new security handler.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFSecurityData Class


InsertPages Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : InsertPages Method
The page number in the current document after which pages from source document are inserted. The first page is 0. If BEFORE_FIRST_PAGE is used, the pages are inserted before the first page in the current document. Use LAST_PAGE to insert pages after the last page in the current document.
The source document containing the pages that are inserted into the current document.
The page number of the first page in source document to insert into the current document. The first page is 0.
The number of pages in source document to insert into the current document. Use ImGearPDFPageRange.ALL_PAGES to insert all pages from source document into the current document.
Options that determine what additional information is copied from source document into the current document. An OR of ImGearPDFInsertFlagsconstants:

BOOKMARKS - Inserts bookmarks as well as pages. The bookmark tree of source document is merged into the bookmark tree of the current document by copying it as a new first-level subtree of the current document's bookmark tree root, of which it becomes the last child. If the current document has no bookmark tree, it acquires one identical to the bookmark tree from source document.

THREADS - Inserts threads as well as pages.

ALL - Inserts document data from pages.

Inserts pages from given document into the current document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InsertPages( _
   ByVal precedingIndex As Integer, _
   ByVal document As ImGearPDFDocument, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer, _
   ByVal options As ImGearPDFInsertFlags _
)
'Usage

Dim instance As ImGearPDFDocument
Dim precedingIndex As Integer
Dim document As ImGearPDFDocument
Dim startPage As Integer
Dim pageCount As Integer
Dim options As ImGearPDFInsertFlags

instance.InsertPages(precedingIndex, document, startPage, pageCount, options)
public void InsertPages(
   int precedingIndex,
   ImGearPDFDocument document,
   int startPage,
   int pageCount,
   ImGearPDFInsertFlags options
)
public: void InsertPages(
   int precedingIndex,
   ImGearPDFDocument* document,
   int startPage,
   int pageCount,
   ImGearPDFInsertFlags options
)
public:
void InsertPages(
   int precedingIndex,
   ImGearPDFDocument^ document,
   int startPage,
   int pageCount,
   ImGearPDFInsertFlags options
)

Parameters

precedingIndex
The page number in the current document after which pages from source document are inserted. The first page is 0. If BEFORE_FIRST_PAGE is used, the pages are inserted before the first page in the current document. Use LAST_PAGE to insert pages after the last page in the current document.
document
The source document containing the pages that are inserted into the current document.
startPage
The page number of the first page in source document to insert into the current document. The first page is 0.
pageCount
The number of pages in source document to insert into the current document. Use ImGearPDFPageRange.ALL_PAGES to insert all pages from source document into the current document.
options
Options that determine what additional information is copied from source document into the current document. An OR of ImGearPDFInsertFlagsconstants:

BOOKMARKS - Inserts bookmarks as well as pages. The bookmark tree of source document is merged into the bookmark tree of the current document by copying it as a new first-level subtree of the current document's bookmark tree root, of which it becomes the last child. If the current document has no bookmark tree, it acquires one identical to the bookmark tree from source document.

THREADS - Inserts threads as well as pages.

ALL - Inserts document data from pages.

See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFInsertFlags Enumeration


PermRequest Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : PermRequest Method
The target object of the permissions request.
The target operation of the permissions request.
An authorization data (password string).
Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function PermRequest( _
   ByVal targetObject As ImGearPDFPermReqObj, _
   ByVal targetOperation As ImGearPDFPermReqOpr, _
   ByVal password As String _
) As ImGearPDFPermReqStatus
'Usage

Dim instance As ImGearPDFDocument
Dim targetObject As ImGearPDFPermReqObj
Dim targetOperation As ImGearPDFPermReqOpr
Dim password As String
Dim value As ImGearPDFPermReqStatus

value = instance.PermRequest(targetObject, targetOperation, password)
public ImGearPDFPermReqStatus PermRequest(
   ImGearPDFPermReqObj targetObject,
   ImGearPDFPermReqOpr targetOperation,
   string password
)
public: ImGearPDFPermReqStatus PermRequest(
   ImGearPDFPermReqObj targetObject,
   ImGearPDFPermReqOpr targetOperation,
   string* password
)
public:
ImGearPDFPermReqStatus PermRequest(
   ImGearPDFPermReqObj targetObject,
   ImGearPDFPermReqOpr targetOperation,
   String^ password
)

Parameters

targetObject
The target object of the permissions request.
targetOperation
The target operation of the permissions request.
password
An authorization data (password string).

Return Value

One of ImGearPDFPermReqStatus enumeration request status constants.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFPermReqObj Enumeration
ImGearPDFPermReqOpr Enumeration
ImGearPDFPermReqStatus Enumeration


Print Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : Print Method
Printing options.
Prints document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Print( _
   ByVal printOptions As ImGearPDFPrintOptions _
)
'Usage

Dim instance As ImGearPDFDocument
Dim printOptions As ImGearPDFPrintOptions

instance.Print(printOptions)
public void Print(
   ImGearPDFPrintOptions printOptions
)
public: void Print(
   ImGearPDFPrintOptions* printOptions
)
public:
void Print(
   ImGearPDFPrintOptions^ printOptions
)

Parameters

printOptions
Printing options.
Remarks
Native PDF document printing limits the set of ImageGear ART marks that can be printed. They are
  • ImageGear.ART.ImGearARTLine
  • ImageGear.ART.ImGearARTPolyline
  • ImageGear.ART.ImGearARTFreeLine
  • ImageGear.ART.ImGearARTPolygon
These marks are converted to native PDF objects and native PDF printing is able to print these marks. Other ART marks cannot be converted to PDF objects and are not printed.
The standard ImageGear.Display.ImGearPageDisplay.Print method can be used for PDF document printing also. This method rasterizes the PDF document pages and applies ART marks to these pages before printing. This way of printing works more slowly than native printing but is able to print all ImageGear ART marks.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFPrintOptions Class


RegisterAuthProc Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : RegisterAuthProc Method
Authorization callback procedure.
User data.
Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterAuthProc( _
   ByVal authorizationCallback As ImGearPDFDocument.ImGearAuthProc, _
   ByVal userData As Object _
)
'Usage

Dim authorizationCallback As ImGearPDFDocument.ImGearAuthProc
Dim userData As Object

ImGearPDFDocument.RegisterAuthProc(authorizationCallback, userData)
public static void RegisterAuthProc(
   ImGearPDFDocument.ImGearAuthProc authorizationCallback,
   object userData
)
public: static void RegisterAuthProc(
   ImGearPDFDocument.ImGearAuthProc* authorizationCallback,
   Object* userData
)
public:
static void RegisterAuthProc(
   ImGearPDFDocument.ImGearAuthProc^ authorizationCallback,
   Object^ userData
)

Parameters

authorizationCallback
Authorization callback procedure.
userData
User data.
Remarks
See ImGearPDFDocument.ImGearAuthProc for more details.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFDocument.ImGearAuthProc Delegate


RemoveLayer Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : RemoveLayer Method
The layer object.
Destroys the layer (optional-content group) object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveLayer( _
   ByVal layer As ImGearPDFLayer _
)
'Usage

Dim instance As ImGearPDFDocument
Dim layer As ImGearPDFLayer

instance.RemoveLayer(layer)
public void RemoveLayer(
   ImGearPDFLayer layer
)
public: void RemoveLayer(
   ImGearPDFLayer* layer
)
public:
void RemoveLayer(
   ImGearPDFLayer^ layer
)

Parameters

layer
The layer object.
Remarks
This does not delete any content.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFLayer Class


Save Method (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : Save Method
Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
Overload List
Overload | Description
Save(Stream,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) | Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
Save(String,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) | Native PDF saving routine, recommended for saving PDF and PS documents.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


Save(Stream,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) Method
Example

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class > Save Method : Save(Stream,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) Method
Stream object to save to. Only FileStream and MemoryStream are currently supported.
File format to save in.
Starting page number in the stream.
Starting page number in the document.
The number of pages to be saved.
Saving mode.
Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal format As ImGearSavingFormats, _
   ByVal startPageInStream As Integer, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer, _
   ByVal saveMode As ImGearSavingModes _
)
'Usage

Dim instance As ImGearPDFDocument
Dim stream As Stream
Dim format As ImGearSavingFormats
Dim startPageInStream As Integer
Dim startPage As Integer
Dim pageCount As Integer
Dim saveMode As ImGearSavingModes

instance.Save(stream, format, startPageInStream, startPage, pageCount, saveMode)
public void Save(
   Stream stream,
   ImGearSavingFormats format,
   int startPageInStream,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)
public: void Save(
   Stream* stream,
   ImGearSavingFormats format,
   int startPageInStream,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)
public:
void Save(
   Stream^ stream,
   ImGearSavingFormats format,
   int startPageInStream,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)

Parameters

stream
Stream object to save to. Only FileStream and MemoryStream are currently supported.
format
File format to save in.
startPageInStream
Starting page number in the stream.
startPage
Starting page number in the document.
pageCount
The number of pages to be saved.
saveMode
Saving mode.
Example
  • C#
if (igDocument is ImGearPDFDocument)
{
    ImGearPDFDocument pdfDoc = igDocument as ImGearPDFDocument;
    using (MemoryStream mem = new MemoryStream())
    {
        pdfDoc.Save(mem, ImGearSavingFormats.PDF, 0, 0, pdfDoc.Pages.Count, ImGearSavingModes.OVERWRITE);
        using (FileStream file = new FileStream(savePath, FileMode.OpenOrCreate))
        {
            byte[] bytes = mem.ToArray();
            file.Write(bytes, 0, bytes.Length);
        }
    }
}
  • Visual Basic
If TypeOf igDoc Is ImGearPDFDocument Then
    Dim pdfDoc As ImGearPDFDocument
    pdfDoc = igDoc
    'Dim mem As MemoryStream
    Using mem As New MemoryStream()
        pdfDoc.Save(mem, ImGearSavingFormats.PDF, 0, 0, pdfDoc.Pages.Count, ImGearSavingModes.OVERWRITE)
        Using file As New FileStream(savePath, FileMode.OpenOrCreate)
            Dim bytes() As Byte
            bytes = mem.ToArray()
            file.Write(bytes, 0, bytes.Length)
        End Using
    End Using
End If
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
Overload List
ImGearPDFDictionary Class
ImGearSavingFormats Enumeration
ImGearSavingModes Enumeration


Save(String,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class > Save Method : Save(String,ImGearSavingFormats,Int32,Int32,Int32,ImGearSavingModes) Method
File name of file to be saved.
File format to save in.
Starting page number in the file.
Starting page number in the document.
The number of pages to be saved.
Saving mode.
Native PDF saving routine, recommended for saving PDF and PS documents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal format As ImGearSavingFormats, _
   ByVal startPageInFile As Integer, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer, _
   ByVal saveMode As ImGearSavingModes _
)
'Usage

Dim instance As ImGearPDFDocument
Dim fileName As String
Dim format As ImGearSavingFormats
Dim startPageInFile As Integer
Dim startPage As Integer
Dim pageCount As Integer
Dim saveMode As ImGearSavingModes

instance.Save(fileName, format, startPageInFile, startPage, pageCount, saveMode)
public void Save(
   string fileName,
   ImGearSavingFormats format,
   int startPageInFile,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)
public: void Save(
   string* fileName,
   ImGearSavingFormats format,
   int startPageInFile,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)
public:
void Save(
   String^ fileName,
   ImGearSavingFormats format,
   int startPageInFile,
   int startPage,
   int pageCount,
   ImGearSavingModes saveMode
)

Parameters

fileName
File name of file to be saved.
format
File format to save in.
startPageInFile
Starting page number in the file.
startPage
Starting page number in the document.
pageCount
The number of pages to be saved.
saveMode
Saving mode.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
Overload List
ImGearPDFDictionary Class
ImGearSavingFormats Enumeration
ImGearSavingModes Enumeration


SetInfo Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : SetInfo Method
The name of the Info dictionary key whose value is set.
String containing the value to associate with infoKey.
Sets the value of a key in a document's Info dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetInfo( _
   ByVal key As String, _
   ByVal value As String _
)
'Usage

Dim instance As ImGearPDFDocument
Dim key As String
Dim value As String

instance.SetInfo(key, value)
public void SetInfo(
   string key,
   string value
)
public: void SetInfo(
   string* key,
   string* value
)
public:
void SetInfo(
   String^ key,
   String^ value
)

Parameters

key
The name of the Info dictionary key whose value is set.
value
String containing the value to associate with infoKey.
Remarks

This method can be used to set new values for the following standard document information dictionary keys: "Title", "Author", "Subject", "Keywords" and "Creator".

NOTE: The following standard document information dictionary keys are read-only: "Producer", "Created" and "Modified", the library will overwrite the values of these keys on document save.

See Section 10.2.1 on Info dictionaries in the PDF Reference for information about Info dictionaries. All values in the Info dictionary should be strings; other data types such as numbers and Booleans should not be used as values in the Info dictionary. If an info dictionary key is specified that is not currently in the info dictionary, it is added to the dictionary.

See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class


SetNewCryptHandler Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : SetNewCryptHandler Method
The PDF atom for the name of the new security handler to use for the document. Use Null to remove security from the document.
This method sets specified document's new security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetNewCryptHandler( _
   ByVal securityHandlerName As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDFDocument
Dim securityHandlerName As ImGearPDFAtom

instance.SetNewCryptHandler(securityHandlerName)
public void SetNewCryptHandler(
   ImGearPDFAtom securityHandlerName
)
public: void SetNewCryptHandler(
   ImGearPDFAtom* securityHandlerName
)
public:
void SetNewCryptHandler(
   ImGearPDFAtom^ securityHandlerName
)

Parameters

securityHandlerName
The PDF atom for the name of the new security handler to use for the document. Use Null to remove security from the document.
Remarks
The security handler will be used after the document is saved. This method returns with no action if the new security handler is the same as the old one.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFAtom Class


SetNewSecurityData Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : SetNewSecurityData Method
The new security data object to set for document.
This method sets the security data structure for the specified document's new security handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetNewSecurityData( _
   ByVal securityData As ImGearPDFSecurityData _
)
'Usage

Dim instance As ImGearPDFDocument
Dim securityData As ImGearPDFSecurityData

instance.SetNewSecurityData(securityData)
public void SetNewSecurityData(
   ImGearPDFSecurityData securityData
)
public: void SetNewSecurityData(
   ImGearPDFSecurityData* securityData
)
public:
void SetNewSecurityData(
   ImGearPDFSecurityData^ securityData
)

Parameters

securityData
The new security data object to set for document.
Remarks

The new security handler must have been previously set using SetNewCryptHandler.

Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.

See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFSecurityData Class


%%PageItemTitle%% $$Properties$$

ImGearPDFDocument Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument Class

For a list of all members of this type, see ImGearPDFDocument members.

Public Properties
 | Name | Description
Public Property | LayerCount | Gets layer count for the document.
Public Property | Pages | Overridden. Gets a collection of the document pages.
Top
See Also

Reference

ImGearPDFDocument Class
ImageGear.Formats.PDF Namespace


LayerCount Property (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : LayerCount Property
Gets layer count for the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerCount As Integer
'Usage

Dim instance As ImGearPDFDocument
Dim value As Integer

value = instance.LayerCount
public int LayerCount {get;}
public: __property int get_LayerCount();
public:
property int LayerCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members


Pages Property (ImGearPDFDocument)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocument Class : Pages Property
Gets a collection of the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearPDFDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImGearPDFDocumentPageArray class object.
Remarks
This property provides access to the document page array.
See Also

Reference

ImGearPDFDocument Class
ImGearPDFDocument Members
ImGearPDFDictionary Class
ImGearPDFDocumentPageArray Class


%%PageItemTitle%%

ImGearPDFDocumentPageArray Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocumentPageArray Class
Represents PDF document page array.
Object Model
ImGearPDFDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearPDFDocumentPageArray
   Inherits ImageGear.Core.ImGearDocumentPageArray
'Usage

Dim instance As ImGearPDFDocumentPageArray
[DefaultMember("Item")]
public sealed class ImGearPDFDocumentPageArray : ImageGear.Core.ImGearDocumentPageArray
[DefaultMember("Item")]
public __gc __sealed class ImGearPDFDocumentPageArray : public ImageGear.Core.ImGearDocumentPageArray
[DefaultMember("Item")]
public ref class ImGearPDFDocumentPageArray sealed : public ImageGear.Core.ImGearDocumentPageArray
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocumentPageArray
ImageGear.Formats.PDF.ImGearPDFDocumentPageArray

See Also

Reference

ImGearPDFDocumentPageArray Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFDocumentPageArray Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocumentPageArray Class

The following tables list the members exposed by ImGearPDFDocumentPageArray.

Public Properties
 | Name | Description
Public Property | Item | Overridden. Gets or sets an individual page.
Top
Public Methods
 | Name | Description
Public Method | Add | Overridden. Adds new page at the end of the document.
Public Method | Clear | Overridden. Removes all pages from the document.
Public Method | CopyTo | Overridden. Copies all the pages from the current page array to destination page array.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | Insert | Overridden. Inserts new page.
Public Method | Remove | Overridden. Removes page from the document.
Public Method | RemoveAt | Overridden. Removes page at given index.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFDocumentPageArray class.
Top
See Also

Reference

ImGearPDFDocumentPageArray Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFDocumentPageArray Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocumentPageArray Class

For a list of all members of this type, see ImGearPDFDocumentPageArray members.

Public Methods
 | Name | Description
Public Method | Add | Overridden. Adds new page at the end of the document.
Public Method | Clear | Overridden. Removes all pages from the document.
Public Method | CopyTo | Overridden. Copies all the pages from the current page array to destination page array.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | Insert | Overridden. Inserts new page.
Public Method | Remove | Overridden. Removes page from the document.
Public Method | RemoveAt | Overridden. Removes page at given index.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFDocumentPageArray class.
Top
See Also

Reference

ImGearPDFDocumentPageArray Class
ImageGear.Formats.PDF Namespace


Add Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Add Method
Page to add.
Adds new page at the end of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Add( _
   ByVal page As ImGearPage _
) As Integer
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim page As ImGearPage
Dim value As Integer

value = instance.Add(page)
public override int Add(
   ImGearPage page
)
public: int Add(
   ImGearPage* page
) override
public:
int Add(
   ImGearPage^ page
) override

Parameters

page
Page to add.

Return Value

Index of the newly added page in the document. Integer value.
Remarks
The page must be parentless. If you want to add a page from another document, clone the page first.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


Clear Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Clear Method
Removes all pages from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub Clear()
'Usage

Dim instance As ImGearPDFDocumentPageArray

instance.Clear()
public override void Clear()
public: void Clear(); override
public:
void Clear(); override
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


CopyTo Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : CopyTo Method
Destination array.
Starting index.
Copies all the pages from the current page array to destination page array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
public override void CopyTo(
   Array array,
   int index
)
public: void CopyTo(
   Array* array,
   int index
) override
public:
void CopyTo(
   Array^ array,
   int index
) override

Parameters

array
Destination array.
index
Starting index.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


Dispose Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Overload List
Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


Dispose() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Dispose() Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearPDFDocumentPageArray

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


Finalize Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Finalize Method
Finalizes an instance of the ImGearPDFDocumentPageArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearPDFDocumentPageArray

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


Insert Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Insert Method
Position to insert at.
Page to insert.
Inserts new page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub Insert( _
   ByVal index As Integer, _
   ByVal page As ImGearPage _
)
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim index As Integer
Dim page As ImGearPage

instance.Insert(index, page)
public override void Insert(
   int index,
   ImGearPage page
)
public: void Insert(
   int index,
   ImGearPage* page
) override
public:
void Insert(
   int index,
   ImGearPage^ page
) override

Parameters

index
Position to insert at.
page
Page to insert.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members
ImGearPage Class


Remove Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Remove Method
Page to remove.
Removes page from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub Remove( _
   ByVal value As ImGearPage _
)
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim value As ImGearPage

instance.Remove(value)
public override void Remove(
   ImGearPage value
)
public: void Remove(
   ImGearPage* value
) override
public:
void Remove(
   ImGearPage^ value
) override

Parameters

value
Page to remove.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


RemoveAt Method (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : RemoveAt Method
Page index to remove at.
Removes page at given index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim index As Integer

instance.RemoveAt(index)
public override void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
) override
public:
void RemoveAt(
   int index
) override

Parameters

index
Page index to remove at.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members


%%PageItemTitle%% $$Properties$$

ImGearPDFDocumentPageArray Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocumentPageArray Class

For a list of all members of this type, see ImGearPDFDocumentPageArray members.

Public Properties
 | Name | Description
Public Property | Item | Overridden. Gets or sets an individual page.
Top
See Also

Reference

ImGearPDFDocumentPageArray Class
ImageGear.Formats.PDF Namespace


Item Property (ImGearPDFDocumentPageArray)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFDocumentPageArray Class : Item Property
Page index.
Gets or sets an individual page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Default Property Item( _
   ByVal index As Integer _
) As ImGearPage
'Usage

Dim instance As ImGearPDFDocumentPageArray
Dim index As Integer
Dim value As ImGearPage

instance.Item(index) = value

value = instance.Item(index)
public override ImGearPage this[
   int index
]; {get; set;}
public: __property ImGearPage* get_Item   int index
 override;
public: __property void set_Item   int index,
   ImGearPage* value
 override;
public:
property ImGearPage^ default [int] override {
   ImGearPage^ get(int index) override;
   void set (int index, ImGearPage^ value) override;
}

Parameters

index
Page index.
Remarks
This is the indexed property for accessing the individual page from the document.
See Also

Reference

ImGearPDFDocumentPageArray Class
ImGearPDFDocumentPageArray Members
ImGearPage Class


%%PageItemTitle%%

ImGearPDFFixedMatrix Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedMatrix Class
Describes a matrix containing fixed numbers.
Object Model
ImGearPDFFixedMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFFixedMatrix
'Usage

Dim instance As ImGearPDFFixedMatrix
public sealed class ImGearPDFFixedMatrix
public __gc __sealed class ImGearPDFFixedMatrix
public ref class ImGearPDFFixedMatrix sealed
Remarks
This class defines a transformation matrix for the content object, which usually corresponds to the Matrix key in the dictionary. A transformation matrix specifies the relationship between two coordinate systems. By modifying a transformation matrix, objects can be scaled, rotated, translated, or transformed in other ways. The transformation between two coordinate systems is represented by a 3-by-3 transformation matrix written as follows:

A B 0

C D 0

H V 1

A transformation matrix has only six elements that can be changed as the six-element array [ a b c d h v ]. It can represent any linear transformation from one coordinate system to another. The transformation matrix multiplication can be presented as follows:

x1 = x*A + y*C + H

y1 = x*B + y* D + V

The following lists the arrays that specify the most common transformations:

  • Translations are specified as [ 1 0 0 1 tx ty ], where tx and ty are the distances to translate the origin of the coordinate system in the horizontal and vertical dimensions, respectively.
  • Scaling is obtained by [ sx 0 0 sy 0 0 ]. This scales the coordinates so that 1 unit in the horizontal and vertical dimensions of the new coordinate system is the same size as sx and sy units, respectively, in the previous coordinate system.
  • Rotations are produced by [ cos Ang sin Ang -sin Ang cos Ang 0 0 ], which has the effect of rotating the coordinate system axes by an angle Ang counterclockwise.
  • Skew is specified by [ 1 tan a tan b 1 0 0 ], which skews the x axis by an angle a and the y axis by an angle b.

If several transformations are combined, the order in which they are applied is significant. For example, first scaling and then translating the x axis is not the same as first translating and then scaling it.

In general, to obtain the expected results, transformations should be done in the following order:

Translate

RotateScale or skew

See section "4.2 Coordinate Systems" of the PDF Reference for more details.

Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFFixedMatrix

See Also

Reference

ImGearPDFFixedMatrix Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFFixedMatrix Class Members
Fields Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedMatrix Class

The following tables list the members exposed by ImGearPDFFixedMatrix.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFFixedMatrix Constructor | Initializes a new instance of the ImGearPDFFixedMatrix class.
Top
Public Fields
 | Name | Description
Public Field | A | A value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | B | B value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | C | C value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | D | D value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | H | H value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | V | V value of the transformation matrix represented as the six-element array [ a b c d h v ].
Top
Public Methods
 | Name | Description
Public Method | Empty | Resets all fields to zeros.
Top
See Also

Reference

ImGearPDFFixedMatrix Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFFixedMatrix Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : ImGearPDFFixedMatrix Constructor
Initializes a new instance of the ImGearPDFFixedMatrix class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFFixedMatrix()
public ImGearPDFFixedMatrix()
public: ImGearPDFFixedMatrix();
public:
ImGearPDFFixedMatrix();
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


%%PageItemTitle%% $$Methods$$

ImGearPDFFixedMatrix Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedMatrix Class

For a list of all members of this type, see ImGearPDFFixedMatrix members.

Public Methods
 | Name | Description
Public Method | Empty | Resets all fields to zeros.
Top
See Also

Reference

ImGearPDFFixedMatrix Class
ImageGear.Formats.PDF Namespace


Empty Method (ImGearPDFFixedMatrix)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : Empty Method
Resets all fields to zeros.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Empty()
'Usage

Dim instance As ImGearPDFFixedMatrix

instance.Empty()
public void Empty()
public: void Empty();
public:
void Empty();
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


%%PageItemTitle%% $$Fields$$

ImGearPDFFixedMatrix Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedMatrix Class

For a list of all members of this type, see ImGearPDFFixedMatrix members.

Public Fields
 | Name | Description
Public Field | A | A value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | B | B value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | C | C value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | D | D value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | H | H value of the transformation matrix represented as the six-element array [ a b c d h v ].
Public Field | V | V value of the transformation matrix represented as the six-element array [ a b c d h v ].
Top
See Also

Reference

ImGearPDFFixedMatrix Class
ImageGear.Formats.PDF Namespace


A Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : A Field
A value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public A As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.A

instance.A = value
public int A
public: int A
public:
int A

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


B Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : B Field
B value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public B As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.B

instance.B = value
public int B
public: int B
public:
int B

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


C Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : C Field
C value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public C As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.C

instance.C = value
public int C
public: int C
public:
int C

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


D Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : D Field
D value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public D As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.D

instance.D = value
public int D
public: int D
public:
int D

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


H Field (ImGearPDFFixedMatrix)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : H Field
H value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public H As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.H

instance.H = value
public int H
public: int H
public:
int H

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


V Field (ImGearPDFFixedMatrix)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedMatrix Class : V Field
V value of the transformation matrix represented as the six-element array [ a b c d h v ].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public V As Integer
'Usage

Dim instance As ImGearPDFFixedMatrix
Dim value As Integer

value = instance.V

instance.V = value
public int V
public: int V
public:
int V

Field Value

Integer value.
Remarks
See ImGearPDFFixedMatrix class for more details.
See Also

Reference

ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Members


%%PageItemTitle%%

ImGearPDFFixedPoint Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedPoint Class
Describes a point (in two-dimensional space) represented by two fixed numbers.
Object Model
ImGearPDFFixedPoint Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDFFixedPoint
public sealed class ImGearPDFFixedPoint
public __gc __sealed class ImGearPDFFixedPoint
public ref class ImGearPDFFixedPoint sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFFixedPoint

See Also

Reference

ImGearPDFFixedPoint Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFFixedPoint Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedPoint Class

The following tables list the members exposed by ImGearPDFFixedPoint.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFFixedPoint Constructor | Overloaded. Initializes a new instance of the ImGearPDFFixedPoint class.
Top
Public Fields
 | Name | Description
Public Field | H | Horizontal value.
Public Field | V | Vertical value.
Top
See Also

Reference

ImGearPDFFixedPoint Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFFixedPoint Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedPoint Class : ImGearPDFFixedPoint Constructor
Initializes a new instance of the ImGearPDFFixedPoint class.
Overload List
Overload | Description
ImGearPDFFixedPoint Constructor() | Initializes a new instance of the ImGearPDFFixedPoint class.
ImGearPDFFixedPoint Constructor(Int32,Int32) | Initializes a new instance of the ImGearPDFFixedPoint class.
See Also

Reference

ImGearPDFFixedPoint Class
ImGearPDFFixedPoint Members


%%PageItemTitle%%

ImGearPDFFixedPoint Constructor()

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedPoint Class > ImGearPDFFixedPoint Constructor : ImGearPDFFixedPoint Constructor()
Initializes a new instance of the ImGearPDFFixedPoint class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFFixedPoint()
public ImGearPDFFixedPoint()
public: ImGearPDFFixedPoint();
public:
ImGearPDFFixedPoint();
See Also

Reference

ImGearPDFFixedPoint Class
ImGearPDFFixedPoint Members
Overload List


%%PageItemTitle%%

ImGearPDFFixedPoint Constructor(Int32,Int32)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedPoint Class > ImGearPDFFixedPoint Constructor : ImGearPDFFixedPoint Constructor(Int32,Int32)
Horizontal value.
Vertical value.
Initializes a new instance of the ImGearPDFFixedPoint class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal horizontalValue As Integer, _
   ByVal verticalValue As Integer _
)
'Usage

Dim horizontalValue As Integer
Dim verticalValue As Integer

Dim instance As New ImGearPDFFixedPoint(horizontalValue, verticalValue)
public ImGearPDFFixedPoint(
   int horizontalValue,
   int verticalValue
)
public: ImGearPDFFixedPoint(
   int horizontalValue,
   int verticalValue
)
public:
ImGearPDFFixedPoint(
   int horizontalValue,
   int verticalValue
)

Parameters

horizontalValue
Horizontal value.
verticalValue
Vertical value.
See Also

Reference

ImGearPDFFixedPoint Class
ImGearPDFFixedPoint Members
Overload List


%%PageItemTitle%% $$Fields$$

ImGearPDFFixedPoint Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedPoint Class

For a list of all members of this type, see ImGearPDFFixedPoint members.

Public Fields
 | Name | Description
Public Field | H | Horizontal value.
Public Field | V | Vertical value.
Top
See Also

Reference

ImGearPDFFixedPoint Class
ImageGear.Formats.PDF Namespace


H Field (ImGearPDFFixedPoint)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedPoint Class : H Field
Horizontal value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public H As Integer
'Usage

Dim instance As ImGearPDFFixedPoint
Dim value As Integer

value = instance.H

instance.H = value
public int H
public: int H
public:
int H

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedPoint Class
ImGearPDFFixedPoint Members


V Field (ImGearPDFFixedPoint)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedPoint Class : V Field
Vertical value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public V As Integer
'Usage

Dim instance As ImGearPDFFixedPoint
Dim value As Integer

value = instance.V

instance.V = value
public int V
public: int V
public:
int V

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedPoint Class
ImGearPDFFixedPoint Members


%%PageItemTitle%%

ImGearPDFFixedQuad Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedQuad Class
Describes a quadrilateral with four fixed points (one at each corner).
Object Model
ImGearPDFFixedQuad Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFFixedQuad
'Usage

Dim instance As ImGearPDFFixedQuad
public sealed class ImGearPDFFixedQuad
public __gc __sealed class ImGearPDFFixedQuad
public ref class ImGearPDFFixedQuad sealed
Remarks
A quadrilateral differs from a rectangle in that the latter must always have horizontal and vertical sides, and opposite sides must be parallel.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFFixedQuad

See Also

Reference

ImGearPDFFixedQuad Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFFixedQuad Class Members
Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedQuad Class

The following tables list the members exposed by ImGearPDFFixedQuad.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFFixedQuad Constructor | Initializes a new instance of the ImGearPDFFixedQuad class.
Top
Public Fields
 | Name | Description
Public Field | BottomLeft | Bottom Left value.
Public Field | BottomRight | Bottom Right value.
Public Field | TopLeft | Top Left value.
Public Field | TopRight | Top Right value.
Top
See Also

Reference

ImGearPDFFixedQuad Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFFixedQuad Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedQuad Class : ImGearPDFFixedQuad Constructor
Initializes a new instance of the ImGearPDFFixedQuad class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFFixedQuad()
public ImGearPDFFixedQuad()
public: ImGearPDFFixedQuad();
public:
ImGearPDFFixedQuad();
See Also

Reference

ImGearPDFFixedQuad Class
ImGearPDFFixedQuad Members


%%PageItemTitle%% $$Fields$$

ImGearPDFFixedQuad Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedQuad Class

For a list of all members of this type, see ImGearPDFFixedQuad members.

Public Fields
 | Name | Description
Public Field | BottomLeft | Bottom Left value.
Public Field | BottomRight | Bottom Right value.
Public Field | TopLeft | Top Left value.
Public Field | TopRight | Top Right value.
Top
See Also

Reference

ImGearPDFFixedQuad Class
ImageGear.Formats.PDF Namespace


BottomLeft Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedQuad Class : BottomLeft Field
Bottom Left value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BottomLeft As ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDFFixedQuad
Dim value As ImGearPDFFixedPoint

value = instance.BottomLeft

instance.BottomLeft = value
public ImGearPDFFixedPoint BottomLeft
public: ImGearPDFFixedPoint* BottomLeft
public:
ImGearPDFFixedPoint^ BottomLeft

Field Value

ImGearPDFFixedPoint class object.
See Also

Reference

ImGearPDFFixedQuad Class
ImGearPDFFixedQuad Members
ImGearPDFFixedPoint Class


BottomRight Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedQuad Class : BottomRight Field
Bottom Right value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BottomRight As ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDFFixedQuad
Dim value As ImGearPDFFixedPoint

value = instance.BottomRight

instance.BottomRight = value
public ImGearPDFFixedPoint BottomRight
public: ImGearPDFFixedPoint* BottomRight
public:
ImGearPDFFixedPoint^ BottomRight

Field Value

ImGearPDFFixedPoint class object.
See Also

Reference

ImGearPDFFixedQuad Class
ImGearPDFFixedQuad Members
ImGearPDFFixedPoint Class


TopLeft Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedQuad Class : TopLeft Field
Top Left value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public TopLeft As ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDFFixedQuad
Dim value As ImGearPDFFixedPoint

value = instance.TopLeft

instance.TopLeft = value
public ImGearPDFFixedPoint TopLeft
public: ImGearPDFFixedPoint* TopLeft
public:
ImGearPDFFixedPoint^ TopLeft

Field Value

ImGearPDFFixedPoint class object.
See Also

Reference

ImGearPDFFixedQuad Class
ImGearPDFFixedQuad Members
ImGearPDFFixedPoint Class


TopRight Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedQuad Class : TopRight Field
Top Right value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public TopRight As ImGearPDFFixedPoint
'Usage

Dim instance As ImGearPDFFixedQuad
Dim value As ImGearPDFFixedPoint

value = instance.TopRight

instance.TopRight = value
public ImGearPDFFixedPoint TopRight
public: ImGearPDFFixedPoint* TopRight
public:
ImGearPDFFixedPoint^ TopRight

Field Value

ImGearPDFFixedPoint class object.
See Also

Reference

ImGearPDFFixedQuad Class
ImGearPDFFixedQuad Members
ImGearPDFFixedPoint Class


%%PageItemTitle%%

ImGearPDFFixedRect Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedRect Class
Describes a rectangle by the coordinates of its four sides.
Object Model
ImGearPDFFixedRect Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFFixedRect
'Usage

Dim instance As ImGearPDFFixedRect
public sealed class ImGearPDFFixedRect
public __gc __sealed class ImGearPDFFixedRect
public ref class ImGearPDFFixedRect sealed
Remarks
A rectangle differs from a quadrilateral in that the former must always have horizontal and vertical sides, and opposite sides must be parallel.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFFixedRect

See Also

Reference

ImGearPDFFixedRect Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFFixedRect Class Members
Fields Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedRect Class

The following tables list the members exposed by ImGearPDFFixedRect.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFFixedRect Constructor | Overloaded. Initializes a new instance of the ImGearPDFFixedRect class.
Top
Public Fields
 | Name | Description
Public Field | Bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public Field | Left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public Field | Right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public Field | Top | Specifies the y-coordinate of the upper-left corner of the rectangle.
Top
Public Methods
 | Name | Description
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Top
See Also

Reference

ImGearPDFFixedRect Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFFixedRect Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : ImGearPDFFixedRect Constructor
Initializes a new instance of the ImGearPDFFixedRect class.
Overload List
Overload | Description
ImGearPDFFixedRect Constructor() | Initializes a new instance of the ImGearPDFFixedRect class.
ImGearPDFFixedRect Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearPDFFixedRect class.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


%%PageItemTitle%%

ImGearPDFFixedRect Constructor()

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class > ImGearPDFFixedRect Constructor : ImGearPDFFixedRect Constructor()
Initializes a new instance of the ImGearPDFFixedRect class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFFixedRect()
public ImGearPDFFixedRect()
public: ImGearPDFFixedRect();
public:
ImGearPDFFixedRect();
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members
Overload List


%%PageItemTitle%%

ImGearPDFFixedRect Constructor(Int32,Int32,Int32,Int32)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class > ImGearPDFFixedRect Constructor : ImGearPDFFixedRect Constructor(Int32,Int32,Int32,Int32)
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The x-coordinate of the lower-right corner of the rectangle.
The y-coordinate of the lower-right corner of the rectangle.
Initializes a new instance of the ImGearPDFFixedRect class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
'Usage

Dim left As Integer
Dim top As Integer
Dim right As Integer
Dim bottom As Integer

Dim instance As New ImGearPDFFixedRect(left, top, right, bottom)
public ImGearPDFFixedRect(
   int left,
   int top,
   int right,
   int bottom
)
public: ImGearPDFFixedRect(
   int left,
   int top,
   int right,
   int bottom
)
public:
ImGearPDFFixedRect(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The x-coordinate of the upper-left corner of the rectangle.
top
The y-coordinate of the upper-left corner of the rectangle.
right
The x-coordinate of the lower-right corner of the rectangle.
bottom
The y-coordinate of the lower-right corner of the rectangle.

Return Value

The new instance of ImGearPDFFixedRect class object.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearPDFFixedRect Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedRect Class

For a list of all members of this type, see ImGearPDFFixedRect members.

Public Methods
 | Name | Description
Public Method | Empty | Sets all numeric properties of the rectangle to their initial values.
Top
See Also

Reference

ImGearPDFFixedRect Class
ImageGear.Formats.PDF Namespace


Empty Method (ImGearPDFFixedRect)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : Empty Method
Sets all numeric properties of the rectangle to their initial values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Empty()
'Usage

Dim instance As ImGearPDFFixedRect

instance.Empty()
public void Empty()
public: void Empty();
public:
void Empty();
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


%%PageItemTitle%% $$Fields$$

ImGearPDFFixedRect Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedRect Class

For a list of all members of this type, see ImGearPDFFixedRect members.

Public Fields
 | Name | Description
Public Field | Bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public Field | Left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public Field | Right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public Field | Top | Specifies the y-coordinate of the upper-left corner of the rectangle.
Top
See Also

Reference

ImGearPDFFixedRect Class
ImageGear.Formats.PDF Namespace


Bottom Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : Bottom Field
Specifies the y-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Bottom As Integer
'Usage

Dim instance As ImGearPDFFixedRect
Dim value As Integer

value = instance.Bottom

instance.Bottom = value
public int Bottom
public: int Bottom
public:
int Bottom

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


Left Field (ImGearPDFFixedRect)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : Left Field
Specifies the x-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Left As Integer
'Usage

Dim instance As ImGearPDFFixedRect
Dim value As Integer

value = instance.Left

instance.Left = value
public int Left
public: int Left
public:
int Left

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


Right Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : Right Field
Specifies the x-coordinate of the lower-right corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Right As Integer
'Usage

Dim instance As ImGearPDFFixedRect
Dim value As Integer

value = instance.Right

instance.Right = value
public int Right
public: int Right
public:
int Right

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


Top Field (ImGearPDFFixedRect)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFFixedRect Class : Top Field
Specifies the y-coordinate of the upper-left corner of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Top As Integer
'Usage

Dim instance As ImGearPDFFixedRect
Dim value As Integer

value = instance.Top

instance.Top = value
public int Top
public: int Top
public:
int Top

Field Value

Integer value.
See Also

Reference

ImGearPDFFixedRect Class
ImGearPDFFixedRect Members


%%PageItemTitle%%

ImGearPDFLayer Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFLayer Class
Represents a named object whose state can be toggled to affect changes in visibility of content.
Object Model
ImGearPDFLayer ClassImGearPDFAtom ClassImGearPDFBasObj Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFLayer
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFLayer
public sealed class ImGearPDFLayer : ImGearPDFObject
public __gc __sealed class ImGearPDFLayer : public ImGearPDFObject
public ref class ImGearPDFLayer sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFLayer

See Also

Reference

ImGearPDFLayer Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFLayer Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFLayer Class

The following tables list the members exposed by ImGearPDFLayer.

Public Properties
 | Name | Description
Public Property | CurrentState | Gets or sets a value indicating whether the layer object's current state is ON or OFF.
Public Property | HasUsageInfo | Gets a value indicating whether a layer object is associated with the Usage dictionary.
Public Property | InitialState | Gets or sets a value indicating whether the layer object's initial state is ON or OFF.
Public Property | Name | Gets or sets name of the layer.
Public Property | UniqueId | Gets a 32-bit integer that is unique for all layer objects.
Top
Public Methods
 | Name | Description
Public Method | GetIntent | Gets the intent list for a layer.
Public Method | GetUsageInfo | Gets usage information from a layer object.
Public Method | SetIntent | Sets the 'Intent' entry in a layer's dictionary.
Public Method | SetUsageInfo | Sets a Usage dictionary entry in a layer object.
Top
See Also

Reference

ImGearPDFLayer Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFLayer Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFLayer Class

For a list of all members of this type, see ImGearPDFLayer members.

Public Methods
 | Name | Description
Public Method | GetIntent | Gets the intent list for a layer.
Public Method | GetUsageInfo | Gets usage information from a layer object.
Public Method | SetIntent | Sets the 'Intent' entry in a layer's dictionary.
Public Method | SetUsageInfo | Sets a Usage dictionary entry in a layer object.
Top
See Also

Reference

ImGearPDFLayer Class
ImageGear.Formats.PDF Namespace


GetIntent Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : GetIntent Method
Gets the intent list for a layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetIntent() As ImGearPDFAtom()
'Usage

Dim instance As ImGearPDFLayer
Dim value() As ImGearPDFAtom

value = instance.GetIntent()
public ImGearPDFAtom[] GetIntent()
public: ImGearPDFAtom*[]* GetIntent();
public:
array<ImGearPDFAtom^>^ GetIntent();

Return Value

ImGearPDFAtom class object array.
Remarks
Intent is an atom value broadly describing the intended use, either View or Design. A layer's content is considered to be optional (that is, the layer's state is considered in its visibility) if any intent in its list matches an intent of the context. The intent list of the context is usually set from the intent list of the document configuration.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members
ImGearPDFAtom Class


GetUsageInfo Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : GetUsageInfo Method
The usage key in the usage dictionary entry. Possible key values are: CreatorInfo, Language, Export, Zoom, Print, View, User, PageElement.
Gets usage information from a layer object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetUsageInfo( _
   ByVal key As ImGearPDFAtom _
) As ImGearPDFBasObj
'Usage

Dim instance As ImGearPDFLayer
Dim key As ImGearPDFAtom
Dim value As ImGearPDFBasObj

value = instance.GetUsageInfo(key)
public ImGearPDFBasObj GetUsageInfo(
   ImGearPDFAtom key
)
public: ImGearPDFBasObj* GetUsageInfo(
   ImGearPDFAtom* key
)
public:
ImGearPDFBasObj^ GetUsageInfo(
   ImGearPDFAtom^ key
)

Parameters

key
The usage key in the usage dictionary entry. Possible key values are: CreatorInfo, Language, Export, Zoom, Print, View, User, PageElement.

Return Value

Returns the usage information associated with the given key in the Usage dictionary for the layer, or a Null, if the operation fails (because the layer is malformed or has no dictionary, or because the dictionary has no entry corresponding to the given key).
Remarks
A Usage dictionary entry provides more specific intended usage information than an intent entry.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members
ImGearPDFAtom Class
ImGearPDFBasObj Class


SetIntent Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : SetIntent Method
The new Intent entry value, an array of intent entries (atoms).
Sets the 'Intent' entry in a layer's dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetIntent( _
   ByVal intent() As ImGearPDFAtom _
)
'Usage

Dim instance As ImGearPDFLayer
Dim intent() As ImGearPDFAtom

instance.SetIntent(intent)
public void SetIntent(
   ImGearPDFAtom[] intent
)
public: void SetIntent(
   ImGearPDFAtom*[]* intent
)
public:
void SetIntent(
   array<ImGearPDFAtom^>^ intent
)

Parameters

intent
The new Intent entry value, an array of intent entries (atoms).
Remarks
Intent is an atom value broadly describing the intended use, either View or Design. A layer's content is considered to be optional (that is, the layer's state is considered in its visibility) if any intent in its list matches an intent of the context. The intent list of the context is usually set from the intent list of the document configuration.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members
ImGearPDFAtom Class
ImGearPDFBasObj Class


SetUsageInfo Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : SetUsageInfo Method
The usage key in the usage dictionary entry. Possible key values are: CreatorInfo, Language, Export, Zoom, Print, View, User, PageElement.
The usage information to associate with the key.
Sets a Usage dictionary entry in a layer object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetUsageInfo( _
   ByVal key As ImGearPDFAtom, _
   ByVal value As ImGearPDFBasObj _
)
'Usage

Dim instance As ImGearPDFLayer
Dim key As ImGearPDFAtom
Dim value As ImGearPDFBasObj

instance.SetUsageInfo(key, value)
public void SetUsageInfo(
   ImGearPDFAtom key,
   ImGearPDFBasObj value
)
public: void SetUsageInfo(
   ImGearPDFAtom* key,
   ImGearPDFBasObj* value
)
public:
void SetUsageInfo(
   ImGearPDFAtom^ key,
   ImGearPDFBasObj^ value
)

Parameters

key
The usage key in the usage dictionary entry. Possible key values are: CreatorInfo, Language, Export, Zoom, Print, View, User, PageElement.
value
The usage information to associate with the key.
Remarks
The entry associates usage information with an entry key for retrieval. If a dictionary does not exist, the method creates one.

A Usage dictionary entry provides more specific intended usage information than an intent entry.

The usage value can act as a kind of metadata, describing the sort of things that belong to the layer: for example, text in French, fine detail on a map, or a watermark. The usage values can also be used by the AutoState mechanism to make decisions about what layers should be on and what layers should be off.

See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members
ImGearPDFAtom Class
ImGearPDFBasObj Class


%%PageItemTitle%% $$Properties$$

ImGearPDFLayer Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFLayer Class

For a list of all members of this type, see ImGearPDFLayer members.

Public Properties
 | Name | Description
Public Property | CurrentState | Gets or sets a value indicating whether the layer object's current state is ON or OFF.
Public Property | HasUsageInfo | Gets a value indicating whether a layer object is associated with the Usage dictionary.
Public Property | InitialState | Gets or sets a value indicating whether the layer object's initial state is ON or OFF.
Public Property | Name | Gets or sets name of the layer.
Public Property | UniqueId | Gets a 32-bit integer that is unique for all layer objects.
Top
See Also

Reference

ImGearPDFLayer Class
ImageGear.Formats.PDF Namespace


CurrentState Property (ImGearPDFLayer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : CurrentState Property
Gets or sets a value indicating whether the layer object's current state is ON or OFF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CurrentState As Boolean
'Usage

Dim instance As ImGearPDFLayer
Dim value As Boolean

instance.CurrentState = value

value = instance.CurrentState
public bool CurrentState {get; set;}
public: __property bool get_CurrentState();
public: __property void set_CurrentState(
   bool value
);
public:
property bool CurrentState {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members


HasUsageInfo Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : HasUsageInfo Property
Gets a value indicating whether a layer object is associated with the Usage dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasUsageInfo As Boolean
'Usage

Dim instance As ImGearPDFLayer
Dim value As Boolean

value = instance.HasUsageInfo
public bool HasUsageInfo {get;}
public: __property bool get_HasUsageInfo();
public:
property bool HasUsageInfo {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members


InitialState Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : InitialState Property
Gets or sets a value indicating whether the layer object's initial state is ON or OFF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InitialState As Boolean
'Usage

Dim instance As ImGearPDFLayer
Dim value As Boolean

instance.InitialState = value

value = instance.InitialState
public bool InitialState {get; set;}
public: __property bool get_InitialState();
public: __property void set_InitialState(
   bool value
);
public:
property bool InitialState {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members


Name Property (ImGearPDFLayer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : Name Property
Gets or sets name of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearPDFLayer
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members


UniqueId Property (ImGearPDFLayer)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFLayer Class : UniqueId Property
Gets a 32-bit integer that is unique for all layer objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UniqueId As Integer
'Usage

Dim instance As ImGearPDFLayer
Dim value As Integer

value = instance.UniqueId
public int UniqueId {get;}
public: __property int get_UniqueId();
public:
property int UniqueId {
   int get();
}

Property Value

Integer value.
Remarks
It is guaranteed that there cannot be two Layer objects with the same UniqueIds.

Can be used for Layer object's identification.

See Also

Reference

ImGearPDFLayer Class
ImGearPDFLayer Members
ImGearPDFDocument Class
ImGearPDFDictionary Class


%%PageItemTitle%%

ImGearPDFObject Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFObject Class
Represents general PDF object that provides disposing routine for all unmanaged resources.
Object Model
ImGearPDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearPDFObject
'Usage

Dim instance As ImGearPDFObject
public abstract class ImGearPDFObject
public __gc abstract class ImGearPDFObject
public ref class ImGearPDFObject abstract
Remarks
This is a base interface for all PDF objects.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEColorSpec
ImageGear.Formats.PDF.ImGearPDEColorValue
ImageGear.Formats.PDF.ImGearPDEGraphicState
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDFAction
ImageGear.Formats.PDF.ImGearPDFAtom
ImageGear.Formats.PDF.ImGearPDFBasObj
ImageGear.Formats.PDF.ImGearPDFBookmark
ImageGear.Formats.PDF.ImGearPDFDestination
ImageGear.Formats.PDF.ImGearPDFDictionary
ImageGear.Formats.PDF.ImGearPDFLayer
ImageGear.Formats.PDF.ImGearPDFPreflight
ImageGear.Formats.PDF.ImGearPDFPreflightConvertOptions
ImageGear.Formats.PDF.ImGearPDFStream
ImageGear.Formats.PDF.ImGearPDFStyle
ImageGear.Formats.PDF.ImGearPDFWord
ImageGear.Formats.PDF.ImGearPDFWordFinder

See Also

Reference

ImGearPDFObject Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFObject Class Members
Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFObject Class

The following tables list the members exposed by ImGearPDFObject.

Public Methods
 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFObject class.
Top
See Also

Reference

ImGearPDFObject Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFObject Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFObject Class

For a list of all members of this type, see ImGearPDFObject members.

Public Methods
 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFObject class.
Top
See Also

Reference

ImGearPDFObject Class
ImageGear.Formats.PDF Namespace


Dispose Method (ImGearPDFObject)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFObject Class : Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Overload List
Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
See Also

Reference

ImGearPDFObject Class
ImGearPDFObject Members


Dispose() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFObject Class : Dispose() Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As ImGearPDFObject

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
public:
virtual void Dispose();
See Also

Reference

ImGearPDFObject Class
ImGearPDFObject Members


Finalize Method (ImGearPDFObject)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFObject Class : Finalize Method
Finalizes an instance of the ImGearPDFObject class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearPDFObject

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearPDFObject Class
ImGearPDFObject Members


%%PageItemTitle%%

ImGearPDFPage Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPage Class
Represents PDF and PS pages.
Object Model
ImGearPDFPage ClassImGearPage ClassImGearRectangle StructureImGearPDEContent ClassImGearPDFBasDict ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearPDFPage
public sealed class ImGearPDFPage : ImageGear.Core.ImGearVectorPage
public __gc __sealed class ImGearPDFPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearPDFPage sealed : public ImageGear.Core.ImGearVectorPage
Remarks
This class is used to work with individual PDF and PS pages.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Formats.PDF.ImGearPDFPage

See Also

Reference

ImGearPDFPage Members
ImageGear.Formats.PDF Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Members$$

ImGearPDFPage Class Members
Fields Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPage Class

The following tables list the members exposed by ImGearPDFPage.

Public Properties
 | Name | Description
Public Property | CropRectangle | Gets the PDF page's crop rectangle (crop box).
Public Property | Rotation | Gets the PDF page's rotation value.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the page.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | GetContent | Creates PDE Content object from the page contents and resources.
Public Method | GetDictionary | This method returns the dictionary of the PDF page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the global parameters.
Public Method | ReleaseContent | Decrements page's PDE content internal reference count.
Public Method | ResetDisplayCache | Causes the display engine to re-render PDF page content.
Public Method | SetContent | Sets the page's PDE content back into the page object.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFPage class.
Top
See Also

Reference

ImGearPDFPage Class
ImageGear.Formats.PDF Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Fields$$

ImGearPDFPage Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPage Class

For a list of all members of this type, see ImGearPDFPage members.

See Also

Reference

ImGearPDFPage Class
ImageGear.Formats.PDF Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Methods$$

ImGearPDFPage Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPage Class

For a list of all members of this type, see ImGearPDFPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the page.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | GetContent | Creates PDE Content object from the page contents and resources.
Public Method | GetDictionary | This method returns the dictionary of the PDF page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the global parameters.
Public Method | ReleaseContent | Decrements page's PDE content internal reference count.
Public Method | ResetDisplayCache | Causes the display engine to re-render PDF page content.
Public Method | SetContent | Sets the page's PDE content back into the page object.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFPage class.
Top
See Also

Reference

ImGearPDFPage Class
ImageGear.Formats.PDF Namespace
ImGearVectorPage Class


Clone Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Clone Method
Clones the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function Clone() As ImGearPage
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearPage Class


Dispose Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Overload List
Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members


Dispose() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Dispose() Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearPDFPage

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members


Finalize Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Finalize Method
Finalizes an instance of the ImGearPDFPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearPDFPage

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members


GetContent Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : GetContent Method
Creates PDE Content object from the page contents and resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearPDEContent
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearPDEContent

value = instance.GetContent()
public ImGearPDEContent GetContent()
public: ImGearPDEContent* GetContent();
public:
ImGearPDEContent^ GetContent();

Return Value

ImGearPDEContent class object.
Remarks
The PDE content is cached, so that subsequent calls on the same page return the same PDF content.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearPDEContent Class


GetDictionary Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : GetDictionary Method
This method returns the dictionary of the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDictionary() As ImGearPDFBasDict
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearPDFBasDict

value = instance.GetDictionary()
public ImGearPDFBasDict GetDictionary()
public: ImGearPDFBasDict* GetDictionary();
public:
ImGearPDFBasDict^ GetDictionary();

Return Value

The resulting dictionary.
Remarks
Dictionary is the root of a PDF page's object hierarchy.

See also the PDF Reference, ch.3.6.

See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearPDFBasDict Class


Rasterize Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Rasterize Method
Rasterizes the page using the global parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the page using the global parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the page using the provided parameters.
Rasterize(ImGearDoublePoint,ImGearSize,Int32,Double,Double) | Rasterizes a portion of the page using the provided parameters.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members


Rasterize() Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class > Rasterize Method : Rasterize() Method
Rasterizes the page using the global parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides NotOverridable Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

ImageGear.Core.ImGearRasterPage class.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
This parameter specifies bit depth in bits-per-pixel during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory required for rasterization. The DIB of the output raster image has this value as a bit count. Available values: 1, 8, 24.
This parameter specifies the horizontal resolution in dots-per-inch during the PDF document conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
Rasterizes the page using the provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides NotOverridable Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearPDFPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
This parameter specifies bit depth in bits-per-pixel during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory required for rasterization. The DIB of the output raster image has this value as a bit count. Available values: 1, 8, 24.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the PDF document conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
Overload List


Rasterize(ImGearDoublePoint,ImGearSize,Int32,Double,Double) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class > Rasterize Method : Rasterize(ImGearDoublePoint,ImGearSize,Int32,Double,Double) Method
Specifies the coordinates of the upper-left corner of the area to be rasterized. The coordinates should be non-negative and provided in the output raster pixel units.
Specifies the size of the rasterized area. The size should be non-negative, non-zero and provided in the output raster pixel units. The output raster image DIB will have this value as a width and height.
Specifies bit depth value for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. The output raster image DIB will have this value as a bit count. Available values: 1, 8, 24 and 32.
Specifies horizontal resolution value in dots-per-inch for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. Must be positive.
Specifies vertical resolution value in dots-per-inch for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. Must be positive.
Rasterizes a portion of the page using the provided parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Rasterize( _
   ByVal location As ImGearDoublePoint, _
   ByVal size As ImGearSize, _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Double, _
   ByVal resolutionY As Double _
) As ImGearRasterPage
'Usage

Dim instance As ImGearPDFPage
Dim location As ImGearDoublePoint
Dim size As ImGearSize
Dim bitDepth As Integer
Dim resolutionX As Double
Dim resolutionY As Double
Dim value As ImGearRasterPage

value = instance.Rasterize(location, size, bitDepth, resolutionX, resolutionY)
public ImGearRasterPage Rasterize(
   ImGearDoublePoint location,
   ImGearSize size,
   int bitDepth,
   double resolutionX,
   double resolutionY
)
public: ImGearRasterPage* Rasterize(
   ImGearDoublePoint location,
   ImGearSize size,
   int bitDepth,
   double resolutionX,
   double resolutionY
)
public:
ImGearRasterPage^ Rasterize(
   ImGearDoublePoint location,
   ImGearSize size,
   int bitDepth,
   double resolutionX,
   double resolutionY
)

Parameters

location
Specifies the coordinates of the upper-left corner of the area to be rasterized. The coordinates should be non-negative and provided in the output raster pixel units.
size
Specifies the size of the rasterized area. The size should be non-negative, non-zero and provided in the output raster pixel units. The output raster image DIB will have this value as a width and height.
bitDepth
Specifies bit depth value for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. The output raster image DIB will have this value as a bit count. Available values: 1, 8, 24 and 32.
resolutionX
Specifies horizontal resolution value in dots-per-inch for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. Must be positive.
resolutionY
Specifies vertical resolution value in dots-per-inch for PDF rasterization. The greater this value, the higher quality of the output raster image you get after rasterization. Must be positive.

Return Value

ImageGear.Core.ImGearRasterPage object representing the rasterized tile.
Remarks

This method is designed to be used for tiled PDF rasterization as illustrated below:

If the size of the area exceeds the size of the page in the output raster pixel coordinates, it will be partially blacked.

See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
Overload List


ReleaseContent Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : ReleaseContent Method
Decrements page's PDE content internal reference count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseContent()
'Usage

Dim instance As ImGearPDFPage

instance.ReleaseContent()
public void ReleaseContent()
public: void ReleaseContent();
public:
void ReleaseContent();
Remarks
The content is not automatically deleted when the reference count becomes zero - it remains in the cache until the cache slot is needed for another page. Thus, you do not need to keep a content acquired for performance reasons.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearPDEContent Class


ResetDisplayCache Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : ResetDisplayCache Method
Causes the display engine to re-render PDF page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ResetDisplayCache()
'Usage

Dim instance As ImGearPDFPage

instance.ResetDisplayCache()
public void ResetDisplayCache()
public: void ResetDisplayCache();
public:
void ResetDisplayCache();
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members


SetContent Method (ImGearPDFPage)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : SetContent Method
Sets the page's PDE content back into the page object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function SetContent() As Boolean
'Usage

Dim instance As ImGearPDFPage
Dim value As Boolean

value = instance.SetContent()
public bool SetContent()
public: bool SetContent();
public:
bool SetContent();

Return Value

Boolean value indicating success.
Remarks
Uses the same compression filters with which the content was previously encoded.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearPDEContent Class


%%PageItemTitle%% $$Properties$$

ImGearPDFPage Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPage Class

For a list of all members of this type, see ImGearPDFPage members.

Public Properties
 | Name | Description
Public Property | CropRectangle | Gets the PDF page's crop rectangle (crop box).
Public Property | Rotation | Gets the PDF page's rotation value.
Top
See Also

Reference

ImGearPDFPage Class
ImageGear.Formats.PDF Namespace
ImGearVectorPage Class


CropRectangle Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : CropRectangle Property
Gets the PDF page's crop rectangle (crop box).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CropRectangle As ImGearRectangle
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearRectangle

value = instance.CropRectangle
public ImGearRectangle CropRectangle {get;}
public: __property ImGearRectangle get_CropRectangle();
public:
property ImGearRectangle CropRectangle {
   ImGearRectangle get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
The crop rectangle sets a visible part of the PDF page content for display and printing.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearRectangle Structure


Rotation Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPage Class : Rotation Property
Gets the PDF page's rotation value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Rotation As ImGearRotationValues
'Usage

Dim instance As ImGearPDFPage
Dim value As ImGearRotationValues

value = instance.Rotation
public ImGearRotationValues Rotation {get;}
public: __property ImGearRotationValues get_Rotation();
public:
property ImGearRotationValues Rotation {
   ImGearRotationValues get();
}

Property Value

ImageGear.Core.ImGearRotationValues enumeration value.
See Also

Reference

ImGearPDFPage Class
ImGearPDFPage Members
ImGearRotationValues Enumeration


%%PageItemTitle%%

ImGearPDFPreflight Class
Members Example

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflight Class
Provides preflight capabilities.
Object Model
ImGearPDFPreflight ClassImGearPDFPreflightReport ClassImGearPDFPreflightReport Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFPreflight
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFPreflight
public sealed class ImGearPDFPreflight : ImGearPDFObject
public __gc __sealed class ImGearPDFPreflight : public ImGearPDFObject
public ref class ImGearPDFPreflight sealed : public ImGearPDFObject
Remarks
Class provides the functionality for verification and conversion of PDF document to PDFA standards. The following code example illustrates how the PDF file can be verified and converted using the instance of this class. Notice, the saving of PDF document should be performed with ImGearPDFDocument.Save method because ImageGear.Formats.ImGearFileFormats.SaveDocument does not support thi functionality.
Example
  • C#
// Stores PDF document to a file as PDFA standard.
   private void SavePdfDocumentAsPDFA(ImGearPDFDocument document, ImGearPDFPreflightProfile profile, string outputFilePathName)
   {
       // Create object-converter.
       using (ImGearPDFPreflight preflight = new ImGearPDFPreflight((ImGearPDFDocument)document))
       {
        ImGearPDFPreflightReport report = preflight.VerifyCompliance(profile, 0, -1);
        if (report.Code == ImGearPDFPreflightReportCodes.SUCCESS)
        {
            // PDF document is already compliant to PDFA standard.
            // Nothing is performed.
        }
        else
        {
            if (report.Status == ImGearPDFPreflightStatusCode.Fixable)
            {
                // Create conversion options. We need to be sure the "ig_rgb_profile.icm" color profile
                // is placed in executable file directory of this application.
                ImGearPDFPreflightConvertOptions conversionOptions = new ImGearPDFPreflightConvertOptions(profile, 0, -1);
                // Perform the conversion.
                report = preflight.Convert(conversionOptions);
                if (report.Code == ImGearPDFPreflightReportCodes.SUCCESS)
                {
                    // Store converted document to a file.
                    using (Stream stream = new FileStream(outputFilePathName, FileMode.Create, FileAccess.Write))
                        pdfDocument.Save(stream, ImGearSavingFormats.UNKNOWN, 0, 0, (int)ImGearPDFPageRange.ALL_PAGES, ImGearSavingModes.OVERWRITE);
                }
                else
                    throw new ApplicationException("PDF document cannot be converted to APDF standard.");
            }
            else
                throw new ApplicationException("PDF document cannot be converted to APDF standard.");
        }
    }
}
  • Visual Basic
' Stores PDF document to a file as PDFA standard.
Private Sub SavePdfDocumentAsPDFA(document As ImGearPDFDocument, profile As ImGearPDFPreflightProfile, outputFilePathName As String)
    ' Create object-converter.
    Using preflight As New ImGearPDFPreflight(DirectCast(document, ImGearPDFDocument))
        Dim report As ImGearPDFPreflightReport = preflight.VerifyCompliance(profile, 0, -1)
                ' PDF document is already compliant to PDFA standard.
                ' Nothing is performed.
        If report.Code = ImGearPDFPreflightReportCodes.SUCCESS Then
        Else
            If report.Status = ImGearPDFPreflightStatusCode.Fixable Then
                ' Create conversion options. We need to be sure the "ig_rgb_profile.icm" color profile
                ' is placed in executable file directory of this application.
                Dim conversionOptions As New ImGearPDFPreflightConvertOptions(profile, 0, -1)
                ' Perform the conversion.
                report = preflight.Convert(conversionOptions)
                If report.Code = ImGearPDFPreflightReportCodes.SUCCESS Then
                    ' Store converted document to a file.
                    Using stream As Stream = New FileStream(outputFilePathName, FileMode.Create, FileAccess.Write)
                        pdfDocument.Save(stream, ImGearSavingFormats.UNKNOWN, 0, 0, DirectCast(ImGearPDFPageRange.ALL_PAGES, Integer), ImGearSavingModes.OVERWRITE)
                    End Using
                Else
                    Throw New ApplicationException("PDF document cannot be converted to APDF standard.")
                End If
            Else
                Throw New ApplicationException("PDF document cannot be converted to APDF standard.")
            End If
        End If
    End Using
End Sub
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFPreflight

See Also

Reference

ImGearPDFPreflight Members
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


%%PageItemTitle%% $$Members$$

ImGearPDFPreflight Class Members
Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflight Class

The following tables list the members exposed by ImGearPDFPreflight.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFPreflight Constructor | Initializes a new instance of the ImGearPDFPreflight class for the specified PDF document.
Top
Public Methods
 | Name | Description
Public Method | Convert | Analyzes the PDF document and converts it according to PDF/A and PDF/X standards.
Public Method | VerifyCompliance | Analyzes the PDF document and determines whether the preflight was created in compliance with PDF/A and PDF/X standards.
Top
See Also

Reference

ImGearPDFPreflight Class
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


%%PageItemTitle%%

ImGearPDFPreflight Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflight Class : ImGearPDFPreflight Constructor
The PDF document for which to create a preflight.
Initializes a new instance of the ImGearPDFPreflight class for the specified PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument _
)
'Usage

Dim document As ImGearPDFDocument

Dim instance As New ImGearPDFPreflight(document)
public ImGearPDFPreflight(
   ImGearPDFDocument document
)
public: ImGearPDFPreflight(
   ImGearPDFDocument* document
)
public:
ImGearPDFPreflight(
   ImGearPDFDocument^ document
)

Parameters

document
The PDF document for which to create a preflight.

Return Value

The new instance of ImGearPDFPreflight class object.
See Also

Reference

ImGearPDFPreflight Class
ImGearPDFPreflight Members
ImGearPDFDictionary Class


%%PageItemTitle%% $$Methods$$

ImGearPDFPreflight Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflight Class

For a list of all members of this type, see ImGearPDFPreflight members.

Public Methods
 | Name | Description
Public Method | Convert | Analyzes the PDF document and converts it according to PDF/A and PDF/X standards.
Public Method | VerifyCompliance | Analyzes the PDF document and determines whether the preflight was created in compliance with PDF/A and PDF/X standards.
Top
See Also

Reference

ImGearPDFPreflight Class
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


Convert Method (ImGearPDFPreflight)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflight Class : Convert Method
A set of options useful in conversion process.
Analyzes the PDF document and converts it according to PDF/A and PDF/X standards.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Convert( _
   ByVal options As ImGearPDFPreflightConvertOptions _
) As ImGearPDFPreflightReport
'Usage

Dim instance As ImGearPDFPreflight
Dim options As ImGearPDFPreflightConvertOptions
Dim value As ImGearPDFPreflightReport

value = instance.Convert(options)
public ImGearPDFPreflightReport Convert(
   ImGearPDFPreflightConvertOptions options
)
public: ImGearPDFPreflightReport* Convert(
   ImGearPDFPreflightConvertOptions* options
)
public:
ImGearPDFPreflightReport^ Convert(
   ImGearPDFPreflightConvertOptions^ options
)

Parameters

options
A set of options useful in conversion process.

Return Value

Result of the verification/conversion as an ImGearPDFPreflightReport class object.
Remarks
The result is returned as an ImGearPDFPreflightReport object.

If the document is converted successfully, or no conversion was applied with the specified profile, the output report's code value is equal to ImGearPDFPreflightReportCodes.SUCCESS.

If the document is not compliant, the output report's code value is equal to ImGearPDFPreflightReportCodes.INCOMPLIANT_DOCUMENT and its Records property will have a complete report of noncompliances.

If the document to convert contains images ImGearPDFPreflightConvertOptions.OutputIntentColorProfile should be initialized. Constructor of ImGearPDFPreflightConvertOptions initializes this property only if "ig_rgb_profile.icm" is placed in executable file directory. If this file is not placed in executable file directory user should initialize this property manually.

Conversion example can be found in description of ImGearPDFPreflight class.

See Also

Reference

ImGearPDFPreflight Class
ImGearPDFPreflight Members
ImGearPDFPreflightReport Class
ImGearPDFPreflightProfile Enumeration


VerifyCompliance Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflight Class : VerifyCompliance Method
Preflight profile with which compliance is being verified.
The first page of the document to analyze.
The number of pages to verify. Specify -1 to verify all pages.
Analyzes the PDF document and determines whether the preflight was created in compliance with PDF/A and PDF/X standards.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function VerifyCompliance( _
   ByVal profile As ImGearPDFPreflightProfile, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
) As ImGearPDFPreflightReport
'Usage

Dim instance As ImGearPDFPreflight
Dim profile As ImGearPDFPreflightProfile
Dim startPage As Integer
Dim pageCount As Integer
Dim value As ImGearPDFPreflightReport

value = instance.VerifyCompliance(profile, startPage, pageCount)
public ImGearPDFPreflightReport VerifyCompliance(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)
public: ImGearPDFPreflightReport* VerifyCompliance(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)
public:
ImGearPDFPreflightReport^ VerifyCompliance(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)

Parameters

profile
Preflight profile with which compliance is being verified.
startPage
The first page of the document to analyze.
pageCount
The number of pages to verify. Specify -1 to verify all pages.

Return Value

Result of the verification as an ImGearPDFPreflightReport class object.
Remarks
The result is returned as an ImGearPDFPreflightReport object.

If the document is compliant with the specified profile, the output report's code value is equal to ImGearPDFPreflightReportCodes.SUCCESS.

If the document is not compliant, the output report's code value is equal to ImGearPDFPreflightReportCodes.INCOMPLIANT_DOCUMENT and its Records property will have a complete report of noncompliances.

See Also

Reference

ImGearPDFPreflight Class
ImGearPDFPreflight Members
ImGearPDFPreflightReport Class
ImGearPDFPreflightProfile Enumeration


%%PageItemTitle%%

ImGearPDFPreflightConvertOptions Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightConvertOptions Class
Provides preflight capabilities.
Object Model
ImGearPDFPreflightConvertOptions ClassImGearColorProfile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFPreflightConvertOptions
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFPreflightConvertOptions
public sealed class ImGearPDFPreflightConvertOptions : ImGearPDFObject
public __gc __sealed class ImGearPDFPreflightConvertOptions : public ImGearPDFObject
public ref class ImGearPDFPreflightConvertOptions sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFPreflightConvertOptions

See Also

Reference

ImGearPDFPreflightConvertOptions Members
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


%%PageItemTitle%% $$Members$$

ImGearPDFPreflightConvertOptions Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightConvertOptions Class

The following tables list the members exposed by ImGearPDFPreflightConvertOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFPreflightConvertOptions Constructor | Initializes a new instance of the ImGearPDFPreflightConvertOptions class.
Top
Public Properties
 | Name | Description
Public Property | OutputIntentColorProfile | Gets or sets a colorspace to use in outputIntent. By default, its IG RgbProfile.
Top
See Also

Reference

ImGearPDFPreflightConvertOptions Class
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


%%PageItemTitle%%

ImGearPDFPreflightConvertOptions Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightConvertOptions Class : ImGearPDFPreflightConvertOptions Constructor
Preflight profile with which compliance is being achieved.
The first page of the document to convert.
The number of pages to verify. Specify -1 to convert all pages.
Initializes a new instance of the ImGearPDFPreflightConvertOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal profile As ImGearPDFPreflightProfile, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
'Usage

Dim profile As ImGearPDFPreflightProfile
Dim startPage As Integer
Dim pageCount As Integer

Dim instance As New ImGearPDFPreflightConvertOptions(profile, startPage, pageCount)
public ImGearPDFPreflightConvertOptions(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)
public: ImGearPDFPreflightConvertOptions(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)
public:
ImGearPDFPreflightConvertOptions(
   ImGearPDFPreflightProfile profile,
   int startPage,
   int pageCount
)

Parameters

profile
Preflight profile with which compliance is being achieved.
startPage
The first page of the document to convert.
pageCount
The number of pages to verify. Specify -1 to convert all pages.

Return Value

The new instance of ImGearPDFPreflightConvertOptions class object.
Remarks
Initialization of OutputIntentColorProfile member is performed on this constructor. For correct initialization "ig_rgb_profile.icm" color profile file should be placed in the same directory as run executable file. Otherwise, OutputIntentColorProfile will not be initialized and conversion of PDF files with images will be impossible, method ImGearPDFPreflight.Convert will not be able to convert images.
See Also

Reference

ImGearPDFPreflightConvertOptions Class
ImGearPDFPreflightConvertOptions Members


%%PageItemTitle%% $$Properties$$

ImGearPDFPreflightConvertOptions Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightConvertOptions Class

For a list of all members of this type, see ImGearPDFPreflightConvertOptions members.

Public Properties
 | Name | Description
Public Property | OutputIntentColorProfile | Gets or sets a colorspace to use in outputIntent. By default, its IG RgbProfile.
Top
See Also

Reference

ImGearPDFPreflightConvertOptions Class
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


%%PageItemTitle%% $$Methods$$

ImGearPDFPreflightConvertOptions Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightConvertOptions Class

For a list of all members of this type, see ImGearPDFPreflightConvertOptions members.

See Also

Reference

ImGearPDFPreflightConvertOptions Class
ImageGear.Formats.PDF Namespace
ImGearPDEObject Class


OutputIntentColorProfile Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightConvertOptions Class : OutputIntentColorProfile Property
Gets or sets a colorspace to use in outputIntent. By default, its IG RgbProfile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputIntentColorProfile As ImGearColorProfile
'Usage

Dim instance As ImGearPDFPreflightConvertOptions
Dim value As ImGearColorProfile

instance.OutputIntentColorProfile = value

value = instance.OutputIntentColorProfile
public ImGearColorProfile OutputIntentColorProfile {get; set;}
public: __property ImGearColorProfile* get_OutputIntentColorProfile();
public: __property void set_OutputIntentColorProfile(
   ImGearColorProfile* value
);
public:
property ImGearColorProfile^ OutputIntentColorProfile {
   ImGearColorProfile^ get();
   void set (    ImGearColorProfile^ value);
}

Property Value

ImGearColorProfile object.
Remarks
Constructor of this class initializes this property with "ig_rgb_profile.icm" color profile which should be placed in executable file directory. Unless this property is initialized the conversion of images in PDF file will be impossible. Place color profile file in executable file directory or initialize this property manually.
See Also

Reference

ImGearPDFPreflightConvertOptions Class
ImGearPDFPreflightConvertOptions Members


%%PageItemTitle%%

ImGearPDFPreflightReport Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightReport Class
Provides preflight reporting.
Object Model
ImGearPDFPreflightReport Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFPreflightReport
'Usage

Dim instance As ImGearPDFPreflightReport
public sealed class ImGearPDFPreflightReport
public __gc __sealed class ImGearPDFPreflightReport
public ref class ImGearPDFPreflightReport sealed
Remarks
This class contains a PDF preflight report in a tree form.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFPreflightReport

See Also

Reference

ImGearPDFPreflightReport Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFPreflightReport Class Members
Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightReport Class

The following tables list the members exposed by ImGearPDFPreflightReport.

Public Properties
 | Name | Description
Public Property | Code | Gets preflight report code of the current report node.
Public Property | Description | Gets description of the current report node.
Public Property | Records | Gets a fixed-size array of child report nodes.
Public Property | Status | Gets preflight conversion status of the current report node.
Top
See Also

Reference

ImGearPDFPreflightReport Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFPreflightReport Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightReport Class

For a list of all members of this type, see ImGearPDFPreflightReport members.

Public Properties
 | Name | Description
Public Property | Code | Gets preflight report code of the current report node.
Public Property | Description | Gets description of the current report node.
Public Property | Records | Gets a fixed-size array of child report nodes.
Public Property | Status | Gets preflight conversion status of the current report node.
Top
See Also

Reference

ImGearPDFPreflightReport Class
ImageGear.Formats.PDF Namespace


Code Property (ImGearPDFPreflightReport)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightReport Class : Code Property
Gets preflight report code of the current report node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Code As ImGearPDFPreflightReportCodes
'Usage

Dim instance As ImGearPDFPreflightReport
Dim value As ImGearPDFPreflightReportCodes

value = instance.Code
public ImGearPDFPreflightReportCodes Code {get;}
public: __property ImGearPDFPreflightReportCodes get_Code();
public:
property ImGearPDFPreflightReportCodes Code {
   ImGearPDFPreflightReportCodes get();
}

Property Value

ImGearPDFPreflightReportCodes enumeration value.
See Also

Reference

ImGearPDFPreflightReport Class
ImGearPDFPreflightReport Members
ImGearPDFPreflightReportCodes Enumeration


Description Property (ImGearPDFPreflightReport)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightReport Class : Description Property
Gets description of the current report node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Description As String
'Usage

Dim instance As ImGearPDFPreflightReport
Dim value As String

value = instance.Description
public string Description {get;}
public: __property string* get_Description();
public:
property String^ Description {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearPDFPreflightReport Class
ImGearPDFPreflightReport Members


Records Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightReport Class : Records Property
Gets a fixed-size array of child report nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Records As IList(Of ImGearPDFPreflightReport)
'Usage

Dim instance As ImGearPDFPreflightReport
Dim value As IList(Of ImGearPDFPreflightReport)

value = instance.Records
public IList<ImGearPDFPreflightReport> Records {get;}
public: __property IList<ImGearPDFPreflightReport*>* get_Records();
public:
property IList<ImGearPDFPreflightReport^>^ Records {
   IList<ImGearPDFPreflightReport^>^ get();
}

Property Value

ImGearPDFPreflightReport array.
See Also

Reference

ImGearPDFPreflightReport Class
ImGearPDFPreflightReport Members


Status Property (ImGearPDFPreflightReport)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPreflightReport Class : Status Property
Gets preflight conversion status of the current report node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Status As ImGearPDFPreflightStatusCode
'Usage

Dim instance As ImGearPDFPreflightReport
Dim value As ImGearPDFPreflightStatusCode

value = instance.Status
public ImGearPDFPreflightStatusCode Status {get;}
public: __property ImGearPDFPreflightStatusCode get_Status();
public:
property ImGearPDFPreflightStatusCode Status {
   ImGearPDFPreflightStatusCode get();
}

Property Value

ImGearPDFPreflightStatusCode enumeration value.
See Also

Reference

ImGearPDFPreflightReport Class
ImGearPDFPreflightReport Members
ImGearPDFPreflightStatusCode Enumeration


%%PageItemTitle%%

ImGearPDFPrintOptions Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPrintOptions Class
Provides PDF printing options.
Object Model
ImGearPDFPrintOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFPrintOptions
'Usage

Dim instance As ImGearPDFPrintOptions
public sealed class ImGearPDFPrintOptions
public __gc __sealed class ImGearPDFPrintOptions
public ref class ImGearPDFPrintOptions sealed
Remarks
This class specifies options for native PDF printing. To print to a printer, set emitToPrinter to true, and fill in inFileName, outFileName, deviceName, driverName, portName, dpi, nCopies, startPage, endPage, psLevel, shrinkToFit, binaryOK, emitHalftones, and platformPrinterDesc.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFPrintOptions

See Also

Reference

ImGearPDFPrintOptions Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFPrintOptions Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPrintOptions Class

The following tables list the members exposed by ImGearPDFPrintOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFPrintOptions Constructor | Initializes a new instance of the ImGearPDFPrintOptions class.
Top
Public Properties
 | Name | Description
Public Property | BinaryOK | Gets or sets a value indicating whether binary data is on.
Public Property | Copies | Gets or sets the number of copies to print.
Public Property | DeviceName | Gets or sets the name of device to print to.
Public Property | DevMode | Gets or sets a DEVMODE structure. Optional.
Public Property | DriverName | Gets or sets the name of the driver.
Public Property | EmitHalftones | Gets or sets a value indicating whether emit half-tones is on.
Public Property | EndPage | Gets or sets the page to end printing on.
Public Property | InFileName | Gets or sets the name of the document.
Public Property | OutFileName | Gets or sets the the name of an output file.
Public Property | PaperHeight | Gets or sets a height of paper in points.
Public Property | PaperWidth | Gets or sets a width of paper in points.
Public Property | PortName | Gets or sets the name of port.
Public Property | PrintAnnots | Gets or sets a value indicating whether annotations must be printed.
Public Property | Reverse | Gets or sets a value indicating whether print order is reversed.
Public Property | ShrinkToFit | Gets or sets a value indicating whether shrinking to fit is on.
Public Property | StartPage | Gets or sets the page to start printing with, 0-based.
Public Property | TransQuality | Gets or sets a transparency flattening quality.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFPrintOptions class.
Top
See Also

Reference

ImGearPDFPrintOptions Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPrintOptions Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : ImGearPDFPrintOptions Constructor
Initializes a new instance of the ImGearPDFPrintOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFPrintOptions()
public ImGearPDFPrintOptions()
public: ImGearPDFPrintOptions();
public:
ImGearPDFPrintOptions();

Return Value

New instance of ImGearPDFPrintOptions class object.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


%%PageItemTitle%% $$Methods$$

ImGearPDFPrintOptions Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPrintOptions Class

For a list of all members of this type, see ImGearPDFPrintOptions members.

Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearPDFPrintOptions class.
Top
See Also

Reference

ImGearPDFPrintOptions Class
ImageGear.Formats.PDF Namespace


Finalize Method (ImGearPDFPrintOptions)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : Finalize Method
Finalizes an instance of the ImGearPDFPrintOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearPDFPrintOptions

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


%%PageItemTitle%% $$Properties$$

ImGearPDFPrintOptions Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPrintOptions Class

For a list of all members of this type, see ImGearPDFPrintOptions members.

Public Properties
 | Name | Description
Public Property | BinaryOK | Gets or sets a value indicating whether binary data is on.
Public Property | Copies | Gets or sets the number of copies to print.
Public Property | DeviceName | Gets or sets the name of device to print to.
Public Property | DevMode | Gets or sets a DEVMODE structure. Optional.
Public Property | DriverName | Gets or sets the name of the driver.
Public Property | EmitHalftones | Gets or sets a value indicating whether emit half-tones is on.
Public Property | EndPage | Gets or sets the page to end printing on.
Public Property | InFileName | Gets or sets the name of the document.
Public Property | OutFileName | Gets or sets the the name of an output file.
Public Property | PaperHeight | Gets or sets a height of paper in points.
Public Property | PaperWidth | Gets or sets a width of paper in points.
Public Property | PortName | Gets or sets the name of port.
Public Property | PrintAnnots | Gets or sets a value indicating whether annotations must be printed.
Public Property | Reverse | Gets or sets a value indicating whether print order is reversed.
Public Property | ShrinkToFit | Gets or sets a value indicating whether shrinking to fit is on.
Public Property | StartPage | Gets or sets the page to start printing with, 0-based.
Public Property | TransQuality | Gets or sets a transparency flattening quality.
Top
See Also

Reference

ImGearPDFPrintOptions Class
ImageGear.Formats.PDF Namespace


BinaryOK Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : BinaryOK Property
Gets or sets a value indicating whether binary data is on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BinaryOK As Boolean
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Boolean

instance.BinaryOK = value

value = instance.BinaryOK
public bool BinaryOK {get; set;}
public: __property bool get_BinaryOK();
public: __property void set_BinaryOK(
   bool value
);
public:
property bool BinaryOK {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


Copies Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : Copies Property
Gets or sets the number of copies to print.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Copies As Integer
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Integer

instance.Copies = value

value = instance.Copies
public int Copies {get; set;}
public: __property int get_Copies();
public: __property void set_Copies(
   int value
);
public:
property int Copies {
   int get();
   void set (    int value);
}

Property Value

Positive integer value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


DeviceName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : DeviceName Property
Gets or sets the name of device to print to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeviceName As String
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As String

instance.DeviceName = value

value = instance.DeviceName
public string DeviceName {get; set;}
public: __property string* get_DeviceName();
public: __property void set_DeviceName(
   string* value
);
public:
property String^ DeviceName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
Aavailable devices can be found in the Windows Registry at HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion\Devices). PrinterSettings.PrinterName can be used to get a device name.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


DevMode Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : DevMode Property
Gets or sets a DEVMODE structure. Optional.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DevMode As IntPtr
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As IntPtr

instance.DevMode = value

value = instance.DevMode
public IntPtr DevMode {get; set;}
public: __property IntPtr get_DevMode();
public: __property void set_DevMode(
   IntPtr value
);
public:
property IntPtr DevMode {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

A pointer to Windows GDI DEVMODE structure.
Remarks
If you do not pass a DEVMODE structure, a new one will be created based on the other properties. The default value is IntPtr.Zero.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members
System.IntPtr


DriverName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : DriverName Property
Gets or sets the name of the driver.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DriverName As String
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As String

instance.DriverName = value

value = instance.DriverName
public string DriverName {get; set;}
public: __property string* get_DriverName();
public: __property void set_DriverName(
   string* value
);
public:
property String^ DriverName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


EmitHalftones Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : EmitHalftones Property
Gets or sets a value indicating whether emit half-tones is on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EmitHalftones As Boolean
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Boolean

instance.EmitHalftones = value

value = instance.EmitHalftones
public bool EmitHalftones {get; set;}
public: __property bool get_EmitHalftones();
public: __property void set_EmitHalftones(
   bool value
);
public:
property bool EmitHalftones {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


EndPage Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : EndPage Property
Gets or sets the page to end printing on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPage As Integer
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Integer

instance.EndPage = value

value = instance.EndPage
public int EndPage {get; set;}
public: __property int get_EndPage();
public: __property void set_EndPage(
   int value
);
public:
property int EndPage {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


InFileName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : InFileName Property
Gets or sets the name of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InFileName As String
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As String

instance.InFileName = value

value = instance.InFileName
public string InFileName {get; set;}
public: __property string* get_InFileName();
public: __property void set_InFileName(
   string* value
);
public:
property String^ InFileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


OutFileName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : OutFileName Property
Gets or sets the the name of an output file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutFileName As String
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As String

instance.OutFileName = value

value = instance.OutFileName
public string OutFileName {get; set;}
public: __property string* get_OutFileName();
public: __property void set_OutFileName(
   string* value
);
public:
property String^ OutFileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
If the string is empty, the output will be sent to the device identified by DeviceName, DriverName, and PortName.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


PaperHeight Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : PaperHeight Property
Gets or sets a height of paper in points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperHeight As UShort
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As UShort

instance.PaperHeight = value

value = instance.PaperHeight
public ushort PaperHeight {get; set;}
public: __property ushort get_PaperHeight();
public: __property void set_PaperHeight(
   ushort value
);
public:
property ushort PaperHeight {
   ushort get();
   void set (    ushort value);
}

Property Value

Ushort value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


PaperWidth Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : PaperWidth Property
Gets or sets a width of paper in points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperWidth As UShort
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As UShort

instance.PaperWidth = value

value = instance.PaperWidth
public ushort PaperWidth {get; set;}
public: __property ushort get_PaperWidth();
public: __property void set_PaperWidth(
   ushort value
);
public:
property ushort PaperWidth {
   ushort get();
   void set (    ushort value);
}

Property Value

Ushort value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


PortName Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : PortName Property
Gets or sets the name of port.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortName As String
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As String

instance.PortName = value

value = instance.PortName
public string PortName {get; set;}
public: __property string* get_PortName();
public: __property void set_PortName(
   string* value
);
public:
property String^ PortName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The port name example: "Ne00".
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


PrintAnnots Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : PrintAnnots Property
Gets or sets a value indicating whether annotations must be printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrintAnnots As Boolean
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Boolean

instance.PrintAnnots = value

value = instance.PrintAnnots
public bool PrintAnnots {get; set;}
public: __property bool get_PrintAnnots();
public: __property void set_PrintAnnots(
   bool value
);
public:
property bool PrintAnnots {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


Reverse Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : Reverse Property
Gets or sets a value indicating whether print order is reversed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Reverse As Boolean
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Boolean

instance.Reverse = value

value = instance.Reverse
public bool Reverse {get; set;}
public: __property bool get_Reverse();
public: __property void set_Reverse(
   bool value
);
public:
property bool Reverse {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


ShrinkToFit Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : ShrinkToFit Property
Gets or sets a value indicating whether shrinking to fit is on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShrinkToFit As Boolean
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Boolean

instance.ShrinkToFit = value

value = instance.ShrinkToFit
public bool ShrinkToFit {get; set;}
public: __property bool get_ShrinkToFit();
public: __property void set_ShrinkToFit(
   bool value
);
public:
property bool ShrinkToFit {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


StartPage Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : StartPage Property
Gets or sets the page to start printing with, 0-based.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPage As Integer
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Integer

instance.StartPage = value

value = instance.StartPage
public int StartPage {get; set;}
public: __property int get_StartPage();
public: __property void set_StartPage(
   int value
);
public:
property int StartPage {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


TransQuality Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFPrintOptions Class : TransQuality Property
Gets or sets a transparency flattening quality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransQuality As Integer
'Usage

Dim instance As ImGearPDFPrintOptions
Dim value As Integer

instance.TransQuality = value

value = instance.TransQuality
public int TransQuality {get; set;}
public: __property int get_TransQuality();
public: __property void set_TransQuality(
   int value
);
public:
property int TransQuality {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
1 is the fastest, 5 is the best. The default value is 3.
See Also

Reference

ImGearPDFPrintOptions Class
ImGearPDFPrintOptions Members


%%PageItemTitle%%

ImGearPDFSaveOptions Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSaveOptions Class
Provides specific PDF options for saving.
Object Model
ImGearPDFSaveOptions ClassImGearPDFPreflightConvertOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPDFSaveOptions
   Inherits ImageGear.Formats.ImGearSaveOptions
'Usage

Dim instance As ImGearPDFSaveOptions
public class ImGearPDFSaveOptions : ImageGear.Formats.ImGearSaveOptions
public __gc class ImGearPDFSaveOptions : public ImageGear.Formats.ImGearSaveOptions
public ref class ImGearPDFSaveOptions : public ImageGear.Formats.ImGearSaveOptions
Remarks
This class can be used to define specific PDF options, such as PDF/A, for saving raster pages and documents to PDF format.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearSaveOptions
ImageGear.Formats.PDF.ImGearPDFSaveOptions

See Also

Reference

ImGearPDFSaveOptions Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFSaveOptions Class Members
Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSaveOptions Class

The following tables list the members exposed by ImGearPDFSaveOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFSaveOptions Constructor | Initializes a new instance of the ImGearPDFSaveOptions class.
Top
Public Properties
 | Name | Description
Public Property | PreflightOptions | Gets or sets preflight options.
Top
See Also

Reference

ImGearPDFSaveOptions Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSaveOptions Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSaveOptions Class : ImGearPDFSaveOptions Constructor
Initializes a new instance of the ImGearPDFSaveOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFSaveOptions()
public ImGearPDFSaveOptions()
public: ImGearPDFSaveOptions();
public:
ImGearPDFSaveOptions();
See Also

Reference

ImGearPDFSaveOptions Class
ImGearPDFSaveOptions Members


%%PageItemTitle%% $$Properties$$

ImGearPDFSaveOptions Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSaveOptions Class

For a list of all members of this type, see ImGearPDFSaveOptions members.

Public Properties
 | Name | Description
Public Property | PreflightOptions | Gets or sets preflight options.
Top
See Also

Reference

ImGearPDFSaveOptions Class
ImageGear.Formats.PDF Namespace


PreflightOptions Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSaveOptions Class : PreflightOptions Property
Gets or sets preflight options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreflightOptions As ImGearPDFPreflightConvertOptions
'Usage

Dim instance As ImGearPDFSaveOptions
Dim value As ImGearPDFPreflightConvertOptions

instance.PreflightOptions = value

value = instance.PreflightOptions
public ImGearPDFPreflightConvertOptions PreflightOptions {get; set;}
public: __property ImGearPDFPreflightConvertOptions* get_PreflightOptions();
public: __property void set_PreflightOptions(
   ImGearPDFPreflightConvertOptions* value
);
public:
property ImGearPDFPreflightConvertOptions^ PreflightOptions {
   ImGearPDFPreflightConvertOptions^ get();
   void set (    ImGearPDFPreflightConvertOptions^ value);
}

Property Value

ImGearPDFPreflightConvertOptions class value.
Remarks
Value of null indicates that no PDF preflight processing is required and saving will be done to standard PDF. The default value is null.
See Also

Reference

ImGearPDFSaveOptions Class
ImGearPDFSaveOptions Members


%%PageItemTitle%%

ImGearPDFSecurityData Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSecurityData Class
Provides data for the standard security handler.
Object Model
ImGearPDFSecurityData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFSecurityData
'Usage

Dim instance As ImGearPDFSecurityData
public sealed class ImGearPDFSecurityData
public __gc __sealed class ImGearPDFSecurityData
public ref class ImGearPDFSecurityData sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFSecurityData

See Also

Reference

ImGearPDFSecurityData Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFSecurityData Class Members
Fields Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSecurityData Class

The following tables list the members exposed by ImGearPDFSecurityData.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFSecurityData Constructor | Initializes a new instance of the ImGearPDFSecurityData class.
Top
Public Fields
 | Name | Description
Public Field | EncryptMethod | Method of encryption for filters to use.
Public Field | KeyLength | Encryption key length in bytes.
Public Field | OwnerPW | The owner password string.
Public Field | Perms | Permissions flags to allow.
Public Field | Revision | Indicates /R revision value.
Public Field | UserPW | The user password string.
Top
Public Properties
 | Name | Description
Public Property | EncryptAttachmentsOnly | Gets or sets a value indicating whether only Attachments are encrypted.
Public Property | EncryptMetadata | Gets or sets a value indicating whether whether document metadata will be encrypted.
Public Property | HasOwnerPW | Gets or sets a value indicating whether the owner password is provided.
Public Property | HasUserPW | Gets or sets a value indicating whether the user password is provided.
Public Property | NewOwnerPW | Gets or sets a value indicating whether the owner password should be changed.
Public Property | NewUserPW | Gets or sets a value indicating whether the user password should be changed.
Top
See Also

Reference

ImGearPDFSecurityData Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSecurityData Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : ImGearPDFSecurityData Constructor
Initializes a new instance of the ImGearPDFSecurityData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPDFSecurityData()
public ImGearPDFSecurityData()
public: ImGearPDFSecurityData();
public:
ImGearPDFSecurityData();

Return Value

A new instance of ImGearPDFSecurityData class object.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


%%PageItemTitle%% $$Properties$$

ImGearPDFSecurityData Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSecurityData Class

For a list of all members of this type, see ImGearPDFSecurityData members.

Public Properties
 | Name | Description
Public Property | EncryptAttachmentsOnly | Gets or sets a value indicating whether only Attachments are encrypted.
Public Property | EncryptMetadata | Gets or sets a value indicating whether whether document metadata will be encrypted.
Public Property | HasOwnerPW | Gets or sets a value indicating whether the owner password is provided.
Public Property | HasUserPW | Gets or sets a value indicating whether the user password is provided.
Public Property | NewOwnerPW | Gets or sets a value indicating whether the owner password should be changed.
Public Property | NewUserPW | Gets or sets a value indicating whether the user password should be changed.
Top
See Also

Reference

ImGearPDFSecurityData Class
ImageGear.Formats.PDF Namespace


EncryptAttachmentsOnly Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : EncryptAttachmentsOnly Property
Gets or sets a value indicating whether only Attachments are encrypted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptAttachmentsOnly As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.EncryptAttachmentsOnly = value

value = instance.EncryptAttachmentsOnly
public bool EncryptAttachmentsOnly {get; set;}
public: __property bool get_EncryptAttachmentsOnly();
public: __property void set_EncryptAttachmentsOnly(
   bool value
);
public:
property bool EncryptAttachmentsOnly {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
EncryptMetadata and EncryptAttachmentsOnly cannot both be true. The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


EncryptMetadata Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : EncryptMetadata Property
Gets or sets a value indicating whether whether document metadata will be encrypted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptMetadata As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
public bool EncryptMetadata {get; set;}
public: __property bool get_EncryptMetadata();
public: __property void set_EncryptMetadata(
   bool value
);
public:
property bool EncryptMetadata {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
EncryptMetadata and EncryptAttachmentsOnly cannot both be true. The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


HasOwnerPW Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : HasOwnerPW Property
Gets or sets a value indicating whether the owner password is provided.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HasOwnerPW As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.HasOwnerPW = value

value = instance.HasOwnerPW
public bool HasOwnerPW {get; set;}
public: __property bool get_HasOwnerPW();
public: __property void set_HasOwnerPW(
   bool value
);
public:
property bool HasOwnerPW {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


HasUserPW Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : HasUserPW Property
Gets or sets a value indicating whether the user password is provided.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HasUserPW As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.HasUserPW = value

value = instance.HasUserPW
public bool HasUserPW {get; set;}
public: __property bool get_HasUserPW();
public: __property void set_HasUserPW(
   bool value
);
public:
property bool HasUserPW {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


NewOwnerPW Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : NewOwnerPW Property
Gets or sets a value indicating whether the owner password should be changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewOwnerPW As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.NewOwnerPW = value

value = instance.NewOwnerPW
public bool NewOwnerPW {get; set;}
public: __property bool get_NewOwnerPW();
public: __property void set_NewOwnerPW(
   bool value
);
public:
property bool NewOwnerPW {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


NewUserPW Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : NewUserPW Property
Gets or sets a value indicating whether the user password should be changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewUserPW As Boolean
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Boolean

instance.NewUserPW = value

value = instance.NewUserPW
public bool NewUserPW {get; set;}
public: __property bool get_NewUserPW();
public: __property void set_NewUserPW(
   bool value
);
public:
property bool NewUserPW {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


%%PageItemTitle%% $$Fields$$

ImGearPDFSecurityData Class Fields

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSecurityData Class

For a list of all members of this type, see ImGearPDFSecurityData members.

Public Fields
 | Name | Description
Public Field | EncryptMethod | Method of encryption for filters to use.
Public Field | KeyLength | Encryption key length in bytes.
Public Field | OwnerPW | The owner password string.
Public Field | Perms | Permissions flags to allow.
Public Field | Revision | Indicates /R revision value.
Public Field | UserPW | The user password string.
Top
See Also

Reference

ImGearPDFSecurityData Class
ImageGear.Formats.PDF Namespace


EncryptMethod Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : EncryptMethod Field
Method of encryption for filters to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public EncryptMethod As ImGearPDFStdSecurityMethod
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As ImGearPDFStdSecurityMethod

value = instance.EncryptMethod

instance.EncryptMethod = value
public ImGearPDFStdSecurityMethod EncryptMethod
public: ImGearPDFStdSecurityMethod EncryptMethod
public:
ImGearPDFStdSecurityMethod EncryptMethod

Field Value

ImGearPDFStdSecurityMethod enumeration value.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members
ImGearPDFStdSecurityMethod Enumeration


KeyLength Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : KeyLength Field
Encryption key length in bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public KeyLength As Integer
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As Integer

value = instance.KeyLength

instance.KeyLength = value
public int KeyLength
public: int KeyLength
public:
int KeyLength

Field Value

Integer value.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


OwnerPW Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : OwnerPW Field
The owner password string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<MarshalAsAttribute(UnmanagedType.Bool Or  _
    UnmanagedType.I1 Or  _
    UnmanagedType.U1 Or  _
    UnmanagedType.I2 Or  _
    UnmanagedType.U2 Or  _
    UnmanagedType.I4 Or  _
    UnmanagedType.BStr Or  _
    UnmanagedType.LPStr Or  _
    UnmanagedType.LPWStr Or  _
    UnmanagedType.LPTStr Or  _
    UnmanagedType.ByValTStr)>
Public OwnerPW As String
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As String

value = instance.OwnerPW

instance.OwnerPW = value
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public string OwnerPW
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public: string* OwnerPW
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public:
String^ OwnerPW

Field Value

String value.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


Perms Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : Perms Field
Permissions flags to allow.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Perms As ImGearPDFPermsFlags
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As ImGearPDFPermsFlags

value = instance.Perms

instance.Perms = value
public ImGearPDFPermsFlags Perms
public: ImGearPDFPermsFlags Perms
public:
ImGearPDFPermsFlags Perms

Field Value

Combination of ImGearPDFPermsFlags enumeration values.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members
ImGearPDFPermsFlags Enumeration


Revision Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : Revision Field
Indicates /R revision value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Revision As ImGearPDFRevision
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As ImGearPDFRevision

value = instance.Revision

instance.Revision = value
public ImGearPDFRevision Revision
public: ImGearPDFRevision Revision
public:
ImGearPDFRevision Revision

Field Value

ImGearPDFRevision enumeration value.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


UserPW Field

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSecurityData Class : UserPW Field
The user password string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<MarshalAsAttribute(UnmanagedType.Bool Or  _
    UnmanagedType.I1 Or  _
    UnmanagedType.U1 Or  _
    UnmanagedType.I2 Or  _
    UnmanagedType.U2 Or  _
    UnmanagedType.I4 Or  _
    UnmanagedType.BStr Or  _
    UnmanagedType.LPStr Or  _
    UnmanagedType.LPWStr Or  _
    UnmanagedType.LPTStr Or  _
    UnmanagedType.ByValTStr)>
Public UserPW As String
'Usage

Dim instance As ImGearPDFSecurityData
Dim value As String

value = instance.UserPW

instance.UserPW = value
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public string UserPW
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public: string* UserPW
[MarshalAs(UnmanagedType.Bool |
    UnmanagedType.I1 |
    UnmanagedType.U1 |
    UnmanagedType.I2 |
    UnmanagedType.U2 |
    UnmanagedType.I4 |
    UnmanagedType.BStr |
    UnmanagedType.LPStr |
    UnmanagedType.LPWStr |
    UnmanagedType.LPTStr |
    UnmanagedType.ByValTStr)]
public:
String^ UserPW

Field Value

String value.
See Also

Reference

ImGearPDFSecurityData Class
ImGearPDFSecurityData Members


%%PageItemTitle%%

ImGearPDFStream Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream Class
Represents a data stream that may be a buffer in memory, or an arbitrary user-written procedure.
Object Model
ImGearPDFStream Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPDFStream
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFStream
public class ImGearPDFStream : ImGearPDFObject
public __gc class ImGearPDFStream : public ImGearPDFObject
public ref class ImGearPDFStream : public ImGearPDFObject
Remarks
Typically used to extract or provide data.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFStream

See Also

Reference

ImGearPDFStream Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFStream Class Members
Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream Class

The following tables list the members exposed by ImGearPDFStream.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFStream Constructor | Overloaded. Initializes a new instance of the ImGearPDFStream class.
Top
Public Methods
 | Name | Description
Public Method | Flush | Flushes any buffered data to the specified stream.
Public Method | Read | Reads data from the stream into memory.
Public Method | Write | Writes data from memory buffer to the stream.
Top
See Also

Reference

ImGearPDFStream Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFStream Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class : ImGearPDFStream Constructor
Initializes a new instance of the ImGearPDFStream class.
Overload List
Overload | Description
ImGearPDFStream Constructor(Byte[]) | Initializes a new instance of the ImGearPDFStream class.
ImGearPDFStream Constructor(ImGearPDFStreamWriter,ImGearPDFStreamCleanUp,Object) | Initializes a new instance of the ImGearPDFStream class.
ImGearPDFStream Constructor(ImGearPDFStreamReader,Object) | Initializes a new instance of the ImGearPDFStream class.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members


%%PageItemTitle%%

ImGearPDFStream Constructor(Byte[])

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class > ImGearPDFStream Constructor : ImGearPDFStream Constructor(Byte[])
Memory buffer to create PDF stream from.
Initializes a new instance of the ImGearPDFStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal byteArray() As Byte _
)
'Usage

Dim byteArray() As Byte

Dim instance As New ImGearPDFStream(byteArray)
public ImGearPDFStream(
   byte[] byteArray
)
public: ImGearPDFStream(
   byte[]* byteArray
)
public:
ImGearPDFStream(
   array<byte>^ byteArray
)

Parameters

byteArray
Memory buffer to create PDF stream from.

Return Value

The new instance of ImGearPDFStream class.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members
Overload List


%%PageItemTitle%%

ImGearPDFStream Constructor(ImGearPDFStreamWriter,ImGearPDFStreamCleanUp,Object)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class > ImGearPDFStream Constructor : ImGearPDFStream Constructor(ImGearPDFStreamWriter,ImGearPDFStreamCleanUp,Object)
PDF stream writer callback routine.
PDF stream clean up callback routine.
User data.
Initializes a new instance of the ImGearPDFStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal writerCallback As ImGearPDFStream.ImGearPDFStreamWriter, _
   ByVal cleanupCallback As ImGearPDFStream.ImGearPDFStreamCleanUp, _
   ByVal userData As Object _
)
'Usage

Dim writerCallback As ImGearPDFStream.ImGearPDFStreamWriter
Dim cleanupCallback As ImGearPDFStream.ImGearPDFStreamCleanUp
Dim userData As Object

Dim instance As New ImGearPDFStream(writerCallback, cleanupCallback, userData)
public ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamWriter writerCallback,
   ImGearPDFStream.ImGearPDFStreamCleanUp cleanupCallback,
   object userData
)
public: ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamWriter* writerCallback,
   ImGearPDFStream.ImGearPDFStreamCleanUp* cleanupCallback,
   Object* userData
)
public:
ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamWriter^ writerCallback,
   ImGearPDFStream.ImGearPDFStreamCleanUp^ cleanupCallback,
   Object^ userData
)

Parameters

writerCallback
PDF stream writer callback routine.
cleanupCallback
PDF stream clean up callback routine.
userData
User data.

Return Value

The new instance of ImGearPDFStream class.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members
Overload List
ImGearPDFStream.ImGearPDFStreamCleanUp Delegate
ImGearPDFStream.ImGearPDFStreamWriter Delegate


%%PageItemTitle%%

ImGearPDFStream Constructor(ImGearPDFStreamReader,Object)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class > ImGearPDFStream Constructor : ImGearPDFStream Constructor(ImGearPDFStreamReader,Object)
PDF stream reader callback routine.
User data.
Initializes a new instance of the ImGearPDFStream class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal readerCallback As ImGearPDFStream.ImGearPDFStreamReader, _
   ByVal userData As Object _
)
'Usage

Dim readerCallback As ImGearPDFStream.ImGearPDFStreamReader
Dim userData As Object

Dim instance As New ImGearPDFStream(readerCallback, userData)
public ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamReader readerCallback,
   object userData
)
public: ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamReader* readerCallback,
   Object* userData
)
public:
ImGearPDFStream(
   ImGearPDFStream.ImGearPDFStreamReader^ readerCallback,
   Object^ userData
)

Parameters

readerCallback
PDF stream reader callback routine.
userData
User data.

Return Value

The new instance of ImGearPDFStream class object.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members
Overload List
ImGearPDFStream.ImGearPDFStreamReader Delegate


%%PageItemTitle%% $$Methods$$

ImGearPDFStream Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream Class

For a list of all members of this type, see ImGearPDFStream members.

Public Methods
 | Name | Description
Public Method | Flush | Flushes any buffered data to the specified stream.
Public Method | Read | Reads data from the stream into memory.
Public Method | Write | Writes data from memory buffer to the stream.
Top
See Also

Reference

ImGearPDFStream Class
ImageGear.Formats.PDF Namespace


Flush Method (ImGearPDFStream)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class : Flush Method
Flushes any buffered data to the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Flush() As Integer
'Usage

Dim instance As ImGearPDFStream
Dim value As Integer

value = instance.Flush()
public int Flush()
public: int Flush();
public:
int Flush();

Return Value

0 if successful, otherwise non-zero.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members


Read Method (ImGearPDFStream)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class : Read Method
Number of items to read. The amount of data read into the memory buffer will be itemCount multiplied by itemSize, unless an EOF is encountered first.The relative values of itemCount and itemSize really do not matter; the only thing that matters is their product. It is often convenient to set itemSize to 1, so that itemCount is the number of bytes to read.
Number of bytes in an item in the stream.
Reads data from the stream into memory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Read( _
   ByVal itemCount As Integer, _
   ByVal itemSize As Integer _
) As Byte()
'Usage

Dim instance As ImGearPDFStream
Dim itemCount As Integer
Dim itemSize As Integer
Dim value() As Byte

value = instance.Read(itemCount, itemSize)
public byte[] Read(
   int itemCount,
   int itemSize
)
public: byte[]* Read(
   int itemCount,
   int itemSize
)
public:
array<byte>^ Read(
   int itemCount,
   int itemSize
)

Parameters

itemCount
Number of items to read. The amount of data read into the memory buffer will be itemCount multiplied by itemSize, unless an EOF is encountered first.The relative values of itemCount and itemSize really do not matter; the only thing that matters is their product. It is often convenient to set itemSize to 1, so that itemCount is the number of bytes to read.
itemSize
Number of bytes in an item in the stream.

Return Value

ImageGear integer array which contains stream data.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members


Write Method (ImGearPDFStream)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStream Class : Write Method
Memory buffer.
Number of items to write. The amount of data written into the memory buffer will be itemCount multiplied by itemSize.The relative values of itemCount and itemSize really do not matter; the only thing that matters is their product. It is often convenient to set itemSize to 1, so that itemCount is the number of bytes to write.
Number of bytes in an item.
Writes data from memory buffer to the stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Write( _
   ByVal buffer() As Byte, _
   ByVal itemCount As Integer, _
   ByVal itemSize As Integer _
)
'Usage

Dim instance As ImGearPDFStream
Dim buffer() As Byte
Dim itemCount As Integer
Dim itemSize As Integer

instance.Write(buffer, itemCount, itemSize)
public void Write(
   byte[] buffer,
   int itemCount,
   int itemSize
)
public: void Write(
   byte[]* buffer,
   int itemCount,
   int itemSize
)
public:
void Write(
   array<byte>^ buffer,
   int itemCount,
   int itemSize
)

Parameters

buffer
Memory buffer.
itemCount
Number of items to write. The amount of data written into the memory buffer will be itemCount multiplied by itemSize.The relative values of itemCount and itemSize really do not matter; the only thing that matters is their product. It is often convenient to set itemSize to 1, so that itemCount is the number of bytes to write.
itemSize
Number of bytes in an item.
See Also

Reference

ImGearPDFStream Class
ImGearPDFStream Members


%%PageItemTitle%%

ImGearPDFStyle Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStyle Class
Represents information about the fonts, font sizes, and colors used in a word.
Object Model
ImGearPDFStyle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFStyle
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFStyle
public sealed class ImGearPDFStyle : ImGearPDFObject
public __gc __sealed class ImGearPDFStyle : public ImGearPDFObject
public ref class ImGearPDFStyle sealed : public ImGearPDFObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFStyle

See Also

Reference

ImGearPDFStyle Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFStyle Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStyle Class

The following tables list the members exposed by ImGearPDFStyle.

Public Properties
 | Name | Description
Public Property | FontSize | Gets the style's font size.
Top
See Also

Reference

ImGearPDFStyle Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Properties$$

ImGearPDFStyle Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStyle Class

For a list of all members of this type, see ImGearPDFStyle members.

Public Properties
 | Name | Description
Public Property | FontSize | Gets the style's font size.
Top
See Also

Reference

ImGearPDFStyle Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFStyle Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStyle Class

For a list of all members of this type, see ImGearPDFStyle members.

See Also

Reference

ImGearPDFStyle Class
ImageGear.Formats.PDF Namespace


FontSize Property (ImGearPDFStyle)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFStyle Class : FontSize Property
Gets the style's font size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontSize As Integer
'Usage

Dim instance As ImGearPDFStyle
Dim value As Integer

value = instance.FontSize
public int FontSize {get;}
public: __property int get_FontSize();
public:
property int FontSize {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFStyle Class
ImGearPDFStyle Members


%%PageItemTitle%%

ImGearPDFSysEncoding Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysEncoding Class
Represents a system encoding for a PDF file.
Object Model
ImGearPDFSysEncoding Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFSysEncoding
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDFSysEncoding
public sealed class ImGearPDFSysEncoding : ImGearPDEObject
public __gc __sealed class ImGearPDFSysEncoding : public ImGearPDEObject
public ref class ImGearPDFSysEncoding sealed : public ImGearPDEObject
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDFSysEncoding

See Also

Reference

ImGearPDFSysEncoding Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFSysEncoding Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysEncoding Class

The following tables list the members exposed by ImGearPDFSysEncoding.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFSysEncoding Constructor | Overloaded. Initializes a new instance of the ImGearPDFSysEncoding class.
Top
Public Properties
 | Name | Description
Public Property | IsIdentity | Gets a value indicating whether the encoding is Identity-H or Identity-V.
Public Property | IsMultiByte | Gets a value indicating whether the encoding is CMap encoding.
Public Property | WritingMode | Gets a writing mode (horizontal or vertical).
Top
See Also

Reference

ImGearPDFSysEncoding Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSysEncoding Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class : ImGearPDFSysEncoding Constructor
Initializes a new instance of the ImGearPDFSysEncoding class.
Overload List
Overload | Description
ImGearPDFSysEncoding Constructor(ImGearPDFAtom,String[]) | Initializes a new instance of the ImGearPDFSysEncoding class.
ImGearPDFSysEncoding Constructor(ImGearPDFAtom) | Initializes a new instance of the ImGearPDFSysEncoding class.
ImGearPDFSysEncoding Constructor(ImGearPDFCodePages,Int16) | Initializes a new instance of the ImGearPDFSysEncoding class.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members


%%PageItemTitle%%

ImGearPDFSysEncoding Constructor(ImGearPDFAtom,String[])

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class > ImGearPDFSysEncoding Constructor : ImGearPDFSysEncoding Constructor(ImGearPDFAtom,String[])
The base encoding. See Section 5.5.5 in the PDF Reference.
Array of 256 Strings describing the differences from the encoding specified by baseEncodingName. May be Null.
Initializes a new instance of the ImGearPDFSysEncoding class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal baseEncodingName As ImGearPDFAtom, _
   ByVal encodingDifference() As String _
)
'Usage

Dim baseEncodingName As ImGearPDFAtom
Dim encodingDifference() As String

Dim instance As New ImGearPDFSysEncoding(baseEncodingName, encodingDifference)
public ImGearPDFSysEncoding(
   ImGearPDFAtom baseEncodingName,
   string[] encodingDifference
)
public: ImGearPDFSysEncoding(
   ImGearPDFAtom* baseEncodingName,
   string*[]* encodingDifference
)
public:
ImGearPDFSysEncoding(
   ImGearPDFAtom^ baseEncodingName,
   array<String^>^ encodingDifference
)

Parameters

baseEncodingName
The base encoding. See Section 5.5.5 in the PDF Reference.
encodingDifference
Array of 256 Strings describing the differences from the encoding specified by baseEncodingName. May be Null.

Return Value

The new instance of ImGearPDFSysEncoding class object.
Remarks
This constructor creates an encoding object from base name.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members
Overload List
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFSysEncoding Constructor(ImGearPDFAtom)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class > ImGearPDFSysEncoding Constructor : ImGearPDFSysEncoding Constructor(ImGearPDFAtom)
The CMap name.
Initializes a new instance of the ImGearPDFSysEncoding class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal encodingName As ImGearPDFAtom _
)
'Usage

Dim encodingName As ImGearPDFAtom

Dim instance As New ImGearPDFSysEncoding(encodingName)
public ImGearPDFSysEncoding(
   ImGearPDFAtom encodingName
)
public: ImGearPDFSysEncoding(
   ImGearPDFAtom* encodingName
)
public:
ImGearPDFSysEncoding(
   ImGearPDFAtom^ encodingName
)

Parameters

encodingName
The CMap name.

Return Value

The new instance of ImGearPDFSysEncoding class object.
Remarks
This constructor creates an encoding object from a PDF CMap name.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members
Overload List
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFSysEncoding Constructor(ImGearPDFCodePages,Int16)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class > ImGearPDFSysEncoding Constructor : ImGearPDFSysEncoding Constructor(ImGearPDFCodePages,Int16)
The code page character-mapping construct.
0 for horizontal writing, 1 for vertical writing.
Initializes a new instance of the ImGearPDFSysEncoding class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal codePage As ImGearPDFCodePages, _
   ByVal writeMode As Short _
)
'Usage

Dim codePage As ImGearPDFCodePages
Dim writeMode As Short

Dim instance As New ImGearPDFSysEncoding(codePage, writeMode)
public ImGearPDFSysEncoding(
   ImGearPDFCodePages codePage,
   short writeMode
)
public: ImGearPDFSysEncoding(
   ImGearPDFCodePages codePage,
   short writeMode
)
public:
ImGearPDFSysEncoding(
   ImGearPDFCodePages codePage,
   short writeMode
)

Parameters

codePage
The code page character-mapping construct.
writeMode
0 for horizontal writing, 1 for vertical writing.

Return Value

The new instance of ImGearPDFSysEncoding class object.
Remarks
This constructor creates an encoding object from a code page.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members
Overload List
ImGearPDFCodePages Enumeration


%%PageItemTitle%% $$Properties$$

ImGearPDFSysEncoding Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysEncoding Class

For a list of all members of this type, see ImGearPDFSysEncoding members.

Public Properties
 | Name | Description
Public Property | IsIdentity | Gets a value indicating whether the encoding is Identity-H or Identity-V.
Public Property | IsMultiByte | Gets a value indicating whether the encoding is CMap encoding.
Public Property | WritingMode | Gets a writing mode (horizontal or vertical).
Top
See Also

Reference

ImGearPDFSysEncoding Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFSysEncoding Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysEncoding Class

For a list of all members of this type, see ImGearPDFSysEncoding members.

See Also

Reference

ImGearPDFSysEncoding Class
ImageGear.Formats.PDF Namespace


IsIdentity Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class : IsIdentity Property
Gets a value indicating whether the encoding is Identity-H or Identity-V.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsIdentity As Boolean
'Usage

Dim instance As ImGearPDFSysEncoding
Dim value As Boolean

value = instance.IsIdentity
public bool IsIdentity {get;}
public: __property bool get_IsIdentity();
public:
property bool IsIdentity {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members


IsMultiByte Property (ImGearPDFSysEncoding)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class : IsMultiByte Property
Gets a value indicating whether the encoding is CMap encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsMultiByte As Boolean
'Usage

Dim instance As ImGearPDFSysEncoding
Dim value As Boolean

value = instance.IsMultiByte
public bool IsMultiByte {get;}
public: __property bool get_IsMultiByte();
public:
property bool IsMultiByte {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members


WritingMode Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysEncoding Class : WritingMode Property
Gets a writing mode (horizontal or vertical).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property WritingMode As Short
'Usage

Dim instance As ImGearPDFSysEncoding
Dim value As Short

value = instance.WritingMode
public short WritingMode {get;}
public: __property short get_WritingMode();
public:
property short WritingMode {
   short get();
}

Property Value

Integer value.
Remarks
Writing mode. 0 for horizontal writing and 1 for vertical writing.
See Also

Reference

ImGearPDFSysEncoding Class
ImGearPDFSysEncoding Members


%%PageItemTitle%%

ImGearPDFSysFont Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysFont Class
Represents a font installed in the host system.
Object Model
ImGearPDFSysFont ClassImGearPDFAtom ClassImGearPDFAtom ClassImGearPDFSysFont ClassImGearPDEFontAttrs ClassImGearPDEFontInfo ClassImGearPDFAtom Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFSysFont
   Inherits ImGearPDEObject
'Usage

Dim instance As ImGearPDFSysFont
public sealed class ImGearPDFSysFont : ImGearPDEObject
public __gc __sealed class ImGearPDFSysFont : public ImGearPDEObject
public ref class ImGearPDFSysFont sealed : public ImGearPDEObject
Remarks
System font methods allow you to list the fonts available in the host system and to find a font in the system that matches a PDE Font, if it is present.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDEObject
ImageGear.Formats.PDF.ImGearPDFSysFont

See Also

Reference

ImGearPDFSysFont Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFSysFont Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysFont Class

The following tables list the members exposed by ImGearPDFSysFont.

Public Properties
 | Name | Description
Public Property | CIDOrdering | Gets an ordering information of a multi-byte system font.
Public Property | CIDRegistry | Gets a registry information of a multi-byte system font.
Public Property | CIDSupplement | Gets a supplement information of a multi-byte system font.
Public Property | Name | Gets a PostScript or TrueType styled name for a system font.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Enumerate | Enumerates system fonts.
static (Shared in Visual Basic) | FindSysFont | Overloaded. Finds a system font that matches the requested attributes.
Public Method | GetAttributes | Gets the attributes of a system font.
Public Method | GetCreateFlags | Obtains flags that can be passed to the PDE font creation routine.
Public Method | GetInfo | Gets high-level information about a system font.
Public Method | GetWidths | Gets the widths of a single byte encoded system font.
Top
See Also

Reference

ImGearPDFSysFont Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Methods$$

ImGearPDFSysFont Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysFont Class

For a list of all members of this type, see ImGearPDFSysFont members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Enumerate | Enumerates system fonts.
static (Shared in Visual Basic) | FindSysFont | Overloaded. Finds a system font that matches the requested attributes.
Public Method | GetAttributes | Gets the attributes of a system font.
Public Method | GetCreateFlags | Obtains flags that can be passed to the PDE font creation routine.
Public Method | GetInfo | Gets high-level information about a system font.
Public Method | GetWidths | Gets the widths of a single byte encoded system font.
Top
See Also

Reference

ImGearPDFSysFont Class
ImageGear.Formats.PDF Namespace


Enumerate Method (ImGearPDFSysFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : Enumerate Method
SystemFont enumeration callback procedure.
User data.
Enumerates system fonts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Enumerate( _
   ByVal fontEnumerationCallback As ImGearPDFSysFont.ImGearPDFSysFontEnumerate, _
   ByVal userData As Object _
)
'Usage

Dim fontEnumerationCallback As ImGearPDFSysFont.ImGearPDFSysFontEnumerate
Dim userData As Object

ImGearPDFSysFont.Enumerate(fontEnumerationCallback, userData)
public static void Enumerate(
   ImGearPDFSysFont.ImGearPDFSysFontEnumerate fontEnumerationCallback,
   object userData
)
public: static void Enumerate(
   ImGearPDFSysFont.ImGearPDFSysFontEnumerate* fontEnumerationCallback,
   Object* userData
)
public:
static void Enumerate(
   ImGearPDFSysFont.ImGearPDFSysFontEnumerate^ fontEnumerationCallback,
   Object^ userData
)

Parameters

fontEnumerationCallback
SystemFont enumeration callback procedure.
userData
User data.
Remarks
Enumerates all of the system fonts with EnumerateProc.

The SystemFont parameters must be copied during the enumeration if they are needed beyond the EnumerateProc.

Developers should not assume that the EnumerateProc will get called. If no system fonts are found, EnumerateProc is never called.

See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class
ImGearPDFSysFont.ImGearPDFSysFontEnumerate Delegate


FindSysFont Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : FindSysFont Method
Finds a system font that matches the requested attributes.
Overload List
Overload | Description
FindSysFont(ImGearPDEFontAttrs,ImGearPDESysFontMatchFlags) | Finds a system font that matches the requested attributes.
FindSysFont(ImGearPDEFont,ImGearPDESysFontMatchFlags) | Finds a system font that matches the requested attributes.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members


FindSysFont(ImGearPDEFontAttrs,ImGearPDESysFontMatchFlags) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class > FindSysFont Method : FindSysFont(ImGearPDEFontAttrs,ImGearPDESysFontMatchFlags) Method
ImGearPDEFontAttrs for the font attributes.
Bit field comprised of ImGearPDESysFontMatchFlags values. Passing zero matches font by name only.
Finds a system font that matches the requested attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FindSysFont( _
   ByVal attributes As ImGearPDEFontAttrs, _
   ByVal options As ImGearPDESysFontMatchFlags _
) As ImGearPDFSysFont
'Usage

Dim attributes As ImGearPDEFontAttrs
Dim options As ImGearPDESysFontMatchFlags
Dim value As ImGearPDFSysFont

value = ImGearPDFSysFont.FindSysFont(attributes, options)
public static ImGearPDFSysFont FindSysFont(
   ImGearPDEFontAttrs attributes,
   ImGearPDESysFontMatchFlags options
)
public: static ImGearPDFSysFont* FindSysFont(
   ImGearPDEFontAttrs* attributes,
   ImGearPDESysFontMatchFlags options
)
public:
static ImGearPDFSysFont^ FindSysFont(
   ImGearPDEFontAttrs^ attributes,
   ImGearPDESysFontMatchFlags options
)

Parameters

attributes
ImGearPDEFontAttrs for the font attributes.
options
Bit field comprised of ImGearPDESysFontMatchFlags values. Passing zero matches font by name only.

Return Value

ImGearPDFSysFont class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
Overload List
ImGearPDFAtom Class
ImGearPDEFontAttrs Class
ImGearPDESysFontMatchFlags Enumeration


FindSysFont(ImGearPDEFont,ImGearPDESysFontMatchFlags) Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class > FindSysFont Method : FindSysFont(ImGearPDEFont,ImGearPDESysFontMatchFlags) Method
A PDE Font whose matching system font is found.
Bit field comprised of ImGearPDESysFontMatchFlags values. Passing zero matches font by name only.
Finds a system font that matches the requested attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FindSysFont( _
   ByVal font As ImGearPDEFont, _
   ByVal options As ImGearPDESysFontMatchFlags _
) As ImGearPDFSysFont
'Usage

Dim font As ImGearPDEFont
Dim options As ImGearPDESysFontMatchFlags
Dim value As ImGearPDFSysFont

value = ImGearPDFSysFont.FindSysFont(font, options)
public static ImGearPDFSysFont FindSysFont(
   ImGearPDEFont font,
   ImGearPDESysFontMatchFlags options
)
public: static ImGearPDFSysFont* FindSysFont(
   ImGearPDEFont* font,
   ImGearPDESysFontMatchFlags options
)
public:
static ImGearPDFSysFont^ FindSysFont(
   ImGearPDEFont^ font,
   ImGearPDESysFontMatchFlags options
)

Parameters

font
A PDE Font whose matching system font is found.
options
Bit field comprised of ImGearPDESysFontMatchFlags values. Passing zero matches font by name only.

Return Value

ImGearPDFSysFont class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
Overload List
ImGearPDFAtom Class
ImGearPDEFont Class
ImGearPDESysFontMatchFlags Enumeration


GetAttributes Method (ImGearPDFSysFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : GetAttributes Method
Gets the attributes of a system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttributes() As ImGearPDEFontAttrs
'Usage

Dim instance As ImGearPDFSysFont
Dim value As ImGearPDEFontAttrs

value = instance.GetAttributes()
public ImGearPDEFontAttrs GetAttributes()
public: ImGearPDEFontAttrs* GetAttributes();
public:
ImGearPDEFontAttrs^ GetAttributes();

Return Value

ImGearPDEFontAttrs class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class
ImGearPDEFontAttrs Class
ImGearPDESysFontMatchFlags Enumeration


GetCreateFlags Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : GetCreateFlags Method
A SysEncoding object.
Obtains flags that can be passed to the PDE font creation routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCreateFlags( _
   ByVal systemEncoding As ImGearPDFSysEncoding _
) As ImGearPDEFontCreateFlags
'Usage

Dim instance As ImGearPDFSysFont
Dim systemEncoding As ImGearPDFSysEncoding
Dim value As ImGearPDEFontCreateFlags

value = instance.GetCreateFlags(systemEncoding)
public ImGearPDEFontCreateFlags GetCreateFlags(
   ImGearPDFSysEncoding systemEncoding
)
public: ImGearPDEFontCreateFlags GetCreateFlags(
   ImGearPDFSysEncoding* systemEncoding
)
public:
ImGearPDEFontCreateFlags GetCreateFlags(
   ImGearPDFSysEncoding^ systemEncoding
)

Parameters

systemEncoding
A SysEncoding object.

Return Value

Superposition of the ImGearPDEFontCreateFlags values.
Remarks
If the combination of the current SysFont and SysEncoding is not allowed, it is set to CREATE_NOT_ALLOWED.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class
ImGearPDEFontCreateFlags Enumeration
ImGearPDFSysEncoding Class


GetInfo Method (ImGearPDFSysFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : GetInfo Method
Gets high-level information about a system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetInfo() As ImGearPDEFontInfo
'Usage

Dim instance As ImGearPDFSysFont
Dim value As ImGearPDEFontInfo

value = instance.GetInfo()
public ImGearPDEFontInfo GetInfo()
public: ImGearPDEFontInfo* GetInfo();
public:
ImGearPDEFontInfo^ GetInfo();

Return Value

ImGearPDEFontInfo class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class
ImGearPDEFontAttrs Class
ImGearPDEFontInfo Class


GetWidths Method (ImGearPDFSysFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : GetWidths Method
Multiple master font design vector.
Gets the widths of a single byte encoded system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetWidths( _
   ByVal designVector() As Integer _
) As Short()
'Usage

Dim instance As ImGearPDFSysFont
Dim designVector() As Integer
Dim value() As Short

value = instance.GetWidths(designVector)
public short[] GetWidths(
   int[] designVector
)
public: short[]* GetWidths(
   int[]* designVector
)
public:
array<short>^ GetWidths(
   array<int>^ designVector
)

Parameters

designVector
Multiple master font design vector.

Return Value

ImageGear integer array of the widths of a single byte encoded system font.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class
ImGearPDEFontAttrs Class
ImGearPDEFontInfo Class


%%PageItemTitle%% $$Properties$$

ImGearPDFSysFont Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysFont Class

For a list of all members of this type, see ImGearPDFSysFont members.

Public Properties
 | Name | Description
Public Property | CIDOrdering | Gets an ordering information of a multi-byte system font.
Public Property | CIDRegistry | Gets a registry information of a multi-byte system font.
Public Property | CIDSupplement | Gets a supplement information of a multi-byte system font.
Public Property | Name | Gets a PostScript or TrueType styled name for a system font.
Top
See Also

Reference

ImGearPDFSysFont Class
ImageGear.Formats.PDF Namespace


CIDOrdering Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : CIDOrdering Property
Gets an ordering information of a multi-byte system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CIDOrdering As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFSysFont
Dim value As ImGearPDFAtom

value = instance.CIDOrdering
public ImGearPDFAtom CIDOrdering {get;}
public: __property ImGearPDFAtom* get_CIDOrdering();
public:
property ImGearPDFAtom^ CIDOrdering {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class


CIDRegistry Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : CIDRegistry Property
Gets a registry information of a multi-byte system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CIDRegistry As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFSysFont
Dim value As ImGearPDFAtom

value = instance.CIDRegistry
public ImGearPDFAtom CIDRegistry {get;}
public: __property ImGearPDFAtom* get_CIDRegistry();
public:
property ImGearPDFAtom^ CIDRegistry {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class


CIDSupplement Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : CIDSupplement Property
Gets a supplement information of a multi-byte system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CIDSupplement As Integer
'Usage

Dim instance As ImGearPDFSysFont
Dim value As Integer

value = instance.CIDSupplement
public int CIDSupplement {get;}
public: __property int get_CIDSupplement();
public:
property int CIDSupplement {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members


Name Property (ImGearPDFSysFont)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFSysFont Class : Name Property
Gets a PostScript or TrueType styled name for a system font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As ImGearPDFAtom
'Usage

Dim instance As ImGearPDFSysFont
Dim value As ImGearPDFAtom

value = instance.Name
public ImGearPDFAtom Name {get;}
public: __property ImGearPDFAtom* get_Name();
public:
property ImGearPDFAtom^ Name {
   ImGearPDFAtom^ get();
}

Property Value

ImGearPDFAtom class object.
See Also

Reference

ImGearPDFSysFont Class
ImGearPDFSysFont Members
ImGearPDFAtom Class


%%PageItemTitle%%

ImGearPDFWord Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWord Class
Represents a word in a PDF file.
Object Model
ImGearPDFWord ClassImGearPDFStyle ClassImGearPDFFixedQuad Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFWord
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFWord
public sealed class ImGearPDFWord : ImGearPDFObject
public __gc __sealed class ImGearPDFWord : public ImGearPDFObject
public ref class ImGearPDFWord sealed : public ImGearPDFObject
Remarks
Each word contains a sequence of characters in one or more styles.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFWord

See Also

Reference

ImGearPDFWord Members
ImageGear.Formats.PDF Namespace
ImGearPDFStyle Class


%%PageItemTitle%% $$Members$$

ImGearPDFWord Class Members
Properties Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWord Class

The following tables list the members exposed by ImGearPDFWord.

Public Properties
 | Name | Description
Public Property | Bytes | Gets a word's byte array and also converts ligatures to their constituent characters.
Public Property | CharOffset | Gets a word's character offset from the beginning of its page.
Public Property | Length | Gets the number of bytes in a word.
Public Property | QuadCount | Gets the number of quads in a word.
Public Property | String | Gets a word's text and also converts ligatures to their constituent characters.
Top
Public Methods
 | Name | Description
Public Method | GetCharStyle | Gets a PDF Style object for the specified style in a word.
Public Method | GetQuad | Gets the word's quad, specified in user space coordinates.
Public Method | GetStyleTransition | Gets the locations of style transitions in a word.
Top
See Also

Reference

ImGearPDFWord Class
ImageGear.Formats.PDF Namespace
ImGearPDFStyle Class


%%PageItemTitle%% $$Methods$$

ImGearPDFWord Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWord Class

For a list of all members of this type, see ImGearPDFWord members.

Public Methods
 | Name | Description
Public Method | GetCharStyle | Gets a PDF Style object for the specified style in a word.
Public Method | GetQuad | Gets the word's quad, specified in user space coordinates.
Public Method | GetStyleTransition | Gets the locations of style transitions in a word.
Top
See Also

Reference

ImGearPDFWord Class
ImageGear.Formats.PDF Namespace
ImGearPDFStyle Class


GetCharStyle Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : GetCharStyle Method
A word finder object.
The index of the style to obtain. The first style in a word has an index of zero.
Gets a PDF Style object for the specified style in a word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCharStyle( _
   ByVal wordFinder As ImGearPDFWordFinder, _
   ByVal index As Integer _
) As ImGearPDFStyle
'Usage

Dim instance As ImGearPDFWord
Dim wordFinder As ImGearPDFWordFinder
Dim index As Integer
Dim value As ImGearPDFStyle

value = instance.GetCharStyle(wordFinder, index)
public ImGearPDFStyle GetCharStyle(
   ImGearPDFWordFinder wordFinder,
   int index
)
public: ImGearPDFStyle* GetCharStyle(
   ImGearPDFWordFinder* wordFinder,
   int index
)
public:
ImGearPDFStyle^ GetCharStyle(
   ImGearPDFWordFinder^ wordFinder,
   int index
)

Parameters

wordFinder
A word finder object.
index
The index of the style to obtain. The first style in a word has an index of zero.

Return Value

ImGearPDFStyle class object.
See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members
ImGearPDFStyle Class
ImGearPDFWordFinder Class


GetQuad Method (ImGearPDFWord)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : GetQuad Method
The index of the quad to obtain. The first quad in a word has an index of zero.
Gets the word's quad, specified in user space coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetQuad( _
   ByVal index As Integer _
) As ImGearPDFFixedQuad
'Usage

Dim instance As ImGearPDFWord
Dim index As Integer
Dim value As ImGearPDFFixedQuad

value = instance.GetQuad(index)
public ImGearPDFFixedQuad GetQuad(
   int index
)
public: ImGearPDFFixedQuad* GetQuad(
   int index
)
public:
ImGearPDFFixedQuad^ GetQuad(
   int index
)

Parameters

index
The index of the quad to obtain. The first quad in a word has an index of zero.

Return Value

ImGearPDFFixedQuad class object.
Remarks
See QuadCount property for a description of a quad.

The quad's height is the height of the font's bounding box, not the height of the tallest character used in the word. The font's bounding box is determined by the glyphs in the font that extend farthest above and below the baseline; it often extends somewhat above the top of "A" and below the bottom of "y."

The quad's width is determined from the characters actually present in the word.

As an example, the quads for the words "AWAY" and "away" have the same height, but generally do not have the same width unless the font is a mono-spaced font (a font in which all characters have the same width).

See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members
ImGearPDFFixedQuad Class
ImGearPDFWordFinder Class


GetStyleTransition Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : GetStyleTransition Method
Style transitions in a word.
Number of entries requested for the locations of style transitions. The word is searched only until this number of style transitions has been found.
Gets the locations of style transitions in a word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStyleTransition( _
   ByVal transitionTable() As Short, _
   ByVal size As Short _
) As Short
'Usage

Dim instance As ImGearPDFWord
Dim transitionTable() As Short
Dim size As Short
Dim value As Short

value = instance.GetStyleTransition(transitionTable, size)
public short GetStyleTransition(
   short[] transitionTable,
   short size
)
public: short GetStyleTransition(
   short[]* transitionTable,
   short size
)
public:
short GetStyleTransition(
   array<short>^ transitionTable,
   short size
)

Parameters

transitionTable
Style transitions in a word.
size
Number of entries requested for the locations of style transitions. The word is searched only until this number of style transitions has been found.

Return Value

The locations of style transitions in a word.
Remarks
Every word has at least one style transition, at character position zero in the word.
See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members
ImGearPDFStyle Class
ImGearPDFWordFinder Class


%%PageItemTitle%% $$Properties$$

ImGearPDFWord Class Properties

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWord Class

For a list of all members of this type, see ImGearPDFWord members.

Public Properties
 | Name | Description
Public Property | Bytes | Gets a word's byte array and also converts ligatures to their constituent characters.
Public Property | CharOffset | Gets a word's character offset from the beginning of its page.
Public Property | Length | Gets the number of bytes in a word.
Public Property | QuadCount | Gets the number of quads in a word.
Public Property | String | Gets a word's text and also converts ligatures to their constituent characters.
Top
See Also

Reference

ImGearPDFWord Class
ImageGear.Formats.PDF Namespace
ImGearPDFStyle Class


Bytes Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : Bytes Property
Gets a word's byte array and also converts ligatures to their constituent characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bytes As Byte()
'Usage

Dim instance As ImGearPDFWord
Dim value() As Byte

value = instance.Bytes
public byte[] Bytes {get;}
public: __property byte[]* get_Bytes();
public:
property array<byte>^ Bytes {
   array<byte>^ get();
}

Property Value

Byte array.
Remarks
The byte array to return includes any word break characters (such as space characters) that follow the word, but not any that precede the word. The characters that are treated as word breaks are defined in the EncInfo parameter of ImGearPDFWordFinder constructor.

The result is provided in whatever encoding the PDF Word uses, for both Roman and non-Roman systems.

See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members


CharOffset Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : CharOffset Property
Gets a word's character offset from the beginning of its page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CharOffset As Integer
'Usage

Dim instance As ImGearPDFWord
Dim value As Integer

value = instance.CharOffset
public int CharOffset {get;}
public: __property int get_CharOffset();
public:
property int CharOffset {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members


Length Property (ImGearPDFWord)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : Length Property
Gets the number of bytes in a word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Integer
'Usage

Dim instance As ImGearPDFWord
Dim value As Integer

value = instance.Length
public int Length {get;}
public: __property int get_Length();
public:
property int Length {
   int get();
}

Property Value

Integer value.
Remarks
This property also works on non-Roman systems.
See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members


QuadCount Property

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : QuadCount Property
Gets the number of quads in a word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property QuadCount As Integer
'Usage

Dim instance As ImGearPDFWord
Dim value As Integer

value = instance.QuadCount
public int QuadCount {get;}
public: __property int get_QuadCount();
public:
property int QuadCount {
   int get();
}

Property Value

Integer value.
Remarks
A quad is a quadrilateral bounding a contiguous piece of a word. Every word has at least one quad. A word has more than one quad, for example, if it is hyphenated and split across multiple lines or if the word is set on a curve rather than on a straight line.
See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members


String Property (ImGearPDFWord)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWord Class : String Property
Gets a word's text and also converts ligatures to their constituent characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property String As String
'Usage

Dim instance As ImGearPDFWord
Dim value As String

value = instance.String
public string String {get;}
public: __property string* get_String();
public:
property String^ String {
   String^ get();
}

Property Value

String value.
Remarks
The string to return includes any word break characters (such as space characters) that follow the word, but not any that precede the word. The characters that are treated as word breaks are defined in the EncInfo parameter of ImGearPDFWordFinder constructor.

The result is provided in whatever encoding the PDF Word uses, for both Roman and non-Roman systems.

See Also

Reference

ImGearPDFWord Class
ImGearPDFWord Members


%%PageItemTitle%%

ImGearPDFWordFinder Class
Members

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWordFinder Class
Represents a word finder object that extracts words from a PDF file.
Object Model
ImGearPDFWordFinder ClassImGearPDFWordFinder ClassImGearPDFWord Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPDFWordFinder
   Inherits ImGearPDFObject
'Usage

Dim instance As ImGearPDFWordFinder
public sealed class ImGearPDFWordFinder : ImGearPDFObject
public __gc __sealed class ImGearPDFWordFinder : public ImGearPDFObject
public ref class ImGearPDFWordFinder sealed : public ImGearPDFObject
Remarks
This class allows to enumerate the words on a single page or on all pages in a document and extracts it.
Inheritance Hierarchy

System.Object
ImageGear.Formats.PDF.ImGearPDFObject
ImageGear.Formats.PDF.ImGearPDFWordFinder

See Also

Reference

ImGearPDFWordFinder Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%% $$Members$$

ImGearPDFWordFinder Class Members
Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWordFinder Class

The following tables list the members exposed by ImGearPDFWordFinder.

Public Constructors
 | Name | Description
Public Constructor | ImGearPDFWordFinder Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | AcquireWordList | Finds all words on the specified page.
static (Shared in Visual Basic) | CreateUnicode | Creates a word finder that is used to extract text in the Unicode from a PDF file.
Public Method | GetWord | Gets the word in the word list obtained using AcquireWordList.
Public Method | ReleaseWordList | Releases the word list for a given page.
Top
See Also

Reference

ImGearPDFWordFinder Class
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFWordFinder Constructor

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class : ImGearPDFWordFinder Constructor
Overload List
Overload | Description
ImGearPDFWordFinder Constructor(ImGearPDFDocument,Int16[],String[],String[],ImGearPDFWordFinderVersion,ImGearPDFContextFlags) | Initializes a new instance of the ImGearPDFWordFinder class.
ImGearPDFWordFinder Constructor(ImGearPDFDocument,ImGearPDFWordFinderVersion,ImGearPDFContextFlags) | Initializes a new instance of the ImGearPDFWordFinder class.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members


%%PageItemTitle%%

ImGearPDFWordFinder Constructor(ImGearPDFDocument,Int16[],String[],String[],ImGearPDFWordFinderVersion,ImGearPDFContextFlags)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class > ImGearPDFWordFinder Constructor : ImGearPDFWordFinder Constructor(ImGearPDFDocument,Int16[],String[],String[],ImGearPDFWordFinderVersion,ImGearPDFContextFlags)
PDF document to find words in.
Array of 256 flags, specifying the type of character at each position in the encoding. Each flag is an OR of the Character Type Codes. If encodingInfo is Null, the platform's default encoding info is used. Use encodingInfo and encodingVector together; for every encodingInfo use a corresponding encodingVector to specify the character at that position in the encoding.
Array of 256 null-terminated strings that are the glyph names in encoding order. See the discussion of character names in Section 5.3 of the PostScript Language Reference Manual, Third Edition. If encodingVector is Null, the platform's default encoding vector is used. Use this parameter with encodingInfo.
A null-terminated array of null-terminated strings. Each string is the glyph name of a ligature in the font. When a word contains a ligature, the glyph name of the ligature is substituted for the ligature (for example, ff is substituted for the ff ligature). If ligatureTbl is Null, a default ligature table is used, containing the following ligatures: fi, ff, fl, ffi, ffl, ch, cl, ct, ll, ss, fs, st, oe, OE.
The version of the word-finding algorithm to use.
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.
Initializes a new instance of the ImGearPDFWordFinder class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal encodingInfo() As Short, _
   ByVal encodingVector() As String, _
   ByVal ligatureTable() As String, _
   ByVal algorithmVersion As ImGearPDFWordFinderVersion, _
   ByVal options As ImGearPDFContextFlags _
)
'Usage

Dim document As ImGearPDFDocument
Dim encodingInfo() As Short
Dim encodingVector() As String
Dim ligatureTable() As String
Dim algorithmVersion As ImGearPDFWordFinderVersion
Dim options As ImGearPDFContextFlags

Dim instance As New ImGearPDFWordFinder(document, encodingInfo, encodingVector, ligatureTable, algorithmVersion, options)
public ImGearPDFWordFinder(
   ImGearPDFDocument document,
   short[] encodingInfo,
   string[] encodingVector,
   string[] ligatureTable,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public: ImGearPDFWordFinder(
   ImGearPDFDocument* document,
   short[]* encodingInfo,
   string*[]* encodingVector,
   string*[]* ligatureTable,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public:
ImGearPDFWordFinder(
   ImGearPDFDocument^ document,
   array<short>^ encodingInfo,
   array<String^>^ encodingVector,
   array<String^>^ ligatureTable,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)

Parameters

document
PDF document to find words in.
encodingInfo
Array of 256 flags, specifying the type of character at each position in the encoding. Each flag is an OR of the Character Type Codes. If encodingInfo is Null, the platform's default encoding info is used. Use encodingInfo and encodingVector together; for every encodingInfo use a corresponding encodingVector to specify the character at that position in the encoding.
encodingVector
Array of 256 null-terminated strings that are the glyph names in encoding order. See the discussion of character names in Section 5.3 of the PostScript Language Reference Manual, Third Edition. If encodingVector is Null, the platform's default encoding vector is used. Use this parameter with encodingInfo.
ligatureTable
A null-terminated array of null-terminated strings. Each string is the glyph name of a ligature in the font. When a word contains a ligature, the glyph name of the ligature is substituted for the ligature (for example, ff is substituted for the ff ligature). If ligatureTbl is Null, a default ligature table is used, containing the following ligatures: fi, ff, fl, ffi, ffl, ch, cl, ct, ll, ss, fs, st, oe, OE.
algorithmVersion
The version of the word-finding algorithm to use.
options
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.

Return Value

The new instance of ImGearPDFWordFinder class object.
Remarks
The word finder that is used to extract text in the host encoding from a PDF file. It also extracts text from Form XObjects that are executed in the page contents. For information about Form XObjects, see Section 4.9 in the PDF Reference.

This method also works for non-Roman (CJK or Chinese-Japanese-Korean) viewers. In this case, words are extracted to the host encoding.

The type of WordFinder determines the encoding of the string returned by ImGearPDFWord.String.

For CJK viewers, words are stored internally using CID encoding. For more information on CIDFonts and related topics, see Section 5.6 in the PDF Reference. For detailed information on CIDFonts, see Technical Note #5092, CID-Keyed Font Technology Overview, and Technical Note #5014, Adobe CMap and CIDFont Files Specification.

See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
Overload List
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


%%PageItemTitle%%

ImGearPDFWordFinder Constructor(ImGearPDFDocument,ImGearPDFWordFinderVersion,ImGearPDFContextFlags)

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class > ImGearPDFWordFinder Constructor : ImGearPDFWordFinder Constructor(ImGearPDFDocument,ImGearPDFWordFinderVersion,ImGearPDFContextFlags)
PDF document to find words in.
The version of the word-finding algorithm to use.
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.
Initializes a new instance of the ImGearPDFWordFinder class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal document As ImGearPDFDocument, _
   ByVal algorithmVersion As ImGearPDFWordFinderVersion, _
   ByVal options As ImGearPDFContextFlags _
)
'Usage

Dim document As ImGearPDFDocument
Dim algorithmVersion As ImGearPDFWordFinderVersion
Dim options As ImGearPDFContextFlags

Dim instance As New ImGearPDFWordFinder(document, algorithmVersion, options)
public ImGearPDFWordFinder(
   ImGearPDFDocument document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public: ImGearPDFWordFinder(
   ImGearPDFDocument* document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public:
ImGearPDFWordFinder(
   ImGearPDFDocument^ document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)

Parameters

document
PDF document to find words in.
algorithmVersion
The version of the word-finding algorithm to use.
options
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.

Return Value

The new instance of ImGearPDFWordFinder class object.
Remarks
Creates a word finder that is used to extract text in the host encoding from a PDF file. The word finder also extracts text from Form XObjects that are executed in the page contents. For information about Form XObjects, see Section 4.9 in the PDF Reference.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
Overload List
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


%%PageItemTitle%% $$Methods$$

ImGearPDFWordFinder Class Methods

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWordFinder Class

For a list of all members of this type, see ImGearPDFWordFinder members.

Public Methods
 | Name | Description
Public Method | AcquireWordList | Finds all words on the specified page.
static (Shared in Visual Basic) | CreateUnicode | Creates a word finder that is used to extract text in the Unicode from a PDF file.
Public Method | GetWord | Gets the word in the word list obtained using AcquireWordList.
Public Method | ReleaseWordList | Releases the word list for a given page.
Top
See Also

Reference

ImGearPDFWordFinder Class
ImageGear.Formats.PDF Namespace


AcquireWordList Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class : AcquireWordList Method
The page number for which words are found. First page is 0.
Finds all words on the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AcquireWordList( _
   ByVal pageNumber As Integer _
) As Integer
'Usage

Dim instance As ImGearPDFWordFinder
Dim pageNumber As Integer
Dim value As Integer

value = instance.AcquireWordList(pageNumber)
public int AcquireWordList(
   int pageNumber
)
public: int AcquireWordList(
   int pageNumber
)
public:
int AcquireWordList(
   int pageNumber
)

Parameters

pageNumber
The page number for which words are found. First page is 0.

Return Value

Word count.
Remarks
Only words within or partially within the page's crop box are enumerated. Words outside the crop box are skipped. There can be only one word list in existence at a time; clients must release the previous word list, using ReleaseWordList, before creating a new one.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


CreateUnicode Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class : CreateUnicode Method
PDF document to find words in.
The version of the word-finding algorithm to use.
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.
Creates a word finder that is used to extract text in the Unicode from a PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateUnicode( _
   ByVal document As ImGearPDFDocument, _
   ByVal algorithmVersion As ImGearPDFWordFinderVersion, _
   ByVal options As ImGearPDFContextFlags _
) As ImGearPDFWordFinder
'Usage

Dim document As ImGearPDFDocument
Dim algorithmVersion As ImGearPDFWordFinderVersion
Dim options As ImGearPDFContextFlags
Dim value As ImGearPDFWordFinder

value = ImGearPDFWordFinder.CreateUnicode(document, algorithmVersion, options)
public static ImGearPDFWordFinder CreateUnicode(
   ImGearPDFDocument document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public: static ImGearPDFWordFinder* CreateUnicode(
   ImGearPDFDocument* document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)
public:
static ImGearPDFWordFinder^ CreateUnicode(
   ImGearPDFDocument^ document,
   ImGearPDFWordFinderVersion algorithmVersion,
   ImGearPDFContextFlags options
)

Parameters

document
PDF document to find words in.
algorithmVersion
The version of the word-finding algorithm to use.
options
Word-finding options that determine the tables filled when using AcquireWordList. Must be an OR of one or more of ImGearPDFContextFlags.

Return Value

The new instance of ImGearPDFWordFinder class object.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


GetWord Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class : GetWord Method
Word-finding options. Must be an OR of one or more of ImGearPDFContextFlags.
The index of the word to obtain. The first word on a page has an index of zero. Words are counted in PDF order.
Gets the word in the word list obtained using AcquireWordList.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetWord( _
   ByVal options As ImGearPDFContextFlags, _
   ByVal index As Integer _
) As ImGearPDFWord
'Usage

Dim instance As ImGearPDFWordFinder
Dim options As ImGearPDFContextFlags
Dim index As Integer
Dim value As ImGearPDFWord

value = instance.GetWord(options, index)
public ImGearPDFWord GetWord(
   ImGearPDFContextFlags options,
   int index
)
public: ImGearPDFWord* GetWord(
   ImGearPDFContextFlags options,
   int index
)
public:
ImGearPDFWord^ GetWord(
   ImGearPDFContextFlags options,
   int index
)

Parameters

options
Word-finding options. Must be an OR of one or more of ImGearPDFContextFlags.
index
The index of the word to obtain. The first word on a page has an index of zero. Words are counted in PDF order.

Return Value

ImGearPDFWord class object.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
ImGearPDFWord Class
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


ReleaseWordList Method

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace > ImGearPDFWordFinder Class : ReleaseWordList Method
The page number for which the word list is released.
Releases the word list for a given page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReleaseWordList( _
   ByVal pageNumber As Integer _
)
'Usage

Dim instance As ImGearPDFWordFinder
Dim pageNumber As Integer

instance.ReleaseWordList(pageNumber)
public void ReleaseWordList(
   int pageNumber
)
public: void ReleaseWordList(
   int pageNumber
)
public:
void ReleaseWordList(
   int pageNumber
)

Parameters

pageNumber
The page number for which the word list is released.
Remarks
Use this to release a list created by AcquireWordList when you are done using this list.
See Also

Reference

ImGearPDFWordFinder Class
ImGearPDFWordFinder Members
ImGearPDFDictionary Class
ImGearPDFWordFinderVersion Enumeration
ImGearPDFContextFlags Enumeration


%%PageItemTitle%%

ImGearPDEContentFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEContentFlags Enumeration
Specifies PDE content attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEContentFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEContentFlags
public enum ImGearPDEContentFlags : System.Enum
__value public enum ImGearPDEContentFlags : public System.Enum
public enum class ImGearPDEContentFlags : public System.Enum
Members
Member | Value | Description
FORM_MATRIX | 0x00000004 | FormMatrix contains a valid matrix.
NOT_SET | 0x00000000 | Flags not set.
SET_CACHE_DEVICE | 0x00000001 | CacheDevice contains 6 cache device values.
SET_CHAR_WIDTH | 0x00000002 | CacheDevice contains 2 char width values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEContentFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEElementCopyFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEElementCopyFlags Enumeration
Specifies PDE element copy flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEElementCopyFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEElementCopyFlags
public enum ImGearPDEElementCopyFlags : System.Enum
__value public enum ImGearPDEElementCopyFlags : public System.Enum
public enum class ImGearPDEElementCopyFlags : public System.Enum
Members
Member | Value | Description
CLIPPING | 0x00000002 | Acquire the clip path and put it in the copied object.
FOR_CLIP | 0x00000001 | Copied element does not need gstate or clip.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEElementCopyFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontCreateFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateFlags Enumeration
Specifies flags for PDE font creation routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEFontCreateFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEFontCreateFlags
public enum ImGearPDEFontCreateFlags : System.Enum
__value public enum ImGearPDEFontCreateFlags : public System.Enum
public enum class ImGearPDEFontCreateFlags : public System.Enum
Members
Member | Value | Description
CREATE_ALL_WIDTHS | 0x00000080 | Supply entire widths table. Affects Type0 fonts only.
CREATE_EMBEDDED | 0x00000001 | Embed the font. Create an embedded font.
CREATE_GID_OVERRIDE | 0x00000020 | The library will convert cp to gid with identity embedded.
CREATE_NOT_ALLOWED | 0xFFFFFFFF | Creation is not allowed. Used when the combination of SysFont and SysEncoding is not allowed.
CREATE_SUBSET | 0x00000002 | Subset the font. Same as WILL_SUBSET.
CREATE_TO_UNICODE | 0x00000040 | Create ToUnicode cmap.
DEFER_WIDTHS | 0x00000010 | Wait to get widths until later (affects Type0 fonts only).
DO_NOT_EMBED | 0x00000004 | Do not embed the font. You cannot set both this and the WILL_SUBSET flags. Nor can you set CREATE_EMBEDDED.
ENCODE_BY_GID | 0x00000008 | Create a CIDFont with identity (GID) encoding.
WILL_SUBSET | 0x00000002 | Subset the font.
Remarks
To subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET flags.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEFontCreateFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontCreateNeedFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontCreateNeedFlags Enumeration
Specifies PDE font flags for creation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEFontCreateNeedFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEFontCreateNeedFlags
public enum ImGearPDEFontCreateNeedFlags : System.Enum
__value public enum ImGearPDEFontCreateNeedFlags : public System.Enum
public enum class ImGearPDEFontCreateNeedFlags : public System.Enum
Members
Member | Value | Description
EMBED | 0x00040000 | Need to embed it.
TO_UNICODE | 0x00020000 | Need to create ToUnicode stream.
WIDTHS | 0x00010000 | Need to create width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEFontCreateNeedFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontFlags Enumeration
Specifies font's attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEFontFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEFontFlags
public enum ImGearPDEFontFlags : System.Enum
__value public enum ImGearPDEFontFlags : public System.Enum
public enum class ImGearPDEFontFlags : public System.Enum
Members
Member | Value | Description
ALL_CAP | 0x00010000 | The font is an all-caps font.
FIXED_WIDTH | 0x00000001 | All glyphs in the font are the same width.
FORCE_BOLD | 0x00040000 | Force bold characters to draw bold even at small point sizes.
ITALIC | 0x00000040 | The font is an italic font.
PI | 0x00000004 | The font is a symbolic (pi) font.
SCRIPT | 0x00000008 | The font is a script font.
SERIF | 0x00000002 | The font is a serif font.
SMALL_CAP | 0x00020000 | The font is a small caps font.
STD_ENCODING | 0x00000020 | The font uses standard encoding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEFontFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEFontProtection Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEFontProtection Enumeration
Specifies font protection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEFontProtection
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEFontProtection
public enum ImGearPDEFontProtection : System.Enum
__value public enum ImGearPDEFontProtection : public System.Enum
public enum class ImGearPDEFontProtection : public System.Enum
Members
Member | Value | Description
NO_EDITABLE_EMBEDDING | 2 | Editable embedding is not allowed.
NO_EMBEDDING | 1 | Embedding is not allowed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEFontProtection

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEGraphicStateWasSetFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEGraphicStateWasSetFlags Enumeration
Specifies a graphics state that was set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEGraphicStateWasSetFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEGraphicStateWasSetFlags
public enum ImGearPDEGraphicStateWasSetFlags : System.Enum
__value public enum ImGearPDEGraphicStateWasSetFlags : public System.Enum
public enum class ImGearPDEGraphicStateWasSetFlags : public System.Enum
Members
Member | Value | Description
DASH | 0x00000010 | A dash specification was set, corresponding to the d (setdash) operator.
EXT_GSTATE | 0x00000800 | An extended graphics state was set, corresponding to the gs operator.
FILL_CSPACE | 0x00000001 | A fill color space was set, corresponding to the cs (setcolorspace) operator.
FILL_CVALUE | 0x00000002 | A color fill value was set, corresponding to the sc (setcolor) operator.
FLATNESS | 0x00000080 | Line flatness was set, corresponding to the i (setflat) operator.
LINE_CAP | 0x00000100 | Line cap style was set, corresponding to the J (setlinecap) operator.
LINE_JOIN | 0x00000200 | Line join style was set, corresponding to the j (setlinejoin) operator.
LINE_WIDTH | 0x00000020 | The line width was set, corresponding to the w (setlinewidth) operator.
MITER_LIMIT | 0x00000040 | The miter limit was set, corresponding to the M (setmiterlimit) operator.
RENDER_INTENT | 0x00000400 | A color rendering intent was set, corresponding to the Intent key in the image dictionary.
STROKE_CSPACE | 0x00000004 | A color space stroke value was set, corresponding to the CS (setcolorspace) operator.
STROKE_CVALUE | 0x00000008 | A color stroke value was set, corresponding to the SC (setcolor) operator.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEGraphicStateWasSetFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEImageAttrFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageAttrFlags Enumeration
Specifies PDE image attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEImageAttrFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEImageAttrFlags
public enum ImGearPDEImageAttrFlags : System.Enum
__value public enum ImGearPDEImageAttrFlags : public System.Enum
public enum class ImGearPDEImageAttrFlags : public System.Enum
Members
Member | Value | Description
EXTERNAL | 0x00000001 | Image is an XObject.
HAVE_DECODE | 0x00000008 | We have a decode array.
INDEXED | 0x00000010 | Uses an indexed color space.
INTERPOLATE | 0x00000004 | Interpolate is true.
MASK | 0x00000002 | Image is an imagemask.
MASKED_BY_COLOR | 0x00000040 | Image has a Mask key containing an array of color values.
MASKED_BY_POSITION | 0x00000020 | Image has a Mask key containing an ImageMask stream.
Remarks
See Section 4.8.4 in the PDF Reference for more information on image attributes.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEImageAttrFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEImageDataFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEImageDataFlags Enumeration
Specifies image data flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEImageDataFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEImageDataFlags
public enum ImGearPDEImageDataFlags : System.Enum
__value public enum ImGearPDEImageDataFlags : public System.Enum
public enum class ImGearPDEImageDataFlags : public System.Enum
Members
Member | Value | Description
DECODED | 0x00000000 | Data is not encoded.
ENCODED | 0x00000001 | Data is encoded.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEImageDataFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEInsertElement Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEInsertElement Enumeration
Specifies pre-defined positions for inserting a PDE element into the content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEInsertElement
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEInsertElement
public enum ImGearPDEInsertElement : System.Enum
__value public enum ImGearPDEInsertElement : public System.Enum
public enum class ImGearPDEInsertElement : public System.Enum
Members
Member | Value | Description
AFTER_LAST | 2147483646 | Specifies the last element position. Used to insert last content element.
BEFORE_FIRST | -1 | Specifies position before the first element. Used to insert first content element.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEInsertElement

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPathElementType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPathElementType Enumeration
Specifies path segment operators in PDE path elements.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEPathElementType
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEPathElementType
public enum ImGearPDEPathElementType : System.Enum
__value public enum ImGearPDEPathElementType : public System.Enum
public enum class ImGearPDEPathElementType : public System.Enum
Members
Member | Value | Description
CLOSE_PATH | 6 | Designates h (closepath) operator, which closes the current subpath.
CURVE_TO | 2 | Designates c (curveto) operator, which appends a Bezier curve to the path.
CURVE_TO_V | 3 | Designates v (curveto) operator, which appends a Bezier curve to the current path when the first control point coincides with initial point on the curve.
CURVE_TO_Y | 4 | Designates y (curveto) operator, which appends a Bezier curve to the current path when the second control point coincides with final point on the curve.
LINE_TO | 1 | Designates l (lineto) operator, which appends a straight line segment from the current point.
MOVE_TO | 0 | Designates m (moveto) operator, which moves the current point.
RECT | 5 | Designates re operator, which adds a rectangle to the current path.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEPathElementType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPathOpFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPathOpFlags Enumeration
Specifies flags for paint operators in a PDE path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEPathOpFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEPathOpFlags
public enum ImGearPDEPathOpFlags : System.Enum
__value public enum ImGearPDEPathOpFlags : public System.Enum
public enum class ImGearPDEPathOpFlags : public System.Enum
Members
Member | Value | Description
EO_FILL | 0x00000004 | Fills the path, using the even-odd rule to determine the region to fill, as with the f* (eofill) operator.
FILL | 0x00000002 | Fills the path, using the nonzero winding number rule to determine the region to fill, as with the f (fill) operator.
INVISIBLE | 0x00000000 | Path is neither stroked nor filled, so it is invisible.
STROKE | 0x00000001 | Stroke the path, as with the S (stroke) operator.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEPathOpFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEPSAttrFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEPSAttrFlags Enumeration
Specifies PostScript attributes flags for ImGearPDEPSAttrs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEPSAttrFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEPSAttrFlags
public enum ImGearPDEPSAttrFlags : System.Enum
__value public enum ImGearPDEPSAttrFlags : public System.Enum
public enum class ImGearPDEPSAttrFlags : public System.Enum
Members
Member | Value | Description
INLINE | 0x00000000 | Inline PostScript.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEPSAttrFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDESoftMaskCreateFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESoftMaskCreateFlags Enumeration
Specifies flags for SoftMask creation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDESoftMaskCreateFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDESoftMaskCreateFlags
public enum ImGearPDESoftMaskCreateFlags : System.Enum
__value public enum ImGearPDESoftMaskCreateFlags : public System.Enum
public enum class ImGearPDESoftMaskCreateFlags : public System.Enum
Members
Member | Value | Description
ALPHA | 0x00000002 | Specifies how the mask is to be computed.
LUMINOSITY | 0x00000001 | Specifies how the mask is to be computed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDESoftMaskCreateFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDESysFontMatchFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESysFontMatchFlags Enumeration
Specifies font matching flags for SysFont find routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDESysFontMatchFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDESysFontMatchFlags
public enum ImGearPDESysFontMatchFlags : System.Enum
__value public enum ImGearPDESysFontMatchFlags : public System.Enum
public enum class ImGearPDESysFontMatchFlags : public System.Enum
Members
Member | Value | Description
FONT_TYPE | 0x00000002 | Match the font type.
NAME_AND_CHARSET | 0x00000001 | Match the font name and character set.
WRITING_MODE | 0x00000004 | Match the writing mode, that is, horizontal or vertical.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDESysFontMatchFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDESysFontPackageType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDESysFontPackageType Enumeration
Specifies system font package type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDESysFontPackageType
   Inherits System.Enum
'Usage

Dim instance As ImGearPDESysFontPackageType
public enum ImGearPDESysFontPackageType : System.Enum
__value public enum ImGearPDESysFontPackageType : public System.Enum
public enum class ImGearPDESysFontPackageType : public System.Enum
Members
Member | Value | Description
ATC | 4 | ATC package.
CID | 3 | CID package.
OCF | 5 | OCF package.
OPENTYPE_CFF | 6 | OpenType CFF package.
OPENTYPE_CID | 7 | OpenType CID package.
OPENTYPE_TT | 8 | OpenType TT package.
TRUETYPE | 2 | TrueType package.
TYPE1 | 1 | Package type 1.
UNKNOWN | 0 | Unknown package type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDESysFontPackageType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDETextFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDETextFlags Enumeration
Specifies PDE text flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDETextFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDETextFlags
public enum ImGearPDETextFlags : System.Enum
__value public enum ImGearPDETextFlags : public System.Enum
public enum class ImGearPDETextFlags : public System.Enum
Members
Member | Value | Description
CHAR | 0x00000002 | Specifies an action for single character.
GET_BOUNDS | 0x00000008 | Specifies using the font descriptor's FontBBox.
PAGE_SPACE | 0x00000004 | Specifies user space.
RUN | 0x00000001 | Specifies an action for the run.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDETextFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEType Enumeration
Specifies types of PDF editing objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEType
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEType
public enum ImGearPDEType : System.Enum
__value public enum ImGearPDEType : public System.Enum
public enum class ImGearPDEType : public System.Enum
Members
Member | Value | Description
BEGIN_CONTAINER | 19 | Object of Begin Container type.
BEGIN_GROUP | 21 | Object of Begin Group type.
CLIP | 7 | Object of Clip type.
COLORSPACE | 9 | Object of color space type.
CONTAINER | 12 | Object of Container type.
CONTENT | 0 | Object of Content type.
DEVICENCOLORS | 15 | Object of Device N Colors type.
DOC | 26 | Object of Document type.
END_CONTAINER | 20 | Object of End Container type.
END_GROUP | 22 | Object of End Group type.
FONT | 8 | Object of Font type.
FORM | 4 | Object of Form type.
GROUP | 17 | Object of Group type.
GSTATE | 10 | Object of Graphic State type.
IMAGE | 3 | Object of Image type.
LASTTYPE | 31 | Last Type.
PAGE | 27 | Object of Page type.
PATH | 2 | Object of Path type.
PATTERN | 14 | Object of Pattern type.
PLACE | 11 | Object of Place type.
POSTSCRIPT | 5 | Object of PostScript type.
READER | 28 | Object of Reader type.
SHADING | 16 | Object of Shading type.
SOFTMASK | 24 | Object of SoftMask type.
SYSENCODING | 25 | Object of System Encoding type.
SYSFONT | 13 | Object of System Font type.
TEXT | 1 | Object of Text type.
TEXTITEM | 30 | Object of Text Item type.
UNKNOWN | 18 | Object of Unknown type.
WRITER | 29 | Object of Writer type.
XGROUP | 23 | Object of XGroup type.
XOBJECT | 6 | Object of XObject type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEXGroupCreateFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEXGroupCreateFlags Enumeration
Specifies creation flags for transparency group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDEXGroupCreateFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDEXGroupCreateFlags
public enum ImGearPDEXGroupCreateFlags : System.Enum
__value public enum ImGearPDEXGroupCreateFlags : public System.Enum
public enum class ImGearPDEXGroupCreateFlags : public System.Enum
Members
Member | Value | Description
TRANSPARENCY | 0x00000001 | Creates a transparency XGroup object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDEXGroupCreateFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBasicType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBasicType Enumeration
Specifies types of basic PDF objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFBasicType
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFBasicType
public enum ImGearPDFBasicType : System.Enum
__value public enum ImGearPDFBasicType : public System.Enum
public enum class ImGearPDFBasicType : public System.Enum
Members
Member | Value | Description
ARRAY | 7 | Array object.
BOOLEAN | 3 | Boolean object.
DICTIONARY | 6 | Dictionary object.
FIXED | 2 | Fixed (real) object.
INTEGER | 1 | Integer object.
NAME | 4 | Name object.
NULL | 0 | Null object.
STREAM | 8 | Stream object.
STRING | 5 | String object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFBasicType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFBookmarkFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFBookmarkFlags Enumeration
Specifies PDF bookmark flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFBookmarkFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFBookmarkFlags
public enum ImGearPDFBookmarkFlags : System.Enum
__value public enum ImGearPDFBookmarkFlags : public System.Enum
public enum class ImGearPDFBookmarkFlags : public System.Enum
Members
Member | Value | Description
FONT_BOLD | 0x00000002 | Bold font.
FONT_ITALIC | 0x00000001 | Italic font.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFBookmarkFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFCodePages Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFCodePages Enumeration
Specifies a code page character-mapping.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFCodePages
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFCodePages
public enum ImGearPDFCodePages : System.Enum
__value public enum ImGearPDFCodePages : public System.Enum
public enum class ImGearPDFCodePages : public System.Enum
Members
Member | Value | Description
MAC_ARABIC | -9986 | Macintosh pseudo code pages.
MAC_CENTRAL_EUROPEAN | -9994 | Macintosh pseudo code pages.
MAC_CROATIAN | -9993 | Macintosh pseudo code pages.
MAC_CYRILLIC | -9991 | Macintosh pseudo code pages.
MAC_GREEK | -9989 | Macintosh pseudo code pages.
MAC_HEBREW | -9987 | Macintosh pseudo code pages.
MAC_ROMANIAN | -9992 | Macintosh pseudo code pages.
MAC_TURKISH | -9988 | Macintosh pseudo code pages.
MAC_UKRAINIAN | -9990 | Macintosh pseudo code pages.
WIN_ARABIC | 1256 | Windows code pages.
WIN_BALTIC | 1257 | Windows code pages.
WIN_CYRILLIC | 1251 | Windows code pages.
WIN_EAST_EUROPEAN_ROMAN | 1250 | Windows code pages.
WIN_GREEK | 1253 | Windows code pages.
WIN_HEBREW | 1255 | Windows code pages.
WIN_TURKISH | 1254 | Windows code pages.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFCodePages

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFContextFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFContextFlags Enumeration
Specifies context flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFContextFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFContextFlags
public enum ImGearPDFContextFlags : System.Enum
__value public enum ImGearPDFContextFlags : public System.Enum
public enum class ImGearPDFContextFlags : public System.Enum
Members
Member | Value | Description
PDF_ORDER | 0x00000002 | Enumerates words in the order they appear in the PDF file.
XY_ORDER | 0x00000004 | Enumerates words sorted by their x- and y-coordinates on the page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFContextFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDestinationType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDestinationType Enumeration
Specifies the types of PDF object destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFDestinationType
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFDestinationType
public enum ImGearPDFDestinationType : System.Enum
__value public enum ImGearPDFDestinationType : public System.Enum
public enum class ImGearPDFDestinationType : public System.Enum
Members
Member | Value | Description
EXPLICIT | 1 | Explicit destination.
INVALID | 0 | Invalid destination.
NAMED | 2 | Named destination.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFDestinationType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFFixedValues Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFFixedValues Enumeration
Specifies predefined PDF fixed-point constants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFFixedValues
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFFixedValues
public enum ImGearPDFFixedValues : System.Enum
__value public enum ImGearPDFFixedValues : public System.Enum
public enum class ImGearPDFFixedValues : public System.Enum
Members
Member | Value | Description
EIGHTH | 8192 | 1/8 predefined value.
GOLDEN | 106039 | Golden predefined value.
HALF | 32768 | 1/2 predefined value.
HUNDREDTH | 655 | 1/100 predefined value.
MAX | 2147483647 | Max fixed-point value.
MIN | -2147483648 | Min fixed-point value.
NEGATIVE_INFINITY | 2147483647 | Negative fixed-point infinity.
ONE | 65536 | 1 predefined value.
ONE1 | 65535 | Predefined -1 value.
PI2 | 102944 | PI/2 predefined value.
PI4 | 51472 | PI/4 predefined value.
POSITIVE_INFINITY | -2147483648 | Positive fixed-point infinity.
QUARTER | 16384 | 1/4 predefined value.
SEVENEIGHTS | 57344 | 7/8 predefined value.
SIXTEENTH | 4096 | 1/16 predefined value.
TEN | 655360 | 10 predefined value.
TENTH | 6553 | 1/10 predefined value.
THIRD | 21845 | 1/3 predefined value.
THREEQUARTERS | 49152 | 3/4 predefined value.
TWELFTH | 5461 | 1/12 predefined value.
TWOTHIRDS | 43690 | 2/3 predefined value.
ZERO | 0 | Zero value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFFixedValues

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFInsertFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFInsertFlags Enumeration
Specifies insert flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFInsertFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFInsertFlags
public enum ImGearPDFInsertFlags : System.Enum
__value public enum ImGearPDFInsertFlags : public System.Enum
public enum class ImGearPDFInsertFlags : public System.Enum
Members
Member | Value | Description
ALL | 0x00001000 | Insert all Catalog and Info Dictionary values as well as pages.
BOOKMARKS | 0x00000001 | Insert bookmarks as well as pages.
DEFAULT | 0x00000000 | Insert by default.
THREADS | 0x00000002 | Insert articles as well.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFInsertFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFOCMDVisPolicy Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFOCMDVisPolicy Enumeration
Specifies PDF dictionary (OCMD) visibility policy types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFOCMDVisPolicy
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFOCMDVisPolicy
public enum ImGearPDFOCMDVisPolicy : System.Enum
__value public enum ImGearPDFOCMDVisPolicy : public System.Enum
public enum class ImGearPDFOCMDVisPolicy : public System.Enum
Members
Member | Value | Description
ALL_OFF | 3 | Content is invisible if all layers are off.
ALL_ON | 0 | Content is visible if all layers are on.
ANY_OFF | 2 | Content is invisible if at least one layer is off.
ANY_ON | 1 | Content is visible if at least one layer is on.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFOCMDVisPolicy

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPageDrawMode Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPageDrawMode Enumeration
Specifies PDF rendering methods used to draw PDF page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPageDrawMode
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPageDrawMode
public enum ImGearPDFPageDrawMode : System.Enum
__value public enum ImGearPDFPageDrawMode : public System.Enum
public enum class ImGearPDFPageDrawMode : public System.Enum
Members
Member | Value | Description
ENTIRE_PAGE | 1 | Draws entire page content into the cache. Optimized for fast scrolling.
VISIBLE_AREA | 2 | Draws visible page content area. Optimized for fast rendering w/o scrolling.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPageDrawMode

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPageNumber Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPageNumber Enumeration
Specifies pre-defined page number values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPageNumber
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPageNumber
public enum ImGearPDFPageNumber : System.Enum
__value public enum ImGearPDFPageNumber : public System.Enum
public enum class ImGearPDFPageNumber : public System.Enum
Members
Member | Value | Description
BEFORE_FIRST_PAGE | -1 | Specifies position before the first page. Used to insert first document page.
LAST_PAGE | -2 | Specifies the last page position. Used to insert last document page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPageNumber

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPageRange Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPageRange Enumeration
Specifies pre-defined page range values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPageRange
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPageRange
public enum ImGearPDFPageRange : System.Enum
__value public enum ImGearPDFPageRange : public System.Enum
public enum class ImGearPDFPageRange : public System.Enum
Members
Member | Value | Description
ALL_PAGES | -3 | All pages in the document.
EVEN_PAGES | -5 | Even pages in the document.
ODD_PAGES | -4 | Odd pages in the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPageRange

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPermReqObj Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPermReqObj Enumeration
Specifies the target objects of a permission request.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPermReqObj
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPermReqObj
public enum ImGearPDFPermReqObj : System.Enum
__value public enum ImGearPDFPermReqObj : public System.Enum
public enum class ImGearPDFPermReqObj : public System.Enum
Members
Member | Value | Description
ANNOT | 6 | Annotation object.
BOOKMARK | 4 | Bookmark object.
DOC | 1 | Document object.
FORM | 7 | Form object.
LAST | 9 | Used for checking cache size.
LINK | 3 | Link object.
PAGE | 2 | Page object.
SIGNATURE | 8 | Signature object.
THUMBNAIL | 5 | Thumbnail object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPermReqObj

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPermReqOpr Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPermReqOpr Enumeration
Specifies the target operations of a permissions request.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPermReqOpr
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPermReqOpr
public enum ImGearPDFPermReqOpr : System.Enum
__value public enum ImGearPDFPermReqOpr : public System.Enum
public enum class ImGearPDFPermReqOpr : public System.Enum
Members
Member | Value | Description
ACCESSIBLE | 6 | For Accessibility use.
ALL | 1 | Check all operations.
ANY | 22 | Used for checking to see if any operation is allowed.
COPY | 5 | Copy operation.
CREATE | 2 | Generic operation.
CROP | 14 | Crop operation.
DELETE | 3 | Delete operation.
EXPORT | 21 | For notes. ExportPS should check print.
FILL_IN | 12 | Form fill-in or Sign existing field.
FULL_SAVE | 19 | For document saving.
IMPORT | 20 | For notes and Image import.
INSERT | 16 | Insert operation.
LAST | 26 | This should be always the last item.
MODIFY | 4 | Modify operation.
OPEN | 8 | For document open.
PRINT_HIGH | 10 | For doc, Regular printing.
PRINT_LOW | 11 | For doc, low quality printing.
REORDER | 18 | For page reordering.
REPLACE | 17 | For page replacing.
ROTATE | 13 | Rotate operation.
SECURE | 9 | For doc to changing security settings.
SELECT | 7 | For doc or page, selecting (not copying) text or graphics.
SPAWN_TEMPLATE | 25 | Allows form to spawn template page.
SUBMIT_STANDALONE | 24 | Submit forms outside of the browser.
SUMMARIZE | 15 | For summarize notes.
UNKNOWNOPR | 23 | Used for error checking.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPermReqOpr

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPermReqStatus Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPermReqStatus Enumeration
Specifies the status of PDF document related permissions methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPermReqStatus
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPermReqStatus
public enum ImGearPDFPermReqStatus : System.Enum
__value public enum ImGearPDFPermReqStatus : public System.Enum
public enum class ImGearPDFPermReqStatus : public System.Enum
Members
Member | Value | Description
DENIED | -1 | Request was denied.
GRANTED | 0 | Request was granted.
OPERATION_NA | 3 | The operation is not applicable for the specified object.
PENDING | 4 | The handler doesn't have enough info to answer at this point. Try again later.
UNKNOWN_OBJECT | 1 | The object is unknown.
UNKNOWN_OPERATION | 2 | The operation is unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPermReqStatus

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPermsFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPermsFlags Enumeration
Specifies permissions wanted and granted for a document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPermsFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPermsFlags
public enum ImGearPDFPermsFlags : System.Enum
__value public enum ImGearPDFPermsFlags : public System.Enum
public enum class ImGearPDFPermsFlags : public System.Enum
Members
Member | Value | Description
ACCESSIBLE | 0x00000200 | Overrides COPY to enable accessibility API.
ALL | 0xFFFFFFFF | All permissions, including OPEN and SECURE.
COPY | 0x00000010 | The user is permitted to copy information from the document to the clipboard.
DOC_ASSEMBLY | 0x00000400 | Overrides various EDIT bit and allow the following operations: page insert/delete/rotate and create bookmark and thumbnail.
EDIT | 0x00000008 | The user is permitted to edit the document more than adding or modifying text notes (see also EDIT_NOTES).
EDIT_NOTES | 0x00000020 | The user is permitted to add, modify, and delete text notes (see also EDIT).
EXT | 0x00000080 | 0x80 flag (no description).
FILL_AND_SIGN | 0x00000100 | Overrides other ImGearPDFPermsFlags bits. It allows user to fill-in or sign existing form or signature fields.
FORM_SPAWN_TEMPL | 0x00020000 | Allows spawning template pages even if IG_PDF_PERM_EDIT and IG_PDF_PERM_EDIT_NOTES are not set.
FORM_SUBMIT | 0x00010000 | Allows submitting forms outside of the browser. This bit is supplement to FILL_AND_SIGN.
HIGH_PRINT | 0x00000800 | This bit is supplement to PRINT. If it is disabled only low quality printing is allowed.
NONE | 0x00000000 | No permissions.
OPEN | 0x00000001 | The user is permitted to open and decrypt the document.
OWNER | 0x00008000 | The user is permitted to perform all operations, regardless of the permissions specified by the document.
PRINT | 0x00000004 | The user is permitted to print the document.
SAVE_AS | 0x00000040 | The user is permitted to perform a Save As action.
SECURE | 0x00000002 | The user is permitted to change the document's security settings.
SETTABLE | 0x0000003C | Combination of the following operations: PRINT, EDIT, COPY and EDIT_NOTES.
USER | 0xFFFFFFFC | All permissions, excluding OPEN and SECURE.
Remarks
Not all permissions will be granted, if the document is protected or if the document is newer version than the application knows about.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPermsFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPreflightProfile Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightProfile Enumeration
Specifies types of supported preflight profiles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPreflightProfile
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPreflightProfile
public enum ImGearPDFPreflightProfile : System.Enum
__value public enum ImGearPDFPreflightProfile : public System.Enum
public enum class ImGearPDFPreflightProfile : public System.Enum
Members
Member | Value | Description
PDFA_1A_2005 | 0 | Profile for PDF/A-1a standard, revision 2005.
PDFA_1B_2005 | 1 | Profile for PDF/A-1b, revision 2005.
PDFX_3_2003 | 2 | Profile for PDF/X-3, revision 2003.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPreflightProfile

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPreflightReportCodes Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightReportCodes Enumeration
Specifies PDF preflight error codes describing incompliance with the specified profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPreflightReportCodes
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPreflightReportCodes
public enum ImGearPDFPreflightReportCodes : System.Enum
__value public enum ImGearPDFPreflightReportCodes : public System.Enum
public enum class ImGearPDFPreflightReportCodes : public System.Enum
Members
Member | Value | Description
INCOMPLIANT_ACTIONS | 29 | Actions are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_ANNOTATIONS | 26 | Annotations are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_ANNOTATIONS_DICT | 28 | Annotation dictionaries are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_ANNOTATIONS_TYPE | 53 | Annotations of unknown type are not compliant.
INCOMPLIANT_ARTIFACTS | 36 | Artifacts are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_BOUNDING_BOXES | 43 | Bounding boxes are not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_CHAR_ENCODINGS | 23 | Character encodings are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_CHAR_PRINTING_CONDITION | 39 | Characterized printing condition is not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_CID_FONTS | 20 | CIDFonts are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_CMAPS | 62 | Font0 CMap is not compliant.
INCOMPLIANT_COLOR_DATA | 38 | Color data is not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_COLOR_SPACES | 10 | Color spaces are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_COMPOSITE_FONTS | 19 | Composite fonts are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_CONTENT_STREAM | 58 | Incompliant content stream.
INCOMPLIANT_CONTENT_STREAM_FILTER_IN_INLINE_IMAGE | 59 | Incompliant inline image encoding (LZW is prohibited).
INCOMPLIANT_CONTENT_STREAM_UNDEFINED_OPERATOR | 60 | Operators not defined in PDF Reference used on page content stream.
INCOMPLIANT_CONTENT_STREAM_UNDEFINED_RENDERING_INTENT | 61 | Rendering intent not defined in PDF Reference used in content stream.
INCOMPLIANT_DEVICE_COLOR_SPACES | 12 | Not compliant uncalibrated color spaces. Reported by PDF/A compliance verifier.
INCOMPLIANT_DOCINFO | 32 | Mismatch between document information dictionary and XMP metadata. Reported by PDF/A compliance verifier.
INCOMPLIANT_DOCUMENT | 1 | Document is not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_EMBEDDED_FILES | 7 | Embedded files are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_ENCRYPTION | 44 | Encryption is not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_EXTGSTATE | 17 | Extended graphics state is not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FILE_HEADER | 4 | File header is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_FILE_IDENTIFICATION | 42 | PDF file identification is not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_FILE_SPEC | 40 | File specifications are not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_FILE_STRUCTURE | 3 | File structure is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_FILE_TRAILER | 5 | File trailer is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_FILTERS | 6 | Document contains non-compliant filters. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FONTS | 18 | Fonts are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FONTS_METRICS | 63 | Fonts metrics are not compliant.
INCOMPLIANT_FONTS_SUBSETS | 22 | Fonts subsets are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_FORMS | 15 | Form XObjects are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_GRAPHICS | 9 | Graphics is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_ICC_COLOR_SPACES | 11 | Not compliant ICCBased color spaces. Reported by PDF/A compliance verifier.
INCOMPLIANT_IDENTIFICATION_SCHEMA | 33 | PDF/A identification schema is missing or incompliant with namespace URI %%. Reported by PDF/A compliance verifier.
INCOMPLIANT_IMAGES | 14 | Images are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_INDIRECT_OBJECTS | 52 | Indirect object syntax is not compliant.
INCOMPLIANT_INTERACTIVE_FORMS | 37 | Interactive forms are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_LOGICAL_STRUCTURE | 34 | Logical structure is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_METADATA | 31 | Metadata is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_MULT_ANNOTATIONS | 27 | Multimedia annotations are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_NOT_EMBEDDED_FONTS | 21 | Not embedded font programs are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_OPTIONAL_CONTENT | 8 | Optional content is not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_OUTPUT_INTENT | 49 | Output intent is not compliant.
INCOMPLIANT_PAGE | 2 | Page is not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_POSTSCRIPT | 16 | PostScript XObjects are not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_SPECIAL_COLOR_SPACES | 13 | Not compliant Separation/DeviceN color spaces. Reported by PDF/A compliance verifier.
INCOMPLIANT_STREAM_WITH_EXTERNAL_FDECODEPARMS | 48 | Stream object is not compliant. External streams are not allowed.
INCOMPLIANT_STREAM_WITH_EXTERNAL_FFILTER | 47 | Stream object is not compliant. External streams are not allowed.
INCOMPLIANT_STREAM_WITH_EXTERNAL_FILE | 46 | Stream object is not compliant. External streams are not allowed.
INCOMPLIANT_TAGGED_PDF | 35 | Document doesn't conform to the Tagged PDF conventions. Reported by PDF/A compliance verifier.
INCOMPLIANT_TRANSPARENCY | 25 | Transparency is not compliant. Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_TRAPPING | 41 | Trapping is not compliant. Reported by PDF/X compliance verifier.
INCOMPLIANT_TRIGGER_EVENTS | 30 | Trigger events are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_UCHAR_MAPS | 24 | Unicode character maps are not compliant. Reported by PDF/A compliance verifier.
INCOMPLIANT_VIEW_PREFERENCES | 45 | Viewer preferences are not compliant. Reported by PDF/X compliance verifier.
LIMITS_BIG_ARRAY | 54 | Array contains more than 8191 elements.
LIMITS_BIG_DICTIONARY | 64 | Dictionary with more than 4095 entries found.
LIMITS_BIG_INTEGER_CONT_STREAM | 56 | Integer value in content stream larger than 2^31-1.
LIMITS_BIG_INTEGER_DICT | 55 | Integer value in dictionary larger than 2^31-1.
LIMITS_BIG_NAME | 57 | Name with more than 127 bytes.
SUCCESS | 0 | Document or Page is compliant with the specified preflight profile. Reported by PDF/A and PDF/X compliance verifier.
WARNING_ACTION_EXISTS | 51 | Document contains an action. This warning is temporary, until full action detection is implemented.
WARNING_FONT_EXISTS | 50 | Document contains a font. This warning is temporary, until full font detection is implemented.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPreflightReportCodes

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFPreflightStatusCode Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFPreflightStatusCode Enumeration
ImGearPDFPreflightStatusCode defines PDF preflight conversion result code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFPreflightStatusCode
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFPreflightStatusCode
public enum ImGearPDFPreflightStatusCode : System.Enum
__value public enum ImGearPDFPreflightStatusCode : public System.Enum
public enum class ImGearPDFPreflightStatusCode : public System.Enum
Members
Member | Value | Description
Failed | 3 | IG tried to fix this error, but the fix was failed.
Fixable | 2 | This error can be fixed.
Fixed | 0 | IG fixed this error.
Unfixable | 4 | This error cannot be fixed in any case.
Warning | 1 | IG found that this file contains an element that cannot be fully tested in the current version.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFPreflightStatusCode

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFRevision Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFRevision Enumeration
Specifies Acrobat revision numbers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFRevision
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFRevision
public enum ImGearPDFRevision : System.Enum
__value public enum ImGearPDFRevision : public System.Enum
public enum class ImGearPDFRevision : public System.Enum
Members
Member | Value | Description
REVISION_2 | 2 | Support by Acrobat 3.0 and up.
REVISION_3 | 3 | Support by Acrobat 5.0 and up.
REVISION_4 | 4 | Support by Acrobat 6.0 and up.
REVISION_5 | 5 | Support by Acrobat 9.0 and up.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFRevision

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSaveFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSaveFlags Enumeration
Specifies save flags for PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFSaveFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFSaveFlags
public enum ImGearPDFSaveFlags : System.Enum
__value public enum ImGearPDFSaveFlags : public System.Enum
public enum class ImGearPDFSaveFlags : public System.Enum
Members
Member | Value | Description
ADD_FLATE | 0x00100000 | Encode any unencoded stream with Flate, except for metadata streams, which are never encoded, and for streams that would be larger if encoded.
BINARY_OK | 0x00000010 | Not currently supported.
COLLECT_GARBAGE | 0x00000020 | Remove unreferenced objects, often reducing file size. This flag can only be specified if FULL is also used.
COMPRESS_STRUCTURE_ONLY | 0x00040000 | Compress only those objects that are related to logical structure (for example, tagged PDF).
COMPRESSED | 0x00020000 | Compress objects, without restrictions about which objects to compress.
COPY | 0x00000002 | Not currently supported.
DO_NOT_SAVE_FILE_ATTRIBUTES | 0x00010000 | Do not save the new file output with the file attributes of the original.
FORCE_INCREMENTAL | 0x00000040 | Not currently supported.
FULL | 0x00000001 | Not currently supported.
INCREMENTAL | 0x00000000 | Not currently supported.
KEEP_MODDATE | 0x00000080 | Not currently supported.
LINEARIZED | 0x00000004 | Linearize for page-served remote access. This flag can only be specified if FULL is also used. During linearization, all objects in the PDF file are usually renumbered.
OPTIMIZE_CONTENT_STREAMS | 0x00800000 | Look for common initial sub-sequences among content streams (the sequences of marking operators), and generate substreams that can be shared (it causes OptimizeGraphics() to be called).
OPTIMIZE_FONTS | 0x01000000 | Merge identical font descriptors and encodings. Does not merge the top-level font dictionary.
OPTIMIZE_XOBJECTS | 0x00400000 | Merge identical forms and images, as determined by an MD5 hash of their contents.
REMOVE_ASCII_FILTERS | 0x00080000 | Remove ASCII85 filters from all streams.
REPLACE_LZW | 0x00200000 | Replace all LZW filters with FlateEncode filters.
UNCOMPRESSED | 0x20000000 | Do not use any stream compression (decompress all).
WITH_PS_HEADER | 0x00000008 | Not currently supported.
Remarks
All undefined flags should be set to zero. If either COLLECT_GARBAGE or COPY are used, FULL must be used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFSaveFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSecurityInfoFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSecurityInfoFlags Enumeration
Specifies flags for various information about the security and permissions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFSecurityInfoFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFSecurityInfoFlags
public enum ImGearPDFSecurityInfoFlags : System.Enum
__value public enum ImGearPDFSecurityInfoFlags : public System.Enum
public enum class ImGearPDFSecurityInfoFlags : public System.Enum
Members
Member | Value | Description
CAN_COPY | 0x00000010 | The document text and graphics can be copied to the clipboard.
CAN_EDIT | 0x00000008 | The document can be modified, for example by adding notes, links, or bookmarks.
CAN_PRINT | 0x00000004 | The document can be printed.
HAS_OWNER_PW | 0x00000002 | The document has an owner password.
HAS_USER_PW | 0x00000001 | The document has a user password.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFSecurityInfoFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSmoothFlags Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSmoothFlags Enumeration
Specifies how a page is rendered (bit flags).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFSmoothFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFSmoothFlags
public enum ImGearPDFSmoothFlags : System.Enum
__value public enum ImGearPDFSmoothFlags : public System.Enum
public enum class ImGearPDFSmoothFlags : public System.Enum
Members
Member | Value | Description
ENHANCE_THIN_LINES | 0x00000008 | Enhance thin lines rendering.
NONE | 0x00000000 | No flags specified.
SMOOTH_IMAGE | 0x00000004 | Draw smooth image.
SMOOTH_LINE_ART | 0x00000002 | Draw smooth line art.
SMOOTH_TEXT | 0x00000001 | Draw smooth text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFSmoothFlags

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFStdSecurityMethod Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStdSecurityMethod Enumeration
Specifies standard security algorithms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFStdSecurityMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFStdSecurityMethod
public enum ImGearPDFStdSecurityMethod : System.Enum
__value public enum ImGearPDFStdSecurityMethod : public System.Enum
public enum class ImGearPDFStdSecurityMethod : public System.Enum
Members
Member | Value | Description
AES_V1 | 5 | AES algorithm for encryption with a zero initialized iv.
AES_V2 | 6 | AES algorithm for encryption with a random initialized iv.
AES_V3 | 7 | AES algorithm for encryption with a 4 byte random iv.
RC4_V1 | 0 | RC4 algorithm for encryption.
RC4_V2 | 2 | RC4 algorithm for encryption.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFStdSecurityMethod

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFTextEncoding Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFTextEncoding Enumeration
Specifies PDF ASCII encoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFTextEncoding
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFTextEncoding
public enum ImGearPDFTextEncoding : System.Enum
__value public enum ImGearPDFTextEncoding : public System.Enum
public enum class ImGearPDFTextEncoding : public System.Enum
Members
Member | Value | Description
ASCII_85 | 2 | ASCII 85 encoding.
ASCII_HEX | 3 | ASCII HEX encoding.
NONE | 1 | No ASCII encoding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFTextEncoding

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFWordFinderVersion Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFWordFinderVersion Enumeration
Specifies word finder algorithm versions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPDFWordFinderVersion
   Inherits System.Enum
'Usage

Dim instance As ImGearPDFWordFinderVersion
public enum ImGearPDFWordFinderVersion : System.Enum
__value public enum ImGearPDFWordFinderVersion : public System.Enum
public enum class ImGearPDFWordFinderVersion : public System.Enum
Members
Member | Value | Description
LATEST_VERSION | 0 | The latest version.
VERSION_2 | 2 | Compatible with Acrobat 3 and 4.
VERSION_3 | 3 | Compatible with Acrobat 5 w/o accessibility enabled. Includes improved word piecing algorithms.
VERSION_4 | 4 | Compatible with Acrobat 5 with accessibility enabled. Includes advanced word ordering algorithms.
Remarks
Use LATEST_VERSION if your client does not care.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPDFWordFinderVersion

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPSLevel Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPSLevel Enumeration
Specifies the PostScript language levels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPSLevel
   Inherits System.Enum
'Usage

Dim instance As ImGearPSLevel
public enum ImGearPSLevel : System.Enum
__value public enum ImGearPSLevel : public System.Enum
public enum class ImGearPSLevel : public System.Enum
Members
Member | Value | Description
LEVEL_1 | 1 | PS language level 1.
LEVEL_2 | 2 | PS language level 2.
LEVEL_3 | 3 | PS language level 3.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPSLevel

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPSType Enumeration

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPSType Enumeration
Specifies output PostScript types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPSType
   Inherits System.Enum
'Usage

Dim instance As ImGearPSType
public enum ImGearPSType : System.Enum
__value public enum ImGearPSType : public System.Enum
public enum class ImGearPSType : public System.Enum
Members
Member | Value | Description
EPS_EXTENDED_PREVIEW | 3 | EPS file with extended preview.
EPS_NO_PREVIEW | 1 | EPS file with no preview.
EPS_STANDARD_PREVIEW | 2 | EPS file with standard preview.
POSTSCRIPT | 0 | PostScript file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.PDF.ImGearPSType

See Also

Reference

ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDEClip.ImGearPDEClipEnumerate Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDEClip.ImGearPDEClipEnumerate Delegate
The clip object.
The user data.
Delegate for the clip enumeration procedure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearPDEClip.ImGearPDEClipEnumerate( _
   ByVal clip As ImGearPDEClip, _
   ByVal userData As Object _
) As Boolean
'Usage

Dim instance As New ImGearPDEClip.ImGearPDEClipEnumerate(AddressOf HandlerMethod)
public delegate bool ImGearPDEClip.ImGearPDEClipEnumerate(
   ImGearPDEClip clip,
   object userData
)
public: __gc __delegate bool ImGearPDEClip.ImGearPDEClipEnumerate(
   ImGearPDEClip* clip,
   Object* userData
)
public delegate bool ImGearPDEClip.ImGearPDEClipEnumerate(
   ImGearPDEClip^ clip,
   Object^ userData
)

Parameters

clip
The clip object.
userData
The user data.

Return Value

Boolean value.
See Also

Reference

ImGearPDEClip.ImGearPDEClipEnumerate Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFDocument.ImGearAuthProc Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFDocument.ImGearAuthProc Delegate
Secured PDF document.
Authorization data.
Delegate describing format of the authorization procedure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearPDFDocument.ImGearAuthProc( _
   ByVal document As ImGearPDFDocument, _
   ByVal authorizationData As Object _
) As Boolean
'Usage

Dim instance As New ImGearPDFDocument.ImGearAuthProc(AddressOf HandlerMethod)
public delegate bool ImGearPDFDocument.ImGearAuthProc(
   ImGearPDFDocument document,
   object authorizationData
)
public: __gc __delegate bool ImGearPDFDocument.ImGearAuthProc(
   ImGearPDFDocument* document,
   Object* authorizationData
)
public delegate bool ImGearPDFDocument.ImGearAuthProc(
   ImGearPDFDocument^ document,
   Object^ authorizationData
)

Parameters

document
Secured PDF document.
authorizationData
Authorization data.

Return Value

True if authorization succeeded; False otherwise.
See Also

Reference

ImGearPDFDocument.ImGearAuthProc Members
ImageGear.Formats.PDF Namespace
ImGearPDFDocument Class


%%PageItemTitle%%

ImGearPDFStream.ImGearPDFStreamCleanUp Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream.ImGearPDFStreamCleanUp Delegate
User data associated with the stream.
Delegate describing PDF stream clean up routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearPDFStream.ImGearPDFStreamCleanUp( _
   ByVal userData As Object _
)
'Usage

Dim instance As New ImGearPDFStream.ImGearPDFStreamCleanUp(AddressOf HandlerMethod)
public delegate void ImGearPDFStream.ImGearPDFStreamCleanUp(
   object userData
)
public: __gc __delegate void ImGearPDFStream.ImGearPDFStreamCleanUp(
   Object* userData
)
public delegate void ImGearPDFStream.ImGearPDFStreamCleanUp(
   Object^ userData
)

Parameters

userData
User data associated with the stream.
See Also

Reference

ImGearPDFStream.ImGearPDFStreamCleanUp Members
ImageGear.Formats.PDF Namespace
ImGearPDFStream Class


%%PageItemTitle%%

ImGearPDFStream.ImGearPDFStreamReader Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream.ImGearPDFStreamReader Delegate
Stream data buffer.
User data associated with the stream.
Delegate describing PDF stream reader.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearPDFStream.ImGearPDFStreamReader( _
   ByVal buffer() As Byte, _
   ByVal userData As Object _
) As Integer
'Usage

Dim instance As New ImGearPDFStream.ImGearPDFStreamReader(AddressOf HandlerMethod)
public delegate int ImGearPDFStream.ImGearPDFStreamReader(
   byte[] buffer,
   object userData
)
public: __gc __delegate int ImGearPDFStream.ImGearPDFStreamReader(
   byte[]* buffer,
   Object* userData
)
public delegate int ImGearPDFStream.ImGearPDFStreamReader(
   array<byte>^ buffer,
   Object^ userData
)

Parameters

buffer
Stream data buffer.
userData
User data associated with the stream.

Return Value

Data size.
See Also

Reference

ImGearPDFStream.ImGearPDFStreamReader Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFStream.ImGearPDFStreamWriter Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFStream.ImGearPDFStreamWriter Delegate
Stream data buffer.
User data associated with the stream.
Delegate describing PDF stream writer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearPDFStream.ImGearPDFStreamWriter( _
   ByVal buffer() As Byte, _
   ByVal userData As Object _
) As Integer
'Usage

Dim instance As New ImGearPDFStream.ImGearPDFStreamWriter(AddressOf HandlerMethod)
public delegate int ImGearPDFStream.ImGearPDFStreamWriter(
   byte[] buffer,
   object userData
)
public: __gc __delegate int ImGearPDFStream.ImGearPDFStreamWriter(
   byte[]* buffer,
   Object* userData
)
public delegate int ImGearPDFStream.ImGearPDFStreamWriter(
   array<byte>^ buffer,
   Object^ userData
)

Parameters

buffer
Stream data buffer.
userData
User data associated with the stream.

Return Value

Data size.
See Also

Reference

ImGearPDFStream.ImGearPDFStreamWriter Members
ImageGear.Formats.PDF Namespace


%%PageItemTitle%%

ImGearPDFSysFont.ImGearPDFSysFontEnumerate Delegate

ImageGear22.Formats.Pdf Assembly > ImageGear.Formats.PDF Namespace : ImGearPDFSysFont.ImGearPDFSysFontEnumerate Delegate
Currently enumerating system font.
User data.
Delegate describing system font enumeration routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearPDFSysFont.ImGearPDFSysFontEnumerate( _
   ByVal systemFont As ImGearPDFSysFont, _
   ByVal userData As Object _
) As Boolean
'Usage

Dim instance As New ImGearPDFSysFont.ImGearPDFSysFontEnumerate(AddressOf HandlerMethod)
public delegate bool ImGearPDFSysFont.ImGearPDFSysFontEnumerate(
   ImGearPDFSysFont systemFont,
   object userData
)
public: __gc __delegate bool ImGearPDFSysFont.ImGearPDFSysFontEnumerate(
   ImGearPDFSysFont* systemFont,
   Object* userData
)
public delegate bool ImGearPDFSysFont.ImGearPDFSysFontEnumerate(
   ImGearPDFSysFont^ systemFont,
   Object^ userData
)

Parameters

systemFont
Currently enumerating system font.
userData
User data.

Return Value

If false, enumeration breaks.
See Also

Reference

ImGearPDFSysFont.ImGearPDFSysFontEnumerate Members
ImageGear.Formats.PDF Namespace


ImageGear.Formats.PDF.ToSVG Namespace
Inheritance Hierarchy
ImageGear22.Formats.Pdf Assembly : ImageGear.Formats.PDF.ToSVG Namespace
See Also

Reference

ImageGear22.Formats.Pdf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.PDF.ToSVG Namespace Inheritance Hierarchy
ImageGear22.Formats.Pdf Assembly : ImageGear.Formats.PDF.ToSVG Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ImageGear22.Formats.Pdf Assembly


ImageGear22.Formats.SimplifiedMetadata Assembly
Namespaces
Namespace | Description
ImageGear.Formats | ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
ImageGear.Formats.EXIF | This namespace provides the API for operating with EXIF non-image data.
ImageGear.Formats.IPTC | This namespace contains classes, structures, and enumerations that provide simplified access to IPTC metadata.
ImageGear.Formats.TIF | This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.
ImageGear.Formats.XMP | This namespace provides the API for XMP format.
ImageGear.Formats.XMP.AdobePDF | This namespace provides the API for XMP.AdobePDF format.
ImageGear.Formats.XMP.Basic | This namespace provides the API for XMP.Basic format.
ImageGear.Formats.XMP.BasicJobTicket | This namespace provides the API for XMP.BasicJobTicket format.
ImageGear.Formats.XMP.CameraRaw | This namespace provides the API for XMP.CameraRaw format.
ImageGear.Formats.XMP.DublinCore | This namespace provides the API for XMP.DublinCore format.
ImageGear.Formats.XMP.DynamicMedia | This namespace provides the API for XMP.DynamicMedia format.
ImageGear.Formats.XMP.EXIF | This namespace provides the API for XMP.EXIF format.
ImageGear.Formats.XMP.EXIFAux | This namespace provides the API for XMP.EXIFAux format.
ImageGear.Formats.XMP.IPTC | This namespace provides the API for XMP.IPTC format.
ImageGear.Formats.XMP.MediaManagement | This namespace provides the API for XMP.MediaManagement format.
ImageGear.Formats.XMP.MicrosoftPhoto | This namespace provides the API for XMP.MicrosoftPhoto format.
ImageGear.Formats.XMP.PagedText | This namespace provides the API for XMP.PagedText format.
ImageGear.Formats.XMP.Photoshop | This namespace provides the API for XMP.Photoshop format.
ImageGear.Formats.XMP.RightsManagement | This namespace provides the API for XMP.RightsManagement format.
ImageGear.Formats.XMP.TIFF | This namespace provides the API for XMP.TIFF format.


ImageGear.Formats Namespace (ImageGear22.Formats.SimplifiedMetadata)
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats Namespace
ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.
Classes
 | Class | Description
Class | ImGearSimplifiedMetadata | Initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats Namespace (ImageGear22.Formats.SimplifiedMetadata) Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearSimplifiedMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearSimplifiedMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats Namespace : ImGearSimplifiedMetadata Class
Initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly.
Object Model
ImGearSimplifiedMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSimplifiedMetadata
'Usage

Dim instance As ImGearSimplifiedMetadata
public class ImGearSimplifiedMetadata
public __gc class ImGearSimplifiedMetadata
public ref class ImGearSimplifiedMetadata
Remarks
This class initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly. It adds formats that are implemented by the component to the ImageGear’s global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearSimplifiedMetadata

See Also

Reference

ImGearSimplifiedMetadata Members
ImageGear.Formats Namespace


%%PageItemTitle%% $$Members$$

ImGearSimplifiedMetadata Class Members
Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats Namespace : ImGearSimplifiedMetadata Class

The following tables list the members exposed by ImGearSimplifiedMetadata.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly.
Top
See Also

Reference

ImGearSimplifiedMetadata Class
ImageGear.Formats Namespace


%%PageItemTitle%% $$Methods$$

ImGearSimplifiedMetadata Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats Namespace : ImGearSimplifiedMetadata Class

For a list of all members of this type, see ImGearSimplifiedMetadata members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly.
Top
See Also

Reference

ImGearSimplifiedMetadata Class
ImageGear.Formats Namespace


Initialize Method (ImGearSimplifiedMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats Namespace > ImGearSimplifiedMetadata Class : Initialize Method
Initializes the ImageGear22.Formats.SimplifiedMetadata.dll assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize()
'Usage

ImGearSimplifiedMetadata.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
Remarks
This method initializes ImageGear22.Formats.SimplifiedMetadata.dll assembly. It adds formats that are implemented by the component to the ImageGear’s global formats list, enabling their detection, reading, and writing. For more information about initializing assemblies, see Assembly Initialization.
See Also

Reference

ImGearSimplifiedMetadata Class
ImGearSimplifiedMetadata Members


ImageGear.Formats.EXIF Namespace (ImageGear22.Formats.SimplifiedMetadata)
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.EXIF Namespace
This namespace provides the API for operating with EXIF non-image data.
Classes
 | Class | Description
Class | ImGearEXIFGPSMetadata | Provides simplified access to EXIF GPS metadata.
Class | ImGearEXIFInteropMetadata | Provides simplified access to EXIF Interoperability metadata.
Class | ImGearEXIFMetadata | Provides simplified access to EXIF metadata.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.EXIF Namespace (ImageGear22.Formats.SimplifiedMetadata) Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.EXIF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.EXIF.ImGearEXIFGPSMetadata
ImageGear.Formats.EXIF.ImGearEXIFInteropMetadata
ImageGear.Formats.EXIF.ImGearEXIFMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearEXIFGPSMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSMetadata Class
Provides simplified access to EXIF GPS metadata.
Object Model
ImGearEXIFGPSMetadata ClassImGearRationalUInt StructureImGearRationalUInt StructureImGearRationalUInt StructureImGearRationalUInt StructureImGearRationalUInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEXIFGPSMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearEXIFGPSMetadata
public class ImGearEXIFGPSMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearEXIFGPSMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearEXIFGPSMetadata : public ImageGear.Formats.ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.EXIF.ImGearEXIFGPSMetadata

See Also

Reference

ImGearEXIFGPSMetadata Members
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearEXIFGPSMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSMetadata Class

The following tables list the members exposed by ImGearEXIFGPSMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearEXIFGPSMetadata Constructor | Initializes a new instance of the ImGearEXIFGPSMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Altitude | Gets or sets Altitude Tag value.
Public Property | AltitudeReference | Gets or sets AltitudeReference Tag value.
Public Property | AreaInformation | Gets or sets AreaInformation Tag value.
Public Property | DateStamp | Gets or sets DateStamp Tag value.
Public Property | DestBearing | Gets or sets DestBearing Tag value.
Public Property | DestBearingReference | Gets or sets DestBearingReference Tag value.
Public Property | DestDistance | Gets or sets DestDistance Tag value.
Public Property | DestDistanceReference | Gets or sets DestDistanceReference Tag value.
Public Property | DestLatitude | Gets or sets DestLatitude Tag value.
Public Property | DestLatitudeReference | Gets or sets DestLatitudeReference Tag value.
Public Property | DestLongitude | Gets or sets DestLongitude Tag value.
Public Property | DestLongitudeReference | Gets or sets DestLongitudeReference Tag value.
Public Property | Differential | Gets or sets Differential Tag value.
Public Property | DOP | Gets or sets DOP Tag value.
Public Property | ImgDirection | Gets or sets ImgDirection Tag value.
Public Property | ImgDirectionReference | Gets or sets ImgDirectionReference Tag value.
Public Property | Latitude | Gets or sets Latitude Tag value.
Public Property | LatitudeReference | Gets or sets LatitudeReference Tag value.
Public Property | Longitude | Gets or sets Longitude Tag value.
Public Property | LongitudeReference | Gets or sets LongitudeReference Tag value.
Public Property | MapDatum | Gets or sets MapDatum Tag value.
Public Property | MeasureMode | Gets or sets MeasureMode Tag value.
Public Property | ProcessingMethod | Gets or sets ProcessingMethod Tag value.
Public Property | Satellites | Gets or sets Satellites Tag value.
Public Property | Speed | Gets or sets Speed Tag value.
Public Property | SpeedReference | Gets or sets SpeedReference Tag value.
Public Property | Status | Gets or sets Status Tag value.
Public Property | TimeStamp | Gets or sets TimeStamp Tag value.
Public Property | Track | Gets or sets Track Tag value.
Public Property | TrackReference | Gets or sets TrackReference Tag value.
Public Property | VersionID | Gets or sets VersionID Tag value.
Top
See Also

Reference

ImGearEXIFGPSMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : ImGearEXIFGPSMetadata Constructor
Initializes a new instance of the ImGearEXIFGPSMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEXIFGPSMetadata()
public ImGearEXIFGPSMetadata()
public: ImGearEXIFGPSMetadata();
public:
ImGearEXIFGPSMetadata();

Return Value

The new instance of ImGearEXIFGPSMetadata class.
See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearEXIFGPSMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFGPSMetadata Class

For a list of all members of this type, see ImGearEXIFGPSMetadata members.

Public Properties
 | Name | Description
Public Property | Altitude | Gets or sets Altitude Tag value.
Public Property | AltitudeReference | Gets or sets AltitudeReference Tag value.
Public Property | AreaInformation | Gets or sets AreaInformation Tag value.
Public Property | DateStamp | Gets or sets DateStamp Tag value.
Public Property | DestBearing | Gets or sets DestBearing Tag value.
Public Property | DestBearingReference | Gets or sets DestBearingReference Tag value.
Public Property | DestDistance | Gets or sets DestDistance Tag value.
Public Property | DestDistanceReference | Gets or sets DestDistanceReference Tag value.
Public Property | DestLatitude | Gets or sets DestLatitude Tag value.
Public Property | DestLatitudeReference | Gets or sets DestLatitudeReference Tag value.
Public Property | DestLongitude | Gets or sets DestLongitude Tag value.
Public Property | DestLongitudeReference | Gets or sets DestLongitudeReference Tag value.
Public Property | Differential | Gets or sets Differential Tag value.
Public Property | DOP | Gets or sets DOP Tag value.
Public Property | ImgDirection | Gets or sets ImgDirection Tag value.
Public Property | ImgDirectionReference | Gets or sets ImgDirectionReference Tag value.
Public Property | Latitude | Gets or sets Latitude Tag value.
Public Property | LatitudeReference | Gets or sets LatitudeReference Tag value.
Public Property | Longitude | Gets or sets Longitude Tag value.
Public Property | LongitudeReference | Gets or sets LongitudeReference Tag value.
Public Property | MapDatum | Gets or sets MapDatum Tag value.
Public Property | MeasureMode | Gets or sets MeasureMode Tag value.
Public Property | ProcessingMethod | Gets or sets ProcessingMethod Tag value.
Public Property | Satellites | Gets or sets Satellites Tag value.
Public Property | Speed | Gets or sets Speed Tag value.
Public Property | SpeedReference | Gets or sets SpeedReference Tag value.
Public Property | Status | Gets or sets Status Tag value.
Public Property | TimeStamp | Gets or sets TimeStamp Tag value.
Public Property | Track | Gets or sets Track Tag value.
Public Property | TrackReference | Gets or sets TrackReference Tag value.
Public Property | VersionID | Gets or sets VersionID Tag value.
Top
See Also

Reference

ImGearEXIFGPSMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFGPSMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : ImGearEXIFGPSMetadata Constructor
Overload List
Overload | Description
ImGearEXIFGPSMetadata Constructor | Initializes a new instance of the ImGearEXIFGPSMetadata class.
See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


Altitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Altitude Property
Gets or sets Altitude Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Altitude As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.Altitude = value

value = instance.Altitude
public Nullable<ImGearRationalUInt> Altitude {get; set;}
public: __property Nullable<ImGearRationalUInt> get_Altitude();
public: __property void set_Altitude(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> Altitude {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

Get accessor returns the tag value, if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


AltitudeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : AltitudeReference Property
Gets or sets AltitudeReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AltitudeReference As Nullable(Of ImGearEXIFGPSAltitudeReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSAltitudeReference)

instance.AltitudeReference = value

value = instance.AltitudeReference
public Nullable<ImGearEXIFGPSAltitudeReference> AltitudeReference {get; set;}
public: __property Nullable<ImGearEXIFGPSAltitudeReference> get_AltitudeReference();
public: __property void set_AltitudeReference(
   Nullable<ImGearEXIFGPSAltitudeReference> value
);
public:
property Nullable<ImGearEXIFGPSAltitudeReference> AltitudeReference {
   Nullable<ImGearEXIFGPSAltitudeReference> get();
   void set (    Nullable<ImGearEXIFGPSAltitudeReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSAltitudeReference enumeration value.
Remarks
This property accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree; adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSAltitudeReference Enumeration


AreaInformation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : AreaInformation Property
Gets or sets AreaInformation Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AreaInformation As Byte()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As Byte

instance.AreaInformation = value

value = instance.AreaInformation
public byte[] AreaInformation {get; set;}
public: __property byte[]* get_AreaInformation();
public: __property void set_AreaInformation(
   byte[]* value
);
public:
property array<byte>^ AreaInformation {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


DateStamp Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DateStamp Property
Gets or sets DateStamp Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateStamp As String
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As String

instance.DateStamp = value

value = instance.DateStamp
public string DateStamp {get; set;}
public: __property string* get_DateStamp();
public: __property void set_DateStamp(
   string* value
);
public:
property String^ DateStamp {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


DestBearing Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestBearing Property
Gets or sets DestBearing Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestBearing As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.DestBearing = value

value = instance.DestBearing
public Nullable<ImGearRationalUInt> DestBearing {get; set;}
public: __property Nullable<ImGearRationalUInt> get_DestBearing();
public: __property void set_DestBearing(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> DestBearing {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


DestBearingReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestBearingReference Property
Gets or sets DestBearingReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestBearingReference As Nullable(Of ImGearEXIFGPSDirectionReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSDirectionReference)

instance.DestBearingReference = value

value = instance.DestBearingReference
public Nullable<ImGearEXIFGPSDirectionReference> DestBearingReference {get; set;}
public: __property Nullable<ImGearEXIFGPSDirectionReference> get_DestBearingReference();
public: __property void set_DestBearingReference(
   Nullable<ImGearEXIFGPSDirectionReference> value
);
public:
property Nullable<ImGearEXIFGPSDirectionReference> DestBearingReference {
   Nullable<ImGearEXIFGPSDirectionReference> get();
   void set (    Nullable<ImGearEXIFGPSDirectionReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value.
Remarks
This property accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSDirectionReference Enumeration


DestDistance Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestDistance Property
Gets or sets DestDistance Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestDistance As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.DestDistance = value

value = instance.DestDistance
public Nullable<ImGearRationalUInt> DestDistance {get; set;}
public: __property Nullable<ImGearRationalUInt> get_DestDistance();
public: __property void set_DestDistance(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> DestDistance {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


DestDistanceReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestDistanceReference Property
Gets or sets DestDistanceReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestDistanceReference As Nullable(Of ImGearEXIFGPSDistanceReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSDistanceReference)

instance.DestDistanceReference = value

value = instance.DestDistanceReference
public Nullable<ImGearEXIFGPSDistanceReference> DestDistanceReference {get; set;}
public: __property Nullable<ImGearEXIFGPSDistanceReference> get_DestDistanceReference();
public: __property void set_DestDistanceReference(
   Nullable<ImGearEXIFGPSDistanceReference> value
);
public:
property Nullable<ImGearEXIFGPSDistanceReference> DestDistanceReference {
   Nullable<ImGearEXIFGPSDistanceReference> get();
   void set (    Nullable<ImGearEXIFGPSDistanceReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSDistanceReference enumeration value.
Remarks
This property accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSDistanceReference Enumeration


DestLatitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestLatitude Property
Gets or sets DestLatitude Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestLatitude As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As ImGearRationalUInt

instance.DestLatitude = value

value = instance.DestLatitude
public ImGearRationalUInt[] DestLatitude {get; set;}
public: __property ImGearRationalUInt[]* get_DestLatitude();
public: __property void set_DestLatitude(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ DestLatitude {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


DestLatitudeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestLatitudeReference Property
Gets or sets DestLatitudeReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestLatitudeReference As Nullable(Of ImGearEXIFGPSLatitudeReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSLatitudeReference)

instance.DestLatitudeReference = value

value = instance.DestLatitudeReference
public Nullable<ImGearEXIFGPSLatitudeReference> DestLatitudeReference {get; set;}
public: __property Nullable<ImGearEXIFGPSLatitudeReference> get_DestLatitudeReference();
public: __property void set_DestLatitudeReference(
   Nullable<ImGearEXIFGPSLatitudeReference> value
);
public:
property Nullable<ImGearEXIFGPSLatitudeReference> DestLatitudeReference {
   Nullable<ImGearEXIFGPSLatitudeReference> get();
   void set (    Nullable<ImGearEXIFGPSLatitudeReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.
Remarks
This property accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSLatitudeReference Enumeration


DestLongitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestLongitude Property
Gets or sets DestLongitude Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestLongitude As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As ImGearRationalUInt

instance.DestLongitude = value

value = instance.DestLongitude
public ImGearRationalUInt[] DestLongitude {get; set;}
public: __property ImGearRationalUInt[]* get_DestLongitude();
public: __property void set_DestLongitude(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ DestLongitude {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure array.
Remarks
This property accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


DestLongitudeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DestLongitudeReference Property
Gets or sets DestLongitudeReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestLongitudeReference As Nullable(Of ImGearEXIFGPSLongitudeReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSLongitudeReference)

instance.DestLongitudeReference = value

value = instance.DestLongitudeReference
public Nullable<ImGearEXIFGPSLongitudeReference> DestLongitudeReference {get; set;}
public: __property Nullable<ImGearEXIFGPSLongitudeReference> get_DestLongitudeReference();
public: __property void set_DestLongitudeReference(
   Nullable<ImGearEXIFGPSLongitudeReference> value
);
public:
property Nullable<ImGearEXIFGPSLongitudeReference> DestLongitudeReference {
   Nullable<ImGearEXIFGPSLongitudeReference> get();
   void set (    Nullable<ImGearEXIFGPSLongitudeReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.
Remarks
This property accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSLongitudeReference Enumeration


Differential Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Differential Property
Gets or sets Differential Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Differential As Nullable(Of ImGearEXIFGPSDifferential)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSDifferential)

instance.Differential = value

value = instance.Differential
public Nullable<ImGearEXIFGPSDifferential> Differential {get; set;}
public: __property Nullable<ImGearEXIFGPSDifferential> get_Differential();
public: __property void set_Differential(
   Nullable<ImGearEXIFGPSDifferential> value
);
public:
property Nullable<ImGearEXIFGPSDifferential> Differential {
   Nullable<ImGearEXIFGPSDifferential> get();
   void set (    Nullable<ImGearEXIFGPSDifferential> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSDifferential enumeration value.
Remarks
This property accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSDifferential Enumeration


DOP Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : DOP Property
Gets or sets DOP Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DOP As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.DOP = value

value = instance.DOP
public Nullable<ImGearRationalUInt> DOP {get; set;}
public: __property Nullable<ImGearRationalUInt> get_DOP();
public: __property void set_DOP(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> DOP {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


ImgDirection Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : ImgDirection Property
Gets or sets ImgDirection Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImgDirection As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.ImgDirection = value

value = instance.ImgDirection
public Nullable<ImGearRationalUInt> ImgDirection {get; set;}
public: __property Nullable<ImGearRationalUInt> get_ImgDirection();
public: __property void set_ImgDirection(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> ImgDirection {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


ImgDirectionReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : ImgDirectionReference Property
Gets or sets ImgDirectionReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImgDirectionReference As Nullable(Of ImGearEXIFGPSDirectionReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSDirectionReference)

instance.ImgDirectionReference = value

value = instance.ImgDirectionReference
public Nullable<ImGearEXIFGPSDirectionReference> ImgDirectionReference {get; set;}
public: __property Nullable<ImGearEXIFGPSDirectionReference> get_ImgDirectionReference();
public: __property void set_ImgDirectionReference(
   Nullable<ImGearEXIFGPSDirectionReference> value
);
public:
property Nullable<ImGearEXIFGPSDirectionReference> ImgDirectionReference {
   Nullable<ImGearEXIFGPSDirectionReference> get();
   void set (    Nullable<ImGearEXIFGPSDirectionReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value.
Remarks
This property accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSDirectionReference Enumeration


Latitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Latitude Property
Gets or sets Latitude Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Latitude As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As ImGearRationalUInt

instance.Latitude = value

value = instance.Latitude
public ImGearRationalUInt[] Latitude {get; set;}
public: __property ImGearRationalUInt[]* get_Latitude();
public: __property void set_Latitude(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ Latitude {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


LatitudeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : LatitudeReference Property
Gets or sets LatitudeReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LatitudeReference As Nullable(Of ImGearEXIFGPSLatitudeReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSLatitudeReference)

instance.LatitudeReference = value

value = instance.LatitudeReference
public Nullable<ImGearEXIFGPSLatitudeReference> LatitudeReference {get; set;}
public: __property Nullable<ImGearEXIFGPSLatitudeReference> get_LatitudeReference();
public: __property void set_LatitudeReference(
   Nullable<ImGearEXIFGPSLatitudeReference> value
);
public:
property Nullable<ImGearEXIFGPSLatitudeReference> LatitudeReference {
   Nullable<ImGearEXIFGPSLatitudeReference> get();
   void set (    Nullable<ImGearEXIFGPSLatitudeReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.
Remarks
This property accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.
See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSLatitudeReference Enumeration


Longitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Longitude Property
Gets or sets Longitude Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Longitude As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As ImGearRationalUInt

instance.Longitude = value

value = instance.Longitude
public ImGearRationalUInt[] Longitude {get; set;}
public: __property ImGearRationalUInt[]* get_Longitude();
public: __property void set_Longitude(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ Longitude {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure array.
Remarks
This property accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


LongitudeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : LongitudeReference Property
Gets or sets LongitudeReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LongitudeReference As Nullable(Of ImGearEXIFGPSLongitudeReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSLongitudeReference)

instance.LongitudeReference = value

value = instance.LongitudeReference
public Nullable<ImGearEXIFGPSLongitudeReference> LongitudeReference {get; set;}
public: __property Nullable<ImGearEXIFGPSLongitudeReference> get_LongitudeReference();
public: __property void set_LongitudeReference(
   Nullable<ImGearEXIFGPSLongitudeReference> value
);
public:
property Nullable<ImGearEXIFGPSLongitudeReference> LongitudeReference {
   Nullable<ImGearEXIFGPSLongitudeReference> get();
   void set (    Nullable<ImGearEXIFGPSLongitudeReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.
Remarks
This property accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSLongitudeReference Enumeration


MapDatum Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : MapDatum Property
Gets or sets MapDatum Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MapDatum As String
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As String

instance.MapDatum = value

value = instance.MapDatum
public string MapDatum {get; set;}
public: __property string* get_MapDatum();
public: __property void set_MapDatum(
   string* value
);
public:
property String^ MapDatum {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


MeasureMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : MeasureMode Property
Gets or sets MeasureMode Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MeasureMode As Nullable(Of ImGearEXIFGPSMeasureMode)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSMeasureMode)

instance.MeasureMode = value

value = instance.MeasureMode
public Nullable<ImGearEXIFGPSMeasureMode> MeasureMode {get; set;}
public: __property Nullable<ImGearEXIFGPSMeasureMode> get_MeasureMode();
public: __property void set_MeasureMode(
   Nullable<ImGearEXIFGPSMeasureMode> value
);
public:
property Nullable<ImGearEXIFGPSMeasureMode> MeasureMode {
   Nullable<ImGearEXIFGPSMeasureMode> get();
   void set (    Nullable<ImGearEXIFGPSMeasureMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSMeasureMode enumeration value.
Remarks
This property accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSMeasureMode Enumeration


ProcessingMethod Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : ProcessingMethod Property
Gets or sets ProcessingMethod Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProcessingMethod As Byte()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As Byte

instance.ProcessingMethod = value

value = instance.ProcessingMethod
public byte[] ProcessingMethod {get; set;}
public: __property byte[]* get_ProcessingMethod();
public: __property void set_ProcessingMethod(
   byte[]* value
);
public:
property array<byte>^ ProcessingMethod {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


Satellites Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Satellites Property
Gets or sets Satellites Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Satellites As String
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As String

instance.Satellites = value

value = instance.Satellites
public string Satellites {get; set;}
public: __property string* get_Satellites();
public: __property void set_Satellites(
   string* value
);
public:
property String^ Satellites {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


Speed Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Speed Property
Gets or sets Speed Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Speed As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.Speed = value

value = instance.Speed
public Nullable<ImGearRationalUInt> Speed {get; set;}
public: __property Nullable<ImGearRationalUInt> get_Speed();
public: __property void set_Speed(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> Speed {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.
See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


SpeedReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : SpeedReference Property
Gets or sets SpeedReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpeedReference As Nullable(Of ImGearEXIFGPSSpeedReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSSpeedReference)

instance.SpeedReference = value

value = instance.SpeedReference
public Nullable<ImGearEXIFGPSSpeedReference> SpeedReference {get; set;}
public: __property Nullable<ImGearEXIFGPSSpeedReference> get_SpeedReference();
public: __property void set_SpeedReference(
   Nullable<ImGearEXIFGPSSpeedReference> value
);
public:
property Nullable<ImGearEXIFGPSSpeedReference> SpeedReference {
   Nullable<ImGearEXIFGPSSpeedReference> get();
   void set (    Nullable<ImGearEXIFGPSSpeedReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSSpeedReference enumeration value.
Remarks
This property accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSSpeedReference Enumeration


Status Property (ImGearEXIFGPSMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Status Property
Gets or sets Status Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Status As Nullable(Of ImGearEXIFGPSStatus)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSStatus)

instance.Status = value

value = instance.Status
public Nullable<ImGearEXIFGPSStatus> Status {get; set;}
public: __property Nullable<ImGearEXIFGPSStatus> get_Status();
public: __property void set_Status(
   Nullable<ImGearEXIFGPSStatus> value
);
public:
property Nullable<ImGearEXIFGPSStatus> Status {
   Nullable<ImGearEXIFGPSStatus> get();
   void set (    Nullable<ImGearEXIFGPSStatus> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSStatus enumeration value.
Remarks
This property accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSStatus Enumeration


TimeStamp Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : TimeStamp Property
Gets or sets TimeStamp Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeStamp As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As ImGearRationalUInt

instance.TimeStamp = value

value = instance.TimeStamp
public ImGearRationalUInt[] TimeStamp {get; set;}
public: __property ImGearRationalUInt[]* get_TimeStamp();
public: __property void set_TimeStamp(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ TimeStamp {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure array.
Remarks
This property accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


Track Property (ImGearEXIFGPSMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : Track Property
Gets or sets Track Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Track As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.Track = value

value = instance.Track
public Nullable<ImGearRationalUInt> Track {get; set;}
public: __property Nullable<ImGearRationalUInt> get_Track();
public: __property void set_Track(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> Track {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearRationalUInt Structure


TrackReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : TrackReference Property
Gets or sets TrackReference Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TrackReference As Nullable(Of ImGearEXIFGPSDirectionReference)
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value As Nullable(Of ImGearEXIFGPSDirectionReference)

instance.TrackReference = value

value = instance.TrackReference
public Nullable<ImGearEXIFGPSDirectionReference> TrackReference {get; set;}
public: __property Nullable<ImGearEXIFGPSDirectionReference> get_TrackReference();
public: __property void set_TrackReference(
   Nullable<ImGearEXIFGPSDirectionReference> value
);
public:
property Nullable<ImGearEXIFGPSDirectionReference> TrackReference {
   Nullable<ImGearEXIFGPSDirectionReference> get();
   void set (    Nullable<ImGearEXIFGPSDirectionReference> value);
}

Property Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value.
Remarks
This property accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members
ImGearEXIFGPSDirectionReference Enumeration


VersionID Property (ImGearEXIFGPSMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFGPSMetadata Class : VersionID Property
Gets or sets VersionID Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VersionID As Byte()
'Usage

Dim instance As ImGearEXIFGPSMetadata
Dim value() As Byte

instance.VersionID = value

value = instance.VersionID
public byte[] VersionID {get; set;}
public: __property byte[]* get_VersionID();
public: __property void set_VersionID(
   byte[]* value
);
public:
property array<byte>^ VersionID {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

ImGearEXIFInteropMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFInteropMetadata Class
Provides simplified access to EXIF Interoperability metadata.
Object Model
ImGearEXIFInteropMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEXIFInteropMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearEXIFInteropMetadata
public class ImGearEXIFInteropMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearEXIFInteropMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearEXIFInteropMetadata : public ImageGear.Formats.ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.EXIF.ImGearEXIFInteropMetadata

See Also

Reference

ImGearEXIFInteropMetadata Members
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearEXIFInteropMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFInteropMetadata Class

The following tables list the members exposed by ImGearEXIFInteropMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearEXIFInteropMetadata Constructor | Initializes a new instance of the ImGearEXIFInteropMetadata class.
Top
Public Properties
 | Name | Description
Public Property | InteroperabilityIndex | Gets or sets InteroperabilityIndex Tag value.
Public Property | InteroperabilityVersion | Gets or sets InteroperabilityVersion Tag value.
Public Property | RelatedImageFileFormat | Gets or sets RelatedImageFileFormat Tag value.
Public Property | RelatedImageLength | Gets or sets RelatedImageLength Tag value.
Public Property | RelatedImageWidth | Gets or sets RelatedImageWidth Tag value.
Top
See Also

Reference

ImGearEXIFInteropMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFInteropMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : ImGearEXIFInteropMetadata Constructor
Initializes a new instance of the ImGearEXIFInteropMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEXIFInteropMetadata()
public ImGearEXIFInteropMetadata()
public: ImGearEXIFInteropMetadata();
public:
ImGearEXIFInteropMetadata();

Return Value

The new instance of ImGearEXIFInteropMetadata class.
See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearEXIFInteropMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFInteropMetadata Class

For a list of all members of this type, see ImGearEXIFInteropMetadata members.

Public Properties
 | Name | Description
Public Property | InteroperabilityIndex | Gets or sets InteroperabilityIndex Tag value.
Public Property | InteroperabilityVersion | Gets or sets InteroperabilityVersion Tag value.
Public Property | RelatedImageFileFormat | Gets or sets RelatedImageFileFormat Tag value.
Public Property | RelatedImageLength | Gets or sets RelatedImageLength Tag value.
Public Property | RelatedImageWidth | Gets or sets RelatedImageWidth Tag value.
Top
See Also

Reference

ImGearEXIFInteropMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFInteropMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : ImGearEXIFInteropMetadata Constructor
Overload List
Overload | Description
ImGearEXIFInteropMetadata Constructor | Initializes a new instance of the ImGearEXIFInteropMetadata class.
See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


InteroperabilityIndex Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : InteroperabilityIndex Property
Gets or sets InteroperabilityIndex Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteroperabilityIndex As String
'Usage

Dim instance As ImGearEXIFInteropMetadata
Dim value As String

instance.InteroperabilityIndex = value

value = instance.InteroperabilityIndex
public string InteroperabilityIndex {get; set;}
public: __property string* get_InteroperabilityIndex();
public: __property void set_InteroperabilityIndex(
   string* value
);
public:
property String^ InteroperabilityIndex {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


InteroperabilityVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : InteroperabilityVersion Property
Gets or sets InteroperabilityVersion Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteroperabilityVersion As Byte()
'Usage

Dim instance As ImGearEXIFInteropMetadata
Dim value() As Byte

instance.InteroperabilityVersion = value

value = instance.InteroperabilityVersion
public byte[] InteroperabilityVersion {get; set;}
public: __property byte[]* get_InteroperabilityVersion();
public: __property void set_InteroperabilityVersion(
   byte[]* value
);
public:
property array<byte>^ InteroperabilityVersion {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the InteroperabilityVersion tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


RelatedImageFileFormat Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : RelatedImageFileFormat Property
Gets or sets RelatedImageFileFormat Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelatedImageFileFormat As String
'Usage

Dim instance As ImGearEXIFInteropMetadata
Dim value As String

instance.RelatedImageFileFormat = value

value = instance.RelatedImageFileFormat
public string RelatedImageFileFormat {get; set;}
public: __property string* get_RelatedImageFileFormat();
public: __property void set_RelatedImageFileFormat(
   string* value
);
public:
property String^ RelatedImageFileFormat {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the RelatedImageFileFormat tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


RelatedImageLength Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : RelatedImageLength Property
Gets or sets RelatedImageLength Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelatedImageLength As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFInteropMetadata
Dim value As Nullable(Of UShort)

instance.RelatedImageLength = value

value = instance.RelatedImageLength
public Nullable<ushort> RelatedImageLength {get; set;}
public: __property Nullable<ushort> get_RelatedImageLength();
public: __property void set_RelatedImageLength(
   Nullable<ushort> value
);
public:
property Nullable<ushort> RelatedImageLength {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the RelatedImageLength tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


RelatedImageWidth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFInteropMetadata Class : RelatedImageWidth Property
Gets or sets RelatedImageWidth Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelatedImageWidth As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFInteropMetadata
Dim value As Nullable(Of UShort)

instance.RelatedImageWidth = value

value = instance.RelatedImageWidth
public Nullable<ushort> RelatedImageWidth {get; set;}
public: __property Nullable<ushort> get_RelatedImageWidth();
public: __property void set_RelatedImageWidth(
   Nullable<ushort> value
);
public:
property Nullable<ushort> RelatedImageWidth {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the RelatedImageWidth tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

ImGearEXIFMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFMetadata Class
Provides simplified access to EXIF metadata.
Object Model
ImGearEXIFMetadata ClassImGearEXIFGPSMetadata ClassImGearEXIFInteropMetadata ClassImGearRationalUInt StructureImGearRationalUInt StructureImGearRationalUInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEXIFMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearEXIFMetadata
public class ImGearEXIFMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearEXIFMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearEXIFMetadata : public ImageGear.Formats.ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.EXIF.ImGearEXIFMetadata

See Also

Reference

ImGearEXIFMetadata Members
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearEXIFMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFMetadata Class

The following tables list the members exposed by ImGearEXIFMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearEXIFMetadata Constructor | Initializes a new instance of the ImGearEXIFMetadata class.
Top
Public Properties
 | Name | Description
Public Property | ApertureValue | Gets or sets ApertureValue Tag value.
Public Property | Artist | Gets or sets Artist Tag value.
Public Property | BitsPerSample | Gets or sets BitsPerSample Tag value.
Public Property | BrightnessValue | Gets or sets BrightnessValue Tag value.
Public Property | CFAPattern | Gets or sets CFAPattern Tag value.
Public Property | ColorSpace | Gets or sets ColorSpace Tag value.
Public Property | ComponentsConfiguration | Gets or sets ComponentsConfiguration Tag value.
Public Property | CompressedBitsPerPixel | Gets or sets CompressedBitsPerPixel Tag value.
Public Property | Compression | Gets or sets Compression Tag value.
Public Property | Contrast | Gets or sets Contrast Tag value.
Public Property | Copyright | Gets or sets Copyright Tag value.
Public Property | CustomRendered | Gets or sets CustomRendered Tag value.
Public Property | DateTime | Gets or sets DateTime Tag value.
Public Property | DateTimeDigitized | Gets or sets DateTimeDigitized Tag value.
Public Property | DateTimeOriginal | Gets or sets DateTimeOriginal Tag value.
Public Property | DeviceSettingDescription | Gets or sets DeviceSettingDescription Tag value.
Public Property | DigitalZoomRatio | Gets or sets DigitalZoomRatio Tag value.
Public Property | ExifVersion | Gets or sets ExifVersion Tag value.
Public Property | ExposureBiasValue | Gets or sets ExposureBiasValue Tag value.
Public Property | ExposureIndex | Gets or sets ExposureIndex Tag value.
Public Property | ExposureMode | Gets or sets ExposureMode Tag value.
Public Property | ExposureProgram | Gets or sets ExposureProgram Tag value.
Public Property | ExposureTime | Gets or sets ExposureTime Tag value.
Public Property | FileSource | Gets or sets FileSource Tag value.
Public Property | Flash | Gets or sets Flash Tag value.
Public Property | FlashEnergy | Gets or sets FlashEnergy Tag value.
Public Property | FlashPixVersion | Gets or sets FlashPixVersion Tag value.
Public Property | FNumber | Gets or sets FNumber Tag value.
Public Property | FocalLength | Gets or sets FocalLength Tag value.
Public Property | FocalLengthIn35mmFilm | Gets or sets FocalLengthIn35mmFilm Tag value.
Public Property | FocalPlaneResolutionUnit | Gets or sets FocalPlaneResolutionUnit Tag value.
Public Property | FocalPlaneXResolution | Gets or sets FocalPlaneXResolution Tag value.
Public Property | FocalPlaneYResolution | Gets or sets FocalPlaneYResolution Tag value.
Public Property | GainControl | Gets or sets GainControl Tag value.
Public Property | GPS | Gets or sets GPS Tag value.
Public Property | ImageDescription | Gets or sets ImageDescription Tag value.
Public Property | ImageLength | Gets or sets ImageLength Tag value.
Public Property | ImageWidth | Gets or sets ImageWidth Tag value.
Public Property | InterColorProfile | Gets or sets InterColorProfile Tag value.
Public Property | Interoperability | Gets or sets Interoperability Tag value.
Public Property | ISOSpeedRatings | Gets or sets ISOSpeedRatings Tag value.
Public Property | JPEGInterchangeFormat | Gets or sets JPEGInterchangeFormat Tag value.
Public Property | JPEGInterchangeFormatLength | Gets or sets JPEGInterchangeFormatLength Tag value.
Public Property | LightSource | Gets or sets LightSource Tag value.
Public Property | Make | Gets or sets Make Tag value.
Public Property | MaxApertureValue | Gets or sets MaxApertureValue Tag value.
Public Property | MeteringMode | Gets or sets MeteringMode Tag value.
Public Property | Model | Gets or sets Model Tag value.
Public Property | OECF | Gets or sets OECF Tag value.
Public Property | Orientation | Gets or sets Orientation Tag value.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation Tag value.
Public Property | PixelXDimension | Gets or sets PixelXDimension Tag value.
Public Property | PixelYDimension | Gets or sets PixelYDimension Tag value.
Public Property | PlanarConfig | Gets or sets PlanarConfig Tag value.
Public Property | PrimaryChromaticities | Gets or sets PrimaryChromaticities Tag value.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite Tag value.
Public Property | RelatedSoundFile | Gets or sets RelatedSoundFile Tag value.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit Tag value.
Public Property | RowsPerStrip | Gets or sets RowsPerStrip Tag value.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel Tag value.
Public Property | Saturation | Gets or sets Saturation Tag value.
Public Property | SceneCaptureType | Gets or sets SceneCaptureType Tag value.
Public Property | SceneType | Gets or sets SceneType Tag value.
Public Property | SensingMethod | Gets or sets SensingMethod Tag value.
Public Property | Sharpness | Gets or sets Sharpness Tag value.
Public Property | ShutterSpeedValue | Gets or sets ShutterSpeedValue Tag value.
Public Property | Software | Gets or sets Software Tag value.
Public Property | SpatialFrequencyResponse | Gets or sets SpatialFrequencyResponse Tag value.
Public Property | SpectralSensitivity | Gets or sets SpectralSensitivity Tag value.
Public Property | StripByteCounts | Gets or sets StripByteCounts Tag value.
Public Property | StripOffsets | Gets or sets StripOffsets Tag value.
Public Property | SubjectArea | Gets or sets SubjectArea Tag value.
Public Property | SubjectDistance | Gets or sets SubjectDistance Tag value.
Public Property | SubjectDistanceRange | Gets or sets SubjectDistanceRange Tag value.
Public Property | SubjectLocation | Gets or sets SubjectLocation Tag value.
Public Property | SubSecTime | Gets or sets SubSecTime Tag value.
Public Property | SubSecTimeDigitized | Gets or sets SubSecTimeDigitized Tag value.
Public Property | SubSecTimeOriginal | Gets or sets SubSecTimeOriginal Tag value.
Public Property | TransferFunction | Gets or sets TransferFunction Tag value.
Public Property | UserComment | Gets or sets UserComment Tag value.
Public Property | WhiteBalance | Gets or sets WhiteBalance Tag value.
Public Property | WhitePoint | Gets or sets WhitePoint Tag value.
Public Property | XResolution | Gets or sets XResolution Tag value.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients Tag value.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning Tag value.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling Tag value.
Public Property | YResolution | Gets or sets YResolution Tag value.
Top
See Also

Reference

ImGearEXIFMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ImGearEXIFMetadata Constructor
Initializes a new instance of the ImGearEXIFMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEXIFMetadata()
public ImGearEXIFMetadata()
public: ImGearEXIFMetadata();
public:
ImGearEXIFMetadata();

Return Value

The new instance of ImGearEXIFMetadata class.
See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearEXIFMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace : ImGearEXIFMetadata Class

For a list of all members of this type, see ImGearEXIFMetadata members.

Public Properties
 | Name | Description
Public Property | ApertureValue | Gets or sets ApertureValue Tag value.
Public Property | Artist | Gets or sets Artist Tag value.
Public Property | BitsPerSample | Gets or sets BitsPerSample Tag value.
Public Property | BrightnessValue | Gets or sets BrightnessValue Tag value.
Public Property | CFAPattern | Gets or sets CFAPattern Tag value.
Public Property | ColorSpace | Gets or sets ColorSpace Tag value.
Public Property | ComponentsConfiguration | Gets or sets ComponentsConfiguration Tag value.
Public Property | CompressedBitsPerPixel | Gets or sets CompressedBitsPerPixel Tag value.
Public Property | Compression | Gets or sets Compression Tag value.
Public Property | Contrast | Gets or sets Contrast Tag value.
Public Property | Copyright | Gets or sets Copyright Tag value.
Public Property | CustomRendered | Gets or sets CustomRendered Tag value.
Public Property | DateTime | Gets or sets DateTime Tag value.
Public Property | DateTimeDigitized | Gets or sets DateTimeDigitized Tag value.
Public Property | DateTimeOriginal | Gets or sets DateTimeOriginal Tag value.
Public Property | DeviceSettingDescription | Gets or sets DeviceSettingDescription Tag value.
Public Property | DigitalZoomRatio | Gets or sets DigitalZoomRatio Tag value.
Public Property | ExifVersion | Gets or sets ExifVersion Tag value.
Public Property | ExposureBiasValue | Gets or sets ExposureBiasValue Tag value.
Public Property | ExposureIndex | Gets or sets ExposureIndex Tag value.
Public Property | ExposureMode | Gets or sets ExposureMode Tag value.
Public Property | ExposureProgram | Gets or sets ExposureProgram Tag value.
Public Property | ExposureTime | Gets or sets ExposureTime Tag value.
Public Property | FileSource | Gets or sets FileSource Tag value.
Public Property | Flash | Gets or sets Flash Tag value.
Public Property | FlashEnergy | Gets or sets FlashEnergy Tag value.
Public Property | FlashPixVersion | Gets or sets FlashPixVersion Tag value.
Public Property | FNumber | Gets or sets FNumber Tag value.
Public Property | FocalLength | Gets or sets FocalLength Tag value.
Public Property | FocalLengthIn35mmFilm | Gets or sets FocalLengthIn35mmFilm Tag value.
Public Property | FocalPlaneResolutionUnit | Gets or sets FocalPlaneResolutionUnit Tag value.
Public Property | FocalPlaneXResolution | Gets or sets FocalPlaneXResolution Tag value.
Public Property | FocalPlaneYResolution | Gets or sets FocalPlaneYResolution Tag value.
Public Property | GainControl | Gets or sets GainControl Tag value.
Public Property | GPS | Gets or sets GPS Tag value.
Public Property | ImageDescription | Gets or sets ImageDescription Tag value.
Public Property | ImageLength | Gets or sets ImageLength Tag value.
Public Property | ImageWidth | Gets or sets ImageWidth Tag value.
Public Property | InterColorProfile | Gets or sets InterColorProfile Tag value.
Public Property | Interoperability | Gets or sets Interoperability Tag value.
Public Property | ISOSpeedRatings | Gets or sets ISOSpeedRatings Tag value.
Public Property | JPEGInterchangeFormat | Gets or sets JPEGInterchangeFormat Tag value.
Public Property | JPEGInterchangeFormatLength | Gets or sets JPEGInterchangeFormatLength Tag value.
Public Property | LightSource | Gets or sets LightSource Tag value.
Public Property | Make | Gets or sets Make Tag value.
Public Property | MaxApertureValue | Gets or sets MaxApertureValue Tag value.
Public Property | MeteringMode | Gets or sets MeteringMode Tag value.
Public Property | Model | Gets or sets Model Tag value.
Public Property | OECF | Gets or sets OECF Tag value.
Public Property | Orientation | Gets or sets Orientation Tag value.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation Tag value.
Public Property | PixelXDimension | Gets or sets PixelXDimension Tag value.
Public Property | PixelYDimension | Gets or sets PixelYDimension Tag value.
Public Property | PlanarConfig | Gets or sets PlanarConfig Tag value.
Public Property | PrimaryChromaticities | Gets or sets PrimaryChromaticities Tag value.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite Tag value.
Public Property | RelatedSoundFile | Gets or sets RelatedSoundFile Tag value.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit Tag value.
Public Property | RowsPerStrip | Gets or sets RowsPerStrip Tag value.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel Tag value.
Public Property | Saturation | Gets or sets Saturation Tag value.
Public Property | SceneCaptureType | Gets or sets SceneCaptureType Tag value.
Public Property | SceneType | Gets or sets SceneType Tag value.
Public Property | SensingMethod | Gets or sets SensingMethod Tag value.
Public Property | Sharpness | Gets or sets Sharpness Tag value.
Public Property | ShutterSpeedValue | Gets or sets ShutterSpeedValue Tag value.
Public Property | Software | Gets or sets Software Tag value.
Public Property | SpatialFrequencyResponse | Gets or sets SpatialFrequencyResponse Tag value.
Public Property | SpectralSensitivity | Gets or sets SpectralSensitivity Tag value.
Public Property | StripByteCounts | Gets or sets StripByteCounts Tag value.
Public Property | StripOffsets | Gets or sets StripOffsets Tag value.
Public Property | SubjectArea | Gets or sets SubjectArea Tag value.
Public Property | SubjectDistance | Gets or sets SubjectDistance Tag value.
Public Property | SubjectDistanceRange | Gets or sets SubjectDistanceRange Tag value.
Public Property | SubjectLocation | Gets or sets SubjectLocation Tag value.
Public Property | SubSecTime | Gets or sets SubSecTime Tag value.
Public Property | SubSecTimeDigitized | Gets or sets SubSecTimeDigitized Tag value.
Public Property | SubSecTimeOriginal | Gets or sets SubSecTimeOriginal Tag value.
Public Property | TransferFunction | Gets or sets TransferFunction Tag value.
Public Property | UserComment | Gets or sets UserComment Tag value.
Public Property | WhiteBalance | Gets or sets WhiteBalance Tag value.
Public Property | WhitePoint | Gets or sets WhitePoint Tag value.
Public Property | XResolution | Gets or sets XResolution Tag value.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients Tag value.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning Tag value.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling Tag value.
Public Property | YResolution | Gets or sets YResolution Tag value.
Top
See Also

Reference

ImGearEXIFMetadata Class
ImageGear.Formats.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ImGearEXIFMetadata Constructor
Overload List
Overload | Description
ImGearEXIFMetadata Constructor | Initializes a new instance of the ImGearEXIFMetadata class.
See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ApertureValue Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ApertureValue Property
Gets or sets ApertureValue Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApertureValue As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.ApertureValue = value

value = instance.ApertureValue
public Nullable<ImGearRationalUInt> ApertureValue {get; set;}
public: __property Nullable<ImGearRationalUInt> get_ApertureValue();
public: __property void set_ApertureValue(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> ApertureValue {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


Artist Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Artist Property
Gets or sets Artist Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Artist As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.Artist = value

value = instance.Artist
public string Artist {get; set;}
public: __property string* get_Artist();
public: __property void set_Artist(
   string* value
);
public:
property String^ Artist {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Artist tag. The tag specifies the person who created the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


BitsPerSample Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : BitsPerSample Property
Gets or sets BitsPerSample Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerSample As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.BitsPerSample = value

value = instance.BitsPerSample
public ushort[] BitsPerSample {get; set;}
public: __property ushort[]* get_BitsPerSample();
public: __property void set_BitsPerSample(
   ushort[]* value
);
public:
property array<ushort>^ BitsPerSample {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the BitsPerSample tag. The tag specifies the number of bits per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


BrightnessValue Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : BrightnessValue Property
Gets or sets BrightnessValue Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BrightnessValue As Nullable(Of ImGearRationalInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalInt)

instance.BrightnessValue = value

value = instance.BrightnessValue
public Nullable<ImGearRationalInt> BrightnessValue {get; set;}
public: __property Nullable<ImGearRationalInt> get_BrightnessValue();
public: __property void set_BrightnessValue(
   Nullable<ImGearRationalInt> value
);
public:
property Nullable<ImGearRationalInt> BrightnessValue {
   Nullable<ImGearRationalInt> get();
   void set (    Nullable<ImGearRationalInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


CFAPattern Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : CFAPattern Property
Gets or sets CFAPattern Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CFAPattern As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.CFAPattern = value

value = instance.CFAPattern
public byte[] CFAPattern {get; set;}
public: __property byte[]* get_CFAPattern();
public: __property void set_CFAPattern(
   byte[]* value
);
public:
property array<byte>^ CFAPattern {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ColorSpace Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ColorSpace Property
Gets or sets ColorSpace Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As Nullable(Of ImGearEXIFColorSpace)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFColorSpace)

instance.ColorSpace = value

value = instance.ColorSpace
public Nullable<ImGearEXIFColorSpace> ColorSpace {get; set;}
public: __property Nullable<ImGearEXIFColorSpace> get_ColorSpace();
public: __property void set_ColorSpace(
   Nullable<ImGearEXIFColorSpace> value
);
public:
property Nullable<ImGearEXIFColorSpace> ColorSpace {
   Nullable<ImGearEXIFColorSpace> get();
   void set (    Nullable<ImGearEXIFColorSpace> value);
}

Property Value

Nullable (boxed) ImGearEXIFColorSpace enumeration value.
Remarks
This property accesses the ColorSpace tag. The tag specifies the color space information.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFColorSpace Enumeration


ComponentsConfiguration Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ComponentsConfiguration Property
Gets or sets ComponentsConfiguration Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ComponentsConfiguration As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.ComponentsConfiguration = value

value = instance.ComponentsConfiguration
public byte[] ComponentsConfiguration {get; set;}
public: __property byte[]* get_ComponentsConfiguration();
public: __property void set_ComponentsConfiguration(
   byte[]* value
);
public:
property array<byte>^ ComponentsConfiguration {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


CompressedBitsPerPixel Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : CompressedBitsPerPixel Property
Gets or sets CompressedBitsPerPixel Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressedBitsPerPixel As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.CompressedBitsPerPixel = value

value = instance.CompressedBitsPerPixel
public Nullable<ImGearRationalUInt> CompressedBitsPerPixel {get; set;}
public: __property Nullable<ImGearRationalUInt> get_CompressedBitsPerPixel();
public: __property void set_CompressedBitsPerPixel(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> CompressedBitsPerPixel {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


Compression Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Compression Property
Gets or sets Compression Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As Nullable(Of ImGearTIFFCompression)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFCompression)

instance.Compression = value

value = instance.Compression
public Nullable<ImGearTIFFCompression> Compression {get; set;}
public: __property Nullable<ImGearTIFFCompression> get_Compression();
public: __property void set_Compression(
   Nullable<ImGearTIFFCompression> value
);
public:
property Nullable<ImGearTIFFCompression> Compression {
   Nullable<ImGearTIFFCompression> get();
   void set (    Nullable<ImGearTIFFCompression> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFCompression enumeration value.
Remarks
This property accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFCompression Enumeration


Contrast Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Contrast Property
Gets or sets Contrast Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contrast As Nullable(Of ImGearEXIFContrastMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFContrastMode)

instance.Contrast = value

value = instance.Contrast
public Nullable<ImGearEXIFContrastMode> Contrast {get; set;}
public: __property Nullable<ImGearEXIFContrastMode> get_Contrast();
public: __property void set_Contrast(
   Nullable<ImGearEXIFContrastMode> value
);
public:
property Nullable<ImGearEXIFContrastMode> Contrast {
   Nullable<ImGearEXIFContrastMode> get();
   void set (    Nullable<ImGearEXIFContrastMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFContrastMode enumeration value.
Remarks
This property accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFContrastMode Enumeration


Copyright Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Copyright Property
Gets or sets Copyright Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Copyright As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.Copyright = value

value = instance.Copyright
public string Copyright {get; set;}
public: __property string* get_Copyright();
public: __property void set_Copyright(
   string* value
);
public:
property String^ Copyright {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Copyright tag. The tag specifies the copyright notice.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


CustomRendered Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : CustomRendered Property
Gets or sets CustomRendered Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomRendered As Nullable(Of ImGearEXIFCustomRendered)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFCustomRendered)

instance.CustomRendered = value

value = instance.CustomRendered
public Nullable<ImGearEXIFCustomRendered> CustomRendered {get; set;}
public: __property Nullable<ImGearEXIFCustomRendered> get_CustomRendered();
public: __property void set_CustomRendered(
   Nullable<ImGearEXIFCustomRendered> value
);
public:
property Nullable<ImGearEXIFCustomRendered> CustomRendered {
   Nullable<ImGearEXIFCustomRendered> get();
   void set (    Nullable<ImGearEXIFCustomRendered> value);
}

Property Value

Nullable (boxed) ImGearEXIFCustomRendered enumeration value.
Remarks
This property accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing.
See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFCustomRendered Enumeration


DateTime Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : DateTime Property
Gets or sets DateTime Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTime As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.DateTime = value

value = instance.DateTime
public string DateTime {get; set;}
public: __property string* get_DateTime();
public: __property void set_DateTime(
   string* value
);
public:
property String^ DateTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DateTime tag. The tag specifies the date and time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


DateTimeDigitized Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : DateTimeDigitized Property
Gets or sets DateTimeDigitized Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeDigitized As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.DateTimeDigitized = value

value = instance.DateTimeDigitized
public string DateTimeDigitized {get; set;}
public: __property string* get_DateTimeDigitized();
public: __property void set_DateTimeDigitized(
   string* value
);
public:
property String^ DateTimeDigitized {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


DateTimeOriginal Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : DateTimeOriginal Property
Gets or sets DateTimeOriginal Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeOriginal As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.DateTimeOriginal = value

value = instance.DateTimeOriginal
public string DateTimeOriginal {get; set;}
public: __property string* get_DateTimeOriginal();
public: __property void set_DateTimeOriginal(
   string* value
);
public:
property String^ DateTimeOriginal {
   String^ get();
   void set (    String^ value);
}

Property Value

System.DateTime value.
Remarks
This property accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


DeviceSettingDescription Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : DeviceSettingDescription Property
Gets or sets DeviceSettingDescription Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeviceSettingDescription As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.DeviceSettingDescription = value

value = instance.DeviceSettingDescription
public byte[] DeviceSettingDescription {get; set;}
public: __property byte[]* get_DeviceSettingDescription();
public: __property void set_DeviceSettingDescription(
   byte[]* value
);
public:
property array<byte>^ DeviceSettingDescription {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


DigitalZoomRatio Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : DigitalZoomRatio Property
Gets or sets DigitalZoomRatio Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DigitalZoomRatio As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.DigitalZoomRatio = value

value = instance.DigitalZoomRatio
public Nullable<ImGearRationalUInt> DigitalZoomRatio {get; set;}
public: __property Nullable<ImGearRationalUInt> get_DigitalZoomRatio();
public: __property void set_DigitalZoomRatio(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> DigitalZoomRatio {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


ExifVersion Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExifVersion Property
Gets or sets ExifVersion Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExifVersion As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.ExifVersion = value

value = instance.ExifVersion
public byte[] ExifVersion {get; set;}
public: __property byte[]* get_ExifVersion();
public: __property void set_ExifVersion(
   byte[]* value
);
public:
property array<byte>^ ExifVersion {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the ExifVersion tag. The tag specifies the version of this standard supported.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ExposureBiasValue Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExposureBiasValue Property
Gets or sets ExposureBiasValue Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureBiasValue As Nullable(Of ImGearRationalInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalInt)

instance.ExposureBiasValue = value

value = instance.ExposureBiasValue
public Nullable<ImGearRationalInt> ExposureBiasValue {get; set;}
public: __property Nullable<ImGearRationalInt> get_ExposureBiasValue();
public: __property void set_ExposureBiasValue(
   Nullable<ImGearRationalInt> value
);
public:
property Nullable<ImGearRationalInt> ExposureBiasValue {
   Nullable<ImGearRationalInt> get();
   void set (    Nullable<ImGearRationalInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


ExposureIndex Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExposureIndex Property
Gets or sets ExposureIndex Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureIndex As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.ExposureIndex = value

value = instance.ExposureIndex
public Nullable<ImGearRationalUInt> ExposureIndex {get; set;}
public: __property Nullable<ImGearRationalUInt> get_ExposureIndex();
public: __property void set_ExposureIndex(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> ExposureIndex {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


ExposureMode Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExposureMode Property
Gets or sets ExposureMode Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureMode As Nullable(Of ImGearEXIFExposureMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFExposureMode)

instance.ExposureMode = value

value = instance.ExposureMode
public Nullable<ImGearEXIFExposureMode> ExposureMode {get; set;}
public: __property Nullable<ImGearEXIFExposureMode> get_ExposureMode();
public: __property void set_ExposureMode(
   Nullable<ImGearEXIFExposureMode> value
);
public:
property Nullable<ImGearEXIFExposureMode> ExposureMode {
   Nullable<ImGearEXIFExposureMode> get();
   void set (    Nullable<ImGearEXIFExposureMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFExposureMode enumeration value.
Remarks
This property accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFExposureMode Enumeration


ExposureProgram Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExposureProgram Property
Gets or sets ExposureProgram Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureProgram As Nullable(Of ImGearEXIFExposureProgram)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFExposureProgram)

instance.ExposureProgram = value

value = instance.ExposureProgram
public Nullable<ImGearEXIFExposureProgram> ExposureProgram {get; set;}
public: __property Nullable<ImGearEXIFExposureProgram> get_ExposureProgram();
public: __property void set_ExposureProgram(
   Nullable<ImGearEXIFExposureProgram> value
);
public:
property Nullable<ImGearEXIFExposureProgram> ExposureProgram {
   Nullable<ImGearEXIFExposureProgram> get();
   void set (    Nullable<ImGearEXIFExposureProgram> value);
}

Property Value

Nullable (boxed) ImGearEXIFExposureProgram enumeration value.
Remarks
This property accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFExposureProgram Enumeration


ExposureTime Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ExposureTime Property
Gets or sets ExposureTime Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureTime As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.ExposureTime = value

value = instance.ExposureTime
public Nullable<ImGearRationalUInt> ExposureTime {get; set;}
public: __property Nullable<ImGearRationalUInt> get_ExposureTime();
public: __property void set_ExposureTime(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> ExposureTime {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


FileSource Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FileSource Property
Gets or sets FileSource Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileSource As Nullable(Of ImGearEXIFFileSource)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFFileSource)

instance.FileSource = value

value = instance.FileSource
public Nullable<ImGearEXIFFileSource> FileSource {get; set;}
public: __property Nullable<ImGearEXIFFileSource> get_FileSource();
public: __property void set_FileSource(
   Nullable<ImGearEXIFFileSource> value
);
public:
property Nullable<ImGearEXIFFileSource> FileSource {
   Nullable<ImGearEXIFFileSource> get();
   void set (    Nullable<ImGearEXIFFileSource> value);
}

Property Value

Nullable (boxed) ImGearEXIFFileSource enumeration value.
Remarks
This property accesses the FileSource tag. The tag indicates the image source.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFFileSource Enumeration


Flash Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Flash Property
Gets or sets Flash Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flash As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UShort)

instance.Flash = value

value = instance.Flash
public Nullable<ushort> Flash {get; set;}
public: __property Nullable<ushort> get_Flash();
public: __property void set_Flash(
   Nullable<ushort> value
);
public:
property Nullable<ushort> Flash {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Flash tag. This tag indicates the status of the flash when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


FlashEnergy Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FlashEnergy Property
Gets or sets FlashEnergy Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashEnergy As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.FlashEnergy = value

value = instance.FlashEnergy
public Nullable<ImGearRationalUInt> FlashEnergy {get; set;}
public: __property Nullable<ImGearRationalUInt> get_FlashEnergy();
public: __property void set_FlashEnergy(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> FlashEnergy {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


FlashPixVersion Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FlashPixVersion Property
Gets or sets FlashPixVersion Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashPixVersion As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.FlashPixVersion = value

value = instance.FlashPixVersion
public byte[] FlashPixVersion {get; set;}
public: __property byte[]* get_FlashPixVersion();
public: __property void set_FlashPixVersion(
   byte[]* value
);
public:
property array<byte>^ FlashPixVersion {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


FNumber Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FNumber Property
Gets or sets FNumber Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FNumber As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.FNumber = value

value = instance.FNumber
public Nullable<ImGearRationalUInt> FNumber {get; set;}
public: __property Nullable<ImGearRationalUInt> get_FNumber();
public: __property void set_FNumber(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> FNumber {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the FNumber tag. The tag specifies the F number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


FocalLength Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FocalLength Property
Gets or sets FocalLength Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalLength As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.FocalLength = value

value = instance.FocalLength
public Nullable<ImGearRationalUInt> FocalLength {get; set;}
public: __property Nullable<ImGearRationalUInt> get_FocalLength();
public: __property void set_FocalLength(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> FocalLength {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


FocalLengthIn35mmFilm Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FocalLengthIn35mmFilm Property
Gets or sets FocalLengthIn35mmFilm Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalLengthIn35mmFilm As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UShort)

instance.FocalLengthIn35mmFilm = value

value = instance.FocalLengthIn35mmFilm
public Nullable<ushort> FocalLengthIn35mmFilm {get; set;}
public: __property Nullable<ushort> get_FocalLengthIn35mmFilm();
public: __property void set_FocalLengthIn35mmFilm(
   Nullable<ushort> value
);
public:
property Nullable<ushort> FocalLengthIn35mmFilm {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


FocalPlaneResolutionUnit Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FocalPlaneResolutionUnit Property
Gets or sets FocalPlaneResolutionUnit Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneResolutionUnit As Nullable(Of ImGearTIFFResolutionUnit)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFResolutionUnit)

instance.FocalPlaneResolutionUnit = value

value = instance.FocalPlaneResolutionUnit
public Nullable<ImGearTIFFResolutionUnit> FocalPlaneResolutionUnit {get; set;}
public: __property Nullable<ImGearTIFFResolutionUnit> get_FocalPlaneResolutionUnit();
public: __property void set_FocalPlaneResolutionUnit(
   Nullable<ImGearTIFFResolutionUnit> value
);
public:
property Nullable<ImGearTIFFResolutionUnit> FocalPlaneResolutionUnit {
   Nullable<ImGearTIFFResolutionUnit> get();
   void set (    Nullable<ImGearTIFFResolutionUnit> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFResolutionUnit enumeration value.
Remarks
This property accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFResolutionUnit Enumeration


FocalPlaneXResolution Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FocalPlaneXResolution Property
Gets or sets FocalPlaneXResolution Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneXResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.FocalPlaneXResolution = value

value = instance.FocalPlaneXResolution
public Nullable<ImGearRationalUInt> FocalPlaneXResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_FocalPlaneXResolution();
public: __property void set_FocalPlaneXResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> FocalPlaneXResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


FocalPlaneYResolution Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : FocalPlaneYResolution Property
Gets or sets FocalPlaneYResolution Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneYResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.FocalPlaneYResolution = value

value = instance.FocalPlaneYResolution
public Nullable<ImGearRationalUInt> FocalPlaneYResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_FocalPlaneYResolution();
public: __property void set_FocalPlaneYResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> FocalPlaneYResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


GainControl Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : GainControl Property
Gets or sets GainControl Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GainControl As Nullable(Of ImGearEXIFGainControl)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFGainControl)

instance.GainControl = value

value = instance.GainControl
public Nullable<ImGearEXIFGainControl> GainControl {get; set;}
public: __property Nullable<ImGearEXIFGainControl> get_GainControl();
public: __property void set_GainControl(
   Nullable<ImGearEXIFGainControl> value
);
public:
property Nullable<ImGearEXIFGainControl> GainControl {
   Nullable<ImGearEXIFGainControl> get();
   void set (    Nullable<ImGearEXIFGainControl> value);
}

Property Value

Nullable (boxed) ImGearEXIFGainControl enumeration value.
Remarks
This property accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFGainControl Enumeration


GPS Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : GPS Property
Gets or sets GPS Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPS As ImGearEXIFGPSMetadata
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As ImGearEXIFGPSMetadata

instance.GPS = value

value = instance.GPS
public ImGearEXIFGPSMetadata GPS {get; set;}
public: __property ImGearEXIFGPSMetadata* get_GPS();
public: __property void set_GPS(
   ImGearEXIFGPSMetadata* value
);
public:
property ImGearEXIFGPSMetadata^ GPS {
   ImGearEXIFGPSMetadata^ get();
   void set (    ImGearEXIFGPSMetadata^ value);
}

Property Value

ImGearEXIFGPSMetadata class value.
Remarks
This property accesses the GPS IFD metadata.
See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFGPSMetadata Class


ImageDescription Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ImageDescription Property
Gets or sets ImageDescription Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageDescription As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.ImageDescription = value

value = instance.ImageDescription
public string ImageDescription {get; set;}
public: __property string* get_ImageDescription();
public: __property void set_ImageDescription(
   string* value
);
public:
property String^ ImageDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the ImageDescription tag. The tag describes the subject of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ImageLength Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ImageLength Property
Gets or sets ImageLength Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageLength As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.ImageLength = value

value = instance.ImageLength
public Nullable<uint> ImageLength {get; set;}
public: __property Nullable<uint> get_ImageLength();
public: __property void set_ImageLength(
   Nullable<uint> value
);
public:
property Nullable<uint> ImageLength {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ImageWidth Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ImageWidth Property
Gets or sets ImageWidth Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageWidth As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.ImageWidth = value

value = instance.ImageWidth
public Nullable<uint> ImageWidth {get; set;}
public: __property Nullable<uint> get_ImageWidth();
public: __property void set_ImageWidth(
   Nullable<uint> value
);
public:
property Nullable<uint> ImageWidth {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the ImageWidth tag. The tag specifies the number of pixels per row.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


InterColorProfile Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : InterColorProfile Property
Gets or sets InterColorProfile Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InterColorProfile As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.InterColorProfile = value

value = instance.InterColorProfile
public byte[] InterColorProfile {get; set;}
public: __property byte[]* get_InterColorProfile();
public: __property void set_InterColorProfile(
   byte[]* value
);
public:
property array<byte>^ InterColorProfile {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


Interoperability Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Interoperability Property
Gets or sets Interoperability Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Interoperability As ImGearEXIFInteropMetadata
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As ImGearEXIFInteropMetadata

instance.Interoperability = value

value = instance.Interoperability
public ImGearEXIFInteropMetadata Interoperability {get; set;}
public: __property ImGearEXIFInteropMetadata* get_Interoperability();
public: __property void set_Interoperability(
   ImGearEXIFInteropMetadata* value
);
public:
property ImGearEXIFInteropMetadata^ Interoperability {
   ImGearEXIFInteropMetadata^ get();
   void set (    ImGearEXIFInteropMetadata^ value);
}

Property Value

ImGearEXIFInteropMetadata class value.
Remarks
This property provides access to the EXIF Interoperability IFD metadata.
See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFInteropMetadata Class


ISOSpeedRatings Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ISOSpeedRatings Property
Gets or sets ISOSpeedRatings Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ISOSpeedRatings As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.ISOSpeedRatings = value

value = instance.ISOSpeedRatings
public ushort[] ISOSpeedRatings {get; set;}
public: __property ushort[]* get_ISOSpeedRatings();
public: __property void set_ISOSpeedRatings(
   ushort[]* value
);
public:
property array<ushort>^ ISOSpeedRatings {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Array of ushort values.
Remarks
This property accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


JPEGInterchangeFormat Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : JPEGInterchangeFormat Property
Gets or sets JPEGInterchangeFormat Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGInterchangeFormat As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.JPEGInterchangeFormat = value

value = instance.JPEGInterchangeFormat
public Nullable<uint> JPEGInterchangeFormat {get; set;}
public: __property Nullable<uint> get_JPEGInterchangeFormat();
public: __property void set_JPEGInterchangeFormat(
   Nullable<uint> value
);
public:
property Nullable<uint> JPEGInterchangeFormat {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


JPEGInterchangeFormatLength Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : JPEGInterchangeFormatLength Property
Gets or sets JPEGInterchangeFormatLength Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGInterchangeFormatLength As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.JPEGInterchangeFormatLength = value

value = instance.JPEGInterchangeFormatLength
public Nullable<uint> JPEGInterchangeFormatLength {get; set;}
public: __property Nullable<uint> get_JPEGInterchangeFormatLength();
public: __property void set_JPEGInterchangeFormatLength(
   Nullable<uint> value
);
public:
property Nullable<uint> JPEGInterchangeFormatLength {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


LightSource Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : LightSource Property
Gets or sets LightSource Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LightSource As Nullable(Of ImGearEXIFLightSource)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFLightSource)

instance.LightSource = value

value = instance.LightSource
public Nullable<ImGearEXIFLightSource> LightSource {get; set;}
public: __property Nullable<ImGearEXIFLightSource> get_LightSource();
public: __property void set_LightSource(
   Nullable<ImGearEXIFLightSource> value
);
public:
property Nullable<ImGearEXIFLightSource> LightSource {
   Nullable<ImGearEXIFLightSource> get();
   void set (    Nullable<ImGearEXIFLightSource> value);
}

Property Value

Nullable (boxed) ImGearEXIFLightSource enumeration value.
Remarks
This property accesses the LightSource tag. The tag specifies the kind of light source.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFLightSource Enumeration


Make Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Make Property
Gets or sets Make Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Make As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.Make = value

value = instance.Make
public string Make {get; set;}
public: __property string* get_Make();
public: __property void set_Make(
   string* value
);
public:
property String^ Make {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


MaxApertureValue Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : MaxApertureValue Property
Gets or sets MaxApertureValue Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxApertureValue As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.MaxApertureValue = value

value = instance.MaxApertureValue
public Nullable<ImGearRationalUInt> MaxApertureValue {get; set;}
public: __property Nullable<ImGearRationalUInt> get_MaxApertureValue();
public: __property void set_MaxApertureValue(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> MaxApertureValue {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


MeteringMode Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : MeteringMode Property
Gets or sets MeteringMode Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MeteringMode As Nullable(Of ImGearEXIFMeteringMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFMeteringMode)

instance.MeteringMode = value

value = instance.MeteringMode
public Nullable<ImGearEXIFMeteringMode> MeteringMode {get; set;}
public: __property Nullable<ImGearEXIFMeteringMode> get_MeteringMode();
public: __property void set_MeteringMode(
   Nullable<ImGearEXIFMeteringMode> value
);
public:
property Nullable<ImGearEXIFMeteringMode> MeteringMode {
   Nullable<ImGearEXIFMeteringMode> get();
   void set (    Nullable<ImGearEXIFMeteringMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFMeteringMode enumeration value.
Remarks
This property accesses the MeteringMode tag. The tag specifies the metering mode.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFMeteringMode Enumeration


Model Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Model Property
Gets or sets Model Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Model As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.Model = value

value = instance.Model
public string Model {get; set;}
public: __property string* get_Model();
public: __property void set_Model(
   string* value
);
public:
property String^ Model {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


OECF Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : OECF Property
Gets or sets OECF Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OECF As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.OECF = value

value = instance.OECF
public byte[] OECF {get; set;}
public: __property byte[]* get_OECF();
public: __property void set_OECF(
   byte[]* value
);
public:
property array<byte>^ OECF {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


Orientation Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Orientation Property
Gets or sets Orientation Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As Nullable(Of ImGearTIFFOrientation)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFOrientation)

instance.Orientation = value

value = instance.Orientation
public Nullable<ImGearTIFFOrientation> Orientation {get; set;}
public: __property Nullable<ImGearTIFFOrientation> get_Orientation();
public: __property void set_Orientation(
   Nullable<ImGearTIFFOrientation> value
);
public:
property Nullable<ImGearTIFFOrientation> Orientation {
   Nullable<ImGearTIFFOrientation> get();
   void set (    Nullable<ImGearTIFFOrientation> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFOrientation enumeration value.
Remarks
This property accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores value of this tag during image saving, and saves a value that corresponds to the saved image parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFOrientation Enumeration


PhotometricInterpretation Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : PhotometricInterpretation Property
Gets or sets PhotometricInterpretation Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PhotometricInterpretation As Nullable(Of ImGearTIFFPhotoInterpretation)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFPhotoInterpretation)

instance.PhotometricInterpretation = value

value = instance.PhotometricInterpretation
public Nullable<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {get; set;}
public: __property Nullable<ImGearTIFFPhotoInterpretation> get_PhotometricInterpretation();
public: __property void set_PhotometricInterpretation(
   Nullable<ImGearTIFFPhotoInterpretation> value
);
public:
property Nullable<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {
   Nullable<ImGearTIFFPhotoInterpretation> get();
   void set (    Nullable<ImGearTIFFPhotoInterpretation> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFPhotoInterpretation enumeration value.
Remarks
This property accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFPhotoInterpretation Enumeration


PixelXDimension Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : PixelXDimension Property
Gets or sets PixelXDimension Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelXDimension As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.PixelXDimension = value

value = instance.PixelXDimension
public Nullable<uint> PixelXDimension {get; set;}
public: __property Nullable<uint> get_PixelXDimension();
public: __property void set_PixelXDimension(
   Nullable<uint> value
);
public:
property Nullable<uint> PixelXDimension {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


PixelYDimension Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : PixelYDimension Property
Gets or sets PixelYDimension Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelYDimension As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.PixelYDimension = value

value = instance.PixelYDimension
public Nullable<uint> PixelYDimension {get; set;}
public: __property Nullable<uint> get_PixelYDimension();
public: __property void set_PixelYDimension(
   Nullable<uint> value
);
public:
property Nullable<uint> PixelYDimension {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) UInt value.
Remarks
This property accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


PlanarConfig Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : PlanarConfig Property
Gets or sets PlanarConfig Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlanarConfig As Nullable(Of ImGearTIFFPlanarConfig)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFPlanarConfig)

instance.PlanarConfig = value

value = instance.PlanarConfig
public Nullable<ImGearTIFFPlanarConfig> PlanarConfig {get; set;}
public: __property Nullable<ImGearTIFFPlanarConfig> get_PlanarConfig();
public: __property void set_PlanarConfig(
   Nullable<ImGearTIFFPlanarConfig> value
);
public:
property Nullable<ImGearTIFFPlanarConfig> PlanarConfig {
   Nullable<ImGearTIFFPlanarConfig> get();
   void set (    Nullable<ImGearTIFFPlanarConfig> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFPlanarConfig enumeration value.
Remarks
This property accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFPlanarConfig Enumeration


PrimaryChromaticities Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : PrimaryChromaticities Property
Gets or sets PrimaryChromaticities Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrimaryChromaticities As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As ImGearRationalUInt

instance.PrimaryChromaticities = value

value = instance.PrimaryChromaticities
public ImGearRationalUInt[] PrimaryChromaticities {get; set;}
public: __property ImGearRationalUInt[]* get_PrimaryChromaticities();
public: __property void set_PrimaryChromaticities(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ PrimaryChromaticities {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


ReferenceBlackWhite Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ReferenceBlackWhite Property
Gets or sets ReferenceBlackWhite Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceBlackWhite As UInteger()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UInteger

instance.ReferenceBlackWhite = value

value = instance.ReferenceBlackWhite
public uint[] ReferenceBlackWhite {get; set;}
public: __property uint[]* get_ReferenceBlackWhite();
public: __property void set_ReferenceBlackWhite(
   uint[]* value
);
public:
property array<uint>^ ReferenceBlackWhite {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


RelatedSoundFile Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : RelatedSoundFile Property
Gets or sets RelatedSoundFile Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelatedSoundFile As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.RelatedSoundFile = value

value = instance.RelatedSoundFile
public string RelatedSoundFile {get; set;}
public: __property string* get_RelatedSoundFile();
public: __property void set_RelatedSoundFile(
   string* value
);
public:
property String^ RelatedSoundFile {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


ResolutionUnit Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ResolutionUnit Property
Gets or sets ResolutionUnit Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionUnit As Nullable(Of ImGearTIFFResolutionUnit)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearTIFFResolutionUnit)

instance.ResolutionUnit = value

value = instance.ResolutionUnit
public Nullable<ImGearTIFFResolutionUnit> ResolutionUnit {get; set;}
public: __property Nullable<ImGearTIFFResolutionUnit> get_ResolutionUnit();
public: __property void set_ResolutionUnit(
   Nullable<ImGearTIFFResolutionUnit> value
);
public:
property Nullable<ImGearTIFFResolutionUnit> ResolutionUnit {
   Nullable<ImGearTIFFResolutionUnit> get();
   void set (    Nullable<ImGearTIFFResolutionUnit> value);
}

Property Value

Nullable (boxed) ImageGear.Formats.TIF.ImGearTIFFResolutionUnit enumeration value.
Remarks
This property accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearTIFFResolutionUnit Enumeration


RowsPerStrip Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : RowsPerStrip Property
Gets or sets RowsPerStrip Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RowsPerStrip As Nullable(Of UInteger)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UInteger)

instance.RowsPerStrip = value

value = instance.RowsPerStrip
public Nullable<uint> RowsPerStrip {get; set;}
public: __property Nullable<uint> get_RowsPerStrip();
public: __property void set_RowsPerStrip(
   Nullable<uint> value
);
public:
property Nullable<uint> RowsPerStrip {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SamplesPerPixel Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SamplesPerPixel Property
Gets or sets SamplesPerPixel Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SamplesPerPixel As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UShort)

instance.SamplesPerPixel = value

value = instance.SamplesPerPixel
public Nullable<ushort> SamplesPerPixel {get; set;}
public: __property Nullable<ushort> get_SamplesPerPixel();
public: __property void set_SamplesPerPixel(
   Nullable<ushort> value
);
public:
property Nullable<ushort> SamplesPerPixel {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


Saturation Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Saturation Property
Gets or sets Saturation Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Saturation As Nullable(Of ImGearEXIFSaturationMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFSaturationMode)

instance.Saturation = value

value = instance.Saturation
public Nullable<ImGearEXIFSaturationMode> Saturation {get; set;}
public: __property Nullable<ImGearEXIFSaturationMode> get_Saturation();
public: __property void set_Saturation(
   Nullable<ImGearEXIFSaturationMode> value
);
public:
property Nullable<ImGearEXIFSaturationMode> Saturation {
   Nullable<ImGearEXIFSaturationMode> get();
   void set (    Nullable<ImGearEXIFSaturationMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFSaturationMode enumeration value.
Remarks
This property accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFSaturationMode Enumeration


SceneCaptureType Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SceneCaptureType Property
Gets or sets SceneCaptureType Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SceneCaptureType As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UShort)

instance.SceneCaptureType = value

value = instance.SceneCaptureType
public Nullable<ushort> SceneCaptureType {get; set;}
public: __property Nullable<ushort> get_SceneCaptureType();
public: __property void set_SceneCaptureType(
   Nullable<ushort> value
);
public:
property Nullable<ushort> SceneCaptureType {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SceneType Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SceneType Property
Gets or sets SceneType Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SceneType As Nullable(Of ImGearEXIFSceneType)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFSceneType)

instance.SceneType = value

value = instance.SceneType
public Nullable<ImGearEXIFSceneType> SceneType {get; set;}
public: __property Nullable<ImGearEXIFSceneType> get_SceneType();
public: __property void set_SceneType(
   Nullable<ImGearEXIFSceneType> value
);
public:
property Nullable<ImGearEXIFSceneType> SceneType {
   Nullable<ImGearEXIFSceneType> get();
   void set (    Nullable<ImGearEXIFSceneType> value);
}

Property Value

Nullable (boxed) ImGearEXIFSceneType enumeration value.
Remarks
This property accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFSceneType Enumeration


SensingMethod Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SensingMethod Property
Gets or sets SensingMethod Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SensingMethod As Nullable(Of ImGearEXIFSensingMethod)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFSensingMethod)

instance.SensingMethod = value

value = instance.SensingMethod
public Nullable<ImGearEXIFSensingMethod> SensingMethod {get; set;}
public: __property Nullable<ImGearEXIFSensingMethod> get_SensingMethod();
public: __property void set_SensingMethod(
   Nullable<ImGearEXIFSensingMethod> value
);
public:
property Nullable<ImGearEXIFSensingMethod> SensingMethod {
   Nullable<ImGearEXIFSensingMethod> get();
   void set (    Nullable<ImGearEXIFSensingMethod> value);
}

Property Value

Nullable (boxed) ImGearEXIFSensingMethod enumeration value.
Remarks
This property accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFSensingMethod Enumeration


Sharpness Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Sharpness Property
Gets or sets Sharpness Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sharpness As Nullable(Of ImGearEXIFSharpnessMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFSharpnessMode)

instance.Sharpness = value

value = instance.Sharpness
public Nullable<ImGearEXIFSharpnessMode> Sharpness {get; set;}
public: __property Nullable<ImGearEXIFSharpnessMode> get_Sharpness();
public: __property void set_Sharpness(
   Nullable<ImGearEXIFSharpnessMode> value
);
public:
property Nullable<ImGearEXIFSharpnessMode> Sharpness {
   Nullable<ImGearEXIFSharpnessMode> get();
   void set (    Nullable<ImGearEXIFSharpnessMode> value);
}

Property Value

Nullable (boxed) ImGearEXIFSharpnessMode enumeration value.
Remarks
This property accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFSharpnessMode Enumeration


ShutterSpeedValue Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : ShutterSpeedValue Property
Gets or sets ShutterSpeedValue Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShutterSpeedValue As Nullable(Of ImGearRationalInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalInt)

instance.ShutterSpeedValue = value

value = instance.ShutterSpeedValue
public Nullable<ImGearRationalInt> ShutterSpeedValue {get; set;}
public: __property Nullable<ImGearRationalInt> get_ShutterSpeedValue();
public: __property void set_ShutterSpeedValue(
   Nullable<ImGearRationalInt> value
);
public:
property Nullable<ImGearRationalInt> ShutterSpeedValue {
   Nullable<ImGearRationalInt> get();
   void set (    Nullable<ImGearRationalInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


Software Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : Software Property
Gets or sets Software Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Software As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.Software = value

value = instance.Software
public string Software {get; set;}
public: __property string* get_Software();
public: __property void set_Software(
   string* value
);
public:
property String^ Software {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SpatialFrequencyResponse Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SpatialFrequencyResponse Property
Gets or sets SpatialFrequencyResponse Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpatialFrequencyResponse As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.SpatialFrequencyResponse = value

value = instance.SpatialFrequencyResponse
public byte[] SpatialFrequencyResponse {get; set;}
public: __property byte[]* get_SpatialFrequencyResponse();
public: __property void set_SpatialFrequencyResponse(
   byte[]* value
);
public:
property array<byte>^ SpatialFrequencyResponse {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SpectralSensitivity Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SpectralSensitivity Property
Gets or sets SpectralSensitivity Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpectralSensitivity As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.SpectralSensitivity = value

value = instance.SpectralSensitivity
public string SpectralSensitivity {get; set;}
public: __property string* get_SpectralSensitivity();
public: __property void set_SpectralSensitivity(
   string* value
);
public:
property String^ SpectralSensitivity {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


StripByteCounts Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : StripByteCounts Property
Gets or sets StripByteCounts Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StripByteCounts As UInteger()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UInteger

instance.StripByteCounts = value

value = instance.StripByteCounts
public uint[] StripByteCounts {get; set;}
public: __property uint[]* get_StripByteCounts();
public: __property void set_StripByteCounts(
   uint[]* value
);
public:
property array<uint>^ StripByteCounts {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


StripOffsets Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : StripOffsets Property
Gets or sets StripOffsets Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StripOffsets As UInteger()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UInteger

instance.StripOffsets = value

value = instance.StripOffsets
public uint[] StripOffsets {get; set;}
public: __property uint[]* get_StripOffsets();
public: __property void set_StripOffsets(
   uint[]* value
);
public:
property array<uint>^ StripOffsets {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SubjectArea Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubjectArea Property
Gets or sets SubjectArea Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectArea As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.SubjectArea = value

value = instance.SubjectArea
public ushort[] SubjectArea {get; set;}
public: __property ushort[]* get_SubjectArea();
public: __property void set_SubjectArea(
   ushort[]* value
);
public:
property array<ushort>^ SubjectArea {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SubjectDistance Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubjectDistance Property
Gets or sets SubjectDistance Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectDistance As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.SubjectDistance = value

value = instance.SubjectDistance
public Nullable<ImGearRationalUInt> SubjectDistance {get; set;}
public: __property Nullable<ImGearRationalUInt> get_SubjectDistance();
public: __property void set_SubjectDistance(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> SubjectDistance {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


SubjectDistanceRange Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubjectDistanceRange Property
Gets or sets SubjectDistanceRange Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectDistanceRange As Nullable(Of ImGearEXIFSubjectDistanceRange)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFSubjectDistanceRange)

instance.SubjectDistanceRange = value

value = instance.SubjectDistanceRange
public Nullable<ImGearEXIFSubjectDistanceRange> SubjectDistanceRange {get; set;}
public: __property Nullable<ImGearEXIFSubjectDistanceRange> get_SubjectDistanceRange();
public: __property void set_SubjectDistanceRange(
   Nullable<ImGearEXIFSubjectDistanceRange> value
);
public:
property Nullable<ImGearEXIFSubjectDistanceRange> SubjectDistanceRange {
   Nullable<ImGearEXIFSubjectDistanceRange> get();
   void set (    Nullable<ImGearEXIFSubjectDistanceRange> value);
}

Property Value

Nullable (boxed) ImGearEXIFSubjectDistanceRange enumeration value.
Remarks
This property accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFSubjectDistanceRange Enumeration


SubjectLocation Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubjectLocation Property
Gets or sets SubjectLocation Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectLocation As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.SubjectLocation = value

value = instance.SubjectLocation
public ushort[] SubjectLocation {get; set;}
public: __property ushort[]* get_SubjectLocation();
public: __property void set_SubjectLocation(
   ushort[]* value
);
public:
property array<ushort>^ SubjectLocation {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short] array.
Remarks
This property accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SubSecTime Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubSecTime Property
Gets or sets SubSecTime Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubSecTime As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.SubSecTime = value

value = instance.SubSecTime
public string SubSecTime {get; set;}
public: __property string* get_SubSecTime();
public: __property void set_SubSecTime(
   string* value
);
public:
property String^ SubSecTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SubSecTimeDigitized Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubSecTimeDigitized Property
Gets or sets SubSecTimeDigitized Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubSecTimeDigitized As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.SubSecTimeDigitized = value

value = instance.SubSecTimeDigitized
public string SubSecTimeDigitized {get; set;}
public: __property string* get_SubSecTimeDigitized();
public: __property void set_SubSecTimeDigitized(
   string* value
);
public:
property String^ SubSecTimeDigitized {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


SubSecTimeOriginal Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : SubSecTimeOriginal Property
Gets or sets SubSecTimeOriginal Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubSecTimeOriginal As String
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As String

instance.SubSecTimeOriginal = value

value = instance.SubSecTimeOriginal
public string SubSecTimeOriginal {get; set;}
public: __property string* get_SubSecTimeOriginal();
public: __property void set_SubSecTimeOriginal(
   string* value
);
public:
property String^ SubSecTimeOriginal {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


TransferFunction Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : TransferFunction Property
Gets or sets TransferFunction Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransferFunction As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.TransferFunction = value

value = instance.TransferFunction
public ushort[] TransferFunction {get; set;}
public: __property ushort[]* get_TransferFunction();
public: __property void set_TransferFunction(
   ushort[]* value
);
public:
property array<ushort>^ TransferFunction {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


UserComment Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : UserComment Property
Gets or sets UserComment Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserComment As Byte()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As Byte

instance.UserComment = value

value = instance.UserComment
public byte[] UserComment {get; set;}
public: __property byte[]* get_UserComment();
public: __property void set_UserComment(
   byte[]* value
);
public:
property array<byte>^ UserComment {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


WhiteBalance Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : WhiteBalance Property
Gets or sets WhiteBalance Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhiteBalance As Nullable(Of ImGearEXIFWhiteBalanceMode)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearEXIFWhiteBalanceMode)

instance.WhiteBalance = value

value = instance.WhiteBalance
public Nullable<ImGearEXIFWhiteBalanceMode> WhiteBalance {get; set;}
public: __property Nullable<ImGearEXIFWhiteBalanceMode> get_WhiteBalance();
public: __property void set_WhiteBalance(
   Nullable<ImGearEXIFWhiteBalanceMode> value
);
public:
property Nullable<ImGearEXIFWhiteBalanceMode> WhiteBalance {
   Nullable<ImGearEXIFWhiteBalanceMode> get();
   void set (    Nullable<ImGearEXIFWhiteBalanceMode> value);
}

Property Value

Nullable (boxed)ImGearEXIFWhiteBalanceMode enumeration value.
Remarks
This property accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearEXIFWhiteBalanceMode Enumeration


WhitePoint Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : WhitePoint Property
Gets or sets WhitePoint Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As ImGearRationalUInt

instance.WhitePoint = value

value = instance.WhitePoint
public ImGearRationalUInt[] WhitePoint {get; set;}
public: __property ImGearRationalUInt[]* get_WhitePoint();
public: __property void set_WhitePoint(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ WhitePoint {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


XResolution Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : XResolution Property
Gets or sets XResolution Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.XResolution = value

value = instance.XResolution
public Nullable<ImGearRationalUInt> XResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_XResolution();
public: __property void set_XResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> XResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


YCbCrCoefficients Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : YCbCrCoefficients Property
Gets or sets YCbCrCoefficients Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrCoefficients As ImGearRationalUInt()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As ImGearRationalUInt

instance.YCbCrCoefficients = value

value = instance.YCbCrCoefficients
public ImGearRationalUInt[] YCbCrCoefficients {get; set;}
public: __property ImGearRationalUInt[]* get_YCbCrCoefficients();
public: __property void set_YCbCrCoefficients(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ YCbCrCoefficients {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


YCbCrPositioning Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : YCbCrPositioning Property
Gets or sets YCbCrPositioning Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrPositioning As Nullable(Of UShort)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of UShort)

instance.YCbCrPositioning = value

value = instance.YCbCrPositioning
public Nullable<ushort> YCbCrPositioning {get; set;}
public: __property Nullable<ushort> get_YCbCrPositioning();
public: __property void set_YCbCrPositioning(
   Nullable<ushort> value
);
public:
property Nullable<ushort> YCbCrPositioning {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


YCbCrSubSampling Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : YCbCrSubSampling Property
Gets or sets YCbCrSubSampling Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrSubSampling As UShort()
'Usage

Dim instance As ImGearEXIFMetadata
Dim value() As UShort

instance.YCbCrSubSampling = value

value = instance.YCbCrSubSampling
public ushort[] YCbCrSubSampling {get; set;}
public: __property ushort[]* get_YCbCrSubSampling();
public: __property void set_YCbCrSubSampling(
   ushort[]* value
);
public:
property array<ushort>^ YCbCrSubSampling {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


YResolution Property (ImGearEXIFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.EXIF Namespace > ImGearEXIFMetadata Class : YResolution Property
Gets or sets YResolution Tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearEXIFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.YResolution = value

value = instance.YResolution
public Nullable<ImGearRationalUInt> YResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_YResolution();
public: __property void set_YResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> YResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members
ImGearRationalUInt Structure


ImageGear.Formats.IPTC Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.IPTC Namespace
This namespace contains classes, structures, and enumerations that provide simplified access to IPTC metadata.
Classes
 | Class | Description
Class | ImGearIPTCMetadata | Provides simplified access to IPTC metadata.
Structures
 | Structure | Description
Structure | ImGearIPTCAudioType | Represents IPTC Audio Type structure.
Structure | ImGearIPTCColourRepresentation | Represents IPTC Colour Representation structure.
Structure | ImGearIPTCImageType | Represents IPTC Image Type structure.
Structure | ImGearIPTCObjectAttributeReference | Represents IPTC Object Attribute Reference structure.
Structure | ImGearIPTCObjectTypeReference | Represents IPTC Object Type Reference structure.
Structure | ImGearIPTCPictureNumber | Represents IPTC Picture Number structure.
Structure | ImGearIPTCSubjectReference | Represents IPTC Subject Reference structure.
Structure | ImGearIPTCUNO | Represents IPTC UNO structure.
Enumerations
 | Enumeration | Description
Enumeration | ImGearIPTCActionAdvised | Represents IPTC Advised Actions.
Enumeration | ImGearIPTCAudioChannelMode | Represents IPTC Audio Channel Modes.
Enumeration | ImGearIPTCAudioContentType | Represents IPTC Audio Content Types.
Enumeration | ImGearIPTCDataCompressionMethod | Represents IPTC Data Compression Methods.
Enumeration | ImGearIPTCExcursionTolerance | Represents IPTC Excursion Tolerance modes.
Enumeration | ImGearIPTCFileFormatID | Represents IPTC File Format IDs.
Enumeration | ImGearIPTCImageBuildUpStructure | Represents IPTC Image Build Up Structures.
Enumeration | ImGearIPTCImageColourMode | Represents IPTC Image Colour Modes.
Enumeration | ImGearIPTCImageComponentMode | Represents IPTC Image Component Modes.
Enumeration | ImGearIPTCImageOrientation | Represents IPTC Image Orientations.
Enumeration | ImGearIPTCImageRotation | Represents IPTC Image Rotations.
Enumeration | ImGearIPTCInterchangeColourSpace | Represents IPTC Interchange Colour Spaces.
Enumeration | ImGearIPTCObjectAttributeNumber | Represents IPTC Object Attribute Numbers.
Enumeration | ImGearIPTCObjectCycle | Represents IPTC Object Cycles.
Enumeration | ImGearIPTCObjectTypeNumber | Represents IPTC Object Type Numbers.
Enumeration | ImGearIPTCQuantisationMethod | Represents IPTC Quantisation Methods.
Enumeration | ImGearIPTCSamplingStructure | Represents IPTC Sampling Structures.
Enumeration | ImGearIPTCScanningDirection | Represents IPTC Scanning Directions.
Enumeration | ImGearIPTCSizeMode | Represents IPTC Size Modes.
Enumeration | ImGearIPTCSubjectReferenceNumber | Represents IPTC Subject Reference Numbers.
Enumeration | ImGearIPTCSupplementType | Represents IPTC Supplement Types.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.IPTC Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.IPTC Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.IPTC.ImGearIPTCMetadata
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCAudioType
ImageGear.Formats.IPTC.ImGearIPTCColourRepresentation
ImageGear.Formats.IPTC.ImGearIPTCImageType
ImageGear.Formats.IPTC.ImGearIPTCObjectAttributeReference
ImageGear.Formats.IPTC.ImGearIPTCObjectTypeReference
ImageGear.Formats.IPTC.ImGearIPTCPictureNumber
ImageGear.Formats.IPTC.ImGearIPTCSubjectReference
ImageGear.Formats.IPTC.ImGearIPTCUNO
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearIPTCMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCMetadata Class
Provides simplified access to IPTC metadata.
Object Model
ImGearIPTCMetadata ClassImGearIPTCObjectAttributeReference StructureImGearIPTCSubjectReference Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearIPTCMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearIPTCMetadata
public class ImGearIPTCMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearIPTCMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearIPTCMetadata : public ImageGear.Formats.ImGearFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.IPTC.ImGearIPTCMetadata

See Also

Reference

ImGearIPTCMetadata Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCMetadata Class

The following tables list the members exposed by ImGearIPTCMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearIPTCMetadata Constructor | Initializes a new instance of the ImGearIPTCMetadata class.
Top
Public Properties
 | Name | Description
Public Property | ActionAdvised | Gets or sets Action Advised IPTC dataset.
Public Property | ARMIdentifier | Gets or sets ARM Identifier IPTC dataset.
Public Property | ARMVersion | Gets or sets ARM Version IPTC dataset.
Public Property | AudioDuration | Gets or sets Audio Duration IPTC dataset.
Public Property | AudioOutcue | Gets or sets Audio Outcue IPTC dataset.
Public Property | AudioSamplingRate | Gets or sets Audio Sampling Rate IPTC dataset.
Public Property | AudioSamplingResolution | Gets or sets Audio Sampling Resolution IPTC dataset.
Public Property | AudioType | Gets or sets Audio Type IPTC dataset.
Public Property | BitsPerComponent | Gets or sets Bits Per Component IPTC dataset.
Public Property | ByLine | Gets or sets By Line IPTC dataset.
Public Property | ByLineTitle | Gets or sets By Line Title IPTC dataset.
Public Property | Caption_Abstract | Gets or sets Caption/Abstract IPTC dataset.
Public Property | Category | Gets or sets Category IPTC dataset.
Public Property | City | Gets or sets City IPTC dataset.
Public Property | CodedCharacterSet | Gets or sets Coded Character Set IPTC dataset.
Public Property | ColourCalibrationMatrixTable | Gets or sets Colour Calibration Matrix Table IPTC dataset.
Public Property | ColourPalette | Gets or sets Colour Palette IPTC dataset.
Public Property | ColourRepresentation | Gets or sets Colour Representation IPTC dataset.
Public Property | ColourSequence | Gets or sets Colour Sequence IPTC dataset.
Public Property | ConfirmedObjectDataSize | Gets or sets Confirmed Object Data Size IPTC dataset.
Public Property | Contact | Gets or sets Contact IPTC dataset.
Public Property | ContentLocationCode | Gets or sets Content Location Code IPTC dataset.
Public Property | ContentLocationName | Gets or sets Content Location Name IPTC dataset.
Public Property | CopyrightNotice | Gets or sets Copyright Notice IPTC dataset.
Public Property | CountryPrimaryLocationCode | Gets or sets Country Primary Location Code IPTC dataset.
Public Property | CountryPrimaryLocationName | Gets or sets Country Primary Location Name IPTC dataset.
Public Property | Credit | Gets or sets Credit IPTC dataset.
Public Property | DataCompressionMethod | Gets or sets Data Compression method IPTC dataset.
Public Property | DateCreated | Gets or sets Date Created IPTC dataset.
Public Property | DateSent | Gets or sets Date Sent IPTC dataset.
Public Property | Destination | Gets or sets Destination IPTC dataset.
Public Property | DigitalCreationDate | Gets or sets Digital Creation Date IPTC dataset.
Public Property | DigitalCreationTime | Gets or sets Digital Creation Time IPTC dataset.
Public Property | EditorialUpdate | Gets or sets Editorial Update IPTC dataset.
Public Property | EditStatus | Gets or sets Edit Status IPTC dataset.
Public Property | EndPoints | Gets or sets End Points IPTC dataset.
Public Property | EnvelopeNumber | Gets or sets Envelope Number IPTC dataset.
Public Property | EnvelopePriority | Gets or sets Envelope Priority IPTC dataset.
Public Property | ExcursionTolerance | Gets or sets Excursion Tolerance IPTC dataset.
Public Property | ExpirationDate | Gets or sets Expiration Date IPTC dataset.
Public Property | ExpirationTime | Gets or sets Expiration Time IPTC dataset.
Public Property | FileFormat | Gets or sets File Format IPTC dataset.
Public Property | FileFormatVersion | Gets or sets File Format Version IPTC dataset.
Public Property | FixtureIdentifier | Gets or sets Fixture Identifier IPTC dataset.
Public Property | GammaCompensatedValue | Gets or sets Gamma Compensated Value IPTC dataset.
Public Property | Headline | Gets or sets Headline IPTC dataset.
Public Property | ICCInputColourProfile | Gets or sets ICC Input Colour Profile IPTC dataset.
Public Property | ImageOrientation | Gets or sets Image Orientation IPTC dataset.
Public Property | ImageRotation | Gets or sets Image Rotation IPTC dataset.
Public Property | ImageType | Gets or sets Image Type IPTC dataset.
Public Property | InterchangeColourSpace | Gets or sets Interchange Colour Space IPTC dataset.
Public Property | Keywords | Gets or sets Keywords IPTC dataset.
Public Property | LanguageIdentifier | Gets or sets Language Identifier IPTC dataset.
Public Property | LookupTable | Gets or sets Lookup Table IPTC dataset.
Public Property | MaximumDensityRange | Gets or sets Maximum Density Range IPTC dataset.
Public Property | MaximumObjectDataSize | Gets or sets Maximum Object Data Size IPTC dataset.
Public Property | MaxSubfileSize | Gets or sets Max Subfile Size IPTC dataset.
Public Property | ModelVersion | Gets or sets Model Version IPTC dataset.
Public Property | NumberOfBitsPerSample | Gets or sets Number Of Bits Per Sample IPTC dataset.
Public Property | NumberOfIndexEntries | Gets or sets Number Of Index Entries IPTC dataset.
Public Property | NumberOfLines | Gets or sets Number Of Line IPTC dataset.
Public Property | ObjectAttributeReference | Gets or sets Object Attribute Reference IPTC dataset.
Public Property | ObjectCycle | Gets or sets Object Cycle IPTC dataset.
Public Property | ObjectDataPreviewData | Gets or sets Object Data Preview Data IPTC dataset.
Public Property | ObjectDataPreviewFileFormat | Gets or sets ObjectData Preview File Format DataSet (2:200).
Public Property | ObjectDataPreviewFileFormatVersion | Gets or sets Object Data Preview File Format Version IPTC dataset.
Public Property | ObjectDataSizeAnnounced | Gets or sets Object Data Size Announced IPTC dataset.
Public Property | ObjectName | Gets or sets Object Name IPTC dataset.
Public Property | ObjectTypeReference | Gets or sets Object Type Reference IPTC dataset.
Public Property | OriginalTransmissionReference | Gets or sets Original Transmission Reference IPTC dataset.
Public Property | OriginatingProgram | Gets or sets Originating Program IPTC dataset.
Public Property | PictureNumber | Gets or sets Picture Number IPTC dataset.
Public Property | PixelSizeInScanningDirection | Gets or sets Pixel Size In Scanning Direction IPTC dataset.
Public Property | PixelSizePerpendicularToScanningDirection | Gets or sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.
Public Property | PixelsPerLine | Gets or sets Pixels Per Line IPTC dataset.
Public Property | ProductID | Gets or sets ProductID IPTC dataset.
Public Property | ProgramVersion | Gets or sets Program Version IPTC dataset.
Public Property | ProvinceState | Gets or sets Province State IPTC dataset.
Public Property | QuantisationMethod | Gets or sets Quantisation method IPTC dataset.
Public Property | RasterizedCaption | Gets or sets Rasterized Caption IPTC dataset.
Public Property | Record2Version | Gets or sets Record2 Version IPTC dataset.
Public Property | Record3Version | Gets or sets Record3 Version IPTC dataset.
Public Property | ReferenceDate | Gets or sets Reference Date IPTC dataset.
Public Property | ReferenceNumber | Gets or sets Reference Number IPTC dataset.
Public Property | ReferenceService | Gets or sets Reference Service IPTC dataset.
Public Property | ReleaseDate | Gets or sets Release Date IPTC dataset.
Public Property | ReleaseTime | Gets or sets Release Time IPTC dataset.
Public Property | SamplingStructure | Gets or sets Sampling structure IPTC dataset.
Public Property | ScanningDirection | Gets or sets Scanning Direction IPTC dataset.
Public Property | ServiceIdentifier | Gets or sets Service Identifier IPTC dataset.
Public Property | SizeMode | Gets or sets Size Mode IPTC dataset.
Public Property | Source | Gets or sets Source IPTC dataset.
Public Property | SpecialInstructions | Gets or sets Special Instructions IPTC dataset.
Public Property | SubjectReference | Gets or sets Subject Reference IPTC dataset.
Public Property | Sublocation | Gets or sets Sublocation IPTC dataset.
Public Property | SupplementalCategory | Gets or sets Supplemental Category IPTC dataset.
Public Property | SupplementType | Gets or sets Supplement Type IPTC dataset.
Public Property | TimeCreated | Gets or sets Time Created IPTC dataset.
Public Property | TimeSent | Gets or sets Time Sent IPTC dataset.
Public Property | UNO | Gets or sets UNO IPTC dataset.
Public Property | Urgency | Gets or sets Urgency IPTC dataset.
Public Property | Writer_Editor | Gets or sets Writer/Editor IPTC dataset.
Top
See Also

Reference

ImGearIPTCMetadata Class
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ImGearIPTCMetadata Constructor
Initializes a new instance of the ImGearIPTCMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearIPTCMetadata()
public ImGearIPTCMetadata()
public: ImGearIPTCMetadata();
public:
ImGearIPTCMetadata();

Return Value

The new instance of ImGearIPTCMetadata class.
See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearIPTCMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCMetadata Class

For a list of all members of this type, see ImGearIPTCMetadata members.

Public Properties
 | Name | Description
Public Property | ActionAdvised | Gets or sets Action Advised IPTC dataset.
Public Property | ARMIdentifier | Gets or sets ARM Identifier IPTC dataset.
Public Property | ARMVersion | Gets or sets ARM Version IPTC dataset.
Public Property | AudioDuration | Gets or sets Audio Duration IPTC dataset.
Public Property | AudioOutcue | Gets or sets Audio Outcue IPTC dataset.
Public Property | AudioSamplingRate | Gets or sets Audio Sampling Rate IPTC dataset.
Public Property | AudioSamplingResolution | Gets or sets Audio Sampling Resolution IPTC dataset.
Public Property | AudioType | Gets or sets Audio Type IPTC dataset.
Public Property | BitsPerComponent | Gets or sets Bits Per Component IPTC dataset.
Public Property | ByLine | Gets or sets By Line IPTC dataset.
Public Property | ByLineTitle | Gets or sets By Line Title IPTC dataset.
Public Property | Caption_Abstract | Gets or sets Caption/Abstract IPTC dataset.
Public Property | Category | Gets or sets Category IPTC dataset.
Public Property | City | Gets or sets City IPTC dataset.
Public Property | CodedCharacterSet | Gets or sets Coded Character Set IPTC dataset.
Public Property | ColourCalibrationMatrixTable | Gets or sets Colour Calibration Matrix Table IPTC dataset.
Public Property | ColourPalette | Gets or sets Colour Palette IPTC dataset.
Public Property | ColourRepresentation | Gets or sets Colour Representation IPTC dataset.
Public Property | ColourSequence | Gets or sets Colour Sequence IPTC dataset.
Public Property | ConfirmedObjectDataSize | Gets or sets Confirmed Object Data Size IPTC dataset.
Public Property | Contact | Gets or sets Contact IPTC dataset.
Public Property | ContentLocationCode | Gets or sets Content Location Code IPTC dataset.
Public Property | ContentLocationName | Gets or sets Content Location Name IPTC dataset.
Public Property | CopyrightNotice | Gets or sets Copyright Notice IPTC dataset.
Public Property | CountryPrimaryLocationCode | Gets or sets Country Primary Location Code IPTC dataset.
Public Property | CountryPrimaryLocationName | Gets or sets Country Primary Location Name IPTC dataset.
Public Property | Credit | Gets or sets Credit IPTC dataset.
Public Property | DataCompressionMethod | Gets or sets Data Compression method IPTC dataset.
Public Property | DateCreated | Gets or sets Date Created IPTC dataset.
Public Property | DateSent | Gets or sets Date Sent IPTC dataset.
Public Property | Destination | Gets or sets Destination IPTC dataset.
Public Property | DigitalCreationDate | Gets or sets Digital Creation Date IPTC dataset.
Public Property | DigitalCreationTime | Gets or sets Digital Creation Time IPTC dataset.
Public Property | EditorialUpdate | Gets or sets Editorial Update IPTC dataset.
Public Property | EditStatus | Gets or sets Edit Status IPTC dataset.
Public Property | EndPoints | Gets or sets End Points IPTC dataset.
Public Property | EnvelopeNumber | Gets or sets Envelope Number IPTC dataset.
Public Property | EnvelopePriority | Gets or sets Envelope Priority IPTC dataset.
Public Property | ExcursionTolerance | Gets or sets Excursion Tolerance IPTC dataset.
Public Property | ExpirationDate | Gets or sets Expiration Date IPTC dataset.
Public Property | ExpirationTime | Gets or sets Expiration Time IPTC dataset.
Public Property | FileFormat | Gets or sets File Format IPTC dataset.
Public Property | FileFormatVersion | Gets or sets File Format Version IPTC dataset.
Public Property | FixtureIdentifier | Gets or sets Fixture Identifier IPTC dataset.
Public Property | GammaCompensatedValue | Gets or sets Gamma Compensated Value IPTC dataset.
Public Property | Headline | Gets or sets Headline IPTC dataset.
Public Property | ICCInputColourProfile | Gets or sets ICC Input Colour Profile IPTC dataset.
Public Property | ImageOrientation | Gets or sets Image Orientation IPTC dataset.
Public Property | ImageRotation | Gets or sets Image Rotation IPTC dataset.
Public Property | ImageType | Gets or sets Image Type IPTC dataset.
Public Property | InterchangeColourSpace | Gets or sets Interchange Colour Space IPTC dataset.
Public Property | Keywords | Gets or sets Keywords IPTC dataset.
Public Property | LanguageIdentifier | Gets or sets Language Identifier IPTC dataset.
Public Property | LookupTable | Gets or sets Lookup Table IPTC dataset.
Public Property | MaximumDensityRange | Gets or sets Maximum Density Range IPTC dataset.
Public Property | MaximumObjectDataSize | Gets or sets Maximum Object Data Size IPTC dataset.
Public Property | MaxSubfileSize | Gets or sets Max Subfile Size IPTC dataset.
Public Property | ModelVersion | Gets or sets Model Version IPTC dataset.
Public Property | NumberOfBitsPerSample | Gets or sets Number Of Bits Per Sample IPTC dataset.
Public Property | NumberOfIndexEntries | Gets or sets Number Of Index Entries IPTC dataset.
Public Property | NumberOfLines | Gets or sets Number Of Line IPTC dataset.
Public Property | ObjectAttributeReference | Gets or sets Object Attribute Reference IPTC dataset.
Public Property | ObjectCycle | Gets or sets Object Cycle IPTC dataset.
Public Property | ObjectDataPreviewData | Gets or sets Object Data Preview Data IPTC dataset.
Public Property | ObjectDataPreviewFileFormat | Gets or sets ObjectData Preview File Format DataSet (2:200).
Public Property | ObjectDataPreviewFileFormatVersion | Gets or sets Object Data Preview File Format Version IPTC dataset.
Public Property | ObjectDataSizeAnnounced | Gets or sets Object Data Size Announced IPTC dataset.
Public Property | ObjectName | Gets or sets Object Name IPTC dataset.
Public Property | ObjectTypeReference | Gets or sets Object Type Reference IPTC dataset.
Public Property | OriginalTransmissionReference | Gets or sets Original Transmission Reference IPTC dataset.
Public Property | OriginatingProgram | Gets or sets Originating Program IPTC dataset.
Public Property | PictureNumber | Gets or sets Picture Number IPTC dataset.
Public Property | PixelSizeInScanningDirection | Gets or sets Pixel Size In Scanning Direction IPTC dataset.
Public Property | PixelSizePerpendicularToScanningDirection | Gets or sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.
Public Property | PixelsPerLine | Gets or sets Pixels Per Line IPTC dataset.
Public Property | ProductID | Gets or sets ProductID IPTC dataset.
Public Property | ProgramVersion | Gets or sets Program Version IPTC dataset.
Public Property | ProvinceState | Gets or sets Province State IPTC dataset.
Public Property | QuantisationMethod | Gets or sets Quantisation method IPTC dataset.
Public Property | RasterizedCaption | Gets or sets Rasterized Caption IPTC dataset.
Public Property | Record2Version | Gets or sets Record2 Version IPTC dataset.
Public Property | Record3Version | Gets or sets Record3 Version IPTC dataset.
Public Property | ReferenceDate | Gets or sets Reference Date IPTC dataset.
Public Property | ReferenceNumber | Gets or sets Reference Number IPTC dataset.
Public Property | ReferenceService | Gets or sets Reference Service IPTC dataset.
Public Property | ReleaseDate | Gets or sets Release Date IPTC dataset.
Public Property | ReleaseTime | Gets or sets Release Time IPTC dataset.
Public Property | SamplingStructure | Gets or sets Sampling structure IPTC dataset.
Public Property | ScanningDirection | Gets or sets Scanning Direction IPTC dataset.
Public Property | ServiceIdentifier | Gets or sets Service Identifier IPTC dataset.
Public Property | SizeMode | Gets or sets Size Mode IPTC dataset.
Public Property | Source | Gets or sets Source IPTC dataset.
Public Property | SpecialInstructions | Gets or sets Special Instructions IPTC dataset.
Public Property | SubjectReference | Gets or sets Subject Reference IPTC dataset.
Public Property | Sublocation | Gets or sets Sublocation IPTC dataset.
Public Property | SupplementalCategory | Gets or sets Supplemental Category IPTC dataset.
Public Property | SupplementType | Gets or sets Supplement Type IPTC dataset.
Public Property | TimeCreated | Gets or sets Time Created IPTC dataset.
Public Property | TimeSent | Gets or sets Time Sent IPTC dataset.
Public Property | UNO | Gets or sets UNO IPTC dataset.
Public Property | Urgency | Gets or sets Urgency IPTC dataset.
Public Property | Writer_Editor | Gets or sets Writer/Editor IPTC dataset.
Top
See Also

Reference

ImGearIPTCMetadata Class
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ImGearIPTCMetadata Constructor
Overload List
Overload | Description
ImGearIPTCMetadata Constructor | Initializes a new instance of the ImGearIPTCMetadata class.
See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ActionAdvised Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ActionAdvised Property
Gets or sets Action Advised IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActionAdvised As Nullable(Of ImGearIPTCActionAdvised)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCActionAdvised)

instance.ActionAdvised = value

value = instance.ActionAdvised
public Nullable<ImGearIPTCActionAdvised> ActionAdvised {get; set;}
public: __property Nullable<ImGearIPTCActionAdvised> get_ActionAdvised();
public: __property void set_ActionAdvised(
   Nullable<ImGearIPTCActionAdvised> value
);
public:
property Nullable<ImGearIPTCActionAdvised> ActionAdvised {
   Nullable<ImGearIPTCActionAdvised> get();
   void set (    Nullable<ImGearIPTCActionAdvised> value);
}

Property Value

Nullable (boxed) ImGearIPTCActionAdvised enumeration value.
Remarks
This property accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCActionAdvised Enumeration


ARMIdentifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ARMIdentifier Property
Gets or sets ARM Identifier IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ARMIdentifier As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.ARMIdentifier = value

value = instance.ARMIdentifier
public Nullable<ushort> ARMIdentifier {get; set;}
public: __property Nullable<ushort> get_ARMIdentifier();
public: __property void set_ARMIdentifier(
   Nullable<ushort> value
);
public:
property Nullable<ushort> ARMIdentifier {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ARMVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ARMVersion Property
Gets or sets ARM Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ARMVersion As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.ARMVersion = value

value = instance.ARMVersion
public Nullable<ushort> ARMVersion {get; set;}
public: __property Nullable<ushort> get_ARMVersion();
public: __property void set_ARMVersion(
   Nullable<ushort> value
);
public:
property Nullable<ushort> ARMVersion {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


AudioDuration Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : AudioDuration Property
Gets or sets Audio Duration IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioDuration As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.AudioDuration = value

value = instance.AudioDuration
public string AudioDuration {get; set;}
public: __property string* get_AudioDuration();
public: __property void set_AudioDuration(
   string* value
);
public:
property String^ AudioDuration {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


AudioOutcue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : AudioOutcue Property
Gets or sets Audio Outcue IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioOutcue As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.AudioOutcue = value

value = instance.AudioOutcue
public string AudioOutcue {get; set;}
public: __property string* get_AudioOutcue();
public: __property void set_AudioOutcue(
   string* value
);
public:
property String^ AudioOutcue {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


AudioSamplingRate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : AudioSamplingRate Property
Gets or sets Audio Sampling Rate IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioSamplingRate As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.AudioSamplingRate = value

value = instance.AudioSamplingRate
public string AudioSamplingRate {get; set;}
public: __property string* get_AudioSamplingRate();
public: __property void set_AudioSamplingRate(
   string* value
);
public:
property String^ AudioSamplingRate {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


AudioSamplingResolution Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : AudioSamplingResolution Property
Gets or sets Audio Sampling Resolution IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioSamplingResolution As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.AudioSamplingResolution = value

value = instance.AudioSamplingResolution
public string AudioSamplingResolution {get; set;}
public: __property string* get_AudioSamplingResolution();
public: __property void set_AudioSamplingResolution(
   string* value
);
public:
property String^ AudioSamplingResolution {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


AudioType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : AudioType Property
Gets or sets Audio Type IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioType As Nullable(Of ImGearIPTCAudioType)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCAudioType)

instance.AudioType = value

value = instance.AudioType
public Nullable<ImGearIPTCAudioType> AudioType {get; set;}
public: __property Nullable<ImGearIPTCAudioType> get_AudioType();
public: __property void set_AudioType(
   Nullable<ImGearIPTCAudioType> value
);
public:
property Nullable<ImGearIPTCAudioType> AudioType {
   Nullable<ImGearIPTCAudioType> get();
   void set (    Nullable<ImGearIPTCAudioType> value);
}

Property Value

Nullable (boxed) ImGearIPTCAudioType structure value.
Remarks
This property accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCAudioType Structure


BitsPerComponent Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : BitsPerComponent Property
Gets or sets Bits Per Component IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerComponent As Nullable(Of Byte)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of Byte)

instance.BitsPerComponent = value

value = instance.BitsPerComponent
public Nullable<byte> BitsPerComponent {get; set;}
public: __property Nullable<byte> get_BitsPerComponent();
public: __property void set_BitsPerComponent(
   Nullable<byte> value
);
public:
property Nullable<byte> BitsPerComponent {
   Nullable<byte> get();
   void set (    Nullable<byte> value);
}

Property Value

Nullable (boxed) byte value.
Remarks
This property accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ByLine Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ByLine Property
Gets or sets By Line IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ByLine As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ByLine = value

value = instance.ByLine
public string[] ByLine {get; set;}
public: __property string*[]* get_ByLine();
public: __property void set_ByLine(
   string*[]* value
);
public:
property array<String^>^ ByLine {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

String array.
Remarks
This property accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ByLineTitle Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ByLineTitle Property
Gets or sets By Line Title IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ByLineTitle As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ByLineTitle = value

value = instance.ByLineTitle
public string[] ByLineTitle {get; set;}
public: __property string*[]* get_ByLineTitle();
public: __property void set_ByLineTitle(
   string*[]* value
);
public:
property array<String^>^ ByLineTitle {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

String array.
Remarks
This property accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Caption_Abstract Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Caption_Abstract Property
Gets or sets Caption/Abstract IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Caption_Abstract As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Caption_Abstract = value

value = instance.Caption_Abstract
public string Caption_Abstract {get; set;}
public: __property string* get_Caption_Abstract();
public: __property void set_Caption_Abstract(
   string* value
);
public:
property String^ Caption_Abstract {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Category Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Category Property
Gets or sets Category IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Category As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Category = value

value = instance.Category
public string Category {get; set;}
public: __property string* get_Category();
public: __property void set_Category(
   string* value
);
public:
property String^ Category {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


City Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : City Property
Gets or sets City IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property City As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.City = value

value = instance.City
public string City {get; set;}
public: __property string* get_City();
public: __property void set_City(
   string* value
);
public:
property String^ City {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


CodedCharacterSet Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : CodedCharacterSet Property
Gets or sets Coded Character Set IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CodedCharacterSet As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.CodedCharacterSet = value

value = instance.CodedCharacterSet
public string CodedCharacterSet {get; set;}
public: __property string* get_CodedCharacterSet();
public: __property void set_CodedCharacterSet(
   string* value
);
public:
property String^ CodedCharacterSet {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ColourCalibrationMatrixTable Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ColourCalibrationMatrixTable Property
Gets or sets Colour Calibration Matrix Table IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColourCalibrationMatrixTable As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.ColourCalibrationMatrixTable = value

value = instance.ColourCalibrationMatrixTable
public byte[] ColourCalibrationMatrixTable {get; set;}
public: __property byte[]* get_ColourCalibrationMatrixTable();
public: __property void set_ColourCalibrationMatrixTable(
   byte[]* value
);
public:
property array<byte>^ ColourCalibrationMatrixTable {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ColourPalette Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ColourPalette Property
Gets or sets Colour Palette IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColourPalette As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.ColourPalette = value

value = instance.ColourPalette
public byte[] ColourPalette {get; set;}
public: __property byte[]* get_ColourPalette();
public: __property void set_ColourPalette(
   byte[]* value
);
public:
property array<byte>^ ColourPalette {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ColourRepresentation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ColourRepresentation Property
Gets or sets Colour Representation IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColourRepresentation As Nullable(Of ImGearIPTCColourRepresentation)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCColourRepresentation)

instance.ColourRepresentation = value

value = instance.ColourRepresentation
public Nullable<ImGearIPTCColourRepresentation> ColourRepresentation {get; set;}
public: __property Nullable<ImGearIPTCColourRepresentation> get_ColourRepresentation();
public: __property void set_ColourRepresentation(
   Nullable<ImGearIPTCColourRepresentation> value
);
public:
property Nullable<ImGearIPTCColourRepresentation> ColourRepresentation {
   Nullable<ImGearIPTCColourRepresentation> get();
   void set (    Nullable<ImGearIPTCColourRepresentation> value);
}

Property Value

Nullable (boxed) ImGearIPTCColourRepresentation structure value.
Remarks
This property accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCColourRepresentation Structure


ColourSequence Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ColourSequence Property
Gets or sets Colour Sequence IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColourSequence As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.ColourSequence = value

value = instance.ColourSequence
public byte[] ColourSequence {get; set;}
public: __property byte[]* get_ColourSequence();
public: __property void set_ColourSequence(
   byte[]* value
);
public:
property array<byte>^ ColourSequence {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ConfirmedObjectDataSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ConfirmedObjectDataSize Property
Gets or sets Confirmed Object Data Size IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConfirmedObjectDataSize As Nullable(Of ULong)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ULong)

instance.ConfirmedObjectDataSize = value

value = instance.ConfirmedObjectDataSize
public Nullable<ulong> ConfirmedObjectDataSize {get; set;}
public: __property Nullable<ulong> get_ConfirmedObjectDataSize();
public: __property void set_ConfirmedObjectDataSize(
   Nullable<ulong> value
);
public:
property Nullable<ulong> ConfirmedObjectDataSize {
   Nullable<ulong> get();
   void set (    Nullable<ulong> value);
}

Property Value

Nullable (boxed) ulong value.
Remarks
This property accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Contact Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Contact Property
Gets or sets Contact IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contact As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.Contact = value

value = instance.Contact
public string[] Contact {get; set;}
public: __property string*[]* get_Contact();
public: __property void set_Contact(
   string*[]* value
);
public:
property array<String^>^ Contact {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ContentLocationCode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ContentLocationCode Property
Gets or sets Content Location Code IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContentLocationCode As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ContentLocationCode = value

value = instance.ContentLocationCode
public string[] ContentLocationCode {get; set;}
public: __property string*[]* get_ContentLocationCode();
public: __property void set_ContentLocationCode(
   string*[]* value
);
public:
property array<String^>^ ContentLocationCode {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ContentLocationName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ContentLocationName Property
Gets or sets Content Location Name IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContentLocationName As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ContentLocationName = value

value = instance.ContentLocationName
public string[] ContentLocationName {get; set;}
public: __property string*[]* get_ContentLocationName();
public: __property void set_ContentLocationName(
   string*[]* value
);
public:
property array<String^>^ ContentLocationName {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


CopyrightNotice Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : CopyrightNotice Property
Gets or sets Copyright Notice IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CopyrightNotice As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.CopyrightNotice = value

value = instance.CopyrightNotice
public string CopyrightNotice {get; set;}
public: __property string* get_CopyrightNotice();
public: __property void set_CopyrightNotice(
   string* value
);
public:
property String^ CopyrightNotice {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


CountryPrimaryLocationCode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : CountryPrimaryLocationCode Property
Gets or sets Country Primary Location Code IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CountryPrimaryLocationCode As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.CountryPrimaryLocationCode = value

value = instance.CountryPrimaryLocationCode
public string[] CountryPrimaryLocationCode {get; set;}
public: __property string*[]* get_CountryPrimaryLocationCode();
public: __property void set_CountryPrimaryLocationCode(
   string*[]* value
);
public:
property array<String^>^ CountryPrimaryLocationCode {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


CountryPrimaryLocationName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : CountryPrimaryLocationName Property
Gets or sets Country Primary Location Name IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CountryPrimaryLocationName As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.CountryPrimaryLocationName = value

value = instance.CountryPrimaryLocationName
public string[] CountryPrimaryLocationName {get; set;}
public: __property string*[]* get_CountryPrimaryLocationName();
public: __property void set_CountryPrimaryLocationName(
   string*[]* value
);
public:
property array<String^>^ CountryPrimaryLocationName {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Credit Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Credit Property
Gets or sets Credit IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Credit As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Credit = value

value = instance.Credit
public string Credit {get; set;}
public: __property string* get_Credit();
public: __property void set_Credit(
   string* value
);
public:
property String^ Credit {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


DataCompressionMethod Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : DataCompressionMethod Property
Gets or sets Data Compression method IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataCompressionMethod As Nullable(Of ImGearIPTCDataCompressionMethod)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCDataCompressionMethod)

instance.DataCompressionMethod = value

value = instance.DataCompressionMethod
public Nullable<ImGearIPTCDataCompressionMethod> DataCompressionMethod {get; set;}
public: __property Nullable<ImGearIPTCDataCompressionMethod> get_DataCompressionMethod();
public: __property void set_DataCompressionMethod(
   Nullable<ImGearIPTCDataCompressionMethod> value
);
public:
property Nullable<ImGearIPTCDataCompressionMethod> DataCompressionMethod {
   Nullable<ImGearIPTCDataCompressionMethod> get();
   void set (    Nullable<ImGearIPTCDataCompressionMethod> value);
}

Property Value

Nullable (boxed) ImGearIPTCDataCompressionMethod enumeration value.
Remarks
This property accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCDataCompressionMethod Enumeration


DateCreated Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : DateCreated Property
Gets or sets Date Created IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateCreated As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.DateCreated = value

value = instance.DateCreated
public string DateCreated {get; set;}
public: __property string* get_DateCreated();
public: __property void set_DateCreated(
   string* value
);
public:
property String^ DateCreated {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


DateSent Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : DateSent Property
Gets or sets Date Sent IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateSent As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.DateSent = value

value = instance.DateSent
public string DateSent {get; set;}
public: __property string* get_DateSent();
public: __property void set_DateSent(
   string* value
);
public:
property String^ DateSent {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Destination Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Destination Property
Gets or sets Destination IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.Destination = value

value = instance.Destination
public string[] Destination {get; set;}
public: __property string*[]* get_Destination();
public: __property void set_Destination(
   string*[]* value
);
public:
property array<String^>^ Destination {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


DigitalCreationDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : DigitalCreationDate Property
Gets or sets Digital Creation Date IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DigitalCreationDate As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.DigitalCreationDate = value

value = instance.DigitalCreationDate
public string DigitalCreationDate {get; set;}
public: __property string* get_DigitalCreationDate();
public: __property void set_DigitalCreationDate(
   string* value
);
public:
property String^ DigitalCreationDate {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


DigitalCreationTime Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : DigitalCreationTime Property
Gets or sets Digital Creation Time IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DigitalCreationTime As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.DigitalCreationTime = value

value = instance.DigitalCreationTime
public string DigitalCreationTime {get; set;}
public: __property string* get_DigitalCreationTime();
public: __property void set_DigitalCreationTime(
   string* value
);
public:
property String^ DigitalCreationTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


EditorialUpdate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : EditorialUpdate Property
Gets or sets Editorial Update IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EditorialUpdate As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.EditorialUpdate = value

value = instance.EditorialUpdate
public string EditorialUpdate {get; set;}
public: __property string* get_EditorialUpdate();
public: __property void set_EditorialUpdate(
   string* value
);
public:
property String^ EditorialUpdate {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


EditStatus Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : EditStatus Property
Gets or sets Edit Status IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EditStatus As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.EditStatus = value

value = instance.EditStatus
public string EditStatus {get; set;}
public: __property string* get_EditStatus();
public: __property void set_EditStatus(
   string* value
);
public:
property String^ EditStatus {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


EndPoints Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : EndPoints Property
Gets or sets End Points IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoints As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.EndPoints = value

value = instance.EndPoints
public byte[] EndPoints {get; set;}
public: __property byte[]* get_EndPoints();
public: __property void set_EndPoints(
   byte[]* value
);
public:
property array<byte>^ EndPoints {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


EnvelopeNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : EnvelopeNumber Property
Gets or sets Envelope Number IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnvelopeNumber As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.EnvelopeNumber = value

value = instance.EnvelopeNumber
public string EnvelopeNumber {get; set;}
public: __property string* get_EnvelopeNumber();
public: __property void set_EnvelopeNumber(
   string* value
);
public:
property String^ EnvelopeNumber {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


EnvelopePriority Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : EnvelopePriority Property
Gets or sets Envelope Priority IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnvelopePriority As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.EnvelopePriority = value

value = instance.EnvelopePriority
public string EnvelopePriority {get; set;}
public: __property string* get_EnvelopePriority();
public: __property void set_EnvelopePriority(
   string* value
);
public:
property String^ EnvelopePriority {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ExcursionTolerance Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ExcursionTolerance Property
Gets or sets Excursion Tolerance IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExcursionTolerance As Nullable(Of ImGearIPTCExcursionTolerance)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCExcursionTolerance)

instance.ExcursionTolerance = value

value = instance.ExcursionTolerance
public Nullable<ImGearIPTCExcursionTolerance> ExcursionTolerance {get; set;}
public: __property Nullable<ImGearIPTCExcursionTolerance> get_ExcursionTolerance();
public: __property void set_ExcursionTolerance(
   Nullable<ImGearIPTCExcursionTolerance> value
);
public:
property Nullable<ImGearIPTCExcursionTolerance> ExcursionTolerance {
   Nullable<ImGearIPTCExcursionTolerance> get();
   void set (    Nullable<ImGearIPTCExcursionTolerance> value);
}

Property Value

Nullable (boxed) ImGearIPTCExcursionTolerance enumeration value.
Remarks
This property accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCExcursionTolerance Enumeration


ExpirationDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ExpirationDate Property
Gets or sets Expiration Date IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExpirationDate As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ExpirationDate = value

value = instance.ExpirationDate
public string ExpirationDate {get; set;}
public: __property string* get_ExpirationDate();
public: __property void set_ExpirationDate(
   string* value
);
public:
property String^ ExpirationDate {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ExpirationTime Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ExpirationTime Property
Gets or sets Expiration Time IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExpirationTime As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ExpirationTime = value

value = instance.ExpirationTime
public string ExpirationTime {get; set;}
public: __property string* get_ExpirationTime();
public: __property void set_ExpirationTime(
   string* value
);
public:
property String^ ExpirationTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


FileFormat Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : FileFormat Property
Gets or sets File Format IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileFormat As Nullable(Of ImGearIPTCFileFormatID)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCFileFormatID)

instance.FileFormat = value

value = instance.FileFormat
public Nullable<ImGearIPTCFileFormatID> FileFormat {get; set;}
public: __property Nullable<ImGearIPTCFileFormatID> get_FileFormat();
public: __property void set_FileFormat(
   Nullable<ImGearIPTCFileFormatID> value
);
public:
property Nullable<ImGearIPTCFileFormatID> FileFormat {
   Nullable<ImGearIPTCFileFormatID> get();
   void set (    Nullable<ImGearIPTCFileFormatID> value);
}

Property Value

Nullable (boxed) ImGearIPTCFileFormatID enumeration value.
Remarks
This property accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCFileFormatID Enumeration


FileFormatVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : FileFormatVersion Property
Gets or sets File Format Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileFormatVersion As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.FileFormatVersion = value

value = instance.FileFormatVersion
public Nullable<ushort> FileFormatVersion {get; set;}
public: __property Nullable<ushort> get_FileFormatVersion();
public: __property void set_FileFormatVersion(
   Nullable<ushort> value
);
public:
property Nullable<ushort> FileFormatVersion {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


FixtureIdentifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : FixtureIdentifier Property
Gets or sets Fixture Identifier IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FixtureIdentifier As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.FixtureIdentifier = value

value = instance.FixtureIdentifier
public string FixtureIdentifier {get; set;}
public: __property string* get_FixtureIdentifier();
public: __property void set_FixtureIdentifier(
   string* value
);
public:
property String^ FixtureIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


GammaCompensatedValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : GammaCompensatedValue Property
Gets or sets Gamma Compensated Value IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GammaCompensatedValue As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.GammaCompensatedValue = value

value = instance.GammaCompensatedValue
public Nullable<ushort> GammaCompensatedValue {get; set;}
public: __property Nullable<ushort> get_GammaCompensatedValue();
public: __property void set_GammaCompensatedValue(
   Nullable<ushort> value
);
public:
property Nullable<ushort> GammaCompensatedValue {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Headline Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Headline Property
Gets or sets Headline IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Headline As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Headline = value

value = instance.Headline
public string Headline {get; set;}
public: __property string* get_Headline();
public: __property void set_Headline(
   string* value
);
public:
property String^ Headline {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ICCInputColourProfile Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ICCInputColourProfile Property
Gets or sets ICC Input Colour Profile IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ICCInputColourProfile As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.ICCInputColourProfile = value

value = instance.ICCInputColourProfile
public byte[] ICCInputColourProfile {get; set;}
public: __property byte[]* get_ICCInputColourProfile();
public: __property void set_ICCInputColourProfile(
   byte[]* value
);
public:
property array<byte>^ ICCInputColourProfile {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ImageOrientation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ImageOrientation Property
Gets or sets Image Orientation IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageOrientation As Nullable(Of ImGearIPTCImageOrientation)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCImageOrientation)

instance.ImageOrientation = value

value = instance.ImageOrientation
public Nullable<ImGearIPTCImageOrientation> ImageOrientation {get; set;}
public: __property Nullable<ImGearIPTCImageOrientation> get_ImageOrientation();
public: __property void set_ImageOrientation(
   Nullable<ImGearIPTCImageOrientation> value
);
public:
property Nullable<ImGearIPTCImageOrientation> ImageOrientation {
   Nullable<ImGearIPTCImageOrientation> get();
   void set (    Nullable<ImGearIPTCImageOrientation> value);
}

Property Value

Nullable (boxed) ImGearIPTCImageOrientation enumeration value.
Remarks
This property accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCImageOrientation Enumeration


ImageRotation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ImageRotation Property
Gets or sets Image Rotation IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageRotation As Nullable(Of ImGearIPTCImageRotation)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCImageRotation)

instance.ImageRotation = value

value = instance.ImageRotation
public Nullable<ImGearIPTCImageRotation> ImageRotation {get; set;}
public: __property Nullable<ImGearIPTCImageRotation> get_ImageRotation();
public: __property void set_ImageRotation(
   Nullable<ImGearIPTCImageRotation> value
);
public:
property Nullable<ImGearIPTCImageRotation> ImageRotation {
   Nullable<ImGearIPTCImageRotation> get();
   void set (    Nullable<ImGearIPTCImageRotation> value);
}

Property Value

Nullable (boxed) ImGearIPTCImageRotation enumeration value.
Remarks
This property accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCImageRotation Enumeration


ImageType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ImageType Property
Gets or sets Image Type IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageType As Nullable(Of ImGearIPTCImageType)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCImageType)

instance.ImageType = value

value = instance.ImageType
public Nullable<ImGearIPTCImageType> ImageType {get; set;}
public: __property Nullable<ImGearIPTCImageType> get_ImageType();
public: __property void set_ImageType(
   Nullable<ImGearIPTCImageType> value
);
public:
property Nullable<ImGearIPTCImageType> ImageType {
   Nullable<ImGearIPTCImageType> get();
   void set (    Nullable<ImGearIPTCImageType> value);
}

Property Value

Nullable (boxed) ImGearIPTCImageType structure value.
Remarks
This property accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCImageType Structure


InterchangeColourSpace Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : InterchangeColourSpace Property
Gets or sets Interchange Colour Space IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InterchangeColourSpace As Nullable(Of ImGearIPTCInterchangeColourSpace)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCInterchangeColourSpace)

instance.InterchangeColourSpace = value

value = instance.InterchangeColourSpace
public Nullable<ImGearIPTCInterchangeColourSpace> InterchangeColourSpace {get; set;}
public: __property Nullable<ImGearIPTCInterchangeColourSpace> get_InterchangeColourSpace();
public: __property void set_InterchangeColourSpace(
   Nullable<ImGearIPTCInterchangeColourSpace> value
);
public:
property Nullable<ImGearIPTCInterchangeColourSpace> InterchangeColourSpace {
   Nullable<ImGearIPTCInterchangeColourSpace> get();
   void set (    Nullable<ImGearIPTCInterchangeColourSpace> value);
}

Property Value

Nullable (boxed) ImGearIPTCInterchangeColourSpace enumeration value.
Remarks
This property accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCInterchangeColourSpace Enumeration


Keywords Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Keywords Property
Gets or sets Keywords IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Keywords As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.Keywords = value

value = instance.Keywords
public string[] Keywords {get; set;}
public: __property string*[]* get_Keywords();
public: __property void set_Keywords(
   string*[]* value
);
public:
property array<String^>^ Keywords {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


LanguageIdentifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : LanguageIdentifier Property
Gets or sets Language Identifier IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LanguageIdentifier As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.LanguageIdentifier = value

value = instance.LanguageIdentifier
public string LanguageIdentifier {get; set;}
public: __property string* get_LanguageIdentifier();
public: __property void set_LanguageIdentifier(
   string* value
);
public:
property String^ LanguageIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


LookupTable Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : LookupTable Property
Gets or sets Lookup Table IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LookupTable As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.LookupTable = value

value = instance.LookupTable
public byte[] LookupTable {get; set;}
public: __property byte[]* get_LookupTable();
public: __property void set_LookupTable(
   byte[]* value
);
public:
property array<byte>^ LookupTable {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


MaximumDensityRange Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : MaximumDensityRange Property
Gets or sets Maximum Density Range IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumDensityRange As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.MaximumDensityRange = value

value = instance.MaximumDensityRange
public Nullable<ushort> MaximumDensityRange {get; set;}
public: __property Nullable<ushort> get_MaximumDensityRange();
public: __property void set_MaximumDensityRange(
   Nullable<ushort> value
);
public:
property Nullable<ushort> MaximumDensityRange {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


MaximumObjectDataSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : MaximumObjectDataSize Property
Gets or sets Maximum Object Data Size IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumObjectDataSize As Nullable(Of ULong)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ULong)

instance.MaximumObjectDataSize = value

value = instance.MaximumObjectDataSize
public Nullable<ulong> MaximumObjectDataSize {get; set;}
public: __property Nullable<ulong> get_MaximumObjectDataSize();
public: __property void set_MaximumObjectDataSize(
   Nullable<ulong> value
);
public:
property Nullable<ulong> MaximumObjectDataSize {
   Nullable<ulong> get();
   void set (    Nullable<ulong> value);
}

Property Value

Nullable (boxed) ulong value.
Remarks
This property accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


MaxSubfileSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : MaxSubfileSize Property
Gets or sets Max Subfile Size IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxSubfileSize As Nullable(Of ULong)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ULong)

instance.MaxSubfileSize = value

value = instance.MaxSubfileSize
public Nullable<ulong> MaxSubfileSize {get; set;}
public: __property Nullable<ulong> get_MaxSubfileSize();
public: __property void set_MaxSubfileSize(
   Nullable<ulong> value
);
public:
property Nullable<ulong> MaxSubfileSize {
   Nullable<ulong> get();
   void set (    Nullable<ulong> value);
}

Property Value

Nullable (boxed) ulong value.
Remarks
This property accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ModelVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ModelVersion Property
Gets or sets Model Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModelVersion As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.ModelVersion = value

value = instance.ModelVersion
public Nullable<ushort> ModelVersion {get; set;}
public: __property Nullable<ushort> get_ModelVersion();
public: __property void set_ModelVersion(
   Nullable<ushort> value
);
public:
property Nullable<ushort> ModelVersion {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


NumberOfBitsPerSample Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : NumberOfBitsPerSample Property
Gets or sets Number Of Bits Per Sample IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfBitsPerSample As Nullable(Of Byte)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of Byte)

instance.NumberOfBitsPerSample = value

value = instance.NumberOfBitsPerSample
public Nullable<byte> NumberOfBitsPerSample {get; set;}
public: __property Nullable<byte> get_NumberOfBitsPerSample();
public: __property void set_NumberOfBitsPerSample(
   Nullable<byte> value
);
public:
property Nullable<byte> NumberOfBitsPerSample {
   Nullable<byte> get();
   void set (    Nullable<byte> value);
}

Property Value

Nullable (boxed) byte value.
Remarks
This property accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


NumberOfIndexEntries Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : NumberOfIndexEntries Property
Gets or sets Number Of Index Entries IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfIndexEntries As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.NumberOfIndexEntries = value

value = instance.NumberOfIndexEntries
public Nullable<ushort> NumberOfIndexEntries {get; set;}
public: __property Nullable<ushort> get_NumberOfIndexEntries();
public: __property void set_NumberOfIndexEntries(
   Nullable<ushort> value
);
public:
property Nullable<ushort> NumberOfIndexEntries {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


NumberOfLines Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : NumberOfLines Property
Gets or sets Number Of Line IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfLines As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.NumberOfLines = value

value = instance.NumberOfLines
public Nullable<ushort> NumberOfLines {get; set;}
public: __property Nullable<ushort> get_NumberOfLines();
public: __property void set_NumberOfLines(
   Nullable<ushort> value
);
public:
property Nullable<ushort> NumberOfLines {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ObjectAttributeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectAttributeReference Property
Gets or sets Object Attribute Reference IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectAttributeReference As ImGearIPTCObjectAttributeReference()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As ImGearIPTCObjectAttributeReference

instance.ObjectAttributeReference = value

value = instance.ObjectAttributeReference
public ImGearIPTCObjectAttributeReference[] ObjectAttributeReference {get; set;}
public: __property ImGearIPTCObjectAttributeReference[]* get_ObjectAttributeReference();
public: __property void set_ObjectAttributeReference(
   ImGearIPTCObjectAttributeReference[]* value
);
public:
property array<ImGearIPTCObjectAttributeReference>^ ObjectAttributeReference {
   array<ImGearIPTCObjectAttributeReference>^ get();
   void set (    array<ImGearIPTCObjectAttributeReference>^ value);
}

Property Value

ImGearIPTCObjectAttributeReference structure[] array.
Remarks
This property accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCObjectAttributeReference Structure


ObjectCycle Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectCycle Property
Gets or sets Object Cycle IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectCycle As Nullable(Of ImGearIPTCObjectCycle)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCObjectCycle)

instance.ObjectCycle = value

value = instance.ObjectCycle
public Nullable<ImGearIPTCObjectCycle> ObjectCycle {get; set;}
public: __property Nullable<ImGearIPTCObjectCycle> get_ObjectCycle();
public: __property void set_ObjectCycle(
   Nullable<ImGearIPTCObjectCycle> value
);
public:
property Nullable<ImGearIPTCObjectCycle> ObjectCycle {
   Nullable<ImGearIPTCObjectCycle> get();
   void set (    Nullable<ImGearIPTCObjectCycle> value);
}

Property Value

Nullable (boxed) ImGearIPTCObjectCycle enumeration value.
Remarks
This property accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCObjectCycle Enumeration


ObjectDataPreviewData Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectDataPreviewData Property
Gets or sets Object Data Preview Data IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectDataPreviewData As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.ObjectDataPreviewData = value

value = instance.ObjectDataPreviewData
public byte[] ObjectDataPreviewData {get; set;}
public: __property byte[]* get_ObjectDataPreviewData();
public: __property void set_ObjectDataPreviewData(
   byte[]* value
);
public:
property array<byte>^ ObjectDataPreviewData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ObjectDataPreviewFileFormat Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectDataPreviewFileFormat Property
Gets or sets ObjectData Preview File Format DataSet (2:200).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectDataPreviewFileFormat As Nullable(Of ImGearIPTCFileFormatID)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCFileFormatID)

instance.ObjectDataPreviewFileFormat = value

value = instance.ObjectDataPreviewFileFormat
public Nullable<ImGearIPTCFileFormatID> ObjectDataPreviewFileFormat {get; set;}
public: __property Nullable<ImGearIPTCFileFormatID> get_ObjectDataPreviewFileFormat();
public: __property void set_ObjectDataPreviewFileFormat(
   Nullable<ImGearIPTCFileFormatID> value
);
public:
property Nullable<ImGearIPTCFileFormatID> ObjectDataPreviewFileFormat {
   Nullable<ImGearIPTCFileFormatID> get();
   void set (    Nullable<ImGearIPTCFileFormatID> value);
}

Property Value

Nullable (boxed) ImGearIPTCFileFormatID enumeration value.
Remarks
This property accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ObjectDataPreviewFileFormatVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectDataPreviewFileFormatVersion Property
Gets or sets Object Data Preview File Format Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectDataPreviewFileFormatVersion As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.ObjectDataPreviewFileFormatVersion = value

value = instance.ObjectDataPreviewFileFormatVersion
public Nullable<ushort> ObjectDataPreviewFileFormatVersion {get; set;}
public: __property Nullable<ushort> get_ObjectDataPreviewFileFormatVersion();
public: __property void set_ObjectDataPreviewFileFormatVersion(
   Nullable<ushort> value
);
public:
property Nullable<ushort> ObjectDataPreviewFileFormatVersion {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ObjectDataSizeAnnounced Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectDataSizeAnnounced Property
Gets or sets Object Data Size Announced IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectDataSizeAnnounced As Nullable(Of ULong)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ULong)

instance.ObjectDataSizeAnnounced = value

value = instance.ObjectDataSizeAnnounced
public Nullable<ulong> ObjectDataSizeAnnounced {get; set;}
public: __property Nullable<ulong> get_ObjectDataSizeAnnounced();
public: __property void set_ObjectDataSizeAnnounced(
   Nullable<ulong> value
);
public:
property Nullable<ulong> ObjectDataSizeAnnounced {
   Nullable<ulong> get();
   void set (    Nullable<ulong> value);
}

Property Value

Nullable (boxed) ulong value.
Remarks
This property accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCMetadata Class


ObjectName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectName Property
Gets or sets Object Name IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectName As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ObjectName = value

value = instance.ObjectName
public string ObjectName {get; set;}
public: __property string* get_ObjectName();
public: __property void set_ObjectName(
   string* value
);
public:
property String^ ObjectName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ObjectTypeReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ObjectTypeReference Property
Gets or sets Object Type Reference IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectTypeReference As Nullable(Of ImGearIPTCObjectTypeReference)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCObjectTypeReference)

instance.ObjectTypeReference = value

value = instance.ObjectTypeReference
public Nullable<ImGearIPTCObjectTypeReference> ObjectTypeReference {get; set;}
public: __property Nullable<ImGearIPTCObjectTypeReference> get_ObjectTypeReference();
public: __property void set_ObjectTypeReference(
   Nullable<ImGearIPTCObjectTypeReference> value
);
public:
property Nullable<ImGearIPTCObjectTypeReference> ObjectTypeReference {
   Nullable<ImGearIPTCObjectTypeReference> get();
   void set (    Nullable<ImGearIPTCObjectTypeReference> value);
}

Property Value

Nullable (boxed) ImGearIPTCObjectTypeReference structure value.
Remarks
This property accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCObjectTypeReference Structure


OriginalTransmissionReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : OriginalTransmissionReference Property
Gets or sets Original Transmission Reference IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OriginalTransmissionReference As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.OriginalTransmissionReference = value

value = instance.OriginalTransmissionReference
public string OriginalTransmissionReference {get; set;}
public: __property string* get_OriginalTransmissionReference();
public: __property void set_OriginalTransmissionReference(
   string* value
);
public:
property String^ OriginalTransmissionReference {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


OriginatingProgram Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : OriginatingProgram Property
Gets or sets Originating Program IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OriginatingProgram As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.OriginatingProgram = value

value = instance.OriginatingProgram
public string OriginatingProgram {get; set;}
public: __property string* get_OriginatingProgram();
public: __property void set_OriginatingProgram(
   string* value
);
public:
property String^ OriginatingProgram {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


PictureNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : PictureNumber Property
Gets or sets Picture Number IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PictureNumber As Nullable(Of ImGearIPTCPictureNumber)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCPictureNumber)

instance.PictureNumber = value

value = instance.PictureNumber
public Nullable<ImGearIPTCPictureNumber> PictureNumber {get; set;}
public: __property Nullable<ImGearIPTCPictureNumber> get_PictureNumber();
public: __property void set_PictureNumber(
   Nullable<ImGearIPTCPictureNumber> value
);
public:
property Nullable<ImGearIPTCPictureNumber> PictureNumber {
   Nullable<ImGearIPTCPictureNumber> get();
   void set (    Nullable<ImGearIPTCPictureNumber> value);
}

Property Value

Nullable (boxed) ImGearIPTCPictureNumber structure value.
Remarks
This property accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCPictureNumber Structure


PixelSizeInScanningDirection Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : PixelSizeInScanningDirection Property
Gets or sets Pixel Size In Scanning Direction IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelSizeInScanningDirection As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.PixelSizeInScanningDirection = value

value = instance.PixelSizeInScanningDirection
public Nullable<ushort> PixelSizeInScanningDirection {get; set;}
public: __property Nullable<ushort> get_PixelSizeInScanningDirection();
public: __property void set_PixelSizeInScanningDirection(
   Nullable<ushort> value
);
public:
property Nullable<ushort> PixelSizeInScanningDirection {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


PixelSizePerpendicularToScanningDirection Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : PixelSizePerpendicularToScanningDirection Property
Gets or sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelSizePerpendicularToScanningDirection As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.PixelSizePerpendicularToScanningDirection = value

value = instance.PixelSizePerpendicularToScanningDirection
public Nullable<ushort> PixelSizePerpendicularToScanningDirection {get; set;}
public: __property Nullable<ushort> get_PixelSizePerpendicularToScanningDirection();
public: __property void set_PixelSizePerpendicularToScanningDirection(
   Nullable<ushort> value
);
public:
property Nullable<ushort> PixelSizePerpendicularToScanningDirection {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


PixelsPerLine Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : PixelsPerLine Property
Gets or sets Pixels Per Line IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelsPerLine As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.PixelsPerLine = value

value = instance.PixelsPerLine
public Nullable<ushort> PixelsPerLine {get; set;}
public: __property Nullable<ushort> get_PixelsPerLine();
public: __property void set_PixelsPerLine(
   Nullable<ushort> value
);
public:
property Nullable<ushort> PixelsPerLine {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ProductID Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ProductID Property
Gets or sets ProductID IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProductID As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ProductID = value

value = instance.ProductID
public string[] ProductID {get; set;}
public: __property string*[]* get_ProductID();
public: __property void set_ProductID(
   string*[]* value
);
public:
property array<String^>^ ProductID {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ProgramVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ProgramVersion Property
Gets or sets Program Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProgramVersion As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ProgramVersion = value

value = instance.ProgramVersion
public string ProgramVersion {get; set;}
public: __property string* get_ProgramVersion();
public: __property void set_ProgramVersion(
   string* value
);
public:
property String^ ProgramVersion {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ProvinceState Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ProvinceState Property
Gets or sets Province State IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProvinceState As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ProvinceState = value

value = instance.ProvinceState
public string ProvinceState {get; set;}
public: __property string* get_ProvinceState();
public: __property void set_ProvinceState(
   string* value
);
public:
property String^ ProvinceState {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


QuantisationMethod Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : QuantisationMethod Property
Gets or sets Quantisation method IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property QuantisationMethod As Nullable(Of ImGearIPTCQuantisationMethod)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCQuantisationMethod)

instance.QuantisationMethod = value

value = instance.QuantisationMethod
public Nullable<ImGearIPTCQuantisationMethod> QuantisationMethod {get; set;}
public: __property Nullable<ImGearIPTCQuantisationMethod> get_QuantisationMethod();
public: __property void set_QuantisationMethod(
   Nullable<ImGearIPTCQuantisationMethod> value
);
public:
property Nullable<ImGearIPTCQuantisationMethod> QuantisationMethod {
   Nullable<ImGearIPTCQuantisationMethod> get();
   void set (    Nullable<ImGearIPTCQuantisationMethod> value);
}

Property Value

Nullable (boxed) ImGearIPTCQuantisationMethod enumeration value.
Remarks
This property accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCQuantisationMethod Enumeration


RasterizedCaption Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : RasterizedCaption Property
Gets or sets Rasterized Caption IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RasterizedCaption As Byte()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As Byte

instance.RasterizedCaption = value

value = instance.RasterizedCaption
public byte[] RasterizedCaption {get; set;}
public: __property byte[]* get_RasterizedCaption();
public: __property void set_RasterizedCaption(
   byte[]* value
);
public:
property array<byte>^ RasterizedCaption {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Record2Version Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Record2Version Property
Gets or sets Record2 Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Record2Version As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.Record2Version = value

value = instance.Record2Version
public Nullable<ushort> Record2Version {get; set;}
public: __property Nullable<ushort> get_Record2Version();
public: __property void set_Record2Version(
   Nullable<ushort> value
);
public:
property Nullable<ushort> Record2Version {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Record3Version Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Record3Version Property
Gets or sets Record3 Version IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Record3Version As Nullable(Of UShort)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of UShort)

instance.Record3Version = value

value = instance.Record3Version
public Nullable<ushort> Record3Version {get; set;}
public: __property Nullable<ushort> get_Record3Version();
public: __property void set_Record3Version(
   Nullable<ushort> value
);
public:
property Nullable<ushort> Record3Version {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ReferenceDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ReferenceDate Property
Gets or sets Reference Date IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceDate As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ReferenceDate = value

value = instance.ReferenceDate
public string[] ReferenceDate {get; set;}
public: __property string*[]* get_ReferenceDate();
public: __property void set_ReferenceDate(
   string*[]* value
);
public:
property array<String^>^ ReferenceDate {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ReferenceNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ReferenceNumber Property
Gets or sets Reference Number IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceNumber As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ReferenceNumber = value

value = instance.ReferenceNumber
public string[] ReferenceNumber {get; set;}
public: __property string*[]* get_ReferenceNumber();
public: __property void set_ReferenceNumber(
   string*[]* value
);
public:
property array<String^>^ ReferenceNumber {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ReferenceService Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ReferenceService Property
Gets or sets Reference Service IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceService As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.ReferenceService = value

value = instance.ReferenceService
public string[] ReferenceService {get; set;}
public: __property string*[]* get_ReferenceService();
public: __property void set_ReferenceService(
   string*[]* value
);
public:
property array<String^>^ ReferenceService {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ReleaseDate Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ReleaseDate Property
Gets or sets Release Date IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReleaseDate As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ReleaseDate = value

value = instance.ReleaseDate
public string ReleaseDate {get; set;}
public: __property string* get_ReleaseDate();
public: __property void set_ReleaseDate(
   string* value
);
public:
property String^ ReleaseDate {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


ReleaseTime Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ReleaseTime Property
Gets or sets Release Time IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReleaseTime As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ReleaseTime = value

value = instance.ReleaseTime
public string ReleaseTime {get; set;}
public: __property string* get_ReleaseTime();
public: __property void set_ReleaseTime(
   string* value
);
public:
property String^ ReleaseTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SamplingStructure Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SamplingStructure Property
Gets or sets Sampling structure IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SamplingStructure As Nullable(Of ImGearIPTCSamplingStructure)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCSamplingStructure)

instance.SamplingStructure = value

value = instance.SamplingStructure
public Nullable<ImGearIPTCSamplingStructure> SamplingStructure {get; set;}
public: __property Nullable<ImGearIPTCSamplingStructure> get_SamplingStructure();
public: __property void set_SamplingStructure(
   Nullable<ImGearIPTCSamplingStructure> value
);
public:
property Nullable<ImGearIPTCSamplingStructure> SamplingStructure {
   Nullable<ImGearIPTCSamplingStructure> get();
   void set (    Nullable<ImGearIPTCSamplingStructure> value);
}

Property Value

Nullable (boxed) ImGearIPTCSamplingStructure enumeration value.
Remarks
This property accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCSamplingStructure Enumeration


ScanningDirection Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ScanningDirection Property
Gets or sets Scanning Direction IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScanningDirection As Nullable(Of ImGearIPTCScanningDirection)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCScanningDirection)

instance.ScanningDirection = value

value = instance.ScanningDirection
public Nullable<ImGearIPTCScanningDirection> ScanningDirection {get; set;}
public: __property Nullable<ImGearIPTCScanningDirection> get_ScanningDirection();
public: __property void set_ScanningDirection(
   Nullable<ImGearIPTCScanningDirection> value
);
public:
property Nullable<ImGearIPTCScanningDirection> ScanningDirection {
   Nullable<ImGearIPTCScanningDirection> get();
   void set (    Nullable<ImGearIPTCScanningDirection> value);
}

Property Value

Nullable (boxed) ImGearIPTCScanningDirection enumeration value.
Remarks
This property accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCScanningDirection Enumeration


ServiceIdentifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : ServiceIdentifier Property
Gets or sets Service Identifier IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ServiceIdentifier As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.ServiceIdentifier = value

value = instance.ServiceIdentifier
public string ServiceIdentifier {get; set;}
public: __property string* get_ServiceIdentifier();
public: __property void set_ServiceIdentifier(
   string* value
);
public:
property String^ ServiceIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SizeMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SizeMode Property
Gets or sets Size Mode IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SizeMode As Nullable(Of ImGearIPTCSizeMode)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCSizeMode)

instance.SizeMode = value

value = instance.SizeMode
public Nullable<ImGearIPTCSizeMode> SizeMode {get; set;}
public: __property Nullable<ImGearIPTCSizeMode> get_SizeMode();
public: __property void set_SizeMode(
   Nullable<ImGearIPTCSizeMode> value
);
public:
property Nullable<ImGearIPTCSizeMode> SizeMode {
   Nullable<ImGearIPTCSizeMode> get();
   void set (    Nullable<ImGearIPTCSizeMode> value);
}

Property Value

Nullable (boxed) ImGearIPTCSizeMode enumeration value.
Remarks
This property accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCSizeMode Enumeration


Source Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Source Property
Gets or sets Source IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Source As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Source = value

value = instance.Source
public string Source {get; set;}
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
public:
property String^ Source {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SpecialInstructions Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SpecialInstructions Property
Gets or sets Special Instructions IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpecialInstructions As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.SpecialInstructions = value

value = instance.SpecialInstructions
public string SpecialInstructions {get; set;}
public: __property string* get_SpecialInstructions();
public: __property void set_SpecialInstructions(
   string* value
);
public:
property String^ SpecialInstructions {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SubjectReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SubjectReference Property
Gets or sets Subject Reference IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectReference As ImGearIPTCSubjectReference()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As ImGearIPTCSubjectReference

instance.SubjectReference = value

value = instance.SubjectReference
public ImGearIPTCSubjectReference[] SubjectReference {get; set;}
public: __property ImGearIPTCSubjectReference[]* get_SubjectReference();
public: __property void set_SubjectReference(
   ImGearIPTCSubjectReference[]* value
);
public:
property array<ImGearIPTCSubjectReference>^ SubjectReference {
   array<ImGearIPTCSubjectReference>^ get();
   void set (    array<ImGearIPTCSubjectReference>^ value);
}

Property Value

ImGearIPTCSubjectReference structure[] array.
Remarks
This property accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCSubjectReference Structure


Sublocation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Sublocation Property
Gets or sets Sublocation IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sublocation As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Sublocation = value

value = instance.Sublocation
public string Sublocation {get; set;}
public: __property string* get_Sublocation();
public: __property void set_Sublocation(
   string* value
);
public:
property String^ Sublocation {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SupplementalCategory Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SupplementalCategory Property
Gets or sets Supplemental Category IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementalCategory As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.SupplementalCategory = value

value = instance.SupplementalCategory
public string[] SupplementalCategory {get; set;}
public: __property string*[]* get_SupplementalCategory();
public: __property void set_SupplementalCategory(
   string*[]* value
);
public:
property array<String^>^ SupplementalCategory {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


SupplementType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : SupplementType Property
Gets or sets Supplement Type IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementType As Nullable(Of ImGearIPTCSupplementType)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCSupplementType)

instance.SupplementType = value

value = instance.SupplementType
public Nullable<ImGearIPTCSupplementType> SupplementType {get; set;}
public: __property Nullable<ImGearIPTCSupplementType> get_SupplementType();
public: __property void set_SupplementType(
   Nullable<ImGearIPTCSupplementType> value
);
public:
property Nullable<ImGearIPTCSupplementType> SupplementType {
   Nullable<ImGearIPTCSupplementType> get();
   void set (    Nullable<ImGearIPTCSupplementType> value);
}

Property Value

Nullable (boxed) ImGearIPTCSupplementType enumeration value.
Remarks
This property accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCSupplementType Enumeration


TimeCreated Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : TimeCreated Property
Gets or sets Time Created IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeCreated As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.TimeCreated = value

value = instance.TimeCreated
public string TimeCreated {get; set;}
public: __property string* get_TimeCreated();
public: __property void set_TimeCreated(
   string* value
);
public:
property String^ TimeCreated {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


TimeSent Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : TimeSent Property
Gets or sets Time Sent IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeSent As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.TimeSent = value

value = instance.TimeSent
public string TimeSent {get; set;}
public: __property string* get_TimeSent();
public: __property void set_TimeSent(
   string* value
);
public:
property String^ TimeSent {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


UNO Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : UNO Property
Gets or sets UNO IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UNO As Nullable(Of ImGearIPTCUNO)
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As Nullable(Of ImGearIPTCUNO)

instance.UNO = value

value = instance.UNO
public Nullable<ImGearIPTCUNO> UNO {get; set;}
public: __property Nullable<ImGearIPTCUNO> get_UNO();
public: __property void set_UNO(
   Nullable<ImGearIPTCUNO> value
);
public:
property Nullable<ImGearIPTCUNO> UNO {
   Nullable<ImGearIPTCUNO> get();
   void set (    Nullable<ImGearIPTCUNO> value);
}

Property Value

Nullable (boxed) ImGearIPTCUNO structure object.
Remarks
This property accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members
ImGearIPTCUNO Structure


Urgency Property (ImGearIPTCMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Urgency Property
Gets or sets Urgency IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Urgency As String
'Usage

Dim instance As ImGearIPTCMetadata
Dim value As String

instance.Urgency = value

value = instance.Urgency
public string Urgency {get; set;}
public: __property string* get_Urgency();
public: __property void set_Urgency(
   string* value
);
public:
property String^ Urgency {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


Writer_Editor Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class : Writer_Editor Property
Gets or sets Writer/Editor IPTC dataset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Writer_Editor As String()
'Usage

Dim instance As ImGearIPTCMetadata
Dim value() As String

instance.Writer_Editor = value

value = instance.Writer_Editor
public string[] Writer_Editor {get; set;}
public: __property string*[]* get_Writer_Editor();
public: __property void set_Writer_Editor(
   string*[]* value
);
public:
property array<String^>^ Writer_Editor {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

ImGearIPTCActionAdvised Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCActionAdvised Enumeration
Represents IPTC Advised Actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCActionAdvised
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCActionAdvised
public enum ImGearIPTCActionAdvised : System.Enum
__value public enum ImGearIPTCActionAdvised : public System.Enum
public enum class ImGearIPTCActionAdvised : public System.Enum
Members
Member | Value | Description
ObjectAppend | 3 | Object Append.
ObjectKill | 1 | Object Kill.
ObjectReference | 4 | Object Reference.
ObjectReplace | 2 | Object Replace.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCActionAdvised

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCAudioChannelMode Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioChannelMode Enumeration
Represents IPTC Audio Channel Modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCAudioChannelMode
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCAudioChannelMode
public enum ImGearIPTCAudioChannelMode : System.Enum
__value public enum ImGearIPTCAudioChannelMode : public System.Enum
public enum class ImGearIPTCAudioChannelMode : public System.Enum
Members
Member | Value | Description
Monaural | 1 | Monaural (1 channel) audio.
NoObjectdata | 0 | No object data.
Stereo | 2 | Stereo (2 channel) audio.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCAudioChannelMode

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCAudioContentType Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioContentType Enumeration
Represents IPTC Audio Content Types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCAudioContentType
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCAudioContentType
public enum ImGearIPTCAudioContentType : System.Enum
__value public enum ImGearIPTCAudioContentType : public System.Enum
public enum class ImGearIPTCAudioContentType : public System.Enum
Members
Member | Value | Description
Actuality | 0 | Actuality content type.
MusicTransmittedByItself | 2 | Music, transmitted by itself content type.
QuestionAndAnswerSession | 1 | Question and answer session content type.
RawSound | 4 | Raw sound content type.
ResponseToAQuestion | 3 | Response to a question content type.
Scener | 5 | Scener content type.
TextOnly | 6 | Text only content type.
Voicer | 7 | Voicer content type.
Wrap | 8 | Wrap content type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCAudioContentType

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCDataCompressionMethod Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCDataCompressionMethod Enumeration
Represents IPTC Data Compression Methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCDataCompressionMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCDataCompressionMethod
public enum ImGearIPTCDataCompressionMethod : System.Enum
__value public enum ImGearIPTCDataCompressionMethod : public System.Enum
public enum class ImGearIPTCDataCompressionMethod : public System.Enum
Members
Member | Value | Description
Hasselblad_2 | 131585 | Hasselblad type 2.
Hasselblad_3 | 131841 | Hasselblad type 3.
JFIF_1_01 | 66049 | JFIF 1.01.
JFIF_1_02 | 66050 | JFIF 1.02.
JPEG | 65793 | JPEG ITU-T Rec T.81 /ISO/IEC 10918-1.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCDataCompressionMethod

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCExcursionTolerance Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCExcursionTolerance Enumeration
Represents IPTC Excursion Tolerance modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCExcursionTolerance
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCExcursionTolerance
public enum ImGearIPTCExcursionTolerance : System.Enum
__value public enum ImGearIPTCExcursionTolerance : public System.Enum
public enum class ImGearIPTCExcursionTolerance : public System.Enum
Members
Member | Value | Description
MayOccur | 1 | May occur.
NotAllowed | 0 | Not allowed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCExcursionTolerance

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCFileFormatID Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCFileFormatID Enumeration
Represents IPTC File Format IDs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCFileFormatID
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCFileFormatID
public enum ImGearIPTCFileFormatID : System.Enum
__value public enum ImGearIPTCFileFormatID : public System.Enum
public enum class ImGearIPTCFileFormatID : public System.Enum
Members
Member | Value | Description
AIFF | 18 | Audio Interchange File Format AIFF (Apple Computer Inc).
AppleSingle | 5 | AppleSingle (Apple Computer Inc).
AVI | 15 | Audio plus Moving Video [*.AVI] (Microsoft).
BMP | 13 | Microsoft Bit Mapped Graphics File [*.BMP].
CorelDraw | 29 | Corel Draw [*.CDR].
Executable | 16 | PC DOS/Windows Executable Files [*.COM][*.EXE].
Freehand | 20 | Freehand (Macromedia/Aldus).
HTML | 21 | Hypertext Markup Language "HTML" (The Internet Society).
Illustrator | 4 | Illustrator (Adobe Graphics data).
IPTC7901RecommendedMessageFormat | 2 | IPTC7901 Recommended Message Format.
IPTCNAADigitalNewsphotoParameterRecord | 1 | IPTC-NAA Digital Newsphoto Parameter Record.
JFIF | 11 | JPEG File Interchange (JFIF).
MacBinaryII | 7 | MacBinary II.
MPEG2AudioLayer2 | 22 | MPEG 2 Audio Layer 2 (Musicom).
MPEG2AudioLayer3 | 23 | MPEG 2 Audio Layer 3.
NAA_89_3_ANPA_1312 | 6 | NAA 89-3 (ANPA 1312) file format.
NITF | 25 | News Industry Text Format (NITF).
NoObjectData | 0 | No object data.
PDF | 24 | Portable Document File (*.PDF) Adobe.
PhotoCD | 12 | Photo-CD Image-Pac (Eastman Kodak).
RBNITF | 28 | Ritzaus Bureau NITF version (RBNITF DTD).
RIFFWave | 19 | RIFF Wave (Microsoft Corporation).
TAR | 26 | Tape Archive (*.TAR).
TIFF | 3 | Tagged Image File Format (Adobe/Aldus Image data).
TTNITF | 27 | Tidningarnas Telegrambyr? NITF version (TTNITF DTD).
UCOFF | 8 | IPTC Unstructured Character Oriented File Format (UCOFF).
UPI_ANPA_1312_Variant | 9 | United Press International ANPA 1312 variant.
UPIDownLoadMessage | 10 | United Press International Down-Load Message.
WAV | 14 | Digital Audio File [*.WAV] (Microsoft and Creative Labs).
ZIP | 17 | Compressed Binary File [*.ZIP] (PKWare Inc).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCFileFormatID

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCImageBuildUpStructure Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageBuildUpStructure Enumeration
Represents IPTC Image Build Up Structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCImageBuildUpStructure
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCImageBuildUpStructure
public enum ImGearIPTCImageBuildUpStructure : System.Enum
__value public enum ImGearIPTCImageBuildUpStructure : public System.Enum
public enum class ImGearIPTCImageBuildUpStructure : public System.Enum
Members
Member | Value | Description
FrameSequentialInMultipleObjects | 1 | Frame Sequential In Multiple Objects.
FrameSequentialInOneObject | 2 | Frame Sequential In One Object.
LineSequential | 3 | Line Sequential.
PixelSequential | 4 | Pixel Sequential.
SingleFrame | 0 | Single Frame.
SpecialInterleavingStructure | 5 | Special Interleaving structure.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCImageBuildUpStructure

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCImageColourMode Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageColourMode Enumeration
Represents IPTC Image Colour Modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCImageColourMode
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCImageColourMode
public enum ImGearIPTCImageColourMode : System.Enum
__value public enum ImGearIPTCImageColourMode : public System.Enum
public enum class ImGearIPTCImageColourMode : public System.Enum
Members
Member | Value | Description
BlackComponent | 4 | Black Component.
BlueComponent | 7 | Blue Component.
CyanComponent | 3 | Cyan Component.
FullColourCompositeFrameSequential | 9 | Full Colour Composite Frame Sequential.
FullColourCompositeLineSequential | 10 | Full Colour Composite Line Sequential.
FullColourCompositePixelSequential | 11 | Full Colour Composite Pixel Sequential.
FullColourCompositeSpecialInterleaving | 12 | Full Colour Composite Special Interleaving.
GreenComponent | 6 | Green Component.
MagentaComponent | 2 | Magenta Component.
Monochrome | 0 | Monochrome mode.
RedComponent | 5 | Red Component.
TextOnly | 8 | Text Only.
YellowComponent | 1 | Yellow Component.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCImageColourMode

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCImageComponentMode Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageComponentMode Enumeration
Represents IPTC Image Component Modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCImageComponentMode
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCImageComponentMode
public enum ImGearIPTCImageComponentMode : System.Enum
__value public enum ImGearIPTCImageComponentMode : public System.Enum
public enum class ImGearIPTCImageComponentMode : public System.Enum
Members
Member | Value | Description
MultiComponent2 | 2 | Two components.
MultiComponent3 | 3 | Three components.
MultiComponent4 | 4 | Four components.
NoObjectData | 0 | No object data.
SingleComponent | 1 | Single component.
SupplementalObjects | 9 | Supplemental objects.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCImageComponentMode

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCImageOrientation Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageOrientation Enumeration
Represents IPTC Image Orientations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCImageOrientation
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCImageOrientation
public enum ImGearIPTCImageOrientation : System.Enum
__value public enum ImGearIPTCImageOrientation : public System.Enum
public enum class ImGearIPTCImageOrientation : public System.Enum
Members
Member | Value | Description
Landscape | 1 | Landscape orientation.
Portrait | 0 | Portrait orientation.
Square | 2 | Square orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCImageOrientation

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCImageRotation Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageRotation Enumeration
Represents IPTC Image Rotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCImageRotation
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCImageRotation
public enum ImGearIPTCImageRotation : System.Enum
__value public enum ImGearIPTCImageRotation : public System.Enum
public enum class ImGearIPTCImageRotation : public System.Enum
Members
Member | Value | Description
NoRotation | 0 | No rotation.
Rotation180Degrees | 2 | 180 degrees rotation.
Rotation270Degrees | 3 | 270 degrees rotation.
Rotation90Degrees | 1 | 90 degrees rotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCImageRotation

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCInterchangeColourSpace Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCInterchangeColourSpace Enumeration
Represents IPTC Interchange Colour Spaces.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCInterchangeColourSpace
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCInterchangeColourSpace
public enum ImGearIPTCInterchangeColourSpace : System.Enum
__value public enum ImGearIPTCInterchangeColourSpace : public System.Enum
public enum class ImGearIPTCInterchangeColourSpace : public System.Enum
Members
Member | Value | Description
CIELab_K | 6 | L*a*b* (K) CIE colour space (default illuminant D50).
CIEXYZ | 1 | X,Y,Z CIE colour space (default illuminant D50).
DeviceDependentCMYK | 5 | CMY(K) device dependent.
DeviceDependentRGB | 4 | RGB device dependent.
SMPTERGB | 2 | RGB SMPTE colour space.
sRGB | 8 | Colour space is sRGB.
YCbCr | 7 | Colour space is YCbCr.
YUV_K | 3 | Y,U,V (K) (default illuminant D65).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCInterchangeColourSpace

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCObjectAttributeNumber Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectAttributeNumber Enumeration
Represents IPTC Object Attribute Numbers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCObjectAttributeNumber
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCObjectAttributeNumber
public enum ImGearIPTCObjectAttributeNumber : System.Enum
__value public enum ImGearIPTCObjectAttributeNumber : public System.Enum
public enum class ImGearIPTCObjectAttributeNumber : public System.Enum
Members
Member | Value | Description
Analysis | 2 | Analysis attribute number.
ArchiveMaterial | 3 | Archive Material attribute number.
Background | 4 | Background attribute number.
Current | 1 | Current attribute number.
Feature | 5 | Feature attribute number.
Forecast | 6 | Forecast attribute number.
FromTheScene | 17 | From The Scene attribute number.
History | 7 | History attribute number.
Interview | 16 | Interview attribute number.
Obituary | 8 | Obituary attribute number.
Opinion | 9 | Opinion attribute number.
PollsAndSurveys | 10 | Polls And Surveys attribute number.
PressRelease | 22 | Press Release attribute number.
Profile | 11 | Profile attribute number.
ResultsListingsAndTables | 12 | Results Listings and Tables attribute number.
Retrospective | 18 | Retrospective attribute number.
SideBarAndSupportingInformation | 13 | Side Bar and Supporting Information attribute number.
Statistics | 19 | Statistics attribute number.
Summary | 14 | Summary attribute number.
TranscriptAndVerbatim | 15 | Transcript and Verbatim attribute number.
Update | 20 | Update attribute number.
WrapUp | 21 | Wrap Up attribute number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCObjectAttributeNumber

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCObjectCycle Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectCycle Enumeration
Represents IPTC Object Cycles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCObjectCycle
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCObjectCycle
public enum ImGearIPTCObjectCycle : System.Enum
__value public enum ImGearIPTCObjectCycle : public System.Enum
public enum class ImGearIPTCObjectCycle : public System.Enum
Members
Member | Value | Description
Both | 2 | Both cycles.
Evening | 1 | Evening cycle.
Morning | 0 | Morning cycle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCObjectCycle

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCObjectTypeNumber Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectTypeNumber Enumeration
Represents IPTC Object Type Numbers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCObjectTypeNumber
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCObjectTypeNumber
public enum ImGearIPTCObjectTypeNumber : System.Enum
__value public enum ImGearIPTCObjectTypeNumber : public System.Enum
public enum class ImGearIPTCObjectTypeNumber : public System.Enum
Members
Member | Value | Description
Advisory | 3 | Advisory type number.
Data | 2 | Data type number.
News | 1 | News type number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCObjectTypeNumber

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCQuantisationMethod Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCQuantisationMethod Enumeration
Represents IPTC Quantisation Methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCQuantisationMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCQuantisationMethod
public enum ImGearIPTCQuantisationMethod : System.Enum
__value public enum ImGearIPTCQuantisationMethod : public System.Enum
public enum class ImGearIPTCQuantisationMethod : public System.Enum
Members
Member | Value | Description
APDomesticAnalogue | 4 | AP Domestic Analogue.
ColourSpaceSpecific | 6 | Colour Space Specific.
CompressionMethodSpecific | 5 | Compression method Specific.
GammaCompensated | 7 | Gamma Compensated.
IPTCRefB | 2 | IPTC Ref B.
LinearDensity | 1 | Linear Density.
LinearDotPercent | 3 | Linear Dot Percent.
LinearReflectance_Transmittance | 0 | Linear Reflectance/Transmittance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCQuantisationMethod

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCSamplingStructure Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSamplingStructure Enumeration
Represents IPTC Sampling Structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCSamplingStructure
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCSamplingStructure
public enum ImGearIPTCSamplingStructure : System.Enum
__value public enum ImGearIPTCSamplingStructure : public System.Enum
public enum class ImGearIPTCSamplingStructure : public System.Enum
Members
Member | Value | Description
DefinedWithinCompressionProcess | 2 | Defined within the compression process.
Orthogonal | 0 | Orthogonal with the same relative sampling frequencies on each component.
Orthogonal_422_4 | 1 | Orthogonal with the sampling frequencies in the ratio of 4:2:2:(4) as described in Appendix G. This structure can only be used with the YUV(K) or LAB(K) colour spaces.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCSamplingStructure

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCScanningDirection Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCScanningDirection Enumeration
Represents IPTC Scanning Directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCScanningDirection
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCScanningDirection
public enum ImGearIPTCScanningDirection : System.Enum
__value public enum ImGearIPTCScanningDirection : public System.Enum
public enum class ImGearIPTCScanningDirection : public System.Enum
Members
Member | Value | Description
BottomToTop_LeftToRight | 5 | Bottom To Top, Left To Right.
BottomToTop_RightToLeft | 7 | Bottom To Top, Right To Left.
LeftToRight_BottomToTop | 2 | Left To Right, Bottom To Top.
LeftToRight_TopToBottom | 0 | Left To Right, Top To Bottom.
RightToLeft_BottomToTop | 3 | Right To Left, Bottom To Top.
RightToLeft_TopToBottom | 1 | Right To Left, Top To Bottom.
TopToBottom_LeftToRight | 4 | Top To Bottom, Left To Right.
TopToBottom_RightToLeft | 6 | Top To Bottom, Right To Left.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCScanningDirection

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCSizeMode Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSizeMode Enumeration
Represents IPTC Size Modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCSizeMode
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCSizeMode
public enum ImGearIPTCSizeMode : System.Enum
__value public enum ImGearIPTCSizeMode : public System.Enum
public enum class ImGearIPTCSizeMode : public System.Enum
Members
Member | Value | Description
Known | 1 | Size is known.
NotKnown | 0 | Size is not known.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCSizeMode

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCSubjectReferenceNumber Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSubjectReferenceNumber Enumeration
Represents IPTC Subject Reference Numbers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCSubjectReferenceNumber
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCSubjectReferenceNumber
public enum ImGearIPTCSubjectReferenceNumber : System.Enum
__value public enum ImGearIPTCSubjectReferenceNumber : public System.Enum
public enum class ImGearIPTCSubjectReferenceNumber : public System.Enum
Members
Member | Value | Description
AccountancyAndAuditing | 4006001 | Accountancy and Auditing subject reference number.
ActsOfTerror | 16001000 | Acts of terror subject reference number.
Addiction | 14001000 | Addiction subject reference number.
AdultEducation | 5001000 | Adult Education subject reference number.
Advertising | 4010001 | Advertising subject reference number.
AeroAndAviationSports | 15001000 | Aero and Aviation Sports subject reference number.
Aerospace | 4011001 | Aerospace subject reference number.
Agriculture | 4001000 | Agriculture subject reference number.
AirTransport | 4015001 | Air Transport subject reference number.
AlcoholicDrinks | 4013001 | Alcoholic Drinks subject reference number.
AlpineSkiing | 15002000 | Alpine Skiing subject reference number.
AlternativeEnergy | 6001000 | Alternative Energy subject reference number.
AlternativeEnergy_EnergyAndResources | 4005001 | Alternative energy subject reference number.
AmericanFootball | 15003000 | American Football subject reference number.
Animals | 8001000 | Animals subject reference number.
AppliedSciences | 13001000 | Applied Sciences subject reference number.
Apprentices | 9001000 | Apprentices subject reference number.
ArableFarming | 4001001 | Arable Farming subject reference number.
Archaeology | 1001000 | Archaeology subject reference number.
Archery | 15004000 | Archery subject reference number.
Architecture | 1002000 | Architecture subject reference number.
ArmedConflict | 16002000 | Armed conflict subject reference number.
ArtsCultureEntertainment | 1000000 | Arts, Culture and Entertainment subject reference number.
AthleticsTrackField | 15005000 | Athletics, Track and field subject reference number.
AutomotiveEquipment | 4011002 | Automotive Equipment subject reference number.
Badminton | 15006000 | Badminton subject reference number.
Banking | 4006002 | Banking subject reference number.
Baseball | 15007000 | Baseball subject reference number.
Basketball | 15008000 | Basketball subject reference number.
Biathlon | 15009000 | Biathlon subject reference number.
BilliardsSnookerPool | 15010000 | Billiards, Snooker and Pool subject reference number.
Biotechnology | 4002001 | Biotechnology subject reference number.
Bobsleigh | 15011000 | Bobsleigh subject reference number.
Books | 4010002 | Books subject reference number.
Bowling | 15012000 | Bowling subject reference number.
BowlsAndPetanque | 15013000 | Bowls and Petanque subject reference number.
Boxing | 15014000 | Boxing subject reference number.
BuildingMaterials | 4012001 | Building materials subject reference number.
Bullfighting | 1003000 | Bullfighting subject reference number.
CanoeingAndKayaking | 15015000 | Canoeing and Kayaking subject reference number.
Carnival | 1004000 | Carnival subject reference number.
CasinosAndGambling | 4014001 | Casinos and Gambling subject reference number.
CentralBanks | 4008001 | Central Banks subject reference number.
Charity | 14002000 | Charity subject reference number.
Chemicals | 4002000 | Chemicals subject reference number.
Cinema | 1005000 | Cinema subject reference number.
Cinema_Media | 4010003 | Cinema subject reference number.
CivilUnrest | 16003000 | Civil unrest subject reference number.
Climbing | 15016000 | Climbing subject reference number.
Clothing | 4007001 | Clothing subject reference number.
Coal | 4005002 | Coal subject reference number.
CollectiveContracts | 9002000 | Collective contracts subject reference number.
ComputingAndInformationTechnology | 4003000 | Computing and Information Technology subject reference number.
Conservation | 6002000 | Conservation subject reference number.
ConstructionAndProperty | 4004000 | Construction and property subject reference number.
ConsultancyServices | 4006003 | Consultancy Services subject reference number.
ConsumerIssues | 4008002 | Consumer Issues subject reference number.
CoupDEtat | 16004000 | Coup d'Etat subject reference number.
Cricket | 15017000 | Cricket subject reference number.
Crime | 2001000 | Crime subject reference number.
CrimeLawJustice | 2000000 | Crime, Law and Justice subject reference number.
CultsAndSects | 12001000 | Cults and sects subject reference number.
Curiosities | 8002000 | Curiosities subject reference number.
Curling | 15018000 | Curling subject reference number.
Cycling | 15019000 | Cycling subject reference number.
Dance | 1006000 | Dance subject reference number.
Dancing | 15020000 | Dancing subject reference number.
DebtMarkets | 4008003 | Debt Markets subject reference number.
Defence | 11001000 | Defence subject reference number.
DefenceEquipment | 4011003 | Defence Equipment subject reference number.
Demographics | 14003000 | Demographics subject reference number.
DepartmentStores | 4007002 | Department stores subject reference number.
Diplomacy | 11002000 | Diplomacy subject reference number.
Disabled | 14004000 | Disabled subject reference number.
DisastersAccidents | 3000000 | Disasters and Accidents subject reference number.
Diseases | 7001000 | Diseases subject reference number.
Diving | 15021000 | Diving subject reference number.
Drought | 3001000 | Drought subject reference number.
Earthquake | 3002000 | Earthquake subject reference number.
EconomicIndicators | 4008004 | Economic Indicators subject reference number.
EconomyBusinessFinance | 4000000 | Economy, Business and Finance subject reference number.
Education | 5000000 | Education subject reference number.
Elections | 11003000 | Elections subject reference number.
ElectricalAppliances | 4011004 | Electrical Appliances subject reference number.
ElectricityProductionAndDistribution | 4005006 | Electricity Production and Distribution subject reference number.
EmergingMarketsDebt | 4008005 | Emerging Markets Debt subject reference number.
Employment | 9003000 | Employment subject reference number.
EmploymentAgencies | 4006004 | Employment Agencies subject reference number.
Energy | 4009001 | Energy subject reference number.
EnergyAndResources | 4005000 | Energy and Resources subject reference number.
EnergySavings | 6003000 | Energy Savings subject reference number.
Engineering | 13002000 | Engineering subject reference number.
EnvironmentalIssues | 6000000 | Environmental Issues subject reference number.
EnvironmentalPolitics | 6004000 | Environmental Politics subject reference number.
EnvironmentalPollution | 6005000 | Environmental pollution subject reference number.
EpidemicAndPlague | 7002000 | Epidemic and Plague subject reference number.
Equestrian | 15022000 | Equestrian subject reference number.
EspionageAndIntelligence | 11004000 | Espionage and Intelligence subject reference number.
Euthanasia | 14005000 | Euthanasia subject reference number.
Faith | 12002000 | Faith subject reference number.
Family | 14006000 | Family subject reference number.
FamilyPlanning | 14007000 | Family planning subject reference number.
Famine | 3003000 | Famine subject reference number.
Fashion | 1007000 | Fashion subject reference number.
Fencing | 15023000 | Fencing subject reference number.
Fertilisers | 4002002 | Fertilisers subject reference number.
FieldHockey | 15024000 | Field Hockey subject reference number.
FigureSkating | 15025000 | Figure Skating subject reference number.
FinancialAndBusinessServices | 4006000 | Financial and Business Services subject reference number.
Fire | 3004000 | Fire subject reference number.
FishingIndustry | 4001002 | Fishing Industry subject reference number.
Flood | 3005000 | Flood subject reference number.
Food | 4007003 | Food subject reference number.
Forecasts | 17001000 | Forecasts subject reference number.
ForeignAid | 11005000 | Foreign Aid subject reference number.
ForeignExchangeMarkets | 4008006 | Foreign Exchange Markets subject reference number.
ForestryAndTimber | 4001003 | Forestry and Timber subject reference number.
FreeMasonry | 12003000 | Free masonry subject reference number.
FreestyleSkiing | 15026000 | Freestyle Skiing subject reference number.
FurnishingsAndFurniture | 4013003 | Furnishings and Furniture subject reference number.
FurtherEducation | 5002000 | Further Education subject reference number.
Games | 10001000 | Games subject reference number.
GamingAndLotteries | 10002000 | Gaming and Lotteries subject reference number.
Gastronomy | 10003000 | Gastronomy subject reference number.
GlobalChange | 17002000 | Global change subject reference number.
GoldAndPreciousMaterials | 4012002 | Gold and Precious Materials subject reference number.
Golf | 15027000 | Golf subject reference number.
GoodsDistribution | 4007000 | Goods Distribution subject reference number.
Government | 11006000 | Government subject reference number.
GovernmentAid | 4008007 | Government Aid subject reference number.
GovernmentDebt | 4008008 | Government Debt subject reference number.
GuerrillaActivities | 16005000 | Guerrilla activities subject reference number.
Gymnastics | 15028000 | Gymnastics subject reference number.
Handball_Team | 15029000 | Handball (Team) subject reference number.
Hardware | 4003001 | Hardware subject reference number.
Health | 7000000 | Health subject reference number.
HealthAndBeautyProducts | 4002003 | Health and Beauty products subject reference number.
HealthcareProviders | 4006005 | Healthcare Providers subject reference number.
HealthInsurance | 14008000 | Health insurance subject reference number.
HealthOrganisations | 7004000 | Health organisations subject reference number.
HealthTreatment | 7003000 | Health treatment subject reference number.
HeavyConstruction | 4004001 | Heavy construction subject reference number.
HeavyEngineering | 4011005 | Heavy engineering subject reference number.
Hobbies | 10004000 | Hobbies subject reference number.
HolidaysAndVacations | 10005000 | Holidays or vacations subject reference number.
Homelessness | 14009000 | Homelessness subject reference number.
HorseRacingAndHarnessRacing | 15030000 | Horse Racing, Harness Racing subject reference number.
HotelsAndAccommodation | 4014002 | Hotels and accommodation subject reference number.
HouseBuilding | 4004002 | House building subject reference number.
HumanInterest | 8000000 | Human Interest subject reference number.
HumanRights | 11007000 | Human Rights subject reference number.
HumanSciences | 13003000 | Human Sciences subject reference number.
IceHockey | 15031000 | Ice Hockey subject reference number.
IndustrialAccident | 3006000 | Industrial accident subject reference number.
IndustrialComponents | 4011006 | Industrial components subject reference number.
InorganicChemicals | 4002004 | Inorganic chemicals subject reference number.
InstrumentEngineering | 4011007 | Instrument engineering subject reference number.
Insurance | 4006006 | Insurance subject reference number.
InterestRates | 4008009 | Interest Rates subject reference number.
InternationalEconomicInstitutions | 4008010 | International Economic Institutions subject reference number.
InternationalTradeIssues | 4008011 | International Trade Issues subject reference number.
IronAndSteel | 4012003 | Iron and Steel subject reference number.
JaiAlai_Pelota | 15032000 | Jai Alai (Pelota) subject reference number.
Judiciary | 2002000 | Judiciary subject reference number.
Judo | 15033000 | Judo subject reference number.
Karate | 15034000 | Karate subject reference number.
Labour | 9000000 | Labour subject reference number.
LabourDispute | 9004000 | Labour dispute subject reference number.
LabourLegislation | 9005000 | Labour legislation subject reference number.
Lacrosse | 15035000 | Lacrosse subject reference number.
Language | 1008000 | Language subject reference number.
LegalServices | 4006007 | Legal services subject reference number.
LibrariesAndMuseums | 1009000 | Libraries and Museums subject reference number.
LifestyleAndLeisure | 10000000 | Lifestyle and Leisure subject reference number.
Literature | 1010000 | Literature subject reference number.
LivestockFarming | 4001004 | Livestock Farming subject reference number.
LoanMarkets | 4008012 | Loan Markets subject reference number.
LocalAuthorities | 11008000 | Local authorities subject reference number.
Luge | 15036000 | Luge subject reference number.
MacroEconomics | 4008000 | Macro Economics subject reference number.
MailOrder | 4007004 | Mail Order subject reference number.
Marathon | 15037000 | Marathon subject reference number.
MarketResearch | 4006008 | Market research subject reference number.
Markets | 4009000 | Markets subject reference number.
Massacre | 16006000 | Massacre subject reference number.
Media | 4010000 | Media subject reference number.
MedicalResearch | 7005000 | Medical research subject reference number.
MedicalStaff | 7006000 | Medical staff subject reference number.
Medicines | 7007000 | Medicines subject reference number.
MetalGoodsAndEngineering | 4011000 | Metal Goods and Engineering subject reference number.
Metals | 4009002 | Metals subject reference number.
MetalsAndMinerals | 4012000 | Metals and Minerals subject reference number.
MeteorologicalDisaster | 3007000 | Meteorological disaster subject reference number.
MinorityGroups | 14010000 | Minority groups subject reference number.
ModernPentathlon | 15038000 | Modern Pentathlon subject reference number.
Motorcycling | 15041000 | Motorcycling subject reference number.
MotorRacing | 15039000 | Motor Racing subject reference number.
MotorRallying | 15040000 | Motor Rallying subject reference number.
Music | 1011000 | Music subject reference number.
NaturalResources | 6006000 | Natural resources subject reference number.
NaturalSciences | 13004000 | Natural Sciences subject reference number.
Nature | 6007000 | Nature subject reference number.
Netball | 15042000 | Netball subject reference number.
Networking | 4003002 | Networking subject reference number.
NewsAgencies | 4010004 | News Agencies subject reference number.
NewspaperAndMagazines | 4010005 | Newspaper and Magazines subject reference number.
NonFerrousMetals | 4012004 | Non ferrous metals subject reference number.
NordicSkiing | 15043000 | Nordic Skiing subject reference number.
NuclearAccident | 3008000 | Nuclear accident subject reference number.
NuclearPower | 4005005 | Nuclear power subject reference number.
OilGasDownstreamActivities | 4005003 | Oil and Gas - Downstream activities subject reference number.
OilGasUpstreamActivities | 4005004 | Oil and Gas - Upstream activities subject reference number.
Online | 4010006 | Online subject reference number.
OrganicChemicals | 4002005 | Organic chemicals subject reference number.
Orienteering | 15044000 | Orienteering subject reference number.
Painting | 1012000 | Painting subject reference number.
PaperAndPackagingProducts | 4013004 | Paper and packaging products subject reference number.
ParentOrganisations | 5003000 | Parent Organisations subject reference number.
Parliament | 11009000 | Parliament subject reference number.
Parties | 11010000 | Parties subject reference number.
People | 8003000 | People subject reference number.
Pharmaceuticals | 4002006 | Pharmaceuticals subject reference number.
PhilosophicalSciences | 13005000 | Philosophical Sciences subject reference number.
Photography | 1013000 | Photography subject reference number.
Police | 2003000 | Police subject reference number.
Politics | 11000000 | Politics subject reference number.
Pollution | 3009000 | Pollution subject reference number.
Polo | 15045000 | Polo subject reference number.
Population | 6008000 | Population subject reference number.
Pornography | 14011000 | Pornography subject reference number.
Poverty | 14012000 | Poverty subject reference number.
PowerBoating | 15046000 | Power Boating subject reference number.
Preschooling | 5004000 | Preschooling subject reference number.
PreventativeMedicine | 7008000 | Preventative medicine subject reference number.
Prison | 2005000 | Prison subject reference number.
ProcessIndustries | 4013000 | Process Industries subject reference number.
Prostitution | 14013000 | Prostitution subject reference number.
PublicRelations | 4010007 | Public Relations subject reference number.
Punishment | 2004000 | Punishment subject reference number.
Racism | 14014000 | Racism subject reference number.
Radio | 1014000 | Radio subject reference number.
Radio_Media | 4010008 | Radio subject reference number.
Railway | 4015002 | Railway subject reference number.
RealEstate | 4004003 | Real Estate subject reference number.
RecreationalAndSportsGoods | 4014003 | Recreational and Sports goods subject reference number.
Refugees | 11011000 | Refugees subject reference number.
RegionalAuthorities | 11012000 | Regional authorities subject reference number.
ReligionAndBelief | 12000000 | Religion and Belief subject reference number.
ReligiousInstitutions | 12004000 | Religious institutions subject reference number.
Reports | 17003000 | Reports subject reference number.
Research | 13006000 | Research subject reference number.
RestaurantsAndCatering | 4014004 | Restaurants and catering subject reference number.
Retail | 4007005 | Retail subject reference number.
Retirement | 9006000 | Retirement subject reference number.
Retraining | 9007000 | Retraining subject reference number.
Riots | 16007000 | Riots subject reference number.
RoadTransport | 4015003 | Road Transport subject reference number.
Rowing | 15047000 | Rowing subject reference number.
RubberProducts | 4013005 | Rubber products subject reference number.
RugbyLeague | 15048000 | Rugby League subject reference number.
RugbyUnion | 15049000 | Rugby Union subject reference number.
Sailing | 15050000 | Sailing subject reference number.
SatelliteAndCableServices | 4010009 | Satellite and Cable Services subject reference number.
SatelliteTechnology | 4003003 | Satellite technology subject reference number.
Schools | 5005000 | Schools subject reference number.
ScienceAndTechnology | 13000000 | Science and Technology subject reference number.
ScientificExploration | 13007000 | Scientific exploration subject reference number.
Sculpture | 1015000 | Sculpture subject reference number.
Securities | 4009003 | Securities subject reference number.
SemiconductorsAndActiveComponents | 4003004 | Semiconductors and active components subject reference number.
Shipbuilding | 4011008 | Shipbuilding subject reference number.
Shooting | 15051000 | Shooting subject reference number.
SkiJumping | 15052000 | Ski Jumping subject reference number.
SnowBoarding | 15053000 | Snow Boarding subject reference number.
Soccer | 15054000 | Soccer subject reference number.
SocialIssues | 14000000 | Social Issues subject reference number.
Softball | 15055000 | Softball subject reference number.
SoftCommodities | 4009004 | Soft Commodities subject reference number.
SoftDrinks | 4013006 | Soft Drinks subject reference number.
Software | 4003005 | Software subject reference number.
SpaceProgrammes | 13008000 | Space programs subject reference number.
SpecialityStores | 4007006 | Speciality stores subject reference number.
SpeedSkating | 15056000 | Speed Skating subject reference number.
Speedway | 15057000 | Speedway subject reference number.
Sport | 15000000 | Sport subject reference number.
SportsOrganisations | 15058000 | Sports Organisations subject reference number.
Squash | 15059000 | Squash subject reference number.
StateBudget | 11013000 | State Budget subject reference number.
Statistics | 17004000 | Statistics subject reference number.
StockBroking | 4006009 | Stock broking subject reference number.
Strike | 9008000 | Strike subject reference number.
SumoWrestling | 15060000 | Sumo Wrestling subject reference number.
Surfing | 15061000 | Surfing subject reference number.
Swimming | 15062000 | Swimming subject reference number.
SyntheticsAndPlastics | 4002007 | Synthetics and Plastics subject reference number.
TableTennis | 15063000 | Table Tennis subject reference number.
TaekwonDo | 15064000 | Taekwon-Do subject reference number.
TeachersUnions | 5006000 | Teachers Unions subject reference number.
TelecommunicationsEquipment | 4003006 | Telecommunications Equipment subject reference number.
TelecommunicationsServices | 4003007 | Telecommunications Services subject reference number.
Television | 1016000 | Television subject reference number.
Television_Media | 4010010 | Television subject reference number.
Tennis | 15065000 | Tennis subject reference number.
TextilesAndClothing | 4013007 | Textiles and Clothing subject reference number.
Theatre | 1017000 | Theatre subject reference number.
Tobacco | 4013008 | Tobacco subject reference number.
Tourism | 10006000 | Tourism subject reference number.
TourismAndLeisure | 4014000 | Tourism and Leisure subject reference number.
TourOperators | 4014005 | Tour operators subject reference number.
Transport | 4015000 | Transport subject reference number.
TransportAccident | 3010000 | Transport accident subject reference number.
TreatiesAndOrganisations | 11014000 | Treaties and Organisations subject reference number.
Triathlon | 15066000 | Triathlon subject reference number.
Unemployment | 9009000 | Unemployment subject reference number.
Unions | 9010000 | Unions subject reference number.
University | 5007000 | University subject reference number.
UnrestConflictsWar | 16000000 | Unrest, Conflicts and War subject reference number.
ViolentDemonstrations | 16008000 | Violent demonstrations subject reference number.
VolcanicEruption | 3011000 | Volcanic eruption subject reference number.
Volleyball | 15067000 | Volleyball subject reference number.
WagesAndPensions | 9011000 | Wages and Pensions subject reference number.
War | 16009000 | War subject reference number.
Warnings | 17005000 | Warnings subject reference number.
Waste | 6009000 | Waste subject reference number.
WasteManagementAndPollutionControl | 4005007 | Waste Management and Pollution Control subject reference number.
WaterPolo | 15068000 | Water Polo subject reference number.
WaterSkiing | 15069000 | Water Skiing subject reference number.
WaterSupplies | 6010000 | Water Supplies subject reference number.
WaterSupply | 4005008 | Water Supply subject reference number.
WaterwayAndMaritimeTransport | 4015004 | Waterway and Maritime Transport subject reference number.
Weather | 17000000 | Weather subject reference number.
Weightlifting | 15070000 | Weightlifting subject reference number.
Welfare | 14015000 | Welfare subject reference number.
Wholesale | 4007007 | Wholesale subject reference number.
Windsurfing | 15071000 | Windsurfing subject reference number.
WorkRelations | 9012000 | Work Relations subject reference number.
Wrestling | 15072000 | Wrestling subject reference number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCSubjectReferenceNumber

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCSupplementType Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSupplementType Enumeration
Represents IPTC Supplement Types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearIPTCSupplementType
   Inherits System.Enum
'Usage

Dim instance As ImGearIPTCSupplementType
public enum ImGearIPTCSupplementType : System.Enum
__value public enum ImGearIPTCSupplementType : public System.Enum
public enum class ImGearIPTCSupplementType : public System.Enum
Members
Member | Value | Description
Logo | 2 | Logo type.
NotSupplement | 0 | Not a supplement.
RasterizedCaption | 3 | Rasterized caption.
ReducedResolutionImage | 1 | Reduced resolution image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.IPTC.ImGearIPTCSupplementType

See Also

Reference

ImageGear.Formats.IPTC Namespace


%%PageItemTitle%%

ImGearIPTCAudioType Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioType Structure
Represents IPTC Audio Type structure.
Object Model
ImGearIPTCAudioType Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCAudioType
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCAudioType
public struct ImGearIPTCAudioType : System.ValueType
public __value struct ImGearIPTCAudioType : public System.ValueType
public value class ImGearIPTCAudioType : public System.ValueType
Remarks
This structure represents IPTC Audio Type structure, used in Audio Type DataSet (2:150).
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCAudioType

See Also

Reference

ImGearIPTCAudioType Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCAudioType Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioType Structure

The following tables list the members exposed by ImGearIPTCAudioType.

Public Fields
 | Name | Description
Public Field | ChannelMode | Indicates the number of channels.
Public Field | ContentType | Indicates exact type of audio contained in the current objectdata.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCAudioType Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCAudioType Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioType Structure

For a list of all members of this type, see ImGearIPTCAudioType members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCAudioType Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCAudioType)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCAudioType Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCAudioType
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCAudioType Structure
ImGearIPTCAudioType Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCAudioType Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCAudioType Structure

For a list of all members of this type, see ImGearIPTCAudioType members.

Public Fields
 | Name | Description
Public Field | ChannelMode | Indicates the number of channels.
Public Field | ContentType | Indicates exact type of audio contained in the current objectdata.
Top
See Also

Reference

ImGearIPTCAudioType Structure
ImageGear.Formats.IPTC Namespace


ChannelMode Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCAudioType Structure : ChannelMode Field
Indicates the number of channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ChannelMode As ImGearIPTCAudioChannelMode
'Usage

Dim instance As ImGearIPTCAudioType
Dim value As ImGearIPTCAudioChannelMode

value = instance.ChannelMode

instance.ChannelMode = value
public ImGearIPTCAudioChannelMode ChannelMode
public: ImGearIPTCAudioChannelMode ChannelMode
public:
ImGearIPTCAudioChannelMode ChannelMode

Field Value

ImGearIPTCAudioChannelMode enumeration value.
Remarks
This property indicates the number of channels in the objectdata.
See Also

Reference

ImGearIPTCAudioType Structure
ImGearIPTCAudioType Members
ImGearIPTCAudioChannelMode Enumeration


ContentType Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCAudioType Structure : ContentType Field
Indicates exact type of audio contained in the current objectdata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ContentType As ImGearIPTCAudioContentType
'Usage

Dim instance As ImGearIPTCAudioType
Dim value As ImGearIPTCAudioContentType

value = instance.ContentType

instance.ContentType = value
public ImGearIPTCAudioContentType ContentType
public: ImGearIPTCAudioContentType ContentType
public:
ImGearIPTCAudioContentType ContentType

Field Value

ImGearIPTCAudioContentType enumeration value.
Remarks
This property indicates the exact type of audio contained in the current objectdata.
See Also

Reference

ImGearIPTCAudioType Structure
ImGearIPTCAudioType Members
ImGearIPTCAudioContentType Enumeration


%%PageItemTitle%%

ImGearIPTCColourRepresentation Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCColourRepresentation Structure
Represents IPTC Colour Representation structure.
Object Model
ImGearIPTCColourRepresentation Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCColourRepresentation
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCColourRepresentation
public struct ImGearIPTCColourRepresentation : System.ValueType
public __value struct ImGearIPTCColourRepresentation : public System.ValueType
public value class ImGearIPTCColourRepresentation : public System.ValueType
Remarks
This structure represents IPTC Colour Representation structure, used in Colour Representation DataSet (3:60).
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCColourRepresentation

See Also

Reference

ImGearIPTCColourRepresentation Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCColourRepresentation Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCColourRepresentation Structure

The following tables list the members exposed by ImGearIPTCColourRepresentation.

Public Fields
 | Name | Description
Public Field | BuildUpStructure | Gives the build-up structure of the image.
Public Field | NumberOfComponents | Specifies the number of components.
Top
Public Methods
 | Name | Description
Public Method | ToByteArray | Converts value to byte array.
Top
See Also

Reference

ImGearIPTCColourRepresentation Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCColourRepresentation Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCColourRepresentation Structure

For a list of all members of this type, see ImGearIPTCColourRepresentation members.

Public Methods
 | Name | Description
Public Method | ToByteArray | Converts value to byte array.
Top
See Also

Reference

ImGearIPTCColourRepresentation Structure
ImageGear.Formats.IPTC Namespace


ToByteArray Method

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCColourRepresentation Structure : ToByteArray Method
Converts value to byte array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToByteArray() As Byte()
'Usage

Dim instance As ImGearIPTCColourRepresentation
Dim value() As Byte

value = instance.ToByteArray()
public byte[] ToByteArray()
public: byte[]* ToByteArray();
public:
array<byte>^ ToByteArray();

Return Value

String value.
See Also

Reference

ImGearIPTCColourRepresentation Structure
ImGearIPTCColourRepresentation Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCColourRepresentation Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCColourRepresentation Structure

For a list of all members of this type, see ImGearIPTCColourRepresentation members.

Public Fields
 | Name | Description
Public Field | BuildUpStructure | Gives the build-up structure of the image.
Public Field | NumberOfComponents | Specifies the number of components.
Top
See Also

Reference

ImGearIPTCColourRepresentation Structure
ImageGear.Formats.IPTC Namespace


BuildUpStructure Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCColourRepresentation Structure : BuildUpStructure Field
Gives the build-up structure of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public BuildUpStructure As ImGearIPTCImageBuildUpStructure
'Usage

Dim instance As ImGearIPTCColourRepresentation
Dim value As ImGearIPTCImageBuildUpStructure

value = instance.BuildUpStructure

instance.BuildUpStructure = value
public ImGearIPTCImageBuildUpStructure BuildUpStructure
public: ImGearIPTCImageBuildUpStructure BuildUpStructure
public:
ImGearIPTCImageBuildUpStructure BuildUpStructure

Field Value

ImGearIPTCImageBuildUpStructure enumeration value.
See Also

Reference

ImGearIPTCColourRepresentation Structure
ImGearIPTCColourRepresentation Members
ImGearIPTCImageBuildUpStructure Enumeration


NumberOfComponents Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCColourRepresentation Structure : NumberOfComponents Field
Specifies the number of components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NumberOfComponents As Integer
'Usage

Dim instance As ImGearIPTCColourRepresentation
Dim value As Integer

value = instance.NumberOfComponents

instance.NumberOfComponents = value
public int NumberOfComponents
public: int NumberOfComponents
public:
int NumberOfComponents

Field Value

int value.
Remarks
This property specifies the number of components in the image.

Allowed values are as follows:

0 - No Image

1 - Monochrome

3 - Three components

4 - Four components

See Also

Reference

ImGearIPTCColourRepresentation Structure
ImGearIPTCColourRepresentation Members


%%PageItemTitle%%

ImGearIPTCImageType Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageType Structure
Represents IPTC Image Type structure.
Object Model
ImGearIPTCImageType Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCImageType
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCImageType
public struct ImGearIPTCImageType : System.ValueType
public __value struct ImGearIPTCImageType : public System.ValueType
public value class ImGearIPTCImageType : public System.ValueType
Remarks
This structure represents IPTC Image Type structure, used in Image Type DataSet (2:130).
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCImageType

See Also

Reference

ImGearIPTCImageType Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCImageType Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageType Structure

The following tables list the members exposed by ImGearIPTCImageType.

Public Fields
 | Name | Description
Public Field | Colour | Indicates the exact content of the current objectdata in terms of colour composition.
Public Field | Component | Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCImageType Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCImageType Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageType Structure

For a list of all members of this type, see ImGearIPTCImageType members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCImageType Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCImageType)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCImageType Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCImageType
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCImageType Structure
ImGearIPTCImageType Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCImageType Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCImageType Structure

For a list of all members of this type, see ImGearIPTCImageType members.

Public Fields
 | Name | Description
Public Field | Colour | Indicates the exact content of the current objectdata in terms of colour composition.
Public Field | Component | Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.
Top
See Also

Reference

ImGearIPTCImageType Structure
ImageGear.Formats.IPTC Namespace


Colour Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCImageType Structure : Colour Field
Indicates the exact content of the current objectdata in terms of colour composition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Colour As ImGearIPTCImageColourMode
'Usage

Dim instance As ImGearIPTCImageType
Dim value As ImGearIPTCImageColourMode

value = instance.Colour

instance.Colour = value
public ImGearIPTCImageColourMode Colour
public: ImGearIPTCImageColourMode Colour
public:
ImGearIPTCImageColourMode Colour

Field Value

ImGearIPTCImageColourMode enumeration value.
See Also

Reference

ImGearIPTCImageType Structure
ImGearIPTCImageType Members
ImGearIPTCImageColourMode Enumeration


Component Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCImageType Structure : Component Field
Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Component As ImGearIPTCImageComponentMode
'Usage

Dim instance As ImGearIPTCImageType
Dim value As ImGearIPTCImageComponentMode

value = instance.Component

instance.Component = value
public ImGearIPTCImageComponentMode Component
public: ImGearIPTCImageComponentMode Component
public:
ImGearIPTCImageComponentMode Component

Field Value

ImGearIPTCImageComponentMode enumeration value.
Remarks
This property indicates one of the following:
  • Record 2 caption for a specific image
  • Number of components in an image, in single or multiple envelopes
  • The objectdata contains supplementary data to an image (as defined in the Digital Newsphoto Parameter Record DataSet 3:55).
See Also

Reference

ImGearIPTCImageType Structure
ImGearIPTCImageType Members
ImGearIPTCImageComponentMode Enumeration


%%PageItemTitle%%

ImGearIPTCObjectAttributeReference Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectAttributeReference Structure
Represents IPTC Object Attribute Reference structure.
Object Model
ImGearIPTCObjectAttributeReference Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCObjectAttributeReference
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCObjectAttributeReference
public struct ImGearIPTCObjectAttributeReference : System.ValueType
public __value struct ImGearIPTCObjectAttributeReference : public System.ValueType
public value class ImGearIPTCObjectAttributeReference : public System.ValueType
Remarks
This structure represents IPTC Object Attribute Reference structure, used in the Object Attribute Reference DataSet (2:04).
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCObjectAttributeReference

See Also

Reference

ImGearIPTCObjectAttributeReference Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCObjectAttributeReference Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectAttributeReference Structure

The following tables list the members exposed by ImGearIPTCObjectAttributeReference.

Public Fields
 | Name | Description
Public Field | Name | Object Attribute Name.
Public Field | Number | Object Attribute Number.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCObjectAttributeReference Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectAttributeReference Structure

For a list of all members of this type, see ImGearIPTCObjectAttributeReference members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCObjectAttributeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectAttributeReference Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCObjectAttributeReference
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCObjectAttributeReference Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectAttributeReference Structure

For a list of all members of this type, see ImGearIPTCObjectAttributeReference members.

Public Fields
 | Name | Description
Public Field | Name | Object Attribute Name.
Public Field | Number | Object Attribute Number.
Top
See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImageGear.Formats.IPTC Namespace


Name Field (ImGearIPTCObjectAttributeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectAttributeReference Structure : Name Field
Object Attribute Name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Name As String
'Usage

Dim instance As ImGearIPTCObjectAttributeReference
Dim value As String

value = instance.Name

instance.Name = value
public string Name
public: string* Name
public:
String^ Name

Field Value

string value.
Remarks
This property contains an optional text representation of the Object Attribute Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImGearIPTCObjectAttributeReference Members


Number Field (ImGearIPTCObjectAttributeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectAttributeReference Structure : Number Field
Object Attribute Number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Number As ImGearIPTCObjectAttributeNumber
'Usage

Dim instance As ImGearIPTCObjectAttributeReference
Dim value As ImGearIPTCObjectAttributeNumber

value = instance.Number

instance.Number = value
public ImGearIPTCObjectAttributeNumber Number
public: ImGearIPTCObjectAttributeNumber Number
public:
ImGearIPTCObjectAttributeNumber Number

Field Value

ImGearIPTCObjectAttributeNumber enumeration value.
Remarks
This property represents a language independent international reference to an Object Attribute.
See Also

Reference

ImGearIPTCObjectAttributeReference Structure
ImGearIPTCObjectAttributeReference Members
ImGearIPTCObjectAttributeNumber Enumeration


%%PageItemTitle%%

ImGearIPTCObjectTypeReference Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectTypeReference Structure
Represents IPTC Object Type Reference structure.
Object Model
ImGearIPTCObjectTypeReference Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCObjectTypeReference
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCObjectTypeReference
public struct ImGearIPTCObjectTypeReference : System.ValueType
public __value struct ImGearIPTCObjectTypeReference : public System.ValueType
public value class ImGearIPTCObjectTypeReference : public System.ValueType
Remarks
This structure represents IPTC Object Type Reference structure, used in the Object Type Reference DataSet (2:03). The Object Type is used to distinguish between different types of objects within the IIM.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCObjectTypeReference

See Also

Reference

ImGearIPTCObjectTypeReference Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCObjectTypeReference Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectTypeReference Structure

The following tables list the members exposed by ImGearIPTCObjectTypeReference.

Public Fields
 | Name | Description
Public Field | Name | Object Type Name.
Public Field | Number | Object Type Number.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCObjectTypeReference Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectTypeReference Structure

For a list of all members of this type, see ImGearIPTCObjectTypeReference members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCObjectTypeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectTypeReference Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCObjectTypeReference
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCObjectTypeReference Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCObjectTypeReference Structure

For a list of all members of this type, see ImGearIPTCObjectTypeReference members.

Public Fields
 | Name | Description
Public Field | Name | Object Type Name.
Public Field | Number | Object Type Number.
Top
See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImageGear.Formats.IPTC Namespace


Name Field (ImGearIPTCObjectTypeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectTypeReference Structure : Name Field
Object Type Name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Name As String
'Usage

Dim instance As ImGearIPTCObjectTypeReference
Dim value As String

value = instance.Name

instance.Name = value
public string Name
public: string* Name
public:
String^ Name

Field Value

string value.
Remarks
This property contains an optional text representation of the Object Type Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImGearIPTCObjectTypeReference Members


Number Field (ImGearIPTCObjectTypeReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCObjectTypeReference Structure : Number Field
Object Type Number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Number As ImGearIPTCObjectTypeNumber
'Usage

Dim instance As ImGearIPTCObjectTypeReference
Dim value As ImGearIPTCObjectTypeNumber

value = instance.Number

instance.Number = value
public ImGearIPTCObjectTypeNumber Number
public: ImGearIPTCObjectTypeNumber Number
public:
ImGearIPTCObjectTypeNumber Number

Field Value

ImGearIPTCObjectTypeNumber enumeration value.
Remarks
This property represents a language independent international reference to an Object Type.
See Also

Reference

ImGearIPTCObjectTypeReference Structure
ImGearIPTCObjectTypeReference Members
ImGearIPTCObjectTypeNumber Enumeration


%%PageItemTitle%%

ImGearIPTCPictureNumber Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCPictureNumber Structure
Represents IPTC Picture Number structure.
Object Model
ImGearIPTCPictureNumber Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCPictureNumber
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCPictureNumber
public struct ImGearIPTCPictureNumber : System.ValueType
public __value struct ImGearIPTCPictureNumber : public System.ValueType
public value class ImGearIPTCPictureNumber : public System.ValueType
Remarks
This structure represents IPTC Picture Number structure, used in the Picture Number DataSet (3:10). The picture number provides a universally unique reference to an image. For example, color images, when split with color components into multiple objects, i.e., envelopes, would carry the same Picture Number.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCPictureNumber

See Also

Reference

ImGearIPTCPictureNumber Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCPictureNumber Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCPictureNumber Structure

The following tables list the members exposed by ImGearIPTCPictureNumber.

Public Fields
 | Name | Description
Public Field | DateIdentifier | Indicates the date the picture number was generated.
Public Field | DeviceIdentifier | Identifies the device that has generated the picture number.
Public Field | NumericIdentifier | A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCPictureNumber Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCPictureNumber Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCPictureNumber Structure

For a list of all members of this type, see ImGearIPTCPictureNumber members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCPictureNumber Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCPictureNumber)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCPictureNumber Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCPictureNumber
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCPictureNumber Structure
ImGearIPTCPictureNumber Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCPictureNumber Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCPictureNumber Structure

For a list of all members of this type, see ImGearIPTCPictureNumber members.

Public Fields
 | Name | Description
Public Field | DateIdentifier | Indicates the date the picture number was generated.
Public Field | DeviceIdentifier | Identifies the device that has generated the picture number.
Public Field | NumericIdentifier | A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
Top
See Also

Reference

ImGearIPTCPictureNumber Structure
ImageGear.Formats.IPTC Namespace


DateIdentifier Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCPictureNumber Structure : DateIdentifier Field
Indicates the date the picture number was generated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public DateIdentifier As String
'Usage

Dim instance As ImGearIPTCPictureNumber
Dim value As String

value = instance.DateIdentifier

instance.DateIdentifier = value
public string DateIdentifier
public: string* DateIdentifier
public:
String^ DateIdentifier

Field Value

string value.
Remarks
This property contains eight numeric characters using the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the picture number was generated.
See Also

Reference

ImGearIPTCPictureNumber Structure
ImGearIPTCPictureNumber Members


DeviceIdentifier Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCPictureNumber Structure : DeviceIdentifier Field
Identifies the device that has generated the picture number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public DeviceIdentifier As Integer
'Usage

Dim instance As ImGearIPTCPictureNumber
Dim value As Integer

value = instance.DeviceIdentifier

instance.DeviceIdentifier = value
public int DeviceIdentifier
public: int DeviceIdentifier
public:
int DeviceIdentifier

Field Value

int value.
Remarks
This property contains a binary number identifying the device that has generated the picture number.
See Also

Reference

ImGearIPTCPictureNumber Structure
ImGearIPTCPictureNumber Members


NumericIdentifier Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCPictureNumber Structure : NumericIdentifier Field
A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NumericIdentifier As Integer
'Usage

Dim instance As ImGearIPTCPictureNumber
Dim value As Integer

value = instance.NumericIdentifier

instance.NumericIdentifier = value
public int NumericIdentifier
public: int NumericIdentifier
public:
int NumericIdentifier

Field Value

int value.
Remarks
This property contains a binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
See Also

Reference

ImGearIPTCPictureNumber Structure
ImGearIPTCPictureNumber Members


%%PageItemTitle%%

ImGearIPTCSubjectReference Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSubjectReference Structure
Represents IPTC Subject Reference structure.
Object Model
ImGearIPTCSubjectReference Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCSubjectReference
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCSubjectReference
public struct ImGearIPTCSubjectReference : System.ValueType
public __value struct ImGearIPTCSubjectReference : public System.ValueType
public value class ImGearIPTCSubjectReference : public System.ValueType
Remarks
This structure represents IPTC Subject Reference structure, used in the Subject Reference DataSet (2:12). The Subject Reference is a structured definition of the subject matter.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCSubjectReference

See Also

Reference

ImGearIPTCSubjectReference Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCSubjectReference Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSubjectReference Structure

The following tables list the members exposed by ImGearIPTCSubjectReference.

Public Fields
 | Name | Description
Public Field | IPR | Information Provider Reference.
Public Field | SubjectDetailName | Subject Detail Name.
Public Field | SubjectMatterName | Subject Matter Name.
Public Field | SubjectName | Subject Name.
Public Field | SubjectReferenceNumber | Subject Reference Number.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCSubjectReference Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCSubjectReference Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSubjectReference Structure

For a list of all members of this type, see ImGearIPTCSubjectReference members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCSubjectReference Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCSubjectReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCSubjectReference Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCSubjectReference Structure

For a list of all members of this type, see ImGearIPTCSubjectReference members.

Public Fields
 | Name | Description
Public Field | IPR | Information Provider Reference.
Public Field | SubjectDetailName | Subject Detail Name.
Public Field | SubjectMatterName | Subject Matter Name.
Public Field | SubjectName | Subject Name.
Public Field | SubjectReferenceNumber | Subject Reference Number.
Top
See Also

Reference

ImGearIPTCSubjectReference Structure
ImageGear.Formats.IPTC Namespace


IPR Field (ImGearIPTCSubjectReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : IPR Field
Information Provider Reference.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public IPR As String
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As String

value = instance.IPR

instance.IPR = value
public string IPR
public: string* IPR
public:
String^ IPR

Field Value

string value.
Remarks
A name, registered with the IPTC/NAA, identifying the provider that provides an indicator of the SDR content. The default value for the IPR is "IPTC" and is mandatory if the Subject Reference exists in the IPTC coding scheme.

Contains 1-32 bytes.

See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members


SubjectDetailName Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : SubjectDetailName Field
Subject Detail Name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public SubjectDetailName As String
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As String

value = instance.SubjectDetailName

instance.SubjectDetailName = value
public string SubjectDetailName
public: string* SubjectDetailName
public:
String^ SubjectDetailName

Field Value

string value.
Remarks
This property contains a text representation of the Subject Detail Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members


SubjectMatterName Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : SubjectMatterName Field
Subject Matter Name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public SubjectMatterName As String
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As String

value = instance.SubjectMatterName

instance.SubjectMatterName = value
public string SubjectMatterName
public: string* SubjectMatterName
public:
String^ SubjectMatterName

Field Value

string value.
Remarks
This property contains a text representation of the Subject Matter Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members


SubjectName Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : SubjectName Field
Subject Name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public SubjectName As String
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As String

value = instance.SubjectName

instance.SubjectName = value
public string SubjectName
public: string* SubjectName
public:
String^ SubjectName

Field Value

string value.
Remarks
This property contains a text representation of the Subject Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members


SubjectReferenceNumber Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCSubjectReference Structure : SubjectReferenceNumber Field
Subject Reference Number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public SubjectReferenceNumber As ImGearIPTCSubjectReferenceNumber
'Usage

Dim instance As ImGearIPTCSubjectReference
Dim value As ImGearIPTCSubjectReferenceNumber

value = instance.SubjectReferenceNumber

instance.SubjectReferenceNumber = value
public ImGearIPTCSubjectReferenceNumber SubjectReferenceNumber
public: ImGearIPTCSubjectReferenceNumber SubjectReferenceNumber
public:
ImGearIPTCSubjectReferenceNumber SubjectReferenceNumber

Field Value

ImGearIPTCSubjectReferenceNumber enumeration value.
Remarks
This property provides a numeric code to indicate the Subject Name plus optional Subject Matter and Subject Detail Names in the language of the service.
See Also

Reference

ImGearIPTCSubjectReference Structure
ImGearIPTCSubjectReference Members
ImGearIPTCSubjectReferenceNumber Enumeration


%%PageItemTitle%%

ImGearIPTCUNO Structure
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCUNO Structure
Represents IPTC UNO structure.
Object Model
ImGearIPTCUNO Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearIPTCUNO
   Inherits System.ValueType
'Usage

Dim instance As ImGearIPTCUNO
public struct ImGearIPTCUNO : System.ValueType
public __value struct ImGearIPTCUNO : public System.ValueType
public value class ImGearIPTCUNO : public System.ValueType
Remarks
This structure represents UNO structure, used in the UNO DataSet (1:100). The UNO (Unique Name of Object) provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Formats.IPTC.ImGearIPTCUNO

See Also

Reference

ImGearIPTCUNO Members
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTCUNO Structure Members
Fields Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCUNO Structure

The following tables list the members exposed by ImGearIPTCUNO.

Public Fields
 | Name | Description
Public Field | IPR | Information Provider Reference (IPR).
Public Field | ODE | Object Descriptor Element (ODE).
Public Field | OVI | Object Variant Indicator (OVI).
Public Field | UCD | UNO Creation Date (UCD).
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCUNO Structure
ImageGear.Formats.IPTC Namespace


%%PageItemTitle%% $$Methods$$

ImGearIPTCUNO Structure Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCUNO Structure

For a list of all members of this type, see ImGearIPTCUNO members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearIPTCUNO Structure
ImageGear.Formats.IPTC Namespace


ToString Method (ImGearIPTCUNO)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCUNO Structure : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearIPTCUNO
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearIPTCUNO Structure
ImGearIPTCUNO Members


%%PageItemTitle%% $$Fields$$

ImGearIPTCUNO Structure Fields

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace : ImGearIPTCUNO Structure

For a list of all members of this type, see ImGearIPTCUNO members.

Public Fields
 | Name | Description
Public Field | IPR | Information Provider Reference (IPR).
Public Field | ODE | Object Descriptor Element (ODE).
Public Field | OVI | Object Variant Indicator (OVI).
Public Field | UCD | UNO Creation Date (UCD).
Top
See Also

Reference

ImGearIPTCUNO Structure
ImageGear.Formats.IPTC Namespace


IPR Field (ImGearIPTCUNO)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCUNO Structure : IPR Field
Information Provider Reference (IPR).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public IPR As String
'Usage

Dim instance As ImGearIPTCUNO
Dim value As String

value = instance.IPR

instance.IPR = value
public string IPR
public: string* IPR
public:
String^ IPR

Field Value

string value.
Remarks
This property represents the IPR element of IPTC UNO structure. The IPR (Information Provider Reference) specifies a name, registered with the IPTC/NAA, identifying the provider that guarantees the uniqueness of the UNO. It may assist in locating an object source.

Contains a minimum of one and a maximum of 32 bytes. A string of graphic characters, except colon ':' solidus '/', asterisk '*' and question mark '?', registered with, and approved by, the IPTC.

See Also

Reference

ImGearIPTCUNO Structure
ImGearIPTCUNO Members


ODE Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCUNO Structure : ODE Field
Object Descriptor Element (ODE).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ODE As String
'Usage

Dim instance As ImGearIPTCUNO
Dim value As String

value = instance.ODE

instance.ODE = value
public string ODE
public: string* ODE
public:
String^ ODE

Field Value

string value.
Remarks
This property represents the ODE element of IPTC UNO structure. The ODE (Object Descriptor Element), in conjunction with the UCD and the IPR, ensures the uniqueness of the UNO. The provider may structure the element by use of a solidus '/' character.

Contains a minimum of one and a maximum of 60 minus the number of IPR bytes, consisting of graphic characters, except colon ':' asterisk '*' and question mark '?'.

See Also

Reference

ImGearIPTCUNO Structure
ImGearIPTCUNO Members


OVI Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCUNO Structure : OVI Field
Object Variant Indicator (OVI).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public OVI As String
'Usage

Dim instance As ImGearIPTCUNO
Dim value As String

value = instance.OVI

instance.OVI = value
public string OVI
public: string* OVI
public:
String^ OVI

Field Value

string value.
Remarks
This property represents the OVI element of IPTC UNO structure. The OVI (Object Variant Indicator) indicates technical variants of the object such as partial objects, or changes of file formats, and coded character sets.

Contains a minimum of one and a maximum of 9 bytes, consisting of graphic characters, except colon ':', asterisk '*' and question mark '?'.

See Also

Reference

ImGearIPTCUNO Structure
ImGearIPTCUNO Members


UCD Field

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.IPTC Namespace > ImGearIPTCUNO Structure : UCD Field
UNO Creation Date (UCD).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UCD As String
'Usage

Dim instance As ImGearIPTCUNO
Dim value As String

value = instance.UCD

instance.UCD = value
public string UCD
public: string* UCD
public:
String^ UCD

Field Value

string value.
Remarks
This property represents the UCD element of IPTC UNO structure. The UCD (UNO Creation Date) specifies a 24 hour period in which the further elements of the UNO have to be unique. It also provides a search facility.

Contains 8 bytes in ISO 8601 date format (CCYYMMDD), consisting of numeric characters.

See Also

Reference

ImGearIPTCUNO Structure
ImGearIPTCUNO Members


ImageGear.Formats.TIF Namespace (ImageGear22.Formats.SimplifiedMetadata)
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.TIF Namespace
This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.
Classes
 | Class | Description
Class | ImGearTIFFMetadata | Provides simplified access to TIFF metadata.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.TIF Namespace (ImageGear22.Formats.SimplifiedMetadata) Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.TIF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.TIF.ImGearTIFFMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearTIFFMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFMetadata Class
Provides simplified access to TIFF metadata.
Object Model
ImGearTIFFMetadata ClassImGearRationalUInt StructureImGearRationalUInt StructureImGearRationalUInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearTIFFMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearTIFFMetadata
public class ImGearTIFFMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearTIFFMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearTIFFMetadata : public ImageGear.Formats.ImGearFormatMetadata
Remarks
This class provides simplified read/write access to TIFF metadata of an ImGearPage. Properties of this class represent specific TIFF tags.

The following file formats may contain TIFF metadata:

- TIFF

- JPEG with EXIF metadata (EXIF specification uses TIFF structure and a subset of TIFF tags).

ImGearTIFFMetadata class provides access to data stored in the general metadata tree. It does not store its own copy of the data.

Types of properties of the class represent TIFF tag types, e.g., string, byte[ ], etc. Instead of value types, ImageGear uses corresponding Nullable types.

If a specific tag is not present in the metadata, corresponding property returns null. Similarly, to remove a specific tag from metadata, set the corresponding property to null.

Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.TIF.ImGearTIFFMetadata

See Also

Reference

ImGearTIFFMetadata Members
ImageGear.Formats.TIF Namespace


%%PageItemTitle%% $$Members$$

ImGearTIFFMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFMetadata Class

The following tables list the members exposed by ImGearTIFFMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearTIFFMetadata Constructor | Initializes a new instance of the ImGearTIFFMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Artist | Gets or sets Artist tag value.
Public Property | BitsPerSample | Gets or sets BitsPerSample tag value.
Public Property | CellLength | Gets or sets CellLength tag value.
Public Property | CellWidth | Gets or sets CellWidth tag value.
Public Property | ColorMap | Gets or sets ColorMap tag value.
Public Property | Compression | Gets or sets Compression tag value.
Public Property | Copyright | Gets or sets Copyright tag value.
Public Property | DateTime | Gets or sets DateTime tag value.
Public Property | DocumentName | Gets or sets DocumentName tag value.
Public Property | DotRange | Gets or sets DotRange tag value.
Public Property | ExtraSamples | Gets or sets ExtraSamples tag value.
Public Property | FillOrder | Gets or sets FillOrder tag value.
Public Property | FreeByteCounts | Gets or sets FreeByteCounts tag value.
Public Property | FreeOffsets | Gets or sets FreeOffsets tag value.
Public Property | GrayResponseCurve | Gets or sets GrayResponseCurve tag value.
Public Property | GrayResponseUnit | Gets or sets GrayResponseUnit tag value.
Public Property | HalftoneHints | Gets or sets HalftoneHints tag value.
Public Property | HostComputer | Gets or sets HostComputer tag value.
Public Property | ImageDescription | Gets or sets ImageDescription tag value.
Public Property | ImageLength | Gets or sets ImageLength tag value.
Public Property | ImageWidth | Gets or sets ImageWidth tag value.
Public Property | InkNames | Gets or sets InkNames tag value.
Public Property | InkSet | Gets or sets InkSet tag value.
Public Property | InterColorProfile | Gets or sets InterColorProfile tag value.
Public Property | JPEGACTables | Gets or sets JPEGACTables tag.
Public Property | JPEGDCTables | Gets or sets JPEGDCTables tag value.
Public Property | JPEGInterchangeFormat | Gets or sets JPEGInterchangeFormat tag value.
Public Property | JPEGInterchangeFormatLength | Gets or sets JPEGInterchangeFormatLngth tag value.
Public Property | JPEGLosslessPredictors | Gets or sets JPEGLosslessPredictors tag value.
Public Property | JPEGPointTransforms | Gets or sets JPEGPointTransforms tag value.
Public Property | JPEGProc | Gets or sets JPEGProc tag value.
Public Property | JPEGQTables | Gets or sets JPEGQTables tag value.
Public Property | JPEGRestartInterval | Gets or sets JPEGRestartInterval tag value.
Public Property | Make | Gets or sets Make tag value.
Public Property | MaxSampleValue | Gets or sets MaxSampleValue tag value.
Public Property | MinSampleValue | Gets or sets MinSampleValue tag value.
Public Property | Model | Gets or sets Model tag value.
Public Property | NewSubfileType | Gets or sets NewSubfileType tag value.
Public Property | NumberOfInks | Gets or sets NumberOfInks tag value.
Public Property | Orientation | Gets or sets Orientation tag value.
Public Property | PageName | Gets or sets PageName tag value.
Public Property | PageNumber | Gets or sets PageNumber tag value.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation tag value.
Public Property | PlanarConfig | Gets or sets PlanarConfig tag value.
Public Property | PredictorType | Gets or sets PredictorType tag value.
Public Property | PrimaryChromaticities | Gets or sets PrimaryChromaticities tag value.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite tag value.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit tag value.
Public Property | RowsPerStrip | Gets or sets RowsPerStrip tag value.
Public Property | SampleFormat | Gets or sets SampleFormat tag value.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel tag value.
Public Property | SMaxSampleValue | Gets or sets SMaxSampleValue tag value.
Public Property | SMinSampleValue | Gets or sets SMinSampleValue tag value.
Public Property | Software | Gets or sets Software tag value.
Public Property | StripByteCounts | Gets or sets StripByteCounts tag value.
Public Property | StripOffsets | Gets or sets StripOffsets tag value.
Public Property | SubFileType | Gets or sets SubFileType tag value.
Public Property | T4Options | Gets or sets T4Options tag value.
Public Property | T6Options | Gets or sets T6Options tag value.
Public Property | TargetPrinter | Gets or sets TargetPrinter tag value.
Public Property | Threshholding | Gets or sets Threshholding tag value.
Public Property | TileByteCounts | Gets or sets TileByteCounts tag value.
Public Property | TileLength | Gets or sets TileLength tag value.
Public Property | TileOffsets | Gets or sets TileOffsets tag value.
Public Property | TileWidth | Gets or sets TileWidth tag value.
Public Property | TransferFunction | Gets or sets TransferFunction tag value.
Public Property | TransferRange | Gets or sets TransferRange tag value.
Public Property | WhitePoint | Gets or sets WhitePoint tag value.
Public Property | XPosition | Gets or sets XPosition tag value.
Public Property | XResolution | Gets or sets XResolution tag value.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients tag.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning tag value.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling tag value.
Public Property | YPosition | Gets or sets YPosition tag value.
Public Property | YResolution | Gets or sets YResolution tag value.
Top
See Also

Reference

ImGearTIFFMetadata Class
ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ImGearTIFFMetadata Constructor
Initializes a new instance of the ImGearTIFFMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearTIFFMetadata()
public ImGearTIFFMetadata()
public: ImGearTIFFMetadata();
public:
ImGearTIFFMetadata();

Return Value

The new instance of ImGearTIFFMetadata class.
Remarks
This constructor creates and initializes an instance of ImGearTIFFMetadata class.
See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearTIFFMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace : ImGearTIFFMetadata Class

For a list of all members of this type, see ImGearTIFFMetadata members.

Public Properties
 | Name | Description
Public Property | Artist | Gets or sets Artist tag value.
Public Property | BitsPerSample | Gets or sets BitsPerSample tag value.
Public Property | CellLength | Gets or sets CellLength tag value.
Public Property | CellWidth | Gets or sets CellWidth tag value.
Public Property | ColorMap | Gets or sets ColorMap tag value.
Public Property | Compression | Gets or sets Compression tag value.
Public Property | Copyright | Gets or sets Copyright tag value.
Public Property | DateTime | Gets or sets DateTime tag value.
Public Property | DocumentName | Gets or sets DocumentName tag value.
Public Property | DotRange | Gets or sets DotRange tag value.
Public Property | ExtraSamples | Gets or sets ExtraSamples tag value.
Public Property | FillOrder | Gets or sets FillOrder tag value.
Public Property | FreeByteCounts | Gets or sets FreeByteCounts tag value.
Public Property | FreeOffsets | Gets or sets FreeOffsets tag value.
Public Property | GrayResponseCurve | Gets or sets GrayResponseCurve tag value.
Public Property | GrayResponseUnit | Gets or sets GrayResponseUnit tag value.
Public Property | HalftoneHints | Gets or sets HalftoneHints tag value.
Public Property | HostComputer | Gets or sets HostComputer tag value.
Public Property | ImageDescription | Gets or sets ImageDescription tag value.
Public Property | ImageLength | Gets or sets ImageLength tag value.
Public Property | ImageWidth | Gets or sets ImageWidth tag value.
Public Property | InkNames | Gets or sets InkNames tag value.
Public Property | InkSet | Gets or sets InkSet tag value.
Public Property | InterColorProfile | Gets or sets InterColorProfile tag value.
Public Property | JPEGACTables | Gets or sets JPEGACTables tag.
Public Property | JPEGDCTables | Gets or sets JPEGDCTables tag value.
Public Property | JPEGInterchangeFormat | Gets or sets JPEGInterchangeFormat tag value.
Public Property | JPEGInterchangeFormatLength | Gets or sets JPEGInterchangeFormatLngth tag value.
Public Property | JPEGLosslessPredictors | Gets or sets JPEGLosslessPredictors tag value.
Public Property | JPEGPointTransforms | Gets or sets JPEGPointTransforms tag value.
Public Property | JPEGProc | Gets or sets JPEGProc tag value.
Public Property | JPEGQTables | Gets or sets JPEGQTables tag value.
Public Property | JPEGRestartInterval | Gets or sets JPEGRestartInterval tag value.
Public Property | Make | Gets or sets Make tag value.
Public Property | MaxSampleValue | Gets or sets MaxSampleValue tag value.
Public Property | MinSampleValue | Gets or sets MinSampleValue tag value.
Public Property | Model | Gets or sets Model tag value.
Public Property | NewSubfileType | Gets or sets NewSubfileType tag value.
Public Property | NumberOfInks | Gets or sets NumberOfInks tag value.
Public Property | Orientation | Gets or sets Orientation tag value.
Public Property | PageName | Gets or sets PageName tag value.
Public Property | PageNumber | Gets or sets PageNumber tag value.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation tag value.
Public Property | PlanarConfig | Gets or sets PlanarConfig tag value.
Public Property | PredictorType | Gets or sets PredictorType tag value.
Public Property | PrimaryChromaticities | Gets or sets PrimaryChromaticities tag value.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite tag value.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit tag value.
Public Property | RowsPerStrip | Gets or sets RowsPerStrip tag value.
Public Property | SampleFormat | Gets or sets SampleFormat tag value.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel tag value.
Public Property | SMaxSampleValue | Gets or sets SMaxSampleValue tag value.
Public Property | SMinSampleValue | Gets or sets SMinSampleValue tag value.
Public Property | Software | Gets or sets Software tag value.
Public Property | StripByteCounts | Gets or sets StripByteCounts tag value.
Public Property | StripOffsets | Gets or sets StripOffsets tag value.
Public Property | SubFileType | Gets or sets SubFileType tag value.
Public Property | T4Options | Gets or sets T4Options tag value.
Public Property | T6Options | Gets or sets T6Options tag value.
Public Property | TargetPrinter | Gets or sets TargetPrinter tag value.
Public Property | Threshholding | Gets or sets Threshholding tag value.
Public Property | TileByteCounts | Gets or sets TileByteCounts tag value.
Public Property | TileLength | Gets or sets TileLength tag value.
Public Property | TileOffsets | Gets or sets TileOffsets tag value.
Public Property | TileWidth | Gets or sets TileWidth tag value.
Public Property | TransferFunction | Gets or sets TransferFunction tag value.
Public Property | TransferRange | Gets or sets TransferRange tag value.
Public Property | WhitePoint | Gets or sets WhitePoint tag value.
Public Property | XPosition | Gets or sets XPosition tag value.
Public Property | XResolution | Gets or sets XResolution tag value.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients tag.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning tag value.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling tag value.
Public Property | YPosition | Gets or sets YPosition tag value.
Public Property | YResolution | Gets or sets YResolution tag value.
Top
See Also

Reference

ImGearTIFFMetadata Class
ImageGear.Formats.TIF Namespace


%%PageItemTitle%%

ImGearTIFFMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ImGearTIFFMetadata Constructor
Overload List
Overload | Description
ImGearTIFFMetadata Constructor | Initializes a new instance of the ImGearTIFFMetadata class.
See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Artist Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Artist Property
Gets or sets Artist tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Artist As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.Artist = value

value = instance.Artist
public string Artist {get; set;}
public: __property string* get_Artist();
public: __property void set_Artist(
   string* value
);
public:
property String^ Artist {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Artist tag. The tag specifies the person who created the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


BitsPerSample Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : BitsPerSample Property
Gets or sets BitsPerSample tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerSample As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.BitsPerSample = value

value = instance.BitsPerSample
public ushort[] BitsPerSample {get; set;}
public: __property ushort[]* get_BitsPerSample();
public: __property void set_BitsPerSample(
   ushort[]* value
);
public:
property array<ushort>^ BitsPerSample {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the BitsPerSample tag. The tag specifies number of bits per image component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


CellLength Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : CellLength Property
Gets or sets CellLength tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CellLength As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.CellLength = value

value = instance.CellLength
public Nullable<ushort> CellLength {get; set;}
public: __property Nullable<ushort> get_CellLength();
public: __property void set_CellLength(
   Nullable<ushort> value
);
public:
property Nullable<ushort> CellLength {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


CellWidth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : CellWidth Property
Gets or sets CellWidth tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CellWidth As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.CellWidth = value

value = instance.CellWidth
public Nullable<ushort> CellWidth {get; set;}
public: __property Nullable<ushort> get_CellWidth();
public: __property void set_CellWidth(
   Nullable<ushort> value
);
public:
property Nullable<ushort> CellWidth {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ColorMap Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ColorMap Property
Gets or sets ColorMap tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorMap As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.ColorMap = value

value = instance.ColorMap
public ushort[] ColorMap {get; set;}
public: __property ushort[]* get_ColorMap();
public: __property void set_ColorMap(
   ushort[]* value
);
public:
property array<ushort>^ ColorMap {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Ushort array.
Remarks
This property accesses the ColorMap tag. The tag specifies a color map for palette color images.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Compression Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Compression Property
Gets or sets Compression tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As Nullable(Of ImGearTIFFCompression)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFCompression)

instance.Compression = value

value = instance.Compression
public Nullable<ImGearTIFFCompression> Compression {get; set;}
public: __property Nullable<ImGearTIFFCompression> get_Compression();
public: __property void set_Compression(
   Nullable<ImGearTIFFCompression> value
);
public:
property Nullable<ImGearTIFFCompression> Compression {
   Nullable<ImGearTIFFCompression> get();
   void set (    Nullable<ImGearTIFFCompression> value);
}

Property Value

Nullable (boxed) ImGearTIFFCompression enumeration value.
Remarks
This property accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFCompression Enumeration


Copyright Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Copyright Property
Gets or sets Copyright tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Copyright As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.Copyright = value

value = instance.Copyright
public string Copyright {get; set;}
public: __property string* get_Copyright();
public: __property void set_Copyright(
   string* value
);
public:
property String^ Copyright {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Copyright tag. The tag specifies the copyright notice for the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


DateTime Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : DateTime Property
Gets or sets DateTime tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTime As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.DateTime = value

value = instance.DateTime
public string DateTime {get; set;}
public: __property string* get_DateTime();
public: __property void set_DateTime(
   string* value
);
public:
property String^ DateTime {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DateTime tag. The tag specifies the date and time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


DocumentName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : DocumentName Property
Gets or sets DocumentName tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentName As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.DocumentName = value

value = instance.DocumentName
public string DocumentName {get; set;}
public: __property string* get_DocumentName();
public: __property void set_DocumentName(
   string* value
);
public:
property String^ DocumentName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


DotRange Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : DotRange Property
Gets or sets DotRange tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DotRange As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.DotRange = value

value = instance.DotRange
public ushort[] DotRange {get; set;}
public: __property ushort[]* get_DotRange();
public: __property void set_DotRange(
   ushort[]* value
);
public:
property array<ushort>^ DotRange {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ExtraSamples Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ExtraSamples Property
Gets or sets ExtraSamples tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtraSamples As Byte()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As Byte

instance.ExtraSamples = value

value = instance.ExtraSamples
public byte[] ExtraSamples {get; set;}
public: __property byte[]* get_ExtraSamples();
public: __property void set_ExtraSamples(
   byte[]* value
);
public:
property array<byte>^ ExtraSamples {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


FillOrder Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : FillOrder Property
Gets or sets FillOrder tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillOrder As Nullable(Of ImGearTIFFFillOrder)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFFillOrder)

instance.FillOrder = value

value = instance.FillOrder
public Nullable<ImGearTIFFFillOrder> FillOrder {get; set;}
public: __property Nullable<ImGearTIFFFillOrder> get_FillOrder();
public: __property void set_FillOrder(
   Nullable<ImGearTIFFFillOrder> value
);
public:
property Nullable<ImGearTIFFFillOrder> FillOrder {
   Nullable<ImGearTIFFFillOrder> get();
   void set (    Nullable<ImGearTIFFFillOrder> value);
}

Property Value

Nullable (boxed) ImGearTIFFFillOrder enumeration value.
Remarks
This property accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFFillOrder Enumeration


FreeByteCounts Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : FreeByteCounts Property
Gets or sets FreeByteCounts tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FreeByteCounts As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.FreeByteCounts = value

value = instance.FreeByteCounts
public uint[] FreeByteCounts {get; set;}
public: __property uint[]* get_FreeByteCounts();
public: __property void set_FreeByteCounts(
   uint[]* value
);
public:
property array<uint>^ FreeByteCounts {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Array of uint.
Remarks
This property accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


FreeOffsets Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : FreeOffsets Property
Gets or sets FreeOffsets tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FreeOffsets As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.FreeOffsets = value

value = instance.FreeOffsets
public uint[] FreeOffsets {get; set;}
public: __property uint[]* get_FreeOffsets();
public: __property void set_FreeOffsets(
   uint[]* value
);
public:
property array<uint>^ FreeOffsets {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


GrayResponseCurve Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : GrayResponseCurve Property
Gets or sets GrayResponseCurve tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GrayResponseCurve As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.GrayResponseCurve = value

value = instance.GrayResponseCurve
public ushort[] GrayResponseCurve {get; set;}
public: __property ushort[]* get_GrayResponseCurve();
public: __property void set_GrayResponseCurve(
   ushort[]* value
);
public:
property array<ushort>^ GrayResponseCurve {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


GrayResponseUnit Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : GrayResponseUnit Property
Gets or sets GrayResponseUnit tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GrayResponseUnit As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.GrayResponseUnit = value

value = instance.GrayResponseUnit
public Nullable<ushort> GrayResponseUnit {get; set;}
public: __property Nullable<ushort> get_GrayResponseUnit();
public: __property void set_GrayResponseUnit(
   Nullable<ushort> value
);
public:
property Nullable<ushort> GrayResponseUnit {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


HalftoneHints Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : HalftoneHints Property
Gets or sets HalftoneHints tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HalftoneHints As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.HalftoneHints = value

value = instance.HalftoneHints
public ushort[] HalftoneHints {get; set;}
public: __property ushort[]* get_HalftoneHints();
public: __property void set_HalftoneHints(
   ushort[]* value
);
public:
property array<ushort>^ HalftoneHints {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


HostComputer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : HostComputer Property
Gets or sets HostComputer tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HostComputer As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.HostComputer = value

value = instance.HostComputer
public string HostComputer {get; set;}
public: __property string* get_HostComputer();
public: __property void set_HostComputer(
   string* value
);
public:
property String^ HostComputer {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ImageDescription Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ImageDescription Property
Gets or sets ImageDescription tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageDescription As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.ImageDescription = value

value = instance.ImageDescription
public string ImageDescription {get; set;}
public: __property string* get_ImageDescription();
public: __property void set_ImageDescription(
   string* value
);
public:
property String^ ImageDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the ImageDescription tag. The tag describes the subject of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ImageLength Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ImageLength Property
Gets or sets ImageLength tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageLength As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.ImageLength = value

value = instance.ImageLength
public Nullable<uint> ImageLength {get; set;}
public: __property Nullable<uint> get_ImageLength();
public: __property void set_ImageLength(
   Nullable<uint> value
);
public:
property Nullable<uint> ImageLength {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ImageWidth Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ImageWidth Property
Gets or sets ImageWidth tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageWidth As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.ImageWidth = value

value = instance.ImageWidth
public Nullable<uint> ImageWidth {get; set;}
public: __property Nullable<uint> get_ImageWidth();
public: __property void set_ImageWidth(
   Nullable<uint> value
);
public:
property Nullable<uint> ImageWidth {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


InkNames Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : InkNames Property
Gets or sets InkNames tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InkNames As String()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As String

instance.InkNames = value

value = instance.InkNames
public string[] InkNames {get; set;}
public: __property string*[]* get_InkNames();
public: __property void set_InkNames(
   string*[]* value
);
public:
property array<String^>^ InkNames {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

Array of strings.
Remarks
This property accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


InkSet Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : InkSet Property
Gets or sets InkSet tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InkSet As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.InkSet = value

value = instance.InkSet
public Nullable<ushort> InkSet {get; set;}
public: __property Nullable<ushort> get_InkSet();
public: __property void set_InkSet(
   Nullable<ushort> value
);
public:
property Nullable<ushort> InkSet {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


InterColorProfile Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : InterColorProfile Property
Gets or sets InterColorProfile tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InterColorProfile As Byte()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As Byte

instance.InterColorProfile = value

value = instance.InterColorProfile
public byte[] InterColorProfile {get; set;}
public: __property byte[]* get_InterColorProfile();
public: __property void set_InterColorProfile(
   byte[]* value
);
public:
property array<byte>^ InterColorProfile {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

Array of bytes.
Remarks
This property accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGACTables Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGACTables Property
Gets or sets JPEGACTables tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGACTables As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.JPEGACTables = value

value = instance.JPEGACTables
public uint[] JPEGACTables {get; set;}
public: __property uint[]* get_JPEGACTables();
public: __property void set_JPEGACTables(
   uint[]* value
);
public:
property array<uint>^ JPEGACTables {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGDCTables Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGDCTables Property
Gets or sets JPEGDCTables tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGDCTables As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.JPEGDCTables = value

value = instance.JPEGDCTables
public uint[] JPEGDCTables {get; set;}
public: __property uint[]* get_JPEGDCTables();
public: __property void set_JPEGDCTables(
   uint[]* value
);
public:
property array<uint>^ JPEGDCTables {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGInterchangeFormat Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGInterchangeFormat Property
Gets or sets JPEGInterchangeFormat tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGInterchangeFormat As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.JPEGInterchangeFormat = value

value = instance.JPEGInterchangeFormat
public Nullable<uint> JPEGInterchangeFormat {get; set;}
public: __property Nullable<uint> get_JPEGInterchangeFormat();
public: __property void set_JPEGInterchangeFormat(
   Nullable<uint> value
);
public:
property Nullable<uint> JPEGInterchangeFormat {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGInterchangeFormatLength Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGInterchangeFormatLength Property
Gets or sets JPEGInterchangeFormatLngth tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGInterchangeFormatLength As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.JPEGInterchangeFormatLength = value

value = instance.JPEGInterchangeFormatLength
public Nullable<uint> JPEGInterchangeFormatLength {get; set;}
public: __property Nullable<uint> get_JPEGInterchangeFormatLength();
public: __property void set_JPEGInterchangeFormatLength(
   Nullable<uint> value
);
public:
property Nullable<uint> JPEGInterchangeFormatLength {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGLosslessPredictors Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGLosslessPredictors Property
Gets or sets JPEGLosslessPredictors tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGLosslessPredictors As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.JPEGLosslessPredictors = value

value = instance.JPEGLosslessPredictors
public Nullable<ushort> JPEGLosslessPredictors {get; set;}
public: __property Nullable<ushort> get_JPEGLosslessPredictors();
public: __property void set_JPEGLosslessPredictors(
   Nullable<ushort> value
);
public:
property Nullable<ushort> JPEGLosslessPredictors {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGPointTransforms Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGPointTransforms Property
Gets or sets JPEGPointTransforms tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGPointTransforms As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.JPEGPointTransforms = value

value = instance.JPEGPointTransforms
public Nullable<ushort> JPEGPointTransforms {get; set;}
public: __property Nullable<ushort> get_JPEGPointTransforms();
public: __property void set_JPEGPointTransforms(
   Nullable<ushort> value
);
public:
property Nullable<ushort> JPEGPointTransforms {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGProc Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGProc Property
Gets or sets JPEGProc tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGProc As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.JPEGProc = value

value = instance.JPEGProc
public Nullable<ushort> JPEGProc {get; set;}
public: __property Nullable<ushort> get_JPEGProc();
public: __property void set_JPEGProc(
   Nullable<ushort> value
);
public:
property Nullable<ushort> JPEGProc {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGQTables Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGQTables Property
Gets or sets JPEGQTables tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGQTables As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.JPEGQTables = value

value = instance.JPEGQTables
public uint[] JPEGQTables {get; set;}
public: __property uint[]* get_JPEGQTables();
public: __property void set_JPEGQTables(
   uint[]* value
);
public:
property array<uint>^ JPEGQTables {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


JPEGRestartInterval Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : JPEGRestartInterval Property
Gets or sets JPEGRestartInterval tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JPEGRestartInterval As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.JPEGRestartInterval = value

value = instance.JPEGRestartInterval
public Nullable<ushort> JPEGRestartInterval {get; set;}
public: __property Nullable<ushort> get_JPEGRestartInterval();
public: __property void set_JPEGRestartInterval(
   Nullable<ushort> value
);
public:
property Nullable<ushort> JPEGRestartInterval {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Make Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Make Property
Gets or sets Make tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Make As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.Make = value

value = instance.Make
public string Make {get; set;}
public: __property string* get_Make();
public: __property void set_Make(
   string* value
);
public:
property String^ Make {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


MaxSampleValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : MaxSampleValue Property
Gets or sets MaxSampleValue tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxSampleValue As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.MaxSampleValue = value

value = instance.MaxSampleValue
public ushort[] MaxSampleValue {get; set;}
public: __property ushort[]* get_MaxSampleValue();
public: __property void set_MaxSampleValue(
   ushort[]* value
);
public:
property array<ushort>^ MaxSampleValue {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


MinSampleValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : MinSampleValue Property
Gets or sets MinSampleValue tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinSampleValue As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.MinSampleValue = value

value = instance.MinSampleValue
public ushort[] MinSampleValue {get; set;}
public: __property ushort[]* get_MinSampleValue();
public: __property void set_MinSampleValue(
   ushort[]* value
);
public:
property array<ushort>^ MinSampleValue {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Model Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Model Property
Gets or sets Model tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Model As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.Model = value

value = instance.Model
public string Model {get; set;}
public: __property string* get_Model();
public: __property void set_Model(
   string* value
);
public:
property String^ Model {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


NewSubfileType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : NewSubfileType Property
Gets or sets NewSubfileType tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewSubfileType As Nullable(Of ImGearTIFFNewSubFileTypeMasks)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFNewSubFileTypeMasks)

instance.NewSubfileType = value

value = instance.NewSubfileType
public Nullable<ImGearTIFFNewSubFileTypeMasks> NewSubfileType {get; set;}
public: __property Nullable<ImGearTIFFNewSubFileTypeMasks> get_NewSubfileType();
public: __property void set_NewSubfileType(
   Nullable<ImGearTIFFNewSubFileTypeMasks> value
);
public:
property Nullable<ImGearTIFFNewSubFileTypeMasks> NewSubfileType {
   Nullable<ImGearTIFFNewSubFileTypeMasks> get();
   void set (    Nullable<ImGearTIFFNewSubFileTypeMasks> value);
}

Property Value

Nullable (boxed) ImGearTIFFNewSubFileTypeMasks enumeration value.
Remarks
This property accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFNewSubFileTypeMasks Enumeration


NumberOfInks Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : NumberOfInks Property
Gets or sets NumberOfInks tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfInks As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.NumberOfInks = value

value = instance.NumberOfInks
public Nullable<ushort> NumberOfInks {get; set;}
public: __property Nullable<ushort> get_NumberOfInks();
public: __property void set_NumberOfInks(
   Nullable<ushort> value
);
public:
property Nullable<ushort> NumberOfInks {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Orientation Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Orientation Property
Gets or sets Orientation tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As Nullable(Of ImGearTIFFOrientation)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFOrientation)

instance.Orientation = value

value = instance.Orientation
public Nullable<ImGearTIFFOrientation> Orientation {get; set;}
public: __property Nullable<ImGearTIFFOrientation> get_Orientation();
public: __property void set_Orientation(
   Nullable<ImGearTIFFOrientation> value
);
public:
property Nullable<ImGearTIFFOrientation> Orientation {
   Nullable<ImGearTIFFOrientation> get();
   void set (    Nullable<ImGearTIFFOrientation> value);
}

Property Value

Nullable (boxed) ImGearTIFFOrientation enumeration value.
Remarks
This property accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFOrientation Enumeration


PageName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PageName Property
Gets or sets PageName tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageName As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.PageName = value

value = instance.PageName
public string PageName {get; set;}
public: __property string* get_PageName();
public: __property void set_PageName(
   string* value
);
public:
property String^ PageName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


PageNumber Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PageNumber Property
Gets or sets PageNumber tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.PageNumber = value

value = instance.PageNumber
public ushort[] PageNumber {get; set;}
public: __property ushort[]* get_PageNumber();
public: __property void set_PageNumber(
   ushort[]* value
);
public:
property array<ushort>^ PageNumber {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

If the TIFF filter option "IncludePageNumber" is set to true, ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


PhotometricInterpretation Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PhotometricInterpretation Property
Gets or sets PhotometricInterpretation tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PhotometricInterpretation As Nullable(Of ImGearTIFFPhotoInterpretation)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFPhotoInterpretation)

instance.PhotometricInterpretation = value

value = instance.PhotometricInterpretation
public Nullable<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {get; set;}
public: __property Nullable<ImGearTIFFPhotoInterpretation> get_PhotometricInterpretation();
public: __property void set_PhotometricInterpretation(
   Nullable<ImGearTIFFPhotoInterpretation> value
);
public:
property Nullable<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {
   Nullable<ImGearTIFFPhotoInterpretation> get();
   void set (    Nullable<ImGearTIFFPhotoInterpretation> value);
}

Property Value

Nullable (boxed) ImGearTIFFPhotoInterpretation enumeration value.
Remarks
This property accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFPhotoInterpretation Enumeration


PlanarConfig Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PlanarConfig Property
Gets or sets PlanarConfig tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlanarConfig As Nullable(Of ImGearTIFFPlanarConfig)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFPlanarConfig)

instance.PlanarConfig = value

value = instance.PlanarConfig
public Nullable<ImGearTIFFPlanarConfig> PlanarConfig {get; set;}
public: __property Nullable<ImGearTIFFPlanarConfig> get_PlanarConfig();
public: __property void set_PlanarConfig(
   Nullable<ImGearTIFFPlanarConfig> value
);
public:
property Nullable<ImGearTIFFPlanarConfig> PlanarConfig {
   Nullable<ImGearTIFFPlanarConfig> get();
   void set (    Nullable<ImGearTIFFPlanarConfig> value);
}

Property Value

Nullable (boxed) ImGearTIFFPlanarConfig enumeration value.
Remarks
This property accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFPlanarConfig Enumeration


PredictorType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PredictorType Property
Gets or sets PredictorType tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PredictorType As Nullable(Of ImGearTIFFPredictorType)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFPredictorType)

instance.PredictorType = value

value = instance.PredictorType
public Nullable<ImGearTIFFPredictorType> PredictorType {get; set;}
public: __property Nullable<ImGearTIFFPredictorType> get_PredictorType();
public: __property void set_PredictorType(
   Nullable<ImGearTIFFPredictorType> value
);
public:
property Nullable<ImGearTIFFPredictorType> PredictorType {
   Nullable<ImGearTIFFPredictorType> get();
   void set (    Nullable<ImGearTIFFPredictorType> value);
}

Property Value

Nullable (boxed) ImGearTIFFPredictorType enumeration value.
Remarks
This property accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFPredictorType Enumeration


PrimaryChromaticities Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : PrimaryChromaticities Property
Gets or sets PrimaryChromaticities tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrimaryChromaticities As ImGearRationalUInt()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As ImGearRationalUInt

instance.PrimaryChromaticities = value

value = instance.PrimaryChromaticities
public ImGearRationalUInt[] PrimaryChromaticities {get; set;}
public: __property ImGearRationalUInt[]* get_PrimaryChromaticities();
public: __property void set_PrimaryChromaticities(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ PrimaryChromaticities {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure array.
Remarks
This property accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


ReferenceBlackWhite Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ReferenceBlackWhite Property
Gets or sets ReferenceBlackWhite tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceBlackWhite As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.ReferenceBlackWhite = value

value = instance.ReferenceBlackWhite
public uint[] ReferenceBlackWhite {get; set;}
public: __property uint[]* get_ReferenceBlackWhite();
public: __property void set_ReferenceBlackWhite(
   uint[]* value
);
public:
property array<uint>^ ReferenceBlackWhite {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


ResolutionUnit Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : ResolutionUnit Property
Gets or sets ResolutionUnit tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionUnit As Nullable(Of ImGearTIFFResolutionUnit)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFResolutionUnit)

instance.ResolutionUnit = value

value = instance.ResolutionUnit
public Nullable<ImGearTIFFResolutionUnit> ResolutionUnit {get; set;}
public: __property Nullable<ImGearTIFFResolutionUnit> get_ResolutionUnit();
public: __property void set_ResolutionUnit(
   Nullable<ImGearTIFFResolutionUnit> value
);
public:
property Nullable<ImGearTIFFResolutionUnit> ResolutionUnit {
   Nullable<ImGearTIFFResolutionUnit> get();
   void set (    Nullable<ImGearTIFFResolutionUnit> value);
}

Property Value

Nullable (boxed) ImGearTIFFResolutionUnit enumeration value.
Remarks
This property accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFResolutionUnit Enumeration


RowsPerStrip Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : RowsPerStrip Property
Gets or sets RowsPerStrip tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RowsPerStrip As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.RowsPerStrip = value

value = instance.RowsPerStrip
public Nullable<uint> RowsPerStrip {get; set;}
public: __property Nullable<uint> get_RowsPerStrip();
public: __property void set_RowsPerStrip(
   Nullable<uint> value
);
public:
property Nullable<uint> RowsPerStrip {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


SampleFormat Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : SampleFormat Property
Gets or sets SampleFormat tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SampleFormat As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.SampleFormat = value

value = instance.SampleFormat
public ushort[] SampleFormat {get; set;}
public: __property ushort[]* get_SampleFormat();
public: __property void set_SampleFormat(
   ushort[]* value
);
public:
property array<ushort>^ SampleFormat {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


SamplesPerPixel Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : SamplesPerPixel Property
Gets or sets SamplesPerPixel tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SamplesPerPixel As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.SamplesPerPixel = value

value = instance.SamplesPerPixel
public Nullable<ushort> SamplesPerPixel {get; set;}
public: __property Nullable<ushort> get_SamplesPerPixel();
public: __property void set_SamplesPerPixel(
   Nullable<ushort> value
);
public:
property Nullable<ushort> SamplesPerPixel {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


SMaxSampleValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : SMaxSampleValue Property
Gets or sets SMaxSampleValue tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SMaxSampleValue As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.SMaxSampleValue = value

value = instance.SMaxSampleValue
public uint[] SMaxSampleValue {get; set;}
public: __property uint[]* get_SMaxSampleValue();
public: __property void set_SMaxSampleValue(
   uint[]* value
);
public:
property array<uint>^ SMaxSampleValue {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


SMinSampleValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : SMinSampleValue Property
Gets or sets SMinSampleValue tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SMinSampleValue As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.SMinSampleValue = value

value = instance.SMinSampleValue
public uint[] SMinSampleValue {get; set;}
public: __property uint[]* get_SMinSampleValue();
public: __property void set_SMinSampleValue(
   uint[]* value
);
public:
property array<uint>^ SMinSampleValue {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Software Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Software Property
Gets or sets Software tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Software As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.Software = value

value = instance.Software
public string Software {get; set;}
public: __property string* get_Software();
public: __property void set_Software(
   string* value
);
public:
property String^ Software {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


StripByteCounts Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : StripByteCounts Property
Gets or sets StripByteCounts tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StripByteCounts As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.StripByteCounts = value

value = instance.StripByteCounts
public uint[] StripByteCounts {get; set;}
public: __property uint[]* get_StripByteCounts();
public: __property void set_StripByteCounts(
   uint[]* value
);
public:
property array<uint>^ StripByteCounts {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


StripOffsets Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : StripOffsets Property
Gets or sets StripOffsets tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StripOffsets As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.StripOffsets = value

value = instance.StripOffsets
public uint[] StripOffsets {get; set;}
public: __property uint[]* get_StripOffsets();
public: __property void set_StripOffsets(
   uint[]* value
);
public:
property array<uint>^ StripOffsets {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


SubFileType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : SubFileType Property
Gets or sets SubFileType tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubFileType As Nullable(Of ImGearTIFFSubFileType)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearTIFFSubFileType)

instance.SubFileType = value

value = instance.SubFileType
public Nullable<ImGearTIFFSubFileType> SubFileType {get; set;}
public: __property Nullable<ImGearTIFFSubFileType> get_SubFileType();
public: __property void set_SubFileType(
   Nullable<ImGearTIFFSubFileType> value
);
public:
property Nullable<ImGearTIFFSubFileType> SubFileType {
   Nullable<ImGearTIFFSubFileType> get();
   void set (    Nullable<ImGearTIFFSubFileType> value);
}

Property Value

Nullable (boxed) ImGearTIFFSubFileType enumeration value.
Remarks
This property accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The NewSubfileType property tag should be used instead.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearTIFFSubFileType Enumeration


T4Options Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : T4Options Property
Gets or sets T4Options tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property T4Options As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.T4Options = value

value = instance.T4Options
public Nullable<uint> T4Options {get; set;}
public: __property Nullable<uint> get_T4Options();
public: __property void set_T4Options(
   Nullable<uint> value
);
public:
property Nullable<uint> T4Options {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


T6Options Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : T6Options Property
Gets or sets T6Options tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property T6Options As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.T6Options = value

value = instance.T6Options
public Nullable<uint> T6Options {get; set;}
public: __property Nullable<uint> get_T6Options();
public: __property void set_T6Options(
   Nullable<uint> value
);
public:
property Nullable<uint> T6Options {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TargetPrinter Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TargetPrinter Property
Gets or sets TargetPrinter tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetPrinter As String
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As String

instance.TargetPrinter = value

value = instance.TargetPrinter
public string TargetPrinter {get; set;}
public: __property string* get_TargetPrinter();
public: __property void set_TargetPrinter(
   string* value
);
public:
property String^ TargetPrinter {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


Threshholding Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : Threshholding Property
Gets or sets Threshholding tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Threshholding As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.Threshholding = value

value = instance.Threshholding
public Nullable<ushort> Threshholding {get; set;}
public: __property Nullable<ushort> get_Threshholding();
public: __property void set_Threshholding(
   Nullable<ushort> value
);
public:
property Nullable<ushort> Threshholding {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TileByteCounts Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TileByteCounts Property
Gets or sets TileByteCounts tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TileByteCounts As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.TileByteCounts = value

value = instance.TileByteCounts
public uint[] TileByteCounts {get; set;}
public: __property uint[]* get_TileByteCounts();
public: __property void set_TileByteCounts(
   uint[]* value
);
public:
property array<uint>^ TileByteCounts {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TileLength Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TileLength Property
Gets or sets TileLength tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TileLength As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.TileLength = value

value = instance.TileLength
public Nullable<uint> TileLength {get; set;}
public: __property Nullable<uint> get_TileLength();
public: __property void set_TileLength(
   Nullable<uint> value
);
public:
property Nullable<uint> TileLength {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the TileLength tag. The tag specifies the number of rows in each tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TileOffsets Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TileOffsets Property
Gets or sets TileOffsets tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TileOffsets As UInteger()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UInteger

instance.TileOffsets = value

value = instance.TileOffsets
public uint[] TileOffsets {get; set;}
public: __property uint[]* get_TileOffsets();
public: __property void set_TileOffsets(
   uint[]* value
);
public:
property array<uint>^ TileOffsets {
   array<uint>^ get();
   void set (    array<uint>^ value);
}

Property Value

Unsigned int array.
Remarks
This property accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TileWidth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TileWidth Property
Gets or sets TileWidth tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TileWidth As Nullable(Of UInteger)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UInteger)

instance.TileWidth = value

value = instance.TileWidth
public Nullable<uint> TileWidth {get; set;}
public: __property Nullable<uint> get_TileWidth();
public: __property void set_TileWidth(
   Nullable<uint> value
);
public:
property Nullable<uint> TileWidth {
   Nullable<uint> get();
   void set (    Nullable<uint> value);
}

Property Value

Nullable (boxed) uint value.
Remarks
This property accesses the TileWidth tag. The tag specifies the number of columns in each tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TransferFunction Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TransferFunction Property
Gets or sets TransferFunction tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransferFunction As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.TransferFunction = value

value = instance.TransferFunction
public ushort[] TransferFunction {get; set;}
public: __property ushort[]* get_TransferFunction();
public: __property void set_TransferFunction(
   ushort[]* value
);
public:
property array<ushort>^ TransferFunction {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


TransferRange Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : TransferRange Property
Gets or sets TransferRange tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransferRange As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.TransferRange = value

value = instance.TransferRange
public ushort[] TransferRange {get; set;}
public: __property ushort[]* get_TransferRange();
public: __property void set_TransferRange(
   ushort[]* value
);
public:
property array<ushort>^ TransferRange {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the TransferRange tag. The tag expands the range of the TransferFunction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


WhitePoint Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : WhitePoint Property
Gets or sets WhitePoint tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As ImGearRationalUInt()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As ImGearRationalUInt

instance.WhitePoint = value

value = instance.WhitePoint
public ImGearRationalUInt[] WhitePoint {get; set;}
public: __property ImGearRationalUInt[]* get_WhitePoint();
public: __property void set_WhitePoint(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ WhitePoint {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure[] array.
Remarks
This property accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


XPosition Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : XPosition Property
Gets or sets XPosition tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XPosition As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.XPosition = value

value = instance.XPosition
public Nullable<ImGearRationalUInt> XPosition {get; set;}
public: __property Nullable<ImGearRationalUInt> get_XPosition();
public: __property void set_XPosition(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> XPosition {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the XPosition tag. The tag specifies x position of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


XResolution Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : XResolution Property
Gets or sets XResolution tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.XResolution = value

value = instance.XResolution
public Nullable<ImGearRationalUInt> XResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_XResolution();
public: __property void set_XResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> XResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


YCbCrCoefficients Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : YCbCrCoefficients Property
Gets or sets YCbCrCoefficients tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrCoefficients As ImGearRationalUInt()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As ImGearRationalUInt

instance.YCbCrCoefficients = value

value = instance.YCbCrCoefficients
public ImGearRationalUInt[] YCbCrCoefficients {get; set;}
public: __property ImGearRationalUInt[]* get_YCbCrCoefficients();
public: __property void set_YCbCrCoefficients(
   ImGearRationalUInt[]* value
);
public:
property array<ImGearRationalUInt>^ YCbCrCoefficients {
   array<ImGearRationalUInt>^ get();
   void set (    array<ImGearRationalUInt>^ value);
}

Property Value

ImageGear.Core.ImGearRationalUInt structure array.
Remarks
This property accesses the YCbCrCoefficients tag value. The tag specifies the transformation from RGB to YCbCr image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


YCbCrPositioning Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : YCbCrPositioning Property
Gets or sets YCbCrPositioning tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrPositioning As Nullable(Of UShort)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of UShort)

instance.YCbCrPositioning = value

value = instance.YCbCrPositioning
public Nullable<ushort> YCbCrPositioning {get; set;}
public: __property Nullable<ushort> get_YCbCrPositioning();
public: __property void set_YCbCrPositioning(
   Nullable<ushort> value
);
public:
property Nullable<ushort> YCbCrPositioning {
   Nullable<ushort> get();
   void set (    Nullable<ushort> value);
}

Property Value

Nullable (boxed) ushort value.
Remarks
This property accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


YCbCrSubSampling Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : YCbCrSubSampling Property
Gets or sets YCbCrSubSampling tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrSubSampling As UShort()
'Usage

Dim instance As ImGearTIFFMetadata
Dim value() As UShort

instance.YCbCrSubSampling = value

value = instance.YCbCrSubSampling
public ushort[] YCbCrSubSampling {get; set;}
public: __property ushort[]* get_YCbCrSubSampling();
public: __property void set_YCbCrSubSampling(
   ushort[]* value
);
public:
property array<ushort>^ YCbCrSubSampling {
   array<ushort>^ get();
   void set (    array<ushort>^ value);
}

Property Value

Unsigned short array.
Remarks
This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


YPosition Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : YPosition Property
Gets or sets YPosition tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YPosition As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.YPosition = value

value = instance.YPosition
public Nullable<ImGearRationalUInt> YPosition {get; set;}
public: __property Nullable<ImGearRationalUInt> get_YPosition();
public: __property void set_YPosition(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> YPosition {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


YResolution Property (ImGearTIFFMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.TIF Namespace > ImGearTIFFMetadata Class : YResolution Property
Gets or sets YResolution tag value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YResolution As Nullable(Of ImGearRationalUInt)
'Usage

Dim instance As ImGearTIFFMetadata
Dim value As Nullable(Of ImGearRationalUInt)

instance.YResolution = value

value = instance.YResolution
public Nullable<ImGearRationalUInt> YResolution {get; set;}
public: __property Nullable<ImGearRationalUInt> get_YResolution();
public: __property void set_YResolution(
   Nullable<ImGearRationalUInt> value
);
public:
property Nullable<ImGearRationalUInt> YResolution {
   Nullable<ImGearRationalUInt> get();
   void set (    Nullable<ImGearRationalUInt> value);
}

Property Value

Nullable (boxed) ImageGear.Core.ImGearRationalUInt structure value.
Remarks
This property accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members
ImGearRationalUInt Structure


ImageGear.Formats.XMP Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP Namespace
This namespace provides the API for XMP format.
Classes
 | Class | Description
Class | ImGearXMPAlt<T> | Represents an array of XMP properties.
Class | ImGearXMPArray<T> | Represents baseline features of an array of XMP properties.
Class | ImGearXMPBag<T> | Represents an unordered array of XMP properties.
Class | ImGearXMPBoolean | Represents a boolean XMP metadata property.
Class | ImGearXMPColorant | Represents an XMP colorant structure.
Class | ImGearXMPDate | Represents a Date XMP metadata type.
Class | ImGearXMPDimensions | Represents an XMP Dimensions structure.
Class | ImGearXMPEnum<T> | Represents an enumeration (closed choice of integer) XMP metadata property.
Class | ImGearXMPFont | Represents an XMP Font structure.
Class | ImGearXMPFormatMetadata | The base for XMP schema accessor classes.
Class | ImGearXMPInteger | Represents an integer XMP metadata property.
Class | ImGearXMPLangAlt | Represents a language alternative.
Class | ImGearXMPMetadataRoot | Provides simplified access to XMP metadata.
Class | ImGearXMPRational | Represents a rational XMP metadata property.
Class | ImGearXMPReal | Represents a floating point XMP metadata property.
Class | ImGearXMPSeq<T> | Represents an ordered array of XMP properties.
Class | ImGearXMPString | Represents a string XMP metadata property.
Class | ImGearXMPStructure | Specifies baseline features for XMP structures.
Class | ImGearXMPThumbnail | Represents an XMP Thumbnail structure.
Class | ImGearXMPValue | Specifies baseline features for an XMP property value.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata
ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata
ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata
ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata
ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata
ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata
ImageGear.Formats.XMP.EXIF.ImGearEXIFXMPMetadata
ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata
ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata
ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata
ImageGear.Formats.XMP.MicrosoftPhoto.ImGearMicrosoftPhotoXMPMetadata
ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata
ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata
ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata
ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata
ImageGear.Formats.XMP.ImGearXMPMetadataRoot
ImageGear.Formats.XMP.ImGearXMPArray<T>
ImageGear.Formats.XMP.ImGearXMPAlt<T>
ImageGear.Formats.XMP.ImGearXMPBag<T>
ImageGear.Formats.XMP.ImGearXMPSeq<T>
ImageGear.Formats.XMP.ImGearXMPLangAlt
ImageGear.Formats.XMP.ImGearXMPReal
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.EXIF.ImGearXMPGPSCoordinate
ImageGear.Formats.XMP.ImGearXMPBoolean
ImageGear.Formats.XMP.ImGearXMPDate
ImageGear.Formats.XMP.ImGearXMPEnum<T>
ImageGear.Formats.XMP.ImGearXMPInteger
ImageGear.Formats.XMP.ImGearXMPRational
ImageGear.Formats.XMP.ImGearXMPString
ImageGear.Formats.XMP.Basic.ImGearBasicXMPIdentifier
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.BasicJobTicket.ImGearXMPJob
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPBeatSpliceStretch
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMarker
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMedia
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPProjectLink
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTime
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimecode
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimeScaleStretch
ImageGear.Formats.XMP.EXIF.ImGearXMPCFAPattern
ImageGear.Formats.XMP.EXIF.ImGearXMPDeviceSettings
ImageGear.Formats.XMP.EXIF.ImGearXMPFlash
ImageGear.Formats.XMP.EXIF.ImGearXMPOECFSFR
ImageGear.Formats.XMP.ImGearXMPColorant
ImageGear.Formats.XMP.ImGearXMPDimensions
ImageGear.Formats.XMP.ImGearXMPFont
ImageGear.Formats.XMP.IPTC.ImGearXMPContactInfo
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceEvent
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceReference
ImageGear.Formats.XMP.MediaManagement.ImGearXMPVersion
ImageGear.Formats.XMP.ImGearXMPThumbnail
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearXMPAlt<T> Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPAlt<T> Class
ImGearXMPValue type.
Represents an array of XMP properties.
Object Model
ImGearXMPAlt<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearXMPAlt(Of T As {New, ImGearXMPValue})
   Inherits ImGearXMPArray(Of T)
'Usage

Dim instance As ImGearXMPAlt(Of T)
public sealed class ImGearXMPAlt<T> : ImGearXMPArray<T>
where T: new(), ImGearXMPValue
public __gc __sealed class ImGearXMPAlt<T> : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
generic<typename T>
public ref class ImGearXMPAlt sealed : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
Type Parameters
T
ImGearXMPValue type.
Remarks
This class represents an array of XMP properties, one of which should be chosen by the application or by the user. First item in the array is considered to be the default one.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPArray<T>
ImageGear.Formats.XMP.ImGearXMPAlt<T>

See Also

Reference

ImGearXMPAlt<T> Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPAlt<T> Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPAlt<T> Class

The following tables list the members exposed by ImGearXMPAlt<T>.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPAlt<T> Constructor | Overloaded. Initializes a new instance of the ImGearXMPAlt<T> class.
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPAlt<T>.
Top
See Also

Reference

ImGearXMPAlt<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Properties$$

ImGearXMPAlt<T> Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPAlt<T> Class

For a list of all members of this type, see ImGearXMPAlt<T> members.

See Also

Reference

ImGearXMPAlt<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPAlt<T> Class : ImGearXMPAlt<T> Constructor
Initializes a new instance of the ImGearXMPAlt<T> class.
Overload List
Overload | Description
ImGearXMPAlt<T> Constructor() | Initializes a new instance of the ImGearXMPAlt<T> class.
ImGearXMPAlt<T> Constructor(String[]) | Initializes a new instance of the ImGearXMPAlt<T> class with values from the string array.
See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPAlt<T> Class > ImGearXMPAlt<T> Constructor : ImGearXMPAlt<T> Constructor()
Initializes a new instance of the ImGearXMPAlt<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPAlt(Of T)()
public ImGearXMPAlt<T>()
public: ImGearXMPAlt<T>();
public:
ImGearXMPAlt<T>();

Return Value

New instance of ImGearXMPAlt<T> generic class object.
Remarks
This constructor creates an empty instance of ImGearXMPAlt<T> generic class.
See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor(String[])

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPAlt<T> Class > ImGearXMPAlt<T> Constructor : ImGearXMPAlt<T> Constructor(String[])
String array.
Initializes a new instance of the ImGearXMPAlt<T> class with values from the string array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value() As String _
)
'Usage

Dim value() As String

Dim instance As New ImGearXMPAlt(Of T)(value)
public ImGearXMPAlt<T>(
   string[] value
)
public: ImGearXMPAlt<T>(
   string*[]* value
)
public:
ImGearXMPAlt<T>(
   array<String^>^ value
)

Parameters

value
String array.

Return Value

New instance of ImGearXMPAlt<T> generic class object.
Remarks
This constructor creates an instance of ImGearXMPAlt<T> generic class and initializes it with values from the string array.
See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPAlt<T> Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPAlt<T> Class

For a list of all members of this type, see ImGearXMPAlt<T> members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPAlt<T>.
Top
See Also

Reference

ImGearXMPAlt<T> Class
ImageGear.Formats.XMP Namespace


GetEnumerator Method (ImGearXMPAlt<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPAlt<T> Class : GetEnumerator Method
Returns an enumerator that iterates through the ImGearXMPAlt<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearXMPAlt(Of T)
Dim value As IEnumerator

value = instance.GetEnumerator()
public new IEnumerator GetEnumerator()
public: new IEnumerator* GetEnumerator();
public:
new IEnumerator^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPAlt<T>.
See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members


%%PageItemTitle%%

ImGearXMPArray<T> Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPArray<T> Class
ImGearXMPValue type.
Represents baseline features of an array of XMP properties.
Object Model
ImGearXMPArray<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearXMPArray(Of T As {New, ImGearXMPValue})
'Usage

Dim instance As ImGearXMPArray(Of T)
[DefaultMember("Item")]
public class ImGearXMPArray<T>
where T: new(), ImGearXMPValue
[DefaultMember("Item")]
public __gc class ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
[DefaultMember("Item")]
generic<typename T>
public ref class ImGearXMPArray
where T: gcnew(), ImGearXMPValue
Type Parameters
T
ImGearXMPValue type.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPArray<T>
ImageGear.Formats.XMP.ImGearXMPAlt<T>
ImageGear.Formats.XMP.ImGearXMPBag<T>
ImageGear.Formats.XMP.ImGearXMPSeq<T>

See Also

Reference

ImGearXMPArray<T> Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPArray<T> Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPArray<T> Class

The following tables list the members exposed by ImGearXMPArray<T>.

Protected Constructors
 | Name | Description
Protected Constructor | ImGearXMPArray<T> Constructor | Initializes a new instance of the ImGearXMPArray<T> class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the ImGearXMPArray<T>.
Public Property | IsReadOnly | Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.
Public Property | Item | Gets or sets the element at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the ImGearXMPArray<T>.
Public Method | Clear | Removes all elements from the ImGearXMPArray<T>.
Public Method | Contains | Determines whether an element is in the ImGearXMPArray<T>.
Public Method | CopyTo | Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPArray<T>.
Public Method | IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.
Public Method | Insert | Inserts an element into the ImGearXMPArray<T> at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the ImGearXMPArray<T>.
Public Method | RemoveAt | Removes the element at the specified index of the ImGearXMPArray<T>.
Public Method | ToString | Returns a System.String that represents the current ImGearXMPArray<T>.
Top
See Also

Reference

ImGearXMPArray<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPArray<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : ImGearXMPArray<T> Constructor
Initializes a new instance of the ImGearXMPArray<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function New()
'Usage

Dim instance As New ImGearXMPArray(Of T)()
protected ImGearXMPArray<T>()
protected: ImGearXMPArray<T>();
protected:
ImGearXMPArray<T>();
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%% $$Methods$$

ImGearXMPArray<T> Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPArray<T> Class

For a list of all members of this type, see ImGearXMPArray<T> members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the ImGearXMPArray<T>.
Public Method | Clear | Removes all elements from the ImGearXMPArray<T>.
Public Method | Contains | Determines whether an element is in the ImGearXMPArray<T>.
Public Method | CopyTo | Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPArray<T>.
Public Method | IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.
Public Method | Insert | Inserts an element into the ImGearXMPArray<T> at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the ImGearXMPArray<T>.
Public Method | RemoveAt | Removes the element at the specified index of the ImGearXMPArray<T>.
Public Method | ToString | Returns a System.String that represents the current ImGearXMPArray<T>.
Top
See Also

Reference

ImGearXMPArray<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPArray<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : ImGearXMPArray<T> Constructor
Overload List
Overload | Description
ImGearXMPArray<T> Constructor | Initializes a new instance of the ImGearXMPArray<T> class.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Add Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Add Method
The object to be added to the end of the ImGearXMPArray<T>.
Adds an object to the end of the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal item As T _
)
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim item As T

instance.Add(item)
public void Add(
   T item
)
public: void Add(
   T* item
)
public:
void Add(
   T^ item
)

Parameters

item
The object to be added to the end of the ImGearXMPArray<T>.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Clear Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Clear Method
Removes all elements from the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearXMPArray(Of T)

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Contains Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Contains Method
The object to locate in the ImGearXMPArray<T>.
Determines whether an element is in the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal item As T _
) As Boolean
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim item As T
Dim value As Boolean

value = instance.Contains(item)
public bool Contains(
   T item
)
public: bool Contains(
   T* item
)
public:
bool Contains(
   T^ item
)

Parameters

item
The object to locate in the ImGearXMPArray<T>.

Return Value

true if item is found in the ImGearXMPArray<T>; otherwise - false.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


CopyTo Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : CopyTo Method
The one-dimensional System.Array that is the destination of the elements copied from ImGearXMPArray<T>. The System.Array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal arrayIndex As Integer _
)
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim array() As T
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
public void CopyTo(
   T[] array,
   int arrayIndex
)
public: void CopyTo(
   T*[]* array,
   int arrayIndex
)
public:
void CopyTo(
   array<T^>^ array,
   int arrayIndex
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from ImGearXMPArray<T>. The System.Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.
Exceptions
Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | arrayIndex is less than 0.
System.ArgumentException | arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ImGearXMPArray<T> is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


GetEnumerator Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : GetEnumerator Method
Returns an enumerator that iterates through the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator(Of T)
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim value As IEnumerator(Of T)

value = instance.GetEnumerator()
public IEnumerator<T> GetEnumerator()
public: IEnumerator<T*>* GetEnumerator();
public:
IEnumerator<T^>^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPArray<T>.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


IndexOf Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : IndexOf Method
The object to locate in the ImGearXMPArray<T>.
Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal item As T _
) As Integer
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim item As T
Dim value As Integer

value = instance.IndexOf(item)
public int IndexOf(
   T item
)
public: int IndexOf(
   T* item
)
public:
int IndexOf(
   T^ item
)

Parameters

item
The object to locate in the ImGearXMPArray<T>.

Return Value

The zero-based index of the first occurrence of item within the entire ImGearXMPArray<T>, if found; otherwise, –1.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Insert Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Insert Method
The zero-based index at which item should be inserted.
The object to insert.
Inserts an element into the ImGearXMPArray<T> at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As T _
)
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim index As Integer
Dim item As T

instance.Insert(index, item)
public void Insert(
   int index,
   T item
)
public: void Insert(
   int index,
   T* item
)
public:
void Insert(
   int index,
   T^ item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is less than 0. -or- index is greater than Count.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Remove Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Remove Method
The object to remove from the ImGearXMPArray<T>.
Removes the first occurrence of a specific object from the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Remove( _
   ByVal item As T _
) As Boolean
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim item As T
Dim value As Boolean

value = instance.Remove(item)
public bool Remove(
   T item
)
public: bool Remove(
   T* item
)
public:
bool Remove(
   T^ item
)

Parameters

item
The object to remove from the ImGearXMPArray<T>.

Return Value

If item was successfully removed, returns true, otherwise - false. This method also returns false if item was not found in the ImGearXMPArray<T>.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


RemoveAt Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is less than 0. -or- index is greater than Count.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


ToString Method (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : ToString Method
Returns a System.String that represents the current ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

A System.String that represents the current object.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%% $$Properties$$

ImGearXMPArray<T> Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPArray<T> Class

For a list of all members of this type, see ImGearXMPArray<T> members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the ImGearXMPArray<T>.
Public Property | IsReadOnly | Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

ImGearXMPArray<T> Class
ImageGear.Formats.XMP Namespace


Count Property (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Count Property
Gets the number of elements actually contained in the ImGearXMPArray<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.The number of elements actually contained in the ImGearXMPArray<T>.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


IsReadOnly Property (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : IsReadOnly Property
Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim value As Boolean

value = instance.IsReadOnly
public bool IsReadOnly {get;}
public: __property bool get_IsReadOnly();
public:
property bool IsReadOnly {
   bool get();
}

Property Value

Boolean value.false
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


Item Property (ImGearXMPArray<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPArray<T> Class : Item Property
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As T
'Usage

Dim instance As ImGearXMPArray(Of T)
Dim index As Integer
Dim value As T

instance.Item(index) = value

value = instance.Item(index)
public T this[
   int index
]; {get; set;}
public: __property T* get_Item   int index
;
public: __property void set_Item   int index,
   T* value
;
public:
property T^ default [int] {
   T^ get(int index);
   void set (int index, T^ value);
}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is less than 0. -or- index is greater than Count.
See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

ImGearXMPBag<T> Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBag<T> Class
ImGearXMPValue type.
Represents an unordered array of XMP properties.
Object Model
ImGearXMPBag<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearXMPBag(Of T As {New, ImGearXMPValue})
   Inherits ImGearXMPArray(Of T)
'Usage

Dim instance As ImGearXMPBag(Of T)
public sealed class ImGearXMPBag<T> : ImGearXMPArray<T>
where T: new(), ImGearXMPValue
public __gc __sealed class ImGearXMPBag<T> : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
generic<typename T>
public ref class ImGearXMPBag sealed : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
Type Parameters
T
ImGearXMPValue type.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPArray<T>
ImageGear.Formats.XMP.ImGearXMPBag<T>

See Also

Reference

ImGearXMPBag<T> Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPBag<T> Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBag<T> Class

The following tables list the members exposed by ImGearXMPBag<T>.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPBag<T> Constructor | Overloaded. Initializes a new instance of the ImGearXMPBag<T> class.
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPBag<T>.
Top
See Also

Reference

ImGearXMPBag<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Properties$$

ImGearXMPBag<T> Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBag<T> Class

For a list of all members of this type, see ImGearXMPBag<T> members.

See Also

Reference

ImGearXMPBag<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPBag<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBag<T> Class : ImGearXMPBag<T> Constructor
Initializes a new instance of the ImGearXMPBag<T> class.
Overload List
Overload | Description
ImGearXMPBag<T> Constructor() | Initializes a new instance of the ImGearXMPBag<T> class.
ImGearXMPBag<T> Constructor(String[]) | Initializes a new instance of the ImGearXMPBag<T> class and initializes it with values from the string array.
See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members


%%PageItemTitle%%

ImGearXMPBag<T> Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBag<T> Class > ImGearXMPBag<T> Constructor : ImGearXMPBag<T> Constructor()
Initializes a new instance of the ImGearXMPBag<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPBag(Of T)()
public ImGearXMPBag<T>()
public: ImGearXMPBag<T>();
public:
ImGearXMPBag<T>();

Return Value

New instance of ImGearXMPBag<T> generic class object.
Remarks
This constructor creates an empty instance of ImGearXMPBag<T> generic class.
See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPBag<T> Constructor(String[])

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBag<T> Class > ImGearXMPBag<T> Constructor : ImGearXMPBag<T> Constructor(String[])
String array.
Initializes a new instance of the ImGearXMPBag<T> class and initializes it with values from the string array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value() As String _
)
'Usage

Dim value() As String

Dim instance As New ImGearXMPBag(Of T)(value)
public ImGearXMPBag<T>(
   string[] value
)
public: ImGearXMPBag<T>(
   string*[]* value
)
public:
ImGearXMPBag<T>(
   array<String^>^ value
)

Parameters

value
String array.

Return Value

New instance of ImGearXMPBag<T> generic class object.
Remarks
This constructor creates an instance of ImGearXMPBag<T> generic class and initializes it with values from the string array.
See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPBag<T> Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBag<T> Class

For a list of all members of this type, see ImGearXMPBag<T> members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPBag<T>.
Top
See Also

Reference

ImGearXMPBag<T> Class
ImageGear.Formats.XMP Namespace


GetEnumerator Method (ImGearXMPBag<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBag<T> Class : GetEnumerator Method
Returns an enumerator that iterates through the ImGearXMPBag<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearXMPBag(Of T)
Dim value As IEnumerator

value = instance.GetEnumerator()
public new IEnumerator GetEnumerator()
public: new IEnumerator* GetEnumerator();
public:
new IEnumerator^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPBag<T>.
See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members


%%PageItemTitle%%

ImGearXMPBoolean Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBoolean Class
Represents a boolean XMP metadata property.
Object Model
ImGearXMPBoolean Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPBoolean
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPBoolean
public class ImGearXMPBoolean : ImGearXMPValue
public __gc class ImGearXMPBoolean : public ImGearXMPValue
public ref class ImGearXMPBoolean : public ImGearXMPValue
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPBoolean

See Also

Reference

ImGearXMPBoolean Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPBoolean Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBoolean Class

The following tables list the members exposed by ImGearXMPBoolean.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPBoolean Constructor | Overloaded. Initializes a new instance of the ImGearXMPBoolean class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets a value indicating whether boolean value is true or false.
Top
See Also

Reference

ImGearXMPBoolean Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPBoolean Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBoolean Class : ImGearXMPBoolean Constructor
Initializes a new instance of the ImGearXMPBoolean class.
Overload List
Overload | Description
ImGearXMPBoolean Constructor(Boolean) | Initializes a new instance of the ImGearXMPBoolean class with a bool value.
ImGearXMPBoolean Constructor() | Initializes a new instance of the ImGearXMPBoolean class with a default value.
See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members


%%PageItemTitle%%

ImGearXMPBoolean Constructor(Boolean)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBoolean Class > ImGearXMPBoolean Constructor : ImGearXMPBoolean Constructor(Boolean)
Boolean value.
Initializes a new instance of the ImGearXMPBoolean class with a bool value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Boolean _
)
'Usage

Dim value As Boolean

Dim instance As New ImGearXMPBoolean(value)
public ImGearXMPBoolean(
   bool value
)
public: ImGearXMPBoolean(
   bool value
)
public:
ImGearXMPBoolean(
   bool value
)

Parameters

value
Boolean value.

Return Value

New instance of ImGearXMPBoolean class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPBoolean class by using a bool value.
See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members
Overload List


%%PageItemTitle%%

ImGearXMPBoolean Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBoolean Class > ImGearXMPBoolean Constructor : ImGearXMPBoolean Constructor()
Initializes a new instance of the ImGearXMPBoolean class with a default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPBoolean()
public ImGearXMPBoolean()
public: ImGearXMPBoolean();
public:
ImGearXMPBoolean();

Return Value

New instance of ImGearXMPBoolean class object.
Remarks
This constructor creates an instance of ImGearXMPBoolean class and initializes it with a default value (false).
See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearXMPBoolean Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPBoolean Class

For a list of all members of this type, see ImGearXMPBoolean members.

Public Properties
 | Name | Description
Public Property | Value | Gets a value indicating whether boolean value is true or false.
Top
See Also

Reference

ImGearXMPBoolean Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPBoolean)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPBoolean Class : Value Property
Gets a value indicating whether boolean value is true or false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Boolean
'Usage

Dim instance As ImGearXMPBoolean
Dim value As Boolean

value = instance.Value
public bool Value {get;}
public: __property bool get_Value();
public:
property bool Value {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members


%%PageItemTitle%%

ImGearXMPColorant Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPColorant Class
Represents an XMP colorant structure.
Object Model
ImGearXMPColorant ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPString ClassImGearXMPReal Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPColorant
   Inherits ImGearXMPStructure
'Usage

Dim instance As ImGearXMPColorant
public class ImGearXMPColorant : ImGearXMPStructure
public __gc class ImGearXMPColorant : public ImGearXMPStructure
public ref class ImGearXMPColorant : public ImGearXMPStructure
Remarks
This structure contains the characteristics of a colorant (swatch) used in a document.

See XMP specification for structure usage details.

Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.ImGearXMPColorant

See Also

Reference

ImGearXMPColorant Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPColorant Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPColorant Class

The following tables list the members exposed by ImGearXMPColorant.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPColorant Constructor | Initializes a new instance of the ImGearXMPColorant class.
Top
Public Properties
 | Name | Description
Public Property | A | Gets or sets A value when the mode is LAB.
Public Property | B | Gets or sets B value when the mode is LAB.
Public Property | Black | Gets or sets black value when the mode is CMYK.
Public Property | Blue | Gets or sets blue value when the mode is RGB.
Public Property | Cyan | Gets or sets cyan value when the mode is CMYK.
Public Property | Green | Gets or sets green value when the mode is RGB.
Public Property | L | Gets or sets L value when the mode is LAB.
Public Property | Magenta | Gets or sets magenta value when the mode is CMYK.
Public Property | Mode | Gets or sets the color space in which the color is defined.
Public Property | Red | Gets or sets red value when the mode is RGB.
Public Property | SwatchName | Gets or sets name of the swatch.
Public Property | Type | Gets or sets the type of color, one of PROCESS or SPOT.
Public Property | Yellow | Gets or sets yellow value when the mode is CMYK.
Top
See Also

Reference

ImGearXMPColorant Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPColorant Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : ImGearXMPColorant Constructor
Initializes a new instance of the ImGearXMPColorant class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPColorant()
public ImGearXMPColorant()
public: ImGearXMPColorant();
public:
ImGearXMPColorant();

Return Value

New instance of ImGearXMPColorant class object.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%% $$Properties$$

ImGearXMPColorant Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPColorant Class

For a list of all members of this type, see ImGearXMPColorant members.

Public Properties
 | Name | Description
Public Property | A | Gets or sets A value when the mode is LAB.
Public Property | B | Gets or sets B value when the mode is LAB.
Public Property | Black | Gets or sets black value when the mode is CMYK.
Public Property | Blue | Gets or sets blue value when the mode is RGB.
Public Property | Cyan | Gets or sets cyan value when the mode is CMYK.
Public Property | Green | Gets or sets green value when the mode is RGB.
Public Property | L | Gets or sets L value when the mode is LAB.
Public Property | Magenta | Gets or sets magenta value when the mode is CMYK.
Public Property | Mode | Gets or sets the color space in which the color is defined.
Public Property | Red | Gets or sets red value when the mode is RGB.
Public Property | SwatchName | Gets or sets name of the swatch.
Public Property | Type | Gets or sets the type of color, one of PROCESS or SPOT.
Public Property | Yellow | Gets or sets yellow value when the mode is CMYK.
Top
See Also

Reference

ImGearXMPColorant Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPColorant Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : ImGearXMPColorant Constructor
Overload List
Overload | Description
ImGearXMPColorant Constructor | Initializes a new instance of the ImGearXMPColorant class.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


A Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : A Property
Gets or sets A value when the mode is LAB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property A As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPInteger

instance.A = value

value = instance.A
public ImGearXMPInteger A {get; set;}
public: __property ImGearXMPInteger* get_A();
public: __property void set_A(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ A {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is -128..127.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


B Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : B Property
Gets or sets B value when the mode is LAB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property B As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPInteger

instance.B = value

value = instance.B
public ImGearXMPInteger B {get; set;}
public: __property ImGearXMPInteger* get_B();
public: __property void set_B(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ B {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is -128..127.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Black Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Black Property
Gets or sets black value when the mode is CMYK.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Black As ImGearXMPReal
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPReal

instance.Black = value

value = instance.Black
public ImGearXMPReal Black {get; set;}
public: __property ImGearXMPReal* get_Black();
public: __property void set_Black(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Black {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
Remarks
Valid range is 0 ... 100.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Blue Property (ImGearXMPColorant)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Blue Property
Gets or sets blue value when the mode is RGB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Blue As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPInteger

instance.Blue = value

value = instance.Blue
public ImGearXMPInteger Blue {get; set;}
public: __property ImGearXMPInteger* get_Blue();
public: __property void set_Blue(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Blue {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..255.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Cyan Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Cyan Property
Gets or sets cyan value when the mode is CMYK.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cyan As ImGearXMPReal
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPReal

instance.Cyan = value

value = instance.Cyan
public ImGearXMPReal Cyan {get; set;}
public: __property ImGearXMPReal* get_Cyan();
public: __property void set_Cyan(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Cyan {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
Remarks
Valid range is 0 ... 100.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Green Property (ImGearXMPColorant)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Green Property
Gets or sets green value when the mode is RGB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Green As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPInteger

instance.Green = value

value = instance.Green
public ImGearXMPInteger Green {get; set;}
public: __property ImGearXMPInteger* get_Green();
public: __property void set_Green(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Green {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..255.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


L Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : L Property
Gets or sets L value when the mode is LAB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property L As ImGearXMPReal
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPReal

instance.L = value

value = instance.L
public ImGearXMPReal L {get; set;}
public: __property ImGearXMPReal* get_L();
public: __property void set_L(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ L {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
Remarks
Valid range is 0..100.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Magenta Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Magenta Property
Gets or sets magenta value when the mode is CMYK.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Magenta As ImGearXMPReal
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPReal

instance.Magenta = value

value = instance.Magenta
public ImGearXMPReal Magenta {get; set;}
public: __property ImGearXMPReal* get_Magenta();
public: __property void set_Magenta(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Magenta {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
Remarks
Valid range is 0 ... 100.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Mode Property (ImGearXMPColorant)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Mode Property
Gets or sets the color space in which the color is defined.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As ImGearXMPString
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPString

instance.Mode = value

value = instance.Mode
public ImGearXMPString Mode {get; set;}
public: __property ImGearXMPString* get_Mode();
public: __property void set_Mode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Mode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Red Property (ImGearXMPColorant)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Red Property
Gets or sets red value when the mode is RGB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Red As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPInteger

instance.Red = value

value = instance.Red
public ImGearXMPInteger Red {get; set;}
public: __property ImGearXMPInteger* get_Red();
public: __property void set_Red(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Red {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..255.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


SwatchName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : SwatchName Property
Gets or sets name of the swatch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SwatchName As ImGearXMPString
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPString

instance.SwatchName = value

value = instance.SwatchName
public ImGearXMPString SwatchName {get; set;}
public: __property ImGearXMPString* get_SwatchName();
public: __property void set_SwatchName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ SwatchName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Type Property (ImGearXMPColorant)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Type Property
Gets or sets the type of color, one of PROCESS or SPOT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearXMPString
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPString

instance.Type = value

value = instance.Type
public ImGearXMPString Type {get; set;}
public: __property ImGearXMPString* get_Type();
public: __property void set_Type(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Type {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


Yellow Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPColorant Class : Yellow Property
Gets or sets yellow value when the mode is CMYK.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Yellow As ImGearXMPReal
'Usage

Dim instance As ImGearXMPColorant
Dim value As ImGearXMPReal

instance.Yellow = value

value = instance.Yellow
public ImGearXMPReal Yellow {get; set;}
public: __property ImGearXMPReal* get_Yellow();
public: __property void set_Yellow(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Yellow {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
Remarks
Valid range is 0 ... 100.
See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

ImGearXMPDate Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDate Class
Represents a Date XMP metadata type.
Object Model
ImGearXMPDate ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPDate
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPDate
public class ImGearXMPDate : ImGearXMPValue
public __gc class ImGearXMPDate : public ImGearXMPValue
public ref class ImGearXMPDate : public ImGearXMPValue
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPDate

See Also

Reference

ImGearXMPDate Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPDate Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDate Class

The following tables list the members exposed by ImGearXMPDate.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPDate Constructor | Overloaded. Initializes a new instance of the ImGearXMPDate class.
Top
Public Properties
 | Name | Description
Public Property | Day | Gets or sets Day value.
Public Property | Fraction | Gets or sets fraction of a second value.
Public Property | Hour | Gets or sets Hour value.
Public Property | Minute | Gets or sets Minute value.
Public Property | Month | Gets or sets Month value.
Public Property | Second | Gets or sets Second value.
Public Property | Year | Gets or sets Year value.
Public Property | ZoneOffsetHour | Gets or sets Zone Offset Hour value.
Public Property | ZoneOffsetMinute | Gets or sets Zone Offset Minute value.
Top
Public Methods
 | Name | Description
Public Method | GetDateTime | Gets the System.DateTime value.
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPDate Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPDate Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : ImGearXMPDate Constructor
Initializes a new instance of the ImGearXMPDate class.
Overload List
Overload | Description
ImGearXMPDate Constructor() | Initializes a new instance of the ImGearXMPDate class.
ImGearXMPDate Constructor(DateTime) | Initializes a new instance of the ImGearXMPDate class.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

ImGearXMPDate Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class > ImGearXMPDate Constructor : ImGearXMPDate Constructor()
Initializes a new instance of the ImGearXMPDate class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPDate()
public ImGearXMPDate()
public: ImGearXMPDate();
public:
ImGearXMPDate();

Return Value

New instance of the ImGearXMPDate class object.
Remarks
This constructor creates an instance of the ImGearXMPDate class and initializes its members to default values.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members
Overload List


%%PageItemTitle%%

ImGearXMPDate Constructor(DateTime)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class > ImGearXMPDate Constructor : ImGearXMPDate Constructor(DateTime)
Date and time.
Initializes a new instance of the ImGearXMPDate class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dateTime As Date _
)
'Usage

Dim dateTime As Date

Dim instance As New ImGearXMPDate(dateTime)
public ImGearXMPDate(
   DateTime dateTime
)
public: ImGearXMPDate(
   DateTime dateTime
)
public:
ImGearXMPDate(
   DateTime dateTime
)

Parameters

dateTime
Date and time.

Return Value

New instance of the ImGearXMPDate class object.
Remarks
This constructor creates and initializes an instance of the ImGearXMPDate class from a System.DateTime value. If the kind of DateTime value is Unspecified, the time zone offset (hour and minute) of the ImGearXMPDate class instance are left uninitialized. If the kind of DateTime value is UTC, the time zone offset (hour and minute) ImGearXMPDate class instance are initialized with zeroes. If the kind of DateTime value is Local, the time zone offset (hour and minute) ImGearXMPDate class instance are initialized with local time zone offset.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPDate Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDate Class

For a list of all members of this type, see ImGearXMPDate members.

Public Methods
 | Name | Description
Public Method | GetDateTime | Gets the System.DateTime value.
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPDate Class
ImageGear.Formats.XMP Namespace


GetDateTime Method

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : GetDateTime Method
Gets the System.DateTime value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDateTime() As Date
'Usage

Dim instance As ImGearXMPDate
Dim value As Date

value = instance.GetDateTime()
public DateTime GetDateTime()
public: DateTime GetDateTime();
public:
DateTime GetDateTime();

Return Value

System.DateTime value.
Remarks
This method gets the System.DateTime value corresponding to the ImGearXMPDate class. If the XMP date does not contain time zone designator, the method returns an DateTime value of an unspecified kind. If the XMP date contains time zone designator, the method returns an DateTime value of UTC kind.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


ToString Method (ImGearXMPDate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPDate
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%% $$Properties$$

ImGearXMPDate Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDate Class

For a list of all members of this type, see ImGearXMPDate members.

Public Properties
 | Name | Description
Public Property | Day | Gets or sets Day value.
Public Property | Fraction | Gets or sets fraction of a second value.
Public Property | Hour | Gets or sets Hour value.
Public Property | Minute | Gets or sets Minute value.
Public Property | Month | Gets or sets Month value.
Public Property | Second | Gets or sets Second value.
Public Property | Year | Gets or sets Year value.
Public Property | ZoneOffsetHour | Gets or sets Zone Offset Hour value.
Public Property | ZoneOffsetMinute | Gets or sets Zone Offset Minute value.
Top
See Also

Reference

ImGearXMPDate Class
ImageGear.Formats.XMP Namespace


Day Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Day Property
Gets or sets Day value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Day As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Day = value

value = instance.Day
public ImGearXMPInteger Day {get; set;}
public: __property ImGearXMPInteger* get_Day();
public: __property void set_Day(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Day {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..31.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Fraction Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Fraction Property
Gets or sets fraction of a second value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fraction As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Fraction = value

value = instance.Fraction
public ImGearXMPInteger Fraction {get; set;}
public: __property ImGearXMPInteger* get_Fraction();
public: __property void set_Fraction(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Fraction {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
The value must be positive.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Hour Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Hour Property
Gets or sets Hour value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hour As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Hour = value

value = instance.Hour
public ImGearXMPInteger Hour {get; set;}
public: __property ImGearXMPInteger* get_Hour();
public: __property void set_Hour(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Hour {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..23.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Minute Property (ImGearXMPDate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Minute Property
Gets or sets Minute value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Minute As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Minute = value

value = instance.Minute
public ImGearXMPInteger Minute {get; set;}
public: __property ImGearXMPInteger* get_Minute();
public: __property void set_Minute(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Minute {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..59.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Month Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Month Property
Gets or sets Month value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Month As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Month = value

value = instance.Month
public ImGearXMPInteger Month {get; set;}
public: __property ImGearXMPInteger* get_Month();
public: __property void set_Month(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Month {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 1..12.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Second Property (ImGearXMPDate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Second Property
Gets or sets Second value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Second As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Second = value

value = instance.Second
public ImGearXMPInteger Second {get; set;}
public: __property ImGearXMPInteger* get_Second();
public: __property void set_Second(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Second {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..59.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


Year Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : Year Property
Gets or sets Year value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Year As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.Year = value

value = instance.Year
public ImGearXMPInteger Year {get; set;}
public: __property ImGearXMPInteger* get_Year();
public: __property void set_Year(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Year {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..9999.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


ZoneOffsetHour Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : ZoneOffsetHour Property
Gets or sets Zone Offset Hour value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoneOffsetHour As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.ZoneOffsetHour = value

value = instance.ZoneOffsetHour
public ImGearXMPInteger ZoneOffsetHour {get; set;}
public: __property ImGearXMPInteger* get_ZoneOffsetHour();
public: __property void set_ZoneOffsetHour(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ZoneOffsetHour {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


ZoneOffsetMinute Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDate Class : ZoneOffsetMinute Property
Gets or sets Zone Offset Minute value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoneOffsetMinute As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDate
Dim value As ImGearXMPInteger

instance.ZoneOffsetMinute = value

value = instance.ZoneOffsetMinute
public ImGearXMPInteger ZoneOffsetMinute {get; set;}
public: __property ImGearXMPInteger* get_ZoneOffsetMinute();
public: __property void set_ZoneOffsetMinute(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ZoneOffsetMinute {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImGearXMPInteger class value.
Remarks
Valid range is 0..59.
See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

ImGearXMPDimensions Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDimensions Class
Represents an XMP Dimensions structure.
Object Model
ImGearXMPDimensions ClassImGearXMPReal ClassImGearXMPString ClassImGearXMPReal Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPDimensions
   Inherits ImGearXMPStructure
'Usage

Dim instance As ImGearXMPDimensions
public class ImGearXMPDimensions : ImGearXMPStructure
public __gc class ImGearXMPDimensions : public ImGearXMPStructure
public ref class ImGearXMPDimensions : public ImGearXMPStructure
Remarks
This structure contains dimensions of a drawn object.

See XMP specification for structure usage details.

Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.ImGearXMPDimensions

See Also

Reference

ImGearXMPDimensions Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPDimensions Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDimensions Class

The following tables list the members exposed by ImGearXMPDimensions.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPDimensions Constructor | Initializes a new instance of the ImGearXMPDimensions class.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets height.
Public Property | Unit | Gets or sets units.
Public Property | Width | Gets or sets width.
Top
See Also

Reference

ImGearXMPDimensions Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPDimensions Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDimensions Class : ImGearXMPDimensions Constructor
Initializes a new instance of the ImGearXMPDimensions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPDimensions()
public ImGearXMPDimensions()
public: ImGearXMPDimensions();
public:
ImGearXMPDimensions();

Return Value

New instance of the ImGearXMPDimensions class object.
See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%% $$Properties$$

ImGearXMPDimensions Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPDimensions Class

For a list of all members of this type, see ImGearXMPDimensions members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets height.
Public Property | Unit | Gets or sets units.
Public Property | Width | Gets or sets width.
Top
See Also

Reference

ImGearXMPDimensions Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPDimensions Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDimensions Class : ImGearXMPDimensions Constructor
Overload List
Overload | Description
ImGearXMPDimensions Constructor | Initializes a new instance of the ImGearXMPDimensions class.
See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


Height Property (ImGearXMPDimensions)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDimensions Class : Height Property
Gets or sets height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As ImGearXMPReal
'Usage

Dim instance As ImGearXMPDimensions
Dim value As ImGearXMPReal

instance.Height = value

value = instance.Height
public ImGearXMPReal Height {get; set;}
public: __property ImGearXMPReal* get_Height();
public: __property void set_Height(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Height {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


Unit Property (ImGearXMPDimensions)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDimensions Class : Unit Property
Gets or sets units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Unit As ImGearXMPString
'Usage

Dim instance As ImGearXMPDimensions
Dim value As ImGearXMPString

instance.Unit = value

value = instance.Unit
public ImGearXMPString Unit {get; set;}
public: __property ImGearXMPString* get_Unit();
public: __property void set_Unit(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Unit {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
Remarks
For example: inch, mm, pixel, pica, point.
See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


Width Property (ImGearXMPDimensions)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPDimensions Class : Width Property
Gets or sets width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As ImGearXMPReal
'Usage

Dim instance As ImGearXMPDimensions
Dim value As ImGearXMPReal

instance.Width = value

value = instance.Width
public ImGearXMPReal Width {get; set;}
public: __property ImGearXMPReal* get_Width();
public: __property void set_Width(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Width {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImGearXMPReal class value.
See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

ImGearXMPEnum<T> Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPEnum<T> Class
Struct type.
Represents an enumeration (closed choice of integer) XMP metadata property.
Object Model
ImGearXMPEnum<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPEnum(Of T As {New, Struct, IComparable, IFormattable, IConvertible})
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPEnum(Of T)
public class ImGearXMPEnum<T> : ImGearXMPValue
where T: new(), struct, IComparable, IFormattable, IConvertible
public __gc class ImGearXMPEnum<T> : public ImGearXMPValue
where T: gcnew(), value class, IComparable, IFormattable, IConvertible
generic<typename T>
public ref class ImGearXMPEnum : public ImGearXMPValue
where T: gcnew(), value class, IComparable, IFormattable, IConvertible
Type Parameters
T
Struct type.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPEnum<T>

See Also

Reference

ImGearXMPEnum<T> Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPEnum<T> Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPEnum<T> Class

The following tables list the members exposed by ImGearXMPEnum<T>.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPEnum<T> Constructor | Overloaded. Initializes a new instance of the ImGearXMPEnum<T> class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the enum value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPEnum<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPEnum<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPEnum<T> Class : ImGearXMPEnum<T> Constructor
Initializes a new instance of the ImGearXMPEnum<T> class.
Overload List
Overload | Description
ImGearXMPEnum<T> Constructor() | Initializes a new instance of the ImGearXMPEnum<T> class.
ImGearXMPEnum<T> Constructor(T) | Initializes a new instance of the ImGearXMPEnum<T> class.
See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%%

ImGearXMPEnum<T> Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPEnum<T> Class > ImGearXMPEnum<T> Constructor : ImGearXMPEnum<T> Constructor()
Initializes a new instance of the ImGearXMPEnum<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPEnum(Of T)()
public ImGearXMPEnum<T>()
public: ImGearXMPEnum<T>();
public:
ImGearXMPEnum<T>();

Return Value

New instance of the ImGearXMPEnum<T> generic class object.
Remarks
This constructor creates an instance of the ImGearXMPEnum<T> generic class.
See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPEnum<T> Constructor(T)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPEnum<T> Class > ImGearXMPEnum<T> Constructor : ImGearXMPEnum<T> Constructor(T)
Enum value.
Initializes a new instance of the ImGearXMPEnum<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As T _
)
'Usage

Dim value As T

Dim instance As New ImGearXMPEnum(Of T)(value)
public ImGearXMPEnum<T>(
   T value
)
public: ImGearXMPEnum<T>(
   T* value
)
public:
ImGearXMPEnum<T>(
   T^ value
)

Parameters

value
Enum value.

Return Value

New instance of the ImGearXMPEnum<T> generic class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPEnum<T> generic class by using an enumeration value.
See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPEnum<T> Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPEnum<T> Class

For a list of all members of this type, see ImGearXMPEnum<T> members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPEnum<T> Class
ImageGear.Formats.XMP Namespace


ToString Method (ImGearXMPEnum<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPEnum<T> Class : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPEnum(Of T)
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%% $$Properties$$

ImGearXMPEnum<T> Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPEnum<T> Class

For a list of all members of this type, see ImGearXMPEnum<T> members.

Public Properties
 | Name | Description
Public Property | Value | Gets the enum value.
Top
See Also

Reference

ImGearXMPEnum<T> Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPEnum<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPEnum<T> Class : Value Property
Gets the enum value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As T
'Usage

Dim instance As ImGearXMPEnum(Of T)
Dim value As T

value = instance.Value
public T Value {get;}
public: __property T* get_Value();
public:
property T^ Value {
   T^ get();
}

Property Value

Template value.
Remarks
This property gets the enumeration value of the ImGearXMPEnum<T> generic class object.
See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%%

ImGearXMPFont Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPFont Class
Represents an XMP Font structure.
Object Model
ImGearXMPFont ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPFont
   Inherits ImGearXMPStructure
'Usage

Dim instance As ImGearXMPFont
public class ImGearXMPFont : ImGearXMPStructure
public __gc class ImGearXMPFont : public ImGearXMPStructure
public ref class ImGearXMPFont : public ImGearXMPStructure
Remarks
This structure contains the characteristics of a font used in a document.

See XMP specification for structure usage details.

Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.ImGearXMPFont

See Also

Reference

ImGearXMPFont Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPFont Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPFont Class

The following tables list the members exposed by ImGearXMPFont.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPFont Constructor | Initializes a new instance of the ImGearXMPFont class.
Top
Public Properties
 | Name | Description
Public Property | ChildFontFiles | Gets or sets list of file names for the fonts that make up a composite font.
Public Property | Composite | Gets or sets a flag if composite font is specified.
Public Property | FontFace | Gets or sets font face name.
Public Property | FontFamily | Gets or sets font family name.
Public Property | FontFileName | Gets or sets font file name (not a complete path).
Public Property | FontName | Gets or sets postscript name of the font.
Public Property | FontType | Gets or sets font type.
Public Property | VersionString | Gets or sets version string.
Top
See Also

Reference

ImGearXMPFont Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPFont Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : ImGearXMPFont Constructor
Initializes a new instance of the ImGearXMPFont class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPFont()
public ImGearXMPFont()
public: ImGearXMPFont();
public:
ImGearXMPFont();

Return Value

New instance of theImGearXMPFont class object.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%% $$Properties$$

ImGearXMPFont Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPFont Class

For a list of all members of this type, see ImGearXMPFont members.

Public Properties
 | Name | Description
Public Property | ChildFontFiles | Gets or sets list of file names for the fonts that make up a composite font.
Public Property | Composite | Gets or sets a flag if composite font is specified.
Public Property | FontFace | Gets or sets font face name.
Public Property | FontFamily | Gets or sets font family name.
Public Property | FontFileName | Gets or sets font file name (not a complete path).
Public Property | FontName | Gets or sets postscript name of the font.
Public Property | FontType | Gets or sets font type.
Public Property | VersionString | Gets or sets version string.
Top
See Also

Reference

ImGearXMPFont Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPFont Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : ImGearXMPFont Constructor
Overload List
Overload | Description
ImGearXMPFont Constructor | Initializes a new instance of the ImGearXMPFont class.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


ChildFontFiles Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : ChildFontFiles Property
Gets or sets list of file names for the fonts that make up a composite font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChildFontFiles As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.ChildFontFiles = value

value = instance.ChildFontFiles
public ImGearXMPSeq<ImGearXMPString> ChildFontFiles {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_ChildFontFiles();
public: __property void set_ChildFontFiles(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ ChildFontFiles {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


Composite Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : Composite Property
Gets or sets a flag if composite font is specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Composite As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPBoolean

instance.Composite = value

value = instance.Composite
public ImGearXMPBoolean Composite {get; set;}
public: __property ImGearXMPBoolean* get_Composite();
public: __property void set_Composite(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Composite {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


FontFace Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : FontFace Property
Gets or sets font face name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontFace As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.FontFace = value

value = instance.FontFace
public ImGearXMPString FontFace {get; set;}
public: __property ImGearXMPString* get_FontFace();
public: __property void set_FontFace(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FontFace {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


FontFamily Property (ImGearXMPFont)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : FontFamily Property
Gets or sets font family name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontFamily As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.FontFamily = value

value = instance.FontFamily
public ImGearXMPString FontFamily {get; set;}
public: __property ImGearXMPString* get_FontFamily();
public: __property void set_FontFamily(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FontFamily {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


FontFileName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : FontFileName Property
Gets or sets font file name (not a complete path).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontFileName As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.FontFileName = value

value = instance.FontFileName
public ImGearXMPString FontFileName {get; set;}
public: __property ImGearXMPString* get_FontFileName();
public: __property void set_FontFileName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FontFileName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


FontName Property (ImGearXMPFont)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : FontName Property
Gets or sets postscript name of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontName As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.FontName = value

value = instance.FontName
public ImGearXMPString FontName {get; set;}
public: __property ImGearXMPString* get_FontName();
public: __property void set_FontName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FontName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


FontType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : FontType Property
Gets or sets font type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontType As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.FontType = value

value = instance.FontType
public ImGearXMPString FontType {get; set;}
public: __property ImGearXMPString* get_FontType();
public: __property void set_FontType(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FontType {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


VersionString Property (ImGearXMPFont)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPFont Class : VersionString Property
Gets or sets version string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VersionString As ImGearXMPString
'Usage

Dim instance As ImGearXMPFont
Dim value As ImGearXMPString

instance.VersionString = value

value = instance.VersionString
public ImGearXMPString VersionString {get; set;}
public: __property ImGearXMPString* get_VersionString();
public: __property void set_VersionString(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VersionString {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPString class value.
See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

ImGearXMPFormatMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPFormatMetadata Class
The base for XMP schema accessor classes.
Object Model
ImGearXMPFormatMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearXMPFormatMetadata
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearXMPFormatMetadata
public abstract class ImGearXMPFormatMetadata : ImageGear.Formats.ImGearFormatMetadata
public __gc abstract class ImGearXMPFormatMetadata : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearXMPFormatMetadata abstract : public ImageGear.Formats.ImGearFormatMetadata
Remarks
This class serves as the base for XMP schema accessor classes.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata
ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata
ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata
ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata
ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata
ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata
ImageGear.Formats.XMP.EXIF.ImGearEXIFXMPMetadata
ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata
ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata
ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata
ImageGear.Formats.XMP.MicrosoftPhoto.ImGearMicrosoftPhotoXMPMetadata
ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata
ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata
ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata
ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata

See Also

Reference

ImGearXMPFormatMetadata Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPFormatMetadata Class Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPFormatMetadata Class

The following tables list the members exposed by ImGearXMPFormatMetadata.

See Also

Reference

ImGearXMPFormatMetadata Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPInteger Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPInteger Class
Represents an integer XMP metadata property.
Object Model
ImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPInteger
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPInteger
public class ImGearXMPInteger : ImGearXMPValue
public __gc class ImGearXMPInteger : public ImGearXMPValue
public ref class ImGearXMPInteger : public ImGearXMPValue
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPInteger

See Also

Reference

ImGearXMPInteger Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPInteger Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPInteger Class

The following tables list the members exposed by ImGearXMPInteger.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPInteger Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the integer value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPInteger Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPInteger Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPInteger Class : ImGearXMPInteger Constructor
Overload List
Overload | Description
ImGearXMPInteger Constructor() | Initializes a new instance of the ImGearXMPInteger class.
ImGearXMPInteger Constructor(Int32) | Initializes a new instance of the ImGearXMPInteger class.
See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%%

ImGearXMPInteger Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPInteger Class > ImGearXMPInteger Constructor : ImGearXMPInteger Constructor()
Initializes a new instance of the ImGearXMPInteger class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPInteger()
public ImGearXMPInteger()
public: ImGearXMPInteger();
public:
ImGearXMPInteger();

Return Value

New instance of the ImGearXMPInteger class object.
See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members
Overload List


%%PageItemTitle%%

ImGearXMPInteger Constructor(Int32)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPInteger Class > ImGearXMPInteger Constructor : ImGearXMPInteger Constructor(Int32)
Integer value.
Initializes a new instance of the ImGearXMPInteger class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Integer _
)
'Usage

Dim value As Integer

Dim instance As New ImGearXMPInteger(value)
public ImGearXMPInteger(
   int value
)
public: ImGearXMPInteger(
   int value
)
public:
ImGearXMPInteger(
   int value
)

Parameters

value
Integer value.

Return Value

New instance of the ImGearXMPInteger class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPInteger class by using an integer value.
See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPInteger Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPInteger Class

For a list of all members of this type, see ImGearXMPInteger members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPInteger Class
ImageGear.Formats.XMP Namespace


ToString Method (ImGearXMPInteger)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPInteger Class : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPInteger
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%% $$Properties$$

ImGearXMPInteger Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPInteger Class

For a list of all members of this type, see ImGearXMPInteger members.

Public Properties
 | Name | Description
Public Property | Value | Gets the integer value.
Top
See Also

Reference

ImGearXMPInteger Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPInteger)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPInteger Class : Value Property
Gets the integer value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Integer
'Usage

Dim instance As ImGearXMPInteger
Dim value As Integer

value = instance.Value
public int Value {get;}
public: __property int get_Value();
public:
property int Value {
   int get();
}

Property Value

Integer value.
Remarks
This property gets the integer value of the ImGearXMPInteger class object.
See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%%

ImGearXMPLangAlt Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPLangAlt Class
Represents a language alternative.
Object Model
ImGearXMPLangAlt Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPLangAlt
'Usage

Dim instance As ImGearXMPLangAlt
public class ImGearXMPLangAlt
public __gc class ImGearXMPLangAlt
public ref class ImGearXMPLangAlt
Remarks
This class represents a language alternative. It contains the same logical text in multiple languages. The text in each specific language is available through properties of the ImGearXMPLangAlt object. If text in a specific language is does not exist in the object, corresponding property returns null. ImGearXMPLangAlt.Default property represents the default value for the language alternative.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPLangAlt

See Also

Reference

ImGearXMPLangAlt Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPLangAlt Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPLangAlt Class

The following tables list the members exposed by ImGearXMPLangAlt.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPLangAlt Constructor | Initializes a new instance of the ImGearXMPLangAlt class.
Top
Public Properties
 | Name | Description
Public Property | Afrikaans | Gets or sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Albanian | Gets or sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicAlgeria | Gets or sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicBahrain | Gets or sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicEgypt | Gets or sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicIraq | Gets or sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicJordan | Gets or sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicKuwait | Gets or sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicLebanon | Gets or sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicLibya | Gets or sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicMorocco | Gets or sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicOman | Gets or sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicQatar | Gets or sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicSaudiArabia | Gets or sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicSyria | Gets or sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicTunisia | Gets or sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicUnitedArabEmirates | Gets or sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicYemen | Gets or sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Armenian | Gets or sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | AzeriCyrillic | Gets or sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | AzeriLatin | Gets or sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Basque | Gets or sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Belarusian | Gets or sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Bulgarian | Gets or sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Catalan | Gets or sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseChina | Gets or sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseHongKongSAR | Gets or sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseMacauSAR | Gets or sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseSingapore | Gets or sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseTaiwan | Gets or sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Croatian | Gets or sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Czech | Gets or sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Danish | Gets or sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Default | Gets or sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | DutchBelgium | Gets or sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | DutchNetherlands | Gets or sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishAustralia | Gets or sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishBelize | Gets or sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishCanada | Gets or sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishCaribbean | Gets or sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishIreland | Gets or sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishJamaica | Gets or sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishNewZealand | Gets or sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishPhillippines | Gets or sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishSouthAfrica | Gets or sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishTrinidad | Gets or sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishUnitedKingdom | Gets or sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishUnitedStates | Gets or sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Estonian | Gets or sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Faroese | Gets or sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Farsi | Gets or sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Finnish | Gets or sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchBelgium | Gets or sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchCanada | Gets or sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchFrance | Gets or sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchLuxembourg | Gets or sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchSwitzerland | Gets or sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GaelicIreland | Gets or sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GaelicScotland | Gets or sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanAustria | Gets or sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanGermany | Gets or sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanLiechtenstein | Gets or sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanLuxembourg | Gets or sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanSwitzerland | Gets or sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Greek | Gets or sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hebrew | Gets or sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hindi | Gets or sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hungarian | Gets or sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Icelandic | Gets or sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Indonesian | Gets or sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ItalianItaly | Gets or sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ItalianSwitzerland | Gets or sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Japanese | Gets or sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Korean | Gets or sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Latvian | Gets or sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Lithuanian | Gets or sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MacedonianFYROM | Gets or sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MalayBrunei | Gets or sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MalayMalaysia | Gets or sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Maltese | Gets or sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Marathi | Gets or sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | NorwegianBokml | Gets or sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | NorwegianNynorsk | Gets or sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Polish | Gets or sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | PortugueseBrazil | Gets or sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | PortuguesePortugal | Gets or sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RaetoRomance | Gets or sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RomanianMoldova | Gets or sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RomanianRomania | Gets or sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Russian | Gets or sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RussianMoldova | Gets or sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Sanskrit | Gets or sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SerbianCyrillic | Gets or sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SerbianLatin | Gets or sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Setsuana | Gets or sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Slovak | Gets or sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Slovenian | Gets or sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Sorbian | Gets or sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SouthernSotho | Gets or sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishArgentina | Gets or sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishBolivia | Gets or sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishChile | Gets or sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishColombia | Gets or sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishCosta | Gets or sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishDominican | Gets or sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishEcuador | Gets or sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishElSalvador | Gets or sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishGuatemala | Gets or sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishHonduras | Gets or sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishMexico | Gets or sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishNicaragua | Gets or sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPanama | Gets or sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishParaguay | Gets or sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPeru | Gets or sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPuertoRico | Gets or sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishSpain | Gets or sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishUruguay | Gets or sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishVenezuela | Gets or sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Swahili | Gets or sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SwedishFinland | Gets or sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SwedishSweden | Gets or sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tamil | Gets or sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tatar | Gets or sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Thai | Gets or sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tsonga | Gets or sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Turkish | Gets or sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Ukrainian | Gets or sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Urdu | Gets or sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | UzbekCyrillic | Gets or sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | UzbekLatin | Gets or sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Vietnamese | Gets or sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Xhosa | Gets or sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Yiddish | Gets or sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Zulu | Gets or sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Top
See Also

Reference

ImGearXMPLangAlt Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPLangAlt Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ImGearXMPLangAlt Constructor
Initializes a new instance of the ImGearXMPLangAlt class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPLangAlt()
public ImGearXMPLangAlt()
public: ImGearXMPLangAlt();
public:
ImGearXMPLangAlt();

Return Value

New instance of ImGearXMPLangAlt class object.
Remarks
This constructor creates an empty instance of ImGearXMPLangAlt class. Use properties of the class to add language alternatives to the new object.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%% $$Properties$$

ImGearXMPLangAlt Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPLangAlt Class

For a list of all members of this type, see ImGearXMPLangAlt members.

Public Properties
 | Name | Description
Public Property | Afrikaans | Gets or sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Albanian | Gets or sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicAlgeria | Gets or sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicBahrain | Gets or sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicEgypt | Gets or sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicIraq | Gets or sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicJordan | Gets or sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicKuwait | Gets or sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicLebanon | Gets or sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicLibya | Gets or sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicMorocco | Gets or sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicOman | Gets or sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicQatar | Gets or sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicSaudiArabia | Gets or sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicSyria | Gets or sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicTunisia | Gets or sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicUnitedArabEmirates | Gets or sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ArabicYemen | Gets or sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Armenian | Gets or sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | AzeriCyrillic | Gets or sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | AzeriLatin | Gets or sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Basque | Gets or sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Belarusian | Gets or sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Bulgarian | Gets or sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Catalan | Gets or sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseChina | Gets or sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseHongKongSAR | Gets or sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseMacauSAR | Gets or sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseSingapore | Gets or sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ChineseTaiwan | Gets or sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Croatian | Gets or sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Czech | Gets or sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Danish | Gets or sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Default | Gets or sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | DutchBelgium | Gets or sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | DutchNetherlands | Gets or sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishAustralia | Gets or sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishBelize | Gets or sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishCanada | Gets or sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishCaribbean | Gets or sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishIreland | Gets or sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishJamaica | Gets or sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishNewZealand | Gets or sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishPhillippines | Gets or sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishSouthAfrica | Gets or sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishTrinidad | Gets or sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishUnitedKingdom | Gets or sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | EnglishUnitedStates | Gets or sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Estonian | Gets or sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Faroese | Gets or sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Farsi | Gets or sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Finnish | Gets or sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchBelgium | Gets or sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchCanada | Gets or sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchFrance | Gets or sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchLuxembourg | Gets or sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | FrenchSwitzerland | Gets or sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GaelicIreland | Gets or sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GaelicScotland | Gets or sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanAustria | Gets or sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanGermany | Gets or sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanLiechtenstein | Gets or sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanLuxembourg | Gets or sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | GermanSwitzerland | Gets or sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Greek | Gets or sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hebrew | Gets or sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hindi | Gets or sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Hungarian | Gets or sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Icelandic | Gets or sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Indonesian | Gets or sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ItalianItaly | Gets or sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | ItalianSwitzerland | Gets or sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Japanese | Gets or sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Korean | Gets or sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Latvian | Gets or sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Lithuanian | Gets or sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MacedonianFYROM | Gets or sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MalayBrunei | Gets or sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | MalayMalaysia | Gets or sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Maltese | Gets or sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Marathi | Gets or sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | NorwegianBokml | Gets or sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | NorwegianNynorsk | Gets or sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Polish | Gets or sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | PortugueseBrazil | Gets or sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | PortuguesePortugal | Gets or sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RaetoRomance | Gets or sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RomanianMoldova | Gets or sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RomanianRomania | Gets or sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Russian | Gets or sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | RussianMoldova | Gets or sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Sanskrit | Gets or sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SerbianCyrillic | Gets or sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SerbianLatin | Gets or sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Setsuana | Gets or sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Slovak | Gets or sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Slovenian | Gets or sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Sorbian | Gets or sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SouthernSotho | Gets or sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishArgentina | Gets or sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishBolivia | Gets or sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishChile | Gets or sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishColombia | Gets or sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishCosta | Gets or sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishDominican | Gets or sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishEcuador | Gets or sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishElSalvador | Gets or sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishGuatemala | Gets or sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishHonduras | Gets or sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishMexico | Gets or sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishNicaragua | Gets or sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPanama | Gets or sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishParaguay | Gets or sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPeru | Gets or sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishPuertoRico | Gets or sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishSpain | Gets or sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishUruguay | Gets or sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SpanishVenezuela | Gets or sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Swahili | Gets or sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SwedishFinland | Gets or sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | SwedishSweden | Gets or sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tamil | Gets or sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tatar | Gets or sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Thai | Gets or sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Tsonga | Gets or sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Turkish | Gets or sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Ukrainian | Gets or sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Urdu | Gets or sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | UzbekCyrillic | Gets or sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | UzbekLatin | Gets or sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Vietnamese | Gets or sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Xhosa | Gets or sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Yiddish | Gets or sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Public Property | Zulu | Gets or sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Top
See Also

Reference

ImGearXMPLangAlt Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPLangAlt Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ImGearXMPLangAlt Constructor
Overload List
Overload | Description
ImGearXMPLangAlt Constructor | Initializes a new instance of the ImGearXMPLangAlt class.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Afrikaans Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Afrikaans Property
Gets or sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Afrikaans As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Afrikaans = value

value = instance.Afrikaans
public string Afrikaans {get; set;}
public: __property string* get_Afrikaans();
public: __property void set_Afrikaans(
   string* value
);
public:
property String^ Afrikaans {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Albanian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Albanian Property
Gets or sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Albanian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Albanian = value

value = instance.Albanian
public string Albanian {get; set;}
public: __property string* get_Albanian();
public: __property void set_Albanian(
   string* value
);
public:
property String^ Albanian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicAlgeria Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicAlgeria Property
Gets or sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicAlgeria As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicAlgeria = value

value = instance.ArabicAlgeria
public string ArabicAlgeria {get; set;}
public: __property string* get_ArabicAlgeria();
public: __property void set_ArabicAlgeria(
   string* value
);
public:
property String^ ArabicAlgeria {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicBahrain Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicBahrain Property
Gets or sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicBahrain As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicBahrain = value

value = instance.ArabicBahrain
public string ArabicBahrain {get; set;}
public: __property string* get_ArabicBahrain();
public: __property void set_ArabicBahrain(
   string* value
);
public:
property String^ ArabicBahrain {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicEgypt Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicEgypt Property
Gets or sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicEgypt As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicEgypt = value

value = instance.ArabicEgypt
public string ArabicEgypt {get; set;}
public: __property string* get_ArabicEgypt();
public: __property void set_ArabicEgypt(
   string* value
);
public:
property String^ ArabicEgypt {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicIraq Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicIraq Property
Gets or sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicIraq As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicIraq = value

value = instance.ArabicIraq
public string ArabicIraq {get; set;}
public: __property string* get_ArabicIraq();
public: __property void set_ArabicIraq(
   string* value
);
public:
property String^ ArabicIraq {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicJordan Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicJordan Property
Gets or sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicJordan As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicJordan = value

value = instance.ArabicJordan
public string ArabicJordan {get; set;}
public: __property string* get_ArabicJordan();
public: __property void set_ArabicJordan(
   string* value
);
public:
property String^ ArabicJordan {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicKuwait Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicKuwait Property
Gets or sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicKuwait As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicKuwait = value

value = instance.ArabicKuwait
public string ArabicKuwait {get; set;}
public: __property string* get_ArabicKuwait();
public: __property void set_ArabicKuwait(
   string* value
);
public:
property String^ ArabicKuwait {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicLebanon Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicLebanon Property
Gets or sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicLebanon As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicLebanon = value

value = instance.ArabicLebanon
public string ArabicLebanon {get; set;}
public: __property string* get_ArabicLebanon();
public: __property void set_ArabicLebanon(
   string* value
);
public:
property String^ ArabicLebanon {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicLibya Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicLibya Property
Gets or sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicLibya As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicLibya = value

value = instance.ArabicLibya
public string ArabicLibya {get; set;}
public: __property string* get_ArabicLibya();
public: __property void set_ArabicLibya(
   string* value
);
public:
property String^ ArabicLibya {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicMorocco Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicMorocco Property
Gets or sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicMorocco As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicMorocco = value

value = instance.ArabicMorocco
public string ArabicMorocco {get; set;}
public: __property string* get_ArabicMorocco();
public: __property void set_ArabicMorocco(
   string* value
);
public:
property String^ ArabicMorocco {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicOman Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicOman Property
Gets or sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicOman As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicOman = value

value = instance.ArabicOman
public string ArabicOman {get; set;}
public: __property string* get_ArabicOman();
public: __property void set_ArabicOman(
   string* value
);
public:
property String^ ArabicOman {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicQatar Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicQatar Property
Gets or sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicQatar As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicQatar = value

value = instance.ArabicQatar
public string ArabicQatar {get; set;}
public: __property string* get_ArabicQatar();
public: __property void set_ArabicQatar(
   string* value
);
public:
property String^ ArabicQatar {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicSaudiArabia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicSaudiArabia Property
Gets or sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicSaudiArabia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicSaudiArabia = value

value = instance.ArabicSaudiArabia
public string ArabicSaudiArabia {get; set;}
public: __property string* get_ArabicSaudiArabia();
public: __property void set_ArabicSaudiArabia(
   string* value
);
public:
property String^ ArabicSaudiArabia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicSyria Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicSyria Property
Gets or sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicSyria As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicSyria = value

value = instance.ArabicSyria
public string ArabicSyria {get; set;}
public: __property string* get_ArabicSyria();
public: __property void set_ArabicSyria(
   string* value
);
public:
property String^ ArabicSyria {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicTunisia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicTunisia Property
Gets or sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicTunisia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicTunisia = value

value = instance.ArabicTunisia
public string ArabicTunisia {get; set;}
public: __property string* get_ArabicTunisia();
public: __property void set_ArabicTunisia(
   string* value
);
public:
property String^ ArabicTunisia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicUnitedArabEmirates Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicUnitedArabEmirates Property
Gets or sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicUnitedArabEmirates As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicUnitedArabEmirates = value

value = instance.ArabicUnitedArabEmirates
public string ArabicUnitedArabEmirates {get; set;}
public: __property string* get_ArabicUnitedArabEmirates();
public: __property void set_ArabicUnitedArabEmirates(
   string* value
);
public:
property String^ ArabicUnitedArabEmirates {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ArabicYemen Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ArabicYemen Property
Gets or sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArabicYemen As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ArabicYemen = value

value = instance.ArabicYemen
public string ArabicYemen {get; set;}
public: __property string* get_ArabicYemen();
public: __property void set_ArabicYemen(
   string* value
);
public:
property String^ ArabicYemen {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Armenian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Armenian Property
Gets or sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Armenian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Armenian = value

value = instance.Armenian
public string Armenian {get; set;}
public: __property string* get_Armenian();
public: __property void set_Armenian(
   string* value
);
public:
property String^ Armenian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


AzeriCyrillic Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : AzeriCyrillic Property
Gets or sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AzeriCyrillic As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.AzeriCyrillic = value

value = instance.AzeriCyrillic
public string AzeriCyrillic {get; set;}
public: __property string* get_AzeriCyrillic();
public: __property void set_AzeriCyrillic(
   string* value
);
public:
property String^ AzeriCyrillic {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


AzeriLatin Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : AzeriLatin Property
Gets or sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AzeriLatin As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.AzeriLatin = value

value = instance.AzeriLatin
public string AzeriLatin {get; set;}
public: __property string* get_AzeriLatin();
public: __property void set_AzeriLatin(
   string* value
);
public:
property String^ AzeriLatin {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Basque Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Basque Property
Gets or sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Basque As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Basque = value

value = instance.Basque
public string Basque {get; set;}
public: __property string* get_Basque();
public: __property void set_Basque(
   string* value
);
public:
property String^ Basque {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Belarusian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Belarusian Property
Gets or sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Belarusian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Belarusian = value

value = instance.Belarusian
public string Belarusian {get; set;}
public: __property string* get_Belarusian();
public: __property void set_Belarusian(
   string* value
);
public:
property String^ Belarusian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Bulgarian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Bulgarian Property
Gets or sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bulgarian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Bulgarian = value

value = instance.Bulgarian
public string Bulgarian {get; set;}
public: __property string* get_Bulgarian();
public: __property void set_Bulgarian(
   string* value
);
public:
property String^ Bulgarian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Catalan Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Catalan Property
Gets or sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Catalan As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Catalan = value

value = instance.Catalan
public string Catalan {get; set;}
public: __property string* get_Catalan();
public: __property void set_Catalan(
   string* value
);
public:
property String^ Catalan {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ChineseChina Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ChineseChina Property
Gets or sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChineseChina As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ChineseChina = value

value = instance.ChineseChina
public string ChineseChina {get; set;}
public: __property string* get_ChineseChina();
public: __property void set_ChineseChina(
   string* value
);
public:
property String^ ChineseChina {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ChineseHongKongSAR Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ChineseHongKongSAR Property
Gets or sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChineseHongKongSAR As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ChineseHongKongSAR = value

value = instance.ChineseHongKongSAR
public string ChineseHongKongSAR {get; set;}
public: __property string* get_ChineseHongKongSAR();
public: __property void set_ChineseHongKongSAR(
   string* value
);
public:
property String^ ChineseHongKongSAR {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ChineseMacauSAR Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ChineseMacauSAR Property
Gets or sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChineseMacauSAR As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ChineseMacauSAR = value

value = instance.ChineseMacauSAR
public string ChineseMacauSAR {get; set;}
public: __property string* get_ChineseMacauSAR();
public: __property void set_ChineseMacauSAR(
   string* value
);
public:
property String^ ChineseMacauSAR {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ChineseSingapore Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ChineseSingapore Property
Gets or sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChineseSingapore As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ChineseSingapore = value

value = instance.ChineseSingapore
public string ChineseSingapore {get; set;}
public: __property string* get_ChineseSingapore();
public: __property void set_ChineseSingapore(
   string* value
);
public:
property String^ ChineseSingapore {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ChineseTaiwan Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ChineseTaiwan Property
Gets or sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChineseTaiwan As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ChineseTaiwan = value

value = instance.ChineseTaiwan
public string ChineseTaiwan {get; set;}
public: __property string* get_ChineseTaiwan();
public: __property void set_ChineseTaiwan(
   string* value
);
public:
property String^ ChineseTaiwan {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Croatian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Croatian Property
Gets or sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Croatian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Croatian = value

value = instance.Croatian
public string Croatian {get; set;}
public: __property string* get_Croatian();
public: __property void set_Croatian(
   string* value
);
public:
property String^ Croatian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Czech Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Czech Property
Gets or sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Czech As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Czech = value

value = instance.Czech
public string Czech {get; set;}
public: __property string* get_Czech();
public: __property void set_Czech(
   string* value
);
public:
property String^ Czech {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Danish Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Danish Property
Gets or sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Danish As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Danish = value

value = instance.Danish
public string Danish {get; set;}
public: __property string* get_Danish();
public: __property void set_Danish(
   string* value
);
public:
property String^ Danish {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Default Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Default Property
Gets or sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Default As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Default = value

value = instance.Default
public string Default {get; set;}
public: __property string* get_Default();
public: __property void set_Default(
   string* value
);
public:
property String^ Default {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


DutchBelgium Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : DutchBelgium Property
Gets or sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DutchBelgium As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.DutchBelgium = value

value = instance.DutchBelgium
public string DutchBelgium {get; set;}
public: __property string* get_DutchBelgium();
public: __property void set_DutchBelgium(
   string* value
);
public:
property String^ DutchBelgium {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


DutchNetherlands Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : DutchNetherlands Property
Gets or sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DutchNetherlands As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.DutchNetherlands = value

value = instance.DutchNetherlands
public string DutchNetherlands {get; set;}
public: __property string* get_DutchNetherlands();
public: __property void set_DutchNetherlands(
   string* value
);
public:
property String^ DutchNetherlands {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishAustralia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishAustralia Property
Gets or sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishAustralia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishAustralia = value

value = instance.EnglishAustralia
public string EnglishAustralia {get; set;}
public: __property string* get_EnglishAustralia();
public: __property void set_EnglishAustralia(
   string* value
);
public:
property String^ EnglishAustralia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishBelize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishBelize Property
Gets or sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishBelize As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishBelize = value

value = instance.EnglishBelize
public string EnglishBelize {get; set;}
public: __property string* get_EnglishBelize();
public: __property void set_EnglishBelize(
   string* value
);
public:
property String^ EnglishBelize {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishCanada Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishCanada Property
Gets or sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishCanada As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishCanada = value

value = instance.EnglishCanada
public string EnglishCanada {get; set;}
public: __property string* get_EnglishCanada();
public: __property void set_EnglishCanada(
   string* value
);
public:
property String^ EnglishCanada {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishCaribbean Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishCaribbean Property
Gets or sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishCaribbean As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishCaribbean = value

value = instance.EnglishCaribbean
public string EnglishCaribbean {get; set;}
public: __property string* get_EnglishCaribbean();
public: __property void set_EnglishCaribbean(
   string* value
);
public:
property String^ EnglishCaribbean {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishIreland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishIreland Property
Gets or sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishIreland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishIreland = value

value = instance.EnglishIreland
public string EnglishIreland {get; set;}
public: __property string* get_EnglishIreland();
public: __property void set_EnglishIreland(
   string* value
);
public:
property String^ EnglishIreland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishJamaica Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishJamaica Property
Gets or sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishJamaica As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishJamaica = value

value = instance.EnglishJamaica
public string EnglishJamaica {get; set;}
public: __property string* get_EnglishJamaica();
public: __property void set_EnglishJamaica(
   string* value
);
public:
property String^ EnglishJamaica {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishNewZealand Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishNewZealand Property
Gets or sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishNewZealand As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishNewZealand = value

value = instance.EnglishNewZealand
public string EnglishNewZealand {get; set;}
public: __property string* get_EnglishNewZealand();
public: __property void set_EnglishNewZealand(
   string* value
);
public:
property String^ EnglishNewZealand {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishPhillippines Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishPhillippines Property
Gets or sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishPhillippines As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishPhillippines = value

value = instance.EnglishPhillippines
public string EnglishPhillippines {get; set;}
public: __property string* get_EnglishPhillippines();
public: __property void set_EnglishPhillippines(
   string* value
);
public:
property String^ EnglishPhillippines {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishSouthAfrica Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishSouthAfrica Property
Gets or sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishSouthAfrica As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishSouthAfrica = value

value = instance.EnglishSouthAfrica
public string EnglishSouthAfrica {get; set;}
public: __property string* get_EnglishSouthAfrica();
public: __property void set_EnglishSouthAfrica(
   string* value
);
public:
property String^ EnglishSouthAfrica {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishTrinidad Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishTrinidad Property
Gets or sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishTrinidad As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishTrinidad = value

value = instance.EnglishTrinidad
public string EnglishTrinidad {get; set;}
public: __property string* get_EnglishTrinidad();
public: __property void set_EnglishTrinidad(
   string* value
);
public:
property String^ EnglishTrinidad {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishUnitedKingdom Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishUnitedKingdom Property
Gets or sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishUnitedKingdom As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishUnitedKingdom = value

value = instance.EnglishUnitedKingdom
public string EnglishUnitedKingdom {get; set;}
public: __property string* get_EnglishUnitedKingdom();
public: __property void set_EnglishUnitedKingdom(
   string* value
);
public:
property String^ EnglishUnitedKingdom {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


EnglishUnitedStates Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : EnglishUnitedStates Property
Gets or sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnglishUnitedStates As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.EnglishUnitedStates = value

value = instance.EnglishUnitedStates
public string EnglishUnitedStates {get; set;}
public: __property string* get_EnglishUnitedStates();
public: __property void set_EnglishUnitedStates(
   string* value
);
public:
property String^ EnglishUnitedStates {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Estonian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Estonian Property
Gets or sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Estonian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Estonian = value

value = instance.Estonian
public string Estonian {get; set;}
public: __property string* get_Estonian();
public: __property void set_Estonian(
   string* value
);
public:
property String^ Estonian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Faroese Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Faroese Property
Gets or sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Faroese As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Faroese = value

value = instance.Faroese
public string Faroese {get; set;}
public: __property string* get_Faroese();
public: __property void set_Faroese(
   string* value
);
public:
property String^ Faroese {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Farsi Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Farsi Property
Gets or sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Farsi As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Farsi = value

value = instance.Farsi
public string Farsi {get; set;}
public: __property string* get_Farsi();
public: __property void set_Farsi(
   string* value
);
public:
property String^ Farsi {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Finnish Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Finnish Property
Gets or sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Finnish As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Finnish = value

value = instance.Finnish
public string Finnish {get; set;}
public: __property string* get_Finnish();
public: __property void set_Finnish(
   string* value
);
public:
property String^ Finnish {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


FrenchBelgium Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : FrenchBelgium Property
Gets or sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrenchBelgium As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.FrenchBelgium = value

value = instance.FrenchBelgium
public string FrenchBelgium {get; set;}
public: __property string* get_FrenchBelgium();
public: __property void set_FrenchBelgium(
   string* value
);
public:
property String^ FrenchBelgium {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


FrenchCanada Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : FrenchCanada Property
Gets or sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrenchCanada As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.FrenchCanada = value

value = instance.FrenchCanada
public string FrenchCanada {get; set;}
public: __property string* get_FrenchCanada();
public: __property void set_FrenchCanada(
   string* value
);
public:
property String^ FrenchCanada {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


FrenchFrance Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : FrenchFrance Property
Gets or sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrenchFrance As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.FrenchFrance = value

value = instance.FrenchFrance
public string FrenchFrance {get; set;}
public: __property string* get_FrenchFrance();
public: __property void set_FrenchFrance(
   string* value
);
public:
property String^ FrenchFrance {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


FrenchLuxembourg Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : FrenchLuxembourg Property
Gets or sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrenchLuxembourg As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.FrenchLuxembourg = value

value = instance.FrenchLuxembourg
public string FrenchLuxembourg {get; set;}
public: __property string* get_FrenchLuxembourg();
public: __property void set_FrenchLuxembourg(
   string* value
);
public:
property String^ FrenchLuxembourg {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


FrenchSwitzerland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : FrenchSwitzerland Property
Gets or sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrenchSwitzerland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.FrenchSwitzerland = value

value = instance.FrenchSwitzerland
public string FrenchSwitzerland {get; set;}
public: __property string* get_FrenchSwitzerland();
public: __property void set_FrenchSwitzerland(
   string* value
);
public:
property String^ FrenchSwitzerland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GaelicIreland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GaelicIreland Property
Gets or sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GaelicIreland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GaelicIreland = value

value = instance.GaelicIreland
public string GaelicIreland {get; set;}
public: __property string* get_GaelicIreland();
public: __property void set_GaelicIreland(
   string* value
);
public:
property String^ GaelicIreland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GaelicScotland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GaelicScotland Property
Gets or sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GaelicScotland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GaelicScotland = value

value = instance.GaelicScotland
public string GaelicScotland {get; set;}
public: __property string* get_GaelicScotland();
public: __property void set_GaelicScotland(
   string* value
);
public:
property String^ GaelicScotland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GermanAustria Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GermanAustria Property
Gets or sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GermanAustria As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GermanAustria = value

value = instance.GermanAustria
public string GermanAustria {get; set;}
public: __property string* get_GermanAustria();
public: __property void set_GermanAustria(
   string* value
);
public:
property String^ GermanAustria {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GermanGermany Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GermanGermany Property
Gets or sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GermanGermany As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GermanGermany = value

value = instance.GermanGermany
public string GermanGermany {get; set;}
public: __property string* get_GermanGermany();
public: __property void set_GermanGermany(
   string* value
);
public:
property String^ GermanGermany {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GermanLiechtenstein Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GermanLiechtenstein Property
Gets or sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GermanLiechtenstein As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GermanLiechtenstein = value

value = instance.GermanLiechtenstein
public string GermanLiechtenstein {get; set;}
public: __property string* get_GermanLiechtenstein();
public: __property void set_GermanLiechtenstein(
   string* value
);
public:
property String^ GermanLiechtenstein {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GermanLuxembourg Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GermanLuxembourg Property
Gets or sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GermanLuxembourg As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GermanLuxembourg = value

value = instance.GermanLuxembourg
public string GermanLuxembourg {get; set;}
public: __property string* get_GermanLuxembourg();
public: __property void set_GermanLuxembourg(
   string* value
);
public:
property String^ GermanLuxembourg {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


GermanSwitzerland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : GermanSwitzerland Property
Gets or sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GermanSwitzerland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.GermanSwitzerland = value

value = instance.GermanSwitzerland
public string GermanSwitzerland {get; set;}
public: __property string* get_GermanSwitzerland();
public: __property void set_GermanSwitzerland(
   string* value
);
public:
property String^ GermanSwitzerland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Greek Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Greek Property
Gets or sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Greek As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Greek = value

value = instance.Greek
public string Greek {get; set;}
public: __property string* get_Greek();
public: __property void set_Greek(
   string* value
);
public:
property String^ Greek {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Hebrew Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Hebrew Property
Gets or sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hebrew As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Hebrew = value

value = instance.Hebrew
public string Hebrew {get; set;}
public: __property string* get_Hebrew();
public: __property void set_Hebrew(
   string* value
);
public:
property String^ Hebrew {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Hindi Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Hindi Property
Gets or sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hindi As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Hindi = value

value = instance.Hindi
public string Hindi {get; set;}
public: __property string* get_Hindi();
public: __property void set_Hindi(
   string* value
);
public:
property String^ Hindi {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Hungarian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Hungarian Property
Gets or sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hungarian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Hungarian = value

value = instance.Hungarian
public string Hungarian {get; set;}
public: __property string* get_Hungarian();
public: __property void set_Hungarian(
   string* value
);
public:
property String^ Hungarian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Icelandic Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Icelandic Property
Gets or sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icelandic As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Icelandic = value

value = instance.Icelandic
public string Icelandic {get; set;}
public: __property string* get_Icelandic();
public: __property void set_Icelandic(
   string* value
);
public:
property String^ Icelandic {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Indonesian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Indonesian Property
Gets or sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Indonesian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Indonesian = value

value = instance.Indonesian
public string Indonesian {get; set;}
public: __property string* get_Indonesian();
public: __property void set_Indonesian(
   string* value
);
public:
property String^ Indonesian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ItalianItaly Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ItalianItaly Property
Gets or sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItalianItaly As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ItalianItaly = value

value = instance.ItalianItaly
public string ItalianItaly {get; set;}
public: __property string* get_ItalianItaly();
public: __property void set_ItalianItaly(
   string* value
);
public:
property String^ ItalianItaly {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


ItalianSwitzerland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : ItalianSwitzerland Property
Gets or sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItalianSwitzerland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.ItalianSwitzerland = value

value = instance.ItalianSwitzerland
public string ItalianSwitzerland {get; set;}
public: __property string* get_ItalianSwitzerland();
public: __property void set_ItalianSwitzerland(
   string* value
);
public:
property String^ ItalianSwitzerland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Japanese Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Japanese Property
Gets or sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Japanese As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Japanese = value

value = instance.Japanese
public string Japanese {get; set;}
public: __property string* get_Japanese();
public: __property void set_Japanese(
   string* value
);
public:
property String^ Japanese {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Korean Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Korean Property
Gets or sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Korean As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Korean = value

value = instance.Korean
public string Korean {get; set;}
public: __property string* get_Korean();
public: __property void set_Korean(
   string* value
);
public:
property String^ Korean {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Latvian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Latvian Property
Gets or sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Latvian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Latvian = value

value = instance.Latvian
public string Latvian {get; set;}
public: __property string* get_Latvian();
public: __property void set_Latvian(
   string* value
);
public:
property String^ Latvian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Lithuanian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Lithuanian Property
Gets or sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Lithuanian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Lithuanian = value

value = instance.Lithuanian
public string Lithuanian {get; set;}
public: __property string* get_Lithuanian();
public: __property void set_Lithuanian(
   string* value
);
public:
property String^ Lithuanian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


MacedonianFYROM Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : MacedonianFYROM Property
Gets or sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MacedonianFYROM As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.MacedonianFYROM = value

value = instance.MacedonianFYROM
public string MacedonianFYROM {get; set;}
public: __property string* get_MacedonianFYROM();
public: __property void set_MacedonianFYROM(
   string* value
);
public:
property String^ MacedonianFYROM {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


MalayBrunei Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : MalayBrunei Property
Gets or sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MalayBrunei As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.MalayBrunei = value

value = instance.MalayBrunei
public string MalayBrunei {get; set;}
public: __property string* get_MalayBrunei();
public: __property void set_MalayBrunei(
   string* value
);
public:
property String^ MalayBrunei {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


MalayMalaysia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : MalayMalaysia Property
Gets or sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MalayMalaysia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.MalayMalaysia = value

value = instance.MalayMalaysia
public string MalayMalaysia {get; set;}
public: __property string* get_MalayMalaysia();
public: __property void set_MalayMalaysia(
   string* value
);
public:
property String^ MalayMalaysia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Maltese Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Maltese Property
Gets or sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Maltese As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Maltese = value

value = instance.Maltese
public string Maltese {get; set;}
public: __property string* get_Maltese();
public: __property void set_Maltese(
   string* value
);
public:
property String^ Maltese {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Marathi Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Marathi Property
Gets or sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Marathi As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Marathi = value

value = instance.Marathi
public string Marathi {get; set;}
public: __property string* get_Marathi();
public: __property void set_Marathi(
   string* value
);
public:
property String^ Marathi {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


NorwegianBokml Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : NorwegianBokml Property
Gets or sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NorwegianBokml As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.NorwegianBokml = value

value = instance.NorwegianBokml
public string NorwegianBokml {get; set;}
public: __property string* get_NorwegianBokml();
public: __property void set_NorwegianBokml(
   string* value
);
public:
property String^ NorwegianBokml {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


NorwegianNynorsk Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : NorwegianNynorsk Property
Gets or sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NorwegianNynorsk As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.NorwegianNynorsk = value

value = instance.NorwegianNynorsk
public string NorwegianNynorsk {get; set;}
public: __property string* get_NorwegianNynorsk();
public: __property void set_NorwegianNynorsk(
   string* value
);
public:
property String^ NorwegianNynorsk {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Polish Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Polish Property
Gets or sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polish As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Polish = value

value = instance.Polish
public string Polish {get; set;}
public: __property string* get_Polish();
public: __property void set_Polish(
   string* value
);
public:
property String^ Polish {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


PortugueseBrazil Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : PortugueseBrazil Property
Gets or sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortugueseBrazil As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.PortugueseBrazil = value

value = instance.PortugueseBrazil
public string PortugueseBrazil {get; set;}
public: __property string* get_PortugueseBrazil();
public: __property void set_PortugueseBrazil(
   string* value
);
public:
property String^ PortugueseBrazil {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


PortuguesePortugal Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : PortuguesePortugal Property
Gets or sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortuguesePortugal As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.PortuguesePortugal = value

value = instance.PortuguesePortugal
public string PortuguesePortugal {get; set;}
public: __property string* get_PortuguesePortugal();
public: __property void set_PortuguesePortugal(
   string* value
);
public:
property String^ PortuguesePortugal {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


RaetoRomance Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : RaetoRomance Property
Gets or sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RaetoRomance As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.RaetoRomance = value

value = instance.RaetoRomance
public string RaetoRomance {get; set;}
public: __property string* get_RaetoRomance();
public: __property void set_RaetoRomance(
   string* value
);
public:
property String^ RaetoRomance {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


RomanianMoldova Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : RomanianMoldova Property
Gets or sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RomanianMoldova As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.RomanianMoldova = value

value = instance.RomanianMoldova
public string RomanianMoldova {get; set;}
public: __property string* get_RomanianMoldova();
public: __property void set_RomanianMoldova(
   string* value
);
public:
property String^ RomanianMoldova {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


RomanianRomania Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : RomanianRomania Property
Gets or sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RomanianRomania As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.RomanianRomania = value

value = instance.RomanianRomania
public string RomanianRomania {get; set;}
public: __property string* get_RomanianRomania();
public: __property void set_RomanianRomania(
   string* value
);
public:
property String^ RomanianRomania {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Russian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Russian Property
Gets or sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Russian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Russian = value

value = instance.Russian
public string Russian {get; set;}
public: __property string* get_Russian();
public: __property void set_Russian(
   string* value
);
public:
property String^ Russian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


RussianMoldova Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : RussianMoldova Property
Gets or sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RussianMoldova As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.RussianMoldova = value

value = instance.RussianMoldova
public string RussianMoldova {get; set;}
public: __property string* get_RussianMoldova();
public: __property void set_RussianMoldova(
   string* value
);
public:
property String^ RussianMoldova {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Sanskrit Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Sanskrit Property
Gets or sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sanskrit As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Sanskrit = value

value = instance.Sanskrit
public string Sanskrit {get; set;}
public: __property string* get_Sanskrit();
public: __property void set_Sanskrit(
   string* value
);
public:
property String^ Sanskrit {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SerbianCyrillic Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SerbianCyrillic Property
Gets or sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SerbianCyrillic As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SerbianCyrillic = value

value = instance.SerbianCyrillic
public string SerbianCyrillic {get; set;}
public: __property string* get_SerbianCyrillic();
public: __property void set_SerbianCyrillic(
   string* value
);
public:
property String^ SerbianCyrillic {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SerbianLatin Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SerbianLatin Property
Gets or sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SerbianLatin As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SerbianLatin = value

value = instance.SerbianLatin
public string SerbianLatin {get; set;}
public: __property string* get_SerbianLatin();
public: __property void set_SerbianLatin(
   string* value
);
public:
property String^ SerbianLatin {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Setsuana Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Setsuana Property
Gets or sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Setsuana As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Setsuana = value

value = instance.Setsuana
public string Setsuana {get; set;}
public: __property string* get_Setsuana();
public: __property void set_Setsuana(
   string* value
);
public:
property String^ Setsuana {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Slovak Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Slovak Property
Gets or sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Slovak As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Slovak = value

value = instance.Slovak
public string Slovak {get; set;}
public: __property string* get_Slovak();
public: __property void set_Slovak(
   string* value
);
public:
property String^ Slovak {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Slovenian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Slovenian Property
Gets or sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Slovenian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Slovenian = value

value = instance.Slovenian
public string Slovenian {get; set;}
public: __property string* get_Slovenian();
public: __property void set_Slovenian(
   string* value
);
public:
property String^ Slovenian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Sorbian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Sorbian Property
Gets or sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sorbian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Sorbian = value

value = instance.Sorbian
public string Sorbian {get; set;}
public: __property string* get_Sorbian();
public: __property void set_Sorbian(
   string* value
);
public:
property String^ Sorbian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SouthernSotho Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SouthernSotho Property
Gets or sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SouthernSotho As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SouthernSotho = value

value = instance.SouthernSotho
public string SouthernSotho {get; set;}
public: __property string* get_SouthernSotho();
public: __property void set_SouthernSotho(
   string* value
);
public:
property String^ SouthernSotho {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishArgentina Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishArgentina Property
Gets or sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishArgentina As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishArgentina = value

value = instance.SpanishArgentina
public string SpanishArgentina {get; set;}
public: __property string* get_SpanishArgentina();
public: __property void set_SpanishArgentina(
   string* value
);
public:
property String^ SpanishArgentina {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishBolivia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishBolivia Property
Gets or sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishBolivia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishBolivia = value

value = instance.SpanishBolivia
public string SpanishBolivia {get; set;}
public: __property string* get_SpanishBolivia();
public: __property void set_SpanishBolivia(
   string* value
);
public:
property String^ SpanishBolivia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishChile Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishChile Property
Gets or sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishChile As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishChile = value

value = instance.SpanishChile
public string SpanishChile {get; set;}
public: __property string* get_SpanishChile();
public: __property void set_SpanishChile(
   string* value
);
public:
property String^ SpanishChile {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishColombia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishColombia Property
Gets or sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishColombia As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishColombia = value

value = instance.SpanishColombia
public string SpanishColombia {get; set;}
public: __property string* get_SpanishColombia();
public: __property void set_SpanishColombia(
   string* value
);
public:
property String^ SpanishColombia {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishCosta Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishCosta Property
Gets or sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishCosta As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishCosta = value

value = instance.SpanishCosta
public string SpanishCosta {get; set;}
public: __property string* get_SpanishCosta();
public: __property void set_SpanishCosta(
   string* value
);
public:
property String^ SpanishCosta {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishDominican Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishDominican Property
Gets or sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishDominican As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishDominican = value

value = instance.SpanishDominican
public string SpanishDominican {get; set;}
public: __property string* get_SpanishDominican();
public: __property void set_SpanishDominican(
   string* value
);
public:
property String^ SpanishDominican {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishEcuador Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishEcuador Property
Gets or sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishEcuador As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishEcuador = value

value = instance.SpanishEcuador
public string SpanishEcuador {get; set;}
public: __property string* get_SpanishEcuador();
public: __property void set_SpanishEcuador(
   string* value
);
public:
property String^ SpanishEcuador {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishElSalvador Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishElSalvador Property
Gets or sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishElSalvador As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishElSalvador = value

value = instance.SpanishElSalvador
public string SpanishElSalvador {get; set;}
public: __property string* get_SpanishElSalvador();
public: __property void set_SpanishElSalvador(
   string* value
);
public:
property String^ SpanishElSalvador {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishGuatemala Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishGuatemala Property
Gets or sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishGuatemala As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishGuatemala = value

value = instance.SpanishGuatemala
public string SpanishGuatemala {get; set;}
public: __property string* get_SpanishGuatemala();
public: __property void set_SpanishGuatemala(
   string* value
);
public:
property String^ SpanishGuatemala {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishHonduras Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishHonduras Property
Gets or sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishHonduras As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishHonduras = value

value = instance.SpanishHonduras
public string SpanishHonduras {get; set;}
public: __property string* get_SpanishHonduras();
public: __property void set_SpanishHonduras(
   string* value
);
public:
property String^ SpanishHonduras {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishMexico Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishMexico Property
Gets or sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishMexico As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishMexico = value

value = instance.SpanishMexico
public string SpanishMexico {get; set;}
public: __property string* get_SpanishMexico();
public: __property void set_SpanishMexico(
   string* value
);
public:
property String^ SpanishMexico {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishNicaragua Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishNicaragua Property
Gets or sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishNicaragua As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishNicaragua = value

value = instance.SpanishNicaragua
public string SpanishNicaragua {get; set;}
public: __property string* get_SpanishNicaragua();
public: __property void set_SpanishNicaragua(
   string* value
);
public:
property String^ SpanishNicaragua {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishPanama Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishPanama Property
Gets or sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishPanama As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishPanama = value

value = instance.SpanishPanama
public string SpanishPanama {get; set;}
public: __property string* get_SpanishPanama();
public: __property void set_SpanishPanama(
   string* value
);
public:
property String^ SpanishPanama {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishParaguay Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishParaguay Property
Gets or sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishParaguay As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishParaguay = value

value = instance.SpanishParaguay
public string SpanishParaguay {get; set;}
public: __property string* get_SpanishParaguay();
public: __property void set_SpanishParaguay(
   string* value
);
public:
property String^ SpanishParaguay {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishPeru Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishPeru Property
Gets or sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishPeru As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishPeru = value

value = instance.SpanishPeru
public string SpanishPeru {get; set;}
public: __property string* get_SpanishPeru();
public: __property void set_SpanishPeru(
   string* value
);
public:
property String^ SpanishPeru {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishPuertoRico Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishPuertoRico Property
Gets or sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishPuertoRico As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishPuertoRico = value

value = instance.SpanishPuertoRico
public string SpanishPuertoRico {get; set;}
public: __property string* get_SpanishPuertoRico();
public: __property void set_SpanishPuertoRico(
   string* value
);
public:
property String^ SpanishPuertoRico {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishSpain Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishSpain Property
Gets or sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishSpain As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishSpain = value

value = instance.SpanishSpain
public string SpanishSpain {get; set;}
public: __property string* get_SpanishSpain();
public: __property void set_SpanishSpain(
   string* value
);
public:
property String^ SpanishSpain {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishUruguay Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishUruguay Property
Gets or sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishUruguay As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishUruguay = value

value = instance.SpanishUruguay
public string SpanishUruguay {get; set;}
public: __property string* get_SpanishUruguay();
public: __property void set_SpanishUruguay(
   string* value
);
public:
property String^ SpanishUruguay {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SpanishVenezuela Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SpanishVenezuela Property
Gets or sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpanishVenezuela As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SpanishVenezuela = value

value = instance.SpanishVenezuela
public string SpanishVenezuela {get; set;}
public: __property string* get_SpanishVenezuela();
public: __property void set_SpanishVenezuela(
   string* value
);
public:
property String^ SpanishVenezuela {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Swahili Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Swahili Property
Gets or sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Swahili As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Swahili = value

value = instance.Swahili
public string Swahili {get; set;}
public: __property string* get_Swahili();
public: __property void set_Swahili(
   string* value
);
public:
property String^ Swahili {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SwedishFinland Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SwedishFinland Property
Gets or sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SwedishFinland As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SwedishFinland = value

value = instance.SwedishFinland
public string SwedishFinland {get; set;}
public: __property string* get_SwedishFinland();
public: __property void set_SwedishFinland(
   string* value
);
public:
property String^ SwedishFinland {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


SwedishSweden Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : SwedishSweden Property
Gets or sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SwedishSweden As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.SwedishSweden = value

value = instance.SwedishSweden
public string SwedishSweden {get; set;}
public: __property string* get_SwedishSweden();
public: __property void set_SwedishSweden(
   string* value
);
public:
property String^ SwedishSweden {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Tamil Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Tamil Property
Gets or sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tamil As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Tamil = value

value = instance.Tamil
public string Tamil {get; set;}
public: __property string* get_Tamil();
public: __property void set_Tamil(
   string* value
);
public:
property String^ Tamil {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Tatar Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Tatar Property
Gets or sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tatar As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Tatar = value

value = instance.Tatar
public string Tatar {get; set;}
public: __property string* get_Tatar();
public: __property void set_Tatar(
   string* value
);
public:
property String^ Tatar {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Thai Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Thai Property
Gets or sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Thai As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Thai = value

value = instance.Thai
public string Thai {get; set;}
public: __property string* get_Thai();
public: __property void set_Thai(
   string* value
);
public:
property String^ Thai {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Tsonga Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Tsonga Property
Gets or sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tsonga As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Tsonga = value

value = instance.Tsonga
public string Tsonga {get; set;}
public: __property string* get_Tsonga();
public: __property void set_Tsonga(
   string* value
);
public:
property String^ Tsonga {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Turkish Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Turkish Property
Gets or sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Turkish As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Turkish = value

value = instance.Turkish
public string Turkish {get; set;}
public: __property string* get_Turkish();
public: __property void set_Turkish(
   string* value
);
public:
property String^ Turkish {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Ukrainian Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Ukrainian Property
Gets or sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ukrainian As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Ukrainian = value

value = instance.Ukrainian
public string Ukrainian {get; set;}
public: __property string* get_Ukrainian();
public: __property void set_Ukrainian(
   string* value
);
public:
property String^ Ukrainian {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Urdu Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Urdu Property
Gets or sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Urdu As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Urdu = value

value = instance.Urdu
public string Urdu {get; set;}
public: __property string* get_Urdu();
public: __property void set_Urdu(
   string* value
);
public:
property String^ Urdu {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


UzbekCyrillic Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : UzbekCyrillic Property
Gets or sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UzbekCyrillic As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.UzbekCyrillic = value

value = instance.UzbekCyrillic
public string UzbekCyrillic {get; set;}
public: __property string* get_UzbekCyrillic();
public: __property void set_UzbekCyrillic(
   string* value
);
public:
property String^ UzbekCyrillic {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


UzbekLatin Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : UzbekLatin Property
Gets or sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UzbekLatin As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.UzbekLatin = value

value = instance.UzbekLatin
public string UzbekLatin {get; set;}
public: __property string* get_UzbekLatin();
public: __property void set_UzbekLatin(
   string* value
);
public:
property String^ UzbekLatin {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Vietnamese Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Vietnamese Property
Gets or sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Vietnamese As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Vietnamese = value

value = instance.Vietnamese
public string Vietnamese {get; set;}
public: __property string* get_Vietnamese();
public: __property void set_Vietnamese(
   string* value
);
public:
property String^ Vietnamese {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Xhosa Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Xhosa Property
Gets or sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Xhosa As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Xhosa = value

value = instance.Xhosa
public string Xhosa {get; set;}
public: __property string* get_Xhosa();
public: __property void set_Xhosa(
   string* value
);
public:
property String^ Xhosa {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Yiddish Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Yiddish Property
Gets or sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Yiddish As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Yiddish = value

value = instance.Yiddish
public string Yiddish {get; set;}
public: __property string* get_Yiddish();
public: __property void set_Yiddish(
   string* value
);
public:
property String^ Yiddish {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


Zulu Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPLangAlt Class : Zulu Property
Gets or sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Zulu As String
'Usage

Dim instance As ImGearXMPLangAlt
Dim value As String

instance.Zulu = value

value = instance.Zulu
public string Zulu {get; set;}
public: __property string* get_Zulu();
public: __property void set_Zulu(
   string* value
);
public:
property String^ Zulu {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

ImGearXMPMetadataRoot Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPMetadataRoot Class
Provides simplified access to XMP metadata.
Object Model
ImGearXMPMetadataRoot ClassImGearAdobePDFXMPMetadata ClassImGearBasicXMPMetadata ClassImGearBasicJobTicketXMPMetadata ClassImGearCameraRawXMPMetadata ClassImGearDublinCoreXMPMetadata ClassImGearDynamicMediaXMPMetadata ClassImGearEXIFXMPMetadata ClassImGearEXIFAuxXMPMetadata ClassImGearIPTC4XMPCoreMetadata ClassImGearMediaManagementXMPMetadata ClassImGearPagedTextXMPMetadata ClassImGearPhotoshopXMPMetadata ClassImGearRightsManagementXMPMetadata ClassImGearTIFFXMPMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPMetadataRoot
   Inherits ImageGear.Formats.ImGearFormatMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
public class ImGearXMPMetadataRoot : ImageGear.Formats.ImGearFormatMetadata
public __gc class ImGearXMPMetadataRoot : public ImageGear.Formats.ImGearFormatMetadata
public ref class ImGearXMPMetadataRoot : public ImageGear.Formats.ImGearFormatMetadata
Remarks
Properties of this class represent XMP schemas that are known to ImageGear.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPMetadataRoot

See Also

Reference

ImGearXMPMetadataRoot Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPMetadataRoot Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPMetadataRoot Class

The following tables list the members exposed by ImGearXMPMetadataRoot.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPMetadataRoot Constructor | Initializes a new instance of the ImGearXMPMetadataRoot class.
Top
Public Properties
 | Name | Description
Public Property | AdobePDF | Gets or sets Adobe PDF XMP schema properties.
Public Property | Basic | Gets or sets Basic XMP schema properties.
Public Property | BasicJobTicket | Gets or sets Basic Job Ticket XMP schema properties.
Public Property | CameraRaw | Gets or sets Camera Raw XMP schema properties.
Public Property | DublinCore | Gets or sets Dublin Core XMP schema properties.
Public Property | DynamicMedia | Gets or sets Dynamic Media XMP schema properties.
Public Property | EXIF | Gets or sets EXIF XMP schema properties.
Public Property | EXIFAux | Gets or sets EXIF Auxiliary XMP schema properties.
Public Property | IPTC | Gets or sets IPTC4XMPCore XMP schema properties.
Public Property | MediaManagement | Gets or sets Media Management XMP schema properties.
Public Property | PagedText | Gets or sets Paged Text XMP schema properties.
Public Property | Photoshop | Gets or sets Photoshop XMP schema properties.
Public Property | RightsManagement | Gets or sets Rights Management XMP schema properties.
Public Property | TIFF | Gets or sets TIFF XMP schema properties.
Top
See Also

Reference

ImGearXMPMetadataRoot Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPMetadataRoot Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : ImGearXMPMetadataRoot Constructor
Initializes a new instance of the ImGearXMPMetadataRoot class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPMetadataRoot()
public ImGearXMPMetadataRoot()
public: ImGearXMPMetadataRoot();
public:
ImGearXMPMetadataRoot();

Return Value

New instance of theImGearXMPMetadataRoot class object.
See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%% $$Properties$$

ImGearXMPMetadataRoot Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPMetadataRoot Class

For a list of all members of this type, see ImGearXMPMetadataRoot members.

Public Properties
 | Name | Description
Public Property | AdobePDF | Gets or sets Adobe PDF XMP schema properties.
Public Property | Basic | Gets or sets Basic XMP schema properties.
Public Property | BasicJobTicket | Gets or sets Basic Job Ticket XMP schema properties.
Public Property | CameraRaw | Gets or sets Camera Raw XMP schema properties.
Public Property | DublinCore | Gets or sets Dublin Core XMP schema properties.
Public Property | DynamicMedia | Gets or sets Dynamic Media XMP schema properties.
Public Property | EXIF | Gets or sets EXIF XMP schema properties.
Public Property | EXIFAux | Gets or sets EXIF Auxiliary XMP schema properties.
Public Property | IPTC | Gets or sets IPTC4XMPCore XMP schema properties.
Public Property | MediaManagement | Gets or sets Media Management XMP schema properties.
Public Property | PagedText | Gets or sets Paged Text XMP schema properties.
Public Property | Photoshop | Gets or sets Photoshop XMP schema properties.
Public Property | RightsManagement | Gets or sets Rights Management XMP schema properties.
Public Property | TIFF | Gets or sets TIFF XMP schema properties.
Top
See Also

Reference

ImGearXMPMetadataRoot Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPMetadataRoot Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : ImGearXMPMetadataRoot Constructor
Overload List
Overload | Description
ImGearXMPMetadataRoot Constructor | Initializes a new instance of the ImGearXMPMetadataRoot class.
See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


AdobePDF Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : AdobePDF Property
Gets or sets Adobe PDF XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AdobePDF As ImGearAdobePDFXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearAdobePDFXMPMetadata

instance.AdobePDF = value

value = instance.AdobePDF
public ImGearAdobePDFXMPMetadata AdobePDF {get; set;}
public: __property ImGearAdobePDFXMPMetadata* get_AdobePDF();
public: __property void set_AdobePDF(
   ImGearAdobePDFXMPMetadata* value
);
public:
property ImGearAdobePDFXMPMetadata^ AdobePDF {
   ImGearAdobePDFXMPMetadata^ get();
   void set (    ImGearAdobePDFXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the property returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


Basic Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : Basic Property
Gets or sets Basic XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Basic As ImGearBasicXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearBasicXMPMetadata

instance.Basic = value

value = instance.Basic
public ImGearBasicXMPMetadata Basic {get; set;}
public: __property ImGearBasicXMPMetadata* get_Basic();
public: __property void set_Basic(
   ImGearBasicXMPMetadata* value
);
public:
property ImGearBasicXMPMetadata^ Basic {
   ImGearBasicXMPMetadata^ get();
   void set (    ImGearBasicXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Basic scheme, the property returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


BasicJobTicket Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : BasicJobTicket Property
Gets or sets Basic Job Ticket XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BasicJobTicket As ImGearBasicJobTicketXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearBasicJobTicketXMPMetadata

instance.BasicJobTicket = value

value = instance.BasicJobTicket
public ImGearBasicJobTicketXMPMetadata BasicJobTicket {get; set;}
public: __property ImGearBasicJobTicketXMPMetadata* get_BasicJobTicket();
public: __property void set_BasicJobTicket(
   ImGearBasicJobTicketXMPMetadata* value
);
public:
property ImGearBasicJobTicketXMPMetadata^ BasicJobTicket {
   ImGearBasicJobTicketXMPMetadata^ get();
   void set (    ImGearBasicJobTicketXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the property returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


CameraRaw Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : CameraRaw Property
Gets or sets Camera Raw XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraRaw As ImGearCameraRawXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearCameraRawXMPMetadata

instance.CameraRaw = value

value = instance.CameraRaw
public ImGearCameraRawXMPMetadata CameraRaw {get; set;}
public: __property ImGearCameraRawXMPMetadata* get_CameraRaw();
public: __property void set_CameraRaw(
   ImGearCameraRawXMPMetadata* value
);
public:
property ImGearCameraRawXMPMetadata^ CameraRaw {
   ImGearCameraRawXMPMetadata^ get();
   void set (    ImGearCameraRawXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Camera Raw scheme, the property returns null.

If the metadata does not have Camera Raw XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata class.

If you need to remove Camera Raw XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


DublinCore Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : DublinCore Property
Gets or sets Dublin Core XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DublinCore As ImGearDublinCoreXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearDublinCoreXMPMetadata

instance.DublinCore = value

value = instance.DublinCore
public ImGearDublinCoreXMPMetadata DublinCore {get; set;}
public: __property ImGearDublinCoreXMPMetadata* get_DublinCore();
public: __property void set_DublinCore(
   ImGearDublinCoreXMPMetadata* value
);
public:
property ImGearDublinCoreXMPMetadata^ DublinCore {
   ImGearDublinCoreXMPMetadata^ get();
   void set (    ImGearDublinCoreXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the property returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


DynamicMedia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : DynamicMedia Property
Gets or sets Dynamic Media XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DynamicMedia As ImGearDynamicMediaXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearDynamicMediaXMPMetadata

instance.DynamicMedia = value

value = instance.DynamicMedia
public ImGearDynamicMediaXMPMetadata DynamicMedia {get; set;}
public: __property ImGearDynamicMediaXMPMetadata* get_DynamicMedia();
public: __property void set_DynamicMedia(
   ImGearDynamicMediaXMPMetadata* value
);
public:
property ImGearDynamicMediaXMPMetadata^ DynamicMedia {
   ImGearDynamicMediaXMPMetadata^ get();
   void set (    ImGearDynamicMediaXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the property returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


EXIF Property (ImGearXMPMetadataRoot)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : EXIF Property
Gets or sets EXIF XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EXIF As ImGearEXIFXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearEXIFXMPMetadata

instance.EXIF = value

value = instance.EXIF
public ImGearEXIFXMPMetadata EXIF {get; set;}
public: __property ImGearEXIFXMPMetadata* get_EXIF();
public: __property void set_EXIF(
   ImGearEXIFXMPMetadata* value
);
public:
property ImGearEXIFXMPMetadata^ EXIF {
   ImGearEXIFXMPMetadata^ get();
   void set (    ImGearEXIFXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.EXIF.ImGearEXIFXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the EXIF scheme, the property returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


EXIFAux Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : EXIFAux Property
Gets or sets EXIF Auxiliary XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EXIFAux As ImGearEXIFAuxXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearEXIFAuxXMPMetadata

instance.EXIFAux = value

value = instance.EXIFAux
public ImGearEXIFAuxXMPMetadata EXIFAux {get; set;}
public: __property ImGearEXIFAuxXMPMetadata* get_EXIFAux();
public: __property void set_EXIFAux(
   ImGearEXIFAuxXMPMetadata* value
);
public:
property ImGearEXIFAuxXMPMetadata^ EXIFAux {
   ImGearEXIFAuxXMPMetadata^ get();
   void set (    ImGearEXIFAuxXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the property returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


IPTC Property (ImGearXMPMetadataRoot)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : IPTC Property
Gets or sets IPTC4XMPCore XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IPTC As ImGearIPTC4XMPCoreMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearIPTC4XMPCoreMetadata

instance.IPTC = value

value = instance.IPTC
public ImGearIPTC4XMPCoreMetadata IPTC {get; set;}
public: __property ImGearIPTC4XMPCoreMetadata* get_IPTC();
public: __property void set_IPTC(
   ImGearIPTC4XMPCoreMetadata* value
);
public:
property ImGearIPTC4XMPCoreMetadata^ IPTC {
   ImGearIPTC4XMPCoreMetadata^ get();
   void set (    ImGearIPTC4XMPCoreMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the property returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


MediaManagement Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : MediaManagement Property
Gets or sets Media Management XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MediaManagement As ImGearMediaManagementXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearMediaManagementXMPMetadata

instance.MediaManagement = value

value = instance.MediaManagement
public ImGearMediaManagementXMPMetadata MediaManagement {get; set;}
public: __property ImGearMediaManagementXMPMetadata* get_MediaManagement();
public: __property void set_MediaManagement(
   ImGearMediaManagementXMPMetadata* value
);
public:
property ImGearMediaManagementXMPMetadata^ MediaManagement {
   ImGearMediaManagementXMPMetadata^ get();
   void set (    ImGearMediaManagementXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Media Management scheme, the property returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


PagedText Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : PagedText Property
Gets or sets Paged Text XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PagedText As ImGearPagedTextXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearPagedTextXMPMetadata

instance.PagedText = value

value = instance.PagedText
public ImGearPagedTextXMPMetadata PagedText {get; set;}
public: __property ImGearPagedTextXMPMetadata* get_PagedText();
public: __property void set_PagedText(
   ImGearPagedTextXMPMetadata* value
);
public:
property ImGearPagedTextXMPMetadata^ PagedText {
   ImGearPagedTextXMPMetadata^ get();
   void set (    ImGearPagedTextXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Paged Text scheme, the property returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


Photoshop Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : Photoshop Property
Gets or sets Photoshop XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Photoshop As ImGearPhotoshopXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearPhotoshopXMPMetadata

instance.Photoshop = value

value = instance.Photoshop
public ImGearPhotoshopXMPMetadata Photoshop {get; set;}
public: __property ImGearPhotoshopXMPMetadata* get_Photoshop();
public: __property void set_Photoshop(
   ImGearPhotoshopXMPMetadata* value
);
public:
property ImGearPhotoshopXMPMetadata^ Photoshop {
   ImGearPhotoshopXMPMetadata^ get();
   void set (    ImGearPhotoshopXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Photoshop scheme, the property returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


RightsManagement Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : RightsManagement Property
Gets or sets Rights Management XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightsManagement As ImGearRightsManagementXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearRightsManagementXMPMetadata

instance.RightsManagement = value

value = instance.RightsManagement
public ImGearRightsManagementXMPMetadata RightsManagement {get; set;}
public: __property ImGearRightsManagementXMPMetadata* get_RightsManagement();
public: __property void set_RightsManagement(
   ImGearRightsManagementXMPMetadata* value
);
public:
property ImGearRightsManagementXMPMetadata^ RightsManagement {
   ImGearRightsManagementXMPMetadata^ get();
   void set (    ImGearRightsManagementXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the Rights Management scheme, the property returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata class.

If you need to remove Rights Management XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


TIFF Property (ImGearXMPMetadataRoot)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPMetadataRoot Class : TIFF Property
Gets or sets TIFF XMP schema properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TIFF As ImGearTIFFXMPMetadata
'Usage

Dim instance As ImGearXMPMetadataRoot
Dim value As ImGearTIFFXMPMetadata

instance.TIFF = value

value = instance.TIFF
public ImGearTIFFXMPMetadata TIFF {get; set;}
public: __property ImGearTIFFXMPMetadata* get_TIFF();
public: __property void set_TIFF(
   ImGearTIFFXMPMetadata* value
);
public:
property ImGearTIFFXMPMetadata^ TIFF {
   ImGearTIFFXMPMetadata^ get();
   void set (    ImGearTIFFXMPMetadata^ value);
}

Property Value

ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata class value.
Remarks

If metadata does not contain XMP properties belonging to the TIFF scheme, the property returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this property to null.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

ImGearXMPRational Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPRational Class
Represents a rational XMP metadata property.
Object Model
ImGearXMPRational ClassImGearRationalInt Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPRational
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPRational
public class ImGearXMPRational : ImGearXMPValue
public __gc class ImGearXMPRational : public ImGearXMPValue
public ref class ImGearXMPRational : public ImGearXMPValue
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPRational

See Also

Reference

ImGearXMPRational Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPRational Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPRational Class

The following tables list the members exposed by ImGearXMPRational.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPRational Constructor | Overloaded. Initializes a new instance of the ImGearXMPRational class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the rational value of the ImGearXMPRational class object.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPRational Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPRational Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPRational Class : ImGearXMPRational Constructor
Initializes a new instance of the ImGearXMPRational class.
Overload List
Overload | Description
ImGearXMPRational Constructor() | Initializes a new instance of the ImGearXMPRational class.
ImGearXMPRational Constructor(ImGearRationalInt) | Initializes a new instance of the ImGearXMPRational class.
See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%%

ImGearXMPRational Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPRational Class > ImGearXMPRational Constructor : ImGearXMPRational Constructor()
Initializes a new instance of the ImGearXMPRational class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPRational()
public ImGearXMPRational()
public: ImGearXMPRational();
public:
ImGearXMPRational();

Return Value

New instance of ImGearXMPRational class object.
Remarks
This constructor creates an instance of ImGearXMPRational class and initializes it with a default value.
See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members
Overload List


%%PageItemTitle%%

ImGearXMPRational Constructor(ImGearRationalInt)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPRational Class > ImGearXMPRational Constructor : ImGearXMPRational Constructor(ImGearRationalInt)
ImageGear.Core.ImGearRationalInt structure value.
Initializes a new instance of the ImGearXMPRational class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As ImGearRationalInt _
)
'Usage

Dim value As ImGearRationalInt

Dim instance As New ImGearXMPRational(value)
public ImGearXMPRational(
   ImGearRationalInt value
)
public: ImGearXMPRational(
   ImGearRationalInt value
)
public:
ImGearXMPRational(
   ImGearRationalInt value
)

Parameters

value
ImageGear.Core.ImGearRationalInt structure value.

Return Value

New instance of ImGearXMPRational class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPRational class by using a ImageGear.Core.ImGearRationalInt structure value.
See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPRational Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPRational Class

For a list of all members of this type, see ImGearXMPRational members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPRational Class
ImageGear.Formats.XMP Namespace


ToString Method (ImGearXMPRational)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPRational Class : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPRational
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%% $$Properties$$

ImGearXMPRational Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPRational Class

For a list of all members of this type, see ImGearXMPRational members.

Public Properties
 | Name | Description
Public Property | Value | Gets the rational value of the ImGearXMPRational class object.
Top
See Also

Reference

ImGearXMPRational Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPRational)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPRational Class : Value Property
Gets the rational value of the ImGearXMPRational class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As ImGearRationalInt
'Usage

Dim instance As ImGearXMPRational
Dim value As ImGearRationalInt

value = instance.Value
public ImGearRationalInt Value {get;}
public: __property ImGearRationalInt get_Value();
public:
property ImGearRationalInt Value {
   ImGearRationalInt get();
}

Property Value

ImageGear.Core.ImGearRationalInt structure value.
See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%%

ImGearXMPReal Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPReal Class
Represents a floating point XMP metadata property.
Object Model
ImGearXMPReal Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPReal
'Usage

Dim instance As ImGearXMPReal
public class ImGearXMPReal
public __gc class ImGearXMPReal
public ref class ImGearXMPReal
Remarks
This property type has an optional qualifier that provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108"

Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPReal

See Also

Reference

ImGearXMPReal Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPReal Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPReal Class

The following tables list the members exposed by ImGearXMPReal.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPReal Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BinRepQualifier | Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as: std size,endian,hexadecimal_value - std is the standard name ("IEEE754") - size is S for 32-bit and D for 64-bit - endian is L for little-endian, B for big-endian. For example: "IEEE754D,L,3A4901F387D31108".
Public Property | Value | Gets the double value of the ImGearXMPReal class object.
Top
See Also

Reference

ImGearXMPReal Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPReal Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPReal Class : ImGearXMPReal Constructor
Overload List
Overload | Description
ImGearXMPReal Constructor(Double) | Initializes a new instance of the ImGearXMPReal class.
ImGearXMPReal Constructor(Double,String) | Initializes a new instance of the ImGearXMPReal class.
See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


%%PageItemTitle%%

ImGearXMPReal Constructor(Double)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPReal Class > ImGearXMPReal Constructor : ImGearXMPReal Constructor(Double)
Double value.
Initializes a new instance of the ImGearXMPReal class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Double _
)
'Usage

Dim value As Double

Dim instance As New ImGearXMPReal(value)
public ImGearXMPReal(
   double value
)
public: ImGearXMPReal(
   double value
)
public:
ImGearXMPReal(
   double value
)

Parameters

value
Double value.

Return Value

New instance of ImGearXMPReal class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPReal class by using a double value.
See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members
Overload List


%%PageItemTitle%%

ImGearXMPReal Constructor(Double,String)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPReal Class > ImGearXMPReal Constructor : ImGearXMPReal Constructor(Double,String)
Double value.
Binary representation qualifier value.
Initializes a new instance of the ImGearXMPReal class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Double, _
   ByVal binRep As String _
)
'Usage

Dim value As Double
Dim binRep As String

Dim instance As New ImGearXMPReal(value, binRep)
public ImGearXMPReal(
   double value,
   string binRep
)
public: ImGearXMPReal(
   double value,
   string* binRep
)
public:
ImGearXMPReal(
   double value,
   String^ binRep
)

Parameters

value
Double value.
binRep
Binary representation qualifier value.

Return Value

New instance of ImGearXMPReal class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPReal class by using a double value and a binary representation qualifier.
See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearXMPReal Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPReal Class

For a list of all members of this type, see ImGearXMPReal members.

Public Properties
 | Name | Description
Public Property | BinRepQualifier | Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as: std size,endian,hexadecimal_value - std is the standard name ("IEEE754") - size is S for 32-bit and D for 64-bit - endian is L for little-endian, B for big-endian. For example: "IEEE754D,L,3A4901F387D31108".
Public Property | Value | Gets the double value of the ImGearXMPReal class object.
Top
See Also

Reference

ImGearXMPReal Class
ImageGear.Formats.XMP Namespace


BinRepQualifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPReal Class : BinRepQualifier Property
Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108".

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BinRepQualifier As String
'Usage

Dim instance As ImGearXMPReal
Dim value As String

value = instance.BinRepQualifier
public string BinRepQualifier {get;}
public: __property string* get_BinRepQualifier();
public:
property String^ BinRepQualifier {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


Value Property (ImGearXMPReal)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPReal Class : Value Property
Gets the double value of the ImGearXMPReal class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Double
'Usage

Dim instance As ImGearXMPReal
Dim value As Double

value = instance.Value
public double Value {get;}
public: __property double get_Value();
public:
property double Value {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


%%PageItemTitle%%

ImGearXMPSeq<T> Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPSeq<T> Class
ImGearXMPValue type.
Represents an ordered array of XMP properties.
Object Model
ImGearXMPSeq<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearXMPSeq(Of T As {New, ImGearXMPValue})
   Inherits ImGearXMPArray(Of T)
'Usage

Dim instance As ImGearXMPSeq(Of T)
public sealed class ImGearXMPSeq<T> : ImGearXMPArray<T>
where T: new(), ImGearXMPValue
public __gc __sealed class ImGearXMPSeq<T> : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
generic<typename T>
public ref class ImGearXMPSeq sealed : public ImGearXMPArray<T>
where T: gcnew(), ImGearXMPValue
Type Parameters
T
ImGearXMPValue type.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPArray<T>
ImageGear.Formats.XMP.ImGearXMPSeq<T>

See Also

Reference

ImGearXMPSeq<T> Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPSeq<T> Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPSeq<T> Class

The following tables list the members exposed by ImGearXMPSeq<T>.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPSeq<T> Constructor | Overloaded. Initializes a new instance of the ImGearXMPSeq<T> class.
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPSeq<T>.
Top
See Also

Reference

ImGearXMPSeq<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Properties$$

ImGearXMPSeq<T> Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPSeq<T> Class

For a list of all members of this type, see ImGearXMPSeq<T> members.

See Also

Reference

ImGearXMPSeq<T> Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPSeq<T> Class : ImGearXMPSeq<T> Constructor
Initializes a new instance of the ImGearXMPSeq<T> class.
Overload List
Overload | Description
ImGearXMPSeq<T> Constructor() | Initializes a new instance of the ImGearXMPSeq<T> class.
ImGearXMPSeq<T> Constructor(String[]) | Initializes a new instance of the ImGearXMPSeq<T> class.
See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPSeq<T> Class > ImGearXMPSeq<T> Constructor : ImGearXMPSeq<T> Constructor()
Initializes a new instance of the ImGearXMPSeq<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPSeq(Of T)()
public ImGearXMPSeq<T>()
public: ImGearXMPSeq<T>();
public:
ImGearXMPSeq<T>();

Return Value

New instance of the ImGearXMPSeq<T> generic class object.
Remarks
This constructor creates an empty instance of ImGearXMPSeq<T> generic class.
See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor(String[])

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPSeq<T> Class > ImGearXMPSeq<T> Constructor : ImGearXMPSeq<T> Constructor(String[])
String array.
Initializes a new instance of the ImGearXMPSeq<T> class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value() As String _
)
'Usage

Dim value() As String

Dim instance As New ImGearXMPSeq(Of T)(value)
public ImGearXMPSeq<T>(
   string[] value
)
public: ImGearXMPSeq<T>(
   string*[]* value
)
public:
ImGearXMPSeq<T>(
   array<String^>^ value
)

Parameters

value
String array.

Return Value

New instance of the ImGearXMPSeq<T> generic class object.
Remarks
This constructor creates an instance of ImGearXMPSeq<T> generic class generic class and initializes it with values from the string array.
See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPSeq<T> Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPSeq<T> Class

For a list of all members of this type, see ImGearXMPSeq<T> members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ImGearXMPSeq<T>.
Top
See Also

Reference

ImGearXMPSeq<T> Class
ImageGear.Formats.XMP Namespace


GetEnumerator Method (ImGearXMPSeq<T>)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPSeq<T> Class : GetEnumerator Method
Returns an enumerator that iterates through the ImGearXMPSeq<T>.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearXMPSeq(Of T)
Dim value As IEnumerator

value = instance.GetEnumerator()
public new IEnumerator GetEnumerator()
public: new IEnumerator* GetEnumerator();
public:
new IEnumerator^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPSeq<T>.
See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members


%%PageItemTitle%%

ImGearXMPString Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPString Class
Represents a string XMP metadata property.
Object Model
ImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPString
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPString
public class ImGearXMPString : ImGearXMPValue
public __gc class ImGearXMPString : public ImGearXMPValue
public ref class ImGearXMPString : public ImGearXMPValue
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPString
ImageGear.Formats.XMP.Basic.ImGearBasicXMPIdentifier

See Also

Reference

ImGearXMPString Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPString Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPString Class

The following tables list the members exposed by ImGearXMPString.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPString Constructor | Overloaded. Initializes a new instance of the ImGearXMPString class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets the string value of the ImGearXMPString class object.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPString Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPString Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPString Class : ImGearXMPString Constructor
Initializes a new instance of the ImGearXMPString class.
Overload List
Overload | Description
ImGearXMPString Constructor() | Initializes a new instance of the ImGearXMPString class.
ImGearXMPString Constructor(String) | Initializes a new instance of the ImGearXMPString class.
See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%%

ImGearXMPString Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPString Class > ImGearXMPString Constructor : ImGearXMPString Constructor()
Initializes a new instance of the ImGearXMPString class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPString()
public ImGearXMPString()
public: ImGearXMPString();
public:
ImGearXMPString();

Return Value

New instance of the ImGearXMPString class object.
Remarks
This constructor creates an instance of ImGearXMPString class and initializes it with a default value.
See Also

Reference

ImGearXMPString Class
ImGearXMPString Members
Overload List


%%PageItemTitle%%

ImGearXMPString Constructor(String)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPString Class > ImGearXMPString Constructor : ImGearXMPString Constructor(String)
String value.
Initializes a new instance of the ImGearXMPString class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New ImGearXMPString(value)
public ImGearXMPString(
   string value
)
public: ImGearXMPString(
   string* value
)
public:
ImGearXMPString(
   String^ value
)

Parameters

value
String value.

Return Value

New instance of the ImGearXMPString class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPString class by using a string value.
See Also

Reference

ImGearXMPString Class
ImGearXMPString Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearXMPString Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPString Class

For a list of all members of this type, see ImGearXMPString members.

Public Methods
 | Name | Description
Public Method | ToString | Converts value to string.
Top
See Also

Reference

ImGearXMPString Class
ImageGear.Formats.XMP Namespace


ToString Method (ImGearXMPString)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPString Class : ToString Method
Converts value to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearXMPString
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%% $$Properties$$

ImGearXMPString Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPString Class

For a list of all members of this type, see ImGearXMPString members.

Public Properties
 | Name | Description
Public Property | Value | Gets the string value of the ImGearXMPString class object.
Top
See Also

Reference

ImGearXMPString Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPString)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPString Class : Value Property
Gets the string value of the ImGearXMPString class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As ImGearXMPString
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%%

ImGearXMPStructure Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPStructure Class
Specifies baseline features for XMP structures.
Object Model
ImGearXMPStructure Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearXMPStructure
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPStructure
public abstract class ImGearXMPStructure : ImGearXMPValue
public __gc abstract class ImGearXMPStructure : public ImGearXMPValue
public ref class ImGearXMPStructure abstract : public ImGearXMPValue
Remarks
This abstract class specifies baseline features for XMP structures, such as ImGearXMPFont class, ImGearXMPColorant class, etc.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.BasicJobTicket.ImGearXMPJob
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPBeatSpliceStretch
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMarker
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMedia
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPProjectLink
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTime
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimecode
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimeScaleStretch
ImageGear.Formats.XMP.EXIF.ImGearXMPCFAPattern
ImageGear.Formats.XMP.EXIF.ImGearXMPDeviceSettings
ImageGear.Formats.XMP.EXIF.ImGearXMPFlash
ImageGear.Formats.XMP.EXIF.ImGearXMPOECFSFR
ImageGear.Formats.XMP.ImGearXMPColorant
ImageGear.Formats.XMP.ImGearXMPDimensions
ImageGear.Formats.XMP.ImGearXMPFont
ImageGear.Formats.XMP.IPTC.ImGearXMPContactInfo
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceEvent
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceReference
ImageGear.Formats.XMP.MediaManagement.ImGearXMPVersion

See Also

Reference

ImGearXMPStructure Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPStructure Class Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPStructure Class

The following tables list the members exposed by ImGearXMPStructure.

See Also

Reference

ImGearXMPStructure Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPThumbnail Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPThumbnail Class
Represents an XMP Thumbnail structure.
Object Model
ImGearXMPThumbnail ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPThumbnail
   Inherits ImGearXMPValue
'Usage

Dim instance As ImGearXMPThumbnail
public class ImGearXMPThumbnail : ImGearXMPValue
public __gc class ImGearXMPThumbnail : public ImGearXMPValue
public ref class ImGearXMPThumbnail : public ImGearXMPValue
Remarks

This class is not implemented yet.

Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPThumbnail

See Also

Reference

ImGearXMPThumbnail Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPThumbnail Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPThumbnail Class

The following tables list the members exposed by ImGearXMPThumbnail.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPThumbnail Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets thumbnail image as an ImageGear.Core.ImGearPage class object. This property is not implemented yet. Get accessor always returns null.
Top
See Also

Reference

ImGearXMPThumbnail Class
ImageGear.Formats.XMP Namespace


%%PageItemTitle%%

ImGearXMPThumbnail Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPThumbnail Class : ImGearXMPThumbnail Constructor
Overload List
Overload | Description
ImGearXMPThumbnail Constructor() | Initializes a new instance of the ImGearXMPThumbnail class.
ImGearXMPThumbnail Constructor(ImGearPage) | Initializes a new instance of the ImGearXMPThumbnail class.
See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members


%%PageItemTitle%%

ImGearXMPThumbnail Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPThumbnail Class > ImGearXMPThumbnail Constructor : ImGearXMPThumbnail Constructor()
Initializes a new instance of the ImGearXMPThumbnail class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPThumbnail()
public ImGearXMPThumbnail()
public: ImGearXMPThumbnail();
public:
ImGearXMPThumbnail();

Return Value

New instance of the ImGearXMPThumbnail class object.
Remarks
This constructor creates an empty instance of ImGearXMPThumbnail class.
See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members
Overload List


%%PageItemTitle%%

ImGearXMPThumbnail Constructor(ImGearPage)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPThumbnail Class > ImGearXMPThumbnail Constructor : ImGearXMPThumbnail Constructor(ImGearPage)
ImGearPage object.
Initializes a new instance of the ImGearXMPThumbnail class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

Dim instance As New ImGearXMPThumbnail(page)
public ImGearXMPThumbnail(
   ImGearPage page
)
public: ImGearXMPThumbnail(
   ImGearPage* page
)
public:
ImGearXMPThumbnail(
   ImGearPage^ page
)

Parameters

page
ImGearPage object.

Return Value

New instance of the ImGearXMPThumbnail class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPThumbnail class by using an ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearXMPThumbnail Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPThumbnail Class

For a list of all members of this type, see ImGearXMPThumbnail members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets thumbnail image as an ImageGear.Core.ImGearPage class object. This property is not implemented yet. Get accessor always returns null.
Top
See Also

Reference

ImGearXMPThumbnail Class
ImageGear.Formats.XMP Namespace


Value Property (ImGearXMPThumbnail)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace > ImGearXMPThumbnail Class : Value Property
Gets or sets thumbnail image as an ImageGear.Core.ImGearPage class object.

This property is not implemented yet. Get accessor always returns null.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As ImGearPage
'Usage

Dim instance As ImGearXMPThumbnail
Dim value As ImGearPage

instance.Value = value

value = instance.Value
public ImGearPage Value {get; set;}
public: __property ImGearPage* get_Value();
public: __property void set_Value(
   ImGearPage* value
);
public:
property ImGearPage^ Value {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members


%%PageItemTitle%%

ImGearXMPValue Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPValue Class
Specifies baseline features for an XMP property value.
Object Model
ImGearXMPValue Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearXMPValue
'Usage

Dim instance As ImGearXMPValue
public abstract class ImGearXMPValue
public __gc abstract class ImGearXMPValue
public ref class ImGearXMPValue abstract
Remarks
This abstract class specifies baseline features for an XMP property value.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.EXIF.ImGearXMPGPSCoordinate
ImageGear.Formats.XMP.ImGearXMPBoolean
ImageGear.Formats.XMP.ImGearXMPDate
ImageGear.Formats.XMP.ImGearXMPEnum<T>
ImageGear.Formats.XMP.ImGearXMPInteger
ImageGear.Formats.XMP.ImGearXMPRational
ImageGear.Formats.XMP.ImGearXMPString
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.ImGearXMPThumbnail

See Also

Reference

ImGearXMPValue Members
ImageGear.Formats.XMP Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPValue Class Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP Namespace : ImGearXMPValue Class

The following tables list the members exposed by ImGearXMPValue.

See Also

Reference

ImGearXMPValue Class
ImageGear.Formats.XMP Namespace


ImageGear.Formats.XMP.AdobePDF Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.AdobePDF Namespace
This namespace provides the API for XMP.AdobePDF format.
Classes
 | Class | Description
Class | ImGearAdobePDFXMPMetadata | Provides simplified access to Adobe PDF XMP metadata scheme.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.AdobePDF Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.AdobePDF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearAdobePDFXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace : ImGearAdobePDFXMPMetadata Class
Provides simplified access to Adobe PDF XMP metadata scheme.
Object Model
ImGearAdobePDFXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAdobePDFXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearAdobePDFXMPMetadata
public class ImGearAdobePDFXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearAdobePDFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearAdobePDFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.AdobePDF.ImGearAdobePDFXMPMetadata

See Also

Reference

ImGearAdobePDFXMPMetadata Members
ImageGear.Formats.XMP.AdobePDF Namespace


%%PageItemTitle%% $$Members$$

ImGearAdobePDFXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace : ImGearAdobePDFXMPMetadata Class

The following tables list the members exposed by ImGearAdobePDFXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearAdobePDFXMPMetadata Constructor | Initializes a new instance of the ImGearAdobePDFXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Keywords | Gets or sets Keywords property of the AdobePDF XMP schema.
Public Property | PDFVersion | Gets or sets PDFVersion property of the AdobePDF XMP schema. This XMP property specifies the PDF file version (for example: 1.0, 1.3, and so on).
Public Property | Producer | Gets or sets Producer property of the AdobePDF XMP schema. This XMP property specifies the name of the tool that created the PDF document.
Top
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImageGear.Formats.XMP.AdobePDF Namespace


%%PageItemTitle%%

ImGearAdobePDFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace > ImGearAdobePDFXMPMetadata Class : ImGearAdobePDFXMPMetadata Constructor
Initializes a new instance of the ImGearAdobePDFXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearAdobePDFXMPMetadata()
public ImGearAdobePDFXMPMetadata()
public: ImGearAdobePDFXMPMetadata();
public:
ImGearAdobePDFXMPMetadata();

Return Value

New instance of the ImGearAdobePDFXMPMetadata class object.
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearAdobePDFXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace : ImGearAdobePDFXMPMetadata Class

For a list of all members of this type, see ImGearAdobePDFXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Keywords | Gets or sets Keywords property of the AdobePDF XMP schema.
Public Property | PDFVersion | Gets or sets PDFVersion property of the AdobePDF XMP schema. This XMP property specifies the PDF file version (for example: 1.0, 1.3, and so on).
Public Property | Producer | Gets or sets Producer property of the AdobePDF XMP schema. This XMP property specifies the name of the tool that created the PDF document.
Top
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImageGear.Formats.XMP.AdobePDF Namespace


%%PageItemTitle%%

ImGearAdobePDFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace > ImGearAdobePDFXMPMetadata Class : ImGearAdobePDFXMPMetadata Constructor
Overload List
Overload | Description
ImGearAdobePDFXMPMetadata Constructor | Initializes a new instance of the ImGearAdobePDFXMPMetadata class.
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


Keywords Property (ImGearAdobePDFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace > ImGearAdobePDFXMPMetadata Class : Keywords Property
Gets or sets Keywords property of the AdobePDF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Keywords As ImGearXMPString
'Usage

Dim instance As ImGearAdobePDFXMPMetadata
Dim value As ImGearXMPString

instance.Keywords = value

value = instance.Keywords
public ImGearXMPString Keywords {get; set;}
public: __property ImGearXMPString* get_Keywords();
public: __property void set_Keywords(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Keywords {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


PDFVersion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace > ImGearAdobePDFXMPMetadata Class : PDFVersion Property
Gets or sets PDFVersion property of the AdobePDF XMP schema. This XMP property specifies the PDF file version (for example: 1.0, 1.3, and so on).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PDFVersion As ImGearXMPString
'Usage

Dim instance As ImGearAdobePDFXMPMetadata
Dim value As ImGearXMPString

instance.PDFVersion = value

value = instance.PDFVersion
public ImGearXMPString PDFVersion {get; set;}
public: __property ImGearXMPString* get_PDFVersion();
public: __property void set_PDFVersion(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ PDFVersion {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


Producer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.AdobePDF Namespace > ImGearAdobePDFXMPMetadata Class : Producer Property
Gets or sets Producer property of the AdobePDF XMP schema. This XMP property specifies the name of the tool that created the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Producer As ImGearXMPString
'Usage

Dim instance As ImGearAdobePDFXMPMetadata
Dim value As ImGearXMPString

instance.Producer = value

value = instance.Producer
public ImGearXMPString Producer {get; set;}
public: __property ImGearXMPString* get_Producer();
public: __property void set_Producer(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Producer {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


ImageGear.Formats.XMP.Basic Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.Basic Namespace
This namespace provides the API for XMP.Basic format.
Classes
 | Class | Description
Class | ImGearBasicXMPIdentifier | Represents an Identifier property of the XMP Basic schema.
Class | ImGearBasicXMPMetadata | Provides simplified access to XMP Basic metadata scheme.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.Basic Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.Basic Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPString
ImageGear.Formats.XMP.Basic.ImGearBasicXMPIdentifier
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearBasicXMPIdentifier Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPIdentifier Class
Represents an Identifier property of the XMP Basic schema.
Object Model
ImGearBasicXMPIdentifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBasicXMPIdentifier
   Inherits ImageGear.Formats.XMP.ImGearXMPString
'Usage

Dim instance As ImGearBasicXMPIdentifier
public class ImGearBasicXMPIdentifier : ImageGear.Formats.XMP.ImGearXMPString
public __gc class ImGearBasicXMPIdentifier : public ImageGear.Formats.XMP.ImGearXMPString
public ref class ImGearBasicXMPIdentifier : public ImageGear.Formats.XMP.ImGearXMPString
Remarks
This class contains a string qualified by an optional Schema qualifier.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPString
ImageGear.Formats.XMP.Basic.ImGearBasicXMPIdentifier

See Also

Reference

ImGearBasicXMPIdentifier Members
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%% $$Members$$

ImGearBasicXMPIdentifier Class Members
Properties Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPIdentifier Class

The following tables list the members exposed by ImGearBasicXMPIdentifier.

Public Constructors
 | Name | Description
Public Constructor | ImGearBasicXMPIdentifier Constructor | Overloaded. Initializes a new instance of the ImGearBasicXMPIdentifier class.
Top
Public Properties
 | Name | Description
Public Property | SchemeQualifier | Gets or sets the Scheme qualifier.
Top
See Also

Reference

ImGearBasicXMPIdentifier Class
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPIdentifier Class : ImGearBasicXMPIdentifier Constructor
Initializes a new instance of the ImGearBasicXMPIdentifier class.
Overload List
Overload | Description
ImGearBasicXMPIdentifier Constructor(String,String) | Initializes a new instance of the ImGearBasicXMPIdentifier class.
ImGearBasicXMPIdentifier Constructor() | Initializes a new instance of the ImGearBasicXMPIdentifier class.
ImGearBasicXMPIdentifier Constructor(String) | Initializes a new instance of the ImGearBasicXMPIdentifier class.
See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor(String,String)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor(String,String)
String value.
Scheme qualifier.
Initializes a new instance of the ImGearBasicXMPIdentifier class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String, _
   ByVal schemeQualifier As String _
)
'Usage

Dim value As String
Dim schemeQualifier As String

Dim instance As New ImGearBasicXMPIdentifier(value, schemeQualifier)
public ImGearBasicXMPIdentifier(
   string value,
   string schemeQualifier
)
public: ImGearBasicXMPIdentifier(
   string* value,
   string* schemeQualifier
)
public:
ImGearBasicXMPIdentifier(
   String^ value,
   String^ schemeQualifier
)

Parameters

value
String value.
schemeQualifier
Scheme qualifier.

Return Value

New instance of ImGearBasicXMPIdentifier class object.
Remarks
This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class, using the specified value and a scheme qualifier.
See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor()
Initializes a new instance of the ImGearBasicXMPIdentifier class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBasicXMPIdentifier()
public ImGearBasicXMPIdentifier()
public: ImGearBasicXMPIdentifier();
public:
ImGearBasicXMPIdentifier();

Return Value

New instance of ImGearBasicXMPIdentifier class object.
Remarks
This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class.
See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor(String)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor(String)
String value.
Initializes a new instance of the ImGearBasicXMPIdentifier class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New ImGearBasicXMPIdentifier(value)
public ImGearBasicXMPIdentifier(
   string value
)
public: ImGearBasicXMPIdentifier(
   string* value
)
public:
ImGearBasicXMPIdentifier(
   String^ value
)

Parameters

value
String value.

Return Value

New instance of ImGearBasicXMPIdentifier class object.
Remarks
This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class, using a string value.
See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearBasicXMPIdentifier Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPIdentifier Class

For a list of all members of this type, see ImGearBasicXMPIdentifier members.

Public Properties
 | Name | Description
Public Property | SchemeQualifier | Gets or sets the Scheme qualifier.
Top
See Also

Reference

ImGearBasicXMPIdentifier Class
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%% $$Methods$$

ImGearBasicXMPIdentifier Class Methods

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPIdentifier Class

For a list of all members of this type, see ImGearBasicXMPIdentifier members.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImageGear.Formats.XMP.Basic Namespace


SchemeQualifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPIdentifier Class : SchemeQualifier Property
Gets or sets the Scheme qualifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SchemeQualifier As String
'Usage

Dim instance As ImGearBasicXMPIdentifier
Dim value As String

instance.SchemeQualifier = value

value = instance.SchemeQualifier
public string SchemeQualifier {get; set;}
public: __property string* get_SchemeQualifier();
public: __property void set_SchemeQualifier(
   string* value
);
public:
property String^ SchemeQualifier {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

ImGearBasicXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPMetadata Class
Provides simplified access to XMP Basic metadata scheme.
Object Model
ImGearBasicXMPMetadata ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBasicXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearBasicXMPMetadata
public class ImGearBasicXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearBasicXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearBasicXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.Basic.ImGearBasicXMPMetadata

See Also

Reference

ImGearBasicXMPMetadata Members
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%% $$Members$$

ImGearBasicXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPMetadata Class

The following tables list the members exposed by ImGearBasicXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearBasicXMPMetadata Constructor | Initializes a new instance of the ImGearBasicXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Advisory | Gets or sets Advisory property of the XMP Basic schema.
Public Property | BaseURL | Gets or sets BaseURL property of the XMP Basic schema.
Public Property | CreateDate | Gets or sets CreateDate property of the XMP Basic schema.
Public Property | CreatorTool | Gets or sets CreatorTool property of the XMP Basic schema.
Public Property | Identifier | Gets or sets Identifier property of the XMP Basic schema.
Public Property | Label | Gets or sets Label property of the XMP Basic schema.
Public Property | MetadataDate | Gets or sets MetadataDate property of the XMP Basic schema.
Public Property | ModifyDate | Gets or sets ModifyDate property of the XMP Basic schema.
Public Property | Nickname | Gets or sets Nickname property of the XMP Basic schema.
Public Property | Rating | Gets or sets Rating property of the XMP Basic schema.
Public Property | Thumbnails | Gets or sets Thumbnails property of the XMP Basic schema.
Top
See Also

Reference

ImGearBasicXMPMetadata Class
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%%

ImGearBasicXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : ImGearBasicXMPMetadata Constructor
Initializes a new instance of the ImGearBasicXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBasicXMPMetadata()
public ImGearBasicXMPMetadata()
public: ImGearBasicXMPMetadata();
public:
ImGearBasicXMPMetadata();

Return Value

New instance of the ImGearBasicXMPMetadata class object.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearBasicXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace : ImGearBasicXMPMetadata Class

For a list of all members of this type, see ImGearBasicXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Advisory | Gets or sets Advisory property of the XMP Basic schema.
Public Property | BaseURL | Gets or sets BaseURL property of the XMP Basic schema.
Public Property | CreateDate | Gets or sets CreateDate property of the XMP Basic schema.
Public Property | CreatorTool | Gets or sets CreatorTool property of the XMP Basic schema.
Public Property | Identifier | Gets or sets Identifier property of the XMP Basic schema.
Public Property | Label | Gets or sets Label property of the XMP Basic schema.
Public Property | MetadataDate | Gets or sets MetadataDate property of the XMP Basic schema.
Public Property | ModifyDate | Gets or sets ModifyDate property of the XMP Basic schema.
Public Property | Nickname | Gets or sets Nickname property of the XMP Basic schema.
Public Property | Rating | Gets or sets Rating property of the XMP Basic schema.
Public Property | Thumbnails | Gets or sets Thumbnails property of the XMP Basic schema.
Top
See Also

Reference

ImGearBasicXMPMetadata Class
ImageGear.Formats.XMP.Basic Namespace


%%PageItemTitle%%

ImGearBasicXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : ImGearBasicXMPMetadata Constructor
Overload List
Overload | Description
ImGearBasicXMPMetadata Constructor | Initializes a new instance of the ImGearBasicXMPMetadata class.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Advisory Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Advisory Property
Gets or sets Advisory property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Advisory As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Advisory = value

value = instance.Advisory
public ImGearXMPBag<ImGearXMPString> Advisory {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Advisory();
public: __property void set_Advisory(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Advisory {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property contains an unordered array specifying properties that were edited outside the authoring application.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


BaseURL Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : BaseURL Property
Gets or sets BaseURL property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BaseURL As ImGearXMPString
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPString

instance.BaseURL = value

value = instance.BaseURL
public ImGearXMPString BaseURL {get; set;}
public: __property ImGearXMPString* get_BaseURL();
public: __property void set_BaseURL(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ BaseURL {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the base URL for relative URLs in the document content.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


CreateDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : CreateDate Property
Gets or sets CreateDate property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreateDate As ImGearXMPDate
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPDate

instance.CreateDate = value

value = instance.CreateDate
public ImGearXMPDate CreateDate {get; set;}
public: __property ImGearXMPDate* get_CreateDate();
public: __property void set_CreateDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ CreateDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies the date and time the resource was originally created.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


CreatorTool Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : CreatorTool Property
Gets or sets CreatorTool property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorTool As ImGearXMPString
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPString

instance.CreatorTool = value

value = instance.CreatorTool
public ImGearXMPString CreatorTool {get; set;}
public: __property ImGearXMPString* get_CreatorTool();
public: __property void set_CreatorTool(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CreatorTool {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the first known tool used to create the resource.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Identifier Property (ImGearBasicXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Identifier Property
Gets or sets Identifier property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Identifier As ImGearXMPBag(Of ImGearBasicXMPIdentifier)
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPBag(Of ImGearBasicXMPIdentifier)

instance.Identifier = value

value = instance.Identifier
public ImGearXMPBag<ImGearBasicXMPIdentifier> Identifier {get; set;}
public: __property ImGearXMPBag<ImGearBasicXMPIdentifier*>* get_Identifier();
public: __property void set_Identifier(
   ImGearXMPBag<ImGearBasicXMPIdentifier*>* value
);
public:
property ImGearXMPBag<ImGearBasicXMPIdentifier^>^ Identifier {
   ImGearXMPBag<ImGearBasicXMPIdentifier^>^ get();
   void set (    ImGearXMPBag<ImGearBasicXMPIdentifier^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImGearBasicXMPIdentifier type parameter.
Remarks
This XMP property specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Label Property (ImGearBasicXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Label Property
Gets or sets Label property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Label As ImGearXMPString
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPString

instance.Label = value

value = instance.Label
public ImGearXMPString Label {get; set;}
public: __property ImGearXMPString* get_Label();
public: __property void set_Label(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Label {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies a word or short phrase that identifies a document as a member of a user-defined collection.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


MetadataDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : MetadataDate Property
Gets or sets MetadataDate property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MetadataDate As ImGearXMPDate
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPDate

instance.MetadataDate = value

value = instance.MetadataDate
public ImGearXMPDate MetadataDate {get; set;}
public: __property ImGearXMPDate* get_MetadataDate();
public: __property void set_MetadataDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ MetadataDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


ModifyDate Property (ImGearBasicXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : ModifyDate Property
Gets or sets ModifyDate property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifyDate As ImGearXMPDate
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPDate

instance.ModifyDate = value

value = instance.ModifyDate
public ImGearXMPDate ModifyDate {get; set;}
public: __property ImGearXMPDate* get_ModifyDate();
public: __property void set_ModifyDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ ModifyDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies the date and time the resource was last modified.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Nickname Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Nickname Property
Gets or sets Nickname property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Nickname As ImGearXMPString
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPString

instance.Nickname = value

value = instance.Nickname
public ImGearXMPString Nickname {get; set;}
public: __property ImGearXMPString* get_Nickname();
public: __property void set_Nickname(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Nickname {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies a short informal name for the resource.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Rating Property (ImGearBasicXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Rating Property
Gets or sets Rating property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rating As ImGearXMPInteger
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPInteger

instance.Rating = value

value = instance.Rating
public ImGearXMPInteger Rating {get; set;}
public: __property ImGearXMPInteger* get_Rating();
public: __property void set_Rating(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Rating {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.
See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


Thumbnails Property (ImGearBasicXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Basic Namespace > ImGearBasicXMPMetadata Class : Thumbnails Property
Gets or sets Thumbnails property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Thumbnails As ImGearXMPAlt(Of ImGearXMPThumbnail)
'Usage

Dim instance As ImGearBasicXMPMetadata
Dim value As ImGearXMPAlt(Of ImGearXMPThumbnail)

instance.Thumbnails = value

value = instance.Thumbnails
public ImGearXMPAlt<ImGearXMPThumbnail> Thumbnails {get; set;}
public: __property ImGearXMPAlt<ImGearXMPThumbnail*>* get_Thumbnails();
public: __property void set_Thumbnails(
   ImGearXMPAlt<ImGearXMPThumbnail*>* value
);
public:
property ImGearXMPAlt<ImGearXMPThumbnail^>^ Thumbnails {
   ImGearXMPAlt<ImGearXMPThumbnail^>^ get();
   void set (    ImGearXMPAlt<ImGearXMPThumbnail^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPAlt<T> generic class value with ImageGear.Formats.XMP.ImGearXMPThumbnail type parameter.
Remarks
This XMP property specifies an alternative array of thumbnail images for a file, which can differ in characteristics such as size or image encoding.

This property is not implemented yet. Get accessor always returns null.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


ImageGear.Formats.XMP.BasicJobTicket Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.BasicJobTicket Namespace
This namespace provides the API for XMP.BasicJobTicket format.
Classes
 | Class | Description
Class | ImGearBasicJobTicketXMPMetadata | Provides simplified access to XMP Basic Job Ticket metadata scheme.
Class | ImGearXMPJob | Represents an XMP Job structure.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.BasicJobTicket Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.BasicJobTicket Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.BasicJobTicket.ImGearXMPJob
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearBasicJobTicketXMPMetadata Class
Provides simplified access to XMP Basic Job Ticket metadata scheme.
Object Model
ImGearBasicJobTicketXMPMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBasicJobTicketXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearBasicJobTicketXMPMetadata
public class ImGearBasicJobTicketXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearBasicJobTicketXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearBasicJobTicketXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.BasicJobTicket.ImGearBasicJobTicketXMPMetadata

See Also

Reference

ImGearBasicJobTicketXMPMetadata Members
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%% $$Members$$

ImGearBasicJobTicketXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearBasicJobTicketXMPMetadata Class

The following tables list the members exposed by ImGearBasicJobTicketXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearBasicJobTicketXMPMetadata Constructor | Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | JobRef | Gets or sets JobRef property of the XMP Basic schema.
Top
See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearBasicJobTicketXMPMetadata Class : ImGearBasicJobTicketXMPMetadata Constructor
Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBasicJobTicketXMPMetadata()
public ImGearBasicJobTicketXMPMetadata()
public: ImGearBasicJobTicketXMPMetadata();
public:
ImGearBasicJobTicketXMPMetadata();

Return Value

New instance of the ImGearBasicJobTicketXMPMetadata class object.
See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearBasicJobTicketXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearBasicJobTicketXMPMetadata Class

For a list of all members of this type, see ImGearBasicJobTicketXMPMetadata members.

Public Properties
 | Name | Description
Public Property | JobRef | Gets or sets JobRef property of the XMP Basic schema.
Top
See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearBasicJobTicketXMPMetadata Class : ImGearBasicJobTicketXMPMetadata Constructor
Overload List
Overload | Description
ImGearBasicJobTicketXMPMetadata Constructor | Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.
See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


JobRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearBasicJobTicketXMPMetadata Class : JobRef Property
Gets or sets JobRef property of the XMP Basic schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JobRef As ImGearXMPBag(Of ImGearXMPJob)
'Usage

Dim instance As ImGearBasicJobTicketXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPJob)

instance.JobRef = value

value = instance.JobRef
public ImGearXMPBag<ImGearXMPJob> JobRef {get; set;}
public: __property ImGearXMPBag<ImGearXMPJob*>* get_JobRef();
public: __property void set_JobRef(
   ImGearXMPBag<ImGearXMPJob*>* value
);
public:
property ImGearXMPBag<ImGearXMPJob^>^ JobRef {
   ImGearXMPBag<ImGearXMPJob^>^ get();
   void set (    ImGearXMPBag<ImGearXMPJob^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImGearXMPJob type parameter.
Remarks
This XMP property references an external job management file for a job process in which the document is being used.
See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


%%PageItemTitle%%

ImGearXMPJob Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearXMPJob Class
Represents an XMP Job structure.
Object Model
ImGearXMPJob ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPJob
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPJob
public class ImGearXMPJob : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPJob : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPJob : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This structure describes a job for a job-management system. See XMP specification for structure usage details.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.BasicJobTicket.ImGearXMPJob

See Also

Reference

ImGearXMPJob Members
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPJob Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearXMPJob Class

The following tables list the members exposed by ImGearXMPJob.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPJob Constructor | Initializes a new instance of the ImGearXMPJob class.
Top
Public Properties
 | Name | Description
Public Property | Id | Gets or sets unique ID for the job. This field is a reference into some external job management system.
Public Property | Name | Gets or sets informal name of the job. This name is for user display and informal systems.
Public Property | URL | Gets or sets a file URL referencing an external job management file.
Top
See Also

Reference

ImGearXMPJob Class
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%%

ImGearXMPJob Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearXMPJob Class : ImGearXMPJob Constructor
Initializes a new instance of the ImGearXMPJob class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPJob()
public ImGearXMPJob()
public: ImGearXMPJob();
public:
ImGearXMPJob();

Return Value

New instance of the ImGearXMPJob class object.
See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%% $$Properties$$

ImGearXMPJob Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace : ImGearXMPJob Class

For a list of all members of this type, see ImGearXMPJob members.

Public Properties
 | Name | Description
Public Property | Id | Gets or sets unique ID for the job. This field is a reference into some external job management system.
Public Property | Name | Gets or sets informal name of the job. This name is for user display and informal systems.
Public Property | URL | Gets or sets a file URL referencing an external job management file.
Top
See Also

Reference

ImGearXMPJob Class
ImageGear.Formats.XMP.BasicJobTicket Namespace


%%PageItemTitle%%

ImGearXMPJob Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearXMPJob Class : ImGearXMPJob Constructor
Overload List
Overload | Description
ImGearXMPJob Constructor | Initializes a new instance of the ImGearXMPJob class.
See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


Id Property (ImGearXMPJob)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearXMPJob Class : Id Property
Gets or sets unique ID for the job. This field is a reference into some external job management system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Id As ImGearXMPString
'Usage

Dim instance As ImGearXMPJob
Dim value As ImGearXMPString

instance.Id = value

value = instance.Id
public ImGearXMPString Id {get; set;}
public: __property ImGearXMPString* get_Id();
public: __property void set_Id(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Id {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


Name Property (ImGearXMPJob)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearXMPJob Class : Name Property
Gets or sets informal name of the job. This name is for user display and informal systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As ImGearXMPString
'Usage

Dim instance As ImGearXMPJob
Dim value As ImGearXMPString

instance.Name = value

value = instance.Name
public ImGearXMPString Name {get; set;}
public: __property ImGearXMPString* get_Name();
public: __property void set_Name(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Name {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


URL Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.BasicJobTicket Namespace > ImGearXMPJob Class : URL Property
Gets or sets a file URL referencing an external job management file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URL As ImGearXMPString
'Usage

Dim instance As ImGearXMPJob
Dim value As ImGearXMPString

instance.URL = value

value = instance.URL
public ImGearXMPString URL {get; set;}
public: __property ImGearXMPString* get_URL();
public: __property void set_URL(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ URL {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


ImageGear.Formats.XMP.CameraRaw Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.CameraRaw Namespace
This namespace provides the API for XMP.CameraRaw format.
Classes
 | Class | Description
Class | ImGearCameraRawXMPMetadata | Provides simplified access to XMP Camera Raw metadata scheme.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.CameraRaw Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.CameraRaw Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearCameraRawXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace : ImGearCameraRawXMPMetadata Class
Provides simplified access to XMP Camera Raw metadata scheme.
Object Model
ImGearCameraRawXMPMetadata ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearCameraRawXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearCameraRawXMPMetadata
public class ImGearCameraRawXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearCameraRawXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearCameraRawXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.CameraRaw.ImGearCameraRawXMPMetadata

See Also

Reference

ImGearCameraRawXMPMetadata Members
ImageGear.Formats.XMP.CameraRaw Namespace


%%PageItemTitle%% $$Members$$

ImGearCameraRawXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace : ImGearCameraRawXMPMetadata Class

The following tables list the members exposed by ImGearCameraRawXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearCameraRawXMPMetadata Constructor | Initializes a new instance of the ImGearCameraRawXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | AutoBrightness | Gets or sets AutoBrightness property of the XMP Camera Raw schema.
Public Property | AutoContrast | Gets or sets AutoContrast property of the XMP Camera Raw schema.
Public Property | AutoExposure | Gets or sets AutoExposure property of the XMP Camera Raw schema.
Public Property | AutoShadows | Gets or sets AutoShadows property of the XMP Camera Raw schema.
Public Property | BlueHue | Gets or sets BlueHue property of the XMP Camera Raw schema.
Public Property | BlueSaturation | Gets or sets BlueSaturation property of the XMP Camera Raw schema.
Public Property | Brightness | Gets or sets Brightness property of the XMP Camera Raw schema.
Public Property | CameraProfile | Gets or sets CameraProfile property of the XMP Camera Raw schema.
Public Property | ChromaticAberationB | Gets or sets ChromaticAberationB property of the XMP Camera Raw schema.
Public Property | ChromaticAberationR | Gets or sets ChromaticAberationR property of the XMP Camera Raw schema.
Public Property | ColorNoiseReduction | Gets or sets ColorNoiseReduction property of the XMP Camera Raw schema.
Public Property | Contrast | Gets or sets Contrast property of the XMP Camera Raw schema.
Public Property | CropAngle | Gets or sets CropAngle property of the XMP Camera Raw schema.
Public Property | CropBottom | Gets or sets CropBottom property of the XMP Camera Raw schema.
Public Property | CropHeight | Gets or sets CropHeight property of the XMP Camera Raw schema.
Public Property | CropHeigth | This property has been deprecated. Gets or sets CropHeight property of the XMP Camera Raw schema.
Public Property | CropLeft | Gets or sets CropLeft property of the XMP Camera Raw schema.
Public Property | CropRight | Gets or sets CropRight property of the XMP Camera Raw schema.
Public Property | CropTop | Gets or sets CropTop property of the XMP Camera Raw schema.
Public Property | CropUnits | Gets or sets CropUnits property of the XMP Camera Raw schema.
Public Property | CropWidth | Gets or sets CropWidth property of the XMP Camera Raw schema.
Public Property | Exposure | Gets or sets Exposure property of the XMP Camera Raw schema.
Public Property | GreenHue | Gets or sets GreenHue property of the XMP Camera Raw schema.
Public Property | GreenSaturation | Gets or sets GreenSaturation property of the XMP Camera Raw schema.
Public Property | HasHue | Gets or sets HasHue property of the XMP Camera Raw schema.
Public Property | HasSettings | Gets or sets HasSettings property of the XMP Camera Raw schema.
Public Property | LuminanceSmoothing | Gets or sets LuminanceSmoothing property of the XMP Camera Raw schema.
Public Property | RawFileName | Gets or sets RawFileName property of the XMP Camera Raw schema.
Public Property | RedHue | Gets or sets RedHue property of the XMP Camera Raw schema.
Public Property | RedSaturation | Gets or sets RedSaturation property of the XMP Camera Raw schema.
Public Property | Saturation | Gets or sets Saturation property of the XMP Camera Raw schema.
Public Property | Shadows | Gets or sets Shadows property of the XMP Camera Raw schema.
Public Property | ShadowTint | Gets or sets ShadowTint property of the XMP Camera Raw schema.
Public Property | ShadowUnit | Gets or sets ShadowUnit property of the XMP Camera Raw schema.
Public Property | Sharpness | Gets or sets Sharpness property of the XMP Camera Raw schema.
Public Property | Temperature | Gets or sets Temperature property of the XMP Camera Raw schema.
Public Property | Tint | Gets or sets Tint property of the XMP Camera Raw schema.
Public Property | ToneCurveName | Gets or sets ToneCurveName property of the XMP Camera Raw schema.
Public Property | Version | Gets or sets Version property of the XMP Camera Raw schema.
Public Property | VignetteAmount | Gets or sets VignetteAmount property of the XMP Camera Raw schema.
Public Property | VignetteMidpoint | Gets or sets VignetteMidpoint property of the XMP Camera Raw schema.
Top
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImageGear.Formats.XMP.CameraRaw Namespace


%%PageItemTitle%%

ImGearCameraRawXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ImGearCameraRawXMPMetadata Constructor
Initializes a new instance of the ImGearCameraRawXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearCameraRawXMPMetadata()
public ImGearCameraRawXMPMetadata()
public: ImGearCameraRawXMPMetadata();
public:
ImGearCameraRawXMPMetadata();

Return Value

New instance of the ImGearCameraRawXMPMetadata class object.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearCameraRawXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace : ImGearCameraRawXMPMetadata Class

For a list of all members of this type, see ImGearCameraRawXMPMetadata members.

Public Properties
 | Name | Description
Public Property | AutoBrightness | Gets or sets AutoBrightness property of the XMP Camera Raw schema.
Public Property | AutoContrast | Gets or sets AutoContrast property of the XMP Camera Raw schema.
Public Property | AutoExposure | Gets or sets AutoExposure property of the XMP Camera Raw schema.
Public Property | AutoShadows | Gets or sets AutoShadows property of the XMP Camera Raw schema.
Public Property | BlueHue | Gets or sets BlueHue property of the XMP Camera Raw schema.
Public Property | BlueSaturation | Gets or sets BlueSaturation property of the XMP Camera Raw schema.
Public Property | Brightness | Gets or sets Brightness property of the XMP Camera Raw schema.
Public Property | CameraProfile | Gets or sets CameraProfile property of the XMP Camera Raw schema.
Public Property | ChromaticAberationB | Gets or sets ChromaticAberationB property of the XMP Camera Raw schema.
Public Property | ChromaticAberationR | Gets or sets ChromaticAberationR property of the XMP Camera Raw schema.
Public Property | ColorNoiseReduction | Gets or sets ColorNoiseReduction property of the XMP Camera Raw schema.
Public Property | Contrast | Gets or sets Contrast property of the XMP Camera Raw schema.
Public Property | CropAngle | Gets or sets CropAngle property of the XMP Camera Raw schema.
Public Property | CropBottom | Gets or sets CropBottom property of the XMP Camera Raw schema.
Public Property | CropHeight | Gets or sets CropHeight property of the XMP Camera Raw schema.
Public Property | CropHeigth | This property has been deprecated. Gets or sets CropHeight property of the XMP Camera Raw schema.
Public Property | CropLeft | Gets or sets CropLeft property of the XMP Camera Raw schema.
Public Property | CropRight | Gets or sets CropRight property of the XMP Camera Raw schema.
Public Property | CropTop | Gets or sets CropTop property of the XMP Camera Raw schema.
Public Property | CropUnits | Gets or sets CropUnits property of the XMP Camera Raw schema.
Public Property | CropWidth | Gets or sets CropWidth property of the XMP Camera Raw schema.
Public Property | Exposure | Gets or sets Exposure property of the XMP Camera Raw schema.
Public Property | GreenHue | Gets or sets GreenHue property of the XMP Camera Raw schema.
Public Property | GreenSaturation | Gets or sets GreenSaturation property of the XMP Camera Raw schema.
Public Property | HasHue | Gets or sets HasHue property of the XMP Camera Raw schema.
Public Property | HasSettings | Gets or sets HasSettings property of the XMP Camera Raw schema.
Public Property | LuminanceSmoothing | Gets or sets LuminanceSmoothing property of the XMP Camera Raw schema.
Public Property | RawFileName | Gets or sets RawFileName property of the XMP Camera Raw schema.
Public Property | RedHue | Gets or sets RedHue property of the XMP Camera Raw schema.
Public Property | RedSaturation | Gets or sets RedSaturation property of the XMP Camera Raw schema.
Public Property | Saturation | Gets or sets Saturation property of the XMP Camera Raw schema.
Public Property | Shadows | Gets or sets Shadows property of the XMP Camera Raw schema.
Public Property | ShadowTint | Gets or sets ShadowTint property of the XMP Camera Raw schema.
Public Property | ShadowUnit | Gets or sets ShadowUnit property of the XMP Camera Raw schema.
Public Property | Sharpness | Gets or sets Sharpness property of the XMP Camera Raw schema.
Public Property | Temperature | Gets or sets Temperature property of the XMP Camera Raw schema.
Public Property | Tint | Gets or sets Tint property of the XMP Camera Raw schema.
Public Property | ToneCurveName | Gets or sets ToneCurveName property of the XMP Camera Raw schema.
Public Property | Version | Gets or sets Version property of the XMP Camera Raw schema.
Public Property | VignetteAmount | Gets or sets VignetteAmount property of the XMP Camera Raw schema.
Public Property | VignetteMidpoint | Gets or sets VignetteMidpoint property of the XMP Camera Raw schema.
Top
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImageGear.Formats.XMP.CameraRaw Namespace


%%PageItemTitle%%

ImGearCameraRawXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ImGearCameraRawXMPMetadata Constructor
Overload List
Overload | Description
ImGearCameraRawXMPMetadata Constructor | Initializes a new instance of the ImGearCameraRawXMPMetadata class.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


AutoBrightness Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : AutoBrightness Property
Gets or sets AutoBrightness property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoBrightness As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.AutoBrightness = value

value = instance.AutoBrightness
public ImGearXMPBoolean AutoBrightness {get; set;}
public: __property ImGearXMPBoolean* get_AutoBrightness();
public: __property void set_AutoBrightness(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ AutoBrightness {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies that "Brightness" is automatically adjusted.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


AutoContrast Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : AutoContrast Property
Gets or sets AutoContrast property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoContrast As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.AutoContrast = value

value = instance.AutoContrast
public ImGearXMPBoolean AutoContrast {get; set;}
public: __property ImGearXMPBoolean* get_AutoContrast();
public: __property void set_AutoContrast(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ AutoContrast {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies that "Contrast" is automatically adjusted.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


AutoExposure Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : AutoExposure Property
Gets or sets AutoExposure property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoExposure As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.AutoExposure = value

value = instance.AutoExposure
public ImGearXMPBoolean AutoExposure {get; set;}
public: __property ImGearXMPBoolean* get_AutoExposure();
public: __property void set_AutoExposure(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ AutoExposure {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies that "Exposure" is automatically adjusted.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


AutoShadows Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : AutoShadows Property
Gets or sets AutoShadows property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoShadows As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.AutoShadows = value

value = instance.AutoShadows
public ImGearXMPBoolean AutoShadows {get; set;}
public: __property ImGearXMPBoolean* get_AutoShadows();
public: __property void set_AutoShadows(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ AutoShadows {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies that "Shadows" is automatically adjusted.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


BlueHue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : BlueHue Property
Gets or sets BlueHue property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlueHue As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.BlueHue = value

value = instance.BlueHue
public ImGearXMPInteger BlueHue {get; set;}
public: __property ImGearXMPInteger* get_BlueHue();
public: __property void set_BlueHue(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ BlueHue {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Blue Hue" setting. Range is -100 to 100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


BlueSaturation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : BlueSaturation Property
Gets or sets BlueSaturation property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlueSaturation As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.BlueSaturation = value

value = instance.BlueSaturation
public ImGearXMPInteger BlueSaturation {get; set;}
public: __property ImGearXMPInteger* get_BlueSaturation();
public: __property void set_BlueSaturation(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ BlueSaturation {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Blue Saturation" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Brightness Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Brightness Property
Gets or sets Brightness property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Brightness As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Brightness = value

value = instance.Brightness
public ImGearXMPInteger Brightness {get; set;}
public: __property ImGearXMPInteger* get_Brightness();
public: __property void set_Brightness(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Brightness {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Brightness" setting. Range is 0 to +150.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CameraProfile Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CameraProfile Property
Gets or sets CameraProfile property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraProfile As ImGearXMPString
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPString

instance.CameraProfile = value

value = instance.CameraProfile
public ImGearXMPString CameraProfile {get; set;}
public: __property ImGearXMPString* get_CameraProfile();
public: __property void set_CameraProfile(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CameraProfile {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies "Camera Profile" setting.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ChromaticAberationB Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ChromaticAberationB Property
Gets or sets ChromaticAberationB property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChromaticAberationB As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.ChromaticAberationB = value

value = instance.ChromaticAberationB
public ImGearXMPInteger ChromaticAberationB {get; set;}
public: __property ImGearXMPInteger* get_ChromaticAberationB();
public: __property void set_ChromaticAberationB(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ChromaticAberationB {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Chomatic Aberration, Fix Blue/Yellow Fringe" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ChromaticAberationR Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ChromaticAberationR Property
Gets or sets ChromaticAberationR property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChromaticAberationR As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.ChromaticAberationR = value

value = instance.ChromaticAberationR
public ImGearXMPInteger ChromaticAberationR {get; set;}
public: __property ImGearXMPInteger* get_ChromaticAberationR();
public: __property void set_ChromaticAberationR(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ChromaticAberationR {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Chomatic Aberration, Fix Red/Cyan Fringe" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ColorNoiseReduction Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ColorNoiseReduction Property
Gets or sets ColorNoiseReduction property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorNoiseReduction As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.ColorNoiseReduction = value

value = instance.ColorNoiseReduction
public ImGearXMPInteger ColorNoiseReduction {get; set;}
public: __property ImGearXMPInteger* get_ColorNoiseReduction();
public: __property void set_ColorNoiseReduction(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ColorNoiseReduction {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Color Noise Reducton" setting. Range is 0 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Contrast Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Contrast Property
Gets or sets Contrast property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contrast As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Contrast = value

value = instance.Contrast
public ImGearXMPInteger Contrast {get; set;}
public: __property ImGearXMPInteger* get_Contrast();
public: __property void set_Contrast(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Contrast {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Contrast" setting. Range is -50 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropAngle Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropAngle Property
Gets or sets CropAngle property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropAngle As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropAngle = value

value = instance.CropAngle
public ImGearXMPReal CropAngle {get; set;}
public: __property ImGearXMPReal* get_CropAngle();
public: __property void set_CropAngle(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropAngle {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
When HasCrop is true, this XMP property specifies angle of crop rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropBottom Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropBottom Property
Gets or sets CropBottom property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropBottom As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropBottom = value

value = instance.CropBottom
public ImGearXMPReal CropBottom {get; set;}
public: __property ImGearXMPReal* get_CropBottom();
public: __property void set_CropBottom(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropBottom {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
When HasCrop is true, this XMP property specifies bottom of crop rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropHeight Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropHeight Property
Gets or sets CropHeight property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropHeight As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropHeight = value

value = instance.CropHeight
public ImGearXMPReal CropHeight {get; set;}
public: __property ImGearXMPReal* get_CropHeight();
public: __property void set_CropHeight(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropHeight {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies height of the resulting cropped image in CropUnits units.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropHeigth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropHeigth Property
This property has been deprecated. Gets or sets CropHeight property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use CropHeight property instead.")>
Public Property CropHeigth As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropHeigth = value

value = instance.CropHeigth
[Obsolete("Use CropHeight property instead.")]
public ImGearXMPReal CropHeigth {get; set;}
[Obsolete("Use CropHeight property instead.")]
public: __property ImGearXMPReal* get_CropHeigth();
public: __property void set_CropHeigth(
   ImGearXMPReal* value
);
[Obsolete("Use CropHeight property instead.")]
public:
property ImGearXMPReal^ CropHeigth {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies height of resulting cropped image in CropUnits units.
This property has been deprecated and will be deleted in a future release. Use CropHeight property instead.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropLeft Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropLeft Property
Gets or sets CropLeft property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropLeft As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropLeft = value

value = instance.CropLeft
public ImGearXMPReal CropLeft {get; set;}
public: __property ImGearXMPReal* get_CropLeft();
public: __property void set_CropLeft(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropLeft {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
When HasCrop is true, this XMP property specifies left of crop rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropRight Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropRight Property
Gets or sets CropRight property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropRight As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropRight = value

value = instance.CropRight
public ImGearXMPReal CropRight {get; set;}
public: __property ImGearXMPReal* get_CropRight();
public: __property void set_CropRight(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropRight {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
When HasCrop is true, this XMP property specifies right of crop rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropTop Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropTop Property
Gets or sets CropTop property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropTop As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropTop = value

value = instance.CropTop
public ImGearXMPReal CropTop {get; set;}
public: __property ImGearXMPReal* get_CropTop();
public: __property void set_CropTop(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropTop {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
When HasCrop is true, this XMP property specifies top of crop rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropUnits Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropUnits Property
Gets or sets CropUnits property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropUnits As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.CropUnits = value

value = instance.CropUnits
public ImGearXMPInteger CropUnits {get; set;}
public: __property ImGearXMPInteger* get_CropUnits();
public: __property void set_CropUnits(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ CropUnits {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies units for CropWidth and CropHeight. One of: 0=pixels 1=inches 2=cm.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


CropWidth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : CropWidth Property
Gets or sets CropWidth property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropWidth As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.CropWidth = value

value = instance.CropWidth
public ImGearXMPReal CropWidth {get; set;}
public: __property ImGearXMPReal* get_CropWidth();
public: __property void set_CropWidth(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ CropWidth {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies width of resulting cropped image in CropUnits units.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Exposure Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Exposure Property
Gets or sets Exposure property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Exposure As ImGearXMPReal
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPReal

instance.Exposure = value

value = instance.Exposure
public ImGearXMPReal Exposure {get; set;}
public: __property ImGearXMPReal* get_Exposure();
public: __property void set_Exposure(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Exposure {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies "Exposure" setting. Range is -4.0 to +4.0.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


GreenHue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : GreenHue Property
Gets or sets GreenHue property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GreenHue As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.GreenHue = value

value = instance.GreenHue
public ImGearXMPInteger GreenHue {get; set;}
public: __property ImGearXMPInteger* get_GreenHue();
public: __property void set_GreenHue(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ GreenHue {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Green Hue" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


GreenSaturation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : GreenSaturation Property
Gets or sets GreenSaturation property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GreenSaturation As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.GreenSaturation = value

value = instance.GreenSaturation
public ImGearXMPInteger GreenSaturation {get; set;}
public: __property ImGearXMPInteger* get_GreenSaturation();
public: __property void set_GreenSaturation(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ GreenSaturation {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Green Saturation" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


HasHue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : HasHue Property
Gets or sets HasHue property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HasHue As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.HasHue = value

value = instance.HasHue
public ImGearXMPBoolean HasHue {get; set;}
public: __property ImGearXMPBoolean* get_HasHue();
public: __property void set_HasHue(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ HasHue {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies that image has a cropping rectangle.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


HasSettings Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : HasSettings Property
Gets or sets HasSettings property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HasSettings As ImGearXMPBoolean
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPBoolean

instance.HasSettings = value

value = instance.HasSettings
public ImGearXMPBoolean HasSettings {get; set;}
public: __property ImGearXMPBoolean* get_HasSettings();
public: __property void set_HasSettings(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ HasSettings {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImGearXMPBoolean value.
Remarks
Setting this XMP property to true specifies non-default camera raw settings.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


LuminanceSmoothing Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : LuminanceSmoothing Property
Gets or sets LuminanceSmoothing property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LuminanceSmoothing As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.LuminanceSmoothing = value

value = instance.LuminanceSmoothing
public ImGearXMPInteger LuminanceSmoothing {get; set;}
public: __property ImGearXMPInteger* get_LuminanceSmoothing();
public: __property void set_LuminanceSmoothing(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ LuminanceSmoothing {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Luminance Smoothing" setting. Range is 0 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


RawFileName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : RawFileName Property
Gets or sets RawFileName property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RawFileName As ImGearXMPString
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPString

instance.RawFileName = value

value = instance.RawFileName
public ImGearXMPString RawFileName {get; set;}
public: __property ImGearXMPString* get_RawFileName();
public: __property void set_RawFileName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RawFileName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies file name for the raw file (not a complete path).
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


RedHue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : RedHue Property
Gets or sets RedHue property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedHue As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.RedHue = value

value = instance.RedHue
public ImGearXMPInteger RedHue {get; set;}
public: __property ImGearXMPInteger* get_RedHue();
public: __property void set_RedHue(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ RedHue {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Red Hue" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


RedSaturation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : RedSaturation Property
Gets or sets RedSaturation property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedSaturation As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.RedSaturation = value

value = instance.RedSaturation
public ImGearXMPInteger RedSaturation {get; set;}
public: __property ImGearXMPInteger* get_RedSaturation();
public: __property void set_RedSaturation(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ RedSaturation {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Red Saturation" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Saturation Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Saturation Property
Gets or sets Saturation property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Saturation As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Saturation = value

value = instance.Saturation
public ImGearXMPInteger Saturation {get; set;}
public: __property ImGearXMPInteger* get_Saturation();
public: __property void set_Saturation(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Saturation {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Saturation" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Shadows Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Shadows Property
Gets or sets Shadows property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Shadows As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Shadows = value

value = instance.Shadows
public ImGearXMPInteger Shadows {get; set;}
public: __property ImGearXMPInteger* get_Shadows();
public: __property void set_Shadows(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Shadows {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Shadows" setting. Range is 0 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ShadowTint Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ShadowTint Property
Gets or sets ShadowTint property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShadowTint As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.ShadowTint = value

value = instance.ShadowTint
public ImGearXMPInteger ShadowTint {get; set;}
public: __property ImGearXMPInteger* get_ShadowTint();
public: __property void set_ShadowTint(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ShadowTint {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Shadow Tint" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ShadowUnit Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ShadowUnit Property
Gets or sets ShadowUnit property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShadowUnit As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.ShadowUnit = value

value = instance.ShadowUnit
public ImGearXMPInteger ShadowUnit {get; set;}
public: __property ImGearXMPInteger* get_ShadowUnit();
public: __property void set_ShadowUnit(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ShadowUnit {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "ShadowUnit" setting.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Sharpness Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Sharpness Property
Gets or sets Sharpness property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sharpness As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Sharpness = value

value = instance.Sharpness
public ImGearXMPInteger Sharpness {get; set;}
public: __property ImGearXMPInteger* get_Sharpness();
public: __property void set_Sharpness(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Sharpness {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Sharpness" setting. Range is 0 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Temperature Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Temperature Property
Gets or sets Temperature property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Temperature As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Temperature = value

value = instance.Temperature
public ImGearXMPInteger Temperature {get; set;}
public: __property ImGearXMPInteger* get_Temperature();
public: __property void set_Temperature(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Temperature {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Temperature" setting. Range is 2000 to 50000.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Tint Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Tint Property
Gets or sets Tint property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tint As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.Tint = value

value = instance.Tint
public ImGearXMPInteger Tint {get; set;}
public: __property ImGearXMPInteger* get_Tint();
public: __property void set_Tint(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Tint {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Tint" setting. Range is -150 to +150.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ToneCurveName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : ToneCurveName Property
Gets or sets ToneCurveName property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToneCurveName As ImGearXMPString
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPString

instance.ToneCurveName = value

value = instance.ToneCurveName
public ImGearXMPString ToneCurveName {get; set;}
public: __property ImGearXMPString* get_ToneCurveName();
public: __property void set_ToneCurveName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ToneCurveName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the name of the Tone Curve described by ToneCurve. One of: 'Linear', 'Medium Contrast', 'Strong Contrast', 'Custom' or a user-defined preset name.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


Version Property (ImGearCameraRawXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : Version Property
Gets or sets Version property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Version As ImGearXMPString
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPString

instance.Version = value

value = instance.Version
public ImGearXMPString Version {get; set;}
public: __property ImGearXMPString* get_Version();
public: __property void set_Version(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Version {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies version of Camera Raw plugin.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


VignetteAmount Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : VignetteAmount Property
Gets or sets VignetteAmount property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VignetteAmount As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.VignetteAmount = value

value = instance.VignetteAmount
public ImGearXMPInteger VignetteAmount {get; set;}
public: __property ImGearXMPInteger* get_VignetteAmount();
public: __property void set_VignetteAmount(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ VignetteAmount {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Vignetting Amount" setting. Range is -100 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


VignetteMidpoint Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.CameraRaw Namespace > ImGearCameraRawXMPMetadata Class : VignetteMidpoint Property
Gets or sets VignetteMidpoint property of the XMP Camera Raw schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VignetteMidpoint As ImGearXMPInteger
'Usage

Dim instance As ImGearCameraRawXMPMetadata
Dim value As ImGearXMPInteger

instance.VignetteMidpoint = value

value = instance.VignetteMidpoint
public ImGearXMPInteger VignetteMidpoint {get; set;}
public: __property ImGearXMPInteger* get_VignetteMidpoint();
public: __property void set_VignetteMidpoint(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ VignetteMidpoint {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies "Vignetting Midpoint" setting. Range is 0 to +100.
See Also

Reference

ImGearCameraRawXMPMetadata Class
ImGearCameraRawXMPMetadata Members


ImageGear.Formats.XMP.DublinCore Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.DublinCore Namespace
This namespace provides the API for XMP.DublinCore format.
Classes
 | Class | Description
Class | ImGearDublinCoreXMPMetadata | Provides simplified access to XMP Dublin Core metadata scheme.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.DublinCore Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.DublinCore Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace : ImGearDublinCoreXMPMetadata Class
Provides simplified access to XMP Dublin Core metadata scheme.
Object Model
ImGearDublinCoreXMPMetadata ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPLangAlt Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDublinCoreXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
public class ImGearDublinCoreXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearDublinCoreXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearDublinCoreXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.DublinCore.ImGearDublinCoreXMPMetadata

See Also

Reference

ImGearDublinCoreXMPMetadata Members
ImageGear.Formats.XMP.DublinCore Namespace


%%PageItemTitle%% $$Members$$

ImGearDublinCoreXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace : ImGearDublinCoreXMPMetadata Class

The following tables list the members exposed by ImGearDublinCoreXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearDublinCoreXMPMetadata Constructor | Initializes a new instance of the ImGearDublinCoreXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Contributor | Gets or sets Contributor property of the XMP Dublin Core schema.
Public Property | Coverage | Gets or sets Coverage property of the XMP Dublin Core schema.
Public Property | Creator | Gets or sets Creator property of the XMP Dublin Core schema.
Public Property | Date | Gets or sets Date property of the XMP Dublin Core schema.
Public Property | Description | Gets or sets Description property of the XMP Dublin Core schema.
Public Property | Format | Gets or sets Format property of the XMP Dublin Core schema.
Public Property | Identifier | Gets or sets Identifier property of the XMP Dublin Core schema.
Public Property | Language | Gets or sets Language property of the XMP Dublin Core schema.
Public Property | Publisher | Gets or sets Publisher property of the XMP Dublin Core schema.
Public Property | Relation | Gets or sets Relation property of the XMP Dublin Core schema.
Public Property | Rights | Gets or sets Rights property of the XMP Dublin Core schema.
Public Property | Source | Gets or sets Source property of the XMP Dublin Core schema.
Public Property | Subject | Gets or sets Subject property of the XMP Dublin Core schema.
Public Property | Title | Gets or sets Title property of the XMP Dublin Core schema.
Public Property | Type | Gets or sets Type property of the XMP Dublin Core schema.
Top
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImageGear.Formats.XMP.DublinCore Namespace


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : ImGearDublinCoreXMPMetadata Constructor
Initializes a new instance of the ImGearDublinCoreXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDublinCoreXMPMetadata()
public ImGearDublinCoreXMPMetadata()
public: ImGearDublinCoreXMPMetadata();
public:
ImGearDublinCoreXMPMetadata();

Return Value

New instance of the ImGearDublinCoreXMPMetadata class object.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearDublinCoreXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace : ImGearDublinCoreXMPMetadata Class

For a list of all members of this type, see ImGearDublinCoreXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Contributor | Gets or sets Contributor property of the XMP Dublin Core schema.
Public Property | Coverage | Gets or sets Coverage property of the XMP Dublin Core schema.
Public Property | Creator | Gets or sets Creator property of the XMP Dublin Core schema.
Public Property | Date | Gets or sets Date property of the XMP Dublin Core schema.
Public Property | Description | Gets or sets Description property of the XMP Dublin Core schema.
Public Property | Format | Gets or sets Format property of the XMP Dublin Core schema.
Public Property | Identifier | Gets or sets Identifier property of the XMP Dublin Core schema.
Public Property | Language | Gets or sets Language property of the XMP Dublin Core schema.
Public Property | Publisher | Gets or sets Publisher property of the XMP Dublin Core schema.
Public Property | Relation | Gets or sets Relation property of the XMP Dublin Core schema.
Public Property | Rights | Gets or sets Rights property of the XMP Dublin Core schema.
Public Property | Source | Gets or sets Source property of the XMP Dublin Core schema.
Public Property | Subject | Gets or sets Subject property of the XMP Dublin Core schema.
Public Property | Title | Gets or sets Title property of the XMP Dublin Core schema.
Public Property | Type | Gets or sets Type property of the XMP Dublin Core schema.
Top
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImageGear.Formats.XMP.DublinCore Namespace


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : ImGearDublinCoreXMPMetadata Constructor
Overload List
Overload | Description
ImGearDublinCoreXMPMetadata Constructor | Initializes a new instance of the ImGearDublinCoreXMPMetadata class.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Contributor Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Contributor Property
Gets or sets Contributor property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contributor As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Contributor = value

value = instance.Contributor
public ImGearXMPBag<ImGearXMPString> Contributor {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Contributor();
public: __property void set_Contributor(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Contributor {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies contributors to the resource (other than the authors).
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Coverage Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Coverage Property
Gets or sets Coverage property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Coverage As ImGearXMPString
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPString

instance.Coverage = value

value = instance.Coverage
public ImGearXMPString Coverage {get; set;}
public: __property ImGearXMPString* get_Coverage();
public: __property void set_Coverage(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Coverage {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the extent or scope of the resource.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Creator Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Creator Property
Gets or sets Creator property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Creator As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.Creator = value

value = instance.Creator
public ImGearXMPSeq<ImGearXMPString> Creator {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_Creator();
public: __property void set_Creator(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ Creator {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies the authors of the resource (listed in order of precedence, if significant).
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Date Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Date Property
Gets or sets Date property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Date As ImGearXMPSeq(Of ImGearXMPDate)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPDate)

instance.Date = value

value = instance.Date
public ImGearXMPSeq<ImGearXMPDate> Date {get; set;}
public: __property ImGearXMPSeq<ImGearXMPDate*>* get_Date();
public: __property void set_Date(
   ImGearXMPSeq<ImGearXMPDate*>* value
);
public:
property ImGearXMPSeq<ImGearXMPDate^>^ Date {
   ImGearXMPSeq<ImGearXMPDate^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPDate^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPDate type parameter.
Remarks
This XMP property specifies date(s) that something interesting happened to the resource.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Description Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Description Property
Gets or sets Description property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As ImGearXMPLangAlt
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPLangAlt

instance.Description = value

value = instance.Description
public ImGearXMPLangAlt Description {get; set;}
public: __property ImGearXMPLangAlt* get_Description();
public: __property void set_Description(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Description {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property specifies a textual description of the content of the resource. Multiple values may be present for different languages.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Format Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Format Property
Gets or sets Format property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Format As ImGearXMPString
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPString

instance.Format = value

value = instance.Format
public ImGearXMPString Format {get; set;}
public: __property ImGearXMPString* get_Format();
public: __property void set_Format(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Format {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the file format used when saving the resource. Tools and applications should set this property to the save format of the data.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Identifier Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Identifier Property
Gets or sets Identifier property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Identifier As ImGearXMPString
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPString

instance.Identifier = value

value = instance.Identifier
public ImGearXMPString Identifier {get; set;}
public: __property ImGearXMPString* get_Identifier();
public: __property void set_Identifier(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Identifier {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies unique identifier of the resource.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Language Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Language Property
Gets or sets Language property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Language As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Language = value

value = instance.Language
public ImGearXMPBag<ImGearXMPString> Language {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Language();
public: __property void set_Language(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Language {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies an unordered array specifying the languages used in the resource.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Publisher Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Publisher Property
Gets or sets Publisher property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Publisher As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Publisher = value

value = instance.Publisher
public ImGearXMPBag<ImGearXMPString> Publisher {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Publisher();
public: __property void set_Publisher(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Publisher {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies external Publishers.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Relation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Relation Property
Gets or sets Relation property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Relation As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Relation = value

value = instance.Relation
public ImGearXMPBag<ImGearXMPString> Relation {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Relation();
public: __property void set_Relation(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Relation {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies relationships to other documents.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Rights Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Rights Property
Gets or sets Rights property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rights As ImGearXMPLangAlt
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPLangAlt

instance.Rights = value

value = instance.Rights
public ImGearXMPLangAlt Rights {get; set;}
public: __property ImGearXMPLangAlt* get_Rights();
public: __property void set_Rights(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Rights {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property specifies informal rights statement, selected by language.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Source Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Source Property
Gets or sets Source property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Source As ImGearXMPString
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPString

instance.Source = value

value = instance.Source
public ImGearXMPString Source {get; set;}
public: __property ImGearXMPString* get_Source();
public: __property void set_Source(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Source {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies unique identifier of the work from which this resource was derived.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Subject Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Subject Property
Gets or sets Subject property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Subject = value

value = instance.Subject
public ImGearXMPBag<ImGearXMPString> Subject {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Subject();
public: __property void set_Subject(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Subject {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Title Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Title Property
Gets or sets Title property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As ImGearXMPLangAlt
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPLangAlt

instance.Title = value

value = instance.Title
public ImGearXMPLangAlt Title {get; set;}
public: __property ImGearXMPLangAlt* get_Title();
public: __property void set_Title(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Title {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


Type Property (ImGearDublinCoreXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DublinCore Namespace > ImGearDublinCoreXMPMetadata Class : Type Property
Gets or sets Type property of the XMP Dublin Core schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearDublinCoreXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Type = value

value = instance.Type
public ImGearXMPBag<ImGearXMPString> Type {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Type();
public: __property void set_Type(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Type {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies a document type; for example, novel, poem, or working paper.
See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


ImageGear.Formats.XMP.DynamicMedia Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.DynamicMedia Namespace
This namespace provides the API for XMP.DynamicMedia format.
Classes
 | Class | Description
Class | ImGearDynamicMediaXMPMetadata | Provides simplified access to Dynamic Media XMP metadata scheme.
Class | ImGearXMPBeatSpliceStretch | Represents an XMP BeatSpliceStretch structure.
Class | ImGearXMPMarker | Represents an XMP Marker structure.
Class | ImGearXMPMedia | Represents an XMP Media structure.
Class | ImGearXMPProjectLink | Represents an XMP ProjectLink structure.
Class | ImGearXMPTime | Represents an XMP Time structure.
Class | ImGearXMPTimecode | Represents an XMP Timecode structure.
Class | ImGearXMPTimeScaleStretch | Represents an XMP TimeScaleStretch structure.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.DynamicMedia Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.DynamicMedia Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPBeatSpliceStretch
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMarker
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMedia
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPProjectLink
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTime
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimecode
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimeScaleStretch
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearDynamicMediaXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearDynamicMediaXMPMetadata Class
Provides simplified access to Dynamic Media XMP metadata scheme.
Object Model
ImGearDynamicMediaXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPBeatSpliceStretch ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString ClassImGearXMPBoolean ClassImGearXMPDate ClassImGearXMPReal ClassImGearXMPTime ClassImGearXMPProjectLink ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPReal ClassImGearXMPTimeScaleStretch ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPColorant ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDimensions ClassImGearXMPDate ClassImGearXMPRational ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDynamicMediaXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
public class ImGearDynamicMediaXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearDynamicMediaXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearDynamicMediaXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.DynamicMedia.ImGearDynamicMediaXMPMetadata

See Also

Reference

ImGearDynamicMediaXMPMetadata Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearDynamicMediaXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearDynamicMediaXMPMetadata Class

The following tables list the members exposed by ImGearDynamicMediaXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearDynamicMediaXMPMetadata Constructor | Initializes a new instance of the ImGearDynamicMediaXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | AbsPeakAudioFilePath | Gets or sets AbsPeakAudioFilePath property of the Dynamic Media XMP schema.
Public Property | Album | Gets or sets Album property of the Dynamic Media XMP schema.
Public Property | AltTapeName | Gets or sets AltTapeName property of the Dynamic Media XMP schema.
Public Property | Artist | Gets or sets Artist property of the Dynamic Media XMP schema.
Public Property | AudioChannelType | Gets or sets AudioChannelType property of the Dynamic Media XMP schema.
Public Property | AudioCompressor | Gets or sets AudioCompressor property of the Dynamic Media XMP schema.
Public Property | AudioModDate | Gets or sets AudioModDate property of the Dynamic Media XMP schema.
Public Property | AudioSampleRate | Gets or sets AudioSampleRate property of the Dynamic Media XMP schema.
Public Property | AudioSampleType | Gets or sets AudioSampleType property of the Dynamic Media XMP schema.
Public Property | BeatSpliceParams | Gets or sets BeatSpliceParams property of the Dynamic Media XMP schema.
Public Property | Composer | Gets or sets Composer property of the Dynamic Media XMP schema.
Public Property | ContributedMedia | Gets or sets ContributedMedia property of the Dynamic Media XMP schema.
Public Property | Copyright | Gets or sets Copyright property of the Dynamic Media XMP schema.
Public Property | Duration | Gets or sets Duration property of the Dynamic Media XMP schema.
Public Property | Engineer | Gets or sets Engineer property of the Dynamic Media XMP schema.
Public Property | FileDataRate | Gets or sets FileDataRate property of the Dynamic Media XMP schema.
Public Property | Genre | Gets or sets Genre property of the Dynamic Media XMP schema.
Public Property | Instrument | Gets or sets Instrument property of the Dynamic Media XMP schema.
Public Property | IntroTime | Gets or sets IntroTime property of the Dynamic Media XMP schema.
Public Property | Key | Gets or sets Key property of the Dynamic Media XMP schema.
Public Property | LogComment | Gets or sets LogComment property of the Dynamic Media XMP schema.
Public Property | Loop | Gets or sets Loop property of the Dynamic Media XMP schema.
Public Property | Markers | Gets or sets Markers property of the Dynamic Media XMP schema.
Public Property | MetadataModDate | Gets or sets MetadataModDate property of the Dynamic Media XMP schema.
Public Property | NumberOfBeats | Gets or sets NumberOfBeats property of the Dynamic Media XMP schema.
Public Property | OutCue | Gets or sets OutCue property of the Dynamic Media XMP schema.
Public Property | ProjectRef | Gets or sets ProjectRef property of the Dynamic Media XMP schema.
Public Property | PullDown | Gets or sets PullDown property of the Dynamic Media XMP schema.
Public Property | RelativePeakAudioFilePath | Gets or sets RelativePeakAudioFilePath property of the Dynamic Media XMP schema.
Public Property | RelativeTimeStamp | Gets or sets RelativeTimestamp property of the Dynamic Media XMP schema.
Public Property | ReleaseDate | Gets or sets ReleaseDate property of the Dynamic Media XMP schema.
Public Property | ResampleParams | Gets or sets ResampleParams property of the Dynamic Media XMP schema.
Public Property | ScaleType | Gets or sets ScaleType property of the Dynamic Media XMP schema.
Public Property | Scene | Gets or sets Scene property of the Dynamic Media XMP schema.
Public Property | ShotDate | Gets or sets ShotDate property of the Dynamic Media XMP schema.
Public Property | Shotlocation | Gets or sets ShotLocation property of the Dynamic Media XMP schema.
Public Property | ShotName | Gets or sets ShotName property of the Dynamic Media XMP schema.
Public Property | SpeakerPlacement | Gets or sets SpeakerPlacement property of the Dynamic Media XMP schema.
Public Property | StretchMode | Gets or sets StretchMode property of the Dynamic Media XMP schema.
Public Property | TapeName | Gets or sets TapeName property of the Dynamic Media XMP schema.
Public Property | Tempo | Gets or sets Tempo property of the Dynamic Media XMP schema.
Public Property | TimeScaleParams | Gets or sets TimeScaleParams property of the Dynamic Media XMP schema.
Public Property | TimeSignature | Gets or sets TimeSignature property of the Dynamic Media XMP schema.
Public Property | TrackNumber | Gets or sets TrackNumber property of the Dynamic Media XMP schema.
Public Property | VideoAlphaMode | Gets or sets VideoAlphaMode property of the Dynamic Media XMP schema.
Public Property | VideoAlphaPremultipleColor | Gets or sets VideoAlphaPremultipleColor property of the Dynamic Media XMP schema.
Public Property | VideoAlphaUnityIsTransparent | Gets or sets VideoAlphaUnityIsTransparent property of the Dynamic Media XMP schema.
Public Property | VideoColorSpace | Gets or sets VideoColorSpace property of the Dynamic Media XMP schema.
Public Property | VideoCompressor | Gets or sets VideoCompressor property of the Dynamic Media XMP schema.
Public Property | VideoFieldOrder | Gets or sets VideoFieldOrder property of the Dynamic Media XMP schema.
Public Property | VideoFrameRate | Gets or sets VideoFrameRate property of the Dynamic Media XMP schema.
Public Property | VideoFrameSize | Gets or sets VideoFrameSize property of the Dynamic Media XMP schema.
Public Property | VideoModDate | Gets or sets VideoModDate property of the Dynamic Media XMP schema.
Public Property | VideoPixelAspectRatio | Gets or sets VideoPixelAspectRatio property of the Dynamic Media XMP schema.
Public Property | VideoPixelDepth | Gets or sets VideoPixelDepth property of the Dynamic Media XMP schema.
Top
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearDynamicMediaXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ImGearDynamicMediaXMPMetadata Constructor
Initializes a new instance of the ImGearDynamicMediaXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDynamicMediaXMPMetadata()
public ImGearDynamicMediaXMPMetadata()
public: ImGearDynamicMediaXMPMetadata();
public:
ImGearDynamicMediaXMPMetadata();

Return Value

New instance of the ImGearDynamicMediaXMPMetadata class object.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearDynamicMediaXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearDynamicMediaXMPMetadata Class

For a list of all members of this type, see ImGearDynamicMediaXMPMetadata members.

Public Properties
 | Name | Description
Public Property | AbsPeakAudioFilePath | Gets or sets AbsPeakAudioFilePath property of the Dynamic Media XMP schema.
Public Property | Album | Gets or sets Album property of the Dynamic Media XMP schema.
Public Property | AltTapeName | Gets or sets AltTapeName property of the Dynamic Media XMP schema.
Public Property | Artist | Gets or sets Artist property of the Dynamic Media XMP schema.
Public Property | AudioChannelType | Gets or sets AudioChannelType property of the Dynamic Media XMP schema.
Public Property | AudioCompressor | Gets or sets AudioCompressor property of the Dynamic Media XMP schema.
Public Property | AudioModDate | Gets or sets AudioModDate property of the Dynamic Media XMP schema.
Public Property | AudioSampleRate | Gets or sets AudioSampleRate property of the Dynamic Media XMP schema.
Public Property | AudioSampleType | Gets or sets AudioSampleType property of the Dynamic Media XMP schema.
Public Property | BeatSpliceParams | Gets or sets BeatSpliceParams property of the Dynamic Media XMP schema.
Public Property | Composer | Gets or sets Composer property of the Dynamic Media XMP schema.
Public Property | ContributedMedia | Gets or sets ContributedMedia property of the Dynamic Media XMP schema.
Public Property | Copyright | Gets or sets Copyright property of the Dynamic Media XMP schema.
Public Property | Duration | Gets or sets Duration property of the Dynamic Media XMP schema.
Public Property | Engineer | Gets or sets Engineer property of the Dynamic Media XMP schema.
Public Property | FileDataRate | Gets or sets FileDataRate property of the Dynamic Media XMP schema.
Public Property | Genre | Gets or sets Genre property of the Dynamic Media XMP schema.
Public Property | Instrument | Gets or sets Instrument property of the Dynamic Media XMP schema.
Public Property | IntroTime | Gets or sets IntroTime property of the Dynamic Media XMP schema.
Public Property | Key | Gets or sets Key property of the Dynamic Media XMP schema.
Public Property | LogComment | Gets or sets LogComment property of the Dynamic Media XMP schema.
Public Property | Loop | Gets or sets Loop property of the Dynamic Media XMP schema.
Public Property | Markers | Gets or sets Markers property of the Dynamic Media XMP schema.
Public Property | MetadataModDate | Gets or sets MetadataModDate property of the Dynamic Media XMP schema.
Public Property | NumberOfBeats | Gets or sets NumberOfBeats property of the Dynamic Media XMP schema.
Public Property | OutCue | Gets or sets OutCue property of the Dynamic Media XMP schema.
Public Property | ProjectRef | Gets or sets ProjectRef property of the Dynamic Media XMP schema.
Public Property | PullDown | Gets or sets PullDown property of the Dynamic Media XMP schema.
Public Property | RelativePeakAudioFilePath | Gets or sets RelativePeakAudioFilePath property of the Dynamic Media XMP schema.
Public Property | RelativeTimeStamp | Gets or sets RelativeTimestamp property of the Dynamic Media XMP schema.
Public Property | ReleaseDate | Gets or sets ReleaseDate property of the Dynamic Media XMP schema.
Public Property | ResampleParams | Gets or sets ResampleParams property of the Dynamic Media XMP schema.
Public Property | ScaleType | Gets or sets ScaleType property of the Dynamic Media XMP schema.
Public Property | Scene | Gets or sets Scene property of the Dynamic Media XMP schema.
Public Property | ShotDate | Gets or sets ShotDate property of the Dynamic Media XMP schema.
Public Property | Shotlocation | Gets or sets ShotLocation property of the Dynamic Media XMP schema.
Public Property | ShotName | Gets or sets ShotName property of the Dynamic Media XMP schema.
Public Property | SpeakerPlacement | Gets or sets SpeakerPlacement property of the Dynamic Media XMP schema.
Public Property | StretchMode | Gets or sets StretchMode property of the Dynamic Media XMP schema.
Public Property | TapeName | Gets or sets TapeName property of the Dynamic Media XMP schema.
Public Property | Tempo | Gets or sets Tempo property of the Dynamic Media XMP schema.
Public Property | TimeScaleParams | Gets or sets TimeScaleParams property of the Dynamic Media XMP schema.
Public Property | TimeSignature | Gets or sets TimeSignature property of the Dynamic Media XMP schema.
Public Property | TrackNumber | Gets or sets TrackNumber property of the Dynamic Media XMP schema.
Public Property | VideoAlphaMode | Gets or sets VideoAlphaMode property of the Dynamic Media XMP schema.
Public Property | VideoAlphaPremultipleColor | Gets or sets VideoAlphaPremultipleColor property of the Dynamic Media XMP schema.
Public Property | VideoAlphaUnityIsTransparent | Gets or sets VideoAlphaUnityIsTransparent property of the Dynamic Media XMP schema.
Public Property | VideoColorSpace | Gets or sets VideoColorSpace property of the Dynamic Media XMP schema.
Public Property | VideoCompressor | Gets or sets VideoCompressor property of the Dynamic Media XMP schema.
Public Property | VideoFieldOrder | Gets or sets VideoFieldOrder property of the Dynamic Media XMP schema.
Public Property | VideoFrameRate | Gets or sets VideoFrameRate property of the Dynamic Media XMP schema.
Public Property | VideoFrameSize | Gets or sets VideoFrameSize property of the Dynamic Media XMP schema.
Public Property | VideoModDate | Gets or sets VideoModDate property of the Dynamic Media XMP schema.
Public Property | VideoPixelAspectRatio | Gets or sets VideoPixelAspectRatio property of the Dynamic Media XMP schema.
Public Property | VideoPixelDepth | Gets or sets VideoPixelDepth property of the Dynamic Media XMP schema.
Top
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearDynamicMediaXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ImGearDynamicMediaXMPMetadata Constructor
Overload List
Overload | Description
ImGearDynamicMediaXMPMetadata Constructor | Initializes a new instance of the ImGearDynamicMediaXMPMetadata class.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AbsPeakAudioFilePath Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AbsPeakAudioFilePath Property
Gets or sets AbsPeakAudioFilePath property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AbsPeakAudioFilePath As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.AbsPeakAudioFilePath = value

value = instance.AbsPeakAudioFilePath
public ImGearXMPString AbsPeakAudioFilePath {get; set;}
public: __property ImGearXMPString* get_AbsPeakAudioFilePath();
public: __property void set_AbsPeakAudioFilePath(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AbsPeakAudioFilePath {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies absolute path to the file's peak audio file. If empty, no peak file exists.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Album Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Album Property
Gets or sets Album property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Album As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Album = value

value = instance.Album
public ImGearXMPString Album {get; set;}
public: __property ImGearXMPString* get_Album();
public: __property void set_Album(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Album {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the album.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AltTapeName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AltTapeName Property
Gets or sets AltTapeName property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AltTapeName As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.AltTapeName = value

value = instance.AltTapeName
public ImGearXMPString AltTapeName {get; set;}
public: __property ImGearXMPString* get_AltTapeName();
public: __property void set_AltTapeName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AltTapeName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Artist Property (ImGearDynamicMediaXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Artist Property
Gets or sets Artist property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Artist As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Artist = value

value = instance.Artist
public ImGearXMPString Artist {get; set;}
public: __property ImGearXMPString* get_Artist();
public: __property void set_Artist(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Artist {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the artist or artists.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AudioChannelType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AudioChannelType Property
Gets or sets AudioChannelType property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioChannelType As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.AudioChannelType = value

value = instance.AudioChannelType
public ImGearXMPString AudioChannelType {get; set;}
public: __property ImGearXMPString* get_AudioChannelType();
public: __property void set_AudioChannelType(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AudioChannelType {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AudioCompressor Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AudioCompressor Property
Gets or sets AudioCompressor property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioCompressor As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.AudioCompressor = value

value = instance.AudioCompressor
public ImGearXMPString AudioCompressor {get; set;}
public: __property ImGearXMPString* get_AudioCompressor();
public: __property void set_AudioCompressor(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AudioCompressor {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies audio compression used. For example, MP3.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AudioModDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AudioModDate Property
Gets or sets AudioModDate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioModDate As ImGearXMPDate
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDate

instance.AudioModDate = value

value = instance.AudioModDate
public ImGearXMPDate AudioModDate {get; set;}
public: __property ImGearXMPDate* get_AudioModDate();
public: __property void set_AudioModDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ AudioModDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies date and time when the audio was last modified.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AudioSampleRate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AudioSampleRate Property
Gets or sets AudioSampleRate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioSampleRate As ImGearXMPInteger
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPInteger

instance.AudioSampleRate = value

value = instance.AudioSampleRate
public ImGearXMPInteger AudioSampleRate {get; set;}
public: __property ImGearXMPInteger* get_AudioSampleRate();
public: __property void set_AudioSampleRate(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ AudioSampleRate {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


AudioSampleType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : AudioSampleType Property
Gets or sets AudioSampleType property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioSampleType As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.AudioSampleType = value

value = instance.AudioSampleType
public ImGearXMPString AudioSampleType {get; set;}
public: __property ImGearXMPString* get_AudioSampleType();
public: __property void set_AudioSampleType(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AudioSampleType {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


BeatSpliceParams Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : BeatSpliceParams Property
Gets or sets BeatSpliceParams property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeatSpliceParams As ImGearXMPBeatSpliceStretch
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPBeatSpliceStretch

instance.BeatSpliceParams = value

value = instance.BeatSpliceParams
public ImGearXMPBeatSpliceStretch BeatSpliceParams {get; set;}
public: __property ImGearXMPBeatSpliceStretch* get_BeatSpliceParams();
public: __property void set_BeatSpliceParams(
   ImGearXMPBeatSpliceStretch* value
);
public:
property ImGearXMPBeatSpliceStretch^ BeatSpliceParams {
   ImGearXMPBeatSpliceStretch^ get();
   void set (    ImGearXMPBeatSpliceStretch^ value);
}

Property Value

ImGearXMPBeatSpliceStretch class value.
Remarks
This XMP property specifies parameters for Beat Splice stretch mode.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Composer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Composer Property
Gets or sets Composer property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Composer As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Composer = value

value = instance.Composer
public ImGearXMPString Composer {get; set;}
public: __property ImGearXMPString* get_Composer();
public: __property void set_Composer(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Composer {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies composer's name.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ContributedMedia Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ContributedMedia Property
Gets or sets ContributedMedia property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContributedMedia As ImGearXMPBag(Of ImGearXMPMedia)
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPMedia)

instance.ContributedMedia = value

value = instance.ContributedMedia
public ImGearXMPBag<ImGearXMPMedia> ContributedMedia {get; set;}
public: __property ImGearXMPBag<ImGearXMPMedia*>* get_ContributedMedia();
public: __property void set_ContributedMedia(
   ImGearXMPBag<ImGearXMPMedia*>* value
);
public:
property ImGearXMPBag<ImGearXMPMedia^>^ ContributedMedia {
   ImGearXMPBag<ImGearXMPMedia^>^ get();
   void set (    ImGearXMPBag<ImGearXMPMedia^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImGearXMPMedia type parameter.
Remarks
This XMP property specifies unordered list of all media used to create this media.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Copyright Property (ImGearDynamicMediaXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Copyright Property
Gets or sets Copyright property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Copyright As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Copyright = value

value = instance.Copyright
public ImGearXMPString Copyright {get; set;}
public: __property ImGearXMPString* get_Copyright();
public: __property void set_Copyright(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Copyright {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies copyright information.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Duration Property (ImGearDynamicMediaXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Duration Property
Gets or sets Duration property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Duration As ImGearXMPTime
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPTime

instance.Duration = value

value = instance.Duration
public ImGearXMPTime Duration {get; set;}
public: __property ImGearXMPTime* get_Duration();
public: __property void set_Duration(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ Duration {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
Remarks
This XMP property specifies duration of the media file.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Engineer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Engineer Property
Gets or sets Engineer property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Engineer As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Engineer = value

value = instance.Engineer
public ImGearXMPString Engineer {get; set;}
public: __property ImGearXMPString* get_Engineer();
public: __property void set_Engineer(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Engineer {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies engineer's name.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


FileDataRate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : FileDataRate Property
Gets or sets FileDataRate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileDataRate As ImGearXMPRational
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPRational

instance.FileDataRate = value

value = instance.FileDataRate
public ImGearXMPRational FileDataRate {get; set;}
public: __property ImGearXMPRational* get_FileDataRate();
public: __property void set_FileDataRate(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FileDataRate {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Genre Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Genre Property
Gets or sets Genre property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Genre As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Genre = value

value = instance.Genre
public ImGearXMPString Genre {get; set;}
public: __property ImGearXMPString* get_Genre();
public: __property void set_Genre(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Genre {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the genre.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Instrument Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Instrument Property
Gets or sets Instrument property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Instrument As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Instrument = value

value = instance.Instrument
public ImGearXMPString Instrument {get; set;}
public: __property ImGearXMPString* get_Instrument();
public: __property void set_Instrument(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Instrument {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies musical instrument.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


IntroTime Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : IntroTime Property
Gets or sets IntroTime property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IntroTime As ImGearXMPTime
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPTime

instance.IntroTime = value

value = instance.IntroTime
public ImGearXMPTime IntroTime {get; set;}
public: __property ImGearXMPTime* get_IntroTime();
public: __property void set_IntroTime(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ IntroTime {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
Remarks
This XMP property specifies duration of lead time for queuing music.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Key Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Key Property
Gets or sets Key property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Key As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Key = value

value = instance.Key
public ImGearXMPString Key {get; set;}
public: __property ImGearXMPString* get_Key();
public: __property void set_Key(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Key {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


LogComment Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : LogComment Property
Gets or sets LogComment property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LogComment As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.LogComment = value

value = instance.LogComment
public ImGearXMPString LogComment {get; set;}
public: __property ImGearXMPString* get_LogComment();
public: __property void set_LogComment(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ LogComment {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies log comments.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Loop Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Loop Property
Gets or sets Loop property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Loop As ImGearXMPBoolean
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPBoolean

instance.Loop = value

value = instance.Loop
public ImGearXMPBoolean Loop {get; set;}
public: __property ImGearXMPBoolean* get_Loop();
public: __property void set_Loop(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Loop {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
Remarks
This XMP property specifies true, the clip can be looped seemlessly.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Markers Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Markers Property
Gets or sets Markers property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Markers As ImGearXMPSeq(Of ImGearXMPMarker)
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPMarker)

instance.Markers = value

value = instance.Markers
public ImGearXMPSeq<ImGearXMPMarker> Markers {get; set;}
public: __property ImGearXMPSeq<ImGearXMPMarker*>* get_Markers();
public: __property void set_Markers(
   ImGearXMPSeq<ImGearXMPMarker*>* value
);
public:
property ImGearXMPSeq<ImGearXMPMarker^>^ Markers {
   ImGearXMPSeq<ImGearXMPMarker^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPMarker^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImGearXMPMarker type parameter.
Remarks
This XMP property specifies ordered list of markers.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


MetadataModDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : MetadataModDate Property
Gets or sets MetadataModDate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MetadataModDate As ImGearXMPDate
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDate

instance.MetadataModDate = value

value = instance.MetadataModDate
public ImGearXMPDate MetadataModDate {get; set;}
public: __property ImGearXMPDate* get_MetadataModDate();
public: __property void set_MetadataModDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ MetadataModDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies date and time when the metadata was last modified.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


NumberOfBeats Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : NumberOfBeats Property
Gets or sets NumberOfBeats property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfBeats As ImGearXMPReal
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPReal

instance.NumberOfBeats = value

value = instance.NumberOfBeats
public ImGearXMPReal NumberOfBeats {get; set;}
public: __property ImGearXMPReal* get_NumberOfBeats();
public: __property void set_NumberOfBeats(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ NumberOfBeats {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies number of beats.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


OutCue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : OutCue Property
Gets or sets OutCue property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutCue As ImGearXMPTime
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPTime

instance.OutCue = value

value = instance.OutCue
public ImGearXMPTime OutCue {get; set;}
public: __property ImGearXMPTime* get_OutCue();
public: __property void set_OutCue(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ OutCue {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
Remarks
This XMP property specifies time at which to fade out.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ProjectRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ProjectRef Property
Gets or sets ProjectRef property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProjectRef As ImGearXMPProjectLink
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPProjectLink

instance.ProjectRef = value

value = instance.ProjectRef
public ImGearXMPProjectLink ProjectRef {get; set;}
public: __property ImGearXMPProjectLink* get_ProjectRef();
public: __property void set_ProjectRef(
   ImGearXMPProjectLink* value
);
public:
property ImGearXMPProjectLink^ ProjectRef {
   ImGearXMPProjectLink^ get();
   void set (    ImGearXMPProjectLink^ value);
}

Property Value

ImGearXMPProjectLink class value.
Remarks
This XMP property specifies reference to the project that created this file.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


PullDown Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : PullDown Property
Gets or sets PullDown property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PullDown As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.PullDown = value

value = instance.PullDown
public ImGearXMPString PullDown {get; set;}
public: __property ImGearXMPString* get_PullDown();
public: __property void set_PullDown(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ PullDown {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


RelativePeakAudioFilePath Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : RelativePeakAudioFilePath Property
Gets or sets RelativePeakAudioFilePath property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelativePeakAudioFilePath As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.RelativePeakAudioFilePath = value

value = instance.RelativePeakAudioFilePath
public ImGearXMPString RelativePeakAudioFilePath {get; set;}
public: __property ImGearXMPString* get_RelativePeakAudioFilePath();
public: __property void set_RelativePeakAudioFilePath(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RelativePeakAudioFilePath {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies relative path to the file's peak audio file. If empty, no peak file exists.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


RelativeTimeStamp Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : RelativeTimeStamp Property
Gets or sets RelativeTimestamp property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelativeTimeStamp As ImGearXMPTime
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPTime

instance.RelativeTimeStamp = value

value = instance.RelativeTimeStamp
public ImGearXMPTime RelativeTimeStamp {get; set;}
public: __property ImGearXMPTime* get_RelativeTimeStamp();
public: __property void set_RelativeTimeStamp(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ RelativeTimeStamp {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
Remarks
This XMP property specifies start time of the media inside the audio project.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ReleaseDate Property (ImGearDynamicMediaXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ReleaseDate Property
Gets or sets ReleaseDate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReleaseDate As ImGearXMPDate
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDate

instance.ReleaseDate = value

value = instance.ReleaseDate
public ImGearXMPDate ReleaseDate {get; set;}
public: __property ImGearXMPDate* get_ReleaseDate();
public: __property void set_ReleaseDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ ReleaseDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies date the title was released.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ResampleParams Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ResampleParams Property
Gets or sets ResampleParams property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResampleParams As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.ResampleParams = value

value = instance.ResampleParams
public ImGearXMPString ResampleParams {get; set;}
public: __property ImGearXMPString* get_ResampleParams();
public: __property void set_ResampleParams(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ResampleParams {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies parameters for Resample stretch mode.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ScaleType Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ScaleType Property
Gets or sets ScaleType property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleType As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.ScaleType = value

value = instance.ScaleType
public ImGearXMPString ScaleType {get; set;}
public: __property ImGearXMPString* get_ScaleType();
public: __property void set_ScaleType(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ScaleType {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Scene Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Scene Property
Gets or sets Scene property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Scene As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Scene = value

value = instance.Scene
public ImGearXMPString Scene {get; set;}
public: __property ImGearXMPString* get_Scene();
public: __property void set_Scene(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Scene {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the scene.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ShotDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ShotDate Property
Gets or sets ShotDate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShotDate As ImGearXMPDate
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDate

instance.ShotDate = value

value = instance.ShotDate
public ImGearXMPDate ShotDate {get; set;}
public: __property ImGearXMPDate* get_ShotDate();
public: __property void set_ShotDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ ShotDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies date and time when the video was shot.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Shotlocation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Shotlocation Property
Gets or sets ShotLocation property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Shotlocation As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.Shotlocation = value

value = instance.Shotlocation
public ImGearXMPString Shotlocation {get; set;}
public: __property ImGearXMPString* get_Shotlocation();
public: __property void set_Shotlocation(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Shotlocation {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


ShotName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : ShotName Property
Gets or sets ShotName property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShotName As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.ShotName = value

value = instance.ShotName
public ImGearXMPString ShotName {get; set;}
public: __property ImGearXMPString* get_ShotName();
public: __property void set_ShotName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ShotName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the shot or take.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


SpeakerPlacement Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : SpeakerPlacement Property
Gets or sets SpeakerPlacement property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpeakerPlacement As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.SpeakerPlacement = value

value = instance.SpeakerPlacement
public ImGearXMPString SpeakerPlacement {get; set;}
public: __property ImGearXMPString* get_SpeakerPlacement();
public: __property void set_SpeakerPlacement(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ SpeakerPlacement {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies description of the speaker angles.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


StretchMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : StretchMode Property
Gets or sets StretchMode property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StretchMode As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.StretchMode = value

value = instance.StretchMode
public ImGearXMPString StretchMode {get; set;}
public: __property ImGearXMPString* get_StretchMode();
public: __property void set_StretchMode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ StretchMode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


TapeName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : TapeName Property
Gets or sets TapeName property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TapeName As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.TapeName = value

value = instance.TapeName
public ImGearXMPString TapeName {get; set;}
public: __property ImGearXMPString* get_TapeName();
public: __property void set_TapeName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ TapeName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies name of the tape from which the clip was captured, as set during the capture process.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


Tempo Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : Tempo Property
Gets or sets Tempo property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tempo As ImGearXMPReal
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPReal

instance.Tempo = value

value = instance.Tempo
public ImGearXMPReal Tempo {get; set;}
public: __property ImGearXMPReal* get_Tempo();
public: __property void set_Tempo(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ Tempo {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
Remarks
This XMP property specifies audio's tempo.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


TimeScaleParams Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : TimeScaleParams Property
Gets or sets TimeScaleParams property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeScaleParams As ImGearXMPTimeScaleStretch
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPTimeScaleStretch

instance.TimeScaleParams = value

value = instance.TimeScaleParams
public ImGearXMPTimeScaleStretch TimeScaleParams {get; set;}
public: __property ImGearXMPTimeScaleStretch* get_TimeScaleParams();
public: __property void set_TimeScaleParams(
   ImGearXMPTimeScaleStretch* value
);
public:
property ImGearXMPTimeScaleStretch^ TimeScaleParams {
   ImGearXMPTimeScaleStretch^ get();
   void set (    ImGearXMPTimeScaleStretch^ value);
}

Property Value

ImGearXMPTimeScaleStretch class value.
Remarks
This XMP property specifies parameters for Time-Scale stretch mode.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


TimeSignature Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : TimeSignature Property
Gets or sets TimeSignature property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeSignature As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.TimeSignature = value

value = instance.TimeSignature
public ImGearXMPString TimeSignature {get; set;}
public: __property ImGearXMPString* get_TimeSignature();
public: __property void set_TimeSignature(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ TimeSignature {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


TrackNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : TrackNumber Property
Gets or sets TrackNumber property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TrackNumber As ImGearXMPInteger
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPInteger

instance.TrackNumber = value

value = instance.TrackNumber
public ImGearXMPInteger TrackNumber {get; set;}
public: __property ImGearXMPInteger* get_TrackNumber();
public: __property void set_TrackNumber(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ TrackNumber {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property specifies numeric value indicating the order of the audio file within its original recording.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoAlphaMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoAlphaMode Property
Gets or sets VideoAlphaMode property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoAlphaMode As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoAlphaMode = value

value = instance.VideoAlphaMode
public ImGearXMPString VideoAlphaMode {get; set;}
public: __property ImGearXMPString* get_VideoAlphaMode();
public: __property void set_VideoAlphaMode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoAlphaMode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoAlphaPremultipleColor Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoAlphaPremultipleColor Property
Gets or sets VideoAlphaPremultipleColor property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoAlphaPremultipleColor As ImGearXMPColorant
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPColorant

instance.VideoAlphaPremultipleColor = value

value = instance.VideoAlphaPremultipleColor
public ImGearXMPColorant VideoAlphaPremultipleColor {get; set;}
public: __property ImGearXMPColorant* get_VideoAlphaPremultipleColor();
public: __property void set_VideoAlphaPremultipleColor(
   ImGearXMPColorant* value
);
public:
property ImGearXMPColorant^ VideoAlphaPremultipleColor {
   ImGearXMPColorant^ get();
   void set (    ImGearXMPColorant^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPColorant class value.
Remarks
This XMP property specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoAlphaUnityIsTransparent Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoAlphaUnityIsTransparent Property
Gets or sets VideoAlphaUnityIsTransparent property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoAlphaUnityIsTransparent As ImGearXMPBoolean
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPBoolean

instance.VideoAlphaUnityIsTransparent = value

value = instance.VideoAlphaUnityIsTransparent
public ImGearXMPBoolean VideoAlphaUnityIsTransparent {get; set;}
public: __property ImGearXMPBoolean* get_VideoAlphaUnityIsTransparent();
public: __property void set_VideoAlphaUnityIsTransparent(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ VideoAlphaUnityIsTransparent {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
Remarks
This XMP property specifies true, unity is clear, when false, it is opaque.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoColorSpace Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoColorSpace Property
Gets or sets VideoColorSpace property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoColorSpace As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoColorSpace = value

value = instance.VideoColorSpace
public ImGearXMPString VideoColorSpace {get; set;}
public: __property ImGearXMPString* get_VideoColorSpace();
public: __property void set_VideoColorSpace(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoColorSpace {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoCompressor Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoCompressor Property
Gets or sets VideoCompressor property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoCompressor As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoCompressor = value

value = instance.VideoCompressor
public ImGearXMPString VideoCompressor {get; set;}
public: __property ImGearXMPString* get_VideoCompressor();
public: __property void set_VideoCompressor(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoCompressor {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies compression used. For example, jpeg.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoFieldOrder Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoFieldOrder Property
Gets or sets VideoFieldOrder property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoFieldOrder As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoFieldOrder = value

value = instance.VideoFieldOrder
public ImGearXMPString VideoFieldOrder {get; set;}
public: __property ImGearXMPString* get_VideoFieldOrder();
public: __property void set_VideoFieldOrder(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoFieldOrder {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoFrameRate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoFrameRate Property
Gets or sets VideoFrameRate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoFrameRate As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoFrameRate = value

value = instance.VideoFrameRate
public ImGearXMPString VideoFrameRate {get; set;}
public: __property ImGearXMPString* get_VideoFrameRate();
public: __property void set_VideoFrameRate(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoFrameRate {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoFrameSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoFrameSize Property
Gets or sets VideoFrameSize property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoFrameSize As ImGearXMPDimensions
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDimensions

instance.VideoFrameSize = value

value = instance.VideoFrameSize
public ImGearXMPDimensions VideoFrameSize {get; set;}
public: __property ImGearXMPDimensions* get_VideoFrameSize();
public: __property void set_VideoFrameSize(
   ImGearXMPDimensions* value
);
public:
property ImGearXMPDimensions^ VideoFrameSize {
   ImGearXMPDimensions^ get();
   void set (    ImGearXMPDimensions^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDimensions class value.
Remarks
This XMP property specifies frame size. For example: w:720, h: 480, unit:pixels.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoModDate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoModDate Property
Gets or sets VideoModDate property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoModDate As ImGearXMPDate
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPDate

instance.VideoModDate = value

value = instance.VideoModDate
public ImGearXMPDate VideoModDate {get; set;}
public: __property ImGearXMPDate* get_VideoModDate();
public: __property void set_VideoModDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ VideoModDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies date and time when the video was last modified.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoPixelAspectRatio Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoPixelAspectRatio Property
Gets or sets VideoPixelAspectRatio property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoPixelAspectRatio As ImGearXMPRational
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPRational

instance.VideoPixelAspectRatio = value

value = instance.VideoPixelAspectRatio
public ImGearXMPRational VideoPixelAspectRatio {get; set;}
public: __property ImGearXMPRational* get_VideoPixelAspectRatio();
public: __property void set_VideoPixelAspectRatio(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ VideoPixelAspectRatio {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


VideoPixelDepth Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearDynamicMediaXMPMetadata Class : VideoPixelDepth Property
Gets or sets VideoPixelDepth property of the Dynamic Media XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VideoPixelDepth As ImGearXMPString
'Usage

Dim instance As ImGearDynamicMediaXMPMetadata
Dim value As ImGearXMPString

instance.VideoPixelDepth = value

value = instance.VideoPixelDepth
public ImGearXMPString VideoPixelDepth {get; set;}
public: __property ImGearXMPString* get_VideoPixelDepth();
public: __property void set_VideoPixelDepth(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VideoPixelDepth {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.
See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

ImGearXMPBeatSpliceStretch Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPBeatSpliceStretch Class
Represents an XMP BeatSpliceStretch structure.
Object Model
ImGearXMPBeatSpliceStretch ClassImGearXMPReal ClassImGearXMPTime ClassImGearXMPBoolean Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPBeatSpliceStretch
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPBeatSpliceStretch
public class ImGearXMPBeatSpliceStretch : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPBeatSpliceStretch : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPBeatSpliceStretch : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class contains a set of parameters used when stretching audio using the Beat Splice stretch mode.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPBeatSpliceStretch

See Also

Reference

ImGearXMPBeatSpliceStretch Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPBeatSpliceStretch Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPBeatSpliceStretch Class

The following tables list the members exposed by ImGearXMPBeatSpliceStretch.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPBeatSpliceStretch Constructor | Initializes a new instance of the ImGearXMPBeatSpliceStretch class.
Top
Public Properties
 | Name | Description
Public Property | RiseInDecibel | Gets or sets the amount sound must increase in amplitude to detect a beat.
Public Property | RiseInTimeDuration | Gets or sets the duration of the sampling window used to measure the audio increase for locating beats.
Public Property | UseFileBeatsMarker | Gets or sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
Top
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPBeatSpliceStretch Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPBeatSpliceStretch Class : ImGearXMPBeatSpliceStretch Constructor
Initializes a new instance of the ImGearXMPBeatSpliceStretch class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPBeatSpliceStretch()
public ImGearXMPBeatSpliceStretch()
public: ImGearXMPBeatSpliceStretch();
public:
ImGearXMPBeatSpliceStretch();

Return Value

New instance of the ImGearXMPBeatSpliceStretch class object.
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%% $$Properties$$

ImGearXMPBeatSpliceStretch Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPBeatSpliceStretch Class

For a list of all members of this type, see ImGearXMPBeatSpliceStretch members.

Public Properties
 | Name | Description
Public Property | RiseInDecibel | Gets or sets the amount sound must increase in amplitude to detect a beat.
Public Property | RiseInTimeDuration | Gets or sets the duration of the sampling window used to measure the audio increase for locating beats.
Public Property | UseFileBeatsMarker | Gets or sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
Top
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPBeatSpliceStretch Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPBeatSpliceStretch Class : ImGearXMPBeatSpliceStretch Constructor
Overload List
Overload | Description
ImGearXMPBeatSpliceStretch Constructor | Initializes a new instance of the ImGearXMPBeatSpliceStretch class.
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


RiseInDecibel Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPBeatSpliceStretch Class : RiseInDecibel Property
Gets or sets the amount sound must increase in amplitude to detect a beat.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RiseInDecibel As ImGearXMPReal
'Usage

Dim instance As ImGearXMPBeatSpliceStretch
Dim value As ImGearXMPReal

instance.RiseInDecibel = value

value = instance.RiseInDecibel
public ImGearXMPReal RiseInDecibel {get; set;}
public: __property ImGearXMPReal* get_RiseInDecibel();
public: __property void set_RiseInDecibel(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ RiseInDecibel {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


RiseInTimeDuration Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPBeatSpliceStretch Class : RiseInTimeDuration Property
Gets or sets the duration of the sampling window used to measure the audio increase for locating beats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RiseInTimeDuration As ImGearXMPTime
'Usage

Dim instance As ImGearXMPBeatSpliceStretch
Dim value As ImGearXMPTime

instance.RiseInTimeDuration = value

value = instance.RiseInTimeDuration
public ImGearXMPTime RiseInTimeDuration {get; set;}
public: __property ImGearXMPTime* get_RiseInTimeDuration();
public: __property void set_RiseInTimeDuration(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ RiseInTimeDuration {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


UseFileBeatsMarker Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPBeatSpliceStretch Class : UseFileBeatsMarker Property
Gets or sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseFileBeatsMarker As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPBeatSpliceStretch
Dim value As ImGearXMPBoolean

instance.UseFileBeatsMarker = value

value = instance.UseFileBeatsMarker
public ImGearXMPBoolean UseFileBeatsMarker {get; set;}
public: __property ImGearXMPBoolean* get_UseFileBeatsMarker();
public: __property void set_UseFileBeatsMarker(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ UseFileBeatsMarker {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

ImGearXMPMarker Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMarker Class
Represents an XMP Marker structure.
Object Model
ImGearXMPMarker ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPMarker
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPMarker
public class ImGearXMPMarker : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPMarker : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPMarker : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class is used to desribe an important location in a video sequence.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMarker

See Also

Reference

ImGearXMPMarker Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPMarker Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMarker Class

The following tables list the members exposed by ImGearXMPMarker.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPMarker Constructor | Initializes a new instance of the ImGearXMPMarker class.
Top
Public Properties
 | Name | Description
Public Property | Comment | Gets or sets a descriptive comment.
Public Property | Duration | Gets or sets the duration of the marker.
Public Property | Location | Gets or sets the URL of the location to jump to.
Public Property | Name | Gets or sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.
Public Property | StartTime | Gets or sets the timeline position of the marker.
Public Property | Target | Gets or sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
Public Property | Type | Gets or sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
Top
See Also

Reference

ImGearXMPMarker Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPMarker Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : ImGearXMPMarker Constructor
Initializes a new instance of the ImGearXMPMarker class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPMarker()
public ImGearXMPMarker()
public: ImGearXMPMarker();
public:
ImGearXMPMarker();

Return Value

New instance of the ImGearXMPMarker class object.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%% $$Properties$$

ImGearXMPMarker Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMarker Class

For a list of all members of this type, see ImGearXMPMarker members.

Public Properties
 | Name | Description
Public Property | Comment | Gets or sets a descriptive comment.
Public Property | Duration | Gets or sets the duration of the marker.
Public Property | Location | Gets or sets the URL of the location to jump to.
Public Property | Name | Gets or sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.
Public Property | StartTime | Gets or sets the timeline position of the marker.
Public Property | Target | Gets or sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
Public Property | Type | Gets or sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
Top
See Also

Reference

ImGearXMPMarker Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPMarker Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : ImGearXMPMarker Constructor
Overload List
Overload | Description
ImGearXMPMarker Constructor | Initializes a new instance of the ImGearXMPMarker class.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Comment Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Comment Property
Gets or sets a descriptive comment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Comment As ImGearXMPString
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPString

instance.Comment = value

value = instance.Comment
public ImGearXMPString Comment {get; set;}
public: __property ImGearXMPString* get_Comment();
public: __property void set_Comment(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Comment {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Duration Property (ImGearXMPMarker)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Duration Property
Gets or sets the duration of the marker.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Duration As ImGearXMPTime
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPTime

instance.Duration = value

value = instance.Duration
public ImGearXMPTime Duration {get; set;}
public: __property ImGearXMPTime* get_Duration();
public: __property void set_Duration(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ Duration {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Location Property (ImGearXMPMarker)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Location Property
Gets or sets the URL of the location to jump to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As ImGearXMPString
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPString

instance.Location = value

value = instance.Location
public ImGearXMPString Location {get; set;}
public: __property ImGearXMPString* get_Location();
public: __property void set_Location(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Location {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Name Property (ImGearXMPMarker)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Name Property
Gets or sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As ImGearXMPString
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPString

instance.Name = value

value = instance.Name
public ImGearXMPString Name {get; set;}
public: __property ImGearXMPString* get_Name();
public: __property void set_Name(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Name {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


StartTime Property (ImGearXMPMarker)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : StartTime Property
Gets or sets the timeline position of the marker.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartTime As ImGearXMPTime
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPTime

instance.StartTime = value

value = instance.StartTime
public ImGearXMPTime StartTime {get; set;}
public: __property ImGearXMPTime* get_StartTime();
public: __property void set_StartTime(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ StartTime {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Target Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Target Property
Gets or sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Target As ImGearXMPString
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPString

instance.Target = value

value = instance.Target
public ImGearXMPString Target {get; set;}
public: __property ImGearXMPString* get_Target();
public: __property void set_Target(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Target {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


Type Property (ImGearXMPMarker)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMarker Class : Type Property
Gets or sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearXMPString
'Usage

Dim instance As ImGearXMPMarker
Dim value As ImGearXMPString

instance.Type = value

value = instance.Type
public ImGearXMPString Type {get; set;}
public: __property ImGearXMPString* get_Type();
public: __property void set_Type(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Type {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

ImGearXMPMedia Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMedia Class
Represents an XMP Media structure.
Object Model
ImGearXMPMedia ClassImGearXMPTime ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPMedia
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPMedia
public class ImGearXMPMedia : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPMedia : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPMedia : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class specifies a reference to a media asset.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPMedia

See Also

Reference

ImGearXMPMedia Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPMedia Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMedia Class

The following tables list the members exposed by ImGearXMPMedia.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPMedia Constructor | Initializes a new instance of the ImGearXMPMedia class.
Top
Public Properties
 | Name | Description
Public Property | Duration | Gets or sets the duration of the media in the timeline.
Public Property | Managed | Gets or sets a rights-managed resource.
Public Property | Path | Gets or sets the location of the media.
Public Property | StartTime | Gets or sets the timeline position of the start of the media. This can be used to locate the media with a track.
Public Property | Track | Gets or sets an identifier for the track that contained this media. Could be a track name or a number.
Public Property | WebStatement | Gets or sets the location of a web page describing the owner and/or rights statement for this resource.
Top
See Also

Reference

ImGearXMPMedia Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPMedia Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : ImGearXMPMedia Constructor
Initializes a new instance of the ImGearXMPMedia class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPMedia()
public ImGearXMPMedia()
public: ImGearXMPMedia();
public:
ImGearXMPMedia();

Return Value

New instance of the ImGearXMPMedia class object.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%% $$Properties$$

ImGearXMPMedia Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPMedia Class

For a list of all members of this type, see ImGearXMPMedia members.

Public Properties
 | Name | Description
Public Property | Duration | Gets or sets the duration of the media in the timeline.
Public Property | Managed | Gets or sets a rights-managed resource.
Public Property | Path | Gets or sets the location of the media.
Public Property | StartTime | Gets or sets the timeline position of the start of the media. This can be used to locate the media with a track.
Public Property | Track | Gets or sets an identifier for the track that contained this media. Could be a track name or a number.
Public Property | WebStatement | Gets or sets the location of a web page describing the owner and/or rights statement for this resource.
Top
See Also

Reference

ImGearXMPMedia Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPMedia Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : ImGearXMPMedia Constructor
Overload List
Overload | Description
ImGearXMPMedia Constructor | Initializes a new instance of the ImGearXMPMedia class.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


Duration Property (ImGearXMPMedia)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : Duration Property
Gets or sets the duration of the media in the timeline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Duration As ImGearXMPTime
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPTime

instance.Duration = value

value = instance.Duration
public ImGearXMPTime Duration {get; set;}
public: __property ImGearXMPTime* get_Duration();
public: __property void set_Duration(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ Duration {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


Managed Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : Managed Property
Gets or sets a rights-managed resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Managed As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPBoolean

instance.Managed = value

value = instance.Managed
public ImGearXMPBoolean Managed {get; set;}
public: __property ImGearXMPBoolean* get_Managed();
public: __property void set_Managed(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Managed {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


Path Property (ImGearXMPMedia)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : Path Property
Gets or sets the location of the media.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Path As ImGearXMPString
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPString

instance.Path = value

value = instance.Path
public ImGearXMPString Path {get; set;}
public: __property ImGearXMPString* get_Path();
public: __property void set_Path(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Path {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


StartTime Property (ImGearXMPMedia)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : StartTime Property
Gets or sets the timeline position of the start of the media. This can be used to locate the media with a track.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartTime As ImGearXMPTime
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPTime

instance.StartTime = value

value = instance.StartTime
public ImGearXMPTime StartTime {get; set;}
public: __property ImGearXMPTime* get_StartTime();
public: __property void set_StartTime(
   ImGearXMPTime* value
);
public:
property ImGearXMPTime^ StartTime {
   ImGearXMPTime^ get();
   void set (    ImGearXMPTime^ value);
}

Property Value

ImGearXMPTime class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


Track Property (ImGearXMPMedia)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : Track Property
Gets or sets an identifier for the track that contained this media. Could be a track name or a number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Track As ImGearXMPString
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPString

instance.Track = value

value = instance.Track
public ImGearXMPString Track {get; set;}
public: __property ImGearXMPString* get_Track();
public: __property void set_Track(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Track {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


WebStatement Property (ImGearXMPMedia)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPMedia Class : WebStatement Property
Gets or sets the location of a web page describing the owner and/or rights statement for this resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WebStatement As ImGearXMPString
'Usage

Dim instance As ImGearXMPMedia
Dim value As ImGearXMPString

instance.WebStatement = value

value = instance.WebStatement
public ImGearXMPString WebStatement {get; set;}
public: __property ImGearXMPString* get_WebStatement();
public: __property void set_WebStatement(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ WebStatement {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

ImGearXMPProjectLink Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPProjectLink Class
Represents an XMP ProjectLink structure.
Object Model
ImGearXMPProjectLink ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPProjectLink
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPProjectLink
public class ImGearXMPProjectLink : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPProjectLink : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPProjectLink : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class specifies the type of a video file and path of the project that created it.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPProjectLink

See Also

Reference

ImGearXMPProjectLink Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPProjectLink Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPProjectLink Class

The following tables list the members exposed by ImGearXMPProjectLink.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPProjectLink Constructor | Initializes a new instance of the ImGearXMPProjectLink class.
Top
Public Properties
 | Name | Description
Public Property | Path | Gets or sets the full path to the project that created this file.
Public Property | Type | Gets or sets the file type. Allowed values are: "movie", "still", "audio", "custom".
Top
See Also

Reference

ImGearXMPProjectLink Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPProjectLink Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPProjectLink Class : ImGearXMPProjectLink Constructor
Initializes a new instance of the ImGearXMPProjectLink class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPProjectLink()
public ImGearXMPProjectLink()
public: ImGearXMPProjectLink();
public:
ImGearXMPProjectLink();

Return Value

New instance of the ImGearXMPProjectLink class object.
See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%% $$Properties$$

ImGearXMPProjectLink Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPProjectLink Class

For a list of all members of this type, see ImGearXMPProjectLink members.

Public Properties
 | Name | Description
Public Property | Path | Gets or sets the full path to the project that created this file.
Public Property | Type | Gets or sets the file type. Allowed values are: "movie", "still", "audio", "custom".
Top
See Also

Reference

ImGearXMPProjectLink Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPProjectLink Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPProjectLink Class : ImGearXMPProjectLink Constructor
Overload List
Overload | Description
ImGearXMPProjectLink Constructor | Initializes a new instance of the ImGearXMPProjectLink class.
See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


Path Property (ImGearXMPProjectLink)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPProjectLink Class : Path Property
Gets or sets the full path to the project that created this file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Path As ImGearXMPString
'Usage

Dim instance As ImGearXMPProjectLink
Dim value As ImGearXMPString

instance.Path = value

value = instance.Path
public ImGearXMPString Path {get; set;}
public: __property ImGearXMPString* get_Path();
public: __property void set_Path(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Path {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


Type Property (ImGearXMPProjectLink)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPProjectLink Class : Type Property
Gets or sets the file type. Allowed values are: "movie", "still", "audio", "custom".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearXMPString
'Usage

Dim instance As ImGearXMPProjectLink
Dim value As ImGearXMPString

instance.Type = value

value = instance.Type
public ImGearXMPString Type {get; set;}
public: __property ImGearXMPString* get_Type();
public: __property void set_Type(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Type {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

ImGearXMPTime Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTime Class
Represents an XMP Time structure.
Object Model
ImGearXMPTime ClassImGearXMPRational ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPTime
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPTime
public class ImGearXMPTime : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPTime : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPTime : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class provides a representation of a time value in seconds.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTime

See Also

Reference

ImGearXMPTime Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPTime Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTime Class

The following tables list the members exposed by ImGearXMPTime.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPTime Constructor | Initializes a new instance of the ImGearXMPTime class.
Top
Public Properties
 | Name | Description
Public Property | Scale | Gets or sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
Public Property | Value | Gets or sets the time value in the specified scale.
Top
See Also

Reference

ImGearXMPTime Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTime Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTime Class : ImGearXMPTime Constructor
Initializes a new instance of the ImGearXMPTime class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPTime()
public ImGearXMPTime()
public: ImGearXMPTime();
public:
ImGearXMPTime();

Return Value

New instance of the ImGearXMPTime class object.
See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%% $$Properties$$

ImGearXMPTime Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTime Class

For a list of all members of this type, see ImGearXMPTime members.

Public Properties
 | Name | Description
Public Property | Scale | Gets or sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
Public Property | Value | Gets or sets the time value in the specified scale.
Top
See Also

Reference

ImGearXMPTime Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTime Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTime Class : ImGearXMPTime Constructor
Overload List
Overload | Description
ImGearXMPTime Constructor | Initializes a new instance of the ImGearXMPTime class.
See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


Scale Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTime Class : Scale Property
Gets or sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Scale As ImGearXMPRational
'Usage

Dim instance As ImGearXMPTime
Dim value As ImGearXMPRational

instance.Scale = value

value = instance.Scale
public ImGearXMPRational Scale {get; set;}
public: __property ImGearXMPRational* get_Scale();
public: __property void set_Scale(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ Scale {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


Value Property (ImGearXMPTime)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTime Class : Value Property
Gets or sets the time value in the specified scale.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPTime
Dim value As ImGearXMPInteger

instance.Value = value

value = instance.Value
public ImGearXMPInteger Value {get; set;}
public: __property ImGearXMPInteger* get_Value();
public: __property void set_Value(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Value {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

ImGearXMPTimecode Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimecode Class
Represents an XMP Timecode structure.
Object Model
ImGearXMPTimecode ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPTimecode
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPTimecode
public class ImGearXMPTimecode : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPTimecode : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPTimecode : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class represents a time value in video.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimecode

See Also

Reference

ImGearXMPTimecode Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPTimecode Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimecode Class

The following tables list the members exposed by ImGearXMPTimecode.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPTimecode Constructor | Initializes a new instance of the ImGearXMPTimecode class.
Top
Public Properties
 | Name | Description
Public Property | TimeFormat | Gets or sets the format used in the TimeValue.
Public Property | TimeValue | Gets or sets a time value in the specified format.
Top
See Also

Reference

ImGearXMPTimecode Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTimecode Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimecode Class : ImGearXMPTimecode Constructor
Initializes a new instance of the ImGearXMPTimecode class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPTimecode()
public ImGearXMPTimecode()
public: ImGearXMPTimecode();
public:
ImGearXMPTimecode();

Return Value

New instance of the ImGearXMPTimecode class object.
See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%% $$Properties$$

ImGearXMPTimecode Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimecode Class

For a list of all members of this type, see ImGearXMPTimecode members.

Public Properties
 | Name | Description
Public Property | TimeFormat | Gets or sets the format used in the TimeValue.
Public Property | TimeValue | Gets or sets a time value in the specified format.
Top
See Also

Reference

ImGearXMPTimecode Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTimecode Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimecode Class : ImGearXMPTimecode Constructor
Overload List
Overload | Description
ImGearXMPTimecode Constructor | Initializes a new instance of the ImGearXMPTimecode class.
See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


TimeFormat Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimecode Class : TimeFormat Property
Gets or sets the format used in the TimeValue.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeFormat As ImGearXMPString
'Usage

Dim instance As ImGearXMPTimecode
Dim value As ImGearXMPString

instance.TimeFormat = value

value = instance.TimeFormat
public ImGearXMPString TimeFormat {get; set;}
public: __property ImGearXMPString* get_TimeFormat();
public: __property void set_TimeFormat(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ TimeFormat {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.
See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


TimeValue Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimecode Class : TimeValue Property
Gets or sets a time value in the specified format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeValue As ImGearXMPString
'Usage

Dim instance As ImGearXMPTimecode
Dim value As ImGearXMPString

instance.TimeValue = value

value = instance.TimeValue
public ImGearXMPString TimeValue {get; set;}
public: __property ImGearXMPString* get_TimeValue();
public: __property void set_TimeValue(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ TimeValue {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.
See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

ImGearXMPTimeScaleStretch Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimeScaleStretch Class
Represents an XMP TimeScaleStretch structure.
Object Model
ImGearXMPTimeScaleStretch ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPTimeScaleStretch
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPTimeScaleStretch
public class ImGearXMPTimeScaleStretch : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPTimeScaleStretch : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPTimeScaleStretch : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This class contains a set of parameters used when stretching audio using the Time-Scale stretch mode.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.DynamicMedia.ImGearXMPTimeScaleStretch

See Also

Reference

ImGearXMPTimeScaleStretch Members
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPTimeScaleStretch Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimeScaleStretch Class

The following tables list the members exposed by ImGearXMPTimeScaleStretch.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPTimeScaleStretch Constructor | Initializes a new instance of the ImGearXMPTimeScaleStretch class.
Top
Public Properties
 | Name | Description
Public Property | FrameOverlappingPercentage | Gets or sets the percentage of overlap between frames.
Public Property | FrameSize | Gets or sets the number of splices per beat.
Public Property | Quality | Gets or sets the stretch quality. Allowed values are: "High", "Medium", "Low".
Top
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTimeScaleStretch Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimeScaleStretch Class : ImGearXMPTimeScaleStretch Constructor
Initializes a new instance of the ImGearXMPTimeScaleStretch class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPTimeScaleStretch()
public ImGearXMPTimeScaleStretch()
public: ImGearXMPTimeScaleStretch();
public:
ImGearXMPTimeScaleStretch();

Return Value

New instance of the ImGearXMPTimeScaleStretch class object.
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%% $$Properties$$

ImGearXMPTimeScaleStretch Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace : ImGearXMPTimeScaleStretch Class

For a list of all members of this type, see ImGearXMPTimeScaleStretch members.

Public Properties
 | Name | Description
Public Property | FrameOverlappingPercentage | Gets or sets the percentage of overlap between frames.
Public Property | FrameSize | Gets or sets the number of splices per beat.
Public Property | Quality | Gets or sets the stretch quality. Allowed values are: "High", "Medium", "Low".
Top
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImageGear.Formats.XMP.DynamicMedia Namespace


%%PageItemTitle%%

ImGearXMPTimeScaleStretch Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimeScaleStretch Class : ImGearXMPTimeScaleStretch Constructor
Overload List
Overload | Description
ImGearXMPTimeScaleStretch Constructor | Initializes a new instance of the ImGearXMPTimeScaleStretch class.
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


FrameOverlappingPercentage Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimeScaleStretch Class : FrameOverlappingPercentage Property
Gets or sets the percentage of overlap between frames.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrameOverlappingPercentage As ImGearXMPReal
'Usage

Dim instance As ImGearXMPTimeScaleStretch
Dim value As ImGearXMPReal

instance.FrameOverlappingPercentage = value

value = instance.FrameOverlappingPercentage
public ImGearXMPReal FrameOverlappingPercentage {get; set;}
public: __property ImGearXMPReal* get_FrameOverlappingPercentage();
public: __property void set_FrameOverlappingPercentage(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ FrameOverlappingPercentage {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


FrameSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimeScaleStretch Class : FrameSize Property
Gets or sets the number of splices per beat.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrameSize As ImGearXMPReal
'Usage

Dim instance As ImGearXMPTimeScaleStretch
Dim value As ImGearXMPReal

instance.FrameSize = value

value = instance.FrameSize
public ImGearXMPReal FrameSize {get; set;}
public: __property ImGearXMPReal* get_FrameSize();
public: __property void set_FrameSize(
   ImGearXMPReal* value
);
public:
property ImGearXMPReal^ FrameSize {
   ImGearXMPReal^ get();
   void set (    ImGearXMPReal^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPReal class value.
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


Quality Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.DynamicMedia Namespace > ImGearXMPTimeScaleStretch Class : Quality Property
Gets or sets the stretch quality. Allowed values are: "High", "Medium", "Low".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quality As ImGearXMPString
'Usage

Dim instance As ImGearXMPTimeScaleStretch
Dim value As ImGearXMPString

instance.Quality = value

value = instance.Quality
public ImGearXMPString Quality {get; set;}
public: __property ImGearXMPString* get_Quality();
public: __property void set_Quality(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Quality {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


ImageGear.Formats.XMP.EXIF Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.EXIF Namespace
This namespace provides the API for XMP.EXIF format.
Classes
 | Class | Description
Class | ImGearEXIFXMPMetadata | Provides simplified access to EXIF XMP metadata schema.
Class | ImGearXMPCFAPattern | Represents an XMP CFAPattern structure.
Class | ImGearXMPDeviceSettings | Represents an XMP DeviceSettings structure.
Class | ImGearXMPFlash | Represents an XMP Flash structure.
Class | ImGearXMPGPSCoordinate | Represents an XMP GPSCoordinate structure.
Class | ImGearXMPOECFSFR | Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.
Enumerations
 | Enumeration | Description
Enumeration | ImGearXMPGPSDirection | Represents GPS directions, used in the EXIF XMP schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.EXIF Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.EXIF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.EXIF.ImGearEXIFXMPMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.EXIF.ImGearXMPGPSCoordinate
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.EXIF.ImGearXMPCFAPattern
ImageGear.Formats.XMP.EXIF.ImGearXMPDeviceSettings
ImageGear.Formats.XMP.EXIF.ImGearXMPFlash
ImageGear.Formats.XMP.EXIF.ImGearXMPOECFSFR
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearEXIFXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearEXIFXMPMetadata Class
Provides simplified access to EXIF XMP metadata schema.
Object Model
ImGearEXIFXMPMetadata ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPCFAPattern ClassImGearXMPRational ClassImGearXMPDate ClassImGearXMPDate ClassImGearXMPDeviceSettings ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPFlash ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPInteger ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPOECFSFR ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPOECFSFR ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPLangAlt Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEXIFXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearEXIFXMPMetadata
public class ImGearEXIFXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearEXIFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearEXIFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This class provides simplified access to EXIF XMP metadata schema. It includes the properties defined solely by the EXIF standard.

See also ImageGear.Formats.XMP.TIFF and ImageGear.Formats.XMP.EXIFAux namespaces.

Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.EXIF.ImGearEXIFXMPMetadata

See Also

Reference

ImGearEXIFXMPMetadata Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearEXIFXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearEXIFXMPMetadata Class

The following tables list the members exposed by ImGearEXIFXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearEXIFXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | ApertureValue | Gets or sets ApertureValue property of the EXIF XMP schema.
Public Property | BrightnessValue | Gets or sets BrightnessValue property of the EXIF XMP schema.
Public Property | CFAPattern | Gets or sets CFAPattern property of the EXIF XMP schema.
Public Property | ColorSpace | Gets or sets ColorSpace property of the EXIF XMP schema.
Public Property | ComponentsConfiguration | Gets or sets ComponentsConfiguration property of the EXIF XMP schema.
Public Property | CompressedBitsPerPixel | Gets or sets CompressedBitsPerPixel property of the EXIF XMP schema.
Public Property | Contrast | Gets or sets Contrast property of the EXIF XMP schema.
Public Property | CustomRendered | Gets or sets CustomRendered property of the EXIF XMP schema.
Public Property | DateTimeDigitized | Gets or sets DateTimeDigitized property of the EXIF XMP schema.
Public Property | DateTimeOriginal | Gets or sets DateTimeOriginal property of the EXIF XMP schema.
Public Property | DeviceSettingDescription | Gets or sets DeviceSettingDescription property of the EXIF XMP schema.
Public Property | DigitalZoomRatio | Gets or sets DigitalZoomRatio property of the EXIF XMP schema.
Public Property | ExifVersion | Gets or sets ExifVersion property of the EXIF XMP schema.
Public Property | ExposureBiasValue | Gets or sets ExposureBiasValue property of the EXIF XMP schema.
Public Property | ExposureIndex | Gets or sets ExposureIndex property of the EXIF XMP schema.
Public Property | ExposureMode | Gets or sets ExposureMode property of the EXIF XMP schema.
Public Property | ExposureProgram | Gets or sets ExposureProgram property of the EXIF XMP schema.
Public Property | ExposureTime | Gets or sets ExposureTime property of the EXIF XMP schema.
Public Property | FileSource | Gets or sets FileSource property of the EXIF XMP schema.
Public Property | Flash | Gets or sets Flash property of the EXIF XMP schema.
Public Property | FlashEnergy | Gets or sets FlashEnergy property of the EXIF XMP schema.
Public Property | FlashpixVersion | Gets or sets FlashpixVersion property of the EXIF XMP schema.
Public Property | FNumber | Gets or sets FNumber property of the EXIF XMP schema.
Public Property | FocalLength | Gets or sets FocalLength property of the EXIF XMP schema.
Public Property | FocalLengthIn35mmFilm | Gets or sets FocalLengthIn35mmFilm property of the EXIF XMP schema.
Public Property | FocalPlaneResolutionUnit | Gets or sets FocalPlaneResolutionUnit property of the EXIF XMP schema.
Public Property | FocalPlaneXResolution | Gets or sets FocalPlaneXResolution property of the EXIF XMP schema.
Public Property | FocalPlaneYResolution | Gets or sets FocalPlaneYResolution property of the EXIF XMP schema.
Public Property | GainControl | Gets or sets GainControl property of the EXIF XMP schema.
Public Property | GPSAltitude | Gets or sets GPSAltitude property of the EXIF XMP schema.
Public Property | GPSAltitudeRef | Gets or sets GPSAltitudeRef property of the EXIF XMP schema.
Public Property | GPSAreaInformation | Gets or sets GPSAreaInformation property of the EXIF XMP schema.
Public Property | GPSDestBearing | Gets or sets GPSDestBearing property of the EXIF XMP schema.
Public Property | GPSDestBearingRef | Gets or sets GPSDestBearingRef property of the EXIF XMP schema.
Public Property | GPSDestDistance | Gets or sets GPSDestDistance property of the EXIF XMP schema.
Public Property | GPSDestDistanceRef | Gets or sets GPSDestDistanceRef property of the EXIF XMP schema.
Public Property | GPSDestLatitude | Gets or sets GPSDestLatitude property of the EXIF XMP schema.
Public Property | GPSDestLongitude | Gets or sets GPSDestLongitude property of the EXIF XMP schema.
Public Property | GPSDifferential | Gets or sets GPSDifferential property of the EXIF XMP schema.
Public Property | GPSDOP | Gets or sets GPSDOP property of the EXIF XMP schema.
Public Property | GPSImgDirection | Gets or sets GPSImgDirection property of the EXIF XMP schema.
Public Property | GPSImgDirectionRef | Gets or sets GPSImgDirectionRef property of the EXIF XMP schema.
Public Property | GPSLatitude | Gets or sets GPSLatitude property of the EXIF XMP schema.
Public Property | GPSLongitude | Gets or sets GPSLongitude property of the EXIF XMP schema.
Public Property | GPSMapDatum | Gets or sets GPSMapDatum property of the EXIF XMP schema.
Public Property | GPSMeasureMode | Gets or sets GPSMeasureMode property of the EXIF XMP schema.
Public Property | GPSProcessingMethod | Gets or sets GPSProcessingMethod property of the EXIF XMP schema.
Public Property | GPSSatellites | Gets or sets GPSSatellites property of the EXIF XMP schema.
Public Property | GPSSpeed | Gets or sets GPSSpeed property of the EXIF XMP schema.
Public Property | GPSSpeedRef | Gets or sets GPSSpeedRef property of the EXIF XMP schema.
Public Property | GPSStatus | Gets or sets GPSStatus property of the EXIF XMP schema.
Public Property | GPSTimeStamp | Gets or sets GPSTimeStamp property of the EXIF XMP schema.
Public Property | GPSTrack | Gets or sets GPSTrack property of the EXIF XMP schema.
Public Property | GPSTrackRef | Gets or sets GPSTrackRef property of the EXIF XMP schema.
Public Property | GPSVersionID | Gets or sets GPSVersionID property of the EXIF XMP schema.
Public Property | ImageUniqueID | Gets or sets ImageUniqueID property of the EXIF XMP schema.
Public Property | ISOSpeedRatings | Gets or sets ISOSpeedRatings property of the EXIF XMP schema.
Public Property | LightSource | Gets or sets LightSource property of the EXIF XMP schema.
Public Property | MaxApertureValue | Gets or sets MaxApertureValue property of the EXIF XMP schema.
Public Property | MeteringMode | Gets or sets MeteringMode property of the EXIF XMP schema.
Public Property | OECF | Gets or sets OECF property of the EXIF XMP schema.
Public Property | PixelXDimension | Gets or sets PixelXDimension property of the EXIF XMP schema.
Public Property | PixelYDimension | Gets or sets PixelYDimension property of the EXIF XMP schema.
Public Property | RelatedSoundFile | Gets or sets RelatedSoundFile property of the EXIF XMP schema.
Public Property | Saturation | Gets or sets Saturation property of the EXIF XMP schema.
Public Property | SceneCaptureType | Gets or sets SceneCaptureType property of the EXIF XMP schema.
Public Property | SceneType | Gets or sets SceneType property of the EXIF XMP schema.
Public Property | SensingMethod | Gets or sets SensingMethod property of the EXIF XMP schema.
Public Property | Sharpness | Gets or sets Sharpness property of the EXIF XMP schema.
Public Property | ShutterSpeedValue | Gets or sets ShutterSpeedValue property of the EXIF XMP schema.
Public Property | SpatialFrequencyResponse | Gets or sets SpatialFrequencyResponse property of the EXIF XMP schema.
Public Property | SpectralSensitivity | Gets or sets SpectralSensitivity property of the EXIF XMP schema.
Public Property | SubjectArea | Gets or sets SubjectArea property of the EXIF XMP schema.
Public Property | SubjectDistance | Gets or sets SubjectDistance property of the EXIF XMP schema.
Public Property | SubjectDistanceRange | Gets or sets SubjectDistanceRange property of the EXIF XMP schema.
Public Property | SubjectLocation | Gets or sets SubjectLocation property of the EXIF XMP schema.
Public Property | UserComment | Gets or sets UserComment property of the EXIF XMP schema.
Public Property | WhiteBalance | Gets or sets WhiteBalance property of the EXIF XMP schema.
Top
See Also

Reference

ImGearEXIFXMPMetadata Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ImGearEXIFXMPMetadata Constructor
Initializes a new instance of the ImGearEXIFXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEXIFXMPMetadata()
public ImGearEXIFXMPMetadata()
public: ImGearEXIFXMPMetadata();
public:
ImGearEXIFXMPMetadata();

Return Value

New instance of ImGearEXIFXMPMetadata class object.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearEXIFXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearEXIFXMPMetadata Class

For a list of all members of this type, see ImGearEXIFXMPMetadata members.

Public Properties
 | Name | Description
Public Property | ApertureValue | Gets or sets ApertureValue property of the EXIF XMP schema.
Public Property | BrightnessValue | Gets or sets BrightnessValue property of the EXIF XMP schema.
Public Property | CFAPattern | Gets or sets CFAPattern property of the EXIF XMP schema.
Public Property | ColorSpace | Gets or sets ColorSpace property of the EXIF XMP schema.
Public Property | ComponentsConfiguration | Gets or sets ComponentsConfiguration property of the EXIF XMP schema.
Public Property | CompressedBitsPerPixel | Gets or sets CompressedBitsPerPixel property of the EXIF XMP schema.
Public Property | Contrast | Gets or sets Contrast property of the EXIF XMP schema.
Public Property | CustomRendered | Gets or sets CustomRendered property of the EXIF XMP schema.
Public Property | DateTimeDigitized | Gets or sets DateTimeDigitized property of the EXIF XMP schema.
Public Property | DateTimeOriginal | Gets or sets DateTimeOriginal property of the EXIF XMP schema.
Public Property | DeviceSettingDescription | Gets or sets DeviceSettingDescription property of the EXIF XMP schema.
Public Property | DigitalZoomRatio | Gets or sets DigitalZoomRatio property of the EXIF XMP schema.
Public Property | ExifVersion | Gets or sets ExifVersion property of the EXIF XMP schema.
Public Property | ExposureBiasValue | Gets or sets ExposureBiasValue property of the EXIF XMP schema.
Public Property | ExposureIndex | Gets or sets ExposureIndex property of the EXIF XMP schema.
Public Property | ExposureMode | Gets or sets ExposureMode property of the EXIF XMP schema.
Public Property | ExposureProgram | Gets or sets ExposureProgram property of the EXIF XMP schema.
Public Property | ExposureTime | Gets or sets ExposureTime property of the EXIF XMP schema.
Public Property | FileSource | Gets or sets FileSource property of the EXIF XMP schema.
Public Property | Flash | Gets or sets Flash property of the EXIF XMP schema.
Public Property | FlashEnergy | Gets or sets FlashEnergy property of the EXIF XMP schema.
Public Property | FlashpixVersion | Gets or sets FlashpixVersion property of the EXIF XMP schema.
Public Property | FNumber | Gets or sets FNumber property of the EXIF XMP schema.
Public Property | FocalLength | Gets or sets FocalLength property of the EXIF XMP schema.
Public Property | FocalLengthIn35mmFilm | Gets or sets FocalLengthIn35mmFilm property of the EXIF XMP schema.
Public Property | FocalPlaneResolutionUnit | Gets or sets FocalPlaneResolutionUnit property of the EXIF XMP schema.
Public Property | FocalPlaneXResolution | Gets or sets FocalPlaneXResolution property of the EXIF XMP schema.
Public Property | FocalPlaneYResolution | Gets or sets FocalPlaneYResolution property of the EXIF XMP schema.
Public Property | GainControl | Gets or sets GainControl property of the EXIF XMP schema.
Public Property | GPSAltitude | Gets or sets GPSAltitude property of the EXIF XMP schema.
Public Property | GPSAltitudeRef | Gets or sets GPSAltitudeRef property of the EXIF XMP schema.
Public Property | GPSAreaInformation | Gets or sets GPSAreaInformation property of the EXIF XMP schema.
Public Property | GPSDestBearing | Gets or sets GPSDestBearing property of the EXIF XMP schema.
Public Property | GPSDestBearingRef | Gets or sets GPSDestBearingRef property of the EXIF XMP schema.
Public Property | GPSDestDistance | Gets or sets GPSDestDistance property of the EXIF XMP schema.
Public Property | GPSDestDistanceRef | Gets or sets GPSDestDistanceRef property of the EXIF XMP schema.
Public Property | GPSDestLatitude | Gets or sets GPSDestLatitude property of the EXIF XMP schema.
Public Property | GPSDestLongitude | Gets or sets GPSDestLongitude property of the EXIF XMP schema.
Public Property | GPSDifferential | Gets or sets GPSDifferential property of the EXIF XMP schema.
Public Property | GPSDOP | Gets or sets GPSDOP property of the EXIF XMP schema.
Public Property | GPSImgDirection | Gets or sets GPSImgDirection property of the EXIF XMP schema.
Public Property | GPSImgDirectionRef | Gets or sets GPSImgDirectionRef property of the EXIF XMP schema.
Public Property | GPSLatitude | Gets or sets GPSLatitude property of the EXIF XMP schema.
Public Property | GPSLongitude | Gets or sets GPSLongitude property of the EXIF XMP schema.
Public Property | GPSMapDatum | Gets or sets GPSMapDatum property of the EXIF XMP schema.
Public Property | GPSMeasureMode | Gets or sets GPSMeasureMode property of the EXIF XMP schema.
Public Property | GPSProcessingMethod | Gets or sets GPSProcessingMethod property of the EXIF XMP schema.
Public Property | GPSSatellites | Gets or sets GPSSatellites property of the EXIF XMP schema.
Public Property | GPSSpeed | Gets or sets GPSSpeed property of the EXIF XMP schema.
Public Property | GPSSpeedRef | Gets or sets GPSSpeedRef property of the EXIF XMP schema.
Public Property | GPSStatus | Gets or sets GPSStatus property of the EXIF XMP schema.
Public Property | GPSTimeStamp | Gets or sets GPSTimeStamp property of the EXIF XMP schema.
Public Property | GPSTrack | Gets or sets GPSTrack property of the EXIF XMP schema.
Public Property | GPSTrackRef | Gets or sets GPSTrackRef property of the EXIF XMP schema.
Public Property | GPSVersionID | Gets or sets GPSVersionID property of the EXIF XMP schema.
Public Property | ImageUniqueID | Gets or sets ImageUniqueID property of the EXIF XMP schema.
Public Property | ISOSpeedRatings | Gets or sets ISOSpeedRatings property of the EXIF XMP schema.
Public Property | LightSource | Gets or sets LightSource property of the EXIF XMP schema.
Public Property | MaxApertureValue | Gets or sets MaxApertureValue property of the EXIF XMP schema.
Public Property | MeteringMode | Gets or sets MeteringMode property of the EXIF XMP schema.
Public Property | OECF | Gets or sets OECF property of the EXIF XMP schema.
Public Property | PixelXDimension | Gets or sets PixelXDimension property of the EXIF XMP schema.
Public Property | PixelYDimension | Gets or sets PixelYDimension property of the EXIF XMP schema.
Public Property | RelatedSoundFile | Gets or sets RelatedSoundFile property of the EXIF XMP schema.
Public Property | Saturation | Gets or sets Saturation property of the EXIF XMP schema.
Public Property | SceneCaptureType | Gets or sets SceneCaptureType property of the EXIF XMP schema.
Public Property | SceneType | Gets or sets SceneType property of the EXIF XMP schema.
Public Property | SensingMethod | Gets or sets SensingMethod property of the EXIF XMP schema.
Public Property | Sharpness | Gets or sets Sharpness property of the EXIF XMP schema.
Public Property | ShutterSpeedValue | Gets or sets ShutterSpeedValue property of the EXIF XMP schema.
Public Property | SpatialFrequencyResponse | Gets or sets SpatialFrequencyResponse property of the EXIF XMP schema.
Public Property | SpectralSensitivity | Gets or sets SpectralSensitivity property of the EXIF XMP schema.
Public Property | SubjectArea | Gets or sets SubjectArea property of the EXIF XMP schema.
Public Property | SubjectDistance | Gets or sets SubjectDistance property of the EXIF XMP schema.
Public Property | SubjectDistanceRange | Gets or sets SubjectDistanceRange property of the EXIF XMP schema.
Public Property | SubjectLocation | Gets or sets SubjectLocation property of the EXIF XMP schema.
Public Property | UserComment | Gets or sets UserComment property of the EXIF XMP schema.
Public Property | WhiteBalance | Gets or sets WhiteBalance property of the EXIF XMP schema.
Top
See Also

Reference

ImGearEXIFXMPMetadata Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearEXIFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ImGearEXIFXMPMetadata Constructor
Overload List
Overload | Description
ImGearEXIFXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFXMPMetadata class.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ApertureValue Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ApertureValue Property
Gets or sets ApertureValue property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApertureValue As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.ApertureValue = value

value = instance.ApertureValue
public ImGearXMPRational ApertureValue {get; set;}
public: __property ImGearXMPRational* get_ApertureValue();
public: __property void set_ApertureValue(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ ApertureValue {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


BrightnessValue Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : BrightnessValue Property
Gets or sets BrightnessValue property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BrightnessValue As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.BrightnessValue = value

value = instance.BrightnessValue
public ImGearXMPRational BrightnessValue {get; set;}
public: __property ImGearXMPRational* get_BrightnessValue();
public: __property void set_BrightnessValue(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ BrightnessValue {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


CFAPattern Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : CFAPattern Property
Gets or sets CFAPattern property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CFAPattern As ImGearXMPCFAPattern
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPCFAPattern

instance.CFAPattern = value

value = instance.CFAPattern
public ImGearXMPCFAPattern CFAPattern {get; set;}
public: __property ImGearXMPCFAPattern* get_CFAPattern();
public: __property void set_CFAPattern(
   ImGearXMPCFAPattern* value
);
public:
property ImGearXMPCFAPattern^ CFAPattern {
   ImGearXMPCFAPattern^ get();
   void set (    ImGearXMPCFAPattern^ value);
}

Property Value

ImGearXMPCFAPattern class value.
Remarks
This XMP property represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ColorSpace Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ColorSpace Property
Gets or sets ColorSpace property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As ImGearXMPEnum(Of ImGearEXIFColorSpace)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFColorSpace)

instance.ColorSpace = value

value = instance.ColorSpace
public ImGearXMPEnum<ImGearEXIFColorSpace> ColorSpace {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFColorSpace>* get_ColorSpace();
public: __property void set_ColorSpace(
   ImGearXMPEnum<ImGearEXIFColorSpace>* value
);
public:
property ImGearXMPEnum<ImGearEXIFColorSpace>^ ColorSpace {
   ImGearXMPEnum<ImGearEXIFColorSpace>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFColorSpace>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFColorSpace type parameter.
Remarks
This XMP property represents EXIF tag 40961 (0xA001) and specifies color space information.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ComponentsConfiguration Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ComponentsConfiguration Property
Gets or sets ComponentsConfiguration property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ComponentsConfiguration As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.ComponentsConfiguration = value

value = instance.ComponentsConfiguration
public ImGearXMPSeq<ImGearXMPInteger> ComponentsConfiguration {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_ComponentsConfiguration();
public: __property void set_ComponentsConfiguration(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ ComponentsConfiguration {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
This XMP property represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


CompressedBitsPerPixel Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : CompressedBitsPerPixel Property
Gets or sets CompressedBitsPerPixel property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressedBitsPerPixel As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.CompressedBitsPerPixel = value

value = instance.CompressedBitsPerPixel
public ImGearXMPRational CompressedBitsPerPixel {get; set;}
public: __property ImGearXMPRational* get_CompressedBitsPerPixel();
public: __property void set_CompressedBitsPerPixel(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ CompressedBitsPerPixel {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


Contrast Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : Contrast Property
Gets or sets Contrast property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Contrast As ImGearXMPEnum(Of ImGearEXIFContrastMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFContrastMode)

instance.Contrast = value

value = instance.Contrast
public ImGearXMPEnum<ImGearEXIFContrastMode> Contrast {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFContrastMode>* get_Contrast();
public: __property void set_Contrast(
   ImGearXMPEnum<ImGearEXIFContrastMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFContrastMode>^ Contrast {
   ImGearXMPEnum<ImGearEXIFContrastMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFContrastMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFContrastMode type parameter.
Remarks
This XMP property represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


CustomRendered Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : CustomRendered Property
Gets or sets CustomRendered property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomRendered As ImGearXMPEnum(Of ImGearEXIFCustomRendered)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFCustomRendered)

instance.CustomRendered = value

value = instance.CustomRendered
public ImGearXMPEnum<ImGearEXIFCustomRendered> CustomRendered {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFCustomRendered>* get_CustomRendered();
public: __property void set_CustomRendered(
   ImGearXMPEnum<ImGearEXIFCustomRendered>* value
);
public:
property ImGearXMPEnum<ImGearEXIFCustomRendered>^ CustomRendered {
   ImGearXMPEnum<ImGearEXIFCustomRendered>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFCustomRendered>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFCustomRendered type parameter.
Remarks
This XMP property represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


DateTimeDigitized Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : DateTimeDigitized Property
Gets or sets DateTimeDigitized property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeDigitized As ImGearXMPDate
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPDate

instance.DateTimeDigitized = value

value = instance.DateTimeDigitized
public ImGearXMPDate DateTimeDigitized {get; set;}
public: __property ImGearXMPDate* get_DateTimeDigitized();
public: __property void set_DateTimeDigitized(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateTimeDigitized {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


DateTimeOriginal Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : DateTimeOriginal Property
Gets or sets DateTimeOriginal property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeOriginal As ImGearXMPDate
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPDate

instance.DateTimeOriginal = value

value = instance.DateTimeOriginal
public ImGearXMPDate DateTimeOriginal {get; set;}
public: __property ImGearXMPDate* get_DateTimeOriginal();
public: __property void set_DateTimeOriginal(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateTimeOriginal {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


DeviceSettingDescription Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : DeviceSettingDescription Property
Gets or sets DeviceSettingDescription property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeviceSettingDescription As ImGearXMPDeviceSettings
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPDeviceSettings

instance.DeviceSettingDescription = value

value = instance.DeviceSettingDescription
public ImGearXMPDeviceSettings DeviceSettingDescription {get; set;}
public: __property ImGearXMPDeviceSettings* get_DeviceSettingDescription();
public: __property void set_DeviceSettingDescription(
   ImGearXMPDeviceSettings* value
);
public:
property ImGearXMPDeviceSettings^ DeviceSettingDescription {
   ImGearXMPDeviceSettings^ get();
   void set (    ImGearXMPDeviceSettings^ value);
}

Property Value

ImGearXMPDeviceSettings class value.
Remarks
This XMP property represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


DigitalZoomRatio Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : DigitalZoomRatio Property
Gets or sets DigitalZoomRatio property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DigitalZoomRatio As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.DigitalZoomRatio = value

value = instance.DigitalZoomRatio
public ImGearXMPRational DigitalZoomRatio {get; set;}
public: __property ImGearXMPRational* get_DigitalZoomRatio();
public: __property void set_DigitalZoomRatio(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ DigitalZoomRatio {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExifVersion Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExifVersion Property
Gets or sets ExifVersion property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExifVersion As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.ExifVersion = value

value = instance.ExifVersion
public ImGearXMPString ExifVersion {get; set;}
public: __property ImGearXMPString* get_ExifVersion();
public: __property void set_ExifVersion(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ExifVersion {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 36864 (0x9000) and specifies EXIF version number.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExposureBiasValue Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExposureBiasValue Property
Gets or sets ExposureBiasValue property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureBiasValue As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.ExposureBiasValue = value

value = instance.ExposureBiasValue
public ImGearXMPRational ExposureBiasValue {get; set;}
public: __property ImGearXMPRational* get_ExposureBiasValue();
public: __property void set_ExposureBiasValue(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ ExposureBiasValue {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExposureIndex Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExposureIndex Property
Gets or sets ExposureIndex property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureIndex As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.ExposureIndex = value

value = instance.ExposureIndex
public ImGearXMPRational ExposureIndex {get; set;}
public: __property ImGearXMPRational* get_ExposureIndex();
public: __property void set_ExposureIndex(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ ExposureIndex {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExposureMode Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExposureMode Property
Gets or sets ExposureMode property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureMode As ImGearXMPEnum(Of ImGearEXIFExposureMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFExposureMode)

instance.ExposureMode = value

value = instance.ExposureMode
public ImGearXMPEnum<ImGearEXIFExposureMode> ExposureMode {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFExposureMode>* get_ExposureMode();
public: __property void set_ExposureMode(
   ImGearXMPEnum<ImGearEXIFExposureMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFExposureMode>^ ExposureMode {
   ImGearXMPEnum<ImGearEXIFExposureMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFExposureMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFExposureMode type parameter.
Remarks
This XMP property represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExposureProgram Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExposureProgram Property
Gets or sets ExposureProgram property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureProgram As ImGearXMPEnum(Of ImGearEXIFExposureProgram)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFExposureProgram)

instance.ExposureProgram = value

value = instance.ExposureProgram
public ImGearXMPEnum<ImGearEXIFExposureProgram> ExposureProgram {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFExposureProgram>* get_ExposureProgram();
public: __property void set_ExposureProgram(
   ImGearXMPEnum<ImGearEXIFExposureProgram>* value
);
public:
property ImGearXMPEnum<ImGearEXIFExposureProgram>^ ExposureProgram {
   ImGearXMPEnum<ImGearEXIFExposureProgram>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFExposureProgram>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFExposureProgram type parameter.
Remarks
This XMP property represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ExposureTime Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ExposureTime Property
Gets or sets ExposureTime property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExposureTime As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.ExposureTime = value

value = instance.ExposureTime
public ImGearXMPRational ExposureTime {get; set;}
public: __property ImGearXMPRational* get_ExposureTime();
public: __property void set_ExposureTime(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ ExposureTime {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FileSource Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FileSource Property
Gets or sets FileSource property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileSource As ImGearXMPEnum(Of ImGearEXIFFileSource)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFFileSource)

instance.FileSource = value

value = instance.FileSource
public ImGearXMPEnum<ImGearEXIFFileSource> FileSource {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFFileSource>* get_FileSource();
public: __property void set_FileSource(
   ImGearXMPEnum<ImGearEXIFFileSource>* value
);
public:
property ImGearXMPEnum<ImGearEXIFFileSource>^ FileSource {
   ImGearXMPEnum<ImGearEXIFFileSource>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFFileSource>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFFileSource type parameter.
Remarks
This XMP property represents EXIF tag 41728 (0xA300) and indicates image source.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


Flash Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : Flash Property
Gets or sets Flash property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flash As ImGearXMPFlash
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPFlash

instance.Flash = value

value = instance.Flash
public ImGearXMPFlash Flash {get; set;}
public: __property ImGearXMPFlash* get_Flash();
public: __property void set_Flash(
   ImGearXMPFlash* value
);
public:
property ImGearXMPFlash^ Flash {
   ImGearXMPFlash^ get();
   void set (    ImGearXMPFlash^ value);
}

Property Value

ImGearXMPFlash class value.
Remarks
This XMP property represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FlashEnergy Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FlashEnergy Property
Gets or sets FlashEnergy property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashEnergy As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.FlashEnergy = value

value = instance.FlashEnergy
public ImGearXMPRational FlashEnergy {get; set;}
public: __property ImGearXMPRational* get_FlashEnergy();
public: __property void set_FlashEnergy(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FlashEnergy {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FlashpixVersion Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FlashpixVersion Property
Gets or sets FlashpixVersion property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashpixVersion As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.FlashpixVersion = value

value = instance.FlashpixVersion
public ImGearXMPString FlashpixVersion {get; set;}
public: __property ImGearXMPString* get_FlashpixVersion();
public: __property void set_FlashpixVersion(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FlashpixVersion {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FNumber Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FNumber Property
Gets or sets FNumber property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FNumber As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.FNumber = value

value = instance.FNumber
public ImGearXMPRational FNumber {get; set;}
public: __property ImGearXMPRational* get_FNumber();
public: __property void set_FNumber(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FNumber {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 33437 (0x829D) and specifies F number.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FocalLength Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FocalLength Property
Gets or sets FocalLength property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalLength As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.FocalLength = value

value = instance.FocalLength
public ImGearXMPRational FocalLength {get; set;}
public: __property ImGearXMPRational* get_FocalLength();
public: __property void set_FocalLength(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FocalLength {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FocalLengthIn35mmFilm Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FocalLengthIn35mmFilm Property
Gets or sets FocalLengthIn35mmFilm property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalLengthIn35mmFilm As ImGearXMPInteger
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPInteger

instance.FocalLengthIn35mmFilm = value

value = instance.FocalLengthIn35mmFilm
public ImGearXMPInteger FocalLengthIn35mmFilm {get; set;}
public: __property ImGearXMPInteger* get_FocalLengthIn35mmFilm();
public: __property void set_FocalLengthIn35mmFilm(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ FocalLengthIn35mmFilm {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FocalPlaneResolutionUnit Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FocalPlaneResolutionUnit Property
Gets or sets FocalPlaneResolutionUnit property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneResolutionUnit As ImGearXMPEnum(Of ImGearTIFFResolutionUnit)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFResolutionUnit)

instance.FocalPlaneResolutionUnit = value

value = instance.FocalPlaneResolutionUnit
public ImGearXMPEnum<ImGearTIFFResolutionUnit> FocalPlaneResolutionUnit {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFResolutionUnit>* get_FocalPlaneResolutionUnit();
public: __property void set_FocalPlaneResolutionUnit(
   ImGearXMPEnum<ImGearTIFFResolutionUnit>* value
);
public:
property ImGearXMPEnum<ImGearTIFFResolutionUnit>^ FocalPlaneResolutionUnit {
   ImGearXMPEnum<ImGearTIFFResolutionUnit>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFResolutionUnit>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.TIF.ImGearTIFFResolutionUnit type parameter.
Remarks
This XMP property represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FocalPlaneXResolution Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FocalPlaneXResolution Property
Gets or sets FocalPlaneXResolution property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneXResolution As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.FocalPlaneXResolution = value

value = instance.FocalPlaneXResolution
public ImGearXMPRational FocalPlaneXResolution {get; set;}
public: __property ImGearXMPRational* get_FocalPlaneXResolution();
public: __property void set_FocalPlaneXResolution(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FocalPlaneXResolution {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


FocalPlaneYResolution Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : FocalPlaneYResolution Property
Gets or sets FocalPlaneYResolution property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FocalPlaneYResolution As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.FocalPlaneYResolution = value

value = instance.FocalPlaneYResolution
public ImGearXMPRational FocalPlaneYResolution {get; set;}
public: __property ImGearXMPRational* get_FocalPlaneYResolution();
public: __property void set_FocalPlaneYResolution(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ FocalPlaneYResolution {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GainControl Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GainControl Property
Gets or sets GainControl property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GainControl As ImGearXMPEnum(Of ImGearEXIFGainControl)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFGainControl)

instance.GainControl = value

value = instance.GainControl
public ImGearXMPEnum<ImGearEXIFGainControl> GainControl {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFGainControl>* get_GainControl();
public: __property void set_GainControl(
   ImGearXMPEnum<ImGearEXIFGainControl>* value
);
public:
property ImGearXMPEnum<ImGearEXIFGainControl>^ GainControl {
   ImGearXMPEnum<ImGearEXIFGainControl>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFGainControl>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFGainControl type parameter.
Remarks
This XMP property represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSAltitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSAltitude Property
Gets or sets GPSAltitude property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSAltitude As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSAltitude = value

value = instance.GPSAltitude
public ImGearXMPRational GPSAltitude {get; set;}
public: __property ImGearXMPRational* get_GPSAltitude();
public: __property void set_GPSAltitude(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSAltitude {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSAltitudeRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSAltitudeRef Property
Gets or sets GPSAltitudeRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSAltitudeRef As ImGearXMPEnum(Of ImGearEXIFGPSAltitudeReference)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFGPSAltitudeReference)

instance.GPSAltitudeRef = value

value = instance.GPSAltitudeRef
public ImGearXMPEnum<ImGearEXIFGPSAltitudeReference> GPSAltitudeRef {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFGPSAltitudeReference>* get_GPSAltitudeRef();
public: __property void set_GPSAltitudeRef(
   ImGearXMPEnum<ImGearEXIFGPSAltitudeReference>* value
);
public:
property ImGearXMPEnum<ImGearEXIFGPSAltitudeReference>^ GPSAltitudeRef {
   ImGearXMPEnum<ImGearEXIFGPSAltitudeReference>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFGPSAltitudeReference>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFGPSAltitudeReference type parameter.
Remarks
This XMP property represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSAreaInformation Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSAreaInformation Property
Gets or sets GPSAreaInformation property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSAreaInformation As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSAreaInformation = value

value = instance.GPSAreaInformation
public ImGearXMPString GPSAreaInformation {get; set;}
public: __property ImGearXMPString* get_GPSAreaInformation();
public: __property void set_GPSAreaInformation(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSAreaInformation {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestBearing Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestBearing Property
Gets or sets GPSDestBearing property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestBearing As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSDestBearing = value

value = instance.GPSDestBearing
public ImGearXMPRational GPSDestBearing {get; set;}
public: __property ImGearXMPRational* get_GPSDestBearing();
public: __property void set_GPSDestBearing(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSDestBearing {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestBearingRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestBearingRef Property
Gets or sets GPSDestBearingRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestBearingRef As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSDestBearingRef = value

value = instance.GPSDestBearingRef
public ImGearXMPString GPSDestBearingRef {get; set;}
public: __property ImGearXMPString* get_GPSDestBearingRef();
public: __property void set_GPSDestBearingRef(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSDestBearingRef {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestDistance Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestDistance Property
Gets or sets GPSDestDistance property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestDistance As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSDestDistance = value

value = instance.GPSDestDistance
public ImGearXMPRational GPSDestDistance {get; set;}
public: __property ImGearXMPRational* get_GPSDestDistance();
public: __property void set_GPSDestDistance(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSDestDistance {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestDistanceRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestDistanceRef Property
Gets or sets GPSDestDistanceRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestDistanceRef As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSDestDistanceRef = value

value = instance.GPSDestDistanceRef
public ImGearXMPString GPSDestDistanceRef {get; set;}
public: __property ImGearXMPString* get_GPSDestDistanceRef();
public: __property void set_GPSDestDistanceRef(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSDestDistanceRef {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestLatitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestLatitude Property
Gets or sets GPSDestLatitude property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestLatitude As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSDestLatitude = value

value = instance.GPSDestLatitude
public ImGearXMPString GPSDestLatitude {get; set;}
public: __property ImGearXMPString* get_GPSDestLatitude();
public: __property void set_GPSDestLatitude(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSDestLatitude {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPGPSCoordinate class value.
Remarks
This XMP property represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDestLongitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDestLongitude Property
Gets or sets GPSDestLongitude property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDestLongitude As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSDestLongitude = value

value = instance.GPSDestLongitude
public ImGearXMPString GPSDestLongitude {get; set;}
public: __property ImGearXMPString* get_GPSDestLongitude();
public: __property void set_GPSDestLongitude(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSDestLongitude {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPGPSCoordinate class value.
Remarks
This XMP property represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDifferential Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDifferential Property
Gets or sets GPSDifferential property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDifferential As ImGearXMPEnum(Of ImGearEXIFGPSDifferential)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFGPSDifferential)

instance.GPSDifferential = value

value = instance.GPSDifferential
public ImGearXMPEnum<ImGearEXIFGPSDifferential> GPSDifferential {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFGPSDifferential>* get_GPSDifferential();
public: __property void set_GPSDifferential(
   ImGearXMPEnum<ImGearEXIFGPSDifferential>* value
);
public:
property ImGearXMPEnum<ImGearEXIFGPSDifferential>^ GPSDifferential {
   ImGearXMPEnum<ImGearEXIFGPSDifferential>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFGPSDifferential>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFGPSDifferential type parameter.
Remarks
This XMP property represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSDOP Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSDOP Property
Gets or sets GPSDOP property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSDOP As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSDOP = value

value = instance.GPSDOP
public ImGearXMPRational GPSDOP {get; set;}
public: __property ImGearXMPRational* get_GPSDOP();
public: __property void set_GPSDOP(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSDOP {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSImgDirection Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSImgDirection Property
Gets or sets GPSImgDirection property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSImgDirection As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSImgDirection = value

value = instance.GPSImgDirection
public ImGearXMPRational GPSImgDirection {get; set;}
public: __property ImGearXMPRational* get_GPSImgDirection();
public: __property void set_GPSImgDirection(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSImgDirection {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSImgDirectionRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSImgDirectionRef Property
Gets or sets GPSImgDirectionRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSImgDirectionRef As ImGearXMPEnum(Of ImGearEXIFGPSDirectionReference)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFGPSDirectionReference)

instance.GPSImgDirectionRef = value

value = instance.GPSImgDirectionRef
public ImGearXMPEnum<ImGearEXIFGPSDirectionReference> GPSImgDirectionRef {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFGPSDirectionReference>* get_GPSImgDirectionRef();
public: __property void set_GPSImgDirectionRef(
   ImGearXMPEnum<ImGearEXIFGPSDirectionReference>* value
);
public:
property ImGearXMPEnum<ImGearEXIFGPSDirectionReference>^ GPSImgDirectionRef {
   ImGearXMPEnum<ImGearEXIFGPSDirectionReference>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFGPSDirectionReference>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFGPSDirectionReference type parameter.
Remarks
This XMP property represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSLatitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSLatitude Property
Gets or sets GPSLatitude property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSLatitude As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSLatitude = value

value = instance.GPSLatitude
public ImGearXMPString GPSLatitude {get; set;}
public: __property ImGearXMPString* get_GPSLatitude();
public: __property void set_GPSLatitude(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSLatitude {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPGPSCoordinate class value.
Remarks
This XMP property represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSLongitude Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSLongitude Property
Gets or sets GPSLongitude property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSLongitude As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSLongitude = value

value = instance.GPSLongitude
public ImGearXMPString GPSLongitude {get; set;}
public: __property ImGearXMPString* get_GPSLongitude();
public: __property void set_GPSLongitude(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSLongitude {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImGearXMPGPSCoordinate class value.
Remarks
This XMP property represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSMapDatum Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSMapDatum Property
Gets or sets GPSMapDatum property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSMapDatum As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSMapDatum = value

value = instance.GPSMapDatum
public ImGearXMPString GPSMapDatum {get; set;}
public: __property ImGearXMPString* get_GPSMapDatum();
public: __property void set_GPSMapDatum(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSMapDatum {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSMeasureMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSMeasureMode Property
Gets or sets GPSMeasureMode property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSMeasureMode As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSMeasureMode = value

value = instance.GPSMeasureMode
public ImGearXMPString GPSMeasureMode {get; set;}
public: __property ImGearXMPString* get_GPSMeasureMode();
public: __property void set_GPSMeasureMode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSMeasureMode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSProcessingMethod Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSProcessingMethod Property
Gets or sets GPSProcessingMethod property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSProcessingMethod As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSProcessingMethod = value

value = instance.GPSProcessingMethod
public ImGearXMPString GPSProcessingMethod {get; set;}
public: __property ImGearXMPString* get_GPSProcessingMethod();
public: __property void set_GPSProcessingMethod(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSProcessingMethod {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSSatellites Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSSatellites Property
Gets or sets GPSSatellites property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSSatellites As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSSatellites = value

value = instance.GPSSatellites
public ImGearXMPString GPSSatellites {get; set;}
public: __property ImGearXMPString* get_GPSSatellites();
public: __property void set_GPSSatellites(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSSatellites {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSSpeed Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSSpeed Property
Gets or sets GPSSpeed property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSSpeed As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSSpeed = value

value = instance.GPSSpeed
public ImGearXMPRational GPSSpeed {get; set;}
public: __property ImGearXMPRational* get_GPSSpeed();
public: __property void set_GPSSpeed(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSSpeed {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSSpeedRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSSpeedRef Property
Gets or sets GPSSpeedRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSSpeedRef As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSSpeedRef = value

value = instance.GPSSpeedRef
public ImGearXMPString GPSSpeedRef {get; set;}
public: __property ImGearXMPString* get_GPSSpeedRef();
public: __property void set_GPSSpeedRef(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSSpeedRef {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSStatus Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSStatus Property
Gets or sets GPSStatus property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSStatus As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSStatus = value

value = instance.GPSStatus
public ImGearXMPString GPSStatus {get; set;}
public: __property ImGearXMPString* get_GPSStatus();
public: __property void set_GPSStatus(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSStatus {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSTimeStamp Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSTimeStamp Property
Gets or sets GPSTimeStamp property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSTimeStamp As ImGearXMPDate
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPDate

instance.GPSTimeStamp = value

value = instance.GPSTimeStamp
public ImGearXMPDate GPSTimeStamp {get; set;}
public: __property ImGearXMPDate* get_GPSTimeStamp();
public: __property void set_GPSTimeStamp(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ GPSTimeStamp {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSTrack Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSTrack Property
Gets or sets GPSTrack property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSTrack As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.GPSTrack = value

value = instance.GPSTrack
public ImGearXMPRational GPSTrack {get; set;}
public: __property ImGearXMPRational* get_GPSTrack();
public: __property void set_GPSTrack(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ GPSTrack {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSTrackRef Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSTrackRef Property
Gets or sets GPSTrackRef property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSTrackRef As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSTrackRef = value

value = instance.GPSTrackRef
public ImGearXMPString GPSTrackRef {get; set;}
public: __property ImGearXMPString* get_GPSTrackRef();
public: __property void set_GPSTrackRef(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSTrackRef {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


GPSVersionID Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : GPSVersionID Property
Gets or sets GPSVersionID property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GPSVersionID As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.GPSVersionID = value

value = instance.GPSVersionID
public ImGearXMPString GPSVersionID {get; set;}
public: __property ImGearXMPString* get_GPSVersionID();
public: __property void set_GPSVersionID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ GPSVersionID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ImageUniqueID Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ImageUniqueID Property
Gets or sets ImageUniqueID property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageUniqueID As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.ImageUniqueID = value

value = instance.ImageUniqueID
public ImGearXMPString ImageUniqueID {get; set;}
public: __property ImGearXMPString* get_ImageUniqueID();
public: __property void set_ImageUniqueID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ImageUniqueID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ISOSpeedRatings Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ISOSpeedRatings Property
Gets or sets ISOSpeedRatings property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ISOSpeedRatings As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.ISOSpeedRatings = value

value = instance.ISOSpeedRatings
public ImGearXMPSeq<ImGearXMPInteger> ISOSpeedRatings {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_ISOSpeedRatings();
public: __property void set_ISOSpeedRatings(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ ISOSpeedRatings {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
This XMP property represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


LightSource Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : LightSource Property
Gets or sets LightSource property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LightSource As ImGearXMPEnum(Of ImGearEXIFLightSource)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFLightSource)

instance.LightSource = value

value = instance.LightSource
public ImGearXMPEnum<ImGearEXIFLightSource> LightSource {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFLightSource>* get_LightSource();
public: __property void set_LightSource(
   ImGearXMPEnum<ImGearEXIFLightSource>* value
);
public:
property ImGearXMPEnum<ImGearEXIFLightSource>^ LightSource {
   ImGearXMPEnum<ImGearEXIFLightSource>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFLightSource>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFLightSource type parameter.
Remarks
This XMP property represents EXIF tag 37384 (0x9208) and specifies light source.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


MaxApertureValue Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : MaxApertureValue Property
Gets or sets MaxApertureValue property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxApertureValue As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.MaxApertureValue = value

value = instance.MaxApertureValue
public ImGearXMPRational MaxApertureValue {get; set;}
public: __property ImGearXMPRational* get_MaxApertureValue();
public: __property void set_MaxApertureValue(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ MaxApertureValue {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


MeteringMode Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : MeteringMode Property
Gets or sets MeteringMode property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MeteringMode As ImGearXMPEnum(Of ImGearEXIFMeteringMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFMeteringMode)

instance.MeteringMode = value

value = instance.MeteringMode
public ImGearXMPEnum<ImGearEXIFMeteringMode> MeteringMode {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFMeteringMode>* get_MeteringMode();
public: __property void set_MeteringMode(
   ImGearXMPEnum<ImGearEXIFMeteringMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFMeteringMode>^ MeteringMode {
   ImGearXMPEnum<ImGearEXIFMeteringMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFMeteringMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFMeteringMode type parameter.
Remarks
This XMP property represents EXIF tag 37383 (0x9207) and specifies image metering mode.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


OECF Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : OECF Property
Gets or sets OECF property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OECF As ImGearXMPOECFSFR
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPOECFSFR

instance.OECF = value

value = instance.OECF
public ImGearXMPOECFSFR OECF {get; set;}
public: __property ImGearXMPOECFSFR* get_OECF();
public: __property void set_OECF(
   ImGearXMPOECFSFR* value
);
public:
property ImGearXMPOECFSFR^ OECF {
   ImGearXMPOECFSFR^ get();
   void set (    ImGearXMPOECFSFR^ value);
}

Property Value

ImGearXMPOECFSFR class value.
Remarks
This XMP property represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


PixelXDimension Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : PixelXDimension Property
Gets or sets PixelXDimension property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelXDimension As ImGearXMPInteger
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPInteger

instance.PixelXDimension = value

value = instance.PixelXDimension
public ImGearXMPInteger PixelXDimension {get; set;}
public: __property ImGearXMPInteger* get_PixelXDimension();
public: __property void set_PixelXDimension(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ PixelXDimension {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


PixelYDimension Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : PixelYDimension Property
Gets or sets PixelYDimension property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelYDimension As ImGearXMPInteger
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPInteger

instance.PixelYDimension = value

value = instance.PixelYDimension
public ImGearXMPInteger PixelYDimension {get; set;}
public: __property ImGearXMPInteger* get_PixelYDimension();
public: __property void set_PixelYDimension(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ PixelYDimension {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


RelatedSoundFile Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : RelatedSoundFile Property
Gets or sets RelatedSoundFile property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelatedSoundFile As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.RelatedSoundFile = value

value = instance.RelatedSoundFile
public ImGearXMPString RelatedSoundFile {get; set;}
public: __property ImGearXMPString* get_RelatedSoundFile();
public: __property void set_RelatedSoundFile(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RelatedSoundFile {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


Saturation Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : Saturation Property
Gets or sets Saturation property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Saturation As ImGearXMPEnum(Of ImGearEXIFSaturationMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSaturationMode)

instance.Saturation = value

value = instance.Saturation
public ImGearXMPEnum<ImGearEXIFSaturationMode> Saturation {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSaturationMode>* get_Saturation();
public: __property void set_Saturation(
   ImGearXMPEnum<ImGearEXIFSaturationMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSaturationMode>^ Saturation {
   ImGearXMPEnum<ImGearEXIFSaturationMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSaturationMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSaturationMode type parameter.
Remarks
This XMP property represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SceneCaptureType Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SceneCaptureType Property
Gets or sets SceneCaptureType property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SceneCaptureType As ImGearXMPEnum(Of ImGearEXIFSceneCaptureType)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSceneCaptureType)

instance.SceneCaptureType = value

value = instance.SceneCaptureType
public ImGearXMPEnum<ImGearEXIFSceneCaptureType> SceneCaptureType {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSceneCaptureType>* get_SceneCaptureType();
public: __property void set_SceneCaptureType(
   ImGearXMPEnum<ImGearEXIFSceneCaptureType>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSceneCaptureType>^ SceneCaptureType {
   ImGearXMPEnum<ImGearEXIFSceneCaptureType>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSceneCaptureType>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSceneCaptureType type parameter.
Remarks
This XMP property represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SceneType Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SceneType Property
Gets or sets SceneType property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SceneType As ImGearXMPEnum(Of ImGearEXIFSceneType)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSceneType)

instance.SceneType = value

value = instance.SceneType
public ImGearXMPEnum<ImGearEXIFSceneType> SceneType {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSceneType>* get_SceneType();
public: __property void set_SceneType(
   ImGearXMPEnum<ImGearEXIFSceneType>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSceneType>^ SceneType {
   ImGearXMPEnum<ImGearEXIFSceneType>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSceneType>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSceneType type parameter.
Remarks
This XMP property represents EXIF tag 41729 (0xA301) and indicates the type of scene.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SensingMethod Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SensingMethod Property
Gets or sets SensingMethod property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SensingMethod As ImGearXMPEnum(Of ImGearEXIFSensingMethod)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSensingMethod)

instance.SensingMethod = value

value = instance.SensingMethod
public ImGearXMPEnum<ImGearEXIFSensingMethod> SensingMethod {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSensingMethod>* get_SensingMethod();
public: __property void set_SensingMethod(
   ImGearXMPEnum<ImGearEXIFSensingMethod>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSensingMethod>^ SensingMethod {
   ImGearXMPEnum<ImGearEXIFSensingMethod>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSensingMethod>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSensingMethod type parameter.
Remarks
This XMP property represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


Sharpness Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : Sharpness Property
Gets or sets Sharpness property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sharpness As ImGearXMPEnum(Of ImGearEXIFSharpnessMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSharpnessMode)

instance.Sharpness = value

value = instance.Sharpness
public ImGearXMPEnum<ImGearEXIFSharpnessMode> Sharpness {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSharpnessMode>* get_Sharpness();
public: __property void set_Sharpness(
   ImGearXMPEnum<ImGearEXIFSharpnessMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSharpnessMode>^ Sharpness {
   ImGearXMPEnum<ImGearEXIFSharpnessMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSharpnessMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSharpnessMode type parameter.
Remarks
This XMP property represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


ShutterSpeedValue Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : ShutterSpeedValue Property
Gets or sets ShutterSpeedValue property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShutterSpeedValue As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.ShutterSpeedValue = value

value = instance.ShutterSpeedValue
public ImGearXMPRational ShutterSpeedValue {get; set;}
public: __property ImGearXMPRational* get_ShutterSpeedValue();
public: __property void set_ShutterSpeedValue(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ ShutterSpeedValue {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SpatialFrequencyResponse Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SpatialFrequencyResponse Property
Gets or sets SpatialFrequencyResponse property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpatialFrequencyResponse As ImGearXMPOECFSFR
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPOECFSFR

instance.SpatialFrequencyResponse = value

value = instance.SpatialFrequencyResponse
public ImGearXMPOECFSFR SpatialFrequencyResponse {get; set;}
public: __property ImGearXMPOECFSFR* get_SpatialFrequencyResponse();
public: __property void set_SpatialFrequencyResponse(
   ImGearXMPOECFSFR* value
);
public:
property ImGearXMPOECFSFR^ SpatialFrequencyResponse {
   ImGearXMPOECFSFR^ get();
   void set (    ImGearXMPOECFSFR^ value);
}

Property Value

ImGearXMPOECFSFR class value.
Remarks
This XMP property represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SpectralSensitivity Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SpectralSensitivity Property
Gets or sets SpectralSensitivity property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpectralSensitivity As ImGearXMPString
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPString

instance.SpectralSensitivity = value

value = instance.SpectralSensitivity
public ImGearXMPString SpectralSensitivity {get; set;}
public: __property ImGearXMPString* get_SpectralSensitivity();
public: __property void set_SpectralSensitivity(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ SpectralSensitivity {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SubjectArea Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SubjectArea Property
Gets or sets SubjectArea property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectArea As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.SubjectArea = value

value = instance.SubjectArea
public ImGearXMPSeq<ImGearXMPInteger> SubjectArea {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_SubjectArea();
public: __property void set_SubjectArea(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ SubjectArea {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
This XMP property represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SubjectDistance Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SubjectDistance Property
Gets or sets SubjectDistance property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectDistance As ImGearXMPRational
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPRational

instance.SubjectDistance = value

value = instance.SubjectDistance
public ImGearXMPRational SubjectDistance {get; set;}
public: __property ImGearXMPRational* get_SubjectDistance();
public: __property void set_SubjectDistance(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ SubjectDistance {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SubjectDistanceRange Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SubjectDistanceRange Property
Gets or sets SubjectDistanceRange property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectDistanceRange As ImGearXMPEnum(Of ImGearEXIFSubjectDistanceRange)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFSubjectDistanceRange)

instance.SubjectDistanceRange = value

value = instance.SubjectDistanceRange
public ImGearXMPEnum<ImGearEXIFSubjectDistanceRange> SubjectDistanceRange {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFSubjectDistanceRange>* get_SubjectDistanceRange();
public: __property void set_SubjectDistanceRange(
   ImGearXMPEnum<ImGearEXIFSubjectDistanceRange>* value
);
public:
property ImGearXMPEnum<ImGearEXIFSubjectDistanceRange>^ SubjectDistanceRange {
   ImGearXMPEnum<ImGearEXIFSubjectDistanceRange>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFSubjectDistanceRange>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFSubjectDistanceRange type parameter.
Remarks
This XMP property represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


SubjectLocation Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : SubjectLocation Property
Gets or sets SubjectLocation property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectLocation As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.SubjectLocation = value

value = instance.SubjectLocation
public ImGearXMPSeq<ImGearXMPInteger> SubjectLocation {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_SubjectLocation();
public: __property void set_SubjectLocation(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ SubjectLocation {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


UserComment Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : UserComment Property
Gets or sets UserComment property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserComment As ImGearXMPLangAlt
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPLangAlt

instance.UserComment = value

value = instance.UserComment
public ImGearXMPLangAlt UserComment {get; set;}
public: __property ImGearXMPLangAlt* get_UserComment();
public: __property void set_UserComment(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ UserComment {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property represents EXIF tag 37510 (0x9286) and specifies comments from user.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


WhiteBalance Property (ImGearEXIFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearEXIFXMPMetadata Class : WhiteBalance Property
Gets or sets WhiteBalance property of the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhiteBalance As ImGearXMPEnum(Of ImGearEXIFWhiteBalanceMode)
'Usage

Dim instance As ImGearEXIFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearEXIFWhiteBalanceMode)

instance.WhiteBalance = value

value = instance.WhiteBalance
public ImGearXMPEnum<ImGearEXIFWhiteBalanceMode> WhiteBalance {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFWhiteBalanceMode>* get_WhiteBalance();
public: __property void set_WhiteBalance(
   ImGearXMPEnum<ImGearEXIFWhiteBalanceMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFWhiteBalanceMode>^ WhiteBalance {
   ImGearXMPEnum<ImGearEXIFWhiteBalanceMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFWhiteBalanceMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFWhiteBalanceMode type parameter.
Remarks
This XMP property represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.
See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

ImGearXMPCFAPattern Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPCFAPattern Class
Represents an XMP CFAPattern structure.
Object Model
ImGearXMPCFAPattern ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPCFAPattern
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPCFAPattern
public class ImGearXMPCFAPattern : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPCFAPattern : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPCFAPattern : public ImageGear.Formats.XMP.ImGearXMPStructure
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.EXIF.ImGearXMPCFAPattern

See Also

Reference

ImGearXMPCFAPattern Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPCFAPattern Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPCFAPattern Class

The following tables list the members exposed by ImGearXMPCFAPattern.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPCFAPattern Constructor | Initializes a new instance of the ImGearXMPCFAPattern class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns, in the CFA pattern.
Public Property | Rows | Gets or sets the number of rows in the CFA pattern.
Public Property | Values | Gets or sets CFA values.
Top
See Also

Reference

ImGearXMPCFAPattern Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPCFAPattern Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPCFAPattern Class : ImGearXMPCFAPattern Constructor
Initializes a new instance of the ImGearXMPCFAPattern class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPCFAPattern()
public ImGearXMPCFAPattern()
public: ImGearXMPCFAPattern();
public:
ImGearXMPCFAPattern();

Return Value

New instance of ImGearXMPCFAPattern class object.
See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%% $$Properties$$

ImGearXMPCFAPattern Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPCFAPattern Class

For a list of all members of this type, see ImGearXMPCFAPattern members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns, in the CFA pattern.
Public Property | Rows | Gets or sets the number of rows in the CFA pattern.
Public Property | Values | Gets or sets CFA values.
Top
See Also

Reference

ImGearXMPCFAPattern Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPCFAPattern Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPCFAPattern Class : ImGearXMPCFAPattern Constructor
Overload List
Overload | Description
ImGearXMPCFAPattern Constructor | Initializes a new instance of the ImGearXMPCFAPattern class.
See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


Columns Property (ImGearXMPCFAPattern)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPCFAPattern Class : Columns Property
Gets or sets the number of columns, in the CFA pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPCFAPattern
Dim value As ImGearXMPInteger

instance.Columns = value

value = instance.Columns
public ImGearXMPInteger Columns {get; set;}
public: __property ImGearXMPInteger* get_Columns();
public: __property void set_Columns(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Columns {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


Rows Property (ImGearXMPCFAPattern)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPCFAPattern Class : Rows Property
Gets or sets the number of rows in the CFA pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPCFAPattern
Dim value As ImGearXMPInteger

instance.Rows = value

value = instance.Rows
public ImGearXMPInteger Rows {get; set;}
public: __property ImGearXMPInteger* get_Rows();
public: __property void set_Rows(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Rows {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


Values Property (ImGearXMPCFAPattern)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPCFAPattern Class : Values Property
Gets or sets CFA values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Values As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearXMPCFAPattern
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.Values = value

value = instance.Values
public ImGearXMPSeq<ImGearXMPInteger> Values {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_Values();
public: __property void set_Values(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ Values {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
CFA values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

ImGearXMPDeviceSettings Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPDeviceSettings Class
Represents an XMP DeviceSettings structure.
Object Model
ImGearXMPDeviceSettings ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPDeviceSettings
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPDeviceSettings
public class ImGearXMPDeviceSettings : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPDeviceSettings : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPDeviceSettings : public ImageGear.Formats.XMP.ImGearXMPStructure
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.EXIF.ImGearXMPDeviceSettings

See Also

Reference

ImGearXMPDeviceSettings Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPDeviceSettings Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPDeviceSettings Class

The following tables list the members exposed by ImGearXMPDeviceSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPDeviceSettings Constructor | Initializes a new instance of the ImGearXMPDeviceSettings class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of display columns.
Public Property | Rows | Gets or sets the number of display rows.
Public Property | Settings | Gets or sets camera settings, in order.
Top
See Also

Reference

ImGearXMPDeviceSettings Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPDeviceSettings Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPDeviceSettings Class : ImGearXMPDeviceSettings Constructor
Initializes a new instance of the ImGearXMPDeviceSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPDeviceSettings()
public ImGearXMPDeviceSettings()
public: ImGearXMPDeviceSettings();
public:
ImGearXMPDeviceSettings();

Return Value

New instance of ImGearXMPDeviceSettings class object.
See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%% $$Properties$$

ImGearXMPDeviceSettings Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPDeviceSettings Class

For a list of all members of this type, see ImGearXMPDeviceSettings members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of display columns.
Public Property | Rows | Gets or sets the number of display rows.
Public Property | Settings | Gets or sets camera settings, in order.
Top
See Also

Reference

ImGearXMPDeviceSettings Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPDeviceSettings Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPDeviceSettings Class : ImGearXMPDeviceSettings Constructor
Overload List
Overload | Description
ImGearXMPDeviceSettings Constructor | Initializes a new instance of the ImGearXMPDeviceSettings class.
See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


Columns Property (ImGearXMPDeviceSettings)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPDeviceSettings Class : Columns Property
Gets or sets the number of display columns.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDeviceSettings
Dim value As ImGearXMPInteger

instance.Columns = value

value = instance.Columns
public ImGearXMPInteger Columns {get; set;}
public: __property ImGearXMPInteger* get_Columns();
public: __property void set_Columns(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Columns {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


Rows Property (ImGearXMPDeviceSettings)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPDeviceSettings Class : Rows Property
Gets or sets the number of display rows.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPDeviceSettings
Dim value As ImGearXMPInteger

instance.Rows = value

value = instance.Rows
public ImGearXMPInteger Rows {get; set;}
public: __property ImGearXMPInteger* get_Rows();
public: __property void set_Rows(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Rows {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


Settings Property (ImGearXMPDeviceSettings)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPDeviceSettings Class : Settings Property
Gets or sets camera settings, in order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Settings As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearXMPDeviceSettings
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.Settings = value

value = instance.Settings
public ImGearXMPSeq<ImGearXMPString> Settings {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_Settings();
public: __property void set_Settings(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ Settings {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

ImGearXMPFlash Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPFlash Class
Represents an XMP Flash structure.
Object Model
ImGearXMPFlash ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPBoolean Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPFlash
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPFlash
public class ImGearXMPFlash : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPFlash : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPFlash : public ImageGear.Formats.XMP.ImGearXMPStructure
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.EXIF.ImGearXMPFlash

See Also

Reference

ImGearXMPFlash Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPFlash Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPFlash Class

The following tables list the members exposed by ImGearXMPFlash.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPFlash Constructor | Initializes a new instance of the ImGearXMPFlash class.
Top
Public Properties
 | Name | Description
Public Property | Fired | Gets or sets flag if flash has fired.
Public Property | Function | Gets or sets if flash function is present. True means that flash function is NOT present.
Public Property | Mode | Gets or sets the flash mode.
Public Property | RedEyeMode | Gets or sets if red-eye reduction is supported.
Public Property | Return | Gets or sets whether strobe return is supported and if supported, detected.
Top
See Also

Reference

ImGearXMPFlash Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPFlash Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : ImGearXMPFlash Constructor
Initializes a new instance of the ImGearXMPFlash class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPFlash()
public ImGearXMPFlash()
public: ImGearXMPFlash();
public:
ImGearXMPFlash();

Return Value

New instance of ImGearXMPFlash class object.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%% $$Properties$$

ImGearXMPFlash Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPFlash Class

For a list of all members of this type, see ImGearXMPFlash members.

Public Properties
 | Name | Description
Public Property | Fired | Gets or sets flag if flash has fired.
Public Property | Function | Gets or sets if flash function is present. True means that flash function is NOT present.
Public Property | Mode | Gets or sets the flash mode.
Public Property | RedEyeMode | Gets or sets if red-eye reduction is supported.
Public Property | Return | Gets or sets whether strobe return is supported and if supported, detected.
Top
See Also

Reference

ImGearXMPFlash Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPFlash Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : ImGearXMPFlash Constructor
Overload List
Overload | Description
ImGearXMPFlash Constructor | Initializes a new instance of the ImGearXMPFlash class.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


Fired Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : Fired Property
Gets or sets flag if flash has fired.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fired As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPFlash
Dim value As ImGearXMPBoolean

instance.Fired = value

value = instance.Fired
public ImGearXMPBoolean Fired {get; set;}
public: __property ImGearXMPBoolean* get_Fired();
public: __property void set_Fired(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Fired {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


Function Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : Function Property
Gets or sets if flash function is present. True means that flash function is NOT present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Function As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPFlash
Dim value As ImGearXMPBoolean

instance.Function = value

value = instance.Function
public ImGearXMPBoolean Function {get; set;}
public: __property ImGearXMPBoolean* get_Function();
public: __property void set_Function(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Function {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


Mode Property (ImGearXMPFlash)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : Mode Property
Gets or sets the flash mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As ImGearXMPEnum(Of ImGearEXIFFlashMode)
'Usage

Dim instance As ImGearXMPFlash
Dim value As ImGearXMPEnum(Of ImGearEXIFFlashMode)

instance.Mode = value

value = instance.Mode
public ImGearXMPEnum<ImGearEXIFFlashMode> Mode {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFFlashMode>* get_Mode();
public: __property void set_Mode(
   ImGearXMPEnum<ImGearEXIFFlashMode>* value
);
public:
property ImGearXMPEnum<ImGearEXIFFlashMode>^ Mode {
   ImGearXMPEnum<ImGearEXIFFlashMode>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFFlashMode>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFFlashMode type parameter.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


RedEyeMode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : RedEyeMode Property
Gets or sets if red-eye reduction is supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedEyeMode As ImGearXMPBoolean
'Usage

Dim instance As ImGearXMPFlash
Dim value As ImGearXMPBoolean

instance.RedEyeMode = value

value = instance.RedEyeMode
public ImGearXMPBoolean RedEyeMode {get; set;}
public: __property ImGearXMPBoolean* get_RedEyeMode();
public: __property void set_RedEyeMode(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ RedEyeMode {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


Return Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPFlash Class : Return Property
Gets or sets whether strobe return is supported and if supported, detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Return As ImGearXMPEnum(Of ImGearEXIFFlashReturn)
'Usage

Dim instance As ImGearXMPFlash
Dim value As ImGearXMPEnum(Of ImGearEXIFFlashReturn)

instance.Return = value

value = instance.Return
public ImGearXMPEnum<ImGearEXIFFlashReturn> Return {get; set;}
public: __property ImGearXMPEnum<ImGearEXIFFlashReturn>* get_Return();
public: __property void set_Return(
   ImGearXMPEnum<ImGearEXIFFlashReturn>* value
);
public:
property ImGearXMPEnum<ImGearEXIFFlashReturn>^ Return {
   ImGearXMPEnum<ImGearEXIFFlashReturn>^ get();
   void set (    ImGearXMPEnum<ImGearEXIFFlashReturn>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.EXIF.ImGearEXIFFlashReturn type parameter.
See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

ImGearXMPGPSCoordinate Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPGPSCoordinate Class
Represents an XMP GPSCoordinate structure.
Object Model
ImGearXMPGPSCoordinate ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPGPSCoordinate
   Inherits ImageGear.Formats.XMP.ImGearXMPValue
'Usage

Dim instance As ImGearXMPGPSCoordinate
public class ImGearXMPGPSCoordinate : ImageGear.Formats.XMP.ImGearXMPValue
public __gc class ImGearXMPGPSCoordinate : public ImageGear.Formats.XMP.ImGearXMPValue
public ref class ImGearXMPGPSCoordinate : public ImageGear.Formats.XMP.ImGearXMPValue
Remarks
A GPS coordinate in XMP may use either Second or MinuteFraction field, but not both.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.EXIF.ImGearXMPGPSCoordinate

See Also

Reference

ImGearXMPGPSCoordinate Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPGPSCoordinate Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPGPSCoordinate Class

The following tables list the members exposed by ImGearXMPGPSCoordinate.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPGPSCoordinate Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Degree | Gets or sets the Degree of GPS Coordinate.
Public Property | Direction | Gets or sets the Direction of GPS Coordinate.
Public Property | Minute | Gets or sets the Minute of GPS Coordinate.
Public Property | MinuteFraction | Gets or sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the property returns null.
Public Property | Second | Gets or sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the property returns null.
Top
See Also

Reference

ImGearXMPGPSCoordinate Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPGPSCoordinate Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : ImGearXMPGPSCoordinate Constructor
Overload List
Overload | Description
ImGearXMPGPSCoordinate Constructor() | Initializes a new instance of the ImGearXMPGPSCoordinate class.
ImGearXMPGPSCoordinate Constructor(Int32,Int32,Int32,ImGearXMPGPSDirection) | Initializes a new instance of the ImGearXMPGPSCoordinate class.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

ImGearXMPGPSCoordinate Constructor()

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class > ImGearXMPGPSCoordinate Constructor : ImGearXMPGPSCoordinate Constructor()
Initializes a new instance of the ImGearXMPGPSCoordinate class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPGPSCoordinate()
public ImGearXMPGPSCoordinate()
public: ImGearXMPGPSCoordinate();
public:
ImGearXMPGPSCoordinate();

Return Value

New instance of ImGearXMPGPSCoordinate class object.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members
Overload List


%%PageItemTitle%%

ImGearXMPGPSCoordinate Constructor(Int32,Int32,Int32,ImGearXMPGPSDirection)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class > ImGearXMPGPSCoordinate Constructor : ImGearXMPGPSCoordinate Constructor(Int32,Int32,Int32,ImGearXMPGPSDirection)
Degree value.
Minute value.
Second value.
Direction value.
Initializes a new instance of the ImGearXMPGPSCoordinate class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal degree As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal direction As ImGearXMPGPSDirection _
)
'Usage

Dim degree As Integer
Dim minute As Integer
Dim second As Integer
Dim direction As ImGearXMPGPSDirection

Dim instance As New ImGearXMPGPSCoordinate(degree, minute, second, direction)
public ImGearXMPGPSCoordinate(
   int degree,
   int minute,
   int second,
   ImGearXMPGPSDirection direction
)
public: ImGearXMPGPSCoordinate(
   int degree,
   int minute,
   int second,
   ImGearXMPGPSDirection direction
)
public:
ImGearXMPGPSCoordinate(
   int degree,
   int minute,
   int second,
   ImGearXMPGPSDirection direction
)

Parameters

degree
Degree value.
minute
Minute value.
second
Second value.
direction
Direction value.

Return Value

New instance of ImGearXMPGPSCoordinate class object.
Remarks
This constructor creates and initializes an instance of ImGearXMPGPSCoordinate class, using Degree, Minute, Second and Direction.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearXMPGPSCoordinate Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPGPSCoordinate Class

For a list of all members of this type, see ImGearXMPGPSCoordinate members.

Public Properties
 | Name | Description
Public Property | Degree | Gets or sets the Degree of GPS Coordinate.
Public Property | Direction | Gets or sets the Direction of GPS Coordinate.
Public Property | Minute | Gets or sets the Minute of GPS Coordinate.
Public Property | MinuteFraction | Gets or sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the property returns null.
Public Property | Second | Gets or sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the property returns null.
Top
See Also

Reference

ImGearXMPGPSCoordinate Class
ImageGear.Formats.XMP.EXIF Namespace


Degree Property (ImGearXMPGPSCoordinate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : Degree Property
Gets or sets the Degree of GPS Coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Degree As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPGPSCoordinate
Dim value As ImGearXMPInteger

instance.Degree = value

value = instance.Degree
public ImGearXMPInteger Degree {get; set;}
public: __property ImGearXMPInteger* get_Degree();
public: __property void set_Degree(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Degree {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


Direction Property (ImGearXMPGPSCoordinate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : Direction Property
Gets or sets the Direction of GPS Coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As ImGearXMPEnum(Of ImGearXMPGPSDirection)
'Usage

Dim instance As ImGearXMPGPSCoordinate
Dim value As ImGearXMPEnum(Of ImGearXMPGPSDirection)

instance.Direction = value

value = instance.Direction
public ImGearXMPEnum<ImGearXMPGPSDirection> Direction {get; set;}
public: __property ImGearXMPEnum<ImGearXMPGPSDirection>* get_Direction();
public: __property void set_Direction(
   ImGearXMPEnum<ImGearXMPGPSDirection>* value
);
public:
property ImGearXMPEnum<ImGearXMPGPSDirection>^ Direction {
   ImGearXMPEnum<ImGearXMPGPSDirection>^ get();
   void set (    ImGearXMPEnum<ImGearXMPGPSDirection>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImGearXMPGPSDirection type parameter.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


Minute Property (ImGearXMPGPSCoordinate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : Minute Property
Gets or sets the Minute of GPS Coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Minute As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPGPSCoordinate
Dim value As ImGearXMPInteger

instance.Minute = value

value = instance.Minute
public ImGearXMPInteger Minute {get; set;}
public: __property ImGearXMPInteger* get_Minute();
public: __property void set_Minute(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Minute {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


MinuteFraction Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : MinuteFraction Property
Gets or sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the property returns null.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinuteFraction As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPGPSCoordinate
Dim value As ImGearXMPInteger

instance.MinuteFraction = value

value = instance.MinuteFraction
public ImGearXMPInteger MinuteFraction {get; set;}
public: __property ImGearXMPInteger* get_MinuteFraction();
public: __property void set_MinuteFraction(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ MinuteFraction {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


Second Property (ImGearXMPGPSCoordinate)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPGPSCoordinate Class : Second Property
Gets or sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the property returns null.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Second As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPGPSCoordinate
Dim value As ImGearXMPInteger

instance.Second = value

value = instance.Second
public ImGearXMPInteger Second {get; set;}
public: __property ImGearXMPInteger* get_Second();
public: __property void set_Second(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Second {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

ImGearXMPOECFSFR Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPOECFSFR Class
Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.
Object Model
ImGearXMPOECFSFR ClassImGearXMPInteger ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPOECFSFR
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPOECFSFR
public class ImGearXMPOECFSFR : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPOECFSFR : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPOECFSFR : public ImageGear.Formats.XMP.ImGearXMPStructure
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.EXIF.ImGearXMPOECFSFR

See Also

Reference

ImGearXMPOECFSFR Members
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPOECFSFR Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPOECFSFR Class

The following tables list the members exposed by ImGearXMPOECFSFR.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPOECFSFR Constructor | Initializes a new instance of the ImGearXMPOECFSFR class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns.
Public Property | Names | Gets or sets column item names.
Public Property | Rows | Gets or sets the number of rows.
Public Property | Values | Gets or sets OECF/SFR values.
Top
See Also

Reference

ImGearXMPOECFSFR Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPOECFSFR Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : ImGearXMPOECFSFR Constructor
Initializes a new instance of the ImGearXMPOECFSFR class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPOECFSFR()
public ImGearXMPOECFSFR()
public: ImGearXMPOECFSFR();
public:
ImGearXMPOECFSFR();

Return Value

New instance of ImGearXMPOECFSFR class object.
See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%% $$Properties$$

ImGearXMPOECFSFR Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPOECFSFR Class

For a list of all members of this type, see ImGearXMPOECFSFR members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns.
Public Property | Names | Gets or sets column item names.
Public Property | Rows | Gets or sets the number of rows.
Public Property | Values | Gets or sets OECF/SFR values.
Top
See Also

Reference

ImGearXMPOECFSFR Class
ImageGear.Formats.XMP.EXIF Namespace


%%PageItemTitle%%

ImGearXMPOECFSFR Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : ImGearXMPOECFSFR Constructor
Overload List
Overload | Description
ImGearXMPOECFSFR Constructor | Initializes a new instance of the ImGearXMPOECFSFR class.
See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


Columns Property (ImGearXMPOECFSFR)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : Columns Property
Gets or sets the number of columns.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPOECFSFR
Dim value As ImGearXMPInteger

instance.Columns = value

value = instance.Columns
public ImGearXMPInteger Columns {get; set;}
public: __property ImGearXMPInteger* get_Columns();
public: __property void set_Columns(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Columns {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


Names Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : Names Property
Gets or sets column item names.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Names As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearXMPOECFSFR
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.Names = value

value = instance.Names
public ImGearXMPSeq<ImGearXMPString> Names {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_Names();
public: __property void set_Names(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ Names {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


Rows Property (ImGearXMPOECFSFR)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : Rows Property
Gets or sets the number of rows.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As ImGearXMPInteger
'Usage

Dim instance As ImGearXMPOECFSFR
Dim value As ImGearXMPInteger

instance.Rows = value

value = instance.Rows
public ImGearXMPInteger Rows {get; set;}
public: __property ImGearXMPInteger* get_Rows();
public: __property void set_Rows(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Rows {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


Values Property (ImGearXMPOECFSFR)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace > ImGearXMPOECFSFR Class : Values Property
Gets or sets OECF/SFR values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Values As ImGearXMPSeq(Of ImGearXMPRational)
'Usage

Dim instance As ImGearXMPOECFSFR
Dim value As ImGearXMPSeq(Of ImGearXMPRational)

instance.Values = value

value = instance.Values
public ImGearXMPSeq<ImGearXMPRational> Values {get; set;}
public: __property ImGearXMPSeq<ImGearXMPRational*>* get_Values();
public: __property void set_Values(
   ImGearXMPSeq<ImGearXMPRational*>* value
);
public:
property ImGearXMPSeq<ImGearXMPRational^>^ Values {
   ImGearXMPSeq<ImGearXMPRational^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPRational^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPRational type parameter.
Remarks
OECF/SFR values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

ImGearXMPGPSDirection Enumeration

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIF Namespace : ImGearXMPGPSDirection Enumeration
Represents GPS directions, used in the EXIF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXMPGPSDirection
   Inherits System.Enum
'Usage

Dim instance As ImGearXMPGPSDirection
public enum ImGearXMPGPSDirection : System.Enum
__value public enum ImGearXMPGPSDirection : public System.Enum
public enum class ImGearXMPGPSDirection : public System.Enum
Members
Member | Value | Description
East | 2 | East direction.
North | 0 | North direction.
South | 1 | South direction.
West | 3 | West direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Formats.XMP.EXIF.ImGearXMPGPSDirection

See Also

Reference

ImageGear.Formats.XMP.EXIF Namespace


ImageGear.Formats.XMP.EXIFAux Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.EXIFAux Namespace
This namespace provides the API for XMP.EXIFAux format.
Classes
 | Class | Description
Class | ImGearEXIFAuxXMPMetadata | Provides simplified access to EXIFAux XMP metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.EXIFAux Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.EXIFAux Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearEXIFAuxXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace : ImGearEXIFAuxXMPMetadata Class
Provides simplified access to EXIFAux XMP metadata schema.
Object Model
ImGearEXIFAuxXMPMetadata ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearEXIFAuxXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearEXIFAuxXMPMetadata
public class ImGearEXIFAuxXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearEXIFAuxXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearEXIFAuxXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This class includes additional properties that describe the equipment used to produce EXIF data.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.EXIFAux.ImGearEXIFAuxXMPMetadata

See Also

Reference

ImGearEXIFAuxXMPMetadata Members
ImageGear.Formats.XMP.EXIFAux Namespace


%%PageItemTitle%% $$Members$$

ImGearEXIFAuxXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace : ImGearEXIFAuxXMPMetadata Class

The following tables list the members exposed by ImGearEXIFAuxXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearEXIFAuxXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFAuxXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Lens | Gets or sets Lens property of the EXIF Aux XMP schema.
Public Property | SerialNumber | Gets or sets SerialNumber property of the EXIF Aux XMP schema.
Top
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImageGear.Formats.XMP.EXIFAux Namespace


%%PageItemTitle%%

ImGearEXIFAuxXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace > ImGearEXIFAuxXMPMetadata Class : ImGearEXIFAuxXMPMetadata Constructor
Initializes a new instance of the ImGearEXIFAuxXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEXIFAuxXMPMetadata()
public ImGearEXIFAuxXMPMetadata()
public: ImGearEXIFAuxXMPMetadata();
public:
ImGearEXIFAuxXMPMetadata();

Return Value

New instance of ImGearEXIFAuxXMPMetadata class object.
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearEXIFAuxXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace : ImGearEXIFAuxXMPMetadata Class

For a list of all members of this type, see ImGearEXIFAuxXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Lens | Gets or sets Lens property of the EXIF Aux XMP schema.
Public Property | SerialNumber | Gets or sets SerialNumber property of the EXIF Aux XMP schema.
Top
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImageGear.Formats.XMP.EXIFAux Namespace


%%PageItemTitle%%

ImGearEXIFAuxXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace > ImGearEXIFAuxXMPMetadata Class : ImGearEXIFAuxXMPMetadata Constructor
Overload List
Overload | Description
ImGearEXIFAuxXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFAuxXMPMetadata class.
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


Lens Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace > ImGearEXIFAuxXMPMetadata Class : Lens Property
Gets or sets Lens property of the EXIF Aux XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Lens As ImGearXMPString
'Usage

Dim instance As ImGearEXIFAuxXMPMetadata
Dim value As ImGearXMPString

instance.Lens = value

value = instance.Lens
public ImGearXMPString Lens {get; set;}
public: __property ImGearXMPString* get_Lens();
public: __property void set_Lens(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Lens {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


SerialNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.EXIFAux Namespace > ImGearEXIFAuxXMPMetadata Class : SerialNumber Property
Gets or sets SerialNumber property of the EXIF Aux XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SerialNumber As ImGearXMPString
'Usage

Dim instance As ImGearEXIFAuxXMPMetadata
Dim value As ImGearXMPString

instance.SerialNumber = value

value = instance.SerialNumber
public ImGearXMPString SerialNumber {get; set;}
public: __property ImGearXMPString* get_SerialNumber();
public: __property void set_SerialNumber(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ SerialNumber {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents serial number of the camera or camera body used to take the photograph.
See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


ImageGear.Formats.XMP.IPTC Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.IPTC Namespace
This namespace provides the API for XMP.IPTC format.
Classes
 | Class | Description
Class | ImGearIPTC4XMPCoreMetadata | Provides simplified access to IPTC4XMPCore XMP metadata schema.
Class | ImGearXMPContactInfo | Represents an XMP ContactInfo structure.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.IPTC Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.IPTC Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.IPTC.ImGearXMPContactInfo
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearIPTC4XMPCoreMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearIPTC4XMPCoreMetadata Class
Provides simplified access to IPTC4XMPCore XMP metadata schema.
Object Model
ImGearIPTC4XMPCoreMetadata ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPContactInfo ClassImGearXMPDate ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPLangAlt Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearIPTC4XMPCoreMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
public class ImGearIPTC4XMPCoreMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearIPTC4XMPCoreMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearIPTC4XMPCoreMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This class includes additional properties that describe the equipment used to produce EXIF data.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.IPTC.ImGearIPTC4XMPCoreMetadata

See Also

Reference

ImGearIPTC4XMPCoreMetadata Members
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearIPTC4XMPCoreMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearIPTC4XMPCoreMetadata Class

The following tables list the members exposed by ImGearIPTC4XMPCoreMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearIPTC4XMPCoreMetadata Constructor | Initializes a new instance of the ImGearIPTC4XMPCoreMetadata class.
Top
Public Properties
 | Name | Description
Public Property | City | Gets or sets City property of the IPTC4XMPCORE XMP schema.
Public Property | CopyrightNotice | Gets or sets CopyrightNotice property of the IPTC4XMPCORE XMP schema.
Public Property | Country | Gets or sets Country property of the IPTC4XMPCORE XMP schema.
Public Property | CountryCode | Gets or sets CountryCode property of the IPTC4XMPCORE XMP schema.
Public Property | Creator | Gets or sets Creator property of the IPTC4XMPCORE XMP schema.
Public Property | CreatorContactInfo | Gets or sets CreatorContactInfo property of the IPTC4XMPCORE XMP schema.
Public Property | DateCreated | Gets or sets DateCreated property of the IPTC4XMPCORE XMP schema.
Public Property | Description | Gets or sets Description property of the IPTC4XMPCORE XMP schema.
Public Property | DescriptionWriter | Gets or sets DescriptionWriter property of the IPTC4XMPCORE XMP schema.
Public Property | HeadLine | Gets or sets HeadLine property of the IPTC4XMPCORE XMP schema.
Public Property | Instructions | Gets or sets Instructions property of the IPTC4XMPCORE XMP schema.
Public Property | IntellectualGenre | Gets or sets IntellectualGenre property of the IPTC4XMPCORE XMP schema.
Public Property | JobID | Gets or sets JobID property of the IPTC4XMPCORE XMP schema.
Public Property | JobTitle | Gets or sets CreatorJobtitle property of the IPTC4XMPCORE XMP schema.
Public Property | Keywords | Gets or sets Keywords property of the IPTC4XMPCORE XMP schema.
Public Property | Location | Gets or sets Location property of the IPTC4XMPCORE XMP schema.
Public Property | Provider | Gets or sets Provider property of the IPTC4XMPCORE XMP schema.
Public Property | ProvinceState | Gets or sets Province-State property of the IPTC4XMPCORE XMP schema.
Public Property | RightsUsageTerms | Gets or sets RightsUsageTerms property of the IPTC4XMPCORE XMP schema.
Public Property | Scene2 | Gets or sets Scene property of the IPTC4XMPCORE XMP schema.
Public Property | Source | Gets or sets Source property of the IPTC4XMPCORE XMP schema.
Public Property | SubjectCode | Gets or sets SubjectCode property of the IPTC4XMPCORE XMP schema.
Public Property | Title | Gets or sets Title property of the IPTC4XMPCORE XMP schema.
Top
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%%

ImGearIPTC4XMPCoreMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : ImGearIPTC4XMPCoreMetadata Constructor
Initializes a new instance of the ImGearIPTC4XMPCoreMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearIPTC4XMPCoreMetadata()
public ImGearIPTC4XMPCoreMetadata()
public: ImGearIPTC4XMPCoreMetadata();
public:
ImGearIPTC4XMPCoreMetadata();

Return Value

New instance of ImGearIPTC4XMPCoreMetadata class object.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearIPTC4XMPCoreMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearIPTC4XMPCoreMetadata Class

For a list of all members of this type, see ImGearIPTC4XMPCoreMetadata members.

Public Properties
 | Name | Description
Public Property | City | Gets or sets City property of the IPTC4XMPCORE XMP schema.
Public Property | CopyrightNotice | Gets or sets CopyrightNotice property of the IPTC4XMPCORE XMP schema.
Public Property | Country | Gets or sets Country property of the IPTC4XMPCORE XMP schema.
Public Property | CountryCode | Gets or sets CountryCode property of the IPTC4XMPCORE XMP schema.
Public Property | Creator | Gets or sets Creator property of the IPTC4XMPCORE XMP schema.
Public Property | CreatorContactInfo | Gets or sets CreatorContactInfo property of the IPTC4XMPCORE XMP schema.
Public Property | DateCreated | Gets or sets DateCreated property of the IPTC4XMPCORE XMP schema.
Public Property | Description | Gets or sets Description property of the IPTC4XMPCORE XMP schema.
Public Property | DescriptionWriter | Gets or sets DescriptionWriter property of the IPTC4XMPCORE XMP schema.
Public Property | HeadLine | Gets or sets HeadLine property of the IPTC4XMPCORE XMP schema.
Public Property | Instructions | Gets or sets Instructions property of the IPTC4XMPCORE XMP schema.
Public Property | IntellectualGenre | Gets or sets IntellectualGenre property of the IPTC4XMPCORE XMP schema.
Public Property | JobID | Gets or sets JobID property of the IPTC4XMPCORE XMP schema.
Public Property | JobTitle | Gets or sets CreatorJobtitle property of the IPTC4XMPCORE XMP schema.
Public Property | Keywords | Gets or sets Keywords property of the IPTC4XMPCORE XMP schema.
Public Property | Location | Gets or sets Location property of the IPTC4XMPCORE XMP schema.
Public Property | Provider | Gets or sets Provider property of the IPTC4XMPCORE XMP schema.
Public Property | ProvinceState | Gets or sets Province-State property of the IPTC4XMPCORE XMP schema.
Public Property | RightsUsageTerms | Gets or sets RightsUsageTerms property of the IPTC4XMPCORE XMP schema.
Public Property | Scene2 | Gets or sets Scene property of the IPTC4XMPCORE XMP schema.
Public Property | Source | Gets or sets Source property of the IPTC4XMPCORE XMP schema.
Public Property | SubjectCode | Gets or sets SubjectCode property of the IPTC4XMPCORE XMP schema.
Public Property | Title | Gets or sets Title property of the IPTC4XMPCORE XMP schema.
Top
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%%

ImGearIPTC4XMPCoreMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : ImGearIPTC4XMPCoreMetadata Constructor
Overload List
Overload | Description
ImGearIPTC4XMPCoreMetadata Constructor | Initializes a new instance of the ImGearIPTC4XMPCoreMetadata class.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


City Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : City Property
Gets or sets City property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property City As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.City = value

value = instance.City
public ImGearXMPString City {get; set;}
public: __property ImGearXMPString* get_City();
public: __property void set_City(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ City {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


CopyrightNotice Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : CopyrightNotice Property
Gets or sets CopyrightNotice property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CopyrightNotice As ImGearXMPLangAlt
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPLangAlt

instance.CopyrightNotice = value

value = instance.CopyrightNotice
public ImGearXMPLangAlt CopyrightNotice {get; set;}
public: __property ImGearXMPLangAlt* get_CopyrightNotice();
public: __property void set_CopyrightNotice(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ CopyrightNotice {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP property (dc:rights) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Country Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Country Property
Gets or sets Country property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Country As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.Country = value

value = instance.Country
public ImGearXMPString Country {get; set;}
public: __property ImGearXMPString* get_Country();
public: __property void set_Country(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Country {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


CountryCode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : CountryCode Property
Gets or sets CountryCode property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CountryCode As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.CountryCode = value

value = instance.CountryCode
public ImGearXMPString CountryCode {get; set;}
public: __property ImGearXMPString* get_CountryCode();
public: __property void set_CountryCode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CountryCode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Creator Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Creator Property
Gets or sets Creator property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Creator As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.Creator = value

value = instance.Creator
public ImGearXMPSeq<ImGearXMPString> Creator {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_Creator();
public: __property void set_Creator(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ Creator {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP property dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


CreatorContactInfo Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : CreatorContactInfo Property
Gets or sets CreatorContactInfo property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorContactInfo As ImGearXMPContactInfo
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPContactInfo

instance.CreatorContactInfo = value

value = instance.CreatorContactInfo
public ImGearXMPContactInfo CreatorContactInfo {get; set;}
public: __property ImGearXMPContactInfo* get_CreatorContactInfo();
public: __property void set_CreatorContactInfo(
   ImGearXMPContactInfo* value
);
public:
property ImGearXMPContactInfo^ CreatorContactInfo {
   ImGearXMPContactInfo^ get();
   void set (    ImGearXMPContactInfo^ value);
}

Property Value

ImGearXMPContactInfo class value.
Remarks
This XMP property provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-properties for proper addressing.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


DateCreated Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : DateCreated Property
Gets or sets DateCreated property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateCreated As ImGearXMPDate
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPDate

instance.DateCreated = value

value = instance.DateCreated
public ImGearXMPDate DateCreated {get; set;}
public: __property ImGearXMPDate* get_DateCreated();
public: __property void set_DateCreated(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateCreated {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Description Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Description Property
Gets or sets Description property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As ImGearXMPLangAlt
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPLangAlt

instance.Description = value

value = instance.Description
public ImGearXMPLangAlt Description {get; set;}
public: __property ImGearXMPLangAlt* get_Description();
public: __property void set_Description(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Description {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP property (dc:description) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


DescriptionWriter Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : DescriptionWriter Property
Gets or sets DescriptionWriter property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DescriptionWriter As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.DescriptionWriter = value

value = instance.DescriptionWriter
public ImGearXMPString DescriptionWriter {get; set;}
public: __property ImGearXMPString* get_DescriptionWriter();
public: __property void set_DescriptionWriter(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ DescriptionWriter {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


HeadLine Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : HeadLine Property
Gets or sets HeadLine property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HeadLine As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.HeadLine = value

value = instance.HeadLine
public ImGearXMPString HeadLine {get; set;}
public: __property ImGearXMPString* get_HeadLine();
public: __property void set_HeadLine(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ HeadLine {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Instructions Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Instructions Property
Gets or sets Instructions property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Instructions As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.Instructions = value

value = instance.Instructions
public ImGearXMPString Instructions {get; set;}
public: __property ImGearXMPString* get_Instructions();
public: __property void set_Instructions(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Instructions {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


IntellectualGenre Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : IntellectualGenre Property
Gets or sets IntellectualGenre property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IntellectualGenre As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.IntellectualGenre = value

value = instance.IntellectualGenre
public ImGearXMPString IntellectualGenre {get; set;}
public: __property ImGearXMPString* get_IntellectualGenre();
public: __property void set_IntellectualGenre(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ IntellectualGenre {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This property replaces ImGearIPTC4XMPCoreMetadata.IntellectuakGenre property which has been deprecated due to a misspelled name.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


JobID Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : JobID Property
Gets or sets JobID property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JobID As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.JobID = value

value = instance.JobID
public ImGearXMPString JobID {get; set;}
public: __property ImGearXMPString* get_JobID();
public: __property void set_JobID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ JobID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


JobTitle Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : JobTitle Property
Gets or sets CreatorJobtitle property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JobTitle As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.JobTitle = value

value = instance.JobTitle
public ImGearXMPString JobTitle {get; set;}
public: __property ImGearXMPString* get_JobTitle();
public: __property void set_JobTitle(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ JobTitle {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Keywords Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Keywords Property
Gets or sets Keywords property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Keywords As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Keywords = value

value = instance.Keywords
public ImGearXMPBag<ImGearXMPString> Keywords {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Keywords();
public: __property void set_Keywords(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Keywords {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Location Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Location Property
Gets or sets Location property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.Location = value

value = instance.Location
public ImGearXMPString Location {get; set;}
public: __property ImGearXMPString* get_Location();
public: __property void set_Location(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Location {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Provider Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Provider Property
Gets or sets Provider property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Provider As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.Provider = value

value = instance.Provider
public ImGearXMPString Provider {get; set;}
public: __property ImGearXMPString* get_Provider();
public: __property void set_Provider(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Provider {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property identifies the provider of the news object, who is not necessarily the owner/creator.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


ProvinceState Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : ProvinceState Property
Gets or sets Province-State property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProvinceState As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.ProvinceState = value

value = instance.ProvinceState
public ImGearXMPString ProvinceState {get; set;}
public: __property ImGearXMPString* get_ProvinceState();
public: __property void set_ProvinceState(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ProvinceState {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


RightsUsageTerms Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : RightsUsageTerms Property
Gets or sets RightsUsageTerms property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightsUsageTerms As ImGearXMPLangAlt
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPLangAlt

instance.RightsUsageTerms = value

value = instance.RightsUsageTerms
public ImGearXMPLangAlt RightsUsageTerms {get; set;}
public: __property ImGearXMPLangAlt* get_RightsUsageTerms();
public: __property void set_RightsUsageTerms(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ RightsUsageTerms {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property is a free text instructions on how this news object can be legally used.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Scene2 Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Scene2 Property
Gets or sets Scene property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Scene2 As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.Scene2 = value

value = instance.Scene2
public ImGearXMPBag<ImGearXMPString> Scene2 {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_Scene2();
public: __property void set_Scene2(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ Scene2 {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
Remarks
This XMP property describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Source Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Source Property
Gets or sets Source property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Source As ImGearXMPString
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPString

instance.Source = value

value = instance.Source
public ImGearXMPString Source {get; set;}
public: __property ImGearXMPString* get_Source();
public: __property void set_Source(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Source {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this property should never be changed or deleted after the information is entered following the news object's inital creation.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


SubjectCode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : SubjectCode Property
Gets or sets SubjectCode property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubjectCode As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.SubjectCode = value

value = instance.SubjectCode
public ImGearXMPBag<ImGearXMPString> SubjectCode {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_SubjectCode();
public: __property void set_SubjectCode(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ SubjectCode {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.
See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


Title Property (ImGearIPTC4XMPCoreMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearIPTC4XMPCoreMetadata Class : Title Property
Gets or sets Title property of the IPTC4XMPCORE XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As ImGearXMPLangAlt
'Usage

Dim instance As ImGearIPTC4XMPCoreMetadata
Dim value As ImGearXMPLangAlt

instance.Title = value

value = instance.Title
public ImGearXMPLangAlt Title {get; set;}
public: __property ImGearXMPLangAlt* get_Title();
public: __property void set_Title(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Title {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP property (dc:title) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

ImGearXMPContactInfo Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearXMPContactInfo Class
Represents an XMP ContactInfo structure.
Object Model
ImGearXMPContactInfo ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPContactInfo
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPContactInfo
public class ImGearXMPContactInfo : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPContactInfo : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPContactInfo : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
This structure provides a basic set of information to get in contact with a person.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.IPTC.ImGearXMPContactInfo

See Also

Reference

ImGearXMPContactInfo Members
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPContactInfo Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearXMPContactInfo Class

The following tables list the members exposed by ImGearXMPContactInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPContactInfo Constructor | Initializes a new instance of the ImGearXMPContactInfo class.
Top
Public Properties
 | Name | Description
Public Property | CiAdrCity | Gets or sets the contact information city part.
Public Property | CiAdrCtry | Gets or sets the the contact information county part.
Public Property | CiAdrExtadr | Gets or sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
Public Property | CiAdrPcode | Gets or sets the contact information part denoting the local postal code.
Public Property | CiAdrRegion | Gets or sets the contact information part denoting regional information like state or province.
Public Property | CiEmailWork | Gets or sets the contact information email address part. Multiple email addresses can be given, separated by a comma.
Public Property | CiTelWork | Gets or sets the contact information phone number part. Multiple numbers can be given, separated by a comma.
Public Property | CiURLWork | Gets or sets the contact information web address part. Multiple addresses can be given, separated by a comma.
Top
See Also

Reference

ImGearXMPContactInfo Class
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%%

ImGearXMPContactInfo Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : ImGearXMPContactInfo Constructor
Initializes a new instance of the ImGearXMPContactInfo class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPContactInfo()
public ImGearXMPContactInfo()
public: ImGearXMPContactInfo();
public:
ImGearXMPContactInfo();

Return Value

New instance of ImGearXMPContactInfo class object.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%% $$Properties$$

ImGearXMPContactInfo Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace : ImGearXMPContactInfo Class

For a list of all members of this type, see ImGearXMPContactInfo members.

Public Properties
 | Name | Description
Public Property | CiAdrCity | Gets or sets the contact information city part.
Public Property | CiAdrCtry | Gets or sets the the contact information county part.
Public Property | CiAdrExtadr | Gets or sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
Public Property | CiAdrPcode | Gets or sets the contact information part denoting the local postal code.
Public Property | CiAdrRegion | Gets or sets the contact information part denoting regional information like state or province.
Public Property | CiEmailWork | Gets or sets the contact information email address part. Multiple email addresses can be given, separated by a comma.
Public Property | CiTelWork | Gets or sets the contact information phone number part. Multiple numbers can be given, separated by a comma.
Public Property | CiURLWork | Gets or sets the contact information web address part. Multiple addresses can be given, separated by a comma.
Top
See Also

Reference

ImGearXMPContactInfo Class
ImageGear.Formats.XMP.IPTC Namespace


%%PageItemTitle%%

ImGearXMPContactInfo Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : ImGearXMPContactInfo Constructor
Overload List
Overload | Description
ImGearXMPContactInfo Constructor | Initializes a new instance of the ImGearXMPContactInfo class.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiAdrCity Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiAdrCity Property
Gets or sets the contact information city part.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiAdrCity As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiAdrCity = value

value = instance.CiAdrCity
public ImGearXMPString CiAdrCity {get; set;}
public: __property ImGearXMPString* get_CiAdrCity();
public: __property void set_CiAdrCity(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiAdrCity {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiAdrCtry Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiAdrCtry Property
Gets or sets the the contact information county part.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiAdrCtry As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiAdrCtry = value

value = instance.CiAdrCtry
public ImGearXMPString CiAdrCtry {get; set;}
public: __property ImGearXMPString* get_CiAdrCtry();
public: __property void set_CiAdrCtry(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiAdrCtry {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiAdrExtadr Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiAdrExtadr Property
Gets or sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiAdrExtadr As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiAdrExtadr = value

value = instance.CiAdrExtadr
public ImGearXMPString CiAdrExtadr {get; set;}
public: __property ImGearXMPString* get_CiAdrExtadr();
public: __property void set_CiAdrExtadr(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiAdrExtadr {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiAdrPcode Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiAdrPcode Property
Gets or sets the contact information part denoting the local postal code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiAdrPcode As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiAdrPcode = value

value = instance.CiAdrPcode
public ImGearXMPString CiAdrPcode {get; set;}
public: __property ImGearXMPString* get_CiAdrPcode();
public: __property void set_CiAdrPcode(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiAdrPcode {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiAdrRegion Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiAdrRegion Property
Gets or sets the contact information part denoting regional information like state or province.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiAdrRegion As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiAdrRegion = value

value = instance.CiAdrRegion
public ImGearXMPString CiAdrRegion {get; set;}
public: __property ImGearXMPString* get_CiAdrRegion();
public: __property void set_CiAdrRegion(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiAdrRegion {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiEmailWork Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiEmailWork Property
Gets or sets the contact information email address part. Multiple email addresses can be given, separated by a comma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiEmailWork As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiEmailWork = value

value = instance.CiEmailWork
public ImGearXMPString CiEmailWork {get; set;}
public: __property ImGearXMPString* get_CiEmailWork();
public: __property void set_CiEmailWork(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiEmailWork {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiTelWork Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiTelWork Property
Gets or sets the contact information phone number part. Multiple numbers can be given, separated by a comma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiTelWork As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiTelWork = value

value = instance.CiTelWork
public ImGearXMPString CiTelWork {get; set;}
public: __property ImGearXMPString* get_CiTelWork();
public: __property void set_CiTelWork(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiTelWork {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


CiURLWork Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.IPTC Namespace > ImGearXMPContactInfo Class : CiURLWork Property
Gets or sets the contact information web address part. Multiple addresses can be given, separated by a comma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CiURLWork As ImGearXMPString
'Usage

Dim instance As ImGearXMPContactInfo
Dim value As ImGearXMPString

instance.CiURLWork = value

value = instance.CiURLWork
public ImGearXMPString CiURLWork {get; set;}
public: __property ImGearXMPString* get_CiURLWork();
public: __property void set_CiURLWork(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CiURLWork {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


ImageGear.Formats.XMP.MediaManagement Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.MediaManagement Namespace
This namespace provides the API for XMP.MediaManagement format.
Classes
 | Class | Description
Class | ImGearMediaManagementXMPMetadata | Provides simplified access to XMP Media Management metadata schema.
Class | ImGearXMPResourceEvent | Represents an XMP ResourceEvent structure.
Class | ImGearXMPResourceReference | Represents an XMP ResourceRef structure.
Class | ImGearXMPVersion | Represents an XMP Version structure.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.MediaManagement Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.MediaManagement Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceEvent
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceReference
ImageGear.Formats.XMP.MediaManagement.ImGearXMPVersion
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearMediaManagementXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearMediaManagementXMPMetadata Class
Provides simplified access to XMP Media Management metadata schema.
Object Model
ImGearMediaManagementXMPMetadata ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMediaManagementXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
public class ImGearMediaManagementXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearMediaManagementXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearMediaManagementXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This schema is primarily used by digital asset management (DAM) systems.

The following properties are 'owned' by the DAM system and should be set by applications under their direction; they should not be used by unmanaged files: ManagedFrom, Manager, ManageTo, ManageUI, ManagerVariant.

The following properties are owned by the DAM system for managed files, but can also be used by applications for unmanaged files: DerivedFrom, DocumentID, RenditionClass, RenditionParams, VersionID, Versions.

The History property is always owned by the application.

Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.MediaManagement.ImGearMediaManagementXMPMetadata

See Also

Reference

ImGearMediaManagementXMPMetadata Members
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%% $$Members$$

ImGearMediaManagementXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearMediaManagementXMPMetadata Class

The following tables list the members exposed by ImGearMediaManagementXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearMediaManagementXMPMetadata Constructor | Initializes a new instance of the ImGearMediaManagementXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | DerivedFrom | Gets or sets DerivedFrom property of the Media Management XMP schema.
Public Property | DocumentID | Gets or sets DocumentID property of the Media Management XMP schema.
Public Property | History | Gets or sets History property of the Media Management XMP schema.
Public Property | InstanceID | Gets or sets InstanceID property of the Media Management XMP schema.
Public Property | LastURL | Gets or sets LastURL property of the Media Management XMP schema.
Public Property | ManagedFrom | Gets or sets ManagedFrom property of the Media Management XMP schema.
Public Property | Manager | Gets or sets Manager property of the Media Management XMP schema.
Public Property | ManagerVariant | Gets or sets ManagerVariant property of the Media Management XMP schema.
Public Property | ManageTo | Gets or sets ManageTo property of the Media Management XMP schema.
Public Property | ManageUI | Gets or sets ManageUI property of the Media Management XMP schema.
Public Property | RenditionClass | Gets or sets RenditionClass property of the Media Management XMP schema.
Public Property | RenditionOf | Gets or sets RenditionOf property of the Media Management XMP schema.
Public Property | RenditionParams | Gets or sets RenditionParams property of the Media Management XMP schema.
Public Property | SaveID | Gets or sets SaveID property of the Media Management XMP schema.
Public Property | Version | Gets or sets Version property of the Media Management XMP schema.
Public Property | VersionID | Gets or sets VersionID property of the Media Management XMP schema.
Top
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearMediaManagementXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ImGearMediaManagementXMPMetadata Constructor
Initializes a new instance of the ImGearMediaManagementXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMediaManagementXMPMetadata()
public ImGearMediaManagementXMPMetadata()
public: ImGearMediaManagementXMPMetadata();
public:
ImGearMediaManagementXMPMetadata();

Return Value

New instance of ImGearMediaManagementXMPMetadata class object.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearMediaManagementXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearMediaManagementXMPMetadata Class

For a list of all members of this type, see ImGearMediaManagementXMPMetadata members.

Public Properties
 | Name | Description
Public Property | DerivedFrom | Gets or sets DerivedFrom property of the Media Management XMP schema.
Public Property | DocumentID | Gets or sets DocumentID property of the Media Management XMP schema.
Public Property | History | Gets or sets History property of the Media Management XMP schema.
Public Property | InstanceID | Gets or sets InstanceID property of the Media Management XMP schema.
Public Property | LastURL | Gets or sets LastURL property of the Media Management XMP schema.
Public Property | ManagedFrom | Gets or sets ManagedFrom property of the Media Management XMP schema.
Public Property | Manager | Gets or sets Manager property of the Media Management XMP schema.
Public Property | ManagerVariant | Gets or sets ManagerVariant property of the Media Management XMP schema.
Public Property | ManageTo | Gets or sets ManageTo property of the Media Management XMP schema.
Public Property | ManageUI | Gets or sets ManageUI property of the Media Management XMP schema.
Public Property | RenditionClass | Gets or sets RenditionClass property of the Media Management XMP schema.
Public Property | RenditionOf | Gets or sets RenditionOf property of the Media Management XMP schema.
Public Property | RenditionParams | Gets or sets RenditionParams property of the Media Management XMP schema.
Public Property | SaveID | Gets or sets SaveID property of the Media Management XMP schema.
Public Property | Version | Gets or sets Version property of the Media Management XMP schema.
Public Property | VersionID | Gets or sets VersionID property of the Media Management XMP schema.
Top
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearMediaManagementXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ImGearMediaManagementXMPMetadata Constructor
Overload List
Overload | Description
ImGearMediaManagementXMPMetadata Constructor | Initializes a new instance of the ImGearMediaManagementXMPMetadata class.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


DerivedFrom Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : DerivedFrom Property
Gets or sets DerivedFrom property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DerivedFrom As ImGearXMPResourceReference
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPResourceReference

instance.DerivedFrom = value

value = instance.DerivedFrom
public ImGearXMPResourceReference DerivedFrom {get; set;}
public: __property ImGearXMPResourceReference* get_DerivedFrom();
public: __property void set_DerivedFrom(
   ImGearXMPResourceReference* value
);
public:
property ImGearXMPResourceReference^ DerivedFrom {
   ImGearXMPResourceReference^ get();
   void set (    ImGearXMPResourceReference^ value);
}

Property Value

ImGearXMPResourceReference class value.
Remarks
This property specifies reference to the original document from which this one is derived.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


DocumentID Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : DocumentID Property
Gets or sets DocumentID property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentID As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.DocumentID = value

value = instance.DocumentID
public ImGearXMPString DocumentID {get; set;}
public: __property ImGearXMPString* get_DocumentID();
public: __property void set_DocumentID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ DocumentID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies common identifier for all versions and renditions of a document.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


History Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : History Property
Gets or sets History property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property History As ImGearXMPSeq(Of ImGearXMPResourceEvent)
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPResourceEvent)

instance.History = value

value = instance.History
public ImGearXMPSeq<ImGearXMPResourceEvent> History {get; set;}
public: __property ImGearXMPSeq<ImGearXMPResourceEvent*>* get_History();
public: __property void set_History(
   ImGearXMPSeq<ImGearXMPResourceEvent*>* value
);
public:
property ImGearXMPSeq<ImGearXMPResourceEvent^>^ History {
   ImGearXMPSeq<ImGearXMPResourceEvent^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPResourceEvent^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImGearXMPResourceEvent type parameter.
Remarks
This property specifies ordered array of high-level user actions that resulted in this resource.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


InstanceID Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : InstanceID Property
Gets or sets InstanceID property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InstanceID As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.InstanceID = value

value = instance.InstanceID
public ImGearXMPString InstanceID {get; set;}
public: __property ImGearXMPString* get_InstanceID();
public: __property void set_InstanceID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ InstanceID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies identifier for a specific incarnation of a document, updated each time a file is saved.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


LastURL Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : LastURL Property
Gets or sets LastURL property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LastURL As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.LastURL = value

value = instance.LastURL
public ImGearXMPString LastURL {get; set;}
public: __property ImGearXMPString* get_LastURL();
public: __property void set_LastURL(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ LastURL {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property is deprecated in XMP specification for privacy protection.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


ManagedFrom Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ManagedFrom Property
Gets or sets ManagedFrom property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManagedFrom As ImGearXMPResourceReference
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPResourceReference

instance.ManagedFrom = value

value = instance.ManagedFrom
public ImGearXMPResourceReference ManagedFrom {get; set;}
public: __property ImGearXMPResourceReference* get_ManagedFrom();
public: __property void set_ManagedFrom(
   ImGearXMPResourceReference* value
);
public:
property ImGearXMPResourceReference^ ManagedFrom {
   ImGearXMPResourceReference^ get();
   void set (    ImGearXMPResourceReference^ value);
}

Property Value

ImGearXMPResourceReference class value.
Remarks
This property specifies reference to the document as it was prior to becoming managed.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


Manager Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : Manager Property
Gets or sets Manager property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Manager As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.Manager = value

value = instance.Manager
public ImGearXMPString Manager {get; set;}
public: __property ImGearXMPString* get_Manager();
public: __property void set_Manager(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Manager {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


ManagerVariant Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ManagerVariant Property
Gets or sets ManagerVariant property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManagerVariant As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.ManagerVariant = value

value = instance.ManagerVariant
public ImGearXMPString ManagerVariant {get; set;}
public: __property ImGearXMPString* get_ManagerVariant();
public: __property void set_ManagerVariant(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManagerVariant {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies a particular variant of the asset management system. The format of this property is private to the specific asset management system.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


ManageTo Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ManageTo Property
Gets or sets ManageTo property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManageTo As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.ManageTo = value

value = instance.ManageTo
public ImGearXMPString ManageTo {get; set;}
public: __property ImGearXMPString* get_ManageTo();
public: __property void set_ManageTo(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManageTo {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


ManageUI Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : ManageUI Property
Gets or sets ManageUI property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManageUI As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.ManageUI = value

value = instance.ManageUI
public ImGearXMPString ManageUI {get; set;}
public: __property ImGearXMPString* get_ManageUI();
public: __property void set_ManageUI(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManageUI {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


RenditionClass Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : RenditionClass Property
Gets or sets RenditionClass property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenditionClass As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.RenditionClass = value

value = instance.RenditionClass
public ImGearXMPString RenditionClass {get; set;}
public: __property ImGearXMPString* get_RenditionClass();
public: __property void set_RenditionClass(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RenditionClass {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies rendition class name for this resource. See XMP specification for more details regarding this property.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


RenditionOf Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : RenditionOf Property
Gets or sets RenditionOf property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenditionOf As ImGearXMPResourceReference
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPResourceReference

instance.RenditionOf = value

value = instance.RenditionOf
public ImGearXMPResourceReference RenditionOf {get; set;}
public: __property ImGearXMPResourceReference* get_RenditionOf();
public: __property void set_RenditionOf(
   ImGearXMPResourceReference* value
);
public:
property ImGearXMPResourceReference^ RenditionOf {
   ImGearXMPResourceReference^ get();
   void set (    ImGearXMPResourceReference^ value);
}

Property Value

ImGearXMPResourceReference class value.
Remarks
This property is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


RenditionParams Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : RenditionParams Property
Gets or sets RenditionParams property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenditionParams As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.RenditionParams = value

value = instance.RenditionParams
public ImGearXMPString RenditionParams {get; set;}
public: __property ImGearXMPString* get_RenditionParams();
public: __property void set_RenditionParams(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RenditionParams {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


SaveID Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : SaveID Property
Gets or sets SaveID property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SaveID As ImGearXMPInteger
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPInteger

instance.SaveID = value

value = instance.SaveID
public ImGearXMPInteger SaveID {get; set;}
public: __property ImGearXMPInteger* get_SaveID();
public: __property void set_SaveID(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ SaveID {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This property is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


Version Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : Version Property
Gets or sets Version property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Version As ImGearXMPSeq(Of ImGearXMPVersion)
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPVersion)

instance.Version = value

value = instance.Version
public ImGearXMPSeq<ImGearXMPVersion> Version {get; set;}
public: __property ImGearXMPSeq<ImGearXMPVersion*>* get_Version();
public: __property void set_Version(
   ImGearXMPSeq<ImGearXMPVersion*>* value
);
public:
property ImGearXMPSeq<ImGearXMPVersion^>^ Version {
   ImGearXMPSeq<ImGearXMPVersion^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPVersion^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImGearXMPVersion type parameter.
Remarks
This property specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


VersionID Property (ImGearMediaManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearMediaManagementXMPMetadata Class : VersionID Property
Gets or sets VersionID property of the Media Management XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VersionID As ImGearXMPString
'Usage

Dim instance As ImGearMediaManagementXMPMetadata
Dim value As ImGearXMPString

instance.VersionID = value

value = instance.VersionID
public ImGearXMPString VersionID {get; set;}
public: __property ImGearXMPString* get_VersionID();
public: __property void set_VersionID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VersionID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This property specifies document version identifier for this resource.
See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

ImGearXMPResourceEvent Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceEvent Class
Represents an XMP ResourceEvent structure.
Object Model
ImGearXMPResourceEvent ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPResourceEvent
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPResourceEvent
public class ImGearXMPResourceEvent : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPResourceEvent : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPResourceEvent : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
The structure specifies a high level event that occurred in the processing of this document.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceEvent

See Also

Reference

ImGearXMPResourceEvent Members
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPResourceEvent Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceEvent Class

The following tables list the members exposed by ImGearXMPResourceEvent.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPResourceEvent Constructor | Initializes a new instance of the ImGearXMPResourceEvent class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action that occurred. See XMP specification for defined values and usage details.
Public Property | InstanceID | Gets or sets the instance ID of the modified resource.
Public Property | Parameters | Gets or sets additional description of the action.
Public Property | SoftwareAgent | Gets or sets the software agent that performed the action.
Public Property | When | Gets or sets optional timestamp of when the action occurred.
Top
See Also

Reference

ImGearXMPResourceEvent Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPResourceEvent Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : ImGearXMPResourceEvent Constructor
Initializes a new instance of the ImGearXMPResourceEvent class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPResourceEvent()
public ImGearXMPResourceEvent()
public: ImGearXMPResourceEvent();
public:
ImGearXMPResourceEvent();

Return Value

New instance of ImGearXMPResourceEvent class object.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%% $$Properties$$

ImGearXMPResourceEvent Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceEvent Class

For a list of all members of this type, see ImGearXMPResourceEvent members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action that occurred. See XMP specification for defined values and usage details.
Public Property | InstanceID | Gets or sets the instance ID of the modified resource.
Public Property | Parameters | Gets or sets additional description of the action.
Public Property | SoftwareAgent | Gets or sets the software agent that performed the action.
Public Property | When | Gets or sets optional timestamp of when the action occurred.
Top
See Also

Reference

ImGearXMPResourceEvent Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPResourceEvent Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : ImGearXMPResourceEvent Constructor
Overload List
Overload | Description
ImGearXMPResourceEvent Constructor | Initializes a new instance of the ImGearXMPResourceEvent class.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


Action Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : Action Property
Gets or sets the action that occurred. See XMP specification for defined values and usage details.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceEvent
Dim value As ImGearXMPString

instance.Action = value

value = instance.Action
public ImGearXMPString Action {get; set;}
public: __property ImGearXMPString* get_Action();
public: __property void set_Action(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Action {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


InstanceID Property (ImGearXMPResourceEvent)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : InstanceID Property
Gets or sets the instance ID of the modified resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InstanceID As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceEvent
Dim value As ImGearXMPString

instance.InstanceID = value

value = instance.InstanceID
public ImGearXMPString InstanceID {get; set;}
public: __property ImGearXMPString* get_InstanceID();
public: __property void set_InstanceID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ InstanceID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


Parameters Property (ImGearXMPResourceEvent)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : Parameters Property
Gets or sets additional description of the action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Parameters As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceEvent
Dim value As ImGearXMPString

instance.Parameters = value

value = instance.Parameters
public ImGearXMPString Parameters {get; set;}
public: __property ImGearXMPString* get_Parameters();
public: __property void set_Parameters(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Parameters {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


SoftwareAgent Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : SoftwareAgent Property
Gets or sets the software agent that performed the action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SoftwareAgent As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceEvent
Dim value As ImGearXMPString

instance.SoftwareAgent = value

value = instance.SoftwareAgent
public ImGearXMPString SoftwareAgent {get; set;}
public: __property ImGearXMPString* get_SoftwareAgent();
public: __property void set_SoftwareAgent(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ SoftwareAgent {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


When Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceEvent Class : When Property
Gets or sets optional timestamp of when the action occurred.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property When As ImGearXMPDate
'Usage

Dim instance As ImGearXMPResourceEvent
Dim value As ImGearXMPDate

instance.When = value

value = instance.When
public ImGearXMPDate When {get; set;}
public: __property ImGearXMPDate* get_When();
public: __property void set_When(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ When {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

ImGearXMPResourceReference Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceReference Class
Represents an XMP ResourceRef structure.
Object Model
ImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPResourceReference
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPResourceReference
public class ImGearXMPResourceReference : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPResourceReference : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPResourceReference : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
The fields present in any specific reference depend on usage and on whether the referenced resource is managed. Except for instanceID, the fields are all properties from the referenced resource's Media Management schema.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.MediaManagement.ImGearXMPResourceReference

See Also

Reference

ImGearXMPResourceReference Members
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPResourceReference Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceReference Class

The following tables list the members exposed by ImGearXMPResourceReference.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPResourceReference Constructor | Initializes a new instance of the ImGearXMPResourceReference class.
Top
Public Properties
 | Name | Description
Public Property | DocumentID | Gets or sets the referenced resource's xmpMM:DocumentID.
Public Property | InstanceID | Gets or sets the referenced resource's instance ID.
Public Property | Manager | Gets or sets the referenced resource's xmpMM:Manager.
Public Property | ManagerVariant | Gets or sets the referenced resource's xmpMM: ManagerVariant.
Public Property | ManageTo | Gets or sets the referenced resource's xmpMM:ManageTo.
Public Property | ManageUI | Gets or sets the referenced resource's xmpMM:ManageUI.
Public Property | RenditionClass | Gets or sets the referenced resource's xmpMM: RenditionClass.
Public Property | RenditionParams | Gets or sets the referenced resource's xmpMM: RenditionParams.
Public Property | VersionID | Gets or sets the referenced resource's xmpMM:VersionID.
Top
See Also

Reference

ImGearXMPResourceReference Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPResourceReference Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : ImGearXMPResourceReference Constructor
Initializes a new instance of the ImGearXMPResourceReference class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPResourceReference()
public ImGearXMPResourceReference()
public: ImGearXMPResourceReference();
public:
ImGearXMPResourceReference();

Return Value

New instance of ImGearXMPResourceReference class object.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%% $$Properties$$

ImGearXMPResourceReference Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPResourceReference Class

For a list of all members of this type, see ImGearXMPResourceReference members.

Public Properties
 | Name | Description
Public Property | DocumentID | Gets or sets the referenced resource's xmpMM:DocumentID.
Public Property | InstanceID | Gets or sets the referenced resource's instance ID.
Public Property | Manager | Gets or sets the referenced resource's xmpMM:Manager.
Public Property | ManagerVariant | Gets or sets the referenced resource's xmpMM: ManagerVariant.
Public Property | ManageTo | Gets or sets the referenced resource's xmpMM:ManageTo.
Public Property | ManageUI | Gets or sets the referenced resource's xmpMM:ManageUI.
Public Property | RenditionClass | Gets or sets the referenced resource's xmpMM: RenditionClass.
Public Property | RenditionParams | Gets or sets the referenced resource's xmpMM: RenditionParams.
Public Property | VersionID | Gets or sets the referenced resource's xmpMM:VersionID.
Top
See Also

Reference

ImGearXMPResourceReference Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPResourceReference Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : ImGearXMPResourceReference Constructor
Overload List
Overload | Description
ImGearXMPResourceReference Constructor | Initializes a new instance of the ImGearXMPResourceReference class.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


DocumentID Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : DocumentID Property
Gets or sets the referenced resource's xmpMM:DocumentID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentID As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.DocumentID = value

value = instance.DocumentID
public ImGearXMPString DocumentID {get; set;}
public: __property ImGearXMPString* get_DocumentID();
public: __property void set_DocumentID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ DocumentID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


InstanceID Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : InstanceID Property
Gets or sets the referenced resource's instance ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InstanceID As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.InstanceID = value

value = instance.InstanceID
public ImGearXMPString InstanceID {get; set;}
public: __property ImGearXMPString* get_InstanceID();
public: __property void set_InstanceID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ InstanceID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


Manager Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : Manager Property
Gets or sets the referenced resource's xmpMM:Manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Manager As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.Manager = value

value = instance.Manager
public ImGearXMPString Manager {get; set;}
public: __property ImGearXMPString* get_Manager();
public: __property void set_Manager(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Manager {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


ManagerVariant Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : ManagerVariant Property
Gets or sets the referenced resource's xmpMM: ManagerVariant.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManagerVariant As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.ManagerVariant = value

value = instance.ManagerVariant
public ImGearXMPString ManagerVariant {get; set;}
public: __property ImGearXMPString* get_ManagerVariant();
public: __property void set_ManagerVariant(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManagerVariant {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


ManageTo Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : ManageTo Property
Gets or sets the referenced resource's xmpMM:ManageTo.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManageTo As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.ManageTo = value

value = instance.ManageTo
public ImGearXMPString ManageTo {get; set;}
public: __property ImGearXMPString* get_ManageTo();
public: __property void set_ManageTo(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManageTo {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


ManageUI Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : ManageUI Property
Gets or sets the referenced resource's xmpMM:ManageUI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ManageUI As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.ManageUI = value

value = instance.ManageUI
public ImGearXMPString ManageUI {get; set;}
public: __property ImGearXMPString* get_ManageUI();
public: __property void set_ManageUI(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ManageUI {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


RenditionClass Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : RenditionClass Property
Gets or sets the referenced resource's xmpMM: RenditionClass.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenditionClass As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.RenditionClass = value

value = instance.RenditionClass
public ImGearXMPString RenditionClass {get; set;}
public: __property ImGearXMPString* get_RenditionClass();
public: __property void set_RenditionClass(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RenditionClass {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


RenditionParams Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : RenditionParams Property
Gets or sets the referenced resource's xmpMM: RenditionParams.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenditionParams As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.RenditionParams = value

value = instance.RenditionParams
public ImGearXMPString RenditionParams {get; set;}
public: __property ImGearXMPString* get_RenditionParams();
public: __property void set_RenditionParams(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ RenditionParams {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


VersionID Property (ImGearXMPResourceReference)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPResourceReference Class : VersionID Property
Gets or sets the referenced resource's xmpMM:VersionID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VersionID As ImGearXMPString
'Usage

Dim instance As ImGearXMPResourceReference
Dim value As ImGearXMPString

instance.VersionID = value

value = instance.VersionID
public ImGearXMPString VersionID {get; set;}
public: __property ImGearXMPString* get_VersionID();
public: __property void set_VersionID(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ VersionID {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

ImGearXMPVersion Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPVersion Class
Represents an XMP Version structure.
Object Model
ImGearXMPVersion ClassImGearXMPString ClassImGearXMPResourceEvent ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXMPVersion
   Inherits ImageGear.Formats.XMP.ImGearXMPStructure
'Usage

Dim instance As ImGearXMPVersion
public class ImGearXMPVersion : ImageGear.Formats.XMP.ImGearXMPStructure
public __gc class ImGearXMPVersion : public ImageGear.Formats.XMP.ImGearXMPStructure
public ref class ImGearXMPVersion : public ImageGear.Formats.XMP.ImGearXMPStructure
Remarks
The structure describes one version of a document.
Inheritance Hierarchy

System.Object
ImageGear.Formats.XMP.ImGearXMPValue
ImageGear.Formats.XMP.ImGearXMPStructure
ImageGear.Formats.XMP.MediaManagement.ImGearXMPVersion

See Also

Reference

ImGearXMPVersion Members
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%% $$Members$$

ImGearXMPVersion Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPVersion Class

The following tables list the members exposed by ImGearXMPVersion.

Public Constructors
 | Name | Description
Public Constructor | ImGearXMPVersion Constructor | Initializes a new instance of the ImGearXMPVersion class.
Top
Public Properties
 | Name | Description
Public Property | Comments | Gets or sets comments concerning what was changed.
Public Property | Event | Gets or sets high level, formal description of what operation the user performed.
Public Property | Modifier | Gets or sets the person who modified this version.
Public Property | ModifyDate | Gets or sets the date on which this version was checked in.
Public Property | Version | Gets or sets the new version number.
Top
See Also

Reference

ImGearXMPVersion Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPVersion Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : ImGearXMPVersion Constructor
Initializes a new instance of the ImGearXMPVersion class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXMPVersion()
public ImGearXMPVersion()
public: ImGearXMPVersion();
public:
ImGearXMPVersion();

Return Value

New instance of ImGearXMPVersion class object.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%% $$Properties$$

ImGearXMPVersion Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace : ImGearXMPVersion Class

For a list of all members of this type, see ImGearXMPVersion members.

Public Properties
 | Name | Description
Public Property | Comments | Gets or sets comments concerning what was changed.
Public Property | Event | Gets or sets high level, formal description of what operation the user performed.
Public Property | Modifier | Gets or sets the person who modified this version.
Public Property | ModifyDate | Gets or sets the date on which this version was checked in.
Public Property | Version | Gets or sets the new version number.
Top
See Also

Reference

ImGearXMPVersion Class
ImageGear.Formats.XMP.MediaManagement Namespace


%%PageItemTitle%%

ImGearXMPVersion Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : ImGearXMPVersion Constructor
Overload List
Overload | Description
ImGearXMPVersion Constructor | Initializes a new instance of the ImGearXMPVersion class.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


Comments Property (ImGearXMPVersion)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : Comments Property
Gets or sets comments concerning what was changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Comments As ImGearXMPString
'Usage

Dim instance As ImGearXMPVersion
Dim value As ImGearXMPString

instance.Comments = value

value = instance.Comments
public ImGearXMPString Comments {get; set;}
public: __property ImGearXMPString* get_Comments();
public: __property void set_Comments(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Comments {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


Event Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : Event Property
Gets or sets high level, formal description of what operation the user performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Event As ImGearXMPResourceEvent
'Usage

Dim instance As ImGearXMPVersion
Dim value As ImGearXMPResourceEvent

instance.Event = value

value = instance.Event
public ImGearXMPResourceEvent Event {get; set;}
public: __property ImGearXMPResourceEvent* get_Event();
public: __property void set_Event(
   ImGearXMPResourceEvent* value
);
public:
property ImGearXMPResourceEvent^ Event {
   ImGearXMPResourceEvent^ get();
   void set (    ImGearXMPResourceEvent^ value);
}

Property Value

ImGearXMPResourceEvent class value.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


Modifier Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : Modifier Property
Gets or sets the person who modified this version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Modifier As ImGearXMPString
'Usage

Dim instance As ImGearXMPVersion
Dim value As ImGearXMPString

instance.Modifier = value

value = instance.Modifier
public ImGearXMPString Modifier {get; set;}
public: __property ImGearXMPString* get_Modifier();
public: __property void set_Modifier(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Modifier {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


ModifyDate Property (ImGearXMPVersion)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : ModifyDate Property
Gets or sets the date on which this version was checked in.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifyDate As ImGearXMPDate
'Usage

Dim instance As ImGearXMPVersion
Dim value As ImGearXMPDate

instance.ModifyDate = value

value = instance.ModifyDate
public ImGearXMPDate ModifyDate {get; set;}
public: __property ImGearXMPDate* get_ModifyDate();
public: __property void set_ModifyDate(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ ModifyDate {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


Version Property (ImGearXMPVersion)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MediaManagement Namespace > ImGearXMPVersion Class : Version Property
Gets or sets the new version number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Version As ImGearXMPString
'Usage

Dim instance As ImGearXMPVersion
Dim value As ImGearXMPString

instance.Version = value

value = instance.Version
public ImGearXMPString Version {get; set;}
public: __property ImGearXMPString* get_Version();
public: __property void set_Version(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Version {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


ImageGear.Formats.XMP.MicrosoftPhoto Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.MicrosoftPhoto Namespace
This namespace provides the API for XMP.MicrosoftPhoto format.
Classes
 | Class | Description
Class | ImGearMicrosoftPhotoXMPMetadata | Provides simplified access to MicrosoftPhoto XMP metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.MicrosoftPhoto Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.MicrosoftPhoto Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.MicrosoftPhoto.ImGearMicrosoftPhotoXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearMicrosoftPhotoXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace : ImGearMicrosoftPhotoXMPMetadata Class
Provides simplified access to MicrosoftPhoto XMP metadata schema.
Object Model
ImGearMicrosoftPhotoXMPMetadata ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMicrosoftPhotoXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
public class ImGearMicrosoftPhotoXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearMicrosoftPhotoXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearMicrosoftPhotoXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.MicrosoftPhoto.ImGearMicrosoftPhotoXMPMetadata

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Members
ImageGear.Formats.XMP.MicrosoftPhoto Namespace


%%PageItemTitle%% $$Members$$

ImGearMicrosoftPhotoXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace : ImGearMicrosoftPhotoXMPMetadata Class

The following tables list the members exposed by ImGearMicrosoftPhotoXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearMicrosoftPhotoXMPMetadata Constructor | Initializes a new instance of the ImGearMicrosoftPhotoXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | CameraSerialNumber | Gets or sets CameraSerialNumber property of the MicrosoftPhoto XMP schema.
Public Property | DateAcquired | Gets or sets DateAcquired property of the MicrosoftPhoto XMP schema.
Public Property | FlashManufacturer | Gets or sets FlashManufacturer property of the MicrosoftPhoto XMP schema.
Public Property | FlashModel | Gets or sets FlashModel property of the MicrosoftPhoto XMP schema.
Public Property | LastKeywordIPTC | Gets or sets LastKeywordIPTC property of the MicrosoftPhoto XMP schema.
Public Property | LastKeywordXMP | Gets or sets LastKeywordXMP property of the MicrosoftPhoto XMP schema.
Public Property | LensManufacturer | Gets or sets LensManufacturer property of the MicrosoftPhoto XMP schema.
Public Property | LensModel | Gets or sets LensModel property of the MicrosoftPhoto XMP schema.
Public Property | Rating | Gets or sets Rating property of the MicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
Top
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImageGear.Formats.XMP.MicrosoftPhoto Namespace


%%PageItemTitle%%

ImGearMicrosoftPhotoXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : ImGearMicrosoftPhotoXMPMetadata Constructor
Initializes a new instance of the ImGearMicrosoftPhotoXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMicrosoftPhotoXMPMetadata()
public ImGearMicrosoftPhotoXMPMetadata()
public: ImGearMicrosoftPhotoXMPMetadata();
public:
ImGearMicrosoftPhotoXMPMetadata();

Return Value

New instance of ImGearMicrosoftPhotoXMPMetadata class object.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearMicrosoftPhotoXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace : ImGearMicrosoftPhotoXMPMetadata Class

For a list of all members of this type, see ImGearMicrosoftPhotoXMPMetadata members.

Public Properties
 | Name | Description
Public Property | CameraSerialNumber | Gets or sets CameraSerialNumber property of the MicrosoftPhoto XMP schema.
Public Property | DateAcquired | Gets or sets DateAcquired property of the MicrosoftPhoto XMP schema.
Public Property | FlashManufacturer | Gets or sets FlashManufacturer property of the MicrosoftPhoto XMP schema.
Public Property | FlashModel | Gets or sets FlashModel property of the MicrosoftPhoto XMP schema.
Public Property | LastKeywordIPTC | Gets or sets LastKeywordIPTC property of the MicrosoftPhoto XMP schema.
Public Property | LastKeywordXMP | Gets or sets LastKeywordXMP property of the MicrosoftPhoto XMP schema.
Public Property | LensManufacturer | Gets or sets LensManufacturer property of the MicrosoftPhoto XMP schema.
Public Property | LensModel | Gets or sets LensModel property of the MicrosoftPhoto XMP schema.
Public Property | Rating | Gets or sets Rating property of the MicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
Top
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImageGear.Formats.XMP.MicrosoftPhoto Namespace


%%PageItemTitle%%

ImGearMicrosoftPhotoXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : ImGearMicrosoftPhotoXMPMetadata Constructor
Overload List
Overload | Description
ImGearMicrosoftPhotoXMPMetadata Constructor | Initializes a new instance of the ImGearMicrosoftPhotoXMPMetadata class.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


CameraSerialNumber Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : CameraSerialNumber Property
Gets or sets CameraSerialNumber property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraSerialNumber As ImGearXMPString
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPString

instance.CameraSerialNumber = value

value = instance.CameraSerialNumber
public ImGearXMPString CameraSerialNumber {get; set;}
public: __property ImGearXMPString* get_CameraSerialNumber();
public: __property void set_CameraSerialNumber(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CameraSerialNumber {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


DateAcquired Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : DateAcquired Property
Gets or sets DateAcquired property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateAcquired As ImGearXMPDate
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPDate

instance.DateAcquired = value

value = instance.DateAcquired
public ImGearXMPDate DateAcquired {get; set;}
public: __property ImGearXMPDate* get_DateAcquired();
public: __property void set_DateAcquired(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateAcquired {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


FlashManufacturer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : FlashManufacturer Property
Gets or sets FlashManufacturer property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashManufacturer As ImGearXMPString
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPString

instance.FlashManufacturer = value

value = instance.FlashManufacturer
public ImGearXMPString FlashManufacturer {get; set;}
public: __property ImGearXMPString* get_FlashManufacturer();
public: __property void set_FlashManufacturer(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FlashManufacturer {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


FlashModel Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : FlashModel Property
Gets or sets FlashModel property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashModel As ImGearXMPString
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPString

instance.FlashModel = value

value = instance.FlashModel
public ImGearXMPString FlashModel {get; set;}
public: __property ImGearXMPString* get_FlashModel();
public: __property void set_FlashModel(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ FlashModel {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


LastKeywordIPTC Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : LastKeywordIPTC Property
Gets or sets LastKeywordIPTC property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LastKeywordIPTC As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.LastKeywordIPTC = value

value = instance.LastKeywordIPTC
public ImGearXMPBag<ImGearXMPString> LastKeywordIPTC {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_LastKeywordIPTC();
public: __property void set_LastKeywordIPTC(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ LastKeywordIPTC {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


LastKeywordXMP Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : LastKeywordXMP Property
Gets or sets LastKeywordXMP property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LastKeywordXMP As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.LastKeywordXMP = value

value = instance.LastKeywordXMP
public ImGearXMPBag<ImGearXMPString> LastKeywordXMP {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_LastKeywordXMP();
public: __property void set_LastKeywordXMP(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ LastKeywordXMP {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


LensManufacturer Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : LensManufacturer Property
Gets or sets LensManufacturer property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LensManufacturer As ImGearXMPString
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPString

instance.LensManufacturer = value

value = instance.LensManufacturer
public ImGearXMPString LensManufacturer {get; set;}
public: __property ImGearXMPString* get_LensManufacturer();
public: __property void set_LensManufacturer(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ LensManufacturer {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


LensModel Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : LensModel Property
Gets or sets LensModel property of the MicrosoftPhoto XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LensModel As ImGearXMPString
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPString

instance.LensModel = value

value = instance.LensModel
public ImGearXMPString LensModel {get; set;}
public: __property ImGearXMPString* get_LensModel();
public: __property void set_LensModel(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ LensModel {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


Rating Property (ImGearMicrosoftPhotoXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.MicrosoftPhoto Namespace > ImGearMicrosoftPhotoXMPMetadata Class : Rating Property
Gets or sets Rating property of the MicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rating As ImGearXMPInteger
'Usage

Dim instance As ImGearMicrosoftPhotoXMPMetadata
Dim value As ImGearXMPInteger

instance.Rating = value

value = instance.Rating
public ImGearXMPInteger Rating {get; set;}
public: __property ImGearXMPInteger* get_Rating();
public: __property void set_Rating(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Rating {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


ImageGear.Formats.XMP.PagedText Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.PagedText Namespace
This namespace provides the API for XMP.PagedText format.
Classes
 | Class | Description
Class | ImGearPagedTextXMPMetadata | Provides simplified access to XMP Paged Text metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.PagedText Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.PagedText Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearPagedTextXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace : ImGearPagedTextXMPMetadata Class
Provides simplified access to XMP Paged Text metadata schema.
Object Model
ImGearPagedTextXMPMetadata ClassImGearXMPDimensions ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPagedTextXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearPagedTextXMPMetadata
public class ImGearPagedTextXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearPagedTextXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearPagedTextXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This schema is used for text appearing on a page in a document.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.PagedText.ImGearPagedTextXMPMetadata

See Also

Reference

ImGearPagedTextXMPMetadata Members
ImageGear.Formats.XMP.PagedText Namespace


%%PageItemTitle%% $$Members$$

ImGearPagedTextXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace : ImGearPagedTextXMPMetadata Class

The following tables list the members exposed by ImGearPagedTextXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearPagedTextXMPMetadata Constructor | Initializes a new instance of the ImGearPagedTextXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Colorants | Gets or sets Colorants property of the Paged Text XMP schema. This XMP property specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
Public Property | Fonts | Gets or sets Fonts property of the Paged Text XMP schema. This XMP property specifies unordered array of fonts that are used in the document (including any in contained documents).
Public Property | MaxPageSize | Gets or sets MaxPageSize property of the Paged Text XMP schema. This XMP property specifies size of the largest page in the document (including any in contained documents).
Public Property | NPages | Gets or sets NPages property of the Paged Text XMP schema. This XMP property specifies number of pages in the document (including any in contained documents).
Public Property | PlateNames | Gets or sets PlateNames property of the Paged Text XMP schema. This XMP property specifies ordered array of plate names that are needed to print the document (including any in contained documents).
Top
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImageGear.Formats.XMP.PagedText Namespace


%%PageItemTitle%%

ImGearPagedTextXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : ImGearPagedTextXMPMetadata Constructor
Initializes a new instance of the ImGearPagedTextXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPagedTextXMPMetadata()
public ImGearPagedTextXMPMetadata()
public: ImGearPagedTextXMPMetadata();
public:
ImGearPagedTextXMPMetadata();

Return Value

New instance of ImGearPagedTextXMPMetadata class object.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearPagedTextXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace : ImGearPagedTextXMPMetadata Class

For a list of all members of this type, see ImGearPagedTextXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Colorants | Gets or sets Colorants property of the Paged Text XMP schema. This XMP property specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
Public Property | Fonts | Gets or sets Fonts property of the Paged Text XMP schema. This XMP property specifies unordered array of fonts that are used in the document (including any in contained documents).
Public Property | MaxPageSize | Gets or sets MaxPageSize property of the Paged Text XMP schema. This XMP property specifies size of the largest page in the document (including any in contained documents).
Public Property | NPages | Gets or sets NPages property of the Paged Text XMP schema. This XMP property specifies number of pages in the document (including any in contained documents).
Public Property | PlateNames | Gets or sets PlateNames property of the Paged Text XMP schema. This XMP property specifies ordered array of plate names that are needed to print the document (including any in contained documents).
Top
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImageGear.Formats.XMP.PagedText Namespace


%%PageItemTitle%%

ImGearPagedTextXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : ImGearPagedTextXMPMetadata Constructor
Overload List
Overload | Description
ImGearPagedTextXMPMetadata Constructor | Initializes a new instance of the ImGearPagedTextXMPMetadata class.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


Colorants Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : Colorants Property
Gets or sets Colorants property of the Paged Text XMP schema. This XMP property specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Colorants As ImGearXMPSeq(Of ImGearXMPColorant)
'Usage

Dim instance As ImGearPagedTextXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPColorant)

instance.Colorants = value

value = instance.Colorants
public ImGearXMPSeq<ImGearXMPColorant> Colorants {get; set;}
public: __property ImGearXMPSeq<ImGearXMPColorant*>* get_Colorants();
public: __property void set_Colorants(
   ImGearXMPSeq<ImGearXMPColorant*>* value
);
public:
property ImGearXMPSeq<ImGearXMPColorant^>^ Colorants {
   ImGearXMPSeq<ImGearXMPColorant^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPColorant^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPColorant type parameter.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


Fonts Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : Fonts Property
Gets or sets Fonts property of the Paged Text XMP schema. This XMP property specifies unordered array of fonts that are used in the document (including any in contained documents).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fonts As ImGearXMPBag(Of ImGearXMPFont)
'Usage

Dim instance As ImGearPagedTextXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPFont)

instance.Fonts = value

value = instance.Fonts
public ImGearXMPBag<ImGearXMPFont> Fonts {get; set;}
public: __property ImGearXMPBag<ImGearXMPFont*>* get_Fonts();
public: __property void set_Fonts(
   ImGearXMPBag<ImGearXMPFont*>* value
);
public:
property ImGearXMPBag<ImGearXMPFont^>^ Fonts {
   ImGearXMPBag<ImGearXMPFont^>^ get();
   void set (    ImGearXMPBag<ImGearXMPFont^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPFont type parameter.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


MaxPageSize Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : MaxPageSize Property
Gets or sets MaxPageSize property of the Paged Text XMP schema. This XMP property specifies size of the largest page in the document (including any in contained documents).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxPageSize As ImGearXMPDimensions
'Usage

Dim instance As ImGearPagedTextXMPMetadata
Dim value As ImGearXMPDimensions

instance.MaxPageSize = value

value = instance.MaxPageSize
public ImGearXMPDimensions MaxPageSize {get; set;}
public: __property ImGearXMPDimensions* get_MaxPageSize();
public: __property void set_MaxPageSize(
   ImGearXMPDimensions* value
);
public:
property ImGearXMPDimensions^ MaxPageSize {
   ImGearXMPDimensions^ get();
   void set (    ImGearXMPDimensions^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDimensions class value.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


NPages Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : NPages Property
Gets or sets NPages property of the Paged Text XMP schema. This XMP property specifies number of pages in the document (including any in contained documents).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NPages As ImGearXMPInteger
'Usage

Dim instance As ImGearPagedTextXMPMetadata
Dim value As ImGearXMPInteger

instance.NPages = value

value = instance.NPages
public ImGearXMPInteger NPages {get; set;}
public: __property ImGearXMPInteger* get_NPages();
public: __property void set_NPages(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ NPages {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


PlateNames Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.PagedText Namespace > ImGearPagedTextXMPMetadata Class : PlateNames Property
Gets or sets PlateNames property of the Paged Text XMP schema. This XMP property specifies ordered array of plate names that are needed to print the document (including any in contained documents).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlateNames As ImGearXMPSeq(Of ImGearXMPString)
'Usage

Dim instance As ImGearPagedTextXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPString)

instance.PlateNames = value

value = instance.PlateNames
public ImGearXMPSeq<ImGearXMPString> PlateNames {get; set;}
public: __property ImGearXMPSeq<ImGearXMPString*>* get_PlateNames();
public: __property void set_PlateNames(
   ImGearXMPSeq<ImGearXMPString*>* value
);
public:
property ImGearXMPSeq<ImGearXMPString^>^ PlateNames {
   ImGearXMPSeq<ImGearXMPString^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


ImageGear.Formats.XMP.Photoshop Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.Photoshop Namespace
This namespace provides the API for XMP.Photoshop format.
Classes
 | Class | Description
Class | ImGearPhotoshopXMPMetadata | Provides simplified access to Photoshop XMP metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.Photoshop Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.Photoshop Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearPhotoshopXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace : ImGearPhotoshopXMPMetadata Class
Provides simplified access to Photoshop XMP metadata schema.
Object Model
ImGearPhotoshopXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPhotoshopXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
public class ImGearPhotoshopXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearPhotoshopXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearPhotoshopXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This schema specifies properties used by Adobe Photoshop.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.Photoshop.ImGearPhotoshopXMPMetadata

See Also

Reference

ImGearPhotoshopXMPMetadata Members
ImageGear.Formats.XMP.Photoshop Namespace


%%PageItemTitle%% $$Members$$

ImGearPhotoshopXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace : ImGearPhotoshopXMPMetadata Class

The following tables list the members exposed by ImGearPhotoshopXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearPhotoshopXMPMetadata Constructor | Initializes a new instance of the ImGearPhotoshopXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | AuthorsPosition | Gets or sets AuthorsPosition property of the Photoshop XMP schema.
Public Property | CaptionWriter | Gets or sets CaptionWriter property of the Photoshop XMP schema.
Public Property | Category | Gets or sets Category property of the Photoshop XMP schema.
Public Property | City | Gets or sets City property of the Photoshop XMP schema.
Public Property | Country | Gets or sets Country property of the Photoshop XMP schema.
Public Property | Credit | Gets or sets Credit property of the Photoshop XMP schema.
Public Property | DateCreated | Gets or sets DateCreated property of the Photoshop XMP schema.
Public Property | Headline | Gets or sets Headline property of the Photoshop XMP schema.
Public Property | Instructions | Gets or sets Instructions property of the Photoshop XMP schema.
Public Property | Source | Gets or sets Source property of the Photoshop XMP schema.
Public Property | State | Gets or sets State property of the Photoshop XMP schema.
Public Property | SupplementalCategories | Gets or sets SupplementalCategories property of the Photoshop XMP schema.
Public Property | TransmissionReference | Gets or sets TransmissionReference property of the Photoshop XMP schema.
Public Property | Urgency | Gets or sets Urgency property of the Photoshop XMP schema.
Top
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImageGear.Formats.XMP.Photoshop Namespace


%%PageItemTitle%%

ImGearPhotoshopXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : ImGearPhotoshopXMPMetadata Constructor
Initializes a new instance of the ImGearPhotoshopXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPhotoshopXMPMetadata()
public ImGearPhotoshopXMPMetadata()
public: ImGearPhotoshopXMPMetadata();
public:
ImGearPhotoshopXMPMetadata();

Return Value

New instance of ImGearPhotoshopXMPMetadata class object.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearPhotoshopXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace : ImGearPhotoshopXMPMetadata Class

For a list of all members of this type, see ImGearPhotoshopXMPMetadata members.

Public Properties
 | Name | Description
Public Property | AuthorsPosition | Gets or sets AuthorsPosition property of the Photoshop XMP schema.
Public Property | CaptionWriter | Gets or sets CaptionWriter property of the Photoshop XMP schema.
Public Property | Category | Gets or sets Category property of the Photoshop XMP schema.
Public Property | City | Gets or sets City property of the Photoshop XMP schema.
Public Property | Country | Gets or sets Country property of the Photoshop XMP schema.
Public Property | Credit | Gets or sets Credit property of the Photoshop XMP schema.
Public Property | DateCreated | Gets or sets DateCreated property of the Photoshop XMP schema.
Public Property | Headline | Gets or sets Headline property of the Photoshop XMP schema.
Public Property | Instructions | Gets or sets Instructions property of the Photoshop XMP schema.
Public Property | Source | Gets or sets Source property of the Photoshop XMP schema.
Public Property | State | Gets or sets State property of the Photoshop XMP schema.
Public Property | SupplementalCategories | Gets or sets SupplementalCategories property of the Photoshop XMP schema.
Public Property | TransmissionReference | Gets or sets TransmissionReference property of the Photoshop XMP schema.
Public Property | Urgency | Gets or sets Urgency property of the Photoshop XMP schema.
Top
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImageGear.Formats.XMP.Photoshop Namespace


%%PageItemTitle%%

ImGearPhotoshopXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : ImGearPhotoshopXMPMetadata Constructor
Overload List
Overload | Description
ImGearPhotoshopXMPMetadata Constructor | Initializes a new instance of the ImGearPhotoshopXMPMetadata class.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


AuthorsPosition Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : AuthorsPosition Property
Gets or sets AuthorsPosition property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AuthorsPosition As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.AuthorsPosition = value

value = instance.AuthorsPosition
public ImGearXMPString AuthorsPosition {get; set;}
public: __property ImGearXMPString* get_AuthorsPosition();
public: __property void set_AuthorsPosition(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ AuthorsPosition {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property specifies by-line title.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


CaptionWriter Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : CaptionWriter Property
Gets or sets CaptionWriter property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CaptionWriter As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.CaptionWriter = value

value = instance.CaptionWriter
public ImGearXMPString CaptionWriter {get; set;}
public: __property ImGearXMPString* get_CaptionWriter();
public: __property void set_CaptionWriter(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ CaptionWriter {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Category Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Category Property
Gets or sets Category property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Category As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Category = value

value = instance.Category
public ImGearXMPString Category {get; set;}
public: __property ImGearXMPString* get_Category();
public: __property void set_Category(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Category {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
It is limited to 3 7-bit ASCII characters.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


City Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : City Property
Gets or sets City property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property City As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.City = value

value = instance.City
public ImGearXMPString City {get; set;}
public: __property ImGearXMPString* get_City();
public: __property void set_City(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ City {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Country Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Country Property
Gets or sets Country property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Country As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Country = value

value = instance.Country
public ImGearXMPString Country {get; set;}
public: __property ImGearXMPString* get_Country();
public: __property void set_Country(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Country {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Credit Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Credit Property
Gets or sets Credit property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Credit As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Credit = value

value = instance.Credit
public ImGearXMPString Credit {get; set;}
public: __property ImGearXMPString* get_Credit();
public: __property void set_Credit(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Credit {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


DateCreated Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : DateCreated Property
Gets or sets DateCreated property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateCreated As ImGearXMPDate
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPDate

instance.DateCreated = value

value = instance.DateCreated
public ImGearXMPDate DateCreated {get; set;}
public: __property ImGearXMPDate* get_DateCreated();
public: __property void set_DateCreated(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateCreated {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Headline Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Headline Property
Gets or sets Headline property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Headline As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Headline = value

value = instance.Headline
public ImGearXMPString Headline {get; set;}
public: __property ImGearXMPString* get_Headline();
public: __property void set_Headline(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Headline {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Instructions Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Instructions Property
Gets or sets Instructions property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Instructions As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Instructions = value

value = instance.Instructions
public ImGearXMPString Instructions {get; set;}
public: __property ImGearXMPString* get_Instructions();
public: __property void set_Instructions(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Instructions {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Source Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Source Property
Gets or sets Source property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Source As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.Source = value

value = instance.Source
public ImGearXMPString Source {get; set;}
public: __property ImGearXMPString* get_Source();
public: __property void set_Source(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Source {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


State Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : State Property
Gets or sets State property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property State As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.State = value

value = instance.State
public ImGearXMPString State {get; set;}
public: __property ImGearXMPString* get_State();
public: __property void set_State(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ State {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


SupplementalCategories Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : SupplementalCategories Property
Gets or sets SupplementalCategories property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementalCategories As ImGearXMPBag(Of ImGearXMPString)
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPBag(Of ImGearXMPString)

instance.SupplementalCategories = value

value = instance.SupplementalCategories
public ImGearXMPBag<ImGearXMPString> SupplementalCategories {get; set;}
public: __property ImGearXMPBag<ImGearXMPString*>* get_SupplementalCategories();
public: __property void set_SupplementalCategories(
   ImGearXMPBag<ImGearXMPString*>* value
);
public:
property ImGearXMPBag<ImGearXMPString^>^ SupplementalCategories {
   ImGearXMPBag<ImGearXMPString^>^ get();
   void set (    ImGearXMPBag<ImGearXMPString^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBag<T> generic class value with ImageGear.Formats.XMP.ImGearXMPString type parameter.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


TransmissionReference Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : TransmissionReference Property
Gets or sets TransmissionReference property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransmissionReference As ImGearXMPString
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPString

instance.TransmissionReference = value

value = instance.TransmissionReference
public ImGearXMPString TransmissionReference {get; set;}
public: __property ImGearXMPString* get_TransmissionReference();
public: __property void set_TransmissionReference(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ TransmissionReference {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


Urgency Property (ImGearPhotoshopXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.Photoshop Namespace > ImGearPhotoshopXMPMetadata Class : Urgency Property
Gets or sets Urgency property of the Photoshop XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Urgency As ImGearXMPInteger
'Usage

Dim instance As ImGearPhotoshopXMPMetadata
Dim value As ImGearXMPInteger

instance.Urgency = value

value = instance.Urgency
public ImGearXMPInteger Urgency {get; set;}
public: __property ImGearXMPInteger* get_Urgency();
public: __property void set_Urgency(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ Urgency {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
Valid range is 1-8.
See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


ImageGear.Formats.XMP.RightsManagement Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.RightsManagement Namespace
This namespace provides the API for XMP.RightsManagement format.
Classes
 | Class | Description
Class | ImGearRightsManagementXMPMetadata | Provides simplified access to Rights Management XMP metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.RightsManagement Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.RightsManagement Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearRightsManagementXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace : ImGearRightsManagementXMPMetadata Class
Provides simplified access to Rights Management XMP metadata schema.
Object Model
ImGearRightsManagementXMPMetadata ClassImGearXMPString ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRightsManagementXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
public class ImGearRightsManagementXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearRightsManagementXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearRightsManagementXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This class includes properties related to rights management. These properties specify information regarding the legal restrictions associated with a resource.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.RightsManagement.ImGearRightsManagementXMPMetadata

See Also

Reference

ImGearRightsManagementXMPMetadata Members
ImageGear.Formats.XMP.RightsManagement Namespace


%%PageItemTitle%% $$Members$$

ImGearRightsManagementXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace : ImGearRightsManagementXMPMetadata Class

The following tables list the members exposed by ImGearRightsManagementXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearRightsManagementXMPMetadata Constructor | Initializes a new instance of the ImGearRightsManagementXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets Certificate property of the XMP Rights Management schema. This XMP property specifies online rights management certificate.
Public Property | Marked | Gets or sets Marked property of the XMP Rights Management schema. This XMP property indicates that this is a rights-managed resource.
Public Property | ProperName | Gets or sets ProperName property of the XMP Rights Management schema.
Public Property | UsageTerms | Gets or sets UsageTerms property of the XMP Rights Management schema. This XMP property specifies instructions on how a resource can be legally used.
Public Property | WebStatement | Gets or sets WebStatement property of the XMP Rights Management schema. This XMP property specifies location of a web page describing the owner and/or rights statement for this resource.
Top
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImageGear.Formats.XMP.RightsManagement Namespace


%%PageItemTitle%%

ImGearRightsManagementXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : ImGearRightsManagementXMPMetadata Constructor
Initializes a new instance of the ImGearRightsManagementXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRightsManagementXMPMetadata()
public ImGearRightsManagementXMPMetadata()
public: ImGearRightsManagementXMPMetadata();
public:
ImGearRightsManagementXMPMetadata();

Return Value

New instance of ImGearRightsManagementXMPMetadata class object.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearRightsManagementXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace : ImGearRightsManagementXMPMetadata Class

For a list of all members of this type, see ImGearRightsManagementXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets Certificate property of the XMP Rights Management schema. This XMP property specifies online rights management certificate.
Public Property | Marked | Gets or sets Marked property of the XMP Rights Management schema. This XMP property indicates that this is a rights-managed resource.
Public Property | ProperName | Gets or sets ProperName property of the XMP Rights Management schema.
Public Property | UsageTerms | Gets or sets UsageTerms property of the XMP Rights Management schema. This XMP property specifies instructions on how a resource can be legally used.
Public Property | WebStatement | Gets or sets WebStatement property of the XMP Rights Management schema. This XMP property specifies location of a web page describing the owner and/or rights statement for this resource.
Top
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImageGear.Formats.XMP.RightsManagement Namespace


%%PageItemTitle%%

ImGearRightsManagementXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : ImGearRightsManagementXMPMetadata Constructor
Overload List
Overload | Description
ImGearRightsManagementXMPMetadata Constructor | Initializes a new instance of the ImGearRightsManagementXMPMetadata class.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


Certificate Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : Certificate Property
Gets or sets Certificate property of the XMP Rights Management schema. This XMP property specifies online rights management certificate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Certificate As ImGearXMPString
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
Dim value As ImGearXMPString

instance.Certificate = value

value = instance.Certificate
public ImGearXMPString Certificate {get; set;}
public: __property ImGearXMPString* get_Certificate();
public: __property void set_Certificate(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Certificate {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


Marked Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : Marked Property
Gets or sets Marked property of the XMP Rights Management schema. This XMP property indicates that this is a rights-managed resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Marked As ImGearXMPBoolean
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
Dim value As ImGearXMPBoolean

instance.Marked = value

value = instance.Marked
public ImGearXMPBoolean Marked {get; set;}
public: __property ImGearXMPBoolean* get_Marked();
public: __property void set_Marked(
   ImGearXMPBoolean* value
);
public:
property ImGearXMPBoolean^ Marked {
   ImGearXMPBoolean^ get();
   void set (    ImGearXMPBoolean^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPBoolean class value.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


ProperName Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : ProperName Property
Gets or sets ProperName property of the XMP Rights Management schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProperName As ImGearXMPString
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
Dim value As ImGearXMPString

instance.ProperName = value

value = instance.ProperName
public ImGearXMPString ProperName {get; set;}
public: __property ImGearXMPString* get_ProperName();
public: __property void set_ProperName(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ ProperName {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


UsageTerms Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : UsageTerms Property
Gets or sets UsageTerms property of the XMP Rights Management schema. This XMP property specifies instructions on how a resource can be legally used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UsageTerms As ImGearXMPLangAlt
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
Dim value As ImGearXMPLangAlt

instance.UsageTerms = value

value = instance.UsageTerms
public ImGearXMPLangAlt UsageTerms {get; set;}
public: __property ImGearXMPLangAlt* get_UsageTerms();
public: __property void set_UsageTerms(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ UsageTerms {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


WebStatement Property (ImGearRightsManagementXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.RightsManagement Namespace > ImGearRightsManagementXMPMetadata Class : WebStatement Property
Gets or sets WebStatement property of the XMP Rights Management schema. This XMP property specifies location of a web page describing the owner and/or rights statement for this resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WebStatement As ImGearXMPString
'Usage

Dim instance As ImGearRightsManagementXMPMetadata
Dim value As ImGearXMPString

instance.WebStatement = value

value = instance.WebStatement
public ImGearXMPString WebStatement {get; set;}
public: __property ImGearXMPString* get_WebStatement();
public: __property void set_WebStatement(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ WebStatement {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


ImageGear.Formats.XMP.TIFF Namespace
Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.TIFF Namespace
This namespace provides the API for XMP.TIFF format.
Classes
 | Class | Description
Class | ImGearTIFFXMPMetadata | Provides simplified access to TIFF XMP metadata schema.
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.XMP.TIFF Namespace Inheritance Hierarchy
ImageGear22.Formats.SimplifiedMetadata Assembly : ImageGear.Formats.XMP.TIFF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata
See Also

Reference

ImageGear22.Formats.SimplifiedMetadata Assembly


%%PageItemTitle%%

ImGearTIFFXMPMetadata Class
Members

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace : ImGearTIFFXMPMetadata Class
Provides simplified access to TIFF XMP metadata schema.
Object Model
ImGearTIFFXMPMetadata ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPDate ClassImGearXMPLangAlt ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPInteger ClassImGearXMPRational Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearTIFFXMPMetadata
   Inherits ImageGear.Formats.XMP.ImGearXMPFormatMetadata
'Usage

Dim instance As ImGearTIFFXMPMetadata
public class ImGearTIFFXMPMetadata : ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public __gc class ImGearTIFFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
public ref class ImGearTIFFXMPMetadata : public ImageGear.Formats.XMP.ImGearXMPFormatMetadata
Remarks
This class includes TIFF-derived data. Only those TIFF properties that are mentioned in the EXIF 2.2 specification are included in this schema.
Inheritance Hierarchy

System.Object
ImageGear.Formats.ImGearFormatMetadata
ImageGear.Formats.XMP.ImGearXMPFormatMetadata
ImageGear.Formats.XMP.TIFF.ImGearTIFFXMPMetadata

See Also

Reference

ImGearTIFFXMPMetadata Members
ImageGear.Formats.XMP.TIFF Namespace


%%PageItemTitle%% $$Members$$

ImGearTIFFXMPMetadata Class Members
Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace : ImGearTIFFXMPMetadata Class

The following tables list the members exposed by ImGearTIFFXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | ImGearTIFFXMPMetadata Constructor | Initializes a new instance of the ImGearTIFFXMPMetadata class.
Top
Public Properties
 | Name | Description
Public Property | Artist | Gets or sets Artist property of the TIFF XMP schema.
Public Property | BitsPerSample | Gets or sets BitsPerSample property of the TIFF XMP schema.
Public Property | Compression | Gets or sets Compression property of the TIFF XMP schema.
Public Property | Copyright | Gets or sets Copyright property of the TIFF XMP schema.
Public Property | DateTime | Gets or sets DateTime property of the TIFF XMP schema.
Public Property | ImageDescription | Gets or sets ImageDescription property of the TIFF XMP schema.
Public Property | ImageLength | Gets or sets ImageLength property of the TIFF XMP schema.
Public Property | ImageWidth | Gets or sets ImageWidth property of the TIFF XMP schema.
Public Property | Make | Gets or sets Make property of the TIFF XMP schema.
Public Property | Model | Gets or sets Model property of the TIFF XMP schema.
Public Property | Orientation | Gets or sets Orientation property of the TIFF XMP schema.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation property of the TIFF XMP schema.
Public Property | PlanarConfiguration | Gets or sets PlanarConfiguration property of the TIFF XMP schema.
Public Property | PrimaryCromaticities | Gets or sets PrimaryCromaticities property of the TIFF XMP schema.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite property of the TIFF XMP schema.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit property of the TIFF XMP schema.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel property of the TIFF XMP schema.
Public Property | Software | Gets or sets Software property of the TIFF XMP schema.
Public Property | TransferFunction | Gets or sets TransferFunction property of the TIFF XMP schema.
Public Property | WhitePoint | Gets or sets WhitePoint property of the TIFF XMP schema.
Public Property | XResolution | Gets or sets XResolution property of the TIFF XMP schema.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients property of the TIFF XMP schema.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning property of the TIFF XMP schema.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling property of the TIFF XMP schema.
Public Property | YResolution | Gets or sets YResolution property of the TIFF XMP schema.
Top
See Also

Reference

ImGearTIFFXMPMetadata Class
ImageGear.Formats.XMP.TIFF Namespace


%%PageItemTitle%%

ImGearTIFFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ImGearTIFFXMPMetadata Constructor
Initializes a new instance of the ImGearTIFFXMPMetadata class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearTIFFXMPMetadata()
public ImGearTIFFXMPMetadata()
public: ImGearTIFFXMPMetadata();
public:
ImGearTIFFXMPMetadata();

Return Value

New instance of ImGearTIFFXMPMetadata class object.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearTIFFXMPMetadata Class Properties

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace : ImGearTIFFXMPMetadata Class

For a list of all members of this type, see ImGearTIFFXMPMetadata members.

Public Properties
 | Name | Description
Public Property | Artist | Gets or sets Artist property of the TIFF XMP schema.
Public Property | BitsPerSample | Gets or sets BitsPerSample property of the TIFF XMP schema.
Public Property | Compression | Gets or sets Compression property of the TIFF XMP schema.
Public Property | Copyright | Gets or sets Copyright property of the TIFF XMP schema.
Public Property | DateTime | Gets or sets DateTime property of the TIFF XMP schema.
Public Property | ImageDescription | Gets or sets ImageDescription property of the TIFF XMP schema.
Public Property | ImageLength | Gets or sets ImageLength property of the TIFF XMP schema.
Public Property | ImageWidth | Gets or sets ImageWidth property of the TIFF XMP schema.
Public Property | Make | Gets or sets Make property of the TIFF XMP schema.
Public Property | Model | Gets or sets Model property of the TIFF XMP schema.
Public Property | Orientation | Gets or sets Orientation property of the TIFF XMP schema.
Public Property | PhotometricInterpretation | Gets or sets PhotometricInterpretation property of the TIFF XMP schema.
Public Property | PlanarConfiguration | Gets or sets PlanarConfiguration property of the TIFF XMP schema.
Public Property | PrimaryCromaticities | Gets or sets PrimaryCromaticities property of the TIFF XMP schema.
Public Property | ReferenceBlackWhite | Gets or sets ReferenceBlackWhite property of the TIFF XMP schema.
Public Property | ResolutionUnit | Gets or sets ResolutionUnit property of the TIFF XMP schema.
Public Property | SamplesPerPixel | Gets or sets SamplesPerPixel property of the TIFF XMP schema.
Public Property | Software | Gets or sets Software property of the TIFF XMP schema.
Public Property | TransferFunction | Gets or sets TransferFunction property of the TIFF XMP schema.
Public Property | WhitePoint | Gets or sets WhitePoint property of the TIFF XMP schema.
Public Property | XResolution | Gets or sets XResolution property of the TIFF XMP schema.
Public Property | YCbCrCoefficients | Gets or sets YCbCrCoefficients property of the TIFF XMP schema.
Public Property | YCbCrPositioning | Gets or sets YCbCrPositioning property of the TIFF XMP schema.
Public Property | YCbCrSubSampling | Gets or sets YCbCrSubSampling property of the TIFF XMP schema.
Public Property | YResolution | Gets or sets YResolution property of the TIFF XMP schema.
Top
See Also

Reference

ImGearTIFFXMPMetadata Class
ImageGear.Formats.XMP.TIFF Namespace


%%PageItemTitle%%

ImGearTIFFXMPMetadata Constructor

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ImGearTIFFXMPMetadata Constructor
Overload List
Overload | Description
ImGearTIFFXMPMetadata Constructor | Initializes a new instance of the ImGearTIFFXMPMetadata class.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Artist Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Artist Property
Gets or sets Artist property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Artist As ImGearXMPString
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPString

instance.Artist = value

value = instance.Artist
public ImGearXMPString Artist {get; set;}
public: __property ImGearXMPString* get_Artist();
public: __property void set_Artist(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Artist {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator.

Note: This property is stored in XMP as the first item in the dc:creator array.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


BitsPerSample Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : BitsPerSample Property
Gets or sets BitsPerSample property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerSample As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.BitsPerSample = value

value = instance.BitsPerSample
public ImGearXMPSeq<ImGearXMPInteger> BitsPerSample {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_BitsPerSample();
public: __property void set_BitsPerSample(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ BitsPerSample {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
This XMP property represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Compression Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Compression Property
Gets or sets Compression property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As ImGearXMPEnum(Of ImGearTIFFCompression)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFCompression)

instance.Compression = value

value = instance.Compression
public ImGearXMPEnum<ImGearTIFFCompression> Compression {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFCompression>* get_Compression();
public: __property void set_Compression(
   ImGearXMPEnum<ImGearTIFFCompression>* value
);
public:
property ImGearXMPEnum<ImGearTIFFCompression>^ Compression {
   ImGearXMPEnum<ImGearTIFFCompression>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFCompression>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.TIF.ImGearTIFFCompression type parameter.
Remarks
This XMP property represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Copyright Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Copyright Property
Gets or sets Copyright property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Copyright As ImGearXMPLangAlt
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPLangAlt

instance.Copyright = value

value = instance.Copyright
public ImGearXMPLangAlt Copyright {get; set;}
public: __property ImGearXMPLangAlt* get_Copyright();
public: __property void set_Copyright(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ Copyright {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property represents TIFF tag 33432 (0x8298) and specifies copyright information.

Note: This property is stored in XMP as dc:rights.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


DateTime Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : DateTime Property
Gets or sets DateTime property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTime As ImGearXMPDate
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPDate

instance.DateTime = value

value = instance.DateTime
public ImGearXMPDate DateTime {get; set;}
public: __property ImGearXMPDate* get_DateTime();
public: __property void set_DateTime(
   ImGearXMPDate* value
);
public:
property ImGearXMPDate^ DateTime {
   ImGearXMPDate^ get();
   void set (    ImGearXMPDate^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPDate class value.
Remarks
This XMP property represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds).

Note: This property is stored in XMP as xmp:ModifyDate.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ImageDescription Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ImageDescription Property
Gets or sets ImageDescription property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageDescription As ImGearXMPLangAlt
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPLangAlt

instance.ImageDescription = value

value = instance.ImageDescription
public ImGearXMPLangAlt ImageDescription {get; set;}
public: __property ImGearXMPLangAlt* get_ImageDescription();
public: __property void set_ImageDescription(
   ImGearXMPLangAlt* value
);
public:
property ImGearXMPLangAlt^ ImageDescription {
   ImGearXMPLangAlt^ get();
   void set (    ImGearXMPLangAlt^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPLangAlt class value.
Remarks
This XMP property represents TIFF tag 270 (0x10E) and specifies description of the image.

Note: This property is stored in XMP as dc:description.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ImageLength Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ImageLength Property
Gets or sets ImageLength property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageLength As ImGearXMPInteger
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPInteger

instance.ImageLength = value

value = instance.ImageLength
public ImGearXMPInteger ImageLength {get; set;}
public: __property ImGearXMPInteger* get_ImageLength();
public: __property void set_ImageLength(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ImageLength {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents TIFF tag 257 (0x101) and specifies image height in pixels.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ImageWidth Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ImageWidth Property
Gets or sets ImageWidth property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageWidth As ImGearXMPInteger
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPInteger

instance.ImageWidth = value

value = instance.ImageWidth
public ImGearXMPInteger ImageWidth {get; set;}
public: __property ImGearXMPInteger* get_ImageWidth();
public: __property void set_ImageWidth(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ ImageWidth {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents TIFF tag 256 (0x100) and specifies image width in pixels.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Make Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Make Property
Gets or sets Make property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Make As ImGearXMPString
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPString

instance.Make = value

value = instance.Make
public ImGearXMPString Make {get; set;}
public: __property ImGearXMPString* get_Make();
public: __property void set_Make(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Make {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Model Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Model Property
Gets or sets Model property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Model As ImGearXMPString
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPString

instance.Model = value

value = instance.Model
public ImGearXMPString Model {get; set;}
public: __property ImGearXMPString* get_Model();
public: __property void set_Model(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Model {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 272 (0x110) and specifies model name or number of equipment.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Orientation Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Orientation Property
Gets or sets Orientation property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As ImGearXMPEnum(Of ImGearTIFFOrientation)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFOrientation)

instance.Orientation = value

value = instance.Orientation
public ImGearXMPEnum<ImGearTIFFOrientation> Orientation {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFOrientation>* get_Orientation();
public: __property void set_Orientation(
   ImGearXMPEnum<ImGearTIFFOrientation>* value
);
public:
property ImGearXMPEnum<ImGearTIFFOrientation>^ Orientation {
   ImGearXMPEnum<ImGearTIFFOrientation>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFOrientation>^ value);
}

Property Value

ImageGear.Formats.TIF.ImGearTIFFOrientation generic class value with ImageGear.Formats.TIF.ImGearTIFFOrientation type parameter.
Remarks
This XMP property represents TIFF tag 274 (0x112) and specifies image orientation.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


PhotometricInterpretation Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : PhotometricInterpretation Property
Gets or sets PhotometricInterpretation property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PhotometricInterpretation As ImGearXMPEnum(Of ImGearTIFFPhotoInterpretation)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFPhotoInterpretation)

instance.PhotometricInterpretation = value

value = instance.PhotometricInterpretation
public ImGearXMPEnum<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFPhotoInterpretation>* get_PhotometricInterpretation();
public: __property void set_PhotometricInterpretation(
   ImGearXMPEnum<ImGearTIFFPhotoInterpretation>* value
);
public:
property ImGearXMPEnum<ImGearTIFFPhotoInterpretation>^ PhotometricInterpretation {
   ImGearXMPEnum<ImGearTIFFPhotoInterpretation>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFPhotoInterpretation>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.TIF.ImGearTIFFPhotoInterpretation type parameter.
Remarks
This XMP property represents TIFF tag 262 (0x106) and specifies pixel composition.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


PlanarConfiguration Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : PlanarConfiguration Property
Gets or sets PlanarConfiguration property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlanarConfiguration As ImGearXMPEnum(Of ImGearTIFFPlanarConfig)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFPlanarConfig)

instance.PlanarConfiguration = value

value = instance.PlanarConfiguration
public ImGearXMPEnum<ImGearTIFFPlanarConfig> PlanarConfiguration {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFPlanarConfig>* get_PlanarConfiguration();
public: __property void set_PlanarConfiguration(
   ImGearXMPEnum<ImGearTIFFPlanarConfig>* value
);
public:
property ImGearXMPEnum<ImGearTIFFPlanarConfig>^ PlanarConfiguration {
   ImGearXMPEnum<ImGearTIFFPlanarConfig>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFPlanarConfig>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.TIF.ImGearTIFFPlanarConfig type parameter.
Remarks
This XMP property represents TIFF tag 284 (0x11C) and specifies data layout.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


PrimaryCromaticities Property

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : PrimaryCromaticities Property
Gets or sets PrimaryCromaticities property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrimaryCromaticities As ImGearXMPSeq(Of ImGearXMPRational)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPRational)

instance.PrimaryCromaticities = value

value = instance.PrimaryCromaticities
public ImGearXMPSeq<ImGearXMPRational> PrimaryCromaticities {get; set;}
public: __property ImGearXMPSeq<ImGearXMPRational*>* get_PrimaryCromaticities();
public: __property void set_PrimaryCromaticities(
   ImGearXMPSeq<ImGearXMPRational*>* value
);
public:
property ImGearXMPSeq<ImGearXMPRational^>^ PrimaryCromaticities {
   ImGearXMPSeq<ImGearXMPRational^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPRational^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPRational type parameter.
Remarks
This XMP property represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ReferenceBlackWhite Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ReferenceBlackWhite Property
Gets or sets ReferenceBlackWhite property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceBlackWhite As ImGearXMPSeq(Of ImGearXMPRational)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPRational)

instance.ReferenceBlackWhite = value

value = instance.ReferenceBlackWhite
public ImGearXMPSeq<ImGearXMPRational> ReferenceBlackWhite {get; set;}
public: __property ImGearXMPSeq<ImGearXMPRational*>* get_ReferenceBlackWhite();
public: __property void set_ReferenceBlackWhite(
   ImGearXMPSeq<ImGearXMPRational*>* value
);
public:
property ImGearXMPSeq<ImGearXMPRational^>^ ReferenceBlackWhite {
   ImGearXMPSeq<ImGearXMPRational^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPRational^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPRational type parameter.
Remarks
This XMP property represents TIFF tag 532 (0x214) and specifies reference black and white point values.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ResolutionUnit Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : ResolutionUnit Property
Gets or sets ResolutionUnit property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionUnit As ImGearXMPEnum(Of ImGearTIFFResolutionUnit)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPEnum(Of ImGearTIFFResolutionUnit)

instance.ResolutionUnit = value

value = instance.ResolutionUnit
public ImGearXMPEnum<ImGearTIFFResolutionUnit> ResolutionUnit {get; set;}
public: __property ImGearXMPEnum<ImGearTIFFResolutionUnit>* get_ResolutionUnit();
public: __property void set_ResolutionUnit(
   ImGearXMPEnum<ImGearTIFFResolutionUnit>* value
);
public:
property ImGearXMPEnum<ImGearTIFFResolutionUnit>^ ResolutionUnit {
   ImGearXMPEnum<ImGearTIFFResolutionUnit>^ get();
   void set (    ImGearXMPEnum<ImGearTIFFResolutionUnit>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPEnum<T> generic class value with ImageGear.Formats.TIF.ImGearTIFFResolutionUnit type parameter.
Remarks
This XMP property represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


SamplesPerPixel Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : SamplesPerPixel Property
Gets or sets SamplesPerPixel property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SamplesPerPixel As ImGearXMPInteger
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPInteger

instance.SamplesPerPixel = value

value = instance.SamplesPerPixel
public ImGearXMPInteger SamplesPerPixel {get; set;}
public: __property ImGearXMPInteger* get_SamplesPerPixel();
public: __property void set_SamplesPerPixel(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ SamplesPerPixel {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents TIFF tag 277 (0x115) and specifies number of components per pixel.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


Software Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : Software Property
Gets or sets Software property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Software As ImGearXMPString
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPString

instance.Software = value

value = instance.Software
public ImGearXMPString Software {get; set;}
public: __property ImGearXMPString* get_Software();
public: __property void set_Software(
   ImGearXMPString* value
);
public:
property ImGearXMPString^ Software {
   ImGearXMPString^ get();
   void set (    ImGearXMPString^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image.

Note: This property is stored in XMP as xmp:CreatorTool.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


TransferFunction Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : TransferFunction Property
Gets or sets TransferFunction property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransferFunction As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.TransferFunction = value

value = instance.TransferFunction
public ImGearXMPSeq<ImGearXMPInteger> TransferFunction {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_TransferFunction();
public: __property void set_TransferFunction(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ TransferFunction {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


WhitePoint Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : WhitePoint Property
Gets or sets WhitePoint property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As ImGearXMPSeq(Of ImGearXMPRational)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPRational)

instance.WhitePoint = value

value = instance.WhitePoint
public ImGearXMPSeq<ImGearXMPRational> WhitePoint {get; set;}
public: __property ImGearXMPSeq<ImGearXMPRational*>* get_WhitePoint();
public: __property void set_WhitePoint(
   ImGearXMPSeq<ImGearXMPRational*>* value
);
public:
property ImGearXMPSeq<ImGearXMPRational^>^ WhitePoint {
   ImGearXMPSeq<ImGearXMPRational^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPRational^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPString class value.
Remarks
This XMP property represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


XResolution Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : XResolution Property
Gets or sets XResolution property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XResolution As ImGearXMPRational
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPRational

instance.XResolution = value

value = instance.XResolution
public ImGearXMPRational XResolution {get; set;}
public: __property ImGearXMPRational* get_XResolution();
public: __property void set_XResolution(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ XResolution {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


YCbCrCoefficients Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : YCbCrCoefficients Property
Gets or sets YCbCrCoefficients property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrCoefficients As ImGearXMPSeq(Of ImGearXMPRational)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPRational)

instance.YCbCrCoefficients = value

value = instance.YCbCrCoefficients
public ImGearXMPSeq<ImGearXMPRational> YCbCrCoefficients {get; set;}
public: __property ImGearXMPSeq<ImGearXMPRational*>* get_YCbCrCoefficients();
public: __property void set_YCbCrCoefficients(
   ImGearXMPSeq<ImGearXMPRational*>* value
);
public:
property ImGearXMPSeq<ImGearXMPRational^>^ YCbCrCoefficients {
   ImGearXMPSeq<ImGearXMPRational^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPRational^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPRational type parameter.
Remarks
This XMP property represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


YCbCrPositioning Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : YCbCrPositioning Property
Gets or sets YCbCrPositioning property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrPositioning As ImGearXMPInteger
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPInteger

instance.YCbCrPositioning = value

value = instance.YCbCrPositioning
public ImGearXMPInteger YCbCrPositioning {get; set;}
public: __property ImGearXMPInteger* get_YCbCrPositioning();
public: __property void set_YCbCrPositioning(
   ImGearXMPInteger* value
);
public:
property ImGearXMPInteger^ YCbCrPositioning {
   ImGearXMPInteger^ get();
   void set (    ImGearXMPInteger^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPInteger class value.
Remarks
This XMP property represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


YCbCrSubSampling Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : YCbCrSubSampling Property
Gets or sets YCbCrSubSampling property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YCbCrSubSampling As ImGearXMPSeq(Of ImGearXMPInteger)
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPSeq(Of ImGearXMPInteger)

instance.YCbCrSubSampling = value

value = instance.YCbCrSubSampling
public ImGearXMPSeq<ImGearXMPInteger> YCbCrSubSampling {get; set;}
public: __property ImGearXMPSeq<ImGearXMPInteger*>* get_YCbCrSubSampling();
public: __property void set_YCbCrSubSampling(
   ImGearXMPSeq<ImGearXMPInteger*>* value
);
public:
property ImGearXMPSeq<ImGearXMPInteger^>^ YCbCrSubSampling {
   ImGearXMPSeq<ImGearXMPInteger^>^ get();
   void set (    ImGearXMPSeq<ImGearXMPInteger^>^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPSeq<T> generic class value with ImageGear.Formats.XMP.ImGearXMPInteger type parameter.
Remarks
This XMP property represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


YResolution Property (ImGearTIFFXMPMetadata)

ImageGear22.Formats.SimplifiedMetadata Assembly > ImageGear.Formats.XMP.TIFF Namespace > ImGearTIFFXMPMetadata Class : YResolution Property
Gets or sets YResolution property of the TIFF XMP schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YResolution As ImGearXMPRational
'Usage

Dim instance As ImGearTIFFXMPMetadata
Dim value As ImGearXMPRational

instance.YResolution = value

value = instance.YResolution
public ImGearXMPRational YResolution {get; set;}
public: __property ImGearXMPRational* get_YResolution();
public: __property void set_YResolution(
   ImGearXMPRational* value
);
public:
property ImGearXMPRational^ YResolution {
   ImGearXMPRational^ get();
   void set (    ImGearXMPRational^ value);
}

Property Value

ImageGear.Formats.XMP.ImGearXMPRational class value.
Remarks
This XMP property represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.
See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


ImageGear22.Formats.Vector Assembly
Namespaces
Namespace | Description
ImageGear.Formats.CAD | This namespace provides the API to create DWG and DXF vector formats.
ImageGear.Formats.CGM | This namespace provides the API to create CGM vector format.
ImageGear.Formats.DGN | This namespace provides the API to create DGN vector format.
ImageGear.Formats.DWF | This namespace provides the API to create DWF vector format.
ImageGear.Formats.HPGL | This namespace provides the API to create HPGL vector format.
ImageGear.Formats.SVG | This namespace provides API to create SVG vector format.
ImageGear.Formats.U3D | This namespace provides the API to create U3D vector format. ImageGear U3D namespace provides read and write support for the following features of Universal 3D format: CLOD Progressive Mesh, Normals, Colors (diffuse and specular), Views, Lights, Textures, Transparency, Linesets, and Pointsets.
ImageGear.Vector | ImageGear.Vector namespace provides objects and methods for displaying, rasterizing, and manipulating vector drawings. Such drawings can be loaded from vector files such as DWF, DWG/DXF, DGN, CGM, HPGL, and U3D.


ImageGear.Formats.CAD Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.CAD Namespace
This namespace provides the API to create DWG and DXF vector formats.
Classes
 | Class | Description
Class | ImGearCAD | Provides CAD specific features, such as creating instances of DWG and DXF formats.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.CAD Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.CAD Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.CAD.ImGearCAD
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearCAD Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace : ImGearCAD Class
Provides CAD specific features, such as creating instances of DWG and DXF formats.
Object Model
ImGearCAD ClassIImGearFormat InterfaceIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCAD
'Usage

Dim instance As ImGearCAD
public sealed class ImGearCAD
public __gc __sealed class ImGearCAD
public ref class ImGearCAD sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.CAD.ImGearCAD

See Also

Reference

ImGearCAD Members
ImageGear.Formats.CAD Namespace


%%PageItemTitle%% $$Members$$

ImGearCAD Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace : ImGearCAD Class

The following tables list the members exposed by ImGearCAD.

Public Constructors
 | Name | Description
Public Constructor | ImGearCAD Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDWGFormat | Overloaded. Creates an instance of DWG format.
static (Shared in Visual Basic) | CreateDXFFormat | Overloaded. Creates an instance of DXF format.
Top
See Also

Reference

ImGearCAD Class
ImageGear.Formats.CAD Namespace


%%PageItemTitle%%

ImGearCAD Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class : ImGearCAD Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearCAD()
public ImGearCAD()
public: ImGearCAD();
public:
ImGearCAD();
See Also

Reference

ImGearCAD Class
ImGearCAD Members


%%PageItemTitle%% $$Methods$$

ImGearCAD Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace : ImGearCAD Class

For a list of all members of this type, see ImGearCAD members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDWGFormat | Overloaded. Creates an instance of DWG format.
static (Shared in Visual Basic) | CreateDXFFormat | Overloaded. Creates an instance of DXF format.
Top
See Also

Reference

ImGearCAD Class
ImageGear.Formats.CAD Namespace


CreateDWGFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class : CreateDWGFormat Method
Creates an instance of DWG format.
Overload List
Overload | Description
CreateDWGFormat() | Creates an instance of DWG format.
CreateDWGFormat(String) | Creates an instance of DWG format, using the specified library path.
See Also

Reference

ImGearCAD Class
ImGearCAD Members


CreateDWGFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class > CreateDWGFormat Method : CreateDWGFormat() Method
Creates an instance of DWG format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDWGFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearCAD.CreateDWGFormat()
public static IImGearFormat CreateDWGFormat()
public: static IImGearFormat* CreateDWGFormat();
public:
static IImGearFormat^ CreateDWGFormat();

Return Value

An instance of DWG format.
See Also

Reference

ImGearCAD Class
ImGearCAD Members
Overload List
IImGearFormat Interface


CreateDWGFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class > CreateDWGFormat Method : CreateDWGFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of DWG format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateDWGFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearCAD.CreateDWGFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateDWGFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateDWGFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateDWGFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of DWG format.
See Also

Reference

ImGearCAD Class
ImGearCAD Members
Overload List
IImGearFormat Interface


CreateDXFFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class : CreateDXFFormat Method
Creates an instance of DXF format.
Overload List
Overload | Description
CreateDXFFormat() | Creates an instance of DXF format.
CreateDXFFormat(String) | Creates an instance of DXF format, using the specified library path.
See Also

Reference

ImGearCAD Class
ImGearCAD Members


CreateDXFFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class > CreateDXFFormat Method : CreateDXFFormat() Method
Creates an instance of DXF format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDXFFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearCAD.CreateDXFFormat()
public static IImGearFormat CreateDXFFormat()
public: static IImGearFormat* CreateDXFFormat();
public:
static IImGearFormat^ CreateDXFFormat();

Return Value

An instance of DXF format.
See Also

Reference

ImGearCAD Class
ImGearCAD Members
Overload List
IImGearFormat Interface


CreateDXFFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CAD Namespace > ImGearCAD Class > CreateDXFFormat Method : CreateDXFFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of DXF format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateDXFFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearCAD.CreateDXFFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateDXFFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateDXFFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateDXFFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of DXF format.
See Also

Reference

ImGearCAD Class
ImGearCAD Members
Overload List
IImGearFormat Interface


ImageGear.Formats.CGM Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.CGM Namespace
This namespace provides the API to create CGM vector format.
Classes
 | Class | Description
Class | ImGearCGM | Provides CGM specific features, such as creating an instance of CGM format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.CGM Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.CGM Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.CGM.ImGearCGM
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearCGM Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace : ImGearCGM Class
Provides CGM specific features, such as creating an instance of CGM format.
Object Model
ImGearCGM ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCGM
'Usage

Dim instance As ImGearCGM
public sealed class ImGearCGM
public __gc __sealed class ImGearCGM
public ref class ImGearCGM sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.CGM.ImGearCGM

See Also

Reference

ImGearCGM Members
ImageGear.Formats.CGM Namespace


%%PageItemTitle%% $$Members$$

ImGearCGM Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace : ImGearCGM Class

The following tables list the members exposed by ImGearCGM.

Public Constructors
 | Name | Description
Public Constructor | ImGearCGM Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateCGMFormat | Overloaded. Creates an instance of CGM format.
Top
See Also

Reference

ImGearCGM Class
ImageGear.Formats.CGM Namespace


%%PageItemTitle%%

ImGearCGM Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace > ImGearCGM Class : ImGearCGM Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearCGM()
public ImGearCGM()
public: ImGearCGM();
public:
ImGearCGM();
See Also

Reference

ImGearCGM Class
ImGearCGM Members


%%PageItemTitle%% $$Methods$$

ImGearCGM Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace : ImGearCGM Class

For a list of all members of this type, see ImGearCGM members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateCGMFormat | Overloaded. Creates an instance of CGM format.
Top
See Also

Reference

ImGearCGM Class
ImageGear.Formats.CGM Namespace


CreateCGMFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace > ImGearCGM Class : CreateCGMFormat Method
Creates an instance of CGM format.
Overload List
Overload | Description
CreateCGMFormat() | Creates an instance of CGM format.
CreateCGMFormat(String) | Creates an instance of CGM format, using the specified library path.
See Also

Reference

ImGearCGM Class
ImGearCGM Members


CreateCGMFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace > ImGearCGM Class > CreateCGMFormat Method : CreateCGMFormat() Method
Creates an instance of CGM format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateCGMFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearCGM.CreateCGMFormat()
public static IImGearFormat CreateCGMFormat()
public: static IImGearFormat* CreateCGMFormat();
public:
static IImGearFormat^ CreateCGMFormat();

Return Value

An instance of CGM format.
See Also

Reference

ImGearCGM Class
ImGearCGM Members
Overload List
IImGearFormat Interface


CreateCGMFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.CGM Namespace > ImGearCGM Class > CreateCGMFormat Method : CreateCGMFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of CGM format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateCGMFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearCGM.CreateCGMFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateCGMFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateCGMFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateCGMFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of CGM format.
See Also

Reference

ImGearCGM Class
ImGearCGM Members
Overload List
IImGearFormat Interface


ImageGear.Formats.DGN Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.DGN Namespace
This namespace provides the API to create DGN vector format.
Classes
 | Class | Description
Class | ImGearDGN | Provides DGN specific features, such as creating an instance of an instance of DGN format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.DGN Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.DGN Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.DGN.ImGearDGN
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearDGN Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace : ImGearDGN Class
Provides DGN specific features, such as creating an instance of an instance of DGN format.
Object Model
ImGearDGN ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearDGN
'Usage

Dim instance As ImGearDGN
public sealed class ImGearDGN
public __gc __sealed class ImGearDGN
public ref class ImGearDGN sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.DGN.ImGearDGN

See Also

Reference

ImGearDGN Members
ImageGear.Formats.DGN Namespace


%%PageItemTitle%% $$Members$$

ImGearDGN Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace : ImGearDGN Class

The following tables list the members exposed by ImGearDGN.

Public Constructors
 | Name | Description
Public Constructor | ImGearDGN Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDGNFormat | Overloaded. Creates an instance of DGN format.
Top
See Also

Reference

ImGearDGN Class
ImageGear.Formats.DGN Namespace


%%PageItemTitle%%

ImGearDGN Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace > ImGearDGN Class : ImGearDGN Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDGN()
public ImGearDGN()
public: ImGearDGN();
public:
ImGearDGN();
See Also

Reference

ImGearDGN Class
ImGearDGN Members


%%PageItemTitle%% $$Methods$$

ImGearDGN Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace : ImGearDGN Class

For a list of all members of this type, see ImGearDGN members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDGNFormat | Overloaded. Creates an instance of DGN format.
Top
See Also

Reference

ImGearDGN Class
ImageGear.Formats.DGN Namespace


CreateDGNFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace > ImGearDGN Class : CreateDGNFormat Method
Creates an instance of DGN format.
Overload List
Overload | Description
CreateDGNFormat() | Creates an instance of DGN format.
CreateDGNFormat(String) | Creates an instance of DGN format, using the specified library path.
See Also

Reference

ImGearDGN Class
ImGearDGN Members


CreateDGNFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace > ImGearDGN Class > CreateDGNFormat Method : CreateDGNFormat() Method
Creates an instance of DGN format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDGNFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearDGN.CreateDGNFormat()
public static IImGearFormat CreateDGNFormat()
public: static IImGearFormat* CreateDGNFormat();
public:
static IImGearFormat^ CreateDGNFormat();

Return Value

An instance of DGN format.
See Also

Reference

ImGearDGN Class
ImGearDGN Members
Overload List
IImGearFormat Interface


CreateDGNFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DGN Namespace > ImGearDGN Class > CreateDGNFormat Method : CreateDGNFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of DGN format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateDGNFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearDGN.CreateDGNFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateDGNFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateDGNFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateDGNFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of DGN format.
See Also

Reference

ImGearDGN Class
ImGearDGN Members
Overload List
IImGearFormat Interface


ImageGear.Formats.DWF Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.DWF Namespace

This namespace provides the API to create DWF vector format.

Classes
 | Class | Description
Class | ImGearDWF | Provides DWF specific features, such as creating an instance of DWF format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.DWF Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.DWF Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.DWF.ImGearDWF
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearDWF Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace : ImGearDWF Class
Provides DWF specific features, such as creating an instance of DWF format.
Object Model
ImGearDWF ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearDWF
'Usage

Dim instance As ImGearDWF
public sealed class ImGearDWF
public __gc __sealed class ImGearDWF
public ref class ImGearDWF sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.DWF.ImGearDWF

See Also

Reference

ImGearDWF Members
ImageGear.Formats.DWF Namespace


%%PageItemTitle%% $$Members$$

ImGearDWF Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace : ImGearDWF Class

The following tables list the members exposed by ImGearDWF.

Public Constructors
 | Name | Description
Public Constructor | ImGearDWF Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDWFFormat | Overloaded. Creates an instance of DWF format.
Top
See Also

Reference

ImGearDWF Class
ImageGear.Formats.DWF Namespace


%%PageItemTitle%%

ImGearDWF Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace > ImGearDWF Class : ImGearDWF Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDWF()
public ImGearDWF()
public: ImGearDWF();
public:
ImGearDWF();
See Also

Reference

ImGearDWF Class
ImGearDWF Members


%%PageItemTitle%% $$Methods$$

ImGearDWF Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace : ImGearDWF Class

For a list of all members of this type, see ImGearDWF members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDWFFormat | Overloaded. Creates an instance of DWF format.
Top
See Also

Reference

ImGearDWF Class
ImageGear.Formats.DWF Namespace


CreateDWFFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace > ImGearDWF Class : CreateDWFFormat Method
Creates an instance of DWF format.
Overload List
Overload | Description
CreateDWFFormat() | Creates an instance of DWF format.
CreateDWFFormat(String) | Creates an instance of DWF format, using the specified library path.
See Also

Reference

ImGearDWF Class
ImGearDWF Members


CreateDWFFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace > ImGearDWF Class > CreateDWFFormat Method : CreateDWFFormat() Method
Creates an instance of DWF format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDWFFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearDWF.CreateDWFFormat()
public static IImGearFormat CreateDWFFormat()
public: static IImGearFormat* CreateDWFFormat();
public:
static IImGearFormat^ CreateDWFFormat();

Return Value

An instance of DWF format.
See Also

Reference

ImGearDWF Class
ImGearDWF Members
Overload List
IImGearFormat Interface


CreateDWFFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.DWF Namespace > ImGearDWF Class > CreateDWFFormat Method : CreateDWFFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of DWF format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateDWFFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearDWF.CreateDWFFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateDWFFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateDWFFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateDWFFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of DWF format.
See Also

Reference

ImGearDWF Class
ImGearDWF Members
Overload List
IImGearFormat Interface


ImageGear.Formats.HPGL Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.HPGL Namespace

This namespace provides the API to create HPGL vector format.

Classes
 | Class | Description
Class | ImGearHPGL | Provides HPGL specific features, such as creating an instance of HPGL format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.HPGL Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.HPGL Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.HPGL.ImGearHPGL
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearHPGL Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace : ImGearHPGL Class
Provides HPGL specific features, such as creating an instance of HPGL format.
Object Model
ImGearHPGL ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearHPGL
'Usage

Dim instance As ImGearHPGL
public sealed class ImGearHPGL
public __gc __sealed class ImGearHPGL
public ref class ImGearHPGL sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.HPGL.ImGearHPGL

See Also

Reference

ImGearHPGL Members
ImageGear.Formats.HPGL Namespace


%%PageItemTitle%% $$Members$$

ImGearHPGL Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace : ImGearHPGL Class

The following tables list the members exposed by ImGearHPGL.

Public Constructors
 | Name | Description
Public Constructor | ImGearHPGL Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateHPGLFormat | Overloaded. Creates an instance of HPGL format.
Top
See Also

Reference

ImGearHPGL Class
ImageGear.Formats.HPGL Namespace


%%PageItemTitle%%

ImGearHPGL Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace > ImGearHPGL Class : ImGearHPGL Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearHPGL()
public ImGearHPGL()
public: ImGearHPGL();
public:
ImGearHPGL();
See Also

Reference

ImGearHPGL Class
ImGearHPGL Members


%%PageItemTitle%% $$Methods$$

ImGearHPGL Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace : ImGearHPGL Class

For a list of all members of this type, see ImGearHPGL members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateHPGLFormat | Overloaded. Creates an instance of HPGL format.
Top
See Also

Reference

ImGearHPGL Class
ImageGear.Formats.HPGL Namespace


CreateHPGLFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace > ImGearHPGL Class : CreateHPGLFormat Method
Creates an instance of HPGL format.
Overload List
Overload | Description
CreateHPGLFormat() | Creates an instance of HPGL format.
CreateHPGLFormat(String) | Creates an instance of HPGL format, using the specified library path.
See Also

Reference

ImGearHPGL Class
ImGearHPGL Members


CreateHPGLFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace > ImGearHPGL Class > CreateHPGLFormat Method : CreateHPGLFormat() Method
Creates an instance of HPGL format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateHPGLFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearHPGL.CreateHPGLFormat()
public static IImGearFormat CreateHPGLFormat()
public: static IImGearFormat* CreateHPGLFormat();
public:
static IImGearFormat^ CreateHPGLFormat();

Return Value

An instance of HPGL format.
See Also

Reference

ImGearHPGL Class
ImGearHPGL Members
Overload List
IImGearFormat Interface


CreateHPGLFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.HPGL Namespace > ImGearHPGL Class > CreateHPGLFormat Method : CreateHPGLFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of HPGL format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateHPGLFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearHPGL.CreateHPGLFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateHPGLFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateHPGLFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateHPGLFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of HPGL format.
See Also

Reference

ImGearHPGL Class
ImGearHPGL Members
Overload List
IImGearFormat Interface


ImageGear.Formats.SVG Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.SVG Namespace
This namespace provides API to create SVG vector format.
Classes
 | Class | Description
Class | ImGearSVG | Provides SVG specific features, such as creating an instance of SVG format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.SVG Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.SVG Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.SVG.ImGearSVG
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearSVG Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.SVG Namespace : ImGearSVG Class
Provides SVG specific features, such as creating an instance of SVG format.
Object Model
ImGearSVG ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ImGearSVG
'Usage

Dim instance As ImGearSVG
public static class ImGearSVG
public __gc abstract __sealed class ImGearSVG
public ref class ImGearSVG abstract sealed
Remarks
Please call CreateSvgFormat prior to using any other functionality, to be able to work with SVG files.
Inheritance Hierarchy

System.Object
ImageGear.Formats.SVG.ImGearSVG

See Also

Reference

ImGearSVG Members
ImageGear.Formats.SVG Namespace


%%PageItemTitle%% $$Members$$

ImGearSVG Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.SVG Namespace : ImGearSVG Class

The following tables list the members exposed by ImGearSVG.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateSvgFormat | Creates an instance of SVG format.
Top
See Also

Reference

ImGearSVG Class
ImageGear.Formats.SVG Namespace


%%PageItemTitle%% $$Methods$$

ImGearSVG Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.SVG Namespace : ImGearSVG Class

For a list of all members of this type, see ImGearSVG members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateSvgFormat | Creates an instance of SVG format.
Top
See Also

Reference

ImGearSVG Class
ImageGear.Formats.SVG Namespace


CreateSvgFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.SVG Namespace > ImGearSVG Class : CreateSvgFormat Method
Creates an instance of SVG format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateSvgFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearSVG.CreateSvgFormat()
public static IImGearFormat CreateSvgFormat()
public: static IImGearFormat* CreateSvgFormat();
public:
static IImGearFormat^ CreateSvgFormat();

Return Value

An instance of SVG format.
See Also

Reference

ImGearSVG Class
ImGearSVG Members
IImGearFormat Interface


ImageGear.Formats.U3D Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.U3D Namespace
This namespace provides the API to create U3D vector format. ImageGear U3D namespace provides read and write support for the following features of Universal 3D format: CLOD Progressive Mesh, Normals, Colors (diffuse and specular), Views, Lights, Textures, Transparency, Linesets, and Pointsets.
Classes
 | Class | Description
Class | ImGearU3D | Provides U3D specific features, such as creating an instance of U3D format.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Formats.U3D Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Formats.U3D Namespace
Inheritance Hierarchy
System.Object
ImageGear.Formats.U3D.ImGearU3D
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGearU3D Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace : ImGearU3D Class
Provides U3D specific features, such as creating an instance of U3D format.
Object Model
ImGearU3D ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearU3D
'Usage

Dim instance As ImGearU3D
public sealed class ImGearU3D
public __gc __sealed class ImGearU3D
public ref class ImGearU3D sealed
Inheritance Hierarchy

System.Object
ImageGear.Formats.U3D.ImGearU3D

See Also

Reference

ImGearU3D Members
ImageGear.Formats.U3D Namespace


%%PageItemTitle%% $$Members$$

ImGearU3D Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace : ImGearU3D Class

The following tables list the members exposed by ImGearU3D.

Public Constructors
 | Name | Description
Public Constructor | ImGearU3D Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateU3DFormat | Overloaded. Creates an instance of U3D format.
Top
See Also

Reference

ImGearU3D Class
ImageGear.Formats.U3D Namespace


%%PageItemTitle%%

ImGearU3D Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace > ImGearU3D Class : ImGearU3D Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearU3D()
public ImGearU3D()
public: ImGearU3D();
public:
ImGearU3D();
See Also

Reference

ImGearU3D Class
ImGearU3D Members


%%PageItemTitle%% $$Methods$$

ImGearU3D Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace : ImGearU3D Class

For a list of all members of this type, see ImGearU3D members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateU3DFormat | Overloaded. Creates an instance of U3D format.
Top
See Also

Reference

ImGearU3D Class
ImageGear.Formats.U3D Namespace


CreateU3DFormat Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace > ImGearU3D Class : CreateU3DFormat Method
Creates an instance of U3D format.
Overload List
Overload | Description
CreateU3DFormat() | Creates an instance of U3D format.
CreateU3DFormat(String) | Creates an instance of U3D format, using the specified library path.
See Also

Reference

ImGearU3D Class
ImGearU3D Members


CreateU3DFormat() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace > ImGearU3D Class > CreateU3DFormat Method : CreateU3DFormat() Method
Creates an instance of U3D format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateU3DFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearU3D.CreateU3DFormat()
public static IImGearFormat CreateU3DFormat()
public: static IImGearFormat* CreateU3DFormat();
public:
static IImGearFormat^ CreateU3DFormat();

Return Value

An instance of U3D format.
See Also

Reference

ImGearU3D Class
ImGearU3D Members
Overload List
IImGearFormat Interface


CreateU3DFormat(String) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Formats.U3D Namespace > ImGearU3D Class > CreateU3DFormat Method : CreateU3DFormat(String) Method
Path to a folder to load the native library from.
Creates an instance of U3D format, using the specified library path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Shared Function CreateU3DFormat( _
   ByVal libraryPath As String _
) As IImGearFormat
'Usage

Dim libraryPath As String
Dim value As IImGearFormat

value = ImGearU3D.CreateU3DFormat(libraryPath)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public static IImGearFormat CreateU3DFormat(
   string libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: static IImGearFormat* CreateU3DFormat(
   string* libraryPath
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
static IImGearFormat^ CreateU3DFormat(
   String^ libraryPath
)

Parameters

libraryPath
Path to a folder to load the native library from.

Return Value

An instance of U3D format.
See Also

Reference

ImGearU3D Class
ImGearU3D Members
Overload List
IImGearFormat Interface


ImageGear.Vector Namespace
Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Vector Namespace

ImageGear.Vector namespace provides objects and methods for displaying, rasterizing, and manipulating vector drawings. Such drawings can be loaded from vector files such as DWF, DWG/DXF, DGN, CGM, HPGL, and U3D.

Classes
 | Class | Description
Class | ImGear3DVisualization | Provides 3D visualization API.
Class | ImGear3DVisualizationVerifier | This object provides CanApplyGenerateIsosurface method to determine whether an ImageGear.Core.ImGearDocument class object can be used to calculate isosurface from.
Class | ImGearIsosurfaceOptions | Contains parameters for the isosurface algorithm.
Class | ImGearVectorData | Represents a collection of vector entities, layers, and views.
Class | ImGearVectorEntity | Represents the base class for all entities. It provides access to the common entity features.
Class | ImGearVectorEntityArc | Represents an elliptical arc that is defined by radii and angles.
Class | ImGearVectorEntityBeziercurve | Represents a Bezier curve that is defined by control points and curve degree.
Class | ImGearVectorEntityBeziersurface | Represents a Bezier surface.
Class | ImGearVectorEntityBlock | This entity includes a container with other entities.
Class | ImGearVectorEntityConnection | Represents a special entity that is used to connect end and start points of neighboring entities in the figure entity container.
Class | ImGearVectorEntityCont | This object is used by blocks and figures to keep its entities.
Class | ImGearVectorEntityEasyline | This entity represent a line specified by start and end point.
Class | ImGearVectorEntityEasysurface | Represents a surface that is drawn exactly by its control points.
Class | ImGearVectorEntityEllipse | Represents an ellipse.
Class | ImGearVectorEntityFigure | Represents an entity that contains several regions. Any region can include other entities such as lines, polylines, arcs and other entities.
Class | ImGearVectorEntityGeometry | Represents a set of drawing primitives such as points, independent line segments, connected line segments, independent and connected triangles, independent and connected quadrilaterals, or polygons.
Class | ImGearVectorEntityInsertion | Represents a transformation wrapper for the block.
Class | ImGearVectorEntityNURBScurve | Represents non-uniform rational bi-spline curve.
Class | ImGearVectorEntityNURBSsurface | Represents a non-uniform rational B-spline surface.
Class | ImGearVectorEntityPolyline | Represents a polyline.
Class | ImGearVectorEntityPolylineEx | Represents extended polyline.
Class | ImGearVectorEntityRaster | Represents a non-rectangular raster image.
Class | ImGearVectorEntitySolid | Represents a quadrangle.
Class | ImGearVectorEntitySplinesurface | Base class for NURBS and Bezier surfaces.
Class | ImGearVectorEntityText | Represents a text string.
Class | ImGearVectorEntityViewport | Represents a viewport.
Class | ImGearVectorFilltype | Represents the fill type for drawing filled objects.
Class | ImGearVectorFloatCont | Represents the container for floating point values.
Class | ImGearVectorFont | Represents the font for the text drawing.
Class | ImGearVectorGradient | This class is used as the base for particular gradient filling classes.
Class | ImGearVectorGradientLinear | Represents a linear gradient object.
Class | ImGearVectorGradientRadial | Represents a radial gradient object.
Class | ImGearVectorHatch | Represents a vector hatch.
Class | ImGearVectorHatchline | Represents the line segment for the vector hatch.
Class | ImGearVectorLayer | Contains drawing attributes that can be applied to several entities.
Class | ImGearVectorLightSource | Implements a light source.
Class | ImGearVectorLinetype | Represents the line type.
Class | ImGearVectorObject | Base class for all vector objects. It implements one read/only property Handle property that returns an internal handle of the object.
Class | ImGearVectorRotation | Provides rotation operations for the ImGearVectorEntityViewport object.
Class | ImGearVectorTextObject | Contains a part of a text string that uses particular set of font attributes.
Class | ImGearVectorVertexCont | Represents a vertex container.
Class | ImGearVectorView | Represents a camera and lighting model for displaying the vector content.
Class | ImGearVectPage | This object represents a vector page which has a background and an ImGearVectorData vector drawing.
Structures
 | Structure | Description
Structure | ImGearVectorColor | Represents a color.
Structure | ImGearVectorColorEx | Represents an extended color.
Structure | ImGearVectorMinMax | Represents a bounding parallelepiped of the object.
Structure | ImGearVectorPoint2D | Represents a two-dimentional point.
Structure | ImGearVectorPoint3D | Represents a three-dimentional point.
Structure | ImGearVectorPoint3DEx | Represents an extended three-dimentional point.
Structure | ImGearVectorVertex | Represents a vertex.
Enumerations
 | Enumeration | Description
Enumeration | ImGearVectAlignment | Specifies text alignment.
Enumeration | ImGearVectArcCloseType | Specifies arc closing type.
Enumeration | ImGearVectAttrib | Specifies different entity attributes.
Enumeration | ImGearVectAttrSource | Specifies sources of the entity attributes.
Enumeration | ImGearVectCullFace | Specifies face culling modes.
Enumeration | ImGearVectDir | Specifies direction of rotate operations.
Enumeration | ImGearVectEntities | Specifies the type of the entity.
Enumeration | ImGearVectFillMode | Specifies the winding rule for the complete polygons.
Enumeration | ImGearVectFillPattern | Specifies constants describing different fill patterns.
Enumeration | ImGearVectGeometryType | Specifies the type of geometry primitives.
Enumeration | ImGearVectGradientSpreadMethod | Specifies gradient spread methods.
Enumeration | ImGearVectGradientType | Specifies types of gradient filling.
Enumeration | ImGearVectGraphics | Specifies the type of the vector graphics to be used for displaying vector data.
Enumeration | ImGearVectMeasurementUnits | Specifies measurement units used by vector drawings.
Enumeration | ImGearVectNURBSFlags | Specifies different flags for NURBS curve and surface.
Enumeration | ImGearVectObjType | These constants define vector object types.
Enumeration | ImGearVectTxtFlags | Specifies different text object effects.
Enumeration | ImGearVectVertexData | Specifies the type of additional data associated with the vertex.
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Vector Namespace Inheritance Hierarchy
ImageGear22.Formats.Vector Assembly : ImageGear.Vector Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Vector.ImGearVectPage
ImageGear.Vector.ImGear3DVisualization
ImageGear.Vector.ImGear3DVisualizationVerifier
ImageGear.Vector.ImGearIsosurfaceOptions
ImageGear.Vector.ImGearVectorData
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityArc
ImageGear.Vector.ImGearVectorEntityBeziercurve
ImageGear.Vector.ImGearVectorEntityBlock
ImageGear.Vector.ImGearVectorEntityConnection
ImageGear.Vector.ImGearVectorEntityEasyline
ImageGear.Vector.ImGearVectorEntityEasysurface
ImageGear.Vector.ImGearVectorEntityEllipse
ImageGear.Vector.ImGearVectorEntityFigure
ImageGear.Vector.ImGearVectorEntityGeometry
ImageGear.Vector.ImGearVectorEntityInsertion
ImageGear.Vector.ImGearVectorEntityNURBScurve
ImageGear.Vector.ImGearVectorEntityPolyline
ImageGear.Vector.ImGearVectorEntityPolylineEx
ImageGear.Vector.ImGearVectorEntityRaster
ImageGear.Vector.ImGearVectorEntitySolid
ImageGear.Vector.ImGearVectorEntitySplinesurface
ImageGear.Vector.ImGearVectorEntityBeziersurface
ImageGear.Vector.ImGearVectorEntityNURBSsurface
ImageGear.Vector.ImGearVectorEntityText
ImageGear.Vector.ImGearVectorEntityViewport
ImageGear.Vector.ImGearVectorEntityCont
ImageGear.Vector.ImGearVectorFilltype
ImageGear.Vector.ImGearVectorFloatCont
ImageGear.Vector.ImGearVectorFont
ImageGear.Vector.ImGearVectorGradient
ImageGear.Vector.ImGearVectorGradientLinear
ImageGear.Vector.ImGearVectorGradientRadial
ImageGear.Vector.ImGearVectorHatch
ImageGear.Vector.ImGearVectorHatchline
ImageGear.Vector.ImGearVectorLayer
ImageGear.Vector.ImGearVectorLightSource
ImageGear.Vector.ImGearVectorLinetype
ImageGear.Vector.ImGearVectorRotation
ImageGear.Vector.ImGearVectorTextObject
ImageGear.Vector.ImGearVectorVertexCont
ImageGear.Vector.ImGearVectorView
System.ValueType
ImageGear.Vector.ImGearVectorColor
ImageGear.Vector.ImGearVectorColorEx
ImageGear.Vector.ImGearVectorMinMax
ImageGear.Vector.ImGearVectorPoint2D
ImageGear.Vector.ImGearVectorPoint3D
ImageGear.Vector.ImGearVectorPoint3DEx
ImageGear.Vector.ImGearVectorVertex
See Also

Reference

ImageGear22.Formats.Vector Assembly


%%PageItemTitle%%

ImGear3DVisualization Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualization Class
Provides 3D visualization API.
Object Model
ImGear3DVisualization ClassImGearVectPage ClassImGear3DVisualizationVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGear3DVisualization
'Usage

Dim instance As ImGear3DVisualization
public sealed class ImGear3DVisualization
public __gc __sealed class ImGear3DVisualization
public ref class ImGear3DVisualization sealed
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGear3DVisualization

See Also

Reference

ImGear3DVisualization Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGear3DVisualization Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualization Class

The following tables list the members exposed by ImGear3DVisualization.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets an object of type ImGear3DVisualizationVerifier class. This object can be used to verify whether an ImageGear.Core.ImGearDocument class can be used to calculate isosurface from.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GenerateIsosurface | This method takes an ImageGear.Core.ImGearDocument class object and extracts the 3D isosurface into a vector page.
Top
See Also

Reference

ImGear3DVisualization Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGear3DVisualization Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualization Class

For a list of all members of this type, see ImGear3DVisualization members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GenerateIsosurface | This method takes an ImageGear.Core.ImGearDocument class object and extracts the 3D isosurface into a vector page.
Top
See Also

Reference

ImGear3DVisualization Class
ImageGear.Vector Namespace


GenerateIsosurface Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGear3DVisualization Class : GenerateIsosurface Method
An ImageGear.Core.ImGearDocument class object, which has slices of images in a 3D series stacked together in the desired order.
An ImGearIsosurfaceOptions class object, which has all the calculation options for isosurface algorithm.
This method takes an ImageGear.Core.ImGearDocument class object and extracts the 3D isosurface into a vector page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GenerateIsosurface( _
   ByVal document As ImGearDocument, _
   ByVal isoOptions As ImGearIsosurfaceOptions _
) As ImGearVectPage
'Usage

Dim document As ImGearDocument
Dim isoOptions As ImGearIsosurfaceOptions
Dim value As ImGearVectPage

value = ImGear3DVisualization.GenerateIsosurface(document, isoOptions)
public static ImGearVectPage GenerateIsosurface(
   ImGearDocument document,
   ImGearIsosurfaceOptions isoOptions
)
public: static ImGearVectPage* GenerateIsosurface(
   ImGearDocument* document,
   ImGearIsosurfaceOptions* isoOptions
)
public:
static ImGearVectPage^ GenerateIsosurface(
   ImGearDocument^ document,
   ImGearIsosurfaceOptions^ isoOptions
)

Parameters

document
An ImageGear.Core.ImGearDocument class object, which has slices of images in a 3D series stacked together in the desired order.
isoOptions
An ImGearIsosurfaceOptions class object, which has all the calculation options for isosurface algorithm.

Return Value

Returns an ImGearVectPage class object, which contains data for the generated isosurface.
See Also

Reference

ImGear3DVisualization Class
ImGear3DVisualization Members
ImGearDocument Class
ImGearIsosurfaceOptions Class
ImGearVectPage Class


%%PageItemTitle%% $$Properties$$

ImGear3DVisualization Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualization Class

For a list of all members of this type, see ImGear3DVisualization members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets an object of type ImGear3DVisualizationVerifier class. This object can be used to verify whether an ImageGear.Core.ImGearDocument class can be used to calculate isosurface from.
Top
See Also

Reference

ImGear3DVisualization Class
ImageGear.Vector Namespace


Verifier Property (ImGear3DVisualization)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGear3DVisualization Class : Verifier Property
Gets an object of type ImGear3DVisualizationVerifier class. This object can be used to verify whether an ImageGear.Core.ImGearDocument class can be used to calculate isosurface from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGear3DVisualizationVerifier
'Usage

Dim value As ImGear3DVisualizationVerifier

value = ImGear3DVisualization.Verifier
public static ImGear3DVisualizationVerifier Verifier {get;}
public: __property static ImGear3DVisualizationVerifier* get_Verifier();
public:
static property ImGear3DVisualizationVerifier^ Verifier {
   ImGear3DVisualizationVerifier^ get();
}

Property Value

An instance of ImGear3DVisualizationVerifier class object.
See Also

Reference

ImGear3DVisualization Class
ImGear3DVisualization Members


%%PageItemTitle%%

ImGear3DVisualizationVerifier Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualizationVerifier Class
This object provides CanApplyGenerateIsosurface method to determine whether an ImageGear.Core.ImGearDocument class object can be used to calculate isosurface from.
Object Model
ImGear3DVisualizationVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGear3DVisualizationVerifier
'Usage

Dim instance As ImGear3DVisualizationVerifier
public sealed class ImGear3DVisualizationVerifier
public __gc __sealed class ImGear3DVisualizationVerifier
public ref class ImGear3DVisualizationVerifier sealed
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGear3DVisualizationVerifier

See Also

Reference

ImGear3DVisualizationVerifier Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGear3DVisualizationVerifier Class Members
Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualizationVerifier Class

The following tables list the members exposed by ImGear3DVisualizationVerifier.

Public Methods
Name Description
Public Method CanApplyGenerateIsosurface This method takes an ImageGear.Core.ImGearDocument class object and determines whether ImGear3DVisualization.GenerateIsosurface method can be applied to it to calculate an isosurface. It checks to make sure the following are all satisfied:
  • The ImageGear.Core.ImGearDocument class object is valid.
  • There is more than one page in the ImageGear.Core.ImGearDocument class object.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same width and height.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same color space.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same bits per channel.
  • The "bits per channel" in the pages is one of the supported depths, i.e., 8, 16, or 32.
Top
See Also

Reference

ImGear3DVisualizationVerifier Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGear3DVisualizationVerifier Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGear3DVisualizationVerifier Class

For a list of all members of this type, see ImGear3DVisualizationVerifier members.

Public Methods
Name Description
Public Method CanApplyGenerateIsosurface This method takes an ImageGear.Core.ImGearDocument class object and determines whether ImGear3DVisualization.GenerateIsosurface method can be applied to it to calculate an isosurface. It checks to make sure the following are all satisfied:
  • The ImageGear.Core.ImGearDocument class object is valid.
  • There is more than one page in the ImageGear.Core.ImGearDocument class object.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same width and height.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same color space.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same bits per channel.
  • The "bits per channel" in the pages is one of the supported depths, i.e., 8, 16, or 32.
Top
See Also

Reference

ImGear3DVisualizationVerifier Class
ImageGear.Vector Namespace


CanApplyGenerateIsosurface Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGear3DVisualizationVerifier Class : CanApplyGenerateIsosurface Method
The ImageGear.Core.ImGearDocument class object to determine whether ImGear3DVisualization.GenerateIsosurface method() can be applied to.
This method takes an ImageGear.Core.ImGearDocument class object and determines whether ImGear3DVisualization.GenerateIsosurface method can be applied to it to calculate an isosurface. It checks to make sure the following are all satisfied:
  • The ImageGear.Core.ImGearDocument class object is valid.
  • There is more than one page in the ImageGear.Core.ImGearDocument class object.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same width and height.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same color space.
  • Pages in the ImageGear.Core.ImGearDocument class object all have the same bits per channel.
  • The "bits per channel" in the pages is one of the supported depths, i.e., 8, 16, or 32.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyGenerateIsosurface( _
   ByVal document As ImGearDocument _
) As Boolean
'Usage

Dim instance As ImGear3DVisualizationVerifier
Dim document As ImGearDocument
Dim value As Boolean

value = instance.CanApplyGenerateIsosurface(document)
public bool CanApplyGenerateIsosurface(
   ImGearDocument document
)
public: bool CanApplyGenerateIsosurface(
   ImGearDocument* document
)
public:
bool CanApplyGenerateIsosurface(
   ImGearDocument^ document
)

Parameters

document
The ImageGear.Core.ImGearDocument class object to determine whether ImGear3DVisualization.GenerateIsosurface method() can be applied to.

Return Value

true if ImGear3DVisualization.GenerateIsosurface method() can be applied, false - otherwise.
See Also

Reference

ImGear3DVisualizationVerifier Class
ImGear3DVisualizationVerifier Members
ImGearDocument Class


%%PageItemTitle%%

ImGearIsosurfaceOptions Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearIsosurfaceOptions Class
Contains parameters for the isosurface algorithm.
Object Model
ImGearIsosurfaceOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearIsosurfaceOptions
'Usage

Dim instance As ImGearIsosurfaceOptions
public sealed class ImGearIsosurfaceOptions
public __gc __sealed class ImGearIsosurfaceOptions
public ref class ImGearIsosurfaceOptions sealed
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearIsosurfaceOptions

See Also

Reference

ImGearIsosurfaceOptions Members
ImageGear.Vector Namespace
GenerateIsosurface Method


%%PageItemTitle%% $$Members$$

ImGearIsosurfaceOptions Class Members
Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearIsosurfaceOptions Class

The following tables list the members exposed by ImGearIsosurfaceOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearIsosurfaceOptions Constructor | Initializes a new instance of the ImGearIsosurfaceOptions class, and initializes all its properties to default values.
Top
Public Properties
 | Name | Description
Public Property | HighExcluRange | Gets or sets the upper limit of the exclusion range.
Public Property | IsAddCoverSlices | Gets or sets a value indicating whether to add cover-up slices at the ends.
Public Property | IsDecimateY | Gets or sets a value indicating whether to decimate in Y direction when considering surface depth. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | IsDecimateZ | Gets or sets a value indicating whether to decimate in Z direction when considering surface depth. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | IsDoNorms | Gets or sets a value indicating whether to calculate normals along with vertices.
Public Property | IsFlipNorms | Gets or sets a value indicating whether to flip normals after calculation.
Public Property | IsLimitDepth | Gets or sets a value indicating whether to limit the surface depth.
Public Property | IsoValue | Gets or sets intensity value of pixels on the isosurface.
Public Property | LowExcluRange | Gets or sets the lower limit of the exclusion range.
Public Property | SurfaceDepth | Gets or sets the depth of the isosurface. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | YDecimFactor | Gets or sets the decimation factor in Y direction. NOTE: In effect only if both IsLimitDepth and IsDecimateY properties of the same ImGearIsosurfaceOptions class object are true.
Public Property | ZDecimFactor | Gets or sets a decimation factor in Z direction. NOTE: In effect only if both IsLimitDepth and IsDecimateZ properties of the same ImGearIsosurfaceOptions class object are true.
Top
See Also

Reference

ImGearIsosurfaceOptions Class
ImageGear.Vector Namespace
GenerateIsosurface Method


%%PageItemTitle%%

ImGearIsosurfaceOptions Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : ImGearIsosurfaceOptions Constructor
Initializes a new instance of the ImGearIsosurfaceOptions class, and initializes all its properties to default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearIsosurfaceOptions()
public ImGearIsosurfaceOptions()
public: ImGearIsosurfaceOptions();
public:
ImGearIsosurfaceOptions();

Return Value

A new instance of the ImGearIsosurfaceOptions class.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members
ImGearIsosurfaceOptions Class


%%PageItemTitle%% $$Properties$$

ImGearIsosurfaceOptions Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearIsosurfaceOptions Class

For a list of all members of this type, see ImGearIsosurfaceOptions members.

Public Properties
 | Name | Description
Public Property | HighExcluRange | Gets or sets the upper limit of the exclusion range.
Public Property | IsAddCoverSlices | Gets or sets a value indicating whether to add cover-up slices at the ends.
Public Property | IsDecimateY | Gets or sets a value indicating whether to decimate in Y direction when considering surface depth. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | IsDecimateZ | Gets or sets a value indicating whether to decimate in Z direction when considering surface depth. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | IsDoNorms | Gets or sets a value indicating whether to calculate normals along with vertices.
Public Property | IsFlipNorms | Gets or sets a value indicating whether to flip normals after calculation.
Public Property | IsLimitDepth | Gets or sets a value indicating whether to limit the surface depth.
Public Property | IsoValue | Gets or sets intensity value of pixels on the isosurface.
Public Property | LowExcluRange | Gets or sets the lower limit of the exclusion range.
Public Property | SurfaceDepth | Gets or sets the depth of the isosurface. NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.
Public Property | YDecimFactor | Gets or sets the decimation factor in Y direction. NOTE: In effect only if both IsLimitDepth and IsDecimateY properties of the same ImGearIsosurfaceOptions class object are true.
Public Property | ZDecimFactor | Gets or sets a decimation factor in Z direction. NOTE: In effect only if both IsLimitDepth and IsDecimateZ properties of the same ImGearIsosurfaceOptions class object are true.
Top
See Also

Reference

ImGearIsosurfaceOptions Class
ImageGear.Vector Namespace
GenerateIsosurface Method


HighExcluRange Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : HighExcluRange Property
Gets or sets the upper limit of the exclusion range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighExcluRange As Integer
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Integer

instance.HighExcluRange = value

value = instance.HighExcluRange
public int HighExcluRange {get; set;}
public: __property int get_HighExcluRange();
public: __property void set_HighExcluRange(
   int value
);
public:
property int HighExcluRange {
   int get();
   void set (    int value);
}

Property Value

Any valid integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsAddCoverSlices Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsAddCoverSlices Property
Gets or sets a value indicating whether to add cover-up slices at the ends.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsAddCoverSlices As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsAddCoverSlices = value

value = instance.IsAddCoverSlices
public bool IsAddCoverSlices {get; set;}
public: __property bool get_IsAddCoverSlices();
public: __property void set_IsAddCoverSlices(
   bool value
);
public:
property bool IsAddCoverSlices {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsDecimateY Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsDecimateY Property
Gets or sets a value indicating whether to decimate in Y direction when considering surface depth.

NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsDecimateY As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsDecimateY = value

value = instance.IsDecimateY
public bool IsDecimateY {get; set;}
public: __property bool get_IsDecimateY();
public: __property void set_IsDecimateY(
   bool value
);
public:
property bool IsDecimateY {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsDecimateZ Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsDecimateZ Property
Gets or sets a value indicating whether to decimate in Z direction when considering surface depth.

NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsDecimateZ As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsDecimateZ = value

value = instance.IsDecimateZ
public bool IsDecimateZ {get; set;}
public: __property bool get_IsDecimateZ();
public: __property void set_IsDecimateZ(
   bool value
);
public:
property bool IsDecimateZ {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsDoNorms Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsDoNorms Property
Gets or sets a value indicating whether to calculate normals along with vertices.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsDoNorms As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsDoNorms = value

value = instance.IsDoNorms
public bool IsDoNorms {get; set;}
public: __property bool get_IsDoNorms();
public: __property void set_IsDoNorms(
   bool value
);
public:
property bool IsDoNorms {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsFlipNorms Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsFlipNorms Property
Gets or sets a value indicating whether to flip normals after calculation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsFlipNorms As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsFlipNorms = value

value = instance.IsFlipNorms
public bool IsFlipNorms {get; set;}
public: __property bool get_IsFlipNorms();
public: __property void set_IsFlipNorms(
   bool value
);
public:
property bool IsFlipNorms {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsLimitDepth Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsLimitDepth Property
Gets or sets a value indicating whether to limit the surface depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsLimitDepth As Boolean
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Boolean

instance.IsLimitDepth = value

value = instance.IsLimitDepth
public bool IsLimitDepth {get; set;}
public: __property bool get_IsLimitDepth();
public: __property void set_IsLimitDepth(
   bool value
);
public:
property bool IsLimitDepth {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


IsoValue Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : IsoValue Property
Gets or sets intensity value of pixels on the isosurface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsoValue As Double
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Double

instance.IsoValue = value

value = instance.IsoValue
public double IsoValue {get; set;}
public: __property double get_IsoValue();
public: __property void set_IsoValue(
   double value
);
public:
property double IsoValue {
   double get();
   void set (    double value);
}

Property Value

Any valid double value.
Remarks
The default value is 120.0.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


LowExcluRange Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : LowExcluRange Property
Gets or sets the lower limit of the exclusion range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LowExcluRange As Integer
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Integer

instance.LowExcluRange = value

value = instance.LowExcluRange
public int LowExcluRange {get; set;}
public: __property int get_LowExcluRange();
public: __property void set_LowExcluRange(
   int value
);
public:
property int LowExcluRange {
   int get();
   void set (    int value);
}

Property Value

Any valid integer value.
Remarks
The default value is 0.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


SurfaceDepth Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : SurfaceDepth Property
Gets or sets the depth of the isosurface.

NOTE: In effect only if IsLimitDepth property of the same ImGearIsosurfaceOptions class object is true.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SurfaceDepth As Integer
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Integer

instance.SurfaceDepth = value

value = instance.SurfaceDepth
public int SurfaceDepth {get; set;}
public: __property int get_SurfaceDepth();
public: __property void set_SurfaceDepth(
   int value
);
public:
property int SurfaceDepth {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
Remarks
The default value is 20.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


YDecimFactor Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : YDecimFactor Property
Gets or sets the decimation factor in Y direction.

NOTE: In effect only if both IsLimitDepth and IsDecimateY properties of the same ImGearIsosurfaceOptions class object are true.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YDecimFactor As Integer
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Integer

instance.YDecimFactor = value

value = instance.YDecimFactor
public int YDecimFactor {get; set;}
public: __property int get_YDecimFactor();
public: __property void set_YDecimFactor(
   int value
);
public:
property int YDecimFactor {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


ZDecimFactor Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearIsosurfaceOptions Class : ZDecimFactor Property
Gets or sets a decimation factor in Z direction.

NOTE: In effect only if both IsLimitDepth and IsDecimateZ properties of the same ImGearIsosurfaceOptions class object are true.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZDecimFactor As Integer
'Usage

Dim instance As ImGearIsosurfaceOptions
Dim value As Integer

instance.ZDecimFactor = value

value = instance.ZDecimFactor
public int ZDecimFactor {get; set;}
public: __property int get_ZDecimFactor();
public: __property void set_ZDecimFactor(
   int value
);
public:
property int ZDecimFactor {
   int get();
   void set (    int value);
}

Property Value

Any integer value.
Remarks
The default value is 1.
See Also

Reference

ImGearIsosurfaceOptions Class
ImGearIsosurfaceOptions Members


%%PageItemTitle%%

ImGearVectorData Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorData Class
Represents a collection of vector entities, layers, and views.
Object Model
ImGearVectorData ClassImGearVectorEntity ClassImGearVectorFont ClassImGearVectorLayer ClassImGearVectorView ClassImGearVectorFont ClassImGearVectorLayer ClassImGearVectorEntity ClassImGearVectorEntity ClassImGearVectorFilltype ClassImGearVectorFont ClassImGearVectorLayer ClassImGearVectorLinetype ClassImGearVectorEntityCont ClassImGearVectorColor StructureImGearVectorView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Class ImGearVectorData
'Usage

Dim instance As ImGearVectorData
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public class ImGearVectorData
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public __gc class ImGearVectorData
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public ref class ImGearVectorData
Remarks
Vector data is created when reading vector files such as DWG/DXF, DGN, CGM, HPGL, and U3D. Vector data is attached to ImGearVectPage class and draws its content itself during display operations.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorData

See Also

Reference

ImGearVectorData Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorData Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorData Class

The following tables list the members exposed by ImGearVectorData.

Public Constructors
 | Name | Description
Public Constructor | ImGearVectorData Constructor | Initializes a new instance of the ImGearVectorData class.
Top
Public Properties
 | Name | Description
Public Property | ActiveViewIndex | Gets or sets an index of the active view.
Public Property | FilltypeCount | Gets total count of fill types in the internal filltype container.
Public Property | FontCount | Gets a total count of fonts in the internal container.
Public Property | GraphicsType | Gets or sets the type of graphics used for displaying vector objects.
Public Property | LayerCount | Gets the total count of layers in the internal container.
Public Property | LinetypeCount | Gets total line type count in the internal line type container.
Public Property | SelectionThickness | Gets or sets the thickness that is used for displaying selected entities.
Public Property | Transparency | Gets or sets a value indicating whether the transparency is enabled.
Public Property | Units | Gets or sets measurement units used by the vector drawing.
Public Property | UnitsFactor | Gets or sets a units factor, that is, a multiplier of unit values.
Public Property | ViewCount | Gets total count of views in the drawing.
Top
Public Methods
 | Name | Description
Public Method | CreateEntity | Creates an entity of the specified type.
Public Method | CreateFont | Creates a font by typeface and weight.
Public Method | CreateGradientFilltype | Creates new fill type with the gradient object specified by gradient name and type.
Public Method | CreateLayer | Creates a new layer.
Public Method | CreateView | Creates a new View and adds it to the end of the view container.
Public Method | DeleteView | Removes the specified View from the internal view container and destroys it.
Public Method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | FindEntityIndex | Looks for an entity with the specified ID.
Public Method | FindFont | Looks for the font with the specified typeface, weight and vector flag.
Public Method | FindLayer | Looks for a layer by name.
Public Method | GetActualGraphics | Returns the type of graphics used for displaying vector objects.
Public Method | GetContent | Returns the main content of the drawing. This is always a block.
Public Method | GetEntity | Returns an entity from the specified position in the internal container.
Public Method | GetFilltype | Returns fill type by its position in the internal container.
Public Method | GetFilltypeIndex | Returns an index of the fill type in the internal container by fill pattern.
Public Method | GetFont | Returns a font by its position in the internal conatiner.
Public Method | GetFontIndex | Returns an index of the specified font in the internal font container.
Public Method | GetGradientFilltypeIndex | Returns index of the fill type associated with the specified gradient object.
Public Method | GetHatchFilltypeIndex | Returns an index of the hatch fill type by the hatch name.
Public Method | GetLayer | Returns a layer by its position in the internal container.
Public Method | GetLinetype | Returns a line type by its position in the internal container.
Public Method | GetLinetypeIndex | Returns the index of the line type in the internal container by the line pattern and pattern length.
Public Method | GetSelection | Looks for the entity that corresponds to the specified device coordinates.
Public Method | GetSelectionColor | Returns the color that is used for displaying entities being selected.
Public Method | GetView | Returns a view from the specified index.
Public Method | Init | Initializes vector content to an empty drawing, discarding any vector entities if they are present.
Public Method | SetSelectionColor | Sets the color that is used for displaying selected entities.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearVectorData class.
Top
See Also

Reference

ImGearVectorData Class
ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectorData Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : ImGearVectorData Constructor
Initializes a new instance of the ImGearVectorData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearVectorData()
public ImGearVectorData()
public: ImGearVectorData();
public:
ImGearVectorData();

Return Value

A new instance of the ImGearVectorData class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectorData Class


%%PageItemTitle%% $$Methods$$

ImGearVectorData Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorData Class

For a list of all members of this type, see ImGearVectorData members.

Public Methods
 | Name | Description
Public Method | CreateEntity | Creates an entity of the specified type.
Public Method | CreateFont | Creates a font by typeface and weight.
Public Method | CreateGradientFilltype | Creates new fill type with the gradient object specified by gradient name and type.
Public Method | CreateLayer | Creates a new layer.
Public Method | CreateView | Creates a new View and adds it to the end of the view container.
Public Method | DeleteView | Removes the specified View from the internal view container and destroys it.
Public Method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | FindEntityIndex | Looks for an entity with the specified ID.
Public Method | FindFont | Looks for the font with the specified typeface, weight and vector flag.
Public Method | FindLayer | Looks for a layer by name.
Public Method | GetActualGraphics | Returns the type of graphics used for displaying vector objects.
Public Method | GetContent | Returns the main content of the drawing. This is always a block.
Public Method | GetEntity | Returns an entity from the specified position in the internal container.
Public Method | GetFilltype | Returns fill type by its position in the internal container.
Public Method | GetFilltypeIndex | Returns an index of the fill type in the internal container by fill pattern.
Public Method | GetFont | Returns a font by its position in the internal conatiner.
Public Method | GetFontIndex | Returns an index of the specified font in the internal font container.
Public Method | GetGradientFilltypeIndex | Returns index of the fill type associated with the specified gradient object.
Public Method | GetHatchFilltypeIndex | Returns an index of the hatch fill type by the hatch name.
Public Method | GetLayer | Returns a layer by its position in the internal container.
Public Method | GetLinetype | Returns a line type by its position in the internal container.
Public Method | GetLinetypeIndex | Returns the index of the line type in the internal container by the line pattern and pattern length.
Public Method | GetSelection | Looks for the entity that corresponds to the specified device coordinates.
Public Method | GetSelectionColor | Returns the color that is used for displaying entities being selected.
Public Method | GetView | Returns a view from the specified index.
Public Method | Init | Initializes vector content to an empty drawing, discarding any vector entities if they are present.
Public Method | SetSelectionColor | Sets the color that is used for displaying selected entities.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearVectorData class.
Top
See Also

Reference

ImGearVectorData Class
ImageGear.Vector Namespace


CreateEntity Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : CreateEntity Method
Type of the entity to be created.
Creates an entity of the specified type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateEntity( _
   ByVal entityType As ImGearVectEntities _
) As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorData
Dim entityType As ImGearVectEntities
Dim value As ImGearVectorEntity

value = instance.CreateEntity(entityType)
public ImGearVectorEntity CreateEntity(
   ImGearVectEntities entityType
)
public: ImGearVectorEntity* CreateEntity(
   ImGearVectEntities entityType
)
public:
ImGearVectorEntity^ CreateEntity(
   ImGearVectEntities entityType
)

Parameters

entityType
Type of the entity to be created.

Return Value

New instance of ImGearVectorEntity class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectorEntity Class
ImGearVectEntities Enumeration


CreateFont Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : CreateFont Method
Typeface of the font.
Font weight.
Flag that tells whether Vector or TrueType font is to be created.
Creates a font by typeface and weight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateFont( _
   ByVal typeface As String, _
   ByVal weight As Integer, _
   ByVal isVector As Boolean _
) As ImGearVectorFont
'Usage

Dim instance As ImGearVectorData
Dim typeface As String
Dim weight As Integer
Dim isVector As Boolean
Dim value As ImGearVectorFont

value = instance.CreateFont(typeface, weight, isVector)
public ImGearVectorFont CreateFont(
   string typeface,
   int weight,
   bool isVector
)
public: ImGearVectorFont* CreateFont(
   string* typeface,
   int weight,
   bool isVector
)
public:
ImGearVectorFont^ CreateFont(
   String^ typeface,
   int weight,
   bool isVector
)

Parameters

typeface
Typeface of the font.
weight
Font weight.
isVector
Flag that tells whether Vector or TrueType font is to be created.

Return Value

New instance of ImGearVectorFont class.
Remarks
If isVector is true then an empty vector font is created. The user is responsible for creating every glyph of such font. Otherwise, a complete TrueType font is created.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectorFont Class


CreateGradientFilltype Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : CreateGradientFilltype Method
Name of the gradient fill type to be created.
Gradient fill type.
Creates new fill type with the gradient object specified by gradient name and type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateGradientFilltype( _
   ByVal gradientName As String, _
   ByVal gradientType As ImGearVectGradientType _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim gradientName As String
Dim gradientType As ImGearVectGradientType
Dim value As Integer

value = instance.CreateGradientFilltype(gradientName, gradientType)
public int CreateGradientFilltype(
   string gradientName,
   ImGearVectGradientType gradientType
)
public: int CreateGradientFilltype(
   string* gradientName,
   ImGearVectGradientType gradientType
)
public:
int CreateGradientFilltype(
   String^ gradientName,
   ImGearVectGradientType gradientType
)

Parameters

gradientName
Name of the gradient fill type to be created.
gradientType
Gradient fill type.

Return Value

Index of the new gradient fill type.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


CreateLayer Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : CreateLayer Method
The name of the newly created layer.
Creates a new layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateLayer( _
   ByVal layerName As String _
) As ImGearVectorLayer
'Usage

Dim instance As ImGearVectorData
Dim layerName As String
Dim value As ImGearVectorLayer

value = instance.CreateLayer(layerName)
public ImGearVectorLayer CreateLayer(
   string layerName
)
public: ImGearVectorLayer* CreateLayer(
   string* layerName
)
public:
ImGearVectorLayer^ CreateLayer(
   String^ layerName
)

Parameters

layerName
The name of the newly created layer.

Return Value

A new instance of ImGearVectorLayer class object.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


CreateView Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : CreateView Method
Creates a new View and adds it to the end of the view container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateView() As ImGearVectorView
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectorView

value = instance.CreateView()
public ImGearVectorView CreateView()
public: ImGearVectorView* CreateView();
public:
ImGearVectorView^ CreateView();

Return Value

New instance of ImGearVectorView class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
DeleteView Method


DeleteView Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : DeleteView Method
Index of View to be removed.
Removes the specified View from the internal view container and destroys it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteView( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorData
Dim index As Integer

instance.DeleteView(index)
public void DeleteView(
   int index
)
public: void DeleteView(
   int index
)
public:
void DeleteView(
   int index
)

Parameters

index
Index of View to be removed.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
CreateView Method
ImGearVectorView Class


Dispose Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Overload List
Overload | Description
Dispose(Boolean) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Dispose() | Standard .NET Dispose method. To minimize memory usage, it should be called before the vector page content is replaced or deleted.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


Dispose(Boolean) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class > Dispose Method : Dispose(Boolean) Method
Value indicating whether the vector data should be destroyed.
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub Dispose( _
   ByVal deleteData As Boolean _
)
'Usage

Dim instance As ImGearVectorData
Dim deleteData As Boolean

instance.Dispose(deleteData)
protected void Dispose(
   bool deleteData
)
protected: void Dispose(
   bool deleteData
)
protected:
void Dispose(
   bool deleteData
)

Parameters

deleteData
Value indicating whether the vector data should be destroyed.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
Overload List


Dispose() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class > Dispose Method : Dispose() Method
Standard .NET Dispose method. To minimize memory usage, it should be called before the vector page content is replaced or deleted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Dispose()
'Usage

Dim instance As ImGearVectorData

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
Overload List


Finalize Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : Finalize Method
Finalizes an instance of the ImGearVectorData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearVectorData

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


FindEntityIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : FindEntityIndex Method
ID of the entity to find.
Start index in the internal container.
Looks for an entity with the specified ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindEntityIndex( _
   ByVal entityId As String, _
   ByVal startIndex As Integer _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim entityId As String
Dim startIndex As Integer
Dim value As Integer

value = instance.FindEntityIndex(entityId, startIndex)
public int FindEntityIndex(
   string entityId,
   int startIndex
)
public: int FindEntityIndex(
   string* entityId,
   int startIndex
)
public:
int FindEntityIndex(
   String^ entityId,
   int startIndex
)

Parameters

entityId
ID of the entity to find.
startIndex
Start index in the internal container.

Return Value

Index of the entity found, or -1 if no entity could be found.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


FindFont Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : FindFont Method
Typeface of the font.
Font weight.
Flag that tells whether font to look for is Vector or TrueType.
Looks for the font with the specified typeface, weight and vector flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindFont( _
   ByVal typeface As String, _
   ByVal weight As Integer, _
   ByVal isVector As Boolean _
) As ImGearVectorFont
'Usage

Dim instance As ImGearVectorData
Dim typeface As String
Dim weight As Integer
Dim isVector As Boolean
Dim value As ImGearVectorFont

value = instance.FindFont(typeface, weight, isVector)
public ImGearVectorFont FindFont(
   string typeface,
   int weight,
   bool isVector
)
public: ImGearVectorFont* FindFont(
   string* typeface,
   int weight,
   bool isVector
)
public:
ImGearVectorFont^ FindFont(
   String^ typeface,
   int weight,
   bool isVector
)

Parameters

typeface
Typeface of the font.
weight
Font weight.
isVector
Flag that tells whether font to look for is Vector or TrueType.

Return Value

Newly created ImGearVectorFont class object or null.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


FindLayer Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : FindLayer Method
Name of the layer to be looked for.
Looks for a layer by name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindLayer( _
   ByVal layerName As String _
) As ImGearVectorLayer
'Usage

Dim instance As ImGearVectorData
Dim layerName As String
Dim value As ImGearVectorLayer

value = instance.FindLayer(layerName)
public ImGearVectorLayer FindLayer(
   string layerName
)
public: ImGearVectorLayer* FindLayer(
   string* layerName
)
public:
ImGearVectorLayer^ FindLayer(
   String^ layerName
)

Parameters

layerName
Name of the layer to be looked for.

Return Value

New instance of ImGearVectorLayer class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetActualGraphics Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetActualGraphics Method
Device context the actual graphics is determined for.
Returns the type of graphics used for displaying vector objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetActualGraphics( _
   ByVal context As IntPtr _
) As ImGearVectGraphics
'Usage

Dim instance As ImGearVectorData
Dim context As IntPtr
Dim value As ImGearVectGraphics

value = instance.GetActualGraphics(context)
public ImGearVectGraphics GetActualGraphics(
   IntPtr context
)
public: ImGearVectGraphics GetActualGraphics(
   IntPtr context
)
public:
ImGearVectGraphics GetActualGraphics(
   IntPtr context
)

Parameters

context
Device context the actual graphics is determined for.

Return Value

Any value of ImGearVectGraphics enumeration.
Remarks
The following graphics types are available:
  • DIRECT3D - Direct3D graphics is used.
  • OPENGL - OpenGL graphics is used.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetContent Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetContent Method
Returns the main content of the drawing. This is always a block.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectorEntity

value = instance.GetContent()
public ImGearVectorEntity GetContent()
public: ImGearVectorEntity* GetContent();
public:
ImGearVectorEntity^ GetContent();

Return Value

New instance of ImGearVectorEntity class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetEntity Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetEntity Method
Position of the entity to be returned.
Returns an entity from the specified position in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEntity( _
   ByVal index As Integer _
) As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorEntity

value = instance.GetEntity(index)
public ImGearVectorEntity GetEntity(
   int index
)
public: ImGearVectorEntity* GetEntity(
   int index
)
public:
ImGearVectorEntity^ GetEntity(
   int index
)

Parameters

index
Position of the entity to be returned.

Return Value

New instance of ImGearVectorEntity class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetFilltype Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetFilltype Method
Fill type index.
Returns fill type by its position in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFilltype( _
   ByVal index As Integer _
) As ImGearVectorFilltype
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorFilltype

value = instance.GetFilltype(index)
public ImGearVectorFilltype GetFilltype(
   int index
)
public: ImGearVectorFilltype* GetFilltype(
   int index
)
public:
ImGearVectorFilltype^ GetFilltype(
   int index
)

Parameters

index
Fill type index.

Return Value

Any value of ImGearVectorFilltype class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetFilltypeIndex Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetFilltypeIndex Method
Fill pattern.
Returns an index of the fill type in the internal container by fill pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFilltypeIndex( _
   ByVal pattern As ImGearVectFillPattern _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim pattern As ImGearVectFillPattern
Dim value As Integer

value = instance.GetFilltypeIndex(pattern)
public int GetFilltypeIndex(
   ImGearVectFillPattern pattern
)
public: int GetFilltypeIndex(
   ImGearVectFillPattern pattern
)
public:
int GetFilltypeIndex(
   ImGearVectFillPattern pattern
)

Parameters

pattern
Fill pattern.

Return Value

Any integer number.
Remarks
If a fill type with such attributes does not exist, it is created.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectFillPattern Enumeration


GetFont Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetFont Method
Position of the font.
Returns a font by its position in the internal conatiner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFont( _
   ByVal index As Integer _
) As ImGearVectorFont
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorFont

value = instance.GetFont(index)
public ImGearVectorFont GetFont(
   int index
)
public: ImGearVectorFont* GetFont(
   int index
)
public:
ImGearVectorFont^ GetFont(
   int index
)

Parameters

index
Position of the font.

Return Value

New instance of ImGearVectorFont class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetFontIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetFontIndex Method
Font object the index is looked for.
Returns an index of the specified font in the internal font container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFontIndex( _
   ByVal font As ImGearVectorFont _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim font As ImGearVectorFont
Dim value As Integer

value = instance.GetFontIndex(font)
public int GetFontIndex(
   ImGearVectorFont font
)
public: int GetFontIndex(
   ImGearVectorFont* font
)
public:
int GetFontIndex(
   ImGearVectorFont^ font
)

Parameters

font
Font object the index is looked for.

Return Value

Integer value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectorFont Class


GetGradientFilltypeIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetGradientFilltypeIndex Method
Name of the fill type.
Returns index of the fill type associated with the specified gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGradientFilltypeIndex( _
   ByVal gradientName As String _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim gradientName As String
Dim value As Integer

value = instance.GetGradientFilltypeIndex(gradientName)
public int GetGradientFilltypeIndex(
   string gradientName
)
public: int GetGradientFilltypeIndex(
   string* gradientName
)
public:
int GetGradientFilltypeIndex(
   String^ gradientName
)

Parameters

gradientName
Name of the fill type.

Return Value

Index of the fill type.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetHatchFilltypeIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetHatchFilltypeIndex Method
Name of the hatch.
Returns an index of the hatch fill type by the hatch name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetHatchFilltypeIndex( _
   ByVal hatchName As String _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim hatchName As String
Dim value As Integer

value = instance.GetHatchFilltypeIndex(hatchName)
public int GetHatchFilltypeIndex(
   string hatchName
)
public: int GetHatchFilltypeIndex(
   string* hatchName
)
public:
int GetHatchFilltypeIndex(
   String^ hatchName
)

Parameters

hatchName
Name of the hatch.

Return Value

Integer value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetLayer Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetLayer Method
Index of the layer.
Returns a layer by its position in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLayer( _
   ByVal index As Integer _
) As ImGearVectorLayer
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorLayer

value = instance.GetLayer(index)
public ImGearVectorLayer GetLayer(
   int index
)
public: ImGearVectorLayer* GetLayer(
   int index
)
public:
ImGearVectorLayer^ GetLayer(
   int index
)

Parameters

index
Index of the layer.

Return Value

New instance of ImGearVectorLayer class.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetLinetype Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetLinetype Method
Index of the line type to be returned.
Returns a line type by its position in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLinetype( _
   ByVal index As Integer _
) As ImGearVectorLinetype
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorLinetype

value = instance.GetLinetype(index)
public ImGearVectorLinetype GetLinetype(
   int index
)
public: ImGearVectorLinetype* GetLinetype(
   int index
)
public:
ImGearVectorLinetype^ GetLinetype(
   int index
)

Parameters

index
Index of the line type to be returned.

Return Value

New instance of ImGearVectorLinetype class object.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetLinetypeIndex Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetLinetypeIndex Method
Fill pattern.
Absolute length of the pattern.
Returns the index of the line type in the internal container by the line pattern and pattern length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLinetypeIndex( _
   ByVal pattern As Integer, _
   ByVal patternLength As Single _
) As Integer
'Usage

Dim instance As ImGearVectorData
Dim pattern As Integer
Dim patternLength As Single
Dim value As Integer

value = instance.GetLinetypeIndex(pattern, patternLength)
public int GetLinetypeIndex(
   int pattern,
   float patternLength
)
public: int GetLinetypeIndex(
   int pattern,
   float patternLength
)
public:
int GetLinetypeIndex(
   int pattern,
   float patternLength
)

Parameters

pattern
Fill pattern.
patternLength
Absolute length of the pattern.

Return Value

Any integer value.
Remarks
If a line type with such attributes does not exist, it is created.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetSelection Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetSelection Method
X device coordinate.
Y device coordinate.
Looks for the entity that corresponds to the specified device coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSelection( _
   ByVal pointX As Integer, _
   ByVal pointY As Integer _
) As ImGearVectorEntityCont
'Usage

Dim instance As ImGearVectorData
Dim pointX As Integer
Dim pointY As Integer
Dim value As ImGearVectorEntityCont

value = instance.GetSelection(pointX, pointY)
public ImGearVectorEntityCont GetSelection(
   int pointX,
   int pointY
)
public: ImGearVectorEntityCont* GetSelection(
   int pointX,
   int pointY
)
public:
ImGearVectorEntityCont^ GetSelection(
   int pointX,
   int pointY
)

Parameters

pointX
X device coordinate.
pointY
Y device coordinate.

Return Value

New instance of ImGearVectorEntityCont class.
Remarks
If the entity has been found, it is placed in the returned entity container together with all including blocks. If no entity has been found, the returned entity container is empty.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetSelectionColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetSelectionColor Method
Returns the color that is used for displaying entities being selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetSelectionColor() As ImGearVectorColor
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectorColor

value = instance.GetSelectionColor()
public ImGearVectorColor GetSelectionColor()
public: ImGearVectorColor GetSelectionColor();
public:
ImGearVectorColor GetSelectionColor();

Return Value

New instance of ImGearVectorColor structure object.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GetView Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GetView Method
Index of view to be returned.
Returns a view from the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetView( _
   ByVal index As Integer _
) As ImGearVectorView
'Usage

Dim instance As ImGearVectorData
Dim index As Integer
Dim value As ImGearVectorView

value = instance.GetView(index)
public ImGearVectorView GetView(
   int index
)
public: ImGearVectorView* GetView(
   int index
)
public:
ImGearVectorView^ GetView(
   int index
)

Parameters

index
Index of view to be returned.

Return Value

ImGearVectorView class object representing the view at the specified index.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


Init Method (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : Init Method
Initializes vector content to an empty drawing, discarding any vector entities if they are present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Init()
'Usage

Dim instance As ImGearVectorData

instance.Init()
public void Init()
public: void Init();
public:
void Init();
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


SetSelectionColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : SetSelectionColor Method
Selection color.
Sets the color that is used for displaying selected entities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSelectionColor( _
   ByVal value As ImGearVectorColor _
)
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectorColor

instance.SetSelectionColor(value)
public void SetSelectionColor(
   ImGearVectorColor value
)
public: void SetSelectionColor(
   ImGearVectorColor value
)
public:
void SetSelectionColor(
   ImGearVectorColor value
)

Parameters

value
Selection color.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectorColor Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorData Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorData Class

For a list of all members of this type, see ImGearVectorData members.

Public Properties
 | Name | Description
Public Property | ActiveViewIndex | Gets or sets an index of the active view.
Public Property | FilltypeCount | Gets total count of fill types in the internal filltype container.
Public Property | FontCount | Gets a total count of fonts in the internal container.
Public Property | GraphicsType | Gets or sets the type of graphics used for displaying vector objects.
Public Property | LayerCount | Gets the total count of layers in the internal container.
Public Property | LinetypeCount | Gets total line type count in the internal line type container.
Public Property | SelectionThickness | Gets or sets the thickness that is used for displaying selected entities.
Public Property | Transparency | Gets or sets a value indicating whether the transparency is enabled.
Public Property | Units | Gets or sets measurement units used by the vector drawing.
Public Property | UnitsFactor | Gets or sets a units factor, that is, a multiplier of unit values.
Public Property | ViewCount | Gets total count of views in the drawing.
Top
See Also

Reference

ImGearVectorData Class
ImageGear.Vector Namespace


ActiveViewIndex Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : ActiveViewIndex Property
Gets or sets an index of the active view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActiveViewIndex As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

instance.ActiveViewIndex = value

value = instance.ActiveViewIndex
public int ActiveViewIndex {get; set;}
public: __property int get_ActiveViewIndex();
public: __property void set_ActiveViewIndex(
   int value
);
public:
property int ActiveViewIndex {
   int get();
   void set (    int value);
}

Property Value

Any positive integer value.
Remarks
Several views can exist but only the active one is used for display. The default value is 0.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


FilltypeCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : FilltypeCount Property
Gets total count of fill types in the internal filltype container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FilltypeCount As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

value = instance.FilltypeCount
public int FilltypeCount {get;}
public: __property int get_FilltypeCount();
public:
property int FilltypeCount {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


FontCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : FontCount Property
Gets a total count of fonts in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontCount As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

value = instance.FontCount
public int FontCount {get;}
public: __property int get_FontCount();
public:
property int FontCount {
   int get();
}

Property Value

Non-negative integer number.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


GraphicsType Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : GraphicsType Property
Gets or sets the type of graphics used for displaying vector objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GraphicsType As ImGearVectGraphics
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectGraphics

instance.GraphicsType = value

value = instance.GraphicsType
public ImGearVectGraphics GraphicsType {get; set;}
public: __property ImGearVectGraphics get_GraphicsType();
public: __property void set_GraphicsType(
   ImGearVectGraphics value
);
public:
property ImGearVectGraphics GraphicsType {
   ImGearVectGraphics get();
   void set (    ImGearVectGraphics value);
}

Property Value

Any value of ImGearVectGraphics enumeration.
Remarks
The default value is AUTO (uses either OPENGL or DIRECT3D)
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectGraphics Enumeration


LayerCount Property (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : LayerCount Property
Gets the total count of layers in the internal container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerCount As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

value = instance.LayerCount
public int LayerCount {get;}
public: __property int get_LayerCount();
public:
property int LayerCount {
   int get();
}

Property Value

Any integer number.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


LinetypeCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : LinetypeCount Property
Gets total line type count in the internal line type container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LinetypeCount As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

value = instance.LinetypeCount
public int LinetypeCount {get;}
public: __property int get_LinetypeCount();
public:
property int LinetypeCount {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


SelectionThickness Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : SelectionThickness Property
Gets or sets the thickness that is used for displaying selected entities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionThickness As Single
'Usage

Dim instance As ImGearVectorData
Dim value As Single

instance.SelectionThickness = value

value = instance.SelectionThickness
public float SelectionThickness {get; set;}
public: __property float get_SelectionThickness();
public: __property void set_SelectionThickness(
   float value
);
public:
property float SelectionThickness {
   float get();
   void set (    float value);
}

Property Value

Non-negative floating-point value.
Remarks
The default value is 0.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


Transparency Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : Transparency Property
Gets or sets a value indicating whether the transparency is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Transparency As Boolean
'Usage

Dim instance As ImGearVectorData
Dim value As Boolean

instance.Transparency = value

value = instance.Transparency
public bool Transparency {get; set;}
public: __property bool get_Transparency();
public: __property void set_Transparency(
   bool value
);
public:
property bool Transparency {
   bool get();
   void set (    bool value);
}

Property Value

If true - transparency is enabled, false - otherwise.
Remarks
If transparency is enabled, all non-transparent objects are drawn first. The default value is false.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


Units Property (ImGearVectorData)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : Units Property
Gets or sets measurement units used by the vector drawing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Units As ImGearVectMeasurementUnits
'Usage

Dim instance As ImGearVectorData
Dim value As ImGearVectMeasurementUnits

instance.Units = value

value = instance.Units
public ImGearVectMeasurementUnits Units {get; set;}
public: __property ImGearVectMeasurementUnits get_Units();
public: __property void set_Units(
   ImGearVectMeasurementUnits value
);
public:
property ImGearVectMeasurementUnits Units {
   ImGearVectMeasurementUnits get();
   void set (    ImGearVectMeasurementUnits value);
}

Property Value

ImGearVectMeasurementUnits enumeration value.
Remarks
Can be useful in determining physical size of objects in the drawing. Many vector files do not define measurement units, so this property will return UNKNOWN.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members
ImGearVectMeasurementUnits Enumeration


UnitsFactor Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : UnitsFactor Property
Gets or sets a units factor, that is, a multiplier of unit values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnitsFactor As Double
'Usage

Dim instance As ImGearVectorData
Dim value As Double

instance.UnitsFactor = value

value = instance.UnitsFactor
public double UnitsFactor {get; set;}
public: __property double get_UnitsFactor();
public: __property void set_UnitsFactor(
   double value
);
public:
property double UnitsFactor {
   double get();
   void set (    double value);
}

Property Value

Any double value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


ViewCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorData Class : ViewCount Property
Gets total count of views in the drawing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ViewCount As Integer
'Usage

Dim instance As ImGearVectorData
Dim value As Integer

value = instance.ViewCount
public int ViewCount {get;}
public: __property int get_ViewCount();
public:
property int ViewCount {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorData Class
ImGearVectorData Members


%%PageItemTitle%%

ImGearVectorEntity Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntity Class
Represents the base class for all entities. It provides access to the common entity features.
Object Model
ImGearVectorEntity ClassImGearVectorColorEx StructureImGearVectorColorEx StructureImGearVectorMinMax StructureImGearVectorLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntity
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorEntity
public class ImGearVectorEntity : ImGearVectorObject
public __gc class ImGearVectorEntity : public ImGearVectorObject
public ref class ImGearVectorEntity : public ImGearVectorObject
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityArc
ImageGear.Vector.ImGearVectorEntityBeziercurve
ImageGear.Vector.ImGearVectorEntityBlock
ImageGear.Vector.ImGearVectorEntityConnection
ImageGear.Vector.ImGearVectorEntityEasyline
ImageGear.Vector.ImGearVectorEntityEasysurface
ImageGear.Vector.ImGearVectorEntityEllipse
ImageGear.Vector.ImGearVectorEntityFigure
ImageGear.Vector.ImGearVectorEntityGeometry
ImageGear.Vector.ImGearVectorEntityInsertion
ImageGear.Vector.ImGearVectorEntityNURBScurve
ImageGear.Vector.ImGearVectorEntityPolyline
ImageGear.Vector.ImGearVectorEntityPolylineEx
ImageGear.Vector.ImGearVectorEntityRaster
ImageGear.Vector.ImGearVectorEntitySolid
ImageGear.Vector.ImGearVectorEntitySplinesurface
ImageGear.Vector.ImGearVectorEntityText
ImageGear.Vector.ImGearVectorEntityViewport

See Also

Reference

ImGearVectorEntity Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntity Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntity Class

The following tables list the members exposed by ImGearVectorEntity.

Public Properties
 | Name | Description
Public Property | AttribFlags | Gets flags indicating which optional attributes are present for the entity.
Public Property | Deleted | Gets or sets a value indicating whether the entity is marked as deleted.
Public Property | Id | Gets or sets an identifier of the entity.
Public Property | Layer | Gets or sets the layer the entity belongs to.
Public Property | Selected | Gets or sets a value indicating whether the entity is selected.
Public Property | Type | Gets a type of the entity.
Top
Public Methods
 | Name | Description
Public Method | CopyTo | Copies one entity to another.
Public Method | GetDrawColor | Returns the draw color of the entity.
Public Method | GetFillColor | Returns the fill color of the entity.
Public Method | GetFilltypeIndex | Returns the fill type index of the entity.
Public Method | GetLineThickness | Returns the line thickness used when drawing the entity.
Public Method | GetLinetypeIndex | Returns the line type index of the entity.
Public Method | GetMatrix | Returns a transformation matrix of the entity.
Public Method | GetMinMax | Calculates a bounding box which completely includes the entity.
Public Method | Move | Moves the entity according to the specified vector.
Public Method | RemoveAttrib | Removes and destroys an attribute.
Public Method | Rotate | Rotates the entity about to the specified vector on the specified angle.
Public Method | Scale | Scales the entity according to the specified scale vector.
Public Method | SetDirty | Marks the entity as dirty.
Public Method | SetDrawColor | Sets draw color for the entity.
Public Method | SetFillColor | Sets the fill color for the entity.
Public Method | SetFilltypeIndex | Sets the fill type index for an entity.
Public Method | SetLineThickness | Sets the line thickness for an entity.
Public Method | SetLinetypeIndex | Sets the line type index for an entity.
Public Method | SetMatrix | Sets a transformation matrix of the entity.
Top
See Also

Reference

ImGearVectorEntity Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntity Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntity Class

For a list of all members of this type, see ImGearVectorEntity members.

Public Methods
 | Name | Description
Public Method | CopyTo | Copies one entity to another.
Public Method | GetDrawColor | Returns the draw color of the entity.
Public Method | GetFillColor | Returns the fill color of the entity.
Public Method | GetFilltypeIndex | Returns the fill type index of the entity.
Public Method | GetLineThickness | Returns the line thickness used when drawing the entity.
Public Method | GetLinetypeIndex | Returns the line type index of the entity.
Public Method | GetMatrix | Returns a transformation matrix of the entity.
Public Method | GetMinMax | Calculates a bounding box which completely includes the entity.
Public Method | Move | Moves the entity according to the specified vector.
Public Method | RemoveAttrib | Removes and destroys an attribute.
Public Method | Rotate | Rotates the entity about to the specified vector on the specified angle.
Public Method | Scale | Scales the entity according to the specified scale vector.
Public Method | SetDirty | Marks the entity as dirty.
Public Method | SetDrawColor | Sets draw color for the entity.
Public Method | SetFillColor | Sets the fill color for the entity.
Public Method | SetFilltypeIndex | Sets the fill type index for an entity.
Public Method | SetLineThickness | Sets the line thickness for an entity.
Public Method | SetLinetypeIndex | Sets the line type index for an entity.
Public Method | SetMatrix | Sets a transformation matrix of the entity.
Top
See Also

Reference

ImGearVectorEntity Class
ImageGear.Vector Namespace


CopyTo Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : CopyTo Method
A valid destination entity to copy to. It may belong to a different vector data object.
Copies one entity to another.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal destinationEntity As ImGearVectorEntity _
)
'Usage

Dim instance As ImGearVectorEntity
Dim destinationEntity As ImGearVectorEntity

instance.CopyTo(destinationEntity)
public void CopyTo(
   ImGearVectorEntity destinationEntity
)
public: void CopyTo(
   ImGearVectorEntity* destinationEntity
)
public:
void CopyTo(
   ImGearVectorEntity^ destinationEntity
)

Parameters

destinationEntity
A valid destination entity to copy to. It may belong to a different vector data object.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members
ImGearVectorEntity Class


GetDrawColor Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetDrawColor Method
Returns the draw color of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDrawColor() As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorColorEx

value = instance.GetDrawColor()
public ImGearVectorColorEx GetDrawColor()
public: ImGearVectorColorEx GetDrawColor();
public:
ImGearVectorColorEx GetDrawColor();

Return Value

Newly created ImGearVectorColorEx structure object or null.
Remarks
If the m_flags field of the returned extended color object is -3, the actual color is defined by the entity layer. In case of -2 it is obtained from the block. Otherwise, the actual m_color value is used.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


GetFillColor Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetFillColor Method
Returns the fill color of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFillColor() As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorColorEx

value = instance.GetFillColor()
public ImGearVectorColorEx GetFillColor()
public: ImGearVectorColorEx GetFillColor();
public:
ImGearVectorColorEx GetFillColor();

Return Value

Newly created ImGearVectorColorEx structure object or null.
Remarks
If the m_flags field of the returned extended color object is -3, the actual color is defined by the entity layer. In case of -2 it is obtained from the block. Otherwise, the actual m_color value is used.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


GetFilltypeIndex Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetFilltypeIndex Method
Returns the fill type index of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFilltypeIndex() As Integer
'Usage

Dim instance As ImGearVectorEntity
Dim value As Integer

value = instance.GetFilltypeIndex()
public int GetFilltypeIndex()
public: int GetFilltypeIndex();
public:
int GetFilltypeIndex();

Return Value

Non-negative value or either -2 or -3.
Remarks

If this value is equal to -3, then the actual fill type index is defined by the entity layer. In case of -2 the index should be obtained from the block. Othervise, the value is used as actual fill type index.

Actual fill type can be retrieved by the index by calling the ImGearVectorData class object's ImGearVectorData.GetFilltype method.

See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


GetLineThickness Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetLineThickness Method
Returns the line thickness used when drawing the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLineThickness() As Single
'Usage

Dim instance As ImGearVectorEntity
Dim value As Single

value = instance.GetLineThickness()
public float GetLineThickness()
public: float GetLineThickness();
public:
float GetLineThickness();

Return Value

Non-negative floating-point value.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


GetLinetypeIndex Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetLinetypeIndex Method
Returns the line type index of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLinetypeIndex() As Integer
'Usage

Dim instance As ImGearVectorEntity
Dim value As Integer

value = instance.GetLinetypeIndex()
public int GetLinetypeIndex()
public: int GetLinetypeIndex();
public:
int GetLinetypeIndex();

Return Value

Non-negative value or either -2 or -3.
Remarks

If this value is equal to -3, then the actual line type index is defined by the entity layer. In case of -2 the index should be obtained from the block. Othervise, the value is used as actual line type index.

Actual line type can be retrieved by the index from the vectdata.GetLineType method, where vectdata is a vector data object.

See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members
SetLinetypeIndex Method


GetMatrix Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetMatrix Method
Returns a transformation matrix of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatrix() As Single()
'Usage

Dim instance As ImGearVectorEntity
Dim value() As Single

value = instance.GetMatrix()
public float[] GetMatrix()
public: float[]* GetMatrix();
public:
array<float>^ GetMatrix();

Return Value

An array of 16 floating-point values.
Remarks
The matrix consists of 16 floating-point values and aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


GetMinMax Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : GetMinMax Method
Calculates a bounding box which completely includes the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMinMax() As ImGearVectorMinMax
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorMinMax

value = instance.GetMinMax()
public ImGearVectorMinMax GetMinMax()
public: ImGearVectorMinMax GetMinMax();
public:
ImGearVectorMinMax GetMinMax();

Return Value

New instance of ImGearVectorMinMax structure object.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Move Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Move Method
X coordinate of the offset vector.
Y coordinate of the offset vector.
Z coordinate of the offset vector.
Flag that defines an order of transformation.
Moves the entity according to the specified vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Move( _
   ByVal offsetX As Single, _
   ByVal offsetY As Single, _
   ByVal offsetZ As Single, _
   ByVal transformBeforeMoving As Boolean _
)
'Usage

Dim instance As ImGearVectorEntity
Dim offsetX As Single
Dim offsetY As Single
Dim offsetZ As Single
Dim transformBeforeMoving As Boolean

instance.Move(offsetX, offsetY, offsetZ, transformBeforeMoving)
public void Move(
   float offsetX,
   float offsetY,
   float offsetZ,
   bool transformBeforeMoving
)
public: void Move(
   float offsetX,
   float offsetY,
   float offsetZ,
   bool transformBeforeMoving
)
public:
void Move(
   float offsetX,
   float offsetY,
   float offsetZ,
   bool transformBeforeMoving
)

Parameters

offsetX
X coordinate of the offset vector.
offsetY
Y coordinate of the offset vector.
offsetZ
Z coordinate of the offset vector.
transformBeforeMoving
Flag that defines an order of transformation.
Remarks
If transformBeforeMoving parameter is true then moving is performed before other transformations (that is, the current matrix is multiplied by the move matrix). Otherwise, the move matrix is multiplied by the current matrix.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


RemoveAttrib Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : RemoveAttrib Method
Attribute being removed.
Removes and destroys an attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAttrib( _
   ByVal attributeType As ImGearVectAttrib _
)
'Usage

Dim instance As ImGearVectorEntity
Dim attributeType As ImGearVectAttrib

instance.RemoveAttrib(attributeType)
public void RemoveAttrib(
   ImGearVectAttrib attributeType
)
public: void RemoveAttrib(
   ImGearVectAttrib attributeType
)
public:
void RemoveAttrib(
   ImGearVectAttrib attributeType
)

Parameters

attributeType
Attribute being removed.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members
ImGearVectAttrib Enumeration


Rotate Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Rotate Method
Rotation angle in radians.
X coordinate of the rotation vector.
Y coordinate of the rotation vector.
Z coordinate of the rotation vector.
Defines the order of transformation.
Rotates the entity about to the specified vector on the specified angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Single, _
   ByVal vectorX As Single, _
   ByVal vectorY As Single, _
   ByVal vectorZ As Single, _
   ByVal transformBeforeRotating As Boolean _
)
'Usage

Dim instance As ImGearVectorEntity
Dim angle As Single
Dim vectorX As Single
Dim vectorY As Single
Dim vectorZ As Single
Dim transformBeforeRotating As Boolean

instance.Rotate(angle, vectorX, vectorY, vectorZ, transformBeforeRotating)
public void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool transformBeforeRotating
)
public: void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool transformBeforeRotating
)
public:
void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool transformBeforeRotating
)

Parameters

angle
Rotation angle in radians.
vectorX
X coordinate of the rotation vector.
vectorY
Y coordinate of the rotation vector.
vectorZ
Z coordinate of the rotation vector.
transformBeforeRotating
Defines the order of transformation.
Remarks
If transformBeforeRotating parameter is true then rotation is performed before other transformations (that is, the current matrix is multiplied by the rotation matrix). Otherwise, the rotation matrix is multiplied by the current matrix.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Scale Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Scale Method
X scale factor.
Y scale factor.
Z scale factor.
Flag that defines an order of transformation.
Scales the entity according to the specified scale vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal scaleX As Single, _
   ByVal scaleY As Single, _
   ByVal scaleZ As Single, _
   ByVal transformBeforeScaling As Boolean _
)
'Usage

Dim instance As ImGearVectorEntity
Dim scaleX As Single
Dim scaleY As Single
Dim scaleZ As Single
Dim transformBeforeScaling As Boolean

instance.Scale(scaleX, scaleY, scaleZ, transformBeforeScaling)
public void Scale(
   float scaleX,
   float scaleY,
   float scaleZ,
   bool transformBeforeScaling
)
public: void Scale(
   float scaleX,
   float scaleY,
   float scaleZ,
   bool transformBeforeScaling
)
public:
void Scale(
   float scaleX,
   float scaleY,
   float scaleZ,
   bool transformBeforeScaling
)

Parameters

scaleX
X scale factor.
scaleY
Y scale factor.
scaleZ
Z scale factor.
transformBeforeScaling
Flag that defines an order of transformation.
Remarks
If transformBeforeScaling parameter is true then scaling is performed before other transformations (that is, the current matrix is multiplied by the scale matrix). Otherwise, the scale matrix is multiplied by the current matrix.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


SetDirty Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetDirty Method
Marks the entity as dirty.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDirty()
'Usage

Dim instance As ImGearVectorEntity

instance.SetDirty()
public void SetDirty()
public: void SetDirty();
public:
void SetDirty();
Remarks
Some entities contain intermediate data which is calculated only once and used directly for entity drawing. This is done for high performance. The user must call this method every time when any changes in the entity are done.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


SetDrawColor Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetDrawColor Method
New draw color to be set.
Sets draw color for the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDrawColor( _
   ByVal value As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorColorEx

instance.SetDrawColor(value)
public void SetDrawColor(
   ImGearVectorColorEx value
)
public: void SetDrawColor(
   ImGearVectorColorEx value
)
public:
void SetDrawColor(
   ImGearVectorColorEx value
)

Parameters

value
New draw color to be set.
Remarks
See GetDrawColor method for possible flag values.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members
ImGearVectorColorEx Structure


SetFillColor Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetFillColor Method
New fill color to be set.
Sets the fill color for the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetFillColor( _
   ByVal value As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorColorEx

instance.SetFillColor(value)
public void SetFillColor(
   ImGearVectorColorEx value
)
public: void SetFillColor(
   ImGearVectorColorEx value
)
public:
void SetFillColor(
   ImGearVectorColorEx value
)

Parameters

value
New fill color to be set.
Remarks
See GetFillColor method for possible flag values.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members
ImGearVectorColorEx Structure


SetFilltypeIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetFilltypeIndex Method
New fill type index to be set.
Sets the fill type index for an entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetFilltypeIndex( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorEntity
Dim index As Integer

instance.SetFilltypeIndex(index)
public void SetFilltypeIndex(
   int index
)
public: void SetFilltypeIndex(
   int index
)
public:
void SetFilltypeIndex(
   int index
)

Parameters

index
New fill type index to be set.
Remarks
See GetFilltypeIndex method for possible values.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


SetLineThickness Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetLineThickness Method
New thickness to be set.
Sets the line thickness for an entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLineThickness( _
   ByVal value As Single _
)
'Usage

Dim instance As ImGearVectorEntity
Dim value As Single

instance.SetLineThickness(value)
public void SetLineThickness(
   float value
)
public: void SetLineThickness(
   float value
)
public:
void SetLineThickness(
   float value
)

Parameters

value
New thickness to be set.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


SetLinetypeIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetLinetypeIndex Method
New line type index to be set.
Sets the line type index for an entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLinetypeIndex( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorEntity
Dim index As Integer

instance.SetLinetypeIndex(index)
public void SetLinetypeIndex(
   int index
)
public: void SetLinetypeIndex(
   int index
)
public:
void SetLinetypeIndex(
   int index
)

Parameters

index
New line type index to be set.
Remarks
See GetLinetypeIndex method for possible values.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


SetMatrix Method (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : SetMatrix Method
Matrix to be set.
Sets a transformation matrix of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatrix( _
   ByVal matrix() As Single _
)
'Usage

Dim instance As ImGearVectorEntity
Dim matrix() As Single

instance.SetMatrix(matrix)
public void SetMatrix(
   float[] matrix
)
public: void SetMatrix(
   float[]* matrix
)
public:
void SetMatrix(
   array<float>^ matrix
)

Parameters

matrix
Matrix to be set.
Remarks
The matrix consists of 16 floating-point values and aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntity Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntity Class

For a list of all members of this type, see ImGearVectorEntity members.

Public Properties
 | Name | Description
Public Property | AttribFlags | Gets flags indicating which optional attributes are present for the entity.
Public Property | Deleted | Gets or sets a value indicating whether the entity is marked as deleted.
Public Property | Id | Gets or sets an identifier of the entity.
Public Property | Layer | Gets or sets the layer the entity belongs to.
Public Property | Selected | Gets or sets a value indicating whether the entity is selected.
Public Property | Type | Gets a type of the entity.
Top
See Also

Reference

ImGearVectorEntity Class
ImageGear.Vector Namespace


AttribFlags Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : AttribFlags Property
Gets flags indicating which optional attributes are present for the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AttribFlags As Integer
'Usage

Dim instance As ImGearVectorEntity
Dim value As Integer

value = instance.AttribFlags
public int AttribFlags {get;}
public: __property int get_AttribFlags();
public:
property int AttribFlags {
   int get();
}

Property Value

Or combination of ImGearVectAttrib enumeration values or 0.
Remarks

An entity may have different optional attributes such as draw color, fill color, line type, fill type, offset, rotation, scale and position. These attributes do not exist until they are created.

Note: OFFSET, ROTATION, SCALE and POSITON flags are deprecated and should not be used. Use Move, Rotate, Scale, GetMatrix and SetMatrix methods to manipulate the corresponding attributes.

See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Deleted Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Deleted Property
Gets or sets a value indicating whether the entity is marked as deleted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Deleted As Boolean
'Usage

Dim instance As ImGearVectorEntity
Dim value As Boolean

instance.Deleted = value

value = instance.Deleted
public bool Deleted {get; set;}
public: __property bool get_Deleted();
public: __property void set_Deleted(
   bool value
);
public:
property bool Deleted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
When the entity is marked as deleted, it is not actually removed but becomes invisible. The user can query all entities and undo delete operation. Deleted entities are not saved in files. The default value is false.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Id Property (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Id Property
Gets or sets an identifier of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Id As String
'Usage

Dim instance As ImGearVectorEntity
Dim value As String

instance.Id = value

value = instance.Id
public string Id {get; set;}
public: __property string* get_Id();
public: __property void set_Id(
   string* value
);
public:
property String^ Id {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string Identifier.
Remarks
This identifier is always unique inside the same vector data object.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Layer Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Layer Property
Gets or sets the layer the entity belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Layer As ImGearVectorLayer
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectorLayer

instance.Layer = value

value = instance.Layer
public ImGearVectorLayer Layer {get; set;}
public: __property ImGearVectorLayer* get_Layer();
public: __property void set_Layer(
   ImGearVectorLayer* value
);
public:
property ImGearVectorLayer^ Layer {
   ImGearVectorLayer^ get();
   void set (    ImGearVectorLayer^ value);
}

Property Value

New instance of ImGearVectorLayer class object.
Remarks
If there is no layer associated with the entity, the property is set to null.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Selected Property (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Selected Property
Gets or sets a value indicating whether the entity is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Selected As Boolean
'Usage

Dim instance As ImGearVectorEntity
Dim value As Boolean

instance.Selected = value

value = instance.Selected
public bool Selected {get; set;}
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Selected entity is displayed in the color that is set as selection color for the vector data object.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


Type Property (ImGearVectorEntity)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntity Class : Type Property
Gets a type of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearVectEntities
'Usage

Dim instance As ImGearVectorEntity
Dim value As ImGearVectEntities

value = instance.Type
public ImGearVectEntities Type {get;}
public: __property ImGearVectEntities get_Type();
public:
property ImGearVectEntities Type {
   ImGearVectEntities get();
}

Property Value

Any value of ImGearVectEntities enumeration.
See Also

Reference

ImGearVectorEntity Class
ImGearVectorEntity Members


%%PageItemTitle%%

ImGearVectorEntityArc Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityArc Class
Represents an elliptical arc that is defined by radii and angles.
Object Model
ImGearVectorEntityArc Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityArc
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityArc
public class ImGearVectorEntityArc : ImGearVectorEntity
public __gc class ImGearVectorEntityArc : public ImGearVectorEntity
public ref class ImGearVectorEntityArc : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityArc

See Also

Reference

ImGearVectorEntityArc Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityArc Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityArc Class

The following tables list the members exposed by ImGearVectorEntityArc.

Public Properties
 | Name | Description
Public Property | Clockwise | Gets or sets a value indicating whether a drawing direction of the elliptical arc is clockwise.
Public Property | CloseType | Gets or sets the arc close type.
Public Property | EndAngle | Gets or sets the end angle of the elliptical arc, in radians.
Public Property | RadiusX | Gets or sets a radius of the elliptical arc along the x-axis.
Public Property | RadiusY | Gets or sets a radius of the elliptical arc along the y-axis.
Public Property | StartAngle | Gets or sets the start angle of the elliptical arc in radians.
Top
See Also

Reference

ImGearVectorEntityArc Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityArc Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityArc Class

For a list of all members of this type, see ImGearVectorEntityArc members.

Public Properties
 | Name | Description
Public Property | Clockwise | Gets or sets a value indicating whether a drawing direction of the elliptical arc is clockwise.
Public Property | CloseType | Gets or sets the arc close type.
Public Property | EndAngle | Gets or sets the end angle of the elliptical arc, in radians.
Public Property | RadiusX | Gets or sets a radius of the elliptical arc along the x-axis.
Public Property | RadiusY | Gets or sets a radius of the elliptical arc along the y-axis.
Public Property | StartAngle | Gets or sets the start angle of the elliptical arc in radians.
Top
See Also

Reference

ImGearVectorEntityArc Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityArc Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityArc Class

For a list of all members of this type, see ImGearVectorEntityArc members.

See Also

Reference

ImGearVectorEntityArc Class
ImageGear.Vector Namespace


Clockwise Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : Clockwise Property
Gets or sets a value indicating whether a drawing direction of the elliptical arc is clockwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Clockwise As Boolean
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As Boolean

instance.Clockwise = value

value = instance.Clockwise
public bool Clockwise {get; set;}
public: __property bool get_Clockwise();
public: __property void set_Clockwise(
   bool value
);
public:
property bool Clockwise {
   bool get();
   void set (    bool value);
}

Property Value

If true then drawing direction is clockwise, otherwise it is counter clockwise.
Remarks
The default value is true.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


CloseType Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : CloseType Property
Gets or sets the arc close type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CloseType As ImGearVectArcCloseType
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As ImGearVectArcCloseType

instance.CloseType = value

value = instance.CloseType
public ImGearVectArcCloseType CloseType {get; set;}
public: __property ImGearVectArcCloseType get_CloseType();
public: __property void set_CloseType(
   ImGearVectArcCloseType value
);
public:
property ImGearVectArcCloseType CloseType {
   ImGearVectArcCloseType get();
   void set (    ImGearVectArcCloseType value);
}

Property Value

Any value of ImGearVectArcCloseType enumeration.
Remarks
Arc can be unclosed, closed like sector and closed like segment.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


EndAngle Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : EndAngle Property
Gets or sets the end angle of the elliptical arc, in radians.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndAngle As Single
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As Single

instance.EndAngle = value

value = instance.EndAngle
public float EndAngle {get; set;}
public: __property float get_EndAngle();
public: __property void set_EndAngle(
   float value
);
public:
property float EndAngle {
   float get();
   void set (    float value);
}

Property Value

Any floating-point value.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


RadiusX Property (ImGearVectorEntityArc)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : RadiusX Property
Gets or sets a radius of the elliptical arc along the x-axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RadiusX As Single
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As Single

instance.RadiusX = value

value = instance.RadiusX
public float RadiusX {get; set;}
public: __property float get_RadiusX();
public: __property void set_RadiusX(
   float value
);
public:
property float RadiusX {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


RadiusY Property (ImGearVectorEntityArc)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : RadiusY Property
Gets or sets a radius of the elliptical arc along the y-axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RadiusY As Single
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As Single

instance.RadiusY = value

value = instance.RadiusY
public float RadiusY {get; set;}
public: __property float get_RadiusY();
public: __property void set_RadiusY(
   float value
);
public:
property float RadiusY {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


StartAngle Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityArc Class : StartAngle Property
Gets or sets the start angle of the elliptical arc in radians.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartAngle As Single
'Usage

Dim instance As ImGearVectorEntityArc
Dim value As Single

instance.StartAngle = value

value = instance.StartAngle
public float StartAngle {get; set;}
public: __property float get_StartAngle();
public: __property void set_StartAngle(
   float value
);
public:
property float StartAngle {
   float get();
   void set (    float value);
}

Property Value

Any value.
See Also

Reference

ImGearVectorEntityArc Class
ImGearVectorEntityArc Members


%%PageItemTitle%%

ImGearVectorEntityBeziercurve Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziercurve Class
Represents a Bezier curve that is defined by control points and curve degree.
Object Model
ImGearVectorEntityBeziercurve ClassImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityBeziercurve
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityBeziercurve
public class ImGearVectorEntityBeziercurve : ImGearVectorEntity
public __gc class ImGearVectorEntityBeziercurve : public ImGearVectorEntity
public ref class ImGearVectorEntityBeziercurve : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityBeziercurve

See Also

Reference

ImGearVectorEntityBeziercurve Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityBeziercurve Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziercurve Class

The following tables list the members exposed by ImGearVectorEntityBeziercurve.

Public Properties
 | Name | Description
Public Property | Degree | Gets or sets a degree of the Bezier interpolation.
Public Property | Flags | Gets or sets different flags of the interpolated curve.
Public Property | PointCount | Gets a number of control points in the Bezier curve.
Public Property | Step | Gets or sets a step of the Bezier interpolation.
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Addss a point to the specified position on the curve.
Public Method | GetPoint | Returns the specified point from the specified position on the curve.
Public Method | SetPoint | Sets the specified point to the specified position on the curve.
Top
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityBeziercurve Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziercurve Class

For a list of all members of this type, see ImGearVectorEntityBeziercurve members.

Public Methods
 | Name | Description
Public Method | AddPoint | Addss a point to the specified position on the curve.
Public Method | GetPoint | Returns the specified point from the specified position on the curve.
Public Method | SetPoint | Sets the specified point to the specified position on the curve.
Top
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImageGear.Vector Namespace


AddPoint Method (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : AddPoint Method
ImGearVectorPoint3D object with point coordinates.
Addss a point to the specified position on the curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim point As ImGearVectorPoint3D

instance.AddPoint(point)
public void AddPoint(
   ImGearVectorPoint3D point
)
public: void AddPoint(
   ImGearVectorPoint3D point
)
public:
void AddPoint(
   ImGearVectorPoint3D point
)

Parameters

point
ImGearVectorPoint3D object with point coordinates.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members
ImGearVectorPoint3D Structure


GetPoint Method (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : GetPoint Method
Index of the point to be returned.
Returns the specified point from the specified position on the curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim index As Integer
Dim value As ImGearVectorPoint3D

value = instance.GetPoint(index)
public ImGearVectorPoint3D GetPoint(
   int index
)
public: ImGearVectorPoint3D GetPoint(
   int index
)
public:
ImGearVectorPoint3D GetPoint(
   int index
)

Parameters

index
Index of the point to be returned.

Return Value

ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members
ImGearVectorPoint3D Structure


SetPoint Method (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : SetPoint Method
Index of the point to be set.
ImGearVectorPoint3D object with new point coordinates.
Sets the specified point to the specified position on the curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim index As Integer
Dim point As ImGearVectorPoint3D

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ImGearVectorPoint3D point
)
public: void SetPoint(
   int index,
   ImGearVectorPoint3D point
)
public:
void SetPoint(
   int index,
   ImGearVectorPoint3D point
)

Parameters

index
Index of the point to be set.
point
ImGearVectorPoint3D object with new point coordinates.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members
ImGearVectorPoint3D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityBeziercurve Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziercurve Class

For a list of all members of this type, see ImGearVectorEntityBeziercurve members.

Public Properties
 | Name | Description
Public Property | Degree | Gets or sets a degree of the Bezier interpolation.
Public Property | Flags | Gets or sets different flags of the interpolated curve.
Public Property | PointCount | Gets a number of control points in the Bezier curve.
Public Property | Step | Gets or sets a step of the Bezier interpolation.
Top
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImageGear.Vector Namespace


Degree Property (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : Degree Property
Gets or sets a degree of the Bezier interpolation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Degree As Integer
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim value As Integer

instance.Degree = value

value = instance.Degree
public int Degree {get; set;}
public: __property int get_Degree();
public: __property void set_Degree(
   int value
);
public:
property int Degree {
   int get();
   void set (    int value);
}

Property Value

Numeric value that is equal to 2 or greater.
Remarks
The default value is 3.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members


Flags Property (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : Flags Property
Gets or sets different flags of the interpolated curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim value As Integer

instance.Flags = value

value = instance.Flags
public int Flags {get; set;}
public: __property int get_Flags();
public: __property void set_Flags(
   int value
);
public:
property int Flags {
   int get();
   void set (    int value);
}

Property Value

Combination of ImGearVectNURBSFlags enumeration values or 0.
Remarks
If the curve is closed, the only possible flag is ImGearVectNURBSFlags.MCLOSED. The default value is 0.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members


PointCount Property (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : PointCount Property
Gets a number of control points in the Bezier curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PointCount As Integer
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim value As Integer

value = instance.PointCount
public int PointCount {get;}
public: __property int get_PointCount();
public:
property int PointCount {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members


Step Property (ImGearVectorEntityBeziercurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziercurve Class : Step Property
Gets or sets a step of the Bezier interpolation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Step As Single
'Usage

Dim instance As ImGearVectorEntityBeziercurve
Dim value As Single

instance.Step = value

value = instance.Step
public float Step {get; set;}
public: __property float get_Step();
public: __property void set_Step(
   float value
);
public:
property float Step {
   float get();
   void set (    float value);
}

Property Value

A value in the 0..1 range.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityBeziercurve Class
ImGearVectorEntityBeziercurve Members


%%PageItemTitle%%

ImGearVectorEntityBeziersurface Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziersurface Class
Represents a Bezier surface.
Object Model
ImGearVectorEntityBeziersurface ClassImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityBeziersurface
   Inherits ImGearVectorEntitySplinesurface
'Usage

Dim instance As ImGearVectorEntityBeziersurface
public class ImGearVectorEntityBeziersurface : ImGearVectorEntitySplinesurface
public __gc class ImGearVectorEntityBeziersurface : public ImGearVectorEntitySplinesurface
public ref class ImGearVectorEntityBeziersurface : public ImGearVectorEntitySplinesurface
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntitySplinesurface
ImageGear.Vector.ImGearVectorEntityBeziersurface

See Also

Reference

ImGearVectorEntityBeziersurface Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityBeziersurface Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziersurface Class

The following tables list the members exposed by ImGearVectorEntityBeziersurface.

Public Properties
 | Name | Description
Public Property | Flags | Overridden. Gets or sets different surface flags.
Public Property | MDegree | Overridden. Gets a surface degree in M direction.
Public Property | MDimension | Overridden. Gets the number of control points in M direction.
Public Property | MStep | Overridden. Gets or sets an interpolation step in M direction.
Public Property | NDegree | Overridden. Gets a surface degree in N direction.
Public Property | NDimension | Overridden. Gets the number of control points in N direction.
Public Property | NStep | Overridden. Gets or sets an interpolation step in N direction.
Top
Public Methods
 | Name | Description
Public Method | GetPoint | Returns a surface point from the specified position.
Public Method | Init | Overridden. Initializes the surface with the specified dimensions and specified degrees.
Public Method | SetPoint | Sets a point at the specified position.
Top
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityBeziersurface Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziersurface Class

For a list of all members of this type, see ImGearVectorEntityBeziersurface members.

Public Methods
 | Name | Description
Public Method | GetPoint | Returns a surface point from the specified position.
Public Method | Init | Overridden. Initializes the surface with the specified dimensions and specified degrees.
Public Method | SetPoint | Sets a point at the specified position.
Top
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImageGear.Vector Namespace


GetPoint Method (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : GetPoint Method
Index of the point in M direction.
Index of the point in N direction.
Returns a surface point from the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer _
) As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim indexM As Integer
Dim indexN As Integer
Dim value As ImGearVectorPoint3D

value = instance.GetPoint(indexM, indexN)
public ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)
public: ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)
public:
ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.

Return Value

New instance of ImGearVectorPoint3DEx structure.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


Init Method (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : Init Method
Number of control points in M direction.
Number of control points in N direction.
Surface degree in M direction.
Surface degree in N direction.
Initializes the surface with the specified dimensions and specified degrees.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Init( _
   ByVal dimensionM As Integer, _
   ByVal dimensionN As Integer, _
   ByVal degreeM As Integer, _
   ByVal degreeN As Integer _
)
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim dimensionM As Integer
Dim dimensionN As Integer
Dim degreeM As Integer
Dim degreeN As Integer

instance.Init(dimensionM, dimensionN, degreeM, degreeN)
public override void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
)
public: void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
) override
public:
void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
) override

Parameters

dimensionM
Number of control points in M direction.
dimensionN
Number of control points in N direction.
degreeM
Surface degree in M direction.
degreeN
Surface degree in N direction.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


SetPoint Method (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : SetPoint Method
Index of the point in M direction.
Index of the point in N direction.
Point value to be set.
Sets a point at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer, _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim indexM As Integer
Dim indexN As Integer
Dim point As ImGearVectorPoint3D

instance.SetPoint(indexM, indexN, point)
public void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)
public: void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)
public:
void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.
point
Point value to be set.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members
ImGearVectorPoint3D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityBeziersurface Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBeziersurface Class

For a list of all members of this type, see ImGearVectorEntityBeziersurface members.

Public Properties
 | Name | Description
Public Property | Flags | Overridden. Gets or sets different surface flags.
Public Property | MDegree | Overridden. Gets a surface degree in M direction.
Public Property | MDimension | Overridden. Gets the number of control points in M direction.
Public Property | MStep | Overridden. Gets or sets an interpolation step in M direction.
Public Property | NDegree | Overridden. Gets a surface degree in N direction.
Public Property | NDimension | Overridden. Gets the number of control points in N direction.
Public Property | NStep | Overridden. Gets or sets an interpolation step in N direction.
Top
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImageGear.Vector Namespace


Flags Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : Flags Property
Gets or sets different surface flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Integer

instance.Flags = value

value = instance.Flags
public override int Flags {get; set;}
public: __property int get_Flags() override;
public: __property void set_Flags(
   int value
) override;
public:
property int Flags {
   int get() override;
   void set (    int value) override;
}

Property Value

Combination of ImGearVectNURBSFlags enumeration or 0.
Remarks
The default value is 0.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


MDegree Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : MDegree Property
Gets a surface degree in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property MDegree As Integer
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Integer

value = instance.MDegree
public override int MDegree {get;}
public: __property int get_MDegree() override;
public:
property int MDegree {
   int get() override;
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


MDimension Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : MDimension Property
Gets the number of control points in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property MDimension As Integer
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Integer

value = instance.MDimension
public override int MDimension {get;}
public: __property int get_MDimension() override;
public:
property int MDimension {
   int get() override;
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


MStep Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : MStep Property
Gets or sets an interpolation step in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property MStep As Single
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Single

instance.MStep = value

value = instance.MStep
public override float MStep {get; set;}
public: __property float get_MStep() override;
public: __property void set_MStep(
   float value
) override;
public:
property float MStep {
   float get() override;
   void set (    float value) override;
}

Property Value

Value in the range 0..1.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


NDegree Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : NDegree Property
Gets a surface degree in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property NDegree As Integer
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Integer

value = instance.NDegree
public override int NDegree {get;}
public: __property int get_NDegree() override;
public:
property int NDegree {
   int get() override;
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


NDimension Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : NDimension Property
Gets the number of control points in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property NDimension As Integer
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Integer

value = instance.NDimension
public override int NDimension {get;}
public: __property int get_NDimension() override;
public:
property int NDimension {
   int get() override;
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


NStep Property (ImGearVectorEntityBeziersurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBeziersurface Class : NStep Property
Gets or sets an interpolation step in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property NStep As Single
'Usage

Dim instance As ImGearVectorEntityBeziersurface
Dim value As Single

instance.NStep = value

value = instance.NStep
public override float NStep {get; set;}
public: __property float get_NStep() override;
public: __property void set_NStep(
   float value
) override;
public:
property float NStep {
   float get() override;
   void set (    float value) override;
}

Property Value

Value in the range 0..1.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityBeziersurface Class
ImGearVectorEntityBeziersurface Members


%%PageItemTitle%%

ImGearVectorEntityBlock Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBlock Class
This entity includes a container with other entities.
Object Model
ImGearVectorEntityBlock ClassImGearVectorEntityCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityBlock
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityBlock
public class ImGearVectorEntityBlock : ImGearVectorEntity
public __gc class ImGearVectorEntityBlock : public ImGearVectorEntity
public ref class ImGearVectorEntityBlock : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityBlock

See Also

Reference

ImGearVectorEntityBlock Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityBlock Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBlock Class

The following tables list the members exposed by ImGearVectorEntityBlock.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets a block name.
Top
Public Methods
 | Name | Description
Public Method | GetEntityCont | Returns the entity container for the block.
Top
See Also

Reference

ImGearVectorEntityBlock Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityBlock Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBlock Class

For a list of all members of this type, see ImGearVectorEntityBlock members.

Public Methods
 | Name | Description
Public Method | GetEntityCont | Returns the entity container for the block.
Top
See Also

Reference

ImGearVectorEntityBlock Class
ImageGear.Vector Namespace


GetEntityCont Method (ImGearVectorEntityBlock)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBlock Class : GetEntityCont Method
Returns the entity container for the block.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetEntityCont() As ImGearVectorEntityCont
'Usage

Dim instance As ImGearVectorEntityBlock
Dim value As ImGearVectorEntityCont

value = instance.GetEntityCont()
public virtual ImGearVectorEntityCont GetEntityCont()
public: virtual ImGearVectorEntityCont* GetEntityCont();
public:
virtual ImGearVectorEntityCont^ GetEntityCont();

Return Value

New instance of ImGearVectorEntityCont class object.
See Also

Reference

ImGearVectorEntityBlock Class
ImGearVectorEntityBlock Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityBlock Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityBlock Class

For a list of all members of this type, see ImGearVectorEntityBlock members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets a block name.
Top
See Also

Reference

ImGearVectorEntityBlock Class
ImageGear.Vector Namespace


Name Property (ImGearVectorEntityBlock)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityBlock Class : Name Property
Gets or sets a block name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearVectorEntityBlock
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string value.
See Also

Reference

ImGearVectorEntityBlock Class
ImGearVectorEntityBlock Members


%%PageItemTitle%%

ImGearVectorEntityConnection Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityConnection Class
Represents a special entity that is used to connect end and start points of neighboring entities in the figure entity container.
Object Model
ImGearVectorEntityConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityConnection
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityConnection
public class ImGearVectorEntityConnection : ImGearVectorEntity
public __gc class ImGearVectorEntityConnection : public ImGearVectorEntity
public ref class ImGearVectorEntityConnection : public ImGearVectorEntity
Remarks
This class does not have public API.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityConnection

See Also

Reference

ImGearVectorEntityConnection Members
ImageGear.Vector Namespace
ImGearVectorEntity Class


%%PageItemTitle%% $$Members$$

ImGearVectorEntityConnection Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityConnection Class

The following tables list the members exposed by ImGearVectorEntityConnection.

See Also

Reference

ImGearVectorEntityConnection Class
ImageGear.Vector Namespace
ImGearVectorEntity Class


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityConnection Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityConnection Class

For a list of all members of this type, see ImGearVectorEntityConnection members.

See Also

Reference

ImGearVectorEntityConnection Class
ImageGear.Vector Namespace
ImGearVectorEntity Class


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityConnection Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityConnection Class

For a list of all members of this type, see ImGearVectorEntityConnection members.

See Also

Reference

ImGearVectorEntityConnection Class
ImageGear.Vector Namespace
ImGearVectorEntity Class


%%PageItemTitle%%

ImGearVectorEntityCont Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityCont Class
This object is used by blocks and figures to keep its entities.
Object Model
ImGearVectorEntityCont ClassImGearVectorEntity Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityCont
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorEntityCont
public class ImGearVectorEntityCont : ImGearVectorObject
public __gc class ImGearVectorEntityCont : public ImGearVectorObject
public ref class ImGearVectorEntityCont : public ImGearVectorObject
Remarks
Entity container does not own entities, it only stores pointers to the entity objects.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntityCont

See Also

Reference

ImGearVectorEntityCont Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityCont Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityCont Class

The following tables list the members exposed by ImGearVectorEntityCont.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of entities in the entity container.
Top
Public Methods
 | Name | Description
Public Method | AddEntity | Adds an entity to the entity container.
Public Method | GetEntity | Returns an entity specified by index.
Public Method | GetEntityIndex | Looks for the index by the entity object.
Public Method | RemoveEntity | Removes an entity specified by index from the container.
Top
See Also

Reference

ImGearVectorEntityCont Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityCont Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityCont Class

For a list of all members of this type, see ImGearVectorEntityCont members.

Public Methods
 | Name | Description
Public Method | AddEntity | Adds an entity to the entity container.
Public Method | GetEntity | Returns an entity specified by index.
Public Method | GetEntityIndex | Looks for the index by the entity object.
Public Method | RemoveEntity | Removes an entity specified by index from the container.
Top
See Also

Reference

ImGearVectorEntityCont Class
ImageGear.Vector Namespace


AddEntity Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityCont Class : AddEntity Method
Entity being added at the tail of the container.
Adds an entity to the entity container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddEntity( _
   ByVal entity As ImGearVectorEntity _
)
'Usage

Dim instance As ImGearVectorEntityCont
Dim entity As ImGearVectorEntity

instance.AddEntity(entity)
public void AddEntity(
   ImGearVectorEntity entity
)
public: void AddEntity(
   ImGearVectorEntity* entity
)
public:
void AddEntity(
   ImGearVectorEntity^ entity
)

Parameters

entity
Entity being added at the tail of the container.
See Also

Reference

ImGearVectorEntityCont Class
ImGearVectorEntityCont Members
ImGearVectorEntity Class


GetEntity Method (ImGearVectorEntityCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityCont Class : GetEntity Method
Index of entity to be returned.
Returns an entity specified by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEntity( _
   ByVal index As Integer _
) As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityCont
Dim index As Integer
Dim value As ImGearVectorEntity

value = instance.GetEntity(index)
public ImGearVectorEntity GetEntity(
   int index
)
public: ImGearVectorEntity* GetEntity(
   int index
)
public:
ImGearVectorEntity^ GetEntity(
   int index
)

Parameters

index
Index of entity to be returned.

Return Value

New instance of ImGearVectorEntity class object.
See Also

Reference

ImGearVectorEntityCont Class
ImGearVectorEntityCont Members


GetEntityIndex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityCont Class : GetEntityIndex Method
Entity being found in the container.
Looks for the index by the entity object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEntityIndex( _
   ByVal entity As ImGearVectorEntity _
) As Integer
'Usage

Dim instance As ImGearVectorEntityCont
Dim entity As ImGearVectorEntity
Dim value As Integer

value = instance.GetEntityIndex(entity)
public int GetEntityIndex(
   ImGearVectorEntity entity
)
public: int GetEntityIndex(
   ImGearVectorEntity* entity
)
public:
int GetEntityIndex(
   ImGearVectorEntity^ entity
)

Parameters

entity
Entity being found in the container.

Return Value

Any integer value.
See Also

Reference

ImGearVectorEntityCont Class
ImGearVectorEntityCont Members
ImGearVectorEntity Class


RemoveEntity Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityCont Class : RemoveEntity Method
Index of the entity being removed.
Removes an entity specified by index from the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveEntity( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorEntityCont
Dim index As Integer

instance.RemoveEntity(index)
public void RemoveEntity(
   int index
)
public: void RemoveEntity(
   int index
)
public:
void RemoveEntity(
   int index
)

Parameters

index
Index of the entity being removed.
See Also

Reference

ImGearVectorEntityCont Class
ImGearVectorEntityCont Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityCont Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityCont Class

For a list of all members of this type, see ImGearVectorEntityCont members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of entities in the entity container.
Top
See Also

Reference

ImGearVectorEntityCont Class
ImageGear.Vector Namespace


Count Property (ImGearVectorEntityCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityCont Class : Count Property
Gets the count of entities in the entity container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearVectorEntityCont
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearVectorEntityCont Class
ImGearVectorEntityCont Members


%%PageItemTitle%%

ImGearVectorEntityEasyline Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasyline Class
This entity represent a line specified by start and end point.
Object Model
ImGearVectorEntityEasyline ClassImGearVectorPoint3D StructureImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityEasyline
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityEasyline
public class ImGearVectorEntityEasyline : ImGearVectorEntity
public __gc class ImGearVectorEntityEasyline : public ImGearVectorEntity
public ref class ImGearVectorEntityEasyline : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityEasyline

See Also

Reference

ImGearVectorEntityEasyline Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityEasyline Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasyline Class

The following tables list the members exposed by ImGearVectorEntityEasyline.

Public Methods
 | Name | Description
Public Method | GetEndPoint | Returns the end point of the line.
Public Method | GetStartPoint | Returns the start point of the line.
Public Method | SetEndPoint | Sets the end point of the line.
Public Method | SetStartPoint | Sets the start point of the line.
Top
See Also

Reference

ImGearVectorEntityEasyline Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityEasyline Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasyline Class

For a list of all members of this type, see ImGearVectorEntityEasyline members.

See Also

Reference

ImGearVectorEntityEasyline Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityEasyline Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasyline Class

For a list of all members of this type, see ImGearVectorEntityEasyline members.

Public Methods
 | Name | Description
Public Method | GetEndPoint | Returns the end point of the line.
Public Method | GetStartPoint | Returns the start point of the line.
Public Method | SetEndPoint | Sets the end point of the line.
Public Method | SetStartPoint | Sets the start point of the line.
Top
See Also

Reference

ImGearVectorEntityEasyline Class
ImageGear.Vector Namespace


GetEndPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasyline Class : GetEndPoint Method
Returns the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEndPoint() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityEasyline
Dim value As ImGearVectorPoint3D

value = instance.GetEndPoint()
public ImGearVectorPoint3D GetEndPoint()
public: ImGearVectorPoint3D GetEndPoint();
public:
ImGearVectorPoint3D GetEndPoint();

Return Value

New instance of ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityEasyline Class
ImGearVectorEntityEasyline Members


GetStartPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasyline Class : GetStartPoint Method
Returns the start point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStartPoint() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityEasyline
Dim value As ImGearVectorPoint3D

value = instance.GetStartPoint()
public ImGearVectorPoint3D GetStartPoint()
public: ImGearVectorPoint3D GetStartPoint();
public:
ImGearVectorPoint3D GetStartPoint();

Return Value

New instance of ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityEasyline Class
ImGearVectorEntityEasyline Members


SetEndPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasyline Class : SetEndPoint Method
An end point of the line.
Sets the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetEndPoint( _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityEasyline
Dim point As ImGearVectorPoint3D

instance.SetEndPoint(point)
public void SetEndPoint(
   ImGearVectorPoint3D point
)
public: void SetEndPoint(
   ImGearVectorPoint3D point
)
public:
void SetEndPoint(
   ImGearVectorPoint3D point
)

Parameters

point
An end point of the line.
See Also

Reference

ImGearVectorEntityEasyline Class
ImGearVectorEntityEasyline Members
ImGearVectorPoint3D Structure


SetStartPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasyline Class : SetStartPoint Method
A start point of the line.
Sets the start point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetStartPoint( _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityEasyline
Dim point As ImGearVectorPoint3D

instance.SetStartPoint(point)
public void SetStartPoint(
   ImGearVectorPoint3D point
)
public: void SetStartPoint(
   ImGearVectorPoint3D point
)
public:
void SetStartPoint(
   ImGearVectorPoint3D point
)

Parameters

point
A start point of the line.
See Also

Reference

ImGearVectorEntityEasyline Class
ImGearVectorEntityEasyline Members
ImGearVectorPoint3D Structure


%%PageItemTitle%%

ImGearVectorEntityEasysurface Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasysurface Class
Represents a surface that is drawn exactly by its control points.
Object Model
ImGearVectorEntityEasysurface ClassImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityEasysurface
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityEasysurface
public class ImGearVectorEntityEasysurface : ImGearVectorEntity
public __gc class ImGearVectorEntityEasysurface : public ImGearVectorEntity
public ref class ImGearVectorEntityEasysurface : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityEasysurface

See Also

Reference

ImGearVectorEntityEasysurface Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityEasysurface Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasysurface Class

The following tables list the members exposed by ImGearVectorEntityEasysurface.

Public Properties
 | Name | Description
Public Property | Flags | Gets or sets a different surface flags such as closing in M or/and N direction.
Public Property | MDimension | Gets the count of points in M direction.
Public Property | NDimension | Gets the count of points in N direction.
Top
Public Methods
 | Name | Description
Public Method | GetPoint | Returns a point at the specified position.
Public Method | Init | Sets initial size of the meshes in M and N direction.
Public Method | SetPoint | Sets a point at the specified position.
Top
See Also

Reference

ImGearVectorEntityEasysurface Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityEasysurface Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasysurface Class

For a list of all members of this type, see ImGearVectorEntityEasysurface members.

Public Methods
 | Name | Description
Public Method | GetPoint | Returns a point at the specified position.
Public Method | Init | Sets initial size of the meshes in M and N direction.
Public Method | SetPoint | Sets a point at the specified position.
Top
See Also

Reference

ImGearVectorEntityEasysurface Class
ImageGear.Vector Namespace


GetPoint Method (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : GetPoint Method
Index of the point in M direction.
Index of the point in N direction.
Returns a point at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer _
) As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim indexM As Integer
Dim indexN As Integer
Dim value As ImGearVectorPoint3D

value = instance.GetPoint(indexM, indexN)
public ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)
public: ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)
public:
ImGearVectorPoint3D GetPoint(
   int indexM,
   int indexN
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.

Return Value

New instance of ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members


Init Method (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : Init Method
New size of the meshes in M direction.
New size of the meshes in N direction.
Sets initial size of the meshes in M and N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Init( _
   ByVal dimensionM As Integer, _
   ByVal dimensionN As Integer _
)
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim dimensionM As Integer
Dim dimensionN As Integer

instance.Init(dimensionM, dimensionN)
public void Init(
   int dimensionM,
   int dimensionN
)
public: void Init(
   int dimensionM,
   int dimensionN
)
public:
void Init(
   int dimensionM,
   int dimensionN
)

Parameters

dimensionM
New size of the meshes in M direction.
dimensionN
New size of the meshes in N direction.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members


SetPoint Method (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : SetPoint Method
Index of the point in M direction.
Index of the point in N direction.
Point value to be set.
Sets a point at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer, _
   ByVal point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim indexM As Integer
Dim indexN As Integer
Dim point As ImGearVectorPoint3D

instance.SetPoint(indexM, indexN, point)
public void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)
public: void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)
public:
void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3D point
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.
point
Point value to be set.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members
ImGearVectorPoint3D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityEasysurface Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEasysurface Class

For a list of all members of this type, see ImGearVectorEntityEasysurface members.

Public Properties
 | Name | Description
Public Property | Flags | Gets or sets a different surface flags such as closing in M or/and N direction.
Public Property | MDimension | Gets the count of points in M direction.
Public Property | NDimension | Gets the count of points in N direction.
Top
See Also

Reference

ImGearVectorEntityEasysurface Class
ImageGear.Vector Namespace


Flags Property (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : Flags Property
Gets or sets a different surface flags such as closing in M or/and N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim value As Integer

instance.Flags = value

value = instance.Flags
public int Flags {get; set;}
public: __property int get_Flags();
public: __property void set_Flags(
   int value
);
public:
property int Flags {
   int get();
   void set (    int value);
}

Property Value

Surface flags.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members


MDimension Property (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : MDimension Property
Gets the count of points in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MDimension As Integer
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim value As Integer

value = instance.MDimension
public int MDimension {get;}
public: __property int get_MDimension();
public:
property int MDimension {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members


NDimension Property (ImGearVectorEntityEasysurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEasysurface Class : NDimension Property
Gets the count of points in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NDimension As Integer
'Usage

Dim instance As ImGearVectorEntityEasysurface
Dim value As Integer

value = instance.NDimension
public int NDimension {get;}
public: __property int get_NDimension();
public:
property int NDimension {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityEasysurface Class
ImGearVectorEntityEasysurface Members


%%PageItemTitle%%

ImGearVectorEntityEllipse Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEllipse Class
Represents an ellipse.
Object Model
ImGearVectorEntityEllipse Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityEllipse
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityEllipse
public class ImGearVectorEntityEllipse : ImGearVectorEntity
public __gc class ImGearVectorEntityEllipse : public ImGearVectorEntity
public ref class ImGearVectorEntityEllipse : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityEllipse

See Also

Reference

ImGearVectorEntityEllipse Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityEllipse Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEllipse Class

The following tables list the members exposed by ImGearVectorEntityEllipse.

Public Properties
 | Name | Description
Public Property | RadiusX | Gets or sets a radius of the ellipse along the x-axis.
Public Property | RadiusY | Gets or sets a radius of the ellipse along the y-axis.
Top
See Also

Reference

ImGearVectorEntityEllipse Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityEllipse Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEllipse Class

For a list of all members of this type, see ImGearVectorEntityEllipse members.

Public Properties
 | Name | Description
Public Property | RadiusX | Gets or sets a radius of the ellipse along the x-axis.
Public Property | RadiusY | Gets or sets a radius of the ellipse along the y-axis.
Top
See Also

Reference

ImGearVectorEntityEllipse Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityEllipse Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityEllipse Class

For a list of all members of this type, see ImGearVectorEntityEllipse members.

See Also

Reference

ImGearVectorEntityEllipse Class
ImageGear.Vector Namespace


RadiusX Property (ImGearVectorEntityEllipse)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEllipse Class : RadiusX Property
Gets or sets a radius of the ellipse along the x-axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RadiusX As Single
'Usage

Dim instance As ImGearVectorEntityEllipse
Dim value As Single

instance.RadiusX = value

value = instance.RadiusX
public float RadiusX {get; set;}
public: __property float get_RadiusX();
public: __property void set_RadiusX(
   float value
);
public:
property float RadiusX {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorEntityEllipse Class
ImGearVectorEntityEllipse Members


RadiusY Property (ImGearVectorEntityEllipse)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityEllipse Class : RadiusY Property
Gets or sets a radius of the ellipse along the y-axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RadiusY As Single
'Usage

Dim instance As ImGearVectorEntityEllipse
Dim value As Single

instance.RadiusY = value

value = instance.RadiusY
public float RadiusY {get; set;}
public: __property float get_RadiusY();
public: __property void set_RadiusY(
   float value
);
public:
property float RadiusY {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorEntityEllipse Class
ImGearVectorEntityEllipse Members


%%PageItemTitle%%

ImGearVectorEntityFigure Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityFigure Class
Represents an entity that contains several regions. Any region can include other entities such as lines, polylines, arcs and other entities.
Object Model
ImGearVectorEntityFigure ClassImGearVectorEntityCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityFigure
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityFigure
public class ImGearVectorEntityFigure : ImGearVectorEntity
public __gc class ImGearVectorEntityFigure : public ImGearVectorEntity
public ref class ImGearVectorEntityFigure : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityFigure

See Also

Reference

ImGearVectorEntityFigure Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityFigure Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityFigure Class

The following tables list the members exposed by ImGearVectorEntityFigure.

Public Properties
 | Name | Description
Public Property | RegionCount | Gets total count of regions in the figure.
Top
Public Methods
 | Name | Description
Public Method | GetEntityCont | Returns an entity container defining the current region.
Public Method | SetRegion | Sets the current region.
Top
See Also

Reference

ImGearVectorEntityFigure Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityFigure Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityFigure Class

For a list of all members of this type, see ImGearVectorEntityFigure members.

Public Methods
 | Name | Description
Public Method | GetEntityCont | Returns an entity container defining the current region.
Public Method | SetRegion | Sets the current region.
Top
See Also

Reference

ImGearVectorEntityFigure Class
ImageGear.Vector Namespace


GetEntityCont Method (ImGearVectorEntityFigure)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityFigure Class : GetEntityCont Method
Returns an entity container defining the current region.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEntityCont() As ImGearVectorEntityCont
'Usage

Dim instance As ImGearVectorEntityFigure
Dim value As ImGearVectorEntityCont

value = instance.GetEntityCont()
public ImGearVectorEntityCont GetEntityCont()
public: ImGearVectorEntityCont* GetEntityCont();
public:
ImGearVectorEntityCont^ GetEntityCont();

Return Value

New instance of ImGearVectorEntityCont class object.
Remarks
Current region is set by the SetRegion method.
See Also

Reference

ImGearVectorEntityFigure Class
ImGearVectorEntityFigure Members


SetRegion Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityFigure Class : SetRegion Method
Current region being set.
Sets the current region.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetRegion( _
   ByVal region As Integer _
)
'Usage

Dim instance As ImGearVectorEntityFigure
Dim region As Integer

instance.SetRegion(region)
public void SetRegion(
   int region
)
public: void SetRegion(
   int region
)
public:
void SetRegion(
   int region
)

Parameters

region
Current region being set.
See Also

Reference

ImGearVectorEntityFigure Class
ImGearVectorEntityFigure Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityFigure Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityFigure Class

For a list of all members of this type, see ImGearVectorEntityFigure members.

Public Properties
 | Name | Description
Public Property | RegionCount | Gets total count of regions in the figure.
Top
See Also

Reference

ImGearVectorEntityFigure Class
ImageGear.Vector Namespace


RegionCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityFigure Class : RegionCount Property
Gets total count of regions in the figure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RegionCount As Integer
'Usage

Dim instance As ImGearVectorEntityFigure
Dim value As Integer

value = instance.RegionCount
public int RegionCount {get;}
public: __property int get_RegionCount();
public:
property int RegionCount {
   int get();
}

Property Value

Any integer value.
See Also

Reference

ImGearVectorEntityFigure Class
ImGearVectorEntityFigure Members


%%PageItemTitle%%

ImGearVectorEntityGeometry Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityGeometry Class
Represents a set of drawing primitives such as points, independent line segments, connected line segments, independent and connected triangles, independent and connected quadrilaterals, or polygons.
Object Model
ImGearVectorEntityGeometry Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityGeometry
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityGeometry
public class ImGearVectorEntityGeometry : ImGearVectorEntity
public __gc class ImGearVectorEntityGeometry : public ImGearVectorEntity
public ref class ImGearVectorEntityGeometry : public ImGearVectorEntity
Remarks
The primitives are specified with vertex array. Normals for any vertex can be specified as well.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityGeometry

See Also

Reference

ImGearVectorEntityGeometry Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityGeometry Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityGeometry Class

The following tables list the members exposed by ImGearVectorEntityGeometry.

Public Properties
 | Name | Description
Public Property | ColorAlign | Gets the byte offset between consecutive colors in the color array.
Public Property | GeometryType | Gets the type of geometry contained by the geometry entity.
Public Property | PointCount | Gets the point count in the entity.
Public Property | UseColors | Gets a value indicating whether local colors are used when drawing the geometry.
Public Property | UseNormals | Gets a value indicating whether normals are used when drawing the geometry.
Top
Public Methods
 | Name | Description
Public Method | GetColors | Returns the geometry colors on the specified range.
Public Method | GetNormals | Returns the geometry normals on the specified range.
Public Method | GetPoints | Returns the geometry points on the specified range.
Public Method | Init | Initializes the geometry with the geometry type, point count, color alignment and flags of using colors and normals.
Public Method | SetColors | Sets the geometry colors on the specified range.
Public Method | SetNormals | Sets the geometry normals on the specified range.
Public Method | SetPoints | Sets the geometry points on the specified range.
Top
See Also

Reference

ImGearVectorEntityGeometry Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityGeometry Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityGeometry Class

For a list of all members of this type, see ImGearVectorEntityGeometry members.

Public Methods
 | Name | Description
Public Method | GetColors | Returns the geometry colors on the specified range.
Public Method | GetNormals | Returns the geometry normals on the specified range.
Public Method | GetPoints | Returns the geometry points on the specified range.
Public Method | Init | Initializes the geometry with the geometry type, point count, color alignment and flags of using colors and normals.
Public Method | SetColors | Sets the geometry colors on the specified range.
Public Method | SetNormals | Sets the geometry normals on the specified range.
Public Method | SetPoints | Sets the geometry points on the specified range.
Top
See Also

Reference

ImGearVectorEntityGeometry Class
ImageGear.Vector Namespace


GetColors Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : GetColors Method
Buffer for the colors. The buffer must be long enough to receive the colors from start to end taking into account the color alignment.
The start position of the color to be returned.
The end position of the color to be returned.
Returns the geometry colors on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetColors( _
   ByVal colors() As Byte, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim colors() As Byte
Dim start As Integer
Dim end As Integer

instance.GetColors(colors, start, end)
public void GetColors(
   byte[] colors,
   int start,
   int end
)
public: void GetColors(
   byte[]* colors,
   int start,
   int end
)
public:
void GetColors(
   array<byte>^ colors,
   int start,
   int end
)

Parameters

colors
Buffer for the colors. The buffer must be long enough to receive the colors from start to end taking into account the color alignment.
start
The start position of the color to be returned.
end
The end position of the color to be returned.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


GetNormals Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : GetNormals Method
Buffer for the normals. The buffer must be long enough to receive the normals from start to end taking into account the normal size (three floating-point values).
The start position of the normal to be returned.
The end position of the normal to be returned.
Returns the geometry normals on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetNormals( _
   ByVal normals() As Single, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim normals() As Single
Dim start As Integer
Dim end As Integer

instance.GetNormals(normals, start, end)
public void GetNormals(
   float[] normals,
   int start,
   int end
)
public: void GetNormals(
   float[]* normals,
   int start,
   int end
)
public:
void GetNormals(
   array<float>^ normals,
   int start,
   int end
)

Parameters

normals
Buffer for the normals. The buffer must be long enough to receive the normals from start to end taking into account the normal size (three floating-point values).
start
The start position of the normal to be returned.
end
The end position of the normal to be returned.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


GetPoints Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : GetPoints Method
Buffer for the points. The buffer must be long enough to receive the points from start to end taking into account the point size (three floating-point values).
The start position of the normal to be returned.
The end position of the normal to be returned.
Returns the geometry points on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetPoints( _
   ByVal points() As Single, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim points() As Single
Dim start As Integer
Dim end As Integer

instance.GetPoints(points, start, end)
public void GetPoints(
   float[] points,
   int start,
   int end
)
public: void GetPoints(
   float[]* points,
   int start,
   int end
)
public:
void GetPoints(
   array<float>^ points,
   int start,
   int end
)

Parameters

points
Buffer for the points. The buffer must be long enough to receive the points from start to end taking into account the point size (three floating-point values).
start
The start position of the normal to be returned.
end
The end position of the normal to be returned.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


Init Method (ImGearVectorEntityGeometry)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : Init Method
Type of the geometry primitives. See enumeration ImGearVectGeometryType enumeration for possible values.
Count of vertices in the geometry. Point, normal and color arrays must have the same amount of elements in case of usage.
Color alignment in the color array. Has effect only if useColors is true.
If true than the normals are taken into account when displaying the geometry. Normals must be set before displaying in this case.
If true then the local colors are taken into account when displaying the geometry. Colors must be set before displaying in this case.
Initializes the geometry with the geometry type, point count, color alignment and flags of using colors and normals.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Init( _
   ByVal geometryType As ImGearVectGeometryType, _
   ByVal pointCount As Integer, _
   ByVal colorAlignment As Integer, _
   ByVal useNormals As Boolean, _
   ByVal useColors As Boolean _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim geometryType As ImGearVectGeometryType
Dim pointCount As Integer
Dim colorAlignment As Integer
Dim useNormals As Boolean
Dim useColors As Boolean

instance.Init(geometryType, pointCount, colorAlignment, useNormals, useColors)
public void Init(
   ImGearVectGeometryType geometryType,
   int pointCount,
   int colorAlignment,
   bool useNormals,
   bool useColors
)
public: void Init(
   ImGearVectGeometryType geometryType,
   int pointCount,
   int colorAlignment,
   bool useNormals,
   bool useColors
)
public:
void Init(
   ImGearVectGeometryType geometryType,
   int pointCount,
   int colorAlignment,
   bool useNormals,
   bool useColors
)

Parameters

geometryType
Type of the geometry primitives. See enumeration ImGearVectGeometryType enumeration for possible values.
pointCount
Count of vertices in the geometry. Point, normal and color arrays must have the same amount of elements in case of usage.
colorAlignment
Color alignment in the color array. Has effect only if useColors is true.
useNormals
If true than the normals are taken into account when displaying the geometry. Normals must be set before displaying in this case.
useColors
If true then the local colors are taken into account when displaying the geometry. Colors must be set before displaying in this case.
Remarks
This method must be called before any other geometry properties and methods.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members
ImGearVectGeometryType Enumeration


SetColors Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : SetColors Method
Buffer with the new colors.
The start position of the color to be set.
The end position of the color to be set.
Sets the geometry colors on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetColors( _
   ByVal colors() As Byte, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim colors() As Byte
Dim start As Integer
Dim end As Integer

instance.SetColors(colors, start, end)
public void SetColors(
   byte[] colors,
   int start,
   int end
)
public: void SetColors(
   byte[]* colors,
   int start,
   int end
)
public:
void SetColors(
   array<byte>^ colors,
   int start,
   int end
)

Parameters

colors
Buffer with the new colors.
start
The start position of the color to be set.
end
The end position of the color to be set.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


SetNormals Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : SetNormals Method
Buffer with the new normals.
The start position of the normal to be set.
The end position of the normal to be set.
Sets the geometry normals on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetNormals( _
   ByVal normals() As Single, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim normals() As Single
Dim start As Integer
Dim end As Integer

instance.SetNormals(normals, start, end)
public void SetNormals(
   float[] normals,
   int start,
   int end
)
public: void SetNormals(
   float[]* normals,
   int start,
   int end
)
public:
void SetNormals(
   array<float>^ normals,
   int start,
   int end
)

Parameters

normals
Buffer with the new normals.
start
The start position of the normal to be set.
end
The end position of the normal to be set.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


SetPoints Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : SetPoints Method
Buffer with the new points.
The start index of the point to be set.
The end index of the point to be set.
Sets the geometry points on the specified range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoints( _
   ByVal points() As Single, _
   ByVal start As Integer, _
   ByVal end As Integer _
)
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim points() As Single
Dim start As Integer
Dim end As Integer

instance.SetPoints(points, start, end)
public void SetPoints(
   float[] points,
   int start,
   int end
)
public: void SetPoints(
   float[]* points,
   int start,
   int end
)
public:
void SetPoints(
   array<float>^ points,
   int start,
   int end
)

Parameters

points
Buffer with the new points.
start
The start index of the point to be set.
end
The end index of the point to be set.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityGeometry Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityGeometry Class

For a list of all members of this type, see ImGearVectorEntityGeometry members.

Public Properties
 | Name | Description
Public Property | ColorAlign | Gets the byte offset between consecutive colors in the color array.
Public Property | GeometryType | Gets the type of geometry contained by the geometry entity.
Public Property | PointCount | Gets the point count in the entity.
Public Property | UseColors | Gets a value indicating whether local colors are used when drawing the geometry.
Public Property | UseNormals | Gets a value indicating whether normals are used when drawing the geometry.
Top
See Also

Reference

ImGearVectorEntityGeometry Class
ImageGear.Vector Namespace


ColorAlign Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : ColorAlign Property
Gets the byte offset between consecutive colors in the color array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorAlign As Integer
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim value As Integer

value = instance.ColorAlign
public int ColorAlign {get;}
public: __property int get_ColorAlign();
public:
property int ColorAlign {
   int get();
}

Property Value

Usually 3 or 4 (rgb, rgba).
Remarks
It makes sense only if UseColors property is true. Color alignment is initially set by Init method.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


GeometryType Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : GeometryType Property
Gets the type of geometry contained by the geometry entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property GeometryType As ImGearVectGeometryType
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim value As ImGearVectGeometryType

value = instance.GeometryType
public ImGearVectGeometryType GeometryType {get;}
public: __property ImGearVectGeometryType get_GeometryType();
public:
property ImGearVectGeometryType GeometryType {
   ImGearVectGeometryType get();
}

Property Value

ImGearVectGeometryType enumeration value.
Remarks
See ImGearVectGeometryType enumeration for more information.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members
ImGearVectGeometryType Enumeration


PointCount Property (ImGearVectorEntityGeometry)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : PointCount Property
Gets the point count in the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PointCount As Integer
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim value As Integer

value = instance.PointCount
public int PointCount {get;}
public: __property int get_PointCount();
public:
property int PointCount {
   int get();
}

Property Value

Any non-negative value.
Remarks
Point count is initially set by Init method.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


UseColors Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : UseColors Property
Gets a value indicating whether local colors are used when drawing the geometry.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UseColors As Boolean
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim value As Boolean

value = instance.UseColors
public bool UseColors {get;}
public: __property bool get_UseColors();
public:
property bool UseColors {
   bool get();
}

Property Value

Boolean value.
Remarks
If it is false then the color array is not used and the geometry is drawn with the current color. Initially this property is set by the useColors parameter in the Init method.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


UseNormals Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityGeometry Class : UseNormals Property
Gets a value indicating whether normals are used when drawing the geometry.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UseNormals As Boolean
'Usage

Dim instance As ImGearVectorEntityGeometry
Dim value As Boolean

value = instance.UseNormals
public bool UseNormals {get;}
public: __property bool get_UseNormals();
public:
property bool UseNormals {
   bool get();
}

Property Value

Boolean value.
Remarks
If it is false then the normal array is not used. Initially this property is set by the useNormals parameter in Init method.
See Also

Reference

ImGearVectorEntityGeometry Class
ImGearVectorEntityGeometry Members


%%PageItemTitle%%

ImGearVectorEntityInsertion Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityInsertion Class
Represents a transformation wrapper for the block.
Object Model
ImGearVectorEntityInsertion ClassImGearVectorEntity Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityInsertion
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityInsertion
public class ImGearVectorEntityInsertion : ImGearVectorEntity
public __gc class ImGearVectorEntityInsertion : public ImGearVectorEntity
public ref class ImGearVectorEntityInsertion : public ImGearVectorEntity
Remarks
The block should be added to the other blocks using insertion. It is not recommended to add blocks to the entity container directly, as well as to change the transformation matrix of the block.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityInsertion

See Also

Reference

ImGearVectorEntityInsertion Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityInsertion Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityInsertion Class

The following tables list the members exposed by ImGearVectorEntityInsertion.

Public Properties
 | Name | Description
Public Property | BlockRef | Gets or sets a block reference for the insertion.
Top
See Also

Reference

ImGearVectorEntityInsertion Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityInsertion Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityInsertion Class

For a list of all members of this type, see ImGearVectorEntityInsertion members.

Public Properties
 | Name | Description
Public Property | BlockRef | Gets or sets a block reference for the insertion.
Top
See Also

Reference

ImGearVectorEntityInsertion Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityInsertion Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityInsertion Class

For a list of all members of this type, see ImGearVectorEntityInsertion members.

See Also

Reference

ImGearVectorEntityInsertion Class
ImageGear.Vector Namespace


BlockRef Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityInsertion Class : BlockRef Property
Gets or sets a block reference for the insertion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlockRef As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityInsertion
Dim value As ImGearVectorEntity

instance.BlockRef = value

value = instance.BlockRef
public ImGearVectorEntity BlockRef {get; set;}
public: __property ImGearVectorEntity* get_BlockRef();
public: __property void set_BlockRef(
   ImGearVectorEntity* value
);
public:
property ImGearVectorEntity^ BlockRef {
   ImGearVectorEntity^ get();
   void set (    ImGearVectorEntity^ value);
}

Property Value

ImGearVectorEntity class object.
See Also

Reference

ImGearVectorEntityInsertion Class
ImGearVectorEntityInsertion Members


%%PageItemTitle%%

ImGearVectorEntityNURBScurve Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBScurve Class
Represents non-uniform rational bi-spline curve.
Object Model
ImGearVectorEntityNURBScurve ClassImGearVectorFloatCont ClassImGearVectorVertexCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityNURBScurve
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityNURBScurve
public class ImGearVectorEntityNURBScurve : ImGearVectorEntity
public __gc class ImGearVectorEntityNURBScurve : public ImGearVectorEntity
public ref class ImGearVectorEntityNURBScurve : public ImGearVectorEntity
Remarks
NURBS curve is defined by control points, spline degree and knot vector. Also, any control point can have additional weights.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityNURBScurve

See Also

Reference

ImGearVectorEntityNURBScurve Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityNURBScurve Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBScurve Class

The following tables list the members exposed by ImGearVectorEntityNURBScurve.

Public Properties
 | Name | Description
Public Property | Degree | Gets or sets a degree of the NURBS curve.
Public Property | Flags | Gets or sets NURBS flags.
Public Property | Step | Gets or sets an interpolation step.
Top
Public Methods
 | Name | Description
Public Method | GetKnots | Returns a container of the NURBS curve knot vector.
Public Method | GetVertexCont | Returns a Vertex Container with the control points of the NURBS curve.
Top
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityNURBScurve Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBScurve Class

For a list of all members of this type, see ImGearVectorEntityNURBScurve members.

Public Methods
 | Name | Description
Public Method | GetKnots | Returns a container of the NURBS curve knot vector.
Public Method | GetVertexCont | Returns a Vertex Container with the control points of the NURBS curve.
Top
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImageGear.Vector Namespace


GetKnots Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBScurve Class : GetKnots Method
Returns a container of the NURBS curve knot vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetKnots() As ImGearVectorFloatCont
'Usage

Dim instance As ImGearVectorEntityNURBScurve
Dim value As ImGearVectorFloatCont

value = instance.GetKnots()
public ImGearVectorFloatCont GetKnots()
public: ImGearVectorFloatCont* GetKnots();
public:
ImGearVectorFloatCont^ GetKnots();

Return Value

ImGearVectorFloatCont class object or null.
Remarks
If knot vector is empty then the standard knot vector is calculated.
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImGearVectorEntityNURBScurve Members


GetVertexCont Method (ImGearVectorEntityNURBScurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBScurve Class : GetVertexCont Method
Returns a Vertex Container with the control points of the NURBS curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVertexCont() As ImGearVectorVertexCont
'Usage

Dim instance As ImGearVectorEntityNURBScurve
Dim value As ImGearVectorVertexCont

value = instance.GetVertexCont()
public ImGearVectorVertexCont GetVertexCont()
public: ImGearVectorVertexCont* GetVertexCont();
public:
ImGearVectorVertexCont^ GetVertexCont();

Return Value

New instance of ImGearVectorVertexCont class.
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImGearVectorEntityNURBScurve Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityNURBScurve Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBScurve Class

For a list of all members of this type, see ImGearVectorEntityNURBScurve members.

Public Properties
 | Name | Description
Public Property | Degree | Gets or sets a degree of the NURBS curve.
Public Property | Flags | Gets or sets NURBS flags.
Public Property | Step | Gets or sets an interpolation step.
Top
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImageGear.Vector Namespace


Degree Property (ImGearVectorEntityNURBScurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBScurve Class : Degree Property
Gets or sets a degree of the NURBS curve.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Degree As Integer
'Usage

Dim instance As ImGearVectorEntityNURBScurve
Dim value As Integer

instance.Degree = value

value = instance.Degree
public int Degree {get; set;}
public: __property int get_Degree();
public: __property void set_Degree(
   int value
);
public:
property int Degree {
   int get();
   void set (    int value);
}

Property Value

Numeric value equal to 2 or greater.
Remarks
Usually count of knots is equals to count of control points + degree + 1. If this is not so then knot vector is corrected. The default value is 3.
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImGearVectorEntityNURBScurve Members


Flags Property (ImGearVectorEntityNURBScurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBScurve Class : Flags Property
Gets or sets NURBS flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntityNURBScurve
Dim value As Integer

instance.Flags = value

value = instance.Flags
public int Flags {get; set;}
public: __property int get_Flags();
public: __property void set_Flags(
   int value
);
public:
property int Flags {
   int get();
   void set (    int value);
}

Property Value

Combination of ImGearVectNURBSFlags enumeration or 0.
Remarks
The default value is 0.
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImGearVectorEntityNURBScurve Members


Step Property (ImGearVectorEntityNURBScurve)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBScurve Class : Step Property
Gets or sets an interpolation step.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Step As Single
'Usage

Dim instance As ImGearVectorEntityNURBScurve
Dim value As Single

instance.Step = value

value = instance.Step
public float Step {get; set;}
public: __property float get_Step();
public: __property void set_Step(
   float value
);
public:
property float Step {
   float get();
   void set (    float value);
}

Property Value

Any value in the 0..1 range.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityNURBScurve Class
ImGearVectorEntityNURBScurve Members


%%PageItemTitle%%

ImGearVectorEntityNURBSsurface Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBSsurface Class
Represents a non-uniform rational B-spline surface.
Object Model
ImGearVectorEntityNURBSsurface ClassImGearVectorFloatCont ClassImGearVectorFloatCont ClassImGearVectorPoint3DEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityNURBSsurface
   Inherits ImGearVectorEntitySplinesurface
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
public class ImGearVectorEntityNURBSsurface : ImGearVectorEntitySplinesurface
public __gc class ImGearVectorEntityNURBSsurface : public ImGearVectorEntitySplinesurface
public ref class ImGearVectorEntityNURBSsurface : public ImGearVectorEntitySplinesurface
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntitySplinesurface
ImageGear.Vector.ImGearVectorEntityNURBSsurface

See Also

Reference

ImGearVectorEntityNURBSsurface Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityNURBSsurface Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBSsurface Class

The following tables list the members exposed by ImGearVectorEntityNURBSsurface.

Public Properties
 | Name | Description
Public Property | Flags | Overridden. Gets or sets NURBS surface flags.
Public Property | MDegree | Overridden. Gets the degree of the NURBS surface in M direction.
Public Property | MDimension | Overridden. Gets a count of control points in M direction.
Public Property | MStep | Overridden. Gets or sets interpolation step in M direction.
Public Property | NDegree | Overridden. Gets the degree of the NURBS surface in N direction.
Public Property | NDimension | Overridden. Gets a count of control points in N direction.
Public Property | NStep | Overridden. Gets or sets interpolation step in N direction.
Top
Public Methods
 | Name | Description
Public Method | GetMKnots | Returns a container with knot vector in M direction. If this container is empty then the standard knot vector is calculated.
Public Method | GetNKnots | Returns a container with knot vector in N direction. If this container is empty then the standard knot vector is calculated.
Public Method | GetPoint | Returns a surface point from the specified position.
Public Method | Init | Overridden. Sets initial dimensions and degrees of the NURBS surface.
Public Method | SetPoint | Sets a point to the specified position of the surface.
Top
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityNURBSsurface Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBSsurface Class

For a list of all members of this type, see ImGearVectorEntityNURBSsurface members.

Public Methods
 | Name | Description
Public Method | GetMKnots | Returns a container with knot vector in M direction. If this container is empty then the standard knot vector is calculated.
Public Method | GetNKnots | Returns a container with knot vector in N direction. If this container is empty then the standard knot vector is calculated.
Public Method | GetPoint | Returns a surface point from the specified position.
Public Method | Init | Overridden. Sets initial dimensions and degrees of the NURBS surface.
Public Method | SetPoint | Sets a point to the specified position of the surface.
Top
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImageGear.Vector Namespace


GetMKnots Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : GetMKnots Method
Returns a container with knot vector in M direction. If this container is empty then the standard knot vector is calculated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMKnots() As ImGearVectorFloatCont
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As ImGearVectorFloatCont

value = instance.GetMKnots()
public ImGearVectorFloatCont GetMKnots()
public: ImGearVectorFloatCont* GetMKnots();
public:
ImGearVectorFloatCont^ GetMKnots();

Return Value

New instance of ImGearVectorFloatCont class.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


GetNKnots Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : GetNKnots Method
Returns a container with knot vector in N direction. If this container is empty then the standard knot vector is calculated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNKnots() As ImGearVectorFloatCont
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As ImGearVectorFloatCont

value = instance.GetNKnots()
public ImGearVectorFloatCont GetNKnots()
public: ImGearVectorFloatCont* GetNKnots();
public:
ImGearVectorFloatCont^ GetNKnots();

Return Value

New instance of ImGearVectorFloatCont class.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


GetPoint Method (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : GetPoint Method
Index of the point in M direction.
Index of the point in N direction.
Returns a surface point from the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer _
) As ImGearVectorPoint3DEx
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim indexM As Integer
Dim indexN As Integer
Dim value As ImGearVectorPoint3DEx

value = instance.GetPoint(indexM, indexN)
public ImGearVectorPoint3DEx GetPoint(
   int indexM,
   int indexN
)
public: ImGearVectorPoint3DEx GetPoint(
   int indexM,
   int indexN
)
public:
ImGearVectorPoint3DEx GetPoint(
   int indexM,
   int indexN
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.

Return Value

New instance of ImGearVectorPoint3DEx structure.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


Init Method (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : Init Method
Number of control points in M direction.
Number of control points in N direction.
Surface degree in M direction.
Surface degree in N direction.
Sets initial dimensions and degrees of the NURBS surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Init( _
   ByVal dimensionM As Integer, _
   ByVal dimensionN As Integer, _
   ByVal degreeM As Integer, _
   ByVal degreeN As Integer _
)
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim dimensionM As Integer
Dim dimensionN As Integer
Dim degreeM As Integer
Dim degreeN As Integer

instance.Init(dimensionM, dimensionN, degreeM, degreeN)
public override void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
)
public: void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
) override
public:
void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
) override

Parameters

dimensionM
Number of control points in M direction.
dimensionN
Number of control points in N direction.
degreeM
Surface degree in M direction.
degreeN
Surface degree in N direction.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


SetPoint Method (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : SetPoint Method
Index of the point in M direction.
Index of the point in N direction.
ImGearVectorPoint3Dx object with new point coordinates.
Sets a point to the specified position of the surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal indexM As Integer, _
   ByVal indexN As Integer, _
   ByVal point As ImGearVectorPoint3DEx _
)
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim indexM As Integer
Dim indexN As Integer
Dim point As ImGearVectorPoint3DEx

instance.SetPoint(indexM, indexN, point)
public void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3DEx point
)
public: void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3DEx point
)
public:
void SetPoint(
   int indexM,
   int indexN,
   ImGearVectorPoint3DEx point
)

Parameters

indexM
Index of the point in M direction.
indexN
Index of the point in N direction.
point
ImGearVectorPoint3Dx object with new point coordinates.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members
ImGearVectorPoint3DEx Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityNURBSsurface Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityNURBSsurface Class

For a list of all members of this type, see ImGearVectorEntityNURBSsurface members.

Public Properties
 | Name | Description
Public Property | Flags | Overridden. Gets or sets NURBS surface flags.
Public Property | MDegree | Overridden. Gets the degree of the NURBS surface in M direction.
Public Property | MDimension | Overridden. Gets a count of control points in M direction.
Public Property | MStep | Overridden. Gets or sets interpolation step in M direction.
Public Property | NDegree | Overridden. Gets the degree of the NURBS surface in N direction.
Public Property | NDimension | Overridden. Gets a count of control points in N direction.
Public Property | NStep | Overridden. Gets or sets interpolation step in N direction.
Top
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImageGear.Vector Namespace


Flags Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : Flags Property
Gets or sets NURBS surface flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Integer

instance.Flags = value

value = instance.Flags
public override int Flags {get; set;}
public: __property int get_Flags() override;
public: __property void set_Flags(
   int value
) override;
public:
property int Flags {
   int get() override;
   void set (    int value) override;
}

Property Value

Combination of ImGearVectNURBSFlags enumeration or 0.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


MDegree Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : MDegree Property
Gets the degree of the NURBS surface in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property MDegree As Integer
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Integer

value = instance.MDegree
public override int MDegree {get;}
public: __property int get_MDegree() override;
public:
property int MDegree {
   int get() override;
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


MDimension Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : MDimension Property
Gets a count of control points in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property MDimension As Integer
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Integer

value = instance.MDimension
public override int MDimension {get;}
public: __property int get_MDimension() override;
public:
property int MDimension {
   int get() override;
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


MStep Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : MStep Property
Gets or sets interpolation step in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property MStep As Single
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Single

instance.MStep = value

value = instance.MStep
public override float MStep {get; set;}
public: __property float get_MStep() override;
public: __property void set_MStep(
   float value
) override;
public:
property float MStep {
   float get() override;
   void set (    float value) override;
}

Property Value

Value in interval 0..1.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


NDegree Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : NDegree Property
Gets the degree of the NURBS surface in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property NDegree As Integer
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Integer

value = instance.NDegree
public override int NDegree {get;}
public: __property int get_NDegree() override;
public:
property int NDegree {
   int get() override;
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


NDimension Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : NDimension Property
Gets a count of control points in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property NDimension As Integer
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Integer

value = instance.NDimension
public override int NDimension {get;}
public: __property int get_NDimension() override;
public:
property int NDimension {
   int get() override;
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


NStep Property (ImGearVectorEntityNURBSsurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityNURBSsurface Class : NStep Property
Gets or sets interpolation step in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property NStep As Single
'Usage

Dim instance As ImGearVectorEntityNURBSsurface
Dim value As Single

instance.NStep = value

value = instance.NStep
public override float NStep {get; set;}
public: __property float get_NStep() override;
public: __property void set_NStep(
   float value
) override;
public:
property float NStep {
   float get() override;
   void set (    float value) override;
}

Property Value

Value in interval 0..1.
Remarks
The default value is 0.2.
See Also

Reference

ImGearVectorEntityNURBSsurface Class
ImGearVectorEntityNURBSsurface Members


%%PageItemTitle%%

ImGearVectorEntityPolyline Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolyline Class
Represents a polyline.
Object Model
ImGearVectorEntityPolyline ClassImGearVectorVertexCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityPolyline
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityPolyline
public class ImGearVectorEntityPolyline : ImGearVectorEntity
public __gc class ImGearVectorEntityPolyline : public ImGearVectorEntity
public ref class ImGearVectorEntityPolyline : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityPolyline

See Also

Reference

ImGearVectorEntityPolyline Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityPolyline Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolyline Class

The following tables list the members exposed by ImGearVectorEntityPolyline.

Public Methods
 | Name | Description
Public Method | GetVertexCont | Returns a vertex container with the polyline vertices.
Top
See Also

Reference

ImGearVectorEntityPolyline Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityPolyline Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolyline Class

For a list of all members of this type, see ImGearVectorEntityPolyline members.

See Also

Reference

ImGearVectorEntityPolyline Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityPolyline Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolyline Class

For a list of all members of this type, see ImGearVectorEntityPolyline members.

Public Methods
 | Name | Description
Public Method | GetVertexCont | Returns a vertex container with the polyline vertices.
Top
See Also

Reference

ImGearVectorEntityPolyline Class
ImageGear.Vector Namespace


GetVertexCont Method (ImGearVectorEntityPolyline)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityPolyline Class : GetVertexCont Method
Returns a vertex container with the polyline vertices.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVertexCont() As ImGearVectorVertexCont
'Usage

Dim instance As ImGearVectorEntityPolyline
Dim value As ImGearVectorVertexCont

value = instance.GetVertexCont()
public ImGearVectorVertexCont GetVertexCont()
public: ImGearVectorVertexCont* GetVertexCont();
public:
ImGearVectorVertexCont^ GetVertexCont();

Return Value

New instance of ImGearVectorVertexCont class.
See Also

Reference

ImGearVectorEntityPolyline Class
ImGearVectorEntityPolyline Members


%%PageItemTitle%%

ImGearVectorEntityPolylineEx Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolylineEx Class
Represents extended polyline.
Object Model
ImGearVectorEntityPolylineEx ClassImGearVectorVertexCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityPolylineEx
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityPolylineEx
public class ImGearVectorEntityPolylineEx : ImGearVectorEntity
public __gc class ImGearVectorEntityPolylineEx : public ImGearVectorEntity
public ref class ImGearVectorEntityPolylineEx : public ImGearVectorEntity
Remarks
Extended polyline object can have more than one disjointed contour.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityPolylineEx

See Also

Reference

ImGearVectorEntityPolylineEx Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityPolylineEx Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolylineEx Class

The following tables list the members exposed by ImGearVectorEntityPolylineEx.

Public Properties
 | Name | Description
Public Property | ContourCount | Gets a total count of the contours in the extended polyline.
Top
Public Methods
 | Name | Description
Public Method | GetVertexCont | Returns a vertex container describing one of the contours of the extended polyline.
Public Method | SetContour | Sets the number of the active contour.
Top
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityPolylineEx Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolylineEx Class

For a list of all members of this type, see ImGearVectorEntityPolylineEx members.

Public Methods
 | Name | Description
Public Method | GetVertexCont | Returns a vertex container describing one of the contours of the extended polyline.
Public Method | SetContour | Sets the number of the active contour.
Top
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImageGear.Vector Namespace


GetVertexCont Method (ImGearVectorEntityPolylineEx)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityPolylineEx Class : GetVertexCont Method
Returns a vertex container describing one of the contours of the extended polyline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVertexCont() As ImGearVectorVertexCont
'Usage

Dim instance As ImGearVectorEntityPolylineEx
Dim value As ImGearVectorVertexCont

value = instance.GetVertexCont()
public ImGearVectorVertexCont GetVertexCont()
public: ImGearVectorVertexCont* GetVertexCont();
public:
ImGearVectorVertexCont^ GetVertexCont();

Return Value

New instance of ImGearVectorVertexCont class.
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImGearVectorEntityPolylineEx Members


SetContour Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityPolylineEx Class : SetContour Method
Number of the active contour being set.
Sets the number of the active contour.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetContour( _
   ByVal contour As Integer _
)
'Usage

Dim instance As ImGearVectorEntityPolylineEx
Dim contour As Integer

instance.SetContour(contour)
public void SetContour(
   int contour
)
public: void SetContour(
   int contour
)
public:
void SetContour(
   int contour
)

Parameters

contour
Number of the active contour being set.
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImGearVectorEntityPolylineEx Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityPolylineEx Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityPolylineEx Class

For a list of all members of this type, see ImGearVectorEntityPolylineEx members.

Public Properties
 | Name | Description
Public Property | ContourCount | Gets a total count of the contours in the extended polyline.
Top
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImageGear.Vector Namespace


ContourCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityPolylineEx Class : ContourCount Property
Gets a total count of the contours in the extended polyline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContourCount As Integer
'Usage

Dim instance As ImGearVectorEntityPolylineEx
Dim value As Integer

value = instance.ContourCount
public int ContourCount {get;}
public: __property int get_ContourCount();
public:
property int ContourCount {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityPolylineEx Class
ImGearVectorEntityPolylineEx Members


%%PageItemTitle%%

ImGearVectorEntityRaster Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityRaster Class
Represents a non-rectangular raster image.
Object Model
ImGearVectorEntityRaster ClassImGearVectorColor StructureImGearVectorPoint3D StructureImGearVectorPoint3D StructureImGearVectorPoint3D StructureImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityRaster
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityRaster
public class ImGearVectorEntityRaster : ImGearVectorEntity
public __gc class ImGearVectorEntityRaster : public ImGearVectorEntity
public ref class ImGearVectorEntityRaster : public ImGearVectorEntity
Remarks
Image shape is defined by four points - left top, left bottom, right bottom and right top.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityRaster

See Also

Reference

ImGearVectorEntityRaster Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityRaster Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityRaster Class

The following tables list the members exposed by ImGearVectorEntityRaster.

Public Properties
 | Name | Description
Public Property | Height | Gets height of the image in pixels.
Public Property | Width | Gets width of the image in pixels.
Top
Public Methods
 | Name | Description
Public Method | GetData | Returns a copy of the image color data.
Public Method | GetLeftBottom | Returns the left bottom point of the raster.
Public Method | GetLeftTop | Returns left top point of the raster.
Public Method | GetRightBottom | Returns the right bottom point of the raster.
Public Method | GetRightTop | Returns the right top point of the raster.
Public Method | Init | Initializes a raster with new width and height.
Public Method | SetData | Replaces image data with new color values.
Public Method | SetLeftBottom | Sets a new left bottom point for the raster.
Public Method | SetLeftTop | Sets a new left top point for the raster.
Public Method | SetRightBottom | Sets a new right bottom point for the raster.
Public Method | SetRightTop | Sets a new right top point for the raster.
Top
See Also

Reference

ImGearVectorEntityRaster Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityRaster Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityRaster Class

For a list of all members of this type, see ImGearVectorEntityRaster members.

Public Methods
 | Name | Description
Public Method | GetData | Returns a copy of the image color data.
Public Method | GetLeftBottom | Returns the left bottom point of the raster.
Public Method | GetLeftTop | Returns left top point of the raster.
Public Method | GetRightBottom | Returns the right bottom point of the raster.
Public Method | GetRightTop | Returns the right top point of the raster.
Public Method | Init | Initializes a raster with new width and height.
Public Method | SetData | Replaces image data with new color values.
Public Method | SetLeftBottom | Sets a new left bottom point for the raster.
Public Method | SetLeftTop | Sets a new left top point for the raster.
Public Method | SetRightBottom | Sets a new right bottom point for the raster.
Public Method | SetRightTop | Sets a new right top point for the raster.
Top
See Also

Reference

ImGearVectorEntityRaster Class
ImageGear.Vector Namespace


GetData Method (ImGearVectorEntityRaster)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : GetData Method
Returns a copy of the image color data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetData() As ImGearVectorColor()
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value() As ImGearVectorColor

value = instance.GetData()
public ImGearVectorColor[] GetData()
public: ImGearVectorColor[]* GetData();
public:
array<ImGearVectorColor>^ GetData();

Return Value

ImGearVectorColor structure[] data.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


GetLeftBottom Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : GetLeftBottom Method
Returns the left bottom point of the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLeftBottom() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

value = instance.GetLeftBottom()
public ImGearVectorPoint3D GetLeftBottom()
public: ImGearVectorPoint3D GetLeftBottom();
public:
ImGearVectorPoint3D GetLeftBottom();

Return Value

ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


GetLeftTop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : GetLeftTop Method
Returns left top point of the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLeftTop() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

value = instance.GetLeftTop()
public ImGearVectorPoint3D GetLeftTop()
public: ImGearVectorPoint3D GetLeftTop();
public:
ImGearVectorPoint3D GetLeftTop();

Return Value

ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


GetRightBottom Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : GetRightBottom Method
Returns the right bottom point of the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRightBottom() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

value = instance.GetRightBottom()
public ImGearVectorPoint3D GetRightBottom()
public: ImGearVectorPoint3D GetRightBottom();
public:
ImGearVectorPoint3D GetRightBottom();

Return Value

ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


GetRightTop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : GetRightTop Method
Returns the right top point of the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRightTop() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

value = instance.GetRightTop()
public ImGearVectorPoint3D GetRightTop()
public: ImGearVectorPoint3D GetRightTop();
public:
ImGearVectorPoint3D GetRightTop();

Return Value

ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


Init Method (ImGearVectorEntityRaster)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : Init Method
New width of the raster.
New height of the raster.
Initializes a raster with new width and height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Init( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim width As Integer
Dim height As Integer

instance.Init(width, height)
public void Init(
   int width,
   int height
)
public: void Init(
   int width,
   int height
)
public:
void Init(
   int width,
   int height
)

Parameters

width
New width of the raster.
height
New height of the raster.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


SetData Method (ImGearVectorEntityRaster)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : SetData Method
New color data.
Replaces image data with new color values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetData( _
   ByVal value() As ImGearVectorColor _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value() As ImGearVectorColor

instance.SetData(value)
public void SetData(
   ImGearVectorColor[] value
)
public: void SetData(
   ImGearVectorColor[]* value
)
public:
void SetData(
   array<ImGearVectorColor>^ value
)

Parameters

value
New color data.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members
ImGearVectorColor Structure


SetLeftBottom Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : SetLeftBottom Method
New left bottom point.
Sets a new left bottom point for the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLeftBottom( _
   ByVal value As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

instance.SetLeftBottom(value)
public void SetLeftBottom(
   ImGearVectorPoint3D value
)
public: void SetLeftBottom(
   ImGearVectorPoint3D value
)
public:
void SetLeftBottom(
   ImGearVectorPoint3D value
)

Parameters

value
New left bottom point.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members
ImGearVectorPoint3D Structure


SetLeftTop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : SetLeftTop Method
New left top point.
Sets a new left top point for the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLeftTop( _
   ByVal value As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

instance.SetLeftTop(value)
public void SetLeftTop(
   ImGearVectorPoint3D value
)
public: void SetLeftTop(
   ImGearVectorPoint3D value
)
public:
void SetLeftTop(
   ImGearVectorPoint3D value
)

Parameters

value
New left top point.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members
ImGearVectorPoint3D Structure


SetRightBottom Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : SetRightBottom Method
New right bottom point.
Sets a new right bottom point for the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetRightBottom( _
   ByVal value As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

instance.SetRightBottom(value)
public void SetRightBottom(
   ImGearVectorPoint3D value
)
public: void SetRightBottom(
   ImGearVectorPoint3D value
)
public:
void SetRightBottom(
   ImGearVectorPoint3D value
)

Parameters

value
New right bottom point.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members
ImGearVectorPoint3D Structure


SetRightTop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : SetRightTop Method
New right top point.
Sets a new right top point for the raster.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetRightTop( _
   ByVal value As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As ImGearVectorPoint3D

instance.SetRightTop(value)
public void SetRightTop(
   ImGearVectorPoint3D value
)
public: void SetRightTop(
   ImGearVectorPoint3D value
)
public:
void SetRightTop(
   ImGearVectorPoint3D value
)

Parameters

value
New right top point.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members
ImGearVectorPoint3D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityRaster Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityRaster Class

For a list of all members of this type, see ImGearVectorEntityRaster members.

Public Properties
 | Name | Description
Public Property | Height | Gets height of the image in pixels.
Public Property | Width | Gets width of the image in pixels.
Top
See Also

Reference

ImGearVectorEntityRaster Class
ImageGear.Vector Namespace


Height Property (ImGearVectorEntityRaster)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : Height Property
Gets height of the image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

Positive integer value.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


Width Property (ImGearVectorEntityRaster)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityRaster Class : Width Property
Gets width of the image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImGearVectorEntityRaster
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

Positive integer value.
See Also

Reference

ImGearVectorEntityRaster Class
ImGearVectorEntityRaster Members


%%PageItemTitle%%

ImGearVectorEntitySolid Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySolid Class
Represents a quadrangle.
Object Model
ImGearVectorEntitySolid ClassImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntitySolid
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntitySolid
public class ImGearVectorEntitySolid : ImGearVectorEntity
public __gc class ImGearVectorEntitySolid : public ImGearVectorEntity
public ref class ImGearVectorEntitySolid : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntitySolid

See Also

Reference

ImGearVectorEntitySolid Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntitySolid Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySolid Class

The following tables list the members exposed by ImGearVectorEntitySolid.

Public Methods
 | Name | Description
Public Method | GetPoint | Returns coordinates of the specified corner.
Public Method | SetPoint | Sets coordinates of the specified corner.
Top
See Also

Reference

ImGearVectorEntitySolid Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntitySolid Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySolid Class

For a list of all members of this type, see ImGearVectorEntitySolid members.

See Also

Reference

ImGearVectorEntitySolid Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntitySolid Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySolid Class

For a list of all members of this type, see ImGearVectorEntitySolid members.

Public Methods
 | Name | Description
Public Method | GetPoint | Returns coordinates of the specified corner.
Public Method | SetPoint | Sets coordinates of the specified corner.
Top
See Also

Reference

ImGearVectorEntitySolid Class
ImageGear.Vector Namespace


GetPoint Method (ImGearVectorEntitySolid)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySolid Class : GetPoint Method
Index of the corner.
Returns coordinates of the specified corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntitySolid
Dim index As Integer
Dim value As ImGearVectorPoint3D

value = instance.GetPoint(index)
public ImGearVectorPoint3D GetPoint(
   int index
)
public: ImGearVectorPoint3D GetPoint(
   int index
)
public:
ImGearVectorPoint3D GetPoint(
   int index
)

Parameters

index
Index of the corner.

Return Value

ImGearVectorPoint3D structure representing the coordinates of the corner specified by index.
See Also

Reference

ImGearVectorEntitySolid Class
ImGearVectorEntitySolid Members


SetPoint Method (ImGearVectorEntitySolid)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySolid Class : SetPoint Method
Index of the corner.
New corner coordinates.
Sets coordinates of the specified corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal index As Integer, _
   ByRef point As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntitySolid
Dim index As Integer
Dim point As ImGearVectorPoint3D

instance.SetPoint(index, point)
public void SetPoint(
   int index,
   ref ImGearVectorPoint3D point
)
public: void SetPoint(
   int index,
   ref ImGearVectorPoint3D point
)
public:
void SetPoint(
   int index,
   ImGearVectorPoint3D% point
)

Parameters

index
Index of the corner.
point
New corner coordinates.
See Also

Reference

ImGearVectorEntitySolid Class
ImGearVectorEntitySolid Members
ImGearVectorPoint3D Structure


%%PageItemTitle%%

ImGearVectorEntitySplinesurface Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySplinesurface Class
Base class for NURBS and Bezier surfaces.
Object Model
ImGearVectorEntitySplinesurface Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearVectorEntitySplinesurface
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntitySplinesurface
public abstract class ImGearVectorEntitySplinesurface : ImGearVectorEntity
public __gc abstract class ImGearVectorEntitySplinesurface : public ImGearVectorEntity
public ref class ImGearVectorEntitySplinesurface abstract : public ImGearVectorEntity
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntitySplinesurface
ImageGear.Vector.ImGearVectorEntityBeziersurface
ImageGear.Vector.ImGearVectorEntityNURBSsurface

See Also

Reference

ImGearVectorEntitySplinesurface Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntitySplinesurface Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySplinesurface Class

The following tables list the members exposed by ImGearVectorEntitySplinesurface.

Public Properties
 | Name | Description
Public Property | Flags | Gets or sets different surface flags.
Public Property | MDegree | Gets a surface degree in M direction.
Public Property | MDimension | Gets a number of control points in M direction.
Public Property | MStep | Gets or sets an interpolation step in M direction.
Public Property | NDegree | Gets a surface degree in N direction.
Public Property | NDimension | Gets a number of control points in N direction.
Public Property | NStep | Gets or sets an interpolation step in N direction.
Top
Public Methods
 | Name | Description
Public Method | Init | Initializes the surface with the specified dimensions and specified degrees.
Top
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntitySplinesurface Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySplinesurface Class

For a list of all members of this type, see ImGearVectorEntitySplinesurface members.

Public Methods
 | Name | Description
Public Method | Init | Initializes the surface with the specified dimensions and specified degrees.
Top
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImageGear.Vector Namespace


Init Method (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : Init Method
Number of control points in M direction.
Number of control points in N direction.
Surface degree in M direction.
Surface degree in N direction.
Initializes the surface with the specified dimensions and specified degrees.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Init( _
   ByVal dimensionM As Integer, _
   ByVal dimensionN As Integer, _
   ByVal degreeM As Integer, _
   ByVal degreeN As Integer _
)
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim dimensionM As Integer
Dim dimensionN As Integer
Dim degreeM As Integer
Dim degreeN As Integer

instance.Init(dimensionM, dimensionN, degreeM, degreeN)
public abstract void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
)
public: abstract void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
)
public:
abstract void Init(
   int dimensionM,
   int dimensionN,
   int degreeM,
   int degreeN
)

Parameters

dimensionM
Number of control points in M direction.
dimensionN
Number of control points in N direction.
degreeM
Surface degree in M direction.
degreeN
Surface degree in N direction.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


%%PageItemTitle%% $$Properties$$

ImGearVectorEntitySplinesurface Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntitySplinesurface Class

For a list of all members of this type, see ImGearVectorEntitySplinesurface members.

Public Properties
 | Name | Description
Public Property | Flags | Gets or sets different surface flags.
Public Property | MDegree | Gets a surface degree in M direction.
Public Property | MDimension | Gets a number of control points in M direction.
Public Property | MStep | Gets or sets an interpolation step in M direction.
Public Property | NDegree | Gets a surface degree in N direction.
Public Property | NDimension | Gets a number of control points in N direction.
Public Property | NStep | Gets or sets an interpolation step in N direction.
Top
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImageGear.Vector Namespace


Flags Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : Flags Property
Gets or sets different surface flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property Flags As Integer
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Integer

instance.Flags = value

value = instance.Flags
public abstract int Flags {get; set;}
public: __property abstract int get_Flags();
public: __property abstract void set_Flags(
   int value
);
public:
abstract property int Flags {
   int get();
   void set (    int value);
}

Property Value

Combination of ImGearVectNURBSFlags enumeration or 0.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


MDegree Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : MDegree Property
Gets a surface degree in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property MDegree As Integer
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Integer

value = instance.MDegree
public abstract int MDegree {get;}
public: __property abstract int get_MDegree();
public:
abstract property int MDegree {
   int get();
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


MDimension Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : MDimension Property
Gets a number of control points in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property MDimension As Integer
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Integer

value = instance.MDimension
public abstract int MDimension {get;}
public: __property abstract int get_MDimension();
public:
abstract property int MDimension {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


MStep Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : MStep Property
Gets or sets an interpolation step in M direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property MStep As Single
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Single

instance.MStep = value

value = instance.MStep
public abstract float MStep {get; set;}
public: __property abstract float get_MStep();
public: __property abstract void set_MStep(
   float value
);
public:
abstract property float MStep {
   float get();
   void set (    float value);
}

Property Value

Value in the range 0..1.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


NDegree Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : NDegree Property
Gets a surface degree in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property NDegree As Integer
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Integer

value = instance.NDegree
public abstract int NDegree {get;}
public: __property abstract int get_NDegree();
public:
abstract property int NDegree {
   int get();
}

Property Value

Numeric value equal to 2 or greater.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


NDimension Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : NDimension Property
Gets a number of control points in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property NDimension As Integer
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Integer

value = instance.NDimension
public abstract int NDimension {get;}
public: __property abstract int get_NDimension();
public:
abstract property int NDimension {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


NStep Property (ImGearVectorEntitySplinesurface)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntitySplinesurface Class : NStep Property
Gets or sets an interpolation step in N direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property NStep As Single
'Usage

Dim instance As ImGearVectorEntitySplinesurface
Dim value As Single

instance.NStep = value

value = instance.NStep
public abstract float NStep {get; set;}
public: __property abstract float get_NStep();
public: __property abstract void set_NStep(
   float value
);
public:
abstract property float NStep {
   float get();
   void set (    float value);
}

Property Value

Value in the range 0..1.
See Also

Reference

ImGearVectorEntitySplinesurface Class
ImGearVectorEntitySplinesurface Members


%%PageItemTitle%%

ImGearVectorEntityText Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityText Class
Represents a text string.
Object Model
ImGearVectorEntityText ClassImGearVectorTextObject ClassImGearVectorPoint2D StructureImGearVectorPoint2D StructureImGearVectorTextObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityText
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityText
public class ImGearVectorEntityText : ImGearVectorEntity
public __gc class ImGearVectorEntityText : public ImGearVectorEntity
public ref class ImGearVectorEntityText : public ImGearVectorEntity
Remarks
Different parts of the text string can have different settings such as color, font or effects, but the whole string has the same alignment and base line angle.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityText

See Also

Reference

ImGearVectorEntityText Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityText Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityText Class

The following tables list the members exposed by ImGearVectorEntityText.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets a flags defining the alignment of the text string.
Public Property | BaseLine | Gets or sets a base line angle for the whole text string.
Public Property | TextObjectCount | Gets a total count of Text Objects in the chain.
Top
Public Methods
 | Name | Description
Public Method | CopySettingsFrom | Copies all common text settings from one text entity to another.
Public Method | CreateTextObject | Creates a new text object and inserts it at index position in the Text Object chain.
Public Method | DeleteTextObject | Removes the Text Object from the position index and destroys it.
Public Method | GetAlignPoint | Returns an additional alignment point.
Public Method | GetRestrictPoint | Returns an additional point defining restriction width and height.
Public Method | GetTextObject | Returns the text object in the Index position in the Text Object chain.
Public Method | SetAlignPoint | Sets an additional alignment point.
Public Method | SetRestrictPoint | Sets an additional point defining restriction width and height.
Top
See Also

Reference

ImGearVectorEntityText Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityText Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityText Class

For a list of all members of this type, see ImGearVectorEntityText members.

Public Methods
 | Name | Description
Public Method | CopySettingsFrom | Copies all common text settings from one text entity to another.
Public Method | CreateTextObject | Creates a new text object and inserts it at index position in the Text Object chain.
Public Method | DeleteTextObject | Removes the Text Object from the position index and destroys it.
Public Method | GetAlignPoint | Returns an additional alignment point.
Public Method | GetRestrictPoint | Returns an additional point defining restriction width and height.
Public Method | GetTextObject | Returns the text object in the Index position in the Text Object chain.
Public Method | SetAlignPoint | Sets an additional alignment point.
Public Method | SetRestrictPoint | Sets an additional point defining restriction width and height.
Top
See Also

Reference

ImGearVectorEntityText Class
ImageGear.Vector Namespace


CopySettingsFrom Method (ImGearVectorEntityText)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : CopySettingsFrom Method
The source text Entity.
Copies all common text settings from one text entity to another.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopySettingsFrom( _
   ByVal textEntity As ImGearVectorEntityText _
)
'Usage

Dim instance As ImGearVectorEntityText
Dim textEntity As ImGearVectorEntityText

instance.CopySettingsFrom(textEntity)
public void CopySettingsFrom(
   ImGearVectorEntityText textEntity
)
public: void CopySettingsFrom(
   ImGearVectorEntityText* textEntity
)
public:
void CopySettingsFrom(
   ImGearVectorEntityText^ textEntity
)

Parameters

textEntity
The source text Entity.
Remarks
This is convenient when creating a new text string with almost the same settings as an existing one.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members
ImGearVectorEntityText Class


CreateTextObject Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : CreateTextObject Method
Index at which the created text object is to be inserted.
Creates a new text object and inserts it at index position in the Text Object chain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateTextObject( _
   ByVal index As Integer _
) As ImGearVectorTextObject
'Usage

Dim instance As ImGearVectorEntityText
Dim index As Integer
Dim value As ImGearVectorTextObject

value = instance.CreateTextObject(index)
public ImGearVectorTextObject CreateTextObject(
   int index
)
public: ImGearVectorTextObject* CreateTextObject(
   int index
)
public:
ImGearVectorTextObject^ CreateTextObject(
   int index
)

Parameters

index
Index at which the created text object is to be inserted.

Return Value

New instance of ImGearVectorTextObject class object.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


DeleteTextObject Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : DeleteTextObject Method
Position of the text object to be removed.
Removes the Text Object from the position index and destroys it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteTextObject( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorEntityText
Dim index As Integer

instance.DeleteTextObject(index)
public void DeleteTextObject(
   int index
)
public: void DeleteTextObject(
   int index
)
public:
void DeleteTextObject(
   int index
)

Parameters

index
Position of the text object to be removed.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


GetAlignPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : GetAlignPoint Method
Returns an additional alignment point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAlignPoint() As ImGearVectorPoint2D
'Usage

Dim instance As ImGearVectorEntityText
Dim value As ImGearVectorPoint2D

value = instance.GetAlignPoint()
public ImGearVectorPoint2D GetAlignPoint()
public: ImGearVectorPoint2D GetAlignPoint();
public:
ImGearVectorPoint2D GetAlignPoint();

Return Value

New instance of ImGearVectorPoint2D structure object.
Remarks
Alignment point is taken into account if CONTINUOUSX or CONTINUOUSY alignment flags are set.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


GetRestrictPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : GetRestrictPoint Method
Returns an additional point defining restriction width and height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRestrictPoint() As ImGearVectorPoint2D
'Usage

Dim instance As ImGearVectorEntityText
Dim value As ImGearVectorPoint2D

value = instance.GetRestrictPoint()
public ImGearVectorPoint2D GetRestrictPoint()
public: ImGearVectorPoint2D GetRestrictPoint();
public:
ImGearVectorPoint2D GetRestrictPoint();

Return Value

New instance of ImGearVectorPoint2D structure object.
Remarks
Restriction is taken into account if any RESTRICT_... alignment flag is set.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


GetTextObject Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : GetTextObject Method
Index of the text object to be returned.
Returns the text object in the Index position in the Text Object chain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTextObject( _
   ByVal index As Integer _
) As ImGearVectorTextObject
'Usage

Dim instance As ImGearVectorEntityText
Dim index As Integer
Dim value As ImGearVectorTextObject

value = instance.GetTextObject(index)
public ImGearVectorTextObject GetTextObject(
   int index
)
public: ImGearVectorTextObject* GetTextObject(
   int index
)
public:
ImGearVectorTextObject^ GetTextObject(
   int index
)

Parameters

index
Index of the text object to be returned.

Return Value

New instance of ImGearVectorTextObject class object.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


SetAlignPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : SetAlignPoint Method
An alignment point to be set.
Sets an additional alignment point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAlignPoint( _
   ByVal value As ImGearVectorPoint2D _
)
'Usage

Dim instance As ImGearVectorEntityText
Dim value As ImGearVectorPoint2D

instance.SetAlignPoint(value)
public void SetAlignPoint(
   ImGearVectorPoint2D value
)
public: void SetAlignPoint(
   ImGearVectorPoint2D value
)
public:
void SetAlignPoint(
   ImGearVectorPoint2D value
)

Parameters

value
An alignment point to be set.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members
ImGearVectorPoint2D Structure


SetRestrictPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : SetRestrictPoint Method
The restriction point to be set.
Sets an additional point defining restriction width and height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetRestrictPoint( _
   ByVal value As ImGearVectorPoint2D _
)
'Usage

Dim instance As ImGearVectorEntityText
Dim value As ImGearVectorPoint2D

instance.SetRestrictPoint(value)
public void SetRestrictPoint(
   ImGearVectorPoint2D value
)
public: void SetRestrictPoint(
   ImGearVectorPoint2D value
)
public:
void SetRestrictPoint(
   ImGearVectorPoint2D value
)

Parameters

value
The restriction point to be set.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members
ImGearVectorPoint2D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityText Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityText Class

For a list of all members of this type, see ImGearVectorEntityText members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets a flags defining the alignment of the text string.
Public Property | BaseLine | Gets or sets a base line angle for the whole text string.
Public Property | TextObjectCount | Gets a total count of Text Objects in the chain.
Top
See Also

Reference

ImGearVectorEntityText Class
ImageGear.Vector Namespace


Alignment Property (ImGearVectorEntityText)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : Alignment Property
Gets or sets a flags defining the alignment of the text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Alignment As Integer
'Usage

Dim instance As ImGearVectorEntityText
Dim value As Integer

instance.Alignment = value

value = instance.Alignment
public int Alignment {get; set;}
public: __property int get_Alignment();
public: __property void set_Alignment(
   int value
);
public:
property int Alignment {
   int get();
   void set (    int value);
}

Property Value

Combination of ImGearVectAlignment enumeration values.
Remarks
The default value is ImGearVectAlignment.NONE.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


BaseLine Property (ImGearVectorEntityText)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : BaseLine Property
Gets or sets a base line angle for the whole text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BaseLine As Single
'Usage

Dim instance As ImGearVectorEntityText
Dim value As Single

instance.BaseLine = value

value = instance.BaseLine
public float BaseLine {get; set;}
public: __property float get_BaseLine();
public: __property void set_BaseLine(
   float value
);
public:
property float BaseLine {
   float get();
   void set (    float value);
}

Property Value

Any value in the range of -2*PI ... 2*PI.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


TextObjectCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityText Class : TextObjectCount Property
Gets a total count of Text Objects in the chain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextObjectCount As Integer
'Usage

Dim instance As ImGearVectorEntityText
Dim value As Integer

value = instance.TextObjectCount
public int TextObjectCount {get;}
public: __property int get_TextObjectCount();
public:
property int TextObjectCount {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorEntityText Class
ImGearVectorEntityText Members


%%PageItemTitle%%

ImGearVectorEntityViewport Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityViewport Class
Represents a viewport.
Object Model
ImGearVectorEntityViewport ClassImGearVectorEntity ClassImGearVectorEntity ClassImGearVectorPoint3D StructureImGearVectorPoint3D StructureImGearVectorRotation ClassImGearVectorPoint3D StructureImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorEntityViewport
   Inherits ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityViewport
public class ImGearVectorEntityViewport : ImGearVectorEntity
public __gc class ImGearVectorEntityViewport : public ImGearVectorEntity
public ref class ImGearVectorEntityViewport : public ImGearVectorEntity
Remarks
Viewport is a rectangular or non-rectangular window where the viewport content is displayed with the specified layout.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityViewport

See Also

Reference

ImGearVectorEntityViewport Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorEntityViewport Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityViewport Class

The following tables list the members exposed by ImGearVectorEntityViewport.

Public Methods
 | Name | Description
Public Method | GetBoundary | Gets an entity that bounds the viewport.
Public Method | GetContent | Returns viewport content. Usually this is a block containing some other entities.
Public Method | GetViewMax | Returns the point with maximum coordinates of the view being mapped to the viewport.
Public Method | GetViewMin | Returns the point with minimum coordinates of the view being mapped to the viewport.
Public Method | GetViewportRotation | Returns rotation of the view being mapped.
Public Method | GetVPMax | Returns the point with maximum coordinates of the viewport.
Public Method | GetVPMin | Returns the point with minimum coordinates of the viewport.
Public Method | SetBoundary | Sets the bounding entity for the viewport.
Public Method | SetContent | Sets the viewport content. Usually this is a block containing some other entities.
Public Method | SetViewMax | Sets new maximum view coordinates.
Public Method | SetViewMin | Sets new minimum coordinates of the view.
Public Method | SetVPMax | Sets new viewport maximum coordinates.
Public Method | SetVPMin | Sets new viewport minimum coordinates.
Top
See Also

Reference

ImGearVectorEntityViewport Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorEntityViewport Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityViewport Class

For a list of all members of this type, see ImGearVectorEntityViewport members.

See Also

Reference

ImGearVectorEntityViewport Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorEntityViewport Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorEntityViewport Class

For a list of all members of this type, see ImGearVectorEntityViewport members.

Public Methods
 | Name | Description
Public Method | GetBoundary | Gets an entity that bounds the viewport.
Public Method | GetContent | Returns viewport content. Usually this is a block containing some other entities.
Public Method | GetViewMax | Returns the point with maximum coordinates of the view being mapped to the viewport.
Public Method | GetViewMin | Returns the point with minimum coordinates of the view being mapped to the viewport.
Public Method | GetViewportRotation | Returns rotation of the view being mapped.
Public Method | GetVPMax | Returns the point with maximum coordinates of the viewport.
Public Method | GetVPMin | Returns the point with minimum coordinates of the viewport.
Public Method | SetBoundary | Sets the bounding entity for the viewport.
Public Method | SetContent | Sets the viewport content. Usually this is a block containing some other entities.
Public Method | SetViewMax | Sets new maximum view coordinates.
Public Method | SetViewMin | Sets new minimum coordinates of the view.
Public Method | SetVPMax | Sets new viewport maximum coordinates.
Public Method | SetVPMin | Sets new viewport minimum coordinates.
Top
See Also

Reference

ImGearVectorEntityViewport Class
ImageGear.Vector Namespace


GetBoundary Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetBoundary Method
Gets an entity that bounds the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBoundary() As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorEntity

value = instance.GetBoundary()
public ImGearVectorEntity GetBoundary()
public: ImGearVectorEntity* GetBoundary();
public:
ImGearVectorEntity^ GetBoundary();

Return Value

New instance of ImGearVectorEntity class.
Remarks
The entity that bounds the viewport can be a rectangle, a polyline, an ellipse or other type of entitity. If the boundary is not set, the viewport is bounded by the values specified by VPMin (, ) and VPMax (, ).
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members
GetVPMin Method
SetVPMin Method
GetVPMax Method
SetVPMax Method


GetContent Method (ImGearVectorEntityViewport)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetContent Method
Returns viewport content. Usually this is a block containing some other entities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetContent() As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorEntity

value = instance.GetContent()
public ImGearVectorEntity GetContent()
public: ImGearVectorEntity* GetContent();
public:
ImGearVectorEntity^ GetContent();

Return Value

New instance of ImGearVectorEntity class.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


GetViewMax Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetViewMax Method
Returns the point with maximum coordinates of the view being mapped to the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetViewMax() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorPoint3D

value = instance.GetViewMax()
public ImGearVectorPoint3D GetViewMax()
public: ImGearVectorPoint3D GetViewMax();
public:
ImGearVectorPoint3D GetViewMax();

Return Value

New instance of ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


GetViewMin Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetViewMin Method
Returns the point with minimum coordinates of the view being mapped to the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetViewMin() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorPoint3D

value = instance.GetViewMin()
public ImGearVectorPoint3D GetViewMin()
public: ImGearVectorPoint3D GetViewMin();
public:
ImGearVectorPoint3D GetViewMin();

Return Value

New instance of ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


GetViewportRotation Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetViewportRotation Method
Returns rotation of the view being mapped.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetViewportRotation() As ImGearVectorRotation
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorRotation

value = instance.GetViewportRotation()
public ImGearVectorRotation GetViewportRotation()
public: ImGearVectorRotation* GetViewportRotation();
public:
ImGearVectorRotation^ GetViewportRotation();

Return Value

New instance of ImGearVectorRotation class.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


GetVPMax Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetVPMax Method
Returns the point with maximum coordinates of the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVPMax() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorPoint3D

value = instance.GetVPMax()
public ImGearVectorPoint3D GetVPMax()
public: ImGearVectorPoint3D GetVPMax();
public:
ImGearVectorPoint3D GetVPMax();

Return Value

New instance of ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


GetVPMin Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : GetVPMin Method
Returns the point with minimum coordinates of the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVPMin() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorEntityViewport
Dim value As ImGearVectorPoint3D

value = instance.GetVPMin()
public ImGearVectorPoint3D GetVPMin()
public: ImGearVectorPoint3D GetVPMin();
public:
ImGearVectorPoint3D GetVPMin();

Return Value

New instance of ImGearVectorPoint3D structure.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


SetBoundary Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetBoundary Method
Bounding entity beinng set.
Sets the bounding entity for the viewport.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetBoundary( _
   ByVal boundary As ImGearVectorEntity _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim boundary As ImGearVectorEntity

instance.SetBoundary(boundary)
public void SetBoundary(
   ImGearVectorEntity boundary
)
public: void SetBoundary(
   ImGearVectorEntity* boundary
)
public:
void SetBoundary(
   ImGearVectorEntity^ boundary
)

Parameters

boundary
Bounding entity beinng set.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members
ImGearVectorEntity Class


SetContent Method (ImGearVectorEntityViewport)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetContent Method
An entity being set as Viewport content.
Sets the viewport content. Usually this is a block containing some other entities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetContent( _
   ByVal content As ImGearVectorEntity _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim content As ImGearVectorEntity

instance.SetContent(content)
public void SetContent(
   ImGearVectorEntity content
)
public: void SetContent(
   ImGearVectorEntity* content
)
public:
void SetContent(
   ImGearVectorEntity^ content
)

Parameters

content
An entity being set as Viewport content.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members
ImGearVectorEntity Class


SetViewMax Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetViewMax Method
New maximum coordinates of the view.
Sets new maximum view coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetViewMax( _
   ByVal maxPoint As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim maxPoint As ImGearVectorPoint3D

instance.SetViewMax(maxPoint)
public void SetViewMax(
   ImGearVectorPoint3D maxPoint
)
public: void SetViewMax(
   ImGearVectorPoint3D maxPoint
)
public:
void SetViewMax(
   ImGearVectorPoint3D maxPoint
)

Parameters

maxPoint
New maximum coordinates of the view.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


SetViewMin Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetViewMin Method
New minimum coordinates of the view.
Sets new minimum coordinates of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetViewMin( _
   ByVal minPoint As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim minPoint As ImGearVectorPoint3D

instance.SetViewMin(minPoint)
public void SetViewMin(
   ImGearVectorPoint3D minPoint
)
public: void SetViewMin(
   ImGearVectorPoint3D minPoint
)
public:
void SetViewMin(
   ImGearVectorPoint3D minPoint
)

Parameters

minPoint
New minimum coordinates of the view.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


SetVPMax Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetVPMax Method
New viewport maximum coordinates.
Sets new viewport maximum coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVPMax( _
   ByVal maxPoint As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim maxPoint As ImGearVectorPoint3D

instance.SetVPMax(maxPoint)
public void SetVPMax(
   ImGearVectorPoint3D maxPoint
)
public: void SetVPMax(
   ImGearVectorPoint3D maxPoint
)
public:
void SetVPMax(
   ImGearVectorPoint3D maxPoint
)

Parameters

maxPoint
New viewport maximum coordinates.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


SetVPMin Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorEntityViewport Class : SetVPMin Method
New viewport minimum coordinates.
Sets new viewport minimum coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVPMin( _
   ByVal minPoint As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorEntityViewport
Dim minPoint As ImGearVectorPoint3D

instance.SetVPMin(minPoint)
public void SetVPMin(
   ImGearVectorPoint3D minPoint
)
public: void SetVPMin(
   ImGearVectorPoint3D minPoint
)
public:
void SetVPMin(
   ImGearVectorPoint3D minPoint
)

Parameters

minPoint
New viewport minimum coordinates.
See Also

Reference

ImGearVectorEntityViewport Class
ImGearVectorEntityViewport Members


%%PageItemTitle%%

ImGearVectorFilltype Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFilltype Class
Represents the fill type for drawing filled objects.
Object Model
ImGearVectorFilltype ClassImGearVectorGradient ClassImGearVectorHatch Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorFilltype
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorFilltype
public class ImGearVectorFilltype : ImGearVectorObject
public __gc class ImGearVectorFilltype : public ImGearVectorObject
public ref class ImGearVectorFilltype : public ImGearVectorObject
Remarks
The style of the fill type object is specified by Pattern property. The fill pattern can be solid, predefined, shadow, gradient, and vector (hatch).
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorFilltype

See Also

Reference

ImGearVectorFilltype Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorFilltype Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFilltype Class

The following tables list the members exposed by ImGearVectorFilltype.

Public Properties
 | Name | Description
Public Property | Pattern | Gets a constant defining a fill pattern.
Top
Public Methods
 | Name | Description
Public Method | GetGradient | Returns the gradient object associated with the fill type in case the Pattern is GRADIENT.
Public Method | GetHatch | Returns the hatch object associated with the fill type in case the Pattern is HATCH_VECTOR.
Top
See Also

Reference

ImGearVectorFilltype Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorFilltype Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFilltype Class

For a list of all members of this type, see ImGearVectorFilltype members.

Public Methods
 | Name | Description
Public Method | GetGradient | Returns the gradient object associated with the fill type in case the Pattern is GRADIENT.
Public Method | GetHatch | Returns the hatch object associated with the fill type in case the Pattern is HATCH_VECTOR.
Top
See Also

Reference

ImGearVectorFilltype Class
ImageGear.Vector Namespace


GetGradient Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFilltype Class : GetGradient Method
Returns the gradient object associated with the fill type in case the Pattern is GRADIENT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGradient() As ImGearVectorGradient
'Usage

Dim instance As ImGearVectorFilltype
Dim value As ImGearVectorGradient

value = instance.GetGradient()
public ImGearVectorGradient GetGradient()
public: ImGearVectorGradient* GetGradient();
public:
ImGearVectorGradient^ GetGradient();

Return Value

New instance of ImGearVectorGradient class object.
See Also

Reference

ImGearVectorFilltype Class
ImGearVectorFilltype Members


GetHatch Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFilltype Class : GetHatch Method
Returns the hatch object associated with the fill type in case the Pattern is HATCH_VECTOR.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetHatch() As ImGearVectorHatch
'Usage

Dim instance As ImGearVectorFilltype
Dim value As ImGearVectorHatch

value = instance.GetHatch()
public ImGearVectorHatch GetHatch()
public: ImGearVectorHatch* GetHatch();
public:
ImGearVectorHatch^ GetHatch();

Return Value

New instance of ImGearVectorHatch class object.
See Also

Reference

ImGearVectorFilltype Class
ImGearVectorFilltype Members


%%PageItemTitle%% $$Properties$$

ImGearVectorFilltype Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFilltype Class

For a list of all members of this type, see ImGearVectorFilltype members.

Public Properties
 | Name | Description
Public Property | Pattern | Gets a constant defining a fill pattern.
Top
See Also

Reference

ImGearVectorFilltype Class
ImageGear.Vector Namespace


Pattern Property (ImGearVectorFilltype)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFilltype Class : Pattern Property
Gets a constant defining a fill pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As ImGearVectFillPattern
'Usage

Dim instance As ImGearVectorFilltype
Dim value As ImGearVectFillPattern

value = instance.Pattern
public ImGearVectFillPattern Pattern {get;}
public: __property ImGearVectFillPattern get_Pattern();
public:
property ImGearVectFillPattern Pattern {
   ImGearVectFillPattern get();
}

Property Value

ImGearVectFillPattern enumeration value.
See Also

Reference

ImGearVectorFilltype Class
ImGearVectorFilltype Members
ImGearVectFillPattern Enumeration


%%PageItemTitle%%

ImGearVectorFloatCont Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFloatCont Class
Represents the container for floating point values.
Object Model
ImGearVectorFloatCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorFloatCont
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorFloatCont
public class ImGearVectorFloatCont : ImGearVectorObject
public __gc class ImGearVectorFloatCont : public ImGearVectorObject
public ref class ImGearVectorFloatCont : public ImGearVectorObject
Remarks
This class is used to keep the pattern for hatch line and the knots for spline curves and surfaces.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorFloatCont

See Also

Reference

ImGearVectorFloatCont Members
ImageGear.Vector Namespace
ImGearVectorObject Class


%%PageItemTitle%% $$Members$$

ImGearVectorFloatCont Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFloatCont Class

The following tables list the members exposed by ImGearVectorFloatCont.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of values in the container.
Top
Public Methods
 | Name | Description
Public Method | AddValue | Adds new value at the end of the container.
Public Method | Clear | Clears the container.
Public Method | GetValue | Returns a value specified by the position.
Public Method | InsertValue | Inserts a value at the specified position.
Public Method | RemoveValue | Removes value specified by the position.
Public Method | SetValue | Sets specified value to the specified position.
Top
See Also

Reference

ImGearVectorFloatCont Class
ImageGear.Vector Namespace
ImGearVectorObject Class


%%PageItemTitle%% $$Methods$$

ImGearVectorFloatCont Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFloatCont Class

For a list of all members of this type, see ImGearVectorFloatCont members.

Public Methods
 | Name | Description
Public Method | AddValue | Adds new value at the end of the container.
Public Method | Clear | Clears the container.
Public Method | GetValue | Returns a value specified by the position.
Public Method | InsertValue | Inserts a value at the specified position.
Public Method | RemoveValue | Removes value specified by the position.
Public Method | SetValue | Sets specified value to the specified position.
Top
See Also

Reference

ImGearVectorFloatCont Class
ImageGear.Vector Namespace
ImGearVectorObject Class


AddValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : AddValue Method
Value to be added to the container.
Adds new value at the end of the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddValue( _
   ByVal value As Single _
)
'Usage

Dim instance As ImGearVectorFloatCont
Dim value As Single

instance.AddValue(value)
public void AddValue(
   float value
)
public: void AddValue(
   float value
)
public:
void AddValue(
   float value
)

Parameters

value
Value to be added to the container.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


Clear Method (ImGearVectorFloatCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : Clear Method
Clears the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearVectorFloatCont

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


GetValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : GetValue Method
Position of the value in the container.
Returns a value specified by the position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValue( _
   ByVal position As Integer _
) As Single
'Usage

Dim instance As ImGearVectorFloatCont
Dim position As Integer
Dim value As Single

value = instance.GetValue(position)
public float GetValue(
   int position
)
public: float GetValue(
   int position
)
public:
float GetValue(
   int position
)

Parameters

position
Position of the value in the container.

Return Value

A float value specified by the position.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


InsertValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : InsertValue Method
Position where the value is inserted.
Value being inserted.
Inserts a value at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InsertValue( _
   ByVal position As Integer, _
   ByVal value As Single _
)
'Usage

Dim instance As ImGearVectorFloatCont
Dim position As Integer
Dim value As Single

instance.InsertValue(position, value)
public void InsertValue(
   int position,
   float value
)
public: void InsertValue(
   int position,
   float value
)
public:
void InsertValue(
   int position,
   float value
)

Parameters

position
Position where the value is inserted.
value
Value being inserted.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


RemoveValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : RemoveValue Method
Position of the value being removed.
Removes value specified by the position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveValue( _
   ByVal position As Integer _
)
'Usage

Dim instance As ImGearVectorFloatCont
Dim position As Integer

instance.RemoveValue(position)
public void RemoveValue(
   int position
)
public: void RemoveValue(
   int position
)
public:
void RemoveValue(
   int position
)

Parameters

position
Position of the value being removed.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


SetValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : SetValue Method
Position where the value is set.
Value being set.
Sets specified value to the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetValue( _
   ByVal position As Integer, _
   ByVal value As Single _
)
'Usage

Dim instance As ImGearVectorFloatCont
Dim position As Integer
Dim value As Single

instance.SetValue(position, value)
public void SetValue(
   int position,
   float value
)
public: void SetValue(
   int position,
   float value
)
public:
void SetValue(
   int position,
   float value
)

Parameters

position
Position where the value is set.
value
Value being set.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


%%PageItemTitle%% $$Properties$$

ImGearVectorFloatCont Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFloatCont Class

For a list of all members of this type, see ImGearVectorFloatCont members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of values in the container.
Top
See Also

Reference

ImGearVectorFloatCont Class
ImageGear.Vector Namespace
ImGearVectorObject Class


Count Property (ImGearVectorFloatCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFloatCont Class : Count Property
Gets the count of values in the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearVectorFloatCont
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorFloatCont Class
ImGearVectorFloatCont Members


%%PageItemTitle%%

ImGearVectorFont Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFont Class
Represents the font for the text drawing.
Object Model
ImGearVectorFont ClassImGearVectorVertexCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorFont
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorFont
public class ImGearVectorFont : ImGearVectorObject
public __gc class ImGearVectorFont : public ImGearVectorObject
public ref class ImGearVectorFont : public ImGearVectorObject
Remarks
Vector and TrueType fonts are supported. Every letter (glyph) of a Vector font is defined by vertex container. The application is completely responsible for creating any glyph of the vector font. TrueType font is created from the corresponding system font and is not modified. Font is created with vector data object by such parameters as type face, weight, "is Vector" flag and saved in the internal font container.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorFont

See Also

Reference

ImGearVectorFont Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorFont Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFont Class

The following tables list the members exposed by ImGearVectorFont.

Public Properties
 | Name | Description
Public Property | GlyphCount | Gets or sets a number of glyphs in the vector font.
Public Property | IsVector | Gets a value indicating whetherthe font is vector (true) or TrueType (false).
Public Property | Typeface | Gets a font typeface.
Public Property | Weight | Gets a TrueType font weight.
Top
Public Methods
 | Name | Description
Public Method | GetGlyph | Returns Vertex Container for access to the Vector glyph.
Top
See Also

Reference

ImGearVectorFont Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorFont Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFont Class

For a list of all members of this type, see ImGearVectorFont members.

Public Methods
 | Name | Description
Public Method | GetGlyph | Returns Vertex Container for access to the Vector glyph.
Top
See Also

Reference

ImGearVectorFont Class
ImageGear.Vector Namespace


GetGlyph Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFont Class : GetGlyph Method
Index of the glyph to be returned.
Returns Vertex Container for access to the Vector glyph.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGlyph( _
   ByVal index As Integer _
) As ImGearVectorVertexCont
'Usage

Dim instance As ImGearVectorFont
Dim index As Integer
Dim value As ImGearVectorVertexCont

value = instance.GetGlyph(index)
public ImGearVectorVertexCont GetGlyph(
   int index
)
public: ImGearVectorVertexCont* GetGlyph(
   int index
)
public:
ImGearVectorVertexCont^ GetGlyph(
   int index
)

Parameters

index
Index of the glyph to be returned.

Return Value

New instance of ImGearVectorVertexCont class object in case of the font is Vector and null for TrueType font.
Remarks
The application can fill and modify any vector glyph. This method returns null for non-vector font.
See Also

Reference

ImGearVectorFont Class
ImGearVectorFont Members


%%PageItemTitle%% $$Properties$$

ImGearVectorFont Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorFont Class

For a list of all members of this type, see ImGearVectorFont members.

Public Properties
 | Name | Description
Public Property | GlyphCount | Gets or sets a number of glyphs in the vector font.
Public Property | IsVector | Gets a value indicating whetherthe font is vector (true) or TrueType (false).
Public Property | Typeface | Gets a font typeface.
Public Property | Weight | Gets a TrueType font weight.
Top
See Also

Reference

ImGearVectorFont Class
ImageGear.Vector Namespace


GlyphCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFont Class : GlyphCount Property
Gets or sets a number of glyphs in the vector font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GlyphCount As Integer
'Usage

Dim instance As ImGearVectorFont
Dim value As Integer

instance.GlyphCount = value

value = instance.GlyphCount
public int GlyphCount {get; set;}
public: __property int get_GlyphCount();
public: __property void set_GlyphCount(
   int value
);
public:
property int GlyphCount {
   int get();
   void set (    int value);
}

Property Value

Non-negative integer value.
Remarks
The property does nothing for TrueType fonts.
See Also

Reference

ImGearVectorFont Class
ImGearVectorFont Members


IsVector Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFont Class : IsVector Property
Gets a value indicating whetherthe font is vector (true) or TrueType (false).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsVector As Boolean
'Usage

Dim instance As ImGearVectorFont
Dim value As Boolean

value = instance.IsVector
public bool IsVector {get;}
public: __property bool get_IsVector();
public:
property bool IsVector {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearVectorFont Class
ImGearVectorFont Members


Typeface Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFont Class : Typeface Property
Gets a font typeface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Typeface As String
'Usage

Dim instance As ImGearVectorFont
Dim value As String

value = instance.Typeface
public string Typeface {get;}
public: __property string* get_Typeface();
public:
property String^ Typeface {
   String^ get();
}

Property Value

The string name of the font type.
See Also

Reference

ImGearVectorFont Class
ImGearVectorFont Members


Weight Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorFont Class : Weight Property
Gets a TrueType font weight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Weight As Integer
'Usage

Dim instance As ImGearVectorFont
Dim value As Integer

value = instance.Weight
public int Weight {get;}
public: __property int get_Weight();
public:
property int Weight {
   int get();
}

Property Value

Integer value of font weight.
Remarks
Weight has the same meaning as the corresponding Windows font parameter: 300 means light, 400 - normal, 700 - bold and so on.
See Also

Reference

ImGearVectorFont Class
ImGearVectorFont Members


%%PageItemTitle%%

ImGearVectorGradient Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradient Class
This class is used as the base for particular gradient filling classes.
Object Model
ImGearVectorGradient ClassImGearVectorColorEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearVectorGradient
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorGradient
public abstract class ImGearVectorGradient : ImGearVectorObject
public __gc abstract class ImGearVectorGradient : public ImGearVectorObject
public ref class ImGearVectorGradient abstract : public ImGearVectorObject
Remarks

There are two types of gradient filllings: linear and radial. They are represented by ImGearVectorGradientLinear class and ImGearVectorGradientRadial class, correspondingly.

The color of the gradient is defined by an array of stops. A stop is a pair of offset and color. Stop offsets are relative to gradient coordinates. 0.0 corresponds to the start point, 1.0 corresponds to the end points, in the case of a linear gradient, or to a point at the outer circle, in the case of a radial gradient. If first stop offset is greater than 0.0, or the last stop offset is less than 1.0, the gradient is expanded according to its Spread method. Gradient color is linearly interpolated between the stops.

Gradient filling can be transformed with an affine matrix.

Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorGradient
ImageGear.Vector.ImGearVectorGradientLinear
ImageGear.Vector.ImGearVectorGradientRadial

See Also

Reference

ImGearVectorGradient Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorGradient Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradient Class

The following tables list the members exposed by ImGearVectorGradient.

Public Properties
 | Name | Description
Public Property | SpreadMethod | Gets or sets spread method for the gradient object.
Top
Public Methods
 | Name | Description
Public Method | AddStop | Adds new stop to the gradient.
Public Method | GetMatrix | Returns the current transformation matrix of the gradient object.
Public Method | GetName | Returns the name of the gradient object.
Public Method | GetStopColor | Returns color of the specified stop.
Public Method | GetStopCount | Returns the number of stops in the gradient object.
Public Method | GetStopOffset | Returns offset of the specified stop.
Public Method | RemoveStop | Removes the specified stop from the gradient.
Public Method | SetMatrix | Sets transformation matrix of the gradient object.
Public Method | SetStopColor | Sets new color for the specified stop.
Public Method | SetStopOffset | Sets new offset for the specified stop.
Top
See Also

Reference

ImGearVectorGradient Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorGradient Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradient Class

For a list of all members of this type, see ImGearVectorGradient members.

Public Methods
 | Name | Description
Public Method | AddStop | Adds new stop to the gradient.
Public Method | GetMatrix | Returns the current transformation matrix of the gradient object.
Public Method | GetName | Returns the name of the gradient object.
Public Method | GetStopColor | Returns color of the specified stop.
Public Method | GetStopCount | Returns the number of stops in the gradient object.
Public Method | GetStopOffset | Returns offset of the specified stop.
Public Method | RemoveStop | Removes the specified stop from the gradient.
Public Method | SetMatrix | Sets transformation matrix of the gradient object.
Public Method | SetStopColor | Sets new color for the specified stop.
Public Method | SetStopOffset | Sets new offset for the specified stop.
Top
See Also

Reference

ImGearVectorGradient Class
ImageGear.Vector Namespace


AddStop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : AddStop Method
Offset of the new gradient stop.
Color of the new gradient stop.
Adds new stop to the gradient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddStop( _
   ByVal offset As Single, _
   ByVal color As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorGradient
Dim offset As Single
Dim color As ImGearVectorColorEx

instance.AddStop(offset, color)
public void AddStop(
   float offset,
   ImGearVectorColorEx color
)
public: void AddStop(
   float offset,
   ImGearVectorColorEx color
)
public:
void AddStop(
   float offset,
   ImGearVectorColorEx color
)

Parameters

offset
Offset of the new gradient stop.
color
Color of the new gradient stop.
Remarks
A stop is defined by its offset and color.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


GetMatrix Method (ImGearVectorGradient)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : GetMatrix Method
Returns the current transformation matrix of the gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatrix() As Single()
'Usage

Dim instance As ImGearVectorGradient
Dim value() As Single

value = instance.GetMatrix()
public float[] GetMatrix()
public: float[]* GetMatrix();
public:
array<float>^ GetMatrix();

Return Value

Array of 16 floating-point values.
Remarks
The matrix consists of 16 floating-point values and is aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44 Use SetMatrix method to set the transformation matrix of the gradient object.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


GetName Method (ImGearVectorGradient)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : GetName Method
Returns the name of the gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetName() As String
'Usage

Dim instance As ImGearVectorGradient
Dim value As String

value = instance.GetName()
public string GetName()
public: string* GetName();
public:
String^ GetName();

Return Value

Name of the gradient object.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


GetStopColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : GetStopColor Method
Stop index.
Returns color of the specified stop.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStopColor( _
   ByVal index As Integer _
) As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorGradient
Dim index As Integer
Dim value As ImGearVectorColorEx

value = instance.GetStopColor(index)
public ImGearVectorColorEx GetStopColor(
   int index
)
public: ImGearVectorColorEx GetStopColor(
   int index
)
public:
ImGearVectorColorEx GetStopColor(
   int index
)

Parameters

index
Stop index.

Return Value

Color of the specified stop.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


GetStopCount Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : GetStopCount Method
Returns the number of stops in the gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStopCount() As Integer
'Usage

Dim instance As ImGearVectorGradient
Dim value As Integer

value = instance.GetStopCount()
public int GetStopCount()
public: int GetStopCount();
public:
int GetStopCount();

Return Value

Number of stops in the gradient object.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


GetStopOffset Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : GetStopOffset Method
Stop index.
Returns offset of the specified stop.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetStopOffset( _
   ByVal index As Integer _
) As Single
'Usage

Dim instance As ImGearVectorGradient
Dim index As Integer
Dim value As Single

value = instance.GetStopOffset(index)
public float GetStopOffset(
   int index
)
public: float GetStopOffset(
   int index
)
public:
float GetStopOffset(
   int index
)

Parameters

index
Stop index.

Return Value

Offset of the specified stop.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


RemoveStop Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : RemoveStop Method
Index of the stop to remove.
Removes the specified stop from the gradient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveStop( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorGradient
Dim index As Integer

instance.RemoveStop(index)
public void RemoveStop(
   int index
)
public: void RemoveStop(
   int index
)
public:
void RemoveStop(
   int index
)

Parameters

index
Index of the stop to remove.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


SetMatrix Method (ImGearVectorGradient)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : SetMatrix Method
New transformation matrix.
Sets transformation matrix of the gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatrix( _
   ByVal matrix() As Single _
)
'Usage

Dim instance As ImGearVectorGradient
Dim matrix() As Single

instance.SetMatrix(matrix)
public void SetMatrix(
   float[] matrix
)
public: void SetMatrix(
   float[]* matrix
)
public:
void SetMatrix(
   array<float>^ matrix
)

Parameters

matrix
New transformation matrix.
Remarks
The matrix consists of 16 floating-point values and is aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members
GetMatrix Method


SetStopColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : SetStopColor Method
Stop index.
New color for the stop.
Sets new color for the specified stop.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetStopColor( _
   ByVal index As Integer, _
   ByVal color As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorGradient
Dim index As Integer
Dim color As ImGearVectorColorEx

instance.SetStopColor(index, color)
public void SetStopColor(
   int index,
   ImGearVectorColorEx color
)
public: void SetStopColor(
   int index,
   ImGearVectorColorEx color
)
public:
void SetStopColor(
   int index,
   ImGearVectorColorEx color
)

Parameters

index
Stop index.
color
New color for the stop.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


SetStopOffset Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : SetStopOffset Method
Stop index.
New offset for the specified stop.
Sets new offset for the specified stop.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetStopOffset( _
   ByVal index As Integer, _
   ByVal offset As Single _
)
'Usage

Dim instance As ImGearVectorGradient
Dim index As Integer
Dim offset As Single

instance.SetStopOffset(index, offset)
public void SetStopOffset(
   int index,
   float offset
)
public: void SetStopOffset(
   int index,
   float offset
)
public:
void SetStopOffset(
   int index,
   float offset
)

Parameters

index
Stop index.
offset
New offset for the specified stop.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


%%PageItemTitle%% $$Properties$$

ImGearVectorGradient Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradient Class

For a list of all members of this type, see ImGearVectorGradient members.

Public Properties
 | Name | Description
Public Property | SpreadMethod | Gets or sets spread method for the gradient object.
Top
See Also

Reference

ImGearVectorGradient Class
ImageGear.Vector Namespace


SpreadMethod Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradient Class : SpreadMethod Property
Gets or sets spread method for the gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpreadMethod As ImGearVectGradientSpreadMethod
'Usage

Dim instance As ImGearVectorGradient
Dim value As ImGearVectGradientSpreadMethod

instance.SpreadMethod = value

value = instance.SpreadMethod
public ImGearVectGradientSpreadMethod SpreadMethod {get; set;}
public: __property ImGearVectGradientSpreadMethod get_SpreadMethod();
public: __property void set_SpreadMethod(
   ImGearVectGradientSpreadMethod value
);
public:
property ImGearVectGradientSpreadMethod SpreadMethod {
   ImGearVectGradientSpreadMethod get();
   void set (    ImGearVectGradientSpreadMethod value);
}

Property Value

ImGearVectGradientSpreadMethod object.
Remarks
Spread method specifies how the gradient is expanded. See ImGearVectGradientSpreadMethod enumeration for the list of available spread methods.
See Also

Reference

ImGearVectorGradient Class
ImGearVectorGradient Members


%%PageItemTitle%%

ImGearVectorGradientLinear Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientLinear Class
Represents a linear gradient object.
Object Model
ImGearVectorGradientLinear Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorGradientLinear
   Inherits ImGearVectorGradient
'Usage

Dim instance As ImGearVectorGradientLinear
public class ImGearVectorGradientLinear : ImGearVectorGradient
public __gc class ImGearVectorGradientLinear : public ImGearVectorGradient
public ref class ImGearVectorGradientLinear : public ImGearVectorGradient
Remarks
Geometric layout of a linear gradient object is defined by its vector (start and end points).
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorGradient
ImageGear.Vector.ImGearVectorGradientLinear

See Also

Reference

ImGearVectorGradientLinear Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorGradientLinear Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientLinear Class

The following tables list the members exposed by ImGearVectorGradientLinear.

Public Methods
 | Name | Description
Public Method | GetVector | Returns the vector that specifies geometric layout of the linear gradient object.
Public Method | SetVector | Sets the vector that specifies geometric layout of the linear gradient object.
Top
See Also

Reference

ImGearVectorGradientLinear Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorGradientLinear Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientLinear Class

For a list of all members of this type, see ImGearVectorGradientLinear members.

See Also

Reference

ImGearVectorGradientLinear Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorGradientLinear Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientLinear Class

For a list of all members of this type, see ImGearVectorGradientLinear members.

Public Methods
 | Name | Description
Public Method | GetVector | Returns the vector that specifies geometric layout of the linear gradient object.
Public Method | SetVector | Sets the vector that specifies geometric layout of the linear gradient object.
Top
See Also

Reference

ImGearVectorGradientLinear Class
ImageGear.Vector Namespace


GetVector Method (ImGearVectorGradientLinear)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradientLinear Class : GetVector Method
Returns gradient start point.
Returns gradient end point.
Returns a flag indicating whether the start and end point coordinates are relative or absolute.
Returns the vector that specifies geometric layout of the linear gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetVector( _
   ByRef gradientStart As ImGearVectorPoint3D, _
   ByRef gradientEnd As ImGearVectorPoint3D, _
   ByRef isAbsolute As Boolean _
)
'Usage

Dim instance As ImGearVectorGradientLinear
Dim gradientStart As ImGearVectorPoint3D
Dim gradientEnd As ImGearVectorPoint3D
Dim isAbsolute As Boolean

instance.GetVector(gradientStart, gradientEnd, isAbsolute)
public void GetVector(
   ref ImGearVectorPoint3D gradientStart,
   ref ImGearVectorPoint3D gradientEnd,
   ref bool isAbsolute
)
public: void GetVector(
   ref ImGearVectorPoint3D gradientStart,
   ref ImGearVectorPoint3D gradientEnd,
   ref bool isAbsolute
)
public:
void GetVector(
   ImGearVectorPoint3D% gradientStart,
   ImGearVectorPoint3D% gradientEnd,
   bool% isAbsolute
)

Parameters

gradientStart
Returns gradient start point.
gradientEnd
Returns gradient end point.
isAbsolute
Returns a flag indicating whether the start and end point coordinates are relative or absolute.
See Also

Reference

ImGearVectorGradientLinear Class
ImGearVectorGradientLinear Members


SetVector Method (ImGearVectorGradientLinear)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradientLinear Class : SetVector Method
Gradient start point.
Gradient end point.
Flag indicating whether the start and end point coordinates are relative or absolute.
Sets the vector that specifies geometric layout of the linear gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVector( _
   ByVal gradientStart As ImGearVectorPoint3D, _
   ByVal gradientEnd As ImGearVectorPoint3D, _
   ByVal isAbsolute As Boolean _
)
'Usage

Dim instance As ImGearVectorGradientLinear
Dim gradientStart As ImGearVectorPoint3D
Dim gradientEnd As ImGearVectorPoint3D
Dim isAbsolute As Boolean

instance.SetVector(gradientStart, gradientEnd, isAbsolute)
public void SetVector(
   ImGearVectorPoint3D gradientStart,
   ImGearVectorPoint3D gradientEnd,
   bool isAbsolute
)
public: void SetVector(
   ImGearVectorPoint3D gradientStart,
   ImGearVectorPoint3D gradientEnd,
   bool isAbsolute
)
public:
void SetVector(
   ImGearVectorPoint3D gradientStart,
   ImGearVectorPoint3D gradientEnd,
   bool isAbsolute
)

Parameters

gradientStart
Gradient start point.
gradientEnd
Gradient end point.
isAbsolute
Flag indicating whether the start and end point coordinates are relative or absolute.
See Also

Reference

ImGearVectorGradientLinear Class
ImGearVectorGradientLinear Members


%%PageItemTitle%%

ImGearVectorGradientRadial Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientRadial Class
Represents a radial gradient object.
Object Model
ImGearVectorGradientRadial Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorGradientRadial
   Inherits ImGearVectorGradient
'Usage

Dim instance As ImGearVectorGradientRadial
public class ImGearVectorGradientRadial : ImGearVectorGradient
public __gc class ImGearVectorGradientRadial : public ImGearVectorGradient
public ref class ImGearVectorGradientRadial : public ImGearVectorGradient
Remarks
Geometric layout of a linear gradient object is defined by its inner point, and center and radius of the outer circle. Start point should be located inside the outer circle, but not necessarily in its center.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorGradient
ImageGear.Vector.ImGearVectorGradientRadial

See Also

Reference

ImGearVectorGradientRadial Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorGradientRadial Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientRadial Class

The following tables list the members exposed by ImGearVectorGradientRadial.

Public Methods
 | Name | Description
Public Method | GetVector | Returns geometric layout of the radial gradient object.
Public Method | SetVector | Sets geometric layout of the radial gradient object.
Top
See Also

Reference

ImGearVectorGradientRadial Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorGradientRadial Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientRadial Class

For a list of all members of this type, see ImGearVectorGradientRadial members.

See Also

Reference

ImGearVectorGradientRadial Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorGradientRadial Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorGradientRadial Class

For a list of all members of this type, see ImGearVectorGradientRadial members.

Public Methods
 | Name | Description
Public Method | GetVector | Returns geometric layout of the radial gradient object.
Public Method | SetVector | Sets geometric layout of the radial gradient object.
Top
See Also

Reference

ImGearVectorGradientRadial Class
ImageGear.Vector Namespace


GetVector Method (ImGearVectorGradientRadial)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradientRadial Class : GetVector Method
Returns coordinates of the inner point.
Returns coordinates of the center of the outer circle.
Returns radius of the outer circle.
Returns a flag indicating whether the coordinates and radius are relative or absolute.
Returns geometric layout of the radial gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetVector( _
   ByRef innerPoint As ImGearVectorPoint3D, _
   ByRef outerCenter As ImGearVectorPoint3D, _
   ByRef outerRadius As Single, _
   ByRef isAbsolute As Boolean _
)
'Usage

Dim instance As ImGearVectorGradientRadial
Dim innerPoint As ImGearVectorPoint3D
Dim outerCenter As ImGearVectorPoint3D
Dim outerRadius As Single
Dim isAbsolute As Boolean

instance.GetVector(innerPoint, outerCenter, outerRadius, isAbsolute)
public void GetVector(
   ref ImGearVectorPoint3D innerPoint,
   ref ImGearVectorPoint3D outerCenter,
   ref float outerRadius,
   ref bool isAbsolute
)
public: void GetVector(
   ref ImGearVectorPoint3D innerPoint,
   ref ImGearVectorPoint3D outerCenter,
   ref float outerRadius,
   ref bool isAbsolute
)
public:
void GetVector(
   ImGearVectorPoint3D% innerPoint,
   ImGearVectorPoint3D% outerCenter,
   float% outerRadius,
   bool% isAbsolute
)

Parameters

innerPoint
Returns coordinates of the inner point.
outerCenter
Returns coordinates of the center of the outer circle.
outerRadius
Returns radius of the outer circle.
isAbsolute
Returns a flag indicating whether the coordinates and radius are relative or absolute.
See Also

Reference

ImGearVectorGradientRadial Class
ImGearVectorGradientRadial Members


SetVector Method (ImGearVectorGradientRadial)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorGradientRadial Class : SetVector Method
Coordinates of the inner point.
Coordinates of the center of the outer circle.
Radius of the outer circle.
Specifies whether coordinates and radius are relative or absolute.
Sets geometric layout of the radial gradient object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVector( _
   ByVal innerPoint As ImGearVectorPoint3D, _
   ByVal outerCenter As ImGearVectorPoint3D, _
   ByVal outerRadius As Single, _
   ByVal isAbsolute As Boolean _
)
'Usage

Dim instance As ImGearVectorGradientRadial
Dim innerPoint As ImGearVectorPoint3D
Dim outerCenter As ImGearVectorPoint3D
Dim outerRadius As Single
Dim isAbsolute As Boolean

instance.SetVector(innerPoint, outerCenter, outerRadius, isAbsolute)
public void SetVector(
   ImGearVectorPoint3D innerPoint,
   ImGearVectorPoint3D outerCenter,
   float outerRadius,
   bool isAbsolute
)
public: void SetVector(
   ImGearVectorPoint3D innerPoint,
   ImGearVectorPoint3D outerCenter,
   float outerRadius,
   bool isAbsolute
)
public:
void SetVector(
   ImGearVectorPoint3D innerPoint,
   ImGearVectorPoint3D outerCenter,
   float outerRadius,
   bool isAbsolute
)

Parameters

innerPoint
Coordinates of the inner point.
outerCenter
Coordinates of the center of the outer circle.
outerRadius
Radius of the outer circle.
isAbsolute
Specifies whether coordinates and radius are relative or absolute.
See Also

Reference

ImGearVectorGradientRadial Class
ImGearVectorGradientRadial Members


%%PageItemTitle%%

ImGearVectorHatch Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatch Class
Represents a vector hatch.
Object Model
ImGearVectorHatch ClassImGearVectorHatchline ClassImGearVectorHatchline Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorHatch
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorHatch
public class ImGearVectorHatch : ImGearVectorObject
public __gc class ImGearVectorHatch : public ImGearVectorObject
public ref class ImGearVectorHatch : public ImGearVectorObject
Remarks
Vector hatch is a special kind of fill type. It is defined by the set of lines with corresponding patterns, offsets and angles.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorHatch

See Also

Reference

ImGearVectorHatch Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorHatch Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatch Class

The following tables list the members exposed by ImGearVectorHatch.

Public Properties
 | Name | Description
Public Property | LineCount | Gets a total line count in the hatch.
Top
Public Methods
 | Name | Description
Public Method | CreateLine | Creates a new hatch line and adds it to the hatch.
Public Method | DeleteLine | Removes the hatch line specified with index from the hatch and destroys it.
Public Method | GetLine | Gets the handle of the hatch line specified by the index.
Top
See Also

Reference

ImGearVectorHatch Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorHatch Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatch Class

For a list of all members of this type, see ImGearVectorHatch members.

Public Methods
 | Name | Description
Public Method | CreateLine | Creates a new hatch line and adds it to the hatch.
Public Method | DeleteLine | Removes the hatch line specified with index from the hatch and destroys it.
Public Method | GetLine | Gets the handle of the hatch line specified by the index.
Top
See Also

Reference

ImGearVectorHatch Class
ImageGear.Vector Namespace


CreateLine Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatch Class : CreateLine Method
Creates a new hatch line and adds it to the hatch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateLine() As ImGearVectorHatchline
'Usage

Dim instance As ImGearVectorHatch
Dim value As ImGearVectorHatchline

value = instance.CreateLine()
public ImGearVectorHatchline CreateLine()
public: ImGearVectorHatchline* CreateLine();
public:
ImGearVectorHatchline^ CreateLine();

Return Value

New instance of ImGearVectorHatchline class object.
See Also

Reference

ImGearVectorHatch Class
ImGearVectorHatch Members


DeleteLine Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatch Class : DeleteLine Method
Index of the line to be deleted.
Removes the hatch line specified with index from the hatch and destroys it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteLine( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearVectorHatch
Dim index As Integer

instance.DeleteLine(index)
public void DeleteLine(
   int index
)
public: void DeleteLine(
   int index
)
public:
void DeleteLine(
   int index
)

Parameters

index
Index of the line to be deleted.
See Also

Reference

ImGearVectorHatch Class
ImGearVectorHatch Members


GetLine Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatch Class : GetLine Method
Index of the line in the hatch.
Gets the handle of the hatch line specified by the index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLine( _
   ByVal index As Integer _
) As ImGearVectorHatchline
'Usage

Dim instance As ImGearVectorHatch
Dim index As Integer
Dim value As ImGearVectorHatchline

value = instance.GetLine(index)
public ImGearVectorHatchline GetLine(
   int index
)
public: ImGearVectorHatchline* GetLine(
   int index
)
public:
ImGearVectorHatchline^ GetLine(
   int index
)

Parameters

index
Index of the line in the hatch.

Return Value

New instance of ImGearVectorHatchline class object.
See Also

Reference

ImGearVectorHatch Class
ImGearVectorHatch Members


%%PageItemTitle%% $$Properties$$

ImGearVectorHatch Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatch Class

For a list of all members of this type, see ImGearVectorHatch members.

Public Properties
 | Name | Description
Public Property | LineCount | Gets a total line count in the hatch.
Top
See Also

Reference

ImGearVectorHatch Class
ImageGear.Vector Namespace


LineCount Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatch Class : LineCount Property
Gets a total line count in the hatch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LineCount As Integer
'Usage

Dim instance As ImGearVectorHatch
Dim value As Integer

value = instance.LineCount
public int LineCount {get;}
public: __property int get_LineCount();
public:
property int LineCount {
   int get();
}

Property Value

Non-negative integer number.
See Also

Reference

ImGearVectorHatch Class
ImGearVectorHatch Members


%%PageItemTitle%%

ImGearVectorHatchline Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatchline Class
Represents the line segment for the vector hatch.
Object Model
ImGearVectorHatchline ClassImGearVectorPoint2D StructureImGearVectorPoint2D StructureImGearVectorFloatCont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorHatchline
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorHatchline
public class ImGearVectorHatchline : ImGearVectorObject
public __gc class ImGearVectorHatchline : public ImGearVectorObject
public ref class ImGearVectorHatchline : public ImGearVectorObject
Remarks
The vector hatch is an especial kind of the fill type. It is defined by the set of lines with corresponding patterns, offsets and angles. Hatch line pattern is a floating point array, not a bit mask as for line type pattern.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorHatchline

See Also

Reference

ImGearVectorHatchline Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorHatchline Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatchline Class

The following tables list the members exposed by ImGearVectorHatchline.

Public Properties
 | Name | Description
Public Property | LineAngle | Gets or sets an angle of the specified hatch line in radians.
Top
Public Methods
 | Name | Description
Public Method | GetBasePoint | Gets a base point of the hatch line.
Public Method | GetOffset | Returns the hatch line offset.
Public Method | GetPattern | Returns a container with floating point values specifying the hatch line pattern.
Public Method | SetBasePoint | Sets the base point of the hatch line.
Public Method | SetOffset | Sets the hatch line offset.
Top
See Also

Reference

ImGearVectorHatchline Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorHatchline Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatchline Class

For a list of all members of this type, see ImGearVectorHatchline members.

Public Methods
 | Name | Description
Public Method | GetBasePoint | Gets a base point of the hatch line.
Public Method | GetOffset | Returns the hatch line offset.
Public Method | GetPattern | Returns a container with floating point values specifying the hatch line pattern.
Public Method | SetBasePoint | Sets the base point of the hatch line.
Public Method | SetOffset | Sets the hatch line offset.
Top
See Also

Reference

ImGearVectorHatchline Class
ImageGear.Vector Namespace


GetBasePoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : GetBasePoint Method
Gets a base point of the hatch line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBasePoint() As ImGearVectorPoint2D
'Usage

Dim instance As ImGearVectorHatchline
Dim value As ImGearVectorPoint2D

value = instance.GetBasePoint()
public ImGearVectorPoint2D GetBasePoint()
public: ImGearVectorPoint2D GetBasePoint();
public:
ImGearVectorPoint2D GetBasePoint();

Return Value

New instance of ImGearVectorPoint2D structure object.
Remarks
The base point is the starting point of the first line in the hatch.
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members


GetOffset Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : GetOffset Method
Returns the hatch line offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOffset() As ImGearVectorPoint2D
'Usage

Dim instance As ImGearVectorHatchline
Dim value As ImGearVectorPoint2D

value = instance.GetOffset()
public ImGearVectorPoint2D GetOffset()
public: ImGearVectorPoint2D GetOffset();
public:
ImGearVectorPoint2D GetOffset();

Return Value

New instance of ImGearVectorPoint2D structure object.
Remarks
X and Y offset coordinates specify the distance between lines in the hatch.
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members


GetPattern Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : GetPattern Method
Returns a container with floating point values specifying the hatch line pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPattern() As ImGearVectorFloatCont
'Usage

Dim instance As ImGearVectorHatchline
Dim value As ImGearVectorFloatCont

value = instance.GetPattern()
public ImGearVectorFloatCont GetPattern()
public: ImGearVectorFloatCont* GetPattern();
public:
ImGearVectorFloatCont^ GetPattern();

Return Value

New instance of ImGearVectorFloatCont class object.
Remarks
The first value in the container corresponds to "pen down", second to "pen up", and so on.
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members


SetBasePoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : SetBasePoint Method
Base point being set.
Sets the base point of the hatch line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetBasePoint( _
   ByVal value As ImGearVectorPoint2D _
)
'Usage

Dim instance As ImGearVectorHatchline
Dim value As ImGearVectorPoint2D

instance.SetBasePoint(value)
public void SetBasePoint(
   ImGearVectorPoint2D value
)
public: void SetBasePoint(
   ImGearVectorPoint2D value
)
public:
void SetBasePoint(
   ImGearVectorPoint2D value
)

Parameters

value
Base point being set.
Remarks
The base point is a start point of the first line in the the hatch.
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members
ImGearVectorPoint2D Structure


SetOffset Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : SetOffset Method
Hatch line offset point to be set.
Sets the hatch line offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetOffset( _
   ByVal value As ImGearVectorPoint2D _
)
'Usage

Dim instance As ImGearVectorHatchline
Dim value As ImGearVectorPoint2D

instance.SetOffset(value)
public void SetOffset(
   ImGearVectorPoint2D value
)
public: void SetOffset(
   ImGearVectorPoint2D value
)
public:
void SetOffset(
   ImGearVectorPoint2D value
)

Parameters

value
Hatch line offset point to be set.
Remarks
X and Y offset coordinates specify distance between lines in the hatch.
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members
ImGearVectorPoint2D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorHatchline Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorHatchline Class

For a list of all members of this type, see ImGearVectorHatchline members.

Public Properties
 | Name | Description
Public Property | LineAngle | Gets or sets an angle of the specified hatch line in radians.
Top
See Also

Reference

ImGearVectorHatchline Class
ImageGear.Vector Namespace


LineAngle Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorHatchline Class : LineAngle Property
Gets or sets an angle of the specified hatch line in radians.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineAngle As Single
'Usage

Dim instance As ImGearVectorHatchline
Dim value As Single

instance.LineAngle = value

value = instance.LineAngle
public float LineAngle {get; set;}
public: __property float get_LineAngle();
public: __property void set_LineAngle(
   float value
);
public:
property float LineAngle {
   float get();
   void set (    float value);
}

Property Value

Any positive value in the range of 0 - 6.28...
See Also

Reference

ImGearVectorHatchline Class
ImGearVectorHatchline Members


%%PageItemTitle%%

ImGearVectorLayer Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLayer Class
Contains drawing attributes that can be applied to several entities.
Object Model
ImGearVectorLayer ClassImGearVectorColorEx StructureImGearVectorColorEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorLayer
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorLayer
public class ImGearVectorLayer : ImGearVectorObject
public __gc class ImGearVectorLayer : public ImGearVectorObject
public ref class ImGearVectorLayer : public ImGearVectorObject
Remarks
The layer is created by vector data object and can be attached to any entity.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorLayer

See Also

Reference

ImGearVectorLayer Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorLayer Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLayer Class

The following tables list the members exposed by ImGearVectorLayer.

Public Properties
 | Name | Description
Public Property | FilltypeIndex | Gets or sets an index of the fill type attribute of the layer.
Public Property | LineThickness | Gets or sets line thickness attribute of the layer.
Public Property | LinetypeIndex | Gets or sets an index of the line type attribute of the layer.
Public Property | Name | Gets or sets the name of the layer.
Top
Public Methods
 | Name | Description
Public Method | CopyTo | Copies layer settings to another layer.
Public Method | GetDrawColor | Gets the draw color of the layer.
Public Method | GetFillColor | Gets the fill color of the layer.
Public Method | SetDrawColor | Sets the draw color of the layer.
Public Method | SetFillColor | Sets the fill color of the layer.
Top
See Also

Reference

ImGearVectorLayer Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorLayer Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLayer Class

For a list of all members of this type, see ImGearVectorLayer members.

Public Methods
 | Name | Description
Public Method | CopyTo | Copies layer settings to another layer.
Public Method | GetDrawColor | Gets the draw color of the layer.
Public Method | GetFillColor | Gets the fill color of the layer.
Public Method | SetDrawColor | Sets the draw color of the layer.
Public Method | SetFillColor | Sets the fill color of the layer.
Top
See Also

Reference

ImGearVectorLayer Class
ImageGear.Vector Namespace


CopyTo Method (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : CopyTo Method
Destination layer to copy the settings to.
Copies layer settings to another layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal destinationLayer As ImGearVectorLayer _
)
'Usage

Dim instance As ImGearVectorLayer
Dim destinationLayer As ImGearVectorLayer

instance.CopyTo(destinationLayer)
public void CopyTo(
   ImGearVectorLayer destinationLayer
)
public: void CopyTo(
   ImGearVectorLayer* destinationLayer
)
public:
void CopyTo(
   ImGearVectorLayer^ destinationLayer
)

Parameters

destinationLayer
Destination layer to copy the settings to.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members
ImGearVectorLayer Class


GetDrawColor Method (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : GetDrawColor Method
Gets the draw color of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDrawColor() As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorLayer
Dim value As ImGearVectorColorEx

value = instance.GetDrawColor()
public ImGearVectorColorEx GetDrawColor()
public: ImGearVectorColorEx GetDrawColor();
public:
ImGearVectorColorEx GetDrawColor();

Return Value

New instance of ImGearVectorColorEx structure object.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


GetFillColor Method (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : GetFillColor Method
Gets the fill color of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFillColor() As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorLayer
Dim value As ImGearVectorColorEx

value = instance.GetFillColor()
public ImGearVectorColorEx GetFillColor()
public: ImGearVectorColorEx GetFillColor();
public:
ImGearVectorColorEx GetFillColor();

Return Value

New instance of ImGearVectorColorEx structure object.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


SetDrawColor Method (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : SetDrawColor Method
The draw color of the layer.
Sets the draw color of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDrawColor( _
   ByVal color As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorLayer
Dim color As ImGearVectorColorEx

instance.SetDrawColor(color)
public void SetDrawColor(
   ImGearVectorColorEx color
)
public: void SetDrawColor(
   ImGearVectorColorEx color
)
public:
void SetDrawColor(
   ImGearVectorColorEx color
)

Parameters

color
The draw color of the layer.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members
ImGearVectorColorEx Structure


SetFillColor Method (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : SetFillColor Method
The fill color of the layer.
Sets the fill color of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetFillColor( _
   ByVal value As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorLayer
Dim value As ImGearVectorColorEx

instance.SetFillColor(value)
public void SetFillColor(
   ImGearVectorColorEx value
)
public: void SetFillColor(
   ImGearVectorColorEx value
)
public:
void SetFillColor(
   ImGearVectorColorEx value
)

Parameters

value
The fill color of the layer.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members
ImGearVectorColorEx Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorLayer Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLayer Class

For a list of all members of this type, see ImGearVectorLayer members.

Public Properties
 | Name | Description
Public Property | FilltypeIndex | Gets or sets an index of the fill type attribute of the layer.
Public Property | LineThickness | Gets or sets line thickness attribute of the layer.
Public Property | LinetypeIndex | Gets or sets an index of the line type attribute of the layer.
Public Property | Name | Gets or sets the name of the layer.
Top
See Also

Reference

ImGearVectorLayer Class
ImageGear.Vector Namespace


FilltypeIndex Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : FilltypeIndex Property
Gets or sets an index of the fill type attribute of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FilltypeIndex As Integer
'Usage

Dim instance As ImGearVectorLayer
Dim value As Integer

instance.FilltypeIndex = value

value = instance.FilltypeIndex
public int FilltypeIndex {get; set;}
public: __property int get_FilltypeIndex();
public: __property void set_FilltypeIndex(
   int value
);
public:
property int FilltypeIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value between 0 and (vectdata.FilltypeCount - 1), where vectdata is the ImGearVectorData class object the layer belongs to.
Remarks
Actual fill types are contained in the fill types container of the vector data object. The default value is 0.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


LineThickness Property (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : LineThickness Property
Gets or sets line thickness attribute of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineThickness As Single
'Usage

Dim instance As ImGearVectorLayer
Dim value As Single

instance.LineThickness = value

value = instance.LineThickness
public float LineThickness {get; set;}
public: __property float get_LineThickness();
public: __property void set_LineThickness(
   float value
);
public:
property float LineThickness {
   float get();
   void set (    float value);
}

Property Value

Any non-negative value.
Remarks
Zero thickness means that the line is always drawn with a width of one pixel. The default value is 0.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


LinetypeIndex Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : LinetypeIndex Property
Gets or sets an index of the line type attribute of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LinetypeIndex As Integer
'Usage

Dim instance As ImGearVectorLayer
Dim value As Integer

instance.LinetypeIndex = value

value = instance.LinetypeIndex
public int LinetypeIndex {get; set;}
public: __property int get_LinetypeIndex();
public: __property void set_LinetypeIndex(
   int value
);
public:
property int LinetypeIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value between 0 and (vectdata.LinetypeCount - 1), where vectdata is the ImGearVectorData class object the layer belongs to.
Remarks
Actual line types are contained in the line types container of the vector data object. The default value is 0.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


Name Property (ImGearVectorLayer)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLayer Class : Name Property
Gets or sets the name of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As ImGearVectorLayer
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Any string value that is unique for the given vector data object.
Remarks
The default value is an empty string.
See Also

Reference

ImGearVectorLayer Class
ImGearVectorLayer Members


%%PageItemTitle%%

ImGearVectorLightSource Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLightSource Class
Implements a light source.
Object Model
ImGearVectorLightSource Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorLightSource
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorLightSource
public class ImGearVectorLightSource : ImGearVectorObject
public __gc class ImGearVectorLightSource : public ImGearVectorObject
public ref class ImGearVectorLightSource : public ImGearVectorObject
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorLightSource

See Also

Reference

ImGearVectorLightSource Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorLightSource Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLightSource Class

The following tables list the members exposed by ImGearVectorLightSource.

Public Properties
 | Name | Description
Public Property | AmbientColor | Gets or sets an ambient color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Public Property | CutoffAngle | Gets or sets a spotlight angle of the light source.
Public Property | DiffuseColor | Gets or sets a diffuse color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, put can be greater than 1.
Public Property | Direction | Gets or sets a light source direction. The direction is presented as an array of three direction components (x, y, z).
Public Property | Enabled | Gets or sets a value indicating whether to enable or disable the light source.
Public Property | Exponent | Gets or sets a spotlight exponent of the light source.
Public Property | Position | Gets or sets a light source position. The position is presented as a vector of three coordinates (x, y, z).
Public Property | SpecularColor | Gets or sets a specular color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Top
Public Methods
 | Name | Description
Public Method | GetAttenuation | Returns constant, linear and quadratic attenuation factors of the light source.
Public Method | SetAttenuation | Sets constant, linear and quadratic attenuation factors of the light source.
Top
See Also

Reference

ImGearVectorLightSource Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorLightSource Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLightSource Class

For a list of all members of this type, see ImGearVectorLightSource members.

Public Methods
 | Name | Description
Public Method | GetAttenuation | Returns constant, linear and quadratic attenuation factors of the light source.
Public Method | SetAttenuation | Sets constant, linear and quadratic attenuation factors of the light source.
Top
See Also

Reference

ImGearVectorLightSource Class
ImageGear.Vector Namespace


GetAttenuation Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : GetAttenuation Method
Returns constant attenuation factor.
Returns attenuation factor.
Returns quadratic attenuation factor.
Returns constant, linear and quadratic attenuation factors of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetAttenuation( _
   ByRef constantFactor As Single, _
   ByRef linearFactor As Single, _
   ByRef quadraticFactor As Single _
)
'Usage

Dim instance As ImGearVectorLightSource
Dim constantFactor As Single
Dim linearFactor As Single
Dim quadraticFactor As Single

instance.GetAttenuation(constantFactor, linearFactor, quadraticFactor)
public void GetAttenuation(
   ref float constantFactor,
   ref float linearFactor,
   ref float quadraticFactor
)
public: void GetAttenuation(
   ref float constantFactor,
   ref float linearFactor,
   ref float quadraticFactor
)
public:
void GetAttenuation(
   float% constantFactor,
   float% linearFactor,
   float% quadraticFactor
)

Parameters

constantFactor
Returns constant attenuation factor.
linearFactor
Returns attenuation factor.
quadraticFactor
Returns quadratic attenuation factor.
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


SetAttenuation Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : SetAttenuation Method
New constant attenuation factor.
New linear attenuation factor.
New quadratic attenuation factor.
Sets constant, linear and quadratic attenuation factors of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAttenuation( _
   ByVal constantFactor As Single, _
   ByVal linearFactor As Single, _
   ByVal quadraticFactor As Single _
)
'Usage

Dim instance As ImGearVectorLightSource
Dim constantFactor As Single
Dim linearFactor As Single
Dim quadraticFactor As Single

instance.SetAttenuation(constantFactor, linearFactor, quadraticFactor)
public void SetAttenuation(
   float constantFactor,
   float linearFactor,
   float quadraticFactor
)
public: void SetAttenuation(
   float constantFactor,
   float linearFactor,
   float quadraticFactor
)
public:
void SetAttenuation(
   float constantFactor,
   float linearFactor,
   float quadraticFactor
)

Parameters

constantFactor
New constant attenuation factor.
linearFactor
New linear attenuation factor.
quadraticFactor
New quadratic attenuation factor.
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


%%PageItemTitle%% $$Properties$$

ImGearVectorLightSource Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLightSource Class

For a list of all members of this type, see ImGearVectorLightSource members.

Public Properties
 | Name | Description
Public Property | AmbientColor | Gets or sets an ambient color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Public Property | CutoffAngle | Gets or sets a spotlight angle of the light source.
Public Property | DiffuseColor | Gets or sets a diffuse color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, put can be greater than 1.
Public Property | Direction | Gets or sets a light source direction. The direction is presented as an array of three direction components (x, y, z).
Public Property | Enabled | Gets or sets a value indicating whether to enable or disable the light source.
Public Property | Exponent | Gets or sets a spotlight exponent of the light source.
Public Property | Position | Gets or sets a light source position. The position is presented as a vector of three coordinates (x, y, z).
Public Property | SpecularColor | Gets or sets a specular color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Top
See Also

Reference

ImGearVectorLightSource Class
ImageGear.Vector Namespace


AmbientColor Property (ImGearVectorLightSource)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : AmbientColor Property
Gets or sets an ambient color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AmbientColor As Single()
'Usage

Dim instance As ImGearVectorLightSource
Dim value() As Single

instance.AmbientColor = value

value = instance.AmbientColor
public float[] AmbientColor {get; set;}
public: __property float[]* get_AmbientColor();
public: __property void set_AmbientColor(
   float[]* value
);
public:
property array<float>^ AmbientColor {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of 4 color components - red, green, blue and alpha.
Remarks
The default value is (0.5, 0.5, 0.5, 1).
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


CutoffAngle Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : CutoffAngle Property
Gets or sets a spotlight angle of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CutoffAngle As Single
'Usage

Dim instance As ImGearVectorLightSource
Dim value As Single

instance.CutoffAngle = value

value = instance.CutoffAngle
public float CutoffAngle {get; set;}
public: __property float get_CutoffAngle();
public: __property void set_CutoffAngle(
   float value
);
public:
property float CutoffAngle {
   float get();
   void set (    float value);
}

Property Value

Floating-point value in the range of 0...90 or 180. 180 means that the light is distributed uniformly.
Remarks
The default value is 180.
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


DiffuseColor Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : DiffuseColor Property
Gets or sets a diffuse color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, put can be greater than 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DiffuseColor As Single()
'Usage

Dim instance As ImGearVectorLightSource
Dim value() As Single

instance.DiffuseColor = value

value = instance.DiffuseColor
public float[] DiffuseColor {get; set;}
public: __property float[]* get_DiffuseColor();
public: __property void set_DiffuseColor(
   float[]* value
);
public:
property array<float>^ DiffuseColor {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of four color components - red, green, blue and alpha.
Remarks
The default value is (0, 0, 0, 1).
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


Direction Property (ImGearVectorLightSource)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : Direction Property
Gets or sets a light source direction. The direction is presented as an array of three direction components (x, y, z).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As Single()
'Usage

Dim instance As ImGearVectorLightSource
Dim value() As Single

instance.Direction = value

value = instance.Direction
public float[] Direction {get; set;}
public: __property float[]* get_Direction();
public: __property void set_Direction(
   float[]* value
);
public:
property array<float>^ Direction {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of three vector components - x, y and z.
Remarks
The default value is (0, 0, 1).
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


Enabled Property (ImGearVectorLightSource)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : Enabled Property
Gets or sets a value indicating whether to enable or disable the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As ImGearVectorLightSource
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is false.
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


Exponent Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : Exponent Property
Gets or sets a spotlight exponent of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Exponent As Single
'Usage

Dim instance As ImGearVectorLightSource
Dim value As Single

instance.Exponent = value

value = instance.Exponent
public float Exponent {get; set;}
public: __property float get_Exponent();
public: __property void set_Exponent(
   float value
);
public:
property float Exponent {
   float get();
   void set (    float value);
}

Property Value

Floating-point value in the range of 0...128.
Remarks
The default value is 128.
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


Position Property (ImGearVectorLightSource)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : Position Property
Gets or sets a light source position. The position is presented as a vector of three coordinates (x, y, z).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Position As Single()
'Usage

Dim instance As ImGearVectorLightSource
Dim value() As Single

instance.Position = value

value = instance.Position
public float[] Position {get; set;}
public: __property float[]* get_Position();
public: __property void set_Position(
   float[]* value
);
public:
property array<float>^ Position {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of three point coordinates - x, y and z.
Remarks
The default value is (0, 0, 0).
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


SpecularColor Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLightSource Class : SpecularColor Property
Gets or sets a specular color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpecularColor As Single()
'Usage

Dim instance As ImGearVectorLightSource
Dim value() As Single

instance.SpecularColor = value

value = instance.SpecularColor
public float[] SpecularColor {get; set;}
public: __property float[]* get_SpecularColor();
public: __property void set_SpecularColor(
   float[]* value
);
public:
property array<float>^ SpecularColor {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of four color components - red, green, blue and alpha.
Remarks
The default value is (0, 0, 0, 1).
See Also

Reference

ImGearVectorLightSource Class
ImGearVectorLightSource Members


%%PageItemTitle%%

ImGearVectorLinetype Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLinetype Class
Represents the line type.
Object Model
ImGearVectorLinetype Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorLinetype
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorLinetype
public class ImGearVectorLinetype : ImGearVectorObject
public __gc class ImGearVectorLinetype : public ImGearVectorObject
public ref class ImGearVectorLinetype : public ImGearVectorObject
Remarks
A line can be drawn as solid or with pattern such as dotted or dashed. Pattern is defined by bit mask and pattern length.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorLinetype

See Also

Reference

ImGearVectorLinetype Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorLinetype Class Members
Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLinetype Class

The following tables list the members exposed by ImGearVectorLinetype.

Public Properties
 | Name | Description
Public Property | Pattern | Gets line type pattern.
Public Property | Patternlen | Gets absolute length of the pattern.
Top
See Also

Reference

ImGearVectorLinetype Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorLinetype Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorLinetype Class

For a list of all members of this type, see ImGearVectorLinetype members.

Public Properties
 | Name | Description
Public Property | Pattern | Gets line type pattern.
Public Property | Patternlen | Gets absolute length of the pattern.
Top
See Also

Reference

ImGearVectorLinetype Class
ImageGear.Vector Namespace


Pattern Property (ImGearVectorLinetype)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLinetype Class : Pattern Property
Gets line type pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As Integer
'Usage

Dim instance As ImGearVectorLinetype
Dim value As Integer

value = instance.Pattern
public int Pattern {get;}
public: __property int get_Pattern();
public:
property int Pattern {
   int get();
}

Property Value

Any integer number.
Remarks
The pattern is a 32-bit mask. A line segment is drawn if the corresponding bit is 1. The bit mask 0xFFFFFFFF corresponds to a solid line.
See Also

Reference

ImGearVectorLinetype Class
ImGearVectorLinetype Members


Patternlen Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorLinetype Class : Patternlen Property
Gets absolute length of the pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Patternlen As Single
'Usage

Dim instance As ImGearVectorLinetype
Dim value As Single

value = instance.Patternlen
public float Patternlen {get;}
public: __property float get_Patternlen();
public:
property float Patternlen {
   float get();
}

Property Value

Any positive value.
Remarks
The pattern is stretched according to this value and repeated periodically when drawing the line.
See Also

Reference

ImGearVectorLinetype Class
ImGearVectorLinetype Members


%%PageItemTitle%%

ImGearVectorObject Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorObject Class
Base class for all vector objects. It implements one read/only property Handle property that returns an internal handle of the object.
Object Model
ImGearVectorObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorObject
'Usage

Dim instance As ImGearVectorObject
public class ImGearVectorObject
public __gc class ImGearVectorObject
public ref class ImGearVectorObject
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorEntity
ImageGear.Vector.ImGearVectorEntityCont
ImageGear.Vector.ImGearVectorFilltype
ImageGear.Vector.ImGearVectorFloatCont
ImageGear.Vector.ImGearVectorFont
ImageGear.Vector.ImGearVectorGradient
ImageGear.Vector.ImGearVectorHatch
ImageGear.Vector.ImGearVectorHatchline
ImageGear.Vector.ImGearVectorLayer
ImageGear.Vector.ImGearVectorLightSource
ImageGear.Vector.ImGearVectorLinetype
ImageGear.Vector.ImGearVectorRotation
ImageGear.Vector.ImGearVectorTextObject
ImageGear.Vector.ImGearVectorVertexCont
ImageGear.Vector.ImGearVectorView

See Also

Reference

ImGearVectorObject Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorObject Class Members
Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorObject Class

The following tables list the members exposed by ImGearVectorObject.

Public Constructors
 | Name | Description
Public Constructor | ImGearVectorObject Constructor | Initializes a new instance of the ImGearVectorObject class.
Top
Public Properties
 | Name | Description
Public Property | Handle | Gets an internal handle of the object. This handle can be used as an unique identifier of the vector object.
Top
See Also

Reference

ImGearVectorObject Class
ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectorObject Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorObject Class : ImGearVectorObject Constructor
Initializes a new instance of the ImGearVectorObject class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearVectorObject()
public ImGearVectorObject()
public: ImGearVectorObject();
public:
ImGearVectorObject();
See Also

Reference

ImGearVectorObject Class
ImGearVectorObject Members


%%PageItemTitle%% $$Properties$$

ImGearVectorObject Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorObject Class

For a list of all members of this type, see ImGearVectorObject members.

Public Properties
 | Name | Description
Public Property | Handle | Gets an internal handle of the object. This handle can be used as an unique identifier of the vector object.
Top
See Also

Reference

ImGearVectorObject Class
ImageGear.Vector Namespace


Handle Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorObject Class : Handle Property
Gets an internal handle of the object. This handle can be used as an unique identifier of the vector object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Handle As IntPtr
'Usage

Dim instance As ImGearVectorObject
Dim value As IntPtr

value = instance.Handle
public IntPtr Handle {get;}
public: __property IntPtr get_Handle();
public:
property IntPtr Handle {
   IntPtr get();
}

Property Value

IntPtr handle.
See Also

Reference

ImGearVectorObject Class
ImGearVectorObject Members


%%PageItemTitle%%

ImGearVectorRotation Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorRotation Class
Provides rotation operations for the ImGearVectorEntityViewport object.
Object Model
ImGearVectorRotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorRotation
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorRotation
public class ImGearVectorRotation : ImGearVectorObject
public __gc class ImGearVectorRotation : public ImGearVectorObject
public ref class ImGearVectorRotation : public ImGearVectorObject
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorRotation

See Also

Reference

ImGearVectorRotation Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorRotation Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorRotation Class

The following tables list the members exposed by ImGearVectorRotation.

Public Methods
 | Name | Description
Public Method | AddMatrix | Adds a 3x3 matrix to the rotation.
Public Method | GetMatrix | Returns a copy of the 3x3 rotation matrix.
Public Method | Rotate | Performs a counterclockwise rotation of angle radians around the vector from the origin through the (x, y, z) point.
Public Method | SetMatrix | Replaces the rotation matrix.
Top
See Also

Reference

ImGearVectorRotation Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Properties$$

ImGearVectorRotation Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorRotation Class

For a list of all members of this type, see ImGearVectorRotation members.

See Also

Reference

ImGearVectorRotation Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorRotation Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorRotation Class

For a list of all members of this type, see ImGearVectorRotation members.

Public Methods
 | Name | Description
Public Method | AddMatrix | Adds a 3x3 matrix to the rotation.
Public Method | GetMatrix | Returns a copy of the 3x3 rotation matrix.
Public Method | Rotate | Performs a counterclockwise rotation of angle radians around the vector from the origin through the (x, y, z) point.
Public Method | SetMatrix | Replaces the rotation matrix.
Top
See Also

Reference

ImGearVectorRotation Class
ImageGear.Vector Namespace


AddMatrix Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorRotation Class : AddMatrix Method
3x3 matrix being added.
Adds a 3x3 matrix to the rotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddMatrix( _
   ByVal matrix() As Single _
)
'Usage

Dim instance As ImGearVectorRotation
Dim matrix() As Single

instance.AddMatrix(matrix)
public void AddMatrix(
   float[] matrix
)
public: void AddMatrix(
   float[]* matrix
)
public:
void AddMatrix(
   array<float>^ matrix
)

Parameters

matrix
3x3 matrix being added.
See Also

Reference

ImGearVectorRotation Class
ImGearVectorRotation Members


GetMatrix Method (ImGearVectorRotation)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorRotation Class : GetMatrix Method
Returns a copy of the 3x3 rotation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatrix() As Single()
'Usage

Dim instance As ImGearVectorRotation
Dim value() As Single

value = instance.GetMatrix()
public float[] GetMatrix()
public: float[]* GetMatrix();
public:
array<float>^ GetMatrix();

Return Value

A float[] copy of the 3x3 rotation matrix.
See Also

Reference

ImGearVectorRotation Class
ImGearVectorRotation Members


Rotate Method (ImGearVectorRotation)
Example

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorRotation Class : Rotate Method
Rotation angle in radians.
X-coordinate of the rotation vector.
Y-coordinate of the rotation vector.
Z-coordinate of the rotation vector.
Performs a counterclockwise rotation of angle radians around the vector from the origin through the (x, y, z) point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Single, _
   ByVal vectorX As Single, _
   ByVal vectorY As Single, _
   ByVal vectorZ As Single _
)
'Usage

Dim instance As ImGearVectorRotation
Dim angle As Single
Dim vectorX As Single
Dim vectorY As Single
Dim vectorZ As Single

instance.Rotate(angle, vectorX, vectorY, vectorZ)
public void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ
)
public: void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ
)
public:
void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ
)

Parameters

angle
Rotation angle in radians.
vectorX
X-coordinate of the rotation vector.
vectorY
Y-coordinate of the rotation vector.
vectorZ
Z-coordinate of the rotation vector.
Example
  • C#
viewport.GetViewportRotation().Rotate((float)(Math.PI / 4), 0, 0, 1);
  • Visual Basic
viewport.GetViewportRotation().Rotate(Math.PI / 4, 0, 0, 1)
See Also

Reference

ImGearVectorRotation Class
ImGearVectorRotation Members


SetMatrix Method (ImGearVectorRotation)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorRotation Class : SetMatrix Method
3x3 rotation matrix being set.
Replaces the rotation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatrix( _
   ByVal matrix() As Single _
)
'Usage

Dim instance As ImGearVectorRotation
Dim matrix() As Single

instance.SetMatrix(matrix)
public void SetMatrix(
   float[] matrix
)
public: void SetMatrix(
   float[]* matrix
)
public:
void SetMatrix(
   array<float>^ matrix
)

Parameters

matrix
3x3 rotation matrix being set.
See Also

Reference

ImGearVectorRotation Class
ImGearVectorRotation Members


%%PageItemTitle%%

ImGearVectorTextObject Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorTextObject Class
Contains a part of a text string that uses particular set of font attributes.
Object Model
ImGearVectorTextObject ClassImGearVectorFont ClassImGearVectorColorEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorTextObject
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorTextObject
public class ImGearVectorTextObject : ImGearVectorObject
public __gc class ImGearVectorTextObject : public ImGearVectorObject
public ref class ImGearVectorTextObject : public ImGearVectorObject
Remarks
This object is used by ImGearVectorEntityText class entity to keep parts of the text string with the same font attributes such as font width, height, char base angle, color and so on.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorTextObject

See Also

Reference

ImGearVectorTextObject Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorTextObject Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorTextObject Class

The following tables list the members exposed by ImGearVectorTextObject.

Public Properties
 | Name | Description
Public Property | CharBase | Gets or sets a char base angle of the text characters.
Public Property | CharSpacing | Gets or sets a char spacing of the text object. Normal char spacing is 1.
Public Property | CharUp | Gets or sets a char up angle of the text characters.
Public Property | Flags | Gets or sets a flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.
Public Property | Font | Gets or sets a font handle assigned to the text object.
Public Property | FontHeight | Gets or sets a font height of the text object.
Public Property | FontWidth | Gets or sets a font width of the text object.
Public Property | Text | Gets or sets a text string assigned to the text object.
Top
Public Methods
 | Name | Description
Public Method | CopySettingsFrom | Copies all settings from one text object to another except text string.
Public Method | GetTextColor | Returns the color of the text object.
Public Method | GetTextWidth | Calculates the actual width of a text string, taking into account the current Text Object settings.
Public Method | SetTextColor | Sets a color for the text object.
Top
See Also

Reference

ImGearVectorTextObject Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorTextObject Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorTextObject Class

For a list of all members of this type, see ImGearVectorTextObject members.

Public Methods
 | Name | Description
Public Method | CopySettingsFrom | Copies all settings from one text object to another except text string.
Public Method | GetTextColor | Returns the color of the text object.
Public Method | GetTextWidth | Calculates the actual width of a text string, taking into account the current Text Object settings.
Public Method | SetTextColor | Sets a color for the text object.
Top
See Also

Reference

ImGearVectorTextObject Class
ImageGear.Vector Namespace


CopySettingsFrom Method (ImGearVectorTextObject)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : CopySettingsFrom Method
Source text object.
Copies all settings from one text object to another except text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopySettingsFrom( _
   ByVal textObject As ImGearVectorTextObject _
)
'Usage

Dim instance As ImGearVectorTextObject
Dim textObject As ImGearVectorTextObject

instance.CopySettingsFrom(textObject)
public void CopySettingsFrom(
   ImGearVectorTextObject textObject
)
public: void CopySettingsFrom(
   ImGearVectorTextObject* textObject
)
public:
void CopySettingsFrom(
   ImGearVectorTextObject^ textObject
)

Parameters

textObject
Source text object.
Remarks
This can be helpful when creating a new text object with almost the same settings as an existing one.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members
ImGearVectorTextObject Class


GetTextColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : GetTextColor Method
Returns the color of the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTextColor() As ImGearVectorColorEx
'Usage

Dim instance As ImGearVectorTextObject
Dim value As ImGearVectorColorEx

value = instance.GetTextColor()
public ImGearVectorColorEx GetTextColor()
public: ImGearVectorColorEx GetTextColor();
public:
ImGearVectorColorEx GetTextColor();

Return Value

ImGearVectorColorEx structure object.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


GetTextWidth Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : GetTextWidth Method
Text string whose actual width is to be calculated. If this parameter is null, the width is calculated for the text assigned to the text object.
Calculates the actual width of a text string, taking into account the current Text Object settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTextWidth( _
   ByVal text As String _
) As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim text As String
Dim value As Single

value = instance.GetTextWidth(text)
public float GetTextWidth(
   string text
)
public: float GetTextWidth(
   string* text
)
public:
float GetTextWidth(
   String^ text
)

Parameters

text
Text string whose actual width is to be calculated. If this parameter is null, the width is calculated for the text assigned to the text object.

Return Value

Any positive value.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


SetTextColor Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : SetTextColor Method
Text object color being set.
Sets a color for the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTextColor( _
   ByVal value As ImGearVectorColorEx _
)
'Usage

Dim instance As ImGearVectorTextObject
Dim value As ImGearVectorColorEx

instance.SetTextColor(value)
public void SetTextColor(
   ImGearVectorColorEx value
)
public: void SetTextColor(
   ImGearVectorColorEx value
)
public:
void SetTextColor(
   ImGearVectorColorEx value
)

Parameters

value
Text object color being set.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members
ImGearVectorColorEx Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorTextObject Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorTextObject Class

For a list of all members of this type, see ImGearVectorTextObject members.

Public Properties
 | Name | Description
Public Property | CharBase | Gets or sets a char base angle of the text characters.
Public Property | CharSpacing | Gets or sets a char spacing of the text object. Normal char spacing is 1.
Public Property | CharUp | Gets or sets a char up angle of the text characters.
Public Property | Flags | Gets or sets a flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.
Public Property | Font | Gets or sets a font handle assigned to the text object.
Public Property | FontHeight | Gets or sets a font height of the text object.
Public Property | FontWidth | Gets or sets a font width of the text object.
Public Property | Text | Gets or sets a text string assigned to the text object.
Top
See Also

Reference

ImGearVectorTextObject Class
ImageGear.Vector Namespace


CharBase Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : CharBase Property
Gets or sets a char base angle of the text characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharBase As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Single

instance.CharBase = value

value = instance.CharBase
public float CharBase {get; set;}
public: __property float get_CharBase();
public: __property void set_CharBase(
   float value
);
public:
property float CharBase {
   float get();
   void set (    float value);
}

Property Value

Any value in the range of -2*PI...2*PI.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


CharSpacing Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : CharSpacing Property
Gets or sets a char spacing of the text object. Normal char spacing is 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharSpacing As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Single

instance.CharSpacing = value

value = instance.CharSpacing
public float CharSpacing {get; set;}
public: __property float get_CharSpacing();
public: __property void set_CharSpacing(
   float value
);
public:
property float CharSpacing {
   float get();
   void set (    float value);
}

Property Value

Any value.
Remarks
The default value is 1.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


CharUp Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : CharUp Property
Gets or sets a char up angle of the text characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharUp As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Single

instance.CharUp = value

value = instance.CharUp
public float CharUp {get; set;}
public: __property float get_CharUp();
public: __property void set_CharUp(
   float value
);
public:
property float CharUp {
   float get();
   void set (    float value);
}

Property Value

Any value in the range of -2*PI... 2*PI.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


Flags Property (ImGearVectorTextObject)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : Flags Property
Gets or sets a flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As Integer
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Integer

instance.Flags = value

value = instance.Flags
public int Flags {get; set;}
public: __property int get_Flags();
public: __property void set_Flags(
   int value
);
public:
property int Flags {
   int get();
   void set (    int value);
}

Property Value

Or combination of ImGearVectTxtFlags enumeration values or 0.
Remarks
The default value is 0.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


Font Property (ImGearVectorTextObject)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : Font Property
Gets or sets a font handle assigned to the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As ImGearVectorFont
'Usage

Dim instance As ImGearVectorTextObject
Dim value As ImGearVectorFont

instance.Font = value

value = instance.Font
public ImGearVectorFont Font {get; set;}
public: __property ImGearVectorFont* get_Font();
public: __property void set_Font(
   ImGearVectorFont* value
);
public:
property ImGearVectorFont^ Font {
   ImGearVectorFont^ get();
   void set (    ImGearVectorFont^ value);
}

Property Value

ImGearVectorFont class object.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


FontHeight Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : FontHeight Property
Gets or sets a font height of the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontHeight As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Single

instance.FontHeight = value

value = instance.FontHeight
public float FontHeight {get; set;}
public: __property float get_FontHeight();
public: __property void set_FontHeight(
   float value
);
public:
property float FontHeight {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


FontWidth Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : FontWidth Property
Gets or sets a font width of the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontWidth As Single
'Usage

Dim instance As ImGearVectorTextObject
Dim value As Single

instance.FontWidth = value

value = instance.FontWidth
public float FontWidth {get; set;}
public: __property float get_FontWidth();
public: __property void set_FontWidth(
   float value
);
public:
property float FontWidth {
   float get();
   void set (    float value);
}

Property Value

Any positive value.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


Text Property (ImGearVectorTextObject)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorTextObject Class : Text Property
Gets or sets a text string assigned to the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearVectorTextObject
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

Any text string.
See Also

Reference

ImGearVectorTextObject Class
ImGearVectorTextObject Members


%%PageItemTitle%%

ImGearVectorVertexCont Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertexCont Class
Represents a vertex container.
Object Model
ImGearVectorVertexCont ClassImGearVectorVertex Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorVertexCont
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorVertexCont
public class ImGearVectorVertexCont : ImGearVectorObject
public __gc class ImGearVectorVertexCont : public ImGearVectorObject
public ref class ImGearVectorVertexCont : public ImGearVectorObject
Remarks
Vertex container is used by polylines, spline curves and surfaces. A vertex contains point coordinates and a visibility flag. It also can have attributes such as bulge and weight (for splines). Vertex container owns the vertices, so, the application should not destroy them explicitly.
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorVertexCont

See Also

Reference

ImGearVectorVertexCont Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorVertexCont Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertexCont Class

The following tables list the members exposed by ImGearVectorVertexCont.

Public Properties
 | Name | Description
Public Property | Count | Gets total count of vertices in the vertex container.
Top
Public Methods
 | Name | Description
Public Method | Clear | Removes all vertices from the container and destroys them.
Public Method | CreateVertex | Creates a vertex and adds it at the end of the container.
Public Method | GetAttribType | Returns the type of vertex attribute if present.
Public Method | GetAttribValue | Returns the value of vertex attribute if present.
Public Method | GetHidden | Returns a flag showing whether the vertex is hidden or not.
Public Method | GetVertex | Returns the vertex object at the specified position.
Public Method | Init | Sets initial size of the vertex container. This is convenient when vertex count is known in advance.
Public Method | SetAttrib | Sets an attribute (value and type) for the vertex. The vertex can have only one attribute, so, previous attribute is not preserved.
Public Method | SetHidden | Sets the Hidden flag for the vertex.
Public Method | SetVertex | Sets the value for the vertex specified by index.
Top
See Also

Reference

ImGearVectorVertexCont Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorVertexCont Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertexCont Class

For a list of all members of this type, see ImGearVectorVertexCont members.

Public Methods
 | Name | Description
Public Method | Clear | Removes all vertices from the container and destroys them.
Public Method | CreateVertex | Creates a vertex and adds it at the end of the container.
Public Method | GetAttribType | Returns the type of vertex attribute if present.
Public Method | GetAttribValue | Returns the value of vertex attribute if present.
Public Method | GetHidden | Returns a flag showing whether the vertex is hidden or not.
Public Method | GetVertex | Returns the vertex object at the specified position.
Public Method | Init | Sets initial size of the vertex container. This is convenient when vertex count is known in advance.
Public Method | SetAttrib | Sets an attribute (value and type) for the vertex. The vertex can have only one attribute, so, previous attribute is not preserved.
Public Method | SetHidden | Sets the Hidden flag for the vertex.
Public Method | SetVertex | Sets the value for the vertex specified by index.
Top
See Also

Reference

ImGearVectorVertexCont Class
ImageGear.Vector Namespace


Clear Method (ImGearVectorVertexCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : Clear Method
Removes all vertices from the container and destroys them.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearVectorVertexCont

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


CreateVertex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : CreateVertex Method
Creates a vertex and adds it at the end of the container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateVertex() As Integer
'Usage

Dim instance As ImGearVectorVertexCont
Dim value As Integer

value = instance.CreateVertex()
public int CreateVertex()
public: int CreateVertex();
public:
int CreateVertex();

Return Value

Index of the newly created vertex.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


GetAttribType Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : GetAttribType Method
Vertex position in the container.
Returns the type of vertex attribute if present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttribType( _
   ByVal index As Integer _
) As ImGearVectVertexData
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim value As ImGearVectVertexData

value = instance.GetAttribType(index)
public ImGearVectVertexData GetAttribType(
   int index
)
public: ImGearVectVertexData GetAttribType(
   int index
)
public:
ImGearVectVertexData GetAttribType(
   int index
)

Parameters

index
Vertex position in the container.

Return Value

The ImGearVectVertexData enumeration constant specifying a type of the vertex attribute.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


GetAttribValue Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : GetAttribValue Method
Vertex position in the container.
Returns the value of vertex attribute if present.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAttribValue( _
   ByVal index As Integer _
) As Single
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim value As Single

value = instance.GetAttribValue(index)
public float GetAttribValue(
   int index
)
public: float GetAttribValue(
   int index
)
public:
float GetAttribValue(
   int index
)

Parameters

index
Vertex position in the container.

Return Value

The floating point value of the attribute (if any).
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


GetHidden Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : GetHidden Method
Vertex position in the container.
Returns a flag showing whether the vertex is hidden or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetHidden( _
   ByVal index As Integer _
) As Boolean
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim value As Boolean

value = instance.GetHidden(index)
public bool GetHidden(
   int index
)
public: bool GetHidden(
   int index
)
public:
bool GetHidden(
   int index
)

Parameters

index
Vertex position in the container.

Return Value

true if vertex is hidden, false - otherwise.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


GetVertex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : GetVertex Method
Index of the vertex to be returned.
Returns the vertex object at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetVertex( _
   ByVal index As Integer _
) As ImGearVectorVertex
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim value As ImGearVectorVertex

value = instance.GetVertex(index)
public ImGearVectorVertex GetVertex(
   int index
)
public: ImGearVectorVertex GetVertex(
   int index
)
public:
ImGearVectorVertex GetVertex(
   int index
)

Parameters

index
Index of the vertex to be returned.

Return Value

New instance of ImGearVectorVertex structure object.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


Init Method (ImGearVectorVertexCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : Init Method
Initial size of the vertex container.
Sets initial size of the vertex container. This is convenient when vertex count is known in advance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Init( _
   ByVal vertexCount As Integer _
)
'Usage

Dim instance As ImGearVectorVertexCont
Dim vertexCount As Integer

instance.Init(vertexCount)
public void Init(
   int vertexCount
)
public: void Init(
   int vertexCount
)
public:
void Init(
   int vertexCount
)

Parameters

vertexCount
Initial size of the vertex container.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


SetAttrib Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : SetAttrib Method
Position of the vertex in container.
The type of vertex attribute.
The value of the vertex attribute.
Sets an attribute (value and type) for the vertex. The vertex can have only one attribute, so, previous attribute is not preserved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAttrib( _
   ByVal index As Integer, _
   ByVal attributeType As ImGearVectVertexData, _
   ByVal attributeValue As Single _
)
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim attributeType As ImGearVectVertexData
Dim attributeValue As Single

instance.SetAttrib(index, attributeType, attributeValue)
public void SetAttrib(
   int index,
   ImGearVectVertexData attributeType,
   float attributeValue
)
public: void SetAttrib(
   int index,
   ImGearVectVertexData attributeType,
   float attributeValue
)
public:
void SetAttrib(
   int index,
   ImGearVectVertexData attributeType,
   float attributeValue
)

Parameters

index
Position of the vertex in container.
attributeType
The type of vertex attribute.
attributeValue
The value of the vertex attribute.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members
ImGearVectVertexData Enumeration


SetHidden Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : SetHidden Method
Position of the vertex in the container.
Hidden flag being set. true means that outgoing line is hidden. The vertex is not hidden by default.
Sets the Hidden flag for the vertex.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetHidden( _
   ByVal index As Integer, _
   ByVal hidden As Boolean _
)
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim hidden As Boolean

instance.SetHidden(index, hidden)
public void SetHidden(
   int index,
   bool hidden
)
public: void SetHidden(
   int index,
   bool hidden
)
public:
void SetHidden(
   int index,
   bool hidden
)

Parameters

index
Position of the vertex in the container.
hidden
Hidden flag being set. true means that outgoing line is hidden. The vertex is not hidden by default.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


SetVertex Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : SetVertex Method
Position of the vertex in the container.
Vertex value to be set.
Sets the value for the vertex specified by index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVertex( _
   ByVal index As Integer, _
   ByVal vertexValue As ImGearVectorVertex _
)
'Usage

Dim instance As ImGearVectorVertexCont
Dim index As Integer
Dim vertexValue As ImGearVectorVertex

instance.SetVertex(index, vertexValue)
public void SetVertex(
   int index,
   ImGearVectorVertex vertexValue
)
public: void SetVertex(
   int index,
   ImGearVectorVertex vertexValue
)
public:
void SetVertex(
   int index,
   ImGearVectorVertex vertexValue
)

Parameters

index
Position of the vertex in the container.
vertexValue
Vertex value to be set.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members
ImGearVectorVertex Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorVertexCont Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertexCont Class

For a list of all members of this type, see ImGearVectorVertexCont members.

Public Properties
 | Name | Description
Public Property | Count | Gets total count of vertices in the vertex container.
Top
See Also

Reference

ImGearVectorVertexCont Class
ImageGear.Vector Namespace


Count Property (ImGearVectorVertexCont)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertexCont Class : Count Property
Gets total count of vertices in the vertex container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearVectorVertexCont
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Non-negative integer value.
See Also

Reference

ImGearVectorVertexCont Class
ImGearVectorVertexCont Members


%%PageItemTitle%%

ImGearVectorView Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorView Class
Represents a camera and lighting model for displaying the vector content.
Object Model
ImGearVectorView ClassImGearVectorEntity ClassImGearVectorColor StructureImGearVectorLightSource ClassImGearVectorPoint3D StructureImGearVectorMinMax Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVectorView
   Inherits ImGearVectorObject
'Usage

Dim instance As ImGearVectorView
public class ImGearVectorView : ImGearVectorObject
public __gc class ImGearVectorView : public ImGearVectorObject
public ref class ImGearVectorView : public ImGearVectorObject
Inheritance Hierarchy

System.Object
ImageGear.Vector.ImGearVectorObject
ImageGear.Vector.ImGearVectorView

See Also

Reference

ImGearVectorView Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorView Class Members
Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorView Class

The following tables list the members exposed by ImGearVectorView.

Public Properties
 | Name | Description
Public Property | AmbientColor | Gets or sets ambient color of the view.
Public Property | Content | Gets or sets a view content. The content is usually a block, but can be any entity.
Public Property | CullFace | Gets or sets face culling mode for the view.
Public Property | DisplayHiddenLayers | Gets or sets a value indicating whether to display the layers that are marked as hidden.
Public Property | Focus | Gets or sets a lens focus of the view.
Public Property | LightingEnabled | Gets or sets a value indicating whether lighting is enabled.
Public Property | MaxLights | Gets total number of available light sources.
Top
Public Methods
 | Name | Description
Public Method | Adjust | Adjusts the view bounding box to match the bounding box of the vector data.
Public Method | GetBkGnd | Returns the current background color of the view.
Public Method | GetLightSource | Returns the light source with the specified index.
Public Method | GetLookPoint | Returns the point in 3D space that the view's camera is looking at. See corresponding method SetLookPoint for more information.
Public Method | GetMatrix | Returns the current transformation matrix of the view.
Public Method | GetMinMax | Returns the bounding parallelepiped of the view.
Public Method | GetName | Returns the name of the view.
Public Method | Move | Moves the camera according to the specified offsets.
Public Method | Rotate | Rotates the camera on the specified angle about the specified vector.
Public Method | Scale | Scales the camera according to the specified scale factors.
Public Method | SetBkGnd | Sets the current background color of the view.
Public Method | SetLookPoint | Sets the point in 3D space that the view's camera is looking at.
Public Method | SetMatrix | Sets the current transformation matrix of the view.
Public Method | SetMinMax | Sets the bounding parallelepiped of the view.
Public Method | SetName | Sets the new name for the view.
Public Method | ToScreen | Converts 3D world coordinates to screen coordinates for the current view.
Top
See Also

Reference

ImGearVectorView Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Methods$$

ImGearVectorView Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorView Class

For a list of all members of this type, see ImGearVectorView members.

Public Methods
 | Name | Description
Public Method | Adjust | Adjusts the view bounding box to match the bounding box of the vector data.
Public Method | GetBkGnd | Returns the current background color of the view.
Public Method | GetLightSource | Returns the light source with the specified index.
Public Method | GetLookPoint | Returns the point in 3D space that the view's camera is looking at. See corresponding method SetLookPoint for more information.
Public Method | GetMatrix | Returns the current transformation matrix of the view.
Public Method | GetMinMax | Returns the bounding parallelepiped of the view.
Public Method | GetName | Returns the name of the view.
Public Method | Move | Moves the camera according to the specified offsets.
Public Method | Rotate | Rotates the camera on the specified angle about the specified vector.
Public Method | Scale | Scales the camera according to the specified scale factors.
Public Method | SetBkGnd | Sets the current background color of the view.
Public Method | SetLookPoint | Sets the point in 3D space that the view's camera is looking at.
Public Method | SetMatrix | Sets the current transformation matrix of the view.
Public Method | SetMinMax | Sets the bounding parallelepiped of the view.
Public Method | SetName | Sets the new name for the view.
Public Method | ToScreen | Converts 3D world coordinates to screen coordinates for the current view.
Top
See Also

Reference

ImGearVectorView Class
ImageGear.Vector Namespace


Adjust Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Adjust Method
Adjusts the view bounding box to match the bounding box of the vector data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Adjust()
'Usage

Dim instance As ImGearVectorView

instance.Adjust()
public void Adjust()
public: void Adjust();
public:
void Adjust();
Remarks
Calling this method prior to rasterization is an easy way to ensure that all of the vector data will be included in the rasterized area after the view or vector data has undergone transformations.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
Rasterize Method


GetBkGnd Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetBkGnd Method
Returns the current background color of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetBkGnd() As ImGearVectorColor
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectorColor

value = instance.GetBkGnd()
public ImGearVectorColor GetBkGnd()
public: ImGearVectorColor GetBkGnd();
public:
ImGearVectorColor GetBkGnd();

Return Value

Current background color of the view.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorColor Structure


GetLightSource Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetLightSource Method
An index of the light source. Must be in the range of (0..MaxLights - 1).
Returns the light source with the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLightSource( _
   ByVal index As Integer _
) As ImGearVectorLightSource
'Usage

Dim instance As ImGearVectorView
Dim index As Integer
Dim value As ImGearVectorLightSource

value = instance.GetLightSource(index)
public ImGearVectorLightSource GetLightSource(
   int index
)
public: ImGearVectorLightSource* GetLightSource(
   int index
)
public:
ImGearVectorLightSource^ GetLightSource(
   int index
)

Parameters

index
An index of the light source. Must be in the range of (0..MaxLights - 1).

Return Value

ImGearVectorLightSource class object.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


GetLookPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetLookPoint Method
Returns the point in 3D space that the view's camera is looking at. See corresponding method SetLookPoint for more information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLookPoint() As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectorPoint3D

value = instance.GetLookPoint()
public ImGearVectorPoint3D GetLookPoint()
public: ImGearVectorPoint3D GetLookPoint();
public:
ImGearVectorPoint3D GetLookPoint();

Return Value

ImGearVectorPoint3D structure object.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorPoint3D Structure


GetMatrix Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetMatrix Method
Returns the current transformation matrix of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMatrix() As Single()
'Usage

Dim instance As ImGearVectorView
Dim value() As Single

value = instance.GetMatrix()
public float[] GetMatrix()
public: float[]* GetMatrix();
public:
array<float>^ GetMatrix();

Return Value

Array of 16 floating-point values.
Remarks
The matrix consists of 16 floating-point values and is aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


GetMinMax Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetMinMax Method
Returns the bounding parallelepiped of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMinMax() As ImGearVectorMinMax
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectorMinMax

value = instance.GetMinMax()
public ImGearVectorMinMax GetMinMax()
public: ImGearVectorMinMax GetMinMax();
public:
ImGearVectorMinMax GetMinMax();

Return Value

Bounding parallelepiped of the view.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorMinMax Structure


GetName Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : GetName Method
Returns the name of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetName() As String
'Usage

Dim instance As ImGearVectorView
Dim value As String

value = instance.GetName()
public string GetName()
public: string* GetName();
public:
String^ GetName();

Return Value

String with the view name.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


Move Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Move Method
Moving distance in X direction.
Moving distance in Y direction.
Moving distance in Z direction.
Moves the camera according to the specified offsets.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Move( _
   ByVal offsetX As Single, _
   ByVal offsetY As Single, _
   ByVal offsetZ As Single _
)
'Usage

Dim instance As ImGearVectorView
Dim offsetX As Single
Dim offsetY As Single
Dim offsetZ As Single

instance.Move(offsetX, offsetY, offsetZ)
public void Move(
   float offsetX,
   float offsetY,
   float offsetZ
)
public: void Move(
   float offsetX,
   float offsetY,
   float offsetZ
)
public:
void Move(
   float offsetX,
   float offsetY,
   float offsetZ
)

Parameters

offsetX
Moving distance in X direction.
offsetY
Moving distance in Y direction.
offsetZ
Moving distance in Z direction.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


Rotate Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Rotate Method
Rotation angle in radians.
X coordinate of the rotation vector.
Y coordinate of the rotation vector.
Z coordinate of the rotation vector.
The value indicating whether to perform a rotation about a look point.
Rotates the camera on the specified angle about the specified vector.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Single, _
   ByVal vectorX As Single, _
   ByVal vectorY As Single, _
   ByVal vectorZ As Single, _
   ByVal rotateAboutLookPoint As Boolean _
)
'Usage

Dim instance As ImGearVectorView
Dim angle As Single
Dim vectorX As Single
Dim vectorY As Single
Dim vectorZ As Single
Dim rotateAboutLookPoint As Boolean

instance.Rotate(angle, vectorX, vectorY, vectorZ, rotateAboutLookPoint)
public void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool rotateAboutLookPoint
)
public: void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool rotateAboutLookPoint
)
public:
void Rotate(
   float angle,
   float vectorX,
   float vectorY,
   float vectorZ,
   bool rotateAboutLookPoint
)

Parameters

angle
Rotation angle in radians.
vectorX
X coordinate of the rotation vector.
vectorY
Y coordinate of the rotation vector.
vectorZ
Z coordinate of the rotation vector.
rotateAboutLookPoint
The value indicating whether to perform a rotation about a look point.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


Scale Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Scale Method
X scale factor.
Y scale factor.
Z scale factor.
Scales the camera according to the specified scale factors.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal scaleX As Single, _
   ByVal scaleY As Single, _
   ByVal scaleZ As Single _
)
'Usage

Dim instance As ImGearVectorView
Dim scaleX As Single
Dim scaleY As Single
Dim scaleZ As Single

instance.Scale(scaleX, scaleY, scaleZ)
public void Scale(
   float scaleX,
   float scaleY,
   float scaleZ
)
public: void Scale(
   float scaleX,
   float scaleY,
   float scaleZ
)
public:
void Scale(
   float scaleX,
   float scaleY,
   float scaleZ
)

Parameters

scaleX
X scale factor.
scaleY
Y scale factor.
scaleZ
Z scale factor.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


SetBkGnd Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : SetBkGnd Method
New background color for the View.
Sets the current background color of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetBkGnd( _
   ByVal backgroundColor As ImGearVectorColor _
)
'Usage

Dim instance As ImGearVectorView
Dim backgroundColor As ImGearVectorColor

instance.SetBkGnd(backgroundColor)
public void SetBkGnd(
   ImGearVectorColor backgroundColor
)
public: void SetBkGnd(
   ImGearVectorColor backgroundColor
)
public:
void SetBkGnd(
   ImGearVectorColor backgroundColor
)

Parameters

backgroundColor
New background color for the View.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorColor Structure


SetLookPoint Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : SetLookPoint Method
The point in 3D space that the view's camera is looking at.
Sets the point in 3D space that the view's camera is looking at.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLookPoint( _
   ByVal value As ImGearVectorPoint3D _
)
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectorPoint3D

instance.SetLookPoint(value)
public void SetLookPoint(
   ImGearVectorPoint3D value
)
public: void SetLookPoint(
   ImGearVectorPoint3D value
)
public:
void SetLookPoint(
   ImGearVectorPoint3D value
)

Parameters

value
The point in 3D space that the view's camera is looking at.
Remarks
By setting a look point with this method, and using the Move method to position the camera, the position and orientation of the camera can easily be defined. Also, Rotate method can optionally take into account the look point.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorPoint3D Structure


SetMatrix Method (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : SetMatrix Method
New transformation matrix for the View.
Sets the current transformation matrix of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMatrix( _
   ByVal matrix() As Single _
)
'Usage

Dim instance As ImGearVectorView
Dim matrix() As Single

instance.SetMatrix(matrix)
public void SetMatrix(
   float[] matrix
)
public: void SetMatrix(
   float[]* matrix
)
public:
void SetMatrix(
   array<float>^ matrix
)

Parameters

matrix
New transformation matrix for the View.
Remarks
The matrix consists of 16 floating-point values and is aligned by columns, that is: a11 a21 a31 a41 a12 a22 a32 a42 a13 a23 a33 a43 a14 a24 a34 a44.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


SetMinMax Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : SetMinMax Method
New bounding parallelepiped for the View.
Sets the bounding parallelepiped of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetMinMax( _
   ByVal bounds As ImGearVectorMinMax _
)
'Usage

Dim instance As ImGearVectorView
Dim bounds As ImGearVectorMinMax

instance.SetMinMax(bounds)
public void SetMinMax(
   ImGearVectorMinMax bounds
)
public: void SetMinMax(
   ImGearVectorMinMax bounds
)
public:
void SetMinMax(
   ImGearVectorMinMax bounds
)

Parameters

bounds
New bounding parallelepiped for the View.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorMinMax Structure


SetName Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : SetName Method
New Name for the View.
Sets the new name for the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetName( _
   ByVal viewName As String _
)
'Usage

Dim instance As ImGearVectorView
Dim viewName As String

instance.SetName(viewName)
public void SetName(
   string viewName
)
public: void SetName(
   string* viewName
)
public:
void SetName(
   String^ viewName
)

Parameters

viewName
New Name for the View.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


ToScreen Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : ToScreen Method
World coordinates to be converted.
Converts 3D world coordinates to screen coordinates for the current view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToScreen( _
   ByVal worldCoordinates() As ImGearVectorPoint3D _
) As Point()
'Usage

Dim instance As ImGearVectorView
Dim worldCoordinates() As ImGearVectorPoint3D
Dim value() As Point

value = instance.ToScreen(worldCoordinates)
public Point[] ToScreen(
   ImGearVectorPoint3D[] worldCoordinates
)
public: Point[]* ToScreen(
   ImGearVectorPoint3D[]* worldCoordinates
)
public:
array<Point>^ ToScreen(
   array<ImGearVectorPoint3D>^ worldCoordinates
)

Parameters

worldCoordinates
World coordinates to be converted.

Return Value

An array of screen coordinates.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members
ImGearVectorPoint3D Structure


%%PageItemTitle%% $$Properties$$

ImGearVectorView Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorView Class

For a list of all members of this type, see ImGearVectorView members.

Public Properties
 | Name | Description
Public Property | AmbientColor | Gets or sets ambient color of the view.
Public Property | Content | Gets or sets a view content. The content is usually a block, but can be any entity.
Public Property | CullFace | Gets or sets face culling mode for the view.
Public Property | DisplayHiddenLayers | Gets or sets a value indicating whether to display the layers that are marked as hidden.
Public Property | Focus | Gets or sets a lens focus of the view.
Public Property | LightingEnabled | Gets or sets a value indicating whether lighting is enabled.
Public Property | MaxLights | Gets total number of available light sources.
Top
See Also

Reference

ImGearVectorView Class
ImageGear.Vector Namespace


AmbientColor Property (ImGearVectorView)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : AmbientColor Property
Gets or sets ambient color of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AmbientColor As Single()
'Usage

Dim instance As ImGearVectorView
Dim value() As Single

instance.AmbientColor = value

value = instance.AmbientColor
public float[] AmbientColor {get; set;}
public: __property float[]* get_AmbientColor();
public: __property void set_AmbientColor(
   float[]* value
);
public:
property array<float>^ AmbientColor {
   array<float>^ get();
   void set (    array<float>^ value);
}

Property Value

An array of four floating-point color components.
Remarks
The ambient color is presented by an array of four floating point values - red, green, blue and alpha. Usually the floating-point color component belongs to the range of 0...1, but can be greater than 1. Ambient color is taken into account only if LightingEnabled property is set to true..
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


Content Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Content Property
Gets or sets a view content. The content is usually a block, but can be any entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Content As ImGearVectorEntity
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectorEntity

instance.Content = value

value = instance.Content
public ImGearVectorEntity Content {get; set;}
public: __property ImGearVectorEntity* get_Content();
public: __property void set_Content(
   ImGearVectorEntity* value
);
public:
property ImGearVectorEntity^ Content {
   ImGearVectorEntity^ get();
   void set (    ImGearVectorEntity^ value);
}

Property Value

ImGearVectorEntity class.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


CullFace Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : CullFace Property
Gets or sets face culling mode for the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CullFace As ImGearVectCullFace
'Usage

Dim instance As ImGearVectorView
Dim value As ImGearVectCullFace

instance.CullFace = value

value = instance.CullFace
public ImGearVectCullFace CullFace {get; set;}
public: __property ImGearVectCullFace get_CullFace();
public: __property void set_CullFace(
   ImGearVectCullFace value
);
public:
property ImGearVectCullFace CullFace {
   ImGearVectCullFace get();
   void set (    ImGearVectCullFace value);
}

Property Value

ImGearVectCullFace enumeration.
Remarks
Face culling mode specifies whether to render both front- and back-facing facets, only front-facing or only back-facing ones. The default value is ImGearVectCullFace.NONE.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


DisplayHiddenLayers Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : DisplayHiddenLayers Property
Gets or sets a value indicating whether to display the layers that are marked as hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayHiddenLayers As Boolean
'Usage

Dim instance As ImGearVectorView
Dim value As Boolean

instance.DisplayHiddenLayers = value

value = instance.DisplayHiddenLayers
public bool DisplayHiddenLayers {get; set;}
public: __property bool get_DisplayHiddenLayers();
public: __property void set_DisplayHiddenLayers(
   bool value
);
public:
property bool DisplayHiddenLayers {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If the hidden layer is attached to the entity and this property is set to false, then the entity is not displayed. The default value is false.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


Focus Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : Focus Property
Gets or sets a lens focus of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Focus As Single
'Usage

Dim instance As ImGearVectorView
Dim value As Single

instance.Focus = value

value = instance.Focus
public float Focus {get; set;}
public: __property float get_Focus();
public: __property void set_Focus(
   float value
);
public:
property float Focus {
   float get();
   void set (    float value);
}

Property Value

Any non-negative floating point value.
Remarks
The default value is 0.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


LightingEnabled Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : LightingEnabled Property
Gets or sets a value indicating whether lighting is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LightingEnabled As Boolean
'Usage

Dim instance As ImGearVectorView
Dim value As Boolean

instance.LightingEnabled = value

value = instance.LightingEnabled
public bool LightingEnabled {get; set;}
public: __property bool get_LightingEnabled();
public: __property void set_LightingEnabled(
   bool value
);
public:
property bool LightingEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If lighting is enabled then view ambient color and light sources are taken into account when displaying the view content. The default value is false.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


MaxLights Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorView Class : MaxLights Property
Gets total number of available light sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MaxLights As Integer
'Usage

Dim instance As ImGearVectorView
Dim value As Integer

value = instance.MaxLights
public int MaxLights {get;}
public: __property int get_MaxLights();
public:
property int MaxLights {
   int get();
}

Property Value

The number of available light sources.
See Also

Reference

ImGearVectorView Class
ImGearVectorView Members


%%PageItemTitle%%

ImGearVectPage Class
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectPage Class
This object represents a vector page which has a background and an ImGearVectorData vector drawing.
Object Model
ImGearVectPage ClassImGearPage ClassImGearRasterPage ClassImGearVectorData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearVectPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearVectPage
public sealed class ImGearVectPage : ImageGear.Core.ImGearVectorPage
public __gc __sealed class ImGearVectPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearVectPage sealed : public ImageGear.Core.ImGearVectorPage
Remarks
Operations such as resize and rotate can be performed on this type of page the same way they are performed on the other types of pages such as ImGearRasterPage. You can also rasterize a vector page to obtain an ImGearRasterPage from the ImGearVectPage.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.Vector.ImGearVectPage

See Also

Reference

ImGearVectPage Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectPage Class Members
Fields Properties Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectPage Class

The following tables list the members exposed by ImGearVectPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearVectPage Constructor | Initializes a new instance of the ImGearVectPage class.
Top
Public Properties
 | Name | Description
Public Property | VectorData | Gets underlying vector data (drawing) for the page.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. This method clones the ImGearVectPage class object.
Public Method | Rasterize | Overloaded. Overridden. This method rasterizes (converts to pixels) the vector data.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearVectPage class.
Top
See Also

Reference

ImGearVectPage Class
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectPage Class Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectPage Class

For a list of all members of this type, see ImGearVectPage members.

See Also

Reference

ImGearVectPage Class
ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectPage Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : ImGearVectPage Constructor
The width of the page..
The height of the page.
The color space of the page.
The channel depth of the page.
Initializes a new instance of the ImGearVectPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal colorSpace As ImGearColorSpace, _
   ByVal channelDepths() As Integer _
)
'Usage

Dim width As Integer
Dim height As Integer
Dim colorSpace As ImGearColorSpace
Dim channelDepths() As Integer

Dim instance As New ImGearVectPage(width, height, colorSpace, channelDepths)
public ImGearVectPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[] channelDepths
)
public: ImGearVectPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[]* channelDepths
)
public:
ImGearVectPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   array<int>^ channelDepths
)

Parameters

width
The width of the page..
height
The height of the page.
colorSpace
The color space of the page.
channelDepths
The channel depth of the page.

Return Value

A new instance of the ImGearVectPage class.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members
ImGearColorSpace Structure


%%PageItemTitle%% $$Methods$$

ImGearVectPage Class Methods

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectPage Class

For a list of all members of this type, see ImGearVectPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. This method clones the ImGearVectPage class object.
Public Method | Rasterize | Overloaded. Overridden. This method rasterizes (converts to pixels) the vector data.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearVectPage class.
Top
See Also

Reference

ImGearVectPage Class
ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectPage Constructor

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : ImGearVectPage Constructor
Overload List
Overload | Description
ImGearVectPage Constructor | Initializes a new instance of the ImGearVectPage class.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members


Clone Method (ImGearVectPage)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : Clone Method
This method clones the ImGearVectPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overrides NotOverridable Function Clone() As ImGearPage
'Usage

Dim instance As ImGearVectPage
Dim value As ImGearPage

value = instance.Clone()
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public override ImGearPage Clone()
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: ImGearPage* Clone(); override
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
ImGearPage^ Clone(); override

Return Value

The clone of ImGearVectPage class object.
Remarks
This method returns a deep copy of the object, so the underlying vector data is duplicated.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members
ImGearPage Class
ImGearVectPage Class


Finalize Method (ImGearVectPage)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : Finalize Method
Finalizes an instance of the ImGearVectPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearVectPage

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members


Rasterize Method (ImGearVectPage)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : Rasterize Method
This method rasterizes (converts to pixels) the vector data.
Overload List
Overload | Description
Rasterize() | This method rasterizes (converts to pixels) the vector data.
Rasterize(Int32,Int32,Int32) | Rasterizes the page using provided bit depth and resolution parameters.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members


Rasterize() Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class > Rasterize Method : Rasterize() Method
This method rasterizes (converts to pixels) the vector data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Overrides NotOverridable Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearVectPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public override ImGearRasterPage Rasterize()
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: ImGearRasterPage* Rasterize(); override
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
ImGearRasterPage^ Rasterize(); override

Return Value

ImageGear.Core.ImGearRasterPage class with rasterized vector data.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members
Overload List


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
Rasterizes the page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert,
   Unrestricted=False)>
Public Overloads Overrides NotOverridable Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearVectPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
[PermissionSet(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Action=SecurityAction.Demand |
    SecurityAction.Assert,
   Unrestricted=false)]
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image, depending on actual vector file format, will have either Indexed color space with 8 bit per pixel depth, or RGB color space with 24 bits per pixel depth.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members
Overload List
ImGearRasterPage Class


%%PageItemTitle%% $$Properties$$

ImGearVectPage Class Properties

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectPage Class

For a list of all members of this type, see ImGearVectPage members.

Public Properties
 | Name | Description
Public Property | VectorData | Gets underlying vector data (drawing) for the page.
Top
See Also

Reference

ImGearVectPage Class
ImageGear.Vector Namespace


VectorData Property

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectPage Class : VectorData Property
Gets underlying vector data (drawing) for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VectorData As ImGearVectorData
'Usage

Dim instance As ImGearVectPage
Dim value As ImGearVectorData

value = instance.VectorData
public ImGearVectorData VectorData {get;}
public: __property ImGearVectorData* get_VectorData();
public:
property ImGearVectorData^ VectorData {
   ImGearVectorData^ get();
}

Property Value

ImGearVectorData class containing the vector data.
See Also

Reference

ImGearVectPage Class
ImGearVectPage Members


%%PageItemTitle%%

ImGearVectAlignment Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectAlignment Enumeration
Specifies text alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearVectAlignment
   Inherits System.Enum
'Usage

Dim instance As ImGearVectAlignment
[Flags()]
public enum ImGearVectAlignment : System.Enum
[Flags()]
__value public enum ImGearVectAlignment : public System.Enum
[Flags()]
public enum class ImGearVectAlignment : public System.Enum
Members
Member | Value | Description
CONTINUOUSX | 0x00000080 | Additional align point is used for alignment along x direction.
CONTINUOUSY | 0x00000100 | Additional align point is used for alignment along y direction.
NONE | 0x00000000 | No alighnment (default alignment).
RESTRICT | 0x00000200 | The text is restricted.
RESTRICT_BASIS | 0x00000400 | The text is exactly restricted in the restrict box by the base line.
RESTRICT_BOXED_ALL | 0x00001000 | The same as RESTRICT_BASIS at the moment.
RESTRICT_BOXED_CAP | 0x00000800 | The text is exactly restricted in the restrict box by the bottom.
RESTRICT_ISOTROPIC_ALL | 0x00004000 | Isotropic restriction in the restrict box by the base line.
RESTRICT_ISOTROPIC_CAP | 0x00002000 | Isotropic restriction in the restrict box by the bottom.
RESTRICT_JUSTIFIED | 0x00008000 | The text is justified inside the restriction box using variable spacing.
X_CENTER | 0x00000002 | Text is centered in x directiont.
X_LEFT | 0x00000001 | Text is left-aligned in x direction.
X_RIGHT | 0x00000004 | Text is right-aligned in x direction.
Y_BASELINE | 0x00000040 | Text is base line aligned.
Y_BOTTOM | 0x00000020 | Text is bottom-aligned in y direction.
Y_CENTER | 0x00000010 | Text is centered in y direction.
Y_TOP | 0x00000008 | Text is top-aligned in y direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectAlignment

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectArcCloseType Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectArcCloseType Enumeration
Specifies arc closing type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectArcCloseType
   Inherits System.Enum
'Usage

Dim instance As ImGearVectArcCloseType
public enum ImGearVectArcCloseType : System.Enum
__value public enum ImGearVectArcCloseType : public System.Enum
public enum class ImGearVectArcCloseType : public System.Enum
Members
Member | Value | Description
NONE | 0 | The arc is not closed.
SECTOR | 1 | The arc is closed as a sector.
SEGMENT | 2 | The arc is closed as a segment.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectArcCloseType

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectAttrib Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectAttrib Enumeration
Specifies different entity attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearVectAttrib
   Inherits System.Enum
'Usage

Dim instance As ImGearVectAttrib
[Flags()]
public enum ImGearVectAttrib : System.Enum
[Flags()]
__value public enum ImGearVectAttrib : public System.Enum
[Flags()]
public enum class ImGearVectAttrib : public System.Enum
Members
Member | Value | Description
DRAWCOLOR | 0x00000001 | Specifies a drawing color.
FILLCOLOR | 0x00000002 | Specifies a filling color.
FILLTYPEINDEX | 0x00000010 | Specifies a fill type index.
LINETYPEINDEX | 0x00000004 | Specifies a line type index.
OFFSET | 0x00000020 | Is no longer in use.
POSITION | 0x00000100 | Is no longer in use.
ROTATION | 0x00000040 | Is no longer in use.
SCALE | 0x00000080 | Is no longer in use.
THICKNESS | 0x00000008 | Specifies a line thickness.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectAttrib

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectAttrSource Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectAttrSource Enumeration
Specifies sources of the entity attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectAttrSource
   Inherits System.Enum
'Usage

Dim instance As ImGearVectAttrSource
public enum ImGearVectAttrSource : System.Enum
__value public enum ImGearVectAttrSource : public System.Enum
public enum class ImGearVectAttrSource : public System.Enum
Members
Member | Value | Description
ACTUAL | -1 | The actual value of attribute is used.
BLOCK | -2 | The attribue value is defined by the parent block.
LAYER | -3 | The attribute value is defined by the layer.
NONE | -1 | The actual value of attribute is used (same as ACTUAL).
Remarks
Attribute sources are applicable to the draw color, fill color, line type, fill type and thickness.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectAttrSource

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectCullFace Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectCullFace Enumeration
Specifies face culling modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectCullFace
   Inherits System.Enum
'Usage

Dim instance As ImGearVectCullFace
public enum ImGearVectCullFace : System.Enum
__value public enum ImGearVectCullFace : public System.Enum
public enum class ImGearVectCullFace : public System.Enum
Members
Member | Value | Description
BACK | 1 | Back-facing facets are culled (only front-facing faces are rendered).
FRONT | 2 | Front-facing facets are culled (only back-facing faces are rendered).
NONE | 0 | No facets are culled (both front and back facing faces are rendered).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectCullFace

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectDir Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectDir Enumeration
Specifies direction of rotate operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectDir
   Inherits System.Enum
'Usage

Dim instance As ImGearVectDir
public enum ImGearVectDir : System.Enum
__value public enum ImGearVectDir : public System.Enum
public enum class ImGearVectDir : public System.Enum
Members
Member | Value | Description
XY | 0 | Rotation in XY direction.
XZ | 2 | Rotation in XZ direction.
YZ | 1 | Rotation in YZ direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectDir

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectEntities Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectEntities Enumeration
Specifies the type of the entity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectEntities
   Inherits System.Enum
'Usage

Dim instance As ImGearVectEntities
public enum ImGearVectEntities : System.Enum
__value public enum ImGearVectEntities : public System.Enum
public enum class ImGearVectEntities : public System.Enum
Members
Member | Value | Description
ARC | 6 | The entity is an elliptical arc.
BEZIER_CURVE | 8 | The entity is a Bezier curve.
BEZIER_SURFACE | 16 | The entity is a Bezier surface.
BLOCK | 1 | The entity is a block.
CONNECTION | 13 | The entity is a connection edge.
EASY_SURFACE | 10 | The entity is an easy surface.
EASYLINE | 2 | The entity is an easy line.
ELLIPSE | 5 | The entity is an ellipse.
FIGURE | 12 | The entity is a figure.
GEOMETRY | 21 | The entity is a geometry.
INSERTION | 20 | The entity is an insertion.
NURBS_CURVE | 9 | The entity is a NURBS curve.
NURBS_SURFACE | 11 | The entity is a NURBS surface.
POLYLINE | 3 | The entity is a polyline.
POLYLINEEX | 4 | The entity is an extended polyline.
RASTER | 14 | The entity is a raster.
SHELL | 17 | The entity is a shell.
SHELLEX | 18 | The entity is an extended shell.
SOLID | 19 | The entity is a solid.
TEXT | 7 | The entity is a text.
UNKNOWN | 0 | Unknow entity.
VIEWPORT | 15 | The entity is a viewport.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectEntities

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectFillMode Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectFillMode Enumeration
Specifies the winding rule for the complete polygons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectFillMode
   Inherits System.Enum
'Usage

Dim instance As ImGearVectFillMode
public enum ImGearVectFillMode : System.Enum
__value public enum ImGearVectFillMode : public System.Enum
public enum class ImGearVectFillMode : public System.Enum
Members
Member | Value | Description
ABS_GEQ_TWO | 4 | This operation is useful for polygon CSG (computational solid geometry) operations.
NEGATIVE | 3 | This operation is useful for polygon CSG (computational solid geometry) operations.
NONZERO | 1 | Nonzero rule is used.
ODD | 0 | Odd rule is used.
POSITIVE | 2 | This operation is useful for polygon CSG (computational solid geometry) operations.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectFillMode

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectFillPattern Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectFillPattern Enumeration
Specifies constants describing different fill patterns.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectFillPattern
   Inherits System.Enum
'Usage

Dim instance As ImGearVectFillPattern
public enum ImGearVectFillPattern : System.Enum
__value public enum ImGearVectFillPattern : public System.Enum
public enum class ImGearVectFillPattern : public System.Enum
Members
Member | Value | Description
GRADIENT | 0x00000010 | Gradient filling.
HATCH_BDIAGONAL | 0x00000001 | Right-to-left diagonal filling.
HATCH_CROSS | 0x00000002 | Cross filling.
HATCH_DIAGCROSS | 0x00000003 | Diagonal cross filling.
HATCH_FDIAGONAL | 0x00000004 | Left-to-right diagonal filling.
HATCH_HORIZONTAL | 0x00000006 | Horizontal line filling.
HATCH_MASK | 0x0000000F | Mask that allows detection and selection the hatch fill type.
HATCH_VECTOR | 0x00000800 | Vector hatch pattern.
HATCH_VERTICAL | 0x00000007 | Vertical line filling.
SHADOW_MASK | 0x000007F0 | Mask that allows setting the shadow fill pattern. Shadow pattern is created by right-shifting the shadow level (1-100) on 4 bits and adding to the shadow mask.
SOLID | 0x00000000 | Solid filling.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectFillPattern

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectGeometryType Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectGeometryType Enumeration
Specifies the type of geometry primitives.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectGeometryType
   Inherits System.Enum
'Usage

Dim instance As ImGearVectGeometryType
public enum ImGearVectGeometryType : System.Enum
__value public enum ImGearVectGeometryType : public System.Enum
public enum class ImGearVectGeometryType : public System.Enum
Members
Member | Value | Description
LINE_LOOP | 2 | Vertices define a connected group of line segments from the first vertex to the last.
LINE_STRIP | 3 | Vertices define a connected group of line segments from the first vertex to the last, then back to the first.
LINES | 1 | Each pair of vertices is an independent line segment.
POINTS | 0 | Each vertex is a single point.
POLYGON | 9 | Vertices define a single, convex polygon.
QUAD_STRIP | 8 | Vertices define a connected group of quadrilaterals. One quadrilateral is defined for each pair of vertices presented after the first pair. Vertices 2n 1, 2n, 2n + 2, and 2n + 1 define quadrilateral n. N quadrilaterals are drawn.
QUADS | 7 | Each group of four vertices is an independent quadrilateral.
TRIANGLE_FAN | 6 | Vertices define a connected group of triangles. One triangle is defined for each vertex presented after the first two vertices. Vertices 1, n + 1, and n + 2 define triangle n. N 2 triangles are drawn.
TRIANGLE_STRIP | 5 | Vertices define a connected group of triangles. One triangle is defined for each vertex presented after the first two vertices. For odd n, vertices n, n + 1, and n + 2 define triangle n. For even n, vertices n + 1, n, and n + 2 define triangle n. N 2 triangles are drawn.
TRIANGLES | 4 | Each triplet of vertices is an independent triangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectGeometryType

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectGradientSpreadMethod Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectGradientSpreadMethod Enumeration
Specifies gradient spread methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectGradientSpreadMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearVectGradientSpreadMethod
public enum ImGearVectGradientSpreadMethod : System.Enum
__value public enum ImGearVectGradientSpreadMethod : public System.Enum
public enum class ImGearVectGradientSpreadMethod : public System.Enum
Members
Member | Value | Description
Pad | 0 | Expand the first or last color.
Reflect | 1 | Repeat the gradient with reflection.
Repeat | 2 | Repeat the gradient periodically.
Remarks
Spread method specifies how the gradient is expanded.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectGradientSpreadMethod

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectGradientType Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectGradientType Enumeration
Specifies types of gradient filling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectGradientType
   Inherits System.Enum
'Usage

Dim instance As ImGearVectGradientType
public enum ImGearVectGradientType : System.Enum
__value public enum ImGearVectGradientType : public System.Enum
public enum class ImGearVectGradientType : public System.Enum
Members
Member | Value | Description
Linear | 0 | Linear gradient.
Radial | 1 | Radial gradient.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectGradientType

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectGraphics Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectGraphics Enumeration
Specifies the type of the vector graphics to be used for displaying vector data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectGraphics
   Inherits System.Enum
'Usage

Dim instance As ImGearVectGraphics
public enum ImGearVectGraphics : System.Enum
__value public enum ImGearVectGraphics : public System.Enum
public enum class ImGearVectGraphics : public System.Enum
Members
Member | Value | Description
AUTO | 0 | The graphics type is defined automatically.
DIRECT3D | 3 | Direct3D graphics is used.
OPENGL | 1 | OpenGL graphics is used.
WINAPI | 2 | This value has been deprecated. Use AUTO, OPENGL or DIRECT3D instead.
Remarks
For ImGearVectGraphics.AUTO the graphics type is defined according to the following rule:
  • If Windows version is Vista or higher, or the video card does not support double buffering, Direct3D is selected.
  • Otherwise, OpenGL is selected.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectGraphics

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectMeasurementUnits Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectMeasurementUnits Enumeration
Specifies measurement units used by vector drawings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectMeasurementUnits
   Inherits System.Enum
'Usage

Dim instance As ImGearVectMeasurementUnits
public enum ImGearVectMeasurementUnits : System.Enum
__value public enum ImGearVectMeasurementUnits : public System.Enum
public enum class ImGearVectMeasurementUnits : public System.Enum
Members
Member | Value | Description
CM | 2 | Measurement units are centimeters.
INCHES | 4 | Measurement units are inches.
M | 3 | Measurement units are meters.
MM | 1 | Measurement units are millimeters.
PLTS | 5 | Measurement units are plot units (1/40 mm).
TWIPS | 6 | Measurement units are twips (1/1440 inch).
UNKNOWN | 0 | Unknown units.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectMeasurementUnits

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectNURBSFlags Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectNURBSFlags Enumeration
Specifies different flags for NURBS curve and surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearVectNURBSFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearVectNURBSFlags
[Flags()]
public enum ImGearVectNURBSFlags : System.Enum
[Flags()]
__value public enum ImGearVectNURBSFlags : public System.Enum
[Flags()]
public enum class ImGearVectNURBSFlags : public System.Enum
Members
Member | Value | Description
MCLOSED | 0x00000004 | The NURBS curve or surface is closed in M direction.
MFIT | 0x00000040 | The curve or surface is interpolated by qubic spline in M direction.
MINTERPOLATE | 0x00000010 | Not in use.
NCLOSED | 0x00000008 | The NURBS surface is closed in N direction.
NFIT | 0x00000080 | The surface is interpolated by qubic spline in N direction.
NINTERPOLATE | 0x00000020 | Not in use.
RATIONAL | 0x00000002 | The NURBS curve or surface is rational.
UNIFORM | 0x00000001 | The NURBS curve or surface is uniform.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectNURBSFlags

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectObjType Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectObjType Enumeration
These constants define vector object types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearVectObjType
   Inherits System.Enum
'Usage

Dim instance As ImGearVectObjType
public enum ImGearVectObjType : System.Enum
__value public enum ImGearVectObjType : public System.Enum
public enum class ImGearVectObjType : public System.Enum
Members
Member | Value | Description
DBLCONT | 6 | Double precision container object.
DRWNG | 2 | Vector drawing object.
ENTITY | 1 | Vector entity object.
ENTITYCONT | 12 | Entity container object.
FILLTYPE | 9 | Fill type object.
FONT | 4 | Font object.
HATCHLINE | 15 | Hatch line definition object.
LAYER | 10 | Drawing layer object.
LAYERCONT | 11 | Layer container object.
LINETYPE | 8 | Line type object.
ROTATION | 7 | Rotation object.
TEXTOBJ | 13 | Text object.
UNKNOWN | 0 | Unknown object type.
VECTORHATCH | 14 | Hatch pattern definition object.
VERTEXCONT | 5 | Vertex container object.
VIEW | 3 | Vector view object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectObjType

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectTxtFlags Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectTxtFlags Enumeration
Specifies different text object effects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearVectTxtFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearVectTxtFlags
[Flags()]
public enum ImGearVectTxtFlags : System.Enum
[Flags()]
__value public enum ImGearVectTxtFlags : public System.Enum
[Flags()]
public enum class ImGearVectTxtFlags : public System.Enum
Members
Member | Value | Description
DBLSTRUCK | 0x00000004 | The text object is struck with two lines.
STRUCK | 0x00000002 | The text object is struck.
SUBSCRIPT | 0x00000010 | The text object is a subscript.
SUPERSCRIPT | 0x00000008 | The text object is a superscript.
UNDERLINED | 0x00000001 | The text object is underlined.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectTxtFlags

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectVertexData Enumeration

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectVertexData Enumeration
Specifies the type of additional data associated with the vertex.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearVectVertexData
   Inherits System.Enum
'Usage

Dim instance As ImGearVectVertexData
[Flags()]
public enum ImGearVectVertexData : System.Enum
[Flags()]
__value public enum ImGearVectVertexData : public System.Enum
[Flags()]
public enum class ImGearVectVertexData : public System.Enum
Members
Member | Value | Description
BULGE | 0x00000002 | The outgoing line segment is bulged.
NONE | 0x00000000 | The vertex doesn't have any additional attributes.
THICKNESS | 0x00000004 | The outgoing line segment has the local thickness.
WEIGHT | 0x00000008 | The vertex has weight. Used in rational B-splines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Vector.ImGearVectVertexData

See Also

Reference

ImageGear.Vector Namespace


%%PageItemTitle%%

ImGearVectorColor Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColor Structure
Represents a color.
Object Model
ImGearVectorColor Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorColor
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorColor
public struct ImGearVectorColor : System.ValueType
public __value struct ImGearVectorColor : public System.ValueType
public value class ImGearVectorColor : public System.ValueType
Remarks
The color consists of four components - red, green, blue and alpha.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorColor

See Also

Reference

ImGearVectorColor Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorColor Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColor Structure

The following tables list the members exposed by ImGearVectorColor.

Public Fields
 | Name | Description
Public Field | m_a | Alpha component of the color.
Public Field | m_b | Blue component of the color.
Public Field | m_g | Green component of the color.
Public Field | m_r | Red component of the color.
Top
See Also

Reference

ImGearVectorColor Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorColor Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColor Structure

For a list of all members of this type, see ImGearVectorColor members.

Public Fields
 | Name | Description
Public Field | m_a | Alpha component of the color.
Public Field | m_b | Blue component of the color.
Public Field | m_g | Green component of the color.
Public Field | m_r | Red component of the color.
Top
See Also

Reference

ImGearVectorColor Structure
ImageGear.Vector Namespace


m_a Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColor Structure : m_a Field
Alpha component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_a As Byte
'Usage

Dim instance As ImGearVectorColor
Dim value As Byte

value = instance.m_a

instance.m_a = value
public byte m_a
public: byte m_a
public:
byte m_a
See Also

Reference

ImGearVectorColor Structure
ImGearVectorColor Members


m_b Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColor Structure : m_b Field
Blue component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_b As Byte
'Usage

Dim instance As ImGearVectorColor
Dim value As Byte

value = instance.m_b

instance.m_b = value
public byte m_b
public: byte m_b
public:
byte m_b
See Also

Reference

ImGearVectorColor Structure
ImGearVectorColor Members


m_g Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColor Structure : m_g Field
Green component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_g As Byte
'Usage

Dim instance As ImGearVectorColor
Dim value As Byte

value = instance.m_g

instance.m_g = value
public byte m_g
public: byte m_g
public:
byte m_g
See Also

Reference

ImGearVectorColor Structure
ImGearVectorColor Members


m_r Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColor Structure : m_r Field
Red component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_r As Byte
'Usage

Dim instance As ImGearVectorColor
Dim value As Byte

value = instance.m_r

instance.m_r = value
public byte m_r
public: byte m_r
public:
byte m_r
See Also

Reference

ImGearVectorColor Structure
ImGearVectorColor Members


%%PageItemTitle%%

ImGearVectorColorEx Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColorEx Structure
Represents an extended color.
Object Model
ImGearVectorColorEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorColorEx
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorColorEx
public struct ImGearVectorColorEx : System.ValueType
public __value struct ImGearVectorColorEx : public System.ValueType
public value class ImGearVectorColorEx : public System.ValueType
Remarks
Extended color has additional flag showing the source of the color.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorColorEx

See Also

Reference

ImGearVectorColorEx Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorColorEx Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColorEx Structure

The following tables list the members exposed by ImGearVectorColorEx.

Public Fields
 | Name | Description
Public Field | m_color | Color component.
Public Field | m_flags | Flag showing a source of the color.
Top
See Also

Reference

ImGearVectorColorEx Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorColorEx Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorColorEx Structure

For a list of all members of this type, see ImGearVectorColorEx members.

Public Fields
 | Name | Description
Public Field | m_color | Color component.
Public Field | m_flags | Flag showing a source of the color.
Top
See Also

Reference

ImGearVectorColorEx Structure
ImageGear.Vector Namespace


m_color Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColorEx Structure : m_color Field
Color component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_color As ImGearVectorColor
'Usage

Dim instance As ImGearVectorColorEx
Dim value As ImGearVectorColor

value = instance.m_color

instance.m_color = value
public ImGearVectorColor m_color
public: ImGearVectorColor m_color
public:
ImGearVectorColor m_color
See Also

Reference

ImGearVectorColorEx Structure
ImGearVectorColorEx Members


m_flags Field (ImGearVectorColorEx)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorColorEx Structure : m_flags Field
Flag showing a source of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_flags As Integer
'Usage

Dim instance As ImGearVectorColorEx
Dim value As Integer

value = instance.m_flags

instance.m_flags = value
public int m_flags
public: int m_flags
public:
int m_flags
See Also

Reference

ImGearVectorColorEx Structure
ImGearVectorColorEx Members
ImGearVectAttrSource Enumeration


%%PageItemTitle%%

ImGearVectorMinMax Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorMinMax Structure
Represents a bounding parallelepiped of the object.
Object Model
ImGearVectorMinMax Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorMinMax
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorMinMax
public struct ImGearVectorMinMax : System.ValueType
public __value struct ImGearVectorMinMax : public System.ValueType
public value class ImGearVectorMinMax : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorMinMax

See Also

Reference

ImGearVectorMinMax Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorMinMax Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorMinMax Structure

The following tables list the members exposed by ImGearVectorMinMax.

Public Fields
 | Name | Description
Public Field | m_xmax | Maximum value of X coordinate.
Public Field | m_xmin | Minimum value of X coordinate.
Public Field | m_ymax | Maximum value of Y coordinate.
Public Field | m_ymin | Minimum value of Y coordinate.
Public Field | m_zmax | Maximum value of Z coordinate.
Public Field | m_zmin | Minimum value of Z coordinate.
Top
See Also

Reference

ImGearVectorMinMax Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorMinMax Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorMinMax Structure

For a list of all members of this type, see ImGearVectorMinMax members.

Public Fields
 | Name | Description
Public Field | m_xmax | Maximum value of X coordinate.
Public Field | m_xmin | Minimum value of X coordinate.
Public Field | m_ymax | Maximum value of Y coordinate.
Public Field | m_ymin | Minimum value of Y coordinate.
Public Field | m_zmax | Maximum value of Z coordinate.
Public Field | m_zmin | Minimum value of Z coordinate.
Top
See Also

Reference

ImGearVectorMinMax Structure
ImageGear.Vector Namespace


m_xmax Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_xmax Field
Maximum value of X coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_xmax As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_xmax

instance.m_xmax = value
public float m_xmax
public: float m_xmax
public:
float m_xmax
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


m_xmin Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_xmin Field
Minimum value of X coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_xmin As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_xmin

instance.m_xmin = value
public float m_xmin
public: float m_xmin
public:
float m_xmin
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


m_ymax Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_ymax Field
Maximum value of Y coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_ymax As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_ymax

instance.m_ymax = value
public float m_ymax
public: float m_ymax
public:
float m_ymax
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


m_ymin Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_ymin Field
Minimum value of Y coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_ymin As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_ymin

instance.m_ymin = value
public float m_ymin
public: float m_ymin
public:
float m_ymin
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


m_zmax Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_zmax Field
Maximum value of Z coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_zmax As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_zmax

instance.m_zmax = value
public float m_zmax
public: float m_zmax
public:
float m_zmax
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


m_zmin Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorMinMax Structure : m_zmin Field
Minimum value of Z coordinate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_zmin As Single
'Usage

Dim instance As ImGearVectorMinMax
Dim value As Single

value = instance.m_zmin

instance.m_zmin = value
public float m_zmin
public: float m_zmin
public:
float m_zmin
See Also

Reference

ImGearVectorMinMax Structure
ImGearVectorMinMax Members


%%PageItemTitle%%

ImGearVectorPoint2D Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint2D Structure
Represents a two-dimentional point.
Object Model
ImGearVectorPoint2D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorPoint2D
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorPoint2D
public struct ImGearVectorPoint2D : System.ValueType
public __value struct ImGearVectorPoint2D : public System.ValueType
public value class ImGearVectorPoint2D : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorPoint2D

See Also

Reference

ImGearVectorPoint2D Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorPoint2D Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint2D Structure

The following tables list the members exposed by ImGearVectorPoint2D.

Public Fields
 | Name | Description
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint2D Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorPoint2D Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint2D Structure

For a list of all members of this type, see ImGearVectorPoint2D members.

Public Fields
 | Name | Description
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint2D Structure
ImageGear.Vector Namespace


m_x Field (ImGearVectorPoint2D)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint2D Structure : m_x Field
X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_x As Single
'Usage

Dim instance As ImGearVectorPoint2D
Dim value As Single

value = instance.m_x

instance.m_x = value
public float m_x
public: float m_x
public:
float m_x
See Also

Reference

ImGearVectorPoint2D Structure
ImGearVectorPoint2D Members


m_y Field (ImGearVectorPoint2D)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint2D Structure : m_y Field
Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_y As Single
'Usage

Dim instance As ImGearVectorPoint2D
Dim value As Single

value = instance.m_y

instance.m_y = value
public float m_y
public: float m_y
public:
float m_y
See Also

Reference

ImGearVectorPoint2D Structure
ImGearVectorPoint2D Members


%%PageItemTitle%%

ImGearVectorPoint3D Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3D Structure
Represents a three-dimentional point.
Object Model
ImGearVectorPoint3D Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorPoint3D
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorPoint3D
public struct ImGearVectorPoint3D : System.ValueType
public __value struct ImGearVectorPoint3D : public System.ValueType
public value class ImGearVectorPoint3D : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorPoint3D

See Also

Reference

ImGearVectorPoint3D Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorPoint3D Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3D Structure

The following tables list the members exposed by ImGearVectorPoint3D.

Public Fields
 | Name | Description
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Public Field | m_z | Z coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint3D Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorPoint3D Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3D Structure

For a list of all members of this type, see ImGearVectorPoint3D members.

Public Fields
 | Name | Description
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Public Field | m_z | Z coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint3D Structure
ImageGear.Vector Namespace


m_x Field (ImGearVectorPoint3D)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3D Structure : m_x Field
X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_x As Single
'Usage

Dim instance As ImGearVectorPoint3D
Dim value As Single

value = instance.m_x

instance.m_x = value
public float m_x
public: float m_x
public:
float m_x
See Also

Reference

ImGearVectorPoint3D Structure
ImGearVectorPoint3D Members


m_y Field (ImGearVectorPoint3D)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3D Structure : m_y Field
Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_y As Single
'Usage

Dim instance As ImGearVectorPoint3D
Dim value As Single

value = instance.m_y

instance.m_y = value
public float m_y
public: float m_y
public:
float m_y
See Also

Reference

ImGearVectorPoint3D Structure
ImGearVectorPoint3D Members


m_z Field (ImGearVectorPoint3D)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3D Structure : m_z Field
Z coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_z As Single
'Usage

Dim instance As ImGearVectorPoint3D
Dim value As Single

value = instance.m_z

instance.m_z = value
public float m_z
public: float m_z
public:
float m_z
See Also

Reference

ImGearVectorPoint3D Structure
ImGearVectorPoint3D Members


%%PageItemTitle%%

ImGearVectorPoint3DEx Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3DEx Structure
Represents an extended three-dimentional point.
Object Model
ImGearVectorPoint3DEx Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorPoint3DEx
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorPoint3DEx
public struct ImGearVectorPoint3DEx : System.ValueType
public __value struct ImGearVectorPoint3DEx : public System.ValueType
public value class ImGearVectorPoint3DEx : public System.ValueType
Remarks
Extended point contains one additional field that is used as a weight for NURBS surfaces.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorPoint3DEx

See Also

Reference

ImGearVectorPoint3DEx Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorPoint3DEx Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3DEx Structure

The following tables list the members exposed by ImGearVectorPoint3DEx.

Public Fields
 | Name | Description
Public Field | m_w | Weight of the point.
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Public Field | m_z | Z coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint3DEx Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorPoint3DEx Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorPoint3DEx Structure

For a list of all members of this type, see ImGearVectorPoint3DEx members.

Public Fields
 | Name | Description
Public Field | m_w | Weight of the point.
Public Field | m_x | X coordinate of the point.
Public Field | m_y | Y coordinate of the point.
Public Field | m_z | Z coordinate of the point.
Top
See Also

Reference

ImGearVectorPoint3DEx Structure
ImageGear.Vector Namespace


m_w Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3DEx Structure : m_w Field
Weight of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_w As Single
'Usage

Dim instance As ImGearVectorPoint3DEx
Dim value As Single

value = instance.m_w

instance.m_w = value
public float m_w
public: float m_w
public:
float m_w
See Also

Reference

ImGearVectorPoint3DEx Structure
ImGearVectorPoint3DEx Members


m_x Field (ImGearVectorPoint3DEx)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3DEx Structure : m_x Field
X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_x As Single
'Usage

Dim instance As ImGearVectorPoint3DEx
Dim value As Single

value = instance.m_x

instance.m_x = value
public float m_x
public: float m_x
public:
float m_x
See Also

Reference

ImGearVectorPoint3DEx Structure
ImGearVectorPoint3DEx Members


m_y Field (ImGearVectorPoint3DEx)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3DEx Structure : m_y Field
Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_y As Single
'Usage

Dim instance As ImGearVectorPoint3DEx
Dim value As Single

value = instance.m_y

instance.m_y = value
public float m_y
public: float m_y
public:
float m_y
See Also

Reference

ImGearVectorPoint3DEx Structure
ImGearVectorPoint3DEx Members


m_z Field (ImGearVectorPoint3DEx)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorPoint3DEx Structure : m_z Field
Z coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_z As Single
'Usage

Dim instance As ImGearVectorPoint3DEx
Dim value As Single

value = instance.m_z

instance.m_z = value
public float m_z
public: float m_z
public:
float m_z
See Also

Reference

ImGearVectorPoint3DEx Structure
ImGearVectorPoint3DEx Members


%%PageItemTitle%%

ImGearVectorVertex Structure
Members

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertex Structure
Represents a vertex.
Object Model
ImGearVectorVertex Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearVectorVertex
   Inherits System.ValueType
'Usage

Dim instance As ImGearVectorVertex
public struct ImGearVectorVertex : System.ValueType
public __value struct ImGearVectorVertex : public System.ValueType
public value class ImGearVectorVertex : public System.ValueType
Remarks
Vertex contains point coordinates and flags that define some additional vertex attributes, such as bulge, thickness, weight, visibility. These attributes are controlled by the owner vertex container.
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Vector.ImGearVectorVertex

See Also

Reference

ImGearVectorVertex Members
ImageGear.Vector Namespace


%%PageItemTitle%% $$Members$$

ImGearVectorVertex Structure Members
Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertex Structure

The following tables list the members exposed by ImGearVectorVertex.

Public Fields
 | Name | Description
Public Field | m_flags | Vertex flags.
Public Field | m_point | Vertex coordinates.
Top
See Also

Reference

ImGearVectorVertex Structure
ImageGear.Vector Namespace


%%PageItemTitle%% $$Fields$$

ImGearVectorVertex Structure Fields

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace : ImGearVectorVertex Structure

For a list of all members of this type, see ImGearVectorVertex members.

Public Fields
 | Name | Description
Public Field | m_flags | Vertex flags.
Public Field | m_point | Vertex coordinates.
Top
See Also

Reference

ImGearVectorVertex Structure
ImageGear.Vector Namespace


m_flags Field (ImGearVectorVertex)

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertex Structure : m_flags Field
Vertex flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_flags As UInteger
'Usage

Dim instance As ImGearVectorVertex
Dim value As UInteger

value = instance.m_flags

instance.m_flags = value
public uint m_flags
public: uint m_flags
public:
uint m_flags
See Also

Reference

ImGearVectorVertex Structure
ImGearVectorVertex Members
ImGearVectVertexData Enumeration


m_point Field

ImageGear22.Formats.Vector Assembly > ImageGear.Vector Namespace > ImGearVectorVertex Structure : m_point Field
Vertex coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public m_point As ImGearVectorPoint3D
'Usage

Dim instance As ImGearVectorVertex
Dim value As ImGearVectorPoint3D

value = instance.m_point

instance.m_point = value
public ImGearVectorPoint3D m_point
public: ImGearVectorPoint3D m_point
public:
ImGearVectorPoint3D m_point
See Also

Reference

ImGearVectorVertex Structure
ImGearVectorVertex Members


ImageGear22.Presentation Assembly
Namespaces
Namespace | Description
ImageGear.ART | The ImageGear ART namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear ART namespace enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper. This chapter provides the ART namespace API reference.
ImageGear.Display | In the ImageGear22.Presentation Assembly, the ImageGear.Display namespace provides the ImageGear for .NET API for displaying and printing in the WPF environment. For more information, see Displaying Images.


ImageGear.ART Namespace (ImageGear22.Presentation)
Inheritance Hierarchy
ImageGear22.Presentation Assembly : ImageGear.ART Namespace
The ImageGear ART namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear ART namespace enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper. This chapter provides the ART namespace API reference.
Classes
 | Class | Description
Class | ImGearARTCustomPresentationController | Provides a set of abstract members for user-defined custom mark controller, using with Wpf drawing engine.
Class | ImGearARTPresentationState | Provides a set of parameters for custom mark's drawing.
See Also

Reference

ImageGear22.Presentation Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.ART Namespace (ImageGear22.Presentation) Inheritance Hierarchy
ImageGear22.Presentation Assembly : ImageGear.ART Namespace
Inheritance Hierarchy
System.Object
ImageGear.ART.ImGearARTCustomController
ImageGear.ART.ImGearARTCustomPresentationController
ImageGear.ART.ImGearARTPresentationState
See Also

Reference

ImageGear22.Presentation Assembly


%%PageItemTitle%%

ImGearARTCustomPresentationController Class
Members

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTCustomPresentationController Class
Provides a set of abstract members for user-defined custom mark controller, using with Wpf drawing engine.
Object Model
ImGearARTCustomPresentationController ClassImGearARTCustomPresentationController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearARTCustomPresentationController
   Inherits ImGearARTCustomController
'Usage

Dim instance As ImGearARTCustomPresentationController
public abstract class ImGearARTCustomPresentationController : ImGearARTCustomController
public __gc abstract class ImGearARTCustomPresentationController : public ImGearARTCustomController
public ref class ImGearARTCustomPresentationController abstract : public ImGearARTCustomController
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTCustomController
ImageGear.ART.ImGearARTCustomPresentationController

See Also

Reference

ImGearARTCustomPresentationController Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTCustomPresentationController Class Members
Methods

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTCustomPresentationController Class

The following tables list the members exposed by ImGearARTCustomPresentationController.

Public Methods
 | Name | Description
Public Method | Draw | Draws a mark.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark controller.
Public Method | HitTest | Checks if the given point is inside the mork or on its border.
static (Shared in Visual Basic) | RegisterCustomController | Registers a presentation controller for a custom mark type.
Top
See Also

Reference

ImGearARTCustomPresentationController Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTCustomPresentationController Class Methods

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTCustomPresentationController Class

For a list of all members of this type, see ImGearARTCustomPresentationController members.

Public Methods
 | Name | Description
Public Method | Draw | Draws a mark.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark controller.
Public Method | HitTest | Checks if the given point is inside the mork or on its border.
static (Shared in Visual Basic) | RegisterCustomController | Registers a presentation controller for a custom mark type.
Top
See Also

Reference

ImGearARTCustomPresentationController Class
ImageGear.ART Namespace


Draw Method (ImGearARTCustomPresentationController)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : Draw Method
Draws a mark.
Overload List
Overload | Description
Draw | Draws a mark.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


Draw(ImGearARTCustomMark,ImGearARTPresentationState) Method

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : Draw(ImGearARTCustomMark,ImGearARTPresentationState) Method
Mark to draw.
A set of parameters for custom mark's drawing.
Draws a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Draw( _
   ByVal mark As ImGearARTCustomMark, _
   ByVal presentationState As ImGearARTPresentationState _
)
'Usage

Dim instance As ImGearARTCustomPresentationController
Dim mark As ImGearARTCustomMark
Dim presentationState As ImGearARTPresentationState

instance.Draw(mark, presentationState)
public abstract void Draw(
   ImGearARTCustomMark mark,
   ImGearARTPresentationState presentationState
)
public: abstract void Draw(
   ImGearARTCustomMark* mark,
   ImGearARTPresentationState* presentationState
)
public:
abstract void Draw(
   ImGearARTCustomMark^ mark,
   ImGearARTPresentationState^ presentationState
)

Parameters

mark
Mark to draw.
presentationState
A set of parameters for custom mark's drawing.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


GetCustomController Method (ImGearARTCustomPresentationController)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : GetCustomController Method
Name of the custom mark type.
Returns a registered custom mark controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetCustomController( _
   ByVal userType As String _
) As ImGearARTCustomPresentationController
'Usage

Dim userType As String
Dim value As ImGearARTCustomPresentationController

value = ImGearARTCustomPresentationController.GetCustomController(userType)
public static ImGearARTCustomPresentationController GetCustomController(
   string userType
)
public: static ImGearARTCustomPresentationController* GetCustomController(
   string* userType
)
public:
static ImGearARTCustomPresentationController^ GetCustomController(
   String^ userType
)

Parameters

userType
Name of the custom mark type.

Return Value

Registered custom controller.
Remarks
userType is an unique name that identifies the type of custom mark. It is stored in ART page and should be the same for all applications that supports a given type of custom mark.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


HitTest Method (ImGearARTCustomPresentationController)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : HitTest Method
Checks if the given point is inside the mork or on its border.
Overload List
Overload | Description
HitTest | Checks if the given point is inside the mork or on its border.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


HitTest(ImGearARTCustomMark,ImGearARTPresentationState,ImGearDoublePoint) Method

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : HitTest(ImGearARTCustomMark,ImGearARTPresentationState,ImGearDoublePoint) Method
Mark to test.
A set of parameters for custom mark's drawing.
Mouse point, in device coordinates.
Checks if the given point is inside the mork or on its border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function HitTest( _
   ByVal mark As ImGearARTCustomMark, _
   ByVal presentationState As ImGearARTPresentationState, _
   ByVal devicePoint As ImGearDoublePoint _
) As ImGearARTMarkHitTest
'Usage

Dim instance As ImGearARTCustomPresentationController
Dim mark As ImGearARTCustomMark
Dim presentationState As ImGearARTPresentationState
Dim devicePoint As ImGearDoublePoint
Dim value As ImGearARTMarkHitTest

value = instance.HitTest(mark, presentationState, devicePoint)
public abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark mark,
   ImGearARTPresentationState presentationState,
   ImGearDoublePoint devicePoint
)
public: abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark* mark,
   ImGearARTPresentationState* presentationState,
   ImGearDoublePoint devicePoint
)
public:
abstract ImGearARTMarkHitTest HitTest(
   ImGearARTCustomMark^ mark,
   ImGearARTPresentationState^ presentationState,
   ImGearDoublePoint devicePoint
)

Parameters

mark
Mark to test.
presentationState
A set of parameters for custom mark's drawing.
devicePoint
Mouse point, in device coordinates.

Return Value

Hit test result.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


RegisterCustomController Method (ImGearARTCustomPresentationController)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTCustomPresentationController Class : RegisterCustomController Method
Name of custom mark type.
Controller object.
Registers a presentation controller for a custom mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterCustomController( _
   ByVal userType As String, _
   ByVal controller As ImGearARTCustomPresentationController _
)
'Usage

Dim userType As String
Dim controller As ImGearARTCustomPresentationController

ImGearARTCustomPresentationController.RegisterCustomController(userType, controller)
public static void RegisterCustomController(
   string userType,
   ImGearARTCustomPresentationController controller
)
public: static void RegisterCustomController(
   string* userType,
   ImGearARTCustomPresentationController* controller
)
public:
static void RegisterCustomController(
   String^ userType,
   ImGearARTCustomPresentationController^ controller
)

Parameters

userType
Name of custom mark type.
controller
Controller object.
Remarks
userType is an unique name that identifies the type of custom mark. It is stored in ART page and should be the same for all applications that supports a given type of custom mark.
See Also

Reference

ImGearARTCustomPresentationController Class
ImGearARTCustomPresentationController Members


%%PageItemTitle%%

ImGearARTPresentationState Class
Members

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTPresentationState Class
Provides a set of parameters for custom mark's drawing.
Object Model
ImGearARTPresentationState ClassImGearDoublePoint StructureImGearRectangle StructureImGearDoublePoint StructureImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTPresentationState
'Usage

Dim instance As ImGearARTPresentationState
public class ImGearARTPresentationState
public __gc class ImGearARTPresentationState
public ref class ImGearARTPresentationState
Inheritance Hierarchy

System.Object
ImageGear.ART.ImGearARTPresentationState

See Also

Reference

ImGearARTPresentationState Members
ImageGear.ART Namespace


%%PageItemTitle%% $$Members$$

ImGearARTPresentationState Class Members
Properties Methods

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTPresentationState Class

The following tables list the members exposed by ImGearARTPresentationState.

Public Properties
 | Name | Description
Public Property | Canvas | Gets a canvas in which custom mark is to be drawn.
Public Property | IsSelected | Gets a value indicating whether the current mark is selected.
Top
Public Methods
 | Name | Description
Public Method | ConvertDeviceToMarkPoint | Converts a point specified in device coordinates to mark coodinates.
Public Method | ConvertDeviceToMarkRectangle | Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Public Method | ConvertMarkToDevicePoint | Converts a point specified in mark coordinates to device coodinates.
Public Method | ConvertMarkToDeviceRectangle | Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Top
See Also

Reference

ImGearARTPresentationState Class
ImageGear.ART Namespace


%%PageItemTitle%% $$Methods$$

ImGearARTPresentationState Class Methods

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTPresentationState Class

For a list of all members of this type, see ImGearARTPresentationState members.

Public Methods
 | Name | Description
Public Method | ConvertDeviceToMarkPoint | Converts a point specified in device coordinates to mark coodinates.
Public Method | ConvertDeviceToMarkRectangle | Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Public Method | ConvertMarkToDevicePoint | Converts a point specified in mark coordinates to device coodinates.
Public Method | ConvertMarkToDeviceRectangle | Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Top
See Also

Reference

ImGearARTPresentationState Class
ImageGear.ART Namespace


ConvertDeviceToMarkPoint Method (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : ConvertDeviceToMarkPoint Method
Point in device coordinates to convert.
Converts a point specified in device coordinates to mark coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertDeviceToMarkPoint( _
   ByVal point As ImGearDoublePoint _
) As ImGearDoublePoint
'Usage

Dim instance As ImGearARTPresentationState
Dim point As ImGearDoublePoint
Dim value As ImGearDoublePoint

value = instance.ConvertDeviceToMarkPoint(point)
public ImGearDoublePoint ConvertDeviceToMarkPoint(
   ImGearDoublePoint point
)
public: ImGearDoublePoint ConvertDeviceToMarkPoint(
   ImGearDoublePoint point
)
public:
ImGearDoublePoint ConvertDeviceToMarkPoint(
   ImGearDoublePoint point
)

Parameters

point
Point in device coordinates to convert.

Return Value

Point in mark coordinates.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members
ImGearDoublePoint Structure
ImGearDoublePoint Structure


ConvertDeviceToMarkRectangle Method (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : ConvertDeviceToMarkRectangle Method
Rectangle in device coordinates to convert.
Converts a rectangle specified in device coordinates to a rectangle in mark coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertDeviceToMarkRectangle( _
   ByVal rectangle As ImGearRectangle _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPresentationState
Dim rectangle As ImGearRectangle
Dim value As ImGearRectangle

value = instance.ConvertDeviceToMarkRectangle(rectangle)
public ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)
public: ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)
public:
ImGearRectangle ConvertDeviceToMarkRectangle(
   ImGearRectangle rectangle
)

Parameters

rectangle
Rectangle in device coordinates to convert.

Return Value

Rectangle in mark coordinates.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members
ImGearRectangle Structure


ConvertMarkToDevicePoint Method (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : ConvertMarkToDevicePoint Method
Point in mark coordinates to convert.
Converts a point specified in mark coordinates to device coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertMarkToDevicePoint( _
   ByVal point As ImGearDoublePoint _
) As ImGearDoublePoint
'Usage

Dim instance As ImGearARTPresentationState
Dim point As ImGearDoublePoint
Dim value As ImGearDoublePoint

value = instance.ConvertMarkToDevicePoint(point)
public ImGearDoublePoint ConvertMarkToDevicePoint(
   ImGearDoublePoint point
)
public: ImGearDoublePoint ConvertMarkToDevicePoint(
   ImGearDoublePoint point
)
public:
ImGearDoublePoint ConvertMarkToDevicePoint(
   ImGearDoublePoint point
)

Parameters

point
Point in mark coordinates to convert.

Return Value

Point in device coordinates.
Remarks
Mark coordinates can be either image coordinates or device coordinates. In both cases the result will be in device coordinates.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members
ImGearDoublePoint Structure


ConvertMarkToDeviceRectangle Method (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : ConvertMarkToDeviceRectangle Method
Rectangle in mark coordinates to convert.
Converts a rectangle specified in mark coordinates to a rectangle in device coodinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertMarkToDeviceRectangle( _
   ByVal rectangle As ImGearRectangle _
) As ImGearRectangle
'Usage

Dim instance As ImGearARTPresentationState
Dim rectangle As ImGearRectangle
Dim value As ImGearRectangle

value = instance.ConvertMarkToDeviceRectangle(rectangle)
public ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)
public: ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)
public:
ImGearRectangle ConvertMarkToDeviceRectangle(
   ImGearRectangle rectangle
)

Parameters

rectangle
Rectangle in mark coordinates to convert.

Return Value

Rectangle in device coordinates.
Remarks
Mark coordinates can be either image coordinates or device coordinates. In both cases the result will be in device coordinates.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

ImGearARTPresentationState Class Properties

ImageGear22.Presentation Assembly > ImageGear.ART Namespace : ImGearARTPresentationState Class

For a list of all members of this type, see ImGearARTPresentationState members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets a canvas in which custom mark is to be drawn.
Public Property | IsSelected | Gets a value indicating whether the current mark is selected.
Top
See Also

Reference

ImGearARTPresentationState Class
ImageGear.ART Namespace


Canvas Property (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : Canvas Property
Gets a canvas in which custom mark is to be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As Canvas
'Usage

Dim instance As ImGearARTPresentationState
Dim value As Canvas

value = instance.Canvas
public Canvas Canvas {get;}
public: __property Canvas* get_Canvas();
public:
property Canvas^ Canvas {
   Canvas^ get();
}

Property Value

Canvas object.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members


IsSelected Property (ImGearARTPresentationState)

ImageGear22.Presentation Assembly > ImageGear.ART Namespace > ImGearARTPresentationState Class : IsSelected Property
Gets a value indicating whether the current mark is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsSelected As Boolean
'Usage

Dim instance As ImGearARTPresentationState
Dim value As Boolean

value = instance.IsSelected
public bool IsSelected {get;}
public: __property bool get_IsSelected();
public:
property bool IsSelected {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearARTPresentationState Class
ImGearARTPresentationState Members


ImageGear.Display Namespace (ImageGear22.Presentation)
Inheritance Hierarchy
ImageGear22.Presentation Assembly : ImageGear.Display Namespace
In the ImageGear22.Presentation Assembly, the ImageGear.Display namespace provides the ImageGear for .NET API for displaying and printing in the WPF environment. For more information, see Displaying Images.
Classes
 | Class | Description
Class | ImGearDisplayScaleSettings | Abstract class which is used as the base for classes that specify a scale engine and provide settings for it.
Class | ImGearNativeDisplayScaleSettings | Specifies scale settings for scaling images using ImageGear.
Class | ImGearPresentation | Class for initialization of Presentation Assembly.
Class | ImGearPresentationPageDisplay | An advanced version of the ImGearPageDisplay class that requires the Windows Presentation Framework and the ImageGear22.Presentation.dll assembly.
Class | ImGearRenderSettings | Specifies image render settings that are specific to particular drawing operations.
Class | ImGearWpfDisplayScaleSettings | Specifies scale settings for scaling images using WPF engine.
See Also

Reference

ImageGear22.Presentation Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Display Namespace (ImageGear22.Presentation) Inheritance Hierarchy
ImageGear22.Presentation Assembly : ImageGear.Display Namespace
Inheritance Hierarchy
System.Object
ImageGear.Display.ImGearDisplayScaleSettings
ImageGear.Display.ImGearNativeDisplayScaleSettings
ImageGear.Display.ImGearWpfDisplayScaleSettings
ImageGear.Display.ImGearPresentation
ImageGear.Display.ImGearRenderSettings
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Display.ImGearPresentationPageDisplay
See Also

Reference

ImageGear22.Presentation Assembly


%%PageItemTitle%%

ImGearDisplayScaleSettings Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearDisplayScaleSettings Class
Abstract class which is used as the base for classes that specify a scale engine and provide settings for it.
Object Model
ImGearDisplayScaleSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearDisplayScaleSettings
'Usage

Dim instance As ImGearDisplayScaleSettings
public abstract class ImGearDisplayScaleSettings
public __gc abstract class ImGearDisplayScaleSettings
public ref class ImGearDisplayScaleSettings abstract
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearDisplayScaleSettings
ImageGear.Display.ImGearNativeDisplayScaleSettings
ImageGear.Display.ImGearWpfDisplayScaleSettings

See Also

Reference

ImGearDisplayScaleSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearDisplayScaleSettings Class Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearDisplayScaleSettings Class

The following tables list the members exposed by ImGearDisplayScaleSettings.

See Also

Reference

ImGearDisplayScaleSettings Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearNativeDisplayScaleSettings Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearNativeDisplayScaleSettings Class
Specifies scale settings for scaling images using ImageGear.
Object Model
ImGearNativeDisplayScaleSettings ClassIImGearResolution Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearNativeDisplayScaleSettings
   Inherits ImGearDisplayScaleSettings
'Usage

Dim instance As ImGearNativeDisplayScaleSettings
public class ImGearNativeDisplayScaleSettings : ImGearDisplayScaleSettings
public __gc class ImGearNativeDisplayScaleSettings : public ImGearDisplayScaleSettings
public ref class ImGearNativeDisplayScaleSettings : public ImGearDisplayScaleSettings
Remarks
In native scaling mode ImageGear renders only the visible part of the image, and scales it to desired display size and resolution. Use this way if you need advanced display interpolation settings that ImageGear provides, or if your application needs to display very large images.

See Displaying Images in WPF Environment for more information.

Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearDisplayScaleSettings
ImageGear.Display.ImGearNativeDisplayScaleSettings

See Also

Reference

ImGearNativeDisplayScaleSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearNativeDisplayScaleSettings Class Members
Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearNativeDisplayScaleSettings Class

The following tables list the members exposed by ImGearNativeDisplayScaleSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearNativeDisplayScaleSettings Constructor | Initializes a new instance of the ImGearNativeDisplayScaleSettings class.
Top
Public Properties
 | Name | Description
Public Property | Resolution | Gets access to the object that specifies resolution of the output device (display or printer).
Top
See Also

Reference

ImGearNativeDisplayScaleSettings Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearNativeDisplayScaleSettings Constructor

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearNativeDisplayScaleSettings Class : ImGearNativeDisplayScaleSettings Constructor
Initializes a new instance of the ImGearNativeDisplayScaleSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearNativeDisplayScaleSettings()
public ImGearNativeDisplayScaleSettings()
public: ImGearNativeDisplayScaleSettings();
public:
ImGearNativeDisplayScaleSettings();
See Also

Reference

ImGearNativeDisplayScaleSettings Class
ImGearNativeDisplayScaleSettings Members


%%PageItemTitle%% $$Properties$$

ImGearNativeDisplayScaleSettings Class Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearNativeDisplayScaleSettings Class

For a list of all members of this type, see ImGearNativeDisplayScaleSettings members.

Public Properties
 | Name | Description
Public Property | Resolution | Gets access to the object that specifies resolution of the output device (display or printer).
Top
See Also

Reference

ImGearNativeDisplayScaleSettings Class
ImageGear.Display Namespace


Resolution Property (ImGearNativeDisplayScaleSettings)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearNativeDisplayScaleSettings Class : Resolution Property
Gets access to the object that specifies resolution of the output device (display or printer).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Resolution As IImGearResolution
'Usage

Dim instance As ImGearNativeDisplayScaleSettings
Dim value As IImGearResolution

value = instance.Resolution
public IImGearResolution Resolution {get;}
public: __property IImGearResolution* get_Resolution();
public:
property IImGearResolution^ Resolution {
   IImGearResolution^ get();
}

Property Value

ImageGear.Core.IImGearResolution interface.
Remarks
Specify the resolution of the output device when display resolution is different from 96 DPI, or when printing an image.

See Displaying Images in WPF Environment for more information.

The default value is 96 DPI

.
See Also

Reference

ImGearNativeDisplayScaleSettings Class
ImGearNativeDisplayScaleSettings Members


%%PageItemTitle%%

ImGearPresentation Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentation Class
Class for initialization of Presentation Assembly.
Object Model
ImGearPresentation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ImGearPresentation
'Usage

Dim instance As ImGearPresentation
public static class ImGearPresentation
public __gc abstract __sealed class ImGearPresentation
public ref class ImGearPresentation abstract sealed
Remarks
This class is necessary for initialization of Presentation Assembly, if SVG rendering/rasterization is necessary in WinForms or Console application. In such case please add reference to the ImageGear Presentation Assembly and call Initialize method prior to using SVG drawing functionality.
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearPresentation

See Also

Reference

ImGearPresentation Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearPresentation Class Members
Methods

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentation Class

The following tables list the members exposed by ImGearPresentation.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the Presentation Assembly.
Top
See Also

Reference

ImGearPresentation Class
ImageGear.Display Namespace


%%PageItemTitle%% $$Methods$$

ImGearPresentation Class Methods

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentation Class

For a list of all members of this type, see ImGearPresentation members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Initialize | Initializes the Presentation Assembly.
Top
See Also

Reference

ImGearPresentation Class
ImageGear.Display Namespace


Initialize Method (ImGearPresentation)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentation Class : Initialize Method
Initializes the Presentation Assembly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Initialize()
'Usage

ImGearPresentation.Initialize()
public static void Initialize()
public: static void Initialize();
public:
static void Initialize();
See Also

Reference

ImGearPresentation Class
ImGearPresentation Members


%%PageItemTitle%%

ImGearPresentationPageDisplay Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class
An advanced version of the ImGearPageDisplay class that requires the Windows Presentation Framework and the ImageGear22.Presentation.dll assembly.
Object Model
ImGearPresentationPageDisplay ClassIImGearAntiAlias InterfaceImGearAnnotationPage ClassIImGearBackground InterfaceImGearDisplayChannels ClassImGearDisplayChannel ClassImGearPresentationPageDisplay ClassIImGearColorAntiAlias InterfaceIImGearDICOMDisplaySettings InterfaceImGearRasterPage ClassImGearScrollInfo StructureImGearZoomInfo StructureIImGearLayout InterfaceImGearMultichannelLUT ClassIImGearOrientation InterfaceImGearPage ClassIImGearResample InterfaceImGearScrollInfo Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearPresentationPageDisplay
   Inherits System.Windows.DependencyObject
   Implements IImGearPageDisplay
'Usage

Dim instance As ImGearPresentationPageDisplay
public sealed class ImGearPresentationPageDisplay : System.Windows.DependencyObject, IImGearPageDisplay
public __gc __sealed class ImGearPresentationPageDisplay : public System.Windows.DependencyObject, IImGearPageDisplay
public ref class ImGearPresentationPageDisplay sealed : public System.Windows.DependencyObject, IImGearPageDisplay
Remarks

This class implements a set of display API for rendering an image specified by the Page property and annotations specified by the ARTPage property in the WPF environment. It is recommended that you use the ImGearPresentationPageDisplay class for WPF and FW 3.0 applications.

The ImGearPresentationPageDisplay class has been changed to derive from the System.Windows.DependencyObject class, allowing the Page, ARTPage, Channels, DICOMDisplaySettings, LUT, Orientation, Contrast, Brightness, and Gamma properties of this class to serve as the source or target of a binding.

Deriving from System.Windows.DependencyObject does create some new requirements that may affect applications upgrading to the new version. Because DependencyObject's have thread affinity, they should only be accessed from the thread on which they were created. Take the example where, using the previous version of ImageGear, an ImGearPresentationPageDisplay instance was created and stored within a ViewModel created in a background worker thread. After upgrading to the new version of ImageGear, the display object in the ViewModel will no longer be accessible from the thread where the application's main window is running.

To overcome this change, the data which the ImGearPresentationPageDisplay object uses as input should itself be stored within the ViewModel, instead of storing the display instance. Then, you can bind the properties of ImGearPresentationPageDisplay to the ViewModel.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Display.ImGearPresentationPageDisplay

See Also

Reference

ImGearPresentationPageDisplay Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearPresentationPageDisplay Class Members
Fields Properties Methods Events

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class

The following tables list the members exposed by ImGearPresentationPageDisplay.

Public Constructors
 | Name | Description
Public Constructor | ImGearPresentationPageDisplay Constructor | Overloaded. Initializes a new instance of the ImGearPresentationPageDisplay class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ARTPageProperty | Represents ARTPage dependency property.
static (Shared in Visual Basic) | BrightnessProperty | Represents Brightness dependency property.
static (Shared in Visual Basic) | ChannelsProperty | Represents Channels dependency property.
static (Shared in Visual Basic) | ContrastProperty | Represents Contrast dependency property.
static (Shared in Visual Basic) | DICOMDisplaySettingsProperty | Represents DICOMDisplaySettings dependency property.
static (Shared in Visual Basic) | GammaProperty | Represents Gamma dependency property.
static (Shared in Visual Basic) | LUTProperty | Represents LUT dependency property.
static (Shared in Visual Basic) | OrientationProperty | Represents Orientation dependency property.
static (Shared in Visual Basic) | PageProperty | Represents Page dependency property.
Top
Public Properties
 | Name | Description
Public Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Public Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Public Property | Background | Gets background drawing attributes.
Public Property | Brightness | Gets or sets the brightness level of the displayed image.
Public Property | Channels | Gets the list of extra channels and their display options.
Public Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Public Property | Contrast | Gets or sets the contrast level of the displayed image.
Public Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Public Property | Gamma | Gets or sets the gamma level of the displayed image.
Public Property | Layout | Gets image display layout settings.
Public Property | LUT | Gets or sets a display lookup table.
Public Property | Orientation | Gets image orientation attributes.
Public Property | Page | Gets or sets ImGearPage object associated with this display page.
Public Property | Resampling | Gets re-sampling attributes.
Top
Public Methods
 | Name | Description
Public Method | Clone | Copies ImGearPresentationPageDisplay class object.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
Public Method | DrawToBitmapImage | Overloaded. Draws an image in a BitmapImage object.
Public Method | DrawToCanvas | Overloaded. Draws an image in a Canvas.
Public Method | Export | Exports the image and annotations content to an ImageGear.Core.ImGearRasterPage.
Public Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Public Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Public Method | HandleScroll | Handles scrolling events.
Public Method | HandleUpdate | Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Public Method | HitTestCanvas | Returns the index of the mark located at the screen position [x, y].
Public Method | InternalUseOnly | This method is used by ImageGear internally.
Public Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Public Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Public Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Public Method | UpdateZoomFrom | Updates image zoom attributes.
Public Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
Public Events
 | Name | Description
Public Event | LUTUpdated | Occurs when the lookup table is updated.
Public Event | PageScrolled | Occurs when a page is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | ScrollChanged | Occurs when a pages is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

ImGearPresentationPageDisplay Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearPresentationPageDisplay Constructor

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ImGearPresentationPageDisplay Constructor
Initializes a new instance of the ImGearPresentationPageDisplay class.
Overload List
Overload | Description
ImGearPresentationPageDisplay Constructor(ImGearPage,ImGearAnnotationPage) | Initializes a new instance of the ImGearPresentationPageDisplay class using the specified ImGearPage and ImGearAnnotationPage objects.
ImGearPresentationPageDisplay Constructor(ImGearPage) | Initializes a new instance of the ImGearPresentationPageDisplay class using the specified ImGearPage object.
ImGearPresentationPageDisplay Constructor() | Initializes a new instance of the ImGearPresentationPageDisplay class.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


%%PageItemTitle%%

ImGearPresentationPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ImGearPresentationPageDisplay Constructor : ImGearPresentationPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)
Specifies the ImGearPage object to associate with new ImGearPresentationPageDisplay instance.
ImGearAnnotationPage object to associate with ImGearPage for display.
Initializes a new instance of the ImGearPresentationPageDisplay class using the specified ImGearPage and ImGearAnnotationPage objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage, _
   ByVal artPage As ImGearAnnotationPage _
)
'Usage

Dim page As ImGearPage
Dim artPage As ImGearAnnotationPage

Dim instance As New ImGearPresentationPageDisplay(page, artPage)
public ImGearPresentationPageDisplay(
   ImGearPage page,
   ImGearAnnotationPage artPage
)
public: ImGearPresentationPageDisplay(
   ImGearPage* page,
   ImGearAnnotationPage* artPage
)
public:
ImGearPresentationPageDisplay(
   ImGearPage^ page,
   ImGearAnnotationPage^ artPage
)

Parameters

page
Specifies the ImGearPage object to associate with new ImGearPresentationPageDisplay instance.
artPage
ImGearAnnotationPage object to associate with ImGearPage for display.

Return Value

A new instance of ImGearPresentationPageDisplay class.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
ImGearPage Class
ImGearAnnotationPage Class


%%PageItemTitle%%

ImGearPresentationPageDisplay Constructor(ImGearPage)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ImGearPresentationPageDisplay Constructor : ImGearPresentationPageDisplay Constructor(ImGearPage)
Specifies the ImGearPage object to associate with new ImGearPresentationPageDisplay instance.
Initializes a new instance of the ImGearPresentationPageDisplay class using the specified ImGearPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

Dim instance As New ImGearPresentationPageDisplay(page)
public ImGearPresentationPageDisplay(
   ImGearPage page
)
public: ImGearPresentationPageDisplay(
   ImGearPage* page
)
public:
ImGearPresentationPageDisplay(
   ImGearPage^ page
)

Parameters

page
Specifies the ImGearPage object to associate with new ImGearPresentationPageDisplay instance.

Return Value

A new instance of ImGearPresentationPageDisplay class.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
ImGearPage Class


%%PageItemTitle%%

ImGearPresentationPageDisplay Constructor()

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ImGearPresentationPageDisplay Constructor : ImGearPresentationPageDisplay Constructor()
Initializes a new instance of the ImGearPresentationPageDisplay class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPresentationPageDisplay()
public ImGearPresentationPageDisplay()
public: ImGearPresentationPageDisplay();
public:
ImGearPresentationPageDisplay();

Return Value

A new instance of ImGearPresentationPageDisplay class.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearPresentationPageDisplay Class Methods

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class

For a list of all members of this type, see ImGearPresentationPageDisplay members.

Public Methods
 | Name | Description
Public Method | Clone | Copies ImGearPresentationPageDisplay class object.
Public Method | ConvertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
Public Method | DrawToBitmapImage | Overloaded. Draws an image in a BitmapImage object.
Public Method | DrawToCanvas | Overloaded. Draws an image in a Canvas.
Public Method | Export | Exports the image and annotations content to an ImageGear.Core.ImGearRasterPage.
Public Method | GetScrollInfo | Returns new instance of image scrolling attributes object.
Public Method | GetZoomInfo | Returns a new instance of an object containing current zoom settings.
Public Method | HandleScroll | Handles scrolling events.
Public Method | HandleUpdate | Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Public Method | HitTestCanvas | Returns the index of the mark located at the screen position [x, y].
Public Method | InternalUseOnly | This method is used by ImageGear internally.
Public Method | ScrollTo | Scrolls the image to the specified position and updates the scrollbars accordingly.
Public Method | UpdateLUT | Updates the ImGearPageDisplay lookup table.
Public Method | UpdateScrollFrom | Updates image scroll attributes with new values.
Public Method | UpdateZoomFrom | Updates image zoom attributes.
Public Method | ZoomToRectangle | Performs zooming to specified device rectangle and returns new zoom information.
Top
See Also

Reference

ImGearPresentationPageDisplay Class
ImageGear.Display Namespace


Clone Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Clone Method
Copies ImGearPresentationPageDisplay class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearPresentationPageDisplay

value = instance.Clone()
public ImGearPresentationPageDisplay Clone()
public: ImGearPresentationPageDisplay* Clone();
public:
ImGearPresentationPageDisplay^ Clone();

Return Value

New instance of ImGearPresentationPageDisplay class object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ConvertCoordinates Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Overload List
Overload | Description
ConvertCoordinates(Canvas,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) | Translates coordinates between image and device coordinate systems.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ConvertCoordinates(Canvas,ImGearCoordConvModes,Array) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ConvertCoordinates Method : ConvertCoordinates(Canvas,ImGearCoordConvModes,Array) Method
Represents the canvas object on which the image is drawn.
Specifies translation direction.
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint). Device coordinates are expressed in WPF device independent units (1/96th inch per unit).
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal canvas As Canvas, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim canvas As Canvas
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(canvas, mode, array)
public void ConvertCoordinates(
   Canvas canvas,
   ImGearCoordConvModes mode,
   Array array
)
public: void ConvertCoordinates(
   Canvas* canvas,
   ImGearCoordConvModes mode,
   Array* array
)
public:
void ConvertCoordinates(
   Canvas^ canvas,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

canvas
Represents the canvas object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint). Device coordinates are expressed in WPF device independent units (1/96th inch per unit).
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List


ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,Array) Method
IImGearScrollableView interface; represents .NET form to draw the image on.
Graphics object used to draw the image.
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
Array with point coordinates.
Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal graphics As Graphics, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim graphics As Graphics
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, graphics, mode, array)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   Graphics graphics,
   ImGearCoordConvModes mode,
   Array array
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   Graphics* graphics,
   ImGearCoordConvModes mode,
   Array* array
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   Graphics^ graphics,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image on.
graphics
Graphics object used to draw the image.
mode
Specifies translation direction; eitherIMAGE_TO_DEVICE orDEVICE_TO_IMAGE.
array
Array with point coordinates.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > ConvertCoordinates Method : ConvertCoordinates(IImGearScrollableView,ImGearCoordConvModes,Array) Method
Represents the scrollable view object on which the image is drawn.
Specifies translation direction.
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Translates coordinates between image and device coordinate systems.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ConvertCoordinates( _
   ByVal pageView As IImGearScrollableView, _
   ByVal mode As ImGearCoordConvModes, _
   ByVal array As Array _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim mode As ImGearCoordConvModes
Dim array As Array

instance.ConvertCoordinates(pageView, mode, array)
public void ConvertCoordinates(
   IImGearScrollableView pageView,
   ImGearCoordConvModes mode,
   Array array
)
public: void ConvertCoordinates(
   IImGearScrollableView* pageView,
   ImGearCoordConvModes mode,
   Array* array
)
public:
void ConvertCoordinates(
   IImGearScrollableView^ pageView,
   ImGearCoordConvModes mode,
   Array^ array
)

Parameters

pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates (ImageGear.Core.ImGearPoint or ImageGear.Core.ImGearDoublePoint).
Remarks

In GDI+ environment, device coordinates are expressed in pixels.

In .Net WPF environment, device coordinates are expressed in WPF device independent units (1/96th inch per unit).

If you display or print an image without an IImGearScrollableView object, use one of these overloads:

  • In GDI+: ConvertCoordinates(IImGearScrollableView, System.Drawing.Graphics, ImGearCoordConvModes, System.Array)
  • In WPF: ConvertCoordinates(System.Windows.Controls.Canvas, ImGearCoordConvModes, System.Array).
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearCoordConvModes Enumeration


DrawToBitmapImage Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : DrawToBitmapImage Method
Draws an image in a BitmapImage object.
Overload List
Overload | Description
DrawToBitmapImage(IImGearScrollableView,BitmapImage) | Draws an image in a BitmapImage object.
DrawToBitmapImage(IImGearScrollableView,BitmapImage,ImGearRenderSettings) | Draws an image in a BitmapImage object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


DrawToBitmapImage(IImGearScrollableView,BitmapImage) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > DrawToBitmapImage Method : DrawToBitmapImage(IImGearScrollableView,BitmapImage) Method
A Scrollable View object that defines image position.
BitmapImage object to draw image in.
Draws an image in a BitmapImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawToBitmapImage( _
   ByVal pageView As IImGearScrollableView, _
   ByVal bitmapImage As BitmapImage _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim bitmapImage As BitmapImage

instance.DrawToBitmapImage(pageView, bitmapImage)
public void DrawToBitmapImage(
   IImGearScrollableView pageView,
   BitmapImage bitmapImage
)
public: void DrawToBitmapImage(
   IImGearScrollableView* pageView,
   BitmapImage* bitmapImage
)
public:
void DrawToBitmapImage(
   IImGearScrollableView^ pageView,
   BitmapImage^ bitmapImage
)

Parameters

pageView
A Scrollable View object that defines image position.
bitmapImage
BitmapImage object to draw image in.
Remarks
This BitmapImage can then be used with various Source properties for certain UIElements. The method does not take into account display layout settings, such as orientation or alignment. The method does not draw annotations that are attached to the PageDisplay object. Use DrawToCanvas(IImGearScrollableView,Canvas) method to display an image taking into account layout settings, or to draw the image with annotations. Dimensions of result bitmap (in pixels) are equal to dimensions of pageView (in WPF device independent units, 1/96th of an inch). This provides exact rendering of images when display uses the standard resolution of 96 DPI. If display resolution is different, or if the image is rendered for printing, use DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings)
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface


DrawToBitmapImage(IImGearScrollableView,BitmapImage,ImGearRenderSettings) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > DrawToBitmapImage Method : DrawToBitmapImage(IImGearScrollableView,BitmapImage,ImGearRenderSettings) Method
A Scrollable View object that defines image position.
BitmapImage object to draw image in.
Speifies rendering settings, such as resolution of the output device.
Draws an image in a BitmapImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawToBitmapImage( _
   ByVal pageView As IImGearScrollableView, _
   ByVal bitmapImage As BitmapImage, _
   ByVal settings As ImGearRenderSettings _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim bitmapImage As BitmapImage
Dim settings As ImGearRenderSettings

instance.DrawToBitmapImage(pageView, bitmapImage, settings)
public void DrawToBitmapImage(
   IImGearScrollableView pageView,
   BitmapImage bitmapImage,
   ImGearRenderSettings settings
)
public: void DrawToBitmapImage(
   IImGearScrollableView* pageView,
   BitmapImage* bitmapImage,
   ImGearRenderSettings* settings
)
public:
void DrawToBitmapImage(
   IImGearScrollableView^ pageView,
   BitmapImage^ bitmapImage,
   ImGearRenderSettings^ settings
)

Parameters

pageView
A Scrollable View object that defines image position.
bitmapImage
BitmapImage object to draw image in.
settings
Speifies rendering settings, such as resolution of the output device.
Remarks
This BitmapImage can then be used with various Source properties for certain UIElements. The method does not take into account display layout settings, such as orientation or alignment. The method does not draw annotations that are attached to the PageDisplay object. Use DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings) method to display an image taking into account layout settings, or to draw the image with annotations.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearRenderSettings Class


DrawToCanvas Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : DrawToCanvas Method
Draws an image in a Canvas.
Overload List
Overload | Description
DrawToCanvas(IImGearScrollableView,Canvas) | Draws an image in a Canvas.
DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings) | Draws an image in a Canvas. If ImGearPresentationPageDisplay class object contains annotations attached to it, the method optionally draws the annotations as well.
DrawToCanvas(Canvas,ImGearRenderSettings) | Draws an image in a Canvas.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


DrawToCanvas(IImGearScrollableView,Canvas) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > DrawToCanvas Method : DrawToCanvas(IImGearScrollableView,Canvas) Method
A Scrollable View object that defines image position.
Canvas object to draw the image in.
Draws an image in a Canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawToCanvas( _
   ByVal pageView As IImGearScrollableView, _
   ByVal canvas As Canvas _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim canvas As Canvas

instance.DrawToCanvas(pageView, canvas)
public void DrawToCanvas(
   IImGearScrollableView pageView,
   Canvas canvas
)
public: void DrawToCanvas(
   IImGearScrollableView* pageView,
   Canvas* canvas
)
public:
void DrawToCanvas(
   IImGearScrollableView^ pageView,
   Canvas^ canvas
)

Parameters

pageView
A Scrollable View object that defines image position.
canvas
Canvas object to draw the image in.
Remarks
An Image element is created and positioned within the canvas based on the pageView parameter. Dimensions of a bitmap in the result Image element (in pixels) are equal to dimensions of pageView (in WPF device independent units, 1/96th of an inch). This provides exact rendering of images when display uses the standard resolution of 96 DPI. If display resolution is different, or if the image is rendered for printing, use DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings).
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface


DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > DrawToCanvas Method : DrawToCanvas(IImGearScrollableView,Canvas,ImGearRenderSettings) Method
A Scrollable View object that defines image position.
Canvas object in which to draw the image.
Specifies rendering settings, such as scale mode and resolution.
Draws an image in a Canvas. If ImGearPresentationPageDisplay class object contains annotations attached to it, the method optionally draws the annotations as well.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawToCanvas( _
   ByVal pageView As IImGearScrollableView, _
   ByVal canvas As Canvas, _
   ByVal renderSettings As ImGearRenderSettings _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim canvas As Canvas
Dim renderSettings As ImGearRenderSettings

instance.DrawToCanvas(pageView, canvas, renderSettings)
public void DrawToCanvas(
   IImGearScrollableView pageView,
   Canvas canvas,
   ImGearRenderSettings renderSettings
)
public: void DrawToCanvas(
   IImGearScrollableView* pageView,
   Canvas* canvas,
   ImGearRenderSettings* renderSettings
)
public:
void DrawToCanvas(
   IImGearScrollableView^ pageView,
   Canvas^ canvas,
   ImGearRenderSettings^ renderSettings
)

Parameters

pageView
A Scrollable View object that defines image position.
canvas
Canvas object in which to draw the image.
renderSettings
Specifies rendering settings, such as scale mode and resolution.
Remarks

An Image element is created and positioned within the canvas based on the pageView parameter. The method supports passing specific resolution for rendering, or scaling the image with the help of the WPF engine.

When using this method for printing, the application shall explicitly call Measure and Arrange methods of the canvas after calling the DrawToCanvas method and before calling PrintDialog.PrintVisual method or XpsDocumentWriter.Write method.

See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
IImGearScrollableView Interface
ImGearRenderSettings Class


DrawToCanvas(Canvas,ImGearRenderSettings) Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class > DrawToCanvas Method : DrawToCanvas(Canvas,ImGearRenderSettings) Method
Canvas object to draw the image in.
Specifies rendering settings, such as scale mode and resolution.
Draws an image in a Canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawToCanvas( _
   ByVal canvas As Canvas, _
   ByVal renderSettings As ImGearRenderSettings _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim canvas As Canvas
Dim renderSettings As ImGearRenderSettings

instance.DrawToCanvas(canvas, renderSettings)
public void DrawToCanvas(
   Canvas canvas,
   ImGearRenderSettings renderSettings
)
public: void DrawToCanvas(
   Canvas* canvas,
   ImGearRenderSettings* renderSettings
)
public:
void DrawToCanvas(
   Canvas^ canvas,
   ImGearRenderSettings^ renderSettings
)

Parameters

canvas
Canvas object to draw the image in.
renderSettings
Specifies rendering settings, such as scale mode and resolution.
Remarks

An Image element is created within the canvas based on the display settings. The application shall set Width and Height properties of the Canvas before calling this method. The method supports passing specific resolution for rendering, or scaling the image with the help of the WPF engine. If ImGearPresentationPageDisplay class object contains annotations attached to it, the method optionally draws the annotations as well.

When using this method for printing, the application shall explicitly call Measure and Arrange methods of the canvas after calling the DrawToCanvas method and before calling PrintDialog.PrintVisual method or XpsDocumentWriter.Write method.

See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
Overload List
ImGearRenderSettings Class


Export Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Export Method
Exports the image and annotations content to an ImageGear.Core.ImGearRasterPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Export() As ImGearRasterPage
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearRasterPage

value = instance.Export()
public ImGearRasterPage Export()
public: ImGearRasterPage* Export();
public:
ImGearRasterPage^ Export();

Return Value

ImageGear.Core.ImGearRasterPage class object.
Remarks

This method renders the image represented by the Page property and the annotations represented by the ARTPage property using the WPF, and exports the result composition to an ImageGear.Core.ImGearRasterPage object. It renders the image with the actual size ignoring display contrast and transform settings, and maintains the original image page orientation.

See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


GetScrollInfo Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : GetScrollInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns new instance of image scrolling attributes object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetScrollInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearScrollInfo
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearScrollInfo

value = instance.GetScrollInfo(pageView)
public ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView pageView
)
public: ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView* pageView
)
public:
ImGearScrollInfo GetScrollInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearScrollInfo structure object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


GetZoomInfo Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : GetZoomInfo Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Returns a new instance of an object containing current zoom settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetZoomInfo( _
   ByVal pageView As IImGearScrollableView _
) As ImGearZoomInfo
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim value As ImGearZoomInfo

value = instance.GetZoomInfo(pageView)
public ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView pageView
)
public: ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView* pageView
)
public:
ImGearZoomInfo GetZoomInfo(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.

Return Value

New instance of ImGearZoomInfo structure object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearZoomInfo Structure
IImGearScrollableView Interface


HandleScroll Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : HandleScroll Method
IImGearScrollableView interface, represents .NET Form to draw image in.
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
Scroll value. Specifies new scrolling position.
Handles scrolling events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HandleScroll( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollValue As Integer _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollBarType As ImGearScrollBarType
Dim scrollValue As Integer

instance.HandleScroll(pageView, scrollBarType, scrollValue)
public void HandleScroll(
   IImGearScrollableView pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
public: void HandleScroll(
   IImGearScrollableView* pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)
public:
void HandleScroll(
   IImGearScrollableView^ pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)

Parameters

pageView
IImGearScrollableView interface, represents .NET Form to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position.
Remarks
Use this method only to handle scrolling events. To scroll image to particular position, use ScrollTo method instead.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearScrollableView Interface
ImGearScrollBarType Enumeration


HandleUpdate Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : HandleUpdate Method
IImGearScrollableView page view control to draw image in.
Handles update event. This handler is called synchronously by page view control, when its Update() method is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HandleUpdate( _
   ByVal pageView As IImGearScrollableView _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView

instance.HandleUpdate(pageView)
public void HandleUpdate(
   IImGearScrollableView pageView
)
public: void HandleUpdate(
   IImGearScrollableView* pageView
)
public:
void HandleUpdate(
   IImGearScrollableView^ pageView
)

Parameters

pageView
IImGearScrollableView page view control to draw image in.
Remarks
The Update() method of page view control can make updates to the page display asynchronously. It means, that some parameters of the page display may be incorrect immediately after calling the Update() method of page view. As a result some methods, such as GetZoomInfo may return incorrect results.

This method synchronizes the internal data structures. Any custom page viewer, which implements IImGearScrollableView interface, should call this handler from Update() method to allow the page display to update some internal parameters synchronously.

See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


HitTestCanvas Method

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : HitTestCanvas Method
Screen position.
PageView control that contains the marks.
System context.
Offset from left.
Offset from top.
Returns the index of the mark located at the screen position [x, y].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function HitTestCanvas( _
   ByVal devicePoint As ImGearDoublePoint, _
   ByVal pageView As IImGearScrollableView, _
   ByVal context As Canvas, _
   ByVal offsetLeft As Integer, _
   ByVal offsetTop As Integer _
) As Integer
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim devicePoint As ImGearDoublePoint
Dim pageView As IImGearScrollableView
Dim context As Canvas
Dim offsetLeft As Integer
Dim offsetTop As Integer
Dim value As Integer

value = instance.HitTestCanvas(devicePoint, pageView, context, offsetLeft, offsetTop)
public int HitTestCanvas(
   ImGearDoublePoint devicePoint,
   IImGearScrollableView pageView,
   Canvas context,
   int offsetLeft,
   int offsetTop
)
public: int HitTestCanvas(
   ImGearDoublePoint devicePoint,
   IImGearScrollableView* pageView,
   Canvas* context,
   int offsetLeft,
   int offsetTop
)
public:
int HitTestCanvas(
   ImGearDoublePoint devicePoint,
   IImGearScrollableView^ pageView,
   Canvas^ context,
   int offsetLeft,
   int offsetTop
)

Parameters

devicePoint
Screen position.
pageView
PageView control that contains the marks.
context
System context.
offsetLeft
Offset from left.
offsetTop
Offset from top.

Return Value

Integer value.
Remarks
If there are no marks at [x,y], the return value from this method is -1.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


InternalUseOnly Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : InternalUseOnly Method
This method is used by ImageGear internally.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function InternalUseOnly() As Object
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As Object

value = instance.InternalUseOnly()
public object InternalUseOnly()
public: Object* InternalUseOnly();
public:
Object^ InternalUseOnly();

Return Value

An object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ScrollTo Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ScrollTo Method
IImGearScrollableView interface; represents .NET form to draw the image in.
New horizontal scroll position.
New vertical scroll position.
Scrolls the image to the specified position and updates the scrollbars accordingly.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ScrollTo( _
   ByVal pageView As IImGearScrollableView, _
   ByVal positionX As Integer, _
   ByVal positionY As Integer _
) As ImGearScrollInfo
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim positionX As Integer
Dim positionY As Integer
Dim value As ImGearScrollInfo

value = instance.ScrollTo(pageView, positionX, positionY)
public ImGearScrollInfo ScrollTo(
   IImGearScrollableView pageView,
   int positionX,
   int positionY
)
public: ImGearScrollInfo ScrollTo(
   IImGearScrollableView* pageView,
   int positionX,
   int positionY
)
public:
ImGearScrollInfo ScrollTo(
   IImGearScrollableView^ pageView,
   int positionX,
   int positionY
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Return Value

Instance of ImGearScrollInfo structure object.
Remarks
This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with GetScrollInfo method.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearScrollInfo Structure
IImGearScrollableView Interface


UpdateLUT Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : UpdateLUT Method
Multichannel lookup table.
Contrast settings.
Updates the ImGearPageDisplay lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateLUT( _
   ByVal colorLUT As ImGearMultichannelLUT, _
   ByVal contrastSettings As IImGearContrastSettings _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim colorLUT As ImGearMultichannelLUT
Dim contrastSettings As IImGearContrastSettings

instance.UpdateLUT(colorLUT, contrastSettings)
public void UpdateLUT(
   ImGearMultichannelLUT colorLUT,
   IImGearContrastSettings contrastSettings
)
public: void UpdateLUT(
   ImGearMultichannelLUT* colorLUT,
   IImGearContrastSettings* contrastSettings
)
public:
void UpdateLUT(
   ImGearMultichannelLUT^ colorLUT,
   IImGearContrastSettings^ contrastSettings
)

Parameters

colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.
Remarks
The ImGearPageDisplay lookup table is updated as follows:
  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearMultichannelLUT Class
IImGearContrastSettings Interface


UpdateScrollFrom Method (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : UpdateScrollFrom Method
IImGearScrollableView interface; represents .NET form to draw image in.
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
Updates image scroll attributes with new values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateScrollFrom( _
   ByVal pageView As IImGearScrollableView, _
   ByVal scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim scrollInfo As ImGearScrollInfo

instance.UpdateScrollFrom(pageView, scrollInfo)
public void UpdateScrollFrom(
   IImGearScrollableView pageView,
   ImGearScrollInfo scrollInfo
)
public: void UpdateScrollFrom(
   IImGearScrollableView* pageView,
   ImGearScrollInfo scrollInfo
)
public:
void UpdateScrollFrom(
   IImGearScrollableView^ pageView,
   ImGearScrollInfo scrollInfo
)

Parameters

pageView
IImGearScrollableView interface; represents .NET form to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearScrollableView Interface
ImGearScrollInfo Structure


UpdateZoomFrom Method (ImGearPresentationPageDisplay)
Example

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : UpdateZoomFrom Method
ImGearZoomInfo object with new zoom attributes.
Updates image zoom attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateZoomFrom( _
   ByVal zoomInfo As ImGearZoomInfo _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim zoomInfo As ImGearZoomInfo

instance.UpdateZoomFrom(zoomInfo)
public void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
public: void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)
public:
void UpdateZoomFrom(
   ImGearZoomInfo zoomInfo
)

Parameters

zoomInfo
ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Get the current Zoom settings
ImGearZoomInfo igZoomInfo =
    imGearPageView.Display.GetZoomInfo(imGearPageView);
// Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Vertical.Fixed = true;
// Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2;
igZoomInfo.Vertical.Value *= 2;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
// Cause a redraw with the new zoom.
imGearPageView.Invalidate();
  • Visual Basic
'Get the current Zoom settings
Dim igZoomInfo As ImGearZoomInfo = _
    ImGearPageView1.Display.GetZoomInfo(ImGearPageView1)
'Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = True
igZoomInfo.Vertical.Fixed = True
'Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2
igZoomInfo.Vertical.Value *= 2
ImGearPageView1.Display.UpdateZoomFrom(igZoomInfo)
'Cause a redraw with the new zoom.
ImGearPageView1.Invalidate()
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearZoomInfo Structure


ZoomToRectangle Method (ImGearPresentationPageDisplay)
Example

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ZoomToRectangle Method
ImGearZoomInfo object with new zoom attributes.
Specified device rectangle.
Performs zooming to specified device rectangle and returns new zoom information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ZoomToRectangle( _
   ByVal pageView As IImGearScrollableView, _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim pageView As IImGearScrollableView
Dim rect As ImGearRectangle

instance.ZoomToRectangle(pageView, rect)
public void ZoomToRectangle(
   IImGearScrollableView pageView,
   ImGearRectangle rect
)
public: void ZoomToRectangle(
   IImGearScrollableView* pageView,
   ImGearRectangle rect
)
public:
void ZoomToRectangle(
   IImGearScrollableView^ pageView,
   ImGearRectangle rect
)

Parameters

pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle.
Remarks
This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo.Fixed field to true, calculates and modifies ImGearZoomComponentInfo.Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.
Example
  • C#
// Variable to toggle if user is currently selecting an area.
private bool m_bZoomToRectSelect = false;
// Set of points defining the selected area.
private ImGearPoint[] igPointsZoomToRect;
// Color of selection box.
private Color m_SelectorColor = Color.White;

// Method to return appropriate height for a specific width
// based upon the size of a scrollable view.
private int GetHeight(IImGearScrollableView igScrollableView, int Width)
{
    return Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width;
}

private void menuZoomToRect_Click(object sender, EventArgs e)
{
    // Menu item used to toggle if Zoom to Rectangle is on or not.
    menuZoomToRect.Checked = !menuZoomToRect.Checked;
}

private void imGearPageView1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (menuZoomToRect.Checked)
    {
        // Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = true;
        // Create a new pair of points to define the rectangle,
        // setting the first point to the current position.
        igPointsZoomToRect = new ImGearPoint[2];
        igPointsZoomToRect[0].X = e.X;
        igPointsZoomToRect[0].Y = e.Y;
        // Register method to draw the selection rectangle.
        imGearPageView.RegisterAfterDraw(
            new ImGearPageView.AfterDraw(DrawSelector));
    }
}

private void imGearPageView1_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Leave Zoom to Rectangle selection mode.
        imGearPageView.RegisterAfterDraw(null);
        m_bZoomToRectSelect = false;
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Create a rectangle based upon the 2 points.
        ImGearRectangle igRectangle = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        if (igRectangle.Width <= 1 || igRectangle.Height <= 1)
            return;
        // Zoom to the selected rectangle
        imGearPageView.Display.ZoomToRectangle(imGearPageView, igRectangle);
        imGearPageView.Invalidate();
        // Disable Zoom to Rectangle.
        menuZoomToRect.Checked = false;
    }
}

private void imGearPageView1_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Cause a redraw which will update the zoom selection rectangle.
        imGearPageView.Invalidate();
    }
}

private void DrawSelector(System.Drawing.Graphics gr)
{
    if (m_bZoomToRectSelect)
    {
        // Create a new pen to draw dotted lines.
        Pen pen = new Pen(m_SelectorColor);
        pen.DashStyle = DashStyle.Dot;
        // Define the currently selected zoom rectangle.
        ImGearRectangle igRectangleZoom = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top,
            igRectangleZoom.Width, igRectangleZoom.Height);
    }
}
  • Visual Basic
'Variable to toggle if user is currently selecting an area.
Private m_bZoomToRectSelect As Boolean = False
'Set of points defining the selected area.
Private igPointsZoomToRect() As ImGearPoint
'Color of selection box.
Private m_SelectorColor As Color = Color.White

'Function to return appropriate height for a specific width
' based upon the size of a scrollable view.
Private Function GetHeight(ByVal igScrollableView As IImGearScrollableView, ByVal Width As Integer) As Integer
    GetHeight = Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width
End Function

Private Sub menuZoomtoRect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles menuZoomtoRect.Click
    menuZoomtoRect.Checked = Not menuZoomtoRect.Checked
End Sub

Private Sub ImGearPageView1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseDown
    If (menuZoomtoRect.Checked) Then
        'Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = True
        'Create a new pair of points to define the rectangle,
        ' setting the first point to the current position.
        ReDim igPointsZoomToRect(2)
        igPointsZoomToRect(0).X = e.X
        igPointsZoomToRect(0).Y = e.Y
        'Register function to draw the selection rectangle.
        ImGearPageView1.RegisterAfterDraw( _
            New ImGearPageView.AfterDraw(AddressOf DrawSelector))
    End If
End Sub

Private Sub ImGearPageView1_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseUp
    If (m_bZoomToRectSelect) Then
        'Leave Zoom to Rectangle selection mode.
        ImGearPageView1.RegisterAfterDraw(Nothing)
        m_bZoomToRectSelect = False
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Create a rectangle based upon the 2 points.
        Dim igRectangle As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        If (igRectangle.Width <= 1 Or igRectangle.Height <= 1) Then
            Return
        End If
        'Zoom to the selected rectangle
        ImGearPageView1.Display.ZoomToRectangle(ImGearPageView1, igRectangle)
        ImGearPageView1.Invalidate()
        'Disable Zoom to Rectangle.
        menuZoomtoRect.Checked = False
    End If
End Sub

Private Sub ImGearPageView1_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseMove
    If (m_bZoomToRectSelect) Then
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Cause a redraw which will update the zoom selection rectangle.
        ImGearPageView1.Invalidate()
    End If
End Sub

Private Sub DrawSelector(ByVal gr As System.Drawing.Graphics)
    If (m_bZoomToRectSelect) Then
        'Create a new pen to draw dotted lines.
        Dim pen As Pen = New Pen(m_SelectorColor)
        Pen.DashStyle = DashStyle.Dot
        'Define the currently selected zoom rectangle.
        Dim igRectangleZoom As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top, igRectangleZoom.Width, igRectangleZoom.Height)
    End If
End Sub
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearScrollableView Interface
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

ImGearPresentationPageDisplay Class Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class

For a list of all members of this type, see ImGearPresentationPageDisplay members.

Public Properties
 | Name | Description
Public Property | AntiAliasing | Gets bitonal anti-aliasing settings.
Public Property | ARTPage | Gets or sets ImGearAnnotationPage object associated with this display page.
Public Property | Background | Gets background drawing attributes.
Public Property | Brightness | Gets or sets the brightness level of the displayed image.
Public Property | Channels | Gets the list of extra channels and their display options.
Public Property | ColorAntiAliasing | Gets color anti-aliasing attributes.
Public Property | Contrast | Gets or sets the contrast level of the displayed image.
Public Property | DICOMDisplaySettings | Gets or sets the DICOM specific display contrast settings.
Public Property | Gamma | Gets or sets the gamma level of the displayed image.
Public Property | Layout | Gets image display layout settings.
Public Property | LUT | Gets or sets a display lookup table.
Public Property | Orientation | Gets image orientation attributes.
Public Property | Page | Gets or sets ImGearPage object associated with this display page.
Public Property | Resampling | Gets re-sampling attributes.
Top
See Also

Reference

ImGearPresentationPageDisplay Class
ImageGear.Display Namespace


AntiAliasing Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : AntiAliasing Property
Gets bitonal anti-aliasing settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AntiAliasing As IImGearAntiAlias
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearAntiAlias

value = instance.AntiAliasing
public IImGearAntiAlias AntiAliasing {get;}
public: __property IImGearAntiAlias* get_AntiAliasing();
public:
property IImGearAntiAlias^ AntiAliasing {
   IImGearAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearAntiAlias Interface


ARTPage Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ARTPage Property
Gets or sets ImGearAnnotationPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property ARTPage As ImGearAnnotationPage
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearAnnotationPage

instance.ARTPage = value

value = instance.ARTPage
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public ImGearAnnotationPage ARTPage {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ImGearAnnotationPage* get_ARTPage();
public: __property void set_ARTPage(
   ImGearAnnotationPage* value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ImGearAnnotationPage^ ARTPage {
   ImGearAnnotationPage^ get();
   void set (    ImGearAnnotationPage^ value);
}

Property Value

ImGearAnnotationPage class.
Remarks
Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class ImageGear.ART.ImGearARTPage class, defined in ImageGear22.Art assembly.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


Background Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Background Property
Gets background drawing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Background As IImGearBackground
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearBackground

value = instance.Background
public IImGearBackground Background {get;}
public: __property IImGearBackground* get_Background();
public:
property IImGearBackground^ Background {
   IImGearBackground^ get();
}

Property Value

IImGearBackground interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

For ImGearPresentationPageDisplay the value of IImGearBackground.IImGearBackground.Mode by default is ImGearBackgroundModes.NONE. To enable backgroud drawing for the ImGearPresentationPageDisplay, please set the IImGearBackground.IImGearBackground.Mode to ImGearBackgroundModes.BEYOND_IMAGE value.

See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearBackground Interface


Brightness Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Brightness Property
Gets or sets the brightness level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Brightness As Double
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As Double

instance.Brightness = value

value = instance.Brightness
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public double Brightness {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property double get_Brightness();
public: __property void set_Brightness(
   double value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property double Brightness {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


Channels Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Channels Property
Gets the list of extra channels and their display options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public ReadOnly Property Channels As ImGearDisplayChannels
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearDisplayChannels

value = instance.Channels
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public ImGearDisplayChannels Channels {get;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ImGearDisplayChannels* get_Channels();
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ImGearDisplayChannels^ Channels {
   ImGearDisplayChannels^ get();
}

Property Value

ImageGear.Core.ImGearDisplayChannels class object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearDisplayChannels Class


ColorAntiAliasing Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ColorAntiAliasing Property
Gets color anti-aliasing attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorAntiAliasing As IImGearColorAntiAlias
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearColorAntiAlias

value = instance.ColorAntiAliasing
public IImGearColorAntiAlias ColorAntiAliasing {get;}
public: __property IImGearColorAntiAlias* get_ColorAntiAliasing();
public:
property IImGearColorAntiAlias^ ColorAntiAliasing {
   IImGearColorAntiAlias^ get();
}

Property Value

IImGearAntiAlias interface.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearAntiAlias Interface


Contrast Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Contrast Property
Gets or sets the contrast level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Contrast As Double
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As Double

instance.Contrast = value

value = instance.Contrast
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public double Contrast {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property double get_Contrast();
public: __property void set_Contrast(
   double value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property double Contrast {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


DICOMDisplaySettings Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : DICOMDisplaySettings Property
Gets or sets the DICOM specific display contrast settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property DICOMDisplaySettings As IImGearDICOMDisplaySettings
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearDICOMDisplaySettings

instance.DICOMDisplaySettings = value

value = instance.DICOMDisplaySettings
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public IImGearDICOMDisplaySettings DICOMDisplaySettings {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property IImGearDICOMDisplaySettings* get_DICOMDisplaySettings();
public: __property void set_DICOMDisplaySettings(
   IImGearDICOMDisplaySettings* value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property IImGearDICOMDisplaySettings^ DICOMDisplaySettings {
   IImGearDICOMDisplaySettings^ get();
   void set (    IImGearDICOMDisplaySettings^ value);
}

Property Value

ImageGear.Core.IImGearDICOMDisplaySettings interface.
Remarks
DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of ImageGear.Core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An ImageGear.Core.IImGearDICOMDisplaySettings interface object can be attached to an ImageGear.Core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImageGear.Core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This property affects grayscale images with bit depths from 2 to 16. Type of this property is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast ImageGear.Core.IImGearDICOMDisplaySettings interface to the actual class ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings class. The default value is null.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearDICOMDisplaySettings Interface
ImGearDICOMDisplaySettings Class


Gamma Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Gamma Property
Gets or sets the gamma level of the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Gamma As Double
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As Double

instance.Gamma = value

value = instance.Gamma
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public double Gamma {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property double get_Gamma();
public: __property void set_Gamma(
   double value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property double Gamma {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


Layout Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Layout Property
Gets image display layout settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Layout As IImGearLayout
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearLayout

value = instance.Layout
public IImGearLayout Layout {get;}
public: __property IImGearLayout* get_Layout();
public:
property IImGearLayout^ Layout {
   IImGearLayout^ get();
}

Property Value

IImGearLayout interface.
Remarks
Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearLayout Interface


LUT Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : LUT Property
Gets or sets a display lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property LUT As ImGearMultichannelLUT
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearMultichannelLUT

instance.LUT = value

value = instance.LUT
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public ImGearMultichannelLUT LUT {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ImGearMultichannelLUT* get_LUT();
public: __property void set_LUT(
   ImGearMultichannelLUT* value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ImGearMultichannelLUT^ LUT {
   ImGearMultichannelLUT^ get();
   void set (    ImGearMultichannelLUT^ value);
}

Property Value

ImageGear.Core.ImGearMultichannelLUT class.
Remarks
This property only supports ImageGear.Core.ImGearRGBLUT class objects.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearMultichannelLUT Class


Orientation Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Orientation Property
Gets image orientation attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public ReadOnly Property Orientation As IImGearOrientation
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearOrientation

value = instance.Orientation
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public IImGearOrientation Orientation {get;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property IImGearOrientation* get_Orientation();
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property IImGearOrientation^ Orientation {
   IImGearOrientation^ get();
}

Property Value

ImageGear.Core.ImGearOrientation structure.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearOrientation Structure


Page Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Page Property
Gets or sets ImGearPage object associated with this display page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Page As ImGearPage
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As ImGearPage

instance.Page = value

value = instance.Page
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public ImGearPage Page {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

Valid ImageGear.Core.ImGearPage class object or null.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
ImGearPage Class


Resampling Property (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : Resampling Property
Gets re-sampling attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Resampling As IImGearResample
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim value As IImGearResample

value = instance.Resampling
public IImGearResample Resampling {get;}
public: __property IImGearResample* get_Resampling();
public:
property IImGearResample^ Resampling {
   IImGearResample^ get();
}

Property Value

IImGearResample interface object.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members
IImGearResample Interface


%%PageItemTitle%% $$Fields$$

ImGearPresentationPageDisplay Class Fields

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class

For a list of all members of this type, see ImGearPresentationPageDisplay members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ARTPageProperty | Represents ARTPage dependency property.
static (Shared in Visual Basic) | BrightnessProperty | Represents Brightness dependency property.
static (Shared in Visual Basic) | ChannelsProperty | Represents Channels dependency property.
static (Shared in Visual Basic) | ContrastProperty | Represents Contrast dependency property.
static (Shared in Visual Basic) | DICOMDisplaySettingsProperty | Represents DICOMDisplaySettings dependency property.
static (Shared in Visual Basic) | GammaProperty | Represents Gamma dependency property.
static (Shared in Visual Basic) | LUTProperty | Represents LUT dependency property.
static (Shared in Visual Basic) | OrientationProperty | Represents Orientation dependency property.
static (Shared in Visual Basic) | PageProperty | Represents Page dependency property.
Top
See Also

Reference

ImGearPresentationPageDisplay Class
ImageGear.Display Namespace


ARTPageProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ARTPageProperty Field
Represents ARTPage dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ARTPageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.ARTPageProperty
public static readonly DependencyProperty ARTPageProperty
public: static readonly DependencyProperty* ARTPageProperty
public:
static readonly DependencyProperty^ ARTPageProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


BrightnessProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : BrightnessProperty Field
Represents Brightness dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly BrightnessProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.BrightnessProperty
public static readonly DependencyProperty BrightnessProperty
public: static readonly DependencyProperty* BrightnessProperty
public:
static readonly DependencyProperty^ BrightnessProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ChannelsProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ChannelsProperty Field
Represents Channels dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ChannelsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.ChannelsProperty
public static readonly DependencyProperty ChannelsProperty
public: static readonly DependencyProperty* ChannelsProperty
public:
static readonly DependencyProperty^ ChannelsProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ContrastProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ContrastProperty Field
Represents Contrast dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ContrastProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.ContrastProperty
public static readonly DependencyProperty ContrastProperty
public: static readonly DependencyProperty* ContrastProperty
public:
static readonly DependencyProperty^ ContrastProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


DICOMDisplaySettingsProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : DICOMDisplaySettingsProperty Field
Represents DICOMDisplaySettings dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOMDisplaySettingsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.DICOMDisplaySettingsProperty
public static readonly DependencyProperty DICOMDisplaySettingsProperty
public: static readonly DependencyProperty* DICOMDisplaySettingsProperty
public:
static readonly DependencyProperty^ DICOMDisplaySettingsProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


GammaProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : GammaProperty Field
Represents Gamma dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly GammaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.GammaProperty
public static readonly DependencyProperty GammaProperty
public: static readonly DependencyProperty* GammaProperty
public:
static readonly DependencyProperty^ GammaProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


LUTProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : LUTProperty Field
Represents LUT dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LUTProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.LUTProperty
public static readonly DependencyProperty LUTProperty
public: static readonly DependencyProperty* LUTProperty
public:
static readonly DependencyProperty^ LUTProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


OrientationProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : OrientationProperty Field
Represents Orientation dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OrientationProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.OrientationProperty
public static readonly DependencyProperty OrientationProperty
public: static readonly DependencyProperty* OrientationProperty
public:
static readonly DependencyProperty^ OrientationProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


PageProperty Field

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : PageProperty Field
Represents Page dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPresentationPageDisplay.PageProperty
public static readonly DependencyProperty PageProperty
public: static readonly DependencyProperty* PageProperty
public:
static readonly DependencyProperty^ PageProperty
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


%%PageItemTitle%% $$Events$$

ImGearPresentationPageDisplay Class Events

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearPresentationPageDisplay Class

For a list of all members of this type, see ImGearPresentationPageDisplay members.

Public Events
 | Name | Description
Public Event | LUTUpdated | Occurs when the lookup table is updated.
Public Event | PageScrolled | Occurs when a page is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | ScrollChanged | Occurs when a pages is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

ImGearPresentationPageDisplay Class
ImageGear.Display Namespace


LUTUpdated Event (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : LUTUpdated Event
Occurs when the lookup table is updated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event LUTUpdated As EventHandler
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim handler As EventHandler

AddHandler instance.LUTUpdated, handler
public event EventHandler LUTUpdated
public: __event EventHandler* LUTUpdated
public:
event EventHandler^ LUTUpdated
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


PageScrolled Event (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : PageScrolled Event
Occurs when a page is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event instead.")>
Public Event PageScrolled As EventHandler
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim handler As EventHandler

AddHandler instance.PageScrolled, handler
[Obsolete("Use the ScrollChanged event instead.")]
public event EventHandler PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public: __event EventHandler* PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public:
event EventHandler^ PageScrolled
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


PageZoomed Event (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : PageZoomed Event
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageZoomed As EventHandler
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim handler As EventHandler

AddHandler instance.PageZoomed, handler
public event EventHandler PageZoomed
public: __event EventHandler* PageZoomed
public:
event EventHandler^ PageZoomed
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


ScrollChanged Event (ImGearPresentationPageDisplay)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearPresentationPageDisplay Class : ScrollChanged Event
Occurs when a pages is scrolled or when the scrollbar visible or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ScrollChanged As ImGearScrollChangedEventHandler
'Usage

Dim instance As ImGearPresentationPageDisplay
Dim handler As ImGearScrollChangedEventHandler

AddHandler instance.ScrollChanged, handler
public event ImGearScrollChangedEventHandler ScrollChanged
public: __event ImGearScrollChangedEventHandler* ScrollChanged
public:
event ImGearScrollChangedEventHandler^ ScrollChanged
Event Data

The event handler receives an argument of type ImGearScrollChangedEventArgs containing data related to this event. The following ImGearScrollChangedEventArgs properties provide information specific to this event.

Property | Description
IsEnabled | Gets a value indicating whether the scrollbar is enabled.
IsVisible | Gets a value indicating whether the scrollbar is visible.
Redraw | Gets a value indicating whether or not the view should be redrawn.
ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
ScrollChangeType | Gets the type of scrollbar change.
ScrollInformation | Gets the scrolling information.
See Also

Reference

ImGearPresentationPageDisplay Class
ImGearPresentationPageDisplay Members


%%PageItemTitle%%

ImGearRenderSettings Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearRenderSettings Class
Specifies image render settings that are specific to particular drawing operations.
Object Model
ImGearRenderSettings ClassImGearDisplayScaleSettings ClassImGearDisplayScaleSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRenderSettings
'Usage

Dim instance As ImGearRenderSettings
public class ImGearRenderSettings
public __gc class ImGearRenderSettings
public ref class ImGearRenderSettings
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearRenderSettings

See Also

Reference

ImGearRenderSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearRenderSettings Class Members
Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearRenderSettings Class

The following tables list the members exposed by ImGearRenderSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearRenderSettings Constructor | Initializes a new instance of the ImGearRenderSettings class object.
Top
Public Properties
 | Name | Description
Public Property | AnnotationScaleSettings | Gets or sets scale settings for the annotations.
Public Property | DrawAnnotations | Gets or sets a value indicating whether the annotations should be drawn.
Public Property | DrawImage | Gets or sets a value indicating whether the image should be drawn.
Public Property | ImageScaleSettings | Gets or sets scale settings for the main image.
Top
See Also

Reference

ImGearRenderSettings Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearRenderSettings Constructor

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearRenderSettings Class : ImGearRenderSettings Constructor
Initializes a new instance of the ImGearRenderSettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRenderSettings()
public ImGearRenderSettings()
public: ImGearRenderSettings();
public:
ImGearRenderSettings();
See Also

Reference

ImGearRenderSettings Class
ImGearRenderSettings Members


%%PageItemTitle%% $$Properties$$

ImGearRenderSettings Class Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearRenderSettings Class

For a list of all members of this type, see ImGearRenderSettings members.

Public Properties
 | Name | Description
Public Property | AnnotationScaleSettings | Gets or sets scale settings for the annotations.
Public Property | DrawAnnotations | Gets or sets a value indicating whether the annotations should be drawn.
Public Property | DrawImage | Gets or sets a value indicating whether the image should be drawn.
Public Property | ImageScaleSettings | Gets or sets scale settings for the main image.
Top
See Also

Reference

ImGearRenderSettings Class
ImageGear.Display Namespace


AnnotationScaleSettings Property (ImGearRenderSettings)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearRenderSettings Class : AnnotationScaleSettings Property
Gets or sets scale settings for the annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnnotationScaleSettings As ImGearDisplayScaleSettings
'Usage

Dim instance As ImGearRenderSettings
Dim value As ImGearDisplayScaleSettings

instance.AnnotationScaleSettings = value

value = instance.AnnotationScaleSettings
public ImGearDisplayScaleSettings AnnotationScaleSettings {get; set;}
public: __property ImGearDisplayScaleSettings* get_AnnotationScaleSettings();
public: __property void set_AnnotationScaleSettings(
   ImGearDisplayScaleSettings* value
);
public:
property ImGearDisplayScaleSettings^ AnnotationScaleSettings {
   ImGearDisplayScaleSettings^ get();
   void set (    ImGearDisplayScaleSettings^ value);
}

Property Value

ImGearDisplayScaleSettings class.
See Also

Reference

ImGearRenderSettings Class
ImGearRenderSettings Members


DrawAnnotations Property

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearRenderSettings Class : DrawAnnotations Property
Gets or sets a value indicating whether the annotations should be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DrawAnnotations As Boolean
'Usage

Dim instance As ImGearRenderSettings
Dim value As Boolean

instance.DrawAnnotations = value

value = instance.DrawAnnotations
public bool DrawAnnotations {get; set;}
public: __property bool get_DrawAnnotations();
public: __property void set_DrawAnnotations(
   bool value
);
public:
property bool DrawAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearRenderSettings Class
ImGearRenderSettings Members


DrawImage Property

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearRenderSettings Class : DrawImage Property
Gets or sets a value indicating whether the image should be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DrawImage As Boolean
'Usage

Dim instance As ImGearRenderSettings
Dim value As Boolean

instance.DrawImage = value

value = instance.DrawImage
public bool DrawImage {get; set;}
public: __property bool get_DrawImage();
public: __property void set_DrawImage(
   bool value
);
public:
property bool DrawImage {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearRenderSettings Class
ImGearRenderSettings Members


ImageScaleSettings Property (ImGearRenderSettings)

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearRenderSettings Class : ImageScaleSettings Property
Gets or sets scale settings for the main image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageScaleSettings As ImGearDisplayScaleSettings
'Usage

Dim instance As ImGearRenderSettings
Dim value As ImGearDisplayScaleSettings

instance.ImageScaleSettings = value

value = instance.ImageScaleSettings
public ImGearDisplayScaleSettings ImageScaleSettings {get; set;}
public: __property ImGearDisplayScaleSettings* get_ImageScaleSettings();
public: __property void set_ImageScaleSettings(
   ImGearDisplayScaleSettings* value
);
public:
property ImGearDisplayScaleSettings^ ImageScaleSettings {
   ImGearDisplayScaleSettings^ get();
   void set (    ImGearDisplayScaleSettings^ value);
}

Property Value

ImGearDisplayScaleSettings class object.
See Also

Reference

ImGearRenderSettings Class
ImGearRenderSettings Members


%%PageItemTitle%%

ImGearWpfDisplayScaleSettings Class
Members

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearWpfDisplayScaleSettings Class
Specifies scale settings for scaling images using WPF engine.
Object Model
ImGearWpfDisplayScaleSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearWpfDisplayScaleSettings
   Inherits ImGearDisplayScaleSettings
'Usage

Dim instance As ImGearWpfDisplayScaleSettings
public class ImGearWpfDisplayScaleSettings : ImGearDisplayScaleSettings
public __gc class ImGearWpfDisplayScaleSettings : public ImGearDisplayScaleSettings
public ref class ImGearWpfDisplayScaleSettings : public ImGearDisplayScaleSettings
Remarks
In WPF scaling mode ImageGear renders the whole image in its original size just once, and then WPF scales and clips image to desired screen size and layout. Use this way for faster display, or if you need a WPF-scalable Visual object.
Inheritance Hierarchy

System.Object
ImageGear.Display.ImGearDisplayScaleSettings
ImageGear.Display.ImGearWpfDisplayScaleSettings

See Also

Reference

ImGearWpfDisplayScaleSettings Members
ImageGear.Display Namespace


%%PageItemTitle%% $$Members$$

ImGearWpfDisplayScaleSettings Class Members
Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearWpfDisplayScaleSettings Class

The following tables list the members exposed by ImGearWpfDisplayScaleSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearWpfDisplayScaleSettings Constructor | Initializes a new instance of the ImGearWpfDisplayScaleSettings class object.
Top
Public Properties
 | Name | Description
Public Property | UpdateLayoutOnly | Gets or sets a value indicating whether ImageGear actually renders the image, or just updates the layout of the image object on the canvas.
Top
See Also

Reference

ImGearWpfDisplayScaleSettings Class
ImageGear.Display Namespace


%%PageItemTitle%%

ImGearWpfDisplayScaleSettings Constructor

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearWpfDisplayScaleSettings Class : ImGearWpfDisplayScaleSettings Constructor
Initializes a new instance of the ImGearWpfDisplayScaleSettings class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearWpfDisplayScaleSettings()
public ImGearWpfDisplayScaleSettings()
public: ImGearWpfDisplayScaleSettings();
public:
ImGearWpfDisplayScaleSettings();
See Also

Reference

ImGearWpfDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Members


%%PageItemTitle%% $$Properties$$

ImGearWpfDisplayScaleSettings Class Properties

ImageGear22.Presentation Assembly > ImageGear.Display Namespace : ImGearWpfDisplayScaleSettings Class

For a list of all members of this type, see ImGearWpfDisplayScaleSettings members.

Public Properties
 | Name | Description
Public Property | UpdateLayoutOnly | Gets or sets a value indicating whether ImageGear actually renders the image, or just updates the layout of the image object on the canvas.
Top
See Also

Reference

ImGearWpfDisplayScaleSettings Class
ImageGear.Display Namespace


UpdateLayoutOnly Property

ImageGear22.Presentation Assembly > ImageGear.Display Namespace > ImGearWpfDisplayScaleSettings Class : UpdateLayoutOnly Property
Gets or sets a value indicating whether ImageGear actually renders the image, or just updates the layout of the image object on the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UpdateLayoutOnly As Boolean
'Usage

Dim instance As ImGearWpfDisplayScaleSettings
Dim value As Boolean

instance.UpdateLayoutOnly = value

value = instance.UpdateLayoutOnly
public bool UpdateLayoutOnly {get; set;}
public: __property bool get_UpdateLayoutOnly();
public: __property void set_UpdateLayoutOnly(
   bool value
);
public:
property bool UpdateLayoutOnly {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set to true for fast zooming, scrolling, or display layout updating.
See Also

Reference

ImGearWpfDisplayScaleSettings Class
ImGearWpfDisplayScaleSettings Members


ImageGear22.Processing.Advanced Assembly
Namespaces
Namespace Description
ImageGear.FreqIP

The ImageGear.FreqIP namespace has been deprecated and will be removed from the public API in a future release.

This namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc.

ImageGear.Processing

This namespace represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as remove red eye, perspective, solarize, warp, wave, etc.

ImageGear.Processing.ImageClean

This namespace contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. It now also includes the ability to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.


ImageGear.FreqIP Namespace
Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.FreqIP Namespace

The ImageGear.FreqIP namespace has been deprecated and will be removed from the public API in a future release.

This namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc.

Classes
 | Class | Description
Class | ImGearComplexObject | Objects of this type can store both real and imaginary part of complex data, which is stored internally using double precision, rather than one of the integral types as in ImageGear.Core.ImGearPage class.
Class | ImGearFrequencyProcessing | This is the main class for all frequency domain image processing operations.
Class | ImGearFrequencyProcessingVerifier | This class contains static methods that check whether the ImGearFrequencyProcessing operation is applicable to the page or not.
Enumerations
 | Enumeration | Description
Enumeration | ImGearCoObjConvType | Specifies the conversion types to convert an ImGearComplexObject class object to an ImageGear.Core.ImGearPage class object.
Enumeration | ImGearFFTScalingMethods | Defines the different scaling methods for the result of Fast Fourier Transform (FFT).
Enumeration | ImGearFreqIPFilterBrands | Defines the different kind of filter brands available.
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.FreqIP Namespace Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.FreqIP Namespace
Inheritance Hierarchy
System.Object
ImageGear.FreqIP.ImGearComplexObject
ImageGear.FreqIP.ImGearFrequencyProcessing
ImageGear.FreqIP.ImGearFrequencyProcessingVerifier
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%PageItemTitle%%

ImGearComplexObject Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearComplexObject Class
Objects of this type can store both real and imaginary part of complex data, which is stored internally using double precision, rather than one of the integral types as in ImageGear.Core.ImGearPage class.
Object Model
ImGearComplexObject ClassImGearArrayRef StructureImGearArrayRef StructureImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearComplexObject
'Usage

Dim instance As ImGearComplexObject
public sealed class ImGearComplexObject
public __gc __sealed class ImGearComplexObject
public ref class ImGearComplexObject sealed
Remarks
Objects of this type can be used as input or output for frequency domain image processing functions so as to keep the precision of the data.
Inheritance Hierarchy

System.Object
ImageGear.FreqIP.ImGearComplexObject

See Also

Reference

ImGearComplexObject Members
ImageGear.FreqIP Namespace


%%PageItemTitle%% $$Members$$

ImGearComplexObject Class Members
Properties Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearComplexObject Class

The following tables list the members exposed by ImGearComplexObject.

Public Constructors
 | Name | Description
Public Constructor | ImGearComplexObject Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets height of the object.
Public Property | Width | Gets width of the object.
Top
Public Methods
 | Name | Description
Public Method | GetImaginaryDataRaster | Gets an ImGearArrayRef to the imaginary buffer of the specified row.
Public Method | GetRealDataRaster | Gets an ImGearArrayRef to the real buffer of the specified row.
Public Method | IsValid | Checks whether an object is a valid ImGearComplexObject class object.
Public Method | ToImage | Overloaded. Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
Public Method | WithImaginaryData | Checks whether a specific ImGearComplexObject class has valid imaginary data.
Top
See Also

Reference

ImGearComplexObject Class
ImageGear.FreqIP Namespace


%%PageItemTitle%%

ImGearComplexObject Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : ImGearComplexObject Constructor
Overload List
Overload | Description
ImGearComplexObject Constructor(Int32,Int32) | Initializes a new instance of the ImGearComplexObject class with empty but allocated buffers, based on the given width and height.
ImGearComplexObject Constructor(ImGearPage,ImGearPage) | Initializes a new instance of the ImGearComplexObject class based on the given realPage and imaginaryPage.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members


%%PageItemTitle%%

ImGearComplexObject Constructor(Int32,Int32)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class > ImGearComplexObject Constructor : ImGearComplexObject Constructor(Int32,Int32)
Width of the object to be created.
Height of the object to be created.
Initializes a new instance of the ImGearComplexObject class with empty but allocated buffers, based on the given width and height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim width As Integer
Dim height As Integer

Dim instance As New ImGearComplexObject(width, height)
public ImGearComplexObject(
   int width,
   int height
)
public: ImGearComplexObject(
   int width,
   int height
)
public:
ImGearComplexObject(
   int width,
   int height
)

Parameters

width
Width of the object to be created.
height
Height of the object to be created.

Return Value

New ImGearComplexObject class object.
Remarks
This constructor creates a new complex object with empty but allocated buffers, based on the given width and height. The buffers can be populated later by obtaining pointers to the buffers.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
Overload List


%%PageItemTitle%%

ImGearComplexObject Constructor(ImGearPage,ImGearPage)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class > ImGearComplexObject Constructor : ImGearComplexObject Constructor(ImGearPage,ImGearPage)
ImageGear.Core.ImGearPage class object to to be used as the real part of the newly created object.
ImageGear.Core.ImGearPage class object to to be used as the imaginary part of the newly created object.
Initializes a new instance of the ImGearComplexObject class based on the given realPage and imaginaryPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal realPage As ImGearPage, _
   ByVal imaginaryPage As ImGearPage _
)
'Usage

Dim realPage As ImGearPage
Dim imaginaryPage As ImGearPage

Dim instance As New ImGearComplexObject(realPage, imaginaryPage)
public ImGearComplexObject(
   ImGearPage realPage,
   ImGearPage imaginaryPage
)
public: ImGearComplexObject(
   ImGearPage* realPage,
   ImGearPage* imaginaryPage
)
public:
ImGearComplexObject(
   ImGearPage^ realPage,
   ImGearPage^ imaginaryPage
)

Parameters

realPage
ImageGear.Core.ImGearPage class object to to be used as the real part of the newly created object.
imaginaryPage
ImageGear.Core.ImGearPage class object to to be used as the imaginary part of the newly created object.

Return Value

New ImGearComplexObject class object.
Remarks
This constructor creates a new object based on the given realPage and imaginaryPage.

The dimension of the newly created object is determined by the width and height of realPage and imaginaryPage. If imaginaryPage is not null, this constructor requires realPage and imaginaryPage to have the same width and height; otherwise, the width and height of realPage is used.

Data from realPage and imaginaryPage is then used respectively to populate the real and imaginary buffer in the newly created object.

Note that realPage and imaginaryPage should only have one channel with bit depth being 8, 16 or 32.

See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
Overload List
ImGearPage Class


%%PageItemTitle%% $$Methods$$

ImGearComplexObject Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearComplexObject Class

For a list of all members of this type, see ImGearComplexObject members.

Public Methods
 | Name | Description
Public Method | GetImaginaryDataRaster | Gets an ImGearArrayRef to the imaginary buffer of the specified row.
Public Method | GetRealDataRaster | Gets an ImGearArrayRef to the real buffer of the specified row.
Public Method | IsValid | Checks whether an object is a valid ImGearComplexObject class object.
Public Method | ToImage | Overloaded. Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
Public Method | WithImaginaryData | Checks whether a specific ImGearComplexObject class has valid imaginary data.
Top
See Also

Reference

ImGearComplexObject Class
ImageGear.FreqIP Namespace


GetImaginaryDataRaster Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : GetImaginaryDataRaster Method
Index of the row for which to get ImageGear.Core.ImGearArrayRef structure.
Gets an ImGearArrayRef to the imaginary buffer of the specified row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetImaginaryDataRaster( _
   ByVal rowNumber As Integer _
) As ImGearArrayRef
'Usage

Dim instance As ImGearComplexObject
Dim rowNumber As Integer
Dim value As ImGearArrayRef

value = instance.GetImaginaryDataRaster(rowNumber)
public ImGearArrayRef GetImaginaryDataRaster(
   int rowNumber
)
public: ImGearArrayRef GetImaginaryDataRaster(
   int rowNumber
)
public:
ImGearArrayRef GetImaginaryDataRaster(
   int rowNumber
)

Parameters

rowNumber
Index of the row for which to get ImageGear.Core.ImGearArrayRef structure.

Return Value

An ImageGear.Core.ImGearArrayRef structure to the imaginary buffer of the specified row.
Remarks
This method gets an ImageGear.Core.ImGearArrayRef to the imaginary buffer of the specified row.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearArrayRef Structure


GetRealDataRaster Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : GetRealDataRaster Method
Index of the row for which to get ImageGear.Core.ImGearArrayRef structure.
Gets an ImGearArrayRef to the real buffer of the specified row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRealDataRaster( _
   ByVal rowNumber As Integer _
) As ImGearArrayRef
'Usage

Dim instance As ImGearComplexObject
Dim rowNumber As Integer
Dim value As ImGearArrayRef

value = instance.GetRealDataRaster(rowNumber)
public ImGearArrayRef GetRealDataRaster(
   int rowNumber
)
public: ImGearArrayRef GetRealDataRaster(
   int rowNumber
)
public:
ImGearArrayRef GetRealDataRaster(
   int rowNumber
)

Parameters

rowNumber
Index of the row for which to get ImageGear.Core.ImGearArrayRef structure.

Return Value

An ImageGear.Core.ImGearArrayRef structure to the real buffer of the specified row.
Remarks
This method gets an ImageGear.Core.ImGearArrayRef structure to the real buffer of the specified row.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearArrayRef Structure


IsValid Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : IsValid Method
Checks whether an object is a valid ImGearComplexObject class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsValid() As Boolean
'Usage

Dim instance As ImGearComplexObject
Dim value As Boolean

value = instance.IsValid()
public bool IsValid()
public: bool IsValid();
public:
bool IsValid();

Return Value

Boolean value.
Remarks
This method checks whether an object is a valid ImGearComplexObject class object.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearComplexObject Class


ToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : ToImage Method
Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
Overload List
Overload | Description
ToImage(ImGearCoObjConvType) | Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
ToImage(ImGearCoObjConvType,Double,Double) | Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members


ToImage(ImGearCoObjConvType) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class > ToImage Method : ToImage(ImGearCoObjConvType) Method
Conversion type used to convert the object to ImageGear.Core.ImGearPage class. See ImGearCoObjConvType enumeration.
Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToImage( _
   ByVal conversionType As ImGearCoObjConvType _
) As ImGearPage
'Usage

Dim instance As ImGearComplexObject
Dim conversionType As ImGearCoObjConvType
Dim value As ImGearPage

value = instance.ToImage(conversionType)
public ImGearPage ToImage(
   ImGearCoObjConvType conversionType
)
public: ImGearPage* ToImage(
   ImGearCoObjConvType conversionType
)
public:
ImGearPage^ ToImage(
   ImGearCoObjConvType conversionType
)

Parameters

conversionType
Conversion type used to convert the object to ImageGear.Core.ImGearPage class. See ImGearCoObjConvType enumeration.

Return Value

ImageGear.Core.ImGearPage class.
Remarks
This method converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType. A complex object should be converted to ImageGear.Core.ImGearPage class only for display purposes; otherwise, it should remain in its original format to retain the data accuracy.

As an ImGearComplexObject class object contains both real and imaginary data, we need firstly to combine these two data sets into one in order to store the result in an ImageGear.Core.ImGearPage class object, using the option specified by the parameter conversionType. Options available include REAL, IMAGINARY, MAGNITUDE, etc. Please see ImGearCoObjConvType enumeration.

The dimensions of the converted ImageGear.Core.ImGearPage class object are determined by those of the complex object, with width and height being the same. The depth of the ImageGear.Core.ImGearPage class object can be 8, 16 or 32, depending on the image size. If the image size is less than or equal to (1 << 8), then the depth will be 8bit; less than or equal to (1 << 16), then 16bit; otherwise, the depth will be 32bit. Of course, the ImageGear.Core.ImGearPage class object will only have one channel.

Once the bit depth is determined, data are then scaled linearly to occupy the entire range of that bit depth and copied to the buffer of ImageGear.Core.ImGearPage class.

See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
Overload List
ImGearPage Class
ImGearCoObjConvType Enumeration


ToImage(ImGearCoObjConvType,Double,Double) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class > ToImage Method : ToImage(ImGearCoObjConvType,Double,Double) Method
Conversion type used to convert the object to ImageGear.Core.ImGearPage class. See ImGearCoObjConvType enumeration.
Returns the minimum value of the data before scaling.
Returns the scale factor.
Converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToImage( _
   ByVal conversionType As ImGearCoObjConvType, _
   ByRef minValue As Double, _
   ByRef scale As Double _
) As ImGearPage
'Usage

Dim instance As ImGearComplexObject
Dim conversionType As ImGearCoObjConvType
Dim minValue As Double
Dim scale As Double
Dim value As ImGearPage

value = instance.ToImage(conversionType, minValue, scale)
public ImGearPage ToImage(
   ImGearCoObjConvType conversionType,
   out double minValue,
   out double scale
)
public: ImGearPage* ToImage(
   ImGearCoObjConvType conversionType,
   [PARAMFLAG::Out] double minValue,
   [PARAMFLAG::Out] double scale
)
public:
ImGearPage^ ToImage(
   ImGearCoObjConvType conversionType,
   [Out] double minValue,
   [Out] double scale
)

Parameters

conversionType
Conversion type used to convert the object to ImageGear.Core.ImGearPage class. See ImGearCoObjConvType enumeration.
minValue
Returns the minimum value of the data before scaling.
scale
Returns the scale factor.

Return Value

ImageGear.Core.ImGearPage class.
Remarks
This method converts a complex object to an ImageGear.Core.ImGearPage class object, using the conversion type specified by parameter conversionType. A complex object should be converted to ImageGear.Core.ImGearPage class only for display purposes; otherwise, it should remain in its original format to retain the data accuracy.

As an ImGearComplexObject class object contains both real and imaginary data, we need firstly to combine these two data sets into one in order to store the result in an ImageGear.Core.ImGearPage class object, using the option specified by the parameter conversionType. Options available include REAL, IMAGINARY, MAGNITUDE, etc. Please see the help page for ImGearCoObjConvType enumeration.

The dimensions of the converted ImageGear.Core.ImGearPage class object are determined by those of the complex object, with width and height being the same. The depth of the ImageGear.Core.ImGearPage class object can be 8, 16 or 32, depending on the image size. If the image size is less than or equal to (1 << 8), then the depth will be 8bit; less than or equal to (1 << 16), then 16bit; otherwise, the depth will be 32bit. Of course, the ImageGear.Core.ImGearPage class object will only have one channel.

Once the bit depth is determined, data are then scaled linearly to occupy the entire range of that bit depth and copied to the buffer of ImageGear.Core.ImGearPage class. Minimum value before scaling and scale factor can be returned through minValue and scale parameters if wanted, so as to provide a coarse way to reconstruct the data.

See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
Overload List
ImGearPage Class
ImGearCoObjConvType Enumeration


WithImaginaryData Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : WithImaginaryData Method
Checks whether a specific ImGearComplexObject class has valid imaginary data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function WithImaginaryData() As Boolean
'Usage

Dim instance As ImGearComplexObject
Dim value As Boolean

value = instance.WithImaginaryData()
public bool WithImaginaryData()
public: bool WithImaginaryData();
public:
bool WithImaginaryData();

Return Value

Boolean value.
Remarks
This method checks whether a specific ImGearComplexObject class has valid imaginary data, by checking whether there is any non-zero value in the imaginary buffer. If yes, then we will assume imaginary data has been assigned; otherwise no. The reason we can use this comparison is that when any ImGearComplexObject class is created, the constructor automatically clears the data buffer to be 0.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearComplexObject Class


%%PageItemTitle%% $$Properties$$

ImGearComplexObject Class Properties

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearComplexObject Class

For a list of all members of this type, see ImGearComplexObject members.

Public Properties
 | Name | Description
Public Property | Height | Gets height of the object.
Public Property | Width | Gets width of the object.
Top
See Also

Reference

ImGearComplexObject Class
ImageGear.FreqIP Namespace


Height Property (ImGearComplexObject)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : Height Property
Gets height of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImGearComplexObject
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

Any integer value.
Remarks
This property specifies the Height of the ImGearComplexObject constructor object.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearComplexObject Class


Width Property (ImGearComplexObject)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearComplexObject Class : Width Property
Gets width of the object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImGearComplexObject
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

Any integer value.
Remarks
This property specifies the Width of the ImGearComplexObject constructor object.
See Also

Reference

ImGearComplexObject Class
ImGearComplexObject Members
ImGearComplexObject Class


%%PageItemTitle%%

ImGearFrequencyProcessing Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessing Class
This is the main class for all frequency domain image processing operations.
Object Model
ImGearFrequencyProcessing ClassImGearComplexObject ClassImGearComplexObject ClassImGearComplexObject ClassImGearComplexObject ClassImGearComplexObject ClassImGearComplexObject ClassImGearComplexObject ClassImGearPage ClassImGearComplexObject ClassImGearPage ClassImGearComplexObject ClassImGearPage ClassImGearFrequencyProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearFrequencyProcessing
'Usage

Dim instance As ImGearFrequencyProcessing
public sealed class ImGearFrequencyProcessing
public __gc __sealed class ImGearFrequencyProcessing
public ref class ImGearFrequencyProcessing sealed
Inheritance Hierarchy

System.Object
ImageGear.FreqIP.ImGearFrequencyProcessing

See Also

Reference

ImGearFrequencyProcessing Members
ImageGear.FreqIP Namespace
ImGearFrequencyProcessingVerifier Class


%%PageItemTitle%% $$Members$$

ImGearFrequencyProcessing Class Members
Properties Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessing Class

The following tables list the members exposed by ImGearFrequencyProcessing.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | IsFFTWInitialized | Gets a value indicating whether FFTW support is initialized.
static (Shared in Visual Basic) | Verifier | Gets ImGearFrequencyProcessingVerifier class to allows you to call its methods.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | BandPassFilter | Filters the input image using a band-pass filter, with the specified parameters.
static (Shared in Visual Basic) | BandStopFilter | Filters the input image using a band-stop filter, with the specified parameters.
static (Shared in Visual Basic) | Convolve | Convolves an image with the given kernel matrix.
static (Shared in Visual Basic) | ForwardDCT | Computes the forward Discrete Cosine Transform (DCT) of the input data.
static (Shared in Visual Basic) | ForwardDCTFromImage | Computes the forward Discrete Cosine Transform (DCT) of the input image.
static (Shared in Visual Basic) | ForwardDST | Computes the forward Discrete Sine Transform (DST) of the input data.
static (Shared in Visual Basic) | ForwardDSTFromImage | Computes the forward Discrete Sine Transform (DST) of the input image.
static (Shared in Visual Basic) | ForwardFFT | Performs a forward Fast Fourier Transform.
static (Shared in Visual Basic) | ForwardFFTFromImage | Performs a forward Fast Fourier Transform of the input image.
static (Shared in Visual Basic) | HighPassFilter | Filters the input image using a high-pass filter, with the specified parameters.
static (Shared in Visual Basic) | InitializeFFTW | Overloaded. Initializes the FFTW algorithm.
static (Shared in Visual Basic) | InverseDCT | Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
static (Shared in Visual Basic) | InverseDCTToImage | Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
static (Shared in Visual Basic) | InverseDST | Computes the inverse Discrete Sine Transform (IDST) of the input data.
static (Shared in Visual Basic) | InverseDSTToImage | Computes the inverse Discrete Sine Transform (IDST) of the input data.
static (Shared in Visual Basic) | InverseFFT | Performs an inverse Fast Fourier Transform.
static (Shared in Visual Basic) | InverseFFTToImage | Performs an inverse Fast Fourier Transform.
static (Shared in Visual Basic) | InverseRestore | Performs image restoration using inverse filtering in the frequency domain.
static (Shared in Visual Basic) | LowPassFilter | Filters the input image using a low-pass filter, with the specified parameters.
static (Shared in Visual Basic) | WienerRestore | Performs image restoration using Wiener filtering in the frequency domain.
Top
See Also

Reference

ImGearFrequencyProcessing Class
ImageGear.FreqIP Namespace
ImGearFrequencyProcessingVerifier Class


%%PageItemTitle%% $$Methods$$

ImGearFrequencyProcessing Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessing Class

For a list of all members of this type, see ImGearFrequencyProcessing members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BandPassFilter | Filters the input image using a band-pass filter, with the specified parameters.
static (Shared in Visual Basic) | BandStopFilter | Filters the input image using a band-stop filter, with the specified parameters.
static (Shared in Visual Basic) | Convolve | Convolves an image with the given kernel matrix.
static (Shared in Visual Basic) | ForwardDCT | Computes the forward Discrete Cosine Transform (DCT) of the input data.
static (Shared in Visual Basic) | ForwardDCTFromImage | Computes the forward Discrete Cosine Transform (DCT) of the input image.
static (Shared in Visual Basic) | ForwardDST | Computes the forward Discrete Sine Transform (DST) of the input data.
static (Shared in Visual Basic) | ForwardDSTFromImage | Computes the forward Discrete Sine Transform (DST) of the input image.
static (Shared in Visual Basic) | ForwardFFT | Performs a forward Fast Fourier Transform.
static (Shared in Visual Basic) | ForwardFFTFromImage | Performs a forward Fast Fourier Transform of the input image.
static (Shared in Visual Basic) | HighPassFilter | Filters the input image using a high-pass filter, with the specified parameters.
static (Shared in Visual Basic) | InitializeFFTW | Overloaded. Initializes the FFTW algorithm.
static (Shared in Visual Basic) | InverseDCT | Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
static (Shared in Visual Basic) | InverseDCTToImage | Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
static (Shared in Visual Basic) | InverseDST | Computes the inverse Discrete Sine Transform (IDST) of the input data.
static (Shared in Visual Basic) | InverseDSTToImage | Computes the inverse Discrete Sine Transform (IDST) of the input data.
static (Shared in Visual Basic) | InverseFFT | Performs an inverse Fast Fourier Transform.
static (Shared in Visual Basic) | InverseFFTToImage | Performs an inverse Fast Fourier Transform.
static (Shared in Visual Basic) | InverseRestore | Performs image restoration using inverse filtering in the frequency domain.
static (Shared in Visual Basic) | LowPassFilter | Filters the input image using a low-pass filter, with the specified parameters.
static (Shared in Visual Basic) | WienerRestore | Performs image restoration using Wiener filtering in the frequency domain.
Top
See Also

Reference

ImGearFrequencyProcessing Class
ImageGear.FreqIP Namespace
ImGearFrequencyProcessingVerifier Class


BandPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : BandPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Brand of the filter to use. Constants are listed in the ImGearFreqIPFilterBrands enumeration.
Lower cutoff frequency for the band-pass filter.
Higher cutoff frequency for the band-pass filter.
Filter order to use, applicable to all except Ideal filter.
A factor which determines the pass-band ripple for Chebyshev filters, with value between [0, 1].
Filters the input image using a band-pass filter, with the specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub BandPassFilter( _
   ByVal page As ImGearRasterPage, _
   ByVal filterBrand As ImGearFreqIPFilterBrands, _
   ByVal lowerCutoffFrequency As Double, _
   ByVal higherCutoffFrequency As Double, _
   ByVal filterOrder As Integer, _
   ByVal rippleFactor As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim filterBrand As ImGearFreqIPFilterBrands
Dim lowerCutoffFrequency As Double
Dim higherCutoffFrequency As Double
Dim filterOrder As Integer
Dim rippleFactor As Double

ImGearFrequencyProcessing.BandPassFilter(page, filterBrand, lowerCutoffFrequency, higherCutoffFrequency, filterOrder, rippleFactor)
public static void BandPassFilter(
   ImGearRasterPage page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public: static void BandPassFilter(
   ImGearRasterPage* page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public:
static void BandPassFilter(
   ImGearRasterPage^ page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
filterBrand
Brand of the filter to use. Constants are listed in the ImGearFreqIPFilterBrands enumeration.
lowerCutoffFrequency
Lower cutoff frequency for the band-pass filter.
higherCutoffFrequency
Higher cutoff frequency for the band-pass filter.
filterOrder
Filter order to use, applicable to all except Ideal filter.
rippleFactor
A factor which determines the pass-band ripple for Chebyshev filters, with value between [0, 1].
Remarks
This method filters the input image using a band-pass filter, with the specified parameters.

Parameter filterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameters lowerCutoffFrequency and higherCutoffFrequency specify the lower and upper cutoff frequencies for the band-pass filter. The parameters should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyBandPassFilter method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class
ImGearFreqIPFilterBrands Enumeration


BandStopFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : BandStopFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
Lower cutoff frequency for the band-pass filter.
Higher cutoff frequency for the band-pass filter.
Filter order to use, applicable to all except Ideal filter.
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].
Filters the input image using a band-stop filter, with the specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub BandStopFilter( _
   ByVal page As ImGearRasterPage, _
   ByVal filterBrand As ImGearFreqIPFilterBrands, _
   ByVal lowerCutoffFrequency As Double, _
   ByVal higherCutoffFrequency As Double, _
   ByVal filterOrder As Integer, _
   ByVal rippleFactor As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim filterBrand As ImGearFreqIPFilterBrands
Dim lowerCutoffFrequency As Double
Dim higherCutoffFrequency As Double
Dim filterOrder As Integer
Dim rippleFactor As Double

ImGearFrequencyProcessing.BandStopFilter(page, filterBrand, lowerCutoffFrequency, higherCutoffFrequency, filterOrder, rippleFactor)
public static void BandStopFilter(
   ImGearRasterPage page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public: static void BandStopFilter(
   ImGearRasterPage* page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public:
static void BandStopFilter(
   ImGearRasterPage^ page,
   ImGearFreqIPFilterBrands filterBrand,
   double lowerCutoffFrequency,
   double higherCutoffFrequency,
   int filterOrder,
   double rippleFactor
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
filterBrand
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
lowerCutoffFrequency
Lower cutoff frequency for the band-pass filter.
higherCutoffFrequency
Higher cutoff frequency for the band-pass filter.
filterOrder
Filter order to use, applicable to all except Ideal filter.
rippleFactor
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].
Remarks
This method filters the input image using a band-stop filter, with the specified parameters.

Parameter filterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameters lowerCutoffFrequency and higherCutoffFrequency specify the lower and upper cutoff frequencies for the band-stop filter. The parameters should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyBandStopFilter method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class
ImGearFreqIPFilterBrands Enumeration


Convolve Method (ImGearFrequencyProcessing)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : Convolve Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Array of kernel elements to convolve with.
Width of kernel matrix.
Height of kernel matrix.
Normalizer of the result.
Whether to add the result of the convolution to the original pixel values, or replace the original pixel values.
Convolves an image with the given kernel matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Convolve( _
   ByVal page As ImGearRasterPage, _
   ByVal matrix() As Integer, _
   ByVal matrixWidth As Integer, _
   ByVal matrixHeight As Integer, _
   ByVal normalizer As Double, _
   ByVal addResultToOriginalPixels As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim matrix() As Integer
Dim matrixWidth As Integer
Dim matrixHeight As Integer
Dim normalizer As Double
Dim addResultToOriginalPixels As Boolean

ImGearFrequencyProcessing.Convolve(page, matrix, matrixWidth, matrixHeight, normalizer, addResultToOriginalPixels)
public static void Convolve(
   ImGearRasterPage page,
   int[] matrix,
   int matrixWidth,
   int matrixHeight,
   double normalizer,
   bool addResultToOriginalPixels
)
public: static void Convolve(
   ImGearRasterPage* page,
   int[]* matrix,
   int matrixWidth,
   int matrixHeight,
   double normalizer,
   bool addResultToOriginalPixels
)
public:
static void Convolve(
   ImGearRasterPage^ page,
   array<int>^ matrix,
   int matrixWidth,
   int matrixHeight,
   double normalizer,
   bool addResultToOriginalPixels
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
matrix
Array of kernel elements to convolve with.
matrixWidth
Width of kernel matrix.
matrixHeight
Height of kernel matrix.
normalizer
Normalizer of the result.
addResultToOriginalPixels
Whether to add the result of the convolution to the original pixel values, or replace the original pixel values.
Remarks
This method convolves an image with the given kernel matrix. The convolution is implemented using FFT, based on the Convolution Theorem, which provides improved performance for larger kernel matrix.

The result of the convolution is multiplied by normalizer to scale the data. For kernels that sum to zero, the normalizer is usually set to 1.0.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyConvolve method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class


ForwardDCT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardDCT Method
An ImGearComplexObject class object to be transformed.
Computes the forward Discrete Cosine Transform (DCT) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardDCT( _
   ByVal value As ImGearComplexObject _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardDCT(value)
public static ImGearComplexObject ForwardDCT(
   ImGearComplexObject value
)
public: static ImGearComplexObject* ForwardDCT(
   ImGearComplexObject* value
)
public:
static ImGearComplexObject^ ForwardDCT(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImGearComplexObject class.
Remarks
This method computes the forward Discrete Cosine Transform (DCT) of the input data.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyForwardDCT method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class


ForwardDCTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardDCTFromImage Method
An ImageGear.Core.ImGearPage class object to be transformed.
Computes the forward Discrete Cosine Transform (DCT) of the input image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardDCTFromImage( _
   ByVal page As ImGearPage _
) As ImGearComplexObject
'Usage

Dim page As ImGearPage
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardDCTFromImage(page)
public static ImGearComplexObject ForwardDCTFromImage(
   ImGearPage page
)
public: static ImGearComplexObject* ForwardDCTFromImage(
   ImGearPage* page
)
public:
static ImGearComplexObject^ ForwardDCTFromImage(
   ImGearPage^ page
)

Parameters

page
An ImageGear.Core.ImGearPage class object to be transformed.

Return Value

ImGearComplexObject class.
Remarks
This method computes the forward Discrete Cosine Transform (DCT) of the input image. The difference between this method and ForwardDCT method is that this one takes an ImageGear.Core.ImGearPage class as the input.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyForwardDCTFromImage method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearPage Class


ForwardDST Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardDST Method
An ImGearComplexObject class object to be transformed.
Computes the forward Discrete Sine Transform (DST) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardDST( _
   ByVal value As ImGearComplexObject _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardDST(value)
public static ImGearComplexObject ForwardDST(
   ImGearComplexObject value
)
public: static ImGearComplexObject* ForwardDST(
   ImGearComplexObject* value
)
public:
static ImGearComplexObject^ ForwardDST(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImGearComplexObject class.
Remarks
This method computes the forward Discrete Sine Transform (DST) of the input data.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

Method ImGearFrequencyProcessingVerifier.CanApplyForwardDST method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class


ForwardDSTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardDSTFromImage Method
An ImageGear.Core.ImGearPage class object to be transformed.
Computes the forward Discrete Sine Transform (DST) of the input image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardDSTFromImage( _
   ByVal page As ImGearPage _
) As ImGearComplexObject
'Usage

Dim page As ImGearPage
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardDSTFromImage(page)
public static ImGearComplexObject ForwardDSTFromImage(
   ImGearPage page
)
public: static ImGearComplexObject* ForwardDSTFromImage(
   ImGearPage* page
)
public:
static ImGearComplexObject^ ForwardDSTFromImage(
   ImGearPage^ page
)

Parameters

page
An ImageGear.Core.ImGearPage class object to be transformed.

Return Value

ImGearComplexObject class.
Remarks
This method computes the forward Discrete Sine Transform (DST) of the input image. The difference between this method and ForwardDST method is that this one takes an ImageGear.Core.ImGearPage class as the input.
See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearPage Class


ForwardFFT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardFFT Method
ImGearComplexObject class object to be processed.
Specifies the method of scaling the result data.
Flag to indicate whether to use centered transform.
Performs a forward Fast Fourier Transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardFFT( _
   ByVal value As ImGearComplexObject, _
   ByVal scalingMethod As ImGearFFTScalingMethods, _
   ByVal useCenteredTransform As Boolean _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim scalingMethod As ImGearFFTScalingMethods
Dim useCenteredTransform As Boolean
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardFFT(value, scalingMethod, useCenteredTransform)
public static ImGearComplexObject ForwardFFT(
   ImGearComplexObject value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public: static ImGearComplexObject* ForwardFFT(
   ImGearComplexObject* value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public:
static ImGearComplexObject^ ForwardFFT(
   ImGearComplexObject^ value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)

Parameters

value
ImGearComplexObject class object to be processed.
scalingMethod
Specifies the method of scaling the result data.
useCenteredTransform
Flag to indicate whether to use centered transform.

Return Value

ImGearComplexObject class.
Remarks
This method performs a forward Fast Fourier Transform.

Note that the user must keep track how the transform is centered in the forward FFT in order to know how to de-center it during the inverse FFT, same goes for the scaling method.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyForwardFFT method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearFFTScalingMethods Enumeration


ForwardFFTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : ForwardFFTFromImage Method
ImageGear.Core.ImGearPage class object to be processed.
Specifies the method of scaling the result data.
Flag to indicate whether to use centered transform.
Performs a forward Fast Fourier Transform of the input image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ForwardFFTFromImage( _
   ByVal page As ImGearPage, _
   ByVal scalingMethod As ImGearFFTScalingMethods, _
   ByVal useCenteredTransform As Boolean _
) As ImGearComplexObject
'Usage

Dim page As ImGearPage
Dim scalingMethod As ImGearFFTScalingMethods
Dim useCenteredTransform As Boolean
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.ForwardFFTFromImage(page, scalingMethod, useCenteredTransform)
public static ImGearComplexObject ForwardFFTFromImage(
   ImGearPage page,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public: static ImGearComplexObject* ForwardFFTFromImage(
   ImGearPage* page,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public:
static ImGearComplexObject^ ForwardFFTFromImage(
   ImGearPage^ page,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)

Parameters

page
ImageGear.Core.ImGearPage class object to be processed.
scalingMethod
Specifies the method of scaling the result data.
useCenteredTransform
Flag to indicate whether to use centered transform.

Return Value

ImGearComplexObject class.
Remarks
This method performs a forward Fast Fourier Transform of the input image. The difference between this method and ForwardFFT method is that this one takes an ImageGear.Core.ImGearPage class as the input object.

Note that the user must keep track how the transform is centered in the forward FFT in order to know how to de-center it during the inverse FFT, same goes for the scaling method.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyForwardFFTFromImage method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearPage Class
ImGearFFTScalingMethods Enumeration


HighPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : HighPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
Cutoff frequency for the high-pass filter.
Filter order to use, applicable to all except Ideal filter.
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].
Filters the input image using a high-pass filter, with the specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub HighPassFilter( _
   ByVal page As ImGearRasterPage, _
   ByVal filterBrand As ImGearFreqIPFilterBrands, _
   ByVal cutoffFrequency As Double, _
   ByVal filterOrder As Integer, _
   ByVal rippleFactor As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim filterBrand As ImGearFreqIPFilterBrands
Dim cutoffFrequency As Double
Dim filterOrder As Integer
Dim rippleFactor As Double

ImGearFrequencyProcessing.HighPassFilter(page, filterBrand, cutoffFrequency, filterOrder, rippleFactor)
public static void HighPassFilter(
   ImGearRasterPage page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public: static void HighPassFilter(
   ImGearRasterPage* page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public:
static void HighPassFilter(
   ImGearRasterPage^ page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
filterBrand
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
cutoffFrequency
Cutoff frequency for the high-pass filter.
filterOrder
Filter order to use, applicable to all except Ideal filter.
rippleFactor
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].
Remarks
This method filters the input image using a high-pass filter, with the specified parameters.

Parameter filterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameter cutoffFrequency specifies the cutoff frequency for the high-pass filter. This parameter should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier.CanApplyHighPassFilter method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class
ImGearFreqIPFilterBrands Enumeration


InitializeFFTW Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InitializeFFTW Method
Initializes the FFTW algorithm.
Overload List
Overload | Description
InitializeFFTW() | Initializes the FFTW algorithm.
InitializeFFTW(String) | Initializes the FFTW algorithm.
See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members


InitializeFFTW() Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class > InitializeFFTW Method : InitializeFFTW() Method
Initializes the FFTW algorithm.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function InitializeFFTW() As Boolean
'Usage

Dim value As Boolean

value = ImGearFrequencyProcessing.InitializeFFTW()
public static bool InitializeFFTW()
public: static bool InitializeFFTW();
public:
static bool InitializeFFTW();

Return Value

If FFTW algorithm is initialized - true, otherwise - false.
Remarks
This method initializes the FFTW algorithm used in ImageGear. Necessary license check will be performed to make sure FFTW is a licensed feature.

Note that this method searches for the library files using system default path.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
Overload List
InitializeFFTW(String) Method


InitializeFFTW(String) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class > InitializeFFTW Method : InitializeFFTW(String) Method
The path to search for needed library files to Initialize FFTW.
Initializes the FFTW algorithm.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function InitializeFFTW( _
   ByVal libraryPath As String _
) As Boolean
'Usage

Dim libraryPath As String
Dim value As Boolean

value = ImGearFrequencyProcessing.InitializeFFTW(libraryPath)
public static bool InitializeFFTW(
   string libraryPath
)
public: static bool InitializeFFTW(
   string* libraryPath
)
public:
static bool InitializeFFTW(
   String^ libraryPath
)

Parameters

libraryPath
The path to search for needed library files to Initialize FFTW.

Return Value

If FFTW algorithm is initialized - true, otherwise - false.
Remarks
This method initializes the FFTW algorithm used in ImageGear. Necessary license check will be performed to make sure FFTW is a licensed feature.

Note that this method searches for the library files using the specified path.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
Overload List
InitializeFFTW Method


InverseDCT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseDCT Method
An ImGearComplexObject class object to be transformed.
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseDCT( _
   ByVal value As ImGearComplexObject _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.InverseDCT(value)
public static ImGearComplexObject InverseDCT(
   ImGearComplexObject value
)
public: static ImGearComplexObject* InverseDCT(
   ImGearComplexObject* value
)
public:
static ImGearComplexObject^ InverseDCT(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImGearComplexObject object.
Remarks
This method computes the inverse Discrete Cosine Transform (IDCT) of the input data.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

Method ImGearFrequencyProcessingVerifier.CanApplyInverseDCT method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class


InverseDCTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseDCTToImage Method
An ImGearComplexObject class object to be transformed.
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseDCTToImage( _
   ByVal value As ImGearComplexObject _
) As ImGearPage
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearPage

value = ImGearFrequencyProcessing.InverseDCTToImage(value)
public static ImGearPage InverseDCTToImage(
   ImGearComplexObject value
)
public: static ImGearPage* InverseDCTToImage(
   ImGearComplexObject* value
)
public:
static ImGearPage^ InverseDCTToImage(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImageGear.Core.ImGearPage class.
Remarks
This method computes the inverse Discrete Cosine Transform (IDCT) of the input data. The difference between this method and InverseDCT method is that this one returns an ImageGear.Core.ImGearPage class as the result, using the default conversion type ImGearCoObjConvType.REAL.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyInverseDCTToImage method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class


InverseDST Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseDST Method
An ImGearComplexObject class object to be transformed.
Computes the inverse Discrete Sine Transform (IDST) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseDST( _
   ByVal value As ImGearComplexObject _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.InverseDST(value)
public static ImGearComplexObject InverseDST(
   ImGearComplexObject value
)
public: static ImGearComplexObject* InverseDST(
   ImGearComplexObject* value
)
public:
static ImGearComplexObject^ InverseDST(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImGearComplexObject class.
Remarks
This method computes the inverse Discrete Sine Transform (IDST) of the input data.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyInverseDST method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class


InverseDSTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseDSTToImage Method
An ImGearComplexObject class object to be transformed.
Computes the inverse Discrete Sine Transform (IDST) of the input data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseDSTToImage( _
   ByVal value As ImGearComplexObject _
) As ImGearPage
'Usage

Dim value As ImGearComplexObject
Dim value As ImGearPage

value = ImGearFrequencyProcessing.InverseDSTToImage(value)
public static ImGearPage InverseDSTToImage(
   ImGearComplexObject value
)
public: static ImGearPage* InverseDSTToImage(
   ImGearComplexObject* value
)
public:
static ImGearPage^ InverseDSTToImage(
   ImGearComplexObject^ value
)

Parameters

value
An ImGearComplexObject class object to be transformed.

Return Value

ImageGear.Core.ImGearPage class.
Remarks
This method computes the inverse Discrete Sine Transform (IDST) of the input data. The difference between this method and InverseDST method is that this one returns an ImageGear.Core.ImGearPage class as the result, using the default conversion type ImGearCoObjConvType.REAL.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyInverseDSTToImage method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearPage Class


InverseFFT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseFFT Method
ImGearComplexObject class object to be processed.
Specifies the method of scaling the result data.
Flag to indicate whether to use centered transform.
Performs an inverse Fast Fourier Transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseFFT( _
   ByVal value As ImGearComplexObject, _
   ByVal scalingMethod As ImGearFFTScalingMethods, _
   ByVal useCenteredTransform As Boolean _
) As ImGearComplexObject
'Usage

Dim value As ImGearComplexObject
Dim scalingMethod As ImGearFFTScalingMethods
Dim useCenteredTransform As Boolean
Dim value As ImGearComplexObject

value = ImGearFrequencyProcessing.InverseFFT(value, scalingMethod, useCenteredTransform)
public static ImGearComplexObject InverseFFT(
   ImGearComplexObject value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public: static ImGearComplexObject* InverseFFT(
   ImGearComplexObject* value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public:
static ImGearComplexObject^ InverseFFT(
   ImGearComplexObject^ value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)

Parameters

value
ImGearComplexObject class object to be processed.
scalingMethod
Specifies the method of scaling the result data.
useCenteredTransform
Flag to indicate whether to use centered transform.

Return Value

ImGearComplexObject class.
Remarks
This method performs an inverse Fast Fourier Transform.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyInverseFFT method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearComplexObject Class
ImGearFFTScalingMethods Enumeration


InverseFFTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseFFTToImage Method
ImGearComplexObject class object to be processed.
Specifies the method of scaling the result data.
Flag to indicate whether to use centered transform.
Performs an inverse Fast Fourier Transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function InverseFFTToImage( _
   ByVal value As ImGearComplexObject, _
   ByVal scalingMethod As ImGearFFTScalingMethods, _
   ByVal useCenteredTransform As Boolean _
) As ImGearPage
'Usage

Dim value As ImGearComplexObject
Dim scalingMethod As ImGearFFTScalingMethods
Dim useCenteredTransform As Boolean
Dim value As ImGearPage

value = ImGearFrequencyProcessing.InverseFFTToImage(value, scalingMethod, useCenteredTransform)
public static ImGearPage InverseFFTToImage(
   ImGearComplexObject value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public: static ImGearPage* InverseFFTToImage(
   ImGearComplexObject* value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)
public:
static ImGearPage^ InverseFFTToImage(
   ImGearComplexObject^ value,
   ImGearFFTScalingMethods scalingMethod,
   bool useCenteredTransform
)

Parameters

value
ImGearComplexObject class object to be processed.
scalingMethod
Specifies the method of scaling the result data.
useCenteredTransform
Flag to indicate whether to use centered transform.

Return Value

ImageGear.Core.ImGearPage class.
Remarks
This method performs an inverse Fast Fourier Transform.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject class object.

ImGearFrequencyProcessingVerifier.CanApplyInverseFFTToImage method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearPage Class
ImGearComplexObject Class
ImGearFFTScalingMethods Enumeration


InverseRestore Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : InverseRestore Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
Size of PSF passed in.
The threshold parameter for Inverse Filtering.
Performs image restoration using inverse filtering in the frequency domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InverseRestore( _
   ByVal page As ImGearRasterPage, _
   ByVal spreadFunctionVector() As Double, _
   ByVal spreadFunctionVectorSize As Integer, _
   ByVal threshold As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim spreadFunctionVector() As Double
Dim spreadFunctionVectorSize As Integer
Dim threshold As Double

ImGearFrequencyProcessing.InverseRestore(page, spreadFunctionVector, spreadFunctionVectorSize, threshold)
public static void InverseRestore(
   ImGearRasterPage page,
   double[] spreadFunctionVector,
   int spreadFunctionVectorSize,
   double threshold
)
public: static void InverseRestore(
   ImGearRasterPage* page,
   double[]* spreadFunctionVector,
   int spreadFunctionVectorSize,
   double threshold
)
public:
static void InverseRestore(
   ImGearRasterPage^ page,
   array<double>^ spreadFunctionVector,
   int spreadFunctionVectorSize,
   double threshold
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
spreadFunctionVector
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
spreadFunctionVectorSize
Size of PSF passed in.
threshold
The threshold parameter for Inverse Filtering.
Remarks
This method performs image restoration using inverse filtering in the frequency domain. The idea is to deconvolve PSF from the blurred data to extract the original image.

The deconvolution involves dividing the Fourier transform of the blurred image by the Fourier transform of PSF. If the transform of PSF has very small values, then the division result from those small values could easily dominate the entire result. The approach used to get around this issue is to limit the smallest value of the transform of PSF, thus we require a threshold value, threshold, to be passed in as a parameter. Ideally, this value will be just above the noise level in the image. This method places zeros in the output for those data points where the magnitude of PSF transform is below the threshold. In this respect, InverseRestore is actually an implementation of a pseudo-inverse filter.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier.CanApplyInverseRestore method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class


LowPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : LowPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
Cutoff frequency for the low-pass filter.
Filter order to use, applicable to all except Ideal filter.
A factor which determines the pass-band ripple for Chebyshev filters, with value between [0, 1].
Filters the input image using a low-pass filter, with the specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub LowPassFilter( _
   ByVal page As ImGearRasterPage, _
   ByVal filterBrand As ImGearFreqIPFilterBrands, _
   ByVal cutoffFrequency As Double, _
   ByVal filterOrder As Integer, _
   ByVal rippleFactor As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim filterBrand As ImGearFreqIPFilterBrands
Dim cutoffFrequency As Double
Dim filterOrder As Integer
Dim rippleFactor As Double

ImGearFrequencyProcessing.LowPassFilter(page, filterBrand, cutoffFrequency, filterOrder, rippleFactor)
public static void LowPassFilter(
   ImGearRasterPage page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public: static void LowPassFilter(
   ImGearRasterPage* page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)
public:
static void LowPassFilter(
   ImGearRasterPage^ page,
   ImGearFreqIPFilterBrands filterBrand,
   double cutoffFrequency,
   int filterOrder,
   double rippleFactor
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
filterBrand
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands enumeration.
cutoffFrequency
Cutoff frequency for the low-pass filter.
filterOrder
Filter order to use, applicable to all except Ideal filter.
rippleFactor
A factor which determines the pass-band ripple for Chebyshev filters, with value between [0, 1].
Remarks
This method filters the input image using a low-pass filter, with the specified parameters.

Parameter filterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameter cutoffFrequency specifies the cutoff frequency for the low-pass filter. This parameter should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessingVerifier.CanApplyLowPassFilter method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class
ImGearFreqIPFilterBrands Enumeration


WienerRestore Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : WienerRestore Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
Size of PSF passed in.
The constant for Wiener Filtering.
Performs image restoration using Wiener filtering in the frequency domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub WienerRestore( _
   ByVal page As ImGearRasterPage, _
   ByVal spreadFunctionVector() As Double, _
   ByVal spreadFunctionVectorSize As Integer, _
   ByVal wienerConstant As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim spreadFunctionVector() As Double
Dim spreadFunctionVectorSize As Integer
Dim wienerConstant As Double

ImGearFrequencyProcessing.WienerRestore(page, spreadFunctionVector, spreadFunctionVectorSize, wienerConstant)
public static void WienerRestore(
   ImGearRasterPage page,
   double[] spreadFunctionVector,
   int spreadFunctionVectorSize,
   double wienerConstant
)
public: static void WienerRestore(
   ImGearRasterPage* page,
   double[]* spreadFunctionVector,
   int spreadFunctionVectorSize,
   double wienerConstant
)
public:
static void WienerRestore(
   ImGearRasterPage^ page,
   array<double>^ spreadFunctionVector,
   int spreadFunctionVectorSize,
   double wienerConstant
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.
spreadFunctionVector
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
spreadFunctionVectorSize
Size of PSF passed in.
wienerConstant
The constant for Wiener Filtering.
Remarks
This method performs image restoration using Wiener filtering in the frequency domain. This filter is also commonly referred to as the minimum mean square error filter or the least square error filter.

Usually Wiener filtering can produce better results than inverse filtering.

Before using this method, like other frequency processing methods, InitializeFFTW method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier.CanApplyWienerRestore method can be called to check whether the operation can be performed or not.

See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearRasterPage Class


%%PageItemTitle%% $$Properties$$

ImGearFrequencyProcessing Class Properties

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessing Class

For a list of all members of this type, see ImGearFrequencyProcessing members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | IsFFTWInitialized | Gets a value indicating whether FFTW support is initialized.
static (Shared in Visual Basic) | Verifier | Gets ImGearFrequencyProcessingVerifier class to allows you to call its methods.
Top
See Also

Reference

ImGearFrequencyProcessing Class
ImageGear.FreqIP Namespace
ImGearFrequencyProcessingVerifier Class


IsFFTWInitialized Property

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : IsFFTWInitialized Property
Gets a value indicating whether FFTW support is initialized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property IsFFTWInitialized As Boolean
'Usage

Dim value As Boolean

value = ImGearFrequencyProcessing.IsFFTWInitialized
public static bool IsFFTWInitialized {get;}
public: __property static bool get_IsFFTWInitialized();
public:
static property bool IsFFTWInitialized {
   bool get();
}

Property Value

If FFTW support is initialized - true, otherwise - false.
See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearFrequencyProcessing Class


Verifier Property (ImGearFrequencyProcessing)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessing Class : Verifier Property
Gets ImGearFrequencyProcessingVerifier class to allows you to call its methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGearFrequencyProcessingVerifier
'Usage

Dim value As ImGearFrequencyProcessingVerifier

value = ImGearFrequencyProcessing.Verifier
public static ImGearFrequencyProcessingVerifier Verifier {get;}
public: __property static ImGearFrequencyProcessingVerifier* get_Verifier();
public:
static property ImGearFrequencyProcessingVerifier^ Verifier {
   ImGearFrequencyProcessingVerifier^ get();
}

Property Value

ImGearFrequencyProcessingVerifier class.
See Also

Reference

ImGearFrequencyProcessing Class
ImGearFrequencyProcessing Members
ImGearFrequencyProcessingVerifier Class


%%PageItemTitle%%

ImGearFrequencyProcessingVerifier Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessingVerifier Class
This class contains static methods that check whether the ImGearFrequencyProcessing operation is applicable to the page or not.
Object Model
ImGearFrequencyProcessingVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearFrequencyProcessingVerifier
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
public sealed class ImGearFrequencyProcessingVerifier
public __gc __sealed class ImGearFrequencyProcessingVerifier
public ref class ImGearFrequencyProcessingVerifier sealed
Inheritance Hierarchy

System.Object
ImageGear.FreqIP.ImGearFrequencyProcessingVerifier

See Also

Reference

ImGearFrequencyProcessingVerifier Members
ImageGear.FreqIP Namespace
ImGearFrequencyProcessing Class


%%PageItemTitle%% $$Members$$

ImGearFrequencyProcessingVerifier Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessingVerifier Class

The following tables list the members exposed by ImGearFrequencyProcessingVerifier.

Public Methods
 | Name | Description
Public Method | CanApplyBandPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandPassFilter can be applied to it.
Public Method | CanApplyBandStopFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandStopFilter can be applied to it.
Public Method | CanApplyConvolve | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.Convolve can be applied to it.
Public Method | CanApplyForwardDCT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDCT can be applied to it.
Public Method | CanApplyForwardDCTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage can be applied to it.
Public Method | CanApplyForwardDST | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDST can be applied to it.
Public Method | CanApplyForwardDSTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage can be applied to it.
Public Method | CanApplyForwardFFT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardFFT can be applied to it.
Public Method | CanApplyForwardFFTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage can be applied to it.
Public Method | CanApplyHighPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.HighPassFilter can be applied to it.
Public Method | CanApplyInverseDCT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCT can be applied to it.
Public Method | CanApplyInverseDCTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage can be applied to it.
Public Method | CanApplyInverseDST | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDST can be applied to it.
Public Method | CanApplyInverseDSTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage can be applied to it.
Public Method | CanApplyInverseFFT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFT can be applied to it.
Public Method | CanApplyInverseFFTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage can be applied to it.
Public Method | CanApplyInverseRestore | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.InverseRestore can be applied to it.
Public Method | CanApplyLowPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.LowPassFilter can be applied to it.
Public Method | CanApplyWienerRestore | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.WienerRestore can be applied to it.
Top
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImageGear.FreqIP Namespace
ImGearFrequencyProcessing Class


%%PageItemTitle%% $$Methods$$

ImGearFrequencyProcessingVerifier Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFrequencyProcessingVerifier Class

For a list of all members of this type, see ImGearFrequencyProcessingVerifier members.

Public Methods
 | Name | Description
Public Method | CanApplyBandPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandPassFilter can be applied to it.
Public Method | CanApplyBandStopFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandStopFilter can be applied to it.
Public Method | CanApplyConvolve | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.Convolve can be applied to it.
Public Method | CanApplyForwardDCT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDCT can be applied to it.
Public Method | CanApplyForwardDCTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage can be applied to it.
Public Method | CanApplyForwardDST | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDST can be applied to it.
Public Method | CanApplyForwardDSTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage can be applied to it.
Public Method | CanApplyForwardFFT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardFFT can be applied to it.
Public Method | CanApplyForwardFFTFromImage | Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage can be applied to it.
Public Method | CanApplyHighPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.HighPassFilter can be applied to it.
Public Method | CanApplyInverseDCT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCT can be applied to it.
Public Method | CanApplyInverseDCTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage can be applied to it.
Public Method | CanApplyInverseDST | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDST can be applied to it.
Public Method | CanApplyInverseDSTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage can be applied to it.
Public Method | CanApplyInverseFFT | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFT can be applied to it.
Public Method | CanApplyInverseFFTToImage | Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage can be applied to it.
Public Method | CanApplyInverseRestore | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.InverseRestore can be applied to it.
Public Method | CanApplyLowPassFilter | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.LowPassFilter can be applied to it.
Public Method | CanApplyWienerRestore | Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.WienerRestore can be applied to it.
Top
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImageGear.FreqIP Namespace
ImGearFrequencyProcessing Class


CanApplyBandPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyBandPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandPassFilter can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyBandPassFilter( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyBandPassFilter(page)
public bool CanApplyBandPassFilter(
   ImGearRasterPage page
)
public: bool CanApplyBandPassFilter(
   ImGearRasterPage* page
)
public:
bool CanApplyBandPassFilter(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
BandPassFilter Method


CanApplyBandStopFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyBandStopFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.BandStopFilter can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyBandStopFilter( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyBandStopFilter(page)
public bool CanApplyBandStopFilter(
   ImGearRasterPage page
)
public: bool CanApplyBandStopFilter(
   ImGearRasterPage* page
)
public:
bool CanApplyBandStopFilter(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
BandStopFilter Method


CanApplyConvolve Method (ImGearFrequencyProcessingVerifier)

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyConvolve Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.Convolve can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyConvolve( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyConvolve(page)
public bool CanApplyConvolve(
   ImGearRasterPage page
)
public: bool CanApplyConvolve(
   ImGearRasterPage* page
)
public:
bool CanApplyConvolve(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
Convolve Method


CanApplyForwardDCT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardDCT Method
The ImGearComplexObject class object to determine whether ForwardDCT can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDCT can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardDCT( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyForwardDCT(value)
public bool CanApplyForwardDCT(
   ImGearComplexObject value
)
public: bool CanApplyForwardDCT(
   ImGearComplexObject* value
)
public:
bool CanApplyForwardDCT(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether ForwardDCT can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
ForwardDCT Method
ImGearComplexObject Class


CanApplyForwardDCTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardDCTFromImage Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardDCTFromImage( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyForwardDCTFromImage(page)
public bool CanApplyForwardDCTFromImage(
   ImGearPage page
)
public: bool CanApplyForwardDCTFromImage(
   ImGearPage* page
)
public:
bool CanApplyForwardDCTFromImage(
   ImGearPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearPage Class
ForwardDCTFromImage Method


CanApplyForwardDST Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardDST Method
The ImGearComplexObject class object to determine whether ForwardDST method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardDST can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardDST( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyForwardDST(value)
public bool CanApplyForwardDST(
   ImGearComplexObject value
)
public: bool CanApplyForwardDST(
   ImGearComplexObject* value
)
public:
bool CanApplyForwardDST(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether ForwardDST method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
ForwardDST Method


CanApplyForwardDSTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardDSTFromImage Method
ImageGear.Core.ImGearPage class object to be processed.
Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardDSTFromImage( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyForwardDSTFromImage(page)
public bool CanApplyForwardDSTFromImage(
   ImGearPage page
)
public: bool CanApplyForwardDSTFromImage(
   ImGearPage* page
)
public:
bool CanApplyForwardDSTFromImage(
   ImGearPage^ page
)

Parameters

page
ImageGear.Core.ImGearPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ForwardDSTFromImage Method


CanApplyForwardFFT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardFFT Method
The ImGearComplexObject class object to determine whether ForwardFFT method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.ForwardFFT can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardFFT( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyForwardFFT(value)
public bool CanApplyForwardFFT(
   ImGearComplexObject value
)
public: bool CanApplyForwardFFT(
   ImGearComplexObject* value
)
public:
bool CanApplyForwardFFT(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether ForwardFFT method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
ForwardFFT Method


CanApplyForwardFFTFromImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyForwardFFTFromImage Method
ImageGear.Core.ImGearPage class object to be processed.
Takes an ImageGear.Core.ImGearPage class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyForwardFFTFromImage( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyForwardFFTFromImage(page)
public bool CanApplyForwardFFTFromImage(
   ImGearPage page
)
public: bool CanApplyForwardFFTFromImage(
   ImGearPage* page
)
public:
bool CanApplyForwardFFTFromImage(
   ImGearPage^ page
)

Parameters

page
ImageGear.Core.ImGearPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearPage Class
ForwardFFTFromImage Method


CanApplyHighPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyHighPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.HighPassFilter can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyHighPassFilter( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyHighPassFilter(page)
public bool CanApplyHighPassFilter(
   ImGearRasterPage page
)
public: bool CanApplyHighPassFilter(
   ImGearRasterPage* page
)
public:
bool CanApplyHighPassFilter(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
HighPassFilter Method


CanApplyInverseDCT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseDCT Method
The ImGearComplexObject class object to determine whether InverseDCT method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCT can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseDCT( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseDCT(value)
public bool CanApplyInverseDCT(
   ImGearComplexObject value
)
public: bool CanApplyInverseDCT(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseDCT(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseDCT method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
InverseDCT Method


CanApplyInverseDCTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseDCTToImage Method
The ImGearComplexObject class object to determine whether InverseDCTToImage method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseDCTToImage( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseDCTToImage(value)
public bool CanApplyInverseDCTToImage(
   ImGearComplexObject value
)
public: bool CanApplyInverseDCTToImage(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseDCTToImage(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseDCTToImage method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
InverseDCTToImage Method


CanApplyInverseDST Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseDST Method
The ImGearComplexObject class object to determine whether InverseDST can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDST can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseDST( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseDST(value)
public bool CanApplyInverseDST(
   ImGearComplexObject value
)
public: bool CanApplyInverseDST(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseDST(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseDST can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
InverseDST Method


CanApplyInverseDSTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseDSTToImage Method
The ImGearComplexObject class object to determine whether InverseDSTToImage method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseDSTToImage( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseDSTToImage(value)
public bool CanApplyInverseDSTToImage(
   ImGearComplexObject value
)
public: bool CanApplyInverseDSTToImage(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseDSTToImage(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseDSTToImage method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
InverseDSTToImage Method


CanApplyInverseFFT Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseFFT Method
The ImGearComplexObject class object to determine whether InverseFFT can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFT can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseFFT( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseFFT(value)
public bool CanApplyInverseFFT(
   ImGearComplexObject value
)
public: bool CanApplyInverseFFT(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseFFT(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseFFT can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
InverseFFT Method


CanApplyInverseFFTToImage Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseFFTToImage Method
The ImGearComplexObject class object to determine whether InverseFFTToImage method can be applied to.
Takes an ImGearComplexObject class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseFFTToImage( _
   ByVal value As ImGearComplexObject _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim value As ImGearComplexObject
Dim value As Boolean

value = instance.CanApplyInverseFFTToImage(value)
public bool CanApplyInverseFFTToImage(
   ImGearComplexObject value
)
public: bool CanApplyInverseFFTToImage(
   ImGearComplexObject* value
)
public:
bool CanApplyInverseFFTToImage(
   ImGearComplexObject^ value
)

Parameters

value
The ImGearComplexObject class object to determine whether InverseFFTToImage method can be applied to.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearComplexObject Class
InverseFFTToImage Method


CanApplyInverseRestore Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyInverseRestore Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.InverseRestore can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInverseRestore( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyInverseRestore(page)
public bool CanApplyInverseRestore(
   ImGearRasterPage page
)
public: bool CanApplyInverseRestore(
   ImGearRasterPage* page
)
public:
bool CanApplyInverseRestore(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
InverseRestore Method


CanApplyLowPassFilter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyLowPassFilter Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.LowPassFilter can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyLowPassFilter( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyLowPassFilter(page)
public bool CanApplyLowPassFilter(
   ImGearRasterPage page
)
public: bool CanApplyLowPassFilter(
   ImGearRasterPage* page
)
public:
bool CanApplyLowPassFilter(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
LowPassFilter Method


CanApplyWienerRestore Method

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace > ImGearFrequencyProcessingVerifier Class : CanApplyWienerRestore Method
ImageGear.Core.ImGearRasterPage class object to be processed.
Takes an ImageGear.Core.ImGearRasterPage class object and determines whether ImGearFrequencyProcessing.WienerRestore can be applied to it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyWienerRestore( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearFrequencyProcessingVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyWienerRestore(page)
public bool CanApplyWienerRestore(
   ImGearRasterPage page
)
public: bool CanApplyWienerRestore(
   ImGearRasterPage* page
)
public:
bool CanApplyWienerRestore(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage class object to be processed.

Return Value

Boolean value.
See Also

Reference

ImGearFrequencyProcessingVerifier Class
ImGearFrequencyProcessingVerifier Members
ImGearRasterPage Class
WienerRestore Method


%%PageItemTitle%%

ImGearCoObjConvType Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearCoObjConvType Enumeration
Specifies the conversion types to convert an ImGearComplexObject class object to an ImageGear.Core.ImGearPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCoObjConvType
   Inherits System.Enum
'Usage

Dim instance As ImGearCoObjConvType
public enum ImGearCoObjConvType : System.Enum
__value public enum ImGearCoObjConvType : public System.Enum
public enum class ImGearCoObjConvType : public System.Enum
Members
Member | Value | Description
IMAGINARY | 1 | Use the imaginary data.
LOGMAG | 4 | Use the logarithm (10) of the magnitude data.
LOGMAGP1 | 5 | Use the logarithm (10) of (magnitude data + 1).
LOGMAGSQ | 7 | Use the logarithm (10) of the square of the magnitude.
LOGMAGSQP1 | 8 | Use the logarithm (10) of (square of the magnitude + 1).
MAGNITUDE | 2 | Use the magnitude data.
MAGSQ | 6 | Use the square of the magnitude.
PHASE | 3 | Use the phase data.
REAL | 0 | Use the real data.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.FreqIP.ImGearCoObjConvType

See Also

Reference

ImageGear.FreqIP Namespace


%%PageItemTitle%%

ImGearFFTScalingMethods Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFFTScalingMethods Enumeration
Defines the different scaling methods for the result of Fast Fourier Transform (FFT).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFFTScalingMethods
   Inherits System.Enum
'Usage

Dim instance As ImGearFFTScalingMethods
public enum ImGearFFTScalingMethods : System.Enum
__value public enum ImGearFFTScalingMethods : public System.Enum
public enum class ImGearFFTScalingMethods : public System.Enum
Members
Member | Value | Description
N | 1 | Scale by 1/N on each dimension.
SQRTN | 2 | Scale by 1/sqrt(N) on each dimension.
UNITY | 0 | Unity scaling, i.e., no scaling on the result.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.FreqIP.ImGearFFTScalingMethods

See Also

Reference

ImageGear.FreqIP Namespace


%%PageItemTitle%%

ImGearFreqIPFilterBrands Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.FreqIP Namespace : ImGearFreqIPFilterBrands Enumeration
Defines the different kind of filter brands available.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFreqIPFilterBrands
   Inherits System.Enum
'Usage

Dim instance As ImGearFreqIPFilterBrands
public enum ImGearFreqIPFilterBrands : System.Enum
__value public enum ImGearFreqIPFilterBrands : public System.Enum
public enum class ImGearFreqIPFilterBrands : public System.Enum
Members
Member | Value | Description
BUTTERWORTH | 1 | Butterworth Filter.
CHEBYSHEV_I | 3 | Type 1 Chebyshev Filter.
CHEBYSHEV_II | 4 | Type 2 Chebyshev Filter.
GAUSSIAN | 2 | Gaussian Filter.
IDEAL | 0 | Ideal Filter.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.FreqIP.ImGearFreqIPFilterBrands

See Also

Reference

ImageGear.FreqIP Namespace


ImageGear.Processing Namespace (ImageGear22.Processing.Advanced)
Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.Processing Namespace

This namespace represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as remove red eye, perspective, solarize, warp, wave, etc.

Classes
 | Class | Description
Class | ImGearEffects | Contains methods for image effects.
Class | ImGearEffectsVerifier | Contains methods that check whether a particular effect can be performed on an image.
Class | ImGearMosaicBorderParams | Describes border characteristics of the Mosaic operation.
Class | ImGearMosaicCellParams | Describes cell parameters of the Mosaic operation.
Class | ImGearMosaicFillParams | Describes fill characteristics of the Mosaic operation.
Class | ImGearMosaicShadowParams | Describes parameters of the shadow effect to be applied to an image after dividing on the cells.
Class | ImGearPicturizeMatchingMatrix | Matches cell images to fragments of the image to which the Picturize effect will be applied.
Class | ImGearPicturizePreprocessedCollection | Preprocesses and stores a collection of cell images for Picturize effect.
Class | ImGearPixelateBorderParams | Describes border characteristics of the Pixelate operation.
Class | ImGearPixelateCellParams | Describes cell parameters of the Pixelate operation.
Class | ImGearPixelateFillParams | Describes fill characteristics of the Pixelate operation.
Class | ImGearPixelCheckerRedEyeRGB | Checks the RGB pixel using red-eye detection algorithm.
Class | ImGearPixelCheckerThreshold | Checks the pixel using the initial pixel and the threshold.
Class | ImGearSpotlight | This class contains parameters of a spotlight that can be used to highlight an image.
Interfaces
 | Interface | Description
Interface | IImGearPixelChecker | An implementation of this interface is passed to ImGearEffects.DetectArea method.
Structures
 | Structure | Description
Structure | ImGearPicturizeDistributionSettings | Stores cell image distribution settings for the Picturize effect.
Structure | ImGearPicturizeMatchingSettings | Stores the settings that specify how the ImGearEffects.Picturize method will match cell images to fragments of the source image.
Structure | ImGearPicturizeMixingSettings | Stores the settings that specify how the ImGearEffects.Picturize method can modify cell images for the Picturize effect.
Enumerations
 | Enumeration | Description
Enumeration | ImGearMonochromeFilmPreset | Identifies preset parameters for the ImGearEffects.MonochromeFilm method.
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Processing Namespace (ImageGear22.Processing.Advanced) Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.Processing Namespace
Inheritance Hierarchy
System.Object
ImageGear.Processing.ImGearEffects
ImageGear.Processing.ImGearEffectsVerifier
ImageGear.Processing.ImGearMosaicBorderParams
ImageGear.Processing.ImGearMosaicCellParams
ImageGear.Processing.ImGearMosaicFillParams
ImageGear.Processing.ImGearMosaicShadowParams
ImageGear.Processing.ImGearPicturizeMatchingMatrix
ImageGear.Processing.ImGearPicturizePreprocessedCollection
ImageGear.Processing.ImGearPixelateBorderParams
ImageGear.Processing.ImGearPixelateCellParams
ImageGear.Processing.ImGearPixelateFillParams
ImageGear.Processing.ImGearPixelCheckerRedEyeRGB
ImageGear.Processing.ImGearPixelCheckerThreshold
ImageGear.Processing.ImGearSpotlight
System.ValueType
ImageGear.Processing.ImGearPicturizeDistributionSettings
ImageGear.Processing.ImGearPicturizeMatchingSettings
ImageGear.Processing.ImGearPicturizeMixingSettings
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%PageItemTitle%%

ImGearEffects Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffects Class
Contains methods for image effects.
Object Model
ImGearEffects ClassImGearRasterPage ClassImGearEffectsVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearEffects
'Usage

Dim instance As ImGearEffects
public sealed class ImGearEffects
public __gc __sealed class ImGearEffects
public ref class ImGearEffects sealed
Remarks
This is the main class for effects processing operations.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearEffects

See Also

Reference

ImGearEffects Members
ImageGear.Processing Namespace
ImGearEffectsVerifier Class


%%PageItemTitle%% $$Members$$

ImGearEffects Class Members
Properties Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffects Class

The following tables list the members exposed by ImGearEffects.

Public Constructors
 | Name | Description
Public Constructor | ImGearEffects Constructor |
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets verificator for general effects functions.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AdjustWhiteBalance | Overloaded. This method allows correction of white balance of the image.
static (Shared in Visual Basic) | Aging | Applies an aging effect to make an image look older.
static (Shared in Visual Basic) | Boost | This method increases saturation, brightness and contrast of the image.
static (Shared in Visual Basic) | DetectArea | This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.
static (Shared in Visual Basic) | DirectionalLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | DirectionalWave | Provides a directional wave effect on the current raster page.
static (Shared in Visual Basic) | DropShadow | This method adds a drop shadow to an image.
static (Shared in Visual Basic) | Duotone | This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.
static (Shared in Visual Basic) | EdgeDetection | Performs the edge detection operation specified by the method argument.
static (Shared in Visual Basic) | EdgeMap | Overloaded. Performs the edge map operation specified by the method argument. Processes color channels only.
static (Shared in Visual Basic) | Fragment | This method fragments an image into four blended images that move diagonally outward from the original image.
static (Shared in Visual Basic) | FreeDirectionalLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | FreeRadialLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | GlowingEdges | Applies 'glowing edges' effect to the image.
static (Shared in Visual Basic) | HighDensityRangeEffect | Makes the image look as if it was taken in a High Density Range mode, by adding bright colors to image edges.
static (Shared in Visual Basic) | HotWax | This method transforms the image so that it looks like it has been coated by hot wax.
static (Shared in Visual Basic) | LensFlare | Applies a lens flare effect to the image.
static (Shared in Visual Basic) | MonochromeFilm | Applies a Monochrome Film effect on the image.
static (Shared in Visual Basic) | Mosaic | This method provides 3D mosaic effect on an image.
static (Shared in Visual Basic) | NightVision | This method applies 'night vision' effect to the image.
static (Shared in Visual Basic) | Oilify | This method applies an effect to an image that makes it appear similar to an oil painting.
static (Shared in Visual Basic) | Perspective | This method provides a perspective-like effect by image corners transformation.
static (Shared in Visual Basic) | Picturize | This method applies the Picturize effect on a raster image.
static (Shared in Visual Basic) | Pinch | This method pinches a page toward or away from the pinch center.
static (Shared in Visual Basic) | Pixelate | This method divides an image into cells and fills every cell according to the cell and fill parameters.
static (Shared in Visual Basic) | Pointillist | Applies an effect to an image that makes it appear to have been painted in the pointillism style of painting.
static (Shared in Visual Basic) | ProcessArea | This method processes all pixels in the ROI area using a specified pixel processor.
static (Shared in Visual Basic) | RadialLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | RadialWave | This method provides a radial wave effect on the current raster page.
static (Shared in Visual Basic) | RemoveChromaticAberration | This method removes chromatic aberration artifacts from an image.
static (Shared in Visual Basic) | Ripple | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RippleFreeHand | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RippleTexture | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RoundCorners | This method rounds the corners of the image and fills them with a specified color.
static (Shared in Visual Basic) | Sepia | This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.
static (Shared in Visual Basic) | Shear | Applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
static (Shared in Visual Basic) | Sketch | Applies a sketch effect on the image.
static (Shared in Visual Basic) | Solarize | Overloaded. This method inverts the colors of pixels whose lightness exceeds the specified threshold.
static (Shared in Visual Basic) | Spatter | This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting.
static (Shared in Visual Basic) | Spotlights | This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.
static (Shared in Visual Basic) | SpotlightsPreview | This method creates a reduced size preview for the Spotlights effect.
static (Shared in Visual Basic) | ToyCamera | This method makes the image look as if it was taken by a toy camera.
static (Shared in Visual Basic) | Vignette | This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
static (Shared in Visual Basic) | WarpCylinder | This method provides warping around cylinder on the current raster page.
static (Shared in Visual Basic) | WarpParabolic | This method provides warping around paraboloid on the current raster page.
static (Shared in Visual Basic) | WarpSphere | This method provides warping around sphere on the current raster page.
Top
See Also

Reference

ImGearEffects Class
ImageGear.Processing Namespace
ImGearEffectsVerifier Class


%%PageItemTitle%%

ImGearEffects Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : ImGearEffects Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEffects()
public ImGearEffects()
public: ImGearEffects();
public:
ImGearEffects();
See Also

Reference

ImGearEffects Class
ImGearEffects Members


%%PageItemTitle%% $$Methods$$

ImGearEffects Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffects Class

For a list of all members of this type, see ImGearEffects members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AdjustWhiteBalance | Overloaded. This method allows correction of white balance of the image.
static (Shared in Visual Basic) | Aging | Applies an aging effect to make an image look older.
static (Shared in Visual Basic) | Boost | This method increases saturation, brightness and contrast of the image.
static (Shared in Visual Basic) | DetectArea | This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.
static (Shared in Visual Basic) | DirectionalLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | DirectionalWave | Provides a directional wave effect on the current raster page.
static (Shared in Visual Basic) | DropShadow | This method adds a drop shadow to an image.
static (Shared in Visual Basic) | Duotone | This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.
static (Shared in Visual Basic) | EdgeDetection | Performs the edge detection operation specified by the method argument.
static (Shared in Visual Basic) | EdgeMap | Overloaded. Performs the edge map operation specified by the method argument. Processes color channels only.
static (Shared in Visual Basic) | Fragment | This method fragments an image into four blended images that move diagonally outward from the original image.
static (Shared in Visual Basic) | FreeDirectionalLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | FreeRadialLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | GlowingEdges | Applies 'glowing edges' effect to the image.
static (Shared in Visual Basic) | HighDensityRangeEffect | Makes the image look as if it was taken in a High Density Range mode, by adding bright colors to image edges.
static (Shared in Visual Basic) | HotWax | This method transforms the image so that it looks like it has been coated by hot wax.
static (Shared in Visual Basic) | LensFlare | Applies a lens flare effect to the image.
static (Shared in Visual Basic) | MonochromeFilm | Applies a Monochrome Film effect on the image.
static (Shared in Visual Basic) | Mosaic | This method provides 3D mosaic effect on an image.
static (Shared in Visual Basic) | NightVision | This method applies 'night vision' effect to the image.
static (Shared in Visual Basic) | Oilify | This method applies an effect to an image that makes it appear similar to an oil painting.
static (Shared in Visual Basic) | Perspective | This method provides a perspective-like effect by image corners transformation.
static (Shared in Visual Basic) | Picturize | This method applies the Picturize effect on a raster image.
static (Shared in Visual Basic) | Pinch | This method pinches a page toward or away from the pinch center.
static (Shared in Visual Basic) | Pixelate | This method divides an image into cells and fills every cell according to the cell and fill parameters.
static (Shared in Visual Basic) | Pointillist | Applies an effect to an image that makes it appear to have been painted in the pointillism style of painting.
static (Shared in Visual Basic) | ProcessArea | This method processes all pixels in the ROI area using a specified pixel processor.
static (Shared in Visual Basic) | RadialLight | This method changes the colors of an image according to the pattern of a sine wave.
static (Shared in Visual Basic) | RadialWave | This method provides a radial wave effect on the current raster page.
static (Shared in Visual Basic) | RemoveChromaticAberration | This method removes chromatic aberration artifacts from an image.
static (Shared in Visual Basic) | Ripple | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RippleFreeHand | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RippleTexture | This method provides the ripple effect on the image, as if it is looked at through a relief glass.
static (Shared in Visual Basic) | RoundCorners | This method rounds the corners of the image and fills them with a specified color.
static (Shared in Visual Basic) | Sepia | This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.
static (Shared in Visual Basic) | Shear | Applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
static (Shared in Visual Basic) | Sketch | Applies a sketch effect on the image.
static (Shared in Visual Basic) | Solarize | Overloaded. This method inverts the colors of pixels whose lightness exceeds the specified threshold.
static (Shared in Visual Basic) | Spatter | This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting.
static (Shared in Visual Basic) | Spotlights | This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.
static (Shared in Visual Basic) | SpotlightsPreview | This method creates a reduced size preview for the Spotlights effect.
static (Shared in Visual Basic) | ToyCamera | This method makes the image look as if it was taken by a toy camera.
static (Shared in Visual Basic) | Vignette | This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
static (Shared in Visual Basic) | WarpCylinder | This method provides warping around cylinder on the current raster page.
static (Shared in Visual Basic) | WarpParabolic | This method provides warping around paraboloid on the current raster page.
static (Shared in Visual Basic) | WarpSphere | This method provides warping around sphere on the current raster page.
Top
See Also

Reference

ImGearEffects Class
ImageGear.Processing Namespace
ImGearEffectsVerifier Class


AdjustWhiteBalance Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : AdjustWhiteBalance Method
This method allows correction of white balance of the image.
Overload List
Overload | Description
AdjustWhiteBalance(ImGearRasterPage,ImGearDoublePoint,ImGearDoublePoint) | This method allows correction of white balance of the image.
AdjustWhiteBalance(ImGearRasterPage,ImGearWhiteBalancePreset,ImGearWhiteBalancePreset) | This method allows correction of white balance of the image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


AdjustWhiteBalance(ImGearRasterPage,ImGearDoublePoint,ImGearDoublePoint) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > AdjustWhiteBalance Method : AdjustWhiteBalance(ImGearRasterPage,ImGearDoublePoint,ImGearDoublePoint) Method
Page to process.
White point used when shooting the source picture.
Correct white point, matching actual shooting conditions better.
This method allows correction of white balance of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub AdjustWhiteBalance( _
   ByVal page As ImGearRasterPage, _
   ByVal sourceWhiteXY As ImGearDoublePoint, _
   ByVal destinationWhiteXY As ImGearDoublePoint _
)
'Usage

Dim page As ImGearRasterPage
Dim sourceWhiteXY As ImGearDoublePoint
Dim destinationWhiteXY As ImGearDoublePoint

ImGearEffects.AdjustWhiteBalance(page, sourceWhiteXY, destinationWhiteXY)
public static void AdjustWhiteBalance(
   ImGearRasterPage page,
   ImGearDoublePoint sourceWhiteXY,
   ImGearDoublePoint destinationWhiteXY
)
public: static void AdjustWhiteBalance(
   ImGearRasterPage* page,
   ImGearDoublePoint sourceWhiteXY,
   ImGearDoublePoint destinationWhiteXY
)
public:
static void AdjustWhiteBalance(
   ImGearRasterPage^ page,
   ImGearDoublePoint sourceWhiteXY,
   ImGearDoublePoint destinationWhiteXY
)

Parameters

page
Page to process.
sourceWhiteXY
White point used when shooting the source picture.
destinationWhiteXY
Correct white point, matching actual shooting conditions better.
Remarks
This method allows to correct white balance of the image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use the AdjustWhiteBalance method, setting source white balance to Tungsten and destination white balance to Daylight.

This method can also be used to make image colors 'cooler' or 'warmer'. To make the image look warmer, use a source white point corresponding to a higher color temperature, and a destination white point corresponding to a lower color temperature. To make the image look cooler, use a source white point corresponding to a lower color temperature, and a destination white point corresponding to a higher color temperature.

You can use ImGearWhiteBalance class object to calculate a white point corresponding to a specific color temperature and tint, or to a preset value.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearRasterPage Class
ImGearWhiteBalance Class


AdjustWhiteBalance(ImGearRasterPage,ImGearWhiteBalancePreset,ImGearWhiteBalancePreset) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > AdjustWhiteBalance Method : AdjustWhiteBalance(ImGearRasterPage,ImGearWhiteBalancePreset,ImGearWhiteBalancePreset) Method
Page to process.
White balance preset value used when shooting the source picture.
Correct white balance preset value, matching actual shooting conditions better.
This method allows correction of white balance of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub AdjustWhiteBalance( _
   ByVal page As ImGearRasterPage, _
   ByVal sourceWhite As ImGearWhiteBalancePreset, _
   ByVal destinationWhite As ImGearWhiteBalancePreset _
)
'Usage

Dim page As ImGearRasterPage
Dim sourceWhite As ImGearWhiteBalancePreset
Dim destinationWhite As ImGearWhiteBalancePreset

ImGearEffects.AdjustWhiteBalance(page, sourceWhite, destinationWhite)
public static void AdjustWhiteBalance(
   ImGearRasterPage page,
   ImGearWhiteBalancePreset sourceWhite,
   ImGearWhiteBalancePreset destinationWhite
)
public: static void AdjustWhiteBalance(
   ImGearRasterPage* page,
   ImGearWhiteBalancePreset sourceWhite,
   ImGearWhiteBalancePreset destinationWhite
)
public:
static void AdjustWhiteBalance(
   ImGearRasterPage^ page,
   ImGearWhiteBalancePreset sourceWhite,
   ImGearWhiteBalancePreset destinationWhite
)

Parameters

page
Page to process.
sourceWhite
White balance preset value used when shooting the source picture.
destinationWhite
Correct white balance preset value, matching actual shooting conditions better.
Remarks
This method allows to correct white balance of the image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use the AdjustWhiteBalance method, setting the source white balance to Tungsten and the destination white balance to Daylight.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearRasterPage Class


Aging Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Aging Method
Image to apply aging effect to.
Adjusts color saturation of the original image. The value should range from 0 to 1, where 0 removes all color from the image, and 1 does not adjust color saturation.
Amount of noise to add to the image. The value should range from 0 to 50.
Adjusts image contrast. The value should range from 0 to 1, where 0 is minimum contrast, and 1 does not adjust contrast. Values less than 0 produce inverted contrast.
Adjusts contrast of random vertical lines added to the image. The value should range from -1 to 1, where -1 is completely black lines, 0 is invisible lines, and 1 is completely white lines. Values between 0 and 1, for example, blend line color between original image pixel colors and white.
Adjusts density (quantity) of random vertical lines added to the image. The value should range from 0 to the width of the image in pixels, where 0 would add no lines, and the width of the image in pixels would fill the image with lines.
Adjusts color tint of the image. The color of the image will be tinted according to the values of the array. The array consists of three elements that represent red, green, and blue adjustment factors. Each element ranges from -1 to 1, where a value of 0 represents no change to the image's color component, -1 represents complete change to the color component's minimum value, and 1 represents complete change to the color component's maximum value.
Applies an aging effect to make an image look older.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Aging( _
   ByVal page As ImGearRasterPage, _
   ByVal saturation As Double, _
   ByVal deviation As Double, _
   ByVal imageContrast As Double, _
   ByVal lineContrast As Double, _
   ByVal lineDensity As Integer, _
   ByVal backgroundColor() As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim saturation As Double
Dim deviation As Double
Dim imageContrast As Double
Dim lineContrast As Double
Dim lineDensity As Integer
Dim backgroundColor() As Double

ImGearEffects.Aging(page, saturation, deviation, imageContrast, lineContrast, lineDensity, backgroundColor)
public static void Aging(
   ImGearRasterPage page,
   double saturation,
   double deviation,
   double imageContrast,
   double lineContrast,
   int lineDensity,
   double[] backgroundColor
)
public: static void Aging(
   ImGearRasterPage* page,
   double saturation,
   double deviation,
   double imageContrast,
   double lineContrast,
   int lineDensity,
   double[]* backgroundColor
)
public:
static void Aging(
   ImGearRasterPage^ page,
   double saturation,
   double deviation,
   double imageContrast,
   double lineContrast,
   int lineDensity,
   array<double>^ backgroundColor
)

Parameters

page
Image to apply aging effect to.
saturation
Adjusts color saturation of the original image. The value should range from 0 to 1, where 0 removes all color from the image, and 1 does not adjust color saturation.
deviation
Amount of noise to add to the image. The value should range from 0 to 50.
imageContrast
Adjusts image contrast. The value should range from 0 to 1, where 0 is minimum contrast, and 1 does not adjust contrast. Values less than 0 produce inverted contrast.
lineContrast
Adjusts contrast of random vertical lines added to the image. The value should range from -1 to 1, where -1 is completely black lines, 0 is invisible lines, and 1 is completely white lines. Values between 0 and 1, for example, blend line color between original image pixel colors and white.
lineDensity
Adjusts density (quantity) of random vertical lines added to the image. The value should range from 0 to the width of the image in pixels, where 0 would add no lines, and the width of the image in pixels would fill the image with lines.
backgroundColor
Adjusts color tint of the image. The color of the image will be tinted according to the values of the array. The array consists of three elements that represent red, green, and blue adjustment factors. Each element ranges from -1 to 1, where a value of 0 represents no change to the image's color component, -1 represents complete change to the color component's minimum value, and 1 represents complete change to the color component's maximum value.
Remarks
The effect can adjust image saturation and contrast, and add noise and random vertical lines to the image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


Boost Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Boost Method
Page to process.
Amount by which to boost (or 'unboost') colors in the image. 1.0 corresponds to no change, < 1.0 decreases saturation and brightness, > 1.0 increases saturation and brightness.
This method increases saturation, brightness and contrast of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Boost( _
   ByVal page As ImGearRasterPage, _
   ByVal strength As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim strength As Double

ImGearEffects.Boost(page, strength)
public static void Boost(
   ImGearRasterPage page,
   double strength
)
public: static void Boost(
   ImGearRasterPage* page,
   double strength
)
public:
static void Boost(
   ImGearRasterPage^ page,
   double strength
)

Parameters

page
Page to process.
strength
Amount by which to boost (or 'unboost') colors in the image. 1.0 corresponds to no change, < 1.0 decreases saturation and brightness, > 1.0 increases saturation and brightness.
Remarks
Use this method if you need a simple way to make old and faded images look more vivid.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


DetectArea Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : DetectArea Method
Page class object.
A point inside the area to be searched.
Implementation of IImGearPixelChecker interface with the implemented method CheckPixel. See IImGearPixelChecker interface for more details.
This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DetectArea( _
   ByVal page As ImGearRasterPage, _
   ByVal point As ImGearPoint, _
   ByVal checker As IImGearPixelChecker _
)
'Usage

Dim page As ImGearRasterPage
Dim point As ImGearPoint
Dim checker As IImGearPixelChecker

ImGearEffects.DetectArea(page, point, checker)
public static void DetectArea(
   ImGearRasterPage page,
   ImGearPoint point,
   IImGearPixelChecker checker
)
public: static void DetectArea(
   ImGearRasterPage* page,
   ImGearPoint point,
   IImGearPixelChecker* checker
)
public:
static void DetectArea(
   ImGearRasterPage^ page,
   ImGearPoint point,
   IImGearPixelChecker^ checker
)

Parameters

page
Page class object.
point
A point inside the area to be searched.
checker
Implementation of IImGearPixelChecker interface with the implemented method CheckPixel. See IImGearPixelChecker interface for more details.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
IImGearPixelChecker Interface
ImGearPixelCheckerRedEyeRGB Class
ImGearRasterPage Class
ImGearPoint Structure


DirectionalLight Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : DirectionalLight Method
Image to apply direct light effect to.
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
This method changes the colors of an image according to the pattern of a sine wave.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DirectionalLight( _
   ByVal page As ImGearRasterPage, _
   ByVal direction As Single, _
   ByVal amplitude() As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single _
)
'Usage

Dim page As ImGearRasterPage
Dim direction As Single
Dim amplitude() As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single

ImGearEffects.DirectionalLight(page, direction, amplitude, frequency, phase, attenuation)
public static void DirectionalLight(
   ImGearRasterPage page,
   float direction,
   float[] amplitude,
   float frequency,
   float phase,
   float attenuation
)
public: static void DirectionalLight(
   ImGearRasterPage* page,
   float direction,
   float[]* amplitude,
   float frequency,
   float phase,
   float attenuation
)
public:
static void DirectionalLight(
   ImGearRasterPage^ page,
   float direction,
   array<float>^ amplitude,
   float frequency,
   float phase,
   float attenuation
)

Parameters

page
Image to apply direct light effect to.
direction
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
amplitude
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
Remarks
The image will appear to have regularly spaced bars of light and shadow overlaid on top of it.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


DirectionalWave Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : DirectionalWave Method
Page class object.
Wave angle, in radians.
Wave amplitude. Measurement units - pixel / 100.
Wave frequency. The frequency is defined as 1 / T, where T is a wave period in pixels.
Wave phase, in radians.
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
If this parameter is true then an interpolation is used during processing.
ImageGear.Core.ImGearPixel class color.
Provides a directional wave effect on the current raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DirectionalWave( _
   ByVal page As ImGearRasterPage, _
   ByVal angle As Single, _
   ByVal amplitude As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim angle As Single
Dim amplitude As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.DirectionalWave(page, angle, amplitude, frequency, phase, attenuation, interpolate, color)
public static void DirectionalWave(
   ImGearRasterPage page,
   float angle,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel color
)
public: static void DirectionalWave(
   ImGearRasterPage* page,
   float angle,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel* color
)
public:
static void DirectionalWave(
   ImGearRasterPage^ page,
   float angle,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page class object.
angle
Wave angle, in radians.
amplitude
Wave amplitude. Measurement units - pixel / 100.
frequency
Wave frequency. The frequency is defined as 1 / T, where T is a wave period in pixels.
phase
Wave phase, in radians.
attenuation
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
interpolate
If this parameter is true then an interpolation is used during processing.
color
ImageGear.Core.ImGearPixel class color.
Example
  • C#
// Warps the image with a wave at a 45 degree angle, an amplitude of 0.25, frequency of 50 pixels,
//  0 phase, and no attenuation. Interpolation is enabled, and no fill color is specified.
ImGearEffects.DirectionalWave(
    igRasterPage, (float)(45.0 / 180.0 * Math.PI), (float)(0.25), (float)(1.0 / 50.0),
    (float)(0.0), (float)(0.0), true, null);
  • Visual Basic
' Warps the image with a wave at a 45 degree angle, an amplitude of 0.25, frequency of 50 pixels,
     '  0 phase, and no attenuation. Interpolation is enabled, and no fill color is specified.
     ImGearEffects.DirectionalWave(igRasterPage, CSng((45 / 180 * Math.PI)), CSng((0.25)), CSng((1 / 50)), _
CSng((0)), CSng((0)), True, Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
CanApplyWave Method
ImGearRasterPage Class
ImGearPixel Class


DropShadow Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : DropShadow Method
Image to apply drop shadow effect to.
Width of background and shadow area to add to the image.
Distance to move image from shadow area.
Angle (direction) of movement of image from shadow area.
Color of shadow area.
Color of background.
This method adds a drop shadow to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DropShadow( _
   ByVal page As ImGearRasterPage, _
   ByVal width As Integer, _
   ByVal distance As Integer, _
   ByVal angle As Integer, _
   ByVal insideColor As ImGearPixel, _
   ByVal outsideColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim width As Integer
Dim distance As Integer
Dim angle As Integer
Dim insideColor As ImGearPixel
Dim outsideColor As ImGearPixel

ImGearEffects.DropShadow(page, width, distance, angle, insideColor, outsideColor)
public static void DropShadow(
   ImGearRasterPage page,
   int width,
   int distance,
   int angle,
   ImGearPixel insideColor,
   ImGearPixel outsideColor
)
public: static void DropShadow(
   ImGearRasterPage* page,
   int width,
   int distance,
   int angle,
   ImGearPixel* insideColor,
   ImGearPixel* outsideColor
)
public:
static void DropShadow(
   ImGearRasterPage^ page,
   int width,
   int distance,
   int angle,
   ImGearPixel^ insideColor,
   ImGearPixel^ outsideColor
)

Parameters

page
Image to apply drop shadow effect to.
width
Width of background and shadow area to add to the image.
distance
Distance to move image from shadow area.
angle
Angle (direction) of movement of image from shadow area.
insideColor
Color of shadow area.
outsideColor
Color of background.
Remarks
The image is enlarged to contain a background and shadowed area.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPixel Class


Duotone Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Duotone Method
Page class object.
Color to which to map the darkest areas of the source image.
Color to which to map the lightest areas of the source image.
This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Duotone( _
   ByVal page As ImGearRasterPage, _
   ByVal color1 As ImGearPixel, _
   ByVal color2 As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim color1 As ImGearPixel
Dim color2 As ImGearPixel

ImGearEffects.Duotone(page, color1, color2)
public static void Duotone(
   ImGearRasterPage page,
   ImGearPixel color1,
   ImGearPixel color2
)
public: static void Duotone(
   ImGearRasterPage* page,
   ImGearPixel* color1,
   ImGearPixel* color2
)
public:
static void Duotone(
   ImGearRasterPage^ page,
   ImGearPixel^ color1,
   ImGearPixel^ color2
)

Parameters

page
Page class object.
color1
Color to which to map the darkest areas of the source image.
color2
Color to which to map the lightest areas of the source image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


EdgeDetection Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : EdgeDetection Method
Performs the edge detection operation specified by the method argument.
Overload List
Overload | Description
EdgeDetection | Performs the edge detection operation specified by the method argument.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


EdgeDetection(ImGearRasterPage,ImGearEdgeDetectionMethods) Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : EdgeDetection(ImGearRasterPage,ImGearEdgeDetectionMethods) Method
An ImageGear.Core.ImGearRasterPage class object on which the algorithm will be performed.
Type of edge detection method to perform.
Performs the edge detection operation specified by the method argument.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub EdgeDetection( _
   ByVal page As ImGearRasterPage, _
   ByVal method As ImGearEdgeDetectionMethods _
)
'Usage

Dim page As ImGearRasterPage
Dim method As ImGearEdgeDetectionMethods

ImGearEffects.EdgeDetection(page, method)
public static void EdgeDetection(
   ImGearRasterPage page,
   ImGearEdgeDetectionMethods method
)
public: static void EdgeDetection(
   ImGearRasterPage* page,
   ImGearEdgeDetectionMethods method
)
public:
static void EdgeDetection(
   ImGearRasterPage^ page,
   ImGearEdgeDetectionMethods method
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object on which the algorithm will be performed.
method
Type of edge detection method to perform.
Remarks
Method can be applied only to 8bit grayscale images with one channel.
Example
  • C#
// Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.Gy));
ImGearEffects.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE);
  • Visual Basic
' Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.Gy))
ImGearEffects.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearEdgeDetectionMethods Enumeration
ImGearRasterPage Class


EdgeMap Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : EdgeMap Method
Performs the edge map operation specified by the method argument. Processes color channels only.
Overload List
Overload | Description
EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods) | Performs the edge map operation specified by the method argument. Processes color channels only.
EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods,ImGearChannelRange) | Performs the edge map operation specified by the method argument. Processes a specified range of channels.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods) Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > EdgeMap Method : EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods) Method
An ImageGear.Core.ImGearRasterPage class object to detect edge map for.
Type of edge map operation to perform.
Performs the edge map operation specified by the method argument. Processes color channels only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub EdgeMap( _
   ByVal page As ImGearRasterPage, _
   ByVal method As ImGearEdgeMapMethods _
)
'Usage

Dim page As ImGearRasterPage
Dim method As ImGearEdgeMapMethods

ImGearEffects.EdgeMap(page, method)
public static void EdgeMap(
   ImGearRasterPage page,
   ImGearEdgeMapMethods method
)
public: static void EdgeMap(
   ImGearRasterPage* page,
   ImGearEdgeMapMethods method
)
public:
static void EdgeMap(
   ImGearRasterPage^ page,
   ImGearEdgeMapMethods method
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to detect edge map for.
method
Type of edge map operation to perform.
Remarks
An edge map is an image that shows where there are changes in contrast in the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This method takes into account the ROI settings of page object that are accessible via the ImageGear.Core.ImGearRasterPage.ROI property. By default ROI is set to the entire image.

Example
  • C#
// Filters an image into an edge map.
ImGearEffects.EdgeMap(igRasterPage, ImGearEdgeMapMethods.PREWITT);
  • Visual Basic
' Filters an image into an edge map.
ImGearEffects.EdgeMap(igRasterPage, ImGearEdgeMapMethods.PREWITT)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearEdgeMapMethods Enumeration
CanApplyEdgeMap Method
ImGearRasterPage Class


EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods,ImGearChannelRange) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > EdgeMap Method : EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods,ImGearChannelRange) Method
An ImageGear.Core.ImGearRasterPage class object to detect edge map for.
Type of edge map operation to perform.
Channel range to apply the operation.
Performs the edge map operation specified by the method argument. Processes a specified range of channels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub EdgeMap( _
   ByVal page As ImGearRasterPage, _
   ByVal method As ImGearEdgeMapMethods, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim method As ImGearEdgeMapMethods
Dim channels As ImGearChannelRange

ImGearEffects.EdgeMap(page, method, channels)
public static void EdgeMap(
   ImGearRasterPage page,
   ImGearEdgeMapMethods method,
   ImGearChannelRange channels
)
public: static void EdgeMap(
   ImGearRasterPage* page,
   ImGearEdgeMapMethods method,
   ImGearChannelRange channels
)
public:
static void EdgeMap(
   ImGearRasterPage^ page,
   ImGearEdgeMapMethods method,
   ImGearChannelRange channels
)

Parameters

page
An ImageGear.Core.ImGearRasterPage class object to detect edge map for.
method
Type of edge map operation to perform.
channels
Channel range to apply the operation.
Remarks
An edge map is an image that shows where there are changes in contrast in the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This method takes into account the ROI settings of page object, that are accessible via the ImageGear.Core.ImGearRasterPage.ROI property. By default ROI is set to the entire image.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearEdgeMapMethods Enumeration
CanApplyEdgeMap Method
ImGearChannelRange Structure
ImGearRasterPage Class


Fragment Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Fragment Method
Image to apply fragment effect to.
Distance in pixels to move each blended image away from the original image.
This method fragments an image into four blended images that move diagonally outward from the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Fragment( _
   ByVal page As ImGearRasterPage, _
   ByVal displacement As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim displacement As Integer

ImGearEffects.Fragment(page, displacement)
public static void Fragment(
   ImGearRasterPage page,
   int displacement
)
public: static void Fragment(
   ImGearRasterPage* page,
   int displacement
)
public:
static void Fragment(
   ImGearRasterPage^ page,
   int displacement
)

Parameters

page
Image to apply fragment effect to.
displacement
Distance in pixels to move each blended image away from the original image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


FreeDirectionalLight Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : FreeDirectionalLight Method
Image to apply free directional light effect to.
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
This method changes the colors of an image according to the pattern of a sine wave.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub FreeDirectionalLight( _
   ByVal page As ImGearRasterPage, _
   ByVal direction As Single, _
   ByVal points() As Single, _
   ByVal amplitude() As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single _
)
'Usage

Dim page As ImGearRasterPage
Dim direction As Single
Dim points() As Single
Dim amplitude() As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single

ImGearEffects.FreeDirectionalLight(page, direction, points, amplitude, frequency, phase, attenuation)
public static void FreeDirectionalLight(
   ImGearRasterPage page,
   float direction,
   float[] points,
   float[] amplitude,
   float frequency,
   float phase,
   float attenuation
)
public: static void FreeDirectionalLight(
   ImGearRasterPage* page,
   float direction,
   float[]* points,
   float[]* amplitude,
   float frequency,
   float phase,
   float attenuation
)
public:
static void FreeDirectionalLight(
   ImGearRasterPage^ page,
   float direction,
   array<float>^ points,
   array<float>^ amplitude,
   float frequency,
   float phase,
   float attenuation
)

Parameters

page
Image to apply free directional light effect to.
direction
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
points
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
amplitude
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
Remarks
The image will appear to have regularly spaced bars of light and/or shadow overlaid on top of it.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


FreeRadialLight Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : FreeRadialLight Method
Image to apply free radial light effect to.
Center point in the image (in pixels) about which the effect is applied.
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
This method changes the colors of an image according to the pattern of a sine wave.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub FreeRadialLight( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal points() As Single, _
   ByVal amplitude() As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim points() As Single
Dim amplitude() As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single

ImGearEffects.FreeRadialLight(page, center, points, amplitude, frequency, phase, attenuation)
public static void FreeRadialLight(
   ImGearRasterPage page,
   ImGearPoint center,
   float[] points,
   float[] amplitude,
   float frequency,
   float phase,
   float attenuation
)
public: static void FreeRadialLight(
   ImGearRasterPage* page,
   ImGearPoint center,
   float[]* points,
   float[]* amplitude,
   float frequency,
   float phase,
   float attenuation
)
public:
static void FreeRadialLight(
   ImGearRasterPage^ page,
   ImGearPoint center,
   array<float>^ points,
   array<float>^ amplitude,
   float frequency,
   float phase,
   float attenuation
)

Parameters

page
Image to apply free radial light effect to.
center
Center point in the image (in pixels) about which the effect is applied.
points
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
amplitude
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
Remarks
The image will appear to have regularly spaced bars of light and/or shadow overlaid on top of it in a radial pattern.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure


GlowingEdges Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : GlowingEdges Method
Page to process.
Specifies intensity for the glowing edges. Useful range is 1...10.
Removes dark pixels from result image, leaving only bright edges. Valid range is 0..255.
Adjusts saturation of the result image. Useful range is 0.1...2.0; Set saturation to 1.0 to leave saturation unchanged.
Applies 'glowing edges' effect to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub GlowingEdges( _
   ByVal page As ImGearRasterPage, _
   ByVal intensity As Integer, _
   ByVal sharpness As Integer, _
   ByVal saturation As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim intensity As Integer
Dim sharpness As Integer
Dim saturation As Double

ImGearEffects.GlowingEdges(page, intensity, sharpness, saturation)
public static void GlowingEdges(
   ImGearRasterPage page,
   int intensity,
   int sharpness,
   double saturation
)
public: static void GlowingEdges(
   ImGearRasterPage* page,
   int intensity,
   int sharpness,
   double saturation
)
public:
static void GlowingEdges(
   ImGearRasterPage^ page,
   int intensity,
   int sharpness,
   double saturation
)

Parameters

page
Page to process.
intensity
Specifies intensity for the glowing edges. Useful range is 1...10.
sharpness
Removes dark pixels from result image, leaving only bright edges. Valid range is 0..255.
saturation
Adjusts saturation of the result image. Useful range is 0.1...2.0; Set saturation to 1.0 to leave saturation unchanged.
Remarks
This method applies a Glowing Edges effect on the image. It highlights edges on the image with bright colors, and fills flat areas with black.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


HighDensityRangeEffect Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : HighDensityRangeEffect Method
Page to process.
Start intensity for the shadow range. Valid values are from 0.0 to shadowEnd. Set this parameter to a non-zero value if there are no black pixels in the image.
End intensity for the shadow range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5. ShadowStart and shadowEnd parameters define the range of pixels that will be brightened.
Maximum brightness for brightened shadow pixels, at which they will be included into the result image. Brighter pixels will be blended as semi-transparent with the result image.
Start intensity for the highlight range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. HighlightStart and highlightEnd parameters define the range of pixels that will be darkened.
End intensity for the highlight range. Valid values are from highlightStart to 1.0. Set this parameter to a value that is less than 1.0 if there are no pixels with maximal brightness in the image.
Minimum brightness for darkened highlight pixels, at which they will be included into the result image. Darker pixels will be blended as semi-transparent with the result image.
Start intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5.
End intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. MidtoneStart and midtoneEnd parameters define increase contrast for the midtone range.
Radius that defines the width of the edge between highlight and midtone areas. Smaller values make the details sharper, but may result in too frequent changes between shadow and highlight areas, actually reducing image contrast and resulting in possible artifacts. Greater values make shadow and highlight areas bigger and smoother, but may result in halos between the shadow and highlight areas. Greater values also result in longer processing. Useful values are in range from 1.0 to 1/4 of the image's smaller dimension.
Makes the image look as if it was taken in a High Density Range mode, by adding bright colors to image edges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub HighDensityRangeEffect( _
   ByVal page As ImGearRasterPage, _
   ByVal shadowStart As Double, _
   ByVal shadowEnd As Double, _
   ByVal shadowThreshold As Double, _
   ByVal highlightStart As Double, _
   ByVal highlightEnd As Double, _
   ByVal highlightThreshold As Double, _
   ByVal midtoneStart As Double, _
   ByVal midtoneEnd As Double, _
   ByVal radius As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim shadowStart As Double
Dim shadowEnd As Double
Dim shadowThreshold As Double
Dim highlightStart As Double
Dim highlightEnd As Double
Dim highlightThreshold As Double
Dim midtoneStart As Double
Dim midtoneEnd As Double
Dim radius As Double

ImGearEffects.HighDensityRangeEffect(page, shadowStart, shadowEnd, shadowThreshold, highlightStart, highlightEnd, highlightThreshold, midtoneStart, midtoneEnd, radius)
public static void HighDensityRangeEffect(
   ImGearRasterPage page,
   double shadowStart,
   double shadowEnd,
   double shadowThreshold,
   double highlightStart,
   double highlightEnd,
   double highlightThreshold,
   double midtoneStart,
   double midtoneEnd,
   double radius
)
public: static void HighDensityRangeEffect(
   ImGearRasterPage* page,
   double shadowStart,
   double shadowEnd,
   double shadowThreshold,
   double highlightStart,
   double highlightEnd,
   double highlightThreshold,
   double midtoneStart,
   double midtoneEnd,
   double radius
)
public:
static void HighDensityRangeEffect(
   ImGearRasterPage^ page,
   double shadowStart,
   double shadowEnd,
   double shadowThreshold,
   double highlightStart,
   double highlightEnd,
   double highlightThreshold,
   double midtoneStart,
   double midtoneEnd,
   double radius
)

Parameters

page
Page to process.
shadowStart
Start intensity for the shadow range. Valid values are from 0.0 to shadowEnd. Set this parameter to a non-zero value if there are no black pixels in the image.
shadowEnd
End intensity for the shadow range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5. ShadowStart and shadowEnd parameters define the range of pixels that will be brightened.
shadowThreshold
Maximum brightness for brightened shadow pixels, at which they will be included into the result image. Brighter pixels will be blended as semi-transparent with the result image.
highlightStart
Start intensity for the highlight range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. HighlightStart and highlightEnd parameters define the range of pixels that will be darkened.
highlightEnd
End intensity for the highlight range. Valid values are from highlightStart to 1.0. Set this parameter to a value that is less than 1.0 if there are no pixels with maximal brightness in the image.
highlightThreshold
Minimum brightness for darkened highlight pixels, at which they will be included into the result image. Darker pixels will be blended as semi-transparent with the result image.
midtoneStart
Start intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5.
midtoneEnd
End intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. MidtoneStart and midtoneEnd parameters define increase contrast for the midtone range.
radius
Radius that defines the width of the edge between highlight and midtone areas. Smaller values make the details sharper, but may result in too frequent changes between shadow and highlight areas, actually reducing image contrast and resulting in possible artifacts. Greater values make shadow and highlight areas bigger and smoother, but may result in halos between the shadow and highlight areas. Greater values also result in longer processing. Useful values are in range from 1.0 to 1/4 of the image's smaller dimension.
Remarks
This method applies a High Density Range effect on the image. It increases contrast separately in shadow, highlight, and midtone areas, imitating the human eye's ability to adapt for light conditions at the point of interest.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


HotWax Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : HotWax Method
Page to process.
Color that imitates the wax color. It is better to use light colors, to avoid overdarkening of the image.
This method transforms the image so that it looks like it has been coated by hot wax.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub HotWax( _
   ByVal page As ImGearRasterPage, _
   ByVal waxColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim waxColor As ImGearPixel

ImGearEffects.HotWax(page, waxColor)
public static void HotWax(
   ImGearRasterPage page,
   ImGearPixel waxColor
)
public: static void HotWax(
   ImGearRasterPage* page,
   ImGearPixel* waxColor
)
public:
static void HotWax(
   ImGearRasterPage^ page,
   ImGearPixel^ waxColor
)

Parameters

page
Page to process.
waxColor
Color that imitates the wax color. It is better to use light colors, to avoid overdarkening of the image.
Remarks
This method applies a HotWax effect on the image, making it look like it has been coated with wax.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPixel Class


LensFlare Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : LensFlare Method
Image to apply lens flare effect to.
Position of the primary flare.
Brightness of the primary flare. This value should range from 0 to 1.
Brightness of the secondary flare. This value should range from 0 to 1.
Predefined flare type to use. Determines the shape and appearance of the lens flare elements.
Applies a lens flare effect to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub LensFlare( _
   ByVal page As ImGearRasterPage, _
   ByVal flareCenter As ImGearPoint, _
   ByVal primaryBrightness As Double, _
   ByVal secondaryBrightness As Double, _
   ByVal flareType As ImGearLensFlareType _
)
'Usage

Dim page As ImGearRasterPage
Dim flareCenter As ImGearPoint
Dim primaryBrightness As Double
Dim secondaryBrightness As Double
Dim flareType As ImGearLensFlareType

ImGearEffects.LensFlare(page, flareCenter, primaryBrightness, secondaryBrightness, flareType)
public static void LensFlare(
   ImGearRasterPage page,
   ImGearPoint flareCenter,
   double primaryBrightness,
   double secondaryBrightness,
   ImGearLensFlareType flareType
)
public: static void LensFlare(
   ImGearRasterPage* page,
   ImGearPoint flareCenter,
   double primaryBrightness,
   double secondaryBrightness,
   ImGearLensFlareType flareType
)
public:
static void LensFlare(
   ImGearRasterPage^ page,
   ImGearPoint flareCenter,
   double primaryBrightness,
   double secondaryBrightness,
   ImGearLensFlareType flareType
)

Parameters

page
Image to apply lens flare effect to.
flareCenter
Position of the primary flare.
primaryBrightness
Brightness of the primary flare. This value should range from 0 to 1.
secondaryBrightness
Brightness of the secondary flare. This value should range from 0 to 1.
flareType
Predefined flare type to use. Determines the shape and appearance of the lens flare elements.
Remarks
The effect simulates a bright light, such as the sun, and some reflections within the lens. It is typically used to add a sense of drama or realism to a photographic image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearLensFlareType Enumeration


MonochromeFilm Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : MonochromeFilm Method
Page to process.
Specifies the type of film to imitate.
Applies a Monochrome Film effect on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub MonochromeFilm( _
   ByVal page As ImGearRasterPage, _
   ByVal preset As ImGearMonochromeFilmPreset _
)
'Usage

Dim page As ImGearRasterPage
Dim preset As ImGearMonochromeFilmPreset

ImGearEffects.MonochromeFilm(page, preset)
public static void MonochromeFilm(
   ImGearRasterPage page,
   ImGearMonochromeFilmPreset preset
)
public: static void MonochromeFilm(
   ImGearRasterPage* page,
   ImGearMonochromeFilmPreset preset
)
public:
static void MonochromeFilm(
   ImGearRasterPage^ page,
   ImGearMonochromeFilmPreset preset
)

Parameters

page
Page to process.
preset
Specifies the type of film to imitate.
Remarks
This method applies a Monochrome Film effect on the image, making it look like it has been taken with an analog camera, using monochrome film. The method takes a parameter specifying the settings, imitating particular film types.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearMonochromeFilmPreset Enumeration


Mosaic Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Mosaic Method
Page class object.
Fill parameters for mosaic operation. See ImGearMosaicFillParams description.
Parameters of the cell for mosaic operation. See ImGearMosaicCellParams description.
Parameters of cell borders. See ImGearMosaicBorderParams description.
Parameters of the shadow effect. See ImGearMosaicShadowParams description.
This method provides 3D mosaic effect on an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Mosaic( _
   ByVal page As ImGearRasterPage, _
   ByVal fillParameters As ImGearMosaicFillParams, _
   ByVal cellParameters As ImGearMosaicCellParams, _
   ByVal borderParameters As ImGearMosaicBorderParams, _
   ByVal shadowParameters As ImGearMosaicShadowParams _
)
'Usage

Dim page As ImGearRasterPage
Dim fillParameters As ImGearMosaicFillParams
Dim cellParameters As ImGearMosaicCellParams
Dim borderParameters As ImGearMosaicBorderParams
Dim shadowParameters As ImGearMosaicShadowParams

ImGearEffects.Mosaic(page, fillParameters, cellParameters, borderParameters, shadowParameters)
public static void Mosaic(
   ImGearRasterPage page,
   ImGearMosaicFillParams fillParameters,
   ImGearMosaicCellParams cellParameters,
   ImGearMosaicBorderParams borderParameters,
   ImGearMosaicShadowParams shadowParameters
)
public: static void Mosaic(
   ImGearRasterPage* page,
   ImGearMosaicFillParams* fillParameters,
   ImGearMosaicCellParams* cellParameters,
   ImGearMosaicBorderParams* borderParameters,
   ImGearMosaicShadowParams* shadowParameters
)
public:
static void Mosaic(
   ImGearRasterPage^ page,
   ImGearMosaicFillParams^ fillParameters,
   ImGearMosaicCellParams^ cellParameters,
   ImGearMosaicBorderParams^ borderParameters,
   ImGearMosaicShadowParams^ shadowParameters
)

Parameters

page
Page class object.
fillParameters
Fill parameters for mosaic operation. See ImGearMosaicFillParams description.
cellParameters
Parameters of the cell for mosaic operation. See ImGearMosaicCellParams description.
borderParameters
Parameters of cell borders. See ImGearMosaicBorderParams description.
shadowParameters
Parameters of the shadow effect. See ImGearMosaicShadowParams description.
Remarks
This method provides a 3D mosaic effect on an image.
Example
  • C#
// Applies a mosaic effect to an image.

// Parameter classes for Mosaic method.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();

//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;

// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;

ImGearEffects.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);
  • Visual Basic
' Applies a mosaic effect to an image.

     ' Parameter classes for Mosaic function.
     Dim igMosaicFillParams As New ImGearMosaicFillParams()
     Dim igMosaicCellParams As New ImGearMosaicCellParams()
     Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
     Dim igMosaicShadowParams As New ImGearMosaicShadowParams()

     'Color for fill and border.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.

     ' Cell parameters
     igMosaicCellParams.Type = ImGearMosaicType.Cartesian
     igMosaicCellParams.Width = 32
     igMosaicCellParams.Height = 32
     igMosaicCellParams.PolarCenterX = 100
     igMosaicCellParams.PolarCenterY = 100
     ' Fill parameters
     igMosaicFillParams.Color = igPixel
     igMosaicFillParams.Opacity = CSng(0.2)
     ' Border parameters
     igMosaicBorderParams.Width = 0
     igMosaicBorderParams.Height = 0
     igMosaicBorderParams.Color = igPixel
     igMosaicBorderParams.Opacity = CSng(0.3)
     igMosaicBorderParams.Irregularity = 0
     ' Shadow Parameters
     igMosaicShadowParams.Enabled = True
     igMosaicShadowParams.Threshold = 0
     igMosaicShadowParams.Direction = ImGearDirection.SouthEast
     igMosaicShadowParams.HighResolution = False
     igMosaicShadowParams.Intensity = CSng(1)

     ImGearEffects.Mosaic(igRasterPage, igMosaicFillParams, _
igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearMosaicFillParams Class
ImGearMosaicCellParams Class
ImGearMosaicBorderParams Class
ImGearMosaicShadowParams Class


NightVision Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : NightVision Method
This method applies 'night vision' effect to the image.
Overload List
Overload | Description
NightVision | This method applies 'night vision' effect to the image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


NightVision(ImGearRasterPage,ImGearNightVisionPresets,Int32,Double) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : NightVision(ImGearRasterPage,ImGearNightVisionPresets,Int32,Double) Method
ImGearPage object to apply effect to.
One of the night vision preset schemes (Camera, Binocular, Sniper, SpyPhoto, Television, Martian, Moonlight).
Width of the border.
Amount of noise to add.
This method applies 'night vision' effect to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub NightVision( _
   ByVal page As ImGearRasterPage, _
   ByVal preset As ImGearNightVisionPresets, _
   ByVal borderWidth As Integer, _
   ByVal noise As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim preset As ImGearNightVisionPresets
Dim borderWidth As Integer
Dim noise As Double

ImGearEffects.NightVision(page, preset, borderWidth, noise)
public static void NightVision(
   ImGearRasterPage page,
   ImGearNightVisionPresets preset,
   int borderWidth,
   double noise
)
public: static void NightVision(
   ImGearRasterPage* page,
   ImGearNightVisionPresets preset,
   int borderWidth,
   double noise
)
public:
static void NightVision(
   ImGearRasterPage^ page,
   ImGearNightVisionPresets preset,
   int borderWidth,
   double noise
)

Parameters

page
ImGearPage object to apply effect to.
preset
One of the night vision preset schemes (Camera, Binocular, Sniper, SpyPhoto, Television, Martian, Moonlight).
borderWidth
Width of the border.
noise
Amount of noise to add.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearNightVisionPresets Enumeration


Oilify Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Oilify Method
Image to apply oilify effect to.
Brush size in pixels. As the brush size is increased, less detail is visible in the image and the effect becomes more dramatic.
This method applies an effect to an image that makes it appear similar to an oil painting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Oilify( _
   ByVal page As ImGearRasterPage, _
   ByVal brushSize As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim brushSize As Integer

ImGearEffects.Oilify(page, brushSize)
public static void Oilify(
   ImGearRasterPage page,
   int brushSize
)
public: static void Oilify(
   ImGearRasterPage* page,
   int brushSize
)
public:
static void Oilify(
   ImGearRasterPage^ page,
   int brushSize
)

Parameters

page
Image to apply oilify effect to.
brushSize
Brush size in pixels. As the brush size is increased, less detail is visible in the image and the effect becomes more dramatic.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


Perspective Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Perspective Method
Page class object.
New coordinates of left top image corner.
New coordinates of right top image corner.
New coordinates of left bottom image corner.
New coordinates of right bottom image corner.
Fill color for empty image part.
This method provides a perspective-like effect by image corners transformation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Perspective( _
   ByVal page As ImGearRasterPage, _
   ByVal point0 As ImGearPoint, _
   ByVal point1 As ImGearPoint, _
   ByVal point2 As ImGearPoint, _
   ByVal point3 As ImGearPoint, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim point0 As ImGearPoint
Dim point1 As ImGearPoint
Dim point2 As ImGearPoint
Dim point3 As ImGearPoint
Dim color As ImGearPixel

ImGearEffects.Perspective(page, point0, point1, point2, point3, color)
public static void Perspective(
   ImGearRasterPage page,
   ImGearPoint point0,
   ImGearPoint point1,
   ImGearPoint point2,
   ImGearPoint point3,
   ImGearPixel color
)
public: static void Perspective(
   ImGearRasterPage* page,
   ImGearPoint point0,
   ImGearPoint point1,
   ImGearPoint point2,
   ImGearPoint point3,
   ImGearPixel* color
)
public:
static void Perspective(
   ImGearRasterPage^ page,
   ImGearPoint point0,
   ImGearPoint point1,
   ImGearPoint point2,
   ImGearPoint point3,
   ImGearPixel^ color
)

Parameters

page
Page class object.
point0
New coordinates of left top image corner.
point1
New coordinates of right top image corner.
point2
New coordinates of left bottom image corner.
point3
New coordinates of right bottom image corner.
color
Fill color for empty image part.
Example
  • C#
//Sample usage of Perspective method.
//New positions for the 4 corners of the image
ImGearPoint igPointLeftTop = new ImGearPoint(igRasterPage.DIB.Width / 4, igRasterPage.DIB.Height / 4);
ImGearPoint igPointRightTop = new ImGearPoint(igRasterPage.DIB.Width, 0);
ImGearPoint igPointLeftBottom = new ImGearPoint(0, igRasterPage.DIB.Height);
ImGearPoint igPointRightBottom = new ImGearPoint(3 * igRasterPage.DIB.Width / 4, 3 * igRasterPage.DIB.Height / 4);
//Background color to fill in after adjusting the corners of the image.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
//Apply the perspective change.
ImGearEffects.Perspective(
    igRasterPage, igPointLeftTop, igPointRightTop,
    igPointLeftBottom, igPointRightBottom, igPixel);
  • Visual Basic
'Sample usage of Perspective function.
     Dim igPointLeftTop As ImGearPoint, igPointRightTop As ImGearPoint
     Dim igPointLeftBottom As ImGearPoint, igPointRightBottom As ImGearPoint
     'New positions for the 4 corners of the image
     igPointLeftTop = New ImGearPoint(igRasterPage.DIB.Width / 4, igRasterPage.DIB.Height / 4)
     igPointRightTop = New ImGearPoint(igRasterPage.DIB.Width, 0)
     igPointLeftBottom = New ImGearPoint(0, igRasterPage.DIB.Height)
     igPointRightBottom = New ImGearPoint(3 * igRasterPage.DIB.Width / 4, 3 * igRasterPage.DIB.Height / 4)
     'Background color to fill in after adjusting the corners of the image.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.
     'Apply the perspective change.
     ImGearEffects.Perspective(igRasterPage, igPointLeftTop, igPointRightTop, _
igPointLeftBottom, igPointRightBottom, igPixel)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure
ImGearPixel Class


Picturize Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Picturize Method
Auxiliary object, containing result of matching the cell images against fragments of the source image.
Specifies distribution settings for Picturize.
Specifies how the cell images will be adjusted before placing to the main image.
This method applies the Picturize effect on a raster image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Picturize( _
   ByVal matchingMatrix As ImGearPicturizeMatchingMatrix, _
   ByVal distributionSettings As ImGearPicturizeDistributionSettings, _
   ByVal mixingSettings As ImGearPicturizeMixingSettings _
) As ImGearRasterPage
'Usage

Dim matchingMatrix As ImGearPicturizeMatchingMatrix
Dim distributionSettings As ImGearPicturizeDistributionSettings
Dim mixingSettings As ImGearPicturizeMixingSettings
Dim value As ImGearRasterPage

value = ImGearEffects.Picturize(matchingMatrix, distributionSettings, mixingSettings)
public static ImGearRasterPage Picturize(
   ImGearPicturizeMatchingMatrix matchingMatrix,
   ImGearPicturizeDistributionSettings distributionSettings,
   ImGearPicturizeMixingSettings mixingSettings
)
public: static ImGearRasterPage* Picturize(
   ImGearPicturizeMatchingMatrix* matchingMatrix,
   ImGearPicturizeDistributionSettings distributionSettings,
   ImGearPicturizeMixingSettings mixingSettings
)
public:
static ImGearRasterPage^ Picturize(
   ImGearPicturizeMatchingMatrix^ matchingMatrix,
   ImGearPicturizeDistributionSettings distributionSettings,
   ImGearPicturizeMixingSettings mixingSettings
)

Parameters

matchingMatrix
Auxiliary object, containing result of matching the cell images against fragments of the source image.
distributionSettings
Specifies distribution settings for Picturize.
mixingSettings
Specifies how the cell images will be adjusted before placing to the main image.

Return Value

ImageGear.Core.ImGearRasterPage class.
Remarks
The method divides the image into rectangular cells, and replaces each cell with an image from the specified image collection, attempting to select cell images such that they match colors of course image.

This method uses a significant amount of calculations, so it has been split into three stages:

Loading and preprocessing cell images, scaling them to their destination size in the picturized image. This stage is done by creation of an ImGearPicturizePreprocessedCollection class object.

Matching cell images to fragments of the main image. This stage is done by creation of a ImGearPicturizeMatchingMatrix class object, which takes ImGearPicturizePreprocessedCollection class on input.Distributing the cell images over the source image, and adjusting their colors to match the main image better. This is done by calling the Picturize method.

The result of the Picturize method depends greatly on how similar the images in the cell image collection are relative to the source image. Also, for best result, the number of images in the cell image collection should be greater than the number of cells in the picturized image.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPicturizeMatchingMatrix Class
ImGearPicturizeDistributionSettings Structure
ImGearPicturizeMixingSettings Structure


Pinch Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Pinch Method
Page to pinch.
Center of the pinch effect.
Radius of the pinch effect.
Pinch strength. Positive value means that the page is pinched away from the center.
If this parameter is true then an interpolation is used during processing.
Pixel color.
This method pinches a page toward or away from the pinch center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Pinch( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal radius As Integer, _
   ByVal strength As Single, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim radius As Integer
Dim strength As Single
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.Pinch(page, center, radius, strength, interpolate, color)
public static void Pinch(
   ImGearRasterPage page,
   ImGearPoint center,
   int radius,
   float strength,
   bool interpolate,
   ImGearPixel color
)
public: static void Pinch(
   ImGearRasterPage* page,
   ImGearPoint center,
   int radius,
   float strength,
   bool interpolate,
   ImGearPixel* color
)
public:
static void Pinch(
   ImGearRasterPage^ page,
   ImGearPoint center,
   int radius,
   float strength,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page to pinch.
center
Center of the pinch effect.
radius
Radius of the pinch effect.
strength
Pinch strength. Positive value means that the page is pinched away from the center.
interpolate
If this parameter is true then an interpolation is used during processing.
color
Pixel color.
Example
  • C#
// Pinches an image.

// Point at which to pinch, center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;

// Pinch using a 128 pixel radius and a strength of 5, interpolation on and no fill color.
ImGearEffects.Pinch(igRasterPage, igPoint, 128, (float)5.0, true, null);
  • Visual Basic
' Pinches an image.

' Point at which to pinch, center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2

' Pinch using a 128 pixel radius and a strength of 5, interpolation on and no fill color.
ImGearEffects.Pinch(igRasterPage, igPoint, 128, CSng(5), True, Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure


Pixelate Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Pixelate Method
Page to pixelate.
Fill parameters for pixelate operation. See ImGearPixelateFillParams description.
Parameters of the cell for pixelate operation. See ImGearPixelateCellParams description.
Parameters of cell borders. See ImGearPixelateBorderParams description.
This method divides an image into cells and fills every cell according to the cell and fill parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Pixelate( _
   ByVal page As ImGearRasterPage, _
   ByVal fillParameters As ImGearPixelateFillParams, _
   ByVal cellParameters As ImGearPixelateCellParams, _
   ByVal borderParameters As ImGearPixelateBorderParams _
)
'Usage

Dim page As ImGearRasterPage
Dim fillParameters As ImGearPixelateFillParams
Dim cellParameters As ImGearPixelateCellParams
Dim borderParameters As ImGearPixelateBorderParams

ImGearEffects.Pixelate(page, fillParameters, cellParameters, borderParameters)
public static void Pixelate(
   ImGearRasterPage page,
   ImGearPixelateFillParams fillParameters,
   ImGearPixelateCellParams cellParameters,
   ImGearPixelateBorderParams borderParameters
)
public: static void Pixelate(
   ImGearRasterPage* page,
   ImGearPixelateFillParams* fillParameters,
   ImGearPixelateCellParams* cellParameters,
   ImGearPixelateBorderParams* borderParameters
)
public:
static void Pixelate(
   ImGearRasterPage^ page,
   ImGearPixelateFillParams^ fillParameters,
   ImGearPixelateCellParams^ cellParameters,
   ImGearPixelateBorderParams^ borderParameters
)

Parameters

page
Page to pixelate.
fillParameters
Fill parameters for pixelate operation. See ImGearPixelateFillParams description.
cellParameters
Parameters of the cell for pixelate operation. See ImGearPixelateCellParams description.
borderParameters
Parameters of cell borders. See ImGearPixelateBorderParams description.
Example
  • C#
// Pixelate an image.

// Parameter classes for Pixelate method.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();

ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);

// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;

// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;

ImGearEffects.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);
  • Visual Basic
' Pixelate an image.

' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()

Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)

' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8

' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)

ImGearEffects.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPixelateFillParams Class
ImGearPixelateCellParams Class
ImGearPixelateBorderParams Class


Pointillist Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Pointillist Method
Image to apply pointillist effect to.
Average size of each point (in pixels).
Type of brush to use for each point. Determines the shape of the point.
Smoothness factor for each point. This value typically ranges from 0 to 100.
Specifies a background color to use. If this parameter is null, all points fit together smoothly with no gaps. If this parameter specifies a background a color, there are some occasional gaps which are set to the specified background color.
Applies an effect to an image that makes it appear to have been painted in the pointillism style of painting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Pointillist( _
   ByVal page As ImGearRasterPage, _
   ByVal pointSize As Integer, _
   ByVal pointType As ImGearBrushType, _
   ByVal smoothness As Integer, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim pointSize As Integer
Dim pointType As ImGearBrushType
Dim smoothness As Integer
Dim color As ImGearPixel

ImGearEffects.Pointillist(page, pointSize, pointType, smoothness, color)
public static void Pointillist(
   ImGearRasterPage page,
   int pointSize,
   ImGearBrushType pointType,
   int smoothness,
   ImGearPixel color
)
public: static void Pointillist(
   ImGearRasterPage* page,
   int pointSize,
   ImGearBrushType pointType,
   int smoothness,
   ImGearPixel* color
)
public:
static void Pointillist(
   ImGearRasterPage^ page,
   int pointSize,
   ImGearBrushType pointType,
   int smoothness,
   ImGearPixel^ color
)

Parameters

page
Image to apply pointillist effect to.
pointSize
Average size of each point (in pixels).
pointType
Type of brush to use for each point. Determines the shape of the point.
smoothness
Smoothness factor for each point. This value typically ranges from 0 to 100.
color
Specifies a background color to use. If this parameter is null, all points fit together smoothly with no gaps. If this parameter specifies a background a color, there are some occasional gaps which are set to the specified background color.
Remarks
The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearBrushType Enumeration
ImGearPixel Class


ProcessArea Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : ProcessArea Method
Page specified.
Implementation of IImGearPixelProcessor interface with the implemented method ProcessPixel. See IImGearPixelChecker interface for more details.
This method processes all pixels in the ROI area using a specified pixel processor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ProcessArea( _
   ByVal page As ImGearRasterPage, _
   ByVal processor As IImGearPixelProcessor _
)
'Usage

Dim page As ImGearRasterPage
Dim processor As IImGearPixelProcessor

ImGearEffects.ProcessArea(page, processor)
public static void ProcessArea(
   ImGearRasterPage page,
   IImGearPixelProcessor processor
)
public: static void ProcessArea(
   ImGearRasterPage* page,
   IImGearPixelProcessor* processor
)
public:
static void ProcessArea(
   ImGearRasterPage^ page,
   IImGearPixelProcessor^ processor
)

Parameters

page
Page specified.
processor
Implementation of IImGearPixelProcessor interface with the implemented method ProcessPixel. See IImGearPixelChecker interface for more details.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
IImGearPixelProcessor Interface
ImGearPixelProcessorRedEyeRGB Class
CanApplyProcessArea Method


RadialLight Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RadialLight Method
Image to apply radial light effect to.
Center point in the image (in pixels) about which the effect is applied.
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to align the bars with image content or boundaries.
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
This method changes the colors of an image according to the pattern of a sine wave.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RadialLight( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal amplitude() As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim amplitude() As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single

ImGearEffects.RadialLight(page, center, amplitude, frequency, phase, attenuation)
public static void RadialLight(
   ImGearRasterPage page,
   ImGearPoint center,
   float[] amplitude,
   float frequency,
   float phase,
   float attenuation
)
public: static void RadialLight(
   ImGearRasterPage* page,
   ImGearPoint center,
   float[]* amplitude,
   float frequency,
   float phase,
   float attenuation
)
public:
static void RadialLight(
   ImGearRasterPage^ page,
   ImGearPoint center,
   array<float>^ amplitude,
   float frequency,
   float phase,
   float attenuation
)

Parameters

page
Image to apply radial light effect to.
center
Center point in the image (in pixels) about which the effect is applied.
amplitude
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to align the bars with image content or boundaries.
attenuation
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.
Remarks
The image will appear to have regularly spaced bars of light and shadow overlaid on top of it in a radial pattern.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


RadialWave Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RadialWave Method
Page specified.
Center of the wave effect.
Wave amplitude. Measurement units - pixel / 100.
Wave frequency. The frequency is defined as 1 / T, where T is a wave period in pixels.
Wave phase, in radians.
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
If this parameter is true then an interpolation is used during processing.
ImageGear.Core.ImGearPixel class color.
This method provides a radial wave effect on the current raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RadialWave( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal amplitude As Single, _
   ByVal frequency As Single, _
   ByVal phase As Single, _
   ByVal attenuation As Single, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim amplitude As Single
Dim frequency As Single
Dim phase As Single
Dim attenuation As Single
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.RadialWave(page, center, amplitude, frequency, phase, attenuation, interpolate, color)
public static void RadialWave(
   ImGearRasterPage page,
   ImGearPoint center,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel color
)
public: static void RadialWave(
   ImGearRasterPage* page,
   ImGearPoint center,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel* color
)
public:
static void RadialWave(
   ImGearRasterPage^ page,
   ImGearPoint center,
   float amplitude,
   float frequency,
   float phase,
   float attenuation,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page specified.
center
Center of the wave effect.
amplitude
Wave amplitude. Measurement units - pixel / 100.
frequency
Wave frequency. The frequency is defined as 1 / T, where T is a wave period in pixels.
phase
Wave phase, in radians.
attenuation
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
interpolate
If this parameter is true then an interpolation is used during processing.
color
ImageGear.Core.ImGearPixel class color.
Example
  • C#
// Distorts an image with a radial wave.

// Center point of the wave, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;

// Warp the image with a radial wave with an amplitude of 0.25, frequency of 20 pixels,
//  0 phase, and slight attenuation. Interpolation is enabled, and no fill color is specified.
ImGearEffects.RadialWave(
        igRasterPage, igPoint, (float)(0.25), (float)(1.0 / 20.0),
        (float)(0.0), (float)(0.01), true, null);
  • Visual Basic
' Distorts an image with a radial wave.

     ' Center point of the wave, set to center of image.
     Dim igPoint As New ImGearPoint()
     igPoint.X = igRasterPage.DIB.Width / 2
     igPoint.Y = igRasterPage.DIB.Height / 2

     ' Warp the image with a radial wave with an amplitude of 0.25, frequency of 20 pixels,
     '  0 phase, and slight attenuation. Interpolation is enabled, and no fill color is specified.
     ImGearEffects.RadialWave(igRasterPage, igPoint, CSng((0.25)), CSng((1 / 20)), CSng((0)), CSng((0.01)), _
True, Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure
ImGearPixel Class


RemoveChromaticAberration Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RemoveChromaticAberration Method
Page to process.
Amount by which to scale the red component of the image. Valid range is 0.95...1.05.
Amount by which to scale the blue component of the image. Valid range is 0.95...1.05.
Center point.
This method removes chromatic aberration artifacts from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveChromaticAberration( _
   ByVal page As ImGearRasterPage, _
   ByVal redScale As Double, _
   ByVal blueScale As Double, _
   ByVal centerPoint As ImGearPoint _
)
'Usage

Dim page As ImGearRasterPage
Dim redScale As Double
Dim blueScale As Double
Dim centerPoint As ImGearPoint

ImGearEffects.RemoveChromaticAberration(page, redScale, blueScale, centerPoint)
public static void RemoveChromaticAberration(
   ImGearRasterPage page,
   double redScale,
   double blueScale,
   ImGearPoint centerPoint
)
public: static void RemoveChromaticAberration(
   ImGearRasterPage* page,
   double redScale,
   double blueScale,
   ImGearPoint centerPoint
)
public:
static void RemoveChromaticAberration(
   ImGearRasterPage^ page,
   double redScale,
   double blueScale,
   ImGearPoint centerPoint
)

Parameters

page
Page to process.
redScale
Amount by which to scale the red component of the image. Valid range is 0.95...1.05.
blueScale
Amount by which to scale the blue component of the image. Valid range is 0.95...1.05.
centerPoint
Center point.
Remarks
Chromatic aberration is caused by differences in refraction of light components by the lens, and is seen as colored 'fringes' around the image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


Ripple Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Ripple Method
Page to apply the effect to.
Strength of the ripple effect.
X period of the ripple pattern in pixels.
Y period of the ripple pattern in pixels.
Identifies a predefined ripple pattern.
Specifies how much the ripple pattern should be smoothed before applying.
Inverts the ripple pattern, effectifely swapping 'convex' and 'concave' areas.
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Ripple( _
   ByVal page As ImGearRasterPage, _
   ByVal depth As Single, _
   ByVal periodX As Integer, _
   ByVal periodY As Integer, _
   ByVal pattern As ImGearRipplePattern, _
   ByVal smoothness As Single, _
   ByVal invert As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim depth As Single
Dim periodX As Integer
Dim periodY As Integer
Dim pattern As ImGearRipplePattern
Dim smoothness As Single
Dim invert As Boolean

ImGearEffects.Ripple(page, depth, periodX, periodY, pattern, smoothness, invert)
public static void Ripple(
   ImGearRasterPage page,
   float depth,
   int periodX,
   int periodY,
   ImGearRipplePattern pattern,
   float smoothness,
   bool invert
)
public: static void Ripple(
   ImGearRasterPage* page,
   float depth,
   int periodX,
   int periodY,
   ImGearRipplePattern pattern,
   float smoothness,
   bool invert
)
public:
static void Ripple(
   ImGearRasterPage^ page,
   float depth,
   int periodX,
   int periodY,
   ImGearRipplePattern pattern,
   float smoothness,
   bool invert
)

Parameters

page
Page to apply the effect to.
depth
Strength of the ripple effect.
periodX
X period of the ripple pattern in pixels.
periodY
Y period of the ripple pattern in pixels.
pattern
Identifies a predefined ripple pattern.
smoothness
Specifies how much the ripple pattern should be smoothed before applying.
invert
Inverts the ripple pattern, effectifely swapping 'convex' and 'concave' areas.
Remarks
This method provides the ripple effect on the image, as if it is looked at through a relief glass. The method uses one of the prefefined ripple patterns.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
RippleFreeHand Method
RippleTexture Method
ImGearRipplePattern Enumeration


RippleFreeHand Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RippleFreeHand Method
Page to apply the effect to.
Strength of the Ripple effect.
Array of points containing relative light deviations along the X axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
Array of points containing relative light deviations along the Y axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
Horizontal period of the repeating pattern. It corresponds to number of points from the distributionX array that should be used in the transform, and does not have to be equal to the length of the array.
Index of the first point in the distributionX array to be used in the transform.
Vertical period of the repeating pattern. It corresponds to number of points from the distributionY array, that should be used in the transform, and does not have to be equal to the length of the array.
Index of the first point in the distributionY array to be used in the transform.
Specifies how much the ripple pattern should be smoothed before applying.
Specifies the angle for the ripple pattern, in degrees. Valid range is from 0 to 360.
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RippleFreeHand( _
   ByVal page As ImGearRasterPage, _
   ByVal depth As Single, _
   ByVal distributionX() As Single, _
   ByVal distributionY() As Single, _
   ByVal periodX As Integer, _
   ByVal phaseX As Integer, _
   ByVal periodY As Integer, _
   ByVal phaseY As Integer, _
   ByVal smoothness As Single, _
   ByVal angle As Single _
)
'Usage

Dim page As ImGearRasterPage
Dim depth As Single
Dim distributionX() As Single
Dim distributionY() As Single
Dim periodX As Integer
Dim phaseX As Integer
Dim periodY As Integer
Dim phaseY As Integer
Dim smoothness As Single
Dim angle As Single

ImGearEffects.RippleFreeHand(page, depth, distributionX, distributionY, periodX, phaseX, periodY, phaseY, smoothness, angle)
public static void RippleFreeHand(
   ImGearRasterPage page,
   float depth,
   float[] distributionX,
   float[] distributionY,
   int periodX,
   int phaseX,
   int periodY,
   int phaseY,
   float smoothness,
   float angle
)
public: static void RippleFreeHand(
   ImGearRasterPage* page,
   float depth,
   float[]* distributionX,
   float[]* distributionY,
   int periodX,
   int phaseX,
   int periodY,
   int phaseY,
   float smoothness,
   float angle
)
public:
static void RippleFreeHand(
   ImGearRasterPage^ page,
   float depth,
   array<float>^ distributionX,
   array<float>^ distributionY,
   int periodX,
   int phaseX,
   int periodY,
   int phaseY,
   float smoothness,
   float angle
)

Parameters

page
Page to apply the effect to.
depth
Strength of the Ripple effect.
distributionX
Array of points containing relative light deviations along the X axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
distributionY
Array of points containing relative light deviations along the Y axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
periodX
Horizontal period of the repeating pattern. It corresponds to number of points from the distributionX array that should be used in the transform, and does not have to be equal to the length of the array.
phaseX
Index of the first point in the distributionX array to be used in the transform.
periodY
Vertical period of the repeating pattern. It corresponds to number of points from the distributionY array, that should be used in the transform, and does not have to be equal to the length of the array.
phaseY
Index of the first point in the distributionY array to be used in the transform.
smoothness
Specifies how much the ripple pattern should be smoothed before applying.
angle
Specifies the angle for the ripple pattern, in degrees. Valid range is from 0 to 360.
Remarks
This method provides the ripple effect on the image, as if it is looked at through a relief glass. The method uses a custom ripple pattern, defined as two one-dimensional arrays containing light deviations in X and Y directions.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
Ripple Method
RippleTexture Method


RippleTexture Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RippleTexture Method
Page to apply the effect to.
Page to use as the ripple pattern.
Strength of the ripple effect.
Specifies the scaling factor for pattern image.
Horizontal offset at which the upper left corner of the ripple texture shall be placed.
Vertical offset at which the upper left corner of the ripple texture shall be placed.
Specifies how much the ripple pattern should be smoothed before applying.
Inverts the ripple pattern, effectively swapping 'convex' and 'concave' areas.
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RippleTexture( _
   ByVal page As ImGearRasterPage, _
   ByVal texture As ImGearRasterPage, _
   ByVal depth As Single, _
   ByVal scale As Single, _
   ByVal offsetX As Integer, _
   ByVal offsetY As Integer, _
   ByVal smoothness As Single, _
   ByVal invert As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim texture As ImGearRasterPage
Dim depth As Single
Dim scale As Single
Dim offsetX As Integer
Dim offsetY As Integer
Dim smoothness As Single
Dim invert As Boolean

ImGearEffects.RippleTexture(page, texture, depth, scale, offsetX, offsetY, smoothness, invert)
public static void RippleTexture(
   ImGearRasterPage page,
   ImGearRasterPage texture,
   float depth,
   float scale,
   int offsetX,
   int offsetY,
   float smoothness,
   bool invert
)
public: static void RippleTexture(
   ImGearRasterPage* page,
   ImGearRasterPage* texture,
   float depth,
   float scale,
   int offsetX,
   int offsetY,
   float smoothness,
   bool invert
)
public:
static void RippleTexture(
   ImGearRasterPage^ page,
   ImGearRasterPage^ texture,
   float depth,
   float scale,
   int offsetX,
   int offsetY,
   float smoothness,
   bool invert
)

Parameters

page
Page to apply the effect to.
texture
Page to use as the ripple pattern.
depth
Strength of the ripple effect.
scale
Specifies the scaling factor for pattern image.
offsetX
Horizontal offset at which the upper left corner of the ripple texture shall be placed.
offsetY
Vertical offset at which the upper left corner of the ripple texture shall be placed.
smoothness
Specifies how much the ripple pattern should be smoothed before applying.
invert
Inverts the ripple pattern, effectively swapping 'convex' and 'concave' areas.
Remarks
This method provides the ripple effect on the image, as if it is looked at through a relief glass. The method uses an image as a ripple pattern. If the scaled ripple pattern image is smaller than the source image, or if offsets are greater than 0, pattern is repeated over the image.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
Ripple Method
RippleFreeHand Method


RoundCorners Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : RoundCorners Method
Page to round the corners of.
Specifies the radius for rounding.
Specifies the fill color for the corners.
This method rounds the corners of the image and fills them with a specified color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RoundCorners( _
   ByVal page As ImGearRasterPage, _
   ByVal radius As Integer, _
   ByVal fillColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim radius As Integer
Dim fillColor As ImGearPixel

ImGearEffects.RoundCorners(page, radius, fillColor)
public static void RoundCorners(
   ImGearRasterPage page,
   int radius,
   ImGearPixel fillColor
)
public: static void RoundCorners(
   ImGearRasterPage* page,
   int radius,
   ImGearPixel* fillColor
)
public:
static void RoundCorners(
   ImGearRasterPage^ page,
   int radius,
   ImGearPixel^ fillColor
)

Parameters

page
Page to round the corners of.
radius
Specifies the radius for rounding.
fillColor
Specifies the fill color for the corners.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


Sepia Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Sepia Method
Page to apply the effect to.
Sepia color.
This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Sepia( _
   ByVal page As ImGearRasterPage, _
   ByVal sepiaColor As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim sepiaColor As ImGearPixel

ImGearEffects.Sepia(page, sepiaColor)
public static void Sepia(
   ImGearRasterPage page,
   ImGearPixel sepiaColor
)
public: static void Sepia(
   ImGearRasterPage* page,
   ImGearPixel* sepiaColor
)
public:
static void Sepia(
   ImGearRasterPage^ page,
   ImGearPixel^ sepiaColor
)

Parameters

page
Page to apply the effect to.
sepiaColor
Sepia color.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPixel Class


Shear Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Shear Method
Image to apply shear effect to.
The array of offsets to move the image by. Every offset is in the range -1 to 1. Negative values shift the raster/column to the left, while positive values shift it to the right. The number of offsets is equal to the image width or height depending on the direction of movement (horizontal or vertical).
Specifies how the empty image area is filled.
If true, interpolation is used to smooth shifted pixel values.
If true, the direction of motion is vertical. Otherwise, the direction is horizontal.
Background color to use for filling empty image area. Only used if the specified fill style uses a fill color.
Applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Shear( _
   ByVal page As ImGearRasterPage, _
   ByVal curvePoints() As Double, _
   ByVal fillStyle As ImGearShearFillStyle, _
   ByVal interpolate As Boolean, _
   ByVal vertical As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim curvePoints() As Double
Dim fillStyle As ImGearShearFillStyle
Dim interpolate As Boolean
Dim vertical As Boolean
Dim color As ImGearPixel

ImGearEffects.Shear(page, curvePoints, fillStyle, interpolate, vertical, color)
public static void Shear(
   ImGearRasterPage page,
   double[] curvePoints,
   ImGearShearFillStyle fillStyle,
   bool interpolate,
   bool vertical,
   ImGearPixel color
)
public: static void Shear(
   ImGearRasterPage* page,
   double[]* curvePoints,
   ImGearShearFillStyle fillStyle,
   bool interpolate,
   bool vertical,
   ImGearPixel* color
)
public:
static void Shear(
   ImGearRasterPage^ page,
   array<double>^ curvePoints,
   ImGearShearFillStyle fillStyle,
   bool interpolate,
   bool vertical,
   ImGearPixel^ color
)

Parameters

page
Image to apply shear effect to.
curvePoints
The array of offsets to move the image by. Every offset is in the range -1 to 1. Negative values shift the raster/column to the left, while positive values shift it to the right. The number of offsets is equal to the image width or height depending on the direction of movement (horizontal or vertical).
fillStyle
Specifies how the empty image area is filled.
interpolate
If true, interpolation is used to smooth shifted pixel values.
vertical
If true, the direction of motion is vertical. Otherwise, the direction is horizontal.
color
Background color to use for filling empty image area. Only used if the specified fill style uses a fill color.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearShearFillStyle Enumeration


Sketch Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Sketch Method
Page to process.
Page to use as a texture.
Scaling factor for resizing the texture image.
Applies a sketch effect on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Sketch( _
   ByVal page As ImGearRasterPage, _
   ByVal texture As ImGearRasterPage, _
   ByVal scaling As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim texture As ImGearRasterPage
Dim scaling As Double

ImGearEffects.Sketch(page, texture, scaling)
public static void Sketch(
   ImGearRasterPage page,
   ImGearRasterPage texture,
   double scaling
)
public: static void Sketch(
   ImGearRasterPage* page,
   ImGearRasterPage* texture,
   double scaling
)
public:
static void Sketch(
   ImGearRasterPage^ page,
   ImGearRasterPage^ texture,
   double scaling
)

Parameters

page
Page to process.
texture
Page to use as a texture.
scaling
Scaling factor for resizing the texture image.
Remarks
This method applies Sketch effect on the image. It blends the source image with a texture image, making it look like painted by a pencil or charcoal.

The texture image can be scaled to imitate finer or thicker pencil strokes. If source image is larger than the texture, the texture is tiled over the image.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


Solarize Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Overload List
Overload | Description
Solarize(ImGearRasterPage,Int32) | This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange) | This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) | This method inverts the colors of pixels whose lightness exceeds the specified threshold.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


Solarize(ImGearRasterPage,Int32) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > Solarize Method : Solarize(ImGearRasterPage,Int32) Method
Image to process.
Lightness threshold above which colors of pixels are inverted.
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Solarize( _
   ByVal page As ImGearRasterPage, _
   ByVal threshold As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim threshold As Integer

ImGearEffects.Solarize(page, threshold)
public static void Solarize(
   ImGearRasterPage page,
   int threshold
)
public: static void Solarize(
   ImGearRasterPage* page,
   int threshold
)
public:
static void Solarize(
   ImGearRasterPage^ page,
   int threshold
)

Parameters

page
Image to process.
threshold
Lightness threshold above which colors of pixels are inverted.
Remarks
This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearRasterPage Class
CanApplySolarize Method


Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange) Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > Solarize Method : Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange) Method
Image to process.
Lightness threshold above which colors of pixels are inverted.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to solarize.
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Solarize( _
   ByVal page As ImGearRasterPage, _
   ByVal threshold As Integer, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange _
)
'Usage

Dim page As ImGearRasterPage
Dim threshold As Integer
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange

ImGearEffects.Solarize(page, threshold, mode, channels)
public static void Solarize(
   ImGearRasterPage page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public: static void Solarize(
   ImGearRasterPage* page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)
public:
static void Solarize(
   ImGearRasterPage^ page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to process.
threshold
Lightness threshold above which colors of pixels are inverted.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to solarize.
Remarks
This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

Example
  • C#
// Channel range to adjust contrast.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Solarize the image, inverting the contrast the contrast if above threshold.
ImGearEffects.Solarize(igRasterPage, 200,
    ImGearContrastModes.AUTO, igChannelRange);
  • Visual Basic
' Channel range to adjust contrast.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Solarize the image, inverting the contrast the contrast if above threshold.
ImGearEffects.Solarize(igRasterPage, 200, ImGearContrastModes.AUTO, igChannelRange)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearRasterPage Class
CanApplySolarize Method
ImGearChannelRange Structure
ImGearContrastModes Enumeration


Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class > Solarize Method : Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
Image to process.
Lightness threshold above which colors of pixels are inverted.
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
Channel range to solarize.
Additional contrast options.
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub Solarize( _
   ByVal page As ImGearRasterPage, _
   ByVal threshold As Integer, _
   ByVal mode As ImGearContrastModes, _
   ByVal channels As ImGearChannelRange, _
   ByVal options As ImGearContrastOptions _
)
'Usage

Dim page As ImGearRasterPage
Dim threshold As Integer
Dim mode As ImGearContrastModes
Dim channels As ImGearChannelRange
Dim options As ImGearContrastOptions

ImGearEffects.Solarize(page, threshold, mode, channels, options)
public static void Solarize(
   ImGearRasterPage page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions options
)
public: static void Solarize(
   ImGearRasterPage* page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions* options
)
public:
static void Solarize(
   ImGearRasterPage^ page,
   int threshold,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions^ options
)

Parameters

page
Image to process.
threshold
Lightness threshold above which colors of pixels are inverted.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to solarize.
options
Additional contrast options.
Remarks
This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
Overload List
ImGearRasterPage Class
CanApplySolarize Method
ImGearChannelRange Structure
ImGearContrastModes Enumeration
ImGearContrastOptions Class


Spatter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Spatter Method
Image to apply spatter effect to.
Factor of horizontal diffusion. The greater this value, the deeper the horizontal diffusion. Typical values range from 1 to 20.
Factor of vertical diffusion. The greater this value, the deeper the vertical diffusion. Typical values range from 1 to 20.
Smoothness factor of diffusion. Typical values range from 0 to 100.
This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Spatter( _
   ByVal page As ImGearRasterPage, _
   ByVal horizontalDiffusion As Integer, _
   ByVal verticalDiffusion As Integer, _
   ByVal smoothness As Integer _
)
'Usage

Dim page As ImGearRasterPage
Dim horizontalDiffusion As Integer
Dim verticalDiffusion As Integer
Dim smoothness As Integer

ImGearEffects.Spatter(page, horizontalDiffusion, verticalDiffusion, smoothness)
public static void Spatter(
   ImGearRasterPage page,
   int horizontalDiffusion,
   int verticalDiffusion,
   int smoothness
)
public: static void Spatter(
   ImGearRasterPage* page,
   int horizontalDiffusion,
   int verticalDiffusion,
   int smoothness
)
public:
static void Spatter(
   ImGearRasterPage^ page,
   int horizontalDiffusion,
   int verticalDiffusion,
   int smoothness
)

Parameters

page
Image to apply spatter effect to.
horizontalDiffusion
Factor of horizontal diffusion. The greater this value, the deeper the horizontal diffusion. Typical values range from 1 to 20.
verticalDiffusion
Factor of vertical diffusion. The greater this value, the deeper the vertical diffusion. Typical values range from 1 to 20.
smoothness
Smoothness factor of diffusion. Typical values range from 0 to 100.
Remarks
The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


Spotlights Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Spotlights Method
Page to apply the effect to.
Array of objects specifying spotlight parameters.
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.
This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Spotlights( _
   ByVal page As ImGearRasterPage, _
   ByVal lights() As ImGearSpotlight, _
   ByVal darkenBy As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim lights() As ImGearSpotlight
Dim darkenBy As Double

ImGearEffects.Spotlights(page, lights, darkenBy)
public static void Spotlights(
   ImGearRasterPage page,
   ImGearSpotlight[] lights,
   double darkenBy
)
public: static void Spotlights(
   ImGearRasterPage* page,
   ImGearSpotlight*[]* lights,
   double darkenBy
)
public:
static void Spotlights(
   ImGearRasterPage^ page,
   array<ImGearSpotlight^>^ lights,
   double darkenBy
)

Parameters

page
Page to apply the effect to.
lights
Array of objects specifying spotlight parameters.
darkenBy
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearSpotlight Class
SpotlightsPreview Method


SpotlightsPreview Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : SpotlightsPreview Method
Page to apply the effect to.
Page to apply preview of the effect to.
Array of objects specifying spotlight parameters.
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.
This method creates a reduced size preview for the Spotlights effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SpotlightsPreview( _
   ByVal page As ImGearRasterPage, _
   ByVal previewPage As ImGearRasterPage, _
   ByVal lights() As ImGearSpotlight, _
   ByVal darkenBy As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim previewPage As ImGearRasterPage
Dim lights() As ImGearSpotlight
Dim darkenBy As Double

ImGearEffects.SpotlightsPreview(page, previewPage, lights, darkenBy)
public static void SpotlightsPreview(
   ImGearRasterPage page,
   ImGearRasterPage previewPage,
   ImGearSpotlight[] lights,
   double darkenBy
)
public: static void SpotlightsPreview(
   ImGearRasterPage* page,
   ImGearRasterPage* previewPage,
   ImGearSpotlight*[]* lights,
   double darkenBy
)
public:
static void SpotlightsPreview(
   ImGearRasterPage^ page,
   ImGearRasterPage^ previewPage,
   array<ImGearSpotlight^>^ lights,
   double darkenBy
)

Parameters

page
Page to apply the effect to.
previewPage
Page to apply preview of the effect to.
lights
Array of objects specifying spotlight parameters.
darkenBy
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.
Remarks
This method creates a reduced size preview for the Spotlights method effect. It accepts the same parameters you would use for the full size image, so you don't have to recalculate them to account for the reduced size of the preview.

The spotlights effect darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.

See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearSpotlight Class
Spotlights Method


ToyCamera Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : ToyCamera Method
Page to apply effect to.
Radius of vignette to add around the image.
Width of vignette to add around the image.
Amount by which to darken the vignette.
Amount by which to blur the vignette.
Amount of noise to add to the image.
Amount to saturate the image by.
Amount of 'fish eye' effect, to imitate geometric distortions caused by a cheap lens.
This method makes the image look as if it was taken by a toy camera.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ToyCamera( _
   ByVal page As ImGearRasterPage, _
   ByVal vignetteRadius As Integer, _
   ByVal vignetteWidth As Integer, _
   ByVal vignetteDarkness As Double, _
   ByVal vignetteBlur As Integer, _
   ByVal noiseAmount As Double, _
   ByVal saturationAmount As Double, _
   ByVal fisheyeAmount As Double _
)
'Usage

Dim page As ImGearRasterPage
Dim vignetteRadius As Integer
Dim vignetteWidth As Integer
Dim vignetteDarkness As Double
Dim vignetteBlur As Integer
Dim noiseAmount As Double
Dim saturationAmount As Double
Dim fisheyeAmount As Double

ImGearEffects.ToyCamera(page, vignetteRadius, vignetteWidth, vignetteDarkness, vignetteBlur, noiseAmount, saturationAmount, fisheyeAmount)
public static void ToyCamera(
   ImGearRasterPage page,
   int vignetteRadius,
   int vignetteWidth,
   double vignetteDarkness,
   int vignetteBlur,
   double noiseAmount,
   double saturationAmount,
   double fisheyeAmount
)
public: static void ToyCamera(
   ImGearRasterPage* page,
   int vignetteRadius,
   int vignetteWidth,
   double vignetteDarkness,
   int vignetteBlur,
   double noiseAmount,
   double saturationAmount,
   double fisheyeAmount
)
public:
static void ToyCamera(
   ImGearRasterPage^ page,
   int vignetteRadius,
   int vignetteWidth,
   double vignetteDarkness,
   int vignetteBlur,
   double noiseAmount,
   double saturationAmount,
   double fisheyeAmount
)

Parameters

page
Page to apply effect to.
vignetteRadius
Radius of vignette to add around the image.
vignetteWidth
Width of vignette to add around the image.
vignetteDarkness
Amount by which to darken the vignette.
vignetteBlur
Amount by which to blur the vignette.
noiseAmount
Amount of noise to add to the image.
saturationAmount
Amount to saturate the image by.
fisheyeAmount
Amount of 'fish eye' effect, to imitate geometric distortions caused by a cheap lens.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


Vignette Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Vignette Method
This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
Overload List
Overload | Description
Vignette | This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


Vignette(ImGearRasterPage,IImGearShape,Int32,Double,ImGearPixel,Boolean) Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Vignette(ImGearRasterPage,IImGearShape,Int32,Double,ImGearPixel,Boolean) Method
Page to add vignette to.
Specifies vignette shape and position. Supported shape types are ImageGear.Core.ImGearRect structure, ImageGear.Core.ImGearEllipse structure, and ImageGear.Core.ImGearRoundedRectangle structure.
Specifies width of the smothing area. Smoothing area is located outside of the shape.
Specifies the shape of the smoothing curve. The value of 0.5 corresponds to linear transition, smaller values result in smother transition at the transparent edge of the vignette, greater values result in stronger transition at the transparent edge of the vignette. The valid range is 0...1.
If the image does not contain an Alpha channel, specifies fill color for the vignette. Otherwise, the Alpha value of fillColor specifies maximum opacity value for the vignette. Must correspond to the colorspace of the source image.
Set to false to fill outside area of the shape (best for applying a colored vignette). Set to true to fill inside area of the shape (best for creating a vignette from an image).
This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Vignette( _
   ByVal page As ImGearRasterPage, _
   ByVal shape As IImGearShape, _
   ByVal smoothWidth As Integer, _
   ByVal smoothFactor As Double, _
   ByVal fillColor As ImGearPixel, _
   ByVal fillInside As Boolean _
)
'Usage

Dim page As ImGearRasterPage
Dim shape As IImGearShape
Dim smoothWidth As Integer
Dim smoothFactor As Double
Dim fillColor As ImGearPixel
Dim fillInside As Boolean

ImGearEffects.Vignette(page, shape, smoothWidth, smoothFactor, fillColor, fillInside)
public static void Vignette(
   ImGearRasterPage page,
   IImGearShape shape,
   int smoothWidth,
   double smoothFactor,
   ImGearPixel fillColor,
   bool fillInside
)
public: static void Vignette(
   ImGearRasterPage* page,
   IImGearShape* shape,
   int smoothWidth,
   double smoothFactor,
   ImGearPixel* fillColor,
   bool fillInside
)
public:
static void Vignette(
   ImGearRasterPage^ page,
   IImGearShape^ shape,
   int smoothWidth,
   double smoothFactor,
   ImGearPixel^ fillColor,
   bool fillInside
)

Parameters

page
Page to add vignette to.
shape
Specifies vignette shape and position. Supported shape types are ImageGear.Core.ImGearRect structure, ImageGear.Core.ImGearEllipse structure, and ImageGear.Core.ImGearRoundedRectangle structure.
smoothWidth
Specifies width of the smothing area. Smoothing area is located outside of the shape.
smoothFactor
Specifies the shape of the smoothing curve. The value of 0.5 corresponds to linear transition, smaller values result in smother transition at the transparent edge of the vignette, greater values result in stronger transition at the transparent edge of the vignette. The valid range is 0...1.
fillColor
If the image does not contain an Alpha channel, specifies fill color for the vignette. Otherwise, the Alpha value of fillColor specifies maximum opacity value for the vignette. Must correspond to the colorspace of the source image.
fillInside
Set to false to fill outside area of the shape (best for applying a colored vignette). Set to true to fill inside area of the shape (best for creating a vignette from an image).
Remarks
This method draws a shape on the image and fills the interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.

The behavior of this method depends on whether the image has an Alpha channel or not.

If the image does not have an Alpha channel, the method uses specified color to fill the shape. Use this mode to add a colored vignette to an image. In this mode, you will most likely set the fillInside parameter to false, to fill the borders of the image.

If the source image has an Alpha channel, the method only modifies the contents of the Alpha channel, and leaves color channels unchanged. It uses the alpha value of fillColor as the maximum opacity value for filling. Use this mode to create a semi-transparent vignette that can then be applied to other images. In this mode, you will most likely set the fillInside parameter to true, to make the interior transparent and leave the borders of the vignette opaque.

See Also

Reference

ImGearEffects Class
ImGearEffects Members


WarpCylinder Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : WarpCylinder Method
Page class object.
Distance to the cylinder axis in pixels. It is measured from the left edge in the case of a vertical cylinder and from the top edge in the case of a horizontal one.
Cylinder radius in pixels.
Height of the cylinder segment in pixels. Height can be changed from (-radius) to (radius).
If this parameter is true then the cylinder is horizontal, otherwise it is vertical.
If this parameter is true then an interpolation is used during processing.
ImageGear.Core.ImGearPixel class color.
This method provides warping around cylinder on the current raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub WarpCylinder( _
   ByVal page As ImGearRasterPage, _
   ByVal distance As Integer, _
   ByVal radius As Integer, _
   ByVal height As Integer, _
   ByVal horizontal As Boolean, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim distance As Integer
Dim radius As Integer
Dim height As Integer
Dim horizontal As Boolean
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.WarpCylinder(page, distance, radius, height, horizontal, interpolate, color)
public static void WarpCylinder(
   ImGearRasterPage page,
   int distance,
   int radius,
   int height,
   bool horizontal,
   bool interpolate,
   ImGearPixel color
)
public: static void WarpCylinder(
   ImGearRasterPage* page,
   int distance,
   int radius,
   int height,
   bool horizontal,
   bool interpolate,
   ImGearPixel* color
)
public:
static void WarpCylinder(
   ImGearRasterPage^ page,
   int distance,
   int radius,
   int height,
   bool horizontal,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page class object.
distance
Distance to the cylinder axis in pixels. It is measured from the left edge in the case of a vertical cylinder and from the top edge in the case of a horizontal one.
radius
Cylinder radius in pixels.
height
Height of the cylinder segment in pixels. Height can be changed from (-radius) to (radius).
horizontal
If this parameter is true then the cylinder is horizontal, otherwise it is vertical.
interpolate
If this parameter is true then an interpolation is used during processing.
color
ImageGear.Core.ImGearPixel class color.
Example
  • C#
// Warp the image around a vertical cylinder, 300 pixels from the left edge,
//  with a 200 pixel radius and 50 pixels below the image.
ImGearEffects.WarpCylinder(igRasterPage, 300, 200, -50, false, true, null);
  • Visual Basic
' Warp the image around a vertical cylinder, 300 pixels from the left edge,
     '  with a 200 pixel radius and 50 pixels below the image.
     ImGearEffects.WarpCylinder(igRasterPage, 300, 200, -50, False, True, _
Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class


WarpParabolic Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : WarpParabolic Method
Page class object.
Center of the paraboloid in pixels.
Extrusion strength.
Length of the effect in X direction in pixels.
Length of the effect in Y direction in pixels.
If this parameter is true then an interpolation is used during processing.
ImageGear.Core.ImGearPixel class color.
This method provides warping around paraboloid on the current raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub WarpParabolic( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal strength As Single, _
   ByVal radiusX As Integer, _
   ByVal radiusY As Integer, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim strength As Single
Dim radiusX As Integer
Dim radiusY As Integer
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.WarpParabolic(page, center, strength, radiusX, radiusY, interpolate, color)
public static void WarpParabolic(
   ImGearRasterPage page,
   ImGearPoint center,
   float strength,
   int radiusX,
   int radiusY,
   bool interpolate,
   ImGearPixel color
)
public: static void WarpParabolic(
   ImGearRasterPage* page,
   ImGearPoint center,
   float strength,
   int radiusX,
   int radiusY,
   bool interpolate,
   ImGearPixel* color
)
public:
static void WarpParabolic(
   ImGearRasterPage^ page,
   ImGearPoint center,
   float strength,
   int radiusX,
   int radiusY,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page class object.
center
Center of the paraboloid in pixels.
strength
Extrusion strength.
radiusX
Length of the effect in X direction in pixels.
radiusY
Length of the effect in Y direction in pixels.
interpolate
If this parameter is true then an interpolation is used during processing.
color
ImageGear.Core.ImGearPixel class color.
Example
  • C#
// Warp the image around a parabola.

// Center point of the parabola, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;

// Warp around the parabola with a strength of 50000, an x radius of 300, a y radius of 100,
//  interpolation on, and no fill color.
ImGearEffects.WarpParabolic(igRasterPage, igPoint, 50000, 300, 100, true, null);
  • Visual Basic
' Warp the image around a parabola.

' Center point of the parabola, set to center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2

' Warp around the parabola with a strength of 50000, an x radius of 300, a y radius of 100,
'  interpolation on, and no fill color.
ImGearEffects.WarpParabolic(igRasterPage, igPoint, 50000, 300, 100, True, Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure


WarpSphere Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : WarpSphere Method
Page class object.
Center of the sphere in pixels.
Sphere radius in pixels.
Height of the sphere segment in pixels. Height can be changed from (-radius) to (radius).
If this parameter is true then an interpolation is used during processing.
ImageGear.Core.ImGearPixel class color.
This method provides warping around sphere on the current raster page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub WarpSphere( _
   ByVal page As ImGearRasterPage, _
   ByVal center As ImGearPoint, _
   ByVal radius As Integer, _
   ByVal height As Integer, _
   ByVal interpolate As Boolean, _
   ByVal color As ImGearPixel _
)
'Usage

Dim page As ImGearRasterPage
Dim center As ImGearPoint
Dim radius As Integer
Dim height As Integer
Dim interpolate As Boolean
Dim color As ImGearPixel

ImGearEffects.WarpSphere(page, center, radius, height, interpolate, color)
public static void WarpSphere(
   ImGearRasterPage page,
   ImGearPoint center,
   int radius,
   int height,
   bool interpolate,
   ImGearPixel color
)
public: static void WarpSphere(
   ImGearRasterPage* page,
   ImGearPoint center,
   int radius,
   int height,
   bool interpolate,
   ImGearPixel* color
)
public:
static void WarpSphere(
   ImGearRasterPage^ page,
   ImGearPoint center,
   int radius,
   int height,
   bool interpolate,
   ImGearPixel^ color
)

Parameters

page
Page class object.
center
Center of the sphere in pixels.
radius
Sphere radius in pixels.
height
Height of the sphere segment in pixels. Height can be changed from (-radius) to (radius).
interpolate
If this parameter is true then an interpolation is used during processing.
color
ImageGear.Core.ImGearPixel class color.
Example
  • C#
// Warp the image around a sphere.

// Center point of the sphere, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;

// Warp around the sphere with a radius of 200, height of -100, interpolation on, and no fill color.
ImGearEffects.WarpSphere(igRasterPage, igPoint, 200, -100, true, null);
  • Visual Basic
' Warp the image around a sphere.

' Center point of the sphere, set to center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2

' Warp around the sphere with a radius of 200, height of -100, interpolation on, and no fill color.
ImGearEffects.WarpSphere(igRasterPage, igPoint, 200, -100, True, Nothing)
See Also

Reference

ImGearEffects Class
ImGearEffects Members
ImGearRasterPage Class
ImGearPoint Structure


%%PageItemTitle%% $$Properties$$

ImGearEffects Class Properties

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffects Class

For a list of all members of this type, see ImGearEffects members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets verificator for general effects functions.
Top
See Also

Reference

ImGearEffects Class
ImageGear.Processing Namespace
ImGearEffectsVerifier Class


Verifier Property (ImGearEffects)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffects Class : Verifier Property
Gets verificator for general effects functions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGearEffectsVerifier
'Usage

Dim value As ImGearEffectsVerifier

value = ImGearEffects.Verifier
public static ImGearEffectsVerifier Verifier {get;}
public: __property static ImGearEffectsVerifier* get_Verifier();
public:
static property ImGearEffectsVerifier^ Verifier {
   ImGearEffectsVerifier^ get();
}

Property Value

ImGearEffectsVerifier object.
See Also

Reference

ImGearEffects Class
ImGearEffects Members


%%PageItemTitle%%

ImGearEffectsVerifier Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffectsVerifier Class
Contains methods that check whether a particular effect can be performed on an image.
Object Model
ImGearEffectsVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearEffectsVerifier
'Usage

Dim instance As ImGearEffectsVerifier
public sealed class ImGearEffectsVerifier
public __gc __sealed class ImGearEffectsVerifier
public ref class ImGearEffectsVerifier sealed
Remarks
This class contains static methods that check whether the ImGearEffects class operation is applicable to the page or not. Note: These methods should be used to distinguish a sub-set of pages for which particular filter is applicable; e.g., ImGearRasterProcessingVerifier.CanApplyDespeckle method returns true only if incoming page image is binary, that is BitDepth == 1. Parameters of all IP functions are checked separately.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearEffectsVerifier

See Also

Reference

ImGearEffectsVerifier Members
ImageGear.Processing Namespace
ImGearEffects Class


%%PageItemTitle%% $$Members$$

ImGearEffectsVerifier Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffectsVerifier Class

The following tables list the members exposed by ImGearEffectsVerifier.

Public Constructors
 | Name | Description
Public Constructor | ImGearEffectsVerifier Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanApplyAdjustWhiteBalance | Returns true if ImGearEffects.AdjustWhiteBalance Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyAging | Returns true if ImGearEffects.Aging method can be applied to the specified page, otherwise - false.
Public Method | CanApplyBoost | Returns true if ImGearEffects.Boost method can be applied to the specified page, otherwise - false.
Public Method | CanApplyCylinder | Returns true if ImGearEffects.WarpCylinder method can be applied to the specified page, otherwise - false.
Public Method | CanApplyDropShadow | Returns true if ImGearEffects.DropShadow method can be applied to the specified page, otherwise - false.
Public Method | CanApplyDuotone | Returns true if ImGearEffects.Duotone method can be applied to the specified page, otherwise - false.
Public Method | CanApplyEdgeDetection | Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyEdgeMap | Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyFragment | Returns true if ImGearEffects.Fragment method can be applied to the specified page, otherwise - false.
Public Method | CanApplyFunctionalLights | Returns true if ImGearEffects.RadialLight method, ImGearEffects.DirectionalLight method, ImGearEffects.FreeRadialLight method and ImGearEffects.FreeDirectionalLight method can be applied to the specified page, otherwise - false.
Public Method | CanApplyGlowingEdges | Returns true if ImGearEffects.GlowingEdges method can be applied to the specified page, otherwise - false.
Public Method | CanApplyHighDensityRangeEffect | Returns true if ImGearEffects.HighDensityRangeEffect method can be applied to the specified page, otherwise - false.
Public Method | CanApplyHotWax | Returns true if ImGearEffects.HotWax method can be applied to the specified page, otherwise - false.
Public Method | CanApplyLensFlare | Returns true if ImGearEffects.LensFlare method can be applied to the specified page, otherwise - false.
Public Method | CanApplyMonochromeFilm | Returns true if ImGearEffects.MonochromeFilm method can be applied to the specified page, otherwise - false.
Public Method | CanApplyMosaic | Returns true if ImGearEffects.Mosaic method can be applied to the specified page, otherwise - false.
Public Method | CanApplyNightVision | Returns true if ImGearEffects.NightVision method can be applied to the specified page, otherwise - false.
Public Method | CanApplyOilify | Returns true if ImGearEffects.Oilify method can be applied to the specified page, otherwise - false.
Public Method | CanApplyParabola | Returns true if ImGearEffects.WarpParabolic method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPerspective | Returns true if ImGearEffects.Perspective method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPicturize | Returns true if ImGearEffects.Picturize method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPinch | Returns true if ImGearEffects.Pinch method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPixelate | Returns true if ImGearEffects.Pixelate method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPointillist | Returns true if ImGearEffects.Pointillist method can be applied to the specified page, otherwise - false.
Public Method | CanApplyProcessArea | Returns true if ImGearEffects.ProcessArea method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRemoveChromaticAberration | Returns true if ImGearEffects.RemoveChromaticAberration method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRipple | Returns true if ImGearEffects.Ripple method, ImGearEffects.RippleFreeHand method and ImGearEffects.RippleTexture method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRoundCorners | Returns true if ImGearEffects.RoundCorners method can be applied to the specified page, otherwise - false.
Public Method | CanApplySepia | Returns true if ImGearEffects.Sepia method can be applied to the specified page, otherwise - false.
Public Method | CanApplyShear | Returns true if ImGearEffects.Shear method can be applied to the specified page, otherwise - false.
Public Method | CanApplySketch | Returns true if ImGearEffects.Sketch method can be applied to the specified page, otherwise - false.
Public Method | CanApplySolarize | Returns true if ImGearEffects.Solarize Method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpatter | Returns true if ImGearEffects.Spatter method can be applied to the specified page, otherwise - false.
Public Method | CanApplySphere | Returns true if ImGearEffects.WarpSphere method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpotlights | Returns true if ImGearEffects.Spotlights method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpotlightsPreview | Returns true if ImGearEffects.SpotlightsPreview method can be applied to the specified page, otherwise - false.
Public Method | CanApplyToyCamera | Returns true if the ImGearEffects.ToyCamera method can be applied to the specified page, otherwise - false.
Public Method | CanApplyVignette | Returns true if ImGearEffects.Vignette method can be applied to the specified page, otherwise - false.
Public Method | CanApplyWave | Returns true if ImGearEffects.DirectionalWave method and ImGearEffects.RadialWave method can be applied to the specified page, otherwise - false.
Top
See Also

Reference

ImGearEffectsVerifier Class
ImageGear.Processing Namespace
ImGearEffects Class


%%PageItemTitle%%

ImGearEffectsVerifier Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : ImGearEffectsVerifier Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearEffectsVerifier()
public ImGearEffectsVerifier()
public: ImGearEffectsVerifier();
public:
ImGearEffectsVerifier();
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members


%%PageItemTitle%% $$Methods$$

ImGearEffectsVerifier Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearEffectsVerifier Class

For a list of all members of this type, see ImGearEffectsVerifier members.

Public Methods
 | Name | Description
Public Method | CanApplyAdjustWhiteBalance | Returns true if ImGearEffects.AdjustWhiteBalance Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyAging | Returns true if ImGearEffects.Aging method can be applied to the specified page, otherwise - false.
Public Method | CanApplyBoost | Returns true if ImGearEffects.Boost method can be applied to the specified page, otherwise - false.
Public Method | CanApplyCylinder | Returns true if ImGearEffects.WarpCylinder method can be applied to the specified page, otherwise - false.
Public Method | CanApplyDropShadow | Returns true if ImGearEffects.DropShadow method can be applied to the specified page, otherwise - false.
Public Method | CanApplyDuotone | Returns true if ImGearEffects.Duotone method can be applied to the specified page, otherwise - false.
Public Method | CanApplyEdgeDetection | Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyEdgeMap | Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Public Method | CanApplyFragment | Returns true if ImGearEffects.Fragment method can be applied to the specified page, otherwise - false.
Public Method | CanApplyFunctionalLights | Returns true if ImGearEffects.RadialLight method, ImGearEffects.DirectionalLight method, ImGearEffects.FreeRadialLight method and ImGearEffects.FreeDirectionalLight method can be applied to the specified page, otherwise - false.
Public Method | CanApplyGlowingEdges | Returns true if ImGearEffects.GlowingEdges method can be applied to the specified page, otherwise - false.
Public Method | CanApplyHighDensityRangeEffect | Returns true if ImGearEffects.HighDensityRangeEffect method can be applied to the specified page, otherwise - false.
Public Method | CanApplyHotWax | Returns true if ImGearEffects.HotWax method can be applied to the specified page, otherwise - false.
Public Method | CanApplyLensFlare | Returns true if ImGearEffects.LensFlare method can be applied to the specified page, otherwise - false.
Public Method | CanApplyMonochromeFilm | Returns true if ImGearEffects.MonochromeFilm method can be applied to the specified page, otherwise - false.
Public Method | CanApplyMosaic | Returns true if ImGearEffects.Mosaic method can be applied to the specified page, otherwise - false.
Public Method | CanApplyNightVision | Returns true if ImGearEffects.NightVision method can be applied to the specified page, otherwise - false.
Public Method | CanApplyOilify | Returns true if ImGearEffects.Oilify method can be applied to the specified page, otherwise - false.
Public Method | CanApplyParabola | Returns true if ImGearEffects.WarpParabolic method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPerspective | Returns true if ImGearEffects.Perspective method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPicturize | Returns true if ImGearEffects.Picturize method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPinch | Returns true if ImGearEffects.Pinch method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPixelate | Returns true if ImGearEffects.Pixelate method can be applied to the specified page, otherwise - false.
Public Method | CanApplyPointillist | Returns true if ImGearEffects.Pointillist method can be applied to the specified page, otherwise - false.
Public Method | CanApplyProcessArea | Returns true if ImGearEffects.ProcessArea method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRemoveChromaticAberration | Returns true if ImGearEffects.RemoveChromaticAberration method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRipple | Returns true if ImGearEffects.Ripple method, ImGearEffects.RippleFreeHand method and ImGearEffects.RippleTexture method can be applied to the specified page, otherwise - false.
Public Method | CanApplyRoundCorners | Returns true if ImGearEffects.RoundCorners method can be applied to the specified page, otherwise - false.
Public Method | CanApplySepia | Returns true if ImGearEffects.Sepia method can be applied to the specified page, otherwise - false.
Public Method | CanApplyShear | Returns true if ImGearEffects.Shear method can be applied to the specified page, otherwise - false.
Public Method | CanApplySketch | Returns true if ImGearEffects.Sketch method can be applied to the specified page, otherwise - false.
Public Method | CanApplySolarize | Returns true if ImGearEffects.Solarize Method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpatter | Returns true if ImGearEffects.Spatter method can be applied to the specified page, otherwise - false.
Public Method | CanApplySphere | Returns true if ImGearEffects.WarpSphere method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpotlights | Returns true if ImGearEffects.Spotlights method can be applied to the specified page, otherwise - false.
Public Method | CanApplySpotlightsPreview | Returns true if ImGearEffects.SpotlightsPreview method can be applied to the specified page, otherwise - false.
Public Method | CanApplyToyCamera | Returns true if the ImGearEffects.ToyCamera method can be applied to the specified page, otherwise - false.
Public Method | CanApplyVignette | Returns true if ImGearEffects.Vignette method can be applied to the specified page, otherwise - false.
Public Method | CanApplyWave | Returns true if ImGearEffects.DirectionalWave method and ImGearEffects.RadialWave method can be applied to the specified page, otherwise - false.
Top
See Also

Reference

ImGearEffectsVerifier Class
ImageGear.Processing Namespace
ImGearEffects Class


CanApplyAdjustWhiteBalance Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyAdjustWhiteBalance Method
Page specified.
Returns true if ImGearEffects.AdjustWhiteBalance Method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyAdjustWhiteBalance( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyAdjustWhiteBalance(page)
public bool CanApplyAdjustWhiteBalance(
   ImGearRasterPage page
)
public: bool CanApplyAdjustWhiteBalance(
   ImGearRasterPage* page
)
public:
bool CanApplyAdjustWhiteBalance(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
AdjustWhiteBalance(ImGearRasterPage,ImGearDoublePoint,ImGearDoublePoint) Method
AdjustWhiteBalance(ImGearRasterPage,ImGearWhiteBalancePreset,ImGearWhiteBalancePreset) Method
ImGearPage Class


CanApplyAging Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyAging Method
Page specified.
Returns true if ImGearEffects.Aging method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyAging( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyAging(page)
public bool CanApplyAging(
   ImGearRasterPage page
)
public: bool CanApplyAging(
   ImGearRasterPage* page
)
public:
bool CanApplyAging(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Aging Method


CanApplyBoost Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyBoost Method
Page specified.
Returns true if ImGearEffects.Boost method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyBoost( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyBoost(page)
public bool CanApplyBoost(
   ImGearRasterPage page
)
public: bool CanApplyBoost(
   ImGearRasterPage* page
)
public:
bool CanApplyBoost(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
Boost Method
ImGearPage Class


CanApplyCylinder Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyCylinder Method
Page specified.
Specify true if interpolation is to be used during processing, otherwise false.
Returns true if ImGearEffects.WarpCylinder method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCylinder( _
   ByVal page As ImGearRasterPage, _
   ByVal interpolate As Boolean _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim interpolate As Boolean
Dim value As Boolean

value = instance.CanApplyCylinder(page, interpolate)
public bool CanApplyCylinder(
   ImGearRasterPage page,
   bool interpolate
)
public: bool CanApplyCylinder(
   ImGearRasterPage* page,
   bool interpolate
)
public:
bool CanApplyCylinder(
   ImGearRasterPage^ page,
   bool interpolate
)

Parameters

page
Page specified.
interpolate
Specify true if interpolation is to be used during processing, otherwise false.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
WarpCylinder Method


CanApplyDropShadow Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyDropShadow Method
Page specified.
Returns true if ImGearEffects.DropShadow method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyDropShadow( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyDropShadow(page)
public bool CanApplyDropShadow(
   ImGearRasterPage page
)
public: bool CanApplyDropShadow(
   ImGearRasterPage* page
)
public:
bool CanApplyDropShadow(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
DropShadow Method


CanApplyDuotone Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyDuotone Method
Page to apply the method to.
Returns true if ImGearEffects.Duotone method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyDuotone( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyDuotone(page)
public bool CanApplyDuotone(
   ImGearRasterPage page
)
public: bool CanApplyDuotone(
   ImGearRasterPage* page
)
public:
bool CanApplyDuotone(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Duotone Method


CanApplyEdgeDetection Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyEdgeDetection Method
Page specified.
Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyEdgeDetection( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyEdgeDetection(page)
public bool CanApplyEdgeDetection(
   ImGearRasterPage page
)
public: bool CanApplyEdgeDetection(
   ImGearRasterPage* page
)
public:
bool CanApplyEdgeDetection(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
Remarks
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
EdgeDetection(ImGearRasterPage,ImGearEdgeDetectionMethods) Method


CanApplyEdgeMap Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyEdgeMap Method
Page specified.
Returns true, if EdgeDetection Method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyEdgeMap( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyEdgeMap(page)
public bool CanApplyEdgeMap(
   ImGearRasterPage page
)
public: bool CanApplyEdgeMap(
   ImGearRasterPage* page
)
public:
bool CanApplyEdgeMap(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods) Method
EdgeMap(ImGearRasterPage,ImGearEdgeMapMethods,ImGearChannelRange) Method


CanApplyFragment Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyFragment Method
Page specified.
Returns true if ImGearEffects.Fragment method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFragment( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFragment(page)
public bool CanApplyFragment(
   ImGearRasterPage page
)
public: bool CanApplyFragment(
   ImGearRasterPage* page
)
public:
bool CanApplyFragment(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Fragment Method


CanApplyFunctionalLights Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyFunctionalLights Method
Page specified.
Returns true if ImGearEffects.RadialLight method, ImGearEffects.DirectionalLight method, ImGearEffects.FreeRadialLight method and ImGearEffects.FreeDirectionalLight method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyFunctionalLights( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyFunctionalLights(page)
public bool CanApplyFunctionalLights(
   ImGearRasterPage page
)
public: bool CanApplyFunctionalLights(
   ImGearRasterPage* page
)
public:
bool CanApplyFunctionalLights(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
Remarks
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
RadialLight Method
DirectionalLight Method
FreeRadialLight Method
FreeDirectionalLight Method


CanApplyGlowingEdges Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyGlowingEdges Method
Page specified.
Returns true if ImGearEffects.GlowingEdges method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyGlowingEdges( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyGlowingEdges(page)
public bool CanApplyGlowingEdges(
   ImGearRasterPage page
)
public: bool CanApplyGlowingEdges(
   ImGearRasterPage* page
)
public:
bool CanApplyGlowingEdges(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
GlowingEdges Method
ImGearPage Class


CanApplyHighDensityRangeEffect Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyHighDensityRangeEffect Method
Page specified.
Returns true if ImGearEffects.HighDensityRangeEffect method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyHighDensityRangeEffect( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyHighDensityRangeEffect(page)
public bool CanApplyHighDensityRangeEffect(
   ImGearRasterPage page
)
public: bool CanApplyHighDensityRangeEffect(
   ImGearRasterPage* page
)
public:
bool CanApplyHighDensityRangeEffect(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
HighDensityRangeEffect Method
ImGearPage Class


CanApplyHotWax Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyHotWax Method
Page specified.
Returns true if ImGearEffects.HotWax method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyHotWax( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyHotWax(page)
public bool CanApplyHotWax(
   ImGearRasterPage page
)
public: bool CanApplyHotWax(
   ImGearRasterPage* page
)
public:
bool CanApplyHotWax(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
HotWax Method
ImGearPage Class


CanApplyLensFlare Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyLensFlare Method
Page specified.
Returns true if ImGearEffects.LensFlare method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyLensFlare( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyLensFlare(page)
public bool CanApplyLensFlare(
   ImGearRasterPage page
)
public: bool CanApplyLensFlare(
   ImGearRasterPage* page
)
public:
bool CanApplyLensFlare(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
LensFlare Method
ImGearLensFlareType Enumeration


CanApplyMonochromeFilm Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyMonochromeFilm Method
Page specified.
Returns true if ImGearEffects.MonochromeFilm method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyMonochromeFilm( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyMonochromeFilm(page)
public bool CanApplyMonochromeFilm(
   ImGearRasterPage page
)
public: bool CanApplyMonochromeFilm(
   ImGearRasterPage* page
)
public:
bool CanApplyMonochromeFilm(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
MonochromeFilm Method
ImGearPage Class


CanApplyMosaic Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyMosaic Method
Page specified.
Returns true if ImGearEffects.Mosaic method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyMosaic( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyMosaic(page)
public bool CanApplyMosaic(
   ImGearRasterPage page
)
public: bool CanApplyMosaic(
   ImGearRasterPage* page
)
public:
bool CanApplyMosaic(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Mosaic Method


CanApplyNightVision Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyNightVision Method
Page to apply the method to.
Returns true if ImGearEffects.NightVision method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyNightVision( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyNightVision(page)
public bool CanApplyNightVision(
   ImGearRasterPage page
)
public: bool CanApplyNightVision(
   ImGearRasterPage* page
)
public:
bool CanApplyNightVision(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
NightVision(ImGearRasterPage,ImGearNightVisionPresets,Int32,Double) Method


CanApplyOilify Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyOilify Method
Page specified.
Returns true if ImGearEffects.Oilify method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyOilify( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyOilify(page)
public bool CanApplyOilify(
   ImGearRasterPage page
)
public: bool CanApplyOilify(
   ImGearRasterPage* page
)
public:
bool CanApplyOilify(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Oilify Method


CanApplyParabola Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyParabola Method
Page specified.
Specify true if interpolation is to be used during processing, otherwise false.
Returns true if ImGearEffects.WarpParabolic method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyParabola( _
   ByVal page As ImGearRasterPage, _
   ByVal interpolate As Boolean _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim interpolate As Boolean
Dim value As Boolean

value = instance.CanApplyParabola(page, interpolate)
public bool CanApplyParabola(
   ImGearRasterPage page,
   bool interpolate
)
public: bool CanApplyParabola(
   ImGearRasterPage* page,
   bool interpolate
)
public:
bool CanApplyParabola(
   ImGearRasterPage^ page,
   bool interpolate
)

Parameters

page
Page specified.
interpolate
Specify true if interpolation is to be used during processing, otherwise false.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
WarpParabolic Method


CanApplyPerspective Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyPerspective Method
Page specified.
Returns true if ImGearEffects.Perspective method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyPerspective( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyPerspective(page)
public bool CanApplyPerspective(
   ImGearRasterPage page
)
public: bool CanApplyPerspective(
   ImGearRasterPage* page
)
public:
bool CanApplyPerspective(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Perspective Method


CanApplyPicturize Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyPicturize Method
Page specified.
Returns true if ImGearEffects.Picturize method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyPicturize( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyPicturize(page)
public bool CanApplyPicturize(
   ImGearRasterPage page
)
public: bool CanApplyPicturize(
   ImGearRasterPage* page
)
public:
bool CanApplyPicturize(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
Remarks
Note that ImGearEffects.Picturize method itself does not have a parameter of type ImageGear.Core.ImGearRasterPage class. Instead, it uses auxiliary classes, and constructor of one of these classes has an ImageGear.Core.ImGearRasterPage class parameter.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
Picturize Method
ImGearPage Class


CanApplyPinch Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyPinch Method
Page specified.
Interpolate flag.
Returns true if ImGearEffects.Pinch method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyPinch( _
   ByVal page As ImGearRasterPage, _
   ByVal interpolate As Boolean _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim interpolate As Boolean
Dim value As Boolean

value = instance.CanApplyPinch(page, interpolate)
public bool CanApplyPinch(
   ImGearRasterPage page,
   bool interpolate
)
public: bool CanApplyPinch(
   ImGearRasterPage* page,
   bool interpolate
)
public:
bool CanApplyPinch(
   ImGearRasterPage^ page,
   bool interpolate
)

Parameters

page
Page specified.
interpolate
Interpolate flag.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Pinch Method


CanApplyPixelate Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyPixelate Method
Page specified.
Returns true if ImGearEffects.Pixelate method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyPixelate( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyPixelate(page)
public bool CanApplyPixelate(
   ImGearRasterPage page
)
public: bool CanApplyPixelate(
   ImGearRasterPage* page
)
public:
bool CanApplyPixelate(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Pixelate Method


CanApplyPointillist Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyPointillist Method
Page specified.
Returns true if ImGearEffects.Pointillist method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyPointillist( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyPointillist(page)
public bool CanApplyPointillist(
   ImGearRasterPage page
)
public: bool CanApplyPointillist(
   ImGearRasterPage* page
)
public:
bool CanApplyPointillist(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Pointillist Method
ImGearBrushType Enumeration


CanApplyProcessArea Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyProcessArea Method
Page specified.
Returns true if ImGearEffects.ProcessArea method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyProcessArea( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyProcessArea(page)
public bool CanApplyProcessArea(
   ImGearRasterPage page
)
public: bool CanApplyProcessArea(
   ImGearRasterPage* page
)
public:
bool CanApplyProcessArea(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
ProcessArea Method


CanApplyRemoveChromaticAberration Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyRemoveChromaticAberration Method
Page specified.
Returns true if ImGearEffects.RemoveChromaticAberration method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRemoveChromaticAberration( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyRemoveChromaticAberration(page)
public bool CanApplyRemoveChromaticAberration(
   ImGearRasterPage page
)
public: bool CanApplyRemoveChromaticAberration(
   ImGearRasterPage* page
)
public:
bool CanApplyRemoveChromaticAberration(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
RemoveChromaticAberration Method
ImGearPage Class


CanApplyRipple Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyRipple Method
Page specified.
Returns true if ImGearEffects.Ripple method, ImGearEffects.RippleFreeHand method and ImGearEffects.RippleTexture method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRipple( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyRipple(page)
public bool CanApplyRipple(
   ImGearRasterPage page
)
public: bool CanApplyRipple(
   ImGearRasterPage* page
)
public:
bool CanApplyRipple(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
Ripple Method
RippleFreeHand Method
RippleTexture Method
ImGearPage Class


CanApplyRoundCorners Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyRoundCorners Method
Page to apply the method to.
Returns true if ImGearEffects.RoundCorners method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRoundCorners( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyRoundCorners(page)
public bool CanApplyRoundCorners(
   ImGearRasterPage page
)
public: bool CanApplyRoundCorners(
   ImGearRasterPage* page
)
public:
bool CanApplyRoundCorners(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
RoundCorners Method


CanApplySepia Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySepia Method
Page to apply the method to.
Returns true if ImGearEffects.Sepia method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySepia( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySepia(page)
public bool CanApplySepia(
   ImGearRasterPage page
)
public: bool CanApplySepia(
   ImGearRasterPage* page
)
public:
bool CanApplySepia(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Sepia Method


CanApplyShear Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyShear Method
Page specified.
Returns true if ImGearEffects.Shear method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyShear( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyShear(page)
public bool CanApplyShear(
   ImGearRasterPage page
)
public: bool CanApplyShear(
   ImGearRasterPage* page
)
public:
bool CanApplyShear(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Shear Method
ImGearShearFillStyle Enumeration


CanApplySketch Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySketch Method
Page specified.
Returns true if ImGearEffects.Sketch method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySketch( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySketch(page)
public bool CanApplySketch(
   ImGearRasterPage page
)
public: bool CanApplySketch(
   ImGearRasterPage* page
)
public:
bool CanApplySketch(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
Sketch Method
ImGearPage Class


CanApplySolarize Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySolarize Method
Page specified.
Returns true if ImGearEffects.Solarize Method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySolarize( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySolarize(page)
public bool CanApplySolarize(
   ImGearRasterPage page
)
public: bool CanApplySolarize(
   ImGearRasterPage* page
)
public:
bool CanApplySolarize(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Solarize(ImGearRasterPage,Int32) Method
Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange) Method
Solarize(ImGearRasterPage,Int32,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method


CanApplySpatter Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySpatter Method
Page specified.
Returns true if ImGearEffects.Spatter method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySpatter( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySpatter(page)
public bool CanApplySpatter(
   ImGearRasterPage page
)
public: bool CanApplySpatter(
   ImGearRasterPage* page
)
public:
bool CanApplySpatter(
   ImGearRasterPage^ page
)

Parameters

page
Page specified.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Spatter Method


CanApplySphere Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySphere Method
Page specified.
Specify true if interpolation is to be used during processing, otherwise false.
Returns true if ImGearEffects.WarpSphere method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySphere( _
   ByVal page As ImGearRasterPage, _
   ByVal interpolate As Boolean _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim interpolate As Boolean
Dim value As Boolean

value = instance.CanApplySphere(page, interpolate)
public bool CanApplySphere(
   ImGearRasterPage page,
   bool interpolate
)
public: bool CanApplySphere(
   ImGearRasterPage* page,
   bool interpolate
)
public:
bool CanApplySphere(
   ImGearRasterPage^ page,
   bool interpolate
)

Parameters

page
Page specified.
interpolate
Specify true if interpolation is to be used during processing, otherwise false.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
WarpSphere Method
ImGearRasterPage Class


CanApplySpotlights Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySpotlights Method
Page to apply the method to.
Returns true if ImGearEffects.Spotlights method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySpotlights( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySpotlights(page)
public bool CanApplySpotlights(
   ImGearRasterPage page
)
public: bool CanApplySpotlights(
   ImGearRasterPage* page
)
public:
bool CanApplySpotlights(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
Spotlights Method
ImGearRasterPage Class


CanApplySpotlightsPreview Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplySpotlightsPreview Method
Page to apply the method to.
Preview page to apply the method to.
Returns true if ImGearEffects.SpotlightsPreview method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplySpotlightsPreview( _
   ByVal page As ImGearRasterPage, _
   ByVal previewPage As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim previewPage As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplySpotlightsPreview(page, previewPage)
public bool CanApplySpotlightsPreview(
   ImGearRasterPage page,
   ImGearRasterPage previewPage
)
public: bool CanApplySpotlightsPreview(
   ImGearRasterPage* page,
   ImGearRasterPage* previewPage
)
public:
bool CanApplySpotlightsPreview(
   ImGearRasterPage^ page,
   ImGearRasterPage^ previewPage
)

Parameters

page
Page to apply the method to.
previewPage
Preview page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
SpotlightsPreview Method
ImGearRasterPage Class


CanApplyToyCamera Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyToyCamera Method
Page to apply the method to.
Returns true if the ImGearEffects.ToyCamera method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyToyCamera( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyToyCamera(page)
public bool CanApplyToyCamera(
   ImGearRasterPage page
)
public: bool CanApplyToyCamera(
   ImGearRasterPage* page
)
public:
bool CanApplyToyCamera(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
ToyCamera Method


CanApplyVignette Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyVignette Method
Page to apply the method to.
Returns true if ImGearEffects.Vignette method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyVignette( _
   ByVal page As ImGearRasterPage _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim value As Boolean

value = instance.CanApplyVignette(page)
public bool CanApplyVignette(
   ImGearRasterPage page
)
public: bool CanApplyVignette(
   ImGearRasterPage* page
)
public:
bool CanApplyVignette(
   ImGearRasterPage^ page
)

Parameters

page
Page to apply the method to.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
ImGearRasterPage Class
Vignette(ImGearRasterPage,IImGearShape,Int32,Double,ImGearPixel,Boolean) Method


CanApplyWave Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearEffectsVerifier Class : CanApplyWave Method
Page specified.
Specify true if interpolation is to be used during processing, otherwise false.
Returns true if ImGearEffects.DirectionalWave method and ImGearEffects.RadialWave method can be applied to the specified page, otherwise - false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyWave( _
   ByVal page As ImGearRasterPage, _
   ByVal interpolate As Boolean _
) As Boolean
'Usage

Dim instance As ImGearEffectsVerifier
Dim page As ImGearRasterPage
Dim interpolate As Boolean
Dim value As Boolean

value = instance.CanApplyWave(page, interpolate)
public bool CanApplyWave(
   ImGearRasterPage page,
   bool interpolate
)
public: bool CanApplyWave(
   ImGearRasterPage* page,
   bool interpolate
)
public:
bool CanApplyWave(
   ImGearRasterPage^ page,
   bool interpolate
)

Parameters

page
Page specified.
interpolate
Specify true if interpolation is to be used during processing, otherwise false.

Return Value

Boolean value.
See Also

Reference

ImGearEffectsVerifier Class
ImGearEffectsVerifier Members
DirectionalWave Method
RadialWave Method
ImGearRasterPage Class


%%PageItemTitle%%

ImGearMosaicBorderParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicBorderParams Class
Describes border characteristics of the Mosaic operation.
Object Model
ImGearMosaicBorderParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMosaicBorderParams
'Usage

Dim instance As ImGearMosaicBorderParams
public class ImGearMosaicBorderParams
public __gc class ImGearMosaicBorderParams
public ref class ImGearMosaicBorderParams
Example
  • C#
// Applies a mosaic effect to an image.

// Parameter classes for Mosaic method.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();

//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;

// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;

ImGearEffects.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);
  • Visual Basic
' Applies a mosaic effect to an image.

     ' Parameter classes for Mosaic function.
     Dim igMosaicFillParams As New ImGearMosaicFillParams()
     Dim igMosaicCellParams As New ImGearMosaicCellParams()
     Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
     Dim igMosaicShadowParams As New ImGearMosaicShadowParams()

     'Color for fill and border.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.

     ' Cell parameters
     igMosaicCellParams.Type = ImGearMosaicType.Cartesian
     igMosaicCellParams.Width = 32
     igMosaicCellParams.Height = 32
     igMosaicCellParams.PolarCenterX = 100
     igMosaicCellParams.PolarCenterY = 100
     ' Fill parameters
     igMosaicFillParams.Color = igPixel
     igMosaicFillParams.Opacity = CSng(0.2)
     ' Border parameters
     igMosaicBorderParams.Width = 0
     igMosaicBorderParams.Height = 0
     igMosaicBorderParams.Color = igPixel
     igMosaicBorderParams.Opacity = CSng(0.3)
     igMosaicBorderParams.Irregularity = 0
     ' Shadow Parameters
     igMosaicShadowParams.Enabled = True
     igMosaicShadowParams.Threshold = 0
     igMosaicShadowParams.Direction = ImGearDirection.SouthEast
     igMosaicShadowParams.HighResolution = False
     igMosaicShadowParams.Intensity = CSng(1)

     ImGearEffects.Mosaic(igRasterPage, igMosaicFillParams, _
igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearMosaicBorderParams

See Also

Reference

ImGearMosaicBorderParams Members
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%% $$Members$$

ImGearMosaicBorderParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicBorderParams Class

The following tables list the members exposed by ImGearMosaicBorderParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearMosaicBorderParams Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Color | Color of the border.
Public Field | Height | Height of the border.
Public Field | Irregularity | Irregularity of the border.
Public Field | Opacity | Border opacity.
Public Field | Width | Width of the border.
Top
See Also

Reference

ImGearMosaicBorderParams Class
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%%

ImGearMosaicBorderParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : ImGearMosaicBorderParams Constructor
Overload List
Overload | Description
ImGearMosaicBorderParams Constructor() | Initializes a new instance of the ImGearMosaicBorderParams class.
ImGearMosaicBorderParams Constructor(ImGearDIB) | Initializes a new instance of the ImGearMosaicBorderParams class.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members


%%PageItemTitle%%

ImGearMosaicBorderParams Constructor()

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class > ImGearMosaicBorderParams Constructor : ImGearMosaicBorderParams Constructor()
Initializes a new instance of the ImGearMosaicBorderParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMosaicBorderParams()
public ImGearMosaicBorderParams()
public: ImGearMosaicBorderParams();
public:
ImGearMosaicBorderParams();
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members
Overload List


%%PageItemTitle%%

ImGearMosaicBorderParams Constructor(ImGearDIB)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class > ImGearMosaicBorderParams Constructor : ImGearMosaicBorderParams Constructor(ImGearDIB)
Uses ChannelCount, BitsPerChannel of the provided DIB.
Initializes a new instance of the ImGearMosaicBorderParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dib As ImGearDIB _
)
'Usage

Dim dib As ImGearDIB

Dim instance As New ImGearMosaicBorderParams(dib)
public ImGearMosaicBorderParams(
   ImGearDIB dib
)
public: ImGearMosaicBorderParams(
   ImGearDIB* dib
)
public:
ImGearMosaicBorderParams(
   ImGearDIB^ dib
)

Parameters

dib
Uses ChannelCount, BitsPerChannel of the provided DIB.

Return Value

The new instance of ImGearMosaicBorderParams class
Remarks
This constructor creates the new instance of the ImGearMosaicBorderParams class.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members
Overload List


%%PageItemTitle%% $$Fields$$

ImGearMosaicBorderParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicBorderParams Class

For a list of all members of this type, see ImGearMosaicBorderParams members.

Public Fields
 | Name | Description
Public Field | Color | Color of the border.
Public Field | Height | Height of the border.
Public Field | Irregularity | Irregularity of the border.
Public Field | Opacity | Border opacity.
Public Field | Width | Width of the border.
Top
See Also

Reference

ImGearMosaicBorderParams Class
ImageGear.Processing Namespace
Mosaic Method


Color Field (ImGearMosaicBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : Color Field
Color of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Color As ImGearPixel
'Usage

Dim instance As ImGearMosaicBorderParams
Dim value As ImGearPixel

value = instance.Color

instance.Color = value
public ImGearPixel Color
public: ImGearPixel* Color
public:
ImGearPixel^ Color

Field Value

ImageGear.Core.ImGearPixel class.
Remarks
This option lets you specify the color of the border.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members
ImGearPixel Class


Height Field (ImGearMosaicBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : Height Field
Height of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearMosaicBorderParams
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Any integer value.
Remarks
This option lets you specify the height of the border in pixels.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members


Irregularity Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : Irregularity Field
Irregularity of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Irregularity As Integer
'Usage

Dim instance As ImGearMosaicBorderParams
Dim value As Integer

value = instance.Irregularity

instance.Irregularity = value
public int Irregularity
public: int Irregularity
public:
int Irregularity

Field Value

Any integer value.
Remarks
This option lets you specify the irregularity of the border. This value must be greater than or equal to zero.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members


Opacity Field (ImGearMosaicBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : Opacity Field
Border opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Opacity As Single
'Usage

Dim instance As ImGearMosaicBorderParams
Dim value As Single

value = instance.Opacity

instance.Opacity = value
public float Opacity
public: float Opacity
public:
float Opacity

Field Value

Value range is 0...1.
Remarks
This option lets you specify the border opacity, where 0.0 is transparent and 1.0 is opaque.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members


Width Field (ImGearMosaicBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicBorderParams Class : Width Field
Width of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearMosaicBorderParams
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Any integer value.
Remarks
This option lets you specify the width of the border in pixels.
See Also

Reference

ImGearMosaicBorderParams Class
ImGearMosaicBorderParams Members


%%PageItemTitle%%

ImGearMosaicCellParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicCellParams Class
Describes cell parameters of the Mosaic operation.
Object Model
ImGearMosaicCellParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMosaicCellParams
'Usage

Dim instance As ImGearMosaicCellParams
public class ImGearMosaicCellParams
public __gc class ImGearMosaicCellParams
public ref class ImGearMosaicCellParams
Example
  • C#
// Applies a mosaic effect to an image.

// Parameter classes for Mosaic method.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();

//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;

// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;

ImGearEffects.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);
  • Visual Basic
' Applies a mosaic effect to an image.

     ' Parameter classes for Mosaic function.
     Dim igMosaicFillParams As New ImGearMosaicFillParams()
     Dim igMosaicCellParams As New ImGearMosaicCellParams()
     Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
     Dim igMosaicShadowParams As New ImGearMosaicShadowParams()

     'Color for fill and border.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.

     ' Cell parameters
     igMosaicCellParams.Type = ImGearMosaicType.Cartesian
     igMosaicCellParams.Width = 32
     igMosaicCellParams.Height = 32
     igMosaicCellParams.PolarCenterX = 100
     igMosaicCellParams.PolarCenterY = 100
     ' Fill parameters
     igMosaicFillParams.Color = igPixel
     igMosaicFillParams.Opacity = CSng(0.2)
     ' Border parameters
     igMosaicBorderParams.Width = 0
     igMosaicBorderParams.Height = 0
     igMosaicBorderParams.Color = igPixel
     igMosaicBorderParams.Opacity = CSng(0.3)
     igMosaicBorderParams.Irregularity = 0
     ' Shadow Parameters
     igMosaicShadowParams.Enabled = True
     igMosaicShadowParams.Threshold = 0
     igMosaicShadowParams.Direction = ImGearDirection.SouthEast
     igMosaicShadowParams.HighResolution = False
     igMosaicShadowParams.Intensity = CSng(1)

     ImGearEffects.Mosaic(igRasterPage, igMosaicFillParams, _
igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearMosaicCellParams

See Also

Reference

ImGearMosaicCellParams Members
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%% $$Members$$

ImGearMosaicCellParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicCellParams Class

The following tables list the members exposed by ImGearMosaicCellParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearMosaicCellParams Constructor | Initializes a new instance of the ImGearMosaicCellParams class.
Top
Public Fields
 | Name | Description
Public Field | Height | Height of the cell.
Public Field | PolarCenterX | X center of the coordinate system.
Public Field | PolarCenterY | Y center of the coordinate system.
Public Field | Type | Type of mosaic.
Public Field | Width | Width of the cell.
Top
See Also

Reference

ImGearMosaicCellParams Class
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%%

ImGearMosaicCellParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : ImGearMosaicCellParams Constructor
Initializes a new instance of the ImGearMosaicCellParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMosaicCellParams()
public ImGearMosaicCellParams()
public: ImGearMosaicCellParams();
public:
ImGearMosaicCellParams();
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members


%%PageItemTitle%% $$Fields$$

ImGearMosaicCellParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicCellParams Class

For a list of all members of this type, see ImGearMosaicCellParams members.

Public Fields
 | Name | Description
Public Field | Height | Height of the cell.
Public Field | PolarCenterX | X center of the coordinate system.
Public Field | PolarCenterY | Y center of the coordinate system.
Public Field | Type | Type of mosaic.
Public Field | Width | Width of the cell.
Top
See Also

Reference

ImGearMosaicCellParams Class
ImageGear.Processing Namespace
Mosaic Method


Height Field (ImGearMosaicCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : Height Field
Height of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearMosaicCellParams
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Any integer value.
Remarks
This option lets you specify the height of the cell in pixels.
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members


PolarCenterX Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : PolarCenterX Field
X center of the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PolarCenterX As Integer
'Usage

Dim instance As ImGearMosaicCellParams
Dim value As Integer

value = instance.PolarCenterX

instance.PolarCenterX = value
public int PolarCenterX
public: int PolarCenterX
public:
int PolarCenterX

Field Value

Any integer value.
Remarks
This option lets you specify the x center of the coordinate system, if Type field is ImGearMosaicType.Polar or ImGearMosaicType.Spiderweb.
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members
ImGearMosaicType Enumeration
Type Field


PolarCenterY Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : PolarCenterY Field
Y center of the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public PolarCenterY As Integer
'Usage

Dim instance As ImGearMosaicCellParams
Dim value As Integer

value = instance.PolarCenterY

instance.PolarCenterY = value
public int PolarCenterY
public: int PolarCenterY
public:
int PolarCenterY

Field Value

Any integer value.
Remarks
This option lets you specify the y center of the coordinate system, if Type field is ImGearMosaicType.Polar or ImGearMosaicType.Spiderweb.
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members
ImGearMosaicType Enumeration
Type Field


Type Field (ImGearMosaicCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : Type Field
Type of mosaic.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Type As ImGearMosaicType
'Usage

Dim instance As ImGearMosaicCellParams
Dim value As ImGearMosaicType

value = instance.Type

instance.Type = value
public ImGearMosaicType Type
public: ImGearMosaicType Type
public:
ImGearMosaicType Type

Field Value

ImGearMosaicType enumeration value
Remarks
This option lets you specify the type of mosaic. See ImGearMosaicType enumeration for detail.
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members
ImGearMosaicType Enumeration
PolarCenterX Field
PolarCenterY Field


Width Field (ImGearMosaicCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicCellParams Class : Width Field
Width of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearMosaicCellParams
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Any integer value.
Remarks
This option lets you specify the width of the cell in pixels.
See Also

Reference

ImGearMosaicCellParams Class
ImGearMosaicCellParams Members


%%PageItemTitle%%

ImGearMosaicFillParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicFillParams Class
Describes fill characteristics of the Mosaic operation.
Object Model
ImGearMosaicFillParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMosaicFillParams
'Usage

Dim instance As ImGearMosaicFillParams
public class ImGearMosaicFillParams
public __gc class ImGearMosaicFillParams
public ref class ImGearMosaicFillParams
Example
  • C#
// Applies a mosaic effect to an image.

// Parameter classes for Mosaic method.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();

//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;

// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;

ImGearEffects.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);
  • Visual Basic
' Applies a mosaic effect to an image.

     ' Parameter classes for Mosaic function.
     Dim igMosaicFillParams As New ImGearMosaicFillParams()
     Dim igMosaicCellParams As New ImGearMosaicCellParams()
     Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
     Dim igMosaicShadowParams As New ImGearMosaicShadowParams()

     'Color for fill and border.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.

     ' Cell parameters
     igMosaicCellParams.Type = ImGearMosaicType.Cartesian
     igMosaicCellParams.Width = 32
     igMosaicCellParams.Height = 32
     igMosaicCellParams.PolarCenterX = 100
     igMosaicCellParams.PolarCenterY = 100
     ' Fill parameters
     igMosaicFillParams.Color = igPixel
     igMosaicFillParams.Opacity = CSng(0.2)
     ' Border parameters
     igMosaicBorderParams.Width = 0
     igMosaicBorderParams.Height = 0
     igMosaicBorderParams.Color = igPixel
     igMosaicBorderParams.Opacity = CSng(0.3)
     igMosaicBorderParams.Irregularity = 0
     ' Shadow Parameters
     igMosaicShadowParams.Enabled = True
     igMosaicShadowParams.Threshold = 0
     igMosaicShadowParams.Direction = ImGearDirection.SouthEast
     igMosaicShadowParams.HighResolution = False
     igMosaicShadowParams.Intensity = CSng(1)

     ImGearEffects.Mosaic(igRasterPage, igMosaicFillParams, _
igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearMosaicFillParams

See Also

Reference

ImGearMosaicFillParams Members
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%% $$Members$$

ImGearMosaicFillParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicFillParams Class

The following tables list the members exposed by ImGearMosaicFillParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearMosaicFillParams Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Color | Fill color.
Public Field | Opacity | Opacity of the cell.
Top
See Also

Reference

ImGearMosaicFillParams Class
ImageGear.Processing Namespace
Mosaic Method


%%PageItemTitle%%

ImGearMosaicFillParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicFillParams Class : ImGearMosaicFillParams Constructor
Overload List
Overload | Description
ImGearMosaicFillParams Constructor() | Initializes a new instance of the ImGearMosaicFillParams class and fills it with default values, suitable for processing of RGB images.
ImGearMosaicFillParams Constructor(ImGearDIB) | Initializes a new instance of the ImGearMosaicFillParams class and fills it with default values, according to pixel format of the specified DIB.
See Also

Reference

ImGearMosaicFillParams Class
ImGearMosaicFillParams Members


%%PageItemTitle%%

ImGearMosaicFillParams Constructor()

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicFillParams Class > ImGearMosaicFillParams Constructor : ImGearMosaicFillParams Constructor()
Initializes a new instance of the ImGearMosaicFillParams class and fills it with default values, suitable for processing of RGB images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMosaicFillParams()
public ImGearMosaicFillParams()
public: ImGearMosaicFillParams();
public:
ImGearMosaicFillParams();
See Also

Reference

ImGearMosaicFillParams Class
ImGearMosaicFillParams Members
Overload List
ImGearMosaicFillParams Constructor(ImGearDIB)


%%PageItemTitle%%

ImGearMosaicFillParams Constructor(ImGearDIB)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicFillParams Class > ImGearMosaicFillParams Constructor : ImGearMosaicFillParams Constructor(ImGearDIB)
DIB which pixel format will be used for creation of ImGearMosaicFillParams class object.
Initializes a new instance of the ImGearMosaicFillParams class and fills it with default values, according to pixel format of the specified DIB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dib As ImGearDIB _
)
'Usage

Dim dib As ImGearDIB

Dim instance As New ImGearMosaicFillParams(dib)
public ImGearMosaicFillParams(
   ImGearDIB dib
)
public: ImGearMosaicFillParams(
   ImGearDIB* dib
)
public:
ImGearMosaicFillParams(
   ImGearDIB^ dib
)

Parameters

dib
DIB which pixel format will be used for creation of ImGearMosaicFillParams class object.
Remarks
This constructor initializes the Color field according to channel count and channel storage format (BitsPerChannel) of the specified DIB.
See Also

Reference

ImGearMosaicFillParams Class
ImGearMosaicFillParams Members
Overload List


%%PageItemTitle%% $$Fields$$

ImGearMosaicFillParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicFillParams Class

For a list of all members of this type, see ImGearMosaicFillParams members.

Public Fields
 | Name | Description
Public Field | Color | Fill color.
Public Field | Opacity | Opacity of the cell.
Top
See Also

Reference

ImGearMosaicFillParams Class
ImageGear.Processing Namespace
Mosaic Method


Color Field (ImGearMosaicFillParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicFillParams Class : Color Field
Fill color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Color As ImGearPixel
'Usage

Dim instance As ImGearMosaicFillParams
Dim value As ImGearPixel

value = instance.Color

instance.Color = value
public ImGearPixel Color
public: ImGearPixel* Color
public:
ImGearPixel^ Color

Field Value

ImageGear.Core.ImGearPixel class.
Remarks
This option lets you specify the fill color. This color is blended with the original cell color according to the Opacity field.
See Also

Reference

ImGearMosaicFillParams Class
ImGearMosaicFillParams Members
Opacity Field
ImGearPixel Class


Opacity Field (ImGearMosaicFillParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicFillParams Class : Opacity Field
Opacity of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Opacity As Single
'Usage

Dim instance As ImGearMosaicFillParams
Dim value As Single

value = instance.Opacity

instance.Opacity = value
public float Opacity
public: float Opacity
public:
float Opacity

Field Value

Valid range is 0...1.
Remarks
This option lets you specify the opacity of the cell, where 0.0 is transparent and 1.0 is opaque.
See Also

Reference

ImGearMosaicFillParams Class
ImGearMosaicFillParams Members
Color Field


%%PageItemTitle%%

ImGearMosaicShadowParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicShadowParams Class
Describes parameters of the shadow effect to be applied to an image after dividing on the cells.
Object Model
ImGearMosaicShadowParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMosaicShadowParams
'Usage

Dim instance As ImGearMosaicShadowParams
public class ImGearMosaicShadowParams
public __gc class ImGearMosaicShadowParams
public ref class ImGearMosaicShadowParams
Example
  • C#
// Applies a mosaic effect to an image.

// Parameter classes for Mosaic method.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();

//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;

// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;

ImGearEffects.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);
  • Visual Basic
' Applies a mosaic effect to an image.

     ' Parameter classes for Mosaic function.
     Dim igMosaicFillParams As New ImGearMosaicFillParams()
     Dim igMosaicCellParams As New ImGearMosaicCellParams()
     Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
     Dim igMosaicShadowParams As New ImGearMosaicShadowParams()

     'Color for fill and border.
     Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
     For i As Integer = 0 To igPixel.ChannelCount - 1
         igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
     Next
     'Set the color to a dark gray based on the bits per channel.

     ' Cell parameters
     igMosaicCellParams.Type = ImGearMosaicType.Cartesian
     igMosaicCellParams.Width = 32
     igMosaicCellParams.Height = 32
     igMosaicCellParams.PolarCenterX = 100
     igMosaicCellParams.PolarCenterY = 100
     ' Fill parameters
     igMosaicFillParams.Color = igPixel
     igMosaicFillParams.Opacity = CSng(0.2)
     ' Border parameters
     igMosaicBorderParams.Width = 0
     igMosaicBorderParams.Height = 0
     igMosaicBorderParams.Color = igPixel
     igMosaicBorderParams.Opacity = CSng(0.3)
     igMosaicBorderParams.Irregularity = 0
     ' Shadow Parameters
     igMosaicShadowParams.Enabled = True
     igMosaicShadowParams.Threshold = 0
     igMosaicShadowParams.Direction = ImGearDirection.SouthEast
     igMosaicShadowParams.HighResolution = False
     igMosaicShadowParams.Intensity = CSng(1)

     ImGearEffects.Mosaic(igRasterPage, igMosaicFillParams, _
igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearMosaicShadowParams

See Also

Reference

ImGearMosaicShadowParams Members
ImageGear.Processing Namespace


%%PageItemTitle%% $$Members$$

ImGearMosaicShadowParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicShadowParams Class

The following tables list the members exposed by ImGearMosaicShadowParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearMosaicShadowParams Constructor | Initializes a new instance of the ImGearMosaicShadowParams class.
Top
Public Fields
 | Name | Description
Public Field | Direction | Location of the light source.
Public Field | Enabled | Enables or disables shadow effect.
Public Field | HighResolution | If this parameter is true then shadow effect is calculated using two neighbor pixels. This decreases 3D effect but gives the image more contrast. If false, three pixels are used for shadow effect.
Public Field | Intensity | Shadow intensity.
Public Field | Threshold | Minimum intensity of the pixel the shadow effect is applied to.
Top
See Also

Reference

ImGearMosaicShadowParams Class
ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearMosaicShadowParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : ImGearMosaicShadowParams Constructor
Initializes a new instance of the ImGearMosaicShadowParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMosaicShadowParams()
public ImGearMosaicShadowParams()
public: ImGearMosaicShadowParams();
public:
ImGearMosaicShadowParams();
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members


%%PageItemTitle%% $$Fields$$

ImGearMosaicShadowParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMosaicShadowParams Class

For a list of all members of this type, see ImGearMosaicShadowParams members.

Public Fields
 | Name | Description
Public Field | Direction | Location of the light source.
Public Field | Enabled | Enables or disables shadow effect.
Public Field | HighResolution | If this parameter is true then shadow effect is calculated using two neighbor pixels. This decreases 3D effect but gives the image more contrast. If false, three pixels are used for shadow effect.
Public Field | Intensity | Shadow intensity.
Public Field | Threshold | Minimum intensity of the pixel the shadow effect is applied to.
Top
See Also

Reference

ImGearMosaicShadowParams Class
ImageGear.Processing Namespace


Direction Field (ImGearMosaicShadowParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : Direction Field
Location of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Direction As ImGearDirection
'Usage

Dim instance As ImGearMosaicShadowParams
Dim value As ImGearDirection

value = instance.Direction

instance.Direction = value
public ImGearDirection Direction
public: ImGearDirection Direction
public:
ImGearDirection Direction

Field Value

ImGearDirection enumeration value.
Remarks
This option lets you specify the location of the light source.
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members
ImGearDirection Enumeration


Enabled Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : Enabled Field
Enables or disables shadow effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enabled As Boolean
'Usage

Dim instance As ImGearMosaicShadowParams
Dim value As Boolean

value = instance.Enabled

instance.Enabled = value
public bool Enabled
public: bool Enabled
public:
bool Enabled

Field Value

Boolean value.
Remarks
This field enables or disables shadow effect.
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members


HighResolution Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : HighResolution Field
If this parameter is true then shadow effect is calculated using two neighbor pixels. This decreases 3D effect but gives the image more contrast. If false, three pixels are used for shadow effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public HighResolution As Boolean
'Usage

Dim instance As ImGearMosaicShadowParams
Dim value As Boolean

value = instance.HighResolution

instance.HighResolution = value
public bool HighResolution
public: bool HighResolution
public:
bool HighResolution

Field Value

Boolean value.
Remarks
If this parameter is true, then the shadow effect is calculated using two neighbor pixels. This decreases the 3D effect, but gives the image more contrast. If this parameter is false, three pixels are used for the shadow effect.
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members


Intensity Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : Intensity Field
Shadow intensity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Intensity As Single
'Usage

Dim instance As ImGearMosaicShadowParams
Dim value As Single

value = instance.Intensity

instance.Intensity = value
public float Intensity
public: float Intensity
public:
float Intensity

Field Value

Must be greater than or equal to zero.
Remarks
This option lets you specify the shadow intensity.
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members


Threshold Field (ImGearMosaicShadowParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearMosaicShadowParams Class : Threshold Field
Minimum intensity of the pixel the shadow effect is applied to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Threshold As Integer
'Usage

Dim instance As ImGearMosaicShadowParams
Dim value As Integer

value = instance.Threshold

instance.Threshold = value
public int Threshold
public: int Threshold
public:
int Threshold

Field Value

Any integer value.
Remarks
This option lets you specify the minimum intensity of the pixel the shadow effect is applied to.
See Also

Reference

ImGearMosaicShadowParams Class
ImGearMosaicShadowParams Members


%%PageItemTitle%%

ImGearPicturizeMatchingMatrix Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMatchingMatrix Class
Matches cell images to fragments of the image to which the Picturize effect will be applied.
Object Model
ImGearPicturizeMatchingMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPicturizeMatchingMatrix
'Usage

Dim instance As ImGearPicturizeMatchingMatrix
public class ImGearPicturizeMatchingMatrix
public __gc class ImGearPicturizeMatchingMatrix
public ref class ImGearPicturizeMatchingMatrix
Remarks
This is an auxiliary class for the ImGearEffects.Picturize method. It matches cell images to fragments of the image to which the Picturize effect will be applied.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPicturizeMatchingMatrix

See Also

Reference

ImGearPicturizeMatchingMatrix Members
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Members$$

ImGearPicturizeMatchingMatrix Class Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMatchingMatrix Class

The following tables list the members exposed by ImGearPicturizeMatchingMatrix.

Public Constructors
 | Name | Description
Public Constructor | ImGearPicturizeMatchingMatrix Constructor | Initializes a new instance of the ImGearPicturizeMatchingMatrix class.
Top
See Also

Reference

ImGearPicturizeMatchingMatrix Class
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%%

ImGearPicturizeMatchingMatrix Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMatchingMatrix Class : ImGearPicturizeMatchingMatrix Constructor
Specifies the preprocessed collection of cell images.
Specifies the settings that control how the cell images are matched to fragments of the source image.
Initializes a new instance of the ImGearPicturizeMatchingMatrix class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal preprocessedCollection As ImGearPicturizePreprocessedCollection, _
   ByVal matchingSettings As ImGearPicturizeMatchingSettings _
)
'Usage

Dim preprocessedCollection As ImGearPicturizePreprocessedCollection
Dim matchingSettings As ImGearPicturizeMatchingSettings

Dim instance As New ImGearPicturizeMatchingMatrix(preprocessedCollection, matchingSettings)
public ImGearPicturizeMatchingMatrix(
   ImGearPicturizePreprocessedCollection preprocessedCollection,
   ImGearPicturizeMatchingSettings matchingSettings
)
public: ImGearPicturizeMatchingMatrix(
   ImGearPicturizePreprocessedCollection* preprocessedCollection,
   ImGearPicturizeMatchingSettings matchingSettings
)
public:
ImGearPicturizeMatchingMatrix(
   ImGearPicturizePreprocessedCollection^ preprocessedCollection,
   ImGearPicturizeMatchingSettings matchingSettings
)

Parameters

preprocessedCollection
Specifies the preprocessed collection of cell images.
matchingSettings
Specifies the settings that control how the cell images are matched to fragments of the source image.

Return Value

The new instance of the ImGearPicturizeMatchingMatrix class.
Remarks
This constructor creates the new instance of the ImGearPicturizeMatchingMatrix class. It matches cell images to fragments of the image to which the Picturize effect will be applied.

Creation of this class serves as the second step in calculation of the Picturize effect. An instance of this class is passed to the ImGearEffects.Picturize method.

See Also

Reference

ImGearPicturizeMatchingMatrix Class
ImGearPicturizeMatchingMatrix Members
Picturize Method
ImGearPicturizeMatchingSettings Structure
ImGearPicturizePreprocessedCollection Class


%%PageItemTitle%%

ImGearPicturizePreprocessedCollection Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizePreprocessedCollection Class
Preprocesses and stores a collection of cell images for Picturize effect.
Object Model
ImGearPicturizePreprocessedCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPicturizePreprocessedCollection
'Usage

Dim instance As ImGearPicturizePreprocessedCollection
public class ImGearPicturizePreprocessedCollection
public __gc class ImGearPicturizePreprocessedCollection
public ref class ImGearPicturizePreprocessedCollection
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPicturizePreprocessedCollection

See Also

Reference

ImGearPicturizePreprocessedCollection Members
ImageGear.Processing Namespace
ImGearPicturizeMatchingMatrix Class
Picturize Method


%%PageItemTitle%% $$Members$$

ImGearPicturizePreprocessedCollection Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizePreprocessedCollection Class

The following tables list the members exposed by ImGearPicturizePreprocessedCollection.

Public Constructors
 | Name | Description
Public Constructor | ImGearPicturizePreprocessedCollection Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | GetMinRepeatCount | Returns the minimal number of occurrences of each tile image in the picturized image, according to the number of available tile images and the number of tiles the image has been divided into.
Top
See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImageGear.Processing Namespace
ImGearPicturizeMatchingMatrix Class
Picturize Method


%%PageItemTitle%%

ImGearPicturizePreprocessedCollection Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizePreprocessedCollection Class : ImGearPicturizePreprocessedCollection Constructor
Overload List
Overload | Description
ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,String[]) | Initializes a new instance of the ImGearPicturizePreprocessedCollection class.
ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,ImGearRasterPage[]) | Initializes a new instance of the ImGearPicturizePreprocessedCollection class.
See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImGearPicturizePreprocessedCollection Members


%%PageItemTitle%%

ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,String[])

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizePreprocessedCollection Class > ImGearPicturizePreprocessedCollection Constructor : ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,String[])
Specifies the image to apply the Picturize effect to.
Specifies the width of cells in the main image that will be replaced with cell images.
Specifies the height of cells in the main image that will be replaced with cell images.
Specifies the list of image file names that will be used for picturizing.
Initializes a new instance of the ImGearPicturizePreprocessedCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mainImage As ImGearRasterPage, _
   ByVal cellWidth As Integer, _
   ByVal cellHeight As Integer, _
   ByVal cellFileNames() As String _
)
'Usage

Dim mainImage As ImGearRasterPage
Dim cellWidth As Integer
Dim cellHeight As Integer
Dim cellFileNames() As String

Dim instance As New ImGearPicturizePreprocessedCollection(mainImage, cellWidth, cellHeight, cellFileNames)
public ImGearPicturizePreprocessedCollection(
   ImGearRasterPage mainImage,
   int cellWidth,
   int cellHeight,
   string[] cellFileNames
)
public: ImGearPicturizePreprocessedCollection(
   ImGearRasterPage* mainImage,
   int cellWidth,
   int cellHeight,
   string*[]* cellFileNames
)
public:
ImGearPicturizePreprocessedCollection(
   ImGearRasterPage^ mainImage,
   int cellWidth,
   int cellHeight,
   array<String^>^ cellFileNames
)

Parameters

mainImage
Specifies the image to apply the Picturize effect to.
cellWidth
Specifies the width of cells in the main image that will be replaced with cell images.
cellHeight
Specifies the height of cells in the main image that will be replaced with cell images.
cellFileNames
Specifies the list of image file names that will be used for picturizing.

Return Value

The new instance of ImGearPicturizePreprocessedCollection class.
Remarks
This constructor creates the new instance of the ImGearPicturizePreprocessedCollection class. It loads a collection of cell images, specified as a list of file names, preprocesses them and stores internally for later use in the ImGearEffects.Picturize method.

Creation of this class serves as the first step in calculation of the Picturize effect. An instance of this class is passed to ImGearPicturizeMatchingMatrix constructor, which in turn is passed to the Picturize method.

See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImGearPicturizePreprocessedCollection Members
Overload List
ImGearPicturizeMatchingMatrix Class
Picturize Method


%%PageItemTitle%%

ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,ImGearRasterPage[])

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizePreprocessedCollection Class > ImGearPicturizePreprocessedCollection Constructor : ImGearPicturizePreprocessedCollection Constructor(ImGearRasterPage,Int32,Int32,ImGearRasterPage[])
Specifies the image to apply the Picturize effect to.
Specifies the width of cells in the main image that will be replaced with cell images.
Specifies the height of cells in the main image that will be replaced with cell images.
Specifies the list of images that will be used for picturizing.
Initializes a new instance of the ImGearPicturizePreprocessedCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mainImage As ImGearRasterPage, _
   ByVal cellWidth As Integer, _
   ByVal cellHeight As Integer, _
   ByVal cellImages() As ImGearRasterPage _
)
'Usage

Dim mainImage As ImGearRasterPage
Dim cellWidth As Integer
Dim cellHeight As Integer
Dim cellImages() As ImGearRasterPage

Dim instance As New ImGearPicturizePreprocessedCollection(mainImage, cellWidth, cellHeight, cellImages)
public ImGearPicturizePreprocessedCollection(
   ImGearRasterPage mainImage,
   int cellWidth,
   int cellHeight,
   ImGearRasterPage[] cellImages
)
public: ImGearPicturizePreprocessedCollection(
   ImGearRasterPage* mainImage,
   int cellWidth,
   int cellHeight,
   ImGearRasterPage*[]* cellImages
)
public:
ImGearPicturizePreprocessedCollection(
   ImGearRasterPage^ mainImage,
   int cellWidth,
   int cellHeight,
   array<ImGearRasterPage^>^ cellImages
)

Parameters

mainImage
Specifies the image to apply the Picturize effect to.
cellWidth
Specifies the width of cells in the main image that will be replaced with cell images.
cellHeight
Specifies the height of cells in the main image that will be replaced with cell images.
cellImages
Specifies the list of images that will be used for picturizing.

Return Value

The new instance of the ImGearPicturizePreprocessedCollection class.
Remarks
This constructor creates the new instance of the ImGearPicturizePreprocessedCollection class. It loads a collection of cell images, specified as a list of ImageGear.Core.ImGearRasterPage objects, preprocesses them and stores internally for later use in the ImGearEffects.Picturize method.

Creation of this class serves as the first step in calculation of the Picturize effect. An instance of this class is passed to ImGearPicturizeMatchingMatrix constructor, which in turn is passed to the Picturize method.

See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImGearPicturizePreprocessedCollection Members
Overload List
ImGearRasterPage Class
ImGearPicturizeMatchingMatrix Class
Picturize Method


%%PageItemTitle%% $$Methods$$

ImGearPicturizePreprocessedCollection Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizePreprocessedCollection Class

For a list of all members of this type, see ImGearPicturizePreprocessedCollection members.

Public Methods
 | Name | Description
Public Method | GetMinRepeatCount | Returns the minimal number of occurrences of each tile image in the picturized image, according to the number of available tile images and the number of tiles the image has been divided into.
Top
See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImageGear.Processing Namespace
ImGearPicturizeMatchingMatrix Class
Picturize Method


GetMinRepeatCount Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizePreprocessedCollection Class : GetMinRepeatCount Method
Returns the minimal number of occurrences of each tile image in the picturized image, according to the number of available tile images and the number of tiles the image has been divided into.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMinRepeatCount() As Integer
'Usage

Dim instance As ImGearPicturizePreprocessedCollection
Dim value As Integer

value = instance.GetMinRepeatCount()
public int GetMinRepeatCount()
public: int GetMinRepeatCount();
public:
int GetMinRepeatCount();

Return Value

Minimal number of occurrences of each tile image in the picturized image.
See Also

Reference

ImGearPicturizePreprocessedCollection Class
ImGearPicturizePreprocessedCollection Members


%%PageItemTitle%%

ImGearPixelateBorderParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateBorderParams Class
Describes border characteristics of the Pixelate operation.
Object Model
ImGearPixelateBorderParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelateBorderParams
'Usage

Dim instance As ImGearPixelateBorderParams
public class ImGearPixelateBorderParams
public __gc class ImGearPixelateBorderParams
public ref class ImGearPixelateBorderParams
Example
  • C#
// Pixelate an image.

// Parameter classes for Pixelate method.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();

ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);

// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;

// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;

ImGearEffects.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);
  • Visual Basic
' Pixelate an image.

' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()

Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)

' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8

' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)

ImGearEffects.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelateBorderParams

See Also

Reference

ImGearPixelateBorderParams Members
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%% $$Members$$

ImGearPixelateBorderParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateBorderParams Class

The following tables list the members exposed by ImGearPixelateBorderParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelateBorderParams Constructor | Initializes a new instance of the ImGearPixelateBorderParams class.
Top
Public Fields
 | Name | Description
Public Field | Color | Border color.
Public Field | Height | Width of the border.
Public Field | Opacity | Border opacity.
Public Field | Width | Height of the border.
Top
See Also

Reference

ImGearPixelateBorderParams Class
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%%

ImGearPixelateBorderParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateBorderParams Class : ImGearPixelateBorderParams Constructor
Initializes a new instance of the ImGearPixelateBorderParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPixelateBorderParams()
public ImGearPixelateBorderParams()
public: ImGearPixelateBorderParams();
public:
ImGearPixelateBorderParams();
See Also

Reference

ImGearPixelateBorderParams Class
ImGearPixelateBorderParams Members


%%PageItemTitle%% $$Fields$$

ImGearPixelateBorderParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateBorderParams Class

For a list of all members of this type, see ImGearPixelateBorderParams members.

Public Fields
 | Name | Description
Public Field | Color | Border color.
Public Field | Height | Width of the border.
Public Field | Opacity | Border opacity.
Public Field | Width | Height of the border.
Top
See Also

Reference

ImGearPixelateBorderParams Class
ImageGear.Processing Namespace
Pixelate Method


Color Field (ImGearPixelateBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateBorderParams Class : Color Field
Border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Color As ImGearPixel
'Usage

Dim instance As ImGearPixelateBorderParams
Dim value As ImGearPixel

value = instance.Color

instance.Color = value
public ImGearPixel Color
public: ImGearPixel* Color
public:
ImGearPixel^ Color

Field Value

ImageGear.Core.ImGearPixel class
Remarks
This option lets you to specify the border color. Color format, that is, color space, channel count and bits per channel must correspond to the DIB color format.
See Also

Reference

ImGearPixelateBorderParams Class
ImGearPixelateBorderParams Members
ImGearPixel Class


Height Field (ImGearPixelateBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateBorderParams Class : Height Field
Width of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearPixelateBorderParams
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Any integer value.
Remarks
This option lets you to specify the width of the border in pixels.
See Also

Reference

ImGearPixelateBorderParams Class
ImGearPixelateBorderParams Members


Opacity Field (ImGearPixelateBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateBorderParams Class : Opacity Field
Border opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Opacity As Single
'Usage

Dim instance As ImGearPixelateBorderParams
Dim value As Single

value = instance.Opacity

instance.Opacity = value
public float Opacity
public: float Opacity
public:
float Opacity

Field Value

Value range is 0...1.
Remarks
This field specifies the border opacity, where 0.0 is transparent and 1.0 is opaque.
See Also

Reference

ImGearPixelateBorderParams Class
ImGearPixelateBorderParams Members


Width Field (ImGearPixelateBorderParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateBorderParams Class : Width Field
Height of the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearPixelateBorderParams
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Any integer value.
Remarks
This field specifies the height of the border in pixels.
See Also

Reference

ImGearPixelateBorderParams Class
ImGearPixelateBorderParams Members


%%PageItemTitle%%

ImGearPixelateCellParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateCellParams Class
Describes cell parameters of the Pixelate operation.
Object Model
ImGearPixelateCellParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelateCellParams
'Usage

Dim instance As ImGearPixelateCellParams
public class ImGearPixelateCellParams
public __gc class ImGearPixelateCellParams
public ref class ImGearPixelateCellParams
Example
  • C#
// Pixelate an image.

// Parameter classes for Pixelate method.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();

ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);

// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;

// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;

ImGearEffects.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);
  • Visual Basic
' Pixelate an image.

' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()

Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)

' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8

' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)

ImGearEffects.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelateCellParams

See Also

Reference

ImGearPixelateCellParams Members
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%% $$Members$$

ImGearPixelateCellParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateCellParams Class

The following tables list the members exposed by ImGearPixelateCellParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelateCellParams Constructor | Initializes a new instance of the ImGearPixelateCellParams class.
Top
Public Fields
 | Name | Description
Public Field | CircleCenterX | X coordinate of the circle center.
Public Field | CircleCenterY | Y coordinate of the circle center.
Public Field | CircleRadius | Circle radius.
Public Field | Height | Height of the cell.
Public Field | RectBoundRadius | Round radius.
Public Field | Type | Type of the cell.
Public Field | Width | Width of the cell.
Top
See Also

Reference

ImGearPixelateCellParams Class
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%%

ImGearPixelateCellParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : ImGearPixelateCellParams Constructor
Initializes a new instance of the ImGearPixelateCellParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPixelateCellParams()
public ImGearPixelateCellParams()
public: ImGearPixelateCellParams();
public:
ImGearPixelateCellParams();
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members


%%PageItemTitle%% $$Fields$$

ImGearPixelateCellParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateCellParams Class

For a list of all members of this type, see ImGearPixelateCellParams members.

Public Fields
 | Name | Description
Public Field | CircleCenterX | X coordinate of the circle center.
Public Field | CircleCenterY | Y coordinate of the circle center.
Public Field | CircleRadius | Circle radius.
Public Field | Height | Height of the cell.
Public Field | RectBoundRadius | Round radius.
Public Field | Type | Type of the cell.
Public Field | Width | Width of the cell.
Top
See Also

Reference

ImGearPixelateCellParams Class
ImageGear.Processing Namespace
Pixelate Method


CircleCenterX Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : CircleCenterX Field
X coordinate of the circle center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CircleCenterX As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.CircleCenterX

instance.CircleCenterX = value
public int CircleCenterX
public: int CircleCenterX
public:
int CircleCenterX

Field Value

Any integer value.
Remarks
This option lets you to specify the X coordinate of the circle center when Type field .
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members
ImGearPixelateCellType Enumeration


CircleCenterY Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : CircleCenterY Field
Y coordinate of the circle center.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CircleCenterY As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.CircleCenterY

instance.CircleCenterY = value
public int CircleCenterY
public: int CircleCenterY
public:
int CircleCenterY

Field Value

Any integer value.
Remarks
This field specifies the Y coordinate of the circle center when Type field.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members
ImGearPixelateCellType Enumeration


CircleRadius Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : CircleRadius Field
Circle radius.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CircleRadius As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.CircleRadius

instance.CircleRadius = value
public int CircleRadius
public: int CircleRadius
public:
int CircleRadius

Field Value

Any integer value.
Remarks
This field specifies the Circle radius when Type field.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members
ImGearPixelateCellType Enumeration


Height Field (ImGearPixelateCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : Height Field
Height of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Height As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.Height

instance.Height = value
public int Height
public: int Height
public:
int Height

Field Value

Any integer value.
Remarks
This option lets you to specify the height of the cell in pixels.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members


RectBoundRadius Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : RectBoundRadius Field
Round radius.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public RectBoundRadius As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.RectBoundRadius

instance.RectBoundRadius = value
public int RectBoundRadius
public: int RectBoundRadius
public:
int RectBoundRadius

Field Value

Any integer value.
Remarks
This option lets you to specify the round radius when Type field.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members
ImGearPixelateCellType Enumeration


Type Field (ImGearPixelateCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : Type Field
Type of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Type As ImGearPixelateCellType
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As ImGearPixelateCellType

value = instance.Type

instance.Type = value
public ImGearPixelateCellType Type
public: ImGearPixelateCellType Type
public:
ImGearPixelateCellType Type

Field Value

ImGearPixelateCellType enumeration value.
Remarks
This option lets you specify the type of the cell. See ImGearPixelateCellType enumeration.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members
ImGearPixelateCellType Enumeration


Width Field (ImGearPixelateCellParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateCellParams Class : Width Field
Width of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Width As Integer
'Usage

Dim instance As ImGearPixelateCellParams
Dim value As Integer

value = instance.Width

instance.Width = value
public int Width
public: int Width
public:
int Width

Field Value

Any integer value.
Remarks
This option lets you specify the width of the cell in pixels.
See Also

Reference

ImGearPixelateCellParams Class
ImGearPixelateCellParams Members


%%PageItemTitle%%

ImGearPixelateFillParams Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateFillParams Class
Describes fill characteristics of the Pixelate operation.
Object Model
ImGearPixelateFillParams Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelateFillParams
'Usage

Dim instance As ImGearPixelateFillParams
public class ImGearPixelateFillParams
public __gc class ImGearPixelateFillParams
public ref class ImGearPixelateFillParams
Example
  • C#
// Pixelate an image.

// Parameter classes for Pixelate method.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();

ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);

// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;

// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;

ImGearEffects.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);
  • Visual Basic
' Pixelate an image.

' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()

Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)

' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8

' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)

ImGearEffects.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelateFillParams

See Also

Reference

ImGearPixelateFillParams Members
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%% $$Members$$

ImGearPixelateFillParams Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateFillParams Class

The following tables list the members exposed by ImGearPixelateFillParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelateFillParams Constructor | Initializes a new instance of the ImGearPixelateFillParams class.
Top
Public Fields
 | Name | Description
Public Field | Color | Fill color.
Public Field | FillMethod | Fill method.
Public Field | Opacity | Opacity of the cell.
Top
See Also

Reference

ImGearPixelateFillParams Class
ImageGear.Processing Namespace
Pixelate Method


%%PageItemTitle%%

ImGearPixelateFillParams Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateFillParams Class : ImGearPixelateFillParams Constructor
Initializes a new instance of the ImGearPixelateFillParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPixelateFillParams()
public ImGearPixelateFillParams()
public: ImGearPixelateFillParams();
public:
ImGearPixelateFillParams();
See Also

Reference

ImGearPixelateFillParams Class
ImGearPixelateFillParams Members


%%PageItemTitle%% $$Fields$$

ImGearPixelateFillParams Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelateFillParams Class

For a list of all members of this type, see ImGearPixelateFillParams members.

Public Fields
 | Name | Description
Public Field | Color | Fill color.
Public Field | FillMethod | Fill method.
Public Field | Opacity | Opacity of the cell.
Top
See Also

Reference

ImGearPixelateFillParams Class
ImageGear.Processing Namespace
Pixelate Method


Color Field (ImGearPixelateFillParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateFillParams Class : Color Field
Fill color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Color As ImGearPixel
'Usage

Dim instance As ImGearPixelateFillParams
Dim value As ImGearPixel

value = instance.Color

instance.Color = value
public ImGearPixel Color
public: ImGearPixel* Color
public:
ImGearPixel^ Color

Field Value

ImageGear.Core.ImGearPixel class
Remarks
This option lets you specify fill color. This parameter is used if FillMethod field is equal to ImGearPixelateFillMethod.Color.
See Also

Reference

ImGearPixelateFillParams Class
ImGearPixelateFillParams Members
ImGearPixel Class


FillMethod Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateFillParams Class : FillMethod Field
Fill method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public FillMethod As ImGearPixelateFillMethod
'Usage

Dim instance As ImGearPixelateFillParams
Dim value As ImGearPixelateFillMethod

value = instance.FillMethod

instance.FillMethod = value
public ImGearPixelateFillMethod FillMethod
public: ImGearPixelateFillMethod FillMethod
public:
ImGearPixelateFillMethod FillMethod

Field Value

ImGearPixelateFillMethod enumeration
Remarks
This field specifies the fill method. See ImGearPixelateFillMethod enumeration for details.
See Also

Reference

ImGearPixelateFillParams Class
ImGearPixelateFillParams Members
ImGearPixelateFillMethod Enumeration


Opacity Field (ImGearPixelateFillParams)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelateFillParams Class : Opacity Field
Opacity of the cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Opacity As Single
'Usage

Dim instance As ImGearPixelateFillParams
Dim value As Single

value = instance.Opacity

instance.Opacity = value
public float Opacity
public: float Opacity
public:
float Opacity

Field Value

Valid range is 0...1.
Remarks
This field specifies the opacity of the cell, where 0.0 is transparent and 1.0 is opaque.
See Also

Reference

ImGearPixelateFillParams Class
ImGearPixelateFillParams Members


%%PageItemTitle%%

ImGearPixelCheckerRedEyeRGB Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerRedEyeRGB Class
Checks the RGB pixel using red-eye detection algorithm.
Object Model
ImGearPixelCheckerRedEyeRGB Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelCheckerRedEyeRGB
   Implements IImGearPixelChecker
'Usage

Dim instance As ImGearPixelCheckerRedEyeRGB
public class ImGearPixelCheckerRedEyeRGB : IImGearPixelChecker
public __gc class ImGearPixelCheckerRedEyeRGB : public IImGearPixelChecker
public ref class ImGearPixelCheckerRedEyeRGB : public IImGearPixelChecker
Remarks
CheckPixel method of this class checks the RGB pixel using red-eye detection algorithm.
Example
  • C#
// Detect the red-eye area around a point and remove the red-eye effect.

// Location of a red-eye, can be obtained by a mouse click by user.
ImGearPoint igPoint = new ImGearPoint(204, 308);
// Detection class for red-eye area, threshold values from 0.5-2.0
ImGearPixelCheckerRedEyeRGB igPixelCheckerRedEyeRGB = new ImGearPixelCheckerRedEyeRGB(0.7);
// Detect the red-eye area around the target point.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB);

// Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearEffects.ProcessArea(igRasterPage,
    new ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5));
  • Visual Basic
' Detect the red-eye area around a point and remove the red-eye effect.

' Location of a red-eye, can be obtained by a mouse click by user.
Dim igPoint As New ImGearPoint(204, 308)
' Detection class for red-eye area, threshold values from 0.5-2.0
Dim igPixelCheckerRedEyeRGB As New ImGearPixelCheckerRedEyeRGB(0.7)
' Detect the red-eye area around the target point.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB)

' Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearEffects.ProcessArea(igRasterPage, New ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5))
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelCheckerRedEyeRGB

See Also

Reference

ImGearPixelCheckerRedEyeRGB Members
ImageGear.Processing Namespace
DetectArea Method
ProcessArea Method


%%PageItemTitle%% $$Members$$

ImGearPixelCheckerRedEyeRGB Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerRedEyeRGB Class

The following tables list the members exposed by ImGearPixelCheckerRedEyeRGB.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelCheckerRedEyeRGB Constructor | Initializes a new instance of the ImGearPixelCheckerRedEyeRGB class.
Top
Public Methods
 | Name | Description
Public Method | CheckPixel | Checks if the pixel belongs to the area.
Top
See Also

Reference

ImGearPixelCheckerRedEyeRGB Class
ImageGear.Processing Namespace
DetectArea Method
ProcessArea Method


%%PageItemTitle%%

ImGearPixelCheckerRedEyeRGB Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelCheckerRedEyeRGB Class : ImGearPixelCheckerRedEyeRGB Constructor
Value in the range 0.5..2 that specifies a part of the red component in the pixel color.
Initializes a new instance of the ImGearPixelCheckerRedEyeRGB class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal threshold As Double _
)
'Usage

Dim threshold As Double

Dim instance As New ImGearPixelCheckerRedEyeRGB(threshold)
public ImGearPixelCheckerRedEyeRGB(
   double threshold
)
public: ImGearPixelCheckerRedEyeRGB(
   double threshold
)
public:
ImGearPixelCheckerRedEyeRGB(
   double threshold
)

Parameters

threshold
Value in the range 0.5..2 that specifies a part of the red component in the pixel color.
See Also

Reference

ImGearPixelCheckerRedEyeRGB Class
ImGearPixelCheckerRedEyeRGB Members


%%PageItemTitle%% $$Methods$$

ImGearPixelCheckerRedEyeRGB Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerRedEyeRGB Class

For a list of all members of this type, see ImGearPixelCheckerRedEyeRGB members.

Public Methods
 | Name | Description
Public Method | CheckPixel | Checks if the pixel belongs to the area.
Top
See Also

Reference

ImGearPixelCheckerRedEyeRGB Class
ImageGear.Processing Namespace
DetectArea Method
ProcessArea Method


CheckPixel Method (ImGearPixelCheckerRedEyeRGB)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelCheckerRedEyeRGB Class : CheckPixel Method
ImageGear.Core.ImGearPixel class object that represents pixel to be tested.
Checks if the pixel belongs to the area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CheckPixel( _
   ByVal pixel As ImGearPixel _
) As Boolean
'Usage

Dim instance As ImGearPixelCheckerRedEyeRGB
Dim pixel As ImGearPixel
Dim value As Boolean

value = instance.CheckPixel(pixel)
public bool CheckPixel(
   ImGearPixel pixel
)
public: bool CheckPixel(
   ImGearPixel* pixel
)
public:
bool CheckPixel(
   ImGearPixel^ pixel
)

Parameters

pixel
ImageGear.Core.ImGearPixel class object that represents pixel to be tested.

Return Value

Boolean value.
Remarks
This method returns true if the pixel does not belong to the area (border found), and false otherwise.
See Also

Reference

ImGearPixelCheckerRedEyeRGB Class
ImGearPixelCheckerRedEyeRGB Members
ImGearPixel Class


%%PageItemTitle%%

ImGearPixelCheckerThreshold Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerThreshold Class
Checks the pixel using the initial pixel and the threshold.
Object Model
ImGearPixelCheckerThreshold Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPixelCheckerThreshold
   Implements IImGearPixelChecker
'Usage

Dim instance As ImGearPixelCheckerThreshold
public class ImGearPixelCheckerThreshold : IImGearPixelChecker
public __gc class ImGearPixelCheckerThreshold : public IImGearPixelChecker
public ref class ImGearPixelCheckerThreshold : public IImGearPixelChecker
Remarks
CheckPixel method of this class checks the pixel using the initial pixel and the threshold. The pixel is supposed to be in the area if the following condition is true for all pixel channels:

pixel[i] >= initialPixel[i] - threshold && pixel[i] <= initialPixel[i] + threshold

Example
  • C#
// Detect an area around a point in an image based upon a base pixel and threshold.

// Top left corner of image
ImGearPoint igPoint = new ImGearPoint(0, 0);
//Get the Pixel currently there.
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// Detection class, threshold is difference in pixel channel values from specified pixel.
ImGearPixelCheckerThreshold igPixelCheckerThreshold = new ImGearPixelCheckerThreshold(igPixel, 100);
// Detect the region around target point within the threshold.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold);

// Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage);
  • Visual Basic
' Detect an area around a point in an image based upon a base pixel and threshold.

' Top left corner of image
Dim igPoint As New ImGearPoint(0, 0)
'Get the Pixel currently there.
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' Detection class, threshold is difference in pixel channel values from specified pixel.
Dim igPixelCheckerThreshold As New ImGearPixelCheckerThreshold(igPixel, 100)
' Detect the region around target point within the threshold.
ImGearEffects.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold)

' Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearPixelCheckerThreshold

See Also

Reference

ImGearPixelCheckerThreshold Members
ImageGear.Processing Namespace
DetectArea Method


%%PageItemTitle%% $$Members$$

ImGearPixelCheckerThreshold Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerThreshold Class

The following tables list the members exposed by ImGearPixelCheckerThreshold.

Public Constructors
 | Name | Description
Public Constructor | ImGearPixelCheckerThreshold Constructor | Initializes a new instance of the ImGearPixelCheckerThreshold class.
Top
Public Methods
 | Name | Description
Public Method | CheckPixel | Checks if the pixel belongs to the area.
Top
See Also

Reference

ImGearPixelCheckerThreshold Class
ImageGear.Processing Namespace
DetectArea Method


%%PageItemTitle%%

ImGearPixelCheckerThreshold Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelCheckerThreshold Class : ImGearPixelCheckerThreshold Constructor
Initial pixel value.
Threshold value.
Initializes a new instance of the ImGearPixelCheckerThreshold class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startPixel As ImGearPixel, _
   ByVal threshold As Integer _
)
'Usage

Dim startPixel As ImGearPixel
Dim threshold As Integer

Dim instance As New ImGearPixelCheckerThreshold(startPixel, threshold)
public ImGearPixelCheckerThreshold(
   ImGearPixel startPixel,
   int threshold
)
public: ImGearPixelCheckerThreshold(
   ImGearPixel* startPixel,
   int threshold
)
public:
ImGearPixelCheckerThreshold(
   ImGearPixel^ startPixel,
   int threshold
)

Parameters

startPixel
Initial pixel value.
threshold
Threshold value.
See Also

Reference

ImGearPixelCheckerThreshold Class
ImGearPixelCheckerThreshold Members
ImGearPixel Class


%%PageItemTitle%% $$Methods$$

ImGearPixelCheckerThreshold Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPixelCheckerThreshold Class

For a list of all members of this type, see ImGearPixelCheckerThreshold members.

Public Methods
 | Name | Description
Public Method | CheckPixel | Checks if the pixel belongs to the area.
Top
See Also

Reference

ImGearPixelCheckerThreshold Class
ImageGear.Processing Namespace
DetectArea Method


CheckPixel Method (ImGearPixelCheckerThreshold)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPixelCheckerThreshold Class : CheckPixel Method
ImageGear.Core.ImGearPixel class object that represents pixel to be tested.
Checks if the pixel belongs to the area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CheckPixel( _
   ByVal pixel As ImGearPixel _
) As Boolean
'Usage

Dim instance As ImGearPixelCheckerThreshold
Dim pixel As ImGearPixel
Dim value As Boolean

value = instance.CheckPixel(pixel)
public bool CheckPixel(
   ImGearPixel pixel
)
public: bool CheckPixel(
   ImGearPixel* pixel
)
public:
bool CheckPixel(
   ImGearPixel^ pixel
)

Parameters

pixel
ImageGear.Core.ImGearPixel class object that represents pixel to be tested.

Return Value

Boolean value.
Remarks
This method returns true if the pixel does not belong to the area (border found), and false otherwise.
See Also

Reference

ImGearPixelCheckerThreshold Class
ImGearPixelCheckerThreshold Members
ImGearPixel Class


%%PageItemTitle%%

ImGearSpotlight Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearSpotlight Class
This class contains parameters of a spotlight that can be used to highlight an image.
Object Model
ImGearSpotlight ClassImGearPixel ClassIImGearPoint Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSpotlight
'Usage

Dim instance As ImGearSpotlight
public class ImGearSpotlight
public __gc class ImGearSpotlight
public ref class ImGearSpotlight
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImGearSpotlight

See Also

Reference

ImGearSpotlight Members
ImageGear.Processing Namespace
Spotlights Method


%%PageItemTitle%% $$Members$$

ImGearSpotlight Class Members
Properties Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearSpotlight Class

The following tables list the members exposed by ImGearSpotlight.

Public Constructors
 | Name | Description
Public Constructor | ImGearSpotlight Constructor | Initializes a new instance of the ImGearSpotlight class.
Top
Public Properties
 | Name | Description
Public Property | BrightnessFactor | Gets or sets a multiplier allowing to highlight the image more, even if the light source is located far from the image border.
Public Property | Color | Gets or sets color of the light source.
Public Property | Description | Gets or sets text description of the spotlight.
Public Property | DirectionAngle | Gets or sets angle that specifies light direction in degrees, clockwise. Angle of 0.0 corresponds to 'North' direction in the image plane.
Public Property | Fade | Gets or sets value that specifies how soon the light fades, depending on the distance from the spotlight. Value of 0 corresponds to no fading, greater values result in sooner fading. Reasonable values are in range 0...4.
Public Property | OpeningAngle | Gets or sets angle that specifies the width of the spotlight, measured between the edges of the light cone.
Public Property | Position | Gets or sets coordinates of the light source.
Public Property | Radius | Gets or sets radius of the spotlight in pixels.
Public Property | Smooth | Gets or sets smoothing width for the light cone. Value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.
Top
Public Methods
 | Name | Description
Public Method | Clone | This method clones ImGearSpotlight class object.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearSpotlight Class
ImageGear.Processing Namespace
Spotlights Method


%%PageItemTitle%%

ImGearSpotlight Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : ImGearSpotlight Constructor
Initializes a new instance of the ImGearSpotlight class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearSpotlight()
public ImGearSpotlight()
public: ImGearSpotlight();
public:
ImGearSpotlight();
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


%%PageItemTitle%% $$Methods$$

ImGearSpotlight Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearSpotlight Class

For a list of all members of this type, see ImGearSpotlight members.

Public Methods
 | Name | Description
Public Method | Clone | This method clones ImGearSpotlight class object.
Public Method | ToString | Converts the value of this instance to its equivalent string representation.
Top
See Also

Reference

ImGearSpotlight Class
ImageGear.Processing Namespace
Spotlights Method


%%PageItemTitle%%

ImGearSpotlight Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : ImGearSpotlight Constructor
Overload List
Overload | Description
ImGearSpotlight Constructor | Initializes a new instance of the ImGearSpotlight class.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Clone Method (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Clone Method
This method clones ImGearSpotlight class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As ImGearSpotlight
Dim value As Object

value = instance.Clone()
public object Clone()
public: Object* Clone();
public:
Object^ Clone();

Return Value

The new instance of ImGearSpotlight class.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


ToString Method (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : ToString Method
Converts the value of this instance to its equivalent string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearSpotlight
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


%%PageItemTitle%% $$Properties$$

ImGearSpotlight Class Properties

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearSpotlight Class

For a list of all members of this type, see ImGearSpotlight members.

Public Properties
 | Name | Description
Public Property | BrightnessFactor | Gets or sets a multiplier allowing to highlight the image more, even if the light source is located far from the image border.
Public Property | Color | Gets or sets color of the light source.
Public Property | Description | Gets or sets text description of the spotlight.
Public Property | DirectionAngle | Gets or sets angle that specifies light direction in degrees, clockwise. Angle of 0.0 corresponds to 'North' direction in the image plane.
Public Property | Fade | Gets or sets value that specifies how soon the light fades, depending on the distance from the spotlight. Value of 0 corresponds to no fading, greater values result in sooner fading. Reasonable values are in range 0...4.
Public Property | OpeningAngle | Gets or sets angle that specifies the width of the spotlight, measured between the edges of the light cone.
Public Property | Position | Gets or sets coordinates of the light source.
Public Property | Radius | Gets or sets radius of the spotlight in pixels.
Public Property | Smooth | Gets or sets smoothing width for the light cone. Value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.
Top
See Also

Reference

ImGearSpotlight Class
ImageGear.Processing Namespace
Spotlights Method


BrightnessFactor Property

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : BrightnessFactor Property
Gets or sets a multiplier allowing to highlight the image more, even if the light source is located far from the image border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BrightnessFactor As Double
'Usage

Dim instance As ImGearSpotlight
Dim value As Double

instance.BrightnessFactor = value

value = instance.BrightnessFactor
public double BrightnessFactor {get; set;}
public: __property double get_BrightnessFactor();
public: __property void set_BrightnessFactor(
   double value
);
public:
property double BrightnessFactor {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Color Property (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Color Property
Gets or sets color of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As ImGearPixel
'Usage

Dim instance As ImGearSpotlight
Dim value As ImGearPixel

instance.Color = value

value = instance.Color
public ImGearPixel Color {get; set;}
public: __property ImGearPixel* get_Color();
public: __property void set_Color(
   ImGearPixel* value
);
public:
property ImGearPixel^ Color {
   ImGearPixel^ get();
   void set (    ImGearPixel^ value);
}

Property Value

ImageGear.Core.ImGearPixel class.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Description Property (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Description Property
Gets or sets text description of the spotlight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As ImGearSpotlight
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


DirectionAngle Property

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : DirectionAngle Property
Gets or sets angle that specifies light direction in degrees, clockwise. Angle of 0.0 corresponds to 'North' direction in the image plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DirectionAngle As Double
'Usage

Dim instance As ImGearSpotlight
Dim value As Double

instance.DirectionAngle = value

value = instance.DirectionAngle
public double DirectionAngle {get; set;}
public: __property double get_DirectionAngle();
public: __property void set_DirectionAngle(
   double value
);
public:
property double DirectionAngle {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
This property specifies the light direction in degrees, clockwise. Angle of 0.0 corresponds to 'North' direction in the image plane.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Fade Property

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Fade Property
Gets or sets value that specifies how soon the light fades, depending on the distance from the spotlight. Value of 0 corresponds to no fading, greater values result in sooner fading. Reasonable values are in range 0...4.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fade As Double
'Usage

Dim instance As ImGearSpotlight
Dim value As Double

instance.Fade = value

value = instance.Fade
public double Fade {get; set;}
public: __property double get_Fade();
public: __property void set_Fade(
   double value
);
public:
property double Fade {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


OpeningAngle Property

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : OpeningAngle Property
Gets or sets angle that specifies the width of the spotlight, measured between the edges of the light cone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpeningAngle As Double
'Usage

Dim instance As ImGearSpotlight
Dim value As Double

instance.OpeningAngle = value

value = instance.OpeningAngle
public double OpeningAngle {get; set;}
public: __property double get_OpeningAngle();
public: __property void set_OpeningAngle(
   double value
);
public:
property double OpeningAngle {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Position Property (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Position Property
Gets or sets coordinates of the light source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Position As IImGearPoint
'Usage

Dim instance As ImGearSpotlight
Dim value As IImGearPoint

instance.Position = value

value = instance.Position
public IImGearPoint Position {get; set;}
public: __property IImGearPoint* get_Position();
public: __property void set_Position(
   IImGearPoint* value
);
public:
property IImGearPoint^ Position {
   IImGearPoint^ get();
   void set (    IImGearPoint^ value);
}

Property Value

ImageGear.Core.ImGearPoint structure.
Remarks
This property represents the coordinates of the light source.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Radius Property (ImGearSpotlight)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Radius Property
Gets or sets radius of the spotlight in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Radius As Integer
'Usage

Dim instance As ImGearSpotlight
Dim value As Integer

instance.Radius = value

value = instance.Radius
public int Radius {get; set;}
public: __property int get_Radius();
public: __property void set_Radius(
   int value
);
public:
property int Radius {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


Smooth Property

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearSpotlight Class : Smooth Property
Gets or sets smoothing width for the light cone. Value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Smooth As Double
'Usage

Dim instance As ImGearSpotlight
Dim value As Double

instance.Smooth = value

value = instance.Smooth
public double Smooth {get; set;}
public: __property double get_Smooth();
public: __property void set_Smooth(
   double value
);
public:
property double Smooth {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearSpotlight Class
ImGearSpotlight Members


%%PageItemTitle%%

ImGearMonochromeFilmPreset Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearMonochromeFilmPreset Enumeration
Identifies preset parameters for the ImGearEffects.MonochromeFilm method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMonochromeFilmPreset
   Inherits System.Enum
'Usage

Dim instance As ImGearMonochromeFilmPreset
public enum ImGearMonochromeFilmPreset : System.Enum
__value public enum ImGearMonochromeFilmPreset : public System.Enum
public enum class ImGearMonochromeFilmPreset : public System.Enum
Members
Member | Value | Description
AgfaPanAPX | 0 | Imitates AgfaPanAPX film.
IIfordDelta | 1 | Imitates IIford Delta film.
IIfordFP4 | 2 | Imitates IIford FP4 film.
KodakTriX | 3 | Imitates Kodak TriX film.
Linear | 4 | Mixes colors linearly with equal weights.
SilverHalide | 5 | Imitates non-sensitized silver halide film. Such film was used in early 1900s. It was mostly sensitive to ultraviolet and blue parts of the light spectrum, much less sensitive to green part, and non-sensitive to yellow and red parts of the spectrum.
Remarks
Members of this enumeration represent different types of monochrome film.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImGearMonochromeFilmPreset

See Also

Reference

ImageGear.Processing Namespace


%%PageItemTitle%%

ImGearPicturizeDistributionSettings Structure
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeDistributionSettings Structure
Stores cell image distribution settings for the Picturize effect.
Object Model
ImGearPicturizeDistributionSettings Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearPicturizeDistributionSettings
   Inherits System.ValueType
'Usage

Dim instance As ImGearPicturizeDistributionSettings
public struct ImGearPicturizeDistributionSettings : System.ValueType
public __value struct ImGearPicturizeDistributionSettings : public System.ValueType
public value class ImGearPicturizeDistributionSettings : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Processing.ImGearPicturizeDistributionSettings

See Also

Reference

ImGearPicturizeDistributionSettings Members
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Members$$

ImGearPicturizeDistributionSettings Structure Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeDistributionSettings Structure

The following tables list the members exposed by ImGearPicturizeDistributionSettings.

Public Fields
 | Name | Description
Public Field | MaxRepeatCount | Specifies how many times a specific tile image may be used in the picturized image.
Top
See Also

Reference

ImGearPicturizeDistributionSettings Structure
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Fields$$

ImGearPicturizeDistributionSettings Structure Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeDistributionSettings Structure

For a list of all members of this type, see ImGearPicturizeDistributionSettings members.

Public Fields
 | Name | Description
Public Field | MaxRepeatCount | Specifies how many times a specific tile image may be used in the picturized image.
Top
See Also

Reference

ImGearPicturizeDistributionSettings Structure
ImageGear.Processing Namespace
Picturize Method


MaxRepeatCount Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeDistributionSettings Structure : MaxRepeatCount Field
Specifies how many times a specific tile image may be used in the picturized image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxRepeatCount As Integer
'Usage

Dim instance As ImGearPicturizeDistributionSettings
Dim value As Integer

value = instance.MaxRepeatCount

instance.MaxRepeatCount = value
public int MaxRepeatCount
public: int MaxRepeatCount
public:
int MaxRepeatCount

Field Value

Any positive integer value.
Remarks
This field specifies how many times a specific tile image may be used in the picturized image.

If collection of cell images is large enough, so that number of cell images is greater than number of cells in the picturized image, set MaxRepeatCount to 1. If you donÒt have enough cell images, set MaxRepeatCount to a greater number to allow using the same cell image several times.

The default value is 1.

See Also

Reference

ImGearPicturizeDistributionSettings Structure
ImGearPicturizeDistributionSettings Members


%%PageItemTitle%%

ImGearPicturizeMatchingSettings Structure
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMatchingSettings Structure
Stores the settings that specify how the ImGearEffects.Picturize method will match cell images to fragments of the source image.
Object Model
ImGearPicturizeMatchingSettings Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearPicturizeMatchingSettings
   Inherits System.ValueType
'Usage

Dim instance As ImGearPicturizeMatchingSettings
public struct ImGearPicturizeMatchingSettings : System.ValueType
public __value struct ImGearPicturizeMatchingSettings : public System.ValueType
public value class ImGearPicturizeMatchingSettings : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Processing.ImGearPicturizeMatchingSettings

See Also

Reference

ImGearPicturizeMatchingSettings Members
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Members$$

ImGearPicturizeMatchingSettings Structure Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMatchingSettings Structure

The following tables list the members exposed by ImGearPicturizeMatchingSettings.

Public Fields
 | Name | Description
Public Field | ColorMatchingFactor | Specifies whether the ImGearEffects.Picturize method shall pay more attention to matching colors, or to matching brightness.
Public Field | CompareSize | Specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.
Top
See Also

Reference

ImGearPicturizeMatchingSettings Structure
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Fields$$

ImGearPicturizeMatchingSettings Structure Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMatchingSettings Structure

For a list of all members of this type, see ImGearPicturizeMatchingSettings members.

Public Fields
 | Name | Description
Public Field | ColorMatchingFactor | Specifies whether the ImGearEffects.Picturize method shall pay more attention to matching colors, or to matching brightness.
Public Field | CompareSize | Specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.
Top
See Also

Reference

ImGearPicturizeMatchingSettings Structure
ImageGear.Processing Namespace
Picturize Method


ColorMatchingFactor Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMatchingSettings Structure : ColorMatchingFactor Field
Specifies whether the ImGearEffects.Picturize method shall pay more attention to matching colors, or to matching brightness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ColorMatchingFactor As Double
'Usage

Dim instance As ImGearPicturizeMatchingSettings
Dim value As Double

value = instance.ColorMatchingFactor

instance.ColorMatchingFactor = value
public double ColorMatchingFactor
public: double ColorMatchingFactor
public:
double ColorMatchingFactor

Field Value

0.0...1.0
Remarks
This field specifies whether the ImGearEffects.Picturize method shall pay more attention to matching colors, or to matching brightness. Smaller values result in better matching brightness, while greater values result in better matching colors.

The default value is 0.0.

See Also

Reference

ImGearPicturizeMatchingSettings Structure
ImGearPicturizeMatchingSettings Members


CompareSize Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMatchingSettings Structure : CompareSize Field
Specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public CompareSize As Integer
'Usage

Dim instance As ImGearPicturizeMatchingSettings
Dim value As Integer

value = instance.CompareSize

instance.CompareSize = value
public int CompareSize
public: int CompareSize
public:
int CompareSize

Field Value

Any positive int value
Remarks
This field specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.

Smaller values result in faster processing, while larger values result in better matching quality, allowing to match finer details. Useful values are in range 2...10; larger values result in significantly slower processing without significant increase in quality.

The default value is 1.

See Also

Reference

ImGearPicturizeMatchingSettings Structure
ImGearPicturizeMatchingSettings Members


%%PageItemTitle%%

ImGearPicturizeMixingSettings Structure
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMixingSettings Structure
Stores the settings that specify how the ImGearEffects.Picturize method can modify cell images for the Picturize effect.
Object Model
ImGearPicturizeMixingSettings Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearPicturizeMixingSettings
   Inherits System.ValueType
'Usage

Dim instance As ImGearPicturizeMixingSettings
public struct ImGearPicturizeMixingSettings : System.ValueType
public __value struct ImGearPicturizeMixingSettings : public System.ValueType
public value class ImGearPicturizeMixingSettings : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Processing.ImGearPicturizeMixingSettings

See Also

Reference

ImGearPicturizeMixingSettings Members
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Members$$

ImGearPicturizeMixingSettings Structure Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMixingSettings Structure

The following tables list the members exposed by ImGearPicturizeMixingSettings.

Public Fields
 | Name | Description
Public Field | AllowBrightnessChange | Specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.
Public Field | AllowColorChange | Specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.
Public Field | AllowPixelsChange | Specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.
Top
See Also

Reference

ImGearPicturizeMixingSettings Structure
ImageGear.Processing Namespace
Picturize Method


%%PageItemTitle%% $$Fields$$

ImGearPicturizeMixingSettings Structure Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : ImGearPicturizeMixingSettings Structure

For a list of all members of this type, see ImGearPicturizeMixingSettings members.

Public Fields
 | Name | Description
Public Field | AllowBrightnessChange | Specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.
Public Field | AllowColorChange | Specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.
Public Field | AllowPixelsChange | Specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.
Top
See Also

Reference

ImGearPicturizeMixingSettings Structure
ImageGear.Processing Namespace
Picturize Method


AllowBrightnessChange Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMixingSettings Structure : AllowBrightnessChange Field
Specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AllowBrightnessChange As Double
'Usage

Dim instance As ImGearPicturizeMixingSettings
Dim value As Double

value = instance.AllowBrightnessChange

instance.AllowBrightnessChange = value
public double AllowBrightnessChange
public: double AllowBrightnessChange
public:
double AllowBrightnessChange

Field Value

0.0...1.0.
Remarks
This field specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve colors of the cell images, while greater values make the picturized image more recognizable.

The default value is 0.0.

See Also

Reference

ImGearPicturizeMixingSettings Structure
ImGearPicturizeMixingSettings Members


AllowColorChange Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMixingSettings Structure : AllowColorChange Field
Specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AllowColorChange As Double
'Usage

Dim instance As ImGearPicturizeMixingSettings
Dim value As Double

value = instance.AllowColorChange

instance.AllowColorChange = value
public double AllowColorChange
public: double AllowColorChange
public:
double AllowColorChange

Field Value

0.0...1.0.
Remarks
This field specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve colors of the cell images, while greater values make the picturized image more recognizable.

The default value is 0.0.

See Also

Reference

ImGearPicturizeMixingSettings Structure
ImGearPicturizeMixingSettings Members


AllowPixelsChange Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > ImGearPicturizeMixingSettings Structure : AllowPixelsChange Field
Specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public AllowPixelsChange As Double
'Usage

Dim instance As ImGearPicturizeMixingSettings
Dim value As Double

value = instance.AllowPixelsChange

instance.AllowPixelsChange = value
public double AllowPixelsChange
public: double AllowPixelsChange
public:
double AllowPixelsChange

Field Value

0.0...1.0.
Remarks
This field specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve details of the cell images, while greater values make the picturized image more recognizable. Usually, setting this parameter to a relatively small value allows to 'develop' details of the picturized image, but does not make any visible changes to the cell images.

The default value is 0.0.

See Also

Reference

ImGearPicturizeMixingSettings Structure
ImGearPicturizeMixingSettings Members


%%PageItemTitle%%

IImGearPixelChecker Interface
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : IImGearPixelChecker Interface
An implementation of this interface is passed to ImGearEffects.DetectArea method.
Object Model
IImGearPixelChecker Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearPixelChecker
'Usage

Dim instance As IImGearPixelChecker
public interface IImGearPixelChecker
public __gc __interface IImGearPixelChecker
public interface class IImGearPixelChecker
Remarks
The interface declares one CheckPixel method that must be implemented by the user.
See Also

Reference

IImGearPixelChecker Members
ImageGear.Processing Namespace
DetectArea Method


%%PageItemTitle%% $$Members$$

IImGearPixelChecker Interface Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : IImGearPixelChecker Interface

The following tables list the members exposed by IImGearPixelChecker.

Public Methods
 | Name | Description
Method | CheckPixel | The method must return true if the pixel does not belong to the area (border found) and false otherwise.
Top
See Also

Reference

IImGearPixelChecker Interface
ImageGear.Processing Namespace
DetectArea Method


%%PageItemTitle%% $$Methods$$

IImGearPixelChecker Interface Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace : IImGearPixelChecker Interface

For a list of all members of this type, see IImGearPixelChecker members.

Public Methods
 | Name | Description
Method | CheckPixel | The method must return true if the pixel does not belong to the area (border found) and false otherwise.
Top
See Also

Reference

IImGearPixelChecker Interface
ImageGear.Processing Namespace
DetectArea Method


CheckPixel Method (IImGearPixelChecker)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing Namespace > IImGearPixelChecker Interface : CheckPixel Method
ImageGear.Core.ImGearPixel class object representing pixel to be tested.
The method must return true if the pixel does not belong to the area (border found) and false otherwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function CheckPixel( _
   ByVal pixel As ImGearPixel _
) As Boolean
'Usage

Dim instance As IImGearPixelChecker
Dim pixel As ImGearPixel
Dim value As Boolean

value = instance.CheckPixel(pixel)
bool CheckPixel(
   ImGearPixel pixel
)
bool CheckPixel(
   ImGearPixel* pixel
)
bool CheckPixel(
   ImGearPixel^ pixel
)

Parameters

pixel
ImageGear.Core.ImGearPixel class object representing pixel to be tested.

Return Value

If the pixel does not belong to the area - true, otherwise - false.
See Also

Reference

IImGearPixelChecker Interface
IImGearPixelChecker Members
ImGearPixel Class


ImageGear.Processing.ImageClean Namespace
Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.Processing.ImageClean Namespace

This namespace contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. It now also includes the ability to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.

Classes
 | Class | Description
Class | ImGearIC | Provides image clean methods for 1-bit document images.
Class | ImGearICBorderOptions | Specifies parameters for ImGearIC.CleanBorders method.
Class | ImGearICDotLineOptions | Specifies parameters for ImGearIC.RemoveDotLines method.
Class | ImGearICLineOptions | Specifies parameters for ImGearIC.RemoveLines method.
Class | ImGearICPunchHoleOptions | Specifies parameters for ImGearIC.RemovePunchHoles method.
Class | ImGearICVerifier | Validates applicability of ImageClean methods to ImGearPage object.
Enumerations
 | Enumeration | Description
Enumeration | ImGearICDirection | This enumeration specifies the types of object orientations used in the ImageClean API.
Enumeration | ImGearICDocumentType | Type of the input document's alignment used for ImGearIC.TextAutoOrientation method.
Enumeration | ImGearICUnits | Type of the units of measure used in ImageClean. Used in the following classes: ImGearICPunchHoleOptions, ImGearICDotLineOptions, and ImGearICLineOptions.
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Processing.ImageClean Namespace Inheritance Hierarchy
ImageGear22.Processing.Advanced Assembly : ImageGear.Processing.ImageClean Namespace
Inheritance Hierarchy
System.Object
ImageGear.Processing.ImageClean.ImGearIC
ImageGear.Processing.ImageClean.ImGearICBorderOptions
ImageGear.Processing.ImageClean.ImGearICDotLineOptions
ImageGear.Processing.ImageClean.ImGearICLineOptions
ImageGear.Processing.ImageClean.ImGearICPunchHoleOptions
ImageGear.Processing.ImageClean.ImGearICVerifier
See Also

Reference

ImageGear22.Processing.Advanced Assembly


%%PageItemTitle%%

ImGearIC Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearIC Class
Provides image clean methods for 1-bit document images.
Object Model
ImGearIC ClassImGearICVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearIC
'Usage

Dim instance As ImGearIC
public sealed class ImGearIC
public __gc __sealed class ImGearIC
public ref class ImGearIC sealed
Remarks
The image clean methods include: check for 'noise' of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. The API also provides methods to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearIC

See Also

Reference

ImGearIC Members
ImageGear.Processing.ImageClean Namespace
ImGearICBorderOptions Class
ImGearICVerifier Class
ImGearICPunchHoleOptions Class
ImGearICDotLineOptions Class
ImGearICLineOptions Class


%%PageItemTitle%% $$Members$$

ImGearIC Class Members
Properties Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearIC Class

The following tables list the members exposed by ImGearIC.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets and validates applicability of ImageClean methods to ImGearPage object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AutoCrop | Detects and crops the white border from the page.
static (Shared in Visual Basic) | CheckForNoise | Checks the black pixels noise on the page.
static (Shared in Visual Basic) | CleanBorders | Detects and removes large black regions located near the borders of the page.
static (Shared in Visual Basic) | InvertBlackImage | Inverts the page if the percentage of black pixels is higher than the specified parameter.
static (Shared in Visual Basic) | InvertWhiteText | Overloaded. Detects and inverts areas of white text on black background.
static (Shared in Visual Basic) | RemoveDotLines | Detects and removes any dotted lines on the page.
static (Shared in Visual Basic) | RemoveLines | Detects and removes horizontal and vertical lines on the page.
static (Shared in Visual Basic) | RemovePunchHoles | Detects and removes any punch holes on the page.
static (Shared in Visual Basic) | TextAutoOrientation | Detects orientation of the page and auto-rotates it.
Top
See Also

Reference

ImGearIC Class
ImageGear.Processing.ImageClean Namespace
ImGearICBorderOptions Class
ImGearICVerifier Class
ImGearICPunchHoleOptions Class
ImGearICDotLineOptions Class
ImGearICLineOptions Class


%%PageItemTitle%% $$Methods$$

ImGearIC Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearIC Class

For a list of all members of this type, see ImGearIC members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AutoCrop | Detects and crops the white border from the page.
static (Shared in Visual Basic) | CheckForNoise | Checks the black pixels noise on the page.
static (Shared in Visual Basic) | CleanBorders | Detects and removes large black regions located near the borders of the page.
static (Shared in Visual Basic) | InvertBlackImage | Inverts the page if the percentage of black pixels is higher than the specified parameter.
static (Shared in Visual Basic) | InvertWhiteText | Overloaded. Detects and inverts areas of white text on black background.
static (Shared in Visual Basic) | RemoveDotLines | Detects and removes any dotted lines on the page.
static (Shared in Visual Basic) | RemoveLines | Detects and removes horizontal and vertical lines on the page.
static (Shared in Visual Basic) | RemovePunchHoles | Detects and removes any punch holes on the page.
static (Shared in Visual Basic) | TextAutoOrientation | Detects orientation of the page and auto-rotates it.
Top
See Also

Reference

ImGearIC Class
ImageGear.Processing.ImageClean Namespace
ImGearICBorderOptions Class
ImGearICVerifier Class
ImGearICPunchHoleOptions Class
ImGearICDotLineOptions Class
ImGearICLineOptions Class


AutoCrop Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : AutoCrop Method
1-bit ImGearPage object to apply the method to.
Detects and crops the white border from the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub AutoCrop( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

ImGearIC.AutoCrop(page)
public static void AutoCrop(
   ImGearPage page
)
public: static void AutoCrop(
   ImGearPage* page
)
public:
static void AutoCrop(
   ImGearPage^ page
)

Parameters

page
1-bit ImGearPage object to apply the method to.
Remarks
This method takes 1-bit ImGearPage and automatically detects and then crops the white borders from all four sides of the page. The page is not resized.
Example
  • C#
// Auto crop the document.
ImGearIC.AutoCrop(igPage);
  • Visual Basic
' Auto crop the document.
ImGearIC.AutoCrop(igPage)
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class


CheckForNoise Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : CheckForNoise Method
1-bit ImGearPage object to apply the method to.
Object size threshold value.
Checks the black pixels noise on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CheckForNoise( _
   ByVal page As ImGearPage, _
   ByVal objectSize As Integer _
) As Integer
'Usage

Dim page As ImGearPage
Dim objectSize As Integer
Dim value As Integer

value = ImGearIC.CheckForNoise(page, objectSize)
public static int CheckForNoise(
   ImGearPage page,
   int objectSize
)
public: static int CheckForNoise(
   ImGearPage* page,
   int objectSize
)
public:
static int CheckForNoise(
   ImGearPage^ page,
   int objectSize
)

Parameters

page
1-bit ImGearPage object to apply the method to.
objectSize
Object size threshold value.

Return Value

Integer The result number of objects.
Remarks
This method takes a 1-bit ImGearPage and a threshold int value specifying an object size and checks the page for the number of objects exceeding the size of the specified threshold value. Object here means a connected group of black pixels. The object size is a diagonal of the minimum circumscribed rectangle that contains the object.

This method can be used to detect blank paper sheets in the scanner tray when the resulting image is almost clear and may contains only several black "noise" pixels.

Example
  • C#
// Check the page for a pixel object exceeding size 12 to see if it is blank or not.
int objectCount = ImGearIC.CheckForNoise(igPage, 12);
  • Visual Basic
' Check the page for a pixel object exceeding size 12 to see if it is blank or not.
Dim objectCount As Integer = ImGearIC.CheckForNoise(igPage, 12)
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class


CleanBorders Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : CleanBorders Method
1-bit ImGearPage object to apply the method to.
Clean borders options.
Detects and removes large black regions located near the borders of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub CleanBorders( _
   ByVal page As ImGearPage, _
   ByVal cleanBorderOptions As ImGearICBorderOptions _
)
'Usage

Dim page As ImGearPage
Dim cleanBorderOptions As ImGearICBorderOptions

ImGearIC.CleanBorders(page, cleanBorderOptions)
public static void CleanBorders(
   ImGearPage page,
   ImGearICBorderOptions cleanBorderOptions
)
public: static void CleanBorders(
   ImGearPage* page,
   ImGearICBorderOptions* cleanBorderOptions
)
public:
static void CleanBorders(
   ImGearPage^ page,
   ImGearICBorderOptions^ cleanBorderOptions
)

Parameters

page
1-bit ImGearPage object to apply the method to.
cleanBorderOptions
Clean borders options.
Remarks
nLeftBorderSize, nRightBorderSize, nTopBorderSize and nBottomBorderSize parameters of ImGearICBorderOptions set maximum size of all borders. It means the pixels that lie outside of the borders will not be deleted. But it doesn't mean that all pixels in the borders will be deleted. nMinLinesNum and nMinLineWidth parameters of ImGearICBorderOptions inform the method which objects in the borders should be deleted - only the black objects that have more than or equal to the number of lines specified with width, not less than specified, will be deleted. As for the left and right borders, objects lines are actually parts of screen lines, but as for top and bottom borders those lines are screen columns.

If cleanBorderOptions parameter is null, then the method automatically detects and removes large black regions near the borders of the page. These black borders can result from scanning an image that was reproduced with a copier onto paper that was larger than the image itself.

Example
  • C#
// Sets options for border cleaning and then applies them.
ImGearICBorderOptions igICBorderOptions = new ImGearICBorderOptions();
igICBorderOptions.nBottomBorderSize = 100;
igICBorderOptions.nLeftBorderSize = 100;
igICBorderOptions.nRightBorderSize = 120;
igICBorderOptions.nTopBorderSize = 100;
igICBorderOptions.nMinLinesNum = 10;
igICBorderOptions.nMinLineWidth = 10;
// Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions);
  • Visual Basic
' Sets options for border cleaning and then applies them.
Dim igICBorderOptions As New ImGearICBorderOptions()
igICBorderOptions.nBottomBorderSize = 100
igICBorderOptions.nLeftBorderSize = 100
igICBorderOptions.nRightBorderSize = 120
igICBorderOptions.nTopBorderSize = 100
igICBorderOptions.nMinLinesNum = 10
igICBorderOptions.nMinLineWidth = 10
' Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions)
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class
ImGearICBorderOptions Class


InvertBlackImage Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : InvertBlackImage Method
1-bit ImGearPage object to apply the method to.
Minimum necessary percentage of black pixels on the image to trigger auto-inversion.
Inverts the page if the percentage of black pixels is higher than the specified parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InvertBlackImage( _
   ByVal page As ImGearPage, _
   ByVal percentOfBlack As Integer _
)
'Usage

Dim page As ImGearPage
Dim percentOfBlack As Integer

ImGearIC.InvertBlackImage(page, percentOfBlack)
public static void InvertBlackImage(
   ImGearPage page,
   int percentOfBlack
)
public: static void InvertBlackImage(
   ImGearPage* page,
   int percentOfBlack
)
public:
static void InvertBlackImage(
   ImGearPage^ page,
   int percentOfBlack
)

Parameters

page
1-bit ImGearPage object to apply the method to.
percentOfBlack
Minimum necessary percentage of black pixels on the image to trigger auto-inversion.
Remarks
Method takes 1-bit ImGearPage and a percent of black pixels' parameter and inverts all the pixel values if the percentage of black pixels is higher than the specified parameter.
Example
  • C#
// Invert the image if over 50% of the pixels are black.
ImGearIC.InvertBlackImage(igPage, 50);
  • Visual Basic
' Invert the image if over 50% of the pixels are black.
ImGearIC.InvertBlackImage(igPage, 50)
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class


InvertWhiteText Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : InvertWhiteText Method
Detects and inverts areas of white text on black background.
Overload List
Overload | Description
InvertWhiteText(ImGearPage,Int32,Int32,Int32) | Detects and inverts areas of white text on black background.
InvertWhiteText(ImGearPage,Int32,Int32,Int32,Int32,Int32,Int32) | Detects and inverts areas of white text on black background.
See Also

Reference

ImGearIC Class
ImGearIC Members


InvertWhiteText(ImGearPage,Int32,Int32,Int32) Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class > InvertWhiteText Method : InvertWhiteText(ImGearPage,Int32,Int32,Int32) Method
1-bit ImGearPage object to apply the method to.
Specifies the minimum width for areas that you would like to invert.
Specifies the minimum height for areas that you would like to invert. For example, if you set minX = 60 and minY = 20, ImageGear will only invert sections of white text on black background that have a minimum width of 60 pixels and a minimum height of 20 pixels.
Specifies the minimum "thickness" of spaces that fall between sections of text that will be inverted. This minimum value indicates those sections of text to be treated as one section based on how close they are to one another. As an example, let's say you have three adjacent sections of white text on black backgrounds that contain the words, "There," "is," and "hope." If "There" and "hope" meet your minimum size requirements they will be inverted. If "is" is below your minimum size requirements, and you have not set minT, "is" will note be inverted, resulting in "There" and "hope" looking normal, while "is" remains white text on black background. To prevent this (if desired), you would need to set minT to a value small enough to include the spaces before and after the word "is." This way, all the words would be treated as one section and inverted together.
Detects and inverts areas of white text on black background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub InvertWhiteText( _
   ByVal page As ImGearPage, _
   ByVal minWidth As Integer, _
   ByVal minHeight As Integer, _
   ByVal minThickness As Integer _
)
'Usage

Dim page As ImGearPage
Dim minWidth As Integer
Dim minHeight As Integer
Dim minThickness As Integer

ImGearIC.InvertWhiteText(page, minWidth, minHeight, minThickness)
public static void InvertWhiteText(
   ImGearPage page,
   int minWidth,
   int minHeight,
   int minThickness
)
public: static void InvertWhiteText(
   ImGearPage* page,
   int minWidth,
   int minHeight,
   int minThickness
)
public:
static void InvertWhiteText(
   ImGearPage^ page,
   int minWidth,
   int minHeight,
   int minThickness
)

Parameters

page
1-bit ImGearPage object to apply the method to.
minWidth
Specifies the minimum width for areas that you would like to invert.
minHeight
Specifies the minimum height for areas that you would like to invert. For example, if you set minX = 60 and minY = 20, ImageGear will only invert sections of white text on black background that have a minimum width of 60 pixels and a minimum height of 20 pixels.
minThickness
Specifies the minimum "thickness" of spaces that fall between sections of text that will be inverted. This minimum value indicates those sections of text to be treated as one section based on how close they are to one another. As an example, let's say you have three adjacent sections of white text on black backgrounds that contain the words, "There," "is," and "hope." If "There" and "hope" meet your minimum size requirements they will be inverted. If "is" is below your minimum size requirements, and you have not set minT, "is" will note be inverted, resulting in "There" and "hope" looking normal, while "is" remains white text on black background. To prevent this (if desired), you would need to set minT to a value small enough to include the spaces before and after the word "is." This way, all the words would be treated as one section and inverted together.
Remarks
This method takes a 1-bit ImGearPage and a set of parameters specifying a minimum width of the region to be considered, a minimum height of the region to be considered, a minimum "thickness" of spaces that fall in between sections of text that will be inverted, and automatically detects areas of white text on black backgrounds, and inverts them so that they become black text on white backgrounds. The letter size means the maximum value of width and height of the letter cell that is the minimum rectangle that completely covers the letter and the argument that sets a size of the maximum border around the letter that will be inverted along with the letter cell.

This method scans your entire image and makes adjustments to all areas of white text on black that fall within the scope of your settings.

Example
  • C#
// Invert sections of white text on black background in the image using
// a minimum height of 10, width of 30, thickness of 10.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10);
  • Visual Basic
' Invert sections of white text on black background in the image using
' a minimum height of 10, width of 30, thickness of 10.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10)
See Also

Reference

ImGearIC Class
ImGearIC Members
Overload List
ImGearPage Class


InvertWhiteText(ImGearPage,Int32,Int32,Int32,Int32,Int32,Int32) Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class > InvertWhiteText Method : InvertWhiteText(ImGearPage,Int32,Int32,Int32,Int32,Int32,Int32) Method
1-bit ImGearPage object to apply the method to.
Specifies the minimum width for areas that you would like to invert.
Specifies the minimum height for areas that you would like to invert. For example, if you set minX = 60 and minY = 20, ImageGear will only invert sections of white text on black background that have a minimum width of 60 pixels and a minimum height of 20 pixels.
Specifies the minimum "thickness" of spaces that fall between sections of text that will be inverted. This minimum value indicates those sections of text to be treated as one section based on how close they are to one another. As an example, let's say you have three adjacent sections of white text on black backgrounds that contain the words, "There," "is," and "hope." If "There" and "hope" meet your minimum size requirements they will be inverted. If "is" is below your minimum size requirements, and you have not set minT, "is" will note be inverted, resulting in "There" and "hope" looking normal, while "is" remains white text on black background. To prevent this (if desired), you would need to set minT to a value small enough to include the spaces before and after the word "is." This way, all the words would be treated as one section and inverted together.
Specifies the minimum size of the white letters to be inverted.
Specifies the maximum size of the white letters to be inverted.
Specifies the size of the maximum border around the letter that will be inverted along with the letter cell. For example, if width and height of the letter cell are 20 and 30 respectively and maxBorder = 10, then the width and the height of the rectangle that will be inverted are 40 (10+20+10) and 50 (10+30+10) respectively. Please be careful when setting this parameter. If it is very large, it is possible that incorrect image areas will be inverted.
Detects and inverts areas of white text on black background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub InvertWhiteText( _
   ByVal page As ImGearPage, _
   ByVal minWidth As Integer, _
   ByVal minHeight As Integer, _
   ByVal minThickness As Integer, _
   ByVal minLetterSize As Integer, _
   ByVal maxLetterSize As Integer, _
   ByVal maxBorderSize As Integer _
)
'Usage

Dim page As ImGearPage
Dim minWidth As Integer
Dim minHeight As Integer
Dim minThickness As Integer
Dim minLetterSize As Integer
Dim maxLetterSize As Integer
Dim maxBorderSize As Integer

ImGearIC.InvertWhiteText(page, minWidth, minHeight, minThickness, minLetterSize, maxLetterSize, maxBorderSize)
public static void InvertWhiteText(
   ImGearPage page,
   int minWidth,
   int minHeight,
   int minThickness,
   int minLetterSize,
   int maxLetterSize,
   int maxBorderSize
)
public: static void InvertWhiteText(
   ImGearPage* page,
   int minWidth,
   int minHeight,
   int minThickness,
   int minLetterSize,
   int maxLetterSize,
   int maxBorderSize
)
public:
static void InvertWhiteText(
   ImGearPage^ page,
   int minWidth,
   int minHeight,
   int minThickness,
   int minLetterSize,
   int maxLetterSize,
   int maxBorderSize
)

Parameters

page
1-bit ImGearPage object to apply the method to.
minWidth
Specifies the minimum width for areas that you would like to invert.
minHeight
Specifies the minimum height for areas that you would like to invert. For example, if you set minX = 60 and minY = 20, ImageGear will only invert sections of white text on black background that have a minimum width of 60 pixels and a minimum height of 20 pixels.
minThickness
Specifies the minimum "thickness" of spaces that fall between sections of text that will be inverted. This minimum value indicates those sections of text to be treated as one section based on how close they are to one another. As an example, let's say you have three adjacent sections of white text on black backgrounds that contain the words, "There," "is," and "hope." If "There" and "hope" meet your minimum size requirements they will be inverted. If "is" is below your minimum size requirements, and you have not set minT, "is" will note be inverted, resulting in "There" and "hope" looking normal, while "is" remains white text on black background. To prevent this (if desired), you would need to set minT to a value small enough to include the spaces before and after the word "is." This way, all the words would be treated as one section and inverted together.
minLetterSize
Specifies the minimum size of the white letters to be inverted.
maxLetterSize
Specifies the maximum size of the white letters to be inverted.
maxBorderSize
Specifies the size of the maximum border around the letter that will be inverted along with the letter cell. For example, if width and height of the letter cell are 20 and 30 respectively and maxBorder = 10, then the width and the height of the rectangle that will be inverted are 40 (10+20+10) and 50 (10+30+10) respectively. Please be careful when setting this parameter. If it is very large, it is possible that incorrect image areas will be inverted.
Remarks
This method takes a 1-bit ImGearPage and a set of parameters specifying a minimum width of the region to be considered, a minimum height of the region to be considered, a minimum "thickness" of spaces that fall in between sections of text that will be inverted, and the minimum and maximum sizes of the white letters to be inverted, and automatically detects areas of white text on black backgrounds, and inverts them so that they become black text on white backgrounds. The letter size means the maximum value of width and height of the letter cell that is the minimum rectangle that completely covers the letter and the argument that sets a size of the maximum border around the letter that will be inverted along with the letter cell.

This method scans your entire image and makes adjustments to all areas of white text on black that fall within the scope of your settings.

Example
  • C#
// Invert sections of white text on black background in the image using
// a minimum height of 10, width of 30, thickness of 10,
// minimum letter size of 10, maximum letter size of 100, and a maximum
// border of 5.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10, 10, 100, 5);
  • Visual Basic
' Invert sections of white text on black background in the image using
' a minimum height of 10, width of 30, thickness of 10,
' minimum letter size of 10, maximum letter size of 100, and a maximum
' border of 5.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10, 10, 100, 5)
See Also

Reference

ImGearIC Class
ImGearIC Members
Overload List
ImGearPage Class


RemoveDotLines Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : RemoveDotLines Method
1-bit ImGearPage object to apply the method to.
Method options.
Detects and removes any dotted lines on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveDotLines( _
   ByVal page As ImGearPage, _
   ByVal options As ImGearICDotLineOptions _
)
'Usage

Dim page As ImGearPage
Dim options As ImGearICDotLineOptions

ImGearIC.RemoveDotLines(page, options)
public static void RemoveDotLines(
   ImGearPage page,
   ImGearICDotLineOptions options
)
public: static void RemoveDotLines(
   ImGearPage* page,
   ImGearICDotLineOptions* options
)
public:
static void RemoveDotLines(
   ImGearPage^ page,
   ImGearICDotLineOptions^ options
)

Parameters

page
1-bit ImGearPage object to apply the method to.
options
Method options.
Remarks
This method automatically detects and removes the dotted lines on the 1-bit scanned image. The method takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and number and diameter of dots.
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class
ImGearICDotLineOptions Class


RemoveLines Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : RemoveLines Method
1-bit ImGearPage object to apply the method to.
Method options.
Detects and removes horizontal and vertical lines on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemoveLines( _
   ByVal page As ImGearPage, _
   ByVal options As ImGearICLineOptions _
)
'Usage

Dim page As ImGearPage
Dim options As ImGearICLineOptions

ImGearIC.RemoveLines(page, options)
public static void RemoveLines(
   ImGearPage page,
   ImGearICLineOptions options
)
public: static void RemoveLines(
   ImGearPage* page,
   ImGearICLineOptions* options
)
public:
static void RemoveLines(
   ImGearPage^ page,
   ImGearICLineOptions^ options
)

Parameters

page
1-bit ImGearPage object to apply the method to.
options
Method options.
Remarks
This method automatically detects and removes the horizontal and vertical lines on the 1-bit scanned image such as frames and tables. The method takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and its parameters.
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class
ImGearICLineOptions Class


RemovePunchHoles Method

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : RemovePunchHoles Method
1-bit ImGearPage object to apply the method to.
Method options.
Detects and removes any punch holes on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RemovePunchHoles( _
   ByVal page As ImGearPage, _
   ByVal options As ImGearICPunchHoleOptions _
)
'Usage

Dim page As ImGearPage
Dim options As ImGearICPunchHoleOptions

ImGearIC.RemovePunchHoles(page, options)
public static void RemovePunchHoles(
   ImGearPage page,
   ImGearICPunchHoleOptions options
)
public: static void RemovePunchHoles(
   ImGearPage* page,
   ImGearICPunchHoleOptions* options
)
public:
static void RemovePunchHoles(
   ImGearPage^ page,
   ImGearICPunchHoleOptions^ options
)

Parameters

page
1-bit ImGearPage object to apply the method to.
options
Method options.
Remarks
This method automatically detects and removes the punch holes on the 1-bit scanned image. It works for most common hole puncher standards including 2, 3, 4 and 5 hole puncher marks. The method takes a 1-bit image page and the set of advanced parameters specifying the location and diameter of punch holes.
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearPage Class
ImGearICPunchHoleOptions Class


TextAutoOrientation Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : TextAutoOrientation Method
1-bit ImGearPage object to apply the method to.
Specifies type of the input document's alignment.
Detects orientation of the page and auto-rotates it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub TextAutoOrientation( _
   ByVal page As ImGearPage, _
   ByVal documentType As ImGearICDocumentType _
)
'Usage

Dim page As ImGearPage
Dim documentType As ImGearICDocumentType

ImGearIC.TextAutoOrientation(page, documentType)
public static void TextAutoOrientation(
   ImGearPage page,
   ImGearICDocumentType documentType
)
public: static void TextAutoOrientation(
   ImGearPage* page,
   ImGearICDocumentType documentType
)
public:
static void TextAutoOrientation(
   ImGearPage^ page,
   ImGearICDocumentType documentType
)

Parameters

page
1-bit ImGearPage object to apply the method to.
documentType
Specifies type of the input document's alignment.
Remarks
Takes 1-bit ImGearPage and the input document's alignment, which is either standard, left aligned or right aligned, and automatically determines what the proper orientation should be and rotates the page to achieve that proper orientation.
Example
  • C#
// Auto Orientate an image of a left-aligned document.
ImGearIC.TextAutoOrientation(igPage, ImGearICDocumentType.LEFT_ALIGNED);
  • Visual Basic
' Auto Orientate an image of a left-aligned document.
ImGearIC.TextAutoOrientation(igPage, ImGearICDocumentType.LEFT_ALIGNED)
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearICDocumentType Enumeration
ImGearPage Class


%%PageItemTitle%% $$Properties$$

ImGearIC Class Properties

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearIC Class

For a list of all members of this type, see ImGearIC members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Verifier | Gets and validates applicability of ImageClean methods to ImGearPage object.
Top
See Also

Reference

ImGearIC Class
ImageGear.Processing.ImageClean Namespace
ImGearICBorderOptions Class
ImGearICVerifier Class
ImGearICPunchHoleOptions Class
ImGearICDotLineOptions Class
ImGearICLineOptions Class


Verifier Property (ImGearIC)
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearIC Class : Verifier Property
Gets and validates applicability of ImageClean methods to ImGearPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Verifier As ImGearICVerifier
'Usage

Dim value As ImGearICVerifier

value = ImGearIC.Verifier
public static ImGearICVerifier Verifier {get;}
public: __property static ImGearICVerifier* get_Verifier();
public:
static property ImGearICVerifier^ Verifier {
   ImGearICVerifier^ get();
}

Property Value

ImGearICVerifier class.
Remarks
This property validates applicability of ImageClean methods to ImGearPage object.
Example
  • C#
if (ImGearIC.Verifier.CanApplyAutoCrop(igPage))
{
    ImGearIC.AutoCrop(igPage);
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyAutoCrop(igPage) Then
    ImGearIC.AutoCrop(igPage)
End If
See Also

Reference

ImGearIC Class
ImGearIC Members
ImGearICVerifier Class


%%PageItemTitle%%

ImGearICBorderOptions Class
Members Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICBorderOptions Class
Specifies parameters for ImGearIC.CleanBorders method.
Object Model
ImGearICBorderOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearICBorderOptions
'Usage

Dim instance As ImGearICBorderOptions
public sealed class ImGearICBorderOptions
public __gc __sealed class ImGearICBorderOptions
public ref class ImGearICBorderOptions sealed
Example
  • C#
// Sets options for border cleaning and then applies them.
ImGearICBorderOptions igICBorderOptions = new ImGearICBorderOptions();
igICBorderOptions.nBottomBorderSize = 100;
igICBorderOptions.nLeftBorderSize = 100;
igICBorderOptions.nRightBorderSize = 120;
igICBorderOptions.nTopBorderSize = 100;
igICBorderOptions.nMinLinesNum = 10;
igICBorderOptions.nMinLineWidth = 10;
// Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions);
  • Visual Basic
' Sets options for border cleaning and then applies them.
Dim igICBorderOptions As New ImGearICBorderOptions()
igICBorderOptions.nBottomBorderSize = 100
igICBorderOptions.nLeftBorderSize = 100
igICBorderOptions.nRightBorderSize = 120
igICBorderOptions.nTopBorderSize = 100
igICBorderOptions.nMinLinesNum = 10
igICBorderOptions.nMinLineWidth = 10
' Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions)
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearICBorderOptions

See Also

Reference

ImGearICBorderOptions Members
ImageGear.Processing.ImageClean Namespace
CleanBorders Method


%%PageItemTitle%% $$Members$$

ImGearICBorderOptions Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICBorderOptions Class

The following tables list the members exposed by ImGearICBorderOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearICBorderOptions Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | nBottomBorderSize | Specifies max size of the bottom border.
Public Field | nLeftBorderSize | Specifies max size of the left border.
Public Field | nMinLinesNum | Specifies min number of lines with width not less than nMinLineWidth in one border block.
Public Field | nMinLineWidth | Specifies min width of lines in one border block.
Public Field | nRightBorderSize | Specifies max size of the right border.
Public Field | nTopBorderSize | Specifies max size of the top border.
Top
See Also

Reference

ImGearICBorderOptions Class
ImageGear.Processing.ImageClean Namespace
CleanBorders Method


%%PageItemTitle%%

ImGearICBorderOptions Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : ImGearICBorderOptions Constructor
Overload List
Overload | Description
ImGearICBorderOptions Constructor() | Initializes a new instance of the ImGearICBorderOptions class.
ImGearICBorderOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Initializes a new instance of the ImGearICBorderOptions class.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members


%%PageItemTitle%%

ImGearICBorderOptions Constructor()

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class > ImGearICBorderOptions Constructor : ImGearICBorderOptions Constructor()
Initializes a new instance of the ImGearICBorderOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearICBorderOptions()
public ImGearICBorderOptions()
public: ImGearICBorderOptions();
public:
ImGearICBorderOptions();
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
Overload List


%%PageItemTitle%%

ImGearICBorderOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class > ImGearICBorderOptions Constructor : ImGearICBorderOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
Max size of the left border.
Max size of the right border.
Max size of the top border.
Max size of bottom border.
Min number of lines with width not less than minLineWidthInBlock in one border block.
Min width of lines in one border block. Those blocks that have not less than minLineCountInBlock number of lines with minLineWidthInBlock width or wider will be removed from image.
Initializes a new instance of the ImGearICBorderOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal maxLeftBorderSize As Integer, _
   ByVal maxRightBorderSize As Integer, _
   ByVal maxTopBorderSize As Integer, _
   ByVal maxBottomBorderSize As Integer, _
   ByVal minLineCountInBlock As Integer, _
   ByVal minLineWidthInBlock As Integer _
)
'Usage

Dim maxLeftBorderSize As Integer
Dim maxRightBorderSize As Integer
Dim maxTopBorderSize As Integer
Dim maxBottomBorderSize As Integer
Dim minLineCountInBlock As Integer
Dim minLineWidthInBlock As Integer

Dim instance As New ImGearICBorderOptions(maxLeftBorderSize, maxRightBorderSize, maxTopBorderSize, maxBottomBorderSize, minLineCountInBlock, minLineWidthInBlock)
public ImGearICBorderOptions(
   int maxLeftBorderSize,
   int maxRightBorderSize,
   int maxTopBorderSize,
   int maxBottomBorderSize,
   int minLineCountInBlock,
   int minLineWidthInBlock
)
public: ImGearICBorderOptions(
   int maxLeftBorderSize,
   int maxRightBorderSize,
   int maxTopBorderSize,
   int maxBottomBorderSize,
   int minLineCountInBlock,
   int minLineWidthInBlock
)
public:
ImGearICBorderOptions(
   int maxLeftBorderSize,
   int maxRightBorderSize,
   int maxTopBorderSize,
   int maxBottomBorderSize,
   int minLineCountInBlock,
   int minLineWidthInBlock
)

Parameters

maxLeftBorderSize
Max size of the left border.
maxRightBorderSize
Max size of the right border.
maxTopBorderSize
Max size of the top border.
maxBottomBorderSize
Max size of bottom border.
minLineCountInBlock
Min number of lines with width not less than minLineWidthInBlock in one border block.
minLineWidthInBlock
Min width of lines in one border block. Those blocks that have not less than minLineCountInBlock number of lines with minLineWidthInBlock width or wider will be removed from image.
Remarks
This constructor creates and initializes an instance of ImGearICBorderOptions class.
Example
  • C#
ImGearICBorderOptions borderOptions = new ImGearICBorderOptions(100, 100, 100, 100, 10, 10);
ImGearIC.CleanBorders(igRasterPage, borderOptions);
  • Visual Basic
Dim borderOptions As ImGearICBorderOptions
borderOptions = New ImGearICBorderOptions(100, 100, 100, 100, 10, 10)
ImGearIC.CleanBorders(igRasterPage, borderOptions)
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
Overload List
CleanBorders Method


%%PageItemTitle%% $$Fields$$

ImGearICBorderOptions Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICBorderOptions Class

For a list of all members of this type, see ImGearICBorderOptions members.

Public Fields
 | Name | Description
Public Field | nBottomBorderSize | Specifies max size of the bottom border.
Public Field | nLeftBorderSize | Specifies max size of the left border.
Public Field | nMinLinesNum | Specifies min number of lines with width not less than nMinLineWidth in one border block.
Public Field | nMinLineWidth | Specifies min width of lines in one border block.
Public Field | nRightBorderSize | Specifies max size of the right border.
Public Field | nTopBorderSize | Specifies max size of the top border.
Top
See Also

Reference

ImGearICBorderOptions Class
ImageGear.Processing.ImageClean Namespace
CleanBorders Method


nBottomBorderSize Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nBottomBorderSize Field
Specifies max size of the bottom border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nBottomBorderSize As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nBottomBorderSize

instance.nBottomBorderSize = value
public int nBottomBorderSize
public: int nBottomBorderSize
public:
int nBottomBorderSize

Field Value

Any integer value.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


nLeftBorderSize Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nLeftBorderSize Field
Specifies max size of the left border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nLeftBorderSize As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nLeftBorderSize

instance.nLeftBorderSize = value
public int nLeftBorderSize
public: int nLeftBorderSize
public:
int nLeftBorderSize

Field Value

Any integer value.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


nMinLinesNum Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nMinLinesNum Field
Specifies min number of lines with width not less than nMinLineWidth in one border block.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nMinLinesNum As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nMinLinesNum

instance.nMinLinesNum = value
public int nMinLinesNum
public: int nMinLinesNum
public:
int nMinLinesNum

Field Value

Any integer value.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


nMinLineWidth Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nMinLineWidth Field
Specifies min width of lines in one border block.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nMinLineWidth As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nMinLineWidth

instance.nMinLineWidth = value
public int nMinLineWidth
public: int nMinLineWidth
public:
int nMinLineWidth

Field Value

Any integer value.
Remarks
Those blocks that have not less than nMinLinesNum number of lines with nMinLineWidth width or wider will be removed from image.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


nRightBorderSize Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nRightBorderSize Field
Specifies max size of the right border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nRightBorderSize As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nRightBorderSize

instance.nRightBorderSize = value
public int nRightBorderSize
public: int nRightBorderSize
public:
int nRightBorderSize

Field Value

Any integer value.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


nTopBorderSize Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICBorderOptions Class : nTopBorderSize Field
Specifies max size of the top border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public nTopBorderSize As Integer
'Usage

Dim instance As ImGearICBorderOptions
Dim value As Integer

value = instance.nTopBorderSize

instance.nTopBorderSize = value
public int nTopBorderSize
public: int nTopBorderSize
public:
int nTopBorderSize

Field Value

Any integer value.
See Also

Reference

ImGearICBorderOptions Class
ImGearICBorderOptions Members
ImGearICBorderOptions Class


%%PageItemTitle%%

ImGearICDotLineOptions Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICDotLineOptions Class
Specifies parameters for ImGearIC.RemoveDotLines method.
Object Model
ImGearICDotLineOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearICDotLineOptions
'Usage

Dim instance As ImGearICDotLineOptions
public sealed class ImGearICDotLineOptions
public __gc __sealed class ImGearICDotLineOptions
public ref class ImGearICDotLineOptions sealed
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearICDotLineOptions

See Also

Reference

ImGearICDotLineOptions Members
ImageGear.Processing.ImageClean Namespace
RemoveDotLines Method
ImGearIC Class


%%PageItemTitle%% $$Members$$

ImGearICDotLineOptions Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICDotLineOptions Class

The following tables list the members exposed by ImGearICDotLineOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearICDotLineOptions Constructor | Initializes a new instance of the ImGearICDotLineOptions class.
Top
Public Fields
 | Name | Description
Public Field | Direction | Direction of lines to detect.
Public Field | MaxDiameter | Maximum size of dot in line, size considered as diameter of respective circle.
Public Field | MinDiameter | Minimum size of dot in a line, size considered as diameter of respective circle.
Public Field | MinNumber | Minimum number of dots in a line.
Public Field | Unit | Dot's size unit of measure.
Top
See Also

Reference

ImGearICDotLineOptions Class
ImageGear.Processing.ImageClean Namespace
RemoveDotLines Method
ImGearIC Class


%%PageItemTitle%%

ImGearICDotLineOptions Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : ImGearICDotLineOptions Constructor
Initializes a new instance of the ImGearICDotLineOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearICDotLineOptions()
public ImGearICDotLineOptions()
public: ImGearICDotLineOptions();
public:
ImGearICDotLineOptions();
See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
RemoveDotLines Method


%%PageItemTitle%% $$Fields$$

ImGearICDotLineOptions Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICDotLineOptions Class

For a list of all members of this type, see ImGearICDotLineOptions members.

Public Fields
 | Name | Description
Public Field | Direction | Direction of lines to detect.
Public Field | MaxDiameter | Maximum size of dot in line, size considered as diameter of respective circle.
Public Field | MinDiameter | Minimum size of dot in a line, size considered as diameter of respective circle.
Public Field | MinNumber | Minimum number of dots in a line.
Public Field | Unit | Dot's size unit of measure.
Top
See Also

Reference

ImGearICDotLineOptions Class
ImageGear.Processing.ImageClean Namespace
RemoveDotLines Method
ImGearIC Class


Direction Field (ImGearICDotLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : Direction Field
Direction of lines to detect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Direction As ImGearICDirection
'Usage

Dim instance As ImGearICDotLineOptions
Dim value As ImGearICDirection

value = instance.Direction

instance.Direction = value
public ImGearICDirection Direction
public: ImGearICDirection Direction
public:
ImGearICDirection Direction

Field Value

ImGearICDirection enumeration.
Remarks
This property specifies the direction of line to be detected.

The default value is ImGearICDirection.HORIZONTAL.

See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
ImGearICDotLineOptions Class
RemoveDotLines Method
ImGearICDirection Enumeration


MaxDiameter Field (ImGearICDotLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : MaxDiameter Field
Maximum size of dot in line, size considered as diameter of respective circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxDiameter As Double
'Usage

Dim instance As ImGearICDotLineOptions
Dim value As Double

value = instance.MaxDiameter

instance.MaxDiameter = value
public double MaxDiameter
public: double MaxDiameter
public:
double MaxDiameter

Field Value

Double.
Remarks
This property specifies the maximum size of dot in line. Size is considered as diameter of respective circle. Unit of measure is set by the Unit property.

The default value is 3 mm.

See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
ImGearICDotLineOptions Class
RemoveDotLines Method


MinDiameter Field (ImGearICDotLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : MinDiameter Field
Minimum size of dot in a line, size considered as diameter of respective circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MinDiameter As Double
'Usage

Dim instance As ImGearICDotLineOptions
Dim value As Double

value = instance.MinDiameter

instance.MinDiameter = value
public double MinDiameter
public: double MinDiameter
public:
double MinDiameter

Field Value

Double.
Remarks
This property specifies the minimum size of dot in line. Size is considered as diameter of respective circle. Unit of measure is set by the Unit property.

The default value is 1 mm.

See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
ImGearICDotLineOptions Class
RemoveDotLines Method


MinNumber Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : MinNumber Field
Minimum number of dots in a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MinNumber As Integer
'Usage

Dim instance As ImGearICDotLineOptions
Dim value As Integer

value = instance.MinNumber

instance.MinNumber = value
public int MinNumber
public: int MinNumber
public:
int MinNumber

Field Value

Int.
Remarks
This property specifies the minimum numbers of dots in a line.

The default value is 4.

See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
ImGearICDotLineOptions Class
RemoveDotLines Method


Unit Field (ImGearICDotLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICDotLineOptions Class : Unit Field
Dot's size unit of measure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Unit As ImGearICUnits
'Usage

Dim instance As ImGearICDotLineOptions
Dim value As ImGearICUnits

value = instance.Unit

instance.Unit = value
public ImGearICUnits Unit
public: ImGearICUnits Unit
public:
ImGearICUnits Unit

Field Value

ImGearICUnits enumeration
Remarks
This property specifies the dot's size unit of measure.

The default value is ImGearICUnits.MM.

See Also

Reference

ImGearICDotLineOptions Class
ImGearICDotLineOptions Members
ImGearICDotLineOptions Class
RemoveDotLines Method
ImGearICUnits Enumeration


%%PageItemTitle%%

ImGearICLineOptions Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICLineOptions Class
Specifies parameters for ImGearIC.RemoveLines method.
Object Model
ImGearICLineOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearICLineOptions
'Usage

Dim instance As ImGearICLineOptions
public sealed class ImGearICLineOptions
public __gc __sealed class ImGearICLineOptions
public ref class ImGearICLineOptions sealed
Remarks
This class specifies parameters for the ImGearIC.RemoveLines method.
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearICLineOptions

See Also

Reference

ImGearICLineOptions Members
ImageGear.Processing.ImageClean Namespace
RemoveLines Method
ImGearIC Class


%%PageItemTitle%% $$Members$$

ImGearICLineOptions Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICLineOptions Class

The following tables list the members exposed by ImGearICLineOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearICLineOptions Constructor | Initializes a new instance of the ImGearICLineOptions class.
Top
Public Fields
 | Name | Description
Public Field | Direction | Direction of lines to detect.
Public Field | MaxBreak | Maximum distance between segments of a broken line.
Public Field | MaxWidth | Maximum width of line segment.
Public Field | MinLength | Minimum length of line segment.
Public Field | Unit | Line's size unit of measure.
Top
See Also

Reference

ImGearICLineOptions Class
ImageGear.Processing.ImageClean Namespace
RemoveLines Method
ImGearIC Class


%%PageItemTitle%%

ImGearICLineOptions Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : ImGearICLineOptions Constructor
Initializes a new instance of the ImGearICLineOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearICLineOptions()
public ImGearICLineOptions()
public: ImGearICLineOptions();
public:
ImGearICLineOptions();
See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method


%%PageItemTitle%% $$Fields$$

ImGearICLineOptions Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICLineOptions Class

For a list of all members of this type, see ImGearICLineOptions members.

Public Fields
 | Name | Description
Public Field | Direction | Direction of lines to detect.
Public Field | MaxBreak | Maximum distance between segments of a broken line.
Public Field | MaxWidth | Maximum width of line segment.
Public Field | MinLength | Minimum length of line segment.
Public Field | Unit | Line's size unit of measure.
Top
See Also

Reference

ImGearICLineOptions Class
ImageGear.Processing.ImageClean Namespace
RemoveLines Method
ImGearIC Class


Direction Field (ImGearICLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : Direction Field
Direction of lines to detect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Direction As ImGearICDirection
'Usage

Dim instance As ImGearICLineOptions
Dim value As ImGearICDirection

value = instance.Direction

instance.Direction = value
public ImGearICDirection Direction
public: ImGearICDirection Direction
public:
ImGearICDirection Direction

Field Value

ImGearICDirection enumeration.
Remarks
This property specifies the direction of line to be detected.

The default value is ImGearICDirection.HORIZONTAL.

See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method
ImGearICLineOptions Class
ImGearICDirection Enumeration


MaxBreak Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : MaxBreak Field
Maximum distance between segments of a broken line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxBreak As Double
'Usage

Dim instance As ImGearICLineOptions
Dim value As Double

value = instance.MaxBreak

instance.MaxBreak = value
public double MaxBreak
public: double MaxBreak
public:
double MaxBreak

Field Value

Double.
Remarks
This property specifies the maximum distance between segments of a broken line. The unit of measure is set by the Unit property.

The default value is 1 mm.

See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method
ImGearICLineOptions Class


MaxWidth Field (ImGearICLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : MaxWidth Field
Maximum width of line segment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxWidth As Double
'Usage

Dim instance As ImGearICLineOptions
Dim value As Double

value = instance.MaxWidth

instance.MaxWidth = value
public double MaxWidth
public: double MaxWidth
public:
double MaxWidth

Field Value

Double.
Remarks
This property specifies the maximum width of a line segment. All lines that exceed this value are ignored. The unit of measure is set by the Unit property.

The default value is 1 mm.

See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method
ImGearICLineOptions Class


MinLength Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : MinLength Field
Minimum length of line segment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MinLength As Double
'Usage

Dim instance As ImGearICLineOptions
Dim value As Double

value = instance.MinLength

instance.MinLength = value
public double MinLength
public: double MinLength
public:
double MinLength

Field Value

Double.
Remarks
This property specifies the minimum length of a line segment. All lines that do not exceed this value are ignored. The unit of measure is set by the Unit property.

The default valuestrong> is 10strong> mm.

See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method
ImGearICLineOptions Class


Unit Field (ImGearICLineOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICLineOptions Class : Unit Field
Line's size unit of measure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Unit As ImGearICUnits
'Usage

Dim instance As ImGearICLineOptions
Dim value As ImGearICUnits

value = instance.Unit

instance.Unit = value
public ImGearICUnits Unit
public: ImGearICUnits Unit
public:
ImGearICUnits Unit

Field Value

ImGearICUnits enumeration
Remarks
This property specifies the line's size unit of measure.

The default value is ImGearICUnits.MM.

See Also

Reference

ImGearICLineOptions Class
ImGearICLineOptions Members
RemoveLines Method
ImGearICLineOptions Class
ImGearICUnits Enumeration


%%PageItemTitle%%

ImGearICPunchHoleOptions Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICPunchHoleOptions Class
Specifies parameters for ImGearIC.RemovePunchHoles method.
Object Model
ImGearICPunchHoleOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearICPunchHoleOptions
'Usage

Dim instance As ImGearICPunchHoleOptions
public sealed class ImGearICPunchHoleOptions
public __gc __sealed class ImGearICPunchHoleOptions
public ref class ImGearICPunchHoleOptions sealed
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearICPunchHoleOptions

See Also

Reference

ImGearICPunchHoleOptions Members
ImageGear.Processing.ImageClean Namespace
RemovePunchHoles Method
ImGearIC Class


%%PageItemTitle%% $$Members$$

ImGearICPunchHoleOptions Class Members
Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICPunchHoleOptions Class

The following tables list the members exposed by ImGearICPunchHoleOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearICPunchHoleOptions Constructor | Initializes a new instance of the ImGearICPunchHoleOptions class.
Top
Public Fields
 | Name | Description
Public Field | Accuracy | Accuracy of the punch hole's detection, measured in percent (%).
Public Field | MaxAspect | Maximum width/height ratio of object dimensions.
Public Field | MaxDiameter | Maximum object size to remove; size considered as diameter respective circle.
Public Field | MinAspect | Minimum width/height ratio of object dimensions.
Public Field | MinDiameter | Minimum object size to remove; size considered as diameter respective circle.
Public Field | Unit | Hole's size unit of measure.
Top
See Also

Reference

ImGearICPunchHoleOptions Class
ImageGear.Processing.ImageClean Namespace
RemovePunchHoles Method
ImGearIC Class


%%PageItemTitle%%

ImGearICPunchHoleOptions Constructor

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : ImGearICPunchHoleOptions Constructor
Initializes a new instance of the ImGearICPunchHoleOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearICPunchHoleOptions()
public ImGearICPunchHoleOptions()
public: ImGearICPunchHoleOptions();
public:
ImGearICPunchHoleOptions();
See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
RemovePunchHoles Method


%%PageItemTitle%% $$Fields$$

ImGearICPunchHoleOptions Class Fields

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICPunchHoleOptions Class

For a list of all members of this type, see ImGearICPunchHoleOptions members.

Public Fields
 | Name | Description
Public Field | Accuracy | Accuracy of the punch hole's detection, measured in percent (%).
Public Field | MaxAspect | Maximum width/height ratio of object dimensions.
Public Field | MaxDiameter | Maximum object size to remove; size considered as diameter respective circle.
Public Field | MinAspect | Minimum width/height ratio of object dimensions.
Public Field | MinDiameter | Minimum object size to remove; size considered as diameter respective circle.
Public Field | Unit | Hole's size unit of measure.
Top
See Also

Reference

ImGearICPunchHoleOptions Class
ImageGear.Processing.ImageClean Namespace
RemovePunchHoles Method
ImGearIC Class


Accuracy Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : Accuracy Field
Accuracy of the punch hole's detection, measured in percent (%).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Accuracy As Integer
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As Integer

value = instance.Accuracy

instance.Accuracy = value
public int Accuracy
public: int Accuracy
public:
int Accuracy

Field Value

int
Remarks
This property specifies the accuracy of the punch hole's detection, measured in percent (%). Default value is 80%.
See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


MaxAspect Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : MaxAspect Field
Maximum width/height ratio of object dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxAspect As Double
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As Double

value = instance.MaxAspect

instance.MaxAspect = value
public double MaxAspect
public: double MaxAspect
public:
double MaxAspect

Field Value

Double.
Remarks
This property specifies the maximum width/height ratio of object dimensions. Can be used to detect non-round holes.

The default value is 1.05.

See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


MaxDiameter Field (ImGearICPunchHoleOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : MaxDiameter Field
Maximum object size to remove; size considered as diameter respective circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MaxDiameter As Double
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As Double

value = instance.MaxDiameter

instance.MaxDiameter = value
public double MaxDiameter
public: double MaxDiameter
public:
double MaxDiameter

Field Value

Double.
Remarks
This property specifies the maximum object size to remove; size considered as diameter respective circle. The Unit of measure is set by the Unit property.

The default value is 8 mm.

See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


MinAspect Field

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : MinAspect Field
Minimum width/height ratio of object dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MinAspect As Double
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As Double

value = instance.MinAspect

instance.MinAspect = value
public double MinAspect
public: double MinAspect
public:
double MinAspect

Field Value

Double.
Remarks
This property specifies the minimum width/height ratio of object dimensions. Can be used to detect non-round holes.

The default value is 0.95.

See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


MinDiameter Field (ImGearICPunchHoleOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : MinDiameter Field
Minimum object size to remove; size considered as diameter respective circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MinDiameter As Double
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As Double

value = instance.MinDiameter

instance.MinDiameter = value
public double MinDiameter
public: double MinDiameter
public:
double MinDiameter

Field Value

Double.
Remarks
This property specifies the minimum object size to remove; size considered as diameter respective circle. The unit of measure is set by the Unit property.

The default value is 4 mm.

See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


Unit Field (ImGearICPunchHoleOptions)

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICPunchHoleOptions Class : Unit Field
Hole's size unit of measure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Unit As ImGearICUnits
'Usage

Dim instance As ImGearICPunchHoleOptions
Dim value As ImGearICUnits

value = instance.Unit

instance.Unit = value
public ImGearICUnits Unit
public: ImGearICUnits Unit
public:
ImGearICUnits Unit

Field Value

ImGearICUnits enumeration
Remarks
This property specifies the hole's size unit of measure.

The default value is ImGearICUnits.MM.

See Also

Reference

ImGearICPunchHoleOptions Class
ImGearICPunchHoleOptions Members
ImGearICPunchHoleOptions Class
RemovePunchHoles Method


%%PageItemTitle%%

ImGearICVerifier Class
Members

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICVerifier Class
Validates applicability of ImageClean methods to ImGearPage object.
Object Model
ImGearICVerifier Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearICVerifier
'Usage

Dim instance As ImGearICVerifier
public sealed class ImGearICVerifier
public __gc __sealed class ImGearICVerifier
public ref class ImGearICVerifier sealed
Inheritance Hierarchy

System.Object
ImageGear.Processing.ImageClean.ImGearICVerifier

See Also

Reference

ImGearICVerifier Members
ImageGear.Processing.ImageClean Namespace
ImGearIC Class
ImGearICBorderOptions Class


%%PageItemTitle%% $$Members$$

ImGearICVerifier Class Members
Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICVerifier Class

The following tables list the members exposed by ImGearICVerifier.

Public Methods
 | Name | Description
Public Method | CanApplyAutoCrop | Checks if ImGearIC.AutoCrop method can be applied to ImGearPage.
Public Method | CanApplyAutoOrient | Checks if ImGearIC.AutoOrient method can be applied to ImGearPage.
Public Method | CanApplyCheckForNoise | Checks if ImGearIC.CheckForNoise method can be applied to ImGearPage.
Public Method | CanApplyCleanBorders | Checks if ImGearIC.CleanBorders method can be applied to ImGearPage.
Public Method | CanApplyInvertBlackImage | Checks if ImGearIC.InvertBlackImagemethod can be applied to ImGearPage.
Public Method | CanApplyInvertWhiteText | Checks if ImGearIC.InvertWhiteTextmethod can be applied to ImGearPage.
Public Method | CanApplyRemoveDotLines | Checks if ImGearIC.RemoveDotLines method can be applied to ImGearPage.
Public Method | CanApplyRemoveLines | Checks if ImGearIC.RemoveLines method can be applied to ImGearPage.
Public Method | CanApplyRemovePunchHoles | Checks if ImGearIC.RemovePunchHoles method can be applied to ImGearPage.
Top
See Also

Reference

ImGearICVerifier Class
ImageGear.Processing.ImageClean Namespace
ImGearIC Class
ImGearICBorderOptions Class


%%PageItemTitle%% $$Methods$$

ImGearICVerifier Class Methods

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICVerifier Class

For a list of all members of this type, see ImGearICVerifier members.

Public Methods
 | Name | Description
Public Method | CanApplyAutoCrop | Checks if ImGearIC.AutoCrop method can be applied to ImGearPage.
Public Method | CanApplyAutoOrient | Checks if ImGearIC.AutoOrient method can be applied to ImGearPage.
Public Method | CanApplyCheckForNoise | Checks if ImGearIC.CheckForNoise method can be applied to ImGearPage.
Public Method | CanApplyCleanBorders | Checks if ImGearIC.CleanBorders method can be applied to ImGearPage.
Public Method | CanApplyInvertBlackImage | Checks if ImGearIC.InvertBlackImagemethod can be applied to ImGearPage.
Public Method | CanApplyInvertWhiteText | Checks if ImGearIC.InvertWhiteTextmethod can be applied to ImGearPage.
Public Method | CanApplyRemoveDotLines | Checks if ImGearIC.RemoveDotLines method can be applied to ImGearPage.
Public Method | CanApplyRemoveLines | Checks if ImGearIC.RemoveLines method can be applied to ImGearPage.
Public Method | CanApplyRemovePunchHoles | Checks if ImGearIC.RemovePunchHoles method can be applied to ImGearPage.
Top
See Also

Reference

ImGearICVerifier Class
ImageGear.Processing.ImageClean Namespace
ImGearIC Class
ImGearICBorderOptions Class


CanApplyAutoCrop Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyAutoCrop Method
ImGearPage object to verify.
Checks if ImGearIC.AutoCrop method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyAutoCrop( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyAutoCrop(page)
public bool CanApplyAutoCrop(
   ImGearPage page
)
public: bool CanApplyAutoCrop(
   ImGearPage* page
)
public:
bool CanApplyAutoCrop(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.AutoCrop method can be applied to the specified page.
False | ImGearIC.AutoCrop method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyAutoCrop(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyAutoCrop(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyAutoOrient Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyAutoOrient Method
ImGearPage object to verify.
Checks if ImGearIC.AutoOrient method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyAutoOrient( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyAutoOrient(page)
public bool CanApplyAutoOrient(
   ImGearPage page
)
public: bool CanApplyAutoOrient(
   ImGearPage* page
)
public:
bool CanApplyAutoOrient(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.TextAutoOrientation method can be applied to the specified page.
False | ImGearIC.TextAutoOrientation method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyAutoOrient(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyAutoOrient(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyCheckForNoise Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyCheckForNoise Method
ImGearPage object to verify.
Checks if ImGearIC.CheckForNoise method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCheckForNoise( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyCheckForNoise(page)
public bool CanApplyCheckForNoise(
   ImGearPage page
)
public: bool CanApplyCheckForNoise(
   ImGearPage* page
)
public:
bool CanApplyCheckForNoise(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.CheckForNoise method can be applied to the specified page.
False | ImGearIC.CheckForNoise method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyCheckForNoise(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyCheckForNoise(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyCleanBorders Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyCleanBorders Method
ImGearPage object to verify.
Checks if ImGearIC.CleanBorders method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyCleanBorders( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyCleanBorders(page)
public bool CanApplyCleanBorders(
   ImGearPage page
)
public: bool CanApplyCleanBorders(
   ImGearPage* page
)
public:
bool CanApplyCleanBorders(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.CleanBorders method can be applied to the specified page.
False | ImGearIC.CleanBorders method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyCleanBorders(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyCleanBorders(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyInvertBlackImage Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyInvertBlackImage Method
ImGearPage object to verify.
Checks if ImGearIC.InvertBlackImagemethod can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInvertBlackImage( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyInvertBlackImage(page)
public bool CanApplyInvertBlackImage(
   ImGearPage page
)
public: bool CanApplyInvertBlackImage(
   ImGearPage* page
)
public:
bool CanApplyInvertBlackImage(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.InvertBlackImage method can be applied to the specified page.
False | ImGearIC.InvertBlackImage method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyInvertBlackImage(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyInvertBlackImage(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyInvertWhiteText Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyInvertWhiteText Method
ImGearPage object to verify.
Checks if ImGearIC.InvertWhiteTextmethod can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyInvertWhiteText( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyInvertWhiteText(page)
public bool CanApplyInvertWhiteText(
   ImGearPage page
)
public: bool CanApplyInvertWhiteText(
   ImGearPage* page
)
public:
bool CanApplyInvertWhiteText(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.InvertWhiteText method can be applied to the specified page.
False | ImGearIC.InvertWhiteText method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyInvertWhiteText(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyInvertWhiteText(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyRemoveDotLines Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyRemoveDotLines Method
ImGearPage object to verify.
Checks if ImGearIC.RemoveDotLines method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRemoveDotLines( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyRemoveDotLines(page)
public bool CanApplyRemoveDotLines(
   ImGearPage page
)
public: bool CanApplyRemoveDotLines(
   ImGearPage* page
)
public:
bool CanApplyRemoveDotLines(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.RemoveDotLines method can be applied to the specified page.
False | ImGearIC.RemoveDotLines method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyRemoveDotLines(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyRemoveDotLines(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyRemoveLines Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyRemoveLines Method
ImGearPage object to verify.
Checks if ImGearIC.RemoveLines method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRemoveLines( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyRemoveLines(page)
public bool CanApplyRemoveLines(
   ImGearPage page
)
public: bool CanApplyRemoveLines(
   ImGearPage* page
)
public:
bool CanApplyRemoveLines(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.RemoveLines method can be applied to the specified page.
False | ImGearIC.RemoveLines method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyRemoveLines(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyRemoveLines(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


CanApplyRemovePunchHoles Method
Example

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace > ImGearICVerifier Class : CanApplyRemovePunchHoles Method
ImGearPage object to verify.
Checks if ImGearIC.RemovePunchHoles method can be applied to ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanApplyRemovePunchHoles( _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim instance As ImGearICVerifier
Dim page As ImGearPage
Dim value As Boolean

value = instance.CanApplyRemovePunchHoles(page)
public bool CanApplyRemovePunchHoles(
   ImGearPage page
)
public: bool CanApplyRemovePunchHoles(
   ImGearPage* page
)
public:
bool CanApplyRemovePunchHoles(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to verify.

Return Value

True | ImGearIC.RemovePunchHoles method can be applied to the specified page.
False | ImGearIC.RemovePunchHoles method cannot be applied to the specified page.
Example
  • C#
if (ImGearIC.Verifier.CanApplyRemovePunchHoles(igPage))
{
    // The IC method can be applied to igPage.
    // Apply it here.
}
  • Visual Basic
If ImGearIC.Verifier.CanApplyRemovePunchHoles(igPage) Then
    ' The IC method can be applied to igPage.
    ' Apply it here.
End If
See Also

Reference

ImGearICVerifier Class
ImGearICVerifier Members
ImGearPage Class


%%PageItemTitle%%

ImGearICDirection Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICDirection Enumeration
This enumeration specifies the types of object orientations used in the ImageClean API.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearICDirection
   Inherits System.Enum
'Usage

Dim instance As ImGearICDirection
public enum ImGearICDirection : System.Enum
__value public enum ImGearICDirection : public System.Enum
public enum class ImGearICDirection : public System.Enum
Members
Member | Value | Description
HORIZONTAL | 1 | Specifies horizontal direction.
VERTICAL | 2 | Specifies vertical direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImageClean.ImGearICDirection

See Also

Reference

ImageGear.Processing.ImageClean Namespace
ImGearICLineOptions Class
ImGearICDotLineOptions Class
RemoveLines Method
RemoveDotLines Method


%%PageItemTitle%%

ImGearICDocumentType Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICDocumentType Enumeration
Type of the input document's alignment used for ImGearIC.TextAutoOrientation method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearICDocumentType
   Inherits System.Enum
'Usage

Dim instance As ImGearICDocumentType
public enum ImGearICDocumentType : System.Enum
__value public enum ImGearICDocumentType : public System.Enum
public enum class ImGearICDocumentType : public System.Enum
Members
Member | Value | Description
LEFT_ALIGNED | 2 | Left aligned document.
RIGHT_ALIGNED | 3 | Right aligned document.
STANDARD | 1 | Document alignment is unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImageClean.ImGearICDocumentType

See Also

Reference

ImageGear.Processing.ImageClean Namespace
TextAutoOrientation Method


%%PageItemTitle%%

ImGearICUnits Enumeration

ImageGear22.Processing.Advanced Assembly > ImageGear.Processing.ImageClean Namespace : ImGearICUnits Enumeration
Type of the units of measure used in ImageClean. Used in the following classes: ImGearICPunchHoleOptions, ImGearICDotLineOptions, and ImGearICLineOptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearICUnits
   Inherits System.Enum
'Usage

Dim instance As ImGearICUnits
public enum ImGearICUnits : System.Enum
__value public enum ImGearICUnits : public System.Enum
public enum class ImGearICUnits : public System.Enum
Members
Member | Value | Description
INCH | 1 | Units set in inches.
MM | 2 | Units set in millimeters.
PIXEL | 0 | Units set in pixels.
Remarks
This enumeration specifies types of the input document's units of measure used in ImageClean.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Processing.ImageClean.ImGearICUnits

See Also

Reference

ImageGear.Processing.ImageClean Namespace
ImGearICDotLineOptions Class
ImGearICLineOptions Class
ImGearICPunchHoleOptions Class
RemoveDotLines Method
RemoveLines Method
RemovePunchHoles Method


ImageGear22.Recognition Assembly
Namespaces
Namespace | Description
ImageGear.Recognition | The ImageGear Recognition namespace API offers a set of objects that provide access to document recognition technology. It enables you to build OCR applications for the Windows .NET development environment.


ImageGear.Recognition Namespace
Inheritance Hierarchy
ImageGear22.Recognition Assembly : ImageGear.Recognition Namespace

The ImageGear Recognition namespace API offers a set of objects that provide access to document recognition technology. It enables you to build OCR applications for the Windows .NET development environment.

Classes
 | Class | Description
Class | ImGearRecAsianSettings | Provides access to settings specific to the ImGearRecModule.ASN (Asian) recognition module.
Class | ImGearRecCheckWordEventArgs | Provides event arguments to event handlers for the CheckWord property event.
Class | ImGearRecCodePageCollection | Collection of ImGearRecCodePage objects (Code Pages for writing recognition output).
Class | ImGearRecDocument | Class that provides a conversion of the recognized data to the specified format.
Class | ImGearRecImage | Image to be recognized, associated with an ImGearRecPage class object and exposed via ImGearRecPage.Image property.
Class | ImGearRecLetter | Represents a single recognized letter, returned as an array by ImGearRecPage.GetLetters method.
Class | ImGearRecModuleCollection | Collection of recognition engine modules, belongs to ImGearRecognition class object.
Class | ImGearRecModuleSettings | Provides access to information and settings for a recognition module.
Class | ImGearRecMORSettings | Provides access to settings specific to the MOR (multi-lingual omnifont recognition) recognition module.
Class | ImGearRecognition | Represents the recognition engine.
Class | ImGearRecOutputFormatCollection | Collection of ImGearRecOutputFormat objects (output formats for writing recognition output).
Class | ImGearRecOutputManager | Provides access to output settings and methods to output recognized data.
Class | ImGearRecPage | Represents a single image imported into the recognition engine.
Class | ImGearRecPDFOutputOptions | Specifies options for creating PDF page from the recognition output.
Class | ImGearRecPreprocessingSettings | Provides access to settings for preprocessing, belongs to ImGearRecognition.
Class | ImGearRecProgressEventArgs | Contains arguments for the ImGearRecognition.Progress event.
Class | ImGearRecRecognitionLanguageEnabled | Provides ability to enable or disable languages for recognition.
Class | ImGearRecRecognitionSettings | Provides the settings that govern the recognition process.
Class | ImGearRecSettingsCollectionObjectBase | Base class for objects that access a Settings Collection.
Class | ImGearRecStatistics | Statistics from recognition processes, exposed via ImGearRecPage.Statistics property.
Class | ImGearRecUDItem | Represents an item (word) in the user dictionary.
Class | ImGearRecUserDictionary | Provides access to the user dictionary used for recognition.
Class | ImGearRecZone | Represents a recognition zone.
Class | ImGearRecZoneCollection | Collection of zones for a page, belongs to ImGearRecPage object.
Structures
 | Structure | Description
Structure | ImGearRecCodePage | Contains information about a Code Page used for writing recognition output.
Structure | ImGearRecOutputFormat | Represents an output format for writing recognition output.
Delegates
 | Delegate | Description
Delegate | ImGearRecCheckWordEventHandler | Event handler for the ImGearRecZone.CheckWord property event.
Delegate | ImGearRecProgressEventHandler | This is the delegate used to pass ImGearRecognition.Progress events on to an application event handler.
Enumerations
 | Enumeration | Description
Enumeration | ImGearRecCheckWordOpinion | Defines opinion values for user-written word checking.
Enumeration | ImGearRecDecompositionMethod | Identifies methods for decomposing the document into zones.
Enumeration | ImGearRecDeskewMode | Identifies image deskewing modes.
Enumeration | ImGearRecDirectTextFormat | Specifies Direct text output formats. These are the formats that are supported by WriteDirectText method.
Enumeration | ImGearRecErrorCodes | Identifies recognition error codes.
Enumeration | ImGearRecFillingMethod | Identifies zone filling methods.
Enumeration | ImGearRecFilter | Identifies character set filters.
Enumeration | ImGearRecFontFlags | Provides character font information.
Enumeration | ImGearRecInvertMode | Identifies image inversion modes.
Enumeration | ImGearRecLanguage | Identifies the different languages supported directly by the Recognition namespace.
Enumeration | ImGearRecLicenseFeature | Identifies public license features.
Enumeration | ImGearRecMakeupInfo | Provides character makeup information.
Enumeration | ImGearRecModule | Identifies the modules of the OmniPage recognition engine.
Enumeration | ImGearRecOrientationMode | Identifies image orientation modes.
Enumeration | ImGearRecOutputCodePageType | Identifies code page categories.
Enumeration | ImGearRecOutputLevel | Identifies pre-defined levels of the format retention for the final output document.
Enumeration | ImGearRecProcess | Identifies processes of the recognition engine.
Enumeration | ImGearRecRecognitionModule | Identifies recognition modules of the OmniPage recognition engine.
Enumeration | ImGearRecReductionMode | Identifies image conversion modes to be applied for conversions from grayscale or 24-bit color image sources.
Enumeration | ImGearRecResEnhancementMode | Determines recognition resolution enhancement mode.
Enumeration | ImGearRecSpaceType | Specifies possible space types.
Enumeration | ImGearRecTradeoff | Tradeoff between accuracy and speed for recognition process.
Enumeration | ImGearRecZoneCheckingFlags | Defines flags for the ImGearRecZone.Checking property.
Enumeration | ImGearRecZoneType | Determines Zone types.
See Also

Reference

ImageGear22.Recognition Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Recognition Namespace Inheritance Hierarchy
ImageGear22.Recognition Assembly : ImageGear.Recognition Namespace
Inheritance Hierarchy
System.Object
ImageGear.Recognition.ImGearRecCodePageCollection
ImageGear.Recognition.ImGearRecLetter
ImageGear.Recognition.ImGearRecModuleSettings
ImageGear.Recognition.ImGearRecOutputFormatCollection
ImageGear.Recognition.ImGearRecPDFOutputOptions
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecAsianSettings
ImageGear.Recognition.ImGearRecDocument
ImageGear.Recognition.ImGearRecImage
ImageGear.Recognition.ImGearRecModuleCollection
ImageGear.Recognition.ImGearRecMORSettings
ImageGear.Recognition.ImGearRecognition
ImageGear.Recognition.ImGearRecOutputManager
ImageGear.Recognition.ImGearRecPage
ImageGear.Recognition.ImGearRecPreprocessingSettings
ImageGear.Recognition.ImGearRecRecognitionLanguageEnabled
ImageGear.Recognition.ImGearRecRecognitionSettings
ImageGear.Recognition.ImGearRecStatistics
ImageGear.Recognition.ImGearRecUserDictionary
ImageGear.Recognition.ImGearRecZoneCollection
ImageGear.Recognition.ImGearRecUDItem
ImageGear.Recognition.ImGearRecZone
System.EventArgs
ImageGear.Recognition.ImGearRecCheckWordEventArgs
ImageGear.Recognition.ImGearRecProgressEventArgs
System.ValueType
ImageGear.Recognition.ImGearRecCodePage
ImageGear.Recognition.ImGearRecOutputFormat
See Also

Reference

ImageGear22.Recognition Assembly


%%PageItemTitle%%

ImGearRecAsianSettings Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecAsianSettings Class
Provides access to settings specific to the ImGearRecModule.ASN (Asian) recognition module.
Object Model
ImGearRecAsianSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecAsianSettings
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecAsianSettings
public sealed class ImGearRecAsianSettings : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecAsianSettings : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecAsianSettings sealed : public ImGearRecSettingsCollectionObjectBase
Remarks

This object provides access to settings specific to the ImGearRecModule.ASN (Asian) recognition module.

Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecAsianSettings

See Also

Reference

ImGearRecAsianSettings Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecAsianSettings Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecAsianSettings Class

The following tables list the members exposed by ImGearRecAsianSettings.

Public Properties
 | Name | Description
Public Property | AllowFullWidthLatinCharacters | Gets or sets a value indicating whether to allow full width Latin characters in the results of Asian text recognition. If false, full width Latin characters will be converted to their half width counterparts.
Public Property | AllowVerticalPunctuation | Gets or sets a value indicating whether to allow vertical punctuation in the results of Asian text recognition. If false, vertical punctuation marks will be replaced with their horizontal counterparts.
Public Property | IgnoreAsianTextForDeskew | Gets or sets a value indicating whether to ignore Asian text during the deskew process of the automatic Deskew method.
Public Property | IgnoreAsianTextForRotation | Gets or sets a value indicating whether to ignore Asian text during the rotation process of the automatic Rotate method.
Public Property | UseFullCharacterSet | Gets or sets a value indicating whether to use the full recognizable character set.
Top
See Also

Reference

ImGearRecAsianSettings Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecAsianSettings Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecAsianSettings Class

For a list of all members of this type, see ImGearRecAsianSettings members.

Public Properties
 | Name | Description
Public Property | AllowFullWidthLatinCharacters | Gets or sets a value indicating whether to allow full width Latin characters in the results of Asian text recognition. If false, full width Latin characters will be converted to their half width counterparts.
Public Property | AllowVerticalPunctuation | Gets or sets a value indicating whether to allow vertical punctuation in the results of Asian text recognition. If false, vertical punctuation marks will be replaced with their horizontal counterparts.
Public Property | IgnoreAsianTextForDeskew | Gets or sets a value indicating whether to ignore Asian text during the deskew process of the automatic Deskew method.
Public Property | IgnoreAsianTextForRotation | Gets or sets a value indicating whether to ignore Asian text during the rotation process of the automatic Rotate method.
Public Property | UseFullCharacterSet | Gets or sets a value indicating whether to use the full recognizable character set.
Top
See Also

Reference

ImGearRecAsianSettings Class
ImageGear.Recognition Namespace


AllowFullWidthLatinCharacters Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecAsianSettings Class : AllowFullWidthLatinCharacters Property
Gets or sets a value indicating whether to allow full width Latin characters in the results of Asian text recognition. If false, full width Latin characters will be converted to their half width counterparts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowFullWidthLatinCharacters As Boolean
'Usage

Dim instance As ImGearRecAsianSettings
Dim value As Boolean

instance.AllowFullWidthLatinCharacters = value

value = instance.AllowFullWidthLatinCharacters
public bool AllowFullWidthLatinCharacters {get; set;}
public: __property bool get_AllowFullWidthLatinCharacters();
public: __property void set_AllowFullWidthLatinCharacters(
   bool value
);
public:
property bool AllowFullWidthLatinCharacters {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

ImGearRecAsianSettings Class
ImGearRecAsianSettings Members


AllowVerticalPunctuation Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecAsianSettings Class : AllowVerticalPunctuation Property
Gets or sets a value indicating whether to allow vertical punctuation in the results of Asian text recognition. If false, vertical punctuation marks will be replaced with their horizontal counterparts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowVerticalPunctuation As Boolean
'Usage

Dim instance As ImGearRecAsianSettings
Dim value As Boolean

instance.AllowVerticalPunctuation = value

value = instance.AllowVerticalPunctuation
public bool AllowVerticalPunctuation {get; set;}
public: __property bool get_AllowVerticalPunctuation();
public: __property void set_AllowVerticalPunctuation(
   bool value
);
public:
property bool AllowVerticalPunctuation {
   bool get();
   void set (    bool value);
}
Remarks

In Asian scripts, the positions of punctuation marks are all rotated 90 degrees when switching between horizontal and vertical text.

The default value is false.

See Also

Reference

ImGearRecAsianSettings Class
ImGearRecAsianSettings Members


IgnoreAsianTextForDeskew Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecAsianSettings Class : IgnoreAsianTextForDeskew Property
Gets or sets a value indicating whether to ignore Asian text during the deskew process of the automatic Deskew method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreAsianTextForDeskew As Boolean
'Usage

Dim instance As ImGearRecAsianSettings
Dim value As Boolean

instance.IgnoreAsianTextForDeskew = value

value = instance.IgnoreAsianTextForDeskew
public bool IgnoreAsianTextForDeskew {get; set;}
public: __property bool get_IgnoreAsianTextForDeskew();
public: __property void set_IgnoreAsianTextForDeskew(
   bool value
);
public:
property bool IgnoreAsianTextForDeskew {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

See Also

Reference

ImGearRecAsianSettings Class
ImGearRecAsianSettings Members


IgnoreAsianTextForRotation Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecAsianSettings Class : IgnoreAsianTextForRotation Property
Gets or sets a value indicating whether to ignore Asian text during the rotation process of the automatic Rotate method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreAsianTextForRotation As Boolean
'Usage

Dim instance As ImGearRecAsianSettings
Dim value As Boolean

instance.IgnoreAsianTextForRotation = value

value = instance.IgnoreAsianTextForRotation
public bool IgnoreAsianTextForRotation {get; set;}
public: __property bool get_IgnoreAsianTextForRotation();
public: __property void set_IgnoreAsianTextForRotation(
   bool value
);
public:
property bool IgnoreAsianTextForRotation {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

ImGearRecAsianSettings Class
ImGearRecAsianSettings Members


UseFullCharacterSet Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecAsianSettings Class : UseFullCharacterSet Property
Gets or sets a value indicating whether to use the full recognizable character set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseFullCharacterSet As Boolean
'Usage

Dim instance As ImGearRecAsianSettings
Dim value As Boolean

instance.UseFullCharacterSet = value

value = instance.UseFullCharacterSet
public bool UseFullCharacterSet {get; set;}
public: __property bool get_UseFullCharacterSet();
public: __property void set_UseFullCharacterSet(
   bool value
);
public:
property bool UseFullCharacterSet {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

ImGearRecAsianSettings Class
ImGearRecAsianSettings Members


%%PageItemTitle%%

ImGearRecCheckWordEventArgs Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCheckWordEventArgs Class
Provides event arguments to event handlers for the CheckWord property event.
Object Model
ImGearRecCheckWordEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This class is deprecated and will be removed from the public API in a future release.")>
Public NotInheritable Class ImGearRecCheckWordEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearRecCheckWordEventArgs
[Obsolete("This class is deprecated and will be removed from the public API in a future release.")]
public sealed class ImGearRecCheckWordEventArgs : System.EventArgs
[Obsolete("This class is deprecated and will be removed from the public API in a future release.")]
public __gc __sealed class ImGearRecCheckWordEventArgs : public System.EventArgs
[Obsolete("This class is deprecated and will be removed from the public API in a future release.")]
public ref class ImGearRecCheckWordEventArgs sealed : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Recognition.ImGearRecCheckWordEventArgs

See Also

Reference

ImGearRecCheckWordEventArgs Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecCheckWordEventArgs Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCheckWordEventArgs Class

The following tables list the members exposed by ImGearRecCheckWordEventArgs.

Public Properties
 | Name | Description
Public Property | CheckWord | Gets word to be checked.
Public Property | Opinion | Gets or sets application's opinion of the word.
Top
See Also

Reference

ImGearRecCheckWordEventArgs Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecCheckWordEventArgs Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCheckWordEventArgs Class

For a list of all members of this type, see ImGearRecCheckWordEventArgs members.

Public Properties
 | Name | Description
Public Property | CheckWord | Gets word to be checked.
Public Property | Opinion | Gets or sets application's opinion of the word.
Top
See Also

Reference

ImGearRecCheckWordEventArgs Class
ImageGear.Recognition Namespace


CheckWord Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCheckWordEventArgs Class : CheckWord Property
Gets word to be checked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CheckWord As String
'Usage

Dim instance As ImGearRecCheckWordEventArgs
Dim value As String

value = instance.CheckWord
public string CheckWord {get;}
public: __property string* get_CheckWord();
public:
property String^ CheckWord {
   String^ get();
}

Property Value

String value.
Remarks
The recognition engine supplies potential recognized words to the application event handler, and the event handler returns its opinion of the probability of the given word being acceptable.
See Also

Reference

ImGearRecCheckWordEventArgs Class
ImGearRecCheckWordEventArgs Members


Opinion Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCheckWordEventArgs Class : Opinion Property
Gets or sets application's opinion of the word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opinion As ImGearRecCheckWordOpinion
'Usage

Dim instance As ImGearRecCheckWordEventArgs
Dim value As ImGearRecCheckWordOpinion

instance.Opinion = value

value = instance.Opinion
public ImGearRecCheckWordOpinion Opinion {get; set;}
public: __property ImGearRecCheckWordOpinion get_Opinion();
public: __property void set_Opinion(
   ImGearRecCheckWordOpinion value
);
public:
property ImGearRecCheckWordOpinion Opinion {
   ImGearRecCheckWordOpinion get();
   void set (    ImGearRecCheckWordOpinion value);
}

Property Value

ImGearRecCheckWordOpinion enumeration value.
Remarks
Returned opinion of the word to be checked. The recognition engine supplies potential recognized words to the application event handler, and the event handler returns its opinion of the probability of the given word being acceptable.
See Also

Reference

ImGearRecCheckWordEventArgs Class
ImGearRecCheckWordEventArgs Members
ImGearRecCheckWordOpinion Enumeration


%%PageItemTitle%%

ImGearRecCodePageCollection Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePageCollection Class
Collection of ImGearRecCodePage objects (Code Pages for writing recognition output).
Object Model
ImGearRecCodePageCollection ClassImGearRecCodePage Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearRecCodePageCollection
'Usage

Dim instance As ImGearRecCodePageCollection
[DefaultMember("Item")]
public sealed class ImGearRecCodePageCollection
[DefaultMember("Item")]
public __gc __sealed class ImGearRecCodePageCollection
[DefaultMember("Item")]
public ref class ImGearRecCodePageCollection sealed
Remarks
Collection of ImGearRecCodePage objects (Code Pages for writing recognition output). Note: The Code Pages are either hard-coded in the Recognition engine (Code Page 437, Roman 8, Greek-ELOT, Greek-MEMOTEK, all the supported Windows Code Pages and the 16-bit UNICODE and WordPerfect) or they are defined in Code Page Definition files, *.SET. The Recognition engine is shipped with a Code Page Definition file called RECOGN.SET.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecCodePageCollection

See Also

Reference

ImGearRecCodePageCollection Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecCodePageCollection Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePageCollection Class

The following tables list the members exposed by ImGearRecCodePageCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets total number of available Code Pages.
Public Property | Item | Provides information about a Code Page.
Top
See Also

Reference

ImGearRecCodePageCollection Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecCodePageCollection Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePageCollection Class

For a list of all members of this type, see ImGearRecCodePageCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets total number of available Code Pages.
Public Property | Item | Provides information about a Code Page.
Top
See Also

Reference

ImGearRecCodePageCollection Class
ImageGear.Recognition Namespace


Count Property (ImGearRecCodePageCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCodePageCollection Class : Count Property
Gets total number of available Code Pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearRecCodePageCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecCodePageCollection Class
ImGearRecCodePageCollection Members


Item Property (ImGearRecCodePageCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCodePageCollection Class : Item Property
Index of the Code Page (from 0 to Count - 1).
Provides information about a Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ImGearRecCodePage
'Usage

Dim instance As ImGearRecCodePageCollection
Dim index As Integer
Dim value As ImGearRecCodePage

value = instance.Item(index)
public ImGearRecCodePage this[
   int index
]; {get;}
public: __property ImGearRecCodePage get_Item   int index
;
public:
property ImGearRecCodePage default [int] {
   ImGearRecCodePage get(int index);
}

Parameters

index
Index of the Code Page (from 0 to Count - 1).

Property Value

ImGearRecCodePage structure.
Remarks
This property provides access to an ImGearRecCodePage structure object for a particular Code Page. This object can be used to retrieve information about the Code Page.
See Also

Reference

ImGearRecCodePageCollection Class
ImGearRecCodePageCollection Members
ImGearRecCodePage Structure


%%PageItemTitle%%

ImGearRecDocument Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDocument Class
Class that provides a conversion of the recognized data to the specified format.
Object Model
ImGearRecDocument ClassImGearRecDocument ClassImGearRecDocument Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecDocument
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecDocument
public sealed class ImGearRecDocument : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecDocument : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecDocument sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
Note: This class requires ImGearRecLicenseFeature.FormattedOutput feature to be enabled.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecDocument

See Also

Reference

ImGearRecDocument Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecDocument Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDocument Class

The following tables list the members exposed by ImGearRecDocument.

Public Properties
 | Name | Description
Public Property | PageCount | Gets the page count in the document.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | This method has been deprecated. Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Public Method | DeletePage | Removes a page from the document.
Public Method | Dispose | Frees all data associated with this object.
Public Method | InsertPage | Inserts a page to the document.
Public Method | MovePage | Changes the index of a page in the document.
static (Shared in Visual Basic) | Open | This method has been deprecated. Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Public Method | Save | Saves the document to the specified data file in the native Nuance format. The document can be opened later using the ImGearRecOutputManager.OpenDocument method.
Public Method | UpdatePage | Overwrites the specified page in the ImGearRecDocument with the page provided.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecDocument class.
Top
See Also

Reference

ImGearRecDocument Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecDocument Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDocument Class

For a list of all members of this type, see ImGearRecDocument members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | This method has been deprecated. Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Public Method | DeletePage | Removes a page from the document.
Public Method | Dispose | Frees all data associated with this object.
Public Method | InsertPage | Inserts a page to the document.
Public Method | MovePage | Changes the index of a page in the document.
static (Shared in Visual Basic) | Open | This method has been deprecated. Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Public Method | Save | Saves the document to the specified data file in the native Nuance format. The document can be opened later using the ImGearRecOutputManager.OpenDocument method.
Public Method | UpdatePage | Overwrites the specified page in the ImGearRecDocument with the page provided.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecDocument class.
Top
See Also

Reference

ImGearRecDocument Class
ImageGear.Recognition Namespace


Create Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : Create Method
Specifies the intermediate data file. If this parameter is null or equal to "", then the file name will be generated automatically.
This method has been deprecated. Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use ImGearRecOutputManager.CreateDocument instead")>
Public Shared Function Create( _
   ByVal dataFilePath As String _
) As ImGearRecDocument
'Usage

Dim dataFilePath As String
Dim value As ImGearRecDocument

value = ImGearRecDocument.Create(dataFilePath)
[Obsolete("Use ImGearRecOutputManager.CreateDocument instead")]
public static ImGearRecDocument Create(
   string dataFilePath
)
[Obsolete("Use ImGearRecOutputManager.CreateDocument instead")]
public: static ImGearRecDocument* Create(
   string* dataFilePath
)
[Obsolete("Use ImGearRecOutputManager.CreateDocument instead")]
public:
static ImGearRecDocument^ Create(
   String^ dataFilePath
)

Parameters

dataFilePath
Specifies the intermediate data file. If this parameter is null or equal to "", then the file name will be generated automatically.

Return Value

New instance of ImGearRecDocument class object.
Remarks

This method throws ImageGear.Core.ImGearException with error code ImageGear.Core.ImGearErrorCodes.NOT_LICENSED if ImGearRecLicenseFeature.FormattedOutput feature is not licensed.

Note: This method has been deprecated and will be removed from the public API in the next release. Please use the ImGearRecOutputManager.CreateDocument method instead.

See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


DeletePage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : DeletePage Method
Index of the page to be removed.
Removes a page from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeletePage( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearRecDocument
Dim index As Integer

instance.DeletePage(index)
public void DeletePage(
   int index
)
public: void DeletePage(
   int index
)
public:
void DeletePage(
   int index
)

Parameters

index
Index of the page to be removed.
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


Dispose Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : Dispose Method
Frees all data associated with this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearRecDocument

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This is a standard .NET Dispose method. It frees all data associated with this object.

It's not required for an application to call this method, since the .NET garbage collector will eventually dispose the object if no references to it exist anymore. However, in order to minimize memory usage, it is recommended for an application to call the Dispose method as soon as the object is no longer needed.

The application is responsible for not accessing any methods or properties of the object after having called its Dispose method.

See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


Finalize Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : Finalize Method
Finalizes an instance of the ImGearRecDocument class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearRecDocument

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


InsertPage Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : InsertPage Method
Page to be inserted into the document.
Insert before this page. -1 means append the page.
Inserts a page to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub InsertPage( _
   ByVal page As ImGearRecPage, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearRecDocument
Dim page As ImGearRecPage
Dim index As Integer

instance.InsertPage(page, index)
public void InsertPage(
   ImGearRecPage page,
   int index
)
public: void InsertPage(
   ImGearRecPage* page,
   int index
)
public:
void InsertPage(
   ImGearRecPage^ page,
   int index
)

Parameters

page
Page to be inserted into the document.
index
Insert before this page. -1 means append the page.
Remarks
After inserting the page becomes invalid. Use ImGearRecPage.IsValid to validate the page.
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members
ImGearRecPage Class


MovePage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : MovePage Method
Starting page index.
Destination page index.
Changes the index of a page in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MovePage( _
   ByVal sourceIndex As Integer, _
   ByVal destinationIndex As Integer _
)
'Usage

Dim instance As ImGearRecDocument
Dim sourceIndex As Integer
Dim destinationIndex As Integer

instance.MovePage(sourceIndex, destinationIndex)
public void MovePage(
   int sourceIndex,
   int destinationIndex
)
public: void MovePage(
   int sourceIndex,
   int destinationIndex
)
public:
void MovePage(
   int sourceIndex,
   int destinationIndex
)

Parameters

sourceIndex
Starting page index.
destinationIndex
Destination page index.
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


Open Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : Open Method
Specifies the valid data file to be copied to the document.
This method has been deprecated. Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use ImGearRecOutputManager.OpenDocument instead")>
Public Shared Function Open( _
   ByVal dataFilePath As String _
) As ImGearRecDocument
'Usage

Dim dataFilePath As String
Dim value As ImGearRecDocument

value = ImGearRecDocument.Open(dataFilePath)
[Obsolete("Use ImGearRecOutputManager.OpenDocument instead")]
public static ImGearRecDocument Open(
   string dataFilePath
)
[Obsolete("Use ImGearRecOutputManager.OpenDocument instead")]
public: static ImGearRecDocument* Open(
   string* dataFilePath
)
[Obsolete("Use ImGearRecOutputManager.OpenDocument instead")]
public:
static ImGearRecDocument^ Open(
   String^ dataFilePath
)

Parameters

dataFilePath
Specifies the valid data file to be copied to the document.

Return Value

New instance of ImGearRecDocument class object.
Remarks

This method throws ImageGear.Core.ImGearException with error code ImageGear.Core.ImGearErrorCodes.NOT_LICENSED if ImGearRecLicenseFeature.FormattedOutput feature is not licensed.

Note: This method has been deprecated and will be removed from the public API in the next release. Please use the ImGearRecOutputManager.OpenDocument method instead.

See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


Save Method (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : Save Method
Specifies the data file to save the document to.
Saves the document to the specified data file in the native Nuance format. The document can be opened later using the ImGearRecOutputManager.OpenDocument method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Save( _
   ByVal dataFilePath As String _
)
'Usage

Dim instance As ImGearRecDocument
Dim dataFilePath As String

instance.Save(dataFilePath)
public void Save(
   string dataFilePath
)
public: void Save(
   string* dataFilePath
)
public:
void Save(
   String^ dataFilePath
)

Parameters

dataFilePath
Specifies the data file to save the document to.
Remarks

This method saves the document to the file system using the specified filename. Any changes made to the document after calling this method will be automatically written to the same file when the ImGearRecDocument object is disposed.

See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


UpdatePage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : UpdatePage Method
Page that will overwrite the page specified by index.
Index of the page to overwrite in the ImGearRecDocument.
Overwrites the specified page in the ImGearRecDocument with the page provided.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdatePage( _
   ByVal page As ImGearRecPage, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearRecDocument
Dim page As ImGearRecPage
Dim index As Integer

instance.UpdatePage(page, index)
public void UpdatePage(
   ImGearRecPage page,
   int index
)
public: void UpdatePage(
   ImGearRecPage* page,
   int index
)
public:
void UpdatePage(
   ImGearRecPage^ page,
   int index
)

Parameters

page
Page that will overwrite the page specified by index.
index
Index of the page to overwrite in the ImGearRecDocument.
Remarks
After overwriting the incoming page becomes invalid. Use ImGearRecPage.IsValid to validate the page.
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members
ImGearRecPage Class


%%PageItemTitle%% $$Properties$$

ImGearRecDocument Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDocument Class

For a list of all members of this type, see ImGearRecDocument members.

Public Properties
 | Name | Description
Public Property | PageCount | Gets the page count in the document.
Top
See Also

Reference

ImGearRecDocument Class
ImageGear.Recognition Namespace


PageCount Property (ImGearRecDocument)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecDocument Class : PageCount Property
Gets the page count in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ImGearRecDocument
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecDocument Class
ImGearRecDocument Members


%%PageItemTitle%%

ImGearRecImage Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecImage Class
Image to be recognized, associated with an ImGearRecPage class object and exposed via ImGearRecPage.Image property.
Object Model
ImGearRecImage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecImage
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecImage
public sealed class ImGearRecImage : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecImage : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecImage sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
This is the image stored within the recognition engine as a result of an ImGearRecognition.ImportPage method call.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecImage

See Also

Reference

ImGearRecImage Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecImage Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecImage Class

The following tables list the members exposed by ImGearRecImage.

Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets number of bits per pixel.
Public Property | BytesPerLine | Gets number of bytes per line used by pixel data.
Public Property | Height | Gets image height in pixels.
Public Property | Width | Gets image width in pixels.
Public Property | XRes | Gets horizontal resolution of image in dots per inch.
Public Property | YRes | Gets vertical resolution of image in dots per inch.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the specified rectangular region of the image.
Public Method | Deskew | Deskews the image.
Public Method | Deskew3D | Performs a three-dimensional deskew on the image.
Public Method | Despeckle | Despeckles the image.
Public Method | DetectBlankPage | Detects whether or not the image is considered to be blank.
Public Method | DetectSkew | Detects the skew amount of the image.
Public Method | Export | Exports the image to an ImageGear.Core.ImGearRasterPage object.
Public Method | Invert | Overloaded. Inverts the image.
Public Method | Orient | Rotates and/or mirrors the image.
Public Method | Preprocess | Performs pre-processing steps on the image.
Public Method | ReduceToBitonal | Reduces an image to bitonal (black and white).
Public Method | TransformPoint | Transforms the coordinates of a point between original input and processed versions of the image.
Public Method | TransformRectangle | Transforms the coordinates of a rectangle between original input and processed versions of the image.
Top
See Also

Reference

ImGearRecImage Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecImage Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecImage Class

For a list of all members of this type, see ImGearRecImage members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the specified rectangular region of the image.
Public Method | Deskew | Deskews the image.
Public Method | Deskew3D | Performs a three-dimensional deskew on the image.
Public Method | Despeckle | Despeckles the image.
Public Method | DetectBlankPage | Detects whether or not the image is considered to be blank.
Public Method | DetectSkew | Detects the skew amount of the image.
Public Method | Export | Exports the image to an ImageGear.Core.ImGearRasterPage object.
Public Method | Invert | Overloaded. Inverts the image.
Public Method | Orient | Rotates and/or mirrors the image.
Public Method | Preprocess | Performs pre-processing steps on the image.
Public Method | ReduceToBitonal | Reduces an image to bitonal (black and white).
Public Method | TransformPoint | Transforms the coordinates of a point between original input and processed versions of the image.
Public Method | TransformRectangle | Transforms the coordinates of a rectangle between original input and processed versions of the image.
Top
See Also

Reference

ImGearRecImage Class
ImageGear.Recognition Namespace


Clear Method (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Clear Method
Rectangular region of the image to clear.
Clears the specified rectangular region of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear( _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As ImGearRecImage
Dim rect As ImGearRectangle

instance.Clear(rect)
public void Clear(
   ImGearRectangle rect
)
public: void Clear(
   ImGearRectangle rect
)
public:
void Clear(
   ImGearRectangle rect
)

Parameters

rect
Rectangular region of the image to clear.
Remarks
Clears all pixel values in the rectangular region of the image to 0.

With a bitonal image, setting all its bits to zero (0) results in an entirely white image. In other cases, the resulting image is entirely black.

If the opposite color is desired, use the Invert method to perform inversion of the region after having it cleared.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRectangle Structure


Deskew Method (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Deskew Method
Integer slope value for deskewing. The value given here is the number of pixels of vertical ascent on 1000 horizontal pixels. That is, the tangent of the deskew angle multiplied by 1000. The slope parameter must be in the range -577 to 577; that means the maximal absolute slope value is 30 degrees. Specifying a positive value rotates the image counter clockwise.
Deskews the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Deskew( _
   ByVal slope As Integer _
)
'Usage

Dim instance As ImGearRecImage
Dim slope As Integer

instance.Deskew(slope)
public void Deskew(
   int slope
)
public: void Deskew(
   int slope
)
public:
void Deskew(
   int slope
)

Parameters

slope
Integer slope value for deskewing. The value given here is the number of pixels of vertical ascent on 1000 horizontal pixels. That is, the tangent of the deskew angle multiplied by 1000. The slope parameter must be in the range -577 to 577; that means the maximal absolute slope value is 30 degrees. Specifying a positive value rotates the image counter clockwise.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


Deskew3D Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Deskew3D Method
Performs a three-dimensional deskew on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Deskew3D()
'Usage

Dim instance As ImGearRecImage

instance.Deskew3D()
public void Deskew3D()
public: void Deskew3D();
public:
void Deskew3D();
Remarks

This method attempts to correct the skew and perspective distortion that can occur in captured images. Typically, this distortion is common in images taken with a digital camera, though this method can be used with any image with similar distortion, regardless of the capture method.

The primary correction applied by this algorithm is to transform parallel text lines so they are horizontal, and to align column edges vertically. To do this, a certain number of characters, text lines and column edges are required. Column edges mean that the beginning and/or end of consecutive text lines have identical positions (i.e. the left edge of a column aligned left or both edges of a justified column). The minimal quantities are approximately 10 text lines and a single edge of two columns or both edges of one column. The accuracy of the algorithm increases when there are a good number of lines and column edges and when these are not confined to a small area of the image. If the image contains only figures or graphics, no transformation will occur.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


Despeckle Method (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Despeckle Method
Despeckles the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Despeckle()
'Usage

Dim instance As ImGearRecImage

instance.Despeckle()
public void Despeckle()
public: void Despeckle();
public:
void Despeckle();
Remarks
This method performs an immediate adaptive noise removal on the bitonal image specified, irrespective of its resolution. An image despeckled by this method replaces the original one and is available for display and export.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


DetectBlankPage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : DetectBlankPage Method
Detects whether or not the image is considered to be blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function DetectBlankPage() As Boolean
'Usage

Dim instance As ImGearRecImage
Dim value As Boolean

value = instance.DetectBlankPage()
public bool DetectBlankPage()
public: bool DetectBlankPage();
public:
bool DetectBlankPage();

Return Value

True if the image is blank, otherwise False.
Remarks

This method will consider an image to be blank (all or mostly white) if there is only a small percentage of noise, especially noise around the edge of the image usually created as a result of scanning.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


DetectSkew Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : DetectSkew Method
Variable to receive detected skew of the image.
Variable to receive detected orientation of the image.
Detects the skew amount of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DetectSkew( _
   ByRef slope As Integer, _
   ByRef orientation As ImGearRecOrientationMode _
)
'Usage

Dim instance As ImGearRecImage
Dim slope As Integer
Dim orientation As ImGearRecOrientationMode

instance.DetectSkew(slope, orientation)
public void DetectSkew(
   out int slope,
   out ImGearRecOrientationMode orientation
)
public: void DetectSkew(
   [PARAMFLAG::Out] int slope,
   [PARAMFLAG::Out] ImGearRecOrientationMode orientation
)
public:
void DetectSkew(
   [Out] int slope,
   [Out] ImGearRecOrientationMode orientation
)

Parameters

slope
Variable to receive detected skew of the image.
orientation
Variable to receive detected orientation of the image.
Remarks
This method detects the orientation and the skew of the image.

Depending on the current setting of the Image deskewing and Image rotation modes, this method returns either with the detected image skew / orientation or with the current values of these settings.

When the image is not bitonal, in some rare cases Preprocess method can deskew the image more accurately than DetectSkew / Deskew methods. This is because DetectSkew uses a simpler and faster binarization algorithm than the Preprocess. The latter can realize that the calculated slope value is unreliable and then binarize the image again with a more precise method and repeat the skew detection.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRecOrientationMode Enumeration


Export Method (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Export Method
Exports the image to an ImageGear.Core.ImGearRasterPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Export() As ImGearRasterPage
'Usage

Dim instance As ImGearRecImage
Dim value As ImGearRasterPage

value = instance.Export()
public ImGearRasterPage Export()
public: ImGearRasterPage* Export();
public:
ImGearRasterPage^ Export();

Return Value

ImageGear.Core.ImGearRasterPage class object.
Remarks
Exports the image stored in the recognition engine to an ImageGear.Core.ImGearRasterPage object. This is useful if further processing or display of the image is desired.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRasterPage Class


Invert Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Invert Method
Inverts the image.
Overload List
Overload | Description
Invert(ImGearRectangle) | Inverts the specified rectangular region of the image.
Invert() | Inverts the entire image.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


Invert(ImGearRectangle) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class > Invert Method : Invert(ImGearRectangle) Method
Rectangular region of the image to invert.
Inverts the specified rectangular region of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Invert( _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As ImGearRecImage
Dim rect As ImGearRectangle

instance.Invert(rect)
public void Invert(
   ImGearRectangle rect
)
public: void Invert(
   ImGearRectangle rect
)
public:
void Invert(
   ImGearRectangle rect
)

Parameters

rect
Rectangular region of the image to invert.
Remarks
This method performs immediate inversion of the color of each pixel within the specified rectangular region of the image. For example, white becomes black, and black becomes white. This method ignores the image inversion mode setting (ImGearRecPreprocessingSettings.InversionMode property). The inverted image replaces the original one and is available to the recognition engine and the application.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
Overload List
ImGearRectangle Structure
ImGearRecPreprocessingSettings Class


Invert() Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class > Invert Method : Invert() Method
Inverts the entire image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Invert()
'Usage

Dim instance As ImGearRecImage

instance.Invert()
public void Invert()
public: void Invert();
public:
void Invert();
Remarks
This method performs immediate inversion of the color of each pixel of the image. For example, white becomes black, and black becomes white. This method ignores the image inversion mode setting (ImGearRecPreprocessingSettings.InversionMode property). The inverted image replaces the original one and is available to the recognition engine and the application.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
Overload List


Orient Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Orient Method
Image rotation/orientation operation to be performed.
Rotates and/or mirrors the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Orient( _
   ByVal orientation As ImGearRecOrientationMode _
)
'Usage

Dim instance As ImGearRecImage
Dim orientation As ImGearRecOrientationMode

instance.Orient(orientation)
public void Orient(
   ImGearRecOrientationMode orientation
)
public: void Orient(
   ImGearRecOrientationMode orientation
)
public:
void Orient(
   ImGearRecOrientationMode orientation
)

Parameters

orientation
Image rotation/orientation operation to be performed.
Remarks
This method immediately rotates and/or mirrors the image according to the specified orientation parameter.

When this method is called, the coordinates of all defined zones in the zone list will be automatically recalculated, i.e., the zones are also rotated.

An alternative to this method is the Preprocess method with the required OrientationMode property set.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRecOrientationMode Enumeration


Preprocess Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Preprocess Method
Performs pre-processing steps on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Preprocess()
'Usage

Dim instance As ImGearRecImage

instance.Preprocess()
public void Preprocess()
public: void Preprocess();
public:
void Preprocess();
Remarks

This method performs a series of image pre-processing steps by activating the ImGearRecProcess.IMGPREPROCESS process. Performing these image pre-processing steps may improve the quality of the image from an OCR point of view, which may have an impact on the overall recognition accuracy for the page.

If pre-processing is desired, it should be done before performing auto-zoning and recognition. The available pre-processing steps are image inversion, despeckling, deskewing, and rotation. Also, if the ImGearRecRecognitionSettings.Tradeoff property is set to ImGearRecTradeoff.FAST, a faster, but less accurate deskew, binarization, and despeckle algorithm will be used during pre-processing.

Note: The image resulting from deskewing and rotation are available to the application and can be exported back to an ImGearPage object using the Export method. Inversion and despeckle run on an internal secondary image, and their result is not available for exporting back to the application. Use Invert and Despeckle methods for explicit inversion and despeckling. See The Recognition Process section for explanation of the "secondary image" term.

Whether and how the Preprocess operation does these steps depends on the settings found in the ImGearRecognition.Preprocessing object properties.

The value needed for programmed deskewing, specified with ImGearRecDeskewMode.SET mode, can be detected by DetectSkew method and defined in the ImGearRecPreprocessingSettings.SkewAmount property.

The ImGearRecDeskewMode.AUTO_3D deskewing mode will not be used if an Asian language is set for recognition before pre-processing occurs.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRecPreprocessingSettings Class


ReduceToBitonal Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : ReduceToBitonal Method
Image conversion mode to be applied during the conversion of the image. Possible values are: AUTO, SET, GLOBAL.
Brightness of the image (range is 0 to 100, where 0 means the darkest and 100 means the lightest resulting image). This parameter has an effect only if the conversion parameter is set to AUTO.
Threshold value to be set. Its range should be between 0 and 255. This parameter has an effect only if the Conversion parameter is set to SET.
Resolution enhancement setting to be applied during the conversion (ImGearRecResEnhancementMode).
Reduces an image to bitonal (black and white).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReduceToBitonal( _
   ByVal reductionMode As ImGearRecReductionMode, _
   ByVal brightness As Integer, _
   ByVal threshold As Integer, _
   ByVal resolutionEnhancementMode As ImGearRecResEnhancementMode _
)
'Usage

Dim instance As ImGearRecImage
Dim reductionMode As ImGearRecReductionMode
Dim brightness As Integer
Dim threshold As Integer
Dim resolutionEnhancementMode As ImGearRecResEnhancementMode

instance.ReduceToBitonal(reductionMode, brightness, threshold, resolutionEnhancementMode)
public void ReduceToBitonal(
   ImGearRecReductionMode reductionMode,
   int brightness,
   int threshold,
   ImGearRecResEnhancementMode resolutionEnhancementMode
)
public: void ReduceToBitonal(
   ImGearRecReductionMode reductionMode,
   int brightness,
   int threshold,
   ImGearRecResEnhancementMode resolutionEnhancementMode
)
public:
void ReduceToBitonal(
   ImGearRecReductionMode reductionMode,
   int brightness,
   int threshold,
   ImGearRecResEnhancementMode resolutionEnhancementMode
)

Parameters

reductionMode
Image conversion mode to be applied during the conversion of the image. Possible values are: AUTO, SET, GLOBAL.
brightness
Brightness of the image (range is 0 to 100, where 0 means the darkest and 100 means the lightest resulting image). This parameter has an effect only if the conversion parameter is set to AUTO.
threshold
Threshold value to be set. Its range should be between 0 and 255. This parameter has an effect only if the Conversion parameter is set to SET.
resolutionEnhancementMode
Resolution enhancement setting to be applied during the conversion (ImGearRecResEnhancementMode).
Remarks
This method performs a direct secondary image conversion step, converting a color or grayscale image to a black-and-white (bitonal) one.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRecReductionMode Enumeration
ImGearRecResEnhancementMode Enumeration


TransformPoint Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : TransformPoint Method
Point whose coordinates are to be transformed.
When true, the method will treat the values in point point as coordinates belonging to the current image, and so it will calculate the corresponding coordinates on the original (incoming) image.When false, the method will treat the values in point point as coordinates belonging to original (incoming) image, and so the method will calculate the corresponding coordinates on the current image.
Transforms the coordinates of a point between original input and processed versions of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformPoint( _
   ByRef point As ImGearPoint, _
   ByVal fromCurrentToOriginal As Boolean _
)
'Usage

Dim instance As ImGearRecImage
Dim point As ImGearPoint
Dim fromCurrentToOriginal As Boolean

instance.TransformPoint(point, fromCurrentToOriginal)
public void TransformPoint(
   ref ImGearPoint point,
   bool fromCurrentToOriginal
)
public: void TransformPoint(
   ref ImGearPoint point,
   bool fromCurrentToOriginal
)
public:
void TransformPoint(
   ImGearPoint% point,
   bool fromCurrentToOriginal
)

Parameters

point
Point whose coordinates are to be transformed.
fromCurrentToOriginal
When true, the method will treat the values in point point as coordinates belonging to the current image, and so it will calculate the corresponding coordinates on the original (incoming) image.When false, the method will treat the values in point point as coordinates belonging to original (incoming) image, and so the method will calculate the corresponding coordinates on the current image.
Remarks
This method can be used to learn the coordinates of a point on the original (incoming) image, when the coordinates of the point on the current image are known. This might be necessary, since images often undergo different image preprocessing steps, such as deskewing, rotation, etc. Alternatively, this method can provide the coordinates of a point on the current image when its coordinates on the original image are given.

Note: ReduceToBitonal method clears the history of image transforms. After applying this method, Recognition engine treats the bitonal image as if it was the original one.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearPoint Structure


TransformRectangle Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : TransformRectangle Method
Rectangle whose coordinates are to be transformed.
When true, the method will treat the values in rect rectangle as coordinates belonging to the current image, and so it will calculate the corresponding coordinates on the original (incoming) image.When false, the method will treat the values in rect rectangle as coordinates belonging to original (incoming) image, and so the method will calculate the corresponding coordinates on the current image.
Transforms the coordinates of a rectangle between original input and processed versions of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformRectangle( _
   ByRef rect As ImGearRectangle, _
   ByVal fromCurrentToOriginal As Boolean _
)
'Usage

Dim instance As ImGearRecImage
Dim rect As ImGearRectangle
Dim fromCurrentToOriginal As Boolean

instance.TransformRectangle(rect, fromCurrentToOriginal)
public void TransformRectangle(
   ref ImGearRectangle rect,
   bool fromCurrentToOriginal
)
public: void TransformRectangle(
   ref ImGearRectangle rect,
   bool fromCurrentToOriginal
)
public:
void TransformRectangle(
   ImGearRectangle% rect,
   bool fromCurrentToOriginal
)

Parameters

rect
Rectangle whose coordinates are to be transformed.
fromCurrentToOriginal
When true, the method will treat the values in rect rectangle as coordinates belonging to the current image, and so it will calculate the corresponding coordinates on the original (incoming) image.When false, the method will treat the values in rect rectangle as coordinates belonging to original (incoming) image, and so the method will calculate the corresponding coordinates on the current image.
Remarks
This method can be used to learn the coordinates of a rectangle on the original (incoming) image, when the coordinates of the rectangle on the current image are known. This might be necessary, since images often undergo different image preprocessing steps, such as deskewing, rotation, etc. Alternatively, this method can provide the coordinates of a rectangle on the current image when its coordinates on the original image are given.

Note: ReduceToBitonal method clears the history of image transforms. After applying this method, Recognition engine treats the bitonal image as if it was the original one.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members
ImGearRectangle Structure


%%PageItemTitle%% $$Properties$$

ImGearRecImage Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecImage Class

For a list of all members of this type, see ImGearRecImage members.

Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets number of bits per pixel.
Public Property | BytesPerLine | Gets number of bytes per line used by pixel data.
Public Property | Height | Gets image height in pixels.
Public Property | Width | Gets image width in pixels.
Public Property | XRes | Gets horizontal resolution of image in dots per inch.
Public Property | YRes | Gets vertical resolution of image in dots per inch.
Top
See Also

Reference

ImGearRecImage Class
ImageGear.Recognition Namespace


BitsPerPixel Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : BitsPerPixel Property
Gets number of bits per pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerPixel As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.BitsPerPixel
public int BitsPerPixel {get;}
public: __property int get_BitsPerPixel();
public:
property int BitsPerPixel {
   int get();
}

Property Value

Integer value.
Remarks
Number of bits per pixel used to store the image in the recognition engine. Also known as image color depth.

This may differ from the original input image's color depth due to processing steps. For example, a 24-bit RGB image could be reduced to bitonal (1-bit black and white) depending on preprocessing settings.

See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


BytesPerLine Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : BytesPerLine Property
Gets number of bytes per line used by pixel data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BytesPerLine As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.BytesPerLine
public int BytesPerLine {get;}
public: __property int get_BytesPerLine();
public:
property int BytesPerLine {
   int get();
}

Property Value

Integer value.
Remarks
Number of bytes used to store a single row of the image's pixel data in memory.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


Height Property (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Height Property
Gets image height in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


Width Property (ImGearRecImage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : Width Property
Gets image width in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


XRes Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : XRes Property
Gets horizontal resolution of image in dots per inch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property XRes As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.XRes
public int XRes {get;}
public: __property int get_XRes();
public:
property int XRes {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


YRes Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecImage Class : YRes Property
Gets vertical resolution of image in dots per inch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property YRes As Integer
'Usage

Dim instance As ImGearRecImage
Dim value As Integer

value = instance.YRes
public int YRes {get;}
public: __property int get_YRes();
public:
property int YRes {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecImage Class
ImGearRecImage Members


%%PageItemTitle%%

ImGearRecLetter Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecLetter Class
Represents a single recognized letter, returned as an array by ImGearRecPage.GetLetters method.
Object Model
ImGearRecLetter ClassImGearRGBQuad StructureImGearRGBQuad StructureIImGearRectangle Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecLetter
'Usage

Dim instance As ImGearRecLetter
public sealed class ImGearRecLetter
public __gc __sealed class ImGearRecLetter
public ref class ImGearRecLetter sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecLetter

See Also

Reference

ImGearRecLetter Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecLetter Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecLetter Class

The following tables list the members exposed by ImGearRecLetter.

Public Properties
 | Name | Description
Public Property | AlternativeCharacters | Gets a collection that contains all of the possible alternative characters to the primary choice available from the Code property.
Public Property | AlternativeLanguage | Gets or sets the alternative language of the recognized word.
Public Property | BackgroundColor | Gets the background color of the letter.
Public Property | Baseline | Gets or sets Y coordinate of the baseline in pixels.
Public Property | CapitalLetterHeight | Gets or sets a measure of the capital letter height in pixels.
Public Property | Code | Gets or sets the character code in UNICODE. This is the first choice of the recognition or a special code 0xfffd for rejected characters.
Public Property | Confidence | Gets or sets confidence level of first guess for the character (0 = not confident, 100 = confident).
Public Property | ConfidenceInfo | Gets or sets the confidence number expressing both the certainty of the recognition of the first guess (Code property) and also the certainty of the word.
Public Property | FontAttribute | Gets or sets font information about the recognized character. Used by the OCR engines. See ImGearRecFontFlags description for more details.
Public Property | ForegroundColor | Gets the foreground color of the letter.
Public Property | Language | Gets or sets the language of the recognized word.
Public Property | Makeup | Gets or sets Makeup infomation (formatting attributes).
Public Property | Rect | Gets a reference to the rectangle exactly containing the character.
Public Property | SpacesCount | Gets or sets the number of spaces if this letter is a space.
Public Property | SpaceType | Gets or sets the type of the space, such as real space, tab, dot leader, etc.
Public Property | UnderlineDotWidth | Gets or sets the width of a dot in pixels if the "underline" is underdots in reality.
Public Property | UnderlineGapWidth | Gets or sets the width of a gap in pixels if the "underline" is underdots in reality.
Public Property | WordSuggestions | Gets a collection that contains all of the possible word suggestions for the current word to which this ImGearRecLetter belongs.
Public Property | WordUncertain | Gets or sets a value indicating whether the word containing the character is uncertain.
Public Property | ZoneIndex | Gets or sets the index of the zone in ImGearRecPage.Zones which contains the character.
Top
See Also

Reference

ImGearRecLetter Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecLetter Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecLetter Class

For a list of all members of this type, see ImGearRecLetter members.

Public Properties
 | Name | Description
Public Property | AlternativeCharacters | Gets a collection that contains all of the possible alternative characters to the primary choice available from the Code property.
Public Property | AlternativeLanguage | Gets or sets the alternative language of the recognized word.
Public Property | BackgroundColor | Gets the background color of the letter.
Public Property | Baseline | Gets or sets Y coordinate of the baseline in pixels.
Public Property | CapitalLetterHeight | Gets or sets a measure of the capital letter height in pixels.
Public Property | Code | Gets or sets the character code in UNICODE. This is the first choice of the recognition or a special code 0xfffd for rejected characters.
Public Property | Confidence | Gets or sets confidence level of first guess for the character (0 = not confident, 100 = confident).
Public Property | ConfidenceInfo | Gets or sets the confidence number expressing both the certainty of the recognition of the first guess (Code property) and also the certainty of the word.
Public Property | FontAttribute | Gets or sets font information about the recognized character. Used by the OCR engines. See ImGearRecFontFlags description for more details.
Public Property | ForegroundColor | Gets the foreground color of the letter.
Public Property | Language | Gets or sets the language of the recognized word.
Public Property | Makeup | Gets or sets Makeup infomation (formatting attributes).
Public Property | Rect | Gets a reference to the rectangle exactly containing the character.
Public Property | SpacesCount | Gets or sets the number of spaces if this letter is a space.
Public Property | SpaceType | Gets or sets the type of the space, such as real space, tab, dot leader, etc.
Public Property | UnderlineDotWidth | Gets or sets the width of a dot in pixels if the "underline" is underdots in reality.
Public Property | UnderlineGapWidth | Gets or sets the width of a gap in pixels if the "underline" is underdots in reality.
Public Property | WordSuggestions | Gets a collection that contains all of the possible word suggestions for the current word to which this ImGearRecLetter belongs.
Public Property | WordUncertain | Gets or sets a value indicating whether the word containing the character is uncertain.
Public Property | ZoneIndex | Gets or sets the index of the zone in ImGearRecPage.Zones which contains the character.
Top
See Also

Reference

ImGearRecLetter Class
ImageGear.Recognition Namespace


AlternativeCharacters Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : AlternativeCharacters Property
Gets a collection that contains all of the possible alternative characters to the primary choice available from the Code property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AlternativeCharacters As ReadOnlyCollection(Of String)
'Usage

Dim instance As ImGearRecLetter
Dim value As ReadOnlyCollection(Of String)

value = instance.AlternativeCharacters
public ReadOnlyCollection<string> AlternativeCharacters {get;}
public: __property ReadOnlyCollection<string*>* get_AlternativeCharacters();
public:
property ReadOnlyCollection<String^>^ AlternativeCharacters {
   ReadOnlyCollection<String^>^ get();
}

Property Value

ReadOnlyCollection value.
Remarks

Alternative character values are commonly available for characters that are frequently misrecognized during the OCR process. For example, 'i' and 'l' are common alternatives for each other. Characters recognized with high confidence will typically not have any alternative character values in which case an empty collection is returned.

This is a read-only property. If the ImGearRecPage.SetLetters method is called with an array of ImGearRecLetter class objects that has been modified, this property will be cleared after the subsequent call to ImGearRecPage.Recognize.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
SetLetters Method


AlternativeLanguage Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : AlternativeLanguage Property
Gets or sets the alternative language of the recognized word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternativeLanguage As ImGearRecLanguage
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRecLanguage

instance.AlternativeLanguage = value

value = instance.AlternativeLanguage
public ImGearRecLanguage AlternativeLanguage {get; set;}
public: __property ImGearRecLanguage get_AlternativeLanguage();
public: __property void set_AlternativeLanguage(
   ImGearRecLanguage value
);
public:
property ImGearRecLanguage AlternativeLanguage {
   ImGearRecLanguage get();
   void set (    ImGearRecLanguage value);
}

Property Value

ImGearRecLanguage value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
Language Property


BackgroundColor Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : BackgroundColor Property
Gets the background color of the letter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BackgroundColor As ImGearRGBQuad
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRGBQuad

value = instance.BackgroundColor
public ImGearRGBQuad BackgroundColor {get;}
public: __property ImGearRGBQuad get_BackgroundColor();
public:
property ImGearRGBQuad BackgroundColor {
   ImGearRGBQuad get();
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
Remarks

This is a read-only property. If the ImGearRecPage.SetLetters method is called with an array of ImGearRecLetter class objects that has been modified, this property will be cleared after the subsequent call to ImGearRecPage.Recognize.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
SetLetters Method


Baseline Property (ImGearRecLetter)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Baseline Property
Gets or sets Y coordinate of the baseline in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Baseline As UShort
'Usage

Dim instance As ImGearRecLetter
Dim value As UShort

instance.Baseline = value

value = instance.Baseline
public ushort Baseline {get; set;}
public: __property ushort get_Baseline();
public: __property void set_Baseline(
   ushort value
);
public:
property ushort Baseline {
   ushort get();
   void set (    ushort value);
}

Property Value

Any positive value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


CapitalLetterHeight Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : CapitalLetterHeight Property
Gets or sets a measure of the capital letter height in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CapitalLetterHeight As UShort
'Usage

Dim instance As ImGearRecLetter
Dim value As UShort

instance.CapitalLetterHeight = value

value = instance.CapitalLetterHeight
public ushort CapitalLetterHeight {get; set;}
public: __property ushort get_CapitalLetterHeight();
public: __property void set_CapitalLetterHeight(
   ushort value
);
public:
property ushort CapitalLetterHeight {
   ushort get();
   void set (    ushort value);
}

Property Value

Ushort value.
Remarks
Font size in points can be roughly calculated from CapitalLetterHeight as follows: FontSize = CapitalLetterHeight * 100 / dpi.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


Code Property (ImGearRecLetter)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Code Property
Gets or sets the character code in UNICODE. This is the first choice of the recognition or a special code 0xfffd for rejected characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Code As Char
'Usage

Dim instance As ImGearRecLetter
Dim value As Char

instance.Code = value

value = instance.Code
public char Code {get; set;}
public: __property char get_Code();
public: __property void set_Code(
   char value
);
public:
property char Code {
   char get();
   void set (    char value);
}

Property Value

Character code in Unicode.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


Confidence Property (ImGearRecLetter)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Confidence Property
Gets or sets confidence level of first guess for the character (0 = not confident, 100 = confident).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Confidence As Integer
'Usage

Dim instance As ImGearRecLetter
Dim value As Integer

instance.Confidence = value

value = instance.Confidence
public int Confidence {get; set;}
public: __property int get_Confidence();
public: __property void set_Confidence(
   int value
);
public:
property int Confidence {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Confidence number expressing the certainty of the recognition of the first guess character code. The value of this property ranges from 0 (not confident) to 100 (very confident).

This property is tied to the ConfidenceInfo property and provides the same information, but in a different way. The confidence value is inverted (to match the intuitive understanding of a confidence estimation) and only the character confidence is provided, rather than both the character confidence and word confidence.

This property is provided for the sake of convenience and does not result in additional storage overhead for the recognized data.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


ConfidenceInfo Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : ConfidenceInfo Property
Gets or sets the confidence number expressing both the certainty of the recognition of the first guess (Code property) and also the certainty of the word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConfidenceInfo As Byte
'Usage

Dim instance As ImGearRecLetter
Dim value As Byte

instance.ConfidenceInfo = value

value = instance.ConfidenceInfo
public byte ConfidenceInfo {get; set;}
public: __property byte get_ConfidenceInfo();
public: __property void set_ConfidenceInfo(
   byte value
);
public:
property byte ConfidenceInfo {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks

The most significant bit is used to express the certainty/uncertainty of the word (word is uncertain, if this bit set to one (1)). The remaining bits represent the certainty of the character recognition, which ranges between 0 and 100. The smaller this value is, the higher is the confidence of the recognition. See Confidence Reporting section for more details.

The Confidence and WordUncertain properties, provided for the sake of convenience, offer the same information but already separated out into two separate values. Note also that the scale used by the Confidence property is inverted to reflect the intuitive understanding of confidence, rather than error estimation.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


FontAttribute Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : FontAttribute Property
Gets or sets font information about the recognized character. Used by the OCR engines. See ImGearRecFontFlags description for more details.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontAttribute As ImGearRecFontFlags
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRecFontFlags

instance.FontAttribute = value

value = instance.FontAttribute
public ImGearRecFontFlags FontAttribute {get; set;}
public: __property ImGearRecFontFlags get_FontAttribute();
public: __property void set_FontAttribute(
   ImGearRecFontFlags value
);
public:
property ImGearRecFontFlags FontAttribute {
   ImGearRecFontFlags get();
   void set (    ImGearRecFontFlags value);
}

Property Value

ImGearRecFontFlags enumeration value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


ForegroundColor Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : ForegroundColor Property
Gets the foreground color of the letter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ForegroundColor As ImGearRGBQuad
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRGBQuad

value = instance.ForegroundColor
public ImGearRGBQuad ForegroundColor {get;}
public: __property ImGearRGBQuad get_ForegroundColor();
public:
property ImGearRGBQuad ForegroundColor {
   ImGearRGBQuad get();
}

Property Value

ImageGear.Core.ImGearRGBQuad value.
Remarks

This is a read-only property. If the ImGearRecPage.SetLetters method is called with an array of ImGearRecLetter class objects that has been modified, this property will be cleared after the subsequent call to ImGearRecPage.Recognize.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
SetLetters Method


Language Property (ImGearRecLetter)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Language Property
Gets or sets the language of the recognized word.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Language As ImGearRecLanguage
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRecLanguage

instance.Language = value

value = instance.Language
public ImGearRecLanguage Language {get; set;}
public: __property ImGearRecLanguage get_Language();
public: __property void set_Language(
   ImGearRecLanguage value
);
public:
property ImGearRecLanguage Language {
   ImGearRecLanguage get();
   void set (    ImGearRecLanguage value);
}

Property Value

ImGearRecLanguage value.
Remarks
This property is used to declare which language the recognized word belongs to. When the recognized word cannot be associated with any language, it is signaled with ImGearRecLanguage.NO. If the recognized word can also be found in another language dictionary, then both Language and AlternativeLanguage properties will contain the language IDs of those languages.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
AlternativeLanguage Property


Makeup Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Makeup Property
Gets or sets Makeup infomation (formatting attributes).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Makeup As ImGearRecMakeupInfo
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRecMakeupInfo

instance.Makeup = value

value = instance.Makeup
public ImGearRecMakeupInfo Makeup {get; set;}
public: __property ImGearRecMakeupInfo get_Makeup();
public: __property void set_Makeup(
   ImGearRecMakeupInfo value
);
public:
property ImGearRecMakeupInfo Makeup {
   ImGearRecMakeupInfo get();
   void set (    ImGearRecMakeupInfo value);
}

Property Value

ImGearRecMakeupInfo enumeration value.
Remarks
Since the recognition data does not contain extra characters for marking the ends of lines, paragraphs, pages, etc, these items of information are stored for the particular characters in this property. It can be any binary OR-ed combination of the ImGearRecMakeupInfo flags.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


Rect Property (ImGearRecLetter)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : Rect Property
Gets a reference to the rectangle exactly containing the character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Rect As IImGearRectangle
'Usage

Dim instance As ImGearRecLetter
Dim value As IImGearRectangle

value = instance.Rect
public IImGearRectangle Rect {get;}
public: __property IImGearRectangle* get_Rect();
public:
property IImGearRectangle^ Rect {
   IImGearRectangle^ get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
Remarks
This rectangle is expressed in current image coordinates. That is, its coordinates are affected by processing operations such as deskew and orientation. It is possible to transform these coordinates back to the original (input) image coordinates using the ImGearRecImage.TransformRectangle method.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
ImGearRectangle Structure


SpacesCount Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : SpacesCount Property
Gets or sets the number of spaces if this letter is a space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpacesCount As UShort
'Usage

Dim instance As ImGearRecLetter
Dim value As UShort

instance.SpacesCount = value

value = instance.SpacesCount
public ushort SpacesCount {get; set;}
public: __property ushort get_SpacesCount();
public: __property void set_SpacesCount(
   ushort value
);
public:
property ushort SpacesCount {
   ushort get();
   void set (    ushort value);
}

Property Value

Ushort value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


SpaceType Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : SpaceType Property
Gets or sets the type of the space, such as real space, tab, dot leader, etc.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpaceType As ImGearRecSpaceType
'Usage

Dim instance As ImGearRecLetter
Dim value As ImGearRecSpaceType

instance.SpaceType = value

value = instance.SpaceType
public ImGearRecSpaceType SpaceType {get; set;}
public: __property ImGearRecSpaceType get_SpaceType();
public: __property void set_SpaceType(
   ImGearRecSpaceType value
);
public:
property ImGearRecSpaceType SpaceType {
   ImGearRecSpaceType get();
   void set (    ImGearRecSpaceType value);
}

Property Value

ImGearRecSpaceType value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


UnderlineDotWidth Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : UnderlineDotWidth Property
Gets or sets the width of a dot in pixels if the "underline" is underdots in reality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnderlineDotWidth As Byte
'Usage

Dim instance As ImGearRecLetter
Dim value As Byte

instance.UnderlineDotWidth = value

value = instance.UnderlineDotWidth
public byte UnderlineDotWidth {get; set;}
public: __property byte get_UnderlineDotWidth();
public: __property void set_UnderlineDotWidth(
   byte value
);
public:
property byte UnderlineDotWidth {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
If the underline contains no gaps, or the letter is not underlined, the value is 0. The property is also used in the case of dotleaders.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


UnderlineGapWidth Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : UnderlineGapWidth Property
Gets or sets the width of a gap in pixels if the "underline" is underdots in reality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnderlineGapWidth As Byte
'Usage

Dim instance As ImGearRecLetter
Dim value As Byte

instance.UnderlineGapWidth = value

value = instance.UnderlineGapWidth
public byte UnderlineGapWidth {get; set;}
public: __property byte get_UnderlineGapWidth();
public: __property void set_UnderlineGapWidth(
   byte value
);
public:
property byte UnderlineGapWidth {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
If the underline contains no gaps, or the letter is not underlined, the value is 0. The property is also used in the case of dotleaders.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


WordSuggestions Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : WordSuggestions Property
Gets a collection that contains all of the possible word suggestions for the current word to which this ImGearRecLetter belongs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property WordSuggestions As ReadOnlyCollection(Of String)
'Usage

Dim instance As ImGearRecLetter
Dim value As ReadOnlyCollection(Of String)

value = instance.WordSuggestions
public ReadOnlyCollection<string> WordSuggestions {get;}
public: __property ReadOnlyCollection<string*>* get_WordSuggestions();
public:
property ReadOnlyCollection<String^>^ WordSuggestions {
   ReadOnlyCollection<String^>^ get();
}

Property Value

ReadOnlyCollection value.
Remarks

Word suggestions will only be available from the first letter of a word. Consecutive words can have the same suggestions, which is the case when the suggestion combines two or more space-separated words into a single one without spaces. For example, the consecutive words "Image" and "Gear" might both have word suggestions of "ImageGear" and "Image Gear" if the space between the words is not sufficient enough to confidently determine the word breaks. Words recognized with high confidence will typically not have any word suggestion values in which case an empty collection is returned. Letters containing spaces will never have word suggestions and always return an empty collection.

In general, this property will only contain word suggestions if the WordUncertain property is true, or if letters within a word are recognized with low confidence. In this case, the word suggestions will include each alternate character of the low confidence letters.

This is a read-only property. If the ImGearRecPage.SetLetters method is called with an array of ImGearRecLetter class objects that has been modified, this property will be cleared after the subsequent call to ImGearRecPage.Recognize.

See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members
SetLetters Method


WordUncertain Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : WordUncertain Property
Gets or sets a value indicating whether the word containing the character is uncertain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WordUncertain As Boolean
'Usage

Dim instance As ImGearRecLetter
Dim value As Boolean

instance.WordUncertain = value

value = instance.WordUncertain
public bool WordUncertain {get; set;}
public: __property bool get_WordUncertain();
public: __property void set_WordUncertain(
   bool value
);
public:
property bool WordUncertain {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Indicates whether the word the character belongs to was recognized uncertainly. If this value is true, the word is uncertain. Otherwise, it’s certain.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


ZoneIndex Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecLetter Class : ZoneIndex Property
Gets or sets the index of the zone in ImGearRecPage.Zones which contains the character.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoneIndex As UShort
'Usage

Dim instance As ImGearRecLetter
Dim value As UShort

instance.ZoneIndex = value

value = instance.ZoneIndex
public ushort ZoneIndex {get; set;}
public: __property ushort get_ZoneIndex();
public: __property void set_ZoneIndex(
   ushort value
);
public:
property ushort ZoneIndex {
   ushort get();
   void set (    ushort value);
}

Property Value

Ushort value.
See Also

Reference

ImGearRecLetter Class
ImGearRecLetter Members


%%PageItemTitle%%

ImGearRecModuleCollection Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleCollection Class
Collection of recognition engine modules, belongs to ImGearRecognition class object.
Object Model
ImGearRecModuleCollection ClassImGearRecAsianSettings ClassImGearRecModuleSettings ClassImGearRecMORSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearRecModuleCollection
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecModuleCollection
[DefaultMember("Item")]
public sealed class ImGearRecModuleCollection : ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public __gc __sealed class ImGearRecModuleCollection : public ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public ref class ImGearRecModuleCollection sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
This object provides indexers which can be used to obtain information and settings for each recognition engine module. It also provides access to objects that offer settings unique to certain modules such as MOR.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecModuleCollection

See Also

Reference

ImGearRecModuleCollection Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecModuleCollection Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleCollection Class

The following tables list the members exposed by ImGearRecModuleCollection.

Public Properties
 | Name | Description
Public Property | Asian | Gets Asian module settings.
Public Property | Count | Gets total number of Recognition engine modules.
Public Property | Item | Overloaded. Provides access to a specific module.
Public Property | MOR | Gets MOR module settings.
Top
See Also

Reference

ImGearRecModuleCollection Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecModuleCollection Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleCollection Class

For a list of all members of this type, see ImGearRecModuleCollection members.

Public Properties
 | Name | Description
Public Property | Asian | Gets Asian module settings.
Public Property | Count | Gets total number of Recognition engine modules.
Public Property | Item | Overloaded. Provides access to a specific module.
Public Property | MOR | Gets MOR module settings.
Top
See Also

Reference

ImGearRecModuleCollection Class
ImageGear.Recognition Namespace


Asian Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class : Asian Property
Gets Asian module settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Asian As ImGearRecAsianSettings
'Usage

Dim instance As ImGearRecModuleCollection
Dim value As ImGearRecAsianSettings

value = instance.Asian
public ImGearRecAsianSettings Asian {get;}
public: __property ImGearRecAsianSettings* get_Asian();
public:
property ImGearRecAsianSettings^ Asian {
   ImGearRecAsianSettings^ get();
}

Property Value

ImGearRecAsianSettings class value.
Remarks

This property provides access to the ImGearRecAsianSettings class object, which provides settings specific to the ASN (Asian) module.

See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
ImGearRecAsianSettings Class


Count Property (ImGearRecModuleCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class : Count Property
Gets total number of Recognition engine modules.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearRecModuleCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members


Item Property (ImGearRecModuleCollection)
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class : Item Property
Provides access to a specific module.
Overload List
Overload | Description
Item(Int32) | Provides access to a specific module.
Item(ImGearRecModule) | Provides access to a specific module.
Item(ImGearRecRecognitionModule) | Provides access to a specific module.
Remarks
This property provides access to a specific Recognition engine module given an index. For example, to print the name of the first module:
Example
  • C#
string moduleList = "";
int i;
for (i = 0; i < igRecognition.Modules.Count; i++)
{
    ImGearRecModuleSettings module = igRecognition.Modules[i];
    moduleList += module.Name + "\r\n";
    ImGearRecModule Id = module.ID;
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " +
        igRecognition.Modules[Id].Version + "\r\n";
}
System.Console.WriteLine(moduleList);
  • Visual Basic
Dim moduleList As String = ""
Dim i As Integer
i = 0
While i < igRecognition.Modules.Count
    Dim [module] As ImGearRecModuleSettings = igRecognition.Modules(i)
    moduleList += [module].Name + vbCr & vbLf
    Dim Id As ImGearRecModule = [module].ID
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " + _
    igRecognition.Modules(Id).Version.ToString() + vbCr & vbLf
    System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
End While
System.Console.WriteLine(moduleList)
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
ImGearRecModuleSettings Class


Item(Int32) Property
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class > Item Property : Item(Int32) Property
Module index (from 0 to Count-1).
Provides access to a specific module.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ImGearRecModuleSettings
'Usage

Dim instance As ImGearRecModuleCollection
Dim index As Integer
Dim value As ImGearRecModuleSettings

value = instance.Item(index)
public ImGearRecModuleSettings Item(
   int index
) {get;}
public: __property ImGearRecModuleSettings* get_Item(
   int index
);
public:
property ImGearRecModuleSettings^ Item {
   ImGearRecModuleSettings^ get(int index);
}

Parameters

index
Module index (from 0 to Count-1).

Property Value

ImGearRecModuleSettings class object.
Remarks
This property provides access to a specific Recognition engine module given an index. For example, to print the name of the first module:
Example
  • C#
string moduleList = "";
int i;
for (i = 0; i < igRecognition.Modules.Count; i++)
{
    ImGearRecModuleSettings module = igRecognition.Modules[i];
    moduleList += module.Name + "\r\n";
    ImGearRecModule Id = module.ID;
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " +
        igRecognition.Modules[Id].Version + "\r\n";
}
System.Console.WriteLine(moduleList);
  • Visual Basic
Dim moduleList As String = ""
Dim i As Integer
i = 0
While i < igRecognition.Modules.Count
    Dim [module] As ImGearRecModuleSettings = igRecognition.Modules(i)
    moduleList += [module].Name + vbCr & vbLf
    Dim Id As ImGearRecModule = [module].ID
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " + _
    igRecognition.Modules(Id).Version.ToString() + vbCr & vbLf
    System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
End While
System.Console.WriteLine(moduleList)
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
Overload List
ImGearRecModuleSettings Class


Item(ImGearRecModule) Property
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class > Item Property : Item(ImGearRecModule) Property
Value from the ImGearRecModule enumeration.
Provides access to a specific module.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As ImGearRecModule _
) As ImGearRecModuleSettings
'Usage

Dim instance As ImGearRecModuleCollection
Dim index As ImGearRecModule
Dim value As ImGearRecModuleSettings

value = instance.Item(index)
public ImGearRecModuleSettings Item(
   ImGearRecModule index
) {get;}
public: __property ImGearRecModuleSettings* get_Item(
   ImGearRecModule index
);
public:
property ImGearRecModuleSettings^ Item {
   ImGearRecModuleSettings^ get(ImGearRecModule index);
}

Parameters

index
Value from the ImGearRecModule enumeration.

Property Value

ImGearRecModuleSettings class object.
Remarks
This property provides access to a specific Recognition engine module given the module’s value from the ImGearRecModuleSettings enumeration. For example:
Example
  • C#
string moduleList = "";
int i;
for (i = 0; i < igRecognition.Modules.Count; i++)
{
    ImGearRecModuleSettings module = igRecognition.Modules[i];
    moduleList += module.Name + "\r\n";
    ImGearRecModule Id = module.ID;
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " +
        igRecognition.Modules[Id].Version + "\r\n";
}
System.Console.WriteLine(moduleList);
  • Visual Basic
Dim moduleList As String = ""
Dim i As Integer
i = 0
While i < igRecognition.Modules.Count
    Dim [module] As ImGearRecModuleSettings = igRecognition.Modules(i)
    moduleList += [module].Name + vbCr & vbLf
    Dim Id As ImGearRecModule = [module].ID
    moduleList += "igRecognition.Modules[" + "ImGearRecModule." + Id.ToString() + "].Version = " + _
    igRecognition.Modules(Id).Version.ToString() + vbCr & vbLf
    System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
End While
System.Console.WriteLine(moduleList)
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
Overload List
ImGearRecModuleSettings Class
ImGearRecModule Enumeration


Item(ImGearRecRecognitionModule) Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class > Item Property : Item(ImGearRecRecognitionModule) Property
Value from the ImGearRecRecognitionModule enumeration.
Provides access to a specific module.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As ImGearRecRecognitionModule _
) As ImGearRecModuleSettings
'Usage

Dim instance As ImGearRecModuleCollection
Dim index As ImGearRecRecognitionModule
Dim value As ImGearRecModuleSettings

value = instance.Item(index)
public ImGearRecModuleSettings Item(
   ImGearRecRecognitionModule index
) {get;}
public: __property ImGearRecModuleSettings* get_Item(
   ImGearRecRecognitionModule index
);
public:
property ImGearRecModuleSettings^ Item {
   ImGearRecModuleSettings^ get(ImGearRecRecognitionModule index);
}

Parameters

index
Value from the ImGearRecRecognitionModule enumeration.

Property Value

ImGearRecModuleSettings class object.
Remarks
This property provides access to a specific Recognition engine module given the module’s value from the ImGearRecRecognitionModule enumeration. For example:
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
Overload List
ImGearRecModuleSettings Class
ImGearRecRecognitionModule Enumeration


MOR Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleCollection Class : MOR Property
Gets MOR module settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MOR As ImGearRecMORSettings
'Usage

Dim instance As ImGearRecModuleCollection
Dim value As ImGearRecMORSettings

value = instance.MOR
public ImGearRecMORSettings MOR {get;}
public: __property ImGearRecMORSettings* get_MOR();
public:
property ImGearRecMORSettings^ MOR {
   ImGearRecMORSettings^ get();
}

Property Value

ImGearRecMORSettings class value.
Remarks
This property provides access to the ImGearRecMORSettings class object, which provides settings specific to the MOR (multi-lingual omnifont recognition) module.
See Also

Reference

ImGearRecModuleCollection Class
ImGearRecModuleCollection Members
ImGearRecMORSettings Class


%%PageItemTitle%%

ImGearRecModuleSettings Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleSettings Class
Provides access to information and settings for a recognition module.
Object Model
ImGearRecModuleSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecModuleSettings
'Usage

Dim instance As ImGearRecModuleSettings
public sealed class ImGearRecModuleSettings
public __gc __sealed class ImGearRecModuleSettings
public ref class ImGearRecModuleSettings sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecModuleSettings

See Also

Reference

ImGearRecModuleSettings Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecModuleSettings Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleSettings Class

The following tables list the members exposed by ImGearRecModuleSettings.

Public Properties
 | Name | Description
Public Property | ID | Gets module ID.
Public Property | InitError | Gets the initialization error code of the module.
Public Property | Name | Gets module name.
Public Property | Version | Gets module version number.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ModuleToRecModule | Converts module enum value to recognition module enum value.
static (Shared in Visual Basic) | RecModuleToModule | Converts recognition module enum value to module enum value.
Top
See Also

Reference

ImGearRecModuleSettings Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecModuleSettings Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleSettings Class

For a list of all members of this type, see ImGearRecModuleSettings members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ModuleToRecModule | Converts module enum value to recognition module enum value.
static (Shared in Visual Basic) | RecModuleToModule | Converts recognition module enum value to module enum value.
Top
See Also

Reference

ImGearRecModuleSettings Class
ImageGear.Recognition Namespace


ModuleToRecModule Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : ModuleToRecModule Method
Value from ImGearRecModule enumeration.
Converts module enum value to recognition module enum value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ModuleToRecModule( _
   ByVal module As ImGearRecModule _
) As ImGearRecRecognitionModule
'Usage

Dim module As ImGearRecModule
Dim value As ImGearRecRecognitionModule

value = ImGearRecModuleSettings.ModuleToRecModule(module)
public static ImGearRecRecognitionModule ModuleToRecModule(
   ImGearRecModule module
)
public: static ImGearRecRecognitionModule ModuleToRecModule(
   ImGearRecModule module
)
public:
static ImGearRecRecognitionModule ModuleToRecModule(
   ImGearRecModule module
)

Parameters

module
Value from ImGearRecModule enumeration.

Return Value

ImGearRecRecognitionModule enumeration value.
Remarks
This utility method converts a value from the general ImGearRecModule enumeration to the more specific ImGearRecRecognitionModule enumeration.
See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members
ImGearRecRecognitionModule Enumeration
ImGearRecModule Enumeration


RecModuleToModule Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : RecModuleToModule Method
Value from ImGearRecRecognitionModule enumeration.
Converts recognition module enum value to module enum value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function RecModuleToModule( _
   ByVal recognitionModule As ImGearRecRecognitionModule _
) As ImGearRecModule
'Usage

Dim recognitionModule As ImGearRecRecognitionModule
Dim value As ImGearRecModule

value = ImGearRecModuleSettings.RecModuleToModule(recognitionModule)
public static ImGearRecModule RecModuleToModule(
   ImGearRecRecognitionModule recognitionModule
)
public: static ImGearRecModule RecModuleToModule(
   ImGearRecRecognitionModule recognitionModule
)
public:
static ImGearRecModule RecModuleToModule(
   ImGearRecRecognitionModule recognitionModule
)

Parameters

recognitionModule
Value from ImGearRecRecognitionModule enumeration.

Return Value

ImGearRecModule enumeration value.
Remarks
This utility method converts a value from the specific ImGearRecRecognitionModule enumeration to the more general ImGearRecModule enumeration.
See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members
ImGearRecRecognitionModule Enumeration
ImGearRecModule Enumeration


%%PageItemTitle%% $$Properties$$

ImGearRecModuleSettings Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModuleSettings Class

For a list of all members of this type, see ImGearRecModuleSettings members.

Public Properties
 | Name | Description
Public Property | ID | Gets module ID.
Public Property | InitError | Gets the initialization error code of the module.
Public Property | Name | Gets module name.
Public Property | Version | Gets module version number.
Top
See Also

Reference

ImGearRecModuleSettings Class
ImageGear.Recognition Namespace


ID Property (ImGearRecModuleSettings)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : ID Property
Gets module ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As ImGearRecModule
'Usage

Dim instance As ImGearRecModuleSettings
Dim value As ImGearRecModule

value = instance.ID
public ImGearRecModule ID {get;}
public: __property ImGearRecModule get_ID();
public:
property ImGearRecModule ID {
   ImGearRecModule get();
}

Property Value

ImGearRecModule enumeration value.
Remarks
This property returns a value from the ImGearRecModule enumeration, so that the module can be identified in code.
See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members
ImGearRecModule Enumeration


InitError Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : InitError Property
Gets the initialization error code of the module.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InitError As ImGearRecErrorCodes
'Usage

Dim instance As ImGearRecModuleSettings
Dim value As ImGearRecErrorCodes

value = instance.InitError
public ImGearRecErrorCodes InitError {get;}
public: __property ImGearRecErrorCodes get_InitError();
public:
property ImGearRecErrorCodes InitError {
   ImGearRecErrorCodes get();
}

Property Value

ImGearRecErrorCodes enumeration value.
Remarks
When the ImGearRecognition class object is instantiated, the recognition engine tries to initialize all its modules.

When a module (or one of its important files) is missing, the initialization of that module will fail. E.g., if the DOT module's basic module DLL file, RNDOT.DLL is missing, neither this module nor its service (9-pin dot-matrix recognition) will be available. When there is no license for a module, even if all the files of the module are present in the Recognition engine binary directory, the initialization of that module will fail. Such failures are indicated by this property.

If a module was initialized successfully, this property will be REC_OK.

See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members
ImGearRecErrorCodes Enumeration


Name Property (ImGearRecModuleSettings)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : Name Property
Gets module name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearRecModuleSettings
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members


Version Property (ImGearRecModuleSettings)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecModuleSettings Class : Version Property
Gets module version number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Version As Integer
'Usage

Dim instance As ImGearRecModuleSettings
Dim value As Integer

value = instance.Version
public int Version {get;}
public: __property int get_Version();
public:
property int Version {
   int get();
}

Property Value

Integer value.
Remarks
This property returns the module version. The version is encoded as an integer. For example, version 12.7 is reported as 1270. Version 3.43 is reported as 343.
See Also

Reference

ImGearRecModuleSettings Class
ImGearRecModuleSettings Members


%%PageItemTitle%%

ImGearRecMORSettings Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecMORSettings Class
Provides access to settings specific to the MOR (multi-lingual omnifont recognition) recognition module.
Object Model
ImGearRecMORSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecMORSettings
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecMORSettings
public sealed class ImGearRecMORSettings : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecMORSettings : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecMORSettings sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
This object provides access to settings specific to the MOR (multi-lingual omnifont recognition) recognition module.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecMORSettings

See Also

Reference

ImGearRecMORSettings Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecMORSettings Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecMORSettings Class

The following tables list the members exposed by ImGearRecMORSettings.

Public Properties
 | Name | Description
Public Property | IsFaxed | Gets or sets a value indicating whether fax mode for MOR module is enabled or disabled.
Top
See Also

Reference

ImGearRecMORSettings Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecMORSettings Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecMORSettings Class

For a list of all members of this type, see ImGearRecMORSettings members.

Public Properties
 | Name | Description
Public Property | IsFaxed | Gets or sets a value indicating whether fax mode for MOR module is enabled or disabled.
Top
See Also

Reference

ImGearRecMORSettings Class
ImageGear.Recognition Namespace


IsFaxed Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecMORSettings Class : IsFaxed Property
Gets or sets a value indicating whether fax mode for MOR module is enabled or disabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsFaxed As Boolean
'Usage

Dim instance As ImGearRecMORSettings
Dim value As Boolean

instance.IsFaxed = value

value = instance.IsFaxed
public bool IsFaxed {get; set;}
public: __property bool get_IsFaxed();
public: __property void set_IsFaxed(
   bool value
);
public:
property bool IsFaxed {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Enables/disables fax mode for the MOR module.

Set this property to true if the image file to be recognized is a fax message transmitted in "Draft" mode with 200 x 100 resolution. Its use is not recommended for reading fax card image files transmitted in "Fine" mode (200 x 200 dpi resolution).

See Also

Reference

ImGearRecMORSettings Class
ImGearRecMORSettings Members


%%PageItemTitle%%

ImGearRecognition Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecognition Class
Represents the recognition engine.
Object Model
ImGearRecognition ClassImGearRecPage ClassImGearRecModuleCollection ClassImGearRecOutputManager ClassImGearRecPreprocessingSettings ClassImGearRecRecognitionSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecognition
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecognition
public sealed class ImGearRecognition : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecognition : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecognition sealed : public ImGearRecSettingsCollectionObjectBase
Remarks

This object provides access to the Recognition engine. An application must first instantiate this object in order to perform any recognition tasks. Multiple instances of this object can exist within a process, though only the first instance will initialize the underlying native Recognition engine, and all subsequent instances will obtain a reference to it. The last instance that explicity calls its Dispose method or is cleaned up from garbage collection will shut down the Recongition engine.

While all instances of this object will access the same underlying Recognition engine, each instance operates on its own set of pages and documents. Each instance can use the shared global collection of Recognition settings by instantiating it with the default constructor. This means that changing settings (e.g. ImGearRecOutputManager.Format) in one instance will affect all other instances using the global settings. To isolate the Recognition settings for each instance, use the overloaded constructor, ImGearRecognition Constructor(Boolean). This will force each instance to use its own collection of unique settings.

Multiple instances of this object can be used in separate threads to perform recognition activities on different images and pages in parallel. However, it is important to remember that for each page, the recognition process must occur sequentially, meaning that a page must first be imported and pre-processed before it can be recognized and exported. Also, access to the underlying formatted output module is synchronized, so only one instance can export to a formatted output document at a time.

Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecognition

See Also

Reference

ImGearRecognition Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecognition Class Members
Properties Methods Events

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecognition Class

The following tables list the members exposed by ImGearRecognition.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecognition Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Modules | Gets access to collection of modules in the Recognition engine.
Public Property | OutputManager | Gets access to methods and properties that are related to the output of recognized data.
Public Property | Preprocessing | Gets access to preprocessing settings.
Public Property | Recognition | Gets access to recognition settings.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Shuts down the recognition engine or releases its reference to it if there are other ImGearRecognition instances remaining.
Public Method | ImportPage | Imports an ImGearRasterPage into the recognition engine.
Public Method | IsFeatureLicensed | Returns whether or not a given recognition feature is licensed.
Public Method | LoadSettings | Loads recognition settings from a file.
Public Method | ResetToDefaultSettings | Resets all recognition engine settings to their original, default values.
Public Method | SaveSettings | Saves recognition settings to a file.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecognition class.
Top
Public Events
 | Name | Description
Public Event | Progress | Event fired during recognition processes to indicate progress and make it possible to abort.
Top
See Also

Reference

ImGearRecognition Class
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecognition Constructor

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : ImGearRecognition Constructor
Overload List
Overload | Description
ImGearRecognition Constructor() | Initializes a new instance of the ImGearRecognition class.
ImGearRecognition Constructor(String) | Initializes a new instance of the ImGearRecognition class and specifies a path to load the native Recognition libraries and resources from.
ImGearRecognition Constructor(Boolean) | Initializes a new instance of the ImGearRecognition class and specifies whether it should create its own unique collection of Recognition settings or use the shared global settings.
ImGearRecognition Constructor(String,Boolean) | Initializes a new instance of the ImGearRecognition class and specifies whether it should create its own unique collection of Recognition settings or use the shared global settings.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


%%PageItemTitle%%

ImGearRecognition Constructor()

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class > ImGearRecognition Constructor : ImGearRecognition Constructor()
Initializes a new instance of the ImGearRecognition class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecognition()
public ImGearRecognition()
public: ImGearRecognition();
public:
ImGearRecognition();
Remarks

The native Recognition engine is initialized during this constructor, unless it has already been initialized by a previously created instance, in which case a reference to the engine is obtained.

Each instance created by this constructor will access the shared global collection of Recognition settings. This means that changing settings (e.g. ImGearRecOutputManager.Format) in one instance will affect all other instances using the global settings. To isolate the Recognition settings for each instance, use the overloaded constructor, ImGearRecognition Constructor(Boolean). This will force each instance to use its own collection of settings.

An application should use exception handling to catch any exceptions thrown by this constructor.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
Overload List
ImGearRecognition Class


%%PageItemTitle%%

ImGearRecognition Constructor(String)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class > ImGearRecognition Constructor : ImGearRecognition Constructor(String)
Path to load the native Recognition libraries and resources from.
Initializes a new instance of the ImGearRecognition class and specifies a path to load the native Recognition libraries and resources from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal resourcePath As String _
)
'Usage

Dim resourcePath As String

Dim instance As New ImGearRecognition(resourcePath)
public ImGearRecognition(
   string resourcePath
)
public: ImGearRecognition(
   string* resourcePath
)
public:
ImGearRecognition(
   String^ resourcePath
)

Parameters

resourcePath
Path to load the native Recognition libraries and resources from.
Remarks

The native Recognition engine is initialized during this constructor, unless it has already been initialized by a previously created instance, in which case a reference to the engine is obtained.

resourcePath is used to specify where the native Recognition libraries and resource files are located.

Each instance created by this constructor will access the shared global collection of Recognition settings. This means that changing settings (e.g. ImGearRecOutputManager.Format) in one instance will affect all other instances using the global settings. To isolate the Recognition settings for each instance, use the overloaded constructor, ImGearRecognition Constructor(Boolean). This will force each instance to use its own collection of settings.

An application should use exception handling to catch any exceptions thrown by this constructor.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
Overload List
ImGearRecognition Class


%%PageItemTitle%%

ImGearRecognition Constructor(Boolean)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class > ImGearRecognition Constructor : ImGearRecognition Constructor(Boolean)
Indicates whether the new instance creates its own unique collection of Recognition engine settings, or uses the shared global settings.
Initializes a new instance of the ImGearRecognition class and specifies whether it should create its own unique collection of Recognition settings or use the shared global settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal createUnique As Boolean _
)
'Usage

Dim createUnique As Boolean

Dim instance As New ImGearRecognition(createUnique)
public ImGearRecognition(
   bool createUnique
)
public: ImGearRecognition(
   bool createUnique
)
public:
ImGearRecognition(
   bool createUnique
)

Parameters

createUnique
Indicates whether the new instance creates its own unique collection of Recognition engine settings, or uses the shared global settings.
Remarks

The native Recognition engine is initialized during this constructor, unless it has already been initialized by a previously created instance, in which case a reference to the engine is obtained.

If createUnique is true, each instance created by this constructor will create and access its own unique collection of Recognition settings. If false, the new instance will use the global collection of Recognition settings that is shared by all other non-unique instances created in the same process.

An application should use exception handling to catch any exceptions thrown by this constructor.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
Overload List
ImGearRecognition Class


%%PageItemTitle%%

ImGearRecognition Constructor(String,Boolean)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class > ImGearRecognition Constructor : ImGearRecognition Constructor(String,Boolean)
Path to load the native Recognition libraries and resources from.
Indicates whether the new instance creates its own unique collection of Recognition engine settings, or uses the shared global settings.
Initializes a new instance of the ImGearRecognition class and specifies whether it should create its own unique collection of Recognition settings or use the shared global settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal resourcePath As String, _
   ByVal createUnique As Boolean _
)
'Usage

Dim resourcePath As String
Dim createUnique As Boolean

Dim instance As New ImGearRecognition(resourcePath, createUnique)
public ImGearRecognition(
   string resourcePath,
   bool createUnique
)
public: ImGearRecognition(
   string* resourcePath,
   bool createUnique
)
public:
ImGearRecognition(
   String^ resourcePath,
   bool createUnique
)

Parameters

resourcePath
Path to load the native Recognition libraries and resources from.
createUnique
Indicates whether the new instance creates its own unique collection of Recognition engine settings, or uses the shared global settings.
Remarks

The native Recognition engine is initialized during this constructor, unless it has already been initialized by a previously created instance, in which case a reference to the engine is obtained.

resourcePath is used to specify where the native Recognition libraries and resource files are located.

If createUnique is true, each instance created by this constructor will create and access its own unique collection of Recognition settings. If false, the new instance will use the global collection of Recognition settings that is shared by all other non-unique instances created in the same process.

An application should use exception handling to catch any exceptions thrown by this constructor.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
Overload List
ImGearRecognition Class


Dispose Method (ImGearRecognition)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Dispose Method
Shuts down the recognition engine or releases its reference to it if there are other ImGearRecognition instances remaining.
Overload List
Overload | Description
Dispose | Shuts down the recognition engine or releases its reference to it if there are other ImGearRecognition instances remaining.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


%%PageItemTitle%% $$Methods$$

ImGearRecognition Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecognition Class

For a list of all members of this type, see ImGearRecognition members.

Public Methods
 | Name | Description
Public Method | Dispose | Shuts down the recognition engine or releases its reference to it if there are other ImGearRecognition instances remaining.
Public Method | ImportPage | Imports an ImGearRasterPage into the recognition engine.
Public Method | IsFeatureLicensed | Returns whether or not a given recognition feature is licensed.
Public Method | LoadSettings | Loads recognition settings from a file.
Public Method | ResetToDefaultSettings | Resets all recognition engine settings to their original, default values.
Public Method | SaveSettings | Saves recognition settings to a file.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecognition class.
Top
See Also

Reference

ImGearRecognition Class
ImageGear.Recognition Namespace


Dispose() Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Dispose() Method
Shuts down the recognition engine or releases its reference to it if there are other ImGearRecognition instances remaining.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearRecognition

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks

This is a standard .NET Dispose method for the ImGearRecognition object. It shuts down the Recognition engine, freeing its associated native resources. The application should ensure that any ImGearRecPage class objects have been disposed before calling this method. After this method has been called, the application should refrain from accessing any methods or properties of ImGearRecognition or any associated objects.

If there are multiple instances of the ImGearRecognition object in your process, only the last remaining instance will shut down the native Recognition engine. This way you can dispose of instances when they are no longer needed and the remaining instances will continue functioning as normal.

It is acceptable to call this Dispose method, instantiate a new ImGearRecognition object, and then use that object.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecPage Class


Finalize Method (ImGearRecognition)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Finalize Method
Finalizes an instance of the ImGearRecognition class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearRecognition

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


ImportPage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : ImportPage Method
ImageGear.Core.ImGearRasterPage object to import into the Recognition engine.
Imports an ImGearRasterPage into the recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ImportPage( _
   ByVal page As ImGearRasterPage _
) As ImGearRecPage
'Usage

Dim instance As ImGearRecognition
Dim page As ImGearRasterPage
Dim value As ImGearRecPage

value = instance.ImportPage(page)
public ImGearRecPage ImportPage(
   ImGearRasterPage page
)
public: ImGearRecPage* ImportPage(
   ImGearRasterPage* page
)
public:
ImGearRecPage^ ImportPage(
   ImGearRasterPage^ page
)

Parameters

page
ImageGear.Core.ImGearRasterPage object to import into the Recognition engine.

Return Value

New ImGearRecPage instance.
Remarks
This method imports an image from ImageGear into the Recognition engine. This step is necessary before any recognition tasks can be performed on an image.

There are a few requirements that an image must meet in order to be successfully imported into the Recognition engine:

  • The image must be a raster image, hence the ImageGear.Core.ImGearRasterPage type of the input parameter. You can cast from ImGearPage to ImGearRasterPage when calling this method, as long as the image is a raster image.
  • The image must have correct resolution information. Allowed range for the resolution is 75 to 2400 DPI. The best resolution for B/W images is 300 or 400 dpi. For grayscale or color images the optimal recogniton resolution is 150 to 300 dpi. Some recognition modules apply additional restrictions on image resolution or physical size. See Specifications for the Recognition Modules section for more information.
  • For B/W images, both the image width and height must not exceed 32000 pixels. For other types of images, both the image width and height must be within 16 and 8400 pixels.
  • To allow saving recognized data to Microsoft Word formats both the physical width and height of the image (defined by image resolution and pixel dimensions) must be between 0.1 and 22 inches.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecPage Class
ImGearRasterPage Class


IsFeatureLicensed Method (ImGearRecognition)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : IsFeatureLicensed Method
Feature to be verified.
Returns whether or not a given recognition feature is licensed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsFeatureLicensed( _
   ByVal feature As ImGearRecLicenseFeature _
) As Boolean
'Usage

Dim instance As ImGearRecognition
Dim feature As ImGearRecLicenseFeature
Dim value As Boolean

value = instance.IsFeatureLicensed(feature)
public bool IsFeatureLicensed(
   ImGearRecLicenseFeature feature
)
public: bool IsFeatureLicensed(
   ImGearRecLicenseFeature feature
)
public:
bool IsFeatureLicensed(
   ImGearRecLicenseFeature feature
)

Parameters

feature
Feature to be verified.

Return Value

True if the feature is licensed, False - otherwise.
Remarks
Verifies whether a Recognition feature is licensed or not.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecLicenseFeature Enumeration


LoadSettings Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : LoadSettings Method
Path to the file to load the settings from.
Loads recognition settings from a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LoadSettings( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecognition
Dim path As String

instance.LoadSettings(path)
public void LoadSettings(
   string path
)
public: void LoadSettings(
   string* path
)
public:
void LoadSettings(
   String^ path
)

Parameters

path
Path to the file to load the settings from.
Remarks
This method loads recognition settings from a settings file previously created with the SaveSettings method.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


ResetToDefaultSettings Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : ResetToDefaultSettings Method
Resets all recognition engine settings to their original, default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ResetToDefaultSettings()
'Usage

Dim instance As ImGearRecognition

instance.ResetToDefaultSettings()
public void ResetToDefaultSettings()
public: void ResetToDefaultSettings();
public:
void ResetToDefaultSettings();
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


SaveSettings Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : SaveSettings Method
Path to the file to save the settings in.
Saves recognition settings to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SaveSettings( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecognition
Dim path As String

instance.SaveSettings(path)
public void SaveSettings(
   string path
)
public: void SaveSettings(
   string* path
)
public:
void SaveSettings(
   String^ path
)

Parameters

path
Path to the file to save the settings in.
Remarks
This method saves all the current settings of the recognition engine to a Settings file for storing or studying purposes. A recognition engine Settings file can be loaded any time with the LoadSettings method.

Though the recognition engine Settings file is an ASCII text file, DO NOT MODIFY IT since once it becomes corrupted it will not be loaded at all, and there is no way to learn which line has caused the problem.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members


%%PageItemTitle%% $$Properties$$

ImGearRecognition Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecognition Class

For a list of all members of this type, see ImGearRecognition members.

Public Properties
 | Name | Description
Public Property | Modules | Gets access to collection of modules in the Recognition engine.
Public Property | OutputManager | Gets access to methods and properties that are related to the output of recognized data.
Public Property | Preprocessing | Gets access to preprocessing settings.
Public Property | Recognition | Gets access to recognition settings.
Top
See Also

Reference

ImGearRecognition Class
ImageGear.Recognition Namespace


Modules Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Modules Property
Gets access to collection of modules in the Recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Modules As ImGearRecModuleCollection
'Usage

Dim instance As ImGearRecognition
Dim value As ImGearRecModuleCollection

value = instance.Modules
public ImGearRecModuleCollection Modules {get;}
public: __property ImGearRecModuleCollection* get_Modules();
public:
property ImGearRecModuleCollection^ Modules {
   ImGearRecModuleCollection^ get();
}

Property Value

ImGearRecModuleCollection class object.
Remarks
Collection of modules can be used to retrieve information about each module. It can also be used to set certain module-specific settings.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecModuleCollection Class


OutputManager Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : OutputManager Property
Gets access to methods and properties that are related to the output of recognized data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutputManager As ImGearRecOutputManager
'Usage

Dim instance As ImGearRecognition
Dim value As ImGearRecOutputManager

value = instance.OutputManager
public ImGearRecOutputManager OutputManager {get;}
public: __property ImGearRecOutputManager* get_OutputManager();
public:
property ImGearRecOutputManager^ OutputManager {
   ImGearRecOutputManager^ get();
}

Property Value

ImGearRecOutputManager class object.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecOutputManager Class


Preprocessing Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Preprocessing Property
Gets access to preprocessing settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Preprocessing As ImGearRecPreprocessingSettings
'Usage

Dim instance As ImGearRecognition
Dim value As ImGearRecPreprocessingSettings

value = instance.Preprocessing
public ImGearRecPreprocessingSettings Preprocessing {get;}
public: __property ImGearRecPreprocessingSettings* get_Preprocessing();
public:
property ImGearRecPreprocessingSettings^ Preprocessing {
   ImGearRecPreprocessingSettings^ get();
}

Property Value

ImGearRecPreprocessingSettings class object.
Remarks
These settings can be used to control how the Recognition engine performs preprocessing on images prior to performing recognition.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecPreprocessingSettings Class


Recognition Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Recognition Property
Gets access to recognition settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Recognition As ImGearRecRecognitionSettings
'Usage

Dim instance As ImGearRecognition
Dim value As ImGearRecRecognitionSettings

value = instance.Recognition
public ImGearRecRecognitionSettings Recognition {get;}
public: __property ImGearRecRecognitionSettings* get_Recognition();
public:
property ImGearRecRecognitionSettings^ Recognition {
   ImGearRecRecognitionSettings^ get();
}

Property Value

ImGearRecRecognitionSettings class object.
Remarks
These settings are related to the page decomposition, layout detection, and recognition tasks.
See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecRecognitionSettings Class


%%PageItemTitle%% $$Events$$

ImGearRecognition Class Events

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecognition Class

For a list of all members of this type, see ImGearRecognition members.

Public Events
 | Name | Description
Public Event | Progress | Event fired during recognition processes to indicate progress and make it possible to abort.
Top
See Also

Reference

ImGearRecognition Class
ImageGear.Recognition Namespace


Progress Event

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecognition Class : Progress Event
Event fired during recognition processes to indicate progress and make it possible to abort.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Progress As ImGearRecProgressEventHandler
'Usage

Dim instance As ImGearRecognition
Dim handler As ImGearRecProgressEventHandler

AddHandler instance.Progress, handler
public event ImGearRecProgressEventHandler Progress
public: __event ImGearRecProgressEventHandler* Progress
public:
event ImGearRecProgressEventHandler^ Progress
Event Data

The event handler receives an argument of type ImGearRecProgressEventArgs containing data related to this event. The following ImGearRecProgressEventArgs properties provide information specific to this event.

Property | Description
Abort | Gets or sets a value indicating whether the current sequence of recognition tasks aborted or not.
Percent | Gets percent completion (from 0 to 100) of the current recognition task.
Process | Gets process identifier of the current recognition task.
Remarks
This event is fired during various recognition processes. It can be used by an application to monitor which recognition process is being performed as well as percent completion on an individual process. It can also be used to abort a recognition process, if the application's event handler sets the ImGearRecProgressEventArgs.Abort property of the event arguments object ImGearRecProgressEventArgs class to true.

Only a minimal amount of work should be performed in the event handler for this event. The application must not access any recognition objects from the event handler other than the ImGearRecProgressEventArgs class argument.

See the documentation for ImGearRecProgressEventHandler delegate for an example of how to use this event.

See Also

Reference

ImGearRecognition Class
ImGearRecognition Members
ImGearRecProgressEventHandler Delegate


%%PageItemTitle%%

ImGearRecOutputFormatCollection Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormatCollection Class
Collection of ImGearRecOutputFormat objects (output formats for writing recognition output).
Object Model
ImGearRecOutputFormatCollection ClassImGearRecOutputFormat Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearRecOutputFormatCollection
'Usage

Dim instance As ImGearRecOutputFormatCollection
[DefaultMember("Item")]
public sealed class ImGearRecOutputFormatCollection
[DefaultMember("Item")]
public __gc __sealed class ImGearRecOutputFormatCollection
[DefaultMember("Item")]
public ref class ImGearRecOutputFormatCollection sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecOutputFormatCollection

See Also

Reference

ImGearRecOutputFormatCollection Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecOutputFormatCollection Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormatCollection Class

The following tables list the members exposed by ImGearRecOutputFormatCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets total number of available output formats.
Public Property | Item | Provides access to an ImGearRecOutputFormat structure object for a particular output format.
Top
See Also

Reference

ImGearRecOutputFormatCollection Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecOutputFormatCollection Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormatCollection Class

For a list of all members of this type, see ImGearRecOutputFormatCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets total number of available output formats.
Public Property | Item | Provides access to an ImGearRecOutputFormat structure object for a particular output format.
Top
See Also

Reference

ImGearRecOutputFormatCollection Class
ImageGear.Recognition Namespace


Count Property (ImGearRecOutputFormatCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputFormatCollection Class : Count Property
Gets total number of available output formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearRecOutputFormatCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecOutputFormatCollection Class
ImGearRecOutputFormatCollection Members


Item Property (ImGearRecOutputFormatCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputFormatCollection Class : Item Property
Index of output format (from 0 to Count - 1).
Provides access to an ImGearRecOutputFormat structure object for a particular output format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ImGearRecOutputFormat
'Usage

Dim instance As ImGearRecOutputFormatCollection
Dim index As Integer
Dim value As ImGearRecOutputFormat

value = instance.Item(index)
public ImGearRecOutputFormat this[
   int index
]; {get;}
public: __property ImGearRecOutputFormat get_Item   int index
;
public:
property ImGearRecOutputFormat default [int] {
   ImGearRecOutputFormat get(int index);
}

Parameters

index
Index of output format (from 0 to Count - 1).

Property Value

ImGearRecOutputFormat structure value.
Remarks
This property provides access to an ImGearRecOutputFormat structure object for a particular output format. This object can be used to retrieve information about the output format.
See Also

Reference

ImGearRecOutputFormatCollection Class
ImGearRecOutputFormatCollection Members
ImGearRecOutputFormat Structure


%%PageItemTitle%%

ImGearRecOutputManager Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputManager Class
Provides access to output settings and methods to output recognized data.
Object Model
ImGearRecOutputManager ClassImGearRecCodePageCollection ClassImGearRecDocument ClassImGearRecOutputFormatCollection ClassImGearRecDocument Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecOutputManager
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecOutputManager
public sealed class ImGearRecOutputManager : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecOutputManager : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecOutputManager sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
Belongs to ImGearRecognition class object.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecOutputManager

See Also

Reference

ImGearRecOutputManager Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecOutputManager Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputManager Class

The following tables list the members exposed by ImGearRecOutputManager.

Public Properties
 | Name | Description
Public Property | CodePage | Gets or sets the Code Page used for output and character conversion.
Public Property | CodePages | Gets collection of available Code Pages for output.
Public Property | DirectTextFormat | Gets or sets direct text format for ImGearRecOutputManager.WriteDirectText methods.
Public Property | Format | Gets or sets format used for output.
Public Property | Formats | Gets collection of available output formats.
Public Property | Level | Gets or sets the level of format retention for the final output document.
Public Property | MissingSymbol | Gets or sets character used for output characters which are missing in the current Code Page.
Public Property | OutOfCodePageCharacters | Gets characters validated for recognition but not available in current Code Page.
Public Property | RejectionSymbol | Gets or sets character used for rejected characters in output.
Top
Public Methods
 | Name | Description
Public Method | ConvertCodePageToUnicode | Converts character from Code Page to Unicode.
Public Method | ConvertUnicodeToCodePage | Converts character from Unicode to Code Page.
Public Method | CreateDocument | Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Public Method | OpenDocument | Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Public Method | WriteDirectText | Overloaded. Writes the recognition data of the page to the file in the direct text format.
Public Method | WriteDocument | Saves a document to the specified file according to the current conversion settings.
Top
See Also

Reference

ImGearRecOutputManager Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecOutputManager Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputManager Class

For a list of all members of this type, see ImGearRecOutputManager members.

Public Methods
 | Name | Description
Public Method | ConvertCodePageToUnicode | Converts character from Code Page to Unicode.
Public Method | ConvertUnicodeToCodePage | Converts character from Unicode to Code Page.
Public Method | CreateDocument | Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Public Method | OpenDocument | Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Public Method | WriteDirectText | Overloaded. Writes the recognition data of the page to the file in the direct text format.
Public Method | WriteDocument | Saves a document to the specified file according to the current conversion settings.
Top
See Also

Reference

ImGearRecOutputManager Class
ImageGear.Recognition Namespace


ConvertCodePageToUnicode Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : ConvertCodePageToUnicode Method
Character (Code Page value) to be converted to Unicode.
Converts character from Code Page to Unicode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertCodePageToUnicode( _
   ByVal value As Byte _
) As Char
'Usage

Dim instance As ImGearRecOutputManager
Dim value As Byte
Dim value As Char

value = instance.ConvertCodePageToUnicode(value)
public char ConvertCodePageToUnicode(
   byte value
)
public: char ConvertCodePageToUnicode(
   byte value
)
public:
char ConvertCodePageToUnicode(
   byte value
)

Parameters

value
Character (Code Page value) to be converted to Unicode.

Return Value

Unicode string.
Remarks
Converts a character from the current, single-byte Code Page (specified by CodePage property) to Unicode.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


ConvertUnicodeToCodePage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : ConvertUnicodeToCodePage Method
Unicode character to be converted to the current Code Page.
Converts character from Unicode to Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertUnicodeToCodePage( _
   ByVal value As Char _
) As Byte
'Usage

Dim instance As ImGearRecOutputManager
Dim value As Char
Dim value As Byte

value = instance.ConvertUnicodeToCodePage(value)
public byte ConvertUnicodeToCodePage(
   char value
)
public: byte ConvertUnicodeToCodePage(
   char value
)
public:
byte ConvertUnicodeToCodePage(
   char value
)

Parameters

value
Unicode character to be converted to the current Code Page.

Return Value

Code Page character code byte.
Remarks
Converts a character from Unicode to the current, single-byte Code Page (specified by CodePage property).
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


CreateDocument Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : CreateDocument Method
Specifies the intermediate data file. If this parameter is null or equal to "", then the file name will be generated automatically.
Creates a new instance of the ImGearRecDocument class. A null or empty string argument is valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateDocument( _
   ByVal dataFilePath As String _
) As ImGearRecDocument
'Usage

Dim instance As ImGearRecOutputManager
Dim dataFilePath As String
Dim value As ImGearRecDocument

value = instance.CreateDocument(dataFilePath)
public ImGearRecDocument CreateDocument(
   string dataFilePath
)
public: ImGearRecDocument* CreateDocument(
   string* dataFilePath
)
public:
ImGearRecDocument^ CreateDocument(
   String^ dataFilePath
)

Parameters

dataFilePath
Specifies the intermediate data file. If this parameter is null or equal to "", then the file name will be generated automatically.

Return Value

New instance of ImGearRecDocument class object.
Remarks

This method throws ImageGear.Core.ImGearException with error code ImageGear.Core.ImGearErrorCodes.NOT_LICENSED if the ImGearRecLicenseFeature.FormattedOutput feature is not licensed.

See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


OpenDocument Method (ImGearRecOutputManager)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : OpenDocument Method
Specifies the valid data file to be copied into the document class object.
Creates a new instance of the ImGearRecDocument class and fills it with data from the specified data file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function OpenDocument( _
   ByVal dataFilePath As String _
) As ImGearRecDocument
'Usage

Dim instance As ImGearRecOutputManager
Dim dataFilePath As String
Dim value As ImGearRecDocument

value = instance.OpenDocument(dataFilePath)
public ImGearRecDocument OpenDocument(
   string dataFilePath
)
public: ImGearRecDocument* OpenDocument(
   string* dataFilePath
)
public:
ImGearRecDocument^ OpenDocument(
   String^ dataFilePath
)

Parameters

dataFilePath
Specifies the valid data file to be copied into the document class object.

Return Value

New instance of ImGearRecDocument class object.
Remarks

This method throws ImageGear.Core.ImGearException with error code ImageGear.Core.ImGearErrorCodes.NOT_LICENSED if the ImGearRecLicenseFeature.FormattedOutput feature is not licensed.

See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


WriteDirectText Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : WriteDirectText Method
Writes the recognition data of the page to the file in the direct text format.
Overload List
Overload | Description
WriteDirectText(ImGearRecPage,String) | Writes the recognition data of the page to the file in the direct text format.
WriteDirectText(ImGearRecPage[],String) | Writes the recognition data of several pages to the file in the direct text format.
WriteDirectText(ImGearRecPage,Stream) | Writes the recognition data of the page to the output stream in the direct text format.
WriteDirectText(ImGearRecPage[],Stream) | Writes the recognition data of several pages to the output stream in the direct text format.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


WriteDirectText(ImGearRecPage,String) Method
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class > WriteDirectText Method : WriteDirectText(ImGearRecPage,String) Method
ImGearRecPage object with the valid recognition data to be saved.
File to save recognition data to.
Writes the recognition data of the page to the file in the direct text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteDirectText( _
   ByVal page As ImGearRecPage, _
   ByVal file As String _
)
'Usage

Dim instance As ImGearRecOutputManager
Dim page As ImGearRecPage
Dim file As String

instance.WriteDirectText(page, file)
public void WriteDirectText(
   ImGearRecPage page,
   string file
)
public: void WriteDirectText(
   ImGearRecPage* page,
   string* file
)
public:
void WriteDirectText(
   ImGearRecPage^ page,
   String^ file
)

Parameters

page
ImGearRecPage object with the valid recognition data to be saved.
file
File to save recognition data to.
Remarks
Use DirectTextFormatto get or set the output format. If file parameter specifies an existing file name, the text outputs are appended.
Example
  • C#
using (FileStream content = new FileStream("test1.tif", FileMode.Open))
{
    ImGearPage igPage = ImGearFileFormats.LoadPage(content, 0);
    ImGearRecPage recPage = igRecognition.ImportPage((ImGearRasterPage)igPage);
    recPage.Image.Preprocess();
    recPage.Recognize();

    igRecognition.OutputManager.CodePage = "Windows ANSI";
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText;
    if (File.Exists("singlePage.TXT"))
    {
        File.Delete("singlePage.TXT");
    }
    igRecognition.OutputManager.WriteDirectText(recPage, "singlePage.TXT");
    recPage.Dispose();
}
  • Visual Basic
Using content As New FileStream("test1.tif", FileMode.Open)
    Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, 0)
    Dim recPage As ImGearRecPage = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
    recPage.Image.Preprocess()
    recPage.Recognize()

    igRecognition.OutputManager.CodePage = "Windows ANSI"
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText
    If File.Exists("singlePage.TXT") Then
        File.Delete("singlePage.TXT")
    End If
    igRecognition.OutputManager.WriteDirectText(recPage, "singlePage.TXT")
    recPage.Dispose()
End Using
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
Overload List


WriteDirectText(ImGearRecPage[],String) Method
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class > WriteDirectText Method : WriteDirectText(ImGearRecPage[],String) Method
Array of ImGearRecPage objects with the valid recognition data to be saved.
File to save recognition data to.
Writes the recognition data of several pages to the file in the direct text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteDirectText( _
   ByVal pages() As ImGearRecPage, _
   ByVal file As String _
)
'Usage

Dim instance As ImGearRecOutputManager
Dim pages() As ImGearRecPage
Dim file As String

instance.WriteDirectText(pages, file)
public void WriteDirectText(
   ImGearRecPage[] pages,
   string file
)
public: void WriteDirectText(
   ImGearRecPage*[]* pages,
   string* file
)
public:
void WriteDirectText(
   array<ImGearRecPage^>^ pages,
   String^ file
)

Parameters

pages
Array of ImGearRecPage objects with the valid recognition data to be saved.
file
File to save recognition data to.
Remarks
Use DirectTextFormat to get or set the output format. If file parameter specifies an existing file name, the text outputs are appended.
Example
  • C#
using (FileStream content = new FileStream("MULTIPAG.TIF", FileMode.Open))
{
    int numPages = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN);
    int i;
    ImGearRecPage[] pages = new ImGearRecPage[numPages];
    for (i = 0; i < numPages; i++)
    {
        ImGearPage igPage = ImGearFileFormats.LoadPage(content, i);
        pages[i] = igRecognition.ImportPage((ImGearRasterPage)igPage);
        pages[i].Image.Preprocess();
        pages[i].Recognize();
    }
    igRecognition.OutputManager.CodePage = "Windows ANSI";
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText;
    if(File.Exists("MULTIPAG.TXT"))
    {
        File.Delete("MULTIPAG.TXT");
    }
    igRecognition.OutputManager.WriteDirectText(pages, "MULTIPAG.TXT");

    for(i = 0; i < pages.Length; i ++)
    {
        pages[i].Dispose();
    }
}
  • Visual Basic
Using content As New FileStream("MULTIPAG.TIF", FileMode.Open)
    Dim numPages As Integer = ImGearFileFormats.GetPageCount(content, ImGearFormats.UNKNOWN)
    Dim i As Integer
    Dim pages As ImGearRecPage() = New ImGearRecPage(numPages) {}
    i = 0
    While i < numPages
        Dim igPage As ImGearPage = ImGearFileFormats.LoadPage(content, i)
        pages(i) = igRecognition.ImportPage(DirectCast(igPage, ImGearRasterPage))
        pages(i).Image.Preprocess()
        pages(i).Recognize()
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
    igRecognition.OutputManager.CodePage = "Windows ANSI"
    igRecognition.OutputManager.DirectTextFormat = ImGearRecDirectTextFormat.FormattedText
    If File.Exists("MULTIPAG.TXT") Then
        File.Delete("MULTIPAG.TXT")
    End If
    igRecognition.OutputManager.WriteDirectText(pages, "MULTIPAG.TXT")

    i = 0
    While i < pages.Length
        pages(i).Dispose()
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
End Using
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
Overload List


WriteDirectText(ImGearRecPage,Stream) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class > WriteDirectText Method : WriteDirectText(ImGearRecPage,Stream) Method
ImGearRecPage object with the valid recognition data to be written.
System.IO.Stream object to which the recognition data will be written.
Writes the recognition data of the page to the output stream in the direct text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteDirectText( _
   ByVal page As ImGearRecPage, _
   ByVal toStream As Stream _
)
'Usage

Dim instance As ImGearRecOutputManager
Dim page As ImGearRecPage
Dim toStream As Stream

instance.WriteDirectText(page, toStream)
public void WriteDirectText(
   ImGearRecPage page,
   Stream toStream
)
public: void WriteDirectText(
   ImGearRecPage* page,
   Stream* toStream
)
public:
void WriteDirectText(
   ImGearRecPage^ page,
   Stream^ toStream
)

Parameters

page
ImGearRecPage object with the valid recognition data to be written.
toStream
System.IO.Stream object to which the recognition data will be written.
Remarks

Use DirectTextFormatto get or set the output format.

The new recognition data will be written starting at the current position of the stream. When this method returns, the current position will be at the end of the stream, so you will need to set the position accordingly if you plan to read the stream later.

The following rules apply if the toStream parameter contains existing data:

  • If the current position is at the beginning of the stream, the existing data will be overwritten. The stream will be truncated or expanded to fit the size of the new data precisely.
  • If the current position is at the end of the stream, the new data will be appended to the existing data. The stream will be expanded to contain both the old and new data.
  • If the position is in the middle of the stream, the existing data from the current position onward will be overwritten. The stream will be truncated or expanded to fit the size of the existing data up to the current position, plus the size of the new data, precisely.

See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
Overload List


WriteDirectText(ImGearRecPage[],Stream) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class > WriteDirectText Method : WriteDirectText(ImGearRecPage[],Stream) Method
Array of ImGearRecPage objects with valid recognition data to be written.
System.IO.Stream object to which the recognition data will be written.
Writes the recognition data of several pages to the output stream in the direct text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteDirectText( _
   ByVal pages() As ImGearRecPage, _
   ByVal toStream As Stream _
)
'Usage

Dim instance As ImGearRecOutputManager
Dim pages() As ImGearRecPage
Dim toStream As Stream

instance.WriteDirectText(pages, toStream)
public void WriteDirectText(
   ImGearRecPage[] pages,
   Stream toStream
)
public: void WriteDirectText(
   ImGearRecPage*[]* pages,
   Stream* toStream
)
public:
void WriteDirectText(
   array<ImGearRecPage^>^ pages,
   Stream^ toStream
)

Parameters

pages
Array of ImGearRecPage objects with valid recognition data to be written.
toStream
System.IO.Stream object to which the recognition data will be written.
Remarks

Use DirectTextFormatto get or set the output format.

The new recognition data will be written starting at the current position of the stream. When this method returns, the position will be at the end of the stream, so you will need to set the position accordingly if you plan on reading the stream later.

The following rules apply if the toStream parameter contains existing data:

  • If the current position is at the beginning of the stream, the existing data will be overwritten. The stream will be truncated or expanded to fit the size of the new data precisely.
  • If the current position is at the end of the stream, the new data will be appended to the existing data. The stream will be expanded to contain both the old and new data.
  • If the position is in the middle of the stream, the existing data from the current position onward will be overwritten. The stream will be truncated or expanded to fit the size of the existing data up to the current position, plus the size of the new data, precisely.

See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
Overload List


WriteDocument Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : WriteDocument Method
ImGearRecDocument to be converted.
Path to the file to save the document to.
Saves a document to the specified file according to the current conversion settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub WriteDocument( _
   ByVal document As ImGearRecDocument, _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecOutputManager
Dim document As ImGearRecDocument
Dim path As String

instance.WriteDocument(document, path)
public void WriteDocument(
   ImGearRecDocument document,
   string path
)
public: void WriteDocument(
   ImGearRecDocument* document,
   string* path
)
public:
void WriteDocument(
   ImGearRecDocument^ document,
   String^ path
)

Parameters

document
ImGearRecDocument to be converted.
path
Path to the file to save the document to.
Remarks
Note: This method requires ImGearRecLicenseFeature.FormattedOutput feature to be enabled. WriteDirectText method provides a simpler ouptut option which does not require this licensing feature.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
ImGearRecDocument Class


%%PageItemTitle%% $$Properties$$

ImGearRecOutputManager Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputManager Class

For a list of all members of this type, see ImGearRecOutputManager members.

Public Properties
 | Name | Description
Public Property | CodePage | Gets or sets the Code Page used for output and character conversion.
Public Property | CodePages | Gets collection of available Code Pages for output.
Public Property | DirectTextFormat | Gets or sets direct text format for ImGearRecOutputManager.WriteDirectText methods.
Public Property | Format | Gets or sets format used for output.
Public Property | Formats | Gets collection of available output formats.
Public Property | Level | Gets or sets the level of format retention for the final output document.
Public Property | MissingSymbol | Gets or sets character used for output characters which are missing in the current Code Page.
Public Property | OutOfCodePageCharacters | Gets characters validated for recognition but not available in current Code Page.
Public Property | RejectionSymbol | Gets or sets character used for rejected characters in output.
Top
See Also

Reference

ImGearRecOutputManager Class
ImageGear.Recognition Namespace


CodePage Property (ImGearRecOutputManager)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : CodePage Property
Gets or sets the Code Page used for output and character conversion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CodePage As String
'Usage

Dim instance As ImGearRecOutputManager
Dim value As String

instance.CodePage = value

value = instance.CodePage
public string CodePage {get; set;}
public: __property string* get_CodePage();
public: __property void set_CodePage(
   string* value
);
public:
property String^ CodePage {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


CodePages Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : CodePages Property
Gets collection of available Code Pages for output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CodePages As ImGearRecCodePageCollection
'Usage

Dim instance As ImGearRecOutputManager
Dim value As ImGearRecCodePageCollection

value = instance.CodePages
public ImGearRecCodePageCollection CodePages {get;}
public: __property ImGearRecCodePageCollection* get_CodePages();
public:
property ImGearRecCodePageCollection^ CodePages {
   ImGearRecCodePageCollection^ get();
}

Property Value

ImGearRecCodePageCollection class object.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
ImGearRecCodePageCollection Class


DirectTextFormat Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : DirectTextFormat Property
Gets or sets direct text format for ImGearRecOutputManager.WriteDirectText methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DirectTextFormat As ImGearRecDirectTextFormat
'Usage

Dim instance As ImGearRecOutputManager
Dim value As ImGearRecDirectTextFormat

instance.DirectTextFormat = value

value = instance.DirectTextFormat
public ImGearRecDirectTextFormat DirectTextFormat {get; set;}
public: __property ImGearRecDirectTextFormat get_DirectTextFormat();
public: __property void set_DirectTextFormat(
   ImGearRecDirectTextFormat value
);
public:
property ImGearRecDirectTextFormat DirectTextFormat {
   ImGearRecDirectTextFormat get();
   void set (    ImGearRecDirectTextFormat value);
}

Property Value

ImGearRecDirectTextFormat enumeration value.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


Format Property (ImGearRecOutputManager)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : Format Property
Gets or sets format used for output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Format As String
'Usage

Dim instance As ImGearRecOutputManager
Dim value As String

instance.Format = value

value = instance.Format
public string Format {get; set;}
public: __property string* get_Format();
public: __property void set_Format(
   string* value
);
public:
property String^ Format {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property specifies the output text format for the final output document. This setting is used during a call to WriteDocument method.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


Formats Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : Formats Property
Gets collection of available output formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Formats As ImGearRecOutputFormatCollection
'Usage

Dim instance As ImGearRecOutputManager
Dim value As ImGearRecOutputFormatCollection

value = instance.Formats
public ImGearRecOutputFormatCollection Formats {get;}
public: __property ImGearRecOutputFormatCollection* get_Formats();
public:
property ImGearRecOutputFormatCollection^ Formats {
   ImGearRecOutputFormatCollection^ get();
}

Property Value

ImGearRecOutputFormatCollection class object.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
ImGearRecOutputFormatCollection Class


Level Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : Level Property
Gets or sets the level of format retention for the final output document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Level As ImGearRecOutputLevel
'Usage

Dim instance As ImGearRecOutputManager
Dim value As ImGearRecOutputLevel

instance.Level = value

value = instance.Level
public ImGearRecOutputLevel Level {get; set;}
public: __property ImGearRecOutputLevel get_Level();
public: __property void set_Level(
   ImGearRecOutputLevel value
);
public:
property ImGearRecOutputLevel Level {
   ImGearRecOutputLevel get();
   void set (    ImGearRecOutputLevel value);
}

Property Value

ImGearRecOutputLevel enumeration value.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members
ImGearRecOutputLevel Enumeration


MissingSymbol Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : MissingSymbol Property
Gets or sets character used for output characters which are missing in the current Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MissingSymbol As Char
'Usage

Dim instance As ImGearRecOutputManager
Dim value As Char

instance.MissingSymbol = value

value = instance.MissingSymbol
public char MissingSymbol {get; set;}
public: __property char get_MissingSymbol();
public: __property void set_MissingSymbol(
   char value
);
public:
property char MissingSymbol {
   char get();
   void set (    char value);
}

Property Value

Char value.
Remarks
This property specifies the code of the missing symbol. The missing symbol is a special character that replaces any character that was recognized by the recognition engine but could not be represented in the final output document, since the character does not exist in the current Code Page.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


OutOfCodePageCharacters Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : OutOfCodePageCharacters Property
Gets characters validated for recognition but not available in current Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutOfCodePageCharacters As String
'Usage

Dim instance As ImGearRecOutputManager
Dim value As String

value = instance.OutOfCodePageCharacters
public string OutOfCodePageCharacters {get;}
public: __property string* get_OutOfCodePageCharacters();
public:
property String^ OutOfCodePageCharacters {
   String^ get();
}

Property Value

String of characters.
Remarks
This property will contain any characters (in Unicode) validated for recognition, which can not be found in the current Code Page.

This property can be used to check whether the current Code Page setting contains all the characters of the current Language environment (characters needed for the language selection, plus any LanguagesPlus characters), and any characters listed as FilterPlus characters.

See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


RejectionSymbol Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputManager Class : RejectionSymbol Property
Gets or sets character used for rejected characters in output.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RejectionSymbol As Char
'Usage

Dim instance As ImGearRecOutputManager
Dim value As Char

instance.RejectionSymbol = value

value = instance.RejectionSymbol
public char RejectionSymbol {get; set;}
public: __property char get_RejectionSymbol();
public: __property void set_RejectionSymbol(
   char value
);
public:
property char RejectionSymbol {
   char get();
   void set (    char value);
}

Property Value

Char value.
Remarks
This property specifies which character is to be used as a symbol for the rejected characters (i.e., unrecognized by the recognition module used in the zone) in the final output document.
See Also

Reference

ImGearRecOutputManager Class
ImGearRecOutputManager Members


%%PageItemTitle%%

ImGearRecPage Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPage Class
Represents a single image imported into the recognition engine.
Object Model
ImGearRecPage ClassImGearRecLetter ClassImGearRecImage ClassImGearRecognition ClassImGearRecStatistics ClassImGearRecZoneCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecPage
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecPage
public sealed class ImGearRecPage : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecPage : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecPage sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
This object is returned by the ImGearRecognition.ImportPage method of ImGearRecognition class.

The data associated with this object includes image data, recognized data and statistics, and a collection of recognition zones.

Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecPage

See Also

Reference

ImGearRecPage Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecPage Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPage Class

The following tables list the members exposed by ImGearRecPage.

Public Properties
 | Name | Description
Public Property | Image | Gets access to image properties and processing methods.
Public Property | IsValid | Gets a value indicating whether ImGearRecPage object is valid, that is, can be used for processing/preprocessing, recognition and so on.
Public Property | Parent | Gets reference to parent ImGearRecognition class object.
Public Property | Statistics | Gets access to recognition statistics for this page.
Public Property | Zones | Gets collection of recognition zones.
Top
Public Methods
 | Name | Description
Public Method | CreatePDFPage | Creates a new page in the given PDF document and populates it with recognized text and image.
Public Method | DeleteRecognitionData | Frees recognized data from memory.
Public Method | DetectFillingMethod | Detects the filling method used for the entire image.
Public Method | Dispose | Frees all data associated with this object.
Public Method | GetLetters | Returns an array of letters describing the recognized data.
Public Method | PopulatePDFPage | Populates an existing PDF page in a PDF document with recognized text and/or image.
Public Method | Recognize | Performs recognition, storing the recognition data in a file automatically managed by the recognition engine.
Public Method | SetLetters | Updates the internally stored recognition data according to the user's copy.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecPage class.
Top
See Also

Reference

ImGearRecPage Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecPage Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPage Class

For a list of all members of this type, see ImGearRecPage members.

Public Methods
 | Name | Description
Public Method | CreatePDFPage | Creates a new page in the given PDF document and populates it with recognized text and image.
Public Method | DeleteRecognitionData | Frees recognized data from memory.
Public Method | DetectFillingMethod | Detects the filling method used for the entire image.
Public Method | Dispose | Frees all data associated with this object.
Public Method | GetLetters | Returns an array of letters describing the recognized data.
Public Method | PopulatePDFPage | Populates an existing PDF page in a PDF document with recognized text and/or image.
Public Method | Recognize | Performs recognition, storing the recognition data in a file automatically managed by the recognition engine.
Public Method | SetLetters | Updates the internally stored recognition data according to the user's copy.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecPage class.
Top
See Also

Reference

ImGearRecPage Class
ImageGear.Recognition Namespace


CreatePDFPage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : CreatePDFPage Method
Existing ImageGear.Formats.PDF.ImGearPDFDocument class to which the new page will be appended.
ImGearRecPDFOutputOptions class object.
Creates a new page in the given PDF document and populates it with recognized text and image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CreatePDFPage( _
   ByVal outputDocument As ImGearPDFDocument, _
   ByVal options As ImGearRecPDFOutputOptions _
)
'Usage

Dim instance As ImGearRecPage
Dim outputDocument As ImGearPDFDocument
Dim options As ImGearRecPDFOutputOptions

instance.CreatePDFPage(outputDocument, options)
public void CreatePDFPage(
   ImGearPDFDocument outputDocument,
   ImGearRecPDFOutputOptions options
)
public: void CreatePDFPage(
   ImGearPDFDocument* outputDocument,
   ImGearRecPDFOutputOptions* options
)
public:
void CreatePDFPage(
   ImGearPDFDocument^ outputDocument,
   ImGearRecPDFOutputOptions^ options
)

Parameters

outputDocument
Existing ImageGear.Formats.PDF.ImGearPDFDocument class to which the new page will be appended.
options
ImGearRecPDFOutputOptions class object.
Remarks
This method creates a new page in the given PDF document and populates it with recognized text and image.

The first parameter is an existing ImageGear.Formats.PDF.ImGearPDFDocument class to which the new page will be appended.

The second parameter is optional and can be used to specify options. Pass Nothing to use default options, which creates a PDF page containing the recognized image along with hidden text elements suitable for searching, highlighting, selection, copying and pasting, etc.

Note: depending on the ImGearRecPDFOutputOptions.UseUnicodeText property value of the options parameter, this method will support either Windows ANSI or Unicode encoding for the recognized text. When using Unicode encoding only, this method will generate ImageGear.Core.ImGearWarning's if the recognized text contains characters that cannot be represented by the selected PDF font. Use the ImGearRecPDFOutputOptions class to specify the PDF fonts used for export.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearPDFDocument Class
ImGearRecPDFOutputOptions Class


DeleteRecognitionData Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : DeleteRecognitionData Method
Frees recognized data from memory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteRecognitionData()
'Usage

Dim instance As ImGearRecPage

instance.DeleteRecognitionData()
public void DeleteRecognitionData()
public: void DeleteRecognitionData();
public:
void DeleteRecognitionData();
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members


DetectFillingMethod Method (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : DetectFillingMethod Method
Detects the filling method used for the entire image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function DetectFillingMethod() As ImGearRecFillingMethod
'Usage

Dim instance As ImGearRecPage
Dim value As ImGearRecFillingMethod

value = instance.DetectFillingMethod()
public ImGearRecFillingMethod DetectFillingMethod()
public: ImGearRecFillingMethod DetectFillingMethod();
public:
ImGearRecFillingMethod DetectFillingMethod();

Return Value

ImGearRecFillingMethod enumeration value.
Remarks
This method tries to determine the type of the text in the zones of a page globally (e.g. machine printed or dot-matrix printed text).

Although this method detects a filling method for the entire image, it requires zones to be defined beforehand. (They could be detected automatically with the Locate method or added manually.) Additionally, this method only looks into zones with the DEFAULT value in their FillingMethod property.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecFillingMethod Enumeration
ImGearRecZone Class
ImGearRecognition Class


Dispose Method (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Dispose Method
Frees all data associated with this object.
Overload List
Overload | Description
Dispose | Frees all data associated with this object.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members


Dispose() Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Dispose() Method
Frees all data associated with this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearRecPage

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This is a standard .NET Dispose method. It frees all data associated with this object as well as releases the associated native objects.

It is required for an application to call this method to properly clean up the native resources. In the case if this method is not explicitly called by the application, the .NET garbage collector might dispose the object after the native resources were unloaded, which might cause General Protection Fault in the Recognition engine.

The application is responsible for not accessing any methods or properties of the object after having called its Dispose method.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members


Finalize Method (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Finalize Method
Finalizes an instance of the ImGearRecPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearRecPage

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members


GetLetters Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : GetLetters Method
Returns an array of letters describing the recognized data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetLetters() As ImGearRecLetter()
'Usage

Dim instance As ImGearRecPage
Dim value() As ImGearRecLetter

value = instance.GetLetters()
public ImGearRecLetter[] GetLetters()
public: ImGearRecLetter*[]* GetLetters();
public:
array<ImGearRecLetter^>^ GetLetters();

Return Value

ImGearRecLetter class array.
Remarks
This method returns an array of ImGearRecLetter class objects which contain a copy of the recognition data. This method can be called after data has been recognized, whether the recognition data has been stored in memory or in a file.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecLetter Class


PopulatePDFPage Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : PopulatePDFPage Method
Existing ImageGear.Formats.PDF.ImGearPDFDocument containing the PDF page to be populated.
Existing ImageGear.Formats.PDF.ImGearPDFPage to be populated with recognized data.
ImGearRecPDFOutputOptions class object.
Populates an existing PDF page in a PDF document with recognized text and/or image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PopulatePDFPage( _
   ByVal outputDocument As ImGearPDFDocument, _
   ByVal outputPage As ImGearPDFPage, _
   ByVal options As ImGearRecPDFOutputOptions _
)
'Usage

Dim instance As ImGearRecPage
Dim outputDocument As ImGearPDFDocument
Dim outputPage As ImGearPDFPage
Dim options As ImGearRecPDFOutputOptions

instance.PopulatePDFPage(outputDocument, outputPage, options)
public void PopulatePDFPage(
   ImGearPDFDocument outputDocument,
   ImGearPDFPage outputPage,
   ImGearRecPDFOutputOptions options
)
public: void PopulatePDFPage(
   ImGearPDFDocument* outputDocument,
   ImGearPDFPage* outputPage,
   ImGearRecPDFOutputOptions* options
)
public:
void PopulatePDFPage(
   ImGearPDFDocument^ outputDocument,
   ImGearPDFPage^ outputPage,
   ImGearRecPDFOutputOptions^ options
)

Parameters

outputDocument
Existing ImageGear.Formats.PDF.ImGearPDFDocument containing the PDF page to be populated.
outputPage
Existing ImageGear.Formats.PDF.ImGearPDFPage to be populated with recognized data.
options
ImGearRecPDFOutputOptions class object.
Remarks
This method populates an existing PDF page in a PDF document with recognized text and/or image. The content of the existing PDF page is preserved and supplemented.

The first two parameters supply the PDF document and page to be populated. The given PDF page must belong to the given PDF document. Also, the dimensions of the PDF page should be appropriate. For example, the aspect ratio of the PDF page should match that of the recognized image, although recognized data will be stretched to fit the PDF page if necessary.

The third parameter is optional and can be used to specify options. Pass Nothing to use default options, which populates the given PDF page with only hidden text elements suitable for searching, highlighting, selection, copying and pasting, etc.

Note: depending on the ImGearRecPDFOutputOptions.UseUnicodeText property value of the options parameter, this method will support either Windows ANSI or Unicode encoding for the recognized text. When using Unicode encoding only, this method will generate ImageGear.Core.ImGearWarning's if the recognized text contains characters that cannot be represented by the selected PDF font. Use the ImGearRecPDFOutputOptions class to specify the PDF fonts used for export.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearPDFDocument Class
ImGearPDFPage Class
ImGearRecPDFOutputOptions Class


Recognize Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Recognize Method
Performs recognition, storing the recognition data in a file automatically managed by the recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Recognize()
'Usage

Dim instance As ImGearRecPage

instance.Recognize()
public void Recognize()
public: void Recognize();
public:
void Recognize();
Remarks
This method performs recognition, storing the recognized data in a recognition data file which is automatically managed by the recognition engine.

If the zone list is empty (i.e., there are no zones defined), the DECOMPOSITION page-layout decomposition process is activated automatically in order to create a zone list for the image before recognition.

The method utilizes the zone information to activate the appropriate recognition module on each zone. Each recognition module recognizes the image parts assigned to it in the zone list.

After all non-graphics zones on the page are recognized, the method collects the necessary information about the recognized characters into a homogenous structure, called the recognition result.

This method offers the services of the checking subsystem to either have suspect characters or words marked, or to allow auto-correction during the recognition process.

This method may activate one or more of the processes PID_RECOGNITION1, PID_RECOGNITION2, PID_RECOGNITION3.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecognition Class
ImGearRecZone Class
ImGearRecZoneCollection Class
ImGearRecModuleCollection Class
ImGearRecPreprocessingSettings Class
ImGearRecLetter Class


SetLetters Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : SetLetters Method
ImGearRecLetter class letters array.
Updates the internally stored recognition data according to the user's copy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLetters( _
   ByVal letters() As ImGearRecLetter _
)
'Usage

Dim instance As ImGearRecPage
Dim letters() As ImGearRecLetter

instance.SetLetters(letters)
public void SetLetters(
   ImGearRecLetter[] letters
)
public: void SetLetters(
   ImGearRecLetter*[]* letters
)
public:
void SetLetters(
   array<ImGearRecLetter^>^ letters
)

Parameters

letters
ImGearRecLetter class letters array.
Remarks

Information set by a call to SetLetters method affects the recognized data output.

Note: it is necessary to call Recognize method after calling SetLetters method for the changes to take effect.

The array of ImGearRecLetter class objects passed to this method should have been obtained by a previous call to the GetLetters method.

See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecLetter Class
GetLetters Method


%%PageItemTitle%% $$Properties$$

ImGearRecPage Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPage Class

For a list of all members of this type, see ImGearRecPage members.

Public Properties
 | Name | Description
Public Property | Image | Gets access to image properties and processing methods.
Public Property | IsValid | Gets a value indicating whether ImGearRecPage object is valid, that is, can be used for processing/preprocessing, recognition and so on.
Public Property | Parent | Gets reference to parent ImGearRecognition class object.
Public Property | Statistics | Gets access to recognition statistics for this page.
Public Property | Zones | Gets collection of recognition zones.
Top
See Also

Reference

ImGearRecPage Class
ImageGear.Recognition Namespace


Image Property (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Image Property
Gets access to image properties and processing methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As ImGearRecImage
'Usage

Dim instance As ImGearRecPage
Dim value As ImGearRecImage

value = instance.Image
public ImGearRecImage Image {get;}
public: __property ImGearRecImage* get_Image();
public:
property ImGearRecImage^ Image {
   ImGearRecImage^ get();
}

Property Value

ImGearRecImage class object.
Remarks
Provides access to image properties and processing methods for the image associated with this ImGearRecPage object. See ImGearRecImage class.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecImage Class


IsValid Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : IsValid Property
Gets a value indicating whether ImGearRecPage object is valid, that is, can be used for processing/preprocessing, recognition and so on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsValid As Boolean
'Usage

Dim instance As ImGearRecPage
Dim value As Boolean

value = instance.IsValid
public bool IsValid {get;}
public: __property bool get_IsValid();
public:
property bool IsValid {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members


Parent Property (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Parent Property
Gets reference to parent ImGearRecognition class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As ImGearRecognition
'Usage

Dim instance As ImGearRecPage
Dim value As ImGearRecognition

value = instance.Parent
public ImGearRecognition Parent {get;}
public: __property ImGearRecognition* get_Parent();
public:
property ImGearRecognition^ Parent {
   ImGearRecognition^ get();
}

Property Value

ImGearRecognition class object.
Remarks
Provides a reference to the parent ImGearRecognition object that created this ImGearRecPage object.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecognition Class


Statistics Property (ImGearRecPage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Statistics Property
Gets access to recognition statistics for this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Statistics As ImGearRecStatistics
'Usage

Dim instance As ImGearRecPage
Dim value As ImGearRecStatistics

value = instance.Statistics
public ImGearRecStatistics Statistics {get;}
public: __property ImGearRecStatistics* get_Statistics();
public:
property ImGearRecStatistics^ Statistics {
   ImGearRecStatistics^ get();
}

Property Value

ImGearRecStatistics class object.
Remarks
Provides access to statistics for recognition processes performed on this ImGearRecPage. See ImGearRecStatistics class.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecStatistics Class


Zones Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPage Class : Zones Property
Gets collection of recognition zones.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Zones As ImGearRecZoneCollection
'Usage

Dim instance As ImGearRecPage
Dim value As ImGearRecZoneCollection

value = instance.Zones
public ImGearRecZoneCollection Zones {get;}
public: __property ImGearRecZoneCollection* get_Zones();
public:
property ImGearRecZoneCollection^ Zones {
   ImGearRecZoneCollection^ get();
}

Property Value

ImGearRecZoneCollection class object.
Remarks
Collection of recognition zones associated with the ImGearRecPage.
See Also

Reference

ImGearRecPage Class
ImGearRecPage Members
ImGearRecZoneCollection Class


%%PageItemTitle%%

ImGearRecPDFOutputOptions Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPDFOutputOptions Class
Specifies options for creating PDF page from the recognition output.
Object Model
ImGearRecPDFOutputOptions ClassImGearPDEFont ClassImGearPDEFont ClassImGearPDEFont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecPDFOutputOptions
'Usage

Dim instance As ImGearRecPDFOutputOptions
public sealed class ImGearRecPDFOutputOptions
public __gc __sealed class ImGearRecPDFOutputOptions
public ref class ImGearRecPDFOutputOptions sealed
Remarks
Options for creating PDF page are used with the ImGearRecPage.CreatePDFPage method.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecPDFOutputOptions

See Also

Reference

ImGearRecPDFOutputOptions Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecPDFOutputOptions Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPDFOutputOptions Class

The following tables list the members exposed by ImGearRecPDFOutputOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecPDFOutputOptions Constructor | Initializes a new instance of the ImGearRecPDFOutputOptions class.
Top
Public Properties
 | Name | Description
Public Property | FontCourier | Gets or sets the font to use for creating monospaced text.
Public Property | FontSans | Gets or sets the font to use for creating sans-serif text.
Public Property | FontSerif | Gets or sets the font to use for creating serif text.
Public Property | ForceProportional | Gets or sets a value indicating whether all text force proportional fonts.
Public Property | ImageCompression | Gets or sets the compression to use for images.
Public Property | OptimizeForPdfa | Gets or sets a value indicating whether or not the PDF output will be optimized for PDF/A-1a compatibility.
Public Property | UseUnicodeText | Gets or sets a value indicating whether text will be added to the PDF as multi-byte Unicode values or encoded using the default Windows codepage.
Public Property | VisibleImage | Gets or sets a value indicating whether the recognized image as an image covering the whole page.
Public Property | VisibleText | Gets or sets a value indicating whether text elements are visible.
Top
See Also

Reference

ImGearRecPDFOutputOptions Class
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecPDFOutputOptions Constructor

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : ImGearRecPDFOutputOptions Constructor
Initializes a new instance of the ImGearRecPDFOutputOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecPDFOutputOptions()
public ImGearRecPDFOutputOptions()
public: ImGearRecPDFOutputOptions();
public:
ImGearRecPDFOutputOptions();
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members
ImGearRecPDFOutputOptions Class


%%PageItemTitle%% $$Properties$$

ImGearRecPDFOutputOptions Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPDFOutputOptions Class

For a list of all members of this type, see ImGearRecPDFOutputOptions members.

Public Properties
 | Name | Description
Public Property | FontCourier | Gets or sets the font to use for creating monospaced text.
Public Property | FontSans | Gets or sets the font to use for creating sans-serif text.
Public Property | FontSerif | Gets or sets the font to use for creating serif text.
Public Property | ForceProportional | Gets or sets a value indicating whether all text force proportional fonts.
Public Property | ImageCompression | Gets or sets the compression to use for images.
Public Property | OptimizeForPdfa | Gets or sets a value indicating whether or not the PDF output will be optimized for PDF/A-1a compatibility.
Public Property | UseUnicodeText | Gets or sets a value indicating whether text will be added to the PDF as multi-byte Unicode values or encoded using the default Windows codepage.
Public Property | VisibleImage | Gets or sets a value indicating whether the recognized image as an image covering the whole page.
Public Property | VisibleText | Gets or sets a value indicating whether text elements are visible.
Top
See Also

Reference

ImGearRecPDFOutputOptions Class
ImageGear.Recognition Namespace


FontCourier Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : FontCourier Property
Gets or sets the font to use for creating monospaced text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontCourier As ImGearPDEFont
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As ImGearPDEFont

instance.FontCourier = value

value = instance.FontCourier
public ImGearPDEFont FontCourier {get; set;}
public: __property ImGearPDEFont* get_FontCourier();
public: __property void set_FontCourier(
   ImGearPDEFont* value
);
public:
property ImGearPDEFont^ FontCourier {
   ImGearPDEFont^ get();
   void set (    ImGearPDEFont^ value);
}

Property Value

ImageGear.Formats.PDF.ImGearPDEFont class object.
Remarks
If the value is null, the Type 1 font Courier will be used.
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members
ImGearPDEFont Class


FontSans Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : FontSans Property
Gets or sets the font to use for creating sans-serif text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSans As ImGearPDEFont
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As ImGearPDEFont

instance.FontSans = value

value = instance.FontSans
public ImGearPDEFont FontSans {get; set;}
public: __property ImGearPDEFont* get_FontSans();
public: __property void set_FontSans(
   ImGearPDEFont* value
);
public:
property ImGearPDEFont^ FontSans {
   ImGearPDEFont^ get();
   void set (    ImGearPDEFont^ value);
}

Property Value

ImageGear.Formats.PDF.ImGearPDEFont class object.
Remarks
This property specifies the font to use for creating sans-serif text. If the value is null, the Type 1 font Helvetica will be used.
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members
ImGearPDEFont Class


FontSerif Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : FontSerif Property
Gets or sets the font to use for creating serif text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontSerif As ImGearPDEFont
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As ImGearPDEFont

instance.FontSerif = value

value = instance.FontSerif
public ImGearPDEFont FontSerif {get; set;}
public: __property ImGearPDEFont* get_FontSerif();
public: __property void set_FontSerif(
   ImGearPDEFont* value
);
public:
property ImGearPDEFont^ FontSerif {
   ImGearPDEFont^ get();
   void set (    ImGearPDEFont^ value);
}

Property Value

ImageGear.Formats.PDF.ImGearPDEFont value.
Remarks
If the value is null, the Type 1 font Times-Roman will be used.
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members
ImGearPDEFont Class


ForceProportional Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : ForceProportional Property
Gets or sets a value indicating whether all text force proportional fonts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ForceProportional As Boolean
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As Boolean

instance.ForceProportional = value

value = instance.ForceProportional
public bool ForceProportional {get; set;}
public: __property bool get_ForceProportional();
public: __property void set_ForceProportional(
   bool value
);
public:
property bool ForceProportional {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If true, forces all text to use proportional fonts (no monospaced font detection).
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members


ImageCompression Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : ImageCompression Property
Gets or sets the compression to use for images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageCompression As ImGearCompressions
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As ImGearCompressions

instance.ImageCompression = value

value = instance.ImageCompression
public ImGearCompressions ImageCompression {get; set;}
public: __property ImGearCompressions get_ImageCompression();
public: __property void set_ImageCompression(
   ImGearCompressions value
);
public:
property ImGearCompressions ImageCompression {
   ImGearCompressions get();
   void set (    ImGearCompressions value);
}

Property Value

ImageGear.Formats.ImGearCompressions enumeration values.
Remarks

This property will determine the compression format of the image that is added to the PDF page when VisibleImage is true. The original image imported into Recognition will be used.

The default value, ImGearCompressions.AUTO, will result in the following automatic compression selection based on the input image's bit depth:

  • 1 Bits Per Pixel - ImGearCompressions.CCITT_G4
  • 4 Bits Per Pixel - ImGearCompressions.DEFLATE
  • 8 Bits Per Pixel - ImGearCompressions.DEFLATE
  • 24 Bits Per Pixel - ImGearCompressions.JPEG

For compression types other than AUTO, the Recognition PDF writer will attempt to convert the original image if needed to make it compatible with the selected compression format. However, this conversion process does not support the binarization of full color, 24 BPP images to black and white, 1 BPP images. If the original input might be a full color image, the CCITT compression types should not be selected as this will cause an exception. Binarization should be performed on the original image, prior to importing it into Recognition, if the PDF output should need it.

If JPEG compression is set here, the compression quality can be adjusted using the global ImageGear filter parameters. The Quality and DecimationType values will be used for JPEG compression of images in the recognition PDF output. All other JPEG filter parameters are ignored. See the JPEG format topic for more information about these parameters. See the Using Filter Control Parameters topic for information on how to set the global filter parameters.

See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members
ImGearCompressions Enumeration


OptimizeForPdfa Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : OptimizeForPdfa Property
Gets or sets a value indicating whether or not the PDF output will be optimized for PDF/A-1a compatibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OptimizeForPdfa As Boolean
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As Boolean

instance.OptimizeForPdfa = value

value = instance.OptimizeForPdfa
public bool OptimizeForPdfa {get; set;}
public: __property bool get_OptimizeForPdfa();
public: __property void set_OptimizeForPdfa(
   bool value
);
public:
property bool OptimizeForPdfa {
   bool get();
   void set (    bool value);
}
Remarks

If this property is true, all fonts used in the PDF will be fully embedded in the document and a document structure will be created with any text content tagged appropriately.

For PDF documents that need to be compatible with the PDF/A-1a standard, this property should be set to true because embedded fonts and the use of tags is a requirement for PDF/A-1. If file size is a priority over archiving (i.e. PDF/A-1a), then consider changing this property to false so the fonts won't be embedded and the structure elements will not be added.

See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members


UseUnicodeText Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : UseUnicodeText Property
Gets or sets a value indicating whether text will be added to the PDF as multi-byte Unicode values or encoded using the default Windows codepage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseUnicodeText As Boolean
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As Boolean

instance.UseUnicodeText = value

value = instance.UseUnicodeText
public bool UseUnicodeText {get; set;}
public: __property bool get_UseUnicodeText();
public: __property void set_UseUnicodeText(
   bool value
);
public:
property bool UseUnicodeText {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

If true, the Unicode text output from Recognition will be added to the PDF page that is created. If false, the Unicode text will first be encoded using the default Windows codepage, and then added to the new PDF page.

Generally, the best option is to write text to the PDF page using the default Windows code page. However, if Recognition results will include characters not support by the default code page, then writing Unicode text to the PDF page is a good option. Unicode text will provide the most flexibility when recognizing text in different languages. However, consideration must go into the PDF font selections specified in the FontSerif, FontSans and FontCourier properties because not all fonts support all languages.

The default value is false.

See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members


VisibleImage Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : VisibleImage Property
Gets or sets a value indicating whether the recognized image as an image covering the whole page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VisibleImage As Boolean
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As Boolean

instance.VisibleImage = value

value = instance.VisibleImage
public bool VisibleImage {get; set;}
public: __property bool get_VisibleImage();
public: __property void set_VisibleImage(
   bool value
);
public:
property bool VisibleImage {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
When property is true recognized image covers the whole page.
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members


VisibleText Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPDFOutputOptions Class : VisibleText Property
Gets or sets a value indicating whether text elements are visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VisibleText As Boolean
'Usage

Dim instance As ImGearRecPDFOutputOptions
Dim value As Boolean

instance.VisibleText = value

value = instance.VisibleText
public bool VisibleText {get; set;}
public: __property bool get_VisibleText();
public: __property void set_VisibleText(
   bool value
);
public:
property bool VisibleText {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property, when true, creates visible text elements (otherwise, the text is hidden if an image is also created).
See Also

Reference

ImGearRecPDFOutputOptions Class
ImGearRecPDFOutputOptions Members


%%PageItemTitle%%

ImGearRecPreprocessingSettings Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPreprocessingSettings Class
Provides access to settings for preprocessing, belongs to ImGearRecognition.
Object Model
ImGearRecPreprocessingSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecPreprocessingSettings
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecPreprocessingSettings
public sealed class ImGearRecPreprocessingSettings : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecPreprocessingSettings : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecPreprocessingSettings sealed : public ImGearRecSettingsCollectionObjectBase
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecPreprocessingSettings

See Also

Reference

ImGearRecPreprocessingSettings Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecPreprocessingSettings Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPreprocessingSettings Class

The following tables list the members exposed by ImGearRecPreprocessingSettings.

Public Properties
 | Name | Description
Public Property | DeskewMode | Gets or sets deskew behavior used by the ImGearRecImage.Preprocess method.
Public Property | DespeckleMode | Gets or sets a value indicating whether the adaptive noise removal algorithm is to be activated during image pre-processing, auto-zoning or recognition.
Public Property | InversionMode | Gets or sets inversion behavior.
Public Property | OrientationMode | Gets or sets orientation behavior.
Public Property | PrimaryReductionMode | Gets or sets image reduction during initial loading step.
Public Property | ReductionBrightness | Gets or sets brightness of image when reduced to bitonal.
Public Property | ReductionThreshold | Gets or sets threshold used when reducing image to bitonal.
Public Property | ResEnhancementMode | Gets or sets whether resolution enhancement occurs when reducing image to bitonal.
Public Property | SecondaryReductionMode | Gets or sets image reduction during preprocessing, decomposition, and recognition steps.
Public Property | SkewAmount | Gets or sets amount of image skew to correct when performing deskewing.
Top
See Also

Reference

ImGearRecPreprocessingSettings Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecPreprocessingSettings Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecPreprocessingSettings Class

For a list of all members of this type, see ImGearRecPreprocessingSettings members.

Public Properties
 | Name | Description
Public Property | DeskewMode | Gets or sets deskew behavior used by the ImGearRecImage.Preprocess method.
Public Property | DespeckleMode | Gets or sets a value indicating whether the adaptive noise removal algorithm is to be activated during image pre-processing, auto-zoning or recognition.
Public Property | InversionMode | Gets or sets inversion behavior.
Public Property | OrientationMode | Gets or sets orientation behavior.
Public Property | PrimaryReductionMode | Gets or sets image reduction during initial loading step.
Public Property | ReductionBrightness | Gets or sets brightness of image when reduced to bitonal.
Public Property | ReductionThreshold | Gets or sets threshold used when reducing image to bitonal.
Public Property | ResEnhancementMode | Gets or sets whether resolution enhancement occurs when reducing image to bitonal.
Public Property | SecondaryReductionMode | Gets or sets image reduction during preprocessing, decomposition, and recognition steps.
Public Property | SkewAmount | Gets or sets amount of image skew to correct when performing deskewing.
Top
See Also

Reference

ImGearRecPreprocessingSettings Class
ImageGear.Recognition Namespace


DeskewMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : DeskewMode Property
Gets or sets deskew behavior used by the ImGearRecImage.Preprocess method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeskewMode As ImGearRecDeskewMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecDeskewMode

instance.DeskewMode = value

value = instance.DeskewMode
public ImGearRecDeskewMode DeskewMode {get; set;}
public: __property ImGearRecDeskewMode get_DeskewMode();
public: __property void set_DeskewMode(
   ImGearRecDeskewMode value
);
public:
property ImGearRecDeskewMode DeskewMode {
   ImGearRecDeskewMode get();
   void set (    ImGearRecDeskewMode value);
}

Property Value

ImGearRecDeskewMode enumeration value.
Remarks

This property specifies which image deskewing mode will be used during ImGearRecProcess.IMGPREPROCESS processes. Deskewing mode can be automatic, programmable, or turned off entirely.

Alternatively, deskewing can be performed manually by the Deskew method.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecDeskewMode Enumeration
Preprocess Method
Deskew Method
Deskew3D Method


DespeckleMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : DespeckleMode Property
Gets or sets a value indicating whether the adaptive noise removal algorithm is to be activated during image pre-processing, auto-zoning or recognition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DespeckleMode As Boolean
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As Boolean

instance.DespeckleMode = value

value = instance.DespeckleMode
public bool DespeckleMode {get; set;}
public: __property bool get_DespeckleMode();
public: __property void set_DespeckleMode(
   bool value
);
public:
property bool DespeckleMode {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

This property specifies the image despeckle mode setting, i.e. whether the adaptive noise removal algorithm is to be activated during image pre-processing, auto-zoning or recognition. The noise removal algorithm runs only on bitonal images with a resolution of 280 DPI or higher.

Note: When despeckle runs as part of the preprocessing (rather than called explicitly), it works on an internal secondary image, so its result is not available for exporting back to the application. Use Despeckle method for explicit despeckling. See The Recognition Process section for explanation of the "secondary image" term.

This setting might influence the accuracy of the recognition.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
Despeckle Method
Preprocess Method
Recognize Method
Locate Method
Locate(ImGearRectangle) Method


InversionMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : InversionMode Property
Gets or sets inversion behavior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InversionMode As ImGearRecInvertMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecInvertMode

instance.InversionMode = value

value = instance.InversionMode
public ImGearRecInvertMode InversionMode {get; set;}
public: __property ImGearRecInvertMode get_InversionMode();
public: __property void set_InversionMode(
   ImGearRecInvertMode value
);
public:
property ImGearRecInvertMode InversionMode {
   ImGearRecInvertMode get();
   void set (    ImGearRecInvertMode value);
}

Property Value

ImGearRecInvertMode enumeration value.
Remarks

This property specifies which image inversion mode will be used during the forthcoming ImGearRecProcess.IMGPREPROCESS processes. The image inversion mode can be either automatic, switched on or switched off.

Note: When inversion runs as part of the preprocessing (rather than called explicitly), it works on an internal secondary image, so its result is not available for exporting back to the application. Use Invert method for explicit inversion. See The Recognition Process section for explanation of the "secondary image" term.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecInvertMode Enumeration


OrientationMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : OrientationMode Property
Gets or sets orientation behavior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OrientationMode As ImGearRecOrientationMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecOrientationMode

instance.OrientationMode = value

value = instance.OrientationMode
public ImGearRecOrientationMode OrientationMode {get; set;}
public: __property ImGearRecOrientationMode get_OrientationMode();
public: __property void set_OrientationMode(
   ImGearRecOrientationMode value
);
public:
property ImGearRecOrientationMode OrientationMode {
   ImGearRecOrientationMode get();
   void set (    ImGearRecOrientationMode value);
}

Property Value

ImGearRecOrientationMode enumeration value.
Remarks

This property specifies which image orientation mode will be used during the forthcoming ImGearRecProcess.IMGPREPROCESS processes. The image orientation mode can be automatic, switched off or programmable.

Valid values are AUTO, NO, LEFT, RIGHT and DOWN.

If this property is set to one of the FLIPPED ImGearRecOrientationMode values, a warning will be created and the orientation mode will not be changed from its current value. Use the ImGearRecImage.Orient method if a flipped orientation is desired.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecOrientationMode Enumeration


PrimaryReductionMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : PrimaryReductionMode Property
Gets or sets image reduction during initial loading step.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrimaryReductionMode As ImGearRecReductionMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecReductionMode

instance.PrimaryReductionMode = value

value = instance.PrimaryReductionMode
public ImGearRecReductionMode PrimaryReductionMode {get; set;}
public: __property ImGearRecReductionMode get_PrimaryReductionMode();
public: __property void set_PrimaryReductionMode(
   ImGearRecReductionMode value
);
public:
property ImGearRecReductionMode PrimaryReductionMode {
   ImGearRecReductionMode get();
   void set (    ImGearRecReductionMode value);
}

Property Value

ImGearRecReductionMode enumeration value.
Remarks
This property specifies which image reduction mode will be used during the primary image conversion step. While importing an image to the recognition engine's memory space (ImportPage method), an image conversion is performed according to the current image conversion mode setting.

The setting specified here will influence what kind of image will be created in the recognition engine's memory, i.e. whether it will be bitonal grayscale or color.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecReductionMode Enumeration
ImportPage Method


ReductionBrightness Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : ReductionBrightness Property
Gets or sets brightness of image when reduced to bitonal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReductionBrightness As Integer
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As Integer

instance.ReductionBrightness = value

value = instance.ReductionBrightness
public int ReductionBrightness {get; set;}
public: __property int get_ReductionBrightness();
public: __property void set_ReductionBrightness(
   int value
);
public:
property int ReductionBrightness {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members


ReductionThreshold Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : ReductionThreshold Property
Gets or sets threshold used when reducing image to bitonal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReductionThreshold As Integer
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As Integer

instance.ReductionThreshold = value

value = instance.ReductionThreshold
public int ReductionThreshold {get; set;}
public: __property int get_ReductionThreshold();
public: __property void set_ReductionThreshold(
   int value
);
public:
property int ReductionThreshold {
   int get();
   void set (    int value);
}

Property Value

Integer in the range 0-100. A value of 0 tunes the conversion to give a lighter image, while a value of 100 results in a darker image.
Remarks
This property fine tunes the threshold calculation in the automatic adaptive image conversion mode (i.e. when AUTO has been specified). This influences the brightness/darkness of the resulting bitonal image.

This property influences both the primary and the secondary image conversions. It has an effect only when the AUTO image conversion mode has been specified.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members


ResEnhancementMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : ResEnhancementMode Property
Gets or sets whether resolution enhancement occurs when reducing image to bitonal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResEnhancementMode As ImGearRecResEnhancementMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecResEnhancementMode

instance.ResEnhancementMode = value

value = instance.ResEnhancementMode
public ImGearRecResEnhancementMode ResEnhancementMode {get; set;}
public: __property ImGearRecResEnhancementMode get_ResEnhancementMode();
public: __property void set_ResEnhancementMode(
   ImGearRecResEnhancementMode value
);
public:
property ImGearRecResEnhancementMode ResEnhancementMode {
   ImGearRecResEnhancementMode get();
   void set (    ImGearRecResEnhancementMode value);
}

Property Value

ImGearRecResEnhancementMode enumeration value.
Remarks
This property specifies the image resolution enhancement mode. This setting is applied only to non-bitonal images stored in the recognition engine's memory space. The value specifies whether the image resolution enhancement is to be activated during the secondary image conversion, i.e. during image pre-processing, auto-zoning or recognition. The resolution enhancement algorithm results in a bitonal image whose resolution is doubled - compared to the original image.

This setting might influence the accuracy of the recognition.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecResEnhancementMode Enumeration


SecondaryReductionMode Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : SecondaryReductionMode Property
Gets or sets image reduction during preprocessing, decomposition, and recognition steps.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SecondaryReductionMode As ImGearRecReductionMode
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As ImGearRecReductionMode

instance.SecondaryReductionMode = value

value = instance.SecondaryReductionMode
public ImGearRecReductionMode SecondaryReductionMode {get; set;}
public: __property ImGearRecReductionMode get_SecondaryReductionMode();
public: __property void set_SecondaryReductionMode(
   ImGearRecReductionMode value
);
public:
property ImGearRecReductionMode SecondaryReductionMode {
   ImGearRecReductionMode get();
   void set (    ImGearRecReductionMode value);
}

Property Value

ImGearRecReductionMode enumeration value.
Remarks
This property specifies which secondary image conversion mode will be used during an implicit secondary image conversion step. This algorithm is performed automatically when the application calls an API method (for example auto-zoning, recognition, deskew detection) whose operation requires a bitonal image, but the requested image is not a bitonal one. This setting influences how a non-bitonal image, stored in the recognition engine, will be converted to a bitonal one.

This setting might influence the accuracy of the recognition.

Valid values are AUTO, SET and GLOBAL.

If this property is set to the NO or GRAY ImGearRecReductionMode values, a warning will be created and the secondary reduction mode will not be changed from its current value.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
ImGearRecReductionMode Enumeration
Recognize Method


SkewAmount Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecPreprocessingSettings Class : SkewAmount Property
Gets or sets amount of image skew to correct when performing deskewing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SkewAmount As Integer
'Usage

Dim instance As ImGearRecPreprocessingSettings
Dim value As Integer

instance.SkewAmount = value

value = instance.SkewAmount
public int SkewAmount {get; set;}
public: __property int get_SkewAmount();
public: __property void set_SkewAmount(
   int value
);
public:
property int SkewAmount {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks

This method specifies the value of the skew (slope value). The value given here is the number of pixels of vertical ascent on 1000 horizontal pixels. That is, the tangent of the deskew angle multiplied by 1000. The slope parameter must be in the range -577 to 577; that means the maximal absolute slope value is 30 degrees. Specifying a positive value rotates the image counter clockwise.

This value is used during the PREPROCESS process when the image deskewing mode is set to SET.

Use the DetectSkew method to detect the skew of an image containing machine printed text.

See Also

Reference

ImGearRecPreprocessingSettings Class
ImGearRecPreprocessingSettings Members
DetectSkew Method


%%PageItemTitle%%

ImGearRecProgressEventArgs Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecProgressEventArgs Class
Contains arguments for the ImGearRecognition.Progress event.
Object Model
ImGearRecProgressEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecProgressEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearRecProgressEventArgs
public sealed class ImGearRecProgressEventArgs : System.EventArgs
public __gc __sealed class ImGearRecProgressEventArgs : public System.EventArgs
public ref class ImGearRecProgressEventArgs sealed : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Recognition.ImGearRecProgressEventArgs

See Also

Reference

ImGearRecProgressEventArgs Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecProgressEventArgs Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecProgressEventArgs Class

The following tables list the members exposed by ImGearRecProgressEventArgs.

Public Properties
 | Name | Description
Public Property | Abort | Gets or sets a value indicating whether the current sequence of recognition tasks aborted or not.
Public Property | Percent | Gets percent completion (from 0 to 100) of the current recognition task.
Public Property | Process | Gets process identifier of the current recognition task.
Top
See Also

Reference

ImGearRecProgressEventArgs Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecProgressEventArgs Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecProgressEventArgs Class

For a list of all members of this type, see ImGearRecProgressEventArgs members.

Public Properties
 | Name | Description
Public Property | Abort | Gets or sets a value indicating whether the current sequence of recognition tasks aborted or not.
Public Property | Percent | Gets percent completion (from 0 to 100) of the current recognition task.
Public Property | Process | Gets process identifier of the current recognition task.
Top
See Also

Reference

ImGearRecProgressEventArgs Class
ImageGear.Recognition Namespace


Abort Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecProgressEventArgs Class : Abort Property
Gets or sets a value indicating whether the current sequence of recognition tasks aborted or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Abort As Boolean
'Usage

Dim instance As ImGearRecProgressEventArgs
Dim value As Boolean

instance.Abort = value

value = instance.Abort
public bool Abort {get; set;}
public: __property bool get_Abort();
public: __property void set_Abort(
   bool value
);
public:
property bool Abort {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property is used by the application to signal to the Recognition engine that the current sequence of recognition processes should be aborted. It is typically used to implement a Cancel button in a user interface.

Set the property to true to signal that the current sequence of recognition processes should be aborted.

See Also

Reference

ImGearRecProgressEventArgs Class
ImGearRecProgressEventArgs Members
Recognize Method


Percent Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecProgressEventArgs Class : Percent Property
Gets percent completion (from 0 to 100) of the current recognition task.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Percent As Integer
'Usage

Dim instance As ImGearRecProgressEventArgs
Dim value As Integer

value = instance.Percent
public int Percent {get;}
public: __property int get_Percent();
public:
property int Percent {
   int get();
}

Property Value

Integer value from 0 to 100.
See Also

Reference

ImGearRecProgressEventArgs Class
ImGearRecProgressEventArgs Members
Recognize Method


Process Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecProgressEventArgs Class : Process Property
Gets process identifier of the current recognition task.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Process As ImGearRecProcess
'Usage

Dim instance As ImGearRecProgressEventArgs
Dim value As ImGearRecProcess

value = instance.Process
public ImGearRecProcess Process {get;}
public: __property ImGearRecProcess get_Process();
public:
property ImGearRecProcess Process {
   ImGearRecProcess get();
}

Property Value

ImGearRecProcess enumeration value.
Remarks
This property indicates which recognition process is currently executing. For the list of possible recognition processes, see ImGearRecProcess.
See Also

Reference

ImGearRecProgressEventArgs Class
ImGearRecProgressEventArgs Members
ImGearRecProcess Enumeration
Recognize Method


%%PageItemTitle%%

ImGearRecRecognitionLanguageEnabled Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionLanguageEnabled Class
Provides ability to enable or disable languages for recognition.
Object Model
ImGearRecRecognitionLanguageEnabled Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearRecRecognitionLanguageEnabled
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecRecognitionLanguageEnabled
[DefaultMember("Item")]
public sealed class ImGearRecRecognitionLanguageEnabled : ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public __gc __sealed class ImGearRecRecognitionLanguageEnabled : public ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public ref class ImGearRecRecognitionLanguageEnabled sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
Use the indexer property to enable or disable specific languages.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecRecognitionLanguageEnabled

See Also

Reference

ImGearRecRecognitionLanguageEnabled Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecRecognitionLanguageEnabled Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionLanguageEnabled Class

The following tables list the members exposed by ImGearRecRecognitionLanguageEnabled.

Public Properties
 | Name | Description
Public Property | Item | Enables or disables a recognition language.
Top
Public Methods
 | Name | Description
Public Method | DisableAll | Disables all recognition languages.
Top
See Also

Reference

ImGearRecRecognitionLanguageEnabled Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecRecognitionLanguageEnabled Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionLanguageEnabled Class

For a list of all members of this type, see ImGearRecRecognitionLanguageEnabled members.

Public Methods
 | Name | Description
Public Method | DisableAll | Disables all recognition languages.
Top
See Also

Reference

ImGearRecRecognitionLanguageEnabled Class
ImageGear.Recognition Namespace


DisableAll Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionLanguageEnabled Class : DisableAll Method
Disables all recognition languages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DisableAll()
'Usage

Dim instance As ImGearRecRecognitionLanguageEnabled

instance.DisableAll()
public void DisableAll()
public: void DisableAll();
public:
void DisableAll();
See Also

Reference

ImGearRecRecognitionLanguageEnabled Class
ImGearRecRecognitionLanguageEnabled Members


%%PageItemTitle%% $$Properties$$

ImGearRecRecognitionLanguageEnabled Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionLanguageEnabled Class

For a list of all members of this type, see ImGearRecRecognitionLanguageEnabled members.

Public Properties
 | Name | Description
Public Property | Item | Enables or disables a recognition language.
Top
See Also

Reference

ImGearRecRecognitionLanguageEnabled Class
ImageGear.Recognition Namespace


Item Property (ImGearRecRecognitionLanguageEnabled)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionLanguageEnabled Class : Item Property
An ImGearRecLanguage enumeration value that specifies the language to be enabled or disabled for recognition.
Enables or disables a recognition language.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As ImGearRecLanguage _
) As Boolean
'Usage

Dim instance As ImGearRecRecognitionLanguageEnabled
Dim index As ImGearRecLanguage
Dim value As Boolean

instance.Item(index) = value

value = instance.Item(index)
public bool this[
   ImGearRecLanguage index
]; {get; set;}
public: __property bool get_Item   ImGearRecLanguage index
;
public: __property void set_Item   ImGearRecLanguage index,
   bool value
;
public:
property bool default [ImGearRecLanguage] {
   bool get(ImGearRecLanguage index);
   void set (ImGearRecLanguage index, bool value);
}

Parameters

index
An ImGearRecLanguage enumeration value that specifies the language to be enabled or disabled for recognition.

Property Value

Boolean value.
Remarks

Recognition languages define the main part of the Language environment of the Recognition engine’s Character Set. The available languages are represented by the ImGearRecLanguage enum.

The default value for Item[ImGearRecLanguage.ENG] is true.

The default value for the rest of the items is false.

See Also

Reference

ImGearRecRecognitionLanguageEnabled Class
ImGearRecRecognitionLanguageEnabled Members
ImGearRecLanguage Enumeration


%%PageItemTitle%%

ImGearRecRecognitionSettings Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionSettings Class
Provides the settings that govern the recognition process.
Object Model
ImGearRecRecognitionSettings ClassImGearRecRecognitionLanguageEnabled ClassImGearRecUserDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecRecognitionSettings
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecRecognitionSettings
public sealed class ImGearRecRecognitionSettings : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecRecognitionSettings : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecRecognitionSettings sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
The types of settings include decomposition, language, checking, and graphics retention settings.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecRecognitionSettings

See Also

Reference

ImGearRecRecognitionSettings Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecRecognitionSettings Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionSettings Class

The following tables list the members exposed by ImGearRecRecognitionSettings.

Public Properties
 | Name | Description
Public Property | CorrectionEnabled | Gets or sets a value indicating whether correction is enabled/disabled in the checking system.
Public Property | DecompDetectNongriddedTablesEnabled | Gets or sets a value indicating whether non-gridded table detection algorithm is enabled/disabled.
Public Property | DecompMethod | Gets or sets decomposition method is used.
Public Property | DecompSingleColumnModeEnabled | Gets or sets a value indicating whether page decomposing into a single column only enabled/disabled.
Public Property | DefaultFillingMethod | Gets or sets default filling method used for zones whose filling method is DEFAULT.
Public Property | DefaultFilter | Gets or sets character set filter used for zones whose filter is DEFAULT.
Public Property | FilterPlus | Gets or sets additional filter characters to be used for zones whose filter includes PLUS.
Public Property | LanguageEnabled | Gets ability to enable/disable various languages for recognition.
Public Property | LanguagesPlus | Gets or sets additional characters to be added to the language environment.
Public Property | SpellingEnabled | Gets or sets a value indicating whether the checking system enabled/disabled.
Public Property | SpellingLanguage | Gets or sets language used for checking.
Public Property | SpellingLanguages | Gets a read-only collection of languages which can be used for checking.
Public Property | Tradeoff | Gets or sets tradeoff between accuracy and speed for recognition process.
Public Property | TrainingFilename | This property has been deprecated. Gets or sets filename of training file to read training data from.
Public Property | UserDictionary | Gets user dictionary object used for loading, editing, and saving user dictionaries for checking system.
Public Property | VerticalDictionary | Gets or sets filename of vertical dictionary used for checking.
Top
See Also

Reference

ImGearRecRecognitionSettings Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecRecognitionSettings Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionSettings Class

For a list of all members of this type, see ImGearRecRecognitionSettings members.

Public Properties
 | Name | Description
Public Property | CorrectionEnabled | Gets or sets a value indicating whether correction is enabled/disabled in the checking system.
Public Property | DecompDetectNongriddedTablesEnabled | Gets or sets a value indicating whether non-gridded table detection algorithm is enabled/disabled.
Public Property | DecompMethod | Gets or sets decomposition method is used.
Public Property | DecompSingleColumnModeEnabled | Gets or sets a value indicating whether page decomposing into a single column only enabled/disabled.
Public Property | DefaultFillingMethod | Gets or sets default filling method used for zones whose filling method is DEFAULT.
Public Property | DefaultFilter | Gets or sets character set filter used for zones whose filter is DEFAULT.
Public Property | FilterPlus | Gets or sets additional filter characters to be used for zones whose filter includes PLUS.
Public Property | LanguageEnabled | Gets ability to enable/disable various languages for recognition.
Public Property | LanguagesPlus | Gets or sets additional characters to be added to the language environment.
Public Property | SpellingEnabled | Gets or sets a value indicating whether the checking system enabled/disabled.
Public Property | SpellingLanguage | Gets or sets language used for checking.
Public Property | SpellingLanguages | Gets a read-only collection of languages which can be used for checking.
Public Property | Tradeoff | Gets or sets tradeoff between accuracy and speed for recognition process.
Public Property | TrainingFilename | This property has been deprecated. Gets or sets filename of training file to read training data from.
Public Property | UserDictionary | Gets user dictionary object used for loading, editing, and saving user dictionaries for checking system.
Public Property | VerticalDictionary | Gets or sets filename of vertical dictionary used for checking.
Top
See Also

Reference

ImGearRecRecognitionSettings Class
ImageGear.Recognition Namespace


CorrectionEnabled Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : CorrectionEnabled Property
Gets or sets a value indicating whether correction is enabled/disabled in the checking system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CorrectionEnabled As Boolean
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As Boolean

instance.CorrectionEnabled = value

value = instance.CorrectionEnabled
public bool CorrectionEnabled {get; set;}
public: __property bool get_CorrectionEnabled();
public: __property void set_CorrectionEnabled(
   bool value
);
public:
property bool CorrectionEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

This method enables or disables the Correction mode setting of the checking subsystem. If this mode is enabled, non-compliant words may be automatically corrected during recognition. The Correction mode is a page-level setting, i.e. when it is enabled, it will be applied to all zones of the page for which at least one of the three possible checking algorithms have been enabled. The application should set this (and other checking-related properties) BEFORE calling the Recognize method.

If CorrectionEnabled is set to false, non-compliant words will be flagged, but no auto-correction will be done. If CorrectionEnabled is set to true, all unchanged non-compliant words will be flagged, while some characters may also be changed by the checking subsystem.

Though the Correction mode is a page-level setting, it can be disabled for any particular zone by setting the CORRECTION_DISABLE flag of the zone's Checking property.

The correction feature will construct possible solutions from two sources only: any second or third character guesses for the characters in the word or character-pair solutions in the TEV.SZO file, designed to handle typical OCR-misrecognitions. These solutions are passed to the checking subsystem, which may result in a refused word being changed.

The default value is true.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
Recognize Method
ImGearRecZone Class
ImGearRecZoneCheckingFlags Enumeration


DecompDetectNongriddedTablesEnabled Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : DecompDetectNongriddedTablesEnabled Property
Gets or sets a value indicating whether non-gridded table detection algorithm is enabled/disabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DecompDetectNongriddedTablesEnabled As Boolean
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As Boolean

instance.DecompDetectNongriddedTablesEnabled = value

value = instance.DecompDetectNongriddedTablesEnabled
public bool DecompDetectNongriddedTablesEnabled {get; set;}
public: __property bool get_DecompDetectNongriddedTablesEnabled();
public: __property void set_DecompDetectNongriddedTablesEnabled(
   bool value
);
public:
property bool DecompDetectNongriddedTablesEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

This property sets the Non-gridded table detection setting of the recognition engine.

Tables with visible gridlines (gridded tables) in an original page can usually be detected successfully by auto-zoning. In contrast, tables without visible cell separators in the original are harder to identify as tables, because they could equally as well be word lists or data arranged in columns. The Recognition component offers an algorithm for detecting such non-gridded tables more confidently. This feature of the recognition engine can only be used in conjunction with an auto-zoning step. The algorithm is based on the result of the character recognition.

When this feature is enabled, a special algorithm tries to find non-gridded table(s) on the image. This algorithm is based on the existing zone list of the image and also on the recognized characters, i.e. this algorithm is activated as one of the last steps in the character recognition.

Because of this, its effect might be visible only after a Recognize call.

The running of this algorithm is strongly controlled, since it may change the zone list belonging to the image. Accordingly, the non-gridded table detection feature may be allowed to run only if all the following conditions are met:

  • the zone list was created through auto-zoning (Locate),
  • there was no change in the zone list
  • none of the zones in zone list was updated by modifying the zone coordinates

It is recommended to disable the Non-gridded table detection algorithm when the FAST page parser algorithm was selected (see: DecompMethod property).

The default value is true.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
Recognize Method
ImGearRecZone Class
ImGearRecZoneCollection Class


DecompMethod Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : DecompMethod Property
Gets or sets decomposition method is used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DecompMethod As ImGearRecDecompositionMethod
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecDecompositionMethod

instance.DecompMethod = value

value = instance.DecompMethod
public ImGearRecDecompositionMethod DecompMethod {get; set;}
public: __property ImGearRecDecompositionMethod get_DecompMethod();
public: __property void set_DecompMethod(
   ImGearRecDecompositionMethod value
);
public:
property ImGearRecDecompositionMethod DecompMethod {
   ImGearRecDecompositionMethod get();
   void set (    ImGearRecDecompositionMethod value);
}

Property Value

ImGearRecDecompositionMethod enumeration value.
Remarks
This property is used to specify the Page parser algorithm setting. This setting is applied whenever the auto-zoning algorithm is activated. The following algorithms are available:
  • AUTO - Specifies that the recognition engine will determine at run-time which page parser algorithm will be applied. (Default.)
  • FAST - This algorithm can be treated as a simplified variant of LEGACY: this algorithm doesn't try to find tables on the page. It is the fastest (but least accurate) parsing algorithm available. Use it only for simple page parsing tasks!
  • LEGACY - The page-parsing algorithm used in the toolkit till version 10.0.
  • STANDARD - The most accurate page parsing algorithm of the recognition engine.
See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecDecompositionMethod Enumeration


DecompSingleColumnModeEnabled Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : DecompSingleColumnModeEnabled Property
Gets or sets a value indicating whether page decomposing into a single column only enabled/disabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DecompSingleColumnModeEnabled As Boolean
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As Boolean

instance.DecompSingleColumnModeEnabled = value

value = instance.DecompSingleColumnModeEnabled
public bool DecompSingleColumnModeEnabled {get; set;}
public: __property bool get_DecompSingleColumnModeEnabled();
public: __property void set_DecompSingleColumnModeEnabled(
   bool value
);
public:
property bool DecompSingleColumnModeEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property specifies the Force Single Column mode for the page-layout (auto-zoning) process. It prevents the decolumnization detecting columns and placing their contents one below the other. It is useful for conserving the columnar structure in tables.

It is highly recommended to switch this on sparingly, only for cases where the image has a single tabular structure and chances are that the automatic decomposition would fail to analyze the layout properly. Its effects are applied to whole pages.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members


DefaultFillingMethod Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : DefaultFillingMethod Property
Gets or sets default filling method used for zones whose filling method is DEFAULT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultFillingMethod As ImGearRecFillingMethod
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecFillingMethod

instance.DefaultFillingMethod = value

value = instance.DefaultFillingMethod
public ImGearRecFillingMethod DefaultFillingMethod {get; set;}
public: __property ImGearRecFillingMethod get_DefaultFillingMethod();
public: __property void set_DefaultFillingMethod(
   ImGearRecFillingMethod value
);
public:
property ImGearRecFillingMethod DefaultFillingMethod {
   ImGearRecFillingMethod get();
   void set (    ImGearRecFillingMethod value);
}

Property Value

ImGearRecFillingMethod enumeration value.
Remarks
This property specifies the default filling method for the page. The default filling method is applied to all zones on the page with the DEFAULT value in their ImGearRecZone.FillingMethod property.

This substitution of the filling method happens at the beginning of the Recognize call.

The default value is ImGearRecFillingMethod.OMNIFONT.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecFillingMethod Enumeration
Recognize Method
ImGearRecZone Class
DetectFillingMethod Method
ImGearRecModuleCollection Class


DefaultFilter Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : DefaultFilter Property
Gets or sets character set filter used for zones whose filter is DEFAULT.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultFilter As ImGearRecFilter
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecFilter

instance.DefaultFilter = value

value = instance.DefaultFilter
public ImGearRecFilter DefaultFilter {get; set;}
public: __property ImGearRecFilter get_DefaultFilter();
public: __property void set_DefaultFilter(
   ImGearRecFilter value
);
public:
property ImGearRecFilter DefaultFilter {
   ImGearRecFilter get();
   void set (    ImGearRecFilter value);
}

Property Value

ImGearRecFilter enumeration value.
Remarks
This property specifies a Global filter, i.e. a Character Set filter to be applied globally, at page level. If this property is not set by the integrating application after the recognition engine initialization, the value ALL is applied, i.e. the Language environment will not be filtered globally. The Global filter setting is applied to all zones with DEFAULT in their ImGearRecZone.Filter property.

The default value is ImGearRecFilter.ALL.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecFilter Enumeration
ImGearRecognition Class
ImGearRecZone Class


FilterPlus Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : FilterPlus Property
Gets or sets additional filter characters to be used for zones whose filter includes PLUS.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FilterPlus As String
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As String

instance.FilterPlus = value

value = instance.FilterPlus
public string FilterPlus {get; set;}
public: __property string* get_FilterPlus();
public: __property void set_FilterPlus(
   string* value
);
public:
property String^ FilterPlus {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
This property specifies a set of individual characters, the FilterPlus characters. The FilterPlus characters broaden or define the filtered set of characters globally or on a per-zone basis. To validate FilterPlus characters, the ImGearRecZone.Filter property should have the ImGearRecFilter.PLUS flag enabled, with or without other filter elements.

The default value is "".

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ConvertCodePageToUnicode Method
CodePage Property
ImGearRecZone Class


LanguageEnabled Property
Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : LanguageEnabled Property
Gets ability to enable/disable various languages for recognition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LanguageEnabled As ImGearRecRecognitionLanguageEnabled
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecRecognitionLanguageEnabled

value = instance.LanguageEnabled
public ImGearRecRecognitionLanguageEnabled LanguageEnabled {get;}
public: __property ImGearRecRecognitionLanguageEnabled* get_LanguageEnabled();
public:
property ImGearRecRecognitionLanguageEnabled^ LanguageEnabled {
   ImGearRecRecognitionLanguageEnabled^ get();
}

Property Value

ImGearRecRecognitionLanguageEnabled class object.
Example
  • C#
igRecognition.Recognition.LanguageEnabled.DisableAll();
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.GER] = true;
igRecognition.Recognition.LanguageEnabled[ImGearRecLanguage.ENG] = true;
  • Visual Basic
igRecognition.Recognition.LanguageEnabled.DisableAll()
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.GER) = True
igRecognition.Recognition.LanguageEnabled(ImGearRecLanguage.ENG) = True
See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecRecognitionLanguageEnabled Class
ConvertCodePageToUnicode Method


LanguagesPlus Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : LanguagesPlus Property
Gets or sets additional characters to be added to the language environment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LanguagesPlus As String
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As String

instance.LanguagesPlus = value

value = instance.LanguagesPlus
public string LanguagesPlus {get; set;}
public: __property string* get_LanguagesPlus();
public: __property void set_LanguagesPlus(
   string* value
);
public:
property String^ LanguagesPlus {
   String^ get();
   void set (    String^ value);
}

Property Value

String name.
Remarks
This property is used to specify some individual characters, the LanguagesPlus characters. These characters are added to the set of characters determined by the language selection. The resulting set of characters is called the Language environment.

The default value is "".

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ConvertCodePageToUnicode Method


SpellingEnabled Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : SpellingEnabled Property
Gets or sets a value indicating whether the checking system enabled/disabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpellingEnabled As Boolean
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As Boolean

instance.SpellingEnabled = value

value = instance.SpellingEnabled
public bool SpellingEnabled {get; set;}
public: __property bool get_SpellingEnabled();
public: __property void set_SpellingEnabled(
   bool value
);
public:
property bool SpellingEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
This property enables or disables the checking subsystem. Its running may improve the overall throughput by marking suspicious words and characters, making it easier to correct them. It can also be set to improve accuracy, by auto-correcting suspicious recognized words.

The default value is true.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members


SpellingLanguage Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : SpellingLanguage Property
Gets or sets language used for checking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpellingLanguage As ImGearRecLanguage
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecLanguage

instance.SpellingLanguage = value

value = instance.SpellingLanguage
public ImGearRecLanguage SpellingLanguage {get; set;}
public: __property ImGearRecLanguage get_SpellingLanguage();
public: __property void set_SpellingLanguage(
   ImGearRecLanguage value
);
public:
property ImGearRecLanguage SpellingLanguage {
   ImGearRecLanguage get();
   void set (    ImGearRecLanguage value);
}

Property Value

ImGearRecLanguage enumeration value.
Remarks
This property specifies the Spelling language for the language checking of the checking subsystem.

The default value is ImGearRecLanguage.AUTO.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecLanguage Enumeration


SpellingLanguages Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : SpellingLanguages Property
Gets a read-only collection of languages which can be used for checking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SpellingLanguages As ReadOnlyCollection(Of ImGearRecLanguage)
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ReadOnlyCollection(Of ImGearRecLanguage)

value = instance.SpellingLanguages
public ReadOnlyCollection<ImGearRecLanguage> SpellingLanguages {get;}
public: __property ReadOnlyCollection<ImGearRecLanguage>* get_SpellingLanguages();
public:
property ReadOnlyCollection<ImGearRecLanguage>^ SpellingLanguages {
   ReadOnlyCollection<ImGearRecLanguage>^ get();
}

Property Value

ReadOnlyCollection of ImGearRecLanguage enumeration values.
Remarks
The returned collection lists the languages which can be used by the checking system. The engine enumerates all dictionaries present in the Recognition engine binary directory to build this collection.
See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecLanguage Enumeration


Tradeoff Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : Tradeoff Property
Gets or sets tradeoff between accuracy and speed for recognition process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tradeoff As ImGearRecTradeoff
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecTradeoff

instance.Tradeoff = value

value = instance.Tradeoff
public ImGearRecTradeoff Tradeoff {get; set;}
public: __property ImGearRecTradeoff get_Tradeoff();
public: __property void set_Tradeoff(
   ImGearRecTradeoff value
);
public:
property ImGearRecTradeoff Tradeoff {
   ImGearRecTradeoff get();
   void set (    ImGearRecTradeoff value);
}

Property Value

ImGearRecTradeoff enumeration value.
Remarks

If this property is set to ImGearRecTradeoff.FAST, a faster, but less accurate deskew, binarization, and despeckle algorithm will be used for the Preprocess method.

The default value is ImGearRecTradeoff.ACCURATE.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecTradeoff Enumeration


TrainingFilename Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : TrainingFilename Property
This property has been deprecated. Gets or sets filename of training file to read training data from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release.")>
Public Property TrainingFilename As String
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As String

instance.TrainingFilename = value

value = instance.TrainingFilename
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public string TrainingFilename {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public: __property string* get_TrainingFilename();
public: __property void set_TrainingFilename(
   string* value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public:
property String^ TrainingFilename {
   String^ get();
   void set (    String^ value);
}

Property Value

String name.
Remarks

The default value is "".

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members


UserDictionary Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : UserDictionary Property
Gets user dictionary object used for loading, editing, and saving user dictionaries for checking system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UserDictionary As ImGearRecUserDictionary
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As ImGearRecUserDictionary

value = instance.UserDictionary
public ImGearRecUserDictionary UserDictionary {get;}
public: __property ImGearRecUserDictionary* get_UserDictionary();
public:
property ImGearRecUserDictionary^ UserDictionary {
   ImGearRecUserDictionary^ get();
}

Property Value

ImGearRecUserDictionary class object.
Remarks
Provides access to the user dictionary object used for loading, editing, and saving user dictionaries for the checking system.
See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members
ImGearRecUserDictionary Class


VerticalDictionary Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecRecognitionSettings Class : VerticalDictionary Property
Gets or sets filename of vertical dictionary used for checking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalDictionary As String
'Usage

Dim instance As ImGearRecRecognitionSettings
Dim value As String

instance.VerticalDictionary = value

value = instance.VerticalDictionary
public string VerticalDictionary {get; set;}
public: __property string* get_VerticalDictionary();
public: __property void set_VerticalDictionary(
   string* value
);
public:
property String^ VerticalDictionary {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks

This property specifies a Vertical dictionary for the checking subsystem. The property operates with text names of the dictionaries, e.g. "Dutch Legal Dictionary".

See Spell Checking for additional details and examples on vectical dictionary usage. See Vertical Dictionary List for the list of supported vertical dictionaries.

See Also

Reference

ImGearRecRecognitionSettings Class
ImGearRecRecognitionSettings Members


%%PageItemTitle%%

ImGearRecSettingsCollectionObjectBase Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecSettingsCollectionObjectBase Class
Base class for objects that access a Settings Collection.
Object Model
ImGearRecSettingsCollectionObjectBase Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecSettingsCollectionObjectBase
public abstract class ImGearRecSettingsCollectionObjectBase
public __gc abstract class ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecSettingsCollectionObjectBase abstract
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecAsianSettings
ImageGear.Recognition.ImGearRecDocument
ImageGear.Recognition.ImGearRecImage
ImageGear.Recognition.ImGearRecModuleCollection
ImageGear.Recognition.ImGearRecMORSettings
ImageGear.Recognition.ImGearRecognition
ImageGear.Recognition.ImGearRecOutputManager
ImageGear.Recognition.ImGearRecPage
ImageGear.Recognition.ImGearRecPreprocessingSettings
ImageGear.Recognition.ImGearRecRecognitionLanguageEnabled
ImageGear.Recognition.ImGearRecRecognitionSettings
ImageGear.Recognition.ImGearRecStatistics
ImageGear.Recognition.ImGearRecUserDictionary
ImageGear.Recognition.ImGearRecZoneCollection

See Also

Reference

ImGearRecSettingsCollectionObjectBase Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecSettingsCollectionObjectBase Class Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecSettingsCollectionObjectBase Class

The following tables list the members exposed by ImGearRecSettingsCollectionObjectBase.

See Also

Reference

ImGearRecSettingsCollectionObjectBase Class
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecStatistics Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecStatistics Class
Statistics from recognition processes, exposed via ImGearRecPage.Statistics property.
Object Model
ImGearRecStatistics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecStatistics
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecStatistics
public sealed class ImGearRecStatistics : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecStatistics : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecStatistics sealed : public ImGearRecSettingsCollectionObjectBase
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecStatistics

See Also

Reference

ImGearRecStatistics Members
ImageGear.Recognition Namespace
Recognize Method
WriteDocument Method


%%PageItemTitle%% $$Members$$

ImGearRecStatistics Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecStatistics Class

The following tables list the members exposed by ImGearRecStatistics.

Public Properties
 | Name | Description
Public Property | CharCount | Gets number of recognized characters.
Public Property | DecompTime | Gets time spent on the image's page-layout decomposition, i.e. auto-zoning.
Public Property | PreProcTime | Gets time spent on image pre-processing.
Public Property | ReadTime | Gets time spent on the image from the start of the recognition process.
Public Property | RecognitionTime | Gets time spent on recognition of the image content.
Public Property | RejectedCharCount | Gets number of rejected characters.
Public Property | WordCount | Gets number of recognized words.
Top
See Also

Reference

ImGearRecStatistics Class
ImageGear.Recognition Namespace
Recognize Method
WriteDocument Method


%%PageItemTitle%% $$Properties$$

ImGearRecStatistics Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecStatistics Class

For a list of all members of this type, see ImGearRecStatistics members.

Public Properties
 | Name | Description
Public Property | CharCount | Gets number of recognized characters.
Public Property | DecompTime | Gets time spent on the image's page-layout decomposition, i.e. auto-zoning.
Public Property | PreProcTime | Gets time spent on image pre-processing.
Public Property | ReadTime | Gets time spent on the image from the start of the recognition process.
Public Property | RecognitionTime | Gets time spent on recognition of the image content.
Public Property | RejectedCharCount | Gets number of rejected characters.
Public Property | WordCount | Gets number of recognized words.
Top
See Also

Reference

ImGearRecStatistics Class
ImageGear.Recognition Namespace
Recognize Method
WriteDocument Method


CharCount Property (ImGearRecStatistics)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : CharCount Property
Gets number of recognized characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CharCount As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.CharCount
public int CharCount {get;}
public: __property int get_CharCount();
public:
property int CharCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


DecompTime Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : DecompTime Property
Gets time spent on the image's page-layout decomposition, i.e. auto-zoning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DecompTime As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.DecompTime
public int DecompTime {get;}
public: __property int get_DecompTime();
public:
property int DecompTime {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


PreProcTime Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : PreProcTime Property
Gets time spent on image pre-processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PreProcTime As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.PreProcTime
public int PreProcTime {get;}
public: __property int get_PreProcTime();
public:
property int PreProcTime {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


ReadTime Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : ReadTime Property
Gets time spent on the image from the start of the recognition process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ReadTime As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.ReadTime
public int ReadTime {get;}
public: __property int get_ReadTime();
public:
property int ReadTime {
   int get();
}

Property Value

Integer value.
Remarks

This includes the time from RecognitionTime property and further steps as follows:

It also consists of the time necessary for sorting the output coming from the different recognition modules, the time spent with the checking subsystem, and the time required to produce the recognition result (e.g. the time necessary to write the recognition result into the recognition data file).

This time may also include the time needed for transferring the recognition result into the final output document - supposing that the statistical information was requested after converting to the final output document.

See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members
Recognize Method
WriteDocument Method


RecognitionTime Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : RecognitionTime Property
Gets time spent on recognition of the image content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RecognitionTime As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.RecognitionTime
public int RecognitionTime {get;}
public: __property int get_RecognitionTime();
public:
property int RecognitionTime {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


RejectedCharCount Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : RejectedCharCount Property
Gets number of rejected characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RejectedCharCount As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.RejectedCharCount
public int RejectedCharCount {get;}
public: __property int get_RejectedCharCount();
public:
property int RejectedCharCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


WordCount Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecStatistics Class : WordCount Property
Gets number of recognized words.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property WordCount As Integer
'Usage

Dim instance As ImGearRecStatistics
Dim value As Integer

value = instance.WordCount
public int WordCount {get;}
public: __property int get_WordCount();
public:
property int WordCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearRecStatistics Class
ImGearRecStatistics Members


%%PageItemTitle%%

ImGearRecUDItem Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUDItem Class
Represents an item (word) in the user dictionary.
Object Model
ImGearRecUDItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecUDItem
'Usage

Dim instance As ImGearRecUDItem
public sealed class ImGearRecUDItem
public __gc __sealed class ImGearRecUDItem
public ref class ImGearRecUDItem sealed
Remarks
See Preparing and Maintaining the User Dictionary section for more information.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecUDItem

See Also

Reference

ImGearRecUDItem Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecUDItem Class Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUDItem Class

The following tables list the members exposed by ImGearRecUDItem.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecUDItem Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | IsRegExp | Gets or sets a value indicating whether or not the item is a regular expression.
Public Property | ItemText | Gets or sets the item text (word or regular expression).
Public Property | SectionName | Gets or sets the name of the user dictionary section to which this item belongs.
Top
See Also

Reference

ImGearRecUDItem Class
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecUDItem Constructor

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class : ImGearRecUDItem Constructor
Overload List
Overload | Description
ImGearRecUDItem Constructor(String,String) | Initializes a new instance of the ImGearRecUDItem class.
ImGearRecUDItem Constructor(String,String,Boolean) | Initializes a new instance of the ImGearRecUDItem class.
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members


%%PageItemTitle%%

ImGearRecUDItem Constructor(String,String)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class > ImGearRecUDItem Constructor : ImGearRecUDItem Constructor(String,String)
Section the item belongs to in the user dictionary.
Item text (word).
Initializes a new instance of the ImGearRecUDItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sectionName As String, _
   ByVal itemText As String _
)
'Usage

Dim sectionName As String
Dim itemText As String

Dim instance As New ImGearRecUDItem(sectionName, itemText)
public ImGearRecUDItem(
   string sectionName,
   string itemText
)
public: ImGearRecUDItem(
   string* sectionName,
   string* itemText
)
public:
ImGearRecUDItem(
   String^ sectionName,
   String^ itemText
)

Parameters

sectionName
Section the item belongs to in the user dictionary.
itemText
Item text (word).
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members
Overload List
ImGearRecUDItem Class


%%PageItemTitle%%

ImGearRecUDItem Constructor(String,String,Boolean)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class > ImGearRecUDItem Constructor : ImGearRecUDItem Constructor(String,String,Boolean)
Section the item belongs to in the user dictionary.
Item text (word).
Set to true if the item is a regular expression, otherwise false.
Initializes a new instance of the ImGearRecUDItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sectionName As String, _
   ByVal itemText As String, _
   ByVal isRegularExpression As Boolean _
)
'Usage

Dim sectionName As String
Dim itemText As String
Dim isRegularExpression As Boolean

Dim instance As New ImGearRecUDItem(sectionName, itemText, isRegularExpression)
public ImGearRecUDItem(
   string sectionName,
   string itemText,
   bool isRegularExpression
)
public: ImGearRecUDItem(
   string* sectionName,
   string* itemText,
   bool isRegularExpression
)
public:
ImGearRecUDItem(
   String^ sectionName,
   String^ itemText,
   bool isRegularExpression
)

Parameters

sectionName
Section the item belongs to in the user dictionary.
itemText
Item text (word).
isRegularExpression
Set to true if the item is a regular expression, otherwise false.
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members
Overload List
ImGearRecUDItem Class


%%PageItemTitle%% $$Properties$$

ImGearRecUDItem Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUDItem Class

For a list of all members of this type, see ImGearRecUDItem members.

Public Properties
 | Name | Description
Public Property | IsRegExp | Gets or sets a value indicating whether or not the item is a regular expression.
Public Property | ItemText | Gets or sets the item text (word or regular expression).
Public Property | SectionName | Gets or sets the name of the user dictionary section to which this item belongs.
Top
See Also

Reference

ImGearRecUDItem Class
ImageGear.Recognition Namespace


IsRegExp Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class : IsRegExp Property
Gets or sets a value indicating whether or not the item is a regular expression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsRegExp As Boolean
'Usage

Dim instance As ImGearRecUDItem
Dim value As Boolean

instance.IsRegExp = value

value = instance.IsRegExp
public bool IsRegExp {get; set;}
public: __property bool get_IsRegExp();
public: __property void set_IsRegExp(
   bool value
);
public:
property bool IsRegExp {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members


ItemText Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class : ItemText Property
Gets or sets the item text (word or regular expression).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemText As String
'Usage

Dim instance As ImGearRecUDItem
Dim value As String

instance.ItemText = value

value = instance.ItemText
public string ItemText {get; set;}
public: __property string* get_ItemText();
public: __property void set_ItemText(
   string* value
);
public:
property String^ ItemText {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members


SectionName Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUDItem Class : SectionName Property
Gets or sets the name of the user dictionary section to which this item belongs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SectionName As String
'Usage

Dim instance As ImGearRecUDItem
Dim value As String

instance.SectionName = value

value = instance.SectionName
public string SectionName {get; set;}
public: __property string* get_SectionName();
public: __property void set_SectionName(
   string* value
);
public:
property String^ SectionName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearRecUDItem Class
ImGearRecUDItem Members


%%PageItemTitle%%

ImGearRecUserDictionary Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUserDictionary Class
Provides access to the user dictionary used for recognition.
Object Model
ImGearRecUserDictionary ClassImGearRecUDItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecUserDictionary
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecUserDictionary
public sealed class ImGearRecUserDictionary : ImGearRecSettingsCollectionObjectBase
public __gc __sealed class ImGearRecUserDictionary : public ImGearRecSettingsCollectionObjectBase
public ref class ImGearRecUserDictionary sealed : public ImGearRecSettingsCollectionObjectBase
Remarks
See Preparing and Maintaining the User Dictionary section for more information.
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecUserDictionary

See Also

Reference

ImGearRecUserDictionary Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecUserDictionary Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUserDictionary Class

The following tables list the members exposed by ImGearRecUserDictionary.

Public Properties
 | Name | Description
Public Property | Modified | Gets a value indicating whether or not the user dictionary has been modified since being loaded.
Top
Public Methods
 | Name | Description
Public Method | AddItem | Adds an item to the user dictionary.
Public Method | Close | Closes the user dictionary.
Public Method | Create | Overloaded. Creates a new user dictionary.
Public Method | DeleteItem | Deletes an item from the user dictionary.
Public Method | GetItems | Returns an array of items in the specified section of the user dictionary.
Public Method | GetSections | Returns the names of sections in the user dictionary.
Public Method | Load | Overloaded. Loads the user dictionary from a file.
Public Method | Save | Saves the user dictionary to a file.
Top
See Also

Reference

ImGearRecUserDictionary Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecUserDictionary Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUserDictionary Class

For a list of all members of this type, see ImGearRecUserDictionary members.

Public Methods
 | Name | Description
Public Method | AddItem | Adds an item to the user dictionary.
Public Method | Close | Closes the user dictionary.
Public Method | Create | Overloaded. Creates a new user dictionary.
Public Method | DeleteItem | Deletes an item from the user dictionary.
Public Method | GetItems | Returns an array of items in the specified section of the user dictionary.
Public Method | GetSections | Returns the names of sections in the user dictionary.
Public Method | Load | Overloaded. Loads the user dictionary from a file.
Public Method | Save | Saves the user dictionary to a file.
Top
See Also

Reference

ImGearRecUserDictionary Class
ImageGear.Recognition Namespace


AddItem Method (ImGearRecUserDictionary)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : AddItem Method
Item to be added to the user dictionary.
Adds an item to the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddItem( _
   ByVal item As ImGearRecUDItem _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim item As ImGearRecUDItem

instance.AddItem(item)
public void AddItem(
   ImGearRecUDItem item
)
public: void AddItem(
   ImGearRecUDItem* item
)
public:
void AddItem(
   ImGearRecUDItem^ item
)

Parameters

item
Item to be added to the user dictionary.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
ImGearRecUDItem Class


Close Method (ImGearRecUserDictionary)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : Close Method
Closes the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As ImGearRecUserDictionary

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Remarks
This must be done before performing recognition, if the user dictionary was examined or modified after being loaded.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


Create Method (ImGearRecUserDictionary)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : Create Method
Creates a new user dictionary.
Overload List
Overload | Description
Create() | Creates a new user dictionary.
Create(String) | Creates a new user dictionary.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


Create() Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class > Create Method : Create() Method
Creates a new user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Create()
'Usage

Dim instance As ImGearRecUserDictionary

instance.Create()
public void Create()
public: void Create();
public:
void Create();
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
Overload List


Create(String) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class > Create Method : Create(String) Method
Default section name used for adding items to the user dictionary.
Creates a new user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Create( _
   ByVal defaultSectionName As String _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim defaultSectionName As String

instance.Create(defaultSectionName)
public void Create(
   string defaultSectionName
)
public: void Create(
   string* defaultSectionName
)
public:
void Create(
   String^ defaultSectionName
)

Parameters

defaultSectionName
Default section name used for adding items to the user dictionary.
Remarks
Creates a new user dictionary with a specified default section name. The default section name is used for adding new items to the user dictionary.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
Overload List


DeleteItem Method (ImGearRecUserDictionary)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : DeleteItem Method
ImGearRecUDItem specifying properties of item to delete from the user dictionary.
Deletes an item from the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteItem( _
   ByVal item As ImGearRecUDItem _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim item As ImGearRecUDItem

instance.DeleteItem(item)
public void DeleteItem(
   ImGearRecUDItem item
)
public: void DeleteItem(
   ImGearRecUDItem* item
)
public:
void DeleteItem(
   ImGearRecUDItem^ item
)

Parameters

item
ImGearRecUDItem specifying properties of item to delete from the user dictionary.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
ImGearRecUDItem Class


GetItems Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : GetItems Method
Name of section in the user dictionary to return items from.
Returns an array of items in the specified section of the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItems( _
   ByVal sectionName As String _
) As ImGearRecUDItem()
'Usage

Dim instance As ImGearRecUserDictionary
Dim sectionName As String
Dim value() As ImGearRecUDItem

value = instance.GetItems(sectionName)
public ImGearRecUDItem[] GetItems(
   string sectionName
)
public: ImGearRecUDItem*[]* GetItems(
   string* sectionName
)
public:
array<ImGearRecUDItem^>^ GetItems(
   String^ sectionName
)

Parameters

sectionName
Name of section in the user dictionary to return items from.

Return Value

ImGearRecUDItem class array.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
ImGearRecUDItem Class


GetSections Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : GetSections Method
Returns the names of sections in the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated and will be removed from the public API in a future release.")>
Public Function GetSections() As String()
'Usage

Dim instance As ImGearRecUserDictionary
Dim value() As String

value = instance.GetSections()
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public string[] GetSections()
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public: string*[]* GetSections();
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public:
array<String^>^ GetSections();

Return Value

String array value.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


Load Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : Load Method
Loads the user dictionary from a file.
Overload List
Overload | Description
Load(String) | Loads the user dictionary from a file.
Load(String,String) | Loads the user dictionary from a file.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


Load(String) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class > Load Method : Load(String) Method
Path to the user dictionary file to load.
Loads the user dictionary from a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim path As String

instance.Load(path)
public void Load(
   string path
)
public: void Load(
   string* path
)
public:
void Load(
   String^ path
)

Parameters

path
Path to the user dictionary file to load.
Remarks
Loads a user dictionary from a file.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
Overload List


Load(String,String) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class > Load Method : Load(String,String) Method
Path to the user dictionary file to load.
Default section name used for adding items to the user dictionary.
Loads the user dictionary from a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal path As String, _
   ByVal defaultSectionName As String _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim path As String
Dim defaultSectionName As String

instance.Load(path, defaultSectionName)
public void Load(
   string path,
   string defaultSectionName
)
public: void Load(
   string* path,
   string* defaultSectionName
)
public:
void Load(
   String^ path,
   String^ defaultSectionName
)

Parameters

path
Path to the user dictionary file to load.
defaultSectionName
Default section name used for adding items to the user dictionary.
Remarks
Loads a user dictionary from a file, specifying a default section name used for new items added to the user dictionary.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members
Overload List


Save Method (ImGearRecUserDictionary)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : Save Method
File path to save user dictionary to.
Saves the user dictionary to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Save( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecUserDictionary
Dim path As String

instance.Save(path)
public void Save(
   string path
)
public: void Save(
   string* path
)
public:
void Save(
   String^ path
)

Parameters

path
File path to save user dictionary to.
Remarks
Note:If the file already exists, it is replaced.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


%%PageItemTitle%% $$Properties$$

ImGearRecUserDictionary Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecUserDictionary Class

For a list of all members of this type, see ImGearRecUserDictionary members.

Public Properties
 | Name | Description
Public Property | Modified | Gets a value indicating whether or not the user dictionary has been modified since being loaded.
Top
See Also

Reference

ImGearRecUserDictionary Class
ImageGear.Recognition Namespace


Modified Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecUserDictionary Class : Modified Property
Gets a value indicating whether or not the user dictionary has been modified since being loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Modified As Boolean
'Usage

Dim instance As ImGearRecUserDictionary
Dim value As Boolean

value = instance.Modified
public bool Modified {get;}
public: __property bool get_Modified();
public:
property bool Modified {
   bool get();
}

Property Value

Boolean value.
Remarks
If this property returns true, the user dictionary must be closed before performing recognition.
See Also

Reference

ImGearRecUserDictionary Class
ImGearRecUserDictionary Members


%%PageItemTitle%%

ImGearRecZone Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZone Class
Represents a recognition zone.
Object Model
ImGearRecZone ClassIImGearRectangle Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecZone
'Usage

Dim instance As ImGearRecZone
public sealed class ImGearRecZone
public __gc __sealed class ImGearRecZone
public ref class ImGearRecZone sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecZone

See Also

Reference

ImGearRecZone Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZone Class Members
Properties Methods Events

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZone Class

The following tables list the members exposed by ImGearRecZone.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecZone Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Checking | Gets or sets zone checking flags.
Public Property | CheckWordIsUsed | Gets a value indicating whether any event handlers are currently registered for the CheckWord event.
Public Property | FillingMethod | Gets or sets zone filling method.
Public Property | Filter | Gets or sets the character set filter for the zone.
Public Property | RecognitionModule | Gets or sets the recognition module to use when performing recognition on the zone.
Public Property | Rect | Gets a reference to the rectangle whose coordinates (in pixels) define the zone boundaries.
Public Property | Type | Gets or sets zone type.
Public Property | UserData | Gets or sets custom user-defined data.
Public Property | UserDictionarySection | Gets or sets the section name to use in the user dictionary.
Top
Public Methods
 | Name | Description
Public Method | ClearCheckWord | Clear any subscribers to the CheckWord event.
Top
Public Events
 | Name | Description
Public Event | CheckWord | Event used for user-defined checking.
Top
See Also

Reference

ImGearRecZone Class
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecZone Constructor

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : ImGearRecZone Constructor
Overload List
Overload | Description
ImGearRecZone Constructor() | Initializes a new instance of the ImGearRecZone class.
ImGearRecZone Constructor(ImGearRecFillingMethod,ImGearRecRecognitionModule) | Initializes a new instance of the ImGearRecZone class.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members


%%PageItemTitle%%

ImGearRecZone Constructor()

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class > ImGearRecZone Constructor : ImGearRecZone Constructor()
Initializes a new instance of the ImGearRecZone class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecZone()
public ImGearRecZone()
public: ImGearRecZone();
public:
ImGearRecZone();
Remarks
Note:The application must then set various properties of the zone before adding it to the zone list.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
Overload List
ImGearRecZone Class


%%PageItemTitle%%

ImGearRecZone Constructor(ImGearRecFillingMethod,ImGearRecRecognitionModule)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class > ImGearRecZone Constructor : ImGearRecZone Constructor(ImGearRecFillingMethod,ImGearRecRecognitionModule)
Filling method to set for the zone.
Recognition module to set for the zone.
Initializes a new instance of the ImGearRecZone class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fillingMethod As ImGearRecFillingMethod, _
   ByVal recognitionModule As ImGearRecRecognitionModule _
)
'Usage

Dim fillingMethod As ImGearRecFillingMethod
Dim recognitionModule As ImGearRecRecognitionModule

Dim instance As New ImGearRecZone(fillingMethod, recognitionModule)
public ImGearRecZone(
   ImGearRecFillingMethod fillingMethod,
   ImGearRecRecognitionModule recognitionModule
)
public: ImGearRecZone(
   ImGearRecFillingMethod fillingMethod,
   ImGearRecRecognitionModule recognitionModule
)
public:
ImGearRecZone(
   ImGearRecFillingMethod fillingMethod,
   ImGearRecRecognitionModule recognitionModule
)

Parameters

fillingMethod
Filling method to set for the zone.
recognitionModule
Recognition module to set for the zone.

Return Value

The new instance of ImGearRecZone class object.
Remarks
Note:The application must then set various properties of the zone before adding it to the zone list.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
Overload List
ImGearRecZone Class
ImGearRecFillingMethod Enumeration
ImGearRecRecognitionModule Enumeration


%%PageItemTitle%% $$Methods$$

ImGearRecZone Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZone Class

For a list of all members of this type, see ImGearRecZone members.

Public Methods
 | Name | Description
Public Method | ClearCheckWord | Clear any subscribers to the CheckWord event.
Top
See Also

Reference

ImGearRecZone Class
ImageGear.Recognition Namespace


ClearCheckWord Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : ClearCheckWord Method
Clear any subscribers to the CheckWord event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated and will be removed from the public API in a future release.")>
Public Sub ClearCheckWord()
'Usage

Dim instance As ImGearRecZone

instance.ClearCheckWord()
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public void ClearCheckWord()
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public: void ClearCheckWord();
[Obsolete("This method is deprecated and will be removed from the public API in a future release.")]
public:
void ClearCheckWord();
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members


%%PageItemTitle%% $$Properties$$

ImGearRecZone Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZone Class

For a list of all members of this type, see ImGearRecZone members.

Public Properties
 | Name | Description
Public Property | Checking | Gets or sets zone checking flags.
Public Property | CheckWordIsUsed | Gets a value indicating whether any event handlers are currently registered for the CheckWord event.
Public Property | FillingMethod | Gets or sets zone filling method.
Public Property | Filter | Gets or sets the character set filter for the zone.
Public Property | RecognitionModule | Gets or sets the recognition module to use when performing recognition on the zone.
Public Property | Rect | Gets a reference to the rectangle whose coordinates (in pixels) define the zone boundaries.
Public Property | Type | Gets or sets zone type.
Public Property | UserData | Gets or sets custom user-defined data.
Public Property | UserDictionarySection | Gets or sets the section name to use in the user dictionary.
Top
See Also

Reference

ImGearRecZone Class
ImageGear.Recognition Namespace


Checking Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : Checking Property
Gets or sets zone checking flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checking As ImGearRecZoneCheckingFlags
'Usage

Dim instance As ImGearRecZone
Dim value As ImGearRecZoneCheckingFlags

instance.Checking = value

value = instance.Checking
public ImGearRecZoneCheckingFlags Checking {get; set;}
public: __property ImGearRecZoneCheckingFlags get_Checking();
public: __property void set_Checking(
   ImGearRecZoneCheckingFlags value
);
public:
property ImGearRecZoneCheckingFlags Checking {
   ImGearRecZoneCheckingFlags get();
   void set (    ImGearRecZoneCheckingFlags value);
}

Property Value

ImGearRecZoneCheckingFlags enumeration value.
Remarks
This property is a bit mask that controls zone checking. It contains a combination of values from ImGearRecZoneCheckingFlags.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecZoneCheckingFlags Enumeration


CheckWordIsUsed Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : CheckWordIsUsed Property
Gets a value indicating whether any event handlers are currently registered for the CheckWord event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release.")>
Public ReadOnly Property CheckWordIsUsed As Boolean
'Usage

Dim instance As ImGearRecZone
Dim value As Boolean

value = instance.CheckWordIsUsed
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public bool CheckWordIsUsed {get;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public: __property bool get_CheckWordIsUsed();
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public:
property bool CheckWordIsUsed {
   bool get();
}

Property Value

Boolean value.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members


FillingMethod Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : FillingMethod Property
Gets or sets zone filling method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillingMethod As ImGearRecFillingMethod
'Usage

Dim instance As ImGearRecZone
Dim value As ImGearRecFillingMethod

instance.FillingMethod = value

value = instance.FillingMethod
public ImGearRecFillingMethod FillingMethod {get; set;}
public: __property ImGearRecFillingMethod get_FillingMethod();
public: __property void set_FillingMethod(
   ImGearRecFillingMethod value
);
public:
property ImGearRecFillingMethod FillingMethod {
   ImGearRecFillingMethod get();
   void set (    ImGearRecFillingMethod value);
}

Property Value

ImGearRecFillingMethod enumeration value.
Remarks
Filling method used by the zone. This is used to define what kind of zone filling method has been used originally on the document to fill the zone's area. (i.e. whether it contains machine print, graphic, etc.).
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecFillingMethod Enumeration


Filter Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : Filter Property
Gets or sets the character set filter for the zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Filter As ImGearRecFilter
'Usage

Dim instance As ImGearRecZone
Dim value As ImGearRecFilter

instance.Filter = value

value = instance.Filter
public ImGearRecFilter Filter {get; set;}
public: __property ImGearRecFilter get_Filter();
public: __property void set_Filter(
   ImGearRecFilter value
);
public:
property ImGearRecFilter Filter {
   ImGearRecFilter get();
   void set (    ImGearRecFilter value);
}

Property Value

ImGearRecFilter enumeration value.
Remarks
Character Set filter is a combination of values from ImGearRecFilter that determine filtering behavior for the zone.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecFilter Enumeration


RecognitionModule Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : RecognitionModule Property
Gets or sets the recognition module to use when performing recognition on the zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RecognitionModule As ImGearRecRecognitionModule
'Usage

Dim instance As ImGearRecZone
Dim value As ImGearRecRecognitionModule

instance.RecognitionModule = value

value = instance.RecognitionModule
public ImGearRecRecognitionModule RecognitionModule {get; set;}
public: __property ImGearRecRecognitionModule get_RecognitionModule();
public: __property void set_RecognitionModule(
   ImGearRecRecognitionModule value
);
public:
property ImGearRecRecognitionModule RecognitionModule {
   ImGearRecRecognitionModule get();
   void set (    ImGearRecRecognitionModule value);
}

Property Value

ImGearRecRecognitionModule enumeration value.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecRecognitionModule Enumeration


Rect Property (ImGearRecZone)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : Rect Property
Gets a reference to the rectangle whose coordinates (in pixels) define the zone boundaries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Rect As IImGearRectangle
'Usage

Dim instance As ImGearRecZone
Dim value As IImGearRectangle

value = instance.Rect
public IImGearRectangle Rect {get;}
public: __property IImGearRectangle* get_Rect();
public:
property IImGearRectangle^ Rect {
   IImGearRectangle^ get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRectangle Structure


Type Property (ImGearRecZone)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : Type Property
Gets or sets zone type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ImGearRecZoneType
'Usage

Dim instance As ImGearRecZone
Dim value As ImGearRecZoneType

instance.Type = value

value = instance.Type
public ImGearRecZoneType Type {get; set;}
public: __property ImGearRecZoneType get_Type();
public: __property void set_Type(
   ImGearRecZoneType value
);
public:
property ImGearRecZoneType Type {
   ImGearRecZoneType get();
   void set (    ImGearRecZoneType value);
}

Property Value

ImGearRecZoneType enumeration value.
Remarks
This property is used to classify the zone into one of the three basic zone categories: flowed text, table or graphics. To set this, use FLOW, TABLE or GRAPHIC, respectively.
  • Flowed text: Any of the following text types can appear instead of FLOW: COLUMN, HEADER, FOOTER, CAPTION, TITLE, OTHER. One of these values is typically created by the page-layout decomposition (auto-zoning) process, however they have the same meaning for the recognition algorithms: the zone contains flowed text.
  • Table text: TABLE is for table-type zones. With this, the recognition engine will try to reconstruct the original table text layout of the zone in the final output document.
  • Graphics zones: For these, use the GRAPHIC type. When specified, no recognition will run on the zone and all other recognition related settings will be ignored. The related SGRAPHIC type can appear as the result of the page-layout decomposition (auto-zoning) process, and also signifies a graphic zone.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecZoneType Enumeration


UserData Property (ImGearRecZone)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : UserData Property
Gets or sets custom user-defined data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserData As Object
'Usage

Dim instance As ImGearRecZone
Dim value As Object

instance.UserData = value

value = instance.UserData
public object UserData {get; set;}
public: __property Object* get_UserData();
public: __property void set_UserData(
   Object* value
);
public:
property Object^ UserData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Data object.
Remarks
This property allows the user to associate an object with this particular zone. It's provided for convenience. However, note that the zone list is reconstructed when performing recognition tasks such as Locate and Recognize, and this value is not preserved during these tasks.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members


UserDictionarySection Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : UserDictionarySection Property
Gets or sets the section name to use in the user dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release.")>
Public Property UserDictionarySection As String
'Usage

Dim instance As ImGearRecZone
Dim value As String

instance.UserDictionarySection = value

value = instance.UserDictionarySection
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public string UserDictionarySection {get; set;}
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public: __property string* get_UserDictionarySection();
public: __property void set_UserDictionarySection(
   string* value
);
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public:
property String^ UserDictionarySection {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
Section name in user dictionary to use for checking.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members


%%PageItemTitle%% $$Events$$

ImGearRecZone Class Events

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZone Class

For a list of all members of this type, see ImGearRecZone members.

Public Events
 | Name | Description
Public Event | CheckWord | Event used for user-defined checking.
Top
See Also

Reference

ImGearRecZone Class
ImageGear.Recognition Namespace


CheckWord Event

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZone Class : CheckWord Event
Event used for user-defined checking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated and will be removed from the public API in a future release.")>
Public Event CheckWord As ImGearRecCheckWordEventHandler
'Usage

Dim instance As ImGearRecZone
Dim handler As ImGearRecCheckWordEventHandler

AddHandler instance.CheckWord, handler
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public event ImGearRecCheckWordEventHandler CheckWord
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public: __event ImGearRecCheckWordEventHandler* CheckWord
[Obsolete("This property is deprecated and will be removed from the public API in a future release.")]
public:
event ImGearRecCheckWordEventHandler^ CheckWord
Event Data

The event handler receives an argument of type ImGearRecCheckWordEventArgs containing data related to this event. The following ImGearRecCheckWordEventArgs properties provide information specific to this event.

Property | Description
CheckWord | Gets word to be checked.
Opinion | Gets or sets application's opinion of the word.
Remarks
CheckWord event used to allow applications to register an event handler for a zone that allows custom checking for the zone.
See Also

Reference

ImGearRecZone Class
ImGearRecZone Members
ImGearRecCheckWordEventHandler Delegate


%%PageItemTitle%%

ImGearRecZoneCollection Class
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneCollection Class
Collection of zones for a page, belongs to ImGearRecPage object.
Object Model
ImGearRecZoneCollection ClassImGearRecZone Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImGearRecZoneCollection
   Inherits ImGearRecSettingsCollectionObjectBase
'Usage

Dim instance As ImGearRecZoneCollection
[DefaultMember("Item")]
public sealed class ImGearRecZoneCollection : ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public __gc __sealed class ImGearRecZoneCollection : public ImGearRecSettingsCollectionObjectBase
[DefaultMember("Item")]
public ref class ImGearRecZoneCollection sealed : public ImGearRecSettingsCollectionObjectBase
Inheritance Hierarchy

System.Object
ImageGear.Recognition.ImGearRecSettingsCollectionObjectBase
ImageGear.Recognition.ImGearRecZoneCollection

See Also

Reference

ImGearRecZoneCollection Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZoneCollection Class Members
Properties Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneCollection Class

The following tables list the members exposed by ImGearRecZoneCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets number of zones.
Public Property | Item | Provides access to a particular zone.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new zone.
Public Method | Clear | Removes all zones.
Public Method | DetectFillingMethod | Detects the filling methods of each zone individually.
Public Method | Insert | Inserts a zone at a specified index.
Public Method | LoadFromFile | Loads the list of zones from a file.
Public Method | Locate | Overloaded. Automatically locates zones by examining the entire image.
Public Method | Remove | Removes the specified zone.
Public Method | RemoveAt | Removes the zone at the specified index.
Public Method | SaveToFile | Saves the list of zones to a file.
Top
See Also

Reference

ImGearRecZoneCollection Class
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Methods$$

ImGearRecZoneCollection Class Methods

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneCollection Class

For a list of all members of this type, see ImGearRecZoneCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new zone.
Public Method | Clear | Removes all zones.
Public Method | DetectFillingMethod | Detects the filling methods of each zone individually.
Public Method | Insert | Inserts a zone at a specified index.
Public Method | LoadFromFile | Loads the list of zones from a file.
Public Method | Locate | Overloaded. Automatically locates zones by examining the entire image.
Public Method | Remove | Removes the specified zone.
Public Method | RemoveAt | Removes the zone at the specified index.
Public Method | SaveToFile | Saves the list of zones to a file.
Top
See Also

Reference

ImGearRecZoneCollection Class
ImageGear.Recognition Namespace


Add Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Add Method
New ImGearRecZone object describing zone to be added.
Adds a new zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal zone As ImGearRecZone _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim zone As ImGearRecZone

instance.Add(zone)
public void Add(
   ImGearRecZone zone
)
public: void Add(
   ImGearRecZone* zone
)
public:
void Add(
   ImGearRecZone^ zone
)

Parameters

zone
New ImGearRecZone object describing zone to be added.
Remarks
Adds a new zone to the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
ImGearRecZone Class


Clear Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Clear Method
Removes all zones.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearRecZoneCollection

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Remarks
Removes all zones from the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


DetectFillingMethod Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : DetectFillingMethod Method
Detects the filling methods of each zone individually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DetectFillingMethod()
'Usage

Dim instance As ImGearRecZoneCollection

instance.DetectFillingMethod()
public void DetectFillingMethod()
public: void DetectFillingMethod();
public:
void DetectFillingMethod();
Remarks
This method tries to determine the type of the text in the zones of a page (e.g. machine printed or dot-matrix printed text). The method performs a zone by zone analysis (instead of suggesting a general filling type for the entire image), and if the algorithm can determine a type for a given zone, the method replaces the DEFAULT value in the zone's ImGearRecZone.FillingMethod property by the determined one.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


Insert Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Insert Method
Index to insert zone at.
New ImGearRecZone object describing zone to be added.
Inserts a zone at a specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal zone As ImGearRecZone _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim index As Integer
Dim zone As ImGearRecZone

instance.Insert(index, zone)
public void Insert(
   int index,
   ImGearRecZone zone
)
public: void Insert(
   int index,
   ImGearRecZone* zone
)
public:
void Insert(
   int index,
   ImGearRecZone^ zone
)

Parameters

index
Index to insert zone at.
zone
New ImGearRecZone object describing zone to be added.
Remarks
Inserts a new zone at the specified index in the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
ImGearRecZone Class


LoadFromFile Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : LoadFromFile Method
Path to the file to load zone list from.
Loads the list of zones from a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LoadFromFile( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim path As String

instance.LoadFromFile(path)
public void LoadFromFile(
   string path
)
public: void LoadFromFile(
   string* path
)
public:
void LoadFromFile(
   String^ path
)

Parameters

path
Path to the file to load zone list from.
Remarks
Loads the zone list from a file. The zone list loaded from the file replaces the existing zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


Locate Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Locate Method
Automatically locates zones by examining the entire image.
Overload List
Overload | Description
Locate() | Automatically locates zones by examining the entire image.
Locate(ImGearRectangle) | Automatically locates zones by examining the specified rectangular region of the image.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


Locate() Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class > Locate Method : Locate() Method
Automatically locates zones by examining the entire image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Locate()
'Usage

Dim instance As ImGearRecZoneCollection

instance.Locate()
public void Locate()
public: void Locate();
public:
void Locate();
Remarks
This method is used for parsing the image (also called: auto-zoning), i.e. it analyzes the structure of the page layout of the image and locates blocks for further processing.

This method performs the analysis over the entire image area. An overload Locate(ImGearRectangle) method is available to analyze a specified area of the image.

This method finds text or graphics blocks within the specified area, builds a zone list and then stores it along with the ImGearRecPage object.

This method activates the DECOMPOSITION process.

See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
Overload List


Locate(ImGearRectangle) Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class > Locate Method : Locate(ImGearRectangle) Method
Rectangular region of image to locate zones in.
Automatically locates zones by examining the specified rectangular region of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Locate( _
   ByVal rect As ImGearRectangle _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim rect As ImGearRectangle

instance.Locate(rect)
public void Locate(
   ImGearRectangle rect
)
public: void Locate(
   ImGearRectangle rect
)
public:
void Locate(
   ImGearRectangle rect
)

Parameters

rect
Rectangular region of image to locate zones in.
Remarks
Locates zones in a specified rectangular region of the image. See Locate method for the full description.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
Overload List
ImGearRectangle Structure


Remove Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Remove Method
Reference to a zone in the zone list to remove.
Removes the specified zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal zone As ImGearRecZone _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim zone As ImGearRecZone

instance.Remove(zone)
public void Remove(
   ImGearRecZone zone
)
public: void Remove(
   ImGearRecZone* zone
)
public:
void Remove(
   ImGearRecZone^ zone
)

Parameters

zone
Reference to a zone in the zone list to remove.
Remarks
Removes the given zone from the zone list. The Zone parameter must be a reference to a zone in the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
ImGearRecZone Class


RemoveAt Method (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : RemoveAt Method
Index of zone in zone list to remove.
Removes the zone at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
Index of zone in zone list to remove.
Remarks
Removes the zone at the specified index in the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


SaveToFile Method

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : SaveToFile Method
File path to save the zone list to.
Saves the list of zones to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SaveToFile( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecZoneCollection
Dim path As String

instance.SaveToFile(path)
public void SaveToFile(
   string path
)
public: void SaveToFile(
   string* path
)
public:
void SaveToFile(
   String^ path
)

Parameters

path
File path to save the zone list to.
Remarks
Saves the list of zones to a zone list file.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


%%PageItemTitle%% $$Properties$$

ImGearRecZoneCollection Class Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneCollection Class

For a list of all members of this type, see ImGearRecZoneCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets number of zones.
Public Property | Item | Provides access to a particular zone.
Top
See Also

Reference

ImGearRecZoneCollection Class
ImageGear.Recognition Namespace


Count Property (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Count Property
Gets number of zones.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearRecZoneCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
Remarks
Returns the total number of zones in the zone list.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members


Item Property (ImGearRecZoneCollection)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecZoneCollection Class : Item Property
Index of zone in zone list to access.
Provides access to a particular zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ImGearRecZone
'Usage

Dim instance As ImGearRecZoneCollection
Dim index As Integer
Dim value As ImGearRecZone

value = instance.Item(index)
public ImGearRecZone this[
   int index
]; {get;}
public: __property ImGearRecZone* get_Item   int index
;
public:
property ImGearRecZone^ default [int] {
   ImGearRecZone^ get(int index);
}

Parameters

index
Index of zone in zone list to access.

Property Value

ImGearRecZone class object.
Remarks
Provides access to properties for an individual zone. See ImGearRecZone class.
See Also

Reference

ImGearRecZoneCollection Class
ImGearRecZoneCollection Members
ImGearRecZone Class


%%PageItemTitle%%

ImGearRecCheckWordOpinion Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCheckWordOpinion Enumeration
Defines opinion values for user-written word checking.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecCheckWordOpinion
   Inherits System.Enum
'Usage

Dim instance As ImGearRecCheckWordOpinion
public enum ImGearRecCheckWordOpinion : System.Enum
__value public enum ImGearRecCheckWordOpinion : public System.Enum
public enum class ImGearRecCheckWordOpinion : public System.Enum
Members
Member | Value | Description
IMPOSSIBLE | 0 | In the application's opinion it is not possible that the recognized string for the given zone passed to the checking function is acceptable.
POSSIBLE | 3 | In the application's opinion it is possible that the recognized string for the given zone passed to the checking function is acceptable.
SURE | 4 | In the application's opinion the recognized string for the given zone passed to the checking function is certainly acceptable.
UNLIKELY | 1 | In the application's opinion the recognized string passed to the checking function for the given zone is unlikely to be acceptable.
UNRESOLVED | 2 | The application's checking function cannot make a decision on the acceptability of the string for the zone.
Remarks
ImGearRecCheckWordEventHandler delegate uses its ImGearRecCheckWordEventArgs e parameter to pass application's opinion on the recognized word back to the Engine. Opinion is returned via the ImGearRecCheckWordEventArgs.Opinion property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecCheckWordOpinion

See Also

Reference

ImageGear.Recognition Namespace
CheckWord Property
Opinion Property
ImGearRecCheckWordEventHandler Delegate


%%PageItemTitle%%

ImGearRecDecompositionMethod Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDecompositionMethod Enumeration
Identifies methods for decomposing the document into zones.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecDecompositionMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearRecDecompositionMethod
public enum ImGearRecDecompositionMethod : System.Enum
__value public enum ImGearRecDecompositionMethod : public System.Enum
public enum class ImGearRecDecompositionMethod : public System.Enum
Members
Member | Value | Description
AUTO | 0 | Specifies that the toolkit will determine at run-time whether the LEGACY or STANDARD algorithm will be applied.
FAST | 3 | This algorithm can be treated as a simplified variant of LEGACY. This algorithm doesn't try to find tables on the page. It is the fastest (but least accurate) parsing algorithm available. Use only for simple page parsing tasks.
LEGACY | 1 | Identifies the page-parsing algorithm exclusively used in the OmniPage toolkit before its version 11.0.
STANDARD | 2 | Identifies the most accurate page parsing algorithm of the Recognition component.
Remarks
Applying the STANDARD algorithm results in better throughput in overall accuracy, though in some complex cases it might require significantly more time to complete.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecDecompositionMethod

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecDeskewMode Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDeskewMode Enumeration
Identifies image deskewing modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecDeskewMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecDeskewMode
public enum ImGearRecDeskewMode : System.Enum
__value public enum ImGearRecDeskewMode : public System.Enum
public enum class ImGearRecDeskewMode : public System.Enum
Members
Member | Value | Description
AUTO | 0 | Automatic deskewing (Default).
AUTO_3D | 3 | Automatic three-dimensional deskewing.
NO | 1 | No deskewing applied.
SET | 2 | Deskew with a given angle set by the ImGearRecPreprocessingSettings.SkewAmount property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecDeskewMode

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecDirectTextFormat Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecDirectTextFormat Enumeration
Specifies Direct text output formats. These are the formats that are supported by WriteDirectText method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecDirectTextFormat
   Inherits System.Enum
'Usage

Dim instance As ImGearRecDirectTextFormat
public enum ImGearRecDirectTextFormat : System.Enum
__value public enum ImGearRecDirectTextFormat : public System.Enum
public enum class ImGearRecDirectTextFormat : public System.Enum
Members
Member | Value | Description
CommaSeparatedText | 1 | Comma-separated text format.
FormattedText | 2 | Formatted text.
SimpleText | 0 | Simple text format.
XmlWithCoordinates | 4 | Simple XML with coordinates format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecDirectTextFormat

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecErrorCodes Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecErrorCodes Enumeration
Identifies recognition error codes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecErrorCodes
   Inherits System.Enum
'Usage

Dim instance As ImGearRecErrorCodes
public enum ImGearRecErrorCodes : System.Enum
__value public enum ImGearRecErrorCodes : public System.Enum
public enum class ImGearRecErrorCodes : public System.Enum
Members
Member | Value | Description
API_BUSY_ERR | 0x8004C415 | Engine is busy.
API_CRYPT_MISS_WARN | 0x0004C41C | Crypt module missing.
API_DOTNET30_OR_LATER_MISSING_ERR | 0x8004C41B | Missing .NET 3.0 or later.
API_ERROR_ERR | 0x8004C40D | General error in the Engine.
API_EVALDATE_EXPIRED_ERR | 0x8004C416 | Evaluation date of the Engine has expired.
API_FILEFORMAT_ERR | 0x8004C418 | Format error in the actual file.
API_GPFAULT_ERR | 0x8004C40E | General Protection Fault in the Engine.
API_HARDLOCK_ERR | 0x8004C412 | Hardlock not found or hardlock service has not been started.
API_HARDTIMEOUT_ERR | 0x8004C41D | Recognition process hard TimeOut.
API_INCORRECTMODULEVERSION_ERR | 0x8004C401 | Inconsistent Engine configuration.
API_INIT_ERR | 0x8004C402 | Engine initialization error, or no appropriate license.
API_INIT_WARN | 0x0004C404 | Module initialization warning.
API_INVALIDSESSION_ERR | 0x8004C419 | Current session is invalid.
API_LICENSE_ERR | 0x8004C413 | Invalid license or Engine Licence file not found.
API_MODULEENTRY_ERR | 0x8004C409 | Missing entry in a module.
API_MODULEINIT_ERR | 0x8004C40B | Module initialization error.
API_MODULEINVALID_ERR | 0x8004C40A | Invalid module.
API_MODULELOAD_ERR | 0x8004C408 | OS could not load a module.
API_MODULEMISSING_ERR | 0x8004C407 | Module not present.
API_NOT_AVAILABLE_ERR | 0x8004C40C | The requested function is unavailable, or there is no appropriate license. This error can also indicate an unsupported combination of recognition parameters, e.g. when a language is not supported for the selected recognition module.
API_PARAMETER_ERR | 0x8004C414 | Invalid parameters.
API_PLATFORM_ERR | 0x8004C40F | Unsupported operating system.
API_PROCESS_ABORTED_ERR | 0x8004C405 | Application has aborted the current process.
API_PROCESS_FINISH | 0x8004C406 | Application has terminated the current recognition process. Recognized text is kept.
API_QUIT_ERR | 0x8004C403 | Engine termination error.
API_STS_ERR | 0x8004C411 | Invalid setting.
API_STS_SYNTAX_ERR | 0x8004C410 | Syntax error in the specified Engine Settings file.
API_TIMEOUT_ERR | 0x8004C417 | Recognition process soft TimeOut.
APIP_INIT_ERR | 0x8004D101 | APIPlus initialization error.
APIP_INTERNAL_ERR | 0x8004D104 | Internal error in RecAPIPlus.
APIP_NOMORE_WARN | 0x0004D103 | No more items available.
APIP_PARAM_ERR | 0x8004D102 | Parameter error.
ASN_INIT_ERR | 0x8004D701 | Asian recognition module initialization error.
BRA_INIT_ERR | 0x8004D201 | Braille recognition module initialization error.
CHR_CODELENGTH_ERR | 0x8004C305 | Length of exported code exceeds buffer size.
CHR_ILLEGALCODE_ERR | 0x8004C301 | Illegal internal code as a parameter.
CHR_ILLEGALSETTING_ERR | 0x8004C302 | Set parameter is not acceptable (e.g. size mismatch.).
CHR_INIT_ERR | 0x8004C308 | Character Set and Code Pages module initialization error.
CHR_LANG_NOTFOUND_ERR | 0x8004C30A | There are no matching languages.
CHR_LANGSET_CODEPAGE_ERR | 0x8004C307 | Conflict: The selected Code Page does not support some characters in the selected languages: there is no exact code in the Code Page for them.
CHR_MISSINGEXPORT_ERR | 0x8004C306 | Character conversion is not available for the given character.
CHR_MULTIPLELANG_FOUND_WARN | 0x0004C309 | There are more than one matching languages.
CHR_NOMORE_WARN | 0x0004C303 | End of list of available Code Pages.
CHR_SETFILE_ERR | 0x8004C304 | Error while loading the Code Page Definition file (RECOGN.SET).
DOT_ERR | 0x8004CC01 | Dot-matrix recognition error.
EXTRACTED_TXT_WARN | 0x0004C90E | Limited information extacted from input document.
FILE_ACCESS_ERR | 0x8004C107 | File access denied.
FILE_ALREADYEXIST_ERR | 0x8004C10F | File already exists.
FILE_CANTCREATE_MUTEX_ERR | 0x8004C117 | Mutex cannot be created.
FILE_CANTRELEASE_MUTEX_ERR | 0x8004C118 | Mutex cannot be released.
FILE_CREATE_ERR | 0x8004C109 | File creation error.
FILE_DIRNOTEMPTY_ERR | 0x8004C113 | Directory is not empty.
FILE_DISKFULL_ERR | 0x8004C10C | Disk full.
FILE_ERR | 0x8004C101 | File operation internal error.
FILE_INIT_ERR | 0x8004C119 | File system initialization error.
FILE_INVALIDFLAG_ERR | 0x8004C110 | Invalid flag specified in a function call.
FILE_INVALIDFUNCTION_ERR | 0x8004C11D | The specified flag combination is not supported.
FILE_INVALIDHANDLE_ERR | 0x8004C114 | Invalid handle specified in a function call.
FILE_INVALIDPARAMETER_ERR | 0x8004C111 | Invalid parameter specified in a function call.
FILE_INVALIDPOINTER_ERR | 0x8004C11C | Invalid pointer specified in a function call.
FILE_IO_ERR | 0x8004C10D | File I/O error.
FILE_LOCKVIOLATION_ERR | 0x8004C112 | File locking error.
FILE_MEM_ERR | 0x8004C10B | Out of memory during file I/O.
FILE_MUTEX_NOTAVAILABLE_ERR | 0x8004C116 | Mutex is not available.
FILE_NOMORE_WARN | 0x0004C11E | Internal use only.
FILE_NOT_IMPLEMENTED_ERR | 0x8004C11B | Function call not implemented yet.
FILE_NOTFOUND_ERR | 0x8004C104 | File not found.
FILE_OPEN_ERR | 0x8004C103 | File open error.
FILE_QUIT_ERR | 0x8004C11A | File Manager's module quit error.
FILE_READ_ERR | 0x8004C105 | File read error.
FILE_REMOVE_ERR | 0x8004C108 | File removal error.
FILE_SEEK_ERR | 0x8004C10A | File seek error.
FILE_SHARE_ERR | 0x8004C10E | Sharing violation.
FILE_SYNTAX_ERR | 0x8004C102 | File handling syntax error.
FILE_TOOLARGE_ERR | 0x8004C115 | File size limit error.
FILE_WRITE_ERR | 0x8004C106 | File write error.
FRX_INIT_ERR | 0x8004D601 | Fireworx recognition module initialization error.
IMF_APPEND_ERR | 0x8004C610 | Appending not allowed.
IMF_CLOSE_ERR | 0x8004C605 | Image file close error.
IMF_COLOR_ERR | 0x8004C60E | Color PCX file is not supported.
IMF_COMP_ERR | 0x8004C60A | Error in image compression.
IMF_COMP_WARN | 0x0004C617 | Problem in image compression.
IMF_CREATE_ERR | 0x8004C606 | Image file create error.
IMF_EMPTYHANDLE_WARN | 0x0004C614 | The file belonging to this handle does not exist any longer.
IMF_FAXVIEWMISS_ERR | 0x8004C612 | Microsoft Fax viewer missing or not installed.
IMF_FILEFORMAT_ERR | 0x8004C60D | File format error.
IMF_FILENOTEMPTY_ERR | 0x8004C611 | Writing into a non-empty file without IMF append mode specified.
IMF_IMGFORM_ERR | 0x8004C60B | Unknown image format.
IMF_INIT_ERR | 0x8004C603 | Image file I/O module initialization error.
IMF_MEMORY_ERR | 0x8004C607 | Out of memory during image file I/O.
IMF_NOTSUP_ERR | 0x8004C608 | Not supported image file format or image file type.
IMF_OPEN_ERR | 0x8004C604 | Image file open error.
IMF_PAGENUM_ERR | 0x8004C60C | Non-existent page number.
IMF_PASSWORD_WARN | 0x0004C613 | Password protected file.
IMF_READ_ERR | 0x8004C601 | Image file read error.
IMF_READ_WARN | 0x0004C616 | Image file read problem.
IMF_TAGMISSING_ERR | 0x8004C609 | Required TIFF basic tag is missing.
IMF_TMPFILE_ERR | 0x8004C60F | Temporary file handling error.
IMF_WRITE_ERR | 0x8004C602 | Image file write error.
IMG_ACCESS_ERR | 0x8004C70C | Image operation denied.
IMG_ANCHOR_WARN | 0x0004C712 | One or more anchor zones were not found.
IMG_ANCHORNOTFOUND_ERR | 0x8004C713 | Neither of the anchor zones were found.
IMG_BITMAPADDRESS_ERR | 0x8004C707 | Invalid bitmap address.
IMG_BITSPERPIXEL_ERR | 0x8004C708 | Unsupported BitsPerPixel value.
IMG_BUFFEROVERFLOW_ERR | 0x8004C70B | Buffer overflow during processing the image.
IMG_COMPRESSED_ERR | 0x8004C706 | Cannot process compressed image.
IMG_DPI_ERR | 0x8004C704 | Non-supported resolution.
IMG_DPI_WARN | 0x0004C711 | Non-supported resolution.
IMG_HANDLE_ERR | 0x8004C70A | Invalid image handle.
IMG_INVALIDOP_ERR | 0x8004C70F | Operation not supported on this image.
IMG_NOMORE_WARN | 0x0004C70D | No more lines in defined image area.
IMG_NOTATTACHED_ERR | 0x8004C709 | Internal use only.
IMG_NOTENOUGHMEMORY_ERR | 0x8004C702 | Not enough memory during image processing.
IMG_NOTFOUND_ERR | 0x8004C705 | Image not found.
IMG_RECT_ERR | 0x8004C703 | Invalid rectangle dimensions.
IMG_SETTING_ERR | 0x8004C701 | Internal use only.
IMG_SIZE_ERR | 0x8004C70E | Non-supported image size.
IMG_ZONE_ERR | 0x8004C710 | Invalid zone operation.
L_ERROR_ABORTED | 0x8004DA1F | The function was aborted.
L_ERROR_APPSET | 0x8004DA1A | Invalid appset.
L_ERROR_BADVERSION | 0x8004DA15 | Wrong Layout Analyser version.
L_ERROR_CALL | 0x8004DA13 | Invalid function call.
L_ERROR_CONV_LECSO | 0x8004DA21 | Layout Analyser command error.
L_ERROR_CONV_NODOCUMENT | 0x8004DA20 | No document in Layout Analyser Storage.
L_ERROR_CONVERTER | 0x8004DA14 | Conversion error.
L_ERROR_DOCFORMATTER | 0x8004DA23 | Internal use only.
L_ERROR_DTK | 0x8004DA17 | DTK function error.
L_ERROR_FILE | 0x8004DA0A | Gerneral file operation error.
L_ERROR_FILE_CLOSE | 0x8004DA0C | File cannot be closed.
L_ERROR_FILE_FORMAT | 0x8004DA10 | Wrong file format.
L_ERROR_FILE_OPEN | 0x8004DA0B | File cannot be opened.
L_ERROR_FILE_READ | 0x8004DA0E | File reading error.
L_ERROR_FILE_SEEK | 0x8004DA0D | File seeking error.
L_ERROR_FILE_WRITE | 0x8004DA0F | File writing error.
L_ERROR_IMAGE | 0x8004DA16 | Image operation error.
L_ERROR_MASTERSOFT | 0x8004DA1E | Text converter filter error.
L_ERROR_NOACCESS | 0x8004DA1C | Access error.
L_ERROR_NOID | 0x8004DA07 | No such Object ID.
L_ERROR_NOTIMPLEMENTED | 0x8004DA1D | Feature not implemented.
L_ERROR_OBJID | 0x8004DA08 | Wrong Object ID.
L_ERROR_OBJTYPE | 0x8004DA09 | Wrong object type.
L_ERROR_OUTPUT_MODE | 0x8004DA19 | Invalid output mode.
L_ERROR_PARAMETER | 0x8004DA11 | Invalid internal parameter.
L_ERROR_PRERENDERING | 0x8004DA1B | Prerendering error.
L_ERROR_RANGE | 0x8004DA12 | Invalid internal range.
L_ERROR_READONLY | 0x8004DA18 | Layour Analyser opened as read only.
L_ERROR_STOP | 0x8004DA24 | Internal use only.
L_ERROR_TOO_MANY_SHEETS | 0x8004DA22 | Too many Excel sheets.
L_ERRORS | 0x8004DA06 | General OmniPage Document (OPD) Error.
L_FATALERRORS | 0x8004DB01 | General OmniPage Document (OPD) Fatal error.
L_FERROR_FILEFORMAT | 0x8004DB04 | Wrong file format or wrong reading or writing methods.
L_FERROR_INDEX | 0x8004DB05 | Wrong index stream.
L_FERROR_INTERNAL | 0x8004DB03 | Internal OmniPage Document (OPD) error.
L_FERROR_MEMORY | 0x8004DB02 | OmniPage Document (OPD) memory problem.
L_FERROR_MISSING | 0x8004DB09 | Missing file (usually a DLL).
L_FERROR_NOSET | 0x8004DB07 | Some attribute was not set.
L_FERROR_PERMISSION | 0x8004DB08 | PDF modification restricted.
L_FERROR_RECAPI | 0x8004DB06 | Error in RecApi.
L_WARNING_MISSING | 0x0004DA04 | Missing data.
L_WARNING_NOTFOUND | 0x0004DA02 | Layout Analyser Object not found.
L_WARNING_NOTOPENED | 0x0004DA03 | Layout Analyser Object not opened.
L_WARNING_SUBSTITUTED | 0x0004DA05 | Data substitution.
L_WARNINGS | 0x0004DA01 | General OmniPage Document (OPD) Warning.
MEM_INVALIDPOINTER_ERR | 0x8004C202 | Invalid pointer to a memory object.
MEM_NOTENOUGH_ERR | 0x8004C201 | Not enough memory for this memory operation.
MGR_ERR | 0x8004C901 | Engine manager module error.
MNG_INIT_ERR | 0x8004D801 | MNG recognition module initialization error.
MOR_BCTCORRUPTED_ERR | 0x8004CA04 | Knowledge base file for MOR recognition module corrupted (RECOGN.BCT).
MOR_BCTNOTFOUND_ERR | 0x8004CA03 | Knowledge base file for MOR recognition module not found (RECOGN.BCT).
MOR_BCTVERSION_ERR | 0x8004CA05 | Incorrect knowledge base file version (RECOGN.BCT).
MOR_DOS_ERR | 0x8004CA02 | DOS error during recognition.
MOR_FILECORRUPTED_ERR | 0x8004CA07 | File corrupted.
MOR_GPFAULT_ERR | 0x8004CA09 | General Protection Fault in the MOR recognition module.
MOR_INIT_ERR | 0x8004CA01 | MOR recognition module initialization error.
MOR_INTERNAL_ERR | 0x8004CA08 | Internal error in the MOR recognition module.
MOR_TOOLARGE_ERR | 0x8004CA06 | Image size too large.
MTX_INIT_ERR | 0x8004D501 | M/TEXT recognition module initialization error.
NO_TXT_WARN | 0x0004C902 | No recognized text available: either because the zone is empty or the required recognition module has not been initialized properly.
NOT_IMPL_ERR | 0x8004C41A | Non-implemented feature.
OCR_NO_MODULE_WARN | 0x0004C903 | No selected recognition module.
PAGE_HANDLE_ERR | 0x8004C802 | Page handle not found.
PAGE_NOTFOUND_ERR | 0x8004C801 | Page not found.
REC_OK | 0x00000000 | Successful operation, no error.
SPL_BADFILEFORMAT_ERR | 0x8004D006 | Invalid file format (TEV.SZO).
SPL_BADWORD_ERR | 0x8004D00F | Item is incorrect (NULL pointer, empty word, or illegal regular expression pattern).
SPL_CLOSE_ERR | 0x8004D008 | User dictionary close error.
SPL_DUPWORD_ERR | 0x8004D00D | Item already exists in the User dictionary.
SPL_EXISTSECT_WARN | 0x0004D012 | Section already exists in User dictionary.
SPL_FOPEN_ERR | 0x8004D003 | Spell file open error.
SPL_FREAD_ERR | 0x8004D004 | Spell file read error.
SPL_FWRITE_ERR | 0x8004D005 | User dictionary write error.
SPL_HANDLE_ERR | 0x8004D00A | Internal spell function call with a wrong handle.
SPL_INIT_ERR | 0x8004D007 | Module initialization error.
SPL_INTERNAL_ERR | 0x8004D00C | Internal checking error.
SPL_LANG_ERR | 0x8004D009 | Illegal language setting.
SPL_MEMORY_ERR | 0x8004D001 | Not enough memory for the SPL module.
SPL_NOINIT_ERR | 0x8004D002 | Uninitialized spell object.
SPL_NOMORE_WARN | 0x0004D00B | No more suggestions/items available.
SPL_NOTFOUND_ERR | 0x8004D00E | Item does not exist in the User dictionary.
SPL_REGEXP_SYNTAX_ERR | 0x8004D011 | Regular expression syntax error.
SPL_UDSECT_ERR | 0x8004D010 | Section does not exist in the User dictionary.
STSMN_BADORMISSINGREF_ERR | 0x8004D909 | The reference of a symbolic link subtree is invalid or the referenced setting does not exist yet.
STSMN_BADTYPE_ERR | 0x8004D903 | Improper setting type.
STSMN_FULLSAVEDTREE_WARN | 0x0004D908 | The loaded settings file may contain default values.
STSMN_HANDLE_ERR | 0x8004D901 | StsMan invalid node handle error.
STSMN_INVALIDFILE_ERR | 0x8004D906 | Settings file content invalid.
STSMN_NOSETTING_ERR | 0x8004D902 | No settings in node.
STSMN_NOTFOUND_ERR | 0x8004D907 | Node not found.
STSMN_OPNOTALLOWED_ERR | 0x8004D904 | Operation not allowed for setting or node.
STSMN_PARAMETER_ERR | 0x8004D905 | Invalid parameter.
ZONE_EXISTING_SEQ_ERR | 0x8004C907 | Internal use only.
ZONE_FILE_ERR | 0x8004C908 | Internal use only.
ZONE_IMAGE_DOWNSAMPLED_WARN | 0x0004C90B | Color image was downsampled.
ZONE_NO_FIELDNAME_WARN | 0x0004C90D | Zone can not have a field name defined.
ZONE_NOTFOUND_ERR | 0x8004C904 | No zone in the zone list.
ZONE_NOTFOUND_WARN | 0x0004C905 | No zone in the zone list.
ZONE_POSITION_ERR | 0x8004C906 | Invalid zone index.
ZONE_SHAPE_ERR | 0x8004C90A | Invalid zone shape (not rectangular).
ZONE_SIZE_ERR | 0x8004C909 | Invalid zone coordinates.
ZONE_SIZE_WARN | 0x0004C90C | Invalid zone coordinates.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecErrorCodes

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecFillingMethod Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecFillingMethod Enumeration
Identifies zone filling methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecFillingMethod
   Inherits System.Enum
'Usage

Dim instance As ImGearRecFillingMethod
public enum ImGearRecFillingMethod : System.Enum
__value public enum ImGearRecFillingMethod : public System.Enum
public enum class ImGearRecFillingMethod : public System.Enum
Members
Member | Value | Description
ASIAN | 14 | Asian zone filling method
DEFAULT | 0 | The default zone filling method. The actual zone filling method for all zones of this type will be retrieved just before recognition, according to the ImGearRecRecognitionSettings.DefaultFillingMethod property.
DRAFTDOT24 | 7 | The 24-pin draft dot-matrix zone filling method. It denotes a 24-pin draft dot-matrix printout.
DRAFTDOT9 | 2 | The 9-pin draft dot-matrix zone filling method. It denotes a 9-pin draft dot-matrix printout.
NO_OCR | 16 | No recognition will be attempted.
OCRA | 8 | OCR-A zone filling method.
OCRB | 9 | OCR-B zone filling method.
OMNIFONT | 1 | The omnifont zone filling method. It denotes a machine printed text with any typeface which is not too stylized.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecFillingMethod

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecFilter Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecFilter Enumeration
Identifies character set filters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearRecFilter
   Inherits System.Enum
'Usage

Dim instance As ImGearRecFilter
[Flags()]
public enum ImGearRecFilter : System.Enum
[Flags()]
__value public enum ImGearRecFilter : public System.Enum
[Flags()]
public enum class ImGearRecFilter : public System.Enum
Members
Member | Value | Description
ALL | 31 | Pre-defined combined filter. Since all elements are enabled, there is no filtering.
ALPHA | 6 | Pre-definedcombined filter. Recognition of upper and lowercase letters only.
DEFAULT | 0 | Used to have the zone handled globally. Do not combine this with any other filter.
DIGIT | 1 | Disjunct filter. Recognition of numerals only. E.g.: "3" (Digit Three).
LOWERCASE | 4 | Disjunct filter. Recognition of lowercase letters only including accented ones. E.g.: "a" (Lowercase a).
MISCELLANEOUS | 16 | Disjunct filter. Recognition of other miscellaneous characters only. E.g.: "+" (Plus sign).
NUMBERS | 33 | Pre-defined combined filter. Recognition of the digits, plus the FilterPlus characters specified by the ImGearRecRecognitionSettings.FilterPlus property.
PLUS | 32 | Special, combinable filter. Enables the use of the FilterPlus characters specified by the ImGearRecRecognitionSettings.FilterPlus property. The FilterPlus characters are added after any filtering.
PUNCTUATION | 8 | Disjunct filter. Recognition of punctuation signs only. E.g.: "!" (Exclamation Mark).
UPPERCASE | 2 | Disjunct filter. Recognition of uppercase letters only, including accented ones. E.g.: "A" (Capital A).
USER_DICT | 64 | Special, combinable filter. Recognition of characters from the user dictionary section assigned to the zone.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecFilter

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecFontFlags Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecFontFlags Enumeration
Provides character font information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearRecFontFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearRecFontFlags
[Flags()]
public enum ImGearRecFontFlags : System.Enum
[Flags()]
__value public enum ImGearRecFontFlags : public System.Enum
[Flags()]
public enum class ImGearRecFontFlags : public System.Enum
Members
Member | Value | Description
BOLD | 0x00000008 | Bold character. See also NO_BOLD.
DROPCAP | 0x00002000 | Dropcap character.
INVERTED | 0x00008000 | Inverted character.
ITALIC | 0x00000002 | Italic character. See also NO_ITALIC.
MONOSPACED | 0x00000080 | Monospaced character. See also PROPORTIONAL.
NO_BOLD | 0x00000004 | Not-Bold character. It is not possible for both BOLD and NO_BOLD to be set. If both are unset we do not know whether it is Bold or not.
NO_ITALIC | 0x00000001 | Not-Italic character. It is not possible for both ITALIC and NO_ITALIC to be set. If both are unset we do not know whether it is Italic or not.
POPCAP | 0x00004000 | Popcap character.
PROPORTIONAL | 0x00000040 | Proportional character. It is not possible for both PROPORTIONAL and MONOSPACED to be set. If both are unset we do not know whether it is Monospaced or not.
SANSSERIF | 0x00000010 | Sans Serif character. It is not possible for both SANSSERIF and SERIF to be set. If both are unset we do not know whether it is Serif or not.
SERIF | 0x00000020 | Serif character. See also SANSSERIF.
SMALLCAPS | 0x00000100 | Character in a Small Caps word. The code is always upper case.
STRIKETHROUGH | 0x00000400 | Struck through character. It is not used. It is only for future versions.
SUBSCRIPT | 0x00000800 | Subscript character.
SUPERSCRIPT | 0x00001000 | Superscript character.
UNDERLINE | 0x00000200 | Underlined character.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecFontFlags

See Also

Reference

ImageGear.Recognition Namespace
FontAttribute Property


%%PageItemTitle%%

ImGearRecInvertMode Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecInvertMode Enumeration
Identifies image inversion modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecInvertMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecInvertMode
public enum ImGearRecInvertMode : System.Enum
__value public enum ImGearRecInvertMode : public System.Enum
public enum class ImGearRecInvertMode : public System.Enum
Members
Member | Value | Description
AUTO | 2 | Automatically inverts image, if necessary.
NO | 0 | No inversion required.
YES | 1 | Image inversion should be performed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecInvertMode

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecLanguage Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecLanguage Enumeration
Identifies the different languages supported directly by the Recognition namespace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecLanguage
   Inherits System.Enum
'Usage

Dim instance As ImGearRecLanguage
public enum ImGearRecLanguage : System.Enum
__value public enum ImGearRecLanguage : public System.Enum
public enum class ImGearRecLanguage : public System.Enum
Members
Member | Value | Description
AFR | 39 | Afrikaans language selection.
ALB | 23 | Albanian language selection.
AUTO | -2 | Automatic language selection (only applicable for spell checking). When ImGearRecRecognitionSettings.SpellingLanguage property is set to AUTO, the actual language of the spell checking will be determined as follows: if ImGearRecRecognitionSettings.SpellingEnabled property is true and only one language has been enabled in the ImGearRecRecognitionSettings.LanguageEnabled property, then this language will be automatically selected for spelling, too. This is the default value for the ImGearRecRecognitionSettings.SpellingLanguage property.
AYM | 40 | Aymara language selection.
BAS | 41 | Basque language selection.
BEL | 34 | Byelorussian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
BEM | 42 | Bemba language selection.
BLA | 43 | Blackfoot language selection.
BRA | 45 | Portuguese (Brazilian) language selection.
BRE | 44 | Breton language selection.
BUG | 46 | Bugotu language selection.
BUL | 33 | Bulgarian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
CAT | 11 | Catalan language selection. Spelling is supported.
CHA | 47 | Chamorro language selection.
CHE | 37 | Chechen language selection.
CHS | 120 | Simplified Chinese language selection.
CHT | 121 | Traditional Chinese language selection.
CHU | 48 | Chuana or Tswana language selection.
COR | 49 | Corsican language selection.
CRO | 21 | Croatian language selection.
CRW | 50 | Crow language selection.
CZH | 17 | Czech language selection. Spelling is supported.
DAN | 7 | Danish language selection. Spelling is supported.
DUT | 3 | Dutch language selection. Spelling is supported.
ENG | 0 | English language selection. Spelling supported (Default for recognition).
ESK | 51 | Eskimo language selection.
ESP | 28 | Esperanto language selection.
EST | 25 | Estonian language selection.
FAR | 52 | Faroese language selection.
FIJ | 53 | Fijian language selection.
FIN | 6 | Finnish language selection. Spelling is supported.
FRE | 2 | French language selection. Spelling is supported.
FRI | 54 | Frisian language selection.
FRU | 55 | Friulian language selection.
GAL | 12 | Galician language selection.
GAN | 58 | Ganda or Luganda language selection.
GER | 1 | German language selection. Spelling is supported.
GLI | 56 | Gaelic Irish language selection.
GLS | 57 | Gaelic Scottish language selection.
GRE | 15 | Greek language selection. This selection includes the characters of the English language. Spelling is supported.
GUA | 59 | Guarani language selection.
HAN | 60 | Hani language selection.
HAW | 61 | Hawaiian language selection.
HUN | 19 | Hungarian language selection. Spelling is supported.
ICE | 8 | Icelandic language selection.
IDO | 62 | Ido language selection.
IND | 63 | Indonesian language selection.
INT | 64 | Interlingua language selection.
ITA | 13 | Italian language selection. Spelling is supported.
JPN | 119 | Japanese language selection.
KAB | 38 | Kabardian language selection.
KAS | 65 | Kasub language selection.
KAW | 66 | Kawa language selection.
KIK | 67 | Kikuyu language selection.
KON | 68 | Kongo language selection.
KPE | 69 | Kpelle language selection.
KRN | 122 | Korean language selection.
KUR | 70 | Kurdish language selection if written in latin alphabet.
LAT | 26 | Latvian language selection.
LIT | 27 | Lithuanian language selection.
LTN | 71 | Latin language selection.
LUB | 72 | Luba language selection.
LUX | 73 | Luxembourgian language selection.
MAC | 31 | Macedonian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
MAL | 14 | Maltese language selection.
MAO | 77 | Maori language selection.
MAY | 78 | Mayan language selection.
MIA | 79 | Miao language selection.
MIN | 80 | Minankabaw language selection.
MLG | 74 | Malagasy language selection.
MLN | 76 | Malinke language selection.
MLY | 75 | Malay language selection.
MOH | 81 | Mohawk language selection.
MOL | 32 | Moldavian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
NAH | 82 | Nahuatl language selection.
NO | -1 | No language selection (only applicable for spell checking). This value can be used to specify that the checking module will not use the Language dictionary.
NOR | 4 | Norwegian language selection. Spelling is supported.
NYA | 83 | Nyanja language selection.
OCC | 84 | Occidental language selection.
OJI | 85 | Ojibway language selection.
PAP | 86 | Papiamento language selection.
PID | 87 | Pidgin English language selection.
POL | 16 | Polish language selection. Spelling is supported.
POR | 9 | Portuguese language selection. Spelling is supported.
PRO | 88 | Provencal language selection.
QUE | 89 | Quechua language selection.
RHA | 90 | Rhaetic language selection.
ROM | 22 | Romanian language selection.
ROY | 91 | Romany language selection.
RUA | 92 | Ruanda language selection.
RUN | 93 | Rundi language selection.
RUS | 36 | Russian (Cyrillic) language selection. This selection includes the characters of the English language, as well. Spelling is supported.
SAM | 94 | Samoan language selection.
SAR | 95 | Sardinian language selection.
SHO | 96 | Shona language selection.
SIO | 97 | Sioux language selection.
SLK | 18 | Slovak language selection.
SLN | 20 | Slovenian language selection.
SMI | 98 | Sami language selection (Combination of the Sami language family).
SML | 99 | Lule Sami language selection.
SMN | 100 | Northern Sami language selection.
SMS | 101 | Southern Sami language selection.
SOM | 102 | Somali language selection.
SOT | 103 | Sotho, Suto or Sesuto language selection.
SPA | 10 | Spanish language selection. Spelling is supported.
SRB | 30 | Serbian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
SRL | 29 | Serbian (Latin) language selection.
START | -3 | Used internally.
SUN | 104 | Sundanese language selection.
SWA | 105 | Swahili language selection.
SWE | 5 | Swedish language selection. Spelling is supported.
SWZ | 106 | Swazi language selection.
TAG | 107 | Tagalog language selection.
TAH | 108 | Tahitian language selection.
TIN | 109 | Tinpo language selection.
TON | 110 | Tongan language selection.
TUN | 111 | Tun language selection.
TUR | 24 | Turkish language selection.
UD | -3 | Used internally.
UKR | 35 | Ukrainian (Cyrillic) language selection. This selection includes the characters of the English language, as well.
VIS | 112 | Visayan language selection.
WEL | 113 | Welsh language selection.
WEN | 114 | Wend or Sorbian language selection.
WOL | 115 | Wolof language selection.
XHO | 116 | Xhosa language selection.
ZAP | 117 | Zapotec language selection.
ZUL | 118 | Zulu language selection.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecLanguage

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecLicenseFeature Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecLicenseFeature Enumeration
Identifies public license features.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecLicenseFeature
   Inherits System.Enum
'Usage

Dim instance As ImGearRecLicenseFeature
public enum ImGearRecLicenseFeature : System.Enum
__value public enum ImGearRecLicenseFeature : public System.Enum
public enum class ImGearRecLicenseFeature : public System.Enum
Members
Member | Value | Description
AsianOcr | 2 | Asian OCR license.
FormattedOutput | 1 | Formatted output feature. Allows saving recognition data to complex formats such as Word document, RTF, etc.
Ocr | 0 | Western OCR license.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecLicenseFeature

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecMakeupInfo Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecMakeupInfo Enumeration
Provides character makeup information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecMakeupInfo
   Inherits System.Enum
'Usage

Dim instance As ImGearRecMakeupInfo
public enum ImGearRecMakeupInfo : System.Enum
__value public enum ImGearRecMakeupInfo : public System.Enum
public enum class ImGearRecMakeupInfo : public System.Enum
Members
Member | Value | Description
ENDOFCELL | 0x00000020 | The character is the last one in a cell.
ENDOFLINE | 0x00000001 | The character is the last one in a line.
ENDOFPAGE | 0x00000010 | The character is the last one on the page.
ENDOFPARA | 0x00000002 | The character is the last one in a paragraph.
ENDOFROW | 0x00000040 | End of the last line of the last filled cell of a table row.
ENDOFWORD | 0x00000004 | The character is the last one of a word.
ENDOFZONE | 0x00000008 | The character is the last one of a zone.
INTABLE | 0x00000080 | Letter is in a table cell.
LEFTTEXT | 0x00000200 | Left rotated / orientation's upward.
NORMTEXT | 0x00000000 | Normal text.
RIGHTTEXT | 0x00000300 | Right rotated / orientation's downward.
TEXT_DIR_MASK | 0x00000700 | Mask of text direction in makeup property.
VERTTEXT | 0x00000100 | Vertical text / neon text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecMakeupInfo

See Also

Reference

ImageGear.Recognition Namespace
Makeup Property


%%PageItemTitle%%

ImGearRecModule Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecModule Enumeration
Identifies the modules of the OmniPage recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecModule
   Inherits System.Enum
'Usage

Dim instance As ImGearRecModule
public enum ImGearRecModule : System.Enum
__value public enum ImGearRecModule : public System.Enum
public enum class ImGearRecModule : public System.Enum
Members
Member | Value | Description
API | 0 | OmniPage core module.
ASN | 21 | Asian languages recognition module.
CHR | 9 | Character Set and Code Page handling module.
DCM | 6 | Automatic page-layout decomposition module.
DOT | 2 | 9-pin draft dot-matrix recognition module.
FRX | 19 | Multi-lingual FRX omnifont recognition module.
IMF | 8 | Image file I/O module.
IMG | 7 | Image handling module.
MGR | 14 | OmniPage core module.
MOR | 1 | Multi-lingual MOR omnifont recognition module.
MTX | 15 | M/TEXT omnifont recognition module.
PLUS2W | 18 | PLUS2W omnifont recognition module.
PLUS3W | 20 | PLUS3W omnifont recognition module.
RSD | 12 | Scanning module (not used in the ImageGear recognition component).
SPL | 11 | Checking module.
TXT | 10 | Output file generation module.
XOCR | 22 | XOCR module. The standard page parse module.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecModule

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecOrientationMode Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOrientationMode Enumeration
Identifies image orientation modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecOrientationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecOrientationMode
public enum ImGearRecOrientationMode : System.Enum
__value public enum ImGearRecOrientationMode : public System.Enum
public enum class ImGearRecOrientationMode : public System.Enum
Members
Member | Value | Description
AUTO | 0 | Automatic image orientation.
DOWN | 3 | Rotate image down (rotate twice).
DOWN_FLIPPED | 131 | Flip around X-axis.
FLIPPED | 129 | Flip around the Y axis.
LEFT | 4 | Rotate image to the left (90 degrees counter-clockwise).
LEFT_FLIPPED | 132 | Flip around the Y axis, then rotate to the left.
NO | 1 | Do not orient the image.
RIGHT | 2 | Rotate image to the right (90 degrees clockwise).
RIGHT_FLIPPED | 130 | Flip around the Y axis, then rotate to the right.
Remarks

Note: Automatic image rotation (AUTO) can only be used with good quality machine-printed texts. It is not applicable to images containing 9-pin dot-matrix text or other non-machine printed text.

Note: Orientation modes that include mirroring values (those with the suffix FLIPPED) are ignored during image pre-processing ImGearRecImage.Preprocess. They are available only through ImGearRecImage.Orient method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecOrientationMode

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecOutputCodePageType Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputCodePageType Enumeration
Identifies code page categories.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecOutputCodePageType
   Inherits System.Enum
'Usage

Dim instance As ImGearRecOutputCodePageType
public enum ImGearRecOutputCodePageType : System.Enum
__value public enum ImGearRecOutputCodePageType : public System.Enum
public enum class ImGearRecOutputCodePageType : public System.Enum
Members
Member | Value | Description
ANSI_BASED | 3 | Code Pages typically used by different localized Windows versions and Windows applications, e.g. Windows Greek.
ASCII_BASED | 2 | Code Pages typically used by different localized DOS versions and DOS applications, e.g. CodePage 437.
ASIAN_CODEPAGE | 6 | Multibyte code pages for Asian languages.
CODEP_UNKNOWN | 0 | Code Pages not classified to any further categories, e.g. Roman-8.
INTERNAL_CP | 5 | Reserved 8-bit and 16 bit Code Pages used internally by the engine.
MAC_BASED | 4 | Code Pages typically used by different localized Mac versions and applications, e.g. Macintosh Central European CP.
SPECIFIC | 1 | 16-bit Code Pages, e.g. UNICODE.
Remarks
This enumeration identifies code page categories. Each output converter is classified into one of these categories.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecOutputCodePageType

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecOutputLevel Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputLevel Enumeration
Identifies pre-defined levels of the format retention for the final output document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecOutputLevel
   Inherits System.Enum
'Usage

Dim instance As ImGearRecOutputLevel
public enum ImGearRecOutputLevel : System.Enum
__value public enum ImGearRecOutputLevel : public System.Enum
public enum class ImGearRecOutputLevel : public System.Enum
Members
Member | Value | Description
AUTO | 0 | Converter default.
FLOWINGPAGE | 4 | Flowing Page.
NOFORMAT | 1 | No formatting.
RFP | 2 | Retain Font and Paragraphs.
SPREADSHEET | 5 | Spread sheet.
TRUEPAGE | 3 | True Page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecOutputLevel

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecProcess Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecProcess Enumeration
Identifies processes of the recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecProcess
   Inherits System.Enum
'Usage

Dim instance As ImGearRecProcess
public enum ImGearRecProcess : System.Enum
__value public enum ImGearRecProcess : public System.Enum
public enum class ImGearRecProcess : public System.Enum
Members
Member | Value | Description
CONVERTIMG | 9 | This identifies the image conversion process activated by the WRITEFOUTDOC process for saving the image of a graphical image zone to the final output document (if this was requested).
DECOMPOSITION | 3 | This identifies the page-layout decomposition (auto-zoning) process.
IMGINPUT | 0 | This identifies the Image importing process.
IMGPREPROCESS | 2 | This identifies the Image pre-processing process.
IMGSAVE | 1 | This identifies the image saving process. During this process the image or a part of it is saved to an image file.
READRDF | 7 | This identifies reading from the recognition data file.
RECOGNITION1 | 4 | This identifies the 1st pass of the Recognition process, if applicable.
RECOGNITION2 | 5 | This identifies the 2nd pass of the Recognition process, if applicable.
RECOGNITION3 | 10 | This identifies the 3rd pass of the Recognition process. This pass is applicable only for the Omnifont PLUS3W recognition module.
SPELLING | 6 | This identifies the Checking process.
UNKNOWN | 11 | Unknown process.
WRITEFOUTDOC | 8 | This identifies the process for writing the recognized text to the final output document (to file or memory).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecProcess

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecRecognitionModule Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecRecognitionModule Enumeration
Identifies recognition modules of the OmniPage recognition engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecRecognitionModule
   Inherits System.Enum
'Usage

Dim instance As ImGearRecRecognitionModule
public enum ImGearRecRecognitionModule : System.Enum
__value public enum ImGearRecRecognitionModule : public System.Enum
public enum class ImGearRecRecognitionModule : public System.Enum
Members
Member | Value | Description
ASIAN | 14 | Specifies the Asian language recognition module.
AUTO | 0 | Specifies that the Recognition component will try to automatically select the most suitable recognition module for the zone. The recognition module to be applied is determined just before recognition, primarily by inquiring the filling method and other settings, most typically the Character Set.
DOT | 3 | Specifies the DOT 9-pin draft dot-matrix module.
OMNIFONT_FRX | 12 | Specifies the FireWorX omnifont recognition module.
OMNIFONT_MOR | 2 | Specifies the multi-lingual MOR omnifont module.
OMNIFONT_MTX | 1 | Specifies the M/TEXT omnifont module.
OMNIFONT_PLUS2W | 11 | Specifies the two-way voting POWR++ omnifont recognition module.
OMNIFONT_PLUS3W | 13 | Specifies the most accurate three-way voting omnifont recognition module.
Remarks
A recognition module must have been assigned to all zones in their ImGearRecZone.RecognitionModule property before processing.

Each zone needs to be associated with a RECOGNITIONMODULE (RM) and a FILLINGMETHOD (FM). This is needed because some RMs support more than one FM, and some FMs are accepted by more than one RM. It is important to ensure that the RM-FM pair is suitable. E.g. the multi-lingual MOR omnifont recognition module (ImGearRecRecognitionModule.OMNIFONT_MOR) is capable of recognizing omnifont machine print (ImGearRecFillingMethod.OMNIFONT) 24-pin draft dot-matrix print (ImGearRecFillingMethod.DRAFTDOT24), OCR-A (ImGearRecFillingMethod.OCRA) and OCR-B (ImGearRecFillingMethod.OCRB) texts.

For precise information on permitted RM-FM pairs see the introduction to the topic <f Recognition module specifications>.

Only recognition modules which have been supplied and successfully installed in the Engine configuration will be available.

The AUTO setting can specifically placed in the zone's ImGearRecZone.RecognitionModule property, it will be generated by ImGearRecPage.ImGearRecZone (auto-zoning) and will, under certain circumstances, be generated by the ImGearRecZoneCollection.DetectFillingMethod method.

You can force the use of a particular RM by specifying it directly in the zone's ImGearRecZone.RecognitionModule property, i.e. you must update the zones concerned with the <f RecUpdateZone> function after calling ImGearRecZoneCollection.Locate or ImGearRecZoneCollection.DetectFillingMethod.

When AUTO is set, the RM is chosen primarily by the FM (either directly specified, taken as default or auto-detected). The choices will be as follows:

  • OMNIFONT | OMNIFONT_MTX or OMNIFONT_MOR,
  • DOTMATRIX24 | OMNIFONT_MTX or OMNIFONT_MOR,
  • DOTMATRIX9 | OMNIFONT_MTX or DOT.

These filling methods will be directed to MTX, unless the engine finds a language, filter or other setting which is not supported by this module.

For further details see the MTX recognition module specification. As an example:

The zone's FM is ImGearRecFillingMethod.OMNIFONT and ImGearRecRecognitionModule.AUTO has been specified. If only the characters of English and/or the main West European languages are validated for recognition, then the M/TEXT omnifont recognition module ( ImGearRecRecognitionModule.OMNIFONT_MTX) will be automatically selected.

However, if e.g. the Polish characters are also to be recognized, the engine manager will select the multi-lingual MOR omnifont recognition module ImGearRecRecognitionModule.OMNIFONT_MOR, since the M/TEXT recognition module does not support the Polish characters, but the MOR recognition module does.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecRecognitionModule

See Also

Reference

ImageGear.Recognition Namespace
ImGearRecZone Class
ImGearRecZoneCollection Class


%%PageItemTitle%%

ImGearRecReductionMode Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecReductionMode Enumeration
Identifies image conversion modes to be applied for conversions from grayscale or 24-bit color image sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecReductionMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecReductionMode
public enum ImGearRecReductionMode : System.Enum
__value public enum ImGearRecReductionMode : public System.Enum
public enum class ImGearRecReductionMode : public System.Enum
Members
Member | Value | Description
AUTO | 0 | This has an effect on grayscale or 24-bit color images: a B/W image is created in Engine's memory. An automatic adaptive thresholding algorithm is applied for the binarization of the image. Use ImGearRecPreprocessingSettings.ReductionBrightness property to fine tune the threshold calculation.
GLOBAL | 3 | This has an effect on grayscale or 24-bit color images: a bitonal image is created internally. An automatic thresholding algorithm with a page-level global threshold value is applied for the binarization of the image.
GRAY | 4 | For a color image: a grayscale image is created internally. For a bitonal or grayscale image: no reduction is performed while loading the image.
NO | 2 | There is no conversion while loading the image. The image is loaded without any conversion (i.e. a color image retains its color attributes).
SET | 1 | This has an effect on grayscale or 24-bit color images: a bitonal image is created internally. Thresholding with a user defined threshold value, set by ImGearRecPreprocessingSettings.ReductionThreshold property.
Remarks
These values specify how the different image types will be converted either during the primary image conversions or during the secondary image conversions.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecReductionMode

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecResEnhancementMode Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecResEnhancementMode Enumeration
Determines recognition resolution enhancement mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecResEnhancementMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecResEnhancementMode
public enum ImGearRecResEnhancementMode : System.Enum
__value public enum ImGearRecResEnhancementMode : public System.Enum
public enum class ImGearRecResEnhancementMode : public System.Enum
Members
Member | Value | Description
AUTO | 4 | Auto enhancement.
NO | 0 | No enhancement.
YES | 1 | Makes enhancement.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecResEnhancementMode

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecSpaceType Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecSpaceType Enumeration
Specifies possible space types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecSpaceType
   Inherits System.Enum
'Usage

Dim instance As ImGearRecSpaceType
public enum ImGearRecSpaceType : System.Enum
__value public enum ImGearRecSpaceType : public System.Enum
public enum class ImGearRecSpaceType : public System.Enum
Members
Member | Value | Description
DotLeader | 2 | Dot leader.
HyphenLeader | 4 | Hyphen leader.
LineLeader | 3 | Line leader.
Space | 0 | Real space.
Tab | 1 | Tabular space.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecSpaceType

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecTradeoff Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecTradeoff Enumeration
Tradeoff between accuracy and speed for recognition process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecTradeoff
   Inherits System.Enum
'Usage

Dim instance As ImGearRecTradeoff
public enum ImGearRecTradeoff : System.Enum
__value public enum ImGearRecTradeoff : public System.Enum
public enum class ImGearRecTradeoff : public System.Enum
Members
Member | Value | Description
ACCURATE | 0 | Most accurate recognition (Default).
BALANCED | 1 | Mid-level accuracy/speed recognition.
FAST | 2 | Fast recognition.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecTradeoff

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecZoneCheckingFlags Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneCheckingFlags Enumeration
Defines flags for the ImGearRecZone.Checking property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearRecZoneCheckingFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearRecZoneCheckingFlags
[Flags()]
public enum ImGearRecZoneCheckingFlags : System.Enum
[Flags()]
__value public enum ImGearRecZoneCheckingFlags : public System.Enum
[Flags()]
public enum class ImGearRecZoneCheckingFlags : public System.Enum
Members
Member | Value | Description
CHECKCBF_PROHIBIT | 0x00000004 | Input flag to prohibit the use of the user-written checking callback function.
CHECKCBF_USED | 0x00040000 | Output "After recognition flag" that tells whether a user-written checking callback function was enabled during the checking process (user-written checking was activated).
CORRECT_PROPERNAME | 0x00000200 | Not used in this version - included for backward compatibility.
CORRECTION_DISABLE | 0x00000080 | Not used in this version - included for backward compatibility.
IGNORE_CASE | 0x00000020 | Input flag to specify case insensitive UD-checking.
IGNORE_WHITESPACE | 0x00000010 | Input flag to ignore white space characters (SPACE and TAB characters) during checking. It should be used together with the PASS_LINES flag.
INCLUDE_PUNCTUATION | 0x00000100 | Input flag to consider punctuation characters on the boundaries of the strings as well.
LANGDICT_PROHIBIT | 0x00000001 | Input flag to prohibit the use of the Language dictionary.
LANGDICT_USED | 0x00010000 | Output "After recognition flag" that tells whether the Language dictionary was enabled during the checking process (spell checking was activated for the zone).
PASS_LINES | 0x00000040 | Input flag to instruct the selected recognition module to pass entire lines to the checker, instead of words. Do not use this attribute in conjunction with spell checking.
USERDICT_PROHIBIT | 0x00000002 | Input flag to prohibit the use of the User dictionary.
USERDICT_USED | 0x00020000 | Output "After recognition flag" that tells whether the User dictionary was enabled during the checking process (UD-checking was activated for the zone).
VERTDICT_PROHIBIT | 0x00000008 | Input flag to prohibit the use of the Vertical dictionary.
VERTDICT_USED | 0x00080000 | Output "After recognition flag" that tells whether a Vertical dictionary was enabled during the checking process.
Remarks
Some of these flags are used to specify how a zone should be checked (Input flags). The others are set by the engine after recognition to provide the info on the settings used during the recognition (Output flags).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecZoneCheckingFlags

See Also

Reference

ImageGear.Recognition Namespace
ImGearRecZone Class


%%PageItemTitle%%

ImGearRecZoneType Enumeration

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecZoneType Enumeration
Determines Zone types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecZoneType
   Inherits System.Enum
'Usage

Dim instance As ImGearRecZoneType
public enum ImGearRecZoneType : System.Enum
__value public enum ImGearRecZoneType : public System.Enum
public enum class ImGearRecZoneType : public System.Enum
Members
Member | Value | Description
FLOW | 0 | Flowed text. This zone type means that the zone contains textual information arranged horizontally without a table type structure inside. It can also be used for horizontally appearing CJK or Chinese-Japanese-Korean characters.
GRAPHIC | 2 | Graphic type zone. This type of zone contains graphics, i.e. this zone will not be recognized at all and all other recognition related settings will be ignored. The only reason to have such a zone is to save or export the image inside it.
IGNORE | 4 | Zone should be ignored during recognition.
LEFTTEXT | 7 | Left rotated text. For Latin, Greek and Cyrillic characters only.
RIGHTTEXT | 8 | Right rotated text. For Latin, Greek and Cyrillic characters only.
TABLE | 1 | Table type zone. This type means that the zone contains a table, i.e. rows and columns, with or without a grid. Such zones will be handled differently from flowed text type zones. The Engine will try to reconstruct as much of the original table text layout of the zone as the final output document format supports.
VERTTEXT | 6 | Vertical text. For CJK or Chinese-Japanese-Korean characters only.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.ImGearRecZoneType

See Also

Reference

ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecCodePage Structure
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePage Structure
Contains information about a Code Page used for writing recognition output.
Object Model
ImGearRecCodePage Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRecCodePage
   Inherits System.ValueType
'Usage

Dim instance As ImGearRecCodePage
public struct ImGearRecCodePage : System.ValueType
public __value struct ImGearRecCodePage : public System.ValueType
public value class ImGearRecCodePage : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Recognition.ImGearRecCodePage

See Also

Reference

ImGearRecCodePage Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecCodePage Structure Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePage Structure

The following tables list the members exposed by ImGearRecCodePage.

Public Properties
 | Name | Description
Public Property | Description | Gets description of the Code Page.
Public Property | Name | Gets long name of the Code Page.
Public Property | Type | Gets code page type.
Top
See Also

Reference

ImGearRecCodePage Structure
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecCodePage Structure Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCodePage Structure

For a list of all members of this type, see ImGearRecCodePage members.

Public Properties
 | Name | Description
Public Property | Description | Gets description of the Code Page.
Public Property | Name | Gets long name of the Code Page.
Public Property | Type | Gets code page type.
Top
See Also

Reference

ImGearRecCodePage Structure
ImageGear.Recognition Namespace


Description Property (ImGearRecCodePage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCodePage Structure : Description Property
Gets description of the Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Description As String
'Usage

Dim instance As ImGearRecCodePage
Dim value As String

value = instance.Description
public string Description {get;}
public: __property string* get_Description();
public:
property String^ Description {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearRecCodePage Structure
ImGearRecCodePage Members


Name Property (ImGearRecCodePage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCodePage Structure : Name Property
Gets long name of the Code Page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearRecCodePage
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearRecCodePage Structure
ImGearRecCodePage Members


Type Property (ImGearRecCodePage)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecCodePage Structure : Type Property
Gets code page type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearRecOutputCodePageType
'Usage

Dim instance As ImGearRecCodePage
Dim value As ImGearRecOutputCodePageType

value = instance.Type
public ImGearRecOutputCodePageType Type {get;}
public: __property ImGearRecOutputCodePageType get_Type();
public:
property ImGearRecOutputCodePageType Type {
   ImGearRecOutputCodePageType get();
}

Property Value

ImGearRecOutputCodePageType enumeration value.
See Also

Reference

ImGearRecCodePage Structure
ImGearRecCodePage Members


%%PageItemTitle%%

ImGearRecOutputFormat Structure
Members

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormat Structure
Represents an output format for writing recognition output.
Object Model
ImGearRecOutputFormat Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure ImGearRecOutputFormat
   Inherits System.ValueType
'Usage

Dim instance As ImGearRecOutputFormat
public struct ImGearRecOutputFormat : System.ValueType
public __value struct ImGearRecOutputFormat : public System.ValueType
public value class ImGearRecOutputFormat : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ImageGear.Recognition.ImGearRecOutputFormat

See Also

Reference

ImGearRecOutputFormat Members
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecOutputFormat Structure Members
Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormat Structure

The following tables list the members exposed by ImGearRecOutputFormat.

Public Properties
 | Name | Description
Public Property | DefaultFileExtension | Gets default file extension of the output format (i.e. "txt").
Public Property | Name | Gets the name of the output format.
Top
See Also

Reference

ImGearRecOutputFormat Structure
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Properties$$

ImGearRecOutputFormat Structure Properties

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecOutputFormat Structure

For a list of all members of this type, see ImGearRecOutputFormat members.

Public Properties
 | Name | Description
Public Property | DefaultFileExtension | Gets default file extension of the output format (i.e. "txt").
Public Property | Name | Gets the name of the output format.
Top
See Also

Reference

ImGearRecOutputFormat Structure
ImageGear.Recognition Namespace


DefaultFileExtension Property

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputFormat Structure : DefaultFileExtension Property
Gets default file extension of the output format (i.e. "txt").
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DefaultFileExtension As String
'Usage

Dim instance As ImGearRecOutputFormat
Dim value As String

value = instance.DefaultFileExtension
public string DefaultFileExtension {get;}
public: __property string* get_DefaultFileExtension();
public:
property String^ DefaultFileExtension {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearRecOutputFormat Structure
ImGearRecOutputFormat Members


Name Property (ImGearRecOutputFormat)

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace > ImGearRecOutputFormat Structure : Name Property
Gets the name of the output format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearRecOutputFormat
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearRecOutputFormat Structure
ImGearRecOutputFormat Members


%%PageItemTitle%%

ImGearRecCheckWordEventHandler Delegate

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecCheckWordEventHandler Delegate
Event sender object.
ImGearRecProgressEventArgs value.
Event handler for the ImGearRecZone.CheckWord property event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This delegate is deprecated and will be removed from the public API in a future release.")>
Public Delegate Sub ImGearRecCheckWordEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearRecCheckWordEventArgs _
)
'Usage

Dim instance As New ImGearRecCheckWordEventHandler(AddressOf HandlerMethod)
[Obsolete("This delegate is deprecated and will be removed from the public API in a future release.")]
public delegate void ImGearRecCheckWordEventHandler(
   object sender,
   ImGearRecCheckWordEventArgs e
)
[Obsolete("This delegate is deprecated and will be removed from the public API in a future release.")]
public: __gc __delegate void ImGearRecCheckWordEventHandler(
   Object* sender,
   ImGearRecCheckWordEventArgs* e
)
[Obsolete("This delegate is deprecated and will be removed from the public API in a future release.")]
public delegate void ImGearRecCheckWordEventHandler(
   Object^ sender,
   ImGearRecCheckWordEventArgs^ e
)

Parameters

sender
Event sender object.
e
ImGearRecProgressEventArgs value.
Remarks
The application should implement this event handler for zones where recognition accuracy should be improved by additional checking provided by the application or by the end user.
See Also

Reference

ImGearRecCheckWordEventHandler Members
ImageGear.Recognition Namespace
ImGearRecCheckWordEventArgs Class


%%PageItemTitle%%

ImGearRecProgressEventHandler Delegate
Example Example

ImageGear22.Recognition Assembly > ImageGear.Recognition Namespace : ImGearRecProgressEventHandler Delegate
Event sender (ImGearRecognition object).
ImGearRecProgressEventArgs value.
This is the delegate used to pass ImGearRecognition.Progress events on to an application event handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearRecProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearRecProgressEventArgs _
)
'Usage

Dim instance As New ImGearRecProgressEventHandler(AddressOf HandlerMethod)
public delegate void ImGearRecProgressEventHandler(
   object sender,
   ImGearRecProgressEventArgs e
)
public: __gc __delegate void ImGearRecProgressEventHandler(
   Object* sender,
   ImGearRecProgressEventArgs* e
)
public delegate void ImGearRecProgressEventHandler(
   Object^ sender,
   ImGearRecProgressEventArgs^ e
)

Parameters

sender
Event sender (ImGearRecognition object).
e
ImGearRecProgressEventArgs value.
Remarks
It follows the standard .NET event model. The ImGearRecognition.Progress event occurs during recognition processes. It indicates which recognition process is being performed, its percent completion, and gives the application a means of aborting the current recognition process.

Here’s an example of typical ImGearRecognition.Progress event registration and declaration:

Example
  • C#
public delegate void UpdateProgressBarDelegate(ImGearRecProgressEventArgs e);
UpdateProgressBarDelegate progressDelegate = null;

void UpdateProgressBar(ImGearRecProgressEventArgs e)
{
    if (e.Percent < 100)
        toolStripStatusProgress.Text = e.Process + " - " + e.Percent + "%";
    else
        toolStripStatusProgress.Text = "Ready";
    this.Update();
}

private void recProgress(object sender, ImGearRecProgressEventArgs e)
{
    if(this.InvokeRequired)
    {
        object[] arg = new object[1];
        arg[0] = e;
        this.Invoke(progressDelegate, arg);
    }
    else
    {
        UpdateProgressBar(e);
    }
}
  • Visual Basic
Public Delegate Sub UpdateProgressBarDelegate(ByVal e As ImGearRecProgressEventArgs)
Public progressDelegate As UpdateProgressBarDelegate

Sub UpdateProgressBar(ByVal e As ImGearRecProgressEventArgs)
    If e.Percent < 100 Then
        toolStripStatusProgress.Text = e.Process.ToString() + " - " + e.Percent.ToString() + "%"
    Else
        toolStripStatusProgress.Text = "Ready"
    End If
    Me.Update()
End Sub

Private Sub recProgress(ByVal sender As Object, ByVal e As ImGearRecProgressEventArgs)
    If Me.InvokeRequired Then
        Dim arg As Object() = New Object(0) {}
        arg(0) = e
        Me.Invoke(progressDelegate, arg)
    Else
        UpdateProgressBar(e)
    End If
End Sub
See Also

Reference

ImGearRecProgressEventHandler Members
ImageGear.Recognition Namespace
ImGearRecProgressEventArgs Class


ImageGear22.Recognition.Forms Assembly
Namespaces
Namespace | Description
ImageGear.Recognition.Forms | This namespace contains classes that offer recognition-related user interface functionality.


ImageGear.Recognition.Forms Namespace
Inheritance Hierarchy
ImageGear22.Recognition.Forms Assembly : ImageGear.Recognition.Forms Namespace
This namespace contains classes that offer recognition-related user interface functionality.
Classes
 | Class | Description
Class | ImGearRecZoneGUI | This is the main recognition zone editor GUI class that allows controlling visibility and customization of the zone editor toolbar, showing zone property pages, processing mouse events, and so on.
Class | ImGearRecZoneGUICustomBtnParam | Represents custom button parameters.
Class | ImGearRecZoneGUICustomBtnParams | Represents custom button parameters collection.
Class | ImGearRecZoneGUICustomToolBar | Provides access to custom tool bar.
Enumerations
 | Enumeration | Description
Enumeration | ImGearRecZoneGUIEditMode | Specifies the edit mode used for zone editing GUI.
Enumeration | ImGearRecZoneGUIMatchingFlags | Specifies flags used to describe which types of zones should match a custom zone editor toolbar button.
Enumeration | ImGearRecZoneGUIType | Zone type used for zone editor toolbar buttons.
See Also

Reference

ImageGear22.Recognition.Forms Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Recognition.Forms Namespace Inheritance Hierarchy
ImageGear22.Recognition.Forms Assembly : ImageGear.Recognition.Forms Namespace
Inheritance Hierarchy
System.Object
ImageGear.Recognition.Forms.ImGearRecZoneGUI
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomToolBar
See Also

Reference

ImageGear22.Recognition.Forms Assembly


%%PageItemTitle%%

ImGearRecZoneGUI Class
Members

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUI Class
This is the main recognition zone editor GUI class that allows controlling visibility and customization of the zone editor toolbar, showing zone property pages, processing mouse events, and so on.
Object Model
ImGearRecZoneGUI Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearRecZoneGUI
'Usage

Dim instance As ImGearRecZoneGUI
public sealed class ImGearRecZoneGUI
public __gc __sealed class ImGearRecZoneGUI
public ref class ImGearRecZoneGUI sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.Forms.ImGearRecZoneGUI

See Also

Reference

ImGearRecZoneGUI Members
ImageGear.Recognition.Forms Namespace
ImageGear.Recognition Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZoneGUI Class Members
Properties Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUI Class

The following tables list the members exposed by ImGearRecZoneGUI.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecZoneGUI Constructor | Initializes a new instance of the ImGearRecZoneGUI class.
Top
Public Properties
 | Name | Description
Public Property | EditMode | Gets or sets edit mode used for zone editing GUI.
Public Property | SelectedButton | Gets or sets the selected button on the toolbar.
Public Property | ToolBarIsCustomized | Gets a value indicating whether or not the recognition zone editor toolbar is customized.
Public Property | ToolBarIsVisible | Gets a value indicating whether the toolbar is visible.
Public Property | ToolBarLicenseCheck | Gets or sets a value indicating whether or not currently licensed recognition modules will be taken into account in the appearance and behavior of the toolbar and property sheets.
Public Property | UtilityButtonsAreHidden | Gets a value indicating whether utility buttons on the recognition zone editor toolbar are hidden.
Top
Public Methods
 | Name | Description
Public Method | ButtonIsCustomized | Returns true if the specified toolbar button is customized.
Public Method | ButtonIsHidden | Returns true if the specified toolbar button is hidden.
Public Method | ClearAllZones | Removes all zones from the recognition page associated with the ImGearRecZoneGUI object.
Public Method | CreateCustomButtonDialog | Creates a custom button using the property sheet GUI.
Public Method | CreateRecGUIPage | Overloaded. Creates a recognition GUI page from an existing recognition page, and optionally an ART page.
Public Method | CustomizeButtonDialog | Opens a property sheet GUI which can be used to customize the specified button.
Public Method | Dispose | Frees all data associated with this object.
Public Method | HideStandardButton | Hides the specified standard toolbar button.
Public Method | HideToolBar | Hides the recognition zone editor toolbar.
Public Method | HideUtilityButtons | Hides the utility buttons on the recognition zone editor toolbar.
Public Method | HideZoneMarks | Hides the zone marks which are used to indicate zone location, size, and type.
Public Method | LoadCustomToolBar | Loads a customized toolbar previously saved to disk in XML format and makes it the current toolbar.
Public Method | ModifyCustomButtonDialog | Modifies custom button dialog.
Public Method | MouseDown | Processes MouseDown events from the application in order to provide zone editor GUI functionality.
Public Method | MouseMove | Processes MouseMove events from the application in order to provide zone editor GUI functionality.
Public Method | MouseUp | Processes MouseUp events from the application in order to provide zone editor GUI functionality.
Public Method | Refresh | Updates the recognition zone editor GUI's collection of marks to match the zones currently defined by the recognition page and also draws the marks.
Public Method | RevertToDefaultToolBar | Clears all modifications to the recognition zone editor toolbar.
Public Method | SaveCustomToolBar | Serializes a custom toolbar created within the ImGearRecZoneGUI class to XML and saves it to the path specified.
Public Method | SetRecGUIZoneType | Defines the attributes of the next zone created using the recognition zone editor GUI.
Public Method | ShowStandardButton | Shows the specified standard toolbar button.
Public Method | ShowToolBar | Shows the recognition zone editor toolbar.
Public Method | ShowUtilityButtons | Shows the utility buttons on the recognition zone editor toolbar.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecZoneGUI class.
Top
See Also

Reference

ImGearRecZoneGUI Class
ImageGear.Recognition.Forms Namespace
ImageGear.Recognition Namespace


%%PageItemTitle%%

ImGearRecZoneGUI Constructor

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ImGearRecZoneGUI Constructor
Page view control used to display the image whose zones are to be edited.
Instance of the recognition engine being used by the application.
Initializes a new instance of the ImGearRecZoneGUI class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal recognitionEngine As ImGearRecognition _
)
'Usage

Dim pageView As ImGearPageView
Dim recognitionEngine As ImGearRecognition

Dim instance As New ImGearRecZoneGUI(pageView, recognitionEngine)
public ImGearRecZoneGUI(
   ImGearPageView pageView,
   ImGearRecognition recognitionEngine
)
public: ImGearRecZoneGUI(
   ImGearPageView* pageView,
   ImGearRecognition* recognitionEngine
)
public:
ImGearRecZoneGUI(
   ImGearPageView^ pageView,
   ImGearRecognition^ recognitionEngine
)

Parameters

pageView
Page view control used to display the image whose zones are to be edited.
recognitionEngine
Instance of the recognition engine being used by the application.

Return Value

Instance of the ImGearRecZoneGUI class representing the recognition zone editor GUI which is set up to work with the given page view control and recognition engine.
Remarks
You must supply a page view control (ImGearPageView object) which will be used to display the image whose zones are to be edited. You must also supply the instance of the recognition engine being used by the application.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUI Class
ImGearRecognition Class
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearRecZoneGUI Class Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUI Class

For a list of all members of this type, see ImGearRecZoneGUI members.

Public Methods
 | Name | Description
Public Method | ButtonIsCustomized | Returns true if the specified toolbar button is customized.
Public Method | ButtonIsHidden | Returns true if the specified toolbar button is hidden.
Public Method | ClearAllZones | Removes all zones from the recognition page associated with the ImGearRecZoneGUI object.
Public Method | CreateCustomButtonDialog | Creates a custom button using the property sheet GUI.
Public Method | CreateRecGUIPage | Overloaded. Creates a recognition GUI page from an existing recognition page, and optionally an ART page.
Public Method | CustomizeButtonDialog | Opens a property sheet GUI which can be used to customize the specified button.
Public Method | Dispose | Frees all data associated with this object.
Public Method | HideStandardButton | Hides the specified standard toolbar button.
Public Method | HideToolBar | Hides the recognition zone editor toolbar.
Public Method | HideUtilityButtons | Hides the utility buttons on the recognition zone editor toolbar.
Public Method | HideZoneMarks | Hides the zone marks which are used to indicate zone location, size, and type.
Public Method | LoadCustomToolBar | Loads a customized toolbar previously saved to disk in XML format and makes it the current toolbar.
Public Method | ModifyCustomButtonDialog | Modifies custom button dialog.
Public Method | MouseDown | Processes MouseDown events from the application in order to provide zone editor GUI functionality.
Public Method | MouseMove | Processes MouseMove events from the application in order to provide zone editor GUI functionality.
Public Method | MouseUp | Processes MouseUp events from the application in order to provide zone editor GUI functionality.
Public Method | Refresh | Updates the recognition zone editor GUI's collection of marks to match the zones currently defined by the recognition page and also draws the marks.
Public Method | RevertToDefaultToolBar | Clears all modifications to the recognition zone editor toolbar.
Public Method | SaveCustomToolBar | Serializes a custom toolbar created within the ImGearRecZoneGUI class to XML and saves it to the path specified.
Public Method | SetRecGUIZoneType | Defines the attributes of the next zone created using the recognition zone editor GUI.
Public Method | ShowStandardButton | Shows the specified standard toolbar button.
Public Method | ShowToolBar | Shows the recognition zone editor toolbar.
Public Method | ShowUtilityButtons | Shows the utility buttons on the recognition zone editor toolbar.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearRecZoneGUI class.
Top
See Also

Reference

ImGearRecZoneGUI Class
ImageGear.Recognition.Forms Namespace
ImageGear.Recognition Namespace


ButtonIsCustomized Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ButtonIsCustomized Method
Button ID to check for being customized.
Returns true if the specified toolbar button is customized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ButtonIsCustomized( _
   ByVal buttonId As ImGearRecZoneGUIType _
) As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim buttonId As ImGearRecZoneGUIType
Dim value As Boolean

value = instance.ButtonIsCustomized(buttonId)
public bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)
public: bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)
public:
bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button ID to check for being customized.

Return Value

true | The specified toolbar button is customized.
false | The specified toolbar button is not customized.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


ButtonIsHidden Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ButtonIsHidden Method
Button ID to check for being hidden.
Returns true if the specified toolbar button is hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ButtonIsHidden( _
   ByVal buttonId As ImGearRecZoneGUIType _
) As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim buttonId As ImGearRecZoneGUIType
Dim value As Boolean

value = instance.ButtonIsHidden(buttonId)
public bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)
public: bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)
public:
bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button ID to check for being hidden.

Return Value

true | The specified toolbar button is hidden.
false | The specified toolbar button is not hidden.
Remarks
This method returns true if the specified toolbar button is hidden.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


ClearAllZones Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ClearAllZones Method
Removes all zones from the recognition page associated with the ImGearRecZoneGUI object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ClearAllZones()
'Usage

Dim instance As ImGearRecZoneGUI

instance.ClearAllZones()
public void ClearAllZones()
public: void ClearAllZones();
public:
void ClearAllZones();
Remarks
This method removes all zones from the recognition page associated with the ImGearRecZoneGUI class object.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


CreateCustomButtonDialog Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : CreateCustomButtonDialog Method
Creates a custom button using the property sheet GUI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateCustomButtonDialog() As Integer
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As Integer

value = instance.CreateCustomButtonDialog()
public int CreateCustomButtonDialog()
public: int CreateCustomButtonDialog();
public:
int CreateCustomButtonDialog();

Return Value

Integer value.
Remarks
This method creates a custom button using the property sheet GUI.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


CreateRecGUIPage Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : CreateRecGUIPage Method
Creates a recognition GUI page from an existing recognition page, and optionally an ART page.
Overload List
Overload | Description
CreateRecGUIPage(ImGearRecPage,ImGearARTPage) | Creates a recognition GUI page from an existing recognition page, and optionally an ART page.
CreateRecGUIPage(ImGearRasterPage,ImGearARTPage) | Creates a recognition GUI page from an existing raster page, and optionally an ART page.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


CreateRecGUIPage(ImGearRecPage,ImGearARTPage) Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class > CreateRecGUIPage Method : CreateRecGUIPage(ImGearRecPage,ImGearARTPage) Method
Recognition page whose zones are to be edited/displayed.
Annotation page corresponding to the recognition page, or null if the application is not using ART with the recognition page.
Creates a recognition GUI page from an existing recognition page, and optionally an ART page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CreateRecGUIPage( _
   ByVal recognitionPage As ImGearRecPage, _
   ByVal annotationPage As ImGearARTPage _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim recognitionPage As ImGearRecPage
Dim annotationPage As ImGearARTPage

instance.CreateRecGUIPage(recognitionPage, annotationPage)
public void CreateRecGUIPage(
   ImGearRecPage recognitionPage,
   ImGearARTPage annotationPage
)
public: void CreateRecGUIPage(
   ImGearRecPage* recognitionPage,
   ImGearARTPage* annotationPage
)
public:
void CreateRecGUIPage(
   ImGearRecPage^ recognitionPage,
   ImGearARTPage^ annotationPage
)

Parameters

recognitionPage
Recognition page whose zones are to be edited/displayed.
annotationPage
Annotation page corresponding to the recognition page, or null if the application is not using ART with the recognition page.
Remarks
This method creates a recognition GUI page from an existing recognition page, and optionally an ART page. If an ART page is specified, it will be used for displaying and editing zones visually. Otherwise, an internally created ART page will be used.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
Overload List
ImGearRecPage Class
ImGearARTPage Class


CreateRecGUIPage(ImGearRasterPage,ImGearARTPage) Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class > CreateRecGUIPage Method : CreateRecGUIPage(ImGearRasterPage,ImGearARTPage) Method
Raster page to be imported into the recognition engine and recognition zone editor GUI.
Annotation page corresponding to the recognition page, or null if the application is not using ART with the recognition page.
Creates a recognition GUI page from an existing raster page, and optionally an ART page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CreateRecGUIPage( _
   ByVal page As ImGearRasterPage, _
   ByVal annotationPage As ImGearARTPage _
) As ImGearRecPage
'Usage

Dim instance As ImGearRecZoneGUI
Dim page As ImGearRasterPage
Dim annotationPage As ImGearARTPage
Dim value As ImGearRecPage

value = instance.CreateRecGUIPage(page, annotationPage)
public ImGearRecPage CreateRecGUIPage(
   ImGearRasterPage page,
   ImGearARTPage annotationPage
)
public: ImGearRecPage* CreateRecGUIPage(
   ImGearRasterPage* page,
   ImGearARTPage* annotationPage
)
public:
ImGearRecPage^ CreateRecGUIPage(
   ImGearRasterPage^ page,
   ImGearARTPage^ annotationPage
)

Parameters

page
Raster page to be imported into the recognition engine and recognition zone editor GUI.
annotationPage
Annotation page corresponding to the recognition page, or null if the application is not using ART with the recognition page.

Return Value

ImageGear.Recognition.ImGearRecPage class. Recognition page created from the raster page passed into the method. This page can be used for recognition tasks, or ignored if the application only needs to work with the zone editing GUI (and not also performing recognition, for example).
Remarks
This method creates a recognition GUI page from an existing raster page, and optionally an ART page. The raster page will be imported into the recognition engine and the resulting ImGearRecPage will be returned by this method. If an ART page is specified, it will be used for displaying and editing zones visually. Otherwise, an internally created ART page will be used.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
Overload List
ImGearRasterPage Class
ImGearARTPage Class
ImGearRecPage Class


CustomizeButtonDialog Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : CustomizeButtonDialog Method
ID of the button to be customized.
Opens a property sheet GUI which can be used to customize the specified button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CustomizeButtonDialog( _
   ByVal buttonId As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim buttonId As ImGearRecZoneGUIType

instance.CustomizeButtonDialog(buttonId)
public void CustomizeButtonDialog(
   ImGearRecZoneGUIType buttonId
)
public: void CustomizeButtonDialog(
   ImGearRecZoneGUIType buttonId
)
public:
void CustomizeButtonDialog(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
ID of the button to be customized.
Remarks
This method opens a property sheet GUI which can be used to customize the specified button.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


Dispose Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : Dispose Method
Frees all data associated with this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearRecZoneGUI

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This is a standard .NET Dispose method. It frees all data associated with this object.

It's not required for an application to call this method, since the .NET garbage collector will eventually dispose the object if no references to it exist anymore. However, in order to minimize memory usage, it is recommended for an application to call the Dispose method as soon as the object is no longer needed.

The application is responsible for not accessing any methods or properties of the object after having called its Dispose method.

See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


Finalize Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : Finalize Method
Finalizes an instance of the ImGearRecZoneGUI class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearRecZoneGUI

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


HideStandardButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : HideStandardButton Method
Button to be hidden.
Hides the specified standard toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HideStandardButton( _
   ByVal buttonId As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim buttonId As ImGearRecZoneGUIType

instance.HideStandardButton(buttonId)
public void HideStandardButton(
   ImGearRecZoneGUIType buttonId
)
public: void HideStandardButton(
   ImGearRecZoneGUIType buttonId
)
public:
void HideStandardButton(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button to be hidden.
Remarks
This method hides the specified standard toolbar button. The button will not be visible the next time the toolbar is shown.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


HideToolBar Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : HideToolBar Method
Hides the recognition zone editor toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HideToolBar()
'Usage

Dim instance As ImGearRecZoneGUI

instance.HideToolBar()
public void HideToolBar()
public: void HideToolBar();
public:
void HideToolBar();
Remarks
This method hides the recognition zone editor toolbar.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


HideUtilityButtons Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : HideUtilityButtons Method
Hides the utility buttons on the recognition zone editor toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HideUtilityButtons()
'Usage

Dim instance As ImGearRecZoneGUI

instance.HideUtilityButtons()
public void HideUtilityButtons()
public: void HideUtilityButtons();
public:
void HideUtilityButtons();
Remarks
This method hides the utility buttons on the recognition zone editor toolbar. These are the buttons which don't represent any particular zone types, but rather some actions that can be carried out directly from the toolbar. For example, automatically detect zones, import zones from a file, export zones to a file.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


HideZoneMarks Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : HideZoneMarks Method
Hides the zone marks which are used to indicate zone location, size, and type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HideZoneMarks()
'Usage

Dim instance As ImGearRecZoneGUI

instance.HideZoneMarks()
public void HideZoneMarks()
public: void HideZoneMarks();
public:
void HideZoneMarks();
Remarks
This method hides the zone marks which are used to indicate zone location, size, and type. The actual zones still exist, and their marks can be drawn again using the Refresh method.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


LoadCustomToolBar Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : LoadCustomToolBar Method
String value path specified.
Loads a customized toolbar previously saved to disk in XML format and makes it the current toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LoadCustomToolBar( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim path As String

instance.LoadCustomToolBar(path)
public void LoadCustomToolBar(
   string path
)
public: void LoadCustomToolBar(
   string* path
)
public:
void LoadCustomToolBar(
   String^ path
)

Parameters

path
String value path specified.
Remarks
This method loads a customized toolbar previously saved to disk in XML format and makes it the current toolbar. This file must have been created using the ImGearRecZoneGUI.SaveCustomToolBar method.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
SaveCustomToolBar Method


ModifyCustomButtonDialog Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ModifyCustomButtonDialog Method
Custom button ID.
Modifies custom button dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ModifyCustomButtonDialog( _
   ByVal customButtonId As Integer _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim customButtonId As Integer

instance.ModifyCustomButtonDialog(customButtonId)
public void ModifyCustomButtonDialog(
   int customButtonId
)
public: void ModifyCustomButtonDialog(
   int customButtonId
)
public:
void ModifyCustomButtonDialog(
   int customButtonId
)

Parameters

customButtonId
Custom button ID.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


MouseDown Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : MouseDown Method
Source of the event. Must be the same as what was passed to the original event handler.
Event parameters. Must be the same as what was passed to the original event handler.
Processes MouseDown events from the application in order to provide zone editor GUI functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseDown(sender, e)
public void MouseDown(
   object sender,
   MouseEventArgs e
)
public: void MouseDown(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseDown(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Source of the event. Must be the same as what was passed to the original event handler.
e
Event parameters. Must be the same as what was passed to the original event handler.
Remarks
This method processes MouseDown events from the application in order to provide zone editor GUI functionality. The application must relay MouseDown events received from the ImGearPageView object to the recognition zone editor GUI by passing them to this method.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


MouseMove Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : MouseMove Method
Source of the event. Must be the same as what was passed to the original event handler.
Event parameters. Must be the same as what was passed to the original event handler.
Processes MouseMove events from the application in order to provide zone editor GUI functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseMove(sender, e)
public void MouseMove(
   object sender,
   MouseEventArgs e
)
public: void MouseMove(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseMove(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Source of the event. Must be the same as what was passed to the original event handler.
e
Event parameters. Must be the same as what was passed to the original event handler.
Remarks
This method processes MouseMove events from the application in order to provide zone editor GUI functionality. The application must relay MouseMove events received from the ImGearPageView object to the recognition zone editor GUI by passing them to this method.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


MouseUp Method (ImGearRecZoneGUI)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : MouseUp Method
Source of the event. Must be the same as what was passed to the original event handler.
Event parameters. Must be the same as what was passed to the original event handler.
Processes MouseUp events from the application in order to provide zone editor GUI functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim sender As Object
Dim e As MouseEventArgs

instance.MouseUp(sender, e)
public void MouseUp(
   object sender,
   MouseEventArgs e
)
public: void MouseUp(
   Object* sender,
   MouseEventArgs* e
)
public:
void MouseUp(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
Source of the event. Must be the same as what was passed to the original event handler.
e
Event parameters. Must be the same as what was passed to the original event handler.
Remarks
This method processes MouseUp events from the application in order to provide zone editor GUI functionality. The application must relay MouseUp events received from the ImGearPageView object to the recognition zone editor GUI by passing them to this method.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


Refresh Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : Refresh Method
Updates the recognition zone editor GUI's collection of marks to match the zones currently defined by the recognition page and also draws the marks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Refresh()
'Usage

Dim instance As ImGearRecZoneGUI

instance.Refresh()
public void Refresh()
public: void Refresh();
public:
void Refresh();
Remarks
This method updates the recognition zone editor GUI's collection of marks to match the zones currently defined by the recognition page and also draws the marks. A zone mark is a shaded area overlaid over an image which represents the location, size, and type of a corresponding recognition zone. NOTE: This method does not need to be called in paint event handlers. Typically it's called after zones have been detected or manipulated via methods of the recognition page, rather than the recognition zone editor GUI.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


RevertToDefaultToolBar Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : RevertToDefaultToolBar Method
Clears all modifications to the recognition zone editor toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RevertToDefaultToolBar()
'Usage

Dim instance As ImGearRecZoneGUI

instance.RevertToDefaultToolBar()
public void RevertToDefaultToolBar()
public: void RevertToDefaultToolBar();
public:
void RevertToDefaultToolBar();
Remarks
This method clears all modifications to the recognition zone editor toolbar, returning it to a default set of zone type buttons and utility buttons.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


SaveCustomToolBar Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : SaveCustomToolBar Method
String value path specified.
Serializes a custom toolbar created within the ImGearRecZoneGUI class to XML and saves it to the path specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SaveCustomToolBar( _
   ByVal path As String _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim path As String

instance.SaveCustomToolBar(path)
public void SaveCustomToolBar(
   string path
)
public: void SaveCustomToolBar(
   string* path
)
public:
void SaveCustomToolBar(
   String^ path
)

Parameters

path
String value path specified.
Remarks
This method serializes a custom toolbar created within the ImGearRecZoneGUI class to XML and saves it to the path specified.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
LoadCustomToolBar Method


SetRecGUIZoneType Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : SetRecGUIZoneType Method
Type of zone to set for future zone creation operations.
Defines the attributes of the next zone created using the recognition zone editor GUI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetRecGUIZoneType( _
   ByVal zoneType As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim zoneType As ImGearRecZoneGUIType

instance.SetRecGUIZoneType(zoneType)
public void SetRecGUIZoneType(
   ImGearRecZoneGUIType zoneType
)
public: void SetRecGUIZoneType(
   ImGearRecZoneGUIType zoneType
)
public:
void SetRecGUIZoneType(
   ImGearRecZoneGUIType zoneType
)

Parameters

zoneType
Type of zone to set for future zone creation operations.
Remarks
This method defines the attributes of the next zone created using the recognition zone editor GUI. For example, if the recognition zone editor GUI is in edit mode and the user drags with the mouse to define a new zone, the new zone will be of the type specified by the last call to this method.

NOTE:

The user may interrupt this if the toolbar is visible by clicking one of the toolbar buttons to select a different zone type.

See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


ShowStandardButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ShowStandardButton Method
ID of the button to be shown.
Shows the specified standard toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowStandardButton( _
   ByVal buttonId As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUI
Dim buttonId As ImGearRecZoneGUIType

instance.ShowStandardButton(buttonId)
public void ShowStandardButton(
   ImGearRecZoneGUIType buttonId
)
public: void ShowStandardButton(
   ImGearRecZoneGUIType buttonId
)
public:
void ShowStandardButton(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
ID of the button to be shown.
Remarks
This method shows the specified standard toolbar button. The button will be visible the next time the toolbar is shown.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIType Enumeration


ShowToolBar Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ShowToolBar Method
Shows the recognition zone editor toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowToolBar()
'Usage

Dim instance As ImGearRecZoneGUI

instance.ShowToolBar()
public void ShowToolBar()
public: void ShowToolBar();
public:
void ShowToolBar();
Remarks
This method shows the recognition zone editor toolbar. The user can use this toolbar to select zones, specify the type of zone to create next, and perform some utility actions such as automatic detection of zones and import/export of the zone collection to a file.

NOTE:

If the toolbar is already visible, no action will be taken. To re-create the toolbar, call HideToolBar and then ShowToolBar.

See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


ShowUtilityButtons Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ShowUtilityButtons Method
Shows the utility buttons on the recognition zone editor toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowUtilityButtons()
'Usage

Dim instance As ImGearRecZoneGUI

instance.ShowUtilityButtons()
public void ShowUtilityButtons()
public: void ShowUtilityButtons();
public:
void ShowUtilityButtons();
Remarks
This method shows the utility buttons on the recognition zone editor toolbar. These are the buttons which don't represent any particular zone types, but rather some actions that can be carried out directly from the toolbar. For example, automatically detect zones, import zones from a file, export zones to a file.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


%%PageItemTitle%% $$Properties$$

ImGearRecZoneGUI Class Properties

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUI Class

For a list of all members of this type, see ImGearRecZoneGUI members.

Public Properties
 | Name | Description
Public Property | EditMode | Gets or sets edit mode used for zone editing GUI.
Public Property | SelectedButton | Gets or sets the selected button on the toolbar.
Public Property | ToolBarIsCustomized | Gets a value indicating whether or not the recognition zone editor toolbar is customized.
Public Property | ToolBarIsVisible | Gets a value indicating whether the toolbar is visible.
Public Property | ToolBarLicenseCheck | Gets or sets a value indicating whether or not currently licensed recognition modules will be taken into account in the appearance and behavior of the toolbar and property sheets.
Public Property | UtilityButtonsAreHidden | Gets a value indicating whether utility buttons on the recognition zone editor toolbar are hidden.
Top
See Also

Reference

ImGearRecZoneGUI Class
ImageGear.Recognition.Forms Namespace
ImageGear.Recognition Namespace


EditMode Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : EditMode Property
Gets or sets edit mode used for zone editing GUI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EditMode As ImGearRecZoneGUIEditMode
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As ImGearRecZoneGUIEditMode

instance.EditMode = value

value = instance.EditMode
public ImGearRecZoneGUIEditMode EditMode {get; set;}
public: __property ImGearRecZoneGUIEditMode get_EditMode();
public: __property void set_EditMode(
   ImGearRecZoneGUIEditMode value
);
public:
property ImGearRecZoneGUIEditMode EditMode {
   ImGearRecZoneGUIEditMode get();
   void set (    ImGearRecZoneGUIEditMode value);
}

Property Value

ImGearRecZoneGUIEditMode enumeration value.
Remarks
This property represents the edit mode used for zone editing GUI. In edit mode, zones can be created, moved, and resized with ease. In view mode, zones are locked into place and the GUI is disabled.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIEditMode Enumeration


SelectedButton Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : SelectedButton Property
Gets or sets the selected button on the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedButton As ImGearRecZoneGUIType
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As ImGearRecZoneGUIType

instance.SelectedButton = value

value = instance.SelectedButton
public ImGearRecZoneGUIType SelectedButton {get; set;}
public: __property ImGearRecZoneGUIType get_SelectedButton();
public: __property void set_SelectedButton(
   ImGearRecZoneGUIType value
);
public:
property ImGearRecZoneGUIType SelectedButton {
   ImGearRecZoneGUIType get();
   void set (    ImGearRecZoneGUIType value);
}

Property Value

ImGearRecZoneGUIEditMode enumeration value.
Remarks
This property represents the selected button on the toolbar. The selected button determines the behavior for mouse event processing, allowing existing zones to be selected or new zones to be created.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members
ImGearRecZoneGUIEditMode Enumeration


ToolBarIsCustomized Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ToolBarIsCustomized Property
Gets a value indicating whether or not the recognition zone editor toolbar is customized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ToolBarIsCustomized As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As Boolean

value = instance.ToolBarIsCustomized
public bool ToolBarIsCustomized {get;}
public: __property bool get_ToolBarIsCustomized();
public:
property bool ToolBarIsCustomized {
   bool get();
}

Property Value

True if toolbar has been customized, otherwise false.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


ToolBarIsVisible Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ToolBarIsVisible Property
Gets a value indicating whether the toolbar is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ToolBarIsVisible As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As Boolean

value = instance.ToolBarIsVisible
public bool ToolBarIsVisible {get;}
public: __property bool get_ToolBarIsVisible();
public:
property bool ToolBarIsVisible {
   bool get();
}

Property Value

Boolean value. True if the toolbar is visible.
Remarks
This property indicates whether or not the recognition zone editor toolbar is visible. To change the visibility of the toolbar, use the ShowToolBar and HideToolBar methods.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


ToolBarLicenseCheck Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : ToolBarLicenseCheck Property
Gets or sets a value indicating whether or not currently licensed recognition modules will be taken into account in the appearance and behavior of the toolbar and property sheets.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToolBarLicenseCheck As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As Boolean

instance.ToolBarLicenseCheck = value

value = instance.ToolBarLicenseCheck
public bool ToolBarLicenseCheck {get; set;}
public: __property bool get_ToolBarLicenseCheck();
public: __property void set_ToolBarLicenseCheck(
   bool value
);
public:
property bool ToolBarLicenseCheck {
   bool get();
   void set (    bool value);
}

Property Value

True if License check is enabled, otherwise false. Default is true.
Remarks
This property controls whether or not currently licensed recognition modules will be taken into account in the appearance and behavior of the toolbar and property sheets. When this property is set to true, built-in FillingMethods and RecognitionModules can be created and edited. Setting this property to false will allow the creation and editing of the full range of zone types but will not allow actual recognition using unlicensed modules.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


UtilityButtonsAreHidden Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUI Class : UtilityButtonsAreHidden Property
Gets a value indicating whether utility buttons on the recognition zone editor toolbar are hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UtilityButtonsAreHidden As Boolean
'Usage

Dim instance As ImGearRecZoneGUI
Dim value As Boolean

value = instance.UtilityButtonsAreHidden
public bool UtilityButtonsAreHidden {get;}
public: __property bool get_UtilityButtonsAreHidden();
public:
property bool UtilityButtonsAreHidden {
   bool get();
}

Property Value

Boolean value. True if the utility buttons on the toolbar are hidden.
Remarks
To change the visibility of the utility buttons, use the HideUtilityButtons and ShowUtilityButtons methods.
See Also

Reference

ImGearRecZoneGUI Class
ImGearRecZoneGUI Members


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParam Class
Members

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParam Class
Represents custom button parameters.
Object Model
ImGearRecZoneGUICustomBtnParam ClassImGearRGBQuad StructureImGearRecZone ClassImGearRecZone Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRecZoneGUICustomBtnParam
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
public class ImGearRecZoneGUICustomBtnParam
public __gc class ImGearRecZoneGUICustomBtnParam
public ref class ImGearRecZoneGUICustomBtnParam
Inheritance Hierarchy

System.Object
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam

See Also

Reference

ImGearRecZoneGUICustomBtnParam Members
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZoneGUICustomBtnParam Class Members
Properties Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParam Class

The following tables list the members exposed by ImGearRecZoneGUICustomBtnParam.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecZoneGUICustomBtnParam Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets botton background color.
Public Property | CustBttnIdx | Gets or sets custom button index.
Public Property | MatchFlags | Gets or sets zone matching flags.
Public Property | Opacity | Gets or sets opacity value.
Public Property | Text | Gets or sets button text.
Public Property | ZnModel | Gets or sets zone model.
Public Property | ZoneType | Gets or sets zone type.
Top
Public Methods
 | Name | Description
Public Method | AddMatchFlag | Adds zone matching flag.
Public Method | GetZoneModelClone | Returns a copy of the zone model.
Public Method | RemoveMatchFlag | Removes zone matching flag.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParam Constructor

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : ImGearRecZoneGUICustomBtnParam Constructor
Overload List
Overload | Description
ImGearRecZoneGUICustomBtnParam Constructor(String,ImGearRecFillingMethod,ImGearRecZoneType,ImGearRecRecognitionModule,ImGearRecFilter,ImGearRecZoneCheckingFlags,Int32,ImGearRGBQuad,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags) | Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
ImGearRecZoneGUICustomBtnParam Constructor(String,Int32,ImGearRGBQuad,ImGearRecZone,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags) | Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
ImGearRecZoneGUICustomBtnParam Constructor() | Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParam Constructor(String,ImGearRecFillingMethod,ImGearRecZoneType,ImGearRecRecognitionModule,ImGearRecFilter,ImGearRecZoneCheckingFlags,Int32,ImGearRGBQuad,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class > ImGearRecZoneGUICustomBtnParam Constructor : ImGearRecZoneGUICustomBtnParam Constructor(String,ImGearRecFillingMethod,ImGearRecZoneType,ImGearRecRecognitionModule,ImGearRecFilter,ImGearRecZoneCheckingFlags,Int32,ImGearRGBQuad,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags)
Button display name.
Zone filling method.
Zone type.
Recognition module.
Recognition filter.
Zone checking flags.
Opacity value.
Face color.
Zone GUI type.
Zone matching flags.
Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal buttonName As String, _
   ByVal fillMethod As ImGearRecFillingMethod, _
   ByVal zoneType As ImGearRecZoneType, _
   ByVal recognitionModule As ImGearRecRecognitionModule, _
   ByVal recognitionFilter As ImGearRecFilter, _
   ByVal checking As ImGearRecZoneCheckingFlags, _
   ByVal opacity As Integer, _
   ByVal faceColor As ImGearRGBQuad, _
   ByVal zoneGuiType As ImGearRecZoneGUIType, _
   ByVal zoneMatching As ImGearRecZoneGUIMatchingFlags _
)
'Usage

Dim buttonName As String
Dim fillMethod As ImGearRecFillingMethod
Dim zoneType As ImGearRecZoneType
Dim recognitionModule As ImGearRecRecognitionModule
Dim recognitionFilter As ImGearRecFilter
Dim checking As ImGearRecZoneCheckingFlags
Dim opacity As Integer
Dim faceColor As ImGearRGBQuad
Dim zoneGuiType As ImGearRecZoneGUIType
Dim zoneMatching As ImGearRecZoneGUIMatchingFlags

Dim instance As New ImGearRecZoneGUICustomBtnParam(buttonName, fillMethod, zoneType, recognitionModule, recognitionFilter, checking, opacity, faceColor, zoneGuiType, zoneMatching)
public ImGearRecZoneGUICustomBtnParam(
   string buttonName,
   ImGearRecFillingMethod fillMethod,
   ImGearRecZoneType zoneType,
   ImGearRecRecognitionModule recognitionModule,
   ImGearRecFilter recognitionFilter,
   ImGearRecZoneCheckingFlags checking,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZoneGUIType zoneGuiType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)
public: ImGearRecZoneGUICustomBtnParam(
   string* buttonName,
   ImGearRecFillingMethod fillMethod,
   ImGearRecZoneType zoneType,
   ImGearRecRecognitionModule recognitionModule,
   ImGearRecFilter recognitionFilter,
   ImGearRecZoneCheckingFlags checking,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZoneGUIType zoneGuiType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)
public:
ImGearRecZoneGUICustomBtnParam(
   String^ buttonName,
   ImGearRecFillingMethod fillMethod,
   ImGearRecZoneType zoneType,
   ImGearRecRecognitionModule recognitionModule,
   ImGearRecFilter recognitionFilter,
   ImGearRecZoneCheckingFlags checking,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZoneGUIType zoneGuiType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)

Parameters

buttonName
Button display name.
fillMethod
Zone filling method.
zoneType
Zone type.
recognitionModule
Recognition module.
recognitionFilter
Recognition filter.
checking
Zone checking flags.
opacity
Opacity value.
faceColor
Face color.
zoneGuiType
Zone GUI type.
zoneMatching
Zone matching flags.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members
Overload List


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParam Constructor(String,Int32,ImGearRGBQuad,ImGearRecZone,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class > ImGearRecZoneGUICustomBtnParam Constructor : ImGearRecZoneGUICustomBtnParam Constructor(String,Int32,ImGearRGBQuad,ImGearRecZone,ImGearRecZoneGUIType,ImGearRecZoneGUIMatchingFlags)
Button display name.
Opacity value.
Face color.
Zone model.
Zone type.
Zone matching flags.
Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal buttonName As String, _
   ByVal opacity As Integer, _
   ByVal faceColor As ImGearRGBQuad, _
   ByVal zoneModel As ImGearRecZone, _
   ByVal zoneType As ImGearRecZoneGUIType, _
   ByVal zoneMatching As ImGearRecZoneGUIMatchingFlags _
)
'Usage

Dim buttonName As String
Dim opacity As Integer
Dim faceColor As ImGearRGBQuad
Dim zoneModel As ImGearRecZone
Dim zoneType As ImGearRecZoneGUIType
Dim zoneMatching As ImGearRecZoneGUIMatchingFlags

Dim instance As New ImGearRecZoneGUICustomBtnParam(buttonName, opacity, faceColor, zoneModel, zoneType, zoneMatching)
public ImGearRecZoneGUICustomBtnParam(
   string buttonName,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZone zoneModel,
   ImGearRecZoneGUIType zoneType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)
public: ImGearRecZoneGUICustomBtnParam(
   string* buttonName,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZone* zoneModel,
   ImGearRecZoneGUIType zoneType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)
public:
ImGearRecZoneGUICustomBtnParam(
   String^ buttonName,
   int opacity,
   ImGearRGBQuad faceColor,
   ImGearRecZone^ zoneModel,
   ImGearRecZoneGUIType zoneType,
   ImGearRecZoneGUIMatchingFlags zoneMatching
)

Parameters

buttonName
Button display name.
opacity
Opacity value.
faceColor
Face color.
zoneModel
Zone model.
zoneType
Zone type.
zoneMatching
Zone matching flags.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members
Overload List


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParam Constructor()

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class > ImGearRecZoneGUICustomBtnParam Constructor : ImGearRecZoneGUICustomBtnParam Constructor()
Initializes a new instance of the ImGearRecZoneGUICustomBtnParam class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecZoneGUICustomBtnParam()
public ImGearRecZoneGUICustomBtnParam()
public: ImGearRecZoneGUICustomBtnParam();
public:
ImGearRecZoneGUICustomBtnParam();
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRecZoneGUICustomBtnParam Class Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParam Class

For a list of all members of this type, see ImGearRecZoneGUICustomBtnParam members.

Public Methods
 | Name | Description
Public Method | AddMatchFlag | Adds zone matching flag.
Public Method | GetZoneModelClone | Returns a copy of the zone model.
Public Method | RemoveMatchFlag | Removes zone matching flag.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImageGear.Recognition.Forms Namespace


AddMatchFlag Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : AddMatchFlag Method
Flag value to add.
Adds zone matching flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddMatchFlag( _
   ByVal zoneMatchingFlag As ImGearRecZoneGUIMatchingFlags _
)
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim zoneMatchingFlag As ImGearRecZoneGUIMatchingFlags

instance.AddMatchFlag(zoneMatchingFlag)
public void AddMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)
public: void AddMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)
public:
void AddMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)

Parameters

zoneMatchingFlag
Flag value to add.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


GetZoneModelClone Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : GetZoneModelClone Method
Returns a copy of the zone model.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetZoneModelClone() As ImGearRecZone
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As ImGearRecZone

value = instance.GetZoneModelClone()
public ImGearRecZone GetZoneModelClone()
public: ImGearRecZone* GetZoneModelClone();
public:
ImGearRecZone^ GetZoneModelClone();

Return Value

ImageGear.Recognition.ImGearRecZone value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


RemoveMatchFlag Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : RemoveMatchFlag Method
Flag value to remove.
Removes zone matching flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveMatchFlag( _
   ByVal zoneMatchingFlag As ImGearRecZoneGUIMatchingFlags _
)
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim zoneMatchingFlag As ImGearRecZoneGUIMatchingFlags

instance.RemoveMatchFlag(zoneMatchingFlag)
public void RemoveMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)
public: void RemoveMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)
public:
void RemoveMatchFlag(
   ImGearRecZoneGUIMatchingFlags zoneMatchingFlag
)

Parameters

zoneMatchingFlag
Flag value to remove.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


%%PageItemTitle%% $$Properties$$

ImGearRecZoneGUICustomBtnParam Class Properties

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParam Class

For a list of all members of this type, see ImGearRecZoneGUICustomBtnParam members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets botton background color.
Public Property | CustBttnIdx | Gets or sets custom button index.
Public Property | MatchFlags | Gets or sets zone matching flags.
Public Property | Opacity | Gets or sets opacity value.
Public Property | Text | Gets or sets button text.
Public Property | ZnModel | Gets or sets zone model.
Public Property | ZoneType | Gets or sets zone type.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImageGear.Recognition.Forms Namespace


BackColor Property (ImGearRecZoneGUICustomBtnParam)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : BackColor Property
Gets or sets botton background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As ImGearRGBQuad
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As ImGearRGBQuad

instance.BackColor = value

value = instance.BackColor
public ImGearRGBQuad BackColor {get; set;}
public: __property ImGearRGBQuad get_BackColor();
public: __property void set_BackColor(
   ImGearRGBQuad value
);
public:
property ImGearRGBQuad BackColor {
   ImGearRGBQuad get();
   void set (    ImGearRGBQuad value);
}

Property Value

ImageGear.Core.ImGearRGBQuad structure value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


CustBttnIdx Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : CustBttnIdx Property
Gets or sets custom button index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustBttnIdx As Integer
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As Integer

instance.CustBttnIdx = value

value = instance.CustBttnIdx
public int CustBttnIdx {get; set;}
public: __property int get_CustBttnIdx();
public: __property void set_CustBttnIdx(
   int value
);
public:
property int CustBttnIdx {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


MatchFlags Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : MatchFlags Property
Gets or sets zone matching flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MatchFlags As ImGearRecZoneGUIMatchingFlags
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As ImGearRecZoneGUIMatchingFlags

instance.MatchFlags = value

value = instance.MatchFlags
public ImGearRecZoneGUIMatchingFlags MatchFlags {get; set;}
public: __property ImGearRecZoneGUIMatchingFlags get_MatchFlags();
public: __property void set_MatchFlags(
   ImGearRecZoneGUIMatchingFlags value
);
public:
property ImGearRecZoneGUIMatchingFlags MatchFlags {
   ImGearRecZoneGUIMatchingFlags get();
   void set (    ImGearRecZoneGUIMatchingFlags value);
}

Property Value

ImGearRecZoneGUIMatchingFlags enumeration value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


Opacity Property (ImGearRecZoneGUICustomBtnParam)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : Opacity Property
Gets or sets opacity value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Integer
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As Integer

instance.Opacity = value

value = instance.Opacity
public int Opacity {get; set;}
public: __property int get_Opacity();
public: __property void set_Opacity(
   int value
);
public:
property int Opacity {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


Text Property (ImGearRecZoneGUICustomBtnParam)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : Text Property
Gets or sets button text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


ZnModel Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : ZnModel Property
Gets or sets zone model.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZnModel As ImGearRecZone
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As ImGearRecZone

instance.ZnModel = value

value = instance.ZnModel
public ImGearRecZone ZnModel {get; set;}
public: __property ImGearRecZone* get_ZnModel();
public: __property void set_ZnModel(
   ImGearRecZone* value
);
public:
property ImGearRecZone^ ZnModel {
   ImGearRecZone^ get();
   void set (    ImGearRecZone^ value);
}

Property Value

ImageGear.Recognition.ImGearRecZone class object.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


ZoneType Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParam Class : ZoneType Property
Gets or sets zone type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoneType As ImGearRecZoneGUIType
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParam
Dim value As ImGearRecZoneGUIType

instance.ZoneType = value

value = instance.ZoneType
public ImGearRecZoneGUIType ZoneType {get; set;}
public: __property ImGearRecZoneGUIType get_ZoneType();
public: __property void set_ZoneType(
   ImGearRecZoneGUIType value
);
public:
property ImGearRecZoneGUIType ZoneType {
   ImGearRecZoneGUIType get();
   void set (    ImGearRecZoneGUIType value);
}

Property Value

ImGearRecZoneGUIType enumeration value.
See Also

Reference

ImGearRecZoneGUICustomBtnParam Class
ImGearRecZoneGUICustomBtnParam Members


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParams Class
Members

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParams Class
Represents custom button parameters collection.
Object Model
ImGearRecZoneGUICustomBtnParams ClassImGearRecZoneGUICustomBtnParam Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<XmlIncludeAttribute(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam)>
<DefaultMemberAttribute("Item")>
Public Class ImGearRecZoneGUICustomBtnParams
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParams
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam)]
[DefaultMember("Item")]
public class ImGearRecZoneGUICustomBtnParams
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam)]
[DefaultMember("Item")]
public __gc class ImGearRecZoneGUICustomBtnParams
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParam)]
[DefaultMember("Item")]
public ref class ImGearRecZoneGUICustomBtnParams
Inheritance Hierarchy

System.Object
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams

See Also

Reference

ImGearRecZoneGUICustomBtnParams Members
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZoneGUICustomBtnParams Class Members
Properties Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParams Class

The following tables list the members exposed by ImGearRecZoneGUICustomBtnParams.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecZoneGUICustomBtnParams Constructor | Initializes a new instance of the ImGearRecZoneGUICustomBtnParams class.
Top
Public Properties
 | Name | Description
Public Property | Item | Provides access to a single ImGearRecZoneGUICustomBtnParam object within the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ImGearRecZoneGUICustomBtnParam object to the collection of parameters.
Public Method | Count | Returns the count of custom buttons.
Public Method | GetEnumerator | Returns enumerator for the collection.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%%

ImGearRecZoneGUICustomBtnParams Constructor

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParams Class : ImGearRecZoneGUICustomBtnParams Constructor
Initializes a new instance of the ImGearRecZoneGUICustomBtnParams class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecZoneGUICustomBtnParams()
public ImGearRecZoneGUICustomBtnParams()
public: ImGearRecZoneGUICustomBtnParams();
public:
ImGearRecZoneGUICustomBtnParams();
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImGearRecZoneGUICustomBtnParams Members


%%PageItemTitle%% $$Methods$$

ImGearRecZoneGUICustomBtnParams Class Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParams Class

For a list of all members of this type, see ImGearRecZoneGUICustomBtnParams members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ImGearRecZoneGUICustomBtnParam object to the collection of parameters.
Public Method | Count | Returns the count of custom buttons.
Public Method | GetEnumerator | Returns enumerator for the collection.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImageGear.Recognition.Forms Namespace


Add Method (ImGearRecZoneGUICustomBtnParams)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParams Class : Add Method
ImGearRecZoneGUICustomBtnParam object to add.
Adds a ImGearRecZoneGUICustomBtnParam object to the collection of parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal newParameter As Object _
) As Integer
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParams
Dim newParameter As Object
Dim value As Integer

value = instance.Add(newParameter)
public int Add(
   object newParameter
)
public: int Add(
   Object* newParameter
)
public:
int Add(
   Object^ newParameter
)

Parameters

newParameter
ImGearRecZoneGUICustomBtnParam object to add.

Return Value

Index of the newly added object in the collection.
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImGearRecZoneGUICustomBtnParams Members


Count Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParams Class : Count Method
Returns the count of custom buttons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Count() As Integer
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParams
Dim value As Integer

value = instance.Count()
public int Count()
public: int Count();
public:
int Count();

Return Value

Integer value.
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImGearRecZoneGUICustomBtnParams Members


GetEnumerator Method (ImGearRecZoneGUICustomBtnParams)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParams Class : GetEnumerator Method
Returns enumerator for the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParams
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();

Return Value

System.Collections.IEnumerator interface.
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImGearRecZoneGUICustomBtnParams Members


%%PageItemTitle%% $$Properties$$

ImGearRecZoneGUICustomBtnParams Class Properties

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomBtnParams Class

For a list of all members of this type, see ImGearRecZoneGUICustomBtnParams members.

Public Properties
 | Name | Description
Public Property | Item | Provides access to a single ImGearRecZoneGUICustomBtnParam object within the collection.
Top
See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImageGear.Recognition.Forms Namespace


Item Property (ImGearRecZoneGUICustomBtnParams)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomBtnParams Class : Item Property
Index of the object to access.
Provides access to a single ImGearRecZoneGUICustomBtnParam object within the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImGearRecZoneGUICustomBtnParam
'Usage

Dim instance As ImGearRecZoneGUICustomBtnParams
Dim index As Integer
Dim value As ImGearRecZoneGUICustomBtnParam

instance.Item(index) = value

value = instance.Item(index)
public ImGearRecZoneGUICustomBtnParam this[
   int index
]; {get; set;}
public: __property ImGearRecZoneGUICustomBtnParam* get_Item   int index
;
public: __property void set_Item   int index,
   ImGearRecZoneGUICustomBtnParam* value
;
public:
property ImGearRecZoneGUICustomBtnParam^ default [int] {
   ImGearRecZoneGUICustomBtnParam^ get(int index);
   void set (int index, ImGearRecZoneGUICustomBtnParam^ value);
}

Parameters

index
Index of the object to access.

Property Value

See Also

Reference

ImGearRecZoneGUICustomBtnParams Class
ImGearRecZoneGUICustomBtnParams Members


%%PageItemTitle%%

ImGearRecZoneGUICustomToolBar Class
Members

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomToolBar Class
Provides access to custom tool bar.
Object Model
ImGearRecZoneGUICustomToolBar ClassImGearRecZoneGUICustomBtnParams ClassImGearRecZoneGUICustomBtnParam ClassImGearRecZoneGUICustomBtnParams ClassImGearRecZoneGUICustomBtnParam ClassImGearRecZoneGUICustomBtnParam ClassImGearRecZoneGUICustomBtnParam Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<XmlIncludeAttribute(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams)>
Public NotInheritable Class ImGearRecZoneGUICustomToolBar
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams)]
public sealed class ImGearRecZoneGUICustomToolBar
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams)]
public __gc __sealed class ImGearRecZoneGUICustomToolBar
[XmlInclude(ImageGear.Recognition.Forms.ImGearRecZoneGUICustomBtnParams)]
public ref class ImGearRecZoneGUICustomToolBar sealed
Inheritance Hierarchy

System.Object
ImageGear.Recognition.Forms.ImGearRecZoneGUICustomToolBar

See Also

Reference

ImGearRecZoneGUICustomToolBar Members
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearRecZoneGUICustomToolBar Class Members
Properties Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomToolBar Class

The following tables list the members exposed by ImGearRecZoneGUICustomToolBar.

Public Constructors
 | Name | Description
Public Constructor | ImGearRecZoneGUICustomToolBar Constructor | Initializes a new instance of the ImGearRecZoneGUICustomToolBar class.
Top
Public Properties
 | Name | Description
Public Property | CustomButtons | Gets or sets custom button parameters.
Public Property | CustomizedButtonIDs | Gets or sets customized button identifiers.
Public Property | CustomizedButtons | Gets or sets customized button parameters.
Public Property | HiddenButtonIDs | Gets or sets hidden button identifiers.
Public Property | SaveByIGVersion | Gets or sets ImageGear version to be used for serialiation of the custom toolbar.
Public Property | UtilityButtonsHidden | Gets or sets a value indicating whether the utility buttons are hidden.
Top
Public Methods
 | Name | Description
Public Method | AddCustomButton | Adds a custom button to the toolbar.
Public Method | AddCustomizedButton | Adds a customized button to the toolbar.
Public Method | ButtonIsCustomized | Returns a boolean value specifying whether the button is customized.
Public Method | ButtonIsHidden | Returns a boolean value specifying whether the button is hidden.
Public Method | GetCustomButtonParam | Returns custom button parameters.
Public Method | GetCustomizedButtonParam | Returns customized button parameters.
Public Method | HideButton | Hides toolbar button.
Public Method | UnHideButton | Unhides toolbar button.
Top
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImageGear.Recognition.Forms Namespace


%%PageItemTitle%%

ImGearRecZoneGUICustomToolBar Constructor

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : ImGearRecZoneGUICustomToolBar Constructor
Initializes a new instance of the ImGearRecZoneGUICustomToolBar class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRecZoneGUICustomToolBar()
public ImGearRecZoneGUICustomToolBar()
public: ImGearRecZoneGUICustomToolBar();
public:
ImGearRecZoneGUICustomToolBar();
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


%%PageItemTitle%% $$Methods$$

ImGearRecZoneGUICustomToolBar Class Methods

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomToolBar Class

For a list of all members of this type, see ImGearRecZoneGUICustomToolBar members.

Public Methods
 | Name | Description
Public Method | AddCustomButton | Adds a custom button to the toolbar.
Public Method | AddCustomizedButton | Adds a customized button to the toolbar.
Public Method | ButtonIsCustomized | Returns a boolean value specifying whether the button is customized.
Public Method | ButtonIsHidden | Returns a boolean value specifying whether the button is hidden.
Public Method | GetCustomButtonParam | Returns custom button parameters.
Public Method | GetCustomizedButtonParam | Returns customized button parameters.
Public Method | HideButton | Hides toolbar button.
Public Method | UnHideButton | Unhides toolbar button.
Top
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImageGear.Recognition.Forms Namespace


AddCustomButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : AddCustomButton Method
Custom button parameters.
Adds a custom button to the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AddCustomButton( _
   ByVal buttonParameters As ImGearRecZoneGUICustomBtnParam _
) As Integer
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonParameters As ImGearRecZoneGUICustomBtnParam
Dim value As Integer

value = instance.AddCustomButton(buttonParameters)
public int AddCustomButton(
   ImGearRecZoneGUICustomBtnParam buttonParameters
)
public: int AddCustomButton(
   ImGearRecZoneGUICustomBtnParam* buttonParameters
)
public:
int AddCustomButton(
   ImGearRecZoneGUICustomBtnParam^ buttonParameters
)

Parameters

buttonParameters
Custom button parameters.

Return Value

Index of the newly added object in the collection.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


AddCustomizedButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : AddCustomizedButton Method
Custom button parameters.
Zone type identifier.
Custom button identifier.
Adds a customized button to the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddCustomizedButton( _
   ByVal buttonParameters As ImGearRecZoneGUICustomBtnParam, _
   ByVal zoneType As ImGearRecZoneGUIType, _
   ByVal buttonId As Integer _
)
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonParameters As ImGearRecZoneGUICustomBtnParam
Dim zoneType As ImGearRecZoneGUIType
Dim buttonId As Integer

instance.AddCustomizedButton(buttonParameters, zoneType, buttonId)
public void AddCustomizedButton(
   ImGearRecZoneGUICustomBtnParam buttonParameters,
   ImGearRecZoneGUIType zoneType,
   int buttonId
)
public: void AddCustomizedButton(
   ImGearRecZoneGUICustomBtnParam* buttonParameters,
   ImGearRecZoneGUIType zoneType,
   int buttonId
)
public:
void AddCustomizedButton(
   ImGearRecZoneGUICustomBtnParam^ buttonParameters,
   ImGearRecZoneGUIType zoneType,
   int buttonId
)

Parameters

buttonParameters
Custom button parameters.
zoneType
Zone type identifier.
buttonId
Custom button identifier.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


ButtonIsCustomized Method (ImGearRecZoneGUICustomToolBar)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : ButtonIsCustomized Method
Button identifier.
Returns a boolean value specifying whether the button is customized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ButtonIsCustomized( _
   ByVal buttonId As ImGearRecZoneGUIType _
) As Boolean
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonId As ImGearRecZoneGUIType
Dim value As Boolean

value = instance.ButtonIsCustomized(buttonId)
public bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)
public: bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)
public:
bool ButtonIsCustomized(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button identifier.

Return Value

True if the button is customized, false otherwise.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


ButtonIsHidden Method (ImGearRecZoneGUICustomToolBar)

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : ButtonIsHidden Method
Button identifier.
Returns a boolean value specifying whether the button is hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ButtonIsHidden( _
   ByVal buttonId As ImGearRecZoneGUIType _
) As Boolean
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonId As ImGearRecZoneGUIType
Dim value As Boolean

value = instance.ButtonIsHidden(buttonId)
public bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)
public: bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)
public:
bool ButtonIsHidden(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button identifier.

Return Value

True if the button is hidden, false otherwise.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


GetCustomButtonParam Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : GetCustomButtonParam Method
Custom button index.
Returns custom button parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCustomButtonParam( _
   ByVal index As Integer _
) As ImGearRecZoneGUICustomBtnParam
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim index As Integer
Dim value As ImGearRecZoneGUICustomBtnParam

value = instance.GetCustomButtonParam(index)
public ImGearRecZoneGUICustomBtnParam GetCustomButtonParam(
   int index
)
public: ImGearRecZoneGUICustomBtnParam* GetCustomButtonParam(
   int index
)
public:
ImGearRecZoneGUICustomBtnParam^ GetCustomButtonParam(
   int index
)

Parameters

index
Custom button index.

Return Value

ImGearRecZoneGUICustomBtnParam class object.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


GetCustomizedButtonParam Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : GetCustomizedButtonParam Method
Zone type identifier.
Returns customized button parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCustomizedButtonParam( _
   ByVal zoneType As ImGearRecZoneGUIType _
) As ImGearRecZoneGUICustomBtnParam
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim zoneType As ImGearRecZoneGUIType
Dim value As ImGearRecZoneGUICustomBtnParam

value = instance.GetCustomizedButtonParam(zoneType)
public ImGearRecZoneGUICustomBtnParam GetCustomizedButtonParam(
   ImGearRecZoneGUIType zoneType
)
public: ImGearRecZoneGUICustomBtnParam* GetCustomizedButtonParam(
   ImGearRecZoneGUIType zoneType
)
public:
ImGearRecZoneGUICustomBtnParam^ GetCustomizedButtonParam(
   ImGearRecZoneGUIType zoneType
)

Parameters

zoneType
Zone type identifier.

Return Value

ImGearRecZoneGUICustomBtnParam class object.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


HideButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : HideButton Method
Button identifier.
Hides toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HideButton( _
   ByVal buttonId As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonId As ImGearRecZoneGUIType

instance.HideButton(buttonId)
public void HideButton(
   ImGearRecZoneGUIType buttonId
)
public: void HideButton(
   ImGearRecZoneGUIType buttonId
)
public:
void HideButton(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button identifier.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


UnHideButton Method

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : UnHideButton Method
Button identifier.
Unhides toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UnHideButton( _
   ByVal buttonId As ImGearRecZoneGUIType _
)
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim buttonId As ImGearRecZoneGUIType

instance.UnHideButton(buttonId)
public void UnHideButton(
   ImGearRecZoneGUIType buttonId
)
public: void UnHideButton(
   ImGearRecZoneGUIType buttonId
)
public:
void UnHideButton(
   ImGearRecZoneGUIType buttonId
)

Parameters

buttonId
Button identifier.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


%%PageItemTitle%% $$Properties$$

ImGearRecZoneGUICustomToolBar Class Properties

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUICustomToolBar Class

For a list of all members of this type, see ImGearRecZoneGUICustomToolBar members.

Public Properties
 | Name | Description
Public Property | CustomButtons | Gets or sets custom button parameters.
Public Property | CustomizedButtonIDs | Gets or sets customized button identifiers.
Public Property | CustomizedButtons | Gets or sets customized button parameters.
Public Property | HiddenButtonIDs | Gets or sets hidden button identifiers.
Public Property | SaveByIGVersion | Gets or sets ImageGear version to be used for serialiation of the custom toolbar.
Public Property | UtilityButtonsHidden | Gets or sets a value indicating whether the utility buttons are hidden.
Top
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImageGear.Recognition.Forms Namespace


CustomButtons Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : CustomButtons Property
Gets or sets custom button parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomButtons As ImGearRecZoneGUICustomBtnParams
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As ImGearRecZoneGUICustomBtnParams

instance.CustomButtons = value

value = instance.CustomButtons
public ImGearRecZoneGUICustomBtnParams CustomButtons {get; set;}
public: __property ImGearRecZoneGUICustomBtnParams* get_CustomButtons();
public: __property void set_CustomButtons(
   ImGearRecZoneGUICustomBtnParams* value
);
public:
property ImGearRecZoneGUICustomBtnParams^ CustomButtons {
   ImGearRecZoneGUICustomBtnParams^ get();
   void set (    ImGearRecZoneGUICustomBtnParams^ value);
}

Property Value

ImGearRecZoneGUICustomBtnParams class object.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


CustomizedButtonIDs Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : CustomizedButtonIDs Property
Gets or sets customized button identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomizedButtonIDs As ImGearRecZoneGUIType
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As ImGearRecZoneGUIType

instance.CustomizedButtonIDs = value

value = instance.CustomizedButtonIDs
public ImGearRecZoneGUIType CustomizedButtonIDs {get; set;}
public: __property ImGearRecZoneGUIType get_CustomizedButtonIDs();
public: __property void set_CustomizedButtonIDs(
   ImGearRecZoneGUIType value
);
public:
property ImGearRecZoneGUIType CustomizedButtonIDs {
   ImGearRecZoneGUIType get();
   void set (    ImGearRecZoneGUIType value);
}

Property Value

ImGearRecZoneGUIType enumeration value.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


CustomizedButtons Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : CustomizedButtons Property
Gets or sets customized button parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomizedButtons As ImGearRecZoneGUICustomBtnParams
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As ImGearRecZoneGUICustomBtnParams

instance.CustomizedButtons = value

value = instance.CustomizedButtons
public ImGearRecZoneGUICustomBtnParams CustomizedButtons {get; set;}
public: __property ImGearRecZoneGUICustomBtnParams* get_CustomizedButtons();
public: __property void set_CustomizedButtons(
   ImGearRecZoneGUICustomBtnParams* value
);
public:
property ImGearRecZoneGUICustomBtnParams^ CustomizedButtons {
   ImGearRecZoneGUICustomBtnParams^ get();
   void set (    ImGearRecZoneGUICustomBtnParams^ value);
}

Property Value

ImGearRecZoneGUICustomBtnParams class object.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


HiddenButtonIDs Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : HiddenButtonIDs Property
Gets or sets hidden button identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HiddenButtonIDs As ImGearRecZoneGUIType
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As ImGearRecZoneGUIType

instance.HiddenButtonIDs = value

value = instance.HiddenButtonIDs
public ImGearRecZoneGUIType HiddenButtonIDs {get; set;}
public: __property ImGearRecZoneGUIType get_HiddenButtonIDs();
public: __property void set_HiddenButtonIDs(
   ImGearRecZoneGUIType value
);
public:
property ImGearRecZoneGUIType HiddenButtonIDs {
   ImGearRecZoneGUIType get();
   void set (    ImGearRecZoneGUIType value);
}

Property Value

ImGearRecZoneGUIType enumeration value.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


SaveByIGVersion Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : SaveByIGVersion Property
Gets or sets ImageGear version to be used for serialiation of the custom toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SaveByIGVersion As String
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As String

instance.SaveByIGVersion = value

value = instance.SaveByIGVersion
public string SaveByIGVersion {get; set;}
public: __property string* get_SaveByIGVersion();
public: __property void set_SaveByIGVersion(
   string* value
);
public:
property String^ SaveByIGVersion {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


UtilityButtonsHidden Property

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace > ImGearRecZoneGUICustomToolBar Class : UtilityButtonsHidden Property
Gets or sets a value indicating whether the utility buttons are hidden.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UtilityButtonsHidden As Boolean
'Usage

Dim instance As ImGearRecZoneGUICustomToolBar
Dim value As Boolean

instance.UtilityButtonsHidden = value

value = instance.UtilityButtonsHidden
public bool UtilityButtonsHidden {get; set;}
public: __property bool get_UtilityButtonsHidden();
public: __property void set_UtilityButtonsHidden(
   bool value
);
public:
property bool UtilityButtonsHidden {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearRecZoneGUICustomToolBar Class
ImGearRecZoneGUICustomToolBar Members


%%PageItemTitle%%

ImGearRecZoneGUIEditMode Enumeration

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUIEditMode Enumeration
Specifies the edit mode used for zone editing GUI.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearRecZoneGUIEditMode
   Inherits System.Enum
'Usage

Dim instance As ImGearRecZoneGUIEditMode
public enum ImGearRecZoneGUIEditMode : System.Enum
__value public enum ImGearRecZoneGUIEditMode : public System.Enum
public enum class ImGearRecZoneGUIEditMode : public System.Enum
Members
Member | Value | Description
EDIT | 0 | Zones can be created, moved, and resized with ease. Mouse events are processed.
VIEW | 1 | Zones are locked into place and the GUI is disabled. Mouse events are not processed.
Remarks
This enumeration specifies the edit mode used for zone editing GUI.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.Forms.ImGearRecZoneGUIEditMode

See Also

Reference

ImageGear.Recognition.Forms Namespace


%%PageItemTitle%%

ImGearRecZoneGUIMatchingFlags Enumeration

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUIMatchingFlags Enumeration
Specifies flags used to describe which types of zones should match a custom zone editor toolbar button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearRecZoneGUIMatchingFlags
   Inherits System.Enum
'Usage

Dim instance As ImGearRecZoneGUIMatchingFlags
[Flags()]
public enum ImGearRecZoneGUIMatchingFlags : System.Enum
[Flags()]
__value public enum ImGearRecZoneGUIMatchingFlags : public System.Enum
[Flags()]
public enum class ImGearRecZoneGUIMatchingFlags : public System.Enum
Members
Member | Value | Description
CHECKINGFLAGS | 16 | Match by checking flags.
FILLINGMETHOD | 1 | Match by recognition filling method.
FILTER | 8 | Match by filter.
MATCH_ALL | 31 | Match all zones.
RECMODULE | 2 | Match by recognition module.
ZONETYPE | 4 | Match by zone type.
Remarks
This enumeration specifies flags used to describe which types of zones should match a custom zone editor toolbar button.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.Forms.ImGearRecZoneGUIMatchingFlags

See Also

Reference

ImageGear.Recognition.Forms Namespace


%%PageItemTitle%%

ImGearRecZoneGUIType Enumeration

ImageGear22.Recognition.Forms Assembly > ImageGear.Recognition.Forms Namespace : ImGearRecZoneGUIType Enumeration
Zone type used for zone editor toolbar buttons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImGearRecZoneGUIType
   Inherits System.Enum
'Usage

Dim instance As ImGearRecZoneGUIType
[Flags()]
public enum ImGearRecZoneGUIType : System.Enum
[Flags()]
__value public enum ImGearRecZoneGUIType : public System.Enum
[Flags()]
public enum class ImGearRecZoneGUIType : public System.Enum
Members
Member | Value | Description
CUSTOM | 128 | Custom zone type.
NONE | 1 | No zone types.
NULL | 0 | Zone type is undefined. Do not use this value.
OCR | 2 | OCR zone type.
OCR_ASIAN | 4 | Asian OCR zone type.
SELECT | 256 | Not actually a zone type, but a type of toolbar button used to access a "select mode" for selecting and editing zones.
Remarks
Each preset zone type represents a commonly used combination of zone parameters. There is also a custom zone type for user-defined zone types.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Recognition.Forms.ImGearRecZoneGUIType

See Also

Reference

ImageGear.Recognition.Forms Namespace


ImageGear22.Twain Assembly
Namespaces
Namespace | Description
ImageGear.TWAIN | The ImageGear TWAIN namespace allows you to control any scanner, digital camera or capture card that has a TWAIN device driver.


ImageGear.TWAIN Namespace
Inheritance Hierarchy
ImageGear22.Twain Assembly : ImageGear.TWAIN Namespace

The ImageGear TWAIN namespace allows you to control any scanner, digital camera or capture card that has a TWAIN device driver.

Classes
 | Class | Description
Class | ImGearCap | This is a base class for the capability classes.
Class | ImGearCapArray | This class describes a capability whose value resides in ImGearContainerType.ARRAY container.
Class | ImGearCapEnumeration | This class describes a capability whose value resides in an ImGearContainerType.ENUMERATION container.
Class | ImGearCapOneValue | This class describes a capability whose value resides in ImGearContainerType.ONEVALUE container.
Class | ImGearCapRange | This class describes a capability whose value resides in ImGearContainerType.RANGE container.
Class | ImGearDataSources | This class holds information about TWAIN data sources.
Class | ImGearFileInfo | This class holds information about TWAIN file system.
Class | ImGearTWAIN | Core TWAIN class.
Class | ImGearTWAINAfterPageEventArgs | Contains arguments for the ImGearTWAIN.AfterPage event.
Class | ImGearTWAINBeforePageEventArgs | Contains arguments for the ImGearTWAIN.BeforePage event.
Delegates
 | Delegate | Description
Delegate | ImGearTWAINAfterPageEventHandler | This is the delegate used to pass ImGearTWAIN.AfterPage events on to an application event handler.
Delegate | ImGearTWAINBeforePageEventHandler | This is the delegate used to pass ImGearTWAIN.BeforePage events on to an application event handler.
Enumerations
 | Enumeration | Description
Enumeration | ImGearAlarms | This enumeration determines specific audible alarms.
Enumeration | ImGearAudioFormats | This enumeration determines which Audio file formats are supported.
Enumeration | ImGearBarcodeRotation | The bar code's orientation on the scanned image.
Enumeration | ImGearBarcodeSearchModes | This enumeration restricts barcode searching to certain orientations, or prioritizes one orientation over the other.
Enumeration | ImGearBarcodeType | This enumeration lists different bar code types.
Enumeration | ImGearBitDepthReduction | This enumeration specifies the Reduction method the Source should use to reduce the bit depth of the data.
Enumeration | ImGearBitOrder | This enumeration specifies how the bytes in an image are filled by the Source.
Enumeration | ImGearCapabilities | Supported capabilities.
Enumeration | ImGearClearBuffers | This enumeration determines the type of buffer clearing process.
Enumeration | ImGearColorDataFormats | This enumeration allows the application and Source to identify which color data formats are available.
Enumeration | ImGearContainerType | Capability container type. Defines how the data for a capability is stored.
Enumeration | ImGearCountries | Country constants.
Enumeration | ImGearDeskewStatus | Status of the deskew operation.
Enumeration | ImGearDeviceEvents | This enumeration determines the device event.
Enumeration | ImGearDuplex | This enumeration determines whether the scanner supports duplex.
Enumeration | ImGearFeederAlignment | This enumeration determines which special actions application may need to take when negotiating frames with the Source.
Enumeration | ImGearFeederOrder | This enumeration determines the order of scanning.
Enumeration | ImGearFileSystem | This enumeration is for an undocumented TWAIN 1.8 capability.
Enumeration | ImGearFileType | File types in the device's file system.
Enumeration | ImGearFilterType | This enumeration determines the color characteristic of the subtractive filter applied to the image data.
Enumeration | ImGearFlashUsed | This enumeration determines which flash the image was acquired to use.
Enumeration | ImGearFlipRotation | This enumeration determines the orientation of images that flip orientation of every other image.
Enumeration | ImGearImageFilter | This enumeration determines the algorithm used to improve the quality of the image.
Enumeration | ImGearJobControl | This enumeration determines how the job can be processed.
Enumeration | ImGearJPEGQuality | This enumeration specifies the kind of JPEG quantization tables that tradeoff quality versus compressed image size.
Enumeration | ImGearLanguages | Language constants.
Enumeration | ImGearLightPath | This enumeration determines whether the image is captured transmissively or reflectively.
Enumeration | ImGearLightSource | This enumeration determines the general color characteristic of the light source used to acquire the image.
Enumeration | ImGearMessages | Capability control messages.
Enumeration | ImGearNoiseFilter | This enumeration selects the algorithm used to remove noise.
Enumeration | ImGearOrientation | This enumeration determines which edge of the paper the image's top is aligned with.
Enumeration | ImGearOverscanModes | This enumeration determines the overscanning mode.
Enumeration | ImGearPatchCode | This enumeration lists different patch code types.
Enumeration | ImGearPixelFlavor | This enumeration correctly describes the sense of the pixel whose numeric value is zero (minimum data value).
Enumeration | ImGearPixelType | This enumeration specifies the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).
Enumeration | ImGearPowerSupply | This enumeration reports the kinds of power available to the device.
Enumeration | ImGearPrinter | This enumeration determines the printer devices being used by application.
Enumeration | ImGearPrinterModes | This enumeration specifies current printer mode.
Enumeration | ImGearSupportedSizes | This enumeration specifies the size(s) the Source can/should use to acquire image data.
Enumeration | ImGearUnits | This enumeration determines the unit of measure for all quantities.
Enumeration | ImGearXferType | This enumeration determines which type of transfer mechanisms the application and Source have in common.
See Also

Reference

ImageGear22.Twain Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.TWAIN Namespace Inheritance Hierarchy
ImageGear22.Twain Assembly : ImageGear.TWAIN Namespace
Inheritance Hierarchy
System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapArray
ImageGear.TWAIN.ImGearCapEnumeration
ImageGear.TWAIN.ImGearCapOneValue
ImageGear.TWAIN.ImGearCapRange
ImageGear.TWAIN.ImGearDataSources
ImageGear.TWAIN.ImGearFileInfo
ImageGear.TWAIN.ImGearTWAIN
System.EventArgs
ImageGear.TWAIN.ImGearTWAINAfterPageEventArgs
ImageGear.TWAIN.ImGearTWAINBeforePageEventArgs
See Also

Reference

ImageGear22.Twain Assembly


%%PageItemTitle%%

ImGearCap Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCap Class
This is a base class for the capability classes.
Object Model
ImGearCap Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearCap
'Usage

Dim instance As ImGearCap
public abstract class ImGearCap
public __gc abstract class ImGearCap
public ref class ImGearCap abstract
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapArray
ImageGear.TWAIN.ImGearCapOneValue
ImageGear.TWAIN.ImGearCapRange

See Also

Reference

ImGearCap Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearCap Class Members
Properties Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCap Class

The following tables list the members exposed by ImGearCap.

Public Properties
 | Name | Description
Public Property | ContainerType | Gets the container type of the capability.
Public Property | ID | Gets or sets the identifier of the capability.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Releases resources used by the class.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearCap class. Diposes of unmanaged resources if they were not already disposed.
Top
See Also

Reference

ImGearCap Class
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Methods$$

ImGearCap Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCap Class

For a list of all members of this type, see ImGearCap members.

Public Methods
 | Name | Description
Public Method | Dispose | Releases resources used by the class.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearCap class. Diposes of unmanaged resources if they were not already disposed.
Top
See Also

Reference

ImGearCap Class
ImageGear.TWAIN Namespace


Dispose Method (ImGearCap)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCap Class : Dispose Method
Releases resources used by the class.
Overload List
Overload | Description
Dispose | Releases resources used by the class.
See Also

Reference

ImGearCap Class
ImGearCap Members


Dispose() Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCap Class : Dispose() Method
Releases resources used by the class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearCap

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearCap Class
ImGearCap Members


Finalize Method (ImGearCap)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCap Class : Finalize Method
Finalizes an instance of the ImGearCap class. Diposes of unmanaged resources if they were not already disposed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearCap

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearCap Class
ImGearCap Members


%%PageItemTitle%% $$Properties$$

ImGearCap Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCap Class

For a list of all members of this type, see ImGearCap members.

Public Properties
 | Name | Description
Public Property | ContainerType | Gets the container type of the capability.
Public Property | ID | Gets or sets the identifier of the capability.
Top
See Also

Reference

ImGearCap Class
ImageGear.TWAIN Namespace


ContainerType Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCap Class : ContainerType Property
Gets the container type of the capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContainerType As ImGearContainerType
'Usage

Dim instance As ImGearCap
Dim value As ImGearContainerType

value = instance.ContainerType
public ImGearContainerType ContainerType {get;}
public: __property ImGearContainerType get_ContainerType();
public:
property ImGearContainerType ContainerType {
   ImGearContainerType get();
}

Property Value

ImGearContainerType enumeration value.
See Also

Reference

ImGearCap Class
ImGearCap Members


ID Property (ImGearCap)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCap Class : ID Property
Gets or sets the identifier of the capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ID As ImGearCapabilities
'Usage

Dim instance As ImGearCap
Dim value As ImGearCapabilities

instance.ID = value

value = instance.ID
public ImGearCapabilities ID {get; set;}
public: __property ImGearCapabilities get_ID();
public: __property void set_ID(
   ImGearCapabilities value
);
public:
property ImGearCapabilities ID {
   ImGearCapabilities get();
   void set (    ImGearCapabilities value);
}

Property Value

ImGearCapabilities enumeration value.
See Also

Reference

ImGearCap Class
ImGearCap Members


%%PageItemTitle%%

ImGearCapArray Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapArray Class
This class describes a capability whose value resides in ImGearContainerType.ARRAY container.
Object Model
ImGearCapArray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearCapArray
   Inherits ImGearCap
'Usage

Dim instance As ImGearCapArray
[DefaultMember("Item")]
public class ImGearCapArray : ImGearCap
[DefaultMember("Item")]
public __gc class ImGearCapArray : public ImGearCap
[DefaultMember("Item")]
public ref class ImGearCapArray : public ImGearCap
Remarks
This class inherits ImGearCap class.
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapArray
ImageGear.TWAIN.ImGearCapEnumeration

See Also

Reference

ImGearCapArray Members
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%% $$Members$$

ImGearCapArray Class Members
Properties Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapArray Class

The following tables list the members exposed by ImGearCapArray.

Public Constructors
 | Name | Description
Public Constructor | ImGearCapArray Constructor | Initializes a new instance of the ImGearCapArray class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements in the array.
Public Property | Item | Gets or sets an element in the array at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | This method adds an object to the end of the array.
Public Method | Clear | This method removes all elements from the array.
Top
See Also

Reference

ImGearCapArray Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapArray Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : ImGearCapArray Constructor
An ImGearCapabilities value, which identifies the capability that this class will represent.
Initializes a new instance of the ImGearCapArray class.
Initializes a new instance of the ImGearCapArray class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal capabilityId As ImGearCapabilities _
)
'Usage

Dim capabilityId As ImGearCapabilities

Dim instance As New ImGearCapArray(capabilityId)
public ImGearCapArray(
   ImGearCapabilities capabilityId
)
public: ImGearCapArray(
   ImGearCapabilities capabilityId
)
public:
ImGearCapArray(
   ImGearCapabilities capabilityId
)

Parameters

capabilityId
An ImGearCapabilities value, which identifies the capability that this class will represent.

Return Value

The new instance of ImGearCapArray class.
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members
ImGearCapabilities Enumeration


%%PageItemTitle%% $$Methods$$

ImGearCapArray Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapArray Class

For a list of all members of this type, see ImGearCapArray members.

Public Methods
 | Name | Description
Public Method | Add | This method adds an object to the end of the array.
Public Method | Clear | This method removes all elements from the array.
Top
See Also

Reference

ImGearCapArray Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapArray Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : ImGearCapArray Constructor
Initializes a new instance of the ImGearCapArray class.
Overload List
Overload | Description
ImGearCapArray Constructor | Initializes a new instance of the ImGearCapArray class.
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members


Add Method (ImGearCapArray)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : Add Method
The capability value to be added to the end of the array.
This method adds an object to the end of the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal value As Object _
)
'Usage

Dim instance As ImGearCapArray
Dim value As Object

instance.Add(value)
public void Add(
   object value
)
public: void Add(
   Object* value
)
public:
void Add(
   Object^ value
)

Parameters

value
The capability value to be added to the end of the array.
Remarks
The Value parameter can be of the following types:
  • System.Boolean
  • System.Double
  • System.Int64
  • System.String
  • ImageGear.Core.ImageGear.Core.ImGearDoubleRectangle structure
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members
ImGearDoubleRectangle Structure


Clear Method (ImGearCapArray)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : Clear Method
This method removes all elements from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearCapArray

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members


%%PageItemTitle%% $$Properties$$

ImGearCapArray Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapArray Class

For a list of all members of this type, see ImGearCapArray members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements in the array.
Public Property | Item | Gets or sets an element in the array at the specified index.
Top
See Also

Reference

ImGearCapArray Class
ImageGear.TWAIN Namespace
ImGearCap Class


Count Property (ImGearCapArray)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : Count Property
Gets the number of elements in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearCapArray
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members


Item Property (ImGearCapArray)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapArray Class : Item Property
Index of element to access.
Gets or sets an element in the array at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Object
'Usage

Dim instance As ImGearCapArray
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
public object this[
   int index
]; {get; set;}
public: __property Object* get_Item   int index
;
public: __property void set_Item   int index,
   Object* value
;
public:
property Object^ default [int] {
   Object^ get(int index);
   void set (int index, Object^ value);
}

Parameters

index
Index of element to access.

Property Value

One of the following types:
  • System.Boolean
  • System.Double
  • System.Int64
  • System.String
  • ImageGear.Core.ImGearDoubleRectangle structure.
See Also

Reference

ImGearCapArray Class
ImGearCapArray Members


%%PageItemTitle%%

ImGearCapEnumeration Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapEnumeration Class
This class describes a capability whose value resides in an ImGearContainerType.ENUMERATION container.
Object Model
ImGearCapEnumeration Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCapEnumeration
   Inherits ImGearCapArray
'Usage

Dim instance As ImGearCapEnumeration
public sealed class ImGearCapEnumeration : ImGearCapArray
public __gc __sealed class ImGearCapEnumeration : public ImGearCapArray
public ref class ImGearCapEnumeration sealed : public ImGearCapArray
Remarks
This class inherits the ImGearCapArray class.
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapArray
ImageGear.TWAIN.ImGearCapEnumeration

See Also

Reference

ImGearCapEnumeration Members
ImageGear.TWAIN Namespace
ImGearCapArray Class


%%PageItemTitle%% $$Members$$

ImGearCapEnumeration Class Members
Properties Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapEnumeration Class

The following tables list the members exposed by ImGearCapEnumeration.

Public Constructors
 | Name | Description
Public Constructor | ImGearCapEnumeration Constructor | Initializes a new instance of the ImGearCapEnumeration class.
Top
Public Properties
 | Name | Description
Public Property | CurrentValueIndex | Gets or sets the index in the array of the current value.
Public Property | DefaultValueIndex | Gets or sets the index in the array of the default value.
Top
See Also

Reference

ImGearCapEnumeration Class
ImageGear.TWAIN Namespace
ImGearCapArray Class


%%PageItemTitle%%

ImGearCapEnumeration Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapEnumeration Class : ImGearCapEnumeration Constructor
An ImGearCapabilities value, which identifies the capability that this class will represent.
Initializes a new instance of the ImGearCapEnumeration class.
Initializes a new instance of the ImGearCapEnumeration class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal capabilityId As ImGearCapabilities _
)
'Usage

Dim capabilityId As ImGearCapabilities

Dim instance As New ImGearCapEnumeration(capabilityId)
public ImGearCapEnumeration(
   ImGearCapabilities capabilityId
)
public: ImGearCapEnumeration(
   ImGearCapabilities capabilityId
)
public:
ImGearCapEnumeration(
   ImGearCapabilities capabilityId
)

Parameters

capabilityId
An ImGearCapabilities value, which identifies the capability that this class will represent.

Return Value

The new instance of ImGearCapEnumeration class.
See Also

Reference

ImGearCapEnumeration Class
ImGearCapEnumeration Members
ImGearCapabilities Enumeration


%%PageItemTitle%% $$Properties$$

ImGearCapEnumeration Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapEnumeration Class

For a list of all members of this type, see ImGearCapEnumeration members.

Public Properties
 | Name | Description
Public Property | CurrentValueIndex | Gets or sets the index in the array of the current value.
Public Property | DefaultValueIndex | Gets or sets the index in the array of the default value.
Top
See Also

Reference

ImGearCapEnumeration Class
ImageGear.TWAIN Namespace
ImGearCapArray Class


%%PageItemTitle%% $$Methods$$

ImGearCapEnumeration Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapEnumeration Class

For a list of all members of this type, see ImGearCapEnumeration members.

See Also

Reference

ImGearCapEnumeration Class
ImageGear.TWAIN Namespace
ImGearCapArray Class


%%PageItemTitle%%

ImGearCapEnumeration Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapEnumeration Class : ImGearCapEnumeration Constructor
Initializes a new instance of the ImGearCapEnumeration class.
Overload List
Overload | Description
ImGearCapEnumeration Constructor | Initializes a new instance of the ImGearCapEnumeration class.
See Also

Reference

ImGearCapEnumeration Class
ImGearCapEnumeration Members


CurrentValueIndex Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapEnumeration Class : CurrentValueIndex Property
Gets or sets the index in the array of the current value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CurrentValueIndex As Integer
'Usage

Dim instance As ImGearCapEnumeration
Dim value As Integer

instance.CurrentValueIndex = value

value = instance.CurrentValueIndex
public int CurrentValueIndex {get; set;}
public: __property int get_CurrentValueIndex();
public: __property void set_CurrentValueIndex(
   int value
);
public:
property int CurrentValueIndex {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Value should be in the 0...Count range.
See Also

Reference

ImGearCapEnumeration Class
ImGearCapEnumeration Members


DefaultValueIndex Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapEnumeration Class : DefaultValueIndex Property
Gets or sets the index in the array of the default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValueIndex As Integer
'Usage

Dim instance As ImGearCapEnumeration
Dim value As Integer

instance.DefaultValueIndex = value

value = instance.DefaultValueIndex
public int DefaultValueIndex {get; set;}
public: __property int get_DefaultValueIndex();
public: __property void set_DefaultValueIndex(
   int value
);
public:
property int DefaultValueIndex {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Value should be in the 0...ImGearCapArray.Count range.
See Also

Reference

ImGearCapEnumeration Class
ImGearCapEnumeration Members


%%PageItemTitle%%

ImGearCapOneValue Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapOneValue Class
This class describes a capability whose value resides in ImGearContainerType.ONEVALUE container.
Object Model
ImGearCapOneValue Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCapOneValue
   Inherits ImGearCap
'Usage

Dim instance As ImGearCapOneValue
public sealed class ImGearCapOneValue : ImGearCap
public __gc __sealed class ImGearCapOneValue : public ImGearCap
public ref class ImGearCapOneValue sealed : public ImGearCap
Remarks
This class inherits the ImGearCap class.
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapOneValue

See Also

Reference

ImGearCapOneValue Members
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%% $$Members$$

ImGearCapOneValue Class Members
Properties Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapOneValue Class

The following tables list the members exposed by ImGearCapOneValue.

Public Constructors
 | Name | Description
Public Constructor | ImGearCapOneValue Constructor | Initializes a new instance of the ImGearCapOneValue class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value of the capability.
Top
See Also

Reference

ImGearCapOneValue Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapOneValue Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapOneValue Class : ImGearCapOneValue Constructor
An ImGearCapabilities value, which identifies the capability that this class will represent.
Initializes a new instance of the ImGearCapOneValue class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal capabilityId As ImGearCapabilities _
)
'Usage

Dim capabilityId As ImGearCapabilities

Dim instance As New ImGearCapOneValue(capabilityId)
public ImGearCapOneValue(
   ImGearCapabilities capabilityId
)
public: ImGearCapOneValue(
   ImGearCapabilities capabilityId
)
public:
ImGearCapOneValue(
   ImGearCapabilities capabilityId
)

Parameters

capabilityId
An ImGearCapabilities value, which identifies the capability that this class will represent.

Return Value

The new instance of ImGearCapOneValue class.
See Also

Reference

ImGearCapOneValue Class
ImGearCapOneValue Members
ImGearCapabilities Enumeration


%%PageItemTitle%% $$Properties$$

ImGearCapOneValue Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapOneValue Class

For a list of all members of this type, see ImGearCapOneValue members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value of the capability.
Top
See Also

Reference

ImGearCapOneValue Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%% $$Methods$$

ImGearCapOneValue Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapOneValue Class

For a list of all members of this type, see ImGearCapOneValue members.

See Also

Reference

ImGearCapOneValue Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapOneValue Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapOneValue Class : ImGearCapOneValue Constructor
Overload List
Overload | Description
ImGearCapOneValue Constructor | Initializes a new instance of the ImGearCapOneValue class.
See Also

Reference

ImGearCapOneValue Class
ImGearCapOneValue Members


Value Property (ImGearCapOneValue)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapOneValue Class : Value Property
Gets or sets the value of the capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As ImGearCapOneValue
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be on of the following types:
  • System.Boolean,
  • System.Double,
  • System.Int64,
  • System.String,
  • ImageGear.Core.ImageGear.Core.ImGearDoubleRectangle structure.
See Also

Reference

ImGearCapOneValue Class
ImGearCapOneValue Members
ImGearDoubleRectangle Structure


%%PageItemTitle%%

ImGearCapRange Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapRange Class
This class describes a capability whose value resides in ImGearContainerType.RANGE container.
Object Model
ImGearCapRange Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearCapRange
   Inherits ImGearCap
'Usage

Dim instance As ImGearCapRange
public sealed class ImGearCapRange : ImGearCap
public __gc __sealed class ImGearCapRange : public ImGearCap
public ref class ImGearCapRange sealed : public ImGearCap
Remarks
This class inherits ImGearCap class.
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearCap
ImageGear.TWAIN.ImGearCapRange

See Also

Reference

ImGearCapRange Members
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%% $$Members$$

ImGearCapRange Class Members
Properties Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapRange Class

The following tables list the members exposed by ImGearCapRange.

Public Constructors
 | Name | Description
Public Constructor | ImGearCapRange Constructor | Initializes a new instance of the ImGearCapRange class.
Top
Public Properties
 | Name | Description
Public Property | CurrentValue | Gets or sets the current value of the range.
Public Property | DefaultValue | Gets or sets the default value of the range.
Public Property | MaxValue | Gets or sets the maximum value of the range.
Public Property | MinValue | Gets or sets the minimum value of the range.
Public Property | StepSize | Gets or sets the step size of the range.
Top
See Also

Reference

ImGearCapRange Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapRange Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : ImGearCapRange Constructor
An ImGearCapabilities value, which identifies the capability that this class will represent.
Initializes a new instance of the ImGearCapRange class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal capabilityId As ImGearCapabilities _
)
'Usage

Dim capabilityId As ImGearCapabilities

Dim instance As New ImGearCapRange(capabilityId)
public ImGearCapRange(
   ImGearCapabilities capabilityId
)
public: ImGearCapRange(
   ImGearCapabilities capabilityId
)
public:
ImGearCapRange(
   ImGearCapabilities capabilityId
)

Parameters

capabilityId
An ImGearCapabilities value, which identifies the capability that this class will represent.

Return Value

The new instance of ImGearCapRange class.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members
ImGearCapabilities Enumeration


%%PageItemTitle%% $$Properties$$

ImGearCapRange Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapRange Class

For a list of all members of this type, see ImGearCapRange members.

Public Properties
 | Name | Description
Public Property | CurrentValue | Gets or sets the current value of the range.
Public Property | DefaultValue | Gets or sets the default value of the range.
Public Property | MaxValue | Gets or sets the maximum value of the range.
Public Property | MinValue | Gets or sets the minimum value of the range.
Public Property | StepSize | Gets or sets the step size of the range.
Top
See Also

Reference

ImGearCapRange Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%% $$Methods$$

ImGearCapRange Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapRange Class

For a list of all members of this type, see ImGearCapRange members.

See Also

Reference

ImGearCapRange Class
ImageGear.TWAIN Namespace
ImGearCap Class


%%PageItemTitle%%

ImGearCapRange Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : ImGearCapRange Constructor
Overload List
Overload | Description
ImGearCapRange Constructor | Initializes a new instance of the ImGearCapRange class.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


CurrentValue Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : CurrentValue Property
Gets or sets the current value of the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CurrentValue As Object
'Usage

Dim instance As ImGearCapRange
Dim value As Object

instance.CurrentValue = value

value = instance.CurrentValue
public object CurrentValue {get; set;}
public: __property Object* get_CurrentValue();
public: __property void set_CurrentValue(
   Object* value
);
public:
property Object^ CurrentValue {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be of the following types:
  • System.Double value.
  • System.Int64 value.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


DefaultValue Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : DefaultValue Property
Gets or sets the default value of the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValue As Object
'Usage

Dim instance As ImGearCapRange
Dim value As Object

instance.DefaultValue = value

value = instance.DefaultValue
public object DefaultValue {get; set;}
public: __property Object* get_DefaultValue();
public: __property void set_DefaultValue(
   Object* value
);
public:
property Object^ DefaultValue {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be of the following types:
  • System.Double value.
  • System.Int64 value.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


MaxValue Property (ImGearCapRange)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : MaxValue Property
Gets or sets the maximum value of the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxValue As Object
'Usage

Dim instance As ImGearCapRange
Dim value As Object

instance.MaxValue = value

value = instance.MaxValue
public object MaxValue {get; set;}
public: __property Object* get_MaxValue();
public: __property void set_MaxValue(
   Object* value
);
public:
property Object^ MaxValue {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be of the following types:
  • System.Double value.
  • System.Int64 value.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


MinValue Property (ImGearCapRange)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : MinValue Property
Gets or sets the minimum value of the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinValue As Object
'Usage

Dim instance As ImGearCapRange
Dim value As Object

instance.MinValue = value

value = instance.MinValue
public object MinValue {get; set;}
public: __property Object* get_MinValue();
public: __property void set_MinValue(
   Object* value
);
public:
property Object^ MinValue {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be of the following types:
  • System.Double value.
  • System.Int64 value.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


StepSize Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearCapRange Class : StepSize Property
Gets or sets the step size of the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StepSize As Object
'Usage

Dim instance As ImGearCapRange
Dim value As Object

instance.StepSize = value

value = instance.StepSize
public object StepSize {get; set;}
public: __property Object* get_StepSize();
public: __property void set_StepSize(
   Object* value
);
public:
property Object^ StepSize {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The value can be of the following types:
  • System.Double value.
  • System.Int64 value.
See Also

Reference

ImGearCapRange Class
ImGearCapRange Members


%%PageItemTitle%%

ImGearDataSources Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDataSources Class
This class holds information about TWAIN data sources.
Object Model
ImGearDataSources Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearDataSources
'Usage

Dim instance As ImGearDataSources
[DefaultMember("Item")]
public class ImGearDataSources
[DefaultMember("Item")]
public __gc class ImGearDataSources
[DefaultMember("Item")]
public ref class ImGearDataSources
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearDataSources

See Also

Reference

ImGearDataSources Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearDataSources Class Members
Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDataSources Class

The following tables list the members exposed by ImGearDataSources.

Public Constructors
 | Name | Description
Public Constructor | ImGearDataSources Constructor | Initializes a new instance of the ImGearDataSources class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of data sources contained in the array.
Public Property | DefaultIndex | Gets the index in the array of the default data source.
Public Property | Item | Gets the name of the specified data source.
Top
See Also

Reference

ImGearDataSources Class
ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearDataSources Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearDataSources Class : ImGearDataSources Constructor
Initializes a new instance of the ImGearDataSources class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearDataSources()
public ImGearDataSources()
public: ImGearDataSources();
public:
ImGearDataSources();

Return Value

The new instance of ImGearDataSources class.
See Also

Reference

ImGearDataSources Class
ImGearDataSources Members


%%PageItemTitle%% $$Properties$$

ImGearDataSources Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDataSources Class

For a list of all members of this type, see ImGearDataSources members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of data sources contained in the array.
Public Property | DefaultIndex | Gets the index in the array of the default data source.
Public Property | Item | Gets the name of the specified data source.
Top
See Also

Reference

ImGearDataSources Class
ImageGear.TWAIN Namespace


Count Property (ImGearDataSources)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearDataSources Class : Count Property
Gets the number of data sources contained in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearDataSources
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearDataSources Class
ImGearDataSources Members


DefaultIndex Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearDataSources Class : DefaultIndex Property
Gets the index in the array of the default data source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DefaultIndex As Integer
'Usage

Dim instance As ImGearDataSources
Dim value As Integer

value = instance.DefaultIndex
public int DefaultIndex {get;}
public: __property int get_DefaultIndex();
public:
property int DefaultIndex {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearDataSources Class
ImGearDataSources Members


Item Property (ImGearDataSources)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearDataSources Class : Item Property
Index of the data source to access.
Gets the name of the specified data source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As String
'Usage

Dim instance As ImGearDataSources
Dim index As Integer
Dim value As String

value = instance.Item(index)
public string this[
   int index
]; {get;}
public: __property string* get_Item   int index
;
public:
property String^ default [int] {
   String^ get(int index);
}

Parameters

index
Index of the data source to access.

Property Value

String name of the data source.
See Also

Reference

ImGearDataSources Class
ImGearDataSources Members


%%PageItemTitle%%

ImGearFileInfo Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFileInfo Class
This class holds information about TWAIN file system.
Object Model
ImGearFileInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearFileInfo
'Usage

Dim instance As ImGearFileInfo
public class ImGearFileInfo
public __gc class ImGearFileInfo
public ref class ImGearFileInfo
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearFileInfo

See Also

Reference

ImGearFileInfo Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearFileInfo Class Members
Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFileInfo Class

The following tables list the members exposed by ImGearFileInfo.

Public Constructors
 | Name | Description
Public Constructor | ImGearFileInfo Constructor | Initializes a new instance of the ImGearFileInfo class.
Top
Public Properties
 | Name | Description
Public Property | CreateTimeDate | Gets the creation date of the file.
Public Property | DeviceGroupMask | Gets the camera's group (e.g., front/rear bitonal, front/rear grayscale, etc.).
Public Property | FreeSpace | Gets bytes of free space on the current device.
Public Property | ModifiedTimeDate | Gets the last date the file was modified.
Public Property | Name | Gets the name of the file.
Public Property | newImageSize | Gets an estimate of the amount of space a new image would take up.
Public Property | NumberOfFiles | Gets the number of files; depends on Type.
Public Property | NumberOfSnippets | Gets the number of audio snippets.
Public Property | Size | Gets the size of current Type.
Public Property | Type | Gets the type of the file.
Top
See Also

Reference

ImGearFileInfo Class
ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFileInfo Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : ImGearFileInfo Constructor
Initializes a new instance of the ImGearFileInfo class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearFileInfo()
public ImGearFileInfo()
public: ImGearFileInfo();
public:
ImGearFileInfo();

Return Value

The new instance of ImGearFileInfo class.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


%%PageItemTitle%% $$Properties$$

ImGearFileInfo Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFileInfo Class

For a list of all members of this type, see ImGearFileInfo members.

Public Properties
 | Name | Description
Public Property | CreateTimeDate | Gets the creation date of the file.
Public Property | DeviceGroupMask | Gets the camera's group (e.g., front/rear bitonal, front/rear grayscale, etc.).
Public Property | FreeSpace | Gets bytes of free space on the current device.
Public Property | ModifiedTimeDate | Gets the last date the file was modified.
Public Property | Name | Gets the name of the file.
Public Property | newImageSize | Gets an estimate of the amount of space a new image would take up.
Public Property | NumberOfFiles | Gets the number of files; depends on Type.
Public Property | NumberOfSnippets | Gets the number of audio snippets.
Public Property | Size | Gets the size of current Type.
Public Property | Type | Gets the type of the file.
Top
See Also

Reference

ImGearFileInfo Class
ImageGear.TWAIN Namespace


CreateTimeDate Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : CreateTimeDate Property
Gets the creation date of the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CreateTimeDate As String
'Usage

Dim instance As ImGearFileInfo
Dim value As String

value = instance.CreateTimeDate
public string CreateTimeDate {get;}
public: __property string* get_CreateTimeDate();
public:
property String^ CreateTimeDate {
   String^ get();
}

Property Value

String time data.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


DeviceGroupMask Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : DeviceGroupMask Property
Gets the camera's group (e.g., front/rear bitonal, front/rear grayscale, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DeviceGroupMask As Integer
'Usage

Dim instance As ImGearFileInfo
Dim value As Integer

value = instance.DeviceGroupMask
public int DeviceGroupMask {get;}
public: __property int get_DeviceGroupMask();
public:
property int DeviceGroupMask {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


FreeSpace Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : FreeSpace Property
Gets bytes of free space on the current device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FreeSpace As Long
'Usage

Dim instance As ImGearFileInfo
Dim value As Long

value = instance.FreeSpace
public long FreeSpace {get;}
public: __property long get_FreeSpace();
public:
property int64 FreeSpace {
   int64 get();
}

Property Value

Int64 value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


ModifiedTimeDate Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : ModifiedTimeDate Property
Gets the last date the file was modified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ModifiedTimeDate As String
'Usage

Dim instance As ImGearFileInfo
Dim value As String

value = instance.ModifiedTimeDate
public string ModifiedTimeDate {get;}
public: __property string* get_ModifiedTimeDate();
public:
property String^ ModifiedTimeDate {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


Name Property (ImGearFileInfo)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : Name Property
Gets the name of the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As ImGearFileInfo
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

String value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


newImageSize Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : newImageSize Property
Gets an estimate of the amount of space a new image would take up.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property newImageSize As Integer
'Usage

Dim instance As ImGearFileInfo
Dim value As Integer

value = instance.newImageSize
public int newImageSize {get;}
public: __property int get_newImageSize();
public:
property int newImageSize {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


NumberOfFiles Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : NumberOfFiles Property
Gets the number of files; depends on Type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NumberOfFiles As Long
'Usage

Dim instance As ImGearFileInfo
Dim value As Long

value = instance.NumberOfFiles
public long NumberOfFiles {get;}
public: __property long get_NumberOfFiles();
public:
property int64 NumberOfFiles {
   int64 get();
}

Property Value

Int64 value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


NumberOfSnippets Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : NumberOfSnippets Property
Gets the number of audio snippets.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NumberOfSnippets As Long
'Usage

Dim instance As ImGearFileInfo
Dim value As Long

value = instance.NumberOfSnippets
public long NumberOfSnippets {get;}
public: __property long get_NumberOfSnippets();
public:
property int64 NumberOfSnippets {
   int64 get();
}

Property Value

Int64 value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


Size Property (ImGearFileInfo)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : Size Property
Gets the size of current Type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Long
'Usage

Dim instance As ImGearFileInfo
Dim value As Long

value = instance.Size
public long Size {get;}
public: __property long get_Size();
public:
property int64 Size {
   int64 get();
}

Property Value

Int64 value.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


Type Property (ImGearFileInfo)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearFileInfo Class : Type Property
Gets the type of the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ImGearFileType
'Usage

Dim instance As ImGearFileInfo
Dim value As ImGearFileType

value = instance.Type
public ImGearFileType Type {get;}
public: __property ImGearFileType get_Type();
public:
property ImGearFileType Type {
   ImGearFileType get();
}

Property Value

ImGearFileType enumeration values.
See Also

Reference

ImGearFileInfo Class
ImGearFileInfo Members


%%PageItemTitle%%

ImGearTWAIN Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAIN Class
Core TWAIN class.
Object Model
ImGearTWAIN ClassImGearDocument ClassImGearPage ClassImGearDataSources ClassImGearCap ClassImGearPage ClassImGearFileInfo ClassImGearFileInfo ClassImGearDoubleRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearTWAIN
'Usage

Dim instance As ImGearTWAIN
public sealed class ImGearTWAIN
public __gc __sealed class ImGearTWAIN
public ref class ImGearTWAIN sealed
Inheritance Hierarchy

System.Object
ImageGear.TWAIN.ImGearTWAIN

See Also

Reference

ImGearTWAIN Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearTWAIN Class Members
Properties Methods Events

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAIN Class

The following tables list the members exposed by ImGearTWAIN.

Public Constructors
 | Name | Description
Public Constructor | ImGearTWAIN Constructor | Initializes a new instance of the ImGearTWAIN class.
Top
Public Properties
 | Name | Description
Public Property | ApplicationName | Gets or sets the name of the application that uses TWAIN.
Public Property | AudioFileName | Gets or sets the file name for recorded audio.
Public Property | DataSources | Gets a list of available TWAIN Data Sources and identifies the one that is the default Data Source.
Public Property | DriverVersionBuild | Gets the build part of the version number of the TWAIN Data Source Manager.
Public Property | DriverVersionMajor | Gets the major part of the version number of the TWAIN Data Source Manager.
Public Property | DriverVersionMinor | Gets the minor part of the version number of the TWAIN Data Source Manager.
Public Property | ImageFileName | Gets or sets the name of a file or directory to which a scanned image will be stored when Disk Transfer Mode is used.
Public Property | UseUI | Gets or sets a value indicating whether to use the scanner's interface.
Public Property | WindowHandle | Gets or sets the window handle to use as the parent window.
Top
Public Methods
 | Name | Description
Public Method | Acquire | Overloaded. Scan multiple pages from a scanner equipped with an AutomaticDocumentFeeder (ADF). Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Public Method | AcquireToDoc | Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF). Pages are saved to an ImageGear.Core.ImGearDocument.
Public Method | AcquireToFile | Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF) to a specified file or directory.
Public Method | AcquireToPage | This method causes the scanning of a single page through a TWAIN device.
Public Method | ChangeDirectory | This method selects the current device within the Data Source (camera, storage, etc).
Public Method | CloseFile | This method closes the file system context.
Public Method | CloseSource | This method closes the currently opened Data Source and it also closes the connection with the Data Source Manager.
Public Method | CopyFile | This method copies the specified file from one directory to another.
Public Method | CreateDirectory | This method creates a new directory within the current directory.
Public Method | DeleteFile | This method deletes a file or directory on the device.
Public Method | Dispose | Releases resources used by the class.
Public Method | FormatMedia | This method formats the specified storage device. Caution: All images and subdirectories under the selected device will be destroyed.
Public Method | GetCapability | This method gets information about a capability.
Public Method | GetCurrentImage | This method retrieves the image that the device's file system context currently points to.
Public Method | GetFileInfo | This method gets information about the requested file.
Public Method | GetFirstFile | This method gets the first filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Public Method | GetImageLayout | Gets the image layout of the selected TWAIN device.
Public Method | GetNextFile | This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Public Method | LoadCustomDSData | This method loads the settings from the specified file, and sets the data source with these settings.
Public Method | OpenSource | This method opens a connection to the TWAIN Data Source Manager and then loads the specified Data Source into main memory and causes its initialization.
Public Method | RenameFile | This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported.
Public Method | SaveCustomDSData | This method queries the data source for its current settings, and saves these settings to the specified file.
Public Method | SetCapability | This method sets or resets the current value of a capability.
Public Method | SetImageLayout | Sets the image layout of the selected TWAIN device.
Public Method | ShowSourceUI | This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearTWAIN class. Diposes of unmanaged resources if they were not already disposed.
Top
Public Events
 | Name | Description
Public Event | AfterPage | This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.
Public Event | BeforePage | This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.
Top
See Also

Reference

ImGearTWAIN Class
ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearTWAIN Constructor

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : ImGearTWAIN Constructor
Initializes a new instance of the ImGearTWAIN class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearTWAIN()
public ImGearTWAIN()
public: ImGearTWAIN();
public:
ImGearTWAIN();

Return Value

The new instance of ImGearTWAIN class.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


%%PageItemTitle%% $$Methods$$

ImGearTWAIN Class Methods

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAIN Class

For a list of all members of this type, see ImGearTWAIN members.

Public Methods
 | Name | Description
Public Method | Acquire | Overloaded. Scan multiple pages from a scanner equipped with an AutomaticDocumentFeeder (ADF). Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Public Method | AcquireToDoc | Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF). Pages are saved to an ImageGear.Core.ImGearDocument.
Public Method | AcquireToFile | Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF) to a specified file or directory.
Public Method | AcquireToPage | This method causes the scanning of a single page through a TWAIN device.
Public Method | ChangeDirectory | This method selects the current device within the Data Source (camera, storage, etc).
Public Method | CloseFile | This method closes the file system context.
Public Method | CloseSource | This method closes the currently opened Data Source and it also closes the connection with the Data Source Manager.
Public Method | CopyFile | This method copies the specified file from one directory to another.
Public Method | CreateDirectory | This method creates a new directory within the current directory.
Public Method | DeleteFile | This method deletes a file or directory on the device.
Public Method | Dispose | Releases resources used by the class.
Public Method | FormatMedia | This method formats the specified storage device. Caution: All images and subdirectories under the selected device will be destroyed.
Public Method | GetCapability | This method gets information about a capability.
Public Method | GetCurrentImage | This method retrieves the image that the device's file system context currently points to.
Public Method | GetFileInfo | This method gets information about the requested file.
Public Method | GetFirstFile | This method gets the first filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Public Method | GetImageLayout | Gets the image layout of the selected TWAIN device.
Public Method | GetNextFile | This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Public Method | LoadCustomDSData | This method loads the settings from the specified file, and sets the data source with these settings.
Public Method | OpenSource | This method opens a connection to the TWAIN Data Source Manager and then loads the specified Data Source into main memory and causes its initialization.
Public Method | RenameFile | This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported.
Public Method | SaveCustomDSData | This method queries the data source for its current settings, and saves these settings to the specified file.
Public Method | SetCapability | This method sets or resets the current value of a capability.
Public Method | SetImageLayout | Sets the image layout of the selected TWAIN device.
Public Method | ShowSourceUI | This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearTWAIN class. Diposes of unmanaged resources if they were not already disposed.
Top
See Also

Reference

ImGearTWAIN Class
ImageGear.TWAIN Namespace


Acquire Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : Acquire Method
Scan multiple pages from a scanner equipped with an AutomaticDocumentFeeder (ADF). Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Overload List
Overload | Description
Acquire(Int32) | Scan multiple pages from a scanner equipped with an AutomaticDocumentFeeder (ADF). Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Acquire(Int32,Boolean) | Scan a single page or multiple pages from a scanner. Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


Acquire(Int32) Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class > Acquire Method : Acquire(Int32) Method
Count of pages to scan. -1 scans all available pages.
Scan multiple pages from a scanner equipped with an AutomaticDocumentFeeder (ADF). Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Acquire( _
   ByVal pageCount As Integer _
)
'Usage

Dim instance As ImGearTWAIN
Dim pageCount As Integer

instance.Acquire(pageCount)
public void Acquire(
   int pageCount
)
public: void Acquire(
   int pageCount
)
public:
void Acquire(
   int pageCount
)

Parameters

pageCount
Count of pages to scan. -1 scans all available pages.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method called while a connection with a data source is not open.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Call SetCapability to set desired capability values.
  • Set up event handlers for the AfterPage event.

In the AfterPage event, the scanned page is made available as an ImageGear.Core.ImGearPage class object.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
Overload List
ImGearDocument Class
OpenSource Method


Acquire(Int32,Boolean) Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class > Acquire Method : Acquire(Int32,Boolean) Method
Count of pages to scan. -1 scans all available pages.
If the scanner has an AutomaticDocumentFeeder (ADF) Setting the enableFeeder to true will be treated as if the user called the Acquire(Int32) method. Setting the enableFeeder to false will turn off the ADF, and set the pageCount to 1.
Scan a single page or multiple pages from a scanner. Each page is saved to an ImageGear.Core.ImGearPage available in an AfterPage event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Acquire( _
   ByVal pageCount As Integer, _
   ByVal enableFeeder As Boolean _
)
'Usage

Dim instance As ImGearTWAIN
Dim pageCount As Integer
Dim enableFeeder As Boolean

instance.Acquire(pageCount, enableFeeder)
public void Acquire(
   int pageCount,
   bool enableFeeder
)
public: void Acquire(
   int pageCount,
   bool enableFeeder
)
public:
void Acquire(
   int pageCount,
   bool enableFeeder
)

Parameters

pageCount
Count of pages to scan. -1 scans all available pages.
enableFeeder
If the scanner has an AutomaticDocumentFeeder (ADF) Setting the enableFeeder to true will be treated as if the user called the Acquire(Int32) method. Setting the enableFeeder to false will turn off the ADF, and set the pageCount to 1.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method called while a connection with a data source is not open.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Call SetCapability to set desired capability values.
  • Set up event handlers for the AfterPage event.

In the AfterPage event, the scanned page is made available as an ImageGear.Core.ImGearPage class object.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
Overload List
ImGearDocument Class
OpenSource Method


AcquireToDoc Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : AcquireToDoc Method
Count of pages to scan. -1 scans all available pages.
Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF). Pages are saved to an ImageGear.Core.ImGearDocument.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AcquireToDoc( _
   ByVal pageCount As Integer _
) As ImGearDocument
'Usage

Dim instance As ImGearTWAIN
Dim pageCount As Integer
Dim value As ImGearDocument

value = instance.AcquireToDoc(pageCount)
public ImGearDocument AcquireToDoc(
   int pageCount
)
public: ImGearDocument* AcquireToDoc(
   int pageCount
)
public:
ImGearDocument^ AcquireToDoc(
   int pageCount
)

Parameters

pageCount
Count of pages to scan. -1 scans all available pages.

Return Value

An ImageGear.Core.ImGearDocument class containing the scanned images.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method called while a connection with a data source is not open.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Call SetCapability to set desired capability values.
  • Set UseUI to true if you want to obtain the capability settings from the end user.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearDocument Class
OpenSource Method


AcquireToFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : AcquireToFile Method
The pathname of the file or directory to which pages are stored.
Count of pages to scan. -1 scans all available pages.
The format of the file to scan to.
Specifies whether every scanned page should be saved in the separate file or not.
Scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF) to a specified file or directory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AcquireToFile( _
   ByVal fileName As String, _
   ByVal pageCount As Integer, _
   ByVal fileFormat As ImGearSavingFormats, _
   ByVal savePagesSeparately As Boolean _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileName As String
Dim pageCount As Integer
Dim fileFormat As ImGearSavingFormats
Dim savePagesSeparately As Boolean

instance.AcquireToFile(fileName, pageCount, fileFormat, savePagesSeparately)
public void AcquireToFile(
   string fileName,
   int pageCount,
   ImGearSavingFormats fileFormat,
   bool savePagesSeparately
)
public: void AcquireToFile(
   string* fileName,
   int pageCount,
   ImGearSavingFormats fileFormat,
   bool savePagesSeparately
)
public:
void AcquireToFile(
   String^ fileName,
   int pageCount,
   ImGearSavingFormats fileFormat,
   bool savePagesSeparately
)

Parameters

fileName
The pathname of the file or directory to which pages are stored.
pageCount
Count of pages to scan. -1 scans all available pages.
fileFormat
The format of the file to scan to.
savePagesSeparately
Specifies whether every scanned page should be saved in the separate file or not.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Call SetCapability to set desired capability values.
  • Set UseUI to true if you want to obtain the capability settings from the end user.

If fileName specifies a directory, then a separate file of type fileFormat will be created for each scanned page, for example: 0000001.tif, 00000002.tif, 00000003.tif, etc. If these files already exist, the existing files will be replaced. The value of savePagesSeparately will be ignored.

If fileName specifies a file name, and savePagesSeparately is set to true, then a separate file will be created for each scanned page. The names of each file will be based on the fileName specified. For example, If fileName = "ScanTest.bmp", each page will be named as follows: ScanTest.bmp, ScanTest0.bmp, ScanTest1.bmp, ScanTest10.bmp, ScanTest11.bmp, etc. If these files already exist, they will be replaced.

If fileName specifies a file name, and savePagesSeparately is set to false, and fileFormat is set to a multiple page format such as TIFF, DCX, or MO:DCA, then the images will be stored in one file with the specified fileName.

If fileName specifies a file name, and savePagesSeparately is set to false, and fileFormat is set to a single page format, then savePagesSeparately will be ignored and behave the same as if it was set to true.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearSavingFormats Enumeration


AcquireToPage Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : AcquireToPage Method
This method causes the scanning of a single page through a TWAIN device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AcquireToPage() As ImGearPage
'Usage

Dim instance As ImGearTWAIN
Dim value As ImGearPage

value = instance.AcquireToPage()
public ImGearPage AcquireToPage()
public: ImGearPage* AcquireToPage();
public:
ImGearPage^ AcquireToPage();

Return Value

An ImageGear.Core.ImGearPage class containig the scanned image.
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method called while a connection with a data source is not open.
Remarks
Prior to calling this method:
  • Call OpenSource to select the desired Data Source.
  • Call SetCapability to set desired capability values.
  • Set UseUI to true if you want to obtain the capability settings from the end user.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearPage Class
OpenSource Method


ChangeDirectory Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : ChangeDirectory Method
The name of directory.
This method selects the current device within the Data Source (camera, storage, etc).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ChangeDirectory( _
   ByVal directoryName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim directoryName As String

instance.ChangeDirectory(directoryName)
public void ChangeDirectory(
   string directoryName
)
public: void ChangeDirectory(
   string* directoryName
)
public:
void ChangeDirectory(
   String^ directoryName
)

Parameters

directoryName
The name of directory.
Remarks
If the device is a ImGearFileType.DOMAIN, then this command enters a directory that can contain ImGearFileType.HOST files. If the device is a ImGearFileType.HOST, then this command enters a directory that can contain ImGearFileType.DIRECTORY files. If the device is a ImGearFileType.DIRECTORY, then this command enters a directory that can contain ImGearFileType.DIRECTORY or ImGearFileType.IMAGE files.

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


CloseFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : CloseFile Method
Information on the file to close.
This method closes the file system context.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CloseFile( _
   ByVal fileInfo As ImGearFileInfo _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileInfo As ImGearFileInfo

instance.CloseFile(fileInfo)
public void CloseFile(
   ImGearFileInfo fileInfo
)
public: void CloseFile(
   ImGearFileInfo* fileInfo
)
public:
void CloseFile(
   ImGearFileInfo^ fileInfo
)

Parameters

fileInfo
Information on the file to close.
Remarks

Prior to calling this method, use OpenSource to select the desired Data Source.

Every call to GetFirstFile must be matched by a call to CloseFile to release the file system context.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearFileInfo Class


CloseSource Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : CloseSource Method
This method closes the currently opened Data Source and it also closes the connection with the Data Source Manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CloseSource()
'Usage

Dim instance As ImGearTWAIN

instance.CloseSource()
public void CloseSource()
public: void CloseSource();
public:
void CloseSource();
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown when this method is called but there is not an open connection with a Data Source.
Remarks
When an application is finished with a Data Source, it must formally close the session between them using this method. This is necessary in case the Data Source only supports connection with a single application (many desktop scanners will behave this way). A Data Source such as this cannot be accessed by other applications until its current session is terminated.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearDataSources Class


CopyFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : CopyFile Method
The path to the source file/directory.
The path to the destination file/directory.
Specifies whether the copying is recursive or not.
This method copies the specified file from one directory to another.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFile( _
   ByVal sourceFileName As String, _
   ByVal destinationFileName As String, _
   ByVal recursive As Boolean _
)
'Usage

Dim instance As ImGearTWAIN
Dim sourceFileName As String
Dim destinationFileName As String
Dim recursive As Boolean

instance.CopyFile(sourceFileName, destinationFileName, recursive)
public void CopyFile(
   string sourceFileName,
   string destinationFileName,
   bool recursive
)
public: void CopyFile(
   string* sourceFileName,
   string* destinationFileName,
   bool recursive
)
public:
void CopyFile(
   String^ sourceFileName,
   String^ destinationFileName,
   bool recursive
)

Parameters

sourceFileName
The path to the source file/directory.
destinationFileName
The path to the destination file/directory.
recursive
Specifies whether the copying is recursive or not.
Remarks
If the Recursive flag is true and the file type specified is ImGearFileType.DIRECTORY, then that directory, and all the files and directories under it, are copied. The application cannot copy files into the root directory.

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


CreateDirectory Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : CreateDirectory Method
The name (NOT the pathname) of directory to create.
This method creates a new directory within the current directory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CreateDirectory( _
   ByVal directoryName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim directoryName As String

instance.CreateDirectory(directoryName)
public void CreateDirectory(
   string directoryName
)
public: void CreateDirectory(
   string* directoryName
)
public:
void CreateDirectory(
   String^ directoryName
)

Parameters

directoryName
The name (NOT the pathname) of directory to create.
Remarks
Prior to calling this method, use OpenSource to select the desired Data Source.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


DeleteFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : DeleteFile Method
The name (not the pathname) of the file or directory to delete.
When recursive is set to true, and the specified fileName is a directory, then all the files and directories within the fileName will be deleted.
This method deletes a file or directory on the device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteFile( _
   ByVal fileName As String, _
   ByVal recursive As Boolean _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileName As String
Dim recursive As Boolean

instance.DeleteFile(fileName, recursive)
public void DeleteFile(
   string fileName,
   bool recursive
)
public: void DeleteFile(
   string* fileName,
   bool recursive
)
public:
void DeleteFile(
   String^ fileName,
   bool recursive
)

Parameters

fileName
The name (not the pathname) of the file or directory to delete.
recursive
When recursive is set to true, and the specified fileName is a directory, then all the files and directories within the fileName will be deleted.
Remarks

Prior to calling this method, use OpenSource to select the desired Data Source.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


Dispose Method (ImGearTWAIN)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : Dispose Method
Releases resources used by the class.
Overload List
Overload | Description
Dispose | Releases resources used by the class.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


Dispose() Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : Dispose() Method
Releases resources used by the class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImGearTWAIN

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


Finalize Method (ImGearTWAIN)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : Finalize Method
Finalizes an instance of the ImGearTWAIN class. Diposes of unmanaged resources if they were not already disposed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearTWAIN

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


FormatMedia Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : FormatMedia Method
The name of the scanning device.

This method formats the specified storage device.

Caution: All images and subdirectories under the selected device will be destroyed.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub FormatMedia( _
   ByVal deviceName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim deviceName As String

instance.FormatMedia(deviceName)
public void FormatMedia(
   string deviceName
)
public: void FormatMedia(
   string* deviceName
)
public:
void FormatMedia(
   String^ deviceName
)

Parameters

deviceName
The name of the scanning device.
Remarks

Caution: All images and subdirectories under the selected device will be destroyed.

Prior to calling this method, use OpenSource to select the desired Data Source.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


GetCapability Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetCapability Method
ID of the capability to get information about.
Can be on of the following values:ImGearMessages.GET - Get one or more capability values.ImGearMessages.GETCURRENT - Get current capability value.ImGearMessages.GETDEFAULT - Get default (e.g. power up) capability value.
This method gets information about a capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCapability( _
   ByVal id As ImGearCapabilities, _
   ByVal message As ImGearMessages _
) As ImGearCap
'Usage

Dim instance As ImGearTWAIN
Dim id As ImGearCapabilities
Dim message As ImGearMessages
Dim value As ImGearCap

value = instance.GetCapability(id, message)
public ImGearCap GetCapability(
   ImGearCapabilities id,
   ImGearMessages message
)
public: ImGearCap* GetCapability(
   ImGearCapabilities id,
   ImGearMessages message
)
public:
ImGearCap^ GetCapability(
   ImGearCapabilities id,
   ImGearMessages message
)

Parameters

id
ID of the capability to get information about.
message
Can be on of the following values:ImGearMessages.GET - Get one or more capability values.ImGearMessages.GETCURRENT - Get current capability value.ImGearMessages.GETDEFAULT - Get default (e.g. power up) capability value.

Return Value

One of the capability objects containing information about the requested capability.
Remarks
Use OpenSource to select the desired Data Source, prior to calling this method.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearCap Class
ImGearCapabilities Enumeration
ImGearMessages Enumeration


GetCurrentImage Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetCurrentImage Method
This method retrieves the image that the device's file system context currently points to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetCurrentImage() As ImGearPage
'Usage

Dim instance As ImGearTWAIN
Dim value As ImGearPage

value = instance.GetCurrentImage()
public ImGearPage GetCurrentImage()
public: ImGearPage* GetCurrentImage();
public:
ImGearPage^ GetCurrentImage();

Return Value

An ImageGear.Core.ImGearPage class containing the requested image.
Remarks

Prior to calling this method:

  • Use OpenSource to select the desired DataSource.
  • Use GetFirstFile and GetNextFile to select the file you want to retrieve.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
GetFirstFile Method
GetNextFile Method


GetFileInfo Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetFileInfo Method
The name of file to get info about.
This method gets information about the requested file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFileInfo( _
   ByVal fileName As String _
) As ImGearFileInfo
'Usage

Dim instance As ImGearTWAIN
Dim fileName As String
Dim value As ImGearFileInfo

value = instance.GetFileInfo(fileName)
public ImGearFileInfo GetFileInfo(
   string fileName
)
public: ImGearFileInfo* GetFileInfo(
   string* fileName
)
public:
ImGearFileInfo^ GetFileInfo(
   String^ fileName
)

Parameters

fileName
The name of file to get info about.

Return Value

An ImGearFileInfo class containing information about the requested file.
Remarks
Use OpenSource to select the desired Data Source, prior to calling this method.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearFileInfo Class


GetFirstFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetFirstFile Method
This method gets the first filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetFirstFile() As ImGearFileInfo
'Usage

Dim instance As ImGearTWAIN
Dim value As ImGearFileInfo

value = instance.GetFirstFile()
public ImGearFileInfo GetFirstFile()
public: ImGearFileInfo* GetFirstFile();
public:
ImGearFileInfo^ GetFirstFile();

Return Value

An ImGearFileInfo class containing information about the first file in a directory.
Remarks
The Data Source positions the file system context to point to the first filename. ImGearFileInfo.Name contains the absolute path and name of the file. If the Application calls GetCurrentImage, the current image will be transferred. Applications must not assume any ordering of the files delivered by the Data Source, with one exception: if GetFirstFile is called in the root directory, the operation must return an ImGearFileType.CAMERA device.

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearFileInfo Class


GetImageLayout Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetImageLayout Method
Gets the image layout of the selected TWAIN device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetImageLayout() As ImGearDoubleRectangle
'Usage

Dim instance As ImGearTWAIN
Dim value As ImGearDoubleRectangle

value = instance.GetImageLayout()
public ImGearDoubleRectangle GetImageLayout()
public: ImGearDoubleRectangle GetImageLayout();
public:
ImGearDoubleRectangle GetImageLayout();

Return Value

ImageGear.Core.ImGearDoubleRectangle that represents the physical bounding box of the region to be acquired.

Note: Use only the Left, Top, Right, and Bottom properties of the return value.

Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method is called while there is not an open connection with a Data Source.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Set the ICAP_UNITS capability, if inches (default) is not the desired unit of measure for the returned bounding box.

Note: Only the Left, Top, Right and Bottom properties of the returned ImageGear.Core.ImGearDoubleRectangle should be used. The Width and Height properties should not be used, because they assume endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. This is not appropriate for a TWAIN image layout rectangle.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearDoubleRectangle Structure


GetNextFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : GetNextFile Method
The file information.
This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetNextFile( _
   ByVal fileInfo As ImGearFileInfo _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileInfo As ImGearFileInfo

instance.GetNextFile(fileInfo)
public void GetNextFile(
   ImGearFileInfo fileInfo
)
public: void GetNextFile(
   ImGearFileInfo* fileInfo
)
public:
void GetNextFile(
   ImGearFileInfo^ fileInfo
)

Parameters

fileInfo
The file information.
Remarks
The Data Source positions the file system context to point to the next filename. ImGearFileInfo.Name contains the absolute path and name of the file. If the Application calls GetCurrentImage, the current image will be transferred. A call to GetFirstFile must be issued on a given directory before the first call to GetNextFile.

Use OpenSource to select the desired Data Source, prior to calling these methods.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearFileInfo Class


LoadCustomDSData Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : LoadCustomDSData Method
Specifies the name or pathname of the file from which to load the settings.
This method loads the settings from the specified file, and sets the data source with these settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LoadCustomDSData( _
   ByVal fileName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileName As String

instance.LoadCustomDSData(fileName)
public void LoadCustomDSData(
   string fileName
)
public: void LoadCustomDSData(
   string* fileName
)
public:
void LoadCustomDSData(
   String^ fileName
)

Parameters

fileName
Specifies the name or pathname of the file from which to load the settings.
Remarks
This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities.CAP_CUSTOMDSDATA.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearCapabilities Enumeration


OpenSource Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : OpenSource Method

Specifies the data source.

If sourceName is String.Empty and UseUI is set to true, then a call to this method will cause Data Source Manager to display the default source selection dialog.

If sourceName is String.Empty and UseUI is set to false, then the default Data Source will be opened.

If sourceName is a name of an existing Data Source, the specified Data Source will be opened.

This method opens a connection to the TWAIN Data Source Manager and then loads the specified Data Source into main memory and causes its initialization.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub OpenSource( _
   ByVal sourceName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim sourceName As String

instance.OpenSource(sourceName)
public void OpenSource(
   string sourceName
)
public: void OpenSource(
   string* sourceName
)
public:
void OpenSource(
   String^ sourceName
)

Parameters

sourceName

Specifies the data source.

If sourceName is String.Empty and UseUI is set to true, then a call to this method will cause Data Source Manager to display the default source selection dialog.

If sourceName is String.Empty and UseUI is set to false, then the default Data Source will be opened.

If sourceName is a name of an existing Data Source, the specified Data Source will be opened.

Remarks
When an application is finished with the Data Source, call CloseSource to close the session between them.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


RenameFile Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : RenameFile Method
The name of the file/directory to be renamed.
The new name of the file/directory.
This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RenameFile( _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim oldName As String
Dim newName As String

instance.RenameFile(oldName, newName)
public void RenameFile(
   string oldName,
   string newName
)
public: void RenameFile(
   string* oldName,
   string* newName
)
public:
void RenameFile(
   String^ oldName,
   String^ newName
)

Parameters

oldName
The name of the file/directory to be renamed.
newName
The new name of the file/directory.
Remarks
A file may not be overwritten with this command. If an Application wishes to do this, it must first delete the unwanted file, then issue the rename command. Filenames in the root directory cannot be moved or renamed.

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


SaveCustomDSData Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : SaveCustomDSData Method
Specifies the name or pathname of the file to which to save the settings.
This method queries the data source for its current settings, and saves these settings to the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SaveCustomDSData( _
   ByVal fileName As String _
)
'Usage

Dim instance As ImGearTWAIN
Dim fileName As String

instance.SaveCustomDSData(fileName)
public void SaveCustomDSData(
   string fileName
)
public: void SaveCustomDSData(
   string* fileName
)
public:
void SaveCustomDSData(
   String^ fileName
)

Parameters

fileName
Specifies the name or pathname of the file to which to save the settings.
Remarks
This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities.CAP_CUSTOMDSDATA.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearCapabilities Enumeration


SetCapability Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : SetCapability Method
Specifies the capability to change.

Specifies whether to set or reset capability value(s).

Note: GET, GETCURRENT, and GETDEFAULT are invalid settings for the message parameter, and will result in an exception.

This method sets or resets the current value of a capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCapability( _
   ByVal capability As ImGearCap, _
   ByVal message As ImGearMessages _
)
'Usage

Dim instance As ImGearTWAIN
Dim capability As ImGearCap
Dim message As ImGearMessages

instance.SetCapability(capability, message)
public void SetCapability(
   ImGearCap capability,
   ImGearMessages message
)
public: void SetCapability(
   ImGearCap* capability,
   ImGearMessages message
)
public:
void SetCapability(
   ImGearCap^ capability,
   ImGearMessages message
)

Parameters

capability
Specifies the capability to change.
message

Specifies whether to set or reset capability value(s).

Note: GET, GETCURRENT, and GETDEFAULT are invalid settings for the message parameter, and will result in an exception.

Remarks

Prior to calling this method, use OpenSource to select the desired Data Source.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearCap Class
ImGearMessages Enumeration


SetImageLayout Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : SetImageLayout Method

The image layout of the selected TWAIN device.

NOTE: Only Left, Top, Right, and Bottom properties of ImageGear.Core.ImGearDoubleRectangle are relevant in setting the image layout.

Sets the image layout of the selected TWAIN device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetImageLayout( _
   ByVal imageLayout As ImGearDoubleRectangle _
)
'Usage

Dim instance As ImGearTWAIN
Dim imageLayout As ImGearDoubleRectangle

instance.SetImageLayout(imageLayout)
public void SetImageLayout(
   ImGearDoubleRectangle imageLayout
)
public: void SetImageLayout(
   ImGearDoubleRectangle imageLayout
)
public:
void SetImageLayout(
   ImGearDoubleRectangle imageLayout
)

Parameters

imageLayout

The image layout of the selected TWAIN device.

NOTE: Only Left, Top, Right, and Bottom properties of ImageGear.Core.ImGearDoubleRectangle are relevant in setting the image layout.

Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if this method is called while there is not an open connection with a Data Source.
Remarks

Prior to calling this method:

  • Call OpenSource to select the desired Data Source.
  • Set the ICAP_UNITS capability, if inches (default) is not the desired unit of measure for the returned bounding box.

NOTE: Only Left, Top, Right, and Bottom properties of ImageGear.Core.ImGearDoubleRectangle are relevant in setting the image layout. The Width and Height properties should not be used, because they assume endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. This is not appropriate for a TWAIN image layout rectangle.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearDoubleRectangle Structure


ShowSourceUI Method

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : ShowSourceUI Method
This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowSourceUI()
'Usage

Dim instance As ImGearTWAIN

instance.ShowSourceUI()
public void ShowSourceUI()
public: void ShowSourceUI();
public:
void ShowSourceUI();
Exceptions
Exception | Description
ImageGear.Core.ImGearException | Thrown if a connection to a data source is not open, or the open data source doesn't support ImGearCapabilities.CAP_ENABLEDSUIONLY.
Remarks
This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities.CAP_ENABLEDSUIONLY.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


%%PageItemTitle%% $$Properties$$

ImGearTWAIN Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAIN Class

For a list of all members of this type, see ImGearTWAIN members.

Public Properties
 | Name | Description
Public Property | ApplicationName | Gets or sets the name of the application that uses TWAIN.
Public Property | AudioFileName | Gets or sets the file name for recorded audio.
Public Property | DataSources | Gets a list of available TWAIN Data Sources and identifies the one that is the default Data Source.
Public Property | DriverVersionBuild | Gets the build part of the version number of the TWAIN Data Source Manager.
Public Property | DriverVersionMajor | Gets the major part of the version number of the TWAIN Data Source Manager.
Public Property | DriverVersionMinor | Gets the minor part of the version number of the TWAIN Data Source Manager.
Public Property | ImageFileName | Gets or sets the name of a file or directory to which a scanned image will be stored when Disk Transfer Mode is used.
Public Property | UseUI | Gets or sets a value indicating whether to use the scanner's interface.
Public Property | WindowHandle | Gets or sets the window handle to use as the parent window.
Top
See Also

Reference

ImGearTWAIN Class
ImageGear.TWAIN Namespace


ApplicationName Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : ApplicationName Property
Gets or sets the name of the application that uses TWAIN.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApplicationName As String
'Usage

Dim instance As ImGearTWAIN
Dim value As String

instance.ApplicationName = value

value = instance.ApplicationName
public string ApplicationName {get; set;}
public: __property string* get_ApplicationName();
public: __property void set_ApplicationName(
   string* value
);
public:
property String^ ApplicationName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


AudioFileName Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : AudioFileName Property
Gets or sets the file name for recorded audio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AudioFileName As String
'Usage

Dim instance As ImGearTWAIN
Dim value As String

instance.AudioFileName = value

value = instance.AudioFileName
public string AudioFileName {get; set;}
public: __property string* get_AudioFileName();
public: __property void set_AudioFileName(
   string* value
);
public:
property String^ AudioFileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


DataSources Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : DataSources Property
Gets a list of available TWAIN Data Sources and identifies the one that is the default Data Source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DataSources As ImGearDataSources
'Usage

Dim instance As ImGearTWAIN
Dim value As ImGearDataSources

value = instance.DataSources
public ImGearDataSources DataSources {get;}
public: __property ImGearDataSources* get_DataSources();
public:
property ImGearDataSources^ DataSources {
   ImGearDataSources^ get();
}

Property Value

An ImGearDataSources class object.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


DriverVersionBuild Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : DriverVersionBuild Property
Gets the build part of the version number of the TWAIN Data Source Manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DriverVersionBuild As Integer
'Usage

Dim instance As ImGearTWAIN
Dim value As Integer

value = instance.DriverVersionBuild
public int DriverVersionBuild {get;}
public: __property int get_DriverVersionBuild();
public:
property int DriverVersionBuild {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


DriverVersionMajor Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : DriverVersionMajor Property
Gets the major part of the version number of the TWAIN Data Source Manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DriverVersionMajor As Integer
'Usage

Dim instance As ImGearTWAIN
Dim value As Integer

value = instance.DriverVersionMajor
public int DriverVersionMajor {get;}
public: __property int get_DriverVersionMajor();
public:
property int DriverVersionMajor {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


DriverVersionMinor Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : DriverVersionMinor Property
Gets the minor part of the version number of the TWAIN Data Source Manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DriverVersionMinor As Integer
'Usage

Dim instance As ImGearTWAIN
Dim value As Integer

value = instance.DriverVersionMinor
public int DriverVersionMinor {get;}
public: __property int get_DriverVersionMinor();
public:
property int DriverVersionMinor {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


ImageFileName Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : ImageFileName Property
Gets or sets the name of a file or directory to which a scanned image will be stored when Disk Transfer Mode is used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageFileName As String
'Usage

Dim instance As ImGearTWAIN
Dim value As String

instance.ImageFileName = value

value = instance.ImageFileName
public string ImageFileName {get; set;}
public: __property string* get_ImageFileName();
public: __property void set_ImageFileName(
   string* value
);
public:
property String^ ImageFileName {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks

Disk Transfer Mode should be used when the TWAIN driver should do the file saving. If instead ImageGear saving is preferred, then AcquireToFile should be used.

If ImageFileName is set to a directory, then when Disk Transfer Mode is used, a separate file will be created for each scanned page, for example: 0000001.tif, 00000002.tif, 00000003.tif, etc. If these files already exist, the existing files will be replaced.

If ImageFileName is set to a filename, then when Disk Transfer Mode is used, a separate file will be created for each scanned page, using the ImageFileName. For example, if ImageFileName = "ScanTest.bmp", then each page will be named as follows: ScanTest.bmp, ScanTest0.bmp, ScanTest1.bmp, ScanTest10.bmp, ScanTest11.bmp, etc. If these files already exist, they will be replaced.

Disk Transfer mode does not support saving multiple pages to a single file regardless of whether the format supports it. A separate file will always be created for each page.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


UseUI Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : UseUI Property
Gets or sets a value indicating whether to use the scanner's interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseUI As Boolean
'Usage

Dim instance As ImGearTWAIN
Dim value As Boolean

instance.UseUI = value

value = instance.UseUI
public bool UseUI {get; set;}
public: __property bool get_UseUI();
public: __property void set_UseUI(
   bool value
);
public:
property bool UseUI {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.

true = Display the TWAIN Data source settings dialog when OpenSource, AcquireToDoc, AcquireToFile, and AcquireToPage are called.

false = Do not display the TWAIN Data source settings dialog.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
OpenSource Method
AcquireToDoc Method
AcquireToFile Method
AcquireToPage Method


WindowHandle Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : WindowHandle Property
Gets or sets the window handle to use as the parent window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WindowHandle As IntPtr
'Usage

Dim instance As ImGearTWAIN
Dim value As IntPtr

instance.WindowHandle = value

value = instance.WindowHandle
public IntPtr WindowHandle {get; set;}
public: __property IntPtr get_WindowHandle();
public: __property void set_WindowHandle(
   IntPtr value
);
public:
property IntPtr WindowHandle {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

IntPtr value.
Remarks
This value is passed to the TWAIN Data Source when it is called by ImGearTWAIN. Your application should set this to the handle of the main window in the application.
See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members


%%PageItemTitle%% $$Events$$

ImGearTWAIN Class Events

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAIN Class

For a list of all members of this type, see ImGearTWAIN members.

Public Events
 | Name | Description
Public Event | AfterPage | This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.
Public Event | BeforePage | This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.
Top
See Also

Reference

ImGearTWAIN Class
ImageGear.TWAIN Namespace


AfterPage Event

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : AfterPage Event
This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterPage As ImGearTWAINAfterPageEventHandler
'Usage

Dim instance As ImGearTWAIN
Dim handler As ImGearTWAINAfterPageEventHandler

AddHandler instance.AfterPage, handler
public event ImGearTWAINAfterPageEventHandler AfterPage
public: __event ImGearTWAINAfterPageEventHandler* AfterPage
public:
event ImGearTWAINAfterPageEventHandler^ AfterPage
Event Data

The event handler receives an argument of type ImGearTWAINAfterPageEventArgs containing data related to this event. The following ImGearTWAINAfterPageEventArgs properties provide information specific to this event.

Property | Description
CancelScanning | Gets or sets a value indicating whether to cancel scanning.
Page | Gets ImGearPage object containing the page just scanned.
PageNumber | Gets number of page just scanned. The first page is number 1.
PendCount | Gets number of pages remaining to be scanned. -1 if unknown.
Remarks

NOTE: Methods and properties of ImGearTWAIN should not be accessed in the event handler for this event.

This event can be used by an application to monitor scanning progress (on a per-page basis) and access the image just scanned. It can also be used to cancel scanning, if the application's event handler sets the ImGearTWAINAfterPageEventArgs.CancelScanning property to true.

See ImGearTWAINAfterPageEventHandler for an example of how to use this event.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearTWAINAfterPageEventHandler Delegate


BeforePage Event

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAIN Class : BeforePage Event
This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforePage As ImGearTWAINBeforePageEventHandler
'Usage

Dim instance As ImGearTWAIN
Dim handler As ImGearTWAINBeforePageEventHandler

AddHandler instance.BeforePage, handler
public event ImGearTWAINBeforePageEventHandler BeforePage
public: __event ImGearTWAINBeforePageEventHandler* BeforePage
public:
event ImGearTWAINBeforePageEventHandler^ BeforePage
Event Data

The event handler receives an argument of type ImGearTWAINBeforePageEventArgs containing data related to this event. The following ImGearTWAINBeforePageEventArgs properties provide information specific to this event.

Property | Description
CancelScanning | Gets or sets a value indicating whether to cancel scanning.
PageNumber | Gets number of page about to be scanned. The first page is number 1.
Remarks

NOTE: Methods and properties of ImGearTWAIN should not be accessed in the event handler for this event.

This event can be used by an application to monitor scanning progress (on a per-page basis).

It can also be used to cancel scanning before scanning the next page, if the application's event handler sets the ImGearTWAINAfterPageEventArgs.CancelScanning property to TRUE.

See ImGearTWAINBeforePageEventHandler for an example of how to use this event.

See Also

Reference

ImGearTWAIN Class
ImGearTWAIN Members
ImGearTWAINBeforePageEventHandler Delegate


%%PageItemTitle%%

ImGearTWAINAfterPageEventArgs Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINAfterPageEventArgs Class
Contains arguments for the ImGearTWAIN.AfterPage event.
Object Model
ImGearTWAINAfterPageEventArgs ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearTWAINAfterPageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearTWAINAfterPageEventArgs
public class ImGearTWAINAfterPageEventArgs : System.EventArgs
public __gc class ImGearTWAINAfterPageEventArgs : public System.EventArgs
public ref class ImGearTWAINAfterPageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.TWAIN.ImGearTWAINAfterPageEventArgs

See Also

Reference

ImGearTWAINAfterPageEventArgs Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearTWAINAfterPageEventArgs Class Members
Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINAfterPageEventArgs Class

The following tables list the members exposed by ImGearTWAINAfterPageEventArgs.

Public Properties
 | Name | Description
Public Property | CancelScanning | Gets or sets a value indicating whether to cancel scanning.
Public Property | Page | Gets ImGearPage object containing the page just scanned.
Public Property | PageNumber | Gets number of page just scanned. The first page is number 1.
Public Property | PendCount | Gets number of pages remaining to be scanned. -1 if unknown.
Top
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Properties$$

ImGearTWAINAfterPageEventArgs Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINAfterPageEventArgs Class

For a list of all members of this type, see ImGearTWAINAfterPageEventArgs members.

Public Properties
 | Name | Description
Public Property | CancelScanning | Gets or sets a value indicating whether to cancel scanning.
Public Property | Page | Gets ImGearPage object containing the page just scanned.
Public Property | PageNumber | Gets number of page just scanned. The first page is number 1.
Public Property | PendCount | Gets number of pages remaining to be scanned. -1 if unknown.
Top
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImageGear.TWAIN Namespace


CancelScanning Property (ImGearTWAINAfterPageEventArgs)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINAfterPageEventArgs Class : CancelScanning Property
Gets or sets a value indicating whether to cancel scanning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CancelScanning As Boolean
'Usage

Dim instance As ImGearTWAINAfterPageEventArgs
Dim value As Boolean

instance.CancelScanning = value

value = instance.CancelScanning
public bool CancelScanning {get; set;}
public: __property bool get_CancelScanning();
public: __property void set_CancelScanning(
   bool value
);
public:
property bool CancelScanning {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set this to TRUE to cancel scanning.
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImGearTWAINAfterPageEventArgs Members


Page Property (ImGearTWAINAfterPageEventArgs)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINAfterPageEventArgs Class : Page Property
Gets ImGearPage object containing the page just scanned.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearTWAINAfterPageEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImGearTWAINAfterPageEventArgs Members
ImGearPage Class


PageNumber Property (ImGearTWAINAfterPageEventArgs)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINAfterPageEventArgs Class : PageNumber Property
Gets number of page just scanned. The first page is number 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearTWAINAfterPageEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImGearTWAINAfterPageEventArgs Members


PendCount Property

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINAfterPageEventArgs Class : PendCount Property
Gets number of pages remaining to be scanned. -1 if unknown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PendCount As Integer
'Usage

Dim instance As ImGearTWAINAfterPageEventArgs
Dim value As Integer

value = instance.PendCount
public int PendCount {get;}
public: __property int get_PendCount();
public:
property int PendCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAINAfterPageEventArgs Class
ImGearTWAINAfterPageEventArgs Members


%%PageItemTitle%%

ImGearTWAINBeforePageEventArgs Class
Members

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINBeforePageEventArgs Class
Contains arguments for the ImGearTWAIN.BeforePage event.
Object Model
ImGearTWAINBeforePageEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearTWAINBeforePageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearTWAINBeforePageEventArgs
public class ImGearTWAINBeforePageEventArgs : System.EventArgs
public __gc class ImGearTWAINBeforePageEventArgs : public System.EventArgs
public ref class ImGearTWAINBeforePageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.TWAIN.ImGearTWAINBeforePageEventArgs

See Also

Reference

ImGearTWAINBeforePageEventArgs Members
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Members$$

ImGearTWAINBeforePageEventArgs Class Members
Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINBeforePageEventArgs Class

The following tables list the members exposed by ImGearTWAINBeforePageEventArgs.

Public Properties
 | Name | Description
Public Property | CancelScanning | Gets or sets a value indicating whether to cancel scanning.
Public Property | PageNumber | Gets number of page about to be scanned. The first page is number 1.
Top
See Also

Reference

ImGearTWAINBeforePageEventArgs Class
ImageGear.TWAIN Namespace


%%PageItemTitle%% $$Properties$$

ImGearTWAINBeforePageEventArgs Class Properties

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINBeforePageEventArgs Class

For a list of all members of this type, see ImGearTWAINBeforePageEventArgs members.

Public Properties
 | Name | Description
Public Property | CancelScanning | Gets or sets a value indicating whether to cancel scanning.
Public Property | PageNumber | Gets number of page about to be scanned. The first page is number 1.
Top
See Also

Reference

ImGearTWAINBeforePageEventArgs Class
ImageGear.TWAIN Namespace


CancelScanning Property (ImGearTWAINBeforePageEventArgs)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINBeforePageEventArgs Class : CancelScanning Property
Gets or sets a value indicating whether to cancel scanning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CancelScanning As Boolean
'Usage

Dim instance As ImGearTWAINBeforePageEventArgs
Dim value As Boolean

instance.CancelScanning = value

value = instance.CancelScanning
public bool CancelScanning {get; set;}
public: __property bool get_CancelScanning();
public: __property void set_CancelScanning(
   bool value
);
public:
property bool CancelScanning {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Set this to TRUE to cancel scanning.
See Also

Reference

ImGearTWAINBeforePageEventArgs Class
ImGearTWAINBeforePageEventArgs Members


PageNumber Property (ImGearTWAINBeforePageEventArgs)

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace > ImGearTWAINBeforePageEventArgs Class : PageNumber Property
Gets number of page about to be scanned. The first page is number 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearTWAINBeforePageEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearTWAINBeforePageEventArgs Class
ImGearTWAINBeforePageEventArgs Members


%%PageItemTitle%%

ImGearAlarms Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearAlarms Enumeration
This enumeration determines specific audible alarms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAlarms
   Inherits System.Enum
'Usage

Dim instance As ImGearAlarms
public enum ImGearAlarms : System.Enum
__value public enum ImGearAlarms : public System.Enum
public enum class ImGearAlarms : public System.Enum
Members
Member | Value | Description
ALARM | 0 | Catch-all for alarms not explicitly listed. It is also used where a device only provides control over a single, multi-use alarm.
BARCODE | 3 | Barcode alarm.
DOUBLEFEED | 4 | Cover paper handling errors.
FEEDERERROR | 1 | Covers paper handling errors such as jams, double-feeds, skewing and the like; conditions that most likely stop scanning.
FEEDERWARNING | 2 | Covers non-fatal events, such as feeder empty.
JAM | 5 | Cover paper handling errors.
PATCHCODE | 6 | Patchcode alarm.
POWER | 7 | Generates alarms for any changes in power to the device.
SKEW | 8 | Cover paper handling errors.
Remarks
ImGearCapabilities.CAP_ALARMS capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearAlarms

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearAudioFormats Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearAudioFormats Enumeration
This enumeration determines which Audio file formats are supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAudioFormats
   Inherits System.Enum
'Usage

Dim instance As ImGearAudioFormats
public enum ImGearAudioFormats : System.Enum
__value public enum ImGearAudioFormats : public System.Enum
public enum class ImGearAudioFormats : public System.Enum
Members
Member | Value | Description
AIFF | 1 | AIFF format.
AU | 3 | AU format.
SND | 4 | SND format.
WAV | 0 | WAV format.
Remarks
ImGearCapabilities.ACAP_AUDIOFILEFORMAT capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearAudioFormats

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearBarcodeRotation Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearBarcodeRotation Enumeration
The bar code's orientation on the scanned image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBarcodeRotation
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeRotation
public enum ImGearBarcodeRotation : System.Enum
__value public enum ImGearBarcodeRotation : public System.Enum
public enum class ImGearBarcodeRotation : public System.Enum
Members
Member | Value | Description
ROT0 | 0 | No rotation.
ROT180 | 2 | Rotation on 180 degrees.
ROT270 | 3 | Rotation on 270 degrees.
ROT90 | 1 | Rotation on 90 degrees.
ROTX | 4 | Rotation on 360 degrees.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearBarcodeRotation

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearBarcodeSearchModes Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearBarcodeSearchModes Enumeration
This enumeration restricts barcode searching to certain orientations, or prioritizes one orientation over the other.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBarcodeSearchModes
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeSearchModes
public enum ImGearBarcodeSearchModes : System.Enum
__value public enum ImGearBarcodeSearchModes : public System.Enum
public enum class ImGearBarcodeSearchModes : public System.Enum
Members
Member | Value | Description
HORZ | 0 | Horizontal mode.
HORZVERT | 2 | Horizontal/Vertical mode.
VERT | 1 | Vertical mode.
VERTHORZ | 3 | Vertical/Horizontal mode.
Remarks
ImGearCapabilities.ICAP_BARCODESEARCHMODE capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearBarcodeSearchModes

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearBarcodeType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearBarcodeType Enumeration
This enumeration lists different bar code types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBarcodeType
   Inherits System.Enum
'Usage

Dim instance As ImGearBarcodeType
public enum ImGearBarcodeType : System.Enum
__value public enum ImGearBarcodeType : public System.Enum
public enum class ImGearBarcodeType : public System.Enum
Members
Member | Value | Description
B2OF5DATALOGIC | 15 | B2OF5DATALOGIC barcode type.
B2OF5IATA | 16 | B2OF5IATA barcode type.
B2OF5INDUSTRIAL | 13 | B2OF5INDUSTRIAL barcode type.
B2OF5INTERLEAVED | 1 | B2OF5INTERLEAVED barcode type.
B2OF5MATRIX | 14 | B2OF5MATRIX barcode type.
B2OF5NONINTERLEAVED | 2 | B2OF5NONINTERLEAVED barcode type.
B3OF9 | 0 | B3OF9 barcode type.
B3OF9FULLASCII | 17 | B3OF9FULLASCII barcode type.
CODABAR | 6 | CODABAR barcode type.
CODABARWITHSTARTSTOP | 18 | CODABARWITHSTARTSTOP barcode type.
CODE128 | 4 | CODE128 barcode type.
CODE93 | 3 | CODE93 barcode type.
EAN13 | 10 | EAN13 barcode type.
EAN8 | 9 | EAN8 barcode type.
MAXICODE | 19 | MAXICODE barcode type.
PDF417 | 12 | PDF417 barcode type.
POSTNET | 11 | POSTNET barcode type.
UCC128 | 5 | UCC128 barcode type.
UPCA | 7 | UPCA barcode type.
UPCE | 8 | UPCE barcode type.
Remarks
ImGearCapabilities.ICAP_SUPPORTEDBARCODETYPES and ImGearCapabilities.ICAP_BARCODESEARCHPRIORITIES capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearBarcodeType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearBitDepthReduction Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearBitDepthReduction Enumeration
This enumeration specifies the Reduction method the Source should use to reduce the bit depth of the data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBitDepthReduction
   Inherits System.Enum
'Usage

Dim instance As ImGearBitDepthReduction
public enum ImGearBitDepthReduction : System.Enum
__value public enum ImGearBitDepthReduction : public System.Enum
public enum class ImGearBitDepthReduction : public System.Enum
Members
Member | Value | Description
CUSTHALFTONE | 2 | Custom Halftone method.
DIFFUSION | 3 | Diffusion method.
HALFTONE | 1 | Halftone method.
THRESHOLD | 0 | Threshold method.
Remarks
ImGearCapabilities.ICAP_BITDEPTHREDUCTION capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearBitDepthReduction

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearBitOrder Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearBitOrder Enumeration
This enumeration specifies how the bytes in an image are filled by the Source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearBitOrder
   Inherits System.Enum
'Usage

Dim instance As ImGearBitOrder
public enum ImGearBitOrder : System.Enum
__value public enum ImGearBitOrder : public System.Enum
public enum class ImGearBitOrder : public System.Enum
Members
Member | Value | Description
LSBFIRST | 0 | Least significant bit first.
MSBFIRST | 1 | Most significant bit first.
Remarks

MSBFIRST indicates that the leftmost bit in the byte (usually bit 7) is the byte's Most Significant Bit.

ImGearCapabilities.BITORDER capability values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearBitOrder

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearCapabilities Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCapabilities Enumeration
Supported capabilities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCapabilities
   Inherits System.Enum
'Usage

Dim instance As ImGearCapabilities
public enum ImGearCapabilities : System.Enum
__value public enum ImGearCapabilities : public System.Enum
public enum class ImGearCapabilities : public System.Enum
Members
Member | Value | Description
ACAP_AUDIOFILEFORMAT | 0x00001201 | Informs the application which audio file formats the Source can generate or tells the Source which audio file formats the application can handle. Uses ImGearAudioFormats values.
ACAP_XFERMECH | 0x00001202 | Allows the Application and Source to identify which audio transfer mechanisms they have in common.
CAP_ALARMS | 0x00001018 | Turns specific audible alarms on and off. Uses ImGearAlarms values.
CAP_ALARMVOLUME | 0x00001019 | The volume of a device’s audible alarm. Note that this control affects the volume of all alarms; no specific volume control for individual types of alarms is provided.
CAP_AUTHOR | 0x00001000 | The name or other identifying information about the Author of the image. It may include a copyright string.
CAP_AUTOFEED | 0x00001007 | Set to TRUE to enable Source’s automatic feeding.
CAP_AUTOMATICCAPTURE | 0x0000101A | The number of images to automatically capture. This does not refer to the number of images to be sent to the Application, use CAP_XFERCOUNT for that.
CAP_AUTOSCAN | 0x00001010 | Enables the source’s automatic document scanning process.
CAP_BATTERYMINUTES | 0x00001032 | The minutes of battery power remaining on a device.
CAP_BATTERYPERCENTAGE | 0x00001033 | Indicates battery power status.
CAP_CAMERAPREVIEWUI | 0x00001021 | Queries the source for UI support for preview mode.
CAP_CAPTION | 0x00001001 | A general note about the acquired image.
CAP_CLEARBUFFERS | 0x0000101D | Getting this reports the presence of data in the scanner’s buffers. Setting with a value of ImGearClearBuffers.CLEAR immediately clears the buffers. Uses ImGearClearBuffers values.
CAP_CLEARPAGE | 0x00001008 | Set to TRUE to eject current page and leave acquire area empty.
CAP_CUSTOMBASE | 0x00008000 | Base of custom capabilities.
CAP_CUSTOMDSDATA | 0x00001015 | Allows the application to query the data source to see if it supports the new operation triplets DG_CONTROL/DAT_CUSTOMDSDATA/MSG_GET and DG_CONTROL/DAT_CUSTOMDSDATA/MSG_SET.
CAP_DEVICEEVENT | 0x00001022 | Selects which events the application wants the source to report. Uses ImGearDeviceEvents values.
CAP_DEVICEONLINE | 0x0000100F | Determines if hardware is on and ready.
CAP_DEVICETIMEDATE | 0x0000101F | Date and time of a device’s clock.
CAP_DUPLEX | 0x00001012 | This indicates whether the scanner supports duplex. If so, it further indicates whether one-path or two-path duplex is supported. Uses ImGearDuplex values.
CAP_DUPLEXENABLED | 0x00001013 | The user can set the duplex option to be TRUE or FALSE. If TRUE, the scanner scans both sides of a paper; otherwise, the scanner will scan only one side of the image.
CAP_ENABLEDSUIONLY | 0x00001014 | Queries an application to see if it implements the new user interface settings dialog.
CAP_ENDORSER | 0x00001016 | Allows the application to specify the starting endorser / imprinter number.
CAP_EXTENDEDCAPS | 0x00001006 | Capabilities negotiated in States 5 & 6.
CAP_FEEDERALIGNMENT | 0x0000102D | If TRUE, feeder is centered; FALSE if it is free-floating. Uses ImGearFeederAlignment values.
CAP_FEEDERENABLED | 0x00001002 | If TRUE, Source’s feeder is available.
CAP_FEEDERLOADED | 0x00001003 | If TRUE, Source has documents loaded in feeder (get only).
CAP_FEEDERORDER | 0x0000102E | Specifies whether feeder starts with top of first or last page. Uses ImGearFeederOrder values.
CAP_FEEDPAGE | 0x00001009 | Set to TRUE to eject current page and feed next page.
CAP_INDICATORS | 0x0000100B | Use the Source’s progress indicator? (valid only when ShowUI==FALSE).
CAP_JOBCONTROL | 0x00001017 | Allows multiple jobs in batch mode.
CAP_LANGUAGE | 0x0000102C | Allows application and source to identify which languages they have in common. Uses ImGearLanguages values.
CAP_MAXBATCHBUFFERS | 0x0000101E | Describes the number of pages that the scanner can buffer when CAP_AUTOSCAN is enabled. Uses ImGearClearBuffers values.
CAP_PAPERDETECTABLE | 0x0000100D | Determines whether source can detect documents on the ADF or flatbed.
CAP_POWERSUPPLY | 0x00001020 | Get reports the kinds of power available; Current reports the current power supply to use. Uses ImGearPowerSupply values.
CAP_PRINTER | 0x00001026 | Gets current list of available printer devices; sets the device for negotiation. Uses ImGearPrinter values.
CAP_PRINTERENABLED | 0x00001027 | Turns the current CAP_PRINTER device on or off.
CAP_PRINTERINDEX | 0x00001028 | Starting number for the CAP_PRINTER device.
CAP_PRINTERMODE | 0x00001029 | Specifies appropriate current CAP_PRINTER device mode. Uses ImGearPrinterModes values.
CAP_PRINTERSTRING | 0x0000102A | String(s) to be used in the string component when CAP_PRINTER device is enabled.
CAP_PRINTERSUFFIX | 0x0000102B | String to be used as current CAP_PRINTER device’s suffix.
CAP_REACQUIREALLOWED | 0x00001030 | Undocumented TWAIN capability.
CAP_REWINDPAGE | 0x0000100A | Set to TRUE to do a reverse feed.
CAP_SERIALNUMBER | 0x00001024 | The serial number of the currently selected source device.
CAP_SUPPORTEDCAPS | 0x00001005 | Inquire valid capabilities for Source.
CAP_SUPPORTEDCAPSEXT | 0x0000100C | Undocumented TWAIN capability.
CAP_THUMBNAILSENABLED | 0x00001011 | Allows an application to request the delivery of thumbnail representations for the set of images that are to be delivered.
CAP_TIMEBEFOREFIRSTCAPTURE | 0x0000101B | Selects the number of seconds before the first picture taken.
CAP_TIMEBETWEENCAPTURES | 0x0000101C | Selects the hundredths of a second to wait between pictures taken.
CAP_TIMEDATE | 0x00001004 | Date and Time the image was acquired.
CAP_UICONTROLLABLE | 0x0000100E | Indicates that Source supports acquisitions with UI disabled.
CAP_XFERCOUNT | 0x00000001 | Number of images the application is willing to accept this session.
ICAP_AUTOBRIGHT | 0x00001100 | Enable Source’s Auto-brightness function.
ICAP_AUTOMATICBORDERDETECTION | 0x00001150 | Turns automatic border detection on and off.
ICAP_AUTOMATICDESKEW | 0x00001151 | Turns automatic skew detection on and off.
ICAP_AUTOMATICROTATE | 0x00001152 | When TRUE, depends on source to automatically rotate the image.
ICAP_BARCODEDETECTIONENABLED | 0x00001137 | Turns bar code detection on and off.
ICAP_BARCODEMAXRETRIES | 0x0000113C | Restricts the number of times a search will be retried if no bar codes are found.
ICAP_BARCODEMAXSEARCHPRIORITIES | 0x00001139 | Specifies the maximum number of supported search priorities.
ICAP_BARCODESEARCHMODE | 0x0000113B | Restricts bar code searching to certain orientations, or prioritizes one orientation over another. Uses ImGearBarcodeSearchModes values.
ICAP_BARCODESEARCHPRIORITIES | 0x0000113A | A prioritized list of bar code types dictating the order in which they will be sought. Uses ImGearBarcodeType values.
ICAP_BARCODETIMEOUT | 0x0000113D | Restricts the total time spent on searching for bar codes on a page.
ICAP_BITDEPTH | 0x0000112B | Pixel bit depth for Current value of ICAP_PIXELTYPE.
ICAP_BITDEPTHREDUCTION | 0x0000112C | Allows a choice of the reduction method for bit depth loss. Uses ImGearBitDepthReduction values.
ICAP_BITORDER | 0x0000111C | Specifies how the bytes in an image are filled by the Source. Uses ImGearBitOrder values.
ICAP_BITORDERCODES | 0x00001126 | CCITT Compression.
ICAP_BRIGHTNESS | 0x00001101 | Source brightness values.
ICAP_CCITTKFACTOR | 0x0000111D | CCITT Compression.
ICAP_COMPRESSION | 0x00000100 | Buffered Memory transfer compression schemes.
ICAP_CONTRAST | 0x00001103 | Source contrast values.
ICAP_CUSTHALFTONE | 0x00001104 | Square-cell halftone (dithering) matrix to be used.
ICAP_EXPOSURETIME | 0x00001105 | Exposure time used to capture the image, in seconds.
ICAP_EXTIMAGEINFO | 0x0000112F | Allows the application to query the data source to see if it supports the new operation triplet DG_IMAGE/DAT_EXTIMAGEINFO/MSG_GET.
ICAP_FILTER | 0x00001106 | Color characteristics of the subtractive filter applied to the image data. Uses ImGearFilterType values.
ICAP_FLASHUSED | 0x00001107 | Specifies whether or not the image was acquired using a flash.
ICAP_FLASHUSED2 | 0x00001146 | For devices that support a flash, setting selects the flash to be used; getting reports the current setting. Uses ImGearFlashUsed values.
ICAP_FLIPROTATION | 0x00001136 | Orients images that flip orientation every other image. Uses ImGearFlipRotation values.
ICAP_FRAMES | 0x00001114 | Size and location of frames on page.
ICAP_GAMMA | 0x00001108 | Gamma correction value for the image data.
ICAP_HALFTONES | 0x00001109 | Source halftone patterns.
ICAP_HIGHLIGHT | 0x0000110A | Lightest highlight, values lighter than this value will be set to this value.
ICAP_IMAGEDATASET | 0x0000112E | Gets or sets the image indices that will be delivered during the standard image transfer.
ICAP_IMAGEFILEFORMAT | 0x0000110C | File formats for file transfers.
ICAP_IMAGEFILTER | 0x00001147 | For devices that support image filtering, selects the algorithm to be used. Uses ImGearImageFilter values.
ICAP_JPEGPIXELTYPE | 0x00001128 | JPEG Compression.
ICAP_JPEGQUALITY | 0x00001153 | JPEG quality. Uses ImGearJPEGQuality values, or values in the range 0 - 100.
ICAP_LAMPSTATE | 0x0000110D | Whether the lamp is on.
ICAP_LIGHTPATH | 0x0000111E | Image was captured transmissively or reflectively. Uses ImGearLightPath values.
ICAP_LIGHTSOURCE | 0x0000110E | Describes the color characteristic of the light source used to acquire the image. Uses ImGearLightSource values.
ICAP_MAXFRAMES | 0x0000111A | Maximum number of frames possible per page.
ICAP_MINIMUMHEIGHT | 0x00001130 | Allows the source to define the minimum height (Y-axis) that the source can acquire.
ICAP_MINIMUMWIDTH | 0x00001131 | Allows the source to define the minimum width (X-axis) that the source can acquire.
ICAP_NOISEFILTER | 0x00001148 | For devices that support noise filtering, selects the algorithm to be used. Uses ImGearNoiseFilter values.
ICAP_ORIENTATION | 0x00001110 | Defines which edge of the paper is the top: Portrait or Landscape. Uses ImGearOrientation values.
ICAP_OVERSCAN | 0x00001149 | For devices that support overscanning, controls whether additional rows or columns are appended to the image. Uses ImGearOverscanModes values.
ICAP_PATCHCODEDETECTIONENABLED | 0x0000113F | Turns patch code detection on and off.
ICAP_PATCHCODEMAXRETRIES | 0x00001144 | Restricts the number of times a search will be retried if none are found on a page.
ICAP_PATCHCODEMAXSEARCHPRIORITIES | 0x00001141 | Maximum number of search priorities.
ICAP_PATCHCODESEARCHMODE | 0x00001143 | Restricts patch code searching to certain orientations, or prioritizes one orientation over another.
ICAP_PATCHCODESEARCHPRIORITIES | 0x00001142 | List of patch code types dictating the order in which patch codes will be sought. Uses ImGearPatchCode values.
ICAP_PATCHCODETIMEOUT | 0x00001145 | Restricts total time for searching for a patch code on a page.
ICAP_PHYSICALHEIGHT | 0x00001112 | Maximum height Source can acquire (in ICAP_UNITS).
ICAP_PHYSICALWIDTH | 0x00001111 | Maximum width Source can acquire (in ICAP_UNITS).
ICAP_PIXELFLAVOR | 0x0000111F | Sense of the pixel whose numeric value is zero. Uses ImGearPixelFlavor values.
ICAP_PIXELFLAVORCODES | 0x00001127 | CCITT Compression.
ICAP_PIXELTYPE | 0x00000101 | The type of pixel data (B/W, gray, color, etc.). Uses ImGearPixelType values.
ICAP_PLANARCHUNKY | 0x00001120 | Color data format - Planar or Chunky. Uses ImGearColorDataFormats values.
ICAP_ROTATION | 0x00001121 | Source can, or should, rotate image this number of degrees.
ICAP_SHADOW | 0x00001113 | Darkest shadow, values darker than this value will be set to this value.
ICAP_SUPPORTEDBARCODETYPES | 0x00001138 | Provides a list of bar code types that can be detected by current data source. Uses ImGearBarcodeType values.
ICAP_SUPPORTEDPATCHCODETYPES | 0x00001140 | List of patch code types that can be detected by current data source. Uses ImGearPatchCode values.
ICAP_SUPPORTEDSIZES | 0x00001122 | This specifies the size(s) the Source can/should use to acquire image data. Uses ImGearSupportedSizes values.
ICAP_THRESHOLD | 0x00001123 | Specifies the dividing line between black and white values.
ICAP_TILES | 0x0000111B | Tiled image data.
ICAP_TIMEFILL | 0x0000112A | CCITT Compression.
ICAP_UNDEFINEDIMAGESIZE | 0x0000112D | The application will accept undefined image size.
ICAP_UNITS | 0x00000102 | Unit of measure (inches, centimeters, etc.). Uses ImGearUnits values.
ICAP_XFERMECH | 0x00000103 | Transfer mechanism - used to learn options and set-up for upcoming transfer. Uses ImGearXferType values.
ICAP_XNATIVERESOLUTION | 0x00001116 | Native optical resolution of device for x-axis.
ICAP_XRESOLUTION | 0x00001118 | Current/Available optical resolutions for x-axis.
ICAP_XSCALING | 0x00001124 | Source Scaling value (1.0 = 100%) for x-axis.
ICAP_YNATIVERESOLUTION | 0x00001117 | Native optical resolution of device for y-axis.
ICAP_YRESOLUTION | 0x00001119 | Current/Available optical resolutions for y-axis.
ICAP_YSCALING | 0x00001125 | Source Scaling value (1.0 = 100%) for y-axis.
ICAP_ZOOMFACTOR | 0x0000113E | Gets all camera supported lens zooming range or sets the selected zoom value.
Remarks
This enumeration specifies ImageGear TWAIN capabilities.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearCapabilities

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearClearBuffers Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearClearBuffers Enumeration
This enumeration determines the type of buffer clearing process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearClearBuffers
   Inherits System.Enum
'Usage

Dim instance As ImGearClearBuffers
public enum ImGearClearBuffers : System.Enum
__value public enum ImGearClearBuffers : public System.Enum
public enum class ImGearClearBuffers : public System.Enum
Members
Member | Value | Description
AUTO | 0 | Causes the Source to automatically clear the buffers.
CLEAR | 1 | Causes the Source to immediately clear its buffers.
NOCLEAR | 2 | Causes the Source to preserve images in the buffers.
Remarks
ImGearCapabilities.CAP_CLEARBUFFERS capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearClearBuffers

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearColorDataFormats Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearColorDataFormats Enumeration
This enumeration allows the application and Source to identify which color data formats are available.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearColorDataFormats
   Inherits System.Enum
'Usage

Dim instance As ImGearColorDataFormats
public enum ImGearColorDataFormats : System.Enum
__value public enum ImGearColorDataFormats : public System.Enum
public enum class ImGearColorDataFormats : public System.Enum
Members
Member | Value | Description
CHUNKY | 0 | Chunky mode.
PLANAR | 1 | Planar mode.
Remarks

There are two options, planar and chunky. For example, planar RGB data is transferred with the entire red plane of data first, followed by the entire green plane, followed by the entire blue plane (typical for three-pass scanners). Chunky mode repetitively interlaces a pixel from each plane until all the data is transferred (R-G-B-R-G-B...) (typical for one-pass scanners).

ImGearCapabilities.ICAP_PLANARCHUNKY capability values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearColorDataFormats

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearContainerType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearContainerType Enumeration
Capability container type. Defines how the data for a capability is stored.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearContainerType
   Inherits System.Enum
'Usage

Dim instance As ImGearContainerType
public enum ImGearContainerType : System.Enum
__value public enum ImGearContainerType : public System.Enum
public enum class ImGearContainerType : public System.Enum
Members
Member | Value | Description
ARRAY | 3 | Indicates Array container.
ENUMERATION | 4 | Indicates enumeration container.
ONEVALUE | 5 | Indicates OneValue container.
RANGE | 6 | Indicates Range container.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearContainerType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearCountries Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearCountries Enumeration
Country constants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearCountries
   Inherits System.Enum
'Usage

Dim instance As ImGearCountries
public enum ImGearCountries : System.Enum
__value public enum ImGearCountries : public System.Enum
public enum class ImGearCountries : public System.Enum
Members
Member | Value | Description
AFGHANISTAN | 1001 | Country of Afghanistan.
ALBANIA | 355 | Country of Albania.
ALGERIA | 213 | Country of Algeria.
AMERICANSAMOA | 684 | Country of American Samoa.
ANDORRA | 33 | Country of Andorra.
ANGOLA | 1002 | Country of Angola.
ANGUILLA | 8090 | Country of Anguilla.
ANTIGUA | 8091 | Country of Antigua.
ARGENTINA | 54 | Country of Argentina.
ARMENIA | 374 | Country of Armenia.
ARUBA | 297 | Country of Aruba.
ASCENSIONI | 247 | Country of Ascensioni.
AUSTRALIA | 61 | Country of Australia.
AUSTRIA | 43 | Country of Austria.
AZERBAIJAN | 994 | Country of Azerbaijan.
BAHAMAS | 8092 | Country of Bahamas.
BAHRAIN | 973 | Country of Bahrain.
BANGLADESH | 880 | Country of Bangladesh.
BARBADOS | 8093 | Country of Barbados.
BELARUS | 375 | Country of Belarus.
BELGIUM | 32 | Country of Belgium.
BELIZE | 501 | Country of Belize.
BENIN | 229 | Country of Benin.
BERMUDA | 8094 | Country of Bermuda.
BHUTAN | 1003 | Country of Bhutan.
BOLIVIA | 591 | Country of Bolivia.
BOSNIAHERZGO | 387 | Country of Bosnia and Herzegovina.
BOTSWANA | 267 | Country of Botswana.
BRAZIL | 55 | Country of Brazil.
BRITAIN | 6 | Country of Britain.
BRITVIRGINIS | 8095 | Country of British Virgin Islands.
BRUNEI | 673 | Country of Brunei.
BULGARIA | 359 | Country of Bulgaria.
BURKINAFASO | 1004 | Country of Burkina Faso.
BURMA | 1005 | Country of Burma.
BURUNDI | 1006 | Country of Burundi.
CAMAROON | 237 | Country of Camaroon.
CAMBODIA | 855 | Country of Cambodia.
CANADA | 2 | Country of Canada.
CAPEVERDEIS | 238 | Country of Cape Verde Islands.
CAYMANIS | 8096 | Country of Cayman Islands.
CENTRALAFREP | 1007 | Country of Central African Republic.
CHAD | 1008 | Country of Chad.
CHILE | 56 | Country of Chile.
CHINA | 86 | Country of China.
CHRISTMASIS | 1009 | Country of Christmas Island.
COCOSIS | 1009 | Country of Cocos Island.
COLOMBIA | 57 | Country of Colombia.
COMOROS | 1010 | Country of Comoros.
CONGO | 1011 | Country of Congo.
COOKIS | 1012 | Country of Cook Islands.
COSTARICA | 506 | Country of Costa Rica.
CROATIA | 385 | Country of Croatia.
CUBA | 5 | Country of Cuba.
CYPRUS | 357 | Country of Cyprus.
CZECHOSLOVAKIA | 42 | Country of Czechoslovakia.
CZECHREPUBLIC | 420 | Country of Czech Republic.
DENMARK | 45 | Country of Denmark.
DIEGOGARCIA | 246 | Country of Diego Garcia.
DJIBOUTI | 1013 | Country of Djibouti.
DOMINCANREP | 8098 | Country of Dominican Republic.
DOMINICA | 8097 | Country of Dominica.
EASTERIS | 1014 | Country of Easter Island.
ECUADOR | 593 | Country of Ecuador.
EGYPT | 20 | Country of Egypt.
ELSALVADOR | 503 | Country of El Salvador.
EQGUINEA | 1015 | Country of Eqguinea.
ERITREA | 291 | Country of Eritrea.
ESTONIA | 372 | Country of Estonia.
ETHIOPIA | 251 | Country of Ethiopia.
FAEROEIS | 298 | Country of Faeroe Islands.
FALKLANDIS | 1016 | Country of Falkland Islands.
FIJIISLANDS | 679 | Country of Fiji Islands.
FINLAND | 358 | Country of Finland.
FRANCE | 33 | Country of France.
FRANTILLES | 596 | Country of French Antilles.
FRGUIANA | 594 | Country of French Guiana.
FRPOLYNEISA | 689 | Country of French Polyneisa.
FUTANAIS | 1043 | Country of Futana Islands.
GABON | 241 | Country of Gabon.
GAMBIA | 220 | Country of Gambia.
GEORGIA | 995 | Country of Georgia.
GERMANY | 49 | Country of Germany.
GHANA | 233 | Country of Ghana.
GIBRALTER | 350 | Country of Gibralter.
GREECE | 30 | Country of Greece.
GREENLAND | 299 | Country of Greenland.
GRENADA | 8099 | Country of Grenada.
GRENEDINES | 8015 | Country of Grenedines.
GUADELOUPE | 590 | Country of Guadeloupe.
GUAM | 671 | Country of Guam.
GUANTANAMOBAY | 5399 | Country of Guantanamo Bay.
GUATEMALA | 502 | Country of Guatemala.
GUINEA | 224 | Country of Guinea.
GUINEABISSAU | 1017 | Country of Guinea-Bissau.
GUYANA | 592 | Country of Guyana.
HAITI | 509 | Country of Haiti.
HONDURAS | 504 | Country of Honduras.
HONGKONG | 852 | Country of Hong Kong.
HUNGARY | 36 | Country of Hungary.
ICELAND | 354 | Country of Iceland.
INDIA | 91 | Country of India.
INDONESIA | 62 | Country of Indonesia.
IRAN | 98 | Country of Iran.
IRAQ | 964 | Country of Iraq.
IRELAND | 353 | Country of Ireland.
ISRAEL | 972 | Country of Israel.
ITALY | 39 | Country of Italy.
IVORYCOAST | 225 | Country of Ivory Coast.
JAMAICA | 8010 | Country of Jamaica.
JAPAN | 81 | Country of Japan.
JORDAN | 962 | Country of Jordan.
KENYA | 254 | Country of Kenya.
KIRIBATI | 1018 | Country of Kiribati.
KOREA | 82 | Country of Korea.
KUWAIT | 965 | Country of Kuwait.
LAOS | 1019 | Country of Laos.
LATVIA | 371 | Country of Latvia.
LEBANON | 1020 | Country of Lebanon.
LESOTHO | 266 | Country of Lesotho.
LIBERIA | 231 | Country of Liberia.
LIBYA | 218 | Country of Libya.
LIECHTENSTEIN | 41 | Country of Liechtenstein.
LITHUANIA | 370 | Country of Lithuania.
LUXENBOURG | 352 | Country of Luxenbourg.
MACAO | 853 | Country of Macao.
MACEDONIA | 389 | Country of Macedonia.
MADAGASCAR | 1021 | Country of Madagascar.
MALAWI | 265 | Country of Malawi.
MALAYSIA | 60 | Country of Malaysia.
MALDIVES | 960 | Country of Maldives.
MALI | 1022 | Country of Mali.
MALTA | 356 | Country of Malta.
MARSHALLIS | 692 | Country of Marshall Islands.
MAURITANIA | 1023 | Country of Mauritania.
MAURITIUS | 230 | Country of Mauritius.
MAYOTTEIS | 269 | Country of Mayotteis.
MEXICO | 3 | Country of Mexico.
MICRONESIA | 691 | Country of Micronesia.
MIQUELON | 508 | Country of Miquelon.
MOLDOVA | 373 | Country of Moldova.
MONACO | 33 | Country of Monaco.
MONGOLIA | 1024 | Country of Mongolia.
MONTSERRAT | 8011 | Country of Montserrat.
MOROCCO | 212 | Country of Morocco.
MOZAMBIQUE | 1025 | Country of Mozambique.
MYANMAR | 95 | Country of Myanmar.
NAMIBIA | 264 | Country of Namibia.
NAURU | 1026 | Country of Nauru.
NEPAL | 977 | Country of Nepal.
NETHANTILLES | 599 | Country of Neth Antilles.
NETHERLANDS | 31 | Country of Netherlands.
NEVIS | 8012 | Country of Nevis.
NEWCALEDONIA | 687 | Country of New Caledonia.
NEWZEALAND | 64 | Country of New Zealand.
NICARAGUA | 505 | Country of Nicaragua.
NIGER | 227 | Country of Niger.
NIGERIA | 234 | Country of Nigeria.
NIUE | 1027 | Country of Niue.
NORFOLKI | 1028 | Country of Norfolk.
NORTHKOREA | 850 | Country of North Korea.
NORWAY | 47 | Country of Norway.
OMAN | 968 | Country of Oman.
PAKISTAN | 92 | Country of Pakistan.
PALAU | 1029 | Country of Palau.
PANAMA | 507 | Country of Panama.
PARAGUAY | 595 | Country of Paraguay.
PERU | 51 | Country of Peru.
PHILLIPPINES | 63 | Country of Phillippines.
PITCAIRNIS | 1030 | Country of Pitcairn Islands.
PNEWGUINEA | 675 | Country of Papua New Guinea.
POLAND | 48 | Country of Poland.
PORTUGAL | 351 | Country of Portugal.
PUERTORICO | 787 | Country of Puerto Rico.
QATAR | 974 | Country of Qatar.
REUNIONI | 1031 | Country of Reunioni.
ROMANIA | 40 | Country of Romania.
RUSSIA | 7 | Country of Russia.
RWANDA | 250 | Country of Rwanda.
SAIPAN | 670 | Country of Saipan.
SANMARINO | 39 | Country of San Marino.
SAOTOME | 1033 | Country of Saotome.
SAUDIARABIA | 966 | Country of Saudi Arabia.
SENEGAL | 221 | Country of Senegal.
SERBIA | 381 | Country of Serbia.
SEYCHELLESIS | 1034 | Country of Seychellesis.
SIERRALEONE | 1035 | Country of Sierra Leone.
SINGAPORE | 65 | Country of Singapore.
SLOVAKIA | 421 | Country of Slovakia.
SLOVENIA | 386 | Country of Slovenia.
SOLOMONIS | 1036 | Country of Solomonis.
SOMALI | 1037 | Country of Somali.
SOUTHAFRICA | 27 | Country of South Africa.
SOUTHKOREA | 82 | Country of South Korea.
SPAIN | 34 | Country of Spain.
SRILANKA | 94 | Country of Sri Lanka.
STHELENA | 1032 | Country of St Helena.
STKITTS | 8013 | Country of St Kitts.
STLUCIA | 8014 | Country of St Lucia.
STPIERRE | 508 | Country of St Pierre.
STVINCENT | 8015 | Country of St Vincent.
SUDAN | 1038 | Country of Sudan.
SURINAME | 597 | Country of Suriname.
SWAZILAND | 268 | Country of Swaziland.
SWEDEN | 46 | Country of Sweden.
SWITZERLAND | 41 | Country of Switzerland.
SYRIA | 1039 | Country of Syria.
TAIWAN | 886 | Country of Taiwan.
TANZANIA | 255 | Country of Tanzania.
THAILAND | 66 | Country of Thailand.
TOBAGO | 8016 | Country of Tobago.
TOGO | 228 | Country of Togo.
TONGAIS | 676 | Country of Tongais.
TRINIDAD | 8016 | Country of Trinidad.
TUNISIA | 216 | Country of Tunisia.
TURKEY | 90 | Country of Turkey.
TURKSCAICOS | 8017 | Country of Turks Caicos.
TUVALU | 1040 | Country of Tuvalu.
UAEMIRATES | 971 | Country of United Arab Emirates.
UGANDA | 256 | Country of Uganda.
UKRAINE | 380 | Country of Ukraine.
UNITEDKINGDOM | 44 | Country of United Kkingdom.
URUGUAY | 598 | Country of Uruguay.
USA | 1 | Country of United Stats of America.
USSR | 7 | Country of Union of Soviet Socialist Republics.
USVIRGINIS | 340 | Country of US Virgin Islands.
VANUATU | 1041 | Country of Vanuatu.
VATICANCITY | 39 | Country of Vatican City.
VENEZUELA | 58 | Country of Venezuela.
VIETNAM | 84 | Country of Vietnam.
WAKE | 104 | Country of Wake.
WALLISIS | 1043 | Country of Wallisis.
WESTERNSAHARA | 1044 | Country of Western Sahara.
WESTERNSAMOA | 1045 | Country of Western Samoa.
YEMEN | 1046 | Country of Yemen.
YUGOSLAVIA | 38 | Country of Yugoslavia.
ZAIRE | 243 | Country of Zaire.
ZAMBIA | 260 | Country of Zambia.
ZIMBABWE | 263 | Country of Zimbabwe.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearCountries

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearDeskewStatus Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDeskewStatus Enumeration
Status of the deskew operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDeskewStatus
   Inherits System.Enum
'Usage

Dim instance As ImGearDeskewStatus
public enum ImGearDeskewStatus : System.Enum
__value public enum ImGearDeskewStatus : public System.Enum
public enum class ImGearDeskewStatus : public System.Enum
Members
Member | Value | Description
DISABLED | 3 | Deskew engine not enabled.
FAIL | 2 | Deskew failed.
REPORTONLY | 1 | Deskew information only.
SUCCESS | 0 | Image successfully deskewed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearDeskewStatus

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearDeviceEvents Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDeviceEvents Enumeration
This enumeration determines the device event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDeviceEvents
   Inherits System.Enum
'Usage

Dim instance As ImGearDeviceEvents
public enum ImGearDeviceEvents : System.Enum
__value public enum ImGearDeviceEvents : public System.Enum
public enum class ImGearDeviceEvents : public System.Enum
Members
Member | Value | Description
CHECKAUTOMATICCAPTURE | 0 | The automatic capture settings on the device have been changed by the user.
CHECKBATTERY | 1 | The status of the battery has changed.
CHECKDEVICEONLINE | 2 | The device has been turned off and on.
CHECKFLASH | 3 | The flash setting on the device has been changed by the user.
CHECKPOWERSUPPLY | 4 | The power supply has been changed.
CHECKRESOLUTION | 5 | The x/y resolution setting on the device has been changed by the user.
CUSTOMEVENTS | 32768 | Baseline for events specific to a given Source.
DEVICEADDED | 6 | The user has added a device (for instance a memory card in a digital camera).
DEVICEOFFLINE | 7 | A device has become unavailable, but has not been removed.
DEVICEREADY | 8 | The device is ready to capture an image.
DEVICEREMOVED | 9 | The user has removed a device.
IMAGECAPTURED | 10 | The user has captured an image to the device's internal storage.
IMAGEDELETED | 11 | The user has removed an image from the device's internal storage.
LAMPFAILURE | 14 | The device's light source has failed.
PAPERDOUBLEFEED | 12 | Two or more sheets of paper have been fed together.
PAPERJAM | 13 | The device's document feeder has jammed.
POWERSAVE | 15 | The device has powered down to save energy.
POWERSAVENOTIFY | 16 | The device is about to power down to save energy.
Remarks
ImGearCapabilities.CAP_DEVICEEVENT capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearDeviceEvents

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearDuplex Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearDuplex Enumeration
This enumeration determines whether the scanner supports duplex.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDuplex
   Inherits System.Enum
'Usage

Dim instance As ImGearDuplex
public enum ImGearDuplex : System.Enum
__value public enum ImGearDuplex : public System.Enum
public enum class ImGearDuplex : public System.Enum
Members
Member | Value | Description
NONE | 0 | No duplex support.
ONEPASSDUPLEX | 1 | One pass duplex is supported.
TWOPASSDUPLEX | 2 | Two pass duplex is supported.
Remarks
ImGearCapabilities.CAP_DUPLEX capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearDuplex

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFeederAlignment Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFeederAlignment Enumeration
This enumeration determines which special actions application may need to take when negotiating frames with the Source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFeederAlignment
   Inherits System.Enum
'Usage

Dim instance As ImGearFeederAlignment
public enum ImGearFeederAlignment : System.Enum
__value public enum ImGearFeederAlignment : public System.Enum
public enum class ImGearFeederAlignment : public System.Enum
Members
Member | Value | Description
CENTER | 2 | The alignment is centered. This means that the paper will be fed in the middle of the ICAP_PHYSICALWIDTH of the device.
LEFT | 1 | The alignment is to the left.
NONE | 0 | The alignment is free-floating.
RIGHT | 3 | The alignment is to the right.
Remarks
ImGearCapabilities.CAP_FEEDERALIGNMENT capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFeederAlignment

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFeederOrder Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFeederOrder Enumeration
This enumeration determines the order of scanning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFeederOrder
   Inherits System.Enum
'Usage

Dim instance As ImGearFeederOrder
public enum ImGearFeederOrder : System.Enum
__value public enum ImGearFeederOrder : public System.Enum
public enum class ImGearFeederOrder : public System.Enum
Members
Member | Value | Description
FIRSTPAGEFIRST | 0 | Feeder starts with the top of the first page.
LASTPAGEFIRST | 1 | Feeder starts with the top of the last page.
Remarks
ImGearCapabilities.CAP_FEEDERORDER capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFeederOrder

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFileSystem Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFileSystem Enumeration
This enumeration is for an undocumented TWAIN 1.8 capability.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFileSystem
   Inherits System.Enum
'Usage

Dim instance As ImGearFileSystem
public enum ImGearFileSystem : System.Enum
__value public enum ImGearFileSystem : public System.Enum
public enum class ImGearFileSystem : public System.Enum
Members
Member | Value | Description
FILESYSTEM | 0 | Undocumented TWAIN 1.8 FILESYSTEM value.
RECURSIVEDELETE | 1 | Undocumented TWAIN 1.8 FILESYSTEM value.
Remarks
ImGearCapabilities.CAP_FILESYSTEM capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFileSystem

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFileType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFileType Enumeration
File types in the device's file system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFileType
   Inherits System.Enum
'Usage

Dim instance As ImGearFileType
public enum ImGearFileType : System.Enum
__value public enum ImGearFileType : public System.Enum
public enum class ImGearFileType : public System.Enum
Members
Member | Value | Description
CAMERA | 0 | Camera file type.
CAMERABOTTOM | 2 | Camera bottom file type.
CAMERAPREVIEW | 3 | Camara preview file type.
CAMERATOP | 1 | Camera top file type.
DIRECTORY | 6 | Directory file type.
DOMAIN | 4 | Domain file type.
HOST | 5 | Host file type.
IMAGE | 7 | Image file type.
UNKNOWN | 8 | Unknown file type.
Remarks
ImGearFileInfo.Type values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFileType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFilterType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFilterType Enumeration
This enumeration determines the color characteristic of the subtractive filter applied to the image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFilterType
   Inherits System.Enum
'Usage

Dim instance As ImGearFilterType
public enum ImGearFilterType : System.Enum
__value public enum ImGearFilterType : public System.Enum
public enum class ImGearFilterType : public System.Enum
Members
Member | Value | Description
FT_BLACK | 8 | Black filter.
FT_BLUE | 2 | Blue filter.
FT_CYAN | 5 | Cyan filter.
FT_GREEN | 1 | Green filter.
FT_MAGENTA | 6 | Magenta filter.
FT_NONE | 3 | None filter.
FT_RED | 0 | Red filter.
FT_WHITE | 4 | White filter.
FT_YELLOW | 7 | Yellow filter.
Remarks
ImGearCapabilities.ICAP_FILTER capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFilterType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFlashUsed Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFlashUsed Enumeration
This enumeration determines which flash the image was acquired to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFlashUsed
   Inherits System.Enum
'Usage

Dim instance As ImGearFlashUsed
public enum ImGearFlashUsed : System.Enum
__value public enum ImGearFlashUsed : public System.Enum
public enum class ImGearFlashUsed : public System.Enum
Members
Member | Value | Description
AUTO | 3 | Auto flash.
NONE | 0 | No flash present.
OFF | 1 | Flash is off.
ON | 2 | Flash is on.
REDEYE | 4 | Redeye flash.
Remarks
ImGearCapabilities.ICAP_FLASHUSED2 capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFlashUsed

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearFlipRotation Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearFlipRotation Enumeration
This enumeration determines the orientation of images that flip orientation of every other image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearFlipRotation
   Inherits System.Enum
'Usage

Dim instance As ImGearFlipRotation
public enum ImGearFlipRotation : System.Enum
__value public enum ImGearFlipRotation : public System.Enum
public enum class ImGearFlipRotation : public System.Enum
Members
Member | Value | Description
BOOK | 0 | The images to be scanned are viewed in book form, flipping each page from left to right or right to left.
FANFOLD | 1 | The images to be scanned are viewed in fanfold paper style, flipping each page up or down.
Remarks
ImGearCapabilities.ICAP_FLIPROTATION capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearFlipRotation

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearImageFilter Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearImageFilter Enumeration
This enumeration determines the algorithm used to improve the quality of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearImageFilter
   Inherits System.Enum
'Usage

Dim instance As ImGearImageFilter
public enum ImGearImageFilter : System.Enum
__value public enum ImGearImageFilter : public System.Enum
public enum class ImGearImageFilter : public System.Enum
Members
Member | Value | Description
AUTO | 1 | Auto selectio nof algorithm.
BANDPASS | 3 | Bandpass algorithm. Good for improving text.
FINELINE | 4 | Fineline algorithm.
HIGHPASS | 4 | Highpass algorithm. Good for improving fine lines.
LOWPASS | 2 | Lowpass algorithm. Good for halftone images.
NONE | 0 | No algorithm.
TEXT | 3 | Text algorithm.
Remarks
ImGearCapabilities.ICAP_IMAGEFILTER capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearImageFilter

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearJobControl Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearJobControl Enumeration
This enumeration determines how the job can be processed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJobControl
   Inherits System.Enum
'Usage

Dim instance As ImGearJobControl
public enum ImGearJobControl : System.Enum
__value public enum ImGearJobControl : public System.Enum
public enum class ImGearJobControl : public System.Enum
Members
Member | Value | Description
JSIC | 1 | Detect and include job separator and continue scanning.
JSIS | 2 | Detect and include job separator and stop scanning.
JSXC | 3 | Detect and exclude job separator and continue scanning.
JSXS | 4 | Detect and exclude job separator and stop scanning.
NONE | 0 | No job control.
Remarks
ImGearCapabilities.CAP_JOBCONTROL capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearJobControl

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearJPEGQuality Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearJPEGQuality Enumeration
This enumeration specifies the kind of JPEG quantization tables that tradeoff quality versus compressed image size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearJPEGQuality
   Inherits System.Enum
'Usage

Dim instance As ImGearJPEGQuality
public enum ImGearJPEGQuality : System.Enum
__value public enum ImGearJPEGQuality : public System.Enum
public enum class ImGearJPEGQuality : public System.Enum
Members
Member | Value | Description
HIGH | -1 | Write-only; implies high quality; the images display the maximum quality that produces any kind of meaningful compression. Note that images at this setting are still considered to be lossy.
LOW | -3 | Write-only; implies low quality; the images are at the maximum compression recommended by the Source.
MEDIUM | -2 | Write-only; implies medium quality; the images are at the balance point between good compression and good images. This is an arbitrary setting on the part of the Source writer that is expected to best represent their device. This is the value that Applications are most encouraged to use.
UNKNOWN | -4 | Read-only; must be the setting for this capability if the user sets the JPEG compression tables using DAT_JPEGCOMPRESSION, and the Source is not able to map theselected tables to a specific percentage of quality.
Remarks
ImGearCapabilities.ICAP_JPEGQUALITY capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearJPEGQuality

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearLanguages Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearLanguages Enumeration
Language constants.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLanguages
   Inherits System.Enum
'Usage

Dim instance As ImGearLanguages
public enum ImGearLanguages : System.Enum
__value public enum ImGearLanguages : public System.Enum
public enum class ImGearLanguages : public System.Enum
Members
Member | Value | Description
AFRIKAANS | 14 | Afrikaans language.
ALBANIA | 15 | Albania language.
ARABIC | 16 | Arabic language.
ARABIC_ALGERIA | 17 | Arabic (Algeria) language.
ARABIC_BAHRAIN | 18 | Arabic (Bahrain) language.
ARABIC_EGYPT | 19 | Arabic (Egypt) language.
ARABIC_IRAQ | 20 | Arabic (Iraq) language.
ARABIC_JORDAN | 21 | Arabic (Jordan) language.
ARABIC_KUWAIT | 22 | Arabic (Kuwait) language.
ARABIC_LEBANON | 23 | Arabic (Lebanon) language.
ARABIC_LIBYA | 24 | Arabic (Libya) language.
ARABIC_MOROCCO | 25 | Arabic (Morocco) language.
ARABIC_OMAN | 26 | Arabic (Oman) language.
ARABIC_QATAR | 27 | Arabic (Qatar) language.
ARABIC_SAUDIARABIA | 28 | Arabic (Saudi Arabia) language.
ARABIC_SYRIA | 29 | Arabic (Syria) language.
ARABIC_TUNISIA | 30 | Arabic (Tunisia) language.
ARABIC_UAE | 31 | Arabic (United Arabic Emirates) language.
ARABIC_YEMEN | 32 | Arabic (Yemen) language.
ASSAMESE | 87 | Assamese language.
BASQUE | 33 | Basque language.
BENGALI | 88 | Bengali language.
BIHARI | 89 | Bihari language.
BODO | 90 | Bodo language.
BULGARIAN | 35 | Bulgarian language.
BYELORUSSIAN | 34 | Byelorussian language.
CATALAN | 36 | Catalan language.
CHINESE | 37 | Chinese language.
CHINESE_HONGKONG | 38 | Chinese (Hong Kong) language.
CHINESE_PRC | 39 | Chinese (People's Republic of China) language.
CHINESE_SIMPLIFIED | 41 | Chinese (Simplified) language.
CHINESE_SINGAPORE | 40 | Chinese (Singapore) language.
CHINESE_TAIWAN | 42 | Chinese (Twaiwan) language.
CHINESE_TRADITIONAL | 43 | Chinese (Traditional) language.
CROATIA | 44 | Crotia language.
CZECH | 45 | Czech language.
DAN | 0 | Danish language.
DANISH | 0 | Danish language.
DOGRI | 91 | Dogri language.
DUT | 1 | Dutch language.
DUTCH | 1 | Dutch language.
DUTCH_BELGIAN | 46 | Dutch (Belgian) language.
ENG | 2 | International English language.
ENGLISH | 2 | English language.
ENGLISH_AUSTRALIAN | 47 | English (Australian) language.
ENGLISH_CANADIAN | 48 | English (Canadian) language.
ENGLISH_IRELAND | 49 | English (Ireland) language.
ENGLISH_NEWZEALAND | 50 | English (New Zealand) language.
ENGLISH_SOUTHAFRICA | 51 | English (South Africa) language.
ENGLISH_UK | 52 | English (UK) language.
ENGLISH_USA | 13 | English (USA) language.
ESTONIAN | 53 | Estonian language.
FAEROESE | 54 | Faeroese language.
FARSI | 55 | Farsi language.
FCF | 3 | French Canadian language.
FIN | 4 | Finnish language.
FINNISH | 4 | Finnish language.
FRENCH | 5 | French language.
FRENCH_BELGIAN | 56 | French (Belgian) language.
FRENCH_CANADIAN | 3 | French (Canadian) language.
FRENCH_LUXEMBOURG | 57 | French (Luxembourg) language.
FRENCH_SWISS | 58 | French (Swiss) language.
FRN | 5 | French language.
GER | 6 | German language.
GERMAN | 6 | German language.
GERMAN_AUSTRIAN | 59 | German (Austrian) language.
GERMAN_LIECHTENSTEIN | 61 | German (Liechtenstein) language.
GERMAN_LUXEMBOURG | 60 | German (Luxembourg) language.
GERMAN_SWISS | 62 | German (Swiss) language.
GREEK | 63 | Greek language.
GUJARATI | 92 | Gujarati language.
HARYANVI | 93 | Haryanvi language.
HEBREW | 64 | Hebrew language.
HINDI | 94 | Hindi language.
HUNGARIAN | 65 | Hungarian language.
ICE | 7 | Icelandic language.
ICELANDIC | 7 | Icelandic language.
INDONESIAN | 66 | Indonesian language.
ITALIAN | 8 | Italian language.
ITALIAN_SWISS | 67 | Italian (Swiss) language.
ITN | 8 | Italian language.
JAPANESE | 68 | Japanese language.
KANNADA | 95 | Kannada language.
KASHMIRI | 96 | Kashmiri language.
KOREAN | 69 | Korean language.
KOREAN_JOHAB | 70 | Korean (Johab) language.
LATVIAN | 71 | Latvian language.
LITHUANIAN | 72 | Lithuanian language.
MALAYALAM | 97 | Malayalam language.
MARATHI | 98 | Marathi language.
MARWARI | 99 | Marwari language.
MEGHALAYAN | 100 | Meghalayan language.
MIZO | 101 | Mizo language.
NAGA | 102 | Naga language.
NOR | 9 | Norwegian language.
NORWEGIAN | 9 | Norwegian language.
NORWEGIAN_BOKMAL | 73 | Norwegian (Bokmal) language.
NORWEGIAN_NYNORSK | 74 | Norwegian (Nynorsk) language.
ORISSI | 103 | Orissi language.
POLISH | 75 | Polish language.
POR | 10 | Portuguese language.
PORTUGUESE | 10 | Portuguese language.
PORTUGUESE_BRAZIL | 76 | Portuguese (Brazil) language.
PUNJABI | 104 | Punjabi language.
PUSHTU | 105 | Pushtu language.
ROMANIAN | 77 | Romanian language.
RUSSIAN | 78 | Russian language.
SERBIAN_CYRILLIC | 106 | Serbian Cyrillic language.
SERBIAN_LATIN | 79 | Serbian Latin language.
SIKKIMI | 107 | Sikkimi language.
SLOVAK | 80 | Slovak language.
SLOVENIAN | 81 | Slovenian language.
SPA | 11 | Spanish language.
SPANISH | 11 | Spanish language.
SPANISH_MEXICAN | 82 | Spanish (Mexican) language.
SPANISH_MODERN | 83 | Spanish (Modern) language.
SWE | 12 | Swedish language.
SWEDISH | 12 | Swedish language.
SWEDISH_FINLAND | 108 | Swedish (Finland) language.
TAMIL | 109 | Tamil language.
TELUGU | 110 | Telugu language.
THAI | 84 | Thai language.
TRIPURI | 111 | Tripuri language.
TURKISH | 85 | Turkish language.
UKRANIAN | 86 | Ukranian language.
URDU | 112 | Urdu language.
USA | 13 | English (USA) language.
USERLOCALE | -1 | User Locale language.
VIETNAMESE | 113 | Vietnamese language.
Remarks
This enumeration specifies language of the scanned document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearLanguages

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearLightPath Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearLightPath Enumeration
This enumeration determines whether the image is captured transmissively or reflectively.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLightPath
   Inherits System.Enum
'Usage

Dim instance As ImGearLightPath
public enum ImGearLightPath : System.Enum
__value public enum ImGearLightPath : public System.Enum
public enum class ImGearLightPath : public System.Enum
Members
Member | Value | Description
REFLECTIVE | 0 | Reflective capture.
TRANSMISSIVE | 1 | Transmissive capture.
Remarks
ImGearCapabilities.ICAP_LIGHTPATH capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearLightPath

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearLightSource Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearLightSource Enumeration
This enumeration determines the general color characteristic of the light source used to acquire the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearLightSource
   Inherits System.Enum
'Usage

Dim instance As ImGearLightSource
public enum ImGearLightSource : System.Enum
__value public enum ImGearLightSource : public System.Enum
public enum class ImGearLightSource : public System.Enum
Members
Member | Value | Description
BLUE | 2 | Blue light source.
GREEN | 1 | Green light source.
IR | 6 | Infrared light source.
NONE | 3 | None light source.
RED | 0 | Red light source.
UV | 5 | Ultraviolet light source.
WHITE | 4 | White light source.
Remarks
ImGearCapabilities.ICAP_LIGHTSOURCE capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearLightSource

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearMessages Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearMessages Enumeration
Capability control messages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMessages
   Inherits System.Enum
'Usage

Dim instance As ImGearMessages
public enum ImGearMessages : System.Enum
__value public enum ImGearMessages : public System.Enum
public enum class ImGearMessages : public System.Enum
Members
Member | Value | Description
GET | 1 | Get one or more values.
GETCURRENT | 2 | Get current value.
GETDEFAULT | 3 | Get default (e.g., power up) value.
RESET | 7 | Set current value to default value.
SET | 6 | Set one or more values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearMessages

See Also

Reference

ImageGear.TWAIN Namespace
ImGearTWAIN.GetCapability
ImGearTWAIN.SetCapability


%%PageItemTitle%%

ImGearNoiseFilter Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearNoiseFilter Enumeration
This enumeration selects the algorithm used to remove noise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearNoiseFilter
   Inherits System.Enum
'Usage

Dim instance As ImGearNoiseFilter
public enum ImGearNoiseFilter : System.Enum
__value public enum ImGearNoiseFilter : public System.Enum
public enum class ImGearNoiseFilter : public System.Enum
Members
Member | Value | Description
AUTO | 1 | Automatic noise removal.
LONEPIXEL | 2 | Lone pixel noise removal.
MAJORITYRULE | 3 | Majority rule noise removal.
NONE | 0 | No noise removal.
Remarks
ImGearCapabilities.ICAP_NOISEFILTER capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearNoiseFilter

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearOrientation Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearOrientation Enumeration
This enumeration determines which edge of the paper the image's top is aligned with.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearOrientation
   Inherits System.Enum
'Usage

Dim instance As ImGearOrientation
public enum ImGearOrientation : System.Enum
__value public enum ImGearOrientation : public System.Enum
public enum class ImGearOrientation : public System.Enum
Members
Member | Value | Description
LANDSCAPE | 3 | Landscape orientation.
PORTRAIT | 0 | Portrait orientation.
ROT0 | 0 | Normal orientation.
ROT180 | 2 | Rotated 180 degrees clockwise orientation.
ROT270 | 3 | Rotated 270 degrees clockwise orientation.
ROT90 | 1 | Rotated 90 degrees clockwise orientation.
Remarks
ImGearCapabilities.ICAP_ORIENTATION capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearOrientation

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearOverscanModes Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearOverscanModes Enumeration
This enumeration determines the overscanning mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearOverscanModes
   Inherits System.Enum
'Usage

Dim instance As ImGearOverscanModes
public enum ImGearOverscanModes : System.Enum
__value public enum ImGearOverscanModes : public System.Enum
public enum class ImGearOverscanModes : public System.Enum
Members
Member | Value | Description
ALL | 4 | Overscan all.
AUTO | 1 | Auto mode.
LEFTRIGHT | 3 | Left-Right mode.
NONE | 0 | No overscan.
TOPBOTTOM | 2 | Top-Bottom mode.
Remarks
ImGearCapabilities.ICAP_OVERSCAN capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearOverscanModes

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPatchCode Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPatchCode Enumeration
This enumeration lists different patch code types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPatchCode
   Inherits System.Enum
'Usage

Dim instance As ImGearPatchCode
public enum ImGearPatchCode : System.Enum
__value public enum ImGearPatchCode : public System.Enum
public enum class ImGearPatchCode : public System.Enum
Members
Member | Value | Description
PATCH1 | 0 | Patch 1 patch code.
PATCH2 | 1 | Patch 2 patch code.
PATCH3 | 2 | Patch 3 patch code.
PATCH4 | 3 | Patch 4 patch code.
PATCH6 | 4 | Patch 6 patch code.
PATCHT | 5 | Patch T patch code.
Remarks
ImGearCapabilities.ICAP_SUPPORTEDPATCHCODETYPES and ImGearCapabilities.ICAP_PATCHCODESEARCHPRIORITIES capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPatchCode

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPixelFlavor Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPixelFlavor Enumeration
This enumeration correctly describes the sense of the pixel whose numeric value is zero (minimum data value).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPixelFlavor
   Inherits System.Enum
'Usage

Dim instance As ImGearPixelFlavor
public enum ImGearPixelFlavor : System.Enum
__value public enum ImGearPixelFlavor : public System.Enum
public enum class ImGearPixelFlavor : public System.Enum
Members
Member | Value | Description
CHOCOLATE | 0 | Zero pixel represents darkest shade.
VANILLA | 1 | Zero pixel represents lightest shade.
Remarks
ImGearCapabilities.ICAP_PIXELFLAVOR capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPixelFlavor

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPixelType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPixelType Enumeration
This enumeration specifies the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPixelType
   Inherits System.Enum
'Usage

Dim instance As ImGearPixelType
public enum ImGearPixelType : System.Enum
__value public enum ImGearPixelType : public System.Enum
public enum class ImGearPixelType : public System.Enum
Members
Member | Value | Description
BW | 0 | Black and white pixel type.
CIEXYZ | 8 | CIEXYZ pixel type.
CMY | 4 | CMY pixel type.
CMYK | 5 | CMYK pixel type.
GRAY | 1 | Gray pixel type.
PALETTE | 3 | Palette pixel type.
RGB | 2 | RGB pixel type.
YUV | 6 | YUV pixel type.
YUVK | 7 | YUVK pixel type.
Remarks
ImGearCapabilities.ICAP_PIXELTYPE capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPixelType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPowerSupply Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPowerSupply Enumeration
This enumeration reports the kinds of power available to the device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPowerSupply
   Inherits System.Enum
'Usage

Dim instance As ImGearPowerSupply
public enum ImGearPowerSupply : System.Enum
__value public enum ImGearPowerSupply : public System.Enum
public enum class ImGearPowerSupply : public System.Enum
Members
Member | Value | Description
BATTERY | 1 | Battery supply.
EXTERNAL | 0 | External supply.
Remarks
ImGearCapabilities.CAP_POWERSUPPLY capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPowerSupply

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPrinter Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPrinter Enumeration
This enumeration determines the printer devices being used by application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPrinter
   Inherits System.Enum
'Usage

Dim instance As ImGearPrinter
public enum ImGearPrinter : System.Enum
__value public enum ImGearPrinter : public System.Enum
public enum class ImGearPrinter : public System.Enum
Members
Member | Value | Description
ENDORSERBOTTOMAFTER | 7 | Endorser bottom/after.
ENDORSERBOTTOMBEFORE | 6 | Endorser bottom/before.
ENDORSERTOPAFTER | 5 | Endorser top/after.
ENDORSERTOPBEFORE | 4 | Endorser top/before.
IMPRINTERBOTTOMAFTER | 3 | Imprinter bottom/after.
IMPRINTERBOTTOMBEFORE | 2 | Imprinter bottom/before.
IMPRINTERTOPAFTER | 1 | Imprinter top/after.
IMPRINTERTOPBEFORE | 0 | Imprinter top/before.
Remarks

Imprinters are used to print data on documents at the time of scanning, and may be used for any purpose. Endorsers are more specific in nature, stamping some kind of proof of scanning on the document.

Top/Bottom refer to duplex devices, and indicate if the printer is writing on the top or the bottom of the sheet of paper. Simplex devices use the top settings.

Before/After indicates whether printing occurs before or after the sheet of paper has been scanned.

ImGearCapabilities.CAP_PRINTER capability values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPrinter

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearPrinterModes Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearPrinterModes Enumeration
This enumeration specifies current printer mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPrinterModes
   Inherits System.Enum
'Usage

Dim instance As ImGearPrinterModes
public enum ImGearPrinterModes : System.Enum
__value public enum ImGearPrinterModes : public System.Enum
public enum class ImGearPrinterModes : public System.Enum
Members
Member | Value | Description
COMPOUNDSTRING | 2 | The printed string will consist of a compound of a String followed by a value followed by a suffix string.
MULTISTRING | 1 | The printed text will consist of an enumerated list of strings to be printed in order.
SINGLESTRING | 0 | The printed text will consist of a single string.
Remarks
ImGearCapabilities.CAP_PRINTERMODE capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearPrinterModes

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearSupportedSizes Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearSupportedSizes Enumeration
This enumeration specifies the size(s) the Source can/should use to acquire image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSupportedSizes
   Inherits System.Enum
'Usage

Dim instance As ImGearSupportedSizes
public enum ImGearSupportedSizes : System.Enum
__value public enum ImGearSupportedSizes : public System.Enum
public enum class ImGearSupportedSizes : public System.Enum
Members
Member | Value | Description
A0 | 19 | A0 size paper.
A02 | 18 | A02 size paper.
A04 | 17 | A04 size paper.
A1 | 20 | A1 size paper.
A10 | 25 | A10 size paper.
A2 | 21 | A2 size paper.
A3 | 11 | A3 size paper.
A4 | 1 | A4 size paper.
A4LETTER | 1 | A4 Letter size paper.
A5 | 5 | A5 size paper.
A6 | 13 | A6 size paper.
A7 | 22 | A7 size paper.
A8 | 23 | A8 size paper.
A9 | 24 | A9 size paper.
B3 | 12 | B3 size paper.
B4 | 6 | B4 size paper.
B5LETTER | 2 | B5 Letter size paper.
B6 | 7 | B6 size paper.
BUSINESSCARD | 53 | Business Card size paper.
C0 | 44 | C0 size paper.
C1 | 45 | C1 size paper.
C10 | 51 | C10 size paper.
C2 | 46 | C2 size paper.
C3 | 47 | C3 size paper.
C4 | 14 | C4 size paper.
C5 | 15 | C5 size paper.
C6 | 16 | C6 size paper.
C7 | 48 | C7 size paper.
C8 | 49 | C8 size paper.
C9 | 50 | C9 size paper.
ISOB0 | 26 | ISO B0 size paper.
ISOB1 | 27 | ISO B1 size paper.
ISOB10 | 33 | ISO B10 size paper.
ISOB2 | 28 | ISO B2 size paper.
ISOB3 | 12 | ISO B3 size paper.
ISOB4 | 6 | ISO B4 size paper.
ISOB5 | 29 | ISO B5 size paper.
ISOB6 | 7 | ISO B6 size paper.
ISOB7 | 30 | ISO B7 size paper.
ISOB8 | 31 | ISO B8 size paper.
ISOB9 | 32 | ISO B9 size paper.
JISB0 | 34 | JIS B0 size paper.
JISB1 | 35 | JIS B1 size paper.
JISB10 | 43 | JIS B10 size paper.
JISB2 | 36 | JIS B2 size paper.
JISB3 | 37 | JIS B3 size paper.
JISB4 | 38 | JIS B4 size paper.
JISB5 | 2 | JIS B5 size paper.
JISB6 | 39 | JIS B6 size paper.
JISB7 | 40 | JIS B7 size paper.
JISB8 | 41 | JIS B8 size paper.
JISB9 | 42 | JIS B9 size paper.
NONE | 0 | No supported size paper.
USEXECUTIVE | 10 | US Executive size paper.
USLEDGER | 9 | US Ledger size paper.
USLEGAL | 4 | US Legal size paper.
USLETTER | 3 | US Letter size paper.
USSTATEMENT | 52 | US Statement size paper.
Remarks
ImGearCapabilities.ICAP_SUPPORTEDSIZES capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearSupportedSizes

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearUnits Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearUnits Enumeration
This enumeration determines the unit of measure for all quantities.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearUnits
   Inherits System.Enum
'Usage

Dim instance As ImGearUnits
public enum ImGearUnits : System.Enum
__value public enum ImGearUnits : public System.Enum
public enum class ImGearUnits : public System.Enum
Members
Member | Value | Description
CENTIMETERS | 1 | Centimeters units.
INCHES | 0 | Inches units.
PICAS | 2 | Picas units.
PIXELS | 5 | Pixels units.
POINTS | 3 | Points units.
TWIPS | 4 | Twips units.
Remarks
ImGearCapabilities.ICAP_UNITS capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearUnits

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearXferType Enumeration

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearXferType Enumeration
This enumeration determines which type of transfer mechanisms the application and Source have in common.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearXferType
   Inherits System.Enum
'Usage

Dim instance As ImGearXferType
public enum ImGearXferType : System.Enum
__value public enum ImGearXferType : public System.Enum
public enum class ImGearXferType : public System.Enum
Members
Member | Value | Description
FILE | 1 | File type.
FILE2 | 3 | File to File type.
MEMORY | 2 | Memory type.
NATIVE | 0 | Native type.
Remarks
ImGearCapabilities.ICAP_XFERMECH capability values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.TWAIN.ImGearXferType

See Also

Reference

ImageGear.TWAIN Namespace


%%PageItemTitle%%

ImGearTWAINAfterPageEventHandler Delegate
Example Example

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINAfterPageEventHandler Delegate
Object which triggered the event.
Data about the event.
This is the delegate used to pass ImGearTWAIN.AfterPage events on to an application event handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearTWAINAfterPageEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearTWAINAfterPageEventArgs _
)
'Usage

Dim instance As New ImGearTWAINAfterPageEventHandler(AddressOf HandlerMethod)
public delegate void ImGearTWAINAfterPageEventHandler(
   object sender,
   ImGearTWAINAfterPageEventArgs e
)
public: __gc __delegate void ImGearTWAINAfterPageEventHandler(
   Object* sender,
   ImGearTWAINAfterPageEventArgs* e
)
public delegate void ImGearTWAINAfterPageEventHandler(
   Object^ sender,
   ImGearTWAINAfterPageEventArgs^ e
)

Parameters

sender
Object which triggered the event.
e
Data about the event.
Remarks

The delegate follows the standard .NET event model. The AfterPage event occurs after scanning a page. It provides the page number to be scanned and gives an opportunity to cancel scanning.

Here's an example of typical AfterPage event registration and declaration:

Example
  • C#
// Event Registration
ImGearTWAIN imGearTWAIN = new ImGearTWAIN();
imGearTWAIN.AfterPage += new ImGearTWAINAfterPageEventHandler(imGearTWAIN_AfterPage);
  • C#
// Event Declaration
void imGearTWAIN_AfterPage(object sender, ImGearTWAINAfterPageEventArgs e)
{
    // Access event arguments via ImGearTWAINAfterPageEventArgs e
}
See Also

Reference

ImGearTWAINAfterPageEventHandler Members
ImageGear.TWAIN Namespace
ImGearTWAINAfterPageEventArgs Class


%%PageItemTitle%%

ImGearTWAINBeforePageEventHandler Delegate
Example Example

ImageGear22.Twain Assembly > ImageGear.TWAIN Namespace : ImGearTWAINBeforePageEventHandler Delegate
Object which triggered the event.
Data about the event.
This is the delegate used to pass ImGearTWAIN.BeforePage events on to an application event handler.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearTWAINBeforePageEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearTWAINBeforePageEventArgs _
)
'Usage

Dim instance As New ImGearTWAINBeforePageEventHandler(AddressOf HandlerMethod)
public delegate void ImGearTWAINBeforePageEventHandler(
   object sender,
   ImGearTWAINBeforePageEventArgs e
)
public: __gc __delegate void ImGearTWAINBeforePageEventHandler(
   Object* sender,
   ImGearTWAINBeforePageEventArgs* e
)
public delegate void ImGearTWAINBeforePageEventHandler(
   Object^ sender,
   ImGearTWAINBeforePageEventArgs^ e
)

Parameters

sender
Object which triggered the event.
e
Data about the event.
Remarks

The delegate follows the standard .NET event model. The ImGearTWAIN.BeforePage event occurs before scanning a page. It provides the page number to be scanned and gives an opportunity to cancel scanning.

Here's an example of typical ImGearTWAIN.BeforePage event registration and declaration:

Example
  • C#
// Event Registration
ImGearTWAIN imGearTWAIN = new ImGearTWAIN();
imGearTWAIN.BeforePage += new ImGearTWAINBeforePageEventHandler(imGearTWAIN_BeforePage);
  • C#
// Event Declaration
void imGearTWAIN_BeforePage(object sender, ImGearTWAINBeforePageEventArgs e)
{
    // Access event arguments via ImGearTWAINBeforePageEventArgs e
}
See Also

Reference

ImGearTWAINBeforePageEventHandler Members
ImageGear.TWAIN Namespace
ImGearTWAINBeforePageEventArgs Class


ImageGear22.Web Assembly
Namespaces
Namespace | Description
ImageGear.Web.UI | The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.


ImageGear.Web.UI Namespace (ImageGear22.Web)
Inheritance Hierarchy
ImageGear22.Web Assembly : ImageGear.Web.UI Namespace
The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.
Classes
 | Class | Description
Class | ImGearSelectionPage | This class represents information required for specifying selected pages in the ImgearThumbnialList control.
Class | ImGearThumbnailList | This class describes the server side ImGearThumbnailList control for viewing a list of document pages represented as thumbnails.
Class | PageView | This class describes the server side PageView control.
Class | ThumbnailView | This class describes the server side ThumbnailView control.
Enumerations
 | Enumeration | Description
Enumeration | ArtEnableOption | Option values for enabling annotations on images.
Enumeration | ClientDebugErrorLevel | Option values for error logging on the client side.
Enumeration | FitType | Option values to determine if the image fit is within the PageView control.
Enumeration | ImGearArtDataServices | Specifies Options for using Art Data services.
Enumeration | ImGearDataBindingType | Specifies page or document level binding.
Enumeration | ImGearThumbnailLayout | Specifies the layout and scroll directions of thumbnails in the control.
Enumeration | ImGearThumbnailSelectionMode | Specifies Thumbnail Selection mode.
Enumeration | MouseTool | Option values used to determine mouse tool selected. Each of these tools will determine a cursor and the behavior of the left mouse button. This enumeration indicates how the viewer should act when a user interacts with it using a mouse.
Enumeration | Rotation | Option values for image rotation.
Enumeration | ScrollBars | Option values to determine how scrollbars should be handled in the Client PageView control at runtime.
Enumeration | VectorFormatsRendering | Specifies the vector format rendering way.
See Also

Reference

ImageGear22.Web Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.UI Namespace (ImageGear22.Web) Inheritance Hierarchy
ImageGear22.Web Assembly : ImageGear.Web.UI Namespace
Inheritance Hierarchy
System.Object
ImageGear.Web.UI.ImGearSelectionPage
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.ScriptControl
ImageGear.Web.UI.PageView
ImageGear.Web.UI.ThumbnailView
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
ImageGear.Web.UI.ImGearThumbnailList
See Also

Reference

ImageGear22.Web Assembly


%%PageItemTitle%%

ImGearSelectionPage Class
Members

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearSelectionPage Class
This class represents information required for specifying selected pages in the ImgearThumbnialList control.
Object Model
ImGearSelectionPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSelectionPage
'Usage

Dim instance As ImGearSelectionPage
public class ImGearSelectionPage
public __gc class ImGearSelectionPage
public ref class ImGearSelectionPage
Remarks

The control ImGearThumbnailList property ImGearThumbnailList.SelectedPages is a collection of Objects of this type.

Inheritance Hierarchy

System.Object
ImageGear.Web.UI.ImGearSelectionPage

See Also

Reference

ImGearSelectionPage Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ImGearSelectionPage Class Members
Properties

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearSelectionPage Class

The following tables list the members exposed by ImGearSelectionPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearSelectionPage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DocumentIdentifier | Gets or sets document identifier for the document.
Public Property | PageNumber | Gets or sets page number for the page that needs to be selected.
Top
See Also

Reference

ImGearSelectionPage Class
ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImGearSelectionPage Constructor

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearSelectionPage Class : ImGearSelectionPage Constructor
Overload List
Overload | Description
ImGearSelectionPage Constructor() | Class constructor without any parameters
ImGearSelectionPage Constructor(String,Int32) | A constructor for creating ImGearSelectionPage object.
See Also

Reference

ImGearSelectionPage Class
ImGearSelectionPage Members


%%PageItemTitle%%

ImGearSelectionPage Constructor()

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearSelectionPage Class > ImGearSelectionPage Constructor : ImGearSelectionPage Constructor()
Class constructor without any parameters
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearSelectionPage()
public ImGearSelectionPage()
public: ImGearSelectionPage();
public:
ImGearSelectionPage();
See Also

Reference

ImGearSelectionPage Class
ImGearSelectionPage Members
Overload List


%%PageItemTitle%%

ImGearSelectionPage Constructor(String,Int32)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearSelectionPage Class > ImGearSelectionPage Constructor : ImGearSelectionPage Constructor(String,Int32)
Document identifier of the document to which the page belongs.
Page number for the page that needs to be selected.
A constructor for creating ImGearSelectionPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal documentIdentifier As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim documentIdentifier As String
Dim pageNumber As Integer

Dim instance As New ImGearSelectionPage(documentIdentifier, pageNumber)
public ImGearSelectionPage(
   string documentIdentifier,
   int pageNumber
)
public: ImGearSelectionPage(
   string* documentIdentifier,
   int pageNumber
)
public:
ImGearSelectionPage(
   String^ documentIdentifier,
   int pageNumber
)

Parameters

documentIdentifier
Document identifier of the document to which the page belongs.
pageNumber
Page number for the page that needs to be selected.
Remarks
This is an alternative constructor that takes the two properties as parameters.
See Also

Reference

ImGearSelectionPage Class
ImGearSelectionPage Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearSelectionPage Class Properties

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearSelectionPage Class

For a list of all members of this type, see ImGearSelectionPage members.

Public Properties
 | Name | Description
Public Property | DocumentIdentifier | Gets or sets document identifier for the document.
Public Property | PageNumber | Gets or sets page number for the page that needs to be selected.
Top
See Also

Reference

ImGearSelectionPage Class
ImageGear.Web.UI Namespace


DocumentIdentifier Property (ImGearSelectionPage)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearSelectionPage Class : DocumentIdentifier Property
Gets or sets document identifier for the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentIdentifier As String
'Usage

Dim instance As ImGearSelectionPage
Dim value As String

instance.DocumentIdentifier = value

value = instance.DocumentIdentifier
public string DocumentIdentifier {get; set;}
public: __property string* get_DocumentIdentifier();
public: __property void set_DocumentIdentifier(
   string* value
);
public:
property String^ DocumentIdentifier {
   String^ get();
   void set (    String^ value);
}
Remarks
The default value is an empty string;
See Also

Reference

ImGearSelectionPage Class
ImGearSelectionPage Members


PageNumber Property (ImGearSelectionPage)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearSelectionPage Class : PageNumber Property
Gets or sets page number for the page that needs to be selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ImGearSelectionPage
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}
Remarks
The default value is 0;
See Also

Reference

ImGearSelectionPage Class
ImGearSelectionPage Members


%%PageItemTitle%%

ImGearThumbnailList Class
Members

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailList Class
This class describes the server side ImGearThumbnailList control for viewing a list of document pages represented as thumbnails.
Object Model
ImGearThumbnailList Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")>
<ToolboxBitmapAttribute()>
<ToolboxDataAttribute("<{0}:ImGearThumbnailList runat=server Width="149px" Height="600px" ></{0}:ImGearThumbnailList>")>
Public Class ImGearThumbnailList
   Inherits System.Web.UI.WebControls.DataBoundControl
'Usage

Dim instance As ImGearThumbnailList
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
[ToolboxData("<{0}:ImGearThumbnailList runat=server Width="149px" Height="600px" ></{0}:ImGearThumbnailList>")]
public class ImGearThumbnailList : System.Web.UI.WebControls.DataBoundControl
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
[ToolboxData("<{0}:ImGearThumbnailList runat=server Width="149px" Height="600px" ></{0}:ImGearThumbnailList>")]
public __gc class ImGearThumbnailList : public System.Web.UI.WebControls.DataBoundControl
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
[ToolboxData("<{0}:ImGearThumbnailList runat=server Width="149px" Height="600px" ></{0}:ImGearThumbnailList>")]
public ref class ImGearThumbnailList : public System.Web.UI.WebControls.DataBoundControl
Remarks

This control is a visual representation of a list of image thumbnails. In normal web based image viewer applications, you will need to have one ImGearThumbnailList control on your web page for images(pages) in documents pages you wish to display as thumbnails.

This control optionally allows you to use your own CSS class definitions for the display of the control and the thumbnails within it. By default, it uses the built in style.

This control can be used either from the server or the client side. On the server side it can be specified in an .aspx page in the Visual Studio editor or dragging it from the Visual Studio tool box to your .aspx page.

A ImGearThumbnialList control contains a list of thumbnail images. These images may belong to one or more multi-page/single page documents or pages selected out of several documents.

Using the server side approach to creating the control lets you bind images from a data source to the control. This databinding approach is as provided in .NET. You can create a list of images from any .NET supported data source and bind this list to the control. The data sources can either be an Xml file,local variables or databases. For more details and examples, see, Data Binding to the Server Side ImGearThumbnailList Control.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
ImageGear.Web.UI.ImGearThumbnailList

See Also

Reference

ImGearThumbnailList Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailList Class Members
Properties Methods Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailList Class

The following tables list the members exposed by ImGearThumbnailList.

Public Properties
 | Name | Description
Public Property | ArtDataServiceOption | Gets or sets a value indicating the service option required for handling annoations data.
Public Property | ClientDebug | Gets or sets a value indicating whether client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client ImGearThumbnailList control will log.
Public Property | DataBindingType | Gets or sets a value indicationg image data binding type in the ImGearThumbnailList control for the image list provided.
Public Property | DocumentCaptionField | Gets or sets document caption field for data binding.
Public Property | DocumentIdentifierField | Gets or sets the DocumentIdentifier field.
Public Property | ImageServicePath | Gets or sets the RESTful WCF image service path.
Public Property | IncludeAllPages | Gets or sets whether all pages in multipage documenta are to be included.
Public Property | Layout | Gets or sets a value indicationg thumbnails layout in the ImGearThumbnailList control.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive event whenever the user releases a mouse button while the cursor is over any part of the ImGearThumbnailList control.
Public Property | OnPageAddFailed | Gets or sets user defined Javascript event handler to receive a call to the client 'pageAddFailed' event.
Public Property | OnPageSelectionChanged | Gets or sets user defined Javascript event handler to receive a call to the client thumbnailSelectionChanged event.
Public Property | OnPropertyChanged | Gets or sets user defined JavaScript event handler to receive a call to the propertyChanged event.
Public Property | PageCaptionField | Gets or sets page caption field for data binding.
Public Property | PageNumberField | Gets or sets the Image Page number field. This property refers to the page number in a multipage document to be displayed in the ImGearThumbnailList control.
Public Property | PageViewClientId | Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
Public Property | SelectedPages | Gets a collection of ImGearSelectionPage objects containing information about pages required to be selected at startup.
Public Property | ThumbnailBackgroundColor | Gets or sets the background color for the thumbnails displayed when in an non-selected state in the control.
Public Property | ThumbnailBorderColor | Gets or sets the for the border color for thumbnails displayed in the control.
Public Property | ThumbnailBorderWidth | Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
Public Property | ThumbnailCaptionFormat | Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
Public Property | ThumbnailHeight | Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
Public Property | ThumbnailSelectedBackgroundColor | Gets or sets the background color for the selected thumbnails displayed in the control.
Public Property | ThumbnailSelectionMode | Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
Public Property | ThumbnailWidth | Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
Public Property | UseDefaultStyling | Gets or sets the default visual style for the thumbnails and their contents.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed in the control.
Public Property | YSpacing | Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Properties$$

ImGearThumbnailList Class Properties

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

Public Properties
 | Name | Description
Public Property | ArtDataServiceOption | Gets or sets a value indicating the service option required for handling annoations data.
Public Property | ClientDebug | Gets or sets a value indicating whether client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client ImGearThumbnailList control will log.
Public Property | DataBindingType | Gets or sets a value indicationg image data binding type in the ImGearThumbnailList control for the image list provided.
Public Property | DocumentCaptionField | Gets or sets document caption field for data binding.
Public Property | DocumentIdentifierField | Gets or sets the DocumentIdentifier field.
Public Property | ImageServicePath | Gets or sets the RESTful WCF image service path.
Public Property | IncludeAllPages | Gets or sets whether all pages in multipage documenta are to be included.
Public Property | Layout | Gets or sets a value indicationg thumbnails layout in the ImGearThumbnailList control.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive event whenever the user releases a mouse button while the cursor is over any part of the ImGearThumbnailList control.
Public Property | OnPageAddFailed | Gets or sets user defined Javascript event handler to receive a call to the client 'pageAddFailed' event.
Public Property | OnPageSelectionChanged | Gets or sets user defined Javascript event handler to receive a call to the client thumbnailSelectionChanged event.
Public Property | OnPropertyChanged | Gets or sets user defined JavaScript event handler to receive a call to the propertyChanged event.
Public Property | PageCaptionField | Gets or sets page caption field for data binding.
Public Property | PageNumberField | Gets or sets the Image Page number field. This property refers to the page number in a multipage document to be displayed in the ImGearThumbnailList control.
Public Property | PageViewClientId | Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
Public Property | SelectedPages | Gets a collection of ImGearSelectionPage objects containing information about pages required to be selected at startup.
Public Property | ThumbnailBackgroundColor | Gets or sets the background color for the thumbnails displayed when in an non-selected state in the control.
Public Property | ThumbnailBorderColor | Gets or sets the for the border color for thumbnails displayed in the control.
Public Property | ThumbnailBorderWidth | Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
Public Property | ThumbnailCaptionFormat | Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
Public Property | ThumbnailHeight | Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
Public Property | ThumbnailSelectedBackgroundColor | Gets or sets the background color for the selected thumbnails displayed in the control.
Public Property | ThumbnailSelectionMode | Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
Public Property | ThumbnailWidth | Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
Public Property | UseDefaultStyling | Gets or sets the default visual style for the thumbnails and their contents.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed in the control.
Public Property | YSpacing | Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Methods$$

ImGearThumbnailList Class Methods

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

See Also

Reference

ImGearThumbnailList Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Events$$

ImGearThumbnailList Class Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

See Also

Reference

ImGearThumbnailList Class
ImageGear.Web.UI Namespace


ArtDataServiceOption Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ArtDataServiceOption Property
Gets or sets a value indicating the service option required for handling annoations data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("An enumeration value representing options for displaying and/or saving annotations.")>
<DefaultValueAttribute()>
<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
Public Property ArtDataServiceOption As ImGearArtDataServices
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearArtDataServices

instance.ArtDataServiceOption = value

value = instance.ArtDataServiceOption
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public ImGearArtDataServices ArtDataServiceOption {get; set;}
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public: __property ImGearArtDataServices get_ArtDataServiceOption();
public: __property void set_ArtDataServiceOption(
   ImGearArtDataServices value
);
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public:
property ImGearArtDataServices ArtDataServiceOption {
   ImGearArtDataServices get();
   void set (    ImGearArtDataServices value);
}

Property Value

The enumeration value that represents, ImGearArtDataServices. It represents options for services to be used for fetching and saving annotations (Art Data) from the server.
Remarks
This property specifies the option for handling annotations data. It must be set to one of the values in the enumeration ImGearArtDataServices.

The default value is ImageGear.Web.UI.ArtDataServices.ArtDataService

. indicating the ImageGear Art data service will be used to obtain annotations data from the server.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ClientDebug Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ClientDebug Property
Gets or sets a value indicating whether client side error logging is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets a value indicating whether client side error logging is enabled.")>
<CategoryAttribute("Clientside Error logging Properties")>
<DefaultValueAttribute()>
Public Property ClientDebug As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim value As Boolean

instance.ClientDebug = value

value = instance.ClientDebug
[Browsable(true)]
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[DefaultValue()]
public bool ClientDebug {get; set;}
[Browsable(true)]
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[DefaultValue()]
public: __property bool get_ClientDebug();
public: __property void set_ClientDebug(
   bool value
);
[Browsable(true)]
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[DefaultValue()]
public:
property bool ClientDebug {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value.
Remarks
Turns on or off the Client side error logging. The default value is 'false'.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ClientDebugErrorLevel Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ClientDebugErrorLevel Property
Gets or sets the amount of information the Client ImGearThumbnailList control will log.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("An enumeration value representing the amount of information the Client ImGearThumbnailList control will log.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Clientside Error logging Properties")>
Public Property ClientDebugErrorLevel As ClientDebugErrorLevel
'Usage

Dim instance As ImGearThumbnailList
Dim value As ClientDebugErrorLevel

instance.ClientDebugErrorLevel = value

value = instance.ClientDebugErrorLevel
[Description("An enumeration value representing the amount of information the Client ImGearThumbnailList control will log.")]
[Browsable(true)]
[DefaultValue()]
[Category("Clientside Error logging Properties")]
public ClientDebugErrorLevel ClientDebugErrorLevel {get; set;}
[Description("An enumeration value representing the amount of information the Client ImGearThumbnailList control will log.")]
[Browsable(true)]
[DefaultValue()]
[Category("Clientside Error logging Properties")]
public: __property ClientDebugErrorLevel get_ClientDebugErrorLevel();
public: __property void set_ClientDebugErrorLevel(
   ClientDebugErrorLevel value
);
[Description("An enumeration value representing the amount of information the Client ImGearThumbnailList control will log.")]
[Browsable(true)]
[DefaultValue()]
[Category("Clientside Error logging Properties")]
public:
property ClientDebugErrorLevel ClientDebugErrorLevel {
   ClientDebugErrorLevel get();
   void set (    ClientDebugErrorLevel value);
}

Property Value

One of the values ClientDebugErrorLevel.
Remarks
The default value is 'Production'.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


DataBindingType Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : DataBindingType Property
Gets or sets a value indicationg image data binding type in the ImGearThumbnailList control for the image list provided.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the data binding type.")>
Public Property DataBindingType As ImGearDataBindingType
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearDataBindingType

instance.DataBindingType = value

value = instance.DataBindingType
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the data binding type.")]
public ImGearDataBindingType DataBindingType {get; set;}
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the data binding type.")]
public: __property ImGearDataBindingType get_DataBindingType();
public: __property void set_DataBindingType(
   ImGearDataBindingType value
);
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the data binding type.")]
public:
property ImGearDataBindingType DataBindingType {
   ImGearDataBindingType get();
   void set (    ImGearDataBindingType value);
}

Property Value

One of value of type ImGearDataBindingType
Remarks

The default value is ImGearDataBindingType.Document.

For details about how to use the data binding feature, refer to the section, Data Binding to the Server Side ImGearThumbnailList Control.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


DocumentCaptionField Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : DocumentCaptionField Property
Gets or sets document caption field for data binding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets document caption field for data binding.")>
Public Property DocumentCaptionField As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.DocumentCaptionField = value

value = instance.DocumentCaptionField
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets document caption field for data binding.")]
public string DocumentCaptionField {get; set;}
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets document caption field for data binding.")]
public: __property string* get_DocumentCaptionField();
public: __property void set_DocumentCaptionField(
   string* value
);
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets document caption field for data binding.")]
public:
property String^ DocumentCaptionField {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

The default value is an empty string

This defines the field name for document caption for data binding For details about data binding, refer to the section, Data Binding to the Server Side ImGearThumbnailList Control.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


DocumentIdentifierField Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : DocumentIdentifierField Property
Gets or sets the DocumentIdentifier field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("This property refers to the data binding field .")>
Public Property DocumentIdentifierField As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.DocumentIdentifierField = value

value = instance.DocumentIdentifierField
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("This property refers to the data binding field .")]
public string DocumentIdentifierField {get; set;}
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("This property refers to the data binding field .")]
public: __property string* get_DocumentIdentifierField();
public: __property void set_DocumentIdentifierField(
   string* value
);
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("This property refers to the data binding field .")]
public:
property String^ DocumentIdentifierField {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

The default value is ”DocumentIdentifier”

This property refers to the image file path or the image URL field for data binding see, Data Binding to the Server Side ImGearThumbnailList Control. ///

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ImageServicePath Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ImageServicePath Property
Gets or sets the RESTful WCF image service path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets RESTful WCF image service path.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ImGearThumbnailList Properties")>
<DefaultValueAttribute()>
Public Property ImageServicePath As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.ImageServicePath = value

value = instance.ImageServicePath
[Description("Gets or sets RESTful WCF image service path.")]
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
public string ImageServicePath {get; set;}
[Description("Gets or sets RESTful WCF image service path.")]
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
public: __property string* get_ImageServicePath();
public: __property void set_ImageServicePath(
   string* value
);
[Description("Gets or sets RESTful WCF image service path.")]
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
public:
property String^ ImageServicePath {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks
The value provided must be a fully qualified URL (absolute URL), a relative URL is not acceptable. Note: It is not necessary to have this property defined if the ImageServicePath setting already exists in the web.config file.

The default value is “~/ImageGearService.svc”

This property is a string that contains the name of the RESTful WCF service path that obtains and processes images on the server.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


IncludeAllPages Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : IncludeAllPages Property
Gets or sets whether all pages in multipage documenta are to be included.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("ImgearThumbnailList Properties")>
<DescriptionAttribute("Gets a collection of ImGearSelectionPage objects.")>
Public Property IncludeAllPages As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim value As Boolean

instance.IncludeAllPages = value

value = instance.IncludeAllPages
[Browsable(true)]
[DefaultValue()]
[Category("ImgearThumbnailList Properties")]
[Description("Gets a collection of ImGearSelectionPage objects.")]
public bool IncludeAllPages {get; set;}
[Browsable(true)]
[DefaultValue()]
[Category("ImgearThumbnailList Properties")]
[Description("Gets a collection of ImGearSelectionPage objects.")]
public: __property bool get_IncludeAllPages();
public: __property void set_IncludeAllPages(
   bool value
);
[Browsable(true)]
[DefaultValue()]
[Category("ImgearThumbnailList Properties")]
[Description("Gets a collection of ImGearSelectionPage objects.")]
public:
property bool IncludeAllPages {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value.
Remarks

The default value is true

Note: This property value will be ignored when binding at the page level.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


Layout Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : Layout Property
Gets or sets a value indicationg thumbnails layout in the ImGearThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the thumbnails layout required in the ImGearThumbnailList control.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property Layout As ImGearThumbnailLayout
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearThumbnailLayout

instance.Layout = value

value = instance.Layout
[Description("Gets or sets the thumbnails layout required in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
[Browsable(true)]
public ImGearThumbnailLayout Layout {get; set;}
[Description("Gets or sets the thumbnails layout required in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
[Browsable(true)]
public: __property ImGearThumbnailLayout get_Layout();
public: __property void set_Layout(
   ImGearThumbnailLayout value
);
[Description("Gets or sets the thumbnails layout required in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
[DefaultValue()]
[Browsable(true)]
public:
property ImGearThumbnailLayout Layout {
   ImGearThumbnailLayout get();
   void set (    ImGearThumbnailLayout value);
}

Property Value

One of value of type ImGearThumbnailLayout
Remarks

The default value is ImGearThumbnailLayout.VerticalScrollDirection.

To display thumbnails in a grid format, use the option ImGearThumbnailLayout.VerticalScrollDirection. This mode will also display thumbnails in a single vertical column. For this, make sure that the width of your control is just a little wider than the thumbnail width plus allowances for the scroll bar and spacing on each side of the thumbnail(XSpacing and YSpacing in the default mode styling).

To display thumbnails in a single horizontal row, choose the ImGearThumbnailLayout.HorizontalScrollDirection option.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnMouseDown Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnMouseDown Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")>
<DefaultValueAttribute()>
<CategoryAttribute("Client ImGearThumbnailList Control Events")>
Public Property OnMouseDown As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnMouseDown = value

value = instance.OnMouseDown
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
public string OnMouseDown {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
public: __property string* get_OnMouseDown();
public: __property void set_OnMouseDown(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
public:
property String^ OnMouseDown {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks
The string value is the name of the Javascript event handler name.

The default value is an empty string

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnMouseMove Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnMouseMove Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client ImGearThumbnailList Control Events")>
<DefaultValueAttribute()>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")>
Public Property OnMouseMove As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnMouseMove = value

value = instance.OnMouseMove
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public string OnMouseMove {get; set;}
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public: __property string* get_OnMouseMove();
public: __property void set_OnMouseMove(
   string* value
);
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public:
property String^ OnMouseMove {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks
The string value is the name of the Javascript event handler name.

The default value is an empty string

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnMouseUp Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnMouseUp Property
Gets or sets user defined Javascript event handler to receive event whenever the user releases a mouse button while the cursor is over any part of the ImGearThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")>
<CategoryAttribute("Client ImGearThumbnailList Control Events")>
<DefaultValueAttribute()>
Public Property OnMouseUp As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnMouseUp = value

value = instance.OnMouseUp
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public string OnMouseUp {get; set;}
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public: __property string* get_OnMouseUp();
public: __property void set_OnMouseUp(
   string* value
);
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public:
property String^ OnMouseUp {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks
The string value is the name of the Javascript event handler name.

The default value is an empty string

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnPageAddFailed Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnPageAddFailed Property
Gets or sets user defined Javascript event handler to receive a call to the client 'pageAddFailed' event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client addPageFailed Event.")>
<CategoryAttribute("Client ImGearThumbnailList Control Events")>
<DefaultValueAttribute()>
Public Property OnPageAddFailed As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnPageAddFailed = value

value = instance.OnPageAddFailed
[Description("A user defined Javascript event handler to receive a call to the Client addPageFailed Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public string OnPageAddFailed {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client addPageFailed Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public: __property string* get_OnPageAddFailed();
public: __property void set_OnPageAddFailed(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client addPageFailed Event.")]
[Category("Client ImGearThumbnailList Control Events")]
[DefaultValue()]
public:
property String^ OnPageAddFailed {
   String^ get();
   void set (    String^ value);
}

Property Value

string value
Remarks
The string value is the name of the Javascript event handler name. This event will be raised when the client control fails to add a page to the ThumbnailList.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnPageSelectionChanged Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnPageSelectionChanged Property
Gets or sets user defined Javascript event handler to receive a call to the client thumbnailSelectionChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("ImGearThumbnailList Client Events")>
<DescriptionAttribute("Gets or sets user defined Javascript event handler to receive a call to the client pageSelectionChanged event.")>
Public Property OnPageSelectionChanged As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnPageSelectionChanged = value

value = instance.OnPageSelectionChanged
[DefaultValue()]
[Category("ImGearThumbnailList Client Events")]
[Description("Gets or sets user defined Javascript event handler to receive a call to the client pageSelectionChanged event.")]
public string OnPageSelectionChanged {get; set;}
[DefaultValue()]
[Category("ImGearThumbnailList Client Events")]
[Description("Gets or sets user defined Javascript event handler to receive a call to the client pageSelectionChanged event.")]
public: __property string* get_OnPageSelectionChanged();
public: __property void set_OnPageSelectionChanged(
   string* value
);
[DefaultValue()]
[Category("ImGearThumbnailList Client Events")]
[Description("Gets or sets user defined Javascript event handler to receive a call to the client pageSelectionChanged event.")]
public:
property String^ OnPageSelectionChanged {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value
Remarks
The string value is the name of the Javascript event handler name.

The default value is an empty string

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnPropertyChanged Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : OnPropertyChanged Property
Gets or sets user defined JavaScript event handler to receive a call to the propertyChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("Client ImGearThumbnailList Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the propertyChanged event.")>
Public Property OnPropertyChanged As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.OnPropertyChanged = value

value = instance.OnPropertyChanged
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public string OnPropertyChanged {get; set;}
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public: __property string* get_OnPropertyChanged();
public: __property void set_OnPropertyChanged(
   string* value
);
[DefaultValue()]
[Category("Client ImGearThumbnailList Control Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public:
property String^ OnPropertyChanged {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks
The string value is the name of the Javascript event handler name.

The default value is an empty string

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


PageCaptionField Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : PageCaptionField Property
Gets or sets page caption field for data binding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets page caption field for data binding.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public Property PageCaptionField As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.PageCaptionField = value

value = instance.PageCaptionField
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets page caption field for data binding.")]
[Category("ImGearThumbnailList Properties")]
public string PageCaptionField {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets page caption field for data binding.")]
[Category("ImGearThumbnailList Properties")]
public: __property string* get_PageCaptionField();
public: __property void set_PageCaptionField(
   string* value
);
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets page caption field for data binding.")]
[Category("ImGearThumbnailList Properties")]
public:
property String^ PageCaptionField {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

The default value is "Page"

This defines the field name for page caption for data binding details see, Data Binding to the Server Side ImGearThumbnailList Control

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


PageNumberField Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : PageNumberField Property
Gets or sets the Image Page number field. This property refers to the page number in a multipage document to be displayed in the ImGearThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("The page number of a multipage document to be displayed. A single page document has a value zero(0).")>
Public Property PageNumberField As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.PageNumberField = value

value = instance.PageNumberField
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
public string PageNumberField {get; set;}
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
public: __property string* get_PageNumberField();
public: __property void set_PageNumberField(
   string* value
);
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
public:
property String^ PageNumberField {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

The default value is ”PageNumber”

This property is used for data binding purpose. It can be an attribute in an xml file or a database field when databinding source is a database (for details about data binding, refer to ImGearThumbnailList class description and the section Data Binding to the Server Side ImGearThumbnailList Control).

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


PageViewClientId Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : PageViewClientId Property
Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("gets or sets PageView control Id where the thumbnail image when selected will be displayed.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
Public Property PageViewClientId As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.PageViewClientId = value

value = instance.PageViewClientId
[DefaultValue()]
[Description("gets or sets PageView control Id where the thumbnail image when selected will be displayed.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public string PageViewClientId {get; set;}
[DefaultValue()]
[Description("gets or sets PageView control Id where the thumbnail image when selected will be displayed.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public: __property string* get_PageViewClientId();
public: __property void set_PageViewClientId(
   string* value
);
[DefaultValue()]
[Description("gets or sets PageView control Id where the thumbnail image when selected will be displayed.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
public:
property String^ PageViewClientId {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

This property is a string that contains the id of the PageView control that should display the image displayed in each of the thumbnails when selected.

The default value is an empty string

It is common for applications of a ImGearThumbnailList control to display the selected thumbnail page element in a larger viewer and this property makes it easier for you to implement that kind of application. Simply set this property to the id of the PageView. This property will not be applicable in a multi selection mode. In the absence of a PageView on a web page, it should be set to an empty string, “”.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectedPages Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : SelectedPages Property
Gets a collection of ImGearSelectionPage objects containing information about pages required to be selected at startup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute(" Gets or sets comma separated string containing pages required to be selected at startup.")>
<BrowsableAttribute(False)>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public ReadOnly Property SelectedPages As Collection(Of ImGearSelectionPage)
'Usage

Dim instance As ImGearThumbnailList
Dim value As Collection(Of ImGearSelectionPage)

value = instance.SelectedPages
[Description(" Gets or sets comma separated string containing pages required to be selected at startup.")]
[Browsable(false)]
[Category("ImGearThumbnailList Properties")]
public Collection<ImGearSelectionPage> SelectedPages {get;}
[Description(" Gets or sets comma separated string containing pages required to be selected at startup.")]
[Browsable(false)]
[Category("ImGearThumbnailList Properties")]
public: __property Collection<ImGearSelectionPage*>* get_SelectedPages();
[Description(" Gets or sets comma separated string containing pages required to be selected at startup.")]
[Browsable(false)]
[Category("ImGearThumbnailList Properties")]
public:
property Collection<ImGearSelectionPage^>^ SelectedPages {
   Collection<ImGearSelectionPage^>^ get();
}

Property Value

A collection of ImGearSelectionPage objects.
Remarks

The default value is an empty collection of ImGearSelectionPage objects.

This is a read only property. It can not be overwritten. It allows access to a ImGearSelectionPage element of a collection.

Objects of ImGearSelectionPage can be created and added to this collection for selection of pages to be selected for the initial view in the control.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailBackgroundColor Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailBackgroundColor Property
Gets or sets the background color for the thumbnails displayed when in an non-selected state in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the thumbnail width.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ThumbnailBackgroundColor As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.ThumbnailBackgroundColor = value

value = instance.ThumbnailBackgroundColor
[Description("Gets or sets the thumbnail width.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
public string ThumbnailBackgroundColor {get; set;}
[Description("Gets or sets the thumbnail width.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
public: __property string* get_ThumbnailBackgroundColor();
public: __property void set_ThumbnailBackgroundColor(
   string* value
);
[Description("Gets or sets the thumbnail width.")]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
public:
property String^ ThumbnailBackgroundColor {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value
Remarks

The default value is gray color.

This property gets or sets the background color for thumbnails displayed when they are in not in a selected state. Note: This property is only relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailBorderColor Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailBorderColor Property
Gets or sets the for the border color for thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailList Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute(" Gets or sets thumbnail border color for the default case.")>
Public Property ThumbnailBorderColor As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.ThumbnailBorderColor = value

value = instance.ThumbnailBorderColor
[Category("ThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets thumbnail border color for the default case.")]
public string ThumbnailBorderColor {get; set;}
[Category("ThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets thumbnail border color for the default case.")]
public: __property string* get_ThumbnailBorderColor();
public: __property void set_ThumbnailBorderColor(
   string* value
);
[Category("ThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets thumbnail border color for the default case.")]
public:
property String^ ThumbnailBorderColor {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value.
Remarks

The default value is "#000000" (black) color.

This property gets or sets the border color for thumbnails displayed in the control. Note: This property is relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailBorderWidth Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailBorderWidth Property
Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute(" Gets or sets a value in pixel units (CSS px) indicating the space to the right of a thumbnail cell.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public Property ThumbnailBorderWidth As Integer
'Usage

Dim instance As ImGearThumbnailList
Dim value As Integer

instance.ThumbnailBorderWidth = value

value = instance.ThumbnailBorderWidth
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the space to the right of a thumbnail cell.")]
[Category("ImGearThumbnailList Properties")]
public int ThumbnailBorderWidth {get; set;}
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the space to the right of a thumbnail cell.")]
[Category("ImGearThumbnailList Properties")]
public: __property int get_ThumbnailBorderWidth();
public: __property void set_ThumbnailBorderWidth(
   int value
);
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the space to the right of a thumbnail cell.")]
[Category("ImGearThumbnailList Properties")]
public:
property int ThumbnailBorderWidth {
   int get();
   void set (    int value);
}

Property Value

An Integer value.
Remarks

The default value is 2 pixel units.

This property gets or sets the border width in pixel units for thumbnails displayed in the control. Note: This property is relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailCaptionFormat Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailCaptionFormat Property
Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the thumbnail caption format.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public Property ThumbnailCaptionFormat As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.ThumbnailCaptionFormat = value

value = instance.ThumbnailCaptionFormat
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the thumbnail caption format.")]
[Category("ImGearThumbnailList Properties")]
public string ThumbnailCaptionFormat {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the thumbnail caption format.")]
[Category("ImGearThumbnailList Properties")]
public: __property string* get_ThumbnailCaptionFormat();
public: __property void set_ThumbnailCaptionFormat(
   string* value
);
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets the thumbnail caption format.")]
[Category("ImGearThumbnailList Properties")]
public:
property String^ ThumbnailCaptionFormat {
   String^ get();
   void set (    String^ value);
}

Property Value

Remarks

The default value is an empty string

This property gets or sets the string format for thumbnail caption for all the thumbnails in the control. The custom formatting supports templated caption. The string will be parsed with the following characters to mean as in the following list. Note:The internal parser expects the characters to be encased within {}. To specify a single literal brace character in the format, specify two opening or closing braces. This follows .NET rules for escaping curly braces.

  • DC - Document Caption: Maps to the value obtained via DocumentCaptionFieldproperty used for data binding. You may choose to add some other string besides the value obtained via DocumentCaptionField. The default value will be the DocumentIdentifier property. If you do not want the DocumentIdentifier displayed as caption, then make sure that this value is set correctly or do not choose this option for the caption. On the client, this maps to the 'caption' property of the 'ImGearDocument' class.
  • PC - Page Caption: Maps to the value obtained via PageCaptionField property used for data binding. You may choose to add some other string besides the value obtained via PageCaptionField. On the client, this maps to the 'casption' property of the 'ImGearPage' class.
  • P# - Page Index: Defines the page index in the client 'ImGearPageCollection' class contained in the client 'ImGearDocument' class. The index is zero based so it will be incremented by one for display in the caption.
  • PP - Page Count: Defines the total number of pages in the client 'ImGearPageCollection' object contained in the client ImGearDocument class.

Note: Each thumbnail displays only one line of caption. If the caption is too long to fit, it will be truncated. If your caption text is too long to fit, you can choose to increase the width of the thumbnail. The only browser that wraps the longer caption is IE7. All newer browsers truncate the text.

Property value = "Title-{DC}:{PC} {P#} of {PP}"

where {PC} was set to “Claims Page ”

The resulting caption for thumbnails will be like:

"Title-MyImage.tif:Claims Page 1 of 150"

Property value = "{DC}:Page {P#}"

The resulting caption for thumbnails will be:

"MyImage.tif:Page 1"

Example
Property value = "Title-{DC}:{PC} {P#} of {PP}"

where {PC} was set to “Claims Page ”

The resulting caption for thumbnails will be like:

"Title-MyImage.tif:Claims Page 1 of 150"

Property value = "{DC}:Page {P#}"

The resulting caption for thumbnails will be:

"MyImage.tif:Page 1"

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailHeight Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailHeight Property
Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the thumbnail height.")>
Public Property ThumbnailHeight As Integer
'Usage

Dim instance As ImGearThumbnailList
Dim value As Integer

instance.ThumbnailHeight = value

value = instance.ThumbnailHeight
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets the thumbnail height.")]
public int ThumbnailHeight {get; set;}
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets the thumbnail height.")]
public: __property int get_ThumbnailHeight();
public: __property void set_ThumbnailHeight(
   int value
);
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[Description("Gets or sets the thumbnail height.")]
public:
property int ThumbnailHeight {
   int get();
   void set (    int value);
}

Property Value

An integer value
Remarks

The default value is is 140 pixel units.

.

This property gets or sets the height in pixel units for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailSelectedBackgroundColor Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailSelectedBackgroundColor Property
Gets or sets the background color for the selected thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<DescriptionAttribute("Gets or sets the thumbnail width.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ThumbnailSelectedBackgroundColor As String
'Usage

Dim instance As ImGearThumbnailList
Dim value As String

instance.ThumbnailSelectedBackgroundColor = value

value = instance.ThumbnailSelectedBackgroundColor
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[Browsable(true)]
[DefaultValue()]
public string ThumbnailSelectedBackgroundColor {get; set;}
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[Browsable(true)]
[DefaultValue()]
public: __property string* get_ThumbnailSelectedBackgroundColor();
public: __property void set_ThumbnailSelectedBackgroundColor(
   string* value
);
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[Browsable(true)]
[DefaultValue()]
public:
property String^ ThumbnailSelectedBackgroundColor {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value
Remarks

The default value is gray color.

This property gets or sets the background color for the selected thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailSelectionMode Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailSelectionMode Property
Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute(" Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public Property ThumbnailSelectionMode As ImGearThumbnailSelectionMode
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearThumbnailSelectionMode

instance.ThumbnailSelectionMode = value

value = instance.ThumbnailSelectionMode
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
public ImGearThumbnailSelectionMode ThumbnailSelectionMode {get; set;}
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
public: __property ImGearThumbnailSelectionMode get_ThumbnailSelectionMode();
public: __property void set_ThumbnailSelectionMode(
   ImGearThumbnailSelectionMode value
);
[DefaultValue()]
[Browsable(true)]
[Description(" Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.")]
[Category("ImGearThumbnailList Properties")]
public:
property ImGearThumbnailSelectionMode ThumbnailSelectionMode {
   ImGearThumbnailSelectionMode get();
   void set (    ImGearThumbnailSelectionMode value);
}

Property Value

One of the values ImGearThumbnailSelectionMode.
Remarks

This property defines the selection behavior in the ImGearThumbnailList control. For the various options, refer to the enumeration ImGearThumbnailSelectionMode.

Note: The selected state of thumbnails is maintained only when using ImGearDataBindingType.Page type data binding.

The default value is ImGearThumbnailSelectionMode.Single.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ThumbnailWidth Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : ThumbnailWidth Property
Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ImGearThumbnailList Properties")>
<DescriptionAttribute("Gets or sets the thumbnail width.")>
<DefaultValueAttribute()>
Public Property ThumbnailWidth As Integer
'Usage

Dim instance As ImGearThumbnailList
Dim value As Integer

instance.ThumbnailWidth = value

value = instance.ThumbnailWidth
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[DefaultValue()]
public int ThumbnailWidth {get; set;}
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[DefaultValue()]
public: __property int get_ThumbnailWidth();
public: __property void set_ThumbnailWidth(
   int value
);
[Browsable(true)]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the thumbnail width.")]
[DefaultValue()]
public:
property int ThumbnailWidth {
   int get();
   void set (    int value);
}

Property Value

An integer value
Remarks

The default value is 124 pixel units..

This property gets or sets the width in pixel units for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


UseDefaultStyling Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : UseDefaultStyling Property
Gets or sets the default visual style for the thumbnails and their contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("ImGearThumbnailList Properties")>
<DescriptionAttribute("Gets or sets the default CSS layout for the ImGearThumbnailList control.")>
Public Property UseDefaultStyling As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim value As Boolean

instance.UseDefaultStyling = value

value = instance.UseDefaultStyling
[Browsable(true)]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the default CSS layout for the ImGearThumbnailList control.")]
public bool UseDefaultStyling {get; set;}
[Browsable(true)]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the default CSS layout for the ImGearThumbnailList control.")]
public: __property bool get_UseDefaultStyling();
public: __property void set_UseDefaultStyling(
   bool value
);
[Browsable(true)]
[DefaultValue()]
[Category("ImGearThumbnailList Properties")]
[Description("Gets or sets the default CSS layout for the ImGearThumbnailList control.")]
public:
property bool UseDefaultStyling {
   bool get();
   void set (    bool value);
}

Property Value

Remarks

When this property is set to a value of 'false', it means the default style for the thumbnails and its contents is not required. Under this condition, your web page containing the ImGearThumbnailList control must include a CSS file that contains definitions for the following named CSS classes:

  • .imGearTNItem, .imGearTNSelected

    In this example, the CSS class group defines the common property styles for the thumbnails that are in "unselected" and "selected" states. Alternatively, you can define two separate CSS classes, .imGearTNItem and .imGearTNSelected. Each containing all the properties that you want them to contain. The end result is the same.

    Example:

    .imGearTNItem, .imGearTNSelected

    {

    width:100px;

    height:160px;

    background-color:gray;

    float:left;

    overflow: hidden;

    border: 1px solid black;

    margin: 2px;

    }
  • .ImGearTNSelected

    This CSS class defines the background for the thumbnail items in the selected state.

    Example:

    .imGearTNSelected strong>

    {

    background-color:#ffBB00;

    }
  • .imGearTNItemCaption

    In this example, the CSS class defines details for thumbnail items caption.

    Example:

    .imGearTNItemCaption

    {

    left:0px;

    font-family: arial,sans-serif;font-size:8pt;text-align: center;

    font-size: 16px;

    top:20px;

    width:100px;

    height:20px;

    }
  • .imGearTNImage

    This CSS class defines thumbnail image style.

    Example:

    .imGearTNImage

    {

    width:120px;

    height:100px;

    position:relative;

    overflow: hidden;

    margin: 2px;

    }
  • .imGearTNItem:Hover

    This CSS class defines thumbnail item style when mouse hovers over it.

    Example:

    .imGearTNItem:Hover

    {

    border:2px solid #ffBB00;

    }

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


XSpacing Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : XSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets a value in pixel units (CSS px) indicating the horizontal space between thumbnail items.")>
<CategoryAttribute("ImGearThumbnailList Properties")>
Public Property XSpacing As Integer
'Usage

Dim instance As ImGearThumbnailList
Dim value As Integer

instance.XSpacing = value

value = instance.XSpacing
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value in pixel units (CSS px) indicating the horizontal space between thumbnail items.")]
[Category("ImGearThumbnailList Properties")]
public int XSpacing {get; set;}
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value in pixel units (CSS px) indicating the horizontal space between thumbnail items.")]
[Category("ImGearThumbnailList Properties")]
public: __property int get_XSpacing();
public: __property void set_XSpacing(
   int value
);
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value in pixel units (CSS px) indicating the horizontal space between thumbnail items.")]
[Category("ImGearThumbnailList Properties")]
public:
property int XSpacing {
   int get();
   void set (    int value);
}

Property Value

An integer value.
Remarks

The default value is 4 pixel units

This property gets or sets the border color for thumbnails displayed in the control. Note: This property is relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


YSpacing Property (ImGearThumbnailList)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ImGearThumbnailList Class : YSpacing Property
Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ImGearThumbnailList Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute(" Gets or sets a value in pixel units (CSS px) indicating the vertical space between thumbnail items.")>
Public Property YSpacing As Integer
'Usage

Dim instance As ImGearThumbnailList
Dim value As Integer

instance.YSpacing = value

value = instance.YSpacing
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the vertical space between thumbnail items.")]
public int YSpacing {get; set;}
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the vertical space between thumbnail items.")]
public: __property int get_YSpacing();
public: __property void set_YSpacing(
   int value
);
[Category("ImGearThumbnailList Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value in pixel units (CSS px) indicating the vertical space between thumbnail items.")]
public:
property int YSpacing {
   int get();
   void set (    int value);
}

Property Value

An integer value.
Remarks

The default value is 4 pixel units

This property gets or sets the border color for thumbnails displayed in the control. Note: This property is relevant when choosing the default mode control style with the UseDefaultStyling set to true;

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%%

PageView Class
Members

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : PageView Class
This class describes the server side PageView control.
Object Model
PageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")>
<ToolboxDataAttribute("<{0}:PageView runat=server Width="300px" Height="300px"></{0}:PageView>")>
<ToolboxBitmapAttribute()>
Public Class PageView
   Inherits System.Web.UI.ScriptControl
'Usage

Dim instance As PageView
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxData("<{0}:PageView runat=server Width="300px" Height="300px"></{0}:PageView>")]
[ToolboxBitmap()]
public class PageView : System.Web.UI.ScriptControl
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxData("<{0}:PageView runat=server Width="300px" Height="300px"></{0}:PageView>")]
[ToolboxBitmap()]
public __gc class PageView : public System.Web.UI.ScriptControl
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxData("<{0}:PageView runat=server Width="300px" Height="300px"></{0}:PageView>")]
[ToolboxBitmap()]
public ref class PageView : public System.Web.UI.ScriptControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.ScriptControl
ImageGear.Web.UI.PageView

See Also

Reference

PageView Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

PageView Class Members
Properties Methods Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : PageView Class

The following tables list the members exposed by PageView.

Public Properties
 | Name | Description
Public Property | ArtEnableMode | Gets or sets the annotations mode.
Public Property | ClientDebug | Gets or sets a value indicating whether the Client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client PageView control will log.
Public Property | DocumentIdentifier | Gets or sets the DocumentIdentifier. This property refers to the image file path or database image key (column/field value).
Public Property | EncodedDocumentIdentifier | Gets the encoded format for sending over to the client. This property refers to the encoded DocumentIdentifier value. This property is a read only property.
Public Property | ImageFitType | Gets or sets the initial Fit Type for the image to be displayed in the Viewer control.
Public Property | ImageHandlerUrl | Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Public Property | IsContextMenuEnabled | Gets or sets the context menu visibility.
Public Property | MagnifierHeight | Gets or sets the flying magnifier height in window pixels.
Public Property | MagnifierMagnification | Gets or sets the magnification of the flying magnifier.
Public Property | MagnifierWidth | Gets or sets the flying magnifier width in window pixels.
Public Property | MouseTool | Gets or sets the behavior of the left mouse button.
Public Property | OnArtPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Public Property | OnContextMenu | Gets or sets user defined Javascript event handler to receive client events that indicate when the user activates the context menu.
Public Property | OnMarkAdded | Gets or sets user defined Javascript event handler to receive client events that indicate when a new mark is added to the collection.
Public Property | OnMarkChanged | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark on the page is changed.
Public Property | OnMarkCreating | Gets or sets user defined Javascript event handler to receive the client markCreating event.
Public Property | OnMarkRemoved | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is removed from the page.
Public Property | OnMarkReordered | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is reordered within the page.
Public Property | OnMarkSelectionChanged | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is selected or unselected.
Public Property | OnMarksLoaded | Gets or sets user defined Javascript event handler to receive client events that indicate when the marks are loaded from a JSON string.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive event when a new mark is being interactively created. .
Public Property | OnPageClosed | Gets or sets user defined Javascript event handler to receive a call to the client imageClosed event.
Public Property | OnPageOpened | Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Public Property | OnPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Public Property | OnPageOpening | Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Public Property | OnPropertyChanged | Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Public Property | PageNumber | Gets or sets the Image Page number. This property refers to the page number to be displayed in a multipage document.
Public Property | PresentationQuality | Gets or sets the presentation quality for the image to be displayed in the Viewer control.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display in the Viewer control.
Public Property | VectorFormatsRendering | Gets or sets the vector formats rendering way.
Public Property | ViewMirror | Gets or sets a value indicating whether the image mirror setting (left and right sides of an image are swapped) is required.
Public Property | ViewRectangle | Gets or sets the portion of the image that needs to be displayed.
Public Property | ViewRotationDegreesClockwise | Gets or sets the Rotation angle for display in the PageView control.
Top
See Also

Reference

PageView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Properties$$

PageView Class Properties

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Properties
 | Name | Description
Public Property | ArtEnableMode | Gets or sets the annotations mode.
Public Property | ClientDebug | Gets or sets a value indicating whether the Client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client PageView control will log.
Public Property | DocumentIdentifier | Gets or sets the DocumentIdentifier. This property refers to the image file path or database image key (column/field value).
Public Property | EncodedDocumentIdentifier | Gets the encoded format for sending over to the client. This property refers to the encoded DocumentIdentifier value. This property is a read only property.
Public Property | ImageFitType | Gets or sets the initial Fit Type for the image to be displayed in the Viewer control.
Public Property | ImageHandlerUrl | Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Public Property | IsContextMenuEnabled | Gets or sets the context menu visibility.
Public Property | MagnifierHeight | Gets or sets the flying magnifier height in window pixels.
Public Property | MagnifierMagnification | Gets or sets the magnification of the flying magnifier.
Public Property | MagnifierWidth | Gets or sets the flying magnifier width in window pixels.
Public Property | MouseTool | Gets or sets the behavior of the left mouse button.
Public Property | OnArtPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Public Property | OnContextMenu | Gets or sets user defined Javascript event handler to receive client events that indicate when the user activates the context menu.
Public Property | OnMarkAdded | Gets or sets user defined Javascript event handler to receive client events that indicate when a new mark is added to the collection.
Public Property | OnMarkChanged | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark on the page is changed.
Public Property | OnMarkCreating | Gets or sets user defined Javascript event handler to receive the client markCreating event.
Public Property | OnMarkRemoved | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is removed from the page.
Public Property | OnMarkReordered | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is reordered within the page.
Public Property | OnMarkSelectionChanged | Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is selected or unselected.
Public Property | OnMarksLoaded | Gets or sets user defined Javascript event handler to receive client events that indicate when the marks are loaded from a JSON string.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive event when a new mark is being interactively created. .
Public Property | OnPageClosed | Gets or sets user defined Javascript event handler to receive a call to the client imageClosed event.
Public Property | OnPageOpened | Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Public Property | OnPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Public Property | OnPageOpening | Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Public Property | OnPropertyChanged | Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Public Property | PageNumber | Gets or sets the Image Page number. This property refers to the page number to be displayed in a multipage document.
Public Property | PresentationQuality | Gets or sets the presentation quality for the image to be displayed in the Viewer control.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display in the Viewer control.
Public Property | VectorFormatsRendering | Gets or sets the vector formats rendering way.
Public Property | ViewMirror | Gets or sets a value indicating whether the image mirror setting (left and right sides of an image are swapped) is required.
Public Property | ViewRectangle | Gets or sets the portion of the image that needs to be displayed.
Public Property | ViewRotationDegreesClockwise | Gets or sets the Rotation angle for display in the PageView control.
Top
See Also

Reference

PageView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Methods$$

PageView Class Methods

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : PageView Class

For a list of all members of this type, see PageView members.

See Also

Reference

PageView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Events$$

PageView Class Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : PageView Class

For a list of all members of this type, see PageView members.

See Also

Reference

PageView Class
ImageGear.Web.UI Namespace


ArtEnableMode Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ArtEnableMode Property
Gets or sets the annotations mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("An enumeration value representing options for displaying and/or saving annotations.")>
Public Property ArtEnableMode As ArtEnableOption
'Usage

Dim instance As PageView
Dim value As ArtEnableOption

instance.ArtEnableMode = value

value = instance.ArtEnableMode
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
public ArtEnableOption ArtEnableMode {get; set;}
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
public: __property ArtEnableOption get_ArtEnableMode();
public: __property void set_ArtEnableMode(
   ArtEnableOption value
);
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
public:
property ArtEnableOption ArtEnableMode {
   ArtEnableOption get();
   void set (    ArtEnableOption value);
}

Property Value

The enumeration value represents options for displaying and/or saving annotations (Art Data) on images ArtEnableOption.
Remarks
This property specifies the option for showing and saving annotations on the displayed images. It must be set to one of the values in the enumeration ArtEnableOption

The default value is is ArtEnableOption.None

. In this mode the annotations are not displayed.
See Also

Reference

PageView Class
PageView Members


ClientDebug Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ClientDebug Property
Gets or sets a value indicating whether the Client side error logging is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether the Client side error logging is enabled.")>
<CategoryAttribute("Clientside Error logging Properties")>
Public Property ClientDebug As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.ClientDebug = value

value = instance.ClientDebug
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets a value indicating whether the Client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
public bool ClientDebug {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets a value indicating whether the Client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
public: __property bool get_ClientDebug();
public: __property void set_ClientDebug(
   bool value
);
[Browsable(true)]
[DefaultValue()]
[Description("Gets or sets a value indicating whether the Client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
public:
property bool ClientDebug {
   bool get();
   void set (    bool value);
}
Remarks
Turns on or off the Client side error logging. The default value is 'false'.
See Also

Reference

PageView Class
PageView Members


ClientDebugErrorLevel Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ClientDebugErrorLevel Property
Gets or sets the amount of information the Client PageView control will log.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("An enumeration value representing the amount of information the Client PageView control will log.")>
<CategoryAttribute("Clientside Error logging Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ClientDebugErrorLevel As ClientDebugErrorLevel
'Usage

Dim instance As PageView
Dim value As ClientDebugErrorLevel

instance.ClientDebugErrorLevel = value

value = instance.ClientDebugErrorLevel
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public ClientDebugErrorLevel ClientDebugErrorLevel {get; set;}
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public: __property ClientDebugErrorLevel get_ClientDebugErrorLevel();
public: __property void set_ClientDebugErrorLevel(
   ClientDebugErrorLevel value
);
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public:
property ClientDebugErrorLevel ClientDebugErrorLevel {
   ClientDebugErrorLevel get();
   void set (    ClientDebugErrorLevel value);
}

Property Value

One of the values ClientDebugErrorLevel. The default value is 'Production'.
Remarks
One of the values ClientDebugErrorLevel. The default value is 'Production'.
See Also

Reference

PageView Class
PageView Members


DocumentIdentifier Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : DocumentIdentifier Property
Gets or sets the DocumentIdentifier. This property refers to the image file path or database image key (column/field value).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Refers to the image file path or database field value.")>
<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
Public Property DocumentIdentifier As String
'Usage

Dim instance As PageView
Dim value As String

instance.DocumentIdentifier = value

value = instance.DocumentIdentifier
[Description("Refers to the image file path or database field value.")]
[Category("PageView Properties")]
[Browsable(true)]
public string DocumentIdentifier {get; set;}
[Description("Refers to the image file path or database field value.")]
[Category("PageView Properties")]
[Browsable(true)]
public: __property string* get_DocumentIdentifier();
public: __property void set_DocumentIdentifier(
   string* value
);
[Description("Refers to the image file path or database field value.")]
[Category("PageView Properties")]
[Browsable(true)]
public:
property String^ DocumentIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

Remarks

The default value is an empty string

See Also

Reference

PageView Class
PageView Members


EncodedDocumentIdentifier Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : EncodedDocumentIdentifier Property
Gets the encoded format for sending over to the client. This property refers to the encoded DocumentIdentifier value. This property is a read only property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A read only encoded DocumentIdentifier value.")>
<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
Public ReadOnly Property EncodedDocumentIdentifier As String
'Usage

Dim instance As PageView
Dim value As String

value = instance.EncodedDocumentIdentifier
[Description("A read only encoded DocumentIdentifier value.")]
[Category("PageView Properties")]
[Browsable(true)]
public string EncodedDocumentIdentifier {get;}
[Description("A read only encoded DocumentIdentifier value.")]
[Category("PageView Properties")]
[Browsable(true)]
public: __property string* get_EncodedDocumentIdentifier();
[Description("A read only encoded DocumentIdentifier value.")]
[Category("PageView Properties")]
[Browsable(true)]
public:
property String^ EncodedDocumentIdentifier {
   String^ get();
}
Remarks

The default value is an empty string

If the DocumentIdentifier property is not set (empty), then this value will be an empty string.

See Also

Reference

PageView Class
PageView Members


ImageFitType Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ImageFitType Property
Gets or sets the initial Fit Type for the image to be displayed in the Viewer control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<DescriptionAttribute("An enumeration value which represents the initial Fit Type for the image to be displayed in the Viewer control.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property ImageFitType As FitType
'Usage

Dim instance As PageView
Dim value As FitType

instance.ImageFitType = value

value = instance.ImageFitType
[Category("PageView Properties")]
[Description("An enumeration value which represents the initial Fit Type for the image to be displayed in the Viewer control.")]
[DefaultValue()]
[Browsable(true)]
public FitType ImageFitType {get; set;}
[Category("PageView Properties")]
[Description("An enumeration value which represents the initial Fit Type for the image to be displayed in the Viewer control.")]
[DefaultValue()]
[Browsable(true)]
public: __property FitType get_ImageFitType();
public: __property void set_ImageFitType(
   FitType value
);
[Category("PageView Properties")]
[Description("An enumeration value which represents the initial Fit Type for the image to be displayed in the Viewer control.")]
[DefaultValue()]
[Browsable(true)]
public:
property FitType ImageFitType {
   FitType get();
   void set (    FitType value);
}

Property Value

The FitType enumeration value.
Remarks

The default value is FullWidth

See Also

Reference

PageView Class
PageView Members


ImageHandlerUrl Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ImageHandlerUrl Property
Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("A string containing a fully qualified URL (absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")>
<DefaultValueAttribute()>
Public Property ImageHandlerUrl As String
'Usage

Dim instance As PageView
Dim value As String

instance.ImageHandlerUrl = value

value = instance.ImageHandlerUrl
[Category("PageView Properties")]
[Browsable(true)]
[Description("A string containing a fully qualified URL (absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
public string ImageHandlerUrl {get; set;}
[Category("PageView Properties")]
[Browsable(true)]
[Description("A string containing a fully qualified URL (absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
public: __property string* get_ImageHandlerUrl();
public: __property void set_ImageHandlerUrl(
   string* value
);
[Category("PageView Properties")]
[Browsable(true)]
[Description("A string containing a fully qualified URL (absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
public:
property String^ ImageHandlerUrl {
   String^ get();
   void set (    String^ value);
}
Remarks
The value provided should be a fully qualified URL (absolute URL), a relative URL is not recommended unless it resides at the same level as the application aspx page. Note: It is not necessary to have this property defined if the Image Service is at the same directory level as the application.

When either the PageView or the ThumbnailView control is dragged from the Visual Studio Toolbox on to the web page design surface when in the 'Design' view mode, an 'Action List' will display. This list has options for configuring the Services. For a detailed description, refer to the web.config settings section in this help document.

Note: If you add the control on your web page using the source editor, then you can still use the Action List menu items (Smart Tags Panel) on the PageView and ThumbnailView by switching to the 'Design' view mode in the Visual Studio.

A more detailed explanation for the Services setting can be found in the web.config settings section of the help file.

See Also

Reference

PageView Class
PageView Members


IsContextMenuEnabled Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : IsContextMenuEnabled Property
Gets or sets the context menu visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets a value indicating wheter control context menu is visibile.")>
Public Property IsContextMenuEnabled As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.IsContextMenuEnabled = value

value = instance.IsContextMenuEnabled
[Category("PageView Properties")]
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value indicating wheter control context menu is visibile.")]
public bool IsContextMenuEnabled {get; set;}
[Category("PageView Properties")]
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value indicating wheter control context menu is visibile.")]
public: __property bool get_IsContextMenuEnabled();
public: __property void set_IsContextMenuEnabled(
   bool value
);
[Category("PageView Properties")]
[DefaultValue()]
[Browsable(true)]
[Description("Gets or sets a value indicating wheter control context menu is visibile.")]
public:
property bool IsContextMenuEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

The default value is true.

See Also

Reference

PageView Class
PageView Members


MagnifierHeight Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : MagnifierHeight Property
Gets or sets the flying magnifier height in window pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<DescriptionAttribute("Flying magnifier height in window pixels in the range between 25 and 500.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property MagnifierHeight As Integer
'Usage

Dim instance As PageView
Dim value As Integer

instance.MagnifierHeight = value

value = instance.MagnifierHeight
[Category("PageView Properties")]
[Description("Flying magnifier height in window pixels in the range between 25 and 500.")]
[Browsable(true)]
[DefaultValue()]
public int MagnifierHeight {get; set;}
[Category("PageView Properties")]
[Description("Flying magnifier height in window pixels in the range between 25 and 500.")]
[Browsable(true)]
[DefaultValue()]
public: __property int get_MagnifierHeight();
public: __property void set_MagnifierHeight(
   int value
);
[Category("PageView Properties")]
[Description("Flying magnifier height in window pixels in the range between 25 and 500.")]
[Browsable(true)]
[DefaultValue()]
public:
property int MagnifierHeight {
   int get();
   void set (    int value);
}

Property Value

An integer value ranging between 25 to 500.
Remarks

This property is a number that specifies the height of the magnifier, in window pixels. The range is between 25 and 500. The default value is 150.

See Also

Reference

PageView Class
PageView Members


MagnifierMagnification Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : MagnifierMagnification Property
Gets or sets the magnification of the flying magnifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Magnification of the flying magnifier. The value should be in the range 1.5 to 8.0.")>
<CategoryAttribute("PageView Properties")>
Public Property MagnifierMagnification As Double
'Usage

Dim instance As PageView
Dim value As Double

instance.MagnifierMagnification = value

value = instance.MagnifierMagnification
[Browsable(true)]
[DefaultValue()]
[Description("Magnification of the flying magnifier. The value should be in the range 1.5 to 8.0.")]
[Category("PageView Properties")]
public double MagnifierMagnification {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Magnification of the flying magnifier. The value should be in the range 1.5 to 8.0.")]
[Category("PageView Properties")]
public: __property double get_MagnifierMagnification();
public: __property void set_MagnifierMagnification(
   double value
);
[Browsable(true)]
[DefaultValue()]
[Description("Magnification of the flying magnifier. The value should be in the range 1.5 to 8.0.")]
[Category("PageView Properties")]
public:
property double MagnifierMagnification {
   double get();
   void set (    double value);
}

Property Value

Value ranges between 1.5 to 8.0.
Remarks

This property is a number that specifies the magnification applied to the image displayed in the magnifier. The value is between 1.5 and 8.0 with larger values maginifying more than the smaller values. In most cases, a value of 3.0 will provide good magnification. The default value is 3.0.

See Also

Reference

PageView Class
PageView Members


MagnifierWidth Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : MagnifierWidth Property
Gets or sets the flying magnifier width in window pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Flying magnifier width in window pixels in the range between 25 and 500")>
<BrowsableAttribute(True)>
<CategoryAttribute("PageView Properties")>
Public Property MagnifierWidth As Integer
'Usage

Dim instance As PageView
Dim value As Integer

instance.MagnifierWidth = value

value = instance.MagnifierWidth
[DefaultValue()]
[Description("Flying magnifier width in window pixels in the range between 25 and 500")]
[Browsable(true)]
[Category("PageView Properties")]
public int MagnifierWidth {get; set;}
[DefaultValue()]
[Description("Flying magnifier width in window pixels in the range between 25 and 500")]
[Browsable(true)]
[Category("PageView Properties")]
public: __property int get_MagnifierWidth();
public: __property void set_MagnifierWidth(
   int value
);
[DefaultValue()]
[Description("Flying magnifier width in window pixels in the range between 25 and 500")]
[Browsable(true)]
[Category("PageView Properties")]
public:
property int MagnifierWidth {
   int get();
   void set (    int value);
}

Property Value

An integer value ranging between 25 to 500.
Remarks

This property is a number that specifies the width of the magnifier, in window pixels. The default value is 250.

See Also

Reference

PageView Class
PageView Members


MouseTool Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : MouseTool Property
Gets or sets the behavior of the left mouse button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("An enumeration value which represents the behavior of the left mouse button.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("PageView Properties")>
Public Property MouseTool As MouseTool
'Usage

Dim instance As PageView
Dim value As MouseTool

instance.MouseTool = value

value = instance.MouseTool
[Description("An enumeration value which represents the behavior of the left mouse button.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public MouseTool MouseTool {get; set;}
[Description("An enumeration value which represents the behavior of the left mouse button.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public: __property MouseTool get_MouseTool();
public: __property void set_MouseTool(
   MouseTool value
);
[Description("An enumeration value which represents the behavior of the left mouse button.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public:
property MouseTool MouseTool {
   MouseTool get();
   void set (    MouseTool value);
}

Property Value

The enumeration value which represents MouseTool.
Remarks
This property specifies the behavior of the left mouse button. It must be set to one of the values in the enumeration MouseTool. In all cases, the viewer will raise the mouseDown (OnMouseDown property), mouseMove (OnMouseMove property), and mouseUp (OnMouseUp property) events.

The default value is MouseTool.RectangleZoom

See Also

Reference

PageView Class
PageView Members


OnArtPageOpenFailed Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnArtPageOpenFailed Property
Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnArtPageOpenFailed As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnArtPageOpenFailed = value

value = instance.OnArtPageOpenFailed
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
[Category("Client PageView Control Events")]
public string OnArtPageOpenFailed {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnArtPageOpenFailed();
public: __property void set_OnArtPageOpenFailed(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnArtPageOpenFailed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised when an ART load fails to open.

See Also

Reference

PageView Class
PageView Members


OnContextMenu Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnContextMenu Property
Gets or sets user defined Javascript event handler to receive client events that indicate when the user activates the context menu.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive the Client contextMenu Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnContextMenu As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnContextMenu = value

value = instance.OnContextMenu
[Description("A user defined Javascript event handler to receive the Client contextMenu Event.")]
[Category("Client PageView Control Events")]
public string OnContextMenu {get; set;}
[Description("A user defined Javascript event handler to receive the Client contextMenu Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnContextMenu();
public: __property void set_OnContextMenu(
   string* value
);
[Description("A user defined Javascript event handler to receive the Client contextMenu Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnContextMenu {
   String^ get();
   void set (    String^ value);
}
Remarks

The viewer will raise this event whenever the user activates the context menu by pressing and releasing the right mouse button while the cursor is over any part of the viewer (except the scrollbars).

On some browsers (Internet Explorer 8), a user can also cause the viewer to raise this event by pressing the context menu button on the keyboard.

The event argument be an instance of the client Javascript "ImageGear.Web.UI.MouseEventArgs" object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

PageView Class
PageView Members


OnMarkAdded Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkAdded Property
Gets or sets user defined Javascript event handler to receive client events that indicate when a new mark is added to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive the Client markAdded Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnMarkAdded As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkAdded = value

value = instance.OnMarkAdded
[Description("A user defined Javascript event handler to receive the Client markAdded Event.")]
[Category("Client PageView Control Events")]
public string OnMarkAdded {get; set;}
[Description("A user defined Javascript event handler to receive the Client markAdded Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnMarkAdded();
public: __property void set_OnMarkAdded(
   string* value
);
[Description("A user defined Javascript event handler to receive the Client markAdded Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnMarkAdded {
   String^ get();
   void set (    String^ value);
}
Remarks

The collection will raise this event whenever a mark is added (as the result of a call to the client Javascript addMark or addMarks functions in the Client API) The object will raise this event after it has added the mark(s).

Note: All the references refer to the Client API library.

When the collection raises this event, it will provide a client Javascript "ImageGear.Web.UI.MarkEventArgs" object as the event argument. When raised as a result of the client Javascript "addMark" function, the event argument will have its "ImageGear.Web.UI.MarkEventArgs.mark" property set to the added mark. When raised as a result of the client Javascript "addMarks" function, the event argument will not contain a client Javascript "ImageGear.Web.UI.MarkEventArgs.mark" property.

See Also

Reference

PageView Class
PageView Members


OnMarkChanged Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkChanged Property
Gets or sets user defined Javascript event handler to receive client events that indicate when a mark on the page is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive the Client markChanged Event.")>
Public Property OnMarkChanged As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkChanged = value

value = instance.OnMarkChanged
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markChanged Event.")]
public string OnMarkChanged {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markChanged Event.")]
public: __property string* get_OnMarkChanged();
public: __property void set_OnMarkChanged(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markChanged Event.")]
public:
property String^ OnMarkChanged {
   String^ get();
   void set (    String^ value);
}
Remarks

The collection will raise this event whenever the value of any property of a mark changes.

Note that one exception to this event is the client Javascript "Mark.selected" property. This object will not raise a markChanged event when that property changes. Instead, this object will raise a client Javascript "markSelectionChanged" event.

When the page raises this event, it will provide the changed client Javascript "Mark" object and the name of the property that changed as the event argument.

See Also

Reference

PageView Class
PageView Members


OnMarkCreating Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkCreating Property
Gets or sets user defined Javascript event handler to receive the client markCreating event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive the Client markCreating Event.")>
Public Property OnMarkCreating As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkCreating = value

value = instance.OnMarkCreating
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markCreating Event.")]
public string OnMarkCreating {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markCreating Event.")]
public: __property string* get_OnMarkCreating();
public: __property void set_OnMarkCreating(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markCreating Event.")]
public:
property String^ OnMarkCreating {
   String^ get();
   void set (    String^ value);
}
Remarks

The viewer will raise this event whenever an end user begins to add a mark to the page. This event occurs before the new mark is first displayed on the viewer.

When the page raises this event, it will provide the new client Javascript "Mark" object as the event argument.

See Also

Reference

PageView Class
PageView Members


OnMarkRemoved Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkRemoved Property
Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is removed from the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive the Client markRemoved Event.")>
Public Property OnMarkRemoved As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkRemoved = value

value = instance.OnMarkRemoved
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markRemoved Event.")]
public string OnMarkRemoved {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markRemoved Event.")]
public: __property string* get_OnMarkRemoved();
public: __property void set_OnMarkRemoved(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markRemoved Event.")]
public:
property String^ OnMarkRemoved {
   String^ get();
   void set (    String^ value);
}
Remarks

The client "ArtPage" will raise this event whenever a mark is removed (as the result of a call to the client Javascript "removeMark" or "removeAllMarks" functions.) The object will raise this event after it has removed the mark.

When the page raises this event, it will provide the removed client Javascript "Mark" object as the event argument.

See Also

Reference

PageView Class
PageView Members


OnMarkReordered Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkReordered Property
Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is reordered within the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive the Client markReordered Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnMarkReordered As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkReordered = value

value = instance.OnMarkReordered
[Description("A user defined Javascript event handler to receive the Client markReordered Event.")]
[Category("Client PageView Control Events")]
public string OnMarkReordered {get; set;}
[Description("A user defined Javascript event handler to receive the Client markReordered Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnMarkReordered();
public: __property void set_OnMarkReordered(
   string* value
);
[Description("A user defined Javascript event handler to receive the Client markReordered Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnMarkReordered {
   String^ get();
   void set (    String^ value);
}
Remarks

The client Javascript "ArtPage" will raise this event whenever a mark is reordered (as the result of a call to the client Javascript "reorderMark" function.) The object will raise this event after it has reordered the mark.

When the page raises this event, it will provide the reordered client Javascript "Mark" object and its new Z-index as the event argument. Note that when a mark is reordered, other marks are implicitly moved as well, but this event is not raised for those marks.

See Also

Reference

PageView Class
PageView Members


OnMarkSelectionChanged Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarkSelectionChanged Property
Gets or sets user defined Javascript event handler to receive client events that indicate when a mark is selected or unselected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive the Client markSelectionChanged Event.")>
Public Property OnMarkSelectionChanged As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarkSelectionChanged = value

value = instance.OnMarkSelectionChanged
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markSelectionChanged Event.")]
public string OnMarkSelectionChanged {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markSelectionChanged Event.")]
public: __property string* get_OnMarkSelectionChanged();
public: __property void set_OnMarkSelectionChanged(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive the Client markSelectionChanged Event.")]
public:
property String^ OnMarkSelectionChanged {
   String^ get();
   void set (    String^ value);
}
Remarks

The page will raise this event after a mark is added to, or removed from, the client Javascript "selectedMarks" collection. The object will raise this event after it has updated the list of selected marks.

When the page raises this event, it will provide the client Javascript "MarkCollection" of selected marks as the event argument.

See Also

Reference

PageView Class
PageView Members


OnMarksLoaded Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMarksLoaded Property
Gets or sets user defined Javascript event handler to receive client events that indicate when the marks are loaded from a JSON string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive the Client marksLoaded Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnMarksLoaded As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMarksLoaded = value

value = instance.OnMarksLoaded
[Description("A user defined Javascript event handler to receive the Client marksLoaded Event.")]
[Category("Client PageView Control Events")]
public string OnMarksLoaded {get; set;}
[Description("A user defined Javascript event handler to receive the Client marksLoaded Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnMarksLoaded();
public: __property void set_OnMarksLoaded(
   string* value
);
[Description("A user defined Javascript event handler to receive the Client marksLoaded Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnMarksLoaded {
   String^ get();
   void set (    String^ value);
}
Remarks

The client Javascript "ArtPage" will raise this event after the client Javascript "loadFromJson" function successfully loads marks from a JSON string, even if that string contained no marks.

See Also

Reference

PageView Class
PageView Members


OnMouseDown Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMouseDown Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnMouseDown As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMouseDown = value

value = instance.OnMouseDown
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[Category("Client PageView Control Events")]
public string OnMouseDown {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnMouseDown();
public: __property void set_OnMouseDown(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnMouseDown {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

PageView Class
PageView Members


OnMouseMove Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMouseMove Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")>
Public Property OnMouseMove As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMouseMove = value

value = instance.OnMouseMove
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public string OnMouseMove {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public: __property string* get_OnMouseMove();
public: __property void set_OnMouseMove(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
public:
property String^ OnMouseMove {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

PageView Class
PageView Members


OnMouseUp Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnMouseUp Property
Gets or sets user defined Javascript event handler to receive event when a new mark is being interactively created. .
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnMouseUp As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnMouseUp = value

value = instance.OnMouseUp
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client PageView Control Events")]
public string OnMouseUp {get; set;}
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnMouseUp();
public: __property void set_OnMouseUp(
   string* value
);
[Description("A ser defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnMouseUp {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

PageView Class
PageView Members


OnPageClosed Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnPageClosed Property
Gets or sets user defined Javascript event handler to receive a call to the client imageClosed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client imageClosed Event.")>
Public Property OnPageClosed As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnPageClosed = value

value = instance.OnPageClosed
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client imageClosed Event.")]
public string OnPageClosed {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client imageClosed Event.")]
public: __property string* get_OnPageClosed();
public: __property void set_OnPageClosed(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client imageClosed Event.")]
public:
property String^ OnPageClosed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised during a call to the viewer.CloseImage().

See Also

Reference

PageView Class
PageView Members


OnPageOpened Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnPageOpened Property
Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")>
Public Property OnPageOpened As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnPageOpened = value

value = instance.OnPageOpened
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public string OnPageOpened {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public: __property string* get_OnPageOpened();
public: __property void set_OnPageOpened(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public:
property String^ OnPageOpened {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised after the image attributes have been received from the server. At this point, the previous image will be discarded. The new current image may not have been displayed yet, but that will occur soon.

See Also

Reference

PageView Class
PageView Members


OnPageOpenFailed Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnPageOpenFailed Property
Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")>
Public Property OnPageOpenFailed As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnPageOpenFailed = value

value = instance.OnPageOpenFailed
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
public string OnPageOpenFailed {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
public: __property string* get_OnPageOpenFailed();
public: __property void set_OnPageOpenFailed(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
public:
property String^ OnPageOpenFailed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised when an apge fails to open.

See Also

Reference

PageView Class
PageView Members


OnPageOpening Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnPageOpening Property
Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client imageOpening Event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnPageOpening As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnPageOpening = value

value = instance.OnPageOpening
[Description("A user defined Javascript event handler to receive a call to the Client imageOpening Event.")]
[Category("Client PageView Control Events")]
public string OnPageOpening {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client imageOpening Event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnPageOpening();
public: __property void set_OnPageOpening(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client imageOpening Event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnPageOpening {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised before the image attributes have been requested from the server, so the viewer will be entering into a transitional state between the current and future image

See Also

Reference

PageView Class
PageView Members


OnPropertyChanged Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : OnPropertyChanged Property
Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the propertyChanged event.")>
<CategoryAttribute("Client PageView Control Events")>
Public Property OnPropertyChanged As String
'Usage

Dim instance As PageView
Dim value As String

instance.OnPropertyChanged = value

value = instance.OnPropertyChanged
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
[Category("Client PageView Control Events")]
public string OnPropertyChanged {get; set;}
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
[Category("Client PageView Control Events")]
public: __property string* get_OnPropertyChanged();
public: __property void set_OnPropertyChanged(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
[Category("Client PageView Control Events")]
public:
property String^ OnPropertyChanged {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

PageView Class
PageView Members


PageNumber Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : PageNumber Property
Gets or sets the Image Page number. This property refers to the page number to be displayed in a multipage document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The page number of a multipage document to be displayed. A single page document has a value zero.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PageView Properties")>
<DefaultValueAttribute()>
Public Property PageNumber As Integer
'Usage

Dim instance As PageView
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
[Description("The page number of a multipage document to be displayed. A single page document has a value zero.")]
[Browsable(true)]
[Category("PageView Properties")]
[DefaultValue()]
public int PageNumber {get; set;}
[Description("The page number of a multipage document to be displayed. A single page document has a value zero.")]
[Browsable(true)]
[Category("PageView Properties")]
[DefaultValue()]
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
[Description("The page number of a multipage document to be displayed. A single page document has a value zero.")]
[Browsable(true)]
[Category("PageView Properties")]
[DefaultValue()]
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value.
Remarks

This property will be the page number for the image to be displayed in the Viewer. The value is zero for a single document image file. The first page of a file has an image page index of zero.

The default value is 0

See Also

Reference

PageView Class
PageView Members


PresentationQuality Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : PresentationQuality Property
Gets or sets the presentation quality for the image to be displayed in the Viewer control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("An integer value ranging between 0 and 100 (0=poor quality)")>
<CategoryAttribute("PageView Properties")>
<DefaultValueAttribute()>
Public Property PresentationQuality As Integer
'Usage

Dim instance As PageView
Dim value As Integer

instance.PresentationQuality = value

value = instance.PresentationQuality
[Browsable(true)]
[Description("An integer value ranging between 0 and 100 (0=poor quality)")]
[Category("PageView Properties")]
[DefaultValue()]
public int PresentationQuality {get; set;}
[Browsable(true)]
[Description("An integer value ranging between 0 and 100 (0=poor quality)")]
[Category("PageView Properties")]
[DefaultValue()]
public: __property int get_PresentationQuality();
public: __property void set_PresentationQuality(
   int value
);
[Browsable(true)]
[Description("An integer value ranging between 0 and 100 (0=poor quality)")]
[Category("PageView Properties")]
[DefaultValue()]
public:
property int PresentationQuality {
   int get();
   void set (    int value);
}

Property Value

An integer value ranging between 0 and 100 (0=poor quality)
Remarks

The range is 0 to 100 (0=poor quality), with higher values resulting in better visual quality in the image and lower values resulting in faster operation of the viewer. The default value is 50.

See Also

Reference

PageView Class
PageView Members


ScrollBars Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ScrollBars Property
Gets or sets the type of scroll bars to display in the Viewer control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("The type of scroll bars to display in the Viewer control.")>
<DefaultValueAttribute()>
Public Property ScrollBars As ScrollBars
'Usage

Dim instance As PageView
Dim value As ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
[Category("PageView Properties")]
[Browsable(true)]
[Description("The type of scroll bars to display in the Viewer control.")]
[DefaultValue()]
public ScrollBars ScrollBars {get; set;}
[Category("PageView Properties")]
[Browsable(true)]
[Description("The type of scroll bars to display in the Viewer control.")]
[DefaultValue()]
public: __property ScrollBars get_ScrollBars();
public: __property void set_ScrollBars(
   ScrollBars value
);
[Category("PageView Properties")]
[Browsable(true)]
[Description("The type of scroll bars to display in the Viewer control.")]
[DefaultValue()]
public:
property ScrollBars ScrollBars {
   ScrollBars get();
   void set (    ScrollBars value);
}

Property Value

One of the values ScrollBars.
Remarks

The default is Auto.

This property enables you to provide horizontal and vertical scroll bars to the user for viewing image in the PageView control to enable scrolling the image within the PageView control that is outside of the physical dimensions of the control (HTML DOM/DIV or CSS Overflow property). You can also use this property to remove scroll bars from the PageView control to restrict scrolling the contents of the PageView control.

See Also

Reference

PageView Class
PageView Members


VectorFormatsRendering Property (PageView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : VectorFormatsRendering Property
Gets or sets the vector formats rendering way.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PageView Properties")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating the way of vector format images rendering.")>
<BrowsableAttribute(True)>
Public Property VectorFormatsRendering As VectorFormatsRendering
'Usage

Dim instance As PageView
Dim value As VectorFormatsRendering

instance.VectorFormatsRendering = value

value = instance.VectorFormatsRendering
[Category("PageView Properties")]
[DefaultValue()]
[Description("Gets or sets a value indicating the way of vector format images rendering.")]
[Browsable(true)]
public VectorFormatsRendering VectorFormatsRendering {get; set;}
[Category("PageView Properties")]
[DefaultValue()]
[Description("Gets or sets a value indicating the way of vector format images rendering.")]
[Browsable(true)]
public: __property VectorFormatsRendering get_VectorFormatsRendering();
public: __property void set_VectorFormatsRendering(
   VectorFormatsRendering value
);
[Category("PageView Properties")]
[DefaultValue()]
[Description("Gets or sets a value indicating the way of vector format images rendering.")]
[Browsable(true)]
public:
property VectorFormatsRendering VectorFormatsRendering {
   VectorFormatsRendering get();
   void set (    VectorFormatsRendering value);
}

Property Value

The enumeration value represents options for vectors format rendering. Default value of property is VectorFormatsRendering.SVG .
Remarks
This property defines the option for rendering vector format images. It must be set to one of the values in the enumeration VectorFormatsRendering. Default value VectorFormatsRendering.SVG defines the mode of rendering of vector format images through SVG format. Set the value of this property to VectorFormatsRendering.Raster for using PNG or JPEG raster formats for rendering of vector format images.
See Also

Reference

PageView Class
PageView Members


ViewMirror Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ViewMirror Property
Gets or sets a value indicating whether the image mirror setting (left and right sides of an image are swapped) is required.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets a value indicating whether Image mirror setting is required.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("PageView Properties")>
Public Property ViewMirror As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.ViewMirror = value

value = instance.ViewMirror
[Description("Gets or sets a value indicating whether Image mirror setting is required.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public bool ViewMirror {get; set;}
[Description("Gets or sets a value indicating whether Image mirror setting is required.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public: __property bool get_ViewMirror();
public: __property void set_ViewMirror(
   bool value
);
[Description("Gets or sets a value indicating whether Image mirror setting is required.")]
[Browsable(true)]
[DefaultValue()]
[Category("PageView Properties")]
public:
property bool ViewMirror {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value
Remarks

The default value is false.

See Also

Reference

PageView Class
PageView Members


ViewRectangle Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ViewRectangle Property
Gets or sets the portion of the image that needs to be displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The PageView Rectangle coordinates for display.")>
<BrowsableAttribute(True)>
<EditorBrowsableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("PageView Properties")>
Public Property ViewRectangle As RectangleF
'Usage

Dim instance As PageView
Dim value As RectangleF

instance.ViewRectangle = value

value = instance.ViewRectangle
[Description("The PageView Rectangle coordinates for display.")]
[Browsable(true)]
[EditorBrowsable()]
[DefaultValue()]
[Category("PageView Properties")]
public RectangleF ViewRectangle {get; set;}
[Description("The PageView Rectangle coordinates for display.")]
[Browsable(true)]
[EditorBrowsable()]
[DefaultValue()]
[Category("PageView Properties")]
public: __property RectangleF get_ViewRectangle();
public: __property void set_ViewRectangle(
   RectangleF value
);
[Description("The PageView Rectangle coordinates for display.")]
[Browsable(true)]
[EditorBrowsable()]
[DefaultValue()]
[Category("PageView Properties")]
public:
property RectangleF ViewRectangle {
   RectangleF get();
   void set (    RectangleF value);
}
Remarks

The default value for this property is applied when this property is not set. The return default value is a rectangle with top, left, width, and height all set to zero.

This property is a System.Drawing.RectangleF rectangle (contains top, left, width, and height properties) that indicates what portion of the image is currently being displayed. The units for the rectangle will be the same as the PageWidth and PageHeight properties (pixels for raster images and points for PDF images.)

See Also

Reference

PageView Class
PageView Members


ViewRotationDegreesClockwise Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > PageView Class : ViewRotationDegreesClockwise Property
Gets or sets the Rotation angle for display in the PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("This property enables you to provide rotation angle for viewing image in the PageView Control.")>
<CategoryAttribute("PageView Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ViewRotationDegreesClockwise As Rotation
'Usage

Dim instance As PageView
Dim value As Rotation

instance.ViewRotationDegreesClockwise = value

value = instance.ViewRotationDegreesClockwise
[Description("This property enables you to provide rotation angle for viewing image in the PageView Control.")]
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
public Rotation ViewRotationDegreesClockwise {get; set;}
[Description("This property enables you to provide rotation angle for viewing image in the PageView Control.")]
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
public: __property Rotation get_ViewRotationDegreesClockwise();
public: __property void set_ViewRotationDegreesClockwise(
   Rotation value
);
[Description("This property enables you to provide rotation angle for viewing image in the PageView Control.")]
[Category("PageView Properties")]
[Browsable(true)]
[DefaultValue()]
public:
property Rotation ViewRotationDegreesClockwise {
   Rotation get();
   void set (    Rotation value);
}

Property Value

One of the values Rotation.
Remarks

The default is RotateNone.

This property enables you to provide rotation angle for viewing image in the PageView Control

See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%%

ThumbnailView Class
Members

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ThumbnailView Class
This class describes the server side ThumbnailView control.
Object Model
ThumbnailView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxDataAttribute("<{0}:ThumbnailView runat=server Width="140px" Height="110px" ></{0}:ThumbnailView>")>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")>
<ToolboxBitmapAttribute()>
Public Class ThumbnailView
   Inherits System.Web.UI.ScriptControl
'Usage

Dim instance As ThumbnailView
[ToolboxData("<{0}:ThumbnailView runat=server Width="140px" Height="110px" ></{0}:ThumbnailView>")]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
public class ThumbnailView : System.Web.UI.ScriptControl
[ToolboxData("<{0}:ThumbnailView runat=server Width="140px" Height="110px" ></{0}:ThumbnailView>")]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
public __gc class ThumbnailView : public System.Web.UI.ScriptControl
[ToolboxData("<{0}:ThumbnailView runat=server Width="140px" Height="110px" ></{0}:ThumbnailView>")]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ImageGear.Web.UI.ViewerDesigner,ImageGear22.Web")]
[ToolboxBitmap()]
public ref class ThumbnailView : public System.Web.UI.ScriptControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.ScriptControl
ImageGear.Web.UI.ThumbnailView

See Also

Reference

ThumbnailView Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ThumbnailView Class Members
Properties Methods Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ThumbnailView Class

The following tables list the members exposed by ThumbnailView.

Public Properties
 | Name | Description
Public Property | ArtEnableMode | Gets or sets a value indicating whether the annotations are required.
Public Property | ClientDebug | Gets or sets a value indicating whether client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client PageView control will log.
Public Property | DocumentIdentifier | Gets or sets the DocumentIdentifier. This property refers to the image file path or the image URL.
Public Property | EncodedDocumentIdentifier | Gets the DocumentIdentifier in encoded format for sending over to the client. This property refers to the encoded image file path or encoded database image key (column/field) value.
Public Property | ImageHandlerUrl | Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Public Property | OnArtPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive a call to the client mouseUp event.
Public Property | OnPageClosed | Gets or sets user defined Javascript event handler to receive a call to the client pageClosed event.
Public Property | OnPageOpened | Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Public Property | OnPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Public Property | OnPageOpening | Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Public Property | OnPropertyChanged | Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Public Property | PageNumber | Gets or sets the Image Page index. This property refers to the index of the page in a multipage document to be displayed in the ThumbnailView control. For a non-multipage document, this value is zero.
Public Property | PageViewID | Gets or sets the PageView control ID where the thumbnail image when selected will be displayed. This ID defines the ThumbnailView control's association with the PageView control.
Public Property | Selected | Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window. If it is set to true, the image in the thumbnail is visible in the associated PageView window.
Top
See Also

Reference

ThumbnailView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Properties$$

ThumbnailView Class Properties

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ThumbnailView Class

For a list of all members of this type, see ThumbnailView members.

Public Properties
 | Name | Description
Public Property | ArtEnableMode | Gets or sets a value indicating whether the annotations are required.
Public Property | ClientDebug | Gets or sets a value indicating whether client side error logging is enabled.
Public Property | ClientDebugErrorLevel | Gets or sets the amount of information the Client PageView control will log.
Public Property | DocumentIdentifier | Gets or sets the DocumentIdentifier. This property refers to the image file path or the image URL.
Public Property | EncodedDocumentIdentifier | Gets the DocumentIdentifier in encoded format for sending over to the client. This property refers to the encoded image file path or encoded database image key (column/field) value.
Public Property | ImageHandlerUrl | Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Public Property | OnArtPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Public Property | OnMouseDown | Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Public Property | OnMouseMove | Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Public Property | OnMouseUp | Gets or sets user defined Javascript event handler to receive a call to the client mouseUp event.
Public Property | OnPageClosed | Gets or sets user defined Javascript event handler to receive a call to the client pageClosed event.
Public Property | OnPageOpened | Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Public Property | OnPageOpenFailed | Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Public Property | OnPageOpening | Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Public Property | OnPropertyChanged | Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Public Property | PageNumber | Gets or sets the Image Page index. This property refers to the index of the page in a multipage document to be displayed in the ThumbnailView control. For a non-multipage document, this value is zero.
Public Property | PageViewID | Gets or sets the PageView control ID where the thumbnail image when selected will be displayed. This ID defines the ThumbnailView control's association with the PageView control.
Public Property | Selected | Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window. If it is set to true, the image in the thumbnail is visible in the associated PageView window.
Top
See Also

Reference

ThumbnailView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Methods$$

ThumbnailView Class Methods

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ThumbnailView Class

For a list of all members of this type, see ThumbnailView members.

See Also

Reference

ThumbnailView Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Events$$

ThumbnailView Class Events

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ThumbnailView Class

For a list of all members of this type, see ThumbnailView members.

See Also

Reference

ThumbnailView Class
ImageGear.Web.UI Namespace


ArtEnableMode Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : ArtEnableMode Property
Gets or sets a value indicating whether the annotations are required.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("An enumeration value representing options for displaying and/or saving annotations.")>
<CategoryAttribute("ThumbnailView Properties")>
<BrowsableAttribute(True)>
Public Property ArtEnableMode As ArtEnableOption
'Usage

Dim instance As ThumbnailView
Dim value As ArtEnableOption

instance.ArtEnableMode = value

value = instance.ArtEnableMode
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
public ArtEnableOption ArtEnableMode {get; set;}
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
public: __property ArtEnableOption get_ArtEnableMode();
public: __property void set_ArtEnableMode(
   ArtEnableOption value
);
[DefaultValue()]
[Description("An enumeration value representing options for displaying and/or saving annotations.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
public:
property ArtEnableOption ArtEnableMode {
   ArtEnableOption get();
   void set (    ArtEnableOption value);
}

Property Value

The enumeration value represents options for displaying and/or saving annotations (Art Data) on images.ArtEnableOption
Remarks
This property specifies the option for showing and saving annotations on the displayed images. It must be set to one of the values in the enumeration ArtEnableOption.

The default value is is ArtEnableOption.None

. In this mode the annotations are not displayed.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


ClientDebug Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : ClientDebug Property
Gets or sets a value indicating whether client side error logging is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets a value indicating whether client side error logging is enabled.")>
<CategoryAttribute("Clientside Error logging Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ClientDebug As Boolean
'Usage

Dim instance As ThumbnailView
Dim value As Boolean

instance.ClientDebug = value

value = instance.ClientDebug
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public bool ClientDebug {get; set;}
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public: __property bool get_ClientDebug();
public: __property void set_ClientDebug(
   bool value
);
[Description("Gets or sets a value indicating whether client side error logging is enabled.")]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[DefaultValue()]
public:
property bool ClientDebug {
   bool get();
   void set (    bool value);
}
Remarks
Turns on or off the Client side error logging. The default value is 'false'.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


ClientDebugErrorLevel Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : ClientDebugErrorLevel Property
Gets or sets the amount of information the Client PageView control will log.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("Clientside Error logging Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("An enumeration value representing the amount of information the Client PageView control will log.")>
Public Property ClientDebugErrorLevel As ClientDebugErrorLevel
'Usage

Dim instance As ThumbnailView
Dim value As ClientDebugErrorLevel

instance.ClientDebugErrorLevel = value

value = instance.ClientDebugErrorLevel
[DefaultValue()]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
public ClientDebugErrorLevel ClientDebugErrorLevel {get; set;}
[DefaultValue()]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
public: __property ClientDebugErrorLevel get_ClientDebugErrorLevel();
public: __property void set_ClientDebugErrorLevel(
   ClientDebugErrorLevel value
);
[DefaultValue()]
[Category("Clientside Error logging Properties")]
[Browsable(true)]
[Description("An enumeration value representing the amount of information the Client PageView control will log.")]
public:
property ClientDebugErrorLevel ClientDebugErrorLevel {
   ClientDebugErrorLevel get();
   void set (    ClientDebugErrorLevel value);
}

Property Value

One of the values ClientDebugErrorLevel. The default value is 'Production'.
Remarks
One of the values ClientDebugErrorLevel. The default value is 'Production'.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


DocumentIdentifier Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : DocumentIdentifier Property
Gets or sets the DocumentIdentifier. This property refers to the image file path or the image URL.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("This property refers to the image file path or database field value.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailView Properties")>
Public Property DocumentIdentifier As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.DocumentIdentifier = value

value = instance.DocumentIdentifier
[Description("This property refers to the image file path or database field value.")]
[Browsable(true)]
[Category("ThumbnailView Properties")]
public string DocumentIdentifier {get; set;}
[Description("This property refers to the image file path or database field value.")]
[Browsable(true)]
[Category("ThumbnailView Properties")]
public: __property string* get_DocumentIdentifier();
public: __property void set_DocumentIdentifier(
   string* value
);
[Description("This property refers to the image file path or database field value.")]
[Browsable(true)]
[Category("ThumbnailView Properties")]
public:
property String^ DocumentIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

Remarks

The default value is an empty string

See Also

Reference

ThumbnailView Class
ThumbnailView Members


EncodedDocumentIdentifier Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : EncodedDocumentIdentifier Property
Gets the DocumentIdentifier in encoded format for sending over to the client. This property refers to the encoded image file path or encoded database image key (column/field) value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Properties")>
<BrowsableAttribute(True)>
<DescriptionAttribute("A read only encoded DocumentIdentifier value.")>
Public ReadOnly Property EncodedDocumentIdentifier As String
'Usage

Dim instance As ThumbnailView
Dim value As String

value = instance.EncodedDocumentIdentifier
[Category("ThumbnailView Properties")]
[Browsable(true)]
[Description("A read only encoded DocumentIdentifier value.")]
public string EncodedDocumentIdentifier {get;}
[Category("ThumbnailView Properties")]
[Browsable(true)]
[Description("A read only encoded DocumentIdentifier value.")]
public: __property string* get_EncodedDocumentIdentifier();
[Category("ThumbnailView Properties")]
[Browsable(true)]
[Description("A read only encoded DocumentIdentifier value.")]
public:
property String^ EncodedDocumentIdentifier {
   String^ get();
}
Remarks

The default value is an empty string

If the DocumentIdentifier property is not set(empty), then this value will be an empty string.

See Also

Reference

ThumbnailView Class
ThumbnailView Members


ImageHandlerUrl Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : ImageHandlerUrl Property
Gets or sets the absolute URL to the Image Service (ImageGearService.svc).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("A fully qualified URL(absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")>
<DefaultValueAttribute()>
<CategoryAttribute("ThumbnailView Properties")>
Public Property ImageHandlerUrl As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.ImageHandlerUrl = value

value = instance.ImageHandlerUrl
[Browsable(true)]
[Description("A fully qualified URL(absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
[Category("ThumbnailView Properties")]
public string ImageHandlerUrl {get; set;}
[Browsable(true)]
[Description("A fully qualified URL(absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
[Category("ThumbnailView Properties")]
public: __property string* get_ImageHandlerUrl();
public: __property void set_ImageHandlerUrl(
   string* value
);
[Browsable(true)]
[Description("A fully qualified URL(absolute URL) to the Image Service (ImageGearService.svc). A relative URL is not recommended.")]
[DefaultValue()]
[Category("ThumbnailView Properties")]
public:
property String^ ImageHandlerUrl {
   String^ get();
   void set (    String^ value);
}
Remarks
The value provided should be a fully qualified URL (absolute URL), a relative URL is not recommended unless it resides at the same level as the application aspx page. Note: It is not necessary to have this property defined if the Image Service is at the same directory level as the application.

When either the PageView or the ThumbnailView control is dragged from the Visual Studio Toolbox on to the web page design surface when in the 'Design' view mode, an 'Action List' will display. This list has options for configuring the Services. For a detailed description, refer to the web.config settings section in this help document.

Note: If you add the control on your web page using the source editor, then you can still use the Action List menu items (Smart Tags Panel) on the PageView and ThumbnailView by switching to the 'Design' view mode in the Visual Studio.

A more detailed explanation for the Services setting can be found in the web.config settings section of the help file.

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnArtPageOpenFailed Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnArtPageOpenFailed Property
Gets or sets user defined Javascript event handler to receive a call to the client artPageOpenFailed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Client PageView Control Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")>
Public Property OnArtPageOpenFailed As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnArtPageOpenFailed = value

value = instance.OnArtPageOpenFailed
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
public string OnArtPageOpenFailed {get; set;}
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
public: __property string* get_OnArtPageOpenFailed();
public: __property void set_OnArtPageOpenFailed(
   string* value
);
[Category("Client PageView Control Events")]
[Description("A user defined Javascript event handler to receive a call to the Client artPageOpenFailed Event.")]
public:
property String^ OnArtPageOpenFailed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised when an ART load fails to open.

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnMouseDown Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnMouseDown Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseDown event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Client Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")>
Public Property OnMouseDown As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnMouseDown = value

value = instance.OnMouseDown
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
public string OnMouseDown {get; set;}
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
public: __property string* get_OnMouseDown();
public: __property void set_OnMouseDown(
   string* value
);
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client mouseDown Event.")]
public:
property String^ OnMouseDown {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnMouseMove Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnMouseMove Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseMove event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")>
<CategoryAttribute("ThumbnailView Client Events")>
Public Property OnMouseMove As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnMouseMove = value

value = instance.OnMouseMove
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
[Category("ThumbnailView Client Events")]
public string OnMouseMove {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
[Category("ThumbnailView Client Events")]
public: __property string* get_OnMouseMove();
public: __property void set_OnMouseMove(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client mouseMove Event.")]
[Category("ThumbnailView Client Events")]
public:
property String^ OnMouseMove {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnMouseUp Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnMouseUp Property
Gets or sets user defined Javascript event handler to receive a call to the client mouseUp event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client mouseUp Event.")>
<CategoryAttribute("ThumbnailView Client Events")>
Public Property OnMouseUp As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnMouseUp = value

value = instance.OnMouseUp
[Description("A user defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("ThumbnailView Client Events")]
public string OnMouseUp {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("ThumbnailView Client Events")]
public: __property string* get_OnMouseUp();
public: __property void set_OnMouseUp(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client mouseUp Event.")]
[Category("ThumbnailView Client Events")]
public:
property String^ OnMouseUp {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnPageClosed Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnPageClosed Property
Gets or sets user defined Javascript event handler to receive a call to the client pageClosed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageClosed Event.")>
<CategoryAttribute("ThumbnailView Client Events")>
Public Property OnPageClosed As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnPageClosed = value

value = instance.OnPageClosed
[Description("A user defined Javascript event handler to receive a call to the Client pageClosed Event.")]
[Category("ThumbnailView Client Events")]
public string OnPageClosed {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client pageClosed Event.")]
[Category("ThumbnailView Client Events")]
public: __property string* get_OnPageClosed();
public: __property void set_OnPageClosed(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client pageClosed Event.")]
[Category("ThumbnailView Client Events")]
public:
property String^ OnPageClosed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised during a call to be raised during a call to viewer.ClosePage().

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnPageOpened Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnPageOpened Property
Gets or sets user defined Javascript event handler to receive a call to the client pageOpened event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Client Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")>
Public Property OnPageOpened As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnPageOpened = value

value = instance.OnPageOpened
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public string OnPageOpened {get; set;}
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public: __property string* get_OnPageOpened();
public: __property void set_OnPageOpened(
   string* value
);
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpened Event.")]
public:
property String^ OnPageOpened {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised after the image attributes have been received from the server. At this point, the previous image will be discarded. The new current image may not have been displayed yet, but that will occur soon

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnPageOpenFailed Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnPageOpenFailed Property
Gets or sets user defined Javascript event handler to receive a call to the client pageOpenFailed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")>
<CategoryAttribute("ThumbnailView Client Events")>
Public Property OnPageOpenFailed As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnPageOpenFailed = value

value = instance.OnPageOpenFailed
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
[Category("ThumbnailView Client Events")]
public string OnPageOpenFailed {get; set;}
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
[Category("ThumbnailView Client Events")]
public: __property string* get_OnPageOpenFailed();
public: __property void set_OnPageOpenFailed(
   string* value
);
[Description("A user defined Javascript event handler to receive a call to the Client pageOpenFailed Event.")]
[Category("ThumbnailView Client Events")]
public:
property String^ OnPageOpenFailed {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised when an image fails to open.

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnPageOpening Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnPageOpening Property
Gets or sets user defined Javascript event handler to receive a call to the client imageOpening event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Client Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the Client pageOpening Event.")>
Public Property OnPageOpening As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnPageOpening = value

value = instance.OnPageOpening
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpening Event.")]
public string OnPageOpening {get; set;}
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpening Event.")]
public: __property string* get_OnPageOpening();
public: __property void set_OnPageOpening(
   string* value
);
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the Client pageOpening Event.")]
public:
property String^ OnPageOpening {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.

This event will be raised before the image attributes have been requested from the server, so the viewer will be entering into a funny state between the current and future image

See Also

Reference

ThumbnailView Class
ThumbnailView Members


OnPropertyChanged Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : OnPropertyChanged Property
Gets or sets user defined Javascript event handler to receive a call to the propertyChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Client Events")>
<DescriptionAttribute("A user defined Javascript event handler to receive a call to the propertyChanged event.")>
Public Property OnPropertyChanged As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.OnPropertyChanged = value

value = instance.OnPropertyChanged
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public string OnPropertyChanged {get; set;}
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public: __property string* get_OnPropertyChanged();
public: __property void set_OnPropertyChanged(
   string* value
);
[Category("ThumbnailView Client Events")]
[Description("A user defined Javascript event handler to receive a call to the propertyChanged event.")]
public:
property String^ OnPropertyChanged {
   String^ get();
   void set (    String^ value);
}
Remarks
The string value is the name of the Javascript event handler name.
See Also

Reference

ThumbnailView Class
ThumbnailView Members


PageNumber Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : PageNumber Property
Gets or sets the Image Page index. This property refers to the index of the page in a multipage document to be displayed in the ThumbnailView control. For a non-multipage document, this value is zero.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Properties")>
<DefaultValueAttribute()>
<DescriptionAttribute("The page number of a multipage document to be displayed. A single page document has a value zero(0).")>
<BrowsableAttribute(True)>
Public Property PageNumber As Integer
'Usage

Dim instance As ThumbnailView
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
[Category("ThumbnailView Properties")]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
[Browsable(true)]
public int PageNumber {get; set;}
[Category("ThumbnailView Properties")]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
[Browsable(true)]
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
[Category("ThumbnailView Properties")]
[DefaultValue()]
[Description("The page number of a multipage document to be displayed. A single page document has a value zero(0).")]
[Browsable(true)]
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value.
Remarks

The default value is 0

See Also

Reference

ThumbnailView Class
ThumbnailView Members


PageViewID Property

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : PageViewID Property
Gets or sets the PageView control ID where the thumbnail image when selected will be displayed. This ID defines the ThumbnailView control's association with the PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("PageView control ID where the thumbnail image when selected will be displayed.")>
<CategoryAttribute("ThumbnailView Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property PageViewID As String
'Usage

Dim instance As ThumbnailView
Dim value As String

instance.PageViewID = value

value = instance.PageViewID
[Description("PageView control ID where the thumbnail image when selected will be displayed.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
public string PageViewID {get; set;}
[Description("PageView control ID where the thumbnail image when selected will be displayed.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
public: __property string* get_PageViewID();
public: __property void set_PageViewID(
   string* value
);
[Description("PageView control ID where the thumbnail image when selected will be displayed.")]
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
public:
property String^ PageViewID {
   String^ get();
   void set (    String^ value);
}

Property Value

a string value
Remarks
a string value

The default value is an empty string.

See Also

Reference

ThumbnailView Class
ThumbnailView Members


Selected Property (ThumbnailView)

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace > ThumbnailView Class : Selected Property
Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window. If it is set to true, the image in the thumbnail is visible in the associated PageView window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ThumbnailView Properties")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute(" Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window.")>
Public Property Selected As Boolean
'Usage

Dim instance As ThumbnailView
Dim value As Boolean

instance.Selected = value

value = instance.Selected
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window.")]
public bool Selected {get; set;}
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window.")]
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
[Category("ThumbnailView Properties")]
[Browsable(true)]
[DefaultValue()]
[Description(" Gets or sets a value indicating whether this thumbnail is required to be displayed in the asosciated PageView window.")]
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value
Remarks
Boolean value

The default value is false

See Also

Reference

ThumbnailView Class
ThumbnailView Members


%%PageItemTitle%%

ArtEnableOption Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ArtEnableOption Enumeration
Option values for enabling annotations on images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ArtEnableOption
   Inherits System.Enum
'Usage

Dim instance As ArtEnableOption
public enum ArtEnableOption : System.Enum
__value public enum ArtEnableOption : public System.Enum
public enum class ArtEnableOption : public System.Enum
Members
Member | Value | Description
None | 0 | Annotations cannot be used on the client. Accessing the Annotations API on the client will not work.
ReadOnly | 1 | Annotations are displayed but can not be edited successfully in this mode. Any edited annotations will not be saved during the postback.
ReadWrite | 2 | In this mode, the annotations are displayed and saved during postbacks by the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ArtEnableOption

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ClientDebugErrorLevel Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ClientDebugErrorLevel Enumeration
Option values for error logging on the client side.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ClientDebugErrorLevel
   Inherits System.Enum
'Usage

Dim instance As ClientDebugErrorLevel
public enum ClientDebugErrorLevel : System.Enum
__value public enum ClientDebugErrorLevel : public System.Enum
public enum class ClientDebugErrorLevel : public System.Enum
Members
Member | Value | Description
Detailed | 2 | In addition to the logging done by the Development level, the PageView client logs all properties read by the page. The text of the log entry will include the name of the property and its current value.
Development | 1 | In addition to the logging done by the Production level, the PageView Client logs all control functions that are called by the page and any properties that are changed by the page. The text of the log entry will include the name of the function, the values of the parameters, and the return value (if any).
Production | 0 | PageView Client will log only exceptions that occur inside the control or an event handler.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ClientDebugErrorLevel

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

FitType Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : FitType Enumeration
Option values to determine if the image fit is within the PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FitType
   Inherits System.Enum
'Usage

Dim instance As FitType
public enum FitType : System.Enum
__value public enum FitType : public System.Enum
public enum class FitType : public System.Enum
Members
Member | Value | Description
ActualSize | 3 | Full actual size image appears in the control. Scales the PageView such that the image is displayed actual size. When displaying an image in this fashion, 1 inch of the screen will display 1 inch of the image. If the image is larger than the screen, portions of the image will not be visible.
FullHeight | 2 | Fit to the height of the PageView control.
FullImage | 0 | Fit such that the entire image appears within the PageView control.
FullWidth | 1 | Fit to the width of the PageView control.
OneToOne | 4 | Image appears in the control with no scaling (each image pixel will occupy one window pixel). If the image does not have square pixels, then the viewer will show one image pixel with exactly one window pixel either horizontally or vertically, and more than one pixel in the other direction. You cannot use this value for PDF images because it is based on pixels, which PDF images do not have. If the image is larger than the screen, portions of the image will not be visible.
Rectangle | 5 | A special value that indicates the viewer should display a particular rectangle. When you use this value, the viewer will display the specified rectangle of the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.FitType

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImGearArtDataServices Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearArtDataServices Enumeration
Specifies Options for using Art Data services.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearArtDataServices
   Inherits System.Enum
'Usage

Dim instance As ImGearArtDataServices
public enum ImGearArtDataServices : System.Enum
__value public enum ImGearArtDataServices : public System.Enum
public enum class ImGearArtDataServices : public System.Enum
Members
Member | Value | Description
ArtDataService | 1 | ImageGear RESTful Art Data Service will be used.
None | 0 | No Annotations services.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ImGearArtDataServices

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImGearDataBindingType Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearDataBindingType Enumeration
Specifies page or document level binding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDataBindingType
   Inherits System.Enum
'Usage

Dim instance As ImGearDataBindingType
public enum ImGearDataBindingType : System.Enum
__value public enum ImGearDataBindingType : public System.Enum
public enum class ImGearDataBindingType : public System.Enum
Members
Member | Value | Description
Document | 0 | The data list provided binds to the control at the document level.
Page | 1 | The data list provided binds to the control at the page level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ImGearDataBindingType

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImGearThumbnailLayout Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailLayout Enumeration
Specifies the layout and scroll directions of thumbnails in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearThumbnailLayout
   Inherits System.Enum
'Usage

Dim instance As ImGearThumbnailLayout
public enum ImGearThumbnailLayout : System.Enum
__value public enum ImGearThumbnailLayout : public System.Enum
public enum class ImGearThumbnailLayout : public System.Enum
Members
Member | Value | Description
HorizontalScrollDirection | 1 | Thumbnails scroll horizontally.
VerticalScrollDirection | 0 | Thumbnails scroll vertically.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ImGearThumbnailLayout

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImGearThumbnailSelectionMode Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ImGearThumbnailSelectionMode Enumeration
Specifies Thumbnail Selection mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearThumbnailSelectionMode
   Inherits System.Enum
'Usage

Dim instance As ImGearThumbnailSelectionMode
public enum ImGearThumbnailSelectionMode : System.Enum
__value public enum ImGearThumbnailSelectionMode : public System.Enum
public enum class ImGearThumbnailSelectionMode : public System.Enum
Members
Member | Value | Description
Multiple | 2 | Thumbnails can be selected in groups using the SHIFT and mouse or arrow keys (Not implemented yet)
Single | 1 | Only one thumbnail can be selected at a time.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ImGearThumbnailSelectionMode

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

MouseTool Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : MouseTool Enumeration
Option values used to determine mouse tool selected. Each of these tools will determine a cursor and the behavior of the left mouse button. This enumeration indicates how the viewer should act when a user interacts with it using a mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MouseTool
   Inherits System.Enum
'Usage

Dim instance As MouseTool
public enum MouseTool : System.Enum
__value public enum MouseTool : public System.Enum
public enum class MouseTool : public System.Enum
Members
Member | Value | Description
CreateEllipseMark | 6 | Pressing the left mouse button and dragging will create an ellipse mark.
CreateFreehandMark | 9 | Pressing the left mouse button and dragging will create a freehand line mark.
CreateLineMark | 7 | Pressing the left mouse button and dragging will create a line mark.
CreatePolygonMark | 10 | Clicking the left mouse button multiple times will create a polygon mark.
CreatePolylineMark | 8 | Clicking the left mouse button multiple times will create a polyline mark.
CreateRectangleMark | 5 | Pressing the left mouse button and dragging will create a rectangle mark.
CreateTextMark | 11 | Pressing the left mouse button and dragging a rectangle will create a text mark.
EditMarks 12 Provides interactive editing of marks.

Action details:

Clicking outside of a mark, then dragging a rectangle will select all the marks that are wholly contained in the rectangle (and de-select all other marks). Clicking outside of a mark while holding the shift key, then dragging a rectangle will select all the marks that are wholly contained in the rectangle (and will not de-select all other marks). Clicking on an unselected mark will select the mark (and de-select all other marks). Clicking on a mark while holding the control or shift key will toggle the selected state of the mark. Clicking on a mark, then dragging will move the selected annotation(s). Clicking on a mark handle, will de-select all other marks. Clicking on a mark handle, then dragging will change the size or shape by moving that portion of the mark. Clicking on a mark handle while holding the control key, then dragging will change the size or shape of the mark and keep the center of the mark in its original location. Clicking on a corner mark handle while holding the shift key, then dragging will change the size of the mark and keep the aspect ratio unchanged. Double-clicking a text mark will select that mark, de-select all other marks, and switch the mark into text-entry mode.

HandPan | 3 | Panning tool. Pressing and moving the left mouse button will drag the image in the direction that the mouse is moved.
Magnifier | 1 | Magnifying window. Pressing the left mouse button displays magnifying glass. Moving the mouse while pressing the button will move the magnifying glass. On releasing the left mouse button the magnifying glass will hide.
None | 0 | No MouseTool is selected. The left mouse button will do nothing and the cursor will be the default browser cursor.
RectangleZoom | 2 | Zoom Rectangle Tool. Pressing the left mouse button and dragging the mouse will select a rectangular area on the image. Releasing the mouse button causes the selected rectangular area to be zoomed.
RunMarks | 13 | The cursor over marks will be a "link" cursor and you can detect when a user clicks on a mark by looking at the mark property of the object.
Select | 4 | Window selection tool. Pressing the left mouse button and dragging a rectangle will select an area. When you release the button, the selection will remain. This mouse tool is useful for supporting some operation that you will perform on a server, such as cropping or OCR.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.MouseTool

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

Rotation Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : Rotation Enumeration
Option values for image rotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Rotation
   Inherits System.Enum
'Usage

Dim instance As Rotation
public enum Rotation : System.Enum
__value public enum Rotation : public System.Enum
public enum class Rotation : public System.Enum
Members
Member | Value | Description
Rotate180 | 180 | Image is rotated 180 degrees clockwise.
Rotate270 | 270 | Image is rotated 270 degrees clockwise.
Rotate90 | 90 | Image is rotated 90 degrees clockwise.
RotateNone | 0 | Image is not rotated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.Rotation

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

ScrollBars Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : ScrollBars Enumeration
Option values to determine how scrollbars should be handled in the Client PageView control at runtime.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ScrollBars
   Inherits System.Enum
'Usage

Dim instance As ScrollBars
public enum ScrollBars : System.Enum
__value public enum ScrollBars : public System.Enum
public enum class ScrollBars : public System.Enum
Members
Member | Value | Description
Auto | 4 | The Client PageView control displays scrollbars only when needed.
Both | 3 | Both vertical and horizontal scrollbars displayed in the Client PageView control.
None | 0 | Scrollbars are not displayed in the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ScrollBars

See Also

Reference

ImageGear.Web.UI Namespace


%%PageItemTitle%%

VectorFormatsRendering Enumeration

ImageGear22.Web Assembly > ImageGear.Web.UI Namespace : VectorFormatsRendering Enumeration
Specifies the vector format rendering way.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum VectorFormatsRendering
   Inherits System.Enum
'Usage

Dim instance As VectorFormatsRendering
public enum VectorFormatsRendering : System.Enum
__value public enum VectorFormatsRendering : public System.Enum
public enum class VectorFormatsRendering : public System.Enum
Members
Member | Value | Description
Raster | 1 | Vector format is rendered as raster format (PNG, JPEG).
SVG | 0 | Vector format is rendered as SVG.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.VectorFormatsRendering

See Also

Reference

ImageGear.Web.UI Namespace


ImageGear22.Web.ImageDataProcessor Assembly
Namespaces
Namespace | Description
ImageGear.Web.UI | The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.


ImageGear.Web.UI Namespace (ImageGear22.Web.ImageDataProcessor)
Inheritance Hierarchy
ImageGear22.Web.ImageDataProcessor Assembly : ImageGear.Web.UI Namespace

The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.

Classes
 | Class | Description
Class | ImageGearBackEnd | The ImageGearBackEnd Control adds all the necessary .NET ImageGear dependent files to the Web Application's bin folder when the control is dragged from the visualStudio Toolbox to the web page in design view. This control has no User interface. Also, this control does not contain any properties or methods.
See Also

Reference

ImageGear22.Web.ImageDataProcessor Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.UI Namespace (ImageGear22.Web.ImageDataProcessor) Inheritance Hierarchy
ImageGear22.Web.ImageDataProcessor Assembly : ImageGear.Web.UI Namespace
Inheritance Hierarchy
System.Object
System.Web.UI.Control
ImageGear.Web.UI.ImageGearBackEnd
See Also

Reference

ImageGear22.Web.ImageDataProcessor Assembly


%%PageItemTitle%%

ImageGearBackEnd Class
Members

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace : ImageGearBackEnd Class
The ImageGearBackEnd Control adds all the necessary .NET ImageGear dependent files to the Web Application's bin folder when the control is dragged from the visualStudio Toolbox to the web page in design view. This control has no User interface. Also, this control does not contain any properties or methods.
Object Model
ImageGearBackEnd Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxDataAttribute("<{0}:ImageGearBackEnd runat=server></{0}:ImageGearBackEnd>")>
<ToolboxBitmapAttribute()>
Public Class ImageGearBackEnd
   Inherits System.Web.UI.Control
'Usage

Dim instance As ImageGearBackEnd
[ToolboxData("<{0}:ImageGearBackEnd runat=server></{0}:ImageGearBackEnd>")]
[ToolboxBitmap()]
public class ImageGearBackEnd : System.Web.UI.Control
[ToolboxData("<{0}:ImageGearBackEnd runat=server></{0}:ImageGearBackEnd>")]
[ToolboxBitmap()]
public __gc class ImageGearBackEnd : public System.Web.UI.Control
[ToolboxData("<{0}:ImageGearBackEnd runat=server></{0}:ImageGearBackEnd>")]
[ToolboxBitmap()]
public ref class ImageGearBackEnd : public System.Web.UI.Control
Remarks
Note: You can choose to remove this ImageGearBackend control tag and registration from your web page after all the necessary files are in your bin folder.

This control can only serve the desired function if you drag from the Visual studio toolbox to your web page.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
ImageGear.Web.UI.ImageGearBackEnd

See Also

Reference

ImageGearBackEnd Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ImageGearBackEnd Class Members
Properties Methods Events

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace : ImageGearBackEnd Class

The following tables list the members exposed by ImageGearBackEnd.

Public Constructors
 | Name | Description
Public Constructor | ImageGearBackEnd Constructor |
Top
See Also

Reference

ImageGearBackEnd Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Properties$$

ImageGearBackEnd Class Properties

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace : ImageGearBackEnd Class

For a list of all members of this type, see ImageGearBackEnd members.

See Also

Reference

ImageGearBackEnd Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Methods$$

ImageGearBackEnd Class Methods

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace : ImageGearBackEnd Class

For a list of all members of this type, see ImageGearBackEnd members.

See Also

Reference

ImageGearBackEnd Class
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Events$$

ImageGearBackEnd Class Events

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace : ImageGearBackEnd Class

For a list of all members of this type, see ImageGearBackEnd members.

See Also

Reference

ImageGearBackEnd Class
ImageGear.Web.UI Namespace


%%PageItemTitle%%

ImageGearBackEnd Constructor

ImageGear22.Web.ImageDataProcessor Assembly > ImageGear.Web.UI Namespace > ImageGearBackEnd Class : ImageGearBackEnd Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageGearBackEnd()
public ImageGearBackEnd()
public: ImageGearBackEnd();
public:
ImageGearBackEnd();
See Also

Reference

ImageGearBackEnd Class
ImageGearBackEnd Members


ImageGear22.Web.Services Assembly
Namespaces
Namespace | Description
ImageGear.Web.DataProviders | The ImageGear.Web.DataProviders namespace includes ImageDataProvider classes for images that are stored in files or in a SQL database, as well as a provider-based model that you can use to create custom image data providers.
ImageGear.Web.UI | The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.


ImageGear.Web.DataProviders Namespace
Inheritance Hierarchy
ImageGear22.Web.Services Assembly : ImageGear.Web.DataProviders Namespace
The ImageGear.Web.DataProviders namespace includes ImageDataProvider classes for images that are stored in files or in a SQL database, as well as a provider-based model that you can use to create custom image data providers.
Classes
 | Class | Description
Class | ArtDataConnection | ArtDataConnection is an abstract base class. All data providers will implement a derived class of this. The class can be used to read or write any number of streams. This class implements System.IDisposable interface.
Class | ArtDocumentDataConnection | This is an abstract base class that represents a connection to a specific document. All data providers would implement a derived class of this. This class implements IDisposable System.IDisposable.
Class | ImageDataConnection | ImageDataConnection is an abstract base class. All data providers will implement a derived class of this. The class can be used to read or write any number of streams. This class implements System.IDisposable interface.
Class | ImageDataProvider | ImageDataProvider is a base class derived from the System.Configuration.Provider.ProviderBase class ( System.Configuration.Provider.ProviderBase ). It provides a base implementation for the ImageGear image data provider for the PageView and ThumbnailView components. This is an abstract class.
Class | ImageDocumentDataConnection | This is an abstract base class that represents a connection to a specific document. All data providers would implement a derived class of this. This class implements IDisposable System.IDisposable.
See Also

Reference

ImageGear22.Web.Services Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.DataProviders Namespace Inheritance Hierarchy
ImageGear22.Web.Services Assembly : ImageGear.Web.DataProviders Namespace
Inheritance Hierarchy
System.Object
ImageGear.Web.DataProviders.ArtDataConnection
ImageGear.Web.DataProviders.ArtDocumentDataConnection
ImageGear.Web.DataProviders.ImageDataConnection
ImageGear.Web.DataProviders.ImageDocumentDataConnection
System.Configuration.Provider.ProviderBase
ImageGear.Web.DataProviders.ImageDataProvider
See Also

Reference

ImageGear22.Web.Services Assembly


%%PageItemTitle%%

ArtDataConnection Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDataConnection Class
ArtDataConnection is an abstract base class. All data providers will implement a derived class of this. The class can be used to read or write any number of streams. This class implements System.IDisposable interface.
Object Model
ArtDataConnection ClassArtDocumentDataConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ArtDataConnection
'Usage

Dim instance As ArtDataConnection
public abstract class ArtDataConnection
public __gc abstract class ArtDataConnection
public ref class ArtDataConnection abstract
Remarks
If you are writing a custom image data provider, then your custom data provider must implement a class derived from this class.

For example code, refer to the RadiologyOffice sample.

Inheritance Hierarchy

System.Object
ImageGear.Web.DataProviders.ArtDataConnection

See Also

Reference

ArtDataConnection Members
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Members$$

ArtDataConnection Class Members
Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDataConnection Class

The following tables list the members exposed by ArtDataConnection.

Public Methods
 | Name | Description
Public Method | Close | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Public Method | Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Public Method | OpenDocument | This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ArtDocumentDataConnection object to the openDocuments set.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | Using this method, the derived class would know when to close its connection with the data source.
Top
See Also

Reference

ArtDataConnection Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Methods$$

ArtDataConnection Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDataConnection Class

For a list of all members of this type, see ArtDataConnection members.

Public Methods
 | Name | Description
Public Method | Close | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Public Method | Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Public Method | OpenDocument | This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ArtDocumentDataConnection object to the openDocuments set.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | Using this method, the derived class would know when to close its connection with the data source.
Top
See Also

Reference

ArtDataConnection Class
ImageGear.Web.DataProviders Namespace


Close Method (ArtDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDataConnection Class : Close Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As ArtDataConnection

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Remarks
See Also

Reference

ArtDataConnection Class
ArtDataConnection Members


Closed Method (ArtDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDataConnection Class : Closed Method
Using this method, the derived class would know when to close its connection with the data source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub Closed()
'Usage

Dim instance As ArtDataConnection

instance.Closed()
protected abstract void Closed()
protected: abstract void Closed();
protected:
abstract void Closed();
See Also

Reference

ArtDataConnection Class
ArtDataConnection Members


Dispose Method (ArtDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDataConnection Class : Dispose Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Overload List
Overload | Description
Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
See Also

Reference

ArtDataConnection Class
ArtDataConnection Members


Dispose() Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDataConnection Class : Dispose() Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ArtDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ArtDataConnection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ArtDataConnection Class
ArtDataConnection Members


OpenDocument Method (ArtDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDataConnection Class : OpenDocument Method
Used to indicate the identifier of the document with which the Page ART data is associated.
This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ArtDocumentDataConnection object to the openDocuments set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function OpenDocument( _
   ByVal documentIdentifier As String _
) As ArtDocumentDataConnection
'Usage

Dim instance As ArtDataConnection
Dim documentIdentifier As String
Dim value As ArtDocumentDataConnection

value = instance.OpenDocument(documentIdentifier)
public abstract ArtDocumentDataConnection OpenDocument(
   string documentIdentifier
)
public: abstract ArtDocumentDataConnection* OpenDocument(
   string* documentIdentifier
)
public:
abstract ArtDocumentDataConnection^ OpenDocument(
   String^ documentIdentifier
)

Parameters

documentIdentifier
Used to indicate the identifier of the document with which the Page ART data is associated.

Return Value

ArtDocumentDataConnection object.
Remarks

For details, refer to the "ImageGear.Web.UI.PageView.DocumentIdentifier".

See Also

Reference

ArtDataConnection Class
ArtDataConnection Members


%%PageItemTitle%%

ArtDocumentDataConnection Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDocumentDataConnection Class
This is an abstract base class that represents a connection to a specific document. All data providers would implement a derived class of this. This class implements IDisposable System.IDisposable.
Object Model
ArtDocumentDataConnection ClassArtDataConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ArtDocumentDataConnection
'Usage

Dim instance As ArtDocumentDataConnection
public abstract class ArtDocumentDataConnection
public __gc abstract class ArtDocumentDataConnection
public ref class ArtDocumentDataConnection abstract
Remarks
If you are writing a custom image data provider, then your custom data provider must implement a class derived from this class.

For example code, refer to the RadiologyOffice sample.

Inheritance Hierarchy

System.Object
ImageGear.Web.DataProviders.ArtDocumentDataConnection

See Also

Reference

ArtDocumentDataConnection Members
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Members$$

ArtDocumentDataConnection Class Members
Properties Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDocumentDataConnection Class

The following tables list the members exposed by ArtDocumentDataConnection.

Public Properties
 | Name | Description
Public Property | ArtDataConnection | Gets (ArtDataConnection) object. object.
Public Property | DocumentIdentifier | Gets DocumentIdentifier property.
Top
Public Methods
 | Name | Description
Public Method | Close | This method simply calls Dispose().
Public Method | Dispose | This closes the connection to a document. The base class also calls ArtDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Public Method | Read | This reads the content of the annotation data and returns it in the form of a stream.
Public Method | Write | This method overwrites the existing ART (annottaions) content.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | The derived class can implement this method to do the necessary cleanup when the document is closed.
Top
See Also

Reference

ArtDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Methods$$

ArtDocumentDataConnection Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDocumentDataConnection Class

For a list of all members of this type, see ArtDocumentDataConnection members.

Public Methods
 | Name | Description
Public Method | Close | This method simply calls Dispose().
Public Method | Dispose | This closes the connection to a document. The base class also calls ArtDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Public Method | Read | This reads the content of the annotation data and returns it in the form of a stream.
Public Method | Write | This method overwrites the existing ART (annottaions) content.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | The derived class can implement this method to do the necessary cleanup when the document is closed.
Top
See Also

Reference

ArtDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


Close Method (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Close Method
This method simply calls Dispose().
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As ArtDocumentDataConnection

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Remarks
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


Closed Method (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Closed Method
The derived class can implement this method to do the necessary cleanup when the document is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub Closed()
'Usage

Dim instance As ArtDocumentDataConnection

instance.Closed()
protected abstract void Closed()
protected: abstract void Closed();
protected:
abstract void Closed();
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


Dispose Method (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Dispose Method
This closes the connection to a document. The base class also calls ArtDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Overload List
Overload | Description
Dispose | This closes the connection to a document. The base class also calls ArtDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


Dispose() Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Dispose() Method
This closes the connection to a document. The base class also calls ArtDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ArtDocumentDataConnection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
For a SQL provider, this does nothing.
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


Read Method (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Read Method
This reads the content of the annotation data and returns it in the form of a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Read() As Stream
'Usage

Dim instance As ArtDocumentDataConnection
Dim value As Stream

value = instance.Read()
public abstract Stream Read()
public: abstract Stream* Read();
public:
abstract Stream^ Read();

Return Value

System.IO.Stream object.
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


Write Method (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : Write Method
A System.IO.Stream of data to be written
This method overwrites the existing ART (annottaions) content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Write( _
   ByVal artDStream As Stream _
)
'Usage

Dim instance As ArtDocumentDataConnection
Dim artDStream As Stream

instance.Write(artDStream)
public abstract void Write(
   Stream artDStream
)
public: abstract void Write(
   Stream* artDStream
)
public:
abstract void Write(
   Stream^ artDStream
)

Parameters

artDStream
A System.IO.Stream of data to be written
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


%%PageItemTitle%% $$Properties$$

ArtDocumentDataConnection Class Properties

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ArtDocumentDataConnection Class

For a list of all members of this type, see ArtDocumentDataConnection members.

Public Properties
 | Name | Description
Public Property | ArtDataConnection | Gets (ArtDataConnection) object. object.
Public Property | DocumentIdentifier | Gets DocumentIdentifier property.
Top
See Also

Reference

ArtDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


ArtDataConnection Property

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : ArtDataConnection Property
Gets (ArtDataConnection) object. object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ArtDataConnection As ArtDataConnection
'Usage

Dim instance As ArtDocumentDataConnection
Dim value As ArtDataConnection

value = instance.ArtDataConnection
public ArtDataConnection ArtDataConnection {get;}
public: __property ArtDataConnection* get_ArtDataConnection();
public:
property ArtDataConnection^ ArtDataConnection {
   ArtDataConnection^ get();
}
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


DocumentIdentifier Property (ArtDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ArtDocumentDataConnection Class : DocumentIdentifier Property
Gets DocumentIdentifier property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DocumentIdentifier As String
'Usage

Dim instance As ArtDocumentDataConnection
Dim value As String

value = instance.DocumentIdentifier
public string DocumentIdentifier {get;}
public: __property string* get_DocumentIdentifier();
public:
property String^ DocumentIdentifier {
   String^ get();
}
See Also

Reference

ArtDocumentDataConnection Class
ArtDocumentDataConnection Members


%%PageItemTitle%%

ImageDataConnection Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataConnection Class
ImageDataConnection is an abstract base class. All data providers will implement a derived class of this. The class can be used to read or write any number of streams. This class implements System.IDisposable interface.
Object Model
ImageDataConnection ClassImageDocumentDataConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImageDataConnection
'Usage

Dim instance As ImageDataConnection
public abstract class ImageDataConnection
public __gc abstract class ImageDataConnection
public ref class ImageDataConnection abstract
Remarks
If you are writing a custom image data provider, then your custom data provider must implement a class derived from this class.
Inheritance Hierarchy

System.Object
ImageGear.Web.DataProviders.ImageDataConnection

See Also

Reference

ImageDataConnection Members
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Members$$

ImageDataConnection Class Members
Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataConnection Class

The following tables list the members exposed by ImageDataConnection.

Public Methods
 | Name | Description
Public Method | Close | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Public Method | Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Public Method | OpenDocument | This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ImageDocumentDataConnection object to the openDocuments set.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | Using this method, the derived class would know when to close its connection with the data source.
Top
See Also

Reference

ImageDataConnection Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Methods$$

ImageDataConnection Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataConnection Class

For a list of all members of this type, see ImageDataConnection members.

Public Methods
 | Name | Description
Public Method | Close | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Public Method | Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Public Method | OpenDocument | This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ImageDocumentDataConnection object to the openDocuments set.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | Using this method, the derived class would know when to close its connection with the data source.
Top
See Also

Reference

ImageDataConnection Class
ImageGear.Web.DataProviders Namespace


Close Method (ImageDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataConnection Class : Close Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Dispose() method. In fact, this method does not need to be virtual; the base class can implement it as a call to Dispose().
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As ImageDataConnection

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Remarks
See Also

Reference

ImageDataConnection Class
ImageDataConnection Members


Closed Method (ImageDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataConnection Class : Closed Method
Using this method, the derived class would know when to close its connection with the data source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub Closed()
'Usage

Dim instance As ImageDataConnection

instance.Closed()
protected abstract void Closed()
protected: abstract void Closed();
protected:
abstract void Closed();
See Also

Reference

ImageDataConnection Class
ImageDataConnection Members


Dispose Method (ImageDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataConnection Class : Dispose Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Overload List
Overload | Description
Dispose | This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
See Also

Reference

ImageDataConnection Class
ImageDataConnection Members


Dispose() Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataConnection Class : Dispose() Method
This releases the resources held by the connection, effectively closing the connection. Calling this method also closes all open ImageDocumentDataConnection objects that were opened by this one. It is essentially the same as the Close() method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImageDataConnection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImageDataConnection Class
ImageDataConnection Members


OpenDocument Method (ImageDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataConnection Class : OpenDocument Method
Used to indicate the identifier of the document with which the Page data is associated.
Meta-Data string to be used by a image data provider per its requirements.
This opens a connection to a specific DocumentIdentifier and returns a connection to that document. It will also add the ImageDocumentDataConnection object to the openDocuments set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function OpenDocument( _
   ByVal documentIdentifier As String, _
   ByVal contextData As String _
) As ImageDocumentDataConnection
'Usage

Dim instance As ImageDataConnection
Dim documentIdentifier As String
Dim contextData As String
Dim value As ImageDocumentDataConnection

value = instance.OpenDocument(documentIdentifier, contextData)
public abstract ImageDocumentDataConnection OpenDocument(
   string documentIdentifier,
   string contextData
)
public: abstract ImageDocumentDataConnection* OpenDocument(
   string* documentIdentifier,
   string* contextData
)
public:
abstract ImageDocumentDataConnection^ OpenDocument(
   String^ documentIdentifier,
   String^ contextData
)

Parameters

documentIdentifier
Used to indicate the identifier of the document with which the Page data is associated.
contextData
Meta-Data string to be used by a image data provider per its requirements.

Return Value

ImageDocumentDataConnection object.
Remarks

For details, refer to the "ImageGear.Web.UI.PageView.DocumentIdentifier".

See Also

Reference

ImageDataConnection Class
ImageDataConnection Members


%%PageItemTitle%%

ImageDataProvider Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataProvider Class
ImageDataProvider is a base class derived from the System.Configuration.Provider.ProviderBase class ( System.Configuration.Provider.ProviderBase ). It provides a base implementation for the ImageGear image data provider for the PageView and ThumbnailView components. This is an abstract class.
Object Model
ImageDataProvider ClassArtDataConnection ClassImageDataConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImageDataProvider
   Inherits System.Configuration.Provider.ProviderBase
'Usage

Dim instance As ImageDataProvider
public abstract class ImageDataProvider : System.Configuration.Provider.ProviderBase
public __gc abstract class ImageDataProvider : public System.Configuration.Provider.ProviderBase
public ref class ImageDataProvider abstract : public System.Configuration.Provider.ProviderBase
Remarks
If you are writing a custom image data provider, then your custom data provider class must derive from this class.

For example code, refer to the RadiologyOffice sample.

Also, if creating a custom provider in a separate assembly, make sure that you add a reference to the .NET assembly "System.Configuration" in the references of the Visual Studio Solution Explorer.

Inheritance Hierarchy

System.Object
System.Configuration.Provider.ProviderBase
ImageGear.Web.DataProviders.ImageDataProvider

See Also

Reference

ImageDataProvider Members
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Members$$

ImageDataProvider Class Members
Properties Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataProvider Class

The following tables list the members exposed by ImageDataProvider.

Public Methods
 | Name | Description
Public Method | GetImage | Retrieves the image specified in the parameter DocumentIdentifier. This call is being deprecated. Please use OpenImageData() instead.This method does not support multiple provider model!!
Public Method | OpenArtData | Opens connection for obtaining ART (annotations) data from the storage system.
Public Method | OpenImageData | Opens connection for obtaining document image data from the storage system. This call has support for create, read and write methods. This method is preferred over GetImage() for reading image data. This method is required if multiple provider support is required or image upload is desired.
Top
See Also

Reference

ImageDataProvider Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Properties$$

ImageDataProvider Class Properties

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataProvider Class

For a list of all members of this type, see ImageDataProvider members.

See Also

Reference

ImageDataProvider Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Methods$$

ImageDataProvider Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDataProvider Class

For a list of all members of this type, see ImageDataProvider members.

Public Methods
 | Name | Description
Public Method | GetImage | Retrieves the image specified in the parameter DocumentIdentifier. This call is being deprecated. Please use OpenImageData() instead.This method does not support multiple provider model!!
Public Method | OpenArtData | Opens connection for obtaining ART (annotations) data from the storage system.
Public Method | OpenImageData | Opens connection for obtaining document image data from the storage system. This call has support for create, read and write methods. This method is preferred over GetImage() for reading image data. This method is required if multiple provider support is required or image upload is desired.
Top
See Also

Reference

ImageDataProvider Class
ImageGear.Web.DataProviders Namespace


GetImage Method (ImageDataProvider)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataProvider Class : GetImage Method

A string that uniquely identifies a single image file.

Retrieves the image specified in the parameter DocumentIdentifier. This call is being deprecated. Please use OpenImageData() instead.This method does not support multiple provider model!!
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Please switch to the OpenImageData API")>
Public Overridable Function GetImage( _
   ByVal documentIdentifier As String _
) As Stream
'Usage

Dim instance As ImageDataProvider
Dim documentIdentifier As String
Dim value As Stream

value = instance.GetImage(documentIdentifier)
[Obsolete("Please switch to the OpenImageData API")]
public virtual Stream GetImage(
   string documentIdentifier
)
[Obsolete("Please switch to the OpenImageData API")]
public: virtual Stream* GetImage(
   string* documentIdentifier
)
[Obsolete("Please switch to the OpenImageData API")]
public:
virtual Stream^ GetImage(
   String^ documentIdentifier
)

Parameters

documentIdentifier

A string that uniquely identifies a single image file.

Return Value

A stream of binary image data
Remarks
The documentIdentifier specifies the identifier for the image to be retrieved. This can represent an image file, a valid file URL or database table data field. Whatever is specified, the viewer will retrieve and display the image specified by this parameter.

The DocumentIdentifier value can depend on the image data provider that you are using. For details, refer to DocumentIdentifier property in "ImageGear.Web.UI.PageView.DocumentIdentifier" in this help document.

An Image Data Provider must be specified in the web.config file. For details refer to the "web.config settings for PageView and ThumbnailView" section."

Note: If you are writing a custom provider derived from this class, then make sure this method returns a binary image data stream.

See Also

Reference

ImageDataProvider Class
ImageDataProvider Members


OpenArtData Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataProvider Class : OpenArtData Method
Opens connection for obtaining ART (annotations) data from the storage system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function OpenArtData() As ArtDataConnection
'Usage

Dim instance As ImageDataProvider
Dim value As ArtDataConnection

value = instance.OpenArtData()
public abstract ArtDataConnection OpenArtData()
public: abstract ArtDataConnection* OpenArtData();
public:
abstract ArtDataConnection^ OpenArtData();

Return Value

ArtDataConnection ArtDataConnection object.
See Also

Reference

ImageDataProvider Class
ImageDataProvider Members


OpenImageData Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDataProvider Class : OpenImageData Method
Opens connection for obtaining document image data from the storage system. This call has support for create, read and write methods. This method is preferred over GetImage() for reading image data. This method is required if multiple provider support is required or image upload is desired.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function OpenImageData() As ImageDataConnection
'Usage

Dim instance As ImageDataProvider
Dim value As ImageDataConnection

value = instance.OpenImageData()
public virtual ImageDataConnection OpenImageData()
public: virtual ImageDataConnection* OpenImageData();
public:
virtual ImageDataConnection^ OpenImageData();

Return Value

ImageDataConnection object ImageDataConnection
See Also

Reference

ImageDataProvider Class
ImageDataProvider Members


%%PageItemTitle%%

ImageDocumentDataConnection Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDocumentDataConnection Class
This is an abstract base class that represents a connection to a specific document. All data providers would implement a derived class of this. This class implements IDisposable System.IDisposable.
Object Model
ImageDocumentDataConnection ClassImageDataConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImageDocumentDataConnection
'Usage

Dim instance As ImageDocumentDataConnection
public abstract class ImageDocumentDataConnection
public __gc abstract class ImageDocumentDataConnection
public ref class ImageDocumentDataConnection abstract
Remarks
If you are writing a custom image data provider, then your custom data provider must implement a class derived from this class.
Inheritance Hierarchy

System.Object
ImageGear.Web.DataProviders.ImageDocumentDataConnection

See Also

Reference

ImageDocumentDataConnection Members
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Members$$

ImageDocumentDataConnection Class Members
Properties Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDocumentDataConnection Class

The following tables list the members exposed by ImageDocumentDataConnection.

Public Properties
 | Name | Description
Public Property | ContextData | Gets Meta-Data property.
Public Property | DocumentIdentifier | Gets DocumentIdentifier property.
Public Property | ImageDataConnection | Gets (ImageDataConnection) object. object.
Top
Public Methods
 | Name | Description
Public Method | Close | This method simply calls Dispose().
Public Method | Create | This method creates new content with the data given. This method is intended to create or insert and not replace content.
Public Method | Dispose | This closes the connection to a document. The base class also calls ImageDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Public Method | Read | This reads the content of the data item and returns it in the form of a stream.
Public Method | Write | This method creates or overwrites the existing content.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | The derived class can implement this method to do the necessary cleanup when the document is closed.
Top
See Also

Reference

ImageDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


%%PageItemTitle%% $$Methods$$

ImageDocumentDataConnection Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDocumentDataConnection Class

For a list of all members of this type, see ImageDocumentDataConnection members.

Public Methods
 | Name | Description
Public Method | Close | This method simply calls Dispose().
Public Method | Create | This method creates new content with the data given. This method is intended to create or insert and not replace content.
Public Method | Dispose | This closes the connection to a document. The base class also calls ImageDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Public Method | Read | This reads the content of the data item and returns it in the form of a stream.
Public Method | Write | This method creates or overwrites the existing content.
Top
Protected Methods
 | Name | Description
Protected Method | Closed | The derived class can implement this method to do the necessary cleanup when the document is closed.
Top
See Also

Reference

ImageDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


Close Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Close Method
This method simply calls Dispose().
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As ImageDocumentDataConnection

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Remarks
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Closed Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Closed Method
The derived class can implement this method to do the necessary cleanup when the document is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Sub Closed()
'Usage

Dim instance As ImageDocumentDataConnection

instance.Closed()
protected abstract void Closed()
protected: abstract void Closed();
protected:
abstract void Closed();
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Create Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Create Method
A System.IO.Stream of data to be written
This method creates new content with the data given. This method is intended to create or insert and not replace content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Create( _
   ByVal imageCStream As Stream _
)
'Usage

Dim instance As ImageDocumentDataConnection
Dim imageCStream As Stream

instance.Create(imageCStream)
public abstract void Create(
   Stream imageCStream
)
public: abstract void Create(
   Stream* imageCStream
)
public:
abstract void Create(
   Stream^ imageCStream
)

Parameters

imageCStream
A System.IO.Stream of data to be written
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Dispose Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Dispose Method
This closes the connection to a document. The base class also calls ImageDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Overload List
Overload | Description
Dispose | This closes the connection to a document. The base class also calls ImageDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Dispose() Method

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Dispose() Method
This closes the connection to a document. The base class also calls ImageDataConnection.DocumentConnectionClosed() to indicate that the document is now closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImageDocumentDataConnection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
For a SQL provider, this does nothing.
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Read Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Read Method
This reads the content of the data item and returns it in the form of a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Read() As Stream
'Usage

Dim instance As ImageDocumentDataConnection
Dim value As Stream

value = instance.Read()
public abstract Stream Read()
public: abstract Stream* Read();
public:
abstract Stream^ Read();

Return Value

System.IO.Stream object.
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


Write Method (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : Write Method
A System.IO.Stream of data to be written
This method creates or overwrites the existing content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Write( _
   ByVal imageDStream As Stream _
)
'Usage

Dim instance As ImageDocumentDataConnection
Dim imageDStream As Stream

instance.Write(imageDStream)
public abstract void Write(
   Stream imageDStream
)
public: abstract void Write(
   Stream* imageDStream
)
public:
abstract void Write(
   Stream^ imageDStream
)

Parameters

imageDStream
A System.IO.Stream of data to be written
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


%%PageItemTitle%% $$Properties$$

ImageDocumentDataConnection Class Properties

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace : ImageDocumentDataConnection Class

For a list of all members of this type, see ImageDocumentDataConnection members.

Public Properties
 | Name | Description
Public Property | ContextData | Gets Meta-Data property.
Public Property | DocumentIdentifier | Gets DocumentIdentifier property.
Public Property | ImageDataConnection | Gets (ImageDataConnection) object. object.
Top
See Also

Reference

ImageDocumentDataConnection Class
ImageGear.Web.DataProviders Namespace


ContextData Property

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : ContextData Property
Gets Meta-Data property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContextData As String
'Usage

Dim instance As ImageDocumentDataConnection
Dim value As String

value = instance.ContextData
public string ContextData {get;}
public: __property string* get_ContextData();
public:
property String^ ContextData {
   String^ get();
}
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


DocumentIdentifier Property (ImageDocumentDataConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : DocumentIdentifier Property
Gets DocumentIdentifier property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DocumentIdentifier As String
'Usage

Dim instance As ImageDocumentDataConnection
Dim value As String

value = instance.DocumentIdentifier
public string DocumentIdentifier {get;}
public: __property string* get_DocumentIdentifier();
public:
property String^ DocumentIdentifier {
   String^ get();
}
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


ImageDataConnection Property

ImageGear22.Web.Services Assembly > ImageGear.Web.DataProviders Namespace > ImageDocumentDataConnection Class : ImageDataConnection Property
Gets (ImageDataConnection) object. object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageDataConnection As ImageDataConnection
'Usage

Dim instance As ImageDocumentDataConnection
Dim value As ImageDataConnection

value = instance.ImageDataConnection
public ImageDataConnection ImageDataConnection {get;}
public: __property ImageDataConnection* get_ImageDataConnection();
public:
property ImageDataConnection^ ImageDataConnection {
   ImageDataConnection^ get();
}
See Also

Reference

ImageDocumentDataConnection Class
ImageDocumentDataConnection Members


ImageGear.Web.UI Namespace (ImageGear22.Web.Services)
Inheritance Hierarchy
ImageGear22.Web.Services Assembly : ImageGear.Web.UI Namespace
The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have both client and server API's and function with and without the Microsoft UpdatePanel.
Classes
 | Class | Description
Class | ArtConnection | Class that reads and writes XML sources from json strings or json objects.
Class | ArtPageJsonPair | Object wrapper that holds json string and page reference.
Enumerations
 | Enumeration | Description
Enumeration | ArtConnection.ArtWriteErrorCodes | Updating art annotation success or failure codes. Most failures are likely the result of a missing ID or an ID not matched on the page of the document.
See Also

Reference

ImageGear22.Web.Services Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.UI Namespace (ImageGear22.Web.Services) Inheritance Hierarchy
ImageGear22.Web.Services Assembly : ImageGear.Web.UI Namespace
Inheritance Hierarchy
System.Object
ImageGear.Web.UI.ArtConnection
ImageGear.Web.UI.ArtPageJsonPair
See Also

Reference

ImageGear22.Web.Services Assembly


%%PageItemTitle%%

ArtConnection Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtConnection Class
Class that reads and writes XML sources from json strings or json objects.
Object Model
ArtConnection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ArtConnection
'Usage

Dim instance As ArtConnection
public class ArtConnection
public __gc class ArtConnection
public ref class ArtConnection
Inheritance Hierarchy

System.Object
ImageGear.Web.UI.ArtConnection

See Also

Reference

ArtConnection Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ArtConnection Class Members
Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtConnection Class

The following tables list the members exposed by ArtConnection.

Public Constructors
 | Name | Description
Public Constructor | ArtConnection Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | Read | Overloaded. Reads a XML source document and converts it to a JSON string.
Public Method | Write | Overloaded. Outputs ImageGear XML art mark annotations to a document.
Top
See Also

Reference

ArtConnection Class
ImageGear.Web.UI Namespace


%%PageItemTitle%%

ArtConnection Constructor

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class : ArtConnection Constructor
Overload List
Overload | Description
ArtConnection Constructor() | Initializes a new instance of the ArtConnection class.
ArtConnection Constructor(String) | Initializes a new instance of the ArtConnection class. May need to rethink this as ASP.NET controls don't handle the provider as yet.
See Also

Reference

ArtConnection Class
ArtConnection Members


%%PageItemTitle%%

ArtConnection Constructor()

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > ArtConnection Constructor : ArtConnection Constructor()
Initializes a new instance of the ArtConnection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ArtConnection()
public ArtConnection()
public: ArtConnection();
public:
ArtConnection();
See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


%%PageItemTitle%%

ArtConnection Constructor(String)

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > ArtConnection Constructor : ArtConnection Constructor(String)
provider name
Initializes a new instance of the ArtConnection class. May need to rethink this as ASP.NET controls don't handle the provider as yet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal provider As String _
)
'Usage

Dim provider As String

Dim instance As New ArtConnection(provider)
public ArtConnection(
   string provider
)
public: ArtConnection(
   string* provider
)
public:
ArtConnection(
   String^ provider
)

Parameters

provider
provider name
See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


%%PageItemTitle%% $$Methods$$

ArtConnection Class Methods

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtConnection Class

For a list of all members of this type, see ArtConnection members.

Public Methods
 | Name | Description
Public Method | Read | Overloaded. Reads a XML source document and converts it to a JSON string.
Public Method | Write | Overloaded. Outputs ImageGear XML art mark annotations to a document.
Top
See Also

Reference

ArtConnection Class
ImageGear.Web.UI Namespace


Read Method (ArtConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class : Read Method
Reads a XML source document and converts it to a JSON string.
Overload List
Overload | Description
Read(String,Int32) | Reads a XML source document and converts it to a JSON string.
Read(String,Int32,Int32) | Reads a number of pages and returns a list of json string objects with associated page numbers.
See Also

Reference

ArtConnection Class
ArtConnection Members


Read(String,Int32) Method

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > Read Method : Read(String,Int32) Method
Source document identifier of an ImageGear XML art document.
Page to obtain art annotation marks.
Reads a XML source document and converts it to a JSON string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal documentIdentifier As String, _
   ByVal pageNumber As Integer _
) As String
'Usage

Dim instance As ArtConnection
Dim documentIdentifier As String
Dim pageNumber As Integer
Dim value As String

value = instance.Read(documentIdentifier, pageNumber)
public string Read(
   string documentIdentifier,
   int pageNumber
)
public: string* Read(
   string* documentIdentifier,
   int pageNumber
)
public:
String^ Read(
   String^ documentIdentifier,
   int pageNumber
)

Parameters

documentIdentifier
Source document identifier of an ImageGear XML art document.
pageNumber
Page to obtain art annotation marks.

Return Value

An ImageGear Asp.Net JSON art string.
Remarks

Page numbers start at zero for the first page in a document.

See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


Read(String,Int32,Int32) Method

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > Read Method : Read(String,Int32,Int32) Method
Source document identifier of an ImageGear XML art document.
First page to begin the page reading sequence.
Number of pages to read starting with the first page number.
Reads a number of pages and returns a list of json string objects with associated page numbers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal documentIdentifier As String, _
   ByVal firstPageNumber As Integer, _
   ByVal countOfPages As Integer _
) As ReadOnlyCollection(Of ArtPageJsonPair)
'Usage

Dim instance As ArtConnection
Dim documentIdentifier As String
Dim firstPageNumber As Integer
Dim countOfPages As Integer
Dim value As ReadOnlyCollection(Of ArtPageJsonPair)

value = instance.Read(documentIdentifier, firstPageNumber, countOfPages)
public ReadOnlyCollection<ArtPageJsonPair> Read(
   string documentIdentifier,
   int firstPageNumber,
   int countOfPages
)
public: ReadOnlyCollection<ArtPageJsonPair*>* Read(
   string* documentIdentifier,
   int firstPageNumber,
   int countOfPages
)
public:
ReadOnlyCollection<ArtPageJsonPair^>^ Read(
   String^ documentIdentifier,
   int firstPageNumber,
   int countOfPages
)

Parameters

documentIdentifier
Source document identifier of an ImageGear XML art document.
firstPageNumber
First page to begin the page reading sequence.
countOfPages
Number of pages to read starting with the first page number.

Return Value

List of objects that contain the json art annotations associated with its page.
Remarks

Page numbers start at zero for the first page in a document.

See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


Write Method (ArtConnection)

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class : Write Method
Outputs ImageGear XML art mark annotations to a document.
Overload List
Overload | Description
Write(String,Int32,String) | Outputs ImageGear XML art mark annotations to a document.
Write(String,IEnumerable<ArtPageJsonPair>) | Outputs ImageGear XML art mark annotations over many pages.
See Also

Reference

ArtConnection Class
ArtConnection Members


Write(String,Int32,String) Method

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > Write Method : Write(String,Int32,String) Method
Output document identifier of an ImageGear XML art document.
Page to update art annotation marks in the document.
JSON string of art annotation marks to save to the document.
Outputs ImageGear XML art mark annotations to a document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal documentIdentifier As String, _
   ByVal pageNumber As Integer, _
   ByVal artPageJson As String _
)
'Usage

Dim instance As ArtConnection
Dim documentIdentifier As String
Dim pageNumber As Integer
Dim artPageJson As String

instance.Write(documentIdentifier, pageNumber, artPageJson)
public void Write(
   string documentIdentifier,
   int pageNumber,
   string artPageJson
)
public: void Write(
   string* documentIdentifier,
   int pageNumber,
   string* artPageJson
)
public:
void Write(
   String^ documentIdentifier,
   int pageNumber,
   String^ artPageJson
)

Parameters

documentIdentifier
Output document identifier of an ImageGear XML art document.
pageNumber
Page to update art annotation marks in the document.
artPageJson
JSON string of art annotation marks to save to the document.
Remarks

Page numbers start at zero for the first page in a document.

If the page exists in the document, it will be replaced with the art annotation being supplied. If the page number is greater than the number of pages in the document, the page will be appended but any missing pages between the document's last page and the new page location will be filled with pages of empty annotations. As an example, an existing two page annotated document that has a sixth page added will save the annotations on the sixth page with pages three, four and five filled with no annotation marks.

This method uses a TransactionScope System.Transactions.TransactionScope object when it writes to prevent concurrency writing issues.

See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


Write(String,IEnumerable<ArtPageJsonPair>) Method

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtConnection Class > Write Method : Write(String,IEnumerable<ArtPageJsonPair>) Method
Output document identifier of an ImageGear XML art document.
List of objects containing a JSON string with page number to be updated.
Outputs ImageGear XML art mark annotations over many pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal documentIdentifier As String, _
   ByVal pagesToWrite As IEnumerable(Of ArtPageJsonPair) _
)
'Usage

Dim instance As ArtConnection
Dim documentIdentifier As String
Dim pagesToWrite As IEnumerable(Of ArtPageJsonPair)

instance.Write(documentIdentifier, pagesToWrite)
public void Write(
   string documentIdentifier,
   IEnumerable<ArtPageJsonPair> pagesToWrite
)
public: void Write(
   string* documentIdentifier,
   IEnumerable<ArtPageJsonPair*>* pagesToWrite
)
public:
void Write(
   String^ documentIdentifier,
   IEnumerable<ArtPageJsonPair^>^ pagesToWrite
)

Parameters

documentIdentifier
Output document identifier of an ImageGear XML art document.
pagesToWrite
List of objects containing a JSON string with page number to be updated.
Remarks

Page numbers start at zero for the first page in a document.

If the page exists in the document, it will be replaced with the art annotation being supplied. If the page number is greater than the number of pages in the document, the page will be appended but any missing pages between the document's last page and the new page location will be filled with pages of empty annotations. As an example, an existing two page annotated document that has a sixth page added will save the annotations on the sixth page with pages three, four and five filled with no annotation marks.

The pages in the list may be in any random non-sequential order.

This method uses a TransactionScope System.Transactions.TransactionScope object when it writes to prevent concurrency writing issues.

See Also

Reference

ArtConnection Class
ArtConnection Members
Overload List


%%PageItemTitle%%

ArtPageJsonPair Class
Members

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtPageJsonPair Class
Object wrapper that holds json string and page reference.
Object Model
ArtPageJsonPair Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ArtPageJsonPair
'Usage

Dim instance As ArtPageJsonPair
public class ArtPageJsonPair
public __gc class ArtPageJsonPair
public ref class ArtPageJsonPair
Inheritance Hierarchy

System.Object
ImageGear.Web.UI.ArtPageJsonPair

See Also

Reference

ArtPageJsonPair Members
ImageGear.Web.UI Namespace


%%PageItemTitle%% $$Members$$

ArtPageJsonPair Class Members
Properties

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtPageJsonPair Class

The following tables list the members exposed by ArtPageJsonPair.

Public Constructors
 | Name | Description
Public Constructor | ArtPageJsonPair Constructor | Initializes a new instance of the ArtPageJsonPair class.
Top
Public Properties
 | Name | Description
Public Property | ArtMarks | Gets or sets ImageGear JSON art mark property string.
Public Property | PageNumber | Gets or sets page number property.
Top
See Also

Reference

ArtPageJsonPair Class
ImageGear.Web.UI Namespace


%%PageItemTitle%%

ArtPageJsonPair Constructor

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtPageJsonPair Class : ArtPageJsonPair Constructor
Page number in ImageGear XML file.
JSON string of annotation marks.
Initializes a new instance of the ArtPageJsonPair class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal artMark As String _
)
'Usage

Dim pageNumber As Integer
Dim artMark As String

Dim instance As New ArtPageJsonPair(pageNumber, artMark)
public ArtPageJsonPair(
   int pageNumber,
   string artMark
)
public: ArtPageJsonPair(
   int pageNumber,
   string* artMark
)
public:
ArtPageJsonPair(
   int pageNumber,
   String^ artMark
)

Parameters

pageNumber
Page number in ImageGear XML file.
artMark
JSON string of annotation marks.
See Also

Reference

ArtPageJsonPair Class
ArtPageJsonPair Members


%%PageItemTitle%% $$Properties$$

ArtPageJsonPair Class Properties

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtPageJsonPair Class

For a list of all members of this type, see ArtPageJsonPair members.

Public Properties
 | Name | Description
Public Property | ArtMarks | Gets or sets ImageGear JSON art mark property string.
Public Property | PageNumber | Gets or sets page number property.
Top
See Also

Reference

ArtPageJsonPair Class
ImageGear.Web.UI Namespace


ArtMarks Property

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtPageJsonPair Class : ArtMarks Property
Gets or sets ImageGear JSON art mark property string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArtMarks As String
'Usage

Dim instance As ArtPageJsonPair
Dim value As String

instance.ArtMarks = value

value = instance.ArtMarks
public string ArtMarks {get; set;}
public: __property string* get_ArtMarks();
public: __property void set_ArtMarks(
   string* value
);
public:
property String^ ArtMarks {
   String^ get();
   void set (    String^ value);
}
See Also

Reference

ArtPageJsonPair Class
ArtPageJsonPair Members


PageNumber Property (ArtPageJsonPair)

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace > ArtPageJsonPair Class : PageNumber Property
Gets or sets page number property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ArtPageJsonPair
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}
See Also

Reference

ArtPageJsonPair Class
ArtPageJsonPair Members


%%PageItemTitle%%

ArtConnection.ArtWriteErrorCodes Enumeration

ImageGear22.Web.Services Assembly > ImageGear.Web.UI Namespace : ArtConnection.ArtWriteErrorCodes Enumeration
Updating art annotation success or failure codes. Most failures are likely the result of a missing ID or an ID not matched on the page of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ArtConnection.ArtWriteErrorCodes
   Inherits System.Enum
'Usage

Dim instance As ArtConnection.ArtWriteErrorCodes
public enum ArtConnection.ArtWriteErrorCodes : System.Enum
__value public enum ArtConnection.ArtWriteErrorCodes : public System.Enum
public enum class ArtConnection.ArtWriteErrorCodes : public System.Enum
Members
Member | Value | Description
ImproperAdd | -3 | Request to add a new art mark object but the ID wasn't zero on the new art object.
ImproperDelete | -1 | Request to delete an art mark object that wasn't there or the ID was bad.
ImproperEdit | -2 | Request to modify an existing art object that is not there (any longer) or the ID was bad and did not match an exiting mark on that page.
SourceFailure | -4 | Unable to either find, read or write art source. Also, could be a permission problem.
Success | 0 | All art updates made successsfully
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Web.UI.ArtConnection.ArtWriteErrorCodes

See Also

Reference

ImageGear.Web.UI Namespace


ImageGear22.Windows.Controls Assembly
Namespaces
Namespace | Description
ImageGear.Core | The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit.
ImageGear.Windows.Controls | This namespace provides WPF Page View and other common controls to simplify development of XAML based applications.


ImageGear.Core Namespace (ImageGear22.Windows.Controls)
Inheritance Hierarchy
ImageGear22.Windows.Controls Assembly : ImageGear.Core Namespace
The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit.
Classes
 | Class | Description
Class | ImGearReadOnlyDictionary<TKey,TValue> | This class represents a read-only dictionary.
See Also

Reference

ImageGear22.Windows.Controls Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Core Namespace (ImageGear22.Windows.Controls) Inheritance Hierarchy
ImageGear22.Windows.Controls Assembly : ImageGear.Core Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearReadOnlyDictionary<TKey,TValue>
See Also

Reference

ImageGear22.Windows.Controls Assembly


%%PageItemTitle%%

ImGearReadOnlyDictionary<TKey,TValue> Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace : ImGearReadOnlyDictionary<TKey,TValue> Class
The key type.
The value type.
This class represents a read-only dictionary.
Object Model
ImGearReadOnlyDictionary<TKey,TValue> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImGearReadOnlyDictionary
    (Of TKey,TValue)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
[DefaultMember("Item")]
public class ImGearReadOnlyDictionary<TKey,TValue>
[DefaultMember("Item")]
public __gc class ImGearReadOnlyDictionary<TKey,TValue>
[DefaultMember("Item")]
generic<typename TKey>
generic<typename TValue>
public ref class ImGearReadOnlyDictionary
Type Parameters
TKey
The key type.
TValue
The value type.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearReadOnlyDictionary<TKey,TValue>

See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Members
ImageGear.Core Namespace


%%PageItemTitle%% $$Members$$

ImGearReadOnlyDictionary<TKey,TValue> Class Members
Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace : ImGearReadOnlyDictionary<TKey,TValue> Class

The following tables list the members exposed by ImGearReadOnlyDictionary<TKey,TValue>.

Public Constructors
 | Name | Description
Public Constructor | ImGearReadOnlyDictionary<TKey,TValue> Constructor | Initializes a new instance of the ImGearReadOnlyDictionary class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the dictionary.
Public Property | IsReadOnly | Gets a value indicating whether the dictionary is read-only.
Public Property | Item | Gets the value associated with the specified key.
Public Property | Keys | Gets a collection containing the keys in the dictionary.
Public Property | Values | Gets a collection containing the values in the dictionary.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. This method is not supported by the ImGearReadOnlyDictionary.
Public Method | Clear | This method is not supported by the ImGearReadOnlyDictionary.
Public Method | Contains | Determines whether the dictionary contains the specified key/value pair.
Public Method | ContainsKey | Determines whether the dictionary contains the specified key.
Public Method | CopyTo | Copies the elements of the dictionary to an array, starting at the specified array index.
Public Method | GetEnumerator | Returns an enumerator that iterates through the dictionary.
Public Method | Remove | Overloaded. This method is not supported by the ImGearReadOnlyDictionary.
Public Method | TryGetValue | Gets the value associated with the specified key.
Top
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImageGear.Core Namespace


%%PageItemTitle%%

ImGearReadOnlyDictionary<TKey,TValue> Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : ImGearReadOnlyDictionary<TKey,TValue> Constructor
A backing dictionary.
Initializes a new instance of the ImGearReadOnlyDictionary class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal backingDict As IDictionary(Of TKey,TValue) _
)
'Usage

Dim backingDict As IDictionary(Of TKey,TValue)

Dim instance As New ImGearReadOnlyDictionary(Of TKey,TValue)(backingDict)
public ImGearReadOnlyDictionary<TKey,TValue>(
   IDictionary<TKey,TValue> backingDict
)
public: ImGearReadOnlyDictionary<TKey,TValue>(
   IDictionary<TKey*,TValue*>* backingDict
)
public:
ImGearReadOnlyDictionary<TKey,TValue>(
   IDictionary<TKey^,TValue^>^ backingDict
)

Parameters

backingDict
A backing dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


%%PageItemTitle%% $$Methods$$

ImGearReadOnlyDictionary<TKey,TValue> Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace : ImGearReadOnlyDictionary<TKey,TValue> Class

For a list of all members of this type, see ImGearReadOnlyDictionary<TKey,TValue> members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. This method is not supported by the ImGearReadOnlyDictionary.
Public Method | Clear | This method is not supported by the ImGearReadOnlyDictionary.
Public Method | Contains | Determines whether the dictionary contains the specified key/value pair.
Public Method | ContainsKey | Determines whether the dictionary contains the specified key.
Public Method | CopyTo | Copies the elements of the dictionary to an array, starting at the specified array index.
Public Method | GetEnumerator | Returns an enumerator that iterates through the dictionary.
Public Method | Remove | Overloaded. This method is not supported by the ImGearReadOnlyDictionary.
Public Method | TryGetValue | Gets the value associated with the specified key.
Top
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImageGear.Core Namespace


Add Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Add Method
This method is not supported by the ImGearReadOnlyDictionary.
Overload List
Overload | Description
Add(KeyValuePair<TKey,TValue>) | This method is not supported by the ImGearReadOnlyDictionary.
Add(TKey,TValue) | This method is not supported by the ImGearReadOnlyDictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Add(KeyValuePair<TKey,TValue>) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class > Add Method : Add(KeyValuePair<TKey,TValue>) Method
The object to add to the dictionary.
This method is not supported by the ImGearReadOnlyDictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal item As KeyValuePair(Of TKey,TValue) _
)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim item As KeyValuePair(Of TKey,TValue)

instance.Add(item)
public void Add(
   KeyValuePair<TKey,TValue> item
)
public: void Add(
   KeyValuePair<TKey*,TValue*> item
)
public:
void Add(
   KeyValuePair<TKey^,TValue^> item
)

Parameters

item
The object to add to the dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members
Overload List


Add(TKey,TValue) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class > Add Method : Add(TKey,TValue) Method
The object to use as the key of the element to add.
The object to use as the value of the element to add.
This method is not supported by the ImGearReadOnlyDictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal key As TKey, _
   ByVal value As TValue _
)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim key As TKey
Dim value As TValue

instance.Add(key, value)
public void Add(
   TKey key,
   TValue value
)
public: void Add(
   TKey* key,
   TValue* value
)
public:
void Add(
   TKey^ key,
   TValue^ value
)

Parameters

key
The object to use as the key of the element to add.
value
The object to use as the value of the element to add.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members
Overload List


Clear Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Clear Method
This method is not supported by the ImGearReadOnlyDictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Contains Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Contains Method
The KeyValuePair to locate in the dictionary.
Determines whether the dictionary contains the specified key/value pair.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal item As KeyValuePair(Of TKey,TValue) _
) As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim item As KeyValuePair(Of TKey,TValue)
Dim value As Boolean

value = instance.Contains(item)
public bool Contains(
   KeyValuePair<TKey,TValue> item
)
public: bool Contains(
   KeyValuePair<TKey*,TValue*> item
)
public:
bool Contains(
   KeyValuePair<TKey^,TValue^> item
)

Parameters

item
The KeyValuePair to locate in the dictionary.

Return Value

Returns true if the dictionary contains the specified KeyValuePair; otherwise, false.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


ContainsKey Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : ContainsKey Method
The key to locate in the dictionary.
Determines whether the dictionary contains the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ContainsKey( _
   ByVal key As TKey _
) As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim key As TKey
Dim value As Boolean

value = instance.ContainsKey(key)
public bool ContainsKey(
   TKey key
)
public: bool ContainsKey(
   TKey* key
)
public:
bool ContainsKey(
   TKey^ key
)

Parameters

key
The key to locate in the dictionary.

Return Value

true if the dictionary contains an element with the specified key; otherwise, false.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


CopyTo Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : CopyTo Method
The one-dimensional array that is the destination of the elements copied from the dictionary. The array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the elements of the dictionary to an array, starting at the specified array index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As KeyValuePair(Of TKey,TValue), _
   ByVal arrayIndex As Integer _
)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim array() As KeyValuePair(Of TKey,TValue)
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
public void CopyTo(
   KeyValuePair<TKey,TValue>[] array,
   int arrayIndex
)
public: void CopyTo(
   KeyValuePair<TKey*,TValue*>[]* array,
   int arrayIndex
)
public:
void CopyTo(
   array<KeyValuePair<TKey^,TValue^>>^ array,
   int arrayIndex
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from the dictionary. The array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


GetEnumerator Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : GetEnumerator Method
Returns an enumerator that iterates through the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of TKey,TValue))
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim value As IEnumerator(Of KeyValuePair(Of TKey,TValue))

value = instance.GetEnumerator()
public IEnumerator<KeyValuePair<TKey,TValue>> GetEnumerator()
public: IEnumerator<KeyValuePair<TKey*,TValue*>>* GetEnumerator();
public:
IEnumerator<KeyValuePair<TKey^,TValue^>>^ GetEnumerator();

Return Value

An enumerator for the dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Remove Method (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Remove Method
This method is not supported by the ImGearReadOnlyDictionary.
Overload List
Overload | Description
Remove(KeyValuePair<TKey,TValue>) | This method is not supported by the ImGearReadOnlyDictionary.
Remove(TKey) | This method is not supported by the ImGearReadOnlyDictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Remove(KeyValuePair<TKey,TValue>) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class > Remove Method : Remove(KeyValuePair<TKey,TValue>) Method
The object to remove from the dictionary.
This method is not supported by the ImGearReadOnlyDictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal item As KeyValuePair(Of TKey,TValue) _
) As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim item As KeyValuePair(Of TKey,TValue)
Dim value As Boolean

value = instance.Remove(item)
public bool Remove(
   KeyValuePair<TKey,TValue> item
)
public: bool Remove(
   KeyValuePair<TKey*,TValue*> item
)
public:
bool Remove(
   KeyValuePair<TKey^,TValue^> item
)

Parameters

item
The object to remove from the dictionary.

Return Value

Boolean value.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members
Overload List


Remove(TKey) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class > Remove Method : Remove(TKey) Method
The key of the element to remove.
This method is not supported by the ImGearReadOnlyDictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal key As TKey _
) As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim key As TKey
Dim value As Boolean

value = instance.Remove(key)
public bool Remove(
   TKey key
)
public: bool Remove(
   TKey* key
)
public:
bool Remove(
   TKey^ key
)

Parameters

key
The key of the element to remove.

Return Value

Boolean value.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members
Overload List


TryGetValue Method

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : TryGetValue Method
The key of the value to get.
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.
Gets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function TryGetValue( _
   ByVal key As TKey, _
   ByRef value As TValue _
) As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim key As TKey
Dim value As TValue
Dim value As Boolean

value = instance.TryGetValue(key, value)
public bool TryGetValue(
   TKey key,
   out TValue value
)
public: bool TryGetValue(
   TKey* key,
   [PARAMFLAG::Out] TValue* value
)
public:
bool TryGetValue(
   TKey^ key,
   [Out] TValue^ value
)

Parameters

key
The key of the value to get.
value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

true if the dictionary contains an element with the specified key; otherwise, false.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


%%PageItemTitle%% $$Properties$$

ImGearReadOnlyDictionary<TKey,TValue> Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace : ImGearReadOnlyDictionary<TKey,TValue> Class

For a list of all members of this type, see ImGearReadOnlyDictionary<TKey,TValue> members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the dictionary.
Public Property | IsReadOnly | Gets a value indicating whether the dictionary is read-only.
Public Property | Item | Gets the value associated with the specified key.
Public Property | Keys | Gets a collection containing the keys in the dictionary.
Public Property | Values | Gets a collection containing the values in the dictionary.
Top
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImageGear.Core Namespace


Count Property (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Count Property
Gets the number of key/value pairs contained in the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

The number of key/value pairs contained in the dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


IsReadOnly Property (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : IsReadOnly Property
Gets a value indicating whether the dictionary is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim value As Boolean

value = instance.IsReadOnly
public bool IsReadOnly {get;}
public: __property bool get_IsReadOnly();
public:
property bool IsReadOnly {
   bool get();
}

Property Value

This property always returns true.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Item Property (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Item Property
The key of the value to get.
Gets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal key As TKey _
) As TValue
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim key As TKey
Dim value As TValue

instance.Item(key) = value

value = instance.Item(key)
public TValue this[
   TKey key
]; {get; set;}
public: __property TValue* get_Item   TKey* key
;
public: __property void set_Item   TKey* key,
   TValue* value
;
public:
property TValue^ default [TKey^] {
   TValue^ get(TKey^ key);
   void set (TKey^ key, TValue^ value);
}

Parameters

key
The key of the value to get.

Property Value

TValue object.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Keys Property

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Keys Property
Gets a collection containing the keys in the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Keys As ICollection(Of TKey)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim value As ICollection(Of TKey)

value = instance.Keys
public ICollection<TKey> Keys {get;}
public: __property ICollection<TKey*>* get_Keys();
public:
property ICollection<TKey^>^ Keys {
   ICollection<TKey^>^ get();
}

Property Value

A collection containing the keys in the dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


Values Property (ImGearReadOnlyDictionary<TKey,TValue>)

ImageGear22.Windows.Controls Assembly > ImageGear.Core Namespace > ImGearReadOnlyDictionary<TKey,TValue> Class : Values Property
Gets a collection containing the values in the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Values As ICollection(Of TValue)
'Usage

Dim instance As ImGearReadOnlyDictionary(Of TKey,TValue)
Dim value As ICollection(Of TValue)

value = instance.Values
public ICollection<TValue> Values {get;}
public: __property ICollection<TValue*>* get_Values();
public:
property ICollection<TValue^>^ Values {
   ICollection<TValue^>^ get();
}

Property Value

A collection containing the values in the dictionary.
See Also

Reference

ImGearReadOnlyDictionary<TKey,TValue> Class
ImGearReadOnlyDictionary<TKey,TValue> Members


ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls)
Inheritance Hierarchy
ImageGear22.Windows.Controls Assembly : ImageGear.Windows.Controls Namespace
This namespace provides WPF Page View and other common controls to simplify development of XAML based applications.
Classes
 | Class | Description
Class | FileOpenedEventArgs | Arguments for the PageView.FileOpened event on the PageView control.
Class | FileOpeningEventArgs | Arguments for the PageView.FileOpening event on the PageView control.
Class | ImGearAnnotationItems | This class represents an object that provides access to the menu items that are displayed when right clicking on an annotation mark.
Class | ImGearAnnotationSettings | Provides a set of settings for the annotation user interface.
Class | ImGearAnnotationTemplates | Provides templates for creating annotations using the mouse.
Class | ImGearCustomMarkMenuItemCollection | This class represents a collection of context menu items for a custom mark.
Class | ImGearCustomMarkMenuItemDictionary | This class represents a dictionary of collections of context menu items for custom marks.
Class | ImGearDelegateCommand | This class represents a delegate command.
Class | ImGearHandPanSettings | This class represents the settings for the hand pan mouse tool.
Class | ImGearImageConverter | This class is used to convert a FrameworkElement passed as a parameter to an image.
Class | ImGearMagnifierSettings | This class represents the settings for the magnifier mouse tool.
Class | ImGearMarksLoadingEventArgs | This class specifies a list of arguments for the MarksLoadingEventHandler delegate.
Class | ImGearMouseToolSettings | This class represents the mouse tool settings for the PageView control.
Class | ImGearPageViewContextMenu | This class represents a context menu for the PageView control.
Class | ImGearPageViewTool | This class represents PageView toolbar item content.
Class | ImGearPageViewToolbar | This class represents a PageView toolbar.
Class | ImGearPageViewToolCollection | This class represents a collection of ImGearPageViewTools.
Class | ImGearRectangleZoomSettings | This class represents the settings for the rectangle zoom mouse tool.
Class | ImGearSelectSettings | This class represents the settings for the select mouse tool.
Class | ImGearThumbnailList | This class controls operations with thumbnail items.
Class | ImGearThumbnailListItem | This class represents a thumbnail item.
Class | ImGearThumbnailMultiPageAdapter | This class can be used to convert a collection of filename strings, Streams, or ImGearDocuments to a collection of ImGearThumbnailPages.
Class | ImGearThumbnailPage | This class represents a thumbnail page.
Class | ImGearThumbnailPageExtension | This class represents a markup extension for the ImGearThumbnailPage class.
Class | ImGearVirtualizingWrapPanel | Virtualizing wrap panel class.
Class | ImGearZoomInSettings | This class represents the settings for the zoom in mouse tool.
Class | ImGearZoomOutSettings | This class represents the settings for the zoom out mouse tool.
Class | PageView | This class provides a user interface element to use in XAML. It takes an ImGearPageDisplay Class object and renders it, allowing for options to scroll, zoom, and other methods of manipulating the display of an image.
Class | ScrollBarIncrement | Settings for a scroll bar increment including the value of the increment and what type of value.
Interfaces
 | Interface | Description
Interface | IImGearCommandManager | An interface for providing command related utility methods that register CommmandBinding and InputBinding objects for class owners and commands, add and remove command event handlers, and provides services for querying the status of a command.
Delegates
 | Delegate | Description
Delegate | ImGearFunc<TParam,TResult> | Encapsulates a method that has one parameter and returns a value of the type specified by the TResult parameter.
Delegate | ImGearMarksLoadingEventHandler | This delegate is used for declaring MarksLoading events.
Enumerations
 | Enumeration | Description
Enumeration | ImGearAnnotationMode | Specifies the mark mode.
Enumeration | ImGearInteractionArea | Specifies the interaction area for editing annotations.
Enumeration | ImGearMouseTool | Specifies the mouse tool.
Enumeration | ImGearPageViewToolbarMouseTool | Specifies the PageView toolbar mouse tool.
Enumeration | ImGearScrollDirection | The direction that the thumbnail items are scrolled.
Enumeration | ImGearUpdateMode | Specifies the update mode.
Enumeration | ScrollBarIncrementType | Types of scroll bar increment values.
See Also

Reference

ImageGear22.Windows.Controls Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls) Inheritance Hierarchy
ImageGear22.Windows.Controls Assembly : ImageGear.Windows.Controls Namespace
Inheritance Hierarchy
System.Object
ImageGear.Windows.Controls.ImGearDelegateCommand
ImageGear.Windows.Controls.ImGearImageConverter
ImageGear.Windows.Controls.ImGearThumbnailPage
ImageGear.Windows.Controls.ScrollBarIncrement
System.Collections.Generic.Dictionary<TKey,TValue>
ImageGear.Windows.Controls.ImGearCustomMarkMenuItemDictionary
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
ImageGear.Windows.Controls.ImGearCustomMarkMenuItemCollection
ImageGear.Windows.Controls.ImGearPageViewToolCollection
System.EventArgs
ImageGear.Windows.Controls.FileOpenedEventArgs
ImageGear.Windows.Controls.FileOpeningEventArgs
ImageGear.Windows.Controls.ImGearMarksLoadingEventArgs
System.Windows.Markup.MarkupExtension
ImageGear.Windows.Controls.ImGearThumbnailPageExtension
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearAnnotationItems
ImageGear.Windows.Controls.ImGearAnnotationSettings
ImageGear.Windows.Controls.ImGearAnnotationTemplates
ImageGear.Windows.Controls.ImGearHandPanSettings
ImageGear.Windows.Controls.ImGearMagnifierSettings
ImageGear.Windows.Controls.ImGearMouseToolSettings
ImageGear.Windows.Controls.ImGearPageViewTool
ImageGear.Windows.Controls.ImGearRectangleZoomSettings
ImageGear.Windows.Controls.ImGearSelectSettings
ImageGear.Windows.Controls.ImGearThumbnailMultiPageAdapter
ImageGear.Windows.Controls.ImGearZoomInSettings
ImageGear.Windows.Controls.ImGearZoomOutSettings
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.PageView
System.Windows.Controls.ContentControl
System.Windows.Controls.ListBoxItem
ImageGear.Windows.Controls.ImGearThumbnailListItem
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.MenuBase
System.Windows.Controls.ContextMenu
ImageGear.Windows.Controls.ImGearPageViewContextMenu
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
ImageGear.Windows.Controls.ImGearPageViewToolbar
ImageGear.Windows.Controls.ImGearThumbnailList
System.Windows.Controls.Panel
System.Windows.Controls.VirtualizingPanel
ImageGear.Windows.Controls.ImGearVirtualizingWrapPanel
See Also

Reference

ImageGear22.Windows.Controls Assembly


%%PageItemTitle%%

FileOpenedEventArgs Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpenedEventArgs Class
Arguments for the PageView.FileOpened event on the PageView control.
Object Model
FileOpenedEventArgs ClassImGearAnnotationPage ClassImGearDocument ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FileOpenedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FileOpenedEventArgs
public class FileOpenedEventArgs : System.EventArgs
public __gc class FileOpenedEventArgs : public System.EventArgs
public ref class FileOpenedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Controls.FileOpenedEventArgs

See Also

Reference

FileOpenedEventArgs Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

FileOpenedEventArgs Class Members
Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpenedEventArgs Class

The following tables list the members exposed by FileOpenedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | FileOpenedEventArgs Constructor | Initializes a new instance of the FileOpenedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | ARTPage | Gets ImGearAnnotationPage loaded into the page view control. Set to null if no annotations were loaded.
Public Property | Document | Gets ImGearDocument loaded for the file if requested, otherwise null.
Public Property | File | Gets FileInfo of file dropped on PageView control.
Public Property | Page | Gets ImGearPage loaded into the page view control. Set to null if no page was loaded.
Public Property | PageNumber | Gets Page number of the image or annotation loaded from the file.
Top
See Also

Reference

FileOpenedEventArgs Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

FileOpenedEventArgs Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : FileOpenedEventArgs Constructor
FileInfo class to associate with the File property.
Page number to set to the PageNumber property.
ImGearPage object to assign to the Page property.
ImGearDocument object to assign to the Document property.
ImGearAnnotationPage object to assign to the ARTPage property.
Initializes a new instance of the FileOpenedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal file As FileInfo, _
   ByVal pageNumber As Integer, _
   ByVal page As ImGearPage, _
   ByVal document As ImGearDocument, _
   ByVal artPage As ImGearAnnotationPage _
)
'Usage

Dim file As FileInfo
Dim pageNumber As Integer
Dim page As ImGearPage
Dim document As ImGearDocument
Dim artPage As ImGearAnnotationPage

Dim instance As New FileOpenedEventArgs(file, pageNumber, page, document, artPage)
public FileOpenedEventArgs(
   FileInfo file,
   int pageNumber,
   ImGearPage page,
   ImGearDocument document,
   ImGearAnnotationPage artPage
)
public: FileOpenedEventArgs(
   FileInfo* file,
   int pageNumber,
   ImGearPage* page,
   ImGearDocument* document,
   ImGearAnnotationPage* artPage
)
public:
FileOpenedEventArgs(
   FileInfo^ file,
   int pageNumber,
   ImGearPage^ page,
   ImGearDocument^ document,
   ImGearAnnotationPage^ artPage
)

Parameters

file
FileInfo class to associate with the File property.
pageNumber
Page number to set to the PageNumber property.
page
ImGearPage object to assign to the Page property.
document
ImGearDocument object to assign to the Document property.
artPage
ImGearAnnotationPage object to assign to the ARTPage property.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


%%PageItemTitle%% $$Properties$$

FileOpenedEventArgs Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpenedEventArgs Class

For a list of all members of this type, see FileOpenedEventArgs members.

Public Properties
 | Name | Description
Public Property | ARTPage | Gets ImGearAnnotationPage loaded into the page view control. Set to null if no annotations were loaded.
Public Property | Document | Gets ImGearDocument loaded for the file if requested, otherwise null.
Public Property | File | Gets FileInfo of file dropped on PageView control.
Public Property | Page | Gets ImGearPage loaded into the page view control. Set to null if no page was loaded.
Public Property | PageNumber | Gets Page number of the image or annotation loaded from the file.
Top
See Also

Reference

FileOpenedEventArgs Class
ImageGear.Windows.Controls Namespace


ARTPage Property (FileOpenedEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : ARTPage Property
Gets ImGearAnnotationPage loaded into the page view control. Set to null if no annotations were loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ARTPage As ImGearAnnotationPage
'Usage

Dim instance As FileOpenedEventArgs
Dim value As ImGearAnnotationPage

value = instance.ARTPage
public ImGearAnnotationPage ARTPage {get;}
public: __property ImGearAnnotationPage* get_ARTPage();
public:
property ImGearAnnotationPage^ ARTPage {
   ImGearAnnotationPage^ get();
}

Property Value

ImGearAnnotation class object.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


Document Property (FileOpenedEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : Document Property
Gets ImGearDocument loaded for the file if requested, otherwise null.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As ImGearDocument
'Usage

Dim instance As FileOpenedEventArgs
Dim value As ImGearDocument

value = instance.Document
public ImGearDocument Document {get;}
public: __property ImGearDocument* get_Document();
public:
property ImGearDocument^ Document {
   ImGearDocument^ get();
}

Property Value

ImGearDocument class object.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


File Property (FileOpenedEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : File Property
Gets FileInfo of file dropped on PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property File As FileInfo
'Usage

Dim instance As FileOpenedEventArgs
Dim value As FileInfo

value = instance.File
public FileInfo File {get;}
public: __property FileInfo* get_File();
public:
property FileInfo^ File {
   FileInfo^ get();
}

Property Value

FileInfo class object.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


Page Property (FileOpenedEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : Page Property
Gets ImGearPage loaded into the page view control. Set to null if no page was loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As FileOpenedEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImGearPage class object.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


PageNumber Property (FileOpenedEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpenedEventArgs Class : PageNumber Property
Gets Page number of the image or annotation loaded from the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As FileOpenedEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


%%PageItemTitle%%

FileOpeningEventArgs Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpeningEventArgs Class
Arguments for the PageView.FileOpening event on the PageView control.
Object Model
FileOpeningEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FileOpeningEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FileOpeningEventArgs
public class FileOpeningEventArgs : System.EventArgs
public __gc class FileOpeningEventArgs : public System.EventArgs
public ref class FileOpeningEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Controls.FileOpeningEventArgs

See Also

Reference

FileOpeningEventArgs Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

FileOpeningEventArgs Class Members
Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpeningEventArgs Class

The following tables list the members exposed by FileOpeningEventArgs.

Public Constructors
 | Name | Description
Public Constructor | FileOpeningEventArgs Constructor | Initializes a new instance of the FileOpeningEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel opening of the file.
Public Property | CreateNewPageDisplayForImage | Gets or sets a value indicating whether to create a new Display object for images.
Public Property | File | Gets FileInfo of file dropped on PageView control. Also contains method to open the file.
Public Property | OpenAnnotations | Gets or sets a value indicating whether annotations will be opened.
Public Property | OpenDocument | Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Public Property | OpenImages | Gets or sets a value indicating whether images will be opened.
Public Property | PageNumber | Gets or sets page number in the file to be opened.
Top
See Also

Reference

FileOpeningEventArgs Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

FileOpeningEventArgs Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : FileOpeningEventArgs Constructor
FileInfo object to assign to the file property.
Initializes a new instance of the FileOpeningEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal file As FileInfo _
)
'Usage

Dim file As FileInfo

Dim instance As New FileOpeningEventArgs(file)
public FileOpeningEventArgs(
   FileInfo file
)
public: FileOpeningEventArgs(
   FileInfo* file
)
public:
FileOpeningEventArgs(
   FileInfo^ file
)

Parameters

file
FileInfo object to assign to the file property.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


%%PageItemTitle%% $$Properties$$

FileOpeningEventArgs Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : FileOpeningEventArgs Class

For a list of all members of this type, see FileOpeningEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel opening of the file.
Public Property | CreateNewPageDisplayForImage | Gets or sets a value indicating whether to create a new Display object for images.
Public Property | File | Gets FileInfo of file dropped on PageView control. Also contains method to open the file.
Public Property | OpenAnnotations | Gets or sets a value indicating whether annotations will be opened.
Public Property | OpenDocument | Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Public Property | OpenImages | Gets or sets a value indicating whether images will be opened.
Public Property | PageNumber | Gets or sets page number in the file to be opened.
Top
See Also

Reference

FileOpeningEventArgs Class
ImageGear.Windows.Controls Namespace


Cancel Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : Cancel Property
Gets or sets a value indicating whether to cancel opening of the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


CreateNewPageDisplayForImage Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : CreateNewPageDisplayForImage Property
Gets or sets a value indicating whether to create a new Display object for images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreateNewPageDisplayForImage As Boolean
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Boolean

instance.CreateNewPageDisplayForImage = value

value = instance.CreateNewPageDisplayForImage
public bool CreateNewPageDisplayForImage {get; set;}
public: __property bool get_CreateNewPageDisplayForImage();
public: __property void set_CreateNewPageDisplayForImage(
   bool value
);
public:
property bool CreateNewPageDisplayForImage {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Defaults to true.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


File Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : File Property
Gets FileInfo of file dropped on PageView control. Also contains method to open the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property File As FileInfo
'Usage

Dim instance As FileOpeningEventArgs
Dim value As FileInfo

value = instance.File
public FileInfo File {get;}
public: __property FileInfo* get_File();
public:
property FileInfo^ File {
   FileInfo^ get();
}

Property Value

FileInfo class object.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


OpenAnnotations Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : OpenAnnotations Property
Gets or sets a value indicating whether annotations will be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpenAnnotations As Boolean
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Boolean

instance.OpenAnnotations = value

value = instance.OpenAnnotations
public bool OpenAnnotations {get; set;}
public: __property bool get_OpenAnnotations();
public: __property void set_OpenAnnotations(
   bool value
);
public:
property bool OpenAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to false.

If set to true, then the ART assembly is required.

See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


OpenDocument Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : OpenDocument Property
Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpenDocument As Boolean
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Boolean

instance.OpenDocument = value

value = instance.OpenDocument
public bool OpenDocument {get; set;}
public: __property bool get_OpenDocument();
public: __property void set_OpenDocument(
   bool value
);
public:
property bool OpenDocument {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to false.

If no display object exists, a new will always be created.

See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


OpenImages Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : OpenImages Property
Gets or sets a value indicating whether images will be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpenImages As Boolean
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Boolean

instance.OpenImages = value

value = instance.OpenImages
public bool OpenImages {get; set;}
public: __property bool get_OpenImages();
public: __property void set_OpenImages(
   bool value
);
public:
property bool OpenImages {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Defaults to true.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


PageNumber Property (FileOpeningEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > FileOpeningEventArgs Class : PageNumber Property
Gets or sets page number in the file to be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As FileOpeningEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Defaults to 0.
See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


%%PageItemTitle%%

ImGearAnnotationItems Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationItems Class
This class represents an object that provides access to the menu items that are displayed when right clicking on an annotation mark.
Object Model
ImGearAnnotationItems ClassImGearCustomMarkMenuItemDictionary ClassImGearCustomMarkMenuItemCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAnnotationItems
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearAnnotationItems
public class ImGearAnnotationItems : System.Windows.DependencyObject
public __gc class ImGearAnnotationItems : public System.Windows.DependencyObject
public ref class ImGearAnnotationItems : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearAnnotationItems

See Also

Reference

ImGearAnnotationItems Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotationItems Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationItems Class

The following tables list the members exposed by ImGearAnnotationItems.

Public Constructors
 | Name | Description
Public Constructor | ImGearAnnotationItems Constructor | Initializes a new instance of the ImGearAnnotationItems class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CommonProperty | Represents Common dependency property.
static (Shared in Visual Basic) | CurveProperty | Represents Curve dependency property.
static (Shared in Visual Basic) | CustomProperty | Represents Custom dependency property.
static (Shared in Visual Basic) | EllipseProperty | Represents Ellipse dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | LineProperty | Represents Line dependency property.
static (Shared in Visual Basic) | PointProperty | Represents Point dependency property.
static (Shared in Visual Basic) | PolygonProperty | Represents Polygon dependency property.
static (Shared in Visual Basic) | PolylineProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PolyRulerProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PopupTextProperty | Represents Popup Text dependency property.
static (Shared in Visual Basic) | ProtractorProperty | Represents Protractor dependency property.
static (Shared in Visual Basic) | RectangleProperty | Represents Rectangle dependency property.
static (Shared in Visual Basic) | RulerProperty | Represents Ruler dependency property.
static (Shared in Visual Basic) | TextProperty | Represents Text dependency property.
Top
Public Properties
 | Name | Description
Public Property | Common | Gets or sets the menu items that are displayed when right clicking on any mark.
Public Property | Curve | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTCurve mark.
Public Property | Custom | Gets or sets a dictionary of custom mark menu items.
Public Property | Ellipse | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTEllipse mark.
Public Property | Image | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTImage mark.
Public Property | Line | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTLine mark.
Public Property | Point | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPoint mark.
Public Property | Polygon | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolygon mark.
Public Property | Polyline | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyline mark.
Public Property | PolyRuler | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyRuler mark.
Public Property | PopupText | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPopupText mark.
Public Property | Protractor | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTProtractor mark.
Public Property | Rectangle | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRectangle mark.
Public Property | Ruler | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRuler mark.
Public Property | Text | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTText mark.
Top
See Also

Reference

ImGearAnnotationItems Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearAnnotationItems Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : ImGearAnnotationItems Constructor
Initializes a new instance of the ImGearAnnotationItems class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearAnnotationItems()
public ImGearAnnotationItems()
public: ImGearAnnotationItems();
public:
ImGearAnnotationItems();
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


%%PageItemTitle%% $$Properties$$

ImGearAnnotationItems Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationItems Class

For a list of all members of this type, see ImGearAnnotationItems members.

Public Properties
 | Name | Description
Public Property | Common | Gets or sets the menu items that are displayed when right clicking on any mark.
Public Property | Curve | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTCurve mark.
Public Property | Custom | Gets or sets a dictionary of custom mark menu items.
Public Property | Ellipse | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTEllipse mark.
Public Property | Image | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTImage mark.
Public Property | Line | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTLine mark.
Public Property | Point | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPoint mark.
Public Property | Polygon | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolygon mark.
Public Property | Polyline | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyline mark.
Public Property | PolyRuler | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyRuler mark.
Public Property | PopupText | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPopupText mark.
Public Property | Protractor | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTProtractor mark.
Public Property | Rectangle | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRectangle mark.
Public Property | Ruler | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRuler mark.
Public Property | Text | Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTText mark.
Top
See Also

Reference

ImGearAnnotationItems Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotationItems Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationItems Class

For a list of all members of this type, see ImGearAnnotationItems members.

See Also

Reference

ImGearAnnotationItems Class
ImageGear.Windows.Controls Namespace


Common Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Common Property
Gets or sets the menu items that are displayed when right clicking on any mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Common As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Common = value

value = instance.Common
public ObservableCollection<object> Common {get; set;}
public: __property ObservableCollection<Object*>* get_Common();
public: __property void set_Common(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Common {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
Remarks
These items are appended to the items that are displayed for the specific mark type. For example, if you right click on a rectangle mark, the Rectangle items are displayed in the context menu, followed by these items.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Curve Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Curve Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTCurve mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Curve As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Curve = value

value = instance.Curve
public ObservableCollection<object> Curve {get; set;}
public: __property ObservableCollection<Object*>* get_Curve();
public: __property void set_Curve(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Curve {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Custom Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Custom Property
Gets or sets a dictionary of custom mark menu items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Custom As ImGearCustomMarkMenuItemDictionary
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ImGearCustomMarkMenuItemDictionary

instance.Custom = value

value = instance.Custom
public ImGearCustomMarkMenuItemDictionary Custom {get; set;}
public: __property ImGearCustomMarkMenuItemDictionary* get_Custom();
public: __property void set_Custom(
   ImGearCustomMarkMenuItemDictionary* value
);
public:
property ImGearCustomMarkMenuItemDictionary^ Custom {
   ImGearCustomMarkMenuItemDictionary^ get();
   void set (    ImGearCustomMarkMenuItemDictionary^ value);
}

Property Value

ImGearCustomMarkMenuItemDictionary object.
Remarks
Each entry of the dictionary contains a collection of objects that represent menu items that are displayed when right clicking on a custom mark that corresponds to the dictionary key.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Ellipse Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Ellipse Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTEllipse mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ellipse As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Ellipse = value

value = instance.Ellipse
public ObservableCollection<object> Ellipse {get; set;}
public: __property ObservableCollection<Object*>* get_Ellipse();
public: __property void set_Ellipse(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Ellipse {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Image Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Image Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTImage mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Image = value

value = instance.Image
public ObservableCollection<object> Image {get; set;}
public: __property ObservableCollection<Object*>* get_Image();
public: __property void set_Image(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Image {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Line Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Line Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTLine mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Line As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Line = value

value = instance.Line
public ObservableCollection<object> Line {get; set;}
public: __property ObservableCollection<Object*>* get_Line();
public: __property void set_Line(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Line {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Point Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Point Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPoint mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Point As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Point = value

value = instance.Point
public ObservableCollection<object> Point {get; set;}
public: __property ObservableCollection<Object*>* get_Point();
public: __property void set_Point(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Point {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Polygon Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Polygon Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolygon mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polygon As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Polygon = value

value = instance.Polygon
public ObservableCollection<object> Polygon {get; set;}
public: __property ObservableCollection<Object*>* get_Polygon();
public: __property void set_Polygon(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Polygon {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Polyline Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Polyline Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyline mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polyline As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Polyline = value

value = instance.Polyline
public ObservableCollection<object> Polyline {get; set;}
public: __property ObservableCollection<Object*>* get_Polyline();
public: __property void set_Polyline(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Polyline {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PolyRuler Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PolyRuler Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPolyRuler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyRuler As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.PolyRuler = value

value = instance.PolyRuler
public ObservableCollection<object> PolyRuler {get; set;}
public: __property ObservableCollection<Object*>* get_PolyRuler();
public: __property void set_PolyRuler(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ PolyRuler {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PopupText Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PopupText Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTPopupText mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupText As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.PopupText = value

value = instance.PopupText
public ObservableCollection<object> PopupText {get; set;}
public: __property ObservableCollection<Object*>* get_PopupText();
public: __property void set_PopupText(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ PopupText {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Protractor Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Protractor Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTProtractor mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protractor As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Protractor = value

value = instance.Protractor
public ObservableCollection<object> Protractor {get; set;}
public: __property ObservableCollection<Object*>* get_Protractor();
public: __property void set_Protractor(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Protractor {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Rectangle Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Rectangle Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRectangle mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rectangle As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Rectangle = value

value = instance.Rectangle
public ObservableCollection<object> Rectangle {get; set;}
public: __property ObservableCollection<Object*>* get_Rectangle();
public: __property void set_Rectangle(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Rectangle {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Ruler Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Ruler Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTRuler mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ruler As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Ruler = value

value = instance.Ruler
public ObservableCollection<object> Ruler {get; set;}
public: __property ObservableCollection<Object*>* get_Ruler();
public: __property void set_Ruler(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Ruler {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


Text Property (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : Text Property
Gets or sets the menu items that are displayed when right clicking on an ImageGear.ART.ImGearARTText mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearAnnotationItems
Dim value As ObservableCollection(Of Object)

instance.Text = value

value = instance.Text
public ObservableCollection<object> Text {get; set;}
public: __property ObservableCollection<Object*>* get_Text();
public: __property void set_Text(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ Text {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


%%PageItemTitle%% $$Fields$$

ImGearAnnotationItems Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationItems Class

For a list of all members of this type, see ImGearAnnotationItems members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CommonProperty | Represents Common dependency property.
static (Shared in Visual Basic) | CurveProperty | Represents Curve dependency property.
static (Shared in Visual Basic) | CustomProperty | Represents Custom dependency property.
static (Shared in Visual Basic) | EllipseProperty | Represents Ellipse dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | LineProperty | Represents Line dependency property.
static (Shared in Visual Basic) | PointProperty | Represents Point dependency property.
static (Shared in Visual Basic) | PolygonProperty | Represents Polygon dependency property.
static (Shared in Visual Basic) | PolylineProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PolyRulerProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PopupTextProperty | Represents Popup Text dependency property.
static (Shared in Visual Basic) | ProtractorProperty | Represents Protractor dependency property.
static (Shared in Visual Basic) | RectangleProperty | Represents Rectangle dependency property.
static (Shared in Visual Basic) | RulerProperty | Represents Ruler dependency property.
static (Shared in Visual Basic) | TextProperty | Represents Text dependency property.
Top
See Also

Reference

ImGearAnnotationItems Class
ImageGear.Windows.Controls Namespace


CommonProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : CommonProperty Field
Represents Common dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CommonProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.CommonProperty
public static readonly DependencyProperty CommonProperty
public: static readonly DependencyProperty* CommonProperty
public:
static readonly DependencyProperty^ CommonProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


CurveProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : CurveProperty Field
Represents Curve dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CurveProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.CurveProperty
public static readonly DependencyProperty CurveProperty
public: static readonly DependencyProperty* CurveProperty
public:
static readonly DependencyProperty^ CurveProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


CustomProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : CustomProperty Field
Represents Custom dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CustomProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.CustomProperty
public static readonly DependencyProperty CustomProperty
public: static readonly DependencyProperty* CustomProperty
public:
static readonly DependencyProperty^ CustomProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


EllipseProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : EllipseProperty Field
Represents Ellipse dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly EllipseProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.EllipseProperty
public static readonly DependencyProperty EllipseProperty
public: static readonly DependencyProperty* EllipseProperty
public:
static readonly DependencyProperty^ EllipseProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


ImageProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : ImageProperty Field
Represents Image dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.ImageProperty
public static readonly DependencyProperty ImageProperty
public: static readonly DependencyProperty* ImageProperty
public:
static readonly DependencyProperty^ ImageProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


LineProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : LineProperty Field
Represents Line dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LineProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.LineProperty
public static readonly DependencyProperty LineProperty
public: static readonly DependencyProperty* LineProperty
public:
static readonly DependencyProperty^ LineProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PointProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PointProperty Field
Represents Point dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PointProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.PointProperty
public static readonly DependencyProperty PointProperty
public: static readonly DependencyProperty* PointProperty
public:
static readonly DependencyProperty^ PointProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PolygonProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PolygonProperty Field
Represents Polygon dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolygonProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.PolygonProperty
public static readonly DependencyProperty PolygonProperty
public: static readonly DependencyProperty* PolygonProperty
public:
static readonly DependencyProperty^ PolygonProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PolylineProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PolylineProperty Field
Represents Polyline dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolylineProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.PolylineProperty
public static readonly DependencyProperty PolylineProperty
public: static readonly DependencyProperty* PolylineProperty
public:
static readonly DependencyProperty^ PolylineProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PolyRulerProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PolyRulerProperty Field
Represents Polyline dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolyRulerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.PolyRulerProperty
public static readonly DependencyProperty PolyRulerProperty
public: static readonly DependencyProperty* PolyRulerProperty
public:
static readonly DependencyProperty^ PolyRulerProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


PopupTextProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : PopupTextProperty Field
Represents Popup Text dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PopupTextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.PopupTextProperty
public static readonly DependencyProperty PopupTextProperty
public: static readonly DependencyProperty* PopupTextProperty
public:
static readonly DependencyProperty^ PopupTextProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


ProtractorProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : ProtractorProperty Field
Represents Protractor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ProtractorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.ProtractorProperty
public static readonly DependencyProperty ProtractorProperty
public: static readonly DependencyProperty* ProtractorProperty
public:
static readonly DependencyProperty^ ProtractorProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


RectangleProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : RectangleProperty Field
Represents Rectangle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RectangleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.RectangleProperty
public static readonly DependencyProperty RectangleProperty
public: static readonly DependencyProperty* RectangleProperty
public:
static readonly DependencyProperty^ RectangleProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


RulerProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : RulerProperty Field
Represents Ruler dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RulerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.RulerProperty
public static readonly DependencyProperty RulerProperty
public: static readonly DependencyProperty* RulerProperty
public:
static readonly DependencyProperty^ RulerProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


TextProperty Field (ImGearAnnotationItems)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationItems Class : TextProperty Field
Represents Text dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationItems.TextProperty
public static readonly DependencyProperty TextProperty
public: static readonly DependencyProperty* TextProperty
public:
static readonly DependencyProperty^ TextProperty
See Also

Reference

ImGearAnnotationItems Class
ImGearAnnotationItems Members


%%PageItemTitle%%

ImGearAnnotationSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationSettings Class
Provides a set of settings for the annotation user interface.
Object Model
ImGearAnnotationSettings ClassImGearPage ClassImGearAnnotationTemplates Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<StyleTypedPropertyAttribute(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)>
Public NotInheritable Class ImGearAnnotationSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearAnnotationSettings
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public sealed class ImGearAnnotationSettings : System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public __gc __sealed class ImGearAnnotationSettings : public System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public ref class ImGearAnnotationSettings sealed : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearAnnotationSettings

See Also

Reference

ImGearAnnotationSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotationSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationSettings Class

The following tables list the members exposed by ImGearAnnotationSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearAnnotationSettings Constructor | Initializes a new instance of the ImGearAnnotationSettings class with default settings.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CreatorColorProperty | Represents CreatorColor dependency property.
static (Shared in Visual Basic) | CreatorOpacityProperty | Represents CreatorOpacity dependency property.
static (Shared in Visual Basic) | DefaultImageProperty | This property has been deprecated. Represents DefaultImage dependency property.
static (Shared in Visual Basic) | DoubleClickThresholdProperty | Represents DoubleClickThreshold dependency property.
static (Shared in Visual Basic) | DrawPreviewProperty | Represents DrawPreview dependency property.
static (Shared in Visual Basic) | HandleSizeProperty | Represents HandleSize dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | IsPolylineAutoCloseEnabledProperty | Represents IsPolylineAutoCloseEnabled dependency property.
static (Shared in Visual Basic) | IsPolyMarkAutoRollbackEnabledProperty | Represents IsPolyMarkRollbackEnabled dependency property.
static (Shared in Visual Basic) | IsResetToolEnabledProperty | Represents IsResetToolEnabled dependency property.
static (Shared in Visual Basic) | IsTextClipboardEnabledProperty | Represents IsTextClipboardEnabled dependency property.
static (Shared in Visual Basic) | PolyMarkAutoRollbackThresholdProperty | Represents PolyMarkAutoRollbackThreshold dependency property.
static (Shared in Visual Basic) | PolyMarkPointRadiusThresholdProperty | Represents PolyMarkPointRadiusThreshold dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
static (Shared in Visual Basic) | TemplatesProperty | Represents Templates dependency property.
Top
Public Properties
 | Name | Description
Public Property | CreatorColor | Gets or sets color of a shape drawn when an annotation is being created.
Public Property | CreatorOpacity | Gets or sets opacity level of a shape drawn when an annotation is being created.
Public Property | DefaultImage | This property has been deprecated. Gets or sets the default image to use when creating an image mark.
Public Property | DoubleClickThreshold | Gets or sets double click threshold value in milliseconds.
Public Property | DrawPreview | Gets or sets a value indicating whether an annotation placeholder is used when drawing an annotation.
Public Property | HandleSize | Gets or sets the length and width in device-independent units (1/96th inch per unit) of the handles that are displayed when an annotation is selected.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | IsResetToolEnabled | Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Public Property | IsTextClipboardEnabled | Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Public Property | Templates | Gets or sets the templates for creating annotations using the mouse.
Top
See Also

Reference

ImGearAnnotationSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearAnnotationSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : ImGearAnnotationSettings Constructor
Initializes a new instance of the ImGearAnnotationSettings class with default settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearAnnotationSettings()
public ImGearAnnotationSettings()
public: ImGearAnnotationSettings();
public:
ImGearAnnotationSettings();
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


%%PageItemTitle%% $$Properties$$

ImGearAnnotationSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationSettings Class

For a list of all members of this type, see ImGearAnnotationSettings members.

Public Properties
 | Name | Description
Public Property | CreatorColor | Gets or sets color of a shape drawn when an annotation is being created.
Public Property | CreatorOpacity | Gets or sets opacity level of a shape drawn when an annotation is being created.
Public Property | DefaultImage | This property has been deprecated. Gets or sets the default image to use when creating an image mark.
Public Property | DoubleClickThreshold | Gets or sets double click threshold value in milliseconds.
Public Property | DrawPreview | Gets or sets a value indicating whether an annotation placeholder is used when drawing an annotation.
Public Property | HandleSize | Gets or sets the length and width in device-independent units (1/96th inch per unit) of the handles that are displayed when an annotation is selected.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | IsPolylineAutoCloseEnabled | Gets or sets a value indicating whether the polyline auto-close is enabled.
Public Property | IsPolyMarkAutoRollbackEnabled | Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Public Property | IsResetToolEnabled | Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Public Property | IsTextClipboardEnabled | Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Public Property | PolyMarkAutoRollbackThreshold | Gets or sets a value indicating a poly mark loop auto- correction threshold.
Public Property | PolyMarkPointRadiusThreshold | Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Public Property | Templates | Gets or sets the templates for creating annotations using the mouse.
Top
See Also

Reference

ImGearAnnotationSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotationSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationSettings Class

For a list of all members of this type, see ImGearAnnotationSettings members.

See Also

Reference

ImGearAnnotationSettings Class
ImageGear.Windows.Controls Namespace


CreatorColor Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : CreatorColor Property
Gets or sets color of a shape drawn when an annotation is being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorColor As Color
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Color

instance.CreatorColor = value

value = instance.CreatorColor
public Color CreatorColor {get; set;}
public: __property Color get_CreatorColor();
public: __property void set_CreatorColor(
   Color value
);
public:
property Color CreatorColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Windows.Media.Color value.
Remarks
The default value is Colors.Gray.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


CreatorOpacity Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : CreatorOpacity Property
Gets or sets opacity level of a shape drawn when an annotation is being created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatorOpacity As Byte
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Byte

instance.CreatorOpacity = value

value = instance.CreatorOpacity
public byte CreatorOpacity {get; set;}
public: __property byte get_CreatorOpacity();
public: __property void set_CreatorOpacity(
   byte value
);
public:
property byte CreatorOpacity {
   byte get();
   void set (    byte value);
}

Property Value

Byte value.
Remarks
The default value is 127.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DefaultImage Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DefaultImage Property
This property has been deprecated. Gets or sets the default image to use when creating an image mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")>
Public Property DefaultImage As ImGearPage
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As ImGearPage

instance.DefaultImage = value

value = instance.DefaultImage
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public ImGearPage DefaultImage {get; set;}
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public: __property ImGearPage* get_DefaultImage();
public: __property void set_DefaultImage(
   ImGearPage* value
);
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public:
property ImGearPage^ DefaultImage {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImGearPage value.
Remarks
The ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.Templates.Image property can also be set to specify a default image. If both properties are set, the ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.DefaultImage property is used. This property has been deprecated. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DoubleClickThreshold Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DoubleClickThreshold Property
Gets or sets double click threshold value in milliseconds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DoubleClickThreshold As Integer
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Integer

instance.DoubleClickThreshold = value

value = instance.DoubleClickThreshold
public int DoubleClickThreshold {get; set;}
public: __property int get_DoubleClickThreshold();
public: __property void set_DoubleClickThreshold(
   int value
);
public:
property int DoubleClickThreshold {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
The default value is 250.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DrawPreview Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DrawPreview Property
Gets or sets a value indicating whether an annotation placeholder is used when drawing an annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DrawPreview As Boolean
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Boolean

instance.DrawPreview = value

value = instance.DrawPreview
public bool DrawPreview {get; set;}
public: __property bool get_DrawPreview();
public: __property void set_DrawPreview(
   bool value
);
public:
property bool DrawPreview {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

If set to true, a preview mark is used when an annotation is being added using the mouse. The color and opacity of the preview mark is specified by the ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.CreatorColor and ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.CreatorOpacity properties. If set to false, the appearance of the mark as it is being added using the mouse will match the appearance of the mark after it has been added.

The default value is false.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


HandleSize Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : HandleSize Property
Gets or sets the length and width in device-independent units (1/96th inch per unit) of the handles that are displayed when an annotation is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HandleSize As Double
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Double

instance.HandleSize = value

value = instance.HandleSize
public double HandleSize {get; set;}
public: __property double get_HandleSize();
public: __property void set_HandleSize(
   double value
);
public:
property double HandleSize {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
The default value is 8.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


InteractionArea Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

InteractionArea enumeration value.
Remarks
By default, it is set to InteractionArea enumeration.Device, which corresponds to the unlimited device area. You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device. This affects creating, selecting, resizing and moving annotations.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsPolylineAutoCloseEnabled Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsPolylineAutoCloseEnabled Property
Gets or sets a value indicating whether the polyline auto-close is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolylineAutoCloseEnabled As Boolean
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Boolean

instance.IsPolylineAutoCloseEnabled = value

value = instance.IsPolylineAutoCloseEnabled
public bool IsPolylineAutoCloseEnabled {get; set;}
public: __property bool get_IsPolylineAutoCloseEnabled();
public: __property void set_IsPolylineAutoCloseEnabled(
   bool value
);
public:
property bool IsPolylineAutoCloseEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the polyline mark is created. If true, then the mark is auto-completed and its "Closed" value is set to "true" when current mouse position is close to the starting poly mark point. In this case the PolyMarkPointRadiusThreshold properly should define a max distance, in pixels, between the current mouse position and the starting point position, to consider that poly mark creation process must be finished and the mark must be closed. The default value is false.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsPolyMarkAutoRollbackEnabled Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsPolyMarkAutoRollbackEnabled Property
Gets or sets a value indicating whether the Curve, Polyline, Polygon or Polyruler's auto correction is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPolyMarkAutoRollbackEnabled As Boolean
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Boolean

instance.IsPolyMarkAutoRollbackEnabled = value

value = instance.IsPolyMarkAutoRollbackEnabled
public bool IsPolyMarkAutoRollbackEnabled {get; set;}
public: __property bool get_IsPolyMarkAutoRollbackEnabled();
public: __property void set_IsPolyMarkAutoRollbackEnabled(
   bool value
);
public:
property bool IsPolyMarkAutoRollbackEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Used when the Curve, Polyline, Polygon, Polyruler or Freelhand line mark is created. If true, then the user has an ability to erase segments of poly mark by dragging mouse over recently drawn segments (for Freehand line) or by clicking on the point that starts the segment chain to be deleted. In this case the PolyMarkPointRadiusThreshold property should define a max distance, in pixels, between the current mouse position and one of the previously added points, to consider that user wants to remove a chain of segments. The default value is false.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsResetToolEnabled Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsResetToolEnabled Property
Gets or sets a value indicating whether the annotator tool should be reset to mark selector after creating a chosen annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsResetToolEnabled As Boolean
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Boolean

instance.IsResetToolEnabled = value

value = instance.IsResetToolEnabled
public bool IsResetToolEnabled {get; set;}
public: __property bool get_IsResetToolEnabled();
public: __property void set_IsResetToolEnabled(
   bool value
);
public:
property bool IsResetToolEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsTextClipboardEnabled Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsTextClipboardEnabled Property
Gets or sets a value indicating whether the clipboard operations for text annotations are enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsTextClipboardEnabled As Boolean
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Boolean

instance.IsTextClipboardEnabled = value

value = instance.IsTextClipboardEnabled
public bool IsTextClipboardEnabled {get; set;}
public: __property bool get_IsTextClipboardEnabled();
public: __property void set_IsTextClipboardEnabled(
   bool value
);
public:
property bool IsTextClipboardEnabled {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The default value is true.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


PolyMarkAutoRollbackThreshold Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : PolyMarkAutoRollbackThreshold Property
Gets or sets a value indicating a poly mark loop auto- correction threshold.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkAutoRollbackThreshold As Double
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Double

instance.PolyMarkAutoRollbackThreshold = value

value = instance.PolyMarkAutoRollbackThreshold
public double PolyMarkAutoRollbackThreshold {get; set;}
public: __property double get_PolyMarkAutoRollbackThreshold();
public: __property void set_PolyMarkAutoRollbackThreshold(
   double value
);
public:
property double PolyMarkAutoRollbackThreshold {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
This value indicates a min loop perimeter/area ratio for which the loop will be considered as correction and removed from the path. The smaller value shows that poly mark correction will be easier, but user won’t be able to draw thin shapes; loop with relatively small area will be treated as correction and excluded from the polyline. Minimal possible value is 4*PI (that means round loop). With this threshold value any loop will be removed. The default value is 40 * PI.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


PolyMarkPointRadiusThreshold Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : PolyMarkPointRadiusThreshold Property
Gets or sets a value indicating a radius, in pixels, for the polyline auto-completion and auto-close.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyMarkPointRadiusThreshold As Integer
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Integer

instance.PolyMarkPointRadiusThreshold = value

value = instance.PolyMarkPointRadiusThreshold
public int PolyMarkPointRadiusThreshold {get; set;}
public: __property int get_PolyMarkPointRadiusThreshold();
public: __property void set_PolyMarkPointRadiusThreshold(
   int value
);
public:
property int PolyMarkPointRadiusThreshold {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Also see IsPolylineAutoCloseEnabled and IsPolyMarkAutoRollbackEnabled. The default value is 50.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


SelectionStyle Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : SelectionStyle Property
Gets or sets the Style of the rectangle that is displayed during selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionStyle As Style
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As Style

instance.SelectionStyle = value

value = instance.SelectionStyle
public Style SelectionStyle {get; set;}
public: __property Style* get_SelectionStyle();
public: __property void set_SelectionStyle(
   Style* value
);
public:
property Style^ SelectionStyle {
   Style^ get();
   void set (    Style^ value);
}

Property Value

A System.Windows.Style object.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


Templates Property (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : Templates Property
Gets or sets the templates for creating annotations using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Templates As ImGearAnnotationTemplates
'Usage

Dim instance As ImGearAnnotationSettings
Dim value As ImGearAnnotationTemplates

instance.Templates = value

value = instance.Templates
public ImGearAnnotationTemplates Templates {get; set;}
public: __property ImGearAnnotationTemplates* get_Templates();
public: __property void set_Templates(
   ImGearAnnotationTemplates* value
);
public:
property ImGearAnnotationTemplates^ Templates {
   ImGearAnnotationTemplates^ get();
   void set (    ImGearAnnotationTemplates^ value);
}

Property Value

ImGearAnnotationTemplates value.
Remarks
These settings only affect mark creation if the ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.DrawPreview property is set to false.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


%%PageItemTitle%% $$Fields$$

ImGearAnnotationSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationSettings Class

For a list of all members of this type, see ImGearAnnotationSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CreatorColorProperty | Represents CreatorColor dependency property.
static (Shared in Visual Basic) | CreatorOpacityProperty | Represents CreatorOpacity dependency property.
static (Shared in Visual Basic) | DefaultImageProperty | This property has been deprecated. Represents DefaultImage dependency property.
static (Shared in Visual Basic) | DoubleClickThresholdProperty | Represents DoubleClickThreshold dependency property.
static (Shared in Visual Basic) | DrawPreviewProperty | Represents DrawPreview dependency property.
static (Shared in Visual Basic) | HandleSizeProperty | Represents HandleSize dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | IsPolylineAutoCloseEnabledProperty | Represents IsPolylineAutoCloseEnabled dependency property.
static (Shared in Visual Basic) | IsPolyMarkAutoRollbackEnabledProperty | Represents IsPolyMarkRollbackEnabled dependency property.
static (Shared in Visual Basic) | IsResetToolEnabledProperty | Represents IsResetToolEnabled dependency property.
static (Shared in Visual Basic) | IsTextClipboardEnabledProperty | Represents IsTextClipboardEnabled dependency property.
static (Shared in Visual Basic) | PolyMarkAutoRollbackThresholdProperty | Represents PolyMarkAutoRollbackThreshold dependency property.
static (Shared in Visual Basic) | PolyMarkPointRadiusThresholdProperty | Represents PolyMarkPointRadiusThreshold dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
static (Shared in Visual Basic) | TemplatesProperty | Represents Templates dependency property.
Top
See Also

Reference

ImGearAnnotationSettings Class
ImageGear.Windows.Controls Namespace


CreatorColorProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : CreatorColorProperty Field
Represents CreatorColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CreatorColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.CreatorColorProperty
public static readonly DependencyProperty CreatorColorProperty
public: static readonly DependencyProperty* CreatorColorProperty
public:
static readonly DependencyProperty^ CreatorColorProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


CreatorOpacityProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : CreatorOpacityProperty Field
Represents CreatorOpacity dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CreatorOpacityProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.CreatorOpacityProperty
public static readonly DependencyProperty CreatorOpacityProperty
public: static readonly DependencyProperty* CreatorOpacityProperty
public:
static readonly DependencyProperty^ CreatorOpacityProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DefaultImageProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DefaultImageProperty Field
This property has been deprecated. Represents DefaultImage dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")>
Public Shared ReadOnly DefaultImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.DefaultImageProperty
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public static readonly DependencyProperty DefaultImageProperty
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public: static readonly DependencyProperty* DefaultImageProperty
[Obsolete("This property will be removed from the public API in a future release. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.")]
public:
static readonly DependencyProperty^ DefaultImageProperty
Remarks
This property has been deprecated. Please use the PageView.MouseToolSettings.Annotation.Templates.Image property instead.
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DoubleClickThresholdProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DoubleClickThresholdProperty Field
Represents DoubleClickThreshold dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DoubleClickThresholdProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.DoubleClickThresholdProperty
public static readonly DependencyProperty DoubleClickThresholdProperty
public: static readonly DependencyProperty* DoubleClickThresholdProperty
public:
static readonly DependencyProperty^ DoubleClickThresholdProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


DrawPreviewProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : DrawPreviewProperty Field
Represents DrawPreview dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DrawPreviewProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.DrawPreviewProperty
public static readonly DependencyProperty DrawPreviewProperty
public: static readonly DependencyProperty* DrawPreviewProperty
public:
static readonly DependencyProperty^ DrawPreviewProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


HandleSizeProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : HandleSizeProperty Field
Represents HandleSize dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HandleSizeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.HandleSizeProperty
public static readonly DependencyProperty HandleSizeProperty
public: static readonly DependencyProperty* HandleSizeProperty
public:
static readonly DependencyProperty^ HandleSizeProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


InteractionAreaProperty Field (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsPolylineAutoCloseEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsPolylineAutoCloseEnabledProperty Field
Represents IsPolylineAutoCloseEnabled dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsPolylineAutoCloseEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.IsPolylineAutoCloseEnabledProperty
public static readonly DependencyProperty IsPolylineAutoCloseEnabledProperty
public: static readonly DependencyProperty* IsPolylineAutoCloseEnabledProperty
public:
static readonly DependencyProperty^ IsPolylineAutoCloseEnabledProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsPolyMarkAutoRollbackEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsPolyMarkAutoRollbackEnabledProperty Field
Represents IsPolyMarkRollbackEnabled dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsPolyMarkAutoRollbackEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.IsPolyMarkAutoRollbackEnabledProperty
public static readonly DependencyProperty IsPolyMarkAutoRollbackEnabledProperty
public: static readonly DependencyProperty* IsPolyMarkAutoRollbackEnabledProperty
public:
static readonly DependencyProperty^ IsPolyMarkAutoRollbackEnabledProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsResetToolEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsResetToolEnabledProperty Field
Represents IsResetToolEnabled dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsResetToolEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.IsResetToolEnabledProperty
public static readonly DependencyProperty IsResetToolEnabledProperty
public: static readonly DependencyProperty* IsResetToolEnabledProperty
public:
static readonly DependencyProperty^ IsResetToolEnabledProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


IsTextClipboardEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : IsTextClipboardEnabledProperty Field
Represents IsTextClipboardEnabled dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsTextClipboardEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.IsTextClipboardEnabledProperty
public static readonly DependencyProperty IsTextClipboardEnabledProperty
public: static readonly DependencyProperty* IsTextClipboardEnabledProperty
public:
static readonly DependencyProperty^ IsTextClipboardEnabledProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


PolyMarkAutoRollbackThresholdProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : PolyMarkAutoRollbackThresholdProperty Field
Represents PolyMarkAutoRollbackThreshold dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolyMarkAutoRollbackThresholdProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.PolyMarkAutoRollbackThresholdProperty
public static readonly DependencyProperty PolyMarkAutoRollbackThresholdProperty
public: static readonly DependencyProperty* PolyMarkAutoRollbackThresholdProperty
public:
static readonly DependencyProperty^ PolyMarkAutoRollbackThresholdProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


PolyMarkPointRadiusThresholdProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : PolyMarkPointRadiusThresholdProperty Field
Represents PolyMarkPointRadiusThreshold dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolyMarkPointRadiusThresholdProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.PolyMarkPointRadiusThresholdProperty
public static readonly DependencyProperty PolyMarkPointRadiusThresholdProperty
public: static readonly DependencyProperty* PolyMarkPointRadiusThresholdProperty
public:
static readonly DependencyProperty^ PolyMarkPointRadiusThresholdProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


SelectionStyleProperty Field (ImGearAnnotationSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : SelectionStyleProperty Field
Represents SelectionStyle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.SelectionStyleProperty
public static readonly DependencyProperty SelectionStyleProperty
public: static readonly DependencyProperty* SelectionStyleProperty
public:
static readonly DependencyProperty^ SelectionStyleProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


TemplatesProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationSettings Class : TemplatesProperty Field
Represents Templates dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TemplatesProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationSettings.TemplatesProperty
public static readonly DependencyProperty TemplatesProperty
public: static readonly DependencyProperty* TemplatesProperty
public:
static readonly DependencyProperty^ TemplatesProperty
See Also

Reference

ImGearAnnotationSettings Class
ImGearAnnotationSettings Members


%%PageItemTitle%%

ImGearAnnotationTemplates Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationTemplates Class
Provides templates for creating annotations using the mouse.
Object Model
ImGearAnnotationTemplates ClassImGearARTCurve ClassImGearARTEllipse ClassImGearARTPolyline ClassImGearARTImage ClassImGearARTLine ClassImGearARTPoint ClassImGearARTPolygon ClassImGearARTPolyline ClassImGearARTPolyRuler ClassImGearARTPopupText ClassImGearARTProtractor ClassImGearARTRectangle ClassImGearARTRuler ClassImGearARTText Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAnnotationTemplates
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearAnnotationTemplates
public class ImGearAnnotationTemplates : System.Windows.DependencyObject
public __gc class ImGearAnnotationTemplates : public System.Windows.DependencyObject
public ref class ImGearAnnotationTemplates : public System.Windows.DependencyObject
Remarks
This class can be used to specify a template for each mark that will be used when creating marks using the mouse. Some properties, such as the size, points, and location, are not used since those are determined when creating the mark. If a page resolution is specified for the Ruler or PolyRuler template, it will not be used; Ruler and PolyRuler marks use the page resolution of the currently displayed page.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearAnnotationTemplates

See Also

Reference

ImGearAnnotationTemplates Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotationTemplates Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationTemplates Class

The following tables list the members exposed by ImGearAnnotationTemplates.

Public Constructors
 | Name | Description
Public Constructor | ImGearAnnotationTemplates Constructor | Initializes a new instance of the ImGearAnnotationTemplates class with default settings.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CurveProperty | Represents Curve dependency property.
static (Shared in Visual Basic) | EllipseProperty | Represents Ellipse dependency property.
static (Shared in Visual Basic) | FreehandProperty | Represents Freehand dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | LineProperty | Represents Line dependency property.
static (Shared in Visual Basic) | PointProperty | Represents Point dependency property.
static (Shared in Visual Basic) | PolygonProperty | Represents Polygon dependency property.
static (Shared in Visual Basic) | PolylineProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PolyRulerProperty | Represents PolyRuler dependency property.
static (Shared in Visual Basic) | PopupTextProperty | Represents Popup Text dependency property.
static (Shared in Visual Basic) | ProtractorProperty | Represents Protractor dependency property.
static (Shared in Visual Basic) | RectangleProperty | Represents Rectangle dependency property.
static (Shared in Visual Basic) | RulerProperty | Represents Ruler dependency property.
static (Shared in Visual Basic) | TextProperty | Represents Text dependency property.
Top
Public Properties
 | Name | Description
Public Property | Curve | Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Public Property | Ellipse | Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Public Property | Freehand | Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Public Property | Image | Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Public Property | Line | Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Public Property | Point | Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Public Property | Polygon | Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Public Property | Polyline | Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Public Property | PolyRuler | Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Public Property | PopupText | Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Public Property | Protractor | Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Public Property | Rectangle | Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Ruler | Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Public Property | Text | Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Top
See Also

Reference

ImGearAnnotationTemplates Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearAnnotationTemplates Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : ImGearAnnotationTemplates Constructor
Initializes a new instance of the ImGearAnnotationTemplates class with default settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearAnnotationTemplates()
public ImGearAnnotationTemplates()
public: ImGearAnnotationTemplates();
public:
ImGearAnnotationTemplates();
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


%%PageItemTitle%% $$Properties$$

ImGearAnnotationTemplates Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationTemplates Class

For a list of all members of this type, see ImGearAnnotationTemplates members.

Public Properties
 | Name | Description
Public Property | Curve | Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Public Property | Ellipse | Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Public Property | Freehand | Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Public Property | Image | Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Public Property | Line | Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Public Property | Point | Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Public Property | Polygon | Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Public Property | Polyline | Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Public Property | PolyRuler | Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Public Property | PopupText | Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Public Property | Protractor | Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Public Property | Rectangle | Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Public Property | Ruler | Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Public Property | Text | Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Top
See Also

Reference

ImGearAnnotationTemplates Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotationTemplates Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationTemplates Class

For a list of all members of this type, see ImGearAnnotationTemplates members.

See Also

Reference

ImGearAnnotationTemplates Class
ImageGear.Windows.Controls Namespace


Curve Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Curve Property
Gets or sets a Curve mark to be used as a template when creating Curve marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Curve As ImGearARTCurve
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTCurve

instance.Curve = value

value = instance.Curve
public ImGearARTCurve Curve {get; set;}
public: __property ImGearARTCurve* get_Curve();
public: __property void set_Curve(
   ImGearARTCurve* value
);
public:
property ImGearARTCurve^ Curve {
   ImGearARTCurve^ get();
   void set (    ImGearARTCurve^ value);
}

Property Value

ImGearARTCurve value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Ellipse Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Ellipse Property
Gets or sets an Ellipse mark to be used as a template when creating Ellipse marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ellipse As ImGearARTEllipse
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTEllipse

instance.Ellipse = value

value = instance.Ellipse
public ImGearARTEllipse Ellipse {get; set;}
public: __property ImGearARTEllipse* get_Ellipse();
public: __property void set_Ellipse(
   ImGearARTEllipse* value
);
public:
property ImGearARTEllipse^ Ellipse {
   ImGearARTEllipse^ get();
   void set (    ImGearARTEllipse^ value);
}

Property Value

ImGearARTEllipse value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Freehand Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Freehand Property
Gets or sets a Freehand mark to be used as a template when creating Freehand marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Freehand As ImGearARTPolyline
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPolyline

instance.Freehand = value

value = instance.Freehand
public ImGearARTPolyline Freehand {get; set;}
public: __property ImGearARTPolyline* get_Freehand();
public: __property void set_Freehand(
   ImGearARTPolyline* value
);
public:
property ImGearARTPolyline^ Freehand {
   ImGearARTPolyline^ get();
   void set (    ImGearARTPolyline^ value);
}

Property Value

ImGearARTPolyline value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Image Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Image Property
Gets or sets an Image mark to be used as a template when creating Image marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As ImGearARTImage
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTImage

instance.Image = value

value = instance.Image
public ImGearARTImage Image {get; set;}
public: __property ImGearARTImage* get_Image();
public: __property void set_Image(
   ImGearARTImage* value
);
public:
property ImGearARTImage^ Image {
   ImGearARTImage^ get();
   void set (    ImGearARTImage^ value);
}

Property Value

ImGearARTImage value.
Remarks
The ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.DefaultImage property can also be set to specify a default image. If both properties are set, the ImageGear.Windows.Controls.PageView.MouseToolSettings.Annotation.DefaultImage property is used.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Line Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Line Property
Gets or sets a Line mark to be used as a template when creating Line marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Line As ImGearARTLine
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTLine

instance.Line = value

value = instance.Line
public ImGearARTLine Line {get; set;}
public: __property ImGearARTLine* get_Line();
public: __property void set_Line(
   ImGearARTLine* value
);
public:
property ImGearARTLine^ Line {
   ImGearARTLine^ get();
   void set (    ImGearARTLine^ value);
}

Property Value

ImGearARTLine value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Point Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Point Property
Gets or sets a Point mark to be used as a template when creating Point marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Point As ImGearARTPoint
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPoint

instance.Point = value

value = instance.Point
public ImGearARTPoint Point {get; set;}
public: __property ImGearARTPoint* get_Point();
public: __property void set_Point(
   ImGearARTPoint* value
);
public:
property ImGearARTPoint^ Point {
   ImGearARTPoint^ get();
   void set (    ImGearARTPoint^ value);
}

Property Value

ImGearARTPoint value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Polygon Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Polygon Property
Gets or sets a Polygon mark to be used as a template when creating Polygon marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polygon As ImGearARTPolygon
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPolygon

instance.Polygon = value

value = instance.Polygon
public ImGearARTPolygon Polygon {get; set;}
public: __property ImGearARTPolygon* get_Polygon();
public: __property void set_Polygon(
   ImGearARTPolygon* value
);
public:
property ImGearARTPolygon^ Polygon {
   ImGearARTPolygon^ get();
   void set (    ImGearARTPolygon^ value);
}

Property Value

ImGearARTPolygon value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Polyline Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Polyline Property
Gets or sets a Polyline mark to be used as a template when creating Polyline marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Polyline As ImGearARTPolyline
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPolyline

instance.Polyline = value

value = instance.Polyline
public ImGearARTPolyline Polyline {get; set;}
public: __property ImGearARTPolyline* get_Polyline();
public: __property void set_Polyline(
   ImGearARTPolyline* value
);
public:
property ImGearARTPolyline^ Polyline {
   ImGearARTPolyline^ get();
   void set (    ImGearARTPolyline^ value);
}

Property Value

ImGearARTPolyline value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PolyRuler Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PolyRuler Property
Gets or sets a PolyRuler mark to be used as a template when creating PolyRuler marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolyRuler As ImGearARTPolyRuler
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPolyRuler

instance.PolyRuler = value

value = instance.PolyRuler
public ImGearARTPolyRuler PolyRuler {get; set;}
public: __property ImGearARTPolyRuler* get_PolyRuler();
public: __property void set_PolyRuler(
   ImGearARTPolyRuler* value
);
public:
property ImGearARTPolyRuler^ PolyRuler {
   ImGearARTPolyRuler^ get();
   void set (    ImGearARTPolyRuler^ value);
}

Property Value

ImGearARTPolyRuler value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PopupText Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PopupText Property
Gets or sets a Popup Text mark to be used as a template when creating Popup Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupText As ImGearARTPopupText
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTPopupText

instance.PopupText = value

value = instance.PopupText
public ImGearARTPopupText PopupText {get; set;}
public: __property ImGearARTPopupText* get_PopupText();
public: __property void set_PopupText(
   ImGearARTPopupText* value
);
public:
property ImGearARTPopupText^ PopupText {
   ImGearARTPopupText^ get();
   void set (    ImGearARTPopupText^ value);
}

Property Value

ImGearARTPopupText value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Protractor Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Protractor Property
Gets or sets a Protractor mark to be used as a template when creating Protractor marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protractor As ImGearARTProtractor
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTProtractor

instance.Protractor = value

value = instance.Protractor
public ImGearARTProtractor Protractor {get; set;}
public: __property ImGearARTProtractor* get_Protractor();
public: __property void set_Protractor(
   ImGearARTProtractor* value
);
public:
property ImGearARTProtractor^ Protractor {
   ImGearARTProtractor^ get();
   void set (    ImGearARTProtractor^ value);
}

Property Value

ImGearARTProtractor value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Rectangle Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Rectangle Property
Gets or sets a Rectangle mark to be used as a template when creating rectangle marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rectangle As ImGearARTRectangle
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTRectangle

instance.Rectangle = value

value = instance.Rectangle
public ImGearARTRectangle Rectangle {get; set;}
public: __property ImGearARTRectangle* get_Rectangle();
public: __property void set_Rectangle(
   ImGearARTRectangle* value
);
public:
property ImGearARTRectangle^ Rectangle {
   ImGearARTRectangle^ get();
   void set (    ImGearARTRectangle^ value);
}

Property Value

ImGearARTRectangle value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Ruler Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Ruler Property
Gets or sets a Ruler mark to be used as a template when creating Ruler marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ruler As ImGearARTRuler
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTRuler

instance.Ruler = value

value = instance.Ruler
public ImGearARTRuler Ruler {get; set;}
public: __property ImGearARTRuler* get_Ruler();
public: __property void set_Ruler(
   ImGearARTRuler* value
);
public:
property ImGearARTRuler^ Ruler {
   ImGearARTRuler^ get();
   void set (    ImGearARTRuler^ value);
}

Property Value

ImGearARTRuler value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


Text Property (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : Text Property
Gets or sets a Text mark to be used as a template when creating Text marks using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As ImGearARTText
'Usage

Dim instance As ImGearAnnotationTemplates
Dim value As ImGearARTText

instance.Text = value

value = instance.Text
public ImGearARTText Text {get; set;}
public: __property ImGearARTText* get_Text();
public: __property void set_Text(
   ImGearARTText* value
);
public:
property ImGearARTText^ Text {
   ImGearARTText^ get();
   void set (    ImGearARTText^ value);
}

Property Value

ImGearARTText value.
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


%%PageItemTitle%% $$Fields$$

ImGearAnnotationTemplates Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationTemplates Class

For a list of all members of this type, see ImGearAnnotationTemplates members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CurveProperty | Represents Curve dependency property.
static (Shared in Visual Basic) | EllipseProperty | Represents Ellipse dependency property.
static (Shared in Visual Basic) | FreehandProperty | Represents Freehand dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | LineProperty | Represents Line dependency property.
static (Shared in Visual Basic) | PointProperty | Represents Point dependency property.
static (Shared in Visual Basic) | PolygonProperty | Represents Polygon dependency property.
static (Shared in Visual Basic) | PolylineProperty | Represents Polyline dependency property.
static (Shared in Visual Basic) | PolyRulerProperty | Represents PolyRuler dependency property.
static (Shared in Visual Basic) | PopupTextProperty | Represents Popup Text dependency property.
static (Shared in Visual Basic) | ProtractorProperty | Represents Protractor dependency property.
static (Shared in Visual Basic) | RectangleProperty | Represents Rectangle dependency property.
static (Shared in Visual Basic) | RulerProperty | Represents Ruler dependency property.
static (Shared in Visual Basic) | TextProperty | Represents Text dependency property.
Top
See Also

Reference

ImGearAnnotationTemplates Class
ImageGear.Windows.Controls Namespace


CurveProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : CurveProperty Field
Represents Curve dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CurveProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.CurveProperty
public static readonly DependencyProperty CurveProperty
public: static readonly DependencyProperty* CurveProperty
public:
static readonly DependencyProperty^ CurveProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


EllipseProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : EllipseProperty Field
Represents Ellipse dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly EllipseProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.EllipseProperty
public static readonly DependencyProperty EllipseProperty
public: static readonly DependencyProperty* EllipseProperty
public:
static readonly DependencyProperty^ EllipseProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


FreehandProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : FreehandProperty Field
Represents Freehand dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly FreehandProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.FreehandProperty
public static readonly DependencyProperty FreehandProperty
public: static readonly DependencyProperty* FreehandProperty
public:
static readonly DependencyProperty^ FreehandProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


ImageProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : ImageProperty Field
Represents Image dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.ImageProperty
public static readonly DependencyProperty ImageProperty
public: static readonly DependencyProperty* ImageProperty
public:
static readonly DependencyProperty^ ImageProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


LineProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : LineProperty Field
Represents Line dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LineProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.LineProperty
public static readonly DependencyProperty LineProperty
public: static readonly DependencyProperty* LineProperty
public:
static readonly DependencyProperty^ LineProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PointProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PointProperty Field
Represents Point dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PointProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.PointProperty
public static readonly DependencyProperty PointProperty
public: static readonly DependencyProperty* PointProperty
public:
static readonly DependencyProperty^ PointProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PolygonProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PolygonProperty Field
Represents Polygon dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolygonProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.PolygonProperty
public static readonly DependencyProperty PolygonProperty
public: static readonly DependencyProperty* PolygonProperty
public:
static readonly DependencyProperty^ PolygonProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PolylineProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PolylineProperty Field
Represents Polyline dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolylineProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.PolylineProperty
public static readonly DependencyProperty PolylineProperty
public: static readonly DependencyProperty* PolylineProperty
public:
static readonly DependencyProperty^ PolylineProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PolyRulerProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PolyRulerProperty Field
Represents PolyRuler dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PolyRulerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.PolyRulerProperty
public static readonly DependencyProperty PolyRulerProperty
public: static readonly DependencyProperty* PolyRulerProperty
public:
static readonly DependencyProperty^ PolyRulerProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


PopupTextProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : PopupTextProperty Field
Represents Popup Text dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PopupTextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.PopupTextProperty
public static readonly DependencyProperty PopupTextProperty
public: static readonly DependencyProperty* PopupTextProperty
public:
static readonly DependencyProperty^ PopupTextProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


ProtractorProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : ProtractorProperty Field
Represents Protractor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ProtractorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.ProtractorProperty
public static readonly DependencyProperty ProtractorProperty
public: static readonly DependencyProperty* ProtractorProperty
public:
static readonly DependencyProperty^ ProtractorProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


RectangleProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : RectangleProperty Field
Represents Rectangle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RectangleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.RectangleProperty
public static readonly DependencyProperty RectangleProperty
public: static readonly DependencyProperty* RectangleProperty
public:
static readonly DependencyProperty^ RectangleProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


RulerProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : RulerProperty Field
Represents Ruler dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RulerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.RulerProperty
public static readonly DependencyProperty RulerProperty
public: static readonly DependencyProperty* RulerProperty
public:
static readonly DependencyProperty^ RulerProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


TextProperty Field (ImGearAnnotationTemplates)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotationTemplates Class : TextProperty Field
Represents Text dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearAnnotationTemplates.TextProperty
public static readonly DependencyProperty TextProperty
public: static readonly DependencyProperty* TextProperty
public:
static readonly DependencyProperty^ TextProperty
See Also

Reference

ImGearAnnotationTemplates Class
ImGearAnnotationTemplates Members


%%PageItemTitle%%

ImGearCustomMarkMenuItemCollection Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemCollection Class
This class represents a collection of context menu items for a custom mark.
Object Model
ImGearCustomMarkMenuItemCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearCustomMarkMenuItemCollection
   Inherits System.Collections.ObjectModel.ObservableCollection(Of Object)
'Usage

Dim instance As ImGearCustomMarkMenuItemCollection
public class ImGearCustomMarkMenuItemCollection : System.Collections.ObjectModel.ObservableCollection<object>
public __gc class ImGearCustomMarkMenuItemCollection : public System.Collections.ObjectModel.ObservableCollection<Object>
public ref class ImGearCustomMarkMenuItemCollection : public System.Collections.ObjectModel.ObservableCollection<Object>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
ImageGear.Windows.Controls.ImGearCustomMarkMenuItemCollection

See Also

Reference

ImGearCustomMarkMenuItemCollection Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearCustomMarkMenuItemCollection Class Members
Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemCollection Class

The following tables list the members exposed by ImGearCustomMarkMenuItemCollection.

Public Constructors
 | Name | Description
Public Constructor | ImGearCustomMarkMenuItemCollection Constructor | Initializes a new instance of the ImGearCustomMarkMenuItemCollection class.
Top
See Also

Reference

ImGearCustomMarkMenuItemCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ImGearCustomMarkMenuItemCollection Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemCollection Class

For a list of all members of this type, see ImGearCustomMarkMenuItemCollection members.

See Also

Reference

ImGearCustomMarkMenuItemCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearCustomMarkMenuItemCollection Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemCollection Class

For a list of all members of this type, see ImGearCustomMarkMenuItemCollection members.

See Also

Reference

ImGearCustomMarkMenuItemCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearCustomMarkMenuItemCollection Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemCollection Class

For a list of all members of this type, see ImGearCustomMarkMenuItemCollection members.

See Also

Reference

ImGearCustomMarkMenuItemCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearCustomMarkMenuItemCollection Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearCustomMarkMenuItemCollection Class : ImGearCustomMarkMenuItemCollection Constructor
Initializes a new instance of the ImGearCustomMarkMenuItemCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearCustomMarkMenuItemCollection()
public ImGearCustomMarkMenuItemCollection()
public: ImGearCustomMarkMenuItemCollection();
public:
ImGearCustomMarkMenuItemCollection();
See Also

Reference

ImGearCustomMarkMenuItemCollection Class
ImGearCustomMarkMenuItemCollection Members


%%PageItemTitle%%

ImGearCustomMarkMenuItemDictionary Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemDictionary Class
This class represents a dictionary of collections of context menu items for custom marks.
Object Model
ImGearCustomMarkMenuItemDictionary ClassImGearCustomMarkMenuItemCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearCustomMarkMenuItemDictionary
   Inherits System.Collections.Generic.Dictionary(Of String,ImGearCustomMarkMenuItemCollection)
'Usage

Dim instance As ImGearCustomMarkMenuItemDictionary
public class ImGearCustomMarkMenuItemDictionary : System.Collections.Generic.Dictionary<string,ImGearCustomMarkMenuItemCollection>
public __gc class ImGearCustomMarkMenuItemDictionary : public System.Collections.Generic.Dictionary<string,ImGearCustomMarkMenuItemCollection>
public ref class ImGearCustomMarkMenuItemDictionary : public System.Collections.Generic.Dictionary<String,ImGearCustomMarkMenuItemCollection>
Inheritance Hierarchy

System.Object
System.Collections.Generic.Dictionary<TKey,TValue>
ImageGear.Windows.Controls.ImGearCustomMarkMenuItemDictionary

See Also

Reference

ImGearCustomMarkMenuItemDictionary Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearCustomMarkMenuItemDictionary Class Members
Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemDictionary Class

The following tables list the members exposed by ImGearCustomMarkMenuItemDictionary.

Public Constructors
 | Name | Description
Public Constructor | ImGearCustomMarkMenuItemDictionary Constructor | Initializes a new instance of the ImGearCustomMarkMenuItemDictionary class.
Top
See Also

Reference

ImGearCustomMarkMenuItemDictionary Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ImGearCustomMarkMenuItemDictionary Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemDictionary Class

For a list of all members of this type, see ImGearCustomMarkMenuItemDictionary members.

See Also

Reference

ImGearCustomMarkMenuItemDictionary Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearCustomMarkMenuItemDictionary Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearCustomMarkMenuItemDictionary Class

For a list of all members of this type, see ImGearCustomMarkMenuItemDictionary members.

See Also

Reference

ImGearCustomMarkMenuItemDictionary Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearCustomMarkMenuItemDictionary Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearCustomMarkMenuItemDictionary Class : ImGearCustomMarkMenuItemDictionary Constructor
Initializes a new instance of the ImGearCustomMarkMenuItemDictionary class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearCustomMarkMenuItemDictionary()
public ImGearCustomMarkMenuItemDictionary()
public: ImGearCustomMarkMenuItemDictionary();
public:
ImGearCustomMarkMenuItemDictionary();
See Also

Reference

ImGearCustomMarkMenuItemDictionary Class
ImGearCustomMarkMenuItemDictionary Members


%%PageItemTitle%%

ImGearDelegateCommand Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearDelegateCommand Class
This class represents a delegate command.
Object Model
ImGearDelegateCommand Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearDelegateCommand
'Usage

Dim instance As ImGearDelegateCommand
public class ImGearDelegateCommand
public __gc class ImGearDelegateCommand
public ref class ImGearDelegateCommand
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearDelegateCommand

See Also

Reference

ImGearDelegateCommand Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearDelegateCommand Class Members
Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearDelegateCommand Class

The following tables list the members exposed by ImGearDelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | ImGearDelegateCommand Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ImGearDelegateCommand Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearDelegateCommand Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class : ImGearDelegateCommand Constructor
Overload List
Overload | Description
ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>,IImGearCommandManager) | Initializes a new instance of the ImGearDelegateCommand class.
ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>) | Initializes a new instance of the ImGearDelegateCommand class.
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members


%%PageItemTitle%%

ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>,IImGearCommandManager)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class > ImGearDelegateCommand Constructor : ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>,IImGearCommandManager)
The execute action.
The can execute function.
The command manager.
Initializes a new instance of the ImGearDelegateCommand class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal executeAction As Action(Of Object), _
   ByVal canExecute As ImGearFunc(Of Object,Boolean), _
   ByVal commandManager As IImGearCommandManager _
)
'Usage

Dim executeAction As Action(Of Object)
Dim canExecute As ImGearFunc(Of Object,Boolean)
Dim commandManager As IImGearCommandManager

Dim instance As New ImGearDelegateCommand(executeAction, canExecute, commandManager)
public ImGearDelegateCommand(
   Action<object> executeAction,
   ImGearFunc<object,bool> canExecute,
   IImGearCommandManager commandManager
)
public: ImGearDelegateCommand(
   Action<Object*>* executeAction,
   ImGearFunc<Object*,bool>* canExecute,
   IImGearCommandManager* commandManager
)
public:
ImGearDelegateCommand(
   Action<Object^>^ executeAction,
   ImGearFunc<Object^,bool>^ canExecute,
   IImGearCommandManager^ commandManager
)

Parameters

executeAction
The execute action.
canExecute
The can execute function.
commandManager
The command manager.
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members
Overload List


%%PageItemTitle%%

ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class > ImGearDelegateCommand Constructor : ImGearDelegateCommand Constructor(Action<Object>,ImGearFunc<Object,Boolean>)
The execute action.
The can execute function.
Initializes a new instance of the ImGearDelegateCommand class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal executeAction As Action(Of Object), _
   ByVal canExecute As ImGearFunc(Of Object,Boolean) _
)
'Usage

Dim executeAction As Action(Of Object)
Dim canExecute As ImGearFunc(Of Object,Boolean)

Dim instance As New ImGearDelegateCommand(executeAction, canExecute)
public ImGearDelegateCommand(
   Action<object> executeAction,
   ImGearFunc<object,bool> canExecute
)
public: ImGearDelegateCommand(
   Action<Object*>* executeAction,
   ImGearFunc<Object*,bool>* canExecute
)
public:
ImGearDelegateCommand(
   Action<Object^>^ executeAction,
   ImGearFunc<Object^,bool>^ canExecute
)

Parameters

executeAction
The execute action.
canExecute
The can execute function.
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearDelegateCommand Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearDelegateCommand Class

For a list of all members of this type, see ImGearDelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Top
See Also

Reference

ImGearDelegateCommand Class
ImageGear.Windows.Controls Namespace


CanExecute Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CanExecute( _
   ByVal parameter As Object _
) As Boolean
'Usage

Dim instance As ImGearDelegateCommand
Dim parameter As Object
Dim value As Boolean

value = instance.CanExecute(parameter)
public bool CanExecute(
   object parameter
)
public: bool CanExecute(
   Object* parameter
)
public:
bool CanExecute(
   Object^ parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this command can be executed; otherwise, false.
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members


Execute Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Execute( _
   ByVal parameter As Object _
)
'Usage

Dim instance As ImGearDelegateCommand
Dim parameter As Object

instance.Execute(parameter)
public void Execute(
   object parameter
)
public: void Execute(
   Object* parameter
)
public:
void Execute(
   Object^ parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members


%%PageItemTitle%% $$Events$$

ImGearDelegateCommand Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearDelegateCommand Class

For a list of all members of this type, see ImGearDelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ImGearDelegateCommand Class
ImageGear.Windows.Controls Namespace


CanExecuteChanged Event

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearDelegateCommand Class : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CanExecuteChanged As EventHandler
'Usage

Dim instance As ImGearDelegateCommand
Dim handler As EventHandler

AddHandler instance.CanExecuteChanged, handler
public event EventHandler CanExecuteChanged
public: __event EventHandler* CanExecuteChanged
public:
event EventHandler^ CanExecuteChanged
See Also

Reference

ImGearDelegateCommand Class
ImGearDelegateCommand Members


%%PageItemTitle%%

ImGearHandPanSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearHandPanSettings Class
This class represents the settings for the hand pan mouse tool.
Object Model
ImGearHandPanSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearHandPanSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearHandPanSettings
public class ImGearHandPanSettings : System.Windows.DependencyObject
public __gc class ImGearHandPanSettings : public System.Windows.DependencyObject
public ref class ImGearHandPanSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearHandPanSettings

See Also

Reference

ImGearHandPanSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearHandPanSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearHandPanSettings Class

The following tables list the members exposed by ImGearHandPanSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearHandPanSettings Constructor | Initializes a new instance of the ImGearHandPanSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Top
See Also

Reference

ImGearHandPanSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearHandPanSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearHandPanSettings Class : ImGearHandPanSettings Constructor
Initializes a new instance of the ImGearHandPanSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearHandPanSettings()
public ImGearHandPanSettings()
public: ImGearHandPanSettings();
public:
ImGearHandPanSettings();
See Also

Reference

ImGearHandPanSettings Class
ImGearHandPanSettings Members


%%PageItemTitle%% $$Properties$$

ImGearHandPanSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearHandPanSettings Class

For a list of all members of this type, see ImGearHandPanSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Top
See Also

Reference

ImGearHandPanSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearHandPanSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearHandPanSettings Class

For a list of all members of this type, see ImGearHandPanSettings members.

See Also

Reference

ImGearHandPanSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearHandPanSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearHandPanSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearHandPanSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearHandPanSettings Class
ImGearHandPanSettings Members


InteractionArea Property (ImGearHandPanSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearHandPanSettings Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearHandPanSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

ImGearInteractionArea enumeration value.
Remarks
The default value is ImGearInteractionArea .Device, which corresponds to the unlimited device area. You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device.
See Also

Reference

ImGearHandPanSettings Class
ImGearHandPanSettings Members


%%PageItemTitle%% $$Fields$$

ImGearHandPanSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearHandPanSettings Class

For a list of all members of this type, see ImGearHandPanSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
Top
See Also

Reference

ImGearHandPanSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearHandPanSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearHandPanSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearHandPanSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearHandPanSettings Class
ImGearHandPanSettings Members


InteractionAreaProperty Field (ImGearHandPanSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearHandPanSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearHandPanSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearHandPanSettings Class
ImGearHandPanSettings Members


%%PageItemTitle%%

ImGearImageConverter Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearImageConverter Class
This class is used to convert a FrameworkElement passed as a parameter to an image.
Object Model
ImGearImageConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearImageConverter
'Usage

Dim instance As ImGearImageConverter
public class ImGearImageConverter
public __gc class ImGearImageConverter
public ref class ImGearImageConverter
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearImageConverter

See Also

Reference

ImGearImageConverter Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearImageConverter Class Members
Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearImageConverter Class

The following tables list the members exposed by ImGearImageConverter.

Public Constructors
 | Name | Description
Public Constructor | ImGearImageConverter Constructor |
Top
Public Methods
 | Name | Description
Public Method | Convert | Converts a FrameworkElement to an image.
Public Method | ConvertBack | This method is not implemented.
Top
See Also

Reference

ImGearImageConverter Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearImageConverter Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearImageConverter Class : ImGearImageConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearImageConverter()
public ImGearImageConverter()
public: ImGearImageConverter();
public:
ImGearImageConverter();
See Also

Reference

ImGearImageConverter Class
ImGearImageConverter Members


%%PageItemTitle%% $$Methods$$

ImGearImageConverter Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearImageConverter Class

For a list of all members of this type, see ImGearImageConverter members.

Public Methods
 | Name | Description
Public Method | Convert | Converts a FrameworkElement to an image.
Public Method | ConvertBack | This method is not implemented.
Top
See Also

Reference

ImGearImageConverter Class
ImageGear.Windows.Controls Namespace


Convert Method (ImGearImageConverter)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearImageConverter Class : Convert Method
The value produced by the binding source.
The type of the binding target property.
The converter parameter to use.
The culture to use in the converter.
Converts a FrameworkElement to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Convert( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
'Usage

Dim instance As ImGearImageConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.Convert(value, targetType, parameter, culture)
public object Convert(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
public: Object* Convert(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
public:
Object^ Convert(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The value produced by the binding source.
targetType
The type of the binding target property.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.
See Also

Reference

ImGearImageConverter Class
ImGearImageConverter Members


ConvertBack Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearImageConverter Class : ConvertBack Method
The value produced by the binding source.
The type of the binding target property.
The converter parameter to use.
The culture to use in the converter.
This method is not implemented.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertBack( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
'Usage

Dim instance As ImGearImageConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.ConvertBack(value, targetType, parameter, culture)
public object ConvertBack(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
public: Object* ConvertBack(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
public:
Object^ ConvertBack(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The value produced by the binding source.
targetType
The type of the binding target property.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.
See Also

Reference

ImGearImageConverter Class
ImGearImageConverter Members


%%PageItemTitle%%

ImGearMagnifierSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMagnifierSettings Class
This class represents the settings for the magnifier mouse tool.
Object Model
ImGearMagnifierSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMagnifierSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearMagnifierSettings
public class ImGearMagnifierSettings : System.Windows.DependencyObject
public __gc class ImGearMagnifierSettings : public System.Windows.DependencyObject
public ref class ImGearMagnifierSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearMagnifierSettings

See Also

Reference

ImGearMagnifierSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMagnifierSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMagnifierSettings Class

The following tables list the members exposed by ImGearMagnifierSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearMagnifierSettings Constructor | Initializes a new instance of the ImGearMagnifierSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | HeightProperty | Represents Height dependency property.
static (Shared in Visual Basic) | WidthProperty | Represents Width dependency property.
static (Shared in Visual Basic) | ZoomProperty | Represents Zoom dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | Height | Gets or sets the height of the magnifier (in device pixels).
Public Property | Width | Gets or sets the width of the magnifier (in device pixels).
Public Property | Zoom | Gets or sets the zoom factor of the magnifier.
Top
See Also

Reference

ImGearMagnifierSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMagnifierSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : ImGearMagnifierSettings Constructor
Initializes a new instance of the ImGearMagnifierSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMagnifierSettings()
public ImGearMagnifierSettings()
public: ImGearMagnifierSettings();
public:
ImGearMagnifierSettings();
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


%%PageItemTitle%% $$Properties$$

ImGearMagnifierSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMagnifierSettings Class

For a list of all members of this type, see ImGearMagnifierSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | Height | Gets or sets the height of the magnifier (in device pixels).
Public Property | Width | Gets or sets the width of the magnifier (in device pixels).
Public Property | Zoom | Gets or sets the zoom factor of the magnifier.
Top
See Also

Reference

ImGearMagnifierSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMagnifierSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMagnifierSettings Class

For a list of all members of this type, see ImGearMagnifierSettings members.

See Also

Reference

ImGearMagnifierSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearMagnifierSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


Height Property (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : Height Property
Gets or sets the height of the magnifier (in device pixels).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As ImGearMagnifierSettings
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Default value is 100.
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


Width Property (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : Width Property
Gets or sets the width of the magnifier (in device pixels).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As ImGearMagnifierSettings
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Default value is 120.
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


Zoom Property (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : Zoom Property
Gets or sets the zoom factor of the magnifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Zoom As Double
'Usage

Dim instance As ImGearMagnifierSettings
Dim value As Double

instance.Zoom = value

value = instance.Zoom
public double Zoom {get; set;}
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
public:
property double Zoom {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 2.0.
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


%%PageItemTitle%% $$Fields$$

ImGearMagnifierSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMagnifierSettings Class

For a list of all members of this type, see ImGearMagnifierSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | HeightProperty | Represents Height dependency property.
static (Shared in Visual Basic) | WidthProperty | Represents Width dependency property.
static (Shared in Visual Basic) | ZoomProperty | Represents Zoom dependency property.
Top
See Also

Reference

ImGearMagnifierSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


HeightProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : HeightProperty Field
Represents Height dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierSettings.HeightProperty
public static readonly DependencyProperty HeightProperty
public: static readonly DependencyProperty* HeightProperty
public:
static readonly DependencyProperty^ HeightProperty
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


WidthProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : WidthProperty Field
Represents Width dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly WidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierSettings.WidthProperty
public static readonly DependencyProperty WidthProperty
public: static readonly DependencyProperty* WidthProperty
public:
static readonly DependencyProperty^ WidthProperty
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


ZoomProperty Field (ImGearMagnifierSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMagnifierSettings Class : ZoomProperty Field
Represents Zoom dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierSettings.ZoomProperty
public static readonly DependencyProperty ZoomProperty
public: static readonly DependencyProperty* ZoomProperty
public:
static readonly DependencyProperty^ ZoomProperty
See Also

Reference

ImGearMagnifierSettings Class
ImGearMagnifierSettings Members


%%PageItemTitle%%

ImGearMarksLoadingEventArgs Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMarksLoadingEventArgs Class
This class specifies a list of arguments for the MarksLoadingEventHandler delegate.
Object Model
ImGearMarksLoadingEventArgs ClassImGearARTPage ClassImGearThumbnailPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMarksLoadingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearMarksLoadingEventArgs
public class ImGearMarksLoadingEventArgs : System.EventArgs
public __gc class ImGearMarksLoadingEventArgs : public System.EventArgs
public ref class ImGearMarksLoadingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Controls.ImGearMarksLoadingEventArgs

See Also

Reference

ImGearMarksLoadingEventArgs Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMarksLoadingEventArgs Class Members
Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMarksLoadingEventArgs Class

The following tables list the members exposed by ImGearMarksLoadingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearMarksLoadingEventArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | ARTPage | Gets or sets the ARTPage that will be displayed in the thumbnail item.
Public Property | Item | Gets the ImGearThumbnailPage in which the marks are loading.
Top
See Also

Reference

ImGearMarksLoadingEventArgs Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMarksLoadingEventArgs Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMarksLoadingEventArgs Class : ImGearMarksLoadingEventArgs Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMarksLoadingEventArgs()
public ImGearMarksLoadingEventArgs()
public: ImGearMarksLoadingEventArgs();
public:
ImGearMarksLoadingEventArgs();
See Also

Reference

ImGearMarksLoadingEventArgs Class
ImGearMarksLoadingEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearMarksLoadingEventArgs Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMarksLoadingEventArgs Class

For a list of all members of this type, see ImGearMarksLoadingEventArgs members.

Public Properties
 | Name | Description
Public Property | ARTPage | Gets or sets the ARTPage that will be displayed in the thumbnail item.
Public Property | Item | Gets the ImGearThumbnailPage in which the marks are loading.
Top
See Also

Reference

ImGearMarksLoadingEventArgs Class
ImageGear.Windows.Controls Namespace


ARTPage Property (ImGearMarksLoadingEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMarksLoadingEventArgs Class : ARTPage Property
Gets or sets the ARTPage that will be displayed in the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ARTPage As ImGearARTPage
'Usage

Dim instance As ImGearMarksLoadingEventArgs
Dim value As ImGearARTPage

instance.ARTPage = value

value = instance.ARTPage
public ImGearARTPage ARTPage {get; set;}
public: __property ImGearARTPage* get_ARTPage();
public: __property void set_ARTPage(
   ImGearARTPage* value
);
public:
property ImGearARTPage^ ARTPage {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImGearARTPage value.
See Also

Reference

ImGearMarksLoadingEventArgs Class
ImGearMarksLoadingEventArgs Members


Item Property (ImGearMarksLoadingEventArgs)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMarksLoadingEventArgs Class : Item Property
Gets the ImGearThumbnailPage in which the marks are loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As ImGearThumbnailPage
'Usage

Dim instance As ImGearMarksLoadingEventArgs
Dim value As ImGearThumbnailPage

value = instance.Item
public ImGearThumbnailPage Item {get;}
public: __property ImGearThumbnailPage* get_Item();
public:
property ImGearThumbnailPage^ Item {
   ImGearThumbnailPage^ get();
}

Property Value

ThumbnailPage value.
See Also

Reference

ImGearMarksLoadingEventArgs Class
ImGearMarksLoadingEventArgs Members


%%PageItemTitle%%

ImGearMouseToolSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseToolSettings Class
This class represents the mouse tool settings for the PageView control.
Object Model
ImGearMouseToolSettings ClassImGearAnnotationSettings ClassImGearHandPanSettings ClassImGearMagnifierSettings ClassImGearRectangleZoomSettings ClassImGearSelectSettings ClassImGearZoomInSettings ClassImGearZoomOutSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMouseToolSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearMouseToolSettings
public class ImGearMouseToolSettings : System.Windows.DependencyObject
public __gc class ImGearMouseToolSettings : public System.Windows.DependencyObject
public ref class ImGearMouseToolSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearMouseToolSettings

See Also

Reference

ImGearMouseToolSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMouseToolSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseToolSettings Class

The following tables list the members exposed by ImGearMouseToolSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearMouseToolSettings Constructor | Initializes a new instance of the ImGearMouseToolSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationProperty | Represents Annotation dependency property.
static (Shared in Visual Basic) | HandPanProperty | Represents HandPan dependency property.
static (Shared in Visual Basic) | MagnifierProperty | Represents Magnifier dependency property.
static (Shared in Visual Basic) | RectangleZoomProperty | Represents RectangleZoom dependency property.
static (Shared in Visual Basic) | SelectProperty | Represents Select dependency property.
static (Shared in Visual Basic) | ZoomInProperty | Represents ZoomIn dependency property.
static (Shared in Visual Basic) | ZoomOutProperty | Represents ZoomOut dependency property.
Top
Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets an object that provides access to the annotation mouse tool settings.
Public Property | HandPan | Gets or sets an object that provides access to the settings of the hand pan mouse tool.
Public Property | Magnifier | Gets or sets an object that provides access to the settings of the magnifier mouse tool.
Public Property | RectangleZoom | Gets or sets an object that provides access to the settings of the rectangle zoom mouse tool.
Public Property | Select | Gets or sets an object that provides access to the settings of the select mouse tool.
Public Property | ZoomIn | Gets or sets an object that provides access to the settings of the zoom in mouse tool.
Public Property | ZoomOut | Gets or sets an object that provides access to the settings of the zoom out mouse tool.
Top
See Also

Reference

ImGearMouseToolSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMouseToolSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : ImGearMouseToolSettings Constructor
Initializes a new instance of the ImGearMouseToolSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMouseToolSettings()
public ImGearMouseToolSettings()
public: ImGearMouseToolSettings();
public:
ImGearMouseToolSettings();
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


%%PageItemTitle%% $$Properties$$

ImGearMouseToolSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseToolSettings Class

For a list of all members of this type, see ImGearMouseToolSettings members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets an object that provides access to the annotation mouse tool settings.
Public Property | HandPan | Gets or sets an object that provides access to the settings of the hand pan mouse tool.
Public Property | Magnifier | Gets or sets an object that provides access to the settings of the magnifier mouse tool.
Public Property | RectangleZoom | Gets or sets an object that provides access to the settings of the rectangle zoom mouse tool.
Public Property | Select | Gets or sets an object that provides access to the settings of the select mouse tool.
Public Property | ZoomIn | Gets or sets an object that provides access to the settings of the zoom in mouse tool.
Public Property | ZoomOut | Gets or sets an object that provides access to the settings of the zoom out mouse tool.
Top
See Also

Reference

ImGearMouseToolSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMouseToolSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseToolSettings Class

For a list of all members of this type, see ImGearMouseToolSettings members.

See Also

Reference

ImGearMouseToolSettings Class
ImageGear.Windows.Controls Namespace


Annotation Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : Annotation Property
Gets or sets an object that provides access to the annotation mouse tool settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Annotation As ImGearAnnotationSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearAnnotationSettings

instance.Annotation = value

value = instance.Annotation
public ImGearAnnotationSettings Annotation {get; set;}
public: __property ImGearAnnotationSettings* get_Annotation();
public: __property void set_Annotation(
   ImGearAnnotationSettings* value
);
public:
property ImGearAnnotationSettings^ Annotation {
   ImGearAnnotationSettings^ get();
   void set (    ImGearAnnotationSettings^ value);
}

Property Value

A ImGearAnnotationSettings object.
Remarks
The Annotation property is null by default and can be set to a new AnnotationSettings object to access the default annotation settings or modify them. The AnnotationSettings class is in the ImageGear.Windows.Controls.Art assembly, so the ImageGear.Windows.Controls.Art assembly must be referenced in order to access or modify annotation settings.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


HandPan Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : HandPan Property
Gets or sets an object that provides access to the settings of the hand pan mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HandPan As ImGearHandPanSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearHandPanSettings

instance.HandPan = value

value = instance.HandPan
public ImGearHandPanSettings HandPan {get; set;}
public: __property ImGearHandPanSettings* get_HandPan();
public: __property void set_HandPan(
   ImGearHandPanSettings* value
);
public:
property ImGearHandPanSettings^ HandPan {
   ImGearHandPanSettings^ get();
   void set (    ImGearHandPanSettings^ value);
}

Property Value

A ImGearHandPanSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


Magnifier Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : Magnifier Property
Gets or sets an object that provides access to the settings of the magnifier mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Magnifier As ImGearMagnifierSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearMagnifierSettings

instance.Magnifier = value

value = instance.Magnifier
public ImGearMagnifierSettings Magnifier {get; set;}
public: __property ImGearMagnifierSettings* get_Magnifier();
public: __property void set_Magnifier(
   ImGearMagnifierSettings* value
);
public:
property ImGearMagnifierSettings^ Magnifier {
   ImGearMagnifierSettings^ get();
   void set (    ImGearMagnifierSettings^ value);
}

Property Value

A ImGearMagnifierSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


RectangleZoom Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : RectangleZoom Property
Gets or sets an object that provides access to the settings of the rectangle zoom mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RectangleZoom As ImGearRectangleZoomSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearRectangleZoomSettings

instance.RectangleZoom = value

value = instance.RectangleZoom
public ImGearRectangleZoomSettings RectangleZoom {get; set;}
public: __property ImGearRectangleZoomSettings* get_RectangleZoom();
public: __property void set_RectangleZoom(
   ImGearRectangleZoomSettings* value
);
public:
property ImGearRectangleZoomSettings^ RectangleZoom {
   ImGearRectangleZoomSettings^ get();
   void set (    ImGearRectangleZoomSettings^ value);
}

Property Value

A ImGearRectangleZoomSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


Select Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : Select Property
Gets or sets an object that provides access to the settings of the select mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Select As ImGearSelectSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearSelectSettings

instance.Select = value

value = instance.Select
public ImGearSelectSettings Select {get; set;}
public: __property ImGearSelectSettings* get_Select();
public: __property void set_Select(
   ImGearSelectSettings* value
);
public:
property ImGearSelectSettings^ Select {
   ImGearSelectSettings^ get();
   void set (    ImGearSelectSettings^ value);
}

Property Value

A ImGearSelectSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


ZoomIn Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : ZoomIn Property
Gets or sets an object that provides access to the settings of the zoom in mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomIn As ImGearZoomInSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearZoomInSettings

instance.ZoomIn = value

value = instance.ZoomIn
public ImGearZoomInSettings ZoomIn {get; set;}
public: __property ImGearZoomInSettings* get_ZoomIn();
public: __property void set_ZoomIn(
   ImGearZoomInSettings* value
);
public:
property ImGearZoomInSettings^ ZoomIn {
   ImGearZoomInSettings^ get();
   void set (    ImGearZoomInSettings^ value);
}

Property Value

A ImGearZoomInSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


ZoomOut Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : ZoomOut Property
Gets or sets an object that provides access to the settings of the zoom out mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomOut As ImGearZoomOutSettings
'Usage

Dim instance As ImGearMouseToolSettings
Dim value As ImGearZoomOutSettings

instance.ZoomOut = value

value = instance.ZoomOut
public ImGearZoomOutSettings ZoomOut {get; set;}
public: __property ImGearZoomOutSettings* get_ZoomOut();
public: __property void set_ZoomOut(
   ImGearZoomOutSettings* value
);
public:
property ImGearZoomOutSettings^ ZoomOut {
   ImGearZoomOutSettings^ get();
   void set (    ImGearZoomOutSettings^ value);
}

Property Value

A ImGearZoomOutSettings object.
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


%%PageItemTitle%% $$Fields$$

ImGearMouseToolSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseToolSettings Class

For a list of all members of this type, see ImGearMouseToolSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationProperty | Represents Annotation dependency property.
static (Shared in Visual Basic) | HandPanProperty | Represents HandPan dependency property.
static (Shared in Visual Basic) | MagnifierProperty | Represents Magnifier dependency property.
static (Shared in Visual Basic) | RectangleZoomProperty | Represents RectangleZoom dependency property.
static (Shared in Visual Basic) | SelectProperty | Represents Select dependency property.
static (Shared in Visual Basic) | ZoomInProperty | Represents ZoomIn dependency property.
static (Shared in Visual Basic) | ZoomOutProperty | Represents ZoomOut dependency property.
Top
See Also

Reference

ImGearMouseToolSettings Class
ImageGear.Windows.Controls Namespace


AnnotationProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : AnnotationProperty Field
Represents Annotation dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AnnotationProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.AnnotationProperty
public static readonly DependencyProperty AnnotationProperty
public: static readonly DependencyProperty* AnnotationProperty
public:
static readonly DependencyProperty^ AnnotationProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


HandPanProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : HandPanProperty Field
Represents HandPan dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HandPanProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.HandPanProperty
public static readonly DependencyProperty HandPanProperty
public: static readonly DependencyProperty* HandPanProperty
public:
static readonly DependencyProperty^ HandPanProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


MagnifierProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : MagnifierProperty Field
Represents Magnifier dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MagnifierProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.MagnifierProperty
public static readonly DependencyProperty MagnifierProperty
public: static readonly DependencyProperty* MagnifierProperty
public:
static readonly DependencyProperty^ MagnifierProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


RectangleZoomProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : RectangleZoomProperty Field
Represents RectangleZoom dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RectangleZoomProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.RectangleZoomProperty
public static readonly DependencyProperty RectangleZoomProperty
public: static readonly DependencyProperty* RectangleZoomProperty
public:
static readonly DependencyProperty^ RectangleZoomProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


SelectProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : SelectProperty Field
Represents Select dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.SelectProperty
public static readonly DependencyProperty SelectProperty
public: static readonly DependencyProperty* SelectProperty
public:
static readonly DependencyProperty^ SelectProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


ZoomInProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : ZoomInProperty Field
Represents ZoomIn dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomInProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.ZoomInProperty
public static readonly DependencyProperty ZoomInProperty
public: static readonly DependencyProperty* ZoomInProperty
public:
static readonly DependencyProperty^ ZoomInProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


ZoomOutProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearMouseToolSettings Class : ZoomOutProperty Field
Represents ZoomOut dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomOutProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMouseToolSettings.ZoomOutProperty
public static readonly DependencyProperty ZoomOutProperty
public: static readonly DependencyProperty* ZoomOutProperty
public:
static readonly DependencyProperty^ ZoomOutProperty
See Also

Reference

ImGearMouseToolSettings Class
ImGearMouseToolSettings Members


%%PageItemTitle%%

ImGearPageViewContextMenu Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class
This class represents a context menu for the PageView control.
Object Model
ImGearPageViewContextMenu ClassImGearAnnotationItems Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageViewContextMenu
   Inherits System.Windows.Controls.ContextMenu
'Usage

Dim instance As ImGearPageViewContextMenu
public class ImGearPageViewContextMenu : System.Windows.Controls.ContextMenu
public __gc class ImGearPageViewContextMenu : public System.Windows.Controls.ContextMenu
public ref class ImGearPageViewContextMenu : public System.Windows.Controls.ContextMenu
Remarks

By default a PageViewContextMenu with default menu items is shown when right clicking on the PageView control. The default menu items may change from version to version.

The PageView.ContextMenu property can be set to an instance of PageViewContextMenu to specify a custom context menu. This class can be used to specify menu items that are always displayed (ImageGear.Windows.Controls.PageViewContextMenu.Items), menu items that are displayed when right clicking on a page (PageItems), menu items that are displayed when right clicking on any annotation (ImageGear.Windows.Controls.PageViewContextMenu.MarkItems.Common), and menu items that are displayed when right clicking on specific types of annotations (ImageGear.Windows.Controls.PageViewContextMenu.MarkItems.Line, ImageGear.Windows.Controls.PageViewContextMenu.MarkItems.Rectangle, etc.).

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.MenuBase
System.Windows.Controls.ContextMenu
ImageGear.Windows.Controls.ImGearPageViewContextMenu

See Also

Reference

ImGearPageViewContextMenu Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearPageViewContextMenu Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class

The following tables list the members exposed by ImGearPageViewContextMenu.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageViewContextMenu Constructor | Initializes a new instance of the ImGearPageViewContextMenu class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationItemsProperty | Represents AnnotationItems dependency property.
static (Shared in Visual Basic) | PageItemsProperty | Represents PageItems dependency property.
Top
Public Properties
 | Name | Description
Public Property | AnnotationItems | Gets or sets an object that provides access to the menu items that are displayed when right clicking on an annotation.
Public Property | PageItems | Gets or sets the menu items that are displayed when right clicking on the page.
Top
See Also

Reference

ImGearPageViewContextMenu Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearPageViewContextMenu Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewContextMenu Class : ImGearPageViewContextMenu Constructor
Initializes a new instance of the ImGearPageViewContextMenu class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageViewContextMenu()
public ImGearPageViewContextMenu()
public: ImGearPageViewContextMenu();
public:
ImGearPageViewContextMenu();
See Also

Reference

ImGearPageViewContextMenu Class
ImGearPageViewContextMenu Members


%%PageItemTitle%% $$Properties$$

ImGearPageViewContextMenu Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class

For a list of all members of this type, see ImGearPageViewContextMenu members.

Public Properties
 | Name | Description
Public Property | AnnotationItems | Gets or sets an object that provides access to the menu items that are displayed when right clicking on an annotation.
Public Property | PageItems | Gets or sets the menu items that are displayed when right clicking on the page.
Top
See Also

Reference

ImGearPageViewContextMenu Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearPageViewContextMenu Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class

For a list of all members of this type, see ImGearPageViewContextMenu members.

See Also

Reference

ImGearPageViewContextMenu Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearPageViewContextMenu Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class

For a list of all members of this type, see ImGearPageViewContextMenu members.

See Also

Reference

ImGearPageViewContextMenu Class
ImageGear.Windows.Controls Namespace


AnnotationItems Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewContextMenu Class : AnnotationItems Property
Gets or sets an object that provides access to the menu items that are displayed when right clicking on an annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnnotationItems As ImGearAnnotationItems
'Usage

Dim instance As ImGearPageViewContextMenu
Dim value As ImGearAnnotationItems

instance.AnnotationItems = value

value = instance.AnnotationItems
public ImGearAnnotationItems AnnotationItems {get; set;}
public: __property ImGearAnnotationItems* get_AnnotationItems();
public: __property void set_AnnotationItems(
   ImGearAnnotationItems* value
);
public:
property ImGearAnnotationItems^ AnnotationItems {
   ImGearAnnotationItems^ get();
   void set (    ImGearAnnotationItems^ value);
}

Property Value

An AnnotationItems object.
See Also

Reference

ImGearPageViewContextMenu Class
ImGearPageViewContextMenu Members


PageItems Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewContextMenu Class : PageItems Property
Gets or sets the menu items that are displayed when right clicking on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageItems As ObservableCollection(Of Object)
'Usage

Dim instance As ImGearPageViewContextMenu
Dim value As ObservableCollection(Of Object)

instance.PageItems = value

value = instance.PageItems
public ObservableCollection<object> PageItems {get; set;}
public: __property ObservableCollection<Object*>* get_PageItems();
public: __property void set_PageItems(
   ObservableCollection<Object*>* value
);
public:
property ObservableCollection<Object^>^ PageItems {
   ObservableCollection<Object^>^ get();
   void set (    ObservableCollection<Object^>^ value);
}

Property Value

A collection of objects.
See Also

Reference

ImGearPageViewContextMenu Class
ImGearPageViewContextMenu Members


%%PageItemTitle%% $$Fields$$

ImGearPageViewContextMenu Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewContextMenu Class

For a list of all members of this type, see ImGearPageViewContextMenu members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationItemsProperty | Represents AnnotationItems dependency property.
static (Shared in Visual Basic) | PageItemsProperty | Represents PageItems dependency property.
Top
See Also

Reference

ImGearPageViewContextMenu Class
ImageGear.Windows.Controls Namespace


AnnotationItemsProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewContextMenu Class : AnnotationItemsProperty Field
Represents AnnotationItems dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AnnotationItemsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewContextMenu.AnnotationItemsProperty
public static readonly DependencyProperty AnnotationItemsProperty
public: static readonly DependencyProperty* AnnotationItemsProperty
public:
static readonly DependencyProperty^ AnnotationItemsProperty
See Also

Reference

ImGearPageViewContextMenu Class
ImGearPageViewContextMenu Members


PageItemsProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewContextMenu Class : PageItemsProperty Field
Represents PageItems dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageItemsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewContextMenu.PageItemsProperty
public static readonly DependencyProperty PageItemsProperty
public: static readonly DependencyProperty* PageItemsProperty
public:
static readonly DependencyProperty^ PageItemsProperty
See Also

Reference

ImGearPageViewContextMenu Class
ImGearPageViewContextMenu Members


%%PageItemTitle%%

ImGearPageViewTool Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewTool Class
This class represents PageView toolbar item content.
Object Model
ImGearPageViewTool Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageViewTool
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearPageViewTool
public class ImGearPageViewTool : System.Windows.DependencyObject
public __gc class ImGearPageViewTool : public System.Windows.DependencyObject
public ref class ImGearPageViewTool : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearPageViewTool

See Also

Reference

ImGearPageViewTool Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearPageViewTool Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewTool Class

The following tables list the members exposed by ImGearPageViewTool.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageViewTool Constructor | Initializes a new instance of the ImGearPageViewTool class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CustomMarkControllerProperty | Represents CustomMarkController dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | ToolTipProperty | Represents ToolTip dependency property.
Top
Public Properties
 | Name | Description
Public Property | CustomMarkController | Gets or sets the custom mark controller.
Public Property | Image | Gets or sets the image that appears in the toolbar item.
Public Property | MouseTool | Gets or sets the PageView mouse tool that corresponds to the toolbar item.
Public Property | ToolTip | Gets or sets the tool tip.
Top
Public Methods
 | Name | Description
Public Method | ToString | Gets the tool tip.
Top
See Also

Reference

ImGearPageViewTool Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearPageViewTool Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : ImGearPageViewTool Constructor
Initializes a new instance of the ImGearPageViewTool class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageViewTool()
public ImGearPageViewTool()
public: ImGearPageViewTool();
public:
ImGearPageViewTool();
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


%%PageItemTitle%% $$Methods$$

ImGearPageViewTool Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewTool Class

For a list of all members of this type, see ImGearPageViewTool members.

Public Methods
 | Name | Description
Public Method | ToString | Gets the tool tip.
Top
See Also

Reference

ImGearPageViewTool Class
ImageGear.Windows.Controls Namespace


ToString Method (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : ToString Method
Gets the tool tip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ImGearPageViewTool
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

String value.
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


%%PageItemTitle%% $$Properties$$

ImGearPageViewTool Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewTool Class

For a list of all members of this type, see ImGearPageViewTool members.

Public Properties
 | Name | Description
Public Property | CustomMarkController | Gets or sets the custom mark controller.
Public Property | Image | Gets or sets the image that appears in the toolbar item.
Public Property | MouseTool | Gets or sets the PageView mouse tool that corresponds to the toolbar item.
Public Property | ToolTip | Gets or sets the tool tip.
Top
See Also

Reference

ImGearPageViewTool Class
ImageGear.Windows.Controls Namespace


CustomMarkController Property (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : CustomMarkController Property
Gets or sets the custom mark controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomMarkController As String
'Usage

Dim instance As ImGearPageViewTool
Dim value As String

instance.CustomMarkController = value

value = instance.CustomMarkController
public string CustomMarkController {get; set;}
public: __property string* get_CustomMarkController();
public: __property void set_CustomMarkController(
   string* value
);
public:
property String^ CustomMarkController {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


Image Property (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : Image Property
Gets or sets the image that appears in the toolbar item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As ImageSource
'Usage

Dim instance As ImGearPageViewTool
Dim value As ImageSource

instance.Image = value

value = instance.Image
public ImageSource Image {get; set;}
public: __property ImageSource* get_Image();
public: __property void set_Image(
   ImageSource* value
);
public:
property ImageSource^ Image {
   ImageSource^ get();
   void set (    ImageSource^ value);
}

Property Value

ImageSource object.
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


MouseTool Property (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : MouseTool Property
Gets or sets the PageView mouse tool that corresponds to the toolbar item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseTool As ImGearPageViewToolbarMouseTool
'Usage

Dim instance As ImGearPageViewTool
Dim value As ImGearPageViewToolbarMouseTool

instance.MouseTool = value

value = instance.MouseTool
public ImGearPageViewToolbarMouseTool MouseTool {get; set;}
public: __property ImGearPageViewToolbarMouseTool get_MouseTool();
public: __property void set_MouseTool(
   ImGearPageViewToolbarMouseTool value
);
public:
property ImGearPageViewToolbarMouseTool MouseTool {
   ImGearPageViewToolbarMouseTool get();
   void set (    ImGearPageViewToolbarMouseTool value);
}

Property Value

ImGearPageViewToolbarMouseTool value.
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


ToolTip Property (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : ToolTip Property
Gets or sets the tool tip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As ImGearPageViewTool
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}
public: __property string* get_ToolTip();
public: __property void set_ToolTip(
   string* value
);
public:
property String^ ToolTip {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


%%PageItemTitle%% $$Fields$$

ImGearPageViewTool Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewTool Class

For a list of all members of this type, see ImGearPageViewTool members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CustomMarkControllerProperty | Represents CustomMarkController dependency property.
static (Shared in Visual Basic) | ImageProperty | Represents Image dependency property.
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | ToolTipProperty | Represents ToolTip dependency property.
Top
See Also

Reference

ImGearPageViewTool Class
ImageGear.Windows.Controls Namespace


CustomMarkControllerProperty Field (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : CustomMarkControllerProperty Field
Represents CustomMarkController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CustomMarkControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewTool.CustomMarkControllerProperty
public static readonly DependencyProperty CustomMarkControllerProperty
public: static readonly DependencyProperty* CustomMarkControllerProperty
public:
static readonly DependencyProperty^ CustomMarkControllerProperty
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


ImageProperty Field (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : ImageProperty Field
Represents Image dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewTool.ImageProperty
public static readonly DependencyProperty ImageProperty
public: static readonly DependencyProperty* ImageProperty
public:
static readonly DependencyProperty^ ImageProperty
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


MouseToolProperty Field (ImGearPageViewTool)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : MouseToolProperty Field
Represents MouseTool dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MouseToolProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewTool.MouseToolProperty
public static readonly DependencyProperty MouseToolProperty
public: static readonly DependencyProperty* MouseToolProperty
public:
static readonly DependencyProperty^ MouseToolProperty
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


ToolTipProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewTool Class : ToolTipProperty Field
Represents ToolTip dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ToolTipProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewTool.ToolTipProperty
public static readonly DependencyProperty ToolTipProperty
public: static readonly DependencyProperty* ToolTipProperty
public:
static readonly DependencyProperty^ ToolTipProperty
See Also

Reference

ImGearPageViewTool Class
ImGearPageViewTool Members


%%PageItemTitle%%

ImGearPageViewToolbar Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class
This class represents a PageView toolbar.
Object Model
ImGearPageViewToolbar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageViewToolbar
   Inherits System.Windows.Controls.ListBox
'Usage

Dim instance As ImGearPageViewToolbar
public class ImGearPageViewToolbar : System.Windows.Controls.ListBox
public __gc class ImGearPageViewToolbar : public System.Windows.Controls.ListBox
public ref class ImGearPageViewToolbar : public System.Windows.Controls.ListBox
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
ImageGear.Windows.Controls.ImGearPageViewToolbar

See Also

Reference

ImGearPageViewToolbar Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearPageViewToolbar Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class

The following tables list the members exposed by ImGearPageViewToolbar.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageViewToolbar Constructor | Initializes a new instance of the ImGearPageViewToolbar class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | SelectedCustomMarkControllerProperty | Represents SelectedCustomMarkController dependency property.
Top
Public Properties
 | Name | Description
Public Property | MouseTool | Gets or sets the mouse tool.
Public Property | SelectedCustomMarkController | Gets or sets the selected custom mark controller.
Top
Protected Methods
 | Name | Description
Protected Method | OnSelectionChanged | Overridden. Fires when a toolbar item is selected.
Top
See Also

Reference

ImGearPageViewToolbar Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearPageViewToolbar Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : ImGearPageViewToolbar Constructor
Initializes a new instance of the ImGearPageViewToolbar class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageViewToolbar()
public ImGearPageViewToolbar()
public: ImGearPageViewToolbar();
public:
ImGearPageViewToolbar();
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


%%PageItemTitle%% $$Methods$$

ImGearPageViewToolbar Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class

For a list of all members of this type, see ImGearPageViewToolbar members.

Protected Methods
 | Name | Description
Protected Method | OnSelectionChanged | Overridden. Fires when a toolbar item is selected.
Top
See Also

Reference

ImGearPageViewToolbar Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearPageViewToolbar Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class

For a list of all members of this type, see ImGearPageViewToolbar members.

See Also

Reference

ImGearPageViewToolbar Class
ImageGear.Windows.Controls Namespace


OnSelectionChanged Method (ImGearPageViewToolbar)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : OnSelectionChanged Method
Event arguments.
Fires when a toolbar item is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
'Usage

Dim instance As ImGearPageViewToolbar
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
protected override void OnSelectionChanged(
   SelectionChangedEventArgs e
)
protected: void OnSelectionChanged(
   SelectionChangedEventArgs* e
) override
protected:
void OnSelectionChanged(
   SelectionChangedEventArgs^ e
) override

Parameters

e
Event arguments.
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


%%PageItemTitle%% $$Properties$$

ImGearPageViewToolbar Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class

For a list of all members of this type, see ImGearPageViewToolbar members.

Public Properties
 | Name | Description
Public Property | MouseTool | Gets or sets the mouse tool.
Public Property | SelectedCustomMarkController | Gets or sets the selected custom mark controller.
Top
See Also

Reference

ImGearPageViewToolbar Class
ImageGear.Windows.Controls Namespace


MouseTool Property (ImGearPageViewToolbar)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : MouseTool Property
Gets or sets the mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseTool As ImGearMouseTool
'Usage

Dim instance As ImGearPageViewToolbar
Dim value As ImGearMouseTool

instance.MouseTool = value

value = instance.MouseTool
public ImGearMouseTool MouseTool {get; set;}
public: __property ImGearMouseTool get_MouseTool();
public: __property void set_MouseTool(
   ImGearMouseTool value
);
public:
property ImGearMouseTool MouseTool {
   ImGearMouseTool get();
   void set (    ImGearMouseTool value);
}

Property Value

MouseTool enumeration value.
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


SelectedCustomMarkController Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : SelectedCustomMarkController Property
Gets or sets the selected custom mark controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedCustomMarkController As String
'Usage

Dim instance As ImGearPageViewToolbar
Dim value As String

instance.SelectedCustomMarkController = value

value = instance.SelectedCustomMarkController
public string SelectedCustomMarkController {get; set;}
public: __property string* get_SelectedCustomMarkController();
public: __property void set_SelectedCustomMarkController(
   string* value
);
public:
property String^ SelectedCustomMarkController {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


%%PageItemTitle%% $$Fields$$

ImGearPageViewToolbar Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbar Class

For a list of all members of this type, see ImGearPageViewToolbar members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | SelectedCustomMarkControllerProperty | Represents SelectedCustomMarkController dependency property.
Top
See Also

Reference

ImGearPageViewToolbar Class
ImageGear.Windows.Controls Namespace


MouseToolProperty Field (ImGearPageViewToolbar)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : MouseToolProperty Field
Represents MouseTool dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MouseToolProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewToolbar.MouseToolProperty
public static readonly DependencyProperty MouseToolProperty
public: static readonly DependencyProperty* MouseToolProperty
public:
static readonly DependencyProperty^ MouseToolProperty
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


SelectedCustomMarkControllerProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolbar Class : SelectedCustomMarkControllerProperty Field
Represents SelectedCustomMarkController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectedCustomMarkControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPageViewToolbar.SelectedCustomMarkControllerProperty
public static readonly DependencyProperty SelectedCustomMarkControllerProperty
public: static readonly DependencyProperty* SelectedCustomMarkControllerProperty
public:
static readonly DependencyProperty^ SelectedCustomMarkControllerProperty
See Also

Reference

ImGearPageViewToolbar Class
ImGearPageViewToolbar Members


%%PageItemTitle%%

ImGearPageViewToolCollection Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolCollection Class
This class represents a collection of ImGearPageViewTools.
Object Model
ImGearPageViewToolCollection ClassImGearPageViewTool Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageViewToolCollection
   Inherits System.Collections.ObjectModel.ObservableCollection(Of ImGearPageViewTool)
'Usage

Dim instance As ImGearPageViewToolCollection
public class ImGearPageViewToolCollection : System.Collections.ObjectModel.ObservableCollection<ImGearPageViewTool>
public __gc class ImGearPageViewToolCollection : public System.Collections.ObjectModel.ObservableCollection<ImGearPageViewTool>
public ref class ImGearPageViewToolCollection : public System.Collections.ObjectModel.ObservableCollection<ImGearPageViewTool>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
ImageGear.Windows.Controls.ImGearPageViewToolCollection

See Also

Reference

ImGearPageViewToolCollection Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearPageViewToolCollection Class Members
Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolCollection Class

The following tables list the members exposed by ImGearPageViewToolCollection.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageViewToolCollection Constructor |
Top
See Also

Reference

ImGearPageViewToolCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ImGearPageViewToolCollection Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolCollection Class

For a list of all members of this type, see ImGearPageViewToolCollection members.

See Also

Reference

ImGearPageViewToolCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearPageViewToolCollection Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolCollection Class

For a list of all members of this type, see ImGearPageViewToolCollection members.

See Also

Reference

ImGearPageViewToolCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearPageViewToolCollection Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolCollection Class

For a list of all members of this type, see ImGearPageViewToolCollection members.

See Also

Reference

ImGearPageViewToolCollection Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearPageViewToolCollection Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearPageViewToolCollection Class : ImGearPageViewToolCollection Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageViewToolCollection()
public ImGearPageViewToolCollection()
public: ImGearPageViewToolCollection();
public:
ImGearPageViewToolCollection();
See Also

Reference

ImGearPageViewToolCollection Class
ImGearPageViewToolCollection Members


%%PageItemTitle%%

ImGearRectangleZoomSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearRectangleZoomSettings Class
This class represents the settings for the rectangle zoom mouse tool.
Object Model
ImGearRectangleZoomSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<StyleTypedPropertyAttribute(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)>
Public Class ImGearRectangleZoomSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearRectangleZoomSettings
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public class ImGearRectangleZoomSettings : System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public __gc class ImGearRectangleZoomSettings : public System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public ref class ImGearRectangleZoomSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearRectangleZoomSettings

See Also

Reference

ImGearRectangleZoomSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearRectangleZoomSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearRectangleZoomSettings Class

The following tables list the members exposed by ImGearRectangleZoomSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearRectangleZoomSettings Constructor | Initializes a new instance of the ImGearRectangleZoomSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | MinimumAreaProperty | Represents MinimumArea dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for the rectangle zoom mouse tool.
Public Property | MinimumArea | Gets or sets the minimum area (measured in image pixels) that can be zoomed.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Top
See Also

Reference

ImGearRectangleZoomSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearRectangleZoomSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : ImGearRectangleZoomSettings Constructor
Initializes a new instance of the ImGearRectangleZoomSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRectangleZoomSettings()
public ImGearRectangleZoomSettings()
public: ImGearRectangleZoomSettings();
public:
ImGearRectangleZoomSettings();
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


%%PageItemTitle%% $$Properties$$

ImGearRectangleZoomSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearRectangleZoomSettings Class

For a list of all members of this type, see ImGearRectangleZoomSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for the rectangle zoom mouse tool.
Public Property | MinimumArea | Gets or sets the minimum area (measured in image pixels) that can be zoomed.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Top
See Also

Reference

ImGearRectangleZoomSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearRectangleZoomSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearRectangleZoomSettings Class

For a list of all members of this type, see ImGearRectangleZoomSettings members.

See Also

Reference

ImGearRectangleZoomSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearRectangleZoomSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


InteractionArea Property (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : InteractionArea Property
Gets or sets the interaction area for the rectangle zoom mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearRectangleZoomSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

ImGearInteractionArea enumeration value.
Remarks
The default value is ImGearInteractionArea .Device, which corresponds to the unlimited device area. You can choose to limit the selection area to the image portion of the page view, or keep it unlimited to the entire device.
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


MinimumArea Property (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : MinimumArea Property
Gets or sets the minimum area (measured in image pixels) that can be zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumArea As Integer
'Usage

Dim instance As ImGearRectangleZoomSettings
Dim value As Integer

instance.MinimumArea = value

value = instance.MinimumArea
public int MinimumArea {get; set;}
public: __property int get_MinimumArea();
public: __property void set_MinimumArea(
   int value
);
public:
property int MinimumArea {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
If set to 0, there is no limit on the area. The default value is 0.
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


SelectionStyle Property (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : SelectionStyle Property
Gets or sets the Style of the rectangle that is displayed during selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionStyle As Style
'Usage

Dim instance As ImGearRectangleZoomSettings
Dim value As Style

instance.SelectionStyle = value

value = instance.SelectionStyle
public Style SelectionStyle {get; set;}
public: __property Style* get_SelectionStyle();
public: __property void set_SelectionStyle(
   Style* value
);
public:
property Style^ SelectionStyle {
   Style^ get();
   void set (    Style^ value);
}

Property Value

A System.Windows.Style object.
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


%%PageItemTitle%% $$Fields$$

ImGearRectangleZoomSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearRectangleZoomSettings Class

For a list of all members of this type, see ImGearRectangleZoomSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | MinimumAreaProperty | Represents MinimumArea dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
Top
See Also

Reference

ImGearRectangleZoomSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearRectangleZoomSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


InteractionAreaProperty Field (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearRectangleZoomSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


MinimumAreaProperty Field (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : MinimumAreaProperty Field
Represents MinimumArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MinimumAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearRectangleZoomSettings.MinimumAreaProperty
public static readonly DependencyProperty MinimumAreaProperty
public: static readonly DependencyProperty* MinimumAreaProperty
public:
static readonly DependencyProperty^ MinimumAreaProperty
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


SelectionStyleProperty Field (ImGearRectangleZoomSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearRectangleZoomSettings Class : SelectionStyleProperty Field
Represents SelectionStyle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearRectangleZoomSettings.SelectionStyleProperty
public static readonly DependencyProperty SelectionStyleProperty
public: static readonly DependencyProperty* SelectionStyleProperty
public:
static readonly DependencyProperty^ SelectionStyleProperty
See Also

Reference

ImGearRectangleZoomSettings Class
ImGearRectangleZoomSettings Members


%%PageItemTitle%%

ImGearSelectSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearSelectSettings Class
This class represents the settings for the select mouse tool.
Object Model
ImGearSelectSettings ClassImGearRectangle Structure
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<StyleTypedPropertyAttribute(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)>
Public Class ImGearSelectSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearSelectSettings
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public class ImGearSelectSettings : System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public __gc class ImGearSelectSettings : public System.Windows.DependencyObject
[StyleTypedProperty(Property="SelectionStyle", StyleTargetType=System.Windows.Shapes.Rectangle)]
public ref class ImGearSelectSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearSelectSettings

See Also

Reference

ImGearSelectSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearSelectSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearSelectSettings Class

The following tables list the members exposed by ImGearSelectSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearSelectSettings Constructor | Initializes a new instance of the ImGearSelectSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | MinimumAreaProperty | Represents MinimumArea dependency property.
static (Shared in Visual Basic) | SelectionRectangleProperty | Represents SelectionRectangle dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for the select mouse tool.
Public Property | MinimumArea | Gets or sets the minimum area (measured in image pixels) that can be selected.
Public Property | SelectionRectangle | Gets or sets the rectangle (in image coordinates) that is displayed during selection.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Top
See Also

Reference

ImGearSelectSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearSelectSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : ImGearSelectSettings Constructor
Initializes a new instance of the ImGearSelectSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearSelectSettings()
public ImGearSelectSettings()
public: ImGearSelectSettings();
public:
ImGearSelectSettings();
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


%%PageItemTitle%% $$Properties$$

ImGearSelectSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearSelectSettings Class

For a list of all members of this type, see ImGearSelectSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for the select mouse tool.
Public Property | MinimumArea | Gets or sets the minimum area (measured in image pixels) that can be selected.
Public Property | SelectionRectangle | Gets or sets the rectangle (in image coordinates) that is displayed during selection.
Public Property | SelectionStyle | Gets or sets the Style of the rectangle that is displayed during selection.
Top
See Also

Reference

ImGearSelectSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearSelectSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearSelectSettings Class

For a list of all members of this type, see ImGearSelectSettings members.

See Also

Reference

ImGearSelectSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearSelectSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


InteractionArea Property (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : InteractionArea Property
Gets or sets the interaction area for the select mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearSelectSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

ImGearInteractionArea enumeration value.
Remarks
The default value is ImGearInteractionArea .Device, which corresponds to the unlimited device area. You can choose to limit the selection area to the image portion of the page view, or keep it unlimited to the entire device.
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


MinimumArea Property (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : MinimumArea Property
Gets or sets the minimum area (measured in image pixels) that can be selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumArea As Integer
'Usage

Dim instance As ImGearSelectSettings
Dim value As Integer

instance.MinimumArea = value

value = instance.MinimumArea
public int MinimumArea {get; set;}
public: __property int get_MinimumArea();
public: __property void set_MinimumArea(
   int value
);
public:
property int MinimumArea {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
If set to 0, there is no limit on the area. The default value is 0.
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


SelectionRectangle Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : SelectionRectangle Property
Gets or sets the rectangle (in image coordinates) that is displayed during selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionRectangle As ImGearRectangle
'Usage

Dim instance As ImGearSelectSettings
Dim value As ImGearRectangle

instance.SelectionRectangle = value

value = instance.SelectionRectangle
public ImGearRectangle SelectionRectangle {get; set;}
public: __property ImGearRectangle get_SelectionRectangle();
public: __property void set_SelectionRectangle(
   ImGearRectangle value
);
public:
property ImGearRectangle SelectionRectangle {
   ImGearRectangle get();
   void set (    ImGearRectangle value);
}

Property Value

A ImageGear.Core.ImGearRectangle object.
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


SelectionStyle Property (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : SelectionStyle Property
Gets or sets the Style of the rectangle that is displayed during selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionStyle As Style
'Usage

Dim instance As ImGearSelectSettings
Dim value As Style

instance.SelectionStyle = value

value = instance.SelectionStyle
public Style SelectionStyle {get; set;}
public: __property Style* get_SelectionStyle();
public: __property void set_SelectionStyle(
   Style* value
);
public:
property Style^ SelectionStyle {
   Style^ get();
   void set (    Style^ value);
}

Property Value

A System.Windows.Style object.
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


%%PageItemTitle%% $$Fields$$

ImGearSelectSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearSelectSettings Class

For a list of all members of this type, see ImGearSelectSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | MinimumAreaProperty | Represents MinimumArea dependency property.
static (Shared in Visual Basic) | SelectionRectangleProperty | Represents SelectionRectangle dependency property.
static (Shared in Visual Basic) | SelectionStyleProperty | Represents SelectionStyle dependency property.
Top
See Also

Reference

ImGearSelectSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearSelectSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


InteractionAreaProperty Field (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearSelectSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


MinimumAreaProperty Field (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : MinimumAreaProperty Field
Represents MinimumArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MinimumAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearSelectSettings.MinimumAreaProperty
public static readonly DependencyProperty MinimumAreaProperty
public: static readonly DependencyProperty* MinimumAreaProperty
public:
static readonly DependencyProperty^ MinimumAreaProperty
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


SelectionRectangleProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : SelectionRectangleProperty Field
Represents SelectionRectangle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionRectangleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearSelectSettings.SelectionRectangleProperty
public static readonly DependencyProperty SelectionRectangleProperty
public: static readonly DependencyProperty* SelectionRectangleProperty
public:
static readonly DependencyProperty^ SelectionRectangleProperty
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


SelectionStyleProperty Field (ImGearSelectSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearSelectSettings Class : SelectionStyleProperty Field
Represents SelectionStyle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearSelectSettings.SelectionStyleProperty
public static readonly DependencyProperty SelectionStyleProperty
public: static readonly DependencyProperty* SelectionStyleProperty
public:
static readonly DependencyProperty^ SelectionStyleProperty
See Also

Reference

ImGearSelectSettings Class
ImGearSelectSettings Members


%%PageItemTitle%%

ImGearThumbnailList Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class
This class controls operations with thumbnail items.
Object Model
ImGearThumbnailList ClassImGearPresentationPageDisplay Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailList
   Inherits System.Windows.Controls.ListBox
   Implements IImGearCommandManager
'Usage

Dim instance As ImGearThumbnailList
public class ImGearThumbnailList : System.Windows.Controls.ListBox, IImGearCommandManager
public __gc class ImGearThumbnailList : public System.Windows.Controls.ListBox, IImGearCommandManager
public ref class ImGearThumbnailList : public System.Windows.Controls.ListBox, IImGearCommandManager
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
ImageGear.Windows.Controls.ImGearThumbnailList

See Also

Reference

ImGearThumbnailList Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailList Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class

The following tables list the members exposed by ImGearThumbnailList.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailList Constructor | Initializes a new instance of the ImGearThumbnailList class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CacheItemContainersProperty | Cache item containers dependency property.
static (Shared in Visual Basic) | DisplayMarksProperty | Represents DisplayMarks dependency property.
static (Shared in Visual Basic) | ItemBackgroundProperty | Represents ItemBackground dependency property.
static (Shared in Visual Basic) | ItemBorderBrushProperty | Represents ItemBorderBrush dependency property.
static (Shared in Visual Basic) | ItemBorderThicknessProperty | Represents ItemBorderThickness dependency property.
static (Shared in Visual Basic) | ItemCaptionBackgroundProperty | Represents ItemCaptionBackground dependency property.
static (Shared in Visual Basic) | ItemCaptionForegroundProperty | Represents ItemCaptionForeground dependency property.
static (Shared in Visual Basic) | ItemHeightProperty | Represents ItemHeight dependency property.
static (Shared in Visual Basic) | ItemsMarginProperty | Represents ItemsMargin dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Represents ItemWidth dependency property.
static (Shared in Visual Basic) | ScrollDirectionProperty | Represents ScrollDirection dependency property.
static (Shared in Visual Basic) | SelectedPageDisplayProperty | Represents SelectedPageDisplay dependency property.
static (Shared in Visual Basic) | XSpacingProperty | Represents XSpacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Represents YSpacing dependency property.
Top
Public Properties
 | Name | Description
Public Property | ARTPageCache | Gets a cache for storing and retrieving ImGearARTPages associated with thumbnail items.
Public Property | CacheItemContainers | Gets or sets a value indicating whether item containers that are out of view are cached.
Public Property | DisplayMarks | Gets or sets a value indicating whether marks are displayed in thumbnails.
Public Property | ItemBackground | Gets or sets the Brush that specifies how the background of thumbnail items is painted.
Public Property | ItemBorderBrush | Gets or sets the Brush that specifies how the border of thumbnail items is painted.
Public Property | ItemBorderThickness | Gets or sets the thickness of the border of thumbnail items.
Public Property | ItemCaptionBackground | Gets or sets the Brush that specifies how the background of the Caption of thumbnail items is painted.
Public Property | ItemCaptionForeground | Gets or sets the Brush that specifies how the foreground of the Caption of thumbnail items is painted.
Public Property | ItemHeight | Gets or sets the height, in WPF device independent units, of each thumbnail item.
Public Property | ItemsMargin | Gets or sets the region within the control (in WPF device independent units) where thumbnail items are displayed.
Public Property | ItemsSource | Gets or sets a collection used to generate the content of the thumbnail control.
Public Property | ItemWidth | Gets or sets the width, in WPF device independent units, of each thumbnail item.
Public Property | ScrollDirection | Gets or sets the direction the thumbnail items will scroll in the control.
Public Property | ScrollToFirstItemCommand | Gets a command for scrolling to the first item in the thumbnail list.
Public Property | ScrollToLastItemCommand | Gets a command for scrolling to the last item in the thumbnail list.
Public Property | ScrollToNextBandCommand | Gets a command for scrolling to the next band of thumbnails in the thumbnail list.
Public Property | ScrollToNextPageCommand | Gets a command for scrolling to the next page of thumbnails in the thumbnail list.
Public Property | ScrollToPreviousBandCommand | Gets a command for scrolling to the previous band of thumbnails in the thumbnail list.
Public Property | ScrollToPreviousPageCommand | Gets a command for scrolling to the previous page of thumbnails in the thumbnail list.
Public Property | SelectedPageDisplay | Gets or sets the page display that contains the source image and marks of the selected thumbnail item.
Public Property | SelectFirstItemCommand | Gets a command for selecting the first item in the thumbnail list.
Public Property | SelectLastItemCommand | Gets a command for selecting the last item in the thumbnail list.
Public Property | SelectNextBandItemCommand | Gets a command for selecting the next band item in the thumbnail list.
Public Property | SelectNextItemCommand | Gets a command for selecting the next item in the thumbnail list.
Public Property | SelectPreviousBandItemCommand | Gets a command for selecting the previous band item in the thumbnail list.
Public Property | SelectPreviousItemCommand | Gets a command for selecting the previous item in the thumbnail list.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in WPF device independent units.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in WPF device independent units.
Top
Public Methods
 | Name | Description
Public Method | LoadAllARTPages | Causes the ThumbnailList to fire the MarksLoading event for each thumbnail item that does not have an associated ImGearARTPage in the ThumbnailList.ARTPageCache.
Public Method | ReloadItem | Reloads the images in the thumbnail items that are currently displayed.
Public Method | ReloadItems | Reloads the images in the thumbnail items that are currently displayed.
Public Method | ScrollIntoView | Overloaded. Causes the thumbnail item at the specified index to scroll into view.
Public Method | ScrollToFirstItem | Scrolls to the first item in the thumbnail list.
Public Method | ScrollToLastItem | Scrolls to the last item in the thumbnail list.
Public Method | ScrollToNextBand | Scrolls the next band of thumbnail items into view.
Public Method | ScrollToNextPage | Scrolls the next page of thumbnail items into view.
Public Method | ScrollToPreviousBand | Scrolls the previous band of thumbnail items into view.
Public Method | ScrollToPreviousPage | Scrolls the previous page of thumbnail items into view.
Public Method | SelectFirstItem | Selects the first item in the thumbnail list.
Public Method | SelectLastItem | Selects the last item in the thumbnail list.
Public Method | SelectNextBandItem | Selects the next band item in the thumbnail list.
Public Method | SelectNextItem | Selects the next item in the thumbnail list.
Public Method | SelectPreviousBandItem | Selects the previous band item in the thumbnail list.
Public Method | SelectPreviousItem | Selects the previous item in the thumbnail list.
Top
Protected Methods
 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. Clears the container for the item.
Protected Method | GetContainerForItemOverride | Overridden. Create or identify the element used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Return true if the item is (or is eligible to be) its own ItemContainer.
Protected Method | OnItemsChanged | Overridden. Fires when items are removed or added to the thumbnail list.
Protected Method | OnKeyDown | Overridden. Fires when a key is pressed.
Protected Method | OnMarksLoading | Occurs when a point is added to the mark.
Protected Method | OnRequerySuggested | Occurs when a requery is suggested.
Protected Method | OnSelectionChanged | Overridden. Fires when the thumbnail items are selected or deselected.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top
Public Events
 | Name | Description
Public Event | MarksLoading | This event is called when a thumbnail item is first generated and can be used to load the marks for the thumbnail item.
Public Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearThumbnailList Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ImGearThumbnailList Constructor
Initializes a new instance of the ImGearThumbnailList class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailList()
public ImGearThumbnailList()
public: ImGearThumbnailList();
public:
ImGearThumbnailList();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailList Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

Public Methods
 | Name | Description
Public Method | LoadAllARTPages | Causes the ThumbnailList to fire the MarksLoading event for each thumbnail item that does not have an associated ImGearARTPage in the ThumbnailList.ARTPageCache.
Public Method | ReloadItem | Reloads the images in the thumbnail items that are currently displayed.
Public Method | ReloadItems | Reloads the images in the thumbnail items that are currently displayed.
Public Method | ScrollIntoView | Overloaded. Causes the thumbnail item at the specified index to scroll into view.
Public Method | ScrollToFirstItem | Scrolls to the first item in the thumbnail list.
Public Method | ScrollToLastItem | Scrolls to the last item in the thumbnail list.
Public Method | ScrollToNextBand | Scrolls the next band of thumbnail items into view.
Public Method | ScrollToNextPage | Scrolls the next page of thumbnail items into view.
Public Method | ScrollToPreviousBand | Scrolls the previous band of thumbnail items into view.
Public Method | ScrollToPreviousPage | Scrolls the previous page of thumbnail items into view.
Public Method | SelectFirstItem | Selects the first item in the thumbnail list.
Public Method | SelectLastItem | Selects the last item in the thumbnail list.
Public Method | SelectNextBandItem | Selects the next band item in the thumbnail list.
Public Method | SelectNextItem | Selects the next item in the thumbnail list.
Public Method | SelectPreviousBandItem | Selects the previous band item in the thumbnail list.
Public Method | SelectPreviousItem | Selects the previous item in the thumbnail list.
Top
Protected Methods
 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. Clears the container for the item.
Protected Method | GetContainerForItemOverride | Overridden. Create or identify the element used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Return true if the item is (or is eligible to be) its own ItemContainer.
Protected Method | OnItemsChanged | Overridden. Fires when items are removed or added to the thumbnail list.
Protected Method | OnKeyDown | Overridden. Fires when a key is pressed.
Protected Method | OnMarksLoading | Occurs when a point is added to the mark.
Protected Method | OnRequerySuggested | Occurs when a requery is suggested.
Protected Method | OnSelectionChanged | Overridden. Fires when the thumbnail items are selected or deselected.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Windows.Controls Namespace


ClearContainerForItemOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ClearContainerForItemOverride Method
Element used to display the specified item.
Specified item.
Clears the container for the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
'Usage

Dim instance As ImGearThumbnailList
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


GetContainerForItemOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : GetContainerForItemOverride Method
Create or identify the element used to display the given item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function GetContainerForItemOverride() As DependencyObject
'Usage

Dim instance As ImGearThumbnailList
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
protected override DependencyObject GetContainerForItemOverride()
protected: DependencyObject* GetContainerForItemOverride(); override
protected:
DependencyObject^ GetContainerForItemOverride(); override

Return Value

DependencyObject value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


IsItemItsOwnContainerOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : IsItemItsOwnContainerOverride Method
The specified item.
Return true if the item is (or is eligible to be) its own ItemContainer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
protected override bool IsItemItsOwnContainerOverride(
   object item
)
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The specified item.

Return Value

Boolean value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


LoadAllARTPages Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : LoadAllARTPages Method
Causes the ThumbnailList to fire the MarksLoading event for each thumbnail item that does not have an associated ImGearARTPage in the ThumbnailList.ARTPageCache.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LoadAllARTPages()
'Usage

Dim instance As ImGearThumbnailList

instance.LoadAllARTPages()
public void LoadAllARTPages()
public: void LoadAllARTPages();
public:
void LoadAllARTPages();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnItemsChanged Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : OnItemsChanged Method
Event arguments.
Fires when items are removed or added to the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
'Usage

Dim instance As ImGearThumbnailList
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Event arguments.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnKeyDown Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : OnKeyDown Method
Event arguments.
Fires when a key is pressed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
'Usage

Dim instance As ImGearThumbnailList
Dim e As KeyEventArgs

instance.OnKeyDown(e)
protected override void OnKeyDown(
   KeyEventArgs e
)
protected: void OnKeyDown(
   KeyEventArgs* e
) override
protected:
void OnKeyDown(
   KeyEventArgs^ e
) override

Parameters

e
Event arguments.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnMarksLoading Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : OnMarksLoading Method
Event arguments.
Occurs when a point is added to the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarksLoading( _
   ByVal e As ImGearMarksLoadingEventArgs _
)
'Usage

Dim instance As ImGearThumbnailList
Dim e As ImGearMarksLoadingEventArgs

instance.OnMarksLoading(e)
protected void OnMarksLoading(
   ImGearMarksLoadingEventArgs e
)
protected: void OnMarksLoading(
   ImGearMarksLoadingEventArgs* e
)
protected:
void OnMarksLoading(
   ImGearMarksLoadingEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnRequerySuggested Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : OnRequerySuggested Method
Event arguments.
Occurs when a requery is suggested.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnRequerySuggested( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As ImGearThumbnailList
Dim e As EventArgs

instance.OnRequerySuggested(e)
protected void OnRequerySuggested(
   EventArgs e
)
protected: void OnRequerySuggested(
   EventArgs* e
)
protected:
void OnRequerySuggested(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


OnSelectionChanged Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : OnSelectionChanged Method
Event arguments.
Fires when the thumbnail items are selected or deselected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
'Usage

Dim instance As ImGearThumbnailList
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
protected override void OnSelectionChanged(
   SelectionChangedEventArgs e
)
protected: void OnSelectionChanged(
   SelectionChangedEventArgs* e
) override
protected:
void OnSelectionChanged(
   SelectionChangedEventArgs^ e
) override

Parameters

e
Event arguments.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


PrepareContainerForItemOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : PrepareContainerForItemOverride Method
Element used to display the specified item.
Specified item.
Prepares the specified element to display the specified item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
'Usage

Dim instance As ImGearThumbnailList
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ReloadItem Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ReloadItem Method
The index of the item to remove.
Reloads the images in the thumbnail items that are currently displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReloadItem( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearThumbnailList
Dim index As Integer

instance.ReloadItem(index)
public void ReloadItem(
   int index
)
public: void ReloadItem(
   int index
)
public:
void ReloadItem(
   int index
)

Parameters

index
The index of the item to remove.
Remarks
If thumbnail items are resized, the thumbnail images will stretch to fit the new size. The ReloadItems method can be called to regenerate the thumbnail images to best fit the new size. This method clears the thumbnail page cache so that any previously viewed thumbnail images will be reloaded from their source when viewed again.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ReloadItems Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ReloadItems Method
Reloads the images in the thumbnail items that are currently displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReloadItems()
'Usage

Dim instance As ImGearThumbnailList

instance.ReloadItems()
public void ReloadItems()
public: void ReloadItems();
public:
void ReloadItems();
Remarks
If thumbnail items are resized, the thumbnail images will stretch to fit the new size. The ReloadItems method can be called to regenerate the thumbnail images to best fit the new size. This method clears the thumbnail page cache so that any previously viewed thumbnail images will be reloaded from their source when viewed again.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollIntoView Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollIntoView Method
Causes the thumbnail item at the specified index to scroll into view.
Overload List
Overload | Description
ScrollIntoView(Int32) | Causes the thumbnail item at the specified index to scroll into view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollIntoView(Int32) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class > ScrollIntoView Method : ScrollIntoView(Int32) Method
The index of the thumbnail item to scroll into view.
Causes the thumbnail item at the specified index to scroll into view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ScrollIntoView( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImGearThumbnailList
Dim index As Integer

instance.ScrollIntoView(index)
public void ScrollIntoView(
   int index
)
public: void ScrollIntoView(
   int index
)
public:
void ScrollIntoView(
   int index
)

Parameters

index
The index of the thumbnail item to scroll into view.
Remarks
Because of a bug in the MS ListBox the ScrollIntoView(object item) method inherited from ListBox does not work with a virtualizing panel. This method should be used instead.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members
Overload List


ScrollToFirstItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToFirstItem Method
Scrolls to the first item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToFirstItem()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToFirstItem()
public void ScrollToFirstItem()
public: void ScrollToFirstItem();
public:
void ScrollToFirstItem();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToLastItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToLastItem Method
Scrolls to the last item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToLastItem()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToLastItem()
public void ScrollToLastItem()
public: void ScrollToLastItem();
public:
void ScrollToLastItem();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToNextBand Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToNextBand Method
Scrolls the next band of thumbnail items into view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToNextBand()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToNextBand()
public void ScrollToNextBand()
public: void ScrollToNextBand();
public:
void ScrollToNextBand();
Remarks
If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToNextPage Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToNextPage Method
Scrolls the next page of thumbnail items into view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToNextPage()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToNextPage()
public void ScrollToNextPage()
public: void ScrollToNextPage();
public:
void ScrollToNextPage();
Remarks
A page of thumbnail items consists of all of the thumbnail items that fit in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToPreviousBand Method (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToPreviousBand Method
Scrolls the previous band of thumbnail items into view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToPreviousBand()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToPreviousBand()
public void ScrollToPreviousBand()
public: void ScrollToPreviousBand();
public:
void ScrollToPreviousBand();
Remarks
If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToPreviousPage Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToPreviousPage Method
Scrolls the previous page of thumbnail items into view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScrollToPreviousPage()
'Usage

Dim instance As ImGearThumbnailList

instance.ScrollToPreviousPage()
public void ScrollToPreviousPage()
public: void ScrollToPreviousPage();
public:
void ScrollToPreviousPage();
Remarks
A page of thumbnail items consists of all of the thumbnail items that fit in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectFirstItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectFirstItem Method
Selects the first item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectFirstItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectFirstItem()
public void SelectFirstItem()
public: void SelectFirstItem();
public:
void SelectFirstItem();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectLastItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectLastItem Method
Selects the last item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectLastItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectLastItem()
public void SelectLastItem()
public: void SelectLastItem();
public:
void SelectLastItem();
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectNextBandItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectNextBandItem Method
Selects the next band item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectNextBandItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectNextBandItem()
public void SelectNextBandItem()
public: void SelectNextBandItem();
public:
void SelectNextBandItem();
Remarks

If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.

This method will have no effect if there is no currently selected item or if the currently selected item is on the last band.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectNextItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectNextItem Method
Selects the next item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectNextItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectNextItem()
public void SelectNextItem()
public: void SelectNextItem();
public:
void SelectNextItem();
Remarks
This method will have no effect if there is no currently selected item or if the currently selected item is the last item.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectPreviousBandItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectPreviousBandItem Method
Selects the previous band item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectPreviousBandItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectPreviousBandItem()
public void SelectPreviousBandItem()
public: void SelectPreviousBandItem();
public:
void SelectPreviousBandItem();
Remarks

If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.

This method will have no effect if there is no currently selected item or if the currently selected item is on the first band.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectPreviousItem Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectPreviousItem Method
Selects the previous item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectPreviousItem()
'Usage

Dim instance As ImGearThumbnailList

instance.SelectPreviousItem()
public void SelectPreviousItem()
public: void SelectPreviousItem();
public:
void SelectPreviousItem();
Remarks
This method will have no effect if there is no currently selected item or if the currently selected item is the first item.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailList Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

Public Properties
 | Name | Description
Public Property | ARTPageCache | Gets a cache for storing and retrieving ImGearARTPages associated with thumbnail items.
Public Property | CacheItemContainers | Gets or sets a value indicating whether item containers that are out of view are cached.
Public Property | DisplayMarks | Gets or sets a value indicating whether marks are displayed in thumbnails.
Public Property | ItemBackground | Gets or sets the Brush that specifies how the background of thumbnail items is painted.
Public Property | ItemBorderBrush | Gets or sets the Brush that specifies how the border of thumbnail items is painted.
Public Property | ItemBorderThickness | Gets or sets the thickness of the border of thumbnail items.
Public Property | ItemCaptionBackground | Gets or sets the Brush that specifies how the background of the Caption of thumbnail items is painted.
Public Property | ItemCaptionForeground | Gets or sets the Brush that specifies how the foreground of the Caption of thumbnail items is painted.
Public Property | ItemHeight | Gets or sets the height, in WPF device independent units, of each thumbnail item.
Public Property | ItemsMargin | Gets or sets the region within the control (in WPF device independent units) where thumbnail items are displayed.
Public Property | ItemsSource | Gets or sets a collection used to generate the content of the thumbnail control.
Public Property | ItemWidth | Gets or sets the width, in WPF device independent units, of each thumbnail item.
Public Property | ScrollDirection | Gets or sets the direction the thumbnail items will scroll in the control.
Public Property | ScrollToFirstItemCommand | Gets a command for scrolling to the first item in the thumbnail list.
Public Property | ScrollToLastItemCommand | Gets a command for scrolling to the last item in the thumbnail list.
Public Property | ScrollToNextBandCommand | Gets a command for scrolling to the next band of thumbnails in the thumbnail list.
Public Property | ScrollToNextPageCommand | Gets a command for scrolling to the next page of thumbnails in the thumbnail list.
Public Property | ScrollToPreviousBandCommand | Gets a command for scrolling to the previous band of thumbnails in the thumbnail list.
Public Property | ScrollToPreviousPageCommand | Gets a command for scrolling to the previous page of thumbnails in the thumbnail list.
Public Property | SelectedPageDisplay | Gets or sets the page display that contains the source image and marks of the selected thumbnail item.
Public Property | SelectFirstItemCommand | Gets a command for selecting the first item in the thumbnail list.
Public Property | SelectLastItemCommand | Gets a command for selecting the last item in the thumbnail list.
Public Property | SelectNextBandItemCommand | Gets a command for selecting the next band item in the thumbnail list.
Public Property | SelectNextItemCommand | Gets a command for selecting the next item in the thumbnail list.
Public Property | SelectPreviousBandItemCommand | Gets a command for selecting the previous band item in the thumbnail list.
Public Property | SelectPreviousItemCommand | Gets a command for selecting the previous item in the thumbnail list.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in WPF device independent units.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in WPF device independent units.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Windows.Controls Namespace


ARTPageCache Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ARTPageCache Property
Gets a cache for storing and retrieving ImGearARTPages associated with thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ARTPageCache As ImGearReadOnlyDictionary(Of ImGearThumbnailPage,ImGearARTPage)
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearReadOnlyDictionary(Of ImGearThumbnailPage,ImGearARTPage)

value = instance.ARTPageCache
public ImGearReadOnlyDictionary<ImGearThumbnailPage,ImGearARTPage> ARTPageCache {get;}
public: __property ImGearReadOnlyDictionary<ImGearThumbnailPage*,ImGearARTPage*>* get_ARTPageCache();
public:
property ImGearReadOnlyDictionary<ImGearThumbnailPage^,ImGearARTPage^>^ ARTPageCache {
   ImGearReadOnlyDictionary<ImGearThumbnailPage^,ImGearARTPage^>^ get();
}

Property Value

ImGearReadOnlyDictionary value.
Remarks

When a thumbnail item is first generated, a new ImGearARTPage is created for the thumbnail item and added to the ARTPageCache. The MarksLoading event fires for the thumbnail item and can be used to specify the ImGearARTPage that is associated with the thumbnail item. The ThumbnailList.LoadAllARTPages method can be used to fire the MarksLoading event for all thumbnail items that do not have an associated ImGearARTPage. If the ThumbnailList.SelectedPageDisplay property is bound to a PageView.Display and the marks are modified in the PageView.Display, the modified ImGearARTPage for the selected thumbnail item will be updated in the ARTPageCache.

This cache can be used to access the ImGearARTPages associated with thumbnail items. For example, when your application is closing, you can iterate through the ImGearARTPages and check the ImGearARTPage.MarksChanged property to determine if an ImGearARTPage should be saved.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


CacheItemContainers Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : CacheItemContainers Property
Gets or sets a value indicating whether item containers that are out of view are cached.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CacheItemContainers As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim value As Boolean

instance.CacheItemContainers = value

value = instance.CacheItemContainers
public bool CacheItemContainers {get; set;}
public: __property bool get_CacheItemContainers();
public: __property void set_CacheItemContainers(
   bool value
);
public:
property bool CacheItemContainers {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

In the default items panel this property is bound to the CacheItemContainers property of an ImGearVirtualizingWrapPanel and affects how item containers are used after being generated. When set to false, the generated thumbnail images are cached and the containers for generated items are destroyed when thumbnail items are scrolled out of view. When scrolled back into view, a thumbnail item's container is regenerated and the view element is set to the cached thumbnail page. This option uses less memory but there is a small delay when displaying cached thumbnails that are scrolled back into view. When set to true, the containers for generated items are not destroyed when thumbnail items are scrolled out of view, which uses more memory but thumbnails that have already been generated are displayed immediately when scrolled back into view.

The default value is true.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


DisplayMarks Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : DisplayMarks Property
Gets or sets a value indicating whether marks are displayed in thumbnails.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayMarks As Boolean
'Usage

Dim instance As ImGearThumbnailList
Dim value As Boolean

instance.DisplayMarks = value

value = instance.DisplayMarks
public bool DisplayMarks {get; set;}
public: __property bool get_DisplayMarks();
public: __property void set_DisplayMarks(
   bool value
);
public:
property bool DisplayMarks {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
When this property is set to false, marks are not visible in thumbnails. Previously cached marks are still displayed (if a display is bound to the ImGearThumbnailList SelectedPageDisplay property) as well as marks loaded using the MarksLoading event, and the thumbnail ART page cache is still updated when marks are modified.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBackground Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBackground Property
Gets or sets the Brush that specifies how the background of thumbnail items is painted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemBackground As Brush
'Usage

Dim instance As ImGearThumbnailList
Dim value As Brush

instance.ItemBackground = value

value = instance.ItemBackground
public Brush ItemBackground {get; set;}
public: __property Brush* get_ItemBackground();
public: __property void set_ItemBackground(
   Brush* value
);
public:
property Brush^ ItemBackground {
   Brush^ get();
   void set (    Brush^ value);
}

Property Value

System.Windows.Media.Brush value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBorderBrush Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBorderBrush Property
Gets or sets the Brush that specifies how the border of thumbnail items is painted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemBorderBrush As Brush
'Usage

Dim instance As ImGearThumbnailList
Dim value As Brush

instance.ItemBorderBrush = value

value = instance.ItemBorderBrush
public Brush ItemBorderBrush {get; set;}
public: __property Brush* get_ItemBorderBrush();
public: __property void set_ItemBorderBrush(
   Brush* value
);
public:
property Brush^ ItemBorderBrush {
   Brush^ get();
   void set (    Brush^ value);
}

Property Value

System.Windows.Media.Brush value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBorderThickness Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBorderThickness Property
Gets or sets the thickness of the border of thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemBorderThickness As Thickness
'Usage

Dim instance As ImGearThumbnailList
Dim value As Thickness

instance.ItemBorderThickness = value

value = instance.ItemBorderThickness
public Thickness ItemBorderThickness {get; set;}
public: __property Thickness get_ItemBorderThickness();
public: __property void set_ItemBorderThickness(
   Thickness value
);
public:
property Thickness ItemBorderThickness {
   Thickness get();
   void set (    Thickness value);
}

Property Value

System.Windows.Thickness value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemCaptionBackground Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemCaptionBackground Property
Gets or sets the Brush that specifies how the background of the Caption of thumbnail items is painted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemCaptionBackground As Brush
'Usage

Dim instance As ImGearThumbnailList
Dim value As Brush

instance.ItemCaptionBackground = value

value = instance.ItemCaptionBackground
public Brush ItemCaptionBackground {get; set;}
public: __property Brush* get_ItemCaptionBackground();
public: __property void set_ItemCaptionBackground(
   Brush* value
);
public:
property Brush^ ItemCaptionBackground {
   Brush^ get();
   void set (    Brush^ value);
}

Property Value

System.Windows.Media.Brush value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemCaptionForeground Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemCaptionForeground Property
Gets or sets the Brush that specifies how the foreground of the Caption of thumbnail items is painted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemCaptionForeground As Brush
'Usage

Dim instance As ImGearThumbnailList
Dim value As Brush

instance.ItemCaptionForeground = value

value = instance.ItemCaptionForeground
public Brush ItemCaptionForeground {get; set;}
public: __property Brush* get_ItemCaptionForeground();
public: __property void set_ItemCaptionForeground(
   Brush* value
);
public:
property Brush^ ItemCaptionForeground {
   Brush^ get();
   void set (    Brush^ value);
}

Property Value

System.Windows.Media.Brush value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemHeight Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemHeight Property
Gets or sets the height, in WPF device independent units, of each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemHeight As Double
'Usage

Dim instance As ImGearThumbnailList
Dim value As Double

instance.ItemHeight = value

value = instance.ItemHeight
public double ItemHeight {get; set;}
public: __property double get_ItemHeight();
public: __property void set_ItemHeight(
   double value
);
public:
property double ItemHeight {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 144.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemsMargin Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemsMargin Property
Gets or sets the region within the control (in WPF device independent units) where thumbnail items are displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemsMargin As Thickness
'Usage

Dim instance As ImGearThumbnailList
Dim value As Thickness

instance.ItemsMargin = value

value = instance.ItemsMargin
public Thickness ItemsMargin {get; set;}
public: __property Thickness get_ItemsMargin();
public: __property void set_ItemsMargin(
   Thickness value
);
public:
property Thickness ItemsMargin {
   Thickness get();
   void set (    Thickness value);
}

Property Value

Thickness value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemsSource Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemsSource Property
Gets or sets a collection used to generate the content of the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property ItemsSource As IEnumerable
'Usage

Dim instance As ImGearThumbnailList
Dim value As IEnumerable

instance.ItemsSource = value

value = instance.ItemsSource
public new IEnumerable ItemsSource {get; set;}
public: __property new IEnumerable* get_ItemsSource();
public: __property new void set_ItemsSource(
   IEnumerable* value
);
public:
new property IEnumerable^ ItemsSource {
   IEnumerable^ get();
   void set (    IEnumerable^ value);
}

Property Value

IEnumerable value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemWidth Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemWidth Property
Gets or sets the width, in WPF device independent units, of each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemWidth As Double
'Usage

Dim instance As ImGearThumbnailList
Dim value As Double

instance.ItemWidth = value

value = instance.ItemWidth
public double ItemWidth {get; set;}
public: __property double get_ItemWidth();
public: __property void set_ItemWidth(
   double value
);
public:
property double ItemWidth {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 128.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollDirection Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollDirection Property
Gets or sets the direction the thumbnail items will scroll in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScrollDirection As ImGearScrollDirection
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearScrollDirection

instance.ScrollDirection = value

value = instance.ScrollDirection
public ImGearScrollDirection ScrollDirection {get; set;}
public: __property ImGearScrollDirection get_ScrollDirection();
public: __property void set_ScrollDirection(
   ImGearScrollDirection value
);
public:
property ImGearScrollDirection ScrollDirection {
   ImGearScrollDirection get();
   void set (    ImGearScrollDirection value);
}

Property Value

ImGearScrollDirection value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToFirstItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToFirstItemCommand Property
Gets a command for scrolling to the first item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToFirstItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToFirstItemCommand
public ICommand ScrollToFirstItemCommand {get;}
public: __property ICommand* get_ScrollToFirstItemCommand();
public:
property ICommand^ ScrollToFirstItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToLastItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToLastItemCommand Property
Gets a command for scrolling to the last item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToLastItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToLastItemCommand
public ICommand ScrollToLastItemCommand {get;}
public: __property ICommand* get_ScrollToLastItemCommand();
public:
property ICommand^ ScrollToLastItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToNextBandCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToNextBandCommand Property
Gets a command for scrolling to the next band of thumbnails in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToNextBandCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToNextBandCommand
public ICommand ScrollToNextBandCommand {get;}
public: __property ICommand* get_ScrollToNextBandCommand();
public:
property ICommand^ ScrollToNextBandCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToNextPageCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToNextPageCommand Property
Gets a command for scrolling to the next page of thumbnails in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToNextPageCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToNextPageCommand
public ICommand ScrollToNextPageCommand {get;}
public: __property ICommand* get_ScrollToNextPageCommand();
public:
property ICommand^ ScrollToNextPageCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
A page of thumbnail items consists of all of the thumbnail items that fit in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToPreviousBandCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToPreviousBandCommand Property
Gets a command for scrolling to the previous band of thumbnails in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToPreviousBandCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToPreviousBandCommand
public ICommand ScrollToPreviousBandCommand {get;}
public: __property ICommand* get_ScrollToPreviousBandCommand();
public:
property ICommand^ ScrollToPreviousBandCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollToPreviousPageCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollToPreviousPageCommand Property
Gets a command for scrolling to the previous page of thumbnails in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollToPreviousPageCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.ScrollToPreviousPageCommand
public ICommand ScrollToPreviousPageCommand {get;}
public: __property ICommand* get_ScrollToPreviousPageCommand();
public:
property ICommand^ ScrollToPreviousPageCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
A page of thumbnail items consists of all of the thumbnail items that fit in the view.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectedPageDisplay Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectedPageDisplay Property
Gets or sets the page display that contains the source image and marks of the selected thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedPageDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearThumbnailList
Dim value As ImGearPresentationPageDisplay

instance.SelectedPageDisplay = value

value = instance.SelectedPageDisplay
public ImGearPresentationPageDisplay SelectedPageDisplay {get; set;}
public: __property ImGearPresentationPageDisplay* get_SelectedPageDisplay();
public: __property void set_SelectedPageDisplay(
   ImGearPresentationPageDisplay* value
);
public:
property ImGearPresentationPageDisplay^ SelectedPageDisplay {
   ImGearPresentationPageDisplay^ get();
   void set (    ImGearPresentationPageDisplay^ value);
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectFirstItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectFirstItemCommand Property
Gets a command for selecting the first item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectFirstItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectFirstItemCommand
public ICommand SelectFirstItemCommand {get;}
public: __property ICommand* get_SelectFirstItemCommand();
public:
property ICommand^ SelectFirstItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectLastItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectLastItemCommand Property
Gets a command for selecting the last item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectLastItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectLastItemCommand
public ICommand SelectLastItemCommand {get;}
public: __property ICommand* get_SelectLastItemCommand();
public:
property ICommand^ SelectLastItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectNextBandItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectNextBandItemCommand Property
Gets a command for selecting the next band item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectNextBandItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectNextBandItemCommand
public ICommand SelectNextBandItemCommand {get;}
public: __property ICommand* get_SelectNextBandItemCommand();
public:
property ICommand^ SelectNextBandItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks

If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.

This command will have no effect if there is no currently selected item, if the currently selected item is on the last band, or if the SelectionMode is None.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectNextItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectNextItemCommand Property
Gets a command for selecting the next item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectNextItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectNextItemCommand
public ICommand SelectNextItemCommand {get;}
public: __property ICommand* get_SelectNextItemCommand();
public:
property ICommand^ SelectNextItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
This command will have no effect if there is no currently selected item, if the currently selected item is the last item, or if the SelectionMode is None.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectPreviousBandItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectPreviousBandItemCommand Property
Gets a command for selecting the previous band item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectPreviousBandItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectPreviousBandItemCommand
public ICommand SelectPreviousBandItemCommand {get;}
public: __property ICommand* get_SelectPreviousBandItemCommand();
public:
property ICommand^ SelectPreviousBandItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks

If the ScrollDirection is Horizontal, a band of thumbnail items consists of the number of thumbnail items that fit in a column in the view. If the ScrollDirection is Vertical, a band of thumbnail items consists of the number of thumbnail items that fit in a row in the view.

This command will have no effect if there is no currently selected item, if the currently selected item is on the first band, or if the SelectionMode is None.

See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectPreviousItemCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectPreviousItemCommand Property
Gets a command for selecting the previous item in the thumbnail list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectPreviousItemCommand As ICommand
'Usage

Dim instance As ImGearThumbnailList
Dim value As ICommand

value = instance.SelectPreviousItemCommand
public ICommand SelectPreviousItemCommand {get;}
public: __property ICommand* get_SelectPreviousItemCommand();
public:
property ICommand^ SelectPreviousItemCommand {
   ICommand^ get();
}

Property Value

ICommand value.
Remarks
This command will have no effect if there is no currently selected item, if the currently selected item is the first item, or if the SelectionMode is None.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


XSpacing Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : XSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed on the control, in WPF device independent units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XSpacing As Double
'Usage

Dim instance As ImGearThumbnailList
Dim value As Double

instance.XSpacing = value

value = instance.XSpacing
public double XSpacing {get; set;}
public: __property double get_XSpacing();
public: __property void set_XSpacing(
   double value
);
public:
property double XSpacing {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 4.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


YSpacing Property (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : YSpacing Property
Gets or sets the amount of vertical space between thumbnails displayed on the control, in WPF device independent units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YSpacing As Double
'Usage

Dim instance As ImGearThumbnailList
Dim value As Double

instance.YSpacing = value

value = instance.YSpacing
public double YSpacing {get; set;}
public: __property double get_YSpacing();
public: __property void set_YSpacing(
   double value
);
public:
property double YSpacing {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 4.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%% $$Fields$$

ImGearThumbnailList Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CacheItemContainersProperty | Cache item containers dependency property.
static (Shared in Visual Basic) | DisplayMarksProperty | Represents DisplayMarks dependency property.
static (Shared in Visual Basic) | ItemBackgroundProperty | Represents ItemBackground dependency property.
static (Shared in Visual Basic) | ItemBorderBrushProperty | Represents ItemBorderBrush dependency property.
static (Shared in Visual Basic) | ItemBorderThicknessProperty | Represents ItemBorderThickness dependency property.
static (Shared in Visual Basic) | ItemCaptionBackgroundProperty | Represents ItemCaptionBackground dependency property.
static (Shared in Visual Basic) | ItemCaptionForegroundProperty | Represents ItemCaptionForeground dependency property.
static (Shared in Visual Basic) | ItemHeightProperty | Represents ItemHeight dependency property.
static (Shared in Visual Basic) | ItemsMarginProperty | Represents ItemsMargin dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Represents ItemWidth dependency property.
static (Shared in Visual Basic) | ScrollDirectionProperty | Represents ScrollDirection dependency property.
static (Shared in Visual Basic) | SelectedPageDisplayProperty | Represents SelectedPageDisplay dependency property.
static (Shared in Visual Basic) | XSpacingProperty | Represents XSpacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Represents YSpacing dependency property.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Windows.Controls Namespace


CacheItemContainersProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : CacheItemContainersProperty Field
Cache item containers dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CacheItemContainersProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.CacheItemContainersProperty
public static readonly DependencyProperty CacheItemContainersProperty
public: static readonly DependencyProperty* CacheItemContainersProperty
public:
static readonly DependencyProperty^ CacheItemContainersProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


DisplayMarksProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : DisplayMarksProperty Field
Represents DisplayMarks dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DisplayMarksProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.DisplayMarksProperty
public static readonly DependencyProperty DisplayMarksProperty
public: static readonly DependencyProperty* DisplayMarksProperty
public:
static readonly DependencyProperty^ DisplayMarksProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBackgroundProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBackgroundProperty Field
Represents ItemBackground dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemBackgroundProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemBackgroundProperty
public static readonly DependencyProperty ItemBackgroundProperty
public: static readonly DependencyProperty* ItemBackgroundProperty
public:
static readonly DependencyProperty^ ItemBackgroundProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBorderBrushProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBorderBrushProperty Field
Represents ItemBorderBrush dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemBorderBrushProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemBorderBrushProperty
public static readonly DependencyProperty ItemBorderBrushProperty
public: static readonly DependencyProperty* ItemBorderBrushProperty
public:
static readonly DependencyProperty^ ItemBorderBrushProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemBorderThicknessProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemBorderThicknessProperty Field
Represents ItemBorderThickness dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemBorderThicknessProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemBorderThicknessProperty
public static readonly DependencyProperty ItemBorderThicknessProperty
public: static readonly DependencyProperty* ItemBorderThicknessProperty
public:
static readonly DependencyProperty^ ItemBorderThicknessProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemCaptionBackgroundProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemCaptionBackgroundProperty Field
Represents ItemCaptionBackground dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemCaptionBackgroundProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemCaptionBackgroundProperty
public static readonly DependencyProperty ItemCaptionBackgroundProperty
public: static readonly DependencyProperty* ItemCaptionBackgroundProperty
public:
static readonly DependencyProperty^ ItemCaptionBackgroundProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemCaptionForegroundProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemCaptionForegroundProperty Field
Represents ItemCaptionForeground dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemCaptionForegroundProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemCaptionForegroundProperty
public static readonly DependencyProperty ItemCaptionForegroundProperty
public: static readonly DependencyProperty* ItemCaptionForegroundProperty
public:
static readonly DependencyProperty^ ItemCaptionForegroundProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemHeightProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemHeightProperty Field
Represents ItemHeight dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemHeightProperty
public static readonly DependencyProperty ItemHeightProperty
public: static readonly DependencyProperty* ItemHeightProperty
public:
static readonly DependencyProperty^ ItemHeightProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemsMarginProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemsMarginProperty Field
Represents ItemsMargin dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemsMarginProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemsMarginProperty
public static readonly DependencyProperty ItemsMarginProperty
public: static readonly DependencyProperty* ItemsMarginProperty
public:
static readonly DependencyProperty^ ItemsMarginProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ItemWidthProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ItemWidthProperty Field
Represents ItemWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ItemWidthProperty
public static readonly DependencyProperty ItemWidthProperty
public: static readonly DependencyProperty* ItemWidthProperty
public:
static readonly DependencyProperty^ ItemWidthProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


ScrollDirectionProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : ScrollDirectionProperty Field
Represents ScrollDirection dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ScrollDirectionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.ScrollDirectionProperty
public static readonly DependencyProperty ScrollDirectionProperty
public: static readonly DependencyProperty* ScrollDirectionProperty
public:
static readonly DependencyProperty^ ScrollDirectionProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


SelectedPageDisplayProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : SelectedPageDisplayProperty Field
Represents SelectedPageDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectedPageDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.SelectedPageDisplayProperty
public static readonly DependencyProperty SelectedPageDisplayProperty
public: static readonly DependencyProperty* SelectedPageDisplayProperty
public:
static readonly DependencyProperty^ SelectedPageDisplayProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


XSpacingProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : XSpacingProperty Field
Represents XSpacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly XSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.XSpacingProperty
public static readonly DependencyProperty XSpacingProperty
public: static readonly DependencyProperty* XSpacingProperty
public:
static readonly DependencyProperty^ XSpacingProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


YSpacingProperty Field (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : YSpacingProperty Field
Represents YSpacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly YSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailList.YSpacingProperty
public static readonly DependencyProperty YSpacingProperty
public: static readonly DependencyProperty* YSpacingProperty
public:
static readonly DependencyProperty^ YSpacingProperty
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%% $$Events$$

ImGearThumbnailList Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailList Class

For a list of all members of this type, see ImGearThumbnailList members.

Public Events
 | Name | Description
Public Event | MarksLoading | This event is called when a thumbnail item is first generated and can be used to load the marks for the thumbnail item.
Public Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Top
See Also

Reference

ImGearThumbnailList Class
ImageGear.Windows.Controls Namespace


MarksLoading Event

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : MarksLoading Event
This event is called when a thumbnail item is first generated and can be used to load the marks for the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarksLoading As ImGearMarksLoadingEventHandler
'Usage

Dim instance As ImGearThumbnailList
Dim handler As ImGearMarksLoadingEventHandler

AddHandler instance.MarksLoading, handler
public event ImGearMarksLoadingEventHandler MarksLoading
public: __event ImGearMarksLoadingEventHandler* MarksLoading
public:
event ImGearMarksLoadingEventHandler^ MarksLoading
Event Data

The event handler receives an argument of type ImGearMarksLoadingEventArgs containing data related to this event. The following ImGearMarksLoadingEventArgs properties provide information specific to this event.

Property | Description
ARTPage | Gets or sets the ARTPage that will be displayed in the thumbnail item.
Item | Gets the ImGearThumbnailPage in which the marks are loading.
Remarks
The LoadAllARTPages method can be used to fire the MarksLoading event for each thumbnail item that does not have an associated ImGearARTPage in the ThumbnailList.ARTPageCache.
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


RequerySuggested Event (ImGearThumbnailList)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailList Class : RequerySuggested Event
Occurs when the command manager detects conditions that might change the ability of a command to execute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event RequerySuggested As EventHandler
'Usage

Dim instance As ImGearThumbnailList
Dim handler As EventHandler

AddHandler instance.RequerySuggested, handler
public event EventHandler RequerySuggested
public: __event EventHandler* RequerySuggested
public:
event EventHandler^ RequerySuggested
See Also

Reference

ImGearThumbnailList Class
ImGearThumbnailList Members


%%PageItemTitle%%

ImGearThumbnailListItem Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class
This class represents a thumbnail item.
Object Model
ImGearThumbnailListItem ClassImGearPresentationPageDisplay Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailListItem
   Inherits System.Windows.Controls.ListBoxItem
'Usage

Dim instance As ImGearThumbnailListItem
public class ImGearThumbnailListItem : System.Windows.Controls.ListBoxItem
public __gc class ImGearThumbnailListItem : public System.Windows.Controls.ListBoxItem
public ref class ImGearThumbnailListItem : public System.Windows.Controls.ListBoxItem
Remarks
Thumbnail items do not load until they are initially displayed. When thumbnail items are initially displayed, the ImGearThumbnailList control asynchronously loads and resizes the images using a System.ComponentModel.BackgroundWorker. The thumbnail image and marks are stored in a memory cache so they can be quickly displayed again if scrolled out of view and back into view.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.ListBoxItem
ImageGear.Windows.Controls.ImGearThumbnailListItem

See Also

Reference

ImGearThumbnailListItem Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailListItem Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class

The following tables list the members exposed by ImGearThumbnailListItem.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailListItem Constructor | Initializes a new instance of the ImGearThumbnailListItem class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CaptionProperty | Represents Caption dependency property.
static (Shared in Visual Basic) | PageCountProperty | Represents PageCount dependency property.
static (Shared in Visual Basic) | PageDisplayProperty | Represents PageDisplay dependency property.
static (Shared in Visual Basic) | PageNumberProperty | Represents PageNumber dependency property.
Top
Public Properties
 | Name | Description
Public Property | Caption | Gets the caption that is displayed in the thumbnail item.
Public Property | PageCount | Gets the page count of the file that this page is from.
Public Property | PageDisplay | Gets the page display that contains the thumbnail image and marks that are displayed in the thumbnail item.
Public Property | PageNumber | Gets the page number of the thumbnail item.
Top
See Also

Reference

ImGearThumbnailListItem Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearThumbnailListItem Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : ImGearThumbnailListItem Constructor
Initializes a new instance of the ImGearThumbnailListItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailListItem()
public ImGearThumbnailListItem()
public: ImGearThumbnailListItem();
public:
ImGearThumbnailListItem();
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailListItem Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class

For a list of all members of this type, see ImGearThumbnailListItem members.

Public Properties
 | Name | Description
Public Property | Caption | Gets the caption that is displayed in the thumbnail item.
Public Property | PageCount | Gets the page count of the file that this page is from.
Public Property | PageDisplay | Gets the page display that contains the thumbnail image and marks that are displayed in the thumbnail item.
Public Property | PageNumber | Gets the page number of the thumbnail item.
Top
See Also

Reference

ImGearThumbnailListItem Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearThumbnailListItem Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class

For a list of all members of this type, see ImGearThumbnailListItem members.

See Also

Reference

ImGearThumbnailListItem Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearThumbnailListItem Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class

For a list of all members of this type, see ImGearThumbnailListItem members.

See Also

Reference

ImGearThumbnailListItem Class
ImageGear.Windows.Controls Namespace


Caption Property (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : Caption Property
Gets the caption that is displayed in the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Caption As String
'Usage

Dim instance As ImGearThumbnailListItem
Dim value As String

value = instance.Caption
public string Caption {get;}
public: __property string* get_Caption();
public:
property String^ Caption {
   String^ get();
}

Property Value

String value.
Remarks
The font of the caption can be set through the font properties of the ThumbnailList class.
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageCount Property (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageCount Property
Gets the page count of the file that this page is from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ImGearThumbnailListItem
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

Integer value.
Remarks
Returns 1 if the page was not loaded from a multi-page file.
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageDisplay Property (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageDisplay Property
Gets the page display that contains the thumbnail image and marks that are displayed in the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearThumbnailListItem
Dim value As ImGearPresentationPageDisplay

value = instance.PageDisplay
public ImGearPresentationPageDisplay PageDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_PageDisplay();
public:
property ImGearPresentationPageDisplay^ PageDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
Remarks
The image is resized to fit in the item but the marks are the same as the source marks.
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageNumber Property (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageNumber Property
Gets the page number of the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailListItem
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


%%PageItemTitle%% $$Fields$$

ImGearThumbnailListItem Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailListItem Class

For a list of all members of this type, see ImGearThumbnailListItem members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CaptionProperty | Represents Caption dependency property.
static (Shared in Visual Basic) | PageCountProperty | Represents PageCount dependency property.
static (Shared in Visual Basic) | PageDisplayProperty | Represents PageDisplay dependency property.
static (Shared in Visual Basic) | PageNumberProperty | Represents PageNumber dependency property.
Top
See Also

Reference

ImGearThumbnailListItem Class
ImageGear.Windows.Controls Namespace


CaptionProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : CaptionProperty Field
Represents Caption dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CaptionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailListItem.CaptionProperty
public static readonly DependencyProperty CaptionProperty
public: static readonly DependencyProperty* CaptionProperty
public:
static readonly DependencyProperty^ CaptionProperty
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageCountProperty Field (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageCountProperty Field
Represents PageCount dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageCountProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailListItem.PageCountProperty
public static readonly DependencyProperty PageCountProperty
public: static readonly DependencyProperty* PageCountProperty
public:
static readonly DependencyProperty^ PageCountProperty
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageDisplayProperty Field (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageDisplayProperty Field
Represents PageDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailListItem.PageDisplayProperty
public static readonly DependencyProperty PageDisplayProperty
public: static readonly DependencyProperty* PageDisplayProperty
public:
static readonly DependencyProperty^ PageDisplayProperty
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


PageNumberProperty Field (ImGearThumbnailListItem)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailListItem Class : PageNumberProperty Field
Represents PageNumber dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageNumberProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailListItem.PageNumberProperty
public static readonly DependencyProperty PageNumberProperty
public: static readonly DependencyProperty* PageNumberProperty
public:
static readonly DependencyProperty^ PageNumberProperty
See Also

Reference

ImGearThumbnailListItem Class
ImGearThumbnailListItem Members


%%PageItemTitle%%

ImGearThumbnailMultiPageAdapter Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailMultiPageAdapter Class
This class can be used to convert a collection of filename strings, Streams, or ImGearDocuments to a collection of ImGearThumbnailPages.
Object Model
ImGearThumbnailMultiPageAdapter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailMultiPageAdapter
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearThumbnailMultiPageAdapter
public class ImGearThumbnailMultiPageAdapter : System.Windows.DependencyObject
public __gc class ImGearThumbnailMultiPageAdapter : public System.Windows.DependencyObject
public ref class ImGearThumbnailMultiPageAdapter : public System.Windows.DependencyObject
Remarks
It is only necessary to use this class when displaying all of the pages of multi-page files. The ItemsSource property of the ImGearThumbnailList control can be bound directly to a collection of documents to load only the first page of each document.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearThumbnailMultiPageAdapter

See Also

Reference

ImGearThumbnailMultiPageAdapter Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailMultiPageAdapter Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailMultiPageAdapter Class

The following tables list the members exposed by ImGearThumbnailMultiPageAdapter.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailMultiPageAdapter Constructor |
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ItemsSourceProperty | Represents ItemsSource dependency property.
Top
Public Properties
 | Name | Description
Public Property | ItemsSource | Gets or sets a collection used to generate the content of the ImGearThumbnailPageAdapater.
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Top
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearThumbnailMultiPageAdapter Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailMultiPageAdapter Class : ImGearThumbnailMultiPageAdapter Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailMultiPageAdapter()
public ImGearThumbnailMultiPageAdapter()
public: ImGearThumbnailMultiPageAdapter();
public:
ImGearThumbnailMultiPageAdapter();
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImGearThumbnailMultiPageAdapter Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailMultiPageAdapter Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailMultiPageAdapter Class

For a list of all members of this type, see ImGearThumbnailMultiPageAdapter members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Top
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImageGear.Windows.Controls Namespace


GetEnumerator Method (ImGearThumbnailMultiPageAdapter)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailMultiPageAdapter Class : GetEnumerator Method
Returns an enumerator that iterates through the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator(Of ImGearThumbnailPage)
'Usage

Dim instance As ImGearThumbnailMultiPageAdapter
Dim value As IEnumerator(Of ImGearThumbnailPage)

value = instance.GetEnumerator()
public IEnumerator<ImGearThumbnailPage> GetEnumerator()
public: IEnumerator<ImGearThumbnailPage*>* GetEnumerator();
public:
IEnumerator<ImGearThumbnailPage^>^ GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImGearThumbnailMultiPageAdapter Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailMultiPageAdapter Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailMultiPageAdapter Class

For a list of all members of this type, see ImGearThumbnailMultiPageAdapter members.

Public Properties
 | Name | Description
Public Property | ItemsSource | Gets or sets a collection used to generate the content of the ImGearThumbnailPageAdapater.
Top
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImageGear.Windows.Controls Namespace


ItemsSource Property (ImGearThumbnailMultiPageAdapter)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailMultiPageAdapter Class : ItemsSource Property
Gets or sets a collection used to generate the content of the ImGearThumbnailPageAdapater.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemsSource As IEnumerable
'Usage

Dim instance As ImGearThumbnailMultiPageAdapter
Dim value As IEnumerable

instance.ItemsSource = value

value = instance.ItemsSource
public IEnumerable ItemsSource {get; set;}
public: __property IEnumerable* get_ItemsSource();
public: __property void set_ItemsSource(
   IEnumerable* value
);
public:
property IEnumerable^ ItemsSource {
   IEnumerable^ get();
   void set (    IEnumerable^ value);
}

Property Value

IEnumerable value.
Remarks
A list of filename strings, Streams, or ImGearDocuments can be bound to this property. The ItemsSource property of a ImGearThumbnailList control can then be bound to the ImGearThumbnailMultiPageAdapter.
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImGearThumbnailMultiPageAdapter Members


%%PageItemTitle%% $$Fields$$

ImGearThumbnailMultiPageAdapter Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailMultiPageAdapter Class

For a list of all members of this type, see ImGearThumbnailMultiPageAdapter members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ItemsSourceProperty | Represents ItemsSource dependency property.
Top
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImageGear.Windows.Controls Namespace


ItemsSourceProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailMultiPageAdapter Class : ItemsSourceProperty Field
Represents ItemsSource dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailMultiPageAdapter.ItemsSourceProperty
public static readonly DependencyProperty ItemsSourceProperty
public: static readonly DependencyProperty* ItemsSourceProperty
public:
static readonly DependencyProperty^ ItemsSourceProperty
See Also

Reference

ImGearThumbnailMultiPageAdapter Class
ImGearThumbnailMultiPageAdapter Members


%%PageItemTitle%%

ImGearThumbnailPage Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPage Class
This class represents a thumbnail page.
Object Model
ImGearThumbnailPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailPage
'Usage

Dim instance As ImGearThumbnailPage
public class ImGearThumbnailPage
public __gc class ImGearThumbnailPage
public ref class ImGearThumbnailPage
Remarks

This class can be used to specify pages other than the first page of a multi-page document to load into the ImGearThumbnailList control.

The ImGearThumbnailPage class is immutable and cannot be used in XAML. The ImGearThumbnailPageExtension class provides read/write properties and can be used in XAML.

Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearThumbnailPage

See Also

Reference

ImGearThumbnailPage Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailPage Class Members
Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPage Class

The following tables list the members exposed by ImGearThumbnailPage.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailPage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Caption | Gets the caption that is displayed in the thumbnail item.
Public Property | PageNumber | Gets the page number.
Public Property | Source | Gets the source of the image document.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current ImGearThumbnailPage.
Public Method | GetHashCode | Serves as a hash function.
Top
Public Operators
public Operator Equality | Returns true if its two operands are equal.
public Operator Inequality | Returns true if its two operands are not equal.
Top
See Also

Reference

ImGearThumbnailPage Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearThumbnailPage Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : ImGearThumbnailPage Constructor
Overload List
Overload | Description
ImGearThumbnailPage Constructor(Object) | Initializes a new instance of the ImGearThumbnailPage class for the first page of the specified file.
ImGearThumbnailPage Constructor(Object,Int32) | Initializes a new instance of the ImGearThumbnailPage class for the specified page of the specified file.
ImGearThumbnailPage Constructor(Object,String) | Initializes a new instance of the ImGearThumbnailPage class for the first page of the specified file.
ImGearThumbnailPage Constructor(Object,Int32,String) | Initializes a new instance of the ImGearThumbnailPage class for the specified page of the specified file.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


%%PageItemTitle%%

ImGearThumbnailPage Constructor(Object)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > ImGearThumbnailPage Constructor : ImGearThumbnailPage Constructor(Object)
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
Initializes a new instance of the ImGearThumbnailPage class for the first page of the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As Object _
)
'Usage

Dim source As Object

Dim instance As New ImGearThumbnailPage(source)
public ImGearThumbnailPage(
   object source
)
public: ImGearThumbnailPage(
   Object* source
)
public:
ImGearThumbnailPage(
   Object^ source
)

Parameters

source
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


%%PageItemTitle%%

ImGearThumbnailPage Constructor(Object,Int32)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > ImGearThumbnailPage Constructor : ImGearThumbnailPage Constructor(Object,Int32)
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
The page number.
Initializes a new instance of the ImGearThumbnailPage class for the specified page of the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As Object, _
   ByVal pageNumber As Integer _
)
'Usage

Dim source As Object
Dim pageNumber As Integer

Dim instance As New ImGearThumbnailPage(source, pageNumber)
public ImGearThumbnailPage(
   object source,
   int pageNumber
)
public: ImGearThumbnailPage(
   Object* source,
   int pageNumber
)
public:
ImGearThumbnailPage(
   Object^ source,
   int pageNumber
)

Parameters

source
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
pageNumber
The page number.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


%%PageItemTitle%%

ImGearThumbnailPage Constructor(Object,String)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > ImGearThumbnailPage Constructor : ImGearThumbnailPage Constructor(Object,String)
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
The caption for the ImGearThumbnailPage.
Initializes a new instance of the ImGearThumbnailPage class for the first page of the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As Object, _
   ByVal caption As String _
)
'Usage

Dim source As Object
Dim caption As String

Dim instance As New ImGearThumbnailPage(source, caption)
public ImGearThumbnailPage(
   object source,
   string caption
)
public: ImGearThumbnailPage(
   Object* source,
   string* caption
)
public:
ImGearThumbnailPage(
   Object^ source,
   String^ caption
)

Parameters

source
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
caption
The caption for the ImGearThumbnailPage.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


%%PageItemTitle%%

ImGearThumbnailPage Constructor(Object,Int32,String)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > ImGearThumbnailPage Constructor : ImGearThumbnailPage Constructor(Object,Int32,String)
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
The page number.
The caption for the ImGearThumbnailPage.
Initializes a new instance of the ImGearThumbnailPage class for the specified page of the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As Object, _
   ByVal pageNumber As Integer, _
   ByVal caption As String _
)
'Usage

Dim source As Object
Dim pageNumber As Integer
Dim caption As String

Dim instance As New ImGearThumbnailPage(source, pageNumber, caption)
public ImGearThumbnailPage(
   object source,
   int pageNumber,
   string caption
)
public: ImGearThumbnailPage(
   Object* source,
   int pageNumber,
   string* caption
)
public:
ImGearThumbnailPage(
   Object^ source,
   int pageNumber,
   String^ caption
)

Parameters

source
The source object for the ImGearThumbnailPage (a filename string, a Stream, an ImGearPage, or an ImGearDocument).
pageNumber
The page number.
caption
The caption for the ImGearThumbnailPage.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearThumbnailPage Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPage Class

For a list of all members of this type, see ImGearThumbnailPage members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current ImGearThumbnailPage.
Public Method | GetHashCode | Serves as a hash function.
Top
See Also

Reference

ImGearThumbnailPage Class
ImageGear.Windows.Controls Namespace


Equals Method (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : Equals Method
Determines whether the specified object is equal to the current ImGearThumbnailPage.
Overload List
Overload | Description
Equals(Object) | Determines whether the specified object is equal to the current ImGearThumbnailPage.
Equals(ImGearThumbnailPage) | Determines whether the specified ImGearThumbnailPage is equal to the current ThumbnailPage.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


Equals(Object) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > Equals Method : Equals(Object) Method
The object to compare with the current ImGearThumbnailPage.
Determines whether the specified object is equal to the current ImGearThumbnailPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As ImGearThumbnailPage
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The object to compare with the current ImGearThumbnailPage.

Return Value

true if the specified object is equal to the current ImGearThumbnailPage; otherwise, false.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


Equals(ImGearThumbnailPage) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class > Equals Method : Equals(ImGearThumbnailPage) Method
The ImGearThumbnailPage to compare with the current ThumbnailPage.
Determines whether the specified ImGearThumbnailPage is equal to the current ThumbnailPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Equals( _
   ByVal other As ImGearThumbnailPage _
) As Boolean
'Usage

Dim instance As ImGearThumbnailPage
Dim other As ImGearThumbnailPage
Dim value As Boolean

value = instance.Equals(other)
public bool Equals(
   ImGearThumbnailPage other
)
public: bool Equals(
   ImGearThumbnailPage* other
)
public:
bool Equals(
   ImGearThumbnailPage^ other
)

Parameters

other
The ImGearThumbnailPage to compare with the current ThumbnailPage.

Return Value

true if the specified ImGearThumbnailPage is equal to the current ThumbnailPage; otherwise, false.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members
Overload List


GetHashCode Method (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : GetHashCode Method
Serves as a hash function.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As ImGearThumbnailPage
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

A hash code for the ImGearThumbnailPage.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailPage Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPage Class

For a list of all members of this type, see ImGearThumbnailPage members.

Public Properties
 | Name | Description
Public Property | Caption | Gets the caption that is displayed in the thumbnail item.
Public Property | PageNumber | Gets the page number.
Public Property | Source | Gets the source of the image document.
Top
See Also

Reference

ImGearThumbnailPage Class
ImageGear.Windows.Controls Namespace


Caption Property (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : Caption Property
Gets the caption that is displayed in the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Caption As String
'Usage

Dim instance As ImGearThumbnailPage
Dim value As String

value = instance.Caption
public string Caption {get;}
public: __property string* get_Caption();
public:
property String^ Caption {
   String^ get();
}

Property Value

String value.
Remarks
The font of the caption can be set through the font properties of the ThumbnailList class.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


PageNumber Property (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : PageNumber Property
Gets the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailPage
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


Source Property (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : Source Property
Gets the source of the image document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Source As Object
'Usage

Dim instance As ImGearThumbnailPage
Dim value As Object

value = instance.Source
public object Source {get;}
public: __property Object* get_Source();
public:
property Object^ Source {
   Object^ get();
}

Property Value

Object value.
Remarks
The source of the image document is a filename string, a Stream, an ImGearPage, or an ImGearDocument.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


Equality Operator (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : Equality Operator
First object to compare.
Second object to compare.
Returns true if its two operands are equal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator =( _
   ByVal thumbnailPage1 As ImGearThumbnailPage, _
   ByVal thumbnailPage2 As ImGearThumbnailPage _
) As Boolean
'Usage

public bool operator ==(
   ImGearThumbnailPage thumbnailPage1,
   ImGearThumbnailPage thumbnailPage2
)
public: bool op_Equality(
   ImGearThumbnailPage* thumbnailPage1,
   ImGearThumbnailPage* thumbnailPage2
)
public:
bool operator ==(
   ImGearThumbnailPage^ thumbnailPage1,
   ImGearThumbnailPage^ thumbnailPage2
)

Parameters

thumbnailPage1
First object to compare.
thumbnailPage2
Second object to compare.

Return Value

True if objects are equal.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


Inequality Operator (ImGearThumbnailPage)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPage Class : Inequality Operator
First object to compare.
Second object to compare.
Returns true if its two operands are not equal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Operator <>( _
   ByVal thumbnailPage1 As ImGearThumbnailPage, _
   ByVal thumbnailPage2 As ImGearThumbnailPage _
) As Boolean
'Usage

public bool operator !=(
   ImGearThumbnailPage thumbnailPage1,
   ImGearThumbnailPage thumbnailPage2
)
public: bool op_Inequality(
   ImGearThumbnailPage* thumbnailPage1,
   ImGearThumbnailPage* thumbnailPage2
)
public:
bool operator !=(
   ImGearThumbnailPage^ thumbnailPage1,
   ImGearThumbnailPage^ thumbnailPage2
)

Parameters

thumbnailPage1
First object to compare.
thumbnailPage2
Second object to compare.

Return Value

True if objects are not equal.
See Also

Reference

ImGearThumbnailPage Class
ImGearThumbnailPage Members


%%PageItemTitle%%

ImGearThumbnailPageExtension Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPageExtension Class
This class represents a markup extension for the ImGearThumbnailPage class.
Object Model
ImGearThumbnailPageExtension Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailPageExtension
   Inherits System.Windows.Markup.MarkupExtension
'Usage

Dim instance As ImGearThumbnailPageExtension
public class ImGearThumbnailPageExtension : System.Windows.Markup.MarkupExtension
public __gc class ImGearThumbnailPageExtension : public System.Windows.Markup.MarkupExtension
public ref class ImGearThumbnailPageExtension : public System.Windows.Markup.MarkupExtension
Remarks
This class can be used to specify pages other than the first page of a multi-page document to load into the ImGearThumbnailList control. The ImGearThumbnailPage class is immutable and cannot be used in XAML. This class provides read/write properties and can be used in XAML.
Inheritance Hierarchy

System.Object
System.Windows.Markup.MarkupExtension
ImageGear.Windows.Controls.ImGearThumbnailPageExtension

See Also

Reference

ImGearThumbnailPageExtension Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailPageExtension Class Members
Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPageExtension Class

The following tables list the members exposed by ImGearThumbnailPageExtension.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailPageExtension Constructor | Initializes a new instance of the ImGearThumbnailPageExtension class.
Top
Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption that is displayed in the thumbnail item.
Public Property | PageNumber | Gets or sets the page number.
Public Property | Source | Gets or sets the source of the image document.
Top
Public Methods
 | Name | Description
Public Method | ProvideValue | Overridden. Returns a thumbnail page object that can be added to the ThumbnailList control.
Top
See Also

Reference

ImGearThumbnailPageExtension Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearThumbnailPageExtension Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPageExtension Class : ImGearThumbnailPageExtension Constructor
Initializes a new instance of the ImGearThumbnailPageExtension class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailPageExtension()
public ImGearThumbnailPageExtension()
public: ImGearThumbnailPageExtension();
public:
ImGearThumbnailPageExtension();
See Also

Reference

ImGearThumbnailPageExtension Class
ImGearThumbnailPageExtension Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailPageExtension Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPageExtension Class

For a list of all members of this type, see ImGearThumbnailPageExtension members.

Public Methods
 | Name | Description
Public Method | ProvideValue | Overridden. Returns a thumbnail page object that can be added to the ThumbnailList control.
Top
See Also

Reference

ImGearThumbnailPageExtension Class
ImageGear.Windows.Controls Namespace


ProvideValue Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPageExtension Class : ProvideValue Method
A service provider helper that can provide services for the markup extension.
Returns a thumbnail page object that can be added to the ThumbnailList control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ProvideValue( _
   ByVal serviceProvider As IServiceProvider _
) As Object
'Usage

Dim instance As ImGearThumbnailPageExtension
Dim serviceProvider As IServiceProvider
Dim value As Object

value = instance.ProvideValue(serviceProvider)
public override object ProvideValue(
   IServiceProvider serviceProvider
)
public: Object* ProvideValue(
   IServiceProvider* serviceProvider
) override
public:
Object^ ProvideValue(
   IServiceProvider^ serviceProvider
) override

Parameters

serviceProvider
A service provider helper that can provide services for the markup extension.

Return Value

A thumbnail page object that can be added to the ThumbnailList control.
See Also

Reference

ImGearThumbnailPageExtension Class
ImGearThumbnailPageExtension Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailPageExtension Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearThumbnailPageExtension Class

For a list of all members of this type, see ImGearThumbnailPageExtension members.

Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption that is displayed in the thumbnail item.
Public Property | PageNumber | Gets or sets the page number.
Public Property | Source | Gets or sets the source of the image document.
Top
See Also

Reference

ImGearThumbnailPageExtension Class
ImageGear.Windows.Controls Namespace


Caption Property (ImGearThumbnailPageExtension)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPageExtension Class : Caption Property
Gets or sets the caption that is displayed in the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Caption As String
'Usage

Dim instance As ImGearThumbnailPageExtension
Dim value As String

instance.Caption = value

value = instance.Caption
public string Caption {get; set;}
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
public:
property String^ Caption {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
Remarks
The font of the caption can be set through the font properties of the ThumbnailList class.
See Also

Reference

ImGearThumbnailPageExtension Class
ImGearThumbnailPageExtension Members


PageNumber Property (ImGearThumbnailPageExtension)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPageExtension Class : PageNumber Property
Gets or sets the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailPageExtension
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailPageExtension Class
ImGearThumbnailPageExtension Members


Source Property (ImGearThumbnailPageExtension)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearThumbnailPageExtension Class : Source Property
Gets or sets the source of the image document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Source As Object
'Usage

Dim instance As ImGearThumbnailPageExtension
Dim value As Object

instance.Source = value

value = instance.Source
public object Source {get; set;}
public: __property Object* get_Source();
public: __property void set_Source(
   Object* value
);
public:
property Object^ Source {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property should be set to a filename string, a Stream, an ImGearPage, or an ImGearDocument.
See Also

Reference

ImGearThumbnailPageExtension Class
ImGearThumbnailPageExtension Members


%%PageItemTitle%%

ImGearVirtualizingWrapPanel Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class
Virtualizing wrap panel class.
Object Model
ImGearVirtualizingWrapPanel Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearVirtualizingWrapPanel
   Inherits System.Windows.Controls.VirtualizingPanel
'Usage

Dim instance As ImGearVirtualizingWrapPanel
public class ImGearVirtualizingWrapPanel : System.Windows.Controls.VirtualizingPanel
public __gc class ImGearVirtualizingWrapPanel : public System.Windows.Controls.VirtualizingPanel
public ref class ImGearVirtualizingWrapPanel : public System.Windows.Controls.VirtualizingPanel
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.VirtualizingPanel
ImageGear.Windows.Controls.ImGearVirtualizingWrapPanel

See Also

Reference

ImGearVirtualizingWrapPanel Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearVirtualizingWrapPanel Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class

The following tables list the members exposed by ImGearVirtualizingWrapPanel.

Public Constructors
 | Name | Description
Public Constructor | ImGearVirtualizingWrapPanel Constructor | Initializes a new instance of the ImGearVirtualizingWrapPanel class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CacheItemContainersProperty | Cache item containers dependency property.
static (Shared in Visual Basic) | ChildHeightProperty | Child height dependency property.
static (Shared in Visual Basic) | ChildWidthProperty | Child width dependency property.
static (Shared in Visual Basic) | ScrollDirectionProperty | Scroll direction dependency property.
static (Shared in Visual Basic) | XSpacingProperty | X spacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Y spacing dependency property.
Top
Public Properties
 | Name | Description
Public Property | CacheItemContainers | Gets or sets a value indicating whether item containers that are out of view are cached.
Public Property | CanHorizontallyScroll | Gets or sets a value indicating whether the control can be scrolled horizontally.
Public Property | CanVerticallyScroll | Gets or sets a value indicating whether the control can be scrolled vertically.
Public Property | ChildHeight | Gets or sets the child height.
Public Property | ChildWidth | Gets or sets the child width.
Public Property | ExtentHeight | Gets the extent height.
Public Property | ExtentWidth | Gets the extent width.
Public Property | HorizontalOffset | Gets the horizontal offset.
Public Property | ScrollDirection | Gets or sets the scroll direction.
Public Property | ScrollOwner | Gets or sets the scroll owner.
Public Property | VerticalOffset | Gets the vertical offset.
Public Property | ViewportHeight | Gets the viewport height.
Public Property | ViewportWidth | Gets the viewport width.
Public Property | XSpacing | Gets or sets the X spacing.
Public Property | YSpacing | Gets or sets the Y spacing.
Top
Public Methods
 | Name | Description
Public Method | LineDown | Moves down a line.
Public Method | LineLeft | Moves left a line.
Public Method | LineRight | Moves right a line.
Public Method | LineUp | Moves up a line.
Public Method | MakeVisible | Makes the specified rectangle visible.
Public Method | MouseWheelDown | Mouse wheel down.
Public Method | MouseWheelLeft | Mouse wheel left.
Public Method | MouseWheelRight | Mouse wheel right.
Public Method | MouseWheelUp | Mouse wheel up.
Public Method | PageDown | Moves down a page.
Public Method | PageLeft | Moves left a page.
Public Method | PageRight | Moves right a page.
Public Method | PageUp | Moves up a page.
Public Method | SetHorizontalOffset | Sets the horizontal offset.
Public Method | SetVerticalOffset | Sets the vertical offset.
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | Overridden. Arrange the children.
Protected Method | MeasureOverride | Overridden. Measure the children.
Protected Method | OnItemsChanged | Overridden. When items are removed, remove the corresponding UI if necessary.
Top
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearVirtualizingWrapPanel Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ImGearVirtualizingWrapPanel Constructor
Initializes a new instance of the ImGearVirtualizingWrapPanel class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearVirtualizingWrapPanel()
public ImGearVirtualizingWrapPanel()
public: ImGearVirtualizingWrapPanel();
public:
ImGearVirtualizingWrapPanel();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


%%PageItemTitle%% $$Methods$$

ImGearVirtualizingWrapPanel Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class

For a list of all members of this type, see ImGearVirtualizingWrapPanel members.

Public Methods
 | Name | Description
Public Method | LineDown | Moves down a line.
Public Method | LineLeft | Moves left a line.
Public Method | LineRight | Moves right a line.
Public Method | LineUp | Moves up a line.
Public Method | MakeVisible | Makes the specified rectangle visible.
Public Method | MouseWheelDown | Mouse wheel down.
Public Method | MouseWheelLeft | Mouse wheel left.
Public Method | MouseWheelRight | Mouse wheel right.
Public Method | MouseWheelUp | Mouse wheel up.
Public Method | PageDown | Moves down a page.
Public Method | PageLeft | Moves left a page.
Public Method | PageRight | Moves right a page.
Public Method | PageUp | Moves up a page.
Public Method | SetHorizontalOffset | Sets the horizontal offset.
Public Method | SetVerticalOffset | Sets the vertical offset.
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | Overridden. Arrange the children.
Protected Method | MeasureOverride | Overridden. Measure the children.
Protected Method | OnItemsChanged | Overridden. When items are removed, remove the corresponding UI if necessary.
Top
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearVirtualizingWrapPanel Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class

For a list of all members of this type, see ImGearVirtualizingWrapPanel members.

See Also

Reference

ImGearVirtualizingWrapPanel Class
ImageGear.Windows.Controls Namespace


ArrangeOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ArrangeOverride Method
Size available.
Arrange the children.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
protected override Size ArrangeOverride(
   Size finalSize
)
protected: Size ArrangeOverride(
   Size finalSize
) override
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
Size available.

Return Value

Size used.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


LineDown Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : LineDown Method
Moves down a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LineDown()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.LineDown()
public void LineDown()
public: void LineDown();
public:
void LineDown();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


LineLeft Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : LineLeft Method
Moves left a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LineLeft()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.LineLeft()
public void LineLeft()
public: void LineLeft();
public:
void LineLeft();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


LineRight Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : LineRight Method
Moves right a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LineRight()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.LineRight()
public void LineRight()
public: void LineRight();
public:
void LineRight();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


LineUp Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : LineUp Method
Moves up a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LineUp()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.LineUp()
public void LineUp()
public: void LineUp();
public:
void LineUp();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MakeVisible Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MakeVisible Method
The visual.
The rectangle.
Makes the specified rectangle visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MakeVisible( _
   ByVal visual As Visual, _
   ByVal rectangle As Rect _
) As Rect
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim visual As Visual
Dim rectangle As Rect
Dim value As Rect

value = instance.MakeVisible(visual, rectangle)
public Rect MakeVisible(
   Visual visual,
   Rect rectangle
)
public: Rect MakeVisible(
   Visual* visual,
   Rect rectangle
)
public:
Rect MakeVisible(
   Visual^ visual,
   Rect rectangle
)

Parameters

visual
The visual.
rectangle
The rectangle.

Return Value

Rect value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MeasureOverride Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MeasureOverride Method
Size available.
Measure the children.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
protected override Size MeasureOverride(
   Size availableSize
)
protected: Size MeasureOverride(
   Size availableSize
) override
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
Size available.

Return Value

Size desired.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MouseWheelDown Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MouseWheelDown Method
Mouse wheel down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelDown()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.MouseWheelDown()
public void MouseWheelDown()
public: void MouseWheelDown();
public:
void MouseWheelDown();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MouseWheelLeft Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MouseWheelLeft Method
Mouse wheel left.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelLeft()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.MouseWheelLeft()
public void MouseWheelLeft()
public: void MouseWheelLeft();
public:
void MouseWheelLeft();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MouseWheelRight Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MouseWheelRight Method
Mouse wheel right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelRight()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.MouseWheelRight()
public void MouseWheelRight()
public: void MouseWheelRight();
public:
void MouseWheelRight();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


MouseWheelUp Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : MouseWheelUp Method
Mouse wheel up.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelUp()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.MouseWheelUp()
public void MouseWheelUp()
public: void MouseWheelUp();
public:
void MouseWheelUp();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


OnItemsChanged Method (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : OnItemsChanged Method
The sender.
The arguments.
When items are removed, remove the corresponding UI if necessary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnItemsChanged( _
   ByVal sender As Object, _
   ByVal args As ItemsChangedEventArgs _
)
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim sender As Object
Dim args As ItemsChangedEventArgs

instance.OnItemsChanged(sender, args)
protected override void OnItemsChanged(
   object sender,
   ItemsChangedEventArgs args
)
protected: void OnItemsChanged(
   Object* sender,
   ItemsChangedEventArgs* args
) override
protected:
void OnItemsChanged(
   Object^ sender,
   ItemsChangedEventArgs^ args
) override

Parameters

sender
The sender.
args
The arguments.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


PageDown Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : PageDown Method
Moves down a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PageDown()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.PageDown()
public void PageDown()
public: void PageDown();
public:
void PageDown();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


PageLeft Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : PageLeft Method
Moves left a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PageLeft()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.PageLeft()
public void PageLeft()
public: void PageLeft();
public:
void PageLeft();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


PageRight Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : PageRight Method
Moves right a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PageRight()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.PageRight()
public void PageRight()
public: void PageRight();
public:
void PageRight();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


PageUp Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : PageUp Method
Moves up a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PageUp()
'Usage

Dim instance As ImGearVirtualizingWrapPanel

instance.PageUp()
public void PageUp()
public: void PageUp();
public:
void PageUp();
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


SetHorizontalOffset Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : SetHorizontalOffset Method
The offset.
Sets the horizontal offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetHorizontalOffset( _
   ByVal offset As Double _
)
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim offset As Double

instance.SetHorizontalOffset(offset)
public void SetHorizontalOffset(
   double offset
)
public: void SetHorizontalOffset(
   double offset
)
public:
void SetHorizontalOffset(
   double offset
)

Parameters

offset
The offset.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


SetVerticalOffset Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : SetVerticalOffset Method
The offset.
Sets the vertical offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetVerticalOffset( _
   ByVal offset As Double _
)
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim offset As Double

instance.SetVerticalOffset(offset)
public void SetVerticalOffset(
   double offset
)
public: void SetVerticalOffset(
   double offset
)
public:
void SetVerticalOffset(
   double offset
)

Parameters

offset
The offset.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


%%PageItemTitle%% $$Properties$$

ImGearVirtualizingWrapPanel Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class

For a list of all members of this type, see ImGearVirtualizingWrapPanel members.

Public Properties
 | Name | Description
Public Property | CacheItemContainers | Gets or sets a value indicating whether item containers that are out of view are cached.
Public Property | CanHorizontallyScroll | Gets or sets a value indicating whether the control can be scrolled horizontally.
Public Property | CanVerticallyScroll | Gets or sets a value indicating whether the control can be scrolled vertically.
Public Property | ChildHeight | Gets or sets the child height.
Public Property | ChildWidth | Gets or sets the child width.
Public Property | ExtentHeight | Gets the extent height.
Public Property | ExtentWidth | Gets the extent width.
Public Property | HorizontalOffset | Gets the horizontal offset.
Public Property | ScrollDirection | Gets or sets the scroll direction.
Public Property | ScrollOwner | Gets or sets the scroll owner.
Public Property | VerticalOffset | Gets the vertical offset.
Public Property | ViewportHeight | Gets the viewport height.
Public Property | ViewportWidth | Gets the viewport width.
Public Property | XSpacing | Gets or sets the X spacing.
Public Property | YSpacing | Gets or sets the Y spacing.
Top
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImageGear.Windows.Controls Namespace


CacheItemContainers Property (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : CacheItemContainers Property
Gets or sets a value indicating whether item containers that are out of view are cached.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CacheItemContainers As Boolean
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Boolean

instance.CacheItemContainers = value

value = instance.CacheItemContainers
public bool CacheItemContainers {get; set;}
public: __property bool get_CacheItemContainers();
public: __property void set_CacheItemContainers(
   bool value
);
public:
property bool CacheItemContainers {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

When set to false, the generated thumbnail images are cached and the containers for generated items are destroyed when thumbnail items are scrolled out of view. When scrolled back into view, a thumbnail item's container is regenerated and the view element is set to the cached thumbnail page. This option uses less memory but there is a small delay when displaying cached thumbnails that are scrolled back into view. When set to true, the containers for generated items are not destroyed when thumbnail items are scrolled out of view, which uses more memory but thumbnails that have already been generated are displayed immediately when scrolled back into view.

The default value is true.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


CanHorizontallyScroll Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : CanHorizontallyScroll Property
Gets or sets a value indicating whether the control can be scrolled horizontally.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanHorizontallyScroll As Boolean
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Boolean

instance.CanHorizontallyScroll = value

value = instance.CanHorizontallyScroll
public bool CanHorizontallyScroll {get; set;}
public: __property bool get_CanHorizontallyScroll();
public: __property void set_CanHorizontallyScroll(
   bool value
);
public:
property bool CanHorizontallyScroll {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


CanVerticallyScroll Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : CanVerticallyScroll Property
Gets or sets a value indicating whether the control can be scrolled vertically.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanVerticallyScroll As Boolean
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Boolean

instance.CanVerticallyScroll = value

value = instance.CanVerticallyScroll
public bool CanVerticallyScroll {get; set;}
public: __property bool get_CanVerticallyScroll();
public: __property void set_CanVerticallyScroll(
   bool value
);
public:
property bool CanVerticallyScroll {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ChildHeight Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ChildHeight Property
Gets or sets the child height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChildHeight As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

instance.ChildHeight = value

value = instance.ChildHeight
public double ChildHeight {get; set;}
public: __property double get_ChildHeight();
public: __property void set_ChildHeight(
   double value
);
public:
property double ChildHeight {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ChildWidth Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ChildWidth Property
Gets or sets the child width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChildWidth As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

instance.ChildWidth = value

value = instance.ChildWidth
public double ChildWidth {get; set;}
public: __property double get_ChildWidth();
public: __property void set_ChildWidth(
   double value
);
public:
property double ChildWidth {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ExtentHeight Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ExtentHeight Property
Gets the extent height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ExtentHeight As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.ExtentHeight
public double ExtentHeight {get;}
public: __property double get_ExtentHeight();
public:
property double ExtentHeight {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ExtentWidth Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ExtentWidth Property
Gets the extent width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ExtentWidth As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.ExtentWidth
public double ExtentWidth {get;}
public: __property double get_ExtentWidth();
public:
property double ExtentWidth {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


HorizontalOffset Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : HorizontalOffset Property
Gets the horizontal offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalOffset As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.HorizontalOffset
public double HorizontalOffset {get;}
public: __property double get_HorizontalOffset();
public:
property double HorizontalOffset {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ScrollDirection Property (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ScrollDirection Property
Gets or sets the scroll direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScrollDirection As ImGearScrollDirection
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As ImGearScrollDirection

instance.ScrollDirection = value

value = instance.ScrollDirection
public ImGearScrollDirection ScrollDirection {get; set;}
public: __property ImGearScrollDirection get_ScrollDirection();
public: __property void set_ScrollDirection(
   ImGearScrollDirection value
);
public:
property ImGearScrollDirection ScrollDirection {
   ImGearScrollDirection get();
   void set (    ImGearScrollDirection value);
}

Property Value

ImGearScrollDirection enumeration value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ScrollOwner Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ScrollOwner Property
Gets or sets the scroll owner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScrollOwner As ScrollViewer
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As ScrollViewer

instance.ScrollOwner = value

value = instance.ScrollOwner
public ScrollViewer ScrollOwner {get; set;}
public: __property ScrollViewer* get_ScrollOwner();
public: __property void set_ScrollOwner(
   ScrollViewer* value
);
public:
property ScrollViewer^ ScrollOwner {
   ScrollViewer^ get();
   void set (    ScrollViewer^ value);
}

Property Value

ScrollViewer object.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


VerticalOffset Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : VerticalOffset Property
Gets the vertical offset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalOffset As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.VerticalOffset
public double VerticalOffset {get;}
public: __property double get_VerticalOffset();
public:
property double VerticalOffset {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ViewportHeight Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ViewportHeight Property
Gets the viewport height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ViewportHeight As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.ViewportHeight
public double ViewportHeight {get;}
public: __property double get_ViewportHeight();
public:
property double ViewportHeight {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ViewportWidth Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ViewportWidth Property
Gets the viewport width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ViewportWidth As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

value = instance.ViewportWidth
public double ViewportWidth {get;}
public: __property double get_ViewportWidth();
public:
property double ViewportWidth {
   double get();
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


XSpacing Property (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : XSpacing Property
Gets or sets the X spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XSpacing As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

instance.XSpacing = value

value = instance.XSpacing
public double XSpacing {get; set;}
public: __property double get_XSpacing();
public: __property void set_XSpacing(
   double value
);
public:
property double XSpacing {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


YSpacing Property (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : YSpacing Property
Gets or sets the Y spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YSpacing As Double
'Usage

Dim instance As ImGearVirtualizingWrapPanel
Dim value As Double

instance.YSpacing = value

value = instance.YSpacing
public double YSpacing {get; set;}
public: __property double get_YSpacing();
public: __property void set_YSpacing(
   double value
);
public:
property double YSpacing {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


%%PageItemTitle%% $$Fields$$

ImGearVirtualizingWrapPanel Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearVirtualizingWrapPanel Class

For a list of all members of this type, see ImGearVirtualizingWrapPanel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CacheItemContainersProperty | Cache item containers dependency property.
static (Shared in Visual Basic) | ChildHeightProperty | Child height dependency property.
static (Shared in Visual Basic) | ChildWidthProperty | Child width dependency property.
static (Shared in Visual Basic) | ScrollDirectionProperty | Scroll direction dependency property.
static (Shared in Visual Basic) | XSpacingProperty | X spacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Y spacing dependency property.
Top
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImageGear.Windows.Controls Namespace


CacheItemContainersProperty Field (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : CacheItemContainersProperty Field
Cache item containers dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CacheItemContainersProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.CacheItemContainersProperty
public static readonly DependencyProperty CacheItemContainersProperty
public: static readonly DependencyProperty* CacheItemContainersProperty
public:
static readonly DependencyProperty^ CacheItemContainersProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ChildHeightProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ChildHeightProperty Field
Child height dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ChildHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.ChildHeightProperty
public static readonly DependencyProperty ChildHeightProperty
public: static readonly DependencyProperty* ChildHeightProperty
public:
static readonly DependencyProperty^ ChildHeightProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ChildWidthProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ChildWidthProperty Field
Child width dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ChildWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.ChildWidthProperty
public static readonly DependencyProperty ChildWidthProperty
public: static readonly DependencyProperty* ChildWidthProperty
public:
static readonly DependencyProperty^ ChildWidthProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


ScrollDirectionProperty Field (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : ScrollDirectionProperty Field
Scroll direction dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ScrollDirectionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.ScrollDirectionProperty
public static readonly DependencyProperty ScrollDirectionProperty
public: static readonly DependencyProperty* ScrollDirectionProperty
public:
static readonly DependencyProperty^ ScrollDirectionProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


XSpacingProperty Field (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : XSpacingProperty Field
X spacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly XSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.XSpacingProperty
public static readonly DependencyProperty XSpacingProperty
public: static readonly DependencyProperty* XSpacingProperty
public:
static readonly DependencyProperty^ XSpacingProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


YSpacingProperty Field (ImGearVirtualizingWrapPanel)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearVirtualizingWrapPanel Class : YSpacingProperty Field
Y spacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly YSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearVirtualizingWrapPanel.YSpacingProperty
public static readonly DependencyProperty YSpacingProperty
public: static readonly DependencyProperty* YSpacingProperty
public:
static readonly DependencyProperty^ YSpacingProperty
See Also

Reference

ImGearVirtualizingWrapPanel Class
ImGearVirtualizingWrapPanel Members


%%PageItemTitle%%

ImGearZoomInSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomInSettings Class
This class represents the settings for the zoom in mouse tool.
Object Model
ImGearZoomInSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearZoomInSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearZoomInSettings
public class ImGearZoomInSettings : System.Windows.DependencyObject
public __gc class ImGearZoomInSettings : public System.Windows.DependencyObject
public ref class ImGearZoomInSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearZoomInSettings

See Also

Reference

ImGearZoomInSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearZoomInSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomInSettings Class

The following tables list the members exposed by ImGearZoomInSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearZoomInSettings Constructor | Initializes a new instance of the ImGearZoomInSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomInFactor dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | ZoomFactor | Gets or sets the factor that the image zoom when using the zoom in mouse tool.
Top
See Also

Reference

ImGearZoomInSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearZoomInSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : ImGearZoomInSettings Constructor
Initializes a new instance of the ImGearZoomInSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearZoomInSettings()
public ImGearZoomInSettings()
public: ImGearZoomInSettings();
public:
ImGearZoomInSettings();
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


%%PageItemTitle%% $$Properties$$

ImGearZoomInSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomInSettings Class

For a list of all members of this type, see ImGearZoomInSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | ZoomFactor | Gets or sets the factor that the image zoom when using the zoom in mouse tool.
Top
See Also

Reference

ImGearZoomInSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearZoomInSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomInSettings Class

For a list of all members of this type, see ImGearZoomInSettings members.

See Also

Reference

ImGearZoomInSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearZoomInSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


InteractionArea Property (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearZoomInSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

ImGearInteractionArea enumeration value.
Remarks
The default value is ImGearInteractionArea .Device, which corresponds to the unlimited device area. You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device.
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


ZoomFactor Property (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : ZoomFactor Property
Gets or sets the factor that the image zoom when using the zoom in mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomFactor As Double
'Usage

Dim instance As ImGearZoomInSettings
Dim value As Double

instance.ZoomFactor = value

value = instance.ZoomFactor
public double ZoomFactor {get; set;}
public: __property double get_ZoomFactor();
public: __property void set_ZoomFactor(
   double value
);
public:
property double ZoomFactor {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 1.2.
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


%%PageItemTitle%% $$Fields$$

ImGearZoomInSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomInSettings Class

For a list of all members of this type, see ImGearZoomInSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomInFactor dependency property.
Top
See Also

Reference

ImGearZoomInSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomInSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


InteractionAreaProperty Field (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomInSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


ZoomFactorProperty Field (ImGearZoomInSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomInSettings Class : ZoomFactorProperty Field
Represents ZoomInFactor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomInSettings.ZoomFactorProperty
public static readonly DependencyProperty ZoomFactorProperty
public: static readonly DependencyProperty* ZoomFactorProperty
public:
static readonly DependencyProperty^ ZoomFactorProperty
See Also

Reference

ImGearZoomInSettings Class
ImGearZoomInSettings Members


%%PageItemTitle%%

ImGearZoomOutSettings Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomOutSettings Class
This class represents the settings for the zoom out mouse tool.
Object Model
ImGearZoomOutSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearZoomOutSettings
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearZoomOutSettings
public class ImGearZoomOutSettings : System.Windows.DependencyObject
public __gc class ImGearZoomOutSettings : public System.Windows.DependencyObject
public ref class ImGearZoomOutSettings : public System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.Windows.Controls.ImGearZoomOutSettings

See Also

Reference

ImGearZoomOutSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearZoomOutSettings Class Members
Fields Properties Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomOutSettings Class

The following tables list the members exposed by ImGearZoomOutSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearZoomOutSettings Constructor | Initializes a new instance of the ImGearZoomOutSettings class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomOutFactor dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | ZoomFactor | Gets or sets the factor that the image zooms when using the zoom out mouse tool.
Top
See Also

Reference

ImGearZoomOutSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearZoomOutSettings Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : ImGearZoomOutSettings Constructor
Initializes a new instance of the ImGearZoomOutSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearZoomOutSettings()
public ImGearZoomOutSettings()
public: ImGearZoomOutSettings();
public:
ImGearZoomOutSettings();
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


%%PageItemTitle%% $$Properties$$

ImGearZoomOutSettings Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomOutSettings Class

For a list of all members of this type, see ImGearZoomOutSettings members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets the cursor.
Public Property | InteractionArea | Gets or sets the interaction area for editing annotations.
Public Property | ZoomFactor | Gets or sets the factor that the image zooms when using the zoom out mouse tool.
Top
See Also

Reference

ImGearZoomOutSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearZoomOutSettings Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomOutSettings Class

For a list of all members of this type, see ImGearZoomOutSettings members.

See Also

Reference

ImGearZoomOutSettings Class
ImageGear.Windows.Controls Namespace


Cursor Property (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : Cursor Property
Gets or sets the cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearZoomOutSettings
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

A System.Windows.Input.Cursor object.
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


InteractionArea Property (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : InteractionArea Property
Gets or sets the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteractionArea As ImGearInteractionArea
'Usage

Dim instance As ImGearZoomOutSettings
Dim value As ImGearInteractionArea

instance.InteractionArea = value

value = instance.InteractionArea
public ImGearInteractionArea InteractionArea {get; set;}
public: __property ImGearInteractionArea get_InteractionArea();
public: __property void set_InteractionArea(
   ImGearInteractionArea value
);
public:
property ImGearInteractionArea InteractionArea {
   ImGearInteractionArea get();
   void set (    ImGearInteractionArea value);
}

Property Value

ImGearInteractionArea enumeration value.
Remarks
The default value is ImGearInteractionArea .Device, which corresponds to the unlimited device area. You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device.
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


ZoomFactor Property (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : ZoomFactor Property
Gets or sets the factor that the image zooms when using the zoom out mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomFactor As Double
'Usage

Dim instance As ImGearZoomOutSettings
Dim value As Double

instance.ZoomFactor = value

value = instance.ZoomFactor
public double ZoomFactor {get; set;}
public: __property double get_ZoomFactor();
public: __property void set_ZoomFactor(
   double value
);
public:
property double ZoomFactor {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Default value is 0.8.
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


%%PageItemTitle%% $$Fields$$

ImGearZoomOutSettings Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearZoomOutSettings Class

For a list of all members of this type, see ImGearZoomOutSettings members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | InteractionAreaProperty | Represents InteractionArea dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomOutFactor dependency property.
Top
See Also

Reference

ImGearZoomOutSettings Class
ImageGear.Windows.Controls Namespace


CursorProperty Field (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomOutSettings.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


InteractionAreaProperty Field (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : InteractionAreaProperty Field
Represents InteractionArea dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteractionAreaProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomOutSettings.InteractionAreaProperty
public static readonly DependencyProperty InteractionAreaProperty
public: static readonly DependencyProperty* InteractionAreaProperty
public:
static readonly DependencyProperty^ InteractionAreaProperty
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


ZoomFactorProperty Field (ImGearZoomOutSettings)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ImGearZoomOutSettings Class : ZoomFactorProperty Field
Represents ZoomOutFactor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearZoomOutSettings.ZoomFactorProperty
public static readonly DependencyProperty ZoomFactorProperty
public: static readonly DependencyProperty* ZoomFactorProperty
public:
static readonly DependencyProperty^ ZoomFactorProperty
See Also

Reference

ImGearZoomOutSettings Class
ImGearZoomOutSettings Members


%%PageItemTitle%%

PageView Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class
This class provides a user interface element to use in XAML. It takes an ImGearPageDisplay Class object and renders it, allowing for options to scroll, zoom, and other methods of manipulating the display of an image.
Object Model
PageView ClassImGearDisplayScaleSettings ClassImGearRectangle StructureImGearARTMark ClassImGearPresentationPageDisplay ClassImGearSize StructureScrollBarIncrement ClassScrollBarIncrement ClassImGearDisplayScaleSettings ClassImGearARTMark ClassImGearMouseToolSettings ClassImGearPage ClassScrollBarIncrement ClassScrollBarIncrement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplatePartAttribute(Name="CanvasElement", Type=System.Windows.Controls.Canvas)>
<TemplatePartAttribute(Name="InProgressMarkCanvasElement", Type=System.Windows.Controls.Canvas)>
<TemplatePartAttribute(Name="HorizontalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)>
<TemplatePartAttribute(Name="VerticalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)>
Public Class PageView
   Inherits System.Windows.Controls.Control
   Implements ImageGear.Display.IImGearScrollableView, IImGearCommandManager
'Usage

Dim instance As PageView
[TemplatePart(Name="CanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="InProgressMarkCanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="HorizontalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
[TemplatePart(Name="VerticalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
public class PageView : System.Windows.Controls.Control, ImageGear.Display.IImGearScrollableView, IImGearCommandManager
[TemplatePart(Name="CanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="InProgressMarkCanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="HorizontalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
[TemplatePart(Name="VerticalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
public __gc class PageView : public System.Windows.Controls.Control, ImageGear.Display.IImGearScrollableView, IImGearCommandManager
[TemplatePart(Name="CanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="InProgressMarkCanvasElement", Type=System.Windows.Controls.Canvas)]
[TemplatePart(Name="HorizontalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
[TemplatePart(Name="VerticalScrollBarElement", Type=System.Windows.Controls.Primitives.ScrollBar)]
public ref class PageView : public System.Windows.Controls.Control, ImageGear.Display.IImGearScrollableView, IImGearCommandManager
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.PageView

See Also

Reference

PageView Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

PageView Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class

The following tables list the members exposed by PageView.

Public Constructors
 | Name | Description
Public Constructor | PageView Constructor | Initializes a new instance of the PageView class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationModeProperty | Represents AnnotationMode dependency property.
static (Shared in Visual Basic) | CreateNewPageDisplayForImageProperty | DependencyProperty for CreateNewPageDisplayForImage.
static (Shared in Visual Basic) | CustomMarkControllerProperty | Represents CustomMarkController dependency property.
static (Shared in Visual Basic) | DefaultPageNumberProperty | DependencyProperty for DefaultPageNumber.
static (Shared in Visual Basic) | DisplayProperty | Represents Display dependency property.
static (Shared in Visual Basic) | DragDropOpenProperty | DependencyProperty for DragDropOpen.
static (Shared in Visual Basic) | IsHandPanEnabledProperty | This property has been deprecated. Dependency property for IsHandPanEnabled.
static (Shared in Visual Basic) | IsMouseWheelScrollEnabledProperty | Dependency property for IsMouseWheelScrollEnabled.
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | MouseToolSettingsProperty | Represents MouseToolSettings dependency property.
static (Shared in Visual Basic) | OpenAnnotationsProperty | DependencyProperty for OpenAnnotations.
static (Shared in Visual Basic) | OpenDocumentProperty | DependencyProperty for OpenDocument.
static (Shared in Visual Basic) | OpenImagesProperty | DependencyProperty for OpenImages.
Top
Public Properties
 | Name | Description
Public Property | AnnotationMode | Gets or sets the annotation mode.
Public Property | AnnotationScaleSettings | Gets or sets the engine for annotation scaling, as well as scale settings that are specific to this engine.
Public Property | Canvas | Gets canvas element used to contain image and other elements of the view.
Public Property | ClientRectangle | Gets the rectangle ImageGear display code should use as the client area rectangle.
Public Property | ContextMenuMark | Gets the mark that corresponds to the context menu.
Public Property | CreateNewPageDisplayForImage | Gets or sets a value indicating whether to create a new Display object for images.
Public Property | CustomMarkController | Gets or sets the custom mark controller to use when the MouseTool property is set to CreateCustomMark.
Public Property | DefaultPageNumber | Gets or sets page number in the file to be opened.
Public Property | Display | Gets or sets the ImGearPageDisplay Class object associated with the control, representing the image and display parameters.
Public Property | DragDropOpen | Gets or sets a value indicating whether hand drag and drop file opening is enabled or not.
Public Property | HorizontalLargeChange | Gets the horizontal ScrollBar large change increment settings.
Public Property | HorizontalSmallChange | Gets the horizontal ScrollBar small change increment settings.
Public Property | ImageScaleSettings | Gets or sets the engine for image scaling, as well as scale settings that are specific to this engine.
Public Property | InProgressMark | Gets or sets an ART mark to display immediately while creating an ART mark using the mouse.
Public Property | IsHandPanEnabled | This property has been deprecated. Gets or sets a value indicating whether hand panning is enabled or not. When true, clicking and dragging on the image will pan the image.
Public Property | IsMouseWheelScrollEnabled | Gets or sets a value indicating whether MouseWheel scrolling is enabled. If true, scrolling the mouse wheel over the control results in vertical scrolling.
Public Property | MarkBringToFrontCommand | Gets a command for bringing a mark to the front of the Z-order.
Public Property | MarkCopyCommand | Gets a command for copying a mark.
Public Property | MarkCutCommand | Gets a command for cutting a mark.
Public Property | MarkDeleteCommand | Gets a command for deleting a mark.
Public Property | MarkPasteCommand | Gets a command for pasting a mark.
Public Property | MarkSendToBackCommand | Gets a command for sending a mark to the back of the Z-order.
Public Property | MouseTool | Gets or sets the mouse tool.
Public Property | MouseToolSettings | Gets or sets an object that provides access to mouse tool settings.
Public Property | OpenAnnotations | Gets or sets a value indicating whether annotations will be opened.
Public Property | OpenDocument | Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Public Property | OpenImages | Gets or sets a value indicating whether images will be opened.
Public Property | Page | Gets or sets the ImGearPage Class associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay Class object.
Public Property | SetAntialiasCommand | Gets a command for setting antialias.
Public Property | SetFitModeCommand | Gets a command for setting the fit mode.
Public Property | SetImageGearScalingCommand | Gets a command for setting ImageGear scaling.
Public Property | SetMarkClosedCommand | Gets a command for setting mark Closed.
Public Property | SetMarkEndHeadTypeCommand | Gets a command for setting mark end head type.
Public Property | SetMarkEndLengthCommand | Gets a command for setting mark end length.
Public Property | SetMarkImageFitModeCommand | Gets a command for setting mark image fit mode.
Public Property | SetMarkOrientationCommand | Gets a command for setting mark orientation.
Public Property | SetMarkPinAlignmentCommand | Gets a command for setting mark pin alignment.
Public Property | SetMarkPrecisionCommand | Gets a command for setting mark precision.
Public Property | SetMarkStartHeadTypeCommand | Gets a command for setting mark start head type.
Public Property | SetMarkStartLengthCommand | Gets a command for setting mark start length.
Public Property | SetMarkStyleCommand | Gets a command for setting mark style or border style.
Public Property | SetMarkTextBorderShadingCommand | Gets a command for setting mark text border shading.
Public Property | SetMarkThicknessCommand | Gets a command for setting mark thickness or border thickness.
Public Property | SetResampleCommand | Gets a command for setting resampling.
Public Property | SetWPFScalingCommand | Gets a command for setting WPF scaling.
Public Property | ShowMarkPropertiesWindowCommand | Gets a command for showing a properties window for a mark.
Public Property | UpdateMode | Gets or sets whether the control updates automatically when the display settings or annotations change.
Public Property | VerticalLargeChange | Gets the vertical ScrollBar large change increment settings.
Public Property | VerticalSmallChange | Gets the vertical ScrollBar small change increment settings.
Public Property | ZoomCommand | Gets a command for zooming.
Top
Public Methods
 | Name | Description
Public Method | AnnotationsAreAvailable | Returns whether or not the annotation assembly (ImageGear.Windows.Controls.Art.dll) is available.
Public Method | EnableScrollBar | Change enable state of scrollbars associated with window.
Public Method | GetScrollBarDimensions | This method returns width and height dimensions of the windows scroll bar.
Public Method | GetScrollParams | This method obtains the attributes of the scrollbar specified.
Public Method | IsScrollBarEnabled | This method returns whether or not the specified scrollbar is enabled.
Public Method | IsScrollBarVisible | This method returns visibility state of the scrollbar specified.
Public Method | OnApplyTemplate | Overridden. Invoked whenever application code or internal processes call ApplyTemplate.
Public Method | SetScrollParams | This method updates the state of specified scrollbar with new values.
Public Method | ShowMarkPropertiesWindow | Displays a dialog window that shows the properties of the specified mark and can be used to modify the properties.
Public Method | ShowScrollBar | Overloaded. Change visibility state of scrollbars associated with window.
Public Method | Update | Overloaded. Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Public Method | UpdateAnnotations | Causes a redraw of the annotations. Can be used instead of Update anytime only the annotations have been updated.
Top
Protected Methods
 | Name | Description
Protected Method | OnContextMenuClosing | Overridden. Fires when the context menu is closing.
Protected Method | OnContextMenuOpening | Overridden. Fires when the context menu is opening.
Protected Method | OnMarkAdded | Occurs when a mark is added.
Protected Method | OnMarkChanged | Occurs when a mark is changed.
Protected Method | OnMarkRemoved | Occurs when a mark is removed.
Protected Method | OnMarkSelectionChanged | Occurs when a mark's selection is changed.
Protected Method | OnMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Protected Method | OnPageScrolled | Occurs when a page is scrolled.
Protected Method | OnPageZoomed | Occurs when a page is zoomed.
Protected Method | OnRequerySuggested | Occurs when a requery is suggested.
Protected Method | OnScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
Public Events
 | Name | Description
Public Event | FileOpened | Event triggered after a file has been opened by the PageView control.
Public Event | FileOpening | Event triggered before a file is opened by the PageView control.
Public Event | MarkAdded | Occurs when a mark is added.
Public Event | MarkChanged | Occurs when a mark is changed.
Public Event | MarkCreating | Occurs when a mark is added using the mouse.
Public Event | MarkRemoved | Occurs when a mark is removed.
Public Event | MarkSelectionChanged | Occurs when a mark's selection is changed.
Public Event | MarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Public Event | PageScrolled | Occurs when a pages is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Public Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Public Event | Updated | Occurs after an update of the image has occurred.
Top
See Also

Reference

PageView Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

PageView Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : PageView Constructor
Initializes a new instance of the PageView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PageView()
public PageView()
public: PageView();
public:
PageView();
See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%% $$Methods$$

PageView Class Methods

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Methods
 | Name | Description
Public Method | AnnotationsAreAvailable | Returns whether or not the annotation assembly (ImageGear.Windows.Controls.Art.dll) is available.
Public Method | EnableScrollBar | Change enable state of scrollbars associated with window.
Public Method | GetScrollBarDimensions | This method returns width and height dimensions of the windows scroll bar.
Public Method | GetScrollParams | This method obtains the attributes of the scrollbar specified.
Public Method | IsScrollBarEnabled | This method returns whether or not the specified scrollbar is enabled.
Public Method | IsScrollBarVisible | This method returns visibility state of the scrollbar specified.
Public Method | OnApplyTemplate | Overridden. Invoked whenever application code or internal processes call ApplyTemplate.
Public Method | SetScrollParams | This method updates the state of specified scrollbar with new values.
Public Method | ShowMarkPropertiesWindow | Displays a dialog window that shows the properties of the specified mark and can be used to modify the properties.
Public Method | ShowScrollBar | Overloaded. Change visibility state of scrollbars associated with window.
Public Method | Update | Overloaded. Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Public Method | UpdateAnnotations | Causes a redraw of the annotations. Can be used instead of Update anytime only the annotations have been updated.
Top
Protected Methods
 | Name | Description
Protected Method | OnContextMenuClosing | Overridden. Fires when the context menu is closing.
Protected Method | OnContextMenuOpening | Overridden. Fires when the context menu is opening.
Protected Method | OnMarkAdded | Occurs when a mark is added.
Protected Method | OnMarkChanged | Occurs when a mark is changed.
Protected Method | OnMarkRemoved | Occurs when a mark is removed.
Protected Method | OnMarkSelectionChanged | Occurs when a mark's selection is changed.
Protected Method | OnMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Protected Method | OnPageScrolled | Occurs when a page is scrolled.
Protected Method | OnPageZoomed | Occurs when a page is zoomed.
Protected Method | OnRequerySuggested | Occurs when a requery is suggested.
Protected Method | OnScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Top
See Also

Reference

PageView Class
ImageGear.Windows.Controls Namespace


AnnotationsAreAvailable Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : AnnotationsAreAvailable Method
Returns whether or not the annotation assembly (ImageGear.Windows.Controls.Art.dll) is available.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AnnotationsAreAvailable() As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

value = instance.AnnotationsAreAvailable()
public bool AnnotationsAreAvailable()
public: bool AnnotationsAreAvailable();
public:
bool AnnotationsAreAvailable();

Return Value

Boolean value.
Remarks
If the annotation assembly is not available, an exception will occur when trying to access annotation functionality. If you right click on an annotation and the annotation assembly is not available, the context menu will be displayed with page menu items rather than annotation menu items.
See Also

Reference

PageView Class
PageView Members


EnableScrollBar Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : EnableScrollBar Method
Specifies the scrollbar whose attributes are requested.
Enable (true) or disable (false) scrollbar.
Change enable state of scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EnableScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal state As Boolean _
)
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim state As Boolean

instance.EnableScrollBar(scrollBarType, state)
public void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
public: void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
public:
void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
state
Enable (true) or disable (false) scrollbar.
See Also

Reference

PageView Class
PageView Members


GetScrollBarDimensions Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : GetScrollBarDimensions Method
Specifies the scrollbar whose attributes are requested.
This method returns width and height dimensions of the windows scroll bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetScrollBarDimensions( _
   ByVal scrollBarType As ImGearScrollBarType _
) As ImGearSize
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim value As ImGearSize

value = instance.GetScrollBarDimensions(scrollBarType)
public ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)
public: ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)
public:
ImGearSize GetScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

Width and Height of the windows scroll bar.
See Also

Reference

PageView Class
PageView Members


GetScrollParams Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : GetScrollParams Method
Specifies the scrollbar whose attributes are requested.
Output parameter; horizontal or vertical field of this parameter is updated with requested information.
This method obtains the attributes of the scrollbar specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetScrollParams( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByRef scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim scrollInfo As ImGearScrollInfo

instance.GetScrollParams(scrollBarType, scrollInfo)
public void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ref ImGearScrollInfo scrollInfo
)
public: void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ref ImGearScrollInfo scrollInfo
)
public:
void GetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo% scrollInfo
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
Output parameter; horizontal or vertical field of this parameter is updated with requested information.
See Also

Reference

PageView Class
PageView Members


IsScrollBarEnabled Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsScrollBarEnabled Method
Specifies the scrollbar whose attributes are requested.
This method returns whether or not the specified scrollbar is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsScrollBarEnabled( _
   ByVal scrollBarType As ImGearScrollBarType _
) As Boolean
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim value As Boolean

value = instance.IsScrollBarEnabled(scrollBarType)
public bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)
public: bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)
public:
bool IsScrollBarEnabled(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

True if scrollbar is enabled, false if it is not enabled.
See Also

Reference

PageView Class
PageView Members


IsScrollBarVisible Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsScrollBarVisible Method
Specifies the scrollbar whose attributes are requested.
This method returns visibility state of the scrollbar specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsScrollBarVisible( _
   ByVal scrollBarType As ImGearScrollBarType _
) As Boolean
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim value As Boolean

value = instance.IsScrollBarVisible(scrollBarType)
public bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)
public: bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)
public:
bool IsScrollBarVisible(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

True if scrollbar is visible, false if it is hidden.
See Also

Reference

PageView Class
PageView Members


OnApplyTemplate Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As PageView

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
See Also

Reference

PageView Class
PageView Members


OnContextMenuClosing Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnContextMenuClosing Method
Context menu event arguments.
Fires when the context menu is closing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnContextMenuClosing( _
   ByVal e As ContextMenuEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ContextMenuEventArgs

instance.OnContextMenuClosing(e)
protected override void OnContextMenuClosing(
   ContextMenuEventArgs e
)
protected: void OnContextMenuClosing(
   ContextMenuEventArgs* e
) override
protected:
void OnContextMenuClosing(
   ContextMenuEventArgs^ e
) override

Parameters

e
Context menu event arguments.
See Also

Reference

PageView Class
PageView Members


OnContextMenuOpening Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnContextMenuOpening Method
Context menu event arguments.
Fires when the context menu is opening.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnContextMenuOpening( _
   ByVal e As ContextMenuEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ContextMenuEventArgs

instance.OnContextMenuOpening(e)
protected override void OnContextMenuOpening(
   ContextMenuEventArgs e
)
protected: void OnContextMenuOpening(
   ContextMenuEventArgs* e
) override
protected:
void OnContextMenuOpening(
   ContextMenuEventArgs^ e
) override

Parameters

e
Context menu event arguments.
See Also

Reference

PageView Class
PageView Members


OnMarkAdded Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnMarkAdded Method
Event arguments.
Occurs when a mark is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkAdded( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearARTMarkEventArgs

instance.OnMarkAdded(e)
protected void OnMarkAdded(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkAdded(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkAdded(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnMarkChanged Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnMarkChanged Method
Event arguments.
Occurs when a mark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearARTMarkEventArgs

instance.OnMarkChanged(e)
protected void OnMarkChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnMarkRemoved Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnMarkRemoved Method
Event arguments.
Occurs when a mark is removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkRemoved( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearARTMarkEventArgs

instance.OnMarkRemoved(e)
protected void OnMarkRemoved(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkRemoved(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkRemoved(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnMarkSelectionChanged Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnMarkSelectionChanged Method
Event arguments.
Occurs when a mark's selection is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkSelectionChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearARTMarkEventArgs

instance.OnMarkSelectionChanged(e)
protected void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkSelectionChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnMarkZOrderChanged Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnMarkZOrderChanged Method
Event arguments.
Occurs when a mark's Z-Order is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnMarkZOrderChanged( _
   ByVal e As ImGearARTMarkEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearARTMarkEventArgs

instance.OnMarkZOrderChanged(e)
protected void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs e
)
protected: void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs* e
)
protected:
void OnMarkZOrderChanged(
   ImGearARTMarkEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnPageScrolled Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnPageScrolled Method
Event arguments.
Occurs when a page is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use OnScrollChanged instead.")>
Protected Sub OnPageScrolled( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As PageView
Dim e As EventArgs

instance.OnPageScrolled(e)
[Obsolete("Use OnScrollChanged instead.")]
protected void OnPageScrolled(
   EventArgs e
)
[Obsolete("Use OnScrollChanged instead.")]
protected: void OnPageScrolled(
   EventArgs* e
)
[Obsolete("Use OnScrollChanged instead.")]
protected:
void OnPageScrolled(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnPageZoomed Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnPageZoomed Method
Event arguments.
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPageZoomed( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As PageView
Dim e As EventArgs

instance.OnPageZoomed(e)
protected void OnPageZoomed(
   EventArgs e
)
protected: void OnPageZoomed(
   EventArgs* e
)
protected:
void OnPageZoomed(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnRequerySuggested Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnRequerySuggested Method
Event arguments.
Occurs when a requery is suggested.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnRequerySuggested( _
   ByVal e As EventArgs _
)
'Usage

Dim instance As PageView
Dim e As EventArgs

instance.OnRequerySuggested(e)
protected void OnRequerySuggested(
   EventArgs e
)
protected: void OnRequerySuggested(
   EventArgs* e
)
protected:
void OnRequerySuggested(
   EventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


OnScrollChanged Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OnScrollChanged Method
Event arguments.
Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnScrollChanged( _
   ByVal e As ImGearScrollChangedEventArgs _
)
'Usage

Dim instance As PageView
Dim e As ImGearScrollChangedEventArgs

instance.OnScrollChanged(e)
protected void OnScrollChanged(
   ImGearScrollChangedEventArgs e
)
protected: void OnScrollChanged(
   ImGearScrollChangedEventArgs* e
)
protected:
void OnScrollChanged(
   ImGearScrollChangedEventArgs^ e
)

Parameters

e
Event arguments.
See Also

Reference

PageView Class
PageView Members


SetScrollParams Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetScrollParams Method
Specifies the scrollbar whose attributes are requested.
New scrollbar state.
Specifies whether or not to redraw image in window.
This method updates the state of specified scrollbar with new values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetScrollParams( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollInfo As ImGearScrollInfo, _
   ByVal redraw As Boolean _
)
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim scrollInfo As ImGearScrollInfo
Dim redraw As Boolean

instance.SetScrollParams(scrollBarType, scrollInfo, redraw)
public void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)
public: void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)
public:
void SetScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   bool redraw
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
New scrollbar state.
redraw
Specifies whether or not to redraw image in window.
See Also

Reference

PageView Class
PageView Members


ShowMarkPropertiesWindow Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ShowMarkPropertiesWindow Method
The ART mark.
The position (in device pixels) of the upper left corner of the dialog window.
Displays a dialog window that shows the properties of the specified mark and can be used to modify the properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowMarkPropertiesWindow( _
   ByVal mark As ImGearARTMark, _
   ByVal position As Point _
)
'Usage

Dim instance As PageView
Dim mark As ImGearARTMark
Dim position As Point

instance.ShowMarkPropertiesWindow(mark, position)
public void ShowMarkPropertiesWindow(
   ImGearARTMark mark,
   Point position
)
public: void ShowMarkPropertiesWindow(
   ImGearARTMark* mark,
   Point position
)
public:
void ShowMarkPropertiesWindow(
   ImGearARTMark^ mark,
   Point position
)

Parameters

mark
The ART mark.
position
The position (in device pixels) of the upper left corner of the dialog window.
See Also

Reference

PageView Class
PageView Members


ShowScrollBar Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ShowScrollBar Method
Change visibility state of scrollbars associated with window.
Overload List
Overload | Description
ShowScrollBar(ImGearScrollBarType,Boolean) | Change visibility state of scrollbars associated with window.
ShowScrollBar(ImGearScrollBarType,ImGearScrollBarModes) | Change visibility state of scrollbars associated with window.
See Also

Reference

PageView Class
PageView Members


ShowScrollBar(ImGearScrollBarType,Boolean) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class > ShowScrollBar Method : ShowScrollBar(ImGearScrollBarType,Boolean) Method
Specifies the scrollbar whose attributes are requested.
Show (true) or hide (false) scrollbar.
Change visibility state of scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ShowScrollBar(ImGearScrollBarType scrollBarType, ImGearScrollBarModes scrollMode) overload instead.")>
Public Overloads Sub ShowScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal state As Boolean _
)
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim state As Boolean

instance.ShowScrollBar(scrollBarType, state)
[Obsolete("Use the ShowScrollBar(ImGearScrollBarType scrollBarType, ImGearScrollBarModes scrollMode) overload instead.")]
public void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ShowScrollBar(ImGearScrollBarType scrollBarType, ImGearScrollBarModes scrollMode) overload instead.")]
public: void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
[Obsolete("Use the ShowScrollBar(ImGearScrollBarType scrollBarType, ImGearScrollBarModes scrollMode) overload instead.")]
public:
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
state
Show (true) or hide (false) scrollbar.
See Also

Reference

PageView Class
PageView Members
Overload List


ShowScrollBar(ImGearScrollBarType,ImGearScrollBarModes) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class > ShowScrollBar Method : ShowScrollBar(ImGearScrollBarType,ImGearScrollBarModes) Method
Specifies the scrollbar whose attributes are requested.
The visibility mode of the scrollbar.
Change visibility state of scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ShowScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollMode As ImGearScrollBarModes _
)
'Usage

Dim instance As PageView
Dim scrollBarType As ImGearScrollBarType
Dim scrollMode As ImGearScrollBarModes

instance.ShowScrollBar(scrollBarType, scrollMode)
public void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)
public: void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)
public:
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollMode
The visibility mode of the scrollbar.
See Also

Reference

PageView Class
PageView Members
Overload List


Update Method (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : Update Method
Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Overload List
Overload | Description
Update() | Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Update(Boolean) | Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
See Also

Reference

PageView Class
PageView Members


Update() Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class > Update Method : Update() Method
Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Update()
'Usage

Dim instance As PageView

instance.Update()
public void Update()
public: void Update();
public:
void Update();
See Also

Reference

PageView Class
PageView Members
Overload List


Update(Boolean) Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class > Update Method : Update(Boolean) Method
Whether the update should update layout only, or should rerender the image. Use true when only layout specific parameters have changed.
Causes a redraw of the display. Required anytime the underlying Display or Page object has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Update( _
   ByVal updateLayoutOnly As Boolean _
)
'Usage

Dim instance As PageView
Dim updateLayoutOnly As Boolean

instance.Update(updateLayoutOnly)
public void Update(
   bool updateLayoutOnly
)
public: void Update(
   bool updateLayoutOnly
)
public:
void Update(
   bool updateLayoutOnly
)

Parameters

updateLayoutOnly
Whether the update should update layout only, or should rerender the image. Use true when only layout specific parameters have changed.
See Also

Reference

PageView Class
PageView Members
Overload List


UpdateAnnotations Method

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : UpdateAnnotations Method
Whether the update should update layout only, or should recreate all the annotations. Use true when only layout specific parameters have changed and no new annotations added.
Causes a redraw of the annotations. Can be used instead of Update anytime only the annotations have been updated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UpdateAnnotations( _
   ByVal updateLayoutOnly As Boolean _
)
'Usage

Dim instance As PageView
Dim updateLayoutOnly As Boolean

instance.UpdateAnnotations(updateLayoutOnly)
public void UpdateAnnotations(
   bool updateLayoutOnly
)
public: void UpdateAnnotations(
   bool updateLayoutOnly
)
public:
void UpdateAnnotations(
   bool updateLayoutOnly
)

Parameters

updateLayoutOnly
Whether the update should update layout only, or should recreate all the annotations. Use true when only layout specific parameters have changed and no new annotations added.
See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%% $$Properties$$

PageView Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Properties
 | Name | Description
Public Property | AnnotationMode | Gets or sets the annotation mode.
Public Property | AnnotationScaleSettings | Gets or sets the engine for annotation scaling, as well as scale settings that are specific to this engine.
Public Property | Canvas | Gets canvas element used to contain image and other elements of the view.
Public Property | ClientRectangle | Gets the rectangle ImageGear display code should use as the client area rectangle.
Public Property | ContextMenuMark | Gets the mark that corresponds to the context menu.
Public Property | CreateNewPageDisplayForImage | Gets or sets a value indicating whether to create a new Display object for images.
Public Property | CustomMarkController | Gets or sets the custom mark controller to use when the MouseTool property is set to CreateCustomMark.
Public Property | DefaultPageNumber | Gets or sets page number in the file to be opened.
Public Property | Display | Gets or sets the ImGearPageDisplay Class object associated with the control, representing the image and display parameters.
Public Property | DragDropOpen | Gets or sets a value indicating whether hand drag and drop file opening is enabled or not.
Public Property | HorizontalLargeChange | Gets the horizontal ScrollBar large change increment settings.
Public Property | HorizontalSmallChange | Gets the horizontal ScrollBar small change increment settings.
Public Property | ImageScaleSettings | Gets or sets the engine for image scaling, as well as scale settings that are specific to this engine.
Public Property | InProgressMark | Gets or sets an ART mark to display immediately while creating an ART mark using the mouse.
Public Property | IsHandPanEnabled | This property has been deprecated. Gets or sets a value indicating whether hand panning is enabled or not. When true, clicking and dragging on the image will pan the image.
Public Property | IsMouseWheelScrollEnabled | Gets or sets a value indicating whether MouseWheel scrolling is enabled. If true, scrolling the mouse wheel over the control results in vertical scrolling.
Public Property | MarkBringToFrontCommand | Gets a command for bringing a mark to the front of the Z-order.
Public Property | MarkCopyCommand | Gets a command for copying a mark.
Public Property | MarkCutCommand | Gets a command for cutting a mark.
Public Property | MarkDeleteCommand | Gets a command for deleting a mark.
Public Property | MarkPasteCommand | Gets a command for pasting a mark.
Public Property | MarkSendToBackCommand | Gets a command for sending a mark to the back of the Z-order.
Public Property | MouseTool | Gets or sets the mouse tool.
Public Property | MouseToolSettings | Gets or sets an object that provides access to mouse tool settings.
Public Property | OpenAnnotations | Gets or sets a value indicating whether annotations will be opened.
Public Property | OpenDocument | Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Public Property | OpenImages | Gets or sets a value indicating whether images will be opened.
Public Property | Page | Gets or sets the ImGearPage Class associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay Class object.
Public Property | SetAntialiasCommand | Gets a command for setting antialias.
Public Property | SetFitModeCommand | Gets a command for setting the fit mode.
Public Property | SetImageGearScalingCommand | Gets a command for setting ImageGear scaling.
Public Property | SetMarkClosedCommand | Gets a command for setting mark Closed.
Public Property | SetMarkEndHeadTypeCommand | Gets a command for setting mark end head type.
Public Property | SetMarkEndLengthCommand | Gets a command for setting mark end length.
Public Property | SetMarkImageFitModeCommand | Gets a command for setting mark image fit mode.
Public Property | SetMarkOrientationCommand | Gets a command for setting mark orientation.
Public Property | SetMarkPinAlignmentCommand | Gets a command for setting mark pin alignment.
Public Property | SetMarkPrecisionCommand | Gets a command for setting mark precision.
Public Property | SetMarkStartHeadTypeCommand | Gets a command for setting mark start head type.
Public Property | SetMarkStartLengthCommand | Gets a command for setting mark start length.
Public Property | SetMarkStyleCommand | Gets a command for setting mark style or border style.
Public Property | SetMarkTextBorderShadingCommand | Gets a command for setting mark text border shading.
Public Property | SetMarkThicknessCommand | Gets a command for setting mark thickness or border thickness.
Public Property | SetResampleCommand | Gets a command for setting resampling.
Public Property | SetWPFScalingCommand | Gets a command for setting WPF scaling.
Public Property | ShowMarkPropertiesWindowCommand | Gets a command for showing a properties window for a mark.
Public Property | UpdateMode | Gets or sets whether the control updates automatically when the display settings or annotations change.
Public Property | VerticalLargeChange | Gets the vertical ScrollBar large change increment settings.
Public Property | VerticalSmallChange | Gets the vertical ScrollBar small change increment settings.
Public Property | ZoomCommand | Gets a command for zooming.
Top
See Also

Reference

PageView Class
ImageGear.Windows.Controls Namespace


AnnotationMode Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : AnnotationMode Property
Gets or sets the annotation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnnotationMode As ImGearAnnotationMode
'Usage

Dim instance As PageView
Dim value As ImGearAnnotationMode

instance.AnnotationMode = value

value = instance.AnnotationMode
public ImGearAnnotationMode AnnotationMode {get; set;}
public: __property ImGearAnnotationMode get_AnnotationMode();
public: __property void set_AnnotationMode(
   ImGearAnnotationMode value
);
public:
property ImGearAnnotationMode AnnotationMode {
   ImGearAnnotationMode get();
   void set (    ImGearAnnotationMode value);
}

Property Value

AnnotationMode enumeration value.
See Also

Reference

PageView Class
PageView Members


AnnotationScaleSettings Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : AnnotationScaleSettings Property
Gets or sets the engine for annotation scaling, as well as scale settings that are specific to this engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AnnotationScaleSettings As ImGearDisplayScaleSettings
'Usage

Dim instance As PageView
Dim value As ImGearDisplayScaleSettings

instance.AnnotationScaleSettings = value

value = instance.AnnotationScaleSettings
public ImGearDisplayScaleSettings AnnotationScaleSettings {get; set;}
public: __property ImGearDisplayScaleSettings* get_AnnotationScaleSettings();
public: __property void set_AnnotationScaleSettings(
   ImGearDisplayScaleSettings* value
);
public:
property ImGearDisplayScaleSettings^ AnnotationScaleSettings {
   ImGearDisplayScaleSettings^ get();
   void set (    ImGearDisplayScaleSettings^ value);
}

Property Value

ImageGear.Display.ImGearDisplayScaleSettings class object.
See Also

Reference

PageView Class
PageView Members


Canvas Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : Canvas Property
Gets canvas element used to contain image and other elements of the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As Canvas
'Usage

Dim instance As PageView
Dim value As Canvas

value = instance.Canvas
public Canvas Canvas {get;}
public: __property Canvas* get_Canvas();
public:
property Canvas^ Canvas {
   Canvas^ get();
}

Property Value

System.Windows.Controls.Canvas class object.
See Also

Reference

PageView Class
PageView Members


ClientRectangle Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ClientRectangle Property
Gets the rectangle ImageGear display code should use as the client area rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ClientRectangle As ImGearRectangle
'Usage

Dim instance As PageView
Dim value As ImGearRectangle

value = instance.ClientRectangle
public ImGearRectangle ClientRectangle {get;}
public: __property ImGearRectangle get_ClientRectangle();
public:
property ImGearRectangle ClientRectangle {
   ImGearRectangle get();
}

Property Value

ImageGear.Core.ImGearRectangle structure object.
See Also

Reference

PageView Class
PageView Members


ContextMenuMark Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ContextMenuMark Property
Gets the mark that corresponds to the context menu.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContextMenuMark As ImGearARTMark
'Usage

Dim instance As PageView
Dim value As ImGearARTMark

value = instance.ContextMenuMark
public ImGearARTMark ContextMenuMark {get;}
public: __property ImGearARTMark* get_ContextMenuMark();
public:
property ImGearARTMark^ ContextMenuMark {
   ImGearARTMark^ get();
}

Property Value

ImGearARTMark object.
Remarks
Returns null if the context menu is not currently displayed.
See Also

Reference

PageView Class
PageView Members


CreateNewPageDisplayForImage Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : CreateNewPageDisplayForImage Property
Gets or sets a value indicating whether to create a new Display object for images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property CreateNewPageDisplayForImage As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.CreateNewPageDisplayForImage = value

value = instance.CreateNewPageDisplayForImage
[Category("File Open Options")]
public bool CreateNewPageDisplayForImage {get; set;}
[Category("File Open Options")]
public: __property bool get_CreateNewPageDisplayForImage();
public: __property void set_CreateNewPageDisplayForImage(
   bool value
);
[Category("File Open Options")]
public:
property bool CreateNewPageDisplayForImage {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to true.

Value is used as initial default in FileOpeningEventArgs.CreateNewPageDisplayForImage for FileOpening event.

See Also

Reference

PageView Class
PageView Members


CustomMarkController Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : CustomMarkController Property
Gets or sets the custom mark controller to use when the MouseTool property is set to CreateCustomMark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomMarkController As String
'Usage

Dim instance As PageView
Dim value As String

instance.CustomMarkController = value

value = instance.CustomMarkController
public string CustomMarkController {get; set;}
public: __property string* get_CustomMarkController();
public: __property void set_CustomMarkController(
   string* value
);
public:
property String^ CustomMarkController {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

PageView Class
PageView Members


DefaultPageNumber Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : DefaultPageNumber Property
Gets or sets page number in the file to be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property DefaultPageNumber As Integer
'Usage

Dim instance As PageView
Dim value As Integer

instance.DefaultPageNumber = value

value = instance.DefaultPageNumber
[Category("File Open Options")]
public int DefaultPageNumber {get; set;}
[Category("File Open Options")]
public: __property int get_DefaultPageNumber();
public: __property void set_DefaultPageNumber(
   int value
);
[Category("File Open Options")]
public:
property int DefaultPageNumber {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks

Defaults to 0.

Value is used as initial default in FileOpeningEventArgs.PageNumber for FileOpening event.

See Also

Reference

PageView Class
PageView Members


Display Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : Display Property
Gets or sets the ImGearPageDisplay Class object associated with the control, representing the image and display parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Display As ImGearPresentationPageDisplay
'Usage

Dim instance As PageView
Dim value As ImGearPresentationPageDisplay

instance.Display = value

value = instance.Display
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public ImGearPresentationPageDisplay Display {get; set;}
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ImGearPresentationPageDisplay* get_Display();
public: __property void set_Display(
   ImGearPresentationPageDisplay* value
);
[Bindable(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ImGearPresentationPageDisplay^ Display {
   ImGearPresentationPageDisplay^ get();
   void set (    ImGearPresentationPageDisplay^ value);
}

Property Value

ImageGear.Display.ImGearPresentationPageDisplay class object.
See Also

Reference

PageView Class
PageView Members


DragDropOpen Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : DragDropOpen Property
Gets or sets a value indicating whether hand drag and drop file opening is enabled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property DragDropOpen As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.DragDropOpen = value

value = instance.DragDropOpen
[Category("File Open Options")]
public bool DragDropOpen {get; set;}
[Category("File Open Options")]
public: __property bool get_DragDropOpen();
public: __property void set_DragDropOpen(
   bool value
);
[Category("File Open Options")]
public:
property bool DragDropOpen {
   bool get();
   void set (    bool value);
}

Property Value

System.Boolean structure object.
Remarks

Default value is false.

When true, dragging a file onto the PageView will trigger opening of the file and associating it with the PageView.

The OpenImages, OpenAnnotations, DefaultPageNumber, CreateNewPageDisplayForImage, and OpenDocument properties can be used to control default loading behavior. In addition the FileOpening event can be used to control loading and FileOpened event can be used to get the results of loading.

See Also

Reference

PageView Class
PageView Members


HorizontalLargeChange Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : HorizontalLargeChange Property
Gets the horizontal ScrollBar large change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalLargeChange As ScrollBarIncrement
'Usage

Dim instance As PageView
Dim value As ScrollBarIncrement

value = instance.HorizontalLargeChange
public ScrollBarIncrement HorizontalLargeChange {get;}
public: __property ScrollBarIncrement* get_HorizontalLargeChange();
public:
property ScrollBarIncrement^ HorizontalLargeChange {
   ScrollBarIncrement^ get();
}

Property Value

ImageGear.Windows.Controls.ScrollBarIncrement class object.
See Also

Reference

PageView Class
PageView Members


HorizontalSmallChange Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : HorizontalSmallChange Property
Gets the horizontal ScrollBar small change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalSmallChange As ScrollBarIncrement
'Usage

Dim instance As PageView
Dim value As ScrollBarIncrement

value = instance.HorizontalSmallChange
public ScrollBarIncrement HorizontalSmallChange {get;}
public: __property ScrollBarIncrement* get_HorizontalSmallChange();
public:
property ScrollBarIncrement^ HorizontalSmallChange {
   ScrollBarIncrement^ get();
}

Property Value

ImageGear.Windows.Controls.ScrollBarIncrement class object.
See Also

Reference

PageView Class
PageView Members


ImageScaleSettings Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ImageScaleSettings Property
Gets or sets the engine for image scaling, as well as scale settings that are specific to this engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageScaleSettings As ImGearDisplayScaleSettings
'Usage

Dim instance As PageView
Dim value As ImGearDisplayScaleSettings

instance.ImageScaleSettings = value

value = instance.ImageScaleSettings
public ImGearDisplayScaleSettings ImageScaleSettings {get; set;}
public: __property ImGearDisplayScaleSettings* get_ImageScaleSettings();
public: __property void set_ImageScaleSettings(
   ImGearDisplayScaleSettings* value
);
public:
property ImGearDisplayScaleSettings^ ImageScaleSettings {
   ImGearDisplayScaleSettings^ get();
   void set (    ImGearDisplayScaleSettings^ value);
}

Property Value

ImageGear.Display.ImGearDisplayScaleSettings class object.
See Also

Reference

PageView Class
PageView Members


InProgressMark Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : InProgressMark Property
Gets or sets an ART mark to display immediately while creating an ART mark using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InProgressMark As ImGearARTMark
'Usage

Dim instance As PageView
Dim value As ImGearARTMark

instance.InProgressMark = value

value = instance.InProgressMark
public ImGearARTMark InProgressMark {get; set;}
public: __property ImGearARTMark* get_InProgressMark();
public: __property void set_InProgressMark(
   ImGearARTMark* value
);
public:
property ImGearARTMark^ InProgressMark {
   ImGearARTMark^ get();
   void set (    ImGearARTMark^ value);
}

Property Value

ImGearARTMark value.
Remarks

This property can be used in the PageView mouse event handlers to display a mark, such as a custom mark, while using the mouse to add a mark (before the mark is actually added to the PageView ART page). The InProgressMark property is set internally while a non-custom mark is being drawn using the mouse, and the property is automatically reset to null after a mark is created. The mark is displayed using image coordinates and is separate from the PageView control's ART page.

If the InProgressMark is an ImGearARTPolyline, then the IsClosed property of the InProgressMark will have no effect. If the IsClosed property of the template mark (specified by the ImGearAnnotationTemplates Polyline or Freehand property) is true, then the polyline is drawn as closed. If it is false, then the ImGearAnnotationSettings IsPolylineAutoCloseEnabled and PolyMarkPointRadiusThreshold properties are used to determine whether the polyline is drawn as closed.

See Also

Reference

PageView Class
PageView Members


IsHandPanEnabled Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsHandPanEnabled Property
This property has been deprecated. Gets or sets a value indicating whether hand panning is enabled or not. When true, clicking and dragging on the image will pan the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Set the MouseTool property to HandPan instead.")>
Public Property IsHandPanEnabled As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.IsHandPanEnabled = value

value = instance.IsHandPanEnabled
[Obsolete("Set the MouseTool property to HandPan instead.")]
public bool IsHandPanEnabled {get; set;}
[Obsolete("Set the MouseTool property to HandPan instead.")]
public: __property bool get_IsHandPanEnabled();
public: __property void set_IsHandPanEnabled(
   bool value
);
[Obsolete("Set the MouseTool property to HandPan instead.")]
public:
property bool IsHandPanEnabled {
   bool get();
   void set (    bool value);
}

Property Value

System.Boolean structure object.
Remarks
This property has been deprecated. Set the MouseTool property to HandPan instead.
See Also

Reference

PageView Class
PageView Members


IsMouseWheelScrollEnabled Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsMouseWheelScrollEnabled Property
Gets or sets a value indicating whether MouseWheel scrolling is enabled. If true, scrolling the mouse wheel over the control results in vertical scrolling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsMouseWheelScrollEnabled As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.IsMouseWheelScrollEnabled = value

value = instance.IsMouseWheelScrollEnabled
public bool IsMouseWheelScrollEnabled {get; set;}
public: __property bool get_IsMouseWheelScrollEnabled();
public: __property void set_IsMouseWheelScrollEnabled(
   bool value
);
public:
property bool IsMouseWheelScrollEnabled {
   bool get();
   void set (    bool value);
}

Property Value

System.Boolean value.
Remarks
Defaults to true.
See Also

Reference

PageView Class
PageView Members


MarkBringToFrontCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkBringToFrontCommand Property
Gets a command for bringing a mark to the front of the Z-order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkBringToFrontCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkBringToFrontCommand
public ICommand MarkBringToFrontCommand {get;}
public: __property ICommand* get_MarkBringToFrontCommand();
public:
property ICommand^ MarkBringToFrontCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MarkCopyCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkCopyCommand Property
Gets a command for copying a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkCopyCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkCopyCommand
public ICommand MarkCopyCommand {get;}
public: __property ICommand* get_MarkCopyCommand();
public:
property ICommand^ MarkCopyCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MarkCutCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkCutCommand Property
Gets a command for cutting a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkCutCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkCutCommand
public ICommand MarkCutCommand {get;}
public: __property ICommand* get_MarkCutCommand();
public:
property ICommand^ MarkCutCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MarkDeleteCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkDeleteCommand Property
Gets a command for deleting a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkDeleteCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkDeleteCommand
public ICommand MarkDeleteCommand {get;}
public: __property ICommand* get_MarkDeleteCommand();
public:
property ICommand^ MarkDeleteCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MarkPasteCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkPasteCommand Property
Gets a command for pasting a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkPasteCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkPasteCommand
public ICommand MarkPasteCommand {get;}
public: __property ICommand* get_MarkPasteCommand();
public:
property ICommand^ MarkPasteCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MarkSendToBackCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkSendToBackCommand Property
Gets a command for sending a mark to the back of the Z-order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MarkSendToBackCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.MarkSendToBackCommand
public ICommand MarkSendToBackCommand {get;}
public: __property ICommand* get_MarkSendToBackCommand();
public:
property ICommand^ MarkSendToBackCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


MouseTool Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MouseTool Property
Gets or sets the mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseTool As ImGearMouseTool
'Usage

Dim instance As PageView
Dim value As ImGearMouseTool

instance.MouseTool = value

value = instance.MouseTool
public ImGearMouseTool MouseTool {get; set;}
public: __property ImGearMouseTool get_MouseTool();
public: __property void set_MouseTool(
   ImGearMouseTool value
);
public:
property ImGearMouseTool MouseTool {
   ImGearMouseTool get();
   void set (    ImGearMouseTool value);
}

Property Value

MouseTool enumeration value.
Remarks
If the annotation assembly is not available, an exception will occur when setting an annotation mouse tool.
See Also

Reference

PageView Class
PageView Members


MouseToolSettings Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MouseToolSettings Property
Gets or sets an object that provides access to mouse tool settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseToolSettings As ImGearMouseToolSettings
'Usage

Dim instance As PageView
Dim value As ImGearMouseToolSettings

instance.MouseToolSettings = value

value = instance.MouseToolSettings
public ImGearMouseToolSettings MouseToolSettings {get; set;}
public: __property ImGearMouseToolSettings* get_MouseToolSettings();
public: __property void set_MouseToolSettings(
   ImGearMouseToolSettings* value
);
public:
property ImGearMouseToolSettings^ MouseToolSettings {
   ImGearMouseToolSettings^ get();
   void set (    ImGearMouseToolSettings^ value);
}

Property Value

A MouseToolSettings object.
See Also

Reference

PageView Class
PageView Members


OpenAnnotations Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenAnnotations Property
Gets or sets a value indicating whether annotations will be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property OpenAnnotations As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.OpenAnnotations = value

value = instance.OpenAnnotations
[Category("File Open Options")]
public bool OpenAnnotations {get; set;}
[Category("File Open Options")]
public: __property bool get_OpenAnnotations();
public: __property void set_OpenAnnotations(
   bool value
);
[Category("File Open Options")]
public:
property bool OpenAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to false.

Value is used as initial default in FileOpeningEventArgs.OpenAnnotations for FileOpening event.

If set to true, then the ART assembly is required.

See Also

Reference

PageView Class
PageView Members


OpenDocument Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenDocument Property
Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property OpenDocument As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.OpenDocument = value

value = instance.OpenDocument
[Category("File Open Options")]
public bool OpenDocument {get; set;}
[Category("File Open Options")]
public: __property bool get_OpenDocument();
public: __property void set_OpenDocument(
   bool value
);
[Category("File Open Options")]
public:
property bool OpenDocument {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to false.

If no display object exists, a new will always be created.

Value is used as initial default in FileOpeningEventArgs.OpenDocument for FileOpening event.

See Also

Reference

PageView Class
PageView Members


OpenImages Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenImages Property
Gets or sets a value indicating whether images will be opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("File Open Options")>
Public Property OpenImages As Boolean
'Usage

Dim instance As PageView
Dim value As Boolean

instance.OpenImages = value

value = instance.OpenImages
[Category("File Open Options")]
public bool OpenImages {get; set;}
[Category("File Open Options")]
public: __property bool get_OpenImages();
public: __property void set_OpenImages(
   bool value
);
[Category("File Open Options")]
public:
property bool OpenImages {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks

Defaults to true.

Value is used as initial default in FileOpeningEventArgs.OpenImages for FileOpening event.

See Also

Reference

PageView Class
PageView Members


Page Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : Page Property
Gets or sets the ImGearPage Class associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay Class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearPage
'Usage

Dim instance As PageView
Dim value As ImGearPage

instance.Page = value

value = instance.Page
public ImGearPage Page {get; set;}
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

PageView Class
PageView Members


SetAntialiasCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetAntialiasCommand Property
Gets a command for setting antialias.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetAntialiasCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetAntialiasCommand
public ICommand SetAntialiasCommand {get;}
public: __property ICommand* get_SetAntialiasCommand();
public:
property ICommand^ SetAntialiasCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetFitModeCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetFitModeCommand Property
Gets a command for setting the fit mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetFitModeCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetFitModeCommand
public ICommand SetFitModeCommand {get;}
public: __property ICommand* get_SetFitModeCommand();
public:
property ICommand^ SetFitModeCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetImageGearScalingCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetImageGearScalingCommand Property
Gets a command for setting ImageGear scaling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetImageGearScalingCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetImageGearScalingCommand
public ICommand SetImageGearScalingCommand {get;}
public: __property ICommand* get_SetImageGearScalingCommand();
public:
property ICommand^ SetImageGearScalingCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkClosedCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkClosedCommand Property
Gets a command for setting mark Closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkClosedCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkClosedCommand
public ICommand SetMarkClosedCommand {get;}
public: __property ICommand* get_SetMarkClosedCommand();
public:
property ICommand^ SetMarkClosedCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkEndHeadTypeCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkEndHeadTypeCommand Property
Gets a command for setting mark end head type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkEndHeadTypeCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkEndHeadTypeCommand
public ICommand SetMarkEndHeadTypeCommand {get;}
public: __property ICommand* get_SetMarkEndHeadTypeCommand();
public:
property ICommand^ SetMarkEndHeadTypeCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkEndLengthCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkEndLengthCommand Property
Gets a command for setting mark end length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkEndLengthCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkEndLengthCommand
public ICommand SetMarkEndLengthCommand {get;}
public: __property ICommand* get_SetMarkEndLengthCommand();
public:
property ICommand^ SetMarkEndLengthCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkImageFitModeCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkImageFitModeCommand Property
Gets a command for setting mark image fit mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkImageFitModeCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkImageFitModeCommand
public ICommand SetMarkImageFitModeCommand {get;}
public: __property ICommand* get_SetMarkImageFitModeCommand();
public:
property ICommand^ SetMarkImageFitModeCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkOrientationCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkOrientationCommand Property
Gets a command for setting mark orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkOrientationCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkOrientationCommand
public ICommand SetMarkOrientationCommand {get;}
public: __property ICommand* get_SetMarkOrientationCommand();
public:
property ICommand^ SetMarkOrientationCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkPinAlignmentCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkPinAlignmentCommand Property
Gets a command for setting mark pin alignment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkPinAlignmentCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkPinAlignmentCommand
public ICommand SetMarkPinAlignmentCommand {get;}
public: __property ICommand* get_SetMarkPinAlignmentCommand();
public:
property ICommand^ SetMarkPinAlignmentCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkPrecisionCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkPrecisionCommand Property
Gets a command for setting mark precision.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkPrecisionCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkPrecisionCommand
public ICommand SetMarkPrecisionCommand {get;}
public: __property ICommand* get_SetMarkPrecisionCommand();
public:
property ICommand^ SetMarkPrecisionCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkStartHeadTypeCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkStartHeadTypeCommand Property
Gets a command for setting mark start head type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkStartHeadTypeCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkStartHeadTypeCommand
public ICommand SetMarkStartHeadTypeCommand {get;}
public: __property ICommand* get_SetMarkStartHeadTypeCommand();
public:
property ICommand^ SetMarkStartHeadTypeCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkStartLengthCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkStartLengthCommand Property
Gets a command for setting mark start length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkStartLengthCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkStartLengthCommand
public ICommand SetMarkStartLengthCommand {get;}
public: __property ICommand* get_SetMarkStartLengthCommand();
public:
property ICommand^ SetMarkStartLengthCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkStyleCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkStyleCommand Property
Gets a command for setting mark style or border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkStyleCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkStyleCommand
public ICommand SetMarkStyleCommand {get;}
public: __property ICommand* get_SetMarkStyleCommand();
public:
property ICommand^ SetMarkStyleCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkTextBorderShadingCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkTextBorderShadingCommand Property
Gets a command for setting mark text border shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkTextBorderShadingCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkTextBorderShadingCommand
public ICommand SetMarkTextBorderShadingCommand {get;}
public: __property ICommand* get_SetMarkTextBorderShadingCommand();
public:
property ICommand^ SetMarkTextBorderShadingCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetMarkThicknessCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetMarkThicknessCommand Property
Gets a command for setting mark thickness or border thickness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetMarkThicknessCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetMarkThicknessCommand
public ICommand SetMarkThicknessCommand {get;}
public: __property ICommand* get_SetMarkThicknessCommand();
public:
property ICommand^ SetMarkThicknessCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetResampleCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetResampleCommand Property
Gets a command for setting resampling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetResampleCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetResampleCommand
public ICommand SetResampleCommand {get;}
public: __property ICommand* get_SetResampleCommand();
public:
property ICommand^ SetResampleCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


SetWPFScalingCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : SetWPFScalingCommand Property
Gets a command for setting WPF scaling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SetWPFScalingCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.SetWPFScalingCommand
public ICommand SetWPFScalingCommand {get;}
public: __property ICommand* get_SetWPFScalingCommand();
public:
property ICommand^ SetWPFScalingCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


ShowMarkPropertiesWindowCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ShowMarkPropertiesWindowCommand Property
Gets a command for showing a properties window for a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ShowMarkPropertiesWindowCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.ShowMarkPropertiesWindowCommand
public ICommand ShowMarkPropertiesWindowCommand {get;}
public: __property ICommand* get_ShowMarkPropertiesWindowCommand();
public:
property ICommand^ ShowMarkPropertiesWindowCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


UpdateMode Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : UpdateMode Property
Gets or sets whether the control updates automatically when the display settings or annotations change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UpdateMode As ImGearUpdateMode
'Usage

Dim instance As PageView
Dim value As ImGearUpdateMode

instance.UpdateMode = value

value = instance.UpdateMode
public ImGearUpdateMode UpdateMode {get; set;}
public: __property ImGearUpdateMode get_UpdateMode();
public: __property void set_UpdateMode(
   ImGearUpdateMode value
);
public:
property ImGearUpdateMode UpdateMode {
   ImGearUpdateMode get();
   void set (    ImGearUpdateMode value);
}

Property Value

UpdateMode enumeration value.
See Also

Reference

PageView Class
PageView Members


VerticalLargeChange Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : VerticalLargeChange Property
Gets the vertical ScrollBar large change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalLargeChange As ScrollBarIncrement
'Usage

Dim instance As PageView
Dim value As ScrollBarIncrement

value = instance.VerticalLargeChange
public ScrollBarIncrement VerticalLargeChange {get;}
public: __property ScrollBarIncrement* get_VerticalLargeChange();
public:
property ScrollBarIncrement^ VerticalLargeChange {
   ScrollBarIncrement^ get();
}

Property Value

ImageGear.Windows.Controls.ScrollBarIncrement class object.
See Also

Reference

PageView Class
PageView Members


VerticalSmallChange Property (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : VerticalSmallChange Property
Gets the vertical ScrollBar small change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalSmallChange As ScrollBarIncrement
'Usage

Dim instance As PageView
Dim value As ScrollBarIncrement

value = instance.VerticalSmallChange
public ScrollBarIncrement VerticalSmallChange {get;}
public: __property ScrollBarIncrement* get_VerticalSmallChange();
public:
property ScrollBarIncrement^ VerticalSmallChange {
   ScrollBarIncrement^ get();
}

Property Value

ImageGear.Windows.Controls.ScrollBarIncrement class object.
See Also

Reference

PageView Class
PageView Members


ZoomCommand Property

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ZoomCommand Property
Gets a command for zooming.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ZoomCommand As ICommand
'Usage

Dim instance As PageView
Dim value As ICommand

value = instance.ZoomCommand
public ICommand ZoomCommand {get;}
public: __property ICommand* get_ZoomCommand();
public:
property ICommand^ ZoomCommand {
   ICommand^ get();
}

Property Value

ICommand object.
See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%% $$Fields$$

PageView Class Fields

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AnnotationModeProperty | Represents AnnotationMode dependency property.
static (Shared in Visual Basic) | CreateNewPageDisplayForImageProperty | DependencyProperty for CreateNewPageDisplayForImage.
static (Shared in Visual Basic) | CustomMarkControllerProperty | Represents CustomMarkController dependency property.
static (Shared in Visual Basic) | DefaultPageNumberProperty | DependencyProperty for DefaultPageNumber.
static (Shared in Visual Basic) | DisplayProperty | Represents Display dependency property.
static (Shared in Visual Basic) | DragDropOpenProperty | DependencyProperty for DragDropOpen.
static (Shared in Visual Basic) | IsHandPanEnabledProperty | This property has been deprecated. Dependency property for IsHandPanEnabled.
static (Shared in Visual Basic) | IsMouseWheelScrollEnabledProperty | Dependency property for IsMouseWheelScrollEnabled.
static (Shared in Visual Basic) | MouseToolProperty | Represents MouseTool dependency property.
static (Shared in Visual Basic) | MouseToolSettingsProperty | Represents MouseToolSettings dependency property.
static (Shared in Visual Basic) | OpenAnnotationsProperty | DependencyProperty for OpenAnnotations.
static (Shared in Visual Basic) | OpenDocumentProperty | DependencyProperty for OpenDocument.
static (Shared in Visual Basic) | OpenImagesProperty | DependencyProperty for OpenImages.
Top
See Also

Reference

PageView Class
ImageGear.Windows.Controls Namespace


AnnotationModeProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : AnnotationModeProperty Field
Represents AnnotationMode dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AnnotationModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.AnnotationModeProperty
public static readonly DependencyProperty AnnotationModeProperty
public: static readonly DependencyProperty* AnnotationModeProperty
public:
static readonly DependencyProperty^ AnnotationModeProperty
See Also

Reference

PageView Class
PageView Members


CreateNewPageDisplayForImageProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : CreateNewPageDisplayForImageProperty Field
DependencyProperty for CreateNewPageDisplayForImage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CreateNewPageDisplayForImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.CreateNewPageDisplayForImageProperty
public static readonly DependencyProperty CreateNewPageDisplayForImageProperty
public: static readonly DependencyProperty* CreateNewPageDisplayForImageProperty
public:
static readonly DependencyProperty^ CreateNewPageDisplayForImageProperty
See Also

Reference

PageView Class
PageView Members


CustomMarkControllerProperty Field (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : CustomMarkControllerProperty Field
Represents CustomMarkController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CustomMarkControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.CustomMarkControllerProperty
public static readonly DependencyProperty CustomMarkControllerProperty
public: static readonly DependencyProperty* CustomMarkControllerProperty
public:
static readonly DependencyProperty^ CustomMarkControllerProperty
See Also

Reference

PageView Class
PageView Members


DefaultPageNumberProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : DefaultPageNumberProperty Field
DependencyProperty for DefaultPageNumber.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DefaultPageNumberProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.DefaultPageNumberProperty
public static readonly DependencyProperty DefaultPageNumberProperty
public: static readonly DependencyProperty* DefaultPageNumberProperty
public:
static readonly DependencyProperty^ DefaultPageNumberProperty
See Also

Reference

PageView Class
PageView Members


DisplayProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : DisplayProperty Field
Represents Display dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.DisplayProperty
public static readonly DependencyProperty DisplayProperty
public: static readonly DependencyProperty* DisplayProperty
public:
static readonly DependencyProperty^ DisplayProperty
See Also

Reference

PageView Class
PageView Members


DragDropOpenProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : DragDropOpenProperty Field
DependencyProperty for DragDropOpen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DragDropOpenProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.DragDropOpenProperty
public static readonly DependencyProperty DragDropOpenProperty
public: static readonly DependencyProperty* DragDropOpenProperty
public:
static readonly DependencyProperty^ DragDropOpenProperty
See Also

Reference

PageView Class
PageView Members


IsHandPanEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsHandPanEnabledProperty Field
This property has been deprecated. Dependency property for IsHandPanEnabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Set the MouseTool property to HandPan instead.")>
Public Shared ReadOnly IsHandPanEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.IsHandPanEnabledProperty
[Obsolete("Set the MouseTool property to HandPan instead.")]
public static readonly DependencyProperty IsHandPanEnabledProperty
[Obsolete("Set the MouseTool property to HandPan instead.")]
public: static readonly DependencyProperty* IsHandPanEnabledProperty
[Obsolete("Set the MouseTool property to HandPan instead.")]
public:
static readonly DependencyProperty^ IsHandPanEnabledProperty
Remarks
This property has been deprecated. Set the MouseTool property to HandPan instead.
See Also

Reference

PageView Class
PageView Members


IsMouseWheelScrollEnabledProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : IsMouseWheelScrollEnabledProperty Field
Dependency property for IsMouseWheelScrollEnabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsMouseWheelScrollEnabledProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.IsMouseWheelScrollEnabledProperty
public static readonly DependencyProperty IsMouseWheelScrollEnabledProperty
public: static readonly DependencyProperty* IsMouseWheelScrollEnabledProperty
public:
static readonly DependencyProperty^ IsMouseWheelScrollEnabledProperty
See Also

Reference

PageView Class
PageView Members


MouseToolProperty Field (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MouseToolProperty Field
Represents MouseTool dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MouseToolProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.MouseToolProperty
public static readonly DependencyProperty MouseToolProperty
public: static readonly DependencyProperty* MouseToolProperty
public:
static readonly DependencyProperty^ MouseToolProperty
See Also

Reference

PageView Class
PageView Members


MouseToolSettingsProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MouseToolSettingsProperty Field
Represents MouseToolSettings dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MouseToolSettingsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.MouseToolSettingsProperty
public static readonly DependencyProperty MouseToolSettingsProperty
public: static readonly DependencyProperty* MouseToolSettingsProperty
public:
static readonly DependencyProperty^ MouseToolSettingsProperty
See Also

Reference

PageView Class
PageView Members


OpenAnnotationsProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenAnnotationsProperty Field
DependencyProperty for OpenAnnotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OpenAnnotationsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.OpenAnnotationsProperty
public static readonly DependencyProperty OpenAnnotationsProperty
public: static readonly DependencyProperty* OpenAnnotationsProperty
public:
static readonly DependencyProperty^ OpenAnnotationsProperty
See Also

Reference

PageView Class
PageView Members


OpenDocumentProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenDocumentProperty Field
DependencyProperty for OpenDocument.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OpenDocumentProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.OpenDocumentProperty
public static readonly DependencyProperty OpenDocumentProperty
public: static readonly DependencyProperty* OpenDocumentProperty
public:
static readonly DependencyProperty^ OpenDocumentProperty
See Also

Reference

PageView Class
PageView Members


OpenImagesProperty Field

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : OpenImagesProperty Field
DependencyProperty for OpenImages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OpenImagesProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = PageView.OpenImagesProperty
public static readonly DependencyProperty OpenImagesProperty
public: static readonly DependencyProperty* OpenImagesProperty
public:
static readonly DependencyProperty^ OpenImagesProperty
See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%% $$Events$$

PageView Class Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Events
 | Name | Description
Public Event | FileOpened | Event triggered after a file has been opened by the PageView control.
Public Event | FileOpening | Event triggered before a file is opened by the PageView control.
Public Event | MarkAdded | Occurs when a mark is added.
Public Event | MarkChanged | Occurs when a mark is changed.
Public Event | MarkCreating | Occurs when a mark is added using the mouse.
Public Event | MarkRemoved | Occurs when a mark is removed.
Public Event | MarkSelectionChanged | Occurs when a mark's selection is changed.
Public Event | MarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Public Event | PageScrolled | Occurs when a pages is scrolled.
Public Event | PageZoomed | Occurs when a page is zoomed.
Public Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Public Event | ScrollChanged | Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Public Event | Updated | Occurs after an update of the image has occurred.
Top
See Also

Reference

PageView Class
ImageGear.Windows.Controls Namespace


FileOpened Event

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : FileOpened Event
Event triggered after a file has been opened by the PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FileOpened As EventHandler(Of FileOpenedEventArgs)
'Usage

Dim instance As PageView
Dim handler As EventHandler(Of FileOpenedEventArgs)

AddHandler instance.FileOpened, handler
public event EventHandler<FileOpenedEventArgs> FileOpened
public: __event EventHandler<FileOpenedEventArgs*>* FileOpened
public:
event EventHandler<FileOpenedEventArgs^>^ FileOpened
Event Data

The event handler receives an argument of type FileOpenedEventArgs containing data related to this event. The following FileOpenedEventArgs properties provide information specific to this event.

Property | Description
ARTPage | Gets ImGearAnnotationPage loaded into the page view control. Set to null if no annotations were loaded.
Document | Gets ImGearDocument loaded for the file if requested, otherwise null.
File | Gets FileInfo of file dropped on PageView control.
Page | Gets ImGearPage loaded into the page view control. Set to null if no page was loaded.
PageNumber | Gets Page number of the image or annotation loaded from the file.
Remarks

Depends upon DragDropOpen being set to true.

Properties of the FileOpenedEventArgs object contain the results of the opening.

See Also

Reference

PageView Class
PageView Members


FileOpening Event

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : FileOpening Event
Event triggered before a file is opened by the PageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FileOpening As EventHandler(Of FileOpeningEventArgs)
'Usage

Dim instance As PageView
Dim handler As EventHandler(Of FileOpeningEventArgs)

AddHandler instance.FileOpening, handler
public event EventHandler<FileOpeningEventArgs> FileOpening
public: __event EventHandler<FileOpeningEventArgs*>* FileOpening
public:
event EventHandler<FileOpeningEventArgs^>^ FileOpening
Event Data

The event handler receives an argument of type FileOpeningEventArgs containing data related to this event. The following FileOpeningEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether to cancel opening of the file.
CreateNewPageDisplayForImage | Gets or sets a value indicating whether to create a new Display object for images.
File | Gets FileInfo of file dropped on PageView control. Also contains method to open the file.
OpenAnnotations | Gets or sets a value indicating whether annotations will be opened.
OpenDocument | Gets or sets a value indicating whether to open an ImageGear.Core.ImGearDocument for images.
OpenImages | Gets or sets a value indicating whether images will be opened.
PageNumber | Gets or sets page number in the file to be opened.
Remarks

Depends upon DragDropOpen being set to true.

Properties of the FileOpeningEventArgs object can be used to control loading behavior.

See Also

Reference

PageView Class
PageView Members


MarkAdded Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkAdded Event
Occurs when a mark is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkAdded As ImGearARTMarkEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkAdded, handler
public event ImGearARTMarkEventHandler MarkAdded
public: __event ImGearARTMarkEventHandler* MarkAdded
public:
event ImGearARTMarkEventHandler^ MarkAdded
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


MarkChanged Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkChanged Event
Occurs when a mark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkChanged, handler
public event ImGearARTMarkEventHandler MarkChanged
public: __event ImGearARTMarkEventHandler* MarkChanged
public:
event ImGearARTMarkEventHandler^ MarkChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


MarkCreating Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkCreating Event
Occurs when a mark is added using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkCreating As ImGearMarkCreatingEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearMarkCreatingEventHandler

AddHandler instance.MarkCreating, handler
public event ImGearMarkCreatingEventHandler MarkCreating
public: __event ImGearMarkCreatingEventHandler* MarkCreating
public:
event ImGearMarkCreatingEventHandler^ MarkCreating
Event Data

The event handler receives an argument of type ImGearMarkCreatingEventArgs containing data related to this event. The following ImGearMarkCreatingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the mark will be created.
Mark | Gets or sets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


MarkRemoved Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkRemoved Event
Occurs when a mark is removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkRemoved As ImGearARTMarkEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkRemoved, handler
public event ImGearARTMarkEventHandler MarkRemoved
public: __event ImGearARTMarkEventHandler* MarkRemoved
public:
event ImGearARTMarkEventHandler^ MarkRemoved
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


MarkSelectionChanged Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkSelectionChanged Event
Occurs when a mark's selection is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkSelectionChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkSelectionChanged, handler
public event ImGearARTMarkEventHandler MarkSelectionChanged
public: __event ImGearARTMarkEventHandler* MarkSelectionChanged
public:
event ImGearARTMarkEventHandler^ MarkSelectionChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


MarkZOrderChanged Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : MarkZOrderChanged Event
Occurs when a mark's Z-Order is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event MarkZOrderChanged As ImGearARTMarkEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearARTMarkEventHandler

AddHandler instance.MarkZOrderChanged, handler
public event ImGearARTMarkEventHandler MarkZOrderChanged
public: __event ImGearARTMarkEventHandler* MarkZOrderChanged
public:
event ImGearARTMarkEventHandler^ MarkZOrderChanged
Event Data

The event handler receives an argument of type ImGearARTMarkEventArgs containing data related to this event. The following ImGearARTMarkEventArgs properties provide information specific to this event.

Property | Description
Mark | Gets the mark in which the event fired.
See Also

Reference

PageView Class
PageView Members


PageScrolled Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : PageScrolled Event
Occurs when a pages is scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Use the ScrollChanged event instead.")>
Public Event PageScrolled As EventHandler
'Usage

Dim instance As PageView
Dim handler As EventHandler

AddHandler instance.PageScrolled, handler
[Obsolete("Use the ScrollChanged event instead.")]
public event EventHandler PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public: __event EventHandler* PageScrolled
[Obsolete("Use the ScrollChanged event instead.")]
public:
event EventHandler^ PageScrolled
See Also

Reference

PageView Class
PageView Members


PageZoomed Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : PageZoomed Event
Occurs when a page is zoomed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageZoomed As EventHandler
'Usage

Dim instance As PageView
Dim handler As EventHandler

AddHandler instance.PageZoomed, handler
public event EventHandler PageZoomed
public: __event EventHandler* PageZoomed
public:
event EventHandler^ PageZoomed
See Also

Reference

PageView Class
PageView Members


RequerySuggested Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : RequerySuggested Event
Occurs when the command manager detects conditions that might change the ability of a command to execute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event RequerySuggested As EventHandler
'Usage

Dim instance As PageView
Dim handler As EventHandler

AddHandler instance.RequerySuggested, handler
public event EventHandler RequerySuggested
public: __event EventHandler* RequerySuggested
public:
event EventHandler^ RequerySuggested
See Also

Reference

PageView Class
PageView Members


ScrollChanged Event (PageView)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : ScrollChanged Event
Occurs when a page is scrolled or when the scrollbar visible or enabled state changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ScrollChanged As ImGearScrollChangedEventHandler
'Usage

Dim instance As PageView
Dim handler As ImGearScrollChangedEventHandler

AddHandler instance.ScrollChanged, handler
public event ImGearScrollChangedEventHandler ScrollChanged
public: __event ImGearScrollChangedEventHandler* ScrollChanged
public:
event ImGearScrollChangedEventHandler^ ScrollChanged
Event Data

The event handler receives an argument of type ImGearScrollChangedEventArgs containing data related to this event. The following ImGearScrollChangedEventArgs properties provide information specific to this event.

Property | Description
IsEnabled | Gets a value indicating whether the scrollbar is enabled.
IsVisible | Gets a value indicating whether the scrollbar is visible.
Redraw | Gets a value indicating whether or not the view should be redrawn.
ScrollBarType | Gets the type (horizontal or vertical) of the scrollbar that is being scrolled.
ScrollChangeType | Gets the type of scrollbar change.
ScrollInformation | Gets the scrolling information.
See Also

Reference

PageView Class
PageView Members


Updated Event

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > PageView Class : Updated Event
Occurs after an update of the image has occurred.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Updated As EventHandler
'Usage

Dim instance As PageView
Dim handler As EventHandler

AddHandler instance.Updated, handler
public event EventHandler Updated
public: __event EventHandler* Updated
public:
event EventHandler^ Updated
See Also

Reference

PageView Class
PageView Members


%%PageItemTitle%%

ScrollBarIncrement Class
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ScrollBarIncrement Class
Settings for a scroll bar increment including the value of the increment and what type of value.
Object Model
ScrollBarIncrement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ScrollBarIncrement
'Usage

Dim instance As ScrollBarIncrement
public class ScrollBarIncrement
public __gc class ScrollBarIncrement
public ref class ScrollBarIncrement
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ScrollBarIncrement

See Also

Reference

ScrollBarIncrement Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ScrollBarIncrement Class Members
Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ScrollBarIncrement Class

The following tables list the members exposed by ScrollBarIncrement.

Public Constructors
 | Name | Description
Public Constructor | ScrollBarIncrement Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the amount to scroll by.
Public Property | ValueType | Gets or sets whether the Value specifies an absolute or relative scroll amount.
Top
See Also

Reference

ScrollBarIncrement Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ScrollBarIncrement Constructor

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ScrollBarIncrement Class : ScrollBarIncrement Constructor
Overload List
Overload | Description
ScrollBarIncrement Constructor() | Initializes a new instance of the ScrollBarIncrement class.
ScrollBarIncrement Constructor(Double,ScrollBarIncrementType) | Initializes a new instance of the ScrollBarIncrement class.
See Also

Reference

ScrollBarIncrement Class
ScrollBarIncrement Members


%%PageItemTitle%%

ScrollBarIncrement Constructor()

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ScrollBarIncrement Class > ScrollBarIncrement Constructor : ScrollBarIncrement Constructor()
Initializes a new instance of the ScrollBarIncrement class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScrollBarIncrement()
public ScrollBarIncrement()
public: ScrollBarIncrement();
public:
ScrollBarIncrement();
See Also

Reference

ScrollBarIncrement Class
ScrollBarIncrement Members
Overload List


%%PageItemTitle%%

ScrollBarIncrement Constructor(Double,ScrollBarIncrementType)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ScrollBarIncrement Class > ScrollBarIncrement Constructor : ScrollBarIncrement Constructor(Double,ScrollBarIncrementType)
The amount to scroll by.
Whether the Value specifies an absolute or relative scroll amount.
Initializes a new instance of the ScrollBarIncrement class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Double, _
   ByVal valueType As ScrollBarIncrementType _
)
'Usage

Dim value As Double
Dim valueType As ScrollBarIncrementType

Dim instance As New ScrollBarIncrement(value, valueType)
public ScrollBarIncrement(
   double value,
   ScrollBarIncrementType valueType
)
public: ScrollBarIncrement(
   double value,
   ScrollBarIncrementType valueType
)
public:
ScrollBarIncrement(
   double value,
   ScrollBarIncrementType valueType
)

Parameters

value
The amount to scroll by.
valueType
Whether the Value specifies an absolute or relative scroll amount.
See Also

Reference

ScrollBarIncrement Class
ScrollBarIncrement Members
Overload List


%%PageItemTitle%% $$Properties$$

ScrollBarIncrement Class Properties

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ScrollBarIncrement Class

For a list of all members of this type, see ScrollBarIncrement members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the amount to scroll by.
Public Property | ValueType | Gets or sets whether the Value specifies an absolute or relative scroll amount.
Top
See Also

Reference

ScrollBarIncrement Class
ImageGear.Windows.Controls Namespace


Value Property (ScrollBarIncrement)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ScrollBarIncrement Class : Value Property
Gets or sets the amount to scroll by.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Double
'Usage

Dim instance As ScrollBarIncrement
Dim value As Double

instance.Value = value

value = instance.Value
public double Value {get; set;}
public: __property double get_Value();
public: __property void set_Value(
   double value
);
public:
property double Value {
   double get();
   void set (    double value);
}

Property Value

System.Double structure value.
Remarks
Exact meaning of the value is determined by the ValueType property.
See Also

Reference

ScrollBarIncrement Class
ScrollBarIncrement Members


ValueType Property (ScrollBarIncrement)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > ScrollBarIncrement Class : ValueType Property
Gets or sets whether the Value specifies an absolute or relative scroll amount.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValueType As ScrollBarIncrementType
'Usage

Dim instance As ScrollBarIncrement
Dim value As ScrollBarIncrementType

instance.ValueType = value

value = instance.ValueType
public ScrollBarIncrementType ValueType {get; set;}
public: __property ScrollBarIncrementType get_ValueType();
public: __property void set_ValueType(
   ScrollBarIncrementType value
);
public:
property ScrollBarIncrementType ValueType {
   ScrollBarIncrementType get();
   void set (    ScrollBarIncrementType value);
}

Property Value

ScrollBarIncrementType class object.
See Also

Reference

ScrollBarIncrement Class
ScrollBarIncrement Members


%%PageItemTitle%%

ImGearAnnotationMode Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotationMode Enumeration
Specifies the mark mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearAnnotationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearAnnotationMode
public enum ImGearAnnotationMode : System.Enum
__value public enum ImGearAnnotationMode : public System.Enum
public enum class ImGearAnnotationMode : public System.Enum
Members
Member | Value | Description
Edit | 0 | Edit mode allows users to create, edit, and delete annotations.
Run | 1 | Run mode allows users to operate on hot spot, audio, and button activities.
View | 2 | View-only mode allows users to view marks, not add or modify them.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearAnnotationMode

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearInteractionArea Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearInteractionArea Enumeration
Specifies the interaction area for editing annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearInteractionArea
   Inherits System.Enum
'Usage

Dim instance As ImGearInteractionArea
public enum ImGearInteractionArea : System.Enum
__value public enum ImGearInteractionArea : public System.Enum
public enum class ImGearInteractionArea : public System.Enum
Members
Member | Value | Description
Device | 0 | Allows unlimited annotation editing for the entire device.
Image | 1 | Limits the annotation editing area to the image portion of the page view.
Remarks
You can choose to limit the annotation editing area to the image portion of the page view, or keep it unlimited to the entire device. This affects creating, selecting, resizing and moving annotations.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearInteractionArea

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMouseTool Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMouseTool Enumeration
Specifies the mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMouseTool
   Inherits System.Enum
'Usage

Dim instance As ImGearMouseTool
public enum ImGearMouseTool : System.Enum
__value public enum ImGearMouseTool : public System.Enum
public enum class ImGearMouseTool : public System.Enum
Members
Member | Value | Description
CreateCurveMark | 18 | Create curve mark mouse tool.
CreateCustomMark | 21 | Create custom mark mouse tool.
CreateEllipseMark | 9 | Create ellipse mark mouse tool.
CreateFreehandMark | 12 | Create freehand mark mouse tool.
CreateImageMark | 19 | Create image mark mouse tool.
CreateLineMark | 10 | Create line mark mouse tool.
CreatePointMark | 17 | Create point mark mouse tool.
CreatePolygonMark | 13 | Create polygon mark mouse tool.
CreatePolylineMark | 11 | Create polyline mark mouse tool.
CreatePolyRulerMark | 16 | Create poly ruler mark mouse tool.
CreatePopupTextMark | 22 | Create popup text mouse tool.
CreateProtractorMark | 20 | Create protractor mark mouse tool.
CreateRectangleMark | 8 | Create rectangle mark mouse tool.
CreateRulerMark | 15 | Create ruler mark mouse tool.
CreateTextMark | 14 | Create text mark mouse tool.
HandPan | 1 | Hand pan mouse tool.
Magnifier | 6 | Magnifier mouse tool.
None | 0 | No tool selected.
RectangleZoom | 3 | Rectangle zoom mouse tool.
Select | 2 | Select mouse tool.
SelectMark | 7 | Select mark mouse tool.
ZoomIn | 4 | Zoom in mouse tool.
ZoomOut | 5 | Zoom out mouse tool.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearMouseTool

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearPageViewToolbarMouseTool Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearPageViewToolbarMouseTool Enumeration
Specifies the PageView toolbar mouse tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearPageViewToolbarMouseTool
   Inherits System.Enum
'Usage

Dim instance As ImGearPageViewToolbarMouseTool
public enum ImGearPageViewToolbarMouseTool : System.Enum
__value public enum ImGearPageViewToolbarMouseTool : public System.Enum
public enum class ImGearPageViewToolbarMouseTool : public System.Enum
Members
Member | Value | Description
CreateCurveMark | 19 | Create curve mark mouse tool.
CreateCustomMark | 22 | Create custom mark mouse tool.
CreateEllipseMark | 10 | Create ellipse mark mouse tool.
CreateFreehandMark | 13 | Create freehand mark mouse tool.
CreateImageMark | 20 | Create image mark mouse tool.
CreateLineMark | 11 | Create line mark mouse tool.
CreatePointMark | 18 | Create point mark mouse tool.
CreatePolygonMark | 14 | Create polygon mark mouse tool.
CreatePolylineMark | 12 | Create polyline mark mouse tool.
CreatePolyRulerMark | 17 | Create poly ruler mark mouse tool.
CreatePopupTextMark | 23 | Create popup text mouse tool.
CreateProtractorMark | 21 | Create protractor mark mouse tool.
CreateRectangleMark | 9 | Create rectangle mark mouse tool.
CreateRulerMark | 16 | Create ruler mark mouse tool.
CreateTextMark | 15 | Create text mark mouse tool.
Custom | 0 | The toolbar mouse tool does not have an equivalent PageView mouse tool and will have no effect when the toolbar MouseTool property is bound to the MouseTool property of a PageView control. You can use the SelectionChanged event to handle the selection of the toolbar item.
HandPan | 2 | Hand pan mouse tool.
Magnifier | 7 | Magnifier mouse tool.
None | 1 | No tool selected.
RectangleZoom | 4 | Rectangle zoom mouse tool.
Select | 3 | Select mouse tool.
SelectMark | 8 | Select mark mouse tool.
ZoomIn | 5 | Zoom in mouse tool.
ZoomOut | 6 | Zoom out mouse tool.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearPageViewToolbarMouseTool

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearScrollDirection Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearScrollDirection Enumeration
The direction that the thumbnail items are scrolled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearScrollDirection
   Inherits System.Enum
'Usage

Dim instance As ImGearScrollDirection
public enum ImGearScrollDirection : System.Enum
__value public enum ImGearScrollDirection : public System.Enum
public enum class ImGearScrollDirection : public System.Enum
Members
Member | Value | Description
Horizontal | 0 | Thumbnail items scroll in a horizontal direction.
Vertical | 1 | Thumbnail items scroll in a vertical direction.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearScrollDirection

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearUpdateMode Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearUpdateMode Enumeration
Specifies the update mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearUpdateMode
   Inherits System.Enum
'Usage

Dim instance As ImGearUpdateMode
public enum ImGearUpdateMode : System.Enum
__value public enum ImGearUpdateMode : public System.Enum
public enum class ImGearUpdateMode : public System.Enum
Members
Member | Value | Description
Automatic | 1 | Automatic update.
Manual | 0 | Manual update.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearUpdateMode

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ScrollBarIncrementType Enumeration

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ScrollBarIncrementType Enumeration
Types of scroll bar increment values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ScrollBarIncrementType
   Inherits System.Enum
'Usage

Dim instance As ScrollBarIncrementType
public enum ScrollBarIncrementType : System.Enum
__value public enum ScrollBarIncrementType : public System.Enum
public enum class ScrollBarIncrementType : public System.Enum
Members
Member | Value | Description
Absolute | 0 | Value is an absolute measurement of ScrollBar.
Relative | 1 | Value is relative to the current view size.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ScrollBarIncrementType

See Also

Reference

ImageGear.Windows.Controls Namespace
ValueType Property


%%PageItemTitle%%

IImGearCommandManager Interface
Members

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : IImGearCommandManager Interface
An interface for providing command related utility methods that register CommmandBinding and InputBinding objects for class owners and commands, add and remove command event handlers, and provides services for querying the status of a command.
Object Model
IImGearCommandManager Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearCommandManager
'Usage

Dim instance As IImGearCommandManager
public interface IImGearCommandManager
public __gc __interface IImGearCommandManager
public interface class IImGearCommandManager
See Also

Reference

IImGearCommandManager Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

IImGearCommandManager Interface Members
Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : IImGearCommandManager Interface

The following tables list the members exposed by IImGearCommandManager.

Public Events
 | Name | Description
Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Top
See Also

Reference

IImGearCommandManager Interface
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

IImGearCommandManager Interface Events

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : IImGearCommandManager Interface

For a list of all members of this type, see IImGearCommandManager members.

Public Events
 | Name | Description
Event | RequerySuggested | Occurs when the command manager detects conditions that might change the ability of a command to execute.
Top
See Also

Reference

IImGearCommandManager Interface
ImageGear.Windows.Controls Namespace


RequerySuggested Event (IImGearCommandManager)

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace > IImGearCommandManager Interface : RequerySuggested Event
Occurs when the command manager detects conditions that might change the ability of a command to execute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Event RequerySuggested As EventHandler
'Usage

Dim instance As IImGearCommandManager
Dim handler As EventHandler

AddHandler instance.RequerySuggested, handler
event EventHandler RequerySuggested
__event EventHandler* RequerySuggested
event EventHandler^ RequerySuggested
See Also

Reference

IImGearCommandManager Interface
IImGearCommandManager Members


%%PageItemTitle%%

ImGearFunc<TParam,TResult> Delegate

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearFunc<TParam,TResult> Delegate
The type of the parameter of the method that this delegate encapsulates.
The type of the return value of the method that this delegate encapsulates.
The parameter of the method that this delegate encapsulates.
Encapsulates a method that has one parameter and returns a value of the type specified by the TResult parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ImGearFunc
    (Of TParam,TResult)( _
   ByVal p As TParam _
) As TResult
'Usage

Dim instance As New ImGearFunc(Of TParam,TResult)(AddressOf HandlerMethod)
public delegate TResult ImGearFunc<TParam,TResult>(
   TParam p
)
public: __gc __delegate TResult* ImGearFunc<TParam,TResult>(
   TParam* p
)
generic<typename TParam>
generic<typename TResult>
public delegate TResult^ ImGearFunc(
   TParam^ p
)

Parameters

p
The parameter of the method that this delegate encapsulates.

Type Parameters

TParam
The type of the parameter of the method that this delegate encapsulates.
TResult
The type of the return value of the method that this delegate encapsulates.

Return Value

The return value of the method that this delegate encapsulates.
See Also

Reference

ImGearFunc<TParam,TResult> Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMarksLoadingEventHandler Delegate

ImageGear22.Windows.Controls Assembly > ImageGear.Windows.Controls Namespace : ImGearMarksLoadingEventHandler Delegate
The source of the event.
MarksLoadingEventArgs object that contains the event data.
This delegate is used for declaring MarksLoading events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearMarksLoadingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearMarksLoadingEventArgs _
)
'Usage

Dim instance As New ImGearMarksLoadingEventHandler(AddressOf HandlerMethod)
public delegate void ImGearMarksLoadingEventHandler(
   object sender,
   ImGearMarksLoadingEventArgs e
)
public: __gc __delegate void ImGearMarksLoadingEventHandler(
   Object* sender,
   ImGearMarksLoadingEventArgs* e
)
public delegate void ImGearMarksLoadingEventHandler(
   Object^ sender,
   ImGearMarksLoadingEventArgs^ e
)

Parameters

sender
The source of the event.
e
MarksLoadingEventArgs object that contains the event data.
See Also

Reference

ImGearMarksLoadingEventHandler Members
ImageGear.Windows.Controls Namespace


ImageGear22.Windows.Controls.Art Assembly
Namespaces
Namespace | Description
ImageGear.Windows.Controls | The ImageGear.Windows.Controls provides WPF Annotation controls and UI.


ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls.Art)
Inheritance Hierarchy
ImageGear22.Windows.Controls.Art Assembly : ImageGear.Windows.Controls Namespace
The ImageGear.Windows.Controls provides WPF Annotation controls and UI.
Classes
 | Class | Description
Class | ImGearAnnotatorCreateMarkData | This class provides mark creation data.
Class | ImGearAnnotatorMarkController | The base class for a custom mark annotator controller.
Class | ImGearAnnotatorMarkControllerData | This class provides mark controller data.
Class | ImGearAnnotatorPolyController | The base class for a point-based custom mark annotator controller.
Class | ImGearAnnotatorRectangleController | The base class for a rectangular custom mark annotator controller.
Class | ImGearMarkCreatingEventArgs | Provides data for the MarkCreating event.
Interfaces
 | Interface | Description
Interface | IImGearMarkEditorWindow | Defines the annotation mark editor window interface.
Delegates
 | Delegate | Description
Delegate | ImGearMarkCreatingEventHandler | Used for declaring a MarkCreating event.
Enumerations
 | Enumeration | Description
Enumeration | ImGearResizeType | Specifies how the mark is being resized.
See Also

Reference

ImageGear22.Windows.Controls.Art Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls.Art) Inheritance Hierarchy
ImageGear22.Windows.Controls.Art Assembly : ImageGear.Windows.Controls Namespace
Inheritance Hierarchy
System.Object
ImageGear.Windows.Controls.ImGearAnnotatorCreateMarkData
ImageGear.Windows.Controls.ImGearAnnotatorMarkController
ImageGear.Windows.Controls.ImGearAnnotatorPolyController
ImageGear.Windows.Controls.ImGearAnnotatorRectangleController
ImageGear.Windows.Controls.ImGearAnnotatorMarkControllerData
System.EventArgs
ImageGear.Windows.Controls.ImGearMarkCreatingEventArgs
See Also

Reference

ImageGear22.Windows.Controls.Art Assembly


%%PageItemTitle%%

ImGearAnnotatorCreateMarkData Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorCreateMarkData Class
This class provides mark creation data.
Object Model
ImGearAnnotatorCreateMarkData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAnnotatorCreateMarkData
'Usage

Dim instance As ImGearAnnotatorCreateMarkData
public class ImGearAnnotatorCreateMarkData
public __gc class ImGearAnnotatorCreateMarkData
public ref class ImGearAnnotatorCreateMarkData
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearAnnotatorCreateMarkData

See Also

Reference

ImGearAnnotatorCreateMarkData Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotatorCreateMarkData Class Members
Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorCreateMarkData Class

The following tables list the members exposed by ImGearAnnotatorCreateMarkData.

Public Properties
 | Name | Description
Public Property | CustomData | Gets or sets custom data.
Public Property | IsDoubleClick | Gets or sets a value indicating whether or not the mouse was double clicked.
Top
See Also

Reference

ImGearAnnotatorCreateMarkData Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ImGearAnnotatorCreateMarkData Class Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorCreateMarkData Class

For a list of all members of this type, see ImGearAnnotatorCreateMarkData members.

Public Properties
 | Name | Description
Public Property | CustomData | Gets or sets custom data.
Public Property | IsDoubleClick | Gets or sets a value indicating whether or not the mouse was double clicked.
Top
See Also

Reference

ImGearAnnotatorCreateMarkData Class
ImageGear.Windows.Controls Namespace


CustomData Property (ImGearAnnotatorCreateMarkData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorCreateMarkData Class : CustomData Property
Gets or sets custom data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomData As Object
'Usage

Dim instance As ImGearAnnotatorCreateMarkData
Dim value As Object

instance.CustomData = value

value = instance.CustomData
public object CustomData {get; set;}
public: __property Object* get_CustomData();
public: __property void set_CustomData(
   Object* value
);
public:
property Object^ CustomData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property can be used to keep track of the state of the mark creation operation so that the current mark creation behavior can affect the behavior of the operation later.
See Also

Reference

ImGearAnnotatorCreateMarkData Class
ImGearAnnotatorCreateMarkData Members


IsDoubleClick Property

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorCreateMarkData Class : IsDoubleClick Property
Gets or sets a value indicating whether or not the mouse was double clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsDoubleClick As Boolean
'Usage

Dim instance As ImGearAnnotatorCreateMarkData
Dim value As Boolean

instance.IsDoubleClick = value

value = instance.IsDoubleClick
public bool IsDoubleClick {get; set;}
public: __property bool get_IsDoubleClick();
public: __property void set_IsDoubleClick(
   bool value
);
public:
property bool IsDoubleClick {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearAnnotatorCreateMarkData Class
ImGearAnnotatorCreateMarkData Members


%%PageItemTitle%%

ImGearAnnotatorMarkController Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkController Class
The base class for a custom mark annotator controller.
Object Model
ImGearAnnotatorMarkController ClassImGearARTMark ClassImGearARTMark ClassImGearARTMark ClassImGearAnnotatorMarkController ClassIImGearMarkEditorWindow Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearAnnotatorMarkController
'Usage

Dim instance As ImGearAnnotatorMarkController
public abstract class ImGearAnnotatorMarkController
public __gc abstract class ImGearAnnotatorMarkController
public ref class ImGearAnnotatorMarkController abstract
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearAnnotatorMarkController
ImageGear.Windows.Controls.ImGearAnnotatorPolyController
ImageGear.Windows.Controls.ImGearAnnotatorRectangleController

See Also

Reference

ImGearAnnotatorMarkController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotatorMarkController Class Members
Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkController Class

The following tables list the members exposed by ImGearAnnotatorMarkController.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Checks if a new mark can be created.
Public Method | CreateInProgressMark | Creates the in-progress mark when the mark is being added using the mouse.
Public Method | CreateMark | Adds the in-progress mark to the ART page.
Public Method | DrawInProgressMark | Draws the in-progress mark when the mark is being added using the mouse.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark annotator controller.
Public Method | GetPropertiesWindow | Gets the properties window for the mark.
Public Method | ManageCursor | Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
static (Shared in Visual Basic) | RegisterCustomController | Registers a controller for a custom mark type.
Public Method | Resize | Method that is called when the mouse is used to resize a mark.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | UpdateCursor | This method sets the ImGearAnnotatorMarkControllerData.Cursor to the Hand cursor if the mouse is over the specified point.
Top
See Also

Reference

ImGearAnnotatorMarkController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotatorMarkController Class Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkController Class

For a list of all members of this type, see ImGearAnnotatorMarkController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Checks if a new mark can be created.
Public Method | CreateInProgressMark | Creates the in-progress mark when the mark is being added using the mouse.
Public Method | CreateMark | Adds the in-progress mark to the ART page.
Public Method | DrawInProgressMark | Draws the in-progress mark when the mark is being added using the mouse.
static (Shared in Visual Basic) | GetCustomController | Returns a registered custom mark annotator controller.
Public Method | GetPropertiesWindow | Gets the properties window for the mark.
Public Method | ManageCursor | Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
static (Shared in Visual Basic) | RegisterCustomController | Registers a controller for a custom mark type.
Public Method | Resize | Method that is called when the mouse is used to resize a mark.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | UpdateCursor | This method sets the ImGearAnnotatorMarkControllerData.Cursor to the Hand cursor if the mouse is over the specified point.
Top
See Also

Reference

ImGearAnnotatorMarkController Class
ImageGear.Windows.Controls Namespace


CanCreateMark Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : CanCreateMark Method
Points already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim points As IEnumerable(Of ImGearPoint)
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createMarkData)
public virtual bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearAnnotatorCreateMarkData createMarkData
)
public: virtual bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearAnnotatorCreateMarkData* createMarkData
)
public:
virtual bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearAnnotatorCreateMarkData^ createMarkData
)

Parameters

points
Points already entered by user.
createMarkData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if a new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


CreateInProgressMark Method

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : CreateInProgressMark Method
Mark creation data.
Creates the in-progress mark when the mark is being added using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function CreateInProgressMark( _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As ImGearARTMark
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As ImGearARTMark

value = instance.CreateInProgressMark(createMarkData)
public virtual ImGearARTMark CreateInProgressMark(
   ImGearAnnotatorCreateMarkData createMarkData
)
public: virtual ImGearARTMark* CreateInProgressMark(
   ImGearAnnotatorCreateMarkData* createMarkData
)
public:
virtual ImGearARTMark^ CreateInProgressMark(
   ImGearAnnotatorCreateMarkData^ createMarkData
)

Parameters

createMarkData
Mark creation data.

Return Value

ImGearARTMark object.
Remarks
This method is called when the mouse is first clicked. The createMarkData parameter is always a default instance of ImGearAnnotatorCreateMarkData in this method.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


CreateMark Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : CreateMark Method
The mark that will be added to the ART page. This is the in-progress mark but can be modified if this method is overridden.
The mouse points.
Mark creation data.
Adds the in-progress mark to the ART page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function CreateMark( _
   ByVal mark As ImGearARTMark, _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As ImGearARTMark
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim mark As ImGearARTMark
Dim points As IEnumerable(Of ImGearPoint)
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As ImGearARTMark

value = instance.CreateMark(mark, points, createMarkData)
public virtual ImGearARTMark CreateMark(
   ImGearARTMark mark,
   IEnumerable<ImGearPoint> points,
   ImGearAnnotatorCreateMarkData createMarkData
)
public: virtual ImGearARTMark* CreateMark(
   ImGearARTMark* mark,
   IEnumerable<ImGearPoint>* points,
   ImGearAnnotatorCreateMarkData* createMarkData
)
public:
virtual ImGearARTMark^ CreateMark(
   ImGearARTMark^ mark,
   IEnumerable<ImGearPoint>^ points,
   ImGearAnnotatorCreateMarkData^ createMarkData
)

Parameters

mark
The mark that will be added to the ART page. This is the in-progress mark but can be modified if this method is overridden.
points
The mouse points.
createMarkData
Mark creation data.

Return Value

ImGearARTMark object.
Remarks
The mark parameter is the in-progress mark, which this method returns by default.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


DrawInProgressMark Method

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : DrawInProgressMark Method
The in-progress mark.
The mouse points.
A set of parameters for custom mark's drawing.
Mark creation data.
Draws the in-progress mark when the mark is being added using the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function DrawInProgressMark( _
   ByVal mark As ImGearARTMark, _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal presentationState As ImGearARTPresentationState, _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As ImGearARTMark
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim mark As ImGearARTMark
Dim points As IEnumerable(Of ImGearPoint)
Dim presentationState As ImGearARTPresentationState
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As ImGearARTMark

value = instance.DrawInProgressMark(mark, points, presentationState, createMarkData)
public virtual ImGearARTMark DrawInProgressMark(
   ImGearARTMark mark,
   IEnumerable<ImGearPoint> points,
   ImGearARTPresentationState presentationState,
   ImGearAnnotatorCreateMarkData createMarkData
)
public: virtual ImGearARTMark* DrawInProgressMark(
   ImGearARTMark* mark,
   IEnumerable<ImGearPoint>* points,
   ImGearARTPresentationState* presentationState,
   ImGearAnnotatorCreateMarkData* createMarkData
)
public:
virtual ImGearARTMark^ DrawInProgressMark(
   ImGearARTMark^ mark,
   IEnumerable<ImGearPoint>^ points,
   ImGearARTPresentationState^ presentationState,
   ImGearAnnotatorCreateMarkData^ createMarkData
)

Parameters

mark
The in-progress mark.
points
The mouse points.
presentationState
A set of parameters for custom mark's drawing.
createMarkData
Mark creation data.

Return Value

ImGearARTMark value.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


GetCustomController Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : GetCustomController Method
String representing the type of the custom mark.
Returns a registered custom mark annotator controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetCustomController( _
   ByVal customTypeName As String _
) As ImGearAnnotatorMarkController
'Usage

Dim customTypeName As String
Dim value As ImGearAnnotatorMarkController

value = ImGearAnnotatorMarkController.GetCustomController(customTypeName)
public static ImGearAnnotatorMarkController GetCustomController(
   string customTypeName
)
public: static ImGearAnnotatorMarkController* GetCustomController(
   string* customTypeName
)
public:
static ImGearAnnotatorMarkController^ GetCustomController(
   String^ customTypeName
)

Parameters

customTypeName
String representing the type of the custom mark.

Return Value

Registered custom controller.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


GetPropertiesWindow Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : GetPropertiesWindow Method
Gets the properties window for the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetPropertiesWindow() As IImGearMarkEditorWindow
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim value As IImGearMarkEditorWindow

value = instance.GetPropertiesWindow()
public virtual IImGearMarkEditorWindow GetPropertiesWindow()
public: virtual IImGearMarkEditorWindow* GetPropertiesWindow();
public:
virtual IImGearMarkEditorWindow^ GetPropertiesWindow();

Return Value

IImGearMarkEditorWindow value.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


ManageCursor Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : ManageCursor Method
The mark the mouse is over.
The position of the mouse (in device pixels).
The mark controller data.
Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearDoublePoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
)
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearDoublePoint
Dim markControllerData As ImGearAnnotatorMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public virtual void ManageCursor(
   ImGearARTMark mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData markControllerData
)
public: virtual void ManageCursor(
   ImGearARTMark* mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData* markControllerData
)
public:
virtual void ManageCursor(
   ImGearARTMark^ mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData^ markControllerData
)

Parameters

mark
The mark the mouse is over.
mousePoint
The position of the mouse (in device pixels).
markControllerData
The mark controller data.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


RegisterCustomController Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : RegisterCustomController Method
String representing the type of the custom mark.
MarkAnnotatorController object.
Registers a controller for a custom mark type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterCustomController( _
   ByVal customTypeName As String, _
   ByVal controller As ImGearAnnotatorMarkController _
)
'Usage

Dim customTypeName As String
Dim controller As ImGearAnnotatorMarkController

ImGearAnnotatorMarkController.RegisterCustomController(customTypeName, controller)
public static void RegisterCustomController(
   string customTypeName,
   ImGearAnnotatorMarkController controller
)
public: static void RegisterCustomController(
   string* customTypeName,
   ImGearAnnotatorMarkController* controller
)
public:
static void RegisterCustomController(
   String^ customTypeName,
   ImGearAnnotatorMarkController^ controller
)

Parameters

customTypeName
String representing the type of the custom mark.
controller
MarkAnnotatorController object.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


Resize Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : Resize Method
The mark being resized.
The new position of the point (in image pixels).
The mark controller data.
Method that is called when the mouse is used to resize a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Resize( _
   ByVal mark As ImGearARTMark, _
   ByVal point As ImGearPoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
)
'Usage

Dim instance As ImGearAnnotatorMarkController
Dim mark As ImGearARTMark
Dim point As ImGearPoint
Dim markControllerData As ImGearAnnotatorMarkControllerData

instance.Resize(mark, point, markControllerData)
public virtual void Resize(
   ImGearARTMark mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData markControllerData
)
public: virtual void Resize(
   ImGearARTMark* mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData* markControllerData
)
public:
virtual void Resize(
   ImGearARTMark^ mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData^ markControllerData
)

Parameters

mark
The mark being resized.
point
The new position of the point (in image pixels).
markControllerData
The mark controller data.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


UpdateCursor Method (ImGearAnnotatorMarkController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkController Class : UpdateCursor Method
The point (in image pixels).
The position of the mouse (in device pixels).
The mark controller data.
This method sets the ImGearAnnotatorMarkControllerData.Cursor to the Hand cursor if the mouse is over the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Shared Function UpdateCursor( _
   ByVal point As ImGearPoint, _
   ByVal mousePoint As ImGearDoublePoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
) As Boolean
'Usage

Dim point As ImGearPoint
Dim mousePoint As ImGearDoublePoint
Dim markControllerData As ImGearAnnotatorMarkControllerData
Dim value As Boolean

value = ImGearAnnotatorMarkController.UpdateCursor(point, mousePoint, markControllerData)
protected static bool UpdateCursor(
   ImGearPoint point,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData markControllerData
)
protected: static bool UpdateCursor(
   ImGearPoint point,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData* markControllerData
)
protected:
static bool UpdateCursor(
   ImGearPoint point,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData^ markControllerData
)

Parameters

point
The point (in image pixels).
mousePoint
The position of the mouse (in device pixels).
markControllerData
The mark controller data.

Return Value

Whether or not the mouse is over the specified point.
See Also

Reference

ImGearAnnotatorMarkController Class
ImGearAnnotatorMarkController Members


%%PageItemTitle%%

ImGearAnnotatorMarkControllerData Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkControllerData Class
This class provides mark controller data.
Object Model
ImGearAnnotatorMarkControllerData ClassIImGearPageDisplay InterfaceImGearRectangle StructureImGearPoint StructureIImGearScrollableView Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAnnotatorMarkControllerData
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
public class ImGearAnnotatorMarkControllerData
public __gc class ImGearAnnotatorMarkControllerData
public ref class ImGearAnnotatorMarkControllerData
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearAnnotatorMarkControllerData

See Also

Reference

ImGearAnnotatorMarkControllerData Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotatorMarkControllerData Class Members
Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkControllerData Class

The following tables list the members exposed by ImGearAnnotatorMarkControllerData.

Public Properties
 | Name | Description
Public Property | ClickPrecision | Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point. A value of half the mark handle size plus three is used internally for non-custom marks.
Public Property | Cursor | Gets or sets the cursor to update.
Public Property | CustomData | Gets or sets custom data.
Public Property | Display | Gets or sets the display.
Public Property | InitialMarkRectangle | Gets or sets the initial bounds of the mark, which are used to determine the center of the mark.
Public Property | InitialOppositePoint | Gets or sets the initial point opposite to the current point. This is null if the resize type is Point.
Public Property | IsHoldingCtrl | Gets or sets a value indicating whether the Ctrl key is currently being held.
Public Property | IsHoldingShift | Gets or sets a value indicating whether the Shift key is currently being held.
Public Property | PointId | Gets or sets the ID of the point in the mark that the cursor is over.
Public Property | ResizeType | Gets or sets the type of resizing to perform for this point.
Public Property | View | Gets or sets the view.
Top
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

ImGearAnnotatorMarkControllerData Class Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorMarkControllerData Class

For a list of all members of this type, see ImGearAnnotatorMarkControllerData members.

Public Properties
 | Name | Description
Public Property | ClickPrecision | Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point. A value of half the mark handle size plus three is used internally for non-custom marks.
Public Property | Cursor | Gets or sets the cursor to update.
Public Property | CustomData | Gets or sets custom data.
Public Property | Display | Gets or sets the display.
Public Property | InitialMarkRectangle | Gets or sets the initial bounds of the mark, which are used to determine the center of the mark.
Public Property | InitialOppositePoint | Gets or sets the initial point opposite to the current point. This is null if the resize type is Point.
Public Property | IsHoldingCtrl | Gets or sets a value indicating whether the Ctrl key is currently being held.
Public Property | IsHoldingShift | Gets or sets a value indicating whether the Shift key is currently being held.
Public Property | PointId | Gets or sets the ID of the point in the mark that the cursor is over.
Public Property | ResizeType | Gets or sets the type of resizing to perform for this point.
Public Property | View | Gets or sets the view.
Top
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImageGear.Windows.Controls Namespace


ClickPrecision Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : ClickPrecision Property
Gets or sets the distance from the mark's point (horizontally or vertically, in device pixels) in which the mouse is considered to be over the point. A value of half the mark handle size plus three is used internally for non-custom marks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClickPrecision As Double
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Double

instance.ClickPrecision = value

value = instance.ClickPrecision
public double ClickPrecision {get; set;}
public: __property double get_ClickPrecision();
public: __property void set_ClickPrecision(
   double value
);
public:
property double ClickPrecision {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


Cursor Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : Cursor Property
Gets or sets the cursor to update.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

Cursor object.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


CustomData Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : CustomData Property
Gets or sets custom data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CustomData As Object
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Object

instance.CustomData = value

value = instance.CustomData
public object CustomData {get; set;}
public: __property Object* get_CustomData();
public: __property void set_CustomData(
   Object* value
);
public:
property Object^ CustomData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object value.
Remarks
This property can be used to keep track of the state of the resize or manage cursor operation so that the current resize or manage cursor behavior can affect the behavior of the operation later.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


Display Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : Display Property
Gets or sets the display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Display As IImGearPageDisplay
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As IImGearPageDisplay

instance.Display = value

value = instance.Display
public IImGearPageDisplay Display {get; set;}
public: __property IImGearPageDisplay* get_Display();
public: __property void set_Display(
   IImGearPageDisplay* value
);
public:
property IImGearPageDisplay^ Display {
   IImGearPageDisplay^ get();
   void set (    IImGearPageDisplay^ value);
}

Property Value

IImGearPageDisplay object.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


InitialMarkRectangle Property

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : InitialMarkRectangle Property
Gets or sets the initial bounds of the mark, which are used to determine the center of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InitialMarkRectangle As ImGearRectangle
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As ImGearRectangle

instance.InitialMarkRectangle = value

value = instance.InitialMarkRectangle
public ImGearRectangle InitialMarkRectangle {get; set;}
public: __property ImGearRectangle get_InitialMarkRectangle();
public: __property void set_InitialMarkRectangle(
   ImGearRectangle value
);
public:
property ImGearRectangle InitialMarkRectangle {
   ImGearRectangle get();
   void set (    ImGearRectangle value);
}

Property Value

ImGearRectangle object.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


InitialOppositePoint Property

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : InitialOppositePoint Property
Gets or sets the initial point opposite to the current point. This is null if the resize type is Point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InitialOppositePoint As ImGearPoint
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As ImGearPoint

instance.InitialOppositePoint = value

value = instance.InitialOppositePoint
public ImGearPoint InitialOppositePoint {get; set;}
public: __property ImGearPoint get_InitialOppositePoint();
public: __property void set_InitialOppositePoint(
   ImGearPoint value
);
public:
property ImGearPoint InitialOppositePoint {
   ImGearPoint get();
   void set (    ImGearPoint value);
}

Property Value

ImGearPoint object.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


IsHoldingCtrl Property

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : IsHoldingCtrl Property
Gets or sets a value indicating whether the Ctrl key is currently being held.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHoldingCtrl As Boolean
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Boolean

instance.IsHoldingCtrl = value

value = instance.IsHoldingCtrl
public bool IsHoldingCtrl {get; set;}
public: __property bool get_IsHoldingCtrl();
public: __property void set_IsHoldingCtrl(
   bool value
);
public:
property bool IsHoldingCtrl {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


IsHoldingShift Property

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : IsHoldingShift Property
Gets or sets a value indicating whether the Shift key is currently being held.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsHoldingShift As Boolean
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Boolean

instance.IsHoldingShift = value

value = instance.IsHoldingShift
public bool IsHoldingShift {get; set;}
public: __property bool get_IsHoldingShift();
public: __property void set_IsHoldingShift(
   bool value
);
public:
property bool IsHoldingShift {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


PointId Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : PointId Property
Gets or sets the ID of the point in the mark that the cursor is over.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PointId As Integer
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As Integer

instance.PointId = value

value = instance.PointId
public int PointId {get; set;}
public: __property int get_PointId();
public: __property void set_PointId(
   int value
);
public:
property int PointId {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


ResizeType Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : ResizeType Property
Gets or sets the type of resizing to perform for this point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResizeType As ImGearResizeType
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As ImGearResizeType

instance.ResizeType = value

value = instance.ResizeType
public ImGearResizeType ResizeType {get; set;}
public: __property ImGearResizeType get_ResizeType();
public: __property void set_ResizeType(
   ImGearResizeType value
);
public:
property ImGearResizeType ResizeType {
   ImGearResizeType get();
   void set (    ImGearResizeType value);
}

Property Value

ResizeType value.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


View Property (ImGearAnnotatorMarkControllerData)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorMarkControllerData Class : View Property
Gets or sets the view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property View As IImGearScrollableView
'Usage

Dim instance As ImGearAnnotatorMarkControllerData
Dim value As IImGearScrollableView

instance.View = value

value = instance.View
public IImGearScrollableView View {get; set;}
public: __property IImGearScrollableView* get_View();
public: __property void set_View(
   IImGearScrollableView* value
);
public:
property IImGearScrollableView^ View {
   IImGearScrollableView^ get();
   void set (    IImGearScrollableView^ value);
}

Property Value

IImGearScrollableView object.
See Also

Reference

ImGearAnnotatorMarkControllerData Class
ImGearAnnotatorMarkControllerData Members


%%PageItemTitle%%

ImGearAnnotatorPolyController Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorPolyController Class
The base class for a point-based custom mark annotator controller.
Object Model
ImGearAnnotatorPolyController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearAnnotatorPolyController
   Inherits ImGearAnnotatorMarkController
'Usage

Dim instance As ImGearAnnotatorPolyController
public abstract class ImGearAnnotatorPolyController : ImGearAnnotatorMarkController
public __gc abstract class ImGearAnnotatorPolyController : public ImGearAnnotatorMarkController
public ref class ImGearAnnotatorPolyController abstract : public ImGearAnnotatorMarkController
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearAnnotatorMarkController
ImageGear.Windows.Controls.ImGearAnnotatorPolyController

See Also

Reference

ImGearAnnotatorPolyController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotatorPolyController Class Members
Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorPolyController Class

The following tables list the members exposed by ImGearAnnotatorPolyController.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | ManageCursor | Overridden. Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Top
See Also

Reference

ImGearAnnotatorPolyController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotatorPolyController Class Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorPolyController Class

For a list of all members of this type, see ImGearAnnotatorPolyController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | ManageCursor | Overridden. Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Top
See Also

Reference

ImGearAnnotatorPolyController Class
ImageGear.Windows.Controls Namespace


CanCreateMark Method (ImGearAnnotatorPolyController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorPolyController Class : CanCreateMark Method
Points already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearAnnotatorPolyController
Dim points As IEnumerable(Of ImGearPoint)
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createMarkData)
public override bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearAnnotatorCreateMarkData createMarkData
)
public: bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearAnnotatorCreateMarkData* createMarkData
) override
public:
bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearAnnotatorCreateMarkData^ createMarkData
) override

Parameters

points
Points already entered by user.
createMarkData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if a new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearAnnotatorPolyController Class
ImGearAnnotatorPolyController Members


ManageCursor Method (ImGearAnnotatorPolyController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorPolyController Class : ManageCursor Method
The mark the mouse is over.
The position of the mouse (in device pixels).
The mark controller data.
Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearDoublePoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
)
'Usage

Dim instance As ImGearAnnotatorPolyController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearDoublePoint
Dim markControllerData As ImGearAnnotatorMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public override void ManageCursor(
   ImGearARTMark mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData markControllerData
)
public: void ManageCursor(
   ImGearARTMark* mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData* markControllerData
) override
public:
void ManageCursor(
   ImGearARTMark^ mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData^ markControllerData
) override

Parameters

mark
The mark the mouse is over.
mousePoint
The position of the mouse (in device pixels).
markControllerData
The mark controller data.
Remarks
This method checks if the mouse is over a point in your custom mark. If it is, the markControllerData parameter is updated so that the Cursor property is set to the Hand cursor and the Hand cursor displays. The ID of the point the cursor is over is set, and the type of resizing to perform for the point is set. If the mouse is clicked, the specified point ID and resize type will be passed to the ImGearAnnotatorMarkController.Resize method, which can use this information to modify the size of the mark or the position of a point in the mark. You must override the Resize method to enable resizing your custom mark.
See Also

Reference

ImGearAnnotatorPolyController Class
ImGearAnnotatorPolyController Members


%%PageItemTitle%%

ImGearAnnotatorRectangleController Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorRectangleController Class
The base class for a rectangular custom mark annotator controller.
Object Model
ImGearAnnotatorRectangleController Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearAnnotatorRectangleController
   Inherits ImGearAnnotatorMarkController
'Usage

Dim instance As ImGearAnnotatorRectangleController
public abstract class ImGearAnnotatorRectangleController : ImGearAnnotatorMarkController
public __gc abstract class ImGearAnnotatorRectangleController : public ImGearAnnotatorMarkController
public ref class ImGearAnnotatorRectangleController abstract : public ImGearAnnotatorMarkController
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearAnnotatorMarkController
ImageGear.Windows.Controls.ImGearAnnotatorRectangleController

See Also

Reference

ImGearAnnotatorRectangleController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearAnnotatorRectangleController Class Members
Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorRectangleController Class

The following tables list the members exposed by ImGearAnnotatorRectangleController.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | ManageCursor | Overridden. Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Public Method | Resize | Overridden. Method that is called when the mouse is used to resize a mark.
Public Method | UpdateBounds | Updates the bounds of the mark.
Top
See Also

Reference

ImGearAnnotatorRectangleController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearAnnotatorRectangleController Class Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearAnnotatorRectangleController Class

For a list of all members of this type, see ImGearAnnotatorRectangleController members.

Public Methods
 | Name | Description
Public Method | CanCreateMark | Overridden. Checks if a new mark can be created.
Public Method | ManageCursor | Overridden. Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Public Method | Resize | Overridden. Method that is called when the mouse is used to resize a mark.
Public Method | UpdateBounds | Updates the bounds of the mark.
Top
See Also

Reference

ImGearAnnotatorRectangleController Class
ImageGear.Windows.Controls Namespace


CanCreateMark Method (ImGearAnnotatorRectangleController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorRectangleController Class : CanCreateMark Method
Points already entered by user.
Data associated with create action.
Checks if a new mark can be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateMark( _
   ByVal points As IEnumerable(Of ImGearPoint), _
   ByVal createMarkData As ImGearAnnotatorCreateMarkData _
) As Boolean
'Usage

Dim instance As ImGearAnnotatorRectangleController
Dim points As IEnumerable(Of ImGearPoint)
Dim createMarkData As ImGearAnnotatorCreateMarkData
Dim value As Boolean

value = instance.CanCreateMark(points, createMarkData)
public override bool CanCreateMark(
   IEnumerable<ImGearPoint> points,
   ImGearAnnotatorCreateMarkData createMarkData
)
public: bool CanCreateMark(
   IEnumerable<ImGearPoint>* points,
   ImGearAnnotatorCreateMarkData* createMarkData
) override
public:
bool CanCreateMark(
   IEnumerable<ImGearPoint>^ points,
   ImGearAnnotatorCreateMarkData^ createMarkData
) override

Parameters

points
Points already entered by user.
createMarkData
Data associated with create action.

Return Value

True if mark can be created using given points and creation data.
Remarks
Annotator calls this method to determine if a new mark can be created from the given set of points. For example, all rectangular marks can be created by two points, but Protractor requires 3 points, and polyline needs double-click to be created.
See Also

Reference

ImGearAnnotatorRectangleController Class
ImGearAnnotatorRectangleController Members


ManageCursor Method (ImGearAnnotatorRectangleController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorRectangleController Class : ManageCursor Method
The mark the mouse is over.
The position of the mouse (in device pixels).
The mark controller data.
Method that is called to update the mouse cursor, set an ID for which point of the mark the mouse is currently over, and set the type of resizing to use for that point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub ManageCursor( _
   ByVal mark As ImGearARTMark, _
   ByVal mousePoint As ImGearDoublePoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
)
'Usage

Dim instance As ImGearAnnotatorRectangleController
Dim mark As ImGearARTMark
Dim mousePoint As ImGearDoublePoint
Dim markControllerData As ImGearAnnotatorMarkControllerData

instance.ManageCursor(mark, mousePoint, markControllerData)
public override void ManageCursor(
   ImGearARTMark mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData markControllerData
)
public: void ManageCursor(
   ImGearARTMark* mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData* markControllerData
) override
public:
void ManageCursor(
   ImGearARTMark^ mark,
   ImGearDoublePoint mousePoint,
   ImGearAnnotatorMarkControllerData^ markControllerData
) override

Parameters

mark
The mark the mouse is over.
mousePoint
The position of the mouse (in device pixels).
markControllerData
The mark controller data.
Remarks
This method checks if the mouse is over a point in your custom mark. If it is, the markControllerData parameter is updated so that the Cursor property is set to the Hand cursor and the Hand cursor displays. The ID of the point the cursor is over is set, and the type of resizing to perform for the point is set. If the mouse is clicked, the specified point ID and resize type will be passed to the ImGearAnnotatorMarkController.Resize method, which can use this information to modify the size of the mark or the position of a point in the mark. You must override the UpdateBounds method to enable resizing your custom mark.
See Also

Reference

ImGearAnnotatorRectangleController Class
ImGearAnnotatorRectangleController Members


Resize Method (ImGearAnnotatorRectangleController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorRectangleController Class : Resize Method
The mark being resized.
The new position of the point (in image pixels).
The mark controller data.
Method that is called when the mouse is used to resize a mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Resize( _
   ByVal mark As ImGearARTMark, _
   ByVal point As ImGearPoint, _
   ByVal markControllerData As ImGearAnnotatorMarkControllerData _
)
'Usage

Dim instance As ImGearAnnotatorRectangleController
Dim mark As ImGearARTMark
Dim point As ImGearPoint
Dim markControllerData As ImGearAnnotatorMarkControllerData

instance.Resize(mark, point, markControllerData)
public override void Resize(
   ImGearARTMark mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData markControllerData
)
public: void Resize(
   ImGearARTMark* mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData* markControllerData
) override
public:
void Resize(
   ImGearARTMark^ mark,
   ImGearPoint point,
   ImGearAnnotatorMarkControllerData^ markControllerData
) override

Parameters

mark
The mark being resized.
point
The new position of the point (in image pixels).
markControllerData
The mark controller data.
Remarks
The UpdateBounds method must be overridden to enable resizing a custom mark using the mouse. If the UpdateBounds method is overriden, then by default this method resizes the mark based on the point parameter and the markControllerData. For example, if the IsHoldingCtrl and IsHoldingShift properties of markControllerData are true, the aspect ratio and a fixed center point will be maintained when resizing the mark.
See Also

Reference

ImGearAnnotatorRectangleController Class
ImGearAnnotatorRectangleController Members


UpdateBounds Method (ImGearAnnotatorRectangleController)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearAnnotatorRectangleController Class : UpdateBounds Method
The mark to update.
The resized rectangle.
Updates the bounds of the mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub UpdateBounds( _
   ByVal mark As ImGearARTMark, _
   ByVal rect As IImGearRectangle _
)
'Usage

Dim instance As ImGearAnnotatorRectangleController
Dim mark As ImGearARTMark
Dim rect As IImGearRectangle

instance.UpdateBounds(mark, rect)
public virtual void UpdateBounds(
   ImGearARTMark mark,
   IImGearRectangle rect
)
public: virtual void UpdateBounds(
   ImGearARTMark* mark,
   IImGearRectangle* rect
)
public:
virtual void UpdateBounds(
   ImGearARTMark^ mark,
   IImGearRectangle^ rect
)

Parameters

mark
The mark to update.
rect
The resized rectangle.
Remarks
This method must be overridden to enable resizing a custom mark using the mouse. In this method you can update the location and size properties of your custom mark by getting those values from the rect parameter.
See Also

Reference

ImGearAnnotatorRectangleController Class
ImGearAnnotatorRectangleController Members


%%PageItemTitle%%

ImGearMarkCreatingEventArgs Class
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearMarkCreatingEventArgs Class
Provides data for the MarkCreating event.
Object Model
ImGearMarkCreatingEventArgs ClassImGearARTMark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMarkCreatingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearMarkCreatingEventArgs
public class ImGearMarkCreatingEventArgs : System.EventArgs
public __gc class ImGearMarkCreatingEventArgs : public System.EventArgs
public ref class ImGearMarkCreatingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Controls.ImGearMarkCreatingEventArgs

See Also

Reference

ImGearMarkCreatingEventArgs Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMarkCreatingEventArgs Class Members
Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearMarkCreatingEventArgs Class

The following tables list the members exposed by ImGearMarkCreatingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearMarkCreatingEventArgs Constructor | Initializes a new instance of the ImGearMarkCreatingEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the mark will be created.
Public Property | Mark | Gets or sets the mark in which the event fired.
Top
See Also

Reference

ImGearMarkCreatingEventArgs Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMarkCreatingEventArgs Constructor

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearMarkCreatingEventArgs Class : ImGearMarkCreatingEventArgs Constructor
The mark in which the event fired.
Initializes a new instance of the ImGearMarkCreatingEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mark As ImGearARTMark _
)
'Usage

Dim mark As ImGearARTMark

Dim instance As New ImGearMarkCreatingEventArgs(mark)
public ImGearMarkCreatingEventArgs(
   ImGearARTMark mark
)
public: ImGearMarkCreatingEventArgs(
   ImGearARTMark* mark
)
public:
ImGearMarkCreatingEventArgs(
   ImGearARTMark^ mark
)

Parameters

mark
The mark in which the event fired.
See Also

Reference

ImGearMarkCreatingEventArgs Class
ImGearMarkCreatingEventArgs Members


%%PageItemTitle%% $$Properties$$

ImGearMarkCreatingEventArgs Class Properties

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearMarkCreatingEventArgs Class

For a list of all members of this type, see ImGearMarkCreatingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the mark will be created.
Public Property | Mark | Gets or sets the mark in which the event fired.
Top
See Also

Reference

ImGearMarkCreatingEventArgs Class
ImageGear.Windows.Controls Namespace


Cancel Property (ImGearMarkCreatingEventArgs)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearMarkCreatingEventArgs Class : Cancel Property
Gets or sets a value indicating whether the mark will be created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As ImGearMarkCreatingEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearMarkCreatingEventArgs Class
ImGearMarkCreatingEventArgs Members


Mark Property (ImGearMarkCreatingEventArgs)

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > ImGearMarkCreatingEventArgs Class : Mark Property
Gets or sets the mark in which the event fired.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mark As ImGearARTMark
'Usage

Dim instance As ImGearMarkCreatingEventArgs
Dim value As ImGearARTMark

instance.Mark = value

value = instance.Mark
public ImGearARTMark Mark {get; set;}
public: __property ImGearARTMark* get_Mark();
public: __property void set_Mark(
   ImGearARTMark* value
);
public:
property ImGearARTMark^ Mark {
   ImGearARTMark^ get();
   void set (    ImGearARTMark^ value);
}

Property Value

ImGearARTMark value.
Remarks
If this property is modified or set, the specified mark will be added.
See Also

Reference

ImGearMarkCreatingEventArgs Class
ImGearMarkCreatingEventArgs Members


%%PageItemTitle%%

ImGearResizeType Enumeration

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearResizeType Enumeration
Specifies how the mark is being resized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearResizeType
   Inherits System.Enum
'Usage

Dim instance As ImGearResizeType
public enum ImGearResizeType : System.Enum
__value public enum ImGearResizeType : public System.Enum
public enum class ImGearResizeType : public System.Enum
Members
Member | Value | Description
East | 1 | Resize east.
North | 2 | Resize north.
NorthEast | 6 | Resize northeast.
NorthWest | 4 | Resize northwest.
Point | 8 | Move a point.
South | 3 | Resize south.
SouthEast | 7 | Resize southeast.
SouthWest | 5 | Resize southwest.
West | 0 | Resize west.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Controls.ImGearResizeType

See Also

Reference

ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

IImGearMarkEditorWindow Interface
Members

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : IImGearMarkEditorWindow Interface
Defines the annotation mark editor window interface.
Object Model
IImGearMarkEditorWindow Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearMarkEditorWindow
'Usage

Dim instance As IImGearMarkEditorWindow
public interface IImGearMarkEditorWindow
public __gc __interface IImGearMarkEditorWindow
public interface class IImGearMarkEditorWindow
Remarks
The annotation mark property editor control should implement this interface in order for the Annotator to link the editor control to the chosen mark and allow automatic redraw of the mark when its attributes are being edited.
See Also

Reference

IImGearMarkEditorWindow Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

IImGearMarkEditorWindow Interface Members
Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : IImGearMarkEditorWindow Interface

The following tables list the members exposed by IImGearMarkEditorWindow.

Public Methods
 | Name | Description
Method | Show | Makes annotation mark editor window visible.
Top
See Also

Reference

IImGearMarkEditorWindow Interface
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

IImGearMarkEditorWindow Interface Methods

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : IImGearMarkEditorWindow Interface

For a list of all members of this type, see IImGearMarkEditorWindow members.

Public Methods
 | Name | Description
Method | Show | Makes annotation mark editor window visible.
Top
See Also

Reference

IImGearMarkEditorWindow Interface
ImageGear.Windows.Controls Namespace


Show Method

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace > IImGearMarkEditorWindow Interface : Show Method
The ART mark.
The position of the window.
Makes annotation mark editor window visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Show( _
   ByVal mark As ImGearARTMark, _
   ByVal position As Point _
)
'Usage

Dim instance As IImGearMarkEditorWindow
Dim mark As ImGearARTMark
Dim position As Point

instance.Show(mark, position)
void Show(
   ImGearARTMark mark,
   Point position
)
void Show(
   ImGearARTMark* mark,
   Point position
)
void Show(
   ImGearARTMark^ mark,
   Point position
)

Parameters

mark
The ART mark.
position
The position of the window.
See Also

Reference

IImGearMarkEditorWindow Interface
IImGearMarkEditorWindow Members


%%PageItemTitle%%

ImGearMarkCreatingEventHandler Delegate

ImageGear22.Windows.Controls.Art Assembly > ImageGear.Windows.Controls Namespace : ImGearMarkCreatingEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring a MarkCreating event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearMarkCreatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearMarkCreatingEventArgs _
)
'Usage

Dim instance As New ImGearMarkCreatingEventHandler(AddressOf HandlerMethod)
public delegate void ImGearMarkCreatingEventHandler(
   object sender,
   ImGearMarkCreatingEventArgs e
)
public: __gc __delegate void ImGearMarkCreatingEventHandler(
   Object* sender,
   ImGearMarkCreatingEventArgs* e
)
public delegate void ImGearMarkCreatingEventHandler(
   Object^ sender,
   ImGearMarkCreatingEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearMarkCreatingEventHandler Members
ImageGear.Windows.Controls Namespace


ImageGear22.Windows.Controls.Dicom Assembly
Namespaces
Namespace | Description
ImageGear.Windows.Controls | This namespace provides WPF Page View and other common controls to simplify development of XAML based applications.


ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls.Dicom)
Inheritance Hierarchy
ImageGear22.Windows.Controls.Dicom Assembly : ImageGear.Windows.Controls Namespace
This namespace provides WPF Page View and other common controls to simplify development of XAML based applications.
Classes
 | Class | Description
Class | ImGearMprAxialController | Represents a controller for performing MPR operations on an axial stack of images.
Class | ImGearMprController | Represents a controller for performing MPR operations.
Class | ImGearMprCoronalController | Represents a controller for performing MPR operations on a coronal stack of images.
Class | ImGearMprSagittalController | Represents a controller for performing MPR operations on a sagittal stack of images.
Class | ImGearMprSettings | Represents MPR settings.
Class | ImGearMprVisualizer | Represents a view for visualizing MPR results.
See Also

Reference

ImageGear22.Windows.Controls.Dicom Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Windows.Controls Namespace (ImageGear22.Windows.Controls.Dicom) Inheritance Hierarchy
ImageGear22.Windows.Controls.Dicom Assembly : ImageGear.Windows.Controls Namespace
Inheritance Hierarchy
System.Object
ImageGear.Windows.Controls.ImGearMprSettings
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprController
ImageGear.Windows.Controls.ImGearMprAxialController
ImageGear.Windows.Controls.ImGearMprCoronalController
ImageGear.Windows.Controls.ImGearMprSagittalController
ImageGear.Windows.Controls.ImGearMprVisualizer
See Also

Reference

ImageGear22.Windows.Controls.Dicom Assembly


%%PageItemTitle%%

ImGearMprAxialController Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class
Represents a controller for performing MPR operations on an axial stack of images.
Object Model
ImGearMprAxialController ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprAxialController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprAxialController
public class ImGearMprAxialController : ImGearMprController
public __gc class ImGearMprAxialController : public ImGearMprController
public ref class ImGearMprAxialController : public ImGearMprController
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprController
ImageGear.Windows.Controls.ImGearMprAxialController

See Also

Reference

ImGearMprAxialController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprAxialController Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class

The following tables list the members exposed by ImGearMprAxialController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprAxialController Constructor | Initializes a new instance of the ImGearMprAxialController class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CoronalDisplayProperty | Represents CoronalDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalDisplayProperty | Represents SagittalDisplay dependency property.
Top
Public Properties
 | Name | Description
Public Property | CoronalDisplay | Gets the output coronal display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Public Property | SagittalDisplay | Gets the output sagittal display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprAxialController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMprAxialController Constructor

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : ImGearMprAxialController Constructor
Initializes a new instance of the ImGearMprAxialController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprAxialController()
public ImGearMprAxialController()
public: ImGearMprAxialController();
public:
ImGearMprAxialController();
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


%%PageItemTitle%% $$Properties$$

ImGearMprAxialController Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

Public Properties
 | Name | Description
Public Property | CoronalDisplay | Gets the output coronal display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Public Property | SagittalDisplay | Gets the output sagittal display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprAxialController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprAxialController Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

See Also

Reference

ImGearMprAxialController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearMprAxialController Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

See Also

Reference

ImGearMprAxialController Class
ImageGear.Windows.Controls Namespace


ControllerType Property (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : ControllerType Property
Gets the MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprAxialController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


CoronalDisplay Property (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : CoronalDisplay Property
Gets the output coronal display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprAxialController
Dim value As ImGearPresentationPageDisplay

value = instance.CoronalDisplay
public ImGearPresentationPageDisplay CoronalDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_CoronalDisplay();
public:
property ImGearPresentationPageDisplay^ CoronalDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


ObliqueDisplay Property (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : ObliqueDisplay Property
Gets the output oblique display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprAxialController
Dim value As ImGearPresentationPageDisplay

value = instance.ObliqueDisplay
public ImGearPresentationPageDisplay ObliqueDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_ObliqueDisplay();
public:
property ImGearPresentationPageDisplay^ ObliqueDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


SagittalDisplay Property (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : SagittalDisplay Property
Gets the output sagittal display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprAxialController
Dim value As ImGearPresentationPageDisplay

value = instance.SagittalDisplay
public ImGearPresentationPageDisplay SagittalDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_SagittalDisplay();
public:
property ImGearPresentationPageDisplay^ SagittalDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


%%PageItemTitle%% $$Fields$$

ImGearMprAxialController Class Fields

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprAxialController Class

For a list of all members of this type, see ImGearMprAxialController members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CoronalDisplayProperty | Represents CoronalDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalDisplayProperty | Represents SagittalDisplay dependency property.
Top
See Also

Reference

ImGearMprAxialController Class
ImageGear.Windows.Controls Namespace


CoronalDisplayProperty Field (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : CoronalDisplayProperty Field
Represents CoronalDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CoronalDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprAxialController.CoronalDisplayProperty
public static readonly DependencyProperty CoronalDisplayProperty
public: static readonly DependencyProperty* CoronalDisplayProperty
public:
static readonly DependencyProperty^ CoronalDisplayProperty
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


ObliqueDisplayProperty Field (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : ObliqueDisplayProperty Field
Represents ObliqueDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ObliqueDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprAxialController.ObliqueDisplayProperty
public static readonly DependencyProperty ObliqueDisplayProperty
public: static readonly DependencyProperty* ObliqueDisplayProperty
public:
static readonly DependencyProperty^ ObliqueDisplayProperty
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


SagittalDisplayProperty Field (ImGearMprAxialController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprAxialController Class : SagittalDisplayProperty Field
Represents SagittalDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SagittalDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprAxialController.SagittalDisplayProperty
public static readonly DependencyProperty SagittalDisplayProperty
public: static readonly DependencyProperty* SagittalDisplayProperty
public:
static readonly DependencyProperty^ SagittalDisplayProperty
See Also

Reference

ImGearMprAxialController Class
ImGearMprAxialController Members


%%PageItemTitle%%

ImGearMprController Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class
Represents a controller for performing MPR operations.
Object Model
ImGearMprController ClassImGearPresentationPageDisplay ClassImGearDocumentPageArray ClassImGearPage ClassImGearMprSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class ImGearMprController
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearMprController
public abstract class ImGearMprController : System.Windows.Controls.Control
public __gc abstract class ImGearMprController : public System.Windows.Controls.Control
public ref class ImGearMprController abstract : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprController
ImageGear.Windows.Controls.ImGearMprAxialController
ImageGear.Windows.Controls.ImGearMprCoronalController
ImageGear.Windows.Controls.ImGearMprSagittalController

See Also

Reference

ImGearMprController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprController Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class

The following tables list the members exposed by ImGearMprController.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | MaximumPageNumberProperty | Represents MaximumPageNumber dependency property.
static (Shared in Visual Basic) | MinimumPageNumberProperty | Represents MinimumPageNumber dependency property.
static (Shared in Visual Basic) | PageCountProperty | Represents PageCount dependency property.
static (Shared in Visual Basic) | PageDisplayProperty | Represents PageDisplay dependency property.
static (Shared in Visual Basic) | PageNumberProperty | Represents PageNumber dependency property.
static (Shared in Visual Basic) | SettingsProperty | Represents Settings dependency property.
Top
Public Properties
 | Name | Description
Public Property | MaximumPageNumber | Gets the maximum page number.
Public Property | MinimumPageNumber | Gets the minimum page number.
Public Property | PageCount | Gets the number of pages for the current view.
Public Property | PageDisplay | Gets or sets the associated page display.
Public Property | PageNumber | Gets or sets the page number to display.
Public Property | Pages | Gets the collection of pages to perform MPR on.
Public Property | PagesViewType | Gets the pages view type.
Public Property | Settings | Gets MPR settings.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Gets the MPR controller type.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Overloaded. Disposes any resources being used.
Public Method | SetPages | Sets the collection of pages to perform MPR on.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprController Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

Public Methods
 | Name | Description
Public Method | Dispose | Overloaded. Disposes any resources being used.
Public Method | SetPages | Sets the collection of pages to perform MPR on.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearMprController Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

See Also

Reference

ImGearMprController Class
ImageGear.Windows.Controls Namespace


Dispose Method (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : Dispose Method
Disposes any resources being used.
Overload List
Overload | Description
Dispose() | Disposes any resources being used.
Dispose(Boolean) | Disposes any resources being used.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Dispose() Method

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class > Dispose Method : Dispose() Method
Disposes any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Dispose()
'Usage

Dim instance As ImGearMprController

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImGearMprController Class
ImGearMprController Members
Overload List


Dispose(Boolean) Method

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Disposes any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearMprController
Dim disposing As Boolean

instance.Dispose(disposing)
protected virtual void Dispose(
   bool disposing
)
protected: virtual void Dispose(
   bool disposing
)
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearMprController Class
ImGearMprController Members
Overload List


SetPages Method (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : SetPages Method
Collection of pages.
View type of the pages.
Sets the collection of pages to perform MPR on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPages( _
   ByVal pages As ImGearDocumentPageArray, _
   ByVal pagesViewType As ImGearMprViewType _
)
'Usage

Dim instance As ImGearMprController
Dim pages As ImGearDocumentPageArray
Dim pagesViewType As ImGearMprViewType

instance.SetPages(pages, pagesViewType)
public void SetPages(
   ImGearDocumentPageArray pages,
   ImGearMprViewType pagesViewType
)
public: void SetPages(
   ImGearDocumentPageArray* pages,
   ImGearMprViewType pagesViewType
)
public:
void SetPages(
   ImGearDocumentPageArray^ pages,
   ImGearMprViewType pagesViewType
)

Parameters

pages
Collection of pages.
pagesViewType
View type of the pages.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


%%PageItemTitle%% $$Properties$$

ImGearMprController Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

Public Properties
 | Name | Description
Public Property | MaximumPageNumber | Gets the maximum page number.
Public Property | MinimumPageNumber | Gets the minimum page number.
Public Property | PageCount | Gets the number of pages for the current view.
Public Property | PageDisplay | Gets or sets the associated page display.
Public Property | PageNumber | Gets or sets the page number to display.
Public Property | Pages | Gets the collection of pages to perform MPR on.
Public Property | PagesViewType | Gets the pages view type.
Public Property | Settings | Gets MPR settings.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Gets the MPR controller type.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Windows.Controls Namespace


ControllerType Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : ControllerType Property
Gets the MPR controller type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected abstract ImGearMprViewType ControllerType {get;}
protected: __property abstract ImGearMprViewType get_ControllerType();
protected:
abstract property ImGearMprViewType ControllerType {
   ImGearMprViewType get();
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


MaximumPageNumber Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : MaximumPageNumber Property
Gets the maximum page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MaximumPageNumber As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

value = instance.MaximumPageNumber
public int MaximumPageNumber {get;}
public: __property int get_MaximumPageNumber();
public:
property int MaximumPageNumber {
   int get();
}
See Also

Reference

ImGearMprController Class
ImGearMprController Members


MinimumPageNumber Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : MinimumPageNumber Property
Gets the minimum page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MinimumPageNumber As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

value = instance.MinimumPageNumber
public int MinimumPageNumber {get;}
public: __property int get_MinimumPageNumber();
public:
property int MinimumPageNumber {
   int get();
}
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageCount Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageCount Property
Gets the number of pages for the current view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageDisplay Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageDisplay Property
Gets or sets the associated page display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprController
Dim value As ImGearPresentationPageDisplay

instance.PageDisplay = value

value = instance.PageDisplay
public ImGearPresentationPageDisplay PageDisplay {get; set;}
public: __property ImGearPresentationPageDisplay* get_PageDisplay();
public: __property void set_PageDisplay(
   ImGearPresentationPageDisplay* value
);
public:
property ImGearPresentationPageDisplay^ PageDisplay {
   ImGearPresentationPageDisplay^ get();
   void set (    ImGearPresentationPageDisplay^ value);
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageNumber Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageNumber Property
Gets or sets the page number to display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ImGearMprController
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Pages Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : Pages Property
Gets the collection of pages to perform MPR on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearMprController
Dim value As ImGearDocumentPageArray

value = instance.Pages
public ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages();
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get();
}

Property Value

ImageGear.Core.ImGearDocumentPageArray class object.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PagesViewType Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PagesViewType Property
Gets the pages view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PagesViewType As ImGearMprViewType
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprViewType

value = instance.PagesViewType
public ImGearMprViewType PagesViewType {get;}
public: __property ImGearMprViewType get_PagesViewType();
public:
property ImGearMprViewType PagesViewType {
   ImGearMprViewType get();
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


Settings Property (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : Settings Property
Gets MPR settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Settings As ImGearMprSettings
'Usage

Dim instance As ImGearMprController
Dim value As ImGearMprSettings

value = instance.Settings
public ImGearMprSettings Settings {get;}
public: __property ImGearMprSettings* get_Settings();
public:
property ImGearMprSettings^ Settings {
   ImGearMprSettings^ get();
}

Property Value

ImGearMprSettings class object.
See Also

Reference

ImGearMprController Class
ImGearMprController Members


%%PageItemTitle%% $$Fields$$

ImGearMprController Class Fields

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprController Class

For a list of all members of this type, see ImGearMprController members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | MaximumPageNumberProperty | Represents MaximumPageNumber dependency property.
static (Shared in Visual Basic) | MinimumPageNumberProperty | Represents MinimumPageNumber dependency property.
static (Shared in Visual Basic) | PageCountProperty | Represents PageCount dependency property.
static (Shared in Visual Basic) | PageDisplayProperty | Represents PageDisplay dependency property.
static (Shared in Visual Basic) | PageNumberProperty | Represents PageNumber dependency property.
static (Shared in Visual Basic) | SettingsProperty | Represents Settings dependency property.
Top
See Also

Reference

ImGearMprController Class
ImageGear.Windows.Controls Namespace


MaximumPageNumberProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : MaximumPageNumberProperty Field
Represents MaximumPageNumber dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MaximumPageNumberProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.MaximumPageNumberProperty
public static readonly DependencyProperty MaximumPageNumberProperty
public: static readonly DependencyProperty* MaximumPageNumberProperty
public:
static readonly DependencyProperty^ MaximumPageNumberProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


MinimumPageNumberProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : MinimumPageNumberProperty Field
Represents MinimumPageNumber dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MinimumPageNumberProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.MinimumPageNumberProperty
public static readonly DependencyProperty MinimumPageNumberProperty
public: static readonly DependencyProperty* MinimumPageNumberProperty
public:
static readonly DependencyProperty^ MinimumPageNumberProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageCountProperty Field (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageCountProperty Field
Represents PageCount dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageCountProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.PageCountProperty
public static readonly DependencyProperty PageCountProperty
public: static readonly DependencyProperty* PageCountProperty
public:
static readonly DependencyProperty^ PageCountProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageDisplayProperty Field (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageDisplayProperty Field
Represents PageDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.PageDisplayProperty
public static readonly DependencyProperty PageDisplayProperty
public: static readonly DependencyProperty* PageDisplayProperty
public:
static readonly DependencyProperty^ PageDisplayProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


PageNumberProperty Field (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : PageNumberProperty Field
Represents PageNumber dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PageNumberProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.PageNumberProperty
public static readonly DependencyProperty PageNumberProperty
public: static readonly DependencyProperty* PageNumberProperty
public:
static readonly DependencyProperty^ PageNumberProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


SettingsProperty Field (ImGearMprController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprController Class : SettingsProperty Field
Represents Settings dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SettingsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprController.SettingsProperty
public static readonly DependencyProperty SettingsProperty
public: static readonly DependencyProperty* SettingsProperty
public:
static readonly DependencyProperty^ SettingsProperty
See Also

Reference

ImGearMprController Class
ImGearMprController Members


%%PageItemTitle%%

ImGearMprCoronalController Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class
Represents a controller for performing MPR operations on a coronal stack of images.
Object Model
ImGearMprCoronalController ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprCoronalController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprCoronalController
public class ImGearMprCoronalController : ImGearMprController
public __gc class ImGearMprCoronalController : public ImGearMprController
public ref class ImGearMprCoronalController : public ImGearMprController
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprController
ImageGear.Windows.Controls.ImGearMprCoronalController

See Also

Reference

ImGearMprCoronalController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprCoronalController Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class

The following tables list the members exposed by ImGearMprCoronalController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprCoronalController Constructor | Initializes a new instance of the ImGearMprCoronalController class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AxialDisplayProperty | Represents AxialDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalDisplayProperty | Represents SagittalDisplay dependency property.
Top
Public Properties
 | Name | Description
Public Property | AxialDisplay | Gets the output axial display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Public Property | SagittalDisplay | Gets the output sagittal display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprCoronalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMprCoronalController Constructor

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : ImGearMprCoronalController Constructor
Initializes a new instance of the ImGearMprCoronalController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprCoronalController()
public ImGearMprCoronalController()
public: ImGearMprCoronalController();
public:
ImGearMprCoronalController();
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


%%PageItemTitle%% $$Properties$$

ImGearMprCoronalController Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

Public Properties
 | Name | Description
Public Property | AxialDisplay | Gets the output axial display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Public Property | SagittalDisplay | Gets the output sagittal display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprCoronalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprCoronalController Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

See Also

Reference

ImGearMprCoronalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearMprCoronalController Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

See Also

Reference

ImGearMprCoronalController Class
ImageGear.Windows.Controls Namespace


AxialDisplay Property (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : AxialDisplay Property
Gets the output axial display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ImGearPresentationPageDisplay

value = instance.AxialDisplay
public ImGearPresentationPageDisplay AxialDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_AxialDisplay();
public:
property ImGearPresentationPageDisplay^ AxialDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


ControllerType Property (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : ControllerType Property
Gets the MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


ObliqueDisplay Property (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : ObliqueDisplay Property
Gets the output oblique display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ImGearPresentationPageDisplay

value = instance.ObliqueDisplay
public ImGearPresentationPageDisplay ObliqueDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_ObliqueDisplay();
public:
property ImGearPresentationPageDisplay^ ObliqueDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


SagittalDisplay Property (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : SagittalDisplay Property
Gets the output sagittal display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprCoronalController
Dim value As ImGearPresentationPageDisplay

value = instance.SagittalDisplay
public ImGearPresentationPageDisplay SagittalDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_SagittalDisplay();
public:
property ImGearPresentationPageDisplay^ SagittalDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


%%PageItemTitle%% $$Fields$$

ImGearMprCoronalController Class Fields

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprCoronalController Class

For a list of all members of this type, see ImGearMprCoronalController members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AxialDisplayProperty | Represents AxialDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalDisplayProperty | Represents SagittalDisplay dependency property.
Top
See Also

Reference

ImGearMprCoronalController Class
ImageGear.Windows.Controls Namespace


AxialDisplayProperty Field (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : AxialDisplayProperty Field
Represents AxialDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AxialDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprCoronalController.AxialDisplayProperty
public static readonly DependencyProperty AxialDisplayProperty
public: static readonly DependencyProperty* AxialDisplayProperty
public:
static readonly DependencyProperty^ AxialDisplayProperty
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


ObliqueDisplayProperty Field (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : ObliqueDisplayProperty Field
Represents ObliqueDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ObliqueDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprCoronalController.ObliqueDisplayProperty
public static readonly DependencyProperty ObliqueDisplayProperty
public: static readonly DependencyProperty* ObliqueDisplayProperty
public:
static readonly DependencyProperty^ ObliqueDisplayProperty
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


SagittalDisplayProperty Field (ImGearMprCoronalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprCoronalController Class : SagittalDisplayProperty Field
Represents SagittalDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SagittalDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprCoronalController.SagittalDisplayProperty
public static readonly DependencyProperty SagittalDisplayProperty
public: static readonly DependencyProperty* SagittalDisplayProperty
public:
static readonly DependencyProperty^ SagittalDisplayProperty
See Also

Reference

ImGearMprCoronalController Class
ImGearMprCoronalController Members


%%PageItemTitle%%

ImGearMprSagittalController Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class
Represents a controller for performing MPR operations on a sagittal stack of images.
Object Model
ImGearMprSagittalController ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay ClassImGearPresentationPageDisplay Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprSagittalController
   Inherits ImGearMprController
'Usage

Dim instance As ImGearMprSagittalController
public class ImGearMprSagittalController : ImGearMprController
public __gc class ImGearMprSagittalController : public ImGearMprController
public ref class ImGearMprSagittalController : public ImGearMprController
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprController
ImageGear.Windows.Controls.ImGearMprSagittalController

See Also

Reference

ImGearMprSagittalController Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprSagittalController Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class

The following tables list the members exposed by ImGearMprSagittalController.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprSagittalController Constructor | Initializes a new instance of the ImGearMprSagittalController class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AxialDisplayProperty | Represents AxialDisplay dependency property.
static (Shared in Visual Basic) | CoronalDisplayProperty | Represents CoronalDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
Top
Public Properties
 | Name | Description
Public Property | AxialDisplay | Gets the output axial display.
Public Property | CoronalDisplay | Gets the output coronal display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprSagittalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMprSagittalController Constructor

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : ImGearMprSagittalController Constructor
Initializes a new instance of the ImGearMprSagittalController class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprSagittalController()
public ImGearMprSagittalController()
public: ImGearMprSagittalController();
public:
ImGearMprSagittalController();
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


%%PageItemTitle%% $$Properties$$

ImGearMprSagittalController Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

Public Properties
 | Name | Description
Public Property | AxialDisplay | Gets the output axial display.
Public Property | CoronalDisplay | Gets the output coronal display.
Public Property | ObliqueDisplay | Gets the output oblique display.
Top
Protected Properties
 | Name | Description
Protected Property | ControllerType | Overridden. Gets the MPR view type.
Top
See Also

Reference

ImGearMprSagittalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

ImGearMprSagittalController Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

See Also

Reference

ImGearMprSagittalController Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearMprSagittalController Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

See Also

Reference

ImGearMprSagittalController Class
ImageGear.Windows.Controls Namespace


AxialDisplay Property (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : AxialDisplay Property
Gets the output axial display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ImGearPresentationPageDisplay

value = instance.AxialDisplay
public ImGearPresentationPageDisplay AxialDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_AxialDisplay();
public:
property ImGearPresentationPageDisplay^ AxialDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


ControllerType Property (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : ControllerType Property
Gets the MPR view type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ControllerType As ImGearMprViewType
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ImGearMprViewType

value = instance.ControllerType
protected override ImGearMprViewType ControllerType {get;}
protected: __property ImGearMprViewType get_ControllerType() override;
protected:
property ImGearMprViewType ControllerType {
   ImGearMprViewType get() override;
}

Property Value

ImGearMprViewType value.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


CoronalDisplay Property (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : CoronalDisplay Property
Gets the output coronal display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ImGearPresentationPageDisplay

value = instance.CoronalDisplay
public ImGearPresentationPageDisplay CoronalDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_CoronalDisplay();
public:
property ImGearPresentationPageDisplay^ CoronalDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


ObliqueDisplay Property (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : ObliqueDisplay Property
Gets the output oblique display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprSagittalController
Dim value As ImGearPresentationPageDisplay

value = instance.ObliqueDisplay
public ImGearPresentationPageDisplay ObliqueDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_ObliqueDisplay();
public:
property ImGearPresentationPageDisplay^ ObliqueDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


%%PageItemTitle%% $$Fields$$

ImGearMprSagittalController Class Fields

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSagittalController Class

For a list of all members of this type, see ImGearMprSagittalController members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AxialDisplayProperty | Represents AxialDisplay dependency property.
static (Shared in Visual Basic) | CoronalDisplayProperty | Represents CoronalDisplay dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
Top
See Also

Reference

ImGearMprSagittalController Class
ImageGear.Windows.Controls Namespace


AxialDisplayProperty Field (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : AxialDisplayProperty Field
Represents AxialDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AxialDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprSagittalController.AxialDisplayProperty
public static readonly DependencyProperty AxialDisplayProperty
public: static readonly DependencyProperty* AxialDisplayProperty
public:
static readonly DependencyProperty^ AxialDisplayProperty
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


CoronalDisplayProperty Field (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : CoronalDisplayProperty Field
Represents CoronalDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CoronalDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprSagittalController.CoronalDisplayProperty
public static readonly DependencyProperty CoronalDisplayProperty
public: static readonly DependencyProperty* CoronalDisplayProperty
public:
static readonly DependencyProperty^ CoronalDisplayProperty
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


ObliqueDisplayProperty Field (ImGearMprSagittalController)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSagittalController Class : ObliqueDisplayProperty Field
Represents ObliqueDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ObliqueDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprSagittalController.ObliqueDisplayProperty
public static readonly DependencyProperty ObliqueDisplayProperty
public: static readonly DependencyProperty* ObliqueDisplayProperty
public:
static readonly DependencyProperty^ ObliqueDisplayProperty
See Also

Reference

ImGearMprSagittalController Class
ImGearMprSagittalController Members


%%PageItemTitle%%

ImGearMprSettings Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSettings Class
Represents MPR settings.
Object Model
ImGearMprSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprSettings
'Usage

Dim instance As ImGearMprSettings
public class ImGearMprSettings
public __gc class ImGearMprSettings
public ref class ImGearMprSettings
Inheritance Hierarchy

System.Object
ImageGear.Windows.Controls.ImGearMprSettings

See Also

Reference

ImGearMprSettings Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprSettings Class Members
Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSettings Class

The following tables list the members exposed by ImGearMprSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprSettings Constructor | Initializes a new instance of the ImGearMprSettings class.
Top
Public Properties
 | Name | Description
Public Property | AxialLineBrush | Gets or sets the color of the MPR line for axial view reconstruction.
Public Property | CoronalLineBrush | Gets or sets the color of the MPR line for coronal view reconstruction.
Public Property | ObliqueLineBrush | Gets or sets the color of the MPR line for oblique view reconstruction.
Public Property | SagittalLineBrush | Gets or sets the color of the MPR line for sagittal view reconstruction.
Top
Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMprSettings Constructor

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : ImGearMprSettings Constructor
Initializes a new instance of the ImGearMprSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprSettings()
public ImGearMprSettings()
public: ImGearMprSettings();
public:
ImGearMprSettings();
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%% $$Methods$$

ImGearMprSettings Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSettings Class

For a list of all members of this type, see ImGearMprSettings members.

Protected Methods
 | Name | Description
Protected Method | OnPropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Windows.Controls Namespace


OnPropertyChanged Method (ImGearMprSettings)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : OnPropertyChanged Method
The name of the property that changed.
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub OnPropertyChanged( _
   ByVal name As String _
)
'Usage

Dim instance As ImGearMprSettings
Dim name As String

instance.OnPropertyChanged(name)
protected void OnPropertyChanged(
   string name
)
protected: void OnPropertyChanged(
   string* name
)
protected:
void OnPropertyChanged(
   String^ name
)

Parameters

name
The name of the property that changed.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%% $$Properties$$

ImGearMprSettings Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSettings Class

For a list of all members of this type, see ImGearMprSettings members.

Public Properties
 | Name | Description
Public Property | AxialLineBrush | Gets or sets the color of the MPR line for axial view reconstruction.
Public Property | CoronalLineBrush | Gets or sets the color of the MPR line for coronal view reconstruction.
Public Property | ObliqueLineBrush | Gets or sets the color of the MPR line for oblique view reconstruction.
Public Property | SagittalLineBrush | Gets or sets the color of the MPR line for sagittal view reconstruction.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Windows.Controls Namespace


AxialLineBrush Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : AxialLineBrush Property
Gets or sets the color of the MPR line for axial view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AxialLineBrush As SolidColorBrush
'Usage

Dim instance As ImGearMprSettings
Dim value As SolidColorBrush

instance.AxialLineBrush = value

value = instance.AxialLineBrush
public SolidColorBrush AxialLineBrush {get; set;}
public: __property SolidColorBrush* get_AxialLineBrush();
public: __property void set_AxialLineBrush(
   SolidColorBrush* value
);
public:
property SolidColorBrush^ AxialLineBrush {
   SolidColorBrush^ get();
   void set (    SolidColorBrush^ value);
}

Property Value

SolidColorBrush value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


CoronalLineBrush Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : CoronalLineBrush Property
Gets or sets the color of the MPR line for coronal view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CoronalLineBrush As SolidColorBrush
'Usage

Dim instance As ImGearMprSettings
Dim value As SolidColorBrush

instance.CoronalLineBrush = value

value = instance.CoronalLineBrush
public SolidColorBrush CoronalLineBrush {get; set;}
public: __property SolidColorBrush* get_CoronalLineBrush();
public: __property void set_CoronalLineBrush(
   SolidColorBrush* value
);
public:
property SolidColorBrush^ CoronalLineBrush {
   SolidColorBrush^ get();
   void set (    SolidColorBrush^ value);
}

Property Value

SolidColorBrush value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


ObliqueLineBrush Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : ObliqueLineBrush Property
Gets or sets the color of the MPR line for oblique view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObliqueLineBrush As SolidColorBrush
'Usage

Dim instance As ImGearMprSettings
Dim value As SolidColorBrush

instance.ObliqueLineBrush = value

value = instance.ObliqueLineBrush
public SolidColorBrush ObliqueLineBrush {get; set;}
public: __property SolidColorBrush* get_ObliqueLineBrush();
public: __property void set_ObliqueLineBrush(
   SolidColorBrush* value
);
public:
property SolidColorBrush^ ObliqueLineBrush {
   SolidColorBrush^ get();
   void set (    SolidColorBrush^ value);
}

Property Value

SolidColorBrush value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


SagittalLineBrush Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : SagittalLineBrush Property
Gets or sets the color of the MPR line for sagittal view reconstruction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SagittalLineBrush As SolidColorBrush
'Usage

Dim instance As ImGearMprSettings
Dim value As SolidColorBrush

instance.SagittalLineBrush = value

value = instance.SagittalLineBrush
public SolidColorBrush SagittalLineBrush {get; set;}
public: __property SolidColorBrush* get_SagittalLineBrush();
public: __property void set_SagittalLineBrush(
   SolidColorBrush* value
);
public:
property SolidColorBrush^ SagittalLineBrush {
   SolidColorBrush^ get();
   void set (    SolidColorBrush^ value);
}

Property Value

SolidColorBrush value.
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%% $$Events$$

ImGearMprSettings Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprSettings Class

For a list of all members of this type, see ImGearMprSettings members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ImGearMprSettings Class
ImageGear.Windows.Controls Namespace


PropertyChanged Event (ImGearMprSettings)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprSettings Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As ImGearMprSettings
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ImGearMprSettings Class
ImGearMprSettings Members


%%PageItemTitle%%

ImGearMprVisualizer Class
Members

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class
Represents a view for visualizing MPR results.
Object Model
ImGearMprVisualizer ClassImGearMprController ClassImGearMprAxialController ClassImGearMprCoronalController ClassImGearPresentationPageDisplay ClassImGearMprSagittalController ClassImGearMprSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMprVisualizer
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearMprVisualizer
public class ImGearMprVisualizer : System.Windows.Controls.Control
public __gc class ImGearMprVisualizer : public System.Windows.Controls.Control
public ref class ImGearMprVisualizer : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.Windows.Controls.ImGearMprVisualizer

See Also

Reference

ImGearMprVisualizer Members
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

ImGearMprVisualizer Class Members
Fields Properties Methods Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class

The following tables list the members exposed by ImGearMprVisualizer.

Public Constructors
 | Name | Description
Public Constructor | ImGearMprVisualizer Constructor | Initializes a new instance of the ImGearMprVisualizer class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ActiveControllerProperty | Represents ActiveController dependency property.
static (Shared in Visual Basic) | AxialControllerProperty | Represents AxialController dependency property.
static (Shared in Visual Basic) | CoronalControllerProperty | Represents CoronalController dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalControllerProperty | Represents SagittalController dependency property.
static (Shared in Visual Basic) | SettingsProperty | Represents Settings dependency property.
Top
Public Properties
 | Name | Description
Public Property | ActiveController | Gets or sets the currently active MPR controller.
Public Property | AxialController | Gets the MPR axial controller.
Public Property | CoronalController | Gets the MPR coronal controller.
Public Property | ObliqueDisplay | Gets the oblique display.
Public Property | SagittalController | Gets the MPR sagittal controller.
Public Property | Settings | Gets MPR settings.
Top
Public Methods
 | Name | Description
Public Method | Initialize | Initializes the visualizer with pages in the specified view type. This method should be called before loading.
Public Method | OnApplyTemplate | Overridden. Applies the template.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%%

ImGearMprVisualizer Constructor

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : ImGearMprVisualizer Constructor
Initializes a new instance of the ImGearMprVisualizer class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMprVisualizer()
public ImGearMprVisualizer()
public: ImGearMprVisualizer();
public:
ImGearMprVisualizer();
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


%%PageItemTitle%% $$Methods$$

ImGearMprVisualizer Class Methods

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

Public Methods
 | Name | Description
Public Method | Initialize | Initializes the visualizer with pages in the specified view type. This method should be called before loading.
Public Method | OnApplyTemplate | Overridden. Applies the template.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

ImGearMprVisualizer Class Events

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

See Also

Reference

ImGearMprVisualizer Class
ImageGear.Windows.Controls Namespace


Initialize Method (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : Initialize Method
Collection of pages to perform MPR on.
Type of MPR view the page collection represents.
Initializes the visualizer with pages in the specified view type. This method should be called before loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Initialize( _
   ByVal pageCollection As ImGearDocumentPageArray, _
   ByVal collectionViewType As ImGearMprViewType _
)
'Usage

Dim instance As ImGearMprVisualizer
Dim pageCollection As ImGearDocumentPageArray
Dim collectionViewType As ImGearMprViewType

instance.Initialize(pageCollection, collectionViewType)
public void Initialize(
   ImGearDocumentPageArray pageCollection,
   ImGearMprViewType collectionViewType
)
public: void Initialize(
   ImGearDocumentPageArray* pageCollection,
   ImGearMprViewType collectionViewType
)
public:
void Initialize(
   ImGearDocumentPageArray^ pageCollection,
   ImGearMprViewType collectionViewType
)

Parameters

pageCollection
Collection of pages to perform MPR on.
collectionViewType
Type of MPR view the page collection represents.
Exceptions
Exception | Description
System.ArgumentNullException | Page collection is null.
System.ArgumentException | View type cannot be Oblique.
ImageGear.Core.ImGearException | The MPR Visualizer is already initialized.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


OnApplyTemplate Method (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : OnApplyTemplate Method
Applies the template.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As ImGearMprVisualizer

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


%%PageItemTitle%% $$Properties$$

ImGearMprVisualizer Class Properties

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

Public Properties
 | Name | Description
Public Property | ActiveController | Gets or sets the currently active MPR controller.
Public Property | AxialController | Gets the MPR axial controller.
Public Property | CoronalController | Gets the MPR coronal controller.
Public Property | ObliqueDisplay | Gets the oblique display.
Public Property | SagittalController | Gets the MPR sagittal controller.
Public Property | Settings | Gets MPR settings.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Windows.Controls Namespace


ActiveController Property

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : ActiveController Property
Gets or sets the currently active MPR controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActiveController As ImGearMprController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprController

instance.ActiveController = value

value = instance.ActiveController
public ImGearMprController ActiveController {get; set;}
public: __property ImGearMprController* get_ActiveController();
public: __property void set_ActiveController(
   ImGearMprController* value
);
public:
property ImGearMprController^ ActiveController {
   ImGearMprController^ get();
   void set (    ImGearMprController^ value);
}

Property Value

ImGearMprController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


AxialController Property (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : AxialController Property
Gets the MPR axial controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AxialController As ImGearMprAxialController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprAxialController

value = instance.AxialController
public ImGearMprAxialController AxialController {get;}
public: __property ImGearMprAxialController* get_AxialController();
public:
property ImGearMprAxialController^ AxialController {
   ImGearMprAxialController^ get();
}

Property Value

ImGearMprAxialController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


CoronalController Property (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : CoronalController Property
Gets the MPR coronal controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CoronalController As ImGearMprCoronalController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprCoronalController

value = instance.CoronalController
public ImGearMprCoronalController CoronalController {get;}
public: __property ImGearMprCoronalController* get_CoronalController();
public:
property ImGearMprCoronalController^ CoronalController {
   ImGearMprCoronalController^ get();
}

Property Value

ImGearMprCoronalController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


ObliqueDisplay Property (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : ObliqueDisplay Property
Gets the oblique display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObliqueDisplay As ImGearPresentationPageDisplay
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearPresentationPageDisplay

value = instance.ObliqueDisplay
public ImGearPresentationPageDisplay ObliqueDisplay {get;}
public: __property ImGearPresentationPageDisplay* get_ObliqueDisplay();
public:
property ImGearPresentationPageDisplay^ ObliqueDisplay {
   ImGearPresentationPageDisplay^ get();
}

Property Value

ImageGear.Display.ImGearPresentationPageDisplay value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


SagittalController Property (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : SagittalController Property
Gets the MPR sagittal controller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SagittalController As ImGearMprSagittalController
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprSagittalController

value = instance.SagittalController
public ImGearMprSagittalController SagittalController {get;}
public: __property ImGearMprSagittalController* get_SagittalController();
public:
property ImGearMprSagittalController^ SagittalController {
   ImGearMprSagittalController^ get();
}

Property Value

ImGearMprSagittalController value.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


Settings Property (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : Settings Property
Gets MPR settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Settings As ImGearMprSettings
'Usage

Dim instance As ImGearMprVisualizer
Dim value As ImGearMprSettings

value = instance.Settings
public ImGearMprSettings Settings {get;}
public: __property ImGearMprSettings* get_Settings();
public:
property ImGearMprSettings^ Settings {
   ImGearMprSettings^ get();
}

Property Value

ImGearMprSettings class object.
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


%%PageItemTitle%% $$Fields$$

ImGearMprVisualizer Class Fields

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace : ImGearMprVisualizer Class

For a list of all members of this type, see ImGearMprVisualizer members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ActiveControllerProperty | Represents ActiveController dependency property.
static (Shared in Visual Basic) | AxialControllerProperty | Represents AxialController dependency property.
static (Shared in Visual Basic) | CoronalControllerProperty | Represents CoronalController dependency property.
static (Shared in Visual Basic) | ObliqueDisplayProperty | Represents ObliqueDisplay dependency property.
static (Shared in Visual Basic) | SagittalControllerProperty | Represents SagittalController dependency property.
static (Shared in Visual Basic) | SettingsProperty | Represents Settings dependency property.
Top
See Also

Reference

ImGearMprVisualizer Class
ImageGear.Windows.Controls Namespace


ActiveControllerProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : ActiveControllerProperty Field
Represents ActiveController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ActiveControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.ActiveControllerProperty
public static readonly DependencyProperty ActiveControllerProperty
public: static readonly DependencyProperty* ActiveControllerProperty
public:
static readonly DependencyProperty^ ActiveControllerProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


AxialControllerProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : AxialControllerProperty Field
Represents AxialController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AxialControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.AxialControllerProperty
public static readonly DependencyProperty AxialControllerProperty
public: static readonly DependencyProperty* AxialControllerProperty
public:
static readonly DependencyProperty^ AxialControllerProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


CoronalControllerProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : CoronalControllerProperty Field
Represents CoronalController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CoronalControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.CoronalControllerProperty
public static readonly DependencyProperty CoronalControllerProperty
public: static readonly DependencyProperty* CoronalControllerProperty
public:
static readonly DependencyProperty^ CoronalControllerProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


ObliqueDisplayProperty Field (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : ObliqueDisplayProperty Field
Represents ObliqueDisplay dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ObliqueDisplayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.ObliqueDisplayProperty
public static readonly DependencyProperty ObliqueDisplayProperty
public: static readonly DependencyProperty* ObliqueDisplayProperty
public:
static readonly DependencyProperty^ ObliqueDisplayProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


SagittalControllerProperty Field

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : SagittalControllerProperty Field
Represents SagittalController dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SagittalControllerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.SagittalControllerProperty
public static readonly DependencyProperty SagittalControllerProperty
public: static readonly DependencyProperty* SagittalControllerProperty
public:
static readonly DependencyProperty^ SagittalControllerProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


SettingsProperty Field (ImGearMprVisualizer)

ImageGear22.Windows.Controls.Dicom Assembly > ImageGear.Windows.Controls Namespace > ImGearMprVisualizer Class : SettingsProperty Field
Represents Settings dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SettingsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMprVisualizer.SettingsProperty
public static readonly DependencyProperty SettingsProperty
public: static readonly DependencyProperty* SettingsProperty
public:
static readonly DependencyProperty^ SettingsProperty
See Also

Reference

ImGearMprVisualizer Class
ImGearMprVisualizer Members


ImageGear22.Windows.Forms Assembly
Namespaces
Namespace | Description
ImageGear.Windows.Forms | The ImageGear.Windows.Forms namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly, using only public ImageGear API, with source code provided to enable modifications.
ImageGear.Windows.Forms.Thumbnails | This namespace provides GUI Thumbnail control API.


ImageGear.Windows.Forms Namespace
Inheritance Hierarchy
ImageGear22.Windows.Forms Assembly : ImageGear.Windows.Forms Namespace
The ImageGear.Windows.Forms namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly, using only public ImageGear API, with source code provided to enable modifications.
Classes
 | Class | Description
Class | AntiAliasingOptions | GUI dialog class for accessing anti-aliasing options.
Class | IGWarningInfoBox | This class provides a window for displaying ImageGear warning messages.
Class | ImGearAfterDrawEventArgs | Event arguments class for ImGearPageView.AfterDrawEvent event.
Class | ImGearARTLoadingSelection | Identifies a file and format selected in an open file dialog for ART annotations.
Class | ImGearARTSavingSelection | Identifies a file and format selected in a save file dialog for ART annotations.
Class | ImGearColorBookProperties | GUI dialog class for accessing color book properties.
Class | ImGearColorBookSettings | GUI dialog class for accessing the available color books.
Class | ImGearColorProfileSettings | GUI dialog class for ICC setting.
Class | ImGearExtraChannelColorChoice | GUI dialog class for choosing a color for the specified extra channel.
Class | ImGearExtraChannelsSwitching | GUI dialog class for enabling and disabling color channels for display.
Class | ImGearFile | Identifies a file and its location.
Class | ImGearLayersSwitching | GUI dialog for turning on and off the layers of the layered page, and flattening them into the raster output page.
Class | ImGearLoadingSelection | Identifies a file and format selected in an open file dialog.
Class | ImGearLoadingSelectionEx | This class identifies a file, format and page index selected in the open file dialog with preview shown by the ImGearWinForms.SelectLocalFileToLoadEx method.
Class | ImGearLocalFile | Represents a file on a local file system.
Class | ImGearMagnifier | Provides interactive magnifying glass style user interface for displayed images.
Class | ImGearPageView | A control for displaying an image within a form.
Class | ImGearPan | This is the GUI Pan Control that allows the visible portion of an image displayed in the ImGearPageView class control to be moved by dragging the mouse around in the image.
Class | ImGearRemoteFile | Represents a file on a remote file system, such as a web server.
Class | ImGearSavingSelection | Identifies a file and format selected in a save file dialog.
Class | ImGearScrollBarIncrement | Settings for a scroll bar increment including the value of the increment and what type of value.
Class | ImGearSpotColorsMissingBox | GUI dialog class for processing missing spot colors.
Class | ImGearWinForms | Provides methods for using common dialogs and error handling infrastructure.
Class | LayerPropertiesBox | GUI dialog for accessing and changing the image layer's properties.
Delegates
 | Delegate | Description
Delegate | ImGearPageView.AfterDraw | Delegate for method registered with RegisterAfterDraw method, to be called after default painting has been performed.
Delegate | ImGearPageView.DelegatePageCalculate | This delegate, if registered, is automatically called from the ImGearPageView class when the user presses Page Up or Page Down.
Enumerations
 | Enumeration | Description
Enumeration | ImGearColorProfileActivationMode | Specifies color profile activation modes.
Enumeration | ImGearMagnifierShapeType | Specifies the shape type of magnifier.
Enumeration | ImGearScrollBarIncrementType | Types of scroll bar increment values.
See Also

Reference

ImageGear22.Windows.Forms Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Windows.Forms Namespace Inheritance Hierarchy
ImageGear22.Windows.Forms Assembly : ImageGear.Windows.Forms Namespace
Inheritance Hierarchy
System.Object
ImageGear.Windows.Forms.ImGearARTLoadingSelection
ImageGear.Windows.Forms.ImGearARTSavingSelection
ImageGear.Windows.Forms.ImGearFile
ImageGear.Windows.Forms.ImGearLocalFile
ImageGear.Windows.Forms.ImGearRemoteFile
ImageGear.Windows.Forms.ImGearLoadingSelection
ImageGear.Windows.Forms.ImGearLoadingSelectionEx
ImageGear.Windows.Forms.ImGearSavingSelection
ImageGear.Windows.Forms.ImGearScrollBarIncrement
ImageGear.Windows.Forms.ImGearWinForms
System.EventArgs
ImageGear.Windows.Forms.ImGearAfterDrawEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
ImageGear.Windows.Forms.ImGearMagnifier
ImageGear.Windows.Forms.ImGearPan
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.AntiAliasingOptions
ImageGear.Windows.Forms.IGWarningInfoBox
ImageGear.Windows.Forms.ImGearColorBookProperties
ImageGear.Windows.Forms.ImGearColorBookSettings
ImageGear.Windows.Forms.ImGearColorProfileSettings
ImageGear.Windows.Forms.ImGearExtraChannelColorChoice
ImageGear.Windows.Forms.ImGearExtraChannelsSwitching
ImageGear.Windows.Forms.ImGearLayersSwitching
ImageGear.Windows.Forms.ImGearSpotColorsMissingBox
ImageGear.Windows.Forms.LayerPropertiesBox
System.Windows.Forms.UserControl
ImageGear.Windows.Forms.ImGearPageView
See Also

Reference

ImageGear22.Windows.Forms Assembly


%%PageItemTitle%%

AntiAliasingOptions Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : AntiAliasingOptions Class
GUI dialog class for accessing anti-aliasing options.
Object Model
AntiAliasingOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AntiAliasingOptions
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As AntiAliasingOptions
public class AntiAliasingOptions : System.Windows.Forms.Form
public __gc class AntiAliasingOptions : public System.Windows.Forms.Form
public ref class AntiAliasingOptions : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.AntiAliasingOptions

See Also

Reference

AntiAliasingOptions Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

AntiAliasingOptions Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : AntiAliasingOptions Class

The following tables list the members exposed by AntiAliasingOptions.

Public Constructors
 | Name | Description
Public Constructor | AntiAliasingOptions Constructor | Initializes a new instance of the AntiAliasingOptions class.
Top
See Also

Reference

AntiAliasingOptions Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Properties$$

AntiAliasingOptions Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : AntiAliasingOptions Class

For a list of all members of this type, see AntiAliasingOptions members.

See Also

Reference

AntiAliasingOptions Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

AntiAliasingOptions Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > AntiAliasingOptions Class : AntiAliasingOptions Constructor
Page view to modify the display options of.
Initializes a new instance of the AntiAliasingOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New AntiAliasingOptions(pageView)
public AntiAliasingOptions(
   ImGearPageView pageView
)
public: AntiAliasingOptions(
   ImGearPageView* pageView
)
public:
AntiAliasingOptions(
   ImGearPageView^ pageView
)

Parameters

pageView
Page view to modify the display options of.
See Also

Reference

AntiAliasingOptions Class
AntiAliasingOptions Members


%%PageItemTitle%% $$Methods$$

AntiAliasingOptions Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : AntiAliasingOptions Class

For a list of all members of this type, see AntiAliasingOptions members.

See Also

Reference

AntiAliasingOptions Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

AntiAliasingOptions Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : AntiAliasingOptions Class

For a list of all members of this type, see AntiAliasingOptions members.

See Also

Reference

AntiAliasingOptions Class
ImageGear.Windows.Forms Namespace


Dispose Method (AntiAliasingOptions)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > AntiAliasingOptions Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

AntiAliasingOptions Class
AntiAliasingOptions Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > AntiAliasingOptions Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As AntiAliasingOptions
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AntiAliasingOptions Class
AntiAliasingOptions Members
Overload List


%%PageItemTitle%%

IGWarningInfoBox Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : IGWarningInfoBox Class
This class provides a window for displaying ImageGear warning messages.
Object Model
IGWarningInfoBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class IGWarningInfoBox
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As IGWarningInfoBox
public class IGWarningInfoBox : System.Windows.Forms.Form
public __gc class IGWarningInfoBox : public System.Windows.Forms.Form
public ref class IGWarningInfoBox : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.IGWarningInfoBox

See Also

Reference

IGWarningInfoBox Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

IGWarningInfoBox Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : IGWarningInfoBox Class

The following tables list the members exposed by IGWarningInfoBox.

Public Constructors
 | Name | Description
Public Constructor | IGWarningInfoBox Constructor | Initializes a new instance of the IGWarningInfoBox class.
Top
Public Methods
 | Name | Description
Public Method | AddWarning | Adds a warning to the list of displayed warnings.
Public Method | ClearWarnings | Clears the list of displayed warnings.
Top
See Also

Reference

IGWarningInfoBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Properties$$

IGWarningInfoBox Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : IGWarningInfoBox Class

For a list of all members of this type, see IGWarningInfoBox members.

See Also

Reference

IGWarningInfoBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

IGWarningInfoBox Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > IGWarningInfoBox Class : IGWarningInfoBox Constructor
Initializes a new instance of the IGWarningInfoBox class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IGWarningInfoBox()
public IGWarningInfoBox()
public: IGWarningInfoBox();
public:
IGWarningInfoBox();
See Also

Reference

IGWarningInfoBox Class
IGWarningInfoBox Members


%%PageItemTitle%% $$Methods$$

IGWarningInfoBox Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : IGWarningInfoBox Class

For a list of all members of this type, see IGWarningInfoBox members.

Public Methods
 | Name | Description
Public Method | AddWarning | Adds a warning to the list of displayed warnings.
Public Method | ClearWarnings | Clears the list of displayed warnings.
Top
See Also

Reference

IGWarningInfoBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

IGWarningInfoBox Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : IGWarningInfoBox Class

For a list of all members of this type, see IGWarningInfoBox members.

See Also

Reference

IGWarningInfoBox Class
ImageGear.Windows.Forms Namespace


AddWarning Method (IGWarningInfoBox)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > IGWarningInfoBox Class : AddWarning Method
Warning to add.
Adds a warning to the list of displayed warnings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddWarning( _
   ByVal warning As ImGearWarning _
)
'Usage

Dim instance As IGWarningInfoBox
Dim warning As ImGearWarning

instance.AddWarning(warning)
public void AddWarning(
   ImGearWarning warning
)
public: void AddWarning(
   ImGearWarning* warning
)
public:
void AddWarning(
   ImGearWarning^ warning
)

Parameters

warning
Warning to add.
See Also

Reference

IGWarningInfoBox Class
IGWarningInfoBox Members
ImGearWarning Class


ClearWarnings Method (IGWarningInfoBox)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > IGWarningInfoBox Class : ClearWarnings Method
Clears the list of displayed warnings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ClearWarnings()
'Usage

Dim instance As IGWarningInfoBox

instance.ClearWarnings()
public void ClearWarnings()
public: void ClearWarnings();
public:
void ClearWarnings();
See Also

Reference

IGWarningInfoBox Class
IGWarningInfoBox Members


Dispose Method (IGWarningInfoBox)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > IGWarningInfoBox Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

IGWarningInfoBox Class
IGWarningInfoBox Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > IGWarningInfoBox Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As IGWarningInfoBox
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

IGWarningInfoBox Class
IGWarningInfoBox Members
Overload List


%%PageItemTitle%%

ImGearAfterDrawEventArgs Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearAfterDrawEventArgs Class
Event arguments class for ImGearPageView.AfterDrawEvent event.
Object Model
ImGearAfterDrawEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearAfterDrawEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearAfterDrawEventArgs
public class ImGearAfterDrawEventArgs : System.EventArgs
public __gc class ImGearAfterDrawEventArgs : public System.EventArgs
public ref class ImGearAfterDrawEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Forms.ImGearAfterDrawEventArgs

See Also

Reference

ImGearAfterDrawEventArgs Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearAfterDrawEventArgs Class Members
Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearAfterDrawEventArgs Class

The following tables list the members exposed by ImGearAfterDrawEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearAfterDrawEventArgs Constructor | Initializes a new instance of the ImGearAfterDrawEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | graphics | Gets Graphics object used for painting on the ImGearPageView class for which the event was triggered.
Top
See Also

Reference

ImGearAfterDrawEventArgs Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearAfterDrawEventArgs Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearAfterDrawEventArgs Class : ImGearAfterDrawEventArgs Constructor
Graphics object to initialize the class with.
Initializes a new instance of the ImGearAfterDrawEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal graphics As Graphics _
)
'Usage

Dim graphics As Graphics

Dim instance As New ImGearAfterDrawEventArgs(graphics)
public ImGearAfterDrawEventArgs(
   Graphics graphics
)
public: ImGearAfterDrawEventArgs(
   Graphics* graphics
)
public:
ImGearAfterDrawEventArgs(
   Graphics^ graphics
)

Parameters

graphics
Graphics object to initialize the class with.

Return Value

The new instance of ImGearAfterDrawEventArgs class.
See Also

Reference

ImGearAfterDrawEventArgs Class
ImGearAfterDrawEventArgs Members
ImGearPageView Class


%%PageItemTitle%% $$Properties$$

ImGearAfterDrawEventArgs Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearAfterDrawEventArgs Class

For a list of all members of this type, see ImGearAfterDrawEventArgs members.

Public Properties
 | Name | Description
Public Property | graphics | Gets Graphics object used for painting on the ImGearPageView class for which the event was triggered.
Top
See Also

Reference

ImGearAfterDrawEventArgs Class
ImageGear.Windows.Forms Namespace


graphics Property (ImGearAfterDrawEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearAfterDrawEventArgs Class : graphics Property
Gets Graphics object used for painting on the ImGearPageView class for which the event was triggered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property graphics As Graphics
'Usage

Dim instance As ImGearAfterDrawEventArgs
Dim value As Graphics

value = instance.graphics
public Graphics graphics {get;}
public: __property Graphics* get_graphics();
public:
property Graphics^ graphics {
   Graphics^ get();
}

Property Value

System.Drawing.Graphics class object.
See Also

Reference

ImGearAfterDrawEventArgs Class
ImGearAfterDrawEventArgs Members
ImGearPageView Class


%%PageItemTitle%%

ImGearARTLoadingSelection Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTLoadingSelection Class
Identifies a file and format selected in an open file dialog for ART annotations.
Object Model
ImGearARTLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTLoadingSelection
'Usage

Dim instance As ImGearARTLoadingSelection
public class ImGearARTLoadingSelection
public __gc class ImGearARTLoadingSelection
public ref class ImGearARTLoadingSelection
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearARTLoadingSelection

See Also

Reference

ImGearARTLoadingSelection Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTLoadingSelection Class Members
Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTLoadingSelection Class

The following tables list the members exposed by ImGearARTLoadingSelection.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the open file dialog.
Public Field | Format | Gets format selected in the open file dialog.
Top
See Also

Reference

ImGearARTLoadingSelection Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Fields$$

ImGearARTLoadingSelection Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTLoadingSelection Class

For a list of all members of this type, see ImGearARTLoadingSelection members.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the open file dialog.
Public Field | Format | Gets format selected in the open file dialog.
Top
See Also

Reference

ImGearARTLoadingSelection Class
ImageGear.Windows.Forms Namespace


File Field (ImGearARTLoadingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearARTLoadingSelection Class : File Field
Gets file selected in the open file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly File As ImGearFile
'Usage

Dim instance As ImGearARTLoadingSelection
Dim value As ImGearFile

value = instance.File
public readonly ImGearFile File
public: readonly ImGearFile* File
public:
readonly ImGearFile^ File

Field Value

ImGearFile class object.
See Also

Reference

ImGearARTLoadingSelection Class
ImGearARTLoadingSelection Members


Format Field (ImGearARTLoadingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearARTLoadingSelection Class : Format Field
Gets format selected in the open file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Format As ImGearARTSaveType
'Usage

Dim instance As ImGearARTLoadingSelection
Dim value As ImGearARTSaveType

value = instance.Format
public readonly ImGearARTSaveType Format
public: readonly ImGearARTSaveType Format
public:
readonly ImGearARTSaveType Format

Field Value

ImageGear.ART.ImGearARTSaveType enumeration value.
See Also

Reference

ImGearARTLoadingSelection Class
ImGearARTLoadingSelection Members
ImGearARTSaveType Enumeration


%%PageItemTitle%%

ImGearARTSavingSelection Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTSavingSelection Class
Identifies a file and format selected in a save file dialog for ART annotations.
Object Model
ImGearARTSavingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearARTSavingSelection
'Usage

Dim instance As ImGearARTSavingSelection
public class ImGearARTSavingSelection
public __gc class ImGearARTSavingSelection
public ref class ImGearARTSavingSelection
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearARTSavingSelection

See Also

Reference

ImGearARTSavingSelection Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearARTSavingSelection Class Members
Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTSavingSelection Class

The following tables list the members exposed by ImGearARTSavingSelection.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the save file dialog.
Public Field | Format | Format selected in the save file dialog.
Top
See Also

Reference

ImGearARTSavingSelection Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Fields$$

ImGearARTSavingSelection Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearARTSavingSelection Class

For a list of all members of this type, see ImGearARTSavingSelection members.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the save file dialog.
Public Field | Format | Format selected in the save file dialog.
Top
See Also

Reference

ImGearARTSavingSelection Class
ImageGear.Windows.Forms Namespace


File Field (ImGearARTSavingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearARTSavingSelection Class : File Field
Gets file selected in the save file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly File As ImGearFile
'Usage

Dim instance As ImGearARTSavingSelection
Dim value As ImGearFile

value = instance.File
public readonly ImGearFile File
public: readonly ImGearFile* File
public:
readonly ImGearFile^ File

Field Value

ImGearFile class object.
See Also

Reference

ImGearARTSavingSelection Class
ImGearARTSavingSelection Members
ImGearFile Class


Format Field (ImGearARTSavingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearARTSavingSelection Class : Format Field
Format selected in the save file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Format As ImGearARTSaveType
'Usage

Dim instance As ImGearARTSavingSelection
Dim value As ImGearARTSaveType

value = instance.Format
public readonly ImGearARTSaveType Format
public: readonly ImGearARTSaveType Format
public:
readonly ImGearARTSaveType Format

Field Value

ImageGear.ART.ImGearARTSaveType enumeration value.
See Also

Reference

ImGearARTSavingSelection Class
ImGearARTSavingSelection Members
ImGearARTSaveType Enumeration


%%PageItemTitle%%

ImGearColorBookProperties Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookProperties Class
GUI dialog class for accessing color book properties.
Object Model
ImGearColorBookProperties Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearColorBookProperties
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearColorBookProperties
public class ImGearColorBookProperties : System.Windows.Forms.Form
public __gc class ImGearColorBookProperties : public System.Windows.Forms.Form
public ref class ImGearColorBookProperties : public System.Windows.Forms.Form
Example
  • C#
if (curBook != null)
{
    using (ImGearColorBookProperties dlg = new ImGearColorBookProperties(curBook))
    {
        dlg.ShowDialog(igPageView.Parent);
    }
}
  • Visual Basic
If curBook IsNot Nothing Then
    Using dlg As New ImGearColorBookProperties(curBook)
        dlg.ShowDialog(igPageView.Parent)
    End Using
End If
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearColorBookProperties

See Also

Reference

ImGearColorBookProperties Members
ImageGear.Windows.Forms Namespace
ImGearColorBook Class


%%PageItemTitle%% $$Members$$

ImGearColorBookProperties Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookProperties Class

The following tables list the members exposed by ImGearColorBookProperties.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorBookProperties Constructor | Initializes a new instance of the ImGearColorBookProperties class.
Top
See Also

Reference

ImGearColorBookProperties Class
ImageGear.Windows.Forms Namespace
ImGearColorBook Class


%%PageItemTitle%% $$Properties$$

ImGearColorBookProperties Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookProperties Class

For a list of all members of this type, see ImGearColorBookProperties members.

See Also

Reference

ImGearColorBookProperties Class
ImageGear.Windows.Forms Namespace
ImGearColorBook Class


%%PageItemTitle%%

ImGearColorBookProperties Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookProperties Class : ImGearColorBookProperties Constructor
Reference to color book object.
Initializes a new instance of the ImGearColorBookProperties class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorBook As ImGearColorBook _
)
'Usage

Dim colorBook As ImGearColorBook

Dim instance As New ImGearColorBookProperties(colorBook)
public ImGearColorBookProperties(
   ImGearColorBook colorBook
)
public: ImGearColorBookProperties(
   ImGearColorBook* colorBook
)
public:
ImGearColorBookProperties(
   ImGearColorBook^ colorBook
)

Parameters

colorBook
Reference to color book object.

Return Value

An instance of ImGearColorBookProperties class GUI dialog.
Example
  • C#
if (curBook != null)
{
    using (ImGearColorBookProperties dlg = new ImGearColorBookProperties(curBook))
    {
        dlg.ShowDialog(igPageView.Parent);
    }
}
  • Visual Basic
If curBook IsNot Nothing Then
    Using dlg As New ImGearColorBookProperties(curBook)
        dlg.ShowDialog(igPageView.Parent)
    End Using
End If
See Also

Reference

ImGearColorBookProperties Class
ImGearColorBookProperties Members
ImGearColorBook Class


%%PageItemTitle%% $$Methods$$

ImGearColorBookProperties Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookProperties Class

For a list of all members of this type, see ImGearColorBookProperties members.

See Also

Reference

ImGearColorBookProperties Class
ImageGear.Windows.Forms Namespace
ImGearColorBook Class


%%PageItemTitle%% $$Events$$

ImGearColorBookProperties Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookProperties Class

For a list of all members of this type, see ImGearColorBookProperties members.

See Also

Reference

ImGearColorBookProperties Class
ImageGear.Windows.Forms Namespace
ImGearColorBook Class


Dispose Method (ImGearColorBookProperties)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookProperties Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearColorBookProperties Class
ImGearColorBookProperties Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookProperties Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearColorBookProperties
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearColorBookProperties Class
ImGearColorBookProperties Members
Overload List


%%PageItemTitle%%

ImGearColorBookSettings Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookSettings Class
GUI dialog class for accessing the available color books.
Object Model
ImGearColorBookSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearColorBookSettings
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearColorBookSettings
public class ImGearColorBookSettings : System.Windows.Forms.Form
public __gc class ImGearColorBookSettings : public System.Windows.Forms.Form
public ref class ImGearColorBookSettings : public System.Windows.Forms.Form
Example
  • C#
using (ImGearColorBookSettings dlg = new ImGearColorBookSettings(igPageView))
{
    dlg.ShowDialog(igPageView.Parent);
}
  • Visual Basic
Using dlg As New ImGearColorBookSettings(igPageView)
    dlg.ShowDialog(igPageView.Parent)
End Using
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearColorBookSettings

See Also

Reference

ImGearColorBookSettings Members
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Members$$

ImGearColorBookSettings Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookSettings Class

The following tables list the members exposed by ImGearColorBookSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorBookSettings Constructor | Initializes a new instance of the ImGearColorBookSettings class.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckForSpotColors | Checks the specified page for spot colors. If any are present but unknown a ImGearSpotColorsMissingBox dialg is shown.
static (Shared in Visual Basic) | InitializeColorBooks | Initializes static members of InitializeColorBooks.
Top
See Also

Reference

ImGearColorBookSettings Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Properties$$

ImGearColorBookSettings Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookSettings Class

For a list of all members of this type, see ImGearColorBookSettings members.

See Also

Reference

ImGearColorBookSettings Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%%

ImGearColorBookSettings Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookSettings Class : ImGearColorBookSettings Constructor
Reference to the page view object.
Initializes a new instance of the ImGearColorBookSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearColorBookSettings(pageView)
public ImGearColorBookSettings(
   ImGearPageView pageView
)
public: ImGearColorBookSettings(
   ImGearPageView* pageView
)
public:
ImGearColorBookSettings(
   ImGearPageView^ pageView
)

Parameters

pageView
Reference to the page view object.

Return Value

An instance of ImGearColorBookSettings class GUI dialog.
Example
  • C#
using (ImGearColorBookSettings dlg = new ImGearColorBookSettings(igPageView))
{
    dlg.ShowDialog(igPageView.Parent);
}
  • Visual Basic
Using dlg As New ImGearColorBookSettings(igPageView)
    dlg.ShowDialog(igPageView.Parent)
End Using
See Also

Reference

ImGearColorBookSettings Class
ImGearColorBookSettings Members
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearColorBookSettings Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookSettings Class

For a list of all members of this type, see ImGearColorBookSettings members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckForSpotColors | Checks the specified page for spot colors. If any are present but unknown a ImGearSpotColorsMissingBox dialg is shown.
static (Shared in Visual Basic) | InitializeColorBooks | Initializes static members of InitializeColorBooks.
Top
See Also

Reference

ImGearColorBookSettings Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Events$$

ImGearColorBookSettings Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorBookSettings Class

For a list of all members of this type, see ImGearColorBookSettings members.

See Also

Reference

ImGearColorBookSettings Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


CheckForSpotColors Method
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookSettings Class : CheckForSpotColors Method
Reference to page to check.
Checks the specified page for spot colors. If any are present but unknown a ImGearSpotColorsMissingBox dialg is shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub CheckForSpotColors( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

ImGearColorBookSettings.CheckForSpotColors(page)
public static void CheckForSpotColors(
   ImGearPage page
)
public: static void CheckForSpotColors(
   ImGearPage* page
)
public:
static void CheckForSpotColors(
   ImGearPage^ page
)

Parameters

page
Reference to page to check.
Example
  • C#
ImGearColorBookSettings.CheckForSpotColors(igPageView.Page);
  • Visual Basic
ImGearColorBookSettings.CheckForSpotColors(igPageView.Page)
See Also

Reference

ImGearColorBookSettings Class
ImGearColorBookSettings Members
ImGearPage Class


Dispose Method (ImGearColorBookSettings)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookSettings Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearColorBookSettings Class
ImGearColorBookSettings Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookSettings Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearColorBookSettings
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearColorBookSettings Class
ImGearColorBookSettings Members
Overload List


InitializeColorBooks Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorBookSettings Class : InitializeColorBooks Method
Initializes static members of InitializeColorBooks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InitializeColorBooks()
'Usage

ImGearColorBookSettings.InitializeColorBooks()
public static void InitializeColorBooks()
public: static void InitializeColorBooks();
public:
static void InitializeColorBooks();
See Also

Reference

ImGearColorBookSettings Class
ImGearColorBookSettings Members


%%PageItemTitle%%

ImGearColorProfileSettings Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileSettings Class
GUI dialog class for ICC setting.
Object Model
ImGearColorProfileSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearColorProfileSettings
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearColorProfileSettings
public class ImGearColorProfileSettings : System.Windows.Forms.Form
public __gc class ImGearColorProfileSettings : public System.Windows.Forms.Form
public ref class ImGearColorProfileSettings : public System.Windows.Forms.Form
Example
  • C#
using (ImGearColorProfileSettings dlg = new ImGearColorProfileSettings(igPageView))
{
    dlg.ShowDialog(igPageView.Parent);
}
  • Visual Basic
Using dlg As New ImGearColorProfileSettings(igPageView)
    dlg.ShowDialog(igPageView.Parent)
End Using
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearColorProfileSettings

See Also

Reference

ImGearColorProfileSettings Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearColorProfileSettings Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileSettings Class

The following tables list the members exposed by ImGearColorProfileSettings.

Public Constructors
 | Name | Description
Public Constructor | ImGearColorProfileSettings Constructor | Initializes a new instance of the ImGearColorProfileSettings class.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckColorMismatch | Checks if the image is of non-RGB color format or it has an embedded color profile and generates a message box when it is recommended to enable ICC support.
static (Shared in Visual Basic) | GetActivationMode | Returns Color Profile activation mode.
static (Shared in Visual Basic) | InitializeAndEnableProfiles | Enables Color Profile support and initializes it with default settings.
static (Shared in Visual Basic) | SetActivationMode | Sets Color Profile activation mode.
Top
See Also

Reference

ImGearColorProfileSettings Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearColorProfileSettings Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileSettings Class

For a list of all members of this type, see ImGearColorProfileSettings members.

See Also

Reference

ImGearColorProfileSettings Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearColorProfileSettings Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : ImGearColorProfileSettings Constructor
Reference to pageview to refresh its content when the settings are applied.
Initializes a new instance of the ImGearColorProfileSettings class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearColorProfileSettings(pageView)
public ImGearColorProfileSettings(
   ImGearPageView pageView
)
public: ImGearColorProfileSettings(
   ImGearPageView* pageView
)
public:
ImGearColorProfileSettings(
   ImGearPageView^ pageView
)

Parameters

pageView
Reference to pageview to refresh its content when the settings are applied.

Return Value

An instance of ImGearColorProfileSettings class GUI dialog.
Remarks
This constructor creates an instance of ImGearColorProfileSettings class GUI dialog. .
Example
  • C#
using (ImGearColorProfileSettings dlg = new ImGearColorProfileSettings(igPageView))
{
    dlg.ShowDialog(igPageView.Parent);
}
  • Visual Basic
Using dlg As New ImGearColorProfileSettings(igPageView)
    dlg.ShowDialog(igPageView.Parent)
End Using
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearColorProfileSettings Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileSettings Class

For a list of all members of this type, see ImGearColorProfileSettings members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckColorMismatch | Checks if the image is of non-RGB color format or it has an embedded color profile and generates a message box when it is recommended to enable ICC support.
static (Shared in Visual Basic) | GetActivationMode | Returns Color Profile activation mode.
static (Shared in Visual Basic) | InitializeAndEnableProfiles | Enables Color Profile support and initializes it with default settings.
static (Shared in Visual Basic) | SetActivationMode | Sets Color Profile activation mode.
Top
See Also

Reference

ImGearColorProfileSettings Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearColorProfileSettings Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileSettings Class

For a list of all members of this type, see ImGearColorProfileSettings members.

See Also

Reference

ImGearColorProfileSettings Class
ImageGear.Windows.Forms Namespace


CheckColorMismatch Method
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : CheckColorMismatch Method
ImGearPage object to check for color mismatch.
Checks if the image is of non-RGB color format or it has an embedded color profile and generates a message box when it is recommended to enable ICC support.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub CheckColorMismatch( _
   ByVal page As ImGearPage _
)
'Usage

Dim page As ImGearPage

ImGearColorProfileSettings.CheckColorMismatch(page)
public static void CheckColorMismatch(
   ImGearPage page
)
public: static void CheckColorMismatch(
   ImGearPage* page
)
public:
static void CheckColorMismatch(
   ImGearPage^ page
)

Parameters

page
ImGearPage object to check for color mismatch.
Example
  • C#
ImGearColorProfileSettings.CheckColorMismatch(igPageView.Page);
  • Visual Basic
ImGearColorProfileSettings.CheckColorMismatch(igPageView.Page)
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members
ImGearPage Class


Dispose Method (ImGearColorProfileSettings)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearColorProfileSettings
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members
Overload List


GetActivationMode Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : GetActivationMode Method
Returns Color Profile activation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetActivationMode() As ImGearColorProfileActivationMode
'Usage

Dim value As ImGearColorProfileActivationMode

value = ImGearColorProfileSettings.GetActivationMode()
public static ImGearColorProfileActivationMode GetActivationMode()
public: static ImGearColorProfileActivationMode GetActivationMode();
public:
static ImGearColorProfileActivationMode GetActivationMode();

Return Value

ImGearColorProfileActivationMode enumeration value.
Remarks
Activation mode is stored in the Windows registry, which allows you to remember user preference between ImageGear sample sessions.
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members
ImGearColorProfileActivationMode Enumeration


InitializeAndEnableProfiles Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : InitializeAndEnableProfiles Method
Enables Color Profile support and initializes it with default settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InitializeAndEnableProfiles()
'Usage

ImGearColorProfileSettings.InitializeAndEnableProfiles()
public static void InitializeAndEnableProfiles()
public: static void InitializeAndEnableProfiles();
public:
static void InitializeAndEnableProfiles();
Remarks
Loads global color profiles, sets default rendering intent for color space conversions.
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members


SetActivationMode Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearColorProfileSettings Class : SetActivationMode Method
Color profile activation mode.
Sets Color Profile activation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SetActivationMode( _
   ByVal mode As ImGearColorProfileActivationMode _
)
'Usage

Dim mode As ImGearColorProfileActivationMode

ImGearColorProfileSettings.SetActivationMode(mode)
public static void SetActivationMode(
   ImGearColorProfileActivationMode mode
)
public: static void SetActivationMode(
   ImGearColorProfileActivationMode mode
)
public:
static void SetActivationMode(
   ImGearColorProfileActivationMode mode
)

Parameters

mode
Color profile activation mode.
Remarks
Activation mode is stored in the Windows registry, which allows it to remember user preference between ImageGear sample sessions.
See Also

Reference

ImGearColorProfileSettings Class
ImGearColorProfileSettings Members
ImGearColorProfileActivationMode Enumeration


%%PageItemTitle%%

ImGearExtraChannelColorChoice Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelColorChoice Class
GUI dialog class for choosing a color for the specified extra channel.
Object Model
ImGearExtraChannelColorChoice Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExtraChannelColorChoice
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearExtraChannelColorChoice
public class ImGearExtraChannelColorChoice : System.Windows.Forms.Form
public __gc class ImGearExtraChannelColorChoice : public System.Windows.Forms.Form
public ref class ImGearExtraChannelColorChoice : public System.Windows.Forms.Form
Example
  • C#
ImGearExtraChannelColorChoice dlg = new ImGearExtraChannelColorChoice(
    igPageView, igPageView.Page.DIB.ExtraChannelInfo, 0);
dlg.ShowDialog();
  • Visual Basic
Dim dlg As New ImGearExtraChannelColorChoice(igPageView, igPageView.Page.DIB.ExtraChannelInfo, 0)
dlg.ShowDialog()
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearExtraChannelColorChoice

See Also

Reference

ImGearExtraChannelColorChoice Members
ImageGear.Windows.Forms Namespace
ImGearPageView Class
ImGearExtraChannelInfo Class


%%PageItemTitle%% $$Members$$

ImGearExtraChannelColorChoice Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelColorChoice Class

The following tables list the members exposed by ImGearExtraChannelColorChoice.

Public Constructors
 | Name | Description
Public Constructor | ImGearExtraChannelColorChoice Constructor | Initializes a new instance of the ImGearExtraChannelColorChoice class.
Top
See Also

Reference

ImGearExtraChannelColorChoice Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class
ImGearExtraChannelInfo Class


%%PageItemTitle%% $$Properties$$

ImGearExtraChannelColorChoice Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelColorChoice Class

For a list of all members of this type, see ImGearExtraChannelColorChoice members.

See Also

Reference

ImGearExtraChannelColorChoice Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class
ImGearExtraChannelInfo Class


%%PageItemTitle%%

ImGearExtraChannelColorChoice Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelColorChoice Class : ImGearExtraChannelColorChoice Constructor
Reference to the page view object.
Array of extra channels.
Index of the extra channel in array to work with.
Initializes a new instance of the ImGearExtraChannelColorChoice class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView, _
   ByVal channelsInfo() As ImGearExtraChannelInfo, _
   ByVal channelNumber As Integer _
)
'Usage

Dim pageView As ImGearPageView
Dim channelsInfo() As ImGearExtraChannelInfo
Dim channelNumber As Integer

Dim instance As New ImGearExtraChannelColorChoice(pageView, channelsInfo, channelNumber)
public ImGearExtraChannelColorChoice(
   ImGearPageView pageView,
   ImGearExtraChannelInfo[] channelsInfo,
   int channelNumber
)
public: ImGearExtraChannelColorChoice(
   ImGearPageView* pageView,
   ImGearExtraChannelInfo*[]* channelsInfo,
   int channelNumber
)
public:
ImGearExtraChannelColorChoice(
   ImGearPageView^ pageView,
   array<ImGearExtraChannelInfo^>^ channelsInfo,
   int channelNumber
)

Parameters

pageView
Reference to the page view object.
channelsInfo
Array of extra channels.
channelNumber
Index of the extra channel in array to work with.

Return Value

An instance of ImGearExtraChannelColorChoice class GUI dialog.
Example
  • C#
ImGearExtraChannelColorChoice dlg = new ImGearExtraChannelColorChoice(
    igPageView, igPageView.Page.DIB.ExtraChannelInfo, 0);
dlg.ShowDialog();
  • Visual Basic
Dim dlg As New ImGearExtraChannelColorChoice(igPageView, igPageView.Page.DIB.ExtraChannelInfo, 0)
dlg.ShowDialog()
See Also

Reference

ImGearExtraChannelColorChoice Class
ImGearExtraChannelColorChoice Members
ImGearPageView Class
ImGearExtraChannelInfo Class


%%PageItemTitle%% $$Methods$$

ImGearExtraChannelColorChoice Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelColorChoice Class

For a list of all members of this type, see ImGearExtraChannelColorChoice members.

See Also

Reference

ImGearExtraChannelColorChoice Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class
ImGearExtraChannelInfo Class


%%PageItemTitle%% $$Events$$

ImGearExtraChannelColorChoice Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelColorChoice Class

For a list of all members of this type, see ImGearExtraChannelColorChoice members.

See Also

Reference

ImGearExtraChannelColorChoice Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class
ImGearExtraChannelInfo Class


Dispose Method (ImGearExtraChannelColorChoice)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelColorChoice Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearExtraChannelColorChoice Class
ImGearExtraChannelColorChoice Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelColorChoice Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearExtraChannelColorChoice
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearExtraChannelColorChoice Class
ImGearExtraChannelColorChoice Members
Overload List


%%PageItemTitle%%

ImGearExtraChannelsSwitching Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelsSwitching Class
GUI dialog class for enabling and disabling color channels for display.
Object Model
ImGearExtraChannelsSwitching Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearExtraChannelsSwitching
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearExtraChannelsSwitching
public class ImGearExtraChannelsSwitching : System.Windows.Forms.Form
public __gc class ImGearExtraChannelsSwitching : public System.Windows.Forms.Form
public ref class ImGearExtraChannelsSwitching : public System.Windows.Forms.Form
Example
  • C#
using (ImGearExtraChannelsSwitching dlg = new ImGearExtraChannelsSwitching(igPageView))
{
    dlg.ShowDialog();
}
  • Visual Basic
Using dlg As New ImGearExtraChannelsSwitching(igPageView)
    dlg.ShowDialog()
End Using
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearExtraChannelsSwitching

See Also

Reference

ImGearExtraChannelsSwitching Members
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Members$$

ImGearExtraChannelsSwitching Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelsSwitching Class

The following tables list the members exposed by ImGearExtraChannelsSwitching.

Public Constructors
 | Name | Description
Public Constructor | ImGearExtraChannelsSwitching Constructor | Initializes a new instance of the ImGearExtraChannelsSwitching class.
Top
See Also

Reference

ImGearExtraChannelsSwitching Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Properties$$

ImGearExtraChannelsSwitching Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelsSwitching Class

For a list of all members of this type, see ImGearExtraChannelsSwitching members.

See Also

Reference

ImGearExtraChannelsSwitching Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%%

ImGearExtraChannelsSwitching Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelsSwitching Class : ImGearExtraChannelsSwitching Constructor
Reference to the page view object.
Initializes a new instance of the ImGearExtraChannelsSwitching class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearExtraChannelsSwitching(pageView)
public ImGearExtraChannelsSwitching(
   ImGearPageView pageView
)
public: ImGearExtraChannelsSwitching(
   ImGearPageView* pageView
)
public:
ImGearExtraChannelsSwitching(
   ImGearPageView^ pageView
)

Parameters

pageView
Reference to the page view object.

Return Value

An instance of ImGearExtraChannelsSwitching class GUI dialog.
Example
  • C#
using (ImGearExtraChannelsSwitching dlg = new ImGearExtraChannelsSwitching(igPageView))
{
    dlg.ShowDialog();
}
  • Visual Basic
Using dlg As New ImGearExtraChannelsSwitching(igPageView)
    dlg.ShowDialog()
End Using
See Also

Reference

ImGearExtraChannelsSwitching Class
ImGearExtraChannelsSwitching Members
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearExtraChannelsSwitching Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelsSwitching Class

For a list of all members of this type, see ImGearExtraChannelsSwitching members.

See Also

Reference

ImGearExtraChannelsSwitching Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Events$$

ImGearExtraChannelsSwitching Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearExtraChannelsSwitching Class

For a list of all members of this type, see ImGearExtraChannelsSwitching members.

See Also

Reference

ImGearExtraChannelsSwitching Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


Dispose Method (ImGearExtraChannelsSwitching)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelsSwitching Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearExtraChannelsSwitching Class
ImGearExtraChannelsSwitching Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearExtraChannelsSwitching Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearExtraChannelsSwitching
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearExtraChannelsSwitching Class
ImGearExtraChannelsSwitching Members
Overload List


%%PageItemTitle%%

ImGearFile Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearFile Class
Identifies a file and its location.
Object Model
ImGearFile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearFile
'Usage

Dim instance As ImGearFile
public class ImGearFile
public __gc class ImGearFile
public ref class ImGearFile
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearFile
ImageGear.Windows.Forms.ImGearLocalFile
ImageGear.Windows.Forms.ImGearRemoteFile

See Also

Reference

ImGearFile Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearFile Class Members
Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearFile Class

The following tables list the members exposed by ImGearFile.

Protected Constructors
 | Name | Description
Protected Constructor | ImGearFile Constructor | Initializes a new instance of the ImGearFile class.
Top
Public Fields
 | Name | Description
Public Field | Path | Gets name of the file with complete path.
Top
See Also

Reference

ImGearFile Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearFile Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearFile Class : ImGearFile Constructor
Name of the file with complete path.
Initializes a new instance of the ImGearFile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function New( _
   ByVal path As String _
)
'Usage

Dim path As String

Dim instance As New ImGearFile(path)
protected ImGearFile(
   string path
)
protected: ImGearFile(
   string* path
)
protected:
ImGearFile(
   String^ path
)

Parameters

path
Name of the file with complete path.
Remarks
This constructor creates and initializes an instance of ImGearFile class.
See Also

Reference

ImGearFile Class
ImGearFile Members


%%PageItemTitle%% $$Fields$$

ImGearFile Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearFile Class

For a list of all members of this type, see ImGearFile members.

Public Fields
 | Name | Description
Public Field | Path | Gets name of the file with complete path.
Top
See Also

Reference

ImGearFile Class
ImageGear.Windows.Forms Namespace


Path Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearFile Class : Path Field
Gets name of the file with complete path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Path As String
'Usage

Dim instance As ImGearFile
Dim value As String

value = instance.Path

instance.Path = value
public string Path
public: string* Path
public:
String^ Path

Field Value

String value.
See Also

Reference

ImGearFile Class
ImGearFile Members


%%PageItemTitle%%

ImGearLayersSwitching Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLayersSwitching Class
GUI dialog for turning on and off the layers of the layered page, and flattening them into the raster output page.
Object Model
ImGearLayersSwitching Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLayersSwitching
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearLayersSwitching
public class ImGearLayersSwitching : System.Windows.Forms.Form
public __gc class ImGearLayersSwitching : public System.Windows.Forms.Form
public ref class ImGearLayersSwitching : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearLayersSwitching

See Also

Reference

ImGearLayersSwitching Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearLayersSwitching Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLayersSwitching Class

The following tables list the members exposed by ImGearLayersSwitching.

Public Constructors
 | Name | Description
Public Constructor | ImGearLayersSwitching Constructor | Initializes a new instance of the ImGearLayersSwitching class. Allows user to turn on and off the layers of the layered page as well as flatten them.
Top
See Also

Reference

ImGearLayersSwitching Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Properties$$

ImGearLayersSwitching Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLayersSwitching Class

For a list of all members of this type, see ImGearLayersSwitching members.

See Also

Reference

ImGearLayersSwitching Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearLayersSwitching Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLayersSwitching Class : ImGearLayersSwitching Constructor
ImGearPageView control to get image from and to trigger updates for.
Initializes a new instance of the ImGearLayersSwitching class. Allows user to turn on and off the layers of the layered page as well as flatten them.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageView As ImGearPageView _
)
'Usage

Dim pageView As ImGearPageView

Dim instance As New ImGearLayersSwitching(pageView)
public ImGearLayersSwitching(
   ImGearPageView pageView
)
public: ImGearLayersSwitching(
   ImGearPageView* pageView
)
public:
ImGearLayersSwitching(
   ImGearPageView^ pageView
)

Parameters

pageView
ImGearPageView control to get image from and to trigger updates for.
See Also

Reference

ImGearLayersSwitching Class
ImGearLayersSwitching Members
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearLayersSwitching Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLayersSwitching Class

For a list of all members of this type, see ImGearLayersSwitching members.

See Also

Reference

ImGearLayersSwitching Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearLayersSwitching Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLayersSwitching Class

For a list of all members of this type, see ImGearLayersSwitching members.

See Also

Reference

ImGearLayersSwitching Class
ImageGear.Windows.Forms Namespace


Dispose Method (ImGearLayersSwitching)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLayersSwitching Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearLayersSwitching Class
ImGearLayersSwitching Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLayersSwitching Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearLayersSwitching
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearLayersSwitching Class
ImGearLayersSwitching Members
Overload List


%%PageItemTitle%%

ImGearLoadingSelection Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelection Class
Identifies a file and format selected in an open file dialog.
Object Model
ImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLoadingSelection
'Usage

Dim instance As ImGearLoadingSelection
public class ImGearLoadingSelection
public __gc class ImGearLoadingSelection
public ref class ImGearLoadingSelection
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearLoadingSelection
ImageGear.Windows.Forms.ImGearLoadingSelectionEx

See Also

Reference

ImGearLoadingSelection Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearLoadingSelection Class Members
Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelection Class

The following tables list the members exposed by ImGearLoadingSelection.

Public Constructors
 | Name | Description
Public Constructor | ImGearLoadingSelection Constructor | Initializes a new instance of the ImGearLoadingSelection class.
Top
Public Fields
 | Name | Description
Public Field | File | Gets file selected in the open file dialog.
Public Field | Format | Gets format selected in the open file dialog.
Top
See Also

Reference

ImGearLoadingSelection Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearLoadingSelection Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLoadingSelection Class : ImGearLoadingSelection Constructor
File selected in an open file dialog.
Format selected in an open file dialog.
Initializes a new instance of the ImGearLoadingSelection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal file As ImGearFile, _
   ByVal format As ImGearFormats _
)
'Usage

Dim file As ImGearFile
Dim format As ImGearFormats

Dim instance As New ImGearLoadingSelection(file, format)
public ImGearLoadingSelection(
   ImGearFile file,
   ImGearFormats format
)
public: ImGearLoadingSelection(
   ImGearFile* file,
   ImGearFormats format
)
public:
ImGearLoadingSelection(
   ImGearFile^ file,
   ImGearFormats format
)

Parameters

file
File selected in an open file dialog.
format
Format selected in an open file dialog.
See Also

Reference

ImGearLoadingSelection Class
ImGearLoadingSelection Members


%%PageItemTitle%% $$Fields$$

ImGearLoadingSelection Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelection Class

For a list of all members of this type, see ImGearLoadingSelection members.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the open file dialog.
Public Field | Format | Gets format selected in the open file dialog.
Top
See Also

Reference

ImGearLoadingSelection Class
ImageGear.Windows.Forms Namespace


File Field (ImGearLoadingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLoadingSelection Class : File Field
Gets file selected in the open file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly File As ImGearFile
'Usage

Dim instance As ImGearLoadingSelection
Dim value As ImGearFile

value = instance.File
public readonly ImGearFile File
public: readonly ImGearFile* File
public:
readonly ImGearFile^ File

Field Value

ImGearFile class object.
See Also

Reference

ImGearLoadingSelection Class
ImGearLoadingSelection Members
ImGearFile Class


Format Field (ImGearLoadingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLoadingSelection Class : Format Field
Gets format selected in the open file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Format As ImGearFormats
'Usage

Dim instance As ImGearLoadingSelection
Dim value As ImGearFormats

value = instance.Format
public readonly ImGearFormats Format
public: readonly ImGearFormats Format
public:
readonly ImGearFormats Format

Field Value

ImageGear.Formats.ImGearFormats enumeration value.
See Also

Reference

ImGearLoadingSelection Class
ImGearLoadingSelection Members
ImGearFormats Enumeration


%%PageItemTitle%%

ImGearLoadingSelectionEx Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelectionEx Class
This class identifies a file, format and page index selected in the open file dialog with preview shown by the ImGearWinForms.SelectLocalFileToLoadEx method.
Object Model
ImGearLoadingSelectionEx Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLoadingSelectionEx
   Inherits ImGearLoadingSelection
'Usage

Dim instance As ImGearLoadingSelectionEx
public class ImGearLoadingSelectionEx : ImGearLoadingSelection
public __gc class ImGearLoadingSelectionEx : public ImGearLoadingSelection
public ref class ImGearLoadingSelectionEx : public ImGearLoadingSelection
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearLoadingSelection
ImageGear.Windows.Forms.ImGearLoadingSelectionEx

See Also

Reference

ImGearLoadingSelectionEx Members
ImageGear.Windows.Forms Namespace
ImGearLoadingSelection Class


%%PageItemTitle%% $$Members$$

ImGearLoadingSelectionEx Class Members
Fields Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelectionEx Class

The following tables list the members exposed by ImGearLoadingSelectionEx.

Public Constructors
 | Name | Description
Public Constructor | ImGearLoadingSelectionEx Constructor | Initializes a new instance of the ImGearLoadingSelectionEx class.
Top
Public Properties
 | Name | Description
Public Property | PageIndex | Gets the 0 based page index selected when using the FileOpenDialog launched by ImGearWinForms.SelectLocalFileToLoadEx method.
Top
See Also

Reference

ImGearLoadingSelectionEx Class
ImageGear.Windows.Forms Namespace
ImGearLoadingSelection Class


%%PageItemTitle%% $$Fields$$

ImGearLoadingSelectionEx Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelectionEx Class

For a list of all members of this type, see ImGearLoadingSelectionEx members.

See Also

Reference

ImGearLoadingSelectionEx Class
ImageGear.Windows.Forms Namespace
ImGearLoadingSelection Class


%%PageItemTitle%%

ImGearLoadingSelectionEx Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLoadingSelectionEx Class : ImGearLoadingSelectionEx Constructor
File selected in an open file dialog.
Format selected in an open file dialog.
Page index selected in an open file dialog.
Initializes a new instance of the ImGearLoadingSelectionEx class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal file As ImGearFile, _
   ByVal format As ImGearFormats, _
   ByVal pageIndex As Integer _
)
'Usage

Dim file As ImGearFile
Dim format As ImGearFormats
Dim pageIndex As Integer

Dim instance As New ImGearLoadingSelectionEx(file, format, pageIndex)
public ImGearLoadingSelectionEx(
   ImGearFile file,
   ImGearFormats format,
   int pageIndex
)
public: ImGearLoadingSelectionEx(
   ImGearFile* file,
   ImGearFormats format,
   int pageIndex
)
public:
ImGearLoadingSelectionEx(
   ImGearFile^ file,
   ImGearFormats format,
   int pageIndex
)

Parameters

file
File selected in an open file dialog.
format
Format selected in an open file dialog.
pageIndex
Page index selected in an open file dialog.
See Also

Reference

ImGearLoadingSelectionEx Class
ImGearLoadingSelectionEx Members


%%PageItemTitle%% $$Properties$$

ImGearLoadingSelectionEx Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLoadingSelectionEx Class

For a list of all members of this type, see ImGearLoadingSelectionEx members.

Public Properties
 | Name | Description
Public Property | PageIndex | Gets the 0 based page index selected when using the FileOpenDialog launched by ImGearWinForms.SelectLocalFileToLoadEx method.
Top
See Also

Reference

ImGearLoadingSelectionEx Class
ImageGear.Windows.Forms Namespace
ImGearLoadingSelection Class


PageIndex Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLoadingSelectionEx Class : PageIndex Property
Gets the 0 based page index selected when using the FileOpenDialog launched by ImGearWinForms.SelectLocalFileToLoadEx method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageIndex As Integer
'Usage

Dim instance As ImGearLoadingSelectionEx
Dim value As Integer

value = instance.PageIndex
public int PageIndex {get;}
public: __property int get_PageIndex();
public:
property int PageIndex {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearLoadingSelectionEx Class
ImGearLoadingSelectionEx Members


%%PageItemTitle%%

ImGearLocalFile Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLocalFile Class
Represents a file on a local file system.
Object Model
ImGearLocalFile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearLocalFile
   Inherits ImGearFile
'Usage

Dim instance As ImGearLocalFile
public class ImGearLocalFile : ImGearFile
public __gc class ImGearLocalFile : public ImGearFile
public ref class ImGearLocalFile : public ImGearFile
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearFile
ImageGear.Windows.Forms.ImGearLocalFile

See Also

Reference

ImGearLocalFile Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearLocalFile Class Members
Fields Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLocalFile Class

The following tables list the members exposed by ImGearLocalFile.

Public Constructors
 | Name | Description
Public Constructor | ImGearLocalFile Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | OpenToRead | Opens a local file for reading.
Public Method | OpenToWrite | Opens a local file for writing.
Top
See Also

Reference

ImGearLocalFile Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Fields$$

ImGearLocalFile Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLocalFile Class

For a list of all members of this type, see ImGearLocalFile members.

See Also

Reference

ImGearLocalFile Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearLocalFile Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLocalFile Class : ImGearLocalFile Constructor
Overload List
Overload | Description
ImGearLocalFile Constructor() | Initializes a new instance of the ImGearLocalFile class.
ImGearLocalFile Constructor(String) | Initializes a new instance of the ImGearLocalFile class.
See Also

Reference

ImGearLocalFile Class
ImGearLocalFile Members


%%PageItemTitle%%

ImGearLocalFile Constructor()

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLocalFile Class > ImGearLocalFile Constructor : ImGearLocalFile Constructor()
Initializes a new instance of the ImGearLocalFile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearLocalFile()
public ImGearLocalFile()
public: ImGearLocalFile();
public:
ImGearLocalFile();
See Also

Reference

ImGearLocalFile Class
ImGearLocalFile Members
Overload List


%%PageItemTitle%%

ImGearLocalFile Constructor(String)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLocalFile Class > ImGearLocalFile Constructor : ImGearLocalFile Constructor(String)
Name of file with full path.
Initializes a new instance of the ImGearLocalFile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal path As String _
)
'Usage

Dim path As String

Dim instance As New ImGearLocalFile(path)
public ImGearLocalFile(
   string path
)
public: ImGearLocalFile(
   string* path
)
public:
ImGearLocalFile(
   String^ path
)

Parameters

path
Name of file with full path.
See Also

Reference

ImGearLocalFile Class
ImGearLocalFile Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearLocalFile Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearLocalFile Class

For a list of all members of this type, see ImGearLocalFile members.

Public Methods
 | Name | Description
Public Method | OpenToRead | Opens a local file for reading.
Public Method | OpenToWrite | Opens a local file for writing.
Top
See Also

Reference

ImGearLocalFile Class
ImageGear.Windows.Forms Namespace


OpenToRead Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLocalFile Class : OpenToRead Method
Opens a local file for reading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function OpenToRead() As FileStream
'Usage

Dim instance As ImGearLocalFile
Dim value As FileStream

value = instance.OpenToRead()
public FileStream OpenToRead()
public: FileStream* OpenToRead();
public:
FileStream^ OpenToRead();

Return Value

FileStream object for opened file.
See Also

Reference

ImGearLocalFile Class
ImGearLocalFile Members


OpenToWrite Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearLocalFile Class : OpenToWrite Method
Opens a local file for writing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function OpenToWrite() As FileStream
'Usage

Dim instance As ImGearLocalFile
Dim value As FileStream

value = instance.OpenToWrite()
public FileStream OpenToWrite()
public: FileStream* OpenToWrite();
public:
FileStream^ OpenToWrite();

Return Value

FileStream object for opened file.
See Also

Reference

ImGearLocalFile Class
ImGearLocalFile Members


%%PageItemTitle%%

ImGearMagnifier Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifier Class
Provides interactive magnifying glass style user interface for displayed images.
Object Model
ImGearMagnifier ClassImGearPageView ClassImGearPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMagnifier
   Inherits System.ComponentModel.Component
'Usage

Dim instance As ImGearMagnifier
public class ImGearMagnifier : System.ComponentModel.Component
public __gc class ImGearMagnifier : public System.ComponentModel.Component
public ref class ImGearMagnifier : public System.ComponentModel.Component
Remarks
This is the GUI Magnifier control class which provides a magnified view of a portion of the image in ImGearPageView class control. It appears either in a separate, stationary window, or as a popup area within the ImGearPageView window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView class control, the magnified display of the image tracks the location of the mouse. If the popup view is used, the magnified display of the image tracks the mouse within the ImGearPageView class control. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView class control. The programmer can set the magnification factor, and can optionally expose that capability to the end user.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ImageGear.Windows.Forms.ImGearMagnifier

See Also

Reference

ImGearMagnifier Members
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Members$$

ImGearMagnifier Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifier Class

The following tables list the members exposed by ImGearMagnifier.

Public Constructors
 | Name | Description
Public Constructor | ImGearMagnifier Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets cursor used while magnifying page area.
Public Property | DestinationView | Gets or sets ImGearPageView object used for displaying the magnified area.
Public Property | IsPopUp | Gets or sets a value indicating whether to show magnifier as pop up or in another view.
Public Property | PopupHeight | Gets or sets height of the popup magnifier window.
Public Property | PopupWidth | Gets or sets width of the popup magnifier window.
Public Property | ShapeType | Gets or sets the shape of the popup magnifier window.
Public Property | SourceView | Gets or sets the ImGearPageView object to be magnified.
Public Property | Zoom | Gets or sets zoom factor.
Top
See Also

Reference

ImGearMagnifier Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%%

ImGearMagnifier Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : ImGearMagnifier Constructor
Overload List
Overload | Description
ImGearMagnifier Constructor(IContainer) | Initializes a new instance of the ImGearMagnifier class.
ImGearMagnifier Constructor() | Initializes a new instance of the ImGearMagnifier class.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members


%%PageItemTitle%%

ImGearMagnifier Constructor(IContainer)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class > ImGearMagnifier Constructor : ImGearMagnifier Constructor(IContainer)
A collection of IComponent objects that represents all the components in the IContainer. Use this.components when initializing in the Windows Form Designer.
Initializes a new instance of the ImGearMagnifier class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New ImGearMagnifier(container)
public ImGearMagnifier(
   IContainer container
)
public: ImGearMagnifier(
   IContainer* container
)
public:
ImGearMagnifier(
   IContainer^ container
)

Parameters

container
A collection of IComponent objects that represents all the components in the IContainer. Use this.components when initializing in the Windows Form Designer.

Return Value

The new instance of ImGearMagnifier class.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
Overload List


%%PageItemTitle%%

ImGearMagnifier Constructor()

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class > ImGearMagnifier Constructor : ImGearMagnifier Constructor()
Initializes a new instance of the ImGearMagnifier class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMagnifier()
public ImGearMagnifier()
public: ImGearMagnifier();
public:
ImGearMagnifier();

Return Value

The new instance of ImGearMagnifier class.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearMagnifier Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifier Class

For a list of all members of this type, see ImGearMagnifier members.

See Also

Reference

ImGearMagnifier Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


%%PageItemTitle%% $$Events$$

ImGearMagnifier Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifier Class

For a list of all members of this type, see ImGearMagnifier members.

See Also

Reference

ImGearMagnifier Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


Dispose Method (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearMagnifier
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearMagnifier Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifier Class

For a list of all members of this type, see ImGearMagnifier members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets cursor used while magnifying page area.
Public Property | DestinationView | Gets or sets ImGearPageView object used for displaying the magnified area.
Public Property | IsPopUp | Gets or sets a value indicating whether to show magnifier as pop up or in another view.
Public Property | PopupHeight | Gets or sets height of the popup magnifier window.
Public Property | PopupWidth | Gets or sets width of the popup magnifier window.
Public Property | ShapeType | Gets or sets the shape of the popup magnifier window.
Public Property | SourceView | Gets or sets the ImGearPageView object to be magnified.
Public Property | Zoom | Gets or sets zoom factor.
Top
See Also

Reference

ImGearMagnifier Class
ImageGear.Windows.Forms Namespace
ImGearPageView Class


Cursor Property (ImGearMagnifier)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : Cursor Property
Gets or sets cursor used while magnifying page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cursor As Cursor
'Usage

Dim instance As ImGearMagnifier
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
public Cursor Cursor {get; set;}
public: __property Cursor* get_Cursor();
public: __property void set_Cursor(
   Cursor* value
);
public:
property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

System.Windows.Forms.Cursor class object.
Example
  • C#
igMagnifier.Cursor = System.Windows.Forms.Cursors.NoMoveHoriz;
  • Visual Basic
igMagnifier.Cursor = System.Windows.Forms.Cursors.NoMoveHoriz
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members


DestinationView Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : DestinationView Property
Gets or sets ImGearPageView object used for displaying the magnified area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestinationView As ImGearPageView
'Usage

Dim instance As ImGearMagnifier
Dim value As ImGearPageView

instance.DestinationView = value

value = instance.DestinationView
public ImGearPageView DestinationView {get; set;}
public: __property ImGearPageView* get_DestinationView();
public: __property void set_DestinationView(
   ImGearPageView* value
);
public:
property ImGearPageView^ DestinationView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImGearPageView class.
Remarks
If IsPopUp property is true, DestinationView could be empty.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
IsPopUp Property
ImGearPageView Class


IsPopUp Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : IsPopUp Property
Gets or sets a value indicating whether to show magnifier as pop up or in another view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPopUp As Boolean
'Usage

Dim instance As ImGearMagnifier
Dim value As Boolean

instance.IsPopUp = value

value = instance.IsPopUp
public bool IsPopUp {get; set;}
public: __property bool get_IsPopUp();
public: __property void set_IsPopUp(
   bool value
);
public:
property bool IsPopUp {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If this property is True, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView. Default value is True.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
DestinationView Property


PopupHeight Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : PopupHeight Property
Gets or sets height of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupHeight As Integer
'Usage

Dim instance As ImGearMagnifier
Dim value As Integer

instance.PopupHeight = value

value = instance.PopupHeight
public int PopupHeight {get; set;}
public: __property int get_PopupHeight();
public: __property void set_PopupHeight(
   int value
);
public:
property int PopupHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
PopupWidth Property


PopupWidth Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : PopupWidth Property
Gets or sets width of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PopupWidth As Integer
'Usage

Dim instance As ImGearMagnifier
Dim value As Integer

instance.PopupWidth = value

value = instance.PopupWidth
public int PopupWidth {get; set;}
public: __property int get_PopupWidth();
public: __property void set_PopupWidth(
   int value
);
public:
property int PopupWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
PopupHeight Property


ShapeType Property (ImGearMagnifier)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : ShapeType Property
Gets or sets the shape of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShapeType As ImGearMagnifierShapeType
'Usage

Dim instance As ImGearMagnifier
Dim value As ImGearMagnifierShapeType

instance.ShapeType = value

value = instance.ShapeType
public ImGearMagnifierShapeType ShapeType {get; set;}
public: __property ImGearMagnifierShapeType get_ShapeType();
public: __property void set_ShapeType(
   ImGearMagnifierShapeType value
);
public:
property ImGearMagnifierShapeType ShapeType {
   ImGearMagnifierShapeType get();
   void set (    ImGearMagnifierShapeType value);
}

Property Value

ImGearMagnifierShapeType enumeration value.
Remarks
Default value is rectangle.
Example
  • C#
igMagnifier.ShapeType = ImageGear.Windows.Forms.ImGearMagnifierShapeType.Ellipse;
  • Visual Basic
igMagnifier.ShapeType = ImageGear.Windows.Forms.ImGearMagnifierShapeType.Ellipse
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
ImGearMagnifierShapeType Enumeration


SourceView Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : SourceView Property
Gets or sets the ImGearPageView object to be magnified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SourceView As ImGearPageView
'Usage

Dim instance As ImGearMagnifier
Dim value As ImGearPageView

instance.SourceView = value

value = instance.SourceView
public ImGearPageView SourceView {get; set;}
public: __property ImGearPageView* get_SourceView();
public: __property void set_SourceView(
   ImGearPageView* value
);
public:
property ImGearPageView^ SourceView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImGearPageView class object.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members
ImGearPageView Class


Zoom Property (ImGearMagnifier)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearMagnifier Class : Zoom Property
Gets or sets zoom factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Zoom As Single
'Usage

Dim instance As ImGearMagnifier
Dim value As Single

instance.Zoom = value

value = instance.Zoom
public float Zoom {get; set;}
public: __property float get_Zoom();
public: __property void set_Zoom(
   float value
);
public:
property float Zoom {
   float get();
   void set (    float value);
}

Property Value

Float value.
Remarks
Zoom factor must be between 1 and 500.
See Also

Reference

ImGearMagnifier Class
ImGearMagnifier Members


%%PageItemTitle%%

ImGearPageView Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView Class
A control for displaying an image within a form.
Object Model
ImGearPageView ClassImGearPageDisplay ClassImGearScrollBarIncrement ClassImGearScrollBarIncrement ClassImGearPage ClassImGearScrollBarIncrement ClassImGearScrollBarIncrement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPageView
   Inherits System.Windows.Forms.UserControl
   Implements ImageGear.Display.IImGearScrollableView
'Usage

Dim instance As ImGearPageView
public class ImGearPageView : System.Windows.Forms.UserControl, ImageGear.Display.IImGearScrollableView
public __gc class ImGearPageView : public System.Windows.Forms.UserControl, ImageGear.Display.IImGearScrollableView
public ref class ImGearPageView : public System.Windows.Forms.UserControl, ImageGear.Display.IImGearScrollableView
Remarks
This is the page view control, used for displaying an image within a form. It encapsulates paint handling, although it offers some ways to customize the painting process.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ImageGear.Windows.Forms.ImGearPageView

See Also

Reference

ImGearPageView Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearPageView Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView Class

The following tables list the members exposed by ImGearPageView.

Public Constructors
 | Name | Description
Public Constructor | ImGearPageView Constructor | Initializes a new instance of the ImGearPageView class.
Top
Public Properties
 | Name | Description
Public Property | BindArrowKeyScrolling | Gets or sets a value indicating whether or not the ImGearPageView control will handle the Arrow keys.
Public Property | Display | Gets or sets ImGearPageDisplay object associated with the control, representing the image and display parameters.
Public Property | HorizontalArrowIncerment | Gets or sets the Horizontal amount to scroll when using the left or right arrow keys.
Public Property | HorizontalLargeChange | Gets the horizontal ScrollBar large change increment settings.
Public Property | HorizontalSmallChange | Gets the horizontal ScrollBar small change increment settings.
Public Property | NotifyPageDown | Gets or sets a reference to a DelegatePageCalculate delegate.
Public Property | NotifyPageUp | Gets or sets a reference to a DelegatePageCaluclate delegate.
Public Property | Page | Gets or sets page associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay object.
Public Property | UseConfiguredScrollbarIncrements | Gets or sets a value indicating whether to use configured HorizontalSmallChange, HorizontalLargeChange, VerticalSmallChange and VerticalLargeChange increments, or automatically calculated values.
Public Property | VerticalArrowIncerment | Gets or sets the vertical amount to scroll when using the up or down arrow keys.
Public Property | VerticalLargeChange | Gets the vertical ScrollBar large change increment settings.
Public Property | VerticalSmallChange | Gets the vertical ScrollBar small change increment settings.
Top
Public Methods
 | Name | Description
Public Method | EnableScrollBar | Enable or disable specified scroll bar.
Public Method | RegisterAfterDraw | Registers a method to be called after default painting has been performed.
Public Method | ShowScrollBar | Change visibility state of scrollbars associated with window.
Public Method | Update | Overloaded. Invalidates the control's area, causing its contents to be repainted.
Top
Protected Methods
 | Name | Description
Protected Method | OnPaint | Overridden. Derived classes can implement this method to handle paint events themselves.
Protected Method | ProcessCmdKey | Overridden. Processes a command key.
Top
Public Events
 | Name | Description
Public Event | AfterDrawEvent | This event is called after default painting has been performed.
Top
See Also

Reference

ImGearPageView Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearPageView Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : ImGearPageView Constructor
Initializes a new instance of the ImGearPageView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPageView()
public ImGearPageView()
public: ImGearPageView();
public:
ImGearPageView();

Return Value

The new instance of ImGearPageView class.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


%%PageItemTitle%% $$Methods$$

ImGearPageView Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView Class

For a list of all members of this type, see ImGearPageView members.

Public Methods
 | Name | Description
Public Method | EnableScrollBar | Enable or disable specified scroll bar.
Public Method | RegisterAfterDraw | Registers a method to be called after default painting has been performed.
Public Method | ShowScrollBar | Change visibility state of scrollbars associated with window.
Public Method | Update | Overloaded. Invalidates the control's area, causing its contents to be repainted.
Top
Protected Methods
 | Name | Description
Protected Method | OnPaint | Overridden. Derived classes can implement this method to handle paint events themselves.
Protected Method | ProcessCmdKey | Overridden. Processes a command key.
Top
See Also

Reference

ImGearPageView Class
ImageGear.Windows.Forms Namespace


Dispose Method (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearPageView
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
Overload List


EnableScrollBar Method (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : EnableScrollBar Method
Which scroll bar to enable to disable.
Whether to enable the scrollbar or not.
Enable or disable specified scroll bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EnableScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal state As Boolean _
)
'Usage

Dim instance As ImGearPageView
Dim scrollBarType As ImGearScrollBarType
Dim state As Boolean

instance.EnableScrollBar(scrollBarType, state)
public void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
public: void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)
public:
void EnableScrollBar(
   ImGearScrollBarType scrollBarType,
   bool state
)

Parameters

scrollBarType
Which scroll bar to enable to disable.
state
Whether to enable the scrollbar or not.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


OnPaint Method (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : OnPaint Method
PaintEventArgs object containing event data.
Derived classes can implement this method to handle paint events themselves.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnPaint( _
   ByVal e As PaintEventArgs _
)
'Usage

Dim instance As ImGearPageView
Dim e As PaintEventArgs

instance.OnPaint(e)
protected override void OnPaint(
   PaintEventArgs e
)
protected: void OnPaint(
   PaintEventArgs* e
) override
protected:
void OnPaint(
   PaintEventArgs^ e
) override

Parameters

e
PaintEventArgs object containing event data.
Remarks
This method is called when the control is required to paint its contents. An application does not call this method directly.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


ProcessCmdKey Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : ProcessCmdKey Method
A Message, passed by reference, that represents the window message to process.
One of the Keys values that represents the key to process.
Processes a command key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function ProcessCmdKey( _
   ByRef msg As Message, _
   ByVal keyData As Keys _
) As Boolean
'Usage

Dim instance As ImGearPageView
Dim msg As Message
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessCmdKey(msg, keyData)
protected override bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
)
protected: bool ProcessCmdKey(
   ref Message msg,
   Keys keyData
) override
protected:
bool ProcessCmdKey(
   Message% msg,
   Keys keyData
) override

Parameters

msg
A Message, passed by reference, that represents the window message to process.
keyData
One of the Keys values that represents the key to process.

Return Value

Returns true if the character was processed by the control; otherwise, false.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


RegisterAfterDraw Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : RegisterAfterDraw Method
Method to be called after default painting.
Registers a method to be called after default painting has been performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RegisterAfterDraw( _
   ByVal callback As ImGearPageView.AfterDraw _
)
'Usage

Dim instance As ImGearPageView
Dim callback As ImGearPageView.AfterDraw

instance.RegisterAfterDraw(callback)
public void RegisterAfterDraw(
   ImGearPageView.AfterDraw callback
)
public: void RegisterAfterDraw(
   ImGearPageView.AfterDraw* callback
)
public:
void RegisterAfterDraw(
   ImGearPageView.AfterDraw^ callback
)

Parameters

callback
Method to be called after default painting.
Remarks
This method can be used by an application to perform additional painting, such as painting overlaid on top of the image. It is recommended that the AfterDrawEvent event be used instead of this method.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
AfterDrawEvent Event


ShowScrollBar Method (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : ShowScrollBar Method
Specifies the scrollbar whose attributes are requested.
The visibility mode of the scrollbar.
Change visibility state of scrollbars associated with window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowScrollBar( _
   ByVal scrollBarType As ImGearScrollBarType, _
   ByVal scrollMode As ImGearScrollBarModes _
)
'Usage

Dim instance As ImGearPageView
Dim scrollBarType As ImGearScrollBarType
Dim scrollMode As ImGearScrollBarModes

instance.ShowScrollBar(scrollBarType, scrollMode)
public void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)
public: void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)
public:
void ShowScrollBar(
   ImGearScrollBarType scrollBarType,
   ImGearScrollBarModes scrollMode
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollMode
The visibility mode of the scrollbar.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


Update Method (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : Update Method
Invalidates the control's area, causing its contents to be repainted.
Overload List
Overload | Description
Update() | Invalidates the control's area, causing its contents to be repainted.
Update(IImGearRectangle) | Invalidates the specified region of the control, causing its contents to be repainted.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


Update() Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class > Update Method : Update() Method
Invalidates the control's area, causing its contents to be repainted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shadows Sub Update()
'Usage

Dim instance As ImGearPageView

instance.Update()
public new void Update()
public: new void Update();
public:
new void Update();
Remarks
When changes are made to the image being displayed, this method is typically called immediately afterwards to make those changes visible.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
Overload List


Update(IImGearRectangle) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class > Update Method : Update(IImGearRectangle) Method
The rectangle to invalidate. If this parameter is null or empty, will be invalidated control's entire client area.
Invalidates the specified region of the control, causing its contents to be repainted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Update( _
   ByVal updateRect As IImGearRectangle _
)
'Usage

Dim instance As ImGearPageView
Dim updateRect As IImGearRectangle

instance.Update(updateRect)
public void Update(
   IImGearRectangle updateRect
)
public: void Update(
   IImGearRectangle* updateRect
)
public:
void Update(
   IImGearRectangle^ updateRect
)

Parameters

updateRect
The rectangle to invalidate. If this parameter is null or empty, will be invalidated control's entire client area.
Remarks
When changes are made to the portion of image being displayed, this method is typically called immediately afterwards to make those changes visible.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearPageView Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView Class

For a list of all members of this type, see ImGearPageView members.

Public Properties
 | Name | Description
Public Property | BindArrowKeyScrolling | Gets or sets a value indicating whether or not the ImGearPageView control will handle the Arrow keys.
Public Property | Display | Gets or sets ImGearPageDisplay object associated with the control, representing the image and display parameters.
Public Property | HorizontalArrowIncerment | Gets or sets the Horizontal amount to scroll when using the left or right arrow keys.
Public Property | HorizontalLargeChange | Gets the horizontal ScrollBar large change increment settings.
Public Property | HorizontalSmallChange | Gets the horizontal ScrollBar small change increment settings.
Public Property | NotifyPageDown | Gets or sets a reference to a DelegatePageCalculate delegate.
Public Property | NotifyPageUp | Gets or sets a reference to a DelegatePageCaluclate delegate.
Public Property | Page | Gets or sets page associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay object.
Public Property | UseConfiguredScrollbarIncrements | Gets or sets a value indicating whether to use configured HorizontalSmallChange, HorizontalLargeChange, VerticalSmallChange and VerticalLargeChange increments, or automatically calculated values.
Public Property | VerticalArrowIncerment | Gets or sets the vertical amount to scroll when using the up or down arrow keys.
Public Property | VerticalLargeChange | Gets the vertical ScrollBar large change increment settings.
Public Property | VerticalSmallChange | Gets the vertical ScrollBar small change increment settings.
Top
See Also

Reference

ImGearPageView Class
ImageGear.Windows.Forms Namespace


BindArrowKeyScrolling Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : BindArrowKeyScrolling Property
Gets or sets a value indicating whether or not the ImGearPageView control will handle the Arrow keys.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BindArrowKeyScrolling As Boolean
'Usage

Dim instance As ImGearPageView
Dim value As Boolean

instance.BindArrowKeyScrolling = value

value = instance.BindArrowKeyScrolling
public bool BindArrowKeyScrolling {get; set;}
public: __property bool get_BindArrowKeyScrolling();
public: __property void set_BindArrowKeyScrolling(
   bool value
);
public:
property bool BindArrowKeyScrolling {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


Display Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : Display Property
Gets or sets ImGearPageDisplay object associated with the control, representing the image and display parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Display As ImGearPageDisplay
'Usage

Dim instance As ImGearPageView
Dim value As ImGearPageDisplay

instance.Display = value

value = instance.Display
public ImGearPageDisplay Display {get; set;}
public: __property ImGearPageDisplay* get_Display();
public: __property void set_Display(
   ImGearPageDisplay* value
);
public:
property ImGearPageDisplay^ Display {
   ImGearPageDisplay^ get();
   void set (    ImGearPageDisplay^ value);
}

Property Value

ImageGear.Display.ImGearPageDisplay class object.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
ImGearPageDisplay Class


HorizontalArrowIncerment Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : HorizontalArrowIncerment Property
Gets or sets the Horizontal amount to scroll when using the left or right arrow keys.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalArrowIncerment As Integer
'Usage

Dim instance As ImGearPageView
Dim value As Integer

instance.HorizontalArrowIncerment = value

value = instance.HorizontalArrowIncerment
public int HorizontalArrowIncerment {get; set;}
public: __property int get_HorizontalArrowIncerment();
public: __property void set_HorizontalArrowIncerment(
   int value
);
public:
property int HorizontalArrowIncerment {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


HorizontalLargeChange Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : HorizontalLargeChange Property
Gets the horizontal ScrollBar large change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalLargeChange As ImGearScrollBarIncrement
'Usage

Dim instance As ImGearPageView
Dim value As ImGearScrollBarIncrement

value = instance.HorizontalLargeChange
public ImGearScrollBarIncrement HorizontalLargeChange {get;}
public: __property ImGearScrollBarIncrement* get_HorizontalLargeChange();
public:
property ImGearScrollBarIncrement^ HorizontalLargeChange {
   ImGearScrollBarIncrement^ get();
}

Property Value

ImGearScrollBarIncrement class object.
Remarks
Note: this property has effect, when UseConfiguredScrollbarIncrements control parameter is on.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
UseConfiguredScrollbarIncrements Property


HorizontalSmallChange Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : HorizontalSmallChange Property
Gets the horizontal ScrollBar small change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalSmallChange As ImGearScrollBarIncrement
'Usage

Dim instance As ImGearPageView
Dim value As ImGearScrollBarIncrement

value = instance.HorizontalSmallChange
public ImGearScrollBarIncrement HorizontalSmallChange {get;}
public: __property ImGearScrollBarIncrement* get_HorizontalSmallChange();
public:
property ImGearScrollBarIncrement^ HorizontalSmallChange {
   ImGearScrollBarIncrement^ get();
}

Property Value

ImGearScrollBarIncrement class object.
Remarks
Note: this property has effect, when UseConfiguredScrollbarIncrements control parameter is on.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
UseConfiguredScrollbarIncrements Property


NotifyPageDown Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : NotifyPageDown Property
Gets or sets a reference to a DelegatePageCalculate delegate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NotifyPageDown As ImGearPageView.DelegatePageCalculate
'Usage

Dim instance As ImGearPageView
Dim value As ImGearPageView.DelegatePageCalculate

instance.NotifyPageDown = value

value = instance.NotifyPageDown
public ImGearPageView.DelegatePageCalculate NotifyPageDown {get; set;}
public: __property ImGearPageView.DelegatePageCalculate* get_NotifyPageDown();
public: __property void set_NotifyPageDown(
   ImGearPageView.DelegatePageCalculate* value
);
public:
property ImGearPageView.DelegatePageCalculate^ NotifyPageDown {
   ImGearPageView.DelegatePageCalculate^ get();
   void set (    ImGearPageView.DelegatePageCalculate^ value);
}

Property Value

ImGearPageView.DelegatePageCalculate delegate.
Remarks
If registered it is called when the Page Down key is pressed and will be used to calculate the amount of scrolling desired. If none is registered the ImGearPageView class control does not handle the Page Down.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
ImGearPageView.DelegatePageCalculate Delegate


NotifyPageUp Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : NotifyPageUp Property
Gets or sets a reference to a DelegatePageCaluclate delegate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NotifyPageUp As ImGearPageView.DelegatePageCalculate
'Usage

Dim instance As ImGearPageView
Dim value As ImGearPageView.DelegatePageCalculate

instance.NotifyPageUp = value

value = instance.NotifyPageUp
public ImGearPageView.DelegatePageCalculate NotifyPageUp {get; set;}
public: __property ImGearPageView.DelegatePageCalculate* get_NotifyPageUp();
public: __property void set_NotifyPageUp(
   ImGearPageView.DelegatePageCalculate* value
);
public:
property ImGearPageView.DelegatePageCalculate^ NotifyPageUp {
   ImGearPageView.DelegatePageCalculate^ get();
   void set (    ImGearPageView.DelegatePageCalculate^ value);
}

Property Value

ImGearPageView.DelegatePageCalculate delegate.
Remarks
If registered it is called when the Page Up key is pressed and will be used to calculate the amount of scrolling desired. If none is registered the ImGearPageView class control does not handle Page Up.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
ImGearPageView.DelegatePageCalculate Delegate


Page Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : Page Property
Gets or sets page associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As ImGearPage
'Usage

Dim instance As ImGearPageView
Dim value As ImGearPage

instance.Page = value

value = instance.Page
public ImGearPage Page {get; set;}
public: __property ImGearPage* get_Page();
public: __property void set_Page(
   ImGearPage* value
);
public:
property ImGearPage^ Page {
   ImGearPage^ get();
   void set (    ImGearPage^ value);
}

Property Value

ImageGear.Core.ImGearPage class.
Remarks
This property represents the ImageGear.Core.ImGearPage class associated with the control. This property is automatically connected to the Display property. It will always refer to the same ImageGear.Core.ImGearPage class object as the Page property of that ImGearDisplay object. Note that if ImGearPageView class Page property is set, its Display property will automatically also be set, and vice versa.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
ImGearPage Class


UseConfiguredScrollbarIncrements Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : UseConfiguredScrollbarIncrements Property
Gets or sets a value indicating whether to use configured HorizontalSmallChange, HorizontalLargeChange, VerticalSmallChange and VerticalLargeChange increments, or automatically calculated values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseConfiguredScrollbarIncrements As Boolean
'Usage

Dim instance As ImGearPageView
Dim value As Boolean

instance.UseConfiguredScrollbarIncrements = value

value = instance.UseConfiguredScrollbarIncrements
public bool UseConfiguredScrollbarIncrements {get; set;}
public: __property bool get_UseConfiguredScrollbarIncrements();
public: __property void set_UseConfiguredScrollbarIncrements(
   bool value
);
public:
property bool UseConfiguredScrollbarIncrements {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
HorizontalSmallChange Property
HorizontalLargeChange Property
VerticalSmallChange Property
VerticalLargeChange Property


VerticalArrowIncerment Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : VerticalArrowIncerment Property
Gets or sets the vertical amount to scroll when using the up or down arrow keys.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalArrowIncerment As Integer
'Usage

Dim instance As ImGearPageView
Dim value As Integer

instance.VerticalArrowIncerment = value

value = instance.VerticalArrowIncerment
public int VerticalArrowIncerment {get; set;}
public: __property int get_VerticalArrowIncerment();
public: __property void set_VerticalArrowIncerment(
   int value
);
public:
property int VerticalArrowIncerment {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearPageView Class
ImGearPageView Members


VerticalLargeChange Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : VerticalLargeChange Property
Gets the vertical ScrollBar large change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalLargeChange As ImGearScrollBarIncrement
'Usage

Dim instance As ImGearPageView
Dim value As ImGearScrollBarIncrement

value = instance.VerticalLargeChange
public ImGearScrollBarIncrement VerticalLargeChange {get;}
public: __property ImGearScrollBarIncrement* get_VerticalLargeChange();
public:
property ImGearScrollBarIncrement^ VerticalLargeChange {
   ImGearScrollBarIncrement^ get();
}

Property Value

ImGearScrollBarIncrement class object.
Remarks
Note: this property has effect, when UseConfiguredScrollbarIncrements control parameter is on.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
UseConfiguredScrollbarIncrements Property


VerticalSmallChange Property (ImGearPageView)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : VerticalSmallChange Property
Gets the vertical ScrollBar small change increment settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalSmallChange As ImGearScrollBarIncrement
'Usage

Dim instance As ImGearPageView
Dim value As ImGearScrollBarIncrement

value = instance.VerticalSmallChange
public ImGearScrollBarIncrement VerticalSmallChange {get;}
public: __property ImGearScrollBarIncrement* get_VerticalSmallChange();
public:
property ImGearScrollBarIncrement^ VerticalSmallChange {
   ImGearScrollBarIncrement^ get();
}

Property Value

ImGearScrollBarIncrement class object.
Remarks
Note: this property has effect, when UseConfiguredScrollbarIncrements control parameter is on.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
UseConfiguredScrollbarIncrements Property


%%PageItemTitle%% $$Events$$

ImGearPageView Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView Class

For a list of all members of this type, see ImGearPageView members.

Public Events
 | Name | Description
Public Event | AfterDrawEvent | This event is called after default painting has been performed.
Top
See Also

Reference

ImGearPageView Class
ImageGear.Windows.Forms Namespace


AfterDrawEvent Event

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPageView Class : AfterDrawEvent Event
This event is called after default painting has been performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterDrawEvent As EventHandler(Of ImGearAfterDrawEventArgs)
'Usage

Dim instance As ImGearPageView
Dim handler As EventHandler(Of ImGearAfterDrawEventArgs)

AddHandler instance.AfterDrawEvent, handler
public event EventHandler<ImGearAfterDrawEventArgs> AfterDrawEvent
public: __event EventHandler<ImGearAfterDrawEventArgs*>* AfterDrawEvent
public:
event EventHandler<ImGearAfterDrawEventArgs^>^ AfterDrawEvent
Event Data

The event handler receives an argument of type ImGearAfterDrawEventArgs containing data related to this event. The following ImGearAfterDrawEventArgs properties provide information specific to this event.

Property | Description
graphics | Gets Graphics object used for painting on the ImGearPageView class for which the event was triggered.
Remarks
This event can be used by an application to perform additional painting, such as painting overlaid on top of the image.
See Also

Reference

ImGearPageView Class
ImGearPageView Members
ImGearAfterDrawEventArgs Class


%%PageItemTitle%%

ImGearPan Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPan Class
This is the GUI Pan Control that allows the visible portion of an image displayed in the ImGearPageView class control to be moved by dragging the mouse around in the image.
Object Model
ImGearPan ClassImGearPageView ClassImGearPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPan
   Inherits System.ComponentModel.Component
'Usage

Dim instance As ImGearPan
public class ImGearPan : System.ComponentModel.Component
public __gc class ImGearPan : public System.ComponentModel.Component
public ref class ImGearPan : public System.ComponentModel.Component
Remarks

The common task for drawing an image in the ImGearPageView control is panning an image inside the window using mouse capturing. This class provides such functionality. This is not a Window or Control; this is a Component that extends the functionality of ImGearPageView with a panning algorithm. Assign the ImGearPageView control to the ImGearPan component to implement the panning functionality in page view. Use the SourceViewCursor property to change the dragging cursor in the source view of the ImGearPan component. Change the mouse button used for dragging with the PanButton property.

Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImGearPageView class control is repositioned. The portion of the image that is visible in the ImGearPageView class control is displayed within the floating window in reverse video. Assign the ImGearPageView control that will illustrate the place of the source view on the image to the DestinationView property of the ImGearPan component.

Example
This example illustrates how the ImGearPan component can be bound with two ImGearPageView controls to implemen the panning functionality. Created with the MainForm constructor of the application, the ImGearPan object is initialized with existing igPanSource and igPanDestination controls to achieve the required functionality. Since ImGearPan is a Component, working with ImGearPan is accessible from the Microsoft NET Windows Forms Designer.
  • C#
using ImageGear.Core;
using ImageGear.Windows.Forms;

public partial class MainForm : Form
{
    // Panning implementation object.
    private ImGearPan igPan;

    // Creates the new application form.
    public MainForm()
    {
        InitializeComponent();

        // Create panning implementation object.
        igPan = new ImGearPan();
        // Assign source window for panning.
        igPan.SourceView = igPanSource;
        // Assign the navigation control.
        igPan.DestinationView = igPanDestination;
    }
}
  • Visual Basic
Imports ImageGear.Core
Imports ImageGear.Windows.Forms

Public Partial Class MainForm
Inherits Form
' Panning implementation object.
Private igPan As ImGearPan

' Creates the new application form.
Public Sub New()
    InitializeComponent()

    ' Create panning implementation object.
    igPan = New ImGearPan()
    ' Assign source window for panning.
    igPan.SourceView = igPanSource
    ' Assign the navigation control.
    igPan.DestinationView = igPanDestination
End Sub
End Class
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ImageGear.Windows.Forms.ImGearPan

See Also

Reference

ImGearPan Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearPan Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPan Class

The following tables list the members exposed by ImGearPan.

Public Constructors
 | Name | Description
Public Constructor | ImGearPan Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AdjustNavigationRectangleByImage | Gets or sets a value indicating whether the size of the navigation rectangle is adjusted.
Public Property | DestinationView | Gets or sets the ImGearPageView object used for displaying the panning area.
Public Property | DestinationViewCursor | Gets or sets the cursor while navigation rectangle is panning.
Public Property | LineColor | Gets or sets the color for the pan rectangle drawing.
Public Property | LineThickness | Gets or sets the line thickness for pan rectangle drawing.
Public Property | PanButton | Gets or sets the mouse button used for panning.
Public Property | SourceView | Gets or sets the ImGearPageView object to apply panning functionality to.
Public Property | SourceViewCursor | Gets or sets the cursor used while panning page area.
Top
See Also

Reference

ImGearPan Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearPan Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : ImGearPan Constructor
Overload List
Overload | Description
ImGearPan Constructor(IContainer) | Initializes a new instance of the ImGearPan class.
ImGearPan Constructor() | Initializes a new instance of the ImGearPan class.
See Also

Reference

ImGearPan Class
ImGearPan Members


%%PageItemTitle%%

ImGearPan Constructor(IContainer)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class > ImGearPan Constructor : ImGearPan Constructor(IContainer)
A collection of IComponent objects that represents all the components in the IContainer. Use this component when initializing in the Windows Form Designer.
Initializes a new instance of the ImGearPan class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New ImGearPan(container)
public ImGearPan(
   IContainer container
)
public: ImGearPan(
   IContainer* container
)
public:
ImGearPan(
   IContainer^ container
)

Parameters

container
A collection of IComponent objects that represents all the components in the IContainer. Use this component when initializing in the Windows Form Designer.

Return Value

New instance of ImGearPan class object.
Remarks
This constructor creates and initializes an instance of ImGearPan class.
See Also

Reference

ImGearPan Class
ImGearPan Members
Overload List


%%PageItemTitle%%

ImGearPan Constructor()

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class > ImGearPan Constructor : ImGearPan Constructor()
Initializes a new instance of the ImGearPan class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPan()
public ImGearPan()
public: ImGearPan();
public:
ImGearPan();
See Also

Reference

ImGearPan Class
ImGearPan Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearPan Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPan Class

For a list of all members of this type, see ImGearPan members.

See Also

Reference

ImGearPan Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

ImGearPan Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPan Class

For a list of all members of this type, see ImGearPan members.

See Also

Reference

ImGearPan Class
ImageGear.Windows.Forms Namespace


Dispose Method (ImGearPan)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearPan Class
ImGearPan Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearPan
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearPan Class
ImGearPan Members
Overload List


%%PageItemTitle%% $$Properties$$

ImGearPan Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPan Class

For a list of all members of this type, see ImGearPan members.

Public Properties
 | Name | Description
Public Property | AdjustNavigationRectangleByImage | Gets or sets a value indicating whether the size of the navigation rectangle is adjusted.
Public Property | DestinationView | Gets or sets the ImGearPageView object used for displaying the panning area.
Public Property | DestinationViewCursor | Gets or sets the cursor while navigation rectangle is panning.
Public Property | LineColor | Gets or sets the color for the pan rectangle drawing.
Public Property | LineThickness | Gets or sets the line thickness for pan rectangle drawing.
Public Property | PanButton | Gets or sets the mouse button used for panning.
Public Property | SourceView | Gets or sets the ImGearPageView object to apply panning functionality to.
Public Property | SourceViewCursor | Gets or sets the cursor used while panning page area.
Top
See Also

Reference

ImGearPan Class
ImageGear.Windows.Forms Namespace


AdjustNavigationRectangleByImage Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : AdjustNavigationRectangleByImage Property
Gets or sets a value indicating whether the size of the navigation rectangle is adjusted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AdjustNavigationRectangleByImage As Boolean
'Usage

Dim instance As ImGearPan
Dim value As Boolean

instance.AdjustNavigationRectangleByImage = value

value = instance.AdjustNavigationRectangleByImage
public bool AdjustNavigationRectangleByImage {get; set;}
public: __property bool get_AdjustNavigationRectangleByImage();
public: __property void set_AdjustNavigationRectangleByImage(
   bool value
);
public:
property bool AdjustNavigationRectangleByImage {
   bool get();
   void set (    bool value);
}

Property Value

When the value is true the size of the navigation rectangle is adjusted to the image size. Default value is false. In this case the size of the navigation rectangle is the source view client rectangle clipped by the destination view client rectangle.
See Also

Reference

ImGearPan Class
ImGearPan Members


DestinationView Property (ImGearPan)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : DestinationView Property
Gets or sets the ImGearPageView object used for displaying the panning area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestinationView As ImGearPageView
'Usage

Dim instance As ImGearPan
Dim value As ImGearPageView

instance.DestinationView = value

value = instance.DestinationView
public ImGearPageView DestinationView {get; set;}
public: __property ImGearPageView* get_DestinationView();
public: __property void set_DestinationView(
   ImGearPageView* value
);
public:
property ImGearPageView^ DestinationView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImGearPageView class object.
See Also

Reference

ImGearPan Class
ImGearPan Members


DestinationViewCursor Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : DestinationViewCursor Property
Gets or sets the cursor while navigation rectangle is panning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestinationViewCursor As Cursor
'Usage

Dim instance As ImGearPan
Dim value As Cursor

instance.DestinationViewCursor = value

value = instance.DestinationViewCursor
public Cursor DestinationViewCursor {get; set;}
public: __property Cursor* get_DestinationViewCursor();
public: __property void set_DestinationViewCursor(
   Cursor* value
);
public:
property Cursor^ DestinationViewCursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

System.Windows.Forms.Cursor class. Default value is System.Windows.Forms.Cursors.Hand.
See Also

Reference

ImGearPan Class
ImGearPan Members


LineColor Property (ImGearPan)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : LineColor Property
Gets or sets the color for the pan rectangle drawing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineColor As Color
'Usage

Dim instance As ImGearPan
Dim value As Color

instance.LineColor = value

value = instance.LineColor
public Color LineColor {get; set;}
public: __property Color get_LineColor();
public: __property void set_LineColor(
   Color value
);
public:
property Color LineColor {
   Color get();
   void set (    Color value);
}

Property Value

The color for the pan rectangle drawing. Default value is System.Drawing.Color.LightGreen.
See Also

Reference

ImGearPan Class
ImGearPan Members


LineThickness Property (ImGearPan)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : LineThickness Property
Gets or sets the line thickness for pan rectangle drawing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineThickness As Single
'Usage

Dim instance As ImGearPan
Dim value As Single

instance.LineThickness = value

value = instance.LineThickness
public float LineThickness {get; set;}
public: __property float get_LineThickness();
public: __property void set_LineThickness(
   float value
);
public:
property float LineThickness {
   float get();
   void set (    float value);
}

Property Value

The line thickness for pan rectangle drawing. Default value is 1.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | An exception will be thrown if the given value is less than or equal to 0 or is greater than 100.
See Also

Reference

ImGearPan Class
ImGearPan Members


PanButton Property (ImGearPan)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : PanButton Property
Gets or sets the mouse button used for panning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PanButton As MouseButtons
'Usage

Dim instance As ImGearPan
Dim value As MouseButtons

instance.PanButton = value

value = instance.PanButton
public MouseButtons PanButton {get; set;}
public: __property MouseButtons get_PanButton();
public: __property void set_PanButton(
   MouseButtons value
);
public:
property MouseButtons PanButton {
   MouseButtons get();
   void set (    MouseButtons value);
}

Property Value

System.Windows.Forms.MouseButtons value. Default value is Left.
Remarks
This value is the dragging mouse button of the ImGearPageView object that is assigned to the SourceView property.
Example
  • C#
igPan.PanButton = System.Windows.Forms.MouseButtons.Left;
  • Visual Basic
igPan.PanButton = System.Windows.Forms.MouseButtons.Left
See Also

Reference

ImGearPan Class
ImGearPan Members


SourceView Property (ImGearPan)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : SourceView Property
Gets or sets the ImGearPageView object to apply panning functionality to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SourceView As ImGearPageView
'Usage

Dim instance As ImGearPan
Dim value As ImGearPageView

instance.SourceView = value

value = instance.SourceView
public ImGearPageView SourceView {get; set;}
public: __property ImGearPageView* get_SourceView();
public: __property void set_SourceView(
   ImGearPageView* value
);
public:
property ImGearPageView^ SourceView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImGearPageView class.
See Also

Reference

ImGearPan Class
ImGearPan Members


SourceViewCursor Property
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearPan Class : SourceViewCursor Property
Gets or sets the cursor used while panning page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SourceViewCursor As Cursor
'Usage

Dim instance As ImGearPan
Dim value As Cursor

instance.SourceViewCursor = value

value = instance.SourceViewCursor
public Cursor SourceViewCursor {get; set;}
public: __property Cursor* get_SourceViewCursor();
public: __property void set_SourceViewCursor(
   Cursor* value
);
public:
property Cursor^ SourceViewCursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

System.Windows.Forms.Cursor class. Default value is System.Windows.Forms.Cursors.Hand.
Remarks
This property value is used in the ImGearPageView object that is assigned to the SourceView property during the dragging process.
Example
  • C#
igPan.Cursor = System.Windows.Forms.Cursors.Hand;
  • Visual Basic
igPan.Cursor = System.Windows.Forms.Cursors.Hand
See Also

Reference

ImGearPan Class
ImGearPan Members


%%PageItemTitle%%

ImGearRemoteFile Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearRemoteFile Class
Represents a file on a remote file system, such as a web server.
Object Model
ImGearRemoteFile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearRemoteFile
   Inherits ImGearFile
'Usage

Dim instance As ImGearRemoteFile
public class ImGearRemoteFile : ImGearFile
public __gc class ImGearRemoteFile : public ImGearFile
public ref class ImGearRemoteFile : public ImGearFile
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearFile
ImageGear.Windows.Forms.ImGearRemoteFile

See Also

Reference

ImGearRemoteFile Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearRemoteFile Class Members
Fields Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearRemoteFile Class

The following tables list the members exposed by ImGearRemoteFile.

Public Constructors
 | Name | Description
Public Constructor | ImGearRemoteFile Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Domain | Gets or sets domain of user account (part of credentials to access file).
Public Field | Password | Gets or sets password (part of credentials to access file).
Public Field | ProxyAddress | Gets or sets address of proxy server to use.
Public Field | ProxyPort | Gets or sets port number of proxy server to use.
Public Field | UseImGearWebStream | Gets or sets a value indicating whether or not to use ImGearWebStream (preferred for multi-page files).
Public Field | UseProxy | Gets or sets a value indicating whether or not to use a proxy server.
Public Field | UserName | Gets or sets username (part of credentials to access file).
Top
Public Methods
 | Name | Description
Public Method | CreateRequest | This method creates a .NET WebRequest using the parameters defined by the properties of the ImGearRemoteFile class object.
Public Method | CreateWebStream | This method creates an ImageGear.Formats.ImGearWebStream class using the parameters defined by the properties of the ImGearRemoteFile class object.
Public Method | Download | Downloads contents of requested file.
Public Method | Upload | Uploads local content to remote resource.
Top
See Also

Reference

ImGearRemoteFile Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearRemoteFile Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : ImGearRemoteFile Constructor
Overload List
Overload | Description
ImGearRemoteFile Constructor() | Initializes a new instance of the ImGearRemoteFile class.
ImGearRemoteFile Constructor(String) | Initializes a new instance of the ImGearRemoteFile class.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members


%%PageItemTitle%%

ImGearRemoteFile Constructor()

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class > ImGearRemoteFile Constructor : ImGearRemoteFile Constructor()
Initializes a new instance of the ImGearRemoteFile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearRemoteFile()
public ImGearRemoteFile()
public: ImGearRemoteFile();
public:
ImGearRemoteFile();

Return Value

The new instance of ImGearRemoteFile class.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
Overload List


%%PageItemTitle%%

ImGearRemoteFile Constructor(String)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class > ImGearRemoteFile Constructor : ImGearRemoteFile Constructor(String)
URL of remote resource to access.
Initializes a new instance of the ImGearRemoteFile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal url As String _
)
'Usage

Dim url As String

Dim instance As New ImGearRemoteFile(url)
public ImGearRemoteFile(
   string url
)
public: ImGearRemoteFile(
   string* url
)
public:
ImGearRemoteFile(
   String^ url
)

Parameters

url
URL of remote resource to access.

Return Value

The new instance of ImGearRemoteFile class.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearRemoteFile Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearRemoteFile Class

For a list of all members of this type, see ImGearRemoteFile members.

Public Methods
 | Name | Description
Public Method | CreateRequest | This method creates a .NET WebRequest using the parameters defined by the properties of the ImGearRemoteFile class object.
Public Method | CreateWebStream | This method creates an ImageGear.Formats.ImGearWebStream class using the parameters defined by the properties of the ImGearRemoteFile class object.
Public Method | Download | Downloads contents of requested file.
Public Method | Upload | Uploads local content to remote resource.
Top
See Also

Reference

ImGearRemoteFile Class
ImageGear.Windows.Forms Namespace


CreateRequest Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : CreateRequest Method
This method creates a .NET WebRequest using the parameters defined by the properties of the ImGearRemoteFile class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateRequest() As WebRequest
'Usage

Dim instance As ImGearRemoteFile
Dim value As WebRequest

value = instance.CreateRequest()
public WebRequest CreateRequest()
public: WebRequest* CreateRequest();
public:
WebRequest^ CreateRequest();

Return Value

System.Net.WebRequest class object.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
ImGearRemoteFile Class


CreateWebStream Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : CreateWebStream Method
This method creates an ImageGear.Formats.ImGearWebStream class using the parameters defined by the properties of the ImGearRemoteFile class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateWebStream() As Stream
'Usage

Dim instance As ImGearRemoteFile
Dim value As Stream

value = instance.CreateWebStream()
public Stream CreateWebStream()
public: Stream* CreateWebStream();
public:
Stream^ CreateWebStream();

Return Value

System.IO.Stream class object.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members


Download Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : Download Method
Downloads contents of requested file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Download() As MemoryStream
'Usage

Dim instance As ImGearRemoteFile
Dim value As MemoryStream

value = instance.Download()
public MemoryStream Download()
public: MemoryStream* Download();
public:
MemoryStream^ Download();

Return Value

System.IO.MemoryStream class.
Remarks
It uses its own WebRequest object to do this, so it's not necessary to create one with the CreateRequest method before calling this method.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members


Upload Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : Upload Method
Content to upload to the remote resource.
Uploads local content to remote resource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Upload( _
   ByVal localContent As Stream _
)
'Usage

Dim instance As ImGearRemoteFile
Dim localContent As Stream

instance.Upload(localContent)
public void Upload(
   Stream localContent
)
public: void Upload(
   Stream* localContent
)
public:
void Upload(
   Stream^ localContent
)

Parameters

localContent
Content to upload to the remote resource.
Remarks
It uses its own WebRequest object to do this, so it's not necessary to create one with the CreateRequest method before calling this method.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members


%%PageItemTitle%% $$Fields$$

ImGearRemoteFile Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearRemoteFile Class

For a list of all members of this type, see ImGearRemoteFile members.

Public Fields
 | Name | Description
Public Field | Domain | Gets or sets domain of user account (part of credentials to access file).
Public Field | Password | Gets or sets password (part of credentials to access file).
Public Field | ProxyAddress | Gets or sets address of proxy server to use.
Public Field | ProxyPort | Gets or sets port number of proxy server to use.
Public Field | UseImGearWebStream | Gets or sets a value indicating whether or not to use ImGearWebStream (preferred for multi-page files).
Public Field | UseProxy | Gets or sets a value indicating whether or not to use a proxy server.
Public Field | UserName | Gets or sets username (part of credentials to access file).
Top
See Also

Reference

ImGearRemoteFile Class
ImageGear.Windows.Forms Namespace


Domain Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : Domain Field
Gets or sets domain of user account (part of credentials to access file).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Domain As String
'Usage

Dim instance As ImGearRemoteFile
Dim value As String

value = instance.Domain

instance.Domain = value
public string Domain
public: string* Domain
public:
String^ Domain

Field Value

String value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
Password Field
UserName Field


Password Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : Password Field
Gets or sets password (part of credentials to access file).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Password As String
'Usage

Dim instance As ImGearRemoteFile
Dim value As String

value = instance.Password

instance.Password = value
public string Password
public: string* Password
public:
String^ Password

Field Value

String value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
UserName Field
Domain Field


ProxyAddress Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : ProxyAddress Field
Gets or sets address of proxy server to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ProxyAddress As String
'Usage

Dim instance As ImGearRemoteFile
Dim value As String

value = instance.ProxyAddress

instance.ProxyAddress = value
public string ProxyAddress
public: string* ProxyAddress
public:
String^ ProxyAddress

Field Value

String value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
ProxyPort Field
UseProxy Field


ProxyPort Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : ProxyPort Field
Gets or sets port number of proxy server to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ProxyPort As Integer
'Usage

Dim instance As ImGearRemoteFile
Dim value As Integer

value = instance.ProxyPort

instance.ProxyPort = value
public int ProxyPort
public: int ProxyPort
public:
int ProxyPort

Field Value

Integer value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
ProxyAddress Field
UseProxy Field


UseImGearWebStream Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : UseImGearWebStream Field
Gets or sets a value indicating whether or not to use ImGearWebStream (preferred for multi-page files).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseImGearWebStream As Boolean
'Usage

Dim instance As ImGearRemoteFile
Dim value As Boolean

value = instance.UseImGearWebStream

instance.UseImGearWebStream = value
public bool UseImGearWebStream
public: bool UseImGearWebStream
public:
bool UseImGearWebStream

Field Value

Boolean value.
Remarks
This property specifies whether or not to use ImageGear.Formats.ImGearWebStream class, a specialized stream for loading of images from the Internet. It is most useful for loading of multipage images, because it downloads only the necessary portions of the remote file.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
ImGearWebStream Class


UseProxy Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : UseProxy Field
Gets or sets a value indicating whether or not to use a proxy server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UseProxy As Boolean
'Usage

Dim instance As ImGearRemoteFile
Dim value As Boolean

value = instance.UseProxy

instance.UseProxy = value
public bool UseProxy
public: bool UseProxy
public:
bool UseProxy

Field Value

Boolean value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
ProxyAddress Field
ProxyPort Field


UserName Field

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearRemoteFile Class : UserName Field
Gets or sets username (part of credentials to access file).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public UserName As String
'Usage

Dim instance As ImGearRemoteFile
Dim value As String

value = instance.UserName

instance.UserName = value
public string UserName
public: string* UserName
public:
String^ UserName

Field Value

String value.
See Also

Reference

ImGearRemoteFile Class
ImGearRemoteFile Members
Password Field
Domain Field


%%PageItemTitle%%

ImGearSavingSelection Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSavingSelection Class
Identifies a file and format selected in a save file dialog.
Object Model
ImGearSavingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSavingSelection
'Usage

Dim instance As ImGearSavingSelection
public class ImGearSavingSelection
public __gc class ImGearSavingSelection
public ref class ImGearSavingSelection
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearSavingSelection

See Also

Reference

ImGearSavingSelection Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearSavingSelection Class Members
Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSavingSelection Class

The following tables list the members exposed by ImGearSavingSelection.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the save file dialog.
Public Field | Format | Gets format selected in the save file dialog.
Top
See Also

Reference

ImGearSavingSelection Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Fields$$

ImGearSavingSelection Class Fields

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSavingSelection Class

For a list of all members of this type, see ImGearSavingSelection members.

Public Fields
 | Name | Description
Public Field | File | Gets file selected in the save file dialog.
Public Field | Format | Gets format selected in the save file dialog.
Top
See Also

Reference

ImGearSavingSelection Class
ImageGear.Windows.Forms Namespace


File Field (ImGearSavingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearSavingSelection Class : File Field
Gets file selected in the save file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly File As ImGearFile
'Usage

Dim instance As ImGearSavingSelection
Dim value As ImGearFile

value = instance.File
public readonly ImGearFile File
public: readonly ImGearFile* File
public:
readonly ImGearFile^ File

Field Value

ImGearFile class.
See Also

Reference

ImGearSavingSelection Class
ImGearSavingSelection Members
ImGearFile Class


Format Field (ImGearSavingSelection)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearSavingSelection Class : Format Field
Gets format selected in the save file dialog.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Format As ImGearSavingFormats
'Usage

Dim instance As ImGearSavingSelection
Dim value As ImGearSavingFormats

value = instance.Format
public readonly ImGearSavingFormats Format
public: readonly ImGearSavingFormats Format
public:
readonly ImGearSavingFormats Format

Field Value

ImageGear.Formats.ImGearSavingFormats enumeration.
See Also

Reference

ImGearSavingSelection Class
ImGearSavingSelection Members
ImGearSavingFormats Enumeration


%%PageItemTitle%%

ImGearScrollBarIncrement Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearScrollBarIncrement Class
Settings for a scroll bar increment including the value of the increment and what type of value.
Object Model
ImGearScrollBarIncrement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearScrollBarIncrement
'Usage

Dim instance As ImGearScrollBarIncrement
public class ImGearScrollBarIncrement
public __gc class ImGearScrollBarIncrement
public ref class ImGearScrollBarIncrement
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearScrollBarIncrement

See Also

Reference

ImGearScrollBarIncrement Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearScrollBarIncrement Class Members
Properties Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearScrollBarIncrement Class

The following tables list the members exposed by ImGearScrollBarIncrement.

Public Constructors
 | Name | Description
Public Constructor | ImGearScrollBarIncrement Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the amount to scroll by.
Public Property | ValueType | Gets or sets whether the Value specifies an absolute or relative scroll amount.
Top
Public Methods
 | Name | Description
Public Method | GetScrollValue | Gets the scroll increment actual value depending on ValueType.
Top
See Also

Reference

ImGearScrollBarIncrement Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearScrollBarIncrement Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class : ImGearScrollBarIncrement Constructor
Overload List
Overload | Description
ImGearScrollBarIncrement Constructor() | Initializes a new instance of the ImGearScrollBarIncrement class.
ImGearScrollBarIncrement Constructor(Double,ImGearScrollBarIncrementType) | Initializes a new instance of the ImGearScrollBarIncrement class.
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members


%%PageItemTitle%%

ImGearScrollBarIncrement Constructor()

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class > ImGearScrollBarIncrement Constructor : ImGearScrollBarIncrement Constructor()
Initializes a new instance of the ImGearScrollBarIncrement class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearScrollBarIncrement()
public ImGearScrollBarIncrement()
public: ImGearScrollBarIncrement();
public:
ImGearScrollBarIncrement();
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members
Overload List


%%PageItemTitle%%

ImGearScrollBarIncrement Constructor(Double,ImGearScrollBarIncrementType)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class > ImGearScrollBarIncrement Constructor : ImGearScrollBarIncrement Constructor(Double,ImGearScrollBarIncrementType)
The amount to scroll by.
Whether the Value specifies an absolute or relative scroll amount.
Initializes a new instance of the ImGearScrollBarIncrement class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Double, _
   ByVal valueType As ImGearScrollBarIncrementType _
)
'Usage

Dim value As Double
Dim valueType As ImGearScrollBarIncrementType

Dim instance As New ImGearScrollBarIncrement(value, valueType)
public ImGearScrollBarIncrement(
   double value,
   ImGearScrollBarIncrementType valueType
)
public: ImGearScrollBarIncrement(
   double value,
   ImGearScrollBarIncrementType valueType
)
public:
ImGearScrollBarIncrement(
   double value,
   ImGearScrollBarIncrementType valueType
)

Parameters

value
The amount to scroll by.
valueType
Whether the Value specifies an absolute or relative scroll amount.
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members
Overload List


%%PageItemTitle%% $$Methods$$

ImGearScrollBarIncrement Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearScrollBarIncrement Class

For a list of all members of this type, see ImGearScrollBarIncrement members.

Public Methods
 | Name | Description
Public Method | GetScrollValue | Gets the scroll increment actual value depending on ValueType.
Top
See Also

Reference

ImGearScrollBarIncrement Class
ImageGear.Windows.Forms Namespace


GetScrollValue Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class : GetScrollValue Method
The current viewport size to use, if the ValueType is ImGearScrollBarIncrementType.Relative.
Gets the scroll increment actual value depending on ValueType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetScrollValue( _
   ByVal viewPortSize As Double _
) As Double
'Usage

Dim instance As ImGearScrollBarIncrement
Dim viewPortSize As Double
Dim value As Double

value = instance.GetScrollValue(viewPortSize)
public double GetScrollValue(
   double viewPortSize
)
public: double GetScrollValue(
   double viewPortSize
)
public:
double GetScrollValue(
   double viewPortSize
)

Parameters

viewPortSize
The current viewport size to use, if the ValueType is ImGearScrollBarIncrementType.Relative.

Return Value

The absolute amount to scroll by.
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members


%%PageItemTitle%% $$Properties$$

ImGearScrollBarIncrement Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearScrollBarIncrement Class

For a list of all members of this type, see ImGearScrollBarIncrement members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the amount to scroll by.
Public Property | ValueType | Gets or sets whether the Value specifies an absolute or relative scroll amount.
Top
See Also

Reference

ImGearScrollBarIncrement Class
ImageGear.Windows.Forms Namespace


Value Property (ImGearScrollBarIncrement)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class : Value Property
Gets or sets the amount to scroll by.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Double
'Usage

Dim instance As ImGearScrollBarIncrement
Dim value As Double

instance.Value = value

value = instance.Value
public double Value {get; set;}
public: __property double get_Value();
public: __property void set_Value(
   double value
);
public:
property double Value {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
Exact meaning of the value is determined by the ValueType property.
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members


ValueType Property (ImGearScrollBarIncrement)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearScrollBarIncrement Class : ValueType Property
Gets or sets whether the Value specifies an absolute or relative scroll amount.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValueType As ImGearScrollBarIncrementType
'Usage

Dim instance As ImGearScrollBarIncrement
Dim value As ImGearScrollBarIncrementType

instance.ValueType = value

value = instance.ValueType
public ImGearScrollBarIncrementType ValueType {get; set;}
public: __property ImGearScrollBarIncrementType get_ValueType();
public: __property void set_ValueType(
   ImGearScrollBarIncrementType value
);
public:
property ImGearScrollBarIncrementType ValueType {
   ImGearScrollBarIncrementType get();
   void set (    ImGearScrollBarIncrementType value);
}

Property Value

ImGearScrollBarIncrementType class object.
See Also

Reference

ImGearScrollBarIncrement Class
ImGearScrollBarIncrement Members


%%PageItemTitle%%

ImGearSpotColorsMissingBox Class
Members Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSpotColorsMissingBox Class
GUI dialog class for processing missing spot colors.
Object Model
ImGearSpotColorsMissingBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearSpotColorsMissingBox
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As ImGearSpotColorsMissingBox
public class ImGearSpotColorsMissingBox : System.Windows.Forms.Form
public __gc class ImGearSpotColorsMissingBox : public System.Windows.Forms.Form
public ref class ImGearSpotColorsMissingBox : public System.Windows.Forms.Form
Remarks
Pops up to define how to display the spot colors.
Example
  • C#
using (ImGearSpotColorsMissingBox dlg = new ImGearSpotColorsMissingBox(spotColorList))
{
    dlg.ShowDialog();
}
  • Visual Basic
Using dlg As New ImGearSpotColorsMissingBox(spotColorList)
    dlg.ShowDialog()
End Using
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.ImGearSpotColorsMissingBox

See Also

Reference

ImGearSpotColorsMissingBox Members
ImageGear.Windows.Forms Namespace
ImGearSpotChannelInfo Class


%%PageItemTitle%% $$Members$$

ImGearSpotColorsMissingBox Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSpotColorsMissingBox Class

The following tables list the members exposed by ImGearSpotColorsMissingBox.

Public Constructors
 | Name | Description
Public Constructor | ImGearSpotColorsMissingBox Constructor | Initializes a new instance of the ImGearSpotColorsMissingBox class.
Top
See Also

Reference

ImGearSpotColorsMissingBox Class
ImageGear.Windows.Forms Namespace
ImGearSpotChannelInfo Class


%%PageItemTitle%% $$Properties$$

ImGearSpotColorsMissingBox Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSpotColorsMissingBox Class

For a list of all members of this type, see ImGearSpotColorsMissingBox members.

See Also

Reference

ImGearSpotColorsMissingBox Class
ImageGear.Windows.Forms Namespace
ImGearSpotChannelInfo Class


%%PageItemTitle%%

ImGearSpotColorsMissingBox Constructor
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearSpotColorsMissingBox Class : ImGearSpotColorsMissingBox Constructor
Array of spot colors.
Initializes a new instance of the ImGearSpotColorsMissingBox class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal spotColors As ArrayList _
)
'Usage

Dim spotColors As ArrayList

Dim instance As New ImGearSpotColorsMissingBox(spotColors)
public ImGearSpotColorsMissingBox(
   ArrayList spotColors
)
public: ImGearSpotColorsMissingBox(
   ArrayList* spotColors
)
public:
ImGearSpotColorsMissingBox(
   ArrayList^ spotColors
)

Parameters

spotColors
Array of spot colors.

Return Value

An instance of ImGearSpotColorsMissingBox class GUI dialog.
Example
  • C#
using (ImGearSpotColorsMissingBox dlg = new ImGearSpotColorsMissingBox(spotColorList))
{
    dlg.ShowDialog();
}
  • Visual Basic
Using dlg As New ImGearSpotColorsMissingBox(spotColorList)
    dlg.ShowDialog()
End Using
See Also

Reference

ImGearSpotColorsMissingBox Class
ImGearSpotColorsMissingBox Members


%%PageItemTitle%% $$Methods$$

ImGearSpotColorsMissingBox Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSpotColorsMissingBox Class

For a list of all members of this type, see ImGearSpotColorsMissingBox members.

See Also

Reference

ImGearSpotColorsMissingBox Class
ImageGear.Windows.Forms Namespace
ImGearSpotChannelInfo Class


%%PageItemTitle%% $$Events$$

ImGearSpotColorsMissingBox Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearSpotColorsMissingBox Class

For a list of all members of this type, see ImGearSpotColorsMissingBox members.

See Also

Reference

ImGearSpotColorsMissingBox Class
ImageGear.Windows.Forms Namespace
ImGearSpotChannelInfo Class


Dispose Method (ImGearSpotColorsMissingBox)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearSpotColorsMissingBox Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearSpotColorsMissingBox Class
ImGearSpotColorsMissingBox Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearSpotColorsMissingBox Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearSpotColorsMissingBox
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearSpotColorsMissingBox Class
ImGearSpotColorsMissingBox Members
Overload List


%%PageItemTitle%%

ImGearWinForms Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearWinForms Class
Provides methods for using common dialogs and error handling infrastructure.
Object Model
ImGearWinForms ClassImGearPage ClassImGearLoadingSelection ClassImGearPage ClassImGearSavingSelection ClassImGearARTLoadingSelection ClassImGearARTSavingSelection ClassImGearLoadingSelection ClassImGearLoadingSelectionEx ClassImGearSavingSelection ClassImGearLoadingSelection ClassImGearSavingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearWinForms
'Usage

Dim instance As ImGearWinForms
public sealed class ImGearWinForms
public __gc __sealed class ImGearWinForms
public ref class ImGearWinForms sealed
Inheritance Hierarchy

System.Object
ImageGear.Windows.Forms.ImGearWinForms

See Also

Reference

ImGearWinForms Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

ImGearWinForms Class Members
Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearWinForms Class

The following tables list the members exposed by ImGearWinForms.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddWarning | Adds a warning to the list of warnings displayed by the warning window.
static (Shared in Visual Basic) | ClearWarnings | Clears the list of warnings displayed by the warning window.
static (Shared in Visual Basic) | LoadPage | Loads a page, using a file open dialog to prompt the user for the location of the page.
static (Shared in Visual Basic) | ManageFiltersControlParams | Overloaded. Shows dialog box with ability to modify filters behavior.
static (Shared in Visual Basic) | ManageMetadata | Overloaded. Shows dialog box with metadata tree.
static (Shared in Visual Basic) | PreflightReport | This method creates and displays a PDF preflight report dialog box.
static (Shared in Visual Basic) | RegisterExceptionHandler | Registers an exception handler for the entire application, used to display ImageGear error information.
static (Shared in Visual Basic) | SavePage | Save a page, using a file save dialog to prompt the user for the format and destination.
static (Shared in Visual Basic) | SelectFileToLoad | Shows dialog box allowing the user to select a local or remote file to load.
static (Shared in Visual Basic) | SelectFileToLoadWithAdjust | Shows dialog box allowing the user to select a local or remote file to load with adjustment dialgs for the image to be loaded.
static (Shared in Visual Basic) | SelectFileToSave | Overloaded. Shows dialog box allowing the user to select a format and destination to save to.
static (Shared in Visual Basic) | SelectLocalARTFileToLoad | Shows ART file open dialog with filtering for all known ART formats.
static (Shared in Visual Basic) | SelectLocalARTFileToSave | Shows ART file save dialog with filtering for all known ART formats.
static (Shared in Visual Basic) | SelectLocalFileToLoad | Shows dialog box allowing the user to select a local file to load.
static (Shared in Visual Basic) | SelectLocalFileToLoadEx | Shows a dialog box allowing the user to select a local file to load.
static (Shared in Visual Basic) | SelectLocalFileToSave | Overloaded. Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
static (Shared in Visual Basic) | SelectRemoteFileToLoad | Shows dialog box allowing the user to select a remote file to load.
static (Shared in Visual Basic) | SelectRemoteFileToSave | Shows dialog box allowing the user to select a format and remote destination to save to.
static (Shared in Visual Basic) | ShowAboutBox | Shows an About box with ImageGear version information.
static (Shared in Visual Basic) | ShowDocumentInfo | Shows a window with information about an ImageGear.Core.ImGearDocument class.
static (Shared in Visual Basic) | ShowExceptionInfo | Shows a window with information about an exception.
static (Shared in Visual Basic) | ShowFileInfo | Shows a window with information about a file.
static (Shared in Visual Basic) | ShowPageInfo | Shows a window with information about a page.
static (Shared in Visual Basic) | ShowWarningInfo | Shows a window with a list of ImageGear warnings that have been added using the AddWarning method.
static (Shared in Visual Basic) | UnRegisterExceptionHandler | Unregisters an exception handler for the entire application, used to display ImageGear error information.
Top
See Also

Reference

ImGearWinForms Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Methods$$

ImGearWinForms Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearWinForms Class

For a list of all members of this type, see ImGearWinForms members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddWarning | Adds a warning to the list of warnings displayed by the warning window.
static (Shared in Visual Basic) | ClearWarnings | Clears the list of warnings displayed by the warning window.
static (Shared in Visual Basic) | LoadPage | Loads a page, using a file open dialog to prompt the user for the location of the page.
static (Shared in Visual Basic) | ManageFiltersControlParams | Overloaded. Shows dialog box with ability to modify filters behavior.
static (Shared in Visual Basic) | ManageMetadata | Overloaded. Shows dialog box with metadata tree.
static (Shared in Visual Basic) | PreflightReport | This method creates and displays a PDF preflight report dialog box.
static (Shared in Visual Basic) | RegisterExceptionHandler | Registers an exception handler for the entire application, used to display ImageGear error information.
static (Shared in Visual Basic) | SavePage | Save a page, using a file save dialog to prompt the user for the format and destination.
static (Shared in Visual Basic) | SelectFileToLoad | Shows dialog box allowing the user to select a local or remote file to load.
static (Shared in Visual Basic) | SelectFileToLoadWithAdjust | Shows dialog box allowing the user to select a local or remote file to load with adjustment dialgs for the image to be loaded.
static (Shared in Visual Basic) | SelectFileToSave | Overloaded. Shows dialog box allowing the user to select a format and destination to save to.
static (Shared in Visual Basic) | SelectLocalARTFileToLoad | Shows ART file open dialog with filtering for all known ART formats.
static (Shared in Visual Basic) | SelectLocalARTFileToSave | Shows ART file save dialog with filtering for all known ART formats.
static (Shared in Visual Basic) | SelectLocalFileToLoad | Shows dialog box allowing the user to select a local file to load.
static (Shared in Visual Basic) | SelectLocalFileToLoadEx | Shows a dialog box allowing the user to select a local file to load.
static (Shared in Visual Basic) | SelectLocalFileToSave | Overloaded. Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
static (Shared in Visual Basic) | SelectRemoteFileToLoad | Shows dialog box allowing the user to select a remote file to load.
static (Shared in Visual Basic) | SelectRemoteFileToSave | Shows dialog box allowing the user to select a format and remote destination to save to.
static (Shared in Visual Basic) | ShowAboutBox | Shows an About box with ImageGear version information.
static (Shared in Visual Basic) | ShowDocumentInfo | Shows a window with information about an ImageGear.Core.ImGearDocument class.
static (Shared in Visual Basic) | ShowExceptionInfo | Shows a window with information about an exception.
static (Shared in Visual Basic) | ShowFileInfo | Shows a window with information about a file.
static (Shared in Visual Basic) | ShowPageInfo | Shows a window with information about a page.
static (Shared in Visual Basic) | ShowWarningInfo | Shows a window with a list of ImageGear warnings that have been added using the AddWarning method.
static (Shared in Visual Basic) | UnRegisterExceptionHandler | Unregisters an exception handler for the entire application, used to display ImageGear error information.
Top
See Also

Reference

ImGearWinForms Class
ImageGear.Windows.Forms Namespace


AddWarning Method (ImGearWinForms)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : AddWarning Method
Warning to add to the list of warnings.
Adds a warning to the list of warnings displayed by the warning window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub AddWarning( _
   ByVal warning As ImGearWarning _
)
'Usage

Dim warning As ImGearWarning

ImGearWinForms.AddWarning(warning)
public static void AddWarning(
   ImGearWarning warning
)
public: static void AddWarning(
   ImGearWarning* warning
)
public:
static void AddWarning(
   ImGearWarning^ warning
)

Parameters

warning
Warning to add to the list of warnings.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearWarning Class


ClearWarnings Method (ImGearWinForms)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ClearWarnings Method
Clears the list of warnings displayed by the warning window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ClearWarnings()
'Usage

ImGearWinForms.ClearWarnings()
public static void ClearWarnings()
public: static void ClearWarnings();
public:
static void ClearWarnings();
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


LoadPage Method (ImGearWinForms)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : LoadPage Method
Handle of window to use as parent for dialog box.
Loads a page, using a file open dialog to prompt the user for the location of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function LoadPage( _
   ByVal owner As IWin32Window _
) As ImGearPage
'Usage

Dim owner As IWin32Window
Dim value As ImGearPage

value = ImGearWinForms.LoadPage(owner)
public static ImGearPage LoadPage(
   IWin32Window owner
)
public: static ImGearPage* LoadPage(
   IWin32Window* owner
)
public:
static ImGearPage^ LoadPage(
   IWin32Window^ owner
)

Parameters

owner
Handle of window to use as parent for dialog box.

Return Value

ImageGear.Core.ImGearPage class.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearPage Class


ManageFiltersControlParams Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ManageFiltersControlParams Method
Shows dialog box with ability to modify filters behavior.
Overload List
Overload | Description
ManageFiltersControlParams(IWin32Window) | Shows dialog box with ability to modify filters behavior.
ManageFiltersControlParams(IWin32Window,ImGearFormats) | Shows dialog box with ability to modify filters behavior, with the specified filter selected.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


ManageFiltersControlParams(IWin32Window) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > ManageFiltersControlParams Method : ManageFiltersControlParams(IWin32Window) Method
Handle of window to use as parent for dialog box.
Shows dialog box with ability to modify filters behavior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ManageFiltersControlParams( _
   ByVal owner As IWin32Window _
)
'Usage

Dim owner As IWin32Window

ImGearWinForms.ManageFiltersControlParams(owner)
public static void ManageFiltersControlParams(
   IWin32Window owner
)
public: static void ManageFiltersControlParams(
   IWin32Window* owner
)
public:
static void ManageFiltersControlParams(
   IWin32Window^ owner
)

Parameters

owner
Handle of window to use as parent for dialog box.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List


ManageFiltersControlParams(IWin32Window,ImGearFormats) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > ManageFiltersControlParams Method : ManageFiltersControlParams(IWin32Window,ImGearFormats) Method
Handle of window to use as parent for dialog box.
Format to select upon opening the dialog box.
Shows dialog box with ability to modify filters behavior, with the specified filter selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ManageFiltersControlParams( _
   ByVal owner As IWin32Window, _
   ByVal formatToSelect As ImGearFormats _
)
'Usage

Dim owner As IWin32Window
Dim formatToSelect As ImGearFormats

ImGearWinForms.ManageFiltersControlParams(owner, formatToSelect)
public static void ManageFiltersControlParams(
   IWin32Window owner,
   ImGearFormats formatToSelect
)
public: static void ManageFiltersControlParams(
   IWin32Window* owner,
   ImGearFormats formatToSelect
)
public:
static void ManageFiltersControlParams(
   IWin32Window^ owner,
   ImGearFormats formatToSelect
)

Parameters

owner
Handle of window to use as parent for dialog box.
formatToSelect
Format to select upon opening the dialog box.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearFormats Enumeration


ManageMetadata Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ManageMetadata Method
Shows dialog box with metadata tree.
Overload List
Overload | Description
ManageMetadata(IWin32Window,ImGearMetadataHead) | Shows dialog box with metadata tree.
ManageMetadata(IWin32Window,ImGearMetadataHead,Font) | Shows dialog box with metadata tree.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


ManageMetadata(IWin32Window,ImGearMetadataHead) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > ManageMetadata Method : ManageMetadata(IWin32Window,ImGearMetadataHead) Method
Handle of window to use as parent for dialog box.
Metadata to display in dialog box.
Shows dialog box with metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ManageMetadata( _
   ByVal owner As IWin32Window, _
   ByVal metadata As ImGearMetadataHead _
)
'Usage

Dim owner As IWin32Window
Dim metadata As ImGearMetadataHead

ImGearWinForms.ManageMetadata(owner, metadata)
public static void ManageMetadata(
   IWin32Window owner,
   ImGearMetadataHead metadata
)
public: static void ManageMetadata(
   IWin32Window* owner,
   ImGearMetadataHead* metadata
)
public:
static void ManageMetadata(
   IWin32Window^ owner,
   ImGearMetadataHead^ metadata
)

Parameters

owner
Handle of window to use as parent for dialog box.
metadata
Metadata to display in dialog box.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearMetadataHead Class


ManageMetadata(IWin32Window,ImGearMetadataHead,Font) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > ManageMetadata Method : ManageMetadata(IWin32Window,ImGearMetadataHead,Font) Method
Handle of window to use as parent for dialog box.
Metadata to display in dialog box.
The font used to display metadata leaf. If the parameter is not null, dialog's text box control, which displays the data, will use the supplied font.
Shows dialog box with metadata tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ManageMetadata( _
   ByVal owner As IWin32Window, _
   ByVal metadata As ImGearMetadataHead, _
   ByVal dataDisplayFont As Font _
)
'Usage

Dim owner As IWin32Window
Dim metadata As ImGearMetadataHead
Dim dataDisplayFont As Font

ImGearWinForms.ManageMetadata(owner, metadata, dataDisplayFont)
public static void ManageMetadata(
   IWin32Window owner,
   ImGearMetadataHead metadata,
   Font dataDisplayFont
)
public: static void ManageMetadata(
   IWin32Window* owner,
   ImGearMetadataHead* metadata,
   Font* dataDisplayFont
)
public:
static void ManageMetadata(
   IWin32Window^ owner,
   ImGearMetadataHead^ metadata,
   Font^ dataDisplayFont
)

Parameters

owner
Handle of window to use as parent for dialog box.
metadata
Metadata to display in dialog box.
dataDisplayFont
The font used to display metadata leaf. If the parameter is not null, dialog's text box control, which displays the data, will use the supplied font.
Remarks
If the metadata can contain Unicode complex script text, text box's default font would not display it properly. In such case provide by dataDisplayFont some alternative font that could display such data.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearMetadataHead Class


PreflightReport Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : PreflightReport Method
Reference to the owner window.
Type of profile the report was created for.
Reference to PDF preflight report object.
This method creates and displays a PDF preflight report dialog box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub PreflightReport( _
   ByVal owner As IWin32Window, _
   ByVal profile As ImGearPDFPreflightProfile, _
   ByVal report As ImGearPDFPreflightReport _
)
'Usage

Dim owner As IWin32Window
Dim profile As ImGearPDFPreflightProfile
Dim report As ImGearPDFPreflightReport

ImGearWinForms.PreflightReport(owner, profile, report)
public static void PreflightReport(
   IWin32Window owner,
   ImGearPDFPreflightProfile profile,
   ImGearPDFPreflightReport report
)
public: static void PreflightReport(
   IWin32Window* owner,
   ImGearPDFPreflightProfile profile,
   ImGearPDFPreflightReport* report
)
public:
static void PreflightReport(
   IWin32Window^ owner,
   ImGearPDFPreflightProfile profile,
   ImGearPDFPreflightReport^ report
)

Parameters

owner
Reference to the owner window.
profile
Type of profile the report was created for.
report
Reference to PDF preflight report object.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearPDFPreflightReport Class
ImGearPDFPreflightProfile Enumeration


RegisterExceptionHandler Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : RegisterExceptionHandler Method
Registers an exception handler for the entire application, used to display ImageGear error information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterExceptionHandler()
'Usage

ImGearWinForms.RegisterExceptionHandler()
public static void RegisterExceptionHandler()
public: static void RegisterExceptionHandler();
public:
static void RegisterExceptionHandler();
Remarks
This exception handler can catch and display information for any type of exception that occurs, allowing the application to continue executing. This method must be called for every thread in the application for which exceptions are to be handled.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
UnRegisterExceptionHandler Method


SavePage Method (ImGearWinForms)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SavePage Method
Handle of window to use as parent for dialog box.
Page to save.
Save a page, using a file save dialog to prompt the user for the format and destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SavePage( _
   ByVal owner As IWin32Window, _
   ByVal page As ImGearPage _
) As Boolean
'Usage

Dim owner As IWin32Window
Dim page As ImGearPage
Dim value As Boolean

value = ImGearWinForms.SavePage(owner, page)
public static bool SavePage(
   IWin32Window owner,
   ImGearPage page
)
public: static bool SavePage(
   IWin32Window* owner,
   ImGearPage* page
)
public:
static bool SavePage(
   IWin32Window^ owner,
   ImGearPage^ page
)

Parameters

owner
Handle of window to use as parent for dialog box.
page
Page to save.

Return Value

True | Page was saved successfully.
False | Page was not saved because user clicked Cancel in dialog box.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearPage Class


SelectFileToLoad Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectFileToLoad Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Allow selecting remote files.
Shows dialog box allowing the user to select a local or remote file to load.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectFileToLoad( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal selectRemote As Boolean _
) As ImGearLoadingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim selectRemote As Boolean
Dim value As ImGearLoadingSelection

value = ImGearWinForms.SelectFileToLoad(owner, title, selectRemote)
public static ImGearLoadingSelection SelectFileToLoad(
   IWin32Window owner,
   string title,
   bool selectRemote
)
public: static ImGearLoadingSelection* SelectFileToLoad(
   IWin32Window* owner,
   string* title,
   bool selectRemote
)
public:
static ImGearLoadingSelection^ SelectFileToLoad(
   IWin32Window^ owner,
   String^ title,
   bool selectRemote
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
selectRemote
Allow selecting remote files.

Return Value

ImGearLoadingSelection class.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearLoadingSelection Class


SelectFileToLoadWithAdjust Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectFileToLoadWithAdjust Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Allow selecting remote files.
Shows dialog box allowing the user to select a local or remote file to load with adjustment dialgs for the image to be loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectFileToLoadWithAdjust( _
   ByVal owner As IWin32Window, _
   ByVal dialogTitle As String, _
   ByVal selectRemote As Boolean _
) As ImGearPage
'Usage

Dim owner As IWin32Window
Dim dialogTitle As String
Dim selectRemote As Boolean
Dim value As ImGearPage

value = ImGearWinForms.SelectFileToLoadWithAdjust(owner, dialogTitle, selectRemote)
public static ImGearPage SelectFileToLoadWithAdjust(
   IWin32Window owner,
   string dialogTitle,
   bool selectRemote
)
public: static ImGearPage* SelectFileToLoadWithAdjust(
   IWin32Window* owner,
   string* dialogTitle,
   bool selectRemote
)
public:
static ImGearPage^ SelectFileToLoadWithAdjust(
   IWin32Window^ owner,
   String^ dialogTitle,
   bool selectRemote
)

Parameters

owner
Handle of window to use as parent for dialog box.
dialogTitle
Window title to use for dialog box.
selectRemote
Allow selecting remote files.

Return Value

ImGearLoadingSelection class.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
SelectFileToLoad Method
ImGearLoadingSelection Class


SelectFileToSave Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectFileToSave Method
Shows dialog box allowing the user to select a format and destination to save to.
Overload List
Overload | Description
SelectFileToSave(IWin32Window,String,ImGearPage,Boolean) | Shows dialog box allowing the user to select a format and destination to save to.
SelectFileToSave(IWin32Window,String,ImGearPage,Boolean,ImGearRasterConversionModes) | Shows a dialog box allowing the user to select a format and destination using the raster conversion option to save a page to.
SelectFileToSave(IWin32Window,String,ImGearDocument) | Shows dialog box allowing the user to select a format and destination to save to.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


SelectFileToSave(IWin32Window,String,ImGearPage,Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectFileToSave Method : SelectFileToSave(IWin32Window,String,ImGearPage,Boolean) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Page to be saved (but not during this method call).
Allow selecting remote files.
Shows dialog box allowing the user to select a format and destination to save to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal page As ImGearPage, _
   ByVal selectRemote As Boolean _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim page As ImGearPage
Dim selectRemote As Boolean
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectFileToSave(owner, title, page, selectRemote)
public static ImGearSavingSelection SelectFileToSave(
   IWin32Window owner,
   string title,
   ImGearPage page,
   bool selectRemote
)
public: static ImGearSavingSelection* SelectFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearPage* page,
   bool selectRemote
)
public:
static ImGearSavingSelection^ SelectFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearPage^ page,
   bool selectRemote
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
page
Page to be saved (but not during this method call).
selectRemote
Allow selecting remote files.

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearPage Class
ImGearSavingSelection Class


SelectFileToSave(IWin32Window,String,ImGearPage,Boolean,ImGearRasterConversionModes) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectFileToSave Method : SelectFileToSave(IWin32Window,String,ImGearPage,Boolean,ImGearRasterConversionModes) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Page to be saved (but not during this method call).
Allow selecting remote files.
Ratster converter mode applicable for saving parameters.
Shows a dialog box allowing the user to select a format and destination using the raster conversion option to save a page to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal page As ImGearPage, _
   ByVal selectRemote As Boolean, _
   ByVal rasterConversionMode As ImGearRasterConversionModes _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim page As ImGearPage
Dim selectRemote As Boolean
Dim rasterConversionMode As ImGearRasterConversionModes
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectFileToSave(owner, title, page, selectRemote, rasterConversionMode)
public static ImGearSavingSelection SelectFileToSave(
   IWin32Window owner,
   string title,
   ImGearPage page,
   bool selectRemote,
   ImGearRasterConversionModes rasterConversionMode
)
public: static ImGearSavingSelection* SelectFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearPage* page,
   bool selectRemote,
   ImGearRasterConversionModes rasterConversionMode
)
public:
static ImGearSavingSelection^ SelectFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearPage^ page,
   bool selectRemote,
   ImGearRasterConversionModes rasterConversionMode
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
page
Page to be saved (but not during this method call).
selectRemote
Allow selecting remote files.
rasterConversionMode
Ratster converter mode applicable for saving parameters.

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearSavingSelection Class
ImGearRasterConversionModes Enumeration
ImGearPage Class


SelectFileToSave(IWin32Window,String,ImGearDocument) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectFileToSave Method : SelectFileToSave(IWin32Window,String,ImGearDocument) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Document to be saved (but not during this method call).
Shows dialog box allowing the user to select a format and destination to save to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal document As ImGearDocument _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim document As ImGearDocument
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectFileToSave(owner, title, document)
public static ImGearSavingSelection SelectFileToSave(
   IWin32Window owner,
   string title,
   ImGearDocument document
)
public: static ImGearSavingSelection* SelectFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearDocument* document
)
public:
static ImGearSavingSelection^ SelectFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearDocument^ document
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
document
Document to be saved (but not during this method call).

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearDocument Class
ImGearSavingSelection Class


SelectLocalARTFileToLoad Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectLocalARTFileToLoad Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Shows ART file open dialog with filtering for all known ART formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectLocalARTFileToLoad( _
   ByVal owner As IWin32Window, _
   ByVal dialogTitle As String _
) As ImGearARTLoadingSelection
'Usage

Dim owner As IWin32Window
Dim dialogTitle As String
Dim value As ImGearARTLoadingSelection

value = ImGearWinForms.SelectLocalARTFileToLoad(owner, dialogTitle)
public static ImGearARTLoadingSelection SelectLocalARTFileToLoad(
   IWin32Window owner,
   string dialogTitle
)
public: static ImGearARTLoadingSelection* SelectLocalARTFileToLoad(
   IWin32Window* owner,
   string* dialogTitle
)
public:
static ImGearARTLoadingSelection^ SelectLocalARTFileToLoad(
   IWin32Window^ owner,
   String^ dialogTitle
)

Parameters

owner
Handle of window to use as parent for dialog box.
dialogTitle
Window title to use for dialog box.

Return Value

ImGearARTLoadingSelection class object.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearARTLoadingSelection Class


SelectLocalARTFileToSave Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectLocalARTFileToSave Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Shows ART file save dialog with filtering for all known ART formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectLocalARTFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String _
) As ImGearARTSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim value As ImGearARTSavingSelection

value = ImGearWinForms.SelectLocalARTFileToSave(owner, title)
public static ImGearARTSavingSelection SelectLocalARTFileToSave(
   IWin32Window owner,
   string title
)
public: static ImGearARTSavingSelection* SelectLocalARTFileToSave(
   IWin32Window* owner,
   string* title
)
public:
static ImGearARTSavingSelection^ SelectLocalARTFileToSave(
   IWin32Window^ owner,
   String^ title
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.

Return Value

ImGearARTSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearARTSavingSelection Class


SelectLocalFileToLoad Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectLocalFileToLoad Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Shows dialog box allowing the user to select a local file to load.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectLocalFileToLoad( _
   ByVal owner As IWin32Window, _
   ByVal dialogTitle As String _
) As ImGearLoadingSelection
'Usage

Dim owner As IWin32Window
Dim dialogTitle As String
Dim value As ImGearLoadingSelection

value = ImGearWinForms.SelectLocalFileToLoad(owner, dialogTitle)
public static ImGearLoadingSelection SelectLocalFileToLoad(
   IWin32Window owner,
   string dialogTitle
)
public: static ImGearLoadingSelection* SelectLocalFileToLoad(
   IWin32Window* owner,
   string* dialogTitle
)
public:
static ImGearLoadingSelection^ SelectLocalFileToLoad(
   IWin32Window^ owner,
   String^ dialogTitle
)

Parameters

owner
Handle of window to use as parent for dialog box.
dialogTitle
Window title to use for dialog box.

Return Value

ImGearLoadingSelection class object.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearLoadingSelection Class


SelectLocalFileToLoadEx Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectLocalFileToLoadEx Method
Handle of window to use as parent for dialog box.
Shows a dialog box allowing the user to select a local file to load.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectLocalFileToLoadEx( _
   ByVal owner As IWin32Window _
) As ImGearLoadingSelectionEx
'Usage

Dim owner As IWin32Window
Dim value As ImGearLoadingSelectionEx

value = ImGearWinForms.SelectLocalFileToLoadEx(owner)
public static ImGearLoadingSelectionEx SelectLocalFileToLoadEx(
   IWin32Window owner
)
public: static ImGearLoadingSelectionEx* SelectLocalFileToLoadEx(
   IWin32Window* owner
)
public:
static ImGearLoadingSelectionEx^ SelectLocalFileToLoadEx(
   IWin32Window^ owner
)

Parameters

owner
Handle of window to use as parent for dialog box.

Return Value

ImGearLoadingSelectionEx class object.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection. Unlike the FileOpenDialog shown by SelectLocalFileToLoad method, this dialog gives the user the option to view an image preview and file/image information as well as the ability to select and preview a specific page from a multi page file.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearLoadingSelectionEx Class
SelectLocalFileToLoad Method


SelectLocalFileToSave Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectLocalFileToSave Method
Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
Overload List
Overload | Description
SelectLocalFileToSave(IWin32Window,String,ImGearPage,ImGearRasterConversionModes) | Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
SelectLocalFileToSave(IWin32Window,String,ImGearPage) | Shows dialog box allowing the user to select a format and local file to save to.
SelectLocalFileToSave(IWin32Window,String,ImGearDocument) | Shows dialog box allowing the user to select a format and local file to save to.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


SelectLocalFileToSave(IWin32Window,String,ImGearPage,ImGearRasterConversionModes) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectLocalFileToSave Method : SelectLocalFileToSave(IWin32Window,String,ImGearPage,ImGearRasterConversionModes) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Page to be saved (but not during this method call).
Ratster converter mode applicable for saving parameters.
Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectLocalFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal page As ImGearPage, _
   ByVal conversionMode As ImGearRasterConversionModes _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim page As ImGearPage
Dim conversionMode As ImGearRasterConversionModes
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectLocalFileToSave(owner, title, page, conversionMode)
public static ImGearSavingSelection SelectLocalFileToSave(
   IWin32Window owner,
   string title,
   ImGearPage page,
   ImGearRasterConversionModes conversionMode
)
public: static ImGearSavingSelection* SelectLocalFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearPage* page,
   ImGearRasterConversionModes conversionMode
)
public:
static ImGearSavingSelection^ SelectLocalFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearPage^ page,
   ImGearRasterConversionModes conversionMode
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
page
Page to be saved (but not during this method call).
conversionMode
Ratster converter mode applicable for saving parameters.

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearSavingSelection Class
ImGearRasterConversionModes Enumeration
ImGearPage Class


SelectLocalFileToSave(IWin32Window,String,ImGearPage) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectLocalFileToSave Method : SelectLocalFileToSave(IWin32Window,String,ImGearPage) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Page to be saved (but not during this method call).
Shows dialog box allowing the user to select a format and local file to save to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectLocalFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal page As ImGearPage _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim page As ImGearPage
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectLocalFileToSave(owner, title, page)
public static ImGearSavingSelection SelectLocalFileToSave(
   IWin32Window owner,
   string title,
   ImGearPage page
)
public: static ImGearSavingSelection* SelectLocalFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearPage* page
)
public:
static ImGearSavingSelection^ SelectLocalFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearPage^ page
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
page
Page to be saved (but not during this method call).

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearPage Class
ImGearSavingSelection Class


SelectLocalFileToSave(IWin32Window,String,ImGearDocument) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class > SelectLocalFileToSave Method : SelectLocalFileToSave(IWin32Window,String,ImGearDocument) Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Document to be saved (but not during this method call).
Shows dialog box allowing the user to select a format and local file to save to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SelectLocalFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal document As ImGearDocument _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim document As ImGearDocument
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectLocalFileToSave(owner, title, document)
public static ImGearSavingSelection SelectLocalFileToSave(
   IWin32Window owner,
   string title,
   ImGearDocument document
)
public: static ImGearSavingSelection* SelectLocalFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearDocument* document
)
public:
static ImGearSavingSelection^ SelectLocalFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearDocument^ document
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
document
Document to be saved (but not during this method call).

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
Overload List
ImGearDocument Class
ImGearSavingSelection Class


SelectRemoteFileToLoad Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectRemoteFileToLoad Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Shows dialog box allowing the user to select a remote file to load.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectRemoteFileToLoad( _
   ByVal owner As IWin32Window, _
   ByVal dialogTitle As String _
) As ImGearLoadingSelection
'Usage

Dim owner As IWin32Window
Dim dialogTitle As String
Dim value As ImGearLoadingSelection

value = ImGearWinForms.SelectRemoteFileToLoad(owner, dialogTitle)
public static ImGearLoadingSelection SelectRemoteFileToLoad(
   IWin32Window owner,
   string dialogTitle
)
public: static ImGearLoadingSelection* SelectRemoteFileToLoad(
   IWin32Window* owner,
   string* dialogTitle
)
public:
static ImGearLoadingSelection^ SelectRemoteFileToLoad(
   IWin32Window^ owner,
   String^ dialogTitle
)

Parameters

owner
Handle of window to use as parent for dialog box.
dialogTitle
Window title to use for dialog box.

Return Value

ImGearLoadingSelection class object.
Remarks
Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearLoadingSelection Class


SelectRemoteFileToSave Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : SelectRemoteFileToSave Method
Handle of window to use as parent for dialog box.
Window title to use for dialog box.
Page to be saved (but not actually saved in this method call).
Shows dialog box allowing the user to select a format and remote destination to save to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function SelectRemoteFileToSave( _
   ByVal owner As IWin32Window, _
   ByVal title As String, _
   ByVal page As ImGearPage _
) As ImGearSavingSelection
'Usage

Dim owner As IWin32Window
Dim title As String
Dim page As ImGearPage
Dim value As ImGearSavingSelection

value = ImGearWinForms.SelectRemoteFileToSave(owner, title, page)
public static ImGearSavingSelection SelectRemoteFileToSave(
   IWin32Window owner,
   string title,
   ImGearPage page
)
public: static ImGearSavingSelection* SelectRemoteFileToSave(
   IWin32Window* owner,
   string* title,
   ImGearPage* page
)
public:
static ImGearSavingSelection^ SelectRemoteFileToSave(
   IWin32Window^ owner,
   String^ title,
   ImGearPage^ page
)

Parameters

owner
Handle of window to use as parent for dialog box.
title
Window title to use for dialog box.
page
Page to be saved (but not actually saved in this method call).

Return Value

ImGearSavingSelection class object.
Remarks
Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearPage Class
ImGearSavingSelection Class


ShowAboutBox Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowAboutBox Method
Handle of window to use as parent for dialog box.
Name of sample (or application) to display in dialog box.
Shows an About box with ImageGear version information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowAboutBox( _
   ByVal owner As IWin32Window, _
   ByVal sampleName As String _
)
'Usage

Dim owner As IWin32Window
Dim sampleName As String

ImGearWinForms.ShowAboutBox(owner, sampleName)
public static void ShowAboutBox(
   IWin32Window owner,
   string sampleName
)
public: static void ShowAboutBox(
   IWin32Window* owner,
   string* sampleName
)
public:
static void ShowAboutBox(
   IWin32Window^ owner,
   String^ sampleName
)

Parameters

owner
Handle of window to use as parent for dialog box.
sampleName
Name of sample (or application) to display in dialog box.
Remarks
Method is meant to be used by ImageGear samples, but could also be used as part of an application.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


ShowDocumentInfo Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowDocumentInfo Method
Handle of window to use as parent for dialog box.
Document to show information about.
Shows a window with information about an ImageGear.Core.ImGearDocument class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowDocumentInfo( _
   ByVal owner As IWin32Window, _
   ByVal document As ImGearDocument _
)
'Usage

Dim owner As IWin32Window
Dim document As ImGearDocument

ImGearWinForms.ShowDocumentInfo(owner, document)
public static void ShowDocumentInfo(
   IWin32Window owner,
   ImGearDocument document
)
public: static void ShowDocumentInfo(
   IWin32Window* owner,
   ImGearDocument* document
)
public:
static void ShowDocumentInfo(
   IWin32Window^ owner,
   ImGearDocument^ document
)

Parameters

owner
Handle of window to use as parent for dialog box.
document
Document to show information about.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ShowPageInfo Method
ShowFileInfo Method
ImGearDocument Class


ShowExceptionInfo Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowExceptionInfo Method
Handle of window to use as parent for dialog box.
Exception to show information about.
Shows a window with information about an exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowExceptionInfo( _
   ByVal owner As IWin32Window, _
   ByVal exception As Exception _
)
'Usage

Dim owner As IWin32Window
Dim exception As Exception

ImGearWinForms.ShowExceptionInfo(owner, exception)
public static void ShowExceptionInfo(
   IWin32Window owner,
   Exception exception
)
public: static void ShowExceptionInfo(
   IWin32Window* owner,
   Exception* exception
)
public:
static void ShowExceptionInfo(
   IWin32Window^ owner,
   Exception^ exception
)

Parameters

owner
Handle of window to use as parent for dialog box.
exception
Exception to show information about.
Remarks
This method is typically called in the outermost catch block of a thread for which RegisterExceptionHandler was called. But, it can be used any time an exception occurs.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members


ShowFileInfo Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowFileInfo Method
Handle of window to use as parent for dialog box.
File to show information about.
Shows a window with information about a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowFileInfo( _
   ByVal owner As IWin32Window, _
   ByVal filePath As String _
)
'Usage

Dim owner As IWin32Window
Dim filePath As String

ImGearWinForms.ShowFileInfo(owner, filePath)
public static void ShowFileInfo(
   IWin32Window owner,
   string filePath
)
public: static void ShowFileInfo(
   IWin32Window* owner,
   string* filePath
)
public:
static void ShowFileInfo(
   IWin32Window^ owner,
   String^ filePath
)

Parameters

owner
Handle of window to use as parent for dialog box.
filePath
File to show information about.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ShowPageInfo Method
ShowDocumentInfo Method


ShowPageInfo Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowPageInfo Method
Handle of window to use as parent for dialog box.
Page to show information about.
Shows a window with information about a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowPageInfo( _
   ByVal owner As IWin32Window, _
   ByVal page As ImGearPage _
)
'Usage

Dim owner As IWin32Window
Dim page As ImGearPage

ImGearWinForms.ShowPageInfo(owner, page)
public static void ShowPageInfo(
   IWin32Window owner,
   ImGearPage page
)
public: static void ShowPageInfo(
   IWin32Window* owner,
   ImGearPage* page
)
public:
static void ShowPageInfo(
   IWin32Window^ owner,
   ImGearPage^ page
)

Parameters

owner
Handle of window to use as parent for dialog box.
page
Page to show information about.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
ImGearPage Class


ShowWarningInfo Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : ShowWarningInfo Method
Handle of window to use as parent for dialog box.
Shows a window with a list of ImageGear warnings that have been added using the AddWarning method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ShowWarningInfo( _
   ByVal owner As IWin32Window _
)
'Usage

Dim owner As IWin32Window

ImGearWinForms.ShowWarningInfo(owner)
public static void ShowWarningInfo(
   IWin32Window owner
)
public: static void ShowWarningInfo(
   IWin32Window* owner
)
public:
static void ShowWarningInfo(
   IWin32Window^ owner
)

Parameters

owner
Handle of window to use as parent for dialog box.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
AddWarning Method


UnRegisterExceptionHandler Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > ImGearWinForms Class : UnRegisterExceptionHandler Method
Unregisters an exception handler for the entire application, used to display ImageGear error information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub UnRegisterExceptionHandler()
'Usage

ImGearWinForms.UnRegisterExceptionHandler()
public static void UnRegisterExceptionHandler()
public: static void UnRegisterExceptionHandler();
public:
static void UnRegisterExceptionHandler();
Remarks
This method must only be called in a thread in which the RegisterExceptionHandler method was previously called.
See Also

Reference

ImGearWinForms Class
ImGearWinForms Members
RegisterExceptionHandler Method


%%PageItemTitle%%

LayerPropertiesBox Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : LayerPropertiesBox Class
GUI dialog for accessing and changing the image layer's properties.
Object Model
LayerPropertiesBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LayerPropertiesBox
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As LayerPropertiesBox
public class LayerPropertiesBox : System.Windows.Forms.Form
public __gc class LayerPropertiesBox : public System.Windows.Forms.Form
public ref class LayerPropertiesBox : public System.Windows.Forms.Form
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ImageGear.Windows.Forms.LayerPropertiesBox

See Also

Reference

LayerPropertiesBox Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Members$$

LayerPropertiesBox Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : LayerPropertiesBox Class

The following tables list the members exposed by LayerPropertiesBox.

Public Constructors
 | Name | Description
Public Constructor | LayerPropertiesBox Constructor | Initializes a new instance of the LayerPropertiesBox class.
Top
See Also

Reference

LayerPropertiesBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Properties$$

LayerPropertiesBox Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : LayerPropertiesBox Class

For a list of all members of this type, see LayerPropertiesBox members.

See Also

Reference

LayerPropertiesBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

LayerPropertiesBox Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > LayerPropertiesBox Class : LayerPropertiesBox Constructor
Reference to the layered page whose image layer is accessed.
Reference to the layer to edit.
Initializes a new instance of the LayerPropertiesBox class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal layeredPage As ImGearLayeredPage, _
   ByVal imageLayer As ImGearLayer _
)
'Usage

Dim layeredPage As ImGearLayeredPage
Dim imageLayer As ImGearLayer

Dim instance As New LayerPropertiesBox(layeredPage, imageLayer)
public LayerPropertiesBox(
   ImGearLayeredPage layeredPage,
   ImGearLayer imageLayer
)
public: LayerPropertiesBox(
   ImGearLayeredPage* layeredPage,
   ImGearLayer* imageLayer
)
public:
LayerPropertiesBox(
   ImGearLayeredPage^ layeredPage,
   ImGearLayer^ imageLayer
)

Parameters

layeredPage
Reference to the layered page whose image layer is accessed.
imageLayer
Reference to the layer to edit.
See Also

Reference

LayerPropertiesBox Class
LayerPropertiesBox Members
ImGearLayeredPage Class
ImGearLayer Class


%%PageItemTitle%% $$Methods$$

LayerPropertiesBox Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : LayerPropertiesBox Class

For a list of all members of this type, see LayerPropertiesBox members.

See Also

Reference

LayerPropertiesBox Class
ImageGear.Windows.Forms Namespace


%%PageItemTitle%% $$Events$$

LayerPropertiesBox Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : LayerPropertiesBox Class

For a list of all members of this type, see LayerPropertiesBox members.

See Also

Reference

LayerPropertiesBox Class
ImageGear.Windows.Forms Namespace


Dispose Method (LayerPropertiesBox)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > LayerPropertiesBox Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

LayerPropertiesBox Class
LayerPropertiesBox Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace > LayerPropertiesBox Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As LayerPropertiesBox
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

LayerPropertiesBox Class
LayerPropertiesBox Members
Overload List


%%PageItemTitle%%

ImGearColorProfileActivationMode Enumeration

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearColorProfileActivationMode Enumeration
Specifies color profile activation modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearColorProfileActivationMode
   Inherits System.Enum
'Usage

Dim instance As ImGearColorProfileActivationMode
public enum ImGearColorProfileActivationMode : System.Enum
__value public enum ImGearColorProfileActivationMode : public System.Enum
public enum class ImGearColorProfileActivationMode : public System.Enum
Members
Member | Value | Description
Disable | 1 | ImageGear samples start with color profile support being disabled, and does not check image color space and color profiles after image loading.
Enable | 2 | ImageGear samples start with color profile support being enabled.
Undefined | 0 | ImageGear samples start with color profile support being disabled. As soon as an image that does not follow the standard RGB color space is loaded, the sample opens a dialog suggesting to enable color profiles.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Forms.ImGearColorProfileActivationMode

See Also

Reference

ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearMagnifierShapeType Enumeration

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearMagnifierShapeType Enumeration
Specifies the shape type of magnifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMagnifierShapeType
   Inherits System.Enum
'Usage

Dim instance As ImGearMagnifierShapeType
public enum ImGearMagnifierShapeType : System.Enum
__value public enum ImGearMagnifierShapeType : public System.Enum
public enum class ImGearMagnifierShapeType : public System.Enum
Members
Member | Value | Description
Ellipse | 1 | Ellipse magnifier.
Rectangle | 0 | Rectangle magnifier.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Forms.ImGearMagnifierShapeType

See Also

Reference

ImageGear.Windows.Forms Namespace
ImGearMagnifier Class


%%PageItemTitle%%

ImGearScrollBarIncrementType Enumeration

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearScrollBarIncrementType Enumeration
Types of scroll bar increment values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearScrollBarIncrementType
   Inherits System.Enum
'Usage

Dim instance As ImGearScrollBarIncrementType
public enum ImGearScrollBarIncrementType : System.Enum
__value public enum ImGearScrollBarIncrementType : public System.Enum
public enum class ImGearScrollBarIncrementType : public System.Enum
Members
Member | Value | Description
Absolute | 0 | Value is an absolute measurement.
Relative | 1 | Value is relative to the current viewport size.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Forms.ImGearScrollBarIncrementType

See Also

Reference

ImageGear.Windows.Forms Namespace
ValueType Property


%%PageItemTitle%%

ImGearPageView.AfterDraw Delegate

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView.AfterDraw Delegate
Graphics object used for painting.
Delegate for method registered with RegisterAfterDraw method, to be called after default painting has been performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearPageView.AfterDraw( _
   ByVal graphics As Graphics _
)
'Usage

Dim instance As New ImGearPageView.AfterDraw(AddressOf HandlerMethod)
public delegate void ImGearPageView.AfterDraw(
   Graphics graphics
)
public: __gc __delegate void ImGearPageView.AfterDraw(
   Graphics* graphics
)
public delegate void ImGearPageView.AfterDraw(
   Graphics^ graphics
)

Parameters

graphics
Graphics object used for painting.
See Also

Reference

ImGearPageView.AfterDraw Members
ImageGear.Windows.Forms Namespace


%%PageItemTitle%%

ImGearPageView.DelegatePageCalculate Delegate

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms Namespace : ImGearPageView.DelegatePageCalculate Delegate
In/out parameter. ImGearScrollInfo object with current attributes for vertical and horizontal scrollbars passed by reference.
This delegate, if registered, is automatically called from the ImGearPageView class when the user presses Page Up or Page Down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearPageView.DelegatePageCalculate( _
   ByRef scrollInfo As ImGearScrollInfo _
)
'Usage

Dim instance As New ImGearPageView.DelegatePageCalculate(AddressOf HandlerMethod)
public delegate void ImGearPageView.DelegatePageCalculate(
   ref ImGearScrollInfo scrollInfo
)
public: __gc __delegate void ImGearPageView.DelegatePageCalculate(
   ref ImGearScrollInfo scrollInfo
)
public delegate void ImGearPageView.DelegatePageCalculate(
   ImGearScrollInfo% scrollInfo
)

Parameters

scrollInfo
In/out parameter. ImGearScrollInfo object with current attributes for vertical and horizontal scrollbars passed by reference.
Remarks
This increment is not standardized, and so its calculation is left in the hands of the user.
See Also

Reference

ImGearPageView.DelegatePageCalculate Members
ImageGear.Windows.Forms Namespace
ImGearScrollInfo Structure


ImageGear.Windows.Forms.Thumbnails Namespace
Inheritance Hierarchy
ImageGear22.Windows.Forms Assembly : ImageGear.Windows.Forms.Thumbnails Namespace

This namespace provides GUI Thumbnail control API.

Classes
 | Class | Description
Class | ImGearThumbnailAfterLoadEventArgs | This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
Class | ImGearThumbnailBeforeLoadEventArgs | Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
Class | ImGearThumbnailCtl | Controls operations with thumbnail items.
Class | ImGearThumbnailItem | Represents one of the thumbnail items displayed on the thumbnail browser.
Class | ImGearThumbnailItemEventArgs | Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.
Interfaces
 | Interface | Description
Interface | IImGearThumbnailCtl | Interface for operations with thumbnail items.
Interface | IImGearThumbnailItem | Provides interface for thumbnail items.
Delegates
 | Delegate | Description
Delegate | ImGearThumbnailAfterLoadEventHandler | Used for declaring ItemAfterLoad event.
Delegate | ImGearThumbnailBeforeLoadEventHandler | Used for declaring ItemBeforeLoad event.
Delegate | ImGearThumbnailItemEventHandler | Used for declaring ImGearThumbnailCtl.ItemAfterCreate, ImGearThumbnailCtl.ItemBeforeDelete, ImGearThumbnailCtl.ItemClicked and ImGearThumbnailCtl.ItemDoubleClicked events.
Enumerations
 | Enumeration | Description
Enumeration | ImGearDragDropOptions | Specifies drag and drop actions that are allowed in the thumbnail control.
Enumeration | ImGearSortOptions | Specifies what sorting is used when a new item is added.
See Also

Reference

ImageGear22.Windows.Forms Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Windows.Forms.Thumbnails Namespace Inheritance Hierarchy
ImageGear22.Windows.Forms Assembly : ImageGear.Windows.Forms.Thumbnails Namespace
Inheritance Hierarchy
System.Object
System.EventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailAfterLoadEventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailBeforeLoadEventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl
System.Windows.Forms.Panel
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem
See Also

Reference

ImageGear22.Windows.Forms Assembly


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventArgs Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailAfterLoadEventArgs Class
This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
Object Model
ImGearThumbnailAfterLoadEventArgs ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailAfterLoadEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
public class ImGearThumbnailAfterLoadEventArgs : System.EventArgs
public __gc class ImGearThumbnailAfterLoadEventArgs : public System.EventArgs
public ref class ImGearThumbnailAfterLoadEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailAfterLoadEventArgs

See Also

Reference

ImGearThumbnailAfterLoadEventArgs Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailAfterLoadEventArgs Class Members
Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailAfterLoadEventArgs Class

The following tables list the members exposed by ImGearThumbnailAfterLoadEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailAfterLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailAfterLoadEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Top
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventArgs Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailAfterLoadEventArgs Class : ImGearThumbnailAfterLoadEventArgs Constructor
ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Flag indicating whether or not to load thumbnail into a control.
Initializes a new instance of the ImGearThumbnailAfterLoadEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage, _
   ByVal skip As Boolean _
)
'Usage

Dim page As ImGearPage
Dim skip As Boolean

Dim instance As New ImGearThumbnailAfterLoadEventArgs(page, skip)
public ImGearThumbnailAfterLoadEventArgs(
   ImGearPage page,
   bool skip
)
public: ImGearThumbnailAfterLoadEventArgs(
   ImGearPage* page,
   bool skip
)
public:
ImGearThumbnailAfterLoadEventArgs(
   ImGearPage^ page,
   bool skip
)

Parameters

page
ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
skip
Flag indicating whether or not to load thumbnail into a control.

Return Value

New instance of ImGearThumbnailAfterLoadEventArgs class.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members
ImGearPage Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailAfterLoadEventArgs Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailAfterLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailAfterLoadEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Top
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


Page Property (ImGearThumbnailAfterLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailAfterLoadEventArgs Class : Page Property
Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members
ImGearPage Class


Skip Property (ImGearThumbnailAfterLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailAfterLoadEventArgs Class : Skip Property
Gets or sets a value indicating whether or not to load thumbnail into a control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Skip As Boolean
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
Dim value As Boolean

instance.Skip = value

value = instance.Skip
public bool Skip {get; set;}
public: __property bool get_Skip();
public: __property void set_Skip(
   bool value
);
public:
property bool Skip {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Client should set this to true if there is no need to load thumbnail into a control.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventArgs Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailBeforeLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
Object Model
ImGearThumbnailBeforeLoadEventArgs ClassImGearPage ClassImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailBeforeLoadEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
public class ImGearThumbnailBeforeLoadEventArgs : System.EventArgs
public __gc class ImGearThumbnailBeforeLoadEventArgs : public System.EventArgs
public ref class ImGearThumbnailBeforeLoadEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailBeforeLoadEventArgs

See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailBeforeLoadEventArgs Class Members
Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailBeforeLoadEventArgs Class

The following tables list the members exposed by ImGearThumbnailBeforeLoadEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailBeforeLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailBeforeLoadEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Public Property | PageNumber | Gets page number of the currently loaded thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Public Property | Source | Gets path and format of the currently loaded thumbnail.
Top
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventArgs Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailBeforeLoadEventArgs Class : ImGearThumbnailBeforeLoadEventArgs Constructor
Path and format of the currently loaded thumbnail.
ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Page number of the currently loaded thumbnail.
Flag indicating whether or not to load thumbnail into a control.
Initializes a new instance of the ImGearThumbnailBeforeLoadEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As ImGearLoadingSelection, _
   ByVal page As ImGearPage, _
   ByVal pageNumber As Integer, _
   ByVal skip As Boolean _
)
'Usage

Dim source As ImGearLoadingSelection
Dim page As ImGearPage
Dim pageNumber As Integer
Dim skip As Boolean

Dim instance As New ImGearThumbnailBeforeLoadEventArgs(source, page, pageNumber, skip)
public ImGearThumbnailBeforeLoadEventArgs(
   ImGearLoadingSelection source,
   ImGearPage page,
   int pageNumber,
   bool skip
)
public: ImGearThumbnailBeforeLoadEventArgs(
   ImGearLoadingSelection* source,
   ImGearPage* page,
   int pageNumber,
   bool skip
)
public:
ImGearThumbnailBeforeLoadEventArgs(
   ImGearLoadingSelection^ source,
   ImGearPage^ page,
   int pageNumber,
   bool skip
)

Parameters

source
Path and format of the currently loaded thumbnail.
page
ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
pageNumber
Page number of the currently loaded thumbnail.
skip
Flag indicating whether or not to load thumbnail into a control.

Return Value

New instance of ImGearThumbnailBeforeLoadEventArgs class.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearPage Class
ImGearLoadingSelection Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailBeforeLoadEventArgs Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailBeforeLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailBeforeLoadEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Public Property | PageNumber | Gets page number of the currently loaded thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Public Property | Source | Gets path and format of the currently loaded thumbnail.
Top
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


Page Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailBeforeLoadEventArgs Class : Page Property
Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearPage Class


PageNumber Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailBeforeLoadEventArgs Class : PageNumber Property
Gets page number of the currently loaded thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members


Skip Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailBeforeLoadEventArgs Class : Skip Property
Gets or sets a value indicating whether or not to load thumbnail into a control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Skip As Boolean
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As Boolean

instance.Skip = value

value = instance.Skip
public bool Skip {get; set;}
public: __property bool get_Skip();
public: __property void set_Skip(
   bool value
);
public:
property bool Skip {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Client should set this to true if there is no need to load thumbnail into a control.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members


Source Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailBeforeLoadEventArgs Class : Source Property
Gets path and format of the currently loaded thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Source As ImGearLoadingSelection
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As ImGearLoadingSelection

value = instance.Source
public ImGearLoadingSelection Source {get;}
public: __property ImGearLoadingSelection* get_Source();
public:
property ImGearLoadingSelection^ Source {
   ImGearLoadingSelection^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearLoadingSelection class.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearLoadingSelection Class


%%PageItemTitle%%

ImGearThumbnailCtl Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailCtl Class
Controls operations with thumbnail items.
Object Model
ImGearThumbnailCtl ClassImGearThumbnailItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailCtl
   Inherits System.Windows.Forms.UserControl
   Implements IImGearThumbnailCtl
'Usage

Dim instance As ImGearThumbnailCtl
public class ImGearThumbnailCtl : System.Windows.Forms.UserControl, IImGearThumbnailCtl
public __gc class ImGearThumbnailCtl : public System.Windows.Forms.UserControl, IImGearThumbnailCtl
public ref class ImGearThumbnailCtl : public System.Windows.Forms.UserControl, IImGearThumbnailCtl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl

See Also

Reference

ImGearThumbnailCtl Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailCtl Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailCtl Class

The following tables list the members exposed by ImGearThumbnailCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailCtl Constructor | Initializes a new instance of the ImGearThumbnailCtl class.
Top
Public Properties
 | Name | Description
Public Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Public Property | AutoFocus | Gets or sets a value indicating whether to automatically grab focus.
Public Property | AutoScroll | Overridden. Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Public Property | BackColor | Overridden. Gets or sets the background color of the Thumbnail control.
Public Property | BorderStyle | Gets or sets border style of the Thumbnail control.
Public Property | BorderWidth | Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Public Property | Count | Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Public Property | DragDropOptions | Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Public Property | Flat | Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Public Property | Font | Overridden. Gets or sets the font used for rendering titles under the thumbnail items.
Public Property | ForeColor | Overridden. Gets or sets color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.
Public Property | HighlightBackColor | Gets or sets the background color used for the Title of highlighted Thumbnail items.
Public Property | HighlightForeColor | Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Public Property | Interior | Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Public Property | ItemHeight | Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Public Property | ItemWidth | Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Public Property | LeftMargin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Public Property | MultiSelect | Gets or sets a value indicating whether multiple selection is allowed.
Public Property | RightToLeft | Overridden. Gets or sets a value indicating whether text appears right to left. Inerhited property not supported by thumbnail control.
Public Property | SelectionBackColor | Gets or sets background color used for the Title of selected Thumbnail items.
Public Property | SelectionForeColor | Gets or sets foreground color used for the Title of selected Thumbnail items.
Public Property | ShadowWidth | Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Public Property | ShowMagnify | Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Public Property | ShowTitles | Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Public Property | Sort | Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Public Property | SortComparer | Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Public Property | TitleFont | Gets or sets a font for items.
Public Property | TitleHeight | Gets or sets height for the item title.
Public Property | TopMargin | Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Public Property | ZoomFactor | Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Top
Public Methods
 | Name | Description
Public Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Public Method | DeleteItem | Removes specified item from the Thumbnail control.
Public Method | DirectoryAppend | Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Public Method | DocumentAppend | Appends ImageGear document to the Thumbnail control.
Public Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Public Method | Item | Returns ImGearThumbnailItem object by given index.
Public Method | PageAppend | Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Public Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Public Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
Public Events
 | Name | Description
Public Event | ItemAfterCreate | Called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemAfterLoad | Called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemBeforeDelete | Called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Public Event | ItemBeforeLoad | Called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImageGear.Core.ImGearPage class object.
Public Event | ItemClicked | Called to indicate that the user clicked somewhere within the thumbnail control.
Public Event | ItemDoubleClicked | Called to indicate that the user double-clicked somewhere within the thumbnail control.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearThumbnailCtl Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ImGearThumbnailCtl Constructor
Initializes a new instance of the ImGearThumbnailCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailCtl()
public ImGearThumbnailCtl()
public: ImGearThumbnailCtl();
public:
ImGearThumbnailCtl();

Return Value

New instance of ImGearThumbnailCtl class.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailCtl Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Methods
 | Name | Description
Public Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Public Method | DeleteItem | Removes specified item from the Thumbnail control.
Public Method | DirectoryAppend | Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Public Method | DocumentAppend | Appends ImageGear document to the Thumbnail control.
Public Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Public Method | Item | Returns ImGearThumbnailItem object by given index.
Public Method | PageAppend | Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Public Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Public Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.Windows.Forms.Thumbnails Namespace


DeleteAllItems Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : DeleteAllItems Method
Removes all the items from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DeleteAllItems()
'Usage

Dim instance As ImGearThumbnailCtl

instance.DeleteAllItems()
[Description()]
public void DeleteAllItems()
[Description()]
public: void DeleteAllItems();
[Description()]
public:
void DeleteAllItems();
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DeleteItem Method (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : DeleteItem Method
Item to be removed.
Removes specified item from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DeleteItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.DeleteItem(item)
[Description()]
public void DeleteItem(
   ImGearThumbnailItem item
)
[Description()]
public: void DeleteItem(
   ImGearThumbnailItem* item
)
[Description()]
public:
void DeleteItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be removed.
Example
  • C#
// Delete the first selected item found.
for (int index = 0; index < igThumbnailCtl.Count; index++)
{
    ImGearThumbnailItem igThumbnailItem = igThumbnailCtl.Item(index);
    if (igThumbnailItem.Selected)
    {
        igThumbnailCtl.DeleteItem(igThumbnailItem);
        break;
    }
}
  • Visual Basic
' Delete the first selected item found.
For index As Integer = 0 To igThumbnailCtl.Count - 1
    Dim igThumbnailItem As ImGearThumbnailItem = igThumbnailCtl.Item(index)
    If igThumbnailItem.Selected Then
        igThumbnailCtl.DeleteItem(igThumbnailItem)
        Exit For
    End If
Next
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


DirectoryAppend Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : DirectoryAppend Method
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DirectoryAppend( _
   ByVal directory As String, _
   ByVal filters As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim directory As String
Dim filters As String

instance.DirectoryAppend(directory, filters)
[Description()]
public void DirectoryAppend(
   string directory,
   string filters
)
[Description()]
public: void DirectoryAppend(
   string* directory,
   string* filters
)
[Description()]
public:
void DirectoryAppend(
   String^ directory,
   String^ filters
)

Parameters

directory
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
filters
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Dispose Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Dispose Method
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Overload List
Overload | Description
Dispose(Boolean) | Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Dispose(Boolean) Method

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class > Dispose Method : Dispose(Boolean) Method
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged resources used by the control and its child controls and optionally releases the managed resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Set true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
Overload List


DocumentAppend Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : DocumentAppend Method
Document to be appended.
Title for new items.
Appends ImageGear document to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DocumentAppend( _
   ByVal documentToAppend As ImGearDocument, _
   ByVal name As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim documentToAppend As ImGearDocument
Dim name As String

instance.DocumentAppend(documentToAppend, name)
[Description()]
public void DocumentAppend(
   ImGearDocument documentToAppend,
   string name
)
[Description()]
public: void DocumentAppend(
   ImGearDocument* documentToAppend,
   string* name
)
[Description()]
public:
void DocumentAppend(
   ImGearDocument^ documentToAppend,
   String^ name
)

Parameters

documentToAppend
Document to be appended.
name
Title for new items.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearDocument Class


FileAppend Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : FileAppend Method
Selection specifying a path and a type of the file to be appended.
Appends a file specified by selection to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub FileAppend( _
   ByVal loadSelection As ImGearLoadingSelection _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim loadSelection As ImGearLoadingSelection

instance.FileAppend(loadSelection)
[Description()]
public void FileAppend(
   ImGearLoadingSelection loadSelection
)
[Description()]
public: void FileAppend(
   ImGearLoadingSelection* loadSelection
)
[Description()]
public:
void FileAppend(
   ImGearLoadingSelection^ loadSelection
)

Parameters

loadSelection
Selection specifying a path and a type of the file to be appended.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearLoadingSelection Class


Item Method (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Item Method
Index of the requested thumbnail.
Returns ImGearThumbnailItem object by given index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Function Item( _
   ByVal index As Integer _
) As ImGearThumbnailItem
'Usage

Dim instance As ImGearThumbnailCtl
Dim index As Integer
Dim value As ImGearThumbnailItem

value = instance.Item(index)
[Description()]
public ImGearThumbnailItem Item(
   int index
)
[Description()]
public: ImGearThumbnailItem* Item(
   int index
)
[Description()]
public:
ImGearThumbnailItem^ Item(
   int index
)

Parameters

index
Index of the requested thumbnail.

Return Value

ImGearThumbnailItem class object.
Example
  • C#
// Delete the first selected item found.
for (int index = 0; index < igThumbnailCtl.Count; index++)
{
    ImGearThumbnailItem igThumbnailItem = igThumbnailCtl.Item(index);
    if (igThumbnailItem.Selected)
    {
        igThumbnailCtl.DeleteItem(igThumbnailItem);
        break;
    }
}
  • Visual Basic
' Delete the first selected item found.
For index As Integer = 0 To igThumbnailCtl.Count - 1
    Dim igThumbnailItem As ImGearThumbnailItem = igThumbnailCtl.Item(index)
    If igThumbnailItem.Selected Then
        igThumbnailCtl.DeleteItem(igThumbnailItem)
        Exit For
    End If
Next
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


PageAppend Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : PageAppend Method
ImageGear.Core.ImGearPage class object to be appended.
Title for new item.
Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub PageAppend( _
   ByVal pageToAppend As ImGearPage, _
   ByVal name As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim pageToAppend As ImGearPage
Dim name As String

instance.PageAppend(pageToAppend, name)
[Description()]
public void PageAppend(
   ImGearPage pageToAppend,
   string name
)
[Description()]
public: void PageAppend(
   ImGearPage* pageToAppend,
   string* name
)
[Description()]
public:
void PageAppend(
   ImGearPage^ pageToAppend,
   String^ name
)

Parameters

pageToAppend
ImageGear.Core.ImGearPage class object to be appended.
name
Title for new item.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearPage Class


ReloadAll Method (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub ReloadAll()
'Usage

Dim instance As ImGearThumbnailCtl

instance.ReloadAll()
[Description()]
public void ReloadAll()
[Description()]
public: void ReloadAll();
[Description()]
public:
void ReloadAll();
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ReloadItem Method (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ReloadItem Method
Item to be reloaded.
Reloads thumbnail picture in the specified thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub ReloadItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.ReloadItem(item)
[Description()]
public void ReloadItem(
   ImGearThumbnailItem item
)
[Description()]
public: void ReloadItem(
   ImGearThumbnailItem* item
)
[Description()]
public:
void ReloadItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be reloaded.
Example
  • C#
// Reload all selected thumbnail items.
for (int index = 0; index < igThumbnailCtl.Count; index++)
{
    ImGearThumbnailItem igThumbnailItem = igThumbnailCtl.Item(index);
    if (igThumbnailItem.Selected)
    {
        igThumbnailCtl.ReloadItem(igThumbnailItem);
    }
}
  • Visual Basic
' Reload all selected thumbnail items.
For index As Integer = 0 To igThumbnailCtl.Count - 1
    Dim igThumbnailItem As ImGearThumbnailItem = igThumbnailCtl.Item(index)
    If igThumbnailItem.Selected Then
        igThumbnailCtl.ReloadItem(igThumbnailItem)
    End If
Next
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailCtl Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Properties
 | Name | Description
Public Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Public Property | AutoFocus | Gets or sets a value indicating whether to automatically grab focus.
Public Property | AutoScroll | Overridden. Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Public Property | BackColor | Overridden. Gets or sets the background color of the Thumbnail control.
Public Property | BorderStyle | Gets or sets border style of the Thumbnail control.
Public Property | BorderWidth | Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Public Property | Count | Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Public Property | DragDropOptions | Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Public Property | Flat | Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Public Property | Font | Overridden. Gets or sets the font used for rendering titles under the thumbnail items.
Public Property | ForeColor | Overridden. Gets or sets color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.
Public Property | HighlightBackColor | Gets or sets the background color used for the Title of highlighted Thumbnail items.
Public Property | HighlightForeColor | Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Public Property | Interior | Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Public Property | ItemHeight | Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Public Property | ItemWidth | Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Public Property | LeftMargin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Public Property | MultiSelect | Gets or sets a value indicating whether multiple selection is allowed.
Public Property | RightToLeft | Overridden. Gets or sets a value indicating whether text appears right to left. Inerhited property not supported by thumbnail control.
Public Property | SelectionBackColor | Gets or sets background color used for the Title of selected Thumbnail items.
Public Property | SelectionForeColor | Gets or sets foreground color used for the Title of selected Thumbnail items.
Public Property | ShadowWidth | Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Public Property | ShowMagnify | Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Public Property | ShowTitles | Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Public Property | Sort | Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Public Property | SortComparer | Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Public Property | TitleFont | Gets or sets a font for items.
Public Property | TitleHeight | Gets or sets height for the item title.
Public Property | TopMargin | Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Public Property | ZoomFactor | Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.Windows.Forms.Thumbnails Namespace


AllPages Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : AllPages Property
Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
Public Property AllPages As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.AllPages = value

value = instance.AllPages
[Category("Items")]
[Description()]
public bool AllPages {get; set;}
[Category("Items")]
[Description()]
public: __property bool get_AllPages();
public: __property void set_AllPages(
   bool value
);
[Category("Items")]
[Description()]
public:
property bool AllPages {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


AutoFocus Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : AutoFocus Property
Gets or sets a value indicating whether to automatically grab focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Property AutoFocus As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.AutoFocus = value

value = instance.AutoFocus
[Description()]
[Category("Behavior")]
public bool AutoFocus {get; set;}
[Description()]
[Category("Behavior")]
public: __property bool get_AutoFocus();
public: __property void set_AutoFocus(
   bool value
);
[Description()]
[Category("Behavior")]
public:
property bool AutoFocus {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


AutoScroll Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : AutoScroll Property
Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Appearance")>
Public Overrides Property AutoScroll As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
[Description()]
[Category("Appearance")]
public override bool AutoScroll {get; set;}
[Description()]
[Category("Appearance")]
public: __property bool get_AutoScroll() override;
public: __property void set_AutoScroll(
   bool value
) override;
[Description()]
[Category("Appearance")]
public:
property bool AutoScroll {
   bool get() override;
   void set (    bool value) override;
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


BackColor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : BackColor Property
Gets or sets the background color of the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
Public Overrides Property BackColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.BackColor = value

value = instance.BackColor
[DefaultValue()]
[Category("Appearance")]
public override Color BackColor {get; set;}
[DefaultValue()]
[Category("Appearance")]
public: __property Color get_BackColor() override;
public: __property void set_BackColor(
   Color value
) override;
[DefaultValue()]
[Category("Appearance")]
public:
property Color BackColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


BorderStyle Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : BorderStyle Property
Gets or sets border style of the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
Public Shadows Property BorderStyle As BorderStyle
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
[Category("Appearance")]
public new BorderStyle BorderStyle {get; set;}
[Category("Appearance")]
public: __property new BorderStyle get_BorderStyle();
public: __property new void set_BorderStyle(
   BorderStyle value
);
[Category("Appearance")]
public:
new property BorderStyle BorderStyle {
   BorderStyle get();
   void set (    BorderStyle value);
}

Property Value

System.Windows.Forms.BorderStyle value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


BorderWidth Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : BorderWidth Property
Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property BorderWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
[Description()]
[Category("Items")]
public int BorderWidth {get; set;}
[Description()]
[Category("Items")]
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
[Description()]
[Category("Items")]
public:
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Count Property (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Count Property
Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

value = instance.Count
[Description()]
[Browsable(false)]
public int Count {get;}
[Description()]
[Browsable(false)]
public: __property int get_Count();
[Description()]
[Browsable(false)]
public:
property int Count {
   int get();
}

Property Value

Integer value.
Example
  • C#
if (igThumbnailCtl.Count > 0)
{
    for (int index = 0; index < igThumbnailCtl.Count; index++)
    {
        ImGearThumbnailItem igThumbnailItem = igThumbnailCtl.Item(index);
        // Perform some operations on each item.
    }
}
  • Visual Basic
If igThumbnailCtl.Count > 0 Then
    For index As Integer = 0 To igThumbnailCtl.Count - 1
        ' Perform some operations on each item.
        Dim igThumbnailItem As ImGearThumbnailItem = igThumbnailCtl.Item(index)
    Next
End If
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DragDropOptions Property (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : DragDropOptions Property
Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Property DragDropOptions As ImGearDragDropOptions
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ImGearDragDropOptions

instance.DragDropOptions = value

value = instance.DragDropOptions
[Description()]
[Category("Behavior")]
public ImGearDragDropOptions DragDropOptions {get; set;}
[Description()]
[Category("Behavior")]
public: __property ImGearDragDropOptions get_DragDropOptions();
public: __property void set_DragDropOptions(
   ImGearDragDropOptions value
);
[Description()]
[Category("Behavior")]
public:
property ImGearDragDropOptions DragDropOptions {
   ImGearDragDropOptions get();
   void set (    ImGearDragDropOptions value);
}

Property Value

ImGearDragDropOptions enumeration value.
Example
  • C#
igThumbnailCtl.DragDropOptions = ImGearDragDropOptions.DragDrop;
  • Visual Basic
igThumbnailCtl.DragDropOptions = ImGearDragDropOptions.DragDrop
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearDragDropOptions Enumeration


Flat Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Flat Property
Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property Flat As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.Flat = value

value = instance.Flat
[Description()]
[Category("Items")]
public bool Flat {get; set;}
[Description()]
[Category("Items")]
public: __property bool get_Flat();
public: __property void set_Flat(
   bool value
);
[Description()]
[Category("Items")]
public:
property bool Flat {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Font Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Font Property
Gets or sets the font used for rendering titles under the thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Overrides Property Font As Font
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Font

instance.Font = value

value = instance.Font
[Browsable(false)]
public override Font Font {get; set;}
[Browsable(false)]
public: __property Font* get_Font() override;
public: __property void set_Font(
   Font* value
) override;
[Browsable(false)]
public:
property Font^ Font {
   Font^ get() override;
   void set (    Font^ value) override;
}

Property Value

System.Drawing.Font value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ForeColor Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ForeColor Property
Gets or sets color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Overrides Property ForeColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
[Browsable(false)]
public override Color ForeColor {get; set;}
[Browsable(false)]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
[Browsable(false)]
public:
property Color ForeColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightBackColor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : HighlightBackColor Property
Gets or sets the background color used for the Title of highlighted Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute("Background color used for the Title of highlighted Thumbnail item.")>
Public Property HighlightBackColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
public Color HighlightBackColor {get; set;}
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
public: __property Color get_HighlightBackColor();
public: __property void set_HighlightBackColor(
   Color value
);
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
public:
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightForeColor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : HighlightForeColor Property
Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Foreground color used for the Title of highlighted Thumbnail item.")>
<CategoryAttribute("Items")>
Public Property HighlightForeColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[Category("Items")]
public Color HighlightForeColor {get; set;}
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[Category("Items")]
public: __property Color get_HighlightForeColor();
public: __property void set_HighlightForeColor(
   Color value
);
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[Category("Items")]
public:
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Interior Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Interior Property
Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<DescriptionAttribute()>
Public Property Interior As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.Interior = value

value = instance.Interior
[Category("Appearance")]
[Description()]
public int Interior {get; set;}
[Category("Appearance")]
[Description()]
public: __property int get_Interior();
public: __property void set_Interior(
   int value
);
[Category("Appearance")]
[Description()]
public:
property int Interior {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemHeight Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemHeight Property
Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property ItemHeight As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ItemHeight = value

value = instance.ItemHeight
[Description()]
[Category("Items")]
public int ItemHeight {get; set;}
[Description()]
[Category("Items")]
public: __property int get_ItemHeight();
public: __property void set_ItemHeight(
   int value
);
[Description()]
[Category("Items")]
public:
property int ItemHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemWidth Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemWidth Property
Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property ItemWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ItemWidth = value

value = instance.ItemWidth
[Description()]
[Category("Items")]
public int ItemWidth {get; set;}
[Description()]
[Category("Items")]
public: __property int get_ItemWidth();
public: __property void set_ItemWidth(
   int value
);
[Description()]
[Category("Items")]
public:
property int ItemWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


LeftMargin Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : LeftMargin Property
Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<DescriptionAttribute()>
Public Property LeftMargin As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.LeftMargin = value

value = instance.LeftMargin
[Category("Appearance")]
[Description()]
public int LeftMargin {get; set;}
[Category("Appearance")]
[Description()]
public: __property int get_LeftMargin();
public: __property void set_LeftMargin(
   int value
);
[Category("Appearance")]
[Description()]
public:
property int LeftMargin {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Note that the Thumbnail control is resizable, so the amount of margin on the right side is determined automatically.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


MultiSelect Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : MultiSelect Property
Gets or sets a value indicating whether multiple selection is allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Determines whether the user can select multiple Thumbnail items at the same time.")>
<CategoryAttribute("Behavior")>
Public Property MultiSelect As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.MultiSelect = value

value = instance.MultiSelect
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public bool MultiSelect {get; set;}
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public: __property bool get_MultiSelect();
public: __property void set_MultiSelect(
   bool value
);
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public:
property bool MultiSelect {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If this property is true that means that the user can select multiple thumbnail items at the same time (shift-left-click to select a range of items, ctrl-left-click to select multiple individual items). If it is false, only one item can be selected - selecting one will automatically de-select any other that is selected.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


RightToLeft Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : RightToLeft Property
Gets or sets a value indicating whether text appears right to left. Inerhited property not supported by thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Overrides Property RightToLeft As RightToLeft
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
[Browsable(false)]
public override RightToLeft RightToLeft {get; set;}
[Browsable(false)]
public: __property RightToLeft get_RightToLeft() override;
public: __property void set_RightToLeft(
   RightToLeft value
) override;
[Browsable(false)]
public:
property RightToLeft RightToLeft {
   RightToLeft get() override;
   void set (    RightToLeft value) override;
}

Property Value

System.Windows.Forms.RightToLeft enumeration value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionBackColor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : SelectionBackColor Property
Gets or sets background color used for the Title of selected Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Background color used for the Title of selected Thumbnail item.")>
<CategoryAttribute("Items")>
Public Property SelectionBackColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.SelectionBackColor = value

value = instance.SelectionBackColor
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public Color SelectionBackColor {get; set;}
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public: __property Color get_SelectionBackColor();
public: __property void set_SelectionBackColor(
   Color value
);
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public:
property Color SelectionBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
Remarks
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the border around the button is changed from BackColor to SelectionBackColor.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionForeColor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : SelectionForeColor Property
Gets or sets foreground color used for the Title of selected Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute("Foreground color used for the Title of selected Thumbnail item.")>
Public Property SelectionForeColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.SelectionForeColor = value

value = instance.SelectionForeColor
[Category("Items")]
[Description("Foreground color used for the Title of selected Thumbnail item.")]
public Color SelectionForeColor {get; set;}
[Category("Items")]
[Description("Foreground color used for the Title of selected Thumbnail item.")]
public: __property Color get_SelectionForeColor();
public: __property void set_SelectionForeColor(
   Color value
);
[Category("Items")]
[Description("Foreground color used for the Title of selected Thumbnail item.")]
public:
property Color SelectionForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
Remarks
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the text is changed from ForeColor to SelectionForeColor.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShadowWidth Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ShadowWidth Property
Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
Public Property ShadowWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ShadowWidth = value

value = instance.ShadowWidth
[Category("Items")]
[Description()]
public int ShadowWidth {get; set;}
[Category("Items")]
[Description()]
public: __property int get_ShadowWidth();
public: __property void set_ShadowWidth(
   int value
);
[Category("Items")]
[Description()]
public:
property int ShadowWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShowMagnify Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ShowMagnify Property
Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Property ShowMagnify As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.ShowMagnify = value

value = instance.ShowMagnify
[Category("Behavior")]
[Description()]
public bool ShowMagnify {get; set;}
[Category("Behavior")]
[Description()]
public: __property bool get_ShowMagnify();
public: __property void set_ShowMagnify(
   bool value
);
[Category("Behavior")]
[Description()]
public:
property bool ShowMagnify {
   bool get();
   void set (    bool value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShowTitles Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ShowTitles Property
Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
Public Property ShowTitles As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.ShowTitles = value

value = instance.ShowTitles
[Category("Items")]
[Description()]
public bool ShowTitles {get; set;}
[Category("Items")]
[Description()]
public: __property bool get_ShowTitles();
public: __property void set_ShowTitles(
   bool value
);
[Category("Items")]
[Description()]
public:
property bool ShowTitles {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Sort Property (ImGearThumbnailCtl)
Example

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : Sort Property
Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property Sort As ImGearSortOptions
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ImGearSortOptions

instance.Sort = value

value = instance.Sort
[Description()]
[Category("Items")]
public ImGearSortOptions Sort {get; set;}
[Description()]
[Category("Items")]
public: __property ImGearSortOptions get_Sort();
public: __property void set_Sort(
   ImGearSortOptions value
);
[Description()]
[Category("Items")]
public:
property ImGearSortOptions Sort {
   ImGearSortOptions get();
   void set (    ImGearSortOptions value);
}

Property Value

ImGearSortOptions enumeration values.
Example
  • C#
igThumbnailCtl.Sort = ImGearSortOptions.TitleAscending;
  • Visual Basic
igThumbnailCtl.Sort = ImGearSortOptions.TitleAscending
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearSortOptions Enumeration


SortComparer Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : SortComparer Property
Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute()>
Public Property SortComparer As IComparer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As IComparer

instance.SortComparer = value

value = instance.SortComparer
[Browsable(false)]
[Description()]
public IComparer SortComparer {get; set;}
[Browsable(false)]
[Description()]
public: __property IComparer* get_SortComparer();
public: __property void set_SortComparer(
   IComparer* value
);
[Browsable(false)]
[Description()]
public:
property IComparer^ SortComparer {
   IComparer^ get();
   void set (    IComparer^ value);
}

Property Value

System.Collections.IComparer class object.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TitleFont Property

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : TitleFont Property
Gets or sets a font for items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
Public Property TitleFont As Font
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Font

instance.TitleFont = value

value = instance.TitleFont
[Category("Appearance")]
public Font TitleFont {get; set;}
[Category("Appearance")]
public: __property Font* get_TitleFont();
public: __property void set_TitleFont(
   Font* value
);
[Category("Appearance")]
public:
property Font^ TitleFont {
   Font^ get();
   void set (    Font^ value);
}

Property Value

System.Drawing.Font class object.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TitleHeight Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : TitleHeight Property
Gets or sets height for the item title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
Public Property TitleHeight As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.TitleHeight = value

value = instance.TitleHeight
[Category("Items")]
[Description()]
public int TitleHeight {get; set;}
[Category("Items")]
[Description()]
public: __property int get_TitleHeight();
public: __property void set_TitleHeight(
   int value
);
[Category("Items")]
[Description()]
public:
property int TitleHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TopMargin Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : TopMargin Property
Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<DescriptionAttribute()>
Public Property TopMargin As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.TopMargin = value

value = instance.TopMargin
[Category("Appearance")]
[Description()]
public int TopMargin {get; set;}
[Category("Appearance")]
[Description()]
public: __property int get_TopMargin();
public: __property void set_TopMargin(
   int value
);
[Category("Appearance")]
[Description()]
public:
property int TopMargin {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Note that Thumbnail control is resizable, so the amount of margin on the bottom side is determined automatically.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


XSpacing Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : XSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<DescriptionAttribute()>
Public Property XSpacing As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.XSpacing = value

value = instance.XSpacing
[Category("Appearance")]
[Description()]
public int XSpacing {get; set;}
[Category("Appearance")]
[Description()]
public: __property int get_XSpacing();
public: __property void set_XSpacing(
   int value
);
[Category("Appearance")]
[Description()]
public:
property int XSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


YSpacing Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : YSpacing Property
Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<CategoryAttribute("Appearance")>
Public Property YSpacing As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.YSpacing = value

value = instance.YSpacing
[Description()]
[Category("Appearance")]
public int YSpacing {get; set;}
[Description()]
[Category("Appearance")]
public: __property int get_YSpacing();
public: __property void set_YSpacing(
   int value
);
[Description()]
[Category("Appearance")]
public:
property int YSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons. When ShowTitles = true, the YSpacing measures the distance from the bottom of a title to the top of the item below it. When ShowTitles = false, the YSpacing measures the distance from the bottom of the item to the top of the one below it.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ZoomFactor Property (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ZoomFactor Property
Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Property ZoomFactor As Single
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Single

instance.ZoomFactor = value

value = instance.ZoomFactor
[Category("Behavior")]
[Description()]
public float ZoomFactor {get; set;}
[Category("Behavior")]
[Description()]
public: __property float get_ZoomFactor();
public: __property void set_ZoomFactor(
   float value
);
[Category("Behavior")]
[Description()]
public:
property float ZoomFactor {
   float get();
   void set (    float value);
}

Property Value

Float value.
Remarks
Value must be between 1.0 and 50.0. This property is only used when ShowMagnify = true..
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


%%PageItemTitle%% $$Events$$

ImGearThumbnailCtl Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Events
 | Name | Description
Public Event | ItemAfterCreate | Called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemAfterLoad | Called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemBeforeDelete | Called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Public Event | ItemBeforeLoad | Called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImageGear.Core.ImGearPage class object.
Public Event | ItemClicked | Called to indicate that the user clicked somewhere within the thumbnail control.
Public Event | ItemDoubleClicked | Called to indicate that the user double-clicked somewhere within the thumbnail control.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.Windows.Forms.Thumbnails Namespace


ItemAfterCreate Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemAfterCreate Event
Called after a new thumbnail item is added to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemAfterCreate As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemAfterCreate, handler
[Category("Item")]
public event ImGearThumbnailItemEventHandler ItemAfterCreate
[Category("Item")]
public: __event ImGearThumbnailItemEventHandler* ItemAfterCreate
[Category("Item")]
public:
event ImGearThumbnailItemEventHandler^ ItemAfterCreate
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
Remarks
During thumbnail item creation, the sequence of events is ItemBeforeLoad, then ItemAfterLoad, then ItemAfterCreate.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemAfterLoad Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemAfterLoad Event
Called after a new thumbnail item is added to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemAfterLoad As ImGearThumbnailAfterLoadEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailAfterLoadEventHandler

AddHandler instance.ItemAfterLoad, handler
[Category("Item")]
public event ImGearThumbnailAfterLoadEventHandler ItemAfterLoad
[Category("Item")]
public: __event ImGearThumbnailAfterLoadEventHandler* ItemAfterLoad
[Category("Item")]
public:
event ImGearThumbnailAfterLoadEventHandler^ ItemAfterLoad
Event Data

The event handler receives an argument of type ImGearThumbnailAfterLoadEventArgs containing data related to this event. The following ImGearThumbnailAfterLoadEventArgs properties provide information specific to this event.

Property | Description
Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Remarks
During thumbnail item creation, the sequence of events is ItemBeforeLoad, then ItemAfterLoad, then ItemAfterCreate.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemBeforeDelete Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemBeforeDelete Event
Called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemBeforeDelete As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemBeforeDelete, handler
[Category("Item")]
public event ImGearThumbnailItemEventHandler ItemBeforeDelete
[Category("Item")]
public: __event ImGearThumbnailItemEventHandler* ItemBeforeDelete
[Category("Item")]
public:
event ImGearThumbnailItemEventHandler^ ItemBeforeDelete
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemBeforeLoad Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemBeforeLoad Event
Called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImageGear.Core.ImGearPage class object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemBeforeLoad As ImGearThumbnailBeforeLoadEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailBeforeLoadEventHandler

AddHandler instance.ItemBeforeLoad, handler
[Category("Item")]
public event ImGearThumbnailBeforeLoadEventHandler ItemBeforeLoad
[Category("Item")]
public: __event ImGearThumbnailBeforeLoadEventHandler* ItemBeforeLoad
[Category("Item")]
public:
event ImGearThumbnailBeforeLoadEventHandler^ ItemBeforeLoad
Event Data

The event handler receives an argument of type ImGearThumbnailBeforeLoadEventArgs containing data related to this event. The following ImGearThumbnailBeforeLoadEventArgs properties provide information specific to this event.

Property | Description
Page | Gets ImageGear.Core.ImGearPage class object containing full-sized picture that was used to create a thumbnail.
PageNumber | Gets page number of the currently loaded thumbnail.
Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Source | Gets path and format of the currently loaded thumbnail.
Remarks
Your application can use this event to set the ImageGear file load handling (e.g., load scaled JPEG image) and the thumbnail image generation handling (e.g., aliasing, interpolation).
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemClicked Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemClicked Event
Called to indicate that the user clicked somewhere within the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemClicked As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemClicked, handler
[Category("Item")]
public event ImGearThumbnailItemEventHandler ItemClicked
[Category("Item")]
public: __event ImGearThumbnailItemEventHandler* ItemClicked
[Category("Item")]
public:
event ImGearThumbnailItemEventHandler^ ItemClicked
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemDoubleClicked Event (ImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailCtl Class : ItemDoubleClicked Event
Called to indicate that the user double-clicked somewhere within the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Item")>
Public Event ItemDoubleClicked As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemDoubleClicked, handler
[Category("Item")]
public event ImGearThumbnailItemEventHandler ItemDoubleClicked
[Category("Item")]
public: __event ImGearThumbnailItemEventHandler* ItemDoubleClicked
[Category("Item")]
public:
event ImGearThumbnailItemEventHandler^ ItemDoubleClicked
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailItem Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItem Class
Represents one of the thumbnail items displayed on the thumbnail browser.
Object Model
ImGearThumbnailItem ClassImGearARTPage ClassImGearPage ClassImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailItem
   Inherits System.Windows.Forms.Panel
   Implements IImGearThumbnailItem
'Usage

Dim instance As ImGearThumbnailItem
public class ImGearThumbnailItem : System.Windows.Forms.Panel, IImGearThumbnailItem
public __gc class ImGearThumbnailItem : public System.Windows.Forms.Panel, IImGearThumbnailItem
public ref class ImGearThumbnailItem : public System.Windows.Forms.Panel, IImGearThumbnailItem
Remarks
Your application can iterate through the collection of ImGearThumbnailItem using the Item method and Count property of ImGearThumbnailCtl. Some of the event handlers are using ImGearThumbnailItem objects (for instance, when someone clicks on a particular thumbnail item).
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem

See Also

Reference

ImGearThumbnailItem Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailItem Class Members
Properties Methods Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItem Class

The following tables list the members exposed by ImGearThumbnailItem.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailItem Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ArtPage | Gets or sets Art page associated with item.
Public Property | BitDepth | Gets original image bit depth.
Public Property | Format | Gets original image format.
Public Property | Height | Gets or sets item's height.
Public Property | HighlightBackColor | Gets or sets title's back color of the highlighted item.
Public Property | Highlighted | Gets or sets a value indicating whether item is highlighted.
Public Property | HighlightForeColor | Gets or sets title's fore color if highlighted.
Public Property | ImageSize | Gets original image size.
Public Property | Page | Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Public Property | PageNumber | Gets page number.
Public Property | PrivateData | Gets or sets user data associated with the item.
Public Property | Selected | Gets or sets a value indicating whether item is selected.
Public Property | Source | Gets ImGearLoadingSelection object containing path and format of the original file.
Public Property | Thumbnail | Gets thumbnail bitmap representing an image.
Public Property | Title | Gets or sets item's title.
Public Property | Width | Gets or sets item's width.
Top
Public Methods
 | Name | Description
Public Method | Reload | Reloads item's picture.
Top
Protected Methods
 | Name | Description
Protected Method | OnPaint | Overridden. Derived classes can implement this method to handle paint events themselves.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearThumbnailItem Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : ImGearThumbnailItem Constructor
Overload List
Overload | Description
ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32) | Initializes a new instance of the ImGearThumbnailItem class.
ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats) | Initializes a new instance of the ImGearThumbnailItem class.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%%

ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class > ImGearThumbnailItem Constructor : ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32)
Reference to the parent ImGearThumbnailCtl object.
Reference to ImGearLoadingSelection object containing path and format of the original file.
Thumbnail item's title.
Page number.
Initializes a new instance of the ImGearThumbnailItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As ImGearThumbnailCtl, _
   ByVal loadingSelection As ImGearLoadingSelection, _
   ByVal title As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim parent As ImGearThumbnailCtl
Dim loadingSelection As ImGearLoadingSelection
Dim title As String
Dim pageNumber As Integer

Dim instance As New ImGearThumbnailItem(parent, loadingSelection, title, pageNumber)
public ImGearThumbnailItem(
   ImGearThumbnailCtl parent,
   ImGearLoadingSelection loadingSelection,
   string title,
   int pageNumber
)
public: ImGearThumbnailItem(
   ImGearThumbnailCtl* parent,
   ImGearLoadingSelection* loadingSelection,
   string* title,
   int pageNumber
)
public:
ImGearThumbnailItem(
   ImGearThumbnailCtl^ parent,
   ImGearLoadingSelection^ loadingSelection,
   String^ title,
   int pageNumber
)

Parameters

parent
Reference to the parent ImGearThumbnailCtl object.
loadingSelection
Reference to ImGearLoadingSelection object containing path and format of the original file.
title
Thumbnail item's title.
pageNumber
Page number.

Return Value

New instance of ImGearThumbnailItem class.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
Overload List
ImGearThumbnailCtl Class
ImGearLoadingSelection Class


%%PageItemTitle%%

ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class > ImGearThumbnailItem Constructor : ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats)
Reference to the parent ImGearThumbnailCtl object.
Reference to ImageGear.Core.ImGearPage class object that contains original image.
Thumbnail item's title.
Page number.
Original image format.
Initializes a new instance of the ImGearThumbnailItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As ImGearThumbnailCtl, _
   ByVal pageToLoad As ImGearPage, _
   ByVal title As String, _
   ByVal pageNumber As Integer, _
   ByVal format As ImGearFormats _
)
'Usage

Dim parent As ImGearThumbnailCtl
Dim pageToLoad As ImGearPage
Dim title As String
Dim pageNumber As Integer
Dim format As ImGearFormats

Dim instance As New ImGearThumbnailItem(parent, pageToLoad, title, pageNumber, format)
public ImGearThumbnailItem(
   ImGearThumbnailCtl parent,
   ImGearPage pageToLoad,
   string title,
   int pageNumber,
   ImGearFormats format
)
public: ImGearThumbnailItem(
   ImGearThumbnailCtl* parent,
   ImGearPage* pageToLoad,
   string* title,
   int pageNumber,
   ImGearFormats format
)
public:
ImGearThumbnailItem(
   ImGearThumbnailCtl^ parent,
   ImGearPage^ pageToLoad,
   String^ title,
   int pageNumber,
   ImGearFormats format
)

Parameters

parent
Reference to the parent ImGearThumbnailCtl object.
pageToLoad
Reference to ImageGear.Core.ImGearPage class object that contains original image.
title
Thumbnail item's title.
pageNumber
Page number.
format
Original image format.

Return Value

New instance of ImGearThumbnailItem class.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
Overload List
ImGearFormats Enumeration
ImGearPage Class
ImGearThumbnailCtl Class


%%PageItemTitle%% $$Methods$$

ImGearThumbnailItem Class Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

Public Methods
 | Name | Description
Public Method | Reload | Reloads item's picture.
Top
Protected Methods
 | Name | Description
Protected Method | OnPaint | Overridden. Derived classes can implement this method to handle paint events themselves.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Events$$

ImGearThumbnailItem Class Events

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

See Also

Reference

ImGearThumbnailItem Class
ImageGear.Windows.Forms.Thumbnails Namespace


OnPaint Method (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : OnPaint Method
PaintEventArgs object containing event data.
Derived classes can implement this method to handle paint events themselves.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub OnPaint( _
   ByVal e As PaintEventArgs _
)
'Usage

Dim instance As ImGearThumbnailItem
Dim e As PaintEventArgs

instance.OnPaint(e)
protected override void OnPaint(
   PaintEventArgs e
)
protected: void OnPaint(
   PaintEventArgs* e
) override
protected:
void OnPaint(
   PaintEventArgs^ e
) override

Parameters

e
PaintEventArgs object containing event data.
Remarks
This method is called when the control is required to paint its contents. An application does not call this method directly.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Reload Method (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Reload Method
Reloads item's picture.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reload()
'Usage

Dim instance As ImGearThumbnailItem

instance.Reload()
public void Reload()
public: void Reload();
public:
void Reload();
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailItem Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

Public Properties
 | Name | Description
Public Property | ArtPage | Gets or sets Art page associated with item.
Public Property | BitDepth | Gets original image bit depth.
Public Property | Format | Gets original image format.
Public Property | Height | Gets or sets item's height.
Public Property | HighlightBackColor | Gets or sets title's back color of the highlighted item.
Public Property | Highlighted | Gets or sets a value indicating whether item is highlighted.
Public Property | HighlightForeColor | Gets or sets title's fore color if highlighted.
Public Property | ImageSize | Gets original image size.
Public Property | Page | Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Public Property | PageNumber | Gets page number.
Public Property | PrivateData | Gets or sets user data associated with the item.
Public Property | Selected | Gets or sets a value indicating whether item is selected.
Public Property | Source | Gets ImGearLoadingSelection object containing path and format of the original file.
Public Property | Thumbnail | Gets thumbnail bitmap representing an image.
Public Property | Title | Gets or sets item's title.
Public Property | Width | Gets or sets item's width.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.Windows.Forms.Thumbnails Namespace


ArtPage Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : ArtPage Property
Gets or sets Art page associated with item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArtPage As ImGearARTPage
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearARTPage

instance.ArtPage = value

value = instance.ArtPage
public ImGearARTPage ArtPage {get; set;}
public: __property ImGearARTPage* get_ArtPage();
public: __property void set_ArtPage(
   ImGearARTPage* value
);
public:
property ImGearARTPage^ ArtPage {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImageGear.ART.ImGearARTPage class object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


BitDepth Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : BitDepth Property
Gets original image bit depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitDepth As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.BitDepth
public int BitDepth {get;}
public: __property int get_BitDepth();
public:
property int BitDepth {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Format Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Format Property
Gets original image format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Format As ImGearFormats
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearFormats

value = instance.Format
public ImGearFormats Format {get;}
public: __property ImGearFormats get_Format();
public:
property ImGearFormats Format {
   ImGearFormats get();
}

Property Value

ImageGear.Formats.ImGearFormats enumeration value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearFormats Enumeration


Height Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Height Property
Gets or sets item's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property Height As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

instance.Height = value

value = instance.Height
public new int Height {get; set;}
public: __property new int get_Height();
public: __property new void set_Height(
   int value
);
public:
new property int Height {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


HighlightBackColor Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : HighlightBackColor Property
Gets or sets title's back color of the highlighted item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightBackColor As Color
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
public Color HighlightBackColor {get; set;}
public: __property Color get_HighlightBackColor();
public: __property void set_HighlightBackColor(
   Color value
);
public:
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
Remarks
If not set, HighlightBackColor from thumbnail control is used.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Highlighted Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Highlighted Property
Gets or sets a value indicating whether item is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlighted As Boolean
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Boolean

instance.Highlighted = value

value = instance.Highlighted
public bool Highlighted {get; set;}
public: __property bool get_Highlighted();
public: __property void set_Highlighted(
   bool value
);
public:
property bool Highlighted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


HighlightForeColor Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : HighlightForeColor Property
Gets or sets title's fore color if highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightForeColor As Color
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
public Color HighlightForeColor {get; set;}
public: __property Color get_HighlightForeColor();
public: __property void set_HighlightForeColor(
   Color value
);
public:
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
Remarks
If not set, HighlightForeColor from thumbnail control is used.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


ImageSize Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : ImageSize Property
Gets original image size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageSize As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.ImageSize
public int ImageSize {get;}
public: __property int get_ImageSize();
public:
property int ImageSize {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Page Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Page Property
Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearPage Class


PageNumber Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : PageNumber Property
Gets page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


PrivateData Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : PrivateData Property
Gets or sets user data associated with the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrivateData As Object
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Object

instance.PrivateData = value

value = instance.PrivateData
public object PrivateData {get; set;}
public: __property Object* get_PrivateData();
public: __property void set_PrivateData(
   Object* value
);
public:
property Object^ PrivateData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Any object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Selected Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Selected Property
Gets or sets a value indicating whether item is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Selected As Boolean
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
public bool Selected {get; set;}
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Source Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Source Property
Gets ImGearLoadingSelection object containing path and format of the original file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Source As ImGearLoadingSelection
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearLoadingSelection

value = instance.Source
public ImGearLoadingSelection Source {get;}
public: __property ImGearLoadingSelection* get_Source();
public:
property ImGearLoadingSelection^ Source {
   ImGearLoadingSelection^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearLoadingSelection class object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearLoadingSelection Class


Thumbnail Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Thumbnail Property
Gets thumbnail bitmap representing an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Thumbnail As Image
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Image

value = instance.Thumbnail
public Image Thumbnail {get;}
public: __property Image* get_Thumbnail();
public:
property Image^ Thumbnail {
   Image^ get();
}

Property Value

System.Drawing.Image class object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Title Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Title Property
Gets or sets item's title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As ImGearThumbnailItem
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Width Property (ImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItem Class : Width Property
Gets or sets item's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property Width As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

instance.Width = value

value = instance.Width
public new int Width {get; set;}
public: __property new int get_Width();
public: __property new void set_Width(
   int value
);
public:
new property int Width {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%%

ImGearThumbnailItemEventArgs Class
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItemEventArgs Class
Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.
Object Model
ImGearThumbnailItemEventArgs ClassImGearThumbnailItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailItemEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImGearThumbnailItemEventArgs
public class ImGearThumbnailItemEventArgs : System.EventArgs
public __gc class ImGearThumbnailItemEventArgs : public System.EventArgs
public ref class ImGearThumbnailItemEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventArgs

See Also

Reference

ImGearThumbnailItemEventArgs Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailItemEventArgs Class Members
Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItemEventArgs Class

The following tables list the members exposed by ImGearThumbnailItemEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailItemEventArgs Constructor | Initializes a new instance of the ImGearThumbnailItemEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets ImGearThumbnailItem object that generated event.
Top
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearThumbnailItemEventArgs Constructor

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItemEventArgs Class : ImGearThumbnailItemEventArgs Constructor
Item that generated event.
Initializes a new instance of the ImGearThumbnailItemEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim item As ImGearThumbnailItem

Dim instance As New ImGearThumbnailItemEventArgs(item)
public ImGearThumbnailItemEventArgs(
   ImGearThumbnailItem item
)
public: ImGearThumbnailItemEventArgs(
   ImGearThumbnailItem* item
)
public:
ImGearThumbnailItemEventArgs(
   ImGearThumbnailItem^ item
)

Parameters

item
Item that generated event.

Return Value

New instance of ImGearThumbnailItemEventArgs class.
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs Members
ImGearThumbnailItem Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailItemEventArgs Class Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItemEventArgs Class

For a list of all members of this type, see ImGearThumbnailItemEventArgs members.

Public Properties
 | Name | Description
Public Property | Item | Gets ImGearThumbnailItem object that generated event.
Top
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImageGear.Windows.Forms.Thumbnails Namespace


Item Property (ImGearThumbnailItemEventArgs)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > ImGearThumbnailItemEventArgs Class : Item Property
Gets ImGearThumbnailItem object that generated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As ImGearThumbnailItem
'Usage

Dim instance As ImGearThumbnailItemEventArgs
Dim value As ImGearThumbnailItem

value = instance.Item
public ImGearThumbnailItem Item {get;}
public: __property ImGearThumbnailItem* get_Item();
public:
property ImGearThumbnailItem^ Item {
   ImGearThumbnailItem^ get();
}

Property Value

ImGearThumbnailItem class object.
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs Members
ImGearThumbnailItem Class


%%PageItemTitle%%

ImGearDragDropOptions Enumeration

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearDragDropOptions Enumeration
Specifies drag and drop actions that are allowed in the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearDragDropOptions
   Inherits System.Enum
'Usage

Dim instance As ImGearDragDropOptions
public enum ImGearDragDropOptions : System.Enum
__value public enum ImGearDragDropOptions : public System.Enum
public enum class ImGearDragDropOptions : public System.Enum
Members
Member | Value | Description
Disable | 0 | No drag and drop actions are allowed.
Drag | 1 | Drag action is allowed.
DragDrop | 3 | Both drag and drop actions are allowed.
Drop | 2 | Drop action is allowed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Forms.Thumbnails.ImGearDragDropOptions

See Also

Reference

ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

ImGearSortOptions Enumeration

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearSortOptions Enumeration
Specifies what sorting is used when a new item is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearSortOptions
   Inherits System.Enum
'Usage

Dim instance As ImGearSortOptions
public enum ImGearSortOptions : System.Enum
__value public enum ImGearSortOptions : public System.Enum
public enum class ImGearSortOptions : public System.Enum
Members
Member | Value | Description
NoSort | 0 | Unsorted mode.
TitleAscending | 1 | Title ascending sorting mode.
TitleDescending | 2 | Title descending sorting mode.
UserSort | 3 | User defined sorting mode.
Remarks
This enumeration specifies what sorting is used when a new item is added.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.Windows.Forms.Thumbnails.ImGearSortOptions

See Also

Reference

ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%%

IImGearThumbnailCtl Interface
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailCtl Interface
Interface for operations with thumbnail items.
Object Model
IImGearThumbnailCtl InterfaceImGearThumbnailItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearThumbnailCtl
'Usage

Dim instance As IImGearThumbnailCtl
public interface IImGearThumbnailCtl
public __gc __interface IImGearThumbnailCtl
public interface class IImGearThumbnailCtl
See Also

Reference

IImGearThumbnailCtl Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

IImGearThumbnailCtl Interface Members
Properties Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailCtl Interface

The following tables list the members exposed by IImGearThumbnailCtl.

Public Properties
 | Name | Description
Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Property | AutoFocus | Gets or sets a value indicating whether to automatically grab focus.
Property | AutoScroll | Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Property | BorderStyle | Gets or sets border style of the Thumbnail control.
Property | BorderWidth | Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Property | Count | Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Property | DragDropOptions | Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Property | Flat | Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Property | Font | Gets or sets the font used for rendering titles under the thumbnail items.
Property | HighlightBackColor | Gets or sets the background color used for the Title of highlighted Thumbnail items.
Property | HighlightForeColor | Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Property | Interior | Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Property | ItemHeight | Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Property | ItemWidth | Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Property | LeftMargin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Property | MultiSelect | Gets or sets a value indicating whether multiple selection is allowed.
Property | SelectionBackColor | Gets or sets background color used for the Title of selected Thumbnail items.
Property | SelectionForeColor | Gets or sets foreground color used for the Title of selected Thumbnail items.
Property | ShadowWidth | Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Property | ShowMagnify | Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Property | ShowTitles | Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Property | Sort | Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Property | SortComparer | Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Property | TitleHeight | Gets or sets height for the item title.
Property | TopMargin | Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Property | ZoomFactor | Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Top
Public Methods
 | Name | Description
Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Method | DeleteItem | Removes specified item from the Thumbnail control.
Method | DirectoryAppend | Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Method | DocumentAppend | Appends ImageGear document to the Thumbnail control.
Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Method | Item | Returns ImGearThumbnailItem object by given index.
Method | PageAppend | Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
See Also

Reference

IImGearThumbnailCtl Interface
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Methods$$

IImGearThumbnailCtl Interface Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailCtl Interface

For a list of all members of this type, see IImGearThumbnailCtl members.

Public Methods
 | Name | Description
Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Method | DeleteItem | Removes specified item from the Thumbnail control.
Method | DirectoryAppend | Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Method | DocumentAppend | Appends ImageGear document to the Thumbnail control.
Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Method | Item | Returns ImGearThumbnailItem object by given index.
Method | PageAppend | Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
See Also

Reference

IImGearThumbnailCtl Interface
ImageGear.Windows.Forms.Thumbnails Namespace


DeleteAllItems Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : DeleteAllItems Method
Removes all the items from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub DeleteAllItems()
'Usage

Dim instance As IImGearThumbnailCtl

instance.DeleteAllItems()
void DeleteAllItems()
void DeleteAllItems();
void DeleteAllItems();
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


DeleteItem Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : DeleteItem Method
Item to be removed.
Removes specified item from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub DeleteItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.DeleteItem(item)
void DeleteItem(
   ImGearThumbnailItem item
)
void DeleteItem(
   ImGearThumbnailItem* item
)
void DeleteItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be removed.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


DirectoryAppend Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : DirectoryAppend Method
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub DirectoryAppend( _
   ByVal directory As String, _
   ByVal filters As String _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim directory As String
Dim filters As String

instance.DirectoryAppend(directory, filters)
void DirectoryAppend(
   string directory,
   string filters
)
void DirectoryAppend(
   string* directory,
   string* filters
)
void DirectoryAppend(
   String^ directory,
   String^ filters
)

Parameters

directory
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
filters
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


DocumentAppend Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : DocumentAppend Method
Document to be appended.
Title for new items.
Appends ImageGear document to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub DocumentAppend( _
   ByVal documentToAppend As ImGearDocument, _
   ByVal name As String _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim documentToAppend As ImGearDocument
Dim name As String

instance.DocumentAppend(documentToAppend, name)
void DocumentAppend(
   ImGearDocument documentToAppend,
   string name
)
void DocumentAppend(
   ImGearDocument* documentToAppend,
   string* name
)
void DocumentAppend(
   ImGearDocument^ documentToAppend,
   String^ name
)

Parameters

documentToAppend
Document to be appended.
name
Title for new items.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


FileAppend Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : FileAppend Method
Selection specifying a path and a type of the file to be appended.
Appends a file specified by selection to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub FileAppend( _
   ByVal loadSelection As ImGearLoadingSelection _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim loadSelection As ImGearLoadingSelection

instance.FileAppend(loadSelection)
void FileAppend(
   ImGearLoadingSelection loadSelection
)
void FileAppend(
   ImGearLoadingSelection* loadSelection
)
void FileAppend(
   ImGearLoadingSelection^ loadSelection
)

Parameters

loadSelection
Selection specifying a path and a type of the file to be appended.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Item Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Item Method
Index of the requested thumbnail.
Returns ImGearThumbnailItem object by given index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Item( _
   ByVal index As Integer _
) As ImGearThumbnailItem
'Usage

Dim instance As IImGearThumbnailCtl
Dim index As Integer
Dim value As ImGearThumbnailItem

value = instance.Item(index)
ImGearThumbnailItem Item(
   int index
)
ImGearThumbnailItem* Item(
   int index
)
ImGearThumbnailItem^ Item(
   int index
)

Parameters

index
Index of the requested thumbnail.

Return Value

ImGearThumbnailItem class object.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


PageAppend Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : PageAppend Method
ImageGear.Core.ImGearPage class object to be appended.
Title for new item.
Appends ImageGear.Core.ImGearPage class object to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub PageAppend( _
   ByVal pageToAppend As ImGearPage, _
   ByVal name As String _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim pageToAppend As ImGearPage
Dim name As String

instance.PageAppend(pageToAppend, name)
void PageAppend(
   ImGearPage pageToAppend,
   string name
)
void PageAppend(
   ImGearPage* pageToAppend,
   string* name
)
void PageAppend(
   ImGearPage^ pageToAppend,
   String^ name
)

Parameters

pageToAppend
ImageGear.Core.ImGearPage class object to be appended.
name
Title for new item.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ReloadAll Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub ReloadAll()
'Usage

Dim instance As IImGearThumbnailCtl

instance.ReloadAll()
void ReloadAll()
void ReloadAll();
void ReloadAll();
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ReloadItem Method (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ReloadItem Method
Item to be reloaded.
Reloads thumbnail picture in the specified thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub ReloadItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As IImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.ReloadItem(item)
void ReloadItem(
   ImGearThumbnailItem item
)
void ReloadItem(
   ImGearThumbnailItem* item
)
void ReloadItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be reloaded.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


%%PageItemTitle%% $$Properties$$

IImGearThumbnailCtl Interface Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailCtl Interface

For a list of all members of this type, see IImGearThumbnailCtl members.

Public Properties
 | Name | Description
Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Property | AutoFocus | Gets or sets a value indicating whether to automatically grab focus.
Property | AutoScroll | Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Property | BorderStyle | Gets or sets border style of the Thumbnail control.
Property | BorderWidth | Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Property | Count | Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Property | DragDropOptions | Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Property | Flat | Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Property | Font | Gets or sets the font used for rendering titles under the thumbnail items.
Property | HighlightBackColor | Gets or sets the background color used for the Title of highlighted Thumbnail items.
Property | HighlightForeColor | Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Property | Interior | Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Property | ItemHeight | Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Property | ItemWidth | Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Property | LeftMargin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Property | MultiSelect | Gets or sets a value indicating whether multiple selection is allowed.
Property | SelectionBackColor | Gets or sets background color used for the Title of selected Thumbnail items.
Property | SelectionForeColor | Gets or sets foreground color used for the Title of selected Thumbnail items.
Property | ShadowWidth | Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Property | ShowMagnify | Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Property | ShowTitles | Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Property | Sort | Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Property | SortComparer | Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Property | TitleHeight | Gets or sets height for the item title.
Property | TopMargin | Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Property | ZoomFactor | Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Top
See Also

Reference

IImGearThumbnailCtl Interface
ImageGear.Windows.Forms.Thumbnails Namespace


AllPages Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : AllPages Property
Gets or sets a value indicating whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AllPages As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.AllPages = value

value = instance.AllPages
bool AllPages {get; set;}
__property bool get_AllPages();
__property void set_AllPages(
   bool value
);
property bool AllPages {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


AutoFocus Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : AutoFocus Property
Gets or sets a value indicating whether to automatically grab focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AutoFocus As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.AutoFocus = value

value = instance.AutoFocus
bool AutoFocus {get; set;}
__property bool get_AutoFocus();
__property void set_AutoFocus(
   bool value
);
property bool AutoFocus {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


AutoScroll Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : AutoScroll Property
Gets or sets a value indicating whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property AutoScroll As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
bool AutoScroll {get; set;}
__property bool get_AutoScroll();
__property void set_AutoScroll(
   bool value
);
property bool AutoScroll {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


BorderStyle Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : BorderStyle Property
Gets or sets border style of the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property BorderStyle As BorderStyle
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
BorderStyle BorderStyle {get; set;}
__property BorderStyle get_BorderStyle();
__property void set_BorderStyle(
   BorderStyle value
);
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (    BorderStyle value);
}

Property Value

System.Windows.Forms.BorderStyle value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


BorderWidth Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : BorderWidth Property
Gets or sets border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property BorderWidth As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
int BorderWidth {get; set;}
__property int get_BorderWidth();
__property void set_BorderWidth(
   int value
);
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Count Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Count Property
Gets the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Count As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

value = instance.Count
int Count {get;}
__property int get_Count();
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


DragDropOptions Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : DragDropOptions Property
Gets or sets a value indicating whether the thumbnail browser can be a Drag source, Drop target or both.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property DragDropOptions As ImGearDragDropOptions
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As ImGearDragDropOptions

instance.DragDropOptions = value

value = instance.DragDropOptions
ImGearDragDropOptions DragDropOptions {get; set;}
__property ImGearDragDropOptions get_DragDropOptions();
__property void set_DragDropOptions(
   ImGearDragDropOptions value
);
property ImGearDragDropOptions DragDropOptions {
   ImGearDragDropOptions get();
   void set (    ImGearDragDropOptions value);
}

Property Value

ImGearDragDropOptions enumeration value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Flat Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Flat Property
Gets or sets a value indicating whether the thumbnail item will appear flat or three dimensional.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Flat As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.Flat = value

value = instance.Flat
bool Flat {get; set;}
__property bool get_Flat();
__property void set_Flat(
   bool value
);
property bool Flat {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Font Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Font Property
Gets or sets the font used for rendering titles under the thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Font As Font
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Font

instance.Font = value

value = instance.Font
Font Font {get; set;}
__property Font* get_Font();
__property void set_Font(
   Font* value
);
property Font^ Font {
   Font^ get();
   void set (    Font^ value);
}

Property Value

System.Drawing.Font value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


HighlightBackColor Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : HighlightBackColor Property
Gets or sets the background color used for the Title of highlighted Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HighlightBackColor As Color
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
Color HighlightBackColor {get; set;}
__property Color get_HighlightBackColor();
__property void set_HighlightBackColor(
   Color value
);
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


HighlightForeColor Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : HighlightForeColor Property
Gets or sets the foreground color used for the Title of highlighted Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HighlightForeColor As Color
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
Color HighlightForeColor {get; set;}
__property Color get_HighlightForeColor();
__property void set_HighlightForeColor(
   Color value
);
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Interior Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Interior Property
Gets or sets the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Interior As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.Interior = value

value = instance.Interior
int Interior {get; set;}
__property int get_Interior();
__property void set_Interior(
   int value
);
property int Interior {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ItemHeight Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ItemHeight Property
Gets or sets item height in pixels of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ItemHeight As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.ItemHeight = value

value = instance.ItemHeight
int ItemHeight {get; set;}
__property int get_ItemHeight();
__property void set_ItemHeight(
   int value
);
property int ItemHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ItemWidth Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ItemWidth Property
Gets or sets item width in pixels of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ItemWidth As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.ItemWidth = value

value = instance.ItemWidth
int ItemWidth {get; set;}
__property int get_ItemWidth();
__property void set_ItemWidth(
   int value
);
property int ItemWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


LeftMargin Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : LeftMargin Property
Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property LeftMargin As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.LeftMargin = value

value = instance.LeftMargin
int LeftMargin {get; set;}
__property int get_LeftMargin();
__property void set_LeftMargin(
   int value
);
property int LeftMargin {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


MultiSelect Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : MultiSelect Property
Gets or sets a value indicating whether multiple selection is allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property MultiSelect As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.MultiSelect = value

value = instance.MultiSelect
bool MultiSelect {get; set;}
__property bool get_MultiSelect();
__property void set_MultiSelect(
   bool value
);
property bool MultiSelect {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


SelectionBackColor Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : SelectionBackColor Property
Gets or sets background color used for the Title of selected Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property SelectionBackColor As Color
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Color

instance.SelectionBackColor = value

value = instance.SelectionBackColor
Color SelectionBackColor {get; set;}
__property Color get_SelectionBackColor();
__property void set_SelectionBackColor(
   Color value
);
property Color SelectionBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


SelectionForeColor Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : SelectionForeColor Property
Gets or sets foreground color used for the Title of selected Thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property SelectionForeColor As Color
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Color

instance.SelectionForeColor = value

value = instance.SelectionForeColor
Color SelectionForeColor {get; set;}
__property Color get_SelectionForeColor();
__property void set_SelectionForeColor(
   Color value
);
property Color SelectionForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ShadowWidth Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ShadowWidth Property
Gets or sets the width of the 3D appearance for every item if the Flat property is set to true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ShadowWidth As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.ShadowWidth = value

value = instance.ShadowWidth
int ShadowWidth {get; set;}
__property int get_ShadowWidth();
__property void set_ShadowWidth(
   int value
);
property int ShadowWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ShowMagnify Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ShowMagnify Property
Gets or sets a value indicating whether to see a larger popup image for the thumbnail when pressing the right-mouse-button down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ShowMagnify As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.ShowMagnify = value

value = instance.ShowMagnify
bool ShowMagnify {get; set;}
__property bool get_ShowMagnify();
__property void set_ShowMagnify(
   bool value
);
property bool ShowMagnify {
   bool get();
   void set (    bool value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ShowTitles Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ShowTitles Property
Gets or sets a value indicating whether a title is shown for each thumbnail, below the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ShowTitles As Boolean
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Boolean

instance.ShowTitles = value

value = instance.ShowTitles
bool ShowTitles {get; set;}
__property bool get_ShowTitles();
__property void set_ShowTitles(
   bool value
);
property bool ShowTitles {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


Sort Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : Sort Property
Gets or sets what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Sort As ImGearSortOptions
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As ImGearSortOptions

instance.Sort = value

value = instance.Sort
ImGearSortOptions Sort {get; set;}
__property ImGearSortOptions get_Sort();
__property void set_Sort(
   ImGearSortOptions value
);
property ImGearSortOptions Sort {
   ImGearSortOptions get();
   void set (    ImGearSortOptions value);
}

Property Value

ImGearSortOptions enumeration values.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


SortComparer Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : SortComparer Property
Gets or sets IComparer used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface for custom sorting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property SortComparer As IComparer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As IComparer

instance.SortComparer = value

value = instance.SortComparer
IComparer SortComparer {get; set;}
__property IComparer* get_SortComparer();
__property void set_SortComparer(
   IComparer* value
);
property IComparer^ SortComparer {
   IComparer^ get();
   void set (    IComparer^ value);
}

Property Value

System.Collections.IComparer class object.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


TitleHeight Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : TitleHeight Property
Gets or sets height for the item title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TitleHeight As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.TitleHeight = value

value = instance.TitleHeight
int TitleHeight {get; set;}
__property int get_TitleHeight();
__property void set_TitleHeight(
   int value
);
property int TitleHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


TopMargin Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : TopMargin Property
Gets or sets the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property TopMargin As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.TopMargin = value

value = instance.TopMargin
int TopMargin {get; set;}
__property int get_TopMargin();
__property void set_TopMargin(
   int value
);
property int TopMargin {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


XSpacing Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : XSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property XSpacing As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.XSpacing = value

value = instance.XSpacing
int XSpacing {get; set;}
__property int get_XSpacing();
__property void set_XSpacing(
   int value
);
property int XSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


YSpacing Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : YSpacing Property
Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property YSpacing As Integer
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Integer

instance.YSpacing = value

value = instance.YSpacing
int YSpacing {get; set;}
__property int get_YSpacing();
__property void set_YSpacing(
   int value
);
property int YSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons. When ShowTitles = true, the YSpacing measures the distance from the bottom of a title to the top of the item below it. When ShowTitles = false, the YSpacing measures the distance from the bottom of the item to the top of the one below it.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


ZoomFactor Property (IImGearThumbnailCtl)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailCtl Interface : ZoomFactor Property
Gets or sets the amount of zoom-in to use when displaying the magnified popup image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ZoomFactor As Single
'Usage

Dim instance As IImGearThumbnailCtl
Dim value As Single

instance.ZoomFactor = value

value = instance.ZoomFactor
float ZoomFactor {get; set;}
__property float get_ZoomFactor();
__property void set_ZoomFactor(
   float value
);
property float ZoomFactor {
   float get();
   void set (    float value);
}

Property Value

Float value.
See Also

Reference

IImGearThumbnailCtl Interface
IImGearThumbnailCtl Members


%%PageItemTitle%%

IImGearThumbnailItem Interface
Members

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailItem Interface
Provides interface for thumbnail items.
Object Model
IImGearThumbnailItem InterfaceImGearARTPage ClassImGearPage ClassImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IImGearThumbnailItem
'Usage

Dim instance As IImGearThumbnailItem
public interface IImGearThumbnailItem
public __gc __interface IImGearThumbnailItem
public interface class IImGearThumbnailItem
See Also

Reference

IImGearThumbnailItem Members
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Members$$

IImGearThumbnailItem Interface Members
Properties Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailItem Interface

The following tables list the members exposed by IImGearThumbnailItem.

Public Properties
 | Name | Description
Property | ArtPage | Gets or sets Art page associated with item.
Property | BitDepth | Gets original image bit depth.
Property | Format | Gets original image format.
Property | HighlightBackColor | Gets or sets title's back color of the highlighted item.
Property | Highlighted | Gets or sets a value indicating whether item is highlighted.
Property | HighlightForeColor | Gets or sets title's fore color if highlighted.
Property | ImageSize | Gets original image size.
Property | Page | Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Property | PageNumber | Gets page number.
Property | PrivateData | Gets or sets user data associated with the item.
Property | Selected | Gets or sets a value indicating whether item is selected.
Property | Source | Gets ImGearLoadingSelection object containing path and format of the original file.
Property | Thumbnail | Gets thumbnail bitmap representing an image.
Property | Title | Gets or sets item's title.
Top
Public Methods
 | Name | Description
Method | Update | Causes the control to redraw the invalidated regions within its client area.
Top
See Also

Reference

IImGearThumbnailItem Interface
ImageGear.Windows.Forms.Thumbnails Namespace


%%PageItemTitle%% $$Methods$$

IImGearThumbnailItem Interface Methods

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailItem Interface

For a list of all members of this type, see IImGearThumbnailItem members.

Public Methods
 | Name | Description
Method | Update | Causes the control to redraw the invalidated regions within its client area.
Top
See Also

Reference

IImGearThumbnailItem Interface
ImageGear.Windows.Forms.Thumbnails Namespace


Update Method (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Update Method
Causes the control to redraw the invalidated regions within its client area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Update()
'Usage

Dim instance As IImGearThumbnailItem

instance.Update()
void Update()
void Update();
void Update();
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


%%PageItemTitle%% $$Properties$$

IImGearThumbnailItem Interface Properties

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : IImGearThumbnailItem Interface

For a list of all members of this type, see IImGearThumbnailItem members.

Public Properties
 | Name | Description
Property | ArtPage | Gets or sets Art page associated with item.
Property | BitDepth | Gets original image bit depth.
Property | Format | Gets original image format.
Property | HighlightBackColor | Gets or sets title's back color of the highlighted item.
Property | Highlighted | Gets or sets a value indicating whether item is highlighted.
Property | HighlightForeColor | Gets or sets title's fore color if highlighted.
Property | ImageSize | Gets original image size.
Property | Page | Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Property | PageNumber | Gets page number.
Property | PrivateData | Gets or sets user data associated with the item.
Property | Selected | Gets or sets a value indicating whether item is selected.
Property | Source | Gets ImGearLoadingSelection object containing path and format of the original file.
Property | Thumbnail | Gets thumbnail bitmap representing an image.
Property | Title | Gets or sets item's title.
Top
See Also

Reference

IImGearThumbnailItem Interface
ImageGear.Windows.Forms.Thumbnails Namespace


ArtPage Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : ArtPage Property
Gets or sets Art page associated with item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property ArtPage As ImGearARTPage
'Usage

Dim instance As IImGearThumbnailItem
Dim value As ImGearARTPage

instance.ArtPage = value

value = instance.ArtPage
ImGearARTPage ArtPage {get; set;}
__property ImGearARTPage* get_ArtPage();
__property void set_ArtPage(
   ImGearARTPage* value
);
property ImGearARTPage^ ArtPage {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImageGear.ART.ImGearARTPage class object.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


BitDepth Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : BitDepth Property
Gets original image bit depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property BitDepth As Integer
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Integer

value = instance.BitDepth
int BitDepth {get;}
__property int get_BitDepth();
property int BitDepth {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Format Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Format Property
Gets original image format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Format As ImGearFormats
'Usage

Dim instance As IImGearThumbnailItem
Dim value As ImGearFormats

value = instance.Format
ImGearFormats Format {get;}
__property ImGearFormats get_Format();
property ImGearFormats Format {
   ImGearFormats get();
}

Property Value

ImageGear.Formats.ImGearFormats enumeration value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


HighlightBackColor Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : HighlightBackColor Property
Gets or sets title's back color of the highlighted item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HighlightBackColor As Color
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
Color HighlightBackColor {get; set;}
__property Color get_HighlightBackColor();
__property void set_HighlightBackColor(
   Color value
);
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Highlighted Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Highlighted Property
Gets or sets a value indicating whether item is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Highlighted As Boolean
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Boolean

instance.Highlighted = value

value = instance.Highlighted
bool Highlighted {get; set;}
__property bool get_Highlighted();
__property void set_Highlighted(
   bool value
);
property bool Highlighted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


HighlightForeColor Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : HighlightForeColor Property
Gets or sets title's fore color if highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property HighlightForeColor As Color
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
Color HighlightForeColor {get; set;}
__property Color get_HighlightForeColor();
__property void set_HighlightForeColor(
   Color value
);
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
Remarks
If not set, HighlightForeColor from thumbnail control is used.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


ImageSize Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : ImageSize Property
Gets original image size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property ImageSize As Integer
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Integer

value = instance.ImageSize
int ImageSize {get;}
__property int get_ImageSize();
property int ImageSize {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Page Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Page Property
Gets ImageGear.Core.ImGearPage class object referencing to the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Page As ImGearPage
'Usage

Dim instance As IImGearThumbnailItem
Dim value As ImGearPage

value = instance.Page
ImGearPage Page {get;}
__property ImGearPage* get_Page();
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


PageNumber Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : PageNumber Property
Gets page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property PageNumber As Integer
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Integer

value = instance.PageNumber
int PageNumber {get;}
__property int get_PageNumber();
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


PrivateData Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : PrivateData Property
Gets or sets user data associated with the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property PrivateData As Object
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Object

instance.PrivateData = value

value = instance.PrivateData
object PrivateData {get; set;}
__property Object* get_PrivateData();
__property void set_PrivateData(
   Object* value
);
property Object^ PrivateData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Any object.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Selected Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Selected Property
Gets or sets a value indicating whether item is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Selected As Boolean
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
bool Selected {get; set;}
__property bool get_Selected();
__property void set_Selected(
   bool value
);
property bool Selected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Source Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Source Property
Gets ImGearLoadingSelection object containing path and format of the original file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Source As ImGearLoadingSelection
'Usage

Dim instance As IImGearThumbnailItem
Dim value As ImGearLoadingSelection

value = instance.Source
ImGearLoadingSelection Source {get;}
__property ImGearLoadingSelection* get_Source();
property ImGearLoadingSelection^ Source {
   ImGearLoadingSelection^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearLoadingSelection class object.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Thumbnail Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Thumbnail Property
Gets thumbnail bitmap representing an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property Thumbnail As Image
'Usage

Dim instance As IImGearThumbnailItem
Dim value As Image

value = instance.Thumbnail
Image Thumbnail {get;}
__property Image* get_Thumbnail();
property Image^ Thumbnail {
   Image^ get();
}

Property Value

System.Drawing.Image class object.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


Title Property (IImGearThumbnailItem)

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace > IImGearThumbnailItem Interface : Title Property
Gets or sets item's title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property Title As String
'Usage

Dim instance As IImGearThumbnailItem
Dim value As String

instance.Title = value

value = instance.Title
string Title {get; set;}
__property string* get_Title();
__property void set_Title(
   string* value
);
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

IImGearThumbnailItem Interface
IImGearThumbnailItem Members


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventHandler Delegate

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailAfterLoadEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ItemAfterLoad event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailAfterLoadEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailAfterLoadEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailAfterLoadEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailAfterLoadEventHandler(
   object sender,
   ImGearThumbnailAfterLoadEventArgs e
)
public: __gc __delegate void ImGearThumbnailAfterLoadEventHandler(
   Object* sender,
   ImGearThumbnailAfterLoadEventArgs* e
)
public delegate void ImGearThumbnailAfterLoadEventHandler(
   Object^ sender,
   ImGearThumbnailAfterLoadEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearThumbnailAfterLoadEventHandler Members
ImageGear.Windows.Forms.Thumbnails Namespace
ItemAfterLoad Event


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventHandler Delegate

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailBeforeLoadEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ItemBeforeLoad event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailBeforeLoadEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailBeforeLoadEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailBeforeLoadEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailBeforeLoadEventHandler(
   object sender,
   ImGearThumbnailBeforeLoadEventArgs e
)
public: __gc __delegate void ImGearThumbnailBeforeLoadEventHandler(
   Object* sender,
   ImGearThumbnailBeforeLoadEventArgs* e
)
public delegate void ImGearThumbnailBeforeLoadEventHandler(
   Object^ sender,
   ImGearThumbnailBeforeLoadEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
Remarks
This delegate is used for declaring ItemBeforeLoad event.
See Also

Reference

ImGearThumbnailBeforeLoadEventHandler Members
ImageGear.Windows.Forms.Thumbnails Namespace
ItemBeforeLoad Event


%%PageItemTitle%%

ImGearThumbnailItemEventHandler Delegate

ImageGear22.Windows.Forms Assembly > ImageGear.Windows.Forms.Thumbnails Namespace : ImGearThumbnailItemEventHandler Delegate
Object that triggered the event.
Information about the event.
Used for declaring ImGearThumbnailCtl.ItemAfterCreate, ImGearThumbnailCtl.ItemBeforeDelete, ImGearThumbnailCtl.ItemClicked and ImGearThumbnailCtl.ItemDoubleClicked events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailItemEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailItemEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailItemEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailItemEventHandler(
   object sender,
   ImGearThumbnailItemEventArgs e
)
public: __gc __delegate void ImGearThumbnailItemEventHandler(
   Object* sender,
   ImGearThumbnailItemEventArgs* e
)
public delegate void ImGearThumbnailItemEventHandler(
   Object^ sender,
   ImGearThumbnailItemEventArgs^ e
)

Parameters

sender
Object that triggered the event.
e
Information about the event.
See Also

Reference

ImGearThumbnailItemEventHandler Members
ImageGear.Windows.Forms.Thumbnails Namespace
ItemAfterCreate Event
ItemBeforeDelete Event
ItemClicked Event
ItemDoubleClicked Event
ImGearThumbnailItemEventArgs Class


ImageGear22.Wpf Assembly
Namespaces
Namespace | Description
ImageGear.WPF | ImageGear.WPF namespace provides UI controls for use with the Windows Presentation Foundation framework.
ImageGear.WPF.BitmapSourceConversion | The ImageGear.WPF.BitmapSourceConversion Namespace provides BitmapSource conversion API.
ImageGear.WPF.HDP | The ImageGear.WPF.HDP Namespace provides functionality for compatibility with the HD Photo (Windows Media Photo) format.
ImageGear.WPF.XPS | ImageGear XPS namespace provides full multi-page reading, writing and printing support for XPS documents and pages. You can detect, read, write, append, insert, replace, delete and print specified pages in the XPS document as well as convert raster images to XPS.


ImageGear.WPF Namespace
Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF Namespace
ImageGear.WPF namespace provides UI controls for use with the Windows Presentation Foundation framework.
Classes
 | Class | Description
Class | ImGearFilterAttribute | Provides filtering properties for the PropertyGrid.
Class | ImGearMagnifierCtl | Provides a magnified view of a portion of the image in ImageGear.Windows.Forms.ImGearPageView control.
Class | ImGearMagnifierPopUpCtl | Provides interactive magnifying glass style pop-up control for displayed images.
Class | ImGearPanCtl | Allows the visible portion of an image displayed in the ImageGear.Windows.Forms.ImGearPageView class control to be moved by dragging the mouse around in the image.
Class | ImGearThumbnailAfterLoadEventArgs | Specifies arguments for the ImGearThumbnailAfterLoadEventHandler delegate.
Class | ImGearThumbnailBeforeLoadEventArgs | Specifies arguments for the ImGearThumbnailBeforeLoadEventHandler delegate.
Class | ImGearThumbnailCtl | Represents a thumbnail control.
Class | ImGearThumbnailItem | Represents a thumbnail item displayed in the thumbnail browser.
Class | ImGearThumbnailItemEventArgs | Specifies arguments for the ImGearThumbnailItemEventHandler delegate.
Class | ImGearThumbnailMagnifierCtl | Provides interaction logic for ThumbnailMagnifierCtl.xaml. ImGearThumbnailMagnifierCtl
Delegates
 | Delegate | Description
Delegate | ImGearThumbnailAfterLoadEventHandler | Delegate for the AfterLoad item event.
Delegate | ImGearThumbnailBeforeLoadEventHandler | Delegate for the BeforeLoad item event.
Delegate | ImGearThumbnailItemEventHandler | Delegate for the thumbnail item events.
Enumerations
 | Enumeration | Description
Enumeration | ImGearMagnifierShapeType | Specifies popup magnifier shape types.
See Also

Reference

ImageGear22.Wpf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.WPF Namespace Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF Namespace
Inheritance Hierarchy
System.Object
System.Attribute
ImageGear.WPF.ImGearFilterAttribute
System.EventArgs
System.Windows.RoutedEventArgs
ImageGear.WPF.ImGearThumbnailAfterLoadEventArgs
ImageGear.WPF.ImGearThumbnailBeforeLoadEventArgs
ImageGear.WPF.ImGearThumbnailItemEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.WPF.ImGearThumbnailItem
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.WPF.ImGearMagnifierCtl
ImageGear.WPF.ImGearMagnifierPopUpCtl
ImageGear.WPF.ImGearPanCtl
ImageGear.WPF.ImGearThumbnailCtl
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
ImageGear.WPF.ImGearThumbnailMagnifierCtl
See Also

Reference

ImageGear22.Wpf Assembly


%%PageItemTitle%%

ImGearFilterAttribute Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearFilterAttribute Class
Provides filtering properties for the PropertyGrid.
Object Model
ImGearFilterAttribute Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Module Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Constructor Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate Or  _
    AttributeTargets.ReturnValue Or  _
    AttributeTargets.GenericParameter Or  _
    AttributeTargets.All,
   AllowMultiple=False,
   Inherited=True)>
Public Class ImGearFilterAttribute
   Inherits System.Attribute
'Usage

Dim instance As ImGearFilterAttribute
[AttributeUsage(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public class ImGearFilterAttribute : System.Attribute
[AttributeUsage(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public __gc class ImGearFilterAttribute : public System.Attribute
[AttributeUsage(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public ref class ImGearFilterAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
ImageGear.WPF.ImGearFilterAttribute

See Also

Reference

ImGearFilterAttribute Members
ImageGear.WPF Namespace


%%PageItemTitle%% $$Members$$

ImGearFilterAttribute Class Members
Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearFilterAttribute Class

The following tables list the members exposed by ImGearFilterAttribute.

Public Constructors
 | Name | Description
Public Constructor | ImGearFilterAttribute Constructor | Initializes a new instance of the ImGearFilterAttribute class.
Top
See Also

Reference

ImGearFilterAttribute Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Properties$$

ImGearFilterAttribute Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearFilterAttribute Class

For a list of all members of this type, see ImGearFilterAttribute members.

See Also

Reference

ImGearFilterAttribute Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Methods$$

ImGearFilterAttribute Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearFilterAttribute Class

For a list of all members of this type, see ImGearFilterAttribute members.

See Also

Reference

ImGearFilterAttribute Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearFilterAttribute Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearFilterAttribute Class : ImGearFilterAttribute Constructor
Overload List
Overload | Description
ImGearFilterAttribute Constructor | Initializes a new instance of the ImGearFilterAttribute class.
See Also

Reference

ImGearFilterAttribute Class
ImGearFilterAttribute Members


%%PageItemTitle%%

ImGearFilterAttribute Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearFilterAttribute Class : ImGearFilterAttribute Constructor
Property filter.
Initializes a new instance of the ImGearFilterAttribute class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal filter As String _
)
'Usage

Dim filter As String

Dim instance As New ImGearFilterAttribute(filter)
public ImGearFilterAttribute(
   string filter
)
public: ImGearFilterAttribute(
   string* filter
)
public:
ImGearFilterAttribute(
   String^ filter
)

Parameters

filter
Property filter.
See Also

Reference

ImGearFilterAttribute Class
ImGearFilterAttribute Members


%%PageItemTitle%%

ImGearMagnifierCtl Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class
Provides a magnified view of a portion of the image in ImageGear.Windows.Forms.ImGearPageView control.
Object Model
ImGearMagnifierCtl ClassImGearPageView ClassImGearPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMagnifierCtl
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearMagnifierCtl
public class ImGearMagnifierCtl : System.Windows.Controls.Control
public __gc class ImGearMagnifierCtl : public System.Windows.Controls.Control
public ref class ImGearMagnifierCtl : public System.Windows.Controls.Control
Remarks
This GUI Magnifier control appears either in a separate, stationary window, or as a pop-up area within the ImageGear.Windows.Forms.ImGearPageView window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView control, the magnified display of the image tracks the location of the mouse. If the pop-up view is used, the magnified display of the image tracks the mouse within the ImGearPageView control. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView control. The programmer can set the magnification factor, and can optionally expose that capability to the end user.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.WPF.ImGearMagnifierCtl

See Also

Reference

ImGearMagnifierCtl Members
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Members$$

ImGearMagnifierCtl Class Members
Fields Properties Methods Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class

The following tables list the members exposed by ImGearMagnifierCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearMagnifierCtl Constructor | Initializes a new instance of the ImGearMagnifierCtl class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | BorderWidthProperty | Represents BorderWidth dependency property.
static (Shared in Visual Basic) | DestinationViewProperty | Represents DestinationView dependency property.
static (Shared in Visual Basic) | IsPopUpProperty | Represents IsPopUp dependency property.
static (Shared in Visual Basic) | PopupHeightProperty | Represents PopupHeight dependency property.
static (Shared in Visual Basic) | PopupWidthProperty | Represents PopupWidth dependency property.
static (Shared in Visual Basic) | ShapeTypeProperty | Represents ShapeType dependency property.
static (Shared in Visual Basic) | SourceViewHostProperty | Represents SourceViewHost dependency property.
static (Shared in Visual Basic) | SourceViewProperty | Represents SourceView dependency property.
static (Shared in Visual Basic) | ZoomProperty | Represents Zoom dependency property.
Top
Public Properties
 | Name | Description
Public Property | BorderWidth | Gets or sets width of the popup window border.
Public Property | DestinationView | Gets or sets ImageGear.Windows.Forms.ImGearPageView object used for displaying the magnified area.
Public Property | IsPopUp | Gets or sets a value indicating whether magnifier window shows right under mouse pointer.
Public Property | MagnifiedImage | Gets or sets the magnified area.
Public Property | PopupHeight | Gets or sets height of the popup magnifier window.
Public Property | PopupWidth | Gets or sets width of the popup magnifier window.
Public Property | ShapeType | Gets or sets a shape of the popup magnifier window.
Public Property | SourceView | Gets or sets ImageGear.Windows.Forms.ImGearPageView object to be magnified.
Public Property | SourceViewHost | Gets or sets UIElement that hosts SourceView object to be magnified.
Public Property | Zoom | Gets or sets zoom factor.
Top
See Also

Reference

ImGearMagnifierCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%%

ImGearMagnifierCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : ImGearMagnifierCtl Constructor
Initializes a new instance of the ImGearMagnifierCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearMagnifierCtl()
public ImGearMagnifierCtl()
public: ImGearMagnifierCtl();
public:
ImGearMagnifierCtl();
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


%%PageItemTitle%% $$Properties$$

ImGearMagnifierCtl Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class

For a list of all members of this type, see ImGearMagnifierCtl members.

Public Properties
 | Name | Description
Public Property | BorderWidth | Gets or sets width of the popup window border.
Public Property | DestinationView | Gets or sets ImageGear.Windows.Forms.ImGearPageView object used for displaying the magnified area.
Public Property | IsPopUp | Gets or sets a value indicating whether magnifier window shows right under mouse pointer.
Public Property | MagnifiedImage | Gets or sets the magnified area.
Public Property | PopupHeight | Gets or sets height of the popup magnifier window.
Public Property | PopupWidth | Gets or sets width of the popup magnifier window.
Public Property | ShapeType | Gets or sets a shape of the popup magnifier window.
Public Property | SourceView | Gets or sets ImageGear.Windows.Forms.ImGearPageView object to be magnified.
Public Property | SourceViewHost | Gets or sets UIElement that hosts SourceView object to be magnified.
Public Property | Zoom | Gets or sets zoom factor.
Top
See Also

Reference

ImGearMagnifierCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearMagnifierCtl Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class

For a list of all members of this type, see ImGearMagnifierCtl members.

See Also

Reference

ImGearMagnifierCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Events$$

ImGearMagnifierCtl Class Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class

For a list of all members of this type, see ImGearMagnifierCtl members.

See Also

Reference

ImGearMagnifierCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


BorderWidth Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : BorderWidth Property
Gets or sets width of the popup window border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property BorderWidth As Double
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
[ImGearFilter()]
public double BorderWidth {get; set;}
[ImGearFilter()]
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
[ImGearFilter()]
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


DestinationView Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : DestinationView Property
Gets or sets ImageGear.Windows.Forms.ImGearPageView object used for displaying the magnified area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ReadOnlyAttribute(True)>
Public Property DestinationView As ImGearPageView
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As ImGearPageView

instance.DestinationView = value

value = instance.DestinationView
[ReadOnly(true)]
public ImGearPageView DestinationView {get; set;}
[ReadOnly(true)]
public: __property ImGearPageView* get_DestinationView();
public: __property void set_DestinationView(
   ImGearPageView* value
);
[ReadOnly(true)]
public:
property ImGearPageView^ DestinationView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImageGear.Windows.Forms.ImGearPageView object.
Remarks
If IsPopUp is true, DestinationView can be empty.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
IsPopUp Property
ImGearPageView Class


IsPopUp Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : IsPopUp Property
Gets or sets a value indicating whether magnifier window shows right under mouse pointer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property IsPopUp As Boolean
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As Boolean

instance.IsPopUp = value

value = instance.IsPopUp
[ImGearFilter()]
public bool IsPopUp {get; set;}
[ImGearFilter()]
public: __property bool get_IsPopUp();
public: __property void set_IsPopUp(
   bool value
);
[ImGearFilter()]
public:
property bool IsPopUp {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If this property is true, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView. Default value is true.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
DestinationView Property


MagnifiedImage Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : MagnifiedImage Property
Gets or sets the magnified area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MagnifiedImage As BitmapSource
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As BitmapSource

instance.MagnifiedImage = value

value = instance.MagnifiedImage
public BitmapSource MagnifiedImage {get; set;}
public: __property BitmapSource* get_MagnifiedImage();
public: __property void set_MagnifiedImage(
   BitmapSource* value
);
public:
property BitmapSource^ MagnifiedImage {
   BitmapSource^ get();
   void set (    BitmapSource^ value);
}

Property Value

System.Windows.Media.Imaging.BitmapSource object.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


PopupHeight Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : PopupHeight Property
Gets or sets height of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property PopupHeight As Integer
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As Integer

instance.PopupHeight = value

value = instance.PopupHeight
[ImGearFilter()]
public int PopupHeight {get; set;}
[ImGearFilter()]
public: __property int get_PopupHeight();
public: __property void set_PopupHeight(
   int value
);
[ImGearFilter()]
public:
property int PopupHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
PopupWidth Property


PopupWidth Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : PopupWidth Property
Gets or sets width of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property PopupWidth As Integer
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As Integer

instance.PopupWidth = value

value = instance.PopupWidth
[ImGearFilter()]
public int PopupWidth {get; set;}
[ImGearFilter()]
public: __property int get_PopupWidth();
public: __property void set_PopupWidth(
   int value
);
[ImGearFilter()]
public:
property int PopupWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
PopupHeight Property


ShapeType Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : ShapeType Property
Gets or sets a shape of the popup magnifier window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property ShapeType As ImGearMagnifierShapeType
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As ImGearMagnifierShapeType

instance.ShapeType = value

value = instance.ShapeType
[ImGearFilter()]
public ImGearMagnifierShapeType ShapeType {get; set;}
[ImGearFilter()]
public: __property ImGearMagnifierShapeType get_ShapeType();
public: __property void set_ShapeType(
   ImGearMagnifierShapeType value
);
[ImGearFilter()]
public:
property ImGearMagnifierShapeType ShapeType {
   ImGearMagnifierShapeType get();
   void set (    ImGearMagnifierShapeType value);
}

Property Value

ImGearMagnifierShapeType enumeration value.
Remarks
Can be either rectangle or ellipse. Default value is ImGearMagnifierShapeType.Rectangle.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
ImGearMagnifierShapeType Enumeration


SourceView Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : SourceView Property
Gets or sets ImageGear.Windows.Forms.ImGearPageView object to be magnified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ReadOnlyAttribute(True)>
Public Property SourceView As ImGearPageView
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As ImGearPageView

instance.SourceView = value

value = instance.SourceView
[ReadOnly(true)]
public ImGearPageView SourceView {get; set;}
[ReadOnly(true)]
public: __property ImGearPageView* get_SourceView();
public: __property void set_SourceView(
   ImGearPageView* value
);
[ReadOnly(true)]
public:
property ImGearPageView^ SourceView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImageGear.Windows.Forms.ImGearPageView object.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members
ImGearPageView Class


SourceViewHost Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : SourceViewHost Property
Gets or sets UIElement that hosts SourceView object to be magnified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ReadOnlyAttribute(True)>
Public Property SourceViewHost As UIElement
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As UIElement

instance.SourceViewHost = value

value = instance.SourceViewHost
[ReadOnly(true)]
public UIElement SourceViewHost {get; set;}
[ReadOnly(true)]
public: __property UIElement* get_SourceViewHost();
public: __property void set_SourceViewHost(
   UIElement* value
);
[ReadOnly(true)]
public:
property UIElement^ SourceViewHost {
   UIElement^ get();
   void set (    UIElement^ value);
}

Property Value

System.Windows.UIElement object.
Remarks
It is required to create a popup window in WPF.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


Zoom Property (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : Zoom Property
Gets or sets zoom factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
Public Property Zoom As Double
'Usage

Dim instance As ImGearMagnifierCtl
Dim value As Double

instance.Zoom = value

value = instance.Zoom
[ImGearFilter()]
public double Zoom {get; set;}
[ImGearFilter()]
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
[ImGearFilter()]
public:
property double Zoom {
   double get();
   void set (    double value);
}

Property Value

Double value between 1 and 500.
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


%%PageItemTitle%% $$Fields$$

ImGearMagnifierCtl Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierCtl Class

For a list of all members of this type, see ImGearMagnifierCtl members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | BorderWidthProperty | Represents BorderWidth dependency property.
static (Shared in Visual Basic) | DestinationViewProperty | Represents DestinationView dependency property.
static (Shared in Visual Basic) | IsPopUpProperty | Represents IsPopUp dependency property.
static (Shared in Visual Basic) | PopupHeightProperty | Represents PopupHeight dependency property.
static (Shared in Visual Basic) | PopupWidthProperty | Represents PopupWidth dependency property.
static (Shared in Visual Basic) | ShapeTypeProperty | Represents ShapeType dependency property.
static (Shared in Visual Basic) | SourceViewHostProperty | Represents SourceViewHost dependency property.
static (Shared in Visual Basic) | SourceViewProperty | Represents SourceView dependency property.
static (Shared in Visual Basic) | ZoomProperty | Represents Zoom dependency property.
Top
See Also

Reference

ImGearMagnifierCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


BorderWidthProperty Field (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : BorderWidthProperty Field
Represents BorderWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly BorderWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.BorderWidthProperty
public static readonly DependencyProperty BorderWidthProperty
public: static readonly DependencyProperty* BorderWidthProperty
public:
static readonly DependencyProperty^ BorderWidthProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


DestinationViewProperty Field (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : DestinationViewProperty Field
Represents DestinationView dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DestinationViewProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.DestinationViewProperty
public static readonly DependencyProperty DestinationViewProperty
public: static readonly DependencyProperty* DestinationViewProperty
public:
static readonly DependencyProperty^ DestinationViewProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


IsPopUpProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : IsPopUpProperty Field
Represents IsPopUp dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsPopUpProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.IsPopUpProperty
public static readonly DependencyProperty IsPopUpProperty
public: static readonly DependencyProperty* IsPopUpProperty
public:
static readonly DependencyProperty^ IsPopUpProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


PopupHeightProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : PopupHeightProperty Field
Represents PopupHeight dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PopupHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.PopupHeightProperty
public static readonly DependencyProperty PopupHeightProperty
public: static readonly DependencyProperty* PopupHeightProperty
public:
static readonly DependencyProperty^ PopupHeightProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


PopupWidthProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : PopupWidthProperty Field
Represents PopupWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PopupWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.PopupWidthProperty
public static readonly DependencyProperty PopupWidthProperty
public: static readonly DependencyProperty* PopupWidthProperty
public:
static readonly DependencyProperty^ PopupWidthProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


ShapeTypeProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : ShapeTypeProperty Field
Represents ShapeType dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ShapeTypeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.ShapeTypeProperty
public static readonly DependencyProperty ShapeTypeProperty
public: static readonly DependencyProperty* ShapeTypeProperty
public:
static readonly DependencyProperty^ ShapeTypeProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


SourceViewHostProperty Field (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : SourceViewHostProperty Field
Represents SourceViewHost dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SourceViewHostProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.SourceViewHostProperty
public static readonly DependencyProperty SourceViewHostProperty
public: static readonly DependencyProperty* SourceViewHostProperty
public:
static readonly DependencyProperty^ SourceViewHostProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


SourceViewProperty Field (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : SourceViewProperty Field
Represents SourceView dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SourceViewProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.SourceViewProperty
public static readonly DependencyProperty SourceViewProperty
public: static readonly DependencyProperty* SourceViewProperty
public:
static readonly DependencyProperty^ SourceViewProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


ZoomProperty Field (ImGearMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierCtl Class : ZoomProperty Field
Represents Zoom dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearMagnifierCtl.ZoomProperty
public static readonly DependencyProperty ZoomProperty
public: static readonly DependencyProperty* ZoomProperty
public:
static readonly DependencyProperty^ ZoomProperty
See Also

Reference

ImGearMagnifierCtl Class
ImGearMagnifierCtl Members


%%PageItemTitle%%

ImGearMagnifierPopUpCtl Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierPopUpCtl Class
Provides interactive magnifying glass style pop-up control for displayed images.
Object Model
ImGearMagnifierPopUpCtl ClassImGearMagnifierCtl Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearMagnifierPopUpCtl
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearMagnifierPopUpCtl
public class ImGearMagnifierPopUpCtl : System.Windows.Controls.Control
public __gc class ImGearMagnifierPopUpCtl : public System.Windows.Controls.Control
public ref class ImGearMagnifierPopUpCtl : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.WPF.ImGearMagnifierPopUpCtl

See Also

Reference

ImGearMagnifierPopUpCtl Members
ImageGear.WPF Namespace


%%PageItemTitle%% $$Members$$

ImGearMagnifierPopUpCtl Class Members
Properties Methods Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierPopUpCtl Class

The following tables list the members exposed by ImGearMagnifierPopUpCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearMagnifierPopUpCtl Constructor | Initializes a new instance of the ImGearMagnifierPopUpCtl class.
Top
Public Properties
 | Name | Description
Public Property | Center | Gets a popup center point.
Public Property | ImageRadius | Gets horizontal and vertical radius of the ellipse.
Public Property | ParentCtl | Gets a reference to ImGearMagnifierCtl object that contains magnifier parameters.
Top
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearMagnifierPopUpCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierPopUpCtl Class : ImGearMagnifierPopUpCtl Constructor
Reference to ImGearMagnifierCtl that contains magnifier parameters.
Initializes a new instance of the ImGearMagnifierPopUpCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As ImGearMagnifierCtl _
)
'Usage

Dim parent As ImGearMagnifierCtl

Dim instance As New ImGearMagnifierPopUpCtl(parent)
public ImGearMagnifierPopUpCtl(
   ImGearMagnifierCtl parent
)
public: ImGearMagnifierPopUpCtl(
   ImGearMagnifierCtl* parent
)
public:
ImGearMagnifierPopUpCtl(
   ImGearMagnifierCtl^ parent
)

Parameters

parent
Reference to ImGearMagnifierCtl that contains magnifier parameters.
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImGearMagnifierPopUpCtl Members
ImGearMagnifierCtl Class


%%PageItemTitle%% $$Properties$$

ImGearMagnifierPopUpCtl Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierPopUpCtl Class

For a list of all members of this type, see ImGearMagnifierPopUpCtl members.

Public Properties
 | Name | Description
Public Property | Center | Gets a popup center point.
Public Property | ImageRadius | Gets horizontal and vertical radius of the ellipse.
Public Property | ParentCtl | Gets a reference to ImGearMagnifierCtl object that contains magnifier parameters.
Top
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Methods$$

ImGearMagnifierPopUpCtl Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierPopUpCtl Class

For a list of all members of this type, see ImGearMagnifierPopUpCtl members.

See Also

Reference

ImGearMagnifierPopUpCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Events$$

ImGearMagnifierPopUpCtl Class Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierPopUpCtl Class

For a list of all members of this type, see ImGearMagnifierPopUpCtl members.

See Also

Reference

ImGearMagnifierPopUpCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearMagnifierPopUpCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierPopUpCtl Class : ImGearMagnifierPopUpCtl Constructor
Overload List
Overload | Description
ImGearMagnifierPopUpCtl Constructor | Initializes a new instance of the ImGearMagnifierPopUpCtl class.
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImGearMagnifierPopUpCtl Members


Center Property (ImGearMagnifierPopUpCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierPopUpCtl Class : Center Property
Gets a popup center point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Center As Point
'Usage

Dim instance As ImGearMagnifierPopUpCtl
Dim value As Point

value = instance.Center
public Point Center {get;}
public: __property Point get_Center();
public:
property Point Center {
   Point get();
}

Property Value

System.Windows.Point value.
Remarks
Required to build geometric path in XAML file.
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImGearMagnifierPopUpCtl Members


ImageRadius Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierPopUpCtl Class : ImageRadius Property
Gets horizontal and vertical radius of the ellipse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageRadius As Size
'Usage

Dim instance As ImGearMagnifierPopUpCtl
Dim value As Size

value = instance.ImageRadius
public Size ImageRadius {get;}
public: __property Size get_ImageRadius();
public:
property Size ImageRadius {
   Size get();
}

Property Value

System.Windows.Size value.
Remarks
Required to build geometric path in XAML file.
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImGearMagnifierPopUpCtl Members


ParentCtl Property (ImGearMagnifierPopUpCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearMagnifierPopUpCtl Class : ParentCtl Property
Gets a reference to ImGearMagnifierCtl object that contains magnifier parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ParentCtl As ImGearMagnifierCtl
'Usage

Dim instance As ImGearMagnifierPopUpCtl
Dim value As ImGearMagnifierCtl

value = instance.ParentCtl
public ImGearMagnifierCtl ParentCtl {get;}
public: __property ImGearMagnifierCtl* get_ParentCtl();
public:
property ImGearMagnifierCtl^ ParentCtl {
   ImGearMagnifierCtl^ get();
}

Property Value

ImGearMagnifierCtl class object.
See Also

Reference

ImGearMagnifierPopUpCtl Class
ImGearMagnifierPopUpCtl Members
ImGearMagnifierCtl Class


%%PageItemTitle%%

ImGearPanCtl Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class
Allows the visible portion of an image displayed in the ImageGear.Windows.Forms.ImGearPageView class control to be moved by dragging the mouse around in the image.
Object Model
ImGearPanCtl ClassImGearPageView ClassImGearPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearPanCtl
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearPanCtl
public class ImGearPanCtl : System.Windows.Controls.Control
public __gc class ImGearPanCtl : public System.Windows.Controls.Control
public ref class ImGearPanCtl : public System.Windows.Controls.Control
Remarks
Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImageGear.Windows.Forms.ImGearPageView class control is repositioned. The portion of the image that is visible in the ImageGear.Windows.Forms.ImGearPageView class control is displayed within the floating window in reverse video.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.WPF.ImGearPanCtl

See Also

Reference

ImGearPanCtl Members
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Members$$

ImGearPanCtl Class Members
Fields Properties Methods Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class

The following tables list the members exposed by ImGearPanCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearPanCtl Constructor | Initializes a new instance of the ImGearPanCtl class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | DestinationViewProperty | Represents DestinationView dependency property.
static (Shared in Visual Basic) | PanButtonProperty | Represents PanButton dependency property.
static (Shared in Visual Basic) | SourceViewHostProperty | Represents SourceViewHost dependency property.
static (Shared in Visual Basic) | SourceViewProperty | Represents SourceView dependency property.
Top
Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets a cursor used while panning the page area.
Public Property | DestinationView | Gets or sets ImageGear.Windows.Forms.ImGearPageView class object used for displaying the panning area.
Public Property | PanButton | Gets or sets a value indicating which mouse button used for panning.
Public Property | SourceView | Gets or sets ImageGear.Windows.Forms.ImGearPageView class object to apply panning functionality to.
Top
See Also

Reference

ImGearPanCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%%

ImGearPanCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : ImGearPanCtl Constructor
Initializes a new instance of the ImGearPanCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearPanCtl()
public ImGearPanCtl()
public: ImGearPanCtl();
public:
ImGearPanCtl();
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


%%PageItemTitle%% $$Properties$$

ImGearPanCtl Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class

For a list of all members of this type, see ImGearPanCtl members.

Public Properties
 | Name | Description
Public Property | Cursor | Gets or sets a cursor used while panning the page area.
Public Property | DestinationView | Gets or sets ImageGear.Windows.Forms.ImGearPageView class object used for displaying the panning area.
Public Property | PanButton | Gets or sets a value indicating which mouse button used for panning.
Public Property | SourceView | Gets or sets ImageGear.Windows.Forms.ImGearPageView class object to apply panning functionality to.
Top
See Also

Reference

ImGearPanCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Methods$$

ImGearPanCtl Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class

For a list of all members of this type, see ImGearPanCtl members.

See Also

Reference

ImGearPanCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


%%PageItemTitle%% $$Events$$

ImGearPanCtl Class Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class

For a list of all members of this type, see ImGearPanCtl members.

See Also

Reference

ImGearPanCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


Cursor Property (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : Cursor Property
Gets or sets a cursor used while panning the page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Mouse cursor for source view.")>
Public Shadows Property Cursor As Cursor
'Usage

Dim instance As ImGearPanCtl
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
[Browsable(false)]
[Description("Mouse cursor for source view.")]
public new Cursor Cursor {get; set;}
[Browsable(false)]
[Description("Mouse cursor for source view.")]
public: __property new Cursor* get_Cursor();
public: __property new void set_Cursor(
   Cursor* value
);
[Browsable(false)]
[Description("Mouse cursor for source view.")]
public:
new property Cursor^ Cursor {
   Cursor^ get();
   void set (    Cursor^ value);
}

Property Value

System.Windows.Forms.Cursor value.
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


DestinationView Property (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : DestinationView Property
Gets or sets ImageGear.Windows.Forms.ImGearPageView class object used for displaying the panning area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ReadOnlyAttribute(True)>
<ImGearFilterAttribute()>
Public Property DestinationView As ImGearPageView
'Usage

Dim instance As ImGearPanCtl
Dim value As ImGearPageView

instance.DestinationView = value

value = instance.DestinationView
[ReadOnly(true)]
[ImGearFilter()]
public ImGearPageView DestinationView {get; set;}
[ReadOnly(true)]
[ImGearFilter()]
public: __property ImGearPageView* get_DestinationView();
public: __property void set_DestinationView(
   ImGearPageView* value
);
[ReadOnly(true)]
[ImGearFilter()]
public:
property ImGearPageView^ DestinationView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImageGear.Windows.Forms.ImGearPageView object.
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members
ImGearPageView Class


PanButton Property (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : PanButton Property
Gets or sets a value indicating which mouse button used for panning.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Mouse button on which panning is to be executed.")>
<ImGearFilterAttribute()>
Public Property PanButton As MouseButtons
'Usage

Dim instance As ImGearPanCtl
Dim value As MouseButtons

instance.PanButton = value

value = instance.PanButton
[Description("Mouse button on which panning is to be executed.")]
[ImGearFilter()]
public MouseButtons PanButton {get; set;}
[Description("Mouse button on which panning is to be executed.")]
[ImGearFilter()]
public: __property MouseButtons get_PanButton();
public: __property void set_PanButton(
   MouseButtons value
);
[Description("Mouse button on which panning is to be executed.")]
[ImGearFilter()]
public:
property MouseButtons PanButton {
   MouseButtons get();
   void set (    MouseButtons value);
}

Property Value

System.Windows.Forms.MouseButtons value.
Remarks
Default value is MouseButtons.Left.
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


SourceView Property (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : SourceView Property
Gets or sets ImageGear.Windows.Forms.ImGearPageView class object to apply panning functionality to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ReadOnlyAttribute(True)>
Public Property SourceView As ImGearPageView
'Usage

Dim instance As ImGearPanCtl
Dim value As ImGearPageView

instance.SourceView = value

value = instance.SourceView
[ReadOnly(true)]
public ImGearPageView SourceView {get; set;}
[ReadOnly(true)]
public: __property ImGearPageView* get_SourceView();
public: __property void set_SourceView(
   ImGearPageView* value
);
[ReadOnly(true)]
public:
property ImGearPageView^ SourceView {
   ImGearPageView^ get();
   void set (    ImGearPageView^ value);
}

Property Value

ImageGear.Windows.Forms.ImGearPageView object.
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members
ImGearPageView Class


%%PageItemTitle%% $$Fields$$

ImGearPanCtl Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearPanCtl Class

For a list of all members of this type, see ImGearPanCtl members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CursorProperty | Represents Cursor dependency property.
static (Shared in Visual Basic) | DestinationViewProperty | Represents DestinationView dependency property.
static (Shared in Visual Basic) | PanButtonProperty | Represents PanButton dependency property.
static (Shared in Visual Basic) | SourceViewHostProperty | Represents SourceViewHost dependency property.
static (Shared in Visual Basic) | SourceViewProperty | Represents SourceView dependency property.
Top
See Also

Reference

ImGearPanCtl Class
ImageGear.WPF Namespace
ImGearPageView Class


CursorProperty Field (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : CursorProperty Field
Represents Cursor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CursorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPanCtl.CursorProperty
public static readonly DependencyProperty CursorProperty
public: static readonly DependencyProperty* CursorProperty
public:
static readonly DependencyProperty^ CursorProperty
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


DestinationViewProperty Field (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : DestinationViewProperty Field
Represents DestinationView dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DestinationViewProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPanCtl.DestinationViewProperty
public static readonly DependencyProperty DestinationViewProperty
public: static readonly DependencyProperty* DestinationViewProperty
public:
static readonly DependencyProperty^ DestinationViewProperty
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


PanButtonProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : PanButtonProperty Field
Represents PanButton dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PanButtonProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPanCtl.PanButtonProperty
public static readonly DependencyProperty PanButtonProperty
public: static readonly DependencyProperty* PanButtonProperty
public:
static readonly DependencyProperty^ PanButtonProperty
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


SourceViewHostProperty Field (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : SourceViewHostProperty Field
Represents SourceViewHost dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SourceViewHostProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPanCtl.SourceViewHostProperty
public static readonly DependencyProperty SourceViewHostProperty
public: static readonly DependencyProperty* SourceViewHostProperty
public:
static readonly DependencyProperty^ SourceViewHostProperty
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


SourceViewProperty Field (ImGearPanCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearPanCtl Class : SourceViewProperty Field
Represents SourceView dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SourceViewProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearPanCtl.SourceViewProperty
public static readonly DependencyProperty SourceViewProperty
public: static readonly DependencyProperty* SourceViewProperty
public:
static readonly DependencyProperty^ SourceViewProperty
See Also

Reference

ImGearPanCtl Class
ImGearPanCtl Members


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventArgs Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailAfterLoadEventArgs Class
Specifies arguments for the ImGearThumbnailAfterLoadEventHandler delegate.
Object Model
ImGearThumbnailAfterLoadEventArgs ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailAfterLoadEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
public class ImGearThumbnailAfterLoadEventArgs : System.Windows.RoutedEventArgs
public __gc class ImGearThumbnailAfterLoadEventArgs : public System.Windows.RoutedEventArgs
public ref class ImGearThumbnailAfterLoadEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
ImageGear.WPF.ImGearThumbnailAfterLoadEventArgs

See Also

Reference

ImGearThumbnailAfterLoadEventArgs Members
ImageGear.WPF Namespace
ImGearThumbnailAfterLoadEventHandler Delegate


%%PageItemTitle%% $$Members$$

ImGearThumbnailAfterLoadEventArgs Class Members
Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailAfterLoadEventArgs Class

The following tables list the members exposed by ImGearThumbnailAfterLoadEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailAfterLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailAfterLoadEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Top
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailAfterLoadEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailAfterLoadEventArgs Class : ImGearThumbnailAfterLoadEventArgs Constructor
Reference to event object.
ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Flag indicating whether or not to load thumbnail into a control.
Initializes a new instance of the ImGearThumbnailAfterLoadEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal routedEvent As RoutedEvent, _
   ByVal page As ImGearPage, _
   ByVal skip As Boolean _
)
'Usage

Dim routedEvent As RoutedEvent
Dim page As ImGearPage
Dim skip As Boolean

Dim instance As New ImGearThumbnailAfterLoadEventArgs(routedEvent, page, skip)
public ImGearThumbnailAfterLoadEventArgs(
   RoutedEvent routedEvent,
   ImGearPage page,
   bool skip
)
public: ImGearThumbnailAfterLoadEventArgs(
   RoutedEvent* routedEvent,
   ImGearPage* page,
   bool skip
)
public:
ImGearThumbnailAfterLoadEventArgs(
   RoutedEvent^ routedEvent,
   ImGearPage^ page,
   bool skip
)

Parameters

routedEvent
Reference to event object.
page
ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
skip
Flag indicating whether or not to load thumbnail into a control.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members
ImGearPage Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailAfterLoadEventArgs Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailAfterLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailAfterLoadEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Top
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailAfterLoadEventHandler Delegate


%%PageItemTitle%% $$Methods$$

ImGearThumbnailAfterLoadEventArgs Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailAfterLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailAfterLoadEventArgs members.

See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailAfterLoadEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailAfterLoadEventArgs Class : ImGearThumbnailAfterLoadEventArgs Constructor
Overload List
Overload | Description
ImGearThumbnailAfterLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailAfterLoadEventArgs class.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members


Page Property (ImGearThumbnailAfterLoadEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailAfterLoadEventArgs Class : Page Property
Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage object.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members
ImGearPage Class


Skip Property (ImGearThumbnailAfterLoadEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailAfterLoadEventArgs Class : Skip Property
Gets or sets a value indicating whether or not to load thumbnail into a control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Skip As Boolean
'Usage

Dim instance As ImGearThumbnailAfterLoadEventArgs
Dim value As Boolean

instance.Skip = value

value = instance.Skip
public bool Skip {get; set;}
public: __property bool get_Skip();
public: __property void set_Skip(
   bool value
);
public:
property bool Skip {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Client should set this to true if there is no need to load thumbnail into a control.
See Also

Reference

ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs Members


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventArgs Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailBeforeLoadEventArgs Class
Specifies arguments for the ImGearThumbnailBeforeLoadEventHandler delegate.
Object Model
ImGearThumbnailBeforeLoadEventArgs ClassImGearPage ClassImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailBeforeLoadEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
public class ImGearThumbnailBeforeLoadEventArgs : System.Windows.RoutedEventArgs
public __gc class ImGearThumbnailBeforeLoadEventArgs : public System.Windows.RoutedEventArgs
public ref class ImGearThumbnailBeforeLoadEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
ImageGear.WPF.ImGearThumbnailBeforeLoadEventArgs

See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Members
ImageGear.WPF Namespace
ImGearThumbnailBeforeLoadEventHandler Delegate


%%PageItemTitle%% $$Members$$

ImGearThumbnailBeforeLoadEventArgs Class Members
Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailBeforeLoadEventArgs Class

The following tables list the members exposed by ImGearThumbnailBeforeLoadEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailBeforeLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailBeforeLoadEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Public Property | PageNumber | Gets the page number of the currently loaded thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Public Property | ThumbnailSource | Gets the path and the format of the currently loaded thumbnail.
Top
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailBeforeLoadEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : ImGearThumbnailBeforeLoadEventArgs Constructor
Reference to event object.
Reference to ImageGear.Windows.Forms.ImGearLoadingSelection object that contains path and format of the currently loaded thumbnail.
ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Page number of the currently loaded thumbnail.
Flag indicating whether or not to load thumbnail into a control.
Initializes a new instance of the ImGearThumbnailBeforeLoadEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As ImGearLoadingSelection, _
   ByVal page As ImGearPage, _
   ByVal pageNumber As Integer, _
   ByVal skip As Boolean _
)
'Usage

Dim routedEvent As RoutedEvent
Dim source As ImGearLoadingSelection
Dim page As ImGearPage
Dim pageNumber As Integer
Dim skip As Boolean

Dim instance As New ImGearThumbnailBeforeLoadEventArgs(routedEvent, source, page, pageNumber, skip)
public ImGearThumbnailBeforeLoadEventArgs(
   RoutedEvent routedEvent,
   ImGearLoadingSelection source,
   ImGearPage page,
   int pageNumber,
   bool skip
)
public: ImGearThumbnailBeforeLoadEventArgs(
   RoutedEvent* routedEvent,
   ImGearLoadingSelection* source,
   ImGearPage* page,
   int pageNumber,
   bool skip
)
public:
ImGearThumbnailBeforeLoadEventArgs(
   RoutedEvent^ routedEvent,
   ImGearLoadingSelection^ source,
   ImGearPage^ page,
   int pageNumber,
   bool skip
)

Parameters

routedEvent
Reference to event object.
source
Reference to ImageGear.Windows.Forms.ImGearLoadingSelection object that contains path and format of the currently loaded thumbnail.
page
ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
pageNumber
Page number of the currently loaded thumbnail.
skip
Flag indicating whether or not to load thumbnail into a control.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearPage Class
ImGearLoadingSelection Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailBeforeLoadEventArgs Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailBeforeLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailBeforeLoadEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Public Property | PageNumber | Gets the page number of the currently loaded thumbnail.
Public Property | Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Public Property | ThumbnailSource | Gets the path and the format of the currently loaded thumbnail.
Top
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailBeforeLoadEventHandler Delegate


%%PageItemTitle%% $$Methods$$

ImGearThumbnailBeforeLoadEventArgs Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailBeforeLoadEventArgs Class

For a list of all members of this type, see ImGearThumbnailBeforeLoadEventArgs members.

See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImageGear.WPF Namespace
ImGearThumbnailBeforeLoadEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : ImGearThumbnailBeforeLoadEventArgs Constructor
Overload List
Overload | Description
ImGearThumbnailBeforeLoadEventArgs Constructor | Initializes a new instance of the ImGearThumbnailBeforeLoadEventArgs class.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members


Page Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : Page Property
Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage object.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearPage Class


PageNumber Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : PageNumber Property
Gets the page number of the currently loaded thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members


Skip Property (ImGearThumbnailBeforeLoadEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : Skip Property
Gets or sets a value indicating whether or not to load thumbnail into a control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Skip As Boolean
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As Boolean

instance.Skip = value

value = instance.Skip
public bool Skip {get; set;}
public: __property bool get_Skip();
public: __property void set_Skip(
   bool value
);
public:
property bool Skip {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Client should set this to true if there is no need to load thumbnail into a control.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members


ThumbnailSource Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailBeforeLoadEventArgs Class : ThumbnailSource Property
Gets the path and the format of the currently loaded thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ThumbnailSource As ImGearLoadingSelection
'Usage

Dim instance As ImGearThumbnailBeforeLoadEventArgs
Dim value As ImGearLoadingSelection

value = instance.ThumbnailSource
public ImGearLoadingSelection ThumbnailSource {get;}
public: __property ImGearLoadingSelection* get_ThumbnailSource();
public:
property ImGearLoadingSelection^ ThumbnailSource {
   ImGearLoadingSelection^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearLoadingSelection object.
See Also

Reference

ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs Members
ImGearLoadingSelection Class


%%PageItemTitle%%

ImGearThumbnailCtl Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class
Represents a thumbnail control.
Object Model
ImGearThumbnailCtl Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplatePartAttribute(Name="PART_ThumbnailListBox", Type=System.Windows.Controls.ListBox)>
Public Class ImGearThumbnailCtl
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ImGearThumbnailCtl
[TemplatePart(Name="PART_ThumbnailListBox", Type=System.Windows.Controls.ListBox)]
public class ImGearThumbnailCtl : System.Windows.Controls.Control
[TemplatePart(Name="PART_ThumbnailListBox", Type=System.Windows.Controls.ListBox)]
public __gc class ImGearThumbnailCtl : public System.Windows.Controls.Control
[TemplatePart(Name="PART_ThumbnailListBox", Type=System.Windows.Controls.ListBox)]
public ref class ImGearThumbnailCtl : public System.Windows.Controls.Control
Remarks
Every thumbnail is associated with ImGearThumbnailItem object containing full information about the image. The collection of ImGearThumbnailItem objects is implemented within the Thumbnail control.
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
ImageGear.WPF.ImGearThumbnailCtl

See Also

Reference

ImGearThumbnailCtl Members
ImageGear.WPF Namespace
ImGearThumbnailItem Class


%%PageItemTitle%% $$Members$$

ImGearThumbnailCtl Class Members
Fields Properties Methods Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class

The following tables list the members exposed by ImGearThumbnailCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailCtl Constructor | Initializes a new instance of the ImGearThumbnailCtl class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AllPagesProperty | Represents AllPages dependency property.
static (Shared in Visual Basic) | AutoFocusProperty | Represents AutoFocus dependency property.
static (Shared in Visual Basic) | BorderWidthProperty | Represents BorderWidth dependency property.
static (Shared in Visual Basic) | DragDropOptionsProperty | Represents DragDropOptions dependency property.
static (Shared in Visual Basic) | HighlightBackColorProperty | Represents HighlightBackColor dependency property.
static (Shared in Visual Basic) | HighlightForeColorProperty | Represents HighlightForeColor dependency property.
static (Shared in Visual Basic) | InteriorProperty | Represents Interior dependency property.
static (Shared in Visual Basic) | ItemHeightProperty | Represents ItemHeight dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Represents ItemWidth dependency property.
static (Shared in Visual Basic) | MarginProperty | Represents Margin dependency property.
static (Shared in Visual Basic) | ScrollBarVisibilityProperty | Represents ScrollBarVisibility dependency property.
static (Shared in Visual Basic) | SelectionBackColorProperty | Represents SelectionBackColor dependency property.
static (Shared in Visual Basic) | SelectionForeColorProperty | Represents SelectionForeColor dependency property.
static (Shared in Visual Basic) | SelectionModeProperty | Represents SelectionMode dependency property.
static (Shared in Visual Basic) | ShadowsVisibilityProperty | Represents ShadowsVisibility dependency property.
static (Shared in Visual Basic) | ShadowWidthProperty | Represents ShadowWidth dependency property.
static (Shared in Visual Basic) | ShowMagnifyProperty | Represents ShowMagnify dependency property.
static (Shared in Visual Basic) | SortComparerProperty | Represents SortComparer dependency property.
static (Shared in Visual Basic) | SortProperty | Represents Sort dependency property.
static (Shared in Visual Basic) | TitleHeightProperty | Represents TitleHeight dependency property.
static (Shared in Visual Basic) | TitlesVisibilityProperty | Represents TitlesVisibility dependency property.
static (Shared in Visual Basic) | XSpacingProperty | Represents XSpacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Represents YSpacing dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomFactor dependency property.
Top
Public Properties
 | Name | Description
Public Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image will be loaded into thumbnails.
Public Property | AutoFocus | Gets or sets a value indicating whether the thumbnail browser gets focus when the mouse cursor is on the window.
Public Property | BorderWidth | Gets or sets the border width, in pixels, around the thumbnail.
Public Property | CellSize | Gets the full thumbnail item size, including size of item itself and spacing.
Public Property | Count | Gets the number of items within the Thumbnail control.
Public Property | DragDropOptions | Gets or sets a value specifying whether the thumbnail browser can be a Drag source, Drop target or both.
Public Property | FontFamily | Gets or sets title's font family.
Public Property | FontSize | Gets or sets title's font size.
Public Property | FontStretch | Gets or sets title's font stretch.
Public Property | FontStyle | Gets or sets title's font style.
Public Property | FontWeight | Gets or sets title's font weight.
Public Property | HighlightBackColor | Gets or sets the color to use as a background for the highlighted Thumbnail item.
Public Property | HighlightForeColor | Gets or sets the color to use as a foreground for a highlighted Thumbnail item.
Public Property | ImageSize | Gets the thumbnail image size.
Public Property | Interior | Gets or sets the amount of extra space around the thumbnail item.
Public Property | ItemHeight | Gets or sets the height, in pixels, of the image to be drawn in each thumbnail item.
Public Property | ItemWidth | Gets or sets the width, in pixels, of the image to be drawn in each thumbnail item.
Public Property | Margin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Public Property | SelectionBackColor | Gets or sets default background color for selected items.
Public Property | SelectionForeColor | Gets or sets default foreground color for selected items.
Public Property | SelectionMode | Gets or sets the selection mode for items.
Public Property | ShadowsVisibility | Gets or sets a value specifying item's shadow visibility.
Public Property | ShadowWidth | Gets or sets the width of item's shadow.
Public Property | ShowMagnify | Gets or sets a value indicating whether a larger popup image will appear by pressing the right-mouse-button down.
Public Property | Sort | Gets or sets a value specifying sort mode used when a new item is added.
Public Property | SortComparer | Gets or sets an object of a class implementing IComparer interface to make user sorting.
Public Property | Thumbnails | Gets the collection of all items.
Public Property | TitleHeight | Gets or sets the height of the item title.
Public Property | TitlesVisibility | Gets or sets a value specifying thumbnails title visibility.
Public Property | VerticalScrollBarVisibility | Gets or sets a value specifying if vertical scrollbar should appear when all items do not fit in the control.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Public Property | ZoomFactor | Gets or sets a value specifying zoom factor for displaying the magnified popup image.
Top
Public Methods
 | Name | Description
Public Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Public Method | DeleteItem | Removes the specified item from the Thumbnail control.
Public Method | DirectoryAppend | Creates a series of thumbnail items.
Public Method | DocumentAppend | Appends all pages from ImageGear.Core.ImGearDocument object to the Thumbnail control.
Public Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Public Method | OnApplyTemplate | Overridden. Override to add setting up of events for template parts.
Public Method | PageAppend | Appends ImageGear.Core.ImGearPage object to the Thumbnail control.
Public Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Public Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
Public Events
 | Name | Description
Public Event | ItemAfterCreate | This event is called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemAfterLoad | This event is called during the process of creating a thumbnail item.
Public Event | ItemBeforeDelete | This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Public Event | ItemBeforeLoad | This event is called during the process of creating a thumbnail item.
Public Event | ItemClicked | This event is called to indicate that the user clicked somewhere within the thumbnail control.
Public Event | ItemDoubleClicked | This event is called to indicate that the user double-clicked somewhere within the thumbnail control.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.WPF Namespace
ImGearThumbnailItem Class


%%PageItemTitle%%

ImGearThumbnailCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ImGearThumbnailCtl Constructor
Initializes a new instance of the ImGearThumbnailCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearThumbnailCtl()
public ImGearThumbnailCtl()
public: ImGearThumbnailCtl();
public:
ImGearThumbnailCtl();
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailCtl Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Methods
 | Name | Description
Public Method | DeleteAllItems | Removes all the items from the Thumbnail control.
Public Method | DeleteItem | Removes the specified item from the Thumbnail control.
Public Method | DirectoryAppend | Creates a series of thumbnail items.
Public Method | DocumentAppend | Appends all pages from ImageGear.Core.ImGearDocument object to the Thumbnail control.
Public Method | FileAppend | Appends a file specified by selection to the Thumbnail control.
Public Method | OnApplyTemplate | Overridden. Override to add setting up of events for template parts.
Public Method | PageAppend | Appends ImageGear.Core.ImGearPage object to the Thumbnail control.
Public Method | ReloadAll | Reloads all thumbnails in the Thumbnail control.
Public Method | ReloadItem | Reloads thumbnail picture in the specified thumbnail item.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.WPF Namespace
ImGearThumbnailItem Class


DeleteAllItems Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DeleteAllItems Method
Removes all the items from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DeleteAllItems()
'Usage

Dim instance As ImGearThumbnailCtl

instance.DeleteAllItems()
[Description()]
public void DeleteAllItems()
[Description()]
public: void DeleteAllItems();
[Description()]
public:
void DeleteAllItems();
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DeleteItem Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DeleteItem Method
Item to be removed.
Removes the specified item from the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub DeleteItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.DeleteItem(item)
[Description()]
public void DeleteItem(
   ImGearThumbnailItem item
)
[Description()]
public: void DeleteItem(
   ImGearThumbnailItem* item
)
[Description()]
public:
void DeleteItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be removed.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


DirectoryAppend Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DirectoryAppend Method
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
Creates a series of thumbnail items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DirectoryAppend( _
   ByVal directory As String, _
   ByVal filters As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim directory As String
Dim filters As String

instance.DirectoryAppend(directory, filters)
public void DirectoryAppend(
   string directory,
   string filters
)
public: void DirectoryAppend(
   string* directory,
   string* filters
)
public:
void DirectoryAppend(
   String^ directory,
   String^ filters
)

Parameters

directory
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
filters
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.
Remarks
This method creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the Filters parameter.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DocumentAppend Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DocumentAppend Method
Document to be appended.
Title for new items.
Appends all pages from ImageGear.Core.ImGearDocument object to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentAppend( _
   ByVal documentToAppend As ImGearDocument, _
   ByVal name As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim documentToAppend As ImGearDocument
Dim name As String

instance.DocumentAppend(documentToAppend, name)
public void DocumentAppend(
   ImGearDocument documentToAppend,
   string name
)
public: void DocumentAppend(
   ImGearDocument* documentToAppend,
   string* name
)
public:
void DocumentAppend(
   ImGearDocument^ documentToAppend,
   String^ name
)

Parameters

documentToAppend
Document to be appended.
name
Title for new items.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearDocument Class


FileAppend Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FileAppend Method
Selection specifying a path and a type of the file to be appended.
Appends a file specified by selection to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub FileAppend( _
   ByVal selection As ImGearLoadingSelection _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim selection As ImGearLoadingSelection

instance.FileAppend(selection)
[Description()]
public void FileAppend(
   ImGearLoadingSelection selection
)
[Description()]
public: void FileAppend(
   ImGearLoadingSelection* selection
)
[Description()]
public:
void FileAppend(
   ImGearLoadingSelection^ selection
)

Parameters

selection
Selection specifying a path and a type of the file to be appended.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearLoadingSelection Class


OnApplyTemplate Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : OnApplyTemplate Method
Override to add setting up of events for template parts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As ImGearThumbnailCtl

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


PageAppend Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : PageAppend Method
ImageGear.Core.ImGearPage object to be appended.
Title for new item.
Appends ImageGear.Core.ImGearPage object to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub PageAppend( _
   ByVal pageToAppend As ImGearPage, _
   ByVal name As String _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim pageToAppend As ImGearPage
Dim name As String

instance.PageAppend(pageToAppend, name)
[Description()]
public void PageAppend(
   ImGearPage pageToAppend,
   string name
)
[Description()]
public: void PageAppend(
   ImGearPage* pageToAppend,
   string* name
)
[Description()]
public:
void PageAppend(
   ImGearPage^ pageToAppend,
   String^ name
)

Parameters

pageToAppend
ImageGear.Core.ImGearPage object to be appended.
name
Title for new item.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearPage Class


ReloadAll Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub ReloadAll()
'Usage

Dim instance As ImGearThumbnailCtl

instance.ReloadAll()
[Description()]
public void ReloadAll()
[Description()]
public: void ReloadAll();
[Description()]
public:
void ReloadAll();
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ReloadItem Method (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ReloadItem Method
Item to be reloaded.
Reloads thumbnail picture in the specified thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
Public Sub ReloadItem( _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim instance As ImGearThumbnailCtl
Dim item As ImGearThumbnailItem

instance.ReloadItem(item)
[Description()]
public void ReloadItem(
   ImGearThumbnailItem item
)
[Description()]
public: void ReloadItem(
   ImGearThumbnailItem* item
)
[Description()]
public:
void ReloadItem(
   ImGearThumbnailItem^ item
)

Parameters

item
Item to be reloaded.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailCtl Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Properties
 | Name | Description
Public Property | AllPages | Gets or sets a value indicating whether all pages of a multi-page image will be loaded into thumbnails.
Public Property | AutoFocus | Gets or sets a value indicating whether the thumbnail browser gets focus when the mouse cursor is on the window.
Public Property | BorderWidth | Gets or sets the border width, in pixels, around the thumbnail.
Public Property | CellSize | Gets the full thumbnail item size, including size of item itself and spacing.
Public Property | Count | Gets the number of items within the Thumbnail control.
Public Property | DragDropOptions | Gets or sets a value specifying whether the thumbnail browser can be a Drag source, Drop target or both.
Public Property | FontFamily | Gets or sets title's font family.
Public Property | FontSize | Gets or sets title's font size.
Public Property | FontStretch | Gets or sets title's font stretch.
Public Property | FontStyle | Gets or sets title's font style.
Public Property | FontWeight | Gets or sets title's font weight.
Public Property | HighlightBackColor | Gets or sets the color to use as a background for the highlighted Thumbnail item.
Public Property | HighlightForeColor | Gets or sets the color to use as a foreground for a highlighted Thumbnail item.
Public Property | ImageSize | Gets the thumbnail image size.
Public Property | Interior | Gets or sets the amount of extra space around the thumbnail item.
Public Property | ItemHeight | Gets or sets the height, in pixels, of the image to be drawn in each thumbnail item.
Public Property | ItemWidth | Gets or sets the width, in pixels, of the image to be drawn in each thumbnail item.
Public Property | Margin | Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Public Property | SelectionBackColor | Gets or sets default background color for selected items.
Public Property | SelectionForeColor | Gets or sets default foreground color for selected items.
Public Property | SelectionMode | Gets or sets the selection mode for items.
Public Property | ShadowsVisibility | Gets or sets a value specifying item's shadow visibility.
Public Property | ShadowWidth | Gets or sets the width of item's shadow.
Public Property | ShowMagnify | Gets or sets a value indicating whether a larger popup image will appear by pressing the right-mouse-button down.
Public Property | Sort | Gets or sets a value specifying sort mode used when a new item is added.
Public Property | SortComparer | Gets or sets an object of a class implementing IComparer interface to make user sorting.
Public Property | Thumbnails | Gets the collection of all items.
Public Property | TitleHeight | Gets or sets the height of the item title.
Public Property | TitlesVisibility | Gets or sets a value specifying thumbnails title visibility.
Public Property | VerticalScrollBarVisibility | Gets or sets a value specifying if vertical scrollbar should appear when all items do not fit in the control.
Public Property | XSpacing | Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Public Property | YSpacing | Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Public Property | ZoomFactor | Gets or sets a value specifying zoom factor for displaying the magnified popup image.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.WPF Namespace
ImGearThumbnailItem Class


AllPages Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : AllPages Property
Gets or sets a value indicating whether all pages of a multi-page image will be loaded into thumbnails.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<ImGearFilterAttribute()>
<DescriptionAttribute()>
Public Property AllPages As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.AllPages = value

value = instance.AllPages
[Category("Items")]
[ImGearFilter()]
[Description()]
public bool AllPages {get; set;}
[Category("Items")]
[ImGearFilter()]
[Description()]
public: __property bool get_AllPages();
public: __property void set_AllPages(
   bool value
);
[Category("Items")]
[ImGearFilter()]
[Description()]
public:
property bool AllPages {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
When set to true all pages of a multi-page image will be loaded into thumbnails, otherwise only the first page will be loaded.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


AutoFocus Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : AutoFocus Property
Gets or sets a value indicating whether the thumbnail browser gets focus when the mouse cursor is on the window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Property AutoFocus As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.AutoFocus = value

value = instance.AutoFocus
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public bool AutoFocus {get; set;}
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public: __property bool get_AutoFocus();
public: __property void set_AutoFocus(
   bool value
);
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public:
property bool AutoFocus {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


BorderWidth Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : BorderWidth Property
Gets or sets the border width, in pixels, around the thumbnail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Items")>
<DescriptionAttribute()>
Public Property BorderWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
[ImGearFilter()]
[Category("Items")]
[Description()]
public int BorderWidth {get; set;}
[ImGearFilter()]
[Category("Items")]
[Description()]
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
[ImGearFilter()]
[Category("Items")]
[Description()]
public:
property int BorderWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


CellSize Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : CellSize Property
Gets the full thumbnail item size, including size of item itself and spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CellSize As Size
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Size

value = instance.CellSize
public Size CellSize {get;}
public: __property Size get_CellSize();
public:
property Size CellSize {
   Size get();
}

Property Value

System.Windows.Size value.
Remarks
Used in XAML.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Count Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : Count Property
Gets the number of items within the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<BrowsableAttribute(False)>
<ImGearFilterAttribute()>
Public ReadOnly Property Count As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

value = instance.Count
[Description()]
[Browsable(false)]
[ImGearFilter()]
public int Count {get;}
[Description()]
[Browsable(false)]
[ImGearFilter()]
public: __property int get_Count();
[Description()]
[Browsable(false)]
[ImGearFilter()]
public:
property int Count {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DragDropOptions Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DragDropOptions Property
Gets or sets a value specifying whether the thumbnail browser can be a Drag source, Drop target or both.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<ImGearFilterAttribute()>
<CategoryAttribute("Behavior")>
Public Property DragDropOptions As ImGearDragDropOptions
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ImGearDragDropOptions

instance.DragDropOptions = value

value = instance.DragDropOptions
[Description()]
[ImGearFilter()]
[Category("Behavior")]
public ImGearDragDropOptions DragDropOptions {get; set;}
[Description()]
[ImGearFilter()]
[Category("Behavior")]
public: __property ImGearDragDropOptions get_DragDropOptions();
public: __property void set_DragDropOptions(
   ImGearDragDropOptions value
);
[Description()]
[ImGearFilter()]
[Category("Behavior")]
public:
property ImGearDragDropOptions DragDropOptions {
   ImGearDragDropOptions get();
   void set (    ImGearDragDropOptions value);
}

Property Value

ImageGear.Windows.Forms.Thumbnails.ImGearDragDropOptions enumeration value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearDragDropOptions Enumeration


FontFamily Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FontFamily Property
Gets or sets title's font family.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Title font")>
<DescriptionAttribute("Determines title font family.")>
Public Shadows Property FontFamily As FontFamily
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As FontFamily

instance.FontFamily = value

value = instance.FontFamily
[ImGearFilter()]
[Category("Title font")]
[Description("Determines title font family.")]
public new FontFamily FontFamily {get; set;}
[ImGearFilter()]
[Category("Title font")]
[Description("Determines title font family.")]
public: __property new FontFamily* get_FontFamily();
public: __property new void set_FontFamily(
   FontFamily* value
);
[ImGearFilter()]
[Category("Title font")]
[Description("Determines title font family.")]
public:
new property FontFamily^ FontFamily {
   FontFamily^ get();
   void set (    FontFamily^ value);
}

Property Value

System.Windows.Media.FontFamily value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


FontSize Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FontSize Property
Gets or sets title's font size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Determines title font size.")>
<ImGearFilterAttribute()>
<CategoryAttribute("Title font")>
Public Shadows Property FontSize As Double
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Double

instance.FontSize = value

value = instance.FontSize
[Description("Determines title font size.")]
[ImGearFilter()]
[Category("Title font")]
public new double FontSize {get; set;}
[Description("Determines title font size.")]
[ImGearFilter()]
[Category("Title font")]
public: __property new double get_FontSize();
public: __property new void set_FontSize(
   double value
);
[Description("Determines title font size.")]
[ImGearFilter()]
[Category("Title font")]
public:
new property double FontSize {
   double get();
   void set (    double value);
}

Property Value

Double value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


FontStretch Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FontStretch Property
Gets or sets title's font stretch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Determines title font stretch.")>
<CategoryAttribute("Title font")>
<ImGearFilterAttribute()>
Public Shadows Property FontStretch As FontStretch
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As FontStretch

instance.FontStretch = value

value = instance.FontStretch
[Description("Determines title font stretch.")]
[Category("Title font")]
[ImGearFilter()]
public new FontStretch FontStretch {get; set;}
[Description("Determines title font stretch.")]
[Category("Title font")]
[ImGearFilter()]
public: __property new FontStretch get_FontStretch();
public: __property new void set_FontStretch(
   FontStretch value
);
[Description("Determines title font stretch.")]
[Category("Title font")]
[ImGearFilter()]
public:
new property FontStretch FontStretch {
   FontStretch get();
   void set (    FontStretch value);
}

Property Value

FontStretch value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


FontStyle Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FontStyle Property
Gets or sets title's font style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Determines title font style.")>
<ImGearFilterAttribute()>
<CategoryAttribute("Title font")>
Public Shadows Property FontStyle As FontStyle
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As FontStyle

instance.FontStyle = value

value = instance.FontStyle
[Description("Determines title font style.")]
[ImGearFilter()]
[Category("Title font")]
public new FontStyle FontStyle {get; set;}
[Description("Determines title font style.")]
[ImGearFilter()]
[Category("Title font")]
public: __property new FontStyle get_FontStyle();
public: __property new void set_FontStyle(
   FontStyle value
);
[Description("Determines title font style.")]
[ImGearFilter()]
[Category("Title font")]
public:
new property FontStyle FontStyle {
   FontStyle get();
   void set (    FontStyle value);
}

Property Value

FontStyle value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


FontWeight Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : FontWeight Property
Gets or sets title's font weight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Title font")>
<DescriptionAttribute("Determines title font weight.")>
<ImGearFilterAttribute()>
Public Shadows Property FontWeight As FontWeight
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As FontWeight

instance.FontWeight = value

value = instance.FontWeight
[Category("Title font")]
[Description("Determines title font weight.")]
[ImGearFilter()]
public new FontWeight FontWeight {get; set;}
[Category("Title font")]
[Description("Determines title font weight.")]
[ImGearFilter()]
public: __property new FontWeight get_FontWeight();
public: __property new void set_FontWeight(
   FontWeight value
);
[Category("Title font")]
[Description("Determines title font weight.")]
[ImGearFilter()]
public:
new property FontWeight FontWeight {
   FontWeight get();
   void set (    FontWeight value);
}

Property Value

FontStyle value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightBackColor Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : HighlightBackColor Property
Gets or sets the color to use as a background for the highlighted Thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute("Background color used for the Title of highlighted Thumbnail item.")>
<ImGearFilterAttribute()>
Public Property HighlightBackColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public Color HighlightBackColor {get; set;}
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public: __property Color get_HighlightBackColor();
public: __property void set_HighlightBackColor(
   Color value
);
[Category("Items")]
[Description("Background color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public:
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightForeColor Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : HighlightForeColor Property
Gets or sets the color to use as a foreground for a highlighted Thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute("Foreground color used for the Title of highlighted Thumbnail item.")>
<ImGearFilterAttribute()>
Public Property HighlightForeColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
[Category("Items")]
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public Color HighlightForeColor {get; set;}
[Category("Items")]
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public: __property Color get_HighlightForeColor();
public: __property void set_HighlightForeColor(
   Color value
);
[Category("Items")]
[Description("Foreground color used for the Title of highlighted Thumbnail item.")]
[ImGearFilter()]
public:
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ImageSize Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ImageSize Property
Gets the thumbnail image size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageSize As Size
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Size

value = instance.ImageSize
public Size ImageSize {get;}
public: __property Size get_ImageSize();
public:
property Size ImageSize {
   Size get();
}

Property Value

System.Windows.Size value.
Remarks
Used in XAML.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Interior Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : Interior Property
Gets or sets the amount of extra space around the thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<DescriptionAttribute()>
<CategoryAttribute("Appearance")>
Public Property Interior As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.Interior = value

value = instance.Interior
[ImGearFilter()]
[Description()]
[Category("Appearance")]
public int Interior {get; set;}
[ImGearFilter()]
[Description()]
[Category("Appearance")]
public: __property int get_Interior();
public: __property void set_Interior(
   int value
);
[ImGearFilter()]
[Description()]
[Category("Appearance")]
public:
property int Interior {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemHeight Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemHeight Property
Gets or sets the height, in pixels, of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
<ImGearFilterAttribute()>
Public Property ItemHeight As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ItemHeight = value

value = instance.ItemHeight
[Category("Items")]
[Description()]
[ImGearFilter()]
public int ItemHeight {get; set;}
[Category("Items")]
[Description()]
[ImGearFilter()]
public: __property int get_ItemHeight();
public: __property void set_ItemHeight(
   int value
);
[Category("Items")]
[Description()]
[ImGearFilter()]
public:
property int ItemHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Default value is 150.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemWidth Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemWidth Property
Gets or sets the width, in pixels, of the image to be drawn in each thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<ImGearFilterAttribute()>
<DescriptionAttribute()>
Public Property ItemWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ItemWidth = value

value = instance.ItemWidth
[Category("Items")]
[ImGearFilter()]
[Description()]
public int ItemWidth {get; set;}
[Category("Items")]
[ImGearFilter()]
[Description()]
public: __property int get_ItemWidth();
public: __property void set_ItemWidth(
   int value
);
[Category("Items")]
[ImGearFilter()]
[Description()]
public:
property int ItemWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Default value is 200.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Margin Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : Margin Property
Gets or sets the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<ImGearFilterAttribute()>
Public Shadows Property Margin As Thickness
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Thickness

instance.Margin = value

value = instance.Margin
[Category("Appearance")]
[ImGearFilter()]
public new Thickness Margin {get; set;}
[Category("Appearance")]
[ImGearFilter()]
public: __property new Thickness get_Margin();
public: __property new void set_Margin(
   Thickness value
);
[Category("Appearance")]
[ImGearFilter()]
public:
new property Thickness Margin {
   Thickness get();
   void set (    Thickness value);
}

Property Value

System.Windows.Thickness value.
Remarks
The Thumbnail control is resizable, so the amount of margin on the right side is determined automatically.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionBackColor Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionBackColor Property
Gets or sets default background color for selected items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<DescriptionAttribute("Background color used for the Title of selected Thumbnail item.")>
<CategoryAttribute("Items")>
Public Property SelectionBackColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.SelectionBackColor = value

value = instance.SelectionBackColor
[ImGearFilter()]
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public Color SelectionBackColor {get; set;}
[ImGearFilter()]
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public: __property Color get_SelectionBackColor();
public: __property void set_SelectionBackColor(
   Color value
);
[ImGearFilter()]
[Description("Background color used for the Title of selected Thumbnail item.")]
[Category("Items")]
public:
property Color SelectionBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionForeColor Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionForeColor Property
Gets or sets default foreground color for selected items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Foreground color used for the Title of selected Thumbnail item.")>
<CategoryAttribute("Items")>
<ImGearFilterAttribute()>
Public Property SelectionForeColor As Color
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Color

instance.SelectionForeColor = value

value = instance.SelectionForeColor
[Description("Foreground color used for the Title of selected Thumbnail item.")]
[Category("Items")]
[ImGearFilter()]
public Color SelectionForeColor {get; set;}
[Description("Foreground color used for the Title of selected Thumbnail item.")]
[Category("Items")]
[ImGearFilter()]
public: __property Color get_SelectionForeColor();
public: __property void set_SelectionForeColor(
   Color value
);
[Description("Foreground color used for the Title of selected Thumbnail item.")]
[Category("Items")]
[ImGearFilter()]
public:
property Color SelectionForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionMode Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionMode Property
Gets or sets the selection mode for items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<DescriptionAttribute("Determines whether the user can select multiple Thumbnail items at the same time.")>
<CategoryAttribute("Behavior")>
Public Property SelectionMode As SelectionMode
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As SelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
[ImGearFilter()]
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public SelectionMode SelectionMode {get; set;}
[ImGearFilter()]
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
[ImGearFilter()]
[Description("Determines whether the user can select multiple Thumbnail items at the same time.")]
[Category("Behavior")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (    SelectionMode value);
}

Property Value

System.Windows.Controls.SelectionMode value.
Remarks
Default value is SelectionMode.Extended.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShadowsVisibility Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShadowsVisibility Property
Gets or sets a value specifying item's shadow visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
<ImGearFilterAttribute()>
Public Property ShadowsVisibility As Visibility
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Visibility

instance.ShadowsVisibility = value

value = instance.ShadowsVisibility
[Category("Items")]
[Description()]
[ImGearFilter()]
public Visibility ShadowsVisibility {get; set;}
[Category("Items")]
[Description()]
[ImGearFilter()]
public: __property Visibility get_ShadowsVisibility();
public: __property void set_ShadowsVisibility(
   Visibility value
);
[Category("Items")]
[Description()]
[ImGearFilter()]
public:
property Visibility ShadowsVisibility {
   Visibility get();
   void set (    Visibility value);
}

Property Value

System.Windows.Visibility value.
Remarks
Default value is Visibility.Visible.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShadowWidth Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShadowWidth Property
Gets or sets the width of item's shadow.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
<ImGearFilterAttribute()>
Public Property ShadowWidth As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.ShadowWidth = value

value = instance.ShadowWidth
[Category("Items")]
[Description()]
[ImGearFilter()]
public int ShadowWidth {get; set;}
[Category("Items")]
[Description()]
[ImGearFilter()]
public: __property int get_ShadowWidth();
public: __property void set_ShadowWidth(
   int value
);
[Category("Items")]
[Description()]
[ImGearFilter()]
public:
property int ShadowWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShowMagnify Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShowMagnify Property
Gets or sets a value indicating whether a larger popup image will appear by pressing the right-mouse-button down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Property ShowMagnify As Boolean
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Boolean

instance.ShowMagnify = value

value = instance.ShowMagnify
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public bool ShowMagnify {get; set;}
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public: __property bool get_ShowMagnify();
public: __property void set_ShowMagnify(
   bool value
);
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public:
property bool ShowMagnify {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
The user may opt to see a larger popup image for the thumbnail by pressing the right-mouse-button down.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Sort Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : Sort Property
Gets or sets a value specifying sort mode used when a new item is added.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
<ImGearFilterAttribute()>
Public Property Sort As ImGearSortOptions
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ImGearSortOptions

instance.Sort = value

value = instance.Sort
[Category("Items")]
[Description()]
[ImGearFilter()]
public ImGearSortOptions Sort {get; set;}
[Category("Items")]
[Description()]
[ImGearFilter()]
public: __property ImGearSortOptions get_Sort();
public: __property void set_Sort(
   ImGearSortOptions value
);
[Category("Items")]
[Description()]
[ImGearFilter()]
public:
property ImGearSortOptions Sort {
   ImGearSortOptions get();
   void set (    ImGearSortOptions value);
}

Property Value

ImageGear.Windows.Forms.Thumbnails.ImGearSortOptions enumeration value.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearSortOptions Enumeration


SortComparer Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SortComparer Property
Gets or sets an object of a class implementing IComparer interface to make user sorting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute()>
<BrowsableAttribute(False)>
Public Property SortComparer As IComparer(Of ImGearThumbnailItem)
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As IComparer(Of ImGearThumbnailItem)

instance.SortComparer = value

value = instance.SortComparer
[Description()]
[Browsable(false)]
public IComparer<ImGearThumbnailItem> SortComparer {get; set;}
[Description()]
[Browsable(false)]
public: __property IComparer<ImGearThumbnailItem*>* get_SortComparer();
public: __property void set_SortComparer(
   IComparer<ImGearThumbnailItem*>* value
);
[Description()]
[Browsable(false)]
public:
property IComparer<ImGearThumbnailItem^>^ SortComparer {
   IComparer<ImGearThumbnailItem^>^ get();
   void set (    IComparer<ImGearThumbnailItem^>^ value);
}

Property Value

System.Collections.IComparer value.
Remarks
This property is used when Sort property is set to UserSort.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


Thumbnails Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : Thumbnails Property
Gets the collection of all items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Thumbnails As ObservableCollection(Of ImGearThumbnailItem)
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ObservableCollection(Of ImGearThumbnailItem)

value = instance.Thumbnails
public ObservableCollection<ImGearThumbnailItem> Thumbnails {get;}
public: __property ObservableCollection<ImGearThumbnailItem*>* get_Thumbnails();
public:
property ObservableCollection<ImGearThumbnailItem^>^ Thumbnails {
   ObservableCollection<ImGearThumbnailItem^>^ get();
}

Property Value

System.Collections.ObjectModel.ObservableCollection collection.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItem Class


TitleHeight Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : TitleHeight Property
Gets or sets the height of the item title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<DescriptionAttribute()>
<CategoryAttribute("Items")>
Public Property TitleHeight As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.TitleHeight = value

value = instance.TitleHeight
[ImGearFilter()]
[Description()]
[Category("Items")]
public int TitleHeight {get; set;}
[ImGearFilter()]
[Description()]
[Category("Items")]
public: __property int get_TitleHeight();
public: __property void set_TitleHeight(
   int value
);
[ImGearFilter()]
[Description()]
[Category("Items")]
public:
property int TitleHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Default value is 40.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TitlesVisibility Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : TitlesVisibility Property
Gets or sets a value specifying thumbnails title visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Items")>
<DescriptionAttribute()>
<ImGearFilterAttribute()>
Public Property TitlesVisibility As Visibility
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Visibility

instance.TitlesVisibility = value

value = instance.TitlesVisibility
[Category("Items")]
[Description()]
[ImGearFilter()]
public Visibility TitlesVisibility {get; set;}
[Category("Items")]
[Description()]
[ImGearFilter()]
public: __property Visibility get_TitlesVisibility();
public: __property void set_TitlesVisibility(
   Visibility value
);
[Category("Items")]
[Description()]
[ImGearFilter()]
public:
property Visibility TitlesVisibility {
   Visibility get();
   void set (    Visibility value);
}

Property Value

System.Windows.Visibility value.
Remarks
If Visibility.Hidden, no visible titles appear, but layout reserved. If Visibility.Collapsed, no titles at all.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


VerticalScrollBarVisibility Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : VerticalScrollBarVisibility Property
Gets or sets a value specifying if vertical scrollbar should appear when all items do not fit in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Appearance")>
<DescriptionAttribute()>
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As ScrollBarVisibility

instance.VerticalScrollBarVisibility = value

value = instance.VerticalScrollBarVisibility
[ImGearFilter()]
[Category("Appearance")]
[Description()]
public ScrollBarVisibility VerticalScrollBarVisibility {get; set;}
[ImGearFilter()]
[Category("Appearance")]
[Description()]
public: __property ScrollBarVisibility get_VerticalScrollBarVisibility();
public: __property void set_VerticalScrollBarVisibility(
   ScrollBarVisibility value
);
[ImGearFilter()]
[Category("Appearance")]
[Description()]
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
   ScrollBarVisibility get();
   void set (    ScrollBarVisibility value);
}

Property Value

System.Windows.Controls.ScrollBarVisibility value.
Remarks
Default value is ScrollBarVisibility.Auto.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


XSpacing Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : XSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<ImGearFilterAttribute()>
<DescriptionAttribute()>
Public Property XSpacing As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.XSpacing = value

value = instance.XSpacing
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public int XSpacing {get; set;}
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public: __property int get_XSpacing();
public: __property void set_XSpacing(
   int value
);
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public:
property int XSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


YSpacing Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : YSpacing Property
Gets or sets the amount of vertical space between thumbnails displayed on the control, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("Appearance")>
<ImGearFilterAttribute()>
<DescriptionAttribute()>
Public Property YSpacing As Integer
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Integer

instance.YSpacing = value

value = instance.YSpacing
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public int YSpacing {get; set;}
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public: __property int get_YSpacing();
public: __property void set_YSpacing(
   int value
);
[Category("Appearance")]
[ImGearFilter()]
[Description()]
public:
property int YSpacing {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
When set to (-1) it will use the default spacing that Windows uses for icons. When TitlesVisibility is set to Visible, the YSpacing measures the distance from the bottom of a title to the top of the item below it. When TitlesVisibility is Collapsed, the YSpacing measures the distance from the bottom of the item to the top of the one below it.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
TitlesVisibility Property


ZoomFactor Property (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ZoomFactor Property
Gets or sets a value specifying zoom factor for displaying the magnified popup image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ImGearFilterAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Property ZoomFactor As Double
'Usage

Dim instance As ImGearThumbnailCtl
Dim value As Double

instance.ZoomFactor = value

value = instance.ZoomFactor
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public double ZoomFactor {get; set;}
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public: __property double get_ZoomFactor();
public: __property void set_ZoomFactor(
   double value
);
[ImGearFilter()]
[Category("Behavior")]
[Description()]
public:
property double ZoomFactor {
   double get();
   void set (    double value);
}

Property Value

Double value.
Remarks
This property only used when ShowMagnify is true. It's value must be 1.0 or greater.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ShowMagnify Property


%%PageItemTitle%% $$Fields$$

ImGearThumbnailCtl Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AllPagesProperty | Represents AllPages dependency property.
static (Shared in Visual Basic) | AutoFocusProperty | Represents AutoFocus dependency property.
static (Shared in Visual Basic) | BorderWidthProperty | Represents BorderWidth dependency property.
static (Shared in Visual Basic) | DragDropOptionsProperty | Represents DragDropOptions dependency property.
static (Shared in Visual Basic) | HighlightBackColorProperty | Represents HighlightBackColor dependency property.
static (Shared in Visual Basic) | HighlightForeColorProperty | Represents HighlightForeColor dependency property.
static (Shared in Visual Basic) | InteriorProperty | Represents Interior dependency property.
static (Shared in Visual Basic) | ItemHeightProperty | Represents ItemHeight dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Represents ItemWidth dependency property.
static (Shared in Visual Basic) | MarginProperty | Represents Margin dependency property.
static (Shared in Visual Basic) | ScrollBarVisibilityProperty | Represents ScrollBarVisibility dependency property.
static (Shared in Visual Basic) | SelectionBackColorProperty | Represents SelectionBackColor dependency property.
static (Shared in Visual Basic) | SelectionForeColorProperty | Represents SelectionForeColor dependency property.
static (Shared in Visual Basic) | SelectionModeProperty | Represents SelectionMode dependency property.
static (Shared in Visual Basic) | ShadowsVisibilityProperty | Represents ShadowsVisibility dependency property.
static (Shared in Visual Basic) | ShadowWidthProperty | Represents ShadowWidth dependency property.
static (Shared in Visual Basic) | ShowMagnifyProperty | Represents ShowMagnify dependency property.
static (Shared in Visual Basic) | SortComparerProperty | Represents SortComparer dependency property.
static (Shared in Visual Basic) | SortProperty | Represents Sort dependency property.
static (Shared in Visual Basic) | TitleHeightProperty | Represents TitleHeight dependency property.
static (Shared in Visual Basic) | TitlesVisibilityProperty | Represents TitlesVisibility dependency property.
static (Shared in Visual Basic) | XSpacingProperty | Represents XSpacing dependency property.
static (Shared in Visual Basic) | YSpacingProperty | Represents YSpacing dependency property.
static (Shared in Visual Basic) | ZoomFactorProperty | Represents ZoomFactor dependency property.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.WPF Namespace
ImGearThumbnailItem Class


AllPagesProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : AllPagesProperty Field
Represents AllPages dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AllPagesProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.AllPagesProperty
public static readonly DependencyProperty AllPagesProperty
public: static readonly DependencyProperty* AllPagesProperty
public:
static readonly DependencyProperty^ AllPagesProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


AutoFocusProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : AutoFocusProperty Field
Represents AutoFocus dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AutoFocusProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.AutoFocusProperty
public static readonly DependencyProperty AutoFocusProperty
public: static readonly DependencyProperty* AutoFocusProperty
public:
static readonly DependencyProperty^ AutoFocusProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


BorderWidthProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : BorderWidthProperty Field
Represents BorderWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly BorderWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.BorderWidthProperty
public static readonly DependencyProperty BorderWidthProperty
public: static readonly DependencyProperty* BorderWidthProperty
public:
static readonly DependencyProperty^ BorderWidthProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


DragDropOptionsProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : DragDropOptionsProperty Field
Represents DragDropOptions dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DragDropOptionsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.DragDropOptionsProperty
public static readonly DependencyProperty DragDropOptionsProperty
public: static readonly DependencyProperty* DragDropOptionsProperty
public:
static readonly DependencyProperty^ DragDropOptionsProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightBackColorProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : HighlightBackColorProperty Field
Represents HighlightBackColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HighlightBackColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.HighlightBackColorProperty
public static readonly DependencyProperty HighlightBackColorProperty
public: static readonly DependencyProperty* HighlightBackColorProperty
public:
static readonly DependencyProperty^ HighlightBackColorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


HighlightForeColorProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : HighlightForeColorProperty Field
Represents HighlightForeColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HighlightForeColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.HighlightForeColorProperty
public static readonly DependencyProperty HighlightForeColorProperty
public: static readonly DependencyProperty* HighlightForeColorProperty
public:
static readonly DependencyProperty^ HighlightForeColorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


InteriorProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : InteriorProperty Field
Represents Interior dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InteriorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.InteriorProperty
public static readonly DependencyProperty InteriorProperty
public: static readonly DependencyProperty* InteriorProperty
public:
static readonly DependencyProperty^ InteriorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemHeightProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemHeightProperty Field
Represents ItemHeight dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ItemHeightProperty
public static readonly DependencyProperty ItemHeightProperty
public: static readonly DependencyProperty* ItemHeightProperty
public:
static readonly DependencyProperty^ ItemHeightProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ItemWidthProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemWidthProperty Field
Represents ItemWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ItemWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ItemWidthProperty
public static readonly DependencyProperty ItemWidthProperty
public: static readonly DependencyProperty* ItemWidthProperty
public:
static readonly DependencyProperty^ ItemWidthProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


MarginProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : MarginProperty Field
Represents Margin dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MarginProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.MarginProperty
public static readonly DependencyProperty MarginProperty
public: static readonly DependencyProperty* MarginProperty
public:
static readonly DependencyProperty^ MarginProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ScrollBarVisibilityProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ScrollBarVisibilityProperty Field
Represents ScrollBarVisibility dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ScrollBarVisibilityProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ScrollBarVisibilityProperty
public static readonly DependencyProperty ScrollBarVisibilityProperty
public: static readonly DependencyProperty* ScrollBarVisibilityProperty
public:
static readonly DependencyProperty^ ScrollBarVisibilityProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionBackColorProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionBackColorProperty Field
Represents SelectionBackColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionBackColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.SelectionBackColorProperty
public static readonly DependencyProperty SelectionBackColorProperty
public: static readonly DependencyProperty* SelectionBackColorProperty
public:
static readonly DependencyProperty^ SelectionBackColorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionForeColorProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionForeColorProperty Field
Represents SelectionForeColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionForeColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.SelectionForeColorProperty
public static readonly DependencyProperty SelectionForeColorProperty
public: static readonly DependencyProperty* SelectionForeColorProperty
public:
static readonly DependencyProperty^ SelectionForeColorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SelectionModeProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SelectionModeProperty Field
Represents SelectionMode dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.SelectionModeProperty
public static readonly DependencyProperty SelectionModeProperty
public: static readonly DependencyProperty* SelectionModeProperty
public:
static readonly DependencyProperty^ SelectionModeProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShadowsVisibilityProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShadowsVisibilityProperty Field
Represents ShadowsVisibility dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ShadowsVisibilityProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ShadowsVisibilityProperty
public static readonly DependencyProperty ShadowsVisibilityProperty
public: static readonly DependencyProperty* ShadowsVisibilityProperty
public:
static readonly DependencyProperty^ ShadowsVisibilityProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShadowWidthProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShadowWidthProperty Field
Represents ShadowWidth dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ShadowWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ShadowWidthProperty
public static readonly DependencyProperty ShadowWidthProperty
public: static readonly DependencyProperty* ShadowWidthProperty
public:
static readonly DependencyProperty^ ShadowWidthProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ShowMagnifyProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ShowMagnifyProperty Field
Represents ShowMagnify dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ShowMagnifyProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ShowMagnifyProperty
public static readonly DependencyProperty ShowMagnifyProperty
public: static readonly DependencyProperty* ShowMagnifyProperty
public:
static readonly DependencyProperty^ ShowMagnifyProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SortComparerProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SortComparerProperty Field
Represents SortComparer dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SortComparerProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.SortComparerProperty
public static readonly DependencyProperty SortComparerProperty
public: static readonly DependencyProperty* SortComparerProperty
public:
static readonly DependencyProperty^ SortComparerProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


SortProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : SortProperty Field
Represents Sort dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SortProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.SortProperty
public static readonly DependencyProperty SortProperty
public: static readonly DependencyProperty* SortProperty
public:
static readonly DependencyProperty^ SortProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TitleHeightProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : TitleHeightProperty Field
Represents TitleHeight dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TitleHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.TitleHeightProperty
public static readonly DependencyProperty TitleHeightProperty
public: static readonly DependencyProperty* TitleHeightProperty
public:
static readonly DependencyProperty^ TitleHeightProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


TitlesVisibilityProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : TitlesVisibilityProperty Field
Represents TitlesVisibility dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TitlesVisibilityProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.TitlesVisibilityProperty
public static readonly DependencyProperty TitlesVisibilityProperty
public: static readonly DependencyProperty* TitlesVisibilityProperty
public:
static readonly DependencyProperty^ TitlesVisibilityProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


XSpacingProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : XSpacingProperty Field
Represents XSpacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly XSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.XSpacingProperty
public static readonly DependencyProperty XSpacingProperty
public: static readonly DependencyProperty* XSpacingProperty
public:
static readonly DependencyProperty^ XSpacingProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


YSpacingProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : YSpacingProperty Field
Represents YSpacing dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly YSpacingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.YSpacingProperty
public static readonly DependencyProperty YSpacingProperty
public: static readonly DependencyProperty* YSpacingProperty
public:
static readonly DependencyProperty^ YSpacingProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


ZoomFactorProperty Field (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ZoomFactorProperty Field
Represents ZoomFactor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailCtl.ZoomFactorProperty
public static readonly DependencyProperty ZoomFactorProperty
public: static readonly DependencyProperty* ZoomFactorProperty
public:
static readonly DependencyProperty^ ZoomFactorProperty
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members


%%PageItemTitle%% $$Events$$

ImGearThumbnailCtl Class Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailCtl Class

For a list of all members of this type, see ImGearThumbnailCtl members.

Public Events
 | Name | Description
Public Event | ItemAfterCreate | This event is called after a new thumbnail item is added to the Thumbnail control.
Public Event | ItemAfterLoad | This event is called during the process of creating a thumbnail item.
Public Event | ItemBeforeDelete | This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Public Event | ItemBeforeLoad | This event is called during the process of creating a thumbnail item.
Public Event | ItemClicked | This event is called to indicate that the user clicked somewhere within the thumbnail control.
Public Event | ItemDoubleClicked | This event is called to indicate that the user double-clicked somewhere within the thumbnail control.
Top
See Also

Reference

ImGearThumbnailCtl Class
ImageGear.WPF Namespace
ImGearThumbnailItem Class


ItemAfterCreate Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemAfterCreate Event
This event is called after a new thumbnail item is added to the Thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemAfterCreate As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemAfterCreate, handler
public event ImGearThumbnailItemEventHandler ItemAfterCreate
public: __event ImGearThumbnailItemEventHandler* ItemAfterCreate
public:
event ImGearThumbnailItemEventHandler^ ItemAfterCreate
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
Remarks
During thumbnail item creation, the sequence of events is ItemBeforeLoad, then ItemAfterLoad, then ItemAfterCreate.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemAfterLoad Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemAfterLoad Event
This event is called during the process of creating a thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemAfterLoad As ImGearThumbnailAfterLoadEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailAfterLoadEventHandler

AddHandler instance.ItemAfterLoad, handler
public event ImGearThumbnailAfterLoadEventHandler ItemAfterLoad
public: __event ImGearThumbnailAfterLoadEventHandler* ItemAfterLoad
public:
event ImGearThumbnailAfterLoadEventHandler^ ItemAfterLoad
Event Data

The event handler receives an argument of type ImGearThumbnailAfterLoadEventArgs containing data related to this event. The following ImGearThumbnailAfterLoadEventArgs properties provide information specific to this event.

Property | Description
Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
Remarks
This event is raised after the image has been loaded into ImageGear.Core.ImGearPage object, but before the thumbnail item is created. Your application can implement this event handler if it needs to restrict the thumbnail items based on the file attributes.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailAfterLoadEventHandler Delegate


ItemBeforeDelete Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemBeforeDelete Event
This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemBeforeDelete As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemBeforeDelete, handler
public event ImGearThumbnailItemEventHandler ItemBeforeDelete
public: __event ImGearThumbnailItemEventHandler* ItemBeforeDelete
public:
event ImGearThumbnailItemEventHandler^ ItemBeforeDelete
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemBeforeLoad Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemBeforeLoad Event
This event is called during the process of creating a thumbnail item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemBeforeLoad As ImGearThumbnailBeforeLoadEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailBeforeLoadEventHandler

AddHandler instance.ItemBeforeLoad, handler
public event ImGearThumbnailBeforeLoadEventHandler ItemBeforeLoad
public: __event ImGearThumbnailBeforeLoadEventHandler* ItemBeforeLoad
public:
event ImGearThumbnailBeforeLoadEventHandler^ ItemBeforeLoad
Event Data

The event handler receives an argument of type ImGearThumbnailBeforeLoadEventArgs containing data related to this event. The following ImGearThumbnailBeforeLoadEventArgs properties provide information specific to this event.

Property | Description
Page | Gets ImageGear.Core.ImGearPage object containing full-sized picture that was used to create a thumbnail.
PageNumber | Gets the page number of the currently loaded thumbnail.
Skip | Gets or sets a value indicating whether or not to load thumbnail into a control.
ThumbnailSource | Gets the path and the format of the currently loaded thumbnail.
Remarks
This event is raised before the image has been loaded into ImageGear.Core.ImGearPage object. Your application can use this event to set the ImageGear file load handling (e.g., load scaled JPEG image) and the thumbnail image generation handling (e.g., aliasing, interpolation).
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailBeforeLoadEventHandler Delegate


ItemClicked Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemClicked Event
This event is called to indicate that the user clicked somewhere within the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemClicked As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemClicked, handler
public event ImGearThumbnailItemEventHandler ItemClicked
public: __event ImGearThumbnailItemEventHandler* ItemClicked
public:
event ImGearThumbnailItemEventHandler^ ItemClicked
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


ItemDoubleClicked Event (ImGearThumbnailCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailCtl Class : ItemDoubleClicked Event
This event is called to indicate that the user double-clicked somewhere within the thumbnail control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ItemDoubleClicked As ImGearThumbnailItemEventHandler
'Usage

Dim instance As ImGearThumbnailCtl
Dim handler As ImGearThumbnailItemEventHandler

AddHandler instance.ItemDoubleClicked, handler
public event ImGearThumbnailItemEventHandler ItemDoubleClicked
public: __event ImGearThumbnailItemEventHandler* ItemDoubleClicked
public:
event ImGearThumbnailItemEventHandler^ ItemDoubleClicked
Event Data

The event handler receives an argument of type ImGearThumbnailItemEventArgs containing data related to this event. The following ImGearThumbnailItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets ImGearThumbnailItem object that generated event.
See Also

Reference

ImGearThumbnailCtl Class
ImGearThumbnailCtl Members
ImGearThumbnailItemEventHandler Delegate


%%PageItemTitle%%

ImGearThumbnailItem Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItem Class
Represents a thumbnail item displayed in the thumbnail browser.
Object Model
ImGearThumbnailItem ClassImGearARTPage ClassImGearPage ClassImGearThumbnailCtl ClassImGearLoadingSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailItem
   Inherits System.Windows.DependencyObject
'Usage

Dim instance As ImGearThumbnailItem
public class ImGearThumbnailItem : System.Windows.DependencyObject
public __gc class ImGearThumbnailItem : public System.Windows.DependencyObject
public ref class ImGearThumbnailItem : public System.Windows.DependencyObject
Remarks
An application can iterate through the collection of ImGearThumbnailItem using the ImGearThumbnailCtl.Thumbnails property and ImGearThumbnailCtl.Count property of ImGearThumbnailCtl. Some of the event handlers are using ImGearThumbnailItem objects (for instance, when someone clicks on a particular thumbnail item).
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
ImageGear.WPF.ImGearThumbnailItem

See Also

Reference

ImGearThumbnailItem Members
ImageGear.WPF Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailItem Class Members
Fields Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItem Class

The following tables list the members exposed by ImGearThumbnailItem.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailItem Constructor | Overloaded. Initializes a new instance of the ImGearThumbnailItem class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | HighlightBackColorProperty | Represents HighlightBackColor dependency property.
static (Shared in Visual Basic) | HighlightedProperty | Represents Hightlighted dependency property.
static (Shared in Visual Basic) | HighlightForeColorProperty | Represents HighlightForeColor dependency property.
static (Shared in Visual Basic) | PrivateDataProperty | Represents PrivateData dependency property.
static (Shared in Visual Basic) | SelectedProperty | Represents Selected dependency property.
static (Shared in Visual Basic) | TitleProperty | Represents Title dependency property.
Top
Public Properties
 | Name | Description
Public Property | ArtPage | Gets or sets the ART page associated with the item.
Public Property | BitDepth | Gets the original image bit depth.
Public Property | CurrentBackground | Gets the current background color.
Public Property | CurrentForeground | Gets the current foreground color.
Public Property | Format | Gets the original image format.
Public Property | HighlightBackColor | Gets or sets the title's back color of the highlighted item.
Public Property | Highlighted | Gets or sets a value indicating whether the item is highlighted.
Public Property | HighlightForeColor | Gets or sets the title's fore color of the highlighted item.
Public Property | Image | Gets scaled thumbnail image.
Public Property | ImageSize | Gets the original image size.
Public Property | Page | Gets ImageGear.Core.ImGearPage object referencing to the original image.
Public Property | PageNumber | Gets page number.
Public Property | ParentCtl | Gets a reference to the parent ImGearThumbnailCtl control.
Public Property | PrivateData | Gets or sets a user data associated with the item.
Public Property | Selected | Gets or sets a value indicating whether the item is selected.
Public Property | Source | Gets ImageGear.Windows.Forms.ImGearLoadingSelection object containing path and format of the original file.
Public Property | Title | Gets or sets an item's title.
Top
Public Methods
 | Name | Description
Public Method | Reload | Reloads item's picture.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearThumbnailItem Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : ImGearThumbnailItem Constructor
Initializes a new instance of the ImGearThumbnailItem class.
Overload List
Overload | Description
ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32) | Initializes a new instance of the ImGearThumbnailItem class.
ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats) | Initializes a new instance of the ImGearThumbnailItem class.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%%

ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class > ImGearThumbnailItem Constructor : ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearLoadingSelection,String,Int32)
Reference to the parent ImGearThumbnailCtl object.
Reference to ImageGear.Windows.Forms.ImGearLoadingSelection object containing path and format of the original file.
Thumbnail item's title.
Page number.
Initializes a new instance of the ImGearThumbnailItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As ImGearThumbnailCtl, _
   ByVal loadingSelection As ImGearLoadingSelection, _
   ByVal title As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim parent As ImGearThumbnailCtl
Dim loadingSelection As ImGearLoadingSelection
Dim title As String
Dim pageNumber As Integer

Dim instance As New ImGearThumbnailItem(parent, loadingSelection, title, pageNumber)
public ImGearThumbnailItem(
   ImGearThumbnailCtl parent,
   ImGearLoadingSelection loadingSelection,
   string title,
   int pageNumber
)
public: ImGearThumbnailItem(
   ImGearThumbnailCtl* parent,
   ImGearLoadingSelection* loadingSelection,
   string* title,
   int pageNumber
)
public:
ImGearThumbnailItem(
   ImGearThumbnailCtl^ parent,
   ImGearLoadingSelection^ loadingSelection,
   String^ title,
   int pageNumber
)

Parameters

parent
Reference to the parent ImGearThumbnailCtl object.
loadingSelection
Reference to ImageGear.Windows.Forms.ImGearLoadingSelection object containing path and format of the original file.
title
Thumbnail item's title.
pageNumber
Page number.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
Overload List
ImGearThumbnailCtl Class
ImGearLoadingSelection Class


%%PageItemTitle%%

ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class > ImGearThumbnailItem Constructor : ImGearThumbnailItem Constructor(ImGearThumbnailCtl,ImGearPage,String,Int32,ImGearFormats)
Reference to the parent ImGearThumbnailCtl object.
Reference to ImageGear.Core.ImGearPage object that contains original image.
Thumbnail item's title.
Page number.
Original image format.
Initializes a new instance of the ImGearThumbnailItem class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As ImGearThumbnailCtl, _
   ByVal pageToLoad As ImGearPage, _
   ByVal title As String, _
   ByVal pageNumber As Integer, _
   ByVal format As ImGearFormats _
)
'Usage

Dim parent As ImGearThumbnailCtl
Dim pageToLoad As ImGearPage
Dim title As String
Dim pageNumber As Integer
Dim format As ImGearFormats

Dim instance As New ImGearThumbnailItem(parent, pageToLoad, title, pageNumber, format)
public ImGearThumbnailItem(
   ImGearThumbnailCtl parent,
   ImGearPage pageToLoad,
   string title,
   int pageNumber,
   ImGearFormats format
)
public: ImGearThumbnailItem(
   ImGearThumbnailCtl* parent,
   ImGearPage* pageToLoad,
   string* title,
   int pageNumber,
   ImGearFormats format
)
public:
ImGearThumbnailItem(
   ImGearThumbnailCtl^ parent,
   ImGearPage^ pageToLoad,
   String^ title,
   int pageNumber,
   ImGearFormats format
)

Parameters

parent
Reference to the parent ImGearThumbnailCtl object.
pageToLoad
Reference to ImageGear.Core.ImGearPage object that contains original image.
title
Thumbnail item's title.
pageNumber
Page number.
format
Original image format.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
Overload List
ImGearThumbnailCtl Class
ImGearPage Class
ImGearFormats Enumeration


%%PageItemTitle%% $$Methods$$

ImGearThumbnailItem Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

Public Methods
 | Name | Description
Public Method | Reload | Reloads item's picture.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.WPF Namespace


Reload Method (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Reload Method
Reloads item's picture.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reload()
'Usage

Dim instance As ImGearThumbnailItem

instance.Reload()
public void Reload()
public: void Reload();
public:
void Reload();
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailItem Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

Public Properties
 | Name | Description
Public Property | ArtPage | Gets or sets the ART page associated with the item.
Public Property | BitDepth | Gets the original image bit depth.
Public Property | CurrentBackground | Gets the current background color.
Public Property | CurrentForeground | Gets the current foreground color.
Public Property | Format | Gets the original image format.
Public Property | HighlightBackColor | Gets or sets the title's back color of the highlighted item.
Public Property | Highlighted | Gets or sets a value indicating whether the item is highlighted.
Public Property | HighlightForeColor | Gets or sets the title's fore color of the highlighted item.
Public Property | Image | Gets scaled thumbnail image.
Public Property | ImageSize | Gets the original image size.
Public Property | Page | Gets ImageGear.Core.ImGearPage object referencing to the original image.
Public Property | PageNumber | Gets page number.
Public Property | ParentCtl | Gets a reference to the parent ImGearThumbnailCtl control.
Public Property | PrivateData | Gets or sets a user data associated with the item.
Public Property | Selected | Gets or sets a value indicating whether the item is selected.
Public Property | Source | Gets ImageGear.Windows.Forms.ImGearLoadingSelection object containing path and format of the original file.
Public Property | Title | Gets or sets an item's title.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.WPF Namespace


ArtPage Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : ArtPage Property
Gets or sets the ART page associated with the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArtPage As ImGearARTPage
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearARTPage

instance.ArtPage = value

value = instance.ArtPage
public ImGearARTPage ArtPage {get; set;}
public: __property ImGearARTPage* get_ArtPage();
public: __property void set_ArtPage(
   ImGearARTPage* value
);
public:
property ImGearARTPage^ ArtPage {
   ImGearARTPage^ get();
   void set (    ImGearARTPage^ value);
}

Property Value

ImageGear.ART.ImGearARTPage object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


BitDepth Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : BitDepth Property
Gets the original image bit depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitDepth As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.BitDepth
public int BitDepth {get;}
public: __property int get_BitDepth();
public:
property int BitDepth {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


CurrentBackground Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : CurrentBackground Property
Gets the current background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CurrentBackground As Brush
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Brush

value = instance.CurrentBackground
public Brush CurrentBackground {get;}
public: __property Brush* get_CurrentBackground();
public:
property Brush^ CurrentBackground {
   Brush^ get();
}

Property Value

System.Windows.Media.Brush value.
Remarks
It is used in XAML.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


CurrentForeground Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : CurrentForeground Property
Gets the current foreground color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CurrentForeground As Brush
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Brush

value = instance.CurrentForeground
public Brush CurrentForeground {get;}
public: __property Brush* get_CurrentForeground();
public:
property Brush^ CurrentForeground {
   Brush^ get();
}

Property Value

System.Windows.Media.Brush value.
Remarks
It is used in XAML.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Format Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Format Property
Gets the original image format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Format As ImGearFormats
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearFormats

value = instance.Format
public ImGearFormats Format {get;}
public: __property ImGearFormats get_Format();
public:
property ImGearFormats Format {
   ImGearFormats get();
}

Property Value

ImageGear.Formats.ImGearFormats enumeration value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearFormats Enumeration


HighlightBackColor Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : HighlightBackColor Property
Gets or sets the title's back color of the highlighted item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightBackColor As Color
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Color

instance.HighlightBackColor = value

value = instance.HighlightBackColor
public Color HighlightBackColor {get; set;}
public: __property Color get_HighlightBackColor();
public: __property void set_HighlightBackColor(
   Color value
);
public:
property Color HighlightBackColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color structure.
Remarks
If it is not set, HighlightBackColor from thumbnail control is used.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Highlighted Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Highlighted Property
Gets or sets a value indicating whether the item is highlighted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Highlighted As Boolean
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Boolean

instance.Highlighted = value

value = instance.Highlighted
public bool Highlighted {get; set;}
public: __property bool get_Highlighted();
public: __property void set_Highlighted(
   bool value
);
public:
property bool Highlighted {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


HighlightForeColor Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : HighlightForeColor Property
Gets or sets the title's fore color of the highlighted item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightForeColor As Color
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Color

instance.HighlightForeColor = value

value = instance.HighlightForeColor
public Color HighlightForeColor {get; set;}
public: __property Color get_HighlightForeColor();
public: __property void set_HighlightForeColor(
   Color value
);
public:
property Color HighlightForeColor {
   Color get();
   void set (    Color value);
}

Property Value

System.Drawing.Color structure.
Remarks
If it is not set, HighlightForeColor from thumbnail control is used.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Image Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Image Property
Gets scaled thumbnail image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As BitmapSource
'Usage

Dim instance As ImGearThumbnailItem
Dim value As BitmapSource

value = instance.Image
public BitmapSource Image {get;}
public: __property BitmapSource* get_Image();
public:
property BitmapSource^ Image {
   BitmapSource^ get();
}

Property Value

System.Windows.Media.Imaging.BitmapSource value.
Remarks
Used in XAML.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


ImageSize Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : ImageSize Property
Gets the original image size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageSize As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.ImageSize
public int ImageSize {get;}
public: __property int get_ImageSize();
public:
property int ImageSize {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Page Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Page Property
Gets ImageGear.Core.ImGearPage object referencing to the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As ImGearPage
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearPage

value = instance.Page
public ImGearPage Page {get;}
public: __property ImGearPage* get_Page();
public:
property ImGearPage^ Page {
   ImGearPage^ get();
}

Property Value

ImageGear.Core.ImGearPage object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearPage Class


PageNumber Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : PageNumber Property
Gets page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

Integer value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


ParentCtl Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : ParentCtl Property
Gets a reference to the parent ImGearThumbnailCtl control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ParentCtl As ImGearThumbnailCtl
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearThumbnailCtl

value = instance.ParentCtl
public ImGearThumbnailCtl ParentCtl {get;}
public: __property ImGearThumbnailCtl* get_ParentCtl();
public:
property ImGearThumbnailCtl^ ParentCtl {
   ImGearThumbnailCtl^ get();
}

Property Value

ImGearThumbnailCtl class object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearThumbnailCtl Class


PrivateData Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : PrivateData Property
Gets or sets a user data associated with the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrivateData As Object
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Object

instance.PrivateData = value

value = instance.PrivateData
public object PrivateData {get; set;}
public: __property Object* get_PrivateData();
public: __property void set_PrivateData(
   Object* value
);
public:
property Object^ PrivateData {
   Object^ get();
   void set (    Object^ value);
}

Property Value

Object of any type.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Selected Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Selected Property
Gets or sets a value indicating whether the item is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Selected As Boolean
'Usage

Dim instance As ImGearThumbnailItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
public bool Selected {get; set;}
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Property Value

Boolean value.
Remarks
Default value is false.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


Source Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Source Property
Gets ImageGear.Windows.Forms.ImGearLoadingSelection object containing path and format of the original file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Source As ImGearLoadingSelection
'Usage

Dim instance As ImGearThumbnailItem
Dim value As ImGearLoadingSelection

value = instance.Source
public ImGearLoadingSelection Source {get;}
public: __property ImGearLoadingSelection* get_Source();
public:
property ImGearLoadingSelection^ Source {
   ImGearLoadingSelection^ get();
}

Property Value

ImageGear.Windows.Forms.ImGearLoadingSelection object.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members
ImGearLoadingSelection Class


Title Property (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : Title Property
Gets or sets an item's title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As ImGearThumbnailItem
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

String value.
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%% $$Fields$$

ImGearThumbnailItem Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItem Class

For a list of all members of this type, see ImGearThumbnailItem members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | HighlightBackColorProperty | Represents HighlightBackColor dependency property.
static (Shared in Visual Basic) | HighlightedProperty | Represents Hightlighted dependency property.
static (Shared in Visual Basic) | HighlightForeColorProperty | Represents HighlightForeColor dependency property.
static (Shared in Visual Basic) | PrivateDataProperty | Represents PrivateData dependency property.
static (Shared in Visual Basic) | SelectedProperty | Represents Selected dependency property.
static (Shared in Visual Basic) | TitleProperty | Represents Title dependency property.
Top
See Also

Reference

ImGearThumbnailItem Class
ImageGear.WPF Namespace


HighlightBackColorProperty Field (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : HighlightBackColorProperty Field
Represents HighlightBackColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HighlightBackColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.HighlightBackColorProperty
public static readonly DependencyProperty HighlightBackColorProperty
public: static readonly DependencyProperty* HighlightBackColorProperty
public:
static readonly DependencyProperty^ HighlightBackColorProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


HighlightedProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : HighlightedProperty Field
Represents Hightlighted dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HighlightedProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.HighlightedProperty
public static readonly DependencyProperty HighlightedProperty
public: static readonly DependencyProperty* HighlightedProperty
public:
static readonly DependencyProperty^ HighlightedProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


HighlightForeColorProperty Field (ImGearThumbnailItem)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : HighlightForeColorProperty Field
Represents HighlightForeColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HighlightForeColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.HighlightForeColorProperty
public static readonly DependencyProperty HighlightForeColorProperty
public: static readonly DependencyProperty* HighlightForeColorProperty
public:
static readonly DependencyProperty^ HighlightForeColorProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


PrivateDataProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : PrivateDataProperty Field
Represents PrivateData dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PrivateDataProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.PrivateDataProperty
public static readonly DependencyProperty PrivateDataProperty
public: static readonly DependencyProperty* PrivateDataProperty
public:
static readonly DependencyProperty^ PrivateDataProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


SelectedProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : SelectedProperty Field
Represents Selected dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectedProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.SelectedProperty
public static readonly DependencyProperty SelectedProperty
public: static readonly DependencyProperty* SelectedProperty
public:
static readonly DependencyProperty^ SelectedProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


TitleProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItem Class : TitleProperty Field
Represents Title dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TitleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailItem.TitleProperty
public static readonly DependencyProperty TitleProperty
public: static readonly DependencyProperty* TitleProperty
public:
static readonly DependencyProperty^ TitleProperty
See Also

Reference

ImGearThumbnailItem Class
ImGearThumbnailItem Members


%%PageItemTitle%%

ImGearThumbnailItemEventArgs Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItemEventArgs Class
Specifies arguments for the ImGearThumbnailItemEventHandler delegate.
Object Model
ImGearThumbnailItemEventArgs ClassImGearThumbnailItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailItemEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As ImGearThumbnailItemEventArgs
public class ImGearThumbnailItemEventArgs : System.Windows.RoutedEventArgs
public __gc class ImGearThumbnailItemEventArgs : public System.Windows.RoutedEventArgs
public ref class ImGearThumbnailItemEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
ImageGear.WPF.ImGearThumbnailItemEventArgs

See Also

Reference

ImGearThumbnailItemEventArgs Members
ImageGear.WPF Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailItemEventArgs Class Members
Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItemEventArgs Class

The following tables list the members exposed by ImGearThumbnailItemEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailItemEventArgs Constructor | Initializes a new instance of the ImGearThumbnailItemEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets ImGearThumbnailItem object that generated event.
Top
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearThumbnailItemEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItemEventArgs Class : ImGearThumbnailItemEventArgs Constructor
Reference to event object.
Item that generated event.
Initializes a new instance of the ImGearThumbnailItemEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal routedEvent As RoutedEvent, _
   ByVal item As ImGearThumbnailItem _
)
'Usage

Dim routedEvent As RoutedEvent
Dim item As ImGearThumbnailItem

Dim instance As New ImGearThumbnailItemEventArgs(routedEvent, item)
public ImGearThumbnailItemEventArgs(
   RoutedEvent routedEvent,
   ImGearThumbnailItem item
)
public: ImGearThumbnailItemEventArgs(
   RoutedEvent* routedEvent,
   ImGearThumbnailItem* item
)
public:
ImGearThumbnailItemEventArgs(
   RoutedEvent^ routedEvent,
   ImGearThumbnailItem^ item
)

Parameters

routedEvent
Reference to event object.
item
Item that generated event.
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs Members
ImGearThumbnailItem Class


%%PageItemTitle%% $$Properties$$

ImGearThumbnailItemEventArgs Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItemEventArgs Class

For a list of all members of this type, see ImGearThumbnailItemEventArgs members.

Public Properties
 | Name | Description
Public Property | Item | Gets ImGearThumbnailItem object that generated event.
Top
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Methods$$

ImGearThumbnailItemEventArgs Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItemEventArgs Class

For a list of all members of this type, see ImGearThumbnailItemEventArgs members.

See Also

Reference

ImGearThumbnailItemEventArgs Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearThumbnailItemEventArgs Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItemEventArgs Class : ImGearThumbnailItemEventArgs Constructor
Overload List
Overload | Description
ImGearThumbnailItemEventArgs Constructor | Initializes a new instance of the ImGearThumbnailItemEventArgs class.
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs Members


Item Property (ImGearThumbnailItemEventArgs)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailItemEventArgs Class : Item Property
Gets ImGearThumbnailItem object that generated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As ImGearThumbnailItem
'Usage

Dim instance As ImGearThumbnailItemEventArgs
Dim value As ImGearThumbnailItem

value = instance.Item
public ImGearThumbnailItem Item {get;}
public: __property ImGearThumbnailItem* get_Item();
public:
property ImGearThumbnailItem^ Item {
   ImGearThumbnailItem^ get();
}

Property Value

ImGearThumbnailItem class.
See Also

Reference

ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs Members
ImGearThumbnailItem Class


%%PageItemTitle%%

ImGearThumbnailMagnifierCtl Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class
Provides interaction logic for ThumbnailMagnifierCtl.xaml. ImGearThumbnailMagnifierCtl
Object Model
ImGearThumbnailMagnifierCtl Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearThumbnailMagnifierCtl
   Inherits System.Windows.Controls.UserControl
'Usage

Dim instance As ImGearThumbnailMagnifierCtl
public class ImGearThumbnailMagnifierCtl : System.Windows.Controls.UserControl
public __gc class ImGearThumbnailMagnifierCtl : public System.Windows.Controls.UserControl
public ref class ImGearThumbnailMagnifierCtl : public System.Windows.Controls.UserControl
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
ImageGear.WPF.ImGearThumbnailMagnifierCtl

See Also

Reference

ImGearThumbnailMagnifierCtl Members
ImageGear.WPF Namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailMagnifierCtl Class Members
Fields Properties Methods Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class

The following tables list the members exposed by ImGearThumbnailMagnifierCtl.

Public Constructors
 | Name | Description
Public Constructor | ImGearThumbnailMagnifierCtl Constructor | Initializes a new instance of the ImGearThumbnailMagnifierCtl class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | MagHeightProperty | Represents Height dependency property.
static (Shared in Visual Basic) | MagWidthProperty | Represents Width dependency property.
Top
Public Properties
 | Name | Description
Public Property | MagHeight | Gets or sets the height of the image displayed in the popup.
Public Property | MagWidth | Gets or sets the width of the image displayed in the popup.
Top
Public Methods
 | Name | Description
Public Method | InitializeComponent | InitializeComponent
Top
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearThumbnailMagnifierCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : ImGearThumbnailMagnifierCtl Constructor
ImGearPage that is to be displayed in magnifier control.
Initial control width.
Initial control height.
Initializes a new instance of the ImGearThumbnailMagnifierCtl class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
'Usage

Dim page As ImGearPage
Dim width As Integer
Dim height As Integer

Dim instance As New ImGearThumbnailMagnifierCtl(page, width, height)
public ImGearThumbnailMagnifierCtl(
   ImGearPage page,
   int width,
   int height
)
public: ImGearThumbnailMagnifierCtl(
   ImGearPage* page,
   int width,
   int height
)
public:
ImGearThumbnailMagnifierCtl(
   ImGearPage^ page,
   int width,
   int height
)

Parameters

page
ImGearPage that is to be displayed in magnifier control.
width
Initial control width.
height
Initial control height.
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailMagnifierCtl Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class

For a list of all members of this type, see ImGearThumbnailMagnifierCtl members.

Public Methods
 | Name | Description
Public Method | InitializeComponent | InitializeComponent
Top
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%% $$Events$$

ImGearThumbnailMagnifierCtl Class Events

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class

For a list of all members of this type, see ImGearThumbnailMagnifierCtl members.

See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImageGear.WPF Namespace


%%PageItemTitle%%

ImGearThumbnailMagnifierCtl Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : ImGearThumbnailMagnifierCtl Constructor
Overload List
Overload | Description
ImGearThumbnailMagnifierCtl Constructor | Initializes a new instance of the ImGearThumbnailMagnifierCtl class.
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


InitializeComponent Method (ImGearThumbnailMagnifierCtl)

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : InitializeComponent Method
InitializeComponent
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<GeneratedCodeAttribute(Tool="PresentationBuildTasks", Version="4.0.0.0")>
<DebuggerNonUserCodeAttribute()>
Public Sub InitializeComponent()
'Usage

Dim instance As ImGearThumbnailMagnifierCtl

instance.InitializeComponent()
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
[DebuggerNonUserCode()]
public void InitializeComponent()
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
[DebuggerNonUserCode()]
public: void InitializeComponent();
[GeneratedCode(Tool="PresentationBuildTasks", Version="4.0.0.0")]
[DebuggerNonUserCode()]
public:
void InitializeComponent();
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailMagnifierCtl Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class

For a list of all members of this type, see ImGearThumbnailMagnifierCtl members.

Public Properties
 | Name | Description
Public Property | MagHeight | Gets or sets the height of the image displayed in the popup.
Public Property | MagWidth | Gets or sets the width of the image displayed in the popup.
Top
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImageGear.WPF Namespace


MagHeight Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : MagHeight Property
Gets or sets the height of the image displayed in the popup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MagHeight As Integer
'Usage

Dim instance As ImGearThumbnailMagnifierCtl
Dim value As Integer

instance.MagHeight = value

value = instance.MagHeight
public int MagHeight {get; set;}
public: __property int get_MagHeight();
public: __property void set_MagHeight(
   int value
);
public:
property int MagHeight {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Used in XAML.
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


MagWidth Property

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : MagWidth Property
Gets or sets the width of the image displayed in the popup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MagWidth As Integer
'Usage

Dim instance As ImGearThumbnailMagnifierCtl
Dim value As Integer

instance.MagWidth = value

value = instance.MagWidth
public int MagWidth {get; set;}
public: __property int get_MagWidth();
public: __property void set_MagWidth(
   int value
);
public:
property int MagWidth {
   int get();
   void set (    int value);
}

Property Value

Integer value.
Remarks
Used in XAML.
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


%%PageItemTitle%% $$Fields$$

ImGearThumbnailMagnifierCtl Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailMagnifierCtl Class

For a list of all members of this type, see ImGearThumbnailMagnifierCtl members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | MagHeightProperty | Represents Height dependency property.
static (Shared in Visual Basic) | MagWidthProperty | Represents Width dependency property.
Top
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImageGear.WPF Namespace


MagHeightProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : MagHeightProperty Field
Represents Height dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MagHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailMagnifierCtl.MagHeightProperty
public static readonly DependencyProperty MagHeightProperty
public: static readonly DependencyProperty* MagHeightProperty
public:
static readonly DependencyProperty^ MagHeightProperty
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


MagWidthProperty Field

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace > ImGearThumbnailMagnifierCtl Class : MagWidthProperty Field
Represents Width dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MagWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = ImGearThumbnailMagnifierCtl.MagWidthProperty
public static readonly DependencyProperty MagWidthProperty
public: static readonly DependencyProperty* MagWidthProperty
public:
static readonly DependencyProperty^ MagWidthProperty

Field Value

Integer value.
See Also

Reference

ImGearThumbnailMagnifierCtl Class
ImGearThumbnailMagnifierCtl Members


%%PageItemTitle%%

ImGearMagnifierShapeType Enumeration

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearMagnifierShapeType Enumeration
Specifies popup magnifier shape types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImGearMagnifierShapeType
   Inherits System.Enum
'Usage

Dim instance As ImGearMagnifierShapeType
public enum ImGearMagnifierShapeType : System.Enum
__value public enum ImGearMagnifierShapeType : public System.Enum
public enum class ImGearMagnifierShapeType : public System.Enum
Members
Member | Value | Description
Ellipse | 1 | Ellipsoid shape.
Rectangle | 0 | Rectangular shape.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ImageGear.WPF.ImGearMagnifierShapeType

See Also

Reference

ImageGear.WPF Namespace
ImGearMagnifierCtl Class


%%PageItemTitle%%

ImGearThumbnailAfterLoadEventHandler Delegate

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailAfterLoadEventHandler Delegate
Sender object.
Event arguments.
Delegate for the AfterLoad item event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailAfterLoadEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailAfterLoadEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailAfterLoadEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailAfterLoadEventHandler(
   object sender,
   ImGearThumbnailAfterLoadEventArgs e
)
public: __gc __delegate void ImGearThumbnailAfterLoadEventHandler(
   Object* sender,
   ImGearThumbnailAfterLoadEventArgs* e
)
public delegate void ImGearThumbnailAfterLoadEventHandler(
   Object^ sender,
   ImGearThumbnailAfterLoadEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
See Also

Reference

ImGearThumbnailAfterLoadEventHandler Members
ImageGear.WPF Namespace
ImGearThumbnailCtl Class
ItemAfterLoad Event


%%PageItemTitle%%

ImGearThumbnailBeforeLoadEventHandler Delegate

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailBeforeLoadEventHandler Delegate
Sender object.
Event arguments.
Delegate for the BeforeLoad item event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailBeforeLoadEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailBeforeLoadEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailBeforeLoadEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailBeforeLoadEventHandler(
   object sender,
   ImGearThumbnailBeforeLoadEventArgs e
)
public: __gc __delegate void ImGearThumbnailBeforeLoadEventHandler(
   Object* sender,
   ImGearThumbnailBeforeLoadEventArgs* e
)
public delegate void ImGearThumbnailBeforeLoadEventHandler(
   Object^ sender,
   ImGearThumbnailBeforeLoadEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
See Also

Reference

ImGearThumbnailBeforeLoadEventHandler Members
ImageGear.WPF Namespace
ImGearThumbnailCtl Class
ItemBeforeLoad Event


%%PageItemTitle%%

ImGearThumbnailItemEventHandler Delegate

ImageGear22.Wpf Assembly > ImageGear.WPF Namespace : ImGearThumbnailItemEventHandler Delegate
Sender object.
Event arguments.
Delegate for the thumbnail item events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImGearThumbnailItemEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImGearThumbnailItemEventArgs _
)
'Usage

Dim instance As New ImGearThumbnailItemEventHandler(AddressOf HandlerMethod)
public delegate void ImGearThumbnailItemEventHandler(
   object sender,
   ImGearThumbnailItemEventArgs e
)
public: __gc __delegate void ImGearThumbnailItemEventHandler(
   Object* sender,
   ImGearThumbnailItemEventArgs* e
)
public delegate void ImGearThumbnailItemEventHandler(
   Object^ sender,
   ImGearThumbnailItemEventArgs^ e
)

Parameters

sender
Sender object.
e
Event arguments.
See Also

Reference

ImGearThumbnailItemEventHandler Members
ImageGear.WPF Namespace


ImageGear.WPF.BitmapSourceConversion Namespace
Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.BitmapSourceConversion Namespace
The ImageGear.WPF.BitmapSourceConversion Namespace provides BitmapSource conversion API.
Classes
 | Class | Description
Class | ImGearBitmapSourceConverter | Provides static methods to convert between WPF BitmapSource and ImageGear.Core.ImGearPage objects.
See Also

Reference

ImageGear22.Wpf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.WPF.BitmapSourceConversion Namespace Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.BitmapSourceConversion Namespace
Inheritance Hierarchy
System.Object
ImageGear.WPF.BitmapSourceConversion.ImGearBitmapSourceConverter
See Also

Reference

ImageGear22.Wpf Assembly


%%PageItemTitle%%

ImGearBitmapSourceConverter Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace : ImGearBitmapSourceConverter Class
Provides static methods to convert between WPF BitmapSource and ImageGear.Core.ImGearPage objects.
Object Model
ImGearBitmapSourceConverter ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearBitmapSourceConverter
'Usage

Dim instance As ImGearBitmapSourceConverter
public class ImGearBitmapSourceConverter
public __gc class ImGearBitmapSourceConverter
public ref class ImGearBitmapSourceConverter
Inheritance Hierarchy

System.Object
ImageGear.WPF.BitmapSourceConversion.ImGearBitmapSourceConverter

See Also

Reference

ImGearBitmapSourceConverter Members
ImageGear.WPF.BitmapSourceConversion Namespace
ImGearPage Class


%%PageItemTitle%% $$Members$$

ImGearBitmapSourceConverter Class Members
Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace : ImGearBitmapSourceConverter Class

The following tables list the members exposed by ImGearBitmapSourceConverter.

Public Constructors
 | Name | Description
Public Constructor | ImGearBitmapSourceConverter Constructor | Initializes a new instance of the ImGearBitmapSourceConverter class.
Top
Public Methods
 | Name | Description
Public Method | BitmapSourceFromBitmap | Converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.
Public Method | BitmapSourceFromImGearPage | Converts ImageGear.Core.ImGearPage to System.Windows.Media.Imaging.BitmapSource.
Public Method | ImGearPageFromBitmapSource | Converts System.Windows.Media.Imaging.BitmapSource to ImageGear.Core.ImGearPage.
Public Method | ThumbnailFromImGearPage | Produces new resized System.Windows.Media.Imaging.BitmapSource from a given ImageGear.Core.ImGearPage.
Top
See Also

Reference

ImGearBitmapSourceConverter Class
ImageGear.WPF.BitmapSourceConversion Namespace
ImGearPage Class


%%PageItemTitle%%

ImGearBitmapSourceConverter Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : ImGearBitmapSourceConverter Constructor
Initializes a new instance of the ImGearBitmapSourceConverter class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearBitmapSourceConverter()
public ImGearBitmapSourceConverter()
public: ImGearBitmapSourceConverter();
public:
ImGearBitmapSourceConverter();
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members


%%PageItemTitle%% $$Methods$$

ImGearBitmapSourceConverter Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace : ImGearBitmapSourceConverter Class

For a list of all members of this type, see ImGearBitmapSourceConverter members.

Public Methods
 | Name | Description
Public Method | BitmapSourceFromBitmap | Converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.
Public Method | BitmapSourceFromImGearPage | Converts ImageGear.Core.ImGearPage to System.Windows.Media.Imaging.BitmapSource.
Public Method | ImGearPageFromBitmapSource | Converts System.Windows.Media.Imaging.BitmapSource to ImageGear.Core.ImGearPage.
Public Method | ThumbnailFromImGearPage | Produces new resized System.Windows.Media.Imaging.BitmapSource from a given ImageGear.Core.ImGearPage.
Top
See Also

Reference

ImGearBitmapSourceConverter Class
ImageGear.WPF.BitmapSourceConversion Namespace
ImGearPage Class


BitmapSourceFromBitmap Method

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : BitmapSourceFromBitmap Method
System.Drawing.Bitmap object to be converted.
Converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BitmapSourceFromBitmap( _
   ByVal bitmap As Bitmap _
) As BitmapSource
'Usage

Dim instance As ImGearBitmapSourceConverter
Dim bitmap As Bitmap
Dim value As BitmapSource

value = instance.BitmapSourceFromBitmap(bitmap)
public BitmapSource BitmapSourceFromBitmap(
   Bitmap bitmap
)
public: BitmapSource* BitmapSourceFromBitmap(
   Bitmap* bitmap
)
public:
BitmapSource^ BitmapSourceFromBitmap(
   Bitmap^ bitmap
)

Parameters

bitmap
System.Drawing.Bitmap object to be converted.

Return Value

System.Windows.Media.Imaging.BitmapSource object.
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members


BitmapSourceFromImGearPage Method

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : BitmapSourceFromImGearPage Method
ImageGear.Core.ImGearPage object to be converted.
Converts ImageGear.Core.ImGearPage to System.Windows.Media.Imaging.BitmapSource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BitmapSourceFromImGearPage( _
   ByVal page As ImGearPage _
) As BitmapSource
'Usage

Dim instance As ImGearBitmapSourceConverter
Dim page As ImGearPage
Dim value As BitmapSource

value = instance.BitmapSourceFromImGearPage(page)
public BitmapSource BitmapSourceFromImGearPage(
   ImGearPage page
)
public: BitmapSource* BitmapSourceFromImGearPage(
   ImGearPage* page
)
public:
BitmapSource^ BitmapSourceFromImGearPage(
   ImGearPage^ page
)

Parameters

page
ImageGear.Core.ImGearPage object to be converted.

Return Value

System.Windows.Media.Imaging.BitmapSource object.
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members
ImGearPage Class


ImGearPageFromBitmapSource Method

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : ImGearPageFromBitmapSource Method
Converts System.Windows.Media.Imaging.BitmapSource to ImageGear.Core.ImGearPage.
Overload List
Overload | Description
ImGearPageFromBitmapSource | Converts System.Windows.Media.Imaging.BitmapSource to ImageGear.Core.ImGearPage.
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members


ImGearPageFromBitmapSource(BitmapSource) Method

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : ImGearPageFromBitmapSource(BitmapSource) Method
System.Windows.Media.Imaging.BitmapSource object to be converted.
Converts System.Windows.Media.Imaging.BitmapSource to ImageGear.Core.ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ImGearPageFromBitmapSource( _
   ByVal bitmapSource As BitmapSource _
) As ImGearPage
'Usage

Dim instance As ImGearBitmapSourceConverter
Dim bitmapSource As BitmapSource
Dim value As ImGearPage

value = instance.ImGearPageFromBitmapSource(bitmapSource)
public ImGearPage ImGearPageFromBitmapSource(
   BitmapSource bitmapSource
)
public: ImGearPage* ImGearPageFromBitmapSource(
   BitmapSource* bitmapSource
)
public:
ImGearPage^ ImGearPageFromBitmapSource(
   BitmapSource^ bitmapSource
)

Parameters

bitmapSource
System.Windows.Media.Imaging.BitmapSource object to be converted.

Return Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members


ThumbnailFromImGearPage Method

ImageGear22.Wpf Assembly > ImageGear.WPF.BitmapSourceConversion Namespace > ImGearBitmapSourceConverter Class : ThumbnailFromImGearPage Method
ImageGear.Core.ImGearPage object to be converted.
Maximum thumbnail width.
Maximum thumbnail height.
Background color for thumbnail.
Horizontal image resolution used for conversion.
Vertical image resolution used for conversion.
Interpolation options used for conversion.
Produces new resized System.Windows.Media.Imaging.BitmapSource from a given ImageGear.Core.ImGearPage.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ThumbnailFromImGearPage( _
   ByVal page As ImGearPage, _
   ByVal thumbnailWidth As Integer, _
   ByVal thumbnailHeight As Integer, _
   ByVal color As Color, _
   ByVal ppmX As Integer, _
   ByVal ppmY As Integer, _
   ByVal interpolation As ImGearInterpolationOptions _
) As BitmapSource
'Usage

Dim instance As ImGearBitmapSourceConverter
Dim page As ImGearPage
Dim thumbnailWidth As Integer
Dim thumbnailHeight As Integer
Dim color As Color
Dim ppmX As Integer
Dim ppmY As Integer
Dim interpolation As ImGearInterpolationOptions
Dim value As BitmapSource

value = instance.ThumbnailFromImGearPage(page, thumbnailWidth, thumbnailHeight, color, ppmX, ppmY, interpolation)
public BitmapSource ThumbnailFromImGearPage(
   ImGearPage page,
   int thumbnailWidth,
   int thumbnailHeight,
   Color color,
   int ppmX,
   int ppmY,
   ImGearInterpolationOptions interpolation
)
public: BitmapSource* ThumbnailFromImGearPage(
   ImGearPage* page,
   int thumbnailWidth,
   int thumbnailHeight,
   Color color,
   int ppmX,
   int ppmY,
   ImGearInterpolationOptions* interpolation
)
public:
BitmapSource^ ThumbnailFromImGearPage(
   ImGearPage^ page,
   int thumbnailWidth,
   int thumbnailHeight,
   Color color,
   int ppmX,
   int ppmY,
   ImGearInterpolationOptions^ interpolation
)

Parameters

page
ImageGear.Core.ImGearPage object to be converted.
thumbnailWidth
Maximum thumbnail width.
thumbnailHeight
Maximum thumbnail height.
color
Background color for thumbnail.
ppmX
Horizontal image resolution used for conversion.
ppmY
Vertical image resolution used for conversion.
interpolation
Interpolation options used for conversion.

Return Value

System.Windows.Media.Imaging.BitmapSource object.
See Also

Reference

ImGearBitmapSourceConverter Class
ImGearBitmapSourceConverter Members
ImGearPage Class
ImGearInterpolationOptions Class


ImageGear.WPF.HDP Namespace
Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.HDP Namespace

The ImageGear.WPF.HDP Namespace provides functionality for compatibility with the HD Photo (Windows Media Photo) format.

Classes
 | Class | Description
Class | ImGearHDPhoto | Initializes HD Photo file format.
See Also

Reference

ImageGear22.Wpf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.WPF.HDP Namespace Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.HDP Namespace
Inheritance Hierarchy
System.Object
ImageGear.WPF.HDP.ImGearHDPhoto
See Also

Reference

ImageGear22.Wpf Assembly


%%PageItemTitle%%

ImGearHDPhoto Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.HDP Namespace : ImGearHDPhoto Class
Initializes HD Photo file format.
Object Model
ImGearHDPhoto ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearHDPhoto
'Usage

Dim instance As ImGearHDPhoto
public sealed class ImGearHDPhoto
public __gc __sealed class ImGearHDPhoto
public ref class ImGearHDPhoto sealed
Remarks

NOTE:

HD Photo format when registered should be inserted before TIFF format because TIFF 2-bytes signature is a part of HD Photo format signature. See ImGearHDPhoto.CreateHDPhotoFormat method for details.

Inheritance Hierarchy

System.Object
ImageGear.WPF.HDP.ImGearHDPhoto

See Also

Reference

ImGearHDPhoto Members
ImageGear.WPF.HDP Namespace


%%PageItemTitle%% $$Members$$

ImGearHDPhoto Class Members
Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.HDP Namespace : ImGearHDPhoto Class

The following tables list the members exposed by ImGearHDPhoto.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateHDPhotoFormat | Creates an instance of HP Photo format that can be added to the collection of registered formats.
Top
See Also

Reference

ImGearHDPhoto Class
ImageGear.WPF.HDP Namespace


%%PageItemTitle%% $$Methods$$

ImGearHDPhoto Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.HDP Namespace : ImGearHDPhoto Class

For a list of all members of this type, see ImGearHDPhoto members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateHDPhotoFormat | Creates an instance of HP Photo format that can be added to the collection of registered formats.
Top
See Also

Reference

ImGearHDPhoto Class
ImageGear.WPF.HDP Namespace


CreateHDPhotoFormat Method

ImageGear22.Wpf Assembly > ImageGear.WPF.HDP Namespace > ImGearHDPhoto Class : CreateHDPhotoFormat Method
Creates an instance of HP Photo format that can be added to the collection of registered formats.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateHDPhotoFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearHDPhoto.CreateHDPhotoFormat()
public static IImGearFormat CreateHDPhotoFormat()
public: static IImGearFormat* CreateHDPhotoFormat();
public:
static IImGearFormat^ CreateHDPhotoFormat();

Return Value

ImageGear.Formats.IImGearFormat interface object.
Remarks

NOTE:

HD Photo format when registered should be inserted before TIFF format, because TIFF 2-bytes signature is a part of HD Photo format signature. This can be done using: ImGearFileFormats.Filters.Insert(0, ImGearHDPhoto.CreateHDPhotoFormat()).

See Also

Reference

ImGearHDPhoto Class
ImGearHDPhoto Members
IImGearFormat Interface


ImageGear.WPF.XPS Namespace
Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.XPS Namespace
ImageGear XPS namespace provides full multi-page reading, writing and printing support for XPS documents and pages. You can detect, read, write, append, insert, replace, delete and print specified pages in the XPS document as well as convert raster images to XPS.
Classes
 | Class | Description
Class | ImGearXPS | Initializes XPS file format.
Class | ImGearXPSDocument | Represents XPS document.
Class | ImGearXPSPage | Represents XPS page.
Class | ImGearXPSPrintOptions | Provides XPS printing options.
See Also

Reference

ImageGear22.Wpf Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.WPF.XPS Namespace Inheritance Hierarchy
ImageGear22.Wpf Assembly : ImageGear.WPF.XPS Namespace
Inheritance Hierarchy
System.Object
ImageGear.Core.ImGearDocument
ImageGear.WPF.XPS.ImGearXPSDocument
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.WPF.XPS.ImGearXPSPage
ImageGear.WPF.XPS.ImGearXPS
ImageGear.WPF.XPS.ImGearXPSPrintOptions
See Also

Reference

ImageGear22.Wpf Assembly


%%PageItemTitle%%

ImGearXPS Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPS Class
Initializes XPS file format.
Object Model
ImGearXPS ClassIImGearFormat Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearXPS
'Usage

Dim instance As ImGearXPS
public sealed class ImGearXPS
public __gc __sealed class ImGearXPS
public ref class ImGearXPS sealed
Inheritance Hierarchy

System.Object
ImageGear.WPF.XPS.ImGearXPS

See Also

Reference

ImGearXPS Members
ImageGear.WPF.XPS Namespace


%%PageItemTitle%% $$Members$$

ImGearXPS Class Members
Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPS Class

The following tables list the members exposed by ImGearXPS.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateXPSFormat | Creates an instance of XPS format.
Top
See Also

Reference

ImGearXPS Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%% $$Methods$$

ImGearXPS Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPS Class

For a list of all members of this type, see ImGearXPS members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateXPSFormat | Creates an instance of XPS format.
Top
See Also

Reference

ImGearXPS Class
ImageGear.WPF.XPS Namespace


CreateXPSFormat Method

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPS Class : CreateXPSFormat Method
Creates an instance of XPS format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateXPSFormat() As IImGearFormat
'Usage

Dim value As IImGearFormat

value = ImGearXPS.CreateXPSFormat()
public static IImGearFormat CreateXPSFormat()
public: static IImGearFormat* CreateXPSFormat();
public:
static IImGearFormat^ CreateXPSFormat();

Return Value

New instance of XPS format.
See Also

Reference

ImGearXPS Class
ImGearXPS Members
IImGearFormat Interface


%%PageItemTitle%%

ImGearXPSDocument Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSDocument Class
Represents XPS document.
Object Model
ImGearXPSDocument ClassImGearDocument ClassImGearDocumentPageArray ClassImGearPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXPSDocument
   Inherits ImageGear.Core.ImGearDocument
'Usage

Dim instance As ImGearXPSDocument
public class ImGearXPSDocument : ImageGear.Core.ImGearDocument
public __gc class ImGearXPSDocument : public ImageGear.Core.ImGearDocument
public ref class ImGearXPSDocument : public ImageGear.Core.ImGearDocument
Remarks

This class is used to work with XPS documents.

The XPS document can only be created and processed in single-threaded apartment (STA) threads.

Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearDocument
ImageGear.WPF.XPS.ImGearXPSDocument

See Also

Reference

ImGearXPSDocument Members
ImageGear.WPF.XPS Namespace


%%PageItemTitle%% $$Members$$

ImGearXPSDocument Class Members
Fields Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSDocument Class

The following tables list the members exposed by ImGearXPSDocument.

Public Constructors
 | Name | Description
Public Constructor | ImGearXPSDocument Constructor | Initializes a new instance of the ImGearXPSDocument class.
Top
Public Properties
 | Name | Description
Public Property | Pages | Overridden. Gets a collection of the document pages.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the document.
Public Method | InsertPage | Inserts ImageGear page into the current document.
Public Method | Print | Prints the document using native XPS printing.
Top
See Also

Reference

ImGearXPSDocument Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%% $$Fields$$

ImGearXPSDocument Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSDocument Class

For a list of all members of this type, see ImGearXPSDocument members.

See Also

Reference

ImGearXPSDocument Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%%

ImGearXPSDocument Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : ImGearXPSDocument Constructor
Initializes a new instance of the ImGearXPSDocument class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImGearXPSDocument()
public ImGearXPSDocument()
public: ImGearXPSDocument();
public:
ImGearXPSDocument();
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members


%%PageItemTitle%% $$Methods$$

ImGearXPSDocument Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSDocument Class

For a list of all members of this type, see ImGearXPSDocument members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the document.
Public Method | InsertPage | Inserts ImageGear page into the current document.
Public Method | Print | Prints the document using native XPS printing.
Top
See Also

Reference

ImGearXPSDocument Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%%

ImGearXPSDocument Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : ImGearXPSDocument Constructor
Overload List
Overload | Description
ImGearXPSDocument Constructor | Initializes a new instance of the ImGearXPSDocument class.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members


Clone Method (ImGearXPSDocument)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : Clone Method
Clones the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearDocument
'Usage

Dim instance As ImGearXPSDocument
Dim value As ImGearDocument

value = instance.Clone()
public override ImGearDocument Clone()
public: ImGearDocument* Clone(); override
public:
ImGearDocument^ Clone(); override

Return Value

Copy of the document.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members


Dispose Method (ImGearXPSDocument)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : Dispose Method
Releases all resources, being used.
Overload List
Overload | Description
Dispose(Boolean) | Releases all resources, being used.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members


Dispose(Boolean) Method

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class > Dispose Method : Dispose(Boolean) Method
Flag indicating whether the object is being disposed by the framework.
Releases all resources, being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ImGearXPSDocument
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
Flag indicating whether the object is being disposed by the framework.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members
Overload List


InsertPage Method (ImGearXPSDocument)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : InsertPage Method
Position where page is to be inserted. If it is less than 0 or more than total page count, it is appended after the last page.
ImageGear.Core.ImGearPage to be inserted.
Width of page, in 1/100 inches.
Height of page, in 1/100 inches.
Inserts ImageGear page into the current document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function InsertPage( _
   ByVal index As Integer, _
   ByVal page As ImGearPage, _
   ByVal width As Integer, _
   ByVal height As Integer _
) As Integer
'Usage

Dim instance As ImGearXPSDocument
Dim index As Integer
Dim page As ImGearPage
Dim width As Integer
Dim height As Integer
Dim value As Integer

value = instance.InsertPage(index, page, width, height)
public int InsertPage(
   int index,
   ImGearPage page,
   int width,
   int height
)
public: int InsertPage(
   int index,
   ImGearPage* page,
   int width,
   int height
)
public:
int InsertPage(
   int index,
   ImGearPage^ page,
   int width,
   int height
)

Parameters

index
Position where page is to be inserted. If it is less than 0 or more than total page count, it is appended after the last page.
page
ImageGear.Core.ImGearPage to be inserted.
width
Width of page, in 1/100 inches.
height
Height of page, in 1/100 inches.

Return Value

Position of the newly inserted page.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members
ImGearPage Class


Print Method (ImGearXPSDocument)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : Print Method
ImGearXPSPrintOptions object specifying printing options.
Prints the document using native XPS printing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Print( _
   ByVal printOptions As ImGearXPSPrintOptions _
)
'Usage

Dim instance As ImGearXPSDocument
Dim printOptions As ImGearXPSPrintOptions

instance.Print(printOptions)
public void Print(
   ImGearXPSPrintOptions printOptions
)
public: void Print(
   ImGearXPSPrintOptions* printOptions
)
public:
void Print(
   ImGearXPSPrintOptions^ printOptions
)

Parameters

printOptions
ImGearXPSPrintOptions object specifying printing options.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members
ImGearXPSPrintOptions Class


%%PageItemTitle%% $$Properties$$

ImGearXPSDocument Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSDocument Class

For a list of all members of this type, see ImGearXPSDocument members.

Public Properties
 | Name | Description
Public Property | Pages | Overridden. Gets a collection of the document pages.
Top
See Also

Reference

ImGearXPSDocument Class
ImageGear.WPF.XPS Namespace


Pages Property (ImGearXPSDocument)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSDocument Class : Pages Property
Gets a collection of the document pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Pages As ImGearDocumentPageArray
'Usage

Dim instance As ImGearXPSDocument
Dim value As ImGearDocumentPageArray

value = instance.Pages
public override ImGearDocumentPageArray Pages {get;}
public: __property ImGearDocumentPageArray* get_Pages() override;
public:
property ImGearDocumentPageArray^ Pages {
   ImGearDocumentPageArray^ get() override;
}

Property Value

ImageGear.Core.ImGearDocumentPageArray object.
Remarks
This property provides access to the document page array.
See Also

Reference

ImGearXPSDocument Class
ImGearXPSDocument Members


%%PageItemTitle%%

ImGearXPSPage Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPage Class
Represents XPS page.
Object Model
ImGearXPSPage ClassImGearPage ClassImGearRasterPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImGearXPSPage
   Inherits ImageGear.Core.ImGearVectorPage
'Usage

Dim instance As ImGearXPSPage
public class ImGearXPSPage : ImageGear.Core.ImGearVectorPage
public __gc class ImGearXPSPage : public ImageGear.Core.ImGearVectorPage
public ref class ImGearXPSPage : public ImageGear.Core.ImGearVectorPage
Remarks
This class is used to work with individual XPS pages.
Inheritance Hierarchy

System.Object
ImageGear.Core.ImGearPage
ImageGear.Core.ImGearVectorPage
ImageGear.WPF.XPS.ImGearXPSPage

See Also

Reference

ImGearXPSPage Members
ImageGear.WPF.XPS Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Members$$

ImGearXPSPage Class Members
Fields Properties Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPage Class

The following tables list the members exposed by ImGearXPSPage.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the global parameters.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearXPSPage class.
Top
See Also

Reference

ImGearXPSPage Class
ImageGear.WPF.XPS Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Fields$$

ImGearXPSPage Class Fields

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPage Class

For a list of all members of this type, see ImGearXPSPage members.

See Also

Reference

ImGearXPSPage Class
ImageGear.WPF.XPS Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Properties$$

ImGearXPSPage Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPage Class

For a list of all members of this type, see ImGearXPSPage members.

See Also

Reference

ImGearXPSPage Class
ImageGear.WPF.XPS Namespace
ImGearVectorPage Class


%%PageItemTitle%% $$Methods$$

ImGearXPSPage Class Methods

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPage Class

For a list of all members of this type, see ImGearXPSPage members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones the page.
Public Method | Rasterize | Overloaded. Overridden. Rasterizes the page using the global parameters.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | Finalizes an instance of the ImGearXPSPage class.
Top
See Also

Reference

ImGearXPSPage Class
ImageGear.WPF.XPS Namespace
ImGearVectorPage Class


Clone Method (ImGearXPSPage)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPage Class : Clone Method
Clones the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As ImGearPage
'Usage

Dim instance As ImGearXPSPage
Dim value As ImGearPage

value = instance.Clone()
public override ImGearPage Clone()
public: ImGearPage* Clone(); override
public:
ImGearPage^ Clone(); override

Return Value

ImageGear.Core.ImGearPage class object.
See Also

Reference

ImGearXPSPage Class
ImGearXPSPage Members
ImGearPage Class


Finalize Method (ImGearXPSPage)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPage Class : Finalize Method
Finalizes an instance of the ImGearXPSPage class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As ImGearXPSPage

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override
See Also

Reference

ImGearXPSPage Class
ImGearXPSPage Members


Rasterize Method (ImGearXPSPage)

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPage Class : Rasterize Method
Rasterizes the page using the global parameters.
Overload List
Overload | Description
Rasterize() | Rasterizes the page using the global parameters.
Rasterize(Int32,Int32,Int32) | Rasterizes the page using provided bit depth and resolution parameters.
See Also

Reference

ImGearXPSPage Class
ImGearXPSPage Members


Rasterize() Method

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPage Class > Rasterize Method : Rasterize() Method
Rasterizes the page using the global parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize() As ImGearRasterPage
'Usage

Dim instance As ImGearXPSPage
Dim value As ImGearRasterPage

value = instance.Rasterize()
public override ImGearRasterPage Rasterize()
public: ImGearRasterPage* Rasterize(); override
public:
ImGearRasterPage^ Rasterize(); override

Return Value

ImageGear.Core.ImGearRasterPage class.
See Also

Reference

ImGearXPSPage Class
ImGearXPSPage Members
Overload List
ImGearRasterPage Class


Rasterize(Int32,Int32,Int32) Method

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPage Class > Rasterize Method : Rasterize(Int32,Int32,Int32) Method
The bit depth of resulting raster page.
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
Rasterizes the page using provided bit depth and resolution parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Rasterize( _
   ByVal bitDepth As Integer, _
   ByVal resolutionX As Integer, _
   ByVal resolutionY As Integer _
) As ImGearRasterPage
'Usage

Dim instance As ImGearXPSPage
Dim bitDepth As Integer
Dim resolutionX As Integer
Dim resolutionY As Integer
Dim value As ImGearRasterPage

value = instance.Rasterize(bitDepth, resolutionX, resolutionY)
public override ImGearRasterPage Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
)
public: ImGearRasterPage* Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override
public:
ImGearRasterPage^ Rasterize(
   int bitDepth,
   int resolutionX,
   int resolutionY
) override

Parameters

bitDepth
The bit depth of resulting raster page.
resolutionX
This parameter specifies the horizontal resolution in dots-per-inch during the vector page conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
resolutionY
This parameter specifies the vertical resolution in dots-per-inch during the vector page conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.

Return Value

ImageGear.Core.ImGearRasterPage class instance with rasterized vector data.
Remarks
The parameter bitDepth is ignored. The DIB of output raster image will have RGBA color space with 32 bits per pixel depth.
See Also

Reference

ImGearXPSPage Class
ImGearXPSPage Members
Overload List
ImGearRasterPage Class


%%PageItemTitle%%

ImGearXPSPrintOptions Class
Members

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPrintOptions Class
Provides XPS printing options.
Object Model
ImGearXPSPrintOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class ImGearXPSPrintOptions
'Usage

Dim instance As ImGearXPSPrintOptions
public sealed class ImGearXPSPrintOptions
public __gc __sealed class ImGearXPSPrintOptions
public ref class ImGearXPSPrintOptions sealed
Inheritance Hierarchy

System.Object
ImageGear.WPF.XPS.ImGearXPSPrintOptions

See Also

Reference

ImGearXPSPrintOptions Members
ImageGear.WPF.XPS Namespace


%%PageItemTitle%% $$Members$$

ImGearXPSPrintOptions Class Members
Properties

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPrintOptions Class

The following tables list the members exposed by ImGearXPSPrintOptions.

Public Constructors
 | Name | Description
Public Constructor | ImGearXPSPrintOptions Constructor | Initializes a new instance of the ImGearXPSPrintOptions class.
Top
Public Properties
 | Name | Description
Public Property | PageRange | Gets the range of pages to be printed.
Public Property | PrintQueue | Gets a queue that should be used to print the document.
Public Property | PrintTicket | Gets the print job settings.
Top
See Also

Reference

ImGearXPSPrintOptions Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%%

ImGearXPSPrintOptions Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPrintOptions Class : ImGearXPSPrintOptions Constructor
Print queue to use to print the document.
Settings for the print job.
The range of pages to print.
Initializes a new instance of the ImGearXPSPrintOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal printQueue As PrintQueue, _
   ByVal printTicket As PrintTicket, _
   ByVal pageRange As PageRange _
)
'Usage

Dim printQueue As PrintQueue
Dim printTicket As PrintTicket
Dim pageRange As PageRange

Dim instance As New ImGearXPSPrintOptions(printQueue, printTicket, pageRange)
public ImGearXPSPrintOptions(
   PrintQueue printQueue,
   PrintTicket printTicket,
   PageRange pageRange
)
public: ImGearXPSPrintOptions(
   PrintQueue* printQueue,
   PrintTicket* printTicket,
   PageRange pageRange
)
public:
ImGearXPSPrintOptions(
   PrintQueue^ printQueue,
   PrintTicket^ printTicket,
   PageRange pageRange
)

Parameters

printQueue
Print queue to use to print the document.
printTicket
Settings for the print job.
pageRange
The range of pages to print.
See Also

Reference

ImGearXPSPrintOptions Class
ImGearXPSPrintOptions Members


%%PageItemTitle%% $$Properties$$

ImGearXPSPrintOptions Class Properties

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace : ImGearXPSPrintOptions Class

For a list of all members of this type, see ImGearXPSPrintOptions members.

Public Properties
 | Name | Description
Public Property | PageRange | Gets the range of pages to be printed.
Public Property | PrintQueue | Gets a queue that should be used to print the document.
Public Property | PrintTicket | Gets the print job settings.
Top
See Also

Reference

ImGearXPSPrintOptions Class
ImageGear.WPF.XPS Namespace


%%PageItemTitle%%

ImGearXPSPrintOptions Constructor

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPrintOptions Class : ImGearXPSPrintOptions Constructor
Overload List
Overload | Description
ImGearXPSPrintOptions Constructor | Initializes a new instance of the ImGearXPSPrintOptions class.
See Also

Reference

ImGearXPSPrintOptions Class
ImGearXPSPrintOptions Members


PageRange Property

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPrintOptions Class : PageRange Property
Gets the range of pages to be printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageRange As PageRange
'Usage

Dim instance As ImGearXPSPrintOptions
Dim value As PageRange

value = instance.PageRange
public PageRange PageRange {get;}
public: __property PageRange get_PageRange();
public:
property PageRange PageRange {
   PageRange get();
}

Property Value

System.Windows.Controls.PageRange structure.
See Also

Reference

ImGearXPSPrintOptions Class
ImGearXPSPrintOptions Members


PrintQueue Property

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPrintOptions Class : PrintQueue Property
Gets a queue that should be used to print the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrintQueue As PrintQueue
'Usage

Dim instance As ImGearXPSPrintOptions
Dim value As PrintQueue

value = instance.PrintQueue
public PrintQueue PrintQueue {get;}
public: __property PrintQueue* get_PrintQueue();
public:
property PrintQueue^ PrintQueue {
   PrintQueue^ get();
}

Property Value

System.Printing.PrintQueue value.
See Also

Reference

ImGearXPSPrintOptions Class
ImGearXPSPrintOptions Members


PrintTicket Property

ImageGear22.Wpf Assembly > ImageGear.WPF.XPS Namespace > ImGearXPSPrintOptions Class : PrintTicket Property
Gets the print job settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrintTicket As PrintTicket
'Usage

Dim instance As ImGearXPSPrintOptions
Dim value As PrintTicket

value = instance.PrintTicket
public PrintTicket PrintTicket {get;}
public: __property PrintTicket* get_PrintTicket();
public:
property PrintTicket^ PrintTicket {
   PrintTicket^ get();
}

Property Value

System.Printing.PrintTicket object.
See Also

Reference

ImGearXPSPrintOptions Class
ImGearXPSPrintOptions Members


ImageGear.Web.Isis Namespace Client API Library
Namespaces
Namespace | Description
ImageGear.Web.Isis | The ImageGear.Web.Isis namespace provides functionality for obtaining an ImGearPage or ImGearDocument from an ISIS or TWAIN compliant device in a web-based application running in a browser.


ImageGear.Web.Isis Namespace
Inheritance Hierarchy
ImageGear.Web.Isis Namespace Client API Library : ImageGear.Web.Isis Namespace
The ImageGear.Web.Isis namespace provides functionality for obtaining an ImGearPage or ImGearDocument from an ISIS or TWAIN compliant device in a web-based application running in a browser.
Classes
class | Description
ImGearIsisBarcode | A barcode detected on a scanned image.
ImGearIsisBarcodeCollection | A collection of barcodes.
ImGearIsisColorFormat | The color format of an image.
ImGearIsisCreateSessionArgs | Represents a create session parameters object.
ImGearIsisDocumentRetrievedResult | A document retrieved result.
ImGearIsisEndorserInfo | Scanner endorser information.
ImGearIsisEndorserInfoCollection | A collection of endorser info.
ImGearIsisImageInfo | Characteristics of an image.
ImGearIsisMetadata | Commonly used supplemental information about a scanned image.
ImGearIsisOperationStatus | The status of an ISIS operation.
ImGearIsisPageRetrievedResult | A page retrieved result.
ImGearIsisScanArgs | Represents a scan parameters object.
ImGearIsisScanJob | A scan job.
ImGearIsisScanner | Represents a scanner that can be set by the ImGearIsisScannerSession and used to scan images.
ImGearIsisScannerCollection | A collection of scanners.
ImGearIsisScannerService | A scanner service.
ImGearIsisScannerSession | A scanner session.
ImGearIsisTagChoices | The set of choices that are valid for an ISIS tag.
ImGearIsisTagIntegerCollection | A collection of tag integers.
ImGearIsisTagRationalDenominatorCollection | A collection of tag rational denominators.
ImGearIsisTagStringCollection | A collection of tag strings.
ImGearIsisTagValue | The choice value of an ISIS tag.
Enumerations
Enumeration | Description
ImGearIsisBarcodeDataType | Progress indicators for tasks.
ImGearIsisChoiceKind | The method used to describe the choices for a tag.
ImGearIsisFileFormat | Supported file formats.
ImGearIsisFileType | Image file types.
ImGearIsisImageCompression | Image compression types.
ImGearIsisLoadScannerOption | Option to show configuration UI.
ImGearIsisOrientation | Image orientation values.
ImGearIsisPageSide | Page side indentifier.
ImGearIsisPhotometric | Color interpretation.
ImGearIsisResolutionUnit | Values for the resolution unit tag.
ImGearIsisScanAhead | Values for the scan ahead tag.
ImGearIsisScanDataType | Specifies the type of data to provide when an image is scanned.
ImGearIsisScanType | Values for the scan type tag.
ImGearIsisStatus | Progress indicators for tasks.
ImGearIsisTag | ISIS tag IDs.
ImGearIsisTagType | Data types for ISIS tags.
See Also

Reference

ImageGear.Web.Isis Namespace Client API Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.Isis Namespace Inheritance Hierarchy
ImageGear.Web.Isis Namespace Client API Library : ImageGear.Web.Isis Namespace
Inheritance Hierarchy
System.Object
ImageGear.Web.Isis.ImGearIsisBarcode
ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImageGear.Web.Isis.ImGearIsisColorFormat
ImageGear.Web.Isis.ImGearIsisCreateSessionArgs
ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult
ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImageGear.Web.Isis.ImGearIsisImageInfo
ImageGear.Web.Isis.ImGearIsisMetadata
ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImageGear.Web.Isis.ImGearIsisScanArgs
ImageGear.Web.Isis.ImGearIsisScanner
ImageGear.Web.Isis.ImGearIsisScannerCollection
ImageGear.Web.Isis.ImGearIsisScannerService
ImageGear.Web.Isis.ImGearIsisScannerSession
ImageGear.Web.Isis.ImGearIsisTagChoices
ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImageGear.Web.Isis.ImGearIsisTagValue
See Also

Reference

ImageGear.Web.Isis Namespace Client API Library


%%PageItemTitle%%

ImGearIsisBarcode class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcode class
A barcode detected on a scanned image.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisBarcode = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisBarcode();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisBarcode

See Also

Reference

ImGearIsisBarcode Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisBarcode class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcode class

The following tables list the members exposed by ImGearIsisBarcode.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisBarcode Constructor |
Top
Public Properties
 | Name | Description
public Property | height | Gets the barcode height, in pixels.
public Property | orientation | Gets the barcode orientation.
public Property | text | Gets the text of the barcode.
public Property | type | Gets the barcode type.
public Property | width | Gets the barcode width, in pixels.
public Property | x | Gets the X position of the detected barcode.
public Property | y | Gets the Y position of the detected barcode.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisBarcode Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : ImGearIsisBarcode Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisBarcode = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisBarcode();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%% $$Properties$$

ImGearIsisBarcode class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcode class

For a list of all members of this type, see ImGearIsisBarcode members.

Public Properties
 | Name | Description
public Property | height | Gets the barcode height, in pixels.
public Property | orientation | Gets the barcode orientation.
public Property | text | Gets the text of the barcode.
public Property | type | Gets the barcode type.
public Property | width | Gets the barcode width, in pixels.
public Property | x | Gets the X position of the detected barcode.
public Property | y | Gets the Y position of the detected barcode.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

height Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : height Property
Gets the barcode height, in pixels.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_height() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_height();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

orientation Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : orientation Property
Gets the barcode orientation.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_orientation() : ImGearIsisOrientation
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_orientation();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

text Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : text Property
Gets the text of the barcode.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_text() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_text();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

type Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : type Property
Gets the barcode type.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_type() : ImageGear.Web.Isis.ImGearIsisBarcodeType
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_type();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

width Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : width Property
Gets the barcode width, in pixels.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_width() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_width();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

x Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : x Property
Gets the X position of the detected barcode.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_x() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_x();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

y Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode : y Property
Gets the Y position of the detected barcode.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_y() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcode.get_y();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcode
ImGearIsisBarcode Members


%%PageItemTitle%%

ImGearIsisBarcodeCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcodeCollection class
A collection of barcodes.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisBarcodeCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisBarcodeCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisBarcodeCollection

See Also

Reference

ImGearIsisBarcodeCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisBarcodeCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcodeCollection class

The following tables list the members exposed by ImGearIsisBarcodeCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisBarcodeCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getBarcode | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisBarcodeCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection : ImGearIsisBarcodeCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisBarcodeCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisBarcodeCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImGearIsisBarcodeCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisBarcodeCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcodeCollection class

For a list of all members of this type, see ImGearIsisBarcodeCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getBarcode | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcodeCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImGearIsisBarcodeCollection Members


%%PageItemTitle%%

getBarcode Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection : getBarcode Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getBarcode(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcodeCollection.getBarcode(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImGearIsisBarcodeCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisBarcodeCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcodeCollection class

For a list of all members of this type, see ImGearIsisBarcodeCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisBarcodeCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisBarcodeCollection
ImGearIsisBarcodeCollection Members


%%PageItemTitle%%

ImGearIsisColorFormat class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisColorFormat class
The color format of an image.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisColorFormat = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisColorFormat();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisColorFormat

See Also

Reference

ImGearIsisColorFormat Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisColorFormat class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisColorFormat class

The following tables list the members exposed by ImGearIsisColorFormat.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisColorFormat Constructor |
Top
Public Properties
 | Name | Description
public Property | bitsPerSample | Gets the number of bits of storage used to define each sample in an image.
public Property | photometric | Gets the photometric interpretation of the image, which indicates how colors are interpreted in the image data.
public Property | samplesPerPixel | Gets the number of samples that are combined to define each pixel in an image.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisColorFormat Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat : ImGearIsisColorFormat Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisColorFormat = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisColorFormat();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImGearIsisColorFormat Members


%%PageItemTitle%% $$Properties$$

ImGearIsisColorFormat class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisColorFormat class

For a list of all members of this type, see ImGearIsisColorFormat members.

Public Properties
 | Name | Description
public Property | bitsPerSample | Gets the number of bits of storage used to define each sample in an image.
public Property | photometric | Gets the photometric interpretation of the image, which indicates how colors are interpreted in the image data.
public Property | samplesPerPixel | Gets the number of samples that are combined to define each pixel in an image.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

bitsPerSample Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat : bitsPerSample Property
Gets the number of bits of storage used to define each sample in an image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_bitsPerSample() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisColorFormat.get_bitsPerSample();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImGearIsisColorFormat Members


%%PageItemTitle%%

photometric Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat : photometric Property
Gets the photometric interpretation of the image, which indicates how colors are interpreted in the image data.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_photometric() : ImGearIsisPhotometric
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisColorFormat.get_photometric();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImGearIsisColorFormat Members


%%PageItemTitle%%

samplesPerPixel Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat : samplesPerPixel Property
Gets the number of samples that are combined to define each pixel in an image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_samplesPerPixel() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisColorFormat.get_samplesPerPixel();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisColorFormat
ImGearIsisColorFormat Members


%%PageItemTitle%%

ImGearIsisCreateSessionArgs class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisCreateSessionArgs class
Represents a create session parameters object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisCreateSessionArgs = function(
   applicationName : string,
   destroyExistingSession : boolean,
   locale : string,
   idleTimeoutMinutes : number(Integer),
   callback : function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisCreateSessionArgs();
Remarks

This object contains the arguments for the ImageGear.Web.Isis.ImGearIsisScannerService.createSession method.

It is not strictly necessary to create an object of this type for providing the parameters. The example code in the ImageGear.Web.Isis.ImGearIsisScannerService.createSession method shows another acceptable way to pass the parameters. This class identifies the fields that are represented in the createSession parameter object.

Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisCreateSessionArgs

See Also

Reference

ImGearIsisCreateSessionArgs Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisCreateSessionArgs class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisCreateSessionArgs class

The following tables list the members exposed by ImGearIsisCreateSessionArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisCreateSessionArgs Constructor |
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisCreateSessionArgs
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisCreateSessionArgs Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisCreateSessionArgs : ImGearIsisCreateSessionArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisCreateSessionArgs = function(
   applicationName : string,
   destroyExistingSession : boolean,
   locale : string,
   idleTimeoutMinutes : number(Integer),
   callback : function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisCreateSessionArgs(string,boolean,string,number(Integer),function);

Parameters

applicationName
destroyExistingSession
locale
idleTimeoutMinutes
callback
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisCreateSessionArgs
ImGearIsisCreateSessionArgs Members


%%PageItemTitle%%

ImGearIsisDocumentRetrievedResult class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisDocumentRetrievedResult class
A document retrieved result.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult

See Also

Reference

ImGearIsisDocumentRetrievedResult Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisDocumentRetrievedResult class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisDocumentRetrievedResult class

The following tables list the members exposed by ImGearIsisDocumentRetrievedResult.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisDocumentRetrievedResult Constructor |
Top
Public Properties
 | Name | Description
public Property | base64Document | Gets the scanned page data as a base 64 string.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisDocumentRetrievedResult Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult : ImGearIsisDocumentRetrievedResult Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult
ImGearIsisDocumentRetrievedResult Members


%%PageItemTitle%% $$Properties$$

ImGearIsisDocumentRetrievedResult class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisDocumentRetrievedResult class

For a list of all members of this type, see ImGearIsisDocumentRetrievedResult members.

Public Properties
 | Name | Description
public Property | base64Document | Gets the scanned page data as a base 64 string.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

base64Document Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult : base64Document Property
Gets the scanned page data as a base 64 string.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_base64Document() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisDocumentRetrievedResult.get_base64Document();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisDocumentRetrievedResult
ImGearIsisDocumentRetrievedResult Members


%%PageItemTitle%%

ImGearIsisEndorserInfo class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfo class
Scanner endorser information.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisEndorserInfo = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisEndorserInfo();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisEndorserInfo

See Also

Reference

ImGearIsisEndorserInfo Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisEndorserInfo class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfo class

The following tables list the members exposed by ImGearIsisEndorserInfo.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisEndorserInfo Constructor |
Top
Public Properties
 | Name | Description
public Property | id | Gets the imprinter unit identifier.
public Property | lastEndorserString | Gets the endorser text printed on the page.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisEndorserInfo Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo : ImGearIsisEndorserInfo Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisEndorserInfo = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisEndorserInfo();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImGearIsisEndorserInfo Members


%%PageItemTitle%% $$Properties$$

ImGearIsisEndorserInfo class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfo class

For a list of all members of this type, see ImGearIsisEndorserInfo members.

Public Properties
 | Name | Description
public Property | id | Gets the imprinter unit identifier.
public Property | lastEndorserString | Gets the endorser text printed on the page.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

id Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo : id Property
Gets the imprinter unit identifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_id() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisEndorserInfo.get_id();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImGearIsisEndorserInfo Members


%%PageItemTitle%%

lastEndorserString Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo : lastEndorserString Property
Gets the endorser text printed on the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_lastEndorserString() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisEndorserInfo.get_lastEndorserString();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfo
ImGearIsisEndorserInfo Members


%%PageItemTitle%%

ImGearIsisEndorserInfoCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfoCollection class
A collection of endorser info.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection

See Also

Reference

ImGearIsisEndorserInfoCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisEndorserInfoCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfoCollection class

The following tables list the members exposed by ImGearIsisEndorserInfoCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisEndorserInfoCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getEndorserInfo | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisEndorserInfoCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection : ImGearIsisEndorserInfoCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImGearIsisEndorserInfoCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisEndorserInfoCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfoCollection class

For a list of all members of this type, see ImGearIsisEndorserInfoCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getEndorserInfo | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisEndorserInfoCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImGearIsisEndorserInfoCollection Members


%%PageItemTitle%%

getEndorserInfo Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection : getEndorserInfo Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getEndorserInfo(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisEndorserInfoCollection.getEndorserInfo(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImGearIsisEndorserInfoCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisEndorserInfoCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisEndorserInfoCollection class

For a list of all members of this type, see ImGearIsisEndorserInfoCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisEndorserInfoCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisEndorserInfoCollection
ImGearIsisEndorserInfoCollection Members


%%PageItemTitle%%

ImGearIsisImageInfo class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisImageInfo class
Characteristics of an image.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisImageInfo = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisImageInfo();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisImageInfo

See Also

Reference

ImGearIsisImageInfo Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisImageInfo class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisImageInfo class

The following tables list the members exposed by ImGearIsisImageInfo.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisImageInfo Constructor |
Top
Public Properties
 | Name | Description
public Property | colorFormat | Gets the color format of the image.
public Property | compression | Gets the type of compression used to store the image data.
public Property | fileType | Gets the file type of the image file.
public Property | height | Gets the height of the image, in pixels.
public Property | width | Gets the width of the image, in pixels.
public Property | xResolution | Gets the horizontal resolution of the image, in dots per inch.
public Property | yResolution | Gets the vertical resolution of the image, in dots per inch.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisImageInfo Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : ImGearIsisImageInfo Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisImageInfo = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisImageInfo();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%% $$Properties$$

ImGearIsisImageInfo class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisImageInfo class

For a list of all members of this type, see ImGearIsisImageInfo members.

Public Properties
 | Name | Description
public Property | colorFormat | Gets the color format of the image.
public Property | compression | Gets the type of compression used to store the image data.
public Property | fileType | Gets the file type of the image file.
public Property | height | Gets the height of the image, in pixels.
public Property | width | Gets the width of the image, in pixels.
public Property | xResolution | Gets the horizontal resolution of the image, in dots per inch.
public Property | yResolution | Gets the vertical resolution of the image, in dots per inch.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

colorFormat Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : colorFormat Property
Gets the color format of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_colorFormat() : ImGearIsisColorFormat
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_colorFormat();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

compression Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : compression Property
Gets the type of compression used to store the image data.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_compression() : ImGearIsisImageCompression
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_compression();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

fileType Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : fileType Property
Gets the file type of the image file.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fileType() : ImGearIsisFileType
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_fileType();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

height Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : height Property
Gets the height of the image, in pixels.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_height() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_height();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

width Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : width Property
Gets the width of the image, in pixels.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_width() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_width();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

xResolution Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : xResolution Property
Gets the horizontal resolution of the image, in dots per inch.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_xResolution() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_xResolution();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

yResolution Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo : yResolution Property
Gets the vertical resolution of the image, in dots per inch.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_yResolution() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisImageInfo.get_yResolution();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisImageInfo
ImGearIsisImageInfo Members


%%PageItemTitle%%

ImGearIsisMetadata class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisMetadata class
Commonly used supplemental information about a scanned image.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisMetadata = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisMetadata();
Remarks
Additional metadata can be stored and retrieved using ImGearIsisMetadataValue objects.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisMetadata

See Also

Reference

ImGearIsisMetadata Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisMetadata class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisMetadata class

The following tables list the members exposed by ImGearIsisMetadata.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisMetadata Constructor |
Top
Public Properties
 | Name | Description
public Property | barcodes | Gets the list of barcodes detected on the image.
public Property | endorserStrings | Gets the endorser strings.
public Property | hardwareJobSeparator | Gets a value indicating whether the page is a hardware job separator.
public Property | pageSide | Gets a value that indicates which side of the sheet of paper the image was originally on.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisMetadata Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata : ImGearIsisMetadata Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisMetadata = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisMetadata();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImGearIsisMetadata Members


%%PageItemTitle%% $$Properties$$

ImGearIsisMetadata class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisMetadata class

For a list of all members of this type, see ImGearIsisMetadata members.

Public Properties
 | Name | Description
public Property | barcodes | Gets the list of barcodes detected on the image.
public Property | endorserStrings | Gets the endorser strings.
public Property | hardwareJobSeparator | Gets a value indicating whether the page is a hardware job separator.
public Property | pageSide | Gets a value that indicates which side of the sheet of paper the image was originally on.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

barcodes Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata : barcodes Property
Gets the list of barcodes detected on the image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_barcodes() : ImGearIsisBarcodeCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisMetadata.get_barcodes();
Remarks
If your scanner does not perform barcode detection, this value will be empty.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImGearIsisMetadata Members


%%PageItemTitle%%

endorserStrings Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata : endorserStrings Property
Gets the endorser strings.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_endorserStrings() : ImGearIsisEndorserInfoCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisMetadata.get_endorserStrings();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImGearIsisMetadata Members


%%PageItemTitle%%

hardwareJobSeparator Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata : hardwareJobSeparator Property
Gets a value indicating whether the page is a hardware job separator.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_hardwareJobSeparator() : boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisMetadata.get_hardwareJobSeparator();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImGearIsisMetadata Members


%%PageItemTitle%%

pageSide Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata : pageSide Property
Gets a value that indicates which side of the sheet of paper the image was originally on.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageSide() : ImGearIsisPageSide
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisMetadata.get_pageSide();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisMetadata
ImGearIsisMetadata Members


%%PageItemTitle%%

ImGearIsisOperationStatus class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisOperationStatus class
The status of an ISIS operation.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisOperationStatus = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisOperationStatus();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis.ImGearIsisScanJob

See Also

Reference

ImGearIsisOperationStatus Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisOperationStatus class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisOperationStatus class

The following tables list the members exposed by ImGearIsisOperationStatus.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisOperationStatus Constructor |
Top
Public Properties
 | Name | Description
public Property | status | Gets the status.
public Property | statusMessage | Gets the status message.
Top
Public Methods
 | Name | Description
public Method | updateStatus | Updates the status of the operation.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisOperationStatus Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus : ImGearIsisOperationStatus Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisOperationStatus = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisOperationStatus();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImGearIsisOperationStatus Members


%%PageItemTitle%% $$Methods$$

ImGearIsisOperationStatus class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisOperationStatus class

For a list of all members of this type, see ImGearIsisOperationStatus members.

Public Methods
 | Name | Description
public Method | updateStatus | Updates the status of the operation.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

updateStatus Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus : updateStatus Method
Updates the status of the operation.
Syntax
ASP.NET Ajax Javascript (Specification)
function updateStatus(
   callback : function
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisOperationStatus.updateStatus(function);

Parameters

callback
Callback which is called when the status is updated.
Example

The JavaScript code below demonstrates how to update the status of an operation, where operationStatus is an ImGearIsisOperationStatus object returned when previously making an asynchronous call:

  • JavaScript
function updateStatusCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

operationStatus.updateStatus(updateStatusCallback);
Remarks

This is an asynchronous method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImGearIsisOperationStatus Members


%%PageItemTitle%% $$Properties$$

ImGearIsisOperationStatus class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisOperationStatus class

For a list of all members of this type, see ImGearIsisOperationStatus members.

Public Properties
 | Name | Description
public Property | status | Gets the status.
public Property | statusMessage | Gets the status message.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

status Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus : status Property
Gets the status.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_status() : ImGearIsisStatus
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisOperationStatus.get_status();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImGearIsisOperationStatus Members


%%PageItemTitle%%

statusMessage Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus : statusMessage Property
Gets the status message.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_statusMessage() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisOperationStatus.get_statusMessage();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisOperationStatus
ImGearIsisOperationStatus Members


%%PageItemTitle%%

ImGearIsisPageRetrievedResult class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisPageRetrievedResult class
A page retrieved result.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisPageRetrievedResult = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisPageRetrievedResult();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisPageRetrievedResult

See Also

Reference

ImGearIsisPageRetrievedResult Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisPageRetrievedResult class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisPageRetrievedResult class

The following tables list the members exposed by ImGearIsisPageRetrievedResult.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisPageRetrievedResult Constructor |
Top
Public Properties
 | Name | Description
public Property | base64Page | Gets the scanned page data as a base 64 string.
public Property | imageInfo | Gets the scanned image information.
public Property | metadata | Gets metadata of the scanned image.
public Property | pageNumber | Gets the page number.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisPageRetrievedResult Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult : ImGearIsisPageRetrievedResult Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisPageRetrievedResult = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisPageRetrievedResult();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImGearIsisPageRetrievedResult Members


%%PageItemTitle%% $$Properties$$

ImGearIsisPageRetrievedResult class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisPageRetrievedResult class

For a list of all members of this type, see ImGearIsisPageRetrievedResult members.

Public Properties
 | Name | Description
public Property | base64Page | Gets the scanned page data as a base 64 string.
public Property | imageInfo | Gets the scanned image information.
public Property | metadata | Gets metadata of the scanned image.
public Property | pageNumber | Gets the page number.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

base64Page Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult : base64Page Property
Gets the scanned page data as a base 64 string.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_base64Page() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisPageRetrievedResult.get_base64Page();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImGearIsisPageRetrievedResult Members


%%PageItemTitle%%

imageInfo Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult : imageInfo Property
Gets the scanned image information.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_imageInfo() : ImGearIsisImageInfo
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisPageRetrievedResult.get_imageInfo();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImGearIsisPageRetrievedResult Members


%%PageItemTitle%%

metadata Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult : metadata Property
Gets metadata of the scanned image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_metadata() : ImGearIsisMetadata
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisPageRetrievedResult.get_metadata();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImGearIsisPageRetrievedResult Members


%%PageItemTitle%%

pageNumber Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult : pageNumber Property
Gets the page number.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageNumber() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisPageRetrievedResult.get_pageNumber();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisPageRetrievedResult
ImGearIsisPageRetrievedResult Members


%%PageItemTitle%%

ImGearIsisScanArgs class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanArgs class
Represents a scan parameters object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanArgs = function(
   pages : number,
   scanDataType : ImGearIsisScanDataType,
   fileFormat : ImGearIsisFileFormat,
   fileType : ImGearIsisFileType,
   compression : ImGearIsisImageCompression,
   pageRetrievedCallback : function,
   documentRetrievedCallback : function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanArgs();
Remarks

This object contains the arguments for the ImageGear.Web.Isis.ImGearIsisScannerSession.scan method.

It is not strictly necessary to create an object of this type for providing the parameters. The example code in the ImageGear.Web.Isis.ImGearIsisScannerSession.scan method shows another acceptable way to pass the parameters. This class identifies the fields that are represented in the scan parameter object.

Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScanArgs

See Also

Reference

ImGearIsisScanArgs Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScanArgs class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanArgs class

The following tables list the members exposed by ImGearIsisScanArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScanArgs Constructor |
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanArgs
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanArgs Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanArgs : ImGearIsisScanArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanArgs = function(
   pages : number,
   scanDataType : ImGearIsisScanDataType,
   fileFormat : ImGearIsisFileFormat,
   fileType : ImGearIsisFileType,
   compression : ImGearIsisImageCompression,
   pageRetrievedCallback : function,
   documentRetrievedCallback : function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanArgs(number,ImGearIsisScanDataType,ImGearIsisFileFormat,ImGearIsisFileType,ImGearIsisImageCompression,function,function);

Parameters

pages
scanDataType
fileFormat
fileType
compression
pageRetrievedCallback
documentRetrievedCallback
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanArgs
ImGearIsisScanArgs Members


%%PageItemTitle%%

ImGearIsisScanJob class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanJob class
A scan job.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanJob = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanJob();
Remarks
This class provides the status of a scan operation.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisOperationStatus
ImageGear.Web.Isis.ImGearIsisScanJob

See Also

Reference

ImGearIsisScanJob Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScanJob class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanJob class

The following tables list the members exposed by ImGearIsisScanJob.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScanJob Constructor |
Top
Public Properties
 | Name | Description
public Property | status | Gets the status. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
public Property | statusMessage | Gets the status message. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
Top
Public Methods
 | Name | Description
public Method | cancel | Cancels the scanning operation.
public Method | destroy | Destroys the scan job (cancels scanning, if needed) and releases all resources including all images.
public Method | updateStatus | Updates the status of the operation. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanJob Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob : ImGearIsisScanJob Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanJob = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanJob();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImGearIsisScanJob Members


%%PageItemTitle%% $$Methods$$

ImGearIsisScanJob class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanJob class

For a list of all members of this type, see ImGearIsisScanJob members.

Public Methods
 | Name | Description
public Method | cancel | Cancels the scanning operation.
public Method | destroy | Destroys the scan job (cancels scanning, if needed) and releases all resources including all images.
public Method | updateStatus | Updates the status of the operation. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Properties$$

ImGearIsisScanJob class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanJob class

For a list of all members of this type, see ImGearIsisScanJob members.

Public Properties
 | Name | Description
public Property | status | Gets the status. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
public Property | statusMessage | Gets the status message. (Inherited from ImageGear.Web.Isis.ImGearIsisOperationStatus)
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

cancel Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob : cancel Method
Cancels the scanning operation.
Syntax
ASP.NET Ajax Javascript (Specification)
function cancel(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanJob.cancel(function);

Parameters

callback
Callback which is called when the scan job is cancelled.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to cancel a scan job:

  • JavaScript
function cancelCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scanJob.cancel(cancelCallback);
Remarks

This is an asynchronous method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImGearIsisScanJob Members


%%PageItemTitle%%

destroy Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob : destroy Method
Destroys the scan job (cancels scanning, if needed) and releases all resources including all images.
Syntax
ASP.NET Ajax Javascript (Specification)
function destroy(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanJob.destroy(function);

Parameters

callback
Callback which is called when the scan job is destroyed.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to destroy a scan job:

  • JavaScript
function destroyCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scanJob.destroy(destroyCallback);
Remarks

This is an asynchronous method.

A scan job does not end automatically when scanning is complete. To end the scan job but continue working in the same session, you must specifically call the destroy method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanJob
ImGearIsisScanJob Members


%%PageItemTitle%%

ImGearIsisScanner class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanner class
Represents a scanner that can be set by the ImGearIsisScannerSession and used to scan images.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanner = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanner();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScanner

See Also

Reference

ImGearIsisScanner Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScanner class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanner class

The following tables list the members exposed by ImGearIsisScanner.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScanner Constructor |
Top
Public Properties
 | Name | Description
public Property | name | Gets the name of the scanner.
public Property | selected | Gets a value indicating whether the scanner is selected.
Top
Public Methods
 | Name | Description
public Method | getAllTags | Gets the current configuration of the scanner in use.
public Method | getTag | Gets the current value of an ISIS tag.
public Method | setAllTags | Configures the scanner in use with the specified setting string.
public Method | setTagInteger | Sets the value of an ISIS tag of data type Integer.
public Method | setTagRational | Sets the value of an ISIS tag of data type Rational.
public Method | setTagString | Sets the value of an ISIS tag of data type String.
public Method | showUI | Displays the configuration window for the currently loaded scanner.
public Method | unload | Unloads a scanner without closing the active session.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanner Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : ImGearIsisScanner Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScanner = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScanner();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%% $$Methods$$

ImGearIsisScanner class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanner class

For a list of all members of this type, see ImGearIsisScanner members.

Public Methods
 | Name | Description
public Method | getAllTags | Gets the current configuration of the scanner in use.
public Method | getTag | Gets the current value of an ISIS tag.
public Method | setAllTags | Configures the scanner in use with the specified setting string.
public Method | setTagInteger | Sets the value of an ISIS tag of data type Integer.
public Method | setTagRational | Sets the value of an ISIS tag of data type Rational.
public Method | setTagString | Sets the value of an ISIS tag of data type String.
public Method | showUI | Displays the configuration window for the currently loaded scanner.
public Method | unload | Unloads a scanner without closing the active session.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

getAllTags Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : getAllTags Method
Gets the current configuration of the scanner in use.
Syntax
ASP.NET Ajax Javascript (Specification)
function getAllTags(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.getAllTags(function);

Parameters

callback
Callback which is called when all tags are retrieved.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to get all scanner ISIS tags:

  • JavaScript
var scannerSettings = "";
...
function getAllTagsCallback(settingString, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
    scannerSettings = settingString;
}

scannerSession.get_scanner().getAllTags(getAllTagsCallback);
Remarks

This is an asynchronous method.

The scanner must be set before calling this method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

getTag Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : getTag Method
Gets the current value of an ISIS tag.
Syntax
ASP.NET Ajax Javascript (Specification)
function getTag(
   tagID : number(Integer),
   index : number(Integer),
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.getTag(number(Integer),number(Integer),function);

Parameters

tagID
The ID of the tag.
index
The index to use, for tags that contain multiple values. If the tag contains only a single value, this must be 0.
callback
Callback which is called when the tag is retrieved.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to get a scanner ISIS tag, where pageSizeSelect is an HTML select element:

  • JavaScript
function getTagCallback(tagID, tagType, choices, tagValue, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }

    var pageSizeSelect = document.getElementById("pageSizeSelect");
    // The page sizes are provided as strings. The choices argument contains properties for getting the list of strings, integers, or numerators and
    // denominators or the minimum, maximum, and step values for a range of integers or numerators and denominators. The tagValue argument contains
    // properties for getting the current string value, integer value, or numerator and denominator values. You can check the tagType argument to
    // determine if the tag values are string, integer, or rational. You can check the choiceKind property of the choices argument to determine if
    // the tag values are provided as a range or in a list. See the ASP .NET ISIS sample for more code that demonstrates accessing the getTag callback
    // arguments for different tags.
    var stringList = choices.get_stringList();
    for (var i = 0; i < stringList.get_length(); i++) {
        var tagString = stringList.getTagString(i);
        var option = document.createElement("option");
        option.text = tagString;
        pageSizeSelect.add(option, null);
    }
}

scannerSession.get_scanner().getTag(ImageGear.Web.Isis.ImGearIsisTag.PageSize, 0, getTagCallback);
Remarks

This is an asynchronous method.

The scanner must be set before calling this method.

For more information on ISIS tags, refer to the ISIS Tags topic.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

setAllTags Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : setAllTags Method
Configures the scanner in use with the specified setting string.
Syntax
ASP.NET Ajax Javascript (Specification)
function setAllTags(
   settings : string,
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.setAllTags(string,function);

Parameters

settings
The string to configure the scanner with. This is usually obtained from an earlier call to getAllTags.
callback
Callback which is called when all tags are set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set the scanner ISIS tags, where scannerSettings is a settings string previously obtained using the getAllTags method:

  • JavaScript
function setAllTagsCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().setAllTags(scannerSettings, setAllTagsCallback);
Remarks

This is an asynchronous method.

The scanner must be set before calling this method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

setTagInteger Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : setTagInteger Method
Sets the value of an ISIS tag of data type Integer.
Syntax
ASP.NET Ajax Javascript (Specification)
function setTagInteger(
   tagID : number(Integer),
   tagInteger : number(Integer),
   index : number(Integer),
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.setTagInteger(number(Integer),number(Integer),number(Integer),function);

Parameters

tagID
The ID of the tag.
tagInteger
The integer value to set the tag to.
index
The index to use, for tags that contain multiple values. If the tag contains only a single value, this must be 0.
callback
Callback which is called when the tag is set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set the scanner ISIS scan type tag to an integer value of 0 (which represents automatic scan type for some scanners). You can use the getTag method to get the tag type and list or range of supported values for a tag.

  • JavaScript
function setTagCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().setTagInteger(ImageGear.Web.Isis.ImGearIsisTag.ScanType, 0, 0, setTagCallback);
Remarks

This is an asynchronous method.

To set the values of multiple tags, it is more efficient to use setAllTags.

The scanner must be set before calling this method.

For more information on ISIS tags, refer to the ISIS Tags topic.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

setTagRational Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : setTagRational Method
Sets the value of an ISIS tag of data type Rational.
Syntax
ASP.NET Ajax Javascript (Specification)
function setTagRational(
   tagID : number(Integer),
   numerator : number(Integer),
   denominator : number(Integer),
   index : number(Integer),
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.setTagRational(number(Integer),number(Integer),number(Integer),number(Integer),function);

Parameters

tagID
The ID of the tag.
numerator
The value to set the tag numerator to.
denominator
The value to set the tag denominator to.
index
The index to use, for tags that contain multiple values. If the tag contains only a single value, this must be 0.
callback
Callback which is called when the tag is set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set the scanner ISIS X resolution tag to a rational value of 300/1. You can use the getTag method to get the tag type and list or range of supported values for a tag.

  • JavaScript
function setTagCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().setTagRational(ImageGear.Web.Isis.ImGearIsisTag.XResolution, 300, 1, 0, setTagCallback);
Remarks

This is an asynchronous method.

To set the values of multiple tags, it is more efficient to use setAllTags.

The scanner must be set before calling this method.

For more information on ISIS tags, refer to the ISIS Tags topic.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

setTagString Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : setTagString Method
Sets the value of an ISIS tag of data type String.
Syntax
ASP.NET Ajax Javascript (Specification)
function setTagString(
   tagID : number(Integer),
   tagString : string,
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.setTagString(number(Integer),string,function);

Parameters

tagID
The ID of the tag.
tagString
The string value to set the tag to.
callback
Callback which is called when the tag is set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set a scanner ISIS page size tag to a string value. You can use the getTag method to get the tag type and list or range of supported values for a tag.

  • JavaScript
function setTagCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().setTagString(ImageGear.Web.Isis.ImGearIsisTag.PageSize, "Letter - 8.5 x 11 in", setTagCallback);
Remarks

This is an asynchronous method.

To set the values of multiple tags, it is more efficient to use setAllTags.

The scanner must be set before calling this method.

For more information on ISIS tags, refer to the ISIS Tags topic.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

showUI Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : showUI Method
Displays the configuration window for the currently loaded scanner.
Syntax
ASP.NET Ajax Javascript (Specification)
function showUI(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.showUI(function);

Parameters

callback
Callback which is called when the UI shows.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to show the scanner user interface:

  • JavaScript
function showUICallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().showUI(showUICallback);
Remarks

This is an asynchronous method.

The scanner must be set before calling this method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

unload Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : unload Method
Unloads a scanner without closing the active session.
Syntax
ASP.NET Ajax Javascript (Specification)
function unload(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.unload(function);

Parameters

callback
Callback which is called when the scanner is unloaded.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to unload a scanner:

  • JavaScript
function unloadScannerCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.get_scanner().unload(unloadScannerCallback);
Remarks

This is an asynchronous method.

You can use this method to release the scanner for use by a different application when you no longer need to scan new images. You might do this if your application performs lengthy post-scanning operations that require the session to remain open.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%% $$Properties$$

ImGearIsisScanner class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanner class

For a list of all members of this type, see ImGearIsisScanner members.

Public Properties
 | Name | Description
public Property | name | Gets the name of the scanner.
public Property | selected | Gets a value indicating whether the scanner is selected.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

name Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : name Property
Gets the name of the scanner.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_name() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.get_name();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

selected Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner : selected Property
Gets a value indicating whether the scanner is selected.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selected() : boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScanner.get_selected();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScanner
ImGearIsisScanner Members


%%PageItemTitle%%

ImGearIsisScannerCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerCollection class
A collection of scanners.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScannerCollection

See Also

Reference

ImGearIsisScannerCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScannerCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerCollection class

The following tables list the members exposed by ImGearIsisScannerCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScannerCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getScanner | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScannerCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection : ImGearIsisScannerCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImGearIsisScannerCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisScannerCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerCollection class

For a list of all members of this type, see ImGearIsisScannerCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getScanner | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImGearIsisScannerCollection Members


%%PageItemTitle%%

getScanner Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection : getScanner Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getScanner(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerCollection.getScanner(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImGearIsisScannerCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisScannerCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerCollection class

For a list of all members of this type, see ImGearIsisScannerCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerCollection
ImGearIsisScannerCollection Members


%%PageItemTitle%%

ImGearIsisScannerService class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerService class
A scanner service.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerService = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerService();
Remarks
This class is the main starting point for ISIS Captiva Cloud functionality which can be used to implement scanning in a web application.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScannerService

See Also

Reference

ImGearIsisScannerService Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScannerService class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerService class

The following tables list the members exposed by ImGearIsisScannerService.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScannerService Constructor |
Top
Public Properties
 | Name | Description
public Property | imGearServicePath | Gets or sets the path of the ImageGear service.
Top
Public Methods
 | Name | Description
public Method | createSession | Creates a new scanning session.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScannerService Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService : ImGearIsisScannerService Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerService = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerService();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImGearIsisScannerService Members


%%PageItemTitle%% $$Methods$$

ImGearIsisScannerService class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerService class

For a list of all members of this type, see ImGearIsisScannerService members.

Public Methods
 | Name | Description
public Method | createSession | Creates a new scanning session.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

createSession Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService : createSession Method
Creates a new scanning session.
Syntax
ASP.NET Ajax Javascript (Specification)
function createSession(
   createSessionArgs : ImGearIsisCreateSessionArgs
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerService.createSession(ImGearIsisCreateSessionArgs);

Parameters

createSessionArgs
An input parameter of type ImGearIsisCreateSessionArgs.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to create a session:

  • JavaScript
var scannerSession;
...
function createSessionCallback(theScannerSession, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
    // Store the scanner session.
    scannerSession = theScannerSession;
}

var scannerService = new ImageGear.Web.Isis.ImGearIsisScannerService();
scannerService.createSession({ applicationName: "ImageGear ISIS Application", destroyExistingSession: true, locale: "en-us", idleTimeoutMinutes: 0, callback: createSessionCallback });
Remarks

This is an asynchronous method.

When this object creates a session, it searches for the network port that the local ISIS Captiva Cloud server is listening on. If the server cannot be found, the session will not be created.

Only one session can be open at a time. The restriction to a single session applies to all applications running on the same system. Only one application at a time can use ISIS Captiva Cloud features.

To license the ISIS functionality, the ImageGear.Web.Isis.ImGearIsisScannerService.imGearServicePath property must be set to the path of the ImageGear service before calling the createSession method. If it is not set to the path of the ImageGear service or if a valid license is not being used, the ISIS functionality works but each scanned image is watermarked and a maximum of 50 pages can be scanned.

This method can be passed an input parameter ImGearIsisCreateSessionArgs with properties applicationName, destroyExistingSession, locale, idleTimeoutMinutes, and callback. It is not necessary to create the ImGearIsisCreateSessionArgs. The parameters can also be passed as shown in the example below.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImGearIsisScannerService Members


%%PageItemTitle%% $$Properties$$

ImGearIsisScannerService class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerService class

For a list of all members of this type, see ImGearIsisScannerService members.

Public Properties
 | Name | Description
public Property | imGearServicePath | Gets or sets the path of the ImageGear service.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

imGearServicePath Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService : imGearServicePath Property
Gets or sets the path of the ImageGear service.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_imGearServicePath() : string
function set_imGearServicePath(value : string)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerService.get_imGearServicePath();
Example

The JavaScript code below demonstrates how to set the ImageGear service path.

  • JavaScript
scannerService = new ImageGear.Web.Isis.ImGearIsisScannerService();
var url = location.href;
var servicePath = url.substring(0, url.indexOf('/', 14)) + '/' + 'ImGearIsisSample';
scannerService.set_imGearServicePath(servicePath);
Remarks
To license the ISIS functionality, this property must be set to the path of the ImageGear service before calling the ImageGear.Web.Isis.ImGearIsisScannerService.createSession method. If it is not set to the path of the ImageGear service or if a valid license is not being used, the ISIS functionality works but each scanned image is watermarked and a maximum of 50 pages can be scanned.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerService
ImGearIsisScannerService Members


%%PageItemTitle%%

ImGearIsisScannerSession class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerSession class
A scanner session.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerSession = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerSession();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScannerSession

See Also

Reference

ImGearIsisScannerSession Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisScannerSession class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerSession class

The following tables list the members exposed by ImGearIsisScannerSession.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisScannerSession Constructor |
Top
Public Properties
 | Name | Description
public Property | scanner | Gets the currently selected scanner.
Top
Public Methods
 | Name | Description
public Method | destroy | Destroys the current session. Terminates all pending scan jobs.
public Method | getScanners | Gets a list of scanners that are installed on the system.
public Method | scan | Starts a scan job.
public Method | setScanner | Loads and sets the specified scanner.
public Method | setScannerWithDialog | Loads and sets a user-selected scanner.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScannerSession Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : ImGearIsisScannerSession Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisScannerSession = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisScannerSession();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%% $$Methods$$

ImGearIsisScannerSession class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerSession class

For a list of all members of this type, see ImGearIsisScannerSession members.

Public Methods
 | Name | Description
public Method | destroy | Destroys the current session. Terminates all pending scan jobs.
public Method | getScanners | Gets a list of scanners that are installed on the system.
public Method | scan | Starts a scan job.
public Method | setScanner | Loads and sets the specified scanner.
public Method | setScannerWithDialog | Loads and sets a user-selected scanner.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

destroy Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : destroy Method
Destroys the current session. Terminates all pending scan jobs.
Syntax
ASP.NET Ajax Javascript (Specification)
function destroy(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.destroy(function);

Parameters

callback
Callback which is called when the session is destroyed.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to destroy a scanner session:

  • JavaScript
function destroyCallback(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }
}

scannerSession.destroy(destroyCallback);
Remarks

This is an asynchronous method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%%

getScanners Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : getScanners Method
Gets a list of scanners that are installed on the system.
Syntax
ASP.NET Ajax Javascript (Specification)
function getScanners(
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.getScanners(function);

Parameters

callback
Callback which is called after scanners are retrieved.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to get a list of the connected devices:

  • JavaScript
var scanners;
...
function getScannersCallback(connectedDevices, undetectedDevices, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }

    // Store the connected devices so they can be accessed later when calling the setScanner method.
    scanners = connectedDevices;
    var select = document.getElementById("scannerSelect");

    for (var i = 0; i < connectedDevices.get_length(); i++) {
        var scanner = connectedDevices.getScanner(i);
        var option = document.createElement("option");
        var scannerName = scanner.get_name();
        option.text = scannerName;
        select.add(option, null);
    }

    // Only devices that are connected and support the ISIS scanner auto-detection feature appear in the
    // connectedDevices collection. Other devices appear in the undetectedDevices collection, which can be
    // accessed using code similar to the code used above to access the connectedDevices collection.
}

// Get a list of connected scanners and add each to an HTML select element.
var operationStatus = scannerSession.getScanners(getScannersCallback);
Remarks

This is an asynchronous method.

The list is broken into two groups, connected devices and undetected devices, which are provided as ImGearIsisScannerCollections. The connected devices are detected using the ISIS scanner auto-detection feature. The undetected devices either aren't available or do not support the ISIS scanner auto-detection feature. Many devices cannot be automatically detected, so it is recommended to have a UI element such as a ListBox to show all the devices, not just the connected devices. The two groups will not have overlapping scanners.

Although the scanner collection is usually retrieved without user interaction, some scanner drivers might display a message box or other window when they are accessed. For example, an unlicensed driver might display a message about permissions.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%%

scan Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : scan Method
Starts a scan job.
Syntax
ASP.NET Ajax Javascript (Specification)
function scan(
   scanArgs : ImGearIsisScanArgs
) : ImGearIsisScanJob;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.scan(ImGearIsisScanArgs);

Parameters

scanArgs
An input parameter.

Return Value

ImGearIsisScanJob value.
Example

The JavaScript code below demonstrates how to scan a G4 compressed TIFF and retrieve the base 64 data string for each scanned page and the base 64 data string for the scanned document:

  • JavaScript
function pageRetrievedCallback(result, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }

    // Get the base 64 data string for the page. The ASP .NET ISIS sample demonstrates how to upload this string and display the image in a PageView control.
    var base64page = result.get_base64Page();

    // Get the image info for the page. This object contains properties for getting the color format, compression, file type, width, height, and resolution.
    var imageInfo = result.get_imageInfo();
...
    // You can also get the image metadata and the scanned page number.
}

function documentRetrievedCallback(result, status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }

    // Get the base 64 data string for the scanned document.
    var base64document = result.get_base64Document();
...
}

// Passing 0 for the number of pages scans all pages in the feeder. You can specify a number greater than 0 to scan that number of pages.
var scanJob = scannerSession.scan({pages: 0, scanDataType: ImageGear.Web.Isis.ImGearIsisScanDataType.Base64Page | ImageGear.Web.Isis.ImGearIsisScanDataType.Base64Document, fileType: ImageGear.Web.Isis.ImGearIsisFileType.Tif, compression: ImageGear.Web.Isis.ImGearIsisImageCompression.G4, pageRetrievedCallback: pageRetrievedCallback, documentRetrievedCallback: documentRetrievedCallback});
Remarks

This is an asynchronous method.

This method returns an ImGearIsisScanJob object which can be used to track the status.

You must load a scanner before calling this method. Use the ImageGear.Web.Isis.ImGearIsisScannerSession.setScanner method or ImageGear.Web.Isis.ImGearIsisScannerSession.setScannerWithDialog method to load a scanner.

Starting a scan job does not automatically end previous scan jobs. However, only one job at a time can be actively scanning. Scanning occurs in the same sequence as the jobs were opened. When you start a new scan job, all scanning activity from previously opened jobs is completed before any images are scanned by the new job.

You can end a scan job (deleting its data) but continue working in the same session by calling the ImageGear.Web.Isis.ImGearIsisScanJob.destroy method.

This method can be passed an input parameter ImGearIsisScanArgs with properties pages, scanDataType, fileType, compression, pageRetrievedCallback, and documentRetrievedCallback. It is not necessary to create the ImGearIsisScanArgs. The parameters can also be passed as shown in the example.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%%

setScanner Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : setScanner Method
Loads and sets the specified scanner.
Syntax
ASP.NET Ajax Javascript (Specification)
function setScanner(
   scanner : ImGearIsisScanner,
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.setScanner(ImGearIsisScanner,function);

Parameters

scanner
The scanner to set.
callback
Callback which is called after a scanner is set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set a scanner, where scannerSelect is an HTML select element that contains the scanners that were previously retrieved (and stored in the scanners variable) using the getScanners method:

  • JavaScript
function onScannerLoaded(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
    }

    // The scanner can now be accessed through the ImGearIsisScannerSession scanner property.
    var scanner = scannerSession.get_scanner();

    // You could use the getTag method or getAllTags method here
    // to get the current scanner settings.
}

var select = document.getElementById('scannerSelect');
var selectedScanner = scanners.getScanner(select.selectedIndex);

// Set the scanner that is selected in the connected list.
scannerSession.setScanner(selectedScanner, onScannerLoaded);
Remarks

This is an asynchronous method.

You must set a scanner before creating a scan job. Only one scanner can be set at a time. Any previously set scanner is unloaded automatically.

A list of scanners that are installed on the system can be retrieved using the ImageGear.Web.Isis.ImGearIsisScannerSession.getScanners method.

If you want to use a built-in user interface to show the scanner list or use the previously selected scanner, use the ImageGear.Web.Isis.ImGearIsisScannerSession.setScannerWithDialog method instead.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%%

setScannerWithDialog Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : setScannerWithDialog Method
Loads and sets a user-selected scanner.
Syntax
ASP.NET Ajax Javascript (Specification)
function setScannerWithDialog(
   loadScannerOption : ImGearIsisLoadScannerOption,
   callback : function
) : ImGearIsisOperationStatus;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.setScannerWithDialog(ImGearIsisLoadScannerOption,function);

Parameters

loadScannerOption
Scanner configuration options to make available to the application user.
callback
Callback which is called after a scanner is set.

Return Value

ImGearIsisOperationStatus value.
Example

The JavaScript code below demonstrates how to set a scanner using a scanner selection dialog:

  • JavaScript
function onScannerLoaded(status) {
    if (status.get_status() !== ImageGear.Web.Isis.ImGearIsisStatus.Completed) {
        alert(status.get_statusMessage());
}

    // The scanner can now be accessed through the ImGearIsisScannerSession scanner property.
    var scanner = scannerSession.get_scanner();

    // You could use the getTag method or getAllTags method here to get the current scanner settings.
}

// Show the scanner selection dialog with a list of connected drivers.
scannerSession.setScannerWithDialog(ImageGear.Web.Isis.ImGearIsisLoadScannerOption.ShowConnectedDriverList, onScannerLoaded);
Remarks

This is an asynchronous method.

You must set a scanner before creating a scan job. Only one scanner can be set at a time. Any previously set scanner is unloaded automatically.

This method loads a scanner based on the user's selection. A built-in user interface is displayed to show the scanner list. If you want to manage the scanner list yourself, use the ImageGear.Web.Isis.ImGearIsisScannerSession.setScanner method instead. A list of scanner drivers on the machine can be retrieved using the getScanners method.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%% $$Properties$$

ImGearIsisScannerSession class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScannerSession class

For a list of all members of this type, see ImGearIsisScannerSession members.

Public Properties
 | Name | Description
public Property | scanner | Gets the currently selected scanner.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

scanner Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession : scanner Property
Gets the currently selected scanner.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_scanner() : ImGearIsisScanner
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisScannerSession.get_scanner();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisScannerSession
ImGearIsisScannerSession Members


%%PageItemTitle%%

ImGearIsisTagChoices class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagChoices class
The set of choices that are valid for an ISIS tag.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagChoices = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagChoices();
Remarks
The set of choices that are valid for an ISIS tag. The ChoiceKind property describes how to specify the set of choices that are available for the tag. For numerical tags, there are two options: If ChoiceKind is set to list, use the TypeList properties to specify the items in the list. If ChoiceKind is set to range, use the MinType, MaxType, and StepType properties to specify the range of valid choices.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagChoices

See Also

Reference

ImGearIsisTagChoices Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisTagChoices class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagChoices class

The following tables list the members exposed by ImGearIsisTagChoices.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisTagChoices Constructor |
Top
Public Properties
 | Name | Description
public Property | choiceKind | Gets the method used to describe the choices for a tag.
public Property | integerList | Gets the available integer choice values.
public Property | maxDenominatorValue | Gets the maximum rational denominator choice value.
public Property | maxValue | Gets the maximum integer choice value.
public Property | minDenominatorValue | Gets the minimum rational denominator choice value.
public Property | minValue | Gets the minimum integer choice value.
public Property | rationalDenominatorList | Gets the available rational denominator choice values.
public Property | stepDenominatorValue | Gets the difference between sequential rational denominator choice values. Otherwise, this value is null.
public Property | stepValue | Gets the difference between sequential choice values.
public Property | stringList | Gets the available string choice values.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagChoices Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : ImGearIsisTagChoices Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagChoices = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagChoices();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%% $$Properties$$

ImGearIsisTagChoices class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagChoices class

For a list of all members of this type, see ImGearIsisTagChoices members.

Public Properties
 | Name | Description
public Property | choiceKind | Gets the method used to describe the choices for a tag.
public Property | integerList | Gets the available integer choice values.
public Property | maxDenominatorValue | Gets the maximum rational denominator choice value.
public Property | maxValue | Gets the maximum integer choice value.
public Property | minDenominatorValue | Gets the minimum rational denominator choice value.
public Property | minValue | Gets the minimum integer choice value.
public Property | rationalDenominatorList | Gets the available rational denominator choice values.
public Property | stepDenominatorValue | Gets the difference between sequential rational denominator choice values. Otherwise, this value is null.
public Property | stepValue | Gets the difference between sequential choice values.
public Property | stringList | Gets the available string choice values.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

choiceKind Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : choiceKind Property
Gets the method used to describe the choices for a tag.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_choiceKind() : ImGearIsisChoiceKind
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_choiceKind();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

integerList Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : integerList Property
Gets the available integer choice values.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_integerList() : ImGearIsisTagIntegerCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_integerList();
Remarks
Use this property when ChoiceKind is set to list. If the value of the TagType property is Rational, then this property specifies the choices for the numerator. If the value of the TagType property is anything other than Integer or Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

maxDenominatorValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : maxDenominatorValue Property
Gets the maximum rational denominator choice value.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_maxDenominatorValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_maxDenominatorValue();
Remarks
Use this property when ChoiceKind is set to range. If the value of the TagType property is anything other than Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

maxValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : maxValue Property
Gets the maximum integer choice value.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_maxValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_maxValue();
Remarks
If the value of the TagType property is Rational, then this property specifies the maximum value for the numerator. Use this property when ChoiceKind is set to range. If the value of the TagType property is anything other than Integer or Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

minDenominatorValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : minDenominatorValue Property
Gets the minimum rational denominator choice value.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_minDenominatorValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_minDenominatorValue();
Remarks
Use this property when ChoiceKind is set to range. If the value of the TagType property is anything other than Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

minValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : minValue Property
Gets the minimum integer choice value.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_minValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_minValue();
Remarks
If the value of the TagType property is Rational, then this property specifies the minimum value for the numerator. Use this property when ChoiceKind is set to range. If the value of the TagType property is anything other than Integer or Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

rationalDenominatorList Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : rationalDenominatorList Property
Gets the available rational denominator choice values.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_rationalDenominatorList() : ImGearIsisTagRationalDenominatorCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_rationalDenominatorList();
Remarks
Use this property when ChoiceKind is set to list. If the value of the TagType property is anything other than Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

stepDenominatorValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : stepDenominatorValue Property
Gets the difference between sequential rational denominator choice values. Otherwise, this value is null.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_stepDenominatorValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_stepDenominatorValue();
Remarks
Use this property when ChoiceKind is set to range. If x is the value of the MinDenominatorValue property and s is the value of the StepDenominatorValue property, then the available choices are x, x + s, x + 2s, and so forth, up to a maximum of the value of the MaxDenominatorValue property. If the value of the TagType property is anything other than Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

stepValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : stepValue Property
Gets the difference between sequential choice values.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_stepValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_stepValue();
Remarks
Use this property when ChoiceKind is set to range. If x is the value of the MinValue property and s is the value of the StepValue property, then the available choices are x, x + s, x + 2s, and so forth, up to a maximum of the value of the MaxValue property. If the value of the TagType property is anything other than Integer or Rational, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

stringList Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices : stringList Property
Gets the available string choice values.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_stringList() : ImGearIsisTagStringCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagChoices.get_stringList();
Remarks
If the value of the TagType property is anything other than String, then this property is null.
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagChoices
ImGearIsisTagChoices Members


%%PageItemTitle%%

ImGearIsisTagIntegerCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagIntegerCollection class
A collection of tag integers.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagIntegerCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagIntegerCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagIntegerCollection

See Also

Reference

ImGearIsisTagIntegerCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisTagIntegerCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagIntegerCollection class

The following tables list the members exposed by ImGearIsisTagIntegerCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisTagIntegerCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagInteger | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagIntegerCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection : ImGearIsisTagIntegerCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagIntegerCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagIntegerCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImGearIsisTagIntegerCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisTagIntegerCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagIntegerCollection class

For a list of all members of this type, see ImGearIsisTagIntegerCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagInteger | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagIntegerCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImGearIsisTagIntegerCollection Members


%%PageItemTitle%%

getTagInteger Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection : getTagInteger Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getTagInteger(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagIntegerCollection.getTagInteger(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImGearIsisTagIntegerCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisTagIntegerCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagIntegerCollection class

For a list of all members of this type, see ImGearIsisTagIntegerCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagIntegerCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagIntegerCollection
ImGearIsisTagIntegerCollection Members


%%PageItemTitle%%

ImGearIsisTagRationalDenominatorCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagRationalDenominatorCollection class
A collection of tag rational denominators.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection

See Also

Reference

ImGearIsisTagRationalDenominatorCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisTagRationalDenominatorCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagRationalDenominatorCollection class

The following tables list the members exposed by ImGearIsisTagRationalDenominatorCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisTagRationalDenominatorCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagRationalDenominator | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagRationalDenominatorCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection : ImGearIsisTagRationalDenominatorCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImGearIsisTagRationalDenominatorCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisTagRationalDenominatorCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagRationalDenominatorCollection class

For a list of all members of this type, see ImGearIsisTagRationalDenominatorCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagRationalDenominator | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagRationalDenominatorCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImGearIsisTagRationalDenominatorCollection Members


%%PageItemTitle%%

getTagRationalDenominator Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection : getTagRationalDenominator Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getTagRationalDenominator(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagRationalDenominatorCollection.getTagRationalDenominator(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImGearIsisTagRationalDenominatorCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisTagRationalDenominatorCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagRationalDenominatorCollection class

For a list of all members of this type, see ImGearIsisTagRationalDenominatorCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagRationalDenominatorCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagRationalDenominatorCollection
ImGearIsisTagRationalDenominatorCollection Members


%%PageItemTitle%%

ImGearIsisTagStringCollection class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagStringCollection class
A collection of tag strings.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagStringCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagStringCollection();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagStringCollection

See Also

Reference

ImGearIsisTagStringCollection Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisTagStringCollection class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagStringCollection class

The following tables list the members exposed by ImGearIsisTagStringCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisTagStringCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagString | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagStringCollection Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection : ImGearIsisTagStringCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagStringCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagStringCollection();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImGearIsisTagStringCollection Members


%%PageItemTitle%% $$Methods$$

ImGearIsisTagStringCollection class Methods

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagStringCollection class

For a list of all members of this type, see ImGearIsisTagStringCollection members.

Public Methods
 | Name | Description
public Method | forEach | Calls the specified function once for each item in the collection.
public Method | getTagString | Returns the item in the collection at the index specified.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

forEach Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection : forEach Method
Calls the specified function once for each item in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagStringCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each item in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the item being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImGearIsisTagStringCollection Members


%%PageItemTitle%%

getTagString Method

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection : getTagString Method
Returns the item in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getTagString(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagStringCollection.getTagString(number(Integer));

Parameters

index
The zero-based index of the item to return.
Remarks

This function returns the item located at the index in the collection.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImGearIsisTagStringCollection Members


%%PageItemTitle%% $$Properties$$

ImGearIsisTagStringCollection class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagStringCollection class

For a list of all members of this type, see ImGearIsisTagStringCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagStringCollection.get_length();
Remarks

This function returns the number of items that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagStringCollection
ImGearIsisTagStringCollection Members


%%PageItemTitle%%

ImGearIsisTagValue class
Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagValue class
The choice value of an ISIS tag.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagValue = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagValue();
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagValue

See Also

Reference

ImGearIsisTagValue Members
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%% $$Members$$

ImGearIsisTagValue class Members

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagValue class

The following tables list the members exposed by ImGearIsisTagValue.

Public Constructors
 | Name | Description
public Constructor | ImGearIsisTagValue Constructor |
Top
Public Properties
 | Name | Description
public Property | denominatorValue | Gets the denominator of the choice value of the tag when its data type is Rational.
public Property | integerValue | Gets the choice value of the tag when its data type is Integer, or the numerator when its data type is Rational.
public Property | stringValue | Gets the choice value of the tag when its data type is String.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagValue Constructor

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue : ImGearIsisTagValue Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.Isis.ImGearIsisTagValue = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.Isis.ImGearIsisTagValue();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImGearIsisTagValue Members


%%PageItemTitle%% $$Properties$$

ImGearIsisTagValue class Properties

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagValue class

For a list of all members of this type, see ImGearIsisTagValue members.

Public Properties
 | Name | Description
public Property | denominatorValue | Gets the denominator of the choice value of the tag when its data type is Rational.
public Property | integerValue | Gets the choice value of the tag when its data type is Integer, or the numerator when its data type is Rational.
public Property | stringValue | Gets the choice value of the tag when its data type is String.
Top
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

denominatorValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue : denominatorValue Property
Gets the denominator of the choice value of the tag when its data type is Rational.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_denominatorValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagValue.get_denominatorValue();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImGearIsisTagValue Members


%%PageItemTitle%%

integerValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue : integerValue Property
Gets the choice value of the tag when its data type is Integer, or the numerator when its data type is Rational.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_integerValue() : number(Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagValue.get_integerValue();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImGearIsisTagValue Members


%%PageItemTitle%%

stringValue Property

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue : stringValue Property
Gets the choice value of the tag when its data type is String.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_stringValue() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearIsisTagValue.get_stringValue();
See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis.ImGearIsisTagValue
ImGearIsisTagValue Members


%%PageItemTitle%%

ImGearIsisBarcodeDataType Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisBarcodeDataType Enumeration
Progress indicators for tasks.
Members
Member | Description
Addon2 | 21 - ADDON2 barcode.
Addon5 | 22 - ADDON5 barcode.
AustralianPost | 42 - Australian Post barcode.
Auto | 23 - Auto detect.
Aztec | 37 - Aztec barcode.
BcdMatrix | 35 - BCD / Matrix barcode.
Codabar | 12 - Codabar barcode.
CodabarStartStop | 27 - Codabar including Start/Stop barcode.
Code128 | 15 - Code 128 barcode.
Code25 | 33 - CODE 2/5 Generic barcode.
Code25Airline | 17 - CODE 2/5 (airline) barcode.
Code25Datalogic | 6 - CODE 2/5 3 lines (datalogic) barcode.
Code25Iata | 29 - CODE 2/5 5 lines IATA barcode.
Code25Industrial | 7 - CODE 2/5 5 lines (industrial) barcode.
Code25Interleaved | 4 - CODE 2/5 interleaved barcode.
Code25Invert | 34 - CODE 2/5 Invert barcode.
Code25Matrix | 5 - CODE 2/5 3 lines (matrix) barcode.
Code32 | 36 - Code 32 barcode.
Code39 | 3 - CODE 39 barcode.
Code39Ascii | 28 - CODE 39 with full ASCII barcode.
Code93 | 14 - Code 93 barcode.
DataMatrix | 38 - Datamatrix barcode.
Ean13 | 2 - EAN-13 barcode.
Ean8 | 1 - EAN-8 barcode.
IntelligentMail | 43 - Intelligent Mail barcode.
MaxiCode | 39 - MaxiCode barcode.
MicrCmc7 | 20 - Check MICR CMC7 barcode.
MicrE13B | 19 - Check MICR E13B barcode.
Msi | 30 - MSI barcode.
None | 0 - No barcode type.
PatchCode | 8 - Patch Code type II, III, or T barcode.
PatchI | 24 - Patch Code type I barcode.
PatchII | 9 - Patch Code type II barcode.
PatchIII | 10 - Patch Code type III barcode.
PatchIV | 25 - Patch Code type IV barcode.
PatchTransfer | 11 - Transfer Patch Code barcode.
PatchVI | 26 - Patch Code type VI barcode.
Pdf417 | 31 - PDF 417 barcode.
PostNet | 16 - PostNet barcode.
QRCode | 40 - QR Code barcode.
Reserved | 99 - Reserved enum member.
Reserved1 | 97 - Reserved enum member.
Reserved2 | 98 - Reserved enum member.
RoyalPost | 41 - Royal Post barcode.
Ucc128 | 32 - UCC 128 barcode.
UpcA | 18 - UPC code rev A barcode.
UpcE | 13 - UPC code rev E barcode.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisBarcodeDataType

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisChoiceKind Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisChoiceKind Enumeration
The method used to describe the choices for a tag.
Members
Member | Description
List | 2 - The choices are described as a list of values. This option is not valid for tags of type String.
None | 0 - Either the tag has no choices, or the choices cannot be summarized as a single type. This is common with tags of type String that can be set to any value (for example, imprinter text).
Range | 1 - The choices are described as a range of numerical values.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisChoiceKind

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisFileFormat Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisFileFormat Enumeration
Supported file formats.
Members
Member | Description
AutoDetect | 0 - An appropriate compression type will be chosen automatically.
Jp2 | 1310720 - JPEG 2000 compression.
Jpg | 720896 - JPEG compression.
Pdf | 1048576 - PDF compression.
PdfG4 | 1048580 - PDF with G4 compression.
PdfJp2 | 1098592 - PDF with JPEG 2000 compression.
PdfJpg | 1048582 - PDF with JPEG compression.
PdfLzw | 1048581 - PDF with LZW compression.
PdfZip | 1098589 - PDF with ZIP compression.
Png | 1245184 - PNG compression.
Tif | 196608 - TIFF with an appropriate compression type chosen automatically.
TifG4 | 196612 - TIF with G4 compression.
TifJpg | 196614 - TIFF with JPEG compression.
TifLzw | 196613 - TIFF with LZW compression.
TifUncompressed | 196609 - TIFF uncompressed.
TifZip | 246621 - TIFF with ZIP compression.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisFileFormat

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisFileType Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisFileType Enumeration
Image file types.
Members
Member | Description
AutoDetect | 0 - An appropriate file type will be chosen automatically.
Jp2 | 1310720 - JPEG 2000 file type.
Jpg | 720896 - JPEG file type.
Pdf | 1048576 - Portable Document Format (PDF) file type.
Png | 1245184 - Portable Network Graphics (PNG) file type.
Tif | 196608 - Tagged Image File Format (TIFF) file type.
Remarks
The JPEG and JPEG 2000 formats only support color and grayscale images.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisFileType

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisImageCompression Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisImageCompression Enumeration
Image compression types.
Members
Member | Description
AutoDetect | 0 - An appropriate compression type will be chosen automatically.
G4 | 4 - CCITT Group 4 compression. This compression is lossless.
Jp2 | 50016 - JPEG 2000 compression. This compression can be either lossless or lossy.
Jpg | 6 - JPEG compression. This is a lossy compression type. Once an image is compressed, the original image data cannot be completely restored.
Lzw | 5 - LZW compression. This compression is lossless.
None | 1 - No compression.
Zip | 50013 - ZIP compression. This compression is lossless.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisImageCompression

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisLoadScannerOption Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisLoadScannerOption Enumeration
Option to show configuration UI.
Members
Member | Description
ShowConnectedDriverList | 2 - Lists, by default, all scanners detected as available for use. The application user can expand the list to show all scanners found on the system. As a result, this option is the same as ShowDriverList except that the default view is different.
ShowDeviceList | 3 - Displays the configuration window for the last used scanner. If this is the first time a scanner is being loaded, or if the last used scanner cannot be loaded, then the list of all scanners found on the system is displayed instead (same behavior as ShowDriverList).
ShowDriverList | 1 - Lists all scanners found on the system, whether or not they are detected as currently available for use.
UseLastConfiguration | 0 - Loads the last used driver, along with its most recent configuration settings. No UI is displayed. If this is the first time a scanner is being loaded, or if the last used scanner cannot be loaded, then the list of all scanners found on the system is displayed instead (same behavior as ShowDriverList).
Remarks

Specifies which options to make available in the user interface when a scanner is loaded.

Some settings are remembered between sessions and are loaded automatically based on the value of this option. Settings are remembered separately for each application ID. This means that different applications using the toolkit behave independently, even when running on the same computer.

Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisLoadScannerOption

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisOrientation Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisOrientation Enumeration
Image orientation values.
Members
Member | Description
Landscape | 2 - Landscape (90-degree counter-clockwise rotation). The 0th row represents the visual left side of the and the 0th column represents the visual bottom.
LandscapeMirrored | 6 - Landscape mirrored. The 0th row represents the visual left side of the image, and the 0th column represents the visual top.
Portrait | 1 - Portrait (0-degree rotation). The 0th row represents the visual top of the image and the 0th column represents the visual left side.
PortraitMirrored | 5 - Portrait mirrored. The 0th row represents the visual top of the image, and the 0th column represents the visual right side.
Rotated180 | 3 - Upside down portrait (180-degree counter-clockwise rotation). The 0th row represents the visual bottom of the image and the 0th column represents the visual right side.
Rotated180Mirrored | 7 - Upside down portrait mirrored. The 0th row represents the visual bottom of the image, and the 0th column represents the visual left side. This is the orientation in which Windows BMP files are stored.
Rotated270 | 4 - Upside down landscape (270-degree counter-clockwise rotation). The 0th row represents the visual right side of the image, and the 0th column represents the visual top.
Rotated270Mirrored | 8 - Upside down landscape mirrored. The 0th row represents the visual right side of the image, and the 0th column represents the visual bottom.
Unknown | 0 - Unknown orientation. This is needed because the serializer will throw an error if the orientation is 0 it cannot be matched to an existing value.
Remarks
The ImGearIsisOrientation defines the current orientation of the image.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisOrientation

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisPageSide Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisPageSide Enumeration
Page side indentifier.
Members
Member | Description
Back | 1 - Back side.
Front | 0 - Front side.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisPageSide

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisPhotometric Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisPhotometric Enumeration
Color interpretation.
Members
Member | Description
Bgr | 120 - Same as RGB, but blue and red planes are reversed.
Cmyk | 5 - CMYK color model.
Lab | 8 - Lab color model, a device-independent 3-channel color model.
Palette | 3 - Palette color image.
Rgb | 2 - RGB image.
Transparency | 4 - Transparency mask for another image.
White0 | 0 - 0 is imaged as white, 1 is imaged as black.
White1 | 1 - 0 is imaged as black, 1 is imaged as white.
Ycbcr | 6 - YCBCR color model.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisPhotometric

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisResolutionUnit Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisResolutionUnit Enumeration
Values for the resolution unit tag.
Members
Member | Description
Centimeter | 3 - Dots per centimeter.
Inch | 2 - Dots per inch.
None | 1 - No absolute unit of measurement.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisResolutionUnit

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanAhead Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanAhead Enumeration
Values for the scan ahead tag.
Members
Member | Description
No | 0 - Scan ahead not enabled.
Yes | 1 - Scan ahead enabled.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScanAhead

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanDataType Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanDataType Enumeration
Specifies the type of data to provide when an image is scanned.
Members
Member | Description
Base64Document | 8 - The scanned data will be provided as a base 64 string available through the ImGearIsisDocumentRetrievedResult Base64Document property.
Base64Page | 4 - The scanned data will be provided as a base 64 string available through the ImGearIsisPageRetrievedResult Base64Page property.
None | 0 - The scanned data will not be provided. The ImGearIsisPageRetrievedResult ScannedPage or ImGearIsisDocumentRetrievedResult ScannedDocument callback parameter must be used to asynchronously get the scanned page or document.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScanDataType

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisScanType Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisScanType Enumeration
Values for the scan type tag.
Members
Member | Description
Automatic | 0 - Scan from the automatic document feeder if pages are detected, otherwise scan from the flatbed.
BackFront | 5 - Scan in duplex mode and return the back side of the page first from the feeder.
BackOnly | 6 - Scan only the back side of the page from the feeder.
Flatbed | 2 - Scan from the flatbed.
FrontBack | 4 - Scan in duplex mode from the feeder.
FrontOnly | 3 - Scan only the front side of the page from the feeder.
Transparency | 1 - Scan from the transparency unit.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisScanType

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisStatus Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisStatus Enumeration
Progress indicators for tasks.
Members
Member | Description
Cancelled | 2 - The task was cancelled before being completed or encountering an error.
Completed | 1 - The task was completed without errors.
Error | 3 - An error occurred.
InProgress | 0 - The task is in progress.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisStatus

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTag Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTag Enumeration
ISIS tag IDs.
Members
Member | Description
BitsPerSample | 258 - Indicates how big a sample is. Typical values are: 1 = Binary; 4 = four-bit gray scale (16 shades of gray); 8 = eight-bit gray scale (256 shades of gray); 24 = 24-bit color.
Brightness | 1282 - The scanner's brightness. If available, -3 will set to auto brightness, -2 will auto darken, and -1 will auto lighten. Values from 0 to the ImGearIsisTagChoices MaxValue property incrementally change the brightness.
Contrast | 1281 - The scanner's contrast. A value of 0 means auto contrast or no contrast control is available.
ImageLength | 257 - Specifies the number of rows of pixels (height) in an image.
ImageWidth | 256 - Specifies the number of columns of pixels (width) in an image.
PageSize | 1294 - The total area available to the scanner.
ResolutionUnit | 296 - Specifies the unit of measurement for XResolution and YResolution. This setting is not available for all scanners and if it is not available, the units are assumed to be DPI. The tag value can be set to any of the values in the ImGearIsisResolutionUnit enum.
SamplesPerPixel | 277 - Indicates how many values each pixel uses to represent the data. Possible values are: 1 sample per pixel = Binary (black/white) and gray scale images; 3 samples per pixel = RGB color images.
ScanAhead | 1293 - Specifies if the scanning source has enabled the ability to continuously scan pages ahead of the current page the application is processing on those scanners that support this functionality. The tag value can be set to any of the values in the ImGearIsisScanAhead enum.
ScanAheadMaxPages | 1404 - If ScanAhead is enabled, this setting specifies the maximum number of pages to scan ahead. A zero value means to scan until the feeder is empty.
ScanAheadPages | 1301 - If ScanAhead is enabled and this setting is supported, it determines how many pages have been scanned in ahead. On some scanners this value is not an accurate measurement for how many pages are scanned in ahead. Therefore, use this setting as a general indicator that there are pages waiting that have been scanned in ahead.
ScanType | 1300 - Specifies the scanning source on those scanners that support this functionality. The tag value can be set to any of the values in the ImGearIsisScanType enum.
XPosition | 286 - Specifies the distance in pixels from the left edge of the page to the start of the image.
XResolution | 282 - The scanner's horizontal resolution in DPI (dots per inch).
YPosition | 283 - Specifies the distance in pixels from the top edge of the page to the start of the image.
YResolution | 283 - The scanner's vertical resolution in DPI.
Remarks

For more information on ISIS tags, refer to the ISIS Tags topic.

Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTag

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


%%PageItemTitle%%

ImGearIsisTagType Enumeration

ImageGear.Web.Isis Namespace Client API Library > ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace : ImGearIsisTagType Enumeration
Data types for ISIS tags.
Members
Member | Description
ByteArray | 3 - A sequence of raw bytes.
Integer | 0 - An integer type.
Rational | 2 - A rational number, which consists of an integer numerator value and an integer denominator value.
String | 1 - A string type.
Inheritance Hierarchy

Object
ImageGear.Web.Isis.ImGearIsisTagType

See Also

Reference

ImageGear.Web.Isis Namespace Client API~ImageGear.Web.Isis_namespace


ImageGear.Web.UI Namespace Client API Library
Namespaces
Namespace | Description
ImageGear.Web.UI | The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have API’s and function with and without the Microsoft UpdatePanel.


ImageGear.Web.UI Namespace (ImageGear.Web.UI Namespace Client API)
Inheritance Hierarchy
ImageGear.Web.UI Namespace Client API Library : ImageGear.Web.UI Namespace
The ImageGear.Web.UI namespace includes ASP.NET WebForms controls to display images and thumbnails in a browser. The controls have API’s and function with and without the Microsoft UpdatePanel.
Classes
class | Description
ArtPage | A page of Mark objects.
ContextMenu | The list of ContextMenuItem objects.
ContextMenuItem | Represents an item in the context menu.
ImGearArgumentException | Represents an ImGearArgumentException object.
ImGearArgumentNullException | Represents an ImGearArgumentNullException object.
ImGearArgumentOutOfRangeException | Represents an ImGearArgumentNullException object.
ImGearArgumentTypeException | Represents an ImGearArgumentNullException object.
ImGearArgumentUndefinedException | Represents an ImGearArgumentUndefinedException object.
ImGearDocument | Represents a single ImGearDocument object in a ImGearDocumentCollection.
ImGearDocumentCollection | A collection of ImGearDocument objects.
ImGearDocumentCreateArgs | Represents object for creating ImGearDocument.
ImGearDocumentEventArgs | The arguments for ImGearDocument events.
ImGearException | Represents a generic custom ImageGear Exception object.
ImGearHttpException | Represents an ImageGear HttpException object.
ImGearInvalidOperationException | Represents an ImGearInvalidOperationException object.
ImGearNotImplementedException | Represents an ImGearNotImplementedException object.
ImGearPage | Represents a single page in a page collection of a document.
ImGearPageCollection | A collection of ImGearPage objects.
ImGearPageCreateArgs | Represents a page create parameters object.
ImGearPageEventArgs | The arguments for ImGearPage events.
ImGearPageOpenFailedEventArgs | The arguments passed for a pageOpenFailed events.
ImGearParameterCountException | Represents an ImGearParameterCountException object.
ImGearThumbnailList | This is an ASP.NET client control for viewing a list of document pages represented as thumbnails.
LogItem | The arguments passed to an onImageGearItemLogged function.
LogItemEventArgs | The arguments passed to an onImageGearItemLogged function.
Mark | An individual mark.
MarkCollection | A collection of Mark objects.
MarkEventArgs | The arguments for mark events.
MouseEvent | The arguments for mouse events.
MouseEventArgs | The arguments for mouse events.
PageView | This is an ASP.NET client control for viewing images.
PageViewState | The control state of an PageView control.
Point | A point in an X/Y coordinate space.
PointCollection | A list of Point objects.
PointEventArgs | The arguments for point events.
Rectangle | A rectangle in an X/Y coordinate space.
ThumbnailView | This is an ASP.NET client control for viewing thumbnails.
ThumbnailViewState | The control state of a ThumbnailView control.
Enumerations
Enumeration | Description
CalloutType | Indicates the type of a text callout.
ContextMenuItemType | Specifies the list of available context menu item types.
DebugErrorLevel | Indicates how much information the control will log (if logging is turned on).
DebugItemCause | Indicates the cause of a debug item.
FillRule | Indicates the fill rule of a polygon mark.
FitType | Specifies a particular scale and scroll state for an image.
FontStyle | Indicates the style of a font.
HorizontalAlignment | Indicates the horizontal alignment of text in a text mark.
ImGearArtDataServices | Specifies options for annotations(art) data services
ImGearPageCountStatus | Specifies the status of page count request from the server.
ImGearThumbnailLayout | Specifies a thumbnails layout within the bounds of the ImGearThumbnailList control.
ImGearThumbnailSelectionMode |
LineHeadType | Indicates the type of the endpoint of a line.
LineStyle | Indicates the style of a line.
MarkType | Indicates the type of a mark.
MouseTool | Indicates what the viewer will do when a user uses the left mouse button.
Orientation | Indicates the rotation and mirroring of text in a text mark.
ScrollBars | Indicates how the image viewer will handle its scrollbars.
VectorFormatsRendering | Specifies the vector format rendering way.
VerticalAlignment | Indicates the vertical alignment of text in a text mark.
See Also

Reference

ImageGear.Web.UI Namespace Client API Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ImageGear.Web.UI Namespace (ImageGear.Web.UI Namespace Client API) Inheritance Hierarchy
ImageGear.Web.UI Namespace Client API Library : ImageGear.Web.UI Namespace
Inheritance Hierarchy
System.Object
ImageGear.Web.UI.ArtPage
ImageGear.Web.UI.ContextMenu
ImageGear.Web.UI.ContextMenuItem
ImageGear.Web.UI.ImGearArgumentException
ImageGear.Web.UI.ImGearArgumentNullException
ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImageGear.Web.UI.ImGearArgumentTypeException
ImageGear.Web.UI.ImGearArgumentUndefinedException
ImageGear.Web.UI.ImGearDocument
ImageGear.Web.UI.ImGearDocumentCollection
ImageGear.Web.UI.ImGearDocumentCreateArgs
ImageGear.Web.UI.ImGearDocumentEventArgs
ImageGear.Web.UI.ImGearException
ImageGear.Web.UI.ImGearHttpException
ImageGear.Web.UI.ImGearInvalidOperationException
ImageGear.Web.UI.ImGearNotImplementedException
ImageGear.Web.UI.ImGearPage
ImageGear.Web.UI.ImGearPageCollection
ImageGear.Web.UI.ImGearPageCreateArgs
ImageGear.Web.UI.ImGearPageEventArgs
ImageGear.Web.UI.ImGearPageOpenFailedEventArgs
ImageGear.Web.UI.ImGearParameterCountException
ImageGear.Web.UI.LogItem
ImageGear.Web.UI.LogItemEventArgs
ImageGear.Web.UI.Mark
ImageGear.Web.UI.MarkCollection
ImageGear.Web.UI.MarkEventArgs
ImageGear.Web.UI.MouseEvent
ImageGear.Web.UI.MouseEventArgs
ImageGear.Web.UI.PageViewState
ImageGear.Web.UI.Point
ImageGear.Web.UI.PointCollection
ImageGear.Web.UI.PointEventArgs
ImageGear.Web.UI.Rectangle
ImageGear.Web.UI.ThumbnailViewState
Sys.Component
Sys.UI.Control
ImageGear.Web.UI.ImGearThumbnailList
ImageGear.Web.UI.PageView
ImageGear.Web.UI.ThumbnailView
See Also

Reference

ImageGear.Web.UI Namespace Client API Library


%%PageItemTitle%%

ArtPage class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ArtPage class
A page of Mark objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ArtPage = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ArtPage();
Remarks

This object is a page of Mark objects. Its primary functions are to associate marks with a viewer and to specify the Z-order of those marks.

Each mark contained in an ArtPage object will have a Z-index, which is both the index of the Mark object in the page and the Z-order of the Mark. The first mark in the page will have a Z-index of 0 and it will also be the Mark that is drawn at the bottom of the Z-order. If any two Mark objects in an ArtPage overlap, the one with the higher Z-index will be drawn on top.

Note that the Z-index of a Mark may change whenever a Mark is added, removed, or reordered in the ArtPage. Also, indices are not unique across ArtPage objects (i.e., any number of ArtPage object may have a Mark with a Z-index of 0).

While a Mark object can only be associated with one ArtPage object, one ArtPage object can be associated with any number (including zero) of PageView or ThumbnailView controls.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ArtPage

See Also

Reference

ArtPage Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ArtPage class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ArtPage class

The following tables list the members exposed by ArtPage.

Public Constructors
 | Name | Description
public Constructor | ArtPage Constructor |
Top
Public Properties
 | Name | Description
public Property | markCount | Returns the number of marks associated with the ArtPage.
public Property | selectedMarks | Contains a list of all the currently-selected marks.
Top
Public Methods
 | Name | Description
public Method | addMark | Appends a mark to the page.
public Method | forEachMark | Calls the specified function once for each mark on the page.
public Method | getMark | Returns the mark at the specified Z-index.
public Method | getZIndexOfMark | Returns the Z-index of the specified mark.
public Method | loadFromJson | Loads marks from a JSON string.
public Method | removeAllMarks | Removes all the marks from the page.
public Method | removeMark | Removes one mark from the page.
public Method | reorderMark | Reorders a mark within the Z-order of the page.
public Method | saveToJson | Saves marks to a JSON string.
Top
Public Events
 | Name | Description
public Event | markAdded | Indicates that a new mark was added to the page.
public Event | markChanged | Indicates that a mark on the page was changed.
public Event | markRemoved | Indicates that a mark was removed from the page.
public Event | markReordered | Indicates that a mark was reordered within the page.
public Event | markSelectionChanged | Indicates that a mark was selected or unselected.
public Event | marksLoaded | Indicates that marks were loaded from a JSON string.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ArtPage Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : ArtPage Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ArtPage = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ArtPage();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%% $$Methods$$

ArtPage class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ArtPage class

For a list of all members of this type, see ArtPage members.

Public Methods
 | Name | Description
public Method | addMark | Appends a mark to the page.
public Method | forEachMark | Calls the specified function once for each mark on the page.
public Method | getMark | Returns the mark at the specified Z-index.
public Method | getZIndexOfMark | Returns the Z-index of the specified mark.
public Method | loadFromJson | Loads marks from a JSON string.
public Method | removeAllMarks | Removes all the marks from the page.
public Method | removeMark | Removes one mark from the page.
public Method | reorderMark | Reorders a mark within the Z-order of the page.
public Method | saveToJson | Saves marks to a JSON string.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

addMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : addMark Method
Appends a mark to the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function addMark(
   mark : Mark
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.addMark(Mark);

Parameters

mark
The mark to add to the collection.
Remarks

The function will add a mark to the ArtPage, at the top of the Z-order. When they overlap, marks that are higher in the Z-order are drawn over marks that are lower.

A mark can only be associated with a single ArtPage at a time. You can move a mark from one ArtPage to another by first removing it from the current ArtPage, then associating it with the new one using ArtPage.addMark.

You can disconnect a mark from its ArtPage by calling either the removeFromPage or Mark.removeMark function.

After this function has added the new mark to the collection, it will raise the markAdded event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

forEachMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : forEachMark Method
Calls the specified function once for each mark on the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEachMark(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.forEachMark(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each mark on the ArtPage. The function will begin with the mark at the bottom of the Z-order and continue in order until it reaches the top of the Z-order. It is very similar to the ASP.NET Ajax Library, Array.forEach() function.

When forEachMark calls the function, it will set this to context, the first function parameter to the mark being enumerated, the second function parameter to the zero-based Z-index of the iteration, and the third function parameter to the collection.

This function copies the list of marks (but not the marks themselves) before starting the enumeration, so you can safely make changes to the collection during the enumeration process. Any marks that you delete during the enumeration will be enumerated; any marks that you add during the enumeration will not be enumerated, any marks that you change during the enumeration will be enumerated with their new value, and any mark that is reordered will be enumerated in the original order.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

getMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : getMark Method
Returns the mark at the specified Z-index.
Syntax
ASP.NET Ajax Javascript (Specification)
function getMark(
   zIndex : number(Integer)
) : Mark;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.getMark(number(Integer));

Parameters

zIndex
The zero-based Z-index of the mark to return.

Return Value

The mark that is at the specified Z-index.
Remarks

This function returns the mark at the specified Z-index. The getZIndexOfMark function performs the opposite operation. The mark at Z-index 0 is the bottom-most mark in the Z-order.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

getZIndexOfMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : getZIndexOfMark Method
Returns the Z-index of the specified mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function getZIndexOfMark(
   mark : Mark
) : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.getZIndexOfMark(Mark);

Parameters

mark
The mark to locate.

Return Value

The zero-based Z-index of the specified mark, or -1 if the mark is not associated with the ArtPage.
Remarks

This function returns the zero-based Z-index of the specified mark. If the mark is not associated with the ArtPage, this function will return -1. The getMark function performs the opposite operation. The mark at Z-index 0 is the bottom-most mark in the Z-order.

Note that a mark Z-index is not the same as an ImageGear for .NET MarkID. MarkID's are unique for a mark and never change, while a mark Z-index simply indicates the position of mark within the Z-order and the mark Z-index will change whenever the Z-order changes.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

loadFromJson Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : loadFromJson Method
Loads marks from a JSON string.
Syntax
ASP.NET Ajax Javascript (Specification)
function loadFromJson(
   json : string
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.loadFromJson(string);

Parameters

json
The JSON string that represents the new marks.
Remarks

This function removes all the marks that are currently associated with the ArtPage and loads a set of new ones from the JSON string. You must use the saveToJson client function or the ImageGear.Web.UI.ArtConnection.Read server function to create JSON strings.

After this function has successfully loaded the marks, it will raise the marksLoaded event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

removeAllMarks Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : removeAllMarks Method
Removes all the marks from the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeAllMarks() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.removeAllMarks();
Remarks

This function removes all marks from the ArtPage. If the ArtPage contains no marks, this function will do nothing (and will not raise a markRemoved event).

After this function removes the marks, it will raise the markRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

removeMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : removeMark Method
Removes one mark from the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeMark(
   mark : Mark
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.removeMark(Mark);

Parameters

mark
The mark to remove.
Remarks

This function removes a single mark from the ArtPage. If the ArtPage does not contain the given mark, this function will do nothing (and will not raise a markRemoved event).

After this function removes the mark, it will raise the markRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

reorderMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : reorderMark Method
Reorders a mark within the Z-order of the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function reorderMark(
   mark : Mark,
   zIndex : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.reorderMark(Mark,number(Integer));

Parameters

mark
The mark to reorder. This mark must already be associated with the ArtPage.
zIndex
The zero-based Z-index that this mark will have after reordering.
Remarks

This function reorders a mark within the Z-order of the page. It will remove it from its current location in the Z-order and re-insert it so it has the given Z-index. If the mark is not currently associated with the page, this function will throw an exception. If the mark already has the specified Z-index, this function will do nothing and will not raise the markReordered event.

After this function reorders the mark, it will raise the markReordered event. Reordering one mark implicitly reorders other marks as well, but this function will not raise the markReordered event for those implicitly-reordered marks.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

saveToJson Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : saveToJson Method
Saves marks to a JSON string.
Syntax
ASP.NET Ajax Javascript (Specification)
function saveToJson() : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.saveToJson();

Return Value

The JSON string that represents the state of all associated marks.
Remarks

This function saves all the marks that are currently associated with the ArtPage to a JSON string.

Note: The JSON format is not a file format and should not be stored in a file or database for later use. The format of JSON strings is specific to a single revision of ImageGear and future versions will not support JSON strings written with this version. If you wish to store marks permanently, use the ImageGear ART XML file formats. You must use the server function, ImageGear.Web.UI.ArtConnection.Write to save JSON strings to the ART XML file format.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%% $$Properties$$

ArtPage class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ArtPage class

For a list of all members of this type, see ArtPage members.

Public Properties
 | Name | Description
public Property | markCount | Returns the number of marks associated with the ArtPage.
public Property | selectedMarks | Contains a list of all the currently-selected marks.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

markCount Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markCount Property
Returns the number of marks associated with the ArtPage.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_markCount() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.get_markCount();
Remarks

This read-only property returns the number of marks associated with the ArtPage. If the page has no marks, this property will be zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

selectedMarks Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : selectedMarks Property
Contains a list of all the currently-selected marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectedMarks() : MarkCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfArtPage.get_selectedMarks();
Example

This JavaScript code unselects all the currently-selected marks.

artPage.get_selectedMarks().removeAllMarks();

This JavaScript code selects a mark, without unselecting the currently-selected marks.

artPage.get_selectedMarks().addMark(markToSelect);
Remarks

This property contains a list of all the currently-selected marks. If you change the value of this property, or if you add or remove a mark from the collection, this object will raise its markSelectionChanged event.

Valid values: Any ImageGear.Web.UI.MarkCollection object.
Default value: new ImageGear.Web.UI.MarkCollection()

ImageGear for .NET name: MarkSelect() and MarkIsSelected()
NotateXpress (version 10) name: Selected

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%% $$Events$$

ArtPage class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ArtPage class

For a list of all members of this type, see ArtPage members.

Public Events
 | Name | Description
public Event | markAdded | Indicates that a new mark was added to the page.
public Event | markChanged | Indicates that a mark on the page was changed.
public Event | markRemoved | Indicates that a mark was removed from the page.
public Event | markReordered | Indicates that a mark was reordered within the page.
public Event | markSelectionChanged | Indicates that a mark was selected or unselected.
public Event | marksLoaded | Indicates that marks were loaded from a JSON string.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

markAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markAdded Event
Indicates that a new mark was added to the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markAdded(handler : Function)
function remove_markAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markAdded(handler);
.remove_markAdded(handler);
Remarks

The collection will raise this event whenever a mark is added (as the result of a call to the addMark function).

When the page raises this event, it will provide the new Mark object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

markChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markChanged Event
Indicates that a mark on the page was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markChanged(handler : Function)
function remove_markChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markChanged(handler);
.remove_markChanged(handler);
Remarks

The collection will raise this event whenever the value of any property of a mark changes.

Note that one exception to this event is the Mark.selected property. This object will not raise a markChanged event when that property changes. Instead, this object will raise a markSelectionChanged event.

When the page raises this event, it will provide the changed Mark object and the name of the property that changed as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

markRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markRemoved Event
Indicates that a mark was removed from the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markRemoved(handler : Function)
function remove_markRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markRemoved(handler);
.remove_markRemoved(handler);
Remarks

The ArtPage will raise this event whenever a mark is removed (as the result of a call to the removeMark or removeAllMarks functions). The object will raise this event after it has removed the mark.

When the page raises this event, it will provide the removed Mark object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

markReordered Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markReordered Event
Indicates that a mark was reordered within the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markReordered(handler : Function)
function remove_markReordered(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markReordered(handler);
.remove_markReordered(handler);
Remarks

The ArtPage will raise this event whenever a mark is reordered (as the result of a call to the reorderMark function). The object will raise this event after it has reordered the mark.

When the page raises this event, it will provide the reordered Mark object and its new Z-index as the event argument. Note that when a mark is reordered, other marks are implicitly moved as well, but this event is not raised for those marks.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

markSelectionChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : markSelectionChanged Event
Indicates that a mark was selected or unselected.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markSelectionChanged(handler : Function)
function remove_markSelectionChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markSelectionChanged(handler);
.remove_markSelectionChanged(handler);
Remarks

The page will raise this event after a mark is added to, or removed from, the selectedMarks collection. The object will raise this event after it has updated the list of selected marks.

When the page raises this event, it will provide the MarkCollection of selected marks as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

marksLoaded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage : marksLoaded Event
Indicates that marks were loaded from a JSON string.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_marksLoaded(handler : Function)
function remove_marksLoaded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_marksLoaded(handler);
.remove_marksLoaded(handler);
Remarks

The ArtPage will raise this event after the loadFromJson function successfully loads marks from a JSON string, even if that string contained no marks.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ArtPage
ArtPage Members


%%PageItemTitle%%

ContextMenu class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenu class
The list of ContextMenuItem objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ContextMenu = function(
   template : Object
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ContextMenu();
Remarks
Parameter template is optional parameter. Context menu can be configured using it's methods insert and remove. As alternate way for context menu initialization the array of context menu items can be passed to the constructor.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ContextMenu

See Also

Reference

ContextMenu Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ContextMenu class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenu class

The following tables list the members exposed by ContextMenu.

Public Constructors
 | Name | Description
public Constructor | ContextMenu Constructor |
Top
Public Properties
 | Name | Description
public Property | innerData | Inner array of context menu items.
public Property | size | The count of items in the list.
Top
Public Methods
 | Name | Description
public Method | get | Returns an item by index.
public Method | insert | Inserts the new item into the list of items.
public Method | remove | Removes the context menu item from the list by index.
public Method | set | Sets given item by index.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ContextMenu Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : ContextMenu Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ContextMenu = function(
   template : Object
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ContextMenu(Object);

Parameters

template
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%% $$Methods$$

ContextMenu class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenu class

For a list of all members of this type, see ContextMenu members.

Public Methods
 | Name | Description
public Method | get | Returns an item by index.
public Method | insert | Inserts the new item into the list of items.
public Method | remove | Removes the context menu item from the list by index.
public Method | set | Sets given item by index.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

get Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : get Method
Returns an item by index.
Syntax
ASP.NET Ajax Javascript (Specification)
function get(
   index : Number
) : ContextMenuItem;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.get(Number);

Parameters

index
Index for item getting for.

Return Value

The context menu item.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%%

insert Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : insert Method
Inserts the new item into the list of items.
Syntax
ASP.NET Ajax Javascript (Specification)
function insert(
   index : Number,
   item : ContextMenuItem
) : Undefined;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.insert(Number,ContextMenuItem);

Parameters

index
Index of position in list for item insert for.
item
The item for insert.

Return Value

The does not returns any value.
Remarks
For insert the item to the end of list the value of size should be passed as index argument.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%%

remove Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : remove Method
Removes the context menu item from the list by index.
Syntax
ASP.NET Ajax Javascript (Specification)
function remove(
   index : Number
) : Undefined;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.remove(Number);

Parameters

index
Index of position for item will be removed.

Return Value

The does not returns any value.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%%

set Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : set Method
Sets given item by index.
Syntax
ASP.NET Ajax Javascript (Specification)
function set(
   index : Number,
   item : ContextMenuItem
) : Undefined;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.set(Number,ContextMenuItem);

Parameters

index
Index for item setting for.
item
The item for replacing existing item.

Return Value

The does not returns any value.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%% $$Properties$$

ContextMenu class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenu class

For a list of all members of this type, see ContextMenu members.

Public Properties
 | Name | Description
public Property | innerData | Inner array of context menu items.
public Property | size | The count of items in the list.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

innerData Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : innerData Property
Inner array of context menu items.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_innerData() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.get_innerData();

Return Value

The array of context menu items.
Remarks
Any changes in this array affect to the ContextMenu instance.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%%

size Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu : size Property
The count of items in the list.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_size() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenu.get_size();

Return Value

The context menu item count.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenu
ContextMenu Members


%%PageItemTitle%%

ContextMenuItem class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenuItem class
Represents an item in the context menu.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ContextMenuItem = function(
   type : ContextMenuItemType,
   text : String,
   contextMenu : ContextMenu,
   clickHandler : Function,
   checkHandler : Function,
   radioHandler : Function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ContextMenuItem();
Remarks

The way the PageView control works with context menu items depends on the type of the item.

For ImageGear.Web.UI.ContextMenuItemType.Separator, “type” is the only required field and the rest of the fields will be ignored by the PageView control.

For ImageGear.Web.UI.ContextMenuItemType.Popup, the PageView control requires “type”, “text” and “contextMenu” to display the popup item and the list of menu objects from the items field.

For ImageGear.Web.UI.ContextMenuItemType.UserMenuItem, in addition to “type” and “text” the PageView control requires clickHandler defined as function(pageView, mark). Optionally, you can specify checkHandler and radioHandler defined as function(pageView, mark) returning Boolean value to display the check and radio markers for the menu.

All menu items corresponding to the other ImageGear.Web.UI.ContextMenuItemType enumeration values are provided by the PageView control with default behavior.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ContextMenuItem

See Also

Reference

ContextMenuItem Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ContextMenuItem class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenuItem class

The following tables list the members exposed by ContextMenuItem.

Public Constructors
 | Name | Description
public Constructor | ContextMenuItem Constructor |
Top
Public Fields
 | Name | Description
public Field | checkHandler | Method defines the visibility of check mark of context menu.
public Field | clickHandler | Method of processing the context menu item.
public Field | contextMenu | Child items of popup menu item.
public Field | radioHandler | Method defines the visibility of radio mark of context menu.
public Field | text | Visible text of context menu item.
public Field | type | Context menu item type.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ContextMenuItem Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : ContextMenuItem Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ContextMenuItem = function(
   type : ContextMenuItemType,
   text : String,
   contextMenu : ContextMenu,
   clickHandler : Function,
   checkHandler : Function,
   radioHandler : Function
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ContextMenuItem(ContextMenuItemType,String,ContextMenu,Function,Function,Function);

Parameters

type
text
contextMenu
clickHandler
checkHandler
radioHandler
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%% $$Fields$$

ContextMenuItem class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenuItem class

For a list of all members of this type, see ContextMenuItem members.

Public Fields
 | Name | Description
public Field | checkHandler | Method defines the visibility of check mark of context menu.
public Field | clickHandler | Method of processing the context menu item.
public Field | contextMenu | Child items of popup menu item.
public Field | radioHandler | Method defines the visibility of radio mark of context menu.
public Field | text | Visible text of context menu item.
public Field | type | Context menu item type.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

checkHandler Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : checkHandler Field
Method defines the visibility of check mark of context menu.
Syntax
ASP.NET Ajax Javascript (Specification)
var checkHandler : Function;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.checkHandler;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

clickHandler Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : clickHandler Field
Method of processing the context menu item.
Syntax
ASP.NET Ajax Javascript (Specification)
var clickHandler : Function;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.clickHandler;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

contextMenu Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : contextMenu Field
Child items of popup menu item.
Syntax
ASP.NET Ajax Javascript (Specification)
var contextMenu : ContextMenu;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.contextMenu;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

radioHandler Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : radioHandler Field
Method defines the visibility of radio mark of context menu.
Syntax
ASP.NET Ajax Javascript (Specification)
var radioHandler : Function;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.radioHandler;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

text Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : text Field
Visible text of context menu item.
Syntax
ASP.NET Ajax Javascript (Specification)
var text : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.text;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

type Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem : type Field
Context menu item type.
Syntax
ASP.NET Ajax Javascript (Specification)
var type : ContextMenuItemType;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfContextMenuItem.type;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ContextMenuItem
ContextMenuItem Members


%%PageItemTitle%%

ImGearArgumentException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentException class
Represents an ImGearArgumentException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentException();
Remarks
When a client function or method is invoked and at least one of the passed arguments does not meet the parameter specification of the called function or method, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArgumentException

See Also

Reference

ImGearArgumentException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearArgumentException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentException class

The following tables list the members exposed by ImGearArgumentException.

Public Constructors
 | Name | Description
public Constructor | ImGearArgumentException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArgumentException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : ImGearArgumentException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentException(String,String);

Parameters

paramName
message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%% $$Methods$$

ImGearArgumentException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentException class

For a list of all members of this type, see ImGearArgumentException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%% $$Fields$$

ImGearArgumentException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentException class

For a list of all members of this type, see ImGearArgumentException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentException
ImGearArgumentException Members


%%PageItemTitle%%

ImGearArgumentNullException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentNullException class
Represents an ImGearArgumentNullException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentNullException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentNullException();
Remarks
When a client function or method is called that has an invalid value of null, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArgumentNullException

See Also

Reference

ImGearArgumentNullException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearArgumentNullException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentNullException class

The following tables list the members exposed by ImGearArgumentNullException.

Public Constructors
 | Name | Description
public Constructor | ImGearArgumentNullException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArgumentNullException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : ImGearArgumentNullException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentNullException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentNullException(String,String);

Parameters

paramName
message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%% $$Methods$$

ImGearArgumentNullException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentNullException class

For a list of all members of this type, see ImGearArgumentNullException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentNullException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%% $$Fields$$

ImGearArgumentNullException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentNullException class

For a list of all members of this type, see ImGearArgumentNullException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentNullException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentNullException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentNullException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentNullException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentNullException
ImGearArgumentNullException Members


%%PageItemTitle%%

ImGearArgumentOutOfRangeException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentOutOfRangeException class
Represents an ImGearArgumentNullException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentOutOfRangeException = function(
   paramName : String,
   actualValue : {Any},
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentOutOfRangeException();
Remarks
When a client function or method is called and an argument value is outside an acceptable range, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArgumentOutOfRangeException

See Also

Reference

ImGearArgumentOutOfRangeException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearArgumentOutOfRangeException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentOutOfRangeException class

The following tables list the members exposed by ImGearArgumentOutOfRangeException.

Public Constructors
 | Name | Description
public Constructor | ImGearArgumentOutOfRangeException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArgumentOutOfRangeException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : ImGearArgumentOutOfRangeException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentOutOfRangeException = function(
   paramName : String,
   actualValue : {Any},
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentOutOfRangeException(String,{Any},String);

Parameters

paramName
actualValue
message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%% $$Methods$$

ImGearArgumentOutOfRangeException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentOutOfRangeException class

For a list of all members of this type, see ImGearArgumentOutOfRangeException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentOutOfRangeException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%% $$Fields$$

ImGearArgumentOutOfRangeException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentOutOfRangeException class

For a list of all members of this type, see ImGearArgumentOutOfRangeException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentOutOfRangeException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentOutOfRangeException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentOutOfRangeException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentOutOfRangeException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentOutOfRangeException
ImGearArgumentOutOfRangeException Members


%%PageItemTitle%%

ImGearArgumentTypeException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentTypeException class
Represents an ImGearArgumentNullException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentTypeException = function(
   paramName : String,
   actualType : {Any},
   expectedType : Type,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentTypeException();
Remarks
When a client function or method is called and an argument passed to it is not an allowed type, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArgumentTypeException

See Also

Reference

ImGearArgumentTypeException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearArgumentTypeException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentTypeException class

The following tables list the members exposed by ImGearArgumentTypeException.

Public Constructors
 | Name | Description
public Constructor | ImGearArgumentTypeException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArgumentTypeException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : ImGearArgumentTypeException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentTypeException = function(
   paramName : String,
   actualType : {Any},
   expectedType : Type,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentTypeException(String,{Any},Type,String);

Parameters

paramName
actualType
expectedType
message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%% $$Methods$$

ImGearArgumentTypeException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentTypeException class

For a list of all members of this type, see ImGearArgumentTypeException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentTypeException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%% $$Fields$$

ImGearArgumentTypeException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentTypeException class

For a list of all members of this type, see ImGearArgumentTypeException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentTypeException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentTypeException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentTypeException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentTypeException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentTypeException
ImGearArgumentTypeException Members


%%PageItemTitle%%

ImGearArgumentUndefinedException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentUndefinedException class
Represents an ImGearArgumentUndefinedException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentUndefinedException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentUndefinedException();
Remarks
When a function or method is called in client script and an argument for a required parameter is undefined, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArgumentUndefinedException

See Also

Reference

ImGearArgumentUndefinedException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearArgumentUndefinedException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentUndefinedException class

The following tables list the members exposed by ImGearArgumentUndefinedException.

Public Constructors
 | Name | Description
public Constructor | ImGearArgumentUndefinedException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArgumentUndefinedException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : ImGearArgumentUndefinedException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearArgumentUndefinedException = function(
   paramName : String,
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearArgumentUndefinedException(String,String);

Parameters

paramName
message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%% $$Methods$$

ImGearArgumentUndefinedException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentUndefinedException class

For a list of all members of this type, see ImGearArgumentUndefinedException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentUndefinedException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%% $$Fields$$

ImGearArgumentUndefinedException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArgumentUndefinedException class

For a list of all members of this type, see ImGearArgumentUndefinedException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentUndefinedException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentUndefinedException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentUndefinedException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearArgumentUndefinedException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearArgumentUndefinedException
ImGearArgumentUndefinedException Members


%%PageItemTitle%%

ImGearDocument class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocument class
Represents a single ImGearDocument object in a ImGearDocumentCollection.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocument = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocument();
Remarks

One or more ImGearDocument objects form ImGearDocumentCollection. Every ImGearThumbnailList control has one ImGearDocumentCollection. An ImGearDocument can represent a whole multi-image file containing several pages or it can also represent a multi-page file with a few selected pages. ImGearDocument mapping with a single page image file is always one to one.

Every ImGearDocument contains one ImGearPageCollection.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearDocument

See Also

Reference

ImGearDocument Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearDocument class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocument class

The following tables list the members exposed by ImGearDocument.

Public Constructors
 | Name | Description
public Constructor | ImGearDocument Constructor |
Top
Public Properties
 | Name | Description
public Property | caption | Gets or sets caption for the ImGearDocument.
public Property | documentIdentifier | Indicates the document identifier of the document.
public Property | encodedDocumentIdentifier | Indicates the encoded document identifier of the document.
public Property | includeAllPages | Gets or sets whether if all pages in a document will be included.
public Property | pageCount | Indicates the total number of pages in the document.
public Property | pageCountStatus | Gets the page count status for the pages contained in the document in the control.
public Property | pages | Gets the page collection that is contained in this document.
Top
Public Methods
 | Name | Description
public Method | decodeDocumentIdentifier | Decodes the encoded document identifier provided in the parameter.
public Method | encodeDocumentIdentifier | Encodes the document identifier provided in the parameter.
Top
Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates that a new ART page failed to open in the document.
public Event | pageAdded | Indicates that a new page was added to the collection.
public Event | pageChanged | Indicates that a page in the page collection of this document was changed.
public Event | pageOpenFailed | Indicates that a new page failed to open in the document.
public Event | pageRemoved | Indicates that a page was removed from the page collection in the document.
public Event | propertyChanged | Indicates that a property of the document changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearDocument Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : ImGearDocument Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocument = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocument();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%% $$Methods$$

ImGearDocument class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocument class

For a list of all members of this type, see ImGearDocument members.

Public Methods
 | Name | Description
public Method | decodeDocumentIdentifier | Decodes the encoded document identifier provided in the parameter.
public Method | encodeDocumentIdentifier | Encodes the document identifier provided in the parameter.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

decodeDocumentIdentifier Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : decodeDocumentIdentifier Method
Decodes the encoded document identifier provided in the parameter.
Syntax
ASP.NET Ajax Javascript (Specification)
function decodeDocumentIdentifier(
   encodedDocumentIdentifier : string
) : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.decodeDocumentIdentifier(string);

Parameters

encodedDocumentIdentifier
The encoded document identifier to be decoded.

Return Value

A DocumentIdentifier string after decoding the input encodeddocumentIdentifier.
Remarks

This method will return decoded string value for the encodedDocumentIdentifier provided in the parameter.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

encodeDocumentIdentifier Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : encodeDocumentIdentifier Method
Encodes the document identifier provided in the parameter.
Syntax
ASP.NET Ajax Javascript (Specification)
function encodeDocumentIdentifier(
   documentIdentifier : string
) : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.encodeDocumentIdentifier(string);

Parameters

documentIdentifier
The document identifier to be encoded.

Return Value

An encoded documentIdentifier string.
Remarks

This method will return encoded string value for the documentIdentifier.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%% $$Properties$$

ImGearDocument class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocument class

For a list of all members of this type, see ImGearDocument members.

Public Properties
 | Name | Description
public Property | caption | Gets or sets caption for the ImGearDocument.
public Property | documentIdentifier | Indicates the document identifier of the document.
public Property | encodedDocumentIdentifier | Indicates the encoded document identifier of the document.
public Property | includeAllPages | Gets or sets whether if all pages in a document will be included.
public Property | pageCount | Indicates the total number of pages in the document.
public Property | pageCountStatus | Gets the page count status for the pages contained in the document in the control.
public Property | pages | Gets the page collection that is contained in this document.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

caption Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : caption Property
Gets or sets caption for the ImGearDocument.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_caption() : String
function set_caption(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_caption();
Remarks

This property value can be used for formatting the string for thumbnail caption, Refer to the property % ImageGear.Web.UI.ImGearThumbnailList.thumbnailCaptionFormat% This property is a string that can be displayed as a caption in the thumbnail in the ImGearThumbnailList control if it is included in format for the thumbnail caption. When this property is changed, it will trigger to fire the "propertyChanged" event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

documentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : documentIdentifier Property
Indicates the document identifier of the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documentIdentifier() : string
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_documentIdentifier();
Remarks

This read-only property is the document identifier for the document. This property will always match the encodedDocumentIdentifier property, except that encodedDocumentIdentifier is base64-encoded so the control can safely use it in a URL or in JavaScript code. This property can be set only at the time of the creation of the document object. if the document object was created with encodedDocumentIdentifier but not the documentIdentifier in the constructor, then the value of this property will be set internally.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

encodedDocumentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : encodedDocumentIdentifier Property
Indicates the encoded document identifier of the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_encodedDocumentIdentifier() : String
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_encodedDocumentIdentifier();
Remarks

This read-only property will be the encoded value for the documentIdentifier. This property will always match the documentIdentifier property, except that this one is base64-encoded so the controls can safely use it in a URL or in JavaScript code. This property can be set only at the time of the creation of the document object. if the document object was created with documentIdentifier but not the encodedDocumentIdentifier in the constructor, then the value of this property will be set internally.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

includeAllPages Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : includeAllPages Property
Gets or sets whether if all pages in a document will be included.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_includeAllPages() : Boolean
function set_includeAllPages(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_includeAllPages();
Remarks

This property indicates whether all pages in a document are to be included.

When this property is set to "true" and the pageCount is unknown, a request will be made to the server for information about the total page count in the document. At this point, the pageCountStatus will be set to "RequestPending" state. The pageCountStatus will be set to "known" value when the pageCount is available. If a request for the pageCount is pending, the pageCountStatus is in an "RequestPending" state and if at this point, this property is changed to value "false", the request will still go ahead. When a request to the server for the page count is being processed, and if at this point an addPage method is called, the page specified will be added. A new instance of a page object with the same page number be created and added to the collection when the result for the pageCount query arrives from the server. In this scenario, the page collection will contain two instances of page objects that represent the same page numbers.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageCount Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageCount Property
Indicates the total number of pages in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageCount() : Number
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_pageCount();
Remarks

This read only property is applicable when the pageCountStatus property is set to ImageGear.Web.UI.ImGearPageCountStatus.Known value. This property value will be undefined when the pageCountStatus property is either in ImageGear.Web.UI.ImGearPageCountStatus.UnRequested or ImageGear.Web.UI.ImGearPageCountStatus.RequestPending state. When the value is first available, the document object will raise the propertyChanged event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageCountStatus Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageCountStatus Property
Gets the page count status for the pages contained in the document in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageCountStatus() : ImGearPageCountStatus
function set_pageCountStatus(value : ImGearPageCountStatus)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_pageCountStatus();
Remarks

This property specifies the page count status for the pages belonging to the document. The status values are defined in the enumeration ImGearPageCountStatus.

A value of "UnRequested" for this property means a request for pageCount has been not been made yet. A value of "RequestPending" means, a request for pageCount has been sent to the server. A value of "Known" means a request for pageCount was made previously and the pageCount is available. When the value is first set to “Known” the pageCount is set to the value obtained from the server. At this point the document will fire the “propertyChanged” event for the “pageCount” property. A request for the pageCount will only be made when includeAllPages is set to "true". ”Failed” means the request failed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pages Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pages Property
Gets the page collection that is contained in this document.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pages() : ImGearPageCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocument.get_pages();
Remarks

This property gives access to the pages that are contained in a document.

Example: The JavaScript code to add pages is shown below:

var doc = new ImageGear.Web.UI.ImGearDocument({documentIdentifier:'MyImage.tif'});

var _page = new ImageGear.Web.UI.ImGearPage({pageNumber:1,caption:'This is the Caption for page 1'});

doc.get_pages().addPages(_page); //add the new page to the document
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%% $$Events$$

ImGearDocument class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocument class

For a list of all members of this type, see ImGearDocument members.

Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates that a new ART page failed to open in the document.
public Event | pageAdded | Indicates that a new page was added to the collection.
public Event | pageChanged | Indicates that a page in the page collection of this document was changed.
public Event | pageOpenFailed | Indicates that a new page failed to open in the document.
public Event | pageRemoved | Indicates that a page was removed from the page collection in the document.
public Event | propertyChanged | Indicates that a property of the document changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : artPageOpenFailed Event
Indicates that a new ART page failed to open in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_artPageOpenFailed(handler : Function)
function remove_artPageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_artPageOpenFailed(handler);
.remove_artPageOpenFailed(handler);
Remarks

The ImGearDocument will raise this event whenever one or more pages fail to load in the document.

The document will provide a ImGearPageOpenFailedEventArgs which contains one parameter, an exception object.

This object contains an exception object which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageAdded Event
Indicates that a new page was added to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageAdded(handler : Function)
function remove_pageAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageAdded(handler);
.remove_pageAdded(handler);
Remarks

The ImGearDocument will raise this event whenever one or more pages are added to the ImGearPageCollection in the document.

The document will provide a ImGearPageEventArgs as the event argument. When this event is raised the ImGearPage is provided in the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageChanged Event
Indicates that a page in the page collection of this document was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageChanged(handler : Function)
function remove_pageChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageChanged(handler);
.remove_pageChanged(handler);
Remarks

The document will raise this event whenever a page is changed in the page collection of this document.

The document will provide a ImGearPageEventArgs as the event argument. The changed ImGearPage will be provided in the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageOpenFailed Event
Indicates that a new page failed to open in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpenFailed(handler : Function)
function remove_pageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpenFailed(handler);
.remove_pageOpenFailed(handler);
Remarks

The ImGearDocument will raise this event whenever one or more pages fail to load in the document.

The document will provide a ImGearPageOpenFailedEventArgs which contains one parameter, an exception object.

This object contains an exception object which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

pageRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : pageRemoved Event
Indicates that a page was removed from the page collection in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageRemoved(handler : Function)
function remove_pageRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageRemoved(handler);
.remove_pageRemoved(handler);
Remarks

The ImGearDocument will raise this event whenever a page is removed (as a result of a call to the removePage or removeAllPages methods).

The ImGearDocument will provide a ImGearPageEventArgs as the event argument. When the page collection raises this event during the removePage function, it will provide the removed page in the event argument ImGearPageEventArgs object When the document raises this event during the removeAllPages function, it will provide the removed page in the ImGearPageEventArgs object. for every page object removed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

propertyChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument : propertyChanged Event
Indicates that a property of the document changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_propertyChanged(handler : Function)
function remove_propertyChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_propertyChanged(handler);
.remove_propertyChanged(handler);
Remarks

The object will raise this event whenever any property of the object is changed.

When the ImGearDocument object raises this event, it will provide the name of the changed property as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocument
ImGearDocument Members


%%PageItemTitle%%

ImGearDocumentCollection class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCollection class
A collection of ImGearDocument objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentCollection();
Remarks

This object is a collection of ImGearDocument objects.

This object is used primarily as a property in ImGearThumbnailList control. It is also available for use by users of ImageGear Web Solutions API.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearDocumentCollection

See Also

Reference

ImGearDocumentCollection Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearDocumentCollection class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCollection class

The following tables list the members exposed by ImGearDocumentCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearDocumentCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | addDocument | Appends a document to the end of the collection.
public Method | forEach | Calls the specified function once for each ImGearDocument in the collection.
public Method | getDocument | Returns a document in the collection.
public Method | insertDocument | Inserts a document in the collection at the location specified by the parameter 'index'.
public Method | removeAllDocuments | Removes all the documents from the collection.
public Method | removeDocument | Removes a document from the collection.
Top
Public Events
 | Name | Description
public Event | documentAdded | Indicates that a new document was added to the collection.
public Event | documentChanged | Indicates that a document in the collection was changed.
public Event | documentRemoved | Indicates that a document was removed from the collection.
public Event | pageAdded | Indicates that a new page was added to the page collection in the document.
public Event | pageChanged | Indicates that a page in the page collection in a document of this document collection was changed.
public Event | pageRemoved | Indicates that a page is removed from the page collection in the document.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearDocumentCollection Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : ImGearDocumentCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentCollection();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%% $$Methods$$

ImGearDocumentCollection class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCollection class

For a list of all members of this type, see ImGearDocumentCollection members.

Public Methods
 | Name | Description
public Method | addDocument | Appends a document to the end of the collection.
public Method | forEach | Calls the specified function once for each ImGearDocument in the collection.
public Method | getDocument | Returns a document in the collection.
public Method | insertDocument | Inserts a document in the collection at the location specified by the parameter 'index'.
public Method | removeAllDocuments | Removes all the documents from the collection.
public Method | removeDocument | Removes a document from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

addDocument Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : addDocument Method
Appends a document to the end of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addDocument(
   imGearDocument : ImGearDocument
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.addDocument(ImGearDocument);

Parameters

imGearDocument
The document to add to the collection.
Remarks

This function will append the ImGearDocument object passed in as the parameter to the collection. This function is similar to the standard JavaScript Array.push() function.

After this function has added the new imGearDocument to the collection, it will raise the documentAdded event. The event argument contains the imGearDocument object added.

Note: When adding a new document to the collection, make sure that the new document does not contain a duplicated instance of a ImGearPage object in the document's page collection ImGearPageCollection, ImageGear.Web.UI.ImGearPageCollection.addPage property for details.

This collection is used within the ImGearThumbnailList control

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

forEach Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : forEach Method
Calls the specified function once for each ImGearDocument in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each ImGearDocument in the collection.

When forEach calls the function, it will set this to context, the first function parameter to a copy of the ImGearDocument being enumerated, the second function parameter to the zero-based index of the iteration, and the third function parameter to the collection.

This function copies the list of documents before starting the enumeration, so you can safely make changes to the collection during the enumeration process. Any document that you delete during the enumeration will be enumerated; any document that you add during the enumeration will not be enumerated, and any documents that you change during the enumeration will be enumerated with their new value. Note: The read-only properties in the documents of the collection, for example, documentIdentifier and encodedDocumentIdentifier cannot be changed, refer to the ImGearDocument properties for details.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

getDocument Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : getDocument Method
Returns a document in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function getDocument(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.getDocument(number(Integer));

Parameters

index
The zero-based index of the ImGearDocument object to return.
Remarks

This function returns the document in the collection at the requested index.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

insertDocument Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : insertDocument Method
Inserts a document in the collection at the location specified by the parameter 'index'.
Syntax
ASP.NET Ajax Javascript (Specification)
function insertDocument(
   index : number(Integer),
   imGearDocument : ImGearDocument
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.insertDocument(number(Integer),ImGearDocument);

Parameters

index
A zero-based index in the document collection where the document is to be inserted.
imGearDocument
The document to be inserted in the collection.
Remarks

The function will insert the document at the location in the collection specified by the index parameter.

After this function has inserted the document to the collection, it will raise the documentAdded event.

Note: A document object instance must be unique in a ImGearThumbnailList control and a web page.

The index will be validated. The value must be a zero or greater than zero but less than or equal to the collection length (0<=index<=length). An exception is thrown for invalid values. The insertion index value must be within the collection's length range. If the collection is empty and insertion index specified is other than 0, an exception will be thrown. Negative values for the index are not acceptable. The insert action at index zero when the collection is empty is equivalent to addDocument action. The insertion occurs at the index specified, for example, insertDocument(0,newDocument) would insert the new document before the existing index 0.

Note: When inserting a new document to the collection, make sure that the new document does not contain a duplicated instance of a ImGearPage object in the document's page collection ImGearPageCollection, addPage property for details.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

removeAllDocuments Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : removeAllDocuments Method
Removes all the documents from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeAllDocuments() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.removeAllDocuments();
Remarks

This function removes all documents from the collection. If the collection has no document, this function will do nothing and will not raise the documentRemoved event.

After this function removes each document, it will raise the documentRemoved event. In other words, a documentRemoved event will be fired for each document removed. Refer to the removeDocument method.for details.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

removeDocument Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : removeDocument Method
Removes a document from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeDocument(
   document : ImGearDocument
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.removeDocument(ImGearDocument);

Parameters

document
The document to remove.
Remarks

This function removes a single document from the collection. If the document is not present in the collection, this function will do nothing and it will not raise a documentRemoved event.

After this function removes the document, it will raise the documentRemoved event. The event argument ImGearDocumentEventArgs will contain the document removed from the collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%% $$Properties$$

ImGearDocumentCollection class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCollection class

For a list of all members of this type, see ImGearDocumentCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCollection.get_length();
Remarks

This function returns the number of documents that the collection contains. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%% $$Events$$

ImGearDocumentCollection class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCollection class

For a list of all members of this type, see ImGearDocumentCollection members.

Public Events
 | Name | Description
public Event | documentAdded | Indicates that a new document was added to the collection.
public Event | documentChanged | Indicates that a document in the collection was changed.
public Event | documentRemoved | Indicates that a document was removed from the collection.
public Event | pageAdded | Indicates that a new page was added to the page collection in the document.
public Event | pageChanged | Indicates that a page in the page collection in a document of this document collection was changed.
public Event | pageRemoved | Indicates that a page is removed from the page collection in the document.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

documentAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : documentAdded Event
Indicates that a new document was added to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_documentAdded(handler : Function)
function remove_documentAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_documentAdded(handler);
.remove_documentAdded(handler);
Remarks

The collection will raise this event whenever documents are added or inserted to the collection (as the result of a call to the addDocument or insertDocument methods).

The collection will provide a ImGearDocumentEventArgs as the event argument. When the collection raises this event during the addDocument method, it will provide the ImGearDocument object added ImGearDocument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

documentChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : documentChanged Event
Indicates that a document in the collection was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_documentChanged(handler : Function)
function remove_documentChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_documentChanged(handler);
.remove_documentChanged(handler);
Remarks

The collection will raise this event whenever a document is changed.

The collection will provide a ImGearDocumentEventArgs as the event argument. When the collection raises this event, it will provide the changed document in the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

documentRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : documentRemoved Event
Indicates that a document was removed from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_documentRemoved(handler : Function)
function remove_documentRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_documentRemoved(handler);
.remove_documentRemoved(handler);
Remarks

The collection will raise this event whenever a document is removed (as a result of a call to the removeDocument or removeAllDocuments functions).

The collection will provide a ImGearDocumentEventArgs as the event argument. When the collection raises this event during the removeDocument function, it will provide ImGearDocument that was removed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

pageAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : pageAdded Event
Indicates that a new page was added to the page collection in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageAdded(handler : Function)
function remove_pageAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageAdded(handler);
.remove_pageAdded(handler);
Remarks

The collection will raise this event whenever one or more pages are added to the page collection (as the result of a call to the addPage function). The event argument object ImGearPageEventArgs contains the added ImGearPage as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

pageChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : pageChanged Event
Indicates that a page in the page collection in a document of this document collection was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageChanged(handler : Function)
function remove_pageChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageChanged(handler);
.remove_pageChanged(handler);
Remarks

The document collection will raise this event whenever a page is changed in page collections in this document collection.

The document collection will provide the event arguments provided ImGearPageEventArgs. The event argument contains the changed ImGearPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

pageRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection : pageRemoved Event
Indicates that a page is removed from the page collection in the document.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageRemoved(handler : Function)
function remove_pageRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageRemoved(handler);
.remove_pageRemoved(handler);
Remarks

The ImGearDocumentCollection raises this event whenever one or more pages are removed from the page collections in the documents(as the result of a call to the removePage function).

The collection provides ImGearPageEventArgs as the event argument. The event argument contains the removed ImGearPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCollection
ImGearDocumentCollection Members


%%PageItemTitle%%

ImGearDocumentCreateArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCreateArgs class
Represents object for creating ImGearDocument.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentCreateArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentCreateArgs();
Remarks

This object contains the parameters for ImGearDocument object creation. It is not necessary to create this object and then pass in as the parameter for Imgear object creation. The fields mentioned above can be passed as in-line parameter object as shown in the constructor for the ImGearDocument class.

Example:

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearDocumentCreateArgs

See Also

Reference

ImGearDocumentCreateArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearDocumentCreateArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCreateArgs class

The following tables list the members exposed by ImGearDocumentCreateArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearDocumentCreateArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | documentIdentifier | The document identifier of the document.
public Field | encodedDocumentidentier | The encoded document identifier.
public Field | imageServicePath | The image service path.
public Field | pageNumber | The start page number for the page range.
public Field | pageRangeCount | The count of pages for the page range.
public Field | pages | An array of pages.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearDocumentCreateArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : ImGearDocumentCreateArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentCreateArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentCreateArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%% $$Fields$$

ImGearDocumentCreateArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentCreateArgs class

For a list of all members of this type, see ImGearDocumentCreateArgs members.

Public Fields
 | Name | Description
public Field | documentIdentifier | The document identifier of the document.
public Field | encodedDocumentidentier | The encoded document identifier.
public Field | imageServicePath | The image service path.
public Field | pageNumber | The start page number for the page range.
public Field | pageRangeCount | The count of pages for the page range.
public Field | pages | An array of pages.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

documentIdentifier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : documentIdentifier Field
The document identifier of the document.
Syntax
ASP.NET Ajax Javascript (Specification)
var documentIdentifier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.documentIdentifier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

encodedDocumentidentier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : encodedDocumentidentier Field
The encoded document identifier.
Syntax
ASP.NET Ajax Javascript (Specification)
var encodedDocumentidentier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.encodedDocumentidentier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

imageServicePath Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : imageServicePath Field
The image service path.
Syntax
ASP.NET Ajax Javascript (Specification)
var imageServicePath : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.imageServicePath;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

pageNumber Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : pageNumber Field
The start page number for the page range.
Syntax
ASP.NET Ajax Javascript (Specification)
var pageNumber : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.pageNumber;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

pageRangeCount Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : pageRangeCount Field
The count of pages for the page range.
Syntax
ASP.NET Ajax Javascript (Specification)
var pageRangeCount : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.pageRangeCount;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

pages Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs : pages Field
An array of pages.
Syntax
ASP.NET Ajax Javascript (Specification)
var pages : array;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentCreateArgs.pages;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentCreateArgs
ImGearDocumentCreateArgs Members


%%PageItemTitle%%

ImGearDocumentEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentEventArgs class
The arguments for ImGearDocument events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentEventArgs();
Remarks

A ImGearDocument will provide an instance of this object whenever it raises a ImGearDocumentCollection.documentAdded or ImGearDocumentCollection.documentRemoved events.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearDocumentEventArgs

See Also

Reference

ImGearDocumentEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearDocumentEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentEventArgs class

The following tables list the members exposed by ImGearDocumentEventArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearDocumentEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | imGearDocument | The document which is most directly related to the event. Events that affect multiple documents will not provide a value for this property.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearDocumentEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs : ImGearDocumentEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearDocumentEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearDocumentEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs
ImGearDocumentEventArgs Members


%%PageItemTitle%% $$Fields$$

ImGearDocumentEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearDocumentEventArgs class

For a list of all members of this type, see ImGearDocumentEventArgs members.

Public Fields
 | Name | Description
public Field | imGearDocument | The document which is most directly related to the event. Events that affect multiple documents will not provide a value for this property.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

imGearDocument Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs : imGearDocument Field
The document which is most directly related to the event. Events that affect multiple documents will not provide a value for this property.
Syntax
ASP.NET Ajax Javascript (Specification)
var imGearDocument : ImGearDocument;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearDocumentEventArgs.imGearDocument;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearDocumentEventArgs
ImGearDocumentEventArgs Members


%%PageItemTitle%%

ImGearException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearException class
Represents a generic custom ImageGear Exception object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearException = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearException();
Remarks

This object is derived from the JavaScript native Error object. The message represents the error message. The second parameter passed is an object whose fields will be attached to the instance of the object.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearException

See Also

Reference

ImGearException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearException class

The following tables list the members exposed by ImGearException.

Public Constructors
 | Name | Description
public Constructor | ImGearException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | errorInfo | Contains object whose fields will be added to the instance of the object.
public Field | message | error message.
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : ImGearException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearException = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearException();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%% $$Methods$$

ImGearException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearException class

For a list of all members of this type, see ImGearException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%% $$Fields$$

ImGearException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearException class

For a list of all members of this type, see ImGearException members.

Public Fields
 | Name | Description
public Field | description |
public Field | errorInfo | Contains object whose fields will be added to the instance of the object.
public Field | message | error message.
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%%

errorInfo Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : errorInfo Field
Contains object whose fields will be added to the instance of the object.
Syntax
ASP.NET Ajax Javascript (Specification)
var errorInfo : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.errorInfo;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : message Field
error message.
Syntax
ASP.NET Ajax Javascript (Specification)
var message : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearException
ImGearException Members


%%PageItemTitle%%

ImGearHttpException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearHttpException class
Represents an ImageGear HttpException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearHttpException = function(
   statusCode : Number,
   message : string,
   customErrorCode : Number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearHttpException();
Remarks

The following list contains the possible statusCodes:

  • 400: Bad request, this status code generally indicates that the documentIdentifier was not given.
  • 404: The image file was missing.
  • 410: Image file could not be opened due to corrupted or unlicensed file.
  • 500: Internal Server Error. This means that something seriously went wrong on the server.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearHttpException

See Also

Reference

ImGearHttpException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearHttpException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearHttpException class

The following tables list the members exposed by ImGearHttpException.

Public Constructors
 | Name | Description
public Constructor | ImGearHttpException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearHttpException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : ImGearHttpException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearHttpException = function(
   statusCode : Number,
   message : string,
   customErrorCode : Number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearHttpException(Number,string,Number);

Parameters

statusCode
message
customErrorCode
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%% $$Methods$$

ImGearHttpException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearHttpException class

For a list of all members of this type, see ImGearHttpException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearHttpException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%% $$Fields$$

ImGearHttpException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearHttpException class

For a list of all members of this type, see ImGearHttpException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearHttpException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearHttpException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearHttpException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearHttpException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearHttpException
ImGearHttpException Members


%%PageItemTitle%%

ImGearInvalidOperationException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearInvalidOperationException class
Represents an ImGearInvalidOperationException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearInvalidOperationException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearInvalidOperationException();
Remarks
When a client function or method is called and an error occurs that is not caused by invalid arguments, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearInvalidOperationException

See Also

Reference

ImGearInvalidOperationException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearInvalidOperationException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearInvalidOperationException class

The following tables list the members exposed by ImGearInvalidOperationException.

Public Constructors
 | Name | Description
public Constructor | ImGearInvalidOperationException Constructor |
Top
Public Fields
 | Name | Description
public Field | protype |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearInvalidOperationException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException : ImGearInvalidOperationException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearInvalidOperationException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearInvalidOperationException(String);

Parameters

message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException
ImGearInvalidOperationException Members


%%PageItemTitle%% $$Fields$$

ImGearInvalidOperationException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearInvalidOperationException class

For a list of all members of this type, see ImGearInvalidOperationException members.

Public Fields
 | Name | Description
public Field | protype |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

protype Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException : protype Field
Syntax
ASP.NET Ajax Javascript (Specification)
var protype : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearInvalidOperationException.protype;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearInvalidOperationException
ImGearInvalidOperationException Members


%%PageItemTitle%%

ImGearNotImplementedException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearNotImplementedException class
Represents an ImGearNotImplementedException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearNotImplementedException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearNotImplementedException();
Remarks
When an attempt is made to call a client method that is not supported by an object, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearNotImplementedException

See Also

Reference

ImGearNotImplementedException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearNotImplementedException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearNotImplementedException class

The following tables list the members exposed by ImGearNotImplementedException.

Public Constructors
 | Name | Description
public Constructor | ImGearNotImplementedException Constructor |
Top
Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearNotImplementedException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : ImGearNotImplementedException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearNotImplementedException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearNotImplementedException(String);

Parameters

message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%% $$Methods$$

ImGearNotImplementedException class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearNotImplementedException class

For a list of all members of this type, see ImGearNotImplementedException members.

Public Methods
 | Name | Description
public Method | popStackFrame |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

popStackFrame Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : popStackFrame Method
Syntax
ASP.NET Ajax Javascript (Specification)
function popStackFrame() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearNotImplementedException.popStackFrame();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%% $$Fields$$

ImGearNotImplementedException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearNotImplementedException class

For a list of all members of this type, see ImGearNotImplementedException members.

Public Fields
 | Name | Description
public Field | description |
public Field | message |
public Field | name |
public Field | number |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

description Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : description Field
Syntax
ASP.NET Ajax Javascript (Specification)
var description : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearNotImplementedException.description;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : message Field
Syntax
ASP.NET Ajax Javascript (Specification)
var message : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearNotImplementedException.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%%

name Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : name Field
Syntax
ASP.NET Ajax Javascript (Specification)
var name : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearNotImplementedException.name;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%%

number Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException : number Field
Syntax
ASP.NET Ajax Javascript (Specification)
var number : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearNotImplementedException.number;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearNotImplementedException
ImGearNotImplementedException Members


%%PageItemTitle%%

ImGearPage class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPage class
Represents a single page in a page collection of a document.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPage = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPage();
Remarks

This object represents a single page in either a one page or a multi-page document. A ImGearPageCollection is composed of one or more of these page objects. Each ImGearDocument has one such ImGearPageCollection object.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPage

See Also

Reference

ImGearPage Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearPage class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPage class

The following tables list the members exposed by ImGearPage.

Public Constructors
 | Name | Description
public Constructor | ImGearPage Constructor |
Top
Public Properties
 | Name | Description
public Property | caption | Gets or sets caption for the page.
public Property | document | Indicates the document object that contains this page.
public Property | pageNumber | Gets the index number for the page in a multipage document.
public Property | selected | Indicates whether the page is selected.
Top
Public Events
 | Name | Description
public Event | propertyChanged | Indicates that a property was changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPage Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : ImGearPage Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPage = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPage();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%% $$Properties$$

ImGearPage class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPage class

For a list of all members of this type, see ImGearPage members.

Public Properties
 | Name | Description
public Property | caption | Gets or sets caption for the page.
public Property | document | Indicates the document object that contains this page.
public Property | pageNumber | Gets the index number for the page in a multipage document.
public Property | selected | Indicates whether the page is selected.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

caption Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : caption Property
Gets or sets caption for the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_caption() : String
function set_caption(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPage.get_caption();
Remarks

This property is a string that is displayed as a caption in the thumbnail in the ImGearThumbnailList control. When this property is changed, it will fire the "propertyChanged" event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%%

document Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : document Property
Indicates the document object that contains this page.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_document() : ImGearDocument
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPage.get_document();
Remarks

This is a read only property. This property is a ImGearDocument that holds this page.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%%

pageNumber Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : pageNumber Property
Gets the index number for the page in a multipage document.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageNumber() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPage.get_pageNumber();
Remarks

This is a read only property. It's value can be specified in the constructor only. It is the image page index for page in a multipage document. The first page of a file has an image page index of zero. This means, that a document that is not a multipage document has this property value as zero. The start index of page numbers in a multipage document is always zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%%

selected Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : selected Property
Indicates whether the page is selected.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selected() : Boolean
function set_selected(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPage.get_selected();
Remarks

This property is a boolean that indicates the page's selection status when it is displayed in the ImGearThumbnailList control. This flag is provided to indicate the selection status of a page.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%% $$Events$$

ImGearPage class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPage class

For a list of all members of this type, see ImGearPage members.

Public Events
 | Name | Description
public Event | propertyChanged | Indicates that a property was changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

propertyChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage : propertyChanged Event
Indicates that a property was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_propertyChanged(handler : Function)
function remove_propertyChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_propertyChanged(handler);
.remove_propertyChanged(handler);
Remarks

The page raises this event when the page properties caption and selected changes. The page will provide the name of the changed property as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPage
ImGearPage Members


%%PageItemTitle%%

ImGearPageCollection class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCollection class
A collection of ImGearPage objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageCollection();
Remarks

This object is an ordered list of ImGearPage objects. It holds and returns ImGearPage objects. It raises pageAdded, pageChanged, and pageRemoved events at appropriate times.

This object is used as a property in a ImGearDocument object and for the selectedPages property in the ImGearThumbnailList class.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPageCollection

See Also

Reference

ImGearPageCollection Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearPageCollection class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCollection class

The following tables list the members exposed by ImGearPageCollection.

Public Constructors
 | Name | Description
public Constructor | ImGearPageCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the pages collection.
Top
Public Methods
 | Name | Description
public Method | addPage | Appends a page to the end of the collection.
public Method | forEach | Calls the specified function once for each page in the collection.
public Method | getPage | Returns a page in the collection at the index specified.
public Method | insertPage | Inserts a page at the location in the collection specified by the parameter 'index'.
public Method | removeAllPages | Removes all the pages from the collection.
public Method | removePage | Removes one page from the collection.
public Method | setPage | Puts the page at the required index in the collection.
Top
Public Events
 | Name | Description
public Event | pageAdded | Indicates that a new page was added to the collection.
public Event | pageChanged | Indicates that a page in the collection was changed.
public Event | pageRemoved | Indicates that a page was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPageCollection Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : ImGearPageCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageCollection();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%% $$Methods$$

ImGearPageCollection class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCollection class

For a list of all members of this type, see ImGearPageCollection members.

Public Methods
 | Name | Description
public Method | addPage | Appends a page to the end of the collection.
public Method | forEach | Calls the specified function once for each page in the collection.
public Method | getPage | Returns a page in the collection at the index specified.
public Method | insertPage | Inserts a page at the location in the collection specified by the parameter 'index'.
public Method | removeAllPages | Removes all the pages from the collection.
public Method | removePage | Removes one page from the collection.
public Method | setPage | Puts the page at the required index in the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

addPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : addPage Method
Appends a page to the end of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addPage(
   page : ImGearPage
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.addPage(ImGearPage);

Parameters

page
The page to add to the collection.
Remarks

This function appends the page passed in as parameter to the collection. It is similar to the standard JavaScript Array.push() function.

After this function has added the page to the collection, it will raise the pageAdded event.

Note: A page object instance can be added only to one ImGearThumbnailList control in a web page. A page object instance must be unique within a ImGearThumbnailList control on an entire web page. Both of these constraints arise because of the selected property. The first constraint exists because a single Page object can either be selected or not-selected and it makes no sense to allow that to span multiple ImGearThumbnailList controls. The second constraint exists because of the "selectedPages" collection on the ImGearThumbnailList control. Each thumbnail in the control should be individually selectable, but that will be impossible to represent if two of them are represented by the same object.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

forEach Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : forEach Method
Calls the specified function once for each page in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each Page in the collection.

When forEach calls the function, it will set this to context, the first function parameter is the Page being enumerated, the second function parameter is the zero-based index of the iteration, and the third function parameter to the collection.

This function copies the list of pages before starting the enumeration, so you can safely make changes to the collection during the enumeration process. Any page that you delete during the enumeration will be enumerated; any pages that you add during the enumeration will not be enumerated, and any pages that you change during the enumeration will be enumerated with their new value.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

getPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : getPage Method
Returns a page in the collection at the index specified.
Syntax
ASP.NET Ajax Javascript (Specification)
function getPage(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.getPage(number(Integer));

Parameters

index
The zero-based index of the ImGearPage to return.
Remarks

This function returns the page located at the index in the collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

insertPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : insertPage Method
Inserts a page at the location in the collection specified by the parameter 'index'.
Syntax
ASP.NET Ajax Javascript (Specification)
function insertPage(
   index : number(Integer),
   page : ImGearPage
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.insertPage(number(Integer),ImGearPage);

Parameters

index
The zero-based index in the page collection where the page is to be inserted.
page
The page to be inserted in the collection.
Remarks

The function will insert the page in the parameter at the location in the collection specified by the index parameter.

The index will be validated. The value must be in the range zero or greater than zero, but less than or equal to the collection length (0 <= index <= current length). An exception is thrown for invalid values. If the collection is empty and insertion index specified is other than 0, an exception will be thrown. Negative values for the index are not acceptable. The insert action at index zero when the collection is empty is equivalent to addPage action. The insertion occurs at the index specified, for example, insertPage(0,newPage) would insert the new page before the existing index 0.

After this function has inserted the page to the collection, it will raise the pageAdded event.

Note: A page object instance can be added only to one ImGearThumbnailList control at a time and a single page object must be unique within a ImGearThumbnailList control on an entire web page. For details see the remarks section of the addPage property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

removeAllPages Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : removeAllPages Method
Removes all the pages from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeAllPages() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.removeAllPages();
Remarks

This function removes all pages from the collection. If the collection contains no page, this function will do nothing and will not raise the pageRemoved event.

A pageRemoved event will be raised for each page removed in the collection. Refer to the pageRemoved event for details about the eventArgs.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

removePage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : removePage Method
Removes one page from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removePage(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.removePage(number(Integer));

Parameters

index
The zero-based index of the page to remove.
Remarks

This function removes a single page from the collection.

After this function removes the page, it will raise the pageRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

setPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : setPage Method
Puts the page at the required index in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function setPage(
   index : number(Integer),
   page : ImGearPage
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.setPage(number(Integer),ImGearPage);

Parameters

index
The zero-based index of the page to change.
page
The new value to assign to the specified page.
Remarks

This function puts the page at the required index. This function will not add a new page to the collection; the collection must contain a page at the given index before you call this function.

This function will raise two events, the pageRemoved event for the removal of the existing page and the pageAdded

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%% $$Properties$$

ImGearPageCollection class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCollection class

For a list of all members of this type, see ImGearPageCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the pages collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : length Property
Returns the length of the pages collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCollection.get_length();
Remarks

This function returns the number of pages that are in the collection. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%% $$Events$$

ImGearPageCollection class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCollection class

For a list of all members of this type, see ImGearPageCollection members.

Public Events
 | Name | Description
public Event | pageAdded | Indicates that a new page was added to the collection.
public Event | pageChanged | Indicates that a page in the collection was changed.
public Event | pageRemoved | Indicates that a page was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

pageAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : pageAdded Event
Indicates that a new page was added to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageAdded(handler : Function)
function remove_pageAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageAdded(handler);
.remove_pageAdded(handler);
Remarks

The collection will raise this event whenever one or more pages are added to the collection (as the result of a call to the addPage function).

The collection will provide a ImGearPageEventArgs as the event argument. When the collection raises this event during the addPage function, it will provide the new ImGearPage being added.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

pageChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : pageChanged Event
Indicates that a page in the collection was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageChanged(handler : Function)
function remove_pageChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageChanged(handler);
.remove_pageChanged(handler);
Remarks

The collection will raise this event whenever a page is changed.

The collection will provide a ImGearPageEventArgs as the event argument. When the collection raises this event, it will provide the changed page.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

pageRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection : pageRemoved Event
Indicates that a page was removed from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageRemoved(handler : Function)
function remove_pageRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageRemoved(handler);
.remove_pageRemoved(handler);
Remarks

The collection will raise this event whenever a page is removed (as the result of a call to the removePage or removeAllPages functions).

The collection will provide a ImGearPageEventArgs as the event argument. When the collection raises this event during the removePage function, it will provide the removed page. When the collection raises this event during the removeAllPages function, it will provide the removed page ImGearPage for every page object removed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCollection
ImGearPageCollection Members


%%PageItemTitle%%

ImGearPageCreateArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCreateArgs class
Represents a page create parameters object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageCreateArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageCreateArgs();
Remarks

This object contains the arguments for ImGearPage creation.

It is not strictly necessary to create an object of this type for providing the parameters. The example code in the constructor for ImGearPage shows another acceptable way to pass the ImGearPage create parameters. This class identifies the fields that are represented in the ImGearPage input parameter object.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPageCreateArgs

See Also

Reference

ImGearPageCreateArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearPageCreateArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCreateArgs class

The following tables list the members exposed by ImGearPageCreateArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearPageCreateArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | caption | The caption for the page.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPageCreateArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs : ImGearPageCreateArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageCreateArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageCreateArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs
ImGearPageCreateArgs Members


%%PageItemTitle%% $$Fields$$

ImGearPageCreateArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCreateArgs class

For a list of all members of this type, see ImGearPageCreateArgs members.

Public Fields
 | Name | Description
public Field | caption | The caption for the page.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

caption Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs : caption Field
The caption for the page.
Syntax
ASP.NET Ajax Javascript (Specification)
var caption : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCreateArgs.caption;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs
ImGearPageCreateArgs Members


%%PageItemTitle%%

pageNumber Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs : pageNumber Field
The page index of a page in a multi-page document. The first page in a file is index 0.
Syntax
ASP.NET Ajax Javascript (Specification)
var pageNumber : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageCreateArgs.pageNumber;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageCreateArgs
ImGearPageCreateArgs Members


%%PageItemTitle%%

ImGearPageEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageEventArgs class
The arguments for ImGearPage events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageEventArgs();
Remarks

This object contains the arguments for Page events. A ImGearPageCollection will provide an instance of this object whenever it raises a ImGearPageCollection.pageAdded or ImGearPageCollection.pageRemoved or ImgearPageCollection.pageInsertedevent.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPageEventArgs

See Also

Reference

ImGearPageEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearPageEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageEventArgs class

The following tables list the members exposed by ImGearPageEventArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearPageEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | imGearPage | . The ImGearPage which is most directly related to the event. For a non-existing ImGearPage, this property will have the value undefined.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPageEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs : ImGearPageEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs
ImGearPageEventArgs Members


%%PageItemTitle%% $$Fields$$

ImGearPageEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageEventArgs class

For a list of all members of this type, see ImGearPageEventArgs members.

Public Fields
 | Name | Description
public Field | imGearPage | . The ImGearPage which is most directly related to the event. For a non-existing ImGearPage, this property will have the value undefined.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

imGearPage Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs : imGearPage Field
. The ImGearPage which is most directly related to the event. For a non-existing ImGearPage, this property will have the value undefined.
Syntax
ASP.NET Ajax Javascript (Specification)
var imGearPage : ImGearPage;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageEventArgs.imGearPage;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageEventArgs
ImGearPageEventArgs Members


%%PageItemTitle%%

ImGearPageOpenFailedEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageOpenFailedEventArgs class
The arguments passed for a pageOpenFailed events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageOpenFailedEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageOpenFailedEventArgs();
Remarks
This object contains the arguments for pageOpenFailed events raised by the PageView or ThumbnailView conrols.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPageOpenFailedEventArgs

See Also

Reference

ImGearPageOpenFailedEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearPageOpenFailedEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageOpenFailedEventArgs class

The following tables list the members exposed by ImGearPageOpenFailedEventArgs.

Public Constructors
 | Name | Description
public Constructor | ImGearPageOpenFailedEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | exception | The exception object.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPageOpenFailedEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs : ImGearPageOpenFailedEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearPageOpenFailedEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearPageOpenFailedEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs
ImGearPageOpenFailedEventArgs Members


%%PageItemTitle%% $$Fields$$

ImGearPageOpenFailedEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageOpenFailedEventArgs class

For a list of all members of this type, see ImGearPageOpenFailedEventArgs members.

Public Fields
 | Name | Description
public Field | exception | The exception object.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

exception Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs : exception Field
The exception object.
Syntax
ASP.NET Ajax Javascript (Specification)
var exception : object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearPageOpenFailedEventArgs.exception;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearPageOpenFailedEventArgs
ImGearPageOpenFailedEventArgs Members


%%PageItemTitle%%

ImGearParameterCountException class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearParameterCountException class
Represents an ImGearParameterCountException object.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearParameterCountException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearParameterCountException();
Remarks
When a client function or method is called and an invalid number of arguments have been passed to it, an object of this type is created.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearParameterCountException

See Also

Reference

ImGearParameterCountException Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearParameterCountException class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearParameterCountException class

The following tables list the members exposed by ImGearParameterCountException.

Public Constructors
 | Name | Description
public Constructor | ImGearParameterCountException Constructor |
Top
Public Fields
 | Name | Description
public Field | prootype |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearParameterCountException Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException : ImGearParameterCountException Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearParameterCountException = function(
   message : String
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearParameterCountException(String);

Parameters

message
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException
ImGearParameterCountException Members


%%PageItemTitle%% $$Fields$$

ImGearParameterCountException class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearParameterCountException class

For a list of all members of this type, see ImGearParameterCountException members.

Public Fields
 | Name | Description
public Field | prootype |
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

prootype Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException : prootype Field
Syntax
ASP.NET Ajax Javascript (Specification)
var prootype : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearParameterCountException.prootype;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearParameterCountException
ImGearParameterCountException Members


%%PageItemTitle%%

ImGearThumbnailList class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailList class
This is an ASP.NET client control for viewing a list of document pages represented as thumbnails.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearThumbnailList = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearThumbnailList();
Remarks

This ASP.NET client control is a viewer for viewing a list of thumbnails. It displays thumbnails for each of the pages that are included in the ImGearPageCollection for every document in the ImGearDocumentCollection. Each of these control contains one ImGearDocumentCollection object.

This control represents a list of thumbnails, so if you wish to show thumbnails in your application then you will need to have one ImGearThumbnailList control on your web page for the document pages you wish to display as thumbnails.

The control optionally allows you to use your own CSS class definitions for the display of the thumbnails within it. For details of CSS class definitions, refer to the the property description for useDefaultStyling. By default, it uses the built in style.

While it is possible to create an instance of this control using client-side JavaScript, you can also create it by placing a server-side ImGearThumbnailList control on an .aspx page. Using the server side approach lets you do data binding for the images in the thumbnails. For details, refer to the server side API for the ImGearThumbnailList control. If you are creating the control using the clientside API, then in your application code, you need to access your image repository to obtain the documentIdentifier values for the ImGearDocument objects that are added to the ImGearThumbnailList control's ImGearDocumentCollection.

Example 1:

There are two ways to create this control using the client-side JavaScript API,

1. Using the Microsoft Ajax library

2. Using the jQuery plugins.

Note: Both methods will not do any postbacks to the server. Also, you can not use jQuery plugins if you are using Microsft Ajax library.

Take the following steps to create client side controls:

Add an empty <DIV> to your HTML.

Give your <DIV> a unique ID (example: ImGearThumbnailList1).

Give your <DIV> a size, using either a CSS style sheet or an inline style. If using CSS style, make sure to use the CSS class names as listed under the property useDefaultStyling

If using Microsft Ajax library, add the following code to your page that creates an instance of the ImGearThumbnailList control.

$create(ImageGear.Web.UI.ImGearThumbnailList, { artServiceOption: ImageGear.Web.UI.ImGearArtDataServices.ArtDataService, thumbnailCaptionFormat: "{DC}:Page {P#}"}, null, null, $get("ImGearThumbnailList1"));

If using ImGearThumbnailListPlugin jQuery plugin, proceed with the following code wrapped inside the code that checks if the browser document is ready:

$(document).ready(function () { });

Note: The options parameter is an an object that takes all the properties for the control that can be set.

$("#ImGearThumbnailList1").ImGearThumbnailListPlugin({ artServiceOption: ImageGear.Web.UI.ImGearArtDataServices.ArtDataService, thumbnailCaptionFormat: "{DC}:Page {P#}", layout: ImageGear.Web.UI.ImGearThumbnailLayout.VerticalScrollDirection});

The default thumbnails layout setting in the control is ImGearThumbnailLayout.VerticalScrollDirection in the enumeration definition ImGearThumbnailLayout. In this example code, we will be using the default value. The number of columns in the control is determined by the width of a thumbnail item and the width of the control. The number of rows will depend on the number of pages in the document collection of the control. if the width of the control is set to greater than at least two thumbnail widths amount, the control will have a multi column grid. However, if the width of the control is less than two thumbnail widths, a single vertical column control will be obtained. If you want your thumbnails to be arranged in a single horizontal line, set the property layout to ImageGear.Web.UI.ImGearThumbnailLayout.HorizontalScrollDirection.

Example 2:

Create Documents and add them to the control.

Add the following code to create an instance of a ImGearDocument.

var _doc = new ImageGear.Web.UI.ImGearDocument({documentIdentifier: "MyImage.tif", includeAllPages:true, imageServicePath:"ImageGearService.svc" });

//set the includeAllPages property of the ImGearDocument to true so that all pages in Multi-page tif file (MyImage.tif) are displayed as thumbnails.

_doc.set_includeAllPages(true);

//If using Microsft ajax library, add ImGearDocument object to the ImGearThumbnailList control whose id is 'ImGearThumbnailList1'.

"$find('ImGearThumbnailList1').get_documents().addDocument(_doc);

If using jQuery plugins, add the documents as shown above, to the control with the following code:

$("#ImGearThumbnailList1").ImGearThumbnailListPlugin().get_documents().addDocument(_doc);

We have selected the default setting for the layout property. If the width of the control can fit only one column of thumbnails, then it will be a single vertical column of thumbnails.

If you want your thumbnails to be arranged in a single horizontal line, set the property layout from the enumeration definition ImageGear.Web.UI.ImGearThumbnailLayout.HorizontalScrollDirection

Inheritance Hierarchy

Object
Sys.Component
Sys.UI.Control
ImageGear.Web.UI.ImGearThumbnailList

See Also

Reference

ImGearThumbnailList Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ImGearThumbnailList class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailList class

The following tables list the members exposed by ImGearThumbnailList.

Public Constructors
 | Name | Description
public Constructor | ImGearThumbnailList Constructor |
Top
Public Properties
 | Name | Description
public Property | artDataChanged | Indicates whether the art data has changed since the last save operation.
public Property | artServiceOption | Indicates ImagedataService option.
public Property | controlStateElementId | Gets or sets the id of the HTML element that will hold the state of this control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Gets or sets how much information the control will log.
public Property | documents | Gets the document collection object that is contained in this control.
public Property | enabled | Indicates if the ImGearThumbnailList control is in an active state.
public Property | layout | Gets or sets the layout for the thumbnails in the ImGearThumbnailList control.
public Property | pageViewClientId | Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | selectedPages | Gets a collection of currently selected pages.
public Property | selectionMode | Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
public Property | thumbnailBackgroundColor | Gets or sets the background color for the thumbnails displayed in the control.
public Property | thumbnailBorderColor | Gets or sets the for the border color for thumbnails displayed in the control.
public Property | thumbnailBorderWidth | Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
public Property | thumbnailCaptionFormat | Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
public Property | thumbnailHeight | Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
public Property | thumbnailSelectedBackgroundColor | Gets or sets the background color for the selected thumbnails displayed in the control.
public Property | thumbnailWidth | Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
public Property | useDefaultStyling | Gets or sets the default visual style for the thumbnails and their contents.
public Property | xSpacing | Gets or sets the amount of horizontal space between thumbnails displayed in the control.
public Property | ySpacing | Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Top
Public Methods
 | Name | Description
public Method | display | Scrolls to the first thumbnail item in the control's thumbnail items list. Forces the ThumbnailList control to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the ImGearThumbnailList.
public Method | getArtPage | Gets the art data of the page specified in the parameter.
public Method | saveArtData | Saves annotations.
public Method | scrollToFirstThumbnail | Scrolls to the first thumbnail item in the control's thumbnail items list.
public Method | scrollToLastThumbnail | Scrolls the last thumbnail item in the list.
public Method | scrollToNextBand | Scrolls the next band of thumbnail items into view.
public Method | scrollToPreviousBand | Scrolls the previous band of thumbnail items into view.
public Method | scrollToSelectedThumbnail | Scrolls to the currently selected thumbnail item in the list.
public Method | selectFirstThumbnail | Selects the first thumbnail in the control's list.
public Method | selectLastThumbnail | Selects the last thumbnail in the control's list.
public Method | selectNextThumbnail | Selects the thumbnail next to the currently selected thumbnail.
public Method | selectPreviousThumbnail | Selects the thumbnail previous to the current thumbnail selection.
public Method | writeToLog | Writes a user-defined event to the log.
Top
Public Events
 | Name | Description
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageAddFailed | Indicates that a page failed to load in a thumbnail.
public Event | pageSelectionChanged | Indicates the thumbnail displaying a page was selected or unselected.
public Event | propertyChanged | Indicates that a property of this ImGearThumbnailList changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearThumbnailList Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : ImGearThumbnailList Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ImGearThumbnailList = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ImGearThumbnailList();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%% $$Methods$$

ImGearThumbnailList class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailList class

For a list of all members of this type, see ImGearThumbnailList members.

Public Methods
 | Name | Description
public Method | display | Scrolls to the first thumbnail item in the control's thumbnail items list. Forces the ThumbnailList control to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the ImGearThumbnailList.
public Method | getArtPage | Gets the art data of the page specified in the parameter.
public Method | saveArtData | Saves annotations.
public Method | scrollToFirstThumbnail | Scrolls to the first thumbnail item in the control's thumbnail items list.
public Method | scrollToLastThumbnail | Scrolls the last thumbnail item in the list.
public Method | scrollToNextBand | Scrolls the next band of thumbnail items into view.
public Method | scrollToPreviousBand | Scrolls the previous band of thumbnail items into view.
public Method | scrollToSelectedThumbnail | Scrolls to the currently selected thumbnail item in the list.
public Method | selectFirstThumbnail | Selects the first thumbnail in the control's list.
public Method | selectLastThumbnail | Selects the last thumbnail in the control's list.
public Method | selectNextThumbnail | Selects the thumbnail next to the currently selected thumbnail.
public Method | selectPreviousThumbnail | Selects the thumbnail previous to the current thumbnail selection.
public Method | writeToLog | Writes a user-defined event to the log.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

display Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : display Method
Scrolls to the first thumbnail item in the control's thumbnail items list. Forces the ThumbnailList control to update its visual presentation immediately.
Syntax
ASP.NET Ajax Javascript (Specification)
function display() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.display();
Remarks

This method scrolls into view the first thumbnail in the list.

Forces the ThumbnailList control to update its visual presentation immediately. Normally, the viewer will wait until the browser is idle before updating the visual presentation.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

dispose Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : dispose Method
Disposes of the resources held by the ImGearThumbnailList.
Syntax
ASP.NET Ajax Javascript (Specification)
function dispose() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.dispose();
Remarks

This function disposes of the resources held by this ImGearThumbnailList and removes all Thumbnails information. After you call this function, you will not be able to use this instance of the ImGearThumbnailList again. You must always call get_enabled() to make sure the control is still available.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

getArtPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : getArtPage Method
Gets the art data of the page specified in the parameter.
Syntax
ASP.NET Ajax Javascript (Specification)
function getArtPage(
   page : ImGearPage
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.getArtPage(ImGearPage);

Parameters

page
The page object whose art data is required.
Remarks
Obtains art data of the page specified in the parameter.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

saveArtData Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : saveArtData Method
Saves annotations.
Syntax
ASP.NET Ajax Javascript (Specification)
function saveArtData() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.saveArtData();
Remarks

This method allows user to save annotations including all its current changes.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

scrollToFirstThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : scrollToFirstThumbnail Method
Scrolls to the first thumbnail item in the control's thumbnail items list.
Syntax
ASP.NET Ajax Javascript (Specification)
function scrollToFirstThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.scrollToFirstThumbnail();
Remarks

This method scrolls into view the first thumbnail in the list.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

scrollToLastThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : scrollToLastThumbnail Method
Scrolls the last thumbnail item in the list.
Syntax
ASP.NET Ajax Javascript (Specification)
function scrollToLastThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.scrollToLastThumbnail();
Remarks

This method scrolls into view the last thumbnail in the list.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

scrollToNextBand Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : scrollToNextBand Method
Scrolls the next band of thumbnail items into view.
Syntax
ASP.NET Ajax Javascript (Specification)
function scrollToNextBand() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.scrollToNextBand();
Remarks

When the control's layout property mode is in vertical scrolling direction, this method scrolls into view the thumbnails contained in the row next to the row in current view. When the control's layout property mode is in horizontal scrolling direction, this method scrolls into view the thumbnails contained in the column next to the column in current view. For thumbnails layout in a grid format, the control always has scroll bar on the right, therefore, the scroll position will move to the next line of thumbnails. When the thumbnail layout has a single vertical column (a special case of grid with one column), the scroll position moves into view one thumbnail below the current position.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

scrollToPreviousBand Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : scrollToPreviousBand Method
Scrolls the previous band of thumbnail items into view.
Syntax
ASP.NET Ajax Javascript (Specification)
function scrollToPreviousBand() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.scrollToPreviousBand();
Remarks

This method scrolls into view the thumbnails contained in the line previous to the band in current view. Note: For thumbnails arranged in a single horizontal line, the scroll position will shift to a single thumbnail previous to the current scroll position. For thumbnails layout in a grid format, this control always has scroll bar on the right, therefore, the scroll position will move to the previous band of thumbnails. When the thumbnail layout has a single vertical column (a special case of grid with one column), the scroll position moves into view one thumbnail above the current position.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

scrollToSelectedThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : scrollToSelectedThumbnail Method
Scrolls to the currently selected thumbnail item in the list.
Syntax
ASP.NET Ajax Javascript (Specification)
function scrollToSelectedThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.scrollToSelectedThumbnail();
Remarks

This method scrolls into view the currently selected thumbnail.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectFirstThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectFirstThumbnail Method
Selects the first thumbnail in the control's list.
Syntax
ASP.NET Ajax Javascript (Specification)
function selectFirstThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.selectFirstThumbnail();
Remarks

This method selects the first thumbnail in the ThumbnailListView. All other thumbnails will be unselected.

Note: When a multi selection mode is in effect and if there are one or more thumbnails selected at that point in time, this method causes de-selection of all the selected thumbnails and it selects the first thumbnail in the list.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectLastThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectLastThumbnail Method
Selects the last thumbnail in the control's list.
Syntax
ASP.NET Ajax Javascript (Specification)
function selectLastThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.selectLastThumbnail();
Remarks

This method selects the last thumbnail in the ImGearThumbnailList. All other thumbnails will be unselected.

Note: When a multi selection mode is in effect and if there are one or more thumbnails selected at that point in time, this method causes de-selection of all the selected thumbnails and it selects the last thumbnail in the list.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectNextThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectNextThumbnail Method
Selects the thumbnail next to the currently selected thumbnail.
Syntax
ASP.NET Ajax Javascript (Specification)
function selectNextThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.selectNextThumbnail();
Remarks

This method selects the thumbnail next to the one currently selected.

Note: When the selection mode is set to multi slection, and if there already is a multi selection currently in effect, then this method will select the next thumbnail to the next highest number in the selected list.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectPreviousThumbnail Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectPreviousThumbnail Method
Selects the thumbnail previous to the current thumbnail selection.
Syntax
ASP.NET Ajax Javascript (Specification)
function selectPreviousThumbnail() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.selectPreviousThumbnail();
Remarks

This method selects the thumbnail previous to the one currently selected.

Note: When the selection mode is set to multi selection and if there are current multiple thumbnail selections, then these will be unselected and the index before the first in the previously selected group will be selected. If no thumbnail(s) are currently selected, then there would be no selection resulting from the call to this method.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

writeToLog Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : writeToLog Method
Writes a user-defined event to the log.
Syntax
ASP.NET Ajax Javascript (Specification)
function writeToLog(
   message : string
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.writeToLog(string);

Parameters

message
The message to write to the log.
Remarks

The ImGearThumbnailList writes a wide variety of information to the log and this function allows you to add your own information to that same log. Normally, you would use this function to send key events to the log so you can see the larger context of events that this product writes into its log.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%% $$Properties$$

ImGearThumbnailList class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailList class

For a list of all members of this type, see ImGearThumbnailList members.

Public Properties
 | Name | Description
public Property | artDataChanged | Indicates whether the art data has changed since the last save operation.
public Property | artServiceOption | Indicates ImagedataService option.
public Property | controlStateElementId | Gets or sets the id of the HTML element that will hold the state of this control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Gets or sets how much information the control will log.
public Property | documents | Gets the document collection object that is contained in this control.
public Property | enabled | Indicates if the ImGearThumbnailList control is in an active state.
public Property | layout | Gets or sets the layout for the thumbnails in the ImGearThumbnailList control.
public Property | pageViewClientId | Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | selectedPages | Gets a collection of currently selected pages.
public Property | selectionMode | Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
public Property | thumbnailBackgroundColor | Gets or sets the background color for the thumbnails displayed in the control.
public Property | thumbnailBorderColor | Gets or sets the for the border color for thumbnails displayed in the control.
public Property | thumbnailBorderWidth | Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
public Property | thumbnailCaptionFormat | Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
public Property | thumbnailHeight | Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
public Property | thumbnailSelectedBackgroundColor | Gets or sets the background color for the selected thumbnails displayed in the control.
public Property | thumbnailWidth | Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
public Property | useDefaultStyling | Gets or sets the default visual style for the thumbnails and their contents.
public Property | xSpacing | Gets or sets the amount of horizontal space between thumbnails displayed in the control.
public Property | ySpacing | Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artDataChanged Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : artDataChanged Property
Indicates whether the art data has changed since the last save operation.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artDataChanged() : Boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_artDataChanged();
Remarks

This is a read only boolean property when “true” indicates that art data contained in the thumbnails were changed by the user since the last call to the saveArtData method. Any changes made to the annotations after the initial display of the control will also be indicated by the value “true”.

When the value of this property is changed, the control will raise propertyChanged event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

artServiceOption Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : artServiceOption Property
Indicates ImagedataService option.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artServiceOption() : ImGearArtDataServices
function set_artServiceOption(value : ImGearArtDataServices)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_artServiceOption();
Remarks

This property lets you choose ImageGear Art Data Service.

If the ImGearThumbnailList control is created using client side API and annotations data are required from the server either for reading or for updating, then this property value must be set to one of the enumeration ImageGear.Web.UI.ImGearArtDataServices.ArtDataService fields.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

controlStateElementId Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : controlStateElementId Property
Gets or sets the id of the HTML element that will hold the state of this control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_controlStateElementId() : String
function set_controlStateElementId(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_controlStateElementId();
Remarks

This property is a string that contains the id of an HTML element that will hold the state of this control. It is for internal use only and the server-side ASP.NET control automatically sets this property to the correct value. If you are not using the server-side ASP.NET control, then you should not use this property because it is only used to convey the client-side control's state back to the server-side control.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

debug Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : debug Property
Indicates whether the control should log its actions.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debug() : Boolean
function set_debug(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_debug();
Remarks

This property turns the control's logging on or off. If you set this to true, the control will log its activities via the ASP.NET client-side trace facility.

You can set the amount of information that the viewer will log using the debugErrorLevel property.

The ASP.NET client-side trace facility is documented in MSDN, but to summarize, the client framework will send trace text to the following locations:

  • A textarea element on your page with an id of "TraceConsole"
  • The IE8 Developer Tools Console window
  • The FireBug Console window
  • The Visual Studio Output window

In addition to the locations that the ASP.NET client-side trace facility sends trace text, this control will send all logged items (with the data to be logged in a LogItemEventArgs object) to a global function, if it is present. In order to use this facility, you need to define a global JavaScript function in your client page called "onImageGearItemLogged".

Example:

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

If using Microsoft Ajax Library

var ImGearThumbnailList1 = $find('ImGearThumbnailList1');

// OR if using ImageGear jQuery plugins

var ImGearThumbnailList1 = $("#ImGearThumbnailList1").ImGearPageViewPlugin();

ImGearThumbnailList.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);

ImGearThumbnailList1.set_debug(true);

This JavaScript code implements the onImageGearItemLogged function, which will automatically receive items that any Accusoft control logs.

function onImageGearItemLogged(logItem) {

}
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

debugErrorLevel Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : debugErrorLevel Property
Gets or sets how much information the control will log.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debugErrorLevel() : DebugErrorLevel
function set_debugErrorLevel(value : DebugErrorLevel)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_debugErrorLevel();
Remarks

This property sets the amount of information the control will log.

In addition to setting this property, you must turn logging on using the debug property.

Example :

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

//if using Microsoft Ajax library

var ImGearThumbnailList1 = $find('ImGearThumbnailList1');

// OR if using ImageGear jQuery plugins

var ImGearThumbnailList1 = $("#ImGearThumbnailList1").ImGearThumbnailListPlugin();

ImGearThumbnailList1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);

ImGearThumbnailList1.set_debug(true);
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

documents Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : documents Property
Gets the document collection object that is contained in this control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documents() : ImGearDocumentCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_documents();
Remarks

This property gives access to the documents that are contained in this control. For details refer to the ImGearDocument

The documents property can be used to access the document collection for adding and removing documents from the control. The example code below illustrates how to add documents to the control.

Example:

The JavaScript code snippet to add documents to the control:

var _doc = new ImageGear.Web.UI.ImGearDocument({documentIdentifier:'MyImage.tif'});

// set the pages property of this document

var _page = new ImageGear.Web.UI.ImGearPage({pageNumber:0, caption:'Page 0, the first page'});

//add the new page to the document

_doc.get_pages().addPage(_page);

//add the newly created document _doc to the previously created ImGearThumbnailList control.

ImGearThumbnailList1.get_documents().addDocument(_doc);
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

enabled Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : enabled Property
Indicates if the ImGearThumbnailList control is in an active state.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_enabled() : Boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_enabled();
Remarks

This is a read-only property. The value will be set to 'true when the control is initialized. It will have a value of 'false', when the control is disposed. A value of true indicates that the ImGearThumbnailList control is an active state. All operations are allowed when in active state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

layout Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : layout Property
Gets or sets the layout for the thumbnails in the ImGearThumbnailList control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_layout() : {Any}
function set_layout(value : {Any})
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_layout();
Remarks

This property defines the placement/arrangement of the thumbnails in the ImGearThumbnailList control. The value for this property is obtained from the enumeration ImGearThumbnailLayout. The default mode is ImageGear.Web.UI.ImGearThumbnailLayout.VerticalScrollDirection. In this mode, the number of columns will be calculated based on the number of thumbnail widths plus intra-thumbnail spaces that can fit in the control's width. The number of rows of thumbnails in the view will depend on the number of thumbnail heights plus intra-thumbnail space that fit in the height of the control. Those thumbnails that are not view can be brought into view using the Vertical scroll bar on the control. In the default mode, the scroll bar is always on the right hand side. The ImageGear.Web.UI.ImGearThumbnailsLayout.HorizontalScrollDirection option displays the thumbnails as a single horizontal band and has a horizontal scroll bar to bring into view the thumbnails that are not in the view.

If you change the value of this property, the control will raise propertyChanged event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

pageViewClientId Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : pageViewClientId Property
Gets or sets the id of the PageView control associated with this ImGearThumbnailList control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageViewClientId() : String
function set_pageViewClientId(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_pageViewClientId();
Remarks

This property is a string that contains the id of the PageView control that should display the image displayed in each of the thumbnails when selected.

It is common for applications of a ImGearThumbnailList control to display the selected thumbnail page element in a larger viewer and this property makes it easier for you to implement that kind of application. Simply set this property to the id of the ImGearPageView. This property will not be applicable in a multi selection mode. In the absence of a PageView on a web page, it should be set to 'undefined'.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

resourcePath Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : resourcePath Property
Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_resourcePath() : string
function set_resourcePath(value : string)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_resourcePath();
Remarks

This property is a string that specifies the image files required for the menu icons and and the art mark handles. These files are png format files and are required when using ImGearThumbnailList control created on the client side. Note: It is necessary for this property to be set when using server side controls.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectedPages Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectedPages Property
Gets a collection of currently selected pages.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectedPages() : ImGearPageCollection
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_selectedPages();
Remarks

This is a read only property. It is a collection of pages (ImGearPageCollection) that are currently selected. Note: This property can not be overwritten but pages can be added and removed from the collection. These are not copies of pages, they are the actual selected pages. If the ImGearThumbnailList control has the property in a single selection mode then you must first always remove the current selection and then add a new one otherwise an exception will be thrown.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

selectionMode Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : selectionMode Property
Gets or sets the selection behavior for the thumbnails in the ImGearThumbnailList control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectionMode() : {Any}
function set_selectionMode(value : {Any})
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_selectionMode();
Remarks

This property defines the selection behavior in the ImGearThumbnailList control. For the various options, refer to ImGearThumbnailSelectionMode. If you change the value of this property, the control will raise its propertyChanged event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailBackgroundColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailBackgroundColor Property
Gets or sets the background color for the thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailBackgroundColor() : Integer
function set_thumbnailBackgroundColor(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailBackgroundColor();
Remarks

This property gets or sets the background color for the thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailBorderColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailBorderColor Property
Gets or sets the for the border color for thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailBorderColor() : String
function set_thumbnailBorderColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailBorderColor();
Remarks

This property gets or sets the border color for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailBorderWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailBorderWidth Property
Gets or sets the for the border width in pixel units for thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailBorderWidth() : Integer
function set_thumbnailBorderWidth(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailBorderWidth();
Remarks

This property gets or sets the border width in pixel units for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailCaptionFormat Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailCaptionFormat Property
Gets or sets the string format for thumbnail caption for all the thumbnails in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailCaptionFormat() : Boolean
function set_thumbnailCaptionFormat(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailCaptionFormat();
Remarks

This property gets or sets the string format for thumbnail caption for all the thumbnails in the control. The custom formatting supports templated caption. The string will be parsed with the following characters to mean as in the following list. Note: The internal parser expects the characters to be encased within {}. To specify a single literal brace character in the format, specify two opening or closing braces. This follows .NET rules for escaping curly braces.

  • DC - Document Caption: Defined by 'caption' property in the ImGearDocument class.
  • PC - Page Caption: Defined by the page 'caption' property of the ImageGear.Web.UI.ImGearPage' class.
  • P# - Page Index: Defined by the page index in the ImGearPageCollection contained in the ImGearDocument class (Note: The displayed index will be incremented by one since the index is zero based)
  • PN - Page Number: Defined by the pageNumber property of the ImageGear.Web.UI.ImGearPage' class (Note: The displayed index will be incremented by one since the page number is zero based)
  • PP - Page Count: Defined by the total number of pages in the ImGearPageCollection contained in the ImGearDocument class.

Example:

Property value = "Title-{DC}:{PC} {P#} of {PP}"

The resulting caption for thumbnails will be like:

"Title-MyImage.tif:Claims Page 1 of 150"

Property value = "{DC}:Page {P#}"

The resulting caption for thumbnails will be:

"MyImage.tif:Page 1"

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailHeight Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailHeight Property
Gets or sets the height for thumbnails in pixel units for thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailHeight() : Integer
function set_thumbnailHeight(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailHeight();
Remarks

This property gets or sets the height in pixel units for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailSelectedBackgroundColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailSelectedBackgroundColor Property
Gets or sets the background color for the selected thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailSelectedBackgroundColor() : Integer
function set_thumbnailSelectedBackgroundColor(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailSelectedBackgroundColor();
Remarks

This property gets or sets the background color for the selected thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

thumbnailWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : thumbnailWidth Property
Gets or sets the width for thumbnails in pixel units for thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_thumbnailWidth() : Integer
function set_thumbnailWidth(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_thumbnailWidth();
Remarks

This property gets or sets the width in pixel units for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

useDefaultStyling Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : useDefaultStyling Property
Gets or sets the default visual style for the thumbnails and their contents.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_useDefaultStyling() : Boolean
function set_useDefaultStyling(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_useDefaultStyling();
Remarks

When this property is set to a value of 'false', it means the default style for the thumbnails and its contents is not required. Under this condition, your web page containing the ImGearThumbnailList control must include a CSS file that contains definitions for the following named CSS classes:

  • .imGearTNItem, .imGearTNSelected

    In this example, the CSS class group defines the common property styles for the thumbnails that are in "unselected" and "selected" states. Alternatively, you can define two separate CSS classes, .imGearTNItem and .imGearTNSelected. Each containing all the properties that you want them to contain. The end result is the same.

    Example:

    .imGearTNItem, .imGearTNSelected

    {

    width:100px;

    height:160px;

    background-color:gray;

    float:left;

    overflow: hidden;

    border: 1px solid black;

    margin: 2px;

    }
  • .ImGearTNSelected

    This CSS class defines the background for the thumbnail items in the selected state.

    Example:

    .imGearTNSelected strong>

    {

    background-color:#ffBB00;

    }
  • .imGearTNItemCaption

    In this example, the CSS class defines details for thumbnail items caption.

    Example:

    .imGearTNItemCaption

    {

    left:0px;

    font-family: arial,sans-serif;font-size:8pt;text-align: center;

    font-size: 16px;

    top:20px;

    width:100px;

    height:20px;

    }
  • .imGearTNImage

    This CSS class defines thumbnail image style.

    Example:

    .imGearTNImage

    {

    width:120px;

    height:100px;

    position:relative;

    overflow: hidden;

    margin: 2px;

    }
  • .imGearTNItem:Hover

    This CSS class defines thumbnail item style when mouse hovers over it.

    Example:

    .imGearTNItem:Hover

    {

    border:2px solid #ffBB00;

    }

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

xSpacing Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : xSpacing Property
Gets or sets the amount of horizontal space between thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_xSpacing() : Integer
function set_xSpacing(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_xSpacing();
Remarks

This property gets or sets the border color for thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

ySpacing Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : ySpacing Property
Gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_ySpacing() : Integer
function set_ySpacing(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfImGearThumbnailList.get_ySpacing();
Remarks

This property gets or sets the amount of vertical space in pixel units between thumbnails displayed in the control. Note: This property is only relevant when choosing the default mode control style with the useDefaultStyling set to true;

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%% $$Events$$

ImGearThumbnailList class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailList class

For a list of all members of this type, see ImGearThumbnailList members.

Public Events
 | Name | Description
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageAddFailed | Indicates that a page failed to load in a thumbnail.
public Event | pageSelectionChanged | Indicates the thumbnail displaying a page was selected or unselected.
public Event | propertyChanged | Indicates that a property of this ImGearThumbnailList changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

mouseDown Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : mouseDown Event
Indicates the user pressed a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseDown(handler : Function)
function remove_mouseDown(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseDown(handler);
.remove_mouseDown(handler);
Remarks

The ImGearThumbnailList will raise this event whenever the user presses a mouse button while the cursor is over any part of the ImGearThumbnailList control (except the scrollbars).

The event argument is an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

mouseMove Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : mouseMove Event
Indicates the user moved the mouse.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseMove(handler : Function)
function remove_mouseMove(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseMove(handler);
.remove_mouseMove(handler);
Remarks

The viewer will raise this event whenever the user moves the mouse over any part of the viewer (except the scrollbars).

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

mouseUp Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : mouseUp Event
Indicates the user released a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseUp(handler : Function)
function remove_mouseUp(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseUp(handler);
.remove_mouseUp(handler);
Remarks

The ImGearThumbnailList control will raise this event whenever the user releases a mouse button while the cursor is over any part of the ImGearThumbnailList control (except the scrollbars).

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

pageAddFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : pageAddFailed Event
Indicates that a page failed to load in a thumbnail.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageAddFailed(handler : Function)
function remove_pageAddFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageAddFailed(handler);
.remove_pageAddFailed(handler);
Remarks

The ImGearThumbnailList control will raise this event whenever a page fails to load in a thumbnail.

Normally, the ImgearThumbnailList will raise this event wehn a page fails to load in a a thumbnail.

When the ImGearThumbnailList raises this event, it will provide an instance of an exception object ImGearPageOpenFailedEventArgs as the event argument. This object contains an exception object whhich may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

pageSelectionChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : pageSelectionChanged Event
Indicates the thumbnail displaying a page was selected or unselected.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageSelectionChanged(handler : Function)
function remove_pageSelectionChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageSelectionChanged(handler);
.remove_pageSelectionChanged(handler);
Remarks

The ImGearThumbnailList control will raise this event whenever the user selects or de-selects thumbnails.

There is no event argument. The newly selected pages can be obtained from the property selectedPages

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

propertyChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList : propertyChanged Event
Indicates that a property of this ImGearThumbnailList changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_propertyChanged(handler : Function)
function remove_propertyChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_propertyChanged(handler);
.remove_propertyChanged(handler);
Remarks

The object will raise this event whenever any property of the object is changed.

When the ImGearThumbnailList raises this event, it will provide the name of the changed property as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ImGearThumbnailList
ImGearThumbnailList Members


%%PageItemTitle%%

LogItem class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItem class
The arguments passed to an onImageGearItemLogged function.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.LogItem = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.LogItem();
Remarks
Whenever an ImageGear control calls the onImageGearItemLogged function, it will pass an object of this type to hold the log arguments. See the PageView.debug and ImageGear.Web.UI.ThumbnailView.debug properties for instructions on setting up client-side logging.
Inheritance Hierarchy

Object
ImageGear.Web.UI.LogItem

See Also

Reference

LogItem Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

LogItem class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItem class

The following tables list the members exposed by LogItem.

Public Constructors
 | Name | Description
public Constructor | LogItem Constructor |
Top
Public Fields
 | Name | Description
public Field | cause | The cause of the logged item.
public Field | id | The client ID of the control that issued the log entry.
public Field | level | The debug level of the logged item.
public Field | message | The text of the log entry.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

LogItem Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem : LogItem Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.LogItem = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.LogItem();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
LogItem Members


%%PageItemTitle%% $$Fields$$

LogItem class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItem class

For a list of all members of this type, see LogItem members.

Public Fields
 | Name | Description
public Field | cause | The cause of the logged item.
public Field | id | The client ID of the control that issued the log entry.
public Field | level | The debug level of the logged item.
public Field | message | The text of the log entry.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

cause Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem : cause Field
The cause of the logged item.
Syntax
ASP.NET Ajax Javascript (Specification)
var cause : DebugItemCause;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItem.cause;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
LogItem Members


%%PageItemTitle%%

id Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem : id Field
The client ID of the control that issued the log entry.
Syntax
ASP.NET Ajax Javascript (Specification)
var id : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItem.id;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
LogItem Members


%%PageItemTitle%%

level Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem : level Field
The debug level of the logged item.
Syntax
ASP.NET Ajax Javascript (Specification)
var level : ImageGear.Web.UI.DebugErrorLevel(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItem.level;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
LogItem Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem : message Field
The text of the log entry.
Syntax
ASP.NET Ajax Javascript (Specification)
var message : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItem.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItem
LogItem Members


%%PageItemTitle%%

LogItemEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItemEventArgs class
The arguments passed to an onImageGearItemLogged function.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.LogItemEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.LogItemEventArgs();
Remarks
Whenever an ImageGear control calls the onImageGearItemLogged function, it will pass an object of this type to hold the log arguments. See the PageView.debug and ImageGear.Web.UI.ThumbnailView.debug properties for instructions on setting up client-side logging.
Inheritance Hierarchy

Object
ImageGear.Web.UI.LogItemEventArgs

See Also

Reference

LogItemEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

LogItemEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItemEventArgs class

The following tables list the members exposed by LogItemEventArgs.

Public Constructors
 | Name | Description
public Constructor | LogItemEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | cause | The cause of the logged item.
public Field | id | The client ID of the control that issued the log entry.
public Field | level | The debug level of the logged item.
public Field | message | The text of the log entry.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

LogItemEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs : LogItemEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.LogItemEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.LogItemEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
LogItemEventArgs Members


%%PageItemTitle%% $$Fields$$

LogItemEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LogItemEventArgs class

For a list of all members of this type, see LogItemEventArgs members.

Public Fields
 | Name | Description
public Field | cause | The cause of the logged item.
public Field | id | The client ID of the control that issued the log entry.
public Field | level | The debug level of the logged item.
public Field | message | The text of the log entry.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

cause Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs : cause Field
The cause of the logged item.
Syntax
ASP.NET Ajax Javascript (Specification)
var cause : DebugItemCause;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItemEventArgs.cause;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
LogItemEventArgs Members


%%PageItemTitle%%

id Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs : id Field
The client ID of the control that issued the log entry.
Syntax
ASP.NET Ajax Javascript (Specification)
var id : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItemEventArgs.id;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
LogItemEventArgs Members


%%PageItemTitle%%

level Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs : level Field
The debug level of the logged item.
Syntax
ASP.NET Ajax Javascript (Specification)
var level : ImageGear.Web.UI.DebugErrorLevel(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItemEventArgs.level;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
LogItemEventArgs Members


%%PageItemTitle%%

message Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs : message Field
The text of the log entry.
Syntax
ASP.NET Ajax Javascript (Specification)
var message : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfLogItemEventArgs.message;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.LogItemEventArgs
LogItemEventArgs Members


%%PageItemTitle%%

Mark class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Mark class
An individual mark.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Mark = function(
   type : MarkType
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Mark();
Remarks

This object represents an individual mark. All marks that you wish ImageGear to draw on a page must be contained in an object of this type. You may also use a Mark object to represent a mark that is not associated with a specific page.

Unlike NotateXpress and the .NET portion of ImageGear, all mark types are represented by this single class. When you create an instance of this class, you must specify the type of the mark and it cannot be changed after that point. This class has many properties, but only a subset of them will be valid for any given mark type. If you try to read or write the properties that are not valid for the mark's type, this object will throw an exception. The table at the bottom of this topic shows which properties are valid for each mark type.

If this mark is associated with a PageView control (via an ArtPage), that control will automatically redraw itself whenever you change a property of this object. To improve performance, the control will schedule that redraw for a time when the browser is idle. If you wish to redraw the control immediately, call the control's PageView.display function. The same behavior applies to marks that are associated with a ThumbnailView control and you can call the ThumbnailView.display function to redraw immediately.

Any specific instance of this type can only be associated with one ArtPage at a time. If you try to associate a mark with two different ArtPage objects at the same time, the second association will throw an exception. This behavior eliminates the most common usage errors that could arise if a mark could be associated with multiple ArtPage objects at the same time.

This table shows which properties are valid for each type of Mark.

Property | Line | Polyline | Rectangle | Ellipse | Polygon | Text
artPage | Y | Y | Y | Y | Y | Y
boundingRectangle | Y | Y | Y | Y | Y | Y
calloutLineColor | N | N | N | N | N | Y
calloutLineIsDistinct | N | N | N | N | N | Y
calloutLineStyle | N | N | N | N | N | Y
calloutLineWidth | N | N | N | N | N | Y
calloutPoint | N | N | N | N | N | Y
calloutType | N | N | N | N | N | Y
calloutVisible | N | N | N | N | N | Y
endHeadAngle | Y | Y | N | N | N | N
endHeadLength | Y | Y | N | N | N | N
endHeadType | Y | Y | N | N | N | N
fillColor | N | N | Y | Y | Y | Y
fillVisible | N | N | Y | Y | Y | Y
fontName | N | N | N | N | N | Y
fontSize | N | N | N | N | N | Y
fontStyle | N | N | N | N | N | Y
headFillColor | Y | Y | N | N | N | N
isClosed | N | Y | N | N | N | N
lineColor | Y | Y | Y | Y | Y | Y
lineStyle | Y | Y | Y | Y | Y | Y
lineVisible | N | N | Y | Y | Y | Y
lineWidth | Y | Y | Y | Y | Y | Y
opacity | Y | Y | Y | Y | Y | Y
points | Y | Y | N | N | Y | N
rectangle | N | N | Y | Y | N | Y
startHeadAngle | Y | Y | N | N | N | N
startHeadLength | Y | Y | N | N | N | N
startHeadType | Y | Y | N | N | N | N
text | N | N | N | N | N | Y
textColor | N | N | N | N | N | Y
textHorizontalAlignment | N | N | N | N | N | Y
textOpacity | N | N | N | N | N | Y
textOrientation | N | N | N | N | N | Y
textVerticalAlignment | N | N | N | N | N | Y
fillRule | N | N | N | N | Y | N
type | Y | Y | Y | Y | Y | Y
visible | Y | Y | Y | Y | Y | Y

Inheritance Hierarchy

Object
ImageGear.Web.UI.Mark

See Also

Reference

Mark Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

Mark class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Mark class

The following tables list the members exposed by Mark.

Public Constructors
 | Name | Description
public Constructor | Mark Constructor |
Top
Public Properties
 | Name | Description
public Property | artPage | The ArtPage with which this mark is associated (if any).
public Property | boundingRectangle | The smallest rectangle that fully contains this mark.
public Property | calloutLineColor | The color of the outline drawn for text callouts.
public Property | calloutLineIsDistinct | Specifies whether the callout has an outline that is distinct from the outline of the text mark.
public Property | calloutLineStyle | The style of the outline drawn for text callouts.
public Property | calloutLineWidth | Specifies the thickness of a callout's border line.
public Property | calloutPoint | Specifies the end point of the callout.
public Property | calloutType | Specifies the end point of the callout.
public Property | calloutVisible | Specifies that a callout is visible.
public Property | endHeadAngle | Specifies the angle between a line and the edge of an arrowhead.
public Property | endHeadLength | Specifies the length of the line that forms an arrowhead on the end of a line.
public Property | endHeadType | Specifies the type of shape or arrowhead drawn on the end of a line.
public Property | fillColor | Specifies the color to use for the interior of marks.
public Property | fillRule | Specifies the fill rule of polygon mark.
public Property | fillVisible | Specifies whether a mark is filled.
public Property | fontName | Specifies the font to use for text marks.
public Property | fontSize | Specifies the font size to use for text marks.
public Property | fontStyle | Specifies the font characteristics to use for text marks.
public Property | headFillColor | Specifies the color of shapes or arrowheads drawn on the ends of a line.
public Property | isClosed |
public Property | lineColor | Specifies the color to use for lines and borders of marks.
public Property | lineStyle | Specifies the style to use for lines and borders of marks.
public Property | lineVisible | Specifies whether a mark has a border line.
public Property | lineWidth | Specifies the thickness of lines and borders of marks.
public Property | opacity | Specifies the opacity to use for marks.
public Property | points |
public Property | rectangle | The smallest rectangle that fully contains this mark.
public Property | selected |
public Property | startHeadAngle | Specifies the angle between a line and the edge of an arrowhead at the start of a line.
public Property | startHeadLength | Specifies the length of the line that forms an arrowhead at the start of a line.
public Property | startHeadType | Specifies the type of shape or arrowhead drawn at the start of a line.
public Property | text | Specifies the text to display in a text mark.
public Property | textColor | Specifies the color of text in a text mark.
public Property | textHorizontalAlignment | Specifies the horizontal alignment of text in a text mark.
public Property | textOpacity | Specifies the opacity of text in a text mark.
public Property | textOrientation | Specifies the orientation of text in a text mark.
public Property | textVerticalAlignment | Specifies the vertical alignment of text in a text mark.
public Property | type | Specifies the type of a mark.
public Property | visible | Specifies whether a mark is visible.
Top
Public Methods
 | Name | Description
public Method | move | Changes the position of the mark.
public Method | moveBackward | Moves the mark one slot toward the bottom of the Z-order.
public Method | moveForward | Moves the mark one slot toward the top of the Z-order.
public Method | moveToBack | Moves the mark to the bottom of the Z-order.
public Method | moveToFront | Moves the mark to the top of the Z-order.
public Method | removeFromPage | Removes the mark from its ArtPage.
Top
Public Events
 | Name | Description
public Event | propertyChanged | Indicates that a property of this mark changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

Mark Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : Mark Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Mark = function(
   type : MarkType
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Mark(MarkType);

Parameters

type
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%% $$Methods$$

Mark class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Mark class

For a list of all members of this type, see Mark members.

Public Methods
 | Name | Description
public Method | move | Changes the position of the mark.
public Method | moveBackward | Moves the mark one slot toward the bottom of the Z-order.
public Method | moveForward | Moves the mark one slot toward the top of the Z-order.
public Method | moveToBack | Moves the mark to the bottom of the Z-order.
public Method | moveToFront | Moves the mark to the top of the Z-order.
public Method | removeFromPage | Removes the mark from its ArtPage.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

move Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : move Method
Changes the position of the mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function move(
   deltaX : number,
   deltaY : number
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.move(number,number);

Parameters

deltaX
The distance (in page coordinates) to move the mark to the right. Negative numbers move the mark to the left.
deltaY
The distance (in page coordinates) to move the mark down. Negative numbers move the mark up.
Remarks

This function changes the position of the mark by the given amounts. Positive numbers move the mark to the right or down and negative numbers move to the left or up.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

moveBackward Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : moveBackward Method
Moves the mark one slot toward the bottom of the Z-order.
Syntax
ASP.NET Ajax Javascript (Specification)
function moveBackward() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.moveBackward();
Remarks

This function moves the mark one slot toward the bottom of the Z-order. When they overlap, marks that are higher in the Z-order are drawn over marks that are lower. You can use ArtPage.reorderMark for the same purpose, but this function is often more convenient.

Because the ordering is stored in an ArtPage, you can only reorder a mark when it is associated with an ArtPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

moveForward Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : moveForward Method
Moves the mark one slot toward the top of the Z-order.
Syntax
ASP.NET Ajax Javascript (Specification)
function moveForward() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.moveForward();
Remarks

This function moves the mark one slot toward the top of the Z-order. When they overlap, marks that are higher in the Z-order are drawn over marks that are lower. You can use ArtPage.reorderMark for the same purpose, but this function is often more convenient.

Because the ordering is stored in an ArtPage, you can only reorder a mark when it is associated with an ArtPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

moveToBack Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : moveToBack Method
Moves the mark to the bottom of the Z-order.
Syntax
ASP.NET Ajax Javascript (Specification)
function moveToBack() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.moveToBack();
Remarks

This function moves the mark to the bottom of the Z-order. When they overlap, marks that are higher in the Z-order are drawn over marks that are lower. You can use ArtPage.reorderMark for the same purpose, but this function is often more convenient.

Because the ordering is stored in an ArtPage, you can only reorder a mark when it is associated with an ArtPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

moveToFront Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : moveToFront Method
Moves the mark to the top of the Z-order.
Syntax
ASP.NET Ajax Javascript (Specification)
function moveToFront() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.moveToFront();
Remarks

This function moves the mark to the top of the Z-order. When they overlap, marks that are higher in the Z-order are drawn over marks that are lower. You can use ArtPage.reorderMark for the same purpose, but this function is often more convenient.

Because the ordering is stored in an ArtPage, you can only reorder a mark when it is associated with an ArtPage.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

removeFromPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : removeFromPage Method
Removes the mark from its ArtPage.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeFromPage() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.removeFromPage();
Remarks

This function removes the mark from its ArtPage. If the mark is not currently part of an ArtPage, this function will do nothing. You can use ArtPage.removeMark for the same purpose, but this function is often more convenient.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%% $$Properties$$

Mark class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Mark class

For a list of all members of this type, see Mark members.

Public Properties
 | Name | Description
public Property | artPage | The ArtPage with which this mark is associated (if any).
public Property | boundingRectangle | The smallest rectangle that fully contains this mark.
public Property | calloutLineColor | The color of the outline drawn for text callouts.
public Property | calloutLineIsDistinct | Specifies whether the callout has an outline that is distinct from the outline of the text mark.
public Property | calloutLineStyle | The style of the outline drawn for text callouts.
public Property | calloutLineWidth | Specifies the thickness of a callout's border line.
public Property | calloutPoint | Specifies the end point of the callout.
public Property | calloutType | Specifies the end point of the callout.
public Property | calloutVisible | Specifies that a callout is visible.
public Property | endHeadAngle | Specifies the angle between a line and the edge of an arrowhead.
public Property | endHeadLength | Specifies the length of the line that forms an arrowhead on the end of a line.
public Property | endHeadType | Specifies the type of shape or arrowhead drawn on the end of a line.
public Property | fillColor | Specifies the color to use for the interior of marks.
public Property | fillRule | Specifies the fill rule of polygon mark.
public Property | fillVisible | Specifies whether a mark is filled.
public Property | fontName | Specifies the font to use for text marks.
public Property | fontSize | Specifies the font size to use for text marks.
public Property | fontStyle | Specifies the font characteristics to use for text marks.
public Property | headFillColor | Specifies the color of shapes or arrowheads drawn on the ends of a line.
public Property | isClosed |
public Property | lineColor | Specifies the color to use for lines and borders of marks.
public Property | lineStyle | Specifies the style to use for lines and borders of marks.
public Property | lineVisible | Specifies whether a mark has a border line.
public Property | lineWidth | Specifies the thickness of lines and borders of marks.
public Property | opacity | Specifies the opacity to use for marks.
public Property | points |
public Property | rectangle | The smallest rectangle that fully contains this mark.
public Property | selected |
public Property | startHeadAngle | Specifies the angle between a line and the edge of an arrowhead at the start of a line.
public Property | startHeadLength | Specifies the length of the line that forms an arrowhead at the start of a line.
public Property | startHeadType | Specifies the type of shape or arrowhead drawn at the start of a line.
public Property | text | Specifies the text to display in a text mark.
public Property | textColor | Specifies the color of text in a text mark.
public Property | textHorizontalAlignment | Specifies the horizontal alignment of text in a text mark.
public Property | textOpacity | Specifies the opacity of text in a text mark.
public Property | textOrientation | Specifies the orientation of text in a text mark.
public Property | textVerticalAlignment | Specifies the vertical alignment of text in a text mark.
public Property | type | Specifies the type of a mark.
public Property | visible | Specifies whether a mark is visible.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPage Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : artPage Property
The ArtPage with which this mark is associated (if any).
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artPage() : ArtPage
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_artPage();
Remarks

This property holds a reference to the ArtPage with which this mark is associated. If this mark is not associated with an ArtPage, the value of this property will be undefined. If you change the value of this property, this object will raise its propertyChanged event.

A mark can only be associated with a single ArtPage at a time. You can move a mark from one ArtPage to another by first removing it from the current ArtPage, then associating it with the new one using ArtPage.addMark.

You can disconnect this mark from its ArtPage by calling either the removeFromPage or ArtPage.removeMark function.

Mark types: This property is valid for all mark types.
Valid values: any ArtPage or undefined
Default value: undefined

ImageGear for .NET name: N/A
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

boundingRectangle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : boundingRectangle Property
The smallest rectangle that fully contains this mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_boundingRectangle() : Rectangle
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_boundingRectangle();
Remarks

This read-only property contains the smallest rectangle that fully contains this mark. For marks that are rectangular in nature (Rectangle, Ellipse, and Text), there is a similar property called rectangle that is writeable.

Mark types: This property is valid for all mark types. ImageGear for .NET name: Bounds

NotateXpress (version 10) name: BoundingRectangle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutLineColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutLineColor Property
The color of the outline drawn for text callouts.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutLineColor() : String
function set_calloutLineColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutLineColor();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the color of the line drawn as part of a callout on a text mark. If calloutLineIsDistinct or calloutVisible are false, this property will have no effect on the visual appearance of the mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose callout is a dark yellow line.

Mark types: This property is valid for Text marks.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: '#000000'

ImageGear for .NET name: Callout.Line.Color
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutLineIsDistinct Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutLineIsDistinct Property
Specifies whether the callout has an outline that is distinct from the outline of the text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutLineIsDistinct() : Boolean
function set_calloutLineIsDistinct(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutLineIsDistinct();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies whether the callout has an outline that is distinct from the outline of the text mark. If this property is false, the viewer will use the lineColor and lineStyle properties instead of calloutLineColor and calloutLineStyle. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark with a callout whose outline is distinct from the outline of the rest of the text mark.

Mark types: This property is valid for Text marks.
Valid values: true or false
Default value: false

ImageGear for .NET name: Callout.Line
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutLineStyle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutLineStyle Property
The style of the outline drawn for text callouts.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutLineStyle() : LineStyle
function set_calloutLineStyle(value : LineStyle)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutLineStyle();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the style of the line drawn as part of a callout on a text mark. If calloutLineIsDistinct or calloutVisible are false, this property will have no effect on the visual appearance of the mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose callout is a dashed line.

Mark types: This property is valid for Text marks.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: ImageGear.Web.UI.LineStyle.Solid

ImageGear for .NET name: Callout.Line.Style
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutLineWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutLineWidth Property
Specifies the thickness of a callout's border line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutLineWidth() : Number
function set_calloutLineWidth(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutLineWidth();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the thickness of a callout's border line. If calloutLineIsDistinct or calloutVisible are false, this property will have no effect on the visual appearance of the mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose callout has an outline that is thinner than the rest of the mark.

Mark types: This property is valid for Text marks.
Valid values: a number between 0 to 50 (inclusive). If you set this property to 0, the line may not be visible.
Default value: 1

ImageGear for .NET name: Callout.Border.Width
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutPoint Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutPoint Property
Specifies the end point of the callout.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutPoint() : Point
function set_calloutPoint(value : Point)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutPoint();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 200, y: 50, width: 100, height: 200 });
mark.set_text('This text mark has a callout.');
mark.set_textOrientation(ImageGear.Web.UI.Orientation.RightTop);
mark.set_lineWidth(2);
mark.set_fillColor('#a0e0f0');
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Triangle);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(-25, 175));

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the location (in relation to the top left corner of the mark, not the page) of the end point of the callout. If calloutVisible is false, this property will have no effect on the visual appearance of the mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark with a callout whose point is to the left of the body of the mark.

Mark types: This property is valid for Text marks.
Valid values: Any ImageGear.Web.UI.Point object.
Default value: new ImageGear.Web.UI.Point(0, 0)

ImageGear for .NET name: Callout.X and Callout.Y
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutType Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutType Property
Specifies the end point of the callout.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutType() : Point
function set_calloutType(value : Point)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutType();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 200, y: 50, width: 100, height: 200 });
mark.set_text('This text mark has a callout.');
mark.set_textOrientation(ImageGear.Web.UI.Orientation.RightTop);
mark.set_lineWidth(2);
mark.set_fillColor('#a0e0f0');
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Triangle);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(-25, 175));

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the location (in page coordinates) of the end point of the callout. If calloutVisible is false, this property will have no effect on the visual appearance of the mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose callout is shaped like a triangle.

Mark types: This property is valid for Text marks.
Valid values: Any member of the CalloutType enumeration.
Default value: ImageGear.Web.UI.CalloutType.Triangle

ImageGear for .NET name: Callout.Type
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

calloutVisible Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : calloutVisible Property
Specifies that a callout is visible.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_calloutVisible() : Point
function set_calloutVisible(value : Point)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_calloutVisible();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 200, y: 50, width: 100, height: 200 });
mark.set_text('This text mark has a callout.');
mark.set_textOrientation(ImageGear.Web.UI.Orientation.RightTop);
mark.set_lineWidth(2);
mark.set_fillColor('#a0e0f0');
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Triangle);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(-25, 175));

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies whether or not the callout is visible. If calloutVisible is false, the viewer will not draw a callout on the mark and the rest of the callout properties will have no effect. If you change the value of this property, this object will raise its propertyChanged event.

For convenience, if you change this property to true while the callout point is set to (0, 0), this function will also change the callout point to (width of mark, height of mark * 1.5). This makes it more obvious to an end user that the callout is now visible.

This figure shows a text mark with a callout.

Mark types: This property is valid for Text marks.
Valid values: true or false
Default value: false

ImageGear for .NET name: Callout
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

endHeadAngle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : endHeadAngle Property
Specifies the angle between a line and the edge of an arrowhead.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_endHeadAngle() : Number
function set_endHeadAngle(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_endHeadAngle();
Example

This JavaScript code will create the marks shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the angle (in degrees) between a line and the edge of an arrowhead. If endHeadType is set to None, then this property will have no effect. A similar property is available for the start of a line: startHeadAngle. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one does not have an arrowhead, so the end head angle is not important and the right one has an end head angle of 30 degrees.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Any number between 0 and 180, inclusive.
Default value: 15

ImageGear for .NET name: EndHeadAngle
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

endHeadLength Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : endHeadLength Property
Specifies the length of the line that forms an arrowhead on the end of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_endHeadLength() : Number
function set_endHeadLength(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_endHeadLength();
Example

This JavaScript code will create the marks shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the length of the line that forms an arrowhead on the end of a line. If endHeadType is set to None, then this property will have no effect. A similar property is available for the start of a line: startHeadLength. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one does not have an arrowhead, so the end head length is not important and the right one has an end head length of 35 image pixels.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Any number between 0 and 100, inclusive.
Default value: 25

ImageGear for .NET name: EndHeadLength
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

endHeadType Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : endHeadType Property
Specifies the type of shape or arrowhead drawn on the end of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_endHeadType() : LineHeadType
function set_endHeadType(value : LineHeadType)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_endHeadType();
Example

This JavaScript code will create the marks shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the type of shape or arrowhead drawn on the end of a line. A similar property is available for the start of a line: startHeadType. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one does not have an arrowhead and the right one has an end head type of Pointer.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Some members of the LineHeadType enumeration.
Default value: ImageGear.Web.UI.LineHeadType.None

ImageGear for .NET name: EndHeadType
NotateXpress (version 10) name: EndPointStyle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fillColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fillColor Property
Specifies the color to use for the interior of marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fillColor() : String
function set_fillColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fillColor();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 200, y: 50, width: 100, height: 200 });
mark.set_text('This text mark has a callout.');
mark.set_textOrientation(ImageGear.Web.UI.Orientation.RightTop);
mark.set_lineWidth(2);
mark.set_fillColor('#a0e0f0');
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Triangle);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(-25, 175));

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the color to use for the interior of marks. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark with a light blue fill color.

Mark types: This property is valid for Rectangle, Ellipse, Polygon, and Text marks.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: '#c0c0c0'

ImageGear for .NET name: FillColor
NotateXpress (version 10) name: FillColor (for Rectangle, Ellipse, and Polygon marks) and BackColor (for Text marks).

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fillRule Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fillRule Property
Specifies the fill rule of polygon mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fillRule() : FillRule
function set_fillRule(value : FillRule)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fillRule();
Example

This JavaScript code will create the polygon mark with fillRule property is ImageGear.Web.UI.FillRule.NonZero.

var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Polygon);

// Set various properties.
var points = mark.get_points();
points.addPoint({ x: 250, y: 75 });
points.addPoint({ x: 323, y: 301 });
points.addPoint({ x: 131, y: 161 });
points.addPoint({ x: 369, y: 161 });
points.addPoint({ x: 177, y: 301 });
mark.set_fillColor('#a0e0f0');
mark.set_fillRule(ImageGear.Web.UI.FillRule.NonZero);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the fill rule of polygon mark. You can select one of two ways of polygon mark fill.

ImageGear.Web.UI.FillRule.EvenOdd value determines the "insideness" of a point on the canvas by drawing a ray from that point to infinity in any direction and counting the number of path segments from the given shape that the ray crosses. If this number is odd, the point is inside; if even, the point is outside.

ImageGear.Web.UI.FillRule.NonZero value determines the "insideness" of a point on the canvas by drawing a ray from that point to infinity in any direction and then examining the places where a segment of the shape crosses the ray. Starting with a count of zero, add one each time a path segment crosses the ray from left to right and subtract one each time a path segment crosses the ray from right to left. After counting the crossings, if the result is zero then the point is outside the path. Otherwise, it is inside.

Mark types: This property is valid for Polygon marks.
Valid values: Any member of the FillRule enumeration.
Default value: ImageGear.Web.UI.FillRule.EvenOdd (value is 0)

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fillVisible Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fillVisible Property
Specifies whether a mark is filled.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fillVisible() : Boolean
function set_fillVisible(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fillVisible();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies whether or not a mark is filled. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark that is not filled.

Mark types: This property is valid for Rectangle, Ellipse, Polygon, and Text marks.
Valid values: true or false
Default value: true

ImageGear for .NET name: FillColor (null or not null)
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fontName Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fontName Property
Specifies the font to use for text marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fontName() : String
function set_fontName(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fontName();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the font to use for text marks. The normal HTML and CSS rules regarding substitution for unavailable fonts apply to this property. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose text is drawn in an Arial font.

Mark types: This property is valid for Text marks.
Valid values: Any CSS Font name.
Default value: 'Arial'

ImageGear for .NET name: FontName
NotateXpress (version 10) name: TextFont

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fontSize Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fontSize Property
Specifies the font size to use for text marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fontSize() : Number
function set_fontSize(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fontSize();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the font size (in points) to use for text marks. If you change the value of this property, this object will raise its propertyChanged event.

Note that ImageGear uses the resolution of the image to determine the size of a point so, for example, a line of 12 point text on a 300 DPI image will be 12 points / 72 point-per-inch * 300 pixels-per-inch = 50 pixels tall.

This figure shows a text mark whose text is drawn using a 14 point font.

Mark types: This property is valid for Text marks.
Valid values: Any number between 0.1 and 288 (inclusive).
Default value: 11.5

ImageGear for .NET name: FontSize
NotateXpress (version 10) name: TextFont

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

fontStyle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : fontStyle Property
Specifies the font characteristics to use for text marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_fontStyle() : FontStyle
function set_fontStyle(value : FontStyle)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_fontStyle();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the font characteristics (such as italics, bold, or underline) to use for text marks. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose text is underlined and italic.

Mark types: This property is valid for Text marks.
Valid values: Any member or combination of members of the FontStyle enumeration.
Default value: ImageGear.Web.UI.FontStyle.Regular

ImageGear for .NET name: FontStyleART
NotateXpress (version 10) name: TextFont

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

headFillColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : headFillColor Property
Specifies the color of shapes or arrowheads drawn on the ends of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_headFillColor() : String
function set_headFillColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_headFillColor();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the color of the shape or arrowhead drawn on the ends of a line. This property applies to both the start and end of a line. If startHeadType or endHeadType are set to None, then this property will have no effect on that end of the line. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one has a head fill color of lavender and the right one has a head fill color of black.

Mark types: This property is valid for Line and Polyline marks.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: '#000000'

ImageGear for .NET name: HeadFillColor
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

isClosed Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : isClosed Property
Syntax
ASP.NET Ajax Javascript (Specification)
function get_isClosed() : {Any}
function set_isClosed(value : {Any})
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_isClosed();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

lineColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : lineColor Property
Specifies the color to use for lines and borders of marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_lineColor() : String
function set_lineColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_lineColor();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the color to use for lines and borders of marks. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one has a line color of black and the right one has a line color of lavender.

Mark types: This property is valid for all mark types.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: '#000000'

ImageGear for .NET name: Color (for Line and Polyline marks) and Border.Color (for Rectangle, Ellipse, Polygon, and Text marks).
NotateXpress (version 10) name: PenColor

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

lineStyle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : lineStyle Property
Specifies the style to use for lines and borders of marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_lineStyle() : String
function set_lineStyle(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_lineStyle();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(125, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(250, 125));
mark.set_lineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Open);
mark.set_lineWidth(1);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the style to use for lines and borders of marks. If you change the value of this property, this object will raise its propertyChanged event. For line and polyline marks, this property will not affect the style of the arrowheads. Arrowheads that are drawn with lines (such as the Pointer and Open types), will always be drawn with a solid style.

This figure shows a line mark whose line is dashed.

Mark types: This property is valid for all mark types.
Valid values: Any member of the ImageGear.Web.UI.LineStyle enumeration
Default value: ImageGear.Web.UI.LineStyle.Solid

ImageGear for .NET name: Style (for Line and Polyline marks) and Border.Style (for Rectangle, Ellipse, Polygon, and Text marks).
NotateXpress (version 10) name: PenStyle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

lineVisible Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : lineVisible Property
Specifies whether a mark has a border line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_lineVisible() : Boolean
function set_lineVisible(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_lineVisible();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new ellipse mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Ellipse);

// Set various properties.
mark.set_rectangle({ x: 125, y: 150, width: 200, height: 125 });
mark.set_fillColor('#ff8080');
mark.set_opacity(127);
mark.set_lineVisible(false);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies whether or not a mark has a border line. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows an ellipse mark whose border is not visible.

Mark types: This property is valid for Rectangle, Ellipse, Polygon, and Text marks.
Valid values: true or false
Default value: true

ImageGear for .NET name: Border
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

lineWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : lineWidth Property
Specifies the thickness of lines and borders of marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_lineWidth() : String
function set_lineWidth(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_lineWidth();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the thickness of lines and borders of marks. If you change the value of this property, this object will raise its propertyChanged event. For line and polyline marks, arrowheads composed of lines (such as the Pointer and Open types), will be drawn with the width specified in this property.

This figure shows two lines; the left one has a thick line and the right one has a thin line.

Mark types: This property is valid for all mark types.
Valid values: a number between 0 to 50 (inclusive). If you set this property to 0, the line may not be visible.
Default value: 1

ImageGear for .NET name: Width (for Line and Polyline marks) and Border.Width (for Rectangle, Ellipse, Polygon, and Text marks).
NotateXpress (version 10) name: PenWidth

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

opacity Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : opacity Property
Specifies the opacity to use for marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_opacity() : Integer
function set_opacity(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_opacity();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new ellipse mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Ellipse);

// Set various properties.
mark.set_rectangle({ x: 125, y: 150, width: 200, height: 125 });
mark.set_fillColor('#ff8080');
mark.set_opacity(127);
mark.set_lineVisible(false);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the opacity to use for marks. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows an ellipse mark that is translucent.

Mark types: This property is valid for all mark types.
Valid values: Any value between 0 and 255 (inclusive). 0 indicates that the mark is transparent and 255 indicates that it is opaque.
Default value: 255

ImageGear for .NET name: Opacity
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

points Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : points Property
Syntax
ASP.NET Ajax Javascript (Specification)
function get_points() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_points();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

rectangle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : rectangle Property
The smallest rectangle that fully contains this mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_rectangle() : Rectangle
function set_rectangle(value : Rectangle)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_rectangle();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new ellipse mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Ellipse);

// Set various properties.
mark.set_rectangle({ x: 125, y: 150, width: 200, height: 125 });
mark.set_fillColor('#ff8080');
mark.set_opacity(127);
mark.set_lineVisible(false);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the bounding box of a Rectangle, Ellipse, or Text mark. For those marks, it will be identical to the read-only boundingRectangle property.

Note that if you provide a rectangle with a negative width or height, this function will silently shift the rectangle (left if width is negative and up if height is negative) and make the size positive.

This figure shows an ellipse mark whose location is defined using a rectangle.

Mark types: This property is valid for Rectangle, Ellipse, and Text mark types. Value values: any Rectangle Default value: new ImageGear.Web.UI.Rectangle(0, 0, 0, 0)

ImageGear for .NET name: Bounds NotateXpress (version 10) name: BoundingRectangle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

selected Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : selected Property
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selected() : {Any}
function set_selected(value : {Any})
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_selected();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

startHeadAngle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : startHeadAngle Property
Specifies the angle between a line and the edge of an arrowhead at the start of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_startHeadAngle() : Number
function set_startHeadAngle(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_startHeadAngle();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the angle (in degrees) between a line and the edge of an arrowhead at the start of a line. If startHeadType is set to None, then this property will have no effect. A similar property is available for the end of a line: endHeadAngle. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one has an start head angle of 45 degrees and the right one has an start head angle of 10 degrees.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Any number between 0 and 180, inclusive.
Default value: 15

ImageGear for .NET name: StartHeadAngle
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

startHeadLength Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : startHeadLength Property
Specifies the length of the line that forms an arrowhead at the start of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_startHeadLength() : Number
function set_startHeadLength(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_startHeadLength();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the length of the line that forms an arrowhead at the start of a line. If startHeadType is set to None, then this property will have no effect. A similar property is available for the end of a line: endHeadLength. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one has a start head length of 10 and the right one has a start head length of 35.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Any number between 0 and 100, inclusive.
Default value: 25

ImageGear for .NET name: StartHeadLength
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

startHeadType Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : startHeadType Property
Specifies the type of shape or arrowhead drawn at the start of a line.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_startHeadType() : LineHeadType
function set_startHeadType(value : LineHeadType)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_startHeadType();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new line mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
var points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(75, 175));
points.setPoint(1, new ImageGear.Web.UI.Point(175, 100));
mark.set_headFillColor('#7070ff');
mark.set_startHeadAngle(45);
mark.set_startHeadLength(10);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.Solid);
mark.set_lineWidth(3);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);

// Create a new line mark.
// Note that if you skip this step, you will overwrite the properties of the original mark and the second call to addMark() will do nothing because the mark is already associated with the ArtPage.
mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Line);

// Set various properties.
points = mark.get_points();
points.setPoint(0, new ImageGear.Web.UI.Point(100, 200));
points.setPoint(1, new ImageGear.Web.UI.Point(200, 125));
mark.set_lineColor('#a0a0ff');
mark.set_endHeadAngle(30);
mark.set_endHeadLength(25);
mark.set_endHeadType(ImageGear.Web.UI.LineHeadType.Pointer);
mark.set_startHeadAngle(10);
mark.set_startHeadLength(35);
mark.set_startHeadType(ImageGear.Web.UI.LineHeadType.PointerSolid);

// Add the mark to the page.
// Adding them after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the type of shape or arrowhead drawn at the start of a line. A similar property is available for the end of a line: endHeadType. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows two lines; the left one has a start head type of Solid and the right one has a start head type of PointerSolid.

Mark types: This property is valid for Line and Polyline marks.
Valid values: Any member of the LineHeadType enumeration.
Default value: ImageGear.Web.UI.LineHeadType.None

ImageGear for .NET name: StartHeadType
NotateXpress (version 10) name: StartPointStyle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

text Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : text Property
Specifies the text to display in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_text() : String
function set_text(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_text();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the text to display in a text mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark with two lines of text.

Mark types: This property is valid for Text marks.
Valid values: Any string.
Default value: A string containing no characters.

ImageGear for .NET name: Text, ActualText
NotateXpress (version 10) name: Text

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

textColor Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : textColor Property
Specifies the color of text in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_textColor() : String
function set_textColor(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_textColor();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the color of text in a text mark. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose text is light blue.

Mark types: This property is valid for Text marks.
Valid values: A 7-character string representing a color. The first letter must be a "#" symbol and the other six characters must be hexadecimal digits representing the red, green, and blue portions of the color. This is identical to one of the common ways to specify colors in HTML.
Default value: '#000000'

ImageGear for .NET name: TextColor
NotateXpress (version 10) name: TextColor

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

textHorizontalAlignment Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : textHorizontalAlignment Property
Specifies the horizontal alignment of text in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_textHorizontalAlignment() : HorizontalAlignment
function set_textHorizontalAlignment(value : HorizontalAlignment)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_textHorizontalAlignment();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 150, width: 275, height: 75 });
mark.set_text('This is a text mark.\nIt has two lines of text.');
mark.set_fontName('Arial');
mark.set_fontSize(14);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Underline | ImageGear.Web.UI.FontStyle.Italic);
mark.set_textHorizontalAlignment(ImageGear.Web.UI.HorizontalAlignment.Center);
mark.set_textColor('#7070ff');

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the horizontal alignment of text in a text mark. Note that text annotations can be rotated or mirrored using the textOrientation property and that orientation will affect the direction in which this property is applied. If you change the value of this property, this object will raise its propertyChanged event.

This figure shows a text mark whose text is centered.

Mark types: This property is valid for Text marks.
Valid values: Any member of the HorizontalAlignment enumeration.
Default value: ImageGear.Web.UI.HorizontalAlignment.Left

ImageGear for .NET name: AlignmentH
NotateXpress (version 10) name: TextJustification

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

textOpacity Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : textOpacity Property
Specifies the opacity of text in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_textOpacity() : Integer
function set_textOpacity(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_textOpacity();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 100, y: 200, width: 300, height: 150 });
mark.set_text('This text mark has a distinctly-styled callout.');
mark.set_lineWidth(6);
mark.set_fontSize(24);
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Line);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(275, 225));
mark.set_calloutLineIsDistinct(true);
mark.set_calloutLineWidth(4);
mark.set_calloutLineStyle(ImageGear.Web.UI.LineStyle.Dash);
mark.set_calloutLineColor('#b4b400');
mark.set_fillVisible(false);
mark.set_fontStyle(ImageGear.Web.UI.FontStyle.Bold);
mark.set_textOpacity(127);

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the opacity of text in a text mark. If you change the value of this property, this object will raise its propertyChanged event.

This property is related to opacity. The opacity property controls the opacity of the entire mark; where this property only affects the opacity of the text in the mark. If you set both values to something other than opaque (255), then both will reduce the opacity of the text and the effective opacity of the text will be the product of the two opacities, divided by 255.

This figure shows a text mark whose text is translucent.

Mark types: This property is valid for Text marks.
Valid values: Any number between 0 and 255 (inclusive).
Default value: 255

ImageGear for .NET name: TextOpacity
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

textOrientation Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : textOrientation Property
Specifies the orientation of text in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_textOrientation() : String
function set_textOrientation(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_textOrientation();
Example

This JavaScript code will create the mark shown in the image on this page.

// Create a new text mark.
var mark = new ImageGear.Web.UI.Mark(ImageGear.Web.UI.MarkType.Text);

// Set various properties.
mark.set_rectangle({ x: 200, y: 50, width: 100, height: 200 });
mark.set_text('This text mark has a callout.');
mark.set_textOrientation(ImageGear.Web.UI.Orientation.RightTop);
mark.set_lineWidth(2);
mark.set_fillColor('#a0e0f0');
mark.set_calloutVisible(true);
mark.set_calloutType(ImageGear.Web.UI.CalloutType.Triangle);
mark.set_calloutPoint(new ImageGear.Web.UI.Point(-25, 175));

// Add the mark to the page.
// Adding it after setting the properties avoids a lot of needless markChanged events.
$find('PageView1').get_artPage().addMark(mark);
Remarks

This property specifies the orientation of text in a text mark. You can rotate the text 90, 180, and 270 degrees, as well as flipping or mirroring the text. If you change the value of this property, this object will raise its propertyChanged event.

There are two distinctly different kinds of text orientation. This property controls the relative orientation between this mark and the image it is associated with. In addition, the PageView control is able to rotate, flip, and mirror the image along with its associated marks. That viewing orientation is applied to text marks, in addition to the orientation indicated by this property.

This figure shows a text mark whose text is rotated 90 degrees clockwise.

Mark types: This property is valid for Text marks.
Valid values: Any member of the Orientation enumeration.
Default value: ImageGear.Web.UI.Orientation.TopLeft

ImageGear for .NET name: Orientation
NotateXpress (version 10) name: TextOrientation

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

textVerticalAlignment Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : textVerticalAlignment Property
Specifies the vertical alignment of text in a text mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_textVerticalAlignment() : VerticalAlignment
function set_textVerticalAlignment(value : VerticalAlignment)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_textVerticalAlignment();
Remarks

This property specifies the vertical alignment of text in a text mark. Note that, due to browser limitations, text marks are drawn without regard for the value of this property. It is present in the API only so the value present in the original ART XML file will be retained. If you change the value of this property, this object will raise its propertyChanged event.

Mark types: This property is valid for Text marks.
Valid values: Any member of the VerticalAlignment enumeration.
Default value: ImageGear.Web.UI.VerticalAlignment.Top

ImageGear for .NET name: AlignmentV
NotateXpress (version 10) name: N/A

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

type Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : type Property
Specifies the type of a mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_type() : MarkType
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_type();
Remarks

This read-only property specifies the type of a mark. Once you have created a mark, you cannot change its type. The only way to determine the type of a mark is to indicate the type as a paratemeter to the object's constructor.

Mark types: This property is valid for all mark types.
Valid values: Any member of the MarkType enumeration.

ImageGear for .NET name: Type
NotateXpress (version 10) name: N/A (Available via .NET's type system.)

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

visible Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : visible Property
Specifies whether a mark is visible.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_visible() : Boolean
function set_visible(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMark.get_visible();
Remarks

This property specifies whether a mark is visible. When this value is false, ImageGear will not draw the annotation with the image in a viewer. If you change the value of this property, this object will raise its propertyChanged event.

Mark types: This property is valid for all mark types.
Valid values: true or false
Default value: true

ImageGear for .NET name: Visible
NotateXpress (version 10) name: Visible

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%% $$Events$$

Mark class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Mark class

For a list of all members of this type, see Mark members.

Public Events
 | Name | Description
public Event | propertyChanged | Indicates that a property of this mark changed.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

propertyChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark : propertyChanged Event
Indicates that a property of this mark changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_propertyChanged(handler : Function)
function remove_propertyChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_propertyChanged(handler);
.remove_propertyChanged(handler);
Remarks

The object will raise this event whenever any property of the object is changed.

When the collection raises this event, it will provide the name of the changed property as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Mark
Mark Members


%%PageItemTitle%%

MarkCollection class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkCollection class
A collection of Mark objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MarkCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MarkCollection();
Remarks

This object is an unordered collection of Mark objects. It will raise events whenever a Mark object is added or removed.

This object is used primarily for the ArtPage.selectedMarks property, but is available for other uses as well.

Inheritance Hierarchy

Object
ImageGear.Web.UI.MarkCollection

See Also

Reference

MarkCollection Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

MarkCollection class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkCollection class

The following tables list the members exposed by MarkCollection.

Public Constructors
 | Name | Description
public Constructor | MarkCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | addMark | Adds a mark to the collection.
public Method | addMarks | Appends a collection of marks to the collection.
public Method | contains | Indicates whether the collection contains the given mark.
public Method | forEach | Calls the specified function once for each mark in the collection.
public Method | removeAllMarks | Removes all the marks from the collection.
public Method | removeMark | Removes one mark from the collection.
Top
Public Events
 | Name | Description
public Event | markAdded | Indicates that a new mark was added to the collection.
public Event | markRemoved | Indicates that a mark was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MarkCollection Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : MarkCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MarkCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MarkCollection();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%% $$Methods$$

MarkCollection class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkCollection class

For a list of all members of this type, see MarkCollection members.

Public Methods
 | Name | Description
public Method | addMark | Adds a mark to the collection.
public Method | addMarks | Appends a collection of marks to the collection.
public Method | contains | Indicates whether the collection contains the given mark.
public Method | forEach | Calls the specified function once for each mark in the collection.
public Method | removeAllMarks | Removes all the marks from the collection.
public Method | removeMark | Removes one mark from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

addMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : addMark Method
Adds a mark to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addMark(
   mark : Mark
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.addMark(Mark);

Parameters

mark
The mark to add to the collection.
Remarks

The function will add a mark to the the collection. If the mark is already present in the collection, this function will do nothing (and will not raise the markAdded event).

After this function has added the new mark to the collection, it will raise the markAdded event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

addMarks Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : addMarks Method
Appends a collection of marks to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addMarks(
   markCollection : MarkCollection
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.addMarks(MarkCollection);

Parameters

markCollection
The collections of marks to add to the collection.
Remarks

The function will add a collection of marks to the the collection. It is similar to the standard JavaScript Array.concat() function. If markCollection contains no marks that are not already in this collection, this function will do nothing and will not raise the markAdded event.

After this function has added all the new marks to the collection, it will raise the markAdded event. It will not provide a specific mark as part of the event, even if it only added one mark. This function will set ImageGear.Web.UI.PointEventArgs.length to the number of new marks added. Note that this may be different from the number of marks in markCollection if some of those marks were already present in this collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

contains Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : contains Method
Indicates whether the collection contains the given mark.
Syntax
ASP.NET Ajax Javascript (Specification)
function contains(
   mark : Mark
) : boolean;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.contains(Mark);

Parameters

mark
The mark to look for.

Return Value

true if the mark is in the collection, false otherwise.
Remarks

This function returns a boolean that indicates whether or not the collection contains the given mark.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

forEach Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : forEach Method
Calls the specified function once for each mark in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each mark in the collection. It is very similar to the ASP.NET Ajax Library, Array.forEach() function.

When forEach calls the function, it will set this to context, the first function parameter to the mark being enumerated, the second function parameter to the zero-based index of the iteration, and the third function parameter to the collection.

This function copies the list of marks before starting the enumeration, so you can safely make changes to the collection during the enumeration process. Any marks that you delete during the enumeration will be enumerated; any marks that you add during the enumeration will not be enumerated, and any marks that you change during the enumeration will be enumerated with their new value.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

removeAllMarks Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : removeAllMarks Method
Removes all the marks from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeAllMarks() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.removeAllMarks();
Remarks

This function removes all marks from the collection. If the collection contains no marks, this function will do nothing (and will not raise a markRemoved event).

After this function removes the marks, it will raise the markRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

removeMark Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : removeMark Method
Removes one mark from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeMark(
   mark : Mark
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.removeMark(Mark);

Parameters

mark
The mark to remove.
Remarks

This function removes a single mark from the collection. If the mark is not present in the collection, this function will do nothing (and will not raise a markRemoved event).

After this function removes the mark, it will raise the markRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%% $$Properties$$

MarkCollection class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkCollection class

For a list of all members of this type, see MarkCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkCollection.get_length();

Return Value

The number of marks in the collection.
Remarks

This function returns the number of marks that the collection contains. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%% $$Events$$

MarkCollection class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkCollection class

For a list of all members of this type, see MarkCollection members.

Public Events
 | Name | Description
public Event | markAdded | Indicates that a new mark was added to the collection.
public Event | markRemoved | Indicates that a mark was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

markAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : markAdded Event
Indicates that a new mark was added to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markAdded(handler : Function)
function remove_markAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markAdded(handler);
.remove_markAdded(handler);
Remarks

The collection will raise this event whenever a mark is added (as the result of a call to the addMark or addMarks functions). The object will raise this event after it has added the mark(s).

When the collection raises this event, it will provide a MarkEventArgs object as the event argument. When raised as a result of the addMark function, the event argument will have its ImageGear.Web.UI.MarkEventArgs.mark property set to the added mark. When raised as a result of the addMarks function, the event argument will not contain a ImageGear.Web.UI.MarkEventArgs.mark property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

markRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection : markRemoved Event
Indicates that a mark was removed from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markRemoved(handler : Function)
function remove_markRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markRemoved(handler);
.remove_markRemoved(handler);
Remarks

The collection will raise this event whenever a mark is removed (as the result of a call to the removeMark or removeAllMarks functions). The object will raise this event after it has removed the mark(s).

When the collection raises this event, it will provide a MarkEventArgs object as the event argument. When raised as a result of the removeMark function, the event argument will have its ImageGear.Web.UI.MarkEventArgs.mark property set to the removed mark. When raised as a result of the removeMarks function, the event argument will not contain a ImageGear.Web.UI.MarkEventArgs.mark property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkCollection
MarkCollection Members


%%PageItemTitle%%

MarkEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkEventArgs class
The arguments for mark events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MarkEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MarkEventArgs();
Remarks

This object contains the arguments for mark events. A MarkCollection will provide an instance of this object whenever it raises a MarkCollection.markAdded or MarkCollection.markRemoved event. An ArtPage will provide an instance of this object whenever it raises a ArtPage.markAdded, ArtPage.markChanged, ArtPage.markRemoved, or ArtPage.markReordered event.

Inheritance Hierarchy

Object
ImageGear.Web.UI.MarkEventArgs

See Also

Reference

MarkEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

MarkEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkEventArgs class

The following tables list the members exposed by MarkEventArgs.

Public Constructors
 | Name | Description
public Constructor | MarkEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | length | The number of marks that are affected by the event. In cases where this value is greater than one, the mark and zIndex properties will not be provided by the event.
public Field | mark | The mark which is most directly related to the event. Events that affect multiple marks will not provide a value for this property.
public Field | propertyName | The name of the property which changed. This is only valid for ArtPage.markChanged events.
public Field | zIndex | The Z-index of a reordered mark. For ArtPage.markReordered events, this will be the new Z-index of the mark that was reordered. For other events, it will be the Z-index of the mark which is most directly related to the event and events that affect multiple marks will not provide a value for this property. The MarkCollection object will never provide a value for this property because the marks in a MarkCollection have no particular order.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MarkEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs : MarkEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MarkEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MarkEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
MarkEventArgs Members


%%PageItemTitle%% $$Fields$$

MarkEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkEventArgs class

For a list of all members of this type, see MarkEventArgs members.

Public Fields
 | Name | Description
public Field | length | The number of marks that are affected by the event. In cases where this value is greater than one, the mark and zIndex properties will not be provided by the event.
public Field | mark | The mark which is most directly related to the event. Events that affect multiple marks will not provide a value for this property.
public Field | propertyName | The name of the property which changed. This is only valid for ArtPage.markChanged events.
public Field | zIndex | The Z-index of a reordered mark. For ArtPage.markReordered events, this will be the new Z-index of the mark that was reordered. For other events, it will be the Z-index of the mark which is most directly related to the event and events that affect multiple marks will not provide a value for this property. The MarkCollection object will never provide a value for this property because the marks in a MarkCollection have no particular order.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

length Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs : length Field
The number of marks that are affected by the event. In cases where this value is greater than one, the mark and zIndex properties will not be provided by the event.
Syntax
ASP.NET Ajax Javascript (Specification)
var length : Integer;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkEventArgs.length;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
MarkEventArgs Members


%%PageItemTitle%%

mark Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs : mark Field
The mark which is most directly related to the event. Events that affect multiple marks will not provide a value for this property.
Syntax
ASP.NET Ajax Javascript (Specification)
var mark : Mark;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkEventArgs.mark;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
MarkEventArgs Members


%%PageItemTitle%%

propertyName Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs : propertyName Field
The name of the property which changed. This is only valid for ArtPage.markChanged events.
Syntax
ASP.NET Ajax Javascript (Specification)
var propertyName : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkEventArgs.propertyName;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
MarkEventArgs Members


%%PageItemTitle%%

zIndex Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs : zIndex Field
The Z-index of a reordered mark. For ArtPage.markReordered events, this will be the new Z-index of the mark that was reordered. For other events, it will be the Z-index of the mark which is most directly related to the event and events that affect multiple marks will not provide a value for this property. The MarkCollection object will never provide a value for this property because the marks in a MarkCollection have no particular order.
Syntax
ASP.NET Ajax Javascript (Specification)
var zIndex : Integer;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMarkEventArgs.zIndex;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MarkEventArgs
MarkEventArgs Members


%%PageItemTitle%%

MouseEvent class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEvent class
The arguments for mouse events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MouseEvent = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MouseEvent();
Remarks

This object contains the arguments for mouse events. A PageView will provide an instance of this object whenever it raises a PageView.mouseDown, PageView.mouseMove, or PageView.mouseUp event.

Inheritance Hierarchy

Object
ImageGear.Web.UI.MouseEvent

See Also

Reference

MouseEvent Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

MouseEvent class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEvent class

The following tables list the members exposed by MouseEvent.

Public Constructors
 | Name | Description
public Constructor | MouseEvent Constructor |
Top
Public Fields
 | Name | Description
public Field | constrainedImagePoint | The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
public Field | domEvent | The original ASP.NET client framework event.
public Field | imagePoint | The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
public Field | mark | If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
public Field | pointLiesWithinImage | A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
public Field | windowPoint | The position of the mouse in window coordinates.
Top
Public Methods
 | Name | Description
public Method | preventDefault | Prevents the viewer from performing its default action with the event.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MouseEvent Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : MouseEvent Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MouseEvent = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MouseEvent();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%% $$Methods$$

MouseEvent class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEvent class

For a list of all members of this type, see MouseEvent members.

Public Methods
 | Name | Description
public Method | preventDefault | Prevents the viewer from performing its default action with the event.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

preventDefault Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : preventDefault Method
Prevents the viewer from performing its default action with the event.
Syntax
ASP.NET Ajax Javascript (Specification)
function preventDefault() : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.preventDefault();

Return Value

A human-readable representation of the object.
Remarks

This is similar to the standard DOM action, preventDefault(). It is primarily used to prevent the viewer from showing its default context menu so you can show your own.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%% $$Fields$$

MouseEvent class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEvent class

For a list of all members of this type, see MouseEvent members.

Public Fields
 | Name | Description
public Field | constrainedImagePoint | The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
public Field | domEvent | The original ASP.NET client framework event.
public Field | imagePoint | The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
public Field | mark | If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
public Field | pointLiesWithinImage | A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
public Field | windowPoint | The position of the mouse in window coordinates.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

constrainedImagePoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : constrainedImagePoint Field
The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var constrainedImagePoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.constrainedImagePoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

domEvent Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : domEvent Field
The original ASP.NET client framework event.
Syntax
ASP.NET Ajax Javascript (Specification)
var domEvent : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.domEvent;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

imagePoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : imagePoint Field
The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var imagePoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.imagePoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

mark Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : mark Field
If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
Syntax
ASP.NET Ajax Javascript (Specification)
var mark : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.mark;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

pointLiesWithinImage Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : pointLiesWithinImage Field
A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var pointLiesWithinImage : Boolean;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.pointLiesWithinImage;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

windowPoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent : windowPoint Field
The position of the mouse in window coordinates.
Syntax
ASP.NET Ajax Javascript (Specification)
var windowPoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEvent.windowPoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEvent
MouseEvent Members


%%PageItemTitle%%

MouseEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEventArgs class
The arguments for mouse events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MouseEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MouseEventArgs();
Remarks

This object contains the arguments for mouse events. A PageView will provide an instance of this object whenever it raises a PageView.mouseDown, PageView.mouseMove, or PageView.mouseUp event.

Inheritance Hierarchy

Object
ImageGear.Web.UI.MouseEventArgs

See Also

Reference

MouseEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

MouseEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEventArgs class

The following tables list the members exposed by MouseEventArgs.

Public Constructors
 | Name | Description
public Constructor | MouseEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | constrainedImagePoint | The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
public Field | domEvent | The original ASP.NET client framework event.
public Field | imagePoint | The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
public Field | mark | If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
public Field | pointLiesWithinImage | A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
public Field | windowPoint | The position of the mouse in window coordinates.
Top
Public Methods
 | Name | Description
public Method | preventDefault | Prevents the viewer from performing its default action with the event.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MouseEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : MouseEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.MouseEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.MouseEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%% $$Methods$$

MouseEventArgs class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEventArgs class

For a list of all members of this type, see MouseEventArgs members.

Public Methods
 | Name | Description
public Method | preventDefault | Prevents the viewer from performing its default action with the event.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

preventDefault Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : preventDefault Method
Prevents the viewer from performing its default action with the event.
Syntax
ASP.NET Ajax Javascript (Specification)
function preventDefault() : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.preventDefault();

Return Value

A human-readable representation of the object.
Remarks

This is similar to the standard DOM action, preventDefault(). It is primarily used to prevent the viewer from showing its default context menu so you can show your own.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%% $$Fields$$

MouseEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseEventArgs class

For a list of all members of this type, see MouseEventArgs members.

Public Fields
 | Name | Description
public Field | constrainedImagePoint | The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
public Field | domEvent | The original ASP.NET client framework event.
public Field | imagePoint | The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
public Field | mark | If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
public Field | pointLiesWithinImage | A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
public Field | windowPoint | The position of the mouse in window coordinates.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

constrainedImagePoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : constrainedImagePoint Field
The position of the mouse in image coordinates. This point will always be constrained to lie within the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var constrainedImagePoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.constrainedImagePoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

domEvent Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : domEvent Field
The original ASP.NET client framework event.
Syntax
ASP.NET Ajax Javascript (Specification)
var domEvent : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.domEvent;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

imagePoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : imagePoint Field
The position of the mouse in image coordinates. This point may lie outside the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var imagePoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.imagePoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

mark Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : mark Field
If the target of the event was a mark, this property will hold a reference to that mark. Otherwise it will be null. Note that, for some mouse tools, the mouse up event will not include a reference to a mark because the mouse tool displayed the selection between the mark and the cursor.
Syntax
ASP.NET Ajax Javascript (Specification)
var mark : Object;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.mark;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

pointLiesWithinImage Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : pointLiesWithinImage Field
A flag that indicates whether the position of the mouse lies inside or outside the bounds of the image.
Syntax
ASP.NET Ajax Javascript (Specification)
var pointLiesWithinImage : Boolean;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.pointLiesWithinImage;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

windowPoint Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs : windowPoint Field
The position of the mouse in window coordinates.
Syntax
ASP.NET Ajax Javascript (Specification)
var windowPoint : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfMouseEventArgs.windowPoint;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.MouseEventArgs
MouseEventArgs Members


%%PageItemTitle%%

PageView class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageView class
This is an ASP.NET client control for viewing images.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PageView = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PageView();
Remarks

This ASP.NET client control is an image viewer.

While it is possible to create an instance of this control using client-side JavaScript, you will normally create it by placing a server-side PageView control on an aspx page. If you wish to create an instance of this control using client-side JavaScript, take the following steps:

  • Add an empty <DIV> to your HTML.
  • Give your <DIV> a unique ID (Example:viewer1).
  • Give your <DIV> a size, in pixels, using either a CSS style sheet or an inline style.
  • If using Microsoft Ajax library, add the following code to your page.

    $create(ImageGear.Web.UI.PageView, { imageHandlerUrl: "ImageGearService.svc", artServiceOption: ImageGear.Web.UI.ImGearArtDataServices.ArtDataService }, null, null, $get("viewer1"));

  • If using ImageGear jQuery Plugins, add the following code to your page.

    $("#viewer1").ImGearPageViewPlugin({ imageHandlerUrl: "ImageGearService.svc", artServiceOption: ImageGear.Web.UI.ImGearArtDataServices.ArtDataService });

Inheritance Hierarchy

Object
Sys.Component
Sys.UI.Control
ImageGear.Web.UI.PageView

See Also

Reference

PageView Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

PageView class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageView class

The following tables list the members exposed by PageView.

Public Constructors
 | Name | Description
public Constructor | PageView Constructor |
Top
Public Properties
 | Name | Description
public Property | artPage | Indicates the ArtPage that contains the marks that are shown on the image.
public Property | artServiceOption | Indicates image data Service option.
public Property | controlStateElementId | Indicates the id of the HTML element that will hold the state of this control.
public Property | currentState | Indicates the current state of the control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Indicates how much information the control will log.
public Property | displayedPageRectangle | Indicates the portion of the image that is currently being displayed.
public Property | documentIdentifier | Indicates the image identifier of the current image.
public Property | documentPageCount | Indicates the number of images in the file that contains the current image.
public Property | encodedDocumentIdentifier | Indicates the encoded image identifier of the current image.
public Property | imageHandlerUrl | Indicates the absolute URL to the image handler.
public Property | includeArtInPostBack | Indicates whether the current annotations will be included in the state posted back to the server.
public Property | magnifierHeight | Indicates the height of the magnifier.
public Property | magnifierMagnification | Indicates the magnification of the magnifier.
public Property | magnifierWidth | Indicates the width of the magnifier.
public Property | magnifierXOffset | Indicates the X offset of the magnifier.
public Property | magnifierYOffset | Indicates the y offset of the magnifier.
public Property | markHandleSize | Indicates the approximate size of the handles shown on selected marks.
public Property | mouseTool | Indicates the behavior of the left mouse button.
public Property | pageHeight | Indicates the height of the current image.
public Property | pageIsOpen | Indicates whether the viewer currently has an image open.
public Property | pageNumber | Indicates the page index of the current image.
public Property | pageWidth | Indicates the width of the current image.
public Property | pageXResolution | Indicates the X resolution of the current image.
public Property | pageYResolution | Indicates the Y resolution of the current image.
public Property | presentationQuality | Indicates the presentation quality for the viewer.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | scrollBars | Indicates how the viewer shows scrollbars.
public Property | selectionIsVisible | Indicates whether the selection is visible.
public Property | selectionPageRectangle | Indicates the portion of the image that is currently selected.
public Property | selectionWindowRectangle | Indicates the portion of the window that is currently selected.
public Property | vectorFormatsRendering | Indicates how the viewer will render vector format images.
Top
Public Methods
 | Name | Description
public Method | closePage | Close the current image.
public Method | display | Forces the viewer to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the viewer.
public Method | extendSelection | Adjust the current selection.
public Method | fitPage | Changes the presentation of the image to one of several pre-defined values.
public Method | flip | Flips the current image (swaps the top and bottom edges).
public Method | getContextMenu | Gets the context menu for the provided mouse tool and mark type.
public Method | getDefaultContextMenu | Gets the context menu for the provided mark type.
public Method | hideContextMenu | Hides the context menu of control.
public Method | hideSelection | Hide the selection.
public Method | mirror | Mirrors the current image (swaps the left and right sides).
public Method | openPage | Open a new image.
public Method | print | Prints document pages.
public Method | rotate | Rotates the current image.
public Method | saveArtPage | Saves all art marks on a page using ImageGear service.
public Method | setContextMenu | Sets the context menu for the mark type.
public Method | setContextMenuForTool | Sets the context menu for the provided mouse tool and mark type.
public Method | showContextMenu | Shows the context menu of control.
public Method | showEmptySelection | Show an empty selection.
public Method | showPagePointAtCenter | Displays the specified point at the center of the viewer.
public Method | showPageRectangle | Displays the specified rectangle in the viewer.
public Method | showPrintDialog | Shows the printing page selection dialog.
public Method | showSelection | Show a selection.
public Method | transformPagePointToWindow | Transforms an image coordinate to a window coordinate.
public Method | transformWindowPointToPage | Transforms a window coordinate to an image coordinate.
public Method | writeToLog | Writes a user-defined event to the log.
public Method | zoomIn | Zooms in on the current image.
public Method | zoomOut | Zooms out from the current image.
Top
Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates the viewer failed to open ART page for requested page.
public Event | contextMenu | Indicates the user activated the context menu.
public Event | markAdded | Indicates that a new mark was added to the page.
public Event | markChanged | Indicates that a mark on the page was changed.
public Event | markCreating | Indicates that a new mark is being interactively created.
public Event | markRemoved | Indicates that a mark was removed from the page.
public Event | markReordered | Indicates that a mark was reordered within the page.
public Event | markSelectionChanged | Indicates that a mark was selected or unselected.
public Event | marksLoaded | Indicates that marks were loaded from a JSON string.
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageClosed | Indicates the viewer has closed the current image.
public Event | pageDisplayed |
public Event | pageOpened | Indicates the viewer has finished opening a new image.
public Event | pageOpenFailed | Indicates the viewer failed to open a new image.
public Event | pageOpening | Indicates the viewer is opening a new image.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

PageView Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : PageView Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PageView = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PageView();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%% $$Methods$$

PageView class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageView class

For a list of all members of this type, see PageView members.

Public Methods
 | Name | Description
public Method | closePage | Close the current image.
public Method | display | Forces the viewer to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the viewer.
public Method | extendSelection | Adjust the current selection.
public Method | fitPage | Changes the presentation of the image to one of several pre-defined values.
public Method | flip | Flips the current image (swaps the top and bottom edges).
public Method | getContextMenu | Gets the context menu for the provided mouse tool and mark type.
public Method | getDefaultContextMenu | Gets the context menu for the provided mark type.
public Method | hideContextMenu | Hides the context menu of control.
public Method | hideSelection | Hide the selection.
public Method | mirror | Mirrors the current image (swaps the left and right sides).
public Method | openPage | Open a new image.
public Method | print | Prints document pages.
public Method | rotate | Rotates the current image.
public Method | saveArtPage | Saves all art marks on a page using ImageGear service.
public Method | setContextMenu | Sets the context menu for the mark type.
public Method | setContextMenuForTool | Sets the context menu for the provided mouse tool and mark type.
public Method | showContextMenu | Shows the context menu of control.
public Method | showEmptySelection | Show an empty selection.
public Method | showPagePointAtCenter | Displays the specified point at the center of the viewer.
public Method | showPageRectangle | Displays the specified rectangle in the viewer.
public Method | showPrintDialog | Shows the printing page selection dialog.
public Method | showSelection | Show a selection.
public Method | transformPagePointToWindow | Transforms an image coordinate to a window coordinate.
public Method | transformWindowPointToPage | Transforms a window coordinate to an image coordinate.
public Method | writeToLog | Writes a user-defined event to the log.
public Method | zoomIn | Zooms in on the current image.
public Method | zoomOut | Zooms out from the current image.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

closePage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : closePage Method
Close the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function closePage() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.closePage();
Remarks

This function causes the viewer to close the current image, reverting the viewer back to a state where it is not displaying an image. Unlike the openPage function, this function does not need to interact with the server, so it will complete it's operation (including raising the pageClosed event) before it returns. Like most other viewer operations, the visual appearance of the viewer will not be updated immediately; instead the viewer will wait until the browser is idle before updating its appearance.

If you call this function while an openPage operation is pending, the control will cancel the pending operation and it will not raise the cancelled pageOpened event.

When you close the image, the viewer will also hide the selection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

display Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : display Method
Forces the viewer to update its visual presentation immediately.
Syntax
ASP.NET Ajax Javascript (Specification)
function display() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.display();
Remarks

Forces the viewer to update its visual presentation immediately. Normally, the viewer will wait until the browser is idle before updating the visual presentation.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

dispose Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : dispose Method
Disposes of the resources held by the viewer.
Syntax
ASP.NET Ajax Javascript (Specification)
function dispose() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.dispose();
Remarks

This function disposes of the resources held by this viewer and removes its user interface. After you call this function, you will not be able to use this instance of the viewer again.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

extendSelection Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : extendSelection Method
Adjust the current selection.
Syntax
ASP.NET Ajax Javascript (Specification)
function extendSelection(
   imagePoint : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.extendSelection(Point);

Parameters

imagePoint
The location at which the selection should be placed. The units of the point are the same as that for pageWidth (pixels for raster images and points for PDF images). The selection will be clipped to the bounds of the actual image.
Remarks

This function causes the viewer to adjust the current selection so the given point is at one of the corners, although that will not affect the visual appearance of the viewer until the browser has some idle time or you call the display function. Normally, you will want to use showEmptySelection and extendSelection together to define a rectangle. Start by calling showEmptySelection, followed by one or more calls to extendSelection. If the viewer does not have an open image, this function will do nothing.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

fitPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : fitPage Method
Changes the presentation of the image to one of several pre-defined values.
Syntax
ASP.NET Ajax Javascript (Specification)
function fitPage(
   type : FitType
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.fitPage(FitType);

Parameters

type
Indicates how the presentation of the image should change.
Remarks

This function will discard the current state of the scaling, panning, rotation, and mirroring applied to the image and set new values to match a pre-defined state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

flip Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : flip Method
Flips the current image (swaps the top and bottom edges).
Syntax
ASP.NET Ajax Javascript (Specification)
function flip() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.flip();
Remarks

Flips the current image (swaps the top and bottom edges), while keeping the portion of the image at the center of the viewer remaining in the same location.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

getContextMenu Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : getContextMenu Method
Gets the context menu for the provided mouse tool and mark type.
Syntax
ASP.NET Ajax Javascript (Specification)
function getContextMenu(
   markType : MarkType,
   mouseTool : MouseTool
) : ContextMenu;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.getContextMenu(MarkType,MouseTool);

Parameters

markType
Specifies ART mark type to return the context menu for.
mouseTool
Specifies the mouse tool to return the context menu for.

Return Value

The method returns ContextMenu.
Remarks
This method returns the context menu for the given mouse tool and the mark type, or the image context menu if null value is provided as a mark type. Please see Context Menu Customization page for more details.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

getDefaultContextMenu Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : getDefaultContextMenu Method
Gets the context menu for the provided mark type.
Syntax
ASP.NET Ajax Javascript (Specification)
function getDefaultContextMenu(
   markType : MarkType
) : ContextMenu;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.getDefaultContextMenu(MarkType);

Parameters

markType
Specifies ART mark type to return the context menu for.

Return Value

The method returns ContextMenu.
Remarks
This method returns independent from specific instance of PageView control context menu for the given mark type and ImageGear.Web.UI.MouseTool.EditMarks mouse tool, or the image context menu if null value is provided as a mark type. Please see Context Menu Customization page for more details.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

hideContextMenu Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : hideContextMenu Method
Hides the context menu of control.
Syntax
ASP.NET Ajax Javascript (Specification)
function hideContextMenu() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.hideContextMenu();
Remarks

Raising "contextMenu" event is suppressed with context menu hiding. This function call from "contextMenu" event handler does not hide context menu which is going to be shown.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

hideSelection Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : hideSelection Method
Hide the selection.
Syntax
ASP.NET Ajax Javascript (Specification)
function hideSelection() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.hideSelection();
Remarks

This function causes the viewer to hide the selection, although that will not affect the visual appearance of the viewer until the browser has some idle time or you call the display function. When the selection is hidden, the selectionIsVisible property will be false and the selectionPageRectangle and selectionWindowRectangle properties will be a rectangle with zeros for the x, y, width, and height values.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

mirror Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : mirror Method
Mirrors the current image (swaps the left and right sides).
Syntax
ASP.NET Ajax Javascript (Specification)
function mirror() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.mirror();
Remarks

Mirrors the current image (swaps the left and right sides), while keeping the portion of the image at the center of the viewer remaining in the same location.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

openPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : openPage Method
Open a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function openPage(
   parameters : PageViewState
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.openPage(PageViewState);

Parameters

parameters
An object whose properties are accepted as parameters of this function. Optionally, you may use a JavaScript object literal instead of constructing a new object.
Remarks

This function causes the viewer to begin the process of opening a new image. That process will involve communicating with the server, raising various events, selecting a scaling value with which to display the image, and then updating the presentation of the viewer. During execution of this function, the viewer will raise the pageOpening event, then begin communicating with the server. In a few cases, the conversation with the server will complete before this function returns, but usually, it will not. Once the conversation with the server is complete, the viewer will update the various image properties (such as pageIsOpen, documentIdentifier, pageWidth, etc.) and then raise the pageOpened event.

After this function returns, but before the communication with the server is complete, you can continue to interact with the previous image opened in the viewer. You must be careful in this case because the viewer will immediately discard the current image when the new image finishes opening.

If you call this function once, but call it again before the open process completes (and raises the pageOpened event), the control will cancel the earlier open process. The same is true if you call this function, then call closePage before the open process completes.

If you call this function and provide an empty string as the image identifier, this function will close the image instead of opening it (and it will raise the pageClosed event instead of pageOpening and pageOpened).

NOTE: This function will not detect some error conditions (such as invalid values for documentIdentifier or pageNumber) until the server responds. It will throw an exception at that time, but the only way to detect the exception is via the control's debug log facility. See the debug property for more information.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

print Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : print Method
Prints document pages.
Syntax
ASP.NET Ajax Javascript (Specification)
function print(
   printOptions : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.print(object);

Parameters

printOptions
Print options is a set of parameters. All parameters are optional.

  • imageHandlerUrl - Defines the service of images. Parameter can be undefined, in this case method will try to use image handler from this viewer. If this viewer is not initialized with image handler the method to do nothing.
  • documentIdentifier - Defines the identifier of printed document. If this parameter is undefined the method will try to use the documentIdentifier of current loaded to this view document. In case of loaded document missing the method to do nothing.
  • pageNumber - Defines the page number of printed page. If this parameter is undefined the method will find pageArray parameter. In other case page with required page number will be printed.
  • pageArray - Defines the page number array for printing. It contains the indexes of document pages. The parameter has lower priority in compare with pageNumber parameter. If both parameters exist pageNumber will be used. Parameter can be not present in the set in case of pageFilter or pageNumber parameter presence.
  • pageFilter - Defines the description of printed pages. This is formulized string which contains comma separated terms, where each term is one of both index of page or range of pages. Range of pages is a pair of page numbers separated with dash. First number of range is started page number of range and second number is last page number of range. If the whole construction has crossings in page numbers the seriated indexes will be merged. This parameter is alternative for pageArray.
  • includeAnnotations - If this parameter is present and its value is true the annotations are printed. Otherwise, annotation marks will not be printed.
  • callback - Defines the handler of printing process. It handler is called on start of printing and after each printed page. This function should be of function(arguments) prototype. The single parameter arguments is a set of parameters:
    • documentIdentifier - Identifier of printing document.
    • pageArray - Array of page indexes which is being printed.
    • printingPageIndex - This is index of printing page number in pageArray. Before printing the page with first index this value is 0. After printing all pages enumerated in pageArray this value is length of pageArray.
    • error - Error which is occured when the page is printed. For more detail inforamtion see ImGearPageOpenFailedEventArgs exception parameter.
    • canceled - The print method sets this parameter to false before callback calling. Callback handler can set these parameter to true for terminating the printing process.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

rotate Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : rotate Method
Rotates the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function rotate(
   degreesClockwise : number
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.rotate(number);

Parameters

degreesClockwise
Use this parameter to indicate how much to rotate the image. Only the following values are accepted: 90, 180, 270, -90, -180, and -270.
Remarks

Rotates the current image, while keeping the portion of the image at the center of the viewer remaining in the same location.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

saveArtPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : saveArtPage Method
Saves all art marks on a page using ImageGear service.
Syntax
ASP.NET Ajax Javascript (Specification)
function saveArtPage(
   onSave : function
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.saveArtPage(function);

Parameters

onSave
The function to call when art page is saved.
Remarks
This method uses ImageGear service to save all marks to the server. This method saves art objects that are changed or newly created by the user. The previous art marks for the page are overwritten.

This method is useful for saving art page when the PageView control is created using client side API.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

setContextMenu Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : setContextMenu Method
Sets the context menu for the mark type.
Syntax
ASP.NET Ajax Javascript (Specification)
function setContextMenu(
   menu : ContextMenu,
   markType : MarkType
) : undefined;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.setContextMenu(ContextMenu,MarkType);

Parameters

menu
ContextMenu object to set as a context menu
markType
Specifies the mouse tool to set the context menu for.

Return Value

Method does not return any values.
Remarks
This method sets the context menu for all mouse tools and the given mark type, or the image context menu if null value is provided as a mark type. Please see Context Menu Customization page for more details.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

setContextMenuForTool Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : setContextMenuForTool Method
Sets the context menu for the provided mouse tool and mark type.
Syntax
ASP.NET Ajax Javascript (Specification)
function setContextMenuForTool(
   menu : ContextMenu,
   markType : MarkType,
   mouseTool : MouseTool
) : undefined;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.setContextMenuForTool(ContextMenu,MarkType,MouseTool);

Parameters

menu
ContextMenu object to set as a context menu.
markType
Specifies the mouse tool to set the context menu for.
mouseTool
Specifies the mouse tool to set the context menu for. This is optional parameter. In case of missing parameter the method sets the provided menu for all mouse tools.

Return Value

Method does not return any values.
Remarks
This method sets the context menu for the given mouse tool and the mark type, or the image context menu if null value is provided as a mark type. Please see Context Menu Customization page for more details.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showContextMenu Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showContextMenu Method
Shows the context menu of control.
Syntax
ASP.NET Ajax Javascript (Specification)
function showContextMenu() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showContextMenu();
Remarks

This method restores the context menu functionality of control after it was hidden with preceding call of hideContextMenu() method.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showEmptySelection Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showEmptySelection Method
Show an empty selection.
Syntax
ASP.NET Ajax Javascript (Specification)
function showEmptySelection(
   imagePoint : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showEmptySelection(Point);

Parameters

imagePoint
The location at which the selection should be placed. The units of the point are the same as that for pageWidth (pixels for raster images and points for PDF images). The selection will be clipped to the bounds of the actual image.
Remarks

This function causes the viewer to show a zero-sized selection at the specified point on the image, although that will not affect the visual appearance of the viewer until the browser has some idle time or you call the display function. Normally, you will want to use showEmptySelection and extendSelection together to define a rectangle. Start by calling showEmptySelection, followed by one or more calls to extendSelection. If the viewer does not have an open image, this function will do nothing.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showPagePointAtCenter Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showPagePointAtCenter Method
Displays the specified point at the center of the viewer.
Syntax
ASP.NET Ajax Javascript (Specification)
function showPagePointAtCenter(
   imagePoint : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showPagePointAtCenter(Point);

Parameters

imagePoint
The image point to display at the center of the viewer. The units for the point are the same as the units for pageWidth and pageHeight (pixels for raster images and points for PDF images).
Remarks

Displays an image point, as specified in the imagePoint parameter, at the center of the viewer. This function will not change the current rotation, mirroring or scaling of the viewer.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showPageRectangle Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showPageRectangle Method
Displays the specified rectangle in the viewer.
Syntax
ASP.NET Ajax Javascript (Specification)
function showPageRectangle(
   imageRectangle : Rectangle
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showPageRectangle(Rectangle);

Parameters

imageRectangle
The rectangle to display in the viewer. The units for the rectangle are the same as the units for pageWidth and pageHeight (pixels for raster images and points for PDF images).
Remarks

Displays the portion of the current image, as specified in the imageRectangle parameter, in the viewer. Unless the aspect ratio of the rectangle matches the viewer, the viewer will expand either the width or height of the rectangle to match the aspect ratio.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showPrintDialog Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showPrintDialog Method
Shows the printing page selection dialog.
Syntax
ASP.NET Ajax Javascript (Specification)
function showPrintDialog(
   printOptions : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showPrintDialog(object);

Parameters

printOptions
Print options is a set of parameters.

  • imageHandlerUrl - Defines the service of images. Parameter can be undefined, in this case method will try to use image handler from this viewer. If this viewer is not initialized with image handler the method to do nothing.
  • documentIdentifier - Defines the identifier of printed document. If this parameter is undefined the method will try to use the documentIdentifier of current loaded to this view document. In case of loaded document missing the method to do nothing.
  • pageArray - Defines the page number array for printing. This parameter allows to preset the initial state of dialog controls.
  • includeAnnotations - Parameter defines the initial state of "Include Annotations" check box.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

showSelection Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : showSelection Method
Show a selection.
Syntax
ASP.NET Ajax Javascript (Specification)
function showSelection(
   imageRectangle : Rectangle
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.showSelection(Rectangle);

Parameters

imageRectangle
The location at which the selection should be placed. The units of the rectangle are the same as that for pageWidth (pixels for raster images and points for PDF images). The selection will be clipped to the bounds of the actual image.
Remarks

This function causes the viewer to show a selection around the specified rectangle of the image, although that will not affect the visual appearance of the viewer until the browser has some idle time or you call the display() function. If the viewer does not have an open image, this function will do nothing.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

transformPagePointToWindow Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : transformPagePointToWindow Method
Transforms an image coordinate to a window coordinate.
Syntax
ASP.NET Ajax Javascript (Specification)
function transformPagePointToWindow(
   imagePoint : Point,
   constrainResultToWindow : Boolean
) : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.transformPagePointToWindow(Point,Boolean);

Parameters

imagePoint
The image point to transform into window coordinates. The units for the point must be pixels, with the origin at the top left corner of the image, and with positive values extending right (x) and down (y). You may provide this function with a point that lies outside the bounds of the image and it will operate as expected.
constrainResultToWindow
If you provide this parameter, and set it to true, this function will constain the resulting point to lie within the bounds of the viewer.

Return Value

The window point that lies in the same location as the given image point or (0, 0) if the viewer does not have an image open. Note that this point may lie outside the bounds of the actual viewer if you do not set constrainResultToWindow to true.
Remarks

This function will transform the location of a point on the image to window coordinates. If the viewer does not have an image open, this function will return a point with the x and y values set to 0.

You can constrain the resulting point to the nearest point that lies within the bounds of the viewer by setting the constrainResultToWindow parameter to true, otherwise the result may lie outside the viewer bounds..

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

transformWindowPointToPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : transformWindowPointToPage Method
Transforms a window coordinate to an image coordinate.
Syntax
ASP.NET Ajax Javascript (Specification)
function transformWindowPointToPage(
   windowPoint : Point,
   constrainResultToImage : Boolean
) : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.transformWindowPointToPage(Point,Boolean);

Parameters

windowPoint
The window point to transform into image coordinates. The units for the point must be pixels, with the origin at the top left corner of the viewer, and with positive values extending right (x) and down (y). You may provide this function with a point that lies outside the bounds of the viewer and it will operate as expected.
constrainResultToImage
If you provide this parameter, and set it to true, this function will constain the resulting point to lie within the bounds of the image.

Return Value

The image point that lies in the same location as the given window point or (0, 0) if the viewer does not have an image open. Note that this point may lie outside the bounds of the actual image if you do not set constrainResultToImage to true.
Remarks

This function will transform the location of a point on the viewer window to image coordinates. If the viewer does not have an image open, this function will return a point with the x and y values set to 0.

You can constrain the resulting point to the nearest point that lies within the bounds of the image by setting the constrainResultToImage parameter to true, otherwise the result may lie outside the image bounds..

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

writeToLog Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : writeToLog Method
Writes a user-defined event to the log.
Syntax
ASP.NET Ajax Javascript (Specification)
function writeToLog(
   message : string
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.writeToLog(string);

Parameters

message
The message to write to the log.
Remarks

The viewer writes a wide variety of information to the log and this function allows you to add your own information to that same log. Normally, you would use this function to send key events to the log so you can see the larger context of events that this product writes into its log.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

zoomIn Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : zoomIn Method
Zooms in on the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function zoomIn(
   factor : number
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.zoomIn(number);

Parameters

factor
Use this parameter to indicate how much to zoom in on the image. The value should be greater than 1 because 1 indicates no zooming. A value of 2 indicates the image should double in size. Typically, you should use a value between 1.25 and 1.75.
Remarks

Zooms in on the current image, while keeping the portion of the image at the center of the viewer remaining in the same location.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

zoomOut Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : zoomOut Method
Zooms out from the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function zoomOut(
   factor : number
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.zoomOut(number);

Parameters

factor
Use this parameter to indicate how much to zoom out from the image. The value should be greater than 1 because 1 indicates no zooming. A value of 2 indicates the image should halve in size. Typically, you should use a value between 1.25 and 1.75.
Remarks

Zooms out from the current image, while keeping the portion of the image at the center of the viewer remaining in the same location.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%% $$Properties$$

PageView class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageView class

For a list of all members of this type, see PageView members.

Public Properties
 | Name | Description
public Property | artPage | Indicates the ArtPage that contains the marks that are shown on the image.
public Property | artServiceOption | Indicates image data Service option.
public Property | controlStateElementId | Indicates the id of the HTML element that will hold the state of this control.
public Property | currentState | Indicates the current state of the control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Indicates how much information the control will log.
public Property | displayedPageRectangle | Indicates the portion of the image that is currently being displayed.
public Property | documentIdentifier | Indicates the image identifier of the current image.
public Property | documentPageCount | Indicates the number of images in the file that contains the current image.
public Property | encodedDocumentIdentifier | Indicates the encoded image identifier of the current image.
public Property | imageHandlerUrl | Indicates the absolute URL to the image handler.
public Property | includeArtInPostBack | Indicates whether the current annotations will be included in the state posted back to the server.
public Property | magnifierHeight | Indicates the height of the magnifier.
public Property | magnifierMagnification | Indicates the magnification of the magnifier.
public Property | magnifierWidth | Indicates the width of the magnifier.
public Property | magnifierXOffset | Indicates the X offset of the magnifier.
public Property | magnifierYOffset | Indicates the y offset of the magnifier.
public Property | markHandleSize | Indicates the approximate size of the handles shown on selected marks.
public Property | mouseTool | Indicates the behavior of the left mouse button.
public Property | pageHeight | Indicates the height of the current image.
public Property | pageIsOpen | Indicates whether the viewer currently has an image open.
public Property | pageNumber | Indicates the page index of the current image.
public Property | pageWidth | Indicates the width of the current image.
public Property | pageXResolution | Indicates the X resolution of the current image.
public Property | pageYResolution | Indicates the Y resolution of the current image.
public Property | presentationQuality | Indicates the presentation quality for the viewer.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | scrollBars | Indicates how the viewer shows scrollbars.
public Property | selectionIsVisible | Indicates whether the selection is visible.
public Property | selectionPageRectangle | Indicates the portion of the image that is currently selected.
public Property | selectionWindowRectangle | Indicates the portion of the window that is currently selected.
public Property | vectorFormatsRendering | Indicates how the viewer will render vector format images.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPage Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : artPage Property
Indicates the ArtPage that contains the marks that are shown on the image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artPage() : ArtPage
function set_artPage(value : ArtPage)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_artPage();
Remarks

Indicates the ArtPage that contains the marks that are shown on the image.

Whenever you change this property to a different ArtPage, or make a change to one of the Mark objects contained in the ArtPage, this viewer will schedule a redraw for the next idle period. If you wish the viewer to redraw itself immediately, call the display function.

Note that multiple PageView and ThumbnailView controls can all reference the same ArtPage object, in which case all of them will automatically redraw themselves as necessary.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

artServiceOption Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : artServiceOption Property
Indicates image data Service option.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artServiceOption() : ImGearArtDataServices
function set_artServiceOption(value : ImGearArtDataServices)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_artServiceOption();
Remarks

This property lets you choose ImageGear Art Data Service.

If the PageView control is created using client side API and annotations data are required from the server either for reading or for updating, then this property value must be set to the enumeration field ImageGear.Web.UI.ImGearArtDataServices.ArtDataService.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

controlStateElementId Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : controlStateElementId Property
Indicates the id of the HTML element that will hold the state of this control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_controlStateElementId() : String
function set_controlStateElementId(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_controlStateElementId();
Remarks

This property is a string that contains the id of an HTML element that will hold the state of this control. It is for internal use only and the server-side ASP.NET control automatically sets this property to the correct value. If you are not using the server-side ASP.NET control, then you should not use this property because it is only used to convey the client-side control's state back to the server-side control.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

currentState Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : currentState Property
Indicates the current state of the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_currentState() : PageViewState
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_currentState();
Remarks

This read-only property will be an PageViewState object that contains the state of the viewer, including such things as the image identifier and the current scaling, rotation, and scrolling values. Note that if you call openPage, the value of this property will immediately change to reflect the image to be opened, even if the opening process has not completed (and the viewer has not yet raised the pageOpened event).

You can use this as part of an undo system, or if you want to save a persistent link to a particular view of an image.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

debug Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : debug Property
Indicates whether the control should log its actions.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debug() : Boolean
function set_debug(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_debug();
Example

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

If using Microsoft Ajax

var viewer1 = $find('viewer1');
viewer1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
viewer1.set_debug(true);

If using ImageGear jQuery plugins

$("#viewer1").ImGearPageViewPlugin().set_debug(true);

This JavaScript code implements the onImageGearItemLogged function, which will automatically receive items that any Accusoft control logs.

  • JavaScript
function onImageGearItemLogged(logItem) {
    // logItem.message is the text of the log entry.
    // logItem.cause is the cause of the logged item. It will be one of the values in the  enumeration.
    // logItem.level is the debug level of the logged item. It will be one of the values in the  enumeration.
    // logItem.id will be the client ID of the control that issued the log entry.
}
Remarks

This property turns the control's logging on or off. If you set this to true, the control will log its activities via the ASP.NET client-side trace facility.

You can set the amount of information that the viewer will log using the debugErrorLevel property.

The ASP.NET client-side trace facility is documented in MSDN, but to summarize, the client framework will send trace text to the following locations:

  • A textarea element on your page with an id of "TraceConsole"
  • The IE8 Developer Tools Console window
  • The FireBug Console window
  • The Visual Studio Output window

In addition to the locations that the ASP.NET client-side trace facility sends trace text, this control will send all logged items (with the data to be logged in an LogItemEventArgs object) to a global function, if it is present. In order to use this facility, you need to define a global JavaScript function in your client page called "onImageGearItemLogged".

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

debugErrorLevel Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : debugErrorLevel Property
Indicates how much information the control will log.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debugErrorLevel() : DebugErrorLevel
function set_debugErrorLevel(value : DebugErrorLevel)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_debugErrorLevel();
Example

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

If using Microsoft Ajax

var viewer1 = $find('viewer1');
viewer1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
viewer1.set_debug(true);

If using ImageGear jQuery plugins

$("#viewer1").ImGearPageViewPlugin().set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
$("#viewer1").ImGearPageViewPlugin().set_debug(true);

Remarks

This property sets the amount of information the control will log.

In addition to setting this property, you must turn logging on using the debug property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

displayedPageRectangle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : displayedPageRectangle Property
Indicates the portion of the image that is currently being displayed.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_displayedPageRectangle() : Rectangle
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_displayedPageRectangle();
Remarks

This read-only property will be a rectangle (contains x, y, width, and height properties) that indicates what portion of the image is currently being displayed. The units for the rectangle will be the same as the pageWidth and pageHeight properties (pixels for raster images and points for PDF images). If the viewer does not have a currently-opened image, this function will return a rectangle with x, y, width, and height all set to zero.

Note that this value will match the actual target state of the viewer, but the viewer may not have updated the visual presentation to match that state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

documentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : documentIdentifier Property
Indicates the image identifier of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documentIdentifier() : String
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_documentIdentifier();
Remarks

This read-only property will be the image identifier for the current image, or an empty string if the viewer does not have a currently-open image. This property will always match the encodedDocumentIdentifier property, except that encodedDocumentIdentifier is base64-encoded so the control can safely use it in a URL or in JavaScript code.

Note that if you call the openPage function, this property will not change to match the new image identifier until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or an empty string if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

documentPageCount Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : documentPageCount Property
Indicates the number of images in the file that contains the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documentPageCount() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_documentPageCount();
Remarks

This read-only property will be the number of images in the file that contains the current image, or zero if the viewer does not have a currently-open image.

Note that if you call the openPage function, this property will not change to match the new page count until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or zero if there is no previously-opened image.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

encodedDocumentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : encodedDocumentIdentifier Property
Indicates the encoded image identifier of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_encodedDocumentIdentifier() : String
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_encodedDocumentIdentifier();
Remarks

This read-only property will be the encoded image identifier for the current image, or an empty string if the viewer does not have a currently-open image. This property will always match the documentIdentifier property, except that this one is base64-encoded so the control can safely use it in a URL or in JavaScript code.

Note that if you call the openPage function, this property will not change to match the new image identifier until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or an empty string if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

imageHandlerUrl Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : imageHandlerUrl Property
Indicates the absolute URL to the image handler.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_imageHandlerUrl() : String
function set_imageHandlerUrl(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_imageHandlerUrl();
Remarks

This property is a string that contains the absolute URL for the image handler. The image handler is an ASP.NET handler that supports various operations of the viewer.

Note that you could use a relative URL for the image handler in most cases, but some versions of FireFox will fail if this URL is not absolute.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

includeArtInPostBack Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : includeArtInPostBack Property
Indicates whether the current annotations will be included in the state posted back to the server.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_includeArtInPostBack() : String
function set_includeArtInPostBack(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_includeArtInPostBack();
Remarks

This property indicates whether the current annotations will be included in the state posted back to the server. It is for internal use only and you should use the server-side control property, (TBD) instead. If you are not using the server-side ASP.NET control, then you should not use this property because it is only used to convey the client-side control's state back to the server-side control.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

magnifierHeight Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : magnifierHeight Property
Indicates the height of the magnifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_magnifierHeight() : Integer
function set_magnifierHeight(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_magnifierHeight();
Remarks

This property is a number that specifies the height of the magnifier, in window pixels. This must be a value between 25 and 500.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

magnifierMagnification Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : magnifierMagnification Property
Indicates the magnification of the magnifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_magnifierMagnification() : Number
function set_magnifierMagnification(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_magnifierMagnification();
Remarks

This property is a number that specifies the magnification applied to the image displayed in the magnifier. This must be a value between 1.5 and 8.0, with larger values magnifying more than smaller ones. In most cases, 3.0 is a good value.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

magnifierWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : magnifierWidth Property
Indicates the width of the magnifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_magnifierWidth() : Integer
function set_magnifierWidth(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_magnifierWidth();
Remarks

This property is a number that specifies the width of the magnifier, in window pixels. This must be a value between 25 and 500.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

magnifierXOffset Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : magnifierXOffset Property
Indicates the X offset of the magnifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_magnifierXOffset() : Integer
function set_magnifierXOffset(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_magnifierXOffset();
Remarks

This property is a number that specifies the X offset of the magnifier, in window pixels. The magnifier offset will offset the magnifier from the location of the cursor. The only normal use of this is for touch interfaces where the user's finger covers up the magnifier. Using an offset in this case allows you to move the magnifier out from under the user's finger. This must be a value between -500 and 500.

You should generally leave this value set to its default value of zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

magnifierYOffset Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : magnifierYOffset Property
Indicates the y offset of the magnifier.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_magnifierYOffset() : Integer
function set_magnifierYOffset(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_magnifierYOffset();
Remarks

This property is a number that specifies the Y offset of the magnifier, in window pixels. The magnifier offset will offset the magnifier from the location of the cursor. The only normal use of this is for touch interfaces where the user's finger covers up the magnifier. Using an offset in this case allows you to move the magnifier out from under the user's finger. This must be a value between -500 and 500.

You should generally leave this value set to its default value of zero or set it a negative number equal to a little over half the height of the magnifier.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markHandleSize Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markHandleSize Property
Indicates the approximate size of the handles shown on selected marks.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_markHandleSize() : Number
function set_markHandleSize(value : Number)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_markHandleSize();
Remarks

This property is a number that specifies the desired size, in inches, of handles that the viewer draws on selected marks. In this version, the viewer has a very limited number of actual sizes to choose from and it will pick the size that is closest to the requested size. In a future version, the viewer will use the exact size specified by this property. This must be a value between 0.1 and .5.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

mouseTool Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : mouseTool Property
Indicates the behavior of the left mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_mouseTool() : MouseTool
function set_mouseTool(value : MouseTool)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_mouseTool();
Remarks

This property specifies the behavior of the left mouse button. It must be set to one of the values in the MouseTool enumeration. In all cases, the viewer will raise the mouseDown, mouseMove, and mouseUp events.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageHeight Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageHeight Property
Indicates the height of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageHeight() : Number
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageHeight();
Remarks

This read-only property will be the height of the image in pixels for raster images, or points (1/72 of an inch) for PDF images. The value will always be an integer for raster images, but may not be an integer for PDF images.

If you need to know the height of an image in inches, simply divide this value by the pageYResolution property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageIsOpen Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageIsOpen Property
Indicates whether the viewer currently has an image open.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageIsOpen() : Boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageIsOpen();
Remarks

This read-only property will be true if the viewer currently has an image open and false otherwise.

Note that there will typically be some delay between the time the viewer begins to open an image and the time the image is fully opened. This property will not be true until the image is fully opened (it will be set to true just before the viewer raises the pageOpened event).

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageNumber Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageNumber Property
Indicates the page index of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageNumber() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageNumber();
Remarks

This read-only property will be the image page index for the current image, or -1 if the viewer does not have a currently-open image. The first page of a file has an image page index of zero.

Note that if you call the openPage function, this property will not change to match the new image page index until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or -1 if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageWidth Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageWidth Property
Indicates the width of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageWidth() : Number
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageWidth();
Remarks

This read-only property will be the width of the image in pixels for raster images, or points (1/72 of an inch) for PDF images. The value will always be an integer for raster images, but may not be an integer for PDF images.

If you need to know the width of an image in inches, simply divide this value by the pageXResolution property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageXResolution Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageXResolution Property
Indicates the X resolution of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageXResolution() : Number
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageXResolution();
Remarks

This read-only property will be the X, or horizontal, resolution of the image. For raster images, the value will be the number of pixels per inch, which will often (but not always) be an integer. For PDF images, the value will always be 72, which is the number of points in an inch.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageYResolution Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageYResolution Property
Indicates the Y resolution of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageYResolution() : Number
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_pageYResolution();
Remarks

This read-only property will be the Y, or vertical, resolution of the image. For raster images, the value will be the number of pixels per inch, which will often (but not always) be an integer. For PDF images, the value will always be 72, which is the number of points in an inch.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

presentationQuality Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : presentationQuality Property
Indicates the presentation quality for the viewer.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_presentationQuality() : Integer
function set_presentationQuality(value : Integer)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_presentationQuality();
Remarks

This property controls several different settings internal to the viewer. This property must be an integer between 0 and 100, with higher values resulting in better visual quality in the image and lower values resulting in faster operation of the viewer.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

resourcePath Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : resourcePath Property
Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_resourcePath() : string
function set_resourcePath(value : string)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_resourcePath();
Remarks

This property is a string that specifies the image files required for the menu icons and and the art mark handles. These files are png format files and are required when using PageView control created on the client side. Note: It is necessary for this property to be set when using server side controls.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

scrollBars Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : scrollBars Property
Indicates how the viewer shows scrollbars.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_scrollBars() : ScrollBars
function set_scrollBars(value : ScrollBars)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_scrollBars();
Remarks

This property controls how the viewer shows scrollbars. You must set it to a member of the ScrollBars enumeration and normally, you should set the value to Auto.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

selectionIsVisible Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : selectionIsVisible Property
Indicates whether the selection is visible.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectionIsVisible() : Boolean
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_selectionIsVisible();
Remarks

This read-only property will be true if the selection is currently visible and false otherwise.

Note that this value will match the actual target state of the viewer, but the viewer may not have updated the visual presentation to match that state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

selectionPageRectangle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : selectionPageRectangle Property
Indicates the portion of the image that is currently selected.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectionPageRectangle() : Rectangle
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_selectionPageRectangle();
Remarks

This read-only property will be a rectangle that indicates what portion of the image is currently selected. The units for the rectangle will be the same as the pageWidth and pageHeight properties (pixels for raster images and points for PDF images). If the viewer does not have a current, visible selection, this function will return a rectangle with x, y, width, and height all set to zero.

Note that this value will match the actual target state of the viewer, but the viewer may not have updated the visual presentation to match that state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

selectionWindowRectangle Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : selectionWindowRectangle Property
Indicates the portion of the window that is currently selected.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selectionWindowRectangle() : Rectangle
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_selectionWindowRectangle();
Remarks

This read-only property will be a rectangle that indicates what portion of the image is currently selected. Although this property represents the same rectangle as the selectionPageRectangle property, this rectangle is measured with respect to the window instead of the image and the units for the rectangle will be window pixels instead of image units. If the viewer does not have a current, visible selection, this function will return a rectangle with x, y, width, and height all set to zero.

Note that this value will match the actual target state of the viewer, but the viewer may not have updated the visual presentation to match that state.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

vectorFormatsRendering Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : vectorFormatsRendering Property
Indicates how the viewer will render vector format images.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_vectorFormatsRendering() : VectorFormatsRendering
function set_vectorFormatsRendering(value : VectorFormatsRendering)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageView.get_vectorFormatsRendering();
Remarks
This property defines the option for rendering vector format images. It must be set to one of the values in the enumeration VectorFormatsRendering. Default value ImageGear.Web.UI.VectorFormatsRendering.SVG defines the mode of rendering of vector format images through SVG format. Set the value of this property to ImageGear.Web.UI.VectorFormatsRendering.Raster for using PNG or JPEG raster formats for rendering of vector format images.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%% $$Events$$

PageView class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageView class

For a list of all members of this type, see PageView members.

Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates the viewer failed to open ART page for requested page.
public Event | contextMenu | Indicates the user activated the context menu.
public Event | markAdded | Indicates that a new mark was added to the page.
public Event | markChanged | Indicates that a mark on the page was changed.
public Event | markCreating | Indicates that a new mark is being interactively created.
public Event | markRemoved | Indicates that a mark was removed from the page.
public Event | markReordered | Indicates that a mark was reordered within the page.
public Event | markSelectionChanged | Indicates that a mark was selected or unselected.
public Event | marksLoaded | Indicates that marks were loaded from a JSON string.
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageClosed | Indicates the viewer has closed the current image.
public Event | pageDisplayed |
public Event | pageOpened | Indicates the viewer has finished opening a new image.
public Event | pageOpenFailed | Indicates the viewer failed to open a new image.
public Event | pageOpening | Indicates the viewer is opening a new image.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : artPageOpenFailed Event
Indicates the viewer failed to open ART page for requested page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_artPageOpenFailed(handler : Function)
function remove_artPageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_artPageOpenFailed(handler);
.remove_artPageOpenFailed(handler);
Remarks

The viewer will raise this event whenever it fails to open ART page for requested page (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after a call to the openPage function fails to load ART page.

When the viewer raises this event, it will provide an instance of an exception object ImGearPageOpenFailedEventArgs as the event argument. This object contains an exception object, which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

contextMenu Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : contextMenu Event
Indicates the user activated the context menu.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_contextMenu(handler : Function)
function remove_contextMenu(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_contextMenu(handler);
.remove_contextMenu(handler);
Remarks

The viewer will raise this event whenever the user activates the context menu by pressing and releasing the right mouse button while the cursor is over any part of the viewer (except the scrollbars).

On some browsers (Internet Explorer 8), a user can also cause the viewer to raise this event by pressing the context menu button on the keyboard.

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markAdded Event
Indicates that a new mark was added to the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markAdded(handler : Function)
function remove_markAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markAdded(handler);
.remove_markAdded(handler);
Remarks

The viewer will raise this event whenever a mark is added (as the result of a call to the ArtPage.addMark function).

When the page raises this event, it will provide the new Mark object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markChanged Event
Indicates that a mark on the page was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markChanged(handler : Function)
function remove_markChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markChanged(handler);
.remove_markChanged(handler);
Remarks

The viewer will raise this event whenever the value of any property of a mark changes.

When the page raises this event, it will provide the changed Mark object and the name of the property that changed as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markCreating Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markCreating Event
Indicates that a new mark is being interactively created.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markCreating(handler : Function)
function remove_markCreating(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markCreating(handler);
.remove_markCreating(handler);
Remarks

The viewer will raise this event whenever an end user begins to add a mark to the page. This event occurs before the new mark is first displayed on the viewer and is the best time to change default values for any properties of the mark.

When the page raises this event, it will provide the new Mark object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markRemoved Event
Indicates that a mark was removed from the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markRemoved(handler : Function)
function remove_markRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markRemoved(handler);
.remove_markRemoved(handler);
Remarks

The PageView will raise this event whenever a mark is removed (as the result of a call to the ArtPage.removeMark or ArtPage.removeAllMarks functions). The object will raise this event after it has removed the mark.

When the page raises this event, it will provide the removed Mark object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markReordered Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markReordered Event
Indicates that a mark was reordered within the page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markReordered(handler : Function)
function remove_markReordered(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markReordered(handler);
.remove_markReordered(handler);
Remarks

The viewer will raise this event whenever a mark is reordered (as the result of a call to the ArtPage.reorderMark function). The object will raise this event after it has reordered the mark.

When the page raises this event, it will provide the reordered Mark object and its new index as the event argument. Note that when a mark is reordered, other marks are implicitly moved as well, but this event is not raised for those marks.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

markSelectionChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : markSelectionChanged Event
Indicates that a mark was selected or unselected.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_markSelectionChanged(handler : Function)
function remove_markSelectionChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_markSelectionChanged(handler);
.remove_markSelectionChanged(handler);
Remarks

The viewer will raise this event after a mark is added to, or removed from, the ArtPage.selectedMarks collection. The object will raise this event after it has updated the list of selected marks.

When the page raises this event, it will provide the MarkCollection of selected marks as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

marksLoaded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : marksLoaded Event
Indicates that marks were loaded from a JSON string.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_marksLoaded(handler : Function)
function remove_marksLoaded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_marksLoaded(handler);
.remove_marksLoaded(handler);
Remarks

The viewer will raise this event after the ArtPage.loadFromJson function successfully loads marks from a JSON string, even if that string contained no marks.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

mouseDown Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : mouseDown Event
Indicates the user pressed a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseDown(handler : Function)
function remove_mouseDown(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseDown(handler);
.remove_mouseDown(handler);
Remarks

The viewer will raise this event whenever the user presses a mouse button while the cursor is over any part of the viewer (except the scrollbars).

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

mouseMove Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : mouseMove Event
Indicates the user moved the mouse.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseMove(handler : Function)
function remove_mouseMove(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseMove(handler);
.remove_mouseMove(handler);
Remarks

The viewer will raise this event whenever the user moves the mouse over any part of the viewer (except the scrollbars).

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

mouseUp Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : mouseUp Event
Indicates the user released a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseUp(handler : Function)
function remove_mouseUp(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseUp(handler);
.remove_mouseUp(handler);
Remarks

The viewer will raise this event whenever the user releases a mouse button while the cursor is over any part of the viewer (except the scrollbars).

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageClosed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageClosed Event
Indicates the viewer has closed the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageClosed(handler : Function)
function remove_pageClosed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageClosed(handler);
.remove_pageClosed(handler);
Remarks

The viewer will raise this event in the following conditions:

  • You called the closePage function and the viewer had an image open.
  • You called the openPage function, there was an image already open, and the new image was different from the old image.
  • You called the dispose function and the viewer had an image open (or the ASP.NET client framework called dispose on your behalf when the page was closed or an UpdatePanel containing the viewer was reloaded).

When the viewer raises this event, it will provide an instance of an PageViewState object as the event argument. This object will contain the state of the viewer just before the image was closed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageDisplayed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageDisplayed Event
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageDisplayed(handler : Function)
function remove_pageDisplayed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageDisplayed(handler);
.remove_pageDisplayed(handler);
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageOpened Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageOpened Event
Indicates the viewer has finished opening a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpened(handler : Function)
function remove_pageOpened(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpened(handler);
.remove_pageOpened(handler);
Remarks

The viewer will raise this event whenever it finishes opening a new image (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after the openPage function returns, but in some cases the viewer will raise it before openPage returns.

When the viewer raises this event, it will provide an instance of an PageViewState object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageOpenFailed Event
Indicates the viewer failed to open a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpenFailed(handler : Function)
function remove_pageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpenFailed(handler);
.remove_pageOpenFailed(handler);
Remarks

The viewer will raise this event whenever it fails to open new image (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after a call to the openPage function fails to load a page.

When the viewer raises this event, it will provide an instance of an exception object ImGearPageOpenFailedEventArgs as the event argument. This object contains an exception object, which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

pageOpening Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView : pageOpening Event
Indicates the viewer is opening a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpening(handler : Function)
function remove_pageOpening(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpening(handler);
.remove_pageOpening(handler);
Remarks

The viewer will raise this event whenever it begins to open a new image (usually as the result of a call to the openPage function).

Note that between this event and the following pageOpened event, the viewer is in a transitional state between the current image and the new image. While in that state, the viewer will continue to display and allow the user to interact with the current image. In addition, nearly all properties of this control (such as documentIdentifier, pageNumber, and pageWidth) will continue to reflect the attributes of the current image. Unlike the other properties, currentState will update during the call to openPage instead of waiting for the pageOpened event. As soon as the server responds with information about the new image, the viewer will discard the current image and begin viewing the new image.

If you call openPage a second time before the first pageOpened event is raised, the viewer will ignore the first call and stay in the transitional state until the second image has completed opening.

When the viewer raises this event, it will provide an instance of an PageViewState object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageView
PageView Members


%%PageItemTitle%%

PageViewState class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageViewState class
The control state of an PageView control.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PageViewState = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PageViewState();
Remarks

This object represents the state of a PageView control. In some cases it will represent an actual state of a PageView control and in other cases it will represent a target state of a PageView control.

Normally, the client and server portions of a PageView control will use this object to manage the control's state without any assistance, but there are a few cases where you must use this object yourself.

  • If you call the PageView.openPage function, you must create an object of this type in order to specify the page to open and how you want it to be initially displayed.
  • If you call the PageView.get_currentState function, it will return an object of this type.
  • The PageView.pageOpening, PageView.pageOpened, and PageView.pageClosed events all use an object of this type to hold the event arguments.

Most of the values in this object are fairly easy to understand, but the documentIdentifier and encodedDocumentIdentifier may be a little confusing. Because the ImageGear product allows you to use any characters (including symbols and unicode characters) in document identifiers, it uses base64 encoding to ensure they are suitable for use in a URL. Unfortunately, there are use cases where you will want to use an encoded document identifier and cases where you will want to use an unencoded document identifier. To support both types of use cases, the ImageGear product gives you read access to both forms of the document identifier and allows you to specify either type when you open a page. For example, when an PageView returns an object of this type, it will set both the documentIdentifier value to the unencoded document identifier and the encodedDocumentIdentifier to an encoded version of the same document identifier. When you provide an instance of this object to the PageView.openPage function, you can specify either value (or set them both to reference the same document identifier).

Inheritance Hierarchy

Object
ImageGear.Web.UI.PageViewState

See Also

Reference

PageViewState Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

PageViewState class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageViewState class

The following tables list the members exposed by PageViewState.

Public Constructors
 | Name | Description
public Constructor | PageViewState Constructor |
Top
Public Fields
 | Name | Description
public Field | artPage | The object containing ART marks to display on the page. If you specify a value for both this property and artPageJson, the PageView.openPage function will ignore artPageJson.
public Field | artPageJson | A string containing ART marks (in JSON format) to display on the page. If you specify a value for both this property and artPage, the PageView.openPage function will ignore this property.
public Field | documentIdentifier | The identifier of a document.
public Field | encodedDocumentIdentifier | The identifier of a document, encoded using a form of base64 encoding.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
public Field | viewFitType | The fit type for the page.
public Field | viewMirror | A flag indicating whether the page should be mirrored. If you want to flip the page instead of mirror it, simply add 180 degrees to viewRotationDegreesClockwise and toggle this value.
public Field | viewRectangle | The rectangle to display in the viewer if viewFitType is set to Rectangle. If viewFitType is not Rectangle then you can omit this value.
public Field | viewRotationDegreesClockwise | The amount of rotation to apply to the page. Valid values are 0 (or do not provide a value), 90, 180, 270, -90, -180, or -270.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

PageViewState Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : PageViewState Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PageViewState = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PageViewState();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%% $$Fields$$

PageViewState class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PageViewState class

For a list of all members of this type, see PageViewState members.

Public Fields
 | Name | Description
public Field | artPage | The object containing ART marks to display on the page. If you specify a value for both this property and artPageJson, the PageView.openPage function will ignore artPageJson.
public Field | artPageJson | A string containing ART marks (in JSON format) to display on the page. If you specify a value for both this property and artPage, the PageView.openPage function will ignore this property.
public Field | documentIdentifier | The identifier of a document.
public Field | encodedDocumentIdentifier | The identifier of a document, encoded using a form of base64 encoding.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
public Field | viewFitType | The fit type for the page.
public Field | viewMirror | A flag indicating whether the page should be mirrored. If you want to flip the page instead of mirror it, simply add 180 degrees to viewRotationDegreesClockwise and toggle this value.
public Field | viewRectangle | The rectangle to display in the viewer if viewFitType is set to Rectangle. If viewFitType is not Rectangle then you can omit this value.
public Field | viewRotationDegreesClockwise | The amount of rotation to apply to the page. Valid values are 0 (or do not provide a value), 90, 180, 270, -90, -180, or -270.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPage Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : artPage Field
The object containing ART marks to display on the page. If you specify a value for both this property and artPageJson, the PageView.openPage function will ignore artPageJson.
Syntax
ASP.NET Ajax Javascript (Specification)
var artPage : ArtPage;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.artPage;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

artPageJson Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : artPageJson Field
A string containing ART marks (in JSON format) to display on the page. If you specify a value for both this property and artPage, the PageView.openPage function will ignore this property.
Syntax
ASP.NET Ajax Javascript (Specification)
var artPageJson : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.artPageJson;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

documentIdentifier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : documentIdentifier Field
The identifier of a document.
Syntax
ASP.NET Ajax Javascript (Specification)
var documentIdentifier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.documentIdentifier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

encodedDocumentIdentifier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : encodedDocumentIdentifier Field
The identifier of a document, encoded using a form of base64 encoding.
Syntax
ASP.NET Ajax Javascript (Specification)
var encodedDocumentIdentifier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.encodedDocumentIdentifier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

pageNumber Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : pageNumber Field
The page index of a page in a multi-page document. The first page in a file is index 0.
Syntax
ASP.NET Ajax Javascript (Specification)
var pageNumber : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.pageNumber;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

viewFitType Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : viewFitType Field
The fit type for the page.
Syntax
ASP.NET Ajax Javascript (Specification)
var viewFitType : FitType;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.viewFitType;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

viewMirror Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : viewMirror Field
A flag indicating whether the page should be mirrored. If you want to flip the page instead of mirror it, simply add 180 degrees to viewRotationDegreesClockwise and toggle this value.
Syntax
ASP.NET Ajax Javascript (Specification)
var viewMirror : boolean;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.viewMirror;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

viewRectangle Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : viewRectangle Field
The rectangle to display in the viewer if viewFitType is set to Rectangle. If viewFitType is not Rectangle then you can omit this value.
Syntax
ASP.NET Ajax Javascript (Specification)
var viewRectangle : Rectangle;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.viewRectangle;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

viewRotationDegreesClockwise Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState : viewRotationDegreesClockwise Field
The amount of rotation to apply to the page. Valid values are 0 (or do not provide a value), 90, 180, 270, -90, -180, or -270.
Syntax
ASP.NET Ajax Javascript (Specification)
var viewRotationDegreesClockwise : number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPageViewState.viewRotationDegreesClockwise;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PageViewState
PageViewState Members


%%PageItemTitle%%

Point class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Point class
A point in an X/Y coordinate space.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Point = function(
   x : number,
   y : number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Point();
Remarks

This object has x and y properties and represents a point in a cartesian coordinate space. The ImageGear product uses this object in a variety of places to represent a position on a window or on an image.

This object is very similar to the ASP.NET client framework object, ImageGear.UI.Point, except that its values are floating point instead of integers.

Inheritance Hierarchy

Object
ImageGear.Web.UI.Point

See Also

Reference

Point Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

Point class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Point class

The following tables list the members exposed by Point.

Public Constructors
 | Name | Description
public Constructor | Point Constructor |
Top
Public Fields
 | Name | Description
public Field | x | The x coordinate of the point.
public Field | y | The y coordinate of the point.
Top
Public Methods
 | Name | Description
public Method | angleWith | Calculates the angle between this vector and given vector.
public Method | composeWith | Makes the composition of this point with given vector.
public Method | constrain | Constrains this point to the bounds of a rectangle.
public Method | module | Calculates the length of this vector.
public Method | scalarProduct | Makes the scalar product of this vector with given vector.
public Method | subtract | Makes the subtraction of given vector from this vector.
public Method | vectorProduct | Makes the scalar product of this vector with given vector.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

Point Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : Point Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Point = function(
   x : number,
   y : number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Point(number,number);

Parameters

x
y
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%% $$Methods$$

Point class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Point class

For a list of all members of this type, see Point members.

Public Methods
 | Name | Description
public Method | angleWith | Calculates the angle between this vector and given vector.
public Method | composeWith | Makes the composition of this point with given vector.
public Method | constrain | Constrains this point to the bounds of a rectangle.
public Method | module | Calculates the length of this vector.
public Method | scalarProduct | Makes the scalar product of this vector with given vector.
public Method | subtract | Makes the subtraction of given vector from this vector.
public Method | vectorProduct | Makes the scalar product of this vector with given vector.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

angleWith Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : angleWith Method
Calculates the angle between this vector and given vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function angleWith(
   vector : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.angleWith(Point);

Parameters

vector
The vector for the angle calculating.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

composeWith Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : composeWith Method
Makes the composition of this point with given vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function composeWith(
   vector : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.composeWith(Point);

Parameters

vector
The vector for the composition.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

constrain Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : constrain Method
Constrains this point to the bounds of a rectangle.
Syntax
ASP.NET Ajax Javascript (Specification)
function constrain(
   rectangle : Rectangle
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.constrain(Rectangle);

Parameters

rectangle
The rectangle to which this function will constrain the point.
Remarks

The function will modify this object so that the point lies within the bounds of the specified rectangle. The resulting point will be as close as possible to the original point, while still lying inside the specified rectangle.

There are two exceptions to the defined behavior of this function: points along the bottom and right edges. Technically, a rectangle contains all the points whose x coordinate is greater than or equal to the left edge and less than the right edge and whose y coordinate is greater than or equal to the top edge and less than the bottom edge. To simplify the implementation of this function, it may select a point whose x coordinate is equal to (not less than) the right edge or whose y coordinate is equal to (not less than) the bottom edge.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

module Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : module Method
Calculates the length of this vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function module() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.module();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

scalarProduct Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : scalarProduct Method
Makes the scalar product of this vector with given vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function scalarProduct(
   vector : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.scalarProduct(Point);

Parameters

vector
The vector for the scalar product with this vector.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

subtract Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : subtract Method
Makes the subtraction of given vector from this vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function subtract(
   vector : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.subtract(Point);

Parameters

vector
The vector for the subtraction from this vector.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

vectorProduct Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : vectorProduct Method
Makes the scalar product of this vector with given vector.
Syntax
ASP.NET Ajax Javascript (Specification)
function vectorProduct(
   vector : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.vectorProduct(Point);

Parameters

vector
The vector for the scalar product with this vector.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%% $$Fields$$

Point class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Point class

For a list of all members of this type, see Point members.

Public Fields
 | Name | Description
public Field | x | The x coordinate of the point.
public Field | y | The y coordinate of the point.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

x Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : x Field
The x coordinate of the point.
Syntax
ASP.NET Ajax Javascript (Specification)
var x : number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.x;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

y Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point : y Field
The y coordinate of the point.
Syntax
ASP.NET Ajax Javascript (Specification)
var y : number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPoint.y;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Point
Point Members


%%PageItemTitle%%

PointCollection class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointCollection class
A list of Point objects.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PointCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PointCollection();
Remarks

This object is an ordered list of Point objects. It holds and returns copies of Point objects so it can guarantee that the events that it raises (pointAdded, pointChanged, and pointRemoved) occur at the appropriate times.

This object is used primarily as part of a Line, Polyline, or Polygon mark.

Inheritance Hierarchy

Object
ImageGear.Web.UI.PointCollection

See Also

Reference

PointCollection Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

PointCollection class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointCollection class

The following tables list the members exposed by PointCollection.

Public Constructors
 | Name | Description
public Constructor | PointCollection Constructor |
Top
Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
Public Methods
 | Name | Description
public Method | addPoint | Appends a point to the end of the collection.
public Method | addPoints | Appends a collection of points to the end of the collection.
public Method | forEach | Calls the specified function once for each point in the collection.
public Method | getPoint | Returns a point in the collection.
public Method | moveAllPoints | Adds an X and Y offset to every point in the collection.
public Method | removeAllPoints | Removes all the points from the collection.
public Method | removePoint | Removes one point from the collection.
public Method | setPoint | Changes the value of a point in the collection.
Top
Public Events
 | Name | Description
public Event | pointAdded | Indicates that a new point was added to the collection.
public Event | pointChanged | Indicates that a point in the collection was changed.
public Event | pointRemoved | Indicates that a point was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

PointCollection Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : PointCollection Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PointCollection = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PointCollection();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%% $$Methods$$

PointCollection class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointCollection class

For a list of all members of this type, see PointCollection members.

Public Methods
 | Name | Description
public Method | addPoint | Appends a point to the end of the collection.
public Method | addPoints | Appends a collection of points to the end of the collection.
public Method | forEach | Calls the specified function once for each point in the collection.
public Method | getPoint | Returns a point in the collection.
public Method | moveAllPoints | Adds an X and Y offset to every point in the collection.
public Method | removeAllPoints | Removes all the points from the collection.
public Method | removePoint | Removes one point from the collection.
public Method | setPoint | Changes the value of a point in the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

addPoint Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : addPoint Method
Appends a point to the end of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addPoint(
   point : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.addPoint(Point);

Parameters

point
The point to add to the collection.
Remarks

The function will append a copy of the point to the end of the collection. It is similar to the standard JavaScript Array.push() function. This function copies the point so it can guarantee that it calls the pointChanged event at the proper time.

After this function has added the new point to the collection, it will raise the pointAdded event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

addPoints Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : addPoints Method
Appends a collection of points to the end of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function addPoints(
   pointCollection : PointCollection
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.addPoints(PointCollection);

Parameters

pointCollection
The collection of points to add to the collection.
Remarks

The function will append a collection of points to the end of the collection. It is similar to the standard JavaScript Array.concat() function. This function copies the points so it can guarantee that it calls the pointChanged event at the proper time. If pointCollection contains no points, this function will do nothing and will not raise the pointAdded event.

After this function has added all the new points to the collection, it will raise the pointAdded event, without providing a specific point. It will set ImageGear.Web.UI.PointEventArgs.index to the new index of the first point added and ImageGear.Web.UI.PointEventArgs.length to the number of new points added.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

forEach Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : forEach Method
Calls the specified function once for each point in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function forEach(
   method : function,
   context : object
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.forEach(function,object);

Parameters

method
The function to call.
context
An object that holds the context of the call.
Remarks

This function calls the specified function once for each point in the collection. It is very similar to the ASP.NET Ajax Library, Array.forEach() function.

When forEach calls the function, it will set this to context, the first function parameter to a copy of the point being enumerated, the second function parameter to the zero-based index of the point, and the third function parameter to the collection.

This function copies the list of points before starting the enumeration, so you can safely make changes to the collection during the enumeration process. Any points that you delete during the enumeration will be enumerated; any points that you add during the enumeration will not be enumerated, and any points that you change during the enumeration will be enumerated with their new value.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

getPoint Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : getPoint Method
Returns a point in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function getPoint(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.getPoint(number(Integer));

Parameters

index
The zero-based index of the point to return.
Remarks

This function returns a copy of the given point in the collection. Because the returned value is a copy, changing the x or y values of the returned Point will have no effect on the point in the collection. This behavior helps to guarantee that a PointCollection object raises the pointChanged event at the appropriate times.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

moveAllPoints Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : moveAllPoints Method
Adds an X and Y offset to every point in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function moveAllPoints() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.moveAllPoints();
Remarks

This function adds the given X and Y offset to every point in the collection. If deltaX and deltaY are both 0, this function will do nothing and will not raise the pointChanged event.

After this function has moved every point, it will raise the pointChanged event a single time, without specifying which providing a specific point. It will set ImageGear.Web.UI.PointEventArgs.index to 0 and ImageGear.Web.UI.PointEventArgs.length to the number of points in the collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

removeAllPoints Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : removeAllPoints Method
Removes all the points from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removeAllPoints() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.removeAllPoints();
Remarks

This function removes all points from the collection. If the collection contains no points, this function will do nothing and will not raise the pointRemoved event.

After this function removes each point, it will raise the pointRemoved event. It will set ImageGear.Web.UI.PointEventArgs.index to 0 and ImageGear.Web.UI.PointEventArgs.length to the number of points removed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

removePoint Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : removePoint Method
Removes one point from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function removePoint(
   index : number(Integer)
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.removePoint(number(Integer));

Parameters

index
The zero-based index of the point to remove.
Remarks

This function removes a single point from the collection.

After this function removes the point, it will raise the pointRemoved event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

setPoint Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : setPoint Method
Changes the value of a point in the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function setPoint(
   index : number(Integer),
   point : Point
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.setPoint(number(Integer),Point);

Parameters

index
The zero-based index of the point to change.
point
The new value to assign to the specified point.
Remarks

This function changes the value of a point to a copy of the specified point. This function will not add a new point to the collection; the collection must contain an point at the given index before you call this function.

If the new value is different from the original value, this function will raise the pointChanged event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%% $$Properties$$

PointCollection class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointCollection class

For a list of all members of this type, see PointCollection members.

Public Properties
 | Name | Description
public Property | length | Returns the length of the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

length Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : length Property
Returns the length of the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_length() : {Any}
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointCollection.get_length();
Remarks

This function returns returns the number of points that the collection contains. If the collection is empty, this function will return zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%% $$Events$$

PointCollection class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointCollection class

For a list of all members of this type, see PointCollection members.

Public Events
 | Name | Description
public Event | pointAdded | Indicates that a new point was added to the collection.
public Event | pointChanged | Indicates that a point in the collection was changed.
public Event | pointRemoved | Indicates that a point was removed from the collection.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

pointAdded Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : pointAdded Event
Indicates that a new point was added to the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pointAdded(handler : Function)
function remove_pointAdded(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pointAdded(handler);
.remove_pointAdded(handler);
Remarks

The collection will raise this event whenever one or more points are added to the collection (as the result of a call to the addPoint or addPoints functions).

The collection will provide a PointEventArgs as the event argument. When the collection raises this event during the addPoint function, it will provide a copy of the new point and the new index of the Point. When the collection raises this event during the addPoints function, it will provide the index of the first new Point and the number of points added.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

pointChanged Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : pointChanged Event
Indicates that a point in the collection was changed.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pointChanged(handler : Function)
function remove_pointChanged(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pointChanged(handler);
.remove_pointChanged(handler);
Remarks

The collection will raise this event whenever a point is changed (as the result of a call to the setPoint function).

The collection will provide a PointEventArgs as the event argument. When the collection raises this event during the setPoint function, it will provide a copy of the changed point and the index of the Point. When the collection raises this event during the movePoints function, it will set the index to 0 and the length to the number of points in the collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

pointRemoved Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection : pointRemoved Event
Indicates that a point was removed from the collection.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pointRemoved(handler : Function)
function remove_pointRemoved(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pointRemoved(handler);
.remove_pointRemoved(handler);
Remarks

The collection will raise this event whenever a point is removed (as the result of a call to the removePoint or removeAllPoints functions).

The collection will provide a PointEventArgs as the event argument. When the collection raises this event during the removePoint function, it will provide a copy of the removed point and the old index of the Point. When the collection raises this event during the removeAllPoints function, it will set the index to 0 and the length to the number of points in the collection.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointCollection
PointCollection Members


%%PageItemTitle%%

PointEventArgs class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointEventArgs class
The arguments for point events.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PointEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PointEventArgs();
Remarks

This object contains the arguments for point events raised by a PointCollection. A PointCollection will provide an instance of this object whenever it raises a PointCollection.pointAdded, PointCollection.pointChanged, or PointCollection.pointRemoved event.

Inheritance Hierarchy

Object
ImageGear.Web.UI.PointEventArgs

See Also

Reference

PointEventArgs Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

PointEventArgs class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointEventArgs class

The following tables list the members exposed by PointEventArgs.

Public Constructors
 | Name | Description
public Constructor | PointEventArgs Constructor |
Top
Public Fields
 | Name | Description
public Field | index | The index of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value 0 and the length property will probably be greater than 1.
public Field | length | The number of points which are related to the event.
public Field | point | A copy of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value undefined.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

PointEventArgs Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs : PointEventArgs Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.PointEventArgs = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.PointEventArgs();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
PointEventArgs Members


%%PageItemTitle%% $$Fields$$

PointEventArgs class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : PointEventArgs class

For a list of all members of this type, see PointEventArgs members.

Public Fields
 | Name | Description
public Field | index | The index of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value 0 and the length property will probably be greater than 1.
public Field | length | The number of points which are related to the event.
public Field | point | A copy of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value undefined.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

index Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs : index Field
The index of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value 0 and the length property will probably be greater than 1.
Syntax
ASP.NET Ajax Javascript (Specification)
var index : Integer;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointEventArgs.index;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
PointEventArgs Members


%%PageItemTitle%%

length Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs : length Field
The number of points which are related to the event.
Syntax
ASP.NET Ajax Javascript (Specification)
var length : Integer;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointEventArgs.length;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
PointEventArgs Members


%%PageItemTitle%%

point Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs : point Field
A copy of the point which is most directly related to the event. If all the points were affected (such as when you call PointCollection.removeAllPoints), then this property will have the value undefined.
Syntax
ASP.NET Ajax Javascript (Specification)
var point : Point;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfPointEventArgs.point;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.PointEventArgs
PointEventArgs Members


%%PageItemTitle%%

Rectangle class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Rectangle class
A rectangle in an X/Y coordinate space.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Rectangle = function(
   x : Number,
   y : Number,
   width : Number,
   height : Number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Rectangle();
Remarks

This object has x, y, width, and height properties and represents a rectangle in a cartesian coordinate space. The ImageGear product uses this object in a variety of places to represent an area on a window or on an image.

Inheritance Hierarchy

Object
ImageGear.Web.UI.Rectangle

See Also

Reference

Rectangle Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

Rectangle class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Rectangle class

The following tables list the members exposed by Rectangle.

Public Constructors
 | Name | Description
public Constructor | Rectangle Constructor |
Top
Public Fields
 | Name | Description
public Field | height | The height of the rectangle.
public Field | width | The width of the rectangle.
public Field | x | The x coordinate of the rectangle (representing the left side).
public Field | y | The y coordinate of the rectangle (representing the top edge).
Top
Public Methods
 | Name | Description
public Method | clone | Creates a copy of the rectangle.
public Method | contains | Indicates whether the rectangle contains a given point.
public Method | equals | Compares two rectangles.
public Method | intersect | Modifies the object to represent the intersection of this rectangle with another.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

Rectangle Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : Rectangle Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.Rectangle = function(
   x : Number,
   y : Number,
   width : Number,
   height : Number
) {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.Rectangle(Number,Number,Number,Number);

Parameters

x
y
width
height
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%% $$Methods$$

Rectangle class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Rectangle class

For a list of all members of this type, see Rectangle members.

Public Methods
 | Name | Description
public Method | clone | Creates a copy of the rectangle.
public Method | contains | Indicates whether the rectangle contains a given point.
public Method | equals | Compares two rectangles.
public Method | intersect | Modifies the object to represent the intersection of this rectangle with another.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

clone Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : clone Method
Creates a copy of the rectangle.
Syntax
ASP.NET Ajax Javascript (Specification)
function clone() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.clone();
Remarks

This function creates a copy of the rectangle.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

contains Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : contains Method
Indicates whether the rectangle contains a given point.
Syntax
ASP.NET Ajax Javascript (Specification)
function contains(
   point : Point
) : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.contains(Point);

Parameters

point
The point to examine.

Return Value

True if the point lies inside the rectangle or false otherwise.
Remarks

This function compares the given point to the rectangle that this object represents and returns true if the point lies inside the rectangle.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

equals Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : equals Method
Compares two rectangles.
Syntax
ASP.NET Ajax Javascript (Specification)
function equals() : String;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.equals();

Return Value

True if this rectangle and a given other rectangle have the same value or false otherwise.
Remarks

This function compares two rectangles.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

intersect Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : intersect Method
Modifies the object to represent the intersection of this rectangle with another.
Syntax
ASP.NET Ajax Javascript (Specification)
function intersect(
   rectangle : Rectangle
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.intersect(Rectangle);

Parameters

rectangle
The rectangle to intersect with this object.
Remarks

This function will modify the rectangle represented by this object to contain only the intersection of this rectangle with another.

If this rectangle does not intersect with the specified one, this function will set the x, y, width, and height properties to zero.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%% $$Fields$$

Rectangle class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Rectangle class

For a list of all members of this type, see Rectangle members.

Public Fields
 | Name | Description
public Field | height | The height of the rectangle.
public Field | width | The width of the rectangle.
public Field | x | The x coordinate of the rectangle (representing the left side).
public Field | y | The y coordinate of the rectangle (representing the top edge).
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

height Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : height Field
The height of the rectangle.
Syntax
ASP.NET Ajax Javascript (Specification)
var height : Number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.height;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

width Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : width Field
The width of the rectangle.
Syntax
ASP.NET Ajax Javascript (Specification)
var width : Number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.width;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

x Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : x Field
The x coordinate of the rectangle (representing the left side).
Syntax
ASP.NET Ajax Javascript (Specification)
var x : Number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.x;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

y Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle : y Field
The y coordinate of the rectangle (representing the top edge).
Syntax
ASP.NET Ajax Javascript (Specification)
var y : Number;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfRectangle.y;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.Rectangle
Rectangle Members


%%PageItemTitle%%

ThumbnailView class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailView class
This is an ASP.NET client control for viewing thumbnails.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ThumbnailView = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ThumbnailView();
Remarks

This ASP.NET client control is a thumbnail viewer. This control represents a single thumbnail, so in normal applications, you will need to have one ThumbnailView control on your page for each thumbnail you wish to display.

While it is possible to create an instance of this control using client-side JavaScript, you will normally create it by placing a server-side ThumbnailView control on an aspx page. If you wish to create an instance of this control using client-side JavaScript, take the following steps:

  • Add an empty <DIV> to your HTML.
  • Give your <DIV> a unique ID (Example:ThumbnailView1).
  • Give your <DIV> a size, using either a CSS style sheet or an inline style. If your thumbnails will be arranged in a single column, set the width to 100% and the height to a size in pixels. If your thumbnails will be arranged in a grid, set both the width and height to a size in pixels.
  • If using Microsft Ajax library, add the following code to your page.
    $create(ImageGear.Web.UI.ThumbnailView,{ imageHandlerUrl: "ImageGearService.svc" }, null, null, $get("ThumbnailView1"));
  • If using ImageGear jQuery Plugins, add the following code to your page.
    $("#ThumbnailView1").ImGearThumbnailViewPlugin({ imageHandlerUrl: "ImageGearService.svc" });
Inheritance Hierarchy

Object
Sys.Component
Sys.UI.Control
ImageGear.Web.UI.ThumbnailView

See Also

Reference

ThumbnailView Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ThumbnailView class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailView class

The following tables list the members exposed by ThumbnailView.

Public Constructors
 | Name | Description
public Constructor | ThumbnailView Constructor |
Top
Public Properties
 | Name | Description
public Property | artPage | Indicates the ArtPage that contains the marks that are shown on the image.
public Property | artServiceOption | Indicates ImagedataService option.
public Property | controlStateElementId | Indicates the id of the HTML element that will hold the state of this control.
public Property | currentState | Indicates the current state of the control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Indicates how much information the control will log.
public Property | documentIdentifier | Indicates the image identifier of the current image.
public Property | documentPageCount | Indicates the number of images in the file that contains the current image.
public Property | encodedDocumentIdentifier | Indicates the encoded image identifier of the current image.
public Property | imageHandlerUrl | Indicates the absolute URL to the image handler.
public Property | includeArtInPostBack | Indicates whether the current annotations will be included in the state posted back to the server.
public Property | pageNumber | Indicates the page index of the current image.
public Property | pageViewClientID | Indicates the id of the PageView control associated with this thumbnail.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | selected | Indicates whether the thumbnail is selected.
public Property | vectorFormatsRendering | Indicates how the viewer will render vector format images.
Top
Public Methods
 | Name | Description
public Method | closePage | Close the current image.
public Method | display | Forces the ThumbnailView control to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the viewer.
public Method | openPage | Open a new image.
public Method | saveArtPage | Saves all art marks on a page using ImageGear service.
public Method | writeToLog | Writes a user-defined event to the log.
Top
Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates the viewer failed to open ART data for requested page.
public Event | contextMenu | Indicates the user activated the context menu.
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageClosed | Indicates the viewer has closed the current image.
public Event | pageDisplayed |
public Event | pageOpened | Indicates the viewer has finished opening a new image.
public Event | pageOpenFailed | Indicates the viewer failed to open a new image.
public Event | pageOpening | Indicates the viewer is opening a new image.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ThumbnailView Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : ThumbnailView Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ThumbnailView = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ThumbnailView();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%% $$Methods$$

ThumbnailView class Methods

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailView class

For a list of all members of this type, see ThumbnailView members.

Public Methods
 | Name | Description
public Method | closePage | Close the current image.
public Method | display | Forces the ThumbnailView control to update its visual presentation immediately.
public Method | dispose | Disposes of the resources held by the viewer.
public Method | openPage | Open a new image.
public Method | saveArtPage | Saves all art marks on a page using ImageGear service.
public Method | writeToLog | Writes a user-defined event to the log.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

closePage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : closePage Method
Close the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function closePage() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.closePage();
Remarks

This function causes the viewer to close the current image, reverting the viewer back to a state where it is not displaying an image. Unlike the openPage function, this function does not need to interact with the server, so it will complete it's operation (including raising the pageClosed event) before it returns. Like most other viewer operations, the visual appearance of the viewer will not be updated immediately; instead the viewer will wait until the browser is idle before updating its appearance.

If you call this function while an openPage operation is pending, the control will cancel the pending operation and it will not raise the cancelled pageOpened event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

display Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : display Method
Forces the ThumbnailView control to update its visual presentation immediately.
Syntax
ASP.NET Ajax Javascript (Specification)
function display() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.display();
Remarks

Forces the ThumbnailView control to update its visual presentation immediately. Normally, the viewer will wait until the browser is idle before updating the visual presentation.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

dispose Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : dispose Method
Disposes of the resources held by the viewer.
Syntax
ASP.NET Ajax Javascript (Specification)
function dispose() : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.dispose();
Remarks

This function disposes of the resources held by this viewer and removes its user interface. After you call this function, you will not be able to use this instance of the viewer again.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

openPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : openPage Method
Open a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function openPage(
   parameters : ThumbnailViewState
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.openPage(ThumbnailViewState);

Parameters

parameters
An object whose properties are accepted as parameters of this function. Optionally, you may use a JavaScript object literal instead of constructing a new object.
Remarks

This function causes the viewer to begin the process of opening a new image. That process will involve communicating with the server, raising various events, selecting a scaling value with which to display the image, and then updating the presentation of the viewer. During execution of this function, the viewer will raise the pageOpening event, then begin communicating with the server. In a few cases, the conversation with the server will complete before the openPage function returns, but usually, it will not. After this function returns, but before the communication with the server is complete, you can continue to interact with the previous image opened in the viewer. You must be careful in this case because the viewer will immediately discard the current image when the new image finishes opening. Once the conversation with the server is complete, the viewer will update the various image properties (such as documentIdentifier, etc.) and then raise the pageOpened event.

If you call this function and provide an empty string as the image identifier, this function will close the image instead of opening it (and it will raise the pageClosed event instead of pageOpening and pageOpened).

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

saveArtPage Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : saveArtPage Method
Saves all art marks on a page using ImageGear service.
Syntax
ASP.NET Ajax Javascript (Specification)
function saveArtPage(
   onSave : function
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.saveArtPage(function);

Parameters

onSave
The function to call when art page is saved.
Remarks
This method uses ImageGear service to save all art marks on a page. The previous art marks for the page are overwritten.

This method is useful for saving art page when the ThumbnailView control is created using client side API.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

writeToLog Method

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : writeToLog Method
Writes a user-defined event to the log.
Syntax
ASP.NET Ajax Javascript (Specification)
function writeToLog(
   message : string
) : (Any);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.writeToLog(string);

Parameters

message
The message to write to the log.
Remarks

The viewer writes a wide variety of information to the log and this function allows you to add your own information to that same log. Normally, you would use this function to send key events to the log so you can see the larger context of events that this product writes into its log.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%% $$Properties$$

ThumbnailView class Properties

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailView class

For a list of all members of this type, see ThumbnailView members.

Public Properties
 | Name | Description
public Property | artPage | Indicates the ArtPage that contains the marks that are shown on the image.
public Property | artServiceOption | Indicates ImagedataService option.
public Property | controlStateElementId | Indicates the id of the HTML element that will hold the state of this control.
public Property | currentState | Indicates the current state of the control.
public Property | debug | Indicates whether the control should log its actions.
public Property | debugErrorLevel | Indicates how much information the control will log.
public Property | documentIdentifier | Indicates the image identifier of the current image.
public Property | documentPageCount | Indicates the number of images in the file that contains the current image.
public Property | encodedDocumentIdentifier | Indicates the encoded image identifier of the current image.
public Property | imageHandlerUrl | Indicates the absolute URL to the image handler.
public Property | includeArtInPostBack | Indicates whether the current annotations will be included in the state posted back to the server.
public Property | pageNumber | Indicates the page index of the current image.
public Property | pageViewClientID | Indicates the id of the PageView control associated with this thumbnail.
public Property | resourcePath | Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
public Property | selected | Indicates whether the thumbnail is selected.
public Property | vectorFormatsRendering | Indicates how the viewer will render vector format images.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPage Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : artPage Property
Indicates the ArtPage that contains the marks that are shown on the image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artPage() : ArtPage
function set_artPage(value : ArtPage)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_artPage();
Remarks

Indicates the ArtPage that contains the marks that are shown on the image.

Whenever you change this property to a different ArtPage, or make a change to one of the Mark objects contained in the ArtPage, this viewer will schedule a redraw for the next idle period. If you wish the viewer to redraw itself immediately, call the display function.

Note that multiple PageView and ThumbnailView controls can all reference the same ArtPage object, in which case all of them will automatically redraw themselves as necessary.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

artServiceOption Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : artServiceOption Property
Indicates ImagedataService option.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_artServiceOption() : ImGearArtDataServices
function set_artServiceOption(value : ImGearArtDataServices)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_artServiceOption();
Remarks

This property lets you choose ImageGear Art Data Service.

If the ThumbnailView control is created using client side API and annotations data are required from the server either for reading or for updating, then this property value must be set to the enumeration field ImageGear.Web.UI.ImGearArtDataServices.ArtDataService.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

controlStateElementId Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : controlStateElementId Property
Indicates the id of the HTML element that will hold the state of this control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_controlStateElementId() : String
function set_controlStateElementId(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_controlStateElementId();
Remarks

This property is a string that contains the id of an HTML element that will hold the state of this control. It is for internal use only and the server-side ASP.NET control automatically sets this property to the correct value. If you are not using the server-side ASP.NET control, then you should not use this property because it is only used to convey the client-side control's state back to the server-side control.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

currentState Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : currentState Property
Indicates the current state of the control.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_currentState() : ThumbnailViewState
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_currentState();
Remarks

This read-only property will be an ImageGear.Web.UI.ThumbnailViewState object that contains the state of the viewer, including such things as the image identifier and the current state of the selected property. Note that if you call openPage, the value of this property will immediately change to reflect the image to be opened, even if the opening process has not completed (and the viewer has not yet raised the pageOpened event).

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

debug Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : debug Property
Indicates whether the control should log its actions.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debug() : Boolean
function set_debug(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_debug();
Example

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

If using Microsoft Ajax Library

var thumb1 = $find('ThumbnailView1');
thumb1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
thumb1.set_debug(true);

If using ImageGear jQuery plugins

$("#ThumbnailView1").ImGearThumbnailViewPlugin().set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
$("#ThumbnailView1").ImGearThumbnailViewPlugin().set_debug(true);

This JavaScript code implements the onImageGearItemLogged function, which will automatically receive items that any Accusoft control logs.

  • JavaScript
function onImageGearItemLogged(logItem) {
}
Remarks

This property turns the control's logging on or off. If you set this to true, the control will log its activities via the ASP.NET client-side trace facility.

You can set the amount of information that the viewer will log using the debugErrorLevel property.

The ASP.NET client-side trace facility is documented in MSDN, but to summarize, the client framework will send trace text to the following locations:

  • A textarea element on your page with an id of "TraceConsole"
  • The IE8 Developer Tools Console window
  • The FireBug Console window
  • The Visual Studio Output window

In addition to the locations that the ASP.NET client-side trace facility sends trace text, this control will send all logged items (with the data to be logged in a LogItemEventArgs object) to a global function, if it is present. In order to use this facility, you need to define a global JavaScript function in your client page called "onImageGearItemLogged".

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

debugErrorLevel Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : debugErrorLevel Property
Indicates how much information the control will log.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_debugErrorLevel() : DebugErrorLevel
function set_debugErrorLevel(value : DebugErrorLevel)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_debugErrorLevel();
Example

This JavaScript code will turn on logging and set the level to log exceptions, calls to viewer functions, and calls to change the value of viewer properties:

If using Microsoft Ajax Library

var thumbnailViewer1 = $find('ThumbnailViewer1');
thumbnailViewer1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
thumbnailViewer1.set_debug(true);

If using ImageGear jQuery plugins

var thumbnailViewer1 = $("#ThumbnailView1").ImGearThumbnailViewPlugin();
thumbnailViewer1.set_debugErrorLevel(ImageGear.Web.UI.DebugErrorLevel.Development);
thumbnailViewer1.set_debug(true);

Remarks

This property sets the amount of information the control will log.

In addition to setting this property, you must turn logging on using the debug property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

documentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : documentIdentifier Property
Indicates the image identifier of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documentIdentifier() : String
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_documentIdentifier();
Remarks

This read-only property will be the image identifier for the current image, or an empty string if the viewer does not have a currently-open image. This property will always match the encodedDocumentIdentifier property, except that encodedDocumentIdentifier is base64-encoded so the control can safely use it in a URL or in JavaScript code.

Note that if you call the openPage function, this property will not change to match the new image identifier until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or an empty string if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

documentPageCount Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : documentPageCount Property
Indicates the number of images in the file that contains the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_documentPageCount() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_documentPageCount();
Remarks

This read-only property will be the number of images in the file that contains the current image, or zero if the viewer does not have a currently-open image.

Note that if you call the openPage function, this property will not change to match the new page count until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or zero if there is no previously-opened image.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

encodedDocumentIdentifier Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : encodedDocumentIdentifier Property
Indicates the encoded image identifier of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_encodedDocumentIdentifier() : String
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_encodedDocumentIdentifier();
Remarks

This read-only property will be the encoded image identifier for the current image, or an empty string if the viewer does not have a currently-open image. This property will always match the documentIdentifier property, except that this one is base64-encoded so the control can safely use it in a URL or in JavaScript code.

Note that if you call the openPage function, this property will not change to match the new image identifier until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or an empty string if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

imageHandlerUrl Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : imageHandlerUrl Property
Indicates the absolute URL to the image handler.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_imageHandlerUrl() : String
function set_imageHandlerUrl(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_imageHandlerUrl();
Remarks

This property is a string that contains the absolute URL for the image handler. The image handler is an ASP.NET handler that supports various operations of the viewer.

Note that you could use a relative URL for the image handler in most cases, but some versions of FireFox will fail if this URL is not absolute.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

includeArtInPostBack Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : includeArtInPostBack Property
Indicates whether the current annotations will be included in the state posted back to the server.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_includeArtInPostBack() : Boolean
function set_includeArtInPostBack(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_includeArtInPostBack();
Remarks

This property indicates whether the current annotations will be included in the state posted back to the server. It is for internal use only and you should use the server-side control property, (TBD) instead. If you are not using the server-side ASP.NET control, then you should not use this property because it is only used to convey the client-side control's state back to the server-side control.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageNumber Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageNumber Property
Indicates the page index of the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageNumber() : Integer
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_pageNumber();
Remarks

This read-only property will be the image page index for the current image, or -1 if the viewer does not have a currently-open image. The first page of a file has an image page index of zero.

Note that if you call the openPage function, this property will not change to match the new image page index until the image is fully opened, which will occur just before the viewer raises the pageOpened event. Prior to that time, this property will continue to hold the value for the previously-opened image or -1 if there is no previously-opened image. If you need the new value of this property before the viewer raises the pageOpened event, use the currentState property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageViewClientID Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageViewClientID Property
Indicates the id of the PageView control associated with this thumbnail.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_pageViewClientID() : String
function set_pageViewClientID(value : String)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_pageViewClientID();
Remarks

This property is a string that contains the id of the PageView control that should display the image displayed in this thumbnail view when you change the value of the selected property from false to true.

It is common for applications of a ThumbnailView control to display the selected thumbnail in a larger viewer and this property makes it easier for you to implement that kind of application. Simply set this property (for all of your ThumbnailView controls) to the id of the PageView you want to use and then add JavaScript to set the selected property of a ThumbnailView control to true when a user clicks on it. The control will automatically change the selected property back to false if you open a different image in the PageView.

You will typically want to adjust your HTML so that the selected ThumbnailView control is visibly different from the rest. The best way to do this is to add a propertyChanged event handler to each of your ThumbnailView controls. In that event handler, ignore all events except for changes to the selected property and either add or remove a CSS class based on the new value of that property.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

resourcePath Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : resourcePath Property
Indicates the resource Url path for the image files required for the menu icons and the art mark handles.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_resourcePath() : string
function set_resourcePath(value : string)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_resourcePath();
Remarks

This property is a string that specifies the image files required for the menu icons and and the art mark handles. These files are png format files and are required when using ThumbnailView control created on the client side. Note: It is necessary for this property to be set when using server side controls.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

selected Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : selected Property
Indicates whether the thumbnail is selected.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_selected() : Boolean
function set_selected(value : Boolean)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_selected();
Remarks

This property is a boolean that indicates whether the thumbnail is selected. In most cases, this property is simply a storage location for the selected flag. However, if you change the value from false to true, you have provided the id of an PageView control, and you have opened an image in this control, this control will instruct the PageView control to open the same image.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

vectorFormatsRendering Property

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : vectorFormatsRendering Property
Indicates how the viewer will render vector format images.
Syntax
ASP.NET Ajax Javascript (Specification)
function get_vectorFormatsRendering() : VectorFormatsRendering
function set_vectorFormatsRendering(value : VectorFormatsRendering)
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailView.get_vectorFormatsRendering();
Remarks
This property defines the option for rendering vector format images. It must be set to one of the values in the enumeration VectorFormatsRendering. Default value ImageGear.Web.UI.VectorFormatsRendering.SVG defines the mode of rendering of vector format images through SVG format. Set the value of this property to ImageGear.Web.UI.VectorFormatsRendering.Raster for using PNG or JPEG raster formats for rendering of vector format images.
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%% $$Events$$

ThumbnailView class Events

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailView class

For a list of all members of this type, see ThumbnailView members.

Public Events
 | Name | Description
public Event | artPageOpenFailed | Indicates the viewer failed to open ART data for requested page.
public Event | contextMenu | Indicates the user activated the context menu.
public Event | mouseDown | Indicates the user pressed a mouse button.
public Event | mouseMove | Indicates the user moved the mouse.
public Event | mouseUp | Indicates the user released a mouse button.
public Event | pageClosed | Indicates the viewer has closed the current image.
public Event | pageDisplayed |
public Event | pageOpened | Indicates the viewer has finished opening a new image.
public Event | pageOpenFailed | Indicates the viewer failed to open a new image.
public Event | pageOpening | Indicates the viewer is opening a new image.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

artPageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : artPageOpenFailed Event
Indicates the viewer failed to open ART data for requested page.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_artPageOpenFailed(handler : Function)
function remove_artPageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_artPageOpenFailed(handler);
.remove_artPageOpenFailed(handler);
Remarks

The viewer will raise this event whenever it fails to load ART data for requested page (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after a call to the openPage function fails to load a page.

When the viewer raises this event, it will provide an instance of an exception object ImGearPageOpenFailedEventArgs as the event argument. This object contains the page number for ART data that is requested. Also, this object contains an exception object, which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

contextMenu Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : contextMenu Event
Indicates the user activated the context menu.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_contextMenu(handler : Function)
function remove_contextMenu(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_contextMenu(handler);
.remove_contextMenu(handler);
Remarks

The viewer will raise this event whenever the user activates the context menu by pressing and releasing the right mouse button while the cursor is over any part of the viewer (except the scrollbars).

On some browsers (Internet Explorer 8), a user can also cause the viewer to raise this event by pressing the context menu button on the keyboard.

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

mouseDown Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : mouseDown Event
Indicates the user pressed a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseDown(handler : Function)
function remove_mouseDown(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseDown(handler);
.remove_mouseDown(handler);
Remarks

The viewer will raise this event whenever the user presses a mouse button while the cursor is over any part of the thumbnail viewer.

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

mouseMove Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : mouseMove Event
Indicates the user moved the mouse.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseMove(handler : Function)
function remove_mouseMove(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseMove(handler);
.remove_mouseMove(handler);
Remarks

The viewer will raise this event whenever the user moves the mouse over any part of the thumbnail viewer.

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

mouseUp Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : mouseUp Event
Indicates the user released a mouse button.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_mouseUp(handler : Function)
function remove_mouseUp(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_mouseUp(handler);
.remove_mouseUp(handler);
Remarks

The viewer will raise this event whenever the user releases a mouse button while the cursor is over any part of the thumbnail viewer.

The event argument be an instance of the MouseEventArgs object, containing information useful specifically for image viewing operations, as well as the original ASP.NET client framework event.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageClosed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageClosed Event
Indicates the viewer has closed the current image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageClosed(handler : Function)
function remove_pageClosed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageClosed(handler);
.remove_pageClosed(handler);
Remarks

The viewer will raise this event in the following conditions:

  • You called the closePage function and the viewer had an image open.
  • You called the openPage function, there was an image already open, and the new image was different from the old image.
  • You called the dispose function and the viewer had an image open (or the ASP.NET client framework called dispose on your behalf when the page was closed or an UpdatePanel containing the viewer was reloaded).

When the viewer raises this event, it will provide an instance of an ThumbnailViewState object as the event argument. This object will contain the state of the viewer just before the image was closed.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageDisplayed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageDisplayed Event
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageDisplayed(handler : Function)
function remove_pageDisplayed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageDisplayed(handler);
.remove_pageDisplayed(handler);
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageOpened Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageOpened Event
Indicates the viewer has finished opening a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpened(handler : Function)
function remove_pageOpened(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpened(handler);
.remove_pageOpened(handler);
Remarks

The viewer will raise this event whenever it finishes opening a new image (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after the openPage function returns, but in some cases the viewer will raise it before openPage returns.

When the viewer raises this event, it will provide an instance of an ThumbnailViewState object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageOpenFailed Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageOpenFailed Event
Indicates the viewer failed to open a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpenFailed(handler : Function)
function remove_pageOpenFailed(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpenFailed(handler);
.remove_pageOpenFailed(handler);
Remarks

The viewer will raise this event whenever it fails to open new image (usually as the result of a call to the openPage function).

Because the viewer must interact with the server, there will be some delay between the time you call openPage and the time the viewer raises this event. Normally, the viewer will raise this event after a call to the openPage function fails to load a page.

When the viewer raises this event, it will provide an instance of an exception object ImGearPageOpenFailedEventArgs as the event argument. This object contains an exception object, which may be of the following type in the list:

  • ImageGear.Web.UI.ImGearHttpException, for details see, ImGearHttpException
  • ImageGear.Web.UI.ImGearArgumentException, for details see, ImGearArgumentException
  • ImageGear.Web.UI.ImGearArgumentOutOfRangeException, for details see, ImGearArgumentOutOfRangeException
  • ImageGear.Web.UI.ImGearInvalidOperationException, for details see, ImGearInvalidOperationException
  • ImageGear.Web.UI.ImGearNotImplementedException, for details see, ImGearNotImplementedException
  • ImageGear.Web.UI.ImGearParameterCountException, for details see, ImGearParameterCountException
  • ImageGear.Web.UI.ImGearArgumentTypeException, for details see, ImGearArgumentTypeException
  • ImageGear.Web.UI.ImGearArgumentNullException, for details see, ImGearArgumentNullException
  • ImageGear.Web.UI.ImGearArgumentUndefinedException, for details see, ImGearArgumentUndefinedException

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

pageOpening Event

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView : pageOpening Event
Indicates the viewer is opening a new image.
Syntax
ASP.NET Ajax Javascript (Specification)
function add_pageOpening(handler : Function)
function remove_pageOpening(handler : Function)
ASP.NET Ajax Javascript (Usage)
.add_pageOpening(handler);
.remove_pageOpening(handler);
Remarks

The viewer will raise this event whenever it begins to open a new image (usually as the result of a call to the openPage function).

Note that between this event and the following pageOpened event, the viewer is in a transitional state between the current image and the new image. While in that state, the viewer will continue to display and allow the user to interact with the current image. In addition, nearly all properties of this control (such as documentIdentifier and pageNumber) will continue to reflect the attributes of the current image. Unlike the other properties, currentState will update during the call to openPage instead of waiting for the pageOpened event. As soon as the server responds with information about the new image, the viewer will discard the current image and begin viewing the new image.

If you call openPage a second time before the first pageOpened event is raised, the viewer will ignore the first call and stay in the transitional state until the second image has completed opening.

When the viewer raises this event, it will provide an instance of an ThumbnailViewState object as the event argument.

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailView
ThumbnailView Members


%%PageItemTitle%%

ThumbnailViewState class
Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailViewState class
The control state of a ThumbnailView control.
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ThumbnailViewState = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ThumbnailViewState();
Remarks

This object represents the state of a ThumbnailView control. In some cases it will represent an actual state of a ThumbnailView control and in other cases it will represent a target state of a ThumbnailView control.

Normally, the client and server portions of a ThumbnailView control will use this object to manage the control's state without any assistance, but there are a few cases where you must use this object yourself.

  • If you call the ImageGear.Web.UI.ThumbnailView.openPage function, you must create an object of this type in order to specify the image to open and how you want it to be initially displayed.
  • If you call the ImageGear.Web.UI.ThumbnailView.get_currentState function, it will return an object of this type.
  • The ImageGear.Web.UI.ThumbnailView.pageOpening, ImageGear.Web.UI.ThumbnailView.pageOpened, and ImageGear.Web.UI.ThumbnailView.pageClosed events all use an object of this type to hold the event arguments.

Most of the values in this object are fairly easy to understand, but the documentIdentifier and encodedDocumentIdentifier may be a little confusing. Because the ImageGear product allows you to use any characters (including symbols and unicode characters) in document identifiers, it uses base64 encoding to ensure they are suitable for use in a URL. Unfortunately, there are use cases where you will want to use an encoded document identifier and cases where you will want to use an unencoded document identifier. To support both types of use cases, the ImageGear product gives you read access to both forms of the document identifier and allows you to specify either type when you open a page. For example, when an ThumbnailView returns an object of this type, it will set both the documentIdentifier value to the unencoded document identifier and the encodedDocumentIdentifier to an encoded version of the same document identifier. When you provide an instance of this object to the ImageGear.Web.UI.ThumbnailView.openPage function, you can specify either value (or set them both to reference the same document identifier).

Inheritance Hierarchy

Object
ImageGear.Web.UI.ThumbnailViewState

See Also

Reference

ThumbnailViewState Members
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%% $$Members$$

ThumbnailViewState class Members

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailViewState class

The following tables list the members exposed by ThumbnailViewState.

Public Constructors
 | Name | Description
public Constructor | ThumbnailViewState Constructor |
Top
Public Fields
 | Name | Description
public Field | documentIdentifier | The identifier of a document.
public Field | encodedDocumentIdentifier | The identifier of a document, encoded using a form of base64 encoding.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
public Field | selected | A flag indicating whether the thumbnail is selected.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ThumbnailViewState Constructor

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState : ThumbnailViewState Constructor
Syntax
ASP.NET Ajax Javascript (Specification)
ImageGear.Web.UI.ThumbnailViewState = function() {};
ASP.NET Ajax Javascript (Usage)
var instanceVar = new ImageGear.Web.UI.ThumbnailViewState();
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ThumbnailViewState Members


%%PageItemTitle%% $$Fields$$

ThumbnailViewState class Fields

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ThumbnailViewState class

For a list of all members of this type, see ThumbnailViewState members.

Public Fields
 | Name | Description
public Field | documentIdentifier | The identifier of a document.
public Field | encodedDocumentIdentifier | The identifier of a document, encoded using a form of base64 encoding.
public Field | pageNumber | The page index of a page in a multi-page document. The first page in a file is index 0.
public Field | selected | A flag indicating whether the thumbnail is selected.
Top
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

documentIdentifier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState : documentIdentifier Field
The identifier of a document.
Syntax
ASP.NET Ajax Javascript (Specification)
var documentIdentifier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailViewState.documentIdentifier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ThumbnailViewState Members


%%PageItemTitle%%

encodedDocumentIdentifier Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState : encodedDocumentIdentifier Field
The identifier of a document, encoded using a form of base64 encoding.
Syntax
ASP.NET Ajax Javascript (Specification)
var encodedDocumentIdentifier : string;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailViewState.encodedDocumentIdentifier;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ThumbnailViewState Members


%%PageItemTitle%%

pageNumber Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState : pageNumber Field
The page index of a page in a multi-page document. The first page in a file is index 0.
Syntax
ASP.NET Ajax Javascript (Specification)
var pageNumber : number(Integer);
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailViewState.pageNumber;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ThumbnailViewState Members


%%PageItemTitle%%

selected Field

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState : selected Field
A flag indicating whether the thumbnail is selected.
Syntax
ASP.NET Ajax Javascript (Specification)
var selected : boolean;
ASP.NET Ajax Javascript (Usage)
var resultVar = instanceOfThumbnailViewState.selected;
See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI.ThumbnailViewState
ThumbnailViewState Members


%%PageItemTitle%%

CalloutType Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : CalloutType Enumeration
Indicates the type of a text callout.
Members
Member | Description
Line | 0 - A line. This is the same type as ImageGear for .NET's ImGearARTCalloutType.LINE.
Triangle | 1 - A triangle pointed away from the text mark. This is the same type as ImageGear for .NET's ImGearARTCalloutType.TRIANGLE.
Remarks

This enumeration indicates the style of a text callout. A text callout is a line or triangle that connects a text mark and the part of the image to which the text mark is related. NotateXpress (version 10) does not have callouts for text marks.

Inheritance Hierarchy

Object
ImageGear.Web.UI.CalloutType

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ContextMenuItemType Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ContextMenuItemType Enumeration
Specifies the list of available context menu item types.
Members
Member | Description
ActualSize | 8 - "Actual Size" menu item.
AreaSelectionTool | 16 - "Area Selection Tool" menu item.
BorderColor | 46 - "Border Color..." menu item.
CalloutLine | 43 - "Line" menu item for text mark.
CalloutTriangle | 44 - "Triangle" menu item for text mark.
CalloutVisible | 45 - "Callout Visible" menu item for text mark.
Color | 47 - "Color..." menu item.
CreateEllipseMark | 23 - "Create Ellipse Mark" menu item.
CreateFreehandMark | 24 - "Create Freehand Mark" menu item.
CreateLineMark | 19 - "Create Line Mark" menu item.
CreatePolygonMark | 20 - "Create Polygon Mark" menu item.
CreatePolylineMark | 21 - "Create Polyline Mark" menu item.
CreateRectangleMark | 22 - "Create Rectangle Mark" menu item.
CreateTextMark | 18 - "Create Text Mark" menu item.
DeleteMark | 30 - "Delete Mark" menu item.
EditMarks | 17 - "Edit Marks" menu item.
EvenOdd | 41 - "Even Odd (0)" menu item.
FillColor | 48 - "Fill Color..." menu item.
FlyingMagnigierTool | 15 - "Flying Magnigier Tool" menu item.
Font | 49 - "Font..." menu item.
FullHeight | 6 - "Full Height" menu item.
FullImage | 4 - "Full Image" menu item.
FullWidth | 5 - "Full Width" menu item.
MirrorHorz | 11 - "Mirror Horizontal" menu item.
MirrorVert | 12 - "Mirror Vertical" menu item.
MoveBackward | 27 - "Move Backward" menu item.
MoveForward | 28 - "Move Forward" menu item.
MoveToBack | 26 - "Move to Back" menu item.
MoveToFront | 29 - "Move to Front" menu item.
NonZero | 42 - "Non Zero (0)" menu item.
OneToOneRatio | 7 - "One To One Ratio" menu item.
Opaque | 40 - Type of menu item for set opacity property of mark as opaque.
PanTool | 13 - "Pan Tool" menu item.
Popup | 1 - Popup menu item.
RotateCCW | 10 - "Rotate Counter Clockwise" menu item.
RotateCW | 9 - "Rotate Clockwise" menu item.
RunMarks | 25 - "Run Marks" menu item.
Separator | 0 - Separator menu item.
Thickness_1 | 31 - Type of menu item for set lineWidth property of mark as 1.
Thickness_2 | 32 - Type of menu item for set lineWidth property of mark as 2.
Thickness_3 | 33 - Type of menu item for set lineWidth property of mark as 3.
Thickness_4 | 34 - Type of menu item for set lineWidth property of mark as 4.
Thickness_5 | 35 - Type of menu item for set lineWidth property of mark as 5.
Thickness_6 | 36 - Type of menu item for set lineWidth property of mark as 6.
Thickness_7 | 37 - Type of menu item for set lineWidth property of mark as 7.
Thickness_8 | 38 - Type of menu item for set lineWidth property of mark as 8.
Translucent | 39 - Type of menu item for set opacity property of mark as translucent.
UserMenuItem | 500 - Type of user menu item.
ZoomIn_25 | 2 - "Zoom In 25%" menu item.
ZoomOut_25 | 3 - "Zoom Out 25%" menu item.
ZoomRectangleTool | 14 - "Zoom Rectangle Tool" menu item.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ContextMenuItemType

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

DebugErrorLevel Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : DebugErrorLevel Enumeration
Indicates how much information the control will log (if logging is turned on).
Members
Member | Description
Detailed | 2 - In addition to the logging done by the Development level, log all properties read by the page. The text of the log entry will include the name of the property and its current value.
Development | 1 - In addition to the logging done by the Production level, log all control functions that are called by the page and any properties that are changed by the page. The text of the log entry will include the name of the function, the values of the parameters, and the return value (if any).
Production | 0 - Log only exceptions that occu///r inside the control or an event handler.
Inheritance Hierarchy

Object
ImageGear.Web.UI.DebugErrorLevel

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

DebugItemCause Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : DebugItemCause Enumeration
Indicates the cause of a debug item.
Members
Member | Description
Custom | 2 - Indicates a log item is a result of a call to the ImageGear.Web.UI.PageView.writeToLog or ImageGear.Web.UI.ThumbnailView.writeToLog functions.
Exception | 1 - Indicates a log item is a result of an exception.
FunctionCall | 0 - Indicates a log item is a result of a JavaScript call made to an Accusoft control. Note that items with this cause may also be due to an Accusoft control calling a different control (such as when a ImageGear.Web.UI.ThumbnailView control interacts with its associated ImageGear.Web.UI.PageView).
UserAction | 3 - Indicates a log item is a result of a user's interaction with the user interface of a control.
Warning | 4 - Indicates a log item is a result of a warning.
Inheritance Hierarchy

Object
ImageGear.Web.UI.DebugItemCause

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

FillRule Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : FillRule Enumeration
Indicates the fill rule of a polygon mark.
Members
Member | Description
EvenOdd | 0 - A even-odd fill rule. This is the same type as ImageGear for .NET's ImGearARTFillRule.EvenOdd. This rule determines the "insideness" of a point on the canvas by drawing a ray from that point to infinity in any direction and counting the number of path segments from the given shape that the ray crosses. If this number is odd, the point is inside; if even, the point is outside.
NonZero | 1 - A non-zero fill rule. This is the same type as ImageGear for .NET's ImGearARTFillRule.NonZero. This rule determines the "insideness" of a point on the canvas by drawing a ray from that point to infinity in any direction and then examining the places where a segment of the shape crosses the ray. Starting with a count of zero, add one each time a path segment crosses the ray from left to right and subtract one each time a path segment crosses the ray from right to left. After counting the crossings, if the result is zero then the point is outside the path.
Remarks
This enumeration indicates the fill rule of polygon mark in case of self-crossing outline of mark.
Inheritance Hierarchy

Object
ImageGear.Web.UI.FillRule

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

FitType Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : FitType Enumeration
Specifies a particular scale and scroll state for an image.
Members
Member | Description
ActualSize | 3 - Displays the image at its actual size. Note that there are a number of situations where this may fail to produce the correct results. For example, if the resolution stored in the original image file is incorrect (or there was no resolution stored in the file), then this operation will produce unexpected results.
FullHeight | 2 - Displays the full height of the image within the bounds of the viewer, but the right side of the image may lie outside the viewer if the aspect ratio of the image is wider than the aspect ratio of the viewer.
FullImage | 0 - Displays the full image within the bounds of the viewer. In most cases, the viewer will scale the image down so it will fit within the bounds of the viewer. If the image is smaller than the viewer, then the viewer will scale the image up.
FullWidth | 1 - Displays the full width of the image within the bounds of the viewer, but the bottom part of the image may lie outside the viewer if the aspect ratio of the image is taller than the aspect ratio of the viewer.
OneToOne | 4 - Displays a raster image with no scaling (each image pixel will occupy one window pixel). If the image does not have square pixels, then the viewer will show one image pixel with exactly one window pixel either horizontally or vertically, and more than one pixel in the other direction. Note that PDF images are not composed of pixels. If you use this value for a PDF image, the viewer will instead apply the ActualSize value.
Rectangle | 5 - This is a special value that indicates the viewer should display a particular rectangle. When you use this value, the viewer will display the specified rectangle of the image. You can only use this value with the PageView.openPage function; the PageView.fitPage function will not accept this value.
Remarks

This enumeration specifies a particular scale and scroll state. The viewer also relies on this enumeration to define the initial state of the image and image viewer applications often allow a user to select the default value for new images.

It is common for an image viewer application to have buttons that will allow a user to change the current scale and scroll state to one of these values, especially FullImage, FullWidth, and ActualSize.

Inheritance Hierarchy

Object
ImageGear.Web.UI.FitType

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

FontStyle Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : FontStyle Enumeration
Indicates the style of a font.
Members
Member | Description
Bold | 1 - Text is bold. This is the same type as ImageGear for .NET's ImGearARTFontStyles.Bold.
Italic | 2 - Text is italic. This is the same type as ImageGear for .NET's ImGearARTFontStyles.Italic.
Regular | 0 - Text has a "normal" style. This is the same type as ImageGear for .NET's ImGearARTFontStyles.Regular.
Strikeout | 8 - Text is struck out. This is the same type as ImageGear for .NET's ImGearARTFontStyles.Strikeout.
Underline | 4 - Text is underlined. This is the same type as ImageGear for .NET's ImGearARTFontStyles.Underline.
Remarks

This enumeration indicates the style of the font used for text marks. These styles may be combined. For example, you can create a bold and italic font using (ImageGear.Web.UI.FontStyle.Bold | ImageGear.Web.UI.FontStyle.Italic). NotateXpress (version 10) exposes the same functionality using the Bold, Italic, Underline, and Strikeout properties of a Font object.

Inheritance Hierarchy

Object
ImageGear.Web.UI.FontStyle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

HorizontalAlignment Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : HorizontalAlignment Enumeration
Indicates the horizontal alignment of text in a text mark.
Members
Member | Description
Center | 16 - Text is centered horizontally. This value does not affect the vertical alignment of the text. This is the same type as NotateXpress's (version 10) TextJustification.Center and ImageGear for .NET's ImGearARTAlignmentHModes.CENTER.
Left | 0 - Text is left-justified. This is the same type as NotateXpress's (version 10) TextJustification.Left and ImageGear for .NET's ImGearARTAlignmentHModes.LEFT.
Right | 32 - Text is right-justified. This is the same type as NotateXpress's (version 10) TextJustification.Right and ImageGear for .NET's ImGearARTAlignmentHModes.RIGHT.
Remarks

This enumeration indicates the horizontal alignment of text in text marks.

Inheritance Hierarchy

Object
ImageGear.Web.UI.HorizontalAlignment

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearArtDataServices Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearArtDataServices Enumeration
Specifies options for annotations(art) data services
Members
Member | Description
ArtDataService | 1 – The ImageGear Art data service will be used
None | 0 - Selection is disabled.
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearArtDataServices

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearPageCountStatus Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearPageCountStatus Enumeration
Specifies the status of page count request from the server.
Members
Member | Description
Failed | -1 - The request to the server for the page count failed.
Known | 2 - Page count is known.
RequestPending | 1 - A request was sent to the server and the reply is pending.
UnRequested | 0 - A request for page count has not yet been sent to the server.
Remarks

When a document is first created for addition to the ImGearThumbnailList control, the total page count in the control is an UnProcessed state. When a request is actually sent, the status is put into "Unknown" state. When the request succeeds, the status is put into "Known state. If for some reason the request fails, the status is "Failed". When the value is set to the "Known" status, the pageCount property will indicate the total number of pages belonging to the document. the server for the page count information.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearPageCountStatus

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearThumbnailLayout Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailLayout Enumeration
Specifies a thumbnails layout within the bounds of the ImGearThumbnailList control.
Members
Member | Description
HorizontalScrollDirection | 1 -The thumbnails will be displayed as a single horizontal strip/band. For the default mode refer to the useDefaultStyling property in the ImageGear.Web.UI.ImGearThumbnailList control. The rows and columns will depend on the width and height of the control and the thumbnails. Note: When calculating width of the control for the layout, take into account the width of the scrollbar and the intra thumbnail spaces.
VerticalScrollDirection |
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearThumbnailLayout

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ImGearThumbnailSelectionMode Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ImGearThumbnailSelectionMode Enumeration
Members
Member | Description
Multiple |
Single |
Inheritance Hierarchy

Object
ImageGear.Web.UI.ImGearThumbnailSelectionMode

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

LineHeadType Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LineHeadType Enumeration
Indicates the type of the endpoint of a line.
Members
Member | Description
None | 4 - No arrowhead. This is the same type as NotateXpress's (version 10) EndPointStyle.Plain and ImageGear for .NET's ImGearARTLineHeadType.NONE.
Open | 2 - An arrowhead composed of a hollow triangle. This is the same type as ImageGear for .NET's ImGearARTLineHeadType.OPEN. NotateXpress (version 10) has no exact equivalent.
Pointer | 0 - An arrowhead composed of two short lines. This is the same type as NotateXpress's (version 10) EndPointStyle.Arrow and ImageGear for .NET's ImGearARTLineHeadType.POINTER.
PointerSolid | 3 - An arrowhead composed of two solid triangles. This is the same type as ImageGear for .NET's ImGearARTLineHeadType.POINTER_SOLID. NotateXpress (version 10) has no exact equivalent.
Solid | 1 - An arrowhead composed of a solid triangle. This is the same type as NotateXpress's (version 10) EndPointStyle.Dash and ImageGear for .NET's ImGearARTLineHeadType.SOLID.
Remarks

This enumeration indicates the style of the endpoints of lines for Line and Polyline marks.

Inheritance Hierarchy

Object
ImageGear.Web.UI.LineHeadType

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

LineStyle Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : LineStyle Enumeration
Indicates the style of a line.
Members
Member | Description
Dash | 1 - A line or border composed of a sequence of dashes. This is the same style as NotateXpress's (version 10) PenStyle.Dash and ImageGear for .NET's ImGearARTPenStyle.DASH.
DashDot | 3 - A line or border composed of an alternating pattern of dashes and dots. This is the same style as NotateXpress's (version 10) PenStyle.DashDot and ImageGear for .NET's ImGearARTPenStyle.DASHDOT.
DashDotDot | 4 - A line or border composed of an alternating pattern of one dash and two dots. This is the same style as NotateXpress's (version 10) PenStyle.DashDotDot and ImageGear for .NET's ImGearARTPenStyle.DASHDOTDOT.
Dot | 2 - A line or border composed of a sequence of dots. This is the same style as NotateXpress's (version 10) PenStyle.Dot and ImageGear for .NET's ImGearARTPenStyle.DOT.
Solid | 0 - A solid, unbroken line or border. This is the same style as NotateXpress's (version 10) PenStyle.Solid and ImageGear for .NET's ImGearARTPenStyle.SOLID.
Remarks

This enumeration indicates the style of a line or border.

Inheritance Hierarchy

Object
ImageGear.Web.UI.LineStyle

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MarkType Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MarkType Enumeration
Indicates the type of a mark.
Members
Member | Description
Ellipse | 601 - An ellipse. This is the same type of mark as NotateXpress's (version 10) EllipseTool and ImageGear for .NET's ImGearARTEllipse.
Line | 3 - A line segment. This is the same type of mark as NotateXpress's (version 10) LineTool and ImageGear for .NET's ImGearARTLine.
Polygon | 604 - A polygon. This is the same type of mark as NotateXpress's (version 10) PolygonTool and ImageGear for .NET's ImGearARTPolygon.
Polyline | 502 - A freehand line or polyline. This is the same type of mark as NotateXpress's (version 10) FreehandTool and PolyLineTool classes and ImageGear for .NET's ImGearARTPolyline.
Rectangle | 600 - A rectangle. This is the same type of mark as NotateXpress's (version 10) RectangleTool and PolyLineTool classes and ImageGear for .NET's ImGearARTRectangle.
Text | 605 - A block of text. This is the same type of mark as NotateXpress's (version 10) TextTool and ImageGear for .NET's ImGearARTText.
Remarks

This enumeration indicates the type of a mark.

This enumeration is patterned after ImageGear.ART.ImGearARTMarkType, but without the types that are not currently supported by the ASP.NET viewer.

Inheritance Hierarchy

Object
ImageGear.Web.UI.MarkType

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

MouseTool Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : MouseTool Enumeration
Indicates what the viewer will do when a user uses the left mouse button.
Members
Member | Description
CreateEllipseMark | 6 - Pressing the left mouse button and dragging will create an ellipse mark.
CreateFreehandMark | 9 - Pressing the left mouse button and dragging will create a freehand line mark.
CreateLineMark | 7 - Pressing the left mouse button and dragging will create a line mark.
CreatePolygonMark | 10 - Clicking the left mouse button multiple times will create a polygon mark. Double-click to finish creating the mark.
CreatePolylineMark | 8 - Clicking the left mouse button multiple times will create a polyline mark. Double-click to finish creating the mark.
CreateRectangleMark | 5 - Pressing the left mouse button and dragging will create a rectangle mark.
CreateTextMark | 11 - Pressing the left mouse button and dragging a rectangle will create a text mark.
EditMarks | 12 - Provides interactive editing of marks. Clicking outside of a mark, then dragging a rectangle will select all the marks that are wholly contained in the rectangle (and de-select all other marks). Clicking outside of a mark while holding the shift key, then dragging a rectangle will select all the marks that are wholly contained in the rectangle (and will not de-select all other marks). Clicking on an unselected mark will select the mark (and de-select all other marks). Clicking on a mark while holding the control or shift key will toggle the selected state of the mark. Clicking on a mark, then dragging will move the selected annotation(s). Clicking on a mark handle, will de-select all other marks. Clicking on a mark handle, then dragging will change the size or shape by moving that portion of the mark. Clicking on a mark handle while holding the control key, then dragging will change the size or shape of the mark and keep the center of the mark in its original location. Clicking on a corner mark handle while holding the shift key, then dragging will change the size of the mark and keep the aspect ratio unchanged. Double-clicking a text mark will select that mark, de-select all other marks, and switch the mark into text-entry mode.
HandPan | 3 - Pressing and moving the left mouse button will drag the image in the direction that the mouse is moved.
Magnifier | 1 - Pressing the left mouse button will display a magnifying glass. Moving the mouse will move the magnifying glass, and releasing the button will hide the magnifying glass.
None | 0 - The left mouse button will do nothing and the cursor will be the default browser cursor.
RectangleZoom | 2 - Pressing the left mouse button and dragging a rectangle will select an area. When you release the button, the viewer will immediately hide the selection and redisplay the image so the selected area fills the window. The cursor will be a crosshair.
RunMarks | 13 - The cursor over marks will be a "link" cursor and you can detect when a user clicks on a mark by looking at the mark property of the mouseEventArgs object.
Select | 4 - Pressing the left mouse button and dragging a rectangle will select an area. When you release the button, the selection will remain. This mouse tool is useful for supporting some operation that you will perform on a server, such as cropping or OCR.
Remarks
This enumeration indicates how the viewer should act when a user interacts with it using a mouse. Each of these tools will determine a cursor and the behavior of the left mouse button.
Inheritance Hierarchy

Object
ImageGear.Web.UI.MouseTool

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

Orientation Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : Orientation Enumeration
Indicates the rotation and mirroring of text in a text mark.
Members
Member | Description
BottomLeft | 4 - Text within a text mark is oriented so that the top of the text is in the same direction as the bottom edge of the image. In addition, the text is mirrored. This is the same type as ImageGear for .NET's ImGearOrientationModes.BOTTOM_LEFT. It is similar to NotateXpress's (version 10) TextOrientation.Degree180 except that the text is mirrored.
BottomRight | 3 - Text within a text mark is oriented so that the top of the text is in the same direction as the bottom edge of the image. In other words, this could be described as an "upside down" orientation. This is the same type as NotateXpress's (version 10) TextOrientation.Degree180 and ImageGear for .NET's ImGearOrientationModes.BOTTOM_RIGHT.
LeftBottom | 8 - Text within a text mark is oriented so that the top of the text is in the same direction as the left edge of the image. In other words, this could be described as a "rotated counterclockwise" orientation. This is the same type as NotateXpress's (version 10) TextOrientation.Degree270 and ImageGear for .NET's ImGearOrientationModes.LEFT_BOTTOM.
LeftTop | 5 - Text within a text mark is oriented so that the top of the text is in the same direction as the left edge of the image. In addition, the text is mirrored. This is the same type as ImageGear for .NET's ImGearOrientationModes.LEFT_TOP. It is similar to NotateXpress's (version 10) TextOrientation.Degree270 except that the text is mirrored.
RightBottom | 7 - Text within a text mark is oriented so that the top of the text is in the same direction as the right edge of the image. In addition, the text is mirrored. This is the same type as ImageGear for .NET's ImGearOrientationModes.RIGHT_BOTTOM. It is similar to NotateXpress's (version 10) TextOrientation.Degree90 except that the text is mirrored.
RightTop | 6 - Text within a text mark is oriented so that the top of the text is in the same direction as the right edge of the image. In other words, this could be described as a "rotated clockwise" orientation. This is the same type as NotateXpress's (version 10) TextOrientation.Degree90 and ImageGear for .NET's ImGearOrientationModes.RIGHT_TOP.
TopLeft | 1 - Text within a text mark is oriented so that the top of the text is in the same direction as the top edge of the image. In other words, this could be described as a "normal" orientation. This is the same type as NotateXpress's (version 10) TextOrientation.Degree0 and ImageGear for .NET's ImGearOrientationModes.TOP_LEFT.
TopRight | 2 - Text within a text mark is oriented so that the top of the text is in the same direction as the top edge of the image. In addition, the text is mirrored. This is the same type as ImageGear for .NET's ImGearOrientationModes.TOP_RIGHT. It is similar to NotateXpress's (version 10) TextOrientation.Degree0 except that the text is mirrored.
Remarks

This enumeration indicates the orientation of text in text marks in relation to the image.

The orientation of marks, as indicated by the members of this enumeration will always be tied to the image itself, not the browser. In other words, a text mark with an orientation of TopLeft will also be rotated or mirrored if the image is rotated.

Inheritance Hierarchy

Object
ImageGear.Web.UI.Orientation

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

ScrollBars Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : ScrollBars Enumeration
Indicates how the image viewer will handle its scrollbars.
Members
Member | Description
Auto | 4 - Display scrollbars only when needed. This is the same as setting the CSS overflow property of an HTML element to "auto".
Both | 3 - Always display scrollbars. This is the same as setting the CSS overflow property of an HTML element to "scroll".
None | 0 - Never display scrollbars. This is the same as setting the CSS overflow property of an HTML element to "hidden".
Remarks

This enumeration indicates how scrollbars should be handled by a viewer. You can choose to never display scrollbars (None), always display scrollbars (Both), or only display scrollbars when needed (Auto).

You should normally use Auto, but if you know the viewer will never need scrolbars, use None. When you use Auto, the viewer will sometimes draw the image twice whenever the scrollbars appear or disappear, which can be distracting. If you wish, you can set this value to Both to avoid that problem.

This value is closely related to the CSS property, overflow. You cannot set this value using CSS because the viewer has to use different rendering approaches on different browsers.

This enumeration is patterned after System.Web.UI.WebControls.Scrollbars, but without the non-standard values, Horizontal and Vertical.

Inheritance Hierarchy

Object
ImageGear.Web.UI.ScrollBars

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

VectorFormatsRendering Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : VectorFormatsRendering Enumeration
Specifies the vector format rendering way.
Members
Member | Description
Raster | 1 – Vector format is rendered as raster format (PNG, JPEG).
SVG | 0 - Vector format is rendered as SVG.
Inheritance Hierarchy

Object
ImageGear.Web.UI.VectorFormatsRendering

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


%%PageItemTitle%%

VerticalAlignment Enumeration

ImageGear.Web.UI Namespace Client API Library > ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace : VerticalAlignment Enumeration
Indicates the vertical alignment of text in a text mark.
Members
Member | Description
Bottom | 2 - Text is right-justified. This is the same type as NotateXpress's (version 10) TextJustification.Right and ImageGear for .NET's ImGearARTAlignmentVModes.BOTTOM.
Center | 1 - Text is centered vertically. This value does not affect the horizontal alignment of the text. This is the same type as NotateXpress's (version 10) TextJustification.Center and ImageGear for .NET's ImGearARTAlignmentVModes.CENTER.
Top | 0 - Text is left-justified. This is the same type as NotateXpress's (version 10) TextJustification.Left and ImageGear for .NET's ImGearARTAlignmentVModes.TOP.
Remarks

This enumeration indicates the vertical alignment of text in text marks. NotateXpress (version 10) does not have an equivalent for this functionality.

Inheritance Hierarchy

Object
ImageGear.Web.UI.VerticalAlignment

See Also

Reference

ImageGear.Web.UI Namespace Client API~ImageGear.Web.UI_namespace


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you